Easy CHM - http://www.eTextWizard.com

您现在使用的CHM文件由Easy CHM的未注册版本制作而成。
注册版本不会在CHM里自动添加此页面。

制作时使用的Easy CHM程序版本号：v3.93
制作日期：2016/11/17

Easy CHM 软件 软件出品: 国华软件 中国北京 |  | 截屏图片
免费下载最新的试用版 | 文件大小: 2989k - 2.84MB | 软件类型: 共享软件 购买注册: 这里

关键词: make chm, create chm, chm制作工具, chm电子书制作工具,chm帮助文件制作工具

描述:

Easy CHM是国华软件推出的一款强大的CHM电子书或CHM帮助文件的快速制作工具。

使用EasyCHM只需要三个步骤就可以完成CHM的制作：
1、用户指定一个目录，EasyCHM会自动导入全部目录及文件;
2、设置CHM编译选项;
3、开始制作。

EasyCHM非常适合个人和单位制作高压缩比的带有全文检索及高亮显示搜索结果的网页集锦、CHM帮助文件、产品说明、公司介绍、CHM电子书等等。

主要功能：

  • 全自动的目录及文件导入（可以包括子目录）;
  • EasyCHM支持导入任意的文件类型;
  • EasyCHM操作速度快，性能稳定，EasyCHM因为上手容易深得广大用户好评;
  • EasyCHM自动生成CHM的目录列表并自动生成所有目录项;
  • 为CHM的目录列表自动添加多级编号;
  • 在编辑目录项、索引项时用到的移动、拖拽、替换等操作中Easy CHM完全支持多选及拖拽操作，避免了一项一项地操作，极大的减少用户手工 － 非常适合企业维护大型CHM帮助文档;
  • 支持批量查找替换多级目录各项的标题文字内容;
  • 允许用户指定从文本文件的第N行自动截取标题;
  • 易用的目录/索引编辑器;
  • 丰富实用的CHM制作选项帮助用户制作更加个性化的专业CHM电子书或CHM帮助文件;
  • EasyCHM自动生成输出Alias和Map头文件;
  • EasyCHM自动生成上下文相关的帮助文件（ContextID），适合于软件公司制作专业的支持Help Context ID的专业帮助文件;
  • EasyCHM可以保存工程文件，方便企业用户编辑维护文档。
  • 批量更换CHM目录各项的图标;
  • 内嵌CHM反编译工具
  • 更多功能

EasyCHM未注册版本的主要限制：

  1. EasyCHM的未注册版本可以制作带任意层级目录的CHM，但是每个CHM的工具栏上都会自动添加一个ABOUT按钮，以提醒用户注册。
    注册版本不会添加ABOUT按钮。
  2. EasyCHM的未注册版本无法保存CHM的通用工程文件，如*.HHP、*.HHC、*.HHK等。
    未注册版本的EasyCHM会自动删除*.HHP、*.HHC、*.HHK这几个文件。
  3. 未注册版本制作的CHM标题上会有Made by UNREGISTERED version of Easy CHM这样的提示您试用的是未注册版本的文字。

注册版本无任何限制，也不会再显示ABOUT按钮或者提示注册的文字。
如果EasyCHM可以为您的工作和学习提供帮助，请注册购买，感谢您给予软件作者的支持。
联系方式:
国华软件站点一: http://www.etextwizard.com
国华软件站点二: http://www.zipghost.com
技术支持信箱: webmaster@etextwizard.com
购买方式:
在线购买:（可提供发票，支持很多种支付方式，包括在线支付、银行电汇、邮政汇款等）
通过“共享软件注册中心”购买单用户企业版

通过“共享软件注册中心”购买单用户家庭版
直接向国华软件注册购买（共3种方式）：
1、招商银行划款:
开户行： 招商银行北京分行双榆树支行
帐 号： 001015570093
户 名： 冯国华
2、中国农业银行金穗卡转帐（注意是卡号）：
金穗卡卡号： 95599 8001 42061 34216
收 款 人： 冯国华
3、中国工商银行牡丹灵通卡转帐：

开户城市：北京
牡丹灵通卡卡号：9558 8202 0000 3186295 （注意是卡号9558820200003186295）
收 款 人： 冯国华

注意事项：
直接向作者注册的用户请在汇出足额的注册费后以EMAIL形式通知作者，同时请尽量提供

  • 汇款日期

  • 汇出城市

  • 您汇到哪个银行帐号？

  • 汇款人姓名

  • 用于接收注册码的信箱（请确保可以接收邮件，最好多提供）

  • 您希望使用的注册用户名（程序将授权给这个用户）

  • 要注册的软件名称及套数

您提供的资料详细些会比较方便确认。
作者在确认支付已完成后将会马上发出注册码。
用户在收到注册信后请尽量给软件作者发个类似“已收到注册码”的确认信 - 感谢您的配合！
免费下载最新的试用版:
http://www.etextwizard.com/cn/download/ecdown.html

系统需求: Win98, WinME, WinXP, Win2000,WinVista, Win7
安装支持: 支持安装及卸载


AccountAgingTotalResult

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountAgingTotalResult

java.lang.Object
    extended by  bb.common.AccountAgingTotalResult
All Implemented Interfaces:
java.io.Serializable
public class AccountAgingTotalResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AccountAgingTotalResult()
Method Summary
java.lang.String | getCurrency()
java.math.BigDecimal | getCurrent()
java.math.BigDecimal | getD01_30()
java.math.BigDecimal | getD31_60()
java.math.BigDecimal | getD61_90()
java.math.BigDecimal | getD90_plus()
java.math.BigDecimal | getTotalDue()
void | setCurrency(java.lang.String currency)
void | setCurrent(java.math.BigDecimal current)
void | setD01_30(java.math.BigDecimal d01_30)
void | setD31_60(java.math.BigDecimal d31_60)
void | setD61_90(java.math.BigDecimal d61_90)
void | setD90_plus(java.math.BigDecimal d90_plus)
void | setTotalDue(java.math.BigDecimal totalDue)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AccountAgingTotalResult

public AccountAgingTotalResult()
Method Detail

setCurrency

public void setCurrency(java.lang.String currency)

setTotalDue

public void setTotalDue(java.math.BigDecimal totalDue)

setCurrent

public void setCurrent(java.math.BigDecimal current)

setD01_30

public void setD01_30(java.math.BigDecimal d01_30)

setD31_60

public void setD31_60(java.math.BigDecimal d31_60)

setD61_90

public void setD61_90(java.math.BigDecimal d61_90)

setD90_plus

public void setD90_plus(java.math.BigDecimal d90_plus)

getCurrency

public java.lang.String getCurrency()

getTotalDue

public java.math.BigDecimal getTotalDue()

getCurrent

public java.math.BigDecimal getCurrent()

getD01_30

public java.math.BigDecimal getD01_30()

getD31_60

public java.math.BigDecimal getD31_60()

getD61_90

public java.math.BigDecimal getD61_90()

getD90_plus

public java.math.BigDecimal getD90_plus()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AccountAuditAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountAuditAgent

java.lang.Object
    extended by  bb.common.AccountAuditAgent
All Implemented Interfaces:
java.io.Serializable
public class AccountAuditAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AccountAuditAgent()
Method Summary
java.lang.String | getAddressIDLike()
java.lang.String | getCurrency()
java.lang.String | getOrderNumLike()
java.util.Date | getStartDate()
void | setAddressIDLike(java.lang.String addressIDLike)
void | setCurrency(java.lang.String currency)
void | setOrderNumLike(java.lang.String orderNumLike)
void | setStartDate(java.util.Date startDate)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AccountAuditAgent

public AccountAuditAgent()
Method Detail

getAddressIDLike

public java.lang.String getAddressIDLike()

setAddressIDLike

public void setAddressIDLike(java.lang.String addressIDLike)

getOrderNumLike

public java.lang.String getOrderNumLike()

setOrderNumLike

public void setOrderNumLike(java.lang.String orderNumLike)

getStartDate

public java.util.Date getStartDate()

setStartDate

public void setStartDate(java.util.Date startDate)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountBalanceAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountBalanceAgent

java.lang.Object
    extended by  bb.common.AccountBalanceAgent
All Implemented Interfaces:
java.io.Serializable
public class AccountBalanceAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AccountBalanceAgent()
Method Summary
java.util.Map<CompanyUnitAccountPK,java.math.BigDecimal> | getCreditAccountBalance()
java.util.Map<CompanyUnitAccountPK,java.math.BigDecimal> | getDebitAccountBalance()
java.lang.String | getGlSummary()
java.lang.String | getMonthYear()
java.util.Map<CompanyUnitAccountPK,java.math.BigDecimal> | getOrgCreditAccountBalance()
java.util.Map<CompanyUnitAccountPK,java.math.BigDecimal> | getOrgDebitAccountBalance()
void | setCreditAccountBalance(java.util.Map<CompanyUnitAccountPK,java.math.BigDecimal> creditAccountBalance)
void | setDebitAccountBalance(java.util.Map<CompanyUnitAccountPK,java.math.BigDecimal> debitAccountBalance)
void | setGlSummary(java.lang.String glSummary)
void | setMonthYear(java.lang.String monthYear)
void | setOrgCreditAccountBalance(java.util.Map<CompanyUnitAccountPK,java.math.BigDecimal> orgCreditAccountBalance)
void | setOrgDebitAccountBalance(java.util.Map<CompanyUnitAccountPK,java.math.BigDecimal> orgDebitAccountBalance)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AccountBalanceAgent

public AccountBalanceAgent()
Method Detail

getMonthYear

public java.lang.String getMonthYear()

setMonthYear

public void setMonthYear(java.lang.String monthYear)

getCreditAccountBalance

public java.util.Map<CompanyUnitAccountPK,java.math.BigDecimal> getCreditAccountBalance()

setCreditAccountBalance

public void setCreditAccountBalance(java.util.Map<CompanyUnitAccountPK,java.math.BigDecimal> creditAccountBalance)

getDebitAccountBalance

public java.util.Map<CompanyUnitAccountPK,java.math.BigDecimal> getDebitAccountBalance()

setDebitAccountBalance

public void setDebitAccountBalance(java.util.Map<CompanyUnitAccountPK,java.math.BigDecimal> debitAccountBalance)

getOrgCreditAccountBalance

public java.util.Map<CompanyUnitAccountPK,java.math.BigDecimal> getOrgCreditAccountBalance()

setOrgCreditAccountBalance

public void setOrgCreditAccountBalance(java.util.Map<CompanyUnitAccountPK,java.math.BigDecimal> orgCreditAccountBalance)

getOrgDebitAccountBalance

public java.util.Map<CompanyUnitAccountPK,java.math.BigDecimal> getOrgDebitAccountBalance()

setOrgDebitAccountBalance

public void setOrgDebitAccountBalance(java.util.Map<CompanyUnitAccountPK,java.math.BigDecimal> orgDebitAccountBalance)

getGlSummary

public java.lang.String getGlSummary()

setGlSummary

public void setGlSummary(java.lang.String glSummary)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountBalanceListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountBalanceListResult

java.lang.Object
    extended by  bb.common.AccountBalanceListResult
All Implemented Interfaces:
java.io.Serializable
public class AccountBalanceListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACCOUNTDESCRIPTION
static java.lang.String | ORDER_BY_ACCOUNTNUMBER
static java.lang.String | ORDER_BY_ADDRESSID
static java.lang.String | ORDER_BY_ADDRESSNAME
static java.lang.String | ORDER_BY_COMPANYUNITID
Constructor Summary
AccountBalanceListResult()
Method Summary
java.lang.String | getAccountDescription()
java.lang.String | getAccountNumber()
java.lang.String | getAddressId()
java.lang.String | getAddressName()
java.math.BigDecimal | getBalance()
java.lang.String | getCompanyUnitId()
java.math.BigDecimal | getCredit()
java.math.BigDecimal | getDebit()
void | setAccountDescription(java.lang.String accountDescription)
void | setAccountNumber(java.lang.String accountNumber)
void | setAddressId(java.lang.String addressId)
void | setAddressName(java.lang.String addressName)
void | setBalance(java.math.BigDecimal balance)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCredit(java.math.BigDecimal credit)
void | setDebit(java.math.BigDecimal debit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_ADDRESSID

public static final java.lang.String ORDER_BY_ADDRESSID
See Also:
Constant Field Values

ORDER_BY_ACCOUNTNUMBER

public static final java.lang.String ORDER_BY_ACCOUNTNUMBER
See Also:
Constant Field Values

ORDER_BY_COMPANYUNITID

public static final java.lang.String ORDER_BY_COMPANYUNITID
See Also:
Constant Field Values

ORDER_BY_ADDRESSNAME

public static final java.lang.String ORDER_BY_ADDRESSNAME
See Also:
Constant Field Values

ORDER_BY_ACCOUNTDESCRIPTION

public static final java.lang.String ORDER_BY_ACCOUNTDESCRIPTION
See Also:
Constant Field Values
Constructor Detail

AccountBalanceListResult

public AccountBalanceListResult()
Method Detail

getBalance

public java.math.BigDecimal getBalance()

getCredit

public java.math.BigDecimal getCredit()

getDebit

public java.math.BigDecimal getDebit()

getAccountDescription

public java.lang.String getAccountDescription()

getAccountNumber

public java.lang.String getAccountNumber()

setAddressId

public void setAddressId(java.lang.String addressId)

setBalance

public void setBalance(java.math.BigDecimal balance)

setCredit

public void setCredit(java.math.BigDecimal credit)

setDebit

public void setDebit(java.math.BigDecimal debit)

setAccountDescription

public void setAccountDescription(java.lang.String accountDescription)

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getAddressId

public java.lang.String getAddressId()

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getAddressName

public java.lang.String getAddressName()

setAddressName

public void setAddressName(java.lang.String addressName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountBalanceResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountBalanceResult

java.lang.Object
    extended by  bb.common.AccountBalanceResult
All Implemented Interfaces:
java.io.Serializable
public class AccountBalanceResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACCOUNTNUMBER
static java.lang.String | ORDER_BY_ADDRESSID
static java.lang.String | ORDER_BY_COMPANYUNITID
Constructor Summary
AccountBalanceResult()
Method Summary
java.lang.String | getAccountNumber()
java.lang.String | getAccountType()
java.math.BigDecimal | getBalance()
java.math.BigDecimal | getBeginPeriodBalance()
java.math.BigDecimal | getCreditAmount()
java.math.BigDecimal | getCreditBeginPeriodBalance()
java.math.BigDecimal | getCreditEndPeriodBalance()
java.math.BigDecimal | getDebitAmount()
java.math.BigDecimal | getDebitBeginPeriodBalance()
java.math.BigDecimal | getDebitEndPeriodBalance()
java.lang.String | getDebitOrCredit()
java.lang.String | getDeductable()
java.lang.String | getDescription()
byte | getItems()
java.lang.String | getLevel()
java.lang.String | getUpLevelAccount()
void | setAccountNumber(java.lang.String accountNumber)
void | setAccountType(java.lang.String accountType)
void | setBalance(java.math.BigDecimal balance)
void | setBeginPeriodBalance(java.math.BigDecimal beginPeriodBalance)
void | setCreditAmount(java.math.BigDecimal creditAmount)
void | setCreditBeginPeriodBalance(java.math.BigDecimal creditBeginPeriodBalance)
void | setCreditEndPeriodBalance(java.math.BigDecimal creditEndPeriodBalance)
void | setDebitAmount(java.math.BigDecimal debitAmount)
void | setDebitBeginPeriodBalance(java.math.BigDecimal debitBeginPeriodBalance)
void | setDebitEndPeriodBalance(java.math.BigDecimal debitEndPeriodBalance)
void | setDebitOrCredit(java.lang.String debitOrCredit)
void | setDeductable(java.lang.String deductable)
void | setDescription(java.lang.String description)
void | setItems(byte items)
void | setLevel(java.lang.String level)
void | setUpLevelAccount(java.lang.String upLevelAccount)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_ADDRESSID

public static final java.lang.String ORDER_BY_ADDRESSID
See Also:
Constant Field Values

ORDER_BY_ACCOUNTNUMBER

public static final java.lang.String ORDER_BY_ACCOUNTNUMBER
See Also:
Constant Field Values

ORDER_BY_COMPANYUNITID

public static final java.lang.String ORDER_BY_COMPANYUNITID
See Also:
Constant Field Values
Constructor Detail

AccountBalanceResult

public AccountBalanceResult()
Method Detail

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getItems

public byte getItems()

setItems

public void setItems(byte items)

getLevel

public java.lang.String getLevel()

setLevel

public void setLevel(java.lang.String level)

getAccountType

public java.lang.String getAccountType()

setAccountType

public void setAccountType(java.lang.String accountType)

getDeductable

public java.lang.String getDeductable()

setDeductable

public void setDeductable(java.lang.String deductable)

getDebitOrCredit

public java.lang.String getDebitOrCredit()

setDebitOrCredit

public void setDebitOrCredit(java.lang.String debitOrCredit)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getDebitBeginPeriodBalance

public java.math.BigDecimal getDebitBeginPeriodBalance()

setDebitBeginPeriodBalance

public void setDebitBeginPeriodBalance(java.math.BigDecimal debitBeginPeriodBalance)

getCreditBeginPeriodBalance

public java.math.BigDecimal getCreditBeginPeriodBalance()

setCreditBeginPeriodBalance

public void setCreditBeginPeriodBalance(java.math.BigDecimal creditBeginPeriodBalance)

getDebitAmount

public java.math.BigDecimal getDebitAmount()

setDebitAmount

public void setDebitAmount(java.math.BigDecimal debitAmount)

getCreditAmount

public java.math.BigDecimal getCreditAmount()

setCreditAmount

public void setCreditAmount(java.math.BigDecimal creditAmount)

getDebitEndPeriodBalance

public java.math.BigDecimal getDebitEndPeriodBalance()

setDebitEndPeriodBalance

public void setDebitEndPeriodBalance(java.math.BigDecimal debitEndPeriodBalance)

getCreditEndPeriodBalance

public java.math.BigDecimal getCreditEndPeriodBalance()

setCreditEndPeriodBalance

public void setCreditEndPeriodBalance(java.math.BigDecimal creditEndPeriodBalance)

getBalance

public java.math.BigDecimal getBalance()

setBalance

public void setBalance(java.math.BigDecimal balance)

getUpLevelAccount

public java.lang.String getUpLevelAccount()

setUpLevelAccount

public void setUpLevelAccount(java.lang.String upLevelAccount)

getBeginPeriodBalance

public java.math.BigDecimal getBeginPeriodBalance()

setBeginPeriodBalance

public void setBeginPeriodBalance(java.math.BigDecimal beginPeriodBalance)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountCreditDebitPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountCreditDebitPK

java.lang.Object
    extended by  bb.common.AccountCreditDebitPK
All Implemented Interfaces:
java.io.Serializable
public class AccountCreditDebitPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
AccountCreditDebitPK()
default constructor
AccountCreditDebitPK(java.lang.Integer itemNumber, java.lang.String transactionNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Integer | getItemNumber()
java.lang.String | getTransactionNumber()
int | hashCode()
void | setItemNumber(java.lang.Integer itemNumber)
void | setTransactionNumber(java.lang.String transactionNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

AccountCreditDebitPK

public AccountCreditDebitPK(java.lang.Integer itemNumber,
                            java.lang.String transactionNumber)
full constructor

AccountCreditDebitPK

public AccountCreditDebitPK()
default constructor

Method Detail

getItemNumber

public java.lang.Integer getItemNumber()

setItemNumber

public void setItemNumber(java.lang.Integer itemNumber)

getTransactionNumber

public java.lang.String getTransactionNumber()

setTransactionNumber

public void setTransactionNumber(java.lang.String transactionNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountCreditVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountCreditVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AccountCreditVO
All Implemented Interfaces:
Alarmable, java.io.Serializable
public class AccountCreditVO
extends VO
implements Alarmable, java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
AccountCreditVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAccountNumber()
AccountsChartVO | getAccountsChart()
java.lang.String | getAddressId()
boolean | getAlarmValue()
java.lang.String | getCause()
java.lang.String | getCompanyUnitId()
java.math.BigDecimal | getCredit()
java.lang.String | getCurrency()
java.lang.String | getDescription()
java.math.BigDecimal | getExchange()
java.math.BigDecimal | getOriginalCredit()
AccountCreditDebitPK | getPk()
java.util.Date | getTransactionDate()
java.lang.String | getTransactionType()
int | hashCode()
void | setAccountNumber(java.lang.String accountNumber)
void | setAccountsChart(AccountsChartVO accountsChart)
void | setAddressId(java.lang.String addressId)
void | setAlarmValue(boolean alarmValue)
void | setCause(java.lang.String cause)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCredit(java.math.BigDecimal credit)
void | setCurrency(java.lang.String currency)
void | setDescription(java.lang.String description)
void | setExchange(java.math.BigDecimal exchange)
void | setOriginalCredit(java.math.BigDecimal originalCredit)
void | setPk(AccountCreditDebitPK pk)
void | setTransactionDate(java.util.Date transactionDate)
void | setTransactionType(java.lang.String transactionType)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

AccountCreditVO

public AccountCreditVO()
default constructor

Method Detail

getPk

public AccountCreditDebitPK getPk()

setPk

public void setPk(AccountCreditDebitPK pk)

getTransactionDate

public java.util.Date getTransactionDate()

setTransactionDate

public void setTransactionDate(java.util.Date transactionDate)

getTransactionType

public java.lang.String getTransactionType()

setTransactionType

public void setTransactionType(java.lang.String transactionType)

getAddressId

public java.lang.String getAddressId()

setAddressId

public void setAddressId(java.lang.String addressId)

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getCredit

public java.math.BigDecimal getCredit()

getAccountsChart

public AccountsChartVO getAccountsChart()

setCredit

public void setCredit(java.math.BigDecimal credit)

setAccountsChart

public void setAccountsChart(AccountsChartVO accountsChart)

getAlarmValue

public boolean getAlarmValue()
Specified by:
getAlarmValue in interface Alarmable

setAlarmValue

public void setAlarmValue(boolean alarmValue)
Specified by:
setAlarmValue in interface Alarmable

getCause

public java.lang.String getCause()
Specified by:
getCause in interface Alarmable

setCause

public void setCause(java.lang.String cause)
Specified by:
setCause in interface Alarmable

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getExchange

public java.math.BigDecimal getExchange()

setExchange

public void setExchange(java.math.BigDecimal exchange)

getOriginalCredit

public java.math.BigDecimal getOriginalCredit()

setOriginalCredit

public void setOriginalCredit(java.math.BigDecimal originalCredit)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountDebitVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountDebitVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AccountDebitVO
All Implemented Interfaces:
Alarmable, java.io.Serializable
public class AccountDebitVO
extends VO
implements Alarmable, java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
AccountDebitVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAccountNumber()
AccountsChartVO | getAccountsChart()
java.lang.String | getAddressId()
boolean | getAlarmValue()
java.lang.String | getCause()
java.lang.String | getCompanyUnitId()
java.lang.String | getCurrency()
java.math.BigDecimal | getDebit()
java.lang.String | getDescription()
java.math.BigDecimal | getExchange()
java.math.BigDecimal | getOriginalDebit()
AccountCreditDebitPK | getPk()
java.util.Date | getTransactionDate()
java.lang.String | getTransactionType()
int | hashCode()
void | setAccountNumber(java.lang.String accountNumber)
void | setAccountsChart(AccountsChartVO accountsChart)
void | setAddressId(java.lang.String addressId)
void | setAlarmValue(boolean alarmValue)
void | setCause(java.lang.String cause)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCurrency(java.lang.String currency)
void | setDebit(java.math.BigDecimal debit)
void | setDescription(java.lang.String description)
void | setExchange(java.math.BigDecimal exchange)
void | setOriginalDebit(java.math.BigDecimal originalDebit)
void | setPk(AccountCreditDebitPK pk)
void | setTransactionDate(java.util.Date transactionDate)
void | setTransactionType(java.lang.String transactionType)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

AccountDebitVO

public AccountDebitVO()
default constructor

Method Detail

getPk

public AccountCreditDebitPK getPk()

setPk

public void setPk(AccountCreditDebitPK pk)

getTransactionDate

public java.util.Date getTransactionDate()

setTransactionDate

public void setTransactionDate(java.util.Date transactionDate)

getTransactionType

public java.lang.String getTransactionType()

setTransactionType

public void setTransactionType(java.lang.String transactionType)

getAddressId

public java.lang.String getAddressId()

setAddressId

public void setAddressId(java.lang.String addressId)

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getDebit

public java.math.BigDecimal getDebit()

getAccountsChart

public AccountsChartVO getAccountsChart()

setDebit

public void setDebit(java.math.BigDecimal debit)

setAccountsChart

public void setAccountsChart(AccountsChartVO accountsChart)

getAlarmValue

public boolean getAlarmValue()
Specified by:
getAlarmValue in interface Alarmable

setAlarmValue

public void setAlarmValue(boolean alarmValue)
Specified by:
setAlarmValue in interface Alarmable

getCause

public java.lang.String getCause()
Specified by:
getCause in interface Alarmable

setCause

public void setCause(java.lang.String cause)
Specified by:
setCause in interface Alarmable

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getExchange

public java.math.BigDecimal getExchange()

setExchange

public void setExchange(java.math.BigDecimal exchange)

getOriginalDebit

public java.math.BigDecimal getOriginalDebit()

setOriginalDebit

public void setOriginalDebit(java.math.BigDecimal originalDebit)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountInfoCenterItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountInfoCenterItemResult

java.lang.Object
    extended by  bb.common.AccountInfoCenterItemResult
All Implemented Interfaces:
java.io.Serializable
public class AccountInfoCenterItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AccountInfoCenterItemResult()
Method Summary
java.lang.Long | getCount()
java.lang.String | getCurrency()
java.math.BigDecimal | getTotal()
void | setCount(java.lang.Long count)
void | setCurrency(java.lang.String currency)
void | setTotal(java.math.BigDecimal total)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AccountInfoCenterItemResult

public AccountInfoCenterItemResult()
Method Detail

setCount

public void setCount(java.lang.Long count)

setTotal

public void setTotal(java.math.BigDecimal total)

setCurrency

public void setCurrency(java.lang.String currency)

getCount

public java.lang.Long getCount()

getTotal

public java.math.BigDecimal getTotal()

getCurrency

public java.lang.String getCurrency()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountInfoCenterResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountInfoCenterResult

java.lang.Object
    extended by  bb.common.AccountInfoCenterResult
All Implemented Interfaces:
java.io.Serializable
public class AccountInfoCenterResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AccountInfoCenterResult()
Method Summary
java.util.Set | getApDueItems()
java.util.Set | getApOpenItems()
java.util.Set | getArDueItems()
java.util.Set | getArOpenItems()
void | setApDueItems(java.util.Set apDueItems)
void | setApOpenItems(java.util.Set apOpenItems)
void | setArDueItems(java.util.Set arDueItems)
void | setArOpenItems(java.util.Set arOpenItems)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AccountInfoCenterResult

public AccountInfoCenterResult()
Method Detail

setArOpenItems

public void setArOpenItems(java.util.Set arOpenItems)

setArDueItems

public void setArDueItems(java.util.Set arDueItems)

setApOpenItems

public void setApOpenItems(java.util.Set apOpenItems)

setApDueItems

public void setApDueItems(java.util.Set apDueItems)

getArOpenItems

public java.util.Set getArOpenItems()

getArDueItems

public java.util.Set getArDueItems()

getApOpenItems

public java.util.Set getApOpenItems()

getApDueItems

public java.util.Set getApDueItems()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountingBalanceSheetResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountingBalanceSheetResult

java.lang.Object
    extended by  bb.common.AccountingBalanceSheetResult
All Implemented Interfaces:
java.io.Serializable
public class AccountingBalanceSheetResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AccountingBalanceSheetResult()
Method Summary
java.math.BigDecimal | getAccountsPayable()
java.math.BigDecimal | getCash()
java.math.BigDecimal | getInventory()
java.math.BigDecimal | getLongTermAssets()
java.math.BigDecimal | getOtherCurrentAssets()
java.math.BigDecimal | getPropertyEquipments()
java.math.BigDecimal | getRetainedEarnings()
java.util.Set | getShareholders()
java.math.BigDecimal | getTotalAssets()
java.math.BigDecimal | getTotalCurrentAssets()
java.math.BigDecimal | getTotalCurrentLiabilities()
java.math.BigDecimal | getTotalLiabilities()
java.math.BigDecimal | getTotalLiabilityesEquity()
java.math.BigDecimal | getTotalShareholdersEquity()
java.math.BigDecimal | getTradeAccount()
void | setAccountsPayable(java.math.BigDecimal accountsPayable)
void | setCash(java.math.BigDecimal cash)
void | setInventory(java.math.BigDecimal inventory)
void | setLongTermAssets(java.math.BigDecimal longTermAssets)
void | setOtherCurrentAssets(java.math.BigDecimal otherCurrentAssets)
void | setPropertyEquipments(java.math.BigDecimal propertyEquipments)
void | setRetainedEarnings(java.math.BigDecimal retainedEarnings)
void | setShareholders(java.util.Set shareholders)
void | setTotalAssets(java.math.BigDecimal totalAssets)
void | setTotalCurrentAssets(java.math.BigDecimal totalCurrentAssets)
void | setTotalCurrentLiabilities(java.math.BigDecimal totalCurrentLiabilities)
void | setTotalLiabilities(java.math.BigDecimal totalLiabilities)
void | setTotalLiabilityesEquity(java.math.BigDecimal totalLiabilityesEquity)
void | setTotalShareholdersEquity(java.math.BigDecimal totalShareholdersEquity)
void | setTradeAccount(java.math.BigDecimal tradeAccount)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AccountingBalanceSheetResult

public AccountingBalanceSheetResult()
Method Detail

getInventory

public java.math.BigDecimal getInventory()

getOtherCurrentAssets

public java.math.BigDecimal getOtherCurrentAssets()

getLongTermAssets

public java.math.BigDecimal getLongTermAssets()

getTotalAssets

public java.math.BigDecimal getTotalAssets()

getRetainedEarnings

public java.math.BigDecimal getRetainedEarnings()

getTotalCurrentAssets

public java.math.BigDecimal getTotalCurrentAssets()

getTotalShareholdersEquity

public java.math.BigDecimal getTotalShareholdersEquity()

getShareholders

public java.util.Set getShareholders()

getPropertyEquipments

public java.math.BigDecimal getPropertyEquipments()

getTotalLiabilities

public java.math.BigDecimal getTotalLiabilities()

getAccountsPayable

public java.math.BigDecimal getAccountsPayable()

getTotalCurrentLiabilities

public java.math.BigDecimal getTotalCurrentLiabilities()

getTradeAccount

public java.math.BigDecimal getTradeAccount()

getTotalLiabilityesEquity

public java.math.BigDecimal getTotalLiabilityesEquity()

setCash

public void setCash(java.math.BigDecimal cash)

setInventory

public void setInventory(java.math.BigDecimal inventory)

setOtherCurrentAssets

public void setOtherCurrentAssets(java.math.BigDecimal otherCurrentAssets)

setLongTermAssets

public void setLongTermAssets(java.math.BigDecimal longTermAssets)

setTotalAssets

public void setTotalAssets(java.math.BigDecimal totalAssets)

setRetainedEarnings

public void setRetainedEarnings(java.math.BigDecimal retainedEarnings)

setTotalCurrentAssets

public void setTotalCurrentAssets(java.math.BigDecimal totalCurrentAssets)

setTotalShareholdersEquity

public void setTotalShareholdersEquity(java.math.BigDecimal totalShareholdersEquity)

setShareholders

public void setShareholders(java.util.Set shareholders)

setPropertyEquipments

public void setPropertyEquipments(java.math.BigDecimal propertyEquipments)

setTotalLiabilities

public void setTotalLiabilities(java.math.BigDecimal totalLiabilities)

setAccountsPayable

public void setAccountsPayable(java.math.BigDecimal accountsPayable)

setTotalCurrentLiabilities

public void setTotalCurrentLiabilities(java.math.BigDecimal totalCurrentLiabilities)

setTradeAccount

public void setTradeAccount(java.math.BigDecimal tradeAccount)

setTotalLiabilityesEquity

public void setTotalLiabilityesEquity(java.math.BigDecimal totalLiabilityesEquity)

getCash

public java.math.BigDecimal getCash()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountingBox

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

bb.common.box
Interface AccountingBox

public interface AccountingBox

Method Summary
java.lang.String | addAccountBalanceGL(AccountBalanceAgent agent)
void | addAccountChartBalanceSheetAdvanceCategory(AccountsChartAdvanceCategoryVO vo)
void | addAccountChartProfitLossAdvanceCategory(AccountsChartAdvanceCategoryVO vo)
void | addAccountChartTaxPayableAdvanceCategory(AccountsChartAdvanceCategoryVO vo)
AccountReceivablePaymentVO | addAccountReceivablePayment(AccountReceivablePaymentVO vo)
java.lang.String | addAccountsChart(AccountsChartVO vo)
AccountsChartCategoryVO | addAccountsChartCategoryForBalanceSheet(AccountsChartCategoryVO vo)
AccountsChartCategoryVO | addAccountsChartCategoryForEbitda(AccountsChartCategoryVO vo)
AccountsChartCategoryVO | addAccountsChartCategoryForProfitLoss(AccountsChartCategoryVO vo)
AccountsChartCategoryVO | addAccountsChartCategoryForTaxDetail(AccountsChartCategoryVO vo)
void | addAccountsChartMapping(AccountsChartMappingVO vo)
void | addAPPayment(PaymentAgent apPaymentAgent)
void | addAPPaymentWithMultiplePrepay(PaymentAgent apPaymentAgent)
void | addAPPaymentWithPrepay(PaymentAgent apPaymentAgent)
java.lang.String | addApPrepayPayment(PrepayPaymentAgent agent)
ARBoilerplateVO | addArBP(ARBoilerplateVO vo)
void | addArPayment(PaymentAgent arPaymentAgent)
void | addARPaymentWithMultiplePrepay(PaymentAgent arPaymentAgent)
void | addARPaymentWithPrepay(PaymentAgent arPaymentAgent)
java.lang.String | addArPrepayPayment(PrepayPaymentAgent agent)
java.lang.String | addARWithoutShipper(AccountsReceivableVO vo)
java.lang.String | addARWithShipper(MakeInvoiceAgent agent)
java.lang.String | addARWithShipperItems(MakeInvoiceAgent agent)
void | addAsset(AssetVO vo)
java.lang.String | addAsset(java.lang.String assetNumber, java.lang.String description)
void | addAssetType(AssetTypeVO vo)
java.util.Collection<AssetUsageVO> | addAssetUsage(AssetUsageVO vo)
BankReconciliationReportVO | addBankReconciliationReport(BankReconciliationReportVO vo)
void | addBatchAccountsChart(java.util.Collection<AccountsChartVO> chartVO)
java.lang.Long | addChangeStdCostWorkSheet(ChangeStdCostWorkSheetVO vo)
void | addChangeStdCostWorkSheetItem(ChangeStdCostWorkSheetItemVO vo)
void | addChecksFromCheckRunNumber(java.lang.String checkRunNumber, boolean first)
AccountsReceivableVO | addCreditMemo(java.lang.String invoiceNumber, java.lang.String summary)
java.lang.String | addCreditMemoWithoutInvoice(AccountsReceivableVO vo)
java.lang.String | addEstimatedPayableWithReceiverItems(MakeAccountPayableAgent agent)
ExpenseVO | addExpense()
ExpenseAccountVO | addExpenseAccount(ExpenseAccountVO vo)
FiscalYearSettingsVO | addFiscalYearSettings(FiscalYearSettingsVO vo)
GeneralLedgerVO | addGeneralLedger(GeneralLedgerVO vo)
java.lang.String | addGeneralLedger(java.lang.String addressId, java.lang.String transactionType)
GeneralLedgerApprovalVO | addGeneralLedgerApproval(java.lang.String employeeId)
GLAutoApproveVO | addGLAutoApprove(GLAutoApproveVO vo)
GeneralLedgerCategoryVO | addGLCategory(GeneralLedgerCategoryVO vo)
MyPrintListVO | addMyPrintList(java.lang.String arNumber)
java.lang.String | addNewGeneralLedger(GeneralLedgerVO vo)
java.lang.String | addPayableWithoutReceiver(AddPayableWithoutReceiverAgent agent)
java.lang.String | addPayableWithReceiver(MakeAccountPayableAgent agent)
java.lang.String | addPayableWithReceiverItems(MakeAccountPayableAgent agent)
RefdocVO | addRefdocTwo(AccountsPayableItemPK apItemPk, java.lang.String orderNumber, java.lang.String itemNumber)
RefdocVO | addRefdocTwo(AccountsReceivableItemPK arItemPk, java.lang.String orderNumber, java.lang.String itemNumber)
java.lang.Long | addRollUpBomStdCostWorkSheet(RollUpBomStdCostWorkSheetVO vo)
AccountPayableCheckVO | addSingleCheck(MakeCheckAgent agent)
AccountPayableCheckVO | addSinglePrepaymentCheck(MakePrepaymentCheckAgent agent)
AccountingTransactionTypeVO | addTransactionType(AccountingTransactionTypeVO vo)
java.lang.String | addWireTransferFromCheckRun(java.lang.String checkRunNumber)
GeneralLedgerVO | approveGeneralLedger(java.lang.String transactionNumber)
java.lang.String | arPaymentRunByCustomer(java.util.List<AccountReceivableInfoWithPrepayResult> list, java.lang.Object[] info)
java.lang.String | autiClosingEntryMonthly(java.lang.String monthYear)
void | batchAddAccountsChartCategorysForBalanceSheet(java.util.List<AccountsChartCategoryVO> voList)
void | batchAddAccountsChartCategorysForEbitda(java.util.List<AccountsChartCategoryVO> voList)
void | batchAddAccountsChartCategorysForProfitLoss(java.util.List<AccountsChartCategoryVO> voList)
void | batchAddAccountsChartCategorysForTaxDetail(java.util.List<AccountsChartCategoryVO> voList)
void | batchApplyPrepay(java.util.List<AccountReceivableInfoWithPrepayResult> list)
ApprovedGLResult | batchApprovalGL(java.util.List<java.lang.String> transactionNumber)
ApprovedGLResult | batchCancelApprovalGL(java.util.List<java.lang.String> transactionNumber)
void | batchUpdateAccountsChartCategorysForBalanceSheet(java.util.List<AccountsChartCategoryVO> list)
void | batchUpdateAccountsChartCategorysForEbitda(java.util.List<AccountsChartCategoryVO> volist)
void | batchUpdateAccountsChartCategorysForProfitLoss(java.util.List<AccountsChartCategoryVO> list)
void | batchUpdateAccountsChartCategorysForTaxDetail(java.util.List<AccountsChartCategoryVO> volist)
void | cancelGeneralLedger(java.lang.String transactionNumber)
void | cancelPostGeneralLedger(java.lang.String fromMonthYear, java.lang.String toMonthYear, java.util.List<java.lang.String> glNumbers)
void | clearCategoryInAccountsChart(java.lang.Long categoryId)
void | clearGeneralLedgers(AccountMonthPK pk, java.util.Map<java.lang.String,java.lang.Boolean> glNumbers)
java.lang.String | closeGeneralLedger()
java.lang.String | closingEntryMonthly(java.lang.String monthYear)
void | commitChangeStdCostWorkSheet(java.lang.Long ii)
void | commitRollUpBomStdCostWorkSheet(java.lang.Long ii)
java.lang.String | dealWithDirectMaterialVariance(java.lang.String month, java.math.BigDecimal variance)
java.lang.String | dealWithEstimatedPayalbeMaterialVariance(java.lang.String month, java.math.BigDecimal variance)
void | deleteAccountChart(java.lang.String accountNumber)
void | deleteAccountPayableCheck(AccountPayableCheckVO vo)
void | deleteAccountReceivablePayment(AccountReceivablePaymentVO vo)
void | deleteAccountsChartCategoryForBalanceSheet(java.lang.Long pk)
void | deleteAccountsChartCategoryForEbitda(java.lang.Long pk)
void | deleteAccountsChartCategoryForProfitLoss(java.lang.Long pk)
void | deleteAccountsChartCategoryForTaxDetail(java.lang.Long pk)
void | deleteAccountsChartMapping(AccountsChartMappingPK pk)
void | deleteAllGeneralLedger()
void | deleteAP(AccountsPayableVO vo)
void | deleteAR(AccountsReceivableVO vo)
void | deleteArBP(java.lang.String bpID)
void | deleteARPaymentRun(ARPaymentRunVO vo)
void | deleteAsset(AssetVO vo)
void | deleteAssetType(java.lang.String id)
void | deleteAssetUsage(AssetUsagePK pk)
void | deleteBankReconciliationReport(BankReconciliationReportVO vo)
void | deleteChangeStdCostWorkSheetItem(ChangeStdCostWorkSheetItemPK pk)
void | deleteFiscalYearSetting(FiscalYearSettingsVO vo, boolean direct)
void | deleteGeneralLedger(GeneralLedgerVO vo)
void | deleteGeneralLedgerApproval(java.lang.String employeeId)
void | deleteGLAutoApproveById(java.lang.Long id)
void | deleteGLCategoryById(java.lang.String id)
void | deleteMyPrintList(java.util.ArrayList arNumberList)
void | deleteReceiverWithoutAPSaveRecords(java.util.Date d)
void | deleteRefdocTwo(BB2RefdocPK pk)
void | deleteTransactionType(AccountingTransactionTypeVO vo)
byte[] | downloadAccInfoDocument(MiscDocAgent agent)
void | errorGeneralLedger(java.lang.String transactionNumber, boolean isCancelError)
java.util.Collection<CustomerPrepayStatementListResult> | find1To30PrepayStatementByCustomerId(java.lang.String customerId, java.lang.String idType, java.lang.String currency, java.util.Date asOf, int firstIndex, int maxLength)
java.util.Collection<VendorPrepayStatementListResult> | find1To30PrepayStatementByVendorId(java.lang.String vendorId, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<CustomerStatementListResult> | find1To30StatementByCustomerId(java.lang.String customerId, java.lang.String idType, java.lang.String currency, java.util.Date asOf, int firstIndex, int maxLength)
java.util.Collection<VendorStatementListResult> | find1To30StatementByVendorId(java.lang.String vendorId, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<CustomerPrepayStatementListResult> | find31To60PrepayStatementByCustomerId(java.lang.String customerId, java.lang.String idType, java.lang.String currency, java.util.Date asOf, int firstIndex, int maxLength)
java.util.Collection<VendorPrepayStatementListResult> | find31To60PrepayStatementByVendorId(java.lang.String vendorId, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<CustomerStatementListResult> | find31To60StatementByCustomerId(java.lang.String customerId, java.lang.String idType, java.lang.String currency, java.util.Date asOf, int firstIndex, int maxLength)
java.util.Collection<VendorStatementListResult> | find31To60StatementByVendorId(java.lang.String vendorId, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<CustomerPrepayStatementListResult> | find61To90PrepayStatementByCustomerId(java.lang.String customerId, java.lang.String idType, java.lang.String currency, java.util.Date asOf, int firstIndex, int maxLength)
java.util.Collection<VendorPrepayStatementListResult> | find61To90PrepayStatementByVendorId(java.lang.String vendorId, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<CustomerStatementListResult> | find61To90StatementByCustomerId(java.lang.String customerId, java.lang.String idType, java.lang.String currency, java.util.Date asOf, int firstIndex, int maxLength)
java.util.Collection<VendorStatementListResult> | find61To90StatementByVendorId(java.lang.String vendorId, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<CustomerPrepayStatementListResult> | find90PlusPrepayStatementByCustomerId(java.lang.String customerId, java.lang.String idType, java.lang.String currency, java.util.Date asOf, int firstIndex, int maxLength)
java.util.Collection<VendorPrepayStatementListResult> | find90PlusPrepayStatementByVendorId(java.lang.String vendorId, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<CustomerStatementListResult> | find90PlusStatementByCustomerId(java.lang.String customerId, java.lang.String idType, java.lang.String currency, java.util.Date asOf, int firstIndex, int maxLength)
java.util.Collection<VendorStatementListResult> | find90PlusStatementByVendorId(java.lang.String vendorId, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<AccountAgingTotalResult> | findAccountAgingTotalResult(java.lang.String[] includeIds, java.lang.String[] excludeIds, boolean useAsOf, java.util.Date asOf)
java.util.Collection<AccountBalanceListResult> | findAccountBalanceById(java.lang.String companyUnitId, java.lang.String accountNumber, java.lang.String language, java.util.Date fromDate, java.util.Date toDate, java.lang.String addressIdLike, int firstIndex, int maxLength)
java.util.List<AccountingInfoDocumentVO> | findAccountingInfoDocument(java.lang.String yearCode, java.lang.String companyUnitId, java.lang.String accountingReportType, int firstIndex, int maxLength)
AccountingTransactionTypeVO | findAccountingTransactionTypeByPk(java.lang.String transactionType)
java.util.Collection<AccountingTransactionTypeVO> | findAccountingTransactionTypes()
java.util.Collection<AccountingTransactionTypeVO> | findAccountingTransactionTypesByType(java.lang.String transactionType, int firstIndex, int maxLength)
java.util.Collection<AccountPayableCheckVO> | findAccountPayableChecksByCheckNumber(java.lang.String checkNumber, int firstIndex, int maxLength)
java.util.Collection<AccountPayableCheckVO> | findAccountPayableChecksByCheckRunNumber(java.lang.String checkRunNumber, int firstIndex, int maxLength)
java.util.Collection<AccountsChartCategoryVO> | findAccountsChartCategoryForBalanceSheetByCategoryName(java.lang.String categoryName, int firstIndex, int maxLength)
java.util.Collection<AccountsChartCategoryVO> | findAccountsChartCategoryForBalanceSheetPredefineByCategoryName(java.lang.String categoryName, int firstIndex, int maxLength)
java.util.Collection<AccountsChartCategoryVO> | findAccountsChartCategoryForProfitLossByCategoryName(java.lang.String categoryName, int firstIndex, int maxLength)
java.util.Collection<AccountsChartCategoryVO> | findAccountsChartCategoryForProfitLossPredefineByCategoryName(java.lang.String categoryName, int firstIndex, int maxLength)
java.util.Collection<AccountsChartCategoryVO> | findAccountsChartCategoryForTaxDetailByCategoryName(java.lang.String categoryName, int firstIndex, int maxLength)
java.util.Collection<AccountsChartCategoryVO> | findAccountsChartCategoryForTaxDetailPredefineByCategoryName(java.lang.String categoryName, int firstIndex, int maxLength)
java.util.Collection<AccountsChartMappingVO> | findAccountsChartMappingBySubcompanyId(java.lang.String subcompanyId, int firstIndex, int maxLength)
java.util.Collection<AccountsChartVO> | findAccountsChartsByCompanyUnit(java.lang.String accountNumber, java.lang.String language, java.lang.String accountType, java.lang.String companyUnitId, int firstIndex, int maxLength)
java.util.Collection<AccountsChartVO> | findAccountsChartsById(java.lang.String accountNumber, int firstIndex, int maxLength)
java.util.Collection<AccountsChartVO> | findAccountsChartsBySubType(java.lang.String accountNumber, java.lang.String language, java.lang.String companyUnitId, java.lang.String accountSubType, int firstIndex, int maxLength)
java.util.Collection<AccountsChartVO> | findAccountsChartsByType(java.lang.String accountNumber, java.lang.String language, java.lang.String accountType, int firstIndex, int maxLength)
java.util.Collection<AccountsChartVO> | findAccountsChartsByType(java.lang.String accountNumber, java.lang.String language, java.lang.String accountType, java.lang.String categoryReportType, int firstIndex, int maxLength)
java.util.Collection<AddressAccountInfo> | findAddressAccountInfo(java.lang.String id, java.util.Date from, java.util.Date to, boolean includeUnpost, int firstIndex, int maxLength)
java.util.Collection<APAgingItemListResult> | findAgingAPItems(java.lang.String[] includeCustomerId, java.lang.String[] excludeCustomerId, boolean useAsOf, java.util.Date asOf, int firstIndex, int length)
java.util.Collection<CustomerStatementTotalResult> | findAgingAps(java.lang.String[] includeVendorId, java.lang.String[] excludeVendorId, boolean useAsOf, java.util.Date asOf, int firstIndex, int maxLength)
java.util.Collection<InvoiceAgingItemListResult> | findAgingARItems(java.lang.String[] includeCustomerId, java.lang.String[] excludeCustomerId, boolean useAsOf, java.util.Date asOf, int firstIndex, int length)
java.util.Collection<CustomerStatementTotalResult> | findAgingARs(java.lang.String[] includeCustomerId, java.lang.String[] excludeCustomerId, boolean useAsOf, java.util.Date asOf, int firstIndex, int length)
java.util.Collection<AccountingTransactionTypeVO> | findAllAccountingTransactionTypes(boolean showJType, int firstIndex, int maxLength)
java.util.Collection<AccountPayableCheckRunVO> | findAllAccountPayableCheckRuns(int firstIndex, int maxLength)
java.util.Collection<AccountPayableCheckVO> | findAllAccountPayableChecks(int firstIndex, int maxLength)
java.util.Collection<AccountReceivablePaymentVO> | findAllAccountReceivablePayments(int firstIndex, int maxLength)
java.util.Collection<AccountsChartVO> | findAllAccountsCharts(boolean showInactive, int firstIndex, int maxLength)
java.util.Collection<AccountsPayableInfoVO> | findAllAPs(int firstIndex, int maxLength)
java.util.Collection<ARBoilerplateVO> | findAllArBP(int firstIndex, int maxLength)
java.util.Collection<AccountsReceivableInfoVO> | findAllARInvoicces(int firstIndex, int maxLength)
java.util.Collection<ARPaymentRunVO> | findAllARPaymentRuns(int firstIndex, int maxLength)
java.util.Collection<AccountsReceivableInfoVO> | findAllARWithoutTracking(int firstIndex, int maxLength)
java.util.Collection<AssetVO> | findAllAssets(int firstIndex, int maxLength)
java.util.Collection<java.lang.String> | findAllAssetsDepreciationMonths(java.lang.String assetNumber, int firstIndex, int maxLength)
java.util.Collection<AssetTypeVO> | findAllAssetTypes(int firstIndex, int maxLength)
GLInfoByPeriodResult | findAllBankOrCashGLByDate(java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String fMonthYear, java.lang.String tMonthYear, boolean includeUnpostGL, boolean showOriginal, int firstIndex, int maxLength)
GLInfoByPeriodResult | findAllDetailAccountTransaction(java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String fMonthYear, java.lang.String tMonthYear, boolean includeUnpostGL, boolean showOpposeAcct, java.lang.String customerId, boolean showOriginal)
java.util.Collection<ExpenseAccountVO> | findAllExpenseAccount(int firstIndex, int maxLength)
java.util.Collection<ExpenseListResult> | findAllExpenses(int firstIndex, int maxLength)
java.util.Collection<AmountsStatementResult> | findAllFirstLevelAccountFiscalYearBalance()
java.util.Collection<FiscalYearSettingsVO> | findAllFiscalYearSettings(int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerApprovalVO> | findAllGeneralLedgerApproval(int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | findAllGeneralLedgers(java.lang.String glCategory, java.lang.String sequenceFrom, java.lang.String sequenceTo, java.lang.String id, java.lang.String accounts, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<GLAutoApproveVO> | findAllGLAutoApproves(int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerCategoryVO> | findAllGLCategories(int firstIndex, int maxLength)
java.util.Collection<GlMonthVO> | findAllGlMonth(int firstIndex, int maxLength)
java.util.Collection<AllStatementsListResult> | findAllStatements()
java.util.Collection<AccountsPayableInfoVO> | findAP(java.lang.String apNumber, java.lang.String vendorId, java.lang.String buyer, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | findAPAccountInfo(java.lang.String apNumber, int firstIndex, int maxLength)
java.util.Collection<AccountAgingTotalResult> | findAPAgingTotalResult(java.lang.String[] includeIds, java.lang.String[] excludeIds, boolean useAsOf, java.util.Date asOf)
java.util.Map | findAPAR(java.lang.String vendoInvoice)
java.util.Collection<TempArApAgingVO> | findAPbyAddressIdSet(java.lang.String[] includeVendorId, java.lang.String[] excludeVendorId, boolean useAsOf, java.util.Date asOf, int firstIndex, int maxLength)
java.util.Collection<APItemListResult> | findApByDate(java.lang.String partNumberLike, java.lang.String partType, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String vendorId, java.lang.String vendorInvoice, java.lang.String status, java.lang.String Datetype, java.util.Date fromDate, java.util.Date toDate, java.lang.String productCode, int firstIndex, int maxLength)
java.util.Collection<APItemListResult> | findApByDate(java.lang.String apNumber, java.lang.String partNumberLike, java.lang.String partType, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String vendorId, java.lang.String vendorInvoice, java.lang.String status, java.lang.String Datetype, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
AccountsPayableVO | findAPByPk(java.lang.String pk)
java.util.Collection<APTaxForZipcodeListResult> | findAPbyZipcodeTaxList(java.lang.String apNumber, java.lang.String vendor, java.lang.String zipcode, java.lang.String status, java.util.Date from, java.util.Date to)
java.util.Collection<ApCheckRunListResult> | findApCheckRunByDate(java.util.Date fromDate, java.util.Date toDate, java.lang.String checkNumber, java.lang.String vendorId, java.lang.String debitAccount, java.lang.String creditAccount, java.lang.String dateColumn, int firstIndex, int maxLength)
java.util.Collection<AccountPayableCheckRunItemVO> | findAPCheckRunItemByCheckRunNumber(java.lang.String checkRunNumber)
java.util.Collection<AccountPayableCheckRunVO> | findAPCheckRunsByCheckRunNumberLike(java.lang.String checkRunNumberLike, int firstIndex, int maxLength)
java.util.Collection<AccountsPayableItemVO> | findAPItemsByApNumber(java.lang.String apNumber)
AccountsPayableItemVO | findAPItemsByPk(AccountsPayableItemPK pk)
java.util.Collection<ApPrepayVO> | findApPrepay(java.lang.String appNumber, java.lang.String vendorId, java.lang.String status, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)
java.util.Collection<APPrepayInfoResult> | findAPPrepayToBatchPaymentbyAddressIdSet(java.lang.String[] includeCustomerId, java.lang.String[] excludeCustomerId, java.lang.String companyUnitId, java.util.Date fromDate, java.util.Date toDate)
java.util.Collection<ApPrepayVO> | findApPrepayTotal(java.lang.String appNumber, java.lang.String vendorId, java.lang.String status, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)
java.util.Collection<AccountsPayableInfoVO> | findAPs(java.lang.String apNumber, java.lang.String vendorId, java.lang.String buyer, java.lang.String status)
java.util.Collection<AccountsPayableInfoVO> | findAPsByAddressIdAndStatus(java.lang.String addressId, java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<AccountsPayableInfoVO> | findAPsByApNumber(java.lang.String apNumber, int firstIndex, int maxLength)
java.util.Collection<AccountsPayableInfoVO> | findAPsByVendorId(java.lang.String vendorId, int firstIndex, int maxLength)
java.util.Collection<AccountsPayableInfoVO> | findAPsByVendorInvoice(java.lang.String vendorInvoice, int firstIndex, int maxLength)
java.util.Collection<AccountingTotalMoneyResult> | findAPsTotalMoneyByVendorId(java.lang.String vendorId)
java.util.Collection<AccountPayableInfoWithPrepayResult> | findAPToBatchPaymentbyAddressIdSet(java.lang.String[] includeVendorId, java.lang.String[] excludeVendorId, java.lang.String companyUnitId, java.lang.String currency, java.util.Date fromDate, java.util.Date toDate)
java.util.Collection<AccountingTotalMoneyResult> | findAPTotalMoneyByDate(java.lang.String apNumber, java.lang.String partNumberLike, java.lang.String partType, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String vendorId, java.lang.String vendorInvoice, java.lang.String status, java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String productCode)
java.util.Collection<GeneralLedgerVO> | findARAccountInfo(java.lang.String arNumber, int firstIndex, int maxLength)
java.util.Collection<ARBoilerplateVO> | findArBPByBPId(java.lang.String bpId, int firstIndex, int maxLength)
java.util.Collection<TempArApAgingVO> | findARbyAddressIdSet(java.lang.String[] includeCustomerId, java.lang.String[] excludeCustomerId, boolean useAsOf, java.util.Date asOf, int firstIndex, int maxLength)
AccountsReceivableVO | findARByPk(java.lang.String pk)
java.util.Collection<ARTaxForZipcodeListResult> | findARbyZipcodeTaxList(java.lang.String arNumber, java.lang.String customer, java.lang.String zipcode, java.lang.String status, java.util.Date from, java.util.Date to)
java.util.Collection<ArCommissionListResult> | findArCommissionByDate(java.lang.String dateType, java.lang.String status, java.lang.String salesCodeId, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<AccountsReceivableItemResult> | findARItemByPartAndDate(java.util.Date fromDate, java.util.Date toDate, BB2Part part, int firstIndex, int maxLength)
java.util.Collection<AccountsReceivableItemVO> | findARItemsByInvoiceNumber(java.lang.String invoiceNumber)
java.util.Collection<AccountsReceivableItemVO> | findARItemsByPartNumber(java.lang.String partNumber)
AccountsReceivableItemVO | findARItemsByPk(AccountsReceivableItemPK pk)
java.util.Collection<AccountsChartVO> | findArPaymentAccounts()
java.util.Collection<ARPaymentRunListResult> | findArPaymentByDate(java.util.Date fromDate, java.util.Date toDate, java.lang.String paymentNumber, java.lang.String customerId, java.lang.String debitAccount, java.lang.String creditAccount, int firstIndex, int maxLength)
java.util.Collection<ARPaymentRunVO> | findARPaymentRunsByPaymentNumberLike(java.lang.String paymentRunNumberLike, int firstIndex, int maxLength)
java.util.Collection<AccountReceivablePaymentVO> | findARPaymentsByPaymentNumberLike(java.lang.String paymentNumberLike, int firstIndex, int maxLength)
java.util.Collection<AccountReceivablePaymentVO> | findARPaymentsByPaymentRunNumber(java.lang.String paymentRunNumber, int firstIndex, int maxLength)
java.util.Collection<ArPrepayVO> | findArPrepay(java.lang.String arpNumber, java.lang.String customerId, java.lang.String status, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)
java.util.Collection<ARPrepayInfoResult> | findARPrepayToBatchReceivebyAddressIdSet(java.lang.String[] includeCustomerId, java.lang.String[] excludeCustomerId, java.lang.String companyUnitId, java.util.Date fromDate, java.util.Date toDate)
java.util.Collection<ArPrepayVO> | findArPrepayTotal(java.lang.String arpNumber, java.lang.String customerId, java.lang.String status, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)
java.util.Collection<AccountsReceivableVO> | findARs(java.lang.String customerId, java.util.Date fromDate, java.util.Date toDate)
java.util.Collection<ArSalesCodeTotalListResult> | findArSalesCodeTotalByDate(java.lang.String dateType, java.lang.String status, java.lang.String salesCodeId, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<AccountsReceivableInfoVO> | findARsByCustomerId(java.lang.String customerId, int firstIndex, int maxLength)
java.util.Collection | findARsByDate(java.lang.String customerId, boolean customerLike, boolean includeCM, java.util.Date dateFrom, java.util.Date dateTo, java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<AccountsReceivableInfoVO> | findARsByInvoiceNumber(java.lang.String invoiceNumber, java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<AccountingTotalMoneyResult> | findARsTotalMoneyByCustomerId(java.lang.String customerId)
java.util.Collection | findARsTotalMoneyByDate(java.lang.String customerId, boolean customerLike, boolean includeCM, java.util.Date dateFrom, java.util.Date dateTo, java.lang.String status)
java.util.Collection<AccountReceivableInfoWithPrepayResult> | findARToBatchReceivebyAddressId(java.lang.String customerId, java.lang.String companyUnitId, java.lang.String currency, java.util.Date fromDate, java.util.Date toDate)
java.util.Collection<AccountReceivableInfoWithPrepayResult> | findARToBatchReceivebyAddressIdSet(java.lang.String[] includeCustomerId, java.lang.String[] excludeCustomerId, java.lang.String companyUnitId, java.lang.String currency, java.util.Date fromDate, java.util.Date toDate)
java.util.List | findARTotalMoneyByDate(boolean isAR, java.lang.String arNumber, java.lang.String customerId, boolean isCludeCmNumber, java.util.Date fromDate, java.util.Date toDate)
java.util.List | findARTotalMoneyByDate(java.lang.String[] arNumbers)
java.util.Collection<AccountingTotalMoneyResult> | findARTotalMoneyByDate(java.lang.String arNumber, java.lang.String pnLike, boolean partNumberlike, java.lang.String pa, java.lang.String productCode, java.lang.String customerId, boolean customerLike, java.lang.String invoiceBy, java.lang.String status, java.lang.String dateType, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isCludeCmNumber, java.util.Date fromDate, java.util.Date toDate, java.math.BigDecimal lessThanMargin, java.math.BigDecimal highThanMargin, boolean billAndHold, java.util.Map moreParameters)
java.util.Collection<AssetAddOrDisposalsReport> | findAssetAdditions(java.lang.String assetNumber, java.lang.String assetType, java.lang.String departmentID, java.lang.String location, java.util.Date fDate, java.util.Date tDate, int firstIndex, int maxLength)
AssetVO | findAssetByPk(java.lang.String assetNumber)
java.util.Collection<AssetDepreciateDetailReport> | findAssetDepreciateDetails(java.lang.String fiscalYear, java.lang.String assetNumber, java.lang.String assetType, java.lang.String departmentID, java.lang.String location, java.lang.String amortizationExpenseAccount, java.lang.String status)
java.util.Collection<AssetDepreciateVO> | findAssetDepreciates(java.lang.String assetNumber, java.lang.String monthYear, java.lang.String departmentID, java.lang.String location, java.lang.String usingStatus, java.lang.String assetType, java.lang.String amortizationExpenseAccount, java.lang.String transactionNumber, int firstIndex, int maxLength)
java.util.Collection<AssetAddOrDisposalsReport> | findAssetDisposals(java.lang.String assetNumber, java.lang.String assetType, java.lang.String departmentID, java.lang.String location, java.util.Date fDate, java.util.Date tDate, int firstIndex, int maxLength)
java.util.Collection<AssetVO> | findAssetsByAssetNumber(java.lang.String assetNumber, int firstIndex, int maxLength)
java.util.Collection<AssetVO> | findAssetsList(java.lang.String assetNumber, java.lang.String assetType, java.lang.String depreciationType, java.lang.String depreciationStatus, java.lang.String location, java.lang.String departmentID, java.lang.String amortizationExpenseAccount, java.lang.String usingStatus, java.lang.String status, int firstIndex, int maxLength)
GLCheckRegisterResult | findBackOrCashCheckRegister(java.lang.String fMonthYear, java.lang.String tMonthYear, java.lang.String companyUnit, java.lang.String accountNumber, java.lang.String id, java.lang.String checkType)
java.util.Collection<GeneralLedgerByDateListResult> | findBackOrCashCheckRegisterDetail(java.lang.String fMonthYear, java.lang.String tMonthYear, java.lang.String companyUnit, java.lang.String accountNumber, java.lang.String id, java.lang.String checkNum, java.lang.String checkType)
AccountingBalanceSheetResult | findBalanceSheet(java.lang.String monthYear)
java.util.Collection<AccountsChartCategoryListResult> | findBalanceSheetOfCategory(java.lang.String monthYear)
BalanceSheetSideBySideResult | findBalanceSheetSBS(java.lang.String monthYear)
java.util.Collection<BankReconciliationReportVO> | findBankReconciliationReport(java.lang.String month, java.lang.String accountNumber, java.lang.String companyUnitID, int firstIndex, int maxLength)
AllBudgetResult | findCashFlowBudget(java.lang.String companyUnitId, java.lang.String month1, java.lang.String month2, boolean isCheck)
CashFlowByMonthReportResult | findCashFlowByMonthReport(java.lang.String companyUnitId, java.lang.String startMonth, java.lang.String endMonth)
java.util.Collection<CashFlowMonthTotalResult> | findCashFlowMonthTotalBudget(java.lang.String companyUnitId, java.lang.String startMonth, java.lang.String endMonth)
java.util.Collection<ChangeStdCostWorkSheetVO> | findChangeStdCostWorkSheet(int firstIndex, int maxLength)
java.util.Collection<ChangeStdCostWorkSheetItemVO> | findChangeStdCostWorkSheetItem(java.lang.Long ii, int firstIndex, int maxLength)
java.util.Collection<java.lang.String> | findCheckNumberByPOWithApp(java.lang.String poNumber)
java.util.Collection<java.lang.String> | findCheckNumberBySOWithArp(java.lang.String soNumber)
java.util.Collection<AccountPayableCheckRunItemVO> | findCheckRunItemByCheckNo(java.lang.String checkRunNo, java.lang.String checkNo, java.lang.String vendorId)
java.util.Collection<GlMonthVO> | findClosedGlMonth(int firstIndex, int maxLength)
ClosingStatementResult | findClosingStatement(java.lang.String monthYear, java.lang.String companyUnitId)
java.util.Collection<AccountsReceivableInfoVO> | findCMByDate(java.lang.String[] cmNumbers, int firstIndex, int maxLength)
java.util.Collection<AccountsReceivableInfoVO> | findCMByDate(java.lang.String invoiceId, java.lang.String customerId, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isInvoiceDate, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<InvoiceItemListResult> | findCMItemByDate(java.lang.String partNumberLike, java.lang.String partType, java.lang.String customerId, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isInvoiceDate, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<AccountsReceivableInfoVO> | findCMsByCMNumber(java.lang.String invoiceNumber, int firstIndex, int maxLength)
java.util.Collection<AccountsReceivableInfoVO> | findCMsByCustomerId(java.lang.String customerId, int firstIndex, int maxLength)
java.util.Collection<AccountsCreditDebitListResult> | findCreditListByApNumber(java.lang.String apNumber, java.lang.String language, int firstIndex, int maxLength)
java.util.Collection<AccountsCreditDebitListResult> | findCreditListByAppNumber(java.lang.String appNumber, int firstIndex, int maxLength)
java.util.Collection<AccountsCreditDebitListResult> | findCreditListByArNumber(java.lang.String arNumber, java.lang.String language, int firstIndex, int maxLength)
java.util.Collection<GlMonthVO> | findCurrentAllGlMonth(int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerByDateListResult> | findCurrentBalanceResult(java.lang.String companyUnitId, java.lang.String accountNumber, java.lang.String language, java.lang.String monthName, int firstIndex, int maxLength)
java.util.Map<java.lang.String,java.math.BigDecimal> | findCurrentFiscalYearARByMonth()
java.util.Map<java.lang.String,java.math.BigDecimal> | findCurrentFiscalYearARGrossMarginByMonth()
java.util.Collection<VendorPrepayStatementListResult> | findCurrentPrepayStatementByVendorId(java.lang.String vendorId, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<CustomerStatementListResult> | findCurrentStatementByCustomerId(java.lang.String customerId, java.lang.String currency, java.util.Date asOf, int firstIndex, int maxLength)
java.util.Collection<VendorStatementListResult> | findCurrentStatementByVendorId(java.lang.String vendorId, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<CustomerPrepayStatementListResult> | findCustomerPrepayStatementById(java.lang.String customerId, java.lang.String currency, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<CustomerPrepayStatementListResult> | findCustomerPrepayStatementById(java.lang.String customerId, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<CustomerPrepayStatementListResult> | findCustomerPrepayStatementById(java.lang.String customerId, java.lang.String idType, java.lang.String currency, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<CustomerStatementTotalResult> | findCustomerPrepayStatementsTotal(java.lang.String customerId, java.util.Date asOf, java.lang.String currency)
java.util.Collection<CustomerStatementTotalResult> | findCustomerPrepayStatementsTotal(java.lang.String customerId, java.lang.String idType, java.util.Date asOf, java.lang.String currency)
java.util.Collection<CustomerStatementTotalResult> | findCustomerStatementsTotal(java.lang.String customerId, java.util.Date asOf, java.lang.String currency)
java.util.Collection<CustomerStatementTotalResult> | findCustomerStatementsTotal(java.lang.String customerId, java.lang.String idType, java.util.Date asOf, java.lang.String currency)
java.util.List<CustomerStatementResult> | findCustomerStatementTotalByDate(java.lang.String customer, java.util.Date startDate, java.util.Date endDate, java.lang.String currency)
java.util.Collection<AccountsCreditDebitListResult> | findDebitListByApNumber(java.lang.String apNumber, java.lang.String language, int firstIndex, int maxLength)
java.util.Collection<AccountsCreditDebitListResult> | findDebitListByAppNumber(java.lang.String appNumber, int firstIndex, int maxLength)
java.util.Collection<AccountsCreditDebitListResult> | findDebitListByArNumber(java.lang.String arNumber, java.lang.String language, int firstIndex, int maxLength)
java.util.List<DepositSummaryResult> | findDepositSummary(java.lang.String[] includableAccount, java.util.Date fromDate, java.util.Date toDate)
java.util.Collection<AccountsPayableInfoVO> | findDM(java.lang.String apNumber, java.lang.String vendorId, java.lang.String buyer, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | findDMAccountInfo(java.lang.String apNumber, int firstIndex, int maxLength)
java.util.Collection<APItemListResult> | findDMByDate(java.lang.String partNumberLike, java.lang.String partType, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String vendorId, java.lang.String vendorInvoice, java.lang.String status, java.lang.String Datetype, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<APItemListResult> | findDMByDate(java.lang.String apNumber, java.lang.String partNumberLike, java.lang.String partType, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String vendorId, java.lang.String vendorInvoice, java.lang.String status, java.lang.String Datetype, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
AccountsPayableVO | findDMByPk(java.lang.String pk)
java.util.Collection<AccountingTotalMoneyResult> | findDMTotalMoneyByDate(java.lang.String apNumber, java.lang.String partNumberLike, java.lang.String partType, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String vendorId, java.lang.String vendorInvoice, java.lang.String status, java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate)
java.util.Collection<AccountsPayableInfoVO> | findEP(java.lang.String apNumber, java.lang.String vendorId, java.lang.String buyer, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)
java.util.Collection<APItemListResult> | findEPByDate(java.lang.String partNumberLike, java.lang.String partType, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String vendorId, java.lang.String vendorInvoice, java.lang.String status, java.lang.String datetype, java.util.Date fromDate, java.util.Date toDate, java.lang.String productCode, java.lang.String receiverNumber, int firstIndex, int maxLength)
AccountsPayableVO | findEPByPk(java.lang.String pk)
java.util.Collection<AccountingTotalMoneyResult> | findEPTotalMoneyByDate(java.lang.String apNumber, java.lang.String partNumberLike, java.lang.String partType, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String vendorId, java.lang.String vendorInvoice, java.lang.String status, java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String productCode, java.lang.String receiverNumber)
java.util.Collection<ExpenseListResult> | findExpensesByExpenseNumber(java.lang.String expenseNumberLike, int firstIndex, int maxLength)
AllBudgetResult | findFiscalYearBudget(java.lang.String fiscalYear, java.lang.String companyUnitId)
AllBudgetResult | findFiscalYearBudget(java.lang.String fiscalYear, java.lang.String companyUnitId, boolean oldYear)
AccountsChartResult | findFiscalYearBudgetAndActualAmountByCharts(java.lang.String[] accountNumber, java.lang.String companyUnitId)
AllBudgetResult | findFiscalYearBudgetByMonth(java.lang.String fiscalYear, java.util.Date startDate, java.util.Date endDate, java.lang.String companyUnitId, boolean includeInactive)
FiscalYearSettingsVO | findFiscalYearSettingsByDate(java.util.Date date)
FiscalYearSettingsVO | findFiscalYearSettingsByPk(java.lang.String fyNumber)
java.util.Collection<GeneralLedgerApprovalVO> | findGeneralLedgerApprovalById(java.lang.String employeeId, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerApprovalVO> | findGeneralLedgerApprovalByName(java.lang.String userName, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerByDateListResult> | findGeneralLedgerByDate(java.lang.String companyUnitId, java.lang.String accountNumber, java.lang.String language, java.util.Date fromDate, java.util.Date toDate, java.lang.String accountType, java.lang.String[] include, java.lang.String[] exclude, int orderBy, java.lang.String checkNumber, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerByDateListResult> | findGeneralLedgerByDate(java.lang.String companyUnitId, java.lang.String accountNumber, java.lang.String language, java.util.Date fromDate, java.util.Date toDate, java.lang.String clearedStatus, java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerListResult> | findGLByConditions(java.lang.String addressId, java.lang.String apNumber, java.lang.String arNumber, java.lang.String soOrWONumber, java.lang.String shipperNumber, java.lang.String receiverNumber, java.lang.String ourPOorWONumber, java.util.Date fromDate, java.util.Date toDate, java.math.BigDecimal amount, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerListResult> | findGLById(java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<GLDebitCreditListResult> | findGLCreditDebitByConditions(java.lang.String addressId, java.lang.String apNumber, java.lang.String arNumber, java.lang.String soOrWONumber, java.lang.String shipperNumber, java.lang.String receiverNumber, java.lang.String ourPOorWONumber, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<GlMonthVO> | findGlMonthByFyNumber(java.lang.String fyNumber, int firstIndex, int maxLength)
java.util.Collection<GlMonthVO> | findGlMonthsByFyNumber(java.lang.String fyNumber)
java.util.Collection<SalesMarginListResult> | findGrossMarginByID(java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<SalesMarginListResult> | findGrossMarginTotalByID(java.util.Date fromDate, java.util.Date toDate)
java.util.List | findInvoiceByDate(boolean isAR, java.lang.String arNumber, java.lang.String customerId, boolean isCludeCmNumber, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.List | findInvoiceByDate(java.lang.String[] arNumbers, int firstIndex, int maxLength)
java.util.Collection<InvoiceItemListResult> | findInvoiceByDate(java.lang.String partNumberLike, boolean partNumberlike, java.lang.String partType, java.lang.String pf, java.lang.String productCode, java.lang.String customerId, boolean customerLike, java.lang.String invoiceBy, java.lang.String status, java.lang.String dateType, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isCludeCmNumber, java.util.Date fromDate, java.util.Date toDate, java.math.BigDecimal lessThanMargin, java.math.BigDecimal highThanMargin, boolean billAndHold, java.util.Map moreParameters, int firstIndex, int maxLength)
java.util.Collection<InvoiceItemListResult> | findInvoiceItemsByPartPK(PartPK partPk, int firstIndex, int maxLength)
java.util.Collection<GlMonthVO> | findLatestOpenFYGlMonth(int firstIndex, int maxLength)
java.util.Collection<MonthSoOrArByCustomerResult> | findMonthARByCustomer(java.util.Date fromMonth, java.util.Date toMonth, java.lang.String ARStatus, java.lang.String customerId, boolean includeCM, int firstIndex, int maxLength)
java.util.Collection<GlMonthBudgetVO> | findMonthList(java.lang.String month1, java.lang.String month2)
java.util.Collection<AccountsReceivableInfoVO> | findMyARPrintList()
java.util.Collection<AccountsPayableInfoVO> | findOpenAPs(int firstIndex, int maxLength)
java.util.Collection<AccountsPayableInfoVO> | findOpenAPsByApNumber(java.lang.String apNumber, int firstIndex, int maxLength)
java.util.Collection<AccountsPayableInfoVO> | findOpenAPsByVendorId(int firstIndex, int maxLength, java.lang.String vendorId)
java.util.Collection<AccountsReceivableInfoVO> | findOpenARs(int firstIndex, int maxLength)
java.util.Collection<AccountsReceivableInfoVO> | findOpenARsByVendorId(int firstIndex, int maxLength, java.lang.String vendorId, boolean includeCM)
java.util.Collection<GlMonthVO> | findOpenGlMonth(int firstIndex, int maxLength)
java.util.Collection<InvoiceItemListResult> | findOpenInvoiceItemsByPartPK(PartPK partPk, int firstIndex, int maxLength)
java.util.Collection<AccountsPayableInfoVO> | findPastDueAPs(int firstIndex, int maxLength)
java.util.Collection<AccountsPayableInfoVO> | findPastdueAPsByVendorId(java.lang.String vendorId, int firstIndex, int maxLength)
java.util.Collection<AccountsReceivableInfoVO> | findPastDueARs(int firstIndex, int maxLength)
java.util.Collection<AccountsReceivableInfoVO> | findPastDueARsByVendor(java.lang.String vendorId, boolean includeCM, int firstIndex, int length)
java.util.Collection<PaymentHistoryVO> | findPaymentHistory(int firstIndex, int maxLength)
java.util.Collection<ARPaymentRunItemVO> | findPaymentRunItemByPaymentNo(java.lang.String paymentRunNo, java.lang.String paymentNumber, java.lang.String customerId)
java.util.Collection<AccountsChartCategoryListResult> | findProfitLossOfCategory(java.lang.String monthYear)
ProfitLossStatementResult | findProfitLossStatement()
ProfitLossStatementResult | findProfitLossStatement(java.lang.String companyUnitId, java.util.Date currentPeriodFrom, java.util.Date currentPeriodTo, java.util.Date priorPeriodFrom, java.util.Date priorPeriodTo)
java.util.Collection<ReceiverVO> | findReceiverItemsWithOutAP(java.lang.String vendorId, java.lang.String currency, java.lang.String buyer, java.util.Date fromDate, java.util.Date toDate, java.lang.String poNumber, int firstIndex, int maxLength)
java.util.Collection<ReceiverInfoVO> | findReceiverWithOutAP(java.lang.String vendorId, java.lang.String buyer, java.lang.String currency, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<TempReceiverWithoutAPInfo> | findReceiverWithoutAPSaveRecordDetails(java.util.Date saveDate, int firstIndex, int maxLength)
java.util.Collection<TempReceiverWithoutAPInfo> | findReceiverWithoutAPSaveRecords(int firstIndex, int maxLength)
java.util.Collection<RollUpBomStdCostWorkSheetVO> | findRollUpBomStdCostWorkSheet(int firstIndex, int maxLength)
java.util.Collection<RollUpBomStdCostWorkSheetItemVO> | findRollUpBomStdCostWorkSheetItem(java.lang.Long ii, int firstIndex, int maxLength)
java.util.Collection<RtvShipperInfoVO> | findRTVShipperWithOutDebitMemo(java.lang.String vendorId, java.lang.String currency, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<SalesTaxListResult> | findSalesTaxByDate(java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String orderBy, java.lang.String reportType, boolean isCM, int firstIndex, int maxLength)
java.util.Collection<AccountingTotalMoneyResult> | findSalesTaxTotalMoneyByDate(java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String reportType, boolean isCM)
java.util.Collection<ShipperVO> | findShipperWithItemsWithOutInvoice(java.lang.String customerId, java.lang.String shippedBy, java.lang.String salesMan, java.lang.String currency, java.util.Date fromDate, java.util.Date toDate, java.lang.String salesOrderNumber, int firstIndex, int maxLength)
java.util.Collection<ShipperVO> | findShipperWithItemsWithOutUnbilled(java.lang.String customerId, java.lang.String shippedBy, java.lang.String salesMan, java.lang.String currency, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<ShipperInfoVO> | findShipperWithOutInvoice(java.lang.String customerId, java.lang.String shippedBy, java.lang.String salesMan, java.lang.String currency, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<CustomerStatementListResult> | findStatementById(java.lang.String customerId, java.lang.String currency, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<CustomerStatementListResult> | findStatementById(java.lang.String customerId, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<CustomerStatementListResult> | findStatementById(java.lang.String customerId, java.lang.String idType, java.lang.String currency, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | findTransactionByAPNumber(java.lang.String apNumber, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | findTransactionByAppNumber(java.lang.String appNumber, boolean showVoid, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | findTransactionByAppNumber(java.lang.String appNumber, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | findTransactionByARNumber(java.lang.String arNumber, boolean showVoid, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | findTransactionByARNumber(java.lang.String arNumber, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | findTransactionByArpNumber(java.lang.String arpNumber, boolean showVoid, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | findTransactionByArpNumber(java.lang.String arpNumber, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | findTransactionByDMNumber(java.lang.String apNumber, boolean showVoid, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | findTransactionByDMNumber(java.lang.String apNumber, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | findTransactionByMPONumber(java.lang.String poNumber, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | findTransactionByPONumber(java.lang.String poNumber, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | findTransactionBySONumber(java.lang.String soNumber, int firstIndex, int maxLength)
TwelveMonthCashFlowReportResult | findTwelveMonthCashFlowReport(java.lang.String monthYear, java.lang.String companyUnitId, int grace)
java.util.Collection<VendorPrepayStatementListResult> | findVendorPrepayStatementById(java.lang.String vendorId, java.lang.String currency, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<VendorPrepayStatementListResult> | findVendorPrepayStatementById(java.lang.String vendorId, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<CustomerStatementTotalResult> | findVendorPrepayStatementsTotal(java.lang.String vendorId, java.lang.String currency)
java.util.Collection<CustomerStatementTotalResult> | findVendorPrepayStatementsTotal(java.lang.String vendorId, java.lang.String currency, java.util.Date toDate)
java.util.Collection<VendorStatementListResult> | findVendorStatementById(java.lang.String vendorId, java.lang.String currency, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<VendorStatementListResult> | findVendorStatementById(java.lang.String vendorId, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<CustomerStatementTotalResult> | findVendorStatementsTotal(java.lang.String vendorId, java.lang.String currency)
java.util.Collection<CustomerStatementTotalResult> | findVendorStatementsTotal(java.lang.String vendorId, java.lang.String currency, java.util.Date toDate)
java.util.Collection<GlMonthBudgetVO> | get15MonthYear()
AccountingInfoDocumentVO | getAccInfoDocumentByID(java.lang.String yearCode, java.lang.String companyUnitId, java.lang.String accountingReportType)
int | getAccountAgingTotalResultCount(java.lang.String[] includeIds, java.lang.String[] excludeIds, boolean useAsOf, java.util.Date asOf)
java.util.Collection<AccountBalanceResult> | getAccountBalance(java.lang.String fMonthYear, java.lang.String tMonthYear, java.lang.String companyUnitId, boolean usePost)
int | getAccountBalanceCountById(java.lang.String companyUnitId, java.lang.String accountNumber, java.util.Date fromDate, java.util.Date toDate, java.lang.String addressIdLike)
AccountsChartAdvanceCategoryVO | getAccountChartBalanceSheetAdvanceCategoryByPk()
AccountsChartAdvanceCategoryVO | getAccountChartBalanceSheetAdvanceCategoryReportByPk(java.lang.String monthYear)
AccountsChartAdvanceCategoryVO | getAccountChartProfitLossAdvanceCategoryByPk()
AccountsChartAdvanceCategoryVO | getAccountChartProfitLossAdvanceCategoryReportByPk(java.lang.String monthYear)
AccountsChartAdvanceCategoryVO | getAccountChartTaxPayableAdvanceCategoryByPk()
AccountsChartAdvanceCategoryVO | getAccountChartTaxPayableAdvanceCategoryReportByPk(java.lang.String monthYear)
int | getAccountingInfoDocument(java.lang.String yearCode, java.lang.String companyUnitId, java.lang.String accountingReportType)
int | getAccountingTransactionTypesCountByType(java.lang.String transactionType)
AccountPayableCheckVO | getAccountPayableCheckByCheckNo(java.lang.String checkNumber)
AccountPayableCheckRunVO | getAccountPayableCheckRunByPk(java.lang.String checkRunNumber)
int | getAccountPayableChecksCountByCheckNumber(java.lang.String checkNumber)
int | getAccountPayableChecksCountByCheckRunNumber(java.lang.String checkRunNumber)
AccountsChartVO | getAccountsChartByPk(java.lang.String accountNumber)
AccountsChartCategoryVO | getAccountsChartCategoryForBalanceSheetByPk(java.lang.Long pk)
AccountsChartCategoryVO | getAccountsChartCategoryForEbitdaByPk(java.lang.Long pk)
AccountsChartCategoryVO | getAccountsChartCategoryForProfitLossByPk(java.lang.Long pk)
AccountsChartCategoryVO | getAccountsChartCategoryForTaxDetailByPk(java.lang.Long pk)
java.util.Collection<AccountsChartCategoryListResult> | getAccountsChartCategoryReport(java.lang.String monthYear)
int | getAccountsChartMappingBySubcompanyIdCount(java.lang.String subcompanyId)
int | getAccountsChartsByIdCount(java.lang.String accountNumber)
int | getAccountsChartsBySubTypeCount(java.lang.String accountNumber, java.lang.String language, java.lang.String companyUnitId, java.lang.String accountSubType)
int | getAccountsChartsByTypeCount(java.lang.String accountNumber, java.lang.String language, java.lang.String accountType)
int | getAccountsChartsByTypeCount(java.lang.String accountNumber, java.lang.String language, java.lang.String accountType, java.lang.String categoryReportType)
int | getAccountsChartsCountByCompanyUnit(java.lang.String accountNumber, java.lang.String language, java.lang.String accountType, java.lang.String companyUnitId)
int | getAddressAccountInfoCount(java.lang.String id, java.util.Date from, java.util.Date to, boolean includeUnpost)
int | getAgingAPItemsCount(java.lang.String[] includeCustomerId, java.lang.String[] excludeCustomerId, boolean useAsOf, java.util.Date asOf)
int | getAgingApsCount(java.lang.String[] includeVendorId, java.lang.String[] excludeVendorId, boolean useAsOf, java.util.Date asOf)
int | getAgingARItemsCount(java.lang.String[] includeCustomerId, java.lang.String[] excludeCustomerId, boolean useAsOf, java.util.Date asOf)
int | getAgingARsCount(java.lang.String[] includeCustomerId, java.lang.String[] excludeCustomerId, boolean useAsOf, java.util.Date asOf)
int | getAllAccountingTransactionTypesCount()
int | getAllAccountPayableCheckRunsCount()
int | getAllAccountPayableChecksCount()
int | getAllAccountReceivablePaymentsCount()
java.util.Collection<MonthBalanceResult> | getAllAccountsChartBalanceByMonth(java.lang.String monthYear)
int | getAllAccountsChartCategoryForBalanceSheetCountByCategoryName(java.lang.String categoryName)
int | getAllAccountsChartCategoryForBalanceSheetPredefineCountByCategoryName(java.lang.String categoryName)
int | getAllAccountsChartCategoryForProfitLossCountByCategoryName(java.lang.String categoryName)
int | getAllAccountsChartCategoryForProfitLossPredefineCountByCategoryName(java.lang.String categoryName)
int | getAllAccountsChartCategoryForTaxDetailCountByCategoryName(java.lang.String categoryName)
int | getAllAccountsChartCategoryForTaxDetailPredefineCountByCategoryName(java.lang.String categoryName)
int | getAllAccountsChartsCount(boolean showInactive)
int | getAllAccountsReceivablesCount()
int | getAllAPCount()
int | getAllArBPCount()
int | getAllARInvoicesCount()
int | getAllARPaymentRunsCount()
int | getAllARWithoutTrackingCount()
int | getAllAssetsCount()
int | getAllAssetsDepreciationMonthsCount(java.lang.String assetNumber)
int | getAllAssetTypesCount()
int | getAllBankOrCashGLByDateCount(java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String fMonthYear, java.lang.String tMonthYear, boolean includeUnpostGL)
int | getAllExpenseAccountCount()
int | getAllExpensesCount()
java.util.Collection<AmountsStatementResult> | getAllFirstLevelAccountBalanceByMonth(java.lang.String monthYear)
java.util.Collection<AccountsChartVO> | getAllFirstLevelAccountCharts()
int | getAllFiscalYearSettingsCount()
int | getAllGeneralLedgerApprovalCount()
int | getAllGeneralLedgersCount(java.lang.String glCategory, java.lang.String sequenceFrom, java.lang.String sequenceTo, java.lang.String id, java.lang.String accounts, java.util.Date fromDate, java.util.Date toDate)
int | getAllGLAutoApproves()
int | getAllGlCategories()
int | getAllGlMonthCount()
java.util.Collection<ProfitAndLossAccountsResult> | getAllProfitAndLossAccounts()
int | getAPAccountInfoCount(java.lang.String apNumber)
int | getAPAgingTotalResultCount(java.lang.String[] includeIds, java.lang.String[] excludeIds, boolean useAsOf, java.util.Date asOf)
java.util.Collection<APAuditListResult> | getAPAuditListResults(java.util.ArrayList<java.lang.String> list, java.lang.String currency)
int | getApByDateCount(java.lang.String partNumberLike, java.lang.String partType, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String vendorId, java.lang.String vendorInvoice, java.lang.String status, java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String productCode)
int | getApByDateCount(java.lang.String apNumber, java.lang.String partNumberLike, java.lang.String partType, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String vendorId, java.lang.String vendorInvoice, java.lang.String status, java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate)
int | getApCheckRunCountByDate(java.util.Date fromDate, java.util.Date toDate, java.lang.String checkNumber, java.lang.String vendorId, java.lang.String debitAccount, java.lang.String creditAccount, java.lang.String dateColumn)
int | getAPCheckRunsCountByCheckRunNumberLike(java.lang.String checkRunNumberLike)
int | getAPCount(java.lang.String apNumber, java.lang.String vendorId, java.lang.String buyer, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, java.util.Date from, java.util.Date to)
int | getAPCountByAddressIdSet(java.lang.String[] includeVendorId, java.lang.String[] excludeVendorId, boolean useAsOf, java.util.Date asOf)
int | getAPCountByAddressIdSet(java.lang.String[] includeVendorId, java.lang.String[] excludeVendorId, java.lang.String companyUnitId, java.lang.String currency, java.util.Date fromDate, java.util.Date toDate)
java.util.Collection<DuePATotalByVendorResult> | getAPDueTotal(java.lang.String vendorId)
int | getAPItemsCountByApNumber(java.lang.String apNumber)
java.util.Collection<java.lang.String> | getAPNumbers(AccountAuditAgent agent)
java.util.Collection<DuePATotalByVendorResult> | getAPOpenByVendorIdTotal(java.lang.String vendorId)
ApPrepayVO | getApPrepayByPK(java.lang.String prepayNumber)
int | getApPrepayCount(java.lang.String appNumber, java.lang.String vendorId, java.lang.String status, java.util.Date from, java.util.Date to)
int | getAPsByAddressIdAndStatus(java.lang.String addressId, java.lang.String status)
int | getAPsByVendorIdCount(java.lang.String vendorId)
int | getAPsCountByApNumber(java.lang.String apNumber)
int | getAPsCountByVendorInvoice(java.lang.String vendorInvoice)
java.util.Collection<TotalByDateResult> | getAPTotal(java.lang.String apNumber, java.lang.String vendorId, java.lang.String buyer, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, java.util.Date from, java.util.Date to)
int | getARAccountInfoCount(java.lang.String arNumber)
java.util.Collection<ARAuditListResult> | getARAuditListResults(java.util.ArrayList<java.lang.String> list, java.lang.String currency)
ARBoilerplateVO | getArBPByPk(java.lang.String arBoilerplateId)
int | getArBPCountByBPId(java.lang.String bpId)
int | getArCommissionCountByDate(java.lang.String dateType, java.lang.String status, java.lang.String salesCodeId, java.util.Date fromDate, java.util.Date toDate)
java.util.Collection<ArCommissionTotalResult> | getArCommissionTotalAmountByDate(java.lang.String dateType, java.lang.String status, java.lang.String salesCodeId, java.util.Date fromDate, java.util.Date toDate)
int | getARCountByAddressIdSet(java.lang.String[] includeCustomerId, java.lang.String[] excludeCustomerId, boolean useAsOf, java.util.Date asOf)
int | getARCountByAddressIdSet(java.lang.String[] includeCustomerId, java.lang.String[] excludeCustomerId, java.lang.String companyUnitId, java.lang.String currency, java.util.Date fromDate, java.util.Date toDate)
int | getARItemCountByPartAndDate(java.util.Date fromDate, java.util.Date toDate, BB2Part part)
int | getARItemsCountByInvoiceNumber(java.lang.String invoiceNumber)
int | getARItemsCountByPartNumber(java.lang.String partNumber)
java.util.Collection<java.lang.String> | getARNumbers(AccountAuditAgent agent)
java.util.Collection<ARPaymentRunListResult> | getArPaymentByDateTotal(java.util.Date fromDate, java.util.Date toDate, java.lang.String paymentNumber, java.lang.String customerId, java.lang.String debitAccount, java.lang.String creditAccount)
AccountReceivablePaymentVO | getARPaymentByPk(java.lang.Long ii)
int | getArPaymentCountByDate(java.util.Date fromDate, java.util.Date toDate, java.lang.String paymentNumber, java.lang.String customerId, java.lang.String debitAccount, java.lang.String creditAccount)
ARPaymentRunVO | getARPaymentRunByPk(java.lang.String paymentRunNumber)
int | getARPaymentRunsCountByPaymentNumberLike(java.lang.String paymentRunNumberLike)
int | getARPaymentsCountByPaymentNumberLike(java.lang.String paymentNumberLike)
int | getARPaymentsCountByPaymentRunNumber(java.lang.String paymentRunNumber)
ArPrepayVO | getArPrepayByPK(java.lang.String prepayNumber)
int | getArPrepayCount(java.lang.String arpNumber, java.lang.String customerId, java.lang.String status, java.util.Date from, java.util.Date to)
int | getArSalesCodeTotalCountByDate(java.lang.String dateType, java.lang.String status, java.lang.String salesCodeId, java.util.Date fromDate, java.util.Date toDate)
int | getARsByCustomerIdCount(java.lang.String customerId)
int | getARsCountByDate(java.lang.String customerId, boolean customerLike, boolean includeCM, java.util.Date dateFrom, java.util.Date dateTo, java.lang.String status)
int | getARsCountByInvoiceNumber(java.lang.String invoiceNumber, java.lang.String status)
int | getAssetAdditionsCount(java.lang.String assetNumber, java.lang.String assetType, java.lang.String departmentID, java.lang.String location, java.util.Date fDate, java.util.Date tDate)
AssetReportSumResult | getAssetAdditionsSum(java.lang.String assetNumber, java.lang.String assetType, java.lang.String departmentID, java.lang.String location, java.util.Date fDate, java.util.Date tDate)
int | getAssetDepreciatesCount(java.lang.String assetNumber, java.lang.String monthYear, java.lang.String departmentID, java.lang.String location, java.lang.String usingStatus, java.lang.String assetType, java.lang.String amortizationExpenseAccount, java.lang.String transactionNumber)
AssetReportSumResult | getAssetDepreciatesSum(java.lang.String assetNumber, java.lang.String monthYear, java.lang.String departmentID, java.lang.String location, java.lang.String usingStatus, java.lang.String assetType, java.lang.String amortizationExpenseAccount, java.lang.String transactionNumber)
int | getAssetDisposalsCount(java.lang.String assetNumber, java.lang.String assetType, java.lang.String departmentID, java.lang.String location, java.util.Date fDate, java.util.Date tDate)
AssetReportSumResult | getAssetDisposalsSum(java.lang.String assetNumber, java.lang.String assetType, java.lang.String departmentID, java.lang.String location, java.util.Date fDate, java.util.Date tDate)
int | getAssetsCount(java.lang.String assetNumber, java.lang.String assetType, java.lang.String depreciationType, java.lang.String depreciationStatus, java.lang.String location, java.lang.String departmentID, java.lang.String amortizationExpenseAccount, java.lang.String usingStatus, java.lang.String status)
int | getAssetsCountByAssetNumber(java.lang.String assetNumber)
AssetTypeVO | getAssetType(java.lang.String id)
java.util.Collection<AssetUsageVO> | getAssetUsageById(java.lang.String assetNumber)
AssetUsageVO | getAssetUsagebyPk(AssetUsagePK pk)
int | getBankReconciliationReportCount(java.lang.String month, java.lang.String accountNumber, java.lang.String companyUnitID)
ChangeStdCostWorkSheetVO | getChangeStdCostWorkSheet(java.lang.Long ii)
int | getChangeStdCostWorkSheetCount()
int | getChangeStdCostWorkSheetItemCount(java.lang.Long ii)
CheckRunItemTotalResult | getCheckRunItemTotal(java.lang.String checkRunNumber)
int | getCMByDateCount(java.lang.String[] cmNumbers)
int | getCMByDateCount(java.lang.String invoiceId, java.lang.String customerId, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isInvoiceDate, java.util.Date fromDate, java.util.Date toDate)
AccountsReceivableVO | getCMByPk(java.lang.String pk)
int | getCMItemByDateCount(java.lang.String partNumberLike, java.lang.String partType, java.lang.String customerId, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isInvoiceDate, java.util.Date fromDate, java.util.Date toDate)
int | getCMsByCustomerIdCount(java.lang.String customerId)
int | getCMsCountByCMNumber(java.lang.String invoiceNumber)
int | getCreditListCountByApNumber(java.lang.String apNumber)
int | getCreditListCountByAppNumber(java.lang.String appNumber)
int | getCreditListCountByArNumber(java.lang.String arNumber)
int | getCurrentAllGlMonthCount()
int | getCurrentBalanceCount(java.lang.String companyUnitId, java.lang.String accountNumber, java.lang.String monthName)
CurrentBalanceResult | getCurrentBalanceResult(java.lang.String companyUnitId, java.lang.String accountNumber, java.lang.String monthName)
FiscalYearSettingsVO | getCurrentFiscalYearSettings()
GlMonthBudgetVO | getCurrentMonthYear()
GeneralLedgerApprovalVO | getCurrentUserApprovalInfo()
int | getCustomerPrepayStatementCountById(java.lang.String customerId, java.lang.String currency)
CustomerStatementResult | getCustomerStatementByDate(java.lang.String customer, java.util.Date startDate, java.util.Date endDate, java.lang.String currency)
CustomerStatementTotalResult | getCustomerStatementTotalResult(java.lang.String customerId)
int | getDate30Due()
int | getDate60Due()
int | getDate90_Due()
int | getDate90Due()
int | getDebitListCountByApNumber(java.lang.String apNumber)
int | getDebitListCountByAppNumber(java.lang.String appNumber)
int | getDebitListCountByArNumber(java.lang.String arNumber)
DebitsCreditsResult | getDebitsCreditsResultForAP(java.lang.String apNumber, java.lang.String language)
DebitsCreditsResult | getDebitsCreditsResultForApp(java.lang.String appNumber)
DebitsCreditsResult | getDebitsCreditsResultForAR(java.lang.String arNumber, java.lang.String language)
DebitsCreditsResult | getDebitsCreditsResultForArp(java.lang.String arpNumber)
DebitsCreditsResult | getDebitsCreditsResultForDM(java.lang.String apNumber, java.lang.String language)
java.math.BigDecimal | getDepreciatedAccm(java.lang.String assetNumber)
int | getDMByDateCount(java.lang.String partNumberLike, java.lang.String partType, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String vendorId, java.lang.String vendorInvoice, java.lang.String status, java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate)
int | getDMByDateCount(java.lang.String apNumber, java.lang.String partNumberLike, java.lang.String partType, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String vendorId, java.lang.String vendorInvoice, java.lang.String status, java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate)
int | getDMCount(java.lang.String apNumber, java.lang.String vendorId, java.lang.String buyer, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, java.util.Date from, java.util.Date to)
java.util.Collection<TotalByDateResult> | getDMTotal(java.lang.String apNumber, java.lang.String vendorId, java.lang.String buyer, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, java.util.Date from, java.util.Date to)
int | getEPByDateCount(java.lang.String partNumberLike, java.lang.String partType, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String vendorId, java.lang.String vendorInvoice, java.lang.String status, java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String productCode, java.lang.String receiverNumber)
int | getEPCount(java.lang.String apNumber, java.lang.String vendorId, java.lang.String buyer, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, java.util.Date from, java.util.Date to)
java.util.Collection<TotalByDateResult> | getEPTotal(java.lang.String apNumber, java.lang.String vendorId, java.lang.String buyer, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, java.util.Date from, java.util.Date to)
ExchangeAuditResult | getExchangeRatePreview(java.lang.String yearCode, java.util.Map map)
ExpenseAccountVO | getExpenseAccountByPk(java.lang.String type)
ExpenseVO | getExpenseByPk(java.lang.String expenseNumber)
int | getExpensesCountByExpenseNumber(java.lang.String expenseNumberLike)
java.lang.String | getFirstMonthYearByDate(java.util.Date fDate, java.util.Date toDate)
GlMonthVO | getFirstOpenMonth()
int | getGeneralLedgerApprovalByIdCount(java.lang.String employeeId)
int | getGeneralLedgerApprovalByNameCount(java.lang.String userName)
GeneralLedgerApprovalVO | getGeneralLedgerApprovalByPk(java.lang.String employeeId)
GeneralLedgerVO | getGeneralLedgerByPk(java.lang.String transactionNumber)
int | getGeneralLedgerCountByDate(java.lang.String companyUnitId, java.lang.String accountNumber, java.util.Date fromDate, java.util.Date toDate, java.lang.String clearedStatus, java.lang.String addressId)
int | getGeneralLedgerCountByDate(java.lang.String companyUnitId, java.lang.String accountNumber, java.util.Date fromDate, java.util.Date toDate, java.lang.String accountType, java.lang.String[] include, java.lang.String[] exclude, java.lang.String checkNumber)
GeneralLedgerResult | getGeneralLedgerResult(java.lang.String transactionNumber)
GLByDateTotalResult | getGeneralLedgerTotalByDate(java.lang.String companyUnitId, java.lang.String accountNumber, java.util.Date fromDate, java.util.Date toDate, java.lang.String clearedStatus, java.lang.String addressId)
GLByDateTotalResult | getGeneralLedgerTotalByDate(java.lang.String companyUnitId, java.lang.String accountNumber, java.util.Date fromDate, java.util.Date toDate, java.lang.String accountType, java.lang.String[] include, java.lang.String[] exclude, java.lang.String checkNumber)
GLAutoApproveVO | getGLAutoApproveByGlType(java.lang.String glType)
GLAutoApproveVO | getGLAutoApproveById(java.lang.Long id)
GeneralLedgerCategoryVO | getGLCategoryById(java.lang.String id)
int | getGLCountByConditions(java.lang.String addressId, java.lang.String apNumber, java.lang.String arNumber, java.lang.String soOrWONumber, java.lang.String shipperNumber, java.lang.String receiverNumber, java.lang.String ourPOorWONumber, java.util.Date fromDate, java.util.Date toDate, java.math.BigDecimal amount)
int | getGLCountById(java.lang.String addressId)
java.util.Map<java.lang.String,java.math.BigDecimal> | getGLCreditDebitByConditionsTotal(java.lang.String addressId, java.lang.String apNumber, java.lang.String arNumber, java.lang.String soOrWONumber, java.lang.String shipperNumber, java.lang.String receiverNumber, java.lang.String ourPOorWONumber, java.util.Date fromDate, java.util.Date toDate)
int | getGLCreditDebitCountByConditions(java.lang.String addressId, java.lang.String apNumber, java.lang.String arNumber, java.lang.String soOrWONumber, java.lang.String shipperNumber, java.lang.String receiverNumber, java.lang.String ourPOorWONumber, java.util.Date fromDate, java.util.Date toDate)
int | getGlMonthByFyNumberCount(java.lang.String fyNumber)
GeneralLedgerPrintResult | getGLPrintByGlCategory(java.lang.String glCategory, int categorySequence)
int | getGrossMarginCountByID(java.util.Date fromDate, java.util.Date toDate)
GeneralLedgerSettingsVO | getGS()
int | getInvoiceByDateCount(boolean isAR, java.lang.String arNumber, java.lang.String customerId, boolean isCludeCmNumber, java.util.Date fromDate, java.util.Date toDate)
int | getInvoiceByDateCount(java.lang.String[] arNumbers)
int | getInvoiceByDateCount(java.lang.String pnLike, boolean partNumberlike, java.lang.String pa, java.lang.String pf, java.lang.String productCode, java.lang.String customerId, boolean customerLike, java.lang.String invoiceBy, java.lang.String status, java.lang.String dateType, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isCludeCmNumber, java.util.Date fromDate, java.util.Date toDate, java.math.BigDecimal lessThanMargin, java.math.BigDecimal highThanMargin, boolean billAndHold, java.util.Map moreParameters)
int | getInvoiceItemsByPartPKCount(PartPK partPk)
java.lang.String | getLastMonthYearByDate(java.util.Date fDate, java.util.Date toDate)
int | getMaxSeqByCategoryId(java.lang.String categoryId, java.util.Date transactionDate)
int | getMonthARByCustomerCount(java.util.Date fromMonth, java.util.Date toMonth, java.lang.String ARStatus, java.lang.String customerId, boolean includeCM)
java.util.Map<java.lang.String,java.math.BigDecimal> | getMonthARByCustomerSum(java.util.Date fromMonth, java.util.Date toMonth, java.lang.String ARStatus, java.lang.String customerId, boolean includeCM)
java.util.Date | getMonthEndDate(java.lang.String yearMonth)
java.util.Date | getMonthFirstDate(java.lang.String yearMonth)
GlMonthBudgetVO | getMonthYearAfter12Month()
java.util.Collection<GLApprovalListResult> | getNeedtoApproveGL(java.lang.String monthYear, java.lang.String original)
java.util.Collection<GLApprovalListResult> | getNeedtoCancelApprovedGL(java.lang.String monthYear, java.lang.String original)
java.util.Collection<GLApprovalListResult> | getNeedtoCancelPostGL(java.lang.String fromMonthYear, java.lang.String toMonthYear, java.lang.String original, java.lang.String approvedBy)
java.util.Collection<GLApprovalListResult> | getNeedtoPostGL(java.lang.String fromMonthYear, java.lang.String toMonthYear, java.lang.String original, java.lang.String approvedBy)
int | getOpenAPsByVendorIdCount(java.lang.String vendorId)
int | getOpenAPsCount()
int | getOpenAPsCountByApNumber(java.lang.String apNumber)
int | getOpenARsByVendorIdCount(java.lang.String vendorId, boolean includeCM)
int | getOpenARsCount()
java.util.Collection<AccountingTotalMoneyResult> | getOpenARsTotalMoneyByVendor(java.lang.String vendorId, boolean includeCM)
int | getOpenGlMonthCount()
int | getOpenInvoiceItemsByPartPKCount(PartPK partPk)
int | getPastDueAPsCount()
int | getPastDueAPsCountByVendorId(java.lang.String vendorId)
int | getPastDueARsCount()
int | getPastDueARsCountByVendor(java.lang.String vendorId, boolean includeCM)
java.util.Collection<AccountingTotalMoneyResult> | getPastDueARsTotalMoney()
java.util.Collection<AccountingTotalMoneyResult> | getPastDueARsTotalMoneyByVendor(java.lang.String vendorId, boolean includeCM)
int | getPaymentHistoryCount()
PaymentRunItemTotalResult | getPaymentRunItemTotal(java.lang.String paymentRunNumber)
java.math.BigDecimal | getPoRecQty(AccountsPayableItemPK pk)
java.math.BigDecimal | getPOTotalByAPPNumber(java.lang.String appNumber)
int | getReceiverWithOutApCount(java.lang.String vendorId, java.lang.String buyer, java.lang.String currency, java.util.Date fromDate, java.util.Date toDate)
int | getReceiverWithoutAPSaveRecordDetailsCount(java.util.Date saveDate)
int | getReceiverWithoutAPSaveRecordsCount()
java.util.Map<CurrencyVO,java.math.BigDecimal> | getReceiverWithOutApTotals(java.lang.String vendorId, java.lang.String buyer, java.lang.String currency, java.util.Date fromDate, java.util.Date toDate)
java.util.Collection<GeneralLedgerListResult> | getRelatedGL(java.lang.String glNumber, java.lang.String apNumber, java.lang.String poNumber, java.lang.String receiverNumber, java.lang.String arNumber, java.lang.String soNumber, java.lang.String shipperNumber)
RollUpBomStdCostWorkSheetVO | getRollUpBomStdCostWorkSheet(java.lang.Long ii)
int | getRollUpBomStdCostWorkSheetCount()
int | getRollUpBomStdCostWorkSheetItemCount(java.lang.Long ii)
int | getRTVShipperWithOutDebitMemoCount(java.lang.String vendorId, java.lang.String currency, java.util.Date fromDate, java.util.Date toDate)
int | getSalesTaxByDateCount(java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String reportType, boolean isCM)
int | getShipperWithOutInvoiceCount(java.lang.String customerId, java.lang.String shippedBy, java.lang.String salesMan, java.lang.String currency, java.util.Date fromDate, java.util.Date toDate)
java.math.BigDecimal | getSOTotalByARPNumber(java.lang.String arpNumber)
java.util.Collection<AccountsChartCategoryListResult> | getTaxOfCategory(java.lang.String monthYear)
int | getTotalDue()
int | getTransactionCountByAPNumber(java.lang.String apNumber)
int | getTransactionCountByAppNumber(java.lang.String appNumber)
int | getTransactionCountByARNumber(java.lang.String arNumber)
int | getTransactionCountByArpNumber(java.lang.String arpNumber)
int | getTransactionCountByDMNumber(java.lang.String apNumber)
int | getTransactionCountByPONumber(java.lang.String poNumber)
int | getTransactionCountBySONumber(java.lang.String soNumber)
java.util.Collection<java.lang.String> | getUsingDepartmentList()
java.lang.String | getYearMonth(java.util.Date date)
java.util.Set<java.lang.String> | getYearMonths(java.util.Date fDate, java.util.Date toDate)
void | importTaxDetailCategoryFromPredefine()
AccountsReceivableItemVO | initAccountsReceivableItemVO(AccountsReceivableVO vo, BB2Part part, java.math.BigDecimal qty)
java.util.Collection<AssetDepreciateVO> | initAssetDepreciate(java.lang.String monthYear, java.lang.String assetNumber, java.lang.String assetType, java.lang.String location, java.lang.String departmentID, java.lang.String amortizationExpenseAccount, java.lang.String usingStatus, boolean showAll, int firstIndex, int maxLength)
int | initAssetDepreciateCount(java.lang.String monthYear, java.lang.String assetNumber, java.lang.String assetType, java.lang.String location, java.lang.String departmentID, java.lang.String amortizationExpenseAccount, java.lang.String usingStatus, boolean isShow)
boolean | isAccountNumberHasChild(java.lang.String accountNumber, java.lang.String companyUnitId)
boolean | isAccountsExist(java.lang.String accountNumber)
boolean | isAPExist(java.lang.String apNumber)
boolean | isArBoilerplateExist(java.lang.String arBoilerplateId)
boolean | isARInMyPrintList(java.lang.String arNumber)
boolean | isBalanceSheetDocumentExist(java.lang.String yearCode, java.lang.String accountingReportType)
boolean | isBankReconciliationReportExistent(AccountMonthPK pk)
boolean | isCategoryUsedInAccountsChart(java.lang.Long categoryId)
boolean | isChangeStdCostWorkSheetItemExistent(ChangeStdCostWorkSheetItemPK pk)
boolean | isClosingStatementDocumentExist(java.lang.String yearCode, java.lang.String companyUnitId)
boolean | isCurrentFYUseAccountingPeriod()
boolean | isCurrentUserHasApproveGLPermission()
boolean | isFiscalYearSettingsExist(java.lang.String fyNumber)
boolean | isFiscalYearUsed(java.lang.String fyNumber)
boolean | isForeignCurrencyAcc(java.lang.String accountNumber)
boolean | isGLApprovedExsitByUserName(java.lang.String userName)
boolean | isGLAutoApproveExist(java.lang.String glType)
boolean | isGLCategoryExist(java.lang.String id)
boolean | isGLCategoryUsed(java.lang.String id)
boolean | isGlMonthExist(java.lang.String monthYear)
boolean | isInvoiceExist(java.lang.String invoiceNumber)
boolean | isLastMonthYear()
boolean | isProfitLossDocumentExist(java.lang.String companyUnitId, java.util.Date currentPeriodFrom, java.util.Date currentPeriodTo, java.util.Date priorPeriodFrom, java.util.Date priorPeriodTo)
boolean | isTransactionExist(java.lang.String transactionNumber)
boolean | isTransactionTypeExist(java.lang.String transactionType)
java.lang.String | makeBillAndHoldInvoiceWithSOItems(MakeInvoiceAgent agent)
java.lang.String | makeCreditMemoWithRMAReceiver(MakeCreditMemoAgent agent)
java.lang.String | makeDebitMemoWithRtvShipper(MakeDebitMemoAgent agent)
java.lang.String | makeDepositGL(java.util.List<DepositSummaryResult> list, java.util.ArrayList<PaymentAgent> agentList)
ExchangeAuditResult | makeExchangeRateAudit(ExchangeAuditResult result)
java.lang.String | makeNonproductivePickingGl(java.lang.String creditAccountNumber, java.lang.String monthYear, java.util.ArrayList<NonproductivePickingItemIssuedListResult> list, java.lang.String glCategory)
java.lang.String | makePurchaseOrderPrepayNumber(PrepayAgent agent)
java.lang.String | makeSalesOrderPrepayNumber(PrepayAgent agent)
java.lang.String | makeUnbilledWithShipperItems(MakeInvoiceAgent agent)
java.lang.String | makeWorkOrderInWipGlByMonth(java.lang.String monthYear)
void | offsetARWithCM(java.util.List<AccountReceivableInfoWithPrepayResult> cmList, java.util.List<AccountReceivableInfoWithPrepayResult> arList, java.lang.Object[] info)
java.lang.String | overCarryingChangeStdCostWorkSheet(java.lang.Long ii)
java.lang.String | overCarryingRollUpBomStdCostWorkSheet(java.lang.Long ii)
GeneralLedgerVO | overCarryProfitAndLoss(java.lang.String monthYear, java.lang.String description, java.util.Date glDate, java.lang.String glCategory)
void | postCheck(PostCheckAgent agent)
void | postGeneralLedger(java.lang.String fromMonthYear, java.lang.String toMonthYear, java.util.List<java.lang.String> glNumbers)
java.lang.String | receivePaymentFromPaymentRunExecuter(java.lang.String paymentRunNumber)
void | refreshChangeStdCostWorkSheetItemStdCostAndOnhand(java.lang.Long ii)
void | rollUpCashFlowBudget(java.lang.String startMonth, java.lang.String endMonth, java.lang.String companyUnitId)
void | rollUpFiscalYearBudget(java.lang.String fiscalYear, java.lang.String companyUnitId)
void | saveReceiverWithOutAP(java.lang.String vendorId, java.lang.String buyer, java.lang.String currency, java.util.Date fromDate, java.util.Date toDate)
java.lang.String | scrapAsset(AssetVO vo, ScrapAssetAgent agent)
java.lang.String | setupAPPrepayWireTransfer(PrepaymentWireTransferAgent agent)
java.lang.String | setupAPWireTransfer(WireTransferAgent agent)
java.lang.String | SetUpARPrepaymentWireTransferExecuter(ARPrepaymentWireTransferAgent agent)
java.lang.String | setupARWireTransfer(WireTransferAgent agent)
java.lang.String | setupCheckRunPayment(ApCheckRunItemAgent agent)
java.lang.String | setupCheckRunPrepayment(ApPrepaymentCheckRunItemAgent agent)
java.lang.String | setupReceivablePayment(ArPaymentRunItemAgent agent)
java.lang.String | setupReceivablePrepayment(ArPrepaymentRunItemAgent agent)
java.lang.String | shipSOOfBillAndHoldInvoice(java.lang.String invoiceNumber)
void | updateAccountChartBalanceSheetAdvanceCategory(AccountsChartAdvanceCategoryVO vo)
void | updateAccountChartProfitLossAdvanceCategory(AccountsChartAdvanceCategoryVO vo)
void | updateAccountChartTaxPayableAdvanceCategory(AccountsChartAdvanceCategoryVO vo)
void | updateAccountPayableCheck(AccountPayableCheckVO vo)
void | updateAccountReceivablePayment(AccountReceivablePaymentVO vo)
java.lang.String | updateAccountsChart(AccountsChartVO vo)
void | updateAccountsChartCategoryForBalanceSheet(AccountsChartCategoryVO vo)
void | updateAccountsChartCategoryForEbitda(AccountsChartCategoryVO vo)
void | updateAccountsChartCategoryForProfitLoss(AccountsChartCategoryVO vo)
void | updateAccountsChartCategoryForTaxDetail(AccountsChartCategoryVO vo)
void | updateAccountsChartMapping(AccountsChartMappingVO vo)
java.lang.String | updateAP(AccountsPayableVO vo)
java.lang.String | updateApCheckRun(AccountPayableCheckRunVO vo)
java.lang.String | updateApPrepay(ApPrepayVO vo)
void | updateAR(AccountsReceivableVO vo)
ARBoilerplateVO | updateArBP(ARBoilerplateVO vo)
java.lang.String | updateArPrepay(ArPrepayVO vo)
java.lang.String | updateAsset(AssetVO vo)
java.lang.String | updateAssetDepreciate(java.util.ArrayList<AssetDepreciateVO> voSet, java.lang.String summary)
void | updateAssetType(AssetTypeVO vo)
void | updateAssetUsage(AssetUsageVO vo)
void | updateCashFlowFromFiscalYearBudget(java.lang.String fiscalYear)
void | updateChangeStdCostWorkSheet(ChangeStdCostWorkSheetVO vo)
void | updateChangeStdCostWorkSheetItem(ChangeStdCostWorkSheetItemVO vo)
AccountsReceivableVO | updateCreditMemo(AccountsReceivableVO vo)
java.lang.String | updateDebitMemo(AccountsPayableVO vo)
java.lang.String | updateEP(AccountsPayableVO vo)
ExpenseVO | updateExpense(ExpenseVO vo)
ExpenseAccountVO | updateExpenseAccount(ExpenseAccountVO vo)
void | updateFiscalYearSettings(FiscalYearSettingsVO vo)
java.lang.String | updateGeneralLedger(GeneralLedgerVO vo)
void | updateGeneralLedgerApproval(GeneralLedgerApprovalVO vo)
GLAutoApproveVO | updateGLAutoApprove(GLAutoApproveVO vo)
void | updateGlCashFlowBudget(java.lang.String companyUnitId, java.util.ArrayList voSet)
GeneralLedgerCategoryVO | updateGLCategory(GeneralLedgerCategoryVO vo)
void | updateGlfiscalYearBudget(java.lang.String companyUnitId, java.util.ArrayList voSet)
java.lang.String | updatePaymentRun(ARPaymentRunVO vo)
RefdocVO | updateRefdocTwo(RefdocVO vo)
void | updateRollUpBomStdCostWorkSheet(RollUpBomStdCostWorkSheetVO vo)
GeneralLedgerSettingsVO | updateTransactionLockDate(java.util.Date date)
void | updateTransactionType(AccountingTransactionTypeVO vo)
java.util.List<AccountingInfoDocumentVO> | uploadOrUpdateAccInfoDocument(MiscDocAgent agent)
void | voidAP(java.lang.String apNumber)
AccountsPayableVO | voidAPPayment(java.lang.String apNumber, java.lang.String glNumber)
AccountsPayableVO | voidAPPaymentWithMultiplePrepay(java.lang.String apNumber, java.lang.String glNumber)
AccountsPayableVO | voidAPPaymentWithPrepay(java.lang.String apNumber, java.lang.String appNumber, java.lang.String glNumber)
void | voidAPPrepay(java.lang.String appNumber)
ApPrepayVO | voidAPPrepayPayment(java.lang.String appNumber, java.lang.String appItemNumber, java.lang.String glNumber)
void | voidAR(java.lang.String arNumber)
AccountsReceivableVO | voidARPayment(java.lang.String arNumber, java.lang.String glNumber)
AccountsReceivableVO | voidARPaymentWithMultiplePrepay(java.lang.String arNumber, java.lang.String glNumber)
AccountsReceivableVO | voidARPaymentWithPrepay(java.lang.String arNumber, java.lang.String arpNumber, java.lang.String glNumber)
void | voidARPrepay(java.lang.String arpNumber)
ArPrepayVO | voidARPrepayPayment(java.lang.String arpNumber, java.lang.String glNumber)
java.lang.String | voidGlTransaction(java.lang.String transactionNumber)
java.lang.String | writeOffEstimatedPayable(java.lang.String apNumber, MakeAccountPayableAgent agent)

Method Detail

makeSalesOrderPrepayNumber

java.lang.String makeSalesOrderPrepayNumber(PrepayAgent agent)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

getArPrepayByPK

ArPrepayVO getArPrepayByPK(java.lang.String prepayNumber)
                           throws java.lang.Exception
Throws:
java.lang.Exception

getSOTotalByARPNumber

java.math.BigDecimal getSOTotalByARPNumber(java.lang.String arpNumber)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

updateArPrepay

java.lang.String updateArPrepay(ArPrepayVO vo)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findArPrepay

java.util.Collection<ArPrepayVO> findArPrepay(java.lang.String arpNumber,
                                              java.lang.String customerId,
                                              java.lang.String status,
                                              java.util.Date from,
                                              java.util.Date to,
                                              int firstIndex,
                                              int maxLength)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

getArPrepayCount

int getArPrepayCount(java.lang.String arpNumber,
                     java.lang.String customerId,
                     java.lang.String status,
                     java.util.Date from,
                     java.util.Date to)
                     throws java.lang.Exception
Throws:
java.lang.Exception

findArPrepayTotal

java.util.Collection<ArPrepayVO> findArPrepayTotal(java.lang.String arpNumber,
                                                   java.lang.String customerId,
                                                   java.lang.String status,
                                                   java.util.Date from,
                                                   java.util.Date to,
                                                   int firstIndex,
                                                   int maxLength)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

findARPrepayToBatchReceivebyAddressIdSet

java.util.Collection<ARPrepayInfoResult> findARPrepayToBatchReceivebyAddressIdSet(java.lang.String[] includeCustomerId,
                                                                                java.lang.String[] excludeCustomerId,
                                                                                java.lang.String companyUnitId,
                                                                                java.util.Date fromDate,
                                                                                java.util.Date toDate)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

setupReceivablePrepayment

java.lang.String setupReceivablePrepayment(ArPrepaymentRunItemAgent agent)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

SetUpARPrepaymentWireTransferExecuter

java.lang.String SetUpARPrepaymentWireTransferExecuter(ARPrepaymentWireTransferAgent agent)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

addARWithoutShipper

java.lang.String addARWithoutShipper(AccountsReceivableVO vo)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

addARWithShipper

java.lang.String addARWithShipper(MakeInvoiceAgent agent)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

addARWithShipperItems

java.lang.String addARWithShipperItems(MakeInvoiceAgent agent)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

makeUnbilledWithShipperItems

java.lang.String makeUnbilledWithShipperItems(MakeInvoiceAgent agent)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

addArPayment

void addArPayment(PaymentAgent arPaymentAgent)
                  throws java.lang.Exception
Throws:
java.lang.Exception

addARPaymentWithPrepay

void addARPaymentWithPrepay(PaymentAgent arPaymentAgent)
                            throws java.lang.Exception
Throws:
java.lang.Exception

addARPaymentWithMultiplePrepay

void addARPaymentWithMultiplePrepay(PaymentAgent arPaymentAgent)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

deleteAR

void deleteAR(AccountsReceivableVO vo)
              throws java.lang.Exception
Throws:
java.lang.Exception

updateAR

void updateAR(AccountsReceivableVO vo)
              throws java.lang.Exception
Throws:
java.lang.Exception

isInvoiceExist

boolean isInvoiceExist(java.lang.String invoiceNumber)
                       throws java.lang.Exception
Throws:
java.lang.Exception

postCheck

void postCheck(PostCheckAgent agent)
               throws java.lang.Exception
Throws:
java.lang.Exception

getAllAccountsReceivablesCount

int getAllAccountsReceivablesCount()
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findARByPk

AccountsReceivableVO findARByPk(java.lang.String pk)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findOpenARs

java.util.Collection<AccountsReceivableInfoVO> findOpenARs(int firstIndex,
                                                           int maxLength)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

findARs

java.util.Collection<AccountsReceivableVO> findARs(java.lang.String customerId,
                                                   java.util.Date fromDate,
                                                   java.util.Date toDate)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getOpenARsCount

int getOpenARsCount()
                    throws java.lang.Exception
Throws:
java.lang.Exception

findCurrentFiscalYearARByMonth

java.util.Map<java.lang.String,java.math.BigDecimal> findCurrentFiscalYearARByMonth()
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findCurrentFiscalYearARGrossMarginByMonth

java.util.Map<java.lang.String,java.math.BigDecimal> findCurrentFiscalYearARGrossMarginByMonth()
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findAllARInvoicces

java.util.Collection<AccountsReceivableInfoVO> findAllARInvoicces(int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getAllARInvoicesCount

int getAllARInvoicesCount()
                          throws java.lang.Exception
Throws:
java.lang.Exception

findARsByCustomerId

java.util.Collection<AccountsReceivableInfoVO> findARsByCustomerId(java.lang.String customerId,
                                                                   int firstIndex,
                                                                   int maxLength)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getARsByCustomerIdCount

int getARsByCustomerIdCount(java.lang.String customerId)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findMonthARByCustomer

java.util.Collection<MonthSoOrArByCustomerResult> findMonthARByCustomer(java.util.Date fromMonth,
                                                                        java.util.Date toMonth,
                                                                        java.lang.String ARStatus,
                                                                        java.lang.String customerId,
                                                                        boolean includeCM,
                                                                        int firstIndex,
                                                                        int maxLength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getMonthARByCustomerCount

int getMonthARByCustomerCount(java.util.Date fromMonth,
                              java.util.Date toMonth,
                              java.lang.String ARStatus,
                              java.lang.String customerId,
                              boolean includeCM)
                              throws java.lang.Exception
Throws:
java.lang.Exception

getMonthARByCustomerSum

java.util.Map<java.lang.String,java.math.BigDecimal> getMonthARByCustomerSum(java.util.Date fromMonth,
                                                                             java.util.Date toMonth,
                                                                             java.lang.String ARStatus,
                                                                             java.lang.String customerId,
                                                                             boolean includeCM)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

findARsTotalMoneyByCustomerId

java.util.Collection<AccountingTotalMoneyResult> findARsTotalMoneyByCustomerId(java.lang.String customerId)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getPastDueARsTotalMoney

java.util.Collection<AccountingTotalMoneyResult> getPastDueARsTotalMoney()
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

findPastDueARs

java.util.Collection<AccountsReceivableInfoVO> findPastDueARs(int firstIndex,
                                                              int maxLength)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getPastDueARsCount

int getPastDueARsCount()
                       throws java.lang.Exception
Throws:
java.lang.Exception

findARsByInvoiceNumber

java.util.Collection<AccountsReceivableInfoVO> findARsByInvoiceNumber(java.lang.String invoiceNumber,
                                                                      java.lang.String status,
                                                                      int firstIndex,
                                                                      int maxLength)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getARsCountByInvoiceNumber

int getARsCountByInvoiceNumber(java.lang.String invoiceNumber,
                               java.lang.String status)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findAllARWithoutTracking

java.util.Collection<AccountsReceivableInfoVO> findAllARWithoutTracking(int firstIndex,
                                                                        int maxLength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getAllARWithoutTrackingCount

int getAllARWithoutTrackingCount()
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findAccountAgingTotalResult

java.util.Collection<AccountAgingTotalResult> findAccountAgingTotalResult(java.lang.String[] includeIds,
                                                                          java.lang.String[] excludeIds,
                                                                          boolean useAsOf,
                                                                          java.util.Date asOf)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getAccountAgingTotalResultCount

int getAccountAgingTotalResultCount(java.lang.String[] includeIds,
                                    java.lang.String[] excludeIds,
                                    boolean useAsOf,
                                    java.util.Date asOf)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findShipperWithOutInvoice

java.util.Collection<ShipperInfoVO> findShipperWithOutInvoice(java.lang.String customerId,
                                                              java.lang.String shippedBy,
                                                              java.lang.String salesMan,
                                                              java.lang.String currency,
                                                              java.util.Date fromDate,
                                                              java.util.Date toDate,
                                                              int firstIndex,
                                                              int maxLength)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

findShipperWithItemsWithOutInvoice

java.util.Collection<ShipperVO> findShipperWithItemsWithOutInvoice(java.lang.String customerId,
                                                                   java.lang.String shippedBy,
                                                                   java.lang.String salesMan,
                                                                   java.lang.String currency,
                                                                   java.util.Date fromDate,
                                                                   java.util.Date toDate,
                                                                   java.lang.String salesOrderNumber,
                                                                   int firstIndex,
                                                                   int maxLength)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

findShipperWithItemsWithOutUnbilled

java.util.Collection<ShipperVO> findShipperWithItemsWithOutUnbilled(java.lang.String customerId,
                                                                    java.lang.String shippedBy,
                                                                    java.lang.String salesMan,
                                                                    java.lang.String currency,
                                                                    java.util.Date fromDate,
                                                                    java.util.Date toDate,
                                                                    int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getShipperWithOutInvoiceCount

int getShipperWithOutInvoiceCount(java.lang.String customerId,
                                  java.lang.String shippedBy,
                                  java.lang.String salesMan,
                                  java.lang.String currency,
                                  java.util.Date fromDate,
                                  java.util.Date toDate)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

getInvoiceByDateCount

int getInvoiceByDateCount(java.lang.String pnLike,
                          boolean partNumberlike,
                          java.lang.String pa,
                          java.lang.String pf,
                          java.lang.String productCode,
                          java.lang.String customerId,
                          boolean customerLike,
                          java.lang.String invoiceBy,
                          java.lang.String status,
                          java.lang.String dateType,
                          java.lang.String accountNumber,
                          java.lang.String companyUnitId,
                          boolean isCludeCmNumber,
                          java.util.Date fromDate,
                          java.util.Date toDate,
                          java.math.BigDecimal lessThanMargin,
                          java.math.BigDecimal highThanMargin,
                          boolean billAndHold,
                          java.util.Map moreParameters)
                          throws java.lang.Exception
Throws:
java.lang.Exception

findInvoiceByDate

java.util.Collection<InvoiceItemListResult> findInvoiceByDate(java.lang.String partNumberLike,
                                                              boolean partNumberlike,
                                                              java.lang.String partType,
                                                              java.lang.String pf,
                                                              java.lang.String productCode,
                                                              java.lang.String customerId,
                                                              boolean customerLike,
                                                              java.lang.String invoiceBy,
                                                              java.lang.String status,
                                                              java.lang.String dateType,
                                                              java.lang.String accountNumber,
                                                              java.lang.String companyUnitId,
                                                              boolean isCludeCmNumber,
                                                              java.util.Date fromDate,
                                                              java.util.Date toDate,
                                                              java.math.BigDecimal lessThanMargin,
                                                              java.math.BigDecimal highThanMargin,
                                                              boolean billAndHold,
                                                              java.util.Map moreParameters,
                                                              int firstIndex,
                                                              int maxLength)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

findAgingARItems

java.util.Collection<InvoiceAgingItemListResult> findAgingARItems(java.lang.String[] includeCustomerId,
                                                                  java.lang.String[] excludeCustomerId,
                                                                  boolean useAsOf,
                                                                  java.util.Date asOf,
                                                                  int firstIndex,
                                                                  int length)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getAgingARItemsCount

int getAgingARItemsCount(java.lang.String[] includeCustomerId,
                         java.lang.String[] excludeCustomerId,
                         boolean useAsOf,
                         java.util.Date asOf)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findOpenInvoiceItemsByPartPK

java.util.Collection<InvoiceItemListResult> findOpenInvoiceItemsByPartPK(PartPK partPk,
                                                                         int firstIndex,
                                                                         int maxLength)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getOpenInvoiceItemsByPartPKCount

int getOpenInvoiceItemsByPartPKCount(PartPK partPk)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findInvoiceItemsByPartPK

java.util.Collection<InvoiceItemListResult> findInvoiceItemsByPartPK(PartPK partPk,
                                                                     int firstIndex,
                                                                     int maxLength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getInvoiceItemsByPartPKCount

int getInvoiceItemsByPartPKCount(PartPK partPk)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findARTotalMoneyByDate

java.util.Collection<AccountingTotalMoneyResult> findARTotalMoneyByDate(java.lang.String arNumber,
                                                                        java.lang.String pnLike,
                                                                        boolean partNumberlike,
                                                                        java.lang.String pa,
                                                                        java.lang.String productCode,
                                                                        java.lang.String customerId,
                                                                        boolean customerLike,
                                                                        java.lang.String invoiceBy,
                                                                        java.lang.String status,
                                                                        java.lang.String dateType,
                                                                        java.lang.String accountNumber,
                                                                        java.lang.String companyUnitId,
                                                                        boolean isCludeCmNumber,
                                                                        java.util.Date fromDate,
                                                                        java.util.Date toDate,
                                                                        java.math.BigDecimal lessThanMargin,
                                                                        java.math.BigDecimal highThanMargin,
                                                                        boolean billAndHold,
                                                                        java.util.Map moreParameters)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getSalesTaxByDateCount

int getSalesTaxByDateCount(java.lang.String dateType,
                           java.util.Date fromDate,
                           java.util.Date toDate,
                           java.lang.String reportType,
                           boolean isCM)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findSalesTaxByDate

java.util.Collection<SalesTaxListResult> findSalesTaxByDate(java.lang.String dateType,
                                                            java.util.Date fromDate,
                                                            java.util.Date toDate,
                                                            java.lang.String orderBy,
                                                            java.lang.String reportType,
                                                            boolean isCM,
                                                            int firstIndex,
                                                            int maxLength)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

findSalesTaxTotalMoneyByDate

java.util.Collection<AccountingTotalMoneyResult> findSalesTaxTotalMoneyByDate(java.lang.String dateType,
                                                                              java.util.Date fromDate,
                                                                              java.util.Date toDate,
                                                                              java.lang.String reportType,
                                                                              boolean isCM)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

findGrossMarginByID

java.util.Collection<SalesMarginListResult> findGrossMarginByID(java.util.Date fromDate,
                                                                java.util.Date toDate,
                                                                int firstIndex,
                                                                int maxLength)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getGrossMarginCountByID

int getGrossMarginCountByID(java.util.Date fromDate,
                            java.util.Date toDate)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findGrossMarginTotalByID

java.util.Collection<SalesMarginListResult> findGrossMarginTotalByID(java.util.Date fromDate,
                                                                     java.util.Date toDate)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getInvoiceByDateCount

int getInvoiceByDateCount(boolean isAR,
                          java.lang.String arNumber,
                          java.lang.String customerId,
                          boolean isCludeCmNumber,
                          java.util.Date fromDate,
                          java.util.Date toDate)
                          throws java.lang.Exception
Throws:
java.lang.Exception

findInvoiceByDate

java.util.List findInvoiceByDate(boolean isAR,
                                 java.lang.String arNumber,
                                 java.lang.String customerId,
                                 boolean isCludeCmNumber,
                                 java.util.Date fromDate,
                                 java.util.Date toDate,
                                 int firstIndex,
                                 int maxLength)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findARTotalMoneyByDate

java.util.List findARTotalMoneyByDate(boolean isAR,
                                      java.lang.String arNumber,
                                      java.lang.String customerId,
                                      boolean isCludeCmNumber,
                                      java.util.Date fromDate,
                                      java.util.Date toDate)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findStatementById

java.util.Collection<CustomerStatementListResult> findStatementById(java.lang.String customerId,
                                                                    java.lang.String currency,
                                                                    int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

findStatementById

java.util.Collection<CustomerStatementListResult> findStatementById(java.lang.String customerId,
                                                                    java.lang.String currency,
                                                                    java.util.Date toDate,
                                                                    int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

findStatementById

java.util.Collection<CustomerStatementListResult> findStatementById(java.lang.String customerId,
                                                                    java.lang.String idType,
                                                                    java.lang.String currency,
                                                                    java.util.Date toDate,
                                                                    int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

findCustomerPrepayStatementById

java.util.Collection<CustomerPrepayStatementListResult> findCustomerPrepayStatementById(java.lang.String customerId,
                                                                                java.lang.String currency,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findCustomerPrepayStatementById

java.util.Collection<CustomerPrepayStatementListResult> findCustomerPrepayStatementById(java.lang.String customerId,
                                                                                java.lang.String currency,
                                                                                java.util.Date toDate,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findCustomerPrepayStatementById

java.util.Collection<CustomerPrepayStatementListResult> findCustomerPrepayStatementById(java.lang.String customerId,
                                                                                java.lang.String idType,
                                                                                java.lang.String currency,
                                                                                java.util.Date toDate,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getCustomerPrepayStatementCountById

int getCustomerPrepayStatementCountById(java.lang.String customerId,
                                        java.lang.String currency)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

getCustomerStatementTotalResult

CustomerStatementTotalResult getCustomerStatementTotalResult(java.lang.String customerId)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

findCurrentStatementByCustomerId

java.util.Collection<CustomerStatementListResult> findCurrentStatementByCustomerId(java.lang.String customerId,
                                                                                java.lang.String currency,
                                                                                java.util.Date asOf,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

find1To30StatementByCustomerId

java.util.Collection<CustomerStatementListResult> find1To30StatementByCustomerId(java.lang.String customerId,
                                                                                java.lang.String idType,
                                                                                java.lang.String currency,
                                                                                java.util.Date asOf,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

find31To60StatementByCustomerId

java.util.Collection<CustomerStatementListResult> find31To60StatementByCustomerId(java.lang.String customerId,
                                                                                java.lang.String idType,
                                                                                java.lang.String currency,
                                                                                java.util.Date asOf,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

find61To90StatementByCustomerId

java.util.Collection<CustomerStatementListResult> find61To90StatementByCustomerId(java.lang.String customerId,
                                                                                java.lang.String idType,
                                                                                java.lang.String currency,
                                                                                java.util.Date asOf,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

find90PlusStatementByCustomerId

java.util.Collection<CustomerStatementListResult> find90PlusStatementByCustomerId(java.lang.String customerId,
                                                                                java.lang.String idType,
                                                                                java.lang.String currency,
                                                                                java.util.Date asOf,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

find1To30PrepayStatementByCustomerId

java.util.Collection<CustomerPrepayStatementListResult> find1To30PrepayStatementByCustomerId(java.lang.String customerId,
                                                                                java.lang.String idType,
                                                                                java.lang.String currency,
                                                                                java.util.Date asOf,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

find31To60PrepayStatementByCustomerId

java.util.Collection<CustomerPrepayStatementListResult> find31To60PrepayStatementByCustomerId(java.lang.String customerId,
                                                                                java.lang.String idType,
                                                                                java.lang.String currency,
                                                                                java.util.Date asOf,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

find61To90PrepayStatementByCustomerId

java.util.Collection<CustomerPrepayStatementListResult> find61To90PrepayStatementByCustomerId(java.lang.String customerId,
                                                                                java.lang.String idType,
                                                                                java.lang.String currency,
                                                                                java.util.Date asOf,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

find90PlusPrepayStatementByCustomerId

java.util.Collection<CustomerPrepayStatementListResult> find90PlusPrepayStatementByCustomerId(java.lang.String customerId,
                                                                                java.lang.String idType,
                                                                                java.lang.String currency,
                                                                                java.util.Date asOf,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findAllStatements

java.util.Collection<AllStatementsListResult> findAllStatements()
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getTotalDue

int getTotalDue()
                throws java.lang.Exception
Throws:
java.lang.Exception

getDate30Due

int getDate30Due()
                 throws java.lang.Exception
Throws:
java.lang.Exception

getDate60Due

int getDate60Due()
                 throws java.lang.Exception
Throws:
java.lang.Exception

getDate90Due

int getDate90Due()
                 throws java.lang.Exception
Throws:
java.lang.Exception

getDate90_Due

int getDate90_Due()
                  throws java.lang.Exception
Throws:
java.lang.Exception

findARItemsByInvoiceNumber

java.util.Collection<AccountsReceivableItemVO> findARItemsByInvoiceNumber(java.lang.String invoiceNumber)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getARItemsCountByInvoiceNumber

int getARItemsCountByInvoiceNumber(java.lang.String invoiceNumber)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findARItemsByPartNumber

java.util.Collection<AccountsReceivableItemVO> findARItemsByPartNumber(java.lang.String partNumber)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getARItemsCountByPartNumber

int getARItemsCountByPartNumber(java.lang.String partNumber)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findARItemsByPk

AccountsReceivableItemVO findARItemsByPk(AccountsReceivableItemPK pk)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

initAccountsReceivableItemVO

AccountsReceivableItemVO initAccountsReceivableItemVO(AccountsReceivableVO vo,
                                                      BB2Part part,
                                                      java.math.BigDecimal qty)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

addArBP

ARBoilerplateVO addArBP(ARBoilerplateVO vo)
                        throws java.lang.Exception
Throws:
java.lang.Exception

updateArBP

ARBoilerplateVO updateArBP(ARBoilerplateVO vo)
                           throws java.lang.Exception
Throws:
java.lang.Exception

deleteArBP

void deleteArBP(java.lang.String bpID)
                throws java.lang.Exception
Throws:
java.lang.Exception

getAllArBPCount

int getAllArBPCount()
                    throws java.lang.Exception
Throws:
java.lang.Exception

findAllArBP

java.util.Collection<ARBoilerplateVO> findAllArBP(int firstIndex,
                                                  int maxLength)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getArBPCountByBPId

int getArBPCountByBPId(java.lang.String bpId)
                       throws java.lang.Exception
Throws:
java.lang.Exception

findArBPByBPId

java.util.Collection<ARBoilerplateVO> findArBPByBPId(java.lang.String bpId,
                                                     int firstIndex,
                                                     int maxLength)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getArBPByPk

ARBoilerplateVO getArBPByPk(java.lang.String arBoilerplateId)
                            throws java.lang.Exception
Throws:
java.lang.Exception

isArBoilerplateExist

boolean isArBoilerplateExist(java.lang.String arBoilerplateId)
                             throws java.lang.Exception
Throws:
java.lang.Exception

addAsset

void addAsset(AssetVO vo)
              throws java.lang.Exception
Throws:
java.lang.Exception

addAsset

java.lang.String addAsset(java.lang.String assetNumber,
                          java.lang.String description)
                          throws java.lang.Exception
Throws:
java.lang.Exception

deleteAsset

void deleteAsset(AssetVO vo)
                 throws java.lang.Exception
Throws:
java.lang.Exception

updateAsset

java.lang.String updateAsset(AssetVO vo)
                             throws java.lang.Exception
Throws:
java.lang.Exception

scrapAsset

java.lang.String scrapAsset(AssetVO vo,
                            ScrapAssetAgent agent)
                            throws java.lang.Exception
Throws:
java.lang.Exception

getUsingDepartmentList

java.util.Collection<java.lang.String> getUsingDepartmentList()
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getAllAssetsCount

int getAllAssetsCount()
                      throws java.lang.Exception
Throws:
java.lang.Exception

findAllAssets

java.util.Collection<AssetVO> findAllAssets(int firstIndex,
                                            int maxLength)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

findAssetByPk

AssetVO findAssetByPk(java.lang.String assetNumber)
                      throws java.lang.Exception
Throws:
java.lang.Exception

findAssetsByAssetNumber

java.util.Collection<AssetVO> findAssetsByAssetNumber(java.lang.String assetNumber,
                                                      int firstIndex,
                                                      int maxLength)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getAssetsCountByAssetNumber

int getAssetsCountByAssetNumber(java.lang.String assetNumber)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findAssetsList

java.util.Collection<AssetVO> findAssetsList(java.lang.String assetNumber,
                                             java.lang.String assetType,
                                             java.lang.String depreciationType,
                                             java.lang.String depreciationStatus,
                                             java.lang.String location,
                                             java.lang.String departmentID,
                                             java.lang.String amortizationExpenseAccount,
                                             java.lang.String usingStatus,
                                             java.lang.String status,
                                             int firstIndex,
                                             int maxLength)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

getAssetsCount

int getAssetsCount(java.lang.String assetNumber,
                   java.lang.String assetType,
                   java.lang.String depreciationType,
                   java.lang.String depreciationStatus,
                   java.lang.String location,
                   java.lang.String departmentID,
                   java.lang.String amortizationExpenseAccount,
                   java.lang.String usingStatus,
                   java.lang.String status)
                   throws java.lang.Exception
Throws:
java.lang.Exception

findAssetDepreciates

java.util.Collection<AssetDepreciateVO> findAssetDepreciates(java.lang.String assetNumber,
                                                             java.lang.String monthYear,
                                                             java.lang.String departmentID,
                                                             java.lang.String location,
                                                             java.lang.String usingStatus,
                                                             java.lang.String assetType,
                                                             java.lang.String amortizationExpenseAccount,
                                                             java.lang.String transactionNumber,
                                                             int firstIndex,
                                                             int maxLength)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getAssetDepreciatesCount

int getAssetDepreciatesCount(java.lang.String assetNumber,
                             java.lang.String monthYear,
                             java.lang.String departmentID,
                             java.lang.String location,
                             java.lang.String usingStatus,
                             java.lang.String assetType,
                             java.lang.String amortizationExpenseAccount,
                             java.lang.String transactionNumber)
                             throws java.lang.Exception
Throws:
java.lang.Exception

initAssetDepreciate

java.util.Collection<AssetDepreciateVO> initAssetDepreciate(java.lang.String monthYear,
                                                            java.lang.String assetNumber,
                                                            java.lang.String assetType,
                                                            java.lang.String location,
                                                            java.lang.String departmentID,
                                                            java.lang.String amortizationExpenseAccount,
                                                            java.lang.String usingStatus,
                                                            boolean showAll,
                                                            int firstIndex,
                                                            int maxLength)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

initAssetDepreciateCount

int initAssetDepreciateCount(java.lang.String monthYear,
                             java.lang.String assetNumber,
                             java.lang.String assetType,
                             java.lang.String location,
                             java.lang.String departmentID,
                             java.lang.String amortizationExpenseAccount,
                             java.lang.String usingStatus,
                             boolean isShow)
                             throws java.lang.Exception
Throws:
java.lang.Exception

updateAssetDepreciate

java.lang.String updateAssetDepreciate(java.util.ArrayList<AssetDepreciateVO> voSet,
                                       java.lang.String summary)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findAssetDisposals

java.util.Collection<AssetAddOrDisposalsReport> findAssetDisposals(java.lang.String assetNumber,
                                                                   java.lang.String assetType,
                                                                   java.lang.String departmentID,
                                                                   java.lang.String location,
                                                                   java.util.Date fDate,
                                                                   java.util.Date tDate,
                                                                   int firstIndex,
                                                                   int maxLength)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getAssetDisposalsCount

int getAssetDisposalsCount(java.lang.String assetNumber,
                           java.lang.String assetType,
                           java.lang.String departmentID,
                           java.lang.String location,
                           java.util.Date fDate,
                           java.util.Date tDate)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findAssetAdditions

java.util.Collection<AssetAddOrDisposalsReport> findAssetAdditions(java.lang.String assetNumber,
                                                                   java.lang.String assetType,
                                                                   java.lang.String departmentID,
                                                                   java.lang.String location,
                                                                   java.util.Date fDate,
                                                                   java.util.Date tDate,
                                                                   int firstIndex,
                                                                   int maxLength)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getAssetAdditionsCount

int getAssetAdditionsCount(java.lang.String assetNumber,
                           java.lang.String assetType,
                           java.lang.String departmentID,
                           java.lang.String location,
                           java.util.Date fDate,
                           java.util.Date tDate)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findAssetDepreciateDetails

java.util.Collection<AssetDepreciateDetailReport> findAssetDepreciateDetails(java.lang.String fiscalYear,
                                                                             java.lang.String assetNumber,
                                                                             java.lang.String assetType,
                                                                             java.lang.String departmentID,
                                                                             java.lang.String location,
                                                                             java.lang.String amortizationExpenseAccount,
                                                                             java.lang.String status)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getDepreciatedAccm

java.math.BigDecimal getDepreciatedAccm(java.lang.String assetNumber)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

getAssetDisposalsSum

AssetReportSumResult getAssetDisposalsSum(java.lang.String assetNumber,
                                          java.lang.String assetType,
                                          java.lang.String departmentID,
                                          java.lang.String location,
                                          java.util.Date fDate,
                                          java.util.Date tDate)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

getAssetAdditionsSum

AssetReportSumResult getAssetAdditionsSum(java.lang.String assetNumber,
                                          java.lang.String assetType,
                                          java.lang.String departmentID,
                                          java.lang.String location,
                                          java.util.Date fDate,
                                          java.util.Date tDate)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

getAssetDepreciatesSum

AssetReportSumResult getAssetDepreciatesSum(java.lang.String assetNumber,
                                            java.lang.String monthYear,
                                            java.lang.String departmentID,
                                            java.lang.String location,
                                            java.lang.String usingStatus,
                                            java.lang.String assetType,
                                            java.lang.String amortizationExpenseAccount,
                                            java.lang.String transactionNumber)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

findAllAssetsDepreciationMonths

java.util.Collection<java.lang.String> findAllAssetsDepreciationMonths(java.lang.String assetNumber,
                                                                       int firstIndex,
                                                                       int maxLength)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getAllAssetsDepreciationMonthsCount

int getAllAssetsDepreciationMonthsCount(java.lang.String assetNumber)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

addAssetType

void addAssetType(AssetTypeVO vo)
                  throws java.lang.Exception
Throws:
java.lang.Exception

updateAssetType

void updateAssetType(AssetTypeVO vo)
                     throws java.lang.Exception
Throws:
java.lang.Exception

deleteAssetType

void deleteAssetType(java.lang.String id)
                     throws java.lang.Exception
Throws:
java.lang.Exception

getAssetType

AssetTypeVO getAssetType(java.lang.String id)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findAllAssetTypes

java.util.Collection<AssetTypeVO> findAllAssetTypes(int firstIndex,
                                                    int maxLength)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getAllAssetTypesCount

int getAllAssetTypesCount()
                          throws java.lang.Exception
Throws:
java.lang.Exception

addAssetUsage

java.util.Collection<AssetUsageVO> addAssetUsage(AssetUsageVO vo)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

deleteAssetUsage

void deleteAssetUsage(AssetUsagePK pk)
                      throws java.lang.Exception
Throws:
java.lang.Exception

updateAssetUsage

void updateAssetUsage(AssetUsageVO vo)
                      throws java.lang.Exception
Throws:
java.lang.Exception

getAssetUsagebyPk

AssetUsageVO getAssetUsagebyPk(AssetUsagePK pk)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getAssetUsageById

java.util.Collection<AssetUsageVO> getAssetUsageById(java.lang.String assetNumber)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

findARToBatchReceivebyAddressIdSet

java.util.Collection<AccountReceivableInfoWithPrepayResult> findARToBatchReceivebyAddressIdSet(java.lang.String[] includeCustomerId,
                                                                                java.lang.String[] excludeCustomerId,
                                                                                java.lang.String companyUnitId,
                                                                                java.lang.String currency,
                                                                                java.util.Date fromDate,
                                                                                java.util.Date toDate)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findARToBatchReceivebyAddressId

java.util.Collection<AccountReceivableInfoWithPrepayResult> findARToBatchReceivebyAddressId(java.lang.String customerId,
                                                                                java.lang.String companyUnitId,
                                                                                java.lang.String currency,
                                                                                java.util.Date fromDate,
                                                                                java.util.Date toDate)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getARCountByAddressIdSet

int getARCountByAddressIdSet(java.lang.String[] includeCustomerId,
                             java.lang.String[] excludeCustomerId,
                             java.lang.String companyUnitId,
                             java.lang.String currency,
                             java.util.Date fromDate,
                             java.util.Date toDate)
                             throws java.lang.Exception
Throws:
java.lang.Exception

findARbyAddressIdSet

java.util.Collection<TempArApAgingVO> findARbyAddressIdSet(java.lang.String[] includeCustomerId,
                                                           java.lang.String[] excludeCustomerId,
                                                           boolean useAsOf,
                                                           java.util.Date asOf,
                                                           int firstIndex,
                                                           int maxLength)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getARCountByAddressIdSet

int getARCountByAddressIdSet(java.lang.String[] includeCustomerId,
                             java.lang.String[] excludeCustomerId,
                             boolean useAsOf,
                             java.util.Date asOf)
                             throws java.lang.Exception
Throws:
java.lang.Exception

findCustomerStatementsTotal

java.util.Collection<CustomerStatementTotalResult> findCustomerStatementsTotal(java.lang.String customerId,
                                                                               java.util.Date asOf,
                                                                               java.lang.String currency)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

findCustomerStatementsTotal

java.util.Collection<CustomerStatementTotalResult> findCustomerStatementsTotal(java.lang.String customerId,
                                                                               java.lang.String idType,
                                                                               java.util.Date asOf,
                                                                               java.lang.String currency)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

findCustomerPrepayStatementsTotal

java.util.Collection<CustomerStatementTotalResult> findCustomerPrepayStatementsTotal(java.lang.String customerId,
                                                                                java.util.Date asOf,
                                                                                java.lang.String currency)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findCustomerPrepayStatementsTotal

java.util.Collection<CustomerStatementTotalResult> findCustomerPrepayStatementsTotal(java.lang.String customerId,
                                                                                java.lang.String idType,
                                                                                java.util.Date asOf,
                                                                                java.lang.String currency)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findAgingARs

java.util.Collection<CustomerStatementTotalResult> findAgingARs(java.lang.String[] includeCustomerId,
                                                                java.lang.String[] excludeCustomerId,
                                                                boolean useAsOf,
                                                                java.util.Date asOf,
                                                                int firstIndex,
                                                                int length)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAgingARsCount

int getAgingARsCount(java.lang.String[] includeCustomerId,
                     java.lang.String[] excludeCustomerId,
                     boolean useAsOf,
                     java.util.Date asOf)
                     throws java.lang.Exception
Throws:
java.lang.Exception

makePurchaseOrderPrepayNumber

java.lang.String makePurchaseOrderPrepayNumber(PrepayAgent agent)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

getApPrepayByPK

ApPrepayVO getApPrepayByPK(java.lang.String prepayNumber)
                           throws java.lang.Exception
Throws:
java.lang.Exception

getPOTotalByAPPNumber

java.math.BigDecimal getPOTotalByAPPNumber(java.lang.String appNumber)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

updateApPrepay

java.lang.String updateApPrepay(ApPrepayVO vo)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findApPrepay

java.util.Collection<ApPrepayVO> findApPrepay(java.lang.String appNumber,
                                              java.lang.String vendorId,
                                              java.lang.String status,
                                              java.util.Date from,
                                              java.util.Date to,
                                              int firstIndex,
                                              int maxLength)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

getApPrepayCount

int getApPrepayCount(java.lang.String appNumber,
                     java.lang.String vendorId,
                     java.lang.String status,
                     java.util.Date from,
                     java.util.Date to)
                     throws java.lang.Exception
Throws:
java.lang.Exception

findApPrepayTotal

java.util.Collection<ApPrepayVO> findApPrepayTotal(java.lang.String appNumber,
                                                   java.lang.String vendorId,
                                                   java.lang.String status,
                                                   java.util.Date from,
                                                   java.util.Date to,
                                                   int firstIndex,
                                                   int maxLength)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

findAPPrepayToBatchPaymentbyAddressIdSet

java.util.Collection<APPrepayInfoResult> findAPPrepayToBatchPaymentbyAddressIdSet(java.lang.String[] includeCustomerId,
                                                                                java.lang.String[] excludeCustomerId,
                                                                                java.lang.String companyUnitId,
                                                                                java.util.Date fromDate,
                                                                                java.util.Date toDate)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

setupCheckRunPrepayment

java.lang.String setupCheckRunPrepayment(ApPrepaymentCheckRunItemAgent agent)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

addSinglePrepaymentCheck

AccountPayableCheckVO addSinglePrepaymentCheck(MakePrepaymentCheckAgent agent)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

setupAPPrepayWireTransfer

java.lang.String setupAPPrepayWireTransfer(PrepaymentWireTransferAgent agent)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

addPayableWithoutReceiver

java.lang.String addPayableWithoutReceiver(AddPayableWithoutReceiverAgent agent)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

addPayableWithReceiver

java.lang.String addPayableWithReceiver(MakeAccountPayableAgent agent)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

addPayableWithReceiverItems

java.lang.String addPayableWithReceiverItems(MakeAccountPayableAgent agent)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

addEstimatedPayableWithReceiverItems

java.lang.String addEstimatedPayableWithReceiverItems(MakeAccountPayableAgent agent)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

addArPrepayPayment

java.lang.String addArPrepayPayment(PrepayPaymentAgent agent)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

addApPrepayPayment

java.lang.String addApPrepayPayment(PrepayPaymentAgent agent)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

addAPPayment

void addAPPayment(PaymentAgent apPaymentAgent)
                  throws java.lang.Exception
Throws:
java.lang.Exception

addAPPaymentWithPrepay

void addAPPaymentWithPrepay(PaymentAgent apPaymentAgent)
                            throws java.lang.Exception
Throws:
java.lang.Exception

addAPPaymentWithMultiplePrepay

void addAPPaymentWithMultiplePrepay(PaymentAgent apPaymentAgent)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

deleteAP

void deleteAP(AccountsPayableVO vo)
              throws java.lang.Exception
Throws:
java.lang.Exception

updateAP

java.lang.String updateAP(AccountsPayableVO vo)
                          throws java.lang.Exception
Throws:
java.lang.Exception

findAPByPk

AccountsPayableVO findAPByPk(java.lang.String pk)
                             throws java.lang.Exception
Throws:
java.lang.Exception

findDMByPk

AccountsPayableVO findDMByPk(java.lang.String pk)
                             throws java.lang.Exception
Throws:
java.lang.Exception

findEPByPk

AccountsPayableVO findEPByPk(java.lang.String pk)
                             throws java.lang.Exception
Throws:
java.lang.Exception

findAPs

java.util.Collection<AccountsPayableInfoVO> findAPs(java.lang.String apNumber,
                                                    java.lang.String vendorId,
                                                    java.lang.String buyer,
                                                    java.lang.String status)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

findAllAPs

java.util.Collection<AccountsPayableInfoVO> findAllAPs(int firstIndex,
                                                       int maxLength)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getAllAPCount

int getAllAPCount()
                  throws java.lang.Exception
Throws:
java.lang.Exception

findOpenAPs

java.util.Collection<AccountsPayableInfoVO> findOpenAPs(int firstIndex,
                                                        int maxLength)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getOpenAPsCount

int getOpenAPsCount()
                    throws java.lang.Exception
Throws:
java.lang.Exception

findAPsByVendorId

java.util.Collection<AccountsPayableInfoVO> findAPsByVendorId(java.lang.String vendorId,
                                                              int firstIndex,
                                                              int maxLength)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getAPsByVendorIdCount

int getAPsByVendorIdCount(java.lang.String vendorId)
                          throws java.lang.Exception
Throws:
java.lang.Exception

findAPsTotalMoneyByVendorId

java.util.Collection<AccountingTotalMoneyResult> findAPsTotalMoneyByVendorId(java.lang.String vendorId)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

findPastDueAPs

java.util.Collection<AccountsPayableInfoVO> findPastDueAPs(int firstIndex,
                                                           int maxLength)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getPastDueAPsCount

int getPastDueAPsCount()
                       throws java.lang.Exception
Throws:
java.lang.Exception

findAPsByApNumber

java.util.Collection<AccountsPayableInfoVO> findAPsByApNumber(java.lang.String apNumber,
                                                              int firstIndex,
                                                              int maxLength)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getAPsCountByApNumber

int getAPsCountByApNumber(java.lang.String apNumber)
                          throws java.lang.Exception
Throws:
java.lang.Exception

findOpenAPsByApNumber

java.util.Collection<AccountsPayableInfoVO> findOpenAPsByApNumber(java.lang.String apNumber,
                                                                  int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getOpenAPsCountByApNumber

int getOpenAPsCountByApNumber(java.lang.String apNumber)
                              throws java.lang.Exception
Throws:
java.lang.Exception

findAPsByVendorInvoice

java.util.Collection<AccountsPayableInfoVO> findAPsByVendorInvoice(java.lang.String vendorInvoice,
                                                                   int firstIndex,
                                                                   int maxLength)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getAPsCountByVendorInvoice

int getAPsCountByVendorInvoice(java.lang.String vendorInvoice)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findAP

java.util.Collection<AccountsPayableInfoVO> findAP(java.lang.String apNumber,
                                                   java.lang.String vendorId,
                                                   java.lang.String buyer,
                                                   java.lang.String status,
                                                   java.lang.String accountNumber,
                                                   java.lang.String companyUnitId,
                                                   java.util.Date from,
                                                   java.util.Date to,
                                                   int firstIndex,
                                                   int maxLength)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

findDM

java.util.Collection<AccountsPayableInfoVO> findDM(java.lang.String apNumber,
                                                   java.lang.String vendorId,
                                                   java.lang.String buyer,
                                                   java.lang.String status,
                                                   java.lang.String accountNumber,
                                                   java.lang.String companyUnitId,
                                                   java.util.Date from,
                                                   java.util.Date to,
                                                   int firstIndex,
                                                   int maxLength)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

findEP

java.util.Collection<AccountsPayableInfoVO> findEP(java.lang.String apNumber,
                                                   java.lang.String vendorId,
                                                   java.lang.String buyer,
                                                   java.lang.String status,
                                                   java.lang.String accountNumber,
                                                   java.lang.String companyUnitId,
                                                   java.util.Date from,
                                                   java.util.Date to,
                                                   int firstIndex,
                                                   int maxLength)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getAPCount

int getAPCount(java.lang.String apNumber,
               java.lang.String vendorId,
               java.lang.String buyer,
               java.lang.String status,
               java.lang.String accountNumber,
               java.lang.String companyUnitId,
               java.util.Date from,
               java.util.Date to)
               throws java.lang.Exception
Throws:
java.lang.Exception

getDMCount

int getDMCount(java.lang.String apNumber,
               java.lang.String vendorId,
               java.lang.String buyer,
               java.lang.String status,
               java.lang.String accountNumber,
               java.lang.String companyUnitId,
               java.util.Date from,
               java.util.Date to)
               throws java.lang.Exception
Throws:
java.lang.Exception

getEPCount

int getEPCount(java.lang.String apNumber,
               java.lang.String vendorId,
               java.lang.String buyer,
               java.lang.String status,
               java.lang.String accountNumber,
               java.lang.String companyUnitId,
               java.util.Date from,
               java.util.Date to)
               throws java.lang.Exception
Throws:
java.lang.Exception

getAPTotal

java.util.Collection<TotalByDateResult> getAPTotal(java.lang.String apNumber,
                                                   java.lang.String vendorId,
                                                   java.lang.String buyer,
                                                   java.lang.String status,
                                                   java.lang.String accountNumber,
                                                   java.lang.String companyUnitId,
                                                   java.util.Date from,
                                                   java.util.Date to)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getDMTotal

java.util.Collection<TotalByDateResult> getDMTotal(java.lang.String apNumber,
                                                   java.lang.String vendorId,
                                                   java.lang.String buyer,
                                                   java.lang.String status,
                                                   java.lang.String accountNumber,
                                                   java.lang.String companyUnitId,
                                                   java.util.Date from,
                                                   java.util.Date to)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getEPTotal

java.util.Collection<TotalByDateResult> getEPTotal(java.lang.String apNumber,
                                                   java.lang.String vendorId,
                                                   java.lang.String buyer,
                                                   java.lang.String status,
                                                   java.lang.String accountNumber,
                                                   java.lang.String companyUnitId,
                                                   java.util.Date from,
                                                   java.util.Date to)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

findAPAgingTotalResult

java.util.Collection<AccountAgingTotalResult> findAPAgingTotalResult(java.lang.String[] includeIds,
                                                                     java.lang.String[] excludeIds,
                                                                     boolean useAsOf,
                                                                     java.util.Date asOf)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getAPAgingTotalResultCount

int getAPAgingTotalResultCount(java.lang.String[] includeIds,
                               java.lang.String[] excludeIds,
                               boolean useAsOf,
                               java.util.Date asOf)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findAPbyZipcodeTaxList

java.util.Collection<APTaxForZipcodeListResult> findAPbyZipcodeTaxList(java.lang.String apNumber,
                                                                       java.lang.String vendor,
                                                                       java.lang.String zipcode,
                                                                       java.lang.String status,
                                                                       java.util.Date from,
                                                                       java.util.Date to)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getPoRecQty

java.math.BigDecimal getPoRecQty(AccountsPayableItemPK pk)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findVendorStatementById

java.util.Collection<VendorStatementListResult> findVendorStatementById(java.lang.String vendorId,
                                                                        java.lang.String currency,
                                                                        java.util.Date toDate,
                                                                        int firstIndex,
                                                                        int maxLength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

findVendorStatementById

java.util.Collection<VendorStatementListResult> findVendorStatementById(java.lang.String vendorId,
                                                                        java.lang.String currency,
                                                                        int firstIndex,
                                                                        int maxLength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

findCurrentStatementByVendorId

java.util.Collection<VendorStatementListResult> findCurrentStatementByVendorId(java.lang.String vendorId,
                                                                               java.lang.String currency,
                                                                               int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

find1To30StatementByVendorId

java.util.Collection<VendorStatementListResult> find1To30StatementByVendorId(java.lang.String vendorId,
                                                                             java.lang.String currency,
                                                                             int firstIndex,
                                                                             int maxLength)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

find31To60StatementByVendorId

java.util.Collection<VendorStatementListResult> find31To60StatementByVendorId(java.lang.String vendorId,
                                                                              java.lang.String currency,
                                                                              int firstIndex,
                                                                              int maxLength)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

find61To90StatementByVendorId

java.util.Collection<VendorStatementListResult> find61To90StatementByVendorId(java.lang.String vendorId,
                                                                              java.lang.String currency,
                                                                              int firstIndex,
                                                                              int maxLength)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

find90PlusStatementByVendorId

java.util.Collection<VendorStatementListResult> find90PlusStatementByVendorId(java.lang.String vendorId,
                                                                              java.lang.String currency,
                                                                              int firstIndex,
                                                                              int maxLength)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

findVendorPrepayStatementById

java.util.Collection<VendorPrepayStatementListResult> findVendorPrepayStatementById(java.lang.String vendorId,
                                                                                java.lang.String currency,
                                                                                java.util.Date toDate,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findVendorPrepayStatementById

java.util.Collection<VendorPrepayStatementListResult> findVendorPrepayStatementById(java.lang.String vendorId,
                                                                                java.lang.String currency,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findCurrentPrepayStatementByVendorId

java.util.Collection<VendorPrepayStatementListResult> findCurrentPrepayStatementByVendorId(java.lang.String vendorId,
                                                                                java.lang.String currency,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

find1To30PrepayStatementByVendorId

java.util.Collection<VendorPrepayStatementListResult> find1To30PrepayStatementByVendorId(java.lang.String vendorId,
                                                                                java.lang.String currency,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

find31To60PrepayStatementByVendorId

java.util.Collection<VendorPrepayStatementListResult> find31To60PrepayStatementByVendorId(java.lang.String vendorId,
                                                                                java.lang.String currency,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

find61To90PrepayStatementByVendorId

java.util.Collection<VendorPrepayStatementListResult> find61To90PrepayStatementByVendorId(java.lang.String vendorId,
                                                                                java.lang.String currency,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

find90PlusPrepayStatementByVendorId

java.util.Collection<VendorPrepayStatementListResult> find90PlusPrepayStatementByVendorId(java.lang.String vendorId,
                                                                                java.lang.String currency,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getApByDateCount

int getApByDateCount(java.lang.String partNumberLike,
                     java.lang.String partType,
                     java.lang.String accountNumber,
                     java.lang.String companyUnitId,
                     java.lang.String vendorId,
                     java.lang.String vendorInvoice,
                     java.lang.String status,
                     java.lang.String dateType,
                     java.util.Date fromDate,
                     java.util.Date toDate,
                     java.lang.String productCode)
                     throws java.lang.Exception
Throws:
java.lang.Exception

getDMByDateCount

int getDMByDateCount(java.lang.String partNumberLike,
                     java.lang.String partType,
                     java.lang.String accountNumber,
                     java.lang.String companyUnitId,
                     java.lang.String vendorId,
                     java.lang.String vendorInvoice,
                     java.lang.String status,
                     java.lang.String dateType,
                     java.util.Date fromDate,
                     java.util.Date toDate)
                     throws java.lang.Exception
Throws:
java.lang.Exception

getEPByDateCount

int getEPByDateCount(java.lang.String partNumberLike,
                     java.lang.String partType,
                     java.lang.String accountNumber,
                     java.lang.String companyUnitId,
                     java.lang.String vendorId,
                     java.lang.String vendorInvoice,
                     java.lang.String status,
                     java.lang.String dateType,
                     java.util.Date fromDate,
                     java.util.Date toDate,
                     java.lang.String productCode,
                     java.lang.String receiverNumber)
                     throws java.lang.Exception
Throws:
java.lang.Exception

findApByDate

java.util.Collection<APItemListResult> findApByDate(java.lang.String partNumberLike,
                                                    java.lang.String partType,
                                                    java.lang.String accountNumber,
                                                    java.lang.String companyUnitId,
                                                    java.lang.String vendorId,
                                                    java.lang.String vendorInvoice,
                                                    java.lang.String status,
                                                    java.lang.String Datetype,
                                                    java.util.Date fromDate,
                                                    java.util.Date toDate,
                                                    java.lang.String productCode,
                                                    int firstIndex,
                                                    int maxLength)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

findDMByDate

java.util.Collection<APItemListResult> findDMByDate(java.lang.String partNumberLike,
                                                    java.lang.String partType,
                                                    java.lang.String accountNumber,
                                                    java.lang.String companyUnitId,
                                                    java.lang.String vendorId,
                                                    java.lang.String vendorInvoice,
                                                    java.lang.String status,
                                                    java.lang.String Datetype,
                                                    java.util.Date fromDate,
                                                    java.util.Date toDate,
                                                    int firstIndex,
                                                    int maxLength)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

findEPByDate

java.util.Collection<APItemListResult> findEPByDate(java.lang.String partNumberLike,
                                                    java.lang.String partType,
                                                    java.lang.String accountNumber,
                                                    java.lang.String companyUnitId,
                                                    java.lang.String vendorId,
                                                    java.lang.String vendorInvoice,
                                                    java.lang.String status,
                                                    java.lang.String datetype,
                                                    java.util.Date fromDate,
                                                    java.util.Date toDate,
                                                    java.lang.String productCode,
                                                    java.lang.String receiverNumber,
                                                    int firstIndex,
                                                    int maxLength)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getApByDateCount

int getApByDateCount(java.lang.String apNumber,
                     java.lang.String partNumberLike,
                     java.lang.String partType,
                     java.lang.String accountNumber,
                     java.lang.String companyUnitId,
                     java.lang.String vendorId,
                     java.lang.String vendorInvoice,
                     java.lang.String status,
                     java.lang.String dateType,
                     java.util.Date fromDate,
                     java.util.Date toDate)
                     throws java.lang.Exception
Throws:
java.lang.Exception

getDMByDateCount

int getDMByDateCount(java.lang.String apNumber,
                     java.lang.String partNumberLike,
                     java.lang.String partType,
                     java.lang.String accountNumber,
                     java.lang.String companyUnitId,
                     java.lang.String vendorId,
                     java.lang.String vendorInvoice,
                     java.lang.String status,
                     java.lang.String dateType,
                     java.util.Date fromDate,
                     java.util.Date toDate)
                     throws java.lang.Exception
Throws:
java.lang.Exception

findApByDate

java.util.Collection<APItemListResult> findApByDate(java.lang.String apNumber,
                                                    java.lang.String partNumberLike,
                                                    java.lang.String partType,
                                                    java.lang.String accountNumber,
                                                    java.lang.String companyUnitId,
                                                    java.lang.String vendorId,
                                                    java.lang.String vendorInvoice,
                                                    java.lang.String status,
                                                    java.lang.String Datetype,
                                                    java.util.Date fromDate,
                                                    java.util.Date toDate,
                                                    int firstIndex,
                                                    int maxLength)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

findDMByDate

java.util.Collection<APItemListResult> findDMByDate(java.lang.String apNumber,
                                                    java.lang.String partNumberLike,
                                                    java.lang.String partType,
                                                    java.lang.String accountNumber,
                                                    java.lang.String companyUnitId,
                                                    java.lang.String vendorId,
                                                    java.lang.String vendorInvoice,
                                                    java.lang.String status,
                                                    java.lang.String Datetype,
                                                    java.util.Date fromDate,
                                                    java.util.Date toDate,
                                                    int firstIndex,
                                                    int maxLength)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

findAPTotalMoneyByDate

java.util.Collection<AccountingTotalMoneyResult> findAPTotalMoneyByDate(java.lang.String apNumber,
                                                                        java.lang.String partNumberLike,
                                                                        java.lang.String partType,
                                                                        java.lang.String accountNumber,
                                                                        java.lang.String companyUnitId,
                                                                        java.lang.String vendorId,
                                                                        java.lang.String vendorInvoice,
                                                                        java.lang.String status,
                                                                        java.lang.String dateType,
                                                                        java.util.Date fromDate,
                                                                        java.util.Date toDate,
                                                                        java.lang.String productCode)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

findDMTotalMoneyByDate

java.util.Collection<AccountingTotalMoneyResult> findDMTotalMoneyByDate(java.lang.String apNumber,
                                                                        java.lang.String partNumberLike,
                                                                        java.lang.String partType,
                                                                        java.lang.String accountNumber,
                                                                        java.lang.String companyUnitId,
                                                                        java.lang.String vendorId,
                                                                        java.lang.String vendorInvoice,
                                                                        java.lang.String status,
                                                                        java.lang.String dateType,
                                                                        java.util.Date fromDate,
                                                                        java.util.Date toDate)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

findEPTotalMoneyByDate

java.util.Collection<AccountingTotalMoneyResult> findEPTotalMoneyByDate(java.lang.String apNumber,
                                                                        java.lang.String partNumberLike,
                                                                        java.lang.String partType,
                                                                        java.lang.String accountNumber,
                                                                        java.lang.String companyUnitId,
                                                                        java.lang.String vendorId,
                                                                        java.lang.String vendorInvoice,
                                                                        java.lang.String status,
                                                                        java.lang.String dateType,
                                                                        java.util.Date fromDate,
                                                                        java.util.Date toDate,
                                                                        java.lang.String productCode,
                                                                        java.lang.String receiverNumber)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

findAPsByAddressIdAndStatus

java.util.Collection<AccountsPayableInfoVO> findAPsByAddressIdAndStatus(java.lang.String addressId,
                                                                        java.lang.String status,
                                                                        int firstIndex,
                                                                        int maxLength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getAPsByAddressIdAndStatus

int getAPsByAddressIdAndStatus(java.lang.String addressId,
                               java.lang.String status)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findAPItemsByApNumber

java.util.Collection<AccountsPayableItemVO> findAPItemsByApNumber(java.lang.String apNumber)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getAPItemsCountByApNumber

int getAPItemsCountByApNumber(java.lang.String apNumber)
                              throws java.lang.Exception
Throws:
java.lang.Exception

findAPItemsByPk

AccountsPayableItemVO findAPItemsByPk(AccountsPayableItemPK pk)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

isAPExist

boolean isAPExist(java.lang.String apNumber)
                  throws java.lang.Exception
Throws:
java.lang.Exception

findVendorStatementsTotal

java.util.Collection<CustomerStatementTotalResult> findVendorStatementsTotal(java.lang.String vendorId,
                                                                             java.lang.String currency,
                                                                             java.util.Date toDate)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

findVendorStatementsTotal

java.util.Collection<CustomerStatementTotalResult> findVendorStatementsTotal(java.lang.String vendorId,
                                                                             java.lang.String currency)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

findVendorPrepayStatementsTotal

java.util.Collection<CustomerStatementTotalResult> findVendorPrepayStatementsTotal(java.lang.String vendorId,
                                                                                java.lang.String currency,
                                                                                java.util.Date toDate)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findVendorPrepayStatementsTotal

java.util.Collection<CustomerStatementTotalResult> findVendorPrepayStatementsTotal(java.lang.String vendorId,
                                                                                java.lang.String currency)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findAgingAps

java.util.Collection<CustomerStatementTotalResult> findAgingAps(java.lang.String[] includeVendorId,
                                                                java.lang.String[] excludeVendorId,
                                                                boolean useAsOf,
                                                                java.util.Date asOf,
                                                                int firstIndex,
                                                                int maxLength)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAgingApsCount

int getAgingApsCount(java.lang.String[] includeVendorId,
                     java.lang.String[] excludeVendorId,
                     boolean useAsOf,
                     java.util.Date asOf)
                     throws java.lang.Exception
Throws:
java.lang.Exception

findAgingAPItems

java.util.Collection<APAgingItemListResult> findAgingAPItems(java.lang.String[] includeCustomerId,
                                                             java.lang.String[] excludeCustomerId,
                                                             boolean useAsOf,
                                                             java.util.Date asOf,
                                                             int firstIndex,
                                                             int length)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getAgingAPItemsCount

int getAgingAPItemsCount(java.lang.String[] includeCustomerId,
                         java.lang.String[] excludeCustomerId,
                         boolean useAsOf,
                         java.util.Date asOf)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findReceiverItemsWithOutAP

java.util.Collection<ReceiverVO> findReceiverItemsWithOutAP(java.lang.String vendorId,
                                                            java.lang.String currency,
                                                            java.lang.String buyer,
                                                            java.util.Date fromDate,
                                                            java.util.Date toDate,
                                                            java.lang.String poNumber,
                                                            int firstIndex,
                                                            int maxLength)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

findReceiverWithOutAP

java.util.Collection<ReceiverInfoVO> findReceiverWithOutAP(java.lang.String vendorId,
                                                           java.lang.String buyer,
                                                           java.lang.String currency,
                                                           java.util.Date fromDate,
                                                           java.util.Date toDate,
                                                           int firstIndex,
                                                           int maxLength)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

saveReceiverWithOutAP

void saveReceiverWithOutAP(java.lang.String vendorId,
                           java.lang.String buyer,
                           java.lang.String currency,
                           java.util.Date fromDate,
                           java.util.Date toDate)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findReceiverWithoutAPSaveRecords

java.util.Collection<TempReceiverWithoutAPInfo> findReceiverWithoutAPSaveRecords(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getReceiverWithoutAPSaveRecordsCount

int getReceiverWithoutAPSaveRecordsCount()
                                         throws java.lang.Exception
Throws:
java.lang.Exception

deleteReceiverWithoutAPSaveRecords

void deleteReceiverWithoutAPSaveRecords(java.util.Date d)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findReceiverWithoutAPSaveRecordDetails

java.util.Collection<TempReceiverWithoutAPInfo> findReceiverWithoutAPSaveRecordDetails(java.util.Date saveDate,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getReceiverWithoutAPSaveRecordDetailsCount

int getReceiverWithoutAPSaveRecordDetailsCount(java.util.Date saveDate)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

getReceiverWithOutApCount

int getReceiverWithOutApCount(java.lang.String vendorId,
                              java.lang.String buyer,
                              java.lang.String currency,
                              java.util.Date fromDate,
                              java.util.Date toDate)
                              throws java.lang.Exception
Throws:
java.lang.Exception

getReceiverWithOutApTotals

java.util.Map<CurrencyVO,java.math.BigDecimal> getReceiverWithOutApTotals(java.lang.String vendorId,
                                                                          java.lang.String buyer,
                                                                          java.lang.String currency,
                                                                          java.util.Date fromDate,
                                                                          java.util.Date toDate)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

findRTVShipperWithOutDebitMemo

java.util.Collection<RtvShipperInfoVO> findRTVShipperWithOutDebitMemo(java.lang.String vendorId,
                                                                      java.lang.String currency,
                                                                      java.util.Date fromDate,
                                                                      java.util.Date toDate,
                                                                      int firstIndex,
                                                                      int maxLength)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getRTVShipperWithOutDebitMemoCount

int getRTVShipperWithOutDebitMemoCount(java.lang.String vendorId,
                                       java.lang.String currency,
                                       java.util.Date fromDate,
                                       java.util.Date toDate)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findAPToBatchPaymentbyAddressIdSet

java.util.Collection<AccountPayableInfoWithPrepayResult> findAPToBatchPaymentbyAddressIdSet(java.lang.String[] includeVendorId,
                                                                                java.lang.String[] excludeVendorId,
                                                                                java.lang.String companyUnitId,
                                                                                java.lang.String currency,
                                                                                java.util.Date fromDate,
                                                                                java.util.Date toDate)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAPCountByAddressIdSet

int getAPCountByAddressIdSet(java.lang.String[] includeVendorId,
                             java.lang.String[] excludeVendorId,
                             java.lang.String companyUnitId,
                             java.lang.String currency,
                             java.util.Date fromDate,
                             java.util.Date toDate)
                             throws java.lang.Exception
Throws:
java.lang.Exception

findAPbyAddressIdSet

java.util.Collection<TempArApAgingVO> findAPbyAddressIdSet(java.lang.String[] includeVendorId,
                                                           java.lang.String[] excludeVendorId,
                                                           boolean useAsOf,
                                                           java.util.Date asOf,
                                                           int firstIndex,
                                                           int maxLength)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getAPCountByAddressIdSet

int getAPCountByAddressIdSet(java.lang.String[] includeVendorId,
                             java.lang.String[] excludeVendorId,
                             boolean useAsOf,
                             java.util.Date asOf)
                             throws java.lang.Exception
Throws:
java.lang.Exception

addTransactionType

AccountingTransactionTypeVO addTransactionType(AccountingTransactionTypeVO vo)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

deleteTransactionType

void deleteTransactionType(AccountingTransactionTypeVO vo)
                           throws java.lang.Exception
Throws:
java.lang.Exception

updateTransactionType

void updateTransactionType(AccountingTransactionTypeVO vo)
                           throws java.lang.Exception
Throws:
java.lang.Exception

getAllAccountingTransactionTypesCount

int getAllAccountingTransactionTypesCount()
                                          throws java.lang.Exception
Throws:
java.lang.Exception

findAllAccountingTransactionTypes

java.util.Collection<AccountingTransactionTypeVO> findAllAccountingTransactionTypes(boolean showJType,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findAccountingTransactionTypeByPk

AccountingTransactionTypeVO findAccountingTransactionTypeByPk(java.lang.String transactionType)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

findAccountingTransactionTypesByType

java.util.Collection<AccountingTransactionTypeVO> findAccountingTransactionTypesByType(java.lang.String transactionType,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAccountingTransactionTypesCountByType

int getAccountingTransactionTypesCountByType(java.lang.String transactionType)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

isTransactionTypeExist

boolean isTransactionTypeExist(java.lang.String transactionType)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findAccountingTransactionTypes

java.util.Collection<AccountingTransactionTypeVO> findAccountingTransactionTypes()
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

addAccountsChart

java.lang.String addAccountsChart(AccountsChartVO vo)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

deleteAccountChart

void deleteAccountChart(java.lang.String accountNumber)
                        throws java.lang.Exception
Throws:
java.lang.Exception

updateAccountsChart

java.lang.String updateAccountsChart(AccountsChartVO vo)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

getAccountsChartsByIdCount

int getAccountsChartsByIdCount(java.lang.String accountNumber)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findAccountsChartsById

java.util.Collection<AccountsChartVO> findAccountsChartsById(java.lang.String accountNumber,
                                                             int firstIndex,
                                                             int maxLength)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

isAccountNumberHasChild

boolean isAccountNumberHasChild(java.lang.String accountNumber,
                                java.lang.String companyUnitId)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findAccountsChartsByType

java.util.Collection<AccountsChartVO> findAccountsChartsByType(java.lang.String accountNumber,
                                                               java.lang.String language,
                                                               java.lang.String accountType,
                                                               int firstIndex,
                                                               int maxLength)
                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getAccountsChartsByTypeCount

int getAccountsChartsByTypeCount(java.lang.String accountNumber,
                                 java.lang.String language,
                                 java.lang.String accountType)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findAccountsChartsByType

java.util.Collection<AccountsChartVO> findAccountsChartsByType(java.lang.String accountNumber,
                                                               java.lang.String language,
                                                               java.lang.String accountType,
                                                               java.lang.String categoryReportType,
                                                               int firstIndex,
                                                               int maxLength)
                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getAccountsChartsByTypeCount

int getAccountsChartsByTypeCount(java.lang.String accountNumber,
                                 java.lang.String language,
                                 java.lang.String accountType,
                                 java.lang.String categoryReportType)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findAccountsChartsByCompanyUnit

java.util.Collection<AccountsChartVO> findAccountsChartsByCompanyUnit(java.lang.String accountNumber,
                                                                      java.lang.String language,
                                                                      java.lang.String accountType,
                                                                      java.lang.String companyUnitId,
                                                                      int firstIndex,
                                                                      int maxLength)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getAccountsChartsCountByCompanyUnit

int getAccountsChartsCountByCompanyUnit(java.lang.String accountNumber,
                                        java.lang.String language,
                                        java.lang.String accountType,
                                        java.lang.String companyUnitId)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findAccountsChartsBySubType

java.util.Collection<AccountsChartVO> findAccountsChartsBySubType(java.lang.String accountNumber,
                                                                  java.lang.String language,
                                                                  java.lang.String companyUnitId,
                                                                  java.lang.String accountSubType,
                                                                  int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getAccountsChartsBySubTypeCount

int getAccountsChartsBySubTypeCount(java.lang.String accountNumber,
                                    java.lang.String language,
                                    java.lang.String companyUnitId,
                                    java.lang.String accountSubType)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

getAllAccountsChartsCount

int getAllAccountsChartsCount(boolean showInactive)
                              throws java.lang.Exception
Throws:
java.lang.Exception

findAllAccountsCharts

java.util.Collection<AccountsChartVO> findAllAccountsCharts(boolean showInactive,
                                                            int firstIndex,
                                                            int maxLength)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getAllFirstLevelAccountCharts

java.util.Collection<AccountsChartVO> getAllFirstLevelAccountCharts()
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getAccountsChartByPk

AccountsChartVO getAccountsChartByPk(java.lang.String accountNumber)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

isAccountsExist

boolean isAccountsExist(java.lang.String accountNumber)
                        throws java.lang.Exception
Throws:
java.lang.Exception

findArPaymentAccounts

java.util.Collection<AccountsChartVO> findArPaymentAccounts()
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

isForeignCurrencyAcc

boolean isForeignCurrencyAcc(java.lang.String accountNumber)
                             throws java.lang.Exception
Throws:
java.lang.Exception

addAccountsChartCategoryForBalanceSheet

AccountsChartCategoryVO addAccountsChartCategoryForBalanceSheet(AccountsChartCategoryVO vo)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

batchAddAccountsChartCategorysForBalanceSheet

void batchAddAccountsChartCategorysForBalanceSheet(java.util.List<AccountsChartCategoryVO> voList)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

updateAccountsChartCategoryForBalanceSheet

void updateAccountsChartCategoryForBalanceSheet(AccountsChartCategoryVO vo)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

batchUpdateAccountsChartCategorysForBalanceSheet

void batchUpdateAccountsChartCategorysForBalanceSheet(java.util.List<AccountsChartCategoryVO> list)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

deleteAccountsChartCategoryForBalanceSheet

void deleteAccountsChartCategoryForBalanceSheet(java.lang.Long pk)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAccountsChartCategoryForBalanceSheetByPk

AccountsChartCategoryVO getAccountsChartCategoryForBalanceSheetByPk(java.lang.Long pk)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

findBalanceSheetOfCategory

java.util.Collection<AccountsChartCategoryListResult> findBalanceSheetOfCategory(java.lang.String monthYear)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findAccountsChartCategoryForBalanceSheetByCategoryName

java.util.Collection<AccountsChartCategoryVO> findAccountsChartCategoryForBalanceSheetByCategoryName(java.lang.String categoryName,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllAccountsChartCategoryForBalanceSheetCountByCategoryName

int getAllAccountsChartCategoryForBalanceSheetCountByCategoryName(java.lang.String categoryName)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

findAccountsChartCategoryForBalanceSheetPredefineByCategoryName

java.util.Collection<AccountsChartCategoryVO> findAccountsChartCategoryForBalanceSheetPredefineByCategoryName(java.lang.String categoryName,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllAccountsChartCategoryForBalanceSheetPredefineCountByCategoryName

int getAllAccountsChartCategoryForBalanceSheetPredefineCountByCategoryName(java.lang.String categoryName)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

addAccountsChartCategoryForProfitLoss

AccountsChartCategoryVO addAccountsChartCategoryForProfitLoss(AccountsChartCategoryVO vo)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

batchAddAccountsChartCategorysForProfitLoss

void batchAddAccountsChartCategorysForProfitLoss(java.util.List<AccountsChartCategoryVO> voList)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

updateAccountsChartCategoryForProfitLoss

void updateAccountsChartCategoryForProfitLoss(AccountsChartCategoryVO vo)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

batchUpdateAccountsChartCategorysForProfitLoss

void batchUpdateAccountsChartCategorysForProfitLoss(java.util.List<AccountsChartCategoryVO> list)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

deleteAccountsChartCategoryForProfitLoss

void deleteAccountsChartCategoryForProfitLoss(java.lang.Long pk)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

getAccountsChartCategoryForProfitLossByPk

AccountsChartCategoryVO getAccountsChartCategoryForProfitLossByPk(java.lang.Long pk)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

findProfitLossOfCategory

java.util.Collection<AccountsChartCategoryListResult> findProfitLossOfCategory(java.lang.String monthYear)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

findAccountsChartCategoryForProfitLossByCategoryName

java.util.Collection<AccountsChartCategoryVO> findAccountsChartCategoryForProfitLossByCategoryName(java.lang.String categoryName,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllAccountsChartCategoryForProfitLossCountByCategoryName

int getAllAccountsChartCategoryForProfitLossCountByCategoryName(java.lang.String categoryName)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findAccountsChartCategoryForProfitLossPredefineByCategoryName

java.util.Collection<AccountsChartCategoryVO> findAccountsChartCategoryForProfitLossPredefineByCategoryName(java.lang.String categoryName,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllAccountsChartCategoryForProfitLossPredefineCountByCategoryName

int getAllAccountsChartCategoryForProfitLossPredefineCountByCategoryName(java.lang.String categoryName)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

addAccountsChartCategoryForEbitda

AccountsChartCategoryVO addAccountsChartCategoryForEbitda(AccountsChartCategoryVO vo)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

batchAddAccountsChartCategorysForEbitda

void batchAddAccountsChartCategorysForEbitda(java.util.List<AccountsChartCategoryVO> voList)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

updateAccountsChartCategoryForEbitda

void updateAccountsChartCategoryForEbitda(AccountsChartCategoryVO vo)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

batchUpdateAccountsChartCategorysForEbitda

void batchUpdateAccountsChartCategorysForEbitda(java.util.List<AccountsChartCategoryVO> volist)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

deleteAccountsChartCategoryForEbitda

void deleteAccountsChartCategoryForEbitda(java.lang.Long pk)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

getAccountsChartCategoryForEbitdaByPk

AccountsChartCategoryVO getAccountsChartCategoryForEbitdaByPk(java.lang.Long pk)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getAccountsChartCategoryReport

java.util.Collection<AccountsChartCategoryListResult> getAccountsChartCategoryReport(java.lang.String monthYear)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

addAccountsChartCategoryForTaxDetail

AccountsChartCategoryVO addAccountsChartCategoryForTaxDetail(AccountsChartCategoryVO vo)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

batchAddAccountsChartCategorysForTaxDetail

void batchAddAccountsChartCategorysForTaxDetail(java.util.List<AccountsChartCategoryVO> voList)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

updateAccountsChartCategoryForTaxDetail

void updateAccountsChartCategoryForTaxDetail(AccountsChartCategoryVO vo)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

batchUpdateAccountsChartCategorysForTaxDetail

void batchUpdateAccountsChartCategorysForTaxDetail(java.util.List<AccountsChartCategoryVO> volist)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

deleteAccountsChartCategoryForTaxDetail

void deleteAccountsChartCategoryForTaxDetail(java.lang.Long pk)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

getAccountsChartCategoryForTaxDetailByPk

AccountsChartCategoryVO getAccountsChartCategoryForTaxDetailByPk(java.lang.Long pk)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findAccountsChartCategoryForTaxDetailByCategoryName

java.util.Collection<AccountsChartCategoryVO> findAccountsChartCategoryForTaxDetailByCategoryName(java.lang.String categoryName,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllAccountsChartCategoryForTaxDetailCountByCategoryName

int getAllAccountsChartCategoryForTaxDetailCountByCategoryName(java.lang.String categoryName)
                                                               throws java.lang.Exception
Throws:
java.lang.Exception

findAccountsChartCategoryForTaxDetailPredefineByCategoryName

java.util.Collection<AccountsChartCategoryVO> findAccountsChartCategoryForTaxDetailPredefineByCategoryName(java.lang.String categoryName,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllAccountsChartCategoryForTaxDetailPredefineCountByCategoryName

int getAllAccountsChartCategoryForTaxDetailPredefineCountByCategoryName(java.lang.String categoryName)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getTaxOfCategory

java.util.Collection<AccountsChartCategoryListResult> getTaxOfCategory(java.lang.String monthYear)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

isCategoryUsedInAccountsChart

boolean isCategoryUsedInAccountsChart(java.lang.Long categoryId)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

clearCategoryInAccountsChart

void clearCategoryInAccountsChart(java.lang.Long categoryId)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

importTaxDetailCategoryFromPredefine

void importTaxDetailCategoryFromPredefine()
                                          throws java.lang.Exception
Throws:
java.lang.Exception

addGeneralLedger

java.lang.String addGeneralLedger(java.lang.String addressId,
                                  java.lang.String transactionType)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

addGeneralLedger

GeneralLedgerVO addGeneralLedger(GeneralLedgerVO vo)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

addNewGeneralLedger

java.lang.String addNewGeneralLedger(GeneralLedgerVO vo)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

deleteAllGeneralLedger

void deleteAllGeneralLedger()
                            throws java.lang.Exception
Throws:
java.lang.Exception

deleteGeneralLedger

void deleteGeneralLedger(GeneralLedgerVO vo)
                         throws java.lang.Exception
Throws:
java.lang.Exception

updateGeneralLedger

java.lang.String updateGeneralLedger(GeneralLedgerVO vo)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

getGLPrintByGlCategory

GeneralLedgerPrintResult getGLPrintByGlCategory(java.lang.String glCategory,
                                                int categorySequence)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

voidGlTransaction

java.lang.String voidGlTransaction(java.lang.String transactionNumber)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

voidAPPayment

AccountsPayableVO voidAPPayment(java.lang.String apNumber,
                                java.lang.String glNumber)
                                throws java.lang.Exception
Throws:
java.lang.Exception

voidAPPaymentWithPrepay

AccountsPayableVO voidAPPaymentWithPrepay(java.lang.String apNumber,
                                          java.lang.String appNumber,
                                          java.lang.String glNumber)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

voidAPPaymentWithMultiplePrepay

AccountsPayableVO voidAPPaymentWithMultiplePrepay(java.lang.String apNumber,
                                                  java.lang.String glNumber)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

voidARPayment

AccountsReceivableVO voidARPayment(java.lang.String arNumber,
                                   java.lang.String glNumber)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

voidARPaymentWithPrepay

AccountsReceivableVO voidARPaymentWithPrepay(java.lang.String arNumber,
                                             java.lang.String arpNumber,
                                             java.lang.String glNumber)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

voidARPaymentWithMultiplePrepay

AccountsReceivableVO voidARPaymentWithMultiplePrepay(java.lang.String arNumber,
                                                     java.lang.String glNumber)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

voidAPPrepayPayment

ApPrepayVO voidAPPrepayPayment(java.lang.String appNumber,
                               java.lang.String appItemNumber,
                               java.lang.String glNumber)
                               throws java.lang.Exception
Throws:
java.lang.Exception

voidARPrepayPayment

ArPrepayVO voidARPrepayPayment(java.lang.String arpNumber,
                               java.lang.String glNumber)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getAllGeneralLedgersCount

int getAllGeneralLedgersCount(java.lang.String glCategory,
                              java.lang.String sequenceFrom,
                              java.lang.String sequenceTo,
                              java.lang.String id,
                              java.lang.String accounts,
                              java.util.Date fromDate,
                              java.util.Date toDate)
                              throws java.lang.Exception
Throws:
java.lang.Exception

findAllGeneralLedgers

java.util.Collection<GeneralLedgerVO> findAllGeneralLedgers(java.lang.String glCategory,
                                                            java.lang.String sequenceFrom,
                                                            java.lang.String sequenceTo,
                                                            java.lang.String id,
                                                            java.lang.String accounts,
                                                            java.util.Date fromDate,
                                                            java.util.Date toDate,
                                                            int firstIndex,
                                                            int maxLength)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

findGLById

java.util.Collection<GeneralLedgerListResult> findGLById(java.lang.String addressId,
                                                         int firstIndex,
                                                         int maxLength)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

findGLByConditions

java.util.Collection<GeneralLedgerListResult> findGLByConditions(java.lang.String addressId,
                                                                 java.lang.String apNumber,
                                                                 java.lang.String arNumber,
                                                                 java.lang.String soOrWONumber,
                                                                 java.lang.String shipperNumber,
                                                                 java.lang.String receiverNumber,
                                                                 java.lang.String ourPOorWONumber,
                                                                 java.util.Date fromDate,
                                                                 java.util.Date toDate,
                                                                 java.math.BigDecimal amount,
                                                                 int firstIndex,
                                                                 int maxLength)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getGLCountByConditions

int getGLCountByConditions(java.lang.String addressId,
                           java.lang.String apNumber,
                           java.lang.String arNumber,
                           java.lang.String soOrWONumber,
                           java.lang.String shipperNumber,
                           java.lang.String receiverNumber,
                           java.lang.String ourPOorWONumber,
                           java.util.Date fromDate,
                           java.util.Date toDate,
                           java.math.BigDecimal amount)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findGLCreditDebitByConditions

java.util.Collection<GLDebitCreditListResult> findGLCreditDebitByConditions(java.lang.String addressId,
                                                                            java.lang.String apNumber,
                                                                            java.lang.String arNumber,
                                                                            java.lang.String soOrWONumber,
                                                                            java.lang.String shipperNumber,
                                                                            java.lang.String receiverNumber,
                                                                            java.lang.String ourPOorWONumber,
                                                                            java.util.Date fromDate,
                                                                            java.util.Date toDate,
                                                                            int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getGLCreditDebitByConditionsTotal

java.util.Map<java.lang.String,java.math.BigDecimal> getGLCreditDebitByConditionsTotal(java.lang.String addressId,
                                                                                java.lang.String apNumber,
                                                                                java.lang.String arNumber,
                                                                                java.lang.String soOrWONumber,
                                                                                java.lang.String shipperNumber,
                                                                                java.lang.String receiverNumber,
                                                                                java.lang.String ourPOorWONumber,
                                                                                java.util.Date fromDate,
                                                                                java.util.Date toDate)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getGLCreditDebitCountByConditions

int getGLCreditDebitCountByConditions(java.lang.String addressId,
                                      java.lang.String apNumber,
                                      java.lang.String arNumber,
                                      java.lang.String soOrWONumber,
                                      java.lang.String shipperNumber,
                                      java.lang.String receiverNumber,
                                      java.lang.String ourPOorWONumber,
                                      java.util.Date fromDate,
                                      java.util.Date toDate)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

getGLCountById

int getGLCountById(java.lang.String addressId)
                   throws java.lang.Exception
Throws:
java.lang.Exception

getGeneralLedgerByPk

GeneralLedgerVO getGeneralLedgerByPk(java.lang.String transactionNumber)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

getGeneralLedgerResult

GeneralLedgerResult getGeneralLedgerResult(java.lang.String transactionNumber)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

isTransactionExist

boolean isTransactionExist(java.lang.String transactionNumber)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findTransactionByAPNumber

java.util.Collection<GeneralLedgerVO> findTransactionByAPNumber(java.lang.String apNumber,
                                                                int firstIndex,
                                                                int maxLength)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getTransactionCountByAPNumber

int getTransactionCountByAPNumber(java.lang.String apNumber)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findTransactionByDMNumber

java.util.Collection<GeneralLedgerVO> findTransactionByDMNumber(java.lang.String apNumber,
                                                                int firstIndex,
                                                                int maxLength)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findTransactionByDMNumber

java.util.Collection<GeneralLedgerVO> findTransactionByDMNumber(java.lang.String apNumber,
                                                                boolean showVoid,
                                                                int firstIndex,
                                                                int maxLength)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getTransactionCountByDMNumber

int getTransactionCountByDMNumber(java.lang.String apNumber)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findTransactionByARNumber

java.util.Collection<GeneralLedgerVO> findTransactionByARNumber(java.lang.String arNumber,
                                                                int firstIndex,
                                                                int maxLength)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findTransactionByARNumber

java.util.Collection<GeneralLedgerVO> findTransactionByARNumber(java.lang.String arNumber,
                                                                boolean showVoid,
                                                                int firstIndex,
                                                                int maxLength)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getTransactionCountByARNumber

int getTransactionCountByARNumber(java.lang.String arNumber)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findTransactionByPONumber

java.util.Collection<GeneralLedgerVO> findTransactionByPONumber(java.lang.String poNumber,
                                                                int firstIndex,
                                                                int maxLength)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findTransactionByMPONumber

java.util.Collection<GeneralLedgerVO> findTransactionByMPONumber(java.lang.String poNumber,
                                                                 int firstIndex,
                                                                 int maxLength)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getTransactionCountByPONumber

int getTransactionCountByPONumber(java.lang.String poNumber)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findTransactionBySONumber

java.util.Collection<GeneralLedgerVO> findTransactionBySONumber(java.lang.String soNumber,
                                                                int firstIndex,
                                                                int maxLength)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getTransactionCountBySONumber

int getTransactionCountBySONumber(java.lang.String soNumber)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findTransactionByAppNumber

java.util.Collection<GeneralLedgerVO> findTransactionByAppNumber(java.lang.String appNumber,
                                                                 int firstIndex,
                                                                 int maxLength)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findCheckNumberByPOWithApp

java.util.Collection<java.lang.String> findCheckNumberByPOWithApp(java.lang.String poNumber)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

findCheckNumberBySOWithArp

java.util.Collection<java.lang.String> findCheckNumberBySOWithArp(java.lang.String soNumber)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getTransactionCountByAppNumber

int getTransactionCountByAppNumber(java.lang.String appNumber)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findTransactionByArpNumber

java.util.Collection<GeneralLedgerVO> findTransactionByArpNumber(java.lang.String arpNumber,
                                                                 int firstIndex,
                                                                 int maxLength)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getTransactionCountByArpNumber

int getTransactionCountByArpNumber(java.lang.String arpNumber)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

getRelatedGL

java.util.Collection<GeneralLedgerListResult> getRelatedGL(java.lang.String glNumber,
                                                           java.lang.String apNumber,
                                                           java.lang.String poNumber,
                                                           java.lang.String receiverNumber,
                                                           java.lang.String arNumber,
                                                           java.lang.String soNumber,
                                                           java.lang.String shipperNumber)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

findARAccountInfo

java.util.Collection<GeneralLedgerVO> findARAccountInfo(java.lang.String arNumber,
                                                        int firstIndex,
                                                        int maxLength)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getARAccountInfoCount

int getARAccountInfoCount(java.lang.String arNumber)
                          throws java.lang.Exception
Throws:
java.lang.Exception

findAPAccountInfo

java.util.Collection<GeneralLedgerVO> findAPAccountInfo(java.lang.String apNumber,
                                                        int firstIndex,
                                                        int maxLength)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

findDMAccountInfo

java.util.Collection<GeneralLedgerVO> findDMAccountInfo(java.lang.String apNumber,
                                                        int firstIndex,
                                                        int maxLength)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getAPAccountInfoCount

int getAPAccountInfoCount(java.lang.String apNumber)
                          throws java.lang.Exception
Throws:
java.lang.Exception

findDebitListByArNumber

java.util.Collection<AccountsCreditDebitListResult> findDebitListByArNumber(java.lang.String arNumber,
                                                                            java.lang.String language,
                                                                            int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getDebitListCountByArNumber

int getDebitListCountByArNumber(java.lang.String arNumber)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findCreditListByArNumber

java.util.Collection<AccountsCreditDebitListResult> findCreditListByArNumber(java.lang.String arNumber,
                                                                             java.lang.String language,
                                                                             int firstIndex,
                                                                             int maxLength)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getCreditListCountByArNumber

int getCreditListCountByArNumber(java.lang.String arNumber)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findDebitListByApNumber

java.util.Collection<AccountsCreditDebitListResult> findDebitListByApNumber(java.lang.String apNumber,
                                                                            java.lang.String language,
                                                                            int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getDebitListCountByApNumber

int getDebitListCountByApNumber(java.lang.String apNumber)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findCreditListByApNumber

java.util.Collection<AccountsCreditDebitListResult> findCreditListByApNumber(java.lang.String apNumber,
                                                                             java.lang.String language,
                                                                             int firstIndex,
                                                                             int maxLength)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getCreditListCountByApNumber

int getCreditListCountByApNumber(java.lang.String apNumber)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findDebitListByAppNumber

java.util.Collection<AccountsCreditDebitListResult> findDebitListByAppNumber(java.lang.String appNumber,
                                                                             int firstIndex,
                                                                             int maxLength)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getDebitListCountByAppNumber

int getDebitListCountByAppNumber(java.lang.String appNumber)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findCreditListByAppNumber

java.util.Collection<AccountsCreditDebitListResult> findCreditListByAppNumber(java.lang.String appNumber,
                                                                              int firstIndex,
                                                                              int maxLength)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getCreditListCountByAppNumber

int getCreditListCountByAppNumber(java.lang.String appNumber)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

getDebitsCreditsResultForApp

DebitsCreditsResult getDebitsCreditsResultForApp(java.lang.String appNumber)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getDebitsCreditsResultForArp

DebitsCreditsResult getDebitsCreditsResultForArp(java.lang.String arpNumber)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getDebitsCreditsResultForAR

DebitsCreditsResult getDebitsCreditsResultForAR(java.lang.String arNumber,
                                                java.lang.String language)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

getDebitsCreditsResultForAP

DebitsCreditsResult getDebitsCreditsResultForAP(java.lang.String apNumber,
                                                java.lang.String language)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

getDebitsCreditsResultForDM

DebitsCreditsResult getDebitsCreditsResultForDM(java.lang.String apNumber,
                                                java.lang.String language)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

findGeneralLedgerByDate

java.util.Collection<GeneralLedgerByDateListResult> findGeneralLedgerByDate(java.lang.String companyUnitId,
                                                                            java.lang.String accountNumber,
                                                                            java.lang.String language,
                                                                            java.util.Date fromDate,
                                                                            java.util.Date toDate,
                                                                            java.lang.String accountType,
                                                                            java.lang.String[] include,
                                                                            java.lang.String[] exclude,
                                                                            int orderBy,
                                                                            java.lang.String checkNumber,
                                                                            int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

findGeneralLedgerByDate

java.util.Collection<GeneralLedgerByDateListResult> findGeneralLedgerByDate(java.lang.String companyUnitId,
                                                                            java.lang.String accountNumber,
                                                                            java.lang.String language,
                                                                            java.util.Date fromDate,
                                                                            java.util.Date toDate,
                                                                            java.lang.String clearedStatus,
                                                                            java.lang.String addressId,
                                                                            int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getGeneralLedgerCountByDate

int getGeneralLedgerCountByDate(java.lang.String companyUnitId,
                                java.lang.String accountNumber,
                                java.util.Date fromDate,
                                java.util.Date toDate,
                                java.lang.String accountType,
                                java.lang.String[] include,
                                java.lang.String[] exclude,
                                java.lang.String checkNumber)
                                throws java.lang.Exception
Throws:
java.lang.Exception

getGeneralLedgerCountByDate

int getGeneralLedgerCountByDate(java.lang.String companyUnitId,
                                java.lang.String accountNumber,
                                java.util.Date fromDate,
                                java.util.Date toDate,
                                java.lang.String clearedStatus,
                                java.lang.String addressId)
                                throws java.lang.Exception
Throws:
java.lang.Exception

getGeneralLedgerTotalByDate

GLByDateTotalResult getGeneralLedgerTotalByDate(java.lang.String companyUnitId,
                                                java.lang.String accountNumber,
                                                java.util.Date fromDate,
                                                java.util.Date toDate,
                                                java.lang.String accountType,
                                                java.lang.String[] include,
                                                java.lang.String[] exclude,
                                                java.lang.String checkNumber)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

getGeneralLedgerTotalByDate

GLByDateTotalResult getGeneralLedgerTotalByDate(java.lang.String companyUnitId,
                                                java.lang.String accountNumber,
                                                java.util.Date fromDate,
                                                java.util.Date toDate,
                                                java.lang.String clearedStatus,
                                                java.lang.String addressId)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

findAccountBalanceById

java.util.Collection<AccountBalanceListResult> findAccountBalanceById(java.lang.String companyUnitId,
                                                                      java.lang.String accountNumber,
                                                                      java.lang.String language,
                                                                      java.util.Date fromDate,
                                                                      java.util.Date toDate,
                                                                      java.lang.String addressIdLike,
                                                                      int firstIndex,
                                                                      int maxLength)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getAccountBalanceCountById

int getAccountBalanceCountById(java.lang.String companyUnitId,
                               java.lang.String accountNumber,
                               java.util.Date fromDate,
                               java.util.Date toDate,
                               java.lang.String addressIdLike)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getCurrentBalanceResult

CurrentBalanceResult getCurrentBalanceResult(java.lang.String companyUnitId,
                                             java.lang.String accountNumber,
                                             java.lang.String monthName)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findCurrentBalanceResult

java.util.Collection<GeneralLedgerByDateListResult> findCurrentBalanceResult(java.lang.String companyUnitId,
                                                                             java.lang.String accountNumber,
                                                                             java.lang.String language,
                                                                             java.lang.String monthName,
                                                                             int firstIndex,
                                                                             int maxLength)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getCurrentBalanceCount

int getCurrentBalanceCount(java.lang.String companyUnitId,
                           java.lang.String accountNumber,
                           java.lang.String monthName)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findAllGlMonth

java.util.Collection<GlMonthVO> findAllGlMonth(int firstIndex,
                                               int maxLength)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

getAllGlMonthCount

int getAllGlMonthCount()
                       throws java.lang.Exception
Throws:
java.lang.Exception

findCurrentAllGlMonth

java.util.Collection<GlMonthVO> findCurrentAllGlMonth(int firstIndex,
                                                      int maxLength)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getCurrentAllGlMonthCount

int getCurrentAllGlMonthCount()
                              throws java.lang.Exception
Throws:
java.lang.Exception

findOpenGlMonth

java.util.Collection<GlMonthVO> findOpenGlMonth(int firstIndex,
                                                int maxLength)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOpenGlMonthCount

int getOpenGlMonthCount()
                        throws java.lang.Exception
Throws:
java.lang.Exception

findClosedGlMonth

java.util.Collection<GlMonthVO> findClosedGlMonth(int firstIndex,
                                                  int maxLength)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getFirstOpenMonth

GlMonthVO getFirstOpenMonth()
                            throws java.lang.Exception
Throws:
java.lang.Exception

isGlMonthExist

boolean isGlMonthExist(java.lang.String monthYear)
                       throws java.lang.Exception
Throws:
java.lang.Exception

addFiscalYearSettings

FiscalYearSettingsVO addFiscalYearSettings(FiscalYearSettingsVO vo)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

deleteFiscalYearSetting

void deleteFiscalYearSetting(FiscalYearSettingsVO vo,
                             boolean direct)
                             throws java.lang.Exception
Throws:
java.lang.Exception

updateFiscalYearSettings

void updateFiscalYearSettings(FiscalYearSettingsVO vo)
                              throws java.lang.Exception
Throws:
java.lang.Exception

getAllFiscalYearSettingsCount

int getAllFiscalYearSettingsCount()
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findAllFiscalYearSettings

java.util.Collection<FiscalYearSettingsVO> findAllFiscalYearSettings(int firstIndex,
                                                                     int maxLength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

findFiscalYearSettingsByPk

FiscalYearSettingsVO findFiscalYearSettingsByPk(java.lang.String fyNumber)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

getCurrentFiscalYearSettings

FiscalYearSettingsVO getCurrentFiscalYearSettings()
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

isFiscalYearSettingsExist

boolean isFiscalYearSettingsExist(java.lang.String fyNumber)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findFiscalYearSettingsByDate

FiscalYearSettingsVO findFiscalYearSettingsByDate(java.util.Date date)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getGS

GeneralLedgerSettingsVO getGS()
                              throws java.lang.Exception
Throws:
java.lang.Exception

updateTransactionLockDate

GeneralLedgerSettingsVO updateTransactionLockDate(java.util.Date date)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

setupCheckRunPayment

java.lang.String setupCheckRunPayment(ApCheckRunItemAgent agent)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

updateApCheckRun

java.lang.String updateApCheckRun(AccountPayableCheckRunVO vo)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

addChecksFromCheckRunNumber

void addChecksFromCheckRunNumber(java.lang.String checkRunNumber,
                                 boolean first)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

addWireTransferFromCheckRun

java.lang.String addWireTransferFromCheckRun(java.lang.String checkRunNumber)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

getCheckRunItemTotal

CheckRunItemTotalResult getCheckRunItemTotal(java.lang.String checkRunNumber)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

getAllAccountPayableCheckRunsCount

int getAllAccountPayableCheckRunsCount()
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findAllAccountPayableCheckRuns

java.util.Collection<AccountPayableCheckRunVO> findAllAccountPayableCheckRuns(int firstIndex,
                                                                              int maxLength)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getAccountPayableCheckRunByPk

AccountPayableCheckRunVO getAccountPayableCheckRunByPk(java.lang.String checkRunNumber)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

findAPCheckRunItemByCheckRunNumber

java.util.Collection<AccountPayableCheckRunItemVO> findAPCheckRunItemByCheckRunNumber(java.lang.String checkRunNumber)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findApCheckRunByDate

java.util.Collection<ApCheckRunListResult> findApCheckRunByDate(java.util.Date fromDate,
                                                                java.util.Date toDate,
                                                                java.lang.String checkNumber,
                                                                java.lang.String vendorId,
                                                                java.lang.String debitAccount,
                                                                java.lang.String creditAccount,
                                                                java.lang.String dateColumn,
                                                                int firstIndex,
                                                                int maxLength)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getApCheckRunCountByDate

int getApCheckRunCountByDate(java.util.Date fromDate,
                             java.util.Date toDate,
                             java.lang.String checkNumber,
                             java.lang.String vendorId,
                             java.lang.String debitAccount,
                             java.lang.String creditAccount,
                             java.lang.String dateColumn)
                             throws java.lang.Exception
Throws:
java.lang.Exception

findAPCheckRunsByCheckRunNumberLike

java.util.Collection<AccountPayableCheckRunVO> findAPCheckRunsByCheckRunNumberLike(java.lang.String checkRunNumberLike,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAPCheckRunsCountByCheckRunNumberLike

int getAPCheckRunsCountByCheckRunNumberLike(java.lang.String checkRunNumberLike)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

setupAPWireTransfer

java.lang.String setupAPWireTransfer(WireTransferAgent agent)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findCheckRunItemByCheckNo

java.util.Collection<AccountPayableCheckRunItemVO> findCheckRunItemByCheckNo(java.lang.String checkRunNo,
                                                                             java.lang.String checkNo,
                                                                             java.lang.String vendorId)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

addSingleCheck

AccountPayableCheckVO addSingleCheck(MakeCheckAgent agent)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

deleteAccountPayableCheck

void deleteAccountPayableCheck(AccountPayableCheckVO vo)
                               throws java.lang.Exception
Throws:
java.lang.Exception

updateAccountPayableCheck

void updateAccountPayableCheck(AccountPayableCheckVO vo)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getAllAccountPayableChecksCount

int getAllAccountPayableChecksCount()
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findAllAccountPayableChecks

java.util.Collection<AccountPayableCheckVO> findAllAccountPayableChecks(int firstIndex,
                                                                        int maxLength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

findAccountPayableChecksByCheckNumber

java.util.Collection<AccountPayableCheckVO> findAccountPayableChecksByCheckNumber(java.lang.String checkNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAccountPayableChecksCountByCheckNumber

int getAccountPayableChecksCountByCheckNumber(java.lang.String checkNumber)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

getAccountPayableCheckByCheckNo

AccountPayableCheckVO getAccountPayableCheckByCheckNo(java.lang.String checkNumber)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

findAccountPayableChecksByCheckRunNumber

java.util.Collection<AccountPayableCheckVO> findAccountPayableChecksByCheckRunNumber(java.lang.String checkRunNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAccountPayableChecksCountByCheckRunNumber

int getAccountPayableChecksCountByCheckRunNumber(java.lang.String checkRunNumber)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

addAccountReceivablePayment

AccountReceivablePaymentVO addAccountReceivablePayment(AccountReceivablePaymentVO vo)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

deleteAccountReceivablePayment

void deleteAccountReceivablePayment(AccountReceivablePaymentVO vo)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

updateAccountReceivablePayment

void updateAccountReceivablePayment(AccountReceivablePaymentVO vo)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

getAllAccountReceivablePaymentsCount

int getAllAccountReceivablePaymentsCount()
                                         throws java.lang.Exception
Throws:
java.lang.Exception

findAllAccountReceivablePayments

java.util.Collection<AccountReceivablePaymentVO> findAllAccountReceivablePayments(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findARPaymentsByPaymentNumberLike

java.util.Collection<AccountReceivablePaymentVO> findARPaymentsByPaymentNumberLike(java.lang.String paymentNumberLike,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getARPaymentsCountByPaymentNumberLike

int getARPaymentsCountByPaymentNumberLike(java.lang.String paymentNumberLike)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

getARPaymentByPk

AccountReceivablePaymentVO getARPaymentByPk(java.lang.Long ii)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

findARPaymentsByPaymentRunNumber

java.util.Collection<AccountReceivablePaymentVO> findARPaymentsByPaymentRunNumber(java.lang.String paymentRunNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getARPaymentsCountByPaymentRunNumber

int getARPaymentsCountByPaymentRunNumber(java.lang.String paymentRunNumber)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

findPaymentRunItemByPaymentNo

java.util.Collection<ARPaymentRunItemVO> findPaymentRunItemByPaymentNo(java.lang.String paymentRunNo,
                                                                       java.lang.String paymentNumber,
                                                                       java.lang.String customerId)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getCMByPk

AccountsReceivableVO getCMByPk(java.lang.String pk)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findCMsByCMNumber

java.util.Collection<AccountsReceivableInfoVO> findCMsByCMNumber(java.lang.String invoiceNumber,
                                                                 int firstIndex,
                                                                 int maxLength)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getCMsCountByCMNumber

int getCMsCountByCMNumber(java.lang.String invoiceNumber)
                          throws java.lang.Exception
Throws:
java.lang.Exception

findCMsByCustomerId

java.util.Collection<AccountsReceivableInfoVO> findCMsByCustomerId(java.lang.String customerId,
                                                                   int firstIndex,
                                                                   int maxLength)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getCMsByCustomerIdCount

int getCMsByCustomerIdCount(java.lang.String customerId)
                            throws java.lang.Exception
Throws:
java.lang.Exception

getCMByDateCount

int getCMByDateCount(java.lang.String invoiceId,
                     java.lang.String customerId,
                     java.lang.String status,
                     java.lang.String accountNumber,
                     java.lang.String companyUnitId,
                     boolean isInvoiceDate,
                     java.util.Date fromDate,
                     java.util.Date toDate)
                     throws java.lang.Exception
Throws:
java.lang.Exception

findCMByDate

java.util.Collection<AccountsReceivableInfoVO> findCMByDate(java.lang.String invoiceId,
                                                            java.lang.String customerId,
                                                            java.lang.String status,
                                                            java.lang.String accountNumber,
                                                            java.lang.String companyUnitId,
                                                            boolean isInvoiceDate,
                                                            java.util.Date fromDate,
                                                            java.util.Date toDate,
                                                            int firstIndex,
                                                            int maxLength)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getCMItemByDateCount

int getCMItemByDateCount(java.lang.String partNumberLike,
                         java.lang.String partType,
                         java.lang.String customerId,
                         java.lang.String status,
                         java.lang.String accountNumber,
                         java.lang.String companyUnitId,
                         boolean isInvoiceDate,
                         java.util.Date fromDate,
                         java.util.Date toDate)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findCMItemByDate

java.util.Collection<InvoiceItemListResult> findCMItemByDate(java.lang.String partNumberLike,
                                                             java.lang.String partType,
                                                             java.lang.String customerId,
                                                             java.lang.String status,
                                                             java.lang.String accountNumber,
                                                             java.lang.String companyUnitId,
                                                             boolean isInvoiceDate,
                                                             java.util.Date fromDate,
                                                             java.util.Date toDate,
                                                             int firstIndex,
                                                             int maxLength)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

setupReceivablePayment

java.lang.String setupReceivablePayment(ArPaymentRunItemAgent agent)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

updatePaymentRun

java.lang.String updatePaymentRun(ARPaymentRunVO vo)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

receivePaymentFromPaymentRunExecuter

java.lang.String receivePaymentFromPaymentRunExecuter(java.lang.String paymentRunNumber)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

deleteARPaymentRun

void deleteARPaymentRun(ARPaymentRunVO vo)
                        throws java.lang.Exception
Throws:
java.lang.Exception

getPaymentRunItemTotal

PaymentRunItemTotalResult getPaymentRunItemTotal(java.lang.String paymentRunNumber)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getAllARPaymentRunsCount

int getAllARPaymentRunsCount()
                             throws java.lang.Exception
Throws:
java.lang.Exception

findAllARPaymentRuns

java.util.Collection<ARPaymentRunVO> findAllARPaymentRuns(int firstIndex,
                                                          int maxLength)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getARPaymentRunByPk

ARPaymentRunVO getARPaymentRunByPk(java.lang.String paymentRunNumber)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findARPaymentRunsByPaymentNumberLike

java.util.Collection<ARPaymentRunVO> findARPaymentRunsByPaymentNumberLike(java.lang.String paymentRunNumberLike,
                                                                          int firstIndex,
                                                                          int maxLength)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getARPaymentRunsCountByPaymentNumberLike

int getARPaymentRunsCountByPaymentNumberLike(java.lang.String paymentRunNumberLike)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findArPaymentByDate

java.util.Collection<ARPaymentRunListResult> findArPaymentByDate(java.util.Date fromDate,
                                                                 java.util.Date toDate,
                                                                 java.lang.String paymentNumber,
                                                                 java.lang.String customerId,
                                                                 java.lang.String debitAccount,
                                                                 java.lang.String creditAccount,
                                                                 int firstIndex,
                                                                 int maxLength)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getArPaymentByDateTotal

java.util.Collection<ARPaymentRunListResult> getArPaymentByDateTotal(java.util.Date fromDate,
                                                                     java.util.Date toDate,
                                                                     java.lang.String paymentNumber,
                                                                     java.lang.String customerId,
                                                                     java.lang.String debitAccount,
                                                                     java.lang.String creditAccount)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getArPaymentCountByDate

int getArPaymentCountByDate(java.util.Date fromDate,
                            java.util.Date toDate,
                            java.lang.String paymentNumber,
                            java.lang.String customerId,
                            java.lang.String debitAccount,
                            java.lang.String creditAccount)
                            throws java.lang.Exception
Throws:
java.lang.Exception

setupARWireTransfer

java.lang.String setupARWireTransfer(WireTransferAgent agent)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

addCreditMemo

AccountsReceivableVO addCreditMemo(java.lang.String invoiceNumber,
                                   java.lang.String summary)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

addCreditMemoWithoutInvoice

java.lang.String addCreditMemoWithoutInvoice(AccountsReceivableVO vo)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

makeCreditMemoWithRMAReceiver

java.lang.String makeCreditMemoWithRMAReceiver(MakeCreditMemoAgent agent)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

updateCreditMemo

AccountsReceivableVO updateCreditMemo(AccountsReceivableVO vo)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

addRefdocTwo

RefdocVO addRefdocTwo(AccountsReceivableItemPK arItemPk,
                      java.lang.String orderNumber,
                      java.lang.String itemNumber)
                      throws java.lang.Exception
Throws:
java.lang.Exception

addRefdocTwo

RefdocVO addRefdocTwo(AccountsPayableItemPK apItemPk,
                      java.lang.String orderNumber,
                      java.lang.String itemNumber)
                      throws java.lang.Exception
Throws:
java.lang.Exception

updateRefdocTwo

RefdocVO updateRefdocTwo(RefdocVO vo)
                         throws java.lang.Exception
Throws:
java.lang.Exception

deleteRefdocTwo

void deleteRefdocTwo(BB2RefdocPK pk)
                     throws java.lang.Exception
Throws:
java.lang.Exception

rollUpCashFlowBudget

void rollUpCashFlowBudget(java.lang.String startMonth,
                          java.lang.String endMonth,
                          java.lang.String companyUnitId)
                          throws java.lang.Exception
Throws:
java.lang.Exception

rollUpFiscalYearBudget

void rollUpFiscalYearBudget(java.lang.String fiscalYear,
                            java.lang.String companyUnitId)
                            throws java.lang.Exception
Throws:
java.lang.Exception

updateGlCashFlowBudget

void updateGlCashFlowBudget(java.lang.String companyUnitId,
                            java.util.ArrayList voSet)
                            throws java.lang.Exception
Throws:
java.lang.Exception

updateGlfiscalYearBudget

void updateGlfiscalYearBudget(java.lang.String companyUnitId,
                              java.util.ArrayList voSet)
                              throws java.lang.Exception
Throws:
java.lang.Exception

getCurrentMonthYear

GlMonthBudgetVO getCurrentMonthYear()
                                    throws java.lang.Exception
Throws:
java.lang.Exception

getMonthYearAfter12Month

GlMonthBudgetVO getMonthYearAfter12Month()
                                         throws java.lang.Exception
Throws:
java.lang.Exception

get15MonthYear

java.util.Collection<GlMonthBudgetVO> get15MonthYear()
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

findMonthList

java.util.Collection<GlMonthBudgetVO> findMonthList(java.lang.String month1,
                                                    java.lang.String month2)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

findCashFlowBudget

AllBudgetResult findCashFlowBudget(java.lang.String companyUnitId,
                                   java.lang.String month1,
                                   java.lang.String month2,
                                   boolean isCheck)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findFiscalYearBudget

AllBudgetResult findFiscalYearBudget(java.lang.String fiscalYear,
                                     java.lang.String companyUnitId)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

updateCashFlowFromFiscalYearBudget

void updateCashFlowFromFiscalYearBudget(java.lang.String fiscalYear)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findCashFlowMonthTotalBudget

java.util.Collection<CashFlowMonthTotalResult> findCashFlowMonthTotalBudget(java.lang.String companyUnitId,
                                                                            java.lang.String startMonth,
                                                                            java.lang.String endMonth)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

findCashFlowByMonthReport

CashFlowByMonthReportResult findCashFlowByMonthReport(java.lang.String companyUnitId,
                                                      java.lang.String startMonth,
                                                      java.lang.String endMonth)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

addExpenseAccount

ExpenseAccountVO addExpenseAccount(ExpenseAccountVO vo)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

updateExpenseAccount

ExpenseAccountVO updateExpenseAccount(ExpenseAccountVO vo)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

getExpenseAccountByPk

ExpenseAccountVO getExpenseAccountByPk(java.lang.String type)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findAllExpenseAccount

java.util.Collection<ExpenseAccountVO> findAllExpenseAccount(int firstIndex,
                                                             int maxLength)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getAllExpenseAccountCount

int getAllExpenseAccountCount()
                              throws java.lang.Exception
Throws:
java.lang.Exception

addExpense

ExpenseVO addExpense()
                     throws java.lang.Exception
Throws:
java.lang.Exception

updateExpense

ExpenseVO updateExpense(ExpenseVO vo)
                        throws java.lang.Exception
Throws:
java.lang.Exception

getExpenseByPk

ExpenseVO getExpenseByPk(java.lang.String expenseNumber)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findAllExpenses

java.util.Collection<ExpenseListResult> findAllExpenses(int firstIndex,
                                                        int maxLength)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getAllExpensesCount

int getAllExpensesCount()
                        throws java.lang.Exception
Throws:
java.lang.Exception

findExpensesByExpenseNumber

java.util.Collection<ExpenseListResult> findExpensesByExpenseNumber(java.lang.String expenseNumberLike,
                                                                    int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getExpensesCountByExpenseNumber

int getExpensesCountByExpenseNumber(java.lang.String expenseNumberLike)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findPaymentHistory

java.util.Collection<PaymentHistoryVO> findPaymentHistory(int firstIndex,
                                                          int maxLength)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getPaymentHistoryCount

int getPaymentHistoryCount()
                           throws java.lang.Exception
Throws:
java.lang.Exception

closeGeneralLedger

java.lang.String closeGeneralLedger()
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findBalanceSheet

AccountingBalanceSheetResult findBalanceSheet(java.lang.String monthYear)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

findBalanceSheetSBS

BalanceSheetSideBySideResult findBalanceSheetSBS(java.lang.String monthYear)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findClosingStatement

ClosingStatementResult findClosingStatement(java.lang.String monthYear,
                                            java.lang.String companyUnitId)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

findProfitLossStatement

ProfitLossStatementResult findProfitLossStatement()
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

findProfitLossStatement

ProfitLossStatementResult findProfitLossStatement(java.lang.String companyUnitId,
                                                  java.util.Date currentPeriodFrom,
                                                  java.util.Date currentPeriodTo,
                                                  java.util.Date priorPeriodFrom,
                                                  java.util.Date priorPeriodTo)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

findTwelveMonthCashFlowReport

TwelveMonthCashFlowReportResult findTwelveMonthCashFlowReport(java.lang.String monthYear,
                                                              java.lang.String companyUnitId,
                                                              int grace)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

makeDebitMemoWithRtvShipper

java.lang.String makeDebitMemoWithRtvShipper(MakeDebitMemoAgent agent)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

updateDebitMemo

java.lang.String updateDebitMemo(AccountsPayableVO vo)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

getAPNumbers

java.util.Collection<java.lang.String> getAPNumbers(AccountAuditAgent agent)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getAPAuditListResults

java.util.Collection<APAuditListResult> getAPAuditListResults(java.util.ArrayList<java.lang.String> list,
                                                              java.lang.String currency)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getARNumbers

java.util.Collection<java.lang.String> getARNumbers(AccountAuditAgent agent)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getARAuditListResults

java.util.Collection<ARAuditListResult> getARAuditListResults(java.util.ArrayList<java.lang.String> list,
                                                              java.lang.String currency)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

isARInMyPrintList

boolean isARInMyPrintList(java.lang.String arNumber)
                          throws java.lang.Exception
Throws:
java.lang.Exception

deleteMyPrintList

void deleteMyPrintList(java.util.ArrayList arNumberList)
                       throws java.lang.Exception
Throws:
java.lang.Exception

addMyPrintList

MyPrintListVO addMyPrintList(java.lang.String arNumber)
                             throws java.lang.Exception
Throws:
java.lang.Exception

findMyARPrintList

java.util.Collection<AccountsReceivableInfoVO> findMyARPrintList()
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findARbyZipcodeTaxList

java.util.Collection<ARTaxForZipcodeListResult> findARbyZipcodeTaxList(java.lang.String arNumber,
                                                                       java.lang.String customer,
                                                                       java.lang.String zipcode,
                                                                       java.lang.String status,
                                                                       java.util.Date from,
                                                                       java.util.Date to)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

addAccountsChartMapping

void addAccountsChartMapping(AccountsChartMappingVO vo)
                             throws java.lang.Exception
Throws:
java.lang.Exception

updateAccountsChartMapping

void updateAccountsChartMapping(AccountsChartMappingVO vo)
                                throws java.lang.Exception
Throws:
java.lang.Exception

deleteAccountsChartMapping

void deleteAccountsChartMapping(AccountsChartMappingPK pk)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findAccountsChartMappingBySubcompanyId

java.util.Collection<AccountsChartMappingVO> findAccountsChartMappingBySubcompanyId(java.lang.String subcompanyId,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAccountsChartMappingBySubcompanyIdCount

int getAccountsChartMappingBySubcompanyIdCount(java.lang.String subcompanyId)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

getAllFirstLevelAccountBalanceByMonth

java.util.Collection<AmountsStatementResult> getAllFirstLevelAccountBalanceByMonth(java.lang.String monthYear)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findAllFirstLevelAccountFiscalYearBalance

java.util.Collection<AmountsStatementResult> findAllFirstLevelAccountFiscalYearBalance()
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findFiscalYearBudgetAndActualAmountByCharts

AccountsChartResult findFiscalYearBudgetAndActualAmountByCharts(java.lang.String[] accountNumber,
                                                                java.lang.String companyUnitId)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllAccountsChartBalanceByMonth

java.util.Collection<MonthBalanceResult> getAllAccountsChartBalanceByMonth(java.lang.String monthYear)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

addAccountBalanceGL

java.lang.String addAccountBalanceGL(AccountBalanceAgent agent)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

addBatchAccountsChart

void addBatchAccountsChart(java.util.Collection<AccountsChartVO> chartVO)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findArCommissionByDate

java.util.Collection<ArCommissionListResult> findArCommissionByDate(java.lang.String dateType,
                                                                    java.lang.String status,
                                                                    java.lang.String salesCodeId,
                                                                    java.util.Date fromDate,
                                                                    java.util.Date toDate,
                                                                    int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getArCommissionCountByDate

int getArCommissionCountByDate(java.lang.String dateType,
                               java.lang.String status,
                               java.lang.String salesCodeId,
                               java.util.Date fromDate,
                               java.util.Date toDate)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getArCommissionTotalAmountByDate

java.util.Collection<ArCommissionTotalResult> getArCommissionTotalAmountByDate(java.lang.String dateType,
                                                                               java.lang.String status,
                                                                               java.lang.String salesCodeId,
                                                                               java.util.Date fromDate,
                                                                               java.util.Date toDate)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

findArSalesCodeTotalByDate

java.util.Collection<ArSalesCodeTotalListResult> findArSalesCodeTotalByDate(java.lang.String dateType,
                                                                            java.lang.String status,
                                                                            java.lang.String salesCodeId,
                                                                            java.util.Date fromDate,
                                                                            java.util.Date toDate,
                                                                            int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getArSalesCodeTotalCountByDate

int getArSalesCodeTotalCountByDate(java.lang.String dateType,
                                   java.lang.String status,
                                   java.lang.String salesCodeId,
                                   java.util.Date fromDate,
                                   java.util.Date toDate)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

dealWithDirectMaterialVariance

java.lang.String dealWithDirectMaterialVariance(java.lang.String month,
                                                java.math.BigDecimal variance)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

makeWorkOrderInWipGlByMonth

java.lang.String makeWorkOrderInWipGlByMonth(java.lang.String monthYear)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

addRollUpBomStdCostWorkSheet

java.lang.Long addRollUpBomStdCostWorkSheet(RollUpBomStdCostWorkSheetVO vo)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

updateRollUpBomStdCostWorkSheet

void updateRollUpBomStdCostWorkSheet(RollUpBomStdCostWorkSheetVO vo)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

getRollUpBomStdCostWorkSheet

RollUpBomStdCostWorkSheetVO getRollUpBomStdCostWorkSheet(java.lang.Long ii)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getRollUpBomStdCostWorkSheetCount

int getRollUpBomStdCostWorkSheetCount()
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findRollUpBomStdCostWorkSheet

java.util.Collection<RollUpBomStdCostWorkSheetVO> findRollUpBomStdCostWorkSheet(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getRollUpBomStdCostWorkSheetItemCount

int getRollUpBomStdCostWorkSheetItemCount(java.lang.Long ii)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

findRollUpBomStdCostWorkSheetItem

java.util.Collection<RollUpBomStdCostWorkSheetItemVO> findRollUpBomStdCostWorkSheetItem(java.lang.Long ii,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

commitRollUpBomStdCostWorkSheet

void commitRollUpBomStdCostWorkSheet(java.lang.Long ii)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

overCarryingRollUpBomStdCostWorkSheet

java.lang.String overCarryingRollUpBomStdCostWorkSheet(java.lang.Long ii)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

addChangeStdCostWorkSheet

java.lang.Long addChangeStdCostWorkSheet(ChangeStdCostWorkSheetVO vo)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

updateChangeStdCostWorkSheet

void updateChangeStdCostWorkSheet(ChangeStdCostWorkSheetVO vo)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

getChangeStdCostWorkSheet

ChangeStdCostWorkSheetVO getChangeStdCostWorkSheet(java.lang.Long ii)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getChangeStdCostWorkSheetCount

int getChangeStdCostWorkSheetCount()
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findChangeStdCostWorkSheet

java.util.Collection<ChangeStdCostWorkSheetVO> findChangeStdCostWorkSheet(int firstIndex,
                                                                          int maxLength)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getChangeStdCostWorkSheetItemCount

int getChangeStdCostWorkSheetItemCount(java.lang.Long ii)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findChangeStdCostWorkSheetItem

java.util.Collection<ChangeStdCostWorkSheetItemVO> findChangeStdCostWorkSheetItem(java.lang.Long ii,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

commitChangeStdCostWorkSheet

void commitChangeStdCostWorkSheet(java.lang.Long ii)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

overCarryingChangeStdCostWorkSheet

java.lang.String overCarryingChangeStdCostWorkSheet(java.lang.Long ii)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

addChangeStdCostWorkSheetItem

void addChangeStdCostWorkSheetItem(ChangeStdCostWorkSheetItemVO vo)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

updateChangeStdCostWorkSheetItem

void updateChangeStdCostWorkSheetItem(ChangeStdCostWorkSheetItemVO vo)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

deleteChangeStdCostWorkSheetItem

void deleteChangeStdCostWorkSheetItem(ChangeStdCostWorkSheetItemPK pk)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

isChangeStdCostWorkSheetItemExistent

boolean isChangeStdCostWorkSheetItemExistent(ChangeStdCostWorkSheetItemPK pk)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

refreshChangeStdCostWorkSheetItemStdCostAndOnhand

void refreshChangeStdCostWorkSheetItemStdCostAndOnhand(java.lang.Long ii)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getAccInfoDocumentByID

AccountingInfoDocumentVO getAccInfoDocumentByID(java.lang.String yearCode,
                                                java.lang.String companyUnitId,
                                                java.lang.String accountingReportType)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

downloadAccInfoDocument

byte[] downloadAccInfoDocument(MiscDocAgent agent)
                               throws java.lang.Exception
Throws:
java.lang.Exception

uploadOrUpdateAccInfoDocument

java.util.List<AccountingInfoDocumentVO> uploadOrUpdateAccInfoDocument(MiscDocAgent agent)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

findAccountingInfoDocument

java.util.List<AccountingInfoDocumentVO> findAccountingInfoDocument(java.lang.String yearCode,
                                                                    java.lang.String companyUnitId,
                                                                    java.lang.String accountingReportType,
                                                                    int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getAccountingInfoDocument

int getAccountingInfoDocument(java.lang.String yearCode,
                              java.lang.String companyUnitId,
                              java.lang.String accountingReportType)
                              throws java.lang.Exception
Throws:
java.lang.Exception

isClosingStatementDocumentExist

boolean isClosingStatementDocumentExist(java.lang.String yearCode,
                                        java.lang.String companyUnitId)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

isBalanceSheetDocumentExist

boolean isBalanceSheetDocumentExist(java.lang.String yearCode,
                                    java.lang.String accountingReportType)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

isProfitLossDocumentExist

boolean isProfitLossDocumentExist(java.lang.String companyUnitId,
                                  java.util.Date currentPeriodFrom,
                                  java.util.Date currentPeriodTo,
                                  java.util.Date priorPeriodFrom,
                                  java.util.Date priorPeriodTo)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

closingEntryMonthly

java.lang.String closingEntryMonthly(java.lang.String monthYear)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

autiClosingEntryMonthly

java.lang.String autiClosingEntryMonthly(java.lang.String monthYear)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

isFiscalYearUsed

boolean isFiscalYearUsed(java.lang.String fyNumber)
                         throws java.lang.Exception
Throws:
java.lang.Exception

isLastMonthYear

boolean isLastMonthYear()
                        throws java.lang.Exception
Throws:
java.lang.Exception

getMonthFirstDate

java.util.Date getMonthFirstDate(java.lang.String yearMonth)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

getMonthEndDate

java.util.Date getMonthEndDate(java.lang.String yearMonth)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getYearMonth

java.lang.String getYearMonth(java.util.Date date)
                              throws java.lang.Exception
Throws:
java.lang.Exception

getYearMonths

java.util.Set<java.lang.String> getYearMonths(java.util.Date fDate,
                                              java.util.Date toDate)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

findGlMonthByFyNumber

java.util.Collection<GlMonthVO> findGlMonthByFyNumber(java.lang.String fyNumber,
                                                      int firstIndex,
                                                      int maxLength)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getGlMonthByFyNumberCount

int getGlMonthByFyNumberCount(java.lang.String fyNumber)
                              throws java.lang.Exception
Throws:
java.lang.Exception

getFirstMonthYearByDate

java.lang.String getFirstMonthYearByDate(java.util.Date fDate,
                                         java.util.Date toDate)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

getLastMonthYearByDate

java.lang.String getLastMonthYearByDate(java.util.Date fDate,
                                        java.util.Date toDate)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

isCurrentFYUseAccountingPeriod

boolean isCurrentFYUseAccountingPeriod()
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findLatestOpenFYGlMonth

java.util.Collection<GlMonthVO> findLatestOpenFYGlMonth(int firstIndex,
                                                        int maxLength)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

findGlMonthsByFyNumber

java.util.Collection<GlMonthVO> findGlMonthsByFyNumber(java.lang.String fyNumber)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

findAllBankOrCashGLByDate

GLInfoByPeriodResult findAllBankOrCashGLByDate(java.lang.String accountNumber,
                                               java.lang.String companyUnitId,
                                               java.lang.String fMonthYear,
                                               java.lang.String tMonthYear,
                                               boolean includeUnpostGL,
                                               boolean showOriginal,
                                               int firstIndex,
                                               int maxLength)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

getAllBankOrCashGLByDateCount

int getAllBankOrCashGLByDateCount(java.lang.String accountNumber,
                                  java.lang.String companyUnitId,
                                  java.lang.String fMonthYear,
                                  java.lang.String tMonthYear,
                                  boolean includeUnpostGL)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findAllDetailAccountTransaction

GLInfoByPeriodResult findAllDetailAccountTransaction(java.lang.String accountNumber,
                                                     java.lang.String companyUnitId,
                                                     java.lang.String fMonthYear,
                                                     java.lang.String tMonthYear,
                                                     boolean includeUnpostGL,
                                                     boolean showOpposeAcct,
                                                     java.lang.String customerId,
                                                     boolean showOriginal)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

addGeneralLedgerApproval

GeneralLedgerApprovalVO addGeneralLedgerApproval(java.lang.String employeeId)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

updateGeneralLedgerApproval

void updateGeneralLedgerApproval(GeneralLedgerApprovalVO vo)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

deleteGeneralLedgerApproval

void deleteGeneralLedgerApproval(java.lang.String employeeId)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

getGeneralLedgerApprovalByPk

GeneralLedgerApprovalVO getGeneralLedgerApprovalByPk(java.lang.String employeeId)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getCurrentUserApprovalInfo

GeneralLedgerApprovalVO getCurrentUserApprovalInfo()
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

isCurrentUserHasApproveGLPermission

boolean isCurrentUserHasApproveGLPermission()
                                            throws java.lang.Exception
Throws:
java.lang.Exception

findAllGeneralLedgerApproval

java.util.Collection<GeneralLedgerApprovalVO> findAllGeneralLedgerApproval(int firstIndex,
                                                                           int maxLength)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getAllGeneralLedgerApprovalCount

int getAllGeneralLedgerApprovalCount()
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findGeneralLedgerApprovalById

java.util.Collection<GeneralLedgerApprovalVO> findGeneralLedgerApprovalById(java.lang.String employeeId,
                                                                            int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getGeneralLedgerApprovalByIdCount

int getGeneralLedgerApprovalByIdCount(java.lang.String employeeId)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findGeneralLedgerApprovalByName

java.util.Collection<GeneralLedgerApprovalVO> findGeneralLedgerApprovalByName(java.lang.String userName,
                                                                              int firstIndex,
                                                                              int maxLength)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getGeneralLedgerApprovalByNameCount

int getGeneralLedgerApprovalByNameCount(java.lang.String userName)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

isGLApprovedExsitByUserName

boolean isGLApprovedExsitByUserName(java.lang.String userName)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

approveGeneralLedger

GeneralLedgerVO approveGeneralLedger(java.lang.String transactionNumber)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

cancelGeneralLedger

void cancelGeneralLedger(java.lang.String transactionNumber)
                         throws java.lang.Exception
Throws:
java.lang.Exception

errorGeneralLedger

void errorGeneralLedger(java.lang.String transactionNumber,
                        boolean isCancelError)
                        throws java.lang.Exception
Throws:
java.lang.Exception

getNeedtoApproveGL

java.util.Collection<GLApprovalListResult> getNeedtoApproveGL(java.lang.String monthYear,
                                                              java.lang.String original)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getNeedtoCancelApprovedGL

java.util.Collection<GLApprovalListResult> getNeedtoCancelApprovedGL(java.lang.String monthYear,
                                                                     java.lang.String original)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

batchApprovalGL

ApprovedGLResult batchApprovalGL(java.util.List<java.lang.String> transactionNumber)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

batchCancelApprovalGL

ApprovedGLResult batchCancelApprovalGL(java.util.List<java.lang.String> transactionNumber)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

getNeedtoPostGL

java.util.Collection<GLApprovalListResult> getNeedtoPostGL(java.lang.String fromMonthYear,
                                                           java.lang.String toMonthYear,
                                                           java.lang.String original,
                                                           java.lang.String approvedBy)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getNeedtoCancelPostGL

java.util.Collection<GLApprovalListResult> getNeedtoCancelPostGL(java.lang.String fromMonthYear,
                                                                 java.lang.String toMonthYear,
                                                                 java.lang.String original,
                                                                 java.lang.String approvedBy)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

postGeneralLedger

void postGeneralLedger(java.lang.String fromMonthYear,
                       java.lang.String toMonthYear,
                       java.util.List<java.lang.String> glNumbers)
                       throws java.lang.Exception
Throws:
java.lang.Exception

cancelPostGeneralLedger

void cancelPostGeneralLedger(java.lang.String fromMonthYear,
                             java.lang.String toMonthYear,
                             java.util.List<java.lang.String> glNumbers)
                             throws java.lang.Exception
Throws:
java.lang.Exception

overCarryProfitAndLoss

GeneralLedgerVO overCarryProfitAndLoss(java.lang.String monthYear,
                                       java.lang.String description,
                                       java.util.Date glDate,
                                       java.lang.String glCategory)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

getAllProfitAndLossAccounts

java.util.Collection<ProfitAndLossAccountsResult> getAllProfitAndLossAccounts()
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

findAllGLCategories

java.util.Collection<GeneralLedgerCategoryVO> findAllGLCategories(int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getAllGlCategories

int getAllGlCategories()
                       throws java.lang.Exception
Throws:
java.lang.Exception

addGLCategory

GeneralLedgerCategoryVO addGLCategory(GeneralLedgerCategoryVO vo)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

updateGLCategory

GeneralLedgerCategoryVO updateGLCategory(GeneralLedgerCategoryVO vo)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

getGLCategoryById

GeneralLedgerCategoryVO getGLCategoryById(java.lang.String id)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

deleteGLCategoryById

void deleteGLCategoryById(java.lang.String id)
                          throws java.lang.Exception
Throws:
java.lang.Exception

isGLCategoryUsed

boolean isGLCategoryUsed(java.lang.String id)
                         throws java.lang.Exception
Throws:
java.lang.Exception

isGLCategoryExist

boolean isGLCategoryExist(java.lang.String id)
                          throws java.lang.Exception
Throws:
java.lang.Exception

getMaxSeqByCategoryId

int getMaxSeqByCategoryId(java.lang.String categoryId,
                          java.util.Date transactionDate)
                          throws java.lang.Exception
Throws:
java.lang.Exception

getExchangeRatePreview

ExchangeAuditResult getExchangeRatePreview(java.lang.String yearCode,
                                           java.util.Map map)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

makeExchangeRateAudit

ExchangeAuditResult makeExchangeRateAudit(ExchangeAuditResult result)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

findAllGLAutoApproves

java.util.Collection<GLAutoApproveVO> findAllGLAutoApproves(int firstIndex,
                                                            int maxLength)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getAllGLAutoApproves

int getAllGLAutoApproves()
                         throws java.lang.Exception
Throws:
java.lang.Exception

addGLAutoApprove

GLAutoApproveVO addGLAutoApprove(GLAutoApproveVO vo)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

updateGLAutoApprove

GLAutoApproveVO updateGLAutoApprove(GLAutoApproveVO vo)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

getGLAutoApproveById

GLAutoApproveVO getGLAutoApproveById(java.lang.Long id)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

deleteGLAutoApproveById

void deleteGLAutoApproveById(java.lang.Long id)
                             throws java.lang.Exception
Throws:
java.lang.Exception

isGLAutoApproveExist

boolean isGLAutoApproveExist(java.lang.String glType)
                             throws java.lang.Exception
Throws:
java.lang.Exception

getGLAutoApproveByGlType

GLAutoApproveVO getGLAutoApproveByGlType(java.lang.String glType)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

findARsByDate

java.util.Collection findARsByDate(java.lang.String customerId,
                                   boolean customerLike,
                                   boolean includeCM,
                                   java.util.Date dateFrom,
                                   java.util.Date dateTo,
                                   java.lang.String status,
                                   int firstIndex,
                                   int maxLength)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

getARsCountByDate

int getARsCountByDate(java.lang.String customerId,
                      boolean customerLike,
                      boolean includeCM,
                      java.util.Date dateFrom,
                      java.util.Date dateTo,
                      java.lang.String status)
                      throws java.lang.Exception
Throws:
java.lang.Exception

findARsTotalMoneyByDate

java.util.Collection findARsTotalMoneyByDate(java.lang.String customerId,
                                             boolean customerLike,
                                             boolean includeCM,
                                             java.util.Date dateFrom,
                                             java.util.Date dateTo,
                                             java.lang.String status)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findARItemByPartAndDate

java.util.Collection<AccountsReceivableItemResult> findARItemByPartAndDate(java.util.Date fromDate,
                                                                           java.util.Date toDate,
                                                                           BB2Part part,
                                                                           int firstIndex,
                                                                           int maxLength)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getARItemCountByPartAndDate

int getARItemCountByPartAndDate(java.util.Date fromDate,
                                java.util.Date toDate,
                                BB2Part part)
                                throws java.lang.Exception
Throws:
java.lang.Exception

addAccountChartBalanceSheetAdvanceCategory

void addAccountChartBalanceSheetAdvanceCategory(AccountsChartAdvanceCategoryVO vo)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

updateAccountChartBalanceSheetAdvanceCategory

void updateAccountChartBalanceSheetAdvanceCategory(AccountsChartAdvanceCategoryVO vo)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getAccountChartBalanceSheetAdvanceCategoryByPk

AccountsChartAdvanceCategoryVO getAccountChartBalanceSheetAdvanceCategoryByPk()
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getAccountChartBalanceSheetAdvanceCategoryReportByPk

AccountsChartAdvanceCategoryVO getAccountChartBalanceSheetAdvanceCategoryReportByPk(java.lang.String monthYear)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

addAccountChartProfitLossAdvanceCategory

void addAccountChartProfitLossAdvanceCategory(AccountsChartAdvanceCategoryVO vo)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

updateAccountChartProfitLossAdvanceCategory

void updateAccountChartProfitLossAdvanceCategory(AccountsChartAdvanceCategoryVO vo)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getAccountChartProfitLossAdvanceCategoryByPk

AccountsChartAdvanceCategoryVO getAccountChartProfitLossAdvanceCategoryByPk()
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getAccountChartProfitLossAdvanceCategoryReportByPk

AccountsChartAdvanceCategoryVO getAccountChartProfitLossAdvanceCategoryReportByPk(java.lang.String monthYear)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

addAccountChartTaxPayableAdvanceCategory

void addAccountChartTaxPayableAdvanceCategory(AccountsChartAdvanceCategoryVO vo)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

updateAccountChartTaxPayableAdvanceCategory

void updateAccountChartTaxPayableAdvanceCategory(AccountsChartAdvanceCategoryVO vo)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getAccountChartTaxPayableAdvanceCategoryByPk

AccountsChartAdvanceCategoryVO getAccountChartTaxPayableAdvanceCategoryByPk()
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getAccountChartTaxPayableAdvanceCategoryReportByPk

AccountsChartAdvanceCategoryVO getAccountChartTaxPayableAdvanceCategoryReportByPk(java.lang.String monthYear)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findAPAR

java.util.Map findAPAR(java.lang.String vendoInvoice)
                       throws java.lang.Exception
Throws:
java.lang.Exception

getAccountBalance

java.util.Collection<AccountBalanceResult> getAccountBalance(java.lang.String fMonthYear,
                                                             java.lang.String tMonthYear,
                                                             java.lang.String companyUnitId,
                                                             boolean usePost)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

writeOffEstimatedPayable

java.lang.String writeOffEstimatedPayable(java.lang.String apNumber,
                                          MakeAccountPayableAgent agent)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

dealWithEstimatedPayalbeMaterialVariance

java.lang.String dealWithEstimatedPayalbeMaterialVariance(java.lang.String month,
                                                          java.math.BigDecimal variance)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

updateEP

java.lang.String updateEP(AccountsPayableVO vo)
                          throws java.lang.Exception
Throws:
java.lang.Exception

makeBillAndHoldInvoiceWithSOItems

java.lang.String makeBillAndHoldInvoiceWithSOItems(MakeInvoiceAgent agent)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

shipSOOfBillAndHoldInvoice

java.lang.String shipSOOfBillAndHoldInvoice(java.lang.String invoiceNumber)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

findFiscalYearBudget

AllBudgetResult findFiscalYearBudget(java.lang.String fiscalYear,
                                     java.lang.String companyUnitId,
                                     boolean oldYear)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findBackOrCashCheckRegister

GLCheckRegisterResult findBackOrCashCheckRegister(java.lang.String fMonthYear,
                                                  java.lang.String tMonthYear,
                                                  java.lang.String companyUnit,
                                                  java.lang.String accountNumber,
                                                  java.lang.String id,
                                                  java.lang.String checkType)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

findBackOrCashCheckRegisterDetail

java.util.Collection<GeneralLedgerByDateListResult> findBackOrCashCheckRegisterDetail(java.lang.String fMonthYear,
                                                                                java.lang.String tMonthYear,
                                                                                java.lang.String companyUnit,
                                                                                java.lang.String accountNumber,
                                                                                java.lang.String id,
                                                                                java.lang.String checkNum,
                                                                                java.lang.String checkType)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findTransactionByAppNumber

java.util.Collection<GeneralLedgerVO> findTransactionByAppNumber(java.lang.String appNumber,
                                                                 boolean showVoid,
                                                                 int firstIndex,
                                                                 int maxLength)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findTransactionByArpNumber

java.util.Collection<GeneralLedgerVO> findTransactionByArpNumber(java.lang.String arpNumber,
                                                                 boolean showVoid,
                                                                 int firstIndex,
                                                                 int maxLength)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findFiscalYearBudgetByMonth

AllBudgetResult findFiscalYearBudgetByMonth(java.lang.String fiscalYear,
                                            java.util.Date startDate,
                                            java.util.Date endDate,
                                            java.lang.String companyUnitId,
                                            boolean includeInactive)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

getPastDueAPsCountByVendorId

int getPastDueAPsCountByVendorId(java.lang.String vendorId)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findPastdueAPsByVendorId

java.util.Collection<AccountsPayableInfoVO> findPastdueAPsByVendorId(java.lang.String vendorId,
                                                                     int firstIndex,
                                                                     int maxLength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getAPDueTotal

java.util.Collection<DuePATotalByVendorResult> getAPDueTotal(java.lang.String vendorId)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getPastDueARsCountByVendor

int getPastDueARsCountByVendor(java.lang.String vendorId,
                               boolean includeCM)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findPastDueARsByVendor

java.util.Collection<AccountsReceivableInfoVO> findPastDueARsByVendor(java.lang.String vendorId,
                                                                      boolean includeCM,
                                                                      int firstIndex,
                                                                      int length)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getPastDueARsTotalMoneyByVendor

java.util.Collection<AccountingTotalMoneyResult> getPastDueARsTotalMoneyByVendor(java.lang.String vendorId,
                                                                                boolean includeCM)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOpenARsByVendorIdCount

int getOpenARsByVendorIdCount(java.lang.String vendorId,
                              boolean includeCM)
                              throws java.lang.Exception
Throws:
java.lang.Exception

findOpenARsByVendorId

java.util.Collection<AccountsReceivableInfoVO> findOpenARsByVendorId(int firstIndex,
                                                                     int maxLength,
                                                                     java.lang.String vendorId,
                                                                     boolean includeCM)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getOpenAPsByVendorIdCount

int getOpenAPsByVendorIdCount(java.lang.String vendorId)
                              throws java.lang.Exception
Throws:
java.lang.Exception

findOpenAPsByVendorId

java.util.Collection<AccountsPayableInfoVO> findOpenAPsByVendorId(int firstIndex,
                                                                  int maxLength,
                                                                  java.lang.String vendorId)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getAPOpenByVendorIdTotal

java.util.Collection<DuePATotalByVendorResult> getAPOpenByVendorIdTotal(java.lang.String vendorId)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getOpenARsTotalMoneyByVendor

java.util.Collection<AccountingTotalMoneyResult> getOpenARsTotalMoneyByVendor(java.lang.String vendorId,
                                                                              boolean includeCM)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

findInvoiceByDate

java.util.List findInvoiceByDate(java.lang.String[] arNumbers,
                                 int firstIndex,
                                 int maxLength)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

getInvoiceByDateCount

int getInvoiceByDateCount(java.lang.String[] arNumbers)
                          throws java.lang.Exception
Throws:
java.lang.Exception

findARTotalMoneyByDate

java.util.List findARTotalMoneyByDate(java.lang.String[] arNumbers)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

getCMByDateCount

int getCMByDateCount(java.lang.String[] cmNumbers)
                     throws java.lang.Exception
Throws:
java.lang.Exception

findCMByDate

java.util.Collection<AccountsReceivableInfoVO> findCMByDate(java.lang.String[] cmNumbers,
                                                            int firstIndex,
                                                            int maxLength)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

voidAP

void voidAP(java.lang.String apNumber)
            throws java.lang.Exception
Throws:
java.lang.Exception

voidAR

void voidAR(java.lang.String arNumber)
            throws java.lang.Exception
Throws:
java.lang.Exception

voidAPPrepay

void voidAPPrepay(java.lang.String appNumber)
                  throws java.lang.Exception
Throws:
java.lang.Exception

voidARPrepay

void voidARPrepay(java.lang.String arpNumber)
                  throws java.lang.Exception
Throws:
java.lang.Exception

getCustomerStatementByDate

CustomerStatementResult getCustomerStatementByDate(java.lang.String customer,
                                                   java.util.Date startDate,
                                                   java.util.Date endDate,
                                                   java.lang.String currency)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

findCustomerStatementTotalByDate

java.util.List<CustomerStatementResult> findCustomerStatementTotalByDate(java.lang.String customer,
                                                                         java.util.Date startDate,
                                                                         java.util.Date endDate,
                                                                         java.lang.String currency)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

batchApplyPrepay

void batchApplyPrepay(java.util.List<AccountReceivableInfoWithPrepayResult> list)
                      throws java.lang.Exception
Throws:
java.lang.Exception

offsetARWithCM

void offsetARWithCM(java.util.List<AccountReceivableInfoWithPrepayResult> cmList,
                    java.util.List<AccountReceivableInfoWithPrepayResult> arList,
                    java.lang.Object[] info)
                    throws java.lang.Exception
Throws:
java.lang.Exception

arPaymentRunByCustomer

java.lang.String arPaymentRunByCustomer(java.util.List<AccountReceivableInfoWithPrepayResult> list,
                                        java.lang.Object[] info)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findDepositSummary

java.util.List<DepositSummaryResult> findDepositSummary(java.lang.String[] includableAccount,
                                                        java.util.Date fromDate,
                                                        java.util.Date toDate)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

makeDepositGL

java.lang.String makeDepositGL(java.util.List<DepositSummaryResult> list,
                               java.util.ArrayList<PaymentAgent> agentList)
                               throws java.lang.Exception
Throws:
java.lang.Exception

clearGeneralLedgers

void clearGeneralLedgers(AccountMonthPK pk,
                         java.util.Map<java.lang.String,java.lang.Boolean> glNumbers)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findAddressAccountInfo

java.util.Collection<AddressAccountInfo> findAddressAccountInfo(java.lang.String id,
                                                                java.util.Date from,
                                                                java.util.Date to,
                                                                boolean includeUnpost,
                                                                int firstIndex,
                                                                int maxLength)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAddressAccountInfoCount

int getAddressAccountInfoCount(java.lang.String id,
                               java.util.Date from,
                               java.util.Date to,
                               boolean includeUnpost)
                               throws java.lang.Exception
Throws:
java.lang.Exception

makeNonproductivePickingGl

java.lang.String makeNonproductivePickingGl(java.lang.String creditAccountNumber,
                                            java.lang.String monthYear,
                                            java.util.ArrayList<NonproductivePickingItemIssuedListResult> list,
                                            java.lang.String glCategory)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

addBankReconciliationReport

BankReconciliationReportVO addBankReconciliationReport(BankReconciliationReportVO vo)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

deleteBankReconciliationReport

void deleteBankReconciliationReport(BankReconciliationReportVO vo)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

isBankReconciliationReportExistent

boolean isBankReconciliationReportExistent(AccountMonthPK pk)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

findBankReconciliationReport

java.util.Collection<BankReconciliationReportVO> findBankReconciliationReport(java.lang.String month,
                                                                              java.lang.String accountNumber,
                                                                              java.lang.String companyUnitID,
                                                                              int firstIndex,
                                                                              int maxLength)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getBankReconciliationReportCount

int getBankReconciliationReportCount(java.lang.String month,
                                     java.lang.String accountNumber,
                                     java.lang.String companyUnitID)
                                     throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AccountingConfigurationVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountingConfigurationVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AccountingConfigurationVO
All Implemented Interfaces:
java.io.Serializable
public class AccountingConfigurationVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AccountingConfigurationVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getApOrdmApprovedBy()
java.lang.String | getArOrcmApprovedBy()
java.lang.String | getAssetApprovedBy()
java.lang.String | getGlStyle()
java.lang.String | getId()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getLocalSettings()
java.lang.String | getNcrScrapApprovedBy()
java.lang.String | getRecWoApprovedBy()
java.lang.String | getStdCostApprovedBy()
int | hashCode()
boolean | isUseApprovalGl()
boolean | isUseAutoApprovalGl()
boolean | isUseCarryOverPL()
boolean | isUseCloseEntry()
boolean | isUseJournalAccount()
boolean | isUsePostGl()
boolean | isUseTaxReport()
void | setApOrdmApprovedBy(java.lang.String apOrdmApprovedBy)
void | setArOrcmApprovedBy(java.lang.String arOrcmApprovedBy)
void | setAssetApprovedBy(java.lang.String assetApprovedBy)
void | setGlStyle(java.lang.String glStyle)
void | setId(java.lang.String id)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLocalSettings(java.lang.String localSettings)
void | setNcrScrapApprovedBy(java.lang.String ncrScrapApprovedBy)
void | setRecWoApprovedBy(java.lang.String recWoApprovedBy)
void | setStdCostApprovedBy(java.lang.String stdCostApprovedBy)
void | setUseApprovalGl(boolean useApprovalGl)
void | setUseAutoApprovalGl(boolean useAutoApprovalGl)
void | setUseCarryOverPL(boolean useCarryOverPL)
void | setUseCloseEntry(boolean useCloseEntry)
void | setUseJournalAccount(boolean useJournalAccount)
void | setUsePostGl(boolean usePostGl)
void | setUseTaxReport(boolean useTaxReport)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

AccountingConfigurationVO

public AccountingConfigurationVO()
Method Detail

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

isUseApprovalGl

public boolean isUseApprovalGl()

setUseApprovalGl

public void setUseApprovalGl(boolean useApprovalGl)

isUseCarryOverPL

public boolean isUseCarryOverPL()

setUseCarryOverPL

public void setUseCarryOverPL(boolean useCarryOverPL)

isUseJournalAccount

public boolean isUseJournalAccount()

setUseJournalAccount

public void setUseJournalAccount(boolean useJournalAccount)

isUsePostGl

public boolean isUsePostGl()

setUsePostGl

public void setUsePostGl(boolean usePostGl)

isUseTaxReport

public boolean isUseTaxReport()

setUseTaxReport

public void setUseTaxReport(boolean useTaxReport)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getApOrdmApprovedBy

public java.lang.String getApOrdmApprovedBy()

setApOrdmApprovedBy

public void setApOrdmApprovedBy(java.lang.String apOrdmApprovedBy)

getArOrcmApprovedBy

public java.lang.String getArOrcmApprovedBy()

setArOrcmApprovedBy

public void setArOrcmApprovedBy(java.lang.String arOrcmApprovedBy)

getAssetApprovedBy

public java.lang.String getAssetApprovedBy()

setAssetApprovedBy

public void setAssetApprovedBy(java.lang.String assetApprovedBy)

getNcrScrapApprovedBy

public java.lang.String getNcrScrapApprovedBy()

setNcrScrapApprovedBy

public void setNcrScrapApprovedBy(java.lang.String ncrScrapApprovedBy)

getRecWoApprovedBy

public java.lang.String getRecWoApprovedBy()

setRecWoApprovedBy

public void setRecWoApprovedBy(java.lang.String recWoApprovedBy)

getStdCostApprovedBy

public java.lang.String getStdCostApprovedBy()

setStdCostApprovedBy

public void setStdCostApprovedBy(java.lang.String stdCostApprovedBy)

getLocalSettings

public java.lang.String getLocalSettings()

setLocalSettings

public void setLocalSettings(java.lang.String localSettings)

getGlStyle

public java.lang.String getGlStyle()

setGlStyle

public void setGlStyle(java.lang.String glStyle)

isUseCloseEntry

public boolean isUseCloseEntry()

setUseCloseEntry

public void setUseCloseEntry(boolean useCloseEntry)

isUseAutoApprovalGl

public boolean isUseAutoApprovalGl()

setUseAutoApprovalGl

public void setUseAutoApprovalGl(boolean useAutoApprovalGl)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountingInfoDocumentVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountingInfoDocumentVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AccountingInfoDocumentVO
All Implemented Interfaces:
java.io.Serializable
public class AccountingInfoDocumentVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACCOUNTINGREPORTTYPE
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_COMPANYUNITID
static java.lang.String | ORDER_BY_DOCLENGTH
static java.lang.String | ORDER_BY_DOCNAME
static java.lang.String | ORDER_BY_DOCUMENTDATE
static java.lang.String | ORDER_BY_EXTENSION
static java.lang.String | ORDER_BY_LASTCHANGEDATE
static java.lang.String | ORDER_BY_LASTUSER
static java.lang.String | ORDER_BY_USERNAME
static java.lang.String | ORDER_BY_YEARCODE
Constructor Summary
AccountingInfoDocumentVO()
Method Summary
java.lang.String | getAccountingReportType()
java.lang.String | getComments()
java.lang.String | getCompanyUnitId()
java.util.Date | getCurrentPeriodFrom()
java.util.Date | getCurrentPeriodTo()
long | getDocLength()
java.lang.String | getDocName()
byte[] | getDocument()
java.util.Date | getDocumentDate()
java.lang.String | getExtension()
java.lang.Long | getIi()
java.util.Date | getLastChangeDate()
java.lang.String | getLastUser()
java.util.Date | getPriorPeriodFrom()
java.util.Date | getPriorPeriodTo()
java.lang.String | getUserName()
java.lang.String | getYearCode()
boolean | isReSend()
void | setAccountingReportType(java.lang.String accountingReportType)
void | setComments(java.lang.String comments)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCurrentPeriodFrom(java.util.Date currentPeriodFrom)
void | setCurrentPeriodTo(java.util.Date currentPeriodTo)
void | setDocLength(long docLength)
void | setDocName(java.lang.String docName)
void | setDocument(byte[] document)
void | setDocumentDate(java.util.Date documentDate)
void | setExtension(java.lang.String extension)
void | setIi(java.lang.Long ii)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastUser(java.lang.String lastUser)
void | setPriorPeriodFrom(java.util.Date priorPeriodFrom)
void | setPriorPeriodTo(java.util.Date priorPeriodTo)
void | setReSend(boolean reSend)
void | setUserName(java.lang.String userName)
void | setYearCode(java.lang.String yearCode)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_YEARCODE

public static final java.lang.String ORDER_BY_YEARCODE
See Also:
Constant Field Values

ORDER_BY_COMPANYUNITID

public static final java.lang.String ORDER_BY_COMPANYUNITID
See Also:
Constant Field Values

ORDER_BY_DOCNAME

public static final java.lang.String ORDER_BY_DOCNAME
See Also:
Constant Field Values

ORDER_BY_EXTENSION

public static final java.lang.String ORDER_BY_EXTENSION
See Also:
Constant Field Values

ORDER_BY_ACCOUNTINGREPORTTYPE

public static final java.lang.String ORDER_BY_ACCOUNTINGREPORTTYPE
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEDATE

public static final java.lang.String ORDER_BY_LASTCHANGEDATE
See Also:
Constant Field Values

ORDER_BY_LASTUSER

public static final java.lang.String ORDER_BY_LASTUSER
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values

ORDER_BY_USERNAME

public static final java.lang.String ORDER_BY_USERNAME
See Also:
Constant Field Values

ORDER_BY_DOCLENGTH

public static final java.lang.String ORDER_BY_DOCLENGTH
See Also:
Constant Field Values

ORDER_BY_DOCUMENTDATE

public static final java.lang.String ORDER_BY_DOCUMENTDATE
See Also:
Constant Field Values
Constructor Detail

AccountingInfoDocumentVO

public AccountingInfoDocumentVO()
Method Detail

getDocLength

public long getDocLength()

setDocLength

public void setDocLength(long docLength)

getDocName

public java.lang.String getDocName()

setDocName

public void setDocName(java.lang.String docName)

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getDocumentDate

public java.util.Date getDocumentDate()

setDocumentDate

public void setDocumentDate(java.util.Date documentDate)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getLastUser

public java.lang.String getLastUser()

setLastUser

public void setLastUser(java.lang.String lastUser)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAccountingReportType

public java.lang.String getAccountingReportType()

setAccountingReportType

public void setAccountingReportType(java.lang.String accountingReportType)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getYearCode

public java.lang.String getYearCode()

setYearCode

public void setYearCode(java.lang.String yearCode)

isReSend

public boolean isReSend()

setReSend

public void setReSend(boolean reSend)

getCurrentPeriodFrom

public java.util.Date getCurrentPeriodFrom()

setCurrentPeriodFrom

public void setCurrentPeriodFrom(java.util.Date currentPeriodFrom)

getCurrentPeriodTo

public java.util.Date getCurrentPeriodTo()

setCurrentPeriodTo

public void setCurrentPeriodTo(java.util.Date currentPeriodTo)

getPriorPeriodFrom

public java.util.Date getPriorPeriodFrom()

setPriorPeriodFrom

public void setPriorPeriodFrom(java.util.Date priorPeriodFrom)

getPriorPeriodTo

public java.util.Date getPriorPeriodTo()

setPriorPeriodTo

public void setPriorPeriodTo(java.util.Date priorPeriodTo)

getDocument

public byte[] getDocument()

setDocument

public void setDocument(byte[] document)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountingSettingsVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountingSettingsVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AccountingSettingsVO
All Implemented Interfaces:
java.io.Serializable
public class AccountingSettingsVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AccountingSettingsVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getApBatch()
java.lang.String | getApDiscountAccount()
java.lang.String | getApDiscountMethod()
java.lang.String | getArDiscountAccount()
java.lang.String | getArDiscountMethod()
java.lang.String | getArWireFeeAccount()
java.lang.String | getAssetDeprCreditAccount()
byte | getCheckPrintAdjust()
byte | getCheckPrintAdjustX()
byte | getCheckPrintAdjustY()
java.lang.String | getCurrentRetainedEarning()
java.lang.String | getCurrentYearMonth()
java.lang.String | getDirectMaterialPriceVarianceAccount()
java.lang.String | getDirectMaterialUsageVarianceAccount()
java.lang.String | getFinancingExpensesAccount()
java.lang.String | getGaAp()
java.lang.String | getGaAr()
java.lang.String | getGaBusinessIncome()
java.lang.String | getGaChecking()
java.lang.String | getGaCheckNo()
java.lang.String | getGaCogs()
java.lang.String | getGaCogsContra()
java.lang.String | getGaDep()
java.lang.String | getGaEmployeeLabor()
java.lang.String | getGaExchangeGainsAndLoss()
java.lang.String | getGaInboundFreight()
java.lang.String | getGaOutboundFreight()
java.lang.String | getGaProfitForCurrentYear()
java.lang.String | getGaPurchaseDiscount()
java.lang.String | getGaScrap()
java.lang.String | getGaWip()
java.lang.String | getGaWoic()
java.math.BigDecimal | getGaZero()
int | getGlNdaysOk()
java.lang.String | getId()
java.lang.String | getInventoryValuation()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getMaterialValuationStorageVarianceAccount()
java.lang.String | getMpoDebitAccount()
java.lang.String | getPoDebitAccount()
java.lang.String | getPoVAT()
java.lang.String | getPurchaseOrderPrepay()
java.lang.String | getSalesOrderPrepay()
java.lang.String | getSoCreditAccount()
java.lang.String | getSoVAT()
java.util.Date | getStartWipDate()
java.lang.String | getUnbilledAccount()
java.lang.String | getUnbilledIncomeAccount()
java.lang.String | getValuationStorageAccount()
java.lang.String | getVendorPaymentVarianceAccount()
java.lang.Integer | getVersion()
java.lang.String | getWoDebitAccount()
int | hashCode()
boolean | isLaborCost()
boolean | isMachineCost()
boolean | isUseZipCode()
void | setApBatch(java.lang.String apBatch)
void | setApDiscountAccount(java.lang.String apDiscountAccount)
void | setApDiscountMethod(java.lang.String apDiscountMethod)
void | setArDiscountAccount(java.lang.String arDiscountAccount)
void | setArDiscountMethod(java.lang.String arDiscountMethod)
void | setArWireFeeAccount(java.lang.String arWireFeeAccount)
void | setAssetDeprCreditAccount(java.lang.String assetDeprCreditAccount)
void | setCheckPrintAdjust(byte checkPrintAdjust)
void | setCheckPrintAdjustX(byte checkPrintAdjustX)
void | setCheckPrintAdjustY(byte checkPrintAdjustY)
void | setCurrentRetainedEarning(java.lang.String currentRetainedEarning)
void | setCurrentYearMonth(java.lang.String currentYearMonth)
void | setDirectMaterialPriceVarianceAccount(java.lang.String directMaterialPriceVarianceAccount)
void | setDirectMaterialUsageVarianceAccount(java.lang.String directMaterialUsageVarianceAccount)
void | setFinancingExpensesAccount(java.lang.String financingExpensesAccount)
void | setGaAp(java.lang.String gaAp)
void | setGaAr(java.lang.String gaAr)
void | setGaBusinessIncome(java.lang.String gaBusinessIncome)
void | setGaChecking(java.lang.String gaChecking)
void | setGaCheckNo(java.lang.String gaCheckNo)
void | setGaCogs(java.lang.String gaCogs)
void | setGaCogsContra(java.lang.String gaCogsContra)
void | setGaDep(java.lang.String gaDep)
void | setGaEmployeeLabor(java.lang.String gaEmployeeLabor)
void | setGaExchangeGainsAndLoss(java.lang.String gaExchangeGainsAndLoss)
void | setGaInboundFreight(java.lang.String gaInboundFreight)
void | setGaOutboundFreight(java.lang.String gaOutboundFreight)
void | setGaProfitForCurrentYear(java.lang.String gaProfitForCurrentYear)
void | setGaPurchaseDiscount(java.lang.String gaPurchaseDiscount)
void | setGaScrap(java.lang.String gaScrap)
void | setGaWip(java.lang.String gaWip)
void | setGaWoic(java.lang.String gaWoic)
void | setGaZero(java.math.BigDecimal gaZero)
void | setGlNdaysOk(int glNdaysOk)
void | setId(java.lang.String id)
void | setInventoryValuation(java.lang.String inventoryValuation)
void | setLaborCost(boolean isLaborCost)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setMachineCost(boolean machineCost)
void | setMaterialValuationStorageVarianceAccount(java.lang.String materialValuationStorageVarianceAccount)
void | setMpoDebitAccount(java.lang.String mpoDebitAccount)
void | setPoDebitAccount(java.lang.String poDebitAccount)
void | setPoVAT(java.lang.String poVAT)
void | setPurchaseOrderPrepay(java.lang.String purchaseOrderPrepay)
void | setSalesOrderPrepay(java.lang.String salesOrderPrepay)
void | setSoCreditAccount(java.lang.String soCreditAccount)
void | setSoVAT(java.lang.String soVAT)
void | setStartWipDate(java.util.Date startWipDate)
void | setUnbilledAccount(java.lang.String unbilledAccount)
void | setUnbilledIncomeAccount(java.lang.String unbilledIncomeAccount)
void | setUseZipCode(boolean useZipCode)
void | setValuationStorageAccount(java.lang.String valuationStorageAccount)
void | setVendorPaymentVarianceAccount(java.lang.String vendorPaymentVarianceAccount)
void | setVersion(java.lang.Integer version)
void | setWoDebitAccount(java.lang.String woDebitAccount)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

AccountingSettingsVO

public AccountingSettingsVO()
default constructor

Method Detail

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getWoDebitAccount

public java.lang.String getWoDebitAccount()

setWoDebitAccount

public void setWoDebitAccount(java.lang.String woDebitAccount)

getPoDebitAccount

public java.lang.String getPoDebitAccount()

setPoDebitAccount

public void setPoDebitAccount(java.lang.String poDebitAccount)

getSoCreditAccount

public java.lang.String getSoCreditAccount()

setSoCreditAccount

public void setSoCreditAccount(java.lang.String soCreditAccount)

getGaInboundFreight

public java.lang.String getGaInboundFreight()

setGaInboundFreight

public void setGaInboundFreight(java.lang.String gaInboundFreight)

getGaOutboundFreight

public java.lang.String getGaOutboundFreight()

setGaOutboundFreight

public void setGaOutboundFreight(java.lang.String gaOutboundFreight)

getGaCogs

public java.lang.String getGaCogs()

setGaCogs

public void setGaCogs(java.lang.String gaCogs)

getGaWoic

public java.lang.String getGaWoic()

setGaWoic

public void setGaWoic(java.lang.String gaWoic)

getGaScrap

public java.lang.String getGaScrap()

setGaScrap

public void setGaScrap(java.lang.String gaScrap)

getGaCogsContra

public java.lang.String getGaCogsContra()

setGaCogsContra

public void setGaCogsContra(java.lang.String gaCogsContra)

getGaBusinessIncome

public java.lang.String getGaBusinessIncome()

setGaBusinessIncome

public void setGaBusinessIncome(java.lang.String gaBusinessIncome)

getGaAp

public java.lang.String getGaAp()

setGaAp

public void setGaAp(java.lang.String gaAp)

getApBatch

public java.lang.String getApBatch()

setApBatch

public void setApBatch(java.lang.String apBatch)

getGaAr

public java.lang.String getGaAr()

setGaAr

public void setGaAr(java.lang.String gaAr)

getGaChecking

public java.lang.String getGaChecking()

setGaChecking

public void setGaChecking(java.lang.String gaChecking)

getGaCheckNo

public java.lang.String getGaCheckNo()

setGaCheckNo

public void setGaCheckNo(java.lang.String gaCheckNo)

getGaZero

public java.math.BigDecimal getGaZero()

setGaZero

public void setGaZero(java.math.BigDecimal gaZero)

getGlNdaysOk

public int getGlNdaysOk()

setGlNdaysOk

public void setGlNdaysOk(int glNdaysOk)

getVersion

public java.lang.Integer getVersion()

getSalesOrderPrepay

public java.lang.String getSalesOrderPrepay()

getPurchaseOrderPrepay

public java.lang.String getPurchaseOrderPrepay()

getCurrentRetainedEarning

public java.lang.String getCurrentRetainedEarning()

getCheckPrintAdjust

public byte getCheckPrintAdjust()

getGaPurchaseDiscount

public java.lang.String getGaPurchaseDiscount()

getInventoryValuation

public java.lang.String getInventoryValuation()

getPoVAT

public java.lang.String getPoVAT()

getSoVAT

public java.lang.String getSoVAT()

setVersion

public void setVersion(java.lang.Integer version)

setSalesOrderPrepay

public void setSalesOrderPrepay(java.lang.String salesOrderPrepay)

setPurchaseOrderPrepay

public void setPurchaseOrderPrepay(java.lang.String purchaseOrderPrepay)

setCurrentRetainedEarning

public void setCurrentRetainedEarning(java.lang.String currentRetainedEarning)

setCheckPrintAdjust

public void setCheckPrintAdjust(byte checkPrintAdjust)

setGaPurchaseDiscount

public void setGaPurchaseDiscount(java.lang.String gaPurchaseDiscount)

setInventoryValuation

public void setInventoryValuation(java.lang.String inventoryValuation)

setPoVAT

public void setPoVAT(java.lang.String poVAT)

setSoVAT

public void setSoVAT(java.lang.String soVAT)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getMpoDebitAccount

public java.lang.String getMpoDebitAccount()

setMpoDebitAccount

public void setMpoDebitAccount(java.lang.String mpoDebitAccount)

getGaEmployeeLabor

public java.lang.String getGaEmployeeLabor()

setGaEmployeeLabor

public void setGaEmployeeLabor(java.lang.String gaEmployeeLabor)

getGaWip

public java.lang.String getGaWip()

setGaWip

public void setGaWip(java.lang.String gaWip)

getArDiscountAccount

public java.lang.String getArDiscountAccount()

setArDiscountAccount

public void setArDiscountAccount(java.lang.String arDiscountAccount)

getArDiscountMethod

public java.lang.String getArDiscountMethod()

setArDiscountMethod

public void setArDiscountMethod(java.lang.String arDiscountMethod)

getApDiscountAccount

public java.lang.String getApDiscountAccount()

setApDiscountAccount

public void setApDiscountAccount(java.lang.String apDiscountAccount)

getApDiscountMethod

public java.lang.String getApDiscountMethod()

setApDiscountMethod

public void setApDiscountMethod(java.lang.String apDiscountMethod)

getArWireFeeAccount

public java.lang.String getArWireFeeAccount()

setArWireFeeAccount

public void setArWireFeeAccount(java.lang.String arWireFeeAccount)

isUseZipCode

public boolean isUseZipCode()

setUseZipCode

public void setUseZipCode(boolean useZipCode)

getAssetDeprCreditAccount

public java.lang.String getAssetDeprCreditAccount()

setAssetDeprCreditAccount

public void setAssetDeprCreditAccount(java.lang.String assetDeprCreditAccount)

isLaborCost

public boolean isLaborCost()

setLaborCost

public void setLaborCost(boolean isLaborCost)

isMachineCost

public boolean isMachineCost()

setMachineCost

public void setMachineCost(boolean machineCost)

getDirectMaterialPriceVarianceAccount

public java.lang.String getDirectMaterialPriceVarianceAccount()

setDirectMaterialPriceVarianceAccount

public void setDirectMaterialPriceVarianceAccount(java.lang.String directMaterialPriceVarianceAccount)

getDirectMaterialUsageVarianceAccount

public java.lang.String getDirectMaterialUsageVarianceAccount()

setDirectMaterialUsageVarianceAccount

public void setDirectMaterialUsageVarianceAccount(java.lang.String directMaterialUsageVarianceAccount)

getStartWipDate

public java.util.Date getStartWipDate()

setStartWipDate

public void setStartWipDate(java.util.Date startWipDate)

getCurrentYearMonth

public java.lang.String getCurrentYearMonth()

setCurrentYearMonth

public void setCurrentYearMonth(java.lang.String currentYearMonth)

getGaExchangeGainsAndLoss

public java.lang.String getGaExchangeGainsAndLoss()

setGaExchangeGainsAndLoss

public void setGaExchangeGainsAndLoss(java.lang.String gaExchangeGainsAndLoss)

getGaProfitForCurrentYear

public java.lang.String getGaProfitForCurrentYear()

setGaProfitForCurrentYear

public void setGaProfitForCurrentYear(java.lang.String gaProfitForCurrentYear)

getValuationStorageAccount

public java.lang.String getValuationStorageAccount()

setValuationStorageAccount

public void setValuationStorageAccount(java.lang.String valuationStorageAccount)

getMaterialValuationStorageVarianceAccount

public java.lang.String getMaterialValuationStorageVarianceAccount()

setMaterialValuationStorageVarianceAccount

public void setMaterialValuationStorageVarianceAccount(java.lang.String materialValuationStorageVarianceAccount)

getUnbilledAccount

public java.lang.String getUnbilledAccount()

setUnbilledAccount

public void setUnbilledAccount(java.lang.String unbilledAccount)

getUnbilledIncomeAccount

public java.lang.String getUnbilledIncomeAccount()

setUnbilledIncomeAccount

public void setUnbilledIncomeAccount(java.lang.String unbilledIncomeAccount)

getVendorPaymentVarianceAccount

public java.lang.String getVendorPaymentVarianceAccount()

setVendorPaymentVarianceAccount

public void setVendorPaymentVarianceAccount(java.lang.String vendorPaymentVarianceAccount)

getGaDep

public java.lang.String getGaDep()

setGaDep

public void setGaDep(java.lang.String gaDep)

getCheckPrintAdjustX

public byte getCheckPrintAdjustX()

setCheckPrintAdjustX

public void setCheckPrintAdjustX(byte checkPrintAdjustX)

getCheckPrintAdjustY

public byte getCheckPrintAdjustY()

setCheckPrintAdjustY

public void setCheckPrintAdjustY(byte checkPrintAdjustY)

getFinancingExpensesAccount

public java.lang.String getFinancingExpensesAccount()

setFinancingExpensesAccount

public void setFinancingExpensesAccount(java.lang.String financingExpensesAccount)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountingTotalMoneyResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountingTotalMoneyResult

java.lang.Object
    extended by  bb.common.AccountingTotalMoneyResult
All Implemented Interfaces:
java.io.Serializable
public class AccountingTotalMoneyResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AccountingTotalMoneyResult()
Method Summary
java.math.BigDecimal | getAmountDue()
java.math.BigDecimal | getAvgMargin()
java.math.BigDecimal | getAvgMarginPercent()
java.lang.String | getCurrency()
java.math.BigDecimal | getDiscountTotal()
java.math.BigDecimal | getFreightTotal()
java.math.BigDecimal | getGrandTotal()
java.math.BigDecimal | getOpenTotal()
java.math.BigDecimal | getShipTotal()
java.math.BigDecimal | getStdMargin()
java.math.BigDecimal | getStdMarginPercent()
java.math.BigDecimal | getSubNetTotal()
java.math.BigDecimal | getTotalNet()
java.math.BigDecimal | getTotalPaid()
java.math.BigDecimal | getTotalTax()
java.math.BigDecimal | getUnitTotal()
void | setAmountDue(java.math.BigDecimal amountDue)
void | setAvgMargin(java.math.BigDecimal avgMargin)
void | setAvgMarginPercent(java.math.BigDecimal avgMarginPercent)
void | setCurrency(java.lang.String currency)
void | setDiscountTotal(java.math.BigDecimal discountTotal)
void | setFreightTotal(java.math.BigDecimal freightTotal)
void | setGrandTotal(java.math.BigDecimal grandTotal)
void | setOpenTotal(java.math.BigDecimal openTotal)
void | setShipTotal(java.math.BigDecimal shipTotal)
void | setStdMargin(java.math.BigDecimal stdMargin)
void | setStdMarginPercent(java.math.BigDecimal stdMarginPercent)
void | setSubNetTotal(java.math.BigDecimal subNetTotal)
void | setTotalNet(java.math.BigDecimal totalNet)
void | setTotalPaid(java.math.BigDecimal totalPaid)
void | setTotalTax(java.math.BigDecimal totalTax)
void | setUnitTotal(java.math.BigDecimal unitTotal)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AccountingTotalMoneyResult

public AccountingTotalMoneyResult()
Method Detail

getTotalNet

public java.math.BigDecimal getTotalNet()

getFreightTotal

public java.math.BigDecimal getFreightTotal()

getUnitTotal

public java.math.BigDecimal getUnitTotal()

getShipTotal

public java.math.BigDecimal getShipTotal()

getCurrency

public java.lang.String getCurrency()

getTotalTax

public java.math.BigDecimal getTotalTax()

getTotalPaid

public java.math.BigDecimal getTotalPaid()

getOpenTotal

public java.math.BigDecimal getOpenTotal()

getGrandTotal

public java.math.BigDecimal getGrandTotal()

setDiscountTotal

public void setDiscountTotal(java.math.BigDecimal discountTotal)

setTotalNet

public void setTotalNet(java.math.BigDecimal totalNet)

setFreightTotal

public void setFreightTotal(java.math.BigDecimal freightTotal)

setUnitTotal

public void setUnitTotal(java.math.BigDecimal unitTotal)

setShipTotal

public void setShipTotal(java.math.BigDecimal shipTotal)

setCurrency

public void setCurrency(java.lang.String currency)

setTotalTax

public void setTotalTax(java.math.BigDecimal totalTax)

setTotalPaid

public void setTotalPaid(java.math.BigDecimal totalPaid)

setOpenTotal

public void setOpenTotal(java.math.BigDecimal openTotal)

setGrandTotal

public void setGrandTotal(java.math.BigDecimal grandTotal)

setAmountDue

public void setAmountDue(java.math.BigDecimal amountDue)

getDiscountTotal

public java.math.BigDecimal getDiscountTotal()

getAmountDue

public java.math.BigDecimal getAmountDue()

getSubNetTotal

public java.math.BigDecimal getSubNetTotal()

setSubNetTotal

public void setSubNetTotal(java.math.BigDecimal subNetTotal)

getAvgMargin

public java.math.BigDecimal getAvgMargin()

setAvgMargin

public void setAvgMargin(java.math.BigDecimal avgMargin)

getStdMargin

public java.math.BigDecimal getStdMargin()

setStdMargin

public void setStdMargin(java.math.BigDecimal stdMargin)

getAvgMarginPercent

public java.math.BigDecimal getAvgMarginPercent()

setAvgMarginPercent

public void setAvgMarginPercent(java.math.BigDecimal avgMarginPercent)

getStdMarginPercent

public java.math.BigDecimal getStdMarginPercent()

setStdMarginPercent

public void setStdMarginPercent(java.math.BigDecimal stdMarginPercent)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountingTransactionTypeVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountingTransactionTypeVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AccountingTransactionTypeVO
All Implemented Interfaces:
java.io.Serializable
public class AccountingTransactionTypeVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AccountingTransactionTypeVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDescription()
java.lang.String | getTransactionType()
int | hashCode()
void | setDescription(java.lang.String description)
void | setTransactionType(java.lang.String transactionType)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

AccountingTransactionTypeVO

public AccountingTransactionTypeVO()
Method Detail

getDescription

public java.lang.String getDescription()

setTransactionType

public void setTransactionType(java.lang.String transactionType)

setDescription

public void setDescription(java.lang.String description)

getTransactionType

public java.lang.String getTransactionType()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountMonthPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountMonthPK

java.lang.Object
    extended by  bb.common.AccountMonthPK
All Implemented Interfaces:
java.io.Serializable
public class AccountMonthPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
AccountMonthPK()
default constructor
AccountMonthPK(java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String month)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAccountNumber()
java.lang.String | getCompanyUnitId()
java.lang.String | getMonth()
int | hashCode()
void | setAccountNumber(java.lang.String accountNumber)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setMonth(java.lang.String month)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

AccountMonthPK

public AccountMonthPK(java.lang.String accountNumber,
                      java.lang.String companyUnitId,
                      java.lang.String month)
full constructor

AccountMonthPK

public AccountMonthPK()
default constructor

Method Detail

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getMonth

public java.lang.String getMonth()

setMonth

public void setMonth(java.lang.String month)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountPayableCheckRunItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountPayableCheckRunItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AccountPayableCheckRunItemVO
All Implemented Interfaces:
java.io.Serializable
public class AccountPayableCheckRunItemVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
AccountPayableCheckRunItemVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getApStatus()
java.math.BigDecimal | getApTotal()
java.lang.String | getCheckNumber()
java.math.BigDecimal | getCheckTotal()
java.lang.String | getCurrency()
CustomerVendorAddressInfoVO | getCustomerAddressInfo()
java.math.BigDecimal | getDue()
java.math.BigDecimal | getExchange()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getMemo()
java.math.BigDecimal | getPaid()
java.util.Date | getPayDate()
PayableCheckRunItemPK | getPk()
java.lang.String | getPoNumber()
java.lang.String | getReceiverNumber()
java.lang.String | getStatus()
java.math.BigDecimal | getToBePaid()
java.lang.String | getTransactionNo()
java.lang.String | getVendorId()
java.lang.String | getVendorInvoice()
java.util.Date | getVendorInvoiceDate()
java.math.BigDecimal | getVendorTotal()
int | getVersion()
int | hashCode()
void | setApStatus(java.lang.String apStatus)
void | setApTotal(java.math.BigDecimal apTotal)
void | setCheckNumber(java.lang.String checkNumber)
void | setCheckTotal(java.math.BigDecimal checkTotal)
void | setCurrency(java.lang.String currency)
void | setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | setDue(java.math.BigDecimal due)
void | setExchange(java.math.BigDecimal exchange)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setMemo(java.lang.String memo)
void | setPaid(java.math.BigDecimal paid)
void | setPayDate(java.util.Date payDate)
void | setPk(PayableCheckRunItemPK pk)
void | setPoNumber(java.lang.String poNumber)
void | setReceiverNumber(java.lang.String receiverNumber)
void | setStatus(java.lang.String status)
void | setToBePaid(java.math.BigDecimal toBePaid)
void | setTransactionNo(java.lang.String transactionNo)
void | setVendorId(java.lang.String vendorId)
void | setVendorInvoice(java.lang.String vendorInvoice)
void | setVendorInvoiceDate(java.util.Date vendorInvoiceDate)
void | setVendorTotal(java.math.BigDecimal vendorTotal)
void | setVersion(int version)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

AccountPayableCheckRunItemVO

public AccountPayableCheckRunItemVO()
default constructor

Method Detail

getPk

public PayableCheckRunItemPK getPk()

setPk

public void setPk(PayableCheckRunItemPK pk)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getCheckNumber

public java.lang.String getCheckNumber()

setCheckNumber

public void setCheckNumber(java.lang.String checkNumber)

getMemo

public java.lang.String getMemo()

setMemo

public void setMemo(java.lang.String memo)

getPoNumber

public java.lang.String getPoNumber()

setPoNumber

public void setPoNumber(java.lang.String poNumber)

getReceiverNumber

public java.lang.String getReceiverNumber()

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getToBePaid

public java.math.BigDecimal getToBePaid()

setToBePaid

public void setToBePaid(java.math.BigDecimal toBePaid)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getExchange

public java.math.BigDecimal getExchange()

setExchange

public void setExchange(java.math.BigDecimal exchange)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getVendorInvoice

public java.lang.String getVendorInvoice()

setVendorInvoice

public void setVendorInvoice(java.lang.String vendorInvoice)

getVendorTotal

public java.math.BigDecimal getVendorTotal()

setVendorTotal

public void setVendorTotal(java.math.BigDecimal vendorTotal)

getVendorInvoiceDate

public java.util.Date getVendorInvoiceDate()

setVendorInvoiceDate

public void setVendorInvoiceDate(java.util.Date vendorInvoiceDate)

getPayDate

public java.util.Date getPayDate()

setPayDate

public void setPayDate(java.util.Date payDate)

getDue

public java.math.BigDecimal getDue()

setDue

public void setDue(java.math.BigDecimal due)

getVersion

public int getVersion()

getApTotal

public java.math.BigDecimal getApTotal()

getPaid

public java.math.BigDecimal getPaid()

getCustomerAddressInfo

public CustomerVendorAddressInfoVO getCustomerAddressInfo()

getCheckTotal

public java.math.BigDecimal getCheckTotal()

getTransactionNo

public java.lang.String getTransactionNo()

getApStatus

public java.lang.String getApStatus()

setVersion

public void setVersion(int version)

setApTotal

public void setApTotal(java.math.BigDecimal apTotal)

setPaid

public void setPaid(java.math.BigDecimal paid)

setCustomerAddressInfo

public void setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)

setCheckTotal

public void setCheckTotal(java.math.BigDecimal checkTotal)

setTransactionNo

public void setTransactionNo(java.lang.String transactionNo)

setApStatus

public void setApStatus(java.lang.String apStatus)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountPayableCheckRunVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountPayableCheckRunVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AccountPayableCheckRunVO
All Implemented Interfaces:
java.io.Serializable
public class AccountPayableCheckRunVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CHECKNUMBER
static java.lang.String | ORDER_BY_CHECKRUNNUMBER
static java.lang.String | ORDER_BY_DATE1
static java.lang.String | ORDER_BY_DATE2
static java.lang.String | ORDER_BY_DATEPAID
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_TRANSACTIONDATE
Constructor Summary
AccountPayableCheckRunVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getChecked()
java.lang.String | getCheckNumber()
java.util.Set | getCheckRunItems()
java.lang.String | getCheckRunNumber()
java.lang.String | getCompanyUnitOfGaAp()
java.lang.String | getCompanyUnitOfGaChecking()
java.util.Date | getDate1()
java.util.Date | getDate2()
java.util.Date | getDatePaid()
java.lang.String | getExclude()
java.lang.String | getGaAp()
java.lang.String | getGaChecking()
java.lang.String | getInclude()
java.lang.String | getMadeBy()
java.lang.String | getStatus()
java.util.Date | getTransactionDate()
int | hashCode()
void | setChecked(java.lang.String checked)
void | setCheckNumber(java.lang.String checkNumber)
void | setCheckRunItems(java.util.Set checkRunItems)
void | setCheckRunNumber(java.lang.String checkRunNumber)
void | setCompanyUnitOfGaAp(java.lang.String companyUnitOfGaAp)
void | setCompanyUnitOfGaChecking(java.lang.String companyUnitOfGaChecking)
void | setDate1(java.util.Date date1)
void | setDate2(java.util.Date date2)
void | setDatePaid(java.util.Date datePaid)
void | setExclude(java.lang.String exclude)
void | setGaAp(java.lang.String gaAp)
void | setGaChecking(java.lang.String gaChecking)
void | setInclude(java.lang.String include)
void | setMadeBy(java.lang.String madeBy)
void | setStatus(java.lang.String status)
void | setTransactionDate(java.util.Date transactionDate)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_CHECKRUNNUMBER

public static final java.lang.String ORDER_BY_CHECKRUNNUMBER
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_CHECKNUMBER

public static final java.lang.String ORDER_BY_CHECKNUMBER
See Also:
Constant Field Values

ORDER_BY_DATEPAID

public static final java.lang.String ORDER_BY_DATEPAID
See Also:
Constant Field Values

ORDER_BY_TRANSACTIONDATE

public static final java.lang.String ORDER_BY_TRANSACTIONDATE
See Also:
Constant Field Values

ORDER_BY_DATE1

public static final java.lang.String ORDER_BY_DATE1
See Also:
Constant Field Values

ORDER_BY_DATE2

public static final java.lang.String ORDER_BY_DATE2
See Also:
Constant Field Values
Constructor Detail

AccountPayableCheckRunVO

public AccountPayableCheckRunVO()
default constructor

Method Detail

getCheckRunNumber

public java.lang.String getCheckRunNumber()

setCheckRunNumber

public void setCheckRunNumber(java.lang.String checkRunNumber)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getCheckNumber

public java.lang.String getCheckNumber()

setCheckNumber

public void setCheckNumber(java.lang.String checkNumber)

getTransactionDate

public java.util.Date getTransactionDate()

setTransactionDate

public void setTransactionDate(java.util.Date transactionDate)

getGaAp

public java.lang.String getGaAp()

setGaAp

public void setGaAp(java.lang.String gaAp)

getGaChecking

public java.lang.String getGaChecking()

setGaChecking

public void setGaChecking(java.lang.String gaChecking)

getInclude

public java.lang.String getInclude()

setInclude

public void setInclude(java.lang.String include)

getExclude

public java.lang.String getExclude()

setExclude

public void setExclude(java.lang.String exclude)

getDate1

public java.util.Date getDate1()

setDate1

public void setDate1(java.util.Date date1)

getDate2

public java.util.Date getDate2()

setDate2

public void setDate2(java.util.Date date2)

getChecked

public java.lang.String getChecked()

setChecked

public void setChecked(java.lang.String checked)

getCheckRunItems

public java.util.Set getCheckRunItems()

getDatePaid

public java.util.Date getDatePaid()

setCheckRunItems

public void setCheckRunItems(java.util.Set checkRunItems)

setDatePaid

public void setDatePaid(java.util.Date datePaid)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getCompanyUnitOfGaAp

public java.lang.String getCompanyUnitOfGaAp()

setCompanyUnitOfGaAp

public void setCompanyUnitOfGaAp(java.lang.String companyUnitOfGaAp)

getCompanyUnitOfGaChecking

public java.lang.String getCompanyUnitOfGaChecking()

setCompanyUnitOfGaChecking

public void setCompanyUnitOfGaChecking(java.lang.String companyUnitOfGaChecking)

getMadeBy

public java.lang.String getMadeBy()

setMadeBy

public void setMadeBy(java.lang.String madeBy)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountPayableCheckVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountPayableCheckVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AccountPayableCheckVO
All Implemented Interfaces:
java.io.Serializable
public class AccountPayableCheckVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CHECKNUMBER
static java.lang.String | ORDER_BY_CHECKRUNNUMBER
static java.lang.String | ORDER_BY_NAME
static java.lang.String | ORDER_BY_VENDORID
Constructor Summary
AccountPayableCheckVO()
default constructor
Method Summary
java.lang.String | getAccountNumber()
java.lang.String | getAddress1()
java.lang.String | getAddress2()
java.lang.String | getCheckNumber()
int | getCheckNumberInt()
java.lang.String | getCheckRunNumber()
java.lang.String | getCity()
java.lang.String | getComment()
java.lang.String | getCompanyUnitId()
java.lang.String | getCountry()
java.lang.String | getCurrency()
java.util.Date | getDatePaid()
java.math.BigDecimal | getExchange()
java.lang.Long | getIi()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getMemo()
java.lang.String | getName()
java.lang.Long | getNumberOfAPs()
java.lang.String | getOrigin()
java.math.BigDecimal | getPaid()
java.lang.String | getPaidExactly()
java.lang.String | getRemitId()
java.lang.String | getState()
java.lang.String | getStatus()
java.lang.String | getTn1()
java.lang.String | getTn2()
java.lang.String | getVendorId()
java.lang.String | getVendorInvoice()
int | getVersion()
java.lang.String | getZip()
void | setAccountNumber(java.lang.String accountNumber)
void | setAddress1(java.lang.String address1)
void | setAddress2(java.lang.String address2)
void | setCheckNumber(java.lang.String checkNumber)
void | setCheckNumberInt(int checkNumberInt)
void | setCheckRunNumber(java.lang.String checkRunNumber)
void | setCity(java.lang.String city)
void | setComment(java.lang.String comment)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCountry(java.lang.String country)
void | setCurrency(java.lang.String currency)
void | setDatePaid(java.util.Date datePaid)
void | setExchange(java.math.BigDecimal exchange)
void | setIi(java.lang.Long ii)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setMemo(java.lang.String memo)
void | setName(java.lang.String name)
void | setNumberOfAPs(java.lang.Long numberOfAPs)
void | setOrigin(java.lang.String origin)
void | setPaid(java.math.BigDecimal paid)
void | setPaidExactly(java.lang.String paidExactly)
void | setRemitId(java.lang.String remitId)
void | setState(java.lang.String state)
void | setStatus(java.lang.String status)
void | setTn1(java.lang.String tn1)
void | setTn2(java.lang.String tn2)
void | setVendorId(java.lang.String vendorId)
void | setVendorInvoice(java.lang.String vendorInvoice)
void | setVersion(int version)
void | setZip(java.lang.String zip)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_CHECKNUMBER

public static final java.lang.String ORDER_BY_CHECKNUMBER
See Also:
Constant Field Values

ORDER_BY_CHECKRUNNUMBER

public static final java.lang.String ORDER_BY_CHECKRUNNUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_NAME

public static final java.lang.String ORDER_BY_NAME
See Also:
Constant Field Values
Constructor Detail

AccountPayableCheckVO

public AccountPayableCheckVO()
default constructor

Method Detail

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getCheckNumberInt

public int getCheckNumberInt()

setCheckNumberInt

public void setCheckNumberInt(int checkNumberInt)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getCheckRunNumber

public java.lang.String getCheckRunNumber()

setCheckRunNumber

public void setCheckRunNumber(java.lang.String checkRunNumber)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getRemitId

public java.lang.String getRemitId()

setRemitId

public void setRemitId(java.lang.String remitId)

getTn1

public java.lang.String getTn1()

setTn1

public void setTn1(java.lang.String tn1)

getTn2

public java.lang.String getTn2()

setTn2

public void setTn2(java.lang.String tn2)

getDatePaid

public java.util.Date getDatePaid()

setDatePaid

public void setDatePaid(java.util.Date datePaid)

getMemo

public java.lang.String getMemo()

setMemo

public void setMemo(java.lang.String memo)

getPaid

public java.math.BigDecimal getPaid()

setPaid

public void setPaid(java.math.BigDecimal paid)

getPaidExactly

public java.lang.String getPaidExactly()

setPaidExactly

public void setPaidExactly(java.lang.String paidExactly)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getExchange

public java.math.BigDecimal getExchange()

setExchange

public void setExchange(java.math.BigDecimal exchange)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getAddress1

public java.lang.String getAddress1()

setAddress1

public void setAddress1(java.lang.String address1)

getAddress2

public java.lang.String getAddress2()

setAddress2

public void setAddress2(java.lang.String address2)

getCity

public java.lang.String getCity()

setCity

public void setCity(java.lang.String city)

getState

public java.lang.String getState()

setState

public void setState(java.lang.String state)

getZip

public java.lang.String getZip()

setZip

public void setZip(java.lang.String zip)

getCountry

public java.lang.String getCountry()

setCountry

public void setCountry(java.lang.String country)

getComment

public java.lang.String getComment()

setComment

public void setComment(java.lang.String comment)

getVersion

public int getVersion()

getNumberOfAPs

public java.lang.Long getNumberOfAPs()

setVersion

public void setVersion(int version)

setNumberOfAPs

public void setNumberOfAPs(java.lang.Long numberOfAPs)

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getCheckNumber

public java.lang.String getCheckNumber()

setCheckNumber

public void setCheckNumber(java.lang.String checkNumber)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getVendorInvoice

public java.lang.String getVendorInvoice()

setVendorInvoice

public void setVendorInvoice(java.lang.String vendorInvoice)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountPayableInfoWithPrepayResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountPayableInfoWithPrepayResult

java.lang.Object
    extended by  bb.common.AccountPayableInfoWithPrepayResult
All Implemented Interfaces:
java.io.Serializable
public class AccountPayableInfoWithPrepayResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AccountPayableInfoWithPrepayResult()
Method Summary
java.math.BigDecimal | getApNet()
java.lang.String | getApNumber()
java.lang.String | getAppNumber()
java.math.BigDecimal | getApPrepay()
java.math.BigDecimal | getApPrepayApply()
java.math.BigDecimal | getApPrepayDue()
java.math.BigDecimal | getApPrepayGl()
java.lang.String | getBuyer()
java.lang.String | getCompanyUnitId()
java.math.BigDecimal | getDue()
java.util.Date | getPayDate()
java.lang.String | getPoNumber()
java.lang.String | getReceiverNumber()
java.lang.String | getStatus()
java.lang.String | getVendorId()
java.lang.String | getVendorInvoice()
java.lang.String | getVendorName()
java.math.BigDecimal | getVendorTotal()
void | setApNet(java.math.BigDecimal apNet)
void | setApNumber(java.lang.String apNumber)
void | setAppNumber(java.lang.String appNumber)
void | setApPrepay(java.math.BigDecimal apPrepay)
void | setApPrepayApply(java.math.BigDecimal apPrepayApply)
void | setApPrepayDue(java.math.BigDecimal apPrepayDue)
void | setApPrepayGl(java.math.BigDecimal apPrepayGl)
void | setBuyer(java.lang.String buyer)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setDue(java.math.BigDecimal due)
void | setPayDate(java.util.Date payDate)
void | setPoNumber(java.lang.String poNumber)
void | setReceiverNumber(java.lang.String receiverNumber)
void | setStatus(java.lang.String status)
void | setVendorId(java.lang.String vendorId)
void | setVendorInvoice(java.lang.String vendorInvoice)
void | setVendorName(java.lang.String vendorName)
void | setVendorTotal(java.math.BigDecimal vendorTotal)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AccountPayableInfoWithPrepayResult

public AccountPayableInfoWithPrepayResult()
Method Detail

getApNet

public java.math.BigDecimal getApNet()

setApNet

public void setApNet(java.math.BigDecimal apNet)

getApNumber

public java.lang.String getApNumber()

setApNumber

public void setApNumber(java.lang.String apNumber)

getAppNumber

public java.lang.String getAppNumber()

setAppNumber

public void setAppNumber(java.lang.String appNumber)

getApPrepay

public java.math.BigDecimal getApPrepay()

setApPrepay

public void setApPrepay(java.math.BigDecimal apPrepay)

getApPrepayDue

public java.math.BigDecimal getApPrepayDue()

setApPrepayDue

public void setApPrepayDue(java.math.BigDecimal apPrepayDue)

getApPrepayGl

public java.math.BigDecimal getApPrepayGl()

setApPrepayGl

public void setApPrepayGl(java.math.BigDecimal apPrepayGl)

getDue

public java.math.BigDecimal getDue()

setDue

public void setDue(java.math.BigDecimal due)

getPayDate

public java.util.Date getPayDate()

setPayDate

public void setPayDate(java.util.Date payDate)

getPoNumber

public java.lang.String getPoNumber()

setPoNumber

public void setPoNumber(java.lang.String poNumber)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getVendorInvoice

public java.lang.String getVendorInvoice()

setVendorInvoice

public void setVendorInvoice(java.lang.String vendorInvoice)

getVendorName

public java.lang.String getVendorName()

setVendorName

public void setVendorName(java.lang.String vendorName)

getVendorTotal

public java.math.BigDecimal getVendorTotal()

setVendorTotal

public void setVendorTotal(java.math.BigDecimal vendorTotal)

getBuyer

public java.lang.String getBuyer()

setBuyer

public void setBuyer(java.lang.String buyer)

getReceiverNumber

public java.lang.String getReceiverNumber()

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getApPrepayApply

public java.math.BigDecimal getApPrepayApply()

setApPrepayApply

public void setApPrepayApply(java.math.BigDecimal apPrepayApply)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountReceivableInfoWithPrepayResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountReceivableInfoWithPrepayResult

java.lang.Object
    extended by  bb.common.AccountReceivableInfoWithPrepayResult
All Implemented Interfaces:
java.io.Serializable
public class AccountReceivableInfoWithPrepayResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_companyUnitId
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_INVOICENUMBER
static java.lang.String | ORDER_BY_NAME
static java.lang.String | ORDER_BY_SALESNUMBER
Constructor Summary
AccountReceivableInfoWithPrepayResult()
Method Summary
java.math.BigDecimal | getAmountDue()
java.lang.String | getArpNumber()
java.math.BigDecimal | getArPrepay()
java.math.BigDecimal | getArPrepayApply()
java.math.BigDecimal | getArPrepayDue()
java.math.BigDecimal | getArPrepayGl()
java.lang.String | getCompanyUnitId()
java.lang.String | getCustomerId()
java.lang.String | getCustomerName()
java.math.BigDecimal | getGrandTotal()
java.lang.String | getInvoiceNumber()
java.util.Date | getPayDate()
java.lang.String | getSalesOrderNumber()
void | setAmountDue(java.math.BigDecimal amountDue)
void | setArpNumber(java.lang.String arpNumber)
void | setArPrepay(java.math.BigDecimal arPrepay)
void | setArPrepayApply(java.math.BigDecimal arPrepayApply)
void | setArPrepayDue(java.math.BigDecimal arPrepayDue)
void | setArPrepayGl(java.math.BigDecimal arPrepayGl)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCustomerId(java.lang.String customerId)
void | setCustomerName(java.lang.String customerName)
void | setGrandTotal(java.math.BigDecimal grandTotal)
void | setInvoiceNumber(java.lang.String invoiceNumber)
void | setPayDate(java.util.Date payDate)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_INVOICENUMBER

public static final java.lang.String ORDER_BY_INVOICENUMBER
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_NAME

public static final java.lang.String ORDER_BY_NAME
See Also:
Constant Field Values

ORDER_BY_SALESNUMBER

public static final java.lang.String ORDER_BY_SALESNUMBER
See Also:
Constant Field Values

ORDER_BY_companyUnitId

public static final java.lang.String ORDER_BY_companyUnitId
See Also:
Constant Field Values
Constructor Detail

AccountReceivableInfoWithPrepayResult

public AccountReceivableInfoWithPrepayResult()
Method Detail

getAmountDue

public java.math.BigDecimal getAmountDue()

setAmountDue

public void setAmountDue(java.math.BigDecimal amountDue)

getArPrepay

public java.math.BigDecimal getArPrepay()

setArPrepay

public void setArPrepay(java.math.BigDecimal arPrepay)

getArPrepayDue

public java.math.BigDecimal getArPrepayDue()

setArPrepayDue

public void setArPrepayDue(java.math.BigDecimal arPrepayDue)

getArPrepayGl

public java.math.BigDecimal getArPrepayGl()

setArPrepayGl

public void setArPrepayGl(java.math.BigDecimal arPrepayGl)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getCustomerName

public java.lang.String getCustomerName()

setCustomerName

public void setCustomerName(java.lang.String customerName)

getGrandTotal

public java.math.BigDecimal getGrandTotal()

setGrandTotal

public void setGrandTotal(java.math.BigDecimal grandTotal)

getInvoiceNumber

public java.lang.String getInvoiceNumber()

setInvoiceNumber

public void setInvoiceNumber(java.lang.String invoiceNumber)

getPayDate

public java.util.Date getPayDate()

setPayDate

public void setPayDate(java.util.Date payDate)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getArpNumber

public java.lang.String getArpNumber()

setArpNumber

public void setArpNumber(java.lang.String arpNumber)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getArPrepayApply

public java.math.BigDecimal getArPrepayApply()

setArPrepayApply

public void setArPrepayApply(java.math.BigDecimal arPrepayApply)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountReceivablePaymentVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountReceivablePaymentVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AccountReceivablePaymentVO
All Implemented Interfaces:
java.io.Serializable
public class AccountReceivablePaymentVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
AccountReceivablePaymentVO()
default constructor
Method Summary
java.lang.String | getAddr1()
java.lang.String | getAddr2()
java.lang.String | getCity()
java.lang.String | getCompanyUnitOfGaChecking()
java.lang.String | getCountry()
java.lang.String | getCurrency()
java.lang.String | getCustomerId()
java.util.Date | getDatePaid()
java.math.BigDecimal | getExchange()
java.lang.String | getGaChecking()
java.lang.Long | getIi()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getMemo()
java.lang.String | getName()
byte | getNnAr()
java.lang.String | getOrigin()
java.math.BigDecimal | getPaid()
java.lang.String | getPaidExactly()
int | getPaymentNoInt()
java.lang.String | getPaymentNumber()
java.lang.String | getPaymentRunNumber()
java.lang.String | getPp()
java.lang.String | getRemitId()
java.lang.String | getState()
java.lang.String | getStatus()
java.lang.String | getTn1()
java.lang.String | getTn2()
int | getVersion()
java.lang.String | getZip()
int | hashCode()
void | setAddr1(java.lang.String addr1)
void | setAddr2(java.lang.String addr2)
void | setCity(java.lang.String city)
void | setCompanyUnitOfGaChecking(java.lang.String companyUnitOfGaChecking)
void | setCountry(java.lang.String country)
void | setCurrency(java.lang.String currency)
void | setCustomerId(java.lang.String customerId)
void | setDatePaid(java.util.Date datePaid)
void | setExchange(java.math.BigDecimal exchange)
void | setGaChecking(java.lang.String gaChecking)
void | setIi(java.lang.Long ii)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setMemo(java.lang.String memo)
void | setName(java.lang.String name)
void | setNnAr(byte nnAr)
void | setOrigin(java.lang.String origin)
void | setPaid(java.math.BigDecimal paid)
void | setPaidExactly(java.lang.String paidExactly)
void | setPaymentNoInt(int paymentNoInt)
void | setPaymentNumber(java.lang.String paymentNumber)
void | setPaymentRunNumber(java.lang.String paymentRunNumber)
void | setPp(java.lang.String pp)
void | setRemitId(java.lang.String remitId)
void | setState(java.lang.String state)
void | setStatus(java.lang.String status)
void | setTn1(java.lang.String tn1)
void | setTn2(java.lang.String tn2)
void | setVersion(int version)
void | setZip(java.lang.String zip)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

AccountReceivablePaymentVO

public AccountReceivablePaymentVO()
default constructor

Method Detail

getGaChecking

public java.lang.String getGaChecking()

setGaChecking

public void setGaChecking(java.lang.String gaChecking)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getPaymentNoInt

public int getPaymentNoInt()

setPaymentNoInt

public void setPaymentNoInt(int paymentNoInt)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getPaymentRunNumber

public java.lang.String getPaymentRunNumber()

setPaymentRunNumber

public void setPaymentRunNumber(java.lang.String paymentRunNumber)

getRemitId

public java.lang.String getRemitId()

setRemitId

public void setRemitId(java.lang.String remitId)

getTn1

public java.lang.String getTn1()

setTn1

public void setTn1(java.lang.String tn1)

getTn2

public java.lang.String getTn2()

setTn2

public void setTn2(java.lang.String tn2)

getNnAr

public byte getNnAr()

setNnAr

public void setNnAr(byte nnAr)

getDatePaid

public java.util.Date getDatePaid()

setDatePaid

public void setDatePaid(java.util.Date datePaid)

getMemo

public java.lang.String getMemo()

setMemo

public void setMemo(java.lang.String memo)

getPaid

public java.math.BigDecimal getPaid()

setPaid

public void setPaid(java.math.BigDecimal paid)

getPaidExactly

public java.lang.String getPaidExactly()

setPaidExactly

public void setPaidExactly(java.lang.String paidExactly)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getExchange

public java.math.BigDecimal getExchange()

setExchange

public void setExchange(java.math.BigDecimal exchange)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getAddr1

public java.lang.String getAddr1()

setAddr1

public void setAddr1(java.lang.String addr1)

getAddr2

public java.lang.String getAddr2()

setAddr2

public void setAddr2(java.lang.String addr2)

getCity

public java.lang.String getCity()

setCity

public void setCity(java.lang.String city)

getState

public java.lang.String getState()

setState

public void setState(java.lang.String state)

getZip

public java.lang.String getZip()

setZip

public void setZip(java.lang.String zip)

getCountry

public java.lang.String getCountry()

setCountry

public void setCountry(java.lang.String country)

getPp

public java.lang.String getPp()

setPp

public void setPp(java.lang.String pp)

getVersion

public int getVersion()

setVersion

public void setVersion(int version)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getPaymentNumber

public java.lang.String getPaymentNumber()

setPaymentNumber

public void setPaymentNumber(java.lang.String paymentNumber)

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getCompanyUnitOfGaChecking

public java.lang.String getCompanyUnitOfGaChecking()

setCompanyUnitOfGaChecking

public void setCompanyUnitOfGaChecking(java.lang.String companyUnitOfGaChecking)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountsChartAdvanceCategoryVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountsChartAdvanceCategoryVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AccountsChartAdvanceCategoryVO
All Implemented Interfaces:
java.io.Serializable
public class AccountsChartAdvanceCategoryVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AccountsChartAdvanceCategoryVO()
Method Summary
byte[] | getData()
java.lang.String | getMonthYear()
java.lang.String | getType()
void | setData(byte[] data)
void | setMonthYear(java.lang.String monthYear)
void | setType(java.lang.String type)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AccountsChartAdvanceCategoryVO

public AccountsChartAdvanceCategoryVO()
Method Detail

getData

public byte[] getData()

setData

public void setData(byte[] data)

getType

public java.lang.String getType()

setType

public void setType(java.lang.String type)

getMonthYear

public java.lang.String getMonthYear()

setMonthYear

public void setMonthYear(java.lang.String monthYear)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountsChartCategoryListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountsChartCategoryListResult

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AccountsChartCategoryVO
            extended by  bb.common.AccountsChartCategoryListResult
All Implemented Interfaces:
java.io.Serializable
public class AccountsChartCategoryListResult
extends AccountsChartCategoryVO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
Fields inherited from class bb.common.AccountsChartCategoryVO
ORDER_BY_CATEGORYNAME, ORDER_BY_DESCRIPTION, ORDER_BY_INDEX
Constructor Summary
AccountsChartCategoryListResult()
Method Summary
java.math.BigDecimal | getBalance()
java.math.BigDecimal | getYearBalance()
void | setBalance(java.math.BigDecimal balance)
void | setYearBalance(java.math.BigDecimal yearBalance)
Methods inherited from class bb.common.AccountsChartCategoryVO
equals, getCategoryName, getCategoryType, getFormula, getIi, getIndex, getParentCategory, getReportType, getYearBalanceFormula, hashCode, isPredefined, isVisibleInReport, setCategoryName, setCategoryType, setFormula, setIi, setIndex, setParentCategory, setPredefined, setReportType, setVisibleInReport, setYearBalanceFormula, toString
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

AccountsChartCategoryListResult

public AccountsChartCategoryListResult()
Method Detail

getBalance

public java.math.BigDecimal getBalance()

setBalance

public void setBalance(java.math.BigDecimal balance)

getYearBalance

public java.math.BigDecimal getYearBalance()

setYearBalance

public void setYearBalance(java.math.BigDecimal yearBalance)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountsChartCategoryVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountsChartCategoryVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AccountsChartCategoryVO
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
AccountsChartCategoryListResult
public class AccountsChartCategoryVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CATEGORYNAME
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_INDEX
Constructor Summary
AccountsChartCategoryVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCategoryName()
java.lang.String | getCategoryType()
java.lang.String | getFormula()
java.lang.Long | getIi()
java.lang.Integer | getIndex()
java.lang.Long | getParentCategory()
java.lang.String | getReportType()
java.lang.String | getYearBalanceFormula()
int | hashCode()
boolean | isPredefined()
boolean | isVisibleInReport()
void | setCategoryName(java.lang.String categoryName)
void | setCategoryType(java.lang.String categoryType)
void | setFormula(java.lang.String formula)
void | setIi(java.lang.Long ii)
void | setIndex(java.lang.Integer index)
void | setParentCategory(java.lang.Long parentCategory)
void | setPredefined(boolean predefined)
void | setReportType(java.lang.String reportType)
void | setVisibleInReport(boolean visibleInReport)
void | setYearBalanceFormula(java.lang.String yearBalanceFormula)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_CATEGORYNAME

public static final java.lang.String ORDER_BY_CATEGORYNAME
See Also:
Constant Field Values

ORDER_BY_INDEX

public static final java.lang.String ORDER_BY_INDEX
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

AccountsChartCategoryVO

public AccountsChartCategoryVO()
Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getCategoryName

public java.lang.String getCategoryName()

setCategoryName

public void setCategoryName(java.lang.String categoryName)

getParentCategory

public java.lang.Long getParentCategory()

setParentCategory

public void setParentCategory(java.lang.Long parentCategory)

getIndex

public java.lang.Integer getIndex()

setIndex

public void setIndex(java.lang.Integer index)

isPredefined

public boolean isPredefined()

setPredefined

public void setPredefined(boolean predefined)

getCategoryType

public java.lang.String getCategoryType()

setCategoryType

public void setCategoryType(java.lang.String categoryType)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getReportType

public java.lang.String getReportType()

setReportType

public void setReportType(java.lang.String reportType)

isVisibleInReport

public boolean isVisibleInReport()

setVisibleInReport

public void setVisibleInReport(boolean visibleInReport)

getFormula

public java.lang.String getFormula()

setFormula

public void setFormula(java.lang.String formula)

getYearBalanceFormula

public java.lang.String getYearBalanceFormula()

setYearBalanceFormula

public void setYearBalanceFormula(java.lang.String yearBalanceFormula)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountsChartMappingPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountsChartMappingPK

java.lang.Object
    extended by  bb.common.AccountsChartMappingPK
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable
public class AccountsChartMappingPK
extends java.lang.Object
implements java.io.Serializable, java.lang.Comparable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
AccountsChartMappingPK()
Method Summary
int | compareTo(java.lang.Object o)
boolean | equals(java.lang.Object other)
java.lang.String | getServerAccountNumber()
java.lang.String | getSubAccountNumber()
java.lang.String | getSubcompanyId()
int | hashCode()
void | setServerAccountNumber(java.lang.String serverAccountNumber)
void | setSubAccountNumber(java.lang.String subAccountNumber)
void | setSubcompanyId(java.lang.String subcompanyId)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

AccountsChartMappingPK

public AccountsChartMappingPK()
Method Detail

getServerAccountNumber

public java.lang.String getServerAccountNumber()

setServerAccountNumber

public void setServerAccountNumber(java.lang.String serverAccountNumber)

getSubAccountNumber

public java.lang.String getSubAccountNumber()

setSubAccountNumber

public void setSubAccountNumber(java.lang.String subAccountNumber)

getSubcompanyId

public java.lang.String getSubcompanyId()

setSubcompanyId

public void setSubcompanyId(java.lang.String subcompanyId)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

compareTo

public int compareTo(java.lang.Object o)
Specified by:
compareTo in interface java.lang.Comparable
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountsChartMappingVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountsChartMappingVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AccountsChartMappingVO
All Implemented Interfaces:
java.io.Serializable
public class AccountsChartMappingVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AccountsChartMappingVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.util.Date | getCreatedDate()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getOrigin()
AccountsChartMappingPK | getPk()
int | hashCode()
void | setComments(java.lang.String comments)
void | setCreatedDate(java.util.Date createdDate)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setOrigin(java.lang.String origin)
void | setPk(AccountsChartMappingPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

AccountsChartMappingVO

public AccountsChartMappingVO()
Method Detail

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getCreatedDate

public java.util.Date getCreatedDate()

setCreatedDate

public void setCreatedDate(java.util.Date createdDate)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getPk

public AccountsChartMappingPK getPk()

setPk

public void setPk(AccountsChartMappingPK pk)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountsChartResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountsChartResult

java.lang.Object
    extended by  bb.common.AccountsChartResult
All Implemented Interfaces:
java.io.Serializable
public class AccountsChartResult
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
AccountsChartResult()
Method Summary
AccountsChartVO | getAccountsChartVO()
java.util.Map<java.util.Date,java.math.BigDecimal> | getActualAccountsChart()
java.util.Map<java.util.Date,java.math.BigDecimal> | getBudgetAccountsChart()
void | setAccountsChartVO(AccountsChartVO accountsChartVO)
void | setActualAccountsChart(java.util.Map<java.util.Date,java.math.BigDecimal> actualAccountsChart)
void | setBudgetAccountsChart(java.util.Map<java.util.Date,java.math.BigDecimal> budgetAccountsChart)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AccountsChartResult

public AccountsChartResult()
Method Detail

getActualAccountsChart

public java.util.Map<java.util.Date,java.math.BigDecimal> getActualAccountsChart()

setActualAccountsChart

public void setActualAccountsChart(java.util.Map<java.util.Date,java.math.BigDecimal> actualAccountsChart)

getBudgetAccountsChart

public java.util.Map<java.util.Date,java.math.BigDecimal> getBudgetAccountsChart()

setBudgetAccountsChart

public void setBudgetAccountsChart(java.util.Map<java.util.Date,java.math.BigDecimal> budgetAccountsChart)

getAccountsChartVO

public AccountsChartVO getAccountsChartVO()

setAccountsChartVO

public void setAccountsChartVO(AccountsChartVO accountsChartVO)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountsChartVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountsChartVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AccountsChartVO
All Implemented Interfaces:
java.io.Serializable
public class AccountsChartVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
AccountsChartVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAccountNumber()
java.lang.String | getAccountSubType()
java.lang.String | getAccountType()
java.util.Date | getAdate()
java.lang.Long | getCategoryId()
java.lang.String | getDebitOrCredit()
java.lang.String | getDeductable()
java.lang.String | getDescription()
byte | getItems()
java.util.Date | getLastChangeDate()
int | getLastChangeTimes()
java.lang.String | getLastChangeUser()
java.lang.String | getLevel()
java.util.Set<MultiLanguageAccountsChartVO> | getMultiLanuageDescription()
java.lang.String | getOrigin()
java.lang.String | getType()
java.lang.String | getUpLevelAccount()
int | hashCode()
boolean | isActive()
boolean | isAuditForeignCurrency()
boolean | isForeignCurrencyAcc()
void | setAccountNumber(java.lang.String accountNumber)
void | setAccountSubType(java.lang.String accountSubType)
void | setAccountType(java.lang.String accountType)
void | setActive(boolean active)
void | setAdate(java.util.Date adate)
void | setAuditForeignCurrency(boolean auditForeignCurrency)
void | setCategoryId(java.lang.Long categoryId)
void | setDebitOrCredit(java.lang.String debitOrCredit)
void | setDeductable(java.lang.String deductable)
void | setDescription(java.lang.String description)
void | setForeignCurrencyAcc(boolean foreignCurrencyAcc)
void | setItems(byte items)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTimes(int lastChangeTimes)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLevel(java.lang.String level)
void | setMultiLanuageDescription(java.util.Set<MultiLanguageAccountsChartVO> multiLanuageDescriptionVO)
void | setOrigin(java.lang.String origin)
void | setType(java.lang.String type)
void | setUpLevelAccount(java.lang.String upLevelAccount)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

AccountsChartVO

public AccountsChartVO()
Method Detail

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getLevel

public java.lang.String getLevel()

setLevel

public void setLevel(java.lang.String level)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getAccountType

public java.lang.String getAccountType()

setAccountType

public void setAccountType(java.lang.String accountType)

getDeductable

public java.lang.String getDeductable()

setDeductable

public void setDeductable(java.lang.String deductable)

getDebitOrCredit

public java.lang.String getDebitOrCredit()

setDebitOrCredit

public void setDebitOrCredit(java.lang.String debitOrCredit)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getLastChangeTimes

public int getLastChangeTimes()

getUpLevelAccount

public java.lang.String getUpLevelAccount()

getItems

public byte getItems()

getType

public java.lang.String getType()

setLastChangeTimes

public void setLastChangeTimes(int lastChangeTimes)

setUpLevelAccount

public void setUpLevelAccount(java.lang.String upLevelAccount)

setItems

public void setItems(byte items)

setType

public void setType(java.lang.String type)

getCategoryId

public java.lang.Long getCategoryId()

setCategoryId

public void setCategoryId(java.lang.Long categoryId)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getMultiLanuageDescription

public java.util.Set<MultiLanguageAccountsChartVO> getMultiLanuageDescription()

setMultiLanuageDescription

public void setMultiLanuageDescription(java.util.Set<MultiLanguageAccountsChartVO> multiLanuageDescriptionVO)

isActive

public boolean isActive()

setActive

public void setActive(boolean active)

getAccountSubType

public java.lang.String getAccountSubType()

setAccountSubType

public void setAccountSubType(java.lang.String accountSubType)

isAuditForeignCurrency

public boolean isAuditForeignCurrency()

setAuditForeignCurrency

public void setAuditForeignCurrency(boolean auditForeignCurrency)

isForeignCurrencyAcc

public boolean isForeignCurrencyAcc()

setForeignCurrencyAcc

public void setForeignCurrencyAcc(boolean foreignCurrencyAcc)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountsCreditDebitListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountsCreditDebitListResult

java.lang.Object
    extended by  bb.common.AccountsCreditDebitListResult
All Implemented Interfaces:
Alarmable, java.io.Serializable
public class AccountsCreditDebitListResult
extends java.lang.Object
implements Alarmable, java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACCOUNTNUMBER
static java.lang.String | ORDER_BY_TRANSACTIONDATE
static java.lang.String | ORDER_BY_TRANSACTIONNO
static java.lang.String | ORDER_BY_TRANSACTIONTYPE
Constructor Summary
AccountsCreditDebitListResult()
Method Summary
java.lang.String | getAccountNumber()
boolean | getAlarmValue()
java.lang.String | getCause()
java.math.BigDecimal | getCreditDebit()
java.lang.String | getDescription()
java.util.Date | getTransactionDate()
java.lang.String | getTransactionNo()
java.lang.String | getTransactionType()
void | setAccountNumber(java.lang.String accountNumber)
void | setAlarmValue(boolean alarmValue)
void | setCause(java.lang.String cause)
void | setCreditDebit(java.math.BigDecimal creditDebit)
void | setDescription(java.lang.String description)
void | setTransactionDate(java.util.Date transactionDate)
void | setTransactionNo(java.lang.String transactionNo)
void | setTransactionType(java.lang.String transactionType)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_TRANSACTIONNO

public static final java.lang.String ORDER_BY_TRANSACTIONNO
See Also:
Constant Field Values

ORDER_BY_TRANSACTIONDATE

public static final java.lang.String ORDER_BY_TRANSACTIONDATE
See Also:
Constant Field Values

ORDER_BY_TRANSACTIONTYPE

public static final java.lang.String ORDER_BY_TRANSACTIONTYPE
See Also:
Constant Field Values

ORDER_BY_ACCOUNTNUMBER

public static final java.lang.String ORDER_BY_ACCOUNTNUMBER
See Also:
Constant Field Values
Constructor Detail

AccountsCreditDebitListResult

public AccountsCreditDebitListResult()
Method Detail

setTransactionNo

public void setTransactionNo(java.lang.String transactionNo)

setTransactionDate

public void setTransactionDate(java.util.Date transactionDate)

setTransactionType

public void setTransactionType(java.lang.String transactionType)

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

setCreditDebit

public void setCreditDebit(java.math.BigDecimal creditDebit)

setDescription

public void setDescription(java.lang.String description)

getTransactionNo

public java.lang.String getTransactionNo()

getTransactionDate

public java.util.Date getTransactionDate()

getTransactionType

public java.lang.String getTransactionType()

getAccountNumber

public java.lang.String getAccountNumber()

getCreditDebit

public java.math.BigDecimal getCreditDebit()

getDescription

public java.lang.String getDescription()

getAlarmValue

public boolean getAlarmValue()
Specified by:
getAlarmValue in interface Alarmable

setAlarmValue

public void setAlarmValue(boolean alarmValue)
Specified by:
setAlarmValue in interface Alarmable

getCause

public java.lang.String getCause()
Specified by:
getCause in interface Alarmable

setCause

public void setCause(java.lang.String cause)
Specified by:
setCause in interface Alarmable
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountsPayableInfoVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountsPayableInfoVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AccountsPayableInfoVO
All Implemented Interfaces:
java.io.Serializable
public class AccountsPayableInfoVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_APFREIGHT
static java.lang.String | ORDER_BY_APNET
static java.lang.String | ORDER_BY_APNUMBER
static java.lang.String | ORDER_BY_APPAIDRCV
static java.lang.String | ORDER_BY_APTAX
static java.lang.String | ORDER_BY_BUYER
static java.lang.String | ORDER_BY_COMPANYUNITID
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_DEBITACCOUNT
static java.lang.String | ORDER_BY_DUE
static java.lang.String | ORDER_BY_NAME
static java.lang.String | ORDER_BY_PAYDATE
static java.lang.String | ORDER_BY_PONUMBER
static java.lang.String | ORDER_BY_RECEIVERNUMBER
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_VENDORINVOICE
static java.lang.String | ORDER_BY_VENDORINVOICEDATE
static java.lang.String | ORDER_BY_VENDORPACKAGE
static java.lang.String | ORDER_BY_VENDORTOTAL
Constructor Summary
AccountsPayableInfoVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.util.Date | getApDate()
java.math.BigDecimal | getApDiscount()
java.math.BigDecimal | getApFreight()
java.math.BigDecimal | getApGl1Recorded()
java.math.BigDecimal | getApGl2Paid()
java.math.BigDecimal | getApNet()
java.lang.String | getApNetSet()
java.lang.String | getApNumber()
java.math.BigDecimal | getApOpen()
java.math.BigDecimal | getApPaidGl()
java.math.BigDecimal | getApPaidRcv()
java.math.BigDecimal | getApRecieved()
java.math.BigDecimal | getApSub()
java.math.BigDecimal | getApTax()
java.lang.String | getApTaxSet()
java.math.BigDecimal | getApTotal()
java.lang.String | getBatch()
java.lang.String | getBp()
java.lang.String | getBuyer()
java.lang.String | getCarrier()
java.lang.String | getCarrierAccount()
java.lang.String | getChangeOrder()
java.lang.String | getCheckNumber()
java.lang.String | getCollect()
java.lang.String | getComments()
java.lang.String | getCompanyUnitId()
java.lang.String | getCurrency()
CustomerVendorAddressInfoVO | getCustomerAddressInfo()
java.util.Date | getDatePaid()
java.util.Date | getDateReceived()
java.lang.String | getDebitAccount()
java.lang.String | getDeliveredTo()
java.math.BigDecimal | getDue()
EmployeeCardVO | getEmployee()
java.lang.String | getEtran()
java.math.BigDecimal | getExchange()
java.lang.String | getFreightBill()
java.lang.String | getFreightWho()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getItran()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getNotes()
java.lang.String | getOrigin()
java.math.BigDecimal | getPaid()
java.util.Date | getPayDate()
java.lang.String | getPoNumber()
java.lang.String | getProject()
java.lang.String | getReceivedBy()
java.lang.String | getReceiverNumber()
java.lang.String | getReldoc()
java.lang.String | getRequestor()
java.lang.String | getShippedVia()
java.lang.String | getStatus()
java.lang.String | getTerms()
java.math.BigDecimal | getTermsDiscount()
java.lang.String | getTermsDiscountDay()
java.lang.String | getTermsDiscountPercent()
java.lang.String | getTracking()
java.lang.String | getVendorId()
java.lang.String | getVendorInvoice()
java.util.Date | getVendorInvoiceDate()
java.lang.String | getVendorPackage()
java.math.BigDecimal | getVendorTotal()
java.lang.Integer | getVersion()
int | hashCode()
void | setAdate(java.util.Date adate)
void | setApDate(java.util.Date apDate)
void | setApDiscount(java.math.BigDecimal apDiscount)
void | setApFreight(java.math.BigDecimal apFreight)
void | setApGl1Recorded(java.math.BigDecimal apGl1Recorded)
void | setApGl2Paid(java.math.BigDecimal apGl2Paid)
void | setApNet(java.math.BigDecimal apNet)
void | setApNetSet(java.lang.String apNetSet)
void | setApNumber(java.lang.String apNumber)
void | setApOpen(java.math.BigDecimal apOpen)
void | setApPaidGl(java.math.BigDecimal apPaidGl)
void | setApPaidRcv(java.math.BigDecimal apPaidRcv)
void | setApRecieved(java.math.BigDecimal apRecieved)
void | setApSub(java.math.BigDecimal apSub)
void | setApTax(java.math.BigDecimal apTax)
void | setApTaxSet(java.lang.String apTaxSet)
void | setApTotal(java.math.BigDecimal apTotal)
void | setBatch(java.lang.String batch)
void | setBp(java.lang.String bp)
void | setBuyer(java.lang.String buyer)
void | setCarrier(java.lang.String carrier)
void | setCarrierAccount(java.lang.String carrierAccount)
void | setChangeOrder(java.lang.String changeOrder)
void | setCheckNumber(java.lang.String checkNumber)
void | setCollect(java.lang.String collect)
void | setComments(java.lang.String comments)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCurrency(java.lang.String currency)
void | setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | setDatePaid(java.util.Date datePaid)
void | setDateReceived(java.util.Date dateReceived)
void | setDebitAccount(java.lang.String debitAccount)
void | setDeliveredTo(java.lang.String deliveredTo)
void | setDue(java.math.BigDecimal due)
void | setEmployee(EmployeeCardVO employee)
void | setEtran(java.lang.String etran)
void | setExchange(java.math.BigDecimal exchange)
void | setFreightBill(java.lang.String freightBill)
void | setFreightWho(java.lang.String freightWho)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setItran(java.lang.String itran)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setNotes(java.lang.String notes)
void | setOrigin(java.lang.String origin)
void | setPaid(java.math.BigDecimal paid)
void | setPayDate(java.util.Date payDate)
void | setPoNumber(java.lang.String poNumber)
void | setProject(java.lang.String project)
void | setReceivedBy(java.lang.String receivedBy)
void | setReceiverNumber(java.lang.String receiverNumber)
void | setReldoc(java.lang.String reldoc)
void | setRequestor(java.lang.String requestor)
void | setShippedVia(java.lang.String shippedVia)
void | setStatus(java.lang.String status)
void | setTerms(java.lang.String terms)
void | setTermsDiscount(java.math.BigDecimal termsDiscount)
void | setTermsDiscountDay(java.lang.String termsDiscountDay)
void | setTermsDiscountPercent(java.lang.String termsDiscountPercent)
void | setTracking(java.lang.String tracking)
void | setVendorId(java.lang.String vendorId)
void | setVendorInvoice(java.lang.String vendorInvoice)
void | setVendorInvoiceDate(java.util.Date vendorInvoiceDate)
void | setVendorPackage(java.lang.String vendorPackage)
void | setVendorTotal(java.math.BigDecimal vendorTotal)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_NAME

public static final java.lang.String ORDER_BY_NAME
See Also:
Constant Field Values

ORDER_BY_APNUMBER

public static final java.lang.String ORDER_BY_APNUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORINVOICE

public static final java.lang.String ORDER_BY_VENDORINVOICE
See Also:
Constant Field Values

ORDER_BY_VENDORTOTAL

public static final java.lang.String ORDER_BY_VENDORTOTAL
See Also:
Constant Field Values

ORDER_BY_APNET

public static final java.lang.String ORDER_BY_APNET
See Also:
Constant Field Values

ORDER_BY_DUE

public static final java.lang.String ORDER_BY_DUE
See Also:
Constant Field Values

ORDER_BY_PAYDATE

public static final java.lang.String ORDER_BY_PAYDATE
See Also:
Constant Field Values

ORDER_BY_PONUMBER

public static final java.lang.String ORDER_BY_PONUMBER
See Also:
Constant Field Values

ORDER_BY_RECEIVERNUMBER

public static final java.lang.String ORDER_BY_RECEIVERNUMBER
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_BUYER

public static final java.lang.String ORDER_BY_BUYER
See Also:
Constant Field Values

ORDER_BY_DEBITACCOUNT

public static final java.lang.String ORDER_BY_DEBITACCOUNT
See Also:
Constant Field Values

ORDER_BY_COMPANYUNITID

public static final java.lang.String ORDER_BY_COMPANYUNITID
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values

ORDER_BY_VENDORPACKAGE

public static final java.lang.String ORDER_BY_VENDORPACKAGE
See Also:
Constant Field Values

ORDER_BY_APFREIGHT

public static final java.lang.String ORDER_BY_APFREIGHT
See Also:
Constant Field Values

ORDER_BY_APTAX

public static final java.lang.String ORDER_BY_APTAX
See Also:
Constant Field Values

ORDER_BY_VENDORINVOICEDATE

public static final java.lang.String ORDER_BY_VENDORINVOICEDATE
See Also:
Constant Field Values

ORDER_BY_APPAIDRCV

public static final java.lang.String ORDER_BY_APPAIDRCV
See Also:
Constant Field Values
Constructor Detail

AccountsPayableInfoVO

public AccountsPayableInfoVO()
default constructor

Method Detail

getApNumber

public java.lang.String getApNumber()

setApNumber

public void setApNumber(java.lang.String apNumber)

getPoNumber

public java.lang.String getPoNumber()

setPoNumber

public void setPoNumber(java.lang.String poNumber)

getReceiverNumber

public java.lang.String getReceiverNumber()

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getBatch

public java.lang.String getBatch()

setBatch

public void setBatch(java.lang.String batch)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getApNetSet

public java.lang.String getApNetSet()

setApNetSet

public void setApNetSet(java.lang.String apNetSet)

getApTaxSet

public java.lang.String getApTaxSet()

setApTaxSet

public void setApTaxSet(java.lang.String apTaxSet)

getApSub

public java.math.BigDecimal getApSub()

setApSub

public void setApSub(java.math.BigDecimal apSub)

getApRecieved

public java.math.BigDecimal getApRecieved()

setApRecieved

public void setApRecieved(java.math.BigDecimal apRecieved)

getApOpen

public java.math.BigDecimal getApOpen()

setApOpen

public void setApOpen(java.math.BigDecimal apOpen)

getApDiscount

public java.math.BigDecimal getApDiscount()

setApDiscount

public void setApDiscount(java.math.BigDecimal apDiscount)

getApNet

public java.math.BigDecimal getApNet()

setApNet

public void setApNet(java.math.BigDecimal apNet)

getApTax

public java.math.BigDecimal getApTax()

setApTax

public void setApTax(java.math.BigDecimal apTax)

getApFreight

public java.math.BigDecimal getApFreight()

setApFreight

public void setApFreight(java.math.BigDecimal apFreight)

getApTotal

public java.math.BigDecimal getApTotal()

setApTotal

public void setApTotal(java.math.BigDecimal apTotal)

getApPaidRcv

public java.math.BigDecimal getApPaidRcv()

setApPaidRcv

public void setApPaidRcv(java.math.BigDecimal apPaidRcv)

getApPaidGl

public java.math.BigDecimal getApPaidGl()

setApPaidGl

public void setApPaidGl(java.math.BigDecimal apPaidGl)

getApGl1Recorded

public java.math.BigDecimal getApGl1Recorded()

setApGl1Recorded

public void setApGl1Recorded(java.math.BigDecimal apGl1Recorded)

getApGl2Paid

public java.math.BigDecimal getApGl2Paid()

setApGl2Paid

public void setApGl2Paid(java.math.BigDecimal apGl2Paid)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getCollect

public java.lang.String getCollect()

setCollect

public void setCollect(java.lang.String collect)

getFreightWho

public java.lang.String getFreightWho()

setFreightWho

public void setFreightWho(java.lang.String freightWho)

getReceivedBy

public java.lang.String getReceivedBy()

setReceivedBy

public void setReceivedBy(java.lang.String receivedBy)

getDateReceived

public java.util.Date getDateReceived()

setDateReceived

public void setDateReceived(java.util.Date dateReceived)

getDeliveredTo

public java.lang.String getDeliveredTo()

setDeliveredTo

public void setDeliveredTo(java.lang.String deliveredTo)

getFreightBill

public java.lang.String getFreightBill()

setFreightBill

public void setFreightBill(java.lang.String freightBill)

getShippedVia

public java.lang.String getShippedVia()

setShippedVia

public void setShippedVia(java.lang.String shippedVia)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAccount

public java.lang.String getCarrierAccount()

setCarrierAccount

public void setCarrierAccount(java.lang.String carrierAccount)

getTracking

public java.lang.String getTracking()

setTracking

public void setTracking(java.lang.String tracking)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getExchange

public java.math.BigDecimal getExchange()

setExchange

public void setExchange(java.math.BigDecimal exchange)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getRequestor

public java.lang.String getRequestor()

setRequestor

public void setRequestor(java.lang.String requestor)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

getReldoc

public java.lang.String getReldoc()

setReldoc

public void setReldoc(java.lang.String reldoc)

getBp

public java.lang.String getBp()

setBp

public void setBp(java.lang.String bp)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getNotes

public java.lang.String getNotes()

setNotes

public void setNotes(java.lang.String notes)

getDue

public java.math.BigDecimal getDue()

setDue

public void setDue(java.math.BigDecimal due)

getVendorInvoice

public java.lang.String getVendorInvoice()

setVendorInvoice

public void setVendorInvoice(java.lang.String vendorInvoice)

getVendorPackage

public java.lang.String getVendorPackage()

setVendorPackage

public void setVendorPackage(java.lang.String vendorPackage)

getVendorTotal

public java.math.BigDecimal getVendorTotal()

setVendorTotal

public void setVendorTotal(java.math.BigDecimal vendorTotal)

getVendorInvoiceDate

public java.util.Date getVendorInvoiceDate()

setVendorInvoiceDate

public void setVendorInvoiceDate(java.util.Date vendorInvoiceDate)

getPayDate

public java.util.Date getPayDate()

setPayDate

public void setPayDate(java.util.Date payDate)

getDatePaid

public java.util.Date getDatePaid()

setDatePaid

public void setDatePaid(java.util.Date datePaid)

getCheckNumber

public java.lang.String getCheckNumber()

setCheckNumber

public void setCheckNumber(java.lang.String checkNumber)

getPaid

public java.math.BigDecimal getPaid()

setPaid

public void setPaid(java.math.BigDecimal paid)

getItran

public java.lang.String getItran()

setItran

public void setItran(java.lang.String itran)

getEtran

public java.lang.String getEtran()

setEtran

public void setEtran(java.lang.String etran)

getVersion

public java.lang.Integer getVersion()

setVersion

public void setVersion(java.lang.Integer version)

getEmployee

public EmployeeCardVO getEmployee()

getCustomerAddressInfo

public CustomerVendorAddressInfoVO getCustomerAddressInfo()

getDebitAccount

public java.lang.String getDebitAccount()

getBuyer

public java.lang.String getBuyer()

getTermsDiscountPercent

public java.lang.String getTermsDiscountPercent()

getTermsDiscountDay

public java.lang.String getTermsDiscountDay()

getTermsDiscount

public java.math.BigDecimal getTermsDiscount()

setEmployee

public void setEmployee(EmployeeCardVO employee)

setCustomerAddressInfo

public void setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

setBuyer

public void setBuyer(java.lang.String buyer)

setTermsDiscountPercent

public void setTermsDiscountPercent(java.lang.String termsDiscountPercent)

setTermsDiscountDay

public void setTermsDiscountDay(java.lang.String termsDiscountDay)

setTermsDiscount

public void setTermsDiscount(java.math.BigDecimal termsDiscount)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getApDate

public java.util.Date getApDate()

setApDate

public void setApDate(java.util.Date apDate)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountsPayableItemManufacturerPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountsPayableItemManufacturerPK

java.lang.Object
    extended by  bb.common.AccountsPayableItemManufacturerPK
All Implemented Interfaces:
java.io.Serializable
public class AccountsPayableItemManufacturerPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AccountsPayableItemManufacturerPK()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getApNumber()
java.lang.Short | getItemNumber()
java.lang.String | getPurchaseOrderItemNumber()
int | hashCode()
void | setApNumber(java.lang.String apNumber)
void | setItemNumber(java.lang.Short itemNumber)
void | setPurchaseOrderItemNumber(java.lang.String purchaseOrderItemNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

AccountsPayableItemManufacturerPK

public AccountsPayableItemManufacturerPK()
Method Detail

setApNumber

public void setApNumber(java.lang.String apNumber)

getApNumber

public java.lang.String getApNumber()

setPurchaseOrderItemNumber

public void setPurchaseOrderItemNumber(java.lang.String purchaseOrderItemNumber)

getPurchaseOrderItemNumber

public java.lang.String getPurchaseOrderItemNumber()

setItemNumber

public void setItemNumber(java.lang.Short itemNumber)

getItemNumber

public java.lang.Short getItemNumber()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountsPayableItemManufacturerVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountsPayableItemManufacturerVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AccountsPayableItemManufacturerVO
All Implemented Interfaces:
java.io.Serializable
public class AccountsPayableItemManufacturerVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AccountsPayableItemManufacturerVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getManufacturerName()
java.lang.String | getManufacturerPartNumber()
AccountsPayableItemManufacturerPK | getPk()
int | hashCode()
void | setManufacturerName(java.lang.String manufacturerName)
void | setManufacturerPartNumber(java.lang.String manufacturerPartNumber)
void | setPk(AccountsPayableItemManufacturerPK pk)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

AccountsPayableItemManufacturerVO

public AccountsPayableItemManufacturerVO()
Method Detail

getPk

public AccountsPayableItemManufacturerPK getPk()

setPk

public void setPk(AccountsPayableItemManufacturerPK pk)

getManufacturerName

public java.lang.String getManufacturerName()

setManufacturerName

public void setManufacturerName(java.lang.String manufacturerName)

getManufacturerPartNumber

public java.lang.String getManufacturerPartNumber()

setManufacturerPartNumber

public void setManufacturerPartNumber(java.lang.String manufacturerPartNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountsPayableItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountsPayableItemPK

java.lang.Object
    extended by  bb.common.AccountsPayableItemPK
All Implemented Interfaces:
java.io.Serializable
public class AccountsPayableItemPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
AccountsPayableItemPK()
default constructor
AccountsPayableItemPK(java.lang.String apNumber, java.lang.String apItemNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getApItemNumber()
java.lang.String | getApNumber()
int | hashCode()
void | setApItemNumber(java.lang.String apItemNumber)
void | setApNumber(java.lang.String apNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

AccountsPayableItemPK

public AccountsPayableItemPK(java.lang.String apNumber,
                             java.lang.String apItemNumber)
full constructor

AccountsPayableItemPK

public AccountsPayableItemPK()
default constructor

Method Detail

getApNumber

public java.lang.String getApNumber()

setApNumber

public void setApNumber(java.lang.String apNumber)

getApItemNumber

public java.lang.String getApItemNumber()

setApItemNumber

public void setApItemNumber(java.lang.String apItemNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountsPayableItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountsPayableItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AccountsPayableItemVO
All Implemented Interfaces:
java.io.Serializable
public class AccountsPayableItemVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
AccountsPayableItemVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAccountNumber()
java.util.Set | getAccountsPayableItemManufacturer()
java.math.BigDecimal | getApDiscount()
java.math.BigDecimal | getApNet()
java.math.BigDecimal | getApOpen()
java.math.BigDecimal | getApReceived()
java.math.BigDecimal | getApSub()
java.math.BigDecimal | getApTax()
java.math.BigDecimal | getApTotal()
java.lang.String | getCheckNumber()
java.lang.String | getComments()
java.lang.String | getCondition()
java.math.BigDecimal | getCost()
java.util.Date | getDatePaid()
java.lang.String | getDescription()
java.math.BigDecimal | getDiscount()
java.math.BigDecimal | getDue()
java.lang.String | getLocation()
java.lang.String | getMfg()
java.lang.String | getMoldeNumber()
java.lang.String | getMpn()
java.lang.String | getNotes()
java.math.BigDecimal | getPaid()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
AccountsPayableItemPK | getPk()
java.lang.String | getPoNumber()
java.math.BigDecimal | getPoRecQty()
java.lang.String | getProductCode()
java.lang.String | getQr()
java.math.BigDecimal | getQtyReceived()
java.math.BigDecimal | getQtyTraced()
java.math.BigDecimal | getQuantity()
java.lang.String | getReceivedBy()
java.lang.String | getReceiverItemNumber()
java.lang.String | getReceiverNumber()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.util.Set | getRefDocOnes()
java.util.Set | getRefDocTwoes()
java.lang.String | getRevision()
java.lang.String | getSentTo()
java.lang.String | getSerial()
java.lang.String | getStatus()
java.math.BigDecimal | getStdCost()
java.math.BigDecimal | getTaxRate()
java.lang.String | getUnit()
int | hashCode()
void | setAccountNumber(java.lang.String accountNumber)
void | setAccountsPayableItemManufacturer(java.util.Set accountsPayableItemManufacturer)
void | setApDiscount(java.math.BigDecimal apDiscount)
void | setApNet(java.math.BigDecimal apNet)
void | setApOpen(java.math.BigDecimal apOpen)
void | setApReceived(java.math.BigDecimal apReceived)
void | setApSub(java.math.BigDecimal apSub)
void | setApTax(java.math.BigDecimal apTax)
void | setApTotal(java.math.BigDecimal apTotal)
void | setCheckNumber(java.lang.String checkNumber)
void | setComments(java.lang.String comments)
void | setCondition(java.lang.String condition)
void | setCost(java.math.BigDecimal cost)
void | setDatePaid(java.util.Date datePaid)
void | setDescription(java.lang.String description)
void | setDiscount(java.math.BigDecimal discount)
void | setDue(java.math.BigDecimal due)
void | setLocation(java.lang.String location)
void | setMfg(java.lang.String mfg)
void | setMoldeNumber(java.lang.String moldeNumber)
void | setMpn(java.lang.String mpn)
void | setNotes(java.lang.String notes)
void | setPaid(java.math.BigDecimal paid)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(AccountsPayableItemPK pk)
void | setPoNumber(java.lang.String poNumber)
void | setPoRecQty(java.math.BigDecimal poRecQty)
void | setProductCode(java.lang.String productCode)
void | setQr(java.lang.String qr)
void | setQtyReceived(java.math.BigDecimal qtyReceived)
void | setQtyTraced(java.math.BigDecimal qtyTraced)
void | setQuantity(java.math.BigDecimal quantity)
void | setReceivedBy(java.lang.String receivedBy)
void | setReceiverItemNumber(java.lang.String receiverItemNumber)
void | setReceiverNumber(java.lang.String receiverNumber)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setRefDocOnes(java.util.Set refDocOnes)
void | setRefDocTwoes(java.util.Set refDocTwoes)
void | setRevision(java.lang.String revision)
void | setSentTo(java.lang.String sentTo)
void | setSerial(java.lang.String serial)
void | setStatus(java.lang.String status)
void | setStdCost(java.math.BigDecimal stdCost)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setUnit(java.lang.String unit)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

AccountsPayableItemVO

public AccountsPayableItemVO()
default constructor

Method Detail

getPk

public AccountsPayableItemPK getPk()

setPk

public void setPk(AccountsPayableItemPK pk)

getPoNumber

public java.lang.String getPoNumber()

setPoNumber

public void setPoNumber(java.lang.String poNumber)

getApSub

public java.math.BigDecimal getApSub()

setApSub

public void setApSub(java.math.BigDecimal apSub)

getApReceived

public java.math.BigDecimal getApReceived()

setApReceived

public void setApReceived(java.math.BigDecimal apReceived)

getApOpen

public java.math.BigDecimal getApOpen()

setApOpen

public void setApOpen(java.math.BigDecimal apOpen)

getApDiscount

public java.math.BigDecimal getApDiscount()

setApDiscount

public void setApDiscount(java.math.BigDecimal apDiscount)

getApNet

public java.math.BigDecimal getApNet()

setApNet

public void setApNet(java.math.BigDecimal apNet)

getApTax

public java.math.BigDecimal getApTax()

setApTax

public void setApTax(java.math.BigDecimal apTax)

getApTotal

public java.math.BigDecimal getApTotal()

setApTotal

public void setApTotal(java.math.BigDecimal apTotal)

getDue

public java.math.BigDecimal getDue()

setDue

public void setDue(java.math.BigDecimal due)

getPaid

public java.math.BigDecimal getPaid()

setPaid

public void setPaid(java.math.BigDecimal paid)

getDatePaid

public java.util.Date getDatePaid()

setDatePaid

public void setDatePaid(java.util.Date datePaid)

getCheckNumber

public java.lang.String getCheckNumber()

setCheckNumber

public void setCheckNumber(java.lang.String checkNumber)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getQr

public java.lang.String getQr()

setQr

public void setQr(java.lang.String qr)

getSentTo

public java.lang.String getSentTo()

setSentTo

public void setSentTo(java.lang.String sentTo)

getReceivedBy

public java.lang.String getReceivedBy()

setReceivedBy

public void setReceivedBy(java.lang.String receivedBy)

getCondition

public java.lang.String getCondition()

setCondition

public void setCondition(java.lang.String condition)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getMoldeNumber

public java.lang.String getMoldeNumber()

setMoldeNumber

public void setMoldeNumber(java.lang.String moldeNumber)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getQtyTraced

public java.math.BigDecimal getQtyTraced()

setQtyTraced

public void setQtyTraced(java.math.BigDecimal qtyTraced)

getQtyReceived

public java.math.BigDecimal getQtyReceived()

setQtyReceived

public void setQtyReceived(java.math.BigDecimal qtyReceived)

getCost

public java.math.BigDecimal getCost()

setCost

public void setCost(java.math.BigDecimal cost)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getSerial

public java.lang.String getSerial()

setSerial

public void setSerial(java.lang.String serial)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getNotes

public java.lang.String getNotes()

getRefDocOnes

public java.util.Set getRefDocOnes()

getPoRecQty

public java.math.BigDecimal getPoRecQty()

setNotes

public void setNotes(java.lang.String notes)

getRefDocTwoes

public java.util.Set getRefDocTwoes()

setRefDocTwoes

public void setRefDocTwoes(java.util.Set refDocTwoes)

setRefDocOnes

public void setRefDocOnes(java.util.Set refDocOnes)

setPoRecQty

public void setPoRecQty(java.math.BigDecimal poRecQty)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getAccountsPayableItemManufacturer

public java.util.Set getAccountsPayableItemManufacturer()

setAccountsPayableItemManufacturer

public void setAccountsPayableItemManufacturer(java.util.Set accountsPayableItemManufacturer)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getReceiverItemNumber

public java.lang.String getReceiverItemNumber()

setReceiverItemNumber

public void setReceiverItemNumber(java.lang.String receiverItemNumber)

getReceiverNumber

public java.lang.String getReceiverNumber()

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getProductCode

public java.lang.String getProductCode()

setProductCode

public void setProductCode(java.lang.String productCode)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountsPayableVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountsPayableVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AccountsPayableVO
All Implemented Interfaces:
java.io.Serializable
public class AccountsPayableVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
AccountsPayableVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Set<AccountsPayableItemVO> | getAccountsPayableItems()
java.util.Date | getAdate()
java.util.Date | getApDate()
java.math.BigDecimal | getApDiscount()
java.math.BigDecimal | getApFreight()
java.math.BigDecimal | getApGl1Recorded()
java.math.BigDecimal | getApGl2Paid()
java.util.Date | getApGLDate()
java.math.BigDecimal | getApNet()
java.lang.String | getApNetSet()
java.lang.String | getApNumber()
java.math.BigDecimal | getApOpen()
java.math.BigDecimal | getApPaidGl()
java.math.BigDecimal | getApPaidRcv()
java.math.BigDecimal | getApRecieved()
java.math.BigDecimal | getApSub()
java.math.BigDecimal | getApTax()
java.lang.String | getApTaxSet()
java.math.BigDecimal | getApTotal()
java.lang.String | getBatch()
java.lang.String | getBp()
java.lang.String | getBuyer()
java.lang.String | getCarrier()
java.lang.String | getCarrierAccount()
java.lang.String | getChangeOrder()
java.lang.String | getCheckNumber()
java.lang.String | getCoComments()
java.lang.String | getCollect()
java.lang.String | getComments()
java.lang.String | getCompanyUnitId()
java.lang.String | getCurrency()
CustomerVendorAddressInfoVO | getCustomerAddressInfo()
java.util.Date | getDatePaid()
java.util.Date | getDateReceived()
java.lang.String | getDebitAccount()
java.lang.String | getDeliveredTo()
java.math.BigDecimal | getDue()
EmployeeCardVO | getEmployee()
java.lang.String | getEtran()
java.math.BigDecimal | getExchange()
java.lang.String | getFreightBill()
java.lang.String | getFreightWho()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getItran()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getNotes()
java.lang.String | getOrigin()
java.math.BigDecimal | getPaid()
java.util.Date | getPayDate()
java.math.BigDecimal | getPaymentVariance()
java.math.BigDecimal | getPoGrandTotal()
java.lang.String | getPoNumber()
java.lang.String | getProject()
java.lang.String | getReceivedBy()
java.lang.String | getReceiverNumber()
java.lang.String | getReldoc()
java.lang.String | getRequestor()
java.lang.String | getShippedVia()
java.lang.String | getStatus()
java.lang.String | getTerms()
java.math.BigDecimal | getTermsDiscount()
java.lang.String | getTermsDiscountDay()
java.lang.String | getTermsDiscountPercent()
java.lang.String | getTracking()
java.lang.String | getVendorId()
java.lang.String | getVendorInvoice()
java.util.Date | getVendorInvoiceDate()
java.lang.String | getVendorPackage()
java.math.BigDecimal | getVendorTotal()
java.lang.Integer | getVersion()
int | hashCode()
boolean | isReCalcSubTotal()
boolean | isReCalcTax()
void | setAccountsPayableItems(java.util.Set<AccountsPayableItemVO> accountsPayableItems)
void | setAdate(java.util.Date adate)
void | setApDate(java.util.Date apDate)
void | setApDiscount(java.math.BigDecimal apDiscount)
void | setApFreight(java.math.BigDecimal apFreight)
void | setApGl1Recorded(java.math.BigDecimal apGl1Recorded)
void | setApGl2Paid(java.math.BigDecimal apGl2Paid)
void | setApGLDate(java.util.Date apGLDate)
void | setApNet(java.math.BigDecimal apNet)
void | setApNetSet(java.lang.String apNetSet)
void | setApNumber(java.lang.String apNumber)
void | setApOpen(java.math.BigDecimal apOpen)
void | setApPaidGl(java.math.BigDecimal apPaidGl)
void | setApPaidRcv(java.math.BigDecimal apPaidRcv)
void | setApRecieved(java.math.BigDecimal apRecieved)
void | setApSub(java.math.BigDecimal apSub)
void | setApTax(java.math.BigDecimal apTax)
void | setApTaxSet(java.lang.String apTaxSet)
void | setApTotal(java.math.BigDecimal apTotal)
void | setBatch(java.lang.String batch)
void | setBp(java.lang.String bp)
void | setBuyer(java.lang.String buyer)
void | setCarrier(java.lang.String carrier)
void | setCarrierAccount(java.lang.String carrierAccount)
void | setChangeOrder(java.lang.String changeOrder)
void | setCheckNumber(java.lang.String checkNumber)
void | setCoComments(java.lang.String coComments)
void | setCollect(java.lang.String collect)
void | setComments(java.lang.String comments)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCurrency(java.lang.String currency)
void | setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | setDatePaid(java.util.Date datePaid)
void | setDateReceived(java.util.Date dateReceived)
void | setDebitAccount(java.lang.String debitAccount)
void | setDeliveredTo(java.lang.String deliveredTo)
void | setDue(java.math.BigDecimal due)
void | setEmployee(EmployeeCardVO employee)
void | setEtran(java.lang.String etran)
void | setExchange(java.math.BigDecimal exchange)
void | setFreightBill(java.lang.String freightBill)
void | setFreightWho(java.lang.String freightWho)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setItran(java.lang.String itran)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setNotes(java.lang.String notes)
void | setOrigin(java.lang.String origin)
void | setPaid(java.math.BigDecimal paid)
void | setPayDate(java.util.Date payDate)
void | setPaymentVariance(java.math.BigDecimal paymentVariance)
void | setPoGrandTotal(java.math.BigDecimal poGrandTotal)
void | setPoNumber(java.lang.String poNumber)
void | setProject(java.lang.String project)
void | setReCalcSubTotal(boolean reCalcSubTotal)
void | setReCalcTax(boolean reCalcTax)
void | setReceivedBy(java.lang.String receivedBy)
void | setReceiverNumber(java.lang.String receiverNumber)
void | setReldoc(java.lang.String reldoc)
void | setRequestor(java.lang.String requestor)
void | setShippedVia(java.lang.String shippedVia)
void | setStatus(java.lang.String status)
void | setTerms(java.lang.String terms)
void | setTermsDiscount(java.math.BigDecimal termsDiscount)
void | setTermsDiscountDay(java.lang.String termsDiscountDay)
void | setTermsDiscountPercent(java.lang.String termsDiscountPercent)
void | setTracking(java.lang.String tracking)
void | setVendorId(java.lang.String vendorId)
void | setVendorInvoice(java.lang.String vendorInvoice)
void | setVendorInvoiceDate(java.util.Date vendorInvoiceDate)
void | setVendorPackage(java.lang.String vendorPackage)
void | setVendorTotal(java.math.BigDecimal vendorTotal)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

AccountsPayableVO

public AccountsPayableVO()
default constructor

Method Detail

getApGLDate

public java.util.Date getApGLDate()

setApGLDate

public void setApGLDate(java.util.Date apGLDate)

getApNumber

public java.lang.String getApNumber()

setApNumber

public void setApNumber(java.lang.String apNumber)

getPoNumber

public java.lang.String getPoNumber()

setPoNumber

public void setPoNumber(java.lang.String poNumber)

getReceiverNumber

public java.lang.String getReceiverNumber()

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getBatch

public java.lang.String getBatch()

setBatch

public void setBatch(java.lang.String batch)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getApNetSet

public java.lang.String getApNetSet()

setApNetSet

public void setApNetSet(java.lang.String apNetSet)

getApTaxSet

public java.lang.String getApTaxSet()

setApTaxSet

public void setApTaxSet(java.lang.String apTaxSet)

getApSub

public java.math.BigDecimal getApSub()

setApSub

public void setApSub(java.math.BigDecimal apSub)

getApRecieved

public java.math.BigDecimal getApRecieved()

setApRecieved

public void setApRecieved(java.math.BigDecimal apRecieved)

getApOpen

public java.math.BigDecimal getApOpen()

setApOpen

public void setApOpen(java.math.BigDecimal apOpen)

getApDiscount

public java.math.BigDecimal getApDiscount()

setApDiscount

public void setApDiscount(java.math.BigDecimal apDiscount)

getApNet

public java.math.BigDecimal getApNet()

setApNet

public void setApNet(java.math.BigDecimal apNet)

getApTax

public java.math.BigDecimal getApTax()

setApTax

public void setApTax(java.math.BigDecimal apTax)

getApFreight

public java.math.BigDecimal getApFreight()

setApFreight

public void setApFreight(java.math.BigDecimal apFreight)

getApTotal

public java.math.BigDecimal getApTotal()

setApTotal

public void setApTotal(java.math.BigDecimal apTotal)

getApPaidRcv

public java.math.BigDecimal getApPaidRcv()

setApPaidRcv

public void setApPaidRcv(java.math.BigDecimal apPaidRcv)

getApPaidGl

public java.math.BigDecimal getApPaidGl()

setApPaidGl

public void setApPaidGl(java.math.BigDecimal apPaidGl)

getApGl1Recorded

public java.math.BigDecimal getApGl1Recorded()

setApGl1Recorded

public void setApGl1Recorded(java.math.BigDecimal apGl1Recorded)

getApGl2Paid

public java.math.BigDecimal getApGl2Paid()

setApGl2Paid

public void setApGl2Paid(java.math.BigDecimal apGl2Paid)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getCollect

public java.lang.String getCollect()

setCollect

public void setCollect(java.lang.String collect)

getFreightWho

public java.lang.String getFreightWho()

setFreightWho

public void setFreightWho(java.lang.String freightWho)

getReceivedBy

public java.lang.String getReceivedBy()

setReceivedBy

public void setReceivedBy(java.lang.String receivedBy)

getDateReceived

public java.util.Date getDateReceived()

setDateReceived

public void setDateReceived(java.util.Date dateReceived)

getDeliveredTo

public java.lang.String getDeliveredTo()

setDeliveredTo

public void setDeliveredTo(java.lang.String deliveredTo)

getFreightBill

public java.lang.String getFreightBill()

setFreightBill

public void setFreightBill(java.lang.String freightBill)

getShippedVia

public java.lang.String getShippedVia()

setShippedVia

public void setShippedVia(java.lang.String shippedVia)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAccount

public java.lang.String getCarrierAccount()

setCarrierAccount

public void setCarrierAccount(java.lang.String carrierAccount)

getTracking

public java.lang.String getTracking()

setTracking

public void setTracking(java.lang.String tracking)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getExchange

public java.math.BigDecimal getExchange()

setExchange

public void setExchange(java.math.BigDecimal exchange)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getRequestor

public java.lang.String getRequestor()

setRequestor

public void setRequestor(java.lang.String requestor)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

getReldoc

public java.lang.String getReldoc()

setReldoc

public void setReldoc(java.lang.String reldoc)

getBp

public java.lang.String getBp()

setBp

public void setBp(java.lang.String bp)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getNotes

public java.lang.String getNotes()

setNotes

public void setNotes(java.lang.String notes)

getDue

public java.math.BigDecimal getDue()

setDue

public void setDue(java.math.BigDecimal due)

getVendorInvoice

public java.lang.String getVendorInvoice()

setVendorInvoice

public void setVendorInvoice(java.lang.String vendorInvoice)

getVendorPackage

public java.lang.String getVendorPackage()

setVendorPackage

public void setVendorPackage(java.lang.String vendorPackage)

getVendorTotal

public java.math.BigDecimal getVendorTotal()

setVendorTotal

public void setVendorTotal(java.math.BigDecimal vendorTotal)

getVendorInvoiceDate

public java.util.Date getVendorInvoiceDate()

setVendorInvoiceDate

public void setVendorInvoiceDate(java.util.Date vendorInvoiceDate)

getPayDate

public java.util.Date getPayDate()

setPayDate

public void setPayDate(java.util.Date payDate)

getDatePaid

public java.util.Date getDatePaid()

setDatePaid

public void setDatePaid(java.util.Date datePaid)

getCheckNumber

public java.lang.String getCheckNumber()

setCheckNumber

public void setCheckNumber(java.lang.String checkNumber)

getPaid

public java.math.BigDecimal getPaid()

setPaid

public void setPaid(java.math.BigDecimal paid)

getItran

public java.lang.String getItran()

setItran

public void setItran(java.lang.String itran)

getEtran

public java.lang.String getEtran()

setEtran

public void setEtran(java.lang.String etran)

getVersion

public java.lang.Integer getVersion()

setVersion

public void setVersion(java.lang.Integer version)

getAccountsPayableItems

public java.util.Set<AccountsPayableItemVO> getAccountsPayableItems()

getCustomerAddressInfo

public CustomerVendorAddressInfoVO getCustomerAddressInfo()

getEmployee

public EmployeeCardVO getEmployee()

getDebitAccount

public java.lang.String getDebitAccount()

getBuyer

public java.lang.String getBuyer()

getCoComments

public java.lang.String getCoComments()

getTermsDiscount

public java.math.BigDecimal getTermsDiscount()

getTermsDiscountPercent

public java.lang.String getTermsDiscountPercent()

getTermsDiscountDay

public java.lang.String getTermsDiscountDay()

setAccountsPayableItems

public void setAccountsPayableItems(java.util.Set<AccountsPayableItemVO> accountsPayableItems)

setCustomerAddressInfo

public void setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)

setEmployee

public void setEmployee(EmployeeCardVO employee)

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

setBuyer

public void setBuyer(java.lang.String buyer)

setCoComments

public void setCoComments(java.lang.String coComments)

setTermsDiscount

public void setTermsDiscount(java.math.BigDecimal termsDiscount)

setTermsDiscountPercent

public void setTermsDiscountPercent(java.lang.String termsDiscountPercent)

setTermsDiscountDay

public void setTermsDiscountDay(java.lang.String termsDiscountDay)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getPoGrandTotal

public java.math.BigDecimal getPoGrandTotal()

setPoGrandTotal

public void setPoGrandTotal(java.math.BigDecimal poGrandTotal)

isReCalcSubTotal

public boolean isReCalcSubTotal()

setReCalcSubTotal

public void setReCalcSubTotal(boolean reCalcSubTotal)

isReCalcTax

public boolean isReCalcTax()

setReCalcTax

public void setReCalcTax(boolean reCalcTax)

getApDate

public java.util.Date getApDate()

setApDate

public void setApDate(java.util.Date apDate)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getPaymentVariance

public java.math.BigDecimal getPaymentVariance()

setPaymentVariance

public void setPaymentVariance(java.math.BigDecimal paymentVariance)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountsReceivableInfoVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountsReceivableInfoVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AccountsReceivableInfoVO
All Implemented Interfaces:
java.io.Serializable
public class AccountsReceivableInfoVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AMOUNTDUE
static java.lang.String | ORDER_BY_BILLTO
static java.lang.String | ORDER_BY_COMPANYUNITID
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_CUSTOMERPONUMBER
static java.lang.String | ORDER_BY_DATEINVOICED
static java.lang.String | ORDER_BY_DATESHIPPED
static java.lang.String | ORDER_BY_GRANDTOTAL
static java.lang.String | ORDER_BY_INVOICENUMBER
static java.lang.String | ORDER_BY_MARGIN
static java.lang.String | ORDER_BY_NAME
static java.lang.String | ORDER_BY_PAID
static java.lang.String | ORDER_BY_PAYDATE
static java.lang.String | ORDER_BY_SALESORDERNUMBER
static java.lang.String | ORDER_BY_SHIPPERNUMBER
static java.lang.String | ORDER_BY_SHIPTO
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
AccountsReceivableInfoVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.math.BigDecimal | getAmountDue()
java.math.BigDecimal | getArGl1Recorded()
java.math.BigDecimal | getArGl2Paid()
java.lang.String | getArNetSet()
java.math.BigDecimal | getArOpen()
java.math.BigDecimal | getArPaidGl()
java.math.BigDecimal | getArPaidInvoice()
java.math.BigDecimal | getArShip()
java.lang.String | getArTaxSet()
java.lang.String | getBatchNumber()
java.lang.String | getBillTo()
java.lang.String | getBp()
java.lang.String | getCarrier()
java.lang.String | getCarrierAcct()
java.lang.String | getChangeOrder()
java.lang.String | getCheckNo()
java.lang.String | getCompanyUnitId()
java.lang.String | getContact()
java.lang.String | getCreditAccount()
java.lang.String | getCurrency()
CustomerVendorAddressInfoVO | getCustomerAddressInfo()
java.lang.String | getCustomerEmail()
java.lang.String | getCustomerId()
java.lang.String | getCustomerPoNumber()
java.util.Date | getDateInvoiced()
java.util.Date | getDatePaid()
java.util.Date | getDateShipped()
java.math.BigDecimal | getExchange()
java.lang.String | getFob()
java.lang.String | getFreightBill()
java.math.BigDecimal | getFreightTotal()
java.lang.String | getFreightWho()
java.math.BigDecimal | getGrandTotal()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getInvoiceBoilerplate()
java.lang.String | getInvoiceComments()
java.lang.String | getInvoicedBy()
java.util.Date | getInvoicedDate()
java.lang.String | getInvoiceNotes()
java.lang.String | getInvoiceNumber()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.math.BigDecimal | getMargin()
java.math.BigDecimal | getMarginByStdCost()
java.math.BigDecimal | getMarginPercent()
java.math.BigDecimal | getMarginPercentByStdCost()
java.lang.String | getOrigin()
java.lang.String | getOtran()
java.math.BigDecimal | getPaid()
java.util.Date | getPaydate()
java.lang.String | getPfInvoiceNumber()
java.lang.String | getReldoc()
java.lang.String | getRemitId()
java.lang.String | getRequestor()
java.lang.String | getRtran()
java.lang.String | getSalesCodeId()
java.lang.String | getSalesman()
java.lang.String | getSalesOrderNumber()
java.util.Date | getShipped()
java.lang.String | getShippedBy()
java.lang.String | getShipperNumber()
java.lang.String | getShipTo()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.math.BigDecimal | getSubDiscountTotal()
java.math.BigDecimal | getSubNetTotal()
java.math.BigDecimal | getSubUnitTotal()
java.math.BigDecimal | getTaxTotal()
java.lang.String | getTerms()
java.math.BigDecimal | getTotalCost()
java.math.BigDecimal | getTotalStdCost()
java.lang.String | getTracking()
java.lang.Integer | getVersion()
int | hashCode()
void | setAdate(java.util.Date adate)
void | setAmountDue(java.math.BigDecimal amountDue)
void | setArGl1Recorded(java.math.BigDecimal arGl1Recorded)
void | setArGl2Paid(java.math.BigDecimal arGl2Paid)
void | setArNetSet(java.lang.String arNetSet)
void | setArOpen(java.math.BigDecimal arOpen)
void | setArPaidGl(java.math.BigDecimal arPaidGl)
void | setArPaidInvoice(java.math.BigDecimal arPaidInvoice)
void | setArShip(java.math.BigDecimal arShip)
void | setArTaxSet(java.lang.String arTaxSet)
void | setBatchNumber(java.lang.String batchNumber)
void | setBillTo(java.lang.String billTo)
void | setBp(java.lang.String bp)
void | setCarrier(java.lang.String carrier)
void | setCarrierAcct(java.lang.String carrierAcct)
void | setChangeOrder(java.lang.String changeOrder)
void | setCheckNo(java.lang.String checkNo)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setContact(java.lang.String contact)
void | setCreditAccount(java.lang.String creditAccount)
void | setCurrency(java.lang.String currency)
void | setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | setCustomerEmail(java.lang.String customerEmail)
void | setCustomerId(java.lang.String customerId)
void | setCustomerPoNumber(java.lang.String customerPoNumber)
void | setDateInvoiced(java.util.Date dateInvoiced)
void | setDatePaid(java.util.Date datePaid)
void | setDateShipped(java.util.Date dateShipped)
void | setExchange(java.math.BigDecimal exchange)
void | setFob(java.lang.String fob)
void | setFreightBill(java.lang.String freightBill)
void | setFreightTotal(java.math.BigDecimal freightTotal)
void | setFreightWho(java.lang.String freightWho)
void | setGrandTotal(java.math.BigDecimal grandTotal)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setInvoiceBoilerplate(java.lang.String invoiceBoilerplate)
void | setInvoiceComments(java.lang.String invoiceComments)
void | setInvoicedBy(java.lang.String invoicedBy)
void | setInvoicedDate(java.util.Date invoicedDate)
void | setInvoiceNotes(java.lang.String invoiceNotes)
void | setInvoiceNumber(java.lang.String invoiceNumber)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setMargin(java.math.BigDecimal margin)
void | setMarginByStdCost(java.math.BigDecimal marginByStdCost)
void | setMarginPercent(java.math.BigDecimal marginPercent)
void | setMarginPercentByStdCost(java.math.BigDecimal marginPercentByStdCost)
void | setOrigin(java.lang.String origin)
void | setOtran(java.lang.String otran)
void | setPaid(java.math.BigDecimal paid)
void | setPaydate(java.util.Date paydate)
void | setPfInvoiceNumber(java.lang.String pfInvoiceNumber)
void | setReldoc(java.lang.String reldoc)
void | setRemitId(java.lang.String remitId)
void | setRequestor(java.lang.String requestor)
void | setRtran(java.lang.String rtran)
void | setSalesCodeId(java.lang.String salesCodeId)
void | setSalesman(java.lang.String salesman)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setShipped(java.util.Date shipped)
void | setShippedBy(java.lang.String shippedBy)
void | setShipperNumber(java.lang.String shipperNumber)
void | setShipTo(java.lang.String shipTo)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setSubDiscountTotal(java.math.BigDecimal subDiscountTotal)
void | setSubNetTotal(java.math.BigDecimal subNetTotal)
void | setSubUnitTotal(java.math.BigDecimal subUnitTotal)
void | setTaxTotal(java.math.BigDecimal taxTotal)
void | setTerms(java.lang.String terms)
void | setTotalCost(java.math.BigDecimal totalCost)
void | setTotalStdCost(java.math.BigDecimal totalStdCost)
void | setTracking(java.lang.String tracking)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_INVOICENUMBER

public static final java.lang.String ORDER_BY_INVOICENUMBER
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_NAME

public static final java.lang.String ORDER_BY_NAME
See Also:
Constant Field Values

ORDER_BY_BILLTO

public static final java.lang.String ORDER_BY_BILLTO
See Also:
Constant Field Values

ORDER_BY_SHIPTO

public static final java.lang.String ORDER_BY_SHIPTO
See Also:
Constant Field Values

ORDER_BY_CUSTOMERPONUMBER

public static final java.lang.String ORDER_BY_CUSTOMERPONUMBER
See Also:
Constant Field Values

ORDER_BY_SALESORDERNUMBER

public static final java.lang.String ORDER_BY_SALESORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_DATESHIPPED

public static final java.lang.String ORDER_BY_DATESHIPPED
See Also:
Constant Field Values

ORDER_BY_DATEINVOICED

public static final java.lang.String ORDER_BY_DATEINVOICED
See Also:
Constant Field Values

ORDER_BY_GRANDTOTAL

public static final java.lang.String ORDER_BY_GRANDTOTAL
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values

ORDER_BY_PAYDATE

public static final java.lang.String ORDER_BY_PAYDATE
See Also:
Constant Field Values

ORDER_BY_SHIPPERNUMBER

public static final java.lang.String ORDER_BY_SHIPPERNUMBER
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_COMPANYUNITID

public static final java.lang.String ORDER_BY_COMPANYUNITID
See Also:
Constant Field Values

ORDER_BY_MARGIN

public static final java.lang.String ORDER_BY_MARGIN
See Also:
Constant Field Values

ORDER_BY_PAID

public static final java.lang.String ORDER_BY_PAID
See Also:
Constant Field Values

ORDER_BY_AMOUNTDUE

public static final java.lang.String ORDER_BY_AMOUNTDUE
See Also:
Constant Field Values
Constructor Detail

AccountsReceivableInfoVO

public AccountsReceivableInfoVO()
default constructor

Method Detail

getInvoiceNumber

public java.lang.String getInvoiceNumber()

setInvoiceNumber

public void setInvoiceNumber(java.lang.String invoiceNumber)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getShipperNumber

public java.lang.String getShipperNumber()

setShipperNumber

public void setShipperNumber(java.lang.String shipperNumber)

getPfInvoiceNumber

public java.lang.String getPfInvoiceNumber()

setPfInvoiceNumber

public void setPfInvoiceNumber(java.lang.String pfInvoiceNumber)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getBillTo

public java.lang.String getBillTo()

setBillTo

public void setBillTo(java.lang.String billTo)

getCustomerPoNumber

public java.lang.String getCustomerPoNumber()

setCustomerPoNumber

public void setCustomerPoNumber(java.lang.String customerPoNumber)

getCustomerEmail

public java.lang.String getCustomerEmail()

setCustomerEmail

public void setCustomerEmail(java.lang.String customerEmail)

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getArNetSet

public java.lang.String getArNetSet()

setArNetSet

public void setArNetSet(java.lang.String arNetSet)

getArTaxSet

public java.lang.String getArTaxSet()

setArTaxSet

public void setArTaxSet(java.lang.String arTaxSet)

getSubUnitTotal

public java.math.BigDecimal getSubUnitTotal()

setSubUnitTotal

public void setSubUnitTotal(java.math.BigDecimal subUnitTotal)

getArShip

public java.math.BigDecimal getArShip()

setArShip

public void setArShip(java.math.BigDecimal arShip)

getArOpen

public java.math.BigDecimal getArOpen()

setArOpen

public void setArOpen(java.math.BigDecimal arOpen)

getSubDiscountTotal

public java.math.BigDecimal getSubDiscountTotal()

setSubDiscountTotal

public void setSubDiscountTotal(java.math.BigDecimal subDiscountTotal)

getSubNetTotal

public java.math.BigDecimal getSubNetTotal()

setSubNetTotal

public void setSubNetTotal(java.math.BigDecimal subNetTotal)

getTaxTotal

public java.math.BigDecimal getTaxTotal()

setTaxTotal

public void setTaxTotal(java.math.BigDecimal taxTotal)

getFreightTotal

public java.math.BigDecimal getFreightTotal()

setFreightTotal

public void setFreightTotal(java.math.BigDecimal freightTotal)

getGrandTotal

public java.math.BigDecimal getGrandTotal()

setGrandTotal

public void setGrandTotal(java.math.BigDecimal grandTotal)

getArPaidInvoice

public java.math.BigDecimal getArPaidInvoice()

setArPaidInvoice

public void setArPaidInvoice(java.math.BigDecimal arPaidInvoice)

getArPaidGl

public java.math.BigDecimal getArPaidGl()

setArPaidGl

public void setArPaidGl(java.math.BigDecimal arPaidGl)

getArGl1Recorded

public java.math.BigDecimal getArGl1Recorded()

setArGl1Recorded

public void setArGl1Recorded(java.math.BigDecimal arGl1Recorded)

getArGl2Paid

public java.math.BigDecimal getArGl2Paid()

setArGl2Paid

public void setArGl2Paid(java.math.BigDecimal arGl2Paid)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getSalesman

public java.lang.String getSalesman()

setSalesman

public void setSalesman(java.lang.String salesman)

getShipped

public java.util.Date getShipped()

setShipped

public void setShipped(java.util.Date shipped)

getShippedBy

public java.lang.String getShippedBy()

setShippedBy

public void setShippedBy(java.lang.String shippedBy)

getInvoicedDate

public java.util.Date getInvoicedDate()

setInvoicedDate

public void setInvoicedDate(java.util.Date invoicedDate)

getInvoicedBy

public java.lang.String getInvoicedBy()

setInvoicedBy

public void setInvoicedBy(java.lang.String invoicedBy)

getShipTo

public java.lang.String getShipTo()

setShipTo

public void setShipTo(java.lang.String shipTo)

getRemitId

public java.lang.String getRemitId()

setRemitId

public void setRemitId(java.lang.String remitId)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAcct

public java.lang.String getCarrierAcct()

setCarrierAcct

public void setCarrierAcct(java.lang.String carrierAcct)

getTracking

public java.lang.String getTracking()

setTracking

public void setTracking(java.lang.String tracking)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getDateShipped

public java.util.Date getDateShipped()

setDateShipped

public void setDateShipped(java.util.Date dateShipped)

getDateInvoiced

public java.util.Date getDateInvoiced()

setDateInvoiced

public void setDateInvoiced(java.util.Date dateInvoiced)

getFreightBill

public java.lang.String getFreightBill()

setFreightBill

public void setFreightBill(java.lang.String freightBill)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getReldoc

public java.lang.String getReldoc()

setReldoc

public void setReldoc(java.lang.String reldoc)

getCreditAccount

public java.lang.String getCreditAccount()

setCreditAccount

public void setCreditAccount(java.lang.String creditAccount)

getBp

public java.lang.String getBp()

setBp

public void setBp(java.lang.String bp)

getInvoiceComments

public java.lang.String getInvoiceComments()

setInvoiceComments

public void setInvoiceComments(java.lang.String invoiceComments)

getInvoiceNotes

public java.lang.String getInvoiceNotes()

setInvoiceNotes

public void setInvoiceNotes(java.lang.String invoiceNotes)

getAmountDue

public java.math.BigDecimal getAmountDue()

setAmountDue

public void setAmountDue(java.math.BigDecimal amountDue)

getPaydate

public java.util.Date getPaydate()

setPaydate

public void setPaydate(java.util.Date paydate)

getDatePaid

public java.util.Date getDatePaid()

setDatePaid

public void setDatePaid(java.util.Date datePaid)

getCheckNo

public java.lang.String getCheckNo()

setCheckNo

public void setCheckNo(java.lang.String checkNo)

getPaid

public java.math.BigDecimal getPaid()

setPaid

public void setPaid(java.math.BigDecimal paid)

getOtran

public java.lang.String getOtran()

setOtran

public void setOtran(java.lang.String otran)

getRtran

public java.lang.String getRtran()

setRtran

public void setRtran(java.lang.String rtran)

getFob

public java.lang.String getFob()

getFreightWho

public java.lang.String getFreightWho()

getBatchNumber

public java.lang.String getBatchNumber()

getExchange

public java.math.BigDecimal getExchange()

getVersion

public java.lang.Integer getVersion()

getCustomerAddressInfo

public CustomerVendorAddressInfoVO getCustomerAddressInfo()

getInvoiceBoilerplate

public java.lang.String getInvoiceBoilerplate()

getMargin

public java.math.BigDecimal getMargin()

getMarginPercent

public java.math.BigDecimal getMarginPercent()

getTotalCost

public java.math.BigDecimal getTotalCost()

setFob

public void setFob(java.lang.String fob)

setFreightWho

public void setFreightWho(java.lang.String freightWho)

setBatchNumber

public void setBatchNumber(java.lang.String batchNumber)

setExchange

public void setExchange(java.math.BigDecimal exchange)

setVersion

public void setVersion(java.lang.Integer version)

setCustomerAddressInfo

public void setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)

setInvoiceBoilerplate

public void setInvoiceBoilerplate(java.lang.String invoiceBoilerplate)

setMargin

public void setMargin(java.math.BigDecimal margin)

setMarginPercent

public void setMarginPercent(java.math.BigDecimal marginPercent)

setTotalCost

public void setTotalCost(java.math.BigDecimal totalCost)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getRequestor

public java.lang.String getRequestor()

setRequestor

public void setRequestor(java.lang.String requestor)

getSalesCodeId

public java.lang.String getSalesCodeId()

setSalesCodeId

public void setSalesCodeId(java.lang.String salesCodeId)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getMarginByStdCost

public java.math.BigDecimal getMarginByStdCost()

setMarginByStdCost

public void setMarginByStdCost(java.math.BigDecimal marginByStdCost)

getMarginPercentByStdCost

public java.math.BigDecimal getMarginPercentByStdCost()

setMarginPercentByStdCost

public void setMarginPercentByStdCost(java.math.BigDecimal marginPercentByStdCost)

getTotalStdCost

public java.math.BigDecimal getTotalStdCost()

setTotalStdCost

public void setTotalStdCost(java.math.BigDecimal totalStdCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountsReceivableItemManufacturerPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountsReceivableItemManufacturerPK

java.lang.Object
    extended by  bb.common.AccountsReceivableItemManufacturerPK
All Implemented Interfaces:
java.io.Serializable
public class AccountsReceivableItemManufacturerPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
AccountsReceivableItemManufacturerPK()
default constructor
AccountsReceivableItemManufacturerPK(java.lang.String invoiceNumber, java.lang.String salesOrderItemNumber, short ii)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Short | getIi()
java.lang.String | getInvoiceNumber()
java.lang.String | getSalesOrderItemNumber()
int | hashCode()
void | setIi(java.lang.Short ii)
void | setInvoiceNumber(java.lang.String invoiceNumber)
void | setSalesOrderItemNumber(java.lang.String salesOrderItemNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

AccountsReceivableItemManufacturerPK

public AccountsReceivableItemManufacturerPK(java.lang.String invoiceNumber,
                                            java.lang.String salesOrderItemNumber,
                                            short ii)
full constructor

AccountsReceivableItemManufacturerPK

public AccountsReceivableItemManufacturerPK()
default constructor

Method Detail

getInvoiceNumber

public java.lang.String getInvoiceNumber()

setInvoiceNumber

public void setInvoiceNumber(java.lang.String invoiceNumber)

getSalesOrderItemNumber

public java.lang.String getSalesOrderItemNumber()

setSalesOrderItemNumber

public void setSalesOrderItemNumber(java.lang.String salesOrderItemNumber)

getIi

public java.lang.Short getIi()

setIi

public void setIi(java.lang.Short ii)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountsReceivableItemManufacturerVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountsReceivableItemManufacturerVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AccountsReceivableItemManufacturerVO
All Implemented Interfaces:
java.io.Serializable
public class AccountsReceivableItemManufacturerVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AccountsReceivableItemManufacturerVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getManufacturerName()
java.lang.String | getManufacturerPartNumber()
AccountsReceivableItemManufacturerPK | getPk()
int | hashCode()
void | setManufacturerName(java.lang.String manufacturerName)
void | setManufacturerPartNumber(java.lang.String manufacturerPartNumber)
void | setPk(AccountsReceivableItemManufacturerPK pk)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

AccountsReceivableItemManufacturerVO

public AccountsReceivableItemManufacturerVO()
Method Detail

getPk

public AccountsReceivableItemManufacturerPK getPk()

setPk

public void setPk(AccountsReceivableItemManufacturerPK pk)

getManufacturerName

public java.lang.String getManufacturerName()

setManufacturerName

public void setManufacturerName(java.lang.String manufacturerName)

getManufacturerPartNumber

public java.lang.String getManufacturerPartNumber()

setManufacturerPartNumber

public void setManufacturerPartNumber(java.lang.String manufacturerPartNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountsReceivableItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountsReceivableItemPK

java.lang.Object
    extended by  bb.common.AccountsReceivableItemPK
All Implemented Interfaces:
java.io.Serializable
public class AccountsReceivableItemPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
AccountsReceivableItemPK()
default constructor
AccountsReceivableItemPK(java.lang.String invoiceNumber, java.lang.String invoiceItemNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getInvoiceItemNumber()
java.lang.String | getInvoiceNumber()
int | hashCode()
void | setInvoiceItemNumber(java.lang.String invoiceItemNumber)
void | setInvoiceNumber(java.lang.String invoiceNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

AccountsReceivableItemPK

public AccountsReceivableItemPK(java.lang.String invoiceNumber,
                                java.lang.String invoiceItemNumber)
full constructor

AccountsReceivableItemPK

public AccountsReceivableItemPK()
default constructor

Method Detail

getInvoiceNumber

public java.lang.String getInvoiceNumber()

setInvoiceNumber

public void setInvoiceNumber(java.lang.String invoiceNumber)

getInvoiceItemNumber

public java.lang.String getInvoiceItemNumber()

setInvoiceItemNumber

public void setInvoiceItemNumber(java.lang.String invoiceItemNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountsReceivableItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountsReceivableItemResult

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AccountsReceivableItemVO
            extended by  bb.common.AccountsReceivableItemResult
All Implemented Interfaces:
java.io.Serializable
public class AccountsReceivableItemResult
extends AccountsReceivableItemVO

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AVGCOST
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_GRANDTOTAL
static java.lang.String | ORDER_BY_PARTFROM
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_QTYSHIPPED
static java.lang.String | ORDER_BY_STDCOST
static java.lang.String | ORDER_BY_SUBTOTAL
Constructor Summary
AccountsReceivableItemResult()
Method Summary
java.math.BigDecimal | getGrandTotal()
java.math.BigDecimal | getSubTotal()
void | setGrandTotal(java.math.BigDecimal grandTotal)
void | setSubTotal(java.math.BigDecimal subTotal)
Methods inherited from class bb.common.AccountsReceivableItemVO
equals, getAccountNumber, getAccountsReceivableItemManufacturer, getArDisc, getArNet, getArOpen, getArShip, getArSub, getArTax, getArTotal, getAvgCost, getCheckNumber, getCountryOrigin, getDateInvoiced, getDatePaid, getDateShipped, getDescription, getDiscount, getDue, getInvoiceComments, getInvoicePrivateNotes, getListPrice, getLocate, getMargin, getMarginByStdCost, getMarginPercent, getMarginPercentByStdCost, getMfg, getModelNumber, getMpn, getPaid, getPartFrom, getPartNumber, getPartType, getPk, getProductCode, getQtyOrdered, getQtyShipped, getRefDoc1, getRefDoc2, getRefDocOnes, getRefDocTwoes, getRevision, getSalesOrderItemNumber, getSalesOrderNumber, getSerial, getShipperItemNumber, getShipperNumber, getShipTo, getShipVia, getStatus, getStdCost, getTaxRate, getUnit, hashCode, setAccountNumber, setAccountsReceivableItemManufacturer, setArDisc, setArNet, setArOpen, setArShip, setArSub, setArTax, setArTotal, setAvgCost, setCheckNumber, setCountryOrigin, setDateInvoiced, setDatePaid, setDateShipped, setDescription, setDiscount, setDue, setInvoiceComments, setInvoicePrivateNotes, setListPrice, setLocate, setMargin, setMarginByStdCost, setMarginPercent, setMarginPercentByStdCost, setMfg, setModelNumber, setMpn, setPaid, setPartFrom, setPartNumber, setPartType, setPk, setProductCode, setQtyOrdered, setQtyShipped, setRefDoc1, setRefDoc2, setRefDocOnes, setRefDocTwoes, setRevision, setSalesOrderItemNumber, setSalesOrderNumber, setSerial, setShipperItemNumber, setShipperNumber, setShipTo, setShipVia, setStatus, setStdCost, setTaxRate, setUnit, toString
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_PARTFROM

public static final java.lang.String ORDER_BY_PARTFROM
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_QTYSHIPPED

public static final java.lang.String ORDER_BY_QTYSHIPPED
See Also:
Constant Field Values

ORDER_BY_AVGCOST

public static final java.lang.String ORDER_BY_AVGCOST
See Also:
Constant Field Values

ORDER_BY_STDCOST

public static final java.lang.String ORDER_BY_STDCOST
See Also:
Constant Field Values

ORDER_BY_GRANDTOTAL

public static final java.lang.String ORDER_BY_GRANDTOTAL
See Also:
Constant Field Values

ORDER_BY_SUBTOTAL

public static final java.lang.String ORDER_BY_SUBTOTAL
See Also:
Constant Field Values
Constructor Detail

AccountsReceivableItemResult

public AccountsReceivableItemResult()
Method Detail

getGrandTotal

public java.math.BigDecimal getGrandTotal()

setGrandTotal

public void setGrandTotal(java.math.BigDecimal grandTotal)

getSubTotal

public java.math.BigDecimal getSubTotal()

setSubTotal

public void setSubTotal(java.math.BigDecimal subTotal)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountsReceivableItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountsReceivableItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AccountsReceivableItemVO
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
AccountsReceivableItemResult
public class AccountsReceivableItemVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AVGCOST
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_PARTFROM
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_QTYSHIPPED
static java.lang.String | ORDER_BY_STDCOST
Constructor Summary
AccountsReceivableItemVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAccountNumber()
java.util.Set | getAccountsReceivableItemManufacturer()
java.math.BigDecimal | getArDisc()
java.math.BigDecimal | getArNet()
java.math.BigDecimal | getArOpen()
java.math.BigDecimal | getArShip()
java.math.BigDecimal | getArSub()
java.math.BigDecimal | getArTax()
java.math.BigDecimal | getArTotal()
java.math.BigDecimal | getAvgCost()
java.lang.String | getCheckNumber()
java.lang.String | getCountryOrigin()
java.util.Date | getDateInvoiced()
java.util.Date | getDatePaid()
java.util.Date | getDateShipped()
java.lang.String | getDescription()
java.math.BigDecimal | getDiscount()
java.math.BigDecimal | getDue()
java.lang.String | getInvoiceComments()
java.lang.String | getInvoicePrivateNotes()
java.math.BigDecimal | getListPrice()
java.lang.String | getLocate()
java.math.BigDecimal | getMargin()
java.math.BigDecimal | getMarginByStdCost()
java.math.BigDecimal | getMarginPercent()
java.math.BigDecimal | getMarginPercentByStdCost()
java.lang.String | getMfg()
java.lang.String | getModelNumber()
java.lang.String | getMpn()
java.math.BigDecimal | getPaid()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
AccountsReceivableItemPK | getPk()
java.lang.String | getProductCode()
java.math.BigDecimal | getQtyOrdered()
java.math.BigDecimal | getQtyShipped()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.util.Set | getRefDocOnes()
java.util.Set | getRefDocTwoes()
java.lang.String | getRevision()
java.lang.String | getSalesOrderItemNumber()
java.lang.String | getSalesOrderNumber()
java.lang.String | getSerial()
java.lang.String | getShipperItemNumber()
java.lang.String | getShipperNumber()
java.lang.String | getShipTo()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.math.BigDecimal | getStdCost()
java.math.BigDecimal | getTaxRate()
java.lang.String | getUnit()
int | hashCode()
void | setAccountNumber(java.lang.String accountNumber)
void | setAccountsReceivableItemManufacturer(java.util.Set accountsReceivableItemManufacturer)
void | setArDisc(java.math.BigDecimal arDisc)
void | setArNet(java.math.BigDecimal arNet)
void | setArOpen(java.math.BigDecimal arOpen)
void | setArShip(java.math.BigDecimal arShip)
void | setArSub(java.math.BigDecimal arSub)
void | setArTax(java.math.BigDecimal arTax)
void | setArTotal(java.math.BigDecimal arTotal)
void | setAvgCost(java.math.BigDecimal avgCost)
void | setCheckNumber(java.lang.String checkNumber)
void | setCountryOrigin(java.lang.String countryOrigin)
void | setDateInvoiced(java.util.Date dateInvoiced)
void | setDatePaid(java.util.Date datePaid)
void | setDateShipped(java.util.Date dateShipped)
void | setDescription(java.lang.String description)
void | setDiscount(java.math.BigDecimal discount)
void | setDue(java.math.BigDecimal due)
void | setInvoiceComments(java.lang.String invoiceComments)
void | setInvoicePrivateNotes(java.lang.String invoicePrivateNotes)
void | setListPrice(java.math.BigDecimal listPrice)
void | setLocate(java.lang.String locate)
void | setMargin(java.math.BigDecimal margin)
void | setMarginByStdCost(java.math.BigDecimal marginByStdCost)
void | setMarginPercent(java.math.BigDecimal marginPercent)
void | setMarginPercentByStdCost(java.math.BigDecimal marginPercentByStdCost)
void | setMfg(java.lang.String mfg)
void | setModelNumber(java.lang.String modelNumber)
void | setMpn(java.lang.String mpn)
void | setPaid(java.math.BigDecimal paid)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(AccountsReceivableItemPK pk)
void | setProductCode(java.lang.String productCode)
void | setQtyOrdered(java.math.BigDecimal qtyOrdered)
void | setQtyShipped(java.math.BigDecimal qtyShipped)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setRefDocOnes(java.util.Set refDocOnes)
void | setRefDocTwoes(java.util.Set refDocTwoes)
void | setRevision(java.lang.String revision)
void | setSalesOrderItemNumber(java.lang.String salesOrderItemNumber)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setSerial(java.lang.String serial)
void | setShipperItemNumber(java.lang.String shipperItemNumber)
void | setShipperNumber(java.lang.String shipperNumber)
void | setShipTo(java.lang.String shipTo)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setStdCost(java.math.BigDecimal stdCost)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setUnit(java.lang.String unit)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_PARTFROM

public static final java.lang.String ORDER_BY_PARTFROM
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_QTYSHIPPED

public static final java.lang.String ORDER_BY_QTYSHIPPED
See Also:
Constant Field Values

ORDER_BY_AVGCOST

public static final java.lang.String ORDER_BY_AVGCOST
See Also:
Constant Field Values

ORDER_BY_STDCOST

public static final java.lang.String ORDER_BY_STDCOST
See Also:
Constant Field Values
Constructor Detail

AccountsReceivableItemVO

public AccountsReceivableItemVO()
default constructor

Method Detail

getPk

public AccountsReceivableItemPK getPk()

setPk

public void setPk(AccountsReceivableItemPK pk)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getShipperNumber

public java.lang.String getShipperNumber()

setShipperNumber

public void setShipperNumber(java.lang.String shipperNumber)

getShipperItemNumber

public java.lang.String getShipperItemNumber()

setShipperItemNumber

public void setShipperItemNumber(java.lang.String shipperItemNumber)

getArSub

public java.math.BigDecimal getArSub()

setArSub

public void setArSub(java.math.BigDecimal arSub)

getArShip

public java.math.BigDecimal getArShip()

setArShip

public void setArShip(java.math.BigDecimal arShip)

getArOpen

public java.math.BigDecimal getArOpen()

setArOpen

public void setArOpen(java.math.BigDecimal arOpen)

getArDisc

public java.math.BigDecimal getArDisc()

setArDisc

public void setArDisc(java.math.BigDecimal arDisc)

getArNet

public java.math.BigDecimal getArNet()

setArNet

public void setArNet(java.math.BigDecimal arNet)

getArTax

public java.math.BigDecimal getArTax()

setArTax

public void setArTax(java.math.BigDecimal arTax)

getArTotal

public java.math.BigDecimal getArTotal()

setArTotal

public void setArTotal(java.math.BigDecimal arTotal)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getDateShipped

public java.util.Date getDateShipped()

setDateShipped

public void setDateShipped(java.util.Date dateShipped)

getDateInvoiced

public java.util.Date getDateInvoiced()

setDateInvoiced

public void setDateInvoiced(java.util.Date dateInvoiced)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getShipTo

public java.lang.String getShipTo()

setShipTo

public void setShipTo(java.lang.String shipTo)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getQtyOrdered

public java.math.BigDecimal getQtyOrdered()

setQtyOrdered

public void setQtyOrdered(java.math.BigDecimal qtyOrdered)

getQtyShipped

public java.math.BigDecimal getQtyShipped()

setQtyShipped

public void setQtyShipped(java.math.BigDecimal qtyShipped)

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

getAvgCost

public java.math.BigDecimal getAvgCost()

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getSerial

public java.lang.String getSerial()

setSerial

public void setSerial(java.lang.String serial)

getInvoiceComments

public java.lang.String getInvoiceComments()

setInvoiceComments

public void setInvoiceComments(java.lang.String invoiceComments)

getInvoicePrivateNotes

public java.lang.String getInvoicePrivateNotes()

getCheckNumber

public java.lang.String getCheckNumber()

getDue

public java.math.BigDecimal getDue()

getDatePaid

public java.util.Date getDatePaid()

getPaid

public java.math.BigDecimal getPaid()

getRefDocOnes

public java.util.Set getRefDocOnes()

getMargin

public java.math.BigDecimal getMargin()

getMarginPercent

public java.math.BigDecimal getMarginPercent()

setInvoicePrivateNotes

public void setInvoicePrivateNotes(java.lang.String invoicePrivateNotes)

setCheckNumber

public void setCheckNumber(java.lang.String checkNumber)

setDue

public void setDue(java.math.BigDecimal due)

setDatePaid

public void setDatePaid(java.util.Date datePaid)

setPaid

public void setPaid(java.math.BigDecimal paid)

getRefDocTwoes

public java.util.Set getRefDocTwoes()

setRefDocTwoes

public void setRefDocTwoes(java.util.Set refDocTwoes)

setRefDocOnes

public void setRefDocOnes(java.util.Set refDocOnes)

setMargin

public void setMargin(java.math.BigDecimal margin)

setMarginPercent

public void setMarginPercent(java.math.BigDecimal marginPercent)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getAccountsReceivableItemManufacturer

public java.util.Set getAccountsReceivableItemManufacturer()

setAccountsReceivableItemManufacturer

public void setAccountsReceivableItemManufacturer(java.util.Set accountsReceivableItemManufacturer)

getMarginByStdCost

public java.math.BigDecimal getMarginByStdCost()

setMarginByStdCost

public void setMarginByStdCost(java.math.BigDecimal marginByStdCost)

getMarginPercentByStdCost

public java.math.BigDecimal getMarginPercentByStdCost()

setMarginPercentByStdCost

public void setMarginPercentByStdCost(java.math.BigDecimal marginPercentByStdCost)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getSalesOrderItemNumber

public java.lang.String getSalesOrderItemNumber()

setSalesOrderItemNumber

public void setSalesOrderItemNumber(java.lang.String salesOrderItemNumber)

getProductCode

public java.lang.String getProductCode()

setProductCode

public void setProductCode(java.lang.String productCode)

getCountryOrigin

public java.lang.String getCountryOrigin()

setCountryOrigin

public void setCountryOrigin(java.lang.String countryOrigin)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AccountsReceivableVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AccountsReceivableVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AccountsReceivableVO
All Implemented Interfaces:
java.io.Serializable
public class AccountsReceivableVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
AccountsReceivableVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Set | getAccountsReceivableItems()
java.util.Date | getAdate()
java.math.BigDecimal | getAmountDue()
java.math.BigDecimal | getArGl1Recorded()
java.math.BigDecimal | getArGl2Paid()
java.lang.String | getArNetSet()
java.math.BigDecimal | getArOpen()
java.math.BigDecimal | getArPaidGl()
java.math.BigDecimal | getArPaidInvoice()
java.math.BigDecimal | getArShip()
java.lang.String | getArTaxSet()
java.lang.String | getBatchNumber()
java.lang.String | getBb2FeedBackNumber()
java.lang.String | getBillAndHold()
java.lang.String | getBillTo()
CustomerVendorAddressInfoVO | getBillToAddressInfo()
java.util.Set | getBoilerplates()
java.lang.String | getBp()
java.lang.String | getCarrier()
java.lang.String | getCarrierAcct()
java.lang.String | getChangeOrder()
java.lang.String | getCheckNo()
java.lang.String | getCoComments()
java.lang.String | getCompanyUnitId()
java.lang.String | getContact()
java.lang.String | getCreditAccount()
java.lang.String | getCurrency()
CustomerVendorAddressInfoVO | getCustomerAddressInfo()
java.lang.String | getCustomerEmail()
java.lang.String | getCustomerId()
java.lang.String | getCustomerPoNumber()
java.util.Date | getDateInvoiced()
java.util.Date | getDatePaid()
java.util.Date | getDateShipped()
java.math.BigDecimal | getExchange()
java.lang.String | getFob()
java.lang.String | getFreightBill()
java.math.BigDecimal | getFreightTotal()
java.lang.String | getFreightWho()
java.math.BigDecimal | getGrandTotal()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getInvoiceBoilerplate()
java.lang.String | getInvoiceComments()
java.lang.String | getInvoicedBy()
java.util.Date | getInvoicedDate()
java.lang.String | getInvoiceNotes()
java.lang.String | getInvoiceNumber()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.math.BigDecimal | getMargin()
java.math.BigDecimal | getMarginByStdCost()
java.math.BigDecimal | getMarginPercent()
java.math.BigDecimal | getMarginPercentByStdCost()
java.lang.String | getOrigin()
java.lang.String | getOtran()
java.math.BigDecimal | getPaid()
java.util.Date | getPaydate()
java.math.BigDecimal | getPaymentVariance()
java.lang.String | getPaymentVarianceGL()
java.lang.String | getPfInvoiceNumber()
java.lang.String | getReldoc()
java.lang.String | getRemitId()
java.lang.String | getRequestor()
java.lang.String | getRtran()
java.lang.String | getSalesCodeId()
java.lang.String | getSalesman()
java.lang.String | getSalesOrderNumber()
java.util.Date | getShipped()
java.lang.String | getShippedBy()
java.lang.String | getShipperNumber()
java.lang.String | getShipTo()
CustomerVendorAddressInfoVO | getShipToAddressInfo()
java.lang.String | getShipVia()
byte[] | getSignature()
java.lang.String | getStatus()
java.math.BigDecimal | getSubDiscountTotal()
java.math.BigDecimal | getSubNetTotal()
java.math.BigDecimal | getSubUnitTotal()
java.math.BigDecimal | getTaxTotal()
java.lang.String | getTerms()
java.math.BigDecimal | getTotalCost()
java.math.BigDecimal | getTotalStdCost()
java.lang.String | getTracking()
java.lang.Integer | getVersion()
int | hashCode()
void | setAccountsReceivableItems(java.util.Set accountsReceivableItems)
void | setAdate(java.util.Date adate)
void | setAmountDue(java.math.BigDecimal amountDue)
void | setArGl1Recorded(java.math.BigDecimal arGl1Recorded)
void | setArGl2Paid(java.math.BigDecimal arGl2Paid)
void | setArNetSet(java.lang.String arNetSet)
void | setArOpen(java.math.BigDecimal arOpen)
void | setArPaidGl(java.math.BigDecimal arPaidGl)
void | setArPaidInvoice(java.math.BigDecimal arPaidInvoice)
void | setArShip(java.math.BigDecimal arShip)
void | setArTaxSet(java.lang.String arTaxSet)
void | setBatchNumber(java.lang.String batchNumber)
void | setBb2FeedBackNumber(java.lang.String bb2FeedBackNumber)
void | setBillAndHold(java.lang.String billAndHold)
void | setBillTo(java.lang.String billTo)
void | setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | setBoilerplates(java.util.Set boilerplates)
void | setBp(java.lang.String bp)
void | setCarrier(java.lang.String carrier)
void | setCarrierAcct(java.lang.String carrierAcct)
void | setChangeOrder(java.lang.String changeOrder)
void | setCheckNo(java.lang.String checkNo)
void | setCoComments(java.lang.String coComments)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setContact(java.lang.String contact)
void | setCreditAccount(java.lang.String creditAccount)
void | setCurrency(java.lang.String currency)
void | setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | setCustomerEmail(java.lang.String customerEmail)
void | setCustomerId(java.lang.String customerId)
void | setCustomerPoNumber(java.lang.String customerPoNumber)
void | setDateInvoiced(java.util.Date dateInvoiced)
void | setDatePaid(java.util.Date datePaid)
void | setDateShipped(java.util.Date dateShipped)
void | setExchange(java.math.BigDecimal exchange)
void | setFob(java.lang.String fob)
void | setFreightBill(java.lang.String freightBill)
void | setFreightTotal(java.math.BigDecimal freightTotal)
void | setFreightWho(java.lang.String freightWho)
void | setGrandTotal(java.math.BigDecimal grandTotal)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setInvoiceBoilerplate(java.lang.String invoiceBoilerplate)
void | setInvoiceComments(java.lang.String invoiceComments)
void | setInvoicedBy(java.lang.String invoicedBy)
void | setInvoicedDate(java.util.Date invoicedDate)
void | setInvoiceNotes(java.lang.String invoiceNotes)
void | setInvoiceNumber(java.lang.String invoiceNumber)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setMargin(java.math.BigDecimal margin)
void | setMarginByStdCost(java.math.BigDecimal marginByStdCost)
void | setMarginPercent(java.math.BigDecimal marginPercent)
void | setMarginPercentByStdCost(java.math.BigDecimal marginPercentByStdCost)
void | setOrigin(java.lang.String origin)
void | setOtran(java.lang.String otran)
void | setPaid(java.math.BigDecimal paid)
void | setPaydate(java.util.Date paydate)
void | setPaymentVariance(java.math.BigDecimal paymentVariance)
void | setPaymentVarianceGL(java.lang.String paymentVarianceGL)
void | setPfInvoiceNumber(java.lang.String pfInvoiceNumber)
void | setReldoc(java.lang.String reldoc)
void | setRemitId(java.lang.String remitId)
void | setRequestor(java.lang.String requestor)
void | setRtran(java.lang.String rtran)
void | setSalesCodeId(java.lang.String salesCodeId)
void | setSalesman(java.lang.String salesman)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setShipped(java.util.Date shipped)
void | setShippedBy(java.lang.String shippedBy)
void | setShipperNumber(java.lang.String shipperNumber)
void | setShipTo(java.lang.String shipTo)
void | setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | setShipVia(java.lang.String shipVia)
void | setSignature(byte[] signature)
void | setStatus(java.lang.String status)
void | setSubDiscountTotal(java.math.BigDecimal subDiscountTotal)
void | setSubNetTotal(java.math.BigDecimal subNetTotal)
void | setSubUnitTotal(java.math.BigDecimal subUnitTotal)
void | setTaxTotal(java.math.BigDecimal taxTotal)
void | setTerms(java.lang.String terms)
void | setTotalCost(java.math.BigDecimal totalCost)
void | setTotalStdCost(java.math.BigDecimal totalStdCost)
void | setTracking(java.lang.String tracking)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

AccountsReceivableVO

public AccountsReceivableVO()
default constructor

Method Detail

getInvoiceNumber

public java.lang.String getInvoiceNumber()

setInvoiceNumber

public void setInvoiceNumber(java.lang.String invoiceNumber)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getShipperNumber

public java.lang.String getShipperNumber()

setShipperNumber

public void setShipperNumber(java.lang.String shipperNumber)

getPfInvoiceNumber

public java.lang.String getPfInvoiceNumber()

setPfInvoiceNumber

public void setPfInvoiceNumber(java.lang.String pfInvoiceNumber)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getBillTo

public java.lang.String getBillTo()

setBillTo

public void setBillTo(java.lang.String billTo)

getCustomerPoNumber

public java.lang.String getCustomerPoNumber()

setCustomerPoNumber

public void setCustomerPoNumber(java.lang.String customerPoNumber)

getCustomerEmail

public java.lang.String getCustomerEmail()

setCustomerEmail

public void setCustomerEmail(java.lang.String customerEmail)

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getArNetSet

public java.lang.String getArNetSet()

setArNetSet

public void setArNetSet(java.lang.String arNetSet)

getArTaxSet

public java.lang.String getArTaxSet()

setArTaxSet

public void setArTaxSet(java.lang.String arTaxSet)

getSubUnitTotal

public java.math.BigDecimal getSubUnitTotal()

setSubUnitTotal

public void setSubUnitTotal(java.math.BigDecimal subUnitTotal)

getArShip

public java.math.BigDecimal getArShip()

setArShip

public void setArShip(java.math.BigDecimal arShip)

getArOpen

public java.math.BigDecimal getArOpen()

setArOpen

public void setArOpen(java.math.BigDecimal arOpen)

getSubDiscountTotal

public java.math.BigDecimal getSubDiscountTotal()

setSubDiscountTotal

public void setSubDiscountTotal(java.math.BigDecimal subDiscountTotal)

getSubNetTotal

public java.math.BigDecimal getSubNetTotal()

setSubNetTotal

public void setSubNetTotal(java.math.BigDecimal subNetTotal)

getTaxTotal

public java.math.BigDecimal getTaxTotal()

setTaxTotal

public void setTaxTotal(java.math.BigDecimal taxTotal)

getFreightTotal

public java.math.BigDecimal getFreightTotal()

setFreightTotal

public void setFreightTotal(java.math.BigDecimal freightTotal)

getGrandTotal

public java.math.BigDecimal getGrandTotal()

setGrandTotal

public void setGrandTotal(java.math.BigDecimal grandTotal)

getArPaidInvoice

public java.math.BigDecimal getArPaidInvoice()

setArPaidInvoice

public void setArPaidInvoice(java.math.BigDecimal arPaidInvoice)

getArPaidGl

public java.math.BigDecimal getArPaidGl()

setArPaidGl

public void setArPaidGl(java.math.BigDecimal arPaidGl)

getArGl1Recorded

public java.math.BigDecimal getArGl1Recorded()

setArGl1Recorded

public void setArGl1Recorded(java.math.BigDecimal arGl1Recorded)

getArGl2Paid

public java.math.BigDecimal getArGl2Paid()

setArGl2Paid

public void setArGl2Paid(java.math.BigDecimal arGl2Paid)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getSalesman

public java.lang.String getSalesman()

setSalesman

public void setSalesman(java.lang.String salesman)

getShipped

public java.util.Date getShipped()

setShipped

public void setShipped(java.util.Date shipped)

getShippedBy

public java.lang.String getShippedBy()

setShippedBy

public void setShippedBy(java.lang.String shippedBy)

getInvoicedDate

public java.util.Date getInvoicedDate()

setInvoicedDate

public void setInvoicedDate(java.util.Date invoicedDate)

getInvoicedBy

public java.lang.String getInvoicedBy()

setInvoicedBy

public void setInvoicedBy(java.lang.String invoicedBy)

getShipTo

public java.lang.String getShipTo()

setShipTo

public void setShipTo(java.lang.String shipTo)

getRemitId

public java.lang.String getRemitId()

setRemitId

public void setRemitId(java.lang.String remitId)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAcct

public java.lang.String getCarrierAcct()

setCarrierAcct

public void setCarrierAcct(java.lang.String carrierAcct)

getTracking

public java.lang.String getTracking()

setTracking

public void setTracking(java.lang.String tracking)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getDateShipped

public java.util.Date getDateShipped()

setDateShipped

public void setDateShipped(java.util.Date dateShipped)

getDateInvoiced

public java.util.Date getDateInvoiced()

setDateInvoiced

public void setDateInvoiced(java.util.Date dateInvoiced)

getFreightBill

public java.lang.String getFreightBill()

setFreightBill

public void setFreightBill(java.lang.String freightBill)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getReldoc

public java.lang.String getReldoc()

setReldoc

public void setReldoc(java.lang.String reldoc)

getCreditAccount

public java.lang.String getCreditAccount()

setCreditAccount

public void setCreditAccount(java.lang.String creditAccount)

getBp

public java.lang.String getBp()

setBp

public void setBp(java.lang.String bp)

getInvoiceComments

public java.lang.String getInvoiceComments()

setInvoiceComments

public void setInvoiceComments(java.lang.String invoiceComments)

getInvoiceNotes

public java.lang.String getInvoiceNotes()

setInvoiceNotes

public void setInvoiceNotes(java.lang.String invoiceNotes)

getAmountDue

public java.math.BigDecimal getAmountDue()

setAmountDue

public void setAmountDue(java.math.BigDecimal amountDue)

getPaydate

public java.util.Date getPaydate()

setPaydate

public void setPaydate(java.util.Date paydate)

getDatePaid

public java.util.Date getDatePaid()

setDatePaid

public void setDatePaid(java.util.Date datePaid)

getCheckNo

public java.lang.String getCheckNo()

setCheckNo

public void setCheckNo(java.lang.String checkNo)

getPaid

public java.math.BigDecimal getPaid()

setPaid

public void setPaid(java.math.BigDecimal paid)

getOtran

public java.lang.String getOtran()

setOtran

public void setOtran(java.lang.String otran)

getRtran

public java.lang.String getRtran()

setRtran

public void setRtran(java.lang.String rtran)

getCustomerAddressInfo

public CustomerVendorAddressInfoVO getCustomerAddressInfo()

setCustomerAddressInfo

public void setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)

getShipToAddressInfo

public CustomerVendorAddressInfoVO getShipToAddressInfo()

setShipToAddressInfo

public void setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)

getBillToAddressInfo

public CustomerVendorAddressInfoVO getBillToAddressInfo()

setBillToAddressInfo

public void setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)

getAccountsReceivableItems

public java.util.Set getAccountsReceivableItems()

getFob

public java.lang.String getFob()

getFreightWho

public java.lang.String getFreightWho()

getBatchNumber

public java.lang.String getBatchNumber()

getExchange

public java.math.BigDecimal getExchange()

getVersion

public java.lang.Integer getVersion()

getInvoiceBoilerplate

public java.lang.String getInvoiceBoilerplate()

getCoComments

public java.lang.String getCoComments()

getMargin

public java.math.BigDecimal getMargin()

getMarginPercent

public java.math.BigDecimal getMarginPercent()

getTotalCost

public java.math.BigDecimal getTotalCost()

getBb2FeedBackNumber

public java.lang.String getBb2FeedBackNumber()

setAccountsReceivableItems

public void setAccountsReceivableItems(java.util.Set accountsReceivableItems)

setFob

public void setFob(java.lang.String fob)

setFreightWho

public void setFreightWho(java.lang.String freightWho)

setBatchNumber

public void setBatchNumber(java.lang.String batchNumber)

setExchange

public void setExchange(java.math.BigDecimal exchange)

setVersion

public void setVersion(java.lang.Integer version)

setInvoiceBoilerplate

public void setInvoiceBoilerplate(java.lang.String invoiceBoilerplate)

setCoComments

public void setCoComments(java.lang.String coComments)

setMargin

public void setMargin(java.math.BigDecimal margin)

setMarginPercent

public void setMarginPercent(java.math.BigDecimal marginPercent)

setTotalCost

public void setTotalCost(java.math.BigDecimal totalCost)

setBb2FeedBackNumber

public void setBb2FeedBackNumber(java.lang.String bb2FeedBackNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getBoilerplates

public java.util.Set getBoilerplates()

setBoilerplates

public void setBoilerplates(java.util.Set boilerplates)

getRequestor

public java.lang.String getRequestor()

setRequestor

public void setRequestor(java.lang.String requestor)

getSalesCodeId

public java.lang.String getSalesCodeId()

setSalesCodeId

public void setSalesCodeId(java.lang.String salesCodeId)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getMarginByStdCost

public java.math.BigDecimal getMarginByStdCost()

setMarginByStdCost

public void setMarginByStdCost(java.math.BigDecimal marginByStdCost)

getMarginPercentByStdCost

public java.math.BigDecimal getMarginPercentByStdCost()

setMarginPercentByStdCost

public void setMarginPercentByStdCost(java.math.BigDecimal marginPercentByStdCost)

getTotalStdCost

public java.math.BigDecimal getTotalStdCost()

setTotalStdCost

public void setTotalStdCost(java.math.BigDecimal totalStdCost)

getBillAndHold

public java.lang.String getBillAndHold()

setBillAndHold

public void setBillAndHold(java.lang.String billAndHold)

getSignature

public byte[] getSignature()

setSignature

public void setSignature(byte[] signature)

getPaymentVariance

public java.math.BigDecimal getPaymentVariance()

setPaymentVariance

public void setPaymentVariance(java.math.BigDecimal paymentVariance)

setPaymentVarianceGL

public void setPaymentVarianceGL(java.lang.String paymentVarianceGL)

getPaymentVarianceGL

public java.lang.String getPaymentVarianceGL()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AddPayableWithoutReceiverAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AddPayableWithoutReceiverAgent

java.lang.Object
    extended by  bb.common.AddPayableWithoutReceiverAgent
All Implemented Interfaces:
java.io.Serializable
public class AddPayableWithoutReceiverAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AddPayableWithoutReceiverAgent()
Method Summary
java.util.Date | getAPGLDate()
java.lang.String | getBatchNumber()
java.lang.String | getCompanyUnitId()
java.lang.String | getDebitAccount()
java.lang.String | getDescription()
java.lang.String | getGlSummary()
java.util.Date | getInvoiceDate()
java.math.BigDecimal | getTaxRate()
java.util.Date | getTransactionDate()
java.math.BigDecimal | getVendorAmount()
java.lang.String | getVendorId()
java.lang.String | getVendorInvoice()
void | setAPGLDate(java.util.Date date)
void | setBatchNumber(java.lang.String batchNumber)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setDebitAccount(java.lang.String debitAccount)
void | setDescription(java.lang.String description)
void | setGlSummary(java.lang.String glSummary)
void | setInvoiceDate(java.util.Date invoiceDate)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setTransactionDate(java.util.Date transactionDate)
void | setVendorAmount(java.math.BigDecimal vendorAmount)
void | setVendorId(java.lang.String vendorId)
void | setVendorInvoice(java.lang.String vendorInvoice)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AddPayableWithoutReceiverAgent

public AddPayableWithoutReceiverAgent()
Method Detail

setBatchNumber

public void setBatchNumber(java.lang.String batchNumber)

setVendorId

public void setVendorId(java.lang.String vendorId)

setVendorInvoice

public void setVendorInvoice(java.lang.String vendorInvoice)

setInvoiceDate

public void setInvoiceDate(java.util.Date invoiceDate)

setVendorAmount

public void setVendorAmount(java.math.BigDecimal vendorAmount)

setDescription

public void setDescription(java.lang.String description)

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getBatchNumber

public java.lang.String getBatchNumber()

getVendorId

public java.lang.String getVendorId()

getVendorInvoice

public java.lang.String getVendorInvoice()

getInvoiceDate

public java.util.Date getInvoiceDate()

getVendorAmount

public java.math.BigDecimal getVendorAmount()

getDescription

public java.lang.String getDescription()

getDebitAccount

public java.lang.String getDebitAccount()

getTaxRate

public java.math.BigDecimal getTaxRate()

getTransactionDate

public java.util.Date getTransactionDate()

setTransactionDate

public void setTransactionDate(java.util.Date transactionDate)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getGlSummary

public java.lang.String getGlSummary()

setGlSummary

public void setGlSummary(java.lang.String glSummary)

getAPGLDate

public java.util.Date getAPGLDate()

setAPGLDate

public void setAPGLDate(java.util.Date date)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AddPhysicalInventoryAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AddPhysicalInventoryAgent

java.lang.Object
    extended by  bb.common.AddPhysicalInventoryAgent
All Implemented Interfaces:
java.io.Serializable
public class AddPhysicalInventoryAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AddPhysicalInventoryAgent()
Method Summary
java.lang.String | getLocation()
java.math.BigDecimal | getNewOnhand()
java.lang.Integer | getPageNumber()
PartPK | getPartPk()
java.lang.String | getTagNumber()
java.lang.Integer | getWorkSheetNumber()
void | setLocation(java.lang.String location)
void | setNewOnhand(java.math.BigDecimal newOnhand)
void | setPageNumber(java.lang.Integer pageNumber)
void | setPartPk(PartPK partPk)
void | setTagNumber(java.lang.String tagNumber)
void | setWorkSheetNumber(java.lang.Integer workSheetNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AddPhysicalInventoryAgent

public AddPhysicalInventoryAgent()
Method Detail

setWorkSheetNumber

public void setWorkSheetNumber(java.lang.Integer workSheetNumber)

setPageNumber

public void setPageNumber(java.lang.Integer pageNumber)

setPartPk

public void setPartPk(PartPK partPk)

setLocation

public void setLocation(java.lang.String location)

setNewOnhand

public void setNewOnhand(java.math.BigDecimal newOnhand)

getWorkSheetNumber

public java.lang.Integer getWorkSheetNumber()

getPageNumber

public java.lang.Integer getPageNumber()

getPartPk

public PartPK getPartPk()

getLocation

public java.lang.String getLocation()

getNewOnhand

public java.math.BigDecimal getNewOnhand()

getTagNumber

public java.lang.String getTagNumber()

setTagNumber

public void setTagNumber(java.lang.String tagNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AddProformaReceiverAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AddProformaReceiverAgent

java.lang.Object
    extended by  bb.common.AddProformaReceiverAgent
All Implemented Interfaces:
java.io.Serializable
public class AddProformaReceiverAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AddProformaReceiverAgent()
AddProformaReceiverAgent(java.lang.String vendorId)
Method Summary
java.util.LinkedHashSet<AddProformaReceiverItemAgent> | getItems()
java.util.Date | getPrDate()
java.lang.String | getVendorId()
void | setItems(java.util.LinkedHashSet<AddProformaReceiverItemAgent> items)
void | setPrDate(java.util.Date prDate)
void | setVendorId(java.lang.String vendorId)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AddProformaReceiverAgent

public AddProformaReceiverAgent()

AddProformaReceiverAgent

public AddProformaReceiverAgent(java.lang.String vendorId)
Method Detail

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getPrDate

public java.util.Date getPrDate()

setPrDate

public void setPrDate(java.util.Date prDate)

getItems

public java.util.LinkedHashSet<AddProformaReceiverItemAgent> getItems()

setItems

public void setItems(java.util.LinkedHashSet<AddProformaReceiverItemAgent> items)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AddProformaReceiverItemAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AddProformaReceiverItemAgent

java.lang.Object
    extended by  bb.common.AddProformaReceiverItemAgent
All Implemented Interfaces:
java.io.Serializable
public class AddProformaReceiverItemAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AddProformaReceiverItemAgent()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getInvoiceNumber()
java.lang.Integer | getPackingBoxNumber()
PurchaseOrderItemPK | getPk()
java.math.BigDecimal | getQty()
java.util.Date | getShipDate()
int | hashCode()
void | setInvoiceNumber(java.lang.String invoiceNumber)
void | setPackingBoxNumber(java.lang.Integer packingBoxNumber)
void | setPk(PurchaseOrderItemPK pk)
void | setQty(java.math.BigDecimal qty)
void | setShipDate(java.util.Date shipDate)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

AddProformaReceiverItemAgent

public AddProformaReceiverItemAgent()
Method Detail

getPk

public PurchaseOrderItemPK getPk()

setPk

public void setPk(PurchaseOrderItemPK pk)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

getShipDate

public java.util.Date getShipDate()

setShipDate

public void setShipDate(java.util.Date shipDate)

getPackingBoxNumber

public java.lang.Integer getPackingBoxNumber()

setPackingBoxNumber

public void setPackingBoxNumber(java.lang.Integer packingBoxNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getInvoiceNumber

public java.lang.String getInvoiceNumber()

setInvoiceNumber

public void setInvoiceNumber(java.lang.String invoiceNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AddressAccountInfo

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AddressAccountInfo

java.lang.Object
    extended by  bb.common.AddressAccountInfo
All Implemented Interfaces:
java.io.Serializable
public class AddressAccountInfo
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AddressAccountInfo()
Method Summary
java.lang.String | getAccountNumber()
java.math.BigDecimal | getApAmount()
java.math.BigDecimal | getApEndBalance()
java.math.BigDecimal | getApOriginalAmount()
java.math.BigDecimal | getAppAmount()
java.math.BigDecimal | getAppEndBalance()
java.math.BigDecimal | getAppOriginalAmount()
java.math.BigDecimal | getAppStartBalance()
java.math.BigDecimal | getApStartBalance()
java.math.BigDecimal | getArAmount()
java.math.BigDecimal | getArEndBalance()
java.math.BigDecimal | getArOriginalAmount()
java.math.BigDecimal | getArpAmount()
java.math.BigDecimal | getArpEndBalance()
java.math.BigDecimal | getArpOriginalAmount()
java.math.BigDecimal | getArpStartBalance()
java.math.BigDecimal | getArStartBalance()
java.lang.String | getCurrency()
java.lang.String | getDebitOrCredit()
java.lang.String | getDescription()
java.math.BigDecimal | getExchange()
java.lang.String | getId()
java.lang.String | getName()
void | setAccountNumber(java.lang.String accountNumber)
void | setApAmount(java.math.BigDecimal apAmount)
void | setApEndBalance(java.math.BigDecimal apEndBalance)
void | setApOriginalAmount(java.math.BigDecimal apOriginalAmount)
void | setAppAmount(java.math.BigDecimal appAmount)
void | setAppEndBalance(java.math.BigDecimal appEndBalance)
void | setAppOriginalAmount(java.math.BigDecimal appOriginalAmount)
void | setAppStartBalance(java.math.BigDecimal appStartBalance)
void | setApStartBalance(java.math.BigDecimal apStartBalance)
void | setArAmount(java.math.BigDecimal arAmount)
void | setArEndBalance(java.math.BigDecimal arEndBalance)
void | setArOriginalAmount(java.math.BigDecimal arOriginalAmount)
void | setArpAmount(java.math.BigDecimal arpAmount)
void | setArpEndBalance(java.math.BigDecimal arpEndBalance)
void | setArpOriginalAmount(java.math.BigDecimal arpOriginalAmount)
void | setArpStartBalance(java.math.BigDecimal arpStartBalance)
void | setArStartBalance(java.math.BigDecimal arStartBalance)
void | setCurrency(java.lang.String currency)
void | setDebitOrCredit(java.lang.String debitOrCredit)
void | setDescription(java.lang.String description)
void | setExchange(java.math.BigDecimal exchange)
void | setId(java.lang.String id)
void | setName(java.lang.String name)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AddressAccountInfo

public AddressAccountInfo()
Method Detail

getApAmount

public java.math.BigDecimal getApAmount()

setApAmount

public void setApAmount(java.math.BigDecimal apAmount)

getApEndBalance

public java.math.BigDecimal getApEndBalance()

setApEndBalance

public void setApEndBalance(java.math.BigDecimal apEndBalance)

getAppAmount

public java.math.BigDecimal getAppAmount()

setAppAmount

public void setAppAmount(java.math.BigDecimal appAmount)

getAppEndBalance

public java.math.BigDecimal getAppEndBalance()

setAppEndBalance

public void setAppEndBalance(java.math.BigDecimal appEndBalance)

getAppStartBalance

public java.math.BigDecimal getAppStartBalance()

setAppStartBalance

public void setAppStartBalance(java.math.BigDecimal appStartBalance)

getApStartBalance

public java.math.BigDecimal getApStartBalance()

setApStartBalance

public void setApStartBalance(java.math.BigDecimal apStartBalance)

getArAmount

public java.math.BigDecimal getArAmount()

setArAmount

public void setArAmount(java.math.BigDecimal arAmount)

getArEndBalance

public java.math.BigDecimal getArEndBalance()

setArEndBalance

public void setArEndBalance(java.math.BigDecimal arEndBalance)

getArpAmount

public java.math.BigDecimal getArpAmount()

setArpAmount

public void setArpAmount(java.math.BigDecimal arpAmount)

getArpEndBalance

public java.math.BigDecimal getArpEndBalance()

setArpEndBalance

public void setArpEndBalance(java.math.BigDecimal arpEndBalance)

getArpStartBalance

public java.math.BigDecimal getArpStartBalance()

setArpStartBalance

public void setArpStartBalance(java.math.BigDecimal arpStartBalance)

getArStartBalance

public java.math.BigDecimal getArStartBalance()

setArStartBalance

public void setArStartBalance(java.math.BigDecimal arStartBalance)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getExchange

public java.math.BigDecimal getExchange()

setExchange

public void setExchange(java.math.BigDecimal exchange)

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getApOriginalAmount

public java.math.BigDecimal getApOriginalAmount()

setApOriginalAmount

public void setApOriginalAmount(java.math.BigDecimal apOriginalAmount)

getAppOriginalAmount

public java.math.BigDecimal getAppOriginalAmount()

setAppOriginalAmount

public void setAppOriginalAmount(java.math.BigDecimal appOriginalAmount)

getArOriginalAmount

public java.math.BigDecimal getArOriginalAmount()

setArOriginalAmount

public void setArOriginalAmount(java.math.BigDecimal arOriginalAmount)

getArpOriginalAmount

public java.math.BigDecimal getArpOriginalAmount()

setArpOriginalAmount

public void setArpOriginalAmount(java.math.BigDecimal arpOriginalAmount)

getDebitOrCredit

public java.lang.String getDebitOrCredit()

setDebitOrCredit

public void setDebitOrCredit(java.lang.String debitOrCredit)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AddressBox

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common.box
Interface AddressBox

public interface AddressBox

Method Summary
CarrierVO | addCarrier(CarrierVO vo)
CustomerVendorAddressVO | addCustomer(CustomerVendorAddressVO vo)
CustomerVendorAddressVO | addCustomerAndVendor(CustomerVendorAddressVO vo)
java.lang.Integer | addCustomerType(java.lang.String customerType, java.lang.String comments)
CustomerVendorAddressVO | addCustomerVendorAddress(CustomerVendorAddressVO cvAddress)
CustomerVendorAddressVO | addDepartment(CustomerVendorAddressVO vo)
ManufacturerAddressVO | addManufacturerAddress(ManufacturerAddressVO vo)
SgClientProgramUserVO | addSgClientProgramUser(SgClientProgramUserVO vo)
CustomerVendorAddressVO | addVendor(CustomerVendorAddressVO vo)
VendorCategoriesVO | addVendorCategories(VendorCategoriesVO vo)
VendorCriticalLevelVO | addVendorCriticalLevel(VendorCriticalLevelVO vo)
VendorGroupUserVO | addVendorGroupUser(VendorGroupUserVO vo)
java.lang.Integer | addVendorType(java.lang.String vendorType, java.lang.String comments)
CustomerVendorAddressVO | constructCustomerVendorAddressForCRFQ(java.lang.String crfqNumber)
java.lang.String | copyCVFormCV(CV2CVAgent agent)
void | deleteAllAddresWhenInit()
void | deleteCarrier(CarrierVO vo)
void | deleteCustomerVendorType(CustomerVendorTypeVO vo)
void | deleteSgClientProgramUser(java.lang.String addressID)
void | deleteVendorCategories(java.lang.String vendorCategory)
void | deleteVendorCriticalLevel(java.lang.String vendorCategory)
void | deleteVendorGroupUser(java.lang.String userName)
int | findAddressContactCount(java.lang.String addressID, java.lang.String addressName)
int | findAddressContactCount(java.lang.String addressID, java.lang.String addressName, boolean idLike)
java.util.Collection<CustomerVendorContactVO> | findAllAddressContact(java.lang.String addressID, java.lang.String addressName, boolean idLike, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorContactVO> | findAllAddressContact(java.lang.String addressID, java.lang.String addressName, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | findAllCustomers(int firstIndex, int maxLength)
java.util.Collection<CustomerVendorTypeVO> | findAllCustomerType(int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | findAllCustomerVendorAddresses(int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | findAllCVAddress()
java.util.Collection<CustomerVendorAddressVO> | findAllDepartments(int firstIndex, int maxLength)
java.util.Collection<AddressQualityDocumentsVO> | findAllExpireDateDoc(java.lang.String searchText, java.lang.String type, java.lang.String dateType, java.util.Date from, java.util.Date to, java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | findAllLockedCustomer(boolean lockTypeIsOverCreditLimit, int firstIndex, int maxLength)
java.util.Collection<ManufacturerAddressInfoVO> | findAllManufacturerAddresses(int firstIndex, int maxLength) *********************below is about ManufacturerAddress*********************
java.util.Collection<CustomerVendorAddressInfoVO> | findAllVendors(int firstIndex, int maxLength)
java.util.Collection<CustomerVendorTypeVO> | findAllVendorType(int firstIndex, int maxLength)
java.util.Collection<CarrierVO> | findCarrierByAddressIds(java.lang.String[] addressIds)
java.util.Collection<CarrierVO> | findCarriersByAddressId(java.lang.String addressId)
java.util.Collection<CustomerVendorAddressInfoVO> | findCustomerAddressesById(java.lang.String idRegex, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | findCustomerAddressesByName(java.lang.String nameRegex, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | findCustomersList(java.lang.String addrId, java.lang.String name, java.lang.String customerType, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | findCustomerVendorAddressesById(java.lang.String idRegex, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | findCustomerVendorAddressesById(java.lang.String addrId, java.lang.String withoutId, java.lang.String addressType)
java.util.Collection<CustomerVendorAddressInfoVO> | findCustomerVendorAddressesByName(java.lang.String nameRegex, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | findCustomerVendorbyType(java.lang.String[] types, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | findCustomerVendors(java.lang.String addrId, java.lang.String name, java.lang.String customerType, java.lang.String vendorType, java.lang.String vendorCategory, java.lang.String criticalLevel, java.lang.String qualityStatus, int firstIndex, int maxLength)
java.util.List | findCustomerVendorsByRegion(java.lang.String region, java.lang.String addressType, int firstIndex, int maxLength)
java.util.List | findCustomerVendorsByValidDate(java.util.Date validDate, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | findDeletedCustomersById(java.lang.String customerId, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | findDeletedCustomerVendorAddressesById(java.lang.String idRegex, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressVO> | findDeletedDepartmentsById(java.lang.String id, int firstIndex, int maxLength)
java.util.Collection<ManufacturerAddressInfoVO> | findDeletedManufacturerAddresses(java.lang.String manufacturerId, java.lang.String name, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | findDeletedVendorsById(java.lang.String vendorId, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressVO> | findDepartmentsById(java.lang.String id, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressVO> | findDepartmentsByName(java.lang.String name, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | findDepartmentsList(java.lang.String addrId, java.lang.String name, int firstIndex, int maxLength)
java.util.Collection<ManufacturerAddressInfoVO> | findManufacturerAddressesById(java.lang.String idRegex, int firstIndex, int maxLength)
java.util.Collection<ManufacturerAddressInfoVO> | findManufacturerAddressesByName(java.lang.String nameRegex, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | findSgClientProgramUser(java.lang.String addressId, java.lang.String addressName, int firstIndex, int maxLength)
java.util.Collection<SgClientProgramUserVO> | findSGClientProgramUsers(java.lang.String addressID, java.lang.String userName, java.lang.Object[] parameters, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | findVendorAddressesById(java.lang.String idRegex, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | findVendorAddressesByName(java.lang.String nameRegex, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<VendorCategoriesVO> | findVendorCategories(java.lang.String vendorCategory, int firstIndex, int maxLength)
java.util.Collection<VendorCriticalLevelVO> | findVendorCriticalLevel(java.lang.String vendorCategory, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | findVendorsList(java.lang.String vendorId, java.lang.String name, java.lang.String vendorType, java.lang.String vendorCategory, java.lang.String criticalLevel, java.lang.String qualityStatus, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | findVendorsListForSeparate(java.lang.String vendorId, java.lang.String name, java.lang.String vendorType, java.lang.String vendorCategory, java.lang.String criticalLevel, java.lang.String qualityStatus, int firstIndex, int maxLength)
java.util.Collection<VendorGroupUserVO> | findVgUser(java.lang.String addressId, java.lang.String userName, int firstIndex, int maxLength)
int | getAllCustomersCount()
int | getAllCustomerTypeCount()
int | getAllCustomerVendorAddressCount()
int | getAllDepartmentsCount()
int | getAllExpireDateDocCount(java.lang.String ii, java.lang.String type, java.lang.String dateType, java.util.Date from, java.util.Date to, java.lang.String addressId)
int | getAllLockedCustomerCount(boolean lockTypeIsOverCreditLimit)
int | getAllManufacturerAddressesCount()
java.util.List<java.lang.String> | getAllTaxType()
int | getAllVendorsCount()
int | getAllVendorTypeCount()
CarrierVO | getCarrierByPk(CarrierPK pk)
int | getCarriersCountByAddressId(java.lang.String addressId)
int | getCustomerAddressesByIdCount(java.lang.String idRegex)
int | getCustomerAddressesByNameCount(java.lang.String nameRegex)
CustomerVendorAddressVO | getCustomerById(java.lang.String addressId)
int | getCustomersListCount(java.lang.String addrId, java.lang.String name, java.lang.String customerType)
CustomerVendorAddressTotalInfo | getCustomerTotalInfo(java.lang.String vendorId)
CustomerVendorTypeVO | getCustomerTypeByType(java.lang.String customerType)
CustomerVendorAddressVO | getCustomerVendorAddressById(java.lang.String id)
int | getCustomerVendorbyTypeCount(java.lang.String[] types)
CustomerVendorAddressInfoVO | getCustomerVendorInfoVoById(java.lang.String id)
CustomerVendorAddressInfoVO | getCustomerVendorInfoVoById(java.lang.String id, java.lang.String languageCode)
int | getCustomerVendorsByRegionCount(java.lang.String region, java.lang.String addressType)
int | getCustomerVendorsCount(java.lang.String addrId, java.lang.String name, java.lang.String customerType, java.lang.String vendorType, java.lang.String vendorCategory, java.lang.String criticalLevel, java.lang.String qualityStatus)
int | getCustomerVendorsCountById(java.lang.String customerId)
int | getCustomerVendorsCountByName(java.lang.String name)
int | getCustomerVendorsCountByValidDate(java.util.Date validDate)
CustomerVendorTypeVO | getCustomerVendorTypeByID(int id)
CustomerVendorAddressTotalInfo | getCVAddressTotalInfo(java.lang.String vendorId)
int | getDeletedCustomersCountById(java.lang.String customerId)
int | getDeletedCustomerVendorAddressesByIdCount(java.lang.String idRegex)
int | getDeletedDepartmentsCountById(java.lang.String id)
int | getDeletedManufacturerAddressesCount(java.lang.String manufacturerId, java.lang.String name)
int | getDeletedVendorsCountById(java.lang.String vendorId)
CustomerVendorAddressVO | getDepartmentById(java.lang.String id)
int | getDepartmentsCountById(java.lang.String id)
int | getDepartmentsCountByName(java.lang.String name)
int | getDepartmentsListCount(java.lang.String addrId, java.lang.String name)
CustomerVendorAddressTotalInfo | getDepartmentTotalInfo(java.lang.String vendorId)
ManufacturerAddressVO | getManufacturerAddressById(java.lang.String id)
ManufacturerAddressVO | getManufacturerAddressById(java.lang.String id, java.lang.String languageCode)
int | getManufacturerAddressesCountById(java.lang.String id)
int | getManufacturerAddressesCountByName(java.lang.String name)
SgClientProgramUserVO | getSgClientProgramUser(java.lang.String addressId)
int | getSgClientProgramUserCount(java.lang.String addressId, java.lang.String addressName)
int | getSGClientProgramUsersCount(java.lang.String addressID, java.lang.String userName, java.lang.Object[] parameters)
int | getVendorAddressesByIdCount(java.lang.String customerId)
int | getVendorAddressesByNameCount(java.lang.String nameRegex)
CustomerVendorAddressVO | getVendorById(java.lang.String addressId)
VendorCategoriesVO | getVendorCategoriesById(java.lang.String vendorCategory)
int | getVendorCategoriesCount(java.lang.String vendorCategory)
VendorCriticalLevelVO | getVendorCriticalLevelById(java.lang.String vendorCategory)
int | getVendorCriticalLevelCount(java.lang.String vendorCategory)
VendorGroupUserVO | getVendorGroupUser(java.lang.String userName)
int | getVendorsListCount(java.lang.String vendorId, java.lang.String name, java.lang.String vendorType, java.lang.String vendorCategory, java.lang.String criticalLevel, java.lang.String qualityStatus)
int | getVendorsListForSeparateCount(java.lang.String vendorId, java.lang.String name, java.lang.String vendorType, java.lang.String vendorCategory, java.lang.String criticalLevel, java.lang.String qualityStatus)
CustomerVendorAddressTotalInfo | getVendorTotalInfo(java.lang.String vendorId)
CustomerVendorTypeVO | getVendorTypeByType(java.lang.String vendorType)
int | getVgUserCount(java.lang.String addressId, java.lang.String userName)
boolean | isAddressDeleted(java.lang.String id)
boolean | isAddressExistent(java.lang.String id)
boolean | isCustomer(java.lang.String addressId)
boolean | isCustomerExist(java.lang.String id)
CustomerCLimitResult | isCustomerHold(java.lang.String customerId)
boolean | isDepartmentExist(java.lang.String id)
boolean | isExtCustomerArTotalDue(java.lang.String customerId)
boolean | isManufacturerIdExist(java.lang.String manufacturerId)
boolean | isParent(java.lang.String id)
boolean | isSgClientProgramUserExistent(java.lang.String addressId)
boolean | isVendor(java.lang.String addressId)
boolean | isVendorExist(java.lang.String id)
boolean | isVendorGroupUserExistent(java.lang.String userName)
java.lang.String | resetSgClientProgramPassword(java.lang.String addressID)
java.lang.String | resetVendorGroupPassword(java.lang.String userName)
CustomerVendorAddressVO | updateAddressQualityInfo(CustomerVendorAddressVO cvAddress)
java.util.Collection<CarrierVO> | updateCarrier(CarrierVO vo)
java.util.Collection<CarrierVO> | updateCarrier(java.util.Vector carrierVoList, java.lang.String addressId)
CustomerVendorAddressVO | updateCustomer(CustomerVendorAddressVO vo)
void | updateCustomerDeletedFlag(java.lang.String id, boolean isDeleted)
void | updateCustomerHold(java.lang.String id, boolean cHold)
void | updateCustomerToAllType(CustomerVendorAddressVO vo)
CustomerVendorAddressVO | updateCustomerVendorAddress(CustomerVendorAddressVO cvAddress)
void | updateCustomerVendorDeletedFlag(java.lang.String addressID, boolean isDeleted)
CustomerVendorTypeVO | updateCustomerVendorType(CustomerVendorTypeVO vo)
void | updateCustomerVendorType(java.util.HashSet customerVendors, java.lang.String type)
CustomerVendorAddressVO | updateDepartment(CustomerVendorAddressVO vo)
void | updateDepartmentDeletedFlag(java.lang.String id, boolean isDeleted)
ManufacturerAddressVO | updateManufacturerAddress(ManufacturerAddressVO vo)
java.lang.String | updateManufacturerAddressDeletedFlag(java.lang.String manufacturerId, boolean isDeleted)
void | updateSgClientProgramUser(SgClientProgramUserVO vo)
CustomerVendorAddressVO | updateVendor(CustomerVendorAddressVO vo)
VendorCategoriesVO | updateVendorCategories(VendorCategoriesVO vo)
VendorCriticalLevelVO | updateVendorCriticalLevel(VendorCriticalLevelVO vo)
void | updateVendorDeletedFlag(java.lang.String id, boolean isDeleted)
void | updateVendorGroupUser(VendorGroupUserVO vo)
CustomerVendorAddressVO | updateVendorQualityInfo(CustomerVendorAddressVO vo)
void | updateVendorToAllType(CustomerVendorAddressVO vo)

Method Detail

findAllCustomerVendorAddresses

java.util.Collection<CustomerVendorAddressInfoVO> findAllCustomerVendorAddresses(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllCustomerVendorAddressCount

int getAllCustomerVendorAddressCount()
                                     throws java.lang.Exception
Throws:
java.lang.Exception

getCustomerVendorAddressById

CustomerVendorAddressVO getCustomerVendorAddressById(java.lang.String id)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

findCustomerVendorAddressesById

java.util.Collection<CustomerVendorAddressInfoVO> findCustomerVendorAddressesById(java.lang.String idRegex,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findCustomerVendorAddressesById

java.util.Collection<CustomerVendorAddressInfoVO> findCustomerVendorAddressesById(java.lang.String addrId,
                                                                                java.lang.String withoutId,
                                                                                java.lang.String addressType)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getCustomerVendorInfoVoById

CustomerVendorAddressInfoVO getCustomerVendorInfoVoById(java.lang.String id,
                                                        java.lang.String languageCode)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

findCustomerVendorAddressesByName

java.util.Collection<CustomerVendorAddressInfoVO> findCustomerVendorAddressesByName(java.lang.String nameRegex,
                                                                                java.lang.String languageCode,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

addCustomerVendorAddress

CustomerVendorAddressVO addCustomerVendorAddress(CustomerVendorAddressVO cvAddress)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

updateCustomerVendorAddress

CustomerVendorAddressVO updateCustomerVendorAddress(CustomerVendorAddressVO cvAddress)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

constructCustomerVendorAddressForCRFQ

CustomerVendorAddressVO constructCustomerVendorAddressForCRFQ(java.lang.String crfqNumber)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getCustomerVendorInfoVoById

CustomerVendorAddressInfoVO getCustomerVendorInfoVoById(java.lang.String id)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

isAddressExistent

boolean isAddressExistent(java.lang.String id)
                          throws java.lang.Exception
Throws:
java.lang.Exception

isAddressDeleted

boolean isAddressDeleted(java.lang.String id)
                         throws java.lang.Exception
Throws:
java.lang.Exception

copyCVFormCV

java.lang.String copyCVFormCV(CV2CVAgent agent)
                              throws java.lang.Exception
Throws:
java.lang.Exception

findAllCVAddress

java.util.Collection<CustomerVendorAddressInfoVO> findAllCVAddress()
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getCustomerVendorsCountById

int getCustomerVendorsCountById(java.lang.String customerId)
                                throws java.lang.Exception
Throws:
java.lang.Exception

getCustomerVendorsCountByName

int getCustomerVendorsCountByName(java.lang.String name)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findCustomerVendors

java.util.Collection<CustomerVendorAddressInfoVO> findCustomerVendors(java.lang.String addrId,
                                                                      java.lang.String name,
                                                                      java.lang.String customerType,
                                                                      java.lang.String vendorType,
                                                                      java.lang.String vendorCategory,
                                                                      java.lang.String criticalLevel,
                                                                      java.lang.String qualityStatus,
                                                                      int firstIndex,
                                                                      int maxLength)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getCustomerVendorsCount

int getCustomerVendorsCount(java.lang.String addrId,
                            java.lang.String name,
                            java.lang.String customerType,
                            java.lang.String vendorType,
                            java.lang.String vendorCategory,
                            java.lang.String criticalLevel,
                            java.lang.String qualityStatus)
                            throws java.lang.Exception
Throws:
java.lang.Exception

isCustomer

boolean isCustomer(java.lang.String addressId)
                   throws java.lang.Exception
Throws:
java.lang.Exception

isVendor

boolean isVendor(java.lang.String addressId)
                 throws java.lang.Exception
Throws:
java.lang.Exception

isExtCustomerArTotalDue

boolean isExtCustomerArTotalDue(java.lang.String customerId)
                                throws java.lang.Exception
Throws:
java.lang.Exception

isCustomerHold

CustomerCLimitResult isCustomerHold(java.lang.String customerId)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

updateCustomerHold

void updateCustomerHold(java.lang.String id,
                        boolean cHold)
                        throws java.lang.Exception
Throws:
java.lang.Exception

findCustomerVendorbyType

java.util.Collection<CustomerVendorAddressInfoVO> findCustomerVendorbyType(java.lang.String[] types,
                                                                           int firstIndex,
                                                                           int maxLength)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getCustomerVendorbyTypeCount

int getCustomerVendorbyTypeCount(java.lang.String[] types)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

updateCustomerVendorType

void updateCustomerVendorType(java.util.HashSet customerVendors,
                              java.lang.String type)
                              throws java.lang.Exception
Throws:
java.lang.Exception

addCustomer

CustomerVendorAddressVO addCustomer(CustomerVendorAddressVO vo)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

updateCustomer

CustomerVendorAddressVO updateCustomer(CustomerVendorAddressVO vo)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

updateCustomerToAllType

void updateCustomerToAllType(CustomerVendorAddressVO vo)
                             throws java.lang.Exception
Throws:
java.lang.Exception

updateCustomerDeletedFlag

void updateCustomerDeletedFlag(java.lang.String id,
                               boolean isDeleted)
                               throws java.lang.Exception
Throws:
java.lang.Exception

isCustomerExist

boolean isCustomerExist(java.lang.String id)
                        throws java.lang.Exception
Throws:
java.lang.Exception

getCustomerById

CustomerVendorAddressVO getCustomerById(java.lang.String addressId)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findAllCustomers

java.util.Collection<CustomerVendorAddressInfoVO> findAllCustomers(int firstIndex,
                                                                   int maxLength)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getAllCustomersCount

int getAllCustomersCount()
                         throws java.lang.Exception
Throws:
java.lang.Exception

findCustomerAddressesById

java.util.Collection<CustomerVendorAddressInfoVO> findCustomerAddressesById(java.lang.String idRegex,
                                                                            int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getCustomerAddressesByIdCount

int getCustomerAddressesByIdCount(java.lang.String idRegex)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findDeletedCustomersById

java.util.Collection<CustomerVendorAddressInfoVO> findDeletedCustomersById(java.lang.String customerId,
                                                                           int firstIndex,
                                                                           int maxLength)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getDeletedCustomersCountById

int getDeletedCustomersCountById(java.lang.String customerId)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findCustomerAddressesByName

java.util.Collection<CustomerVendorAddressInfoVO> findCustomerAddressesByName(java.lang.String nameRegex,
                                                                              java.lang.String languageCode,
                                                                              int firstIndex,
                                                                              int maxLength)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getCustomerAddressesByNameCount

int getCustomerAddressesByNameCount(java.lang.String nameRegex)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findCustomersList

java.util.Collection<CustomerVendorAddressInfoVO> findCustomersList(java.lang.String addrId,
                                                                    java.lang.String name,
                                                                    java.lang.String customerType,
                                                                    int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getCustomersListCount

int getCustomersListCount(java.lang.String addrId,
                          java.lang.String name,
                          java.lang.String customerType)
                          throws java.lang.Exception
Throws:
java.lang.Exception

addCustomerAndVendor

CustomerVendorAddressVO addCustomerAndVendor(CustomerVendorAddressVO vo)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

updateVendorToAllType

void updateVendorToAllType(CustomerVendorAddressVO vo)
                           throws java.lang.Exception
Throws:
java.lang.Exception

deleteAllAddresWhenInit

void deleteAllAddresWhenInit()
                             throws java.lang.Exception
Throws:
java.lang.Exception

addVendor

CustomerVendorAddressVO addVendor(CustomerVendorAddressVO vo)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

updateVendor

CustomerVendorAddressVO updateVendor(CustomerVendorAddressVO vo)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

updateVendorQualityInfo

CustomerVendorAddressVO updateVendorQualityInfo(CustomerVendorAddressVO vo)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

updateVendorDeletedFlag

void updateVendorDeletedFlag(java.lang.String id,
                             boolean isDeleted)
                             throws java.lang.Exception
Throws:
java.lang.Exception

isVendorExist

boolean isVendorExist(java.lang.String id)
                      throws java.lang.Exception
Throws:
java.lang.Exception

getVendorById

CustomerVendorAddressVO getVendorById(java.lang.String addressId)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findAllVendors

java.util.Collection<CustomerVendorAddressInfoVO> findAllVendors(int firstIndex,
                                                                 int maxLength)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getAllVendorsCount

int getAllVendorsCount()
                       throws java.lang.Exception
Throws:
java.lang.Exception

findDeletedVendorsById

java.util.Collection<CustomerVendorAddressInfoVO> findDeletedVendorsById(java.lang.String vendorId,
                                                                         int firstIndex,
                                                                         int maxLength)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getDeletedVendorsCountById

int getDeletedVendorsCountById(java.lang.String vendorId)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findVendorAddressesById

java.util.Collection<CustomerVendorAddressInfoVO> findVendorAddressesById(java.lang.String idRegex,
                                                                          int firstIndex,
                                                                          int maxLength)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getVendorAddressesByIdCount

int getVendorAddressesByIdCount(java.lang.String customerId)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findVendorAddressesByName

java.util.Collection<CustomerVendorAddressInfoVO> findVendorAddressesByName(java.lang.String nameRegex,
                                                                            java.lang.String languageCode,
                                                                            int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getVendorAddressesByNameCount

int getVendorAddressesByNameCount(java.lang.String nameRegex)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findVendorsList

java.util.Collection<CustomerVendorAddressInfoVO> findVendorsList(java.lang.String vendorId,
                                                                  java.lang.String name,
                                                                  java.lang.String vendorType,
                                                                  java.lang.String vendorCategory,
                                                                  java.lang.String criticalLevel,
                                                                  java.lang.String qualityStatus,
                                                                  int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

findVendorsListForSeparate

java.util.Collection<CustomerVendorAddressInfoVO> findVendorsListForSeparate(java.lang.String vendorId,
                                                                             java.lang.String name,
                                                                             java.lang.String vendorType,
                                                                             java.lang.String vendorCategory,
                                                                             java.lang.String criticalLevel,
                                                                             java.lang.String qualityStatus,
                                                                             int firstIndex,
                                                                             int maxLength)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getVendorsListCount

int getVendorsListCount(java.lang.String vendorId,
                        java.lang.String name,
                        java.lang.String vendorType,
                        java.lang.String vendorCategory,
                        java.lang.String criticalLevel,
                        java.lang.String qualityStatus)
                        throws java.lang.Exception
Throws:
java.lang.Exception

getVendorsListForSeparateCount

int getVendorsListForSeparateCount(java.lang.String vendorId,
                                   java.lang.String name,
                                   java.lang.String vendorType,
                                   java.lang.String vendorCategory,
                                   java.lang.String criticalLevel,
                                   java.lang.String qualityStatus)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

addDepartment

CustomerVendorAddressVO addDepartment(CustomerVendorAddressVO vo)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

updateDepartment

CustomerVendorAddressVO updateDepartment(CustomerVendorAddressVO vo)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

updateDepartmentDeletedFlag

void updateDepartmentDeletedFlag(java.lang.String id,
                                 boolean isDeleted)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

isDepartmentExist

boolean isDepartmentExist(java.lang.String id)
                          throws java.lang.Exception
Throws:
java.lang.Exception

getDepartmentById

CustomerVendorAddressVO getDepartmentById(java.lang.String id)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

findAllDepartments

java.util.Collection<CustomerVendorAddressVO> findAllDepartments(int firstIndex,
                                                                 int maxLength)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getAllDepartmentsCount

int getAllDepartmentsCount()
                           throws java.lang.Exception
Throws:
java.lang.Exception

findDeletedDepartmentsById

java.util.Collection<CustomerVendorAddressVO> findDeletedDepartmentsById(java.lang.String id,
                                                                         int firstIndex,
                                                                         int maxLength)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getDeletedDepartmentsCountById

int getDeletedDepartmentsCountById(java.lang.String id)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findDepartmentsById

java.util.Collection<CustomerVendorAddressVO> findDepartmentsById(java.lang.String id,
                                                                  int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getDepartmentsCountById

int getDepartmentsCountById(java.lang.String id)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findDepartmentsByName

java.util.Collection<CustomerVendorAddressVO> findDepartmentsByName(java.lang.String name,
                                                                    java.lang.String languageCode,
                                                                    int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getDepartmentsCountByName

int getDepartmentsCountByName(java.lang.String name)
                              throws java.lang.Exception
Throws:
java.lang.Exception

findAllManufacturerAddresses

java.util.Collection<ManufacturerAddressInfoVO> findAllManufacturerAddresses(int firstIndex,
                                                                             int maxLength)
                                                                             throws java.lang.Exception
*********************below is about ManufacturerAddress*********************

Throws:
java.lang.Exception

getAllManufacturerAddressesCount

int getAllManufacturerAddressesCount()
                                     throws java.lang.Exception
Throws:
java.lang.Exception

getManufacturerAddressById

ManufacturerAddressVO getManufacturerAddressById(java.lang.String id)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getManufacturerAddressById

ManufacturerAddressVO getManufacturerAddressById(java.lang.String id,
                                                 java.lang.String languageCode)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

isManufacturerIdExist

boolean isManufacturerIdExist(java.lang.String manufacturerId)
                              throws java.lang.Exception
Throws:
java.lang.Exception

updateManufacturerAddressDeletedFlag

java.lang.String updateManufacturerAddressDeletedFlag(java.lang.String manufacturerId,
                                                      boolean isDeleted)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

findDeletedManufacturerAddresses

java.util.Collection<ManufacturerAddressInfoVO> findDeletedManufacturerAddresses(java.lang.String manufacturerId,
                                                                                java.lang.String name,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getDeletedManufacturerAddressesCount

int getDeletedManufacturerAddressesCount(java.lang.String manufacturerId,
                                         java.lang.String name)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

updateManufacturerAddress

ManufacturerAddressVO updateManufacturerAddress(ManufacturerAddressVO vo)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

addManufacturerAddress

ManufacturerAddressVO addManufacturerAddress(ManufacturerAddressVO vo)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findManufacturerAddressesById

java.util.Collection<ManufacturerAddressInfoVO> findManufacturerAddressesById(java.lang.String idRegex,
                                                                              int firstIndex,
                                                                              int maxLength)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

findManufacturerAddressesByName

java.util.Collection<ManufacturerAddressInfoVO> findManufacturerAddressesByName(java.lang.String nameRegex,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getManufacturerAddressesCountById

int getManufacturerAddressesCountById(java.lang.String id)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

getManufacturerAddressesCountByName

int getManufacturerAddressesCountByName(java.lang.String name)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findCarriersByAddressId

java.util.Collection<CarrierVO> findCarriersByAddressId(java.lang.String addressId)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getCarriersCountByAddressId

int getCarriersCountByAddressId(java.lang.String addressId)
                                throws java.lang.Exception
Throws:
java.lang.Exception

updateCarrier

java.util.Collection<CarrierVO> updateCarrier(CarrierVO vo)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

updateCarrier

java.util.Collection<CarrierVO> updateCarrier(java.util.Vector carrierVoList,
                                              java.lang.String addressId)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

addCarrier

CarrierVO addCarrier(CarrierVO vo)
                     throws java.lang.Exception
Throws:
java.lang.Exception

deleteCarrier

void deleteCarrier(CarrierVO vo)
                   throws java.lang.Exception
Throws:
java.lang.Exception

getCarrierByPk

CarrierVO getCarrierByPk(CarrierPK pk)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findCarrierByAddressIds

java.util.Collection<CarrierVO> findCarrierByAddressIds(java.lang.String[] addressIds)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getCVAddressTotalInfo

CustomerVendorAddressTotalInfo getCVAddressTotalInfo(java.lang.String vendorId)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getCustomerTotalInfo

CustomerVendorAddressTotalInfo getCustomerTotalInfo(java.lang.String vendorId)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getVendorTotalInfo

CustomerVendorAddressTotalInfo getVendorTotalInfo(java.lang.String vendorId)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getDepartmentTotalInfo

CustomerVendorAddressTotalInfo getDepartmentTotalInfo(java.lang.String vendorId)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

updateAddressQualityInfo

CustomerVendorAddressVO updateAddressQualityInfo(CustomerVendorAddressVO cvAddress)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getCustomerVendorTypeByID

CustomerVendorTypeVO getCustomerVendorTypeByID(int id)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

getCustomerTypeByType

CustomerVendorTypeVO getCustomerTypeByType(java.lang.String customerType)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

getVendorTypeByType

CustomerVendorTypeVO getVendorTypeByType(java.lang.String vendorType)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

addCustomerType

java.lang.Integer addCustomerType(java.lang.String customerType,
                                  java.lang.String comments)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

addVendorType

java.lang.Integer addVendorType(java.lang.String vendorType,
                                java.lang.String comments)
                                throws java.lang.Exception
Throws:
java.lang.Exception

deleteCustomerVendorType

void deleteCustomerVendorType(CustomerVendorTypeVO vo)
                              throws java.lang.Exception
Throws:
java.lang.Exception

findAllCustomerType

java.util.Collection<CustomerVendorTypeVO> findAllCustomerType(int firstIndex,
                                                               int maxLength)
                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getAllCustomerTypeCount

int getAllCustomerTypeCount()
                            throws java.lang.Exception
Throws:
java.lang.Exception

findAllVendorType

java.util.Collection<CustomerVendorTypeVO> findAllVendorType(int firstIndex,
                                                             int maxLength)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getAllVendorTypeCount

int getAllVendorTypeCount()
                          throws java.lang.Exception
Throws:
java.lang.Exception

updateCustomerVendorType

CustomerVendorTypeVO updateCustomerVendorType(CustomerVendorTypeVO vo)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

addVendorCategories

VendorCategoriesVO addVendorCategories(VendorCategoriesVO vo)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

getVendorCategoriesById

VendorCategoriesVO getVendorCategoriesById(java.lang.String vendorCategory)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

updateVendorCategories

VendorCategoriesVO updateVendorCategories(VendorCategoriesVO vo)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

deleteVendorCategories

void deleteVendorCategories(java.lang.String vendorCategory)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findVendorCategories

java.util.Collection<VendorCategoriesVO> findVendorCategories(java.lang.String vendorCategory,
                                                              int firstIndex,
                                                              int maxLength)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getVendorCategoriesCount

int getVendorCategoriesCount(java.lang.String vendorCategory)
                             throws java.lang.Exception
Throws:
java.lang.Exception

addVendorCriticalLevel

VendorCriticalLevelVO addVendorCriticalLevel(VendorCriticalLevelVO vo)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

getVendorCriticalLevelById

VendorCriticalLevelVO getVendorCriticalLevelById(java.lang.String vendorCategory)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

updateVendorCriticalLevel

VendorCriticalLevelVO updateVendorCriticalLevel(VendorCriticalLevelVO vo)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

deleteVendorCriticalLevel

void deleteVendorCriticalLevel(java.lang.String vendorCategory)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findVendorCriticalLevel

java.util.Collection<VendorCriticalLevelVO> findVendorCriticalLevel(java.lang.String vendorCategory,
                                                                    int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getVendorCriticalLevelCount

int getVendorCriticalLevelCount(java.lang.String vendorCategory)
                                throws java.lang.Exception
Throws:
java.lang.Exception

addVendorGroupUser

VendorGroupUserVO addVendorGroupUser(VendorGroupUserVO vo)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

updateVendorGroupUser

void updateVendorGroupUser(VendorGroupUserVO vo)
                           throws java.lang.Exception
Throws:
java.lang.Exception

getVendorGroupUser

VendorGroupUserVO getVendorGroupUser(java.lang.String userName)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

isVendorGroupUserExistent

boolean isVendorGroupUserExistent(java.lang.String userName)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

deleteVendorGroupUser

void deleteVendorGroupUser(java.lang.String userName)
                           throws java.lang.Exception
Throws:
java.lang.Exception

resetVendorGroupPassword

java.lang.String resetVendorGroupPassword(java.lang.String userName)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

findVgUser

java.util.Collection<VendorGroupUserVO> findVgUser(java.lang.String addressId,
                                                   java.lang.String userName,
                                                   int firstIndex,
                                                   int maxLength)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getVgUserCount

int getVgUserCount(java.lang.String addressId,
                   java.lang.String userName)
                   throws java.lang.Exception
Throws:
java.lang.Exception

addSgClientProgramUser

SgClientProgramUserVO addSgClientProgramUser(SgClientProgramUserVO vo)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

getSgClientProgramUser

SgClientProgramUserVO getSgClientProgramUser(java.lang.String addressId)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

updateSgClientProgramUser

void updateSgClientProgramUser(SgClientProgramUserVO vo)
                               throws java.lang.Exception
Throws:
java.lang.Exception

isSgClientProgramUserExistent

boolean isSgClientProgramUserExistent(java.lang.String addressId)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

deleteSgClientProgramUser

void deleteSgClientProgramUser(java.lang.String addressID)
                               throws java.lang.Exception
Throws:
java.lang.Exception

resetSgClientProgramPassword

java.lang.String resetSgClientProgramPassword(java.lang.String addressID)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

findSgClientProgramUser

java.util.Collection<CustomerVendorAddressInfoVO> findSgClientProgramUser(java.lang.String addressId,
                                                                          java.lang.String addressName,
                                                                          int firstIndex,
                                                                          int maxLength)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getSgClientProgramUserCount

int getSgClientProgramUserCount(java.lang.String addressId,
                                java.lang.String addressName)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findSGClientProgramUsers

java.util.Collection<SgClientProgramUserVO> findSGClientProgramUsers(java.lang.String addressID,
                                                                     java.lang.String userName,
                                                                     java.lang.Object[] parameters,
                                                                     int firstIndex,
                                                                     int maxLength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getSGClientProgramUsersCount

int getSGClientProgramUsersCount(java.lang.String addressID,
                                 java.lang.String userName,
                                 java.lang.Object[] parameters)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

updateCustomerVendorDeletedFlag

void updateCustomerVendorDeletedFlag(java.lang.String addressID,
                                     boolean isDeleted)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findDeletedCustomerVendorAddressesById

java.util.Collection<CustomerVendorAddressInfoVO> findDeletedCustomerVendorAddressesById(java.lang.String idRegex,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getDeletedCustomerVendorAddressesByIdCount

int getDeletedCustomerVendorAddressesByIdCount(java.lang.String idRegex)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

findAllLockedCustomer

java.util.Collection<CustomerVendorAddressInfoVO> findAllLockedCustomer(boolean lockTypeIsOverCreditLimit,
                                                                        int firstIndex,
                                                                        int maxLength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getAllLockedCustomerCount

int getAllLockedCustomerCount(boolean lockTypeIsOverCreditLimit)
                              throws java.lang.Exception
Throws:
java.lang.Exception

findAddressContactCount

int findAddressContactCount(java.lang.String addressID,
                            java.lang.String addressName)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findAllAddressContact

java.util.Collection<CustomerVendorContactVO> findAllAddressContact(java.lang.String addressID,
                                                                    java.lang.String addressName,
                                                                    int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getAllExpireDateDocCount

int getAllExpireDateDocCount(java.lang.String ii,
                             java.lang.String type,
                             java.lang.String dateType,
                             java.util.Date from,
                             java.util.Date to,
                             java.lang.String addressId)
                             throws java.lang.Exception
Throws:
java.lang.Exception

findAllExpireDateDoc

java.util.Collection<AddressQualityDocumentsVO> findAllExpireDateDoc(java.lang.String searchText,
                                                                     java.lang.String type,
                                                                     java.lang.String dateType,
                                                                     java.util.Date from,
                                                                     java.util.Date to,
                                                                     java.lang.String addressId,
                                                                     int firstIndex,
                                                                     int maxLength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

findCustomerVendorsByValidDate

java.util.List findCustomerVendorsByValidDate(java.util.Date validDate,
                                              int firstIndex,
                                              int maxLength)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

getCustomerVendorsCountByValidDate

int getCustomerVendorsCountByValidDate(java.util.Date validDate)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findDepartmentsList

java.util.Collection<CustomerVendorAddressInfoVO> findDepartmentsList(java.lang.String addrId,
                                                                      java.lang.String name,
                                                                      int firstIndex,
                                                                      int maxLength)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

isParent

boolean isParent(java.lang.String id)
                 throws java.lang.Exception
Throws:
java.lang.Exception

getDepartmentsListCount

int getDepartmentsListCount(java.lang.String addrId,
                            java.lang.String name)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findAddressContactCount

int findAddressContactCount(java.lang.String addressID,
                            java.lang.String addressName,
                            boolean idLike)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findAllAddressContact

java.util.Collection<CustomerVendorContactVO> findAllAddressContact(java.lang.String addressID,
                                                                    java.lang.String addressName,
                                                                    boolean idLike,
                                                                    int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getAllTaxType

java.util.List<java.lang.String> getAllTaxType()
                                               throws java.lang.Exception
Throws:
java.lang.Exception

getCustomerVendorsByRegionCount

int getCustomerVendorsByRegionCount(java.lang.String region,
                                    java.lang.String addressType)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findCustomerVendorsByRegion

java.util.List findCustomerVendorsByRegion(java.lang.String region,
                                           java.lang.String addressType,
                                           int firstIndex,
                                           int maxLength)
                                           throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AddressQualityDocumentsVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AddressQualityDocumentsVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AddressQualityDocumentsVO
All Implemented Interfaces:
java.io.Serializable
public class AddressQualityDocumentsVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AddressQualityDocumentsVO()
default constructor
AddressQualityDocumentsVO(java.lang.String addressId, java.lang.String docType, java.lang.String lastChangeUser, java.util.Date lastChangeDate, java.util.Date uploadDate, java.lang.String documentDescription, java.lang.Long documentLength, java.lang.String documentExtension)
full constructor
AddressQualityDocumentsVO(java.lang.String addressId, java.lang.String docType, java.lang.String lastChangeUser, java.lang.String documentExtension)
minimal constructor
Method Summary
java.lang.String | getAddressId()
java.lang.String | getCategory()
java.lang.String | getDocName()
java.lang.String | getDocType()
java.lang.String | getDocumentDescription()
java.lang.String | getDocumentExtension()
java.lang.Long | getDocumentLength()
java.util.Date | getExpireDate()
java.lang.Long | getIi()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.util.Date | getUploadDate()
void | setAddressId(java.lang.String addressId)
void | setCategory(java.lang.String category)
void | setDocName(java.lang.String docName)
void | setDocType(java.lang.String docType)
void | setDocumentDescription(java.lang.String documentDescription)
void | setDocumentExtension(java.lang.String documentExtension)
void | setDocumentLength(java.lang.Long documentLength)
void | setExpireDate(java.util.Date expireDate)
void | setIi(java.lang.Long ii)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setUploadDate(java.util.Date uploadDate)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AddressQualityDocumentsVO

public AddressQualityDocumentsVO(java.lang.String addressId,
                                 java.lang.String docType,
                                 java.lang.String lastChangeUser,
                                 java.util.Date lastChangeDate,
                                 java.util.Date uploadDate,
                                 java.lang.String documentDescription,
                                 java.lang.Long documentLength,
                                 java.lang.String documentExtension)
full constructor

AddressQualityDocumentsVO

public AddressQualityDocumentsVO()
default constructor

AddressQualityDocumentsVO

public AddressQualityDocumentsVO(java.lang.String addressId,
                                 java.lang.String docType,
                                 java.lang.String lastChangeUser,
                                 java.lang.String documentExtension)
minimal constructor

Method Detail

getCategory

public java.lang.String getCategory()

setCategory

public void setCategory(java.lang.String category)

getExpireDate

public java.util.Date getExpireDate()

setExpireDate

public void setExpireDate(java.util.Date expireDate)

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getAddressId

public java.lang.String getAddressId()

setAddressId

public void setAddressId(java.lang.String addressId)

getDocType

public java.lang.String getDocType()

setDocType

public void setDocType(java.lang.String docType)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getUploadDate

public java.util.Date getUploadDate()

setUploadDate

public void setUploadDate(java.util.Date uploadDate)

getDocumentDescription

public java.lang.String getDocumentDescription()

setDocumentDescription

public void setDocumentDescription(java.lang.String documentDescription)

getDocumentLength

public java.lang.Long getDocumentLength()

setDocumentLength

public void setDocumentLength(java.lang.Long documentLength)

getDocName

public java.lang.String getDocName()

setDocName

public void setDocName(java.lang.String docName)

getDocumentExtension

public java.lang.String getDocumentExtension()

setDocumentExtension

public void setDocumentExtension(java.lang.String documentExtension)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AddRTVAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AddRTVAgent

java.lang.Object
    extended by  bb.common.AddRTVAgent
All Implemented Interfaces:
java.io.Serializable
public class AddRTVAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AddRTVAgent()
Method Summary
java.util.List<PurchaseOrderItemPK> | getPoItemPk()
java.lang.String | getValue()
boolean | isByVendor()
void | setByVendor(boolean byVendor)
void | setPoItemPk(java.util.List<PurchaseOrderItemPK> poItemPk)
void | setValue(java.lang.String value)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AddRTVAgent

public AddRTVAgent()
Method Detail

getValue

public java.lang.String getValue()

setValue

public void setValue(java.lang.String value)

isByVendor

public boolean isByVendor()

setByVendor

public void setByVendor(boolean byVendor)

getPoItemPk

public java.util.List<PurchaseOrderItemPK> getPoItemPk()

setPoItemPk

public void setPoItemPk(java.util.List<PurchaseOrderItemPK> poItemPk)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


A-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M N O P Q R S T U V W X Y Z

A

A - Static variable in class bb.common.Constant.Prefix
A - Static variable in class bb.common.Constant.TransactionType
AC - Static variable in class bb.common.Constant.ChartOfAccountType
ACA - Static variable in class bb.common.Constant.AmountType
ACCELERATED_DEPRECIATIONMETHODS - Static variable in class bb.common.Constant.Depreciation.DepreciationMethod
Accepted - Static variable in class bb.common.Constant.Status
acceptPoMessage(String, String, Hashtable) - Method in interface bb.common.box.PurchasingBox
acceptRfqMessage(String, String, Hashtable, boolean) - Method in interface bb.common.box.PurchasingBox
ACCOUNT_CHART - Static variable in class bb.common.BizTarget
ACCOUNT_CHART_CATEGORY - Static variable in class bb.common.BizTarget
ACCOUNT_CHART_CATEGORY_ALREADY_EXIST - Static variable in class bb.common.BIZReason
ACCOUNT_CHART_CATEGORY_NAME_ALREADY_EXIST - Static variable in class bb.common.BIZReason
ACCOUNT_CHART_CATEGORY_NAME_NOT_EXIST - Static variable in class bb.common.BIZReason
ACCOUNT_CHART_CATEGORY_NOT_EXIST - Static variable in class bb.common.BIZReason
ACCOUNT_CHART_MAPPING - Static variable in class bb.common.BizTarget
ACCOUNT_CHART_MAPPING_ALREADY_EXIST - Static variable in class bb.common.BIZReason
ACCOUNT_CHART_MAPPING_NOT_EXIST - Static variable in class bb.common.BIZReason
ACCOUNT_CHART_NUMBER - Static variable in class bb.common.BizTarget
ACCOUNT_CHECK_RUN - Static variable in class bb.common.BizTarget
ACCOUNT_CREDIT - Static variable in class bb.common.BizTarget
ACCOUNT_CREDIT_DEBIT_WRONG - Static variable in class bb.common.BIZReason
ACCOUNT_DEBIT - Static variable in class bb.common.BizTarget
ACCOUNT_FISCALYEAR_SETTING_NOT_EXIST - Static variable in class bb.common.BIZReason
ACCOUNT_FISCALYEAR_SETTINGS - Static variable in class bb.common.BizTarget
ACCOUNT_GENERALlEDGER_SETTTINGS - Static variable in class bb.common.BizTarget
ACCOUNT_MUST_BE_CURRENT_ASSET - Static variable in class bb.common.BIZReason
ACCOUNT_NUMBER_ALREADY_EXIST - Static variable in class bb.common.BIZReason
ACCOUNT_NUMBER_HAS_CHILD - Static variable in class bb.common.BIZReason
ACCOUNT_NUMBER_IN_USE - Static variable in class bb.common.BIZReason
ACCOUNT_NUMBER_IS_NOT_EXPENSE_ACCOUNT - Static variable in class bb.common.BIZReason
ACCOUNT_NUMBER_IS_USED_IN_ASSET - Static variable in class bb.common.BIZReason
ACCOUNT_NUMBER_IS_USED_IN_CREDIT - Static variable in class bb.common.BIZReason
ACCOUNT_NUMBER_IS_USED_IN_DEBIT - Static variable in class bb.common.BIZReason
ACCOUNT_NUMBER_NOT_EXIST - Static variable in class bb.common.BIZReason
ACCOUNT_NUMBER_USING_IN_OPEN_FISCAL_YEAR - Static variable in class bb.common.BIZReason
ACCOUNT_PAYABLE - Static variable in class bb.common.BizTarget
ACCOUNT_PAYABLE_NOT_EXIST - Static variable in class bb.common.BIZReason
ACCOUNT_PAYABLE_PREPAY - Static variable in class bb.common.BizTarget
ACCOUNT_PAYMENT_RUN - Static variable in class bb.common.BizTarget
ACCOUNT_RECEIVABLE - Static variable in class bb.common.BizTarget
ACCOUNT_RECEIVABLE_PAYMENT - Static variable in class bb.common.BizTarget
ACCOUNT_RECEIVABLE_PREPAY - Static variable in class bb.common.BizTarget
ACCOUNT_SETTING - Static variable in class bb.common.BizTarget
ACCOUNT_SETTINGS_DID_NOT_SET_WIP_START_DATE - Static variable in class bb.common.BIZReason
ACCOUNT_SETTINGS_GA_COGS_WRONG - Static variable in class bb.common.BIZReason
ACCOUNT_SETTINGS_GA_PROFIT_FOR_CURRENT_YEAR_WRONG - Static variable in class bb.common.BIZReason
ACCOUNT_SETTINGS_GA_WIP_WRONG - Static variable in class bb.common.BIZReason
ACCOUNT_SETTINGS_NOT_EXIST - Static variable in class bb.common.BIZReason
ACCOUNT_SETTINGS_UNKNOWN_INVENTORY_COST_MOTHED - Static variable in class bb.common.BIZReason
ACCOUNT_TRANSACTION - Static variable in class bb.common.BizTarget
ACCOUNT_TRANSACTION_TYPE - Static variable in class bb.common.BizTarget
ACCOUNT_TRANSACTION_TYPE_ALREADY_EXIST - Static variable in class bb.common.BIZReason
ACCOUNT_TRANSACTION_TYPE_NOT_EXIST - Static variable in class bb.common.BIZReason
ACCOUNT_TYPE_EMPTY - Static variable in class bb.common.BIZReason
AccountAgingTotalResult - Class in bb.common
AccountAgingTotalResult() - Constructor for class bb.common.AccountAgingTotalResult
AccountAuditAgent - Class in bb.common
AccountAuditAgent() - Constructor for class bb.common.AccountAuditAgent
AccountBalanceAgent - Class in bb.common
AccountBalanceAgent() - Constructor for class bb.common.AccountBalanceAgent
AccountBalanceListResult - Class in bb.common
AccountBalanceListResult() - Constructor for class bb.common.AccountBalanceListResult
AccountBalanceResult - Class in bb.common
AccountBalanceResult() - Constructor for class bb.common.AccountBalanceResult
AccountCreditDebitPK - Class in bb.common
AccountCreditDebitPK(Integer, String) - Constructor for class bb.common.AccountCreditDebitPK
full constructor
AccountCreditDebitPK() - Constructor for class bb.common.AccountCreditDebitPK
default constructor
AccountCreditVO - Class in bb.common
AccountCreditVO() - Constructor for class bb.common.AccountCreditVO
default constructor
AccountDebitVO - Class in bb.common
AccountDebitVO() - Constructor for class bb.common.AccountDebitVO
default constructor
AccountInfoCenterItemResult - Class in bb.common
AccountInfoCenterItemResult() - Constructor for class bb.common.AccountInfoCenterItemResult
AccountInfoCenterResult - Class in bb.common
AccountInfoCenterResult() - Constructor for class bb.common.AccountInfoCenterResult
ACCOUNTING - Static variable in class bb.common.Configure.Module
ACCOUNTING_INFO_DOC - Static variable in class bb.common.BizTarget
ACCOUNTING_INFO_DOC_NOT_FIND - Static variable in class bb.common.BIZReason
ACCOUNTING_MAIL - Static variable in class bb.common.Constant.CustomerVendorMailType
ACCOUNTING_PERIOD - Static variable in class bb.common.BizTarget
ACCOUNTING_PERIOD_ALREADY_EXISTS - Static variable in class bb.common.BIZReason
ACCOUNTING_REPORTS_IN_THIS_FISCAL_YEAR__NEED_TO_BACK_UP - Static variable in class bb.common.BIZReason
AccountingBalanceSheetResult - Class in bb.common
AccountingBalanceSheetResult() - Constructor for class bb.common.AccountingBalanceSheetResult
AccountingBox - Interface in bb.common.box
AccountingConfigurationVO - Class in bb.common
AccountingConfigurationVO() - Constructor for class bb.common.AccountingConfigurationVO
AccountingInfoDocumentVO - Class in bb.common
AccountingInfoDocumentVO() - Constructor for class bb.common.AccountingInfoDocumentVO
AccountingSettingsVO - Class in bb.common
AccountingSettingsVO() - Constructor for class bb.common.AccountingSettingsVO
default constructor
AccountingTotalMoneyResult - Class in bb.common
AccountingTotalMoneyResult() - Constructor for class bb.common.AccountingTotalMoneyResult
AccountingTransactionTypeVO - Class in bb.common
AccountingTransactionTypeVO() - Constructor for class bb.common.AccountingTransactionTypeVO
AccountMonthPK - Class in bb.common
AccountMonthPK(String, String, String) - Constructor for class bb.common.AccountMonthPK
full constructor
AccountMonthPK() - Constructor for class bb.common.AccountMonthPK
default constructor
AccountPayableCheckRunItemVO - Class in bb.common
AccountPayableCheckRunItemVO() - Constructor for class bb.common.AccountPayableCheckRunItemVO
default constructor
AccountPayableCheckRunVO - Class in bb.common
AccountPayableCheckRunVO() - Constructor for class bb.common.AccountPayableCheckRunVO
default constructor
AccountPayableCheckVO - Class in bb.common
AccountPayableCheckVO() - Constructor for class bb.common.AccountPayableCheckVO
default constructor
AccountPayableInfoWithPrepayResult - Class in bb.common
AccountPayableInfoWithPrepayResult() - Constructor for class bb.common.AccountPayableInfoWithPrepayResult
AccountReceivableInfoWithPrepayResult - Class in bb.common
AccountReceivableInfoWithPrepayResult() - Constructor for class bb.common.AccountReceivableInfoWithPrepayResult
AccountReceivablePaymentVO - Class in bb.common
AccountReceivablePaymentVO() - Constructor for class bb.common.AccountReceivablePaymentVO
default constructor
AccountsChartAdvanceCategoryVO - Class in bb.common
AccountsChartAdvanceCategoryVO() - Constructor for class bb.common.AccountsChartAdvanceCategoryVO
AccountsChartCategoryListResult - Class in bb.common
AccountsChartCategoryListResult() - Constructor for class bb.common.AccountsChartCategoryListResult
AccountsChartCategoryVO - Class in bb.common
AccountsChartCategoryVO() - Constructor for class bb.common.AccountsChartCategoryVO
AccountsChartMappingPK - Class in bb.common
AccountsChartMappingPK() - Constructor for class bb.common.AccountsChartMappingPK
AccountsChartMappingVO - Class in bb.common
AccountsChartMappingVO() - Constructor for class bb.common.AccountsChartMappingVO
AccountsChartResult - Class in bb.common
AccountsChartResult() - Constructor for class bb.common.AccountsChartResult
AccountsChartVO - Class in bb.common
AccountsChartVO() - Constructor for class bb.common.AccountsChartVO
AccountsCreditDebitListResult - Class in bb.common
AccountsCreditDebitListResult() - Constructor for class bb.common.AccountsCreditDebitListResult
ACCOUNTSPAYABLE - Static variable in class bb.common.Constant.OrderType
AccountsPayableInfoVO - Class in bb.common
AccountsPayableInfoVO() - Constructor for class bb.common.AccountsPayableInfoVO
default constructor
AccountsPayableItemManufacturerPK - Class in bb.common
AccountsPayableItemManufacturerPK() - Constructor for class bb.common.AccountsPayableItemManufacturerPK
AccountsPayableItemManufacturerVO - Class in bb.common
AccountsPayableItemManufacturerVO() - Constructor for class bb.common.AccountsPayableItemManufacturerVO
AccountsPayableItemPK - Class in bb.common
AccountsPayableItemPK(String, String) - Constructor for class bb.common.AccountsPayableItemPK
full constructor
AccountsPayableItemPK() - Constructor for class bb.common.AccountsPayableItemPK
default constructor
AccountsPayableItemVO - Class in bb.common
AccountsPayableItemVO() - Constructor for class bb.common.AccountsPayableItemVO
default constructor
AccountsPayableVO - Class in bb.common
AccountsPayableVO() - Constructor for class bb.common.AccountsPayableVO
default constructor
ACCOUNTSRECEIVABLE - Static variable in class bb.common.Constant.OrderType
AccountsReceivableInfoVO - Class in bb.common
AccountsReceivableInfoVO() - Constructor for class bb.common.AccountsReceivableInfoVO
default constructor
AccountsReceivableItemManufacturerPK - Class in bb.common
AccountsReceivableItemManufacturerPK(String, String, short) - Constructor for class bb.common.AccountsReceivableItemManufacturerPK
full constructor
AccountsReceivableItemManufacturerPK() - Constructor for class bb.common.AccountsReceivableItemManufacturerPK
default constructor
AccountsReceivableItemManufacturerVO - Class in bb.common
AccountsReceivableItemManufacturerVO() - Constructor for class bb.common.AccountsReceivableItemManufacturerVO
AccountsReceivableItemPK - Class in bb.common
AccountsReceivableItemPK(String, String) - Constructor for class bb.common.AccountsReceivableItemPK
full constructor
AccountsReceivableItemPK() - Constructor for class bb.common.AccountsReceivableItemPK
default constructor
AccountsReceivableItemResult - Class in bb.common
AccountsReceivableItemResult() - Constructor for class bb.common.AccountsReceivableItemResult
AccountsReceivableItemVO - Class in bb.common
AccountsReceivableItemVO() - Constructor for class bb.common.AccountsReceivableItemVO
default constructor
AccountsReceivableVO - Class in bb.common
AccountsReceivableVO() - Constructor for class bb.common.AccountsReceivableVO
default constructor
ACCT_OF_PAYABLE_METHOD_IS_NULL - Static variable in class bb.common.BIZReason
ACCUMULATED_DEPR_ACCOUNT_EMPTY - Static variable in class bb.common.BIZReason
Acknowledged - Static variable in class bb.common.Constant.Status
activeLabelTemplate(int) - Method in interface bb.common.box.WarehouseBox
AD - Static variable in class bb.common.Constant.ChartOfAccountType
ADA - Static variable in class bb.common.Constant.AmountType
ADD - Static variable in class bb.common.Constant.EngineeringSharingImportType
ADD - Static variable in class bb.common.Constant.NoticeAction
ADD_ECN - Static variable in class bb.common.Constant.SystemUserGroup
ADD_NCR - Static variable in class bb.common.Constant.SystemUserGroup
ADD_PO - Static variable in class bb.common.Constant.SystemUserGroup
ADD_SO - Static variable in class bb.common.Constant.SystemUserGroup
addAccountBalanceGL(AccountBalanceAgent) - Method in interface bb.common.box.AccountingBox
addAccountChartBalanceSheetAdvanceCategory(AccountsChartAdvanceCategoryVO) - Method in interface bb.common.box.AccountingBox
addAccountChartProfitLossAdvanceCategory(AccountsChartAdvanceCategoryVO) - Method in interface bb.common.box.AccountingBox
addAccountChartTaxPayableAdvanceCategory(AccountsChartAdvanceCategoryVO) - Method in interface bb.common.box.AccountingBox
addAccountReceivablePayment(AccountReceivablePaymentVO) - Method in interface bb.common.box.AccountingBox
addAccountsChart(AccountsChartVO) - Method in interface bb.common.box.AccountingBox
addAccountsChartCategoryForBalanceSheet(AccountsChartCategoryVO) - Method in interface bb.common.box.AccountingBox
addAccountsChartCategoryForEbitda(AccountsChartCategoryVO) - Method in interface bb.common.box.AccountingBox
addAccountsChartCategoryForProfitLoss(AccountsChartCategoryVO) - Method in interface bb.common.box.AccountingBox
addAccountsChartCategoryForTaxDetail(AccountsChartCategoryVO) - Method in interface bb.common.box.AccountingBox
addAccountsChartMapping(AccountsChartMappingVO) - Method in interface bb.common.box.AccountingBox
addAddressQualityDocuments(AddressQualityDocumentsVO) - Method in interface bb.common.box.QualityBox
addAgent(String) - Method in class bb.common.WorkCenterAgent
addAPPayment(PaymentAgent) - Method in interface bb.common.box.AccountingBox
addAPPaymentWithMultiplePrepay(PaymentAgent) - Method in interface bb.common.box.AccountingBox
addAPPaymentWithPrepay(PaymentAgent) - Method in interface bb.common.box.AccountingBox
addApPrepayPayment(PrepayPaymentAgent) - Method in interface bb.common.box.AccountingBox
addArBP(ARBoilerplateVO) - Method in interface bb.common.box.AccountingBox
addArPayment(PaymentAgent) - Method in interface bb.common.box.AccountingBox
addARPaymentWithMultiplePrepay(PaymentAgent) - Method in interface bb.common.box.AccountingBox
addARPaymentWithPrepay(PaymentAgent) - Method in interface bb.common.box.AccountingBox
addArPrepayPayment(PrepayPaymentAgent) - Method in interface bb.common.box.AccountingBox
addARWithoutShipper(AccountsReceivableVO) - Method in interface bb.common.box.AccountingBox
addARWithShipper(MakeInvoiceAgent) - Method in interface bb.common.box.AccountingBox
addARWithShipperItems(MakeInvoiceAgent) - Method in interface bb.common.box.AccountingBox
addAsset(AssetVO) - Method in interface bb.common.box.AccountingBox
addAsset(String, String) - Method in interface bb.common.box.AccountingBox
addAssetType(AssetTypeVO) - Method in interface bb.common.box.AccountingBox
addAssetUsage(AssetUsageVO) - Method in interface bb.common.box.AccountingBox
addBankReconciliationReport(BankReconciliationReportVO) - Method in interface bb.common.box.AccountingBox
addBatchAccountsChart(Collection<AccountsChartVO>) - Method in interface bb.common.box.AccountingBox
addBill(BillVO) - Method in interface bb.common.box.EngineeringBox
**************above are EngineeringChange, below about Bill and BillItem
addBillItem(BillItemVO) - Method in interface bb.common.box.EngineeringBox
addBomApproval(String) - Method in interface bb.common.box.EngineeringBox
addBuyerCode(BuyerCodeVO) - Method in interface bb.common.box.CompanyBox
addCar(CorrectiveActionRequestVO) - Method in interface bb.common.box.QualityBox
addCarrier(CarrierVO) - Method in interface bb.common.box.AddressBox
addCashier(CashierVO) - Method in interface bb.common.box.CompanyBox
addCatalog(CatalogVO) - Method in interface bb.common.box.SalesBox
addCertificateDescription(CertificateDescriptionVO) - Method in interface bb.common.box.QualityBox
addChangeStdCostWorkSheet(ChangeStdCostWorkSheetVO) - Method in interface bb.common.box.AccountingBox
addChangeStdCostWorkSheetItem(ChangeStdCostWorkSheetItemVO) - Method in interface bb.common.box.AccountingBox
addChecksFromCheckRunNumber(String, boolean) - Method in interface bb.common.box.AccountingBox
addCommonPrintTemplate(CommonPrintTemplateVO) - Method in interface bb.common.box.CompanyBox
addCompanyUnit(CompanyUnitVO) - Method in interface bb.common.box.CompanyBox
addCompanyUnitAccount(CompanyUnitAccountVO) - Method in interface bb.common.box.CompanyBox
addContractPrice(ContractPriceVO) - Method in interface bb.common.box.SalesBox
addContractPriceCustomer(ContractPriceCustomerVO) - Method in interface bb.common.box.SalesBox
addContractPriceItem(ContractPriceItemVO) - Method in interface bb.common.box.SalesBox
addContractPriceItems(ArrayList) - Method in interface bb.common.box.SalesBox
addCreditMemo(String, String) - Method in interface bb.common.box.AccountingBox
addCreditMemoWithoutInvoice(AccountsReceivableVO) - Method in interface bb.common.box.AccountingBox
addCurrency(CurrencyVO) - Method in interface bb.common.box.CompanyBox
addCustomAsset(CustomAssetVO) - Method in interface bb.common.box.HumanResourceBox
addCustomAssetRecord(CustomAssetRecordVO) - Method in interface bb.common.box.HumanResourceBox
addCustomCheckUpEmployee(CustomCheckUpEmployeeVO) - Method in interface bb.common.box.HumanResourceBox
addCustomColumn(AppColumnVO) - Method in interface bb.common.box.CompanyBox
addCustomDepartment(CustomDepartmentVO) - Method in interface bb.common.box.HumanResourceBox
addCustomEmployee(CustomEmployeeVO) - Method in interface bb.common.box.HumanResourceBox
addCustomEmployeeTrain(CustomEmployeeTrainVO) - Method in interface bb.common.box.HumanResourceBox
addCustomEmployeeWorkExperience(CustomEmployeeWorkExperienceVO) - Method in interface bb.common.box.HumanResourceBox
addCustomer(CustomerVendorAddressVO) - Method in interface bb.common.box.AddressBox
addCustomerAndVendor(CustomerVendorAddressVO) - Method in interface bb.common.box.AddressBox
addCustomerFeedback(CustomerFeedbackVO) - Method in interface bb.common.box.CustomerServiceBox
addCustomerFeedback(String) - Method in interface bb.common.box.CustomerServiceBox
addCustomerFeedbackByCustomerId(String) - Method in interface bb.common.box.CustomerServiceBox
addCustomerFeedbackBySoNumber(String) - Method in interface bb.common.box.CustomerServiceBox
addCustomerFeedbackItem(FeedbackItemVO) - Method in interface bb.common.box.CustomerServiceBox
addCustomerFeedbackItem(ArrayList) - Method in interface bb.common.box.CustomerServiceBox
addCustomerType(String, String) - Method in interface bb.common.box.AddressBox
addCustomerVendorAddress(CustomerVendorAddressVO) - Method in interface bb.common.box.AddressBox
addCustomGoodsBreed(CustomGoodsBreedVO) - Method in interface bb.common.box.HumanResourceBox
addCustomGoodsRecord(CustomGoodsRecordVO) - Method in interface bb.common.box.HumanResourceBox
addCustomJobCategory(CustomJobCategoryVO) - Method in interface bb.common.box.HumanResourceBox
addCustomSearch(CustomSearchVO) - Method in interface bb.common.box.CompanyBox
addCycleCount(AddPhysicalInventoryAgent) - Method in interface bb.common.box.WarehouseBox
addDataFilter(DataFilterVO) - Method in interface bb.common.box.CompanyBox
addDC(DesignControlVO) - Method in interface bb.common.box.EngineeringBox
addDepartment(CustomerVendorAddressVO) - Method in interface bb.common.box.AddressBox
addDepartmentLocationForBackflush(DepartmentLocationForBackflushVO) - Method in interface bb.common.box.WarehouseBox
addDisassembleWorkOrder(String) - Method in interface bb.common.box.WorkOrderBox
addDisassembleWorkOrderApproval(String) - Method in interface bb.common.box.WorkOrderBox
addDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemPK, BigDecimal, BigDecimal, BigDecimal, String) - Method in interface bb.common.box.WorkOrderBox
addDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemPK, BB2Part, BigDecimal, BigDecimal) - Method in interface bb.common.box.WorkOrderBox
addDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemPK, LinkedHashMap<BB2Part, BigDecimal>) - Method in interface bb.common.box.WorkOrderBox
addDocumentServerSettings(DocumentServerVO) - Method in interface bb.common.box.CompanyBox
addDwfUploadSettings(DwfUploadSettingsVO) - Method in interface bb.common.box.CompanyBox
addDwgUploadSettings(DwgUploadSettingsVO) - Method in interface bb.common.box.CompanyBox
addECNControl(String) - Method in interface bb.common.box.EngineeringBox
addECRControl(String) - Method in interface bb.common.box.EngineeringBox
addECRequest(EngineeringChangeRequestVO) - Method in interface bb.common.box.EngineeringBox
addEjbMethod(EjbMethodVO) - Method in interface bb.common.box.SecurityBox
addEmployeeCard(EmployeeCardVO, boolean) - Method in interface bb.common.box.HumanResourceBox
addEmployeeCardToTemp(String, String) - Method in interface bb.common.box.HumanResourceBox
addEmployeeEducation(EmployeeEducationVO) - Method in interface bb.common.box.HumanResourceBox
addEmployeeHome(EmployeeHomeVO) - Method in interface bb.common.box.HumanResourceBox
addEmployeeLabor(EmployeeLaborAgent) - Method in interface bb.common.box.WorkOrderBox
addEmployeeTraining(EmployeeTrainingVO) - Method in interface bb.common.box.HumanResourceBox
addEmployeeWorkExperience(EmployeeWorkExperienceVO) - Method in interface bb.common.box.HumanResourceBox
addEngGroup(EngGroupVO) - Method in interface bb.common.box.EngineeringBox
addEngGroupUser(EngGroupUserVO) - Method in interface bb.common.box.EngineeringBox
addEngineeringChange(EngineeringChangeVO) - Method in interface bb.common.box.EngineeringBox
addEngineeringSharing(EngineeringSharingVO) - Method in interface bb.common.box.EngineeringBox
addEngineeringSharingItem(EngineeringSharingItemVO) - Method in interface bb.common.box.EngineeringBox
addEngineeringSharingItems(ArrayList<PartPK>, String) - Method in interface bb.common.box.EngineeringBox
addEngineeringSharingItemsByPart(String, String, String, String, String) - Method in interface bb.common.box.EngineeringBox
addEquipment(EquipmentVO) - Method in interface bb.common.box.ManufacturingBox
addEstimatedPayableWithReceiverItems(MakeAccountPayableAgent) - Method in interface bb.common.box.AccountingBox
addExpense() - Method in interface bb.common.box.AccountingBox
addExpenseAccount(ExpenseAccountVO) - Method in interface bb.common.box.AccountingBox
addFeedbackQuestion(FeedbackQuestionVO) - Method in interface bb.common.box.CustomerServiceBox
addFiscalYearSettings(FiscalYearSettingsVO) - Method in interface bb.common.box.AccountingBox
addGeneralLedger(String, String) - Method in interface bb.common.box.AccountingBox
addGeneralLedger(GeneralLedgerVO) - Method in interface bb.common.box.AccountingBox
addGeneralLedgerApproval(String) - Method in interface bb.common.box.AccountingBox
addGLAutoApprove(GLAutoApproveVO) - Method in interface bb.common.box.AccountingBox
addGLCategory(GeneralLedgerCategoryVO) - Method in interface bb.common.box.AccountingBox
addGroupUser(GroupUserVO) - Method in interface bb.common.box.CompanyBox
addHelpServer(HelpServerVO) - Method in interface bb.common.box.CompanyBox
addICR(InspectionConformanceReportVO) - Method in interface bb.common.box.QualityBox
addIncident(CustomerServiceIncidentVO) - Method in interface bb.common.box.CustomerServiceBox
addIncoterm(IncotermVO) - Method in interface bb.common.box.SalesBox
addInspectionItem(InspectionItemVO) - Method in interface bb.common.box.ManufacturingBox
addInspectionReport(InspectionReportVO) - Method in interface bb.common.box.ManufacturingBox
addInspectionReportInspectMethod(InspectionReportInspectMethodVO) - Method in interface bb.common.box.ManufacturingBox
addInspectionType(InspectionTypeVO) - Method in interface bb.common.box.QualityBox
addItem(ArrayList<BillItemUsagePathResult>) - Method in class bb.common.BillItemUsageResult
ADDITEM - Static variable in class bb.common.Constant.EngineeringSharingImportType
addItem(String, WorkOrderWorkInstructionSequencePK) - Method in class bb.common.POForWISeqAgent
addItem(String, WorkOrderWorkInstructionSequencePK, Date, BigDecimal) - Method in class bb.common.POForWISeqAgent
addItem(WorkCenterAgent) - Method in class bb.common.WCLoadAgent
addItems(ArrayList<ArrayList<BillItemUsagePathResult>>) - Method in class bb.common.BillItemUsageResult
addItems(Collection<WorkCenterAgent>) - Method in class bb.common.WCLoadAgent
addLabelTemplate(LabelTemplateVO) - Method in interface bb.common.box.WarehouseBox
addList(List<Object>) - Method in class bb.common.ListCache
addLogInventory(LogInventoryVO) - Method in interface bb.common.box.WarehouseBox
addMaintenanceItem(MaintenanceItemVO) - Method in interface bb.common.box.ManufacturingBox
addManufacturerAddress(ManufacturerAddressVO) - Method in interface bb.common.box.AddressBox
addManufacturerEngineeringChange(EngineeringChangeVO) - Method in interface bb.common.box.ManufacturingBox
addMECRequest(EngineeringChangeRequestVO) - Method in interface bb.common.box.ManufacturingBox
addMECRequest(PartPK) - Method in interface bb.common.box.ManufacturingBox
addMessage(MessageAgent) - Method in interface bb.common.box.CompanyBox
addMiscDocSetting(MiscDocumentSettingVO) - Method in interface bb.common.box.CompanyBox
addMultiplePartTracking(Collection<PartTrackingVO>) - Method in interface bb.common.box.QualityBox
addMyPrintList(String) - Method in interface bb.common.box.AccountingBox
addMyPrintList(String) - Method in interface bb.common.box.PurchasingBox
addMyPrintList(String) - Method in interface bb.common.box.SalesBox
addNCC(NonConformanceCodeVO) - Method in interface bb.common.box.QualityBox
addNCR(NonConformanceReportVO) - Method in interface bb.common.box.QualityBox
addNCR(NonConformanceReportVO, HashSet<Integer>) - Method in interface bb.common.box.QualityBox
addNcrApproval(String, String) - Method in interface bb.common.box.QualityBox
addNCRPicture(NCRPictureVO) - Method in interface bb.common.box.QualityBox
addNewGeneralLedger(GeneralLedgerVO) - Method in interface bb.common.box.AccountingBox
addNewLocation(BB2Part, String, String) - Method in interface bb.common.box.WarehouseBox
addNonproductivePicking(NonproductivePickingVO) - Method in interface bb.common.box.WarehouseBox
addNonproductivePickingApproval(String) - Method in interface bb.common.box.WarehouseBox
addNonproductivePickingType(NonproductivePickingTypeVO) - Method in interface bb.common.box.WarehouseBox
addOIPrincipal(OIPrincipalVO) - Method in interface bb.common.box.ManufacturingBox
addOnLoan(OnLoanVO) - Method in interface bb.common.box.WarehouseBox
addOnloanControl(String) - Method in interface bb.common.box.WarehouseBox
addOperatingInstructions(OperatingInstructionsVO) - Method in interface bb.common.box.ManufacturingBox
addOperatingInstructionsInspectStandard(OperatingInstructionsInspectStandardVO) - Method in interface bb.common.box.ManufacturingBox
addOperatingInstructionsManual(OperatingInstructionsManualVO) - Method in interface bb.common.box.ManufacturingBox
addOperatingInstructionsType(OperatingInstructionsTypeVO) - Method in interface bb.common.box.ManufacturingBox
addOperatingOutputFileType(OperatingOutputFileTypeVO) - Method in interface bb.common.box.ManufacturingBox
addPackingBox(String) - Method in interface bb.common.box.WarehouseBox
addPAR(PreventiveActionRequestVO) - Method in interface bb.common.box.QualityBox
addPart(PartVO) - Method in interface bb.common.box.EngineeringBox
addPartCatagory(PartCatagoryVO) - Method in interface bb.common.box.EngineeringBox
addPartCatalog(String, HashSet<PartCatalogPK>) - Method in interface bb.common.box.SalesBox
addPartClass(PartClassVO) - Method in interface bb.common.box.WarehouseBox
addPartDiscount(PartDiscountVO) - Method in interface bb.common.box.SalesBox
addPartInspection(PartInspectionVO) - Method in interface bb.common.box.QualityBox
addPartMaterial(PartPK) - Method in interface bb.common.box.EngineeringBox
addPartOnhand(PartOnhandVO) - Method in interface bb.common.box.WarehouseBox
addPartOnOder(PurchaseOrderItemVO) - Method in interface bb.common.box.WarehouseBox
addPartPicture(PartPictureVO) - Method in interface bb.common.box.EngineeringBox
addPartSecurityLevel(PartSecurityLevelVO) - Method in interface bb.common.box.EngineeringBox
addPartTraceableCategory(PartTraceableCategoryVO) - Method in interface bb.common.box.EngineeringBox
addPartTraceableSpec(PartTraceableSpecVO) - Method in interface bb.common.box.EngineeringBox
addPartType(PartTypeVO) - Method in interface bb.common.box.CompanyBox
addPartUseType(PartUseTypeVO) - Method in interface bb.common.box.WorkOrderBox
addPartVendor(PartVendorVO) - Method in interface bb.common.box.EngineeringBox
addPath(ArrayList<PartBasicInfo>) - Method in class bb.common.RecursiveBillPath
addPath(HashSet<ArrayList<PartBasicInfo>>) - Method in class bb.common.RecursiveBillPath
addPayableWithoutReceiver(AddPayableWithoutReceiverAgent) - Method in interface bb.common.box.AccountingBox
AddPayableWithoutReceiverAgent - Class in bb.common
AddPayableWithoutReceiverAgent() - Constructor for class bb.common.AddPayableWithoutReceiverAgent
addPayableWithReceiver(MakeAccountPayableAgent) - Method in interface bb.common.box.AccountingBox
addPayableWithReceiverItems(MakeAccountPayableAgent) - Method in interface bb.common.box.AccountingBox
addPayment(PayableMethodVO) - Method in interface bb.common.box.CompanyBox
addPermission(PermissionVO) - Method in interface bb.common.box.SecurityBox
addPermissionMethod(PermissionMethodVO) - Method in interface bb.common.box.SecurityBox
addPfReceiver(String) - Method in interface bb.common.box.PurchasingBox
addPfReceiver(ProformaReceiverPackingBoxAgent) - Method in interface bb.common.box.PurchasingBox
addPhysicalInventory(AddPhysicalInventoryAgent) - Method in interface bb.common.box.WarehouseBox
AddPhysicalInventoryAgent - Class in bb.common
AddPhysicalInventoryAgent() - Constructor for class bb.common.AddPhysicalInventoryAgent
addPoMessage(String) - Method in interface bb.common.box.PurchasingBox
addPOSurveyReportWithPO(POSurveyReportAgent) - Method in interface bb.common.box.QualityBox
addPosZipCodeTax(PosZipCodeTaxVO) - Method in interface bb.common.box.CompanyBox
addPOWSFromQuote(String) - Method in interface bb.common.box.PurchasingBox
addPOWSFromSO(String) - Method in interface bb.common.box.PurchasingBox
addPrintLogo(PrintLogoVO) - Method in interface bb.common.box.CompanyBox
addPrintTemplate(PrintTemplateVO) - Method in interface bb.common.box.CompanyBox
addProformaInvoice(String) - Method in interface bb.common.box.WarehouseBox
addProformaInvoice(ProformaInvoiceVO) - Method in interface bb.common.box.WarehouseBox
AddProformaReceiverAgent - Class in bb.common
AddProformaReceiverAgent() - Constructor for class bb.common.AddProformaReceiverAgent
AddProformaReceiverAgent(String) - Constructor for class bb.common.AddProformaReceiverAgent
AddProformaReceiverItemAgent - Class in bb.common
AddProformaReceiverItemAgent() - Constructor for class bb.common.AddProformaReceiverItemAgent
addProject(ProjectVO) - Method in interface bb.common.box.SalesBox
addPurchaseOrder(String) - Method in interface bb.common.box.ManufacturingBox
addPurchaseOrder(String) - Method in interface bb.common.box.PurchasingBox
addPurchaseOrderApproval(String) - Method in interface bb.common.box.ManufacturingBox
addPurchaseOrderApproval(String) - Method in interface bb.common.box.PurchasingBox
addPurchaseOrderBP(PurchaseOrderBoilerplateVO) - Method in interface bb.common.box.PurchasingBox
addPurchaseOrderByMPNPart(String) - Method in interface bb.common.box.PurchasingBox
addPurchaseOrderFromRequestForQuote(String) - Method in interface bb.common.box.ManufacturingBox
addPurchaseOrderFromRequestForQuote(String, String) - Method in interface bb.common.box.PurchasingBox
addPurchaseOrderFromWISeq(POForWISeqAgent) - Method in interface bb.common.box.ManufacturingBox
addPurchaseOrderFromWISeq(String, WorkOrderWorkInstructionSequencePK) - Method in interface bb.common.box.PurchasingBox
addPurchaseOrderFromWISeq(POForWISeqAgent) - Method in interface bb.common.box.PurchasingBox
addPurchaseOrderItem(PurchaseOrderItemVO) - Method in interface bb.common.box.ManufacturingBox
addPurchaseOrderItem(PurchaseOrderItemVO) - Method in interface bb.common.box.PurchasingBox
addPurchaseWorkSheet() - Method in interface bb.common.box.ManufacturingBox
addPurchaseWorkSheet(PurchaseWorkSheetVO) - Method in interface bb.common.box.ManufacturingBox
addPurchaseWorkSheet() - Method in interface bb.common.box.PurchasingBox
addPurchaseWorkSheet(PurchaseWorkSheetVO) - Method in interface bb.common.box.PurchasingBox
addPurchaseWorkSheet(ArrayList) - Method in interface bb.common.box.PurchasingBox
addPurchaseWorkSheetItem(PurchaseWorkSheetItemVO) - Method in interface bb.common.box.PurchasingBox
addQualityGroup(QualityGroupVO) - Method in interface bb.common.box.QualityBox
addQuote(QuoteVO) - Method in interface bb.common.box.SalesBox
addQuoteBP(QuoteBoilerplateVO) - Method in interface bb.common.box.SalesBox
addReceiver(ReceiverVO) - Method in interface bb.common.box.WarehouseBox
addReceiverToMyPrintList(String) - Method in interface bb.common.box.WarehouseBox
addRefdocOne(SalesOrderItemPK, String, String, BigDecimal) - Method in interface bb.common.box.SalesBox
addRefdocOne(WorkOrderItemPK, String, String, BigDecimal) - Method in interface bb.common.box.WorkOrderBox
addRefdocTwo(AccountsReceivableItemPK, String, String) - Method in interface bb.common.box.AccountingBox
addRefdocTwo(AccountsPayableItemPK, String, String) - Method in interface bb.common.box.AccountingBox
addRefdocTwo(PurchaseOrderItemPK, String, String, BigDecimal) - Method in interface bb.common.box.PurchasingBox
addRefdocTwo(ShipperItemPK, String, String) - Method in interface bb.common.box.WarehouseBox
addRefdocTwo(ReceiverItemPK, String, String) - Method in interface bb.common.box.WarehouseBox
addRefdocTwo(WorkOrderItemPK, String, String, BigDecimal) - Method in interface bb.common.box.WorkOrderBox
addRequestForQuote(String) - Method in interface bb.common.box.ManufacturingBox
addRequestForQuote(String) - Method in interface bb.common.box.PurchasingBox
addRequestForQuote(String, String, boolean) - Method in interface bb.common.box.PurchasingBox
ADDRESS - Static variable in class bb.common.BizTarget
ADDRESS - Static variable in class bb.common.Configure.Module
ADDRESS_CAN_NOT_USE_BACKFLUSH - Static variable in class bb.common.BIZReason
ADDRESS_ID_DOES_NOT_EXIST - Static variable in class bb.common.BIZReason
ADDRESS_ID_IS_DELETED - Static variable in class bb.common.BIZReason
ADDRESS_ID_IS_NOT_CUSTOMER - Static variable in class bb.common.BIZReason
ADDRESS_ID_USED_IN_AP - Static variable in class bb.common.BIZReason
ADDRESS_ID_USED_IN_AR - Static variable in class bb.common.BIZReason
ADDRESS_ID_USED_IN_PO - Static variable in class bb.common.BIZReason
ADDRESS_ID_USED_IN_QUOTE - Static variable in class bb.common.BIZReason
ADDRESS_ID_USED_IN_RFQ - Static variable in class bb.common.BIZReason
ADDRESS_ID_USED_IN_RMA - Static variable in class bb.common.BIZReason
ADDRESS_ID_USED_IN_RTV - Static variable in class bb.common.BIZReason
ADDRESS_ID_USED_IN_SO - Static variable in class bb.common.BIZReason
ADDRESS_ID_USED_IN_WO - Static variable in class bb.common.BIZReason
ADDRESS_QA_DOC - Static variable in class bb.common.BizTarget
ADDRESS_QA_DOC - Static variable in class bb.common.Constant.MiscDocType
ADDRESS_QA_DOC_NOT_FIND - Static variable in class bb.common.BIZReason
AddressAccountInfo - Class in bb.common
AddressAccountInfo() - Constructor for class bb.common.AddressAccountInfo
AddressBox - Interface in bb.common.box
AddressQualityDocumentsVO - Class in bb.common
AddressQualityDocumentsVO(String, String, String, Date, Date, String, Long, String) - Constructor for class bb.common.AddressQualityDocumentsVO
full constructor
AddressQualityDocumentsVO() - Constructor for class bb.common.AddressQualityDocumentsVO
default constructor
AddressQualityDocumentsVO(String, String, String, String) - Constructor for class bb.common.AddressQualityDocumentsVO
minimal constructor
addReturnOrder(RunningAccountOrderVO, String) - Method in interface bb.common.box.CompanyBox
addReturnToVendor(String) - Method in interface bb.common.box.ManufacturingBox
addReturnToVendor(AddRTVAgent) - Method in interface bb.common.box.PurchasingBox
addRFC(WorkInstructionRequestForChangeVO) - Method in interface bb.common.box.ManufacturingBox
addRfqFromQuote(String, String) - Method in interface bb.common.box.PurchasingBox
addRfqFromSO(String, String, boolean) - Method in interface bb.common.box.PurchasingBox
addRfqMessage(String) - Method in interface bb.common.box.PurchasingBox
addRma(String, boolean) - Method in interface bb.common.box.SalesBox
addRmaByCustomerId(String) - Method in interface bb.common.box.SalesBox
addRmaBySalesOrder(String, boolean) - Method in interface bb.common.box.SalesBox
addRMAReview(String) - Method in interface bb.common.box.SalesBox
addRole(RoleVO) - Method in interface bb.common.box.SecurityBox
addRoleToUser(String, String) - Method in interface bb.common.box.SecurityBox
addRollUpBomStdCostWorkSheet(RollUpBomStdCostWorkSheetVO) - Method in interface bb.common.box.AccountingBox
addRollUPCost(PartPK, BigDecimal) - Method in class bb.common.BOMTreeRollUPMap
AddRTVAgent - Class in bb.common
AddRTVAgent() - Constructor for class bb.common.AddRTVAgent
addRTVApproval(String) - Method in interface bb.common.box.PurchasingBox
addRunningAccountOrder(RunningAccountOrderVO) - Method in interface bb.common.box.CompanyBox
addSalesCodeByAddressId(String, String) - Method in interface bb.common.box.SalesBox
addSalesCodeByEmployeeId(String, String) - Method in interface bb.common.box.SalesBox
addSalesCodeCustomerByAddressIds(List, String) - Method in interface bb.common.box.SalesBox
addSalesman(String) - Method in interface bb.common.box.SalesBox
addSalesman(SalesmanVO) - Method in interface bb.common.box.SalesBox
addSalesOrder(SalesOrderVO) - Method in interface bb.common.box.SalesBox
addSalesOrderBP(SalesOrderBoilerplateVO) - Method in interface bb.common.box.SalesBox
addSalesOrderControl(String) - Method in interface bb.common.box.SalesBox
addSalesOrderItemToPackingBox(PackingBoxSalesOrderItemAgent) - Method in interface bb.common.box.WarehouseBox
addSalesOrderToPackingBox(ArrayList) - Method in interface bb.common.box.WarehouseBox
addSerialNumber(PartCertificateVO) - Method in interface bb.common.box.QualityBox
addSerialNumber(PartCertificateVO, String) - Method in interface bb.common.box.QualityBox
addSgClientProgramUser(SgClientProgramUserVO) - Method in interface bb.common.box.AddressBox
addSGCustomerCatalog(String, PartCatalogPK) - Method in interface bb.common.box.SalesBox
addSGCustomerCatalog(String, ArrayList<PartCatalogPK>, boolean) - Method in interface bb.common.box.SalesBox
addSGSaleItem(SGSaleItemAgent) - Method in interface bb.common.box.SalesBox
addShipList(ShipListAgent) - Method in interface bb.common.box.PlanningBox
addShipList(ShipListVO) - Method in interface bb.common.box.PlanningBox
addShipListItem(ShipListItemVO) - Method in interface bb.common.box.PlanningBox
addShipListOwner(String) - Method in interface bb.common.box.PlanningBox
addShipListOwner(ShipListOwnerVO) - Method in interface bb.common.box.PlanningBox
addShipListOwnerAttribute(ShipListOwnerAttributeVO) - Method in interface bb.common.box.PlanningBox
addShipper(ShipperVO) - Method in interface bb.common.box.WarehouseBox
addShipperToMyPrintList(String) - Method in interface bb.common.box.WarehouseBox
addSingleCheck(MakeCheckAgent) - Method in interface bb.common.box.AccountingBox
addSinglePrepaymentCheck(MakePrepaymentCheckAgent) - Method in interface bb.common.box.AccountingBox
addStdCost(PartPK, BigDecimal) - Method in class bb.common.BOMTreeRollUPMap
addStdRollUPCost(PartPK, BigDecimal, BigDecimal) - Method in class bb.common.BOMTreeRollUPMap
addSubcompany(SubcompanyVO) - Method in interface bb.common.box.CompanyBox
addSwapOrder(String) - Method in interface bb.common.box.PurchasingBox
addSwapOrderApproval(String) - Method in interface bb.common.box.PurchasingBox
addTask(TaskVO) - Method in interface bb.common.box.CompanyBox
addTaxAccount(TaxAccountVO) - Method in interface bb.common.box.CompanyBox
addTemporaryEmployee(EmployeeCardVO) - Method in interface bb.common.box.HumanResourceBox
addTempToEmployeeCard(EmployeeCardVO, String) - Method in interface bb.common.box.HumanResourceBox
addTerm(TermAgent) - Method in interface bb.common.box.CompanyBox
addTermsConditions(TermsConditionVO) - Method in interface bb.common.box.CompanyBox
addTimeCard(WorkOrderTimeCardVO) - Method in interface bb.common.box.ManufacturingBox
addTimeCard(WorkOrderTimeCardVO, boolean) - Method in interface bb.common.box.ManufacturingBox
addTool(ToolVO) - Method in interface bb.common.box.ManufacturingBox
addToolCalibration(PartPK, String) - Method in interface bb.common.box.ManufacturingBox
addToolList(ToolListVO) - Method in interface bb.common.box.ManufacturingBox
addToolListItem(ToolListItemVO) - Method in interface bb.common.box.ManufacturingBox
addToolOnOder(PurchaseOrderItemVO) - Method in interface bb.common.box.WarehouseBox
addTraceableCategories(TraceableCategoriesVO) - Method in interface bb.common.box.EngineeringBox
Traceable****************************************************************
addTraceableSpecs(TraceableSpecsVO) - Method in interface bb.common.box.EngineeringBox
addTransactionType(AccountingTransactionTypeVO) - Method in interface bb.common.box.AccountingBox
addTransferOrder(TransferOrderVO) - Method in interface bb.common.box.WarehouseBox
addTransferOrderApproval(TransferOrderApprovalVO) - Method in interface bb.common.box.WarehouseBox
addUnit(UnitVO) - Method in interface bb.common.box.EngineeringBox
addUser(BizboxUserVO) - Method in interface bb.common.box.SecurityBox
addUserGroup(UserGroupVO) - Method in interface bb.common.box.CompanyBox
addVendor(CustomerVendorAddressVO) - Method in interface bb.common.box.AddressBox
addVendorCategories(VendorCategoriesVO) - Method in interface bb.common.box.AddressBox
addVendorContractPrice(VendorContractPriceVO) - Method in interface bb.common.box.PurchasingBox
addVendorContractPriceItem(VendorContractPriceItemVO) - Method in interface bb.common.box.PurchasingBox
addVendorContractPriceItems(ArrayList) - Method in interface bb.common.box.PurchasingBox
addVendorContractPriceVendor(VendorContractPriceVendorVO) - Method in interface bb.common.box.PurchasingBox
addVendorCriticalLevel(VendorCriticalLevelVO) - Method in interface bb.common.box.AddressBox
addVendorGroupUser(VendorGroupUserVO) - Method in interface bb.common.box.AddressBox
addVendorPart(VendorPartVO) - Method in interface bb.common.box.WarehouseBox
addVendorQtyPrice(VendorQtyPriceVO) - Method in interface bb.common.box.EngineeringBox
addVendorType(String, String) - Method in interface bb.common.box.AddressBox
addWarehouse(WarehouseVO) - Method in interface bb.common.box.WarehouseBox
addWeightUnit(WeightUnitVO) - Method in interface bb.common.box.CompanyBox
addWireTransferFromCheckRun(String) - Method in interface bb.common.box.AccountingBox
addWOReceiver(WorkOrderReceiverVO) - Method in interface bb.common.box.WarehouseBox
addWorkCalendar(WorkCalendarVO) - Method in interface bb.common.box.ManufacturingBox
addWorkCenter(WorkCenterVO) - Method in interface bb.common.box.ManufacturingBox
addWorkFlow(WorkFlowVO) - Method in interface bb.common.box.CompanyBox
addWorkInstruction(WorkInstructionPK) - Method in interface bb.common.box.ManufacturingBox
addWorkInstructionApproval(String) - Method in interface bb.common.box.ManufacturingBox
addWorkInstructionPicture(WorkInstructionPictureVO) - Method in interface bb.common.box.ManufacturingBox
addWorkOrder(String) - Method in interface bb.common.box.WorkOrderBox
addWorkOrderAndIssueParts(WorkOrderVO, WorkOrderItemVO, ArrayList<WorkOrderItemSetupItemAgent>, Set<IssueItemAgent>, ReceiverAgent) - Method in interface bb.common.box.WarehouseBox
addWorkOrderAndReceiveParts(WorkOrderVO) - Method in interface bb.common.box.WarehouseBox
addWorkOrderApproval(String) - Method in interface bb.common.box.WorkOrderBox
addWorkOrderBP(WorkOrderBoilerplateVO) - Method in interface bb.common.box.WorkOrderBox
addWorkOrderFromMasterWorkOrder(Date, WorkOrderItemPK, HashMap<String, HashSet<WorkOrderItemAgent>>) - Method in interface bb.common.box.WorkOrderBox
addWorkOrderItemIssue(WorkOrderItemPK, BB2Part, BigDecimal) - Method in interface bb.common.box.WorkOrderBox
addWorkOrderItemIssue(WorkOrderItemPK, BigDecimal, BigDecimal, BigDecimal, String) - Method in interface bb.common.box.WorkOrderBox
addWorkOrderItemIssue(WorkOrderItemPK, LinkedHashMap<BB2Part, BigDecimal>, LinkedHashMap<BB2Part, String>) - Method in interface bb.common.box.WorkOrderBox
addWorkOrderItemTimeDetail(WorkOrderItemTimeDetailVO) - Method in interface bb.common.box.WorkOrderBox
addWorkOrderWorkInstruction(WorkOrderItemPK, WorkInstructionPK) - Method in interface bb.common.box.WorkOrderBox
addWorkOrderWorkInstruction(WorkOrderWorkInstructionVO) - Method in interface bb.common.box.WorkOrderBox
addWorkOrderWorkInstructionSequence(WorkOrderWorkInstructionSequenceVO) - Method in interface bb.common.box.WorkOrderBox
addWorkOrderWorkSheet() - Method in interface bb.common.box.WorkOrderBox
addWorkOrderWorkSheet(ArrayList) - Method in interface bb.common.box.WorkOrderBox
addWorkOrderWorkSheet(WorkOrderWorkSheetVO) - Method in interface bb.common.box.WorkOrderBox
addWorkOrderWorkSheetItem(WorkOrderWorkSheetItemVO) - Method in interface bb.common.box.WorkOrderBox
addZipCode(ZipCodeVO) - Method in interface bb.common.box.CompanyBox
addZipCodeTax(ZipCodeTaxVO) - Method in interface bb.common.box.CompanyBox
adjustInventory(ArrayList, BB2Part, String) - Method in interface bb.common.box.WarehouseBox
AdjustInventoryByPos(Collection<RunningAccountOrderItemResult>) - Method in interface bb.common.box.CompanyBox
adjustNaRecTobyPartNumber(String) - Method in class bb.common.ReceiverItemAgent
ADMIN_ACCOUNT_CAN_NOT_BE_REMOVED - Static variable in class bb.common.BIZReason
AF - Static variable in class bb.common.Constant.ChartOfAccountType
AL - Static variable in class bb.common.Constant.ChartOfAccountType
Alarmable - Interface in bb.common
ALIGN_BOTTOM - Static variable in class bb.common.LabelTemplateConstant
ALIGN_CENTER - Static variable in class bb.common.LabelTemplateConstant
ALIGN_LEFT - Static variable in class bb.common.LabelTemplateConstant
ALIGN_RIGHT - Static variable in class bb.common.LabelTemplateConstant
ALIGN_TOP - Static variable in class bb.common.LabelTemplateConstant
ALL - Static variable in class bb.common.Constant.CheckType
ALL - Static variable in class bb.common.Constant.CVAddressType
ALL - Static variable in class bb.common.Constant.ECRPriority
ALL - Static variable in class bb.common.Constant.PayableMethod
ALL - Static variable in class bb.common.Constant.PosOrderType
ALL - Static variable in class bb.common.Constant.Status
All - Static variable in class bb.common.Constant.WorkCenterSearchType
ALL_SALES - Static variable in class bb.common.Constant.SalesTaxReportType
AllBudgetResult - Class in bb.common
AllBudgetResult() - Constructor for class bb.common.AllBudgetResult
AllExamines - Static variable in class bb.common.Constant.IRType
AllPartDocumentsPK - Class in bb.common
AllPartDocumentsPK(String, String, String, String) - Constructor for class bb.common.AllPartDocumentsPK
full constructor
AllPartDocumentsPK() - Constructor for class bb.common.AllPartDocumentsPK
default constructor
AllPartDocumentsVO - Class in bb.common
AllPartDocumentsVO(AllPartDocumentsPK, Date, String, boolean, String, String) - Constructor for class bb.common.AllPartDocumentsVO
full constructor
AllPartDocumentsVO() - Constructor for class bb.common.AllPartDocumentsVO
default constructor
AllStatementsListResult - Class in bb.common
AllStatementsListResult() - Constructor for class bb.common.AllStatementsListResult
ALREADY_LOGOUT - Static variable in class bb.common.BIZReason
ALREADY_WRITE_OFF - Static variable in class bb.common.BIZReason
AMORTIZATION_EXPENSE_ACCOUNT_EMPTY - Static variable in class bb.common.BIZReason
AmountsStatementResult - Class in bb.common
AmountsStatementResult() - Constructor for class bb.common.AmountsStatementResult
AP - Static variable in class bb.common.Constant.NaRecTo
AP - Static variable in class bb.common.Constant.Prefix
AP_PREPAY_ALREADY_CANCELLED - Static variable in class bb.common.BIZReason
AP_PREPAY_ALREADY_EXIST - Static variable in class bb.common.BIZReason
AP_PREPAY_ALREDAY_APPLY - Static variable in class bb.common.BIZReason
AP_PREPAY_ALREDAY_PAID - Static variable in class bb.common.BIZReason
AP_PREPAY_BIGGER_THAN_PO_TOTAL - Static variable in class bb.common.BIZReason
AP_PREPAY_GL_IS_NOT_ENOUGH - Static variable in class bb.common.BIZReason
AP_PREPAY_PAID_BIGGER_THAN_PO_TOTAL - Static variable in class bb.common.BIZReason
APAgingItemListResult - Class in bb.common
APAgingItemListResult() - Constructor for class bb.common.APAgingItemListResult
APAuditListResult - Class in bb.common
APAuditListResult() - Constructor for class bb.common.APAuditListResult
ApCheckRunItemAgent - Class in bb.common
ApCheckRunItemAgent() - Constructor for class bb.common.ApCheckRunItemAgent
ApCheckRunListResult - Class in bb.common
ApCheckRunListResult() - Constructor for class bb.common.ApCheckRunListResult
APDM - Static variable in class bb.common.Constant.GLApprovedType
APDM_APPROVED_BY_CAN_NOT_BE_EMPTY - Static variable in class bb.common.BIZReason
APDM_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY - Static variable in class bb.common.BIZReason
APItemListResult - Class in bb.common
APItemListResult() - Constructor for class bb.common.APItemListResult
APP - Static variable in class bb.common.BizTarget
APP - Static variable in class bb.common.Constant.Prefix
APP_COLUMN_NAME_SHOULD_START_WITH_APP - Static variable in class bb.common.BIZReason
APP_ITEM_NOT_EXIST - Static variable in class bb.common.BIZReason
APP_TABLE_NAME_SHOULD_START_WITH_APP - Static variable in class bb.common.BIZReason
AppColumnVO - Class in bb.common
AppColumnVO() - Constructor for class bb.common.AppColumnVO
AppColumnVO(String, String) - Constructor for class bb.common.AppColumnVO
AppException - Exception in bb.common
AppException(Exception) - Constructor for exception bb.common.AppException
AppException(String) - Constructor for exception bb.common.AppException
APPrepayInfoResult - Class in bb.common
APPrepayInfoResult() - Constructor for class bb.common.APPrepayInfoResult
ApPrepayItemPK - Class in bb.common
ApPrepayItemPK(String, String) - Constructor for class bb.common.ApPrepayItemPK
ApPrepayItemPK() - Constructor for class bb.common.ApPrepayItemPK
ApPrepayItemVO - Class in bb.common
ApPrepayItemVO() - Constructor for class bb.common.ApPrepayItemVO
ApPrepaymentCheckRunItemAgent - Class in bb.common
ApPrepaymentCheckRunItemAgent() - Constructor for class bb.common.ApPrepaymentCheckRunItemAgent
ApPrepayVO - Class in bb.common
ApPrepayVO() - Constructor for class bb.common.ApPrepayVO
approvalBill(BillVO) - Method in interface bb.common.box.EngineeringBox
approvalNcrForEng(NonConformanceReportVO) - Method in interface bb.common.box.QualityBox
approvalNcrForMfg(NonConformanceReportVO) - Method in interface bb.common.box.QualityBox
approvalNcrForQa(NonConformanceReportVO) - Method in interface bb.common.box.QualityBox
approvalSwapOrder(SwapOrderVO) - Method in interface bb.common.box.PurchasingBox
approvalTransferOrder(TransferOrderVO) - Method in interface bb.common.box.WarehouseBox
APPROVE - Static variable in class bb.common.Constant.NoticeAction
APPROVE_PO - Static variable in class bb.common.Constant.SystemUserGroup
Approved - Static variable in class bb.common.Constant.Status
APPROVED_ACTION_IS_FORBIDDEN_WHEN_UPDATE - Static variable in class bb.common.BIZReason
APPROVED_IS_FORBIDDEN_WHEN_UPDATE - Static variable in class bb.common.BIZReason
APPROVED_OBJECT_NOT_ALLOW_UPDATE_AGAIN - Static variable in class bb.common.BIZReason
approvedECR(String) - Method in interface bb.common.box.EngineeringBox
ApprovedGLResult - Class in bb.common
ApprovedGLResult() - Constructor for class bb.common.ApprovedGLResult
approveDisassembleWorkOrder(DisassembleWorkOrderVO) - Method in interface bb.common.box.WorkOrderBox
ApproveEng - Static variable in class bb.common.Constant.NcrApprovableType
approveEngineeringChange(String) - Method in interface bb.common.box.EngineeringBox
approveGeneralLedger(String) - Method in interface bb.common.box.AccountingBox
ApproveMFG - Static variable in class bb.common.Constant.NcrApprovableType
approveNonproductivePicking(NonproductivePickingVO) - Method in interface bb.common.box.WarehouseBox
approveOperatingInstructions(OperatingInstructionsVO) - Method in interface bb.common.box.ManufacturingBox
approveOrderChangeByID(Long, String) - Method in interface bb.common.box.WorkOrderBox
approvePoMessageByVendor(String, String) - Method in interface bb.common.box.PurchasingBox
approvePurchaseOrder(PurchaseOrderVO) - Method in interface bb.common.box.ManufacturingBox
approvePurchaseOrder(String) - Method in interface bb.common.box.ManufacturingBox
approvePurchaseOrder(PurchaseOrderVO) - Method in interface bb.common.box.PurchasingBox
approvePurchaseOrder(String) - Method in interface bb.common.box.PurchasingBox
ApproveQA - Static variable in class bb.common.Constant.NcrApprovableType
approveRequestForQuote(RequestForQuoteVO) - Method in interface bb.common.box.ManufacturingBox
approveRequestForQuote(String) - Method in interface bb.common.box.ManufacturingBox
approveRequestForQuote(RequestForQuoteVO) - Method in interface bb.common.box.PurchasingBox
approveRequestForQuote(String) - Method in interface bb.common.box.PurchasingBox
approveReturnToVendor(ReturnToVendorVO) - Method in interface bb.common.box.ManufacturingBox
approveReturnToVendor(String) - Method in interface bb.common.box.ManufacturingBox
approveReturnToVendor(ReturnToVendorVO) - Method in interface bb.common.box.PurchasingBox
approveReturnToVendor(String) - Method in interface bb.common.box.PurchasingBox
approveWorkInstruction(WorkInstructionVO) - Method in interface bb.common.box.ManufacturingBox
approveWorkOrder(WorkOrderVO) - Method in interface bb.common.box.WorkOrderBox
APTaxForZipcodeListResult - Class in bb.common
APTaxForZipcodeListResult() - Constructor for class bb.common.APTaxForZipcodeListResult
AR - Static variable in class bb.common.Constant.Prefix
AR - Static variable in class bb.common.Constant.TermsConditonType
AR_IS_CLOSED - Static variable in class bb.common.BIZReason
AR_PREPAY_ALREADY_EXIST - Static variable in class bb.common.BIZReason
AR_PREPAY_ALREDAY_PAID - Static variable in class bb.common.BIZReason
AR_PREPAY_BIGGER_THAN_SO_TOTAL - Static variable in class bb.common.BIZReason
AR_PREPAY_GL_IS_NOT_ENOUGH - Static variable in class bb.common.BIZReason
ARAllStatementsListResult - Class in bb.common
ARAllStatementsListResult() - Constructor for class bb.common.ARAllStatementsListResult
ARAuditListResult - Class in bb.common
ARAuditListResult() - Constructor for class bb.common.ARAuditListResult
ARBoilerplateVO - Class in bb.common
ARBoilerplateVO() - Constructor for class bb.common.ARBoilerplateVO
ARCM - Static variable in class bb.common.Constant.GLApprovedType
ARCM_APPROVED_BY_CAN_NOT_BE_EMPTY - Static variable in class bb.common.BIZReason
ARCM_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY - Static variable in class bb.common.BIZReason
ArCommissionListResult - Class in bb.common
ArCommissionListResult() - Constructor for class bb.common.ArCommissionListResult
ArCommissionTotalResult - Class in bb.common
ArCommissionTotalResult() - Constructor for class bb.common.ArCommissionTotalResult
ARP - Static variable in class bb.common.Constant.Prefix
arPaymentRunByCustomer(List<AccountReceivableInfoWithPrepayResult>, Object[]) - Method in interface bb.common.box.AccountingBox
ArPaymentRunItemAgent - Class in bb.common
ArPaymentRunItemAgent() - Constructor for class bb.common.ArPaymentRunItemAgent
ARPaymentRunItemPK - Class in bb.common
ARPaymentRunItemPK(String, String) - Constructor for class bb.common.ARPaymentRunItemPK
full constructor
ARPaymentRunItemPK() - Constructor for class bb.common.ARPaymentRunItemPK
default constructor
ARPaymentRunItemVO - Class in bb.common
ARPaymentRunItemVO() - Constructor for class bb.common.ARPaymentRunItemVO
default constructor
ARPaymentRunListResult - Class in bb.common
ARPaymentRunListResult() - Constructor for class bb.common.ARPaymentRunListResult
ARPaymentRunVO - Class in bb.common
ARPaymentRunVO() - Constructor for class bb.common.ARPaymentRunVO
default constructor
ARPrepayAllStatementsListResult - Class in bb.common
ARPrepayAllStatementsListResult() - Constructor for class bb.common.ARPrepayAllStatementsListResult
ARPrepayInfoResult - Class in bb.common
ARPrepayInfoResult() - Constructor for class bb.common.ARPrepayInfoResult
ArPrepayItemPK - Class in bb.common
ArPrepayItemPK(String, String) - Constructor for class bb.common.ArPrepayItemPK
ArPrepayItemPK() - Constructor for class bb.common.ArPrepayItemPK
ArPrepayItemVO - Class in bb.common
ArPrepayItemVO() - Constructor for class bb.common.ArPrepayItemVO
ArPrepaymentRunItemAgent - Class in bb.common
ArPrepaymentRunItemAgent() - Constructor for class bb.common.ArPrepaymentRunItemAgent
ARPrepaymentWireTransferAgent - Class in bb.common
ARPrepaymentWireTransferAgent() - Constructor for class bb.common.ARPrepaymentWireTransferAgent
ArPrepayVO - Class in bb.common
ArPrepayVO() - Constructor for class bb.common.ArPrepayVO
ARRIVALDATE - Static variable in class bb.common.Constant.DateType
ArSalesCodeTotalListResult - Class in bb.common
ArSalesCodeTotalListResult() - Constructor for class bb.common.ArSalesCodeTotalListResult
ARTaxForZipcodeListResult - Class in bb.common
ARTaxForZipcodeListResult() - Constructor for class bb.common.ARTaxForZipcodeListResult
ASC - Static variable in class bb.common.OrderBy
ASSET - Static variable in class bb.common.BizTarget
ASSET - Static variable in class bb.common.Constant.GLApprovedType
ASSET_ACCUMULATED_DEPRECIATION_OVER - Static variable in class bb.common.BIZReason
ASSET_ACQUISITION_COST_LESS_THAN_INITIAL_DEPRECIATE_COST - Static variable in class bb.common.BIZReason
ASSET_APPROVED_BY_CAN_NOT_BE_EMPTY - Static variable in class bb.common.BIZReason
ASSET_ASSETNUMBER - Static variable in class bb.common.LabelTemplateConstant
ASSET_ASSETTYPE - Static variable in class bb.common.LabelTemplateConstant
ASSET_ASSETTYPE2 - Static variable in class bb.common.LabelTemplateConstant
ASSET_CHECKDATE - Static variable in class bb.common.LabelTemplateConstant
ASSET_DEPARTMENTID - Static variable in class bb.common.LabelTemplateConstant
ASSET_DEPRECIATE - Static variable in class bb.common.BizTarget
ASSET_DEPRECIATE_ALREADY_EXIST - Static variable in class bb.common.BIZReason
ASSET_DEPRECIATE_HAVE_MADE_GL - Static variable in class bb.common.BIZReason
ASSET_DESCRIPTION - Static variable in class bb.common.LabelTemplateConstant
ASSET_HAS_EXIST - Static variable in class bb.common.BIZReason
ASSET_INITIAL_DEPRECIATE_COST_LESS_THAN_DEPRECIATED_ACCM - Static variable in class bb.common.BIZReason
ASSET_LOCATION - Static variable in class bb.common.LabelTemplateConstant
ASSET_NOT_EXIST - Static variable in class bb.common.BIZReason
ASSET_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY - Static variable in class bb.common.BIZReason
ASSET_TYPE - Static variable in class bb.common.BizTarget
ASSET_TYPE_ALREADY_EXIST - Static variable in class bb.common.BIZReason
ASSET_TYPE_IS_ALREADY_USED - Static variable in class bb.common.BIZReason
AssetAddOrDisposalsReport - Class in bb.common
AssetAddOrDisposalsReport() - Constructor for class bb.common.AssetAddOrDisposalsReport
default constructor
AssetAmortizationExpenseAccountPK - Class in bb.common
AssetAmortizationExpenseAccountPK() - Constructor for class bb.common.AssetAmortizationExpenseAccountPK
AssetAmortizationExpenseAccountPK(String, String) - Constructor for class bb.common.AssetAmortizationExpenseAccountPK
AssetAmortizationExpenseAccountVO - Class in bb.common
AssetAmortizationExpenseAccountVO() - Constructor for class bb.common.AssetAmortizationExpenseAccountVO
AssetDepreciateDetailReport - Class in bb.common
AssetDepreciateDetailReport() - Constructor for class bb.common.AssetDepreciateDetailReport
default constructor
AssetDepreciatePK - Class in bb.common
AssetDepreciatePK(String, String) - Constructor for class bb.common.AssetDepreciatePK
full constructor
AssetDepreciatePK() - Constructor for class bb.common.AssetDepreciatePK
default constructor
AssetDepreciateVO - Class in bb.common
AssetDepreciateVO() - Constructor for class bb.common.AssetDepreciateVO
default constructor
AssetReportSumResult - Class in bb.common
AssetReportSumResult() - Constructor for class bb.common.AssetReportSumResult
AssetTypeVO - Class in bb.common
AssetTypeVO() - Constructor for class bb.common.AssetTypeVO
AssetUsagePK - Class in bb.common
AssetUsagePK() - Constructor for class bb.common.AssetUsagePK
AssetUsageVO - Class in bb.common
AssetUsageVO() - Constructor for class bb.common.AssetUsageVO
AssetVO - Class in bb.common
AssetVO() - Constructor for class bb.common.AssetVO
AthoerException - Static variable in class bb.common.Constant.Download
AthoerException - Static variable in class bb.common.Constant.Upload
AUDIT - Static variable in class bb.common.BizTarget
auditAllOnHand() - Method in interface bb.common.box.WarehouseBox
auditing(ArrayList) - Method in interface bb.common.box.PurchasingBox
auditingWorkInstructionAvgHrs(HashMap) - Method in interface bb.common.box.ManufacturingBox
auditInSTO(BB2Part) - Method in interface bb.common.box.WarehouseBox
auditInWip(BB2Part) - Method in interface bb.common.box.WarehouseBox
auditLastInventoryDate(String, String, Date) - Method in interface bb.common.box.WarehouseBox
AuditLogVO - Class in bb.common
AuditLogVO() - Constructor for class bb.common.AuditLogVO
auditOnDemand(BB2Part) - Method in interface bb.common.box.WarehouseBox
AuditOnDemandResult - Class in bb.common
AuditOnDemandResult() - Constructor for class bb.common.AuditOnDemandResult
auditOnOrder(BB2Part) - Method in interface bb.common.box.WarehouseBox
auditPartBomFlag(HashSet<PartPK>) - Method in interface bb.common.box.EngineeringBox
auditPartDwgFlag(HashSet<BB2Part>) - Method in interface bb.common.box.EngineeringBox
AuditPartInQAResult - Class in bb.common
AuditPartInQAResult() - Constructor for class bb.common.AuditPartInQAResult
auditPartPictureFlag(HashSet<PartPK>) - Method in interface bb.common.box.EngineeringBox
auditPartWIFlag(HashSet<PartPK>) - Method in interface bb.common.box.EngineeringBox
auditUsage(BB2Part) - Method in interface bb.common.box.WarehouseBox
AUTHORIZATION_REQUIRED - Static variable in class bb.common.BIZReason
autiClosingEntryMonthly(String) - Method in interface bb.common.box.AccountingBox
AVGCOST - Static variable in class bb.common.Constant.CostControl
Overview Package Class Use Tree Deprecated Index Help
PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M N O P Q R S T U V W X Y Z


Alarmable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Interface Alarmable

All Known Implementing Classes:
AccountCreditVO, AccountDebitVO, AccountsCreditDebitListResult, APAuditListResult, ARAuditListResult, LockedCustomerAddressResult, PartCatalogAuditResult, PartOnHandAuditResult
public interface Alarmable

Method Summary
boolean | getAlarmValue()
java.lang.String | getCause()
void | setAlarmValue(boolean alarmValue)
void | setCause(java.lang.String cause)

Method Detail

getAlarmValue

boolean getAlarmValue()

setAlarmValue

void setAlarmValue(boolean alarmValue)

getCause

java.lang.String getCause()

setCause

void setCause(java.lang.String cause)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 All Classes
AccountAgingTotalResult
AccountAuditAgent
AccountBalanceAgent
AccountBalanceListResult
AccountBalanceResult
AccountCreditDebitPK
AccountCreditVO
AccountDebitVO
AccountInfoCenterItemResult
AccountInfoCenterResult
AccountingBalanceSheetResult
AccountingBox
AccountingConfigurationVO
AccountingInfoDocumentVO
AccountingSettingsVO
AccountingTotalMoneyResult
AccountingTransactionTypeVO
AccountMonthPK
AccountPayableCheckRunItemVO
AccountPayableCheckRunVO
AccountPayableCheckVO
AccountPayableInfoWithPrepayResult
AccountReceivableInfoWithPrepayResult
AccountReceivablePaymentVO
AccountsChartAdvanceCategoryVO
AccountsChartCategoryListResult
AccountsChartCategoryVO
AccountsChartMappingPK
AccountsChartMappingVO
AccountsChartResult
AccountsChartVO
AccountsCreditDebitListResult
AccountsPayableInfoVO
AccountsPayableItemManufacturerPK
AccountsPayableItemManufacturerVO
AccountsPayableItemPK
AccountsPayableItemVO
AccountsPayableVO
AccountsReceivableInfoVO
AccountsReceivableItemManufacturerPK
AccountsReceivableItemManufacturerVO
AccountsReceivableItemPK
AccountsReceivableItemResult
AccountsReceivableItemVO
AccountsReceivableVO
AddPayableWithoutReceiverAgent
AddPhysicalInventoryAgent
AddProformaReceiverAgent
AddProformaReceiverItemAgent
AddressAccountInfo
AddressBox
AddressQualityDocumentsVO
AddRTVAgent
Alarmable
AllBudgetResult
AllPartDocumentsPK
AllPartDocumentsVO
AllStatementsListResult
AmountsStatementResult
APAgingItemListResult
APAuditListResult
ApCheckRunItemAgent
ApCheckRunListResult
APItemListResult
AppColumnVO
AppException
APPrepayInfoResult
ApPrepayItemPK
ApPrepayItemVO
ApPrepaymentCheckRunItemAgent
ApPrepayVO
ApprovedGLResult
APTaxForZipcodeListResult
ARAllStatementsListResult
ARAuditListResult
ARBoilerplateVO
ArCommissionListResult
ArCommissionTotalResult
ArPaymentRunItemAgent
ARPaymentRunItemPK
ARPaymentRunItemVO
ARPaymentRunListResult
ARPaymentRunVO
ARPrepayAllStatementsListResult
ARPrepayInfoResult
ArPrepayItemPK
ArPrepayItemVO
ArPrepaymentRunItemAgent
ARPrepaymentWireTransferAgent
ArPrepayVO
ArSalesCodeTotalListResult
ARTaxForZipcodeListResult
AssetAddOrDisposalsReport
AssetAmortizationExpenseAccountPK
AssetAmortizationExpenseAccountVO
AssetDepreciateDetailReport
AssetDepreciatePK
AssetDepreciateVO
AssetReportSumResult
AssetTypeVO
AssetUsagePK
AssetUsageVO
AssetVO
AuditLogVO
AuditOnDemandResult
AuditPartInQAResult
BalanceSheetSideBySideItemResult
BalanceSheetSideBySideResult
BankReconciliationReportVO
BB2AttachFile
BB2BigDecimalAndString
BB2BugNotice
BB2Document
BB2DocumentException
BB2DoubleCost
BB2DoubleString
BB2Event
BB2File
BB2FiscalYearDate
BB2Login
BB2MessagingException
BB2Notice
BB2Part
BB2PartBasicInfo
BB2PartByDateResult
BB2PartInfo
BB2PartInSipItemResult
BB2PartInSipOfSoItemResult
BB2PartInSitItemResult
BB2PartInSTOItemResult
BB2PartInventoryResult
BB2PartMrpResult
BB2PartOnDemandListResult
BB2PartOnhandPK
BB2PartOnLoanItemResult
BB2PartTotalInQADetailResult
BB2PartTotalInSipDetailResult
BB2PartTotalInSitDetailResult
BB2PartTotalInSTODetailResult
BB2PartTotalInWipDetailResult
BB2PartTotalOndemandDetailResult
BB2PartTotalOnhandDetailResult
BB2PartTotalOnloanDetailResult
BB2PartTotalOnorderDetailResult
BB2Picture
BB2QtyAndMoneyMap
BB2RefdocPK
BB2ServerException
BB2Task
BB2TimeFactory
BB2tripleString
BB2Util
BB2WeightInfoResult
BB2Zip
BillDetailCostResult
BillDetailCostWithPartInfoResult
BillItemDetailCostWithPartInfoResult
BillItemOnHandUsageResult
BillItemOnHandWithPartInfoResult
BillItemPK
BillItemReplacementVO
BillItemSalesCostResult
BillItemSalesResult
BillItemSalesXResult
BillItemUsagePathResult
BillItemUsageResult
BillItemVO
BillItemWithPartInfoResult
BillLogVO
BillOnHandWithPartInfoResult
BillPK
BillSalesCostResult
BillSalesOfCostResult
BillSalesResult
BillSalesXResult
BillVO
BillWhereUsedItemResult
BillWhereUsedResult
BillWithPartInfoResult
BizboxBugChangesInfoVO
BizboxBugChangesVO
BizboxBugInfoVO
BizboxBugVO
BizBoxServer
BizBoxUserEmployeeResult
BizboxUserListResult
BizboxUserVO
BizException
BIZReason
BizTarget
BomApprovalVO
BOMCanAssyAgent
BOMCanAssyListResult
BomItemWithOEMResult
BomPickListItemResult
BomPickListResult
BOMTreeRollUPMap
BomWithOEMResult
BudgetListResult
BuyerCodeVO
CarrierPK
CarrierVO
CashFlowByMonthReportResult
CashFlowMonthTotalResult
CashierVO
CatalogVO
CertificateDescriptionVO
ChangeStdCostWorkSheetItemPK
ChangeStdCostWorkSheetItemVO
ChangeStdCostWorkSheetVO
CheckInvoiceItemListResult
CheckRunItemTotalResult
ClientAutoInvokeMethodsManager
ClientListItem
ClosingStatementItemResult
ClosingStatementResult
ClosingStatementTotalResult
CommonPrintTemplateVO
CompanyBox
CompanyUnitAccountPK
CompanyUnitAccountVO
CompanyUnitVO
CompanyVO
Configure
Configure.LoginStatus
Configure.Module
Configure.Organization
Configure.UpdatePermission
Configure.UserLocked
Configure.UserType
Constant
Constant.ActiveStatus
Constant.AddressType
Constant.AgeLevel
Constant.AmountType
Constant.ARDiscountMethod
Constant.CategoryReportType
Constant.CategoryType
Constant.ChartOfAccountSubType
Constant.ChartOfAccountType
Constant.CheckType
Constant.CostControl
Constant.CustomerVendorMailType
Constant.CVAddressType
Constant.CycleCountPeriodUnit
Constant.DataFilterType
Constant.DateType
Constant.DebitOrCredit
Constant.Depreciation
Constant.Depreciation.DepreciateStatus
Constant.Depreciation.DepreciationMethod
Constant.Depreciation.UsingType
Constant.Download
Constant.DrawingType
Constant.ECRPriority
Constant.EmployeeSecurityLevel
Constant.EmployeeStatus
Constant.EngineeringSharingImportDataType
Constant.EngineeringSharingImportType
Constant.EquipmentStatus
Constant.ExchangeRateType
Constant.FileExt
Constant.GLApprovedType
Constant.GLStyle
Constant.GLType
Constant.InventoryCostMothed
Constant.InventoryWorkSheetOrderBy
Constant.IrDateType
Constant.IRType
Constant.IssuedFrom
Constant.LanguageCode
Constant.LocalSettings
Constant.LoginType
Constant.MakeBuy
Constant.MiscDocType
Constant.NaRecTo
Constant.NcrApprovableType
Constant.NoticeAction
Constant.NoticeType
Constant.OITypeSerialNumberType
Constant.OrderType
Constant.Package
Constant.PageCycleCount
Constant.PAOffsetType
Constant.PartFrom
Constant.PartNumberGenerateType
Constant.PartQtyType
Constant.PayableMethod
Constant.PeriodUnit
Constant.PosOrderType
Constant.Prefix
Constant.PrintTemplateType
Constant.ReceiveCondition
Constant.ReceivedTo
Constant.SalesTaxReportType
Constant.SGType
Constant.StatementType
Constant.Status
Constant.SystemUserGroup
Constant.TaxType
Constant.TermsConditonType
Constant.TrackingNumberType
Constant.TransactionType
Constant.TransferType
Constant.Upload
Constant.VendorQualityStatus
Constant.WorkCenterSearchType
Constant.WorkCenterType
Constant.WorkLevel
Constant.YesNO
ContractPriceCustomerPK
ContractPriceCustomerVO
ContractPriceItemPK
ContractPriceItemVO
ContractPriceVO
CopyUtil
CorrectiveActionRequestVO
CPItemFromQuoteResult
CRTVItemListResult
CRTVListResult
CSRAgent
CurrencyAgent
CurrencyExchangePK
CurrencyExchangeVO
CurrencyVO
CurrentBalanceResult
CustomAssetRecordPK
CustomAssetRecordVO
CustomAssetVO
CustomCheckUpEmployeeVO
CustomDepartmentVO
CustomEmployeeTrainPK
CustomEmployeeTrainVO
CustomEmployeeVO
CustomEmployeeWorkExperienceVO
CustomerCLimitResult
CustomerFeedbackVO
CustomerPrepayStatementListResult
CustomerReturnToVendorItemPK
CustomerReturnToVendorItemVO
CustomerReturnToVendorVO
CustomerServiceBox
CustomerServiceIncidentItemListResult
CustomerServiceIncidentItemVO
CustomerServiceIncidentListResult
CustomerServiceIncidentVO
CustomerStatementListResult
CustomerStatementResult
CustomerStatementTotalResult
CustomerVendorAddressInfoVO
CustomerVendorAddressTotalInfo
CustomerVendorAddressVO
CustomerVendorContactPK
CustomerVendorContactVO
CustomerVendorDescriptionPK
CustomerVendorDescriptionVO
CustomerVendorTypeVO
CustomGoodsBreedVO
CustomGoodsRecordVO
CustomJobCategoryGoodsPK
CustomJobCategoryGoodsVO
CustomJobCategoryVO
CustomSearchVO
CustomTranslationVO
CV2CVAgent
CycleCountAgent
CycleCountListResult
CycleCountListTotalResult
CycleCountPK
CycleCountStatusVO
CycleCountVO
DataFilterVO
DBAccessException
DBReason
DebitsCreditsResult
DepartmentLocationForBackflushVO
DepositSummaryResult
DepreciateMonthlyReport
DesignControlDocumentVO
DesignControlInfoVO
DesignControlListResult
DesignControlVO
DisassembleWorkOrderApprovalVO
DisassembleWorkOrderDocumentVO
DisassembleWorkOrderIssueVO
DisassembleWorkOrderIssuingItemResult
DisassembleWorkOrderIssuingResult
DisassembleWorkOrderItemListResult
DisassembleWorkOrderItemPartDetailItemResult
DisassembleWorkOrderItemPartDetailResult
DisassembleWorkOrderItemPK
DisassembleWorkOrderItemReceiverPK
DisassembleWorkOrderItemReceiverVO
DisassembleWorkOrderItemVO
DisassembleWorkOrderListResult
DisassembleWorkOrderReceivingResult
DisassembleWorkOrderVO
DocumentAction
DocumentAction.DwfAndDwgDocAction
DocumentAction.MiscDocAction
DocumentAction.PartDocAction
DocumentBox
DocumentInfoAgent
DocumentLogVO
DocumentServerVO
DuePATotalByVendorResult
DwfUploadSettingsVO
DwgUploadSettingsVO
DWOIssueDetail
DynamicSearchFilter
EcnCheckOrderResult
EcnPOOrderResult
ECNReviewVO
EcnWOOrderResult
ECRReviewVO
EjbMethodVO
EmployeeCardVO
EmployeeEducationPK
EmployeeEducationResult
EmployeeEducationVO
EmployeeHomeVO
EmployeeJobDescriptionVO
EmployeeLaborAgent
EmployeePutGoodListResult
EmployeeRecordsVO
EmployeeTimeCardResult
EmployeeTrainingVO
EmployeeWorkExperiencePK
EmployeeWorkExperienceVO
EngGroupUserPK
EngGroupUserVO
EngGroupVO
EngineeringBox
EngineeringChangeDocumentVO
EngineeringChangeListResult
EngineeringChangeRequestDocumentVO
EngineeringChangeRequestListResult
EngineeringChangeRequestVO
EngineeringChangeVO
EngineeringInfoCenterResult
EngineeringSharingImportLogVO
EngineeringSharingItemPK
EngineeringSharingItemVO
EngineeringSharingVO
EquipmentListResult
EquipmentVO
ExchangeAuditItemResult
ExchangeAuditResult
ExpenseAccountVO
ExpenseItemPK
ExpenseItemVO
ExpenseListResult
ExpenseVO
Facade
FeedbackAnswerPK
FeedbackAnswerVO
FeedBackItemPK
FeedbackItemVO
FeedbackQuestionVO
FinishProformaReceiverAgent
FiscalYearSettingsVO
GeneralLedgerApprovalVO
GeneralLedgerByDateListResult
GeneralLedgerCategoryVO
GeneralLedgerEntry
GeneralLedgerListResult
GeneralLedgerPrintResult
GeneralLedgerResult
GeneralLedgerSettingsVO
GeneralLedgerVO
GLApprovalListResult
GLAutoApproveVO
GlBalanceInfoResult
GLByDateTotalResult
GlCashFlowBudgetVO
GLCatAndSequence
GLCheckRegisterResult
GLDebitCreditListResult
GlFiscalYearBudgetVO
GLInfoByPeriodResult
GLItemVO
GlMonthBudgetVO
GlMonthVO
GroupUserPK
GroupUserVO
HelpServerVO
HighUsagePartResult
HistoricalInventoryTotalResult
HistoricalInventoryVO
HumanResourceBox
I18nEvent
IcrItemListResult
IcrListResult
ImportContractPriceData
ImportDataVO
IncomeByMonthChartResult
IncotermVO
InfoByFiscalChartResult
InfoByMonthChartResult
InfoByMonthResult
InSipAudittListResult
InspectionConformanceReportItemCheckPK
InspectionConformanceReportItemCheckVO
InspectionConformanceReportItemInfo
InspectionConformanceReportItemPK
InspectionConformanceReportItemVO
InspectionConformanceReportVO
InspectionItemPK
InspectionItemVO
InspectionReportInfoVO
InspectionReportInspectMethodItemPK
InspectionReportInspectMethodItemVO
InspectionReportInspectMethodVO
InspectionReportInspectStandardItemPK
InspectionReportInspectStandardItemVO
InspectionReportItemPK
InspectionReportItemQtyPK
InspectionReportItemQtyVO
InspectionReportItemVO
InspectionReportVO
InspectionTypeItemPK
InspectionTypeItemVO
InspectionTypeVO
InventoryAdjustmentDetailResult
InventoryAdjustmentListResult
InventoryAdjustmentVO
InventoryAmountByMonth
InventoryAuditReportResult
InventoryCycleItemResult
InventoryCycleResult
InventoryListResult
InventoryMonthReport
InventoryNotUsedInMonthsforAppResult
InventoryNotUsedInMonthsResult
InventoryNotUsedTotal
InventoryPartInOutDetailListResult
InventoryReportListResult
InventoryTotalCostResult
InventoryTotalResult
InvoiceAgingItemListResult
InvoiceItemListResult
InvokeException
IpAddressVO
IssuedFromOrderItem
IssueItemAgent
IssueItemDetailAgent
IssuingItemResult
IssuingResult
JobProcessSheetItemResult
JobProcessSheetListResult
JobProcessSheetResult
JounalEntryListResult
LabelTemplateConstant
LabelTemplateItemPK
LabelTemplateItemVO
LabelTemplateVO
ListCache
LnShipperItemListResult
LnShipperListResult
LocationResult
LockedCustomerAddressResult
LogBox
LoginException
LogInventoryListResult
LogInventoryVO
LogMethodPK
LogMethodVO
LogMiscDocumentVO
LogPartDocumentVO
LogPartDwfVO
LogPartDwgVO
LogTaskVO
LogTrackingVO
MaintenanceItemPK
MaintenanceItemVO
MakeAccountPayableAgent
MakeBillAndHoldInvoiceAgent
MakeCheckAgent
MakeCreditMemoAgent
MakeDebitMemoAgent
MakeInvoiceAgent
MakePrepaymentCheckAgent
ManagementBox
ManufacturerAddressInfoVO
ManufacturerAddressVO
ManufacturerContactPK
ManufacturerContactVO
ManufacturerDescriptionPK
ManufacturerDescriptionVO
ManufacturingBox
MasterWorkOrderTreeItemResult
MessageAgent
MessageVO
MfrMpnListResult
MiscDocAgent
MiscDocumentSettingVO
Money
MoneyInDrawResult
MonthBalanceResult
MonthSoOrArByCustomerResult
MrpByMonthResult
MrpItemOrderDemandRecordsResult
MrpItemResult
MrpReportAgent
MultiLanguageAccountsChartPK
MultiLanguageAccountsChartVO
MyPrintListPK
MyPrintListVO
NCQRejectResult
NcrApprovalPK
NcrApprovalVO
NcrNeedToScrapListResult
NCRPartOnhandPK
NCRPictureListResult
NCRPictureVO
NcrReportListResult
NcrScrapAgent
NonConformanceCodeDescriptionPK
NonConformanceCodeDescriptionVO
NonConformanceCodeVO
NonConformanceQuantityPK
NonConformanceQuantityVO
NonConformanceReportResult
NonConformanceReportVO
NonproductivePickingApprovalVO
NonproductivePickingApproveVO
NonproductivePickingItemIssuedListResult
NonproductivePickingItemIssuedVO
NonproductivePickingItemPK
NonproductivePickingItemResult
NonproductivePickingItemVO
NonproductivePickingOnDemandResult
NonproductivePickingTypeVO
NonproductivePickingVO
NoticeUserEmployeeListResult
OIPrincipalVO
OnhandQualityResult
OnloanDocumentVO
OnLoanItemListResult
OnLoanItemPK
OnLoanItemVO
OnLoanListResult
OnloanReceiverItemListResult
OnloanReceiverItemPK
OnloanReceiverItemVO
OnloanReceiverListResult
OnloanReceiverVO
OnloanReviewVO
OnloanShipperItemPK
OnloanShipperItemVO
OnloanShipperVO
OnLoanVO
OnTimeAgent
OntimeDeliveryRateListResult
OntimeDeliveryRateResult
OpCodeShortcutPK
OpCodeShortcutVO
OperatingInstructionsInspectMethodItemPK
OperatingInstructionsInspectMethodItemVO
OperatingInstructionsInspectResultItemPK
OperatingInstructionsInspectResultItemVO
OperatingInstructionsInspectStandardItemPK
OperatingInstructionsInspectStandardItemVO
OperatingInstructionsInspectStandardVO
OperatingInstructionsManualItemPK
OperatingInstructionsManualItemVO
OperatingInstructionsManualVO
OperatingInstructionsTypeVO
OperatingInstructionsUserStatisticalResult
OperatingInstructionsVO
OperatingOutputFileItemPK
OperatingOutputFileItemVO
OperatingOutputFileTypeVO
OperationLogVO
OrderApprovalItemsVO
OrderApprovalVO
OrderBoilerplatePK
OrderBoilerplateVO
OrderBy
OrderDemandForReceiverResult
OrderDocumentVO
OrderPK
OrderVendorItem
OutputValueByMonthResult
PackingBoxItemListResult
PackingBoxItemPK
PackingBoxItemVO
PackingBoxPK
PackingBoxSalesOrderItemAgent
PackingBoxSalesOrderItemResult
PackingBoxVO
PartBasicInfo
PartBasicInfoWithNewEngGroup
PartBasicInfoWithNewListPrice
PartCatagoryPK
PartCatagoryVO
PartCatalogAuditResult
PartCatalogPK
PartCatalogVO
PartCertificateListResult
PartCertificateVO
PartClassInfoResult
PartClassVO
PartCostVarianceListResult
PartDescriptionPK
PartDescriptionVO
PartDiscountPK
PartDiscountVO
PartDocumentPK
PartDocumentVO
PartDueAddressListResult
PartDwfAgent
PartDwfPK
PartDwfVO
PartDwfWithPartInfoResult
PartDwgAgent
PartDwgPK
PartDwgVO
PartDwgWithPartInfoResult
PartExportInfo
PartInMrpListResult
PartInQAAgent
PartInQAResult
PartInQAVO
PartInspectionPK
PartInspectionResult
PartInspectionVO
PartInventoryVO
PartInWipForIDListResult
PartIssuedListResult
PartIssuedVO
PartIssueTotalResult
PartManufacturerAgent
PartManufacturerPK
PartManufacturerVO
PartMaterialBomListResult
PartMaterialListResult
PartMaterialReportAgent
PartMaterialVO
PartMaterialWhereUsedItemResult
PartMaterialWhereUsedResult
PartMRPVO
PartNumberGenerateRuleVO
PartOnhandAndCostResult
PartOnHandAuditAgent
PartOnHandAuditResult
PartOnhandCostVO
PartOnhandPK
PartOnhandResult
PartOnhandVO
PartOnhandWithAverageCostResult
PartOnHandWithMfgInfoResult
PartOnHandWithPartBasicInfoResult
PartPictureVO
PartPK
PartReceivedListResult
PartReceivedVO
PartSecurityLevelVO
PartsToDeleteResult
PartToAuditFlagResult
PartTraceableCategoryPK
PartTraceableCategoryVO
PartTraceableInfoResult
PartTraceableListResult
PartTraceableResult
PartTraceableSpecPK
PartTraceableSpecVO
PartTrackingPK
PartTrackingVO
PartTypeVO
PartUnitPK
PartUnitVO
partUsedInfoResult
PartUseTypeVO
PartVendorPK
PartVendorVO
PartVO
PartWhereUsedItemResult
PartWhereUsedResult
PartWithExcessiveInventoryListResult
PartWithInventoryInfoListResult
PartWithManufacturerInfoResult
PartWithOnhandDetailInfoResult
PartWithOnhandsVO
PartWithOnLoanQtyListResult
PartWithoutLocateResult
PartWithQAQtyListResult
PartWithQtyListResult
PartWithSipQtyListResult
PartWithSITQtyListResult
PartWithSTOQtyListResult
PartWithWipQtyListResult
PasswordPolicyAgent
PayableCheckRunItemPK
PayableMethodVO
PaymentAgent
PaymentHistoryVO
PaymentInvoicesResult
PaymentRunItemTotalResult
PaymentVO
PermissionDescriptionPK
PermissionDescriptionVO
PermissionException
PermissionListResult
PermissionMethodPK
PermissionMethodVO
PermissionVO
PfReceiverItemPK
PfReceiverItemVO
PfReceiverItemWithNumberPK
PfReceiverVO
PhysicalInventoryListResult
PhysicalInventoryListTotalResult
PhysicalInventoryListWithAppDataResult
PhysicalInventoryPK
PhysicalInventoryStatusVO
PhysicalInventoryVO
PlanningBox
PO2POAgent
PO2SOExchange
PO2SOExchangeItem
PO2SOExchangeItemManufacturer
POAndWOStatusResult
POForWISeqAgent
PointOfSaleVO
POItemByRefDoc1ListResult
PoMessageItemPK
PoMessageItemVO
PoMessageListResult
PoMessageVO
PoReceiverByDateSummaryResult
POReceiverItemListResult
PosRefdocVO
POStatisticsResult
PostCheckAgent
POSurveyReportAgent
POSurveyReportItemPK
POSurveyReportItemVO
POSurveyReportVO
PosZipCodeTaxPK
PosZipCodeTaxVO
PrepayAgent
PrepaymentWireTransferAgent
PrepayPaymentAgent
PreventiveActionRequestItemVO
PreventiveActionRequestVO
PrintLogoVO
PrintTemplateVO
ProfitAndLossAccountsResult
ProfitLossStatementItemResult
ProfitLossStatementResult
ProformaInvoiceItemListResult
ProformaInvoiceItemManufacturerPK
ProformaInvoiceItemManufacturerVO
ProformaInvoiceItemPK
ProformaInvoiceItemVO
ProformaInvoiceListResult
ProformaInvoiceVO
ProformaReceiverPackingBoxAgent
ProformaReceiverPackingBoxItemAgent
ProjectVO
PrPackingBoxItemPK
PrPackingBoxItemVO
PrPackingBoxPK
PrPackingBoxVO
PrReceiverListResult
PrReceiverWithQualityListResult
PullFromWorkOrderPartDetailAgent
PurchaseOnTimeResult
PurchaseOrderApprovalVO
PurchaseOrderBoilerplateVO
PurchaseOrderCheckListResult
PurchaseOrderContractResult
PurchaseOrderDocumentVO
PurchaseOrderItemListResult
PurchaseOrderItemManufacturerPK
PurchaseOrderItemManufacturerVO
PurchaseOrderItemPK
PurchaseOrderItemVO
PurchaseOrderListResult
PurchaseOrderOnOrderResult
PurchaseOrderOnTimeItemResult
PurchaseOrderOnTimeResult
PurchaseOrderOpenDueListResult
PurchaseOrderVO
PurchaseWorkSheetItemPK
PurchaseWorkSheetItemVO
PurchaseWorkSheetItemWithRelatedInfoResult
PurchaseWorkSheetPK
PurchaseWorkSheetVO
PurchasingBox
PurchasingInfoCenterResult
PuttoInQAAgent
QtyAndMoney
QtyDetailResult
QualityBox
QualityGroupPK
QualityGroupVO
QualityInfoCenterResult
Quote2QuoteAgent
QuoteBoilerplateVO
QuoteDocumentVO
QuoteItemListResult
QuoteItemManufacturerPK
QuoteItemManufacturerVO
QuoteItemPK
QuoteItemVO
QuoteListResult
QuoteVO
Reason
RebackInQAAgent
ReceivedToOrderItem
ReceiverAgent
ReceiverInfoVO
ReceiverItemAgent
ReceiverItemDetailAgent
ReceiverItemManufacturerPK
ReceiverItemManufacturerVO
ReceiverItemPK
ReceiverItemTrackingLogAgent
ReceiverItemVO
ReceiverShipAgent
ReceiverVO
ReceivingItemResult
ReceivingResult
RecursiveBillPath
RefdocElement
RefdocVO
RequestForQuoteCheckListResult
RequestForQuoteItemListResult
RequestForQuoteItemManufacturerPK
RequestForQuoteItemManufacturerVO
RequestForQuoteItemPK
RequestForQuoteItemVO
RequestForQuoteListResult
RequestForQuoteVO
RequestForRMAItemPK
RequestForRMAItemVO
RequestForRMAVO
ReturnMaterialAuthorizationDocumentVO
ReturnMaterialAuthorizationItemManufacturerPK
ReturnMaterialAuthorizationItemManufacturerVO
ReturnMaterialAuthorizationItemPK
ReturnMaterialAuthorizationItemVO
ReturnMaterialAuthorizationVO
ReturnToVendorByDateListResult
ReturnToVendorCheckListResult
ReturnToVendorItemListResult
ReturnToVendorItemManufacturerPK
ReturnToVendorItemManufacturerVO
ReturnToVendorItemPK
ReturnToVendorItemVO
ReturnToVendorListResult
ReturnToVendorVO
RfqMessageItemPK
RfqMessageItemVO
RfqMessageListResult
RfqMessageVO
RMAItemListResult
RMAListResult
RMAReceiverItemListResult
RMAReceiverItemPK
RMAReceiverItemVO
RMAReceiverListResult
RMAReceiverResult
RMAReceiverVO
RMAReviewVO
RoleDescriptionPK
RoleDescriptionVO
RoleListResult
RolePermissionPK
RolePermissionVO
RoleVO
RollUpBomStdCostWorkSheetItemPK
RollUpBomStdCostWorkSheetItemVO
RollUpBomStdCostWorkSheetVO
RollUPPartStandardCostResult
RRMAItemListResult
RRMAListResult
RTVApprovalVO
RtvShipperInfoVO
RtvShipperItemListResult
RtvShipperItemPK
RtvShipperItemVO
RtvShipperListResult
RtvShipperVO
RunningAccountOrderItemPK
RunningAccountOrderItemResult
RunningAccountOrderItemVO
RunningAccountOrderVO
RunTaxPaymentResult
SalesBomItemResult
SalesBomResult
SalesBox
SalesCodeVO
SalesInfoCenter
SalesInfoCenter.DueSoCount
SalesInfoCenter.DueSoSum
SalesInfoCenter.GrossMargin
SalesInfoCenter.InvoicedSum
SalesInfoCenter.OpenSoSum
SalesInfoCenter.SoCount
SalesInfoCenter.SoCountWithPartsOnhold
SalesInfoCenter.SoItemCount
SalesInfoCenter.SoTotalSum
SalesInfoCenterResult
SalesmanVO
SalesMarginListResult
SalesOnTimeResult
SalesOrder12MonthMarginResult
SalesOrderBoilerplateVO
SalesOrderCheckListResult
SalesOrderDocumentVO
SalesOrderItemCostResult
SalesOrderItemCustomerTotalResult
SalesOrderItemGroupByPartListResult
SalesOrderItemInfoVO
SalesOrderItemListResult
SalesOrderItemManufacturerPK
SalesOrderItemManufacturerVO
SalesOrderItemPK
SalesOrderItemVO
SalesOrderListResult
SalesOrderOnDemandResult
SalesOrderOnTimeItemResult
SalesOrderOnTimeResult
SalesOrderOrphanedResult
SalesOrderReviewVO
SalesOrderShipDateListResult
SalesOrderVO
SalesPartListItemResult
SalesPartListResult
SalesTaxListResult
ScrapAssetAgent
ScrapReportVO
SecurityBox
SerialNumberItemPK
SerialNumberItemResult
SerialNumberItemVO
SerialNumberPK
SerialNumberResult
SerialNumberVO
ServerAction
ServerClientPropertyPK
ServerClientPropertyVO
ServerException
SGBillItemPK
SGBillItemVO
SGBOMItemResult
SGBOMResult
SGCartCheckOutResult
SGCartLogin
SGClientAccountPK
SGClientAccountVO
SGClientLogin
SgClientProgramUserVO
SGCompanyPK
SGCompanyVO
SGCustomerCatalogPK
SGCustomerCatalogVO
SGCustomerServiceRequestVO
SGCustRequestForQuoteItemPK
SGCustRequestForQuoteItemResult
SGCustRequestForQuoteItemVO
SGCustRequestForQuoteListResult
SGCustRequestForQuoteResult
SGCustRequestForQuoteVO
SGDocPartPK
SGDocPartVO
SGDwgPicturePK
SGDwgPictureVO
SGLogLoginVO
SGPartCartAgent
SGPartCatalogResult
SGPartDocFlagResult
SGPartListItemResult
SGPartListResult
SGPicturePK
SGPictureVO
SGQuoteAddressResult
SGQuoteAddressVO
SGQuoteCartListResult
SGQuoteCartVO
SGQuoteLoginVO
SGSaleItemAgent
SGSaleItemVO
SGWeightUnitVO
ShareHoldersEquityResult
ShipListAgent
ShipListInfoVO
ShipListItemPK
ShipListItemRelatedDocResult
ShipListItemVO
ShipListItemVOResult
ShipListOwnerAttributePK
ShipListOwnerAttributeVO
ShipListOwnerVO
ShipListVO
ShipperAgent
ShipperInfoVO
ShipperItemAgent
ShipperItemDetailAgent
ShipperItemListResult
ShipperItemManufacturerPK
ShipperItemManufacturerVO
ShipperItemPK
ShipperItemVO
ShipperListResult
ShipperVO
ShippingItemResult
ShippingResult
ShoppingCartItem
SmtpServerVO
SO2POAgent
SO2SOAgent
SO2WOAgent
SoPickListResult
SOShipperItemListResult
Spiderman
StaffWorkingInformationResult
StockTransactionAdjustmentResult
StockTransactionPartInfoResult
StockTransactionPOReceiverResult
StockTransactionSOShipperResult
StockTransactionWOReceiverResult
StockTransactionWOShipperResult
StringListConvertor
SubcompanyLoginAgent
SubcompanyVO
SwapOrderApprovalVO
SwapOrderItemListResult
SwapOrderItemPK
SwapOrderItemVO
SwapOrderListResult
SwapOrderVO
SwapReceiverItemListResult
SwapReceiverItemPK
SwapReceiverItemVO
SwapReceiverListResult
SwapReceiverVO
SwapShipperItemListResult
SwapShipperItemPK
SwapShipperItemVO
SwapShipperListResult
SwapShipperOnOrderResult
SwapShipperVO
TakeCycleCountAgent
TaskFileResult
TaskVO
TaxAccountVO
TempArApAgingVO
TempReceiverWithoutAPInfo
TermAgent
TermsConditionVO
TermVO
ToolBasicInfo
ToolCalibrateListResult
ToolCalibrationVO
ToolDescriptionVO
ToolInventoryVO
ToolListDetailCostResult
ToolListDetailCostWithToolInfoResult
ToolListInfoVO
ToolListItemDetailCostWithToolInfoResult
ToolListItemVO
ToolListItemWithToolInfoResult
ToolListVO
ToolListWithToolInfoResult
ToolManufacturerVO
ToolOnhandVO
ToolOnhandWithAverageCostResult
ToolVendorVO
ToolVO
ToolWhereUsedItemResult
ToolWhereUsedResult
ToolWithManufacturerInfoResult
ToolWithOnhandsVO
TotalAmountInPOByRefDoc
TotalByDateResult
TraceableCategoriesVO
TraceableSpecsVO
TransferOrderApprovalVO
TransferOrderItemListResult
TransferOrderItemPK
TransferOrderItemVO
TransferOrderListResult
TransferOrderVO
TransferReceiverItemListResult
TransferReceiverItemPK
TransferReceiverItemVO
TransferReceiverListResult
TransferReceiverVO
TransferShipperItemListResult
TransferShipperItemPK
TransferShipperItemVO
TransferShipperListResult
TransferShipperVO
TwelveMonthCashFlowReportResult
UnitVO
UpdatePhysicalInventoryAgent
User2UserAgent
UserGroupVO
UserRolePermissionListResult
UserRolePK
UserRoleVO
VendorCategoriesVO
VendorContractPriceItemPK
VendorContractPriceItemVO
VendorContractPriceVendorPK
VendorContractPriceVendorVO
VendorContractPriceVO
VendorCriticalLevelVO
VendorGroupUserVO
VendorPartPK
VendorPartVO
VendorPrepayStatementListResult
VendorPriceAgent
VendorQtyPricePK
VendorQtyPriceVO
VendorStatementListResult
VendorTotalAmountInPO
VersionInformation
VO
WarehouseBox
WareHousePartPrefixKeeperVO
WarehouseTransferPK
WarehouseTransferVO
WarehouseVO
WareHousingInfoCenterResult
WC2WCAgent
WCLoadAgent
WCLoadByDateResult
WCLoadDetailResult
WCLoadOnDateResult
WeightUnitVO
WireTransferAgent
WO2WOAgent
WOIssuedByMonthChartResult
WOIssuedByMonthResult
WOItemCostControlAgent
WOItemPartDetailNotIssue
WoItemPickListItemResult
WoItemPickListResult
WoItemWorkInstructionListResult
WOReceiverDetail
WorkCalendarVO
WorkCenterAgent
WorkCenterGroupItemPK
WorkCenterGroupItemVO
WorkCenterLoadAgent
WorkCenterLoadListResult
WorkCenterOnDateAgent
WorkCenterRunTimeAgent
WorkCenterRunTimeListResult
WorkCenterRunTimeTotalResult
WorkCenterVendorPK
WorkCenterVendorVO
WorkCenterVO
WorkFlowVO
WorkInstructionApprovalVO
WorkInstructionDocumentVO
WorkInstructionListResult
WorkInstructionPictureVO
WorkInstructionPK
WorkInstructionRequestForChangeVO
WorkInstructionSeqAuditListResult
WorkInstructionSequenceListResult
WorkInstructionSequencePK
WorkInstructionSequenceVO
WorkInstructionSummaryItemResult
WorkInstructionSummaryResult
WorkInstructionVO
WorkOrderApprovalVO
WorkOrderBoilerplateVO
WorkOrderBox
WorkOrderCheckListResult
WorkOrderDocumentVO
WorkOrderInfoCenterResult
WorkOrderInWipResult
WorkOrderIssuedOrderListResult
WorkOrderIssueStatisticsResult
WorkOrderItemAgent
WorkOrderItemCanAssyAgent
WorkOrderItemCanAssyResult
WorkOrderItemInfoResult
WorkOrderItemInWipListResult
WorkOrderItemIssuedTotalResult
WorkOrderItemIssuePK
WorkOrderItemIssueVO
WorkOrderItemLaborCostListResult
WorkOrderItemListResult
WorkOrderItemPartDetail
WorkOrderItemPartDetailInWipVO
WorkOrderItemPartDetailItemResult
WorkOrderItemPartDetailResult
WorkOrderItemPK
WorkOrderItemReviewCostResult
WorkOrderItemSeqWCLoadResult
WorkOrderItemSetupItemAgent
WorkOrderItemTimeDetailResult
WorkOrderItemTimeDetailVO
WorkOrderItemToIssueResult
WorkOrderItemVO
WorkOrderItemWCLoadResult
WorkOrderListResult
WorkOrderNotSetupResult
WorkOrderOnDemandResult
WorkOrderOnOrderResult
WorkOrderOnTimeItemResult
WorkOrderOnTimeResult
WorkOrderOverIssueListResult
WorkOrderQueryInfo
WorkOrderReceiverVO
WorkOrderTimeCardVO
WorkOrderVO
WorkOrderWorkInstructionListResult
WorkOrderWorkInstructionPK
WorkOrderWorkInstructionSequenceDateAgent
WorkOrderWorkInstructionSequencePK
WorkOrderWorkInstructionSequenceVO
WorkOrderWorkInstructionVO
WorkOrderWorkItemDateAgent
WorkOrderWorkSheetItemPK
WorkOrderWorkSheetItemVO
WorkOrderWorkSheetItemWithRelatedInfoResult
WorkOrderWorkSheetPK
WorkOrderWorkSheetVO
WorkPeriodVO
WorkSheetPartAgent
YearMonthManager
ZipCodeTaxVO
ZipcodeTotalsResult
ZipCodeVO
ZippedByteArray


AllBudgetResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AllBudgetResult

java.lang.Object
    extended by  bb.common.AllBudgetResult
All Implemented Interfaces:
java.io.Serializable
public class AllBudgetResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AllBudgetResult()
Method Summary
java.util.List<BudgetListResult> | getBudgetForExpenseListResult()
java.util.List<BudgetListResult> | getBudgetForRevenueListResult()
void | setBudgetForExpenseListResult(java.util.List<BudgetListResult> budgetForExpenseListResult)
void | setBudgetForRevenueListResult(java.util.List<BudgetListResult> budgetForRevenueListResult)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AllBudgetResult

public AllBudgetResult()
Method Detail

getBudgetForRevenueListResult

public java.util.List<BudgetListResult> getBudgetForRevenueListResult()

setBudgetForRevenueListResult

public void setBudgetForRevenueListResult(java.util.List<BudgetListResult> budgetForRevenueListResult)

getBudgetForExpenseListResult

public java.util.List<BudgetListResult> getBudgetForExpenseListResult()

setBudgetForExpenseListResult

public void setBudgetForExpenseListResult(java.util.List<BudgetListResult> budgetForExpenseListResult)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AllPartDocumentsPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AllPartDocumentsPK

java.lang.Object
    extended by  bb.common.AllPartDocumentsPK
All Implemented Interfaces:
java.io.Serializable
public class AllPartDocumentsPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
AllPartDocumentsPK()
default constructor
AllPartDocumentsPK(java.lang.String partNumber, java.lang.String documentType, java.lang.String language, java.lang.String docVersion)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDocumentType()
java.lang.String | getDocVersion()
java.lang.String | getLanguage()
java.lang.String | getPartNumber()
int | hashCode()
void | setDocumentType(java.lang.String documentType)
void | setDocVersion(java.lang.String docVersion)
void | setLanguage(java.lang.String language)
void | setPartNumber(java.lang.String partNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

AllPartDocumentsPK

public AllPartDocumentsPK(java.lang.String partNumber,
                          java.lang.String documentType,
                          java.lang.String language,
                          java.lang.String docVersion)
full constructor

AllPartDocumentsPK

public AllPartDocumentsPK()
default constructor

Method Detail

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getDocumentType

public java.lang.String getDocumentType()

setDocumentType

public void setDocumentType(java.lang.String documentType)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getDocVersion

public java.lang.String getDocVersion()

setDocVersion

public void setDocVersion(java.lang.String docVersion)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AllPartDocumentsVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AllPartDocumentsVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AllPartDocumentsVO
All Implemented Interfaces:
java.io.Serializable
public class AllPartDocumentsVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_DOCUMENTTYPE
static java.lang.String | ORDER_BY_LANGUAGE
static java.lang.String | ORDER_BY_LASTCHANGEDATE
static java.lang.String | ORDER_BY_LASTCHANGEUSER
static java.lang.String | ORDER_BY_PK
Constructor Summary
AllPartDocumentsVO()
default constructor
AllPartDocumentsVO(AllPartDocumentsPK pk, java.util.Date lastChangeDate, java.lang.String lastChangeUser, boolean publicDoc, java.lang.String description, java.lang.String comments)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.lang.String | getDescription()
java.lang.Long | getDocumentLengthByte()
java.lang.String | getExtension()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
AllPartDocumentsPK | getPk()
int | hashCode()
boolean | isPublicDoc()
void | setComments(java.lang.String comments)
void | setDescription(java.lang.String description)
void | setDocumentLengthByte(java.lang.Long documentLengthByte)
void | setExtension(java.lang.String extension)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setPk(AllPartDocumentsPK pk)
void | setPublicDoc(boolean publicDoc)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PK

public static final java.lang.String ORDER_BY_PK
See Also:
Constant Field Values

ORDER_BY_LANGUAGE

public static final java.lang.String ORDER_BY_LANGUAGE
See Also:
Constant Field Values

ORDER_BY_DOCUMENTTYPE

public static final java.lang.String ORDER_BY_DOCUMENTTYPE
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEUSER

public static final java.lang.String ORDER_BY_LASTCHANGEUSER
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEDATE

public static final java.lang.String ORDER_BY_LASTCHANGEDATE
See Also:
Constant Field Values
Constructor Detail

AllPartDocumentsVO

public AllPartDocumentsVO(AllPartDocumentsPK pk,
                          java.util.Date lastChangeDate,
                          java.lang.String lastChangeUser,
                          boolean publicDoc,
                          java.lang.String description,
                          java.lang.String comments)
full constructor

AllPartDocumentsVO

public AllPartDocumentsVO()
default constructor

Method Detail

getPk

public AllPartDocumentsPK getPk()

setPk

public void setPk(AllPartDocumentsPK pk)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

isPublicDoc

public boolean isPublicDoc()

setPublicDoc

public void setPublicDoc(boolean publicDoc)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getDocumentLengthByte

public java.lang.Long getDocumentLengthByte()

setDocumentLengthByte

public void setDocumentLengthByte(java.lang.Long documentLengthByte)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AllStatementsListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AllStatementsListResult

java.lang.Object
    extended by  bb.common.AllStatementsListResult
All Implemented Interfaces:
java.io.Serializable
public class AllStatementsListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AllStatementsListResult()
Method Summary
java.math.BigDecimal | getArAmountPaid()
java.math.BigDecimal | getArBalenceDue()
java.lang.String | getArCurrency()
java.math.BigDecimal | getArTotalDue()
java.lang.String | getBillTo()
java.util.Set<CustomerVendorContactVO> | getContacts()
java.lang.String | getCustomerId()
java.lang.String | getCustomerName()
java.lang.String | getCustomerParentId()
java.lang.String | getEmail()
java.util.Set | getEmails()
java.math.BigDecimal | getPrepayAmountPaid()
java.math.BigDecimal | getPrepayApply()
java.math.BigDecimal | getPrepayBalenceDue()
java.lang.String | getPrepayCurrency()
java.math.BigDecimal | getPrepayTotalDue()
void | setArAmountPaid(java.math.BigDecimal arAmountPaid)
void | setArBalenceDue(java.math.BigDecimal arBalenceDue)
void | setArCurrency(java.lang.String arCurrency)
void | setArTotalDue(java.math.BigDecimal arTotalDue)
void | setBillTo(java.lang.String billTo)
void | setContacts(java.util.Set<CustomerVendorContactVO> contacts)
void | setCustomerId(java.lang.String customerId)
void | setCustomerName(java.lang.String customerName)
void | setCustomerParentId(java.lang.String customerParentId)
void | setEmail(java.lang.String email)
void | setEmails(java.util.Set emails)
void | setPrepayAmountPaid(java.math.BigDecimal prepayAmountPaid)
void | setPrepayApply(java.math.BigDecimal prepayApply)
void | setPrepayBalenceDue(java.math.BigDecimal prepayBalenceDue)
void | setPrepayCurrency(java.lang.String prepayCurrency)
void | setPrepayTotalDue(java.math.BigDecimal prepayTotalDue)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AllStatementsListResult

public AllStatementsListResult()
Method Detail

getArAmountPaid

public java.math.BigDecimal getArAmountPaid()

setArAmountPaid

public void setArAmountPaid(java.math.BigDecimal arAmountPaid)

getArBalenceDue

public java.math.BigDecimal getArBalenceDue()

setArBalenceDue

public void setArBalenceDue(java.math.BigDecimal arBalenceDue)

getArTotalDue

public java.math.BigDecimal getArTotalDue()

setArTotalDue

public void setArTotalDue(java.math.BigDecimal arTotalDue)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getCustomerName

public java.lang.String getCustomerName()

setCustomerName

public void setCustomerName(java.lang.String customerName)

getEmail

public java.lang.String getEmail()

setEmail

public void setEmail(java.lang.String email)

getPrepayAmountPaid

public java.math.BigDecimal getPrepayAmountPaid()

setPrepayAmountPaid

public void setPrepayAmountPaid(java.math.BigDecimal prepayAmountPaid)

getPrepayBalenceDue

public java.math.BigDecimal getPrepayBalenceDue()

setPrepayBalenceDue

public void setPrepayBalenceDue(java.math.BigDecimal prepayBalenceDue)

getPrepayTotalDue

public java.math.BigDecimal getPrepayTotalDue()

setPrepayTotalDue

public void setPrepayTotalDue(java.math.BigDecimal prepayTotalDue)

getArCurrency

public java.lang.String getArCurrency()

setArCurrency

public void setArCurrency(java.lang.String arCurrency)

getPrepayCurrency

public java.lang.String getPrepayCurrency()

setPrepayCurrency

public void setPrepayCurrency(java.lang.String prepayCurrency)

getPrepayApply

public java.math.BigDecimal getPrepayApply()

setPrepayApply

public void setPrepayApply(java.math.BigDecimal prepayApply)

getCustomerParentId

public java.lang.String getCustomerParentId()

setCustomerParentId

public void setCustomerParentId(java.lang.String customerParentId)

getContacts

public java.util.Set<CustomerVendorContactVO> getContacts()

setContacts

public void setContacts(java.util.Set<CustomerVendorContactVO> contacts)

getEmails

public java.util.Set getEmails()

setEmails

public void setEmails(java.util.Set emails)

getBillTo

public java.lang.String getBillTo()

setBillTo

public void setBillTo(java.lang.String billTo)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AmountsStatementResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AmountsStatementResult

java.lang.Object
    extended by  bb.common.AmountsStatementResult
All Implemented Interfaces:
java.io.Serializable
public class AmountsStatementResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AmountsStatementResult()
Method Summary
java.lang.String | getAccountNumber()
java.lang.String | getAccountType()
java.lang.String | getDebitOrCredit()
java.lang.String | getDescription()
java.math.BigDecimal | getTotalAmount()
void | setAccountNumber(java.lang.String accountNumber)
void | setAccountType(java.lang.String accountType)
void | setDebitOrCredit(java.lang.String debitOrCredit)
void | setDescription(java.lang.String description)
void | setTotalAmount(java.math.BigDecimal totalAmount)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AmountsStatementResult

public AmountsStatementResult()
Method Detail

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getAccountType

public java.lang.String getAccountType()

setAccountType

public void setAccountType(java.lang.String accountType)

getDebitOrCredit

public java.lang.String getDebitOrCredit()

setDebitOrCredit

public void setDebitOrCredit(java.lang.String debitOrCredit)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getTotalAmount

public java.math.BigDecimal getTotalAmount()

setTotalAmount

public void setTotalAmount(java.math.BigDecimal totalAmount)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


APAgingItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class APAgingItemListResult

java.lang.Object
    extended by  bb.common.APItemListResult
        extended by  bb.common.APAgingItemListResult
All Implemented Interfaces:
java.io.Serializable
public class APAgingItemListResult
extends APItemListResult
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_APNUMBER
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PAYDATE
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_VENDORINVOICEDATE
Fields inherited from class bb.common.APItemListResult
ORDER_BY_APITEMNUMBER, ORDER_BY_COMPANYUNITID, ORDER_BY_DATEPAID, ORDER_BY_DATERECEIVED, ORDER_BY_DEBITACCOUNT, ORDER_BY_OURPONUMBER, ORDER_BY_PARTTYPE, ORDER_BY_PRODUCTCODE, ORDER_BY_VENDORINVOICE
Constructor Summary
APAgingItemListResult()
Method Summary
java.util.Date | getVendorInvoiceDate()
void | setVendorInvoiceDate(java.util.Date vendorInvoiceDate)
Methods inherited from class bb.common.APItemListResult
getApItemNumber, getApNumber, getCompanyUnitId, getCost, getDatePaid, getDateReceived, getDebitAccount, getDescription, getDiscount, getDue, getExtPrice, getOurPoNumber, getPartFrom, getPartNumber, getPartType, getPayDate, getProductCode, getQtyOrdered, getQtyReceived, getReceiverNumber, getStatus, getTaxRate, getTerms, getVendorId, getVendorInvoice, setApItemNumber, setApNumber, setCompanyUnitId, setCost, setDatePaid, setDateReceived, setDebitAccount, setDescription, setDiscount, setDue, setExtPrice, setOurPoNumber, setPartFrom, setPartNumber, setPartType, setPayDate, setProductCode, setQtyOrdered, setQtyReceived, setReceiverNumber, setStatus, setTaxRate, setTerms, setVendorId, setVendorInvoice
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_VENDORINVOICEDATE

public static final java.lang.String ORDER_BY_VENDORINVOICEDATE
See Also:
Constant Field Values

ORDER_BY_PAYDATE

public static final java.lang.String ORDER_BY_PAYDATE
See Also:
Constant Field Values

ORDER_BY_APNUMBER

public static final java.lang.String ORDER_BY_APNUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values
Constructor Detail

APAgingItemListResult

public APAgingItemListResult()
Method Detail

getVendorInvoiceDate

public java.util.Date getVendorInvoiceDate()
Overrides:
getVendorInvoiceDate in class APItemListResult

setVendorInvoiceDate

public void setVendorInvoiceDate(java.util.Date vendorInvoiceDate)
Overrides:
setVendorInvoiceDate in class APItemListResult
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


APAuditListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class APAuditListResult

java.lang.Object
    extended by  bb.common.APAuditListResult
All Implemented Interfaces:
Alarmable, java.io.Serializable
public class APAuditListResult
extends java.lang.Object
implements java.io.Serializable, Alarmable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_APNUMBER
static java.lang.String | ORDER_BY_VENDORID
Constructor Summary
APAuditListResult()
Method Summary
boolean | getAlarmValue()
java.math.BigDecimal | getApDue()
java.math.BigDecimal | getApFreight()
java.math.BigDecimal | getApNet()
java.lang.String | getApNumber()
java.math.BigDecimal | getApPaid()
java.math.BigDecimal | getApTax()
java.math.BigDecimal | getApTotal()
java.math.BigDecimal | getCalcNet()
java.lang.String | getCause()
java.lang.String | getCurrency()
java.math.BigDecimal | getExchange()
java.lang.String | getStatus()
java.math.BigDecimal | getTotalE()
java.math.BigDecimal | getTotalI()
java.util.Date | getTransactionEDate()
java.util.Date | getTransactionIDate()
java.lang.String | getVendorID()
java.math.BigDecimal | getVendorTotal()
boolean | isPaybyVendorInvoiceTotal()
void | setAlarmValue(boolean alarmValue)
void | setApDue(java.math.BigDecimal apDue)
void | setApFreight(java.math.BigDecimal apFreight)
void | setApNet(java.math.BigDecimal apNet)
void | setApNumber(java.lang.String apNumber)
void | setApPaid(java.math.BigDecimal apPaid)
void | setApTax(java.math.BigDecimal apTax)
void | setApTotal(java.math.BigDecimal apTotal)
void | setCalcNet(java.math.BigDecimal calcNet)
void | setCause(java.lang.String cause)
void | setCurrency(java.lang.String currency)
void | setExchange(java.math.BigDecimal exchange)
void | setPaybyVendorInvoiceTotal(boolean paybyVendorInvoiceTotal)
void | setStatus(java.lang.String status)
void | setTotalE(java.math.BigDecimal totalE)
void | setTotalI(java.math.BigDecimal totalI)
void | setTransactionEDate(java.util.Date transactionEDate)
void | setTransactionIDate(java.util.Date transactionIDate)
void | setVendorID(java.lang.String vendorID)
void | setVendorTotal(java.math.BigDecimal vendorTotal)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_APNUMBER

public static final java.lang.String ORDER_BY_APNUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values
Constructor Detail

APAuditListResult

public APAuditListResult()
Method Detail

getAlarmValue

public boolean getAlarmValue()
Specified by:
getAlarmValue in interface Alarmable

getCause

public java.lang.String getCause()
Specified by:
getCause in interface Alarmable

setAlarmValue

public void setAlarmValue(boolean alarmValue)
Specified by:
setAlarmValue in interface Alarmable

setCause

public void setCause(java.lang.String cause)
Specified by:
setCause in interface Alarmable

getTotalE

public java.math.BigDecimal getTotalE()

setTotalE

public void setTotalE(java.math.BigDecimal totalE)

getTotalI

public java.math.BigDecimal getTotalI()

setTotalI

public void setTotalI(java.math.BigDecimal totalI)

getTransactionEDate

public java.util.Date getTransactionEDate()

setTransactionEDate

public void setTransactionEDate(java.util.Date transactionEDate)

getTransactionIDate

public java.util.Date getTransactionIDate()

setTransactionIDate

public void setTransactionIDate(java.util.Date transactionIDate)

getApDue

public java.math.BigDecimal getApDue()

setApDue

public void setApDue(java.math.BigDecimal apDue)

getApFreight

public java.math.BigDecimal getApFreight()

setApFreight

public void setApFreight(java.math.BigDecimal apFreight)

getApNet

public java.math.BigDecimal getApNet()

setApNet

public void setApNet(java.math.BigDecimal apNet)

getApNumber

public java.lang.String getApNumber()

setApNumber

public void setApNumber(java.lang.String apNumber)

getApPaid

public java.math.BigDecimal getApPaid()

setApPaid

public void setApPaid(java.math.BigDecimal apPaid)

getApTax

public java.math.BigDecimal getApTax()

setApTax

public void setApTax(java.math.BigDecimal apTax)

getApTotal

public java.math.BigDecimal getApTotal()

setApTotal

public void setApTotal(java.math.BigDecimal apTotal)

getCalcNet

public java.math.BigDecimal getCalcNet()

setCalcNet

public void setCalcNet(java.math.BigDecimal calcNet)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

isPaybyVendorInvoiceTotal

public boolean isPaybyVendorInvoiceTotal()

setPaybyVendorInvoiceTotal

public void setPaybyVendorInvoiceTotal(boolean paybyVendorInvoiceTotal)

getVendorID

public java.lang.String getVendorID()

setVendorID

public void setVendorID(java.lang.String vendorID)

getVendorTotal

public java.math.BigDecimal getVendorTotal()

setVendorTotal

public void setVendorTotal(java.math.BigDecimal vendorTotal)

getExchange

public java.math.BigDecimal getExchange()

setExchange

public void setExchange(java.math.BigDecimal exchange)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ApCheckRunItemAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ApCheckRunItemAgent

java.lang.Object
    extended by  bb.common.ApCheckRunItemAgent
All Implemented Interfaces:
java.io.Serializable
public class ApCheckRunItemAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ApCheckRunItemAgent()
Method Summary
java.lang.String[] | getApNumber()
java.lang.String | getCurrency()
java.lang.String[] | getExcludeVendorId()
java.util.Date | getFromDate()
java.lang.String[] | getIncludeVendorId()
java.util.Date | getToDate()
void | setApNumber(java.lang.String[] apNumber)
void | setCurrency(java.lang.String currency)
void | setExcludeVendorId(java.lang.String[] excludeVendorId)
void | setFromDate(java.util.Date fromDate)
void | setIncludeVendorId(java.lang.String[] includeVendorId)
void | setToDate(java.util.Date toDate)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ApCheckRunItemAgent

public ApCheckRunItemAgent()
Method Detail

getApNumber

public java.lang.String[] getApNumber()

getToDate

public java.util.Date getToDate()

getFromDate

public java.util.Date getFromDate()

getExcludeVendorId

public java.lang.String[] getExcludeVendorId()

setIncludeVendorId

public void setIncludeVendorId(java.lang.String[] includeVendorId)

setApNumber

public void setApNumber(java.lang.String[] apNumber)

setToDate

public void setToDate(java.util.Date toDate)

setFromDate

public void setFromDate(java.util.Date fromDate)

setExcludeVendorId

public void setExcludeVendorId(java.lang.String[] excludeVendorId)

getIncludeVendorId

public java.lang.String[] getIncludeVendorId()

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ApCheckRunListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ApCheckRunListResult

java.lang.Object
    extended by  bb.common.ApCheckRunListResult
All Implemented Interfaces:
java.io.Serializable
public class ApCheckRunListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AMOUNT
static java.lang.String | ORDER_BY_APNUMBER
static java.lang.String | ORDER_BY_CHECKNUMBER
static java.lang.String | ORDER_BY_CHECKRUNNUMBER
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_DATECHECKRUNPAID
static java.lang.String | ORDER_BY_PAYDATE
static java.lang.String | ORDER_BY_PONUMBER
static java.lang.String | ORDER_BY_TRANSACTIONNUMBER
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_VENDORNAME
Constructor Summary
ApCheckRunListResult()
Method Summary
java.math.BigDecimal | getAmount()
java.lang.String | getApNumber()
java.lang.String | getCheckNumber()
java.lang.String | getCheckRunNumber()
java.lang.String | getCurrency()
java.util.Date | getDateCheckPaid()
java.util.Date | getDateCheckRunPaid()
java.util.Date | getPayDate()
java.lang.String | getPoNumber()
java.lang.String | getTransactionNumber()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
void | setAmount(java.math.BigDecimal amount)
void | setApNumber(java.lang.String apNumber)
void | setCheckNumber(java.lang.String checkNumber)
void | setCheckRunNumber(java.lang.String checkRunNumber)
void | setCurrency(java.lang.String currency)
void | setDateCheckPaid(java.util.Date dateCheckPaid)
void | setDateCheckRunPaid(java.util.Date dateCheckRunPaid)
void | setPayDate(java.util.Date payDate)
void | setPoNumber(java.lang.String poNumber)
void | setTransactionNumber(java.lang.String transactionNumber)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_CHECKRUNNUMBER

public static final java.lang.String ORDER_BY_CHECKRUNNUMBER
See Also:
Constant Field Values

ORDER_BY_CHECKNUMBER

public static final java.lang.String ORDER_BY_CHECKNUMBER
See Also:
Constant Field Values

ORDER_BY_TRANSACTIONNUMBER

public static final java.lang.String ORDER_BY_TRANSACTIONNUMBER
See Also:
Constant Field Values

ORDER_BY_PAYDATE

public static final java.lang.String ORDER_BY_PAYDATE
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_VENDORNAME

public static final java.lang.String ORDER_BY_VENDORNAME
See Also:
Constant Field Values

ORDER_BY_APNUMBER

public static final java.lang.String ORDER_BY_APNUMBER
See Also:
Constant Field Values

ORDER_BY_PONUMBER

public static final java.lang.String ORDER_BY_PONUMBER
See Also:
Constant Field Values

ORDER_BY_DATECHECKRUNPAID

public static final java.lang.String ORDER_BY_DATECHECKRUNPAID
See Also:
Constant Field Values

ORDER_BY_AMOUNT

public static final java.lang.String ORDER_BY_AMOUNT
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values
Constructor Detail

ApCheckRunListResult

public ApCheckRunListResult()
Method Detail

getPoNumber

public java.lang.String getPoNumber()

getTransactionNumber

public java.lang.String getTransactionNumber()

getCurrency

public java.lang.String getCurrency()

getCheckNumber

public java.lang.String getCheckNumber()

getPayDate

public java.util.Date getPayDate()

getVendorId

public java.lang.String getVendorId()

getApNumber

public java.lang.String getApNumber()

getCheckRunNumber

public java.lang.String getCheckRunNumber()

getAmount

public java.math.BigDecimal getAmount()

setVendorName

public void setVendorName(java.lang.String vendorName)

setPoNumber

public void setPoNumber(java.lang.String poNumber)

setTransactionNumber

public void setTransactionNumber(java.lang.String transactionNumber)

setCurrency

public void setCurrency(java.lang.String currency)

setCheckNumber

public void setCheckNumber(java.lang.String checkNumber)

setPayDate

public void setPayDate(java.util.Date payDate)

setVendorId

public void setVendorId(java.lang.String vendorId)

setApNumber

public void setApNumber(java.lang.String apNumber)

setCheckRunNumber

public void setCheckRunNumber(java.lang.String checkRunNumber)

setAmount

public void setAmount(java.math.BigDecimal amount)

getVendorName

public java.lang.String getVendorName()

getDateCheckPaid

public java.util.Date getDateCheckPaid()

setDateCheckPaid

public void setDateCheckPaid(java.util.Date dateCheckPaid)

getDateCheckRunPaid

public java.util.Date getDateCheckRunPaid()

setDateCheckRunPaid

public void setDateCheckRunPaid(java.util.Date dateCheckRunPaid)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


API Help

PREV NEXT FRAMES NO FRAMES

How This API Document Is Organized

This API (Application Programming Interface) document has pages corresponding to the items in the navigation bar, described as follows.

Overview

The Overview page is the front page of this API document and provides a list of all packages with a summary for each. This page can also contain an overall description of the set of packages.

Package

Each package has a page that contains a list of its classes and interfaces, with a summary for each. This page can contain four categories:

  • Interfaces (italic)
  • Classes
  • Enums
  • Exceptions
  • Errors
  • Annotation Types

Class/Interface

Each class, interface, nested class and nested interface has its own separate page. Each of these pages has three sections consisting of a class/interface description, summary tables, and detailed member descriptions:

  • Class inheritance diagram
  • Direct Subclasses
  • All Known Subinterfaces
  • All Known Implementing Classes
  • Class/interface declaration
  • Class/interface description

  • Nested Class Summary
  • Field Summary
  • Constructor Summary
  • Method Summary

  • Field Detail
  • Constructor Detail
  • Method Detail
Each summary entry contains the first sentence from the detailed description for that item. The summary entries are alphabetical, while the detailed descriptions are in the order they appear in the source code. This preserves the logical groupings established by the programmer.

Annotation Type

Each annotation type has its own separate page with the following sections:

  • Annotation Type declaration
  • Annotation Type description
  • Required Element Summary
  • Optional Element Summary
  • Element Detail

Enum

Each enum has its own separate page with the following sections:

  • Enum declaration
  • Enum description
  • Enum Constant Summary
  • Enum Constant Detail

Use

Each documented package, class and interface has its own Use page. This page describes what packages, classes, methods, constructors and fields use any part of the given class or package. Given a class or interface A, its Use page includes subclasses of A, fields declared as A, methods that return A, and methods and constructors with parameters of type A. You can access this page by first going to the package, class or interface, then clicking on the "Use" link in the navigation bar.

Tree (Class Hierarchy)

There is a Class Hierarchy page for all packages, plus a hierarchy for each package. Each hierarchy page contains a list of classes and a list of interfaces. The classes are organized by inheritance structure starting with java.lang.Object. The interfaces do not inherit from java.lang.Object.
  • When viewing the Overview page, clicking on "Tree" displays the hierarchy for all packages.
  • When viewing a particular package, class or interface page, clicking "Tree" displays the hierarchy for only that package.

Deprecated API

The Deprecated API page lists all of the API that have been deprecated. A deprecated API is not recommended for use, generally due to improvements, and a replacement API is usually given. Deprecated APIs may be removed in future implementations.

Index

The Index contains an alphabetic list of all classes, interfaces, constructors, methods, and fields.

Prev/Next

These links take you to the next or previous class, interface, package, or related page.

Frames/No Frames

These links show and hide the HTML frames. All pages are available with or without frames.

Serialized Form

Each serializable or externalizable class has a description of its serialization fields and methods. This information is of interest to re-implementors, not to developers using the API. While there is no link in the navigation bar, you can get to this information by going to any serialized class and clicking "Serialized Form" in the "See also" section of the class description.

Constant Field Values

The Constant Field Values page lists the static final fields and their values.

This help file applies to API documentation generated using the standard doclet.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


APItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class APItemListResult

java.lang.Object
    extended by  bb.common.APItemListResult
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
APAgingItemListResult
public class APItemListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_APITEMNUMBER
static java.lang.String | ORDER_BY_APNUMBER
static java.lang.String | ORDER_BY_COMPANYUNITID
static java.lang.String | ORDER_BY_DATEPAID
static java.lang.String | ORDER_BY_DATERECEIVED
static java.lang.String | ORDER_BY_DEBITACCOUNT
static java.lang.String | ORDER_BY_OURPONUMBER
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_PAYDATE
static java.lang.String | ORDER_BY_PRODUCTCODE
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_VENDORINVOICE
static java.lang.String | ORDER_BY_VENDORINVOICEDATE
Constructor Summary
APItemListResult()
Method Summary
java.lang.String | getApItemNumber()
java.lang.String | getApNumber()
java.lang.String | getCompanyUnitId()
java.math.BigDecimal | getCost()
java.util.Date | getDatePaid()
java.util.Date | getDateReceived()
java.lang.String | getDebitAccount()
java.lang.String | getDescription()
java.math.BigDecimal | getDiscount()
java.math.BigDecimal | getDue()
java.math.BigDecimal | getExtPrice()
java.lang.String | getOurPoNumber()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.util.Date | getPayDate()
java.lang.String | getProductCode()
java.math.BigDecimal | getQtyOrdered()
java.math.BigDecimal | getQtyReceived()
java.lang.String | getReceiverNumber()
java.lang.String | getStatus()
java.math.BigDecimal | getTaxRate()
java.lang.String | getTerms()
java.lang.String | getVendorId()
java.lang.String | getVendorInvoice()
java.util.Date | getVendorInvoiceDate()
void | setApItemNumber(java.lang.String apItemNumber)
void | setApNumber(java.lang.String apNumber)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCost(java.math.BigDecimal cost)
void | setDatePaid(java.util.Date datePaid)
void | setDateReceived(java.util.Date dateReceived)
void | setDebitAccount(java.lang.String debitAccount)
void | setDescription(java.lang.String description)
void | setDiscount(java.math.BigDecimal discount)
void | setDue(java.math.BigDecimal due)
void | setExtPrice(java.math.BigDecimal extPrice)
void | setOurPoNumber(java.lang.String ourPoNumber)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPayDate(java.util.Date payDate)
void | setProductCode(java.lang.String productCode)
void | setQtyOrdered(java.math.BigDecimal qtyOrdered)
void | setQtyReceived(java.math.BigDecimal qtyReceived)
void | setReceiverNumber(java.lang.String receiverNumber)
void | setStatus(java.lang.String status)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setTerms(java.lang.String terms)
void | setVendorId(java.lang.String vendorId)
void | setVendorInvoice(java.lang.String vendorInvoice)
void | setVendorInvoiceDate(java.util.Date vendorInvoiceDate)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_DATERECEIVED

public static final java.lang.String ORDER_BY_DATERECEIVED
See Also:
Constant Field Values

ORDER_BY_VENDORINVOICEDATE

public static final java.lang.String ORDER_BY_VENDORINVOICEDATE
See Also:
Constant Field Values

ORDER_BY_PAYDATE

public static final java.lang.String ORDER_BY_PAYDATE
See Also:
Constant Field Values

ORDER_BY_APNUMBER

public static final java.lang.String ORDER_BY_APNUMBER
See Also:
Constant Field Values

ORDER_BY_APITEMNUMBER

public static final java.lang.String ORDER_BY_APITEMNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_OURPONUMBER

public static final java.lang.String ORDER_BY_OURPONUMBER
See Also:
Constant Field Values

ORDER_BY_DEBITACCOUNT

public static final java.lang.String ORDER_BY_DEBITACCOUNT
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_VENDORINVOICE

public static final java.lang.String ORDER_BY_VENDORINVOICE
See Also:
Constant Field Values

ORDER_BY_DATEPAID

public static final java.lang.String ORDER_BY_DATEPAID
See Also:
Constant Field Values

ORDER_BY_COMPANYUNITID

public static final java.lang.String ORDER_BY_COMPANYUNITID
See Also:
Constant Field Values

ORDER_BY_PRODUCTCODE

public static final java.lang.String ORDER_BY_PRODUCTCODE
See Also:
Constant Field Values
Constructor Detail

APItemListResult

public APItemListResult()
Method Detail

getStatus

public java.lang.String getStatus()

getExtPrice

public java.math.BigDecimal getExtPrice()

getTaxRate

public java.math.BigDecimal getTaxRate()

getQtyOrdered

public java.math.BigDecimal getQtyOrdered()

getDescription

public java.lang.String getDescription()

getPartFrom

public java.lang.String getPartFrom()

getPartType

public java.lang.String getPartType()

getPartNumber

public java.lang.String getPartNumber()

getPayDate

public java.util.Date getPayDate()

getQtyReceived

public java.math.BigDecimal getQtyReceived()

getApNumber

public java.lang.String getApNumber()

getDebitAccount

public java.lang.String getDebitAccount()

getVendorId

public java.lang.String getVendorId()

getApItemNumber

public java.lang.String getApItemNumber()

getCost

public java.math.BigDecimal getCost()

getOurPoNumber

public java.lang.String getOurPoNumber()

getDateReceived

public java.util.Date getDateReceived()

getDue

public java.math.BigDecimal getDue()

setStatus

public void setStatus(java.lang.String status)

setExtPrice

public void setExtPrice(java.math.BigDecimal extPrice)

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

setQtyOrdered

public void setQtyOrdered(java.math.BigDecimal qtyOrdered)

setDescription

public void setDescription(java.lang.String description)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setPartType

public void setPartType(java.lang.String partType)

setPartNumber

public void setPartNumber(java.lang.String partNumber)

setPayDate

public void setPayDate(java.util.Date payDate)

setQtyReceived

public void setQtyReceived(java.math.BigDecimal qtyReceived)

setApNumber

public void setApNumber(java.lang.String apNumber)

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

setVendorId

public void setVendorId(java.lang.String vendorId)

setApItemNumber

public void setApItemNumber(java.lang.String apItemNumber)

setCost

public void setCost(java.math.BigDecimal cost)

setOurPoNumber

public void setOurPoNumber(java.lang.String ourPoNumber)

setDateReceived

public void setDateReceived(java.util.Date dateReceived)

setDue

public void setDue(java.math.BigDecimal due)

getVendorInvoice

public java.lang.String getVendorInvoice()

setVendorInvoice

public void setVendorInvoice(java.lang.String vendorInvoice)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getVendorInvoiceDate

public java.util.Date getVendorInvoiceDate()

setVendorInvoiceDate

public void setVendorInvoiceDate(java.util.Date vendorInvoiceDate)

getDatePaid

public java.util.Date getDatePaid()

setDatePaid

public void setDatePaid(java.util.Date datePaid)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getProductCode

public java.lang.String getProductCode()

setProductCode

public void setProductCode(java.lang.String productCode)

getReceiverNumber

public java.lang.String getReceiverNumber()

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AppColumnVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AppColumnVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AppColumnVO
All Implemented Interfaces:
java.io.Serializable
public class AppColumnVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AppColumnVO()
AppColumnVO(java.lang.String name, java.lang.String type)
Method Summary
java.lang.String | getDisplayName()
java.lang.String | getFormula()
java.lang.String | getName()
java.lang.String | getPoClass()
java.lang.String | getTableName()
java.lang.String | getType()
boolean | isEditable()
void | setDisplayName(java.lang.String displayName)
void | setEditable(boolean editable)
void | setFormula(java.lang.String formula)
void | setName(java.lang.String name)
void | setPoClass(java.lang.String poClass)
void | setTableName(java.lang.String tableName)
void | setType(java.lang.String type)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AppColumnVO

public AppColumnVO()

AppColumnVO

public AppColumnVO(java.lang.String name,
                   java.lang.String type)
Method Detail

isEditable

public boolean isEditable()

setEditable

public void setEditable(boolean editable)

getFormula

public java.lang.String getFormula()

setFormula

public void setFormula(java.lang.String formula)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getType

public java.lang.String getType()

setType

public void setType(java.lang.String type)

getDisplayName

public java.lang.String getDisplayName()

setDisplayName

public void setDisplayName(java.lang.String displayName)

getPoClass

public java.lang.String getPoClass()

setPoClass

public void setPoClass(java.lang.String poClass)

getTableName

public java.lang.String getTableName()

setTableName

public void setTableName(java.lang.String tableName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AppException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AppException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  bb.common.BB2ServerException
                extended by  bb.common.AppException
All Implemented Interfaces:
java.io.Serializable
public class AppException
extends BB2ServerException

See Also:
Serialized Form

Field Summary
Fields inherited from class bb.common.BB2ServerException
UNKNOWN_EXCEPTION
Constructor Summary
AppException(java.lang.Exception e)
AppException(java.lang.String message)
Method Summary
Methods inherited from class bb.common.BB2ServerException
getParameter, getReason, setParameter
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

AppException

public AppException(java.lang.Exception e)

AppException

public AppException(java.lang.String message)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


APPrepayInfoResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class APPrepayInfoResult

java.lang.Object
    extended by  bb.common.APPrepayInfoResult
All Implemented Interfaces:
java.io.Serializable
public class APPrepayInfoResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
APPrepayInfoResult()
Method Summary
java.math.BigDecimal | getAppiPrepay()
java.math.BigDecimal | getAppiPrepayDue()
java.math.BigDecimal | getAppiPrepayGl()
java.lang.String | getCompanyUnitId()
java.util.Date | getPayDate()
ApPrepayItemPK | getPk()
java.lang.String | getPoNumber()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
void | setAppiPrepay(java.math.BigDecimal appiPrepay)
void | setAppiPrepayDue(java.math.BigDecimal appiPrepayDue)
void | setAppiPrepayGl(java.math.BigDecimal appiPrepayGl)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setPayDate(java.util.Date payDate)
void | setPk(ApPrepayItemPK pk)
void | setPoNumber(java.lang.String poNumber)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

APPrepayInfoResult

public APPrepayInfoResult()
Method Detail

getAppiPrepay

public java.math.BigDecimal getAppiPrepay()

setAppiPrepay

public void setAppiPrepay(java.math.BigDecimal appiPrepay)

getAppiPrepayDue

public java.math.BigDecimal getAppiPrepayDue()

setAppiPrepayDue

public void setAppiPrepayDue(java.math.BigDecimal appiPrepayDue)

getAppiPrepayGl

public java.math.BigDecimal getAppiPrepayGl()

setAppiPrepayGl

public void setAppiPrepayGl(java.math.BigDecimal appiPrepayGl)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getPayDate

public java.util.Date getPayDate()

setPayDate

public void setPayDate(java.util.Date payDate)

getPk

public ApPrepayItemPK getPk()

setPk

public void setPk(ApPrepayItemPK pk)

getPoNumber

public java.lang.String getPoNumber()

setPoNumber

public void setPoNumber(java.lang.String poNumber)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getVendorName

public java.lang.String getVendorName()

setVendorName

public void setVendorName(java.lang.String vendorName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ApPrepayItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ApPrepayItemPK

java.lang.Object
    extended by  bb.common.ApPrepayItemPK
All Implemented Interfaces:
java.io.Serializable
public class ApPrepayItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ApPrepayItemPK()
ApPrepayItemPK(java.lang.String apPrepayNumber, java.lang.String apPrepayItemNumber)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getApPrepayItemNumber()
java.lang.String | getApPrepayNumber()
int | hashCode()
void | setApPrepayItemNumber(java.lang.String apPrepayItemNumber)
void | setApPrepayNumber(java.lang.String apPrepayNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ApPrepayItemPK

public ApPrepayItemPK(java.lang.String apPrepayNumber,
                      java.lang.String apPrepayItemNumber)

ApPrepayItemPK

public ApPrepayItemPK()
Method Detail

getApPrepayItemNumber

public java.lang.String getApPrepayItemNumber()

setApPrepayItemNumber

public void setApPrepayItemNumber(java.lang.String apPrepayItemNumber)

getApPrepayNumber

public java.lang.String getApPrepayNumber()

setApPrepayNumber

public void setApPrepayNumber(java.lang.String apPrepayNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ApPrepayItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ApPrepayItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ApPrepayItemVO
All Implemented Interfaces:
java.io.Serializable
public class ApPrepayItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ApPrepayItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getAppiPrepay()
java.math.BigDecimal | getAppiPrepayDue()
java.math.BigDecimal | getAppiPrepayGl()
java.lang.String | getComments()
java.util.Date | getDateRequired()
ApPrepayItemPK | getPk()
java.lang.String | getPoNumber()
java.lang.String | getStatus()
int | hashCode()
void | setAppiPrepay(java.math.BigDecimal appiPrepay)
void | setAppiPrepayDue(java.math.BigDecimal appiPrepayDue)
void | setAppiPrepayGl(java.math.BigDecimal appiPrepayGl)
void | setComments(java.lang.String comments)
void | setDateRequired(java.util.Date dateRequired)
void | setPk(ApPrepayItemPK pk)
void | setPoNumber(java.lang.String poNumber)
void | setStatus(java.lang.String status)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ApPrepayItemVO

public ApPrepayItemVO()
Method Detail

getAppiPrepay

public java.math.BigDecimal getAppiPrepay()

setAppiPrepay

public void setAppiPrepay(java.math.BigDecimal appiPrepay)

getAppiPrepayDue

public java.math.BigDecimal getAppiPrepayDue()

setAppiPrepayDue

public void setAppiPrepayDue(java.math.BigDecimal appiPrepayDue)

getAppiPrepayGl

public java.math.BigDecimal getAppiPrepayGl()

setAppiPrepayGl

public void setAppiPrepayGl(java.math.BigDecimal appiPrepayGl)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getDateRequired

public java.util.Date getDateRequired()

setDateRequired

public void setDateRequired(java.util.Date dateRequired)

getPk

public ApPrepayItemPK getPk()

setPk

public void setPk(ApPrepayItemPK pk)

getPoNumber

public java.lang.String getPoNumber()

setPoNumber

public void setPoNumber(java.lang.String poNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ApPrepaymentCheckRunItemAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ApPrepaymentCheckRunItemAgent

java.lang.Object
    extended by  bb.common.ApPrepaymentCheckRunItemAgent
All Implemented Interfaces:
java.io.Serializable
public class ApPrepaymentCheckRunItemAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ApPrepaymentCheckRunItemAgent()
Method Summary
ApPrepayItemPK[] | getAppiPk()
java.lang.String[] | getExcludeVendorId()
java.util.Date | getFromDate()
java.lang.String[] | getIncludeVendorId()
java.util.Date | getToDate()
void | setAppiPk(ApPrepayItemPK[] appiPk)
void | setExcludeVendorId(java.lang.String[] excludeVendorId)
void | setFromDate(java.util.Date fromDate)
void | setIncludeVendorId(java.lang.String[] includeVendorId)
void | setToDate(java.util.Date toDate)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ApPrepaymentCheckRunItemAgent

public ApPrepaymentCheckRunItemAgent()
Method Detail

getAppiPk

public ApPrepayItemPK[] getAppiPk()

setAppiPk

public void setAppiPk(ApPrepayItemPK[] appiPk)

getExcludeVendorId

public java.lang.String[] getExcludeVendorId()

setExcludeVendorId

public void setExcludeVendorId(java.lang.String[] excludeVendorId)

getFromDate

public java.util.Date getFromDate()

setFromDate

public void setFromDate(java.util.Date fromDate)

getIncludeVendorId

public java.lang.String[] getIncludeVendorId()

setIncludeVendorId

public void setIncludeVendorId(java.lang.String[] includeVendorId)

getToDate

public java.util.Date getToDate()

setToDate

public void setToDate(java.util.Date toDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ApPrepayVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ApPrepayVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ApPrepayVO
All Implemented Interfaces:
java.io.Serializable
public class ApPrepayVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_APPDATE
static java.lang.String | ORDER_BY_APPREPAYNUMBER
static java.lang.String | ORDER_BY_COMPANYUNITID
static java.lang.String | ORDER_BY_PONUMBER
static java.lang.String | ORDER_BY_VENDORID
Constructor Summary
ApPrepayVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAppDate()
java.math.BigDecimal | getApPrepay()
java.math.BigDecimal | getApPrepayApply()
java.math.BigDecimal | getApPrepayDue()
java.math.BigDecimal | getApPrepayGl()
java.util.Set<ApPrepayItemVO> | getApPrepayItem()
java.lang.String | getApPrepayNumber()
java.lang.String | getCheck()
java.lang.String | getCompanyUnitId()
java.lang.String | getCurrency()
java.math.BigDecimal | getExchange()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.math.BigDecimal | getPoTotal()
java.lang.String | getPurchaseOrderNumber()
java.lang.String | getRequester()
java.lang.String | getStatus()
CustomerVendorAddressInfoVO | getVendorAddressInfo()
java.lang.String | getVendorId()
java.lang.String | getVendorInvoice()
java.math.BigDecimal | getVendorInvoiceTotal()
java.lang.String | getVendorSO()
int | hashCode()
void | setAppDate(java.util.Date appDate)
void | setApPrepay(java.math.BigDecimal apPrepay)
void | setApPrepayApply(java.math.BigDecimal apPrepayApply)
void | setApPrepayDue(java.math.BigDecimal apPrepayDue)
void | setApPrepayGl(java.math.BigDecimal apPrepayGl)
void | setApPrepayItem(java.util.Set<ApPrepayItemVO> apPrepayItem)
void | setApPrepayNumber(java.lang.String apPrepayNumber)
void | setCheck(java.lang.String check)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCurrency(java.lang.String currency)
void | setExchange(java.math.BigDecimal exchange)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setPoTotal(java.math.BigDecimal poTotal)
void | setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)
void | setRequester(java.lang.String requester)
void | setStatus(java.lang.String status)
void | setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)
void | setVendorId(java.lang.String vendorId)
void | setVendorInvoice(java.lang.String vendorInvoice)
void | setVendorInvoiceTotal(java.math.BigDecimal vendorInvoiceTotal)
void | setVendorSO(java.lang.String vendorSO)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_APPREPAYNUMBER

public static final java.lang.String ORDER_BY_APPREPAYNUMBER
See Also:
Constant Field Values

ORDER_BY_PONUMBER

public static final java.lang.String ORDER_BY_PONUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_APPDATE

public static final java.lang.String ORDER_BY_APPDATE
See Also:
Constant Field Values

ORDER_BY_COMPANYUNITID

public static final java.lang.String ORDER_BY_COMPANYUNITID
See Also:
Constant Field Values
Constructor Detail

ApPrepayVO

public ApPrepayVO()
Method Detail

getAppDate

public java.util.Date getAppDate()

setAppDate

public void setAppDate(java.util.Date appDate)

getApPrepay

public java.math.BigDecimal getApPrepay()

setApPrepay

public void setApPrepay(java.math.BigDecimal apPrepay)

getApPrepayDue

public java.math.BigDecimal getApPrepayDue()

setApPrepayDue

public void setApPrepayDue(java.math.BigDecimal apPrepayDue)

getApPrepayGl

public java.math.BigDecimal getApPrepayGl()

setApPrepayGl

public void setApPrepayGl(java.math.BigDecimal apPrepayGl)

getApPrepayNumber

public java.lang.String getApPrepayNumber()

setApPrepayNumber

public void setApPrepayNumber(java.lang.String apPrepayNumber)

getCheck

public java.lang.String getCheck()

setCheck

public void setCheck(java.lang.String check)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getExchange

public java.math.BigDecimal getExchange()

setExchange

public void setExchange(java.math.BigDecimal exchange)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getPoTotal

public java.math.BigDecimal getPoTotal()

setPoTotal

public void setPoTotal(java.math.BigDecimal poTotal)

getPurchaseOrderNumber

public java.lang.String getPurchaseOrderNumber()

setPurchaseOrderNumber

public void setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)

getRequester

public java.lang.String getRequester()

setRequester

public void setRequester(java.lang.String requester)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getVendorAddressInfo

public CustomerVendorAddressInfoVO getVendorAddressInfo()

setVendorAddressInfo

public void setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getVendorInvoice

public java.lang.String getVendorInvoice()

setVendorInvoice

public void setVendorInvoice(java.lang.String vendorInvoice)

getVendorInvoiceTotal

public java.math.BigDecimal getVendorInvoiceTotal()

setVendorInvoiceTotal

public void setVendorInvoiceTotal(java.math.BigDecimal vendorInvoiceTotal)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getApPrepayItem

public java.util.Set<ApPrepayItemVO> getApPrepayItem()

setApPrepayItem

public void setApPrepayItem(java.util.Set<ApPrepayItemVO> apPrepayItem)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getVendorSO

public java.lang.String getVendorSO()

setVendorSO

public void setVendorSO(java.lang.String vendorSO)

getApPrepayApply

public java.math.BigDecimal getApPrepayApply()

setApPrepayApply

public void setApPrepayApply(java.math.BigDecimal apPrepayApply)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ApprovedGLResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ApprovedGLResult

java.lang.Object
    extended by  bb.common.ApprovedGLResult
All Implemented Interfaces:
java.io.Serializable
public class ApprovedGLResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ApprovedGLResult()
Method Summary
java.util.List<java.lang.String> | getApprovedErrorList()
java.util.List<java.lang.String> | getApprovedGLList()
int | getApproveSuccessGL()
java.util.List<java.lang.String> | getApproveSuccessGLList()
int | getErrorGL()
java.util.List<java.lang.String> | getErrorGLList()
java.util.List<java.lang.String> | getOverdueList()
int | getTotalGL()
void | setApprovedErrorList(java.util.List<java.lang.String> approvedErrorList)
void | setApprovedGLList(java.util.List<java.lang.String> approvedGLList)
void | setApproveSuccessGL(int approveSuccessGL)
void | setApproveSuccessGLList(java.util.List<java.lang.String> approveSuccessGLList)
void | setErrorGL(int errorGL)
void | setErrorGLList(java.util.List<java.lang.String> errorGLList)
void | setOverdueList(java.util.List<java.lang.String> overdueList)
void | setTotalGL(int totalGL)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ApprovedGLResult

public ApprovedGLResult()
Method Detail

getApprovedErrorList

public java.util.List<java.lang.String> getApprovedErrorList()

setApprovedErrorList

public void setApprovedErrorList(java.util.List<java.lang.String> approvedErrorList)

getApprovedGLList

public java.util.List<java.lang.String> getApprovedGLList()

setApprovedGLList

public void setApprovedGLList(java.util.List<java.lang.String> approvedGLList)

getApproveSuccessGL

public int getApproveSuccessGL()

setApproveSuccessGL

public void setApproveSuccessGL(int approveSuccessGL)

getApproveSuccessGLList

public java.util.List<java.lang.String> getApproveSuccessGLList()

setApproveSuccessGLList

public void setApproveSuccessGLList(java.util.List<java.lang.String> approveSuccessGLList)

getErrorGL

public int getErrorGL()

setErrorGL

public void setErrorGL(int errorGL)

getErrorGLList

public java.util.List<java.lang.String> getErrorGLList()

setErrorGLList

public void setErrorGLList(java.util.List<java.lang.String> errorGLList)

getTotalGL

public int getTotalGL()

setTotalGL

public void setTotalGL(int totalGL)

getOverdueList

public java.util.List<java.lang.String> getOverdueList()

setOverdueList

public void setOverdueList(java.util.List<java.lang.String> overdueList)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


APTaxForZipcodeListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class APTaxForZipcodeListResult

java.lang.Object
    extended by  bb.common.APTaxForZipcodeListResult
All Implemented Interfaces:
java.io.Serializable
public class APTaxForZipcodeListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_VENDORNAME
static java.lang.String | ORDER_BY_ZIPCODE
Constructor Summary
APTaxForZipcodeListResult()
Method Summary
int | getAcount()
java.lang.String | getCurrency()
java.math.BigDecimal | getTotaltax()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
java.lang.String | getZipcode()
void | setAcount(int acount)
void | setCurrency(java.lang.String currency)
void | setTotaltax(java.math.BigDecimal totaltax)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
void | setZipcode(java.lang.String zipcode)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_VENDORNAME

public static final java.lang.String ORDER_BY_VENDORNAME
See Also:
Constant Field Values

ORDER_BY_ZIPCODE

public static final java.lang.String ORDER_BY_ZIPCODE
See Also:
Constant Field Values
Constructor Detail

APTaxForZipcodeListResult

public APTaxForZipcodeListResult()
Method Detail

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getAcount

public int getAcount()

setAcount

public void setAcount(int acount)

getTotaltax

public java.math.BigDecimal getTotaltax()

setTotaltax

public void setTotaltax(java.math.BigDecimal totaltax)

getZipcode

public java.lang.String getZipcode()

setZipcode

public void setZipcode(java.lang.String zipcode)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getVendorName

public java.lang.String getVendorName()

setVendorName

public void setVendorName(java.lang.String vendorName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ARAllStatementsListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ARAllStatementsListResult

java.lang.Object
    extended by  bb.common.ARAllStatementsListResult
All Implemented Interfaces:
java.io.Serializable
public class ARAllStatementsListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_CUSTOMERNAME
Constructor Summary
ARAllStatementsListResult()
Method Summary
java.math.BigDecimal | getAmountPaid()
java.math.BigDecimal | getBalenceDue()
java.lang.String | getCurrency()
java.lang.String | getCustomerId()
java.lang.String | getCustomerName()
java.lang.String | getEmail()
java.math.BigDecimal | getTotalDue()
void | setAmountPaid(java.math.BigDecimal amountPaid)
void | setBalenceDue(java.math.BigDecimal balenceDue)
void | setCurrency(java.lang.String currency)
void | setCustomerId(java.lang.String customerId)
void | setCustomerName(java.lang.String customerName)
void | setEmail(java.lang.String email)
void | setTotalDue(java.math.BigDecimal totalDue)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_CUSTOMERNAME

public static final java.lang.String ORDER_BY_CUSTOMERNAME
See Also:
Constant Field Values
Constructor Detail

ARAllStatementsListResult

public ARAllStatementsListResult()
Method Detail

getCurrency

public java.lang.String getCurrency()

getBalenceDue

public java.math.BigDecimal getBalenceDue()

getAmountPaid

public java.math.BigDecimal getAmountPaid()

getTotalDue

public java.math.BigDecimal getTotalDue()

getCustomerName

public java.lang.String getCustomerName()

setCustomerId

public void setCustomerId(java.lang.String customerId)

setCurrency

public void setCurrency(java.lang.String currency)

setBalenceDue

public void setBalenceDue(java.math.BigDecimal balenceDue)

setAmountPaid

public void setAmountPaid(java.math.BigDecimal amountPaid)

setTotalDue

public void setTotalDue(java.math.BigDecimal totalDue)

setCustomerName

public void setCustomerName(java.lang.String customerName)

getCustomerId

public java.lang.String getCustomerId()

getEmail

public java.lang.String getEmail()

setEmail

public void setEmail(java.lang.String email)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ARAuditListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ARAuditListResult

java.lang.Object
    extended by  bb.common.ARAuditListResult
All Implemented Interfaces:
Alarmable, java.io.Serializable
public class ARAuditListResult
extends java.lang.Object
implements java.io.Serializable, Alarmable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ARNUMBER
static java.lang.String | ORDER_BY_CUSTID
Constructor Summary
ARAuditListResult()
Method Summary
boolean | getAlarmValue()
java.math.BigDecimal | getArDue()
java.math.BigDecimal | getArFreight()
java.math.BigDecimal | getArNet()
java.lang.String | getArNumber()
java.math.BigDecimal | getArPaid()
java.math.BigDecimal | getArTax()
java.math.BigDecimal | getArTotal()
java.math.BigDecimal | getCalcNet()
java.lang.String | getCause()
java.lang.String | getCurrency()
java.lang.String | getCustID()
java.math.BigDecimal | getExchange()
java.lang.String | getStatus()
java.math.BigDecimal | getTotalO()
java.math.BigDecimal | getTotalR()
java.util.Date | getTransactionODate()
java.util.Date | getTransactionRDate()
void | setAlarmValue(boolean alarmValue)
void | setArDue(java.math.BigDecimal arDue)
void | setArFreight(java.math.BigDecimal arFreight)
void | setArNet(java.math.BigDecimal arNet)
void | setArNumber(java.lang.String arNumber)
void | setArPaid(java.math.BigDecimal arPaid)
void | setArTax(java.math.BigDecimal arTax)
void | setArTotal(java.math.BigDecimal arTotal)
void | setCalcNet(java.math.BigDecimal calcNet)
void | setCause(java.lang.String cause)
void | setCurrency(java.lang.String currency)
void | setCustID(java.lang.String custID)
void | setExchange(java.math.BigDecimal exchange)
void | setStatus(java.lang.String status)
void | setTotalO(java.math.BigDecimal totalO)
void | setTotalR(java.math.BigDecimal totalR)
void | setTransactionODate(java.util.Date transactionODate)
void | setTransactionRDate(java.util.Date transactionRDate)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_ARNUMBER

public static final java.lang.String ORDER_BY_ARNUMBER
See Also:
Constant Field Values

ORDER_BY_CUSTID

public static final java.lang.String ORDER_BY_CUSTID
See Also:
Constant Field Values
Constructor Detail

ARAuditListResult

public ARAuditListResult()
Method Detail

getAlarmValue

public boolean getAlarmValue()
Specified by:
getAlarmValue in interface Alarmable

getCause

public java.lang.String getCause()
Specified by:
getCause in interface Alarmable

setAlarmValue

public void setAlarmValue(boolean alarmValue)
Specified by:
setAlarmValue in interface Alarmable

setCause

public void setCause(java.lang.String cause)
Specified by:
setCause in interface Alarmable

getArDue

public java.math.BigDecimal getArDue()

setArDue

public void setArDue(java.math.BigDecimal arDue)

getArFreight

public java.math.BigDecimal getArFreight()

setArFreight

public void setArFreight(java.math.BigDecimal arFreight)

getArNet

public java.math.BigDecimal getArNet()

setArNet

public void setArNet(java.math.BigDecimal arNet)

getArNumber

public java.lang.String getArNumber()

setArNumber

public void setArNumber(java.lang.String arNumber)

getArPaid

public java.math.BigDecimal getArPaid()

setArPaid

public void setArPaid(java.math.BigDecimal arPaid)

getArTax

public java.math.BigDecimal getArTax()

setArTax

public void setArTax(java.math.BigDecimal arTax)

getArTotal

public java.math.BigDecimal getArTotal()

setArTotal

public void setArTotal(java.math.BigDecimal arTotal)

getCalcNet

public java.math.BigDecimal getCalcNet()

setCalcNet

public void setCalcNet(java.math.BigDecimal calcNet)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getTotalO

public java.math.BigDecimal getTotalO()

setTotalO

public void setTotalO(java.math.BigDecimal totalO)

getTotalR

public java.math.BigDecimal getTotalR()

setTotalR

public void setTotalR(java.math.BigDecimal totalR)

getTransactionODate

public java.util.Date getTransactionODate()

setTransactionODate

public void setTransactionODate(java.util.Date transactionODate)

getTransactionRDate

public java.util.Date getTransactionRDate()

setTransactionRDate

public void setTransactionRDate(java.util.Date transactionRDate)

getCustID

public java.lang.String getCustID()

setCustID

public void setCustID(java.lang.String custID)

getExchange

public java.math.BigDecimal getExchange()

setExchange

public void setExchange(java.math.BigDecimal exchange)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ARBoilerplateVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ARBoilerplateVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ARBoilerplateVO
All Implemented Interfaces:
java.io.Serializable
public class ARBoilerplateVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ARBOILERPLATE
static java.lang.String | ORDER_BY_BOILERPLATEID
static java.lang.String | ORDER_BY_DESCRIPTION
Constructor Summary
ARBoilerplateVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getArBoilerplate()
java.lang.String | getBoilerplateId()
java.lang.String | getDescription()
int | hashCode()
void | setArBoilerplate(java.lang.String arBoilerplate)
void | setBoilerplateId(java.lang.String boilerplateId)
void | setDescription(java.lang.String description)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_BOILERPLATEID

public static final java.lang.String ORDER_BY_BOILERPLATEID
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_ARBOILERPLATE

public static final java.lang.String ORDER_BY_ARBOILERPLATE
See Also:
Constant Field Values
Constructor Detail

ARBoilerplateVO

public ARBoilerplateVO()
Method Detail

getBoilerplateId

public java.lang.String getBoilerplateId()

setBoilerplateId

public void setBoilerplateId(java.lang.String boilerplateId)

getDescription

public java.lang.String getDescription()

getArBoilerplate

public java.lang.String getArBoilerplate()

setDescription

public void setDescription(java.lang.String description)

setArBoilerplate

public void setArBoilerplate(java.lang.String arBoilerplate)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ArCommissionListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ArCommissionListResult

java.lang.Object
    extended by  bb.common.ArCommissionListResult
All Implemented Interfaces:
java.io.Serializable
public class ArCommissionListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ADDRESSID
static java.lang.String | ORDER_BY_ADDRESSNAME
static java.lang.String | ORDER_BY_COMMISSIONRATE
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_CUSTOMERPO
static java.lang.String | ORDER_BY_DATEINVOICED
static java.lang.String | ORDER_BY_EMPLOYEEID
static java.lang.String | ORDER_BY_FREIGHTTOTAL
static java.lang.String | ORDER_BY_GRANDTOTAL
static java.lang.String | ORDER_BY_INVOICENUMBER
static java.lang.String | ORDER_BY_PAIDDATE
static java.lang.String | ORDER_BY_PAYDATE
static java.lang.String | ORDER_BY_SALESCODEID
static java.lang.String | ORDER_BY_SALESCODENAME
static java.lang.String | ORDER_BY_SALESORDERNUMBER
static java.lang.String | ORDER_BY_SUBDISCOUNTTOTAL
static java.lang.String | ORDER_BY_SUBNETTOTAL
static java.lang.String | ORDER_BY_SUBUNITTOTAL
static java.lang.String | ORDER_BY_TAXTOTAL
Constructor Summary
ArCommissionListResult()
Method Summary
java.lang.String | getAddressId()
java.lang.String | getAddressName()
java.math.BigDecimal | getCommissionRate()
java.lang.String | getCurrency()
java.lang.String | getCustomerId()
java.lang.String | getCustomerPO()
java.util.Date | getDateInvoiced()
java.lang.String | getEmployeeId()
java.math.BigDecimal | getFreightTotal()
java.math.BigDecimal | getGrandTotal()
java.lang.String | getInvoiceNumber()
java.util.Date | getPaidDate()
java.util.Date | getPayDate()
java.lang.String | getSalesCodeId()
java.lang.String | getSalesCodeName()
java.lang.String | getSalesOrderNumber()
java.lang.String | getStatus()
java.math.BigDecimal | getSubDiscountTotal()
java.math.BigDecimal | getSubNetTotal()
java.math.BigDecimal | getSubUnitTotal()
java.math.BigDecimal | getTaxTotal()
java.math.BigDecimal | getTotalCommission()
void | setAddressId(java.lang.String addressId)
void | setAddressName(java.lang.String addressName)
void | setCommissionRate(java.math.BigDecimal commissionRate)
void | setCurrency(java.lang.String currency)
void | setCustomerId(java.lang.String customerId)
void | setCustomerPO(java.lang.String customerPO)
void | setDateInvoiced(java.util.Date dateInvoiced)
void | setEmployeeId(java.lang.String employeeId)
void | setFreightTotal(java.math.BigDecimal freightTotal)
void | setGrandTotal(java.math.BigDecimal grandTotal)
void | setInvoiceNumber(java.lang.String invoiceNumber)
void | setPaidDate(java.util.Date paidDate)
void | setPayDate(java.util.Date payDate)
void | setSalesCodeId(java.lang.String salesCodeId)
void | setSalesCodeName(java.lang.String salesCodeName)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setStatus(java.lang.String status)
void | setSubDiscountTotal(java.math.BigDecimal subDiscountTotal)
void | setSubNetTotal(java.math.BigDecimal subNetTotal)
void | setSubUnitTotal(java.math.BigDecimal subUnitTotal)
void | setTaxTotal(java.math.BigDecimal taxTotal)
void | setTotalCommission(java.math.BigDecimal totalCommission)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_INVOICENUMBER

public static final java.lang.String ORDER_BY_INVOICENUMBER
See Also:
Constant Field Values

ORDER_BY_SALESORDERNUMBER

public static final java.lang.String ORDER_BY_SALESORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_PAIDDATE

public static final java.lang.String ORDER_BY_PAIDDATE
See Also:
Constant Field Values

ORDER_BY_DATEINVOICED

public static final java.lang.String ORDER_BY_DATEINVOICED
See Also:
Constant Field Values

ORDER_BY_PAYDATE

public static final java.lang.String ORDER_BY_PAYDATE
See Also:
Constant Field Values

ORDER_BY_SALESCODEID

public static final java.lang.String ORDER_BY_SALESCODEID
See Also:
Constant Field Values

ORDER_BY_SALESCODENAME

public static final java.lang.String ORDER_BY_SALESCODENAME
See Also:
Constant Field Values

ORDER_BY_ADDRESSID

public static final java.lang.String ORDER_BY_ADDRESSID
See Also:
Constant Field Values

ORDER_BY_ADDRESSNAME

public static final java.lang.String ORDER_BY_ADDRESSNAME
See Also:
Constant Field Values

ORDER_BY_SUBUNITTOTAL

public static final java.lang.String ORDER_BY_SUBUNITTOTAL
See Also:
Constant Field Values

ORDER_BY_SUBDISCOUNTTOTAL

public static final java.lang.String ORDER_BY_SUBDISCOUNTTOTAL
See Also:
Constant Field Values

ORDER_BY_SUBNETTOTAL

public static final java.lang.String ORDER_BY_SUBNETTOTAL
See Also:
Constant Field Values

ORDER_BY_TAXTOTAL

public static final java.lang.String ORDER_BY_TAXTOTAL
See Also:
Constant Field Values

ORDER_BY_FREIGHTTOTAL

public static final java.lang.String ORDER_BY_FREIGHTTOTAL
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values

ORDER_BY_GRANDTOTAL

public static final java.lang.String ORDER_BY_GRANDTOTAL
See Also:
Constant Field Values

ORDER_BY_EMPLOYEEID

public static final java.lang.String ORDER_BY_EMPLOYEEID
See Also:
Constant Field Values

ORDER_BY_COMMISSIONRATE

public static final java.lang.String ORDER_BY_COMMISSIONRATE
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_CUSTOMERPO

public static final java.lang.String ORDER_BY_CUSTOMERPO
See Also:
Constant Field Values
Constructor Detail

ArCommissionListResult

public ArCommissionListResult()
Method Detail

getAddressId

public java.lang.String getAddressId()

getCustomerPO

public java.lang.String getCustomerPO()

setCustomerPO

public void setCustomerPO(java.lang.String customerPO)

setAddressId

public void setAddressId(java.lang.String addressId)

getAddressName

public java.lang.String getAddressName()

setAddressName

public void setAddressName(java.lang.String addressName)

getDateInvoiced

public java.util.Date getDateInvoiced()

setDateInvoiced

public void setDateInvoiced(java.util.Date dateInvoiced)

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getInvoiceNumber

public java.lang.String getInvoiceNumber()

setInvoiceNumber

public void setInvoiceNumber(java.lang.String invoiceNumber)

getPaidDate

public java.util.Date getPaidDate()

setPaidDate

public void setPaidDate(java.util.Date paidDate)

getPayDate

public java.util.Date getPayDate()

setPayDate

public void setPayDate(java.util.Date payDate)

getSalesCodeId

public java.lang.String getSalesCodeId()

setSalesCodeId

public void setSalesCodeId(java.lang.String salesCodeId)

getSalesCodeName

public java.lang.String getSalesCodeName()

setSalesCodeName

public void setSalesCodeName(java.lang.String salesCodeName)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getTotalCommission

public java.math.BigDecimal getTotalCommission()

setTotalCommission

public void setTotalCommission(java.math.BigDecimal totalCommission)

getCommissionRate

public java.math.BigDecimal getCommissionRate()

setCommissionRate

public void setCommissionRate(java.math.BigDecimal commissionRate)

getFreightTotal

public java.math.BigDecimal getFreightTotal()

setFreightTotal

public void setFreightTotal(java.math.BigDecimal freightTotal)

getGrandTotal

public java.math.BigDecimal getGrandTotal()

setGrandTotal

public void setGrandTotal(java.math.BigDecimal grandTotal)

getSubDiscountTotal

public java.math.BigDecimal getSubDiscountTotal()

setSubDiscountTotal

public void setSubDiscountTotal(java.math.BigDecimal subDiscountTotal)

getSubNetTotal

public java.math.BigDecimal getSubNetTotal()

setSubNetTotal

public void setSubNetTotal(java.math.BigDecimal subNetTotal)

getSubUnitTotal

public java.math.BigDecimal getSubUnitTotal()

setSubUnitTotal

public void setSubUnitTotal(java.math.BigDecimal subUnitTotal)

getTaxTotal

public java.math.BigDecimal getTaxTotal()

setTaxTotal

public void setTaxTotal(java.math.BigDecimal taxTotal)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ArCommissionTotalResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ArCommissionTotalResult

java.lang.Object
    extended by  bb.common.ArCommissionTotalResult
All Implemented Interfaces:
java.io.Serializable
public class ArCommissionTotalResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ArCommissionTotalResult()
Method Summary
java.math.BigDecimal | getCommissionTotal()
java.lang.String | getCurrency()
java.math.BigDecimal | getDiscountTotal()
java.math.BigDecimal | getFreightTotal()
java.math.BigDecimal | getGrandTotal()
java.math.BigDecimal | getNetTotal()
java.math.BigDecimal | getSubTotal()
java.math.BigDecimal | getTaxTotal()
void | setCommissionTotal(java.math.BigDecimal commissionTotal)
void | setCurrency(java.lang.String currency)
void | setDiscountTotal(java.math.BigDecimal discountTotal)
void | setFreightTotal(java.math.BigDecimal freightTotal)
void | setGrandTotal(java.math.BigDecimal grandTotal)
void | setNetTotal(java.math.BigDecimal netTotal)
void | setSubTotal(java.math.BigDecimal subTotal)
void | setTaxTotal(java.math.BigDecimal taxTotal)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ArCommissionTotalResult

public ArCommissionTotalResult()
Method Detail

getCommissionTotal

public java.math.BigDecimal getCommissionTotal()

setCommissionTotal

public void setCommissionTotal(java.math.BigDecimal commissionTotal)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getDiscountTotal

public java.math.BigDecimal getDiscountTotal()

setDiscountTotal

public void setDiscountTotal(java.math.BigDecimal discountTotal)

getFreightTotal

public java.math.BigDecimal getFreightTotal()

setFreightTotal

public void setFreightTotal(java.math.BigDecimal freightTotal)

getGrandTotal

public java.math.BigDecimal getGrandTotal()

setGrandTotal

public void setGrandTotal(java.math.BigDecimal grandTotal)

getNetTotal

public java.math.BigDecimal getNetTotal()

setNetTotal

public void setNetTotal(java.math.BigDecimal netTotal)

getSubTotal

public java.math.BigDecimal getSubTotal()

setSubTotal

public void setSubTotal(java.math.BigDecimal subTotal)

getTaxTotal

public java.math.BigDecimal getTaxTotal()

setTaxTotal

public void setTaxTotal(java.math.BigDecimal taxTotal)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ArPaymentRunItemAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ArPaymentRunItemAgent

java.lang.Object
    extended by  bb.common.ArPaymentRunItemAgent
All Implemented Interfaces:
java.io.Serializable
public class ArPaymentRunItemAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ArPaymentRunItemAgent()
Method Summary
java.lang.String[] | getArNumber()
java.lang.String[] | getExcludeVendorId()
java.util.Date | getFromDate()
java.lang.String[] | getIncludeVendorId()
java.util.Date | getToDate()
void | setArNumber(java.lang.String[] arNumber)
void | setExcludeVendorId(java.lang.String[] excludeVendorId)
void | setFromDate(java.util.Date fromDate)
void | setIncludeVendorId(java.lang.String[] includeVendorId)
void | setToDate(java.util.Date toDate)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ArPaymentRunItemAgent

public ArPaymentRunItemAgent()
Method Detail

getToDate

public java.util.Date getToDate()

getFromDate

public java.util.Date getFromDate()

getExcludeVendorId

public java.lang.String[] getExcludeVendorId()

setIncludeVendorId

public void setIncludeVendorId(java.lang.String[] includeVendorId)

setToDate

public void setToDate(java.util.Date toDate)

setFromDate

public void setFromDate(java.util.Date fromDate)

setExcludeVendorId

public void setExcludeVendorId(java.lang.String[] excludeVendorId)

setArNumber

public void setArNumber(java.lang.String[] arNumber)

getIncludeVendorId

public java.lang.String[] getIncludeVendorId()

getArNumber

public java.lang.String[] getArNumber()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ARPaymentRunItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ARPaymentRunItemPK

java.lang.Object
    extended by  bb.common.ARPaymentRunItemPK
All Implemented Interfaces:
java.io.Serializable
public class ARPaymentRunItemPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
ARPaymentRunItemPK()
default constructor
ARPaymentRunItemPK(java.lang.String paymentRunNumber, java.lang.String arNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getArNumber()
java.lang.String | getPaymentRunNumber()
int | hashCode()
void | setArNumber(java.lang.String arNumber)
void | setPaymentRunNumber(java.lang.String paymentRunNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ARPaymentRunItemPK

public ARPaymentRunItemPK(java.lang.String paymentRunNumber,
                          java.lang.String arNumber)
full constructor

ARPaymentRunItemPK

public ARPaymentRunItemPK()
default constructor

Method Detail

getPaymentRunNumber

public java.lang.String getPaymentRunNumber()

setPaymentRunNumber

public void setPaymentRunNumber(java.lang.String paymentRunNumber)

getArNumber

public java.lang.String getArNumber()

setArNumber

public void setArNumber(java.lang.String arNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ARPaymentRunItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ARPaymentRunItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ARPaymentRunItemVO
All Implemented Interfaces:
java.io.Serializable
public class ARPaymentRunItemVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
ARPaymentRunItemVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getArStatus()
java.math.BigDecimal | getArTotal()
java.lang.String | getCurrency()
CustomerVendorAddressInfoVO | getCustomerAddressInfo()
java.lang.String | getCustomerId()
java.util.Date | getDateInvoiced()
java.math.BigDecimal | getDue()
java.math.BigDecimal | getExchange()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getMemo()
java.math.BigDecimal | getPaid()
java.math.BigDecimal | getPaidToDate()
java.util.Date | getPayDate()
java.lang.String | getPaymentNumber()
ARPaymentRunItemPK | getPk()
java.lang.String | getPoNumber()
java.lang.String | getSn()
java.lang.String | getSoNumber()
java.lang.String | getStatus()
java.lang.String | getTransactionNo()
int | getVersion()
int | hashCode()
void | setArStatus(java.lang.String arStatus)
void | setArTotal(java.math.BigDecimal arTotal)
void | setCurrency(java.lang.String currency)
void | setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | setCustomerId(java.lang.String customerId)
void | setDateInvoiced(java.util.Date dateInvoiced)
void | setDue(java.math.BigDecimal due)
void | setExchange(java.math.BigDecimal exchange)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setMemo(java.lang.String memo)
void | setPaid(java.math.BigDecimal paid)
void | setPaidToDate(java.math.BigDecimal paidToDate)
void | setPayDate(java.util.Date payDate)
void | setPaymentNumber(java.lang.String paymentNumber)
void | setPk(ARPaymentRunItemPK pk)
void | setPoNumber(java.lang.String poNumber)
void | setSn(java.lang.String sn)
void | setSoNumber(java.lang.String soNumber)
void | setStatus(java.lang.String status)
void | setTransactionNo(java.lang.String transactionNo)
void | setVersion(int version)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ARPaymentRunItemVO

public ARPaymentRunItemVO()
default constructor

Method Detail

getPk

public ARPaymentRunItemPK getPk()

setPk

public void setPk(ARPaymentRunItemPK pk)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getPaymentNumber

public java.lang.String getPaymentNumber()

setPaymentNumber

public void setPaymentNumber(java.lang.String paymentNumber)

getMemo

public java.lang.String getMemo()

setMemo

public void setMemo(java.lang.String memo)

getSoNumber

public java.lang.String getSoNumber()

setSoNumber

public void setSoNumber(java.lang.String soNumber)

getSn

public java.lang.String getSn()

setSn

public void setSn(java.lang.String sn)

getPaid

public java.math.BigDecimal getPaid()

setPaid

public void setPaid(java.math.BigDecimal paid)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getExchange

public java.math.BigDecimal getExchange()

setExchange

public void setExchange(java.math.BigDecimal exchange)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getPoNumber

public java.lang.String getPoNumber()

setPoNumber

public void setPoNumber(java.lang.String poNumber)

getArTotal

public java.math.BigDecimal getArTotal()

setArTotal

public void setArTotal(java.math.BigDecimal arTotal)

getDateInvoiced

public java.util.Date getDateInvoiced()

setDateInvoiced

public void setDateInvoiced(java.util.Date dateInvoiced)

getPayDate

public java.util.Date getPayDate()

setPayDate

public void setPayDate(java.util.Date payDate)

getDue

public java.math.BigDecimal getDue()

setDue

public void setDue(java.math.BigDecimal due)

getVersion

public int getVersion()

getArStatus

public java.lang.String getArStatus()

getCustomerAddressInfo

public CustomerVendorAddressInfoVO getCustomerAddressInfo()

getPaidToDate

public java.math.BigDecimal getPaidToDate()

getCustomerId

public java.lang.String getCustomerId()

getTransactionNo

public java.lang.String getTransactionNo()

setVersion

public void setVersion(int version)

setArStatus

public void setArStatus(java.lang.String arStatus)

setCustomerAddressInfo

public void setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)

setPaidToDate

public void setPaidToDate(java.math.BigDecimal paidToDate)

setCustomerId

public void setCustomerId(java.lang.String customerId)

setTransactionNo

public void setTransactionNo(java.lang.String transactionNo)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ARPaymentRunListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ARPaymentRunListResult

java.lang.Object
    extended by  bb.common.ARPaymentRunListResult
All Implemented Interfaces:
java.io.Serializable
public class ARPaymentRunListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ARNUMBER
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_CUSTOMERNAME
static java.lang.String | ORDER_BY_PAYDATE
static java.lang.String | ORDER_BY_PAYMENTNUMBER
static java.lang.String | ORDER_BY_PAYMENTRUNNUMBER
static java.lang.String | ORDER_BY_SONUMBER
static java.lang.String | ORDER_BY_TRANSACTIONNUMBER
Constructor Summary
ARPaymentRunListResult()
Method Summary
java.math.BigDecimal | getAmount()
java.lang.String | getArNumber()
java.lang.String | getCurrency()
java.lang.String | getCustomerId()
java.lang.String | getCustomerName()
java.util.Date | getPayDate()
java.lang.String | getPaymentNumber()
java.lang.String | getPaymentRunNumber()
java.lang.String | getSoNumber()
java.lang.String | getTransactionNumber()
void | setAmount(java.math.BigDecimal amount)
void | setArNumber(java.lang.String arNumber)
void | setCurrency(java.lang.String currency)
void | setCustomerId(java.lang.String customerId)
void | setCustomerName(java.lang.String customerName)
void | setPayDate(java.util.Date payDate)
void | setPaymentNumber(java.lang.String paymentNumber)
void | setPaymentRunNumber(java.lang.String paymentRunNumber)
void | setSoNumber(java.lang.String soNumber)
void | setTransactionNumber(java.lang.String transactionNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PAYMENTRUNNUMBER

public static final java.lang.String ORDER_BY_PAYMENTRUNNUMBER
See Also:
Constant Field Values

ORDER_BY_PAYMENTNUMBER

public static final java.lang.String ORDER_BY_PAYMENTNUMBER
See Also:
Constant Field Values

ORDER_BY_TRANSACTIONNUMBER

public static final java.lang.String ORDER_BY_TRANSACTIONNUMBER
See Also:
Constant Field Values

ORDER_BY_PAYDATE

public static final java.lang.String ORDER_BY_PAYDATE
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_CUSTOMERNAME

public static final java.lang.String ORDER_BY_CUSTOMERNAME
See Also:
Constant Field Values

ORDER_BY_ARNUMBER

public static final java.lang.String ORDER_BY_ARNUMBER
See Also:
Constant Field Values

ORDER_BY_SONUMBER

public static final java.lang.String ORDER_BY_SONUMBER
See Also:
Constant Field Values
Constructor Detail

ARPaymentRunListResult

public ARPaymentRunListResult()
Method Detail

getSoNumber

public java.lang.String getSoNumber()

getArNumber

public java.lang.String getArNumber()

getCustomerName

public java.lang.String getCustomerName()

getCustomerId

public java.lang.String getCustomerId()

getPayDate

public java.util.Date getPayDate()

getTransactionNumber

public java.lang.String getTransactionNumber()

getCurrency

public java.lang.String getCurrency()

getAmount

public java.math.BigDecimal getAmount()

getPaymentNumber

public java.lang.String getPaymentNumber()

setPaymentRunNumber

public void setPaymentRunNumber(java.lang.String paymentRunNumber)

setSoNumber

public void setSoNumber(java.lang.String soNumber)

setArNumber

public void setArNumber(java.lang.String arNumber)

setCustomerName

public void setCustomerName(java.lang.String customerName)

setCustomerId

public void setCustomerId(java.lang.String customerId)

setPayDate

public void setPayDate(java.util.Date payDate)

setTransactionNumber

public void setTransactionNumber(java.lang.String transactionNumber)

setCurrency

public void setCurrency(java.lang.String currency)

setAmount

public void setAmount(java.math.BigDecimal amount)

setPaymentNumber

public void setPaymentNumber(java.lang.String paymentNumber)

getPaymentRunNumber

public java.lang.String getPaymentRunNumber()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ARPaymentRunVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ARPaymentRunVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ARPaymentRunVO
All Implemented Interfaces:
java.io.Serializable
public class ARPaymentRunVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DATE1
static java.lang.String | ORDER_BY_DATE2
static java.lang.String | ORDER_BY_EXCLUDE
static java.lang.String | ORDER_BY_GAAR
static java.lang.String | ORDER_BY_GACHECKING
static java.lang.String | ORDER_BY_INCLUDE
static java.lang.String | ORDER_BY_PAYMENTNUMBER
static java.lang.String | ORDER_BY_PAYMENTRUNNUMBER
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_TOTALWIREFEE
static java.lang.String | ORDER_BY_TRANSACTIONDATE
static java.lang.String | ORDER_BY_WIREFEEACCOUNT
static java.lang.String | ORDER_BY_WIREFEEAPNUMBER
Constructor Summary
ARPaymentRunVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getChecked()
java.lang.String | getCompanyUnitOfGaAr()
java.lang.String | getCompanyUnitOfGaChecking()
java.lang.String | getCompanyUnitOfWireFeeAcc()
java.util.Date | getDate1()
java.util.Date | getDate2()
java.util.Date | getDatePaid()
java.lang.String | getExclude()
java.lang.String | getGaAr()
java.lang.String | getGaChecking()
java.lang.String | getInclude()
java.lang.String | getMadeBy()
java.lang.String | getPaymentNumber()
java.util.Set | getPaymentRunItems()
java.lang.String | getPaymentRunNumber()
java.lang.String | getStatus()
java.math.BigDecimal | getTotalWireFee()
java.util.Date | getTransactionDate()
java.lang.String | getWireFeeAccount()
java.lang.String | getWireFeeApNumber()
int | hashCode()
void | setChecked(java.lang.String checked)
void | setCompanyUnitOfGaAr(java.lang.String companyUnitOfGaAr)
void | setCompanyUnitOfGaChecking(java.lang.String companyUnitOfGaChecking)
void | setCompanyUnitOfWireFeeAcc(java.lang.String companyUnitOfWireFeeAcc)
void | setDate1(java.util.Date date1)
void | setDate2(java.util.Date date2)
void | setDatePaid(java.util.Date datePaid)
void | setExclude(java.lang.String exclude)
void | setGaAr(java.lang.String gaAr)
void | setGaChecking(java.lang.String gaChecking)
void | setInclude(java.lang.String include)
void | setMadeBy(java.lang.String madeBy)
void | setPaymentNumber(java.lang.String paymentNumber)
void | setPaymentRunItems(java.util.Set paymentRunItems)
void | setPaymentRunNumber(java.lang.String paymentRunNumber)
void | setStatus(java.lang.String status)
void | setTotalWireFee(java.math.BigDecimal totalWireFee)
void | setTransactionDate(java.util.Date transactionDate)
void | setWireFeeAccount(java.lang.String wireFeeAccount)
void | setWireFeeApNumber(java.lang.String wireFeeApNumber)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PAYMENTRUNNUMBER

public static final java.lang.String ORDER_BY_PAYMENTRUNNUMBER
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_PAYMENTNUMBER

public static final java.lang.String ORDER_BY_PAYMENTNUMBER
See Also:
Constant Field Values

ORDER_BY_TRANSACTIONDATE

public static final java.lang.String ORDER_BY_TRANSACTIONDATE
See Also:
Constant Field Values

ORDER_BY_GAAR

public static final java.lang.String ORDER_BY_GAAR
See Also:
Constant Field Values

ORDER_BY_GACHECKING

public static final java.lang.String ORDER_BY_GACHECKING
See Also:
Constant Field Values

ORDER_BY_WIREFEEACCOUNT

public static final java.lang.String ORDER_BY_WIREFEEACCOUNT
See Also:
Constant Field Values

ORDER_BY_TOTALWIREFEE

public static final java.lang.String ORDER_BY_TOTALWIREFEE
See Also:
Constant Field Values

ORDER_BY_WIREFEEAPNUMBER

public static final java.lang.String ORDER_BY_WIREFEEAPNUMBER
See Also:
Constant Field Values

ORDER_BY_INCLUDE

public static final java.lang.String ORDER_BY_INCLUDE
See Also:
Constant Field Values

ORDER_BY_EXCLUDE

public static final java.lang.String ORDER_BY_EXCLUDE
See Also:
Constant Field Values

ORDER_BY_DATE1

public static final java.lang.String ORDER_BY_DATE1
See Also:
Constant Field Values

ORDER_BY_DATE2

public static final java.lang.String ORDER_BY_DATE2
See Also:
Constant Field Values
Constructor Detail

ARPaymentRunVO

public ARPaymentRunVO()
default constructor

Method Detail

getPaymentRunNumber

public java.lang.String getPaymentRunNumber()

setPaymentRunNumber

public void setPaymentRunNumber(java.lang.String paymentRunNumber)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getPaymentNumber

public java.lang.String getPaymentNumber()

setPaymentNumber

public void setPaymentNumber(java.lang.String paymentNumber)

getTransactionDate

public java.util.Date getTransactionDate()

setTransactionDate

public void setTransactionDate(java.util.Date transactionDate)

getGaAr

public java.lang.String getGaAr()

setGaAr

public void setGaAr(java.lang.String gaAr)

getGaChecking

public java.lang.String getGaChecking()

setGaChecking

public void setGaChecking(java.lang.String gaChecking)

getInclude

public java.lang.String getInclude()

setInclude

public void setInclude(java.lang.String include)

getExclude

public java.lang.String getExclude()

setExclude

public void setExclude(java.lang.String exclude)

getDate1

public java.util.Date getDate1()

setDate1

public void setDate1(java.util.Date date1)

getDate2

public java.util.Date getDate2()

setDate2

public void setDate2(java.util.Date date2)

getChecked

public java.lang.String getChecked()

getPaymentRunItems

public java.util.Set getPaymentRunItems()

getDatePaid

public java.util.Date getDatePaid()

setChecked

public void setChecked(java.lang.String checked)

setPaymentRunItems

public void setPaymentRunItems(java.util.Set paymentRunItems)

setDatePaid

public void setDatePaid(java.util.Date datePaid)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getWireFeeAccount

public java.lang.String getWireFeeAccount()

setWireFeeAccount

public void setWireFeeAccount(java.lang.String wireFeeAccount)

getTotalWireFee

public java.math.BigDecimal getTotalWireFee()

setTotalWireFee

public void setTotalWireFee(java.math.BigDecimal totalWireFee)

getWireFeeApNumber

public java.lang.String getWireFeeApNumber()

setWireFeeApNumber

public void setWireFeeApNumber(java.lang.String wireFeeApNumber)

getCompanyUnitOfGaAr

public java.lang.String getCompanyUnitOfGaAr()

setCompanyUnitOfGaAr

public void setCompanyUnitOfGaAr(java.lang.String companyUnitOfGaAr)

getCompanyUnitOfGaChecking

public java.lang.String getCompanyUnitOfGaChecking()

setCompanyUnitOfGaChecking

public void setCompanyUnitOfGaChecking(java.lang.String companyUnitOfGaChecking)

getCompanyUnitOfWireFeeAcc

public java.lang.String getCompanyUnitOfWireFeeAcc()

setCompanyUnitOfWireFeeAcc

public void setCompanyUnitOfWireFeeAcc(java.lang.String companyUnitOfWireFeeAcc)

getMadeBy

public java.lang.String getMadeBy()

setMadeBy

public void setMadeBy(java.lang.String madeBy)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ARPrepayAllStatementsListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ARPrepayAllStatementsListResult

java.lang.Object
    extended by  bb.common.ARPrepayAllStatementsListResult
All Implemented Interfaces:
java.io.Serializable
public class ARPrepayAllStatementsListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_CUSTOMERNAME
Constructor Summary
ARPrepayAllStatementsListResult()
Method Summary
java.math.BigDecimal | getAmountPaid()
java.math.BigDecimal | getBalanceDue()
java.lang.String | getCurrency()
java.lang.String | getCustomerId()
java.lang.String | getCustomerName()
java.lang.String | getEmail()
java.math.BigDecimal | getTotalApply()
java.math.BigDecimal | getTotalDue()
void | setAmountPaid(java.math.BigDecimal amountPaid)
void | setBalanceDue(java.math.BigDecimal balanceDue)
void | setCurrency(java.lang.String currency)
void | setCustomerId(java.lang.String customerId)
void | setCustomerName(java.lang.String customerName)
void | setEmail(java.lang.String email)
void | setTotalApply(java.math.BigDecimal totalApply)
void | setTotalDue(java.math.BigDecimal totalDue)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_CUSTOMERNAME

public static final java.lang.String ORDER_BY_CUSTOMERNAME
See Also:
Constant Field Values
Constructor Detail

ARPrepayAllStatementsListResult

public ARPrepayAllStatementsListResult()
Method Detail

getAmountPaid

public java.math.BigDecimal getAmountPaid()

setAmountPaid

public void setAmountPaid(java.math.BigDecimal amountPaid)

getBalanceDue

public java.math.BigDecimal getBalanceDue()

setBalanceDue

public void setBalanceDue(java.math.BigDecimal balanceDue)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getCustomerName

public java.lang.String getCustomerName()

setCustomerName

public void setCustomerName(java.lang.String customerName)

getEmail

public java.lang.String getEmail()

setEmail

public void setEmail(java.lang.String email)

getTotalDue

public java.math.BigDecimal getTotalDue()

setTotalDue

public void setTotalDue(java.math.BigDecimal totalDue)

getTotalApply

public java.math.BigDecimal getTotalApply()

setTotalApply

public void setTotalApply(java.math.BigDecimal totalApply)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ARPrepayInfoResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ARPrepayInfoResult

java.lang.Object
    extended by  bb.common.ARPrepayInfoResult
All Implemented Interfaces:
java.io.Serializable
public class ARPrepayInfoResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ARPrepayInfoResult()
Method Summary
java.math.BigDecimal | getArpiPrepay()
java.math.BigDecimal | getArpiPrepayDue()
java.math.BigDecimal | getArpiPrepayGl()
java.lang.String | getCompanyUnitId()
java.lang.String | getCustomerId()
java.lang.String | getCustomerName()
java.util.Date | getPayDate()
ArPrepayItemPK | getPk()
java.lang.String | getSalesOrderNumber()
void | setArpiPrepay(java.math.BigDecimal arpiPrepay)
void | setArpiPrepayDue(java.math.BigDecimal arpiPrepayDue)
void | setArpiPrepayGl(java.math.BigDecimal arpiPrepayGl)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCustomerId(java.lang.String customerId)
void | setCustomerName(java.lang.String customerName)
void | setPayDate(java.util.Date payDate)
void | setPk(ArPrepayItemPK pk)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ARPrepayInfoResult

public ARPrepayInfoResult()
Method Detail

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getCustomerName

public java.lang.String getCustomerName()

setCustomerName

public void setCustomerName(java.lang.String customerName)

getPayDate

public java.util.Date getPayDate()

setPayDate

public void setPayDate(java.util.Date payDate)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getPk

public ArPrepayItemPK getPk()

setPk

public void setPk(ArPrepayItemPK pk)

getArpiPrepay

public java.math.BigDecimal getArpiPrepay()

setArpiPrepay

public void setArpiPrepay(java.math.BigDecimal arpiPrepay)

getArpiPrepayDue

public java.math.BigDecimal getArpiPrepayDue()

setArpiPrepayDue

public void setArpiPrepayDue(java.math.BigDecimal arpiPrepayDue)

getArpiPrepayGl

public java.math.BigDecimal getArpiPrepayGl()

setArpiPrepayGl

public void setArpiPrepayGl(java.math.BigDecimal arpiPrepayGl)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ArPrepayItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ArPrepayItemPK

java.lang.Object
    extended by  bb.common.ArPrepayItemPK
All Implemented Interfaces:
java.io.Serializable
public class ArPrepayItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ArPrepayItemPK()
ArPrepayItemPK(java.lang.String arPrepayNumber, java.lang.String arPrepayItemNumber)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getArPrepayItemNumber()
java.lang.String | getArPrepayNumber()
int | hashCode()
void | setArPrepayItemNumber(java.lang.String arPrepayItemNumber)
void | setArPrepayNumber(java.lang.String arPrepayNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ArPrepayItemPK

public ArPrepayItemPK(java.lang.String arPrepayNumber,
                      java.lang.String arPrepayItemNumber)

ArPrepayItemPK

public ArPrepayItemPK()
Method Detail

getArPrepayItemNumber

public java.lang.String getArPrepayItemNumber()

setArPrepayItemNumber

public void setArPrepayItemNumber(java.lang.String arPrepayItemNumber)

getArPrepayNumber

public java.lang.String getArPrepayNumber()

setArPrepayNumber

public void setArPrepayNumber(java.lang.String arPrepayNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ArPrepayItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ArPrepayItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ArPrepayItemVO
All Implemented Interfaces:
java.io.Serializable
public class ArPrepayItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ArPrepayItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getArpiPrepay()
java.math.BigDecimal | getArpiPrepayDue()
java.math.BigDecimal | getArpiPrepayGl()
java.lang.String | getComments()
java.util.Date | getDateRequired()
ArPrepayItemPK | getPk()
java.lang.String | getSoNumber()
java.lang.String | getStatus()
int | hashCode()
void | setArpiPrepay(java.math.BigDecimal arpiPrepay)
void | setArpiPrepayDue(java.math.BigDecimal arpiPrepayDue)
void | setArpiPrepayGl(java.math.BigDecimal arpiPrepayGl)
void | setComments(java.lang.String comments)
void | setDateRequired(java.util.Date dateRequired)
void | setPk(ArPrepayItemPK pk)
void | setSoNumber(java.lang.String soNumber)
void | setStatus(java.lang.String status)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ArPrepayItemVO

public ArPrepayItemVO()
Method Detail

getArpiPrepay

public java.math.BigDecimal getArpiPrepay()

setArpiPrepay

public void setArpiPrepay(java.math.BigDecimal arpiPrepay)

getArpiPrepayDue

public java.math.BigDecimal getArpiPrepayDue()

setArpiPrepayDue

public void setArpiPrepayDue(java.math.BigDecimal arpiPrepayDue)

getArpiPrepayGl

public java.math.BigDecimal getArpiPrepayGl()

setArpiPrepayGl

public void setArpiPrepayGl(java.math.BigDecimal arpiPrepayGl)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getDateRequired

public java.util.Date getDateRequired()

setDateRequired

public void setDateRequired(java.util.Date dateRequired)

getPk

public ArPrepayItemPK getPk()

setPk

public void setPk(ArPrepayItemPK pk)

getSoNumber

public java.lang.String getSoNumber()

setSoNumber

public void setSoNumber(java.lang.String soNumber)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ArPrepaymentRunItemAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ArPrepaymentRunItemAgent

java.lang.Object
    extended by  bb.common.ArPrepaymentRunItemAgent
All Implemented Interfaces:
java.io.Serializable
public class ArPrepaymentRunItemAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ArPrepaymentRunItemAgent()
Method Summary
ArPrepayItemPK[] | getArpiNumber()
java.lang.String[] | getExcludeVendorId()
java.util.Date | getFromDate()
java.lang.String[] | getIncludeVendorId()
java.util.Date | getToDate()
void | setArpiNumber(ArPrepayItemPK[] arpiNumber)
void | setExcludeVendorId(java.lang.String[] excludeVendorId)
void | setFromDate(java.util.Date fromDate)
void | setIncludeVendorId(java.lang.String[] includeVendorId)
void | setToDate(java.util.Date toDate)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ArPrepaymentRunItemAgent

public ArPrepaymentRunItemAgent()
Method Detail

getExcludeVendorId

public java.lang.String[] getExcludeVendorId()

setExcludeVendorId

public void setExcludeVendorId(java.lang.String[] excludeVendorId)

getFromDate

public java.util.Date getFromDate()

setFromDate

public void setFromDate(java.util.Date fromDate)

getIncludeVendorId

public java.lang.String[] getIncludeVendorId()

setIncludeVendorId

public void setIncludeVendorId(java.lang.String[] includeVendorId)

getToDate

public java.util.Date getToDate()

setToDate

public void setToDate(java.util.Date toDate)

getArpiNumber

public ArPrepayItemPK[] getArpiNumber()

setArpiNumber

public void setArpiNumber(ArPrepayItemPK[] arpiNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ARPrepaymentWireTransferAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ARPrepaymentWireTransferAgent

java.lang.Object
    extended by  bb.common.ARPrepaymentWireTransferAgent
All Implemented Interfaces:
java.io.Serializable
public class ARPrepaymentWireTransferAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ARPrepaymentWireTransferAgent()
Method Summary
ArPrepayItemPK[] | getArpiPk()
java.lang.String | getBankTransferFeeAccount()
java.lang.String | getCompanyUnitOfCreditAcc()
java.lang.String | getCompanyUnitOfDebitAcc()
java.lang.String | getCompanyUnitOfTransferFeeAcc()
java.lang.String | getCreditAccount()
java.lang.String | getDebitAccount()
java.lang.String[] | getExcludeVendorId()
java.util.Date | getFromDate()
java.lang.String[] | getIncludeVendorId()
java.util.Date | getToDate()
java.util.Date | getTransactionDate()
java.lang.String | getWireTransferNo()
void | setArpiPk(ArPrepayItemPK[] arpiPk)
void | setBankTransferFeeAccount(java.lang.String bankTransferFeeAccount)
void | setCompanyUnitOfCreditAcc(java.lang.String companyUnitOfCreditAcc)
void | setCompanyUnitOfDebitAcc(java.lang.String companyUnitOfDebitAcc)
void | setCompanyUnitOfTransferFeeAcc(java.lang.String companyUnitOfTransferFeeAcc)
void | setCreditAccount(java.lang.String creditAccount)
void | setDebitAccount(java.lang.String debitAccount)
void | setExcludeVendorId(java.lang.String[] excludeVendorId)
void | setFromDate(java.util.Date fromDate)
void | setIncludeVendorId(java.lang.String[] includeVendorId)
void | setToDate(java.util.Date toDate)
void | setTransactionDate(java.util.Date transactionDate)
void | setWireTransferNo(java.lang.String wireTransferNo)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ARPrepaymentWireTransferAgent

public ARPrepaymentWireTransferAgent()
Method Detail

getArpiPk

public ArPrepayItemPK[] getArpiPk()

setArpiPk

public void setArpiPk(ArPrepayItemPK[] arpiPk)

getBankTransferFeeAccount

public java.lang.String getBankTransferFeeAccount()

setBankTransferFeeAccount

public void setBankTransferFeeAccount(java.lang.String bankTransferFeeAccount)

getCompanyUnitOfCreditAcc

public java.lang.String getCompanyUnitOfCreditAcc()

setCompanyUnitOfCreditAcc

public void setCompanyUnitOfCreditAcc(java.lang.String companyUnitOfCreditAcc)

getCompanyUnitOfDebitAcc

public java.lang.String getCompanyUnitOfDebitAcc()

setCompanyUnitOfDebitAcc

public void setCompanyUnitOfDebitAcc(java.lang.String companyUnitOfDebitAcc)

getCompanyUnitOfTransferFeeAcc

public java.lang.String getCompanyUnitOfTransferFeeAcc()

setCompanyUnitOfTransferFeeAcc

public void setCompanyUnitOfTransferFeeAcc(java.lang.String companyUnitOfTransferFeeAcc)

getCreditAccount

public java.lang.String getCreditAccount()

setCreditAccount

public void setCreditAccount(java.lang.String creditAccount)

getDebitAccount

public java.lang.String getDebitAccount()

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

getExcludeVendorId

public java.lang.String[] getExcludeVendorId()

setExcludeVendorId

public void setExcludeVendorId(java.lang.String[] excludeVendorId)

getFromDate

public java.util.Date getFromDate()

setFromDate

public void setFromDate(java.util.Date fromDate)

getIncludeVendorId

public java.lang.String[] getIncludeVendorId()

setIncludeVendorId

public void setIncludeVendorId(java.lang.String[] includeVendorId)

getToDate

public java.util.Date getToDate()

setToDate

public void setToDate(java.util.Date toDate)

getTransactionDate

public java.util.Date getTransactionDate()

setTransactionDate

public void setTransactionDate(java.util.Date transactionDate)

getWireTransferNo

public java.lang.String getWireTransferNo()

setWireTransferNo

public void setWireTransferNo(java.lang.String wireTransferNo)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ArPrepayVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ArPrepayVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ArPrepayVO
All Implemented Interfaces:
java.io.Serializable
public class ArPrepayVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ARPDATE
static java.lang.String | ORDER_BY_ARPREPAYNUMBER
static java.lang.String | ORDER_BY_COMPANYUNITID
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_SONUMBER
Constructor Summary
ArPrepayVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getArpDate()
java.math.BigDecimal | getArPrepay()
java.math.BigDecimal | getArPrepayApply()
java.math.BigDecimal | getArPrepayDue()
java.math.BigDecimal | getArPrepayGl()
java.util.Set<ArPrepayItemVO> | getArPrepayItem()
java.lang.String | getArPrepayNumber()
CustomerVendorAddressInfoVO | getBillToAddressInfo()
java.lang.String | getBillToId()
java.lang.String | getCheck()
java.lang.String | getCompanyUnitId()
java.lang.String | getCurrency()
CustomerVendorAddressInfoVO | getCustomerAddressInfo()
java.lang.String | getCustomerId()
java.lang.String | getCustomerPO()
java.math.BigDecimal | getExchange()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getRequester()
java.lang.String | getSalesOrderNumber()
CustomerVendorAddressInfoVO | getShipToAddressInfo()
java.lang.String | getShipToId()
java.math.BigDecimal | getSoTotal()
java.lang.String | getStatus()
int | hashCode()
void | setArpDate(java.util.Date arpDate)
void | setArPrepay(java.math.BigDecimal arPrepay)
void | setArPrepayApply(java.math.BigDecimal arPrepayApply)
void | setArPrepayDue(java.math.BigDecimal arPrepayDue)
void | setArPrepayGl(java.math.BigDecimal arPrepayGl)
void | setArPrepayItem(java.util.Set<ArPrepayItemVO> arPrepayItem)
void | setArPrepayNumber(java.lang.String arPrepayNumber)
void | setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | setBillToId(java.lang.String billToId)
void | setCheck(java.lang.String check)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCurrency(java.lang.String currency)
void | setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | setCustomerId(java.lang.String customerId)
void | setCustomerPO(java.lang.String customerPO)
void | setExchange(java.math.BigDecimal exchange)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setRequester(java.lang.String requester)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | setShipToId(java.lang.String shipToId)
void | setSoTotal(java.math.BigDecimal soTotal)
void | setStatus(java.lang.String status)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ARPREPAYNUMBER

public static final java.lang.String ORDER_BY_ARPREPAYNUMBER
See Also:
Constant Field Values

ORDER_BY_SONUMBER

public static final java.lang.String ORDER_BY_SONUMBER
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_ARPDATE

public static final java.lang.String ORDER_BY_ARPDATE
See Also:
Constant Field Values

ORDER_BY_COMPANYUNITID

public static final java.lang.String ORDER_BY_COMPANYUNITID
See Also:
Constant Field Values
Constructor Detail

ArPrepayVO

public ArPrepayVO()
Method Detail

getArPrepay

public java.math.BigDecimal getArPrepay()

setArPrepay

public void setArPrepay(java.math.BigDecimal arPrepay)

getArPrepayDue

public java.math.BigDecimal getArPrepayDue()

setArPrepayDue

public void setArPrepayDue(java.math.BigDecimal arPrepayDue)

getArPrepayGl

public java.math.BigDecimal getArPrepayGl()

setArPrepayGl

public void setArPrepayGl(java.math.BigDecimal arPrepayGl)

getArPrepayNumber

public java.lang.String getArPrepayNumber()

setArPrepayNumber

public void setArPrepayNumber(java.lang.String arPrepayNumber)

getCheck

public java.lang.String getCheck()

setCheck

public void setCheck(java.lang.String check)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getCustomerAddressInfo

public CustomerVendorAddressInfoVO getCustomerAddressInfo()

setCustomerAddressInfo

public void setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getExchange

public java.math.BigDecimal getExchange()

setExchange

public void setExchange(java.math.BigDecimal exchange)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getRequester

public java.lang.String getRequester()

setRequester

public void setRequester(java.lang.String requester)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getSoTotal

public java.math.BigDecimal getSoTotal()

setSoTotal

public void setSoTotal(java.math.BigDecimal soTotal)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getArpDate

public java.util.Date getArpDate()

setArpDate

public void setArpDate(java.util.Date arpDate)

getArPrepayItem

public java.util.Set<ArPrepayItemVO> getArPrepayItem()

setArPrepayItem

public void setArPrepayItem(java.util.Set<ArPrepayItemVO> arPrepayItem)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getCustomerPO

public java.lang.String getCustomerPO()

setCustomerPO

public void setCustomerPO(java.lang.String customerPO)

getArPrepayApply

public java.math.BigDecimal getArPrepayApply()

setArPrepayApply

public void setArPrepayApply(java.math.BigDecimal arPrepayApply)

getBillToAddressInfo

public CustomerVendorAddressInfoVO getBillToAddressInfo()

setBillToAddressInfo

public void setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)

getShipToAddressInfo

public CustomerVendorAddressInfoVO getShipToAddressInfo()

setShipToAddressInfo

public void setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)

getBillToId

public java.lang.String getBillToId()

setBillToId

public void setBillToId(java.lang.String billToId)

getShipToId

public java.lang.String getShipToId()

setShipToId

public void setShipToId(java.lang.String shipToId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ArSalesCodeTotalListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ArSalesCodeTotalListResult

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SalesCodeVO
            extended by  bb.common.ArSalesCodeTotalListResult
All Implemented Interfaces:
java.io.Serializable
public class ArSalesCodeTotalListResult
extends SalesCodeVO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ADDRESSID
static java.lang.String | ORDER_BY_ADDRESSNAME
static java.lang.String | ORDER_BY_COMMISSIONRATE
static java.lang.String | ORDER_BY_COMMISSIONTOTAL
static java.lang.String | ORDER_BY_DISCOUNTTOTAL
static java.lang.String | ORDER_BY_EMPLOYEEID
static java.lang.String | ORDER_BY_FREIGHTTOTAL
static java.lang.String | ORDER_BY_GRANDTOTAL
static java.lang.String | ORDER_BY_NETTOTAL
static java.lang.String | ORDER_BY_SALESCODEID
static java.lang.String | ORDER_BY_SALESCODENAME
static java.lang.String | ORDER_BY_SUBTOTAL
static java.lang.String | ORDER_BY_TAXTOTAL
Constructor Summary
ArSalesCodeTotalListResult()
Method Summary
java.math.BigDecimal | getCommissionTotal()
java.math.BigDecimal | getDiscountTotal()
java.math.BigDecimal | getFreightTotal()
java.math.BigDecimal | getGrandTotal()
java.math.BigDecimal | getNetTotal()
java.math.BigDecimal | getSubTotal()
java.math.BigDecimal | getTaxTotal()
void | setCommissionTotal(java.math.BigDecimal commissionTotal)
void | setDiscountTotal(java.math.BigDecimal discountTotal)
void | setFreightTotal(java.math.BigDecimal freightTotal)
void | setGrandTotal(java.math.BigDecimal grandTotal)
void | setNetTotal(java.math.BigDecimal netTotal)
void | setSubTotal(java.math.BigDecimal subTotal)
void | setTaxTotal(java.math.BigDecimal taxTotal)
Methods inherited from class bb.common.SalesCodeVO
equals, getAddressId, getAddressName, getComments, getCommissionRate, getEmployeeId, getLastChangeDate, getLastChangeTimes, getLastChangeUser, getSalesCodeId, getSalesCodeIds, getSalesCodeName, hashCode, isContainTax, setAddressId, setAddressName, setComments, setCommissionRate, setContainTax, setEmployeeId, setLastChangeDate, setLastChangeTimes, setLastChangeUser, setSalesCodeId, setSalesCodeIds, setSalesCodeName, toString, uniqueStr
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_SALESCODEID

public static final java.lang.String ORDER_BY_SALESCODEID
See Also:
Constant Field Values

ORDER_BY_SALESCODENAME

public static final java.lang.String ORDER_BY_SALESCODENAME
See Also:
Constant Field Values

ORDER_BY_ADDRESSID

public static final java.lang.String ORDER_BY_ADDRESSID
See Also:
Constant Field Values

ORDER_BY_ADDRESSNAME

public static final java.lang.String ORDER_BY_ADDRESSNAME
See Also:
Constant Field Values

ORDER_BY_EMPLOYEEID

public static final java.lang.String ORDER_BY_EMPLOYEEID
See Also:
Constant Field Values

ORDER_BY_COMMISSIONRATE

public static final java.lang.String ORDER_BY_COMMISSIONRATE
See Also:
Constant Field Values

ORDER_BY_SUBTOTAL

public static final java.lang.String ORDER_BY_SUBTOTAL
See Also:
Constant Field Values

ORDER_BY_DISCOUNTTOTAL

public static final java.lang.String ORDER_BY_DISCOUNTTOTAL
See Also:
Constant Field Values

ORDER_BY_NETTOTAL

public static final java.lang.String ORDER_BY_NETTOTAL
See Also:
Constant Field Values

ORDER_BY_TAXTOTAL

public static final java.lang.String ORDER_BY_TAXTOTAL
See Also:
Constant Field Values

ORDER_BY_FREIGHTTOTAL

public static final java.lang.String ORDER_BY_FREIGHTTOTAL
See Also:
Constant Field Values

ORDER_BY_GRANDTOTAL

public static final java.lang.String ORDER_BY_GRANDTOTAL
See Also:
Constant Field Values

ORDER_BY_COMMISSIONTOTAL

public static final java.lang.String ORDER_BY_COMMISSIONTOTAL
See Also:
Constant Field Values
Constructor Detail

ArSalesCodeTotalListResult

public ArSalesCodeTotalListResult()
Method Detail

getCommissionTotal

public java.math.BigDecimal getCommissionTotal()

setCommissionTotal

public void setCommissionTotal(java.math.BigDecimal commissionTotal)

getDiscountTotal

public java.math.BigDecimal getDiscountTotal()

setDiscountTotal

public void setDiscountTotal(java.math.BigDecimal discountTotal)

getFreightTotal

public java.math.BigDecimal getFreightTotal()

setFreightTotal

public void setFreightTotal(java.math.BigDecimal freightTotal)

getGrandTotal

public java.math.BigDecimal getGrandTotal()

setGrandTotal

public void setGrandTotal(java.math.BigDecimal grandTotal)

getNetTotal

public java.math.BigDecimal getNetTotal()

setNetTotal

public void setNetTotal(java.math.BigDecimal netTotal)

getSubTotal

public java.math.BigDecimal getSubTotal()

setSubTotal

public void setSubTotal(java.math.BigDecimal subTotal)

getTaxTotal

public java.math.BigDecimal getTaxTotal()

setTaxTotal

public void setTaxTotal(java.math.BigDecimal taxTotal)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ARTaxForZipcodeListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ARTaxForZipcodeListResult

java.lang.Object
    extended by  bb.common.ARTaxForZipcodeListResult
All Implemented Interfaces:
java.io.Serializable
public class ARTaxForZipcodeListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_CUSTOMERNAME
static java.lang.String | ORDER_BY_ZIPCODE
Constructor Summary
ARTaxForZipcodeListResult()
Method Summary
int | getAcount()
java.lang.String | getCurrency()
java.lang.String | getCustomerId()
java.lang.String | getCustomerName()
java.math.BigDecimal | getTotaltax()
java.lang.String | getZipcode()
void | setAcount(int acount)
void | setCurrency(java.lang.String currency)
void | setCustomerId(java.lang.String customerId)
void | setCustomerName(java.lang.String customerName)
void | setTotaltax(java.math.BigDecimal totaltax)
void | setZipcode(java.lang.String zipcode)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_CUSTOMERNAME

public static final java.lang.String ORDER_BY_CUSTOMERNAME
See Also:
Constant Field Values

ORDER_BY_ZIPCODE

public static final java.lang.String ORDER_BY_ZIPCODE
See Also:
Constant Field Values
Constructor Detail

ARTaxForZipcodeListResult

public ARTaxForZipcodeListResult()
Method Detail

getCurrency

public java.lang.String getCurrency()

getCustomerName

public java.lang.String getCustomerName()

setCustomerId

public void setCustomerId(java.lang.String customerId)

setCurrency

public void setCurrency(java.lang.String currency)

setCustomerName

public void setCustomerName(java.lang.String customerName)

getCustomerId

public java.lang.String getCustomerId()

getAcount

public int getAcount()

setAcount

public void setAcount(int acount)

getTotaltax

public java.math.BigDecimal getTotaltax()

setTotaltax

public void setTotaltax(java.math.BigDecimal totaltax)

getZipcode

public java.lang.String getZipcode()

setZipcode

public void setZipcode(java.lang.String zipcode)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AssetAddOrDisposalsReport

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AssetAddOrDisposalsReport

java.lang.Object
    extended by  bb.common.AssetAddOrDisposalsReport
All Implemented Interfaces:
java.io.Serializable
public class AssetAddOrDisposalsReport
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACCMDEPRECIATECOST
static java.lang.String | ORDER_BY_ACQUISITIONCOST
static java.lang.String | ORDER_BY_ACQUISITIONDATE
static java.lang.String | ORDER_BY_ASSETNUMBER
static java.lang.String | ORDER_BY_ASSETTYPE
static java.lang.String | ORDER_BY_DEPARTMENTID
static java.lang.String | ORDER_BY_DEPRECIATEENDDATE
static java.lang.String | ORDER_BY_DEPRECIATESTARTDATE
static java.lang.String | ORDER_BY_DEPRECIATESTATUS
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_INITIALDEPRECIATECOST
static java.lang.String | ORDER_BY_LOCATION
static java.lang.String | ORDER_BY_NETSALVAGE
static java.lang.String | ORDER_BY_QUANTITY
Constructor Summary
AssetAddOrDisposalsReport()
default constructor
Method Summary
java.math.BigDecimal | getAccmDepreciateCost()
java.math.BigDecimal | getAcquisitionCost()
java.util.Date | getAcquisitionDate()
java.lang.String | getAssetNumber()
java.lang.String | getAssetType()
java.lang.String | getDepartmentID()
java.util.Date | getDepreciateEndDate()
java.util.Date | getDepreciateStartDate()
java.lang.String | getDepreciateStatus()
java.lang.String | getDescription()
java.math.BigDecimal | getInitialDepreciateCost()
java.lang.String | getLocation()
java.math.BigDecimal | getNetBookValue()
java.math.BigDecimal | getNetSalvage()
java.math.BigDecimal | getQuantity()
void | setAccmDepreciateCost(java.math.BigDecimal accmDepreciateCost)
void | setAcquisitionCost(java.math.BigDecimal acquisitionCost)
void | setAcquisitionDate(java.util.Date acquisitionDate)
void | setAssetNumber(java.lang.String assetNumber)
void | setAssetType(java.lang.String assetType)
void | setDepartmentID(java.lang.String departmentID)
void | setDepreciateEndDate(java.util.Date depreciateEndDate)
void | setDepreciateStartDate(java.util.Date depreciateStartDate)
void | setDepreciateStatus(java.lang.String depreciateStatus)
void | setDescription(java.lang.String description)
void | setInitialDepreciateCost(java.math.BigDecimal initialDepreciateCost)
void | setLocation(java.lang.String location)
void | setNetBookValue(java.math.BigDecimal netBookValue)
void | setNetSalvage(java.math.BigDecimal netSalvage)
void | setQuantity(java.math.BigDecimal quantity)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_ASSETNUMBER

public static final java.lang.String ORDER_BY_ASSETNUMBER
See Also:
Constant Field Values

ORDER_BY_ASSETTYPE

public static final java.lang.String ORDER_BY_ASSETTYPE
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_QUANTITY

public static final java.lang.String ORDER_BY_QUANTITY
See Also:
Constant Field Values

ORDER_BY_DEPRECIATESTARTDATE

public static final java.lang.String ORDER_BY_DEPRECIATESTARTDATE
See Also:
Constant Field Values

ORDER_BY_DEPRECIATEENDDATE

public static final java.lang.String ORDER_BY_DEPRECIATEENDDATE
See Also:
Constant Field Values

ORDER_BY_ACQUISITIONCOST

public static final java.lang.String ORDER_BY_ACQUISITIONCOST
See Also:
Constant Field Values

ORDER_BY_NETSALVAGE

public static final java.lang.String ORDER_BY_NETSALVAGE
See Also:
Constant Field Values

ORDER_BY_INITIALDEPRECIATECOST

public static final java.lang.String ORDER_BY_INITIALDEPRECIATECOST
See Also:
Constant Field Values

ORDER_BY_ACQUISITIONDATE

public static final java.lang.String ORDER_BY_ACQUISITIONDATE
See Also:
Constant Field Values

ORDER_BY_DEPRECIATESTATUS

public static final java.lang.String ORDER_BY_DEPRECIATESTATUS
See Also:
Constant Field Values

ORDER_BY_DEPARTMENTID

public static final java.lang.String ORDER_BY_DEPARTMENTID
See Also:
Constant Field Values

ORDER_BY_LOCATION

public static final java.lang.String ORDER_BY_LOCATION
See Also:
Constant Field Values

ORDER_BY_ACCMDEPRECIATECOST

public static final java.lang.String ORDER_BY_ACCMDEPRECIATECOST
See Also:
Constant Field Values
Constructor Detail

AssetAddOrDisposalsReport

public AssetAddOrDisposalsReport()
default constructor

Method Detail

getDepreciateStatus

public java.lang.String getDepreciateStatus()

setDepreciateStatus

public void setDepreciateStatus(java.lang.String depreciateStatus)

getAssetType

public java.lang.String getAssetType()

setAssetType

public void setAssetType(java.lang.String assetType)

getAcquisitionCost

public java.math.BigDecimal getAcquisitionCost()

setAcquisitionCost

public void setAcquisitionCost(java.math.BigDecimal acquisitionCost)

getAcquisitionDate

public java.util.Date getAcquisitionDate()

setAcquisitionDate

public void setAcquisitionDate(java.util.Date acquisitionDate)

getAssetNumber

public java.lang.String getAssetNumber()

setAssetNumber

public void setAssetNumber(java.lang.String assetNumber)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getAccmDepreciateCost

public java.math.BigDecimal getAccmDepreciateCost()

setAccmDepreciateCost

public void setAccmDepreciateCost(java.math.BigDecimal accmDepreciateCost)

getDepreciateEndDate

public java.util.Date getDepreciateEndDate()

setDepreciateEndDate

public void setDepreciateEndDate(java.util.Date depreciateEndDate)

getDepreciateStartDate

public java.util.Date getDepreciateStartDate()

setDepreciateStartDate

public void setDepreciateStartDate(java.util.Date depreciateStartDate)

getInitialDepreciateCost

public java.math.BigDecimal getInitialDepreciateCost()

setInitialDepreciateCost

public void setInitialDepreciateCost(java.math.BigDecimal initialDepreciateCost)

getNetSalvage

public java.math.BigDecimal getNetSalvage()

setNetSalvage

public void setNetSalvage(java.math.BigDecimal netSalvage)

getNetBookValue

public java.math.BigDecimal getNetBookValue()

setNetBookValue

public void setNetBookValue(java.math.BigDecimal netBookValue)

getDepartmentID

public java.lang.String getDepartmentID()

setDepartmentID

public void setDepartmentID(java.lang.String departmentID)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AssetAmortizationExpenseAccountPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AssetAmortizationExpenseAccountPK

java.lang.Object
    extended by  bb.common.AssetAmortizationExpenseAccountPK
All Implemented Interfaces:
java.io.Serializable
public class AssetAmortizationExpenseAccountPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AssetAmortizationExpenseAccountPK()
AssetAmortizationExpenseAccountPK(java.lang.String assetNumber, java.lang.String item)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAssetNumber()
java.lang.String | getItem()
int | hashCode()
void | setAssetNumber(java.lang.String assetNumber)
void | setItem(java.lang.String item)
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AssetAmortizationExpenseAccountPK

public AssetAmortizationExpenseAccountPK()

AssetAmortizationExpenseAccountPK

public AssetAmortizationExpenseAccountPK(java.lang.String assetNumber,
                                         java.lang.String item)
Method Detail

getAssetNumber

public java.lang.String getAssetNumber()

setAssetNumber

public void setAssetNumber(java.lang.String assetNumber)

getItem

public java.lang.String getItem()

setItem

public void setItem(java.lang.String item)

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AssetAmortizationExpenseAccountVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AssetAmortizationExpenseAccountVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AssetAmortizationExpenseAccountVO
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<AssetAmortizationExpenseAccountVO>
public class AssetAmortizationExpenseAccountVO
extends VO
implements java.io.Serializable, java.lang.Comparable<AssetAmortizationExpenseAccountVO>

See Also:
Serialized Form

Constructor Summary
AssetAmortizationExpenseAccountVO()
Method Summary
int | compareTo(AssetAmortizationExpenseAccountVO o)
boolean | equals(java.lang.Object other)
java.lang.String | getAccount()
java.lang.String | getCompanyUnit()
java.math.BigDecimal | getPercent()
AssetAmortizationExpenseAccountPK | getPk()
int | hashCode()
void | setAccount(java.lang.String account)
void | setCompanyUnit(java.lang.String companyUnit)
void | setPercent(java.math.BigDecimal percent)
void | setPk(AssetAmortizationExpenseAccountPK pk)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AssetAmortizationExpenseAccountVO

public AssetAmortizationExpenseAccountVO()
Method Detail

getPk

public AssetAmortizationExpenseAccountPK getPk()

setPk

public void setPk(AssetAmortizationExpenseAccountPK pk)

getAccount

public java.lang.String getAccount()

setAccount

public void setAccount(java.lang.String account)

getCompanyUnit

public java.lang.String getCompanyUnit()

setCompanyUnit

public void setCompanyUnit(java.lang.String companyUnit)

getPercent

public java.math.BigDecimal getPercent()

setPercent

public void setPercent(java.math.BigDecimal percent)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

compareTo

public int compareTo(AssetAmortizationExpenseAccountVO o)
Specified by:
compareTo in interface java.lang.Comparable<AssetAmortizationExpenseAccountVO>
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AssetDepreciateDetailReport

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AssetDepreciateDetailReport

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AssetDepreciateDetailReport
All Implemented Interfaces:
java.io.Serializable
public class AssetDepreciateDetailReport
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACQUISITIONCOST
static java.lang.String | ORDER_BY_ASSETTYPE
static java.lang.String | ORDER_BY_DEPARTMENTID
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_PK
static java.lang.String | ORDER_BY_QUANTITY
Constructor Summary
AssetDepreciateDetailReport()
default constructor
Method Summary
java.math.BigDecimal | getAcquisitionCost()
java.lang.String | getAssetNumber()
java.lang.String | getAssetType()
java.math.BigDecimal | getCurrentYearDepreciateTotal()
java.math.BigDecimal | getCurrentYearDepreciationAccm()
java.util.Date | getDatePaid()
java.lang.String | getDepartmentID()
java.util.Map<java.lang.String,java.math.BigDecimal> | getDepreciate()
java.math.BigDecimal | getDepreciatedAccm()
java.util.Date | getDepreciateEndDate()
java.util.Date | getDepreciateStartDate()
java.lang.String | getDescription()
java.math.BigDecimal | getEstimateDepreciate()
java.math.BigDecimal | getInitialDepreciateCost()
java.math.BigDecimal | getLastYearDepreciationAccm()
java.math.BigDecimal | getMonthDepreciationRate()
java.math.BigDecimal | getNetSalvage()
java.math.BigDecimal | getQuantity()
java.lang.String | getStatus()
java.math.BigDecimal | getUndepreciatedBalance()
int | getUsingLife()
void | setAcquisitionCost(java.math.BigDecimal acquisitionCost)
void | setAssetNumber(java.lang.String assetNumber)
void | setAssetType(java.lang.String assetType)
void | setCurrentYearDepreciateTotal(java.math.BigDecimal currentYearDepreciateTotal)
void | setCurrentYearDepreciationAccm(java.math.BigDecimal currentYearDepreciationAccm)
void | setDatePaid(java.util.Date datePaid)
void | setDepartmentID(java.lang.String departmentID)
void | setDepreciate(java.util.Map<java.lang.String,java.math.BigDecimal> depreciate)
void | setDepreciatedAccm(java.math.BigDecimal depreciatedAccm)
void | setDepreciateEndDate(java.util.Date depreciateEndDate)
void | setDepreciateStartDate(java.util.Date depreciateStartDate)
void | setDescription(java.lang.String description)
void | setEstimateDepreciate(java.math.BigDecimal estimateDepreciate)
void | setInitialDepreciateCost(java.math.BigDecimal initialDepreciateCost)
void | setLastYearDepreciationAccm(java.math.BigDecimal lastYearDepreciationAccm)
void | setMonthDepreciationRate(java.math.BigDecimal monthDepreciationRate)
void | setNetSalvage(java.math.BigDecimal netSalvage)
void | setQuantity(java.math.BigDecimal quantity)
void | setStatus(java.lang.String status)
void | setUndepreciatedBalance(java.math.BigDecimal undepreciatedBalance)
void | setUsingLife(int usingLife)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PK

public static final java.lang.String ORDER_BY_PK
See Also:
Constant Field Values

ORDER_BY_ASSETTYPE

public static final java.lang.String ORDER_BY_ASSETTYPE
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_QUANTITY

public static final java.lang.String ORDER_BY_QUANTITY
See Also:
Constant Field Values

ORDER_BY_DEPARTMENTID

public static final java.lang.String ORDER_BY_DEPARTMENTID
See Also:
Constant Field Values

ORDER_BY_ACQUISITIONCOST

public static final java.lang.String ORDER_BY_ACQUISITIONCOST
See Also:
Constant Field Values
Constructor Detail

AssetDepreciateDetailReport

public AssetDepreciateDetailReport()
default constructor

Method Detail

getAssetType

public java.lang.String getAssetType()

setAssetType

public void setAssetType(java.lang.String assetType)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getAcquisitionCost

public java.math.BigDecimal getAcquisitionCost()

setAcquisitionCost

public void setAcquisitionCost(java.math.BigDecimal acquisitionCost)

getDepartmentID

public java.lang.String getDepartmentID()

setDepartmentID

public void setDepartmentID(java.lang.String departmentID)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getMonthDepreciationRate

public java.math.BigDecimal getMonthDepreciationRate()

setMonthDepreciationRate

public void setMonthDepreciationRate(java.math.BigDecimal monthDepreciationRate)

getAssetNumber

public java.lang.String getAssetNumber()

setAssetNumber

public void setAssetNumber(java.lang.String assetNumber)

getUsingLife

public int getUsingLife()

setUsingLife

public void setUsingLife(int usingLife)

getDepreciate

public java.util.Map<java.lang.String,java.math.BigDecimal> getDepreciate()

setDepreciate

public void setDepreciate(java.util.Map<java.lang.String,java.math.BigDecimal> depreciate)

getCurrentYearDepreciationAccm

public java.math.BigDecimal getCurrentYearDepreciationAccm()

setCurrentYearDepreciationAccm

public void setCurrentYearDepreciationAccm(java.math.BigDecimal currentYearDepreciationAccm)

getEstimateDepreciate

public java.math.BigDecimal getEstimateDepreciate()

setEstimateDepreciate

public void setEstimateDepreciate(java.math.BigDecimal estimateDepreciate)

getLastYearDepreciationAccm

public java.math.BigDecimal getLastYearDepreciationAccm()

setLastYearDepreciationAccm

public void setLastYearDepreciationAccm(java.math.BigDecimal lastYearDepreciationAccm)

getUndepreciatedBalance

public java.math.BigDecimal getUndepreciatedBalance()

setUndepreciatedBalance

public void setUndepreciatedBalance(java.math.BigDecimal undepreciatedBalance)

getCurrentYearDepreciateTotal

public java.math.BigDecimal getCurrentYearDepreciateTotal()

setCurrentYearDepreciateTotal

public void setCurrentYearDepreciateTotal(java.math.BigDecimal currentYearDepreciateTotal)

getDepreciatedAccm

public java.math.BigDecimal getDepreciatedAccm()

setDepreciatedAccm

public void setDepreciatedAccm(java.math.BigDecimal depreciatedAccm)

getInitialDepreciateCost

public java.math.BigDecimal getInitialDepreciateCost()

setInitialDepreciateCost

public void setInitialDepreciateCost(java.math.BigDecimal initialDepreciateCost)

getNetSalvage

public java.math.BigDecimal getNetSalvage()

setNetSalvage

public void setNetSalvage(java.math.BigDecimal netSalvage)

getDatePaid

public java.util.Date getDatePaid()

setDatePaid

public void setDatePaid(java.util.Date datePaid)

getDepreciateStartDate

public java.util.Date getDepreciateStartDate()

setDepreciateStartDate

public void setDepreciateStartDate(java.util.Date depreciateStartDate)

getDepreciateEndDate

public java.util.Date getDepreciateEndDate()

setDepreciateEndDate

public void setDepreciateEndDate(java.util.Date depreciateEndDate)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AssetDepreciatePK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AssetDepreciatePK

java.lang.Object
    extended by  bb.common.AssetDepreciatePK
All Implemented Interfaces:
java.io.Serializable
public class AssetDepreciatePK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
AssetDepreciatePK()
default constructor
AssetDepreciatePK(java.lang.String assetNumber, java.lang.String month)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAssetNumber()
java.lang.String | getMonth()
int | hashCode()
void | setAssetNumber(java.lang.String assetNumber)
void | setMonth(java.lang.String month)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

AssetDepreciatePK

public AssetDepreciatePK(java.lang.String assetNumber,
                         java.lang.String month)
full constructor

AssetDepreciatePK

public AssetDepreciatePK()
default constructor

Method Detail

getMonth

public java.lang.String getMonth()

setMonth

public void setMonth(java.lang.String month)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getAssetNumber

public java.lang.String getAssetNumber()

setAssetNumber

public void setAssetNumber(java.lang.String assetNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AssetDepreciateVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AssetDepreciateVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AssetDepreciateVO
All Implemented Interfaces:
java.io.Serializable
public class AssetDepreciateVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACQUISITIONCOST
static java.lang.String | ORDER_BY_amortizationExpenseAccount
static java.lang.String | ORDER_BY_ASSETTYPE
static java.lang.String | ORDER_BY_CURRENTMONTHDEPRECIATE
static java.lang.String | ORDER_BY_DEPARTMENTID
static java.lang.String | ORDER_BY_depreciatedAccm
static java.lang.String | ORDER_BY_DEPRECIATESTATUS
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_GLCATEGORY
static java.lang.String | ORDER_BY_initialDepreciateCost
static java.lang.String | ORDER_BY_LASTMONTHDEPRECIATE
static java.lang.String | ORDER_BY_location
static java.lang.String | ORDER_BY_month
static java.lang.String | ORDER_BY_monthDepreciationRate
static java.lang.String | ORDER_BY_netSalvage
static java.lang.String | ORDER_BY_QUANTITY
static java.lang.String | ORDER_BY_USINGSTATUS
Constructor Summary
AssetDepreciateVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAccumulatedDeprAccount()
java.math.BigDecimal | getAcquisitionCost()
java.lang.String | getAmortizationExpenseAccount()
java.util.Set<AssetAmortizationExpenseAccountVO> | getAmortizationExpenseAccounts()
java.lang.String | getAssetType()
java.lang.Integer | getCategorySequence()
java.lang.String | getCompanyUnitOfAmorExpenseAcc()
java.lang.String | getCoUnitOfAccumulatedDeprAcc()
java.math.BigDecimal | getCurrentMonthDepreciate()
java.lang.String | getDepartmentID()
java.math.BigDecimal | getDepreciatedAccm()
java.util.Date | getDepreciateDate()
java.lang.String | getDepreciateStatus()
java.lang.String | getDescription()
java.math.BigDecimal | getEstimateNetSalRate()
java.lang.String | getGlCategory()
java.math.BigDecimal | getInitialDepreciateCost()
int | getLastChangeTimes()
java.math.BigDecimal | getLastYeardepreciatedAccm()
java.lang.String | getLocation()
java.math.BigDecimal | getMonthDepreciationRate()
java.math.BigDecimal | getNetSalvage()
AssetDepreciatePK | getPk()
java.lang.String | getTransactionNumber()
java.math.BigDecimal | getUnDepreciatedAccm()
java.math.BigDecimal | getUndepreciatedBalance()
int | getUsingLife()
java.lang.String | getUsingStatus()
int | hashCode()
void | setAccumulatedDeprAccount(java.lang.String accumulatedDeprAccount)
void | setAcquisitionCost(java.math.BigDecimal acquisitionCost)
void | setAmortizationExpenseAccount(java.lang.String amortizationExpenseAccount)
void | setAmortizationExpenseAccounts(java.util.Set<AssetAmortizationExpenseAccountVO> amortizationExpenseAccounts)
void | setAssetType(java.lang.String assetType)
void | setCategorySequence(java.lang.Integer categorySequence)
void | setCompanyUnitOfAmorExpenseAcc(java.lang.String companyUnitOfAmorExpenseAcc)
void | setCoUnitOfAccumulatedDeprAcc(java.lang.String coUnitOfAccumulatedDeprAcc)
void | setCurrentMonthDepreciate(java.math.BigDecimal currentMonthDepreciate)
void | setDepartmentID(java.lang.String departmentID)
void | setDepreciatedAccm(java.math.BigDecimal depreciatedAccm)
void | setDepreciateDate(java.util.Date depreciateDate)
void | setDepreciateStatus(java.lang.String depreciateStatus)
void | setDescription(java.lang.String description)
void | setEstimateNetSalRate(java.math.BigDecimal estimateNetSalRate)
void | setGlCategory(java.lang.String glCategory)
void | setInitialDepreciateCost(java.math.BigDecimal initialDepreciateCost)
void | setLastChangeTimes(int lastChangeTimes)
void | setLastYeardepreciatedAccm(java.math.BigDecimal lastYeardepreciatedAccm)
void | setLocation(java.lang.String location)
void | setMonthDepreciationRate(java.math.BigDecimal monthDepreciationRate)
void | setNetSalvage(java.math.BigDecimal netSalvage)
void | setPk(AssetDepreciatePK pk)
void | setTransactionNumber(java.lang.String transactionNumber)
void | setUnDepreciatedAccm(java.math.BigDecimal unDepreciatedAccm)
void | setUndepreciatedBalance(java.math.BigDecimal undepreciatedBalance)
void | setUsingLife(int usingLife)
void | setUsingStatus(java.lang.String usingStatus)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ASSETTYPE

public static final java.lang.String ORDER_BY_ASSETTYPE
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_QUANTITY

public static final java.lang.String ORDER_BY_QUANTITY
See Also:
Constant Field Values

ORDER_BY_USINGSTATUS

public static final java.lang.String ORDER_BY_USINGSTATUS
See Also:
Constant Field Values

ORDER_BY_DEPARTMENTID

public static final java.lang.String ORDER_BY_DEPARTMENTID
See Also:
Constant Field Values

ORDER_BY_DEPRECIATESTATUS

public static final java.lang.String ORDER_BY_DEPRECIATESTATUS
See Also:
Constant Field Values

ORDER_BY_ACQUISITIONCOST

public static final java.lang.String ORDER_BY_ACQUISITIONCOST
See Also:
Constant Field Values

ORDER_BY_LASTMONTHDEPRECIATE

public static final java.lang.String ORDER_BY_LASTMONTHDEPRECIATE
See Also:
Constant Field Values

ORDER_BY_CURRENTMONTHDEPRECIATE

public static final java.lang.String ORDER_BY_CURRENTMONTHDEPRECIATE
See Also:
Constant Field Values

ORDER_BY_location

public static final java.lang.String ORDER_BY_location
See Also:
Constant Field Values

ORDER_BY_month

public static final java.lang.String ORDER_BY_month
See Also:
Constant Field Values

ORDER_BY_amortizationExpenseAccount

public static final java.lang.String ORDER_BY_amortizationExpenseAccount
See Also:
Constant Field Values

ORDER_BY_monthDepreciationRate

public static final java.lang.String ORDER_BY_monthDepreciationRate
See Also:
Constant Field Values

ORDER_BY_initialDepreciateCost

public static final java.lang.String ORDER_BY_initialDepreciateCost
See Also:
Constant Field Values

ORDER_BY_netSalvage

public static final java.lang.String ORDER_BY_netSalvage
See Also:
Constant Field Values

ORDER_BY_depreciatedAccm

public static final java.lang.String ORDER_BY_depreciatedAccm
See Also:
Constant Field Values

ORDER_BY_GLCATEGORY

public static final java.lang.String ORDER_BY_GLCATEGORY
See Also:
Constant Field Values
Constructor Detail

AssetDepreciateVO

public AssetDepreciateVO()
default constructor

Method Detail

getDepreciateStatus

public java.lang.String getDepreciateStatus()

setDepreciateStatus

public void setDepreciateStatus(java.lang.String depreciateStatus)

getUsingStatus

public java.lang.String getUsingStatus()

setUsingStatus

public void setUsingStatus(java.lang.String usingStatus)

getAssetType

public java.lang.String getAssetType()

setAssetType

public void setAssetType(java.lang.String assetType)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getAcquisitionCost

public java.math.BigDecimal getAcquisitionCost()

setAcquisitionCost

public void setAcquisitionCost(java.math.BigDecimal acquisitionCost)

getLastChangeTimes

public int getLastChangeTimes()

setLastChangeTimes

public void setLastChangeTimes(int lastChangeTimes)

getDepartmentID

public java.lang.String getDepartmentID()

setDepartmentID

public void setDepartmentID(java.lang.String departmentID)

getCurrentMonthDepreciate

public java.math.BigDecimal getCurrentMonthDepreciate()

setCurrentMonthDepreciate

public void setCurrentMonthDepreciate(java.math.BigDecimal currentMonthDepreciate)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getPk

public AssetDepreciatePK getPk()

setPk

public void setPk(AssetDepreciatePK pk)

getMonthDepreciationRate

public java.math.BigDecimal getMonthDepreciationRate()

setMonthDepreciationRate

public void setMonthDepreciationRate(java.math.BigDecimal monthDepreciationRate)

getTransactionNumber

public java.lang.String getTransactionNumber()

setTransactionNumber

public void setTransactionNumber(java.lang.String transactionNumber)

getAmortizationExpenseAccount

public java.lang.String getAmortizationExpenseAccount()

setAmortizationExpenseAccount

public void setAmortizationExpenseAccount(java.lang.String amortizationExpenseAccount)

getUndepreciatedBalance

public java.math.BigDecimal getUndepreciatedBalance()

setUndepreciatedBalance

public void setUndepreciatedBalance(java.math.BigDecimal undepreciatedBalance)

getDepreciatedAccm

public java.math.BigDecimal getDepreciatedAccm()

setDepreciatedAccm

public void setDepreciatedAccm(java.math.BigDecimal depreciatedAccm)

getNetSalvage

public java.math.BigDecimal getNetSalvage()

setNetSalvage

public void setNetSalvage(java.math.BigDecimal netSalvage)

getInitialDepreciateCost

public java.math.BigDecimal getInitialDepreciateCost()

setInitialDepreciateCost

public void setInitialDepreciateCost(java.math.BigDecimal initialDepreciateCost)

getDepreciateDate

public java.util.Date getDepreciateDate()

setDepreciateDate

public void setDepreciateDate(java.util.Date depreciateDate)

getLastYeardepreciatedAccm

public java.math.BigDecimal getLastYeardepreciatedAccm()

setLastYeardepreciatedAccm

public void setLastYeardepreciatedAccm(java.math.BigDecimal lastYeardepreciatedAccm)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getCompanyUnitOfAmorExpenseAcc

public java.lang.String getCompanyUnitOfAmorExpenseAcc()

setCompanyUnitOfAmorExpenseAcc

public void setCompanyUnitOfAmorExpenseAcc(java.lang.String companyUnitOfAmorExpenseAcc)

getCategorySequence

public java.lang.Integer getCategorySequence()

setCategorySequence

public void setCategorySequence(java.lang.Integer categorySequence)

getGlCategory

public java.lang.String getGlCategory()

setGlCategory

public void setGlCategory(java.lang.String glCategory)

getAccumulatedDeprAccount

public java.lang.String getAccumulatedDeprAccount()

setAccumulatedDeprAccount

public void setAccumulatedDeprAccount(java.lang.String accumulatedDeprAccount)

getCoUnitOfAccumulatedDeprAcc

public java.lang.String getCoUnitOfAccumulatedDeprAcc()

setCoUnitOfAccumulatedDeprAcc

public void setCoUnitOfAccumulatedDeprAcc(java.lang.String coUnitOfAccumulatedDeprAcc)

getAmortizationExpenseAccounts

public java.util.Set<AssetAmortizationExpenseAccountVO> getAmortizationExpenseAccounts()

setAmortizationExpenseAccounts

public void setAmortizationExpenseAccounts(java.util.Set<AssetAmortizationExpenseAccountVO> amortizationExpenseAccounts)

getUsingLife

public int getUsingLife()

setUsingLife

public void setUsingLife(int usingLife)

getEstimateNetSalRate

public java.math.BigDecimal getEstimateNetSalRate()

setEstimateNetSalRate

public void setEstimateNetSalRate(java.math.BigDecimal estimateNetSalRate)

getUnDepreciatedAccm

public java.math.BigDecimal getUnDepreciatedAccm()

setUnDepreciatedAccm

public void setUnDepreciatedAccm(java.math.BigDecimal unDepreciatedAccm)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AssetReportSumResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AssetReportSumResult

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AssetReportSumResult
All Implemented Interfaces:
java.io.Serializable
public class AssetReportSumResult
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AssetReportSumResult()
Method Summary
java.math.BigDecimal | getAcquisitionCost()
java.math.BigDecimal | getCurrentMonthDepreciate()
java.math.BigDecimal | getDepreciatedAccm()
java.math.BigDecimal | getInitialDepreciateCost()
java.math.BigDecimal | getNetSalvage()
java.math.BigDecimal | getQty()
void | setAcquisitionCost(java.math.BigDecimal acquisitionCost)
void | setCurrentMonthDepreciate(java.math.BigDecimal currentMonthDepreciate)
void | setDepreciatedAccm(java.math.BigDecimal depreciatedAccm)
void | setInitialDepreciateCost(java.math.BigDecimal initialDepreciateCost)
void | setNetSalvage(java.math.BigDecimal netSalvage)
void | setQty(java.math.BigDecimal qty)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AssetReportSumResult

public AssetReportSumResult()
Method Detail

getNetSalvage

public java.math.BigDecimal getNetSalvage()

setNetSalvage

public void setNetSalvage(java.math.BigDecimal netSalvage)

getAcquisitionCost

public java.math.BigDecimal getAcquisitionCost()

setAcquisitionCost

public void setAcquisitionCost(java.math.BigDecimal acquisitionCost)

getCurrentMonthDepreciate

public java.math.BigDecimal getCurrentMonthDepreciate()

setCurrentMonthDepreciate

public void setCurrentMonthDepreciate(java.math.BigDecimal currentMonthDepreciate)

getDepreciatedAccm

public java.math.BigDecimal getDepreciatedAccm()

setDepreciatedAccm

public void setDepreciatedAccm(java.math.BigDecimal depreciatedAccm)

getInitialDepreciateCost

public java.math.BigDecimal getInitialDepreciateCost()

setInitialDepreciateCost

public void setInitialDepreciateCost(java.math.BigDecimal initialDepreciateCost)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AssetTypeVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AssetTypeVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AssetTypeVO
All Implemented Interfaces:
java.io.Serializable
public class AssetTypeVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ID
static java.lang.String | ORDER_BY_NAME
Constructor Summary
AssetTypeVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getId()
java.util.Date | getLastChangeDate()
java.lang.Integer | getLastChangeTimes()
java.lang.String | getLastChangeUser()
java.lang.String | getName()
int | hashCode()
void | setId(java.lang.String id)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTimes(java.lang.Integer lastChangeTimes)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setName(java.lang.String name)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ID

public static final java.lang.String ORDER_BY_ID
See Also:
Constant Field Values

ORDER_BY_NAME

public static final java.lang.String ORDER_BY_NAME
See Also:
Constant Field Values
Constructor Detail

AssetTypeVO

public AssetTypeVO()
Method Detail

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeTimes

public java.lang.Integer getLastChangeTimes()

setLastChangeTimes

public void setLastChangeTimes(java.lang.Integer lastChangeTimes)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AssetUsagePK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AssetUsagePK

java.lang.Object
    extended by  bb.common.AssetUsagePK
All Implemented Interfaces:
java.io.Serializable
public class AssetUsagePK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AssetUsagePK()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAssetNumber()
java.lang.Short | getIi()
int | hashCode()
void | setAssetNumber(java.lang.String assetNumber)
void | setIi(java.lang.Short ii)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

AssetUsagePK

public AssetUsagePK()
Method Detail

getIi

public java.lang.Short getIi()

setIi

public void setIi(java.lang.Short ii)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getAssetNumber

public java.lang.String getAssetNumber()

setAssetNumber

public void setAssetNumber(java.lang.String assetNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AssetUsageVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AssetUsageVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AssetUsageVO
All Implemented Interfaces:
java.io.Serializable
public class AssetUsageVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AssetUsageVO()
Method Summary
AssetUsagePK | getPk()
java.lang.String | getReceiveComment()
java.util.Date | getReceiveDate()
java.lang.String | getReceiveDepartment()
java.lang.String | getReceiveSign()
java.lang.String | getReturnComment()
java.util.Date | getReturnDate()
java.lang.String | getReturnDepartment()
java.lang.String | getReturnSign()
java.lang.String | getUser()
void | setPk(AssetUsagePK pk)
void | setReceiveComment(java.lang.String receiveComment)
void | setReceiveDate(java.util.Date receiveDate)
void | setReceiveDepartment(java.lang.String receiveDepartment)
void | setReceiveSign(java.lang.String receiveSign)
void | setReturnComment(java.lang.String returnComment)
void | setReturnDate(java.util.Date returnDate)
void | setReturnDepartment(java.lang.String returnDepartment)
void | setReturnSign(java.lang.String returnSign)
void | setUser(java.lang.String user)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AssetUsageVO

public AssetUsageVO()
Method Detail

getPk

public AssetUsagePK getPk()

setPk

public void setPk(AssetUsagePK pk)

getReceiveComment

public java.lang.String getReceiveComment()

setReceiveComment

public void setReceiveComment(java.lang.String receiveComment)

getReceiveDate

public java.util.Date getReceiveDate()

setReceiveDate

public void setReceiveDate(java.util.Date receiveDate)

getReceiveSign

public java.lang.String getReceiveSign()

setReceiveSign

public void setReceiveSign(java.lang.String receiveSign)

getReturnComment

public java.lang.String getReturnComment()

setReturnComment

public void setReturnComment(java.lang.String returnComment)

getReturnDate

public java.util.Date getReturnDate()

setReturnDate

public void setReturnDate(java.util.Date returnDate)

getReturnSign

public java.lang.String getReturnSign()

setReturnSign

public void setReturnSign(java.lang.String returnSign)

getUser

public java.lang.String getUser()

setUser

public void setUser(java.lang.String user)

getReceiveDepartment

public java.lang.String getReceiveDepartment()

setReceiveDepartment

public void setReceiveDepartment(java.lang.String receiveDepartment)

getReturnDepartment

public java.lang.String getReturnDepartment()

setReturnDepartment

public void setReturnDepartment(java.lang.String returnDepartment)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AssetVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AssetVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AssetVO
All Implemented Interfaces:
java.io.Serializable
public class AssetVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACQUISITIONCOST
static java.lang.String | ORDER_BY_ACQUISITIONDATE
static java.lang.String | ORDER_BY_AMORTIZATIONEXPENSEACCOUNT
static java.lang.String | ORDER_BY_ANNUALDEPRECIATIONRATE
static java.lang.String | ORDER_BY_ASSETNUMBER
static java.lang.String | ORDER_BY_ASSETTYPE
static java.lang.String | ORDER_BY_ASSETTYPE2
static java.lang.String | ORDER_BY_DEPARTMENTID
static java.lang.String | ORDER_BY_DEPRECIATEDACCM
static java.lang.String | ORDER_BY_DEPRECIATEDACCMMONTHS
static java.lang.String | ORDER_BY_DEPRECIATEDDATE
static java.lang.String | ORDER_BY_DEPRECIATEENDDATE
static java.lang.String | ORDER_BY_DEPRECIATESTARTDATE
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_ESTIMATENETSALRATE
static java.lang.String | ORDER_BY_GLACCOUNTNUMBER
static java.lang.String | ORDER_BY_INITIALDEPRECIATECOST
static java.lang.String | ORDER_BY_MONTHDEPRECIATIONRATE
Constructor Summary
AssetVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAccumulatedDeprAccount()
java.math.BigDecimal | getAcquisitionCost()
java.util.Date | getAcquisitionDate()
java.util.Date | getAdate()
java.lang.String | getAmortizationExpenseAccount()
java.util.Set<AssetAmortizationExpenseAccountVO> | getAmortizationExpenseAccounts()
java.math.BigDecimal | getAnnualDepreciationRate()
java.lang.String | getAssetNumber()
java.lang.String | getAssetStatus()
java.lang.String | getAssetType()
java.lang.String | getAssetType2()
java.lang.String | getAssignTo()
java.lang.String | getComments()
java.lang.String | getCompanyUnitOfAmorExpenseAcc()
java.lang.String | getCompanyUnitOfGlAcc()
java.lang.String | getCoUnitOfAccumulatedDeprAcc()
java.util.Date | getDatePaid()
java.lang.String | getDepartmentID()
java.math.BigDecimal | getDepreciatedAccm()
int | getDepreciatedAccmMonths()
java.math.BigDecimal | getDepreciatedCost()
java.util.Date | getDepreciateEndDate()
java.util.Date | getDepreciateStartDate()
java.lang.String | getDepreciateStatus()
java.util.Set | getDepreciations()
java.lang.String | getDepreciationType()
java.lang.String | getDescription()
java.math.BigDecimal | getEstimateNetSalRate()
java.lang.String | getForeignCurrency()
java.math.BigDecimal | getForeignCurrencyCost()
java.lang.String | getGlAccountNumber()
java.math.BigDecimal | getInitialDepreciateCost()
java.util.Date | getLastChangeDate()
int | getLastChangeTimes()
java.lang.String | getLastChangeUser()
java.lang.String | getLocation()
java.lang.String | getMfgCode()
java.lang.String | getMfgID()
java.lang.String | getModelNO()
java.math.BigDecimal | getMonthDepreciation()
java.math.BigDecimal | getMonthDepreciationRate()
java.math.BigDecimal | getNetSalvage()
java.math.BigDecimal | getNetValue()
java.lang.String | getOrigin()
java.lang.String | getProject()
java.lang.String | getPurchaseOrderNumber()
java.math.BigDecimal | getQuantity()
java.util.Date | getReceiveDate()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.lang.String | getSerialNumber()
java.lang.String | getStatus()
int | getUsingLife()
java.lang.String | getUsingStatus()
int | hashCode()
void | setAccumulatedDeprAccount(java.lang.String accumulatedDeprAccount)
void | setAcquisitionCost(java.math.BigDecimal acquisitionCost)
void | setAcquisitionDate(java.util.Date acquisitionDate)
void | setAdate(java.util.Date adate)
void | setAmortizationExpenseAccount(java.lang.String amortizationExpenseAccount)
void | setAmortizationExpenseAccounts(java.util.Set<AssetAmortizationExpenseAccountVO> amortizationExpenseAccounts)
void | setAnnualDepreciationRate(java.math.BigDecimal annualDepreciationRate)
void | setAssetNumber(java.lang.String assetNumber)
void | setAssetStatus(java.lang.String assetStatus)
void | setAssetType(java.lang.String assetType)
void | setAssetType2(java.lang.String assetType2)
void | setAssignTo(java.lang.String assignTo)
void | setComments(java.lang.String comments)
void | setCompanyUnitOfAmorExpenseAcc(java.lang.String companyUnitOfAmorExpenseAcc)
void | setCompanyUnitOfGlAcc(java.lang.String companyUnitOfGlAcc)
void | setCoUnitOfAccumulatedDeprAcc(java.lang.String coUnitOfAccumulatedDeprAcc)
void | setDatePaid(java.util.Date datePaid)
void | setDepartmentID(java.lang.String departmentID)
void | setDepreciatedAccm(java.math.BigDecimal depreciatedAccm)
void | setDepreciatedAccmMonths(int depreciatedAccmMonths)
void | setDepreciatedCost(java.math.BigDecimal depreciatedCost)
void | setDepreciateEndDate(java.util.Date depreciateEndDate)
void | setDepreciateStartDate(java.util.Date depreciateStartDate)
void | setDepreciateStatus(java.lang.String depreciateStatus)
void | setDepreciations(java.util.Set depreciations)
void | setDepreciationType(java.lang.String depreciationType)
void | setDescription(java.lang.String description)
void | setEstimateNetSalRate(java.math.BigDecimal estimateNetSalRate)
void | setForeignCurrency(java.lang.String foreignCurrency)
void | setForeignCurrencyCost(java.math.BigDecimal foreignCurrencyCost)
void | setGlAccountNumber(java.lang.String glAccountNumber)
void | setInitialDepreciateCost(java.math.BigDecimal initialDepreciateCost)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTimes(int lastChangeTimes)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLocation(java.lang.String location)
void | setMfgCode(java.lang.String mfgCode)
void | setMfgID(java.lang.String mfgID)
void | setModelNO(java.lang.String modelNO)
void | setMonthDepreciation(java.math.BigDecimal monthDepreciation)
void | setMonthDepreciationRate(java.math.BigDecimal monthDepreciationRate)
void | setNetSalvage(java.math.BigDecimal netSalvage)
void | setOrigin(java.lang.String origin)
void | setProject(java.lang.String project)
void | setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)
void | setQuantity(java.math.BigDecimal quantity)
void | setReceiveDate(java.util.Date receiveDate)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setSerialNumber(java.lang.String serialNumber)
void | setStatus(java.lang.String status)
void | setUsingLife(int usingLife)
void | setUsingStatus(java.lang.String usingStatus)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ASSETNUMBER

public static final java.lang.String ORDER_BY_ASSETNUMBER
See Also:
Constant Field Values

ORDER_BY_ASSETTYPE

public static final java.lang.String ORDER_BY_ASSETTYPE
See Also:
Constant Field Values

ORDER_BY_ASSETTYPE2

public static final java.lang.String ORDER_BY_ASSETTYPE2
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_ACQUISITIONDATE

public static final java.lang.String ORDER_BY_ACQUISITIONDATE
See Also:
Constant Field Values

ORDER_BY_DEPRECIATEDDATE

public static final java.lang.String ORDER_BY_DEPRECIATEDDATE
See Also:
Constant Field Values

ORDER_BY_DEPARTMENTID

public static final java.lang.String ORDER_BY_DEPARTMENTID
See Also:
Constant Field Values

ORDER_BY_ESTIMATENETSALRATE

public static final java.lang.String ORDER_BY_ESTIMATENETSALRATE
See Also:
Constant Field Values

ORDER_BY_ACQUISITIONCOST

public static final java.lang.String ORDER_BY_ACQUISITIONCOST
See Also:
Constant Field Values

ORDER_BY_MONTHDEPRECIATIONRATE

public static final java.lang.String ORDER_BY_MONTHDEPRECIATIONRATE
See Also:
Constant Field Values

ORDER_BY_ANNUALDEPRECIATIONRATE

public static final java.lang.String ORDER_BY_ANNUALDEPRECIATIONRATE
See Also:
Constant Field Values

ORDER_BY_DEPRECIATEDACCM

public static final java.lang.String ORDER_BY_DEPRECIATEDACCM
See Also:
Constant Field Values

ORDER_BY_INITIALDEPRECIATECOST

public static final java.lang.String ORDER_BY_INITIALDEPRECIATECOST
See Also:
Constant Field Values

ORDER_BY_DEPRECIATESTARTDATE

public static final java.lang.String ORDER_BY_DEPRECIATESTARTDATE
See Also:
Constant Field Values

ORDER_BY_DEPRECIATEENDDATE

public static final java.lang.String ORDER_BY_DEPRECIATEENDDATE
See Also:
Constant Field Values

ORDER_BY_GLACCOUNTNUMBER

public static final java.lang.String ORDER_BY_GLACCOUNTNUMBER
See Also:
Constant Field Values

ORDER_BY_AMORTIZATIONEXPENSEACCOUNT

public static final java.lang.String ORDER_BY_AMORTIZATIONEXPENSEACCOUNT
See Also:
Constant Field Values

ORDER_BY_DEPRECIATEDACCMMONTHS

public static final java.lang.String ORDER_BY_DEPRECIATEDACCMMONTHS
See Also:
Constant Field Values
Constructor Detail

AssetVO

public AssetVO()
Method Detail

getMonthDepreciation

public java.math.BigDecimal getMonthDepreciation()

setMonthDepreciation

public void setMonthDepreciation(java.math.BigDecimal monthDepreciation)

getNetValue

public java.math.BigDecimal getNetValue()

getDepreciateStatus

public java.lang.String getDepreciateStatus()

setDepreciateStatus

public void setDepreciateStatus(java.lang.String depreciateStatus)

getUsingStatus

public java.lang.String getUsingStatus()

setUsingStatus

public void setUsingStatus(java.lang.String usingStatus)

getAssetNumber

public java.lang.String getAssetNumber()

setAssetNumber

public void setAssetNumber(java.lang.String assetNumber)

getGlAccountNumber

public java.lang.String getGlAccountNumber()

setGlAccountNumber

public void setGlAccountNumber(java.lang.String glAccountNumber)

getAssetType

public java.lang.String getAssetType()

setAssetType

public void setAssetType(java.lang.String assetType)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getDepreciationType

public java.lang.String getDepreciationType()

setDepreciationType

public void setDepreciationType(java.lang.String depreciationType)

getSerialNumber

public java.lang.String getSerialNumber()

setSerialNumber

public void setSerialNumber(java.lang.String serialNumber)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getAcquisitionDate

public java.util.Date getAcquisitionDate()

setAcquisitionDate

public void setAcquisitionDate(java.util.Date acquisitionDate)

getAcquisitionCost

public java.math.BigDecimal getAcquisitionCost()

setAcquisitionCost

public void setAcquisitionCost(java.math.BigDecimal acquisitionCost)

getDepreciatedCost

public java.math.BigDecimal getDepreciatedCost()

setDepreciatedCost

public void setDepreciatedCost(java.math.BigDecimal depreciatedCost)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getLastChangeTimes

public int getLastChangeTimes()

setLastChangeTimes

public void setLastChangeTimes(int lastChangeTimes)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getUsingLife

public int getUsingLife()

setUsingLife

public void setUsingLife(int usingLife)

getMonthDepreciationRate

public java.math.BigDecimal getMonthDepreciationRate()

setMonthDepreciationRate

public void setMonthDepreciationRate(java.math.BigDecimal monthDepreciationRate)

getEstimateNetSalRate

public java.math.BigDecimal getEstimateNetSalRate()

setEstimateNetSalRate

public void setEstimateNetSalRate(java.math.BigDecimal estimateNetSalRate)

getAnnualDepreciationRate

public java.math.BigDecimal getAnnualDepreciationRate()

setAnnualDepreciationRate

public void setAnnualDepreciationRate(java.math.BigDecimal annualDepreciationRate)

getDepartmentID

public java.lang.String getDepartmentID()

setDepartmentID

public void setDepartmentID(java.lang.String departmentID)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getForeignCurrencyCost

public java.math.BigDecimal getForeignCurrencyCost()

setForeignCurrencyCost

public void setForeignCurrencyCost(java.math.BigDecimal foreignCurrencyCost)

getForeignCurrency

public java.lang.String getForeignCurrency()

setForeignCurrency

public void setForeignCurrency(java.lang.String foreignCurrency)

getPurchaseOrderNumber

public java.lang.String getPurchaseOrderNumber()

setPurchaseOrderNumber

public void setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)

getAmortizationExpenseAccount

public java.lang.String getAmortizationExpenseAccount()

setAmortizationExpenseAccount

public void setAmortizationExpenseAccount(java.lang.String amortizationExpenseAccount)

getDepreciateEndDate

public java.util.Date getDepreciateEndDate()

setDepreciateEndDate

public void setDepreciateEndDate(java.util.Date depreciateEndDate)

getDepreciateStartDate

public java.util.Date getDepreciateStartDate()

setDepreciateStartDate

public void setDepreciateStartDate(java.util.Date depreciateStartDate)

getNetSalvage

public java.math.BigDecimal getNetSalvage()

setNetSalvage

public void setNetSalvage(java.math.BigDecimal netSalvage)

getInitialDepreciateCost

public java.math.BigDecimal getInitialDepreciateCost()

setInitialDepreciateCost

public void setInitialDepreciateCost(java.math.BigDecimal initialDepreciateCost)

getDepreciations

public java.util.Set getDepreciations()

setDepreciations

public void setDepreciations(java.util.Set depreciations)

getDepreciatedAccm

public java.math.BigDecimal getDepreciatedAccm()

setDepreciatedAccm

public void setDepreciatedAccm(java.math.BigDecimal depreciatedAccm)

getCompanyUnitOfAmorExpenseAcc

public java.lang.String getCompanyUnitOfAmorExpenseAcc()

setCompanyUnitOfAmorExpenseAcc

public void setCompanyUnitOfAmorExpenseAcc(java.lang.String companyUnitOfAmorExpenseAcc)

getCompanyUnitOfGlAcc

public java.lang.String getCompanyUnitOfGlAcc()

setCompanyUnitOfGlAcc

public void setCompanyUnitOfGlAcc(java.lang.String companyUnitOfGlAcc)

getAssetStatus

public java.lang.String getAssetStatus()

setAssetStatus

public void setAssetStatus(java.lang.String assetStatus)

getAssignTo

public java.lang.String getAssignTo()

setAssignTo

public void setAssignTo(java.lang.String assignTo)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getDatePaid

public java.util.Date getDatePaid()

setDatePaid

public void setDatePaid(java.util.Date datePaid)

getMfgCode

public java.lang.String getMfgCode()

setMfgCode

public void setMfgCode(java.lang.String mfgCode)

getMfgID

public java.lang.String getMfgID()

setMfgID

public void setMfgID(java.lang.String mfgID)

getModelNO

public java.lang.String getModelNO()

setModelNO

public void setModelNO(java.lang.String modelNO)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

getReceiveDate

public java.util.Date getReceiveDate()

setReceiveDate

public void setReceiveDate(java.util.Date receiveDate)

getAccumulatedDeprAccount

public java.lang.String getAccumulatedDeprAccount()

setAccumulatedDeprAccount

public void setAccumulatedDeprAccount(java.lang.String accumulatedDeprAccount)

getCoUnitOfAccumulatedDeprAcc

public java.lang.String getCoUnitOfAccumulatedDeprAcc()

setCoUnitOfAccumulatedDeprAcc

public void setCoUnitOfAccumulatedDeprAcc(java.lang.String coUnitOfAccumulatedDeprAcc)

getAssetType2

public java.lang.String getAssetType2()

setAssetType2

public void setAssetType2(java.lang.String assetType2)

getAmortizationExpenseAccounts

public java.util.Set<AssetAmortizationExpenseAccountVO> getAmortizationExpenseAccounts()

setAmortizationExpenseAccounts

public void setAmortizationExpenseAccounts(java.util.Set<AssetAmortizationExpenseAccountVO> amortizationExpenseAccounts)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getDepreciatedAccmMonths

public int getDepreciatedAccmMonths()

setDepreciatedAccmMonths

public void setDepreciatedAccmMonths(int depreciatedAccmMonths)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AuditLogVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AuditLogVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AuditLogVO
All Implemented Interfaces:
java.io.Serializable
public class AuditLogVO
extends VO

See Also:
Serialized Form

Constructor Summary
AuditLogVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAuditBy()
java.util.Date | getAuditTime()
java.lang.Long | getIi()
int | hashCode()
void | setAuditBy(java.lang.String auditBy)
void | setAuditTime(java.util.Date auditTime)
void | setIi(java.lang.Long ii)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

AuditLogVO

public AuditLogVO()
Method Detail

setIi

public void setIi(java.lang.Long ii)

setAuditBy

public void setAuditBy(java.lang.String auditBy)

setAuditTime

public void setAuditTime(java.util.Date auditTime)

getIi

public java.lang.Long getIi()

getAuditBy

public java.lang.String getAuditBy()

getAuditTime

public java.util.Date getAuditTime()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AuditOnDemandResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AuditOnDemandResult

java.lang.Object
    extended by  bb.common.AuditOnDemandResult
All Implemented Interfaces:
java.io.Serializable
public class AuditOnDemandResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ONHANDQTY
static java.lang.String | ORDER_BY_PARTPK
Constructor Summary
AuditOnDemandResult()
Method Summary
java.math.BigDecimal | getAuditOndemand()
java.math.BigDecimal | getAuditOnhandQty()
java.math.BigDecimal | getAuditOnorder()
java.math.BigDecimal | getAuditQtrUsage()
java.math.BigDecimal | getAuditWip()
java.math.BigDecimal | getAuditYrUsage()
java.lang.String | getDescription()
java.math.BigDecimal | getOnhandQty()
PartPK | getPartPk()
java.math.BigDecimal | getSystemOndemand()
java.math.BigDecimal | getSystemOnorder()
java.math.BigDecimal | getSystemQtrUsage()
java.math.BigDecimal | getSystemWip()
java.math.BigDecimal | getSystemYrUsage()
void | setAuditOndemand(java.math.BigDecimal auditOndemand)
void | setAuditOnhandQty(java.math.BigDecimal auditOnhandQty)
void | setAuditOnorder(java.math.BigDecimal auditOnorder)
void | setAuditQtrUsage(java.math.BigDecimal auditQtrUsage)
void | setAuditWip(java.math.BigDecimal auditWip)
void | setAuditYrUsage(java.math.BigDecimal auditYrUsage)
void | setDescription(java.lang.String description)
void | setOnhandQty(java.math.BigDecimal onhandQty)
void | setPartPk(PartPK partPk)
void | setSystemOndemand(java.math.BigDecimal systemOndemand)
void | setSystemOnorder(java.math.BigDecimal systemOnorder)
void | setSystemQtrUsage(java.math.BigDecimal systemQtrUsage)
void | setSystemWip(java.math.BigDecimal systemWip)
void | setSystemYrUsage(java.math.BigDecimal systemYrUsage)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_ONHANDQTY

public static final java.lang.String ORDER_BY_ONHANDQTY
See Also:
Constant Field Values

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values
Constructor Detail

AuditOnDemandResult

public AuditOnDemandResult()
Method Detail

setDescription

public void setDescription(java.lang.String description)

setSystemWip

public void setSystemWip(java.math.BigDecimal systemWip)

setAuditWip

public void setAuditWip(java.math.BigDecimal auditWip)

setSystemOndemand

public void setSystemOndemand(java.math.BigDecimal systemOndemand)

setAuditOndemand

public void setAuditOndemand(java.math.BigDecimal auditOndemand)

setSystemOnorder

public void setSystemOnorder(java.math.BigDecimal systemOnorder)

setAuditOnorder

public void setAuditOnorder(java.math.BigDecimal auditOnorder)

setSystemYrUsage

public void setSystemYrUsage(java.math.BigDecimal systemYrUsage)

setAuditYrUsage

public void setAuditYrUsage(java.math.BigDecimal auditYrUsage)

setSystemQtrUsage

public void setSystemQtrUsage(java.math.BigDecimal systemQtrUsage)

setAuditQtrUsage

public void setAuditQtrUsage(java.math.BigDecimal auditQtrUsage)

getDescription

public java.lang.String getDescription()

getSystemWip

public java.math.BigDecimal getSystemWip()

getAuditWip

public java.math.BigDecimal getAuditWip()

getSystemOndemand

public java.math.BigDecimal getSystemOndemand()

getAuditOndemand

public java.math.BigDecimal getAuditOndemand()

getSystemOnorder

public java.math.BigDecimal getSystemOnorder()

getAuditOnorder

public java.math.BigDecimal getAuditOnorder()

getSystemYrUsage

public java.math.BigDecimal getSystemYrUsage()

getAuditYrUsage

public java.math.BigDecimal getAuditYrUsage()

getSystemQtrUsage

public java.math.BigDecimal getSystemQtrUsage()

getAuditQtrUsage

public java.math.BigDecimal getAuditQtrUsage()

getPartPk

public PartPK getPartPk()

setPartPk

public void setPartPk(PartPK partPk)

getOnhandQty

public java.math.BigDecimal getOnhandQty()

setOnhandQty

public void setOnhandQty(java.math.BigDecimal onhandQty)

getAuditOnhandQty

public java.math.BigDecimal getAuditOnhandQty()

setAuditOnhandQty

public void setAuditOnhandQty(java.math.BigDecimal auditOnhandQty)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AuditPartInQAResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class AuditPartInQAResult

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.AuditPartInQAResult
All Implemented Interfaces:
java.io.Serializable
public class AuditPartInQAResult
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
AuditPartInQAResult()
Method Summary
java.math.BigDecimal | getInQAQty()
java.lang.String | getNcrNumber()
java.lang.String | getNcrStatus()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getTotalQty()
void | setInQAQty(java.math.BigDecimal inQAQty)
void | setNcrNumber(java.lang.String ncrNumber)
void | setNcrStatus(java.lang.String ncrStatus)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setQuantity(java.math.BigDecimal quantity)
void | setTotalQty(java.math.BigDecimal totalQty)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AuditPartInQAResult

public AuditPartInQAResult()
Method Detail

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getNcrNumber

public java.lang.String getNcrNumber()

setNcrNumber

public void setNcrNumber(java.lang.String ncrNumber)

getInQAQty

public java.math.BigDecimal getInQAQty()

setInQAQty

public void setInQAQty(java.math.BigDecimal inQAQty)

getNcrStatus

public java.lang.String getNcrStatus()

setNcrStatus

public void setNcrStatus(java.lang.String ncrStatus)

getTotalQty

public java.math.BigDecimal getTotalQty()

setTotalQty

public void setTotalQty(java.math.BigDecimal totalQty)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BalanceSheetSideBySideItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BalanceSheetSideBySideItemResult

java.lang.Object
    extended by  bb.common.BalanceSheetSideBySideItemResult
All Implemented Interfaces:
java.io.Serializable
public class BalanceSheetSideBySideItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BalanceSheetSideBySideItemResult()
Method Summary
java.lang.String | getAccountDescription()
java.lang.String | getAccountNumber()
java.lang.String | getAccountType()
java.math.BigDecimal | getBalance()
java.lang.String | getCreditOrDebit()
byte | getItems()
java.lang.String | getLevel()
java.lang.Double | getPercentage()
java.lang.String | getUpLevelAccountNumber()
void | setAccountDescription(java.lang.String accountDescription)
void | setAccountNumber(java.lang.String accountNumber)
void | setAccountType(java.lang.String accountType)
void | setBalance(java.math.BigDecimal balance)
void | setCreditOrDebit(java.lang.String creditOrDebit)
void | setItems(byte items)
void | setLevel(java.lang.String level)
void | setPercentage(java.lang.Double percentage)
void | setUpLevelAccountNumber(java.lang.String upLevelAccountNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BalanceSheetSideBySideItemResult

public BalanceSheetSideBySideItemResult()
Method Detail

getUpLevelAccountNumber

public java.lang.String getUpLevelAccountNumber()

getAccountType

public java.lang.String getAccountType()

getAccountNumber

public java.lang.String getAccountNumber()

getItems

public byte getItems()

getAccountDescription

public java.lang.String getAccountDescription()

getCreditOrDebit

public java.lang.String getCreditOrDebit()

setLevel

public void setLevel(java.lang.String level)

setUpLevelAccountNumber

public void setUpLevelAccountNumber(java.lang.String upLevelAccountNumber)

setAccountType

public void setAccountType(java.lang.String accountType)

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

setItems

public void setItems(byte items)

setAccountDescription

public void setAccountDescription(java.lang.String accountDescription)

setCreditOrDebit

public void setCreditOrDebit(java.lang.String creditOrDebit)

setPercentage

public void setPercentage(java.lang.Double percentage)

getLevel

public java.lang.String getLevel()

getPercentage

public java.lang.Double getPercentage()

getBalance

public java.math.BigDecimal getBalance()

setBalance

public void setBalance(java.math.BigDecimal balance)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BalanceSheetSideBySideResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BalanceSheetSideBySideResult

java.lang.Object
    extended by  bb.common.BalanceSheetSideBySideResult
All Implemented Interfaces:
java.io.Serializable
public class BalanceSheetSideBySideResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BalanceSheetSideBySideResult()
Method Summary
java.util.List | getCurrentAssets()
java.util.List | getCurrentLiability()
java.util.List | getFixedAssets()
java.lang.String | getMonthYear()
java.util.List | getOtherAssets()
java.util.List | getOtherLiability()
java.util.List | getOwnersEquity()
BalanceSheetSideBySideItemResult | getTotalAssets()
BalanceSheetSideBySideItemResult | getTotalCurrentAssets()
BalanceSheetSideBySideItemResult | getTotalCurrentLiability()
BalanceSheetSideBySideItemResult | getTotalFixedAssets()
BalanceSheetSideBySideItemResult | getTotalLiability()
BalanceSheetSideBySideItemResult | getTotalLiabilityEquity()
BalanceSheetSideBySideItemResult | getTotalOtherAssets()
BalanceSheetSideBySideItemResult | getTotalOtherLiability()
BalanceSheetSideBySideItemResult | getTotalOwnersEquity()
BalanceSheetSideBySideItemResult | getTotalReturainedEarnings()
void | setCurrentAssets(java.util.List currentAssets)
void | setCurrentLiability(java.util.List currentLiability)
void | setFixedAssets(java.util.List fixedAssets)
void | setMonthYear(java.lang.String monthYear)
void | setOtherAssets(java.util.List otherAssets)
void | setOtherLiability(java.util.List otherLiability)
void | setOwnersEquity(java.util.List ownersEquity)
void | setTotalAssets(BalanceSheetSideBySideItemResult totalAssets)
void | setTotalCurrentAssets(BalanceSheetSideBySideItemResult totalCurrentAssets)
void | setTotalCurrentLiability(BalanceSheetSideBySideItemResult totalCurrentLiability)
void | setTotalFixedAssets(BalanceSheetSideBySideItemResult totalFixedAssets)
void | setTotalLiability(BalanceSheetSideBySideItemResult totalLiability)
void | setTotalLiabilityEquity(BalanceSheetSideBySideItemResult totalLiabilityEquity)
void | setTotalOtherAssets(BalanceSheetSideBySideItemResult totalOtherAssets)
void | setTotalOtherLiability(BalanceSheetSideBySideItemResult totalOtherLiability)
void | setTotalOwnersEquity(BalanceSheetSideBySideItemResult totalOwnersEquity)
void | setTotalReturainedEarnings(BalanceSheetSideBySideItemResult totalReturainedEarnings)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BalanceSheetSideBySideResult

public BalanceSheetSideBySideResult()
Method Detail

getTotalOtherAssets

public BalanceSheetSideBySideItemResult getTotalOtherAssets()

getTotalFixedAssets

public BalanceSheetSideBySideItemResult getTotalFixedAssets()

getCurrentLiability

public java.util.List getCurrentLiability()

getTotalOtherLiability

public BalanceSheetSideBySideItemResult getTotalOtherLiability()

getOwnersEquity

public java.util.List getOwnersEquity()

getTotalAssets

public BalanceSheetSideBySideItemResult getTotalAssets()

getFixedAssets

public java.util.List getFixedAssets()

getTotalCurrentAssets

public BalanceSheetSideBySideItemResult getTotalCurrentAssets()

getOtherAssets

public java.util.List getOtherAssets()

getTotalCurrentLiability

public BalanceSheetSideBySideItemResult getTotalCurrentLiability()

getOtherLiability

public java.util.List getOtherLiability()

getTotalOwnersEquity

public BalanceSheetSideBySideItemResult getTotalOwnersEquity()

getCurrentAssets

public java.util.List getCurrentAssets()

setTotalLiability

public void setTotalLiability(BalanceSheetSideBySideItemResult totalLiability)

setTotalOtherAssets

public void setTotalOtherAssets(BalanceSheetSideBySideItemResult totalOtherAssets)

setTotalFixedAssets

public void setTotalFixedAssets(BalanceSheetSideBySideItemResult totalFixedAssets)

setCurrentLiability

public void setCurrentLiability(java.util.List currentLiability)

setTotalOtherLiability

public void setTotalOtherLiability(BalanceSheetSideBySideItemResult totalOtherLiability)

setOwnersEquity

public void setOwnersEquity(java.util.List ownersEquity)

setTotalAssets

public void setTotalAssets(BalanceSheetSideBySideItemResult totalAssets)

setFixedAssets

public void setFixedAssets(java.util.List fixedAssets)

setTotalCurrentAssets

public void setTotalCurrentAssets(BalanceSheetSideBySideItemResult totalCurrentAssets)

setOtherAssets

public void setOtherAssets(java.util.List otherAssets)

setTotalCurrentLiability

public void setTotalCurrentLiability(BalanceSheetSideBySideItemResult totalCurrentLiability)

setOtherLiability

public void setOtherLiability(java.util.List otherLiability)

setTotalOwnersEquity

public void setTotalOwnersEquity(BalanceSheetSideBySideItemResult totalOwnersEquity)

setCurrentAssets

public void setCurrentAssets(java.util.List currentAssets)

setTotalLiabilityEquity

public void setTotalLiabilityEquity(BalanceSheetSideBySideItemResult totalLiabilityEquity)

setMonthYear

public void setMonthYear(java.lang.String monthYear)

getTotalLiability

public BalanceSheetSideBySideItemResult getTotalLiability()

getTotalLiabilityEquity

public BalanceSheetSideBySideItemResult getTotalLiabilityEquity()

getMonthYear

public java.lang.String getMonthYear()

getTotalReturainedEarnings

public BalanceSheetSideBySideItemResult getTotalReturainedEarnings()

setTotalReturainedEarnings

public void setTotalReturainedEarnings(BalanceSheetSideBySideItemResult totalReturainedEarnings)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BankReconciliationReportVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BankReconciliationReportVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.BankReconciliationReportVO
All Implemented Interfaces:
java.io.Serializable
public class BankReconciliationReportVO
extends VO

See Also:
Serialized Form

Constructor Summary
BankReconciliationReportVO()
Method Summary
boolean | equals(java.lang.Object other)
AccountMonthPK | getPk()
java.lang.String | getStatus()
int | hashCode()
void | setPk(AccountMonthPK pk)
void | setStatus(java.lang.String status)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

BankReconciliationReportVO

public BankReconciliationReportVO()
Method Detail

getPk

public AccountMonthPK getPk()

setPk

public void setPk(AccountMonthPK pk)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2AttachFile

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2AttachFile

java.lang.Object
    extended by  bb.common.BB2AttachFile
All Implemented Interfaces:
java.io.Serializable
public class BB2AttachFile
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2AttachFile()
Method Summary
byte[] | getFile()
java.lang.String | getFilename()
void | setFile(byte[] file)
void | setFilename(java.lang.String filename)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2AttachFile

public BB2AttachFile()
Method Detail

getFile

public byte[] getFile()

setFile

public void setFile(byte[] file)

getFilename

public java.lang.String getFilename()

setFilename

public void setFilename(java.lang.String filename)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2BigDecimalAndString

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2BigDecimalAndString

java.lang.Object
    extended by  bb.common.BB2BigDecimalAndString
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable
public class BB2BigDecimalAndString
extends java.lang.Object
implements java.io.Serializable, java.lang.Comparable

See Also:
Serialized Form

Constructor Summary
BB2BigDecimalAndString(java.lang.Float f, java.lang.String desc)
Method Summary
int | compareTo(java.lang.Object o)
boolean | equals(java.lang.Object other)
java.lang.String | getDesc()
java.math.BigDecimal | getId()
int | hashCode()
void | setDesc(java.lang.String desc)
void | setId(java.math.BigDecimal id)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

BB2BigDecimalAndString

public BB2BigDecimalAndString(java.lang.Float f,
                              java.lang.String desc)
Method Detail

compareTo

public int compareTo(java.lang.Object o)
Specified by:
compareTo in interface java.lang.Comparable

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getId

public java.math.BigDecimal getId()

setId

public void setId(java.math.BigDecimal id)

getDesc

public java.lang.String getDesc()

setDesc

public void setDesc(java.lang.String desc)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2BugNotice

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2BugNotice

java.lang.Object
    extended by  bb.common.BB2BugNotice
All Implemented Interfaces:
java.io.Serializable
public class BB2BugNotice
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2BugNotice()
Method Summary
java.util.ArrayList<BB2AttachFile> | getAttach()
java.lang.String | getContent()
java.lang.String | getSendFrom()
java.lang.String | getSendTo()
java.lang.String | getSubject()
void | setAttach(java.util.ArrayList<BB2AttachFile> attach)
void | setContent(java.lang.String content)
void | setSendFrom(java.lang.String sendFrom)
void | setSendTo(java.lang.String sendTo)
void | setSubject(java.lang.String subject)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2BugNotice

public BB2BugNotice()
Method Detail

getContent

public java.lang.String getContent()

setContent

public void setContent(java.lang.String content)

getSubject

public java.lang.String getSubject()

setSubject

public void setSubject(java.lang.String subject)

getSendFrom

public java.lang.String getSendFrom()

setSendFrom

public void setSendFrom(java.lang.String sendFrom)

getAttach

public java.util.ArrayList<BB2AttachFile> getAttach()

setAttach

public void setAttach(java.util.ArrayList<BB2AttachFile> attach)

getSendTo

public java.lang.String getSendTo()

setSendTo

public void setSendTo(java.lang.String sendTo)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2Document

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2Document

java.lang.Object
    extended by  bb.common.BB2Document
All Implemented Interfaces:
java.io.Serializable
public class BB2Document
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2Document(java.lang.String pn, java.lang.String language, java.lang.String documentType)
BB2Document(java.lang.String pn, java.lang.String version, java.lang.String language, java.lang.String documentType)
Method Summary
byte[] | getBytes()
java.lang.String | getComments()
java.lang.String | getDocumentType()
java.lang.String | getFileName()
java.lang.String | getFrom()
java.lang.String | getLanguage()
java.lang.String | getPartNumber()
java.lang.String | getVersion()
void | setBytes(byte[] bytes)
void | setComments(java.lang.String comments)
void | setFrom(java.lang.String from)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2Document

public BB2Document(java.lang.String pn,
                   java.lang.String version,
                   java.lang.String language,
                   java.lang.String documentType)

BB2Document

public BB2Document(java.lang.String pn,
                   java.lang.String language,
                   java.lang.String documentType)
Method Detail

setBytes

public void setBytes(byte[] bytes)

setFrom

public void setFrom(java.lang.String from)

getBytes

public byte[] getBytes()

getFrom

public java.lang.String getFrom()

getDocumentType

public java.lang.String getDocumentType()

getPartNumber

public java.lang.String getPartNumber()

getVersion

public java.lang.String getVersion()

getLanguage

public java.lang.String getLanguage()

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getFileName

public java.lang.String getFileName()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2DocumentException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2DocumentException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  bb.common.BB2ServerException
                extended by  bb.common.BB2DocumentException
All Implemented Interfaces:
java.io.Serializable
public class BB2DocumentException
extends BB2ServerException

See Also:
Serialized Form

Field Summary
static Reason | FILE_ALREADY_EXIST
static Reason | FILE_IN_PROCESS
static Reason | FILE_NOT_EXIST
static Reason | TIME_OUT
Fields inherited from class bb.common.BB2ServerException
UNKNOWN_EXCEPTION
Constructor Summary
BB2DocumentException()
BB2DocumentException(java.lang.Exception e)
BB2DocumentException(java.lang.Exception e, java.lang.String target)
BB2DocumentException(java.lang.Exception e, java.lang.String target, Reason reason)
BB2DocumentException(java.lang.String target, Reason reason)
Method Summary
 java.lang.String getTarget()
Methods inherited from class bb.common.BB2ServerException
getParameter, getReason, setParameter
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

FILE_ALREADY_EXIST

public static final Reason FILE_ALREADY_EXIST

FILE_IN_PROCESS

public static final Reason FILE_IN_PROCESS

FILE_NOT_EXIST

public static final Reason FILE_NOT_EXIST

TIME_OUT

public static final Reason TIME_OUT
Constructor Detail

BB2DocumentException

public BB2DocumentException(java.lang.String target,
                            Reason reason)

BB2DocumentException

public BB2DocumentException()

BB2DocumentException

public BB2DocumentException(java.lang.Exception e,
                            java.lang.String target,
                            Reason reason)

BB2DocumentException

public BB2DocumentException(java.lang.Exception e,
                            java.lang.String target)

BB2DocumentException

public BB2DocumentException(java.lang.Exception e)
Method Detail

getTarget

public java.lang.String getTarget()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2DoubleCost

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2DoubleCost

java.lang.Object
    extended by  bb.common.BB2DoubleCost
All Implemented Interfaces:
java.io.Serializable
public class BB2DoubleCost
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2DoubleCost()
BB2DoubleCost(java.math.BigDecimal avgAmount, java.math.BigDecimal stdAmount)
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getAvgAmount()
java.math.BigDecimal | getStdAmount()
int | hashCode()
void | setAvgAmount(java.math.BigDecimal avgAmount)
void | setStdAmount(java.math.BigDecimal stdAmount)
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2DoubleCost

public BB2DoubleCost()

BB2DoubleCost

public BB2DoubleCost(java.math.BigDecimal avgAmount,
                     java.math.BigDecimal stdAmount)
Method Detail

getAvgAmount

public java.math.BigDecimal getAvgAmount()

setAvgAmount

public void setAvgAmount(java.math.BigDecimal avgAmount)

getStdAmount

public java.math.BigDecimal getStdAmount()

setStdAmount

public void setStdAmount(java.math.BigDecimal stdAmount)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2DoubleString

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2DoubleString

java.lang.Object
    extended by  bb.common.BB2DoubleString
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable
public class BB2DoubleString
extends java.lang.Object
implements java.io.Serializable, java.lang.Comparable

See Also:
Serialized Form

Constructor Summary
BB2DoubleString()
BB2DoubleString(java.lang.Float identifier, java.lang.String description)
BB2DoubleString(java.lang.String identifier, java.lang.String description)
Method Summary
int | compareTo(java.lang.Object o)
boolean | equals(java.lang.Object other)
java.lang.String | getDescription()
java.lang.String | getIdentifier()
int | hashCode()
void | setDescription(java.lang.String description)
void | setIdentifier(java.lang.String identifier)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

BB2DoubleString

public BB2DoubleString()

BB2DoubleString

public BB2DoubleString(java.lang.String identifier,
                       java.lang.String description)

BB2DoubleString

public BB2DoubleString(java.lang.Float identifier,
                       java.lang.String description)
Method Detail

setIdentifier

public void setIdentifier(java.lang.String identifier)

setDescription

public void setDescription(java.lang.String description)

getIdentifier

public java.lang.String getIdentifier()

getDescription

public java.lang.String getDescription()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

compareTo

public int compareTo(java.lang.Object o)
Specified by:
compareTo in interface java.lang.Comparable
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2Event

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2Event

java.lang.Object
    extended by  bb.common.BB2Event
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
I18nEvent
public class BB2Event
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | CLOSE_DOCUMENT
static java.lang.String | DOWNLOAD
static java.lang.String | OPEN_DOCUMENT
static java.lang.String | SUBMIT_DOCUMENT
static java.lang.String | UPLOAD
Constructor Summary
BB2Event(java.lang.String source)
BB2Event(java.lang.String source, java.lang.String action)
BB2Event(java.lang.String source, java.lang.String action, java.lang.String message)
BB2Event(java.lang.String source, java.lang.String action, java.lang.String message, boolean popup)
Method Summary
java.lang.String | getAction()
java.lang.String | getMessage()
java.lang.String | getSource()
boolean | isPopup()
void | setPopup(boolean popup)
java.lang.String | toString()
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

OPEN_DOCUMENT

public static final java.lang.String OPEN_DOCUMENT
See Also:
Constant Field Values

CLOSE_DOCUMENT

public static final java.lang.String CLOSE_DOCUMENT
See Also:
Constant Field Values

SUBMIT_DOCUMENT

public static final java.lang.String SUBMIT_DOCUMENT
See Also:
Constant Field Values

UPLOAD

public static final java.lang.String UPLOAD
See Also:
Constant Field Values

DOWNLOAD

public static final java.lang.String DOWNLOAD
See Also:
Constant Field Values
Constructor Detail

BB2Event

public BB2Event(java.lang.String source,
                java.lang.String action,
                java.lang.String message,
                boolean popup)

BB2Event

public BB2Event(java.lang.String source,
                java.lang.String action,
                java.lang.String message)

BB2Event

public BB2Event(java.lang.String source,
                java.lang.String action)

BB2Event

public BB2Event(java.lang.String source)
Method Detail

getSource

public java.lang.String getSource()

getAction

public java.lang.String getAction()

getMessage

public java.lang.String getMessage()

isPopup

public boolean isPopup()

setPopup

public void setPopup(boolean popup)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2File

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2File

java.lang.Object
    extended by  bb.common.BB2File
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
BB2Picture
public class BB2File
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2File()
Method Summary
byte[] | getContext()
java.lang.String | getExt()
java.lang.String | getFilename()
void | setContext(byte[] context)
void | setExt(java.lang.String ext)
void | setFilename(java.lang.String filename)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2File

public BB2File()
Method Detail

getFilename

public java.lang.String getFilename()

setFilename

public void setFilename(java.lang.String filename)

setContext

public void setContext(byte[] context)

setExt

public void setExt(java.lang.String ext)

getContext

public byte[] getContext()

getExt

public java.lang.String getExt()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2FiscalYearDate

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2FiscalYearDate

java.lang.Object
    extended by  bb.common.BB2FiscalYearDate
All Implemented Interfaces:
java.io.Serializable
public class BB2FiscalYearDate
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2FiscalYearDate()
Method Summary
java.util.Date | getEndDate()
int | getMonthCount()
java.util.Date | getStartDate()
void | setEndDate(java.util.Date endDate)
void | setMonthCount(int monthCount)
void | setStartDate(java.util.Date startDate)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2FiscalYearDate

public BB2FiscalYearDate()
Method Detail

getEndDate

public java.util.Date getEndDate()

setEndDate

public void setEndDate(java.util.Date endDate)

getStartDate

public java.util.Date getStartDate()

setStartDate

public void setStartDate(java.util.Date startDate)

getMonthCount

public int getMonthCount()

setMonthCount

public void setMonthCount(int monthCount)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2Login

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2Login

java.lang.Object
    extended by  bb.common.BB2Login
All Implemented Interfaces:
java.io.Serializable
public final class BB2Login
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2Login(java.lang.String userName, java.lang.String password, java.lang.String system)
BB2Login(java.lang.String userName, java.lang.String password, java.lang.String system, java.lang.String loginType)
Method Summary
java.lang.String | getClientIP()
java.lang.String | getClientMAC()
java.lang.String | getClientWanIp()
java.lang.String | getLanguage()
java.lang.String | getLoginType()
java.lang.String | getPassword()
java.lang.String | getSystem()
java.lang.String | getUserName()
void | setClientIP(java.lang.String clientIP)
void | setClientMAC(java.lang.String clientMAC)
void | setClientWanIp(java.lang.String clientWanIp)
void | setLanguage(java.lang.String language)
void | setLoginType(java.lang.String loginType)
void | setPassword(java.lang.String password)
void | setSystem(java.lang.String system)
void | setUserName(java.lang.String userName)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2Login

public BB2Login(java.lang.String userName,
                java.lang.String password,
                java.lang.String system)

BB2Login

public BB2Login(java.lang.String userName,
                java.lang.String password,
                java.lang.String system,
                java.lang.String loginType)
Method Detail

setUserName

public void setUserName(java.lang.String userName)

setPassword

public void setPassword(java.lang.String password)

setSystem

public void setSystem(java.lang.String system)

getUserName

public java.lang.String getUserName()

getPassword

public java.lang.String getPassword()

getSystem

public java.lang.String getSystem()

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getClientIP

public java.lang.String getClientIP()

setClientIP

public void setClientIP(java.lang.String clientIP)

getClientMAC

public java.lang.String getClientMAC()

setClientMAC

public void setClientMAC(java.lang.String clientMAC)

getClientWanIp

public java.lang.String getClientWanIp()

setClientWanIp

public void setClientWanIp(java.lang.String clientWanIp)

getLoginType

public java.lang.String getLoginType()

setLoginType

public void setLoginType(java.lang.String loginType)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2MessagingException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2MessagingException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  bb.common.BB2ServerException
                extended by  bb.common.BB2MessagingException
All Implemented Interfaces:
java.io.Serializable
public class BB2MessagingException
extends BB2ServerException

See Also:
Serialized Form

Field Summary
Fields inherited from class bb.common.BB2ServerException
UNKNOWN_EXCEPTION
Constructor Summary
BB2MessagingException(java.lang.Exception e)
BB2MessagingException(Reason reason)
Method Summary
Methods inherited from class bb.common.BB2ServerException
getParameter, getReason, setParameter
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

BB2MessagingException

public BB2MessagingException(java.lang.Exception e)

BB2MessagingException

public BB2MessagingException(Reason reason)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2Notice

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2Notice

java.lang.Object
    extended by  bb.common.BB2Notice
All Implemented Interfaces:
java.io.Serializable
public class BB2Notice
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2Notice()
Method Summary
java.util.ArrayList<BB2AttachFile> | getAttach()
java.lang.String[] | getCopyTo()
java.lang.String | getHostName()
java.lang.String | getMessageNumber()
java.lang.String | getNoticeText()
java.lang.String | getOrderNumber()
java.lang.String | getSendFrom()
java.lang.String[] | getSentTo()
java.lang.String | getSubject()
java.lang.String | getValidateCode()
boolean | isNeedReply()
void | setAttach(java.util.ArrayList<BB2AttachFile> attach)
void | setCopyTo(java.lang.String[] copyTo)
void | setHostName(java.lang.String hostName)
void | setMessageNumber(java.lang.String messageNumber)
void | setNeedReply(boolean needReply)
void | setNoticeText(java.lang.String noticeText)
void | setOrderNumber(java.lang.String orderNumber)
void | setSendFrom(java.lang.String sendFrom)
void | setSentTo(java.lang.String[] sentTo)
void | setSubject(java.lang.String subject)
void | setValidateCode(java.lang.String validateCode)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2Notice

public BB2Notice()
Method Detail

setSentTo

public void setSentTo(java.lang.String[] sentTo)

setCopyTo

public void setCopyTo(java.lang.String[] copyTo)

setNoticeText

public void setNoticeText(java.lang.String noticeText)

getSentTo

public java.lang.String[] getSentTo()

getCopyTo

public java.lang.String[] getCopyTo()

getNoticeText

public java.lang.String getNoticeText()

getOrderNumber

public java.lang.String getOrderNumber()

setOrderNumber

public void setOrderNumber(java.lang.String orderNumber)

getValidateCode

public java.lang.String getValidateCode()

setValidateCode

public void setValidateCode(java.lang.String validateCode)

isNeedReply

public boolean isNeedReply()

setNeedReply

public void setNeedReply(boolean needReply)

getHostName

public java.lang.String getHostName()

setHostName

public void setHostName(java.lang.String hostName)

getMessageNumber

public java.lang.String getMessageNumber()

setMessageNumber

public void setMessageNumber(java.lang.String messageNumber)

getSubject

public java.lang.String getSubject()

setSubject

public void setSubject(java.lang.String subject)

getAttach

public java.util.ArrayList<BB2AttachFile> getAttach()

setAttach

public void setAttach(java.util.ArrayList<BB2AttachFile> attach)

getSendFrom

public java.lang.String getSendFrom()

setSendFrom

public void setSendFrom(java.lang.String sendFrom)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2Part

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2Part

java.lang.Object
    extended by  bb.common.BB2Part
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<BB2Part>
public class BB2Part
extends java.lang.Object
implements java.io.Serializable, java.lang.Comparable<BB2Part>

See Also:
Serialized Form

Constructor Summary
BB2Part()
BB2Part(PartPK partPk, java.lang.String partFrom)
BB2Part(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom)
Method Summary
int | compareTo(BB2Part other)
boolean | equals(java.lang.Object other)
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
PartPK | getPartPk()
java.lang.String | getPartType()
int | hashCode()
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

BB2Part

public BB2Part()

BB2Part

public BB2Part(PartPK partPk,
               java.lang.String partFrom)

BB2Part

public BB2Part(java.lang.String partNumber,
               java.lang.String partType,
               java.lang.String partFrom)
Method Detail

setPartPk

public void setPartPk(PartPK partPk)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartPk

public PartPK getPartPk()

getPartFrom

public java.lang.String getPartFrom()

getPartNumber

public java.lang.String getPartNumber()

getPartType

public java.lang.String getPartType()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

compareTo

public int compareTo(BB2Part other)
Specified by:
compareTo in interface java.lang.Comparable<BB2Part>
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2PartBasicInfo

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2PartBasicInfo

java.lang.Object
    extended by  bb.common.BB2PartBasicInfo
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
BB2PartInfo, BB2PartTotalInQADetailResult, BB2PartTotalInSipDetailResult, BB2PartTotalInSitDetailResult, BB2PartTotalInSTODetailResult, BB2PartTotalInWipDetailResult, BB2PartTotalOndemandDetailResult, BB2PartTotalOnhandDetailResult, BB2PartTotalOnloanDetailResult, BB2PartTotalOnorderDetailResult
public class BB2PartBasicInfo
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2PartBasicInfo()
Method Summary
java.lang.String | getDescription()
BB2Part | getPart()
void | setDescription(java.lang.String description)
void | setPart(BB2Part part)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2PartBasicInfo

public BB2PartBasicInfo()
Method Detail

setPart

public void setPart(BB2Part part)

setDescription

public void setDescription(java.lang.String description)

getPart

public BB2Part getPart()

getDescription

public java.lang.String getDescription()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2PartByDateResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2PartByDateResult

java.lang.Object
    extended by  bb.common.BB2PartByDateResult
All Implemented Interfaces:
java.io.Serializable
public class BB2PartByDateResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2PartByDateResult()
Method Summary
java.lang.String | getCurrency()
java.math.BigDecimal | getNewOnhand()
java.math.BigDecimal | getNewTotalCost()
java.math.BigDecimal | getOldOnhand()
java.math.BigDecimal | getOldTotalCost()
BB2Part | getPart()
java.math.BigDecimal | getTotalIssuedCost()
java.math.BigDecimal | getTotalIssuedQty()
java.math.BigDecimal | getTotalReceivedCost()
java.math.BigDecimal | getTotalReceiveQty()
java.lang.String | getUnit()
void | setCurrency(java.lang.String currency)
void | setNewOnhand(java.math.BigDecimal newOnhand)
void | setNewTotalCost(java.math.BigDecimal newTotalCost)
void | setOldOnhand(java.math.BigDecimal oldOnhand)
void | setOldTotalCost(java.math.BigDecimal oldTotalCost)
void | setPart(BB2Part part)
void | setTotalIssuedCost(java.math.BigDecimal totalIssuedCost)
void | setTotalIssuedQty(java.math.BigDecimal totalIssuedQty)
void | setTotalReceivedCost(java.math.BigDecimal totalReceivedCost)
void | setTotalReceiveQty(java.math.BigDecimal totalReceiveQty)
void | setUnit(java.lang.String unit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2PartByDateResult

public BB2PartByDateResult()
Method Detail

getPart

public BB2Part getPart()

setPart

public void setPart(BB2Part part)

getNewOnhand

public java.math.BigDecimal getNewOnhand()

setNewOnhand

public void setNewOnhand(java.math.BigDecimal newOnhand)

getOldOnhand

public java.math.BigDecimal getOldOnhand()

setOldOnhand

public void setOldOnhand(java.math.BigDecimal oldOnhand)

getTotalIssuedQty

public java.math.BigDecimal getTotalIssuedQty()

setTotalIssuedQty

public void setTotalIssuedQty(java.math.BigDecimal totalIssuedQty)

getTotalReceiveQty

public java.math.BigDecimal getTotalReceiveQty()

setTotalReceiveQty

public void setTotalReceiveQty(java.math.BigDecimal totalReceiveQty)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getNewTotalCost

public java.math.BigDecimal getNewTotalCost()

setNewTotalCost

public void setNewTotalCost(java.math.BigDecimal newTotalCost)

getOldTotalCost

public java.math.BigDecimal getOldTotalCost()

setOldTotalCost

public void setOldTotalCost(java.math.BigDecimal oldTotalCost)

getTotalIssuedCost

public java.math.BigDecimal getTotalIssuedCost()

setTotalIssuedCost

public void setTotalIssuedCost(java.math.BigDecimal totalIssuedCost)

getTotalReceivedCost

public java.math.BigDecimal getTotalReceivedCost()

setTotalReceivedCost

public void setTotalReceivedCost(java.math.BigDecimal totalReceivedCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2PartInfo

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2PartInfo

java.lang.Object
    extended by  bb.common.BB2PartBasicInfo
        extended by  bb.common.BB2PartInfo
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
BB2PartMrpResult
public class BB2PartInfo
extends BB2PartBasicInfo
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2PartInfo()
Method Summary
java.lang.String | getBom()
java.lang.String | getDwg()
java.lang.String | getHold()
java.math.BigDecimal | getInSip()
java.math.BigDecimal | getInSit()
java.math.BigDecimal | getInWip()
java.math.BigDecimal | getLeadtime()
java.math.BigDecimal | getMaxQty()
java.math.BigDecimal | getMinQty()
java.math.BigDecimal | getOndemand()
java.math.BigDecimal | getOnhand()
java.math.BigDecimal | getOnorder()
java.math.BigDecimal | getQtrUsage()
java.lang.String | getRev()
java.math.BigDecimal | getYrUsage()
void | setBom(java.lang.String bom)
void | setDwg(java.lang.String dwg)
void | setHold(java.lang.String hold)
void | setInSip(java.math.BigDecimal inSip)
void | setInSit(java.math.BigDecimal inSit)
void | setInWip(java.math.BigDecimal inWip)
void | setLeadtime(java.math.BigDecimal leadtime)
void | setMaxQty(java.math.BigDecimal maxQty)
void | setMinQty(java.math.BigDecimal minQty)
void | setOndemand(java.math.BigDecimal ondemand)
void | setOnhand(java.math.BigDecimal onhand)
void | setOnorder(java.math.BigDecimal onorder)
void | setQtrUsage(java.math.BigDecimal qtrUsage)
void | setRev(java.lang.String rev)
void | setYrUsage(java.math.BigDecimal yrUsage)
Methods inherited from class bb.common.BB2PartBasicInfo
getDescription, getPart, setDescription, setPart
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2PartInfo

public BB2PartInfo()
Method Detail

getDwg

public java.lang.String getDwg()

getBom

public java.lang.String getBom()

getHold

public java.lang.String getHold()

getRev

public java.lang.String getRev()

getOnhand

public java.math.BigDecimal getOnhand()

getOnorder

public java.math.BigDecimal getOnorder()

getOndemand

public java.math.BigDecimal getOndemand()

getInWip

public java.math.BigDecimal getInWip()

getInSip

public java.math.BigDecimal getInSip()

getInSit

public java.math.BigDecimal getInSit()

getMinQty

public java.math.BigDecimal getMinQty()

getMaxQty

public java.math.BigDecimal getMaxQty()

getYrUsage

public java.math.BigDecimal getYrUsage()

getQtrUsage

public java.math.BigDecimal getQtrUsage()

getLeadtime

public java.math.BigDecimal getLeadtime()

setDwg

public void setDwg(java.lang.String dwg)

setBom

public void setBom(java.lang.String bom)

setHold

public void setHold(java.lang.String hold)

setRev

public void setRev(java.lang.String rev)

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

setOnorder

public void setOnorder(java.math.BigDecimal onorder)

setOndemand

public void setOndemand(java.math.BigDecimal ondemand)

setInWip

public void setInWip(java.math.BigDecimal inWip)

setInSip

public void setInSip(java.math.BigDecimal inSip)

setInSit

public void setInSit(java.math.BigDecimal inSit)

setMinQty

public void setMinQty(java.math.BigDecimal minQty)

setMaxQty

public void setMaxQty(java.math.BigDecimal maxQty)

setYrUsage

public void setYrUsage(java.math.BigDecimal yrUsage)

setQtrUsage

public void setQtrUsage(java.math.BigDecimal qtrUsage)

setLeadtime

public void setLeadtime(java.math.BigDecimal leadtime)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2PartInSipItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2PartInSipItemResult

java.lang.Object
    extended by  bb.common.BB2PartInSipItemResult
All Implemented Interfaces:
java.io.Serializable
public class BB2PartInSipItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2PartInSipItemResult()
Method Summary
java.lang.String | getCustomerId()
java.util.Date | getDeliveryDate()
PackingBoxItemPK | getPackBoxItemPk()
java.math.BigDecimal | getQtyInSip()
void | setCustomerId(java.lang.String customerId)
void | setDeliveryDate(java.util.Date deliveryDate)
void | setPackBoxItemPk(PackingBoxItemPK packBoxItemPk)
void | setQtyInSip(java.math.BigDecimal qtyInSip)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2PartInSipItemResult

public BB2PartInSipItemResult()
Method Detail

setPackBoxItemPk

public void setPackBoxItemPk(PackingBoxItemPK packBoxItemPk)

setQtyInSip

public void setQtyInSip(java.math.BigDecimal qtyInSip)

setDeliveryDate

public void setDeliveryDate(java.util.Date deliveryDate)

setCustomerId

public void setCustomerId(java.lang.String customerId)

getPackBoxItemPk

public PackingBoxItemPK getPackBoxItemPk()

getQtyInSip

public java.math.BigDecimal getQtyInSip()

getDeliveryDate

public java.util.Date getDeliveryDate()

getCustomerId

public java.lang.String getCustomerId()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2PartInSipOfSoItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2PartInSipOfSoItemResult

java.lang.Object
    extended by  bb.common.BB2PartInSipOfSoItemResult
All Implemented Interfaces:
java.io.Serializable
public class BB2PartInSipOfSoItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2PartInSipOfSoItemResult()
Method Summary
java.lang.String | getCustomerId()
java.util.Date | getDeliveryDate()
SalesOrderItemPK | getPk()
java.math.BigDecimal | getQtyInSip()
java.math.BigDecimal | getQtyOrdered()
java.math.BigDecimal | getQtyShipped()
void | setCustomerId(java.lang.String customerId)
void | setDeliveryDate(java.util.Date deliveryDate)
void | setPk(SalesOrderItemPK pk)
void | setQtyInSip(java.math.BigDecimal qtyInSip)
void | setQtyOrdered(java.math.BigDecimal qtyOrdered)
void | setQtyShipped(java.math.BigDecimal qtyShipped)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2PartInSipOfSoItemResult

public BB2PartInSipOfSoItemResult()
Method Detail

setQtyInSip

public void setQtyInSip(java.math.BigDecimal qtyInSip)

setDeliveryDate

public void setDeliveryDate(java.util.Date deliveryDate)

setCustomerId

public void setCustomerId(java.lang.String customerId)

getQtyInSip

public java.math.BigDecimal getQtyInSip()

getDeliveryDate

public java.util.Date getDeliveryDate()

getCustomerId

public java.lang.String getCustomerId()

getPk

public SalesOrderItemPK getPk()

setPk

public void setPk(SalesOrderItemPK pk)

getQtyOrdered

public java.math.BigDecimal getQtyOrdered()

setQtyOrdered

public void setQtyOrdered(java.math.BigDecimal qtyOrdered)

getQtyShipped

public java.math.BigDecimal getQtyShipped()

setQtyShipped

public void setQtyShipped(java.math.BigDecimal qtyShipped)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2PartInSitItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2PartInSitItemResult

java.lang.Object
    extended by  bb.common.BB2PartInSitItemResult
All Implemented Interfaces:
java.io.Serializable
public class BB2PartInSitItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2PartInSitItemResult()
Method Summary
java.util.Date | getArrivalDate()
java.util.Date | getDeliveryDate()
PrPackingBoxItemPK | getPackBoxItemPk()
java.math.BigDecimal | getQtyInSit()
java.lang.String | getShipToId()
java.lang.String | getVendorId()
void | setArrivalDate(java.util.Date arrivalDate)
void | setDeliveryDate(java.util.Date deliveryDate)
void | setPackBoxItemPk(PrPackingBoxItemPK packBoxItemPk)
void | setQtyInSit(java.math.BigDecimal qtyInSit)
void | setShipToId(java.lang.String shipToId)
void | setVendorId(java.lang.String vendorId)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2PartInSitItemResult

public BB2PartInSitItemResult()
Method Detail

setPackBoxItemPk

public void setPackBoxItemPk(PrPackingBoxItemPK packBoxItemPk)

setQtyInSit

public void setQtyInSit(java.math.BigDecimal qtyInSit)

setDeliveryDate

public void setDeliveryDate(java.util.Date deliveryDate)

setVendorId

public void setVendorId(java.lang.String vendorId)

getPackBoxItemPk

public PrPackingBoxItemPK getPackBoxItemPk()

getQtyInSit

public java.math.BigDecimal getQtyInSit()

getDeliveryDate

public java.util.Date getDeliveryDate()

getVendorId

public java.lang.String getVendorId()

getArrivalDate

public java.util.Date getArrivalDate()

setArrivalDate

public void setArrivalDate(java.util.Date arrivalDate)

getShipToId

public java.lang.String getShipToId()

setShipToId

public void setShipToId(java.lang.String shipToId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2PartInSTOItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2PartInSTOItemResult

java.lang.Object
    extended by  bb.common.BB2PartInSTOItemResult
All Implemented Interfaces:
java.io.Serializable
public class BB2PartInSTOItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2PartInSTOItemResult()
Method Summary
TransferShipperItemPK | getPk()
java.math.BigDecimal | getQty()
java.util.Date | getShipDate()
java.lang.String | getStatus()
java.lang.String | getToAddressId()
void | setPk(TransferShipperItemPK pk)
void | setQty(java.math.BigDecimal qty)
void | setShipDate(java.util.Date shipDate)
void | setStatus(java.lang.String status)
void | setToAddressId(java.lang.String toAddressId)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2PartInSTOItemResult

public BB2PartInSTOItemResult()
Method Detail

setQty

public void setQty(java.math.BigDecimal qty)

setStatus

public void setStatus(java.lang.String status)

getQty

public java.math.BigDecimal getQty()

getStatus

public java.lang.String getStatus()

getShipDate

public java.util.Date getShipDate()

setShipDate

public void setShipDate(java.util.Date shipDate)

getPk

public TransferShipperItemPK getPk()

setPk

public void setPk(TransferShipperItemPK pk)

getToAddressId

public java.lang.String getToAddressId()

setToAddressId

public void setToAddressId(java.lang.String toAddressId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2PartInventoryResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2PartInventoryResult

java.lang.Object
    extended by  bb.common.BB2PartInventoryResult
All Implemented Interfaces:
java.io.Serializable
public class BB2PartInventoryResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2PartInventoryResult()
BB2PartInventoryResult(BB2Part part)
Method Summary
java.math.BigDecimal | getAvgcost()
java.math.BigDecimal | getOnDemandQty()
java.math.BigDecimal | getOnhand()
java.math.BigDecimal | getOnOrderQty()
BB2Part | getPart()
java.math.BigDecimal | getShipInProcessQty()
java.math.BigDecimal | getShipInTransactionQty()
java.math.BigDecimal | getWorkInProcessQty()
void | setAvgcost(java.math.BigDecimal avgcost)
void | setOnDemandQty(java.math.BigDecimal onDemandQty)
void | setOnhand(java.math.BigDecimal onhand)
void | setOnOrderQty(java.math.BigDecimal onOrderQty)
void | setPart(BB2Part part)
void | setShipInProcessQty(java.math.BigDecimal shipInProcessQty)
void | setShipInTransactionQty(java.math.BigDecimal shipInTransactionQty)
void | setWorkInProcessQty(java.math.BigDecimal workInProcessQty)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2PartInventoryResult

public BB2PartInventoryResult()

BB2PartInventoryResult

public BB2PartInventoryResult(BB2Part part)
Method Detail

getOnDemandQty

public java.math.BigDecimal getOnDemandQty()

setOnDemandQty

public void setOnDemandQty(java.math.BigDecimal onDemandQty)

getOnhand

public java.math.BigDecimal getOnhand()

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

getOnOrderQty

public java.math.BigDecimal getOnOrderQty()

setOnOrderQty

public void setOnOrderQty(java.math.BigDecimal onOrderQty)

getPart

public BB2Part getPart()

setPart

public void setPart(BB2Part part)

getShipInProcessQty

public java.math.BigDecimal getShipInProcessQty()

setShipInProcessQty

public void setShipInProcessQty(java.math.BigDecimal shipInProcessQty)

getShipInTransactionQty

public java.math.BigDecimal getShipInTransactionQty()

setShipInTransactionQty

public void setShipInTransactionQty(java.math.BigDecimal shipInTransactionQty)

getWorkInProcessQty

public java.math.BigDecimal getWorkInProcessQty()

setWorkInProcessQty

public void setWorkInProcessQty(java.math.BigDecimal workInProcessQty)

getAvgcost

public java.math.BigDecimal getAvgcost()

setAvgcost

public void setAvgcost(java.math.BigDecimal avgcost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2PartMrpResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2PartMrpResult

java.lang.Object
    extended by  bb.common.BB2PartBasicInfo
        extended by  bb.common.BB2PartInfo
            extended by  bb.common.BB2PartMrpResult
All Implemented Interfaces:
java.io.Serializable
public class BB2PartMrpResult
extends BB2PartInfo
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2PartMrpResult()
Method Summary
java.util.ArrayList | getPurchaseOrderOnOrderResult()
java.util.ArrayList | getSalesOrderOnDemandResult()
java.util.ArrayList | getSalesOrderOrphanedResult()
java.util.ArrayList | getWorkOrderOnDemandResult()
java.util.ArrayList | getWorkOrderOnOrderResult()
void | setPurchaseOrderOnOrderResult(java.util.ArrayList purchaseOrderOnOrderResult)
void | setSalesOrderOnDemandResult(java.util.ArrayList salesOrderOnDemandResult)
void | setSalesOrderOrphanedResult(java.util.ArrayList salesOrderOrphanedResult)
void | setWorkOrderOnDemandResult(java.util.ArrayList workOrderOnDemandResult)
void | setWorkOrderOnOrderResult(java.util.ArrayList workOrderOnOrderResult)
Methods inherited from class bb.common.BB2PartInfo
getBom, getDwg, getHold, getInSip, getInSit, getInWip, getLeadtime, getMaxQty, getMinQty, getOndemand, getOnhand, getOnorder, getQtrUsage, getRev, getYrUsage, setBom, setDwg, setHold, setInSip, setInSit, setInWip, setLeadtime, setMaxQty, setMinQty, setOndemand, setOnhand, setOnorder, setQtrUsage, setRev, setYrUsage
Methods inherited from class bb.common.BB2PartBasicInfo
getDescription, getPart, setDescription, setPart
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2PartMrpResult

public BB2PartMrpResult()
Method Detail

getPurchaseOrderOnOrderResult

public java.util.ArrayList getPurchaseOrderOnOrderResult()

setPurchaseOrderOnOrderResult

public void setPurchaseOrderOnOrderResult(java.util.ArrayList purchaseOrderOnOrderResult)

getWorkOrderOnOrderResult

public java.util.ArrayList getWorkOrderOnOrderResult()

setWorkOrderOnOrderResult

public void setWorkOrderOnOrderResult(java.util.ArrayList workOrderOnOrderResult)

getWorkOrderOnDemandResult

public java.util.ArrayList getWorkOrderOnDemandResult()

setWorkOrderOnDemandResult

public void setWorkOrderOnDemandResult(java.util.ArrayList workOrderOnDemandResult)

getSalesOrderOnDemandResult

public java.util.ArrayList getSalesOrderOnDemandResult()

setSalesOrderOnDemandResult

public void setSalesOrderOnDemandResult(java.util.ArrayList salesOrderOnDemandResult)

getSalesOrderOrphanedResult

public java.util.ArrayList getSalesOrderOrphanedResult()

setSalesOrderOrphanedResult

public void setSalesOrderOrphanedResult(java.util.ArrayList salesOrderOrphanedResult)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2PartOnDemandListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2PartOnDemandListResult

java.lang.Object
    extended by  bb.common.BB2PartOnDemandListResult
All Implemented Interfaces:
java.io.Serializable
public class BB2PartOnDemandListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_INSIP
static java.lang.String | ORDER_BY_INSIT
static java.lang.String | ORDER_BY_INWIP
static java.lang.String | ORDER_BY_ONDEMAND
static java.lang.String | ORDER_BY_ONHAND
static java.lang.String | ORDER_BY_ONORDER
static java.lang.String | ORDER_BY_PART
Constructor Summary
BB2PartOnDemandListResult()
Method Summary
java.lang.String | getDescription()
java.math.BigDecimal | getInsip()
java.math.BigDecimal | getInsit()
java.math.BigDecimal | getInwip()
java.math.BigDecimal | getOndemand()
java.math.BigDecimal | getOnhand()
java.math.BigDecimal | getOnorder()
BB2Part | getPart()
void | setDescription(java.lang.String description)
void | setInsip(java.math.BigDecimal insip)
void | setInsit(java.math.BigDecimal insit)
void | setInwip(java.math.BigDecimal inwip)
void | setOndemand(java.math.BigDecimal ondemand)
void | setOnhand(java.math.BigDecimal onhand)
void | setOnorder(java.math.BigDecimal onorder)
void | setPart(BB2Part part)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PART

public static final java.lang.String ORDER_BY_PART
See Also:
Constant Field Values

ORDER_BY_ONHAND

public static final java.lang.String ORDER_BY_ONHAND
See Also:
Constant Field Values

ORDER_BY_ONORDER

public static final java.lang.String ORDER_BY_ONORDER
See Also:
Constant Field Values

ORDER_BY_ONDEMAND

public static final java.lang.String ORDER_BY_ONDEMAND
See Also:
Constant Field Values

ORDER_BY_INSIP

public static final java.lang.String ORDER_BY_INSIP
See Also:
Constant Field Values

ORDER_BY_INSIT

public static final java.lang.String ORDER_BY_INSIT
See Also:
Constant Field Values

ORDER_BY_INWIP

public static final java.lang.String ORDER_BY_INWIP
See Also:
Constant Field Values
Constructor Detail

BB2PartOnDemandListResult

public BB2PartOnDemandListResult()
Method Detail

getPart

public BB2Part getPart()

getDescription

public java.lang.String getDescription()

getOnhand

public java.math.BigDecimal getOnhand()

getOnorder

public java.math.BigDecimal getOnorder()

getOndemand

public java.math.BigDecimal getOndemand()

getInsip

public java.math.BigDecimal getInsip()

getInsit

public java.math.BigDecimal getInsit()

getInwip

public java.math.BigDecimal getInwip()

setPart

public void setPart(BB2Part part)

setDescription

public void setDescription(java.lang.String description)

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

setOnorder

public void setOnorder(java.math.BigDecimal onorder)

setOndemand

public void setOndemand(java.math.BigDecimal ondemand)

setInsip

public void setInsip(java.math.BigDecimal insip)

setInsit

public void setInsit(java.math.BigDecimal insit)

setInwip

public void setInwip(java.math.BigDecimal inwip)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2PartOnhandPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2PartOnhandPK

java.lang.Object
    extended by  bb.common.BB2PartOnhandPK
All Implemented Interfaces:
java.io.Serializable
public final class BB2PartOnhandPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2PartOnhandPK(BB2Part part, java.lang.String location)
BB2PartOnhandPK(PartPK pk, java.lang.String partFrom, java.lang.String location)
Method Summary
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
PartOnhandPK | getPk()
void | setPartFrom(java.lang.String partFrom)
void | setPk(PartOnhandPK pk)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2PartOnhandPK

public BB2PartOnhandPK(BB2Part part,
                       java.lang.String location)

BB2PartOnhandPK

public BB2PartOnhandPK(PartPK pk,
                       java.lang.String partFrom,
                       java.lang.String location)
Method Detail

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPk

public PartOnhandPK getPk()

setPk

public void setPk(PartOnhandPK pk)

getPartNumber

public java.lang.String getPartNumber()

getPartType

public java.lang.String getPartType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2PartOnLoanItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2PartOnLoanItemResult

java.lang.Object
    extended by  bb.common.BB2PartOnLoanItemResult
All Implemented Interfaces:
java.io.Serializable
public class BB2PartOnLoanItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2PartOnLoanItemResult()
Method Summary
java.lang.String | getCustomerId()
OnloanShipperItemPK | getPk()
java.math.BigDecimal | getQty()
java.util.Date | getShipDate()
java.lang.String | getStatus()
void | setCustomerId(java.lang.String customerId)
void | setPk(OnloanShipperItemPK pk)
void | setQty(java.math.BigDecimal qty)
void | setShipDate(java.util.Date shipDate)
void | setStatus(java.lang.String status)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2PartOnLoanItemResult

public BB2PartOnLoanItemResult()
Method Detail

setQty

public void setQty(java.math.BigDecimal qty)

setStatus

public void setStatus(java.lang.String status)

getQty

public java.math.BigDecimal getQty()

getStatus

public java.lang.String getStatus()

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getShipDate

public java.util.Date getShipDate()

setShipDate

public void setShipDate(java.util.Date shipDate)

getPk

public OnloanShipperItemPK getPk()

setPk

public void setPk(OnloanShipperItemPK pk)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2PartTotalInQADetailResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2PartTotalInQADetailResult

java.lang.Object
    extended by  bb.common.BB2PartBasicInfo
        extended by  bb.common.BB2PartTotalInQADetailResult
All Implemented Interfaces:
java.io.Serializable
public class BB2PartTotalInQADetailResult
extends BB2PartBasicInfo
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2PartTotalInQADetailResult()
Method Summary
java.util.List<PartInQAVO> | getDetails()
java.math.BigDecimal | getTotalInQA()
void | setDetails(java.util.List<PartInQAVO> details)
void | setTotalInQA(java.math.BigDecimal totalInQA)
Methods inherited from class bb.common.BB2PartBasicInfo
getDescription, getPart, setDescription, setPart
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2PartTotalInQADetailResult

public BB2PartTotalInQADetailResult()
Method Detail

getTotalInQA

public java.math.BigDecimal getTotalInQA()

setTotalInQA

public void setTotalInQA(java.math.BigDecimal totalInQA)

getDetails

public java.util.List<PartInQAVO> getDetails()

setDetails

public void setDetails(java.util.List<PartInQAVO> details)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2PartTotalInSipDetailResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2PartTotalInSipDetailResult

java.lang.Object
    extended by  bb.common.BB2PartBasicInfo
        extended by  bb.common.BB2PartTotalInSipDetailResult
All Implemented Interfaces:
java.io.Serializable
public class BB2PartTotalInSipDetailResult
extends BB2PartBasicInfo
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2PartTotalInSipDetailResult()
Method Summary
java.util.ArrayList | getDetails()
java.math.BigDecimal | getTotalInSip()
void | setDetails(java.util.ArrayList details)
void | setTotalInSip(java.math.BigDecimal totalInSip)
Methods inherited from class bb.common.BB2PartBasicInfo
getDescription, getPart, setDescription, setPart
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2PartTotalInSipDetailResult

public BB2PartTotalInSipDetailResult()
Method Detail

setTotalInSip

public void setTotalInSip(java.math.BigDecimal totalInSip)

setDetails

public void setDetails(java.util.ArrayList details)

getTotalInSip

public java.math.BigDecimal getTotalInSip()

getDetails

public java.util.ArrayList getDetails()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2PartTotalInSitDetailResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2PartTotalInSitDetailResult

java.lang.Object
    extended by  bb.common.BB2PartBasicInfo
        extended by  bb.common.BB2PartTotalInSitDetailResult
All Implemented Interfaces:
java.io.Serializable
public class BB2PartTotalInSitDetailResult
extends BB2PartBasicInfo
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2PartTotalInSitDetailResult()
Method Summary
java.util.ArrayList | getDetails()
java.math.BigDecimal | getTotalInSit()
void | setDetails(java.util.ArrayList details)
void | setTotalInSit(java.math.BigDecimal totalInSit)
Methods inherited from class bb.common.BB2PartBasicInfo
getDescription, getPart, setDescription, setPart
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2PartTotalInSitDetailResult

public BB2PartTotalInSitDetailResult()
Method Detail

setTotalInSit

public void setTotalInSit(java.math.BigDecimal totalInSit)

setDetails

public void setDetails(java.util.ArrayList details)

getTotalInSit

public java.math.BigDecimal getTotalInSit()

getDetails

public java.util.ArrayList getDetails()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2PartTotalInSTODetailResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2PartTotalInSTODetailResult

java.lang.Object
    extended by  bb.common.BB2PartBasicInfo
        extended by  bb.common.BB2PartTotalInSTODetailResult
All Implemented Interfaces:
java.io.Serializable
public class BB2PartTotalInSTODetailResult
extends BB2PartBasicInfo
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2PartTotalInSTODetailResult()
Method Summary
java.util.ArrayList | getDetails()
java.math.BigDecimal | getTotalInSTO()
void | setDetails(java.util.ArrayList details)
void | setTotalInSTO(java.math.BigDecimal totalInSTO)
Methods inherited from class bb.common.BB2PartBasicInfo
getDescription, getPart, setDescription, setPart
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2PartTotalInSTODetailResult

public BB2PartTotalInSTODetailResult()
Method Detail

setDetails

public void setDetails(java.util.ArrayList details)

getDetails

public java.util.ArrayList getDetails()

getTotalInSTO

public java.math.BigDecimal getTotalInSTO()

setTotalInSTO

public void setTotalInSTO(java.math.BigDecimal totalInSTO)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2PartTotalInWipDetailResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2PartTotalInWipDetailResult

java.lang.Object
    extended by  bb.common.BB2PartBasicInfo
        extended by  bb.common.BB2PartTotalInWipDetailResult
All Implemented Interfaces:
java.io.Serializable
public class BB2PartTotalInWipDetailResult
extends BB2PartBasicInfo
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2PartTotalInWipDetailResult()
Method Summary
java.util.ArrayList | getDetails()
java.util.ArrayList | getDwoDetails()
java.math.BigDecimal | getTotalInWip()
void | setDetails(java.util.ArrayList details)
void | setDwoDetails(java.util.ArrayList dwoDetails)
void | setTotalInWip(java.math.BigDecimal totalInWip)
Methods inherited from class bb.common.BB2PartBasicInfo
getDescription, getPart, setDescription, setPart
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2PartTotalInWipDetailResult

public BB2PartTotalInWipDetailResult()
Method Detail

setTotalInWip

public void setTotalInWip(java.math.BigDecimal totalInWip)

setDetails

public void setDetails(java.util.ArrayList details)

getTotalInWip

public java.math.BigDecimal getTotalInWip()

getDetails

public java.util.ArrayList getDetails()

getDwoDetails

public java.util.ArrayList getDwoDetails()

setDwoDetails

public void setDwoDetails(java.util.ArrayList dwoDetails)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2PartTotalOndemandDetailResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2PartTotalOndemandDetailResult

java.lang.Object
    extended by  bb.common.BB2PartBasicInfo
        extended by  bb.common.BB2PartTotalOndemandDetailResult
All Implemented Interfaces:
java.io.Serializable
public class BB2PartTotalOndemandDetailResult
extends BB2PartBasicInfo
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2PartTotalOndemandDetailResult()
Method Summary
java.util.ArrayList | getDwoDetails()
java.util.ArrayList<NonproductivePickingOnDemandResult> | getNpDetails()
java.util.ArrayList<RMAReceiverResult> | getRmaDetails()
java.util.ArrayList | getSoDetails()
java.math.BigDecimal | getTotalOndemand()
java.util.ArrayList | getWoDetails()
void | setDwoDetails(java.util.ArrayList dwoDetails)
void | setNpDetails(java.util.ArrayList<NonproductivePickingOnDemandResult> npDetails)
void | setRmaDetails(java.util.ArrayList<RMAReceiverResult> rmaDetails)
void | setSoDetails(java.util.ArrayList soDetails)
void | setTotalOndemand(java.math.BigDecimal totalOndemand)
void | setWoDetails(java.util.ArrayList woDetails)
Methods inherited from class bb.common.BB2PartBasicInfo
getDescription, getPart, setDescription, setPart
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2PartTotalOndemandDetailResult

public BB2PartTotalOndemandDetailResult()
Method Detail

setTotalOndemand

public void setTotalOndemand(java.math.BigDecimal totalOndemand)

setSoDetails

public void setSoDetails(java.util.ArrayList soDetails)

setWoDetails

public void setWoDetails(java.util.ArrayList woDetails)

getTotalOndemand

public java.math.BigDecimal getTotalOndemand()

getSoDetails

public java.util.ArrayList getSoDetails()

getWoDetails

public java.util.ArrayList getWoDetails()

getDwoDetails

public java.util.ArrayList getDwoDetails()

setDwoDetails

public void setDwoDetails(java.util.ArrayList dwoDetails)

getNpDetails

public java.util.ArrayList<NonproductivePickingOnDemandResult> getNpDetails()

setNpDetails

public void setNpDetails(java.util.ArrayList<NonproductivePickingOnDemandResult> npDetails)

getRmaDetails

public java.util.ArrayList<RMAReceiverResult> getRmaDetails()

setRmaDetails

public void setRmaDetails(java.util.ArrayList<RMAReceiverResult> rmaDetails)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2PartTotalOnhandDetailResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2PartTotalOnhandDetailResult

java.lang.Object
    extended by  bb.common.BB2PartBasicInfo
        extended by  bb.common.BB2PartTotalOnhandDetailResult
All Implemented Interfaces:
java.io.Serializable
public class BB2PartTotalOnhandDetailResult
extends BB2PartBasicInfo
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2PartTotalOnhandDetailResult()
Method Summary
java.util.ArrayList | getDetails()
java.math.BigDecimal | getMaxQty()
java.math.BigDecimal | getMinQty()
java.math.BigDecimal | getQtrUsage()
java.math.BigDecimal | getTotalOnhand()
java.lang.String | getUnit()
java.math.BigDecimal | getWeight()
java.lang.String | getWeightUnit()
java.math.BigDecimal | getYrUsage()
void | setDetails(java.util.ArrayList details)
void | setMaxQty(java.math.BigDecimal maxQty)
void | setMinQty(java.math.BigDecimal minQty)
void | setQtrUsage(java.math.BigDecimal qtrUsage)
void | setTotalOnhand(java.math.BigDecimal totalOnhand)
void | setUnit(java.lang.String unit)
void | setWeight(java.math.BigDecimal weight)
void | setWeightUnit(java.lang.String weightUnit)
void | setYrUsage(java.math.BigDecimal yrUsage)
Methods inherited from class bb.common.BB2PartBasicInfo
getDescription, getPart, setDescription, setPart
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2PartTotalOnhandDetailResult

public BB2PartTotalOnhandDetailResult()
Method Detail

setTotalOnhand

public void setTotalOnhand(java.math.BigDecimal totalOnhand)

setDetails

public void setDetails(java.util.ArrayList details)

setMinQty

public void setMinQty(java.math.BigDecimal minQty)

setMaxQty

public void setMaxQty(java.math.BigDecimal maxQty)

setQtrUsage

public void setQtrUsage(java.math.BigDecimal qtrUsage)

setYrUsage

public void setYrUsage(java.math.BigDecimal yrUsage)

setWeight

public void setWeight(java.math.BigDecimal weight)

setWeightUnit

public void setWeightUnit(java.lang.String weightUnit)

setUnit

public void setUnit(java.lang.String unit)

getTotalOnhand

public java.math.BigDecimal getTotalOnhand()

getDetails

public java.util.ArrayList getDetails()

getMinQty

public java.math.BigDecimal getMinQty()

getMaxQty

public java.math.BigDecimal getMaxQty()

getQtrUsage

public java.math.BigDecimal getQtrUsage()

getYrUsage

public java.math.BigDecimal getYrUsage()

getWeight

public java.math.BigDecimal getWeight()

getWeightUnit

public java.lang.String getWeightUnit()

getUnit

public java.lang.String getUnit()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2PartTotalOnloanDetailResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2PartTotalOnloanDetailResult

java.lang.Object
    extended by  bb.common.BB2PartBasicInfo
        extended by  bb.common.BB2PartTotalOnloanDetailResult
All Implemented Interfaces:
java.io.Serializable
public class BB2PartTotalOnloanDetailResult
extends BB2PartBasicInfo
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2PartTotalOnloanDetailResult()
Method Summary
java.util.ArrayList | getDetails()
java.math.BigDecimal | getTotalOnloan()
void | setDetails(java.util.ArrayList details)
void | setTotalOnloan(java.math.BigDecimal totalOnloan)
Methods inherited from class bb.common.BB2PartBasicInfo
getDescription, getPart, setDescription, setPart
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2PartTotalOnloanDetailResult

public BB2PartTotalOnloanDetailResult()
Method Detail

setTotalOnloan

public void setTotalOnloan(java.math.BigDecimal totalOnloan)

setDetails

public void setDetails(java.util.ArrayList details)

getTotalOnloan

public java.math.BigDecimal getTotalOnloan()

getDetails

public java.util.ArrayList getDetails()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2PartTotalOnorderDetailResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2PartTotalOnorderDetailResult

java.lang.Object
    extended by  bb.common.BB2PartBasicInfo
        extended by  bb.common.BB2PartTotalOnorderDetailResult
All Implemented Interfaces:
java.io.Serializable
public class BB2PartTotalOnorderDetailResult
extends BB2PartBasicInfo
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2PartTotalOnorderDetailResult()
Method Summary
java.util.ArrayList | getDwoDetails()
java.util.ArrayList | getPoDetails()
java.util.ArrayList | getSwsDetails()
java.math.BigDecimal | getTotalOnorder()
java.util.ArrayList | getWoDetails()
void | setDwoDetails(java.util.ArrayList dwoDetails)
void | setPoDetails(java.util.ArrayList poDetails)
void | setSwsDetails(java.util.ArrayList swsDetails)
void | setTotalOnorder(java.math.BigDecimal totalOnorder)
void | setWoDetails(java.util.ArrayList woDetails)
Methods inherited from class bb.common.BB2PartBasicInfo
getDescription, getPart, setDescription, setPart
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2PartTotalOnorderDetailResult

public BB2PartTotalOnorderDetailResult()
Method Detail

setTotalOnorder

public void setTotalOnorder(java.math.BigDecimal totalOnorder)

setPoDetails

public void setPoDetails(java.util.ArrayList poDetails)

setWoDetails

public void setWoDetails(java.util.ArrayList woDetails)

getTotalOnorder

public java.math.BigDecimal getTotalOnorder()

getPoDetails

public java.util.ArrayList getPoDetails()

getWoDetails

public java.util.ArrayList getWoDetails()

getSwsDetails

public java.util.ArrayList getSwsDetails()

setSwsDetails

public void setSwsDetails(java.util.ArrayList swsDetails)

getDwoDetails

public java.util.ArrayList getDwoDetails()

setDwoDetails

public void setDwoDetails(java.util.ArrayList dwoDetails)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2Picture

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2Picture

java.lang.Object
    extended by  bb.common.BB2File
        extended by  bb.common.BB2Picture
All Implemented Interfaces:
java.io.Serializable
public class BB2Picture
extends BB2File

See Also:
Serialized Form

Constructor Summary
BB2Picture()
Method Summary
java.lang.Short | getHeight()
java.lang.Long | getId()
java.lang.Short | getWidth()
boolean | isMainPicture()
void | setHeight(java.lang.Short height)
void | setId(java.lang.Long id)
void | setMainPicture(boolean mainPicture)
void | setWidth(java.lang.Short width)
Methods inherited from class bb.common.BB2File
getContext, getExt, getFilename, setContext, setExt, setFilename
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2Picture

public BB2Picture()
Method Detail

getId

public java.lang.Long getId()

setId

public void setId(java.lang.Long id)

isMainPicture

public boolean isMainPicture()

setMainPicture

public void setMainPicture(boolean mainPicture)

getHeight

public java.lang.Short getHeight()

setHeight

public void setHeight(java.lang.Short height)

getWidth

public java.lang.Short getWidth()

setWidth

public void setWidth(java.lang.Short width)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2QtyAndMoneyMap

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2QtyAndMoneyMap

java.lang.Object
    extended by  bb.common.BB2QtyAndMoneyMap
All Implemented Interfaces:
java.io.Serializable
public class BB2QtyAndMoneyMap
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | INSIP
static java.lang.String | INSIT
Constructor Summary
BB2QtyAndMoneyMap()
Method Summary
QtyAndMoney | get(java.lang.String key)
void | put(java.lang.String key, QtyAndMoney value)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

INSIP

public static java.lang.String INSIP

INSIT

public static java.lang.String INSIT
Constructor Detail

BB2QtyAndMoneyMap

public BB2QtyAndMoneyMap()
Method Detail

put

public void put(java.lang.String key,
                QtyAndMoney value)

get

public QtyAndMoney get(java.lang.String key)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2RefdocPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2RefdocPK

java.lang.Object
    extended by  bb.common.BB2RefdocPK
All Implemented Interfaces:
java.io.Serializable
public class BB2RefdocPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2RefdocPK(RefdocVO vo)
BB2RefdocPK(java.lang.String forderNumber, java.lang.String fitemNumber, java.lang.String torderNumber, java.lang.String titemNumber)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getFitemNumber()
java.lang.String | getForderNumber()
java.lang.String | getTitemNumber()
java.lang.String | getTorderNumber()
int | hashCode()
void | setFitemNumber(java.lang.String fitemNumber)
void | setForderNumber(java.lang.String forderNumber)
void | setTitemNumber(java.lang.String titemNumber)
void | setTorderNumber(java.lang.String torderNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

BB2RefdocPK

public BB2RefdocPK(java.lang.String forderNumber,
                   java.lang.String fitemNumber,
                   java.lang.String torderNumber,
                   java.lang.String titemNumber)

BB2RefdocPK

public BB2RefdocPK(RefdocVO vo)
Method Detail

getForderNumber

public java.lang.String getForderNumber()

setForderNumber

public void setForderNumber(java.lang.String forderNumber)

getFitemNumber

public java.lang.String getFitemNumber()

setFitemNumber

public void setFitemNumber(java.lang.String fitemNumber)

getTorderNumber

public java.lang.String getTorderNumber()

setTorderNumber

public void setTorderNumber(java.lang.String torderNumber)

getTitemNumber

public java.lang.String getTitemNumber()

setTitemNumber

public void setTitemNumber(java.lang.String titemNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2ServerException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2ServerException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  bb.common.BB2ServerException
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
AppException, BB2DocumentException, BB2MessagingException, BizException, DBAccessException, InvokeException, LoginException
public class BB2ServerException
extends java.lang.Exception

See Also:
Serialized Form

Field Summary
static Reason UNKNOWN_EXCEPTION
Constructor Summary
BB2ServerException(java.lang.Exception e)
BB2ServerException(java.lang.Exception e, java.lang.Object parameter)
BB2ServerException(java.lang.Exception e, Reason reason)
BB2ServerException(java.lang.Exception e, Reason reason, java.lang.Object parameter)
BB2ServerException(Reason reason)
BB2ServerException(Reason reason, java.lang.Object parameter)
BB2ServerException(java.lang.String message)
BB2ServerException(java.lang.String message, java.lang.Object parameter)
BB2ServerException(java.lang.String message, Reason reason)
BB2ServerException(java.lang.String message, Reason reason, java.lang.Object parameter)
Method Summary
java.lang.Object | getParameter()
Reason | getReason()
void | setParameter(java.lang.Object parameter)
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

UNKNOWN_EXCEPTION

public static final Reason UNKNOWN_EXCEPTION
Constructor Detail

BB2ServerException

public BB2ServerException(java.lang.Exception e)

BB2ServerException

public BB2ServerException(java.lang.Exception e,
                          java.lang.Object parameter)

BB2ServerException

public BB2ServerException(java.lang.String message)

BB2ServerException

public BB2ServerException(java.lang.String message,
                          java.lang.Object parameter)

BB2ServerException

public BB2ServerException(java.lang.Exception e,
                          Reason reason)

BB2ServerException

public BB2ServerException(java.lang.Exception e,
                          Reason reason,
                          java.lang.Object parameter)

BB2ServerException

public BB2ServerException(Reason reason)

BB2ServerException

public BB2ServerException(Reason reason,
                          java.lang.Object parameter)

BB2ServerException

public BB2ServerException(java.lang.String message,
                          Reason reason)

BB2ServerException

public BB2ServerException(java.lang.String message,
                          Reason reason,
                          java.lang.Object parameter)
Method Detail

getReason

public Reason getReason()

getParameter

public java.lang.Object getParameter()

setParameter

public void setParameter(java.lang.Object parameter)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2Task

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2Task

java.lang.Object
    extended by  bb.common.BB2Task
All Implemented Interfaces:
java.io.Serializable
public class BB2Task
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2Task(java.lang.String name, java.lang.String taskClass, java.lang.String description, java.lang.String params)
Method Summary
java.lang.String | getDescription()
java.lang.String | getName()
java.lang.String | getParams()
java.lang.String | getTaskClass()
void | setDescription(java.lang.String description)
void | setName(java.lang.String name)
void | setParams(java.lang.String params)
void | setTaskClass(java.lang.String taskClass)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2Task

public BB2Task(java.lang.String name,
               java.lang.String taskClass,
               java.lang.String description,
               java.lang.String params)
Method Detail

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getParams

public java.lang.String getParams()

setParams

public void setParams(java.lang.String params)

getTaskClass

public java.lang.String getTaskClass()

setTaskClass

public void setTaskClass(java.lang.String taskClass)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2TimeFactory

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2TimeFactory

java.lang.Object
    extended by  bb.common.BB2TimeFactory

public class BB2TimeFactory
extends java.lang.Object

Constructor Summary
BB2TimeFactory()
Method Summary
static void | clearServerTime()
static java.util.Date | getBB2Time()
static java.util.Date | getBB2Time(java.util.Date date)
static void | initServerTime(long initServerTime)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2TimeFactory

public BB2TimeFactory()
Method Detail

initServerTime

public static void initServerTime(long initServerTime)

clearServerTime

public static void clearServerTime()

getBB2Time

public static java.util.Date getBB2Time()

getBB2Time

public static java.util.Date getBB2Time(java.util.Date date)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2tripleString

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2tripleString

java.lang.Object
    extended by  bb.common.BB2tripleString
All Implemented Interfaces:
java.io.Serializable
public class BB2tripleString
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
BB2tripleString()
default constructor
BB2tripleString(java.lang.String accountNumber, java.lang.String currency, java.lang.String addressId)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAccountNumber()
java.lang.String | getAddressId()
java.lang.String | getCurrency()
int | hashCode()
void | setAccountNumber(java.lang.String accountNumber)
void | setAddressId(java.lang.String addressId)
void | setCurrency(java.lang.String currency)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

BB2tripleString

public BB2tripleString(java.lang.String accountNumber,
                       java.lang.String currency,
                       java.lang.String addressId)
full constructor

BB2tripleString

public BB2tripleString()
default constructor

Method Detail

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getAddressId

public java.lang.String getAddressId()

setAddressId

public void setAddressId(java.lang.String addressId)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2Util

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2Util

java.lang.Object
    extended by  bb.common.BB2Util

public class BB2Util
extends java.lang.Object

Method Summary
static void clearDir(java.io.File dir)
static java.util.HashMap collectionToMapByProperty(java.util.Collection objects, java.lang.String propertyName)
static java.util.HashMap collectionToMapByProperty(java.util.Collection objects, java.lang.String propertyName, boolean single)
static int compareDateWithoutTime(java.util.Date date1, java.util.Date date2)
static boolean compareList(java.util.List list1, java.util.List list2, boolean shift)
static java.lang.String concatLocation(java.lang.String warehouse, java.lang.String location, java.lang.String split)
static java.lang.String convertVOClassToPOClass(java.lang.String voClass)
static java.math.BigDecimal cost(java.math.BigDecimal cost, java.math.BigDecimal exchange, java.math.BigDecimal tax, java.math.BigDecimal disc, boolean includePoTax, int length)
static
<T> T
duplicateVO(T vo)
static java.lang.String filtrateLanguage(java.lang.String language)
static java.lang.String formateIntegerToFixedLengthStirng(int number, int stringLength)
static java.lang.String formatIntegerNumber(java.lang.Object value, int num)
static BB2Part getBB2PartFromOrderItem(java.lang.Object item)
static java.math.BigDecimal getBigDecimal(java.lang.Object obj)
static java.lang.String getBizBoxUserPairString(java.lang.String userName, java.lang.String system)
static byte[] getByteArrayFromImageIcon(javax.swing.ImageIcon icon)
static java.lang.Class getCollectionFieldGenericType(java.lang.reflect.Field f)
static java.util.Date getCurrentMonthEndDate()
static java.util.Date getCurrentMonthStartDate()
static java.util.Date getCurrentYearFirstDate()
static java.util.Date getCurrentYearLastDate()
static java.util.Date getDateAfter(java.util.Date date, int value)
static java.util.Date getDateAfter(java.util.Date date, int value, int calendarType)
static java.util.Date getDateAfter(int value)
static java.util.Date getDateAfter(int value, int calendarType)
static java.lang.String getDateLocalString(java.util.Date date)
static java.lang.String getDateTimeLocalString(java.util.Date date)
static java.util.Date getDateWithMaxTime(java.util.Date date)
static java.util.Date getDateWithMinTime(java.util.Date date)
static java.util.Date getDateWithoutTime(java.util.Date date)
static java.util.Map getDayMatchTime(java.lang.String values, java.lang.String split)
static java.lang.Object getFItemPK(RefdocVO vo, java.lang.Class<?> clazz)
static java.lang.String getFRefDocString(RefdocVO vo)
static javax.swing.ImageIcon getImageIconFromByteArray(byte[] bs)
static java.util.Date getMonthEndDate(int year, int month)
static java.util.Date getMonthFirstDate(java.util.Date date)
static java.util.Date getMonthFirstDateMinTime(java.util.Date date)
static java.util.Date getMonthLastDate(java.util.Date date)
static java.util.Date getMonthLastDateMaxTime(java.util.Date date)
static int getMonthOffset(java.util.Date date1, java.util.Date date2)
static java.util.Date getMonthStartDate(int year, int month)
static java.lang.String getNextItemNumber(java.lang.String oldItemNumber, int bit, boolean order)
static java.lang.String getNormalSubInQuery(java.lang.String values)
static java.lang.String getNumberString(java.lang.Object obj)
static java.lang.Object getObjectBeanValue(java.lang.Class object, java.lang.String propertyName)
static java.lang.Object getObjectBeanValue(java.lang.Object object, java.lang.String propertyName)
static java.lang.String getObjectParam(java.lang.String values)
static OrderPK getOrderPkFromRefDoc(java.lang.String refDoc)
static java.lang.String getPartFrom(boolean isTool)
static java.lang.String getRefDocString(java.lang.String orderNumber, java.lang.String itemNumber)
static java.lang.String getRefDocTwo(RefdocVO vo)
static java.lang.String getSgUserName(SgClientProgramUserVO sgUser)
static java.lang.String getStringNumber(java.lang.String str)
static java.lang.String getSubInQuery(java.lang.String values, java.lang.String split)
static java.lang.String getTerm(int term, java.math.BigDecimal discount, int days)
static java.math.BigDecimal getTermDiscount(java.lang.String value)
static int getTermDiscountDays(java.lang.String value)
static int getTermNumber(java.lang.String value)
static java.lang.String getTimeZoneString(boolean shortStyle)
static java.lang.Object getTItemPK(RefdocVO vo, java.lang.Class<?> clazz)
static java.lang.String getTRefDocString(RefdocVO vo)
static java.lang.String getWarehouseFromLocation(java.lang.String location, java.lang.String split)
static java.util.Date getYearFirstDate(java.util.Date date)
static java.util.Date getYearLastDate(java.util.Date date)
static java.lang.String getYearMonth(java.util.Date date)
static java.lang.String getYearMonthLocalString(java.util.Date date)
static java.util.Set<java.lang.String> getYearMonths(java.util.Date fDate, java.util.Date toDate)
static java.lang.String initMessageStatus(java.lang.String values)
static boolean inStrings(java.lang.String value, java.lang.String values, java.lang.String split)
static int interval(java.util.Date from, java.util.Date end)
static int intervalAbs(java.util.Date from, java.util.Date end)
static boolean isDoubleDigit(java.lang.String value, boolean negative)
static boolean isEmailAddressValid(java.lang.String emailAddress)
static boolean isEmptyString(java.lang.String str)
static boolean isInteger(java.lang.String value, boolean allowNegative)
static boolean isLegalTerms(java.lang.String value)
static boolean isNotAllString(java.lang.String str)
static boolean isNotEmptyString(java.lang.String str)
static java.lang.String leftTrim(java.lang.String value, java.lang.String trim)
static boolean makeDocumentDir(java.lang.String dir)
static java.util.Map<java.lang.String,java.lang.Object> mergeNumberMap(java.util.Map<java.lang.String,java.lang.Object> destMap, java.util.Map<java.lang.String,java.lang.Object> sourceMap)
static java.math.BigDecimal[] parseNumber(java.lang.String numberStr)
static void print(java.lang.Object obj)
Debug tool print
static java.lang.Object readByBytes(byte[] bytes)
static java.lang.String removeLastComma(java.lang.String text)
static java.lang.String replaceString(java.lang.String text, java.lang.String comma)
static java.math.BigDecimal restrictValue(java.math.BigDecimal value)
static java.math.BigDecimal restrictValue(java.math.BigDecimal value, java.math.BigDecimal from, java.math.BigDecimal to)
static java.math.BigDecimal restrictValue(java.math.BigDecimal value, int multiple)
static java.lang.String rightTrim(java.lang.String value, java.lang.String trim)
static void setBeanValue(java.lang.Object object, java.lang.String propertyName, java.lang.Object value)
static void setRefDocTwo(RefdocVO vo, java.lang.String refString)
static java.lang.String[] splitStrings(java.lang.String values, java.lang.String split)
static java.util.Date toDate(java.lang.String date)
static java.lang.String trim(java.lang.String value, java.lang.String trim)
static java.lang.String trim(java.lang.String value, java.lang.String trim, boolean left, boolean right)
static byte[] unzipFile(byte[] data)
static java.util.Collection unzipObject(byte[] bytes)
static java.lang.String upperCaseFirstLetter(java.lang.String text)
static byte[] writeToBytes(java.lang.Object exchange)
static byte[] zipObject(java.util.Collection data)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

zipObject

public static byte[] zipObject(java.util.Collection data)
                        throws java.lang.Exception
Throws:
java.lang.Exception

unzipObject

public static java.util.Collection unzipObject(byte[] bytes)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

unzipFile

public static byte[] unzipFile(byte[] data)
                        throws java.lang.Exception
Throws:
java.lang.Exception

getRefDocTwo

public static java.lang.String getRefDocTwo(RefdocVO vo)

setRefDocTwo

public static void setRefDocTwo(RefdocVO vo,
                                java.lang.String refString)

splitStrings

public static java.lang.String[] splitStrings(java.lang.String values,
                                              java.lang.String split)

inStrings

public static boolean inStrings(java.lang.String value,
                                java.lang.String values,
                                java.lang.String split)

duplicateVO

public static <T> T duplicateVO(T vo)

getSubInQuery

public static java.lang.String getSubInQuery(java.lang.String values,
                                             java.lang.String split)

getObjectParam

public static java.lang.String getObjectParam(java.lang.String values)

getDayMatchTime

public static java.util.Map getDayMatchTime(java.lang.String values,
                                            java.lang.String split)

getNormalSubInQuery

public static java.lang.String getNormalSubInQuery(java.lang.String values)

interval

public static int interval(java.util.Date from,
                           java.util.Date end)

intervalAbs

public static int intervalAbs(java.util.Date from,
                              java.util.Date end)

cost

public static java.math.BigDecimal cost(java.math.BigDecimal cost,
                                        java.math.BigDecimal exchange,
                                        java.math.BigDecimal tax,
                                        java.math.BigDecimal disc,
                                        boolean includePoTax,
                                        int length)

getPartFrom

public static java.lang.String getPartFrom(boolean isTool)

getRefDocString

public static java.lang.String getRefDocString(java.lang.String orderNumber,
                                               java.lang.String itemNumber)

getFRefDocString

public static java.lang.String getFRefDocString(RefdocVO vo)

getTRefDocString

public static java.lang.String getTRefDocString(RefdocVO vo)

getFItemPK

public static java.lang.Object getFItemPK(RefdocVO vo,
                                          java.lang.Class<?> clazz)
                                   throws java.lang.Exception
Parameters:
vo - RefdocVO
clazz - Class, Require that a constructor(String, String) exists
Returns:
Object
Throws:
java.lang.Exception

getTItemPK

public static java.lang.Object getTItemPK(RefdocVO vo,
                                          java.lang.Class<?> clazz)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

getDateAfter

public static java.util.Date getDateAfter(java.util.Date date,
                                          int value)

getDateAfter

public static java.util.Date getDateAfter(java.util.Date date,
                                          int value,
                                          int calendarType)

getDateAfter

public static java.util.Date getDateAfter(int value)

getDateAfter

public static java.util.Date getDateAfter(int value,
                                          int calendarType)

getMonthStartDate

public static java.util.Date getMonthStartDate(int year,
                                               int month)

getMonthEndDate

public static java.util.Date getMonthEndDate(int year,
                                             int month)

getCurrentMonthStartDate

public static java.util.Date getCurrentMonthStartDate()

getMonthOffset

public static int getMonthOffset(java.util.Date date1,
                                 java.util.Date date2)

compareDateWithoutTime

public static int compareDateWithoutTime(java.util.Date date1,
                                         java.util.Date date2)

getDateWithoutTime

public static java.util.Date getDateWithoutTime(java.util.Date date)

getCurrentMonthEndDate

public static java.util.Date getCurrentMonthEndDate()

getMonthFirstDate

public static java.util.Date getMonthFirstDate(java.util.Date date)

getMonthFirstDateMinTime

public static java.util.Date getMonthFirstDateMinTime(java.util.Date date)

getMonthLastDate

public static java.util.Date getMonthLastDate(java.util.Date date)

getMonthLastDateMaxTime

public static java.util.Date getMonthLastDateMaxTime(java.util.Date date)

getDateWithMinTime

public static java.util.Date getDateWithMinTime(java.util.Date date)

getDateWithMaxTime

public static java.util.Date getDateWithMaxTime(java.util.Date date)

getCurrentYearFirstDate

public static java.util.Date getCurrentYearFirstDate()

getCurrentYearLastDate

public static java.util.Date getCurrentYearLastDate()

getYearFirstDate

public static java.util.Date getYearFirstDate(java.util.Date date)

getYearLastDate

public static java.util.Date getYearLastDate(java.util.Date date)

getYearMonth

public static java.lang.String getYearMonth(java.util.Date date)

getYearMonths

public static java.util.Set<java.lang.String> getYearMonths(java.util.Date fDate,
                                                            java.util.Date toDate)

getBizBoxUserPairString

public static java.lang.String getBizBoxUserPairString(java.lang.String userName,
                                                       java.lang.String system)

formatIntegerNumber

public static java.lang.String formatIntegerNumber(java.lang.Object value,
                                                   int num)

formateIntegerToFixedLengthStirng

public static java.lang.String formateIntegerToFixedLengthStirng(int number,
                                                                 int stringLength)

readByBytes

public static java.lang.Object readByBytes(byte[] bytes)

writeToBytes

public static byte[] writeToBytes(java.lang.Object exchange)

isLegalTerms

public static boolean isLegalTerms(java.lang.String value)

getTermNumber

public static int getTermNumber(java.lang.String value)

getTermDiscount

public static java.math.BigDecimal getTermDiscount(java.lang.String value)

getTermDiscountDays

public static int getTermDiscountDays(java.lang.String value)

getTerm

public static java.lang.String getTerm(int term,
                                       java.math.BigDecimal discount,
                                       int days)

restrictValue

public static java.math.BigDecimal restrictValue(java.math.BigDecimal value,
                                                 java.math.BigDecimal from,
                                                 java.math.BigDecimal to)

restrictValue

public static java.math.BigDecimal restrictValue(java.math.BigDecimal value)

restrictValue

public static java.math.BigDecimal restrictValue(java.math.BigDecimal value,
                                                 int multiple)

getOrderPkFromRefDoc

public static OrderPK getOrderPkFromRefDoc(java.lang.String refDoc)

compareList

public static boolean compareList(java.util.List list1,
                                  java.util.List list2,
                                  boolean shift)

clearDir

public static void clearDir(java.io.File dir)

trim

public static java.lang.String trim(java.lang.String value,
                                    java.lang.String trim,
                                    boolean left,
                                    boolean right)

trim

public static java.lang.String trim(java.lang.String value,
                                    java.lang.String trim)

leftTrim

public static java.lang.String leftTrim(java.lang.String value,
                                        java.lang.String trim)

rightTrim

public static java.lang.String rightTrim(java.lang.String value,
                                         java.lang.String trim)

getTimeZoneString

public static java.lang.String getTimeZoneString(boolean shortStyle)

isNotEmptyString

public static boolean isNotEmptyString(java.lang.String str)

isEmptyString

public static boolean isEmptyString(java.lang.String str)

isNotAllString

public static boolean isNotAllString(java.lang.String str)

getDateLocalString

public static java.lang.String getDateLocalString(java.util.Date date)

getYearMonthLocalString

public static java.lang.String getYearMonthLocalString(java.util.Date date)

getDateTimeLocalString

public static java.lang.String getDateTimeLocalString(java.util.Date date)

toDate

public static java.util.Date toDate(java.lang.String date)

isEmailAddressValid

public static boolean isEmailAddressValid(java.lang.String emailAddress)

makeDocumentDir

public static boolean makeDocumentDir(java.lang.String dir)

removeLastComma

public static java.lang.String removeLastComma(java.lang.String text)

replaceString

public static java.lang.String replaceString(java.lang.String text,
                                             java.lang.String comma)

initMessageStatus

public static java.lang.String initMessageStatus(java.lang.String values)

getImageIconFromByteArray

public static javax.swing.ImageIcon getImageIconFromByteArray(byte[] bs)

getByteArrayFromImageIcon

public static byte[] getByteArrayFromImageIcon(javax.swing.ImageIcon icon)

print

public static void print(java.lang.Object obj)
Debug tool print

setBeanValue

public static void setBeanValue(java.lang.Object object,
                                java.lang.String propertyName,
                                java.lang.Object value)
                         throws java.lang.Exception
Throws:
java.lang.Exception

getObjectBeanValue

public static java.lang.Object getObjectBeanValue(java.lang.Object object,
                                                  java.lang.String propertyName)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

getObjectBeanValue

public static java.lang.Object getObjectBeanValue(java.lang.Class object,
                                                  java.lang.String propertyName)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

getCollectionFieldGenericType

public static java.lang.Class getCollectionFieldGenericType(java.lang.reflect.Field f)

collectionToMapByProperty

public static java.util.HashMap collectionToMapByProperty(java.util.Collection objects,
                                                          java.lang.String propertyName)

collectionToMapByProperty

public static java.util.HashMap collectionToMapByProperty(java.util.Collection objects,
                                                          java.lang.String propertyName,
                                                          boolean single)

convertVOClassToPOClass

public static java.lang.String convertVOClassToPOClass(java.lang.String voClass)

filtrateLanguage

public static java.lang.String filtrateLanguage(java.lang.String language)

getNextItemNumber

public static java.lang.String getNextItemNumber(java.lang.String oldItemNumber,
                                                 int bit,
                                                 boolean order)

isDoubleDigit

public static boolean isDoubleDigit(java.lang.String value,
                                    boolean negative)

getStringNumber

public static java.lang.String getStringNumber(java.lang.String str)

mergeNumberMap

public static java.util.Map<java.lang.String,java.lang.Object> mergeNumberMap(java.util.Map<java.lang.String,java.lang.Object> destMap,
                                                                              java.util.Map<java.lang.String,java.lang.Object> sourceMap)
Parameters:
destMap -
sourceMap -
Returns:
map; merge two map which contains BigDecimal value or number format String value. for example destMap contains key "A" and value 1, sourceMap contains key "A" value 2 and key "B" value 1; after merging, the destMap constains key "A" and value 3 and key "B" value 1;

getWarehouseFromLocation

public static java.lang.String getWarehouseFromLocation(java.lang.String location,
                                                        java.lang.String split)

concatLocation

public static java.lang.String concatLocation(java.lang.String warehouse,
                                              java.lang.String location,
                                              java.lang.String split)

getBB2PartFromOrderItem

public static BB2Part getBB2PartFromOrderItem(java.lang.Object item)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

upperCaseFirstLetter

public static java.lang.String upperCaseFirstLetter(java.lang.String text)

getNumberString

public static java.lang.String getNumberString(java.lang.Object obj)

getBigDecimal

public static java.math.BigDecimal getBigDecimal(java.lang.Object obj)

getSgUserName

public static java.lang.String getSgUserName(SgClientProgramUserVO sgUser)

parseNumber

public static java.math.BigDecimal[] parseNumber(java.lang.String numberStr)

isInteger

public static boolean isInteger(java.lang.String value,
                                boolean allowNegative)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2WeightInfoResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2WeightInfoResult

java.lang.Object
    extended by  bb.common.BB2WeightInfoResult
All Implemented Interfaces:
java.io.Serializable
public class BB2WeightInfoResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BB2WeightInfoResult()
Method Summary
BB2Part | getPart()
java.math.BigDecimal | getVolume()
java.lang.String | getVolumeUnit()
java.math.BigDecimal | getWeight()
java.lang.String | getWeightUnit()
void | setPart(BB2Part part)
void | setVolume(java.math.BigDecimal volume)
void | setVolumeUnit(java.lang.String volumeUnit)
void | setWeight(java.math.BigDecimal weight)
void | setWeightUnit(java.lang.String weightUnit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2WeightInfoResult

public BB2WeightInfoResult()
Method Detail

getPart

public BB2Part getPart()

setPart

public void setPart(BB2Part part)

getWeight

public java.math.BigDecimal getWeight()

setWeight

public void setWeight(java.math.BigDecimal weight)

getWeightUnit

public java.lang.String getWeightUnit()

setWeightUnit

public void setWeightUnit(java.lang.String weightUnit)

getVolume

public java.math.BigDecimal getVolume()

setVolume

public void setVolume(java.math.BigDecimal volume)

getVolumeUnit

public java.lang.String getVolumeUnit()

setVolumeUnit

public void setVolumeUnit(java.lang.String volumeUnit)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BB2Zip

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BB2Zip

java.lang.Object
    extended by  bb.common.BB2Zip

public final class BB2Zip
extends java.lang.Object

Constructor Summary
BB2Zip()
Method Summary
static void | main(java.lang.String[] arg)
static void | zip(java.io.OutputStream outStream, java.io.InputStream in, java.lang.String entryName)
static void | zip(java.lang.String zipFileName, java.lang.String inputFileName, java.lang.String base)
static void | zip(java.util.zip.ZipOutputStream out, java.io.File f, java.lang.String base)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BB2Zip

public BB2Zip()
Method Detail

main

public static void main(java.lang.String[] arg)

zip

public static void zip(java.lang.String zipFileName,
                       java.lang.String inputFileName,
                       java.lang.String base)
                throws java.lang.Exception
Throws:
java.lang.Exception

zip

public static void zip(java.util.zip.ZipOutputStream out,
                       java.io.File f,
                       java.lang.String base)
                throws java.lang.Exception
Throws:
java.lang.Exception

zip

public static void zip(java.io.OutputStream outStream,
                       java.io.InputStream in,
                       java.lang.String entryName)
                throws java.io.IOException
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


 bb.common
Interfaces
Alarmable
Facade
Classes
AccountAgingTotalResult
AccountAuditAgent
AccountBalanceAgent
AccountBalanceListResult
AccountBalanceResult
AccountCreditDebitPK
AccountCreditVO
AccountDebitVO
AccountInfoCenterItemResult
AccountInfoCenterResult
AccountingBalanceSheetResult
AccountingConfigurationVO
AccountingInfoDocumentVO
AccountingSettingsVO
AccountingTotalMoneyResult
AccountingTransactionTypeVO
AccountMonthPK
AccountPayableCheckRunItemVO
AccountPayableCheckRunVO
AccountPayableCheckVO
AccountPayableInfoWithPrepayResult
AccountReceivableInfoWithPrepayResult
AccountReceivablePaymentVO
AccountsChartAdvanceCategoryVO
AccountsChartCategoryListResult
AccountsChartCategoryVO
AccountsChartMappingPK
AccountsChartMappingVO
AccountsChartResult
AccountsChartVO
AccountsCreditDebitListResult
AccountsPayableInfoVO
AccountsPayableItemManufacturerPK
AccountsPayableItemManufacturerVO
AccountsPayableItemPK
AccountsPayableItemVO
AccountsPayableVO
AccountsReceivableInfoVO
AccountsReceivableItemManufacturerPK
AccountsReceivableItemManufacturerVO
AccountsReceivableItemPK
AccountsReceivableItemResult
AccountsReceivableItemVO
AccountsReceivableVO
AddPayableWithoutReceiverAgent
AddPhysicalInventoryAgent
AddProformaReceiverAgent
AddProformaReceiverItemAgent
AddressAccountInfo
AddressQualityDocumentsVO
AddRTVAgent
AllBudgetResult
AllPartDocumentsPK
AllPartDocumentsVO
AllStatementsListResult
AmountsStatementResult
APAgingItemListResult
APAuditListResult
ApCheckRunItemAgent
ApCheckRunListResult
APItemListResult
AppColumnVO
APPrepayInfoResult
ApPrepayItemPK
ApPrepayItemVO
ApPrepaymentCheckRunItemAgent
ApPrepayVO
ApprovedGLResult
APTaxForZipcodeListResult
ARAllStatementsListResult
ARAuditListResult
ARBoilerplateVO
ArCommissionListResult
ArCommissionTotalResult
ArPaymentRunItemAgent
ARPaymentRunItemPK
ARPaymentRunItemVO
ARPaymentRunListResult
ARPaymentRunVO
ARPrepayAllStatementsListResult
ARPrepayInfoResult
ArPrepayItemPK
ArPrepayItemVO
ArPrepaymentRunItemAgent
ARPrepaymentWireTransferAgent
ArPrepayVO
ArSalesCodeTotalListResult
ARTaxForZipcodeListResult
AssetAddOrDisposalsReport
AssetAmortizationExpenseAccountPK
AssetAmortizationExpenseAccountVO
AssetDepreciateDetailReport
AssetDepreciatePK
AssetDepreciateVO
AssetReportSumResult
AssetTypeVO
AssetUsagePK
AssetUsageVO
AssetVO
AuditLogVO
AuditOnDemandResult
AuditPartInQAResult
BalanceSheetSideBySideItemResult
BalanceSheetSideBySideResult
BankReconciliationReportVO
BB2AttachFile
BB2BigDecimalAndString
BB2BugNotice
BB2Document
BB2DoubleCost
BB2DoubleString
BB2Event
BB2File
BB2FiscalYearDate
BB2Login
BB2Notice
BB2Part
BB2PartBasicInfo
BB2PartByDateResult
BB2PartInfo
BB2PartInSipItemResult
BB2PartInSipOfSoItemResult
BB2PartInSitItemResult
BB2PartInSTOItemResult
BB2PartInventoryResult
BB2PartMrpResult
BB2PartOnDemandListResult
BB2PartOnhandPK
BB2PartOnLoanItemResult
BB2PartTotalInQADetailResult
BB2PartTotalInSipDetailResult
BB2PartTotalInSitDetailResult
BB2PartTotalInSTODetailResult
BB2PartTotalInWipDetailResult
BB2PartTotalOndemandDetailResult
BB2PartTotalOnhandDetailResult
BB2PartTotalOnloanDetailResult
BB2PartTotalOnorderDetailResult
BB2Picture
BB2QtyAndMoneyMap
BB2RefdocPK
BB2Task
BB2TimeFactory
BB2tripleString
BB2Util
BB2WeightInfoResult
BB2Zip
BillDetailCostResult
BillDetailCostWithPartInfoResult
BillItemDetailCostWithPartInfoResult
BillItemOnHandUsageResult
BillItemOnHandWithPartInfoResult
BillItemPK
BillItemReplacementVO
BillItemSalesCostResult
BillItemSalesResult
BillItemSalesXResult
BillItemUsagePathResult
BillItemUsageResult
BillItemVO
BillItemWithPartInfoResult
BillLogVO
BillOnHandWithPartInfoResult
BillPK
BillSalesCostResult
BillSalesOfCostResult
BillSalesResult
BillSalesXResult
BillVO
BillWhereUsedItemResult
BillWhereUsedResult
BillWithPartInfoResult
BizboxBugChangesInfoVO
BizboxBugChangesVO
BizboxBugInfoVO
BizboxBugVO
BizBoxServer
BizBoxUserEmployeeResult
BizboxUserListResult
BizboxUserVO
BIZReason
BizTarget
BomApprovalVO
BOMCanAssyAgent
BOMCanAssyListResult
BomItemWithOEMResult
BomPickListItemResult
BomPickListResult
BOMTreeRollUPMap
BomWithOEMResult
BudgetListResult
BuyerCodeVO
CarrierPK
CarrierVO
CashFlowByMonthReportResult
CashFlowMonthTotalResult
CashierVO
CatalogVO
CertificateDescriptionVO
ChangeStdCostWorkSheetItemPK
ChangeStdCostWorkSheetItemVO
ChangeStdCostWorkSheetVO
CheckInvoiceItemListResult
CheckRunItemTotalResult
ClientAutoInvokeMethodsManager
ClientListItem
ClosingStatementItemResult
ClosingStatementResult
ClosingStatementTotalResult
CommonPrintTemplateVO
CompanyUnitAccountPK
CompanyUnitAccountVO
CompanyUnitVO
CompanyVO
Configure
Configure.LoginStatus
Configure.Module
Configure.Organization
Configure.UpdatePermission
Configure.UserLocked
Configure.UserType
Constant
Constant.ActiveStatus
Constant.AddressType
Constant.AgeLevel
Constant.AmountType
Constant.ARDiscountMethod
Constant.CategoryReportType
Constant.CategoryType
Constant.ChartOfAccountSubType
Constant.ChartOfAccountType
Constant.CheckType
Constant.CostControl
Constant.CustomerVendorMailType
Constant.CVAddressType
Constant.CycleCountPeriodUnit
Constant.DataFilterType
Constant.DateType
Constant.DebitOrCredit
Constant.Depreciation
Constant.Depreciation.DepreciateStatus
Constant.Depreciation.DepreciationMethod
Constant.Depreciation.UsingType
Constant.Download
Constant.DrawingType
Constant.ECRPriority
Constant.EmployeeSecurityLevel
Constant.EmployeeStatus
Constant.EngineeringSharingImportDataType
Constant.EngineeringSharingImportType
Constant.EquipmentStatus
Constant.ExchangeRateType
Constant.FileExt
Constant.GLApprovedType
Constant.GLStyle
Constant.GLType
Constant.InventoryCostMothed
Constant.InventoryWorkSheetOrderBy
Constant.IrDateType
Constant.IRType
Constant.IssuedFrom
Constant.LanguageCode
Constant.LocalSettings
Constant.LoginType
Constant.MakeBuy
Constant.MiscDocType
Constant.NaRecTo
Constant.NcrApprovableType
Constant.NoticeAction
Constant.NoticeType
Constant.OITypeSerialNumberType
Constant.OrderType
Constant.Package
Constant.PageCycleCount
Constant.PAOffsetType
Constant.PartFrom
Constant.PartNumberGenerateType
Constant.PartQtyType
Constant.PayableMethod
Constant.PeriodUnit
Constant.PosOrderType
Constant.Prefix
Constant.PrintTemplateType
Constant.ReceiveCondition
Constant.ReceivedTo
Constant.SalesTaxReportType
Constant.SGType
Constant.StatementType
Constant.Status
Constant.SystemUserGroup
Constant.TaxType
Constant.TermsConditonType
Constant.TrackingNumberType
Constant.TransactionType
Constant.TransferType
Constant.Upload
Constant.VendorQualityStatus
Constant.WorkCenterSearchType
Constant.WorkCenterType
Constant.WorkLevel
Constant.YesNO
ContractPriceCustomerPK
ContractPriceCustomerVO
ContractPriceItemPK
ContractPriceItemVO
ContractPriceVO
CopyUtil
CorrectiveActionRequestVO
CPItemFromQuoteResult
CRTVItemListResult
CRTVListResult
CSRAgent
CurrencyAgent
CurrencyExchangePK
CurrencyExchangeVO
CurrencyVO
CurrentBalanceResult
CustomAssetRecordPK
CustomAssetRecordVO
CustomAssetVO
CustomCheckUpEmployeeVO
CustomDepartmentVO
CustomEmployeeTrainPK
CustomEmployeeTrainVO
CustomEmployeeVO
CustomEmployeeWorkExperienceVO
CustomerCLimitResult
CustomerFeedbackVO
CustomerPrepayStatementListResult
CustomerReturnToVendorItemPK
CustomerReturnToVendorItemVO
CustomerReturnToVendorVO
CustomerServiceIncidentItemListResult
CustomerServiceIncidentItemVO
CustomerServiceIncidentListResult
CustomerServiceIncidentVO
CustomerStatementListResult
CustomerStatementResult
CustomerStatementTotalResult
CustomerVendorAddressInfoVO
CustomerVendorAddressTotalInfo
CustomerVendorAddressVO
CustomerVendorContactPK
CustomerVendorContactVO
CustomerVendorDescriptionPK
CustomerVendorDescriptionVO
CustomerVendorTypeVO
CustomGoodsBreedVO
CustomGoodsRecordVO
CustomJobCategoryGoodsPK
CustomJobCategoryGoodsVO
CustomJobCategoryVO
CustomSearchVO
CustomTranslationVO
CV2CVAgent
CycleCountAgent
CycleCountListResult
CycleCountListTotalResult
CycleCountPK
CycleCountStatusVO
CycleCountVO
DataFilterVO
DBReason
DebitsCreditsResult
DepartmentLocationForBackflushVO
DepositSummaryResult
DepreciateMonthlyReport
DesignControlDocumentVO
DesignControlInfoVO
DesignControlListResult
DesignControlVO
DisassembleWorkOrderApprovalVO
DisassembleWorkOrderDocumentVO
DisassembleWorkOrderIssueVO
DisassembleWorkOrderIssuingItemResult
DisassembleWorkOrderIssuingResult
DisassembleWorkOrderItemListResult
DisassembleWorkOrderItemPartDetailItemResult
DisassembleWorkOrderItemPartDetailResult
DisassembleWorkOrderItemPK
DisassembleWorkOrderItemReceiverPK
DisassembleWorkOrderItemReceiverVO
DisassembleWorkOrderItemVO
DisassembleWorkOrderListResult
DisassembleWorkOrderReceivingResult
DisassembleWorkOrderVO
DocumentAction
DocumentAction.DwfAndDwgDocAction
DocumentAction.MiscDocAction
DocumentAction.PartDocAction
DocumentInfoAgent
DocumentLogVO
DocumentServerVO
DuePATotalByVendorResult
DwfUploadSettingsVO
DwgUploadSettingsVO
DWOIssueDetail
DynamicSearchFilter
EcnCheckOrderResult
EcnPOOrderResult
ECNReviewVO
EcnWOOrderResult
ECRReviewVO
EjbMethodVO
EmployeeCardVO
EmployeeEducationPK
EmployeeEducationResult
EmployeeEducationVO
EmployeeHomeVO
EmployeeJobDescriptionVO
EmployeeLaborAgent
EmployeePutGoodListResult
EmployeeRecordsVO
EmployeeTimeCardResult
EmployeeTrainingVO
EmployeeWorkExperiencePK
EmployeeWorkExperienceVO
EngGroupUserPK
EngGroupUserVO
EngGroupVO
EngineeringChangeDocumentVO
EngineeringChangeListResult
EngineeringChangeRequestDocumentVO
EngineeringChangeRequestListResult
EngineeringChangeRequestVO
EngineeringChangeVO
EngineeringInfoCenterResult
EngineeringSharingImportLogVO
EngineeringSharingItemPK
EngineeringSharingItemVO
EngineeringSharingVO
EquipmentListResult
EquipmentVO
ExchangeAuditItemResult
ExchangeAuditResult
ExpenseAccountVO
ExpenseItemPK
ExpenseItemVO
ExpenseListResult
ExpenseVO
FeedbackAnswerPK
FeedbackAnswerVO
FeedBackItemPK
FeedbackItemVO
FeedbackQuestionVO
FinishProformaReceiverAgent
FiscalYearSettingsVO
GeneralLedgerApprovalVO
GeneralLedgerByDateListResult
GeneralLedgerCategoryVO
GeneralLedgerEntry
GeneralLedgerListResult
GeneralLedgerPrintResult
GeneralLedgerResult
GeneralLedgerSettingsVO
GeneralLedgerVO
GLApprovalListResult
GLAutoApproveVO
GlBalanceInfoResult
GLByDateTotalResult
GlCashFlowBudgetVO
GLCatAndSequence
GLCheckRegisterResult
GLDebitCreditListResult
GlFiscalYearBudgetVO
GLInfoByPeriodResult
GLItemVO
GlMonthBudgetVO
GlMonthVO
GroupUserPK
GroupUserVO
HelpServerVO
HighUsagePartResult
HistoricalInventoryTotalResult
HistoricalInventoryVO
I18nEvent
IcrItemListResult
IcrListResult
ImportContractPriceData
ImportDataVO
IncomeByMonthChartResult
IncotermVO
InfoByFiscalChartResult
InfoByMonthChartResult
InfoByMonthResult
InSipAudittListResult
InspectionConformanceReportItemCheckPK
InspectionConformanceReportItemCheckVO
InspectionConformanceReportItemInfo
InspectionConformanceReportItemPK
InspectionConformanceReportItemVO
InspectionConformanceReportVO
InspectionItemPK
InspectionItemVO
InspectionReportInfoVO
InspectionReportInspectMethodItemPK
InspectionReportInspectMethodItemVO
InspectionReportInspectMethodVO
InspectionReportInspectStandardItemPK
InspectionReportInspectStandardItemVO
InspectionReportItemPK
InspectionReportItemQtyPK
InspectionReportItemQtyVO
InspectionReportItemVO
InspectionReportVO
InspectionTypeItemPK
InspectionTypeItemVO
InspectionTypeVO
InventoryAdjustmentDetailResult
InventoryAdjustmentListResult
InventoryAdjustmentVO
InventoryAmountByMonth
InventoryAuditReportResult
InventoryCycleItemResult
InventoryCycleResult
InventoryListResult
InventoryMonthReport
InventoryNotUsedInMonthsforAppResult
InventoryNotUsedInMonthsResult
InventoryNotUsedTotal
InventoryPartInOutDetailListResult
InventoryReportListResult
InventoryTotalCostResult
InventoryTotalResult
InvoiceAgingItemListResult
InvoiceItemListResult
IpAddressVO
IssuedFromOrderItem
IssueItemAgent
IssueItemDetailAgent
IssuingItemResult
IssuingResult
JobProcessSheetItemResult
JobProcessSheetListResult
JobProcessSheetResult
JounalEntryListResult
LabelTemplateConstant
LabelTemplateItemPK
LabelTemplateItemVO
LabelTemplateVO
ListCache
LnShipperItemListResult
LnShipperListResult
LocationResult
LockedCustomerAddressResult
LogInventoryListResult
LogInventoryVO
LogMethodPK
LogMethodVO
LogMiscDocumentVO
LogPartDocumentVO
LogPartDwfVO
LogPartDwgVO
LogTaskVO
LogTrackingVO
MaintenanceItemPK
MaintenanceItemVO
MakeAccountPayableAgent
MakeBillAndHoldInvoiceAgent
MakeCheckAgent
MakeCreditMemoAgent
MakeDebitMemoAgent
MakeInvoiceAgent
MakePrepaymentCheckAgent
ManufacturerAddressInfoVO
ManufacturerAddressVO
ManufacturerContactPK
ManufacturerContactVO
ManufacturerDescriptionPK
ManufacturerDescriptionVO
MasterWorkOrderTreeItemResult
MessageAgent
MessageVO
MfrMpnListResult
MiscDocAgent
MiscDocumentSettingVO
Money
MoneyInDrawResult
MonthBalanceResult
MonthSoOrArByCustomerResult
MrpByMonthResult
MrpItemOrderDemandRecordsResult
MrpItemResult
MrpReportAgent
MultiLanguageAccountsChartPK
MultiLanguageAccountsChartVO
MyPrintListPK
MyPrintListVO
NCQRejectResult
NcrApprovalPK
NcrApprovalVO
NcrNeedToScrapListResult
NCRPartOnhandPK
NCRPictureListResult
NCRPictureVO
NcrReportListResult
NcrScrapAgent
NonConformanceCodeDescriptionPK
NonConformanceCodeDescriptionVO
NonConformanceCodeVO
NonConformanceQuantityPK
NonConformanceQuantityVO
NonConformanceReportResult
NonConformanceReportVO
NonproductivePickingApprovalVO
NonproductivePickingApproveVO
NonproductivePickingItemIssuedListResult
NonproductivePickingItemIssuedVO
NonproductivePickingItemPK
NonproductivePickingItemResult
NonproductivePickingItemVO
NonproductivePickingOnDemandResult
NonproductivePickingTypeVO
NonproductivePickingVO
NoticeUserEmployeeListResult
OIPrincipalVO
OnhandQualityResult
OnloanDocumentVO
OnLoanItemListResult
OnLoanItemPK
OnLoanItemVO
OnLoanListResult
OnloanReceiverItemListResult
OnloanReceiverItemPK
OnloanReceiverItemVO
OnloanReceiverListResult
OnloanReceiverVO
OnloanReviewVO
OnloanShipperItemPK
OnloanShipperItemVO
OnloanShipperVO
OnLoanVO
OnTimeAgent
OntimeDeliveryRateListResult
OntimeDeliveryRateResult
OpCodeShortcutPK
OpCodeShortcutVO
OperatingInstructionsInspectMethodItemPK
OperatingInstructionsInspectMethodItemVO
OperatingInstructionsInspectResultItemPK
OperatingInstructionsInspectResultItemVO
OperatingInstructionsInspectStandardItemPK
OperatingInstructionsInspectStandardItemVO
OperatingInstructionsInspectStandardVO
OperatingInstructionsManualItemPK
OperatingInstructionsManualItemVO
OperatingInstructionsManualVO
OperatingInstructionsTypeVO
OperatingInstructionsUserStatisticalResult
OperatingInstructionsVO
OperatingOutputFileItemPK
OperatingOutputFileItemVO
OperatingOutputFileTypeVO
OperationLogVO
OrderApprovalItemsVO
OrderApprovalVO
OrderBoilerplatePK
OrderBoilerplateVO
OrderBy
OrderDemandForReceiverResult
OrderDocumentVO
OrderPK
OrderVendorItem
OutputValueByMonthResult
PackingBoxItemListResult
PackingBoxItemPK
PackingBoxItemVO
PackingBoxPK
PackingBoxSalesOrderItemAgent
PackingBoxSalesOrderItemResult
PackingBoxVO
PartBasicInfo
PartBasicInfoWithNewEngGroup
PartBasicInfoWithNewListPrice
PartCatagoryPK
PartCatagoryVO
PartCatalogAuditResult
PartCatalogPK
PartCatalogVO
PartCertificateListResult
PartCertificateVO
PartClassInfoResult
PartClassVO
PartCostVarianceListResult
PartDescriptionPK
PartDescriptionVO
PartDiscountPK
PartDiscountVO
PartDocumentPK
PartDocumentVO
PartDueAddressListResult
PartDwfAgent
PartDwfPK
PartDwfVO
PartDwfWithPartInfoResult
PartDwgAgent
PartDwgPK
PartDwgVO
PartDwgWithPartInfoResult
PartExportInfo
PartInMrpListResult
PartInQAAgent
PartInQAResult
PartInQAVO
PartInspectionPK
PartInspectionResult
PartInspectionVO
PartInventoryVO
PartInWipForIDListResult
PartIssuedListResult
PartIssuedVO
PartIssueTotalResult
PartManufacturerAgent
PartManufacturerPK
PartManufacturerVO
PartMaterialBomListResult
PartMaterialListResult
PartMaterialReportAgent
PartMaterialVO
PartMaterialWhereUsedItemResult
PartMaterialWhereUsedResult
PartMRPVO
PartNumberGenerateRuleVO
PartOnhandAndCostResult
PartOnHandAuditAgent
PartOnHandAuditResult
PartOnhandCostVO
PartOnhandPK
PartOnhandResult
PartOnhandVO
PartOnhandWithAverageCostResult
PartOnHandWithMfgInfoResult
PartOnHandWithPartBasicInfoResult
PartPictureVO
PartPK
PartReceivedListResult
PartReceivedVO
PartSecurityLevelVO
PartsToDeleteResult
PartToAuditFlagResult
PartTraceableCategoryPK
PartTraceableCategoryVO
PartTraceableInfoResult
PartTraceableListResult
PartTraceableResult
PartTraceableSpecPK
PartTraceableSpecVO
PartTrackingPK
PartTrackingVO
PartTypeVO
PartUnitPK
PartUnitVO
partUsedInfoResult
PartUseTypeVO
PartVendorPK
PartVendorVO
PartVO
PartWhereUsedItemResult
PartWhereUsedResult
PartWithExcessiveInventoryListResult
PartWithInventoryInfoListResult
PartWithManufacturerInfoResult
PartWithOnhandDetailInfoResult
PartWithOnhandsVO
PartWithOnLoanQtyListResult
PartWithoutLocateResult
PartWithQAQtyListResult
PartWithQtyListResult
PartWithSipQtyListResult
PartWithSITQtyListResult
PartWithSTOQtyListResult
PartWithWipQtyListResult
PasswordPolicyAgent
PayableCheckRunItemPK
PayableMethodVO
PaymentAgent
PaymentHistoryVO
PaymentInvoicesResult
PaymentRunItemTotalResult
PaymentVO
PermissionDescriptionPK
PermissionDescriptionVO
PermissionListResult
PermissionMethodPK
PermissionMethodVO
PermissionVO
PfReceiverItemPK
PfReceiverItemVO
PfReceiverItemWithNumberPK
PfReceiverVO
PhysicalInventoryListResult
PhysicalInventoryListTotalResult
PhysicalInventoryListWithAppDataResult
PhysicalInventoryPK
PhysicalInventoryStatusVO
PhysicalInventoryVO
PO2POAgent
PO2SOExchange
PO2SOExchangeItem
PO2SOExchangeItemManufacturer
POAndWOStatusResult
POForWISeqAgent
PointOfSaleVO
POItemByRefDoc1ListResult
PoMessageItemPK
PoMessageItemVO
PoMessageListResult
PoMessageVO
PoReceiverByDateSummaryResult
POReceiverItemListResult
PosRefdocVO
POStatisticsResult
PostCheckAgent
POSurveyReportAgent
POSurveyReportItemPK
POSurveyReportItemVO
POSurveyReportVO
PosZipCodeTaxPK
PosZipCodeTaxVO
PrepayAgent
PrepaymentWireTransferAgent
PrepayPaymentAgent
PreventiveActionRequestItemVO
PreventiveActionRequestVO
PrintLogoVO
PrintTemplateVO
ProfitAndLossAccountsResult
ProfitLossStatementItemResult
ProfitLossStatementResult
ProformaInvoiceItemListResult
ProformaInvoiceItemManufacturerPK
ProformaInvoiceItemManufacturerVO
ProformaInvoiceItemPK
ProformaInvoiceItemVO
ProformaInvoiceListResult
ProformaInvoiceVO
ProformaReceiverPackingBoxAgent
ProformaReceiverPackingBoxItemAgent
ProjectVO
PrPackingBoxItemPK
PrPackingBoxItemVO
PrPackingBoxPK
PrPackingBoxVO
PrReceiverListResult
PrReceiverWithQualityListResult
PullFromWorkOrderPartDetailAgent
PurchaseOnTimeResult
PurchaseOrderApprovalVO
PurchaseOrderBoilerplateVO
PurchaseOrderCheckListResult
PurchaseOrderContractResult
PurchaseOrderDocumentVO
PurchaseOrderItemListResult
PurchaseOrderItemManufacturerPK
PurchaseOrderItemManufacturerVO
PurchaseOrderItemPK
PurchaseOrderItemVO
PurchaseOrderListResult
PurchaseOrderOnOrderResult
PurchaseOrderOnTimeItemResult
PurchaseOrderOnTimeResult
PurchaseOrderOpenDueListResult
PurchaseOrderVO
PurchaseWorkSheetItemPK
PurchaseWorkSheetItemVO
PurchaseWorkSheetItemWithRelatedInfoResult
PurchaseWorkSheetPK
PurchaseWorkSheetVO
PurchasingInfoCenterResult
PuttoInQAAgent
QtyAndMoney
QtyDetailResult
QualityGroupPK
QualityGroupVO
QualityInfoCenterResult
Quote2QuoteAgent
QuoteBoilerplateVO
QuoteDocumentVO
QuoteItemListResult
QuoteItemManufacturerPK
QuoteItemManufacturerVO
QuoteItemPK
QuoteItemVO
QuoteListResult
QuoteVO
Reason
RebackInQAAgent
ReceivedToOrderItem
ReceiverAgent
ReceiverInfoVO
ReceiverItemAgent
ReceiverItemDetailAgent
ReceiverItemManufacturerPK
ReceiverItemManufacturerVO
ReceiverItemPK
ReceiverItemTrackingLogAgent
ReceiverItemVO
ReceiverShipAgent
ReceiverVO
ReceivingItemResult
ReceivingResult
RecursiveBillPath
RefdocElement
RefdocVO
RequestForQuoteCheckListResult
RequestForQuoteItemListResult
RequestForQuoteItemManufacturerPK
RequestForQuoteItemManufacturerVO
RequestForQuoteItemPK
RequestForQuoteItemVO
RequestForQuoteListResult
RequestForQuoteVO
RequestForRMAItemPK
RequestForRMAItemVO
RequestForRMAVO
ReturnMaterialAuthorizationDocumentVO
ReturnMaterialAuthorizationItemManufacturerPK
ReturnMaterialAuthorizationItemManufacturerVO
ReturnMaterialAuthorizationItemPK
ReturnMaterialAuthorizationItemVO
ReturnMaterialAuthorizationVO
ReturnToVendorByDateListResult
ReturnToVendorCheckListResult
ReturnToVendorItemListResult
ReturnToVendorItemManufacturerPK
ReturnToVendorItemManufacturerVO
ReturnToVendorItemPK
ReturnToVendorItemVO
ReturnToVendorListResult
ReturnToVendorVO
RfqMessageItemPK
RfqMessageItemVO
RfqMessageListResult
RfqMessageVO
RMAItemListResult
RMAListResult
RMAReceiverItemListResult
RMAReceiverItemPK
RMAReceiverItemVO
RMAReceiverListResult
RMAReceiverResult
RMAReceiverVO
RMAReviewVO
RoleDescriptionPK
RoleDescriptionVO
RoleListResult
RolePermissionPK
RolePermissionVO
RoleVO
RollUpBomStdCostWorkSheetItemPK
RollUpBomStdCostWorkSheetItemVO
RollUpBomStdCostWorkSheetVO
RollUPPartStandardCostResult
RRMAItemListResult
RRMAListResult
RTVApprovalVO
RtvShipperInfoVO
RtvShipperItemListResult
RtvShipperItemPK
RtvShipperItemVO
RtvShipperListResult
RtvShipperVO
RunningAccountOrderItemPK
RunningAccountOrderItemResult
RunningAccountOrderItemVO
RunningAccountOrderVO
RunTaxPaymentResult
SalesBomItemResult
SalesBomResult
SalesCodeVO
SalesInfoCenter
SalesInfoCenter.DueSoCount
SalesInfoCenter.DueSoSum
SalesInfoCenter.GrossMargin
SalesInfoCenter.InvoicedSum
SalesInfoCenter.OpenSoSum
SalesInfoCenter.SoCount
SalesInfoCenter.SoCountWithPartsOnhold
SalesInfoCenter.SoItemCount
SalesInfoCenter.SoTotalSum
SalesInfoCenterResult
SalesmanVO
SalesMarginListResult
SalesOnTimeResult
SalesOrder12MonthMarginResult
SalesOrderBoilerplateVO
SalesOrderCheckListResult
SalesOrderDocumentVO
SalesOrderItemCostResult
SalesOrderItemCustomerTotalResult
SalesOrderItemGroupByPartListResult
SalesOrderItemInfoVO
SalesOrderItemListResult
SalesOrderItemManufacturerPK
SalesOrderItemManufacturerVO
SalesOrderItemPK
SalesOrderItemVO
SalesOrderListResult
SalesOrderOnDemandResult
SalesOrderOnTimeItemResult
SalesOrderOnTimeResult
SalesOrderOrphanedResult
SalesOrderReviewVO
SalesOrderShipDateListResult
SalesOrderVO
SalesPartListItemResult
SalesPartListResult
SalesTaxListResult
ScrapAssetAgent
ScrapReportVO
SerialNumberItemPK
SerialNumberItemResult
SerialNumberItemVO
SerialNumberPK
SerialNumberResult
SerialNumberVO
ServerAction
ServerClientPropertyPK
ServerClientPropertyVO
SGBillItemPK
SGBillItemVO
SGBOMItemResult
SGBOMResult
SGCartCheckOutResult
SGCartLogin
SGClientAccountPK
SGClientAccountVO
SGClientLogin
SgClientProgramUserVO
SGCompanyPK
SGCompanyVO
SGCustomerCatalogPK
SGCustomerCatalogVO
SGCustomerServiceRequestVO
SGCustRequestForQuoteItemPK
SGCustRequestForQuoteItemResult
SGCustRequestForQuoteItemVO
SGCustRequestForQuoteListResult
SGCustRequestForQuoteResult
SGCustRequestForQuoteVO
SGDocPartPK
SGDocPartVO
SGDwgPicturePK
SGDwgPictureVO
SGLogLoginVO
SGPartCartAgent
SGPartCatalogResult
SGPartDocFlagResult
SGPartListItemResult
SGPartListResult
SGPicturePK
SGPictureVO
SGQuoteAddressResult
SGQuoteAddressVO
SGQuoteCartListResult
SGQuoteCartVO
SGQuoteLoginVO
SGSaleItemAgent
SGSaleItemVO
SGWeightUnitVO
ShareHoldersEquityResult
ShipListAgent
ShipListInfoVO
ShipListItemPK
ShipListItemRelatedDocResult
ShipListItemVO
ShipListItemVOResult
ShipListOwnerAttributePK
ShipListOwnerAttributeVO
ShipListOwnerVO
ShipListVO
ShipperAgent
ShipperInfoVO
ShipperItemAgent
ShipperItemDetailAgent
ShipperItemListResult
ShipperItemManufacturerPK
ShipperItemManufacturerVO
ShipperItemPK
ShipperItemVO
ShipperListResult
ShipperVO
ShippingItemResult
ShippingResult
ShoppingCartItem
SmtpServerVO
SO2POAgent
SO2SOAgent
SO2WOAgent
SoPickListResult
SOShipperItemListResult
Spiderman
StaffWorkingInformationResult
StockTransactionAdjustmentResult
StockTransactionPartInfoResult
StockTransactionPOReceiverResult
StockTransactionSOShipperResult
StockTransactionWOReceiverResult
StockTransactionWOShipperResult
StringListConvertor
SubcompanyLoginAgent
SubcompanyVO
SwapOrderApprovalVO
SwapOrderItemListResult
SwapOrderItemPK
SwapOrderItemVO
SwapOrderListResult
SwapOrderVO
SwapReceiverItemListResult
SwapReceiverItemPK
SwapReceiverItemVO
SwapReceiverListResult
SwapReceiverVO
SwapShipperItemListResult
SwapShipperItemPK
SwapShipperItemVO
SwapShipperListResult
SwapShipperOnOrderResult
SwapShipperVO
TakeCycleCountAgent
TaskFileResult
TaskVO
TaxAccountVO
TempArApAgingVO
TempReceiverWithoutAPInfo
TermAgent
TermsConditionVO
TermVO
ToolBasicInfo
ToolCalibrateListResult
ToolCalibrationVO
ToolDescriptionVO
ToolInventoryVO
ToolListDetailCostResult
ToolListDetailCostWithToolInfoResult
ToolListInfoVO
ToolListItemDetailCostWithToolInfoResult
ToolListItemVO
ToolListItemWithToolInfoResult
ToolListVO
ToolListWithToolInfoResult
ToolManufacturerVO
ToolOnhandVO
ToolOnhandWithAverageCostResult
ToolVendorVO
ToolVO
ToolWhereUsedItemResult
ToolWhereUsedResult
ToolWithManufacturerInfoResult
ToolWithOnhandsVO
TotalAmountInPOByRefDoc
TotalByDateResult
TraceableCategoriesVO
TraceableSpecsVO
TransferOrderApprovalVO
TransferOrderItemListResult
TransferOrderItemPK
TransferOrderItemVO
TransferOrderListResult
TransferOrderVO
TransferReceiverItemListResult
TransferReceiverItemPK
TransferReceiverItemVO
TransferReceiverListResult
TransferReceiverVO
TransferShipperItemListResult
TransferShipperItemPK
TransferShipperItemVO
TransferShipperListResult
TransferShipperVO
TwelveMonthCashFlowReportResult
UnitVO
UpdatePhysicalInventoryAgent
User2UserAgent
UserGroupVO
UserRolePermissionListResult
UserRolePK
UserRoleVO
VendorCategoriesVO
VendorContractPriceItemPK
VendorContractPriceItemVO
VendorContractPriceVendorPK
VendorContractPriceVendorVO
VendorContractPriceVO
VendorCriticalLevelVO
VendorGroupUserVO
VendorPartPK
VendorPartVO
VendorPrepayStatementListResult
VendorPriceAgent
VendorQtyPricePK
VendorQtyPriceVO
VendorStatementListResult
VendorTotalAmountInPO
VersionInformation
VO
WareHousePartPrefixKeeperVO
WarehouseTransferPK
WarehouseTransferVO
WarehouseVO
WareHousingInfoCenterResult
WC2WCAgent
WCLoadAgent
WCLoadByDateResult
WCLoadDetailResult
WCLoadOnDateResult
WeightUnitVO
WireTransferAgent
WO2WOAgent
WOIssuedByMonthChartResult
WOIssuedByMonthResult
WOItemCostControlAgent
WOItemPartDetailNotIssue
WoItemPickListItemResult
WoItemPickListResult
WoItemWorkInstructionListResult
WOReceiverDetail
WorkCalendarVO
WorkCenterAgent
WorkCenterGroupItemPK
WorkCenterGroupItemVO
WorkCenterLoadAgent
WorkCenterLoadListResult
WorkCenterOnDateAgent
WorkCenterRunTimeAgent
WorkCenterRunTimeListResult
WorkCenterRunTimeTotalResult
WorkCenterVendorPK
WorkCenterVendorVO
WorkCenterVO
WorkFlowVO
WorkInstructionApprovalVO
WorkInstructionDocumentVO
WorkInstructionListResult
WorkInstructionPictureVO
WorkInstructionPK
WorkInstructionRequestForChangeVO
WorkInstructionSeqAuditListResult
WorkInstructionSequenceListResult
WorkInstructionSequencePK
WorkInstructionSequenceVO
WorkInstructionSummaryItemResult
WorkInstructionSummaryResult
WorkInstructionVO
WorkOrderApprovalVO
WorkOrderBoilerplateVO
WorkOrderCheckListResult
WorkOrderDocumentVO
WorkOrderInfoCenterResult
WorkOrderInWipResult
WorkOrderIssuedOrderListResult
WorkOrderIssueStatisticsResult
WorkOrderItemAgent
WorkOrderItemCanAssyAgent
WorkOrderItemCanAssyResult
WorkOrderItemInfoResult
WorkOrderItemInWipListResult
WorkOrderItemIssuedTotalResult
WorkOrderItemIssuePK
WorkOrderItemIssueVO
WorkOrderItemLaborCostListResult
WorkOrderItemListResult
WorkOrderItemPartDetail
WorkOrderItemPartDetailInWipVO
WorkOrderItemPartDetailItemResult
WorkOrderItemPartDetailResult
WorkOrderItemPK
WorkOrderItemReviewCostResult
WorkOrderItemSeqWCLoadResult
WorkOrderItemSetupItemAgent
WorkOrderItemTimeDetailResult
WorkOrderItemTimeDetailVO
WorkOrderItemToIssueResult
WorkOrderItemVO
WorkOrderItemWCLoadResult
WorkOrderListResult
WorkOrderNotSetupResult
WorkOrderOnDemandResult
WorkOrderOnOrderResult
WorkOrderOnTimeItemResult
WorkOrderOnTimeResult
WorkOrderOverIssueListResult
WorkOrderQueryInfo
WorkOrderReceiverVO
WorkOrderTimeCardVO
WorkOrderVO
WorkOrderWorkInstructionListResult
WorkOrderWorkInstructionPK
WorkOrderWorkInstructionSequenceDateAgent
WorkOrderWorkInstructionSequencePK
WorkOrderWorkInstructionSequenceVO
WorkOrderWorkInstructionVO
WorkOrderWorkItemDateAgent
WorkOrderWorkSheetItemPK
WorkOrderWorkSheetItemVO
WorkOrderWorkSheetItemWithRelatedInfoResult
WorkOrderWorkSheetPK
WorkOrderWorkSheetVO
WorkPeriodVO
WorkSheetPartAgent
YearMonthManager
ZipCodeTaxVO
ZipcodeTotalsResult
ZipCodeVO
ZippedByteArray
Exceptions
AppException
BB2DocumentException
BB2MessagingException
BB2ServerException
BizException
DBAccessException
InvokeException
LoginException
PermissionException
ServerException


bb.common

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package bb.common

Interface Summary
Alarmable
Facade

Class Summary
AccountAgingTotalResult |
AccountAuditAgent |
AccountBalanceAgent |
AccountBalanceListResult |
AccountBalanceResult |
AccountCreditDebitPK |
AccountCreditVO |
AccountDebitVO |
AccountInfoCenterItemResult |
AccountInfoCenterResult |
AccountingBalanceSheetResult |
AccountingConfigurationVO |
AccountingInfoDocumentVO |
AccountingSettingsVO |
AccountingTotalMoneyResult |
AccountingTransactionTypeVO |
AccountMonthPK |
AccountPayableCheckRunItemVO |
AccountPayableCheckRunVO |
AccountPayableCheckVO |
AccountPayableInfoWithPrepayResult |
AccountReceivableInfoWithPrepayResult |
AccountReceivablePaymentVO |
AccountsChartAdvanceCategoryVO |
AccountsChartCategoryListResult |
AccountsChartCategoryVO |
AccountsChartMappingPK |
AccountsChartMappingVO |
AccountsChartResult |
AccountsChartVO |
AccountsCreditDebitListResult |
AccountsPayableInfoVO |
AccountsPayableItemManufacturerPK |
AccountsPayableItemManufacturerVO |
AccountsPayableItemPK |
AccountsPayableItemVO |
AccountsPayableVO |
AccountsReceivableInfoVO |
AccountsReceivableItemManufacturerPK |
AccountsReceivableItemManufacturerVO |
AccountsReceivableItemPK |
AccountsReceivableItemResult |
AccountsReceivableItemVO |
AccountsReceivableVO |
AddPayableWithoutReceiverAgent |
AddPhysicalInventoryAgent |
AddProformaReceiverAgent |
AddProformaReceiverItemAgent |
AddressAccountInfo |
AddressQualityDocumentsVO |
AddRTVAgent |
AllBudgetResult |
AllPartDocumentsPK |
AllPartDocumentsVO |
AllStatementsListResult |
AmountsStatementResult |
APAgingItemListResult |
APAuditListResult |
ApCheckRunItemAgent |
ApCheckRunListResult |
APItemListResult |
AppColumnVO |
APPrepayInfoResult |
ApPrepayItemPK |
ApPrepayItemVO |
ApPrepaymentCheckRunItemAgent |
ApPrepayVO |
ApprovedGLResult |
APTaxForZipcodeListResult |
ARAllStatementsListResult |
ARAuditListResult |
ARBoilerplateVO |
ArCommissionListResult |
ArCommissionTotalResult |
ArPaymentRunItemAgent |
ARPaymentRunItemPK |
ARPaymentRunItemVO |
ARPaymentRunListResult |
ARPaymentRunVO |
ARPrepayAllStatementsListResult |
ARPrepayInfoResult |
ArPrepayItemPK |
ArPrepayItemVO |
ArPrepaymentRunItemAgent |
ARPrepaymentWireTransferAgent |
ArPrepayVO |
ArSalesCodeTotalListResult |
ARTaxForZipcodeListResult |
AssetAddOrDisposalsReport |
AssetAmortizationExpenseAccountPK |
AssetAmortizationExpenseAccountVO |
AssetDepreciateDetailReport |
AssetDepreciatePK |
AssetDepreciateVO |
AssetReportSumResult |
AssetTypeVO |
AssetUsagePK |
AssetUsageVO |
AssetVO |
AuditLogVO |
AuditOnDemandResult |
AuditPartInQAResult |
BalanceSheetSideBySideItemResult |
BalanceSheetSideBySideResult |
BankReconciliationReportVO |
BB2AttachFile |
BB2BigDecimalAndString |
BB2BugNotice |
BB2Document |
BB2DoubleCost |
BB2DoubleString |
BB2Event |
BB2File |
BB2FiscalYearDate |
BB2Login |
BB2Notice |
BB2Part |
BB2PartBasicInfo |
BB2PartByDateResult |
BB2PartInfo |
BB2PartInSipItemResult |
BB2PartInSipOfSoItemResult |
BB2PartInSitItemResult |
BB2PartInSTOItemResult |
BB2PartInventoryResult |
BB2PartMrpResult |
BB2PartOnDemandListResult |
BB2PartOnhandPK |
BB2PartOnLoanItemResult |
BB2PartTotalInQADetailResult |
BB2PartTotalInSipDetailResult |
BB2PartTotalInSitDetailResult |
BB2PartTotalInSTODetailResult |
BB2PartTotalInWipDetailResult |
BB2PartTotalOndemandDetailResult |
BB2PartTotalOnhandDetailResult |
BB2PartTotalOnloanDetailResult |
BB2PartTotalOnorderDetailResult |
BB2Picture |
BB2QtyAndMoneyMap |
BB2RefdocPK |
BB2Task |
BB2TimeFactory |
BB2tripleString |
BB2Util |
BB2WeightInfoResult |
BB2Zip |
BillDetailCostResult |
BillDetailCostWithPartInfoResult |
BillItemDetailCostWithPartInfoResult |
BillItemOnHandUsageResult |
BillItemOnHandWithPartInfoResult |
BillItemPK |
BillItemReplacementVO |
BillItemSalesCostResult |
BillItemSalesResult |
BillItemSalesXResult |
BillItemUsagePathResult |
BillItemUsageResult |
BillItemVO |
BillItemWithPartInfoResult |
BillLogVO |
BillOnHandWithPartInfoResult |
BillPK |
BillSalesCostResult |
BillSalesOfCostResult |
BillSalesResult |
BillSalesXResult |
BillVO |
BillWhereUsedItemResult |
BillWhereUsedResult |
BillWithPartInfoResult |
BizboxBugChangesInfoVO |
BizboxBugChangesVO |
BizboxBugInfoVO |
BizboxBugVO |
BizBoxServer |
BizBoxUserEmployeeResult |
BizboxUserListResult |
BizboxUserVO |
BIZReason |
BizTarget |
BomApprovalVO |
BOMCanAssyAgent |
BOMCanAssyListResult |
BomItemWithOEMResult |
BomPickListItemResult |
BomPickListResult |
BOMTreeRollUPMap |
BomWithOEMResult |
BudgetListResult |
BuyerCodeVO |
CarrierPK |
CarrierVO |
CashFlowByMonthReportResult |
CashFlowMonthTotalResult |
CashierVO |
CatalogVO |
CertificateDescriptionVO |
ChangeStdCostWorkSheetItemPK |
ChangeStdCostWorkSheetItemVO |
ChangeStdCostWorkSheetVO |
CheckInvoiceItemListResult |
CheckRunItemTotalResult |
ClientAutoInvokeMethodsManager |
ClientListItem |
ClosingStatementItemResult |
ClosingStatementResult |
ClosingStatementTotalResult |
CommonPrintTemplateVO |
CompanyUnitAccountPK |
CompanyUnitAccountVO |
CompanyUnitVO |
CompanyVO |
Configure |
Configure.LoginStatus |
Configure.Module |
Configure.Organization |
Configure.UpdatePermission |
Configure.UserLocked |
Configure.UserType |
Constant |
Constant.ActiveStatus |
Constant.AddressType |
Constant.AgeLevel |
Constant.AmountType |
Constant.ARDiscountMethod |
Constant.CategoryReportType |
Constant.CategoryType |
Constant.ChartOfAccountSubType |
Constant.ChartOfAccountType |
Constant.CheckType |
Constant.CostControl |
Constant.CustomerVendorMailType |
Constant.CVAddressType |
Constant.CycleCountPeriodUnit |
Constant.DataFilterType |
Constant.DateType |
Constant.DebitOrCredit |
Constant.Depreciation |
Constant.Depreciation.DepreciateStatus |
Constant.Depreciation.DepreciationMethod |
Constant.Depreciation.UsingType |
Constant.Download |
Constant.DrawingType |
Constant.ECRPriority |
Constant.EmployeeSecurityLevel |
Constant.EmployeeStatus |
Constant.EngineeringSharingImportDataType |
Constant.EngineeringSharingImportType |
Constant.EquipmentStatus |
Constant.ExchangeRateType |
Constant.FileExt |
Constant.GLApprovedType |
Constant.GLStyle |
Constant.GLType |
Constant.InventoryCostMothed |
Constant.InventoryWorkSheetOrderBy |
Constant.IrDateType |
Constant.IRType |
Constant.IssuedFrom |
Constant.LanguageCode |
Constant.LocalSettings |
Constant.LoginType |
Constant.MakeBuy |
Constant.MiscDocType |
Constant.NaRecTo |
Constant.NcrApprovableType |
Constant.NoticeAction |
Constant.NoticeType |
Constant.OITypeSerialNumberType |
Constant.OrderType |
Constant.Package |
Constant.PageCycleCount |
Constant.PAOffsetType |
Constant.PartFrom |
Constant.PartNumberGenerateType |
Constant.PartQtyType |
Constant.PayableMethod |
Constant.PeriodUnit |
Constant.PosOrderType |
Constant.Prefix |
Constant.PrintTemplateType |
Constant.ReceiveCondition |
Constant.ReceivedTo |
Constant.SalesTaxReportType |
Constant.SGType |
Constant.StatementType |
Constant.Status |
Constant.SystemUserGroup |
Constant.TaxType |
Constant.TermsConditonType |
Constant.TrackingNumberType |
Constant.TransactionType |
Constant.TransferType |
Constant.Upload |
Constant.VendorQualityStatus |
Constant.WorkCenterSearchType |
Constant.WorkCenterType |
Constant.WorkLevel |
Constant.YesNO |
ContractPriceCustomerPK |
ContractPriceCustomerVO |
ContractPriceItemPK |
ContractPriceItemVO |
ContractPriceVO |
CopyUtil |
CorrectiveActionRequestVO |
CPItemFromQuoteResult |
CRTVItemListResult |
CRTVListResult |
CSRAgent |
CurrencyAgent |
CurrencyExchangePK |
CurrencyExchangeVO |
CurrencyVO |
CurrentBalanceResult |
CustomAssetRecordPK |
CustomAssetRecordVO |
CustomAssetVO |
CustomCheckUpEmployeeVO |
CustomDepartmentVO |
CustomEmployeeTrainPK |
CustomEmployeeTrainVO |
CustomEmployeeVO |
CustomEmployeeWorkExperienceVO |
CustomerCLimitResult |
CustomerFeedbackVO |
CustomerPrepayStatementListResult |
CustomerReturnToVendorItemPK |
CustomerReturnToVendorItemVO |
CustomerReturnToVendorVO |
CustomerServiceIncidentItemListResult |
CustomerServiceIncidentItemVO |
CustomerServiceIncidentListResult |
CustomerServiceIncidentVO |
CustomerStatementListResult |
CustomerStatementResult |
CustomerStatementTotalResult |
CustomerVendorAddressInfoVO |
CustomerVendorAddressTotalInfo |
CustomerVendorAddressVO |
CustomerVendorContactPK |
CustomerVendorContactVO |
CustomerVendorDescriptionPK |
CustomerVendorDescriptionVO |
CustomerVendorTypeVO |
CustomGoodsBreedVO |
CustomGoodsRecordVO |
CustomJobCategoryGoodsPK |
CustomJobCategoryGoodsVO |
CustomJobCategoryVO |
CustomSearchVO |
CustomTranslationVO |
CV2CVAgent |
CycleCountAgent |
CycleCountListResult |
CycleCountListTotalResult |
CycleCountPK |
CycleCountStatusVO |
CycleCountVO |
DataFilterVO |
DBReason |
DebitsCreditsResult |
DepartmentLocationForBackflushVO |
DepositSummaryResult |
DepreciateMonthlyReport |
DesignControlDocumentVO |
DesignControlInfoVO |
DesignControlListResult |
DesignControlVO |
DisassembleWorkOrderApprovalVO |
DisassembleWorkOrderDocumentVO |
DisassembleWorkOrderIssueVO |
DisassembleWorkOrderIssuingItemResult |
DisassembleWorkOrderIssuingResult |
DisassembleWorkOrderItemListResult |
DisassembleWorkOrderItemPartDetailItemResult |
DisassembleWorkOrderItemPartDetailResult |
DisassembleWorkOrderItemPK |
DisassembleWorkOrderItemReceiverPK |
DisassembleWorkOrderItemReceiverVO |
DisassembleWorkOrderItemVO |
DisassembleWorkOrderListResult |
DisassembleWorkOrderReceivingResult |
DisassembleWorkOrderVO |
DocumentAction |
DocumentAction.DwfAndDwgDocAction |
DocumentAction.MiscDocAction |
DocumentAction.PartDocAction |
DocumentInfoAgent |
DocumentLogVO |
DocumentServerVO |
DuePATotalByVendorResult |
DwfUploadSettingsVO |
DwgUploadSettingsVO |
DWOIssueDetail |
DynamicSearchFilter |
EcnCheckOrderResult |
EcnPOOrderResult |
ECNReviewVO |
EcnWOOrderResult |
ECRReviewVO |
EjbMethodVO |
EmployeeCardVO |
EmployeeEducationPK |
EmployeeEducationResult |
EmployeeEducationVO |
EmployeeHomeVO |
EmployeeJobDescriptionVO |
EmployeeLaborAgent |
EmployeePutGoodListResult |
EmployeeRecordsVO |
EmployeeTimeCardResult |
EmployeeTrainingVO |
EmployeeWorkExperiencePK |
EmployeeWorkExperienceVO |
EngGroupUserPK |
EngGroupUserVO |
EngGroupVO |
EngineeringChangeDocumentVO |
EngineeringChangeListResult |
EngineeringChangeRequestDocumentVO |
EngineeringChangeRequestListResult |
EngineeringChangeRequestVO |
EngineeringChangeVO |
EngineeringInfoCenterResult |
EngineeringSharingImportLogVO |
EngineeringSharingItemPK |
EngineeringSharingItemVO |
EngineeringSharingVO |
EquipmentListResult |
EquipmentVO |
ExchangeAuditItemResult |
ExchangeAuditResult |
ExpenseAccountVO |
ExpenseItemPK |
ExpenseItemVO |
ExpenseListResult |
ExpenseVO |
FeedbackAnswerPK |
FeedbackAnswerVO |
FeedBackItemPK |
FeedbackItemVO |
FeedbackQuestionVO |
FinishProformaReceiverAgent |
FiscalYearSettingsVO |
GeneralLedgerApprovalVO |
GeneralLedgerByDateListResult |
GeneralLedgerCategoryVO |
GeneralLedgerEntry |
GeneralLedgerListResult |
GeneralLedgerPrintResult |
GeneralLedgerResult |
GeneralLedgerSettingsVO |
GeneralLedgerVO |
GLApprovalListResult |
GLAutoApproveVO |
GlBalanceInfoResult |
GLByDateTotalResult |
GlCashFlowBudgetVO |
GLCatAndSequence |
GLCheckRegisterResult |
GLDebitCreditListResult |
GlFiscalYearBudgetVO |
GLInfoByPeriodResult |
GLItemVO |
GlMonthBudgetVO |
GlMonthVO |
GroupUserPK |
GroupUserVO |
HelpServerVO |
HighUsagePartResult |
HistoricalInventoryTotalResult |
HistoricalInventoryVO |
I18nEvent |
IcrItemListResult |
IcrListResult |
ImportContractPriceData |
ImportDataVO |
IncomeByMonthChartResult |
IncotermVO |
InfoByFiscalChartResult |
InfoByMonthChartResult |
InfoByMonthResult |
InSipAudittListResult |
InspectionConformanceReportItemCheckPK |
InspectionConformanceReportItemCheckVO |
InspectionConformanceReportItemInfo |
InspectionConformanceReportItemPK |
InspectionConformanceReportItemVO |
InspectionConformanceReportVO |
InspectionItemPK |
InspectionItemVO |
InspectionReportInfoVO |
InspectionReportInspectMethodItemPK |
InspectionReportInspectMethodItemVO |
InspectionReportInspectMethodVO |
InspectionReportInspectStandardItemPK |
InspectionReportInspectStandardItemVO |
InspectionReportItemPK |
InspectionReportItemQtyPK |
InspectionReportItemQtyVO |
InspectionReportItemVO |
InspectionReportVO |
InspectionTypeItemPK |
InspectionTypeItemVO |
InspectionTypeVO |
InventoryAdjustmentDetailResult |
InventoryAdjustmentListResult |
InventoryAdjustmentVO |
InventoryAmountByMonth |
InventoryAuditReportResult |
InventoryCycleItemResult |
InventoryCycleResult |
InventoryListResult |
InventoryMonthReport |
InventoryNotUsedInMonthsforAppResult |
InventoryNotUsedInMonthsResult |
InventoryNotUsedTotal |
InventoryPartInOutDetailListResult |
InventoryReportListResult |
InventoryTotalCostResult |
InventoryTotalResult |
InvoiceAgingItemListResult |
InvoiceItemListResult |
IpAddressVO |
IssuedFromOrderItem |
IssueItemAgent |
IssueItemDetailAgent |
IssuingItemResult |
IssuingResult |
JobProcessSheetItemResult |
JobProcessSheetListResult |
JobProcessSheetResult |
JounalEntryListResult |
LabelTemplateConstant |
LabelTemplateItemPK |
LabelTemplateItemVO |
LabelTemplateVO |
ListCache |
LnShipperItemListResult |
LnShipperListResult |
LocationResult |
LockedCustomerAddressResult |
LogInventoryListResult |
LogInventoryVO |
LogMethodPK |
LogMethodVO |
LogMiscDocumentVO |
LogPartDocumentVO |
LogPartDwfVO |
LogPartDwgVO |
LogTaskVO |
LogTrackingVO |
MaintenanceItemPK |
MaintenanceItemVO |
MakeAccountPayableAgent |
MakeBillAndHoldInvoiceAgent |
MakeCheckAgent |
MakeCreditMemoAgent |
MakeDebitMemoAgent |
MakeInvoiceAgent |
MakePrepaymentCheckAgent |
ManufacturerAddressInfoVO |
ManufacturerAddressVO |
ManufacturerContactPK |
ManufacturerContactVO |
ManufacturerDescriptionPK |
ManufacturerDescriptionVO |
MasterWorkOrderTreeItemResult |
MessageAgent |
MessageVO |
MfrMpnListResult |
MiscDocAgent |
MiscDocumentSettingVO |
Money |
MoneyInDrawResult |
MonthBalanceResult |
MonthSoOrArByCustomerResult |
MrpByMonthResult |
MrpItemOrderDemandRecordsResult |
MrpItemResult |
MrpReportAgent |
MultiLanguageAccountsChartPK |
MultiLanguageAccountsChartVO |
MyPrintListPK |
MyPrintListVO |
NCQRejectResult |
NcrApprovalPK |
NcrApprovalVO |
NcrNeedToScrapListResult |
NCRPartOnhandPK |
NCRPictureListResult |
NCRPictureVO |
NcrReportListResult |
NcrScrapAgent |
NonConformanceCodeDescriptionPK |
NonConformanceCodeDescriptionVO |
NonConformanceCodeVO |
NonConformanceQuantityPK |
NonConformanceQuantityVO |
NonConformanceReportResult |
NonConformanceReportVO |
NonproductivePickingApprovalVO |
NonproductivePickingApproveVO |
NonproductivePickingItemIssuedListResult |
NonproductivePickingItemIssuedVO |
NonproductivePickingItemPK |
NonproductivePickingItemResult |
NonproductivePickingItemVO |
NonproductivePickingOnDemandResult |
NonproductivePickingTypeVO |
NonproductivePickingVO |
NoticeUserEmployeeListResult |
OIPrincipalVO |
OnhandQualityResult |
OnloanDocumentVO |
OnLoanItemListResult |
OnLoanItemPK |
OnLoanItemVO |
OnLoanListResult |
OnloanReceiverItemListResult |
OnloanReceiverItemPK |
OnloanReceiverItemVO |
OnloanReceiverListResult |
OnloanReceiverVO |
OnloanReviewVO |
OnloanShipperItemPK |
OnloanShipperItemVO |
OnloanShipperVO |
OnLoanVO |
OnTimeAgent |
OntimeDeliveryRateListResult |
OntimeDeliveryRateResult |
OpCodeShortcutPK |
OpCodeShortcutVO |
OperatingInstructionsInspectMethodItemPK |
OperatingInstructionsInspectMethodItemVO |
OperatingInstructionsInspectResultItemPK |
OperatingInstructionsInspectResultItemVO |
OperatingInstructionsInspectStandardItemPK |
OperatingInstructionsInspectStandardItemVO |
OperatingInstructionsInspectStandardVO |
OperatingInstructionsManualItemPK |
OperatingInstructionsManualItemVO |
OperatingInstructionsManualVO |
OperatingInstructionsTypeVO |
OperatingInstructionsUserStatisticalResult |
OperatingInstructionsVO |
OperatingOutputFileItemPK |
OperatingOutputFileItemVO |
OperatingOutputFileTypeVO |
OperationLogVO |
OrderApprovalItemsVO |
OrderApprovalVO | OrderApproval generated by MyEclipse Persistence Tools
OrderBoilerplatePK |
OrderBoilerplateVO |
OrderBy |
OrderDemandForReceiverResult |
OrderDocumentVO |
OrderPK |
OrderVendorItem |
OutputValueByMonthResult |
PackingBoxItemListResult |
PackingBoxItemPK |
PackingBoxItemVO |
PackingBoxPK |
PackingBoxSalesOrderItemAgent |
PackingBoxSalesOrderItemResult |
PackingBoxVO |
PartBasicInfo |
PartBasicInfoWithNewEngGroup |
PartBasicInfoWithNewListPrice |
PartCatagoryPK |
PartCatagoryVO |
PartCatalogAuditResult |
PartCatalogPK |
PartCatalogVO |
PartCertificateListResult |
PartCertificateVO |
PartClassInfoResult |
PartClassVO |
PartCostVarianceListResult |
PartDescriptionPK |
PartDescriptionVO |
PartDiscountPK |
PartDiscountVO |
PartDocumentPK |
PartDocumentVO |
PartDueAddressListResult |
PartDwfAgent |
PartDwfPK |
PartDwfVO |
PartDwfWithPartInfoResult |
PartDwgAgent |
PartDwgPK |
PartDwgVO |
PartDwgWithPartInfoResult |
PartExportInfo |
PartInMrpListResult |
PartInQAAgent |
PartInQAResult |
PartInQAVO |
PartInspectionPK |
PartInspectionResult |
PartInspectionVO |
PartInventoryVO |
PartInWipForIDListResult |
PartIssuedListResult |
PartIssuedVO |
PartIssueTotalResult |
PartManufacturerAgent |
PartManufacturerPK |
PartManufacturerVO |
PartMaterialBomListResult |
PartMaterialListResult |
PartMaterialReportAgent |
PartMaterialVO |
PartMaterialWhereUsedItemResult |
PartMaterialWhereUsedResult |
PartMRPVO |
PartNumberGenerateRuleVO |
PartOnhandAndCostResult |
PartOnHandAuditAgent |
PartOnHandAuditResult |
PartOnhandCostVO |
PartOnhandPK |
PartOnhandResult |
PartOnhandVO |
PartOnhandWithAverageCostResult |
PartOnHandWithMfgInfoResult |
PartOnHandWithPartBasicInfoResult |
PartPictureVO |
PartPK |
PartReceivedListResult |
PartReceivedVO |
PartSecurityLevelVO |
PartsToDeleteResult |
PartToAuditFlagResult |
PartTraceableCategoryPK |
PartTraceableCategoryVO |
PartTraceableInfoResult |
PartTraceableListResult |
PartTraceableResult |
PartTraceableSpecPK |
PartTraceableSpecVO |
PartTrackingPK |
PartTrackingVO |
PartTypeVO |
PartUnitPK |
PartUnitVO |
partUsedInfoResult |
PartUseTypeVO |
PartVendorPK |
PartVendorVO |
PartVO |
PartWhereUsedItemResult |
PartWhereUsedResult |
PartWithExcessiveInventoryListResult |
PartWithInventoryInfoListResult |
PartWithManufacturerInfoResult |
PartWithOnhandDetailInfoResult |
PartWithOnhandsVO |
PartWithOnLoanQtyListResult |
PartWithoutLocateResult |
PartWithQAQtyListResult |
PartWithQtyListResult |
PartWithSipQtyListResult |
PartWithSITQtyListResult |
PartWithSTOQtyListResult |
PartWithWipQtyListResult |
PasswordPolicyAgent |
PayableCheckRunItemPK |
PayableMethodVO |
PaymentAgent |
PaymentHistoryVO |
PaymentInvoicesResult |
PaymentRunItemTotalResult |
PaymentVO |
PermissionDescriptionPK |
PermissionDescriptionVO |
PermissionListResult |
PermissionMethodPK |
PermissionMethodVO |
PermissionVO |
PfReceiverItemPK |
PfReceiverItemVO |
PfReceiverItemWithNumberPK |
PfReceiverVO |
PhysicalInventoryListResult |
PhysicalInventoryListTotalResult |
PhysicalInventoryListWithAppDataResult |
PhysicalInventoryPK |
PhysicalInventoryStatusVO |
PhysicalInventoryVO |
PO2POAgent |
PO2SOExchange |
PO2SOExchangeItem |
PO2SOExchangeItemManufacturer |
POAndWOStatusResult |
POForWISeqAgent |
PointOfSaleVO |
POItemByRefDoc1ListResult |
PoMessageItemPK |
PoMessageItemVO |
PoMessageListResult |
PoMessageVO |
PoReceiverByDateSummaryResult |
POReceiverItemListResult |
PosRefdocVO |
POStatisticsResult |
PostCheckAgent |
POSurveyReportAgent |
POSurveyReportItemPK |
POSurveyReportItemVO |
POSurveyReportVO |
PosZipCodeTaxPK |
PosZipCodeTaxVO |
PrepayAgent |
PrepaymentWireTransferAgent |
PrepayPaymentAgent |
PreventiveActionRequestItemVO |
PreventiveActionRequestVO |
PrintLogoVO |
PrintTemplateVO |
ProfitAndLossAccountsResult |
ProfitLossStatementItemResult |
ProfitLossStatementResult |
ProformaInvoiceItemListResult |
ProformaInvoiceItemManufacturerPK |
ProformaInvoiceItemManufacturerVO |
ProformaInvoiceItemPK |
ProformaInvoiceItemVO |
ProformaInvoiceListResult |
ProformaInvoiceVO |
ProformaReceiverPackingBoxAgent |
ProformaReceiverPackingBoxItemAgent |
ProjectVO |
PrPackingBoxItemPK |
PrPackingBoxItemVO |
PrPackingBoxPK |
PrPackingBoxVO |
PrReceiverListResult |
PrReceiverWithQualityListResult |
PullFromWorkOrderPartDetailAgent |
PurchaseOnTimeResult |
PurchaseOrderApprovalVO |
PurchaseOrderBoilerplateVO |
PurchaseOrderCheckListResult |
PurchaseOrderContractResult |
PurchaseOrderDocumentVO |
PurchaseOrderItemListResult |
PurchaseOrderItemManufacturerPK |
PurchaseOrderItemManufacturerVO |
PurchaseOrderItemPK |
PurchaseOrderItemVO |
PurchaseOrderListResult |
PurchaseOrderOnOrderResult |
PurchaseOrderOnTimeItemResult |
PurchaseOrderOnTimeResult |
PurchaseOrderOpenDueListResult |
PurchaseOrderVO |
PurchaseWorkSheetItemPK |
PurchaseWorkSheetItemVO |
PurchaseWorkSheetItemWithRelatedInfoResult |
PurchaseWorkSheetPK |
PurchaseWorkSheetVO |
PurchasingInfoCenterResult |
PuttoInQAAgent |
QtyAndMoney |
QtyDetailResult |
QualityGroupPK |
QualityGroupVO |
QualityInfoCenterResult |
Quote2QuoteAgent |
QuoteBoilerplateVO |
QuoteDocumentVO |
QuoteItemListResult |
QuoteItemManufacturerPK |
QuoteItemManufacturerVO |
QuoteItemPK |
QuoteItemVO |
QuoteListResult |
QuoteVO |
Reason |
RebackInQAAgent |
ReceivedToOrderItem |
ReceiverAgent |
ReceiverInfoVO |
ReceiverItemAgent |
ReceiverItemDetailAgent |
ReceiverItemManufacturerPK |
ReceiverItemManufacturerVO |
ReceiverItemPK |
ReceiverItemTrackingLogAgent |
ReceiverItemVO |
ReceiverShipAgent |
ReceiverVO |
ReceivingItemResult |
ReceivingResult |
RecursiveBillPath |
RefdocElement |
RefdocVO |
RequestForQuoteCheckListResult |
RequestForQuoteItemListResult |
RequestForQuoteItemManufacturerPK |
RequestForQuoteItemManufacturerVO |
RequestForQuoteItemPK |
RequestForQuoteItemVO |
RequestForQuoteListResult |
RequestForQuoteVO |
RequestForRMAItemPK |
RequestForRMAItemVO |
RequestForRMAVO |
ReturnMaterialAuthorizationDocumentVO |
ReturnMaterialAuthorizationItemManufacturerPK |
ReturnMaterialAuthorizationItemManufacturerVO |
ReturnMaterialAuthorizationItemPK |
ReturnMaterialAuthorizationItemVO |
ReturnMaterialAuthorizationVO |
ReturnToVendorByDateListResult |
ReturnToVendorCheckListResult |
ReturnToVendorItemListResult |
ReturnToVendorItemManufacturerPK |
ReturnToVendorItemManufacturerVO |
ReturnToVendorItemPK |
ReturnToVendorItemVO |
ReturnToVendorListResult |
ReturnToVendorVO |
RfqMessageItemPK |
RfqMessageItemVO |
RfqMessageListResult |
RfqMessageVO |
RMAItemListResult |
RMAListResult |
RMAReceiverItemListResult |
RMAReceiverItemPK |
RMAReceiverItemVO |
RMAReceiverListResult |
RMAReceiverResult |
RMAReceiverVO |
RMAReviewVO |
RoleDescriptionPK |
RoleDescriptionVO |
RoleListResult |
RolePermissionPK |
RolePermissionVO |
RoleVO |
RollUpBomStdCostWorkSheetItemPK |
RollUpBomStdCostWorkSheetItemVO |
RollUpBomStdCostWorkSheetVO |
RollUPPartStandardCostResult |
RRMAItemListResult |
RRMAListResult |
RTVApprovalVO |
RtvShipperInfoVO |
RtvShipperItemListResult |
RtvShipperItemPK |
RtvShipperItemVO |
RtvShipperListResult |
RtvShipperVO |
RunningAccountOrderItemPK |
RunningAccountOrderItemResult |
RunningAccountOrderItemVO |
RunningAccountOrderVO |
RunTaxPaymentResult |
SalesBomItemResult |
SalesBomResult |
SalesCodeVO |
SalesInfoCenter |
SalesInfoCenter.DueSoCount |
SalesInfoCenter.DueSoSum |
SalesInfoCenter.GrossMargin |
SalesInfoCenter.InvoicedSum |
SalesInfoCenter.OpenSoSum |
SalesInfoCenter.SoCount |
SalesInfoCenter.SoCountWithPartsOnhold |
SalesInfoCenter.SoItemCount |
SalesInfoCenter.SoTotalSum |
SalesInfoCenterResult |
SalesmanVO |
SalesMarginListResult |
SalesOnTimeResult |
SalesOrder12MonthMarginResult |
SalesOrderBoilerplateVO |
SalesOrderCheckListResult |
SalesOrderDocumentVO |
SalesOrderItemCostResult |
SalesOrderItemCustomerTotalResult |
SalesOrderItemGroupByPartListResult |
SalesOrderItemInfoVO |
SalesOrderItemListResult |
SalesOrderItemManufacturerPK |
SalesOrderItemManufacturerVO |
SalesOrderItemPK |
SalesOrderItemVO |
SalesOrderListResult |
SalesOrderOnDemandResult |
SalesOrderOnTimeItemResult |
SalesOrderOnTimeResult |
SalesOrderOrphanedResult |
SalesOrderReviewVO |
SalesOrderShipDateListResult |
SalesOrderVO |
SalesPartListItemResult |
SalesPartListResult |
SalesTaxListResult |
ScrapAssetAgent |
ScrapReportVO |
SerialNumberItemPK |
SerialNumberItemResult |
SerialNumberItemVO |
SerialNumberPK |
SerialNumberResult |
SerialNumberVO |
ServerAction |
ServerClientPropertyPK |
ServerClientPropertyVO |
SGBillItemPK |
SGBillItemVO |
SGBOMItemResult |
SGBOMResult |
SGCartCheckOutResult |
SGCartLogin |
SGClientAccountPK |
SGClientAccountVO |
SGClientLogin |
SgClientProgramUserVO |
SGCompanyPK |
SGCompanyVO |
SGCustomerCatalogPK |
SGCustomerCatalogVO |
SGCustomerServiceRequestVO |
SGCustRequestForQuoteItemPK |
SGCustRequestForQuoteItemResult |
SGCustRequestForQuoteItemVO |
SGCustRequestForQuoteListResult |
SGCustRequestForQuoteResult |
SGCustRequestForQuoteVO |
SGDocPartPK |
SGDocPartVO |
SGDwgPicturePK |
SGDwgPictureVO |
SGLogLoginVO |
SGPartCartAgent |
SGPartCatalogResult |
SGPartDocFlagResult |
SGPartListItemResult |
SGPartListResult |
SGPicturePK |
SGPictureVO |
SGQuoteAddressResult |
SGQuoteAddressVO |
SGQuoteCartListResult |
SGQuoteCartVO |
SGQuoteLoginVO |
SGSaleItemAgent |
SGSaleItemVO |
SGWeightUnitVO |
ShareHoldersEquityResult |
ShipListAgent |
ShipListInfoVO |
ShipListItemPK |
ShipListItemRelatedDocResult |
ShipListItemVO |
ShipListItemVOResult |
ShipListOwnerAttributePK |
ShipListOwnerAttributeVO |
ShipListOwnerVO |
ShipListVO |
ShipperAgent |
ShipperInfoVO |
ShipperItemAgent |
ShipperItemDetailAgent |
ShipperItemListResult |
ShipperItemManufacturerPK |
ShipperItemManufacturerVO |
ShipperItemPK |
ShipperItemVO |
ShipperListResult |
ShipperVO |
ShippingItemResult |
ShippingResult |
ShoppingCartItem |
SmtpServerVO |
SO2POAgent |
SO2SOAgent |
SO2WOAgent |
SoPickListResult |
SOShipperItemListResult |
Spiderman |
StaffWorkingInformationResult |
StockTransactionAdjustmentResult |
StockTransactionPartInfoResult |
StockTransactionPOReceiverResult |
StockTransactionSOShipperResult |
StockTransactionWOReceiverResult |
StockTransactionWOShipperResult |
StringListConvertor |
SubcompanyLoginAgent |
SubcompanyVO |
SwapOrderApprovalVO |
SwapOrderItemListResult |
SwapOrderItemPK |
SwapOrderItemVO |
SwapOrderListResult |
SwapOrderVO |
SwapReceiverItemListResult |
SwapReceiverItemPK |
SwapReceiverItemVO |
SwapReceiverListResult |
SwapReceiverVO |
SwapShipperItemListResult |
SwapShipperItemPK |
SwapShipperItemVO |
SwapShipperListResult |
SwapShipperOnOrderResult |
SwapShipperVO |
TakeCycleCountAgent |
TaskFileResult |
TaskVO |
TaxAccountVO |
TempArApAgingVO |
TempReceiverWithoutAPInfo |
TermAgent |
TermsConditionVO |
TermVO |
ToolBasicInfo |
ToolCalibrateListResult |
ToolCalibrationVO |
ToolDescriptionVO |
ToolInventoryVO |
ToolListDetailCostResult |
ToolListDetailCostWithToolInfoResult |
ToolListInfoVO |
ToolListItemDetailCostWithToolInfoResult |
ToolListItemVO |
ToolListItemWithToolInfoResult |
ToolListVO |
ToolListWithToolInfoResult |
ToolManufacturerVO |
ToolOnhandVO |
ToolOnhandWithAverageCostResult |
ToolVendorVO |
ToolVO |
ToolWhereUsedItemResult |
ToolWhereUsedResult |
ToolWithManufacturerInfoResult |
ToolWithOnhandsVO |
TotalAmountInPOByRefDoc |
TotalByDateResult |
TraceableCategoriesVO |
TraceableSpecsVO |
TransferOrderApprovalVO |
TransferOrderItemListResult |
TransferOrderItemPK |
TransferOrderItemVO |
TransferOrderListResult |
TransferOrderVO |
TransferReceiverItemListResult |
TransferReceiverItemPK |
TransferReceiverItemVO |
TransferReceiverListResult |
TransferReceiverVO |
TransferShipperItemListResult |
TransferShipperItemPK |
TransferShipperItemVO |
TransferShipperListResult |
TransferShipperVO |
TwelveMonthCashFlowReportResult |
UnitVO |
UpdatePhysicalInventoryAgent |
User2UserAgent |
UserGroupVO |
UserRolePermissionListResult |
UserRolePK |
UserRoleVO |
VendorCategoriesVO |
VendorContractPriceItemPK |
VendorContractPriceItemVO |
VendorContractPriceVendorPK |
VendorContractPriceVendorVO |
VendorContractPriceVO |
VendorCriticalLevelVO |
VendorGroupUserVO |
VendorPartPK |
VendorPartVO |
VendorPrepayStatementListResult |
VendorPriceAgent |
VendorQtyPricePK |
VendorQtyPriceVO |
VendorStatementListResult |
VendorTotalAmountInPO |
VersionInformation |
VO |
WareHousePartPrefixKeeperVO |
WarehouseTransferPK |
WarehouseTransferVO |
WarehouseVO |
WareHousingInfoCenterResult |
WC2WCAgent |
WCLoadAgent |
WCLoadByDateResult |
WCLoadDetailResult |
WCLoadOnDateResult |
WeightUnitVO |
WireTransferAgent |
WO2WOAgent |
WOIssuedByMonthChartResult |
WOIssuedByMonthResult |
WOItemCostControlAgent |
WOItemPartDetailNotIssue |
WoItemPickListItemResult |
WoItemPickListResult |
WoItemWorkInstructionListResult |
WOReceiverDetail |
WorkCalendarVO |
WorkCenterAgent |
WorkCenterGroupItemPK |
WorkCenterGroupItemVO |
WorkCenterLoadAgent |
WorkCenterLoadListResult |
WorkCenterOnDateAgent |
WorkCenterRunTimeAgent |
WorkCenterRunTimeListResult |
WorkCenterRunTimeTotalResult |
WorkCenterVendorPK |
WorkCenterVendorVO |
WorkCenterVO | Title:
WorkFlowVO |
WorkInstructionApprovalVO |
WorkInstructionDocumentVO |
WorkInstructionListResult |
WorkInstructionPictureVO |
WorkInstructionPK |
WorkInstructionRequestForChangeVO |
WorkInstructionSeqAuditListResult |
WorkInstructionSequenceListResult |
WorkInstructionSequencePK |
WorkInstructionSequenceVO |
WorkInstructionSummaryItemResult |
WorkInstructionSummaryResult |
WorkInstructionVO |
WorkOrderApprovalVO |
WorkOrderBoilerplateVO |
WorkOrderCheckListResult |
WorkOrderDocumentVO |
WorkOrderInfoCenterResult |
WorkOrderInWipResult |
WorkOrderIssuedOrderListResult |
WorkOrderIssueStatisticsResult |
WorkOrderItemAgent |
WorkOrderItemCanAssyAgent |
WorkOrderItemCanAssyResult |
WorkOrderItemInfoResult |
WorkOrderItemInWipListResult |
WorkOrderItemIssuedTotalResult |
WorkOrderItemIssuePK |
WorkOrderItemIssueVO |
WorkOrderItemLaborCostListResult |
WorkOrderItemListResult |
WorkOrderItemPartDetail |
WorkOrderItemPartDetailInWipVO |
WorkOrderItemPartDetailItemResult |
WorkOrderItemPartDetailResult |
WorkOrderItemPK |
WorkOrderItemReviewCostResult |
WorkOrderItemSeqWCLoadResult |
WorkOrderItemSetupItemAgent |
WorkOrderItemTimeDetailResult |
WorkOrderItemTimeDetailVO |
WorkOrderItemToIssueResult |
WorkOrderItemVO |
WorkOrderItemWCLoadResult |
WorkOrderListResult |
WorkOrderNotSetupResult |
WorkOrderOnDemandResult |
WorkOrderOnOrderResult |
WorkOrderOnTimeItemResult |
WorkOrderOnTimeResult |
WorkOrderOverIssueListResult |
WorkOrderQueryInfo |
WorkOrderReceiverVO |
WorkOrderTimeCardVO |
WorkOrderVO |
WorkOrderWorkInstructionListResult |
WorkOrderWorkInstructionPK |
WorkOrderWorkInstructionSequenceDateAgent |
WorkOrderWorkInstructionSequencePK |
WorkOrderWorkInstructionSequenceVO |
WorkOrderWorkInstructionVO |
WorkOrderWorkItemDateAgent |
WorkOrderWorkSheetItemPK |
WorkOrderWorkSheetItemVO |
WorkOrderWorkSheetItemWithRelatedInfoResult |
WorkOrderWorkSheetPK |
WorkOrderWorkSheetVO |
WorkPeriodVO |
WorkSheetPartAgent |
YearMonthManager |
ZipCodeTaxVO |
ZipcodeTotalsResult |
ZipCodeVO |
ZippedByteArray |

Exception Summary
AppException
BB2DocumentException
BB2MessagingException
BB2ServerException
BizException
DBAccessException
InvokeException
LoginException
PermissionException
ServerException

Overview Package Class Use Tree Deprecated Index Help
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


bb.common Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package bb.common

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • bb.common.AccountAgingTotalResult (implements java.io.Serializable)
    • bb.common.AccountAuditAgent (implements java.io.Serializable)
    • bb.common.AccountBalanceAgent (implements java.io.Serializable)
    • bb.common.AccountBalanceListResult (implements java.io.Serializable)
    • bb.common.AccountBalanceResult (implements java.io.Serializable)
    • bb.common.AccountCreditDebitPK (implements java.io.Serializable)
    • bb.common.AccountInfoCenterItemResult (implements java.io.Serializable)
    • bb.common.AccountInfoCenterResult (implements java.io.Serializable)
    • bb.common.AccountingBalanceSheetResult (implements java.io.Serializable)
    • bb.common.AccountingTotalMoneyResult (implements java.io.Serializable)
    • bb.common.AccountMonthPK (implements java.io.Serializable)
    • bb.common.AccountPayableInfoWithPrepayResult (implements java.io.Serializable)
    • bb.common.AccountReceivableInfoWithPrepayResult (implements java.io.Serializable)
    • bb.common.AccountsChartMappingPK (implements java.lang.Comparable<T>, java.io.Serializable)
    • bb.common.AccountsChartResult (implements java.io.Serializable)
    • bb.common.AccountsCreditDebitListResult (implements bb.common.Alarmable, java.io.Serializable)
    • bb.common.AccountsPayableItemManufacturerPK (implements java.io.Serializable)
    • bb.common.AccountsPayableItemPK (implements java.io.Serializable)
    • bb.common.AccountsReceivableItemManufacturerPK (implements java.io.Serializable)
    • bb.common.AccountsReceivableItemPK (implements java.io.Serializable)
    • bb.common.AddPayableWithoutReceiverAgent (implements java.io.Serializable)
    • bb.common.AddPhysicalInventoryAgent (implements java.io.Serializable)
    • bb.common.AddProformaReceiverAgent (implements java.io.Serializable)
    • bb.common.AddProformaReceiverItemAgent (implements java.io.Serializable)
    • bb.common.AddressAccountInfo (implements java.io.Serializable)
    • bb.common.AddRTVAgent (implements java.io.Serializable)
    • bb.common.AllBudgetResult (implements java.io.Serializable)
    • bb.common.AllPartDocumentsPK (implements java.io.Serializable)
    • bb.common.AllStatementsListResult (implements java.io.Serializable)
    • bb.common.AmountsStatementResult (implements java.io.Serializable)
    • bb.common.APAuditListResult (implements bb.common.Alarmable, java.io.Serializable)
    • bb.common.ApCheckRunItemAgent (implements java.io.Serializable)
    • bb.common.ApCheckRunListResult (implements java.io.Serializable)
    • bb.common.APItemListResult (implements java.io.Serializable)
      • bb.common.APAgingItemListResult (implements java.io.Serializable)
    • bb.common.APPrepayInfoResult (implements java.io.Serializable)
    • bb.common.ApPrepayItemPK (implements java.io.Serializable)
    • bb.common.ApPrepaymentCheckRunItemAgent (implements java.io.Serializable)
    • bb.common.ApprovedGLResult (implements java.io.Serializable)
    • bb.common.APTaxForZipcodeListResult (implements java.io.Serializable)
    • bb.common.ARAllStatementsListResult (implements java.io.Serializable)
    • bb.common.ARAuditListResult (implements bb.common.Alarmable, java.io.Serializable)
    • bb.common.ArCommissionListResult (implements java.io.Serializable)
    • bb.common.ArCommissionTotalResult (implements java.io.Serializable)
    • bb.common.ArPaymentRunItemAgent (implements java.io.Serializable)
    • bb.common.ARPaymentRunItemPK (implements java.io.Serializable)
    • bb.common.ARPaymentRunListResult (implements java.io.Serializable)
    • bb.common.ARPrepayAllStatementsListResult (implements java.io.Serializable)
    • bb.common.ARPrepayInfoResult (implements java.io.Serializable)
    • bb.common.ArPrepayItemPK (implements java.io.Serializable)
    • bb.common.ArPrepaymentRunItemAgent (implements java.io.Serializable)
    • bb.common.ARPrepaymentWireTransferAgent (implements java.io.Serializable)
    • bb.common.ARTaxForZipcodeListResult (implements java.io.Serializable)
    • bb.common.AssetAddOrDisposalsReport (implements java.io.Serializable)
    • bb.common.AssetAmortizationExpenseAccountPK (implements java.io.Serializable)
    • bb.common.AssetDepreciatePK (implements java.io.Serializable)
    • bb.common.AssetUsagePK (implements java.io.Serializable)
    • bb.common.AuditOnDemandResult (implements java.io.Serializable)
    • bb.common.BalanceSheetSideBySideItemResult (implements java.io.Serializable)
    • bb.common.BalanceSheetSideBySideResult (implements java.io.Serializable)
    • bb.common.BB2AttachFile (implements java.io.Serializable)
    • bb.common.BB2BigDecimalAndString (implements java.lang.Comparable<T>, java.io.Serializable)
    • bb.common.BB2BugNotice (implements java.io.Serializable)
    • bb.common.BB2Document (implements java.io.Serializable)
    • bb.common.BB2DoubleCost (implements java.io.Serializable)
    • bb.common.BB2DoubleString (implements java.lang.Comparable<T>, java.io.Serializable)
    • bb.common.BB2Event (implements java.io.Serializable)
      • bb.common.I18nEvent
    • bb.common.BB2File (implements java.io.Serializable)
      • bb.common.BB2Picture
    • bb.common.BB2FiscalYearDate (implements java.io.Serializable)
    • bb.common.BB2Login (implements java.io.Serializable)
    • bb.common.BB2Notice (implements java.io.Serializable)
    • bb.common.BB2Part (implements java.lang.Comparable<T>, java.io.Serializable)
    • bb.common.BB2PartBasicInfo (implements java.io.Serializable)
      • bb.common.BB2PartInfo (implements java.io.Serializable)
        • bb.common.BB2PartMrpResult (implements java.io.Serializable)
      • bb.common.BB2PartTotalInQADetailResult (implements java.io.Serializable)
      • bb.common.BB2PartTotalInSipDetailResult (implements java.io.Serializable)
      • bb.common.BB2PartTotalInSitDetailResult (implements java.io.Serializable)
      • bb.common.BB2PartTotalInSTODetailResult (implements java.io.Serializable)
      • bb.common.BB2PartTotalInWipDetailResult (implements java.io.Serializable)
      • bb.common.BB2PartTotalOndemandDetailResult (implements java.io.Serializable)
      • bb.common.BB2PartTotalOnhandDetailResult (implements java.io.Serializable)
      • bb.common.BB2PartTotalOnloanDetailResult (implements java.io.Serializable)
      • bb.common.BB2PartTotalOnorderDetailResult (implements java.io.Serializable)
    • bb.common.BB2PartByDateResult (implements java.io.Serializable)
    • bb.common.BB2PartInSipItemResult (implements java.io.Serializable)
    • bb.common.BB2PartInSipOfSoItemResult (implements java.io.Serializable)
    • bb.common.BB2PartInSitItemResult (implements java.io.Serializable)
    • bb.common.BB2PartInSTOItemResult (implements java.io.Serializable)
    • bb.common.BB2PartInventoryResult (implements java.io.Serializable)
    • bb.common.BB2PartOnDemandListResult (implements java.io.Serializable)
    • bb.common.BB2PartOnhandPK (implements java.io.Serializable)
    • bb.common.BB2PartOnLoanItemResult (implements java.io.Serializable)
    • bb.common.BB2QtyAndMoneyMap (implements java.io.Serializable)
    • bb.common.BB2RefdocPK (implements java.io.Serializable)
    • bb.common.BB2Task (implements java.io.Serializable)
    • bb.common.BB2TimeFactory
    • bb.common.BB2tripleString (implements java.io.Serializable)
    • bb.common.BB2Util
    • bb.common.BB2WeightInfoResult (implements java.io.Serializable)
    • bb.common.BB2Zip
    • bb.common.BillDetailCostResult (implements java.io.Serializable)
    • bb.common.BillItemPK (implements java.io.Serializable)
    • bb.common.BillItemSalesResult (implements java.io.Serializable)
    • bb.common.BillItemSalesXResult (implements java.io.Serializable)
    • bb.common.BillItemUsagePathResult (implements java.io.Serializable)
    • bb.common.BillPK (implements java.io.Serializable)
    • bb.common.BillSalesOfCostResult (implements java.io.Serializable)
    • bb.common.BillSalesResult (implements java.io.Serializable)
    • bb.common.BillSalesXResult (implements java.io.Serializable)
    • bb.common.BillWhereUsedItemResult (implements java.io.Serializable)
    • bb.common.BillWhereUsedResult (implements java.io.Serializable)
    • bb.common.BizBoxServer (implements java.io.Serializable)
    • bb.common.BizBoxUserEmployeeResult (implements java.io.Serializable)
    • bb.common.BIZReason
    • bb.common.BizTarget
    • bb.common.BOMCanAssyAgent (implements java.io.Serializable)
    • bb.common.BOMCanAssyListResult (implements java.io.Serializable)
    • bb.common.BomItemWithOEMResult (implements java.io.Serializable)
    • bb.common.BomPickListItemResult (implements java.io.Serializable)
    • bb.common.BomPickListResult (implements java.io.Serializable)
    • bb.common.BOMTreeRollUPMap (implements java.io.Serializable)
    • bb.common.BomWithOEMResult (implements java.io.Serializable)
    • bb.common.BudgetListResult (implements java.io.Serializable)
    • bb.common.CarrierPK (implements java.io.Serializable)
    • bb.common.CashFlowByMonthReportResult (implements java.io.Serializable)
    • bb.common.CashFlowMonthTotalResult (implements java.io.Serializable)
    • bb.common.ChangeStdCostWorkSheetItemPK (implements java.io.Serializable)
    • bb.common.CheckRunItemTotalResult (implements java.io.Serializable)
    • bb.common.ClientAutoInvokeMethodsManager
    • bb.common.ClientListItem (implements java.io.Serializable)
    • bb.common.ClosingStatementItemResult (implements java.io.Serializable)
    • bb.common.ClosingStatementResult (implements java.io.Serializable)
    • bb.common.ClosingStatementTotalResult (implements java.io.Serializable)
    • bb.common.CompanyUnitAccountPK (implements java.io.Serializable)
    • bb.common.Configure
    • bb.common.Configure.LoginStatus
    • bb.common.Configure.Module
    • bb.common.Configure.Organization
    • bb.common.Configure.UpdatePermission
    • bb.common.Configure.UserLocked
    • bb.common.Configure.UserType
    • bb.common.Constant
    • bb.common.Constant.ActiveStatus
    • bb.common.Constant.AddressType
    • bb.common.Constant.AgeLevel
    • bb.common.Constant.AmountType
    • bb.common.Constant.ARDiscountMethod
    • bb.common.Constant.CategoryReportType
    • bb.common.Constant.CategoryType
    • bb.common.Constant.ChartOfAccountSubType
    • bb.common.Constant.ChartOfAccountType
    • bb.common.Constant.CheckType
    • bb.common.Constant.CostControl
    • bb.common.Constant.CustomerVendorMailType
    • bb.common.Constant.CVAddressType
    • bb.common.Constant.CycleCountPeriodUnit
    • bb.common.Constant.DataFilterType
    • bb.common.Constant.DateType
    • bb.common.Constant.DebitOrCredit
    • bb.common.Constant.Depreciation
    • bb.common.Constant.Depreciation.DepreciateStatus
    • bb.common.Constant.Depreciation.DepreciationMethod
    • bb.common.Constant.Depreciation.UsingType
    • bb.common.Constant.Download
    • bb.common.Constant.DrawingType
    • bb.common.Constant.ECRPriority
    • bb.common.Constant.EmployeeSecurityLevel
    • bb.common.Constant.EmployeeStatus
    • bb.common.Constant.EngineeringSharingImportDataType
    • bb.common.Constant.EngineeringSharingImportType
    • bb.common.Constant.EquipmentStatus
    • bb.common.Constant.ExchangeRateType
    • bb.common.Constant.FileExt
    • bb.common.Constant.GLApprovedType
    • bb.common.Constant.GLStyle
    • bb.common.Constant.GLType
    • bb.common.Constant.InventoryCostMothed
    • bb.common.Constant.InventoryWorkSheetOrderBy
    • bb.common.Constant.IrDateType
    • bb.common.Constant.IRType
    • bb.common.Constant.IssuedFrom
    • bb.common.Constant.LanguageCode
    • bb.common.Constant.LocalSettings
    • bb.common.Constant.LoginType
    • bb.common.Constant.MakeBuy
    • bb.common.Constant.MiscDocType
    • bb.common.Constant.NaRecTo
    • bb.common.Constant.NcrApprovableType
    • bb.common.Constant.NoticeAction
    • bb.common.Constant.NoticeType
    • bb.common.Constant.OITypeSerialNumberType
    • bb.common.Constant.OrderType
    • bb.common.Constant.Package
    • bb.common.Constant.PageCycleCount
    • bb.common.Constant.PAOffsetType
    • bb.common.Constant.PartFrom
    • bb.common.Constant.PartNumberGenerateType
    • bb.common.Constant.PartQtyType
    • bb.common.Constant.PayableMethod
    • bb.common.Constant.PeriodUnit
    • bb.common.Constant.PosOrderType
    • bb.common.Constant.Prefix
    • bb.common.Constant.PrintTemplateType
    • bb.common.Constant.ReceiveCondition
    • bb.common.Constant.ReceivedTo
    • bb.common.Constant.SalesTaxReportType
    • bb.common.Constant.SGType
    • bb.common.Constant.StatementType
    • bb.common.Constant.Status
    • bb.common.Constant.SystemUserGroup
    • bb.common.Constant.TaxType
    • bb.common.Constant.TermsConditonType
    • bb.common.Constant.TrackingNumberType
    • bb.common.Constant.TransactionType
    • bb.common.Constant.TransferType
    • bb.common.Constant.Upload
    • bb.common.Constant.VendorQualityStatus
    • bb.common.Constant.WorkCenterSearchType
    • bb.common.Constant.WorkCenterType
    • bb.common.Constant.WorkLevel
    • bb.common.Constant.YesNO
    • bb.common.ContractPriceCustomerPK (implements java.io.Serializable)
    • bb.common.ContractPriceItemPK (implements java.io.Serializable)
    • bb.common.CopyUtil
    • bb.common.CPItemFromQuoteResult (implements java.io.Serializable)
    • bb.common.CRTVItemListResult (implements java.io.Serializable)
    • bb.common.CRTVListResult (implements java.io.Serializable)
    • bb.common.CSRAgent (implements java.io.Serializable)
    • bb.common.CurrencyExchangePK (implements java.io.Serializable)
    • bb.common.CurrentBalanceResult (implements java.io.Serializable)
    • bb.common.CustomAssetRecordPK (implements java.io.Serializable)
    • bb.common.CustomEmployeeTrainPK (implements java.io.Serializable)
    • bb.common.CustomerCLimitResult (implements java.io.Serializable)
    • bb.common.CustomerPrepayStatementListResult (implements java.io.Serializable)
    • bb.common.CustomerReturnToVendorItemPK (implements java.io.Serializable)
    • bb.common.CustomerServiceIncidentItemListResult (implements java.io.Serializable)
    • bb.common.CustomerServiceIncidentListResult (implements java.io.Serializable)
    • bb.common.CustomerStatementListResult (implements java.io.Serializable)
    • bb.common.CustomerStatementResult (implements java.io.Serializable)
    • bb.common.CustomerStatementTotalResult (implements java.io.Serializable)
    • bb.common.CustomerVendorAddressTotalInfo (implements java.io.Serializable)
    • bb.common.CustomerVendorContactPK (implements java.io.Serializable)
    • bb.common.CustomerVendorDescriptionPK (implements java.io.Serializable)
    • bb.common.CustomJobCategoryGoodsPK (implements java.io.Serializable)
    • bb.common.CV2CVAgent (implements java.io.Serializable)
    • bb.common.CycleCountAgent (implements java.io.Serializable)
    • bb.common.CycleCountListResult (implements java.io.Serializable)
    • bb.common.CycleCountListTotalResult (implements java.io.Serializable)
    • bb.common.CycleCountPK (implements java.io.Serializable)
    • bb.common.DBReason
    • bb.common.DebitsCreditsResult (implements java.io.Serializable)
    • bb.common.DepositSummaryResult (implements java.io.Serializable)
    • bb.common.DepreciateMonthlyReport (implements java.io.Serializable)
    • bb.common.DesignControlListResult (implements java.io.Serializable)
    • bb.common.DisassembleWorkOrderIssuingItemResult (implements java.io.Serializable)
    • bb.common.DisassembleWorkOrderIssuingResult (implements java.io.Serializable)
    • bb.common.DisassembleWorkOrderItemListResult (implements java.io.Serializable)
    • bb.common.DisassembleWorkOrderItemPartDetailItemResult (implements java.io.Serializable)
    • bb.common.DisassembleWorkOrderItemPartDetailResult (implements java.io.Serializable)
    • bb.common.DisassembleWorkOrderItemPK (implements java.lang.Comparable<T>, java.io.Serializable)
    • bb.common.DisassembleWorkOrderItemReceiverPK (implements java.io.Serializable)
    • bb.common.DisassembleWorkOrderListResult (implements java.io.Serializable)
    • bb.common.DisassembleWorkOrderReceivingResult (implements java.io.Serializable)
    • bb.common.DocumentAction
    • bb.common.DocumentAction.DwfAndDwgDocAction
    • bb.common.DocumentAction.MiscDocAction
    • bb.common.DocumentAction.PartDocAction
    • bb.common.DocumentInfoAgent (implements java.io.Serializable)
    • bb.common.DuePATotalByVendorResult (implements java.io.Serializable)
    • bb.common.DWOIssueDetail (implements java.io.Serializable)
    • bb.common.DynamicSearchFilter (implements java.io.Serializable)
    • bb.common.EcnCheckOrderResult (implements java.io.Serializable)
    • bb.common.EcnPOOrderResult (implements java.io.Serializable)
    • bb.common.EcnWOOrderResult (implements java.io.Serializable)
    • bb.common.EmployeeEducationPK (implements java.io.Serializable)
    • bb.common.EmployeeLaborAgent (implements java.io.Serializable)
    • bb.common.EmployeePutGoodListResult (implements java.io.Serializable)
    • bb.common.EmployeeTimeCardResult (implements java.io.Serializable)
    • bb.common.EmployeeWorkExperiencePK (implements java.io.Serializable)
    • bb.common.EngGroupUserPK (implements java.io.Serializable)
    • bb.common.EngineeringChangeListResult (implements java.io.Serializable)
    • bb.common.EngineeringChangeRequestListResult (implements java.io.Serializable)
    • bb.common.EngineeringInfoCenterResult (implements java.io.Serializable)
    • bb.common.EngineeringSharingItemPK (implements java.io.Serializable)
    • bb.common.EquipmentListResult (implements java.io.Serializable)
    • bb.common.ExchangeAuditItemResult (implements java.io.Serializable)
    • bb.common.ExchangeAuditResult (implements java.io.Serializable)
    • bb.common.ExpenseItemPK (implements java.io.Serializable)
    • bb.common.ExpenseListResult (implements java.io.Serializable)
    • bb.common.FeedbackAnswerPK (implements java.io.Serializable)
    • bb.common.FeedBackItemPK (implements java.io.Serializable)
    • bb.common.FinishProformaReceiverAgent (implements java.io.Serializable)
    • bb.common.GeneralLedgerByDateListResult (implements java.io.Serializable)
    • bb.common.GeneralLedgerEntry (implements java.io.Serializable)
    • bb.common.GeneralLedgerListResult (implements java.io.Serializable)
      • bb.common.GLDebitCreditListResult (implements java.io.Serializable)
    • bb.common.GeneralLedgerPrintResult (implements java.io.Serializable)
    • bb.common.GeneralLedgerResult (implements java.io.Serializable)
    • bb.common.GLApprovalListResult (implements java.io.Serializable)
    • bb.common.GlBalanceInfoResult (implements java.io.Serializable)
    • bb.common.GLByDateTotalResult (implements java.io.Serializable)
    • bb.common.GLCatAndSequence (implements java.io.Serializable)
    • bb.common.GLCheckRegisterResult (implements java.io.Serializable)
    • bb.common.GLInfoByPeriodResult (implements java.io.Serializable)
    • bb.common.GroupUserPK (implements java.io.Serializable)
    • bb.common.HighUsagePartResult (implements java.io.Serializable)
    • bb.common.HistoricalInventoryTotalResult (implements java.io.Serializable)
    • bb.common.IcrListResult (implements java.io.Serializable)
    • bb.common.IncomeByMonthChartResult (implements java.io.Serializable)
    • bb.common.InfoByFiscalChartResult (implements java.io.Serializable)
    • bb.common.InfoByMonthChartResult (implements java.io.Serializable)
    • bb.common.InfoByMonthResult (implements java.io.Serializable)
    • bb.common.InSipAudittListResult (implements java.io.Serializable)
    • bb.common.InspectionConformanceReportItemCheckPK (implements java.io.Serializable)
    • bb.common.InspectionConformanceReportItemInfo (implements java.io.Serializable)
    • bb.common.InspectionConformanceReportItemPK (implements java.io.Serializable)
    • bb.common.InspectionItemPK (implements java.io.Serializable)
    • bb.common.InspectionReportInspectMethodItemPK (implements java.io.Serializable)
    • bb.common.InspectionReportInspectStandardItemPK (implements java.io.Serializable)
    • bb.common.InspectionReportItemPK (implements java.io.Serializable)
    • bb.common.InspectionReportItemQtyPK (implements java.io.Serializable)
    • bb.common.InspectionTypeItemPK (implements java.io.Serializable)
    • bb.common.InventoryAdjustmentDetailResult (implements java.io.Serializable)
    • bb.common.InventoryAmountByMonth (implements java.io.Serializable)
    • bb.common.InventoryCycleItemResult (implements java.io.Serializable)
    • bb.common.InventoryCycleResult (implements java.io.Serializable)
    • bb.common.InventoryListResult (implements java.io.Serializable)
    • bb.common.InventoryMonthReport (implements java.io.Serializable)
    • bb.common.InventoryNotUsedInMonthsResult (implements java.io.Serializable)
      • bb.common.InventoryNotUsedInMonthsforAppResult
    • bb.common.InventoryNotUsedTotal (implements java.io.Serializable)
    • bb.common.InventoryReportListResult (implements java.io.Serializable)
      • bb.common.InventoryAuditReportResult (implements java.io.Serializable)
    • bb.common.InventoryTotalCostResult (implements java.io.Serializable)
    • bb.common.InventoryTotalResult (implements java.io.Serializable)
    • bb.common.InvoiceItemListResult (implements java.io.Serializable)
      • bb.common.CheckInvoiceItemListResult
      • bb.common.InvoiceAgingItemListResult (implements java.io.Serializable)
    • bb.common.IssuedFromOrderItem (implements java.io.Serializable)
    • bb.common.IssueItemAgent (implements java.io.Serializable)
    • bb.common.IssueItemDetailAgent (implements java.io.Serializable)
    • bb.common.IssuingItemResult (implements java.io.Serializable)
    • bb.common.IssuingResult (implements java.io.Serializable)
    • bb.common.JobProcessSheetItemResult (implements java.io.Serializable)
    • bb.common.JobProcessSheetListResult (implements java.io.Serializable)
    • bb.common.JobProcessSheetResult (implements java.io.Serializable)
    • bb.common.JounalEntryListResult (implements java.io.Serializable)
    • bb.common.LabelTemplateConstant (implements java.io.Serializable)
    • bb.common.LabelTemplateItemPK (implements java.io.Serializable)
    • bb.common.ListCache (implements java.io.Serializable)
    • bb.common.LnShipperItemListResult (implements java.io.Serializable)
    • bb.common.LnShipperListResult (implements java.io.Serializable)
    • bb.common.LocationResult (implements java.io.Serializable)
    • bb.common.LockedCustomerAddressResult (implements bb.common.Alarmable, java.io.Serializable)
    • bb.common.LogInventoryListResult (implements java.io.Serializable)
    • bb.common.LogMethodPK (implements java.io.Serializable)
    • bb.common.MaintenanceItemPK (implements java.io.Serializable)
    • bb.common.MakeAccountPayableAgent (implements java.io.Serializable)
    • bb.common.MakeBillAndHoldInvoiceAgent (implements java.io.Serializable)
    • bb.common.MakeCheckAgent (implements java.io.Serializable)
    • bb.common.MakeCreditMemoAgent (implements java.io.Serializable)
    • bb.common.MakeDebitMemoAgent (implements java.io.Serializable)
    • bb.common.MakeInvoiceAgent (implements java.io.Serializable)
    • bb.common.MakePrepaymentCheckAgent (implements java.io.Serializable)
    • bb.common.ManufacturerContactPK (implements java.io.Serializable)
    • bb.common.ManufacturerDescriptionPK (implements java.io.Serializable)
    • bb.common.MessageAgent (implements java.io.Serializable)
    • bb.common.MfrMpnListResult (implements java.io.Serializable)
    • bb.common.MiscDocAgent (implements java.io.Serializable)
    • bb.common.Money (implements java.io.Serializable)
    • bb.common.MoneyInDrawResult (implements java.io.Serializable)
    • bb.common.MonthBalanceResult (implements java.io.Serializable)
    • bb.common.MonthSoOrArByCustomerResult (implements java.io.Serializable)
    • bb.common.MrpByMonthResult (implements java.lang.Cloneable, java.io.Serializable)
    • bb.common.MrpItemOrderDemandRecordsResult (implements java.io.Serializable)
    • bb.common.MrpItemResult (implements java.io.Serializable)
    • bb.common.MrpReportAgent (implements java.io.Serializable)
    • bb.common.MultiLanguageAccountsChartPK (implements java.io.Serializable)
    • bb.common.MyPrintListPK (implements java.io.Serializable)
    • bb.common.NCQRejectResult (implements java.io.Serializable)
    • bb.common.NcrApprovalPK (implements java.io.Serializable)
    • bb.common.NcrNeedToScrapListResult (implements java.io.Serializable)
    • bb.common.NCRPartOnhandPK
    • bb.common.NCRPictureListResult (implements java.io.Serializable)
    • bb.common.NcrReportListResult (implements java.io.Serializable)
    • bb.common.NcrScrapAgent (implements java.io.Serializable)
    • bb.common.NonConformanceCodeDescriptionPK (implements java.io.Serializable)
    • bb.common.NonConformanceQuantityPK (implements java.io.Serializable)
    • bb.common.NonConformanceReportResult (implements java.io.Serializable)
    • bb.common.NonproductivePickingItemIssuedListResult (implements java.io.Serializable)
    • bb.common.NonproductivePickingItemPK (implements java.io.Serializable)
    • bb.common.NonproductivePickingItemResult (implements java.io.Serializable)
    • bb.common.NonproductivePickingOnDemandResult (implements java.io.Serializable)
    • bb.common.NoticeUserEmployeeListResult (implements java.io.Serializable)
    • bb.common.OnhandQualityResult (implements java.io.Serializable)
    • bb.common.OnLoanItemListResult (implements java.io.Serializable)
    • bb.common.OnLoanItemPK (implements java.io.Serializable)
    • bb.common.OnLoanListResult (implements java.io.Serializable)
    • bb.common.OnloanReceiverItemListResult (implements java.io.Serializable)
    • bb.common.OnloanReceiverItemPK (implements java.io.Serializable)
    • bb.common.OnloanReceiverListResult (implements java.io.Serializable)
    • bb.common.OnloanShipperItemPK (implements java.io.Serializable)
    • bb.common.OnTimeAgent (implements java.io.Serializable)
    • bb.common.OntimeDeliveryRateListResult (implements java.io.Serializable)
    • bb.common.OntimeDeliveryRateResult (implements java.io.Serializable)
    • bb.common.OpCodeShortcutPK (implements java.lang.Comparable<T>, java.io.Serializable)
    • bb.common.OperatingInstructionsInspectMethodItemPK (implements java.io.Serializable)
    • bb.common.OperatingInstructionsInspectResultItemPK (implements java.io.Serializable)
    • bb.common.OperatingInstructionsInspectStandardItemPK (implements java.io.Serializable)
    • bb.common.OperatingInstructionsManualItemPK (implements java.io.Serializable)
    • bb.common.OperatingInstructionsUserStatisticalResult (implements java.io.Serializable)
    • bb.common.OperatingOutputFileItemPK (implements java.io.Serializable)
    • bb.common.OrderBoilerplatePK (implements java.io.Serializable)
    • bb.common.OrderBy (implements java.io.Serializable)
    • bb.common.OrderDemandForReceiverResult (implements java.io.Serializable)
    • bb.common.OrderPK (implements java.io.Serializable)
    • bb.common.OrderVendorItem (implements java.io.Serializable)
    • bb.common.OutputValueByMonthResult (implements java.io.Serializable)
    • bb.common.PackingBoxItemListResult (implements java.io.Serializable)
    • bb.common.PackingBoxItemPK (implements java.io.Serializable)
    • bb.common.PackingBoxPK (implements java.io.Serializable)
    • bb.common.PackingBoxSalesOrderItemAgent (implements java.io.Serializable)
    • bb.common.PackingBoxSalesOrderItemResult (implements java.io.Serializable)
    • bb.common.PartBasicInfo (implements java.io.Serializable)
      • bb.common.BillItemSalesCostResult (implements java.io.Serializable)
      • bb.common.BillItemUsageResult (implements java.io.Serializable)
        • bb.common.BillItemOnHandUsageResult (implements java.io.Serializable)
      • bb.common.BillItemWithPartInfoResult (implements java.io.Serializable)
        • bb.common.BillItemDetailCostWithPartInfoResult (implements java.io.Serializable)
        • bb.common.BillItemOnHandWithPartInfoResult (implements java.io.Serializable)
          • bb.common.MasterWorkOrderTreeItemResult (implements java.io.Serializable)
      • bb.common.BillSalesCostResult (implements java.io.Serializable)
      • bb.common.BillWithPartInfoResult (implements java.io.Serializable)
        • bb.common.BillDetailCostWithPartInfoResult (implements java.io.Serializable)
        • bb.common.BillOnHandWithPartInfoResult (implements java.io.Serializable)
      • bb.common.PartBasicInfoWithNewEngGroup (implements java.io.Serializable)
      • bb.common.PartBasicInfoWithNewListPrice (implements java.io.Serializable)
      • bb.common.PartExportInfo (implements java.io.Serializable)
      • bb.common.PartMaterialListResult (implements java.io.Serializable)
        • bb.common.PartMaterialBomListResult (implements java.io.Serializable)
      • bb.common.PartOnHandWithMfgInfoResult (implements java.io.Serializable)
      • bb.common.PartOnHandWithPartBasicInfoResult (implements java.io.Serializable)
      • bb.common.PartTraceableListResult (implements java.io.Serializable)
      • bb.common.PartTraceableResult (implements java.io.Serializable)
      • bb.common.PartWithOnhandDetailInfoResult (implements java.io.Serializable)
      • bb.common.PartWithoutLocateResult
      • bb.common.ToolBasicInfo (implements java.io.Serializable)
        • bb.common.ToolListItemWithToolInfoResult (implements java.io.Serializable)
          • bb.common.ToolListItemDetailCostWithToolInfoResult (implements java.io.Serializable)
        • bb.common.ToolListWithToolInfoResult (implements java.io.Serializable)
          • bb.common.ToolListDetailCostWithToolInfoResult (implements java.io.Serializable)
    • bb.common.PartCatagoryPK (implements java.io.Serializable)
    • bb.common.PartCatalogAuditResult (implements bb.common.Alarmable, java.io.Serializable)
    • bb.common.PartCatalogPK (implements java.io.Serializable)
    • bb.common.PartCertificateListResult (implements java.io.Serializable)
    • bb.common.PartClassInfoResult (implements java.io.Serializable)
    • bb.common.PartCostVarianceListResult (implements java.io.Serializable)
    • bb.common.PartDescriptionPK (implements java.io.Serializable)
    • bb.common.PartDiscountPK (implements java.io.Serializable)
    • bb.common.PartDocumentPK (implements java.io.Serializable)
    • bb.common.PartDueAddressListResult (implements java.io.Serializable)
    • bb.common.PartDwfAgent (implements java.io.Serializable)
    • bb.common.PartDwfPK (implements java.io.Serializable)
    • bb.common.PartDwfWithPartInfoResult (implements java.io.Serializable)
    • bb.common.PartDwgAgent (implements java.io.Serializable)
    • bb.common.PartDwgPK (implements java.io.Serializable)
    • bb.common.PartDwgWithPartInfoResult (implements java.io.Serializable)
    • bb.common.PartInMrpListResult (implements java.io.Serializable)
    • bb.common.PartInQAAgent (implements java.io.Serializable)
    • bb.common.PartInspectionPK (implements java.io.Serializable)
    • bb.common.PartInspectionResult (implements java.io.Serializable)
    • bb.common.PartInWipForIDListResult (implements java.io.Serializable)
    • bb.common.PartIssueTotalResult (implements java.io.Serializable)
    • bb.common.PartManufacturerAgent
    • bb.common.PartManufacturerPK (implements java.io.Serializable)
    • bb.common.PartMaterialReportAgent (implements java.io.Serializable)
    • bb.common.PartMaterialWhereUsedItemResult (implements java.io.Serializable)
    • bb.common.PartMaterialWhereUsedResult (implements java.io.Serializable)
    • bb.common.PartOnhandAndCostResult (implements java.io.Serializable)
    • bb.common.PartOnHandAuditAgent (implements java.io.Serializable)
    • bb.common.PartOnHandAuditResult (implements bb.common.Alarmable, java.io.Serializable)
    • bb.common.PartOnhandPK (implements java.io.Serializable)
    • bb.common.PartOnhandResult (implements java.io.Serializable)
    • bb.common.PartOnhandWithAverageCostResult (implements java.io.Serializable)
    • bb.common.PartPK (implements java.lang.Comparable<T>, java.io.Serializable)
    • bb.common.PartsToDeleteResult (implements java.io.Serializable)
    • bb.common.PartToAuditFlagResult (implements java.io.Serializable)
    • bb.common.PartTraceableCategoryPK (implements java.io.Serializable)
    • bb.common.PartTraceableInfoResult (implements java.io.Serializable)
    • bb.common.PartTraceableSpecPK (implements java.io.Serializable)
    • bb.common.PartTrackingPK (implements java.io.Serializable)
    • bb.common.PartUnitPK (implements java.io.Serializable)
    • bb.common.partUsedInfoResult (implements java.io.Serializable)
    • bb.common.PartVendorPK (implements java.io.Serializable)
    • bb.common.PartWhereUsedItemResult (implements java.io.Serializable)
    • bb.common.PartWhereUsedResult (implements java.io.Serializable)
    • bb.common.PartWithExcessiveInventoryListResult (implements java.io.Serializable)
    • bb.common.PartWithInventoryInfoListResult (implements java.io.Serializable)
    • bb.common.PartWithManufacturerInfoResult (implements java.io.Serializable)
      • bb.common.ToolWithManufacturerInfoResult (implements java.io.Serializable)
    • bb.common.PartWithOnLoanQtyListResult (implements java.io.Serializable)
    • bb.common.PartWithQAQtyListResult (implements java.io.Serializable)
    • bb.common.PartWithQtyListResult (implements java.io.Serializable)
    • bb.common.PartWithSipQtyListResult (implements java.io.Serializable)
    • bb.common.PartWithSITQtyListResult (implements java.io.Serializable)
    • bb.common.PartWithSTOQtyListResult (implements java.io.Serializable)
    • bb.common.PartWithWipQtyListResult (implements java.io.Serializable)
    • bb.common.PasswordPolicyAgent (implements java.io.Serializable)
    • bb.common.PayableCheckRunItemPK (implements java.io.Serializable)
    • bb.common.PaymentAgent (implements java.io.Serializable)
    • bb.common.PaymentInvoicesResult (implements java.io.Serializable)
    • bb.common.PaymentRunItemTotalResult (implements java.io.Serializable)
    • bb.common.PermissionDescriptionPK (implements java.io.Serializable)
    • bb.common.PermissionListResult (implements java.io.Serializable)
    • bb.common.PermissionMethodPK (implements java.io.Serializable)
    • bb.common.PfReceiverItemPK (implements java.io.Serializable)
    • bb.common.PfReceiverItemWithNumberPK (implements java.io.Serializable)
    • bb.common.PhysicalInventoryListResult (implements java.io.Serializable)
      • bb.common.PhysicalInventoryListWithAppDataResult (implements java.io.Serializable)
    • bb.common.PhysicalInventoryListTotalResult (implements java.io.Serializable)
    • bb.common.PhysicalInventoryPK (implements java.io.Serializable)
    • bb.common.PO2POAgent (implements java.io.Serializable)
    • bb.common.PO2SOExchange (implements java.io.Serializable)
    • bb.common.PO2SOExchangeItem (implements java.io.Serializable)
    • bb.common.PO2SOExchangeItemManufacturer (implements java.io.Serializable)
    • bb.common.POAndWOStatusResult (implements java.io.Serializable)
    • bb.common.POForWISeqAgent (implements java.io.Serializable)
    • bb.common.PoMessageItemPK (implements java.io.Serializable)
    • bb.common.PoMessageListResult (implements java.io.Serializable)
    • bb.common.PoReceiverByDateSummaryResult (implements java.io.Serializable)
    • bb.common.POReceiverItemListResult (implements java.io.Serializable)
    • bb.common.POStatisticsResult (implements java.io.Serializable)
    • bb.common.PostCheckAgent (implements java.io.Serializable)
    • bb.common.POSurveyReportAgent (implements java.io.Serializable)
    • bb.common.POSurveyReportItemPK (implements java.io.Serializable)
    • bb.common.PosZipCodeTaxPK (implements java.io.Serializable)
    • bb.common.PrepayAgent (implements java.io.Serializable)
    • bb.common.PrepaymentWireTransferAgent (implements java.io.Serializable)
    • bb.common.PrepayPaymentAgent (implements java.io.Serializable)
    • bb.common.ProfitAndLossAccountsResult (implements java.io.Serializable)
    • bb.common.ProfitLossStatementItemResult (implements java.io.Serializable)
    • bb.common.ProfitLossStatementResult (implements java.io.Serializable)
    • bb.common.ProformaInvoiceItemListResult (implements java.io.Serializable)
    • bb.common.ProformaInvoiceItemManufacturerPK (implements java.io.Serializable)
    • bb.common.ProformaInvoiceItemPK (implements java.io.Serializable)
    • bb.common.ProformaInvoiceListResult (implements java.io.Serializable)
    • bb.common.ProformaReceiverPackingBoxAgent (implements java.io.Serializable)
    • bb.common.ProformaReceiverPackingBoxItemAgent (implements java.io.Serializable)
    • bb.common.PrPackingBoxItemPK (implements java.lang.Comparable<T>, java.io.Serializable)
    • bb.common.PrPackingBoxPK (implements java.io.Serializable)
    • bb.common.PrReceiverListResult (implements java.io.Serializable)
    • bb.common.PrReceiverWithQualityListResult (implements java.io.Serializable)
    • bb.common.PullFromWorkOrderPartDetailAgent (implements java.io.Serializable)
    • bb.common.PurchaseOnTimeResult (implements java.io.Serializable)
    • bb.common.PurchaseOrderCheckListResult (implements java.io.Serializable)
    • bb.common.PurchaseOrderContractResult (implements java.io.Serializable)
    • bb.common.PurchaseOrderItemListResult (implements java.io.Serializable)
      • bb.common.POItemByRefDoc1ListResult
    • bb.common.PurchaseOrderItemManufacturerPK (implements java.io.Serializable)
    • bb.common.PurchaseOrderItemPK (implements java.io.Serializable)
    • bb.common.PurchaseOrderListResult (implements java.io.Serializable)
    • bb.common.PurchaseOrderOnOrderResult (implements java.io.Serializable)
    • bb.common.PurchaseOrderOnTimeItemResult (implements java.io.Serializable)
    • bb.common.PurchaseOrderOnTimeResult (implements java.io.Serializable)
    • bb.common.PurchaseOrderOpenDueListResult (implements java.io.Serializable)
    • bb.common.PurchaseWorkSheetItemPK (implements java.io.Serializable)
    • bb.common.PurchaseWorkSheetItemWithRelatedInfoResult (implements java.io.Serializable)
    • bb.common.PurchaseWorkSheetPK (implements java.io.Serializable)
    • bb.common.PurchasingInfoCenterResult (implements java.io.Serializable)
    • bb.common.PuttoInQAAgent (implements java.io.Serializable)
    • bb.common.QtyAndMoney (implements java.io.Serializable)
    • bb.common.QtyDetailResult (implements java.io.Serializable)
    • bb.common.QualityGroupPK (implements java.io.Serializable)
    • bb.common.QualityInfoCenterResult (implements java.io.Serializable)
    • bb.common.Quote2QuoteAgent (implements java.io.Serializable)
    • bb.common.QuoteItemListResult (implements java.io.Serializable)
    • bb.common.QuoteItemManufacturerPK (implements java.io.Serializable)
    • bb.common.QuoteItemPK (implements java.io.Serializable)
    • bb.common.QuoteListResult (implements java.io.Serializable)
    • bb.common.Reason (implements java.io.Serializable)
    • bb.common.RebackInQAAgent (implements java.io.Serializable)
    • bb.common.ReceivedToOrderItem (implements java.io.Serializable)
    • bb.common.ReceiverAgent (implements java.io.Serializable)
    • bb.common.ReceiverItemAgent (implements java.io.Serializable)
    • bb.common.ReceiverItemDetailAgent (implements java.io.Serializable)
    • bb.common.ReceiverItemManufacturerPK (implements java.io.Serializable)
    • bb.common.ReceiverItemPK (implements java.io.Serializable)
    • bb.common.ReceiverItemTrackingLogAgent (implements java.io.Serializable)
    • bb.common.ReceiverShipAgent (implements java.io.Serializable)
    • bb.common.ReceivingItemResult (implements java.io.Serializable)
    • bb.common.ReceivingResult (implements java.io.Serializable)
    • bb.common.RecursiveBillPath (implements java.io.Serializable)
    • bb.common.RefdocElement (implements java.io.Serializable)
    • bb.common.RequestForQuoteCheckListResult (implements java.io.Serializable)
    • bb.common.RequestForQuoteItemListResult (implements java.io.Serializable)
    • bb.common.RequestForQuoteItemManufacturerPK (implements java.io.Serializable)
    • bb.common.RequestForQuoteItemPK (implements java.io.Serializable)
    • bb.common.RequestForQuoteListResult (implements java.io.Serializable)
    • bb.common.RequestForRMAItemPK (implements java.io.Serializable)
    • bb.common.ReturnMaterialAuthorizationItemManufacturerPK (implements java.io.Serializable)
    • bb.common.ReturnMaterialAuthorizationItemPK (implements java.io.Serializable)
    • bb.common.ReturnToVendorByDateListResult (implements java.io.Serializable)
    • bb.common.ReturnToVendorCheckListResult (implements java.io.Serializable)
    • bb.common.ReturnToVendorItemListResult (implements java.io.Serializable)
    • bb.common.ReturnToVendorItemManufacturerPK (implements java.io.Serializable)
    • bb.common.ReturnToVendorItemPK (implements java.io.Serializable)
    • bb.common.ReturnToVendorListResult (implements java.io.Serializable)
    • bb.common.RfqMessageItemPK (implements java.io.Serializable)
    • bb.common.RfqMessageListResult (implements java.io.Serializable)
    • bb.common.RMAItemListResult (implements java.io.Serializable)
    • bb.common.RMAListResult (implements java.io.Serializable)
    • bb.common.RMAReceiverItemListResult (implements java.io.Serializable)
    • bb.common.RMAReceiverItemPK (implements java.io.Serializable)
    • bb.common.RMAReceiverListResult (implements java.io.Serializable)
    • bb.common.RMAReceiverResult (implements java.io.Serializable)
    • bb.common.RoleDescriptionPK (implements java.io.Serializable)
    • bb.common.RoleListResult (implements java.io.Serializable)
    • bb.common.RolePermissionPK (implements java.io.Serializable)
    • bb.common.RollUpBomStdCostWorkSheetItemPK (implements java.io.Serializable)
    • bb.common.RollUPPartStandardCostResult (implements java.io.Serializable)
    • bb.common.RRMAItemListResult (implements java.io.Serializable)
    • bb.common.RRMAListResult (implements java.io.Serializable)
    • bb.common.RtvShipperItemListResult (implements java.io.Serializable)
    • bb.common.RtvShipperItemPK (implements java.io.Serializable)
    • bb.common.RtvShipperListResult (implements java.io.Serializable)
    • bb.common.RunningAccountOrderItemPK (implements java.io.Serializable)
    • bb.common.RunTaxPaymentResult (implements java.io.Serializable)
    • bb.common.SalesBomItemResult (implements java.io.Serializable)
    • bb.common.SalesBomResult (implements java.io.Serializable)
    • bb.common.SalesInfoCenter (implements java.io.Serializable)
    • bb.common.SalesInfoCenter.DueSoCount
    • bb.common.SalesInfoCenter.DueSoSum
    • bb.common.SalesInfoCenter.GrossMargin
    • bb.common.SalesInfoCenter.InvoicedSum
    • bb.common.SalesInfoCenter.OpenSoSum
    • bb.common.SalesInfoCenter.SoCount (implements java.io.Serializable)
    • bb.common.SalesInfoCenter.SoCountWithPartsOnhold
    • bb.common.SalesInfoCenter.SoItemCount (implements java.io.Serializable)
    • bb.common.SalesInfoCenter.SoTotalSum (implements java.io.Serializable)
    • bb.common.SalesInfoCenterResult (implements java.io.Serializable)
    • bb.common.SalesMarginListResult (implements java.io.Serializable)
    • bb.common.SalesOnTimeResult (implements java.io.Serializable)
    • bb.common.SalesOrder12MonthMarginResult (implements java.io.Serializable)
    • bb.common.SalesOrderCheckListResult (implements java.io.Serializable)
    • bb.common.SalesOrderItemCostResult (implements java.io.Serializable)
    • bb.common.SalesOrderItemCustomerTotalResult (implements java.io.Serializable)
    • bb.common.SalesOrderItemGroupByPartListResult (implements java.io.Serializable)
    • bb.common.SalesOrderItemListResult (implements java.io.Serializable)
    • bb.common.SalesOrderItemManufacturerPK (implements java.io.Serializable)
    • bb.common.SalesOrderItemPK (implements java.io.Serializable)
    • bb.common.SalesOrderListResult (implements java.io.Serializable)
    • bb.common.SalesOrderOnDemandResult (implements java.io.Serializable)
      • bb.common.SalesOrderOrphanedResult (implements java.io.Serializable)
    • bb.common.SalesOrderOnTimeItemResult (implements java.io.Serializable)
    • bb.common.SalesOrderOnTimeResult (implements java.io.Serializable)
    • bb.common.SalesOrderShipDateListResult (implements java.io.Serializable)
    • bb.common.SalesPartListItemResult (implements java.io.Serializable)
    • bb.common.SalesPartListResult (implements java.io.Serializable)
    • bb.common.SalesTaxListResult (implements java.io.Serializable)
    • bb.common.ScrapAssetAgent (implements java.io.Serializable)
    • bb.common.SerialNumberItemPK (implements java.io.Serializable)
    • bb.common.SerialNumberItemResult (implements java.io.Serializable)
    • bb.common.SerialNumberPK (implements java.io.Serializable)
    • bb.common.SerialNumberResult (implements java.io.Serializable)
    • bb.common.ServerAction (implements java.io.Serializable)
    • bb.common.ServerClientPropertyPK (implements java.io.Serializable)
    • bb.common.SGBillItemPK (implements java.io.Serializable)
    • bb.common.SGBOMItemResult (implements java.io.Serializable)
    • bb.common.SGBOMResult (implements java.io.Serializable)
    • bb.common.SGCartCheckOutResult (implements java.io.Serializable)
    • bb.common.SGCartLogin (implements java.io.Serializable)
    • bb.common.SGClientAccountPK (implements java.io.Serializable)
    • bb.common.SGClientLogin (implements java.io.Serializable)
    • bb.common.SGCompanyPK (implements java.io.Serializable)
    • bb.common.SGCustomerCatalogPK (implements java.io.Serializable)
    • bb.common.SGCustRequestForQuoteItemPK (implements java.io.Serializable)
    • bb.common.SGCustRequestForQuoteItemResult (implements java.io.Serializable)
    • bb.common.SGCustRequestForQuoteListResult (implements java.io.Serializable)
    • bb.common.SGCustRequestForQuoteResult (implements java.io.Serializable)
    • bb.common.SGDocPartPK (implements java.io.Serializable)
    • bb.common.SGDwgPicturePK (implements java.io.Serializable)
    • bb.common.SGPartCartAgent (implements java.io.Serializable)
    • bb.common.SGPartCatalogResult (implements java.io.Serializable)
    • bb.common.SGPartDocFlagResult (implements java.io.Serializable)
    • bb.common.SGPartListItemResult (implements java.io.Serializable)
    • bb.common.SGPartListResult (implements java.io.Serializable)
    • bb.common.SGPicturePK (implements java.io.Serializable)
    • bb.common.SGQuoteAddressResult (implements java.io.Serializable)
    • bb.common.SGQuoteCartListResult (implements java.io.Serializable)
    • bb.common.SGSaleItemAgent (implements java.io.Serializable)
    • bb.common.ShareHoldersEquityResult (implements java.io.Serializable)
    • bb.common.ShipListAgent (implements java.io.Serializable)
    • bb.common.ShipListItemPK (implements java.io.Serializable)
    • bb.common.ShipListItemRelatedDocResult (implements java.io.Serializable)
    • bb.common.ShipListOwnerAttributePK (implements java.io.Serializable)
    • bb.common.ShipperAgent (implements java.io.Serializable)
    • bb.common.ShipperItemAgent (implements java.io.Serializable)
    • bb.common.ShipperItemDetailAgent (implements java.io.Serializable)
    • bb.common.ShipperItemListResult (implements java.io.Serializable)
    • bb.common.ShipperItemManufacturerPK (implements java.io.Serializable)
    • bb.common.ShipperItemPK (implements java.io.Serializable)
    • bb.common.ShipperListResult (implements java.io.Serializable)
    • bb.common.ShippingItemResult (implements java.io.Serializable)
    • bb.common.ShippingResult (implements java.io.Serializable)
    • bb.common.ShoppingCartItem (implements java.io.Serializable)
    • bb.common.SO2POAgent (implements java.io.Serializable)
    • bb.common.SO2SOAgent (implements java.io.Serializable)
    • bb.common.SO2WOAgent (implements java.io.Serializable)
    • bb.common.SoPickListResult (implements java.io.Serializable)
    • bb.common.SOShipperItemListResult (implements java.io.Serializable)
    • bb.common.Spiderman
    • bb.common.StaffWorkingInformationResult (implements java.io.Serializable)
    • bb.common.StockTransactionAdjustmentResult (implements java.io.Serializable)
    • bb.common.StockTransactionPartInfoResult (implements java.io.Serializable)
    • bb.common.StockTransactionPOReceiverResult (implements java.io.Serializable)
    • bb.common.StockTransactionSOShipperResult (implements java.io.Serializable)
    • bb.common.StockTransactionWOReceiverResult (implements java.io.Serializable)
    • bb.common.StockTransactionWOShipperResult (implements java.io.Serializable)
    • bb.common.StringListConvertor
    • bb.common.SubcompanyLoginAgent (implements java.io.Serializable)
    • bb.common.SwapOrderItemListResult (implements java.io.Serializable)
    • bb.common.SwapOrderItemPK (implements java.io.Serializable)
    • bb.common.SwapReceiverItemListResult (implements java.io.Serializable)
    • bb.common.SwapReceiverItemPK (implements java.io.Serializable)
    • bb.common.SwapReceiverListResult (implements java.io.Serializable)
    • bb.common.SwapShipperItemListResult (implements java.io.Serializable)
    • bb.common.SwapShipperItemPK (implements java.lang.Comparable<T>, java.io.Serializable)
    • bb.common.SwapShipperListResult (implements java.io.Serializable)
    • bb.common.SwapShipperOnOrderResult (implements java.io.Serializable)
    • bb.common.TakeCycleCountAgent (implements java.io.Serializable)
    • bb.common.TaskFileResult (implements java.io.Serializable)
    • bb.common.TermAgent (implements java.io.Serializable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • bb.common.BB2ServerException
          • bb.common.AppException
          • bb.common.BB2DocumentException
          • bb.common.BB2MessagingException
          • bb.common.BizException
          • bb.common.DBAccessException
          • bb.common.InvokeException
          • bb.common.LoginException
        • bb.common.PermissionException
        • bb.common.ServerException
    • bb.common.ToolListDetailCostResult (implements java.io.Serializable)
    • bb.common.ToolOnhandWithAverageCostResult (implements java.io.Serializable)
    • bb.common.ToolWhereUsedItemResult (implements java.io.Serializable)
    • bb.common.ToolWhereUsedResult (implements java.io.Serializable)
    • bb.common.TotalByDateResult (implements java.io.Serializable)
    • bb.common.TransferOrderItemListResult (implements java.io.Serializable)
    • bb.common.TransferOrderItemPK (implements java.io.Serializable)
    • bb.common.TransferOrderListResult (implements java.io.Serializable)
    • bb.common.TransferReceiverItemListResult (implements java.io.Serializable)
    • bb.common.TransferReceiverItemPK (implements java.io.Serializable)
    • bb.common.TransferReceiverListResult (implements java.io.Serializable)
    • bb.common.TransferShipperItemListResult (implements java.io.Serializable)
    • bb.common.TransferShipperItemPK (implements java.io.Serializable)
    • bb.common.TransferShipperListResult (implements java.io.Serializable)
    • bb.common.TwelveMonthCashFlowReportResult (implements java.io.Serializable)
    • bb.common.UpdatePhysicalInventoryAgent (implements java.io.Serializable)
    • bb.common.User2UserAgent (implements java.io.Serializable)
    • bb.common.UserRolePK (implements java.io.Serializable)
    • bb.common.VendorContractPriceItemPK (implements java.io.Serializable)
    • bb.common.VendorContractPriceVendorPK (implements java.io.Serializable)
    • bb.common.VendorPartPK (implements java.lang.Comparable<T>, java.io.Serializable)
    • bb.common.VendorPrepayStatementListResult (implements java.io.Serializable)
    • bb.common.VendorPriceAgent
    • bb.common.VendorQtyPricePK (implements java.io.Serializable)
    • bb.common.VendorStatementListResult (implements java.io.Serializable)
    • bb.common.VendorTotalAmountInPO (implements java.io.Serializable)
      • bb.common.TotalAmountInPOByRefDoc (implements java.io.Serializable)
    • bb.common.VersionInformation
    • bb.common.VO (implements java.io.Serializable)
      • bb.common.AccountCreditVO (implements bb.common.Alarmable, java.io.Serializable)
      • bb.common.AccountDebitVO (implements bb.common.Alarmable, java.io.Serializable)
      • bb.common.AccountingConfigurationVO (implements java.io.Serializable)
      • bb.common.AccountingInfoDocumentVO (implements java.io.Serializable)
      • bb.common.AccountingSettingsVO (implements java.io.Serializable)
      • bb.common.AccountingTransactionTypeVO (implements java.io.Serializable)
      • bb.common.AccountPayableCheckRunItemVO (implements java.io.Serializable)
      • bb.common.AccountPayableCheckRunVO (implements java.io.Serializable)
      • bb.common.AccountPayableCheckVO (implements java.io.Serializable)
      • bb.common.AccountReceivablePaymentVO (implements java.io.Serializable)
      • bb.common.AccountsChartAdvanceCategoryVO (implements java.io.Serializable)
      • bb.common.AccountsChartCategoryVO (implements java.io.Serializable)
        • bb.common.AccountsChartCategoryListResult (implements java.io.Serializable)
      • bb.common.AccountsChartMappingVO (implements java.io.Serializable)
      • bb.common.AccountsChartVO (implements java.io.Serializable)
      • bb.common.AccountsPayableInfoVO (implements java.io.Serializable)
      • bb.common.AccountsPayableItemManufacturerVO (implements java.io.Serializable)
      • bb.common.AccountsPayableItemVO (implements java.io.Serializable)
      • bb.common.AccountsPayableVO (implements java.io.Serializable)
      • bb.common.AccountsReceivableInfoVO (implements java.io.Serializable)
      • bb.common.AccountsReceivableItemManufacturerVO (implements java.io.Serializable)
      • bb.common.AccountsReceivableItemVO (implements java.io.Serializable)
        • bb.common.AccountsReceivableItemResult
      • bb.common.AccountsReceivableVO (implements java.io.Serializable)
      • bb.common.AddressQualityDocumentsVO (implements java.io.Serializable)
      • bb.common.AllPartDocumentsVO (implements java.io.Serializable)
      • bb.common.AppColumnVO (implements java.io.Serializable)
      • bb.common.ApPrepayItemVO (implements java.io.Serializable)
      • bb.common.ApPrepayVO (implements java.io.Serializable)
      • bb.common.ARBoilerplateVO (implements java.io.Serializable)
      • bb.common.ARPaymentRunItemVO (implements java.io.Serializable)
      • bb.common.ARPaymentRunVO (implements java.io.Serializable)
      • bb.common.ArPrepayItemVO (implements java.io.Serializable)
      • bb.common.ArPrepayVO (implements java.io.Serializable)
      • bb.common.AssetAmortizationExpenseAccountVO (implements java.lang.Comparable<T>, java.io.Serializable)
      • bb.common.AssetDepreciateDetailReport (implements java.io.Serializable)
      • bb.common.AssetDepreciateVO (implements java.io.Serializable)
      • bb.common.AssetReportSumResult (implements java.io.Serializable)
      • bb.common.AssetTypeVO (implements java.io.Serializable)
      • bb.common.AssetUsageVO (implements java.io.Serializable)
      • bb.common.AssetVO (implements java.io.Serializable)
      • bb.common.AuditLogVO
      • bb.common.AuditPartInQAResult (implements java.io.Serializable)
      • bb.common.BankReconciliationReportVO
      • bb.common.BillItemReplacementVO (implements java.io.Serializable)
      • bb.common.BillItemVO (implements java.io.Serializable)
      • bb.common.BillLogVO (implements java.io.Serializable)
      • bb.common.BillVO (implements java.io.Serializable)
      • bb.common.BizboxBugChangesInfoVO (implements java.io.Serializable)
      • bb.common.BizboxBugChangesVO (implements java.io.Serializable)
      • bb.common.BizboxBugInfoVO (implements java.io.Serializable)
      • bb.common.BizboxBugVO (implements java.io.Serializable)
      • bb.common.BizboxUserListResult (implements java.io.Serializable)
      • bb.common.BizboxUserVO (implements java.io.Serializable)
      • bb.common.BomApprovalVO (implements java.io.Serializable)
      • bb.common.BuyerCodeVO (implements java.io.Serializable)
      • bb.common.CarrierVO (implements java.io.Serializable)
      • bb.common.CashierVO (implements java.io.Serializable)
      • bb.common.CatalogVO (implements java.io.Serializable)
      • bb.common.CertificateDescriptionVO (implements java.io.Serializable)
      • bb.common.ChangeStdCostWorkSheetItemVO (implements java.io.Serializable)
      • bb.common.ChangeStdCostWorkSheetVO (implements java.io.Serializable)
      • bb.common.CommonPrintTemplateVO
      • bb.common.CompanyUnitAccountVO (implements java.io.Serializable)
      • bb.common.CompanyUnitVO (implements java.io.Serializable)
      • bb.common.CompanyVO (implements java.io.Serializable)
      • bb.common.ContractPriceCustomerVO (implements java.io.Serializable)
      • bb.common.ContractPriceItemVO (implements java.io.Serializable)
      • bb.common.ContractPriceVO (implements java.io.Serializable)
      • bb.common.CorrectiveActionRequestVO (implements java.io.Serializable)
      • bb.common.CurrencyAgent (implements java.io.Serializable)
      • bb.common.CurrencyExchangeVO (implements java.io.Serializable)
      • bb.common.CurrencyVO (implements java.io.Serializable)
      • bb.common.CustomAssetRecordVO (implements java.io.Serializable)
      • bb.common.CustomAssetVO (implements java.io.Serializable)
      • bb.common.CustomCheckUpEmployeeVO (implements java.io.Serializable)
      • bb.common.CustomDepartmentVO (implements java.io.Serializable)
      • bb.common.CustomEmployeeTrainVO (implements java.io.Serializable)
      • bb.common.CustomEmployeeVO (implements java.io.Serializable)
      • bb.common.CustomEmployeeWorkExperienceVO (implements java.io.Serializable)
      • bb.common.CustomerFeedbackVO (implements java.io.Serializable)
      • bb.common.CustomerReturnToVendorItemVO (implements java.io.Serializable)
      • bb.common.CustomerReturnToVendorVO (implements java.io.Serializable)
      • bb.common.CustomerServiceIncidentItemVO (implements java.io.Serializable)
      • bb.common.CustomerServiceIncidentVO (implements java.io.Serializable)
      • bb.common.CustomerVendorAddressInfoVO (implements java.io.Serializable)
      • bb.common.CustomerVendorAddressVO (implements java.io.Serializable)
      • bb.common.CustomerVendorContactVO (implements java.io.Serializable)
      • bb.common.CustomerVendorDescriptionVO (implements java.io.Serializable)
      • bb.common.CustomerVendorTypeVO (implements java.io.Serializable)
      • bb.common.CustomGoodsBreedVO (implements java.io.Serializable)
      • bb.common.CustomGoodsRecordVO (implements java.io.Serializable)
      • bb.common.CustomJobCategoryGoodsVO (implements java.io.Serializable)
      • bb.common.CustomJobCategoryVO (implements java.io.Serializable)
      • bb.common.CustomSearchVO (implements java.io.Serializable)
      • bb.common.CustomTranslationVO (implements java.io.Serializable)
      • bb.common.CycleCountStatusVO (implements java.io.Serializable)
      • bb.common.CycleCountVO (implements java.io.Serializable)
      • bb.common.DataFilterVO
      • bb.common.DepartmentLocationForBackflushVO (implements java.io.Serializable)
      • bb.common.DesignControlDocumentVO (implements java.io.Serializable)
      • bb.common.DesignControlInfoVO (implements java.io.Serializable)
      • bb.common.DesignControlVO (implements java.io.Serializable)
      • bb.common.DisassembleWorkOrderApprovalVO (implements java.io.Serializable)
      • bb.common.DisassembleWorkOrderDocumentVO (implements java.io.Serializable)
      • bb.common.DisassembleWorkOrderIssueVO (implements java.io.Serializable)
      • bb.common.DisassembleWorkOrderItemReceiverVO (implements java.io.Serializable)
      • bb.common.DisassembleWorkOrderItemVO (implements java.io.Serializable)
      • bb.common.DisassembleWorkOrderVO (implements java.io.Serializable)
      • bb.common.DocumentLogVO (implements java.io.Serializable)
      • bb.common.DocumentServerVO (implements java.io.Serializable)
      • bb.common.DwfUploadSettingsVO (implements java.io.Serializable)
      • bb.common.DwgUploadSettingsVO (implements java.io.Serializable)
      • bb.common.ECNReviewVO (implements java.io.Serializable)
      • bb.common.ECRReviewVO (implements java.io.Serializable)
      • bb.common.EjbMethodVO (implements java.io.Serializable)
      • bb.common.EmployeeCardVO (implements java.io.Serializable)
      • bb.common.EmployeeEducationVO (implements java.io.Serializable)
        • bb.common.EmployeeEducationResult
      • bb.common.EmployeeHomeVO (implements java.io.Serializable)
      • bb.common.EmployeeJobDescriptionVO (implements java.io.Serializable)
      • bb.common.EmployeeRecordsVO (implements java.io.Serializable)
      • bb.common.EmployeeTrainingVO (implements java.io.Serializable)
      • bb.common.EmployeeWorkExperienceVO (implements java.io.Serializable)
      • bb.common.EngGroupUserVO (implements java.io.Serializable)
      • bb.common.EngGroupVO (implements java.io.Serializable)
      • bb.common.EngineeringChangeDocumentVO (implements java.io.Serializable)
      • bb.common.EngineeringChangeRequestDocumentVO (implements java.io.Serializable)
      • bb.common.EngineeringChangeRequestVO (implements java.io.Serializable)
      • bb.common.EngineeringChangeVO (implements java.io.Serializable)
      • bb.common.EngineeringSharingImportLogVO
      • bb.common.EngineeringSharingItemVO (implements java.io.Serializable)
      • bb.common.EngineeringSharingVO (implements java.io.Serializable)
      • bb.common.EquipmentVO (implements java.io.Serializable)
      • bb.common.ExpenseAccountVO (implements java.io.Serializable)
      • bb.common.ExpenseItemVO (implements java.io.Serializable)
      • bb.common.ExpenseVO (implements java.io.Serializable)
      • bb.common.FeedbackAnswerVO (implements java.io.Serializable)
      • bb.common.FeedbackItemVO (implements java.io.Serializable)
      • bb.common.FeedbackQuestionVO (implements java.io.Serializable)
      • bb.common.FiscalYearSettingsVO (implements java.io.Serializable)
      • bb.common.GeneralLedgerApprovalVO (implements java.io.Serializable)
      • bb.common.GeneralLedgerCategoryVO (implements java.io.Serializable)
      • bb.common.GeneralLedgerSettingsVO (implements java.io.Serializable)
      • bb.common.GeneralLedgerVO (implements java.io.Serializable)
      • bb.common.GLAutoApproveVO (implements java.io.Serializable)
      • bb.common.GlCashFlowBudgetVO (implements java.io.Serializable)
      • bb.common.GlFiscalYearBudgetVO (implements java.io.Serializable)
      • bb.common.GLItemVO
      • bb.common.GlMonthBudgetVO (implements java.io.Serializable)
      • bb.common.GlMonthVO (implements java.io.Serializable)
      • bb.common.GroupUserVO (implements java.io.Serializable)
      • bb.common.HelpServerVO (implements java.io.Serializable)
      • bb.common.HistoricalInventoryVO (implements java.io.Serializable)
      • bb.common.IcrItemListResult (implements java.io.Serializable)
      • bb.common.ImportContractPriceData (implements java.io.Serializable)
      • bb.common.ImportDataVO (implements java.io.Serializable)
      • bb.common.IncotermVO (implements java.io.Serializable)
      • bb.common.InspectionConformanceReportItemCheckVO (implements java.io.Serializable)
      • bb.common.InspectionConformanceReportItemVO (implements java.io.Serializable)
      • bb.common.InspectionConformanceReportVO (implements java.io.Serializable)
      • bb.common.InspectionItemVO (implements java.io.Serializable)
      • bb.common.InspectionReportInfoVO (implements java.io.Serializable)
      • bb.common.InspectionReportInspectMethodItemVO (implements java.io.Serializable)
      • bb.common.InspectionReportInspectMethodVO (implements java.io.Serializable)
      • bb.common.InspectionReportInspectStandardItemVO (implements java.io.Serializable)
      • bb.common.InspectionReportItemQtyVO (implements java.io.Serializable)
      • bb.common.InspectionReportItemVO (implements java.io.Serializable)
      • bb.common.InspectionReportVO (implements java.io.Serializable)
      • bb.common.InspectionTypeItemVO (implements java.io.Serializable)
      • bb.common.InspectionTypeVO (implements java.io.Serializable)
      • bb.common.InventoryAdjustmentVO (implements java.io.Serializable)
        • bb.common.InventoryAdjustmentListResult (implements java.io.Serializable)
      • bb.common.InventoryPartInOutDetailListResult
      • bb.common.IpAddressVO (implements java.io.Serializable)
      • bb.common.LabelTemplateItemVO (implements java.lang.Comparable<T>, java.io.Serializable)
      • bb.common.LabelTemplateVO (implements java.io.Serializable)
      • bb.common.LogInventoryVO (implements java.io.Serializable)
      • bb.common.LogMethodVO (implements java.io.Serializable)
      • bb.common.LogMiscDocumentVO (implements java.io.Serializable)
      • bb.common.LogPartDocumentVO (implements java.io.Serializable)
      • bb.common.LogPartDwfVO (implements java.io.Serializable)
      • bb.common.LogPartDwgVO (implements java.io.Serializable)
      • bb.common.LogTaskVO (implements java.io.Serializable)
      • bb.common.LogTrackingVO (implements java.io.Serializable)
      • bb.common.MaintenanceItemVO (implements java.io.Serializable)
      • bb.common.ManufacturerAddressInfoVO (implements java.io.Serializable)
      • bb.common.ManufacturerAddressVO (implements java.io.Serializable)
      • bb.common.ManufacturerContactVO (implements java.io.Serializable)
      • bb.common.ManufacturerDescriptionVO (implements java.io.Serializable)
      • bb.common.MessageVO (implements java.io.Serializable)
      • bb.common.MiscDocumentSettingVO (implements java.io.Serializable)
      • bb.common.MultiLanguageAccountsChartVO (implements java.io.Serializable)
      • bb.common.MyPrintListVO (implements java.io.Serializable)
      • bb.common.NcrApprovalVO (implements java.io.Serializable)
      • bb.common.NCRPictureVO (implements java.io.Serializable)
      • bb.common.NonConformanceCodeDescriptionVO (implements java.io.Serializable)
      • bb.common.NonConformanceCodeVO (implements java.io.Serializable)
      • bb.common.NonConformanceQuantityVO (implements java.io.Serializable)
      • bb.common.NonConformanceReportVO (implements java.io.Serializable)
      • bb.common.NonproductivePickingApprovalVO (implements java.io.Serializable)
      • bb.common.NonproductivePickingApproveVO (implements java.io.Serializable)
      • bb.common.NonproductivePickingItemIssuedVO (implements java.io.Serializable)
      • bb.common.NonproductivePickingItemVO (implements java.io.Serializable)
      • bb.common.NonproductivePickingTypeVO (implements java.io.Serializable)
      • bb.common.NonproductivePickingVO (implements java.io.Serializable)
      • bb.common.OIPrincipalVO (implements java.io.Serializable)
      • bb.common.OnloanDocumentVO (implements java.io.Serializable)
      • bb.common.OnLoanItemVO (implements java.io.Serializable)
      • bb.common.OnloanReceiverItemVO (implements java.io.Serializable)
      • bb.common.OnloanReceiverVO (implements java.io.Serializable)
      • bb.common.OnloanReviewVO (implements java.io.Serializable)
      • bb.common.OnloanShipperItemVO (implements java.io.Serializable)
      • bb.common.OnloanShipperVO (implements java.io.Serializable)
      • bb.common.OnLoanVO (implements java.io.Serializable)
      • bb.common.OpCodeShortcutVO (implements java.io.Serializable)
      • bb.common.OperatingInstructionsInspectMethodItemVO (implements java.io.Serializable)
      • bb.common.OperatingInstructionsInspectResultItemVO (implements java.io.Serializable)
      • bb.common.OperatingInstructionsInspectStandardItemVO (implements java.io.Serializable)
      • bb.common.OperatingInstructionsInspectStandardVO (implements java.io.Serializable)
      • bb.common.OperatingInstructionsManualItemVO (implements java.io.Serializable)
      • bb.common.OperatingInstructionsManualVO (implements java.io.Serializable)
      • bb.common.OperatingInstructionsTypeVO (implements java.io.Serializable)
      • bb.common.OperatingInstructionsVO (implements java.io.Serializable)
      • bb.common.OperatingOutputFileItemVO (implements java.io.Serializable)
      • bb.common.OperatingOutputFileTypeVO (implements java.io.Serializable)
      • bb.common.OperationLogVO (implements java.io.Serializable)
      • bb.common.OrderApprovalItemsVO (implements java.io.Serializable)
      • bb.common.OrderApprovalVO (implements java.io.Serializable)
      • bb.common.OrderBoilerplateVO (implements java.io.Serializable)
      • bb.common.OrderDocumentVO (implements java.io.Serializable)
      • bb.common.PackingBoxItemVO (implements java.io.Serializable)
      • bb.common.PackingBoxVO (implements java.io.Serializable)
      • bb.common.PartCatagoryVO (implements java.io.Serializable)
      • bb.common.PartCatalogVO (implements java.io.Serializable)
      • bb.common.PartCertificateVO (implements java.io.Serializable)
      • bb.common.PartClassVO (implements java.io.Serializable)
      • bb.common.PartDescriptionVO (implements java.io.Serializable)
      • bb.common.PartDiscountVO (implements java.io.Serializable)
      • bb.common.PartDocumentVO (implements java.io.Serializable)
      • bb.common.PartDwfVO (implements java.io.Serializable)
      • bb.common.PartDwgVO (implements java.io.Serializable)
      • bb.common.PartInQAResult (implements java.io.Serializable)
      • bb.common.PartInQAVO (implements java.io.Serializable)
      • bb.common.PartInspectionVO (implements java.io.Serializable)
      • bb.common.PartInventoryVO (implements java.io.Serializable)
      • bb.common.PartIssuedVO (implements java.io.Serializable)
        • bb.common.PartIssuedListResult (implements java.io.Serializable)
      • bb.common.PartManufacturerVO (implements java.io.Serializable)
      • bb.common.PartMaterialVO (implements java.io.Serializable)
      • bb.common.PartMRPVO (implements java.io.Serializable)
      • bb.common.PartNumberGenerateRuleVO (implements java.io.Serializable)
      • bb.common.PartOnhandCostVO (implements java.io.Serializable)
      • bb.common.PartOnhandVO (implements java.io.Serializable)
      • bb.common.PartPictureVO (implements java.io.Serializable)
      • bb.common.PartReceivedVO (implements java.io.Serializable)
        • bb.common.PartReceivedListResult (implements java.io.Serializable)
      • bb.common.PartSecurityLevelVO (implements java.io.Serializable)
      • bb.common.PartTraceableCategoryVO (implements java.io.Serializable)
      • bb.common.PartTraceableSpecVO (implements java.io.Serializable)
      • bb.common.PartTrackingVO (implements java.io.Serializable)
      • bb.common.PartTypeVO (implements java.io.Serializable)
      • bb.common.PartUnitVO (implements java.io.Serializable)
      • bb.common.PartUseTypeVO (implements java.io.Serializable)
      • bb.common.PartVendorVO (implements java.io.Serializable)
      • bb.common.PartVO (implements java.io.Serializable)
      • bb.common.PartWithOnhandsVO (implements java.io.Serializable)
      • bb.common.PayableMethodVO (implements java.io.Serializable)
      • bb.common.PaymentHistoryVO (implements java.io.Serializable)
      • bb.common.PaymentVO (implements java.io.Serializable)
      • bb.common.PermissionDescriptionVO (implements java.io.Serializable)
      • bb.common.PermissionMethodVO (implements java.io.Serializable)
      • bb.common.PermissionVO (implements java.io.Serializable)
      • bb.common.PfReceiverItemVO (implements java.io.Serializable)
      • bb.common.PfReceiverVO (implements java.io.Serializable)
      • bb.common.PhysicalInventoryStatusVO (implements java.io.Serializable)
      • bb.common.PhysicalInventoryVO (implements java.io.Serializable)
      • bb.common.PointOfSaleVO (implements java.io.Serializable)
      • bb.common.PoMessageItemVO (implements java.io.Serializable)
      • bb.common.PoMessageVO (implements java.io.Serializable)
      • bb.common.PosRefdocVO (implements java.io.Serializable)
      • bb.common.POSurveyReportItemVO (implements java.io.Serializable)
      • bb.common.POSurveyReportVO (implements java.io.Serializable)
      • bb.common.PosZipCodeTaxVO (implements java.io.Serializable)
      • bb.common.PreventiveActionRequestItemVO (implements java.io.Serializable)
      • bb.common.PreventiveActionRequestVO (implements java.io.Serializable)
      • bb.common.PrintLogoVO (implements java.io.Serializable)
      • bb.common.PrintTemplateVO (implements java.io.Serializable)
      • bb.common.ProformaInvoiceItemManufacturerVO (implements java.io.Serializable)
      • bb.common.ProformaInvoiceItemVO (implements java.io.Serializable)
      • bb.common.ProformaInvoiceVO (implements java.io.Serializable)
      • bb.common.ProjectVO (implements java.io.Serializable)
      • bb.common.PrPackingBoxItemVO (implements java.lang.Comparable<T>, java.io.Serializable)
      • bb.common.PrPackingBoxVO (implements java.io.Serializable)
      • bb.common.PurchaseOrderApprovalVO (implements java.io.Serializable)
      • bb.common.PurchaseOrderBoilerplateVO (implements java.io.Serializable)
      • bb.common.PurchaseOrderDocumentVO (implements java.io.Serializable)
      • bb.common.PurchaseOrderItemManufacturerVO (implements java.io.Serializable)
      • bb.common.PurchaseOrderItemVO (implements java.io.Serializable)
      • bb.common.PurchaseOrderVO (implements java.io.Serializable)
      • bb.common.PurchaseWorkSheetItemVO (implements java.io.Serializable)
      • bb.common.PurchaseWorkSheetVO (implements java.io.Serializable)
      • bb.common.QualityGroupVO (implements java.io.Serializable)
      • bb.common.QuoteBoilerplateVO (implements java.io.Serializable)
      • bb.common.QuoteDocumentVO (implements java.io.Serializable)
      • bb.common.QuoteItemManufacturerVO (implements java.io.Serializable)
      • bb.common.QuoteItemVO (implements java.io.Serializable)
      • bb.common.QuoteVO (implements java.io.Serializable)
      • bb.common.ReceiverInfoVO (implements java.io.Serializable)
      • bb.common.ReceiverItemManufacturerVO (implements java.io.Serializable)
      • bb.common.ReceiverItemVO (implements java.io.Serializable)
      • bb.common.ReceiverVO (implements java.io.Serializable)
      • bb.common.RefdocVO (implements java.io.Serializable)
      • bb.common.RequestForQuoteItemManufacturerVO (implements java.io.Serializable)
      • bb.common.RequestForQuoteItemVO (implements java.io.Serializable)
      • bb.common.RequestForQuoteVO (implements java.io.Serializable)
      • bb.common.RequestForRMAItemVO (implements java.io.Serializable)
      • bb.common.RequestForRMAVO (implements java.io.Serializable)
      • bb.common.ReturnMaterialAuthorizationDocumentVO (implements java.io.Serializable)
      • bb.common.ReturnMaterialAuthorizationItemManufacturerVO (implements java.io.Serializable)
      • bb.common.ReturnMaterialAuthorizationItemVO (implements java.io.Serializable)
      • bb.common.ReturnMaterialAuthorizationVO (implements java.io.Serializable)
      • bb.common.ReturnToVendorItemManufacturerVO (implements java.io.Serializable)
      • bb.common.ReturnToVendorItemVO (implements java.io.Serializable)
      • bb.common.ReturnToVendorVO (implements java.io.Serializable)
      • bb.common.RfqMessageItemVO (implements java.io.Serializable)
      • bb.common.RfqMessageVO (implements java.io.Serializable)
      • bb.common.RMAReceiverItemVO (implements java.io.Serializable)
      • bb.common.RMAReceiverVO (implements java.io.Serializable)
      • bb.common.RMAReviewVO (implements java.io.Serializable)
      • bb.common.RoleDescriptionVO (implements java.io.Serializable)
      • bb.common.RolePermissionVO (implements java.io.Serializable)
      • bb.common.RoleVO (implements java.io.Serializable)
      • bb.common.RollUpBomStdCostWorkSheetItemVO (implements java.io.Serializable)
      • bb.common.RollUpBomStdCostWorkSheetVO (implements java.io.Serializable)
      • bb.common.RTVApprovalVO (implements java.io.Serializable)
      • bb.common.RtvShipperInfoVO (implements java.io.Serializable)
      • bb.common.RtvShipperItemVO (implements java.io.Serializable)
      • bb.common.RtvShipperVO (implements java.io.Serializable)
      • bb.common.RunningAccountOrderItemVO (implements java.io.Serializable)
        • bb.common.RunningAccountOrderItemResult (implements java.io.Serializable)
      • bb.common.RunningAccountOrderVO (implements java.io.Serializable)
      • bb.common.SalesCodeVO (implements java.io.Serializable)
        • bb.common.ArSalesCodeTotalListResult (implements java.io.Serializable)
      • bb.common.SalesmanVO (implements java.io.Serializable)
      • bb.common.SalesOrderBoilerplateVO (implements java.io.Serializable)
      • bb.common.SalesOrderDocumentVO (implements java.io.Serializable)
      • bb.common.SalesOrderItemInfoVO (implements java.io.Serializable)
      • bb.common.SalesOrderItemManufacturerVO (implements java.io.Serializable)
      • bb.common.SalesOrderItemVO (implements java.io.Serializable)
      • bb.common.SalesOrderReviewVO (implements java.io.Serializable)
      • bb.common.SalesOrderVO (implements java.io.Serializable)
      • bb.common.ScrapReportVO (implements java.io.Serializable)
      • bb.common.SerialNumberItemVO (implements java.io.Serializable)
      • bb.common.SerialNumberVO (implements java.io.Serializable)
      • bb.common.ServerClientPropertyVO (implements java.io.Serializable)
      • bb.common.SGBillItemVO (implements java.io.Serializable)
      • bb.common.SGClientAccountVO (implements java.io.Serializable)
      • bb.common.SgClientProgramUserVO (implements java.io.Serializable)
      • bb.common.SGCompanyVO (implements java.io.Serializable)
      • bb.common.SGCustomerCatalogVO (implements java.io.Serializable)
      • bb.common.SGCustomerServiceRequestVO (implements java.io.Serializable)
      • bb.common.SGCustRequestForQuoteItemVO (implements java.io.Serializable)
      • bb.common.SGCustRequestForQuoteVO (implements java.io.Serializable)
      • bb.common.SGDocPartVO (implements java.io.Serializable)
      • bb.common.SGDwgPictureVO (implements java.io.Serializable)
      • bb.common.SGLogLoginVO (implements java.io.Serializable)
      • bb.common.SGPictureVO (implements java.io.Serializable)
      • bb.common.SGQuoteAddressVO (implements java.io.Serializable)
      • bb.common.SGQuoteCartVO (implements java.io.Serializable)
      • bb.common.SGQuoteLoginVO (implements java.io.Serializable)
      • bb.common.SGSaleItemVO (implements java.io.Serializable)
      • bb.common.SGWeightUnitVO (implements java.io.Serializable)
      • bb.common.ShipListInfoVO (implements java.io.Serializable)
      • bb.common.ShipListItemVO (implements java.io.Serializable)
        • bb.common.ShipListItemVOResult
      • bb.common.ShipListOwnerAttributeVO (implements java.io.Serializable)
      • bb.common.ShipListOwnerVO (implements java.io.Serializable)
      • bb.common.ShipListVO (implements java.io.Serializable)
      • bb.common.ShipperInfoVO (implements java.io.Serializable)
      • bb.common.ShipperItemManufacturerVO (implements java.io.Serializable)
      • bb.common.ShipperItemVO (implements java.io.Serializable)
      • bb.common.ShipperVO (implements java.io.Serializable)
      • bb.common.SmtpServerVO (implements java.io.Serializable)
      • bb.common.SubcompanyVO (implements java.io.Serializable)
      • bb.common.SwapOrderApprovalVO (implements java.io.Serializable)
      • bb.common.SwapOrderItemVO (implements java.io.Serializable)
      • bb.common.SwapOrderVO (implements java.io.Serializable)
        • bb.common.SwapOrderListResult
      • bb.common.SwapReceiverItemVO (implements java.io.Serializable)
      • bb.common.SwapReceiverVO (implements java.io.Serializable)
      • bb.common.SwapShipperItemVO (implements java.io.Serializable)
      • bb.common.SwapShipperVO (implements java.io.Serializable)
      • bb.common.TaskVO (implements java.io.Serializable)
      • bb.common.TaxAccountVO (implements java.io.Serializable)
      • bb.common.TempArApAgingVO (implements java.io.Serializable)
      • bb.common.TempReceiverWithoutAPInfo (implements java.io.Serializable)
      • bb.common.TermsConditionVO (implements java.io.Serializable)
      • bb.common.TermVO (implements java.io.Serializable)
      • bb.common.ToolCalibrationVO (implements java.io.Serializable)
        • bb.common.ToolCalibrateListResult (implements java.io.Serializable)
      • bb.common.ToolDescriptionVO (implements java.io.Serializable)
      • bb.common.ToolInventoryVO (implements java.io.Serializable)
      • bb.common.ToolListInfoVO (implements java.io.Serializable)
      • bb.common.ToolListItemVO (implements java.io.Serializable)
      • bb.common.ToolListVO (implements java.io.Serializable)
      • bb.common.ToolManufacturerVO (implements java.io.Serializable)
      • bb.common.ToolOnhandVO (implements java.io.Serializable)
      • bb.common.ToolVendorVO (implements java.io.Serializable)
      • bb.common.ToolVO (implements java.io.Serializable)
      • bb.common.ToolWithOnhandsVO (implements java.io.Serializable)
      • bb.common.TraceableCategoriesVO (implements java.io.Serializable)
      • bb.common.TraceableSpecsVO (implements java.io.Serializable)
      • bb.common.TransferOrderApprovalVO (implements java.io.Serializable)
      • bb.common.TransferOrderItemVO (implements java.io.Serializable)
      • bb.common.TransferOrderVO (implements java.io.Serializable)
      • bb.common.TransferReceiverItemVO (implements java.io.Serializable)
      • bb.common.TransferReceiverVO (implements java.io.Serializable)
      • bb.common.TransferShipperItemVO (implements java.io.Serializable)
      • bb.common.TransferShipperVO (implements java.io.Serializable)
      • bb.common.UnitVO (implements java.io.Serializable)
      • bb.common.UserGroupVO (implements java.io.Serializable)
      • bb.common.UserRolePermissionListResult (implements java.io.Serializable)
      • bb.common.UserRoleVO (implements java.io.Serializable)
      • bb.common.VendorCategoriesVO (implements java.io.Serializable)
      • bb.common.VendorContractPriceItemVO (implements java.io.Serializable)
      • bb.common.VendorContractPriceVendorVO (implements java.io.Serializable)
      • bb.common.VendorContractPriceVO (implements java.io.Serializable)
      • bb.common.VendorCriticalLevelVO (implements java.io.Serializable)
      • bb.common.VendorGroupUserVO (implements java.io.Serializable)
      • bb.common.VendorPartVO (implements java.lang.Comparable<T>, java.io.Serializable)
      • bb.common.VendorQtyPriceVO (implements java.io.Serializable)
      • bb.common.WareHousePartPrefixKeeperVO (implements java.io.Serializable)
      • bb.common.WarehouseTransferVO (implements java.io.Serializable)
      • bb.common.WarehouseVO (implements java.io.Serializable)
      • bb.common.WeightUnitVO (implements java.io.Serializable)
      • bb.common.WorkCalendarVO (implements java.io.Serializable)
      • bb.common.WorkCenterGroupItemVO (implements java.io.Serializable)
      • bb.common.WorkCenterVendorVO (implements java.io.Serializable)
      • bb.common.WorkCenterVO (implements java.lang.Comparable<T>, java.io.Serializable)
      • bb.common.WorkFlowVO (implements java.io.Serializable)
      • bb.common.WorkInstructionApprovalVO (implements java.io.Serializable)
      • bb.common.WorkInstructionDocumentVO (implements java.io.Serializable)
      • bb.common.WorkInstructionPictureVO (implements java.io.Serializable)
      • bb.common.WorkInstructionRequestForChangeVO (implements java.io.Serializable)
      • bb.common.WorkInstructionSequenceVO (implements java.io.Serializable)
      • bb.common.WorkInstructionVO (implements java.io.Serializable)
      • bb.common.WorkOrderApprovalVO (implements java.io.Serializable)
      • bb.common.WorkOrderBoilerplateVO (implements java.io.Serializable)
      • bb.common.WorkOrderDocumentVO (implements java.io.Serializable)
      • bb.common.WorkOrderItemIssueVO (implements java.io.Serializable)
      • bb.common.WorkOrderItemPartDetailInWipVO (implements java.io.Serializable)
      • bb.common.WorkOrderItemTimeDetailVO (implements java.io.Serializable)
      • bb.common.WorkOrderItemVO (implements java.io.Serializable)
      • bb.common.WorkOrderReceiverVO (implements java.io.Serializable)
      • bb.common.WorkOrderTimeCardVO (implements java.io.Serializable)
      • bb.common.WorkOrderVO (implements java.io.Serializable)
      • bb.common.WorkOrderWorkInstructionSequenceVO (implements java.io.Serializable)
      • bb.common.WorkOrderWorkInstructionVO (implements java.io.Serializable)
      • bb.common.WorkOrderWorkSheetItemVO (implements java.io.Serializable)
      • bb.common.WorkOrderWorkSheetVO (implements java.io.Serializable)
      • bb.common.WorkPeriodVO (implements java.io.Serializable)
      • bb.common.ZipCodeTaxVO (implements java.io.Serializable)
      • bb.common.ZipCodeVO (implements java.io.Serializable)
    • bb.common.WarehouseTransferPK (implements java.io.Serializable)
    • bb.common.WareHousingInfoCenterResult (implements java.io.Serializable)
    • bb.common.WC2WCAgent (implements java.io.Serializable)
    • bb.common.WCLoadAgent (implements java.io.Serializable)
    • bb.common.WCLoadByDateResult (implements java.io.Serializable)
    • bb.common.WCLoadDetailResult (implements java.io.Serializable)
    • bb.common.WCLoadOnDateResult (implements java.io.Serializable)
    • bb.common.WireTransferAgent (implements java.io.Serializable)
    • bb.common.WO2WOAgent (implements java.io.Serializable)
    • bb.common.WOIssuedByMonthChartResult (implements java.io.Serializable)
    • bb.common.WOIssuedByMonthResult (implements java.io.Serializable)
    • bb.common.WOItemCostControlAgent (implements java.io.Serializable)
    • bb.common.WOItemPartDetailNotIssue (implements java.io.Serializable)
    • bb.common.WoItemPickListItemResult (implements java.io.Serializable)
    • bb.common.WoItemPickListResult (implements java.io.Serializable)
    • bb.common.WoItemWorkInstructionListResult (implements java.io.Serializable)
    • bb.common.WOReceiverDetail (implements java.io.Serializable)
    • bb.common.WorkCenterAgent (implements java.io.Serializable)
      • bb.common.WorkCenterOnDateAgent
    • bb.common.WorkCenterGroupItemPK (implements java.io.Serializable)
    • bb.common.WorkCenterLoadAgent (implements java.io.Serializable)
    • bb.common.WorkCenterLoadListResult (implements java.io.Serializable)
    • bb.common.WorkCenterRunTimeAgent (implements java.io.Serializable)
    • bb.common.WorkCenterRunTimeListResult (implements java.io.Serializable)
    • bb.common.WorkCenterRunTimeTotalResult (implements java.io.Serializable)
    • bb.common.WorkCenterVendorPK (implements java.io.Serializable)
    • bb.common.WorkInstructionListResult (implements java.io.Serializable)
    • bb.common.WorkInstructionPK (implements java.io.Serializable)
    • bb.common.WorkInstructionSeqAuditListResult (implements java.io.Serializable)
    • bb.common.WorkInstructionSequenceListResult (implements java.io.Serializable)
    • bb.common.WorkInstructionSequencePK (implements java.io.Serializable)
    • bb.common.WorkInstructionSummaryItemResult (implements java.io.Serializable)
    • bb.common.WorkInstructionSummaryResult (implements java.io.Serializable)
    • bb.common.WorkOrderCheckListResult (implements java.io.Serializable)
    • bb.common.WorkOrderInfoCenterResult (implements java.io.Serializable)
    • bb.common.WorkOrderInWipResult (implements java.io.Serializable)
    • bb.common.WorkOrderIssuedOrderListResult (implements java.io.Serializable)
    • bb.common.WorkOrderIssueStatisticsResult (implements java.io.Serializable)
    • bb.common.WorkOrderItemAgent (implements java.io.Serializable)
    • bb.common.WorkOrderItemCanAssyAgent (implements java.io.Serializable)
    • bb.common.WorkOrderItemCanAssyResult (implements java.io.Serializable)
    • bb.common.WorkOrderItemInfoResult (implements java.io.Serializable)
    • bb.common.WorkOrderItemInWipListResult (implements java.io.Serializable)
    • bb.common.WorkOrderItemIssuedTotalResult (implements java.io.Serializable)
    • bb.common.WorkOrderItemIssuePK (implements java.io.Serializable)
    • bb.common.WorkOrderItemLaborCostListResult (implements java.io.Serializable)
    • bb.common.WorkOrderItemListResult (implements java.io.Serializable)
    • bb.common.WorkOrderItemPartDetail (implements java.io.Serializable)
    • bb.common.WorkOrderItemPartDetailItemResult (implements java.io.Serializable)
    • bb.common.WorkOrderItemPartDetailResult (implements java.io.Serializable)
    • bb.common.WorkOrderItemPK (implements java.lang.Comparable<T>, java.io.Serializable)
    • bb.common.WorkOrderItemReviewCostResult (implements java.io.Serializable)
    • bb.common.WorkOrderItemSeqWCLoadResult (implements java.io.Serializable)
    • bb.common.WorkOrderItemSetupItemAgent (implements java.lang.Comparable<T>, java.io.Serializable)
    • bb.common.WorkOrderItemTimeDetailResult (implements java.io.Serializable)
    • bb.common.WorkOrderItemToIssueResult (implements java.io.Serializable)
    • bb.common.WorkOrderItemWCLoadResult (implements java.io.Serializable)
    • bb.common.WorkOrderListResult (implements java.io.Serializable)
    • bb.common.WorkOrderOnDemandResult (implements java.io.Serializable)
      • bb.common.WorkOrderNotSetupResult (implements java.io.Serializable)
    • bb.common.WorkOrderOnOrderResult (implements java.io.Serializable)
    • bb.common.WorkOrderOnTimeItemResult (implements java.io.Serializable)
    • bb.common.WorkOrderOnTimeResult (implements java.io.Serializable)
    • bb.common.WorkOrderOverIssueListResult (implements java.io.Serializable)
    • bb.common.WorkOrderQueryInfo (implements java.io.Serializable)
    • bb.common.WorkOrderWorkInstructionListResult (implements java.io.Serializable)
    • bb.common.WorkOrderWorkInstructionPK (implements java.io.Serializable)
    • bb.common.WorkOrderWorkInstructionSequenceDateAgent (implements java.io.Serializable)
    • bb.common.WorkOrderWorkInstructionSequencePK (implements java.io.Serializable)
    • bb.common.WorkOrderWorkItemDateAgent (implements java.io.Serializable)
    • bb.common.WorkOrderWorkSheetItemPK (implements java.io.Serializable)
    • bb.common.WorkOrderWorkSheetItemWithRelatedInfoResult (implements java.io.Serializable)
    • bb.common.WorkOrderWorkSheetPK (implements java.io.Serializable)
    • bb.common.WorkSheetPartAgent (implements java.io.Serializable)
    • bb.common.YearMonthManager
    • bb.common.ZipcodeTotalsResult (implements java.lang.Comparable<T>, java.io.Serializable)
    • bb.common.ZippedByteArray (implements java.io.Serializable)

Interface Hierarchy

  • bb.common.Alarmable
  • bb.common.Facade
Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 bb.common.box
Interfaces
AccountingBox
AddressBox
CompanyBox
CustomerServiceBox
DocumentBox
EngineeringBox
HumanResourceBox
LogBox
ManagementBox
ManufacturingBox
PlanningBox
PurchasingBox
QualityBox
SalesBox
SecurityBox
WarehouseBox
WorkOrderBox


bb.common.box

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package bb.common.box

Interface Summary
AccountingBox
AddressBox
CompanyBox
CustomerServiceBox
DocumentBox
EngineeringBox
HumanResourceBox
LogBox
ManagementBox
ManufacturingBox
PlanningBox
PurchasingBox
QualityBox
SalesBox
SecurityBox
WarehouseBox
WorkOrderBox

Overview Package Class Use Tree Deprecated Index Help
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


bb.common.box Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package bb.common.box

Package Hierarchies:
All Packages

Interface Hierarchy

  • bb.common.box.AccountingBox
  • bb.common.box.AddressBox
  • bb.common.box.CompanyBox
  • bb.common.box.CustomerServiceBox
  • bb.common.box.DocumentBox
  • bb.common.box.EngineeringBox
  • bb.common.box.HumanResourceBox
  • bb.common.box.LogBox
  • bb.common.box.ManagementBox
  • bb.common.box.ManufacturingBox
  • bb.common.box.PlanningBox
  • bb.common.box.PurchasingBox
  • bb.common.box.QualityBox
  • bb.common.box.SalesBox
  • bb.common.box.SecurityBox
  • bb.common.box.WarehouseBox
  • bb.common.box.WorkOrderBox
Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


BillDetailCostResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BillDetailCostResult

java.lang.Object
    extended by  bb.common.BillDetailCostResult
All Implemented Interfaces:
java.io.Serializable
public class BillDetailCostResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BillDetailCostResult()
Method Summary
java.math.BigDecimal | getAverageCost()
BillDetailCostWithPartInfoResult | getBillInfo()
java.util.Set | getBillItems()
java.math.BigDecimal | getListCost()
java.lang.Integer | getMissingItems()
java.math.BigDecimal | getStandardCost()
java.math.BigDecimal | getVendorAverageCost()
java.math.BigDecimal | getVendorHighestCost()
java.math.BigDecimal | getVendorLowestCost()
void | setAverageCost(java.math.BigDecimal averageCost)
void | setBillInfo(BillDetailCostWithPartInfoResult billInfo)
void | setBillItems(java.util.Set billItems)
void | setListCost(java.math.BigDecimal listCost)
void | setMissingItems(java.lang.Integer missingItems)
void | setStandardCost(java.math.BigDecimal standardCost)
void | setVendorAverageCost(java.math.BigDecimal vendorAverageCost)
void | setVendorHighestCost(java.math.BigDecimal vendorHighestCost)
void | setVendorLowestCost(java.math.BigDecimal vendorLowestCost)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BillDetailCostResult

public BillDetailCostResult()
Method Detail

getAverageCost

public java.math.BigDecimal getAverageCost()

getBillInfo

public BillDetailCostWithPartInfoResult getBillInfo()

getListCost

public java.math.BigDecimal getListCost()

getMissingItems

public java.lang.Integer getMissingItems()

getStandardCost

public java.math.BigDecimal getStandardCost()

getVendorAverageCost

public java.math.BigDecimal getVendorAverageCost()

getVendorHighestCost

public java.math.BigDecimal getVendorHighestCost()

getVendorLowestCost

public java.math.BigDecimal getVendorLowestCost()

getBillItems

public java.util.Set getBillItems()

setAverageCost

public void setAverageCost(java.math.BigDecimal averageCost)

setBillInfo

public void setBillInfo(BillDetailCostWithPartInfoResult billInfo)

setListCost

public void setListCost(java.math.BigDecimal listCost)

setMissingItems

public void setMissingItems(java.lang.Integer missingItems)

setStandardCost

public void setStandardCost(java.math.BigDecimal standardCost)

setVendorAverageCost

public void setVendorAverageCost(java.math.BigDecimal vendorAverageCost)

setVendorHighestCost

public void setVendorHighestCost(java.math.BigDecimal vendorHighestCost)

setVendorLowestCost

public void setVendorLowestCost(java.math.BigDecimal vendorLowestCost)

setBillItems

public void setBillItems(java.util.Set billItems)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BillDetailCostWithPartInfoResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BillDetailCostWithPartInfoResult

java.lang.Object
    extended by  bb.common.PartBasicInfo
        extended by  bb.common.BillWithPartInfoResult
            extended by  bb.common.BillDetailCostWithPartInfoResult
All Implemented Interfaces:
java.io.Serializable
public class BillDetailCostWithPartInfoResult
extends BillWithPartInfoResult
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
Fields inherited from class bb.common.BillWithPartInfoResult
ORDER_BY_BILLPK, ORDER_BY_CREATEDDATE, ORDER_BY_DESCRIPTION, ORDER_BY_DRAWING, ORDER_BY_LASTCHANGEDATE, ORDER_BY_LASTCHANGEUSER, ORDER_BY_ORIGIN, ORDER_BY_STATUS
Fields inherited from class bb.common.PartBasicInfo
ORDER_BY_BILL, ORDER_BY_BUYERCODE, ORDER_BY_COMMODITYCODE, ORDER_BY_HOLD, ORDER_BY_LASTUSER, ORDER_BY_MAKEBUY, ORDER_BY_MODELNUMBER, ORDER_BY_ORGANIZATION, ORDER_BY_PARTNUMBER, ORDER_BY_PARTTYPE, ORDER_BY_PARTUNIT, ORDER_BY_PRODUCTCODE, ORDER_BY_SECURITYLEVEL, ORDER_BY_WEIGHT
Constructor Summary
BillDetailCostWithPartInfoResult()
BillDetailCostWithPartInfoResult(BillWithPartInfoResult vo)
Method Summary
java.math.BigDecimal | getAverageCost()
java.math.BigDecimal | getListPrice()
java.math.BigDecimal | getStandardCost()
void | setAverageCost(java.math.BigDecimal averageCost)
void | setListPrice(java.math.BigDecimal listPrice)
void | setStandardCost(java.math.BigDecimal standardCost)
Methods inherited from class bb.common.BillWithPartInfoResult
getApprovedBy, getApprovedDate, getBillPk, getCreatedDate, getEcnList, getLastChangeDate, getLastChangeUser, getPartManufacturer, getStatus, getTraceableLevel, setApprovedBy, setApprovedDate, setBillPk, setCreatedDate, setEcnList, setLastChangeDate, setLastChangeUser, setPartManufacturer, setStatus, setTraceableLevel
Methods inherited from class bb.common.PartBasicInfo
equals, getBill, getBuyerCode, getCommodityCode, getCountryOrigin, getDescription, getDetectionStandard, getDrawing, getEngGroup, getHavePicture, getHold, getLastUser, getLeadTime, getMakeBuy, getMaterial, getModelNumber, getOrigin, getPartPk, getPartUnit, getProductCode, getRevision, getSaleable, getSalesDrawing, getSecurityLevel, getTraceable, getVolume, getVolumeUnit, getWeight, getWeightUnit, getWi, hashCode, setBill, setBuyerCode, setCommodityCode, setCountryOrigin, setDescription, setDetectionStandard, setDrawing, setEngGroup, setHavePicture, setHold, setLastUser, setLeadTime, setMakeBuy, setMaterial, setModelNumber, setOrigin, setPartPk, setPartUnit, setProductCode, setRevision, setSaleable, setSalesDrawing, setSecurityLevel, setTraceable, setVolume, setVolumeUnit, setWeight, setWeightUnit, setWi, toString
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

BillDetailCostWithPartInfoResult

public BillDetailCostWithPartInfoResult()

BillDetailCostWithPartInfoResult

public BillDetailCostWithPartInfoResult(BillWithPartInfoResult vo)
Method Detail

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

getAverageCost

public java.math.BigDecimal getAverageCost()

setAverageCost

public void setAverageCost(java.math.BigDecimal averageCost)

getStandardCost

public java.math.BigDecimal getStandardCost()

setStandardCost

public void setStandardCost(java.math.BigDecimal standardCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BillItemDetailCostWithPartInfoResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BillItemDetailCostWithPartInfoResult

java.lang.Object
    extended by  bb.common.PartBasicInfo
        extended by  bb.common.BillItemWithPartInfoResult
            extended by  bb.common.BillItemDetailCostWithPartInfoResult
All Implemented Interfaces:
java.io.Serializable
public class BillItemDetailCostWithPartInfoResult
extends BillItemWithPartInfoResult
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
Fields inherited from class bb.common.PartBasicInfo
ORDER_BY_BILL, ORDER_BY_BUYERCODE, ORDER_BY_COMMODITYCODE, ORDER_BY_DESCRIPTION, ORDER_BY_DRAWING, ORDER_BY_HOLD, ORDER_BY_LASTCHANGEDATE, ORDER_BY_LASTUSER, ORDER_BY_MAKEBUY, ORDER_BY_MODELNUMBER, ORDER_BY_ORGANIZATION, ORDER_BY_ORIGIN, ORDER_BY_PARTNUMBER, ORDER_BY_PARTTYPE, ORDER_BY_PARTUNIT, ORDER_BY_PRODUCTCODE, ORDER_BY_SECURITYLEVEL, ORDER_BY_WEIGHT
Constructor Summary
BillItemDetailCostWithPartInfoResult()
BillItemDetailCostWithPartInfoResult(BillItemWithPartInfoResult vo)
Method Summary
java.math.BigDecimal | getAverageCost()
java.math.BigDecimal | getListPrice()
java.math.BigDecimal | getStandardCost()
void | setAverageCost(java.math.BigDecimal averageCost)
void | setListPrice(java.math.BigDecimal listPrice)
void | setStandardCost(java.math.BigDecimal standardCost)
Methods inherited from class bb.common.BillItemWithPartInfoResult
equals, getAsmSequenceNo, getBillItemPk, getBillItemReplacements, getComments, getEcnList, getKitNumber, getMultiQtyforApplying, getPartManufacturer, getPartQuantity, getScrapQty, getScrapRate, getSparePart, getTraceableLevel, hashCode, isBackflushMaterial, setAsmSequenceNo, setBackflushMaterial, setBillItemPk, setBillItemReplacements, setComments, setEcnList, setKitNumber, setMultiQtyforApplying, setPartManufacturer, setPartQuantity, setScrapQty, setScrapRate, setSparePart, setTraceableLevel, toString
Methods inherited from class bb.common.PartBasicInfo
getBill, getBuyerCode, getCommodityCode, getCountryOrigin, getDescription, getDetectionStandard, getDrawing, getEngGroup, getHavePicture, getHold, getLastChangeDate, getLastUser, getLeadTime, getMakeBuy, getMaterial, getModelNumber, getOrigin, getPartPk, getPartUnit, getProductCode, getRevision, getSaleable, getSalesDrawing, getSecurityLevel, getTraceable, getVolume, getVolumeUnit, getWeight, getWeightUnit, getWi, setBill, setBuyerCode, setCommodityCode, setCountryOrigin, setDescription, setDetectionStandard, setDrawing, setEngGroup, setHavePicture, setHold, setLastChangeDate, setLastUser, setLeadTime, setMakeBuy, setMaterial, setModelNumber, setOrigin, setPartPk, setPartUnit, setProductCode, setRevision, setSaleable, setSalesDrawing, setSecurityLevel, setTraceable, setVolume, setVolumeUnit, setWeight, setWeightUnit, setWi
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

BillItemDetailCostWithPartInfoResult

public BillItemDetailCostWithPartInfoResult()

BillItemDetailCostWithPartInfoResult

public BillItemDetailCostWithPartInfoResult(BillItemWithPartInfoResult vo)
Method Detail

getListPrice

public java.math.BigDecimal getListPrice()
Overrides:
getListPrice in class BillItemWithPartInfoResult

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)
Overrides:
setListPrice in class BillItemWithPartInfoResult

getAverageCost

public java.math.BigDecimal getAverageCost()

setAverageCost

public void setAverageCost(java.math.BigDecimal averageCost)

getStandardCost

public java.math.BigDecimal getStandardCost()

setStandardCost

public void setStandardCost(java.math.BigDecimal standardCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BillItemOnHandUsageResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BillItemOnHandUsageResult

java.lang.Object
    extended by  bb.common.PartBasicInfo
        extended by  bb.common.BillItemUsageResult
            extended by  bb.common.BillItemOnHandUsageResult
All Implemented Interfaces:
java.io.Serializable
public class BillItemOnHandUsageResult
extends BillItemUsageResult
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
Fields inherited from class bb.common.PartBasicInfo
ORDER_BY_BILL, ORDER_BY_BUYERCODE, ORDER_BY_COMMODITYCODE, ORDER_BY_DESCRIPTION, ORDER_BY_DRAWING, ORDER_BY_HOLD, ORDER_BY_LASTCHANGEDATE, ORDER_BY_LASTUSER, ORDER_BY_MAKEBUY, ORDER_BY_MODELNUMBER, ORDER_BY_ORGANIZATION, ORDER_BY_ORIGIN, ORDER_BY_PARTNUMBER, ORDER_BY_PARTTYPE, ORDER_BY_PARTUNIT, ORDER_BY_PRODUCTCODE, ORDER_BY_SECURITYLEVEL, ORDER_BY_WEIGHT
Constructor Summary
BillItemOnHandUsageResult()
Method Summary
java.math.BigDecimal | getInSip()
java.math.BigDecimal | getInSit()
java.math.BigDecimal | getInWip()
java.math.BigDecimal | getOndemand()
java.math.BigDecimal | getOnhand()
java.util.Collection | getOnhandLocation()
java.math.BigDecimal | getOnorder()
void | setInSip(java.math.BigDecimal inSip)
void | setInSit(java.math.BigDecimal inSit)
void | setInWip(java.math.BigDecimal inWip)
void | setOndemand(java.math.BigDecimal ondemand)
void | setOnhand(java.math.BigDecimal onhand)
void | setOnhandLocation(java.util.Collection onhandLocation)
void | setOnorder(java.math.BigDecimal onorder)
Methods inherited from class bb.common.BillItemUsageResult
addItem, addItems, getAverageCost, getFixedQty, getItems, getListPrice, getSpareQty, getStandardCost, getTotalQty, setAverageCost, setFixedQty, setListPrice, setSpareQty, setStandardCost, setTotalQty
Methods inherited from class bb.common.PartBasicInfo
equals, getBill, getBuyerCode, getCommodityCode, getCountryOrigin, getDescription, getDetectionStandard, getDrawing, getEngGroup, getHavePicture, getHold, getLastChangeDate, getLastUser, getLeadTime, getMakeBuy, getMaterial, getModelNumber, getOrigin, getPartPk, getPartUnit, getProductCode, getRevision, getSaleable, getSalesDrawing, getSecurityLevel, getTraceable, getVolume, getVolumeUnit, getWeight, getWeightUnit, getWi, hashCode, setBill, setBuyerCode, setCommodityCode, setCountryOrigin, setDescription, setDetectionStandard, setDrawing, setEngGroup, setHavePicture, setHold, setLastChangeDate, setLastUser, setLeadTime, setMakeBuy, setMaterial, setModelNumber, setOrigin, setPartPk, setPartUnit, setProductCode, setRevision, setSaleable, setSalesDrawing, setSecurityLevel, setTraceable, setVolume, setVolumeUnit, setWeight, setWeightUnit, setWi, toString
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

BillItemOnHandUsageResult

public BillItemOnHandUsageResult()
Method Detail

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

setOnorder

public void setOnorder(java.math.BigDecimal onorder)

setOndemand

public void setOndemand(java.math.BigDecimal ondemand)

setInWip

public void setInWip(java.math.BigDecimal inWip)

getOnhand

public java.math.BigDecimal getOnhand()

getOnorder

public java.math.BigDecimal getOnorder()

getOndemand

public java.math.BigDecimal getOndemand()

getInWip

public java.math.BigDecimal getInWip()

getInSip

public java.math.BigDecimal getInSip()

setInSip

public void setInSip(java.math.BigDecimal inSip)

getInSit

public java.math.BigDecimal getInSit()

setInSit

public void setInSit(java.math.BigDecimal inSit)

getOnhandLocation

public java.util.Collection getOnhandLocation()

setOnhandLocation

public void setOnhandLocation(java.util.Collection onhandLocation)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BillItemOnHandWithPartInfoResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BillItemOnHandWithPartInfoResult

java.lang.Object
    extended by  bb.common.PartBasicInfo
        extended by  bb.common.BillItemWithPartInfoResult
            extended by  bb.common.BillItemOnHandWithPartInfoResult
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
MasterWorkOrderTreeItemResult
public class BillItemOnHandWithPartInfoResult
extends BillItemWithPartInfoResult
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
Fields inherited from class bb.common.PartBasicInfo
ORDER_BY_BILL, ORDER_BY_BUYERCODE, ORDER_BY_COMMODITYCODE, ORDER_BY_DESCRIPTION, ORDER_BY_DRAWING, ORDER_BY_HOLD, ORDER_BY_LASTCHANGEDATE, ORDER_BY_LASTUSER, ORDER_BY_MAKEBUY, ORDER_BY_MODELNUMBER, ORDER_BY_ORGANIZATION, ORDER_BY_ORIGIN, ORDER_BY_PARTNUMBER, ORDER_BY_PARTTYPE, ORDER_BY_PARTUNIT, ORDER_BY_PRODUCTCODE, ORDER_BY_SECURITYLEVEL, ORDER_BY_WEIGHT
Constructor Summary
BillItemOnHandWithPartInfoResult()
Method Summary
java.math.BigDecimal | getInSip()
java.math.BigDecimal | getInSit()
java.math.BigDecimal | getInWip()
java.math.BigDecimal | getOndemand()
java.math.BigDecimal | getOnhand()
java.util.Collection | getOnhandLocation()
java.math.BigDecimal | getOnorder()
void | setInSip(java.math.BigDecimal inSip)
void | setInSit(java.math.BigDecimal inSit)
void | setInWip(java.math.BigDecimal inWip)
void | setOndemand(java.math.BigDecimal ondemand)
void | setOnhand(java.math.BigDecimal onhand)
void | setOnhandLocation(java.util.Collection onhandLocation)
void | setOnorder(java.math.BigDecimal onorder)
Methods inherited from class bb.common.BillItemWithPartInfoResult
equals, getAsmSequenceNo, getBillItemPk, getBillItemReplacements, getComments, getEcnList, getKitNumber, getListPrice, getMultiQtyforApplying, getPartManufacturer, getPartQuantity, getScrapQty, getScrapRate, getSparePart, getTraceableLevel, hashCode, isBackflushMaterial, setAsmSequenceNo, setBackflushMaterial, setBillItemPk, setBillItemReplacements, setComments, setEcnList, setKitNumber, setListPrice, setMultiQtyforApplying, setPartManufacturer, setPartQuantity, setScrapQty, setScrapRate, setSparePart, setTraceableLevel, toString
Methods inherited from class bb.common.PartBasicInfo
getBill, getBuyerCode, getCommodityCode, getCountryOrigin, getDescription, getDetectionStandard, getDrawing, getEngGroup, getHavePicture, getHold, getLastChangeDate, getLastUser, getLeadTime, getMakeBuy, getMaterial, getModelNumber, getOrigin, getPartPk, getPartUnit, getProductCode, getRevision, getSaleable, getSalesDrawing, getSecurityLevel, getTraceable, getVolume, getVolumeUnit, getWeight, getWeightUnit, getWi, setBill, setBuyerCode, setCommodityCode, setCountryOrigin, setDescription, setDetectionStandard, setDrawing, setEngGroup, setHavePicture, setHold, setLastChangeDate, setLastUser, setLeadTime, setMakeBuy, setMaterial, setModelNumber, setOrigin, setPartPk, setPartUnit, setProductCode, setRevision, setSaleable, setSalesDrawing, setSecurityLevel, setTraceable, setVolume, setVolumeUnit, setWeight, setWeightUnit, setWi
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

BillItemOnHandWithPartInfoResult

public BillItemOnHandWithPartInfoResult()
Method Detail

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

setOnorder

public void setOnorder(java.math.BigDecimal onorder)

setOndemand

public void setOndemand(java.math.BigDecimal ondemand)

setInWip

public void setInWip(java.math.BigDecimal inWip)

getOnhand

public java.math.BigDecimal getOnhand()

getOnorder

public java.math.BigDecimal getOnorder()

getOndemand

public java.math.BigDecimal getOndemand()

getInWip

public java.math.BigDecimal getInWip()

getInSip

public java.math.BigDecimal getInSip()

setInSip

public void setInSip(java.math.BigDecimal inSip)

getInSit

public java.math.BigDecimal getInSit()

setInSit

public void setInSit(java.math.BigDecimal inSit)

getOnhandLocation

public java.util.Collection getOnhandLocation()

setOnhandLocation

public void setOnhandLocation(java.util.Collection onhandLocation)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BillItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BillItemPK

java.lang.Object
    extended by  bb.common.BillItemPK
All Implemented Interfaces:
java.io.Serializable
public class BillItemPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
BillItemPK()
default constructor
BillItemPK(java.lang.String billNumber, java.lang.String billType, java.lang.String billItemNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getBillItemNumber()
java.lang.String | getBillNumber()
java.lang.String | getBillType()
int | hashCode()
void | setBillItemNumber(java.lang.String billItemNumber)
void | setBillNumber(java.lang.String billNumber)
void | setBillType(java.lang.String billType)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

BillItemPK

public BillItemPK(java.lang.String billNumber,
                  java.lang.String billType,
                  java.lang.String billItemNumber)
full constructor

BillItemPK

public BillItemPK()
default constructor

Method Detail

getBillNumber

public java.lang.String getBillNumber()

setBillNumber

public void setBillNumber(java.lang.String billNumber)

getBillType

public java.lang.String getBillType()

setBillType

public void setBillType(java.lang.String billType)

getBillItemNumber

public java.lang.String getBillItemNumber()

setBillItemNumber

public void setBillItemNumber(java.lang.String billItemNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BillItemReplacementVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BillItemReplacementVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.BillItemReplacementVO
All Implemented Interfaces:
java.io.Serializable
public class BillItemReplacementVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BillItemReplacementVO()
Method Summary
boolean | equals(java.lang.Object obj)
java.lang.String | getAsmSequenceNo()
java.lang.String | getBillNumber()
java.lang.String | getBillType()
java.lang.Long | getIi()
java.lang.String | getItemComments()
java.math.BigDecimal | getOnHand()
java.math.BigDecimal | getRatio()
java.lang.String | getReplaceDesc()
java.lang.String | getReplacePartNumber()
java.lang.String | getReplacePartType()
java.math.BigDecimal | getScrapRate()
int | hashCode()
void | setAsmSequenceNo(java.lang.String asmSequenceNo)
void | setBillNumber(java.lang.String billNumber)
void | setBillType(java.lang.String billType)
void | setIi(java.lang.Long ii)
void | setItemComments(java.lang.String itemComments)
void | setOnHand(java.math.BigDecimal onHand)
void | setRatio(java.math.BigDecimal ratio)
void | setReplaceDesc(java.lang.String replaceDesc)
void | setReplacePartNumber(java.lang.String replacePartNumber)
void | setReplacePartType(java.lang.String replacePartType)
void | setScrapRate(java.math.BigDecimal scrapRate)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BillItemReplacementVO

public BillItemReplacementVO()
Method Detail

setIi

public void setIi(java.lang.Long ii)

getIi

public java.lang.Long getIi()

setBillNumber

public void setBillNumber(java.lang.String billNumber)

getBillNumber

public java.lang.String getBillNumber()

setBillType

public void setBillType(java.lang.String billType)

getBillType

public java.lang.String getBillType()

setAsmSequenceNo

public void setAsmSequenceNo(java.lang.String asmSequenceNo)

getAsmSequenceNo

public java.lang.String getAsmSequenceNo()

setReplacePartNumber

public void setReplacePartNumber(java.lang.String replacePartNumber)

getReplacePartNumber

public java.lang.String getReplacePartNumber()

setReplacePartType

public void setReplacePartType(java.lang.String replacePartType)

getReplacePartType

public java.lang.String getReplacePartType()

setRatio

public void setRatio(java.math.BigDecimal ratio)

getRatio

public java.math.BigDecimal getRatio()

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getScrapRate

public java.math.BigDecimal getScrapRate()

setScrapRate

public void setScrapRate(java.math.BigDecimal scrapRate)

getReplaceDesc

public java.lang.String getReplaceDesc()

setReplaceDesc

public void setReplaceDesc(java.lang.String replaceDesc)

getItemComments

public java.lang.String getItemComments()

setItemComments

public void setItemComments(java.lang.String itemComments)

getOnHand

public java.math.BigDecimal getOnHand()

setOnHand

public void setOnHand(java.math.BigDecimal onHand)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BillItemSalesCostResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BillItemSalesCostResult

java.lang.Object
    extended by  bb.common.PartBasicInfo
        extended by  bb.common.BillItemSalesCostResult
All Implemented Interfaces:
java.io.Serializable
public class BillItemSalesCostResult
extends PartBasicInfo
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
Fields inherited from class bb.common.PartBasicInfo
ORDER_BY_BILL, ORDER_BY_BUYERCODE, ORDER_BY_COMMODITYCODE, ORDER_BY_DESCRIPTION, ORDER_BY_DRAWING, ORDER_BY_HOLD, ORDER_BY_LASTCHANGEDATE, ORDER_BY_LASTUSER, ORDER_BY_MAKEBUY, ORDER_BY_MODELNUMBER, ORDER_BY_ORGANIZATION, ORDER_BY_ORIGIN, ORDER_BY_PARTNUMBER, ORDER_BY_PARTTYPE, ORDER_BY_PARTUNIT, ORDER_BY_PRODUCTCODE, ORDER_BY_SECURITYLEVEL, ORDER_BY_WEIGHT
Constructor Summary
BillItemSalesCostResult()
Method Summary
java.math.BigDecimal | getAverageCost()
java.lang.String | getBill()
BillItemPK | getBillItemPk()
java.lang.String | getDescription()
java.lang.String | getHold()
java.math.BigDecimal | getListPrice()
java.util.List<PartManufacturerVO> | getPartManufacturer()
java.math.BigDecimal | getQty()
java.lang.String | getSalesable()
java.lang.String | getSparePart()
java.math.BigDecimal | getStandardCost()
java.math.BigDecimal | getTotalAvgCost()
java.math.BigDecimal | getTotalListPrice()
java.math.BigDecimal | getTotalStdCost()
void | setAverageCost(java.math.BigDecimal averageCost)
void | setBill(java.lang.String bill)
void | setBillItemPk(BillItemPK billItemPk)
void | setDescription(java.lang.String description)
void | setHold(java.lang.String hold)
void | setListPrice(java.math.BigDecimal listPrice)
void | setPartManufacturer(java.util.List<PartManufacturerVO> partManufacturer)
void | setQty(java.math.BigDecimal qty)
void | setSalesable(java.lang.String salesable)
void | setSparePart(java.lang.String sparePart)
void | setStandardCost(java.math.BigDecimal standardCost)
void | setTotalAvgCost(java.math.BigDecimal totalAvgCost)
void | setTotalListPrice(java.math.BigDecimal totalListPrice)
void | setTotalStdCost(java.math.BigDecimal totalStdCost)
Methods inherited from class bb.common.PartBasicInfo
equals, getBuyerCode, getCommodityCode, getCountryOrigin, getDetectionStandard, getDrawing, getEngGroup, getHavePicture, getLastChangeDate, getLastUser, getLeadTime, getMakeBuy, getMaterial, getModelNumber, getOrigin, getPartPk, getPartUnit, getProductCode, getRevision, getSaleable, getSalesDrawing, getSecurityLevel, getTraceable, getVolume, getVolumeUnit, getWeight, getWeightUnit, getWi, hashCode, setBuyerCode, setCommodityCode, setCountryOrigin, setDetectionStandard, setDrawing, setEngGroup, setHavePicture, setLastChangeDate, setLastUser, setLeadTime, setMakeBuy, setMaterial, setModelNumber, setOrigin, setPartPk, setPartUnit, setProductCode, setRevision, setSaleable, setSalesDrawing, setSecurityLevel, setTraceable, setVolume, setVolumeUnit, setWeight, setWeightUnit, setWi, toString
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

BillItemSalesCostResult

public BillItemSalesCostResult()
Method Detail

getSparePart

public java.lang.String getSparePart()

setSparePart

public void setSparePart(java.lang.String sparePart)

setSalesable

public void setSalesable(java.lang.String salesable)

setBillItemPk

public void setBillItemPk(BillItemPK billItemPk)

setQty

public void setQty(java.math.BigDecimal qty)

setHold

public void setHold(java.lang.String hold)
Overrides:
setHold in class PartBasicInfo

setBill

public void setBill(java.lang.String bill)
Overrides:
setBill in class PartBasicInfo

setDescription

public void setDescription(java.lang.String description)
Overrides:
setDescription in class PartBasicInfo

getSalesable

public java.lang.String getSalesable()

getBillItemPk

public BillItemPK getBillItemPk()

getQty

public java.math.BigDecimal getQty()

getHold

public java.lang.String getHold()
Overrides:
getHold in class PartBasicInfo

getBill

public java.lang.String getBill()
Overrides:
getBill in class PartBasicInfo

getDescription

public java.lang.String getDescription()
Overrides:
getDescription in class PartBasicInfo

getAverageCost

public java.math.BigDecimal getAverageCost()

setAverageCost

public void setAverageCost(java.math.BigDecimal averageCost)

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

getStandardCost

public java.math.BigDecimal getStandardCost()

setStandardCost

public void setStandardCost(java.math.BigDecimal standardCost)

getPartManufacturer

public java.util.List<PartManufacturerVO> getPartManufacturer()

setPartManufacturer

public void setPartManufacturer(java.util.List<PartManufacturerVO> partManufacturer)

getTotalListPrice

public java.math.BigDecimal getTotalListPrice()

setTotalListPrice

public void setTotalListPrice(java.math.BigDecimal totalListPrice)

getTotalStdCost

public java.math.BigDecimal getTotalStdCost()

setTotalStdCost

public void setTotalStdCost(java.math.BigDecimal totalStdCost)

getTotalAvgCost

public java.math.BigDecimal getTotalAvgCost()

setTotalAvgCost

public void setTotalAvgCost(java.math.BigDecimal totalAvgCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BillItemSalesResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BillItemSalesResult

java.lang.Object
    extended by  bb.common.BillItemSalesResult
All Implemented Interfaces:
java.io.Serializable
public class BillItemSalesResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BillItemSalesResult()
Method Summary
BillItemPK | getBillItemPk()
java.lang.String | getDescription()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getQty()
java.lang.String | getRev()
java.lang.String | getSparePart()
java.lang.String | getUnit()
void | setBillItemPk(BillItemPK billItemPk)
void | setDescription(java.lang.String description)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setQty(java.math.BigDecimal qty)
void | setRev(java.lang.String rev)
void | setSparePart(java.lang.String sparePart)
void | setUnit(java.lang.String unit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BillItemSalesResult

public BillItemSalesResult()
Method Detail

getSparePart

public java.lang.String getSparePart()

setSparePart

public void setSparePart(java.lang.String sparePart)

setBillItemPk

public void setBillItemPk(BillItemPK billItemPk)

setQty

public void setQty(java.math.BigDecimal qty)

setPartNumber

public void setPartNumber(java.lang.String partNumber)

setPartType

public void setPartType(java.lang.String partType)

setRev

public void setRev(java.lang.String rev)

setUnit

public void setUnit(java.lang.String unit)

setDescription

public void setDescription(java.lang.String description)

getBillItemPk

public BillItemPK getBillItemPk()

getQty

public java.math.BigDecimal getQty()

getPartNumber

public java.lang.String getPartNumber()

getPartType

public java.lang.String getPartType()

getRev

public java.lang.String getRev()

getUnit

public java.lang.String getUnit()

getDescription

public java.lang.String getDescription()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BillItemSalesXResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BillItemSalesXResult

java.lang.Object
    extended by  bb.common.BillItemSalesXResult
All Implemented Interfaces:
java.io.Serializable
public class BillItemSalesXResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BillItemSalesXResult()
Method Summary
java.math.BigDecimal | getAverageCost()
java.lang.String | getBill()
BillItemPK | getBillItemPk()
java.lang.String | getDescription()
java.lang.String | getDwg()
java.lang.String | getHold()
java.math.BigDecimal | getListPrice()
java.lang.String | getMakeBuy()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getQty()
java.lang.String | getRev()
java.lang.String | getSalesable()
java.lang.String | getSparePart()
java.math.BigDecimal | getStandardCost()
java.lang.String | getUnit()
void | setAverageCost(java.math.BigDecimal averageCost)
void | setBill(java.lang.String bill)
void | setBillItemPk(BillItemPK billItemPk)
void | setDescription(java.lang.String description)
void | setDwg(java.lang.String dwg)
void | setHold(java.lang.String hold)
void | setListPrice(java.math.BigDecimal listPrice)
void | setMakeBuy(java.lang.String makeBuy)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setQty(java.math.BigDecimal qty)
void | setRev(java.lang.String rev)
void | setSalesable(java.lang.String salesable)
void | setSparePart(java.lang.String sparePart)
void | setStandardCost(java.math.BigDecimal standardCost)
void | setUnit(java.lang.String unit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BillItemSalesXResult

public BillItemSalesXResult()
Method Detail

getSparePart

public java.lang.String getSparePart()

setSparePart

public void setSparePart(java.lang.String sparePart)

setSalesable

public void setSalesable(java.lang.String salesable)

setBillItemPk

public void setBillItemPk(BillItemPK billItemPk)

setQty

public void setQty(java.math.BigDecimal qty)

setPartNumber

public void setPartNumber(java.lang.String partNumber)

setPartType

public void setPartType(java.lang.String partType)

setRev

public void setRev(java.lang.String rev)

setHold

public void setHold(java.lang.String hold)

setDwg

public void setDwg(java.lang.String dwg)

setUnit

public void setUnit(java.lang.String unit)

setBill

public void setBill(java.lang.String bill)

setDescription

public void setDescription(java.lang.String description)

getSalesable

public java.lang.String getSalesable()

getBillItemPk

public BillItemPK getBillItemPk()

getQty

public java.math.BigDecimal getQty()

getPartNumber

public java.lang.String getPartNumber()

getPartType

public java.lang.String getPartType()

getRev

public java.lang.String getRev()

getHold

public java.lang.String getHold()

getDwg

public java.lang.String getDwg()

getUnit

public java.lang.String getUnit()

getBill

public java.lang.String getBill()

getDescription

public java.lang.String getDescription()

getAverageCost

public java.math.BigDecimal getAverageCost()

setAverageCost

public void setAverageCost(java.math.BigDecimal averageCost)

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

getStandardCost

public java.math.BigDecimal getStandardCost()

setStandardCost

public void setStandardCost(java.math.BigDecimal standardCost)

getMakeBuy

public java.lang.String getMakeBuy()

setMakeBuy

public void setMakeBuy(java.lang.String makeBuy)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BillItemUsagePathResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BillItemUsagePathResult

java.lang.Object
    extended by  bb.common.BillItemUsagePathResult
All Implemented Interfaces:
java.io.Serializable
public class BillItemUsagePathResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BillItemUsagePathResult()
Method Summary
java.lang.String | getDescripiton()
java.lang.String | getItemComments()
java.lang.String | getItemNumber()
java.math.BigDecimal | getItemQty()
PartPK | getPk()
java.lang.String | getSparePart()
java.math.BigDecimal | getUsageQty()
void | setDescripiton(java.lang.String descripiton)
void | setItemComments(java.lang.String itemComments)
void | setItemNumber(java.lang.String itemNumber)
void | setItemQty(java.math.BigDecimal itemQty)
void | setPk(PartPK pk)
void | setSparePart(java.lang.String sparePart)
void | setUsageQty(java.math.BigDecimal usageQty)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BillItemUsagePathResult

public BillItemUsagePathResult()
Method Detail

getPk

public PartPK getPk()

setPk

public void setPk(PartPK pk)

getItemNumber

public java.lang.String getItemNumber()

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

getItemQty

public java.math.BigDecimal getItemQty()

setItemQty

public void setItemQty(java.math.BigDecimal itemQty)

getUsageQty

public java.math.BigDecimal getUsageQty()

setUsageQty

public void setUsageQty(java.math.BigDecimal usageQty)

getSparePart

public java.lang.String getSparePart()

setSparePart

public void setSparePart(java.lang.String sparePart)

getDescripiton

public java.lang.String getDescripiton()

setDescripiton

public void setDescripiton(java.lang.String descripiton)

getItemComments

public java.lang.String getItemComments()

setItemComments

public void setItemComments(java.lang.String itemComments)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BillItemUsageResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BillItemUsageResult

java.lang.Object
    extended by  bb.common.PartBasicInfo
        extended by  bb.common.BillItemUsageResult
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
BillItemOnHandUsageResult
public class BillItemUsageResult
extends PartBasicInfo
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
Fields inherited from class bb.common.PartBasicInfo
ORDER_BY_BILL, ORDER_BY_BUYERCODE, ORDER_BY_COMMODITYCODE, ORDER_BY_DESCRIPTION, ORDER_BY_DRAWING, ORDER_BY_HOLD, ORDER_BY_LASTCHANGEDATE, ORDER_BY_LASTUSER, ORDER_BY_MAKEBUY, ORDER_BY_MODELNUMBER, ORDER_BY_ORGANIZATION, ORDER_BY_ORIGIN, ORDER_BY_PARTNUMBER, ORDER_BY_PARTTYPE, ORDER_BY_PARTUNIT, ORDER_BY_PRODUCTCODE, ORDER_BY_SECURITYLEVEL, ORDER_BY_WEIGHT
Constructor Summary
BillItemUsageResult()
Method Summary
void | addItem(java.util.ArrayList<BillItemUsagePathResult> item)
void | addItems(java.util.ArrayList<java.util.ArrayList<BillItemUsagePathResult>> items)
java.math.BigDecimal | getAverageCost()
java.math.BigDecimal | getFixedQty()
java.util.Iterator<java.util.ArrayList<BillItemUsagePathResult>> | getItems()
java.math.BigDecimal | getListPrice()
java.math.BigDecimal | getSpareQty()
java.math.BigDecimal | getStandardCost()
java.math.BigDecimal | getTotalQty()
void | setAverageCost(java.math.BigDecimal averageCost)
void | setFixedQty(java.math.BigDecimal fixedQty)
void | setListPrice(java.math.BigDecimal listPrice)
void | setSpareQty(java.math.BigDecimal spareQty)
void | setStandardCost(java.math.BigDecimal standardCost)
void | setTotalQty(java.math.BigDecimal totalQty)
Methods inherited from class bb.common.PartBasicInfo
equals, getBill, getBuyerCode, getCommodityCode, getCountryOrigin, getDescription, getDetectionStandard, getDrawing, getEngGroup, getHavePicture, getHold, getLastChangeDate, getLastUser, getLeadTime, getMakeBuy, getMaterial, getModelNumber, getOrigin, getPartPk, getPartUnit, getProductCode, getRevision, getSaleable, getSalesDrawing, getSecurityLevel, getTraceable, getVolume, getVolumeUnit, getWeight, getWeightUnit, getWi, hashCode, setBill, setBuyerCode, setCommodityCode, setCountryOrigin, setDescription, setDetectionStandard, setDrawing, setEngGroup, setHavePicture, setHold, setLastChangeDate, setLastUser, setLeadTime, setMakeBuy, setMaterial, setModelNumber, setOrigin, setPartPk, setPartUnit, setProductCode, setRevision, setSaleable, setSalesDrawing, setSecurityLevel, setTraceable, setVolume, setVolumeUnit, setWeight, setWeightUnit, setWi, toString
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

BillItemUsageResult

public BillItemUsageResult()
Method Detail

getFixedQty

public java.math.BigDecimal getFixedQty()

setFixedQty

public void setFixedQty(java.math.BigDecimal fixedQty)

getSpareQty

public java.math.BigDecimal getSpareQty()

setSpareQty

public void setSpareQty(java.math.BigDecimal spareQty)

getAverageCost

public java.math.BigDecimal getAverageCost()

setAverageCost

public void setAverageCost(java.math.BigDecimal averageCost)

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

getStandardCost

public java.math.BigDecimal getStandardCost()

setStandardCost

public void setStandardCost(java.math.BigDecimal standardCost)

getTotalQty

public java.math.BigDecimal getTotalQty()

setTotalQty

public void setTotalQty(java.math.BigDecimal totalQty)

addItem

public void addItem(java.util.ArrayList<BillItemUsagePathResult> item)

getItems

public java.util.Iterator<java.util.ArrayList<BillItemUsagePathResult>> getItems()

addItems

public void addItems(java.util.ArrayList<java.util.ArrayList<BillItemUsagePathResult>> items)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BillItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BillItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.BillItemVO
All Implemented Interfaces:
java.io.Serializable
public class BillItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BillItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAsmSequenceNo()
java.lang.String | getBc()
java.util.Set<BillItemReplacementVO> | getBillItemReplacements()
java.lang.String | getComments()
java.lang.Integer | getKitNumber()
java.lang.String | getPartNumber()
java.math.BigDecimal | getPartQuantity()
java.lang.String | getPartType()
BillItemPK | getPk()
java.math.BigDecimal | getScrapRate()
java.lang.String | getSparePart()
int | hashCode()
boolean | isRoundToIntForSetup()
void | setAsmSequenceNo(java.lang.String asmSequenceNo)
void | setBc(java.lang.String bc)
void | setBillItemReplacements(java.util.Set<BillItemReplacementVO> billItemReplacements)
void | setComments(java.lang.String comments)
void | setKitNumber(java.lang.Integer kitNumber)
void | setPartNumber(java.lang.String partNumber)
void | setPartQuantity(java.math.BigDecimal partQuantity)
void | setPartType(java.lang.String partType)
void | setPk(BillItemPK pk)
void | setRoundToIntForSetup(boolean roundToIntForSetup)
void | setScrapRate(java.math.BigDecimal scrapRate)
void | setSparePart(java.lang.String sparePart)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

BillItemVO

public BillItemVO()
Method Detail

getPk

public BillItemPK getPk()

setPk

public void setPk(BillItemPK pk)

getBc

public java.lang.String getBc()

setBc

public void setBc(java.lang.String bc)

getPartQuantity

public java.math.BigDecimal getPartQuantity()

setPartQuantity

public void setPartQuantity(java.math.BigDecimal partQuantity)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getAsmSequenceNo

public java.lang.String getAsmSequenceNo()

setAsmSequenceNo

public void setAsmSequenceNo(java.lang.String asmSequenceNo)

getKitNumber

public java.lang.Integer getKitNumber()

setKitNumber

public void setKitNumber(java.lang.Integer kitNumber)

getSparePart

public java.lang.String getSparePart()

setSparePart

public void setSparePart(java.lang.String sparePart)

setBillItemReplacements

public void setBillItemReplacements(java.util.Set<BillItemReplacementVO> billItemReplacements)

getBillItemReplacements

public java.util.Set<BillItemReplacementVO> getBillItemReplacements()

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

isRoundToIntForSetup

public boolean isRoundToIntForSetup()

setRoundToIntForSetup

public void setRoundToIntForSetup(boolean roundToIntForSetup)

getScrapRate

public java.math.BigDecimal getScrapRate()

setScrapRate

public void setScrapRate(java.math.BigDecimal scrapRate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BillItemWithPartInfoResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BillItemWithPartInfoResult

java.lang.Object
    extended by  bb.common.PartBasicInfo
        extended by  bb.common.BillItemWithPartInfoResult
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
BillItemDetailCostWithPartInfoResult, BillItemOnHandWithPartInfoResult
public class BillItemWithPartInfoResult
extends PartBasicInfo
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
Fields inherited from class bb.common.PartBasicInfo
ORDER_BY_BILL, ORDER_BY_BUYERCODE, ORDER_BY_COMMODITYCODE, ORDER_BY_DESCRIPTION, ORDER_BY_DRAWING, ORDER_BY_HOLD, ORDER_BY_LASTCHANGEDATE, ORDER_BY_LASTUSER, ORDER_BY_MAKEBUY, ORDER_BY_MODELNUMBER, ORDER_BY_ORGANIZATION, ORDER_BY_ORIGIN, ORDER_BY_PARTNUMBER, ORDER_BY_PARTTYPE, ORDER_BY_PARTUNIT, ORDER_BY_PRODUCTCODE, ORDER_BY_SECURITYLEVEL, ORDER_BY_WEIGHT
Constructor Summary
BillItemWithPartInfoResult()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAsmSequenceNo()
BillItemPK | getBillItemPk()
java.util.Set<BillItemReplacementVO> | getBillItemReplacements()
java.lang.String | getComments()
java.util.List<EngineeringChangeListResult> | getEcnList()
java.lang.Integer | getKitNumber()
java.math.BigDecimal | getListPrice()
java.math.BigDecimal | getMultiQtyforApplying()
java.util.List<PartManufacturerVO> | getPartManufacturer()
java.math.BigDecimal | getPartQuantity()
java.math.BigDecimal | getScrapQty()
java.math.BigDecimal | getScrapRate()
java.lang.String | getSparePart()
java.lang.Byte | getTraceableLevel()
int | hashCode()
boolean | isBackflushMaterial()
void | setAsmSequenceNo(java.lang.String asmSequenceNo)
void | setBackflushMaterial(boolean backflushMaterial)
void | setBillItemPk(BillItemPK billItemPk)
void | setBillItemReplacements(java.util.Set<BillItemReplacementVO> billItemReplacements)
void | setComments(java.lang.String comments)
void | setEcnList(java.util.List<EngineeringChangeListResult> ecnList)
void | setKitNumber(java.lang.Integer kitNumber)
void | setListPrice(java.math.BigDecimal listPrice)
void | setMultiQtyforApplying(java.math.BigDecimal multiQtyforApplying)
void | setPartManufacturer(java.util.List<PartManufacturerVO> partManufacturer)
void | setPartQuantity(java.math.BigDecimal partQuantity)
void | setScrapQty(java.math.BigDecimal scrapQty)
void | setScrapRate(java.math.BigDecimal scrapRate)
void | setSparePart(java.lang.String sparePart)
void | setTraceableLevel(java.lang.Byte traceableLevel)
java.lang.String | toString()
Methods inherited from class bb.common.PartBasicInfo
getBill, getBuyerCode, getCommodityCode, getCountryOrigin, getDescription, getDetectionStandard, getDrawing, getEngGroup, getHavePicture, getHold, getLastChangeDate, getLastUser, getLeadTime, getMakeBuy, getMaterial, getModelNumber, getOrigin, getPartPk, getPartUnit, getProductCode, getRevision, getSaleable, getSalesDrawing, getSecurityLevel, getTraceable, getVolume, getVolumeUnit, getWeight, getWeightUnit, getWi, setBill, setBuyerCode, setCommodityCode, setCountryOrigin, setDescription, setDetectionStandard, setDrawing, setEngGroup, setHavePicture, setHold, setLastChangeDate, setLastUser, setLeadTime, setMakeBuy, setMaterial, setModelNumber, setOrigin, setPartPk, setPartUnit, setProductCode, setRevision, setSaleable, setSalesDrawing, setSecurityLevel, setTraceable, setVolume, setVolumeUnit, setWeight, setWeightUnit, setWi
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

BillItemWithPartInfoResult

public BillItemWithPartInfoResult()
Method Detail

getBillItemPk

public BillItemPK getBillItemPk()

setBillItemPk

public void setBillItemPk(BillItemPK billItemPk)

getTraceableLevel

public java.lang.Byte getTraceableLevel()

setTraceableLevel

public void setTraceableLevel(java.lang.Byte traceableLevel)

getPartQuantity

public java.math.BigDecimal getPartQuantity()

setPartQuantity

public void setPartQuantity(java.math.BigDecimal partQuantity)

getAsmSequenceNo

public java.lang.String getAsmSequenceNo()

setAsmSequenceNo

public void setAsmSequenceNo(java.lang.String asmSequenceNo)

getKitNumber

public java.lang.Integer getKitNumber()

setKitNumber

public void setKitNumber(java.lang.Integer kitNumber)

getSparePart

public java.lang.String getSparePart()

setSparePart

public void setSparePart(java.lang.String sparePart)

getPartManufacturer

public java.util.List<PartManufacturerVO> getPartManufacturer()

setPartManufacturer

public void setPartManufacturer(java.util.List<PartManufacturerVO> partManufacturer)

setBillItemReplacements

public void setBillItemReplacements(java.util.Set<BillItemReplacementVO> billItemReplacements)

getBillItemReplacements

public java.util.Set<BillItemReplacementVO> getBillItemReplacements()

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class PartBasicInfo

hashCode

public int hashCode()
Overrides:
hashCode in class PartBasicInfo

toString

public java.lang.String toString()
Overrides:
toString in class PartBasicInfo

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getScrapRate

public java.math.BigDecimal getScrapRate()

setScrapRate

public void setScrapRate(java.math.BigDecimal scrapRate)

isBackflushMaterial

public boolean isBackflushMaterial()

setBackflushMaterial

public void setBackflushMaterial(boolean backflushMaterial)

getScrapQty

public java.math.BigDecimal getScrapQty()

setScrapQty

public void setScrapQty(java.math.BigDecimal scrapQty)

getEcnList

public java.util.List<EngineeringChangeListResult> getEcnList()

setEcnList

public void setEcnList(java.util.List<EngineeringChangeListResult> ecnList)

getMultiQtyforApplying

public java.math.BigDecimal getMultiQtyforApplying()

setMultiQtyforApplying

public void setMultiQtyforApplying(java.math.BigDecimal multiQtyforApplying)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BillLogVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BillLogVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.BillLogVO
All Implemented Interfaces:
java.io.Serializable
public class BillLogVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_BILLITEMNUMBER
static java.lang.String | ORDER_BY_BILLNUMBER
static java.lang.String | ORDER_BY_BILLTYPE
static java.lang.String | ORDER_BY_LASTCHANGETIME
static java.lang.String | ORDER_BY_LASTCHANGEUSER
static java.lang.String | ORDER_BY_NEWPARTNUMBER
static java.lang.String | ORDER_BY_NEWPARTQUANTITY
static java.lang.String | ORDER_BY_NEWPARTTYPE
static java.lang.String | ORDER_BY_NEWSPAREPART
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTQUANTITY
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_SPAREPART
Constructor Summary
BillLogVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getBillItemNumber()
java.lang.String | getBillNumber()
java.lang.String | getBillType()
java.lang.Long | getIi()
java.util.Date | getLastChangeTime()
java.lang.String | getLastChangeUser()
java.lang.String | getNewPartNumber()
java.math.BigDecimal | getNewPartQuantity()
java.lang.String | getNewPartType()
java.lang.String | getNewSparePart()
java.lang.String | getPartNumber()
java.math.BigDecimal | getPartQuantity()
java.lang.String | getPartType()
java.lang.String | getSparePart()
int | hashCode()
void | setBillItemNumber(java.lang.String billItemNumber)
void | setBillNumber(java.lang.String billNumber)
void | setBillType(java.lang.String billType)
void | setIi(java.lang.Long ii)
void | setLastChangeTime(java.util.Date lastChangeTime)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setNewPartNumber(java.lang.String newPartNumber)
void | setNewPartQuantity(java.math.BigDecimal newPartQuantity)
void | setNewPartType(java.lang.String newPartType)
void | setNewSparePart(java.lang.String newSparePart)
void | setPartNumber(java.lang.String partNumber)
void | setPartQuantity(java.math.BigDecimal partQuantity)
void | setPartType(java.lang.String partType)
void | setSparePart(java.lang.String sparePart)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_BILLNUMBER

public static final java.lang.String ORDER_BY_BILLNUMBER
See Also:
Constant Field Values

ORDER_BY_BILLTYPE

public static final java.lang.String ORDER_BY_BILLTYPE
See Also:
Constant Field Values

ORDER_BY_BILLITEMNUMBER

public static final java.lang.String ORDER_BY_BILLITEMNUMBER
See Also:
Constant Field Values

ORDER_BY_LASTCHANGETIME

public static final java.lang.String ORDER_BY_LASTCHANGETIME
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEUSER

public static final java.lang.String ORDER_BY_LASTCHANGEUSER
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_PARTQUANTITY

public static final java.lang.String ORDER_BY_PARTQUANTITY
See Also:
Constant Field Values

ORDER_BY_SPAREPART

public static final java.lang.String ORDER_BY_SPAREPART
See Also:
Constant Field Values

ORDER_BY_NEWPARTNUMBER

public static final java.lang.String ORDER_BY_NEWPARTNUMBER
See Also:
Constant Field Values

ORDER_BY_NEWPARTTYPE

public static final java.lang.String ORDER_BY_NEWPARTTYPE
See Also:
Constant Field Values

ORDER_BY_NEWPARTQUANTITY

public static final java.lang.String ORDER_BY_NEWPARTQUANTITY
See Also:
Constant Field Values

ORDER_BY_NEWSPAREPART

public static final java.lang.String ORDER_BY_NEWSPAREPART
See Also:
Constant Field Values
Constructor Detail

BillLogVO

public BillLogVO()
Method Detail

getBillItemNumber

public java.lang.String getBillItemNumber()

setBillItemNumber

public void setBillItemNumber(java.lang.String billItemNumber)

getBillNumber

public java.lang.String getBillNumber()

setBillNumber

public void setBillNumber(java.lang.String billNumber)

getBillType

public java.lang.String getBillType()

setBillType

public void setBillType(java.lang.String billType)

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getLastChangeTime

public java.util.Date getLastChangeTime()

setLastChangeTime

public void setLastChangeTime(java.util.Date lastChangeTime)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getNewPartNumber

public java.lang.String getNewPartNumber()

setNewPartNumber

public void setNewPartNumber(java.lang.String newPartNumber)

getNewPartQuantity

public java.math.BigDecimal getNewPartQuantity()

setNewPartQuantity

public void setNewPartQuantity(java.math.BigDecimal newPartQuantity)

getNewPartType

public java.lang.String getNewPartType()

setNewPartType

public void setNewPartType(java.lang.String newPartType)

getNewSparePart

public java.lang.String getNewSparePart()

setNewSparePart

public void setNewSparePart(java.lang.String newSparePart)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartQuantity

public java.math.BigDecimal getPartQuantity()

setPartQuantity

public void setPartQuantity(java.math.BigDecimal partQuantity)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getSparePart

public java.lang.String getSparePart()

setSparePart

public void setSparePart(java.lang.String sparePart)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BillOnHandWithPartInfoResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BillOnHandWithPartInfoResult

java.lang.Object
    extended by  bb.common.PartBasicInfo
        extended by  bb.common.BillWithPartInfoResult
            extended by  bb.common.BillOnHandWithPartInfoResult
All Implemented Interfaces:
java.io.Serializable
public class BillOnHandWithPartInfoResult
extends BillWithPartInfoResult
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_BILLPK
static java.lang.String | ORDER_BY_LASTCHANGEDATE
static java.lang.String | ORDER_BY_LASTCHANGEUSER
static java.lang.String | ORDER_BY_ONDEMAND
static java.lang.String | ORDER_BY_ONHAND
static java.lang.String | ORDER_BY_ONORDER
Fields inherited from class bb.common.BillWithPartInfoResult
ORDER_BY_CREATEDDATE, ORDER_BY_DESCRIPTION, ORDER_BY_DRAWING, ORDER_BY_ORIGIN, ORDER_BY_STATUS
Fields inherited from class bb.common.PartBasicInfo
ORDER_BY_BILL, ORDER_BY_BUYERCODE, ORDER_BY_COMMODITYCODE, ORDER_BY_HOLD, ORDER_BY_LASTUSER, ORDER_BY_MAKEBUY, ORDER_BY_MODELNUMBER, ORDER_BY_ORGANIZATION, ORDER_BY_PARTNUMBER, ORDER_BY_PARTTYPE, ORDER_BY_PARTUNIT, ORDER_BY_PRODUCTCODE, ORDER_BY_SECURITYLEVEL, ORDER_BY_WEIGHT
Constructor Summary
BillOnHandWithPartInfoResult()
Method Summary
java.math.BigDecimal | getInSip()
java.math.BigDecimal | getInSit()
java.math.BigDecimal | getInWip()
java.math.BigDecimal | getLocationOnhand()
java.math.BigDecimal | getOndemand()
java.math.BigDecimal | getOnhand()
java.math.BigDecimal | getOnorder()
void | setInSip(java.math.BigDecimal inSip)
void | setInSit(java.math.BigDecimal inSit)
void | setInWip(java.math.BigDecimal inWip)
void | setLocationOnhand(java.math.BigDecimal locationOnhand)
void | setOndemand(java.math.BigDecimal ondemand)
void | setOnhand(java.math.BigDecimal onhand)
void | setOnorder(java.math.BigDecimal onorder)
Methods inherited from class bb.common.BillWithPartInfoResult
getApprovedBy, getApprovedDate, getBillPk, getCreatedDate, getEcnList, getLastChangeDate, getLastChangeUser, getPartManufacturer, getStatus, getTraceableLevel, setApprovedBy, setApprovedDate, setBillPk, setCreatedDate, setEcnList, setLastChangeDate, setLastChangeUser, setPartManufacturer, setStatus, setTraceableLevel
Methods inherited from class bb.common.PartBasicInfo
equals, getBill, getBuyerCode, getCommodityCode, getCountryOrigin, getDescription, getDetectionStandard, getDrawing, getEngGroup, getHavePicture, getHold, getLastUser, getLeadTime, getMakeBuy, getMaterial, getModelNumber, getOrigin, getPartPk, getPartUnit, getProductCode, getRevision, getSaleable, getSalesDrawing, getSecurityLevel, getTraceable, getVolume, getVolumeUnit, getWeight, getWeightUnit, getWi, hashCode, setBill, setBuyerCode, setCommodityCode, setCountryOrigin, setDescription, setDetectionStandard, setDrawing, setEngGroup, setHavePicture, setHold, setLastUser, setLeadTime, setMakeBuy, setMaterial, setModelNumber, setOrigin, setPartPk, setPartUnit, setProductCode, setRevision, setSaleable, setSalesDrawing, setSecurityLevel, setTraceable, setVolume, setVolumeUnit, setWeight, setWeightUnit, setWi, toString
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_LASTCHANGEUSER

public static final java.lang.String ORDER_BY_LASTCHANGEUSER
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEDATE

public static final java.lang.String ORDER_BY_LASTCHANGEDATE
See Also:
Constant Field Values

ORDER_BY_BILLPK

public static final java.lang.String ORDER_BY_BILLPK
See Also:
Constant Field Values

ORDER_BY_ONHAND

public static final java.lang.String ORDER_BY_ONHAND
See Also:
Constant Field Values

ORDER_BY_ONORDER

public static final java.lang.String ORDER_BY_ONORDER
See Also:
Constant Field Values

ORDER_BY_ONDEMAND

public static final java.lang.String ORDER_BY_ONDEMAND
See Also:
Constant Field Values
Constructor Detail

BillOnHandWithPartInfoResult

public BillOnHandWithPartInfoResult()
Method Detail

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

setOnorder

public void setOnorder(java.math.BigDecimal onorder)

setOndemand

public void setOndemand(java.math.BigDecimal ondemand)

setInWip

public void setInWip(java.math.BigDecimal inWip)

getOnhand

public java.math.BigDecimal getOnhand()

getOnorder

public java.math.BigDecimal getOnorder()

getOndemand

public java.math.BigDecimal getOndemand()

getInWip

public java.math.BigDecimal getInWip()

getInSip

public java.math.BigDecimal getInSip()

setInSip

public void setInSip(java.math.BigDecimal inSip)

getInSit

public java.math.BigDecimal getInSit()

setInSit

public void setInSit(java.math.BigDecimal inSit)

getLocationOnhand

public java.math.BigDecimal getLocationOnhand()

setLocationOnhand

public void setLocationOnhand(java.math.BigDecimal locationOnhand)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BillPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BillPK

java.lang.Object
    extended by  bb.common.BillPK
All Implemented Interfaces:
java.io.Serializable
public class BillPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BillPK()
BillPK(PartPK partPk)
BillPK(java.lang.String billNumber, java.lang.String billType)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getBillNumber()
java.lang.String | getBillType()
int | hashCode()
void | setBillNumber(java.lang.String billNumber)
void | setBillType(java.lang.String billType)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

BillPK

public BillPK(java.lang.String billNumber,
              java.lang.String billType)

BillPK

public BillPK(PartPK partPk)

BillPK

public BillPK()
Method Detail

getBillNumber

public java.lang.String getBillNumber()

setBillNumber

public void setBillNumber(java.lang.String billNumber)

getBillType

public java.lang.String getBillType()

setBillType

public void setBillType(java.lang.String billType)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BillSalesCostResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BillSalesCostResult

java.lang.Object
    extended by  bb.common.PartBasicInfo
        extended by  bb.common.BillSalesCostResult
All Implemented Interfaces:
java.io.Serializable
public class BillSalesCostResult
extends PartBasicInfo
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
Fields inherited from class bb.common.PartBasicInfo
ORDER_BY_BILL, ORDER_BY_BUYERCODE, ORDER_BY_COMMODITYCODE, ORDER_BY_DESCRIPTION, ORDER_BY_DRAWING, ORDER_BY_HOLD, ORDER_BY_LASTCHANGEDATE, ORDER_BY_LASTUSER, ORDER_BY_MAKEBUY, ORDER_BY_MODELNUMBER, ORDER_BY_ORGANIZATION, ORDER_BY_ORIGIN, ORDER_BY_PARTNUMBER, ORDER_BY_PARTTYPE, ORDER_BY_PARTUNIT, ORDER_BY_PRODUCTCODE, ORDER_BY_SECURITYLEVEL, ORDER_BY_WEIGHT
Constructor Summary
BillSalesCostResult()
Method Summary
java.math.BigDecimal | getAverageCost()
BillPK | getBillPk()
java.lang.String | getDescription()
java.lang.String | getHold()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.math.BigDecimal | getListPrice()
java.lang.String | getSaleable()
java.math.BigDecimal | getStandardCost()
void | setAverageCost(java.math.BigDecimal averageCost)
void | setBillPk(BillPK billPk)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setListPrice(java.math.BigDecimal listPrice)
void | setPartPk(PartPK partPk)
void | setSaleable(java.lang.String saleable)
void | setStandardCost(java.math.BigDecimal standardCost)
Methods inherited from class bb.common.PartBasicInfo
equals, getBill, getBuyerCode, getCommodityCode, getCountryOrigin, getDetectionStandard, getDrawing, getEngGroup, getHavePicture, getLastUser, getLeadTime, getMakeBuy, getMaterial, getModelNumber, getOrigin, getPartPk, getPartUnit, getProductCode, getRevision, getSalesDrawing, getSecurityLevel, getTraceable, getVolume, getVolumeUnit, getWeight, getWeightUnit, getWi, hashCode, setBill, setBuyerCode, setCommodityCode, setCountryOrigin, setDescription, setDetectionStandard, setDrawing, setEngGroup, setHavePicture, setHold, setLastUser, setLeadTime, setMakeBuy, setMaterial, setModelNumber, setOrigin, setPartUnit, setProductCode, setRevision, setSalesDrawing, setSecurityLevel, setTraceable, setVolume, setVolumeUnit, setWeight, setWeightUnit, setWi, toString
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

BillSalesCostResult

public BillSalesCostResult()
Method Detail

setPartPk

public void setPartPk(PartPK partPk)
Overrides:
setPartPk in class PartBasicInfo

getHold

public java.lang.String getHold()
Overrides:
getHold in class PartBasicInfo

getDescription

public java.lang.String getDescription()
Overrides:
getDescription in class PartBasicInfo

getAverageCost

public java.math.BigDecimal getAverageCost()

setAverageCost

public void setAverageCost(java.math.BigDecimal averageCost)

getStandardCost

public java.math.BigDecimal getStandardCost()

setStandardCost

public void setStandardCost(java.math.BigDecimal standardCost)

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

getBillPk

public BillPK getBillPk()

setBillPk

public void setBillPk(BillPK billPk)

getLastChangeDate

public java.util.Date getLastChangeDate()
Overrides:
getLastChangeDate in class PartBasicInfo

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)
Overrides:
setLastChangeDate in class PartBasicInfo

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getSaleable

public java.lang.String getSaleable()
Overrides:
getSaleable in class PartBasicInfo

setSaleable

public void setSaleable(java.lang.String saleable)
Overrides:
setSaleable in class PartBasicInfo
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BillSalesOfCostResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BillSalesOfCostResult

java.lang.Object
    extended by  bb.common.BillSalesOfCostResult
All Implemented Interfaces:
java.io.Serializable
public class BillSalesOfCostResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BillSalesOfCostResult()
Method Summary
java.lang.Integer | getMissingItems()
java.math.BigDecimal | getTotalaverageCost()
java.math.BigDecimal | getTotallistCost()
java.math.BigDecimal | getTotalstandardCost()
java.math.BigDecimal | getVendorAverageCost()
java.math.BigDecimal | getVendorHighestCost()
java.math.BigDecimal | getVendorLowestCost()
void | setMissingItems(java.lang.Integer missingItems)
void | setTotalaverageCost(java.math.BigDecimal totalaverageCost)
void | setTotallistCost(java.math.BigDecimal totallistCost)
void | setTotalstandardCost(java.math.BigDecimal totalstandardCost)
void | setVendorAverageCost(java.math.BigDecimal vendorAverageCost)
void | setVendorHighestCost(java.math.BigDecimal vendorHighestCost)
void | setVendorLowestCost(java.math.BigDecimal vendorLowestCost)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BillSalesOfCostResult

public BillSalesOfCostResult()
Method Detail

getMissingItems

public java.lang.Integer getMissingItems()

setMissingItems

public void setMissingItems(java.lang.Integer missingItems)

getVendorAverageCost

public java.math.BigDecimal getVendorAverageCost()

setVendorAverageCost

public void setVendorAverageCost(java.math.BigDecimal vendorAverageCost)

getVendorHighestCost

public java.math.BigDecimal getVendorHighestCost()

setVendorHighestCost

public void setVendorHighestCost(java.math.BigDecimal vendorHighestCost)

getVendorLowestCost

public java.math.BigDecimal getVendorLowestCost()

setVendorLowestCost

public void setVendorLowestCost(java.math.BigDecimal vendorLowestCost)

getTotalaverageCost

public java.math.BigDecimal getTotalaverageCost()

setTotalaverageCost

public void setTotalaverageCost(java.math.BigDecimal totalaverageCost)

getTotallistCost

public java.math.BigDecimal getTotallistCost()

setTotallistCost

public void setTotallistCost(java.math.BigDecimal totallistCost)

getTotalstandardCost

public java.math.BigDecimal getTotalstandardCost()

setTotalstandardCost

public void setTotalstandardCost(java.math.BigDecimal totalstandardCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BillSalesResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BillSalesResult

java.lang.Object
    extended by  bb.common.BillSalesResult
All Implemented Interfaces:
java.io.Serializable
public class BillSalesResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BillSalesResult()
Method Summary
java.lang.String | getDescription()
java.util.Set | getItems()
PartPK | getPartPk()
java.lang.String | getRev()
java.lang.String | getUnit()
void | setDescription(java.lang.String description)
void | setItems(java.util.Set items)
void | setPartPk(PartPK partPk)
void | setRev(java.lang.String rev)
void | setUnit(java.lang.String unit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BillSalesResult

public BillSalesResult()
Method Detail

setPartPk

public void setPartPk(PartPK partPk)

setRev

public void setRev(java.lang.String rev)

setUnit

public void setUnit(java.lang.String unit)

setDescription

public void setDescription(java.lang.String description)

setItems

public void setItems(java.util.Set items)

getPartPk

public PartPK getPartPk()

getRev

public java.lang.String getRev()

getUnit

public java.lang.String getUnit()

getDescription

public java.lang.String getDescription()

getItems

public java.util.Set getItems()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BillSalesXResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BillSalesXResult

java.lang.Object
    extended by  bb.common.BillSalesXResult
All Implemented Interfaces:
java.io.Serializable
public class BillSalesXResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BillSalesXResult()
Method Summary
java.math.BigDecimal | getAverageCost()
java.lang.String | getDescription()
java.lang.String | getDwg()
java.lang.String | getHold()
java.util.Set | getItems()
java.math.BigDecimal | getListPrice()
java.lang.Integer | getMissingItems()
PartPK | getPartPk()
java.lang.String | getRev()
java.lang.String | getSalesable()
java.math.BigDecimal | getStandardCost()
java.math.BigDecimal | getTotalaverageCost()
java.math.BigDecimal | getTotallistCost()
java.math.BigDecimal | getTotalstandardCost()
java.lang.String | getUnit()
java.math.BigDecimal | getVendorAverageCost()
java.math.BigDecimal | getVendorHighestCost()
java.math.BigDecimal | getVendorLowestCost()
void | setAverageCost(java.math.BigDecimal averageCost)
void | setDescription(java.lang.String description)
void | setDwg(java.lang.String dwg)
void | setHold(java.lang.String hold)
void | setItems(java.util.Set items)
void | setListPrice(java.math.BigDecimal listPrice)
void | setMissingItems(java.lang.Integer missingItems)
void | setPartPk(PartPK partPk)
void | setRev(java.lang.String rev)
void | setSalesable(java.lang.String salesable)
void | setStandardCost(java.math.BigDecimal standardCost)
void | setTotalaverageCost(java.math.BigDecimal totalaverageCost)
void | setTotallistCost(java.math.BigDecimal totallistCost)
void | setTotalstandardCost(java.math.BigDecimal totalstandardCost)
void | setUnit(java.lang.String unit)
void | setVendorAverageCost(java.math.BigDecimal vendorAverageCost)
void | setVendorHighestCost(java.math.BigDecimal vendorHighestCost)
void | setVendorLowestCost(java.math.BigDecimal vendorLowestCost)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BillSalesXResult

public BillSalesXResult()
Method Detail

setPartPk

public void setPartPk(PartPK partPk)

setSalesable

public void setSalesable(java.lang.String salesable)

setHold

public void setHold(java.lang.String hold)

setDwg

public void setDwg(java.lang.String dwg)

setRev

public void setRev(java.lang.String rev)

setUnit

public void setUnit(java.lang.String unit)

setDescription

public void setDescription(java.lang.String description)

setItems

public void setItems(java.util.Set items)

getPartPk

public PartPK getPartPk()

getSalesable

public java.lang.String getSalesable()

getHold

public java.lang.String getHold()

getDwg

public java.lang.String getDwg()

getRev

public java.lang.String getRev()

getUnit

public java.lang.String getUnit()

getDescription

public java.lang.String getDescription()

getItems

public java.util.Set getItems()

getAverageCost

public java.math.BigDecimal getAverageCost()

setAverageCost

public void setAverageCost(java.math.BigDecimal averageCost)

getMissingItems

public java.lang.Integer getMissingItems()

setMissingItems

public void setMissingItems(java.lang.Integer missingItems)

getStandardCost

public java.math.BigDecimal getStandardCost()

setStandardCost

public void setStandardCost(java.math.BigDecimal standardCost)

getVendorAverageCost

public java.math.BigDecimal getVendorAverageCost()

setVendorAverageCost

public void setVendorAverageCost(java.math.BigDecimal vendorAverageCost)

getVendorHighestCost

public java.math.BigDecimal getVendorHighestCost()

setVendorHighestCost

public void setVendorHighestCost(java.math.BigDecimal vendorHighestCost)

getVendorLowestCost

public java.math.BigDecimal getVendorLowestCost()

setVendorLowestCost

public void setVendorLowestCost(java.math.BigDecimal vendorLowestCost)

getTotalaverageCost

public java.math.BigDecimal getTotalaverageCost()

setTotalaverageCost

public void setTotalaverageCost(java.math.BigDecimal totalaverageCost)

getTotallistCost

public java.math.BigDecimal getTotallistCost()

setTotallistCost

public void setTotallistCost(java.math.BigDecimal totallistCost)

getTotalstandardCost

public java.math.BigDecimal getTotalstandardCost()

setTotalstandardCost

public void setTotalstandardCost(java.math.BigDecimal totalstandardCost)

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BillVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BillVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.BillVO
All Implemented Interfaces:
java.io.Serializable
public class BillVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BillVO()
BillVO(BillPK pk, java.lang.String lastChangeUser, java.lang.String origin, java.util.Date lastChangeDate, java.util.Date createdDate, java.util.Set billItem)
full constructor
BillVO(BillPK pk, java.lang.String lastChangeUser, java.lang.String origin, java.util.Set billItem)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getApprovedBy()
java.util.Date | getApprovedDate()
java.util.Set | getBillItem()
java.util.Date | getCreatedDate()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getMfgBillSetupInfo()
java.lang.String | getOrigin()
BillPK | getPk()
java.lang.String | getRbFlag()
java.lang.String | getStatus()
java.lang.Integer | getVersion()
int | hashCode()
void | setApprovedBy(java.lang.String approvedBy)
void | setApprovedDate(java.util.Date approvedDate)
void | setBillItem(java.util.Set billItem)
void | setCreatedDate(java.util.Date createdDate)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setMfgBillSetupInfo(java.lang.String mfgBillSetupInfo)
void | setOrigin(java.lang.String origin)
void | setPk(BillPK pk)
void | setRbFlag(java.lang.String rbFlag)
void | setStatus(java.lang.String status)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

BillVO

public BillVO(BillPK pk,
              java.lang.String lastChangeUser,
              java.lang.String origin,
              java.util.Date lastChangeDate,
              java.util.Date createdDate,
              java.util.Set billItem)
full constructor

BillVO

public BillVO()

BillVO

public BillVO(BillPK pk,
              java.lang.String lastChangeUser,
              java.lang.String origin,
              java.util.Set billItem)
Method Detail

getPk

public BillPK getPk()

setPk

public void setPk(BillPK pk)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getBillItem

public java.util.Set getBillItem()

setBillItem

public void setBillItem(java.util.Set billItem)

getVersion

public java.lang.Integer getVersion()

setVersion

public void setVersion(java.lang.Integer version)

getRbFlag

public java.lang.String getRbFlag()

setRbFlag

public void setRbFlag(java.lang.String rbFlag)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getMfgBillSetupInfo

public java.lang.String getMfgBillSetupInfo()

setMfgBillSetupInfo

public void setMfgBillSetupInfo(java.lang.String mfgBillSetupInfo)

getCreatedDate

public java.util.Date getCreatedDate()

setCreatedDate

public void setCreatedDate(java.util.Date createdDate)

getApprovedBy

public java.lang.String getApprovedBy()

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)

getApprovedDate

public java.util.Date getApprovedDate()

setApprovedDate

public void setApprovedDate(java.util.Date approvedDate)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BillWhereUsedItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BillWhereUsedItemResult

java.lang.Object
    extended by  bb.common.BillWhereUsedItemResult
All Implemented Interfaces:
java.io.Serializable
public class BillWhereUsedItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BillWhereUsedItemResult()
Method Summary
java.lang.String | getBill()
BillItemPK | getBillItemPk()
java.lang.String | getDescription()
java.math.BigDecimal | getOnhand()
java.math.BigDecimal | getQty()
void | setBill(java.lang.String bill)
void | setBillItemPk(BillItemPK billItemPk)
void | setDescription(java.lang.String description)
void | setOnhand(java.math.BigDecimal onhand)
void | setQty(java.math.BigDecimal qty)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BillWhereUsedItemResult

public BillWhereUsedItemResult()
Method Detail

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

setBillItemPk

public void setBillItemPk(BillItemPK billItemPk)

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

setDescription

public void setDescription(java.lang.String description)

setBill

public void setBill(java.lang.String bill)

getBillItemPk

public BillItemPK getBillItemPk()

getOnhand

public java.math.BigDecimal getOnhand()

getDescription

public java.lang.String getDescription()

getBill

public java.lang.String getBill()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BillWhereUsedResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BillWhereUsedResult

java.lang.Object
    extended by  bb.common.BillWhereUsedResult
All Implemented Interfaces:
java.io.Serializable
public class BillWhereUsedResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BillWhereUsedResult()
Method Summary
java.lang.String | getDescription()
java.util.Set<java.util.List<BillWhereUsedItemResult>> | getItems()
java.lang.String | getMakeBuy()
java.math.BigDecimal | getOndemand()
java.math.BigDecimal | getOnhand()
java.math.BigDecimal | getOnorder()
PartPK | getPartPk()
java.math.BigDecimal | getTotalQty()
void | setDescription(java.lang.String description)
void | setItems(java.util.Set<java.util.List<BillWhereUsedItemResult>> items)
void | setMakeBuy(java.lang.String makeBuy)
void | setOndemand(java.math.BigDecimal ondemand)
void | setOnhand(java.math.BigDecimal onhand)
void | setOnorder(java.math.BigDecimal onorder)
void | setPartPk(PartPK partPk)
void | setTotalQty(java.math.BigDecimal totalQty)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BillWhereUsedResult

public BillWhereUsedResult()
Method Detail

setPartPk

public void setPartPk(PartPK partPk)

setDescription

public void setDescription(java.lang.String description)

setItems

public void setItems(java.util.Set<java.util.List<BillWhereUsedItemResult>> items)

getPartPk

public PartPK getPartPk()

getDescription

public java.lang.String getDescription()

getItems

public java.util.Set<java.util.List<BillWhereUsedItemResult>> getItems()

getTotalQty

public java.math.BigDecimal getTotalQty()

setTotalQty

public void setTotalQty(java.math.BigDecimal totalQty)

getMakeBuy

public java.lang.String getMakeBuy()

setMakeBuy

public void setMakeBuy(java.lang.String makeBuy)

getOndemand

public java.math.BigDecimal getOndemand()

setOndemand

public void setOndemand(java.math.BigDecimal ondemand)

getOnhand

public java.math.BigDecimal getOnhand()

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

getOnorder

public java.math.BigDecimal getOnorder()

setOnorder

public void setOnorder(java.math.BigDecimal onorder)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BillWithPartInfoResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BillWithPartInfoResult

java.lang.Object
    extended by  bb.common.PartBasicInfo
        extended by  bb.common.BillWithPartInfoResult
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
BillDetailCostWithPartInfoResult, BillOnHandWithPartInfoResult
public class BillWithPartInfoResult
extends PartBasicInfo
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_BILLPK
static java.lang.String | ORDER_BY_CREATEDDATE
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_DRAWING
static java.lang.String | ORDER_BY_LASTCHANGEDATE
static java.lang.String | ORDER_BY_LASTCHANGEUSER
static java.lang.String | ORDER_BY_ORIGIN
static java.lang.String | ORDER_BY_STATUS
Fields inherited from class bb.common.PartBasicInfo
ORDER_BY_BILL, ORDER_BY_BUYERCODE, ORDER_BY_COMMODITYCODE, ORDER_BY_HOLD, ORDER_BY_LASTUSER, ORDER_BY_MAKEBUY, ORDER_BY_MODELNUMBER, ORDER_BY_ORGANIZATION, ORDER_BY_PARTNUMBER, ORDER_BY_PARTTYPE, ORDER_BY_PARTUNIT, ORDER_BY_PRODUCTCODE, ORDER_BY_SECURITYLEVEL, ORDER_BY_WEIGHT
Constructor Summary
BillWithPartInfoResult()
Method Summary
java.lang.String | getApprovedBy()
java.util.Date | getApprovedDate()
BillPK | getBillPk()
java.util.Date | getCreatedDate()
java.util.List<EngineeringChangeListResult> | getEcnList()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.util.List<PartManufacturerVO> | getPartManufacturer()
java.lang.String | getStatus()
java.lang.Byte | getTraceableLevel()
void | setApprovedBy(java.lang.String approvedBy)
void | setApprovedDate(java.util.Date approvedDate)
void | setBillPk(BillPK billPk)
void | setCreatedDate(java.util.Date createdDate)
void | setEcnList(java.util.List<EngineeringChangeListResult> ecnList)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setPartManufacturer(java.util.List<PartManufacturerVO> partManufacturer)
void | setStatus(java.lang.String status)
void | setTraceableLevel(java.lang.Byte traceableLevel)
Methods inherited from class bb.common.PartBasicInfo
equals, getBill, getBuyerCode, getCommodityCode, getCountryOrigin, getDescription, getDetectionStandard, getDrawing, getEngGroup, getHavePicture, getHold, getLastUser, getLeadTime, getMakeBuy, getMaterial, getModelNumber, getOrigin, getPartPk, getPartUnit, getProductCode, getRevision, getSaleable, getSalesDrawing, getSecurityLevel, getTraceable, getVolume, getVolumeUnit, getWeight, getWeightUnit, getWi, hashCode, setBill, setBuyerCode, setCommodityCode, setCountryOrigin, setDescription, setDetectionStandard, setDrawing, setEngGroup, setHavePicture, setHold, setLastUser, setLeadTime, setMakeBuy, setMaterial, setModelNumber, setOrigin, setPartPk, setPartUnit, setProductCode, setRevision, setSaleable, setSalesDrawing, setSecurityLevel, setTraceable, setVolume, setVolumeUnit, setWeight, setWeightUnit, setWi, toString
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_LASTCHANGEUSER

public static final java.lang.String ORDER_BY_LASTCHANGEUSER
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEDATE

public static final java.lang.String ORDER_BY_LASTCHANGEDATE
See Also:
Constant Field Values

ORDER_BY_BILLPK

public static final java.lang.String ORDER_BY_BILLPK
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_DRAWING

public static final java.lang.String ORDER_BY_DRAWING
See Also:
Constant Field Values

ORDER_BY_CREATEDDATE

public static final java.lang.String ORDER_BY_CREATEDDATE
See Also:
Constant Field Values

ORDER_BY_ORIGIN

public static final java.lang.String ORDER_BY_ORIGIN
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values
Constructor Detail

BillWithPartInfoResult

public BillWithPartInfoResult()
Method Detail

getBillPk

public BillPK getBillPk()

setBillPk

public void setBillPk(BillPK billPk)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()
Overrides:
getLastChangeDate in class PartBasicInfo

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)
Overrides:
setLastChangeDate in class PartBasicInfo

getTraceableLevel

public java.lang.Byte getTraceableLevel()

setTraceableLevel

public void setTraceableLevel(java.lang.Byte traceableLevel)

getCreatedDate

public java.util.Date getCreatedDate()

setCreatedDate

public void setCreatedDate(java.util.Date createdDate)

getPartManufacturer

public java.util.List<PartManufacturerVO> getPartManufacturer()

setPartManufacturer

public void setPartManufacturer(java.util.List<PartManufacturerVO> partManufacturer)

getApprovedBy

public java.lang.String getApprovedBy()

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)

getApprovedDate

public java.util.Date getApprovedDate()

setApprovedDate

public void setApprovedDate(java.util.Date approvedDate)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getEcnList

public java.util.List<EngineeringChangeListResult> getEcnList()

setEcnList

public void setEcnList(java.util.List<EngineeringChangeListResult> ecnList)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


B-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M N O P Q R S T U V W X Y Z

B

B - Static variable in class bb.common.Constant.AmountType
BACKFLUSH_LOCATION_FOR_DEPARTMENT_NOT_EXIST - Static variable in class bb.common.BIZReason
BACKFLUSH_MATERIAL - Static variable in class bb.common.BizTarget
BALANCE_SHEET - Static variable in class bb.common.BizTarget
BALANCE_SHEET - Static variable in class bb.common.Constant.CategoryReportType
BALANCE_SHEET - Static variable in class bb.common.Constant.MiscDocType
BALANCE_SHEET_PRE - Static variable in class bb.common.Constant.CategoryReportType
BALANCE_SHEET_SIDE_BY_SIDE - Static variable in class bb.common.Constant.MiscDocType
BalanceSheetSideBySideItemResult - Class in bb.common
BalanceSheetSideBySideItemResult() - Constructor for class bb.common.BalanceSheetSideBySideItemResult
BalanceSheetSideBySideResult - Class in bb.common
BalanceSheetSideBySideResult() - Constructor for class bb.common.BalanceSheetSideBySideResult
BANK - Static variable in class bb.common.Constant.ChartOfAccountSubType
BANK_RECONCILIATION_REPORT - Static variable in class bb.common.BizTarget
BANK_RECONCILIATION_REPORT_HAS_EXIST - Static variable in class bb.common.BIZReason
BANK_RECONCILIATION_REPORT_NOT_EXIST - Static variable in class bb.common.BIZReason
BankReconciliationReportVO - Class in bb.common
BankReconciliationReportVO() - Constructor for class bb.common.BankReconciliationReportVO
BASE_ROLE - Static variable in class bb.common.Constant
batchAddAccountsChartCategorysForBalanceSheet(List<AccountsChartCategoryVO>) - Method in interface bb.common.box.AccountingBox
batchAddAccountsChartCategorysForEbitda(List<AccountsChartCategoryVO>) - Method in interface bb.common.box.AccountingBox
batchAddAccountsChartCategorysForProfitLoss(List<AccountsChartCategoryVO>) - Method in interface bb.common.box.AccountingBox
batchAddAccountsChartCategorysForTaxDetail(List<AccountsChartCategoryVO>) - Method in interface bb.common.box.AccountingBox
batchApplyPrepay(List<AccountReceivableInfoWithPrepayResult>) - Method in interface bb.common.box.AccountingBox
batchApprovalGL(List<String>) - Method in interface bb.common.box.AccountingBox
batchCancelApprovalGL(List<String>) - Method in interface bb.common.box.AccountingBox
batchCloseNcrs(List<String>) - Method in interface bb.common.box.QualityBox
batchDisassembelWorkOrderGLByDwoItem(DisassembleWorkOrderItemPK[], String, String) - Method in interface bb.common.box.WorkOrderBox
batchMoveLocation(Map<PartOnhandPK, BigDecimal>, String) - Method in interface bb.common.box.WarehouseBox
batchUpdateAccountsChartCategorysForBalanceSheet(List<AccountsChartCategoryVO>) - Method in interface bb.common.box.AccountingBox
batchUpdateAccountsChartCategorysForEbitda(List<AccountsChartCategoryVO>) - Method in interface bb.common.box.AccountingBox
batchUpdateAccountsChartCategorysForProfitLoss(List<AccountsChartCategoryVO>) - Method in interface bb.common.box.AccountingBox
batchUpdateAccountsChartCategorysForTaxDetail(List<AccountsChartCategoryVO>) - Method in interface bb.common.box.AccountingBox
batchUpdateContractItemDiscount(String, BigDecimal) - Method in interface bb.common.box.SalesBox
batchUpdateExpiredDate(Date) - Method in interface bb.common.box.SecurityBox
batchUpdatePartsEngGroup(String, String, String, String) - Method in interface bb.common.box.EngineeringBox
batchUpdatePartsListPrice(BigDecimal, String) - Method in interface bb.common.box.EngineeringBox
batchUpdatePartWithOnhands(Map<PartPK, HashSet<PartOnhandVO>>) - Method in interface bb.common.box.EngineeringBox
BB - Static variable in class bb.common.Constant.AmountType
bb.common - package bb.common
bb.common.box - package bb.common.box
BB2_ROUND_MODE - Static variable in class bb.common.Constant
BB2_ZERO - Static variable in class bb.common.Constant
BB2_ZERO_double_VALUE - Static variable in class bb.common.Constant
BB2AttachFile - Class in bb.common
BB2AttachFile() - Constructor for class bb.common.BB2AttachFile
BB2BigDecimalAndString - Class in bb.common
BB2BigDecimalAndString(Float, String) - Constructor for class bb.common.BB2BigDecimalAndString
BB2BugNotice - Class in bb.common
BB2BugNotice() - Constructor for class bb.common.BB2BugNotice
BB2Document - Class in bb.common
BB2Document(String, String, String, String) - Constructor for class bb.common.BB2Document
BB2Document(String, String, String) - Constructor for class bb.common.BB2Document
BB2DocumentException - Exception in bb.common
BB2DocumentException(String, Reason) - Constructor for exception bb.common.BB2DocumentException
BB2DocumentException() - Constructor for exception bb.common.BB2DocumentException
BB2DocumentException(Exception, String, Reason) - Constructor for exception bb.common.BB2DocumentException
BB2DocumentException(Exception, String) - Constructor for exception bb.common.BB2DocumentException
BB2DocumentException(Exception) - Constructor for exception bb.common.BB2DocumentException
BB2DoubleCost - Class in bb.common
BB2DoubleCost() - Constructor for class bb.common.BB2DoubleCost
BB2DoubleCost(BigDecimal, BigDecimal) - Constructor for class bb.common.BB2DoubleCost
BB2DoubleString - Class in bb.common
BB2DoubleString() - Constructor for class bb.common.BB2DoubleString
BB2DoubleString(String, String) - Constructor for class bb.common.BB2DoubleString
BB2DoubleString(Float, String) - Constructor for class bb.common.BB2DoubleString
BB2Event - Class in bb.common
BB2Event(String, String, String, boolean) - Constructor for class bb.common.BB2Event
BB2Event(String, String, String) - Constructor for class bb.common.BB2Event
BB2Event(String, String) - Constructor for class bb.common.BB2Event
BB2Event(String) - Constructor for class bb.common.BB2Event
BB2File - Class in bb.common
BB2File() - Constructor for class bb.common.BB2File
BB2FiscalYearDate - Class in bb.common
BB2FiscalYearDate() - Constructor for class bb.common.BB2FiscalYearDate
BB2Login - Class in bb.common
BB2Login(String, String, String) - Constructor for class bb.common.BB2Login
BB2Login(String, String, String, String) - Constructor for class bb.common.BB2Login
BB2MessagingException - Exception in bb.common
BB2MessagingException(Exception) - Constructor for exception bb.common.BB2MessagingException
BB2MessagingException(Reason) - Constructor for exception bb.common.BB2MessagingException
BB2Notice - Class in bb.common
BB2Notice() - Constructor for class bb.common.BB2Notice
BB2Part - Class in bb.common
BB2Part() - Constructor for class bb.common.BB2Part
BB2Part(PartPK, String) - Constructor for class bb.common.BB2Part
BB2Part(String, String, String) - Constructor for class bb.common.BB2Part
BB2PartBasicInfo - Class in bb.common
BB2PartBasicInfo() - Constructor for class bb.common.BB2PartBasicInfo
BB2PartByDateResult - Class in bb.common
BB2PartByDateResult() - Constructor for class bb.common.BB2PartByDateResult
BB2PartInfo - Class in bb.common
BB2PartInfo() - Constructor for class bb.common.BB2PartInfo
BB2PartInSipItemResult - Class in bb.common
BB2PartInSipItemResult() - Constructor for class bb.common.BB2PartInSipItemResult
BB2PartInSipOfSoItemResult - Class in bb.common
BB2PartInSipOfSoItemResult() - Constructor for class bb.common.BB2PartInSipOfSoItemResult
BB2PartInSitItemResult - Class in bb.common
BB2PartInSitItemResult() - Constructor for class bb.common.BB2PartInSitItemResult
BB2PartInSTOItemResult - Class in bb.common
BB2PartInSTOItemResult() - Constructor for class bb.common.BB2PartInSTOItemResult
BB2PartInventoryResult - Class in bb.common
BB2PartInventoryResult() - Constructor for class bb.common.BB2PartInventoryResult
BB2PartInventoryResult(BB2Part) - Constructor for class bb.common.BB2PartInventoryResult
BB2PartMrpResult - Class in bb.common
BB2PartMrpResult() - Constructor for class bb.common.BB2PartMrpResult
BB2PartOnDemandListResult - Class in bb.common
BB2PartOnDemandListResult() - Constructor for class bb.common.BB2PartOnDemandListResult
BB2PartOnhandPK - Class in bb.common
BB2PartOnhandPK(BB2Part, String) - Constructor for class bb.common.BB2PartOnhandPK
BB2PartOnhandPK(PartPK, String, String) - Constructor for class bb.common.BB2PartOnhandPK
BB2PartOnLoanItemResult - Class in bb.common
BB2PartOnLoanItemResult() - Constructor for class bb.common.BB2PartOnLoanItemResult
BB2PartTotalInQADetailResult - Class in bb.common
BB2PartTotalInQADetailResult() - Constructor for class bb.common.BB2PartTotalInQADetailResult
BB2PartTotalInSipDetailResult - Class in bb.common
BB2PartTotalInSipDetailResult() - Constructor for class bb.common.BB2PartTotalInSipDetailResult
BB2PartTotalInSitDetailResult - Class in bb.common
BB2PartTotalInSitDetailResult() - Constructor for class bb.common.BB2PartTotalInSitDetailResult
BB2PartTotalInSTODetailResult - Class in bb.common
BB2PartTotalInSTODetailResult() - Constructor for class bb.common.BB2PartTotalInSTODetailResult
BB2PartTotalInWipDetailResult - Class in bb.common
BB2PartTotalInWipDetailResult() - Constructor for class bb.common.BB2PartTotalInWipDetailResult
BB2PartTotalOndemandDetailResult - Class in bb.common
BB2PartTotalOndemandDetailResult() - Constructor for class bb.common.BB2PartTotalOndemandDetailResult
BB2PartTotalOnhandDetailResult - Class in bb.common
BB2PartTotalOnhandDetailResult() - Constructor for class bb.common.BB2PartTotalOnhandDetailResult
BB2PartTotalOnloanDetailResult - Class in bb.common
BB2PartTotalOnloanDetailResult() - Constructor for class bb.common.BB2PartTotalOnloanDetailResult
BB2PartTotalOnorderDetailResult - Class in bb.common
BB2PartTotalOnorderDetailResult() - Constructor for class bb.common.BB2PartTotalOnorderDetailResult
BB2Picture - Class in bb.common
BB2Picture() - Constructor for class bb.common.BB2Picture
BB2QtyAndMoneyMap - Class in bb.common
BB2QtyAndMoneyMap() - Constructor for class bb.common.BB2QtyAndMoneyMap
BB2RefdocPK - Class in bb.common
BB2RefdocPK(String, String, String, String) - Constructor for class bb.common.BB2RefdocPK
BB2RefdocPK(RefdocVO) - Constructor for class bb.common.BB2RefdocPK
BB2ServerException - Exception in bb.common
BB2ServerException(Exception) - Constructor for exception bb.common.BB2ServerException
BB2ServerException(Exception, Object) - Constructor for exception bb.common.BB2ServerException
BB2ServerException(String) - Constructor for exception bb.common.BB2ServerException
BB2ServerException(String, Object) - Constructor for exception bb.common.BB2ServerException
BB2ServerException(Exception, Reason) - Constructor for exception bb.common.BB2ServerException
BB2ServerException(Exception, Reason, Object) - Constructor for exception bb.common.BB2ServerException
BB2ServerException(Reason) - Constructor for exception bb.common.BB2ServerException
BB2ServerException(Reason, Object) - Constructor for exception bb.common.BB2ServerException
BB2ServerException(String, Reason) - Constructor for exception bb.common.BB2ServerException
BB2ServerException(String, Reason, Object) - Constructor for exception bb.common.BB2ServerException
BB2Task - Class in bb.common
BB2Task(String, String, String, String) - Constructor for class bb.common.BB2Task
BB2TimeFactory - Class in bb.common
BB2TimeFactory() - Constructor for class bb.common.BB2TimeFactory
BB2tripleString - Class in bb.common
BB2tripleString(String, String, String) - Constructor for class bb.common.BB2tripleString
full constructor
BB2tripleString() - Constructor for class bb.common.BB2tripleString
default constructor
BB2Util - Class in bb.common
BB2WeightInfoResult - Class in bb.common
BB2WeightInfoResult() - Constructor for class bb.common.BB2WeightInfoResult
BB2Zip - Class in bb.common
BB2Zip() - Constructor for class bb.common.BB2Zip
BCB - Static variable in class bb.common.Constant.AmountType
BDB - Static variable in class bb.common.Constant.AmountType
BILL_CAN_NOT_CONTAINS_ITSELF - Static variable in class bb.common.BIZReason
BILL_TO_ID_IS_NOT_EXIST - Static variable in class bb.common.BIZReason
BillDetailCostResult - Class in bb.common
BillDetailCostResult() - Constructor for class bb.common.BillDetailCostResult
BillDetailCostWithPartInfoResult - Class in bb.common
BillDetailCostWithPartInfoResult() - Constructor for class bb.common.BillDetailCostWithPartInfoResult
BillDetailCostWithPartInfoResult(BillWithPartInfoResult) - Constructor for class bb.common.BillDetailCostWithPartInfoResult
BillItemDetailCostWithPartInfoResult - Class in bb.common
BillItemDetailCostWithPartInfoResult() - Constructor for class bb.common.BillItemDetailCostWithPartInfoResult
BillItemDetailCostWithPartInfoResult(BillItemWithPartInfoResult) - Constructor for class bb.common.BillItemDetailCostWithPartInfoResult
BillItemOnHandUsageResult - Class in bb.common
BillItemOnHandUsageResult() - Constructor for class bb.common.BillItemOnHandUsageResult
BillItemOnHandWithPartInfoResult - Class in bb.common
BillItemOnHandWithPartInfoResult() - Constructor for class bb.common.BillItemOnHandWithPartInfoResult
BillItemPK - Class in bb.common
BillItemPK(String, String, String) - Constructor for class bb.common.BillItemPK
full constructor
BillItemPK() - Constructor for class bb.common.BillItemPK
default constructor
BillItemReplacementVO - Class in bb.common
BillItemReplacementVO() - Constructor for class bb.common.BillItemReplacementVO
BillItemSalesCostResult - Class in bb.common
BillItemSalesCostResult() - Constructor for class bb.common.BillItemSalesCostResult
BillItemSalesResult - Class in bb.common
BillItemSalesResult() - Constructor for class bb.common.BillItemSalesResult
BillItemSalesXResult - Class in bb.common
BillItemSalesXResult() - Constructor for class bb.common.BillItemSalesXResult
BillItemUsagePathResult - Class in bb.common
BillItemUsagePathResult() - Constructor for class bb.common.BillItemUsagePathResult
BillItemUsageResult - Class in bb.common
BillItemUsageResult() - Constructor for class bb.common.BillItemUsageResult
BillItemVO - Class in bb.common
BillItemVO() - Constructor for class bb.common.BillItemVO
BillItemWithPartInfoResult - Class in bb.common
BillItemWithPartInfoResult() - Constructor for class bb.common.BillItemWithPartInfoResult
BillLogVO - Class in bb.common
BillLogVO() - Constructor for class bb.common.BillLogVO
BillOnHandWithPartInfoResult - Class in bb.common
BillOnHandWithPartInfoResult() - Constructor for class bb.common.BillOnHandWithPartInfoResult
BillPK - Class in bb.common
BillPK(String, String) - Constructor for class bb.common.BillPK
BillPK(PartPK) - Constructor for class bb.common.BillPK
BillPK() - Constructor for class bb.common.BillPK
BillSalesCostResult - Class in bb.common
BillSalesCostResult() - Constructor for class bb.common.BillSalesCostResult
BillSalesOfCostResult - Class in bb.common
BillSalesOfCostResult() - Constructor for class bb.common.BillSalesOfCostResult
BillSalesResult - Class in bb.common
BillSalesResult() - Constructor for class bb.common.BillSalesResult
BillSalesXResult - Class in bb.common
BillSalesXResult() - Constructor for class bb.common.BillSalesXResult
BillVO - Class in bb.common
BillVO(BillPK, String, String, Date, Date, Set) - Constructor for class bb.common.BillVO
full constructor
BillVO() - Constructor for class bb.common.BillVO
BillVO(BillPK, String, String, Set) - Constructor for class bb.common.BillVO
BillWhereUsedItemResult - Class in bb.common
BillWhereUsedItemResult() - Constructor for class bb.common.BillWhereUsedItemResult
BillWhereUsedResult - Class in bb.common
BillWhereUsedResult() - Constructor for class bb.common.BillWhereUsedResult
BillWithPartInfoResult - Class in bb.common
BillWithPartInfoResult() - Constructor for class bb.common.BillWithPartInfoResult
BIZBOX_USER - Static variable in class bb.common.BizTarget
BIZBOX_USER_ALREADY_EXIST - Static variable in class bb.common.BIZReason
BIZBOX_USER_HAS_NO_RULES - Static variable in class bb.common.BIZReason
BIZBOX_USER_IS_EMPLOYEE - Static variable in class bb.common.BIZReason
BIZBOX_USER_IS_LOCKED - Static variable in class bb.common.BIZReason
BIZBOX_USER_NOT_EMPLOYEE - Static variable in class bb.common.BIZReason
BIZBOX_USER_NOT_EXIST - Static variable in class bb.common.BIZReason
BIZBOX_USER_NOT_EXIST_FOR_THIS_EMPLOYEE - Static variable in class bb.common.BIZReason
BizboxBugChangesInfoVO - Class in bb.common
BizboxBugChangesInfoVO() - Constructor for class bb.common.BizboxBugChangesInfoVO
BizboxBugChangesVO - Class in bb.common
BizboxBugChangesVO() - Constructor for class bb.common.BizboxBugChangesVO
default constructor
BizboxBugInfoVO - Class in bb.common
BizboxBugInfoVO() - Constructor for class bb.common.BizboxBugInfoVO
default constructor
BizboxBugVO - Class in bb.common
BizboxBugVO() - Constructor for class bb.common.BizboxBugVO
BizBoxServer - Class in bb.common
BizBoxServer(String, String, String, String) - Constructor for class bb.common.BizBoxServer
BizBoxServer(String, String, String, String, String, String) - Constructor for class bb.common.BizBoxServer
BizBoxUserEmployeeResult - Class in bb.common
BizBoxUserEmployeeResult() - Constructor for class bb.common.BizBoxUserEmployeeResult
BizboxUserListResult - Class in bb.common
BizboxUserListResult() - Constructor for class bb.common.BizboxUserListResult
BizboxUserVO - Class in bb.common
BizboxUserVO() - Constructor for class bb.common.BizboxUserVO
BizboxUserVO(String, String, String) - Constructor for class bb.common.BizboxUserVO
BizException - Exception in bb.common
BizException(String, Reason) - Constructor for exception bb.common.BizException
BizException(String, Reason, Object) - Constructor for exception bb.common.BizException
BizException(Exception, String, Reason) - Constructor for exception bb.common.BizException
BizException(Exception, String, Reason, Object) - Constructor for exception bb.common.BizException
BizException(Exception, String) - Constructor for exception bb.common.BizException
BizException(Exception) - Constructor for exception bb.common.BizException
BIZReason - Class in bb.common
BIZReason() - Constructor for class bb.common.BIZReason
BizTarget - Class in bb.common
BizTarget() - Constructor for class bb.common.BizTarget
BOM - Static variable in class bb.common.BizTarget
BOM - Static variable in class bb.common.Constant.EngineeringSharingImportDataType
BOM - Static variable in class bb.common.Constant.PrintTemplateType
BOM_ALREADY_EXIST - Static variable in class bb.common.BIZReason
BOM_APPROVAL - Static variable in class bb.common.BizTarget
BOM_APPROVAL_ALREADY_EXIST - Static variable in class bb.common.BIZReason
BOM_APPROVAL_NOT_EXIST - Static variable in class bb.common.BIZReason
BOM_Cost - Static variable in class bb.common.Constant.PrintTemplateType
BOM_NOT_EXIST - Static variable in class bb.common.BIZReason
BOM_PARTS - Static variable in class bb.common.Constant
BomApprovalVO - Class in bb.common
BomApprovalVO() - Constructor for class bb.common.BomApprovalVO
BOMCanAssyAgent - Class in bb.common
BOMCanAssyAgent() - Constructor for class bb.common.BOMCanAssyAgent
BOMCanAssyListResult - Class in bb.common
BOMCanAssyListResult() - Constructor for class bb.common.BOMCanAssyListResult
BomItemWithOEMResult - Class in bb.common
BomItemWithOEMResult() - Constructor for class bb.common.BomItemWithOEMResult
BomPickListItemResult - Class in bb.common
BomPickListItemResult() - Constructor for class bb.common.BomPickListItemResult
BomPickListResult - Class in bb.common
BomPickListResult() - Constructor for class bb.common.BomPickListResult
BOMTreeRollUPMap - Class in bb.common
BOMTreeRollUPMap() - Constructor for class bb.common.BOMTreeRollUPMap
BomWithOEMResult - Class in bb.common
BomWithOEMResult() - Constructor for class bb.common.BomWithOEMResult
BUDGET - Static variable in class bb.common.BizTarget
BudgetListResult - Class in bb.common
BudgetListResult() - Constructor for class bb.common.BudgetListResult
Buy - Static variable in class bb.common.Constant.MakeBuy
BUYER_CODE - Static variable in class bb.common.BizTarget
BUYER_CODE_ALREADY_EXIST - Static variable in class bb.common.BIZReason
BUYER_CODE_DO_NOT_EXIST - Static variable in class bb.common.BIZReason
BUYER_CODE_IS_USING - Static variable in class bb.common.BIZReason
BuyerCodeVO - Class in bb.common
BuyerCodeVO() - Constructor for class bb.common.BuyerCodeVO
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M N O P Q R S T U V W X Y Z


BizboxBugChangesInfoVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BizboxBugChangesInfoVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.BizboxBugChangesInfoVO
All Implemented Interfaces:
java.io.Serializable
public class BizboxBugChangesInfoVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
BizboxBugChangesInfoVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAction()
java.lang.Integer | getBugId()
java.lang.String | getDescription()
java.lang.String | getExtension()
java.lang.String | getFixedBy()
java.util.Date | getFixedDate()
java.lang.Integer | getId()
java.lang.Integer | getLength()
java.lang.String | getStatus()
int | hashCode()
void | setAction(java.lang.String action)
void | setBugId(java.lang.Integer bugId)
void | setDescription(java.lang.String description)
void | setExtension(java.lang.String extension)
void | setFixedBy(java.lang.String fixedBy)
void | setFixedDate(java.util.Date fixedDate)
void | setId(java.lang.Integer id)
void | setLength(java.lang.Integer length)
void | setStatus(java.lang.String status)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

BizboxBugChangesInfoVO

public BizboxBugChangesInfoVO()
Method Detail

getId

public java.lang.Integer getId()

setId

public void setId(java.lang.Integer id)

getBugId

public java.lang.Integer getBugId()

setBugId

public void setBugId(java.lang.Integer bugId)

getAction

public java.lang.String getAction()

setAction

public void setAction(java.lang.String action)

getFixedBy

public java.lang.String getFixedBy()

setFixedBy

public void setFixedBy(java.lang.String fixedBy)

getFixedDate

public java.util.Date getFixedDate()

setFixedDate

public void setFixedDate(java.util.Date fixedDate)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

getStatus

public java.lang.String getStatus()

getLength

public java.lang.Integer getLength()

setStatus

public void setStatus(java.lang.String status)

setLength

public void setLength(java.lang.Integer length)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BizboxBugChangesVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BizboxBugChangesVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.BizboxBugChangesVO
All Implemented Interfaces:
java.io.Serializable
public class BizboxBugChangesVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
BizboxBugChangesVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAction()
byte[] | getAttachment()
java.lang.Integer | getBugId()
java.lang.String | getDescription()
java.lang.String | getExtension()
java.lang.String | getFixedBy()
java.util.Date | getFixedDate()
java.lang.Integer | getId()
java.lang.String | getStatus()
int | hashCode()
void | setAction(java.lang.String action)
void | setAttachment(byte[] attachment)
void | setBugId(java.lang.Integer bugId)
void | setDescription(java.lang.String description)
void | setExtension(java.lang.String extension)
void | setFixedBy(java.lang.String fixedBy)
void | setFixedDate(java.util.Date fixedDate)
void | setId(java.lang.Integer id)
void | setStatus(java.lang.String status)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

BizboxBugChangesVO

public BizboxBugChangesVO()
default constructor

Method Detail

getId

public java.lang.Integer getId()

setId

public void setId(java.lang.Integer id)

getBugId

public java.lang.Integer getBugId()

setBugId

public void setBugId(java.lang.Integer bugId)

getAction

public java.lang.String getAction()

setAction

public void setAction(java.lang.String action)

getFixedBy

public java.lang.String getFixedBy()

setFixedBy

public void setFixedBy(java.lang.String fixedBy)

getFixedDate

public java.util.Date getFixedDate()

setFixedDate

public void setFixedDate(java.util.Date fixedDate)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getAttachment

public byte[] getAttachment()

setAttachment

public void setAttachment(byte[] attachment)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BizboxBugInfoVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BizboxBugInfoVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.BizboxBugInfoVO
All Implemented Interfaces:
java.io.Serializable
public class BizboxBugInfoVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
BizboxBugInfoVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getBugDescription()
java.lang.String | getBugTitle()
java.util.Set | getChanges()
java.lang.String | getExtension()
java.lang.Integer | getId()
java.lang.String | getJreVersion()
java.lang.Integer | getLength()
java.lang.String | getModuleName()
java.lang.String | getOsType()
java.lang.String | getPriority()
java.lang.String | getReportBy()
java.util.Date | getReportDate()
java.lang.String | getScreenSize()
java.lang.String | getSeverity()
java.lang.String | getStatus()
int | hashCode()
void | setBugDescription(java.lang.String bugDescription)
void | setBugTitle(java.lang.String bugTitle)
void | setChanges(java.util.Set changes)
void | setExtension(java.lang.String extension)
void | setId(java.lang.Integer id)
void | setJreVersion(java.lang.String jreVersion)
void | setLength(java.lang.Integer length)
void | setModuleName(java.lang.String moduleName)
void | setOsType(java.lang.String osType)
void | setPriority(java.lang.String priority)
void | setReportBy(java.lang.String reportBy)
void | setReportDate(java.util.Date reportDate)
void | setScreenSize(java.lang.String screenSize)
void | setSeverity(java.lang.String severity)
void | setStatus(java.lang.String status)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

BizboxBugInfoVO

public BizboxBugInfoVO()
default constructor

Method Detail

getId

public java.lang.Integer getId()

setId

public void setId(java.lang.Integer id)

getBugTitle

public java.lang.String getBugTitle()

setBugTitle

public void setBugTitle(java.lang.String bugTitle)

getModuleName

public java.lang.String getModuleName()

setModuleName

public void setModuleName(java.lang.String moduleName)

getOsType

public java.lang.String getOsType()

setOsType

public void setOsType(java.lang.String osType)

getJreVersion

public java.lang.String getJreVersion()

setJreVersion

public void setJreVersion(java.lang.String jreVersion)

getScreenSize

public java.lang.String getScreenSize()

setScreenSize

public void setScreenSize(java.lang.String screenSize)

getReportBy

public java.lang.String getReportBy()

setReportBy

public void setReportBy(java.lang.String reportBy)

getReportDate

public java.util.Date getReportDate()

setReportDate

public void setReportDate(java.util.Date reportDate)

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getSeverity

public java.lang.String getSeverity()

setSeverity

public void setSeverity(java.lang.String severity)

getBugDescription

public java.lang.String getBugDescription()

setBugDescription

public void setBugDescription(java.lang.String bugDescription)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getLength

public java.lang.Integer getLength()

getChanges

public java.util.Set getChanges()

setLength

public void setLength(java.lang.Integer length)

setChanges

public void setChanges(java.util.Set changes)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BizboxBugVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BizboxBugVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.BizboxBugVO
All Implemented Interfaces:
java.io.Serializable
public class BizboxBugVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
BizboxBugVO()
Method Summary
boolean | equals(java.lang.Object other)
byte[] | getAttachment()
java.lang.String | getBugDescription()
java.lang.String | getBugTitle()
java.lang.String | getExtension()
java.lang.Integer | getId()
java.lang.String | getJreVersion()
java.lang.String | getModuleName()
java.lang.String | getOsType()
java.lang.String | getPriority()
java.lang.String | getReportBy()
java.util.Date | getReportDate()
java.lang.String | getScreenSize()
java.lang.String | getSeverity()
java.lang.String | getStatus()
int | hashCode()
void | setAttachment(byte[] attachment)
void | setBugDescription(java.lang.String bugDescription)
void | setBugTitle(java.lang.String bugTitle)
void | setExtension(java.lang.String extension)
void | setId(java.lang.Integer id)
void | setJreVersion(java.lang.String jreVersion)
void | setModuleName(java.lang.String moduleName)
void | setOsType(java.lang.String osType)
void | setPriority(java.lang.String priority)
void | setReportBy(java.lang.String reportBy)
void | setReportDate(java.util.Date reportDate)
void | setScreenSize(java.lang.String screenSize)
void | setSeverity(java.lang.String severity)
void | setStatus(java.lang.String status)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

BizboxBugVO

public BizboxBugVO()
Method Detail

getId

public java.lang.Integer getId()

setId

public void setId(java.lang.Integer id)

getBugTitle

public java.lang.String getBugTitle()

setBugTitle

public void setBugTitle(java.lang.String bugTitle)

getModuleName

public java.lang.String getModuleName()

setModuleName

public void setModuleName(java.lang.String moduleName)

getOsType

public java.lang.String getOsType()

setOsType

public void setOsType(java.lang.String osType)

getJreVersion

public java.lang.String getJreVersion()

setJreVersion

public void setJreVersion(java.lang.String jreVersion)

getScreenSize

public java.lang.String getScreenSize()

setScreenSize

public void setScreenSize(java.lang.String screenSize)

getReportBy

public java.lang.String getReportBy()

setReportBy

public void setReportBy(java.lang.String reportBy)

getReportDate

public java.util.Date getReportDate()

setReportDate

public void setReportDate(java.util.Date reportDate)

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getSeverity

public java.lang.String getSeverity()

setSeverity

public void setSeverity(java.lang.String severity)

getBugDescription

public java.lang.String getBugDescription()

setBugDescription

public void setBugDescription(java.lang.String bugDescription)

getAttachment

public byte[] getAttachment()

setAttachment

public void setAttachment(byte[] attachment)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BizBoxServer

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BizBoxServer

java.lang.Object
    extended by  bb.common.BizBoxServer
All Implemented Interfaces:
java.io.Serializable
public class BizBoxServer
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | LANGUAGE_CN
static java.lang.String | LANGUAGE_EN
static java.lang.String | PORT_DEFAULT
Constructor Summary
BizBoxServer(java.lang.String server, java.lang.String system, java.lang.String username, java.lang.String password)
BizBoxServer(java.lang.String server, java.lang.String port, java.lang.String system, java.lang.String username, java.lang.String password, java.lang.String languageCode)
Method Summary
java.lang.String | getLanguageCode()
java.lang.String | getPassword()
java.lang.String | getPort()
java.lang.String | getServer()
java.lang.String | getSystem()
java.lang.String | getUsername()
void | setLanguageCode(java.lang.String languageCode)
void | setPassword(java.lang.String password)
void | setPort(java.lang.String port)
void | setServer(java.lang.String server)
void | setSystem(java.lang.String system)
void | setUsername(java.lang.String username)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

PORT_DEFAULT

public static final java.lang.String PORT_DEFAULT
See Also:
Constant Field Values

LANGUAGE_EN

public static final java.lang.String LANGUAGE_EN
See Also:
Constant Field Values

LANGUAGE_CN

public static final java.lang.String LANGUAGE_CN
See Also:
Constant Field Values
Constructor Detail

BizBoxServer

public BizBoxServer(java.lang.String server,
                    java.lang.String system,
                    java.lang.String username,
                    java.lang.String password)

BizBoxServer

public BizBoxServer(java.lang.String server,
                    java.lang.String port,
                    java.lang.String system,
                    java.lang.String username,
                    java.lang.String password,
                    java.lang.String languageCode)
Method Detail

getLanguageCode

public java.lang.String getLanguageCode()

getPassword

public java.lang.String getPassword()

getPort

public java.lang.String getPort()

getServer

public java.lang.String getServer()

getSystem

public java.lang.String getSystem()

getUsername

public java.lang.String getUsername()

setUsername

public void setUsername(java.lang.String username)

setSystem

public void setSystem(java.lang.String system)

setServer

public void setServer(java.lang.String server)

setPort

public void setPort(java.lang.String port)

setPassword

public void setPassword(java.lang.String password)

setLanguageCode

public void setLanguageCode(java.lang.String languageCode)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BizBoxUserEmployeeResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BizBoxUserEmployeeResult

java.lang.Object
    extended by  bb.common.BizBoxUserEmployeeResult
All Implemented Interfaces:
java.io.Serializable
public class BizBoxUserEmployeeResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_COMMENT
static java.lang.String | ORDER_BY_DEPARTMENT
static java.lang.String | ORDER_BY_EMAIL
static java.lang.String | ORDER_BY_HOMEPHONE
static java.lang.String | ORDER_BY_MOBILE
static java.lang.String | ORDER_BY_PHONE
static java.lang.String | ORDER_BY_SYSTEMUSERNAME
static java.lang.String | ORDER_BY_TYPE
static java.lang.String | ORDER_BY_USERNAME
Constructor Summary
BizBoxUserEmployeeResult()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComment()
java.lang.String | getDepartment()
java.lang.String | getEmail()
java.lang.String | getFirstName()
java.lang.String | getFullName()
java.lang.String | getHomePhone()
java.lang.String | getLastName()
java.lang.String | getMiddleName()
java.lang.String | getMobile()
java.lang.String | getPhone()
java.lang.String | getRefId()
java.lang.String | getSystemUserName()
int | getType()
java.lang.String | getUserName()
int | hashCode()
boolean | isLocked()
void | setComment(java.lang.String comment)
void | setDepartment(java.lang.String department)
void | setEmail(java.lang.String email)
void | setFirstName(java.lang.String firstName)
void | setFullName(java.lang.String fullName)
void | setHomePhone(java.lang.String homePhone)
void | setLastName(java.lang.String lastName)
void | setLocked(boolean locked)
void | setMiddleName(java.lang.String middleName)
void | setMobile(java.lang.String mobile)
void | setPhone(java.lang.String phone)
void | setRefId(java.lang.String refId)
void | setSystemUserName(java.lang.String systemUserName)
void | setType(int type)
void | setUserName(java.lang.String userName)
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_USERNAME

public static final java.lang.String ORDER_BY_USERNAME
See Also:
Constant Field Values

ORDER_BY_SYSTEMUSERNAME

public static final java.lang.String ORDER_BY_SYSTEMUSERNAME
See Also:
Constant Field Values

ORDER_BY_TYPE

public static final java.lang.String ORDER_BY_TYPE
See Also:
Constant Field Values

ORDER_BY_DEPARTMENT

public static final java.lang.String ORDER_BY_DEPARTMENT
See Also:
Constant Field Values

ORDER_BY_PHONE

public static final java.lang.String ORDER_BY_PHONE
See Also:
Constant Field Values

ORDER_BY_EMAIL

public static final java.lang.String ORDER_BY_EMAIL
See Also:
Constant Field Values

ORDER_BY_MOBILE

public static final java.lang.String ORDER_BY_MOBILE
See Also:
Constant Field Values

ORDER_BY_HOMEPHONE

public static final java.lang.String ORDER_BY_HOMEPHONE
See Also:
Constant Field Values

ORDER_BY_COMMENT

public static final java.lang.String ORDER_BY_COMMENT
See Also:
Constant Field Values
Constructor Detail

BizBoxUserEmployeeResult

public BizBoxUserEmployeeResult()
Method Detail

getDepartment

public java.lang.String getDepartment()

setDepartment

public void setDepartment(java.lang.String department)

getEmail

public java.lang.String getEmail()

setEmail

public void setEmail(java.lang.String email)

getHomePhone

public java.lang.String getHomePhone()

setHomePhone

public void setHomePhone(java.lang.String homePhone)

isLocked

public boolean isLocked()

setLocked

public void setLocked(boolean locked)

getMobile

public java.lang.String getMobile()

setMobile

public void setMobile(java.lang.String mobile)

getPhone

public java.lang.String getPhone()

setPhone

public void setPhone(java.lang.String phone)

getRefId

public java.lang.String getRefId()

setRefId

public void setRefId(java.lang.String refId)

getSystemUserName

public java.lang.String getSystemUserName()

setSystemUserName

public void setSystemUserName(java.lang.String systemUserName)

getType

public int getType()

setType

public void setType(int type)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getComment

public java.lang.String getComment()

setComment

public void setComment(java.lang.String comment)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getFirstName

public java.lang.String getFirstName()

setFirstName

public void setFirstName(java.lang.String firstName)

getMiddleName

public java.lang.String getMiddleName()

setMiddleName

public void setMiddleName(java.lang.String middleName)

getLastName

public java.lang.String getLastName()

setLastName

public void setLastName(java.lang.String lastName)

getFullName

public java.lang.String getFullName()

setFullName

public void setFullName(java.lang.String fullName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BizboxUserListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BizboxUserListResult

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.BizboxUserListResult
All Implemented Interfaces:
java.io.Serializable
public class BizboxUserListResult
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_EXPIREDATE
static java.lang.String | ORDER_BY_LASTLOGIN
static java.lang.String | ORDER_BY_LOCKED
static java.lang.String | ORDER_BY_REFID
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_SYSTEMUSERNAME
static java.lang.String | ORDER_BY_TYPE
static java.lang.String | ORDER_BY_USERNAME
Constructor Summary
BizboxUserListResult()
Method Summary
short | getCanUpdateAnything()
java.lang.String | getComment()
java.util.Date | getCreateTime()
java.lang.String | getDepartment()
java.util.Date | getExpireDate()
java.lang.String | getIp()
java.util.Date | getLastLogin()
java.util.Date | getLastLogout()
java.lang.String | getRefId()
int | getStatus()
java.lang.String | getSystemUserName()
int | getType()
java.lang.String | getUserName()
boolean | isLocked()
void | setCanUpdateAnything(short canUpdateAnything)
void | setComment(java.lang.String comment)
void | setCreateTime(java.util.Date createTime)
void | setDepartment(java.lang.String department)
void | setExpireDate(java.util.Date expireDate)
void | setIp(java.lang.String ip)
void | setLastLogin(java.util.Date lastLogin)
void | setLastLogout(java.util.Date lastLogout)
void | setLocked(boolean locked)
void | setRefId(java.lang.String refId)
void | setStatus(int status)
void | setSystemUserName(java.lang.String systemUserName)
void | setType(int type)
void | setUserName(java.lang.String userName)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_USERNAME

public static final java.lang.String ORDER_BY_USERNAME
See Also:
Constant Field Values

ORDER_BY_SYSTEMUSERNAME

public static final java.lang.String ORDER_BY_SYSTEMUSERNAME
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_LASTLOGIN

public static final java.lang.String ORDER_BY_LASTLOGIN
See Also:
Constant Field Values

ORDER_BY_TYPE

public static final java.lang.String ORDER_BY_TYPE
See Also:
Constant Field Values

ORDER_BY_REFID

public static final java.lang.String ORDER_BY_REFID
See Also:
Constant Field Values

ORDER_BY_EXPIREDATE

public static final java.lang.String ORDER_BY_EXPIREDATE
See Also:
Constant Field Values

ORDER_BY_LOCKED

public static final java.lang.String ORDER_BY_LOCKED
See Also:
Constant Field Values
Constructor Detail

BizboxUserListResult

public BizboxUserListResult()
Method Detail

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getIp

public java.lang.String getIp()

setIp

public void setIp(java.lang.String ip)

getStatus

public int getStatus()

setStatus

public void setStatus(int status)

getLastLogin

public java.util.Date getLastLogin()

setLastLogin

public void setLastLogin(java.util.Date lastLogin)

getLastLogout

public java.util.Date getLastLogout()

setLastLogout

public void setLastLogout(java.util.Date lastLogout)

getCreateTime

public java.util.Date getCreateTime()

setCreateTime

public void setCreateTime(java.util.Date createTime)

getType

public int getType()

setType

public void setType(int type)

getRefId

public java.lang.String getRefId()

setRefId

public void setRefId(java.lang.String refId)

isLocked

public boolean isLocked()

setLocked

public void setLocked(boolean locked)

getExpireDate

public java.util.Date getExpireDate()

setExpireDate

public void setExpireDate(java.util.Date expireDate)

getComment

public java.lang.String getComment()

getCanUpdateAnything

public short getCanUpdateAnything()

setComment

public void setComment(java.lang.String comment)

setCanUpdateAnything

public void setCanUpdateAnything(short canUpdateAnything)

getSystemUserName

public java.lang.String getSystemUserName()

setSystemUserName

public void setSystemUserName(java.lang.String systemUserName)

getDepartment

public java.lang.String getDepartment()

setDepartment

public void setDepartment(java.lang.String department)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BizboxUserVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BizboxUserVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.BizboxUserVO
All Implemented Interfaces:
java.io.Serializable
public class BizboxUserVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_COMPANYUNITID
static java.lang.String | ORDER_BY_IP
static java.lang.String | ORDER_BY_LANIP
static java.lang.String | ORDER_BY_MACADDRESS
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_USERNAME
Constructor Summary
BizboxUserVO()
BizboxUserVO(java.lang.String userName, java.lang.String password, java.lang.String refId)
Method Summary
boolean | equals(java.lang.Object other)
short | getCanUpdateAnything()
java.lang.String | getComment()
java.lang.String | getCompanyUnitId()
java.util.Date | getCreateTime()
java.util.Date | getExpireDate()
java.lang.String | getIp()
java.lang.String | getLanIp()
java.util.Date | getLastChangePassword()
java.util.Date | getLastLogin()
java.util.Date | getLastLogout()
java.lang.String | getMacAddress()
java.lang.String | getMultiCompanyUnit()
java.lang.String | getPassword()
java.lang.String | getRefId()
int | getStatus()
int | getType()
java.lang.String | getUserName()
int | hashCode()
boolean | isLocked()
void | setCanUpdateAnything(short canUpdateAnything)
void | setComment(java.lang.String comment)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCreateTime(java.util.Date createTime)
void | setExpireDate(java.util.Date expireDate)
void | setIp(java.lang.String ip)
void | setLanIp(java.lang.String lanIp)
void | setLastChangePassword(java.util.Date lastChangePassword)
void | setLastLogin(java.util.Date lastLogin)
void | setLastLogout(java.util.Date lastLogout)
void | setLocked(boolean locked)
void | setMacAddress(java.lang.String macAddress)
void | setMultiCompanyUnit(java.lang.String multiCompanyUnit)
void | setPassword(java.lang.String password)
void | setRefId(java.lang.String refId)
void | setStatus(int status)
void | setType(int type)
void | setUserName(java.lang.String userName)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_USERNAME

public static final java.lang.String ORDER_BY_USERNAME
See Also:
Constant Field Values

ORDER_BY_IP

public static final java.lang.String ORDER_BY_IP
See Also:
Constant Field Values

ORDER_BY_MACADDRESS

public static final java.lang.String ORDER_BY_MACADDRESS
See Also:
Constant Field Values

ORDER_BY_LANIP

public static final java.lang.String ORDER_BY_LANIP
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_COMPANYUNITID

public static final java.lang.String ORDER_BY_COMPANYUNITID
See Also:
Constant Field Values
Constructor Detail

BizboxUserVO

public BizboxUserVO()

BizboxUserVO

public BizboxUserVO(java.lang.String userName,
                    java.lang.String password,
                    java.lang.String refId)
Method Detail

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getPassword

public java.lang.String getPassword()

setPassword

public void setPassword(java.lang.String password)

getIp

public java.lang.String getIp()

setIp

public void setIp(java.lang.String ip)

getStatus

public int getStatus()

setStatus

public void setStatus(int status)

getLastLogin

public java.util.Date getLastLogin()

setLastLogin

public void setLastLogin(java.util.Date lastLogin)

getLastLogout

public java.util.Date getLastLogout()

setLastLogout

public void setLastLogout(java.util.Date lastLogout)

getCreateTime

public java.util.Date getCreateTime()

setCreateTime

public void setCreateTime(java.util.Date createTime)

getType

public int getType()

setType

public void setType(int type)

getRefId

public java.lang.String getRefId()

setRefId

public void setRefId(java.lang.String refId)

isLocked

public boolean isLocked()

setLocked

public void setLocked(boolean locked)

getExpireDate

public java.util.Date getExpireDate()

setExpireDate

public void setExpireDate(java.util.Date expireDate)

getComment

public java.lang.String getComment()

getCanUpdateAnything

public short getCanUpdateAnything()

setComment

public void setComment(java.lang.String comment)

setCanUpdateAnything

public void setCanUpdateAnything(short canUpdateAnything)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getLanIp

public java.lang.String getLanIp()

setLanIp

public void setLanIp(java.lang.String lanIp)

getMacAddress

public java.lang.String getMacAddress()

setMacAddress

public void setMacAddress(java.lang.String macAddress)

getLastChangePassword

public java.util.Date getLastChangePassword()

setLastChangePassword

public void setLastChangePassword(java.util.Date lastChangePassword)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getMultiCompanyUnit

public java.lang.String getMultiCompanyUnit()

setMultiCompanyUnit

public void setMultiCompanyUnit(java.lang.String multiCompanyUnit)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BizException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BizException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  bb.common.BB2ServerException
                extended by  bb.common.BizException
All Implemented Interfaces:
java.io.Serializable
public class BizException
extends BB2ServerException

See Also:
Serialized Form

Field Summary
Fields inherited from class bb.common.BB2ServerException
UNKNOWN_EXCEPTION
Constructor Summary
BizException(java.lang.Exception e)
BizException(java.lang.Exception e, java.lang.String target)
BizException(java.lang.Exception e, java.lang.String target, Reason reason)
BizException(java.lang.Exception e, java.lang.String target, Reason reason, java.lang.Object parameter)
BizException(java.lang.String target, Reason reason)
BizException(java.lang.String target, Reason reason, java.lang.Object parameter)
Method Summary
static BizException | getBizException(DBAccessException ex, java.lang.String target, Reason reason)
java.lang.Object | getParameter()
java.lang.String | getTarget()
void | setParameter(java.lang.Object parameter)
Methods inherited from class bb.common.BB2ServerException
getReason
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

BizException

public BizException(java.lang.String target,
                    Reason reason)

BizException

public BizException(java.lang.String target,
                    Reason reason,
                    java.lang.Object parameter)

BizException

public BizException(java.lang.Exception e,
                    java.lang.String target,
                    Reason reason)

BizException

public BizException(java.lang.Exception e,
                    java.lang.String target,
                    Reason reason,
                    java.lang.Object parameter)

BizException

public BizException(java.lang.Exception e,
                    java.lang.String target)

BizException

public BizException(java.lang.Exception e)
Method Detail

getTarget

public java.lang.String getTarget()

getParameter

public java.lang.Object getParameter()
Overrides:
getParameter in class BB2ServerException

setParameter

public void setParameter(java.lang.Object parameter)
Overrides:
setParameter in class BB2ServerException

getBizException

public static BizException getBizException(DBAccessException ex,
                                           java.lang.String target,
                                           Reason reason)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BIZReason

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BIZReason

java.lang.Object
    extended by  bb.common.BIZReason

public class BIZReason
extends java.lang.Object

Field Summary
static Reason | ACCOUNT_CHART_CATEGORY_ALREADY_EXIST
static Reason | ACCOUNT_CHART_CATEGORY_NAME_ALREADY_EXIST
static Reason | ACCOUNT_CHART_CATEGORY_NAME_NOT_EXIST
static Reason | ACCOUNT_CHART_CATEGORY_NOT_EXIST
static Reason | ACCOUNT_CHART_MAPPING_ALREADY_EXIST
static Reason | ACCOUNT_CHART_MAPPING_NOT_EXIST
static Reason | ACCOUNT_CREDIT_DEBIT_WRONG
static Reason | ACCOUNT_FISCALYEAR_SETTING_NOT_EXIST
static Reason | ACCOUNT_MUST_BE_CURRENT_ASSET
static Reason | ACCOUNT_NUMBER_ALREADY_EXIST
static Reason | ACCOUNT_NUMBER_HAS_CHILD
static Reason | ACCOUNT_NUMBER_IN_USE
static Reason | ACCOUNT_NUMBER_IS_NOT_EXPENSE_ACCOUNT
static Reason | ACCOUNT_NUMBER_IS_USED_IN_ASSET
static Reason | ACCOUNT_NUMBER_IS_USED_IN_CREDIT
static Reason | ACCOUNT_NUMBER_IS_USED_IN_DEBIT
static Reason | ACCOUNT_NUMBER_NOT_EXIST
static Reason | ACCOUNT_NUMBER_USING_IN_OPEN_FISCAL_YEAR
static Reason | ACCOUNT_PAYABLE_NOT_EXIST
static Reason | ACCOUNT_SETTINGS_DID_NOT_SET_WIP_START_DATE
static Reason | ACCOUNT_SETTINGS_GA_COGS_WRONG
static Reason | ACCOUNT_SETTINGS_GA_PROFIT_FOR_CURRENT_YEAR_WRONG
static Reason | ACCOUNT_SETTINGS_GA_WIP_WRONG
static Reason | ACCOUNT_SETTINGS_NOT_EXIST
static Reason | ACCOUNT_SETTINGS_UNKNOWN_INVENTORY_COST_MOTHED
static Reason | ACCOUNT_TRANSACTION_TYPE_ALREADY_EXIST
static Reason | ACCOUNT_TRANSACTION_TYPE_NOT_EXIST
static Reason | ACCOUNT_TYPE_EMPTY
static Reason | ACCOUNTING_INFO_DOC_NOT_FIND
static Reason | ACCOUNTING_PERIOD_ALREADY_EXISTS
static Reason | ACCOUNTING_REPORTS_IN_THIS_FISCAL_YEAR__NEED_TO_BACK_UP
static Reason | ACCT_OF_PAYABLE_METHOD_IS_NULL
static Reason | ACCUMULATED_DEPR_ACCOUNT_EMPTY
static Reason | ADDRESS_CAN_NOT_USE_BACKFLUSH
static Reason | ADDRESS_ID_DOES_NOT_EXIST
static Reason | ADDRESS_ID_IS_DELETED
static Reason | ADDRESS_ID_IS_NOT_CUSTOMER
static Reason | ADDRESS_ID_USED_IN_AP
static Reason | ADDRESS_ID_USED_IN_AR
static Reason | ADDRESS_ID_USED_IN_PO
static Reason | ADDRESS_ID_USED_IN_QUOTE
static Reason | ADDRESS_ID_USED_IN_RFQ
static Reason | ADDRESS_ID_USED_IN_RMA
static Reason | ADDRESS_ID_USED_IN_RTV
static Reason | ADDRESS_ID_USED_IN_SO
static Reason | ADDRESS_ID_USED_IN_WO
static Reason | ADDRESS_QA_DOC_NOT_FIND
static Reason | ADMIN_ACCOUNT_CAN_NOT_BE_REMOVED
static Reason | ALREADY_LOGOUT
static Reason | ALREADY_WRITE_OFF
static Reason | AMORTIZATION_EXPENSE_ACCOUNT_EMPTY
static Reason | AP_PREPAY_ALREADY_CANCELLED
static Reason | AP_PREPAY_ALREADY_EXIST
static Reason | AP_PREPAY_ALREDAY_APPLY
static Reason | AP_PREPAY_ALREDAY_PAID
static Reason | AP_PREPAY_BIGGER_THAN_PO_TOTAL
static Reason | AP_PREPAY_GL_IS_NOT_ENOUGH
static Reason | AP_PREPAY_PAID_BIGGER_THAN_PO_TOTAL
static Reason | APDM_APPROVED_BY_CAN_NOT_BE_EMPTY
static Reason | APDM_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY
static Reason | APP_COLUMN_NAME_SHOULD_START_WITH_APP
static Reason | APP_ITEM_NOT_EXIST
static Reason | APP_TABLE_NAME_SHOULD_START_WITH_APP
static Reason | APPROVED_ACTION_IS_FORBIDDEN_WHEN_UPDATE
static Reason | APPROVED_IS_FORBIDDEN_WHEN_UPDATE
static Reason | APPROVED_OBJECT_NOT_ALLOW_UPDATE_AGAIN
static Reason | AR_IS_CLOSED
static Reason | AR_PREPAY_ALREADY_EXIST
static Reason | AR_PREPAY_ALREDAY_PAID
static Reason | AR_PREPAY_BIGGER_THAN_SO_TOTAL
static Reason | AR_PREPAY_GL_IS_NOT_ENOUGH
static Reason | ARCM_APPROVED_BY_CAN_NOT_BE_EMPTY
static Reason | ARCM_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY
static Reason | ASSET_ACCUMULATED_DEPRECIATION_OVER
static Reason | ASSET_ACQUISITION_COST_LESS_THAN_INITIAL_DEPRECIATE_COST
static Reason | ASSET_APPROVED_BY_CAN_NOT_BE_EMPTY
static Reason | ASSET_DEPRECIATE_ALREADY_EXIST
static Reason | ASSET_DEPRECIATE_HAVE_MADE_GL
static Reason | ASSET_HAS_EXIST
static Reason | ASSET_INITIAL_DEPRECIATE_COST_LESS_THAN_DEPRECIATED_ACCM
static Reason | ASSET_NOT_EXIST
static Reason | ASSET_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY
static Reason | ASSET_TYPE_ALREADY_EXIST
static Reason | ASSET_TYPE_IS_ALREADY_USED
static Reason | AUTHORIZATION_REQUIRED
static Reason | BACKFLUSH_LOCATION_FOR_DEPARTMENT_NOT_EXIST
static Reason | BANK_RECONCILIATION_REPORT_HAS_EXIST
static Reason | BANK_RECONCILIATION_REPORT_NOT_EXIST
static Reason | BILL_CAN_NOT_CONTAINS_ITSELF
static Reason | BILL_TO_ID_IS_NOT_EXIST
static Reason | BIZBOX_USER_ALREADY_EXIST
static Reason | BIZBOX_USER_HAS_NO_RULES
static Reason | BIZBOX_USER_IS_EMPLOYEE
static Reason | BIZBOX_USER_IS_LOCKED
static Reason | BIZBOX_USER_NOT_EMPLOYEE
static Reason | BIZBOX_USER_NOT_EXIST
static Reason | BIZBOX_USER_NOT_EXIST_FOR_THIS_EMPLOYEE
static Reason | BOM_ALREADY_EXIST
static Reason | BOM_APPROVAL_ALREADY_EXIST
static Reason | BOM_APPROVAL_NOT_EXIST
static Reason | BOM_NOT_EXIST
static Reason | BUYER_CODE_ALREADY_EXIST
static Reason | BUYER_CODE_DO_NOT_EXIST
static Reason | BUYER_CODE_IS_USING
static Reason | CALCULATE_NEW_CSI_NUMBER_ERROR
static Reason | CALCULATE_NEW_DEBIT_MEMO_NUMBER_ERROR
static Reason | CALCULATE_NEW_EXPENSES_NUMBER_ERROR
static Reason | CALCULATE_NEW_LOAN_NUMBER_ERROR
static Reason | CALCULATE_NEW_PAYMENT_RUN_NUMBER_ERROR
static Reason | CALCULATE_NEW_QUOTE_ERROR
static Reason | CALCULATE_NEW_RFC_NUMBER_ERROR
static Reason | CALCULATE_NEW_RRMA_NUMBER_ERROR
static Reason | CALCULATE_NEW_SALES_ORDER_ERROR
static Reason | CAN_NOT_ADD_NEW_IR_ITEM
static Reason | CAN_NOT_ADD_NEW_PAYABLE_METHOD
static Reason | CAN_NOT_APPROVE_ERROR_GL
static Reason | CAN_NOT_APPROVE_GL_CREATED_BY_YOURSELF
static Reason | CAN_NOT_BE_RECEIVED
static Reason | CAN_NOT_CANCEL_AP_WITH_PAYMENT
static Reason | CAN_NOT_CANCEL_AR_WITH_RECEIVED_PAYMENT
static Reason | CAN_NOT_CANCEL_GL_APPROVED_BY_OTHER
static Reason | CAN_NOT_CANCEL_THE_OPEN_ORDER
static Reason | CAN_NOT_CHANGE_DISASSEMBLE_WORK_ORDER_ITEM_QTY_ISSUED
static Reason | CAN_NOT_CHANGE_IR_QUALITIFY_QTY
static Reason | CAN_NOT_CHANGE_PART_FOR_DWO_HAS_ISSUED
static Reason | CAN_NOT_CHANGE_PART_FOR_HAS_ISSUED
static Reason | CAN_NOT_CHANGE_PART_FOR_HAS_RECEIVED
static Reason | CAN_NOT_CHANGE_PART_FOR_HAS_SHIPPED
static Reason | CAN_NOT_CHANGE_STATUS
static Reason | CAN_NOT_CHANGE_THE_FISCAL_YEAR_SETTINGS
static Reason | CAN_NOT_CHANGE_THIS_MONTH_EXCHANGE_RATE
static Reason | CAN_NOT_CHANGE_TRANSFER_TYPE
static Reason | CAN_NOT_CHANGE_WORK_ORDER_ITEM_QTY_ASM
static Reason | CAN_NOT_COPY_NOT_APPROVED_ECR
static Reason | CAN_NOT_COPY_PURCHASE_ORDER_FROM_CLOSED_SALES_ORDER_OR_NOT_REVIEW_SALES_ORDER
static Reason | CAN_NOT_COPY_WORK_ORDER_FROM_CLOSED_SALES_ORDER_OR_NOT_REVIEW_SALES_ORDER
static Reason | CAN_NOT_DELETE_DEFAULT_WI
static Reason | CAN_NOT_DELETE_DISASSEMBLE_WORK_ORDER_ITEM
static Reason | CAN_NOT_DELETE_ISSUED_RECORD
static Reason | CAN_NOT_DELETE_NONPRODUCTIVE_PICKING_ITEM
static Reason | CAN_NOT_DELETE_PREDEFINED_CHART_ACCOUNT_CATEGORY
static Reason | CAN_NOT_DELETE_REF_DOC_IN_IR
static Reason | CAN_NOT_DELETE_SWA_SHIPPER_ITEM
static Reason | CAN_NOT_DELETE_SWAP_ORDER_ITEM
static Reason | CAN_NOT_DELETE_THE_FISCAL_YEAR_SETTINGS
static Reason | CAN_NOT_DELETE_TRANSFER_ORDER_ITEM
static Reason | CAN_NOT_DELETE_TRANSFER_SHIPPER_ITEM
static Reason | CAN_NOT_DELETE_WORK_ORDER_ITEM
static Reason | CAN_NOT_ERROR_OR_CANCEL_GL_CREATED_BY_YOURSELF
static Reason | CAN_NOT_FIND_ACCOUNTING_INFO_DOC_SETTINGS
static Reason | CAN_NOT_FIND_ADDRESS_QA_DOC_SETTINGS
static Reason | CAN_NOT_FIND_CS_ITEM_DOC_SETTINGS
static Reason | CAN_NOT_FIND_CUSTOMER_DOC_SETTINGS
static Reason | CAN_NOT_FIND_DOCUMENT
static Reason | CAN_NOT_FIND_DOCUMENT_SETTINGS
static Reason | CAN_NOT_FIND_DWF_SETTINGS
static Reason | CAN_NOT_FIND_DWG_SETTINGS
static Reason | CAN_NOT_FIND_EDC_DOC_SETTINGS
static Reason | CAN_NOT_FIND_EMP_TRAINING_RECORDS_SETTINGS
static Reason | CAN_NOT_FIND_INIT_FILE
static Reason | CAN_NOT_FIND_QT_DOC_SETTINGS
static Reason | CAN_NOT_FIND_RMA_DOC_SETTINGS
static Reason | CAN_NOT_FIND_SO_DOC_SETTINGS
static Reason | CAN_NOT_FIND_VENDOR_DOC_SETTINGS
static Reason | CAN_NOT_FIND_VENDOR_PART
static Reason | CAN_NOT_FIND_YOUR_TRUE_NAME
static Reason | CAN_NOT_GET_SYSTEM_INFO
static Reason | CAN_NOT_HAVE_WORK_ORDER_ITEM_QTY_ASM
static Reason | CAN_NOT_LINK_TO_MORE_THAN_ONE_ORDERS
static Reason | CAN_NOT_NULL
static Reason | CAN_NOT_RECEIVE_NA_AND_OTHER_PART_AT_SAME_TIME
static Reason | CAN_NOT_UPDATE_SHIPPED_PACKING_BOX
static Reason | CAN_NOT_ZERO_SIZE_FILE
static Reason | CAN_ONLY_APPROVE_NOT_APPROVED_OPERATING_INSTRUCTION
static Reason | CAN_ONLY_CLOSE_FINISH_INSPECTIONFOR_OPERATING_INSTRUCTION
static Reason | CAN_ONLY_COMMIT_FINISHED_WORKSHEET
static Reason | CAN_ONLY_COMMIT_OPEN_WORKSHEET
static Reason | CAN_ONLY_CONTINUE_PAUSED_OPERATING_INSTRUCTION
static Reason | CAN_ONLY_CREATE_INSPECTION_REPORT_FROM_REQUEST_INSPECTIONFOR_OPERATING_INSTRUCTION
static Reason | CAN_ONLY_FINISH_OPEN_OPERATING_INSTRUCTION
static Reason | CAN_ONLY_OVER_CARRYING_COMMITTED_WORKSHEET
static Reason | CAN_ONLY_PAUSE_OPEN_OPERATING_INSTRUCTION
static Reason | CAN_ONLY_REQUEST_INSPECTIONFOR_FINISH_OPERATING_INSTRUCTION
static Reason | CAN_ONLY_UPDATE_WAITING_WORKSHEET
static Reason | CARRIER_ALREADY_EXIST
static Reason | CARRIER_NOT_EXIST
static Reason | CARRIER_USING_BY_PO
static Reason | CARRIER_USING_BY_RMA
static Reason | CARRIER_USING_BY_RTV
static Reason | CARRIER_USING_BY_SO
static Reason | CASH_OR_BANK_BALANCE_CAN_BE_NEGATIVE
static Reason | CASHIER_ALREADY_EXIST
static Reason | CATALOG_ALREADY_EXIST
static Reason | CATALOG_IS_USED
static Reason | CATALOG_NOT_EXIST
static Reason | CATEGORY_ID_HAS_EXIST
static Reason | CATEGORY_ID_NOT_EXIST
static Reason | CATEGORY_ID_STILL_USED
static Reason | CATEGORY_INDEX_ALREADY_EXIST_IN_PARENT_CATEGORY
static Reason | CERTIFICATE_DESCRIPTION_ALREADY_EXIST
static Reason | CERTIFICATE_DESCRIPTION_IS_NOT_USING
static Reason | CERTIFICATE_DESCRIPTION_IS_USING
static Reason | CERTIFICATE_DESCRIPTION_NOT_EXIST
static Reason | CERTIFICATE_DOC_NOT_FIND
static Reason | CERTIFICATE_NUMBER_IS_USED
static Reason | CHANGE_STD_COST_WORKSHEET_NOT_EXIST
static Reason | CHECK_NUMBER_ALREADY_EXIST
static Reason | CHECK_NUMBER_NOT_EXIST
static Reason | CHECK_NUMBER_NOT_MATCH
static Reason | CHECK_OBJECT_EXIST_ERROR
static Reason | CHECK_RUN_ALREADY_COMMITTED
static Reason | CHECK_RUN_ALREADY_EXIST
static Reason | CHECK_RUN_NOT_EXIST
static Reason | CLEAR_REFERENCE_DOC_ERROR
static Reason | CLOSED_OBJECT_CAN_NOT_ALLOWED_IF_ITEM_NOT_FINISHED
static Reason | CLOSED_OBJECT_NOT_ALLOW_UPDATE_AGAIN
static Reason | CLOSEING_STATEMENT_WRONG
static Reason | COMPANY_NOT_EXIST
static Reason | COMPANY_UNIT_ACCOUNT_ALREADY_EXIST
static Reason | COMPANY_UNIT_ACCOUNT_NOT_EXIST
static Reason | COMPANY_UNIT_ALREADY_EXIST
static Reason | COMPANY_UNIT_DOES_NOT_MATCH
static Reason | COMPANY_UNIT_NOT_EXIST
static Reason | CONTRACT_PRICE_CUSTOMER_HAS_EXIST
static Reason | CONTRACT_PRICE_CUSTOMER_NOT_EXIST
static Reason | CONTRACT_PRICE_HAS_EXIST
static Reason | CONTRACT_PRICE_ITEM_HAS_EXIST
static Reason | CONTRACT_PRICE_ITEM_NOT_EXIST
static Reason | CONTRACT_PRICE_NOT_EXIST
static Reason | COST_CAN_NOT_BE_ZERO
static Reason | CREATE_DIRECTORY_FAILED
static Reason | CREDIT_MEMO_ALREADY_EXIST
static Reason | CREDIT_MEMO_NOT_EXIST
static Reason | CS_ITEM_DOC_NOT_FIND
static Reason | CURRENCY_ALREADY_EXIST
static Reason | CURRENCY_EXCHANGE_MUST_BE_ONE
static Reason | CURRENCY_EXCHANGE_NOT_EXIST
static Reason | CURRENCY_EXCHANGE_SHOULD_BE_POSITIVE
static Reason | CURRENCY_NOT_EXIST
static Reason | CUSTOMER_DOC_NOT_FIND
static Reason | CUSTOMER_FEEDBACK_ALREADY_EXIST
static Reason | CUSTOMER_FEEDBACK_ITEM_ALREADY_EXIST
static Reason | CUSTOMER_FEEDBACK_ITEM_NOT_EXIST
static Reason | CUSTOMER_FEEDBACK_NOT_EXIST
static Reason | CUSTOMER_NOT_EXIST_TERM
static Reason | CUSTOMER_PART_CATALOG_ALREADY_EXIST
static Reason | CUSTOMER_PART_CATALOG_NOT_EXIST
static Reason | CUSTOMER_PART_NOT_EXIST
static Reason | CUSTOMER_SERVICE_INCIDENT_ALREADY_EXIST
static Reason | CUSTOMER_SERVICE_INCIDENT_NOT_EXIST
static Reason | CUSTOMER_SERVICE_REQUEST_NOT_EXIST
static Reason | CUSTOMER_VENDOR_TYPE_ALREADY_EXIST
static Reason | CUSTOMER_VENDOR_TYPE_NOT_EXIST
static Reason | CYCLE_WORK_SHEET_ALREADY_CLOSED
static Reason | CYCLE_WORK_SHEET_HAS_EXIST
static Reason | CYCLE_WORK_SHEET_NOT_EXIST
static Reason | CYCLE_WORK_SHEET_NUMBER_REQUIRE
static Reason | CYCLE_WORK_SHEET_PAGE_NUMBER_HAS_EXIST
static Reason | CYCLE_WORK_SHEET_PAGE_NUMBER_NOT_EXIST
static Reason | DATE_CAN_NOT_BE_NULL
static Reason | DATE_WRONG
static Reason | DEBITS_NOT_MATCH_CREDITS
static Reason | DEBITS_OR_CREDIT_DOES_NOT_ZERO
static Reason | DEFAULT_MFG_IS_EMPTY
static Reason | DELETE_FROM_DB_ERROR
static Reason | DELETE_ON_LOAN_ITEM_ERROR
static Reason | DELETE_PICTURE_FIRST
static Reason | DELETE_QUOTE_ITEM_ERROR
static Reason | DELETE_RMA_ITEM_ERROR
static Reason | DELETE_SALES_ORDER_ITEM_ERROR
static Reason | DEPARTMENT_LOCATION_FOR_BACKFLUSH_ALREADY_ADDED
static Reason | DEPARTMENT_LOCATION_FOR_BACKFLUSH_NOT_EXIST
static Reason | DESIGN_CONTROL_NOT_EXIST
static Reason | DESTINATION_NOT_EXIST
static Reason | DIRECTORY_NOT_EXIST
static Reason | DISASSEMBLE_WORK_ORDER_ALREADY_SETUP_OR_RUN
static Reason | DISASSEMBLE_WORK_ORDER_APPROVAL_ALREADY_EXIST
static Reason | DISASSEMBLE_WORK_ORDER_APPROVAL_NOT_EXIST
static Reason | DISASSEMBLE_WORK_ORDER_ITEM_GL_HAS_CREATED
static Reason | DISASSEMBLE_WORK_ORDER_ITEM_HAS_CLOSED
static Reason | DISASSEMBLE_WORK_ORDER_ITEM_HAS_NOT_CLOSED
static Reason | DISASSEMBLE_WORK_ORDER_ITEM_NOT_EXIST
static Reason | DISASSEMBLE_WORK_ORDER_ITEM_NOT_OPEN
static Reason | DISASSEMBLE_WORK_ORDER_ITEM_RECEIVED_QTY_IS_OVER
static Reason | DISASSEMBLE_WORK_ORDER_ITEM_RECEIVER_NOT_EXIST
static Reason | DISASSEMBLE_WORK_ORDER_NOT_EXIST
static Reason | DISASSEMBLE_WORK_ORDER_NOT_OPEN
static Reason | DOCUMENT_NOT_FOUND
static Reason | DOCUMENT_SERVER_SETTINGS_ALREADY_EXIST
static Reason | DOCUMENT_SETTINGS_NOT_EXIST
static Reason | DOCUMENT_SETTINGS_NOT_SAVE_TO_FTP
static Reason | DOCUMENT_SETTINGS_WRONG
static Reason | DOES_NOT_SET_UNBILLED_ACCOUNT
static Reason | DOES_NOT_SET_UNBILLED_INCOME_ACCOUNT
static Reason | DRAWING_WAS_DAMEDAGED
static Reason | DUPLICATE_ITEM
static Reason | DUPLICATE_KEY_ITEM
static Reason | DUPLICATE_LOGIN
static Reason | DUPLICATE_MPN
static Reason | DUPLICATE_PERIOD_ID
static Reason | DUPLICATE_REVISION_LETTERS
static Reason | DWO_ITEM_RETURN_QTY_IS_OVER
static Reason | ECN_REVIEW_ALREADY_EXIST
static Reason | ECN_REVIEW_NOT_EXIST
static Reason | ECR_APPROVAL_ALREADY_EXIST
static Reason | ECR_APPROVAL_NOT_EXIST
static Reason | EDC_DOC_NOT_FIND
static Reason | EJB_INVOKE_FAILED
static Reason | EMP_TRAINING_RECORDS_NOT_FIND
static Reason | EMPLOYEE_ALREADY_ADDED
static Reason | EMPLOYEE_ALREADY_HAS_BIZBOX_USER_ACCOUNT
static Reason | EMPLOYEE_HAS_NO_BIZBOX_USER_ACCOUNT
static Reason | EMPLOYEE_ID_NOT_EXIST
static Reason | EMPLOYEE_TRAINING_ID_HAS_EXIST
static Reason | EMPLOYEE_TRAINING_ID_NOT_EXIST
static Reason | EMPTY_COLLECTION
static Reason | EMPTY_DOCUMENT
static Reason | EMPTY_GL_OR_ZERO_GL_ITEM
static Reason | EMPTY_ITEM_COLLECTION
static Reason | END_DATE_SHOULD_BE_BEFORE_THE_FOLLOW_FISCAL_YEAR_START_DATE
static Reason | END_MONTH_CAN_NOT_BE_EARLIER_THAN_START_MONTH
static Reason | ENG_GROUP_USED_IN_ENG_GROUP_USER
static Reason | ENG_GROUP_USED_IN_PART
static Reason | ENGINEERING_CHANGE_NOTICE_NOT_CLOSED_EXIST_FOR_THIS_PART
static Reason | ENGINEERING_CHANGE_NOTICE_NOT_EXIST
static Reason | ENGINEERING_CHANGE_REQUEST_NOT_EXIST
static Reason | ENGINEERING_SHARING_ALREADY_EXIST
static Reason | ENGINEERING_SHARING_ITEM_ALREADY_EXIST
static Reason | ENGINEERING_SHARING_NOT_EXIST
static Reason | ENGROUP_EXIST
static Reason | ENGROUP_HAS_ITEM
static Reason | ENGROUP_NOT_EXIST
static Reason | ENGROUP_USER_EXIST
static Reason | ENGROUP_USER_NOT_EXIST
static Reason | EQUIPMENT_ALREADY_EXIST
static Reason | EQUIPMENT_ALREADY_REF_TO_ASSET
static Reason | EQUIPMENT_ALREADY_USED_IN_WORK_CENTER
static Reason | EQUIPMENT_NOT_EXIST
static Reason | ERROR_GL_CAN_NOT_POST
static Reason | EXCEED_AUTHORIZED_APPROVAL_LIMIT
static Reason | EXCHANGE_RATE_IN_FISCAL_YEAR
static Reason | EXCHANGE_RATE_NOT_SETUP
static Reason | EXCHANGERATE_APPROVED_BY_BY_CAN_NOT_BE_EMPTY
static Reason | EXCHANGERATE_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY
static Reason | EXPENSE_ACCOUNT_ALREADY_EXIST
static Reason | EXPENSE_ACCOUNT_NOT_EXIST
static Reason | EXPENSE_ALREADY_EXIST
static Reason | EXPENSE_NOT_EXIST
static Reason | FAIL_LOGIN
static Reason | FEEDBACK_QUESTION_ALREADY_EXIST
static Reason | FEEDBACK_QUESTION_IN_USING
static Reason | FEEDBACK_QUESTION_NOT_EXIST
static Reason | FILE_SYSTEM_OPERATION_FAILED
static Reason | FINANCING_EXPENSE_ACCOUNT_NOT_EXIST
static Reason | FIND_ACCOUNT_NUMBER_ERROR
static Reason | FIND_ACCOUNTING_SETTINGS_ERROR
static Reason | FIND_ADDRESS_ID_ERROR
static Reason | FIND_AP_CHECK_RUN_ERROR
static Reason | FIND_AP_ERROR
static Reason | FIND_APP_ERROR
static Reason | FIND_APP_ITEM_ERROR
static Reason | FIND_ARP_ERROR
static Reason | FIND_ARP_ITEM_ERROR
static Reason | FIND_BALANCE_SHEET_ERROR
static Reason | FIND_BIZBOX_USER_ERROR
static Reason | FIND_CAR_ERROR
static Reason | FIND_CARRIER_ERROR
static Reason | FIND_COMPANY_SETTINGS_ERROR
static Reason | FIND_CONTRACT_PRICE_ERROR
static Reason | FIND_CREDIT_MEMO_ERROR
static Reason | FIND_CURRENCY_ERROR
static Reason | FIND_DB_ERROR
static Reason | FIND_DEBIT_MEMO_ERROR
static Reason | FIND_EMPLOYEE_ID_ERROR
static Reason | FIND_FISCALYEAR_ERROR
static Reason | FIND_GENERAL_LEDGER_ERROR
static Reason | FIND_GENERAL_LEDGER_SETTINGS
static Reason | FIND_INCOTERMS_ERROR
static Reason | FIND_INSPECTION_TYPE_ERROR
static Reason | FIND_INVOICE_ERROR
static Reason | FIND_MANUFACTURER_ID_ERROR
static Reason | FIND_NCR_ERROR
static Reason | FIND_ON_LOAN_ERROR
static Reason | FIND_ON_LOAN_ITEM_ERROR
static Reason | FIND_PAR_ERROR
static Reason | FIND_PART_DESCRIPTION_ERROR
static Reason | FIND_PART_DISCOUNT_ERROR
static Reason | FIND_PARTPK_ERROR
static Reason | FIND_PAYMENT_RUN_ERROR
static Reason | FIND_POS_ERROR
static Reason | FIND_PURCHASE_ORDER_ERROR
static Reason | FIND_QUOTE_ERROR
static Reason | FIND_QUOTE_ITEM_ERROR
static Reason | FIND_RECEIVER_ERROR
static Reason | FIND_RMA_ERROR
static Reason | FIND_RMA_ITEM_ERROR
static Reason | FIND_RRMA_ERROR
static Reason | FIND_RRMA_ITEM_ERROR
static Reason | FIND_RTV_ERROR
static Reason | FIND_SALES_CODE_ERROR
static Reason | FIND_SALES_ORDER_ERROR
static Reason | FIND_SALES_ORDER_ID_ERROR
static Reason | FIND_SALES_ORDER_ITEM_ERROR
static Reason | FIND_SALESMAN_ERROR
static Reason | FIND_SHIPPER_ERROR
static Reason | FIND_SRUNNING_ACCOUNT_ORDER_ERROR
static Reason | FIND_TEMPORARYEMPLOYEE_ID_ERROR
static Reason | FIND_USER_GROUP_ERROR
static Reason | FIND_USER_ZIPCODE_TAX_ERROR
static Reason | FIND_VENDOR_ID_ERROR
static Reason | FIND_WEIGHT_UNIT_ERROR
static Reason | FIND_WORK_CENTER_ERROR
static Reason | FIND_WORK_INSTRUCTION_ERROR
static Reason | FIND_WORK_ORDER_ERROR
static Reason | FISCAL_YEAR_NOT_EXIST
static Reason | FISCAL_YEAR_SETTINGS_ALREADY_EXISTS
static Reason | FISCAL_YEAR_SETTINGS_CAN_NOT_BE_NULL
static Reason | FISCAL_YEAR_SETTINGS_STATUS_AFTER_NEED_TO_CHANGE
static Reason | FISCAL_YEAR_SETTINGS_STATUS_BEFORE_NEED_TO_CHANGE
static Reason | FISCAL_YEAR_SETTINGS_STATUS_SHOULD_BE_OPEN
static Reason | FTP_OPERATION_FAILED
static Reason | GENERAL_LEDGER_ALREADY_APPROVED
static Reason | GENERAL_LEDGER_ALREADY_EXIST
static Reason | GENERAL_LEDGER_APPROVAL_ALREADY_EXIST
static Reason | GENERAL_LEDGER_APPROVAL_NOT_EXIST
static Reason | GENERAL_LEDGER_BEEN_LOCKED
static Reason | GENERAL_LEDGER_CREDIT_DESRIPTION_IS_NULL
static Reason | GENERAL_LEDGER_DEBIT_DESRIPTION_IS_NULL
static Reason | GENERAL_LEDGER_NOT_BEEN_LOCKED
static Reason | GENERAL_LEDGER_NOT_EXIST
static Reason | GENERAL_LEDGER_SEQUENCE_ALREADY_EXIST
static Reason | GENERAL_LEDGER_SEQUENCE_CAN_NOT_BE_EMPTY
static Reason | GENERAL_LEDGER_SEQUENCE_NOT_EXIST
static Reason | GET_AP_PREPAY_ERROR
static Reason | GET_AR_PREPAY_ERROR
static Reason | GET_CG_CSRNUMBER_FAIL
static Reason | GET_CG_CUST_RFQNUMBER_FAIL
static Reason | GET_CUSTOMER_PART_ERROR
static Reason | GET_DISASSEMBLE_WORK_ORDER_APPROVAL_ERROR
static Reason | GET_ENGINEERING_CHANGE_REQUEST_WRONG
static Reason | GET_NEW_PURCHASE_WORK_SHEET_NUMBER_ERROR
static Reason | GET_ONLOAN_REVIEW_ERROR
static Reason | GET_ORDER_ITEM_ERROR
static Reason | GET_PART_STANDARD_COST_ERROR
static Reason | GET_PART_VERSION_ERROR
static Reason | GET_PROFORMA_RECEIVER_ERROR
static Reason | GET_PURCHASE_ORDER_APPROVAL_ERROR
static Reason | GET_PURCHASE_ORDER_ERROR
static Reason | GET_PURCHASE_WORK_SHEET_ERROR
static Reason | GET_REQUEST_FOR_QUOTE_ERROR
static Reason | GET_RETURN_TO_VENDOR_APPROVAL_ERROR
static Reason | GET_RETURN_TO_VENDOR_ERROR
static Reason | GET_RFQ_MESSAGE_ERROR
static Reason | GET_RMA_REVIEW_ERROR
static Reason | GET_SALES_ORDER_REVIEW_ERROR
static Reason | GET_USER_TRUENAME_WRONG
static Reason | GET_VENDOR_ERROR
static Reason | GET_VENDOR_PART_ERROR
static Reason | GET_VERSION_ERROR
static Reason | GET_WORK_ORDER_APPROVAL_ERROR
static Reason | GET_WORK_ORDER_ERROR
static Reason | GET_WORK_WORK_SHEET_ERROR
static Reason | GL_IN_FISCAL_YEAR
static Reason | GL_LOCKED_DATE_SHOULD_BE_AFTER_FY_END_DATE
static Reason | GL_MONTH_ALREADY_CLOSED
static Reason | GL_MONTH_NOT_EXIST
static Reason | HAVE_CALIBRATION_RECORDS
static Reason | HAVE_ITEMS_NOT_CLOSED
static Reason | HAVE_NO_CALIBRATION_RECORDS
static Reason | HAVE_NOT_ENOUGH_QTY_TO_REC_IN_IR
static Reason | HAVE_NOT_INVENTORY
static Reason | ILEGAL_CREDIT_MEMO
static Reason | ILLEGAL_ACCOUNT_NUMBER
static Reason | ILLEGAL_CARRIER_ID
static Reason | ILLEGAL_CATEGORY_ID
static Reason | ILLEGAL_CCODE
static Reason | ILLEGAL_CONTRACT_PRICE_NUMBER
static Reason | ILLEGAL_DCODE
static Reason | ILLEGAL_DESIGN_CONTROL_DOCUMENT_EXTENSION
static Reason | ILLEGAL_DESIGN_CONTROL_DOCUMENT_SEQUENCE
static Reason | ILLEGAL_DRAWING_EXTENSION
static Reason | ILLEGAL_ECODE
static Reason | ILLEGAL_EDC_NUMBER
static Reason | ILLEGAL_ENGINEERING_CHANGE_REQUEST
static Reason | ILLEGAL_INCOTERM_ID
static Reason | ILLEGAL_MAKE_BUY_X
static Reason | ILLEGAL_OCODE
static Reason | ILLEGAL_PART_NUMBER_FORMAT
static Reason | ILLEGAL_PART_REVISION
static Reason | ILLEGAL_PCODE
static Reason | ILLEGAL_PO_MESSAGE_NUMBER
static Reason | ILLEGAL_PROFORMA_INVOICE_NUMBER
static Reason | ILLEGAL_PURCHASE_ORDER_ITEM_NUMBER
static Reason | ILLEGAL_PURCHASE_ORDER_MESSAGE_ITEM_NUMBER
static Reason | ILLEGAL_PURCHASE_ORDER_NUMBER
static Reason | ILLEGAL_QUOTE_ITEM_NUMBER
static Reason | ILLEGAL_REQUEST_FOR_QUOTE_ITEM_NUMBER
static Reason | ILLEGAL_REQUEST_FOR_QUOTE_NUMBER
static Reason | ILLEGAL_RETURN_TO_VENDOR_ITEM_NUMBER
static Reason | ILLEGAL_RETURN_TO_VENDOR_NUMBER
static Reason | ILLEGAL_REVISION_NUMBER_FORMAT
static Reason | ILLEGAL_RFQ_MESSAGE_ITEM_NUMBER
static Reason | ILLEGAL_RFQ_MESSAGE_NUMBER
static Reason | ILLEGAL_SALES_ORDER_ITEM_NUMBER
static Reason | ILLEGAL_SHIP_LIST_NUMBER
static Reason | ILLEGAL_SHIPPER_NUMBER
static Reason | ILLEGAL_SPECIFICATION_ID
static Reason | ILLEGAL_UNIT_NAME
static Reason | ILLEGAL_WORK_INSTRUCTION_SEQUENCE_NUMBER
static Reason | ILLEGAL_WORK_INSTRUCTION_SET_NUMBER
static Reason | ILLEGAL_WORK_ORDER_ITEM_NUMBER
static Reason | ILLEGAL_WORK_ORDER_NUMBER
static Reason | INCLUDE_BOM_SELF
static Reason | INCOTERM_ALREADY_EXIST
static Reason | INCOTERM_NOT_EXIST
static Reason | INCOTERM_USING_BY_PO
static Reason | INCOTERM_USING_BY_RMA
static Reason | INCOTERM_USING_BY_RTV
static Reason | INCOTERM_USING_BY_SO
static Reason | INPUT_CAN_NOT_BE_EMPTY_STRING
static Reason | INPUT_MUST_BE_EMPTY_STRING
static Reason | INQA_ALREADY_CREATE_NCR
static Reason | INSPECTION_REPORT_NOT_EXIST
static Reason | INSPECTION_TYPE_IS_EXISTENT
static Reason | INSPECTION_TYPE_IS_NOT_EXISTENT
static Reason | INSPECTION_TYPE_IS_USED
static Reason | INTERNAL_COMPANY_EMPLOYID_CAN_NOT_BE_NULL
static Reason | INVALID_ARGUMENT
static Reason | INVALID_PAY_DATE
static Reason | INVALID_USER
static Reason | INVOICE_NOT_CONSISTENT
static Reason | INVOICE_NOT_EXIST
static Reason | INVOKE_FAILED
static Reason | IR_ALREADY_EXIST
static Reason | IR_NOT_EXIST
static Reason | IRNUMBER_HAS_BEEN_USED
static Reason | IRNUMBER_IS_NOT_FOR_THIS_PURCHASE_ORDER_ITEM
static Reason | IRNUMBER_IS_NOT_FOR_THIS_WORK_ORDER_ITEM
static Reason | IRNUMBER_NOT_EXIST
static Reason | IRNUMBER_NOT_MATCH_PURCHASE_ORDER
static Reason | IRNUMBER_NOT_MATCH_WORK_ORDER
static Reason | ISSUED_QTY_IS_OVER_THAN_WO_ITEM_PART_DETAIL_QTY
static Reason | IT_HAS_NO_GL_TO_OVER_CARRY
static Reason | ITEM_QTY_IS_NOT_RIGHT
static Reason | ITEM_STATUS_IS_FORBIDDEN_TO_CHANGE_CURRENTLY
static Reason | JOB_CATEGORY_IS_USED
static Reason | LAST_PACKING_BOX_IS_EMPTY
static Reason | LEVEL_OR_UP_ACCOUNT_NUMBER_WRONG
static Reason | LINED_QTY_IS_OVER
static Reason | LINKED_ITEM_NOT_EXIST
static Reason | LINKED_ITEM_STATUS_IS_CLOSED
static Reason | LN_RECEIVER_NOT_EXIST
static Reason | LN_SHIPPER_EXIST
static Reason | LN_SHIPPER_ITEM_NOT_EXIST
static Reason | LN_SHIPPER_NOT_EXIST
static Reason | LOCATE_ALREADY_EXIST
static Reason | LOCATION_FOR_RETURN_MASTERIAL_IS_NOT_CONFIGURED
static Reason | LOCATION_OF_DEPARTMENT_LOCATION_FOR_BACKFLUSH_ALREADY_ADDED
static Reason | LOGIN_DATA_NOT_COMPLETED
static Reason | MAINTENANCE_ITEM_ALREADY_EXIST
static Reason | MAINTENANCE_ITEM_NOT_EXIST
static Reason | MANUFACTURE_ENGINEERING_CHANGE_NOTICE_NOT_CLOSED_EXIST_FOR_THIS_PART
static Reason | MANUFACTURER_ID_ALREADY_EXIST
static Reason | MANUFACTURER_ID_IS_DELETED
static Reason | MANUFACTURER_ID_NOT_EXIST
static Reason | MANUFACTURER_ID_USED_IN_PART
static Reason | MANUFACTURER_PART_NUMBER_NOT_EXIST
static Reason | MESSAGE_ALREADY_READ_BY_RECEIVER
static Reason | MESSAGE_IN_MONTH_NEED_REMAIN
static Reason | MESSAGE_NOT_EXIST
static Reason | METHOD_NOT_EXIST
static Reason | MISSING_OR_WRONG_ACCOUNT_FOR_RETAINED_ERANINGS
static Reason | MODIFY_ONHAND_INQA_ERROR
static Reason | MUST_NULL_OR_EMPTY
static Reason | MYSELF_CAN_NOT_BE_REMOVED
static Reason | NA_PART_NUMBER_CAN_NOT_ALLOW
static Reason | NCR_ALREADY_EXIST
static Reason | NCR_APPROVAL_ALREADY_EXIST
static Reason | NCR_APPROVAL_ENG_ALREADY_EXIST
static Reason | NCR_APPROVAL_MFG_ALREADY_EXIST
static Reason | NCR_APPROVAL_NOT_EXIST
static Reason | NCR_APPROVAL_QA_ALREADY_EXIST
static Reason | NCR_APPROVED_BY_CAN_NOT_BE_EMPTY
static Reason | NCR_HAS_NO_IN_QA_QTY_TO_SCRAP
static Reason | NCR_IN_QA_COST_CAN_NOT_BE_ZERO
static Reason | NCR_NOT_EXIST
static Reason | NCR_PART_IN_DEAL_QTY_ALREADY_BIGGER_THAN_TOTAL_QTY
static Reason | NCR_PARTNUMBER_CANNOT_BE_CHANGED
static Reason | NCR_SCRAP_QTY_CAN_NOT_BE_ZERO
static Reason | NCR_SCRAP_QTY_MORE_THAN_IN_QA_QTY
static Reason | NCR_SCRAP_QTY_MORE_THAN_PULLED_QTY
static Reason | NCR_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY
static Reason | NEED_TO_CREATE_NEXT_FISCAL_YEAR
static Reason | NEW_FISCAL_YEAR_SETTINGS_CLOSED
static Reason | NEW_QTY_RECEIVED_IS_MORE_THAN_QTY_SHORTAGE
static Reason | NEW_TRANSACTION_ARE_FUTURE_DATE
static Reason | NEW_TRANSACTION_DATE_LOCKED
static Reason | NEW_TRANSACTION_DATE_OVER_GL_NDAYS_OK_OLD
static Reason | NO_CUSTOMER_IS_CHOISE
static Reason | NO_ITEM_TO_TRANSFER
static Reason | NO_OPEN_SALES_ORDER_FOUND
static Reason | NO_PERMISSION_TO_UPDATE_CLOSED_ORDER
static Reason | NO_RECEIVERS
static Reason | NO_RIGHT_WORK_INSTRUCTION_SET_ID
static Reason | NO_SELECT_OBJECT
static Reason | NO_SUCH_ORDER
static Reason | NO_WAREHOUSE_FOR_LOCATION
static Reason | NO_WORK_INSTRUCTION_SEQUENCES
static Reason | NON_CONFORMANCE_CODE_ALREADY_EXIST
static Reason | NON_CONFORMANCE_CODE_DESCRIPTION_CANNOT_BE_EMPTY
static Reason | NON_CONFORMANCE_CODE_NOT_EXIST
static Reason | NONPRODUCTIVE_PICKING_APPROVAL_ALREADY_ADDED
static Reason | NONPRODUCTIVE_PICKING_APPROVAL_NOT_EXIST
static Reason | NONPRODUCTIVE_PICKING_NOT_EXIST
static Reason | NONPRODUCTIVE_PICKING_NOT_OPEN
static Reason | NONPRODUCTIVE_PICKING_TYPE_ALREADY_ADDED
static Reason | NONPRODUCTIVE_PICKING_TYPE_CAN_BE_DELETE
static Reason | NONPRODUCTIVE_PICKING_TYPE_IS_USED
static Reason | NONPRODUCTIVE_PICKING_TYPE_NOT_EXIST
static Reason | NOT_APPROVED_GL_CAN_NOT_POST
static Reason | NOT_APPROVED_GL_TO_CANCEL
static Reason | NOT_APPROVED_OBJECT_ONLY_ALLOW_UPDATE
static Reason | NOT_APPROVED_REQUEST_FOR_QUOTE_IS_NOT_ALLOWED_TO_PURCHASE_ORDER
static Reason | NOT_APPROVED_WORK_ORDER_ITEM_WILL_BE_SETUP
static Reason | NOT_AUTHORIZED_APPROVER
static Reason | NOT_AUTHORIZED_APPROVER_TO_APPROVE_SELF
static Reason | NOT_CHARACTER
static Reason | NOT_DIGDECIMAL
static Reason | NOT_ENOUGH_ONHAND
static Reason | NOT_EQUALS
static Reason | NOT_EXIST_ITEM_TO_RECEIVE_OR_SHIP
static Reason | NOT_FOUND_APPROVED_BY_IN_SETTINGS
static Reason | NOT_FOUND_TAX_RATE_ACCOUNT
static Reason | NOT_GROUP_ISSUE_ITEM_AGENT_ITEM_NUMBER_NOT_RIGHT
static Reason | NOT_IDENTITY_EMPLOYEE_ID
static Reason | NOT_INVOICE_NUMBER
static Reason | NOT_LETTER
static Reason | NOT_MATCH_BIZBOX_USER_EXIST
static Reason | NOT_MATCH_EMPLOYEE_ID_WITH_BIZBOX_USER
static Reason | NOT_MATCH_OWNER_NAME_WITH_SHIP_LIST_OWNER
static Reason | NOT_MATCH_PART_WiTH_SALES_ORDER_ITEM
static Reason | NOT_MATCH_PART_WiTH_WORK_ORDER_ITEM
static Reason | NOT_MATCH_SHIP_LIST_NUMBER_WITH_SHIP_LIST
static Reason | NOT_NUMBER
static Reason | NOT_NUMBER_STRING
static Reason | NOT_OBJECT_TO_APPROVED
static Reason | NOT_OPEN_NCR_TO_SHIP
static Reason | NOT_OPEN_SALES_ORDER_ITEM_ADD_TO_SHIPPER
static Reason | NOT_OPEN_SALES_ORDER_ITEM_TO_SHIP
static Reason | NOT_OPEN_SALES_ORDER_TO_MAKE_SHIPPER
static Reason | NOT_OPEN_SALES_ORDER_TO_SHIP
static Reason | NOT_OPEN_WORK_ORDER_ITEM_TO_ISSUE_PART
static Reason | NOT_OPEN_WORK_ORDER_TO_ISSUE_PART
static Reason | NOT_RIGHT_AP_PREPAY_ITEM
static Reason | NOT_RIGHT_AR_PREPAY_ITEM
static Reason | NOT_RIGHT_BOM_ITEM
static Reason | NOT_RIGHT_DESIGN_CONTROL_NUMBER_OF_DOCUMENT
static Reason | NOT_RIGHT_MANUFACTURERS_GROUP_FORMAT
static Reason | NOT_RIGHT_PACKING_BOX_NUMBER
static Reason | NOT_RIGHT_PART_TRACEABLE_CATEGORY_ITEM
static Reason | NOT_RIGHT_PART_TRACEABLE_SPECIFICATION_ITEM
static Reason | NOT_RIGHT_PROFORMA_INVOICE_NUMBER
static Reason | NOT_RIGHT_PURCHASE_ORDER_ITEM
static Reason | NOT_RIGHT_PURCHASE_ORDER_ITEM_MANUFACTURER
static Reason | NOT_RIGHT_PURCHASE_ORDER_MESSAGE_ITEM
static Reason | NOT_RIGHT_PURCHASE_WORK_SHEET_ITEM
static Reason | NOT_RIGHT_REQUEST_FOR_QUOTE_ITEM
static Reason | NOT_RIGHT_REQUEST_FOR_QUOTE_ITEM_MANUFACTURER
static Reason | NOT_RIGHT_RETURN_MATERIAL_AUTHORIZATION_ITEM_MANUFACTURER
static Reason | NOT_RIGHT_RETURN_TO_VENDOR_ITEM
static Reason | NOT_RIGHT_RETURN_TO_VENDOR_ITEM_MANUFACTURER
static Reason | NOT_RIGHT_RFQ_MESSAGE_ITEM
static Reason | NOT_RIGHT_SALES_ORDER_ADD_TO_SHIPPER
static Reason | NOT_RIGHT_SALES_ORDER_ITEM_ADD_TO_SHIPPER
static Reason | NOT_RIGHT_SPECIFY_FOR_WHAT_TO_ADD_TYPE
static Reason | NOT_RIGHT_VENDORS_GROUP_FORMAT
static Reason | NOT_RIGHT_WORK_ORDER_ITEM
static Reason | NOT_RIGHT_WORK_ORDER_WORK_INSTRUCTION_SEQUENCE
static Reason | NOT_RIGHT_WORK_WORK_SHEET_ITEM
static Reason | NOT_SAME_ADDRESS_ID_WITH_PROFROMA_INVOICE
static Reason | NOT_SAME_PART_FROM
static Reason | NOT_STRING
static Reason | NOTICE_USER_EXIST
static Reason | NOTICE_USER_NOT_EXIST
static Reason | NUMBER_CAN_NOT_BE_ZERO
static Reason | NUMBER_CAN_NOT_LESS_THEN_ZERO
static Reason | OBJECT_ALREADY_APPROVED
static Reason | OLD_FISCAL_YEAR_SETTINGS_CLOSED
static Reason | OLD_TRANSACTION_DATE_LOCKED
static Reason | ON_LOAN_ALREADY_EXIST
static Reason | ON_LOAN_ALREADY_REVIEWED
static Reason | ON_lOAN_ITEM_ALREADY_EXIST
static Reason | ON_LOAN_ITEM_NOT_EXIST
static Reason | ON_LOAN_ITEM_PK_ERROR
static Reason | ON_LOAN_NOT_EXIST
static Reason | ONHAND_IS_NOT_ENOUGH
static Reason | ONLINE_USER_CAN_NOT_BE_REMOVED
static Reason | ONLOAN_REVIEW_ALREADY_EXIST
static Reason | ONLOAN_REVIEW_NOT_EXIST
static Reason | ONLY_APP_COLUMN_CAN_BE_DROP
static Reason | ONLY_APP_TABLE_CAN_BE_DROP
static Reason | ONLY_ONE_PRIMARY_KEY_PERMITTED
static Reason | OPERATING_INSTRUCTION_NOT_EXIST
static Reason | OPERATING_INSTRUCTION_TYPE_NOT_EXIST
static Reason | ORDER_ALREADY_IN_MY_PRINTLIST
static Reason | ORDER_CAN_NOT_LINK_TO_ITSELF
static Reason | ORDER_HAS_BEEN_CLOSED_ENTRY
static Reason | ORDER_IS_HOLD
static Reason | ORDER_NOT_IN_MY_PRINTLIST
static Reason | ORDER_WAS_CHANGED
static Reason | OTHER_PEOPLE_IS_RECEIVING_PLEASE_TRY_AGAIN
static Reason | OTHER_PEOPLE_IS_RUNNING_AUDIT_ONDEMAND_PLEASE_TRY_AGAIN_LATER
static Reason | OTHER_PEOPLE_IS_RUNNING_MRP_PLEASE_TRY_AGAIN_LATER
static Reason | OUTSIDE_COMPANY_EMPLOYID_MUST_BE_NULL
static Reason | OVER_CARRY_PROFIT_AND_LOSS_APPROVED_BY_BY_CAN_NOT_BE_EMPTY
static Reason | OVER_CARRY_PROFIT_AND_LOSS_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY
static Reason | PACKING_BOX_ALREADY_EXIST
static Reason | PACKING_BOX_BOX_INFO_NOT_COMPLETED
static Reason | PACKING_BOX_IS_NOT_EMPTY
static Reason | PACKING_BOX_ITEM_ALREADY_EXIST
static Reason | PACKING_BOX_ITEM_NOT_EXIST
static Reason | PACKING_BOX_NOT_EXIST
static Reason | PAID_TOTAL_IS_NOT_EAUAL
static Reason | PAR_ALREADY_EXIST
static Reason | PAR_ITEM_ALREADY_EXIST
static Reason | PAR_ITEM_NOT_EXIST
static Reason | PAR_NOT_EXIST
static Reason | PART_ALREADY_BOM
static Reason | PART_ALREADY_EXIST
static Reason | PART_ALREADY_USED
static Reason | PART_CATALOG_ALREADY_EXIST
static Reason | PART_CATALOG_NOT_EXIST
static Reason | PART_CATEGORY_NOT_EXIST
static Reason | PART_CERTIFICATE_ALREADY_EXIST
static Reason | PART_CERTIFICATE_NOT_EXIST
static Reason | PART_CLASS_ALREADY_EXIST
static Reason | PART_CLASS_IS_USED
static Reason | PART_CLASS_NEED_BE_A_LETTER
static Reason | PART_CLASS_NOT_EXIST
static Reason | PART_EXIST
static Reason | PART_FROM_NOT_EXIST
static Reason | PART_HAS_BEAN_RETURN
static Reason | PART_HAS_DRAWING
static Reason | PART_HAS_MANUFACTURER
static Reason | PART_HAS_MATERIAL
static Reason | PART_HAS_ONDEMAND
static Reason | PART_HAS_ONHAND
static Reason | PART_HAS_ONLOAN
static Reason | PART_HAS_ONORDER
static Reason | PART_HAS_PICTURE
static Reason | PART_HAS_QA
static Reason | PART_HAS_SIP
static Reason | PART_HAS_SIT
static Reason | PART_HAS_VENDOR
static Reason | PART_HAS_WIP
static Reason | PART_HAS_WORK_INSTRUCTION
static Reason | PART_IMPORT_FROM_OTHER_COMPANY_CANT_EDIT_REV
static Reason | PART_IN_QA_NOT_EXIST
static Reason | PART_IN_SIP
static Reason | PART_INVENTORY_NOT_ENOUGH
static Reason | PART_IS_BOM
static Reason | PART_IS_DELETED
static Reason | PART_IS_LOCKED
static Reason | PART_IS_NOT_BACKFLUSH_MATERIAL
static Reason | PART_MATERIAL_ALREADY_EXIST
static Reason | PART_MATERIAL_NOT_EXIST
static Reason | PART_NOT_BOM
static Reason | PART_NOT_EXIST
static Reason | PART_NOT_SALEABLE
static Reason | PART_NOT_SAME_BETWEEN_TWO_ORDERS
static Reason | PART_NUMBER_ALREADY_IN_USE
static Reason | PART_NUMBER_FOR_CATEGORY_IS_USED_UP
static Reason | PART_NUMBER_IS_USED_UP
static Reason | PART_NUMBER_MAX_LENGTH_CAN_NOT_SAMLLER_THAN
static Reason | PART_ONHAND_NOT_ENOUGH
static Reason | PART_ONHAND_NOT_EXIST
static Reason | PART_PICTURE_EXIST
static Reason | PART_PICTURE_WITHOUT_LENGTH
static Reason | PART_SECURITY_LEVEL_EXIST
static Reason | PART_SECURITY_LEVEL_NOT_EXIST
static Reason | PART_SECURITY_LEVEL_USED_IN_PART
static Reason | PART_SHARE_COMPANY_ID_DOES_NOT_EXIST
static Reason | PART_STILL_IS_HOLD
static Reason | PART_TPYE_IS_USING
static Reason | PART_TYPE_ALREADY_EXIST
static Reason | PART_TYPE_NOT_EXIST
static Reason | PART_USE_TYPE_IS_EXIST
static Reason | PART_USE_TYPE_NOT_EXIST
static Reason | PART_USED_IN_API
static Reason | PART_USED_IN_ARI
static Reason | PART_USED_IN_BOM
static Reason | PART_USED_IN_ECN
static Reason | PART_USED_IN_ECR
static Reason | PART_USED_IN_EDC
static Reason | PART_USED_IN_LNI
static Reason | PART_USED_IN_POI
static Reason | PART_USED_IN_QTI
static Reason | PART_USED_IN_RFQI
static Reason | PART_USED_IN_RMAI
static Reason | PART_USED_IN_RTVI
static Reason | PART_USED_IN_SOI
static Reason | PART_USED_IN_SWSI
static Reason | PART_USED_IN_TOI
static Reason | PART_USED_IN_WOI
static Reason | PART_VENDOR_EXIST
static Reason | PART_VENDOR_NOT_EXIST
static Reason | PART_WITH_NCR
static Reason | PART_WITHOUT_INVENTORY
static Reason | PARTCATALOG_NOT_EXIST
static Reason | PARTDWF_NOT_FOUND
static Reason | PARTDWG_NOT_FOUND
static Reason | PASSWORD_IS_TOO_SHORT
static Reason | PAY_DATE_SHOULD_BE_AFTER_GL_LOCKED_DATE
static Reason | PAYMENT_RUN_ALREADY_COMMITTED
static Reason | PAYMENT_RUN_ALREADY_EXIST
static Reason | PAYMENT_RUN_NOT_EXIST
static Reason | PAYMENT_VARIANCE_OVER_THAN_GA_ZERO_CAN_NOT_CLOSE
static Reason | PHYSICAL_WORK_SHEET_ALREADY_CLOSED
static Reason | PHYSICAL_WORK_SHEET_HAS_EXIST
static Reason | PHYSICAL_WORK_SHEET_NOT_EXIST
static Reason | PHYSICAL_WORK_SHEET_PAGE_NUMBER_HAS_EXIST
static Reason | PHYSICAL_WORK_SHEET_PAGE_NUMBER_NOT_EXIST
static Reason | PICTURE_NOT_FOUND
static Reason | PLEASE_CHANGE_CONDITION_THEN_SEARCH_AGAIN
static Reason | PLEASE_CHECK_WORK_INSTRUCTION_SEQUENCE
static Reason | PLEASE_CHECK_WORK_INSTRUCTION_SEQUENCE_OR_WORK_CENTER
static Reason | PLEASE_FILL_IN_UOM
static Reason | PLEASE_INPUT_A_OPEN_WORK_ORDER
static Reason | PLEASE_LOGIN_FIRST
static Reason | POS_NOT_EXIST
static Reason | POSTED_GL_CAN_NOT_BE_CANCEL_APPROVE
static Reason | PROFORMA_INVOICE_HAS_EXIST
static Reason | PROFORMA_INVOICE_ITEM_NOT_EXIST
static Reason | PROFORMA_INVOICE_NOT_EXIST
static Reason | PROFORMA_INVOICE_NOT_OPEN
static Reason | PROFORMA_RECEIVER_HAS_EXIST
static Reason | PROFORMA_RECEIVER_NOT_EXIST
static Reason | PULL_OUT_ON_DEMAND_ERROR
static Reason | PURCHASE_ORDER_ALREADY_RECEIVED
static Reason | PURCHASE_ORDER_APPROVAL_ALREADY_EXIST
static Reason | PURCHASE_ORDER_APPROVAL_NOT_EXIST
static Reason | PURCHASE_ORDER_HAS_EXIST
static Reason | PURCHASE_ORDER_ITEM_ALREADY_RECEIVED_OR_IN_SIT
static Reason | PURCHASE_ORDER_ITEM_HAS_REFERENCE
static Reason | PURCHASE_ORDER_ITEM_NOT_CONTAINS_THIS_PART
static Reason | PURCHASE_ORDER_ITEM_NOT_EXIST
static Reason | PURCHASE_ORDER_ITEM_STATUS_NOT_OPEN
static Reason | PURCHASE_ORDER_MESSAGE_HAS_EXIST
static Reason | PURCHASE_ORDER_MESSAGE_NOT_EXIST
static Reason | PURCHASE_ORDER_NOT_APPROVED
static Reason | PURCHASE_ORDER_NOT_EXIST
static Reason | PURCHASE_ORDER_NOT_OPEN
static Reason | PURCHASE_WORK_SHEET_HAS_EXIST
static Reason | PURCHASE_WORK_SHEET_ITEM_NOT_EXIST
static Reason | PURCHASE_WORK_SHEET_NOT_EXIST
static Reason | QT_DOC_NOT_FIND
static Reason | QTY_RECEIVED_CAN_NOT_MORE_THAN_QTY_PURCHASED
static Reason | QTY_RECEIVED_CAN_NOT_MORE_THAN_QTY_QUALIFIED
static Reason | QTY_SHOULD_BE_BIGGER_THAN_ISSUED_QTY
static Reason | QTY_SHOULD_HAS_SAME_POSITIVE_NEGATIVE_WITH_ISSUED_QTY
static Reason | QUANTIRY_CAN_NOT_BE_ZERO
static Reason | QUANTITY_CAN_NOT_LESS_THAN_ZERO
static Reason | QUOTE_ALREADY_REVIEWED
static Reason | QUOTE_ITEM_PK_WRONG
static Reason | QUOTE_NOT_EXIST
static Reason | QUOTE_WITHOUT_ITEMS
static Reason | RECEIVE_ITEM_DOSE_NOT_EXIST_IN_WO_PART_DETAIL
static Reason | RECEIVE_QTY_IS_NOT_SAME_WITH_WO_PART_DETAIL_QTY
static Reason | RECEIVE_QTY_IS_OVER_THAN_RMA_ITEM_ORDERED
static Reason | RECEIVE_TO_WRONG_WAREHOUSE
static Reason | RECEIVED_TOTAL_IS_NOT_EAUAL
static Reason | RECEIVER_HAS_BEEN_CLOSED
static Reason | RECEIVER_HAS_EXIST
static Reason | RECEIVER_IS_NOT_FOR_THIS_PO
static Reason | RECEIVER_ITEM_HAS_BEEN_CLOSED
static Reason | RECEIVER_ITEM_HAS_BEEN_CREATED_AP
static Reason | RECEIVER_ITEM_HAS_EXIST
static Reason | RECEIVER_ITEM_NOT_EXIST
static Reason | RECEIVER_NOT_EXIST
static Reason | RECEIVER_QTY_CAN_NOT_BE_CHANGED
static Reason | RECEIVER_REF_DOC_NUMBER_CAN_NOT_BE_CHANGED
static Reason | RECURSIVE_BOM_NOT_ALLOWED
static Reason | REF_DOC_CLOSED
static Reason | REF_DOC_HAS_EXIST
static Reason | REF_DOC_LINK_TO_NOT_EXIST_ORDER
static Reason | REF_DOC_NOT_EXIST
static Reason | REF_DOC_TOTAL_QTY_MORE_THAN_QTY_OF_FROM_ORDER
static Reason | REF_DOC_TOTAL_QTY_MORE_THAN_QTY_OF_TO_ORDER
static Reason | REPLACEMENT_PART_ITEMS_ERROR
static Reason | REQUEST_FOR_QUOTE_ITEM_NOT_EXIST
static Reason | REQUEST_FOR_QUOTE_NOT_EXIST
static Reason | RETURN_ADDRESS_ID_TO_ID_IS_NOT_EXIST
static Reason | RETURN_TO_VENDOR_ITEM_NOT_EXIST
static Reason | RETURN_TO_VENDOR_NOT_EXIST
static Reason | RFQ_MESSAGE_HAS_EXIST
static Reason | RFQ_MESSAGE_NOT_EXIST
static Reason | RMA_ALREADY_REVIEWED
static Reason | RMA_DEBIT_ACCOUNT_IS_NOT_CONFIGURED
static Reason | RMA_DOC_NOT_FIND
static Reason | RMA_HAS_EXIST
static Reason | RMA_ITEM_HAS_EXIST
static Reason | RMA_ITEM_NOT_EXIST
static Reason | RMA_NOT_EXIST
static Reason | RMA_NOT_REVIEWED
static Reason | RMA_ORDER_ITEM_ALREADY_RECEIVED
static Reason | RMA_PK_WRONG
static Reason | RMA_RECEIVER_HAS_HAVED_CREDITMEMO
static Reason | RMA_RECEIVER_NOT_EXIST
static Reason | RMA_REVIEW_ALREADY_EXIST
static Reason | RMA_REVIEW_NOT_EXIST
static Reason | ROLL_UP_BOM_STD_COST_WORKSHEET_NOT_EXIST
static Reason | RRMA_ALREADY_REVIEWED
static Reason | RRMA_CUSTOMERID_NOT_MATCH
static Reason | RRMA_NOT_EXIST
static Reason | RRMA_NOT_OPEN
static Reason | RRMA_PK_WRONG
static Reason | RTV_APPROVAL_ALREADY_EXIST
static Reason | RTV_APPROVAL_NOT_EXIST
static Reason | RTV_ITEM_ALREADY_SHIPPER
static Reason | RTV_ORDER_ITEM_ALREADY_SHIPPED
static Reason | RTV_SHIPPER_NOT_EXIST
static Reason | SALES_CODE_ALREADY_EXIST
static Reason | SALES_CODE_NOT_EXIST
static Reason | SALES_ITEM_HAS_BEEN_CLOSED
static Reason | SALES_ITEM_HAS_BEEN_CREATED_INVOICE
static Reason | SALES_ORDER_ALREADY_CLOSED
static Reason | SALES_ORDER_ALREADY_REVIEWED
static Reason | SALES_ORDER_ALREADY_SHIPPED
static Reason | SALES_ORDER_HAS_BEEN_CLOSED
static Reason | SALES_ORDER_HAS_BEEN_HOLD
static Reason | SALES_ORDER_IS_BILL_AND_HOLD
static Reason | SALES_ORDER_IS_NOT_REVIEWED
static Reason | SALES_ORDER_ITEM_ALREADY_COMPLETED
static Reason | SALES_ORDER_ITEM_ALREADY_SHIPPED_OR_IN_SIP
static Reason | SALES_ORDER_ITEM_HAS_EXIST
static Reason | SALES_ORDER_ITEM_MFG_PK_WRONG
static Reason | SALES_ORDER_ITEM_NOT_EXIST
static Reason | SALES_ORDER_ITEM_NOT_EXIST_FOR_THIS_SHIPPER_ITEM
static Reason | SALES_ORDER_ITEM_NOT_OPEN
static Reason | SALES_ORDER_ITEM_PK_WRONG
static Reason | SALES_ORDER_ITEM_WITHOUT_SUCH_QTY_TO_SHIPPED
static Reason | SALES_ORDER_NOT_EXIST
static Reason | SALES_ORDER_NOT_OPEN
static Reason | SALES_ORDER_REVIEW_ALREADY_EXIST
static Reason | SALES_ORDER_REVIEW_NOT_EXIST
static Reason | SALES_ORDER_SHIPPER_NOT_EXIST
static Reason | SALESMAN_NOT_EXIST
static Reason | SAVE_TO_DB_ERROR
static Reason | SECURITY_ACCESS_TO_METHOD
static Reason | SEND_MAIL_ERROR
static Reason | SERIAL_NUMBER_ALREADY_EXIST
static Reason | SERIAL_NUMBER_NOT_EXIST
static Reason | SERVER_TIME_ERROR
static Reason | SG_CLIENT_ACCOUNT_ALREADY_EXIST
static Reason | SG_CLIENT_ACCOUNT_NOT_EXIST
static Reason | SG_CLIENT_PROGRAM_USER_ALREADY_EXIST
static Reason | SG_CLIENT_PROGRAM_USER_INFO_NOT_EXACT
static Reason | SG_CLIENT_PROGRAM_USER_NOT_EXIST
static Reason | SG_COMPANY_ALREADY_EXIST
static Reason | SG_COMPANY_NOT_EXIST
static Reason | SG_CUST_RFQ_ALREADY_EXIST
static Reason | SG_CUST_RFQ_ALREADY_QUOTED
static Reason | SG_CUST_RFQ_NOT_EXIST
static Reason | SG_CUST_RFQ_NOT_QUOTED
static Reason | SG_QUOTE_ADDRESS_ALREADY_EXIST
static Reason | SG_QUOTE_ADDRESS_NOT_EXIST
static Reason | SG_SALE_ITEM_NOT_EXIST
static Reason | SHIP_LIST_HAS_EXIST
static Reason | SHIP_LIST_NOT_EXIST
static Reason | SHIP_LIST_OWNER_HAS_EXIST
static Reason | SHIP_LIST_OWNER_NOT_EXIST
static Reason | SHIP_QTY_IS_OVER_THAN_DWO_ITEM_ORDERED
static Reason | SHIP_QTY_IS_OVER_THAN_LOCATION_ONHAND
static Reason | SHIP_QTY_IS_OVER_THAN_ONHAND
static Reason | SHIP_QTY_IS_OVER_THAN_ONLOAN_ITEM_ORDERED
static Reason | SHIP_QTY_IS_OVER_THAN_RTV_ITEM_ORDERED
static Reason | SHIP_QTY_IS_OVER_THAN_SO_ITEM_ORDERED
static Reason | SHIP_QTY_IS_OVER_THAN_SWAP_ITEM_ORDERED
static Reason | SHIP_QTY_IS_OVER_THAN_TRANSFER_ITEM_ORDERED
static Reason | SHIP_QTY_IS_SMALLER_THAN_RECEIVE_QTY
static Reason | SHIP_TO_ID_IS_NOT_EXIST
static Reason | SHIPPED_QTY_IS_OVER
static Reason | SHIPPED_QTY_IS_ZERO
static Reason | SHIPPER_HAS_BEEN_CLOSED
static Reason | SHIPPER_HAS_EXIST
static Reason | SHIPPER_ITEM_HAS_BEEN_CLOSED
static Reason | SHIPPER_ITEM_HAS_BEEN_CREATED_INVOICE
static Reason | SHIPPER_ITEM_HAS_MADE_UNBILLED
static Reason | SHIPPER_ITEM_HAS_SHIPPED_COMPLETELY
static Reason | SHIPPER_ITEM_NOT_EXIST
static Reason | SHIPPER_NOT_EXIST
static Reason | SHIPPER_NOT_FOR_SALES_ORDER
static Reason | SO_DOC_NOT_FIND
static Reason | SO_ITEM_NOT_TOTALLY_SHIPPED
static Reason | SO_TOTAL_SMALLER_THAN_AR_PREPAY_PAID_TOTAL
static Reason | SOME_ORDER_IS_ALREADY_HOLD
static Reason | SOME_PARTS_HAVE_BEEN_ISSUED_TO_WO
static Reason | SOMEONE_ELSE_HAVE_UPDATED_IT
static Reason | SOMEONE_ELSE_IS_CHANGING_SERVER_TIME
static Reason | SPEC_ID_HAS_EXIST
static Reason | SPEC_ID_NOT_EXIST
static Reason | SPEC_ID_STILL_USED
static Reason | START_DATE_SHOULD_BE_AFTER_THE_PRIOR_FISCAL_YEAR_END_DATE
static Reason | START_DATE_SHOULD_BE_BEFORE_THE_END_DATE
static Reason | STATUS_ONLY_CAN_CHANGE_TO_CLOSE
static Reason | STATUS_ONLY_CAN_CHANGE_TO_CLOSE_OR_CANCELLED
static Reason | STATUS_ONLY_CAN_CHANGE_TO_NOTAPPROVED
static Reason | STATUS_ONLY_CAN_CHANGE_TO_NOTREVIEWED
static Reason | STATUS_ONLY_CAN_NOT_CHANGE_TO_CLOSE
static Reason | STD_COST_APPROVED_BY_CAN_NOT_BE_EMPTY
static Reason | STD_COST_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY
static Reason | SUB_COMPANY_UNIT_HAS_THE_ACCOUNT_NUMBER
static Reason | SUBCOMPANY_ALREADY_EXIST
static Reason | SUBCOMPANY_NOT_EXIST
static Reason | SWAP_ORDER_APPROVAL_ALREADY_EXIST
static Reason | SWAP_ORDER_APPROVAL_NOT_EXIST
static Reason | SWAP_ORDER_ITEM_ALREADY_SHIPPED
static Reason | SWAP_ORDER_ITEM_NOT_EXIST_FOR_THIS_SWAP_SHIPPER_ITEM
static Reason | SWAP_ORDER_NOT_EXIST
static Reason | SWAP_RECEIVER_NOT_EXIST
static Reason | SWAP_SHIPPER_ITEM_NOT_EXIST
static Reason | SWAP_SHIPPER_NOT_EXIST
static Reason | SYSTEM_LOGIN_LOCKED
static Reason | TEMPLATE_ERROR
static Reason | TEMPORARYEMPLOYEE_ALREADY_ADDED
static Reason | TEMPORARYEMPLOYEE_ID_NOT_EXIST
static Reason | TERM_ALIAS_ALREADY_EXIST
static Reason | TERM_ALREADY_EXIST
static Reason | TERM_NOT_EXIST
static Reason | TERM_VALUE_NOT_LEGAL
static Reason | TERM_WITH_SAME_ALIAS_ALREADY_EXIST
static Reason | TERMINATED_DATE_CAN_NOT_BE_NULL
static Reason | THE_CURRENT_FISCAL_YEAR_DID_NOT_SET
static Reason | THE_CUSTOMER_ALREADY_HAS_A_SALES_CODE
static Reason | THERE_IS_A_RUNNING_WORKSHEET
static Reason | THERE_IS_A_WAITING_WORKSHEET
static Reason | THERE_IS_NO_PART_ONHAND
static Reason | TIME_CARDS_ALREADY_EXIST
static Reason | TIME_CARDS_NOT_EXIST
static Reason | TO_lOCATION_SHOULD_BE_TO_ADDRESS_ID
static Reason | TOOL_CALIBRATION_CONTROL_NUMBER_WRONG
static Reason | TOOL_HAS_ONDEMAND
static Reason | TOOL_HAS_ONHAND
static Reason | TOOL_HAS_ONLOAN
static Reason | TOOL_HAS_ONORDER
static Reason | TOOL_HAS_QA
static Reason | TOOL_HAS_SIP
static Reason | TOOL_HAS_SIT
static Reason | TOOL_HAS_WIP
static Reason | TOOL_INVENTORY_NOT_ENOUGH
static Reason | TOOL_IS_INACTIVE
static Reason | TOOL_IS_TOOL_LIST
static Reason | TOOL_NOT_EXIST
static Reason | TOOL_ONHAND_NOT_EXIST
static Reason | TOOL_USED_IN_API
static Reason | TOOL_USED_IN_ARI
static Reason | TOOL_USED_IN_ECN
static Reason | TOOL_USED_IN_ECR
static Reason | TOOL_USED_IN_LNI
static Reason | TOOL_USED_IN_POI
static Reason | TOOL_USED_IN_QTI
static Reason | TOOL_USED_IN_RFQI
static Reason | TOOL_USED_IN_RMAI
static Reason | TOOL_USED_IN_RTVI
static Reason | TOOL_USED_IN_SOI
static Reason | TOOL_USED_IN_SWSI
static Reason | TOOL_USED_IN_TOI
static Reason | TOOL_USED_IN_TOOL_LIST
static Reason | TOOL_USED_IN_WI
static Reason | TOOL_USED_IN_WIS
static Reason | TOOL_USED_IN_WOI
static Reason | TRACKING_ALREADY_EXIST
static Reason | TRACKING_NOT_EXIST
static Reason | TRACKING_QTY_IS_NEGATIVE
static Reason | TRACKING_QTY_IS_NOT_ENOUGH
static Reason | TRACKING_QTY_IS_ZERO
static Reason | TRACKING_QTY_OVER
static Reason | TRANSACTION_DATE_OVER_GL_NDAYS_OK_OLD
static Reason | TRANSACTION_IS_TOO_OLD
static Reason | TRANSFER_ORDER_APPROVAL_ALREADY_EXIST
static Reason | TRANSFER_ORDER_APPROVAL_NOT_EXIST
static Reason | TRANSFER_ORDER_ITEM_NOT_EXIST_FOR_THIS_TRANSFER_SHIPPER_ITEM
static Reason | TRANSFER_ORDER_ITEM_SHOULD_BE_BACKFLUSH_MATERIAL
static Reason | TRANSFER_ORDER_NOT_EXIST
static Reason | TRANSFER_ORDER_NOT_INNER
static Reason | TRANSFER_ORDER_NOT_OPEN
static Reason | TRANSFER_RECEIVER_NOT_EXIST
static Reason | TRANSFER_SHIPPER_ALREADY_EXIST
static Reason | TRANSFER_SHIPPER_ITEM_NOT_EXIST
static Reason | TRANSFER_SHIPPER_NOT_EXIST
static Reason | UNBILLED_ITEMS_SHOULD_BE_WITH_THE_SAME_UNBILLED_EXCHANGE_FOR_OFFSET
static Reason | UPC_MFG_IS_EMPTY
static Reason | UPDATE_CURRENCY_ERROR
static Reason | UPDATE_ONDEMAND_ERROR
static Reason | USE_TYPE_IS_EXIST
static Reason | USER_GROUP_EXIST
static Reason | USER_GROUP_NOT_EXIST
static Reason | USER_HAS_NO_PERMISSION_TO_UPDATE_ENG_GROUP_PART
static Reason | USER_LOCKED
static Reason | USER_NOT_EXIST
static Reason | VALUE_NOT_MATCH_SUCH_PATTERN
static Reason | VARIANCE_CAN_NOT_BE_ZERO
static Reason | VENDOR_CATALOG_ALREADY_EXIST
static Reason | VENDOR_CATALOG_ALREADY_USED
static Reason | VENDOR_CONTRACT_PRICE_HAS_EXIST
static Reason | VENDOR_CONTRACT_PRICE_ITEM_HAS_EXIST
static Reason | VENDOR_CONTRACT_PRICE_ITEM_NOT_EXIST
static Reason | VENDOR_CONTRACT_PRICE_NOT_EXIST
static Reason | VENDOR_CONTRACT_PRICE_VENDOR_HAS_EXIST
static Reason | VENDOR_CONTRACT_PRICE_VENDOR_NOT_EXIST
static Reason | VENDOR_DOC_NOT_FIND
static Reason | VENDOR_GROUP_USER_ALREADY_EXISTS
static Reason | VENDOR_HAS_BEEN_LOCKED
static Reason | VENDOR_ID_NOT_EXIST
static Reason | VERSION_NOT_SET
static Reason | WEIGHT_UNIT_NOT_EXIST
static Reason | WITHOUT_IRNUMBER
static Reason | WITHOUT_RECEIVER_ITEM_DETAILS
static Reason | WITHOUT_SUCH_METHOD
static Reason | WO_APPROVED_BY_CAN_NOT_BE_EMPTY
static Reason | WO_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY
static Reason | WORK_CENTER_GROUP_ALREADY_EXIST
static Reason | WORK_CENTER_GROUP_ITEM_IS_EMPTY
static Reason | WORK_CENTER_GROUP_ITEM_NUMBER_WRONG
static Reason | WORK_CENTER_GROUP_NOT_EXIST
static Reason | WORK_CENTER_HAS_EXIST
static Reason | WORK_CENTER_IS_BEING_USED
static Reason | WORK_CENTER_NOT_EXIST
static Reason | WORK_CENTER_UNIT_NUMBER_WRONG
static Reason | WORK_INSTRUCTION_ALREADY_EXIST
static Reason | WORK_INSTRUCTION_APPROVAL_ALREADY_EXIST
static Reason | WORK_INSTRUCTION_APPROVAL_NOT_EXIST
static Reason | WORK_INSTRUCTION_NOT_EXIST
static Reason | WORK_ORDER_ALREADY_SETUP_OR_RUN
static Reason | WORK_ORDER_APPROVAL_ALREADY_EXIST
static Reason | WORK_ORDER_APPROVAL_NOT_EXIST
static Reason | WORK_ORDER_ITEM_CAN_NOT_LINK_TO_ITSELF
static Reason | WORK_ORDER_ITEM_HAS_CLOSED
static Reason | WORK_ORDER_ITEM_ISSUE_NOT_EXIST
static Reason | WORK_ORDER_ITEM_ISSUE_NOT_FINISHED
static Reason | WORK_ORDER_ITEM_MFG_STATUS_HAS_SETUP
static Reason | WORK_ORDER_ITEM_MFG_STATUS_NOT_SETUP
static Reason | WORK_ORDER_ITEM_NOT_EXIST
static Reason | WORK_ORDER_ITEM_NOT_OPEN
static Reason | WORK_ORDER_ITEM_QTY_CAN_NOT_CHANGE_TO_ZERO
static Reason | WORK_ORDER_ITEM_QTY_CAN_NOT_LESS_THAN_QTY_ASM
static Reason | WORK_ORDER_ITEM_TIME_DETAIL_NOT_EXIST
static Reason | WORK_ORDER_NOT_EXIST
static Reason | WORK_ORDER_NOT_OPEN
static Reason | WORK_ORDER_WORK_INSTRUCTION_HAS_EXIST
static Reason | WORK_ORDER_WORK_INSTRUCTION_HAS_FINISHED
static Reason | WORK_ORDER_WORK_INSTRUCTION_NOT_EXIST
static Reason | WORK_WORK_SHEET_HAS_EXIST
static Reason | WORK_WORK_SHEET_NOT_EXIST
static Reason | WRONG_CURRENCY_FOR_CUSTOMER
static Reason | WRONG_DOCUMENT_SETTINGS
static Reason | WRONG_DOCUMENT_TYPE
static Reason | WRONG_MONTH_YEAR_NAME
static Reason | WRONG_PASSWORD
static Reason | WRONG_SHIPPER_FOR_SALES_ORDER
static Reason | YOU_CAN_NOT_CHANGE_THE_OTHERS_EXPENSE
static Reason | YOU_CAN_NOT_CHANGE_TOTAL_ONHAND
static Reason | YOU_DID_NOT_LOG_OFF
static Reason | YOU_HAVE_NO_PERMISSION_APPROVAL_OWN_RMA
static Reason | YOU_HAVE_NO_PERMISSION_REVIEW_OWN_ONLOAN
static Reason | YOU_HAVE_NO_PERMISSION_REVIEW_OWN_QUOTE
static Reason | YOU_HAVE_NO_PERMISSION_REVIEW_OWN_SALES_ORDER
static Reason | YOU_HAVE_NOT_APPROVED_GL
static Reason | YOU_HAVE_NOT_OVER_CARRY_ALL_PROFIT_AND_LOSS_ACCOUNT
static Reason | YOU_HAVE_NOT_POST_GL
static Reason | YOUR_ACCOUNT_EXPIRED
Constructor Summary
BIZReason()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

YOUR_ACCOUNT_EXPIRED

public static final Reason YOUR_ACCOUNT_EXPIRED

ACCOUNT_NUMBER_IS_NOT_EXPENSE_ACCOUNT

public static final Reason ACCOUNT_NUMBER_IS_NOT_EXPENSE_ACCOUNT

ADMIN_ACCOUNT_CAN_NOT_BE_REMOVED

public static final Reason ADMIN_ACCOUNT_CAN_NOT_BE_REMOVED

ASSET_HAS_EXIST

public static final Reason ASSET_HAS_EXIST

ASSET_TYPE_ALREADY_EXIST

public static final Reason ASSET_TYPE_ALREADY_EXIST

ASSET_TYPE_IS_ALREADY_USED

public static final Reason ASSET_TYPE_IS_ALREADY_USED

ASSET_ACQUISITION_COST_LESS_THAN_INITIAL_DEPRECIATE_COST

public static final Reason ASSET_ACQUISITION_COST_LESS_THAN_INITIAL_DEPRECIATE_COST

ASSET_INITIAL_DEPRECIATE_COST_LESS_THAN_DEPRECIATED_ACCM

public static final Reason ASSET_INITIAL_DEPRECIATE_COST_LESS_THAN_DEPRECIATED_ACCM

ASSET_NOT_EXIST

public static final Reason ASSET_NOT_EXIST

ACCOUNT_NUMBER_NOT_EXIST

public static final Reason ACCOUNT_NUMBER_NOT_EXIST

ACCOUNT_NUMBER_ALREADY_EXIST

public static final Reason ACCOUNT_NUMBER_ALREADY_EXIST

ASSET_DEPRECIATE_ALREADY_EXIST

public static final Reason ASSET_DEPRECIATE_ALREADY_EXIST

ASSET_ACCUMULATED_DEPRECIATION_OVER

public static final Reason ASSET_ACCUMULATED_DEPRECIATION_OVER

ACCOUNT_NUMBER_IN_USE

public static final Reason ACCOUNT_NUMBER_IN_USE

ACCOUNT_NUMBER_IS_USED_IN_CREDIT

public static final Reason ACCOUNT_NUMBER_IS_USED_IN_CREDIT

ACCOUNT_NUMBER_IS_USED_IN_DEBIT

public static final Reason ACCOUNT_NUMBER_IS_USED_IN_DEBIT

ACCOUNT_NUMBER_IS_USED_IN_ASSET

public static final Reason ACCOUNT_NUMBER_IS_USED_IN_ASSET

ACCOUNT_NUMBER_HAS_CHILD

public static final Reason ACCOUNT_NUMBER_HAS_CHILD

SUB_COMPANY_UNIT_HAS_THE_ACCOUNT_NUMBER

public static final Reason SUB_COMPANY_UNIT_HAS_THE_ACCOUNT_NUMBER

THE_CURRENT_FISCAL_YEAR_DID_NOT_SET

public static final Reason THE_CURRENT_FISCAL_YEAR_DID_NOT_SET

ACCOUNT_CREDIT_DEBIT_WRONG

public static final Reason ACCOUNT_CREDIT_DEBIT_WRONG

ACCOUNT_FISCALYEAR_SETTING_NOT_EXIST

public static final Reason ACCOUNT_FISCALYEAR_SETTING_NOT_EXIST

ACCOUNT_MUST_BE_CURRENT_ASSET

public static final Reason ACCOUNT_MUST_BE_CURRENT_ASSET

ACCOUNT_PAYABLE_NOT_EXIST

public static final Reason ACCOUNT_PAYABLE_NOT_EXIST

ACCOUNT_SETTINGS_GA_COGS_WRONG

public static final Reason ACCOUNT_SETTINGS_GA_COGS_WRONG

ACCOUNT_SETTINGS_GA_PROFIT_FOR_CURRENT_YEAR_WRONG

public static final Reason ACCOUNT_SETTINGS_GA_PROFIT_FOR_CURRENT_YEAR_WRONG

ACCOUNT_SETTINGS_GA_WIP_WRONG

public static final Reason ACCOUNT_SETTINGS_GA_WIP_WRONG

ACCOUNT_SETTINGS_DID_NOT_SET_WIP_START_DATE

public static final Reason ACCOUNT_SETTINGS_DID_NOT_SET_WIP_START_DATE

ACCOUNT_SETTINGS_UNKNOWN_INVENTORY_COST_MOTHED

public static final Reason ACCOUNT_SETTINGS_UNKNOWN_INVENTORY_COST_MOTHED

ACCOUNT_SETTINGS_NOT_EXIST

public static final Reason ACCOUNT_SETTINGS_NOT_EXIST

ACCOUNT_TRANSACTION_TYPE_NOT_EXIST

public static final Reason ACCOUNT_TRANSACTION_TYPE_NOT_EXIST

ACCOUNT_TRANSACTION_TYPE_ALREADY_EXIST

public static final Reason ACCOUNT_TRANSACTION_TYPE_ALREADY_EXIST

ACCOUNT_TYPE_EMPTY

public static final Reason ACCOUNT_TYPE_EMPTY

AMORTIZATION_EXPENSE_ACCOUNT_EMPTY

public static final Reason AMORTIZATION_EXPENSE_ACCOUNT_EMPTY

ACCUMULATED_DEPR_ACCOUNT_EMPTY

public static final Reason ACCUMULATED_DEPR_ACCOUNT_EMPTY

ACCOUNT_CHART_MAPPING_NOT_EXIST

public static final Reason ACCOUNT_CHART_MAPPING_NOT_EXIST

ACCOUNT_CHART_MAPPING_ALREADY_EXIST

public static final Reason ACCOUNT_CHART_MAPPING_ALREADY_EXIST

ACCOUNT_CHART_CATEGORY_NAME_ALREADY_EXIST

public static final Reason ACCOUNT_CHART_CATEGORY_NAME_ALREADY_EXIST

ACCOUNT_CHART_CATEGORY_NAME_NOT_EXIST

public static final Reason ACCOUNT_CHART_CATEGORY_NAME_NOT_EXIST

ACCOUNT_CHART_CATEGORY_NOT_EXIST

public static final Reason ACCOUNT_CHART_CATEGORY_NOT_EXIST

ACCOUNT_CHART_CATEGORY_ALREADY_EXIST

public static final Reason ACCOUNT_CHART_CATEGORY_ALREADY_EXIST

PAID_TOTAL_IS_NOT_EAUAL

public static final Reason PAID_TOTAL_IS_NOT_EAUAL

RECEIVED_TOTAL_IS_NOT_EAUAL

public static final Reason RECEIVED_TOTAL_IS_NOT_EAUAL

ARCM_APPROVED_BY_CAN_NOT_BE_EMPTY

public static final Reason ARCM_APPROVED_BY_CAN_NOT_BE_EMPTY

APDM_APPROVED_BY_CAN_NOT_BE_EMPTY

public static final Reason APDM_APPROVED_BY_CAN_NOT_BE_EMPTY

ARCM_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY

public static final Reason ARCM_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY

APDM_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY

public static final Reason APDM_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY

ASSET_APPROVED_BY_CAN_NOT_BE_EMPTY

public static final Reason ASSET_APPROVED_BY_CAN_NOT_BE_EMPTY

ASSET_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY

public static final Reason ASSET_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY

NCR_APPROVED_BY_CAN_NOT_BE_EMPTY

public static final Reason NCR_APPROVED_BY_CAN_NOT_BE_EMPTY

NCR_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY

public static final Reason NCR_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY

STD_COST_APPROVED_BY_CAN_NOT_BE_EMPTY

public static final Reason STD_COST_APPROVED_BY_CAN_NOT_BE_EMPTY

STD_COST_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY

public static final Reason STD_COST_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY

WO_APPROVED_BY_CAN_NOT_BE_EMPTY

public static final Reason WO_APPROVED_BY_CAN_NOT_BE_EMPTY

WO_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY

public static final Reason WO_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY

ILLEGAL_ACCOUNT_NUMBER

public static final Reason ILLEGAL_ACCOUNT_NUMBER

ADDRESS_ID_IS_NOT_CUSTOMER

public static final Reason ADDRESS_ID_IS_NOT_CUSTOMER

ADDRESS_ID_DOES_NOT_EXIST

public static final Reason ADDRESS_ID_DOES_NOT_EXIST

PART_SHARE_COMPANY_ID_DOES_NOT_EXIST

public static final Reason PART_SHARE_COMPANY_ID_DOES_NOT_EXIST

MANUFACTURER_ID_USED_IN_PART

public static final Reason MANUFACTURER_ID_USED_IN_PART

MANUFACTURER_ID_IS_DELETED

public static final Reason MANUFACTURER_ID_IS_DELETED

ADDRESS_ID_IS_DELETED

public static final Reason ADDRESS_ID_IS_DELETED

ADDRESS_ID_USED_IN_PO

public static final Reason ADDRESS_ID_USED_IN_PO

ADDRESS_ID_USED_IN_SO

public static final Reason ADDRESS_ID_USED_IN_SO

ADDRESS_ID_USED_IN_RFQ

public static final Reason ADDRESS_ID_USED_IN_RFQ

ADDRESS_ID_USED_IN_RTV

public static final Reason ADDRESS_ID_USED_IN_RTV

ADDRESS_ID_USED_IN_RMA

public static final Reason ADDRESS_ID_USED_IN_RMA

ADDRESS_ID_USED_IN_QUOTE

public static final Reason ADDRESS_ID_USED_IN_QUOTE

ADDRESS_ID_USED_IN_WO

public static final Reason ADDRESS_ID_USED_IN_WO

ADDRESS_ID_USED_IN_AR

public static final Reason ADDRESS_ID_USED_IN_AR

ADDRESS_ID_USED_IN_AP

public static final Reason ADDRESS_ID_USED_IN_AP

APPROVED_ACTION_IS_FORBIDDEN_WHEN_UPDATE

public static final Reason APPROVED_ACTION_IS_FORBIDDEN_WHEN_UPDATE

BIZBOX_USER_IS_LOCKED

public static final Reason BIZBOX_USER_IS_LOCKED

BIZBOX_USER_NOT_EMPLOYEE

public static final Reason BIZBOX_USER_NOT_EMPLOYEE

BIZBOX_USER_NOT_EXIST

public static final Reason BIZBOX_USER_NOT_EXIST

BIZBOX_USER_HAS_NO_RULES

public static final Reason BIZBOX_USER_HAS_NO_RULES

BIZBOX_USER_ALREADY_EXIST

public static final Reason BIZBOX_USER_ALREADY_EXIST

BUYER_CODE_DO_NOT_EXIST

public static final Reason BUYER_CODE_DO_NOT_EXIST

BUYER_CODE_ALREADY_EXIST

public static final Reason BUYER_CODE_ALREADY_EXIST

BUYER_CODE_IS_USING

public static final Reason BUYER_CODE_IS_USING

CASH_OR_BANK_BALANCE_CAN_BE_NEGATIVE

public static final Reason CASH_OR_BANK_BALANCE_CAN_BE_NEGATIVE

CATALOG_ALREADY_EXIST

public static final Reason CATALOG_ALREADY_EXIST

CATALOG_NOT_EXIST

public static final Reason CATALOG_NOT_EXIST

CATALOG_IS_USED

public static final Reason CATALOG_IS_USED

JOB_CATEGORY_IS_USED

public static final Reason JOB_CATEGORY_IS_USED

CALCULATE_NEW_CSI_NUMBER_ERROR

public static final Reason CALCULATE_NEW_CSI_NUMBER_ERROR

CALCULATE_NEW_EXPENSES_NUMBER_ERROR

public static final Reason CALCULATE_NEW_EXPENSES_NUMBER_ERROR

CALCULATE_NEW_SALES_ORDER_ERROR

public static final Reason CALCULATE_NEW_SALES_ORDER_ERROR

CALCULATE_NEW_LOAN_NUMBER_ERROR

public static final Reason CALCULATE_NEW_LOAN_NUMBER_ERROR

CALCULATE_NEW_QUOTE_ERROR

public static final Reason CALCULATE_NEW_QUOTE_ERROR

CALCULATE_NEW_RFC_NUMBER_ERROR

public static final Reason CALCULATE_NEW_RFC_NUMBER_ERROR

CALCULATE_NEW_PAYMENT_RUN_NUMBER_ERROR

public static final Reason CALCULATE_NEW_PAYMENT_RUN_NUMBER_ERROR

CAN_NOT_APPROVE_ERROR_GL

public static final Reason CAN_NOT_APPROVE_ERROR_GL

CAN_NOT_CANCEL_GL_APPROVED_BY_OTHER

public static final Reason CAN_NOT_CANCEL_GL_APPROVED_BY_OTHER

CAN_NOT_APPROVE_GL_CREATED_BY_YOURSELF

public static final Reason CAN_NOT_APPROVE_GL_CREATED_BY_YOURSELF

CAN_NOT_ERROR_OR_CANCEL_GL_CREATED_BY_YOURSELF

public static final Reason CAN_NOT_ERROR_OR_CANCEL_GL_CREATED_BY_YOURSELF

CAN_NOT_DELETE_ISSUED_RECORD

public static final Reason CAN_NOT_DELETE_ISSUED_RECORD

CAN_NOT_DELETE_WORK_ORDER_ITEM

public static final Reason CAN_NOT_DELETE_WORK_ORDER_ITEM

CAN_NOT_DELETE_DISASSEMBLE_WORK_ORDER_ITEM

public static final Reason CAN_NOT_DELETE_DISASSEMBLE_WORK_ORDER_ITEM

CAN_NOT_DELETE_PREDEFINED_CHART_ACCOUNT_CATEGORY

public static final Reason CAN_NOT_DELETE_PREDEFINED_CHART_ACCOUNT_CATEGORY

CAN_NOT_CHANGE_PART_FOR_HAS_ISSUED

public static final Reason CAN_NOT_CHANGE_PART_FOR_HAS_ISSUED

CAN_NOT_CHANGE_PART_FOR_HAS_RECEIVED

public static final Reason CAN_NOT_CHANGE_PART_FOR_HAS_RECEIVED

CAN_NOT_CHANGE_PART_FOR_HAS_SHIPPED

public static final Reason CAN_NOT_CHANGE_PART_FOR_HAS_SHIPPED

CAN_NOT_CHANGE_STATUS

public static final Reason CAN_NOT_CHANGE_STATUS

CAN_NOT_CHANGE_THIS_MONTH_EXCHANGE_RATE

public static final Reason CAN_NOT_CHANGE_THIS_MONTH_EXCHANGE_RATE

CAN_NOT_CHANGE_WORK_ORDER_ITEM_QTY_ASM

public static final Reason CAN_NOT_CHANGE_WORK_ORDER_ITEM_QTY_ASM

CAN_NOT_HAVE_WORK_ORDER_ITEM_QTY_ASM

public static final Reason CAN_NOT_HAVE_WORK_ORDER_ITEM_QTY_ASM

CAN_NOT_COPY_PURCHASE_ORDER_FROM_CLOSED_SALES_ORDER_OR_NOT_REVIEW_SALES_ORDER

public static final Reason CAN_NOT_COPY_PURCHASE_ORDER_FROM_CLOSED_SALES_ORDER_OR_NOT_REVIEW_SALES_ORDER

CAN_NOT_COPY_WORK_ORDER_FROM_CLOSED_SALES_ORDER_OR_NOT_REVIEW_SALES_ORDER

public static final Reason CAN_NOT_COPY_WORK_ORDER_FROM_CLOSED_SALES_ORDER_OR_NOT_REVIEW_SALES_ORDER

CAN_NOT_FIND_YOUR_TRUE_NAME

public static final Reason CAN_NOT_FIND_YOUR_TRUE_NAME

CAN_NOT_FIND_DOCUMENT_SETTINGS

public static final Reason CAN_NOT_FIND_DOCUMENT_SETTINGS

CAN_NOT_FIND_DWG_SETTINGS

public static final Reason CAN_NOT_FIND_DWG_SETTINGS

CAN_NOT_FIND_DWF_SETTINGS

public static final Reason CAN_NOT_FIND_DWF_SETTINGS

CAN_NOT_FIND_DOCUMENT

public static final Reason CAN_NOT_FIND_DOCUMENT

CAN_NOT_FIND_SO_DOC_SETTINGS

public static final Reason CAN_NOT_FIND_SO_DOC_SETTINGS

CAN_NOT_FIND_RMA_DOC_SETTINGS

public static final Reason CAN_NOT_FIND_RMA_DOC_SETTINGS

CAN_NOT_FIND_QT_DOC_SETTINGS

public static final Reason CAN_NOT_FIND_QT_DOC_SETTINGS

CAN_NOT_FIND_ACCOUNTING_INFO_DOC_SETTINGS

public static final Reason CAN_NOT_FIND_ACCOUNTING_INFO_DOC_SETTINGS

CAN_NOT_FIND_EDC_DOC_SETTINGS

public static final Reason CAN_NOT_FIND_EDC_DOC_SETTINGS

CAN_NOT_FIND_ADDRESS_QA_DOC_SETTINGS

public static final Reason CAN_NOT_FIND_ADDRESS_QA_DOC_SETTINGS

CAN_NOT_FIND_CUSTOMER_DOC_SETTINGS

public static final Reason CAN_NOT_FIND_CUSTOMER_DOC_SETTINGS

CAN_NOT_FIND_VENDOR_DOC_SETTINGS

public static final Reason CAN_NOT_FIND_VENDOR_DOC_SETTINGS

CAN_NOT_FIND_EMP_TRAINING_RECORDS_SETTINGS

public static final Reason CAN_NOT_FIND_EMP_TRAINING_RECORDS_SETTINGS

CAN_NOT_FIND_CS_ITEM_DOC_SETTINGS

public static final Reason CAN_NOT_FIND_CS_ITEM_DOC_SETTINGS

CAN_NOT_NULL

public static final Reason CAN_NOT_NULL

END_MONTH_CAN_NOT_BE_EARLIER_THAN_START_MONTH

public static final Reason END_MONTH_CAN_NOT_BE_EARLIER_THAN_START_MONTH

SO_DOC_NOT_FIND

public static final Reason SO_DOC_NOT_FIND

RMA_DOC_NOT_FIND

public static final Reason RMA_DOC_NOT_FIND

QT_DOC_NOT_FIND

public static final Reason QT_DOC_NOT_FIND

ACCOUNTING_INFO_DOC_NOT_FIND

public static final Reason ACCOUNTING_INFO_DOC_NOT_FIND

EDC_DOC_NOT_FIND

public static final Reason EDC_DOC_NOT_FIND

ASSET_DEPRECIATE_HAVE_MADE_GL

public static final Reason ASSET_DEPRECIATE_HAVE_MADE_GL

CERTIFICATE_DOC_NOT_FIND

public static final Reason CERTIFICATE_DOC_NOT_FIND

ADDRESS_QA_DOC_NOT_FIND

public static final Reason ADDRESS_QA_DOC_NOT_FIND

VENDOR_DOC_NOT_FIND

public static final Reason VENDOR_DOC_NOT_FIND

CUSTOMER_DOC_NOT_FIND

public static final Reason CUSTOMER_DOC_NOT_FIND

EMP_TRAINING_RECORDS_NOT_FIND

public static final Reason EMP_TRAINING_RECORDS_NOT_FIND

CS_ITEM_DOC_NOT_FIND

public static final Reason CS_ITEM_DOC_NOT_FIND

CAN_NOT_BE_RECEIVED

public static final Reason CAN_NOT_BE_RECEIVED

COST_CAN_NOT_BE_ZERO

public static final Reason COST_CAN_NOT_BE_ZERO

NO_SELECT_OBJECT

public static final Reason NO_SELECT_OBJECT

CARRIER_ALREADY_EXIST

public static final Reason CARRIER_ALREADY_EXIST

CARRIER_USING_BY_SO

public static final Reason CARRIER_USING_BY_SO

CARRIER_USING_BY_PO

public static final Reason CARRIER_USING_BY_PO

CARRIER_USING_BY_RMA

public static final Reason CARRIER_USING_BY_RMA

CARRIER_USING_BY_RTV

public static final Reason CARRIER_USING_BY_RTV

CATEGORY_ID_HAS_EXIST

public static final Reason CATEGORY_ID_HAS_EXIST

CARRIER_NOT_EXIST

public static final Reason CARRIER_NOT_EXIST

GL_MONTH_NOT_EXIST

public static final Reason GL_MONTH_NOT_EXIST

GL_MONTH_ALREADY_CLOSED

public static final Reason GL_MONTH_ALREADY_CLOSED

IT_HAS_NO_GL_TO_OVER_CARRY

public static final Reason IT_HAS_NO_GL_TO_OVER_CARRY

CAN_NOT_ZERO_SIZE_FILE

public static final Reason CAN_NOT_ZERO_SIZE_FILE

CATEGORY_ID_NOT_EXIST

public static final Reason CATEGORY_ID_NOT_EXIST

CATEGORY_ID_STILL_USED

public static final Reason CATEGORY_ID_STILL_USED

CERTIFICATE_DESCRIPTION_NOT_EXIST

public static final Reason CERTIFICATE_DESCRIPTION_NOT_EXIST

CERTIFICATE_DESCRIPTION_ALREADY_EXIST

public static final Reason CERTIFICATE_DESCRIPTION_ALREADY_EXIST

CHECK_NUMBER_NOT_EXIST

public static final Reason CHECK_NUMBER_NOT_EXIST

CHECK_NUMBER_ALREADY_EXIST

public static final Reason CHECK_NUMBER_ALREADY_EXIST

CHECK_NUMBER_NOT_MATCH

public static final Reason CHECK_NUMBER_NOT_MATCH

CHECK_RUN_NOT_EXIST

public static final Reason CHECK_RUN_NOT_EXIST

CHECK_RUN_ALREADY_EXIST

public static final Reason CHECK_RUN_ALREADY_EXIST

CHECK_RUN_ALREADY_COMMITTED

public static final Reason CHECK_RUN_ALREADY_COMMITTED

CHECK_OBJECT_EXIST_ERROR

public static final Reason CHECK_OBJECT_EXIST_ERROR

CLEAR_REFERENCE_DOC_ERROR

public static final Reason CLEAR_REFERENCE_DOC_ERROR

CLOSED_OBJECT_CAN_NOT_ALLOWED_IF_ITEM_NOT_FINISHED

public static final Reason CLOSED_OBJECT_CAN_NOT_ALLOWED_IF_ITEM_NOT_FINISHED

CLOSED_OBJECT_NOT_ALLOW_UPDATE_AGAIN

public static final Reason CLOSED_OBJECT_NOT_ALLOW_UPDATE_AGAIN

CONTRACT_PRICE_HAS_EXIST

public static final Reason CONTRACT_PRICE_HAS_EXIST

CONTRACT_PRICE_NOT_EXIST

public static final Reason CONTRACT_PRICE_NOT_EXIST

CONTRACT_PRICE_ITEM_HAS_EXIST

public static final Reason CONTRACT_PRICE_ITEM_HAS_EXIST

CONTRACT_PRICE_ITEM_NOT_EXIST

public static final Reason CONTRACT_PRICE_ITEM_NOT_EXIST

CONTRACT_PRICE_CUSTOMER_HAS_EXIST

public static final Reason CONTRACT_PRICE_CUSTOMER_HAS_EXIST

CONTRACT_PRICE_CUSTOMER_NOT_EXIST

public static final Reason CONTRACT_PRICE_CUSTOMER_NOT_EXIST

CERTIFICATE_DESCRIPTION_IS_USING

public static final Reason CERTIFICATE_DESCRIPTION_IS_USING

CERTIFICATE_DESCRIPTION_IS_NOT_USING

public static final Reason CERTIFICATE_DESCRIPTION_IS_NOT_USING

CLOSEING_STATEMENT_WRONG

public static final Reason CLOSEING_STATEMENT_WRONG

CREDIT_MEMO_ALREADY_EXIST

public static final Reason CREDIT_MEMO_ALREADY_EXIST

CREDIT_MEMO_NOT_EXIST

public static final Reason CREDIT_MEMO_NOT_EXIST

COMPANY_NOT_EXIST

public static final Reason COMPANY_NOT_EXIST

COMPANY_UNIT_ALREADY_EXIST

public static final Reason COMPANY_UNIT_ALREADY_EXIST

COMPANY_UNIT_DOES_NOT_MATCH

public static final Reason COMPANY_UNIT_DOES_NOT_MATCH

COMPANY_UNIT_NOT_EXIST

public static final Reason COMPANY_UNIT_NOT_EXIST

COMPANY_UNIT_ACCOUNT_NOT_EXIST

public static final Reason COMPANY_UNIT_ACCOUNT_NOT_EXIST

COMPANY_UNIT_ACCOUNT_ALREADY_EXIST

public static final Reason COMPANY_UNIT_ACCOUNT_ALREADY_EXIST

CURRENCY_NOT_EXIST

public static final Reason CURRENCY_NOT_EXIST

POS_NOT_EXIST

public static final Reason POS_NOT_EXIST

FIND_POS_ERROR

public static final Reason FIND_POS_ERROR

ORDER_HAS_BEEN_CLOSED_ENTRY

public static final Reason ORDER_HAS_BEEN_CLOSED_ENTRY

LOCATION_FOR_RETURN_MASTERIAL_IS_NOT_CONFIGURED

public static final Reason LOCATION_FOR_RETURN_MASTERIAL_IS_NOT_CONFIGURED

RMA_DEBIT_ACCOUNT_IS_NOT_CONFIGURED

public static final Reason RMA_DEBIT_ACCOUNT_IS_NOT_CONFIGURED

CUSTOMER_NOT_EXIST_TERM

public static final Reason CUSTOMER_NOT_EXIST_TERM

SUBCOMPANY_ALREADY_EXIST

public static final Reason SUBCOMPANY_ALREADY_EXIST

SUBCOMPANY_NOT_EXIST

public static final Reason SUBCOMPANY_NOT_EXIST

CURRENCY_EXCHANGE_NOT_EXIST

public static final Reason CURRENCY_EXCHANGE_NOT_EXIST

CURRENCY_EXCHANGE_SHOULD_BE_POSITIVE

public static final Reason CURRENCY_EXCHANGE_SHOULD_BE_POSITIVE

CURRENCY_ALREADY_EXIST

public static final Reason CURRENCY_ALREADY_EXIST

CUSTOMER_PART_CATALOG_ALREADY_EXIST

public static final Reason CUSTOMER_PART_CATALOG_ALREADY_EXIST

CUSTOMER_SERVICE_INCIDENT_NOT_EXIST

public static final Reason CUSTOMER_SERVICE_INCIDENT_NOT_EXIST

CUSTOMER_SERVICE_INCIDENT_ALREADY_EXIST

public static final Reason CUSTOMER_SERVICE_INCIDENT_ALREADY_EXIST

CUSTOMER_SERVICE_REQUEST_NOT_EXIST

public static final Reason CUSTOMER_SERVICE_REQUEST_NOT_EXIST

CUSTOMER_FEEDBACK_NOT_EXIST

public static final Reason CUSTOMER_FEEDBACK_NOT_EXIST

CUSTOMER_FEEDBACK_ALREADY_EXIST

public static final Reason CUSTOMER_FEEDBACK_ALREADY_EXIST

CUSTOMER_FEEDBACK_ITEM_NOT_EXIST

public static final Reason CUSTOMER_FEEDBACK_ITEM_NOT_EXIST

CUSTOMER_FEEDBACK_ITEM_ALREADY_EXIST

public static final Reason CUSTOMER_FEEDBACK_ITEM_ALREADY_EXIST

CUSTOMER_VENDOR_TYPE_ALREADY_EXIST

public static final Reason CUSTOMER_VENDOR_TYPE_ALREADY_EXIST

CYCLE_WORK_SHEET_HAS_EXIST

public static final Reason CYCLE_WORK_SHEET_HAS_EXIST

CYCLE_WORK_SHEET_NOT_EXIST

public static final Reason CYCLE_WORK_SHEET_NOT_EXIST

CYCLE_WORK_SHEET_ALREADY_CLOSED

public static final Reason CYCLE_WORK_SHEET_ALREADY_CLOSED

CYCLE_WORK_SHEET_PAGE_NUMBER_HAS_EXIST

public static final Reason CYCLE_WORK_SHEET_PAGE_NUMBER_HAS_EXIST

CYCLE_WORK_SHEET_PAGE_NUMBER_NOT_EXIST

public static final Reason CYCLE_WORK_SHEET_PAGE_NUMBER_NOT_EXIST

NOT_RIGHT_SPECIFY_FOR_WHAT_TO_ADD_TYPE

public static final Reason NOT_RIGHT_SPECIFY_FOR_WHAT_TO_ADD_TYPE

DATE_WRONG

public static final Reason DATE_WRONG

DATE_CAN_NOT_BE_NULL

public static final Reason DATE_CAN_NOT_BE_NULL

DEBITS_NOT_MATCH_CREDITS

public static final Reason DEBITS_NOT_MATCH_CREDITS

DEBITS_OR_CREDIT_DOES_NOT_ZERO

public static final Reason DEBITS_OR_CREDIT_DOES_NOT_ZERO

DESIGN_CONTROL_NOT_EXIST

public static final Reason DESIGN_CONTROL_NOT_EXIST

DELETE_FROM_DB_ERROR

public static final Reason DELETE_FROM_DB_ERROR

DELETE_ON_LOAN_ITEM_ERROR

public static final Reason DELETE_ON_LOAN_ITEM_ERROR

DELETE_QUOTE_ITEM_ERROR

public static final Reason DELETE_QUOTE_ITEM_ERROR

DELETE_RMA_ITEM_ERROR

public static final Reason DELETE_RMA_ITEM_ERROR

DELETE_SALES_ORDER_ITEM_ERROR

public static final Reason DELETE_SALES_ORDER_ITEM_ERROR

DRAWING_WAS_DAMEDAGED

public static final Reason DRAWING_WAS_DAMEDAGED

DOCUMENT_NOT_FOUND

public static final Reason DOCUMENT_NOT_FOUND

PICTURE_NOT_FOUND

public static final Reason PICTURE_NOT_FOUND

DOCUMENT_SERVER_SETTINGS_ALREADY_EXIST

public static final Reason DOCUMENT_SERVER_SETTINGS_ALREADY_EXIST

PARTDWG_NOT_FOUND

public static final Reason PARTDWG_NOT_FOUND

PARTDWF_NOT_FOUND

public static final Reason PARTDWF_NOT_FOUND

DUPLICATE_ITEM

public static final Reason DUPLICATE_ITEM

DUPLICATE_PERIOD_ID

public static final Reason DUPLICATE_PERIOD_ID

DUPLICATE_KEY_ITEM

public static final Reason DUPLICATE_KEY_ITEM

DOCUMENT_SETTINGS_WRONG

public static final Reason DOCUMENT_SETTINGS_WRONG

DOCUMENT_SETTINGS_NOT_EXIST

public static final Reason DOCUMENT_SETTINGS_NOT_EXIST

EMPTY_DOCUMENT

public static final Reason EMPTY_DOCUMENT

EMPLOYEE_ALREADY_ADDED

public static final Reason EMPLOYEE_ALREADY_ADDED

EMPLOYEE_ALREADY_HAS_BIZBOX_USER_ACCOUNT

public static final Reason EMPLOYEE_ALREADY_HAS_BIZBOX_USER_ACCOUNT

EMPLOYEE_HAS_NO_BIZBOX_USER_ACCOUNT

public static final Reason EMPLOYEE_HAS_NO_BIZBOX_USER_ACCOUNT

EMPLOYEE_ID_NOT_EXIST

public static final Reason EMPLOYEE_ID_NOT_EXIST

EMPLOYEE_TRAINING_ID_HAS_EXIST

public static final Reason EMPLOYEE_TRAINING_ID_HAS_EXIST

EMPLOYEE_TRAINING_ID_NOT_EXIST

public static final Reason EMPLOYEE_TRAINING_ID_NOT_EXIST

EMPTY_COLLECTION

public static final Reason EMPTY_COLLECTION

EMPTY_ITEM_COLLECTION

public static final Reason EMPTY_ITEM_COLLECTION

ENGINEERING_CHANGE_NOTICE_NOT_EXIST

public static final Reason ENGINEERING_CHANGE_NOTICE_NOT_EXIST

PART_STILL_IS_HOLD

public static final Reason PART_STILL_IS_HOLD

ORDER_IS_HOLD

public static final Reason ORDER_IS_HOLD

SOME_ORDER_IS_ALREADY_HOLD

public static final Reason SOME_ORDER_IS_ALREADY_HOLD

ENGINEERING_CHANGE_NOTICE_NOT_CLOSED_EXIST_FOR_THIS_PART

public static final Reason ENGINEERING_CHANGE_NOTICE_NOT_CLOSED_EXIST_FOR_THIS_PART

MANUFACTURE_ENGINEERING_CHANGE_NOTICE_NOT_CLOSED_EXIST_FOR_THIS_PART

public static final Reason MANUFACTURE_ENGINEERING_CHANGE_NOTICE_NOT_CLOSED_EXIST_FOR_THIS_PART

PART_IMPORT_FROM_OTHER_COMPANY_CANT_EDIT_REV

public static final Reason PART_IMPORT_FROM_OTHER_COMPANY_CANT_EDIT_REV

ENGINEERING_CHANGE_REQUEST_NOT_EXIST

public static final Reason ENGINEERING_CHANGE_REQUEST_NOT_EXIST

ENGINEERING_SHARING_ALREADY_EXIST

public static final Reason ENGINEERING_SHARING_ALREADY_EXIST

ENGINEERING_SHARING_NOT_EXIST

public static final Reason ENGINEERING_SHARING_NOT_EXIST

ENGINEERING_SHARING_ITEM_ALREADY_EXIST

public static final Reason ENGINEERING_SHARING_ITEM_ALREADY_EXIST

EXCEED_AUTHORIZED_APPROVAL_LIMIT

public static final Reason EXCEED_AUTHORIZED_APPROVAL_LIMIT

EXPENSE_ACCOUNT_ALREADY_EXIST

public static final Reason EXPENSE_ACCOUNT_ALREADY_EXIST

EXPENSE_ACCOUNT_NOT_EXIST

public static final Reason EXPENSE_ACCOUNT_NOT_EXIST

EXPENSE_ALREADY_EXIST

public static final Reason EXPENSE_ALREADY_EXIST

EXPENSE_NOT_EXIST

public static final Reason EXPENSE_NOT_EXIST

FEEDBACK_QUESTION_NOT_EXIST

public static final Reason FEEDBACK_QUESTION_NOT_EXIST

FEEDBACK_QUESTION_ALREADY_EXIST

public static final Reason FEEDBACK_QUESTION_ALREADY_EXIST

FIND_ACCOUNTING_SETTINGS_ERROR

public static final Reason FIND_ACCOUNTING_SETTINGS_ERROR

FIND_ACCOUNT_NUMBER_ERROR

public static final Reason FIND_ACCOUNT_NUMBER_ERROR

FIND_PURCHASE_ORDER_ERROR

public static final Reason FIND_PURCHASE_ORDER_ERROR

FIND_AP_ERROR

public static final Reason FIND_AP_ERROR

FIND_ARP_ERROR

public static final Reason FIND_ARP_ERROR

FIND_ARP_ITEM_ERROR

public static final Reason FIND_ARP_ITEM_ERROR

FIND_APP_ERROR

public static final Reason FIND_APP_ERROR

FIND_APP_ITEM_ERROR

public static final Reason FIND_APP_ITEM_ERROR

APP_ITEM_NOT_EXIST

public static final Reason APP_ITEM_NOT_EXIST

FIND_AP_CHECK_RUN_ERROR

public static final Reason FIND_AP_CHECK_RUN_ERROR

FIND_BALANCE_SHEET_ERROR

public static final Reason FIND_BALANCE_SHEET_ERROR

FIND_GENERAL_LEDGER_SETTINGS

public static final Reason FIND_GENERAL_LEDGER_SETTINGS

FIND_GENERAL_LEDGER_ERROR

public static final Reason FIND_GENERAL_LEDGER_ERROR

FIND_ADDRESS_ID_ERROR

public static final Reason FIND_ADDRESS_ID_ERROR

FIND_CAR_ERROR

public static final Reason FIND_CAR_ERROR

FIND_CARRIER_ERROR

public static final Reason FIND_CARRIER_ERROR

FIND_COMPANY_SETTINGS_ERROR

public static final Reason FIND_COMPANY_SETTINGS_ERROR

FIND_CONTRACT_PRICE_ERROR

public static final Reason FIND_CONTRACT_PRICE_ERROR

FIND_CREDIT_MEMO_ERROR

public static final Reason FIND_CREDIT_MEMO_ERROR

FIND_CURRENCY_ERROR

public static final Reason FIND_CURRENCY_ERROR

FIND_DB_ERROR

public static final Reason FIND_DB_ERROR

TEMPLATE_ERROR

public static final Reason TEMPLATE_ERROR

PART_NUMBER_IS_USED_UP

public static final Reason PART_NUMBER_IS_USED_UP

PART_NUMBER_FOR_CATEGORY_IS_USED_UP

public static final Reason PART_NUMBER_FOR_CATEGORY_IS_USED_UP

PART_NUMBER_ALREADY_IN_USE

public static final Reason PART_NUMBER_ALREADY_IN_USE

PART_NUMBER_MAX_LENGTH_CAN_NOT_SAMLLER_THAN

public static final Reason PART_NUMBER_MAX_LENGTH_CAN_NOT_SAMLLER_THAN

ORDER_WAS_CHANGED

public static final Reason ORDER_WAS_CHANGED

FIND_DEBIT_MEMO_ERROR

public static final Reason FIND_DEBIT_MEMO_ERROR

FIND_EMPLOYEE_ID_ERROR

public static final Reason FIND_EMPLOYEE_ID_ERROR

FIND_TEMPORARYEMPLOYEE_ID_ERROR

public static final Reason FIND_TEMPORARYEMPLOYEE_ID_ERROR

FIND_FISCALYEAR_ERROR

public static final Reason FIND_FISCALYEAR_ERROR

FIND_INVOICE_ERROR

public static final Reason FIND_INVOICE_ERROR

FIND_ON_LOAN_ERROR

public static final Reason FIND_ON_LOAN_ERROR

FIND_ON_LOAN_ITEM_ERROR

public static final Reason FIND_ON_LOAN_ITEM_ERROR

FIND_PARTPK_ERROR

public static final Reason FIND_PARTPK_ERROR

FIND_PART_DESCRIPTION_ERROR

public static final Reason FIND_PART_DESCRIPTION_ERROR

FIND_PART_DISCOUNT_ERROR

public static final Reason FIND_PART_DISCOUNT_ERROR

FIND_PAYMENT_RUN_ERROR

public static final Reason FIND_PAYMENT_RUN_ERROR

FIND_QUOTE_ITEM_ERROR

public static final Reason FIND_QUOTE_ITEM_ERROR

FIND_QUOTE_ERROR

public static final Reason FIND_QUOTE_ERROR

FIND_RECEIVER_ERROR

public static final Reason FIND_RECEIVER_ERROR

FIND_RMA_ERROR

public static final Reason FIND_RMA_ERROR

FIND_RTV_ERROR

public static final Reason FIND_RTV_ERROR

FIND_SALESMAN_ERROR

public static final Reason FIND_SALESMAN_ERROR

FIND_SALES_ORDER_ITEM_ERROR

public static final Reason FIND_SALES_ORDER_ITEM_ERROR

FIND_SALES_ORDER_ERROR

public static final Reason FIND_SALES_ORDER_ERROR

FIND_INCOTERMS_ERROR

public static final Reason FIND_INCOTERMS_ERROR

FIND_MANUFACTURER_ID_ERROR

public static final Reason FIND_MANUFACTURER_ID_ERROR

FIND_NCR_ERROR

public static final Reason FIND_NCR_ERROR

FIND_VENDOR_ID_ERROR

public static final Reason FIND_VENDOR_ID_ERROR

FIND_PAR_ERROR

public static final Reason FIND_PAR_ERROR

FIND_RMA_ITEM_ERROR

public static final Reason FIND_RMA_ITEM_ERROR

FIND_SALES_ORDER_ID_ERROR

public static final Reason FIND_SALES_ORDER_ID_ERROR

FIND_SHIPPER_ERROR

public static final Reason FIND_SHIPPER_ERROR

FIND_WEIGHT_UNIT_ERROR

public static final Reason FIND_WEIGHT_UNIT_ERROR

FIND_WORK_INSTRUCTION_ERROR

public static final Reason FIND_WORK_INSTRUCTION_ERROR

FIND_WORK_CENTER_ERROR

public static final Reason FIND_WORK_CENTER_ERROR

FIND_WORK_ORDER_ERROR

public static final Reason FIND_WORK_ORDER_ERROR

FIND_RRMA_ERROR

public static final Reason FIND_RRMA_ERROR

FIND_RRMA_ITEM_ERROR

public static final Reason FIND_RRMA_ITEM_ERROR

RRMA_CUSTOMERID_NOT_MATCH

public static final Reason RRMA_CUSTOMERID_NOT_MATCH

RRMA_NOT_EXIST

public static final Reason RRMA_NOT_EXIST

RRMA_PK_WRONG

public static final Reason RRMA_PK_WRONG

CALCULATE_NEW_RRMA_NUMBER_ERROR

public static final Reason CALCULATE_NEW_RRMA_NUMBER_ERROR

RRMA_NOT_OPEN

public static final Reason RRMA_NOT_OPEN

RRMA_ALREADY_REVIEWED

public static final Reason RRMA_ALREADY_REVIEWED

FTP_OPERATION_FAILED

public static final Reason FTP_OPERATION_FAILED

FILE_SYSTEM_OPERATION_FAILED

public static final Reason FILE_SYSTEM_OPERATION_FAILED

FISCAL_YEAR_SETTINGS_CAN_NOT_BE_NULL

public static final Reason FISCAL_YEAR_SETTINGS_CAN_NOT_BE_NULL

GENERAL_LEDGER_NOT_EXIST

public static final Reason GENERAL_LEDGER_NOT_EXIST

GENERAL_LEDGER_APPROVAL_NOT_EXIST

public static final Reason GENERAL_LEDGER_APPROVAL_NOT_EXIST

GENERAL_LEDGER_ALREADY_EXIST

public static final Reason GENERAL_LEDGER_ALREADY_EXIST

GENERAL_LEDGER_ALREADY_APPROVED

public static final Reason GENERAL_LEDGER_ALREADY_APPROVED

GENERAL_LEDGER_DEBIT_DESRIPTION_IS_NULL

public static final Reason GENERAL_LEDGER_DEBIT_DESRIPTION_IS_NULL

GENERAL_LEDGER_CREDIT_DESRIPTION_IS_NULL

public static final Reason GENERAL_LEDGER_CREDIT_DESRIPTION_IS_NULL

GENERAL_LEDGER_APPROVAL_ALREADY_EXIST

public static final Reason GENERAL_LEDGER_APPROVAL_ALREADY_EXIST

GENERAL_LEDGER_BEEN_LOCKED

public static final Reason GENERAL_LEDGER_BEEN_LOCKED

GENERAL_LEDGER_NOT_BEEN_LOCKED

public static final Reason GENERAL_LEDGER_NOT_BEEN_LOCKED

GENERAL_LEDGER_SEQUENCE_CAN_NOT_BE_EMPTY

public static final Reason GENERAL_LEDGER_SEQUENCE_CAN_NOT_BE_EMPTY

GENERAL_LEDGER_SEQUENCE_ALREADY_EXIST

public static final Reason GENERAL_LEDGER_SEQUENCE_ALREADY_EXIST

GENERAL_LEDGER_SEQUENCE_NOT_EXIST

public static final Reason GENERAL_LEDGER_SEQUENCE_NOT_EXIST

GET_ENGINEERING_CHANGE_REQUEST_WRONG

public static final Reason GET_ENGINEERING_CHANGE_REQUEST_WRONG

GET_NEW_PURCHASE_WORK_SHEET_NUMBER_ERROR

public static final Reason GET_NEW_PURCHASE_WORK_SHEET_NUMBER_ERROR

GET_PART_STANDARD_COST_ERROR

public static final Reason GET_PART_STANDARD_COST_ERROR

GET_PART_VERSION_ERROR

public static final Reason GET_PART_VERSION_ERROR

GET_PROFORMA_RECEIVER_ERROR

public static final Reason GET_PROFORMA_RECEIVER_ERROR

GET_PURCHASE_ORDER_ERROR

public static final Reason GET_PURCHASE_ORDER_ERROR

GET_AP_PREPAY_ERROR

public static final Reason GET_AP_PREPAY_ERROR

AP_PREPAY_BIGGER_THAN_PO_TOTAL

public static final Reason AP_PREPAY_BIGGER_THAN_PO_TOTAL

AP_PREPAY_PAID_BIGGER_THAN_PO_TOTAL

public static final Reason AP_PREPAY_PAID_BIGGER_THAN_PO_TOTAL

GET_AR_PREPAY_ERROR

public static final Reason GET_AR_PREPAY_ERROR

AR_PREPAY_BIGGER_THAN_SO_TOTAL

public static final Reason AR_PREPAY_BIGGER_THAN_SO_TOTAL

GET_PURCHASE_ORDER_APPROVAL_ERROR

public static final Reason GET_PURCHASE_ORDER_APPROVAL_ERROR

GET_PURCHASE_WORK_SHEET_ERROR

public static final Reason GET_PURCHASE_WORK_SHEET_ERROR

GET_REQUEST_FOR_QUOTE_ERROR

public static final Reason GET_REQUEST_FOR_QUOTE_ERROR

GET_RFQ_MESSAGE_ERROR

public static final Reason GET_RFQ_MESSAGE_ERROR

GET_RETURN_TO_VENDOR_ERROR

public static final Reason GET_RETURN_TO_VENDOR_ERROR

GET_RETURN_TO_VENDOR_APPROVAL_ERROR

public static final Reason GET_RETURN_TO_VENDOR_APPROVAL_ERROR

GET_SALES_ORDER_REVIEW_ERROR

public static final Reason GET_SALES_ORDER_REVIEW_ERROR

GET_ONLOAN_REVIEW_ERROR

public static final Reason GET_ONLOAN_REVIEW_ERROR

GET_CG_CUST_RFQNUMBER_FAIL

public static final Reason GET_CG_CUST_RFQNUMBER_FAIL

GET_CG_CSRNUMBER_FAIL

public static final Reason GET_CG_CSRNUMBER_FAIL

GET_RMA_REVIEW_ERROR

public static final Reason GET_RMA_REVIEW_ERROR

GET_ORDER_ITEM_ERROR

public static final Reason GET_ORDER_ITEM_ERROR

GET_USER_TRUENAME_WRONG

public static final Reason GET_USER_TRUENAME_WRONG

GET_VENDOR_ERROR

public static final Reason GET_VENDOR_ERROR

GET_VENDOR_PART_ERROR

public static final Reason GET_VENDOR_PART_ERROR

GET_CUSTOMER_PART_ERROR

public static final Reason GET_CUSTOMER_PART_ERROR

CUSTOMER_PART_NOT_EXIST

public static final Reason CUSTOMER_PART_NOT_EXIST

GET_VERSION_ERROR

public static final Reason GET_VERSION_ERROR

GET_WORK_ORDER_ERROR

public static final Reason GET_WORK_ORDER_ERROR

GET_WORK_ORDER_APPROVAL_ERROR

public static final Reason GET_WORK_ORDER_APPROVAL_ERROR

GET_WORK_WORK_SHEET_ERROR

public static final Reason GET_WORK_WORK_SHEET_ERROR

HAVE_CALIBRATION_RECORDS

public static final Reason HAVE_CALIBRATION_RECORDS

HAVE_NO_CALIBRATION_RECORDS

public static final Reason HAVE_NO_CALIBRATION_RECORDS

ILLEGAL_CATEGORY_ID

public static final Reason ILLEGAL_CATEGORY_ID

ILEGAL_CREDIT_MEMO

public static final Reason ILEGAL_CREDIT_MEMO

ILLEGAL_DRAWING_EXTENSION

public static final Reason ILLEGAL_DRAWING_EXTENSION

ILLEGAL_DESIGN_CONTROL_DOCUMENT_EXTENSION

public static final Reason ILLEGAL_DESIGN_CONTROL_DOCUMENT_EXTENSION

ILLEGAL_DESIGN_CONTROL_DOCUMENT_SEQUENCE

public static final Reason ILLEGAL_DESIGN_CONTROL_DOCUMENT_SEQUENCE

ILLEGAL_INCOTERM_ID

public static final Reason ILLEGAL_INCOTERM_ID

ILLEGAL_MAKE_BUY_X

public static final Reason ILLEGAL_MAKE_BUY_X

ILLEGAL_EDC_NUMBER

public static final Reason ILLEGAL_EDC_NUMBER

ILLEGAL_ENGINEERING_CHANGE_REQUEST

public static final Reason ILLEGAL_ENGINEERING_CHANGE_REQUEST

ILLEGAL_PART_NUMBER_FORMAT

public static final Reason ILLEGAL_PART_NUMBER_FORMAT

ILLEGAL_PCODE

public static final Reason ILLEGAL_PCODE

ILLEGAL_ECODE

public static final Reason ILLEGAL_ECODE

ILLEGAL_CCODE

public static final Reason ILLEGAL_CCODE

ILLEGAL_OCODE

public static final Reason ILLEGAL_OCODE

ILLEGAL_DCODE

public static final Reason ILLEGAL_DCODE

ILLEGAL_PROFORMA_INVOICE_NUMBER

public static final Reason ILLEGAL_PROFORMA_INVOICE_NUMBER

ILLEGAL_PURCHASE_ORDER_NUMBER

public static final Reason ILLEGAL_PURCHASE_ORDER_NUMBER

ILLEGAL_PO_MESSAGE_NUMBER

public static final Reason ILLEGAL_PO_MESSAGE_NUMBER

ILLEGAL_PURCHASE_ORDER_ITEM_NUMBER

public static final Reason ILLEGAL_PURCHASE_ORDER_ITEM_NUMBER

ILLEGAL_PURCHASE_ORDER_MESSAGE_ITEM_NUMBER

public static final Reason ILLEGAL_PURCHASE_ORDER_MESSAGE_ITEM_NUMBER

ILLEGAL_REQUEST_FOR_QUOTE_NUMBER

public static final Reason ILLEGAL_REQUEST_FOR_QUOTE_NUMBER

ILLEGAL_RFQ_MESSAGE_NUMBER

public static final Reason ILLEGAL_RFQ_MESSAGE_NUMBER

ILLEGAL_REQUEST_FOR_QUOTE_ITEM_NUMBER

public static final Reason ILLEGAL_REQUEST_FOR_QUOTE_ITEM_NUMBER

ILLEGAL_RFQ_MESSAGE_ITEM_NUMBER

public static final Reason ILLEGAL_RFQ_MESSAGE_ITEM_NUMBER

ILLEGAL_RETURN_TO_VENDOR_NUMBER

public static final Reason ILLEGAL_RETURN_TO_VENDOR_NUMBER

ILLEGAL_RETURN_TO_VENDOR_ITEM_NUMBER

public static final Reason ILLEGAL_RETURN_TO_VENDOR_ITEM_NUMBER

ILLEGAL_REVISION_NUMBER_FORMAT

public static final Reason ILLEGAL_REVISION_NUMBER_FORMAT

ILLEGAL_SALES_ORDER_ITEM_NUMBER

public static final Reason ILLEGAL_SALES_ORDER_ITEM_NUMBER

ILLEGAL_QUOTE_ITEM_NUMBER

public static final Reason ILLEGAL_QUOTE_ITEM_NUMBER

ILLEGAL_SHIPPER_NUMBER

public static final Reason ILLEGAL_SHIPPER_NUMBER

ILLEGAL_SHIP_LIST_NUMBER

public static final Reason ILLEGAL_SHIP_LIST_NUMBER

ILLEGAL_SPECIFICATION_ID

public static final Reason ILLEGAL_SPECIFICATION_ID

ILLEGAL_UNIT_NAME

public static final Reason ILLEGAL_UNIT_NAME

ILLEGAL_WORK_INSTRUCTION_SET_NUMBER

public static final Reason ILLEGAL_WORK_INSTRUCTION_SET_NUMBER

ILLEGAL_WORK_INSTRUCTION_SEQUENCE_NUMBER

public static final Reason ILLEGAL_WORK_INSTRUCTION_SEQUENCE_NUMBER

ILLEGAL_WORK_ORDER_NUMBER

public static final Reason ILLEGAL_WORK_ORDER_NUMBER

ILLEGAL_WORK_ORDER_ITEM_NUMBER

public static final Reason ILLEGAL_WORK_ORDER_ITEM_NUMBER

INCOTERM_ALREADY_EXIST

public static final Reason INCOTERM_ALREADY_EXIST

INCOTERM_NOT_EXIST

public static final Reason INCOTERM_NOT_EXIST

INCOTERM_USING_BY_SO

public static final Reason INCOTERM_USING_BY_SO

INCOTERM_USING_BY_PO

public static final Reason INCOTERM_USING_BY_PO

INCOTERM_USING_BY_RMA

public static final Reason INCOTERM_USING_BY_RMA

INCOTERM_USING_BY_RTV

public static final Reason INCOTERM_USING_BY_RTV

INPUT_CAN_NOT_BE_EMPTY_STRING

public static final Reason INPUT_CAN_NOT_BE_EMPTY_STRING

INCLUDE_BOM_SELF

public static final Reason INCLUDE_BOM_SELF

INVOICE_NOT_EXIST

public static final Reason INVOICE_NOT_EXIST

INVOICE_NOT_CONSISTENT

public static final Reason INVOICE_NOT_CONSISTENT

INVALID_PAY_DATE

public static final Reason INVALID_PAY_DATE

AP_PREPAY_GL_IS_NOT_ENOUGH

public static final Reason AP_PREPAY_GL_IS_NOT_ENOUGH

AR_PREPAY_GL_IS_NOT_ENOUGH

public static final Reason AR_PREPAY_GL_IS_NOT_ENOUGH

LINKED_ITEM_NOT_EXIST

public static final Reason LINKED_ITEM_NOT_EXIST

LINKED_ITEM_STATUS_IS_CLOSED

public static final Reason LINKED_ITEM_STATUS_IS_CLOSED

LINED_QTY_IS_OVER

public static final Reason LINED_QTY_IS_OVER

LEVEL_OR_UP_ACCOUNT_NUMBER_WRONG

public static final Reason LEVEL_OR_UP_ACCOUNT_NUMBER_WRONG

ACCOUNT_NUMBER_USING_IN_OPEN_FISCAL_YEAR

public static final Reason ACCOUNT_NUMBER_USING_IN_OPEN_FISCAL_YEAR

NA_PART_NUMBER_CAN_NOT_ALLOW

public static final Reason NA_PART_NUMBER_CAN_NOT_ALLOW

RECURSIVE_BOM_NOT_ALLOWED

public static final Reason RECURSIVE_BOM_NOT_ALLOWED

NON_CONFORMANCE_CODE_NOT_EXIST

public static final Reason NON_CONFORMANCE_CODE_NOT_EXIST

NON_CONFORMANCE_CODE_DESCRIPTION_CANNOT_BE_EMPTY

public static final Reason NON_CONFORMANCE_CODE_DESCRIPTION_CANNOT_BE_EMPTY

NON_CONFORMANCE_CODE_ALREADY_EXIST

public static final Reason NON_CONFORMANCE_CODE_ALREADY_EXIST

NCR_ALREADY_EXIST

public static final Reason NCR_ALREADY_EXIST

NCR_NOT_EXIST

public static final Reason NCR_NOT_EXIST

NCR_SCRAP_QTY_CAN_NOT_BE_ZERO

public static final Reason NCR_SCRAP_QTY_CAN_NOT_BE_ZERO

NCR_SCRAP_QTY_MORE_THAN_PULLED_QTY

public static final Reason NCR_SCRAP_QTY_MORE_THAN_PULLED_QTY

NCR_SCRAP_QTY_MORE_THAN_IN_QA_QTY

public static final Reason NCR_SCRAP_QTY_MORE_THAN_IN_QA_QTY

NCR_HAS_NO_IN_QA_QTY_TO_SCRAP

public static final Reason NCR_HAS_NO_IN_QA_QTY_TO_SCRAP

NCR_PART_IN_DEAL_QTY_ALREADY_BIGGER_THAN_TOTAL_QTY

public static final Reason NCR_PART_IN_DEAL_QTY_ALREADY_BIGGER_THAN_TOTAL_QTY

NCR_IN_QA_COST_CAN_NOT_BE_ZERO

public static final Reason NCR_IN_QA_COST_CAN_NOT_BE_ZERO

NOT_INVOICE_NUMBER

public static final Reason NOT_INVOICE_NUMBER

NOT_SAME_PART_FROM

public static final Reason NOT_SAME_PART_FROM

NOTICE_USER_NOT_EXIST

public static final Reason NOTICE_USER_NOT_EXIST

NOTICE_USER_EXIST

public static final Reason NOTICE_USER_EXIST

PART_ALREADY_EXIST

public static final Reason PART_ALREADY_EXIST

PART_HAS_ONHAND

public static final Reason PART_HAS_ONHAND

PART_HAS_ONDEMAND

public static final Reason PART_HAS_ONDEMAND

PART_HAS_ONORDER

public static final Reason PART_HAS_ONORDER

PART_HAS_ONLOAN

public static final Reason PART_HAS_ONLOAN

PART_HAS_QA

public static final Reason PART_HAS_QA

PART_HAS_WIP

public static final Reason PART_HAS_WIP

PART_HAS_SIP

public static final Reason PART_HAS_SIP

PART_HAS_SIT

public static final Reason PART_HAS_SIT

PART_HAS_MATERIAL

public static final Reason PART_HAS_MATERIAL

PART_HAS_PICTURE

public static final Reason PART_HAS_PICTURE

PART_HAS_WORK_INSTRUCTION

public static final Reason PART_HAS_WORK_INSTRUCTION

PART_HAS_DRAWING

public static final Reason PART_HAS_DRAWING

PART_IS_DELETED

public static final Reason PART_IS_DELETED

PART_IS_LOCKED

public static final Reason PART_IS_LOCKED

PART_IS_BOM

public static final Reason PART_IS_BOM

PART_USED_IN_BOM

public static final Reason PART_USED_IN_BOM

PART_USED_IN_POI

public static final Reason PART_USED_IN_POI

PART_USED_IN_SOI

public static final Reason PART_USED_IN_SOI

PART_USED_IN_WOI

public static final Reason PART_USED_IN_WOI

PART_USED_IN_QTI

public static final Reason PART_USED_IN_QTI

PART_USED_IN_RFQI

public static final Reason PART_USED_IN_RFQI

PART_USED_IN_RTVI

public static final Reason PART_USED_IN_RTVI

PART_USED_IN_RMAI

public static final Reason PART_USED_IN_RMAI

PART_USED_IN_ARI

public static final Reason PART_USED_IN_ARI

PART_USED_IN_API

public static final Reason PART_USED_IN_API

PART_USED_IN_ECR

public static final Reason PART_USED_IN_ECR

PART_USED_IN_ECN

public static final Reason PART_USED_IN_ECN

PART_USED_IN_EDC

public static final Reason PART_USED_IN_EDC

PART_USED_IN_LNI

public static final Reason PART_USED_IN_LNI

PART_USED_IN_TOI

public static final Reason PART_USED_IN_TOI

PART_USED_IN_SWSI

public static final Reason PART_USED_IN_SWSI

PART_CLASS_NEED_BE_A_LETTER

public static final Reason PART_CLASS_NEED_BE_A_LETTER

CAN_NOT_COPY_NOT_APPROVED_ECR

public static final Reason CAN_NOT_COPY_NOT_APPROVED_ECR

PART_NOT_EXIST

public static final Reason PART_NOT_EXIST

PART_SECURITY_LEVEL_NOT_EXIST

public static final Reason PART_SECURITY_LEVEL_NOT_EXIST

PART_SECURITY_LEVEL_USED_IN_PART

public static final Reason PART_SECURITY_LEVEL_USED_IN_PART

ENG_GROUP_USED_IN_PART

public static final Reason ENG_GROUP_USED_IN_PART

ENG_GROUP_USED_IN_ENG_GROUP_USER

public static final Reason ENG_GROUP_USED_IN_ENG_GROUP_USER

ENGROUP_HAS_ITEM

public static final Reason ENGROUP_HAS_ITEM

ENGROUP_NOT_EXIST

public static final Reason ENGROUP_NOT_EXIST

ENGROUP_EXIST

public static final Reason ENGROUP_EXIST

ENGROUP_USER_NOT_EXIST

public static final Reason ENGROUP_USER_NOT_EXIST

ENGROUP_USER_EXIST

public static final Reason ENGROUP_USER_EXIST

USER_HAS_NO_PERMISSION_TO_UPDATE_ENG_GROUP_PART

public static final Reason USER_HAS_NO_PERMISSION_TO_UPDATE_ENG_GROUP_PART

ONLINE_USER_CAN_NOT_BE_REMOVED

public static final Reason ONLINE_USER_CAN_NOT_BE_REMOVED

PART_TPYE_IS_USING

public static final Reason PART_TPYE_IS_USING

QUOTE_NOT_EXIST

public static final Reason QUOTE_NOT_EXIST

QUOTE_WITHOUT_ITEMS

public static final Reason QUOTE_WITHOUT_ITEMS

QUOTE_ITEM_PK_WRONG

public static final Reason QUOTE_ITEM_PK_WRONG

BOM_ALREADY_EXIST

public static final Reason BOM_ALREADY_EXIST

BOM_NOT_EXIST

public static final Reason BOM_NOT_EXIST

BOM_APPROVAL_NOT_EXIST

public static final Reason BOM_APPROVAL_NOT_EXIST

BOM_APPROVAL_ALREADY_EXIST

public static final Reason BOM_APPROVAL_ALREADY_EXIST

PART_NOT_BOM

public static final Reason PART_NOT_BOM

PART_NOT_SAME_BETWEEN_TWO_ORDERS

public static final Reason PART_NOT_SAME_BETWEEN_TWO_ORDERS

PLEASE_FILL_IN_UOM

public static final Reason PLEASE_FILL_IN_UOM

EQUIPMENT_NOT_EXIST

public static final Reason EQUIPMENT_NOT_EXIST

EQUIPMENT_ALREADY_EXIST

public static final Reason EQUIPMENT_ALREADY_EXIST

EQUIPMENT_ALREADY_USED_IN_WORK_CENTER

public static final Reason EQUIPMENT_ALREADY_USED_IN_WORK_CENTER

EQUIPMENT_ALREADY_REF_TO_ASSET

public static final Reason EQUIPMENT_ALREADY_REF_TO_ASSET

MAINTENANCE_ITEM_NOT_EXIST

public static final Reason MAINTENANCE_ITEM_NOT_EXIST

MAINTENANCE_ITEM_ALREADY_EXIST

public static final Reason MAINTENANCE_ITEM_ALREADY_EXIST

MANUFACTURER_ID_NOT_EXIST

public static final Reason MANUFACTURER_ID_NOT_EXIST

MESSAGE_IN_MONTH_NEED_REMAIN

public static final Reason MESSAGE_IN_MONTH_NEED_REMAIN

MISSING_OR_WRONG_ACCOUNT_FOR_RETAINED_ERANINGS

public static final Reason MISSING_OR_WRONG_ACCOUNT_FOR_RETAINED_ERANINGS

MODIFY_ONHAND_INQA_ERROR

public static final Reason MODIFY_ONHAND_INQA_ERROR

MYSELF_CAN_NOT_BE_REMOVED

public static final Reason MYSELF_CAN_NOT_BE_REMOVED

OTHER_PEOPLE_IS_RUNNING_MRP_PLEASE_TRY_AGAIN_LATER

public static final Reason OTHER_PEOPLE_IS_RUNNING_MRP_PLEASE_TRY_AGAIN_LATER

OTHER_PEOPLE_IS_RECEIVING_PLEASE_TRY_AGAIN

public static final Reason OTHER_PEOPLE_IS_RECEIVING_PLEASE_TRY_AGAIN

OTHER_PEOPLE_IS_RUNNING_AUDIT_ONDEMAND_PLEASE_TRY_AGAIN_LATER

public static final Reason OTHER_PEOPLE_IS_RUNNING_AUDIT_ONDEMAND_PLEASE_TRY_AGAIN_LATER

NCR_PARTNUMBER_CANNOT_BE_CHANGED

public static final Reason NCR_PARTNUMBER_CANNOT_BE_CHANGED

NO_OPEN_SALES_ORDER_FOUND

public static final Reason NO_OPEN_SALES_ORDER_FOUND

NO_RECEIVERS

public static final Reason NO_RECEIVERS

NO_WORK_INSTRUCTION_SEQUENCES

public static final Reason NO_WORK_INSTRUCTION_SEQUENCES

NOT_APPROVED_WORK_ORDER_ITEM_WILL_BE_SETUP

public static final Reason NOT_APPROVED_WORK_ORDER_ITEM_WILL_BE_SETUP

REPLACEMENT_PART_ITEMS_ERROR

public static final Reason REPLACEMENT_PART_ITEMS_ERROR

NOT_AUTHORIZED_APPROVER

public static final Reason NOT_AUTHORIZED_APPROVER

NOT_AUTHORIZED_APPROVER_TO_APPROVE_SELF

public static final Reason NOT_AUTHORIZED_APPROVER_TO_APPROVE_SELF

NOT_GROUP_ISSUE_ITEM_AGENT_ITEM_NUMBER_NOT_RIGHT

public static final Reason NOT_GROUP_ISSUE_ITEM_AGENT_ITEM_NUMBER_NOT_RIGHT

NOT_FOUND_TAX_RATE_ACCOUNT

public static final Reason NOT_FOUND_TAX_RATE_ACCOUNT

NOT_FOUND_APPROVED_BY_IN_SETTINGS

public static final Reason NOT_FOUND_APPROVED_BY_IN_SETTINGS

NOT_EXIST_ITEM_TO_RECEIVE_OR_SHIP

public static final Reason NOT_EXIST_ITEM_TO_RECEIVE_OR_SHIP

NOT_OBJECT_TO_APPROVED

public static final Reason NOT_OBJECT_TO_APPROVED

NOT_OPEN_NCR_TO_SHIP

public static final Reason NOT_OPEN_NCR_TO_SHIP

NOT_APPROVED_GL_TO_CANCEL

public static final Reason NOT_APPROVED_GL_TO_CANCEL

POSTED_GL_CAN_NOT_BE_CANCEL_APPROVE

public static final Reason POSTED_GL_CAN_NOT_BE_CANCEL_APPROVE

NOT_APPROVED_GL_CAN_NOT_POST

public static final Reason NOT_APPROVED_GL_CAN_NOT_POST

ERROR_GL_CAN_NOT_POST

public static final Reason ERROR_GL_CAN_NOT_POST

NOT_OPEN_SALES_ORDER_TO_MAKE_SHIPPER

public static final Reason NOT_OPEN_SALES_ORDER_TO_MAKE_SHIPPER

NOT_OPEN_SALES_ORDER_ITEM_ADD_TO_SHIPPER

public static final Reason NOT_OPEN_SALES_ORDER_ITEM_ADD_TO_SHIPPER

NOT_OPEN_SALES_ORDER_ITEM_TO_SHIP

public static final Reason NOT_OPEN_SALES_ORDER_ITEM_TO_SHIP

NOT_OPEN_SALES_ORDER_TO_SHIP

public static final Reason NOT_OPEN_SALES_ORDER_TO_SHIP

NOT_OPEN_WORK_ORDER_ITEM_TO_ISSUE_PART

public static final Reason NOT_OPEN_WORK_ORDER_ITEM_TO_ISSUE_PART

NOT_OPEN_WORK_ORDER_TO_ISSUE_PART

public static final Reason NOT_OPEN_WORK_ORDER_TO_ISSUE_PART

RECEIVE_QTY_IS_NOT_SAME_WITH_WO_PART_DETAIL_QTY

public static final Reason RECEIVE_QTY_IS_NOT_SAME_WITH_WO_PART_DETAIL_QTY

RECEIVE_ITEM_DOSE_NOT_EXIST_IN_WO_PART_DETAIL

public static final Reason RECEIVE_ITEM_DOSE_NOT_EXIST_IN_WO_PART_DETAIL

NOT_STRING

public static final Reason NOT_STRING

NOT_CHARACTER

public static final Reason NOT_CHARACTER

NOT_LETTER

public static final Reason NOT_LETTER

NOT_MATCH_PART_WiTH_WORK_ORDER_ITEM

public static final Reason NOT_MATCH_PART_WiTH_WORK_ORDER_ITEM

NOT_MATCH_EMPLOYEE_ID_WITH_BIZBOX_USER

public static final Reason NOT_MATCH_EMPLOYEE_ID_WITH_BIZBOX_USER

NOT_MATCH_OWNER_NAME_WITH_SHIP_LIST_OWNER

public static final Reason NOT_MATCH_OWNER_NAME_WITH_SHIP_LIST_OWNER

NOT_MATCH_BIZBOX_USER_EXIST

public static final Reason NOT_MATCH_BIZBOX_USER_EXIST

NOT_NUMBER_STRING

public static final Reason NOT_NUMBER_STRING

NOT_NUMBER

public static final Reason NOT_NUMBER

NOT_DIGDECIMAL

public static final Reason NOT_DIGDECIMAL

NOT_RIGHT_BOM_ITEM

public static final Reason NOT_RIGHT_BOM_ITEM

NOT_RIGHT_MANUFACTURERS_GROUP_FORMAT

public static final Reason NOT_RIGHT_MANUFACTURERS_GROUP_FORMAT

NOT_RIGHT_DESIGN_CONTROL_NUMBER_OF_DOCUMENT

public static final Reason NOT_RIGHT_DESIGN_CONTROL_NUMBER_OF_DOCUMENT

NOT_RIGHT_PACKING_BOX_NUMBER

public static final Reason NOT_RIGHT_PACKING_BOX_NUMBER

NOT_RIGHT_PART_TRACEABLE_CATEGORY_ITEM

public static final Reason NOT_RIGHT_PART_TRACEABLE_CATEGORY_ITEM

NOT_RIGHT_PART_TRACEABLE_SPECIFICATION_ITEM

public static final Reason NOT_RIGHT_PART_TRACEABLE_SPECIFICATION_ITEM

NOT_RIGHT_PURCHASE_ORDER_ITEM

public static final Reason NOT_RIGHT_PURCHASE_ORDER_ITEM

NOT_RIGHT_AP_PREPAY_ITEM

public static final Reason NOT_RIGHT_AP_PREPAY_ITEM

NOT_RIGHT_AR_PREPAY_ITEM

public static final Reason NOT_RIGHT_AR_PREPAY_ITEM

AP_PREPAY_ALREDAY_PAID

public static final Reason AP_PREPAY_ALREDAY_PAID

AP_PREPAY_ALREDAY_APPLY

public static final Reason AP_PREPAY_ALREDAY_APPLY

AR_PREPAY_ALREDAY_PAID

public static final Reason AR_PREPAY_ALREDAY_PAID

NOT_RIGHT_PURCHASE_ORDER_MESSAGE_ITEM

public static final Reason NOT_RIGHT_PURCHASE_ORDER_MESSAGE_ITEM

NOT_RIGHT_PROFORMA_INVOICE_NUMBER

public static final Reason NOT_RIGHT_PROFORMA_INVOICE_NUMBER

NOT_RIGHT_PURCHASE_WORK_SHEET_ITEM

public static final Reason NOT_RIGHT_PURCHASE_WORK_SHEET_ITEM

NOT_RIGHT_PURCHASE_ORDER_ITEM_MANUFACTURER

public static final Reason NOT_RIGHT_PURCHASE_ORDER_ITEM_MANUFACTURER

NOT_RIGHT_REQUEST_FOR_QUOTE_ITEM

public static final Reason NOT_RIGHT_REQUEST_FOR_QUOTE_ITEM

NOT_RIGHT_RFQ_MESSAGE_ITEM

public static final Reason NOT_RIGHT_RFQ_MESSAGE_ITEM

NOT_RIGHT_REQUEST_FOR_QUOTE_ITEM_MANUFACTURER

public static final Reason NOT_RIGHT_REQUEST_FOR_QUOTE_ITEM_MANUFACTURER

NOT_RIGHT_RETURN_TO_VENDOR_ITEM

public static final Reason NOT_RIGHT_RETURN_TO_VENDOR_ITEM

NOT_RIGHT_RETURN_TO_VENDOR_ITEM_MANUFACTURER

public static final Reason NOT_RIGHT_RETURN_TO_VENDOR_ITEM_MANUFACTURER

NOT_RIGHT_RETURN_MATERIAL_AUTHORIZATION_ITEM_MANUFACTURER

public static final Reason NOT_RIGHT_RETURN_MATERIAL_AUTHORIZATION_ITEM_MANUFACTURER

NOT_RIGHT_SALES_ORDER_ADD_TO_SHIPPER

public static final Reason NOT_RIGHT_SALES_ORDER_ADD_TO_SHIPPER

NOT_RIGHT_SALES_ORDER_ITEM_ADD_TO_SHIPPER

public static final Reason NOT_RIGHT_SALES_ORDER_ITEM_ADD_TO_SHIPPER

NOT_RIGHT_VENDORS_GROUP_FORMAT

public static final Reason NOT_RIGHT_VENDORS_GROUP_FORMAT

NO_RIGHT_WORK_INSTRUCTION_SET_ID

public static final Reason NO_RIGHT_WORK_INSTRUCTION_SET_ID

NOT_RIGHT_WORK_ORDER_ITEM

public static final Reason NOT_RIGHT_WORK_ORDER_ITEM

NOT_RIGHT_WORK_ORDER_WORK_INSTRUCTION_SEQUENCE

public static final Reason NOT_RIGHT_WORK_ORDER_WORK_INSTRUCTION_SEQUENCE

NOT_RIGHT_WORK_WORK_SHEET_ITEM

public static final Reason NOT_RIGHT_WORK_WORK_SHEET_ITEM

NOT_APPROVED_REQUEST_FOR_QUOTE_IS_NOT_ALLOWED_TO_PURCHASE_ORDER

public static final Reason NOT_APPROVED_REQUEST_FOR_QUOTE_IS_NOT_ALLOWED_TO_PURCHASE_ORDER

NUMBER_CAN_NOT_LESS_THEN_ZERO

public static final Reason NUMBER_CAN_NOT_LESS_THEN_ZERO

NUMBER_CAN_NOT_BE_ZERO

public static final Reason NUMBER_CAN_NOT_BE_ZERO

ON_LOAN_ALREADY_REVIEWED

public static final Reason ON_LOAN_ALREADY_REVIEWED

ON_LOAN_NOT_EXIST

public static final Reason ON_LOAN_NOT_EXIST

ON_LOAN_ALREADY_EXIST

public static final Reason ON_LOAN_ALREADY_EXIST

ON_LOAN_ITEM_PK_ERROR

public static final Reason ON_LOAN_ITEM_PK_ERROR

ON_LOAN_ITEM_NOT_EXIST

public static final Reason ON_LOAN_ITEM_NOT_EXIST

SHIP_QTY_IS_OVER_THAN_ONLOAN_ITEM_ORDERED

public static final Reason SHIP_QTY_IS_OVER_THAN_ONLOAN_ITEM_ORDERED

ORDER_NOT_IN_MY_PRINTLIST

public static final Reason ORDER_NOT_IN_MY_PRINTLIST

ORDER_ALREADY_IN_MY_PRINTLIST

public static final Reason ORDER_ALREADY_IN_MY_PRINTLIST

OUTSIDE_COMPANY_EMPLOYID_MUST_BE_NULL

public static final Reason OUTSIDE_COMPANY_EMPLOYID_MUST_BE_NULL

INTERNAL_COMPANY_EMPLOYID_CAN_NOT_BE_NULL

public static final Reason INTERNAL_COMPANY_EMPLOYID_CAN_NOT_BE_NULL

HAVE_ITEMS_NOT_CLOSED

public static final Reason HAVE_ITEMS_NOT_CLOSED

NO_PERMISSION_TO_UPDATE_CLOSED_ORDER

public static final Reason NO_PERMISSION_TO_UPDATE_CLOSED_ORDER

PART_ALREADY_BOM

public static final Reason PART_ALREADY_BOM

PART_WITH_NCR

public static final Reason PART_WITH_NCR

PAR_ALREADY_EXIST

public static final Reason PAR_ALREADY_EXIST

PAR_NOT_EXIST

public static final Reason PAR_NOT_EXIST

PAR_ITEM_ALREADY_EXIST

public static final Reason PAR_ITEM_ALREADY_EXIST

PASSWORD_IS_TOO_SHORT

public static final Reason PASSWORD_IS_TOO_SHORT

PAR_ITEM_NOT_EXIST

public static final Reason PAR_ITEM_NOT_EXIST

PACKING_BOX_NOT_EXIST

public static final Reason PACKING_BOX_NOT_EXIST

PACKING_BOX_ALREADY_EXIST

public static final Reason PACKING_BOX_ALREADY_EXIST

PACKING_BOX_ITEM_NOT_EXIST

public static final Reason PACKING_BOX_ITEM_NOT_EXIST

PACKING_BOX_ITEM_ALREADY_EXIST

public static final Reason PACKING_BOX_ITEM_ALREADY_EXIST

LAST_PACKING_BOX_IS_EMPTY

public static final Reason LAST_PACKING_BOX_IS_EMPTY

PACKING_BOX_IS_NOT_EMPTY

public static final Reason PACKING_BOX_IS_NOT_EMPTY

CAN_NOT_UPDATE_SHIPPED_PACKING_BOX

public static final Reason CAN_NOT_UPDATE_SHIPPED_PACKING_BOX

PACKING_BOX_BOX_INFO_NOT_COMPLETED

public static final Reason PACKING_BOX_BOX_INFO_NOT_COMPLETED

PAYMENT_RUN_NOT_EXIST

public static final Reason PAYMENT_RUN_NOT_EXIST

PAYMENT_RUN_ALREADY_EXIST

public static final Reason PAYMENT_RUN_ALREADY_EXIST

ILLEGAL_PART_REVISION

public static final Reason ILLEGAL_PART_REVISION

PARTCATALOG_NOT_EXIST

public static final Reason PARTCATALOG_NOT_EXIST

PART_CERTIFICATE_NOT_EXIST

public static final Reason PART_CERTIFICATE_NOT_EXIST

PART_CERTIFICATE_ALREADY_EXIST

public static final Reason PART_CERTIFICATE_ALREADY_EXIST

PART_CLASS_NOT_EXIST

public static final Reason PART_CLASS_NOT_EXIST

PART_CLASS_IS_USED

public static final Reason PART_CLASS_IS_USED

PART_CLASS_ALREADY_EXIST

public static final Reason PART_CLASS_ALREADY_EXIST

PART_FROM_NOT_EXIST

public static final Reason PART_FROM_NOT_EXIST

PART_EXIST

public static final Reason PART_EXIST

PART_SECURITY_LEVEL_EXIST

public static final Reason PART_SECURITY_LEVEL_EXIST

PART_PICTURE_WITHOUT_LENGTH

public static final Reason PART_PICTURE_WITHOUT_LENGTH

PART_MATERIAL_NOT_EXIST

public static final Reason PART_MATERIAL_NOT_EXIST

PART_MATERIAL_ALREADY_EXIST

public static final Reason PART_MATERIAL_ALREADY_EXIST

PART_ONHAND_NOT_EXIST

public static final Reason PART_ONHAND_NOT_EXIST

PART_TYPE_ALREADY_EXIST

public static final Reason PART_TYPE_ALREADY_EXIST

PART_TYPE_NOT_EXIST

public static final Reason PART_TYPE_NOT_EXIST

PART_VENDOR_EXIST

public static final Reason PART_VENDOR_EXIST

PART_VENDOR_NOT_EXIST

public static final Reason PART_VENDOR_NOT_EXIST

PAYMENT_RUN_ALREADY_COMMITTED

public static final Reason PAYMENT_RUN_ALREADY_COMMITTED

PLEASE_INPUT_A_OPEN_WORK_ORDER

public static final Reason PLEASE_INPUT_A_OPEN_WORK_ORDER

PLEASE_CHECK_WORK_INSTRUCTION_SEQUENCE

public static final Reason PLEASE_CHECK_WORK_INSTRUCTION_SEQUENCE

PLEASE_CHECK_WORK_INSTRUCTION_SEQUENCE_OR_WORK_CENTER

public static final Reason PLEASE_CHECK_WORK_INSTRUCTION_SEQUENCE_OR_WORK_CENTER

PHYSICAL_WORK_SHEET_HAS_EXIST

public static final Reason PHYSICAL_WORK_SHEET_HAS_EXIST

PHYSICAL_WORK_SHEET_NOT_EXIST

public static final Reason PHYSICAL_WORK_SHEET_NOT_EXIST

PHYSICAL_WORK_SHEET_PAGE_NUMBER_HAS_EXIST

public static final Reason PHYSICAL_WORK_SHEET_PAGE_NUMBER_HAS_EXIST

PHYSICAL_WORK_SHEET_PAGE_NUMBER_NOT_EXIST

public static final Reason PHYSICAL_WORK_SHEET_PAGE_NUMBER_NOT_EXIST

PHYSICAL_WORK_SHEET_ALREADY_CLOSED

public static final Reason PHYSICAL_WORK_SHEET_ALREADY_CLOSED

PROFORMA_INVOICE_HAS_EXIST

public static final Reason PROFORMA_INVOICE_HAS_EXIST

PROFORMA_INVOICE_NOT_EXIST

public static final Reason PROFORMA_INVOICE_NOT_EXIST

PROFORMA_INVOICE_NOT_OPEN

public static final Reason PROFORMA_INVOICE_NOT_OPEN

PROFORMA_INVOICE_ITEM_NOT_EXIST

public static final Reason PROFORMA_INVOICE_ITEM_NOT_EXIST

PROFORMA_RECEIVER_NOT_EXIST

public static final Reason PROFORMA_RECEIVER_NOT_EXIST

PULL_OUT_ON_DEMAND_ERROR

public static final Reason PULL_OUT_ON_DEMAND_ERROR

PURCHASE_ORDER_APPROVAL_NOT_EXIST

public static final Reason PURCHASE_ORDER_APPROVAL_NOT_EXIST

ECR_APPROVAL_NOT_EXIST

public static final Reason ECR_APPROVAL_NOT_EXIST

PURCHASE_ORDER_APPROVAL_ALREADY_EXIST

public static final Reason PURCHASE_ORDER_APPROVAL_ALREADY_EXIST

PURCHASE_ORDER_HAS_EXIST

public static final Reason PURCHASE_ORDER_HAS_EXIST

PURCHASE_ORDER_MESSAGE_HAS_EXIST

public static final Reason PURCHASE_ORDER_MESSAGE_HAS_EXIST

PURCHASE_ORDER_MESSAGE_NOT_EXIST

public static final Reason PURCHASE_ORDER_MESSAGE_NOT_EXIST

PURCHASE_ORDER_NOT_EXIST

public static final Reason PURCHASE_ORDER_NOT_EXIST

AP_PREPAY_ALREADY_EXIST

public static final Reason AP_PREPAY_ALREADY_EXIST

AP_PREPAY_ALREADY_CANCELLED

public static final Reason AP_PREPAY_ALREADY_CANCELLED

PURCHASE_ORDER_ALREADY_RECEIVED

public static final Reason PURCHASE_ORDER_ALREADY_RECEIVED

PURCHASE_ORDER_ITEM_ALREADY_RECEIVED_OR_IN_SIT

public static final Reason PURCHASE_ORDER_ITEM_ALREADY_RECEIVED_OR_IN_SIT

PURCHASE_ORDER_NOT_OPEN

public static final Reason PURCHASE_ORDER_NOT_OPEN

PURCHASE_ORDER_NOT_APPROVED

public static final Reason PURCHASE_ORDER_NOT_APPROVED

PURCHASE_ORDER_ITEM_NOT_EXIST

public static final Reason PURCHASE_ORDER_ITEM_NOT_EXIST

PURCHASE_ORDER_ITEM_NOT_CONTAINS_THIS_PART

public static final Reason PURCHASE_ORDER_ITEM_NOT_CONTAINS_THIS_PART

PURCHASE_ORDER_ITEM_STATUS_NOT_OPEN

public static final Reason PURCHASE_ORDER_ITEM_STATUS_NOT_OPEN

PURCHASE_WORK_SHEET_HAS_EXIST

public static final Reason PURCHASE_WORK_SHEET_HAS_EXIST

PURCHASE_WORK_SHEET_NOT_EXIST

public static final Reason PURCHASE_WORK_SHEET_NOT_EXIST

PURCHASE_ORDER_ITEM_HAS_REFERENCE

public static final Reason PURCHASE_ORDER_ITEM_HAS_REFERENCE

QUANTITY_CAN_NOT_LESS_THAN_ZERO

public static final Reason QUANTITY_CAN_NOT_LESS_THAN_ZERO

QUANTIRY_CAN_NOT_BE_ZERO

public static final Reason QUANTIRY_CAN_NOT_BE_ZERO

RECEIVER_NOT_EXIST

public static final Reason RECEIVER_NOT_EXIST

RECEIVER_HAS_EXIST

public static final Reason RECEIVER_HAS_EXIST

RECEIVER_IS_NOT_FOR_THIS_PO

public static final Reason RECEIVER_IS_NOT_FOR_THIS_PO

RECEIVER_HAS_BEEN_CLOSED

public static final Reason RECEIVER_HAS_BEEN_CLOSED

RECEIVER_ITEM_HAS_BEEN_CLOSED

public static final Reason RECEIVER_ITEM_HAS_BEEN_CLOSED

RECEIVER_ITEM_HAS_BEEN_CREATED_AP

public static final Reason RECEIVER_ITEM_HAS_BEEN_CREATED_AP

RECEIVE_TO_WRONG_WAREHOUSE

public static final Reason RECEIVE_TO_WRONG_WAREHOUSE

REF_DOC_HAS_EXIST

public static final Reason REF_DOC_HAS_EXIST

REF_DOC_NOT_EXIST

public static final Reason REF_DOC_NOT_EXIST

REF_DOC_CLOSED

public static final Reason REF_DOC_CLOSED

REF_DOC_TOTAL_QTY_MORE_THAN_QTY_OF_FROM_ORDER

public static final Reason REF_DOC_TOTAL_QTY_MORE_THAN_QTY_OF_FROM_ORDER

REF_DOC_TOTAL_QTY_MORE_THAN_QTY_OF_TO_ORDER

public static final Reason REF_DOC_TOTAL_QTY_MORE_THAN_QTY_OF_TO_ORDER

REQUEST_FOR_QUOTE_NOT_EXIST

public static final Reason REQUEST_FOR_QUOTE_NOT_EXIST

DUPLICATE_REVISION_LETTERS

public static final Reason DUPLICATE_REVISION_LETTERS

RFQ_MESSAGE_NOT_EXIST

public static final Reason RFQ_MESSAGE_NOT_EXIST

RFQ_MESSAGE_HAS_EXIST

public static final Reason RFQ_MESSAGE_HAS_EXIST

RETURN_TO_VENDOR_NOT_EXIST

public static final Reason RETURN_TO_VENDOR_NOT_EXIST

RTV_SHIPPER_NOT_EXIST

public static final Reason RTV_SHIPPER_NOT_EXIST

RTV_ITEM_ALREADY_SHIPPER

public static final Reason RTV_ITEM_ALREADY_SHIPPER

RTV_APPROVAL_ALREADY_EXIST

public static final Reason RTV_APPROVAL_ALREADY_EXIST

RTV_APPROVAL_NOT_EXIST

public static final Reason RTV_APPROVAL_NOT_EXIST

RMA_ALREADY_REVIEWED

public static final Reason RMA_ALREADY_REVIEWED

RMA_NOT_EXIST

public static final Reason RMA_NOT_EXIST

RMA_RECEIVER_NOT_EXIST

public static final Reason RMA_RECEIVER_NOT_EXIST

LN_SHIPPER_NOT_EXIST

public static final Reason LN_SHIPPER_NOT_EXIST

LN_SHIPPER_EXIST

public static final Reason LN_SHIPPER_EXIST

LN_RECEIVER_NOT_EXIST

public static final Reason LN_RECEIVER_NOT_EXIST

RMA_RECEIVER_HAS_HAVED_CREDITMEMO

public static final Reason RMA_RECEIVER_HAS_HAVED_CREDITMEMO

RMA_ITEM_NOT_EXIST

public static final Reason RMA_ITEM_NOT_EXIST

LN_SHIPPER_ITEM_NOT_EXIST

public static final Reason LN_SHIPPER_ITEM_NOT_EXIST

RMA_PK_WRONG

public static final Reason RMA_PK_WRONG

RMA_REVIEW_ALREADY_EXIST

public static final Reason RMA_REVIEW_ALREADY_EXIST

RMA_REVIEW_NOT_EXIST

public static final Reason RMA_REVIEW_NOT_EXIST

SALESMAN_NOT_EXIST

public static final Reason SALESMAN_NOT_EXIST

SALES_CODE_NOT_EXIST

public static final Reason SALES_CODE_NOT_EXIST

SALES_CODE_ALREADY_EXIST

public static final Reason SALES_CODE_ALREADY_EXIST

THE_CUSTOMER_ALREADY_HAS_A_SALES_CODE

public static final Reason THE_CUSTOMER_ALREADY_HAS_A_SALES_CODE

NO_CUSTOMER_IS_CHOISE

public static final Reason NO_CUSTOMER_IS_CHOISE

SALES_ORDER_NOT_OPEN

public static final Reason SALES_ORDER_NOT_OPEN

SALES_ORDER_IS_NOT_REVIEWED

public static final Reason SALES_ORDER_IS_NOT_REVIEWED

SALES_ORDER_ITEM_NOT_OPEN

public static final Reason SALES_ORDER_ITEM_NOT_OPEN

SALES_ORDER_ITEM_NOT_EXIST_FOR_THIS_SHIPPER_ITEM

public static final Reason SALES_ORDER_ITEM_NOT_EXIST_FOR_THIS_SHIPPER_ITEM

SALES_ORDER_ITEM_PK_WRONG

public static final Reason SALES_ORDER_ITEM_PK_WRONG

SALES_ORDER_ITEM_MFG_PK_WRONG

public static final Reason SALES_ORDER_ITEM_MFG_PK_WRONG

SALES_ORDER_ITEM_ALREADY_COMPLETED

public static final Reason SALES_ORDER_ITEM_ALREADY_COMPLETED

SALES_ORDER_NOT_EXIST

public static final Reason SALES_ORDER_NOT_EXIST

SALES_ORDER_IS_BILL_AND_HOLD

public static final Reason SALES_ORDER_IS_BILL_AND_HOLD

AR_PREPAY_ALREADY_EXIST

public static final Reason AR_PREPAY_ALREADY_EXIST

AR_IS_CLOSED

public static final Reason AR_IS_CLOSED

SALES_ORDER_SHIPPER_NOT_EXIST

public static final Reason SALES_ORDER_SHIPPER_NOT_EXIST

SALES_ORDER_ITEM_HAS_EXIST

public static final Reason SALES_ORDER_ITEM_HAS_EXIST

SALES_ORDER_ITEM_NOT_EXIST

public static final Reason SALES_ORDER_ITEM_NOT_EXIST

SG_SALE_ITEM_NOT_EXIST

public static final Reason SG_SALE_ITEM_NOT_EXIST

SALES_ORDER_ITEM_WITHOUT_SUCH_QTY_TO_SHIPPED

public static final Reason SALES_ORDER_ITEM_WITHOUT_SUCH_QTY_TO_SHIPPED

SALES_ORDER_ALREADY_CLOSED

public static final Reason SALES_ORDER_ALREADY_CLOSED

SALES_ORDER_ALREADY_REVIEWED

public static final Reason SALES_ORDER_ALREADY_REVIEWED

SALES_ORDER_REVIEW_NOT_EXIST

public static final Reason SALES_ORDER_REVIEW_NOT_EXIST

SALES_ORDER_ITEM_ALREADY_SHIPPED_OR_IN_SIP

public static final Reason SALES_ORDER_ITEM_ALREADY_SHIPPED_OR_IN_SIP

ONLOAN_REVIEW_NOT_EXIST

public static final Reason ONLOAN_REVIEW_NOT_EXIST

ONLOAN_REVIEW_ALREADY_EXIST

public static final Reason ONLOAN_REVIEW_ALREADY_EXIST

SALES_ORDER_REVIEW_ALREADY_EXIST

public static final Reason SALES_ORDER_REVIEW_ALREADY_EXIST

ECN_REVIEW_NOT_EXIST

public static final Reason ECN_REVIEW_NOT_EXIST

ECN_REVIEW_ALREADY_EXIST

public static final Reason ECN_REVIEW_ALREADY_EXIST

ECR_APPROVAL_ALREADY_EXIST

public static final Reason ECR_APPROVAL_ALREADY_EXIST

SAVE_TO_DB_ERROR

public static final Reason SAVE_TO_DB_ERROR

PART_USE_TYPE_IS_EXIST

public static final Reason PART_USE_TYPE_IS_EXIST

PART_USE_TYPE_NOT_EXIST

public static final Reason PART_USE_TYPE_NOT_EXIST

USE_TYPE_IS_EXIST

public static final Reason USE_TYPE_IS_EXIST

SERVER_TIME_ERROR

public static final Reason SERVER_TIME_ERROR

SERIAL_NUMBER_ALREADY_EXIST

public static final Reason SERIAL_NUMBER_ALREADY_EXIST

SERIAL_NUMBER_NOT_EXIST

public static final Reason SERIAL_NUMBER_NOT_EXIST

CATEGORY_INDEX_ALREADY_EXIST_IN_PARENT_CATEGORY

public static final Reason CATEGORY_INDEX_ALREADY_EXIST_IN_PARENT_CATEGORY

SG_QUOTE_ADDRESS_NOT_EXIST

public static final Reason SG_QUOTE_ADDRESS_NOT_EXIST

SG_QUOTE_ADDRESS_ALREADY_EXIST

public static final Reason SG_QUOTE_ADDRESS_ALREADY_EXIST

SG_CUST_RFQ_NOT_EXIST

public static final Reason SG_CUST_RFQ_NOT_EXIST

SG_CUST_RFQ_ALREADY_EXIST

public static final Reason SG_CUST_RFQ_ALREADY_EXIST

SG_CUST_RFQ_NOT_QUOTED

public static final Reason SG_CUST_RFQ_NOT_QUOTED

SG_CUST_RFQ_ALREADY_QUOTED

public static final Reason SG_CUST_RFQ_ALREADY_QUOTED

SG_COMPANY_NOT_EXIST

public static final Reason SG_COMPANY_NOT_EXIST

SG_COMPANY_ALREADY_EXIST

public static final Reason SG_COMPANY_ALREADY_EXIST

SG_CLIENT_ACCOUNT_NOT_EXIST

public static final Reason SG_CLIENT_ACCOUNT_NOT_EXIST

SG_CLIENT_ACCOUNT_ALREADY_EXIST

public static final Reason SG_CLIENT_ACCOUNT_ALREADY_EXIST

SG_CLIENT_PROGRAM_USER_NOT_EXIST

public static final Reason SG_CLIENT_PROGRAM_USER_NOT_EXIST

SG_CLIENT_PROGRAM_USER_ALREADY_EXIST

public static final Reason SG_CLIENT_PROGRAM_USER_ALREADY_EXIST

PART_NOT_SALEABLE

public static final Reason PART_NOT_SALEABLE

PART_IN_SIP

public static final Reason PART_IN_SIP

SHIPPER_HAS_EXIST

public static final Reason SHIPPER_HAS_EXIST

SHIPPER_NOT_EXIST

public static final Reason SHIPPER_NOT_EXIST

SHIPPER_NOT_FOR_SALES_ORDER

public static final Reason SHIPPER_NOT_FOR_SALES_ORDER

SHIPPER_HAS_BEEN_CLOSED

public static final Reason SHIPPER_HAS_BEEN_CLOSED

SHIPPER_ITEM_HAS_BEEN_CREATED_INVOICE

public static final Reason SHIPPER_ITEM_HAS_BEEN_CREATED_INVOICE

SALES_ORDER_HAS_BEEN_CLOSED

public static final Reason SALES_ORDER_HAS_BEEN_CLOSED

SALES_ORDER_HAS_BEEN_HOLD

public static final Reason SALES_ORDER_HAS_BEEN_HOLD

SHIPPER_ITEM_HAS_BEEN_CLOSED

public static final Reason SHIPPER_ITEM_HAS_BEEN_CLOSED

SALES_ITEM_HAS_BEEN_CLOSED

public static final Reason SALES_ITEM_HAS_BEEN_CLOSED

SALES_ITEM_HAS_BEEN_CREATED_INVOICE

public static final Reason SALES_ITEM_HAS_BEEN_CREATED_INVOICE

SHIPPED_QTY_IS_ZERO

public static final Reason SHIPPED_QTY_IS_ZERO

SHIPPED_QTY_IS_OVER

public static final Reason SHIPPED_QTY_IS_OVER

SHIP_QTY_IS_OVER_THAN_ONHAND

public static final Reason SHIP_QTY_IS_OVER_THAN_ONHAND

SHIP_QTY_IS_OVER_THAN_SO_ITEM_ORDERED

public static final Reason SHIP_QTY_IS_OVER_THAN_SO_ITEM_ORDERED

SHIP_QTY_IS_OVER_THAN_DWO_ITEM_ORDERED

public static final Reason SHIP_QTY_IS_OVER_THAN_DWO_ITEM_ORDERED

DWO_ITEM_RETURN_QTY_IS_OVER

public static final Reason DWO_ITEM_RETURN_QTY_IS_OVER

ISSUED_QTY_IS_OVER_THAN_WO_ITEM_PART_DETAIL_QTY

public static final Reason ISSUED_QTY_IS_OVER_THAN_WO_ITEM_PART_DETAIL_QTY

SHIP_QTY_IS_OVER_THAN_RTV_ITEM_ORDERED

public static final Reason SHIP_QTY_IS_OVER_THAN_RTV_ITEM_ORDERED

RECEIVE_QTY_IS_OVER_THAN_RMA_ITEM_ORDERED

public static final Reason RECEIVE_QTY_IS_OVER_THAN_RMA_ITEM_ORDERED

SHIP_LIST_HAS_EXIST

public static final Reason SHIP_LIST_HAS_EXIST

SHIP_LIST_NOT_EXIST

public static final Reason SHIP_LIST_NOT_EXIST

SHIP_LIST_OWNER_HAS_EXIST

public static final Reason SHIP_LIST_OWNER_HAS_EXIST

SHIP_LIST_OWNER_NOT_EXIST

public static final Reason SHIP_LIST_OWNER_NOT_EXIST

SHIPPER_ITEM_HAS_SHIPPED_COMPLETELY

public static final Reason SHIPPER_ITEM_HAS_SHIPPED_COMPLETELY

SEND_MAIL_ERROR

public static final Reason SEND_MAIL_ERROR

SOMEONE_ELSE_HAVE_UPDATED_IT

public static final Reason SOMEONE_ELSE_HAVE_UPDATED_IT

SOMEONE_ELSE_IS_CHANGING_SERVER_TIME

public static final Reason SOMEONE_ELSE_IS_CHANGING_SERVER_TIME

SPEC_ID_HAS_EXIST

public static final Reason SPEC_ID_HAS_EXIST

SPEC_ID_NOT_EXIST

public static final Reason SPEC_ID_NOT_EXIST

SPEC_ID_STILL_USED

public static final Reason SPEC_ID_STILL_USED

STATUS_ONLY_CAN_CHANGE_TO_CLOSE

public static final Reason STATUS_ONLY_CAN_CHANGE_TO_CLOSE

STATUS_ONLY_CAN_NOT_CHANGE_TO_CLOSE

public static final Reason STATUS_ONLY_CAN_NOT_CHANGE_TO_CLOSE

STATUS_ONLY_CAN_CHANGE_TO_CLOSE_OR_CANCELLED

public static final Reason STATUS_ONLY_CAN_CHANGE_TO_CLOSE_OR_CANCELLED

STATUS_ONLY_CAN_CHANGE_TO_NOTREVIEWED

public static final Reason STATUS_ONLY_CAN_CHANGE_TO_NOTREVIEWED

STATUS_ONLY_CAN_CHANGE_TO_NOTAPPROVED

public static final Reason STATUS_ONLY_CAN_CHANGE_TO_NOTAPPROVED

TEMPORARYEMPLOYEE_ALREADY_ADDED

public static final Reason TEMPORARYEMPLOYEE_ALREADY_ADDED

TEMPORARYEMPLOYEE_ID_NOT_EXIST

public static final Reason TEMPORARYEMPLOYEE_ID_NOT_EXIST

TERMINATED_DATE_CAN_NOT_BE_NULL

public static final Reason TERMINATED_DATE_CAN_NOT_BE_NULL

TERM_VALUE_NOT_LEGAL

public static final Reason TERM_VALUE_NOT_LEGAL

TERM_NOT_EXIST

public static final Reason TERM_NOT_EXIST

TERM_ALIAS_ALREADY_EXIST

public static final Reason TERM_ALIAS_ALREADY_EXIST

TERM_WITH_SAME_ALIAS_ALREADY_EXIST

public static final Reason TERM_WITH_SAME_ALIAS_ALREADY_EXIST

TIME_CARDS_ALREADY_EXIST

public static final Reason TIME_CARDS_ALREADY_EXIST

TIME_CARDS_NOT_EXIST

public static final Reason TIME_CARDS_NOT_EXIST

TRACKING_QTY_OVER

public static final Reason TRACKING_QTY_OVER

TRACKING_ALREADY_EXIST

public static final Reason TRACKING_ALREADY_EXIST

TRACKING_NOT_EXIST

public static final Reason TRACKING_NOT_EXIST

TRACKING_QTY_IS_ZERO

public static final Reason TRACKING_QTY_IS_ZERO

TRACKING_QTY_IS_NEGATIVE

public static final Reason TRACKING_QTY_IS_NEGATIVE

TRACKING_QTY_IS_NOT_ENOUGH

public static final Reason TRACKING_QTY_IS_NOT_ENOUGH

PLEASE_CHANGE_CONDITION_THEN_SEARCH_AGAIN

public static final Reason PLEASE_CHANGE_CONDITION_THEN_SEARCH_AGAIN

TOOL_ONHAND_NOT_EXIST

public static final Reason TOOL_ONHAND_NOT_EXIST

NEW_QTY_RECEIVED_IS_MORE_THAN_QTY_SHORTAGE

public static final Reason NEW_QTY_RECEIVED_IS_MORE_THAN_QTY_SHORTAGE

NEW_TRANSACTION_DATE_LOCKED

public static final Reason NEW_TRANSACTION_DATE_LOCKED

NEW_TRANSACTION_DATE_OVER_GL_NDAYS_OK_OLD

public static final Reason NEW_TRANSACTION_DATE_OVER_GL_NDAYS_OK_OLD

OLD_TRANSACTION_DATE_LOCKED

public static final Reason OLD_TRANSACTION_DATE_LOCKED

TRANSACTION_IS_TOO_OLD

public static final Reason TRANSACTION_IS_TOO_OLD

VALUE_NOT_MATCH_SUCH_PATTERN

public static final Reason VALUE_NOT_MATCH_SUCH_PATTERN

UPDATE_ONDEMAND_ERROR

public static final Reason UPDATE_ONDEMAND_ERROR

UPDATE_CURRENCY_ERROR

public static final Reason UPDATE_CURRENCY_ERROR

VENDOR_CATALOG_ALREADY_EXIST

public static final Reason VENDOR_CATALOG_ALREADY_EXIST

VENDOR_CATALOG_ALREADY_USED

public static final Reason VENDOR_CATALOG_ALREADY_USED

VENDOR_ID_NOT_EXIST

public static final Reason VENDOR_ID_NOT_EXIST

VENDOR_GROUP_USER_ALREADY_EXISTS

public static final Reason VENDOR_GROUP_USER_ALREADY_EXISTS

VERSION_NOT_SET

public static final Reason VERSION_NOT_SET

VENDOR_HAS_BEEN_LOCKED

public static final Reason VENDOR_HAS_BEEN_LOCKED

VARIANCE_CAN_NOT_BE_ZERO

public static final Reason VARIANCE_CAN_NOT_BE_ZERO

WEIGHT_UNIT_NOT_EXIST

public static final Reason WEIGHT_UNIT_NOT_EXIST

WITHOUT_RECEIVER_ITEM_DETAILS

public static final Reason WITHOUT_RECEIVER_ITEM_DETAILS

WITHOUT_IRNUMBER

public static final Reason WITHOUT_IRNUMBER

IRNUMBER_NOT_MATCH_WORK_ORDER

public static final Reason IRNUMBER_NOT_MATCH_WORK_ORDER

IRNUMBER_NOT_EXIST

public static final Reason IRNUMBER_NOT_EXIST

QTY_RECEIVED_CAN_NOT_MORE_THAN_QTY_QUALIFIED

public static final Reason QTY_RECEIVED_CAN_NOT_MORE_THAN_QTY_QUALIFIED

IRNUMBER_NOT_MATCH_PURCHASE_ORDER

public static final Reason IRNUMBER_NOT_MATCH_PURCHASE_ORDER

IRNUMBER_HAS_BEEN_USED

public static final Reason IRNUMBER_HAS_BEEN_USED

IRNUMBER_IS_NOT_FOR_THIS_PURCHASE_ORDER_ITEM

public static final Reason IRNUMBER_IS_NOT_FOR_THIS_PURCHASE_ORDER_ITEM

IRNUMBER_IS_NOT_FOR_THIS_WORK_ORDER_ITEM

public static final Reason IRNUMBER_IS_NOT_FOR_THIS_WORK_ORDER_ITEM

WORK_CENTER_HAS_EXIST

public static final Reason WORK_CENTER_HAS_EXIST

WORK_CENTER_IS_BEING_USED

public static final Reason WORK_CENTER_IS_BEING_USED

WORK_CENTER_NOT_EXIST

public static final Reason WORK_CENTER_NOT_EXIST

WORK_CENTER_GROUP_NOT_EXIST

public static final Reason WORK_CENTER_GROUP_NOT_EXIST

WORK_CENTER_GROUP_ITEM_NUMBER_WRONG

public static final Reason WORK_CENTER_GROUP_ITEM_NUMBER_WRONG

WORK_CENTER_GROUP_ALREADY_EXIST

public static final Reason WORK_CENTER_GROUP_ALREADY_EXIST

WORK_CENTER_UNIT_NUMBER_WRONG

public static final Reason WORK_CENTER_UNIT_NUMBER_WRONG

WORK_INSTRUCTION_APPROVAL_NOT_EXIST

public static final Reason WORK_INSTRUCTION_APPROVAL_NOT_EXIST

WORK_INSTRUCTION_APPROVAL_ALREADY_EXIST

public static final Reason WORK_INSTRUCTION_APPROVAL_ALREADY_EXIST

WORK_INSTRUCTION_NOT_EXIST

public static final Reason WORK_INSTRUCTION_NOT_EXIST

WORK_INSTRUCTION_ALREADY_EXIST

public static final Reason WORK_INSTRUCTION_ALREADY_EXIST

DELETE_PICTURE_FIRST

public static final Reason DELETE_PICTURE_FIRST

WORK_ORDER_NOT_EXIST

public static final Reason WORK_ORDER_NOT_EXIST

WORK_ORDER_ITEM_NOT_EXIST

public static final Reason WORK_ORDER_ITEM_NOT_EXIST

WORK_ORDER_ITEM_NOT_OPEN

public static final Reason WORK_ORDER_ITEM_NOT_OPEN

WORK_ORDER_ITEM_ISSUE_NOT_EXIST

public static final Reason WORK_ORDER_ITEM_ISSUE_NOT_EXIST

WORK_ORDER_ITEM_ISSUE_NOT_FINISHED

public static final Reason WORK_ORDER_ITEM_ISSUE_NOT_FINISHED

SOME_PARTS_HAVE_BEEN_ISSUED_TO_WO

public static final Reason SOME_PARTS_HAVE_BEEN_ISSUED_TO_WO

WORK_ORDER_ITEM_MFG_STATUS_NOT_SETUP

public static final Reason WORK_ORDER_ITEM_MFG_STATUS_NOT_SETUP

WORK_ORDER_ITEM_MFG_STATUS_HAS_SETUP

public static final Reason WORK_ORDER_ITEM_MFG_STATUS_HAS_SETUP

WORK_ORDER_ITEM_QTY_CAN_NOT_CHANGE_TO_ZERO

public static final Reason WORK_ORDER_ITEM_QTY_CAN_NOT_CHANGE_TO_ZERO

WORK_ORDER_ITEM_QTY_CAN_NOT_LESS_THAN_QTY_ASM

public static final Reason WORK_ORDER_ITEM_QTY_CAN_NOT_LESS_THAN_QTY_ASM

WORK_ORDER_ITEM_CAN_NOT_LINK_TO_ITSELF

public static final Reason WORK_ORDER_ITEM_CAN_NOT_LINK_TO_ITSELF

WORK_ORDER_ALREADY_SETUP_OR_RUN

public static final Reason WORK_ORDER_ALREADY_SETUP_OR_RUN

WORK_ORDER_ITEM_TIME_DETAIL_NOT_EXIST

public static final Reason WORK_ORDER_ITEM_TIME_DETAIL_NOT_EXIST

WORK_ORDER_APPROVAL_NOT_EXIST

public static final Reason WORK_ORDER_APPROVAL_NOT_EXIST

WORK_ORDER_APPROVAL_ALREADY_EXIST

public static final Reason WORK_ORDER_APPROVAL_ALREADY_EXIST

WORK_ORDER_NOT_OPEN

public static final Reason WORK_ORDER_NOT_OPEN

DISASSEMBLE_WORK_ORDER_NOT_OPEN

public static final Reason DISASSEMBLE_WORK_ORDER_NOT_OPEN

WORK_ORDER_ITEM_HAS_CLOSED

public static final Reason WORK_ORDER_ITEM_HAS_CLOSED

DISASSEMBLE_WORK_ORDER_ITEM_HAS_CLOSED

public static final Reason DISASSEMBLE_WORK_ORDER_ITEM_HAS_CLOSED

DISASSEMBLE_WORK_ORDER_ITEM_HAS_NOT_CLOSED

public static final Reason DISASSEMBLE_WORK_ORDER_ITEM_HAS_NOT_CLOSED

DISASSEMBLE_WORK_ORDER_ITEM_GL_HAS_CREATED

public static final Reason DISASSEMBLE_WORK_ORDER_ITEM_GL_HAS_CREATED

DISASSEMBLE_WORK_ORDER_ALREADY_SETUP_OR_RUN

public static final Reason DISASSEMBLE_WORK_ORDER_ALREADY_SETUP_OR_RUN

CAN_NOT_CHANGE_DISASSEMBLE_WORK_ORDER_ITEM_QTY_ISSUED

public static final Reason CAN_NOT_CHANGE_DISASSEMBLE_WORK_ORDER_ITEM_QTY_ISSUED

CAN_NOT_CHANGE_PART_FOR_DWO_HAS_ISSUED

public static final Reason CAN_NOT_CHANGE_PART_FOR_DWO_HAS_ISSUED

WORK_ORDER_WORK_INSTRUCTION_HAS_EXIST

public static final Reason WORK_ORDER_WORK_INSTRUCTION_HAS_EXIST

WORK_ORDER_WORK_INSTRUCTION_NOT_EXIST

public static final Reason WORK_ORDER_WORK_INSTRUCTION_NOT_EXIST

WORK_ORDER_WORK_INSTRUCTION_HAS_FINISHED

public static final Reason WORK_ORDER_WORK_INSTRUCTION_HAS_FINISHED

WORK_WORK_SHEET_HAS_EXIST

public static final Reason WORK_WORK_SHEET_HAS_EXIST

WORK_WORK_SHEET_NOT_EXIST

public static final Reason WORK_WORK_SHEET_NOT_EXIST

DISASSEMBLE_WORK_ORDER_NOT_EXIST

public static final Reason DISASSEMBLE_WORK_ORDER_NOT_EXIST

DISASSEMBLE_WORK_ORDER_ITEM_NOT_EXIST

public static final Reason DISASSEMBLE_WORK_ORDER_ITEM_NOT_EXIST

DISASSEMBLE_WORK_ORDER_ITEM_NOT_OPEN

public static final Reason DISASSEMBLE_WORK_ORDER_ITEM_NOT_OPEN

DISASSEMBLE_WORK_ORDER_APPROVAL_NOT_EXIST

public static final Reason DISASSEMBLE_WORK_ORDER_APPROVAL_NOT_EXIST

GET_DISASSEMBLE_WORK_ORDER_APPROVAL_ERROR

public static final Reason GET_DISASSEMBLE_WORK_ORDER_APPROVAL_ERROR

DISASSEMBLE_WORK_ORDER_APPROVAL_ALREADY_EXIST

public static final Reason DISASSEMBLE_WORK_ORDER_APPROVAL_ALREADY_EXIST

DISASSEMBLE_WORK_ORDER_ITEM_RECEIVER_NOT_EXIST

public static final Reason DISASSEMBLE_WORK_ORDER_ITEM_RECEIVER_NOT_EXIST

DISASSEMBLE_WORK_ORDER_ITEM_RECEIVED_QTY_IS_OVER

public static final Reason DISASSEMBLE_WORK_ORDER_ITEM_RECEIVED_QTY_IS_OVER

WRONG_CURRENCY_FOR_CUSTOMER

public static final Reason WRONG_CURRENCY_FOR_CUSTOMER

WRONG_DOCUMENT_SETTINGS

public static final Reason WRONG_DOCUMENT_SETTINGS

WRONG_SHIPPER_FOR_SALES_ORDER

public static final Reason WRONG_SHIPPER_FOR_SALES_ORDER

WRONG_MONTH_YEAR_NAME

public static final Reason WRONG_MONTH_YEAR_NAME

YOU_HAVE_NOT_APPROVED_GL

public static final Reason YOU_HAVE_NOT_APPROVED_GL

YOU_HAVE_NOT_POST_GL

public static final Reason YOU_HAVE_NOT_POST_GL

YOU_HAVE_NOT_OVER_CARRY_ALL_PROFIT_AND_LOSS_ACCOUNT

public static final Reason YOU_HAVE_NOT_OVER_CARRY_ALL_PROFIT_AND_LOSS_ACCOUNT

YOU_HAVE_NO_PERMISSION_REVIEW_OWN_QUOTE

public static final Reason YOU_HAVE_NO_PERMISSION_REVIEW_OWN_QUOTE

YOU_HAVE_NO_PERMISSION_APPROVAL_OWN_RMA

public static final Reason YOU_HAVE_NO_PERMISSION_APPROVAL_OWN_RMA

YOU_HAVE_NO_PERMISSION_REVIEW_OWN_SALES_ORDER

public static final Reason YOU_HAVE_NO_PERMISSION_REVIEW_OWN_SALES_ORDER

YOU_HAVE_NO_PERMISSION_REVIEW_OWN_ONLOAN

public static final Reason YOU_HAVE_NO_PERMISSION_REVIEW_OWN_ONLOAN

YOU_CAN_NOT_CHANGE_TOTAL_ONHAND

public static final Reason YOU_CAN_NOT_CHANGE_TOTAL_ONHAND

YOU_CAN_NOT_CHANGE_THE_OTHERS_EXPENSE

public static final Reason YOU_CAN_NOT_CHANGE_THE_OTHERS_EXPENSE

PLEASE_LOGIN_FIRST

public static final Reason PLEASE_LOGIN_FIRST

ALREADY_LOGOUT

public static final Reason ALREADY_LOGOUT

SALES_ORDER_ALREADY_SHIPPED

public static final Reason SALES_ORDER_ALREADY_SHIPPED

FIND_USER_ZIPCODE_TAX_ERROR

public static final Reason FIND_USER_ZIPCODE_TAX_ERROR

CAN_NOT_CHANGE_THE_FISCAL_YEAR_SETTINGS

public static final Reason CAN_NOT_CHANGE_THE_FISCAL_YEAR_SETTINGS

CAN_NOT_DELETE_THE_FISCAL_YEAR_SETTINGS

public static final Reason CAN_NOT_DELETE_THE_FISCAL_YEAR_SETTINGS

NEED_TO_CREATE_NEXT_FISCAL_YEAR

public static final Reason NEED_TO_CREATE_NEXT_FISCAL_YEAR

GL_LOCKED_DATE_SHOULD_BE_AFTER_FY_END_DATE

public static final Reason GL_LOCKED_DATE_SHOULD_BE_AFTER_FY_END_DATE

FISCAL_YEAR_SETTINGS_STATUS_BEFORE_NEED_TO_CHANGE

public static final Reason FISCAL_YEAR_SETTINGS_STATUS_BEFORE_NEED_TO_CHANGE

FISCAL_YEAR_SETTINGS_STATUS_AFTER_NEED_TO_CHANGE

public static final Reason FISCAL_YEAR_SETTINGS_STATUS_AFTER_NEED_TO_CHANGE

GL_IN_FISCAL_YEAR

public static final Reason GL_IN_FISCAL_YEAR

EXCHANGE_RATE_IN_FISCAL_YEAR

public static final Reason EXCHANGE_RATE_IN_FISCAL_YEAR

FISCAL_YEAR_SETTINGS_STATUS_SHOULD_BE_OPEN

public static final Reason FISCAL_YEAR_SETTINGS_STATUS_SHOULD_BE_OPEN

FISCAL_YEAR_SETTINGS_ALREADY_EXISTS

public static final Reason FISCAL_YEAR_SETTINGS_ALREADY_EXISTS

ACCOUNTING_PERIOD_ALREADY_EXISTS

public static final Reason ACCOUNTING_PERIOD_ALREADY_EXISTS

ACCOUNTING_REPORTS_IN_THIS_FISCAL_YEAR__NEED_TO_BACK_UP

public static final Reason ACCOUNTING_REPORTS_IN_THIS_FISCAL_YEAR__NEED_TO_BACK_UP

NEW_FISCAL_YEAR_SETTINGS_CLOSED

public static final Reason NEW_FISCAL_YEAR_SETTINGS_CLOSED

OLD_FISCAL_YEAR_SETTINGS_CLOSED

public static final Reason OLD_FISCAL_YEAR_SETTINGS_CLOSED

START_DATE_SHOULD_BE_AFTER_THE_PRIOR_FISCAL_YEAR_END_DATE

public static final Reason START_DATE_SHOULD_BE_AFTER_THE_PRIOR_FISCAL_YEAR_END_DATE

END_DATE_SHOULD_BE_BEFORE_THE_FOLLOW_FISCAL_YEAR_START_DATE

public static final Reason END_DATE_SHOULD_BE_BEFORE_THE_FOLLOW_FISCAL_YEAR_START_DATE

START_DATE_SHOULD_BE_BEFORE_THE_END_DATE

public static final Reason START_DATE_SHOULD_BE_BEFORE_THE_END_DATE

PAY_DATE_SHOULD_BE_AFTER_GL_LOCKED_DATE

public static final Reason PAY_DATE_SHOULD_BE_AFTER_GL_LOCKED_DATE

DESTINATION_NOT_EXIST

public static final Reason DESTINATION_NOT_EXIST

USER_LOCKED

public static final Reason USER_LOCKED

USER_NOT_EXIST

public static final Reason USER_NOT_EXIST

SYSTEM_LOGIN_LOCKED

public static final Reason SYSTEM_LOGIN_LOCKED

DUPLICATE_LOGIN

public static final Reason DUPLICATE_LOGIN

FAIL_LOGIN

public static final Reason FAIL_LOGIN

LOGIN_DATA_NOT_COMPLETED

public static final Reason LOGIN_DATA_NOT_COMPLETED

WRONG_PASSWORD

public static final Reason WRONG_PASSWORD

INVALID_ARGUMENT

public static final Reason INVALID_ARGUMENT

METHOD_NOT_EXIST

public static final Reason METHOD_NOT_EXIST

EJB_INVOKE_FAILED

public static final Reason EJB_INVOKE_FAILED

INVOKE_FAILED

public static final Reason INVOKE_FAILED

INVALID_USER

public static final Reason INVALID_USER

YOU_DID_NOT_LOG_OFF

public static final Reason YOU_DID_NOT_LOG_OFF

AUTHORIZATION_REQUIRED

public static final Reason AUTHORIZATION_REQUIRED

VENDOR_CONTRACT_PRICE_HAS_EXIST

public static final Reason VENDOR_CONTRACT_PRICE_HAS_EXIST

VENDOR_CONTRACT_PRICE_NOT_EXIST

public static final Reason VENDOR_CONTRACT_PRICE_NOT_EXIST

VENDOR_CONTRACT_PRICE_ITEM_HAS_EXIST

public static final Reason VENDOR_CONTRACT_PRICE_ITEM_HAS_EXIST

VENDOR_CONTRACT_PRICE_ITEM_NOT_EXIST

public static final Reason VENDOR_CONTRACT_PRICE_ITEM_NOT_EXIST

VENDOR_CONTRACT_PRICE_VENDOR_HAS_EXIST

public static final Reason VENDOR_CONTRACT_PRICE_VENDOR_HAS_EXIST

VENDOR_CONTRACT_PRICE_VENDOR_NOT_EXIST

public static final Reason VENDOR_CONTRACT_PRICE_VENDOR_NOT_EXIST

FIND_USER_GROUP_ERROR

public static final Reason FIND_USER_GROUP_ERROR

USER_GROUP_NOT_EXIST

public static final Reason USER_GROUP_NOT_EXIST

USER_GROUP_EXIST

public static final Reason USER_GROUP_EXIST

ROLL_UP_BOM_STD_COST_WORKSHEET_NOT_EXIST

public static final Reason ROLL_UP_BOM_STD_COST_WORKSHEET_NOT_EXIST

CAN_ONLY_COMMIT_FINISHED_WORKSHEET

public static final Reason CAN_ONLY_COMMIT_FINISHED_WORKSHEET

CAN_ONLY_OVER_CARRYING_COMMITTED_WORKSHEET

public static final Reason CAN_ONLY_OVER_CARRYING_COMMITTED_WORKSHEET

CAN_ONLY_UPDATE_WAITING_WORKSHEET

public static final Reason CAN_ONLY_UPDATE_WAITING_WORKSHEET

THERE_IS_A_RUNNING_WORKSHEET

public static final Reason THERE_IS_A_RUNNING_WORKSHEET

THERE_IS_A_WAITING_WORKSHEET

public static final Reason THERE_IS_A_WAITING_WORKSHEET

CAN_ONLY_COMMIT_OPEN_WORKSHEET

public static final Reason CAN_ONLY_COMMIT_OPEN_WORKSHEET

CHANGE_STD_COST_WORKSHEET_NOT_EXIST

public static final Reason CHANGE_STD_COST_WORKSHEET_NOT_EXIST

DIRECTORY_NOT_EXIST

public static final Reason DIRECTORY_NOT_EXIST

CREATE_DIRECTORY_FAILED

public static final Reason CREATE_DIRECTORY_FAILED

OPERATING_INSTRUCTION_NOT_EXIST

public static final Reason OPERATING_INSTRUCTION_NOT_EXIST

INSPECTION_REPORT_NOT_EXIST

public static final Reason INSPECTION_REPORT_NOT_EXIST

OPERATING_INSTRUCTION_TYPE_NOT_EXIST

public static final Reason OPERATING_INSTRUCTION_TYPE_NOT_EXIST

CAN_ONLY_APPROVE_NOT_APPROVED_OPERATING_INSTRUCTION

public static final Reason CAN_ONLY_APPROVE_NOT_APPROVED_OPERATING_INSTRUCTION

CAN_ONLY_PAUSE_OPEN_OPERATING_INSTRUCTION

public static final Reason CAN_ONLY_PAUSE_OPEN_OPERATING_INSTRUCTION

CAN_ONLY_CONTINUE_PAUSED_OPERATING_INSTRUCTION

public static final Reason CAN_ONLY_CONTINUE_PAUSED_OPERATING_INSTRUCTION

CAN_ONLY_REQUEST_INSPECTIONFOR_FINISH_OPERATING_INSTRUCTION

public static final Reason CAN_ONLY_REQUEST_INSPECTIONFOR_FINISH_OPERATING_INSTRUCTION

CAN_ONLY_CLOSE_FINISH_INSPECTIONFOR_OPERATING_INSTRUCTION

public static final Reason CAN_ONLY_CLOSE_FINISH_INSPECTIONFOR_OPERATING_INSTRUCTION

CAN_ONLY_CREATE_INSPECTION_REPORT_FROM_REQUEST_INSPECTIONFOR_OPERATING_INSTRUCTION

public static final Reason CAN_ONLY_CREATE_INSPECTION_REPORT_FROM_REQUEST_INSPECTIONFOR_OPERATING_INSTRUCTION

FIND_SALES_CODE_ERROR

public static final Reason FIND_SALES_CODE_ERROR

OVER_CARRY_PROFIT_AND_LOSS_APPROVED_BY_BY_CAN_NOT_BE_EMPTY

public static final Reason OVER_CARRY_PROFIT_AND_LOSS_APPROVED_BY_BY_CAN_NOT_BE_EMPTY

OVER_CARRY_PROFIT_AND_LOSS_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY

public static final Reason OVER_CARRY_PROFIT_AND_LOSS_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY

EXCHANGERATE_APPROVED_BY_BY_CAN_NOT_BE_EMPTY

public static final Reason EXCHANGERATE_APPROVED_BY_BY_CAN_NOT_BE_EMPTY

EXCHANGERATE_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY

public static final Reason EXCHANGERATE_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY

CAN_ONLY_FINISH_OPEN_OPERATING_INSTRUCTION

public static final Reason CAN_ONLY_FINISH_OPEN_OPERATING_INSTRUCTION

PART_HAS_MANUFACTURER

public static final Reason PART_HAS_MANUFACTURER

PART_HAS_VENDOR

public static final Reason PART_HAS_VENDOR

PART_ALREADY_USED

public static final Reason PART_ALREADY_USED

FISCAL_YEAR_NOT_EXIST

public static final Reason FISCAL_YEAR_NOT_EXIST

FIND_BIZBOX_USER_ERROR

public static final Reason FIND_BIZBOX_USER_ERROR

CURRENCY_EXCHANGE_MUST_BE_ONE

public static final Reason CURRENCY_EXCHANGE_MUST_BE_ONE

CYCLE_WORK_SHEET_NUMBER_REQUIRE

public static final Reason CYCLE_WORK_SHEET_NUMBER_REQUIRE

WORK_CENTER_GROUP_ITEM_IS_EMPTY

public static final Reason WORK_CENTER_GROUP_ITEM_IS_EMPTY

WITHOUT_SUCH_METHOD

public static final Reason WITHOUT_SUCH_METHOD

SECURITY_ACCESS_TO_METHOD

public static final Reason SECURITY_ACCESS_TO_METHOD

NOT_APPROVED_OBJECT_ONLY_ALLOW_UPDATE

public static final Reason NOT_APPROVED_OBJECT_ONLY_ALLOW_UPDATE

TOOL_NOT_EXIST

public static final Reason TOOL_NOT_EXIST

TOOL_CALIBRATION_CONTROL_NUMBER_WRONG

public static final Reason TOOL_CALIBRATION_CONTROL_NUMBER_WRONG

SHIPPER_ITEM_NOT_EXIST

public static final Reason SHIPPER_ITEM_NOT_EXIST

RMA_ITEM_HAS_EXIST

public static final Reason RMA_ITEM_HAS_EXIST

RMA_HAS_EXIST

public static final Reason RMA_HAS_EXIST

RETURN_TO_VENDOR_ITEM_NOT_EXIST

public static final Reason RETURN_TO_VENDOR_ITEM_NOT_EXIST

REQUEST_FOR_QUOTE_ITEM_NOT_EXIST

public static final Reason REQUEST_FOR_QUOTE_ITEM_NOT_EXIST

RECEIVER_ITEM_NOT_EXIST

public static final Reason RECEIVER_ITEM_NOT_EXIST

RECEIVER_ITEM_HAS_EXIST

public static final Reason RECEIVER_ITEM_HAS_EXIST

QUOTE_ALREADY_REVIEWED

public static final Reason QUOTE_ALREADY_REVIEWED

PURCHASE_WORK_SHEET_ITEM_NOT_EXIST

public static final Reason PURCHASE_WORK_SHEET_ITEM_NOT_EXIST

PART_WITHOUT_INVENTORY

public static final Reason PART_WITHOUT_INVENTORY

ON_lOAN_ITEM_ALREADY_EXIST

public static final Reason ON_lOAN_ITEM_ALREADY_EXIST

OBJECT_ALREADY_APPROVED

public static final Reason OBJECT_ALREADY_APPROVED

NOT_SAME_ADDRESS_ID_WITH_PROFROMA_INVOICE

public static final Reason NOT_SAME_ADDRESS_ID_WITH_PROFROMA_INVOICE

MESSAGE_ALREADY_READ_BY_RECEIVER

public static final Reason MESSAGE_ALREADY_READ_BY_RECEIVER

MUST_NULL_OR_EMPTY

public static final Reason MUST_NULL_OR_EMPTY

DOCUMENT_SETTINGS_NOT_SAVE_TO_FTP

public static final Reason DOCUMENT_SETTINGS_NOT_SAVE_TO_FTP

WRONG_DOCUMENT_TYPE

public static final Reason WRONG_DOCUMENT_TYPE

TERM_ALREADY_EXIST

public static final Reason TERM_ALREADY_EXIST

SG_CLIENT_PROGRAM_USER_INFO_NOT_EXACT

public static final Reason SG_CLIENT_PROGRAM_USER_INFO_NOT_EXACT

ITEM_QTY_IS_NOT_RIGHT

public static final Reason ITEM_QTY_IS_NOT_RIGHT

CUSTOMER_VENDOR_TYPE_NOT_EXIST

public static final Reason CUSTOMER_VENDOR_TYPE_NOT_EXIST

CUSTOMER_PART_CATALOG_NOT_EXIST

public static final Reason CUSTOMER_PART_CATALOG_NOT_EXIST

CAN_NOT_GET_SYSTEM_INFO

public static final Reason CAN_NOT_GET_SYSTEM_INFO

APPROVED_IS_FORBIDDEN_WHEN_UPDATE

public static final Reason APPROVED_IS_FORBIDDEN_WHEN_UPDATE

APPROVED_OBJECT_NOT_ALLOW_UPDATE_AGAIN

public static final Reason APPROVED_OBJECT_NOT_ALLOW_UPDATE_AGAIN

CAN_NOT_FIND_VENDOR_PART

public static final Reason CAN_NOT_FIND_VENDOR_PART

CALCULATE_NEW_DEBIT_MEMO_NUMBER_ERROR

public static final Reason CALCULATE_NEW_DEBIT_MEMO_NUMBER_ERROR

BILL_CAN_NOT_CONTAINS_ITSELF

public static final Reason BILL_CAN_NOT_CONTAINS_ITSELF

NEW_TRANSACTION_ARE_FUTURE_DATE

public static final Reason NEW_TRANSACTION_ARE_FUTURE_DATE

PROFORMA_RECEIVER_HAS_EXIST

public static final Reason PROFORMA_RECEIVER_HAS_EXIST

FEEDBACK_QUESTION_IN_USING

public static final Reason FEEDBACK_QUESTION_IN_USING

NOT_EQUALS

public static final Reason NOT_EQUALS

MANUFACTURER_PART_NUMBER_NOT_EXIST

public static final Reason MANUFACTURER_PART_NUMBER_NOT_EXIST

MANUFACTURER_ID_ALREADY_EXIST

public static final Reason MANUFACTURER_ID_ALREADY_EXIST

ITEM_STATUS_IS_FORBIDDEN_TO_CHANGE_CURRENTLY

public static final Reason ITEM_STATUS_IS_FORBIDDEN_TO_CHANGE_CURRENTLY

INPUT_MUST_BE_EMPTY_STRING

public static final Reason INPUT_MUST_BE_EMPTY_STRING

PART_PICTURE_EXIST

public static final Reason PART_PICTURE_EXIST

TRANSACTION_DATE_OVER_GL_NDAYS_OK_OLD

public static final Reason TRANSACTION_DATE_OVER_GL_NDAYS_OK_OLD

RMA_NOT_REVIEWED

public static final Reason RMA_NOT_REVIEWED

REF_DOC_LINK_TO_NOT_EXIST_ORDER

public static final Reason REF_DOC_LINK_TO_NOT_EXIST_ORDER

MESSAGE_NOT_EXIST

public static final Reason MESSAGE_NOT_EXIST

PART_IN_QA_NOT_EXIST

public static final Reason PART_IN_QA_NOT_EXIST

PART_CATALOG_NOT_EXIST

public static final Reason PART_CATALOG_NOT_EXIST

PART_CATALOG_ALREADY_EXIST

public static final Reason PART_CATALOG_ALREADY_EXIST

ILLEGAL_CARRIER_ID

public static final Reason ILLEGAL_CARRIER_ID

ILLEGAL_CONTRACT_PRICE_NUMBER

public static final Reason ILLEGAL_CONTRACT_PRICE_NUMBER

NOT_MATCH_SHIP_LIST_NUMBER_WITH_SHIP_LIST

public static final Reason NOT_MATCH_SHIP_LIST_NUMBER_WITH_SHIP_LIST

NOT_ENOUGH_ONHAND

public static final Reason NOT_ENOUGH_ONHAND

NOT_MATCH_PART_WiTH_SALES_ORDER_ITEM

public static final Reason NOT_MATCH_PART_WiTH_SALES_ORDER_ITEM

NOT_IDENTITY_EMPLOYEE_ID

public static final Reason NOT_IDENTITY_EMPLOYEE_ID

BIZBOX_USER_IS_EMPLOYEE

public static final Reason BIZBOX_USER_IS_EMPLOYEE

BIZBOX_USER_NOT_EXIST_FOR_THIS_EMPLOYEE

public static final Reason BIZBOX_USER_NOT_EXIST_FOR_THIS_EMPLOYEE

PART_CATEGORY_NOT_EXIST

public static final Reason PART_CATEGORY_NOT_EXIST

IR_NOT_EXIST

public static final Reason IR_NOT_EXIST

IR_ALREADY_EXIST

public static final Reason IR_ALREADY_EXIST

CAN_NOT_LINK_TO_MORE_THAN_ONE_ORDERS

public static final Reason CAN_NOT_LINK_TO_MORE_THAN_ONE_ORDERS

HAVE_NOT_ENOUGH_QTY_TO_REC_IN_IR

public static final Reason HAVE_NOT_ENOUGH_QTY_TO_REC_IN_IR

RECEIVER_REF_DOC_NUMBER_CAN_NOT_BE_CHANGED

public static final Reason RECEIVER_REF_DOC_NUMBER_CAN_NOT_BE_CHANGED

CAN_NOT_ADD_NEW_IR_ITEM

public static final Reason CAN_NOT_ADD_NEW_IR_ITEM

CAN_NOT_DELETE_REF_DOC_IN_IR

public static final Reason CAN_NOT_DELETE_REF_DOC_IN_IR

CAN_NOT_CHANGE_IR_QUALITIFY_QTY

public static final Reason CAN_NOT_CHANGE_IR_QUALITIFY_QTY

SHIP_QTY_IS_OVER_THAN_LOCATION_ONHAND

public static final Reason SHIP_QTY_IS_OVER_THAN_LOCATION_ONHAND

RECEIVER_QTY_CAN_NOT_BE_CHANGED

public static final Reason RECEIVER_QTY_CAN_NOT_BE_CHANGED

CAN_NOT_DELETE_DEFAULT_WI

public static final Reason CAN_NOT_DELETE_DEFAULT_WI

EMPTY_GL_OR_ZERO_GL_ITEM

public static final Reason EMPTY_GL_OR_ZERO_GL_ITEM

ALREADY_WRITE_OFF

public static final Reason ALREADY_WRITE_OFF

SO_ITEM_NOT_TOTALLY_SHIPPED

public static final Reason SO_ITEM_NOT_TOTALLY_SHIPPED

FIND_SRUNNING_ACCOUNT_ORDER_ERROR

public static final Reason FIND_SRUNNING_ACCOUNT_ORDER_ERROR

ACCT_OF_PAYABLE_METHOD_IS_NULL

public static final Reason ACCT_OF_PAYABLE_METHOD_IS_NULL

HAVE_NOT_INVENTORY

public static final Reason HAVE_NOT_INVENTORY

TRANSFER_ORDER_NOT_EXIST

public static final Reason TRANSFER_ORDER_NOT_EXIST

CAN_NOT_ADD_NEW_PAYABLE_METHOD

public static final Reason CAN_NOT_ADD_NEW_PAYABLE_METHOD

CASHIER_ALREADY_EXIST

public static final Reason CASHIER_ALREADY_EXIST

TRANSFER_ORDER_APPROVAL_NOT_EXIST

public static final Reason TRANSFER_ORDER_APPROVAL_NOT_EXIST

TRANSFER_ORDER_APPROVAL_ALREADY_EXIST

public static final Reason TRANSFER_ORDER_APPROVAL_ALREADY_EXIST

TRANSFER_RECEIVER_NOT_EXIST

public static final Reason TRANSFER_RECEIVER_NOT_EXIST

TRANSFER_SHIPPER_NOT_EXIST

public static final Reason TRANSFER_SHIPPER_NOT_EXIST

TRANSFER_SHIPPER_ITEM_NOT_EXIST

public static final Reason TRANSFER_SHIPPER_ITEM_NOT_EXIST

TRANSFER_SHIPPER_ALREADY_EXIST

public static final Reason TRANSFER_SHIPPER_ALREADY_EXIST

TRANSFER_ORDER_ITEM_NOT_EXIST_FOR_THIS_TRANSFER_SHIPPER_ITEM

public static final Reason TRANSFER_ORDER_ITEM_NOT_EXIST_FOR_THIS_TRANSFER_SHIPPER_ITEM

SHIP_QTY_IS_OVER_THAN_TRANSFER_ITEM_ORDERED

public static final Reason SHIP_QTY_IS_OVER_THAN_TRANSFER_ITEM_ORDERED

TRANSFER_ORDER_NOT_OPEN

public static final Reason TRANSFER_ORDER_NOT_OPEN

TRANSFER_ORDER_NOT_INNER

public static final Reason TRANSFER_ORDER_NOT_INNER

NO_ITEM_TO_TRANSFER

public static final Reason NO_ITEM_TO_TRANSFER

PART_ONHAND_NOT_ENOUGH

public static final Reason PART_ONHAND_NOT_ENOUGH

PART_INVENTORY_NOT_ENOUGH

public static final Reason PART_INVENTORY_NOT_ENOUGH

SHIP_QTY_IS_SMALLER_THAN_RECEIVE_QTY

public static final Reason SHIP_QTY_IS_SMALLER_THAN_RECEIVE_QTY

CAN_NOT_CHANGE_TRANSFER_TYPE

public static final Reason CAN_NOT_CHANGE_TRANSFER_TYPE

CAN_NOT_DELETE_TRANSFER_ORDER_ITEM

public static final Reason CAN_NOT_DELETE_TRANSFER_ORDER_ITEM

CAN_NOT_DELETE_TRANSFER_SHIPPER_ITEM

public static final Reason CAN_NOT_DELETE_TRANSFER_SHIPPER_ITEM

CAN_NOT_RECEIVE_NA_AND_OTHER_PART_AT_SAME_TIME

public static final Reason CAN_NOT_RECEIVE_NA_AND_OTHER_PART_AT_SAME_TIME

CAN_NOT_FIND_INIT_FILE

public static final Reason CAN_NOT_FIND_INIT_FILE

THERE_IS_NO_PART_ONHAND

public static final Reason THERE_IS_NO_PART_ONHAND

QTY_RECEIVED_CAN_NOT_MORE_THAN_QTY_PURCHASED

public static final Reason QTY_RECEIVED_CAN_NOT_MORE_THAN_QTY_PURCHASED

QTY_SHOULD_BE_BIGGER_THAN_ISSUED_QTY

public static final Reason QTY_SHOULD_BE_BIGGER_THAN_ISSUED_QTY

QTY_SHOULD_HAS_SAME_POSITIVE_NEGATIVE_WITH_ISSUED_QTY

public static final Reason QTY_SHOULD_HAS_SAME_POSITIVE_NEGATIVE_WITH_ISSUED_QTY

ONHAND_IS_NOT_ENOUGH

public static final Reason ONHAND_IS_NOT_ENOUGH

PART_HAS_BEAN_RETURN

public static final Reason PART_HAS_BEAN_RETURN

TOOL_HAS_ONHAND

public static final Reason TOOL_HAS_ONHAND

TOOL_HAS_ONDEMAND

public static final Reason TOOL_HAS_ONDEMAND

TOOL_HAS_ONORDER

public static final Reason TOOL_HAS_ONORDER

TOOL_HAS_ONLOAN

public static final Reason TOOL_HAS_ONLOAN

TOOL_HAS_QA

public static final Reason TOOL_HAS_QA

TOOL_HAS_WIP

public static final Reason TOOL_HAS_WIP

TOOL_HAS_SIP

public static final Reason TOOL_HAS_SIP

TOOL_HAS_SIT

public static final Reason TOOL_HAS_SIT

TOOL_IS_TOOL_LIST

public static final Reason TOOL_IS_TOOL_LIST

TOOL_USED_IN_TOOL_LIST

public static final Reason TOOL_USED_IN_TOOL_LIST

TOOL_USED_IN_POI

public static final Reason TOOL_USED_IN_POI

TOOL_USED_IN_SOI

public static final Reason TOOL_USED_IN_SOI

TOOL_USED_IN_WOI

public static final Reason TOOL_USED_IN_WOI

TOOL_USED_IN_QTI

public static final Reason TOOL_USED_IN_QTI

TOOL_USED_IN_RFQI

public static final Reason TOOL_USED_IN_RFQI

TOOL_USED_IN_RTVI

public static final Reason TOOL_USED_IN_RTVI

TOOL_USED_IN_RMAI

public static final Reason TOOL_USED_IN_RMAI

TOOL_USED_IN_ARI

public static final Reason TOOL_USED_IN_ARI

TOOL_USED_IN_API

public static final Reason TOOL_USED_IN_API

TOOL_USED_IN_WI

public static final Reason TOOL_USED_IN_WI

TOOL_USED_IN_ECR

public static final Reason TOOL_USED_IN_ECR

TOOL_USED_IN_ECN

public static final Reason TOOL_USED_IN_ECN

TOOL_IS_INACTIVE

public static final Reason TOOL_IS_INACTIVE

TOOL_USED_IN_LNI

public static final Reason TOOL_USED_IN_LNI

TOOL_USED_IN_TOI

public static final Reason TOOL_USED_IN_TOI

TOOL_USED_IN_SWSI

public static final Reason TOOL_USED_IN_SWSI

TOOL_USED_IN_WIS

public static final Reason TOOL_USED_IN_WIS

TOOL_INVENTORY_NOT_ENOUGH

public static final Reason TOOL_INVENTORY_NOT_ENOUGH

SHIP_TO_ID_IS_NOT_EXIST

public static final Reason SHIP_TO_ID_IS_NOT_EXIST

BILL_TO_ID_IS_NOT_EXIST

public static final Reason BILL_TO_ID_IS_NOT_EXIST

RETURN_ADDRESS_ID_TO_ID_IS_NOT_EXIST

public static final Reason RETURN_ADDRESS_ID_TO_ID_IS_NOT_EXIST

DOES_NOT_SET_UNBILLED_ACCOUNT

public static final Reason DOES_NOT_SET_UNBILLED_ACCOUNT

DOES_NOT_SET_UNBILLED_INCOME_ACCOUNT

public static final Reason DOES_NOT_SET_UNBILLED_INCOME_ACCOUNT

FIND_INSPECTION_TYPE_ERROR

public static final Reason FIND_INSPECTION_TYPE_ERROR

INSPECTION_TYPE_IS_EXISTENT

public static final Reason INSPECTION_TYPE_IS_EXISTENT

INSPECTION_TYPE_IS_NOT_EXISTENT

public static final Reason INSPECTION_TYPE_IS_NOT_EXISTENT

INSPECTION_TYPE_IS_USED

public static final Reason INSPECTION_TYPE_IS_USED

SWAP_ORDER_NOT_EXIST

public static final Reason SWAP_ORDER_NOT_EXIST

SWAP_ORDER_APPROVAL_NOT_EXIST

public static final Reason SWAP_ORDER_APPROVAL_NOT_EXIST

SWAP_ORDER_APPROVAL_ALREADY_EXIST

public static final Reason SWAP_ORDER_APPROVAL_ALREADY_EXIST

CAN_NOT_DELETE_SWAP_ORDER_ITEM

public static final Reason CAN_NOT_DELETE_SWAP_ORDER_ITEM

SWAP_SHIPPER_NOT_EXIST

public static final Reason SWAP_SHIPPER_NOT_EXIST

SWAP_SHIPPER_ITEM_NOT_EXIST

public static final Reason SWAP_SHIPPER_ITEM_NOT_EXIST

SWAP_ORDER_ITEM_NOT_EXIST_FOR_THIS_SWAP_SHIPPER_ITEM

public static final Reason SWAP_ORDER_ITEM_NOT_EXIST_FOR_THIS_SWAP_SHIPPER_ITEM

SHIP_QTY_IS_OVER_THAN_SWAP_ITEM_ORDERED

public static final Reason SHIP_QTY_IS_OVER_THAN_SWAP_ITEM_ORDERED

CAN_NOT_DELETE_SWA_SHIPPER_ITEM

public static final Reason CAN_NOT_DELETE_SWA_SHIPPER_ITEM

SWAP_RECEIVER_NOT_EXIST

public static final Reason SWAP_RECEIVER_NOT_EXIST

NCR_APPROVAL_NOT_EXIST

public static final Reason NCR_APPROVAL_NOT_EXIST

NCR_APPROVAL_ALREADY_EXIST

public static final Reason NCR_APPROVAL_ALREADY_EXIST

NCR_APPROVAL_ENG_ALREADY_EXIST

public static final Reason NCR_APPROVAL_ENG_ALREADY_EXIST

NCR_APPROVAL_MFG_ALREADY_EXIST

public static final Reason NCR_APPROVAL_MFG_ALREADY_EXIST

NCR_APPROVAL_QA_ALREADY_EXIST

public static final Reason NCR_APPROVAL_QA_ALREADY_EXIST

CERTIFICATE_NUMBER_IS_USED

public static final Reason CERTIFICATE_NUMBER_IS_USED

SHIPPER_ITEM_HAS_MADE_UNBILLED

public static final Reason SHIPPER_ITEM_HAS_MADE_UNBILLED

APP_TABLE_NAME_SHOULD_START_WITH_APP

public static final Reason APP_TABLE_NAME_SHOULD_START_WITH_APP

APP_COLUMN_NAME_SHOULD_START_WITH_APP

public static final Reason APP_COLUMN_NAME_SHOULD_START_WITH_APP

ONLY_APP_TABLE_CAN_BE_DROP

public static final Reason ONLY_APP_TABLE_CAN_BE_DROP

ONLY_APP_COLUMN_CAN_BE_DROP

public static final Reason ONLY_APP_COLUMN_CAN_BE_DROP

UNBILLED_ITEMS_SHOULD_BE_WITH_THE_SAME_UNBILLED_EXCHANGE_FOR_OFFSET

public static final Reason UNBILLED_ITEMS_SHOULD_BE_WITH_THE_SAME_UNBILLED_EXCHANGE_FOR_OFFSET

CAN_NOT_CANCEL_AR_WITH_RECEIVED_PAYMENT

public static final Reason CAN_NOT_CANCEL_AR_WITH_RECEIVED_PAYMENT

CAN_NOT_CANCEL_AP_WITH_PAYMENT

public static final Reason CAN_NOT_CANCEL_AP_WITH_PAYMENT

ONLY_ONE_PRIMARY_KEY_PERMITTED

public static final Reason ONLY_ONE_PRIMARY_KEY_PERMITTED

SO_TOTAL_SMALLER_THAN_AR_PREPAY_PAID_TOTAL

public static final Reason SO_TOTAL_SMALLER_THAN_AR_PREPAY_PAID_TOTAL

DEFAULT_MFG_IS_EMPTY

public static final Reason DEFAULT_MFG_IS_EMPTY

UPC_MFG_IS_EMPTY

public static final Reason UPC_MFG_IS_EMPTY

DUPLICATE_MPN

public static final Reason DUPLICATE_MPN

NO_WAREHOUSE_FOR_LOCATION

public static final Reason NO_WAREHOUSE_FOR_LOCATION

NO_SUCH_ORDER

public static final Reason NO_SUCH_ORDER

ORDER_CAN_NOT_LINK_TO_ITSELF

public static final Reason ORDER_CAN_NOT_LINK_TO_ITSELF

TRANSFER_ORDER_ITEM_SHOULD_BE_BACKFLUSH_MATERIAL

public static final Reason TRANSFER_ORDER_ITEM_SHOULD_BE_BACKFLUSH_MATERIAL

TO_lOCATION_SHOULD_BE_TO_ADDRESS_ID

public static final Reason TO_lOCATION_SHOULD_BE_TO_ADDRESS_ID

NONPRODUCTIVE_PICKING_TYPE_ALREADY_ADDED

public static final Reason NONPRODUCTIVE_PICKING_TYPE_ALREADY_ADDED

NONPRODUCTIVE_PICKING_TYPE_NOT_EXIST

public static final Reason NONPRODUCTIVE_PICKING_TYPE_NOT_EXIST

NONPRODUCTIVE_PICKING_APPROVAL_ALREADY_ADDED

public static final Reason NONPRODUCTIVE_PICKING_APPROVAL_ALREADY_ADDED

NONPRODUCTIVE_PICKING_APPROVAL_NOT_EXIST

public static final Reason NONPRODUCTIVE_PICKING_APPROVAL_NOT_EXIST

DEPARTMENT_LOCATION_FOR_BACKFLUSH_ALREADY_ADDED

public static final Reason DEPARTMENT_LOCATION_FOR_BACKFLUSH_ALREADY_ADDED

DEPARTMENT_LOCATION_FOR_BACKFLUSH_NOT_EXIST

public static final Reason DEPARTMENT_LOCATION_FOR_BACKFLUSH_NOT_EXIST

NONPRODUCTIVE_PICKING_NOT_EXIST

public static final Reason NONPRODUCTIVE_PICKING_NOT_EXIST

CAN_NOT_DELETE_NONPRODUCTIVE_PICKING_ITEM

public static final Reason CAN_NOT_DELETE_NONPRODUCTIVE_PICKING_ITEM

LOCATION_OF_DEPARTMENT_LOCATION_FOR_BACKFLUSH_ALREADY_ADDED

public static final Reason LOCATION_OF_DEPARTMENT_LOCATION_FOR_BACKFLUSH_ALREADY_ADDED

BACKFLUSH_LOCATION_FOR_DEPARTMENT_NOT_EXIST

public static final Reason BACKFLUSH_LOCATION_FOR_DEPARTMENT_NOT_EXIST

PART_IS_NOT_BACKFLUSH_MATERIAL

public static final Reason PART_IS_NOT_BACKFLUSH_MATERIAL

ADDRESS_CAN_NOT_USE_BACKFLUSH

public static final Reason ADDRESS_CAN_NOT_USE_BACKFLUSH

NONPRODUCTIVE_PICKING_NOT_OPEN

public static final Reason NONPRODUCTIVE_PICKING_NOT_OPEN

LOCATE_ALREADY_EXIST

public static final Reason LOCATE_ALREADY_EXIST

NONPRODUCTIVE_PICKING_TYPE_IS_USED

public static final Reason NONPRODUCTIVE_PICKING_TYPE_IS_USED

NONPRODUCTIVE_PICKING_TYPE_CAN_BE_DELETE

public static final Reason NONPRODUCTIVE_PICKING_TYPE_CAN_BE_DELETE

CAN_NOT_CANCEL_THE_OPEN_ORDER

public static final Reason CAN_NOT_CANCEL_THE_OPEN_ORDER

SWAP_ORDER_ITEM_ALREADY_SHIPPED

public static final Reason SWAP_ORDER_ITEM_ALREADY_SHIPPED

RTV_ORDER_ITEM_ALREADY_SHIPPED

public static final Reason RTV_ORDER_ITEM_ALREADY_SHIPPED

RMA_ORDER_ITEM_ALREADY_RECEIVED

public static final Reason RMA_ORDER_ITEM_ALREADY_RECEIVED

EXCHANGE_RATE_NOT_SETUP

public static final Reason EXCHANGE_RATE_NOT_SETUP

INQA_ALREADY_CREATE_NCR

public static final Reason INQA_ALREADY_CREATE_NCR

FINANCING_EXPENSE_ACCOUNT_NOT_EXIST

public static final Reason FINANCING_EXPENSE_ACCOUNT_NOT_EXIST

PAYMENT_VARIANCE_OVER_THAN_GA_ZERO_CAN_NOT_CLOSE

public static final Reason PAYMENT_VARIANCE_OVER_THAN_GA_ZERO_CAN_NOT_CLOSE

BANK_RECONCILIATION_REPORT_NOT_EXIST

public static final Reason BANK_RECONCILIATION_REPORT_NOT_EXIST

BANK_RECONCILIATION_REPORT_HAS_EXIST

public static final Reason BANK_RECONCILIATION_REPORT_HAS_EXIST
Constructor Detail

BIZReason

public BIZReason()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BizTarget

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BizTarget

java.lang.Object
    extended by  bb.common.BizTarget

public class BizTarget
extends java.lang.Object

Field Summary
static java.lang.String | ACCOUNT_CHART
static java.lang.String | ACCOUNT_CHART_CATEGORY
static java.lang.String | ACCOUNT_CHART_MAPPING
static java.lang.String | ACCOUNT_CHART_NUMBER
static java.lang.String | ACCOUNT_CHECK_RUN
static java.lang.String | ACCOUNT_CREDIT
static java.lang.String | ACCOUNT_DEBIT
static java.lang.String | ACCOUNT_FISCALYEAR_SETTINGS
static java.lang.String | ACCOUNT_GENERALlEDGER_SETTTINGS
static java.lang.String | ACCOUNT_PAYABLE
static java.lang.String | ACCOUNT_PAYABLE_PREPAY
static java.lang.String | ACCOUNT_PAYMENT_RUN
static java.lang.String | ACCOUNT_RECEIVABLE
static java.lang.String | ACCOUNT_RECEIVABLE_PAYMENT
static java.lang.String | ACCOUNT_RECEIVABLE_PREPAY
static java.lang.String | ACCOUNT_SETTING
static java.lang.String | ACCOUNT_TRANSACTION
static java.lang.String | ACCOUNT_TRANSACTION_TYPE
static java.lang.String | ACCOUNTING_INFO_DOC
static java.lang.String | ACCOUNTING_PERIOD
static java.lang.String | ADDRESS
static java.lang.String | ADDRESS_QA_DOC
static java.lang.String | APP
static java.lang.String | ASSET
static java.lang.String | ASSET_DEPRECIATE
static java.lang.String | ASSET_TYPE
static java.lang.String | AUDIT
static java.lang.String | BACKFLUSH_MATERIAL
static java.lang.String | BALANCE_SHEET
static java.lang.String | BANK_RECONCILIATION_REPORT
static java.lang.String | BIZBOX_USER
static java.lang.String | BOM
static java.lang.String | BOM_APPROVAL
static java.lang.String | BUDGET
static java.lang.String | BUYER_CODE
static java.lang.String | CARRIER
static java.lang.String | CASH_FLOW_BUDGET
static java.lang.String | CASHIER
static java.lang.String | CATALOG
static java.lang.String | CATEGORY_INDEX
static java.lang.String | CERTIFICATE_DESCRIPTION
static java.lang.String | CERTIFICATE_DOC
static java.lang.String | CG_CLIENT_PROGRAM_USER
static java.lang.String | CG_CUST_RFQ
static java.lang.String | CG_CUSTOMER_SERVICE_REQUEST
static java.lang.String | CG_PART
static java.lang.String | CG_QUOTE_ADDRESS
static java.lang.String | CG_SALE_ITEM
static java.lang.String | CHANGE_STD_COST_WORKSHEET
static java.lang.String | CLOSING_SATEMENT
static java.lang.String | COMPANY_DEFAULT_PA
static java.lang.String | COMPANY_SETTING
static java.lang.String | COMPANY_UNIT
static java.lang.String | COMPANY_UNIT_ACCOUNT
static java.lang.String | CONTRACE_PRICE
static java.lang.String | CONTRACE_PRICE_CUSTOMER
static java.lang.String | CONTRACE_PRICE_ITEM
static java.lang.String | CORRICTIVE_ACTION_REQUEST
static java.lang.String | CREDIT_MEMO
static java.lang.String | CS_ITEM_DOC
static java.lang.String | CURRENCY
static java.lang.String | CURRENCY_EXCHANGE
static java.lang.String | CUSTOMER
static java.lang.String | CUSTOMER_CATALOG
static java.lang.String | CUSTOMER_DOC
static java.lang.String | CUSTOMER_FEEDBACK
static java.lang.String | CUSTOMER_FEEDBACK_ITEM
static java.lang.String | CUSTOMER_PART
static java.lang.String | CUSTOMER_SERVICE_INCIDENT
static java.lang.String | CUSTOMER_SERVICE_INCIDENT_ITEM
static java.lang.String | CUSTOMER_SERVICE_REQUEST
static java.lang.String | CUSTOMER_VENDOR_TYPE
static java.lang.String | CYCLE_WORK_SHEET
static java.lang.String | CYCLE_WORK_SHEET_PAGE_NUMBER
static java.lang.String | DEBIT_MEMO
static java.lang.String | DEPARTMENT_LOCATION_FOR_BACKFLUSH
static java.lang.String | DESIGN_CONTROL
static java.lang.String | DESIGN_CONTROL_DOCUMENT
static java.lang.String | DISASSEMBLE_WORK_ORDER
static java.lang.String | DISASSEMBLE_WORK_ORDER_APPROVAL
static java.lang.String | DISASSEMBLE_WORK_ORDER_ITEM
static java.lang.String | DISASSEMBLE_WORK_ORDER_ITEM_ISSUE
static java.lang.String | DISASSEMBLE_WORK_ORDER_ITEM_RECEIVER
static java.lang.String | DOCUMENT
static java.lang.String | DOCUMENT_SETTINGS
static java.lang.String | DWF_DRAWING
static java.lang.String | DWG_DRAWING
static java.lang.String | ECN
static java.lang.String | ECN_REVIEW
static java.lang.String | ECR
static java.lang.String | ECR_APPROVAL
static java.lang.String | EDC_DOC
static java.lang.String | EMP_TRAINING_RECORDS
static java.lang.String | EMPLOYEE
static java.lang.String | EMPLOYEE_TRAINING
static java.lang.String | ENG_GROUP
static java.lang.String | ENG_GROUP_USER
static java.lang.String | ENGINEERING_SHARING
static java.lang.String | ENGINEERING_SHARING_ITEM
static java.lang.String | EQUIPMENT
static java.lang.String | EXCHANAGE_RATE
static java.lang.String | Exchange_Gain_And_Loss_Account
static java.lang.String | EXPENSE
static java.lang.String | EXPENSE_ACCOUNT
static java.lang.String | FEEDBACK_QUESTION
static java.lang.String | FILE_SYSTEM
static java.lang.String | FISCAL_YEAR
static java.lang.String | FISCAL_YEAR_BUDGET
static java.lang.String | FISCAL_YEAR_SETTINGS
static java.lang.String | FTP
static java.lang.String | GENERAL_LEDGER
static java.lang.String | GENERAL_LEDGER_APPROVAL
static java.lang.String | GL_CLOSED
static java.lang.String | GL_MONTH
static java.lang.String | GROUP_USER
static java.lang.String | HISTORICAL_INVENTORY
static java.lang.String | INCOTERM
static java.lang.String | INSPECTION_REPORT
static java.lang.String | INSPECTION_TYPE
static java.lang.String | INVENTORY_ADJUSTMENT
static java.lang.String | INVOICE
static java.lang.String | IR
static java.lang.String | ISSUE_ITEM_AGENT
static java.lang.String | ITEM_STATUS
static java.lang.String | JOB_CATEGORY
static java.lang.String | LN_RECEIVER
static java.lang.String | LN_SHIPPER
static java.lang.String | LN_SHIPPER_ITEM
static java.lang.String | MAINTENANCE_ITEM
static java.lang.String | MAKE_CHECK
static java.lang.String | MANUFACTURER
static java.lang.String | MANUFACTURER_PART_NUMBER
static java.lang.String | MECN
static java.lang.String | MESSAGE
static java.lang.String | MONTH_YEAR
static java.lang.String | MULTI_LANGUAGE_DESCRIPTION
static java.lang.String | MY_PRINT_LIST
static java.lang.String | NCR
static java.lang.String | NCR_APPROVAL
static java.lang.String | NON_CONFORMANCE_CODE
static java.lang.String | NONPRODUCTIVE_PICKING
static java.lang.String | NONPRODUCTIVE_PICKING_APPROVAL
static java.lang.String | NONPRODUCTIVE_PICKING_ITEM_ISSUE
static java.lang.String | NONPRODUCTIVE_PICKING_TYPE
static java.lang.String | NOTICE_USER
static java.lang.String | ON_LOAN
static java.lang.String | ON_LOAN_ITEM
static java.lang.String | ONLOAN_REVIEW
static java.lang.String | ONLOAN_SHIPPER
static java.lang.String | OPERATING_INSTRUCTION
static java.lang.String | OPERATING_INSTRUCTION_TYPE
static java.lang.String | ORDER
static java.lang.String | PA_ACCOUNT
static java.lang.String | PA_VARIANCE_ACCOUNT
static java.lang.String | PACKING_BOX
static java.lang.String | PACKING_BOX_ITEM
static java.lang.String | PART
static java.lang.String | PART_CATALOG
static java.lang.String | PART_CERTIFICATE
static java.lang.String | PART_CLASS
static java.lang.String | PART_DESCRIPTION
static java.lang.String | PART_DISCOUNT
static java.lang.String | PART_IN_QA
static java.lang.String | PART_INSPECTION
static java.lang.String | PART_INVENTORY
static java.lang.String | PART_ISSUE
static java.lang.String | PART_MANUFACTURER
static java.lang.String | PART_MATERIAL
static java.lang.String | PART_ONHAND
static java.lang.String | PART_PICTURE
static java.lang.String | PART_SECURITY_LEVEL
static java.lang.String | PART_SHARE_COMPANY
static java.lang.String | PART_TRACEABLE
static java.lang.String | PART_TYPE
static java.lang.String | PART_UOM
static java.lang.String | PART_VENDOR
static java.lang.String | PAYABLE_METHOD
static java.lang.String | PAYMENT
static java.lang.String | PAYMENT_RUN
static java.lang.String | PHYSICAL_WORK_SHEET
static java.lang.String | PHYSICAL_WORK_SHEET_PAGE_NUMBER
static java.lang.String | PO_NNMBER
static java.lang.String | POS_SETTING
static java.lang.String | POST_CHECK
static java.lang.String | PREVENTIVE_ACTION_REQUEST
static java.lang.String | PREVENTIVE_ACTION_REQUEST_ITEM
static java.lang.String | PRINT_TEMPLATE
static java.lang.String | PROFORMA_INVOICE
static java.lang.String | PROFORMA_RECEIVER
static java.lang.String | PROJECT_CLASS
static java.lang.String | PURCHASE_ORDER
static java.lang.String | PURCHASE_ORDER_APPROVAL
static java.lang.String | PURCHASE_ORDER_ITEM
static java.lang.String | PURCHASE_ORDER_ITEM_MANUFACTURER
static java.lang.String | PURCHASE_ORDER_MESSAGE
static java.lang.String | PURCHASE_WORK_SHEET
static java.lang.String | PURCHASE_WORK_SHEET_ITEM
static java.lang.String | QT_DOC
static java.lang.String | QUOTE
static java.lang.String | QUOTE_ITEM
static java.lang.String | QUOTE_ITEM_MFG
static java.lang.String | RECEIVER
static java.lang.String | RECEIVER_ITEM
static java.lang.String | RECEIVER_ITEM_AGENT
static java.lang.String | RECEIVER_WORK_ORDER
static java.lang.String | REFERENCE_DOC
static java.lang.String | REQUEST_FOR_CHANGE
static java.lang.String | REQUEST_FOR_QUOTE
static java.lang.String | REQUEST_FOR_QUOTE_ITEM
static java.lang.String | REQUEST_FOR_QUOTE_ITEM_MANUFACTURER
static java.lang.String | RETURN_MATERIAL_AUTHORIZATION_ITEM_MANUFACTURER
static java.lang.String | RETURN_TO_VENDOR
static java.lang.String | RETURN_TO_VENDOR_ITEM
static java.lang.String | RETURN_TO_VENDOR_ITEM_MANUFACTURER
static java.lang.String | RFQ_MESSAGE
static java.lang.String | RFQ_MESSAGE_ITEM
static java.lang.String | RMA
static java.lang.String | RMA_DOC
static java.lang.String | RMA_ITEM
static java.lang.String | RMA_RECEIVER
static java.lang.String | RMA_RECEIVER_ITEM
static java.lang.String | RMA_REVIEW
static java.lang.String | ROLL_UP_BOM_STD_COST_WORKSHEET
static java.lang.String | RRMA
static java.lang.String | RRMA_ITEM
static java.lang.String | RTV_APPROVAL
static java.lang.String | RTV_SHIPPER
static java.lang.String | RUNNING_ACCOUNT_ORDER
static java.lang.String | SALES_CODE
static java.lang.String | SALES_ORDER
static java.lang.String | SALES_ORDER_CURRENCY
static java.lang.String | SALES_ORDER_ITEM
static java.lang.String | SALES_ORDER_ITEM_MFG
static java.lang.String | SALES_ORDER_REVIEW
static java.lang.String | SALESMAN
static java.lang.String | SERIAL_NUMBER
static java.lang.String | SHIP_LIST
static java.lang.String | SHIP_LIST_ITEM
static java.lang.String | SHIP_LIST_OWNER
static java.lang.String | SHIP_LIST_OWNER_ITEM
static java.lang.String | SHIPPER
static java.lang.String | SHIPPER_ITEM
static java.lang.String | SO_DOC
static java.lang.String | SR_NUMBER
static java.lang.String | SWAP_ORDER
static java.lang.String | SWAP_ORDER_APPROVAL
static java.lang.String | SWAP_ORDER_ITEM
static java.lang.String | SWAP_RECEIVER
static java.lang.String | SWAP_RECEIVER_ITEM
static java.lang.String | SWAP_SHIPPER
static java.lang.String | SWAP_SHIPPER_ITEM
static java.lang.String | TASK
static java.lang.String | TEMPORARYEMPLOYEE
static java.lang.String | TERM
static java.lang.String | TIME_CARDS
static java.lang.String | TOO_MUCH_DATA_TO_SEARCH
static java.lang.String | TOOL
static java.lang.String | TOOL_CALIBRATION
static java.lang.String | TOOL_ONHAND
static java.lang.String | TRACEABLE
static java.lang.String | TRACEABLE_CATEGORIES
static java.lang.String | TRACEABLE_SPECIFITIONS
static java.lang.String | TRACKING
static java.lang.String | TRANSFER_ORDER
static java.lang.String | TRANSFER_ORDER_APPROVAL
static java.lang.String | TRANSFER_ORDER_ITEM
static java.lang.String | TRANSFER_RECIEVER
static java.lang.String | TRANSFER_RECIEVER_ITEM
static java.lang.String | TRANSFER_SHIPPER
static java.lang.String | TRANSFER_SHIPPER_ITEM
static java.lang.String | UNBILLED
static java.lang.String | USER_GROUP
static java.lang.String | USER_TRUE_NAME
static java.lang.String | USER_ZIPCODE_TAX
static java.lang.String | VENDOR
static java.lang.String | VENDOR_CONTRACE_PRICE
static java.lang.String | VENDOR_CONTRACE_PRICE_ITEM
static java.lang.String | VENDOR_CONTRACE_PRICE_VENDOR
static java.lang.String | VENDOR_CRITICAL_LEVEL
static java.lang.String | VENDOR_DOC
static java.lang.String | VENDOR_GROUP_USER
static java.lang.String | VENDOR_PART
static java.lang.String | WAREHOUSE
static java.lang.String | WEIGHT_UNIT
static java.lang.String | WIP_PHYSICAL_WORK_SHEET
static java.lang.String | WORK_CALENDAR
static java.lang.String | WORK_CENTER
static java.lang.String | WORK_CENTER_GROUP
static java.lang.String | WORK_INSTRUCTION
static java.lang.String | WORK_INSTRUCTION_APPROVAL
static java.lang.String | WORK_INSTRUCTION_DOC
static java.lang.String | WORK_ORDER
static java.lang.String | WORK_ORDER_APPROVAL
static java.lang.String | WORK_ORDER_ITEM
static java.lang.String | WORK_ORDER_ITEM_ISSUE
static java.lang.String | WORK_ORDER_ITEM_PART_DETAIL
static java.lang.String | WORK_ORDER_ITEM_TIME_DETAIL
static java.lang.String | WORK_ORDER_WORK_INSTRUCTION
static java.lang.String | WORK_ORDER_WORK_INSTRUCTION_SEQ
static java.lang.String | WORK_PERIOD
static java.lang.String | WORK_WORK_SHEET
static java.lang.String | WORK_WORK_SHEET_ITEM
Constructor Summary
BizTarget()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ACCOUNT_SETTING

public static final java.lang.String ACCOUNT_SETTING
See Also:
Constant Field Values

ACCOUNT_CHART_NUMBER

public static final java.lang.String ACCOUNT_CHART_NUMBER
See Also:
Constant Field Values

ACCOUNT_CHART

public static final java.lang.String ACCOUNT_CHART
See Also:
Constant Field Values

ACCOUNT_FISCALYEAR_SETTINGS

public static final java.lang.String ACCOUNT_FISCALYEAR_SETTINGS
See Also:
Constant Field Values

ACCOUNT_GENERALlEDGER_SETTTINGS

public static final java.lang.String ACCOUNT_GENERALlEDGER_SETTTINGS
See Also:
Constant Field Values

ACCOUNT_RECEIVABLE

public static final java.lang.String ACCOUNT_RECEIVABLE
See Also:
Constant Field Values

ACCOUNT_RECEIVABLE_PAYMENT

public static final java.lang.String ACCOUNT_RECEIVABLE_PAYMENT
See Also:
Constant Field Values

ACCOUNT_PAYABLE

public static final java.lang.String ACCOUNT_PAYABLE
See Also:
Constant Field Values

ACCOUNT_PAYABLE_PREPAY

public static final java.lang.String ACCOUNT_PAYABLE_PREPAY
See Also:
Constant Field Values

ACCOUNT_RECEIVABLE_PREPAY

public static final java.lang.String ACCOUNT_RECEIVABLE_PREPAY
See Also:
Constant Field Values

ACCOUNT_PAYMENT_RUN

public static final java.lang.String ACCOUNT_PAYMENT_RUN
See Also:
Constant Field Values

ACCOUNT_TRANSACTION

public static final java.lang.String ACCOUNT_TRANSACTION
See Also:
Constant Field Values

ACCOUNT_CREDIT

public static final java.lang.String ACCOUNT_CREDIT
See Also:
Constant Field Values

ACCOUNT_DEBIT

public static final java.lang.String ACCOUNT_DEBIT
See Also:
Constant Field Values

ACCOUNT_TRANSACTION_TYPE

public static final java.lang.String ACCOUNT_TRANSACTION_TYPE
See Also:
Constant Field Values

ACCOUNT_CHECK_RUN

public static final java.lang.String ACCOUNT_CHECK_RUN
See Also:
Constant Field Values

ACCOUNT_CHART_MAPPING

public static final java.lang.String ACCOUNT_CHART_MAPPING
See Also:
Constant Field Values

ACCOUNT_CHART_CATEGORY

public static final java.lang.String ACCOUNT_CHART_CATEGORY
See Also:
Constant Field Values

ADDRESS

public static final java.lang.String ADDRESS
See Also:
Constant Field Values

AUDIT

public static final java.lang.String AUDIT
See Also:
Constant Field Values

ASSET

public static final java.lang.String ASSET
See Also:
Constant Field Values

ASSET_TYPE

public static final java.lang.String ASSET_TYPE
See Also:
Constant Field Values

ASSET_DEPRECIATE

public static final java.lang.String ASSET_DEPRECIATE
See Also:
Constant Field Values

BALANCE_SHEET

public static final java.lang.String BALANCE_SHEET
See Also:
Constant Field Values

BIZBOX_USER

public static final java.lang.String BIZBOX_USER
See Also:
Constant Field Values

BOM

public static final java.lang.String BOM
See Also:
Constant Field Values

BUYER_CODE

public static final java.lang.String BUYER_CODE
See Also:
Constant Field Values

BUDGET

public static final java.lang.String BUDGET
See Also:
Constant Field Values

CASH_FLOW_BUDGET

public static final java.lang.String CASH_FLOW_BUDGET
See Also:
Constant Field Values

FISCAL_YEAR_BUDGET

public static final java.lang.String FISCAL_YEAR_BUDGET
See Also:
Constant Field Values

TOOL_CALIBRATION

public static final java.lang.String TOOL_CALIBRATION
See Also:
Constant Field Values

CATALOG

public static final java.lang.String CATALOG
See Also:
Constant Field Values

PART_CATALOG

public static final java.lang.String PART_CATALOG
See Also:
Constant Field Values

CUSTOMER_CATALOG

public static final java.lang.String CUSTOMER_CATALOG
See Also:
Constant Field Values

CERTIFICATE_DESCRIPTION

public static final java.lang.String CERTIFICATE_DESCRIPTION
See Also:
Constant Field Values

CLOSING_SATEMENT

public static final java.lang.String CLOSING_SATEMENT
See Also:
Constant Field Values

COMPANY_DEFAULT_PA

public static final java.lang.String COMPANY_DEFAULT_PA
See Also:
Constant Field Values

COMPANY_SETTING

public static final java.lang.String COMPANY_SETTING
See Also:
Constant Field Values

CONTRACE_PRICE

public static final java.lang.String CONTRACE_PRICE
See Also:
Constant Field Values

CONTRACE_PRICE_ITEM

public static final java.lang.String CONTRACE_PRICE_ITEM
See Also:
Constant Field Values

CONTRACE_PRICE_CUSTOMER

public static final java.lang.String CONTRACE_PRICE_CUSTOMER
See Also:
Constant Field Values

CORRICTIVE_ACTION_REQUEST

public static final java.lang.String CORRICTIVE_ACTION_REQUEST
See Also:
Constant Field Values

COMPANY_UNIT

public static final java.lang.String COMPANY_UNIT
See Also:
Constant Field Values

COMPANY_UNIT_ACCOUNT

public static final java.lang.String COMPANY_UNIT_ACCOUNT
See Also:
Constant Field Values

CUSTOMER_FEEDBACK

public static final java.lang.String CUSTOMER_FEEDBACK
See Also:
Constant Field Values

CUSTOMER_FEEDBACK_ITEM

public static final java.lang.String CUSTOMER_FEEDBACK_ITEM
See Also:
Constant Field Values

CUSTOMER_VENDOR_TYPE

public static final java.lang.String CUSTOMER_VENDOR_TYPE
See Also:
Constant Field Values

CREDIT_MEMO

public static final java.lang.String CREDIT_MEMO
See Also:
Constant Field Values

CARRIER

public static final java.lang.String CARRIER
See Also:
Constant Field Values

CURRENCY

public static final java.lang.String CURRENCY
See Also:
Constant Field Values

CURRENCY_EXCHANGE

public static final java.lang.String CURRENCY_EXCHANGE
See Also:
Constant Field Values

CUSTOMER

public static final java.lang.String CUSTOMER
See Also:
Constant Field Values

CUSTOMER_SERVICE_INCIDENT

public static final java.lang.String CUSTOMER_SERVICE_INCIDENT
See Also:
Constant Field Values

CUSTOMER_SERVICE_REQUEST

public static final java.lang.String CUSTOMER_SERVICE_REQUEST
See Also:
Constant Field Values

CUSTOMER_SERVICE_INCIDENT_ITEM

public static final java.lang.String CUSTOMER_SERVICE_INCIDENT_ITEM
See Also:
Constant Field Values

CYCLE_WORK_SHEET

public static final java.lang.String CYCLE_WORK_SHEET
See Also:
Constant Field Values

CYCLE_WORK_SHEET_PAGE_NUMBER

public static final java.lang.String CYCLE_WORK_SHEET_PAGE_NUMBER
See Also:
Constant Field Values

DEBIT_MEMO

public static final java.lang.String DEBIT_MEMO
See Also:
Constant Field Values

DESIGN_CONTROL

public static final java.lang.String DESIGN_CONTROL
See Also:
Constant Field Values

DESIGN_CONTROL_DOCUMENT

public static final java.lang.String DESIGN_CONTROL_DOCUMENT
See Also:
Constant Field Values

DOCUMENT

public static final java.lang.String DOCUMENT
See Also:
Constant Field Values

DOCUMENT_SETTINGS

public static final java.lang.String DOCUMENT_SETTINGS
See Also:
Constant Field Values

DWF_DRAWING

public static final java.lang.String DWF_DRAWING
See Also:
Constant Field Values

DWG_DRAWING

public static final java.lang.String DWG_DRAWING
See Also:
Constant Field Values

SO_DOC

public static final java.lang.String SO_DOC
See Also:
Constant Field Values

QT_DOC

public static final java.lang.String QT_DOC
See Also:
Constant Field Values

EDC_DOC

public static final java.lang.String EDC_DOC
See Also:
Constant Field Values

ACCOUNTING_INFO_DOC

public static final java.lang.String ACCOUNTING_INFO_DOC
See Also:
Constant Field Values

WORK_INSTRUCTION_DOC

public static final java.lang.String WORK_INSTRUCTION_DOC
See Also:
Constant Field Values

ACCOUNTING_PERIOD

public static final java.lang.String ACCOUNTING_PERIOD
See Also:
Constant Field Values

CERTIFICATE_DOC

public static final java.lang.String CERTIFICATE_DOC
See Also:
Constant Field Values

ADDRESS_QA_DOC

public static final java.lang.String ADDRESS_QA_DOC
See Also:
Constant Field Values

CUSTOMER_DOC

public static final java.lang.String CUSTOMER_DOC
See Also:
Constant Field Values

VENDOR_DOC

public static final java.lang.String VENDOR_DOC
See Also:
Constant Field Values

EMP_TRAINING_RECORDS

public static final java.lang.String EMP_TRAINING_RECORDS
See Also:
Constant Field Values

CS_ITEM_DOC

public static final java.lang.String CS_ITEM_DOC
See Also:
Constant Field Values

ECN

public static final java.lang.String ECN
See Also:
Constant Field Values

MECN

public static final java.lang.String MECN
See Also:
Constant Field Values

ECR

public static final java.lang.String ECR
See Also:
Constant Field Values

EMPLOYEE

public static final java.lang.String EMPLOYEE
See Also:
Constant Field Values

EMPLOYEE_TRAINING

public static final java.lang.String EMPLOYEE_TRAINING
See Also:
Constant Field Values

EXPENSE

public static final java.lang.String EXPENSE
See Also:
Constant Field Values

EXPENSE_ACCOUNT

public static final java.lang.String EXPENSE_ACCOUNT
See Also:
Constant Field Values

ENGINEERING_SHARING

public static final java.lang.String ENGINEERING_SHARING
See Also:
Constant Field Values

ENGINEERING_SHARING_ITEM

public static final java.lang.String ENGINEERING_SHARING_ITEM
See Also:
Constant Field Values

FEEDBACK_QUESTION

public static final java.lang.String FEEDBACK_QUESTION
See Also:
Constant Field Values

FTP

public static final java.lang.String FTP
See Also:
Constant Field Values

FILE_SYSTEM

public static final java.lang.String FILE_SYSTEM
See Also:
Constant Field Values

FISCAL_YEAR

public static final java.lang.String FISCAL_YEAR
See Also:
Constant Field Values

FISCAL_YEAR_SETTINGS

public static final java.lang.String FISCAL_YEAR_SETTINGS
See Also:
Constant Field Values

GENERAL_LEDGER

public static final java.lang.String GENERAL_LEDGER
See Also:
Constant Field Values

GENERAL_LEDGER_APPROVAL

public static final java.lang.String GENERAL_LEDGER_APPROVAL
See Also:
Constant Field Values

GL_MONTH

public static final java.lang.String GL_MONTH
See Also:
Constant Field Values

GL_CLOSED

public static final java.lang.String GL_CLOSED
See Also:
Constant Field Values

ISSUE_ITEM_AGENT

public static final java.lang.String ISSUE_ITEM_AGENT
See Also:
Constant Field Values

ITEM_STATUS

public static final java.lang.String ITEM_STATUS
See Also:
Constant Field Values

INCOTERM

public static final java.lang.String INCOTERM
See Also:
Constant Field Values

INVOICE

public static final java.lang.String INVOICE
See Also:
Constant Field Values

INVENTORY_ADJUSTMENT

public static final java.lang.String INVENTORY_ADJUSTMENT
See Also:
Constant Field Values

HISTORICAL_INVENTORY

public static final java.lang.String HISTORICAL_INVENTORY
See Also:
Constant Field Values

MAKE_CHECK

public static final java.lang.String MAKE_CHECK
See Also:
Constant Field Values

MANUFACTURER_PART_NUMBER

public static final java.lang.String MANUFACTURER_PART_NUMBER
See Also:
Constant Field Values

MESSAGE

public static final java.lang.String MESSAGE
See Also:
Constant Field Values

MY_PRINT_LIST

public static final java.lang.String MY_PRINT_LIST
See Also:
Constant Field Values

MONTH_YEAR

public static final java.lang.String MONTH_YEAR
See Also:
Constant Field Values

NCR

public static final java.lang.String NCR
See Also:
Constant Field Values

IR

public static final java.lang.String IR
See Also:
Constant Field Values

NOTICE_USER

public static final java.lang.String NOTICE_USER
See Also:
Constant Field Values

ON_LOAN

public static final java.lang.String ON_LOAN
See Also:
Constant Field Values

ON_LOAN_ITEM

public static final java.lang.String ON_LOAN_ITEM
See Also:
Constant Field Values

PACKING_BOX

public static final java.lang.String PACKING_BOX
See Also:
Constant Field Values

PACKING_BOX_ITEM

public static final java.lang.String PACKING_BOX_ITEM
See Also:
Constant Field Values

PROFORMA_INVOICE

public static final java.lang.String PROFORMA_INVOICE
See Also:
Constant Field Values

PROFORMA_RECEIVER

public static final java.lang.String PROFORMA_RECEIVER
See Also:
Constant Field Values

PART_DISCOUNT

public static final java.lang.String PART_DISCOUNT
See Also:
Constant Field Values

PART_CLASS

public static final java.lang.String PART_CLASS
See Also:
Constant Field Values

PAYMENT

public static final java.lang.String PAYMENT
See Also:
Constant Field Values

PAYMENT_RUN

public static final java.lang.String PAYMENT_RUN
See Also:
Constant Field Values

POST_CHECK

public static final java.lang.String POST_CHECK
See Also:
Constant Field Values

PAYABLE_METHOD

public static final java.lang.String PAYABLE_METHOD
See Also:
Constant Field Values

CASHIER

public static final java.lang.String CASHIER
See Also:
Constant Field Values

TRACEABLE

public static final java.lang.String TRACEABLE
See Also:
Constant Field Values

TRACEABLE_CATEGORIES

public static final java.lang.String TRACEABLE_CATEGORIES
See Also:
Constant Field Values

TRACEABLE_SPECIFITIONS

public static final java.lang.String TRACEABLE_SPECIFITIONS
See Also:
Constant Field Values

SALESMAN

public static final java.lang.String SALESMAN
See Also:
Constant Field Values

SALES_CODE

public static final java.lang.String SALES_CODE
See Also:
Constant Field Values

SALES_ORDER

public static final java.lang.String SALES_ORDER
See Also:
Constant Field Values

CG_SALE_ITEM

public static final java.lang.String CG_SALE_ITEM
See Also:
Constant Field Values

SALES_ORDER_CURRENCY

public static final java.lang.String SALES_ORDER_CURRENCY
See Also:
Constant Field Values

SALES_ORDER_REVIEW

public static final java.lang.String SALES_ORDER_REVIEW
See Also:
Constant Field Values

ECN_REVIEW

public static final java.lang.String ECN_REVIEW
See Also:
Constant Field Values

ONLOAN_REVIEW

public static final java.lang.String ONLOAN_REVIEW
See Also:
Constant Field Values

ECR_APPROVAL

public static final java.lang.String ECR_APPROVAL
See Also:
Constant Field Values

SALES_ORDER_ITEM

public static final java.lang.String SALES_ORDER_ITEM
See Also:
Constant Field Values

SALES_ORDER_ITEM_MFG

public static final java.lang.String SALES_ORDER_ITEM_MFG
See Also:
Constant Field Values

SHIPPER

public static final java.lang.String SHIPPER
See Also:
Constant Field Values

ONLOAN_SHIPPER

public static final java.lang.String ONLOAN_SHIPPER
See Also:
Constant Field Values

SHIPPER_ITEM

public static final java.lang.String SHIPPER_ITEM
See Also:
Constant Field Values

SHIP_LIST

public static final java.lang.String SHIP_LIST
See Also:
Constant Field Values

SHIP_LIST_ITEM

public static final java.lang.String SHIP_LIST_ITEM
See Also:
Constant Field Values

SHIP_LIST_OWNER

public static final java.lang.String SHIP_LIST_OWNER
See Also:
Constant Field Values

SHIP_LIST_OWNER_ITEM

public static final java.lang.String SHIP_LIST_OWNER_ITEM
See Also:
Constant Field Values

CATEGORY_INDEX

public static final java.lang.String CATEGORY_INDEX
See Also:
Constant Field Values

TOOL

public static final java.lang.String TOOL
See Also:
Constant Field Values

TRACKING

public static final java.lang.String TRACKING
See Also:
Constant Field Values

TEMPORARYEMPLOYEE

public static final java.lang.String TEMPORARYEMPLOYEE
See Also:
Constant Field Values

TERM

public static final java.lang.String TERM
See Also:
Constant Field Values

REFERENCE_DOC

public static final java.lang.String REFERENCE_DOC
See Also:
Constant Field Values

PART

public static final java.lang.String PART
See Also:
Constant Field Values

PART_IN_QA

public static final java.lang.String PART_IN_QA
See Also:
Constant Field Values

PART_ISSUE

public static final java.lang.String PART_ISSUE
See Also:
Constant Field Values

PART_CERTIFICATE

public static final java.lang.String PART_CERTIFICATE
See Also:
Constant Field Values

PART_DESCRIPTION

public static final java.lang.String PART_DESCRIPTION
See Also:
Constant Field Values

PART_INVENTORY

public static final java.lang.String PART_INVENTORY
See Also:
Constant Field Values

PART_MANUFACTURER

public static final java.lang.String PART_MANUFACTURER
See Also:
Constant Field Values

PART_PICTURE

public static final java.lang.String PART_PICTURE
See Also:
Constant Field Values

PART_ONHAND

public static final java.lang.String PART_ONHAND
See Also:
Constant Field Values

PART_VENDOR

public static final java.lang.String PART_VENDOR
See Also:
Constant Field Values

PART_TRACEABLE

public static final java.lang.String PART_TRACEABLE
See Also:
Constant Field Values

PART_TYPE

public static final java.lang.String PART_TYPE
See Also:
Constant Field Values

PART_MATERIAL

public static final java.lang.String PART_MATERIAL
See Also:
Constant Field Values

PART_SECURITY_LEVEL

public static final java.lang.String PART_SECURITY_LEVEL
See Also:
Constant Field Values

PHYSICAL_WORK_SHEET

public static final java.lang.String PHYSICAL_WORK_SHEET
See Also:
Constant Field Values

WIP_PHYSICAL_WORK_SHEET

public static final java.lang.String WIP_PHYSICAL_WORK_SHEET
See Also:
Constant Field Values

PHYSICAL_WORK_SHEET_PAGE_NUMBER

public static final java.lang.String PHYSICAL_WORK_SHEET_PAGE_NUMBER
See Also:
Constant Field Values

PREVENTIVE_ACTION_REQUEST

public static final java.lang.String PREVENTIVE_ACTION_REQUEST
See Also:
Constant Field Values

PREVENTIVE_ACTION_REQUEST_ITEM

public static final java.lang.String PREVENTIVE_ACTION_REQUEST_ITEM
See Also:
Constant Field Values

PURCHASE_ORDER

public static final java.lang.String PURCHASE_ORDER
See Also:
Constant Field Values

PURCHASE_ORDER_MESSAGE

public static final java.lang.String PURCHASE_ORDER_MESSAGE
See Also:
Constant Field Values

PURCHASE_ORDER_APPROVAL

public static final java.lang.String PURCHASE_ORDER_APPROVAL
See Also:
Constant Field Values

PURCHASE_ORDER_ITEM

public static final java.lang.String PURCHASE_ORDER_ITEM
See Also:
Constant Field Values

PURCHASE_ORDER_ITEM_MANUFACTURER

public static final java.lang.String PURCHASE_ORDER_ITEM_MANUFACTURER
See Also:
Constant Field Values

PURCHASE_WORK_SHEET

public static final java.lang.String PURCHASE_WORK_SHEET
See Also:
Constant Field Values

PURCHASE_WORK_SHEET_ITEM

public static final java.lang.String PURCHASE_WORK_SHEET_ITEM
See Also:
Constant Field Values

QUOTE

public static final java.lang.String QUOTE
See Also:
Constant Field Values

QUOTE_ITEM

public static final java.lang.String QUOTE_ITEM
See Also:
Constant Field Values

QUOTE_ITEM_MFG

public static final java.lang.String QUOTE_ITEM_MFG
See Also:
Constant Field Values

RECEIVER

public static final java.lang.String RECEIVER
See Also:
Constant Field Values

RECEIVER_WORK_ORDER

public static final java.lang.String RECEIVER_WORK_ORDER
See Also:
Constant Field Values

RECEIVER_ITEM

public static final java.lang.String RECEIVER_ITEM
See Also:
Constant Field Values

RECEIVER_ITEM_AGENT

public static final java.lang.String RECEIVER_ITEM_AGENT
See Also:
Constant Field Values

REQUEST_FOR_CHANGE

public static final java.lang.String REQUEST_FOR_CHANGE
See Also:
Constant Field Values

REQUEST_FOR_QUOTE

public static final java.lang.String REQUEST_FOR_QUOTE
See Also:
Constant Field Values

REQUEST_FOR_QUOTE_ITEM

public static final java.lang.String REQUEST_FOR_QUOTE_ITEM
See Also:
Constant Field Values

REQUEST_FOR_QUOTE_ITEM_MANUFACTURER

public static final java.lang.String REQUEST_FOR_QUOTE_ITEM_MANUFACTURER
See Also:
Constant Field Values

RFQ_MESSAGE

public static final java.lang.String RFQ_MESSAGE
See Also:
Constant Field Values

RFQ_MESSAGE_ITEM

public static final java.lang.String RFQ_MESSAGE_ITEM
See Also:
Constant Field Values

RETURN_TO_VENDOR

public static final java.lang.String RETURN_TO_VENDOR
See Also:
Constant Field Values

RETURN_TO_VENDOR_ITEM

public static final java.lang.String RETURN_TO_VENDOR_ITEM
See Also:
Constant Field Values

RETURN_TO_VENDOR_ITEM_MANUFACTURER

public static final java.lang.String RETURN_TO_VENDOR_ITEM_MANUFACTURER
See Also:
Constant Field Values

RETURN_MATERIAL_AUTHORIZATION_ITEM_MANUFACTURER

public static final java.lang.String RETURN_MATERIAL_AUTHORIZATION_ITEM_MANUFACTURER
See Also:
Constant Field Values

RTV_SHIPPER

public static final java.lang.String RTV_SHIPPER
See Also:
Constant Field Values

RTV_APPROVAL

public static final java.lang.String RTV_APPROVAL
See Also:
Constant Field Values

RMA

public static final java.lang.String RMA
See Also:
Constant Field Values

RMA_ITEM

public static final java.lang.String RMA_ITEM
See Also:
Constant Field Values

RRMA

public static final java.lang.String RRMA
See Also:
Constant Field Values

RRMA_ITEM

public static final java.lang.String RRMA_ITEM
See Also:
Constant Field Values

LN_SHIPPER

public static final java.lang.String LN_SHIPPER
See Also:
Constant Field Values

LN_SHIPPER_ITEM

public static final java.lang.String LN_SHIPPER_ITEM
See Also:
Constant Field Values

RMA_RECEIVER

public static final java.lang.String RMA_RECEIVER
See Also:
Constant Field Values

RMA_RECEIVER_ITEM

public static final java.lang.String RMA_RECEIVER_ITEM
See Also:
Constant Field Values

LN_RECEIVER

public static final java.lang.String LN_RECEIVER
See Also:
Constant Field Values

RMA_REVIEW

public static final java.lang.String RMA_REVIEW
See Also:
Constant Field Values

SERIAL_NUMBER

public static final java.lang.String SERIAL_NUMBER
See Also:
Constant Field Values

CG_QUOTE_ADDRESS

public static final java.lang.String CG_QUOTE_ADDRESS
See Also:
Constant Field Values

CG_CUST_RFQ

public static final java.lang.String CG_CUST_RFQ
See Also:
Constant Field Values

CG_CUSTOMER_SERVICE_REQUEST

public static final java.lang.String CG_CUSTOMER_SERVICE_REQUEST
See Also:
Constant Field Values

CG_CLIENT_PROGRAM_USER

public static final java.lang.String CG_CLIENT_PROGRAM_USER
See Also:
Constant Field Values

CG_PART

public static final java.lang.String CG_PART
See Also:
Constant Field Values

TIME_CARDS

public static final java.lang.String TIME_CARDS
See Also:
Constant Field Values

TOOL_ONHAND

public static final java.lang.String TOOL_ONHAND
See Also:
Constant Field Values

MANUFACTURER

public static final java.lang.String MANUFACTURER
See Also:
Constant Field Values

EQUIPMENT

public static final java.lang.String EQUIPMENT
See Also:
Constant Field Values

MAINTENANCE_ITEM

public static final java.lang.String MAINTENANCE_ITEM
See Also:
Constant Field Values

NON_CONFORMANCE_CODE

public static final java.lang.String NON_CONFORMANCE_CODE
See Also:
Constant Field Values

VENDOR

public static final java.lang.String VENDOR
See Also:
Constant Field Values

VENDOR_GROUP_USER

public static final java.lang.String VENDOR_GROUP_USER
See Also:
Constant Field Values

VENDOR_PART

public static final java.lang.String VENDOR_PART
See Also:
Constant Field Values

CUSTOMER_PART

public static final java.lang.String CUSTOMER_PART
See Also:
Constant Field Values

VENDOR_CRITICAL_LEVEL

public static final java.lang.String VENDOR_CRITICAL_LEVEL
See Also:
Constant Field Values

WEIGHT_UNIT

public static final java.lang.String WEIGHT_UNIT
See Also:
Constant Field Values

WORK_CENTER

public static final java.lang.String WORK_CENTER
See Also:
Constant Field Values

WORK_CENTER_GROUP

public static final java.lang.String WORK_CENTER_GROUP
See Also:
Constant Field Values

WORK_INSTRUCTION

public static final java.lang.String WORK_INSTRUCTION
See Also:
Constant Field Values

WORK_CALENDAR

public static final java.lang.String WORK_CALENDAR
See Also:
Constant Field Values

WORK_PERIOD

public static final java.lang.String WORK_PERIOD
See Also:
Constant Field Values

WORK_INSTRUCTION_APPROVAL

public static final java.lang.String WORK_INSTRUCTION_APPROVAL
See Also:
Constant Field Values

WORK_ORDER

public static final java.lang.String WORK_ORDER
See Also:
Constant Field Values

WORK_ORDER_APPROVAL

public static final java.lang.String WORK_ORDER_APPROVAL
See Also:
Constant Field Values

WORK_ORDER_ITEM

public static final java.lang.String WORK_ORDER_ITEM
See Also:
Constant Field Values

WORK_ORDER_ITEM_ISSUE

public static final java.lang.String WORK_ORDER_ITEM_ISSUE
See Also:
Constant Field Values

DISASSEMBLE_WORK_ORDER_ITEM_ISSUE

public static final java.lang.String DISASSEMBLE_WORK_ORDER_ITEM_ISSUE
See Also:
Constant Field Values

WORK_ORDER_ITEM_PART_DETAIL

public static final java.lang.String WORK_ORDER_ITEM_PART_DETAIL
See Also:
Constant Field Values

WORK_ORDER_ITEM_TIME_DETAIL

public static final java.lang.String WORK_ORDER_ITEM_TIME_DETAIL
See Also:
Constant Field Values

WORK_WORK_SHEET

public static final java.lang.String WORK_WORK_SHEET
See Also:
Constant Field Values

WORK_WORK_SHEET_ITEM

public static final java.lang.String WORK_WORK_SHEET_ITEM
See Also:
Constant Field Values

WORK_ORDER_WORK_INSTRUCTION

public static final java.lang.String WORK_ORDER_WORK_INSTRUCTION
See Also:
Constant Field Values

WORK_ORDER_WORK_INSTRUCTION_SEQ

public static final java.lang.String WORK_ORDER_WORK_INSTRUCTION_SEQ
See Also:
Constant Field Values

USER_TRUE_NAME

public static final java.lang.String USER_TRUE_NAME
See Also:
Constant Field Values

USER_ZIPCODE_TAX

public static final java.lang.String USER_ZIPCODE_TAX
See Also:
Constant Field Values

TOO_MUCH_DATA_TO_SEARCH

public static final java.lang.String TOO_MUCH_DATA_TO_SEARCH
See Also:
Constant Field Values

VENDOR_CONTRACE_PRICE

public static final java.lang.String VENDOR_CONTRACE_PRICE
See Also:
Constant Field Values

VENDOR_CONTRACE_PRICE_ITEM

public static final java.lang.String VENDOR_CONTRACE_PRICE_ITEM
See Also:
Constant Field Values

VENDOR_CONTRACE_PRICE_VENDOR

public static final java.lang.String VENDOR_CONTRACE_PRICE_VENDOR
See Also:
Constant Field Values

PART_SHARE_COMPANY

public static final java.lang.String PART_SHARE_COMPANY
See Also:
Constant Field Values

ENG_GROUP

public static final java.lang.String ENG_GROUP
See Also:
Constant Field Values

USER_GROUP

public static final java.lang.String USER_GROUP
See Also:
Constant Field Values

GROUP_USER

public static final java.lang.String GROUP_USER
See Also:
Constant Field Values

ROLL_UP_BOM_STD_COST_WORKSHEET

public static final java.lang.String ROLL_UP_BOM_STD_COST_WORKSHEET
See Also:
Constant Field Values

CHANGE_STD_COST_WORKSHEET

public static final java.lang.String CHANGE_STD_COST_WORKSHEET
See Also:
Constant Field Values

INSPECTION_REPORT

public static final java.lang.String INSPECTION_REPORT
See Also:
Constant Field Values

OPERATING_INSTRUCTION

public static final java.lang.String OPERATING_INSTRUCTION
See Also:
Constant Field Values

OPERATING_INSTRUCTION_TYPE

public static final java.lang.String OPERATING_INSTRUCTION_TYPE
See Also:
Constant Field Values

BOM_APPROVAL

public static final java.lang.String BOM_APPROVAL
See Also:
Constant Field Values

ENG_GROUP_USER

public static final java.lang.String ENG_GROUP_USER
See Also:
Constant Field Values

TASK

public static final java.lang.String TASK
See Also:
Constant Field Values

SR_NUMBER

public static final java.lang.String SR_NUMBER
See Also:
Constant Field Values

JOB_CATEGORY

public static final java.lang.String JOB_CATEGORY
See Also:
Constant Field Values

PO_NNMBER

public static final java.lang.String PO_NNMBER
See Also:
Constant Field Values

MULTI_LANGUAGE_DESCRIPTION

public static final java.lang.String MULTI_LANGUAGE_DESCRIPTION
See Also:
Constant Field Values

PA_VARIANCE_ACCOUNT

public static final java.lang.String PA_VARIANCE_ACCOUNT
See Also:
Constant Field Values

PA_ACCOUNT

public static final java.lang.String PA_ACCOUNT
See Also:
Constant Field Values

POS_SETTING

public static final java.lang.String POS_SETTING
See Also:
Constant Field Values

PART_UOM

public static final java.lang.String PART_UOM
See Also:
Constant Field Values

PROJECT_CLASS

public static final java.lang.String PROJECT_CLASS
See Also:
Constant Field Values

RUNNING_ACCOUNT_ORDER

public static final java.lang.String RUNNING_ACCOUNT_ORDER
See Also:
Constant Field Values

Exchange_Gain_And_Loss_Account

public static final java.lang.String Exchange_Gain_And_Loss_Account
See Also:
Constant Field Values

TRANSFER_ORDER

public static final java.lang.String TRANSFER_ORDER
See Also:
Constant Field Values

TRANSFER_ORDER_APPROVAL

public static final java.lang.String TRANSFER_ORDER_APPROVAL
See Also:
Constant Field Values

TRANSFER_ORDER_ITEM

public static final java.lang.String TRANSFER_ORDER_ITEM
See Also:
Constant Field Values

TRANSFER_SHIPPER

public static final java.lang.String TRANSFER_SHIPPER
See Also:
Constant Field Values

TRANSFER_RECIEVER

public static final java.lang.String TRANSFER_RECIEVER
See Also:
Constant Field Values

TRANSFER_SHIPPER_ITEM

public static final java.lang.String TRANSFER_SHIPPER_ITEM
See Also:
Constant Field Values

TRANSFER_RECIEVER_ITEM

public static final java.lang.String TRANSFER_RECIEVER_ITEM
See Also:
Constant Field Values

RMA_DOC

public static final java.lang.String RMA_DOC
See Also:
Constant Field Values

INSPECTION_TYPE

public static final java.lang.String INSPECTION_TYPE
See Also:
Constant Field Values

PART_INSPECTION

public static final java.lang.String PART_INSPECTION
See Also:
Constant Field Values

SWAP_ORDER

public static final java.lang.String SWAP_ORDER
See Also:
Constant Field Values

SWAP_ORDER_APPROVAL

public static final java.lang.String SWAP_ORDER_APPROVAL
See Also:
Constant Field Values

SWAP_SHIPPER

public static final java.lang.String SWAP_SHIPPER
See Also:
Constant Field Values

SWAP_ORDER_ITEM

public static final java.lang.String SWAP_ORDER_ITEM
See Also:
Constant Field Values

SWAP_SHIPPER_ITEM

public static final java.lang.String SWAP_SHIPPER_ITEM
See Also:
Constant Field Values

SWAP_RECEIVER

public static final java.lang.String SWAP_RECEIVER
See Also:
Constant Field Values

SWAP_RECEIVER_ITEM

public static final java.lang.String SWAP_RECEIVER_ITEM
See Also:
Constant Field Values

NCR_APPROVAL

public static final java.lang.String NCR_APPROVAL
See Also:
Constant Field Values

APP

public static final java.lang.String APP
See Also:
Constant Field Values

UNBILLED

public static final java.lang.String UNBILLED
See Also:
Constant Field Values

PRINT_TEMPLATE

public static final java.lang.String PRINT_TEMPLATE
See Also:
Constant Field Values

WAREHOUSE

public static final java.lang.String WAREHOUSE
See Also:
Constant Field Values

ORDER

public static final java.lang.String ORDER
See Also:
Constant Field Values

NONPRODUCTIVE_PICKING_TYPE

public static final java.lang.String NONPRODUCTIVE_PICKING_TYPE
See Also:
Constant Field Values

DISASSEMBLE_WORK_ORDER

public static final java.lang.String DISASSEMBLE_WORK_ORDER
See Also:
Constant Field Values

NONPRODUCTIVE_PICKING_APPROVAL

public static final java.lang.String NONPRODUCTIVE_PICKING_APPROVAL
See Also:
Constant Field Values

DISASSEMBLE_WORK_ORDER_APPROVAL

public static final java.lang.String DISASSEMBLE_WORK_ORDER_APPROVAL
See Also:
Constant Field Values

DISASSEMBLE_WORK_ORDER_ITEM

public static final java.lang.String DISASSEMBLE_WORK_ORDER_ITEM
See Also:
Constant Field Values

DISASSEMBLE_WORK_ORDER_ITEM_RECEIVER

public static final java.lang.String DISASSEMBLE_WORK_ORDER_ITEM_RECEIVER
See Also:
Constant Field Values

DEPARTMENT_LOCATION_FOR_BACKFLUSH

public static final java.lang.String DEPARTMENT_LOCATION_FOR_BACKFLUSH
See Also:
Constant Field Values

BACKFLUSH_MATERIAL

public static final java.lang.String BACKFLUSH_MATERIAL
See Also:
Constant Field Values

NONPRODUCTIVE_PICKING

public static final java.lang.String NONPRODUCTIVE_PICKING
See Also:
Constant Field Values

NONPRODUCTIVE_PICKING_ITEM_ISSUE

public static final java.lang.String NONPRODUCTIVE_PICKING_ITEM_ISSUE
See Also:
Constant Field Values

EXCHANAGE_RATE

public static final java.lang.String EXCHANAGE_RATE
See Also:
Constant Field Values

BANK_RECONCILIATION_REPORT

public static final java.lang.String BANK_RECONCILIATION_REPORT
See Also:
Constant Field Values
Constructor Detail

BizTarget

public BizTarget()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BomApprovalVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BomApprovalVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.BomApprovalVO
All Implemented Interfaces:
java.io.Serializable
public class BomApprovalVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CANAPPROVEOWNBOM
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_EMPLOYEEID
static java.lang.String | ORDER_BY_USERNAME
Constructor Summary
BomApprovalVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.lang.String | getEmployeeId()
java.lang.String | getUserName()
int | hashCode()
boolean | isCanApproveOwnBom()
void | setCanApproveOwnBom(boolean canApproveOwnBom)
void | setComments(java.lang.String comments)
void | setEmployeeId(java.lang.String employeeId)
void | setUserName(java.lang.String userName)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_EMPLOYEEID

public static final java.lang.String ORDER_BY_EMPLOYEEID
See Also:
Constant Field Values

ORDER_BY_USERNAME

public static final java.lang.String ORDER_BY_USERNAME
See Also:
Constant Field Values

ORDER_BY_CANAPPROVEOWNBOM

public static final java.lang.String ORDER_BY_CANAPPROVEOWNBOM
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values
Constructor Detail

BomApprovalVO

public BomApprovalVO()
Method Detail

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

isCanApproveOwnBom

public boolean isCanApproveOwnBom()

setCanApproveOwnBom

public void setCanApproveOwnBom(boolean canApproveOwnBom)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BOMCanAssyAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BOMCanAssyAgent

java.lang.Object
    extended by  bb.common.BOMCanAssyAgent
All Implemented Interfaces:
java.io.Serializable
public class BOMCanAssyAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BOMCanAssyAgent()
Method Summary
java.lang.String | getBillNumber()
java.util.List<java.lang.String> | getPartNums()
java.util.Date | getUsedDate()
boolean | isListBOM()
boolean | isListSO()
boolean | isListWO()
boolean | isRootBOM()
void | setBillNumber(java.lang.String billNumber)
void | setListBOM(boolean listBOM)
void | setListSO(boolean listSO)
void | setListWO(boolean listWO)
void | setPartNums(java.util.List<java.lang.String> partNums)
void | setRootBOM(boolean rootBOM)
void | setUsedDate(java.util.Date usedDate)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BOMCanAssyAgent

public BOMCanAssyAgent()
Method Detail

isListBOM

public boolean isListBOM()

setListBOM

public void setListBOM(boolean listBOM)

isListSO

public boolean isListSO()

setListSO

public void setListSO(boolean listSO)

isListWO

public boolean isListWO()

setListWO

public void setListWO(boolean listWO)

getPartNums

public java.util.List<java.lang.String> getPartNums()

setPartNums

public void setPartNums(java.util.List<java.lang.String> partNums)

isRootBOM

public boolean isRootBOM()

setRootBOM

public void setRootBOM(boolean rootBOM)

getUsedDate

public java.util.Date getUsedDate()

setUsedDate

public void setUsedDate(java.util.Date usedDate)

getBillNumber

public java.lang.String getBillNumber()

setBillNumber

public void setBillNumber(java.lang.String billNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BOMCanAssyListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BOMCanAssyListResult

java.lang.Object
    extended by  bb.common.BOMCanAssyListResult
All Implemented Interfaces:
java.io.Serializable
public class BOMCanAssyListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BOMCanAssyListResult()
Method Summary
java.lang.String | getDescription()
java.math.BigDecimal | getOndemand()
java.math.BigDecimal | getOnhand()
java.math.BigDecimal | getOnOrder()
PartPK | getPk()
java.math.BigDecimal | getQty()
void | setDescription(java.lang.String description)
void | setOndemand(java.math.BigDecimal ondemand)
void | setOnhand(java.math.BigDecimal onhand)
void | setOnOrder(java.math.BigDecimal onOrder)
void | setPk(PartPK pk)
void | setQty(java.math.BigDecimal qty)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BOMCanAssyListResult

public BOMCanAssyListResult()
Method Detail

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getOndemand

public java.math.BigDecimal getOndemand()

setOndemand

public void setOndemand(java.math.BigDecimal ondemand)

getOnhand

public java.math.BigDecimal getOnhand()

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

getOnOrder

public java.math.BigDecimal getOnOrder()

setOnOrder

public void setOnOrder(java.math.BigDecimal onOrder)

getPk

public PartPK getPk()

setPk

public void setPk(PartPK pk)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BomItemWithOEMResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BomItemWithOEMResult

java.lang.Object
    extended by  bb.common.BomItemWithOEMResult
All Implemented Interfaces:
java.io.Serializable
public class BomItemWithOEMResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BomItemWithOEMResult()
Method Summary
BillItemPK | getBillItemPk()
java.lang.String | getBom()
java.lang.String | getDescription()
java.lang.String | getDwg()
java.math.BigDecimal | getListPrice()
java.lang.String | getMfgID()
java.lang.String | getMpn()
PartPK | getPartPk()
java.math.BigDecimal | getQty()
java.lang.String | getRev()
java.lang.String | getTraceable()
java.lang.String | getUnit()
java.lang.String | getWi()
void | setBillItemPk(BillItemPK billItemPk)
void | setBom(java.lang.String bom)
void | setDescription(java.lang.String description)
void | setDwg(java.lang.String dwg)
void | setListPrice(java.math.BigDecimal listPrice)
void | setMfgID(java.lang.String mfgID)
void | setMpn(java.lang.String mpn)
void | setPartPk(PartPK partPk)
void | setQty(java.math.BigDecimal qty)
void | setRev(java.lang.String rev)
void | setTraceable(java.lang.String traceable)
void | setUnit(java.lang.String unit)
void | setWi(java.lang.String wi)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BomItemWithOEMResult

public BomItemWithOEMResult()
Method Detail

setBillItemPk

public void setBillItemPk(BillItemPK billItemPk)

setQty

public void setQty(java.math.BigDecimal qty)

setPartPk

public void setPartPk(PartPK partPk)

setMpn

public void setMpn(java.lang.String mpn)

setRev

public void setRev(java.lang.String rev)

setDwg

public void setDwg(java.lang.String dwg)

setBom

public void setBom(java.lang.String bom)

setWi

public void setWi(java.lang.String wi)

setUnit

public void setUnit(java.lang.String unit)

setTraceable

public void setTraceable(java.lang.String traceable)

setDescription

public void setDescription(java.lang.String description)

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

getBillItemPk

public BillItemPK getBillItemPk()

getQty

public java.math.BigDecimal getQty()

getPartPk

public PartPK getPartPk()

getMpn

public java.lang.String getMpn()

getRev

public java.lang.String getRev()

getDwg

public java.lang.String getDwg()

getBom

public java.lang.String getBom()

getWi

public java.lang.String getWi()

getUnit

public java.lang.String getUnit()

getTraceable

public java.lang.String getTraceable()

getDescription

public java.lang.String getDescription()

getListPrice

public java.math.BigDecimal getListPrice()

getMfgID

public java.lang.String getMfgID()

setMfgID

public void setMfgID(java.lang.String mfgID)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BomPickListItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BomPickListItemResult

java.lang.Object
    extended by  bb.common.BomPickListItemResult
All Implemented Interfaces:
java.io.Serializable
public class BomPickListItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BomPickListItemResult()
Method Summary
BillItemPK | getBillItemPk()
java.lang.String | getBom()
java.lang.String | getDescription()
java.lang.String | getDwg()
java.lang.String | getLocation()
java.math.BigDecimal | getOnhand()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.lang.String | getPartUnit()
java.math.BigDecimal | getQtyPicked()
java.math.BigDecimal | getQtyRequested()
java.lang.String | getRevision()
void | setBillItemPk(BillItemPK billItemPk)
void | setBom(java.lang.String bom)
void | setDescription(java.lang.String description)
void | setDwg(java.lang.String dwg)
void | setLocation(java.lang.String location)
void | setOnhand(java.math.BigDecimal onhand)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setPartUnit(java.lang.String partUnit)
void | setQtyPicked(java.math.BigDecimal qtyPicked)
void | setQtyRequested(java.math.BigDecimal qtyRequested)
void | setRevision(java.lang.String revision)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BomPickListItemResult

public BomPickListItemResult()
Method Detail

setBillItemPk

public void setBillItemPk(BillItemPK billItemPk)

setPartPk

public void setPartPk(PartPK partPk)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setRevision

public void setRevision(java.lang.String revision)

setDwg

public void setDwg(java.lang.String dwg)

setBom

public void setBom(java.lang.String bom)

setDescription

public void setDescription(java.lang.String description)

setLocation

public void setLocation(java.lang.String location)

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

setQtyRequested

public void setQtyRequested(java.math.BigDecimal qtyRequested)

setQtyPicked

public void setQtyPicked(java.math.BigDecimal qtyPicked)

getBillItemPk

public BillItemPK getBillItemPk()

getPartPk

public PartPK getPartPk()

getPartFrom

public java.lang.String getPartFrom()

getRevision

public java.lang.String getRevision()

getDwg

public java.lang.String getDwg()

getBom

public java.lang.String getBom()

getDescription

public java.lang.String getDescription()

getLocation

public java.lang.String getLocation()

getOnhand

public java.math.BigDecimal getOnhand()

getQtyRequested

public java.math.BigDecimal getQtyRequested()

getQtyPicked

public java.math.BigDecimal getQtyPicked()

getPartUnit

public java.lang.String getPartUnit()

setPartUnit

public void setPartUnit(java.lang.String partUnit)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BomPickListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BomPickListResult

java.lang.Object
    extended by  bb.common.BomPickListResult
All Implemented Interfaces:
java.io.Serializable
public class BomPickListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BomPickListResult()
Method Summary
BillPK | getBillPk()
java.lang.String | getDescription()
java.util.Set | getItems()
java.lang.String | getPartFrom()
java.math.BigDecimal | getQuantity()
void | setBillPk(BillPK billPk)
void | setDescription(java.lang.String description)
void | setItems(java.util.Set items)
void | setPartFrom(java.lang.String partFrom)
void | setQuantity(java.math.BigDecimal quantity)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BomPickListResult

public BomPickListResult()
Method Detail

getBillPk

public BillPK getBillPk()

getPartFrom

public java.lang.String getPartFrom()

getDescription

public java.lang.String getDescription()

getQuantity

public java.math.BigDecimal getQuantity()

getItems

public java.util.Set getItems()

setBillPk

public void setBillPk(BillPK billPk)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setDescription

public void setDescription(java.lang.String description)

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

setItems

public void setItems(java.util.Set items)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BOMTreeRollUPMap

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BOMTreeRollUPMap

java.lang.Object
    extended by  bb.common.BOMTreeRollUPMap
All Implemented Interfaces:
java.io.Serializable
public class BOMTreeRollUPMap
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BOMTreeRollUPMap()
Method Summary
void | addRollUPCost(PartPK pk, java.math.BigDecimal value)
void | addStdCost(PartPK pk, java.math.BigDecimal value)
void | addStdRollUPCost(PartPK pk, java.math.BigDecimal val, java.math.BigDecimal val2)
boolean | contain(PartPK pk)
java.util.Iterator<PartPK> | getPartPKs()
java.math.BigDecimal | getRollUPCost(PartPK pk)
java.math.BigDecimal | getStdCost(PartPK pk)
boolean | isEmpty()
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BOMTreeRollUPMap

public BOMTreeRollUPMap()
Method Detail

getStdCost

public java.math.BigDecimal getStdCost(PartPK pk)

getRollUPCost

public java.math.BigDecimal getRollUPCost(PartPK pk)

addStdRollUPCost

public void addStdRollUPCost(PartPK pk,
                             java.math.BigDecimal val,
                             java.math.BigDecimal val2)

addStdCost

public void addStdCost(PartPK pk,
                       java.math.BigDecimal value)

addRollUPCost

public void addRollUPCost(PartPK pk,
                          java.math.BigDecimal value)

getPartPKs

public java.util.Iterator<PartPK> getPartPKs()

isEmpty

public boolean isEmpty()

contain

public boolean contain(PartPK pk)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BomWithOEMResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BomWithOEMResult

java.lang.Object
    extended by  bb.common.BomWithOEMResult
All Implemented Interfaces:
java.io.Serializable
public class BomWithOEMResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BomWithOEMResult()
Method Summary
BillPK | getBillPk()
java.lang.String | getDescription()
java.lang.String | getDwg()
java.util.Set | getItems()
java.math.BigDecimal | getListPrice()
java.lang.String | getMfgID()
java.lang.String | getMpn()
java.lang.String | getRev()
java.lang.String | getUnit()
void | setBillPk(BillPK billPk)
void | setDescription(java.lang.String description)
void | setDwg(java.lang.String dwg)
void | setItems(java.util.Set items)
void | setListPrice(java.math.BigDecimal listPrice)
void | setMfgID(java.lang.String mfgID)
void | setMpn(java.lang.String mpn)
void | setRev(java.lang.String rev)
void | setUnit(java.lang.String unit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BomWithOEMResult

public BomWithOEMResult()
Method Detail

setBillPk

public void setBillPk(BillPK billPk)

setMfgID

public void setMfgID(java.lang.String mfgID)

setMpn

public void setMpn(java.lang.String mpn)

setRev

public void setRev(java.lang.String rev)

setDwg

public void setDwg(java.lang.String dwg)

setUnit

public void setUnit(java.lang.String unit)

setDescription

public void setDescription(java.lang.String description)

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

setItems

public void setItems(java.util.Set items)

getBillPk

public BillPK getBillPk()

getMfgID

public java.lang.String getMfgID()

getMpn

public java.lang.String getMpn()

getRev

public java.lang.String getRev()

getDwg

public java.lang.String getDwg()

getUnit

public java.lang.String getUnit()

getDescription

public java.lang.String getDescription()

getListPrice

public java.math.BigDecimal getListPrice()

getItems

public java.util.Set getItems()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BudgetListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BudgetListResult

java.lang.Object
    extended by  bb.common.BudgetListResult
All Implemented Interfaces:
java.io.Serializable
public class BudgetListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
BudgetListResult()
Method Summary
java.lang.String | getAccountNumber()
java.lang.String | getAccountType()
java.util.Map | getActual()
java.math.BigDecimal | getActualTotal()
java.util.HashMap<java.lang.String,java.util.Map> | getActualTotleMap()
java.util.Map | getActualYTD()
java.util.Map | getBudget()
java.math.BigDecimal | getBudgetTotal()
java.util.Map | getBudgetYTD()
java.lang.String | getCheckedItem()
java.lang.String | getDescription()
byte | getItems()
java.lang.String | getLevel()
java.math.BigDecimal | getTotal()
java.lang.String | getUpLevelAccount()
java.util.Map | getVarianceAMT()
java.math.BigDecimal | getVarianceAMTTotal()
java.util.Map | getVarianceAMTYTD()
java.util.Map | getVariancePercentage()
java.math.BigDecimal | getVariancePercentageTotal()
java.util.Map | getVariancePercentageYTD()
boolean | isActive()
boolean | isChecked()
void | setAccountNumber(java.lang.String accountNumber)
void | setAccountType(java.lang.String accountType)
void | setActive(boolean active)
void | setActual(java.util.Map actual)
void | setActualTotal(java.math.BigDecimal actualTotal)
void | setActualTotleMap(java.util.HashMap<java.lang.String,java.util.Map> actualTotleMap)
void | setActualYTD(java.util.Map actualYTD)
void | setBudget(java.util.Map budget)
void | setBudgetTotal(java.math.BigDecimal budgetTotal)
void | setBudgetYTD(java.util.Map budgetYTD)
void | setChecked(boolean checked)
void | setCheckedItem(java.lang.String checkedItem)
void | setDescription(java.lang.String description)
void | setItems(byte items)
void | setLevel(java.lang.String level)
void | setTotal(java.math.BigDecimal total)
void | setUpLevelAccount(java.lang.String upLevelAccount)
void | setVarianceAMT(java.util.Map varianceAMT)
void | setVarianceAMTTotal(java.math.BigDecimal varianceAMTTotal)
void | setVarianceAMTYTD(java.util.Map varianceAMTYTD)
void | setVariancePercentage(java.util.Map variancePercentage)
void | setVariancePercentageTotal(java.math.BigDecimal variancePercentageTotal)
void | setVariancePercentageYTD(java.util.Map variancePercentageYTD)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BudgetListResult

public BudgetListResult()
Method Detail

getActual

public java.util.Map getActual()

setActual

public void setActual(java.util.Map actual)

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

setAccountType

public void setAccountType(java.lang.String accountType)

setLevel

public void setLevel(java.lang.String level)

setUpLevelAccount

public void setUpLevelAccount(java.lang.String upLevelAccount)

setItems

public void setItems(byte items)

setDescription

public void setDescription(java.lang.String description)

setBudget

public void setBudget(java.util.Map budget)

setCheckedItem

public void setCheckedItem(java.lang.String checkedItem)

getAccountNumber

public java.lang.String getAccountNumber()

getAccountType

public java.lang.String getAccountType()

getLevel

public java.lang.String getLevel()

getUpLevelAccount

public java.lang.String getUpLevelAccount()

getItems

public byte getItems()

getDescription

public java.lang.String getDescription()

getBudget

public java.util.Map getBudget()

getCheckedItem

public java.lang.String getCheckedItem()

getTotal

public java.math.BigDecimal getTotal()

setTotal

public void setTotal(java.math.BigDecimal total)

isChecked

public boolean isChecked()

setChecked

public void setChecked(boolean checked)

isActive

public boolean isActive()

setActive

public void setActive(boolean active)

getBudgetTotal

public java.math.BigDecimal getBudgetTotal()

setBudgetTotal

public void setBudgetTotal(java.math.BigDecimal budgetTotal)

getActualTotal

public java.math.BigDecimal getActualTotal()

setActualTotal

public void setActualTotal(java.math.BigDecimal actualTotal)

getVarianceAMTTotal

public java.math.BigDecimal getVarianceAMTTotal()

setVarianceAMTTotal

public void setVarianceAMTTotal(java.math.BigDecimal varianceAMTTotal)

getVariancePercentageTotal

public java.math.BigDecimal getVariancePercentageTotal()

setVariancePercentageTotal

public void setVariancePercentageTotal(java.math.BigDecimal variancePercentageTotal)

getVarianceAMT

public java.util.Map getVarianceAMT()

setVarianceAMT

public void setVarianceAMT(java.util.Map varianceAMT)

getVariancePercentage

public java.util.Map getVariancePercentage()

setVariancePercentage

public void setVariancePercentage(java.util.Map variancePercentage)

getActualYTD

public java.util.Map getActualYTD()

setActualYTD

public void setActualYTD(java.util.Map actualYTD)

getBudgetYTD

public java.util.Map getBudgetYTD()

setBudgetYTD

public void setBudgetYTD(java.util.Map budgetYTD)

getVarianceAMTYTD

public java.util.Map getVarianceAMTYTD()

setVarianceAMTYTD

public void setVarianceAMTYTD(java.util.Map varianceAMTYTD)

getVariancePercentageYTD

public java.util.Map getVariancePercentageYTD()

setVariancePercentageYTD

public void setVariancePercentageYTD(java.util.Map variancePercentageYTD)

getActualTotleMap

public java.util.HashMap<java.lang.String,java.util.Map> getActualTotleMap()

setActualTotleMap

public void setActualTotleMap(java.util.HashMap<java.lang.String,java.util.Map> actualTotleMap)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BuyerCodeVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class BuyerCodeVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.BuyerCodeVO
All Implemented Interfaces:
java.io.Serializable
public class BuyerCodeVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACTIONTYPE
static java.lang.String | ORDER_BY_BUYERCODE
static java.lang.String | ORDER_BY_BUYERNAME
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_DEPARTMENT
static java.lang.String | ORDER_BY_DEPARTMENTID
static java.lang.String | ORDER_BY_DESCRIPTION
Constructor Summary
BuyerCodeVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getActionType()
java.lang.String | getBuyerCode()
java.lang.String | getBuyerName()
java.lang.String | getComments()
java.lang.String | getDepartment()
java.lang.String | getDepartmentId()
java.lang.String | getDescription()
java.lang.Integer | getId()
int | hashCode()
void | setActionType(java.lang.String actionType)
void | setBuyerCode(java.lang.String buyerCode)
void | setBuyerName(java.lang.String buyerName)
void | setComments(java.lang.String comments)
void | setDepartment(java.lang.String department)
void | setDepartmentId(java.lang.String departmentId)
void | setDescription(java.lang.String description)
void | setId(java.lang.Integer id)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_BUYERCODE

public static final java.lang.String ORDER_BY_BUYERCODE
See Also:
Constant Field Values

ORDER_BY_ACTIONTYPE

public static final java.lang.String ORDER_BY_ACTIONTYPE
See Also:
Constant Field Values

ORDER_BY_DEPARTMENTID

public static final java.lang.String ORDER_BY_DEPARTMENTID
See Also:
Constant Field Values

ORDER_BY_DEPARTMENT

public static final java.lang.String ORDER_BY_DEPARTMENT
See Also:
Constant Field Values

ORDER_BY_BUYERNAME

public static final java.lang.String ORDER_BY_BUYERNAME
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values
Constructor Detail

BuyerCodeVO

public BuyerCodeVO()
Method Detail

getId

public java.lang.Integer getId()

setId

public void setId(java.lang.Integer id)

getBuyerCode

public java.lang.String getBuyerCode()

setBuyerCode

public void setBuyerCode(java.lang.String buyerCode)

getActionType

public java.lang.String getActionType()

setActionType

public void setActionType(java.lang.String actionType)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getBuyerName

public java.lang.String getBuyerName()

setBuyerName

public void setBuyerName(java.lang.String buyerName)

getDepartment

public java.lang.String getDepartment()

setDepartment

public void setDepartment(java.lang.String department)

getDepartmentId

public java.lang.String getDepartmentId()

getComments

public java.lang.String getComments()

setDepartmentId

public void setDepartmentId(java.lang.String departmentId)

setComments

public void setComments(java.lang.String comments)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CarrierPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CarrierPK

java.lang.Object
    extended by  bb.common.CarrierPK
All Implemented Interfaces:
java.io.Serializable
public class CarrierPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
CarrierPK()
default constructor
CarrierPK(java.lang.String addressId, java.lang.String seq)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAddressId()
java.lang.String | getSeq()
int | hashCode()
void | setAddressId(java.lang.String addressId)
void | setSeq(java.lang.String seq)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CarrierPK

public CarrierPK(java.lang.String addressId,
                 java.lang.String seq)
full constructor

CarrierPK

public CarrierPK()
default constructor

Method Detail

getAddressId

public java.lang.String getAddressId()

setAddressId

public void setAddressId(java.lang.String addressId)

getSeq

public java.lang.String getSeq()

setSeq

public void setSeq(java.lang.String seq)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CarrierVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CarrierVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CarrierVO
All Implemented Interfaces:
java.io.Serializable
public class CarrierVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CarrierVO()
default constructor
CarrierVO(CarrierPK pk, java.lang.String carrier, java.lang.String carrierAccount, java.lang.String remarks)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCarrier()
java.lang.String | getCarrierAccount()
CarrierPK | getPk()
java.lang.String | getRemarks()
int | hashCode()
void | setCarrier(java.lang.String carrier)
void | setCarrierAccount(java.lang.String carrierAccount)
void | setPk(CarrierPK pk)
void | setRemarks(java.lang.String remarks)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CarrierVO

public CarrierVO(CarrierPK pk,
                 java.lang.String carrier,
                 java.lang.String carrierAccount,
                 java.lang.String remarks)
full constructor

CarrierVO

public CarrierVO()
default constructor

Method Detail

getPk

public CarrierPK getPk()

setPk

public void setPk(CarrierPK pk)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAccount

public java.lang.String getCarrierAccount()

setCarrierAccount

public void setCarrierAccount(java.lang.String carrierAccount)

getRemarks

public java.lang.String getRemarks()

setRemarks

public void setRemarks(java.lang.String remarks)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CashFlowByMonthReportResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CashFlowByMonthReportResult

java.lang.Object
    extended by  bb.common.CashFlowByMonthReportResult
All Implemented Interfaces:
java.io.Serializable
public class CashFlowByMonthReportResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CashFlowByMonthReportResult()
Method Summary
java.util.Map<java.lang.String,java.math.BigDecimal> | getAp()
java.math.BigDecimal | getApPastDue()
java.util.Map<java.lang.String,java.math.BigDecimal> | getApPrepay()
java.math.BigDecimal | getApPrepayPastDue()
java.util.Map<java.lang.String,java.math.BigDecimal> | getAr()
java.math.BigDecimal | getArPastDue()
java.util.Map<java.lang.String,java.math.BigDecimal> | getArPrepay()
java.math.BigDecimal | getArPrepayPastDue()
java.util.Map<java.lang.String,java.math.BigDecimal> | getOpenPo()
java.util.Map<java.lang.String,java.math.BigDecimal> | getOpenSo()
java.math.BigDecimal | getPoPastDue()
java.math.BigDecimal | getSoPastDue()
void | setAp(java.util.Map<java.lang.String,java.math.BigDecimal> ap)
void | setApPastDue(java.math.BigDecimal apPastDue)
void | setApPrepay(java.util.Map<java.lang.String,java.math.BigDecimal> apPrepay)
void | setApPrepayPastDue(java.math.BigDecimal apPrepayPastDue)
void | setAr(java.util.Map<java.lang.String,java.math.BigDecimal> ar)
void | setArPastDue(java.math.BigDecimal arPastDue)
void | setArPrepay(java.util.Map<java.lang.String,java.math.BigDecimal> arPrepay)
void | setArPrepayPastDue(java.math.BigDecimal arPrepayPastDue)
void | setOpenPo(java.util.Map<java.lang.String,java.math.BigDecimal> openPo)
void | setOpenSo(java.util.Map<java.lang.String,java.math.BigDecimal> openSo)
void | setPoPastDue(java.math.BigDecimal poPastDue)
void | setSoPastDue(java.math.BigDecimal soPastDue)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CashFlowByMonthReportResult

public CashFlowByMonthReportResult()
Method Detail

getAp

public java.util.Map<java.lang.String,java.math.BigDecimal> getAp()

setAp

public void setAp(java.util.Map<java.lang.String,java.math.BigDecimal> ap)

getApPrepay

public java.util.Map<java.lang.String,java.math.BigDecimal> getApPrepay()

setApPrepay

public void setApPrepay(java.util.Map<java.lang.String,java.math.BigDecimal> apPrepay)

getAr

public java.util.Map<java.lang.String,java.math.BigDecimal> getAr()

setAr

public void setAr(java.util.Map<java.lang.String,java.math.BigDecimal> ar)

getArPrepay

public java.util.Map<java.lang.String,java.math.BigDecimal> getArPrepay()

setArPrepay

public void setArPrepay(java.util.Map<java.lang.String,java.math.BigDecimal> arPrepay)

getOpenPo

public java.util.Map<java.lang.String,java.math.BigDecimal> getOpenPo()

setOpenPo

public void setOpenPo(java.util.Map<java.lang.String,java.math.BigDecimal> openPo)

getOpenSo

public java.util.Map<java.lang.String,java.math.BigDecimal> getOpenSo()

setOpenSo

public void setOpenSo(java.util.Map<java.lang.String,java.math.BigDecimal> openSo)

getApPastDue

public java.math.BigDecimal getApPastDue()

setApPastDue

public void setApPastDue(java.math.BigDecimal apPastDue)

getApPrepayPastDue

public java.math.BigDecimal getApPrepayPastDue()

setApPrepayPastDue

public void setApPrepayPastDue(java.math.BigDecimal apPrepayPastDue)

getArPastDue

public java.math.BigDecimal getArPastDue()

setArPastDue

public void setArPastDue(java.math.BigDecimal arPastDue)

getArPrepayPastDue

public java.math.BigDecimal getArPrepayPastDue()

setArPrepayPastDue

public void setArPrepayPastDue(java.math.BigDecimal arPrepayPastDue)

getPoPastDue

public java.math.BigDecimal getPoPastDue()

setPoPastDue

public void setPoPastDue(java.math.BigDecimal poPastDue)

getSoPastDue

public java.math.BigDecimal getSoPastDue()

setSoPastDue

public void setSoPastDue(java.math.BigDecimal soPastDue)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CashFlowMonthTotalResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CashFlowMonthTotalResult

java.lang.Object
    extended by  bb.common.CashFlowMonthTotalResult
All Implemented Interfaces:
java.io.Serializable
public class CashFlowMonthTotalResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CashFlowMonthTotalResult()
default constructor
Method Summary
java.math.BigDecimal | getEndMonthBudget()
java.math.BigDecimal | getETotalBudget()
java.lang.String | getMonth()
java.math.BigDecimal | getRTotalBudget()
java.math.BigDecimal | getStartMonthBudget()
void | setEndMonthBudget(java.math.BigDecimal endMonthBudget)
void | setETotalBudget(java.math.BigDecimal totalBudget)
void | setMonth(java.lang.String month)
void | setRTotalBudget(java.math.BigDecimal totalBudget)
void | setStartMonthBudget(java.math.BigDecimal startMonthBudget)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CashFlowMonthTotalResult

public CashFlowMonthTotalResult()
default constructor

Method Detail

getEndMonthBudget

public java.math.BigDecimal getEndMonthBudget()

setEndMonthBudget

public void setEndMonthBudget(java.math.BigDecimal endMonthBudget)

getMonth

public java.lang.String getMonth()

setMonth

public void setMonth(java.lang.String month)

getStartMonthBudget

public java.math.BigDecimal getStartMonthBudget()

setStartMonthBudget

public void setStartMonthBudget(java.math.BigDecimal startMonthBudget)

getETotalBudget

public java.math.BigDecimal getETotalBudget()

setETotalBudget

public void setETotalBudget(java.math.BigDecimal totalBudget)

getRTotalBudget

public java.math.BigDecimal getRTotalBudget()

setRTotalBudget

public void setRTotalBudget(java.math.BigDecimal totalBudget)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CashierVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CashierVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CashierVO
All Implemented Interfaces:
java.io.Serializable
public class CashierVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CashierVO()
Method Summary
java.lang.String | getCashier()
java.lang.String | getFirstName()
java.lang.String | getLastName()
java.lang.String | getMiddleName()
java.lang.String | getPassword()
void | setCashier(java.lang.String cashier)
void | setFirstName(java.lang.String firstName)
void | setLastName(java.lang.String lastName)
void | setMiddleName(java.lang.String middleName)
void | setPassword(java.lang.String password)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CashierVO

public CashierVO()
Method Detail

getCashier

public java.lang.String getCashier()

setCashier

public void setCashier(java.lang.String cashier)

getPassword

public java.lang.String getPassword()

setPassword

public void setPassword(java.lang.String password)

getLastName

public java.lang.String getLastName()

setLastName

public void setLastName(java.lang.String lastName)

getMiddleName

public java.lang.String getMiddleName()

setMiddleName

public void setMiddleName(java.lang.String middleName)

getFirstName

public java.lang.String getFirstName()

setFirstName

public void setFirstName(java.lang.String firstName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CatalogVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CatalogVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CatalogVO
All Implemented Interfaces:
java.io.Serializable
public class CatalogVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CatalogVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCatalogID()
java.lang.String | getDescription()
int | hashCode()
void | setCatalogID(java.lang.String catalogID)
void | setDescription(java.lang.String description)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CatalogVO

public CatalogVO()
Method Detail

getCatalogID

public java.lang.String getCatalogID()

setCatalogID

public void setCatalogID(java.lang.String catalogID)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CertificateDescriptionVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CertificateDescriptionVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CertificateDescriptionVO
All Implemented Interfaces:
java.io.Serializable
public class CertificateDescriptionVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_ID
Constructor Summary
CertificateDescriptionVO()
CertificateDescriptionVO(java.lang.Integer id, java.lang.String description)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDescription()
java.lang.Integer | getId()
int | hashCode()
void | setDescription(java.lang.String description)
void | setId(java.lang.Integer id)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ID

public static final java.lang.String ORDER_BY_ID
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

CertificateDescriptionVO

public CertificateDescriptionVO(java.lang.Integer id,
                                java.lang.String description)
full constructor

CertificateDescriptionVO

public CertificateDescriptionVO()
Method Detail

setId

public void setId(java.lang.Integer id)

getId

public java.lang.Integer getId()

setDescription

public void setDescription(java.lang.String description)

getDescription

public java.lang.String getDescription()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ChangeStdCostWorkSheetItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ChangeStdCostWorkSheetItemPK

java.lang.Object
    extended by  bb.common.ChangeStdCostWorkSheetItemPK
All Implemented Interfaces:
java.io.Serializable
public class ChangeStdCostWorkSheetItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ChangeStdCostWorkSheetItemPK()
ChangeStdCostWorkSheetItemPK(java.lang.Long ii, java.lang.String partNumber, java.lang.String partType)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Long | getIi()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
int | hashCode()
void | setIi(java.lang.Long ii)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ChangeStdCostWorkSheetItemPK

public ChangeStdCostWorkSheetItemPK()

ChangeStdCostWorkSheetItemPK

public ChangeStdCostWorkSheetItemPK(java.lang.Long ii,
                                    java.lang.String partNumber,
                                    java.lang.String partType)
Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ChangeStdCostWorkSheetItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ChangeStdCostWorkSheetItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ChangeStdCostWorkSheetItemVO
All Implemented Interfaces:
java.io.Serializable
public class ChangeStdCostWorkSheetItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AVGCOST
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_MAKEBUY
static java.lang.String | ORDER_BY_NEWSTDCOST
static java.lang.String | ORDER_BY_ONHAND
static java.lang.String | ORDER_BY_PK
static java.lang.String | ORDER_BY_STDCOST
static java.lang.String | ORDER_BY_VARIANCEPERCENT
Constructor Summary
ChangeStdCostWorkSheetItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getAvgCost()
java.lang.String | getDescription()
java.lang.String | getMakeBuy()
java.math.BigDecimal | getNewStdCost()
java.math.BigDecimal | getOnHand()
ChangeStdCostWorkSheetItemPK | getPk()
java.math.BigDecimal | getStdCost()
java.math.BigDecimal | getVariancePercent()
int | hashCode()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setDescription(java.lang.String description)
void | setMakeBuy(java.lang.String makeBuy)
void | setNewStdCost(java.math.BigDecimal newStdCost)
void | setOnHand(java.math.BigDecimal onHand)
void | setPk(ChangeStdCostWorkSheetItemPK pk)
void | setStdCost(java.math.BigDecimal stdCost)
void | setVariancePercent(java.math.BigDecimal variancePercent)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PK

public static final java.lang.String ORDER_BY_PK
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_AVGCOST

public static final java.lang.String ORDER_BY_AVGCOST
See Also:
Constant Field Values

ORDER_BY_STDCOST

public static final java.lang.String ORDER_BY_STDCOST
See Also:
Constant Field Values

ORDER_BY_NEWSTDCOST

public static final java.lang.String ORDER_BY_NEWSTDCOST
See Also:
Constant Field Values

ORDER_BY_VARIANCEPERCENT

public static final java.lang.String ORDER_BY_VARIANCEPERCENT
See Also:
Constant Field Values

ORDER_BY_ONHAND

public static final java.lang.String ORDER_BY_ONHAND
See Also:
Constant Field Values

ORDER_BY_MAKEBUY

public static final java.lang.String ORDER_BY_MAKEBUY
See Also:
Constant Field Values
Constructor Detail

ChangeStdCostWorkSheetItemVO

public ChangeStdCostWorkSheetItemVO()
Method Detail

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getPk

public ChangeStdCostWorkSheetItemPK getPk()

setPk

public void setPk(ChangeStdCostWorkSheetItemPK pk)

getNewStdCost

public java.math.BigDecimal getNewStdCost()

setNewStdCost

public void setNewStdCost(java.math.BigDecimal newStdCost)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getMakeBuy

public java.lang.String getMakeBuy()

setMakeBuy

public void setMakeBuy(java.lang.String makeBuy)

getOnHand

public java.math.BigDecimal getOnHand()

setOnHand

public void setOnHand(java.math.BigDecimal onHand)

getAvgCost

public java.math.BigDecimal getAvgCost()

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

getVariancePercent

public java.math.BigDecimal getVariancePercent()

setVariancePercent

public void setVariancePercent(java.math.BigDecimal variancePercent)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ChangeStdCostWorkSheetVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ChangeStdCostWorkSheetVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ChangeStdCostWorkSheetVO
All Implemented Interfaces:
java.io.Serializable
public class ChangeStdCostWorkSheetVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_COMMITTEDBY
static java.lang.String | ORDER_BY_COMMITTEDDATE
static java.lang.String | ORDER_BY_CREATEDBY
static java.lang.String | ORDER_BY_CREATEDDATE
static java.lang.String | ORDER_BY_II
static java.lang.String | ORDER_BY_ITEMCOUNT
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_TRANSACTIONNUMBER
static java.lang.String | ORDER_BY_VARIANCEAMOUNT
Constructor Summary
ChangeStdCostWorkSheetVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.lang.String | getCommittedBy()
java.util.Date | getCommittedDate()
java.lang.String | getCreatedBy()
java.util.Date | getCreatedDate()
java.lang.Long | getIi()
java.lang.Integer | getItemCount()
java.lang.String | getStatus()
java.lang.String | getTransactionNumber()
java.math.BigDecimal | getVarianceAmount()
int | hashCode()
void | setComments(java.lang.String comments)
void | setCommittedBy(java.lang.String committedBy)
void | setCommittedDate(java.util.Date committedDate)
void | setCreatedBy(java.lang.String createdBy)
void | setCreatedDate(java.util.Date createdDate)
void | setIi(java.lang.Long ii)
void | setItemCount(java.lang.Integer itemCount)
void | setStatus(java.lang.String status)
void | setTransactionNumber(java.lang.String transactionNumber)
void | setVarianceAmount(java.math.BigDecimal varianceAmount)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_II

public static final java.lang.String ORDER_BY_II
See Also:
Constant Field Values

ORDER_BY_CREATEDBY

public static final java.lang.String ORDER_BY_CREATEDBY
See Also:
Constant Field Values

ORDER_BY_CREATEDDATE

public static final java.lang.String ORDER_BY_CREATEDDATE
See Also:
Constant Field Values

ORDER_BY_ITEMCOUNT

public static final java.lang.String ORDER_BY_ITEMCOUNT
See Also:
Constant Field Values

ORDER_BY_VARIANCEAMOUNT

public static final java.lang.String ORDER_BY_VARIANCEAMOUNT
See Also:
Constant Field Values

ORDER_BY_COMMITTEDDATE

public static final java.lang.String ORDER_BY_COMMITTEDDATE
See Also:
Constant Field Values

ORDER_BY_COMMITTEDBY

public static final java.lang.String ORDER_BY_COMMITTEDBY
See Also:
Constant Field Values

ORDER_BY_TRANSACTIONNUMBER

public static final java.lang.String ORDER_BY_TRANSACTIONNUMBER
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values
Constructor Detail

ChangeStdCostWorkSheetVO

public ChangeStdCostWorkSheetVO()
Method Detail

getItemCount

public java.lang.Integer getItemCount()

setItemCount

public void setItemCount(java.lang.Integer itemCount)

getCommittedBy

public java.lang.String getCommittedBy()

setCommittedBy

public void setCommittedBy(java.lang.String committedBy)

getCommittedDate

public java.util.Date getCommittedDate()

setCommittedDate

public void setCommittedDate(java.util.Date committedDate)

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getCreatedBy

public java.lang.String getCreatedBy()

setCreatedBy

public void setCreatedBy(java.lang.String createdBy)

getCreatedDate

public java.util.Date getCreatedDate()

setCreatedDate

public void setCreatedDate(java.util.Date createdDate)

getVarianceAmount

public java.math.BigDecimal getVarianceAmount()

setVarianceAmount

public void setVarianceAmount(java.math.BigDecimal varianceAmount)

getTransactionNumber

public java.lang.String getTransactionNumber()

setTransactionNumber

public void setTransactionNumber(java.lang.String transactionNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CheckInvoiceItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CheckInvoiceItemListResult

java.lang.Object
    extended by  bb.common.InvoiceItemListResult
        extended by  bb.common.CheckInvoiceItemListResult
All Implemented Interfaces:
java.io.Serializable
public class CheckInvoiceItemListResult
extends InvoiceItemListResult

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_DATEINVOICED
static java.lang.String | ORDER_BY_INVOICENUMBER
static java.lang.String | ORDER_BY_PARTNUMBER
Fields inherited from class bb.common.InvoiceItemListResult
ORDER_BY_COMPANYUNITID, ORDER_BY_CREDITACCOUNT, ORDER_BY_CURRENCY, ORDER_BY_CUSTOMERPO, ORDER_BY_CUSTOMERTOCOUNTRY, ORDER_BY_CUSTOMERTOSTATE, ORDER_BY_PAIDDATE, ORDER_BY_PAYDATE, ORDER_BY_PRODUCTCODE, ORDER_BY_SALESORDERNUMBER, ORDER_BY_SHIPPERNUMBER, ORDER_BY_SHIPTOCOUNTRY, ORDER_BY_SHIPTOID, ORDER_BY_SHIPTOSTATE
Constructor Summary
CheckInvoiceItemListResult()
Method Summary
java.lang.String | getRaoNumber()
byte[] | getSignature()
void | setRaoNumber(java.lang.String raoNumber)
void | setSignature(byte[] signature)
Methods inherited from class bb.common.InvoiceItemListResult
getCompanyUnitId, getCreditAccount, getCurrency, getCustomerId, getCustomerPo, getCustomerToCountry, getCustomerTostate, getDateInvoiced, getDescription, getDicount, getDue, getExtPrice, getInvoiceItemNumber, getInvoiceNumber, getMargin, getMarginPercent, getPaidDate, getPartFrom, getPartNumber, getPartType, getPayDate, getProductCode, getQtyOrdered, getQtyShipped, getSalesOrderNumber, getShipperNumber, getShipToCountry, getShipToId, getShipToState, getStatus, getTaxRate, getUnitPrice, setCompanyUnitId, setCreditAccount, setCurrency, setCustomerId, setCustomerPo, setCustomerToCountry, setCustomerTostate, setDateInvoiced, setDescription, setDicount, setDue, setExtPrice, setInvoiceItemNumber, setInvoiceNumber, setMargin, setMarginPercent, setPaidDate, setPartFrom, setPartNumber, setPartType, setPayDate, setProductCode, setQtyOrdered, setQtyShipped, setSalesOrderNumber, setShipperNumber, setShipToCountry, setShipToId, setShipToState, setStatus, setTaxRate, setUnitPrice
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_INVOICENUMBER

public static final java.lang.String ORDER_BY_INVOICENUMBER
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_DATEINVOICED

public static final java.lang.String ORDER_BY_DATEINVOICED
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values
Constructor Detail

CheckInvoiceItemListResult

public CheckInvoiceItemListResult()
Method Detail

getSignature

public byte[] getSignature()

setSignature

public void setSignature(byte[] signature)

getRaoNumber

public java.lang.String getRaoNumber()

setRaoNumber

public void setRaoNumber(java.lang.String raoNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CheckRunItemTotalResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CheckRunItemTotalResult

java.lang.Object
    extended by  bb.common.CheckRunItemTotalResult
All Implemented Interfaces:
java.io.Serializable
public class CheckRunItemTotalResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CheckRunItemTotalResult()
Method Summary
java.math.BigDecimal | getApTotal()
java.math.BigDecimal | getTotalDue()
java.math.BigDecimal | getTotalPaid()
java.math.BigDecimal | getTotalToBePaid()
java.math.BigDecimal | getVendorTotal()
void | setApTotal(java.math.BigDecimal apTotal)
void | setTotalDue(java.math.BigDecimal totalDue)
void | setTotalPaid(java.math.BigDecimal totalPaid)
void | setTotalToBePaid(java.math.BigDecimal totalToBePaid)
void | setVendorTotal(java.math.BigDecimal vendorTotal)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CheckRunItemTotalResult

public CheckRunItemTotalResult()
Method Detail

getTotalToBePaid

public java.math.BigDecimal getTotalToBePaid()

getTotalDue

public java.math.BigDecimal getTotalDue()

getTotalPaid

public java.math.BigDecimal getTotalPaid()

getApTotal

public java.math.BigDecimal getApTotal()

setVendorTotal

public void setVendorTotal(java.math.BigDecimal vendorTotal)

setTotalToBePaid

public void setTotalToBePaid(java.math.BigDecimal totalToBePaid)

setTotalDue

public void setTotalDue(java.math.BigDecimal totalDue)

setTotalPaid

public void setTotalPaid(java.math.BigDecimal totalPaid)

setApTotal

public void setApTotal(java.math.BigDecimal apTotal)

getVendorTotal

public java.math.BigDecimal getVendorTotal()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


C-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M N O P Q R S T U V W X Y Z

C

C - Static variable in class bb.common.Constant.SGType
CA - Static variable in class bb.common.Constant.AmountType
CALCULATE_NEW_CSI_NUMBER_ERROR - Static variable in class bb.common.BIZReason
CALCULATE_NEW_DEBIT_MEMO_NUMBER_ERROR - Static variable in class bb.common.BIZReason
CALCULATE_NEW_EXPENSES_NUMBER_ERROR - Static variable in class bb.common.BIZReason
CALCULATE_NEW_LOAN_NUMBER_ERROR - Static variable in class bb.common.BIZReason
CALCULATE_NEW_PAYMENT_RUN_NUMBER_ERROR - Static variable in class bb.common.BIZReason
CALCULATE_NEW_QUOTE_ERROR - Static variable in class bb.common.BIZReason
CALCULATE_NEW_RFC_NUMBER_ERROR - Static variable in class bb.common.BIZReason
CALCULATE_NEW_RRMA_NUMBER_ERROR - Static variable in class bb.common.BIZReason
CALCULATE_NEW_SALES_ORDER_ERROR - Static variable in class bb.common.BIZReason
CAN - Static variable in class bb.common.Configure.UpdatePermission
CAN_NOT - Static variable in class bb.common.Configure.UpdatePermission
CAN_NOT_ADD_NEW_IR_ITEM - Static variable in class bb.common.BIZReason
CAN_NOT_ADD_NEW_PAYABLE_METHOD - Static variable in class bb.common.BIZReason
CAN_NOT_APPROVE_ERROR_GL - Static variable in class bb.common.BIZReason
CAN_NOT_APPROVE_GL_CREATED_BY_YOURSELF - Static variable in class bb.common.BIZReason
CAN_NOT_BE_RECEIVED - Static variable in class bb.common.BIZReason
CAN_NOT_CANCEL_AP_WITH_PAYMENT - Static variable in class bb.common.BIZReason
CAN_NOT_CANCEL_AR_WITH_RECEIVED_PAYMENT - Static variable in class bb.common.BIZReason
CAN_NOT_CANCEL_GL_APPROVED_BY_OTHER - Static variable in class bb.common.BIZReason
CAN_NOT_CANCEL_THE_OPEN_ORDER - Static variable in class bb.common.BIZReason
CAN_NOT_CHANGE_DISASSEMBLE_WORK_ORDER_ITEM_QTY_ISSUED - Static variable in class bb.common.BIZReason
CAN_NOT_CHANGE_IR_QUALITIFY_QTY - Static variable in class bb.common.BIZReason
CAN_NOT_CHANGE_PART_FOR_DWO_HAS_ISSUED - Static variable in class bb.common.BIZReason
CAN_NOT_CHANGE_PART_FOR_HAS_ISSUED - Static variable in class bb.common.BIZReason
CAN_NOT_CHANGE_PART_FOR_HAS_RECEIVED - Static variable in class bb.common.BIZReason
CAN_NOT_CHANGE_PART_FOR_HAS_SHIPPED - Static variable in class bb.common.BIZReason
CAN_NOT_CHANGE_STATUS - Static variable in class bb.common.BIZReason
CAN_NOT_CHANGE_THE_FISCAL_YEAR_SETTINGS - Static variable in class bb.common.BIZReason
CAN_NOT_CHANGE_THIS_MONTH_EXCHANGE_RATE - Static variable in class bb.common.BIZReason
CAN_NOT_CHANGE_TRANSFER_TYPE - Static variable in class bb.common.BIZReason
CAN_NOT_CHANGE_WORK_ORDER_ITEM_QTY_ASM - Static variable in class bb.common.BIZReason
CAN_NOT_COPY_NOT_APPROVED_ECR - Static variable in class bb.common.BIZReason
CAN_NOT_COPY_PURCHASE_ORDER_FROM_CLOSED_SALES_ORDER_OR_NOT_REVIEW_SALES_ORDER - Static variable in class bb.common.BIZReason
CAN_NOT_COPY_WORK_ORDER_FROM_CLOSED_SALES_ORDER_OR_NOT_REVIEW_SALES_ORDER - Static variable in class bb.common.BIZReason
CAN_NOT_DELETE_DEFAULT_WI - Static variable in class bb.common.BIZReason
CAN_NOT_DELETE_DISASSEMBLE_WORK_ORDER_ITEM - Static variable in class bb.common.BIZReason
CAN_NOT_DELETE_ISSUED_RECORD - Static variable in class bb.common.BIZReason
CAN_NOT_DELETE_NONPRODUCTIVE_PICKING_ITEM - Static variable in class bb.common.BIZReason
CAN_NOT_DELETE_PREDEFINED_CHART_ACCOUNT_CATEGORY - Static variable in class bb.common.BIZReason
CAN_NOT_DELETE_REF_DOC_IN_IR - Static variable in class bb.common.BIZReason
CAN_NOT_DELETE_SWA_SHIPPER_ITEM - Static variable in class bb.common.BIZReason
CAN_NOT_DELETE_SWAP_ORDER_ITEM - Static variable in class bb.common.BIZReason
CAN_NOT_DELETE_THE_FISCAL_YEAR_SETTINGS - Static variable in class bb.common.BIZReason
CAN_NOT_DELETE_TRANSFER_ORDER_ITEM - Static variable in class bb.common.BIZReason
CAN_NOT_DELETE_TRANSFER_SHIPPER_ITEM - Static variable in class bb.common.BIZReason
CAN_NOT_DELETE_WORK_ORDER_ITEM - Static variable in class bb.common.BIZReason
CAN_NOT_ERROR_OR_CANCEL_GL_CREATED_BY_YOURSELF - Static variable in class bb.common.BIZReason
CAN_NOT_FIND_ACCOUNTING_INFO_DOC_SETTINGS - Static variable in class bb.common.BIZReason
CAN_NOT_FIND_ADDRESS_QA_DOC_SETTINGS - Static variable in class bb.common.BIZReason
CAN_NOT_FIND_CS_ITEM_DOC_SETTINGS - Static variable in class bb.common.BIZReason
CAN_NOT_FIND_CUSTOMER_DOC_SETTINGS - Static variable in class bb.common.BIZReason
CAN_NOT_FIND_DOCUMENT - Static variable in class bb.common.BIZReason
CAN_NOT_FIND_DOCUMENT_SETTINGS - Static variable in class bb.common.BIZReason
CAN_NOT_FIND_DWF_SETTINGS - Static variable in class bb.common.BIZReason
CAN_NOT_FIND_DWG_SETTINGS - Static variable in class bb.common.BIZReason
CAN_NOT_FIND_EDC_DOC_SETTINGS - Static variable in class bb.common.BIZReason
CAN_NOT_FIND_EMP_TRAINING_RECORDS_SETTINGS - Static variable in class bb.common.BIZReason
CAN_NOT_FIND_INIT_FILE - Static variable in class bb.common.BIZReason
CAN_NOT_FIND_QT_DOC_SETTINGS - Static variable in class bb.common.BIZReason
CAN_NOT_FIND_RMA_DOC_SETTINGS - Static variable in class bb.common.BIZReason
CAN_NOT_FIND_SO_DOC_SETTINGS - Static variable in class bb.common.BIZReason
CAN_NOT_FIND_VENDOR_DOC_SETTINGS - Static variable in class bb.common.BIZReason
CAN_NOT_FIND_VENDOR_PART - Static variable in class bb.common.BIZReason
CAN_NOT_FIND_YOUR_TRUE_NAME - Static variable in class bb.common.BIZReason
CAN_NOT_GET_SYSTEM_INFO - Static variable in class bb.common.BIZReason
CAN_NOT_HAVE_WORK_ORDER_ITEM_QTY_ASM - Static variable in class bb.common.BIZReason
CAN_NOT_LINK_TO_MORE_THAN_ONE_ORDERS - Static variable in class bb.common.BIZReason
CAN_NOT_NULL - Static variable in class bb.common.BIZReason
CAN_NOT_RECEIVE_NA_AND_OTHER_PART_AT_SAME_TIME - Static variable in class bb.common.BIZReason
CAN_NOT_UPDATE_SHIPPED_PACKING_BOX - Static variable in class bb.common.BIZReason
CAN_NOT_ZERO_SIZE_FILE - Static variable in class bb.common.BIZReason
CAN_ONLY_APPROVE_NOT_APPROVED_OPERATING_INSTRUCTION - Static variable in class bb.common.BIZReason
CAN_ONLY_CLOSE_FINISH_INSPECTIONFOR_OPERATING_INSTRUCTION - Static variable in class bb.common.BIZReason
CAN_ONLY_COMMIT_FINISHED_WORKSHEET - Static variable in class bb.common.BIZReason
CAN_ONLY_COMMIT_OPEN_WORKSHEET - Static variable in class bb.common.BIZReason
CAN_ONLY_CONTINUE_PAUSED_OPERATING_INSTRUCTION - Static variable in class bb.common.BIZReason
CAN_ONLY_CREATE_INSPECTION_REPORT_FROM_REQUEST_INSPECTIONFOR_OPERATING_INSTRUCTION - Static variable in class bb.common.BIZReason
CAN_ONLY_FINISH_OPEN_OPERATING_INSTRUCTION - Static variable in class bb.common.BIZReason
CAN_ONLY_OVER_CARRYING_COMMITTED_WORKSHEET - Static variable in class bb.common.BIZReason
CAN_ONLY_PAUSE_OPEN_OPERATING_INSTRUCTION - Static variable in class bb.common.BIZReason
CAN_ONLY_REQUEST_INSPECTIONFOR_FINISH_OPERATING_INSTRUCTION - Static variable in class bb.common.BIZReason
CAN_ONLY_UPDATE_WAITING_WORKSHEET - Static variable in class bb.common.BIZReason
cancelDisassembleWorkOrder(String) - Method in interface bb.common.box.WorkOrderBox
cancelFinishOperatingInstructions(OperatingInstructionsVO) - Method in interface bb.common.box.ManufacturingBox
cancelGeneralLedger(String) - Method in interface bb.common.box.AccountingBox
CANCELLED - Static variable in class bb.common.Constant.Status
cancelOrderChangeByID(Long, String) - Method in interface bb.common.box.WorkOrderBox
cancelPostGeneralLedger(String, String, List<String>) - Method in interface bb.common.box.AccountingBox
cancelPurchaseOrder(String) - Method in interface bb.common.box.PurchasingBox
cancelQuote(String) - Method in interface bb.common.box.SalesBox
cancelRfq(String) - Method in interface bb.common.box.PurchasingBox
cancelRMA(String) - Method in interface bb.common.box.SalesBox
cancelRTV(String) - Method in interface bb.common.box.PurchasingBox
cancelSalesOrder(String) - Method in interface bb.common.box.SalesBox
cancelSwap(String) - Method in interface bb.common.box.PurchasingBox
cancelWorkOrder(String) - Method in interface bb.common.box.WorkOrderBox
CARRIER - Static variable in class bb.common.BizTarget
CARRIER_ALREADY_EXIST - Static variable in class bb.common.BIZReason
CARRIER_NOT_EXIST - Static variable in class bb.common.BIZReason
CARRIER_USING_BY_PO - Static variable in class bb.common.BIZReason
CARRIER_USING_BY_RMA - Static variable in class bb.common.BIZReason
CARRIER_USING_BY_RTV - Static variable in class bb.common.BIZReason
CARRIER_USING_BY_SO - Static variable in class bb.common.BIZReason
CarrierPK - Class in bb.common
CarrierPK(String, String) - Constructor for class bb.common.CarrierPK
full constructor
CarrierPK() - Constructor for class bb.common.CarrierPK
default constructor
CarrierVO - Class in bb.common
CarrierVO(CarrierPK, String, String, String) - Constructor for class bb.common.CarrierVO
full constructor
CarrierVO() - Constructor for class bb.common.CarrierVO
default constructor
CASH - Static variable in class bb.common.Constant.ChartOfAccountSubType
CASH - Static variable in class bb.common.Constant.PayableMethod
CASH_FLOW_BUDGET - Static variable in class bb.common.BizTarget
CASH_OR_BANK_BALANCE_CAN_BE_NEGATIVE - Static variable in class bb.common.BIZReason
CashFlowByMonthReportResult - Class in bb.common
CashFlowByMonthReportResult() - Constructor for class bb.common.CashFlowByMonthReportResult
CashFlowMonthTotalResult - Class in bb.common
CashFlowMonthTotalResult() - Constructor for class bb.common.CashFlowMonthTotalResult
default constructor
CASHIER - Static variable in class bb.common.BizTarget
CASHIER_ALREADY_EXIST - Static variable in class bb.common.BIZReason
CashierVO - Class in bb.common
CashierVO() - Constructor for class bb.common.CashierVO
CATAGORY - Static variable in class bb.common.Constant.PartNumberGenerateType
CATALOG - Static variable in class bb.common.BizTarget
CATALOG_ALREADY_EXIST - Static variable in class bb.common.BIZReason
CATALOG_IS_USED - Static variable in class bb.common.BIZReason
CATALOG_NOT_EXIST - Static variable in class bb.common.BIZReason
CatalogVO - Class in bb.common
CatalogVO() - Constructor for class bb.common.CatalogVO
CATEGORY_ASSETS - Static variable in class bb.common.Constant.CategoryType
CATEGORY_EQUITY - Static variable in class bb.common.Constant.CategoryType
CATEGORY_ID_HAS_EXIST - Static variable in class bb.common.BIZReason
CATEGORY_ID_NOT_EXIST - Static variable in class bb.common.BIZReason
CATEGORY_ID_STILL_USED - Static variable in class bb.common.BIZReason
CATEGORY_INDEX - Static variable in class bb.common.BizTarget
CATEGORY_INDEX_ALREADY_EXIST_IN_PARENT_CATEGORY - Static variable in class bb.common.BIZReason
CATEGORY_LIABILITIES - Static variable in class bb.common.Constant.CategoryType
CB - Static variable in class bb.common.Constant.AmountType
CERTIFICATE_DESCRIPTION - Static variable in class bb.common.BizTarget
CERTIFICATE_DESCRIPTION_ALREADY_EXIST - Static variable in class bb.common.BIZReason
CERTIFICATE_DESCRIPTION_IS_NOT_USING - Static variable in class bb.common.BIZReason
CERTIFICATE_DESCRIPTION_IS_USING - Static variable in class bb.common.BIZReason
CERTIFICATE_DESCRIPTION_NOT_EXIST - Static variable in class bb.common.BIZReason
CERTIFICATE_DOC - Static variable in class bb.common.BizTarget
CERTIFICATE_DOC - Static variable in class bb.common.Constant.MiscDocType
CERTIFICATE_DOC_NOT_FIND - Static variable in class bb.common.BIZReason
CERTIFICATE_NUMBER_IS_USED - Static variable in class bb.common.BIZReason
CertificateDescriptionVO - Class in bb.common
CertificateDescriptionVO(Integer, String) - Constructor for class bb.common.CertificateDescriptionVO
full constructor
CertificateDescriptionVO() - Constructor for class bb.common.CertificateDescriptionVO
CFB_DATE - Static variable in class bb.common.Constant.DateType
CG_CLIENT_PROGRAM_USER - Static variable in class bb.common.BizTarget
CG_CUST_RFQ - Static variable in class bb.common.BizTarget
CG_CUSTOMER_SERVICE_REQUEST - Static variable in class bb.common.BizTarget
CG_PART - Static variable in class bb.common.BizTarget
CG_QUOTE_ADDRESS - Static variable in class bb.common.BizTarget
CG_SALE_ITEM - Static variable in class bb.common.BizTarget
CHANGE_STD_COST_WORKSHEET - Static variable in class bb.common.BizTarget
CHANGE_STD_COST_WORKSHEET_NOT_EXIST - Static variable in class bb.common.BIZReason
changeOperatingInstructionsStatusToCancel(OperatingInstructionsVO) - Method in interface bb.common.box.ManufacturingBox
changeServerSystemTime(Date) - Method in interface bb.common.box.CompanyBox
ChangeStdCostWorkSheetItemPK - Class in bb.common
ChangeStdCostWorkSheetItemPK() - Constructor for class bb.common.ChangeStdCostWorkSheetItemPK
ChangeStdCostWorkSheetItemPK(Long, String, String) - Constructor for class bb.common.ChangeStdCostWorkSheetItemPK
ChangeStdCostWorkSheetItemVO - Class in bb.common
ChangeStdCostWorkSheetItemVO() - Constructor for class bb.common.ChangeStdCostWorkSheetItemVO
ChangeStdCostWorkSheetVO - Class in bb.common
ChangeStdCostWorkSheetVO() - Constructor for class bb.common.ChangeStdCostWorkSheetVO
CHECK - Static variable in class bb.common.Constant.PayableMethod
CHECK_NUMBER_ALREADY_EXIST - Static variable in class bb.common.BIZReason
CHECK_NUMBER_NOT_EXIST - Static variable in class bb.common.BIZReason
CHECK_NUMBER_NOT_MATCH - Static variable in class bb.common.BIZReason
CHECK_OBJECT_EXIST_ERROR - Static variable in class bb.common.BIZReason
CHECK_RUN_ALREADY_COMMITTED - Static variable in class bb.common.BIZReason
CHECK_RUN_ALREADY_EXIST - Static variable in class bb.common.BIZReason
CHECK_RUN_NOT_EXIST - Static variable in class bb.common.BIZReason
checkCloseProformaInvoice(String) - Method in interface bb.common.box.WarehouseBox
checkIfOverControl(BigDecimal) - Method in class bb.common.IssuingResult
checkIfOverControl(BigDecimal) - Method in class bb.common.WOItemCostControlAgent
CheckInvoiceItemListResult - Class in bb.common
CheckInvoiceItemListResult() - Constructor for class bb.common.CheckInvoiceItemListResult
checkOrderExist - Static variable in class bb.common.Constant
checkOrderItemExist(OrderPK) - Method in interface bb.common.box.PurchasingBox
CHECKRUNDATE - Static variable in class bb.common.Constant.DateType
CheckRunItemTotalResult - Class in bb.common
CheckRunItemTotalResult() - Constructor for class bb.common.CheckRunItemTotalResult
CHINA - Static variable in class bb.common.Constant.LocalSettings
CHINESE_LOCALE - Static variable in class bb.common.Constant
clear() - Method in class bb.common.ListCache
clear() - Method in class bb.common.PackingBoxSalesOrderItemAgent
clear() - Method in class bb.common.PackingBoxSalesOrderItemResult
clear() - Method in class bb.common.RecursiveBillPath
CLEAR_REFERENCE_DOC_ERROR - Static variable in class bb.common.BIZReason
clearAgent() - Method in class bb.common.WorkCenterAgent
clearAllReferenceDocOnesToPurchaseOrderItem(PurchaseOrderItemPK) - Method in interface bb.common.box.ManufacturingBox
clearAllReferenceDocOnesToPurchaseOrderItem(PurchaseOrderItemPK) - Method in interface bb.common.box.PurchasingBox
clearAllReferenceDocTwoesToPurchaseOrderItem(PurchaseOrderItemPK) - Method in interface bb.common.box.ManufacturingBox
clearAllReferenceDocTwoesToPurchaseOrderItem(PurchaseOrderItemPK) - Method in interface bb.common.box.PurchasingBox
clearCategoryInAccountsChart(Long) - Method in interface bb.common.box.AccountingBox
clearDir(File) - Static method in class bb.common.BB2Util
CLEARED - Static variable in class bb.common.Constant.Status
clearGeneralLedgers(AccountMonthPK, Map<String, Boolean>) - Method in interface bb.common.box.AccountingBox
clearItems() - Method in class bb.common.POForWISeqAgent
clearItems() - Method in class bb.common.WCLoadAgent
clearMyPurchaseOrderPrintList(String) - Method in interface bb.common.box.PurchasingBox
clearMySalesOrderPrintList(String) - Method in interface bb.common.box.SalesBox
clearNCRReferenceDocOne(String) - Method in interface bb.common.box.QualityBox
clearNCRReferenceDocTwo(String) - Method in interface bb.common.box.QualityBox
clearOnLoanItemReferenceDocOne(String) - Method in interface bb.common.box.WarehouseBox
clearOnLoanItemReferenceDocTwo(String) - Method in interface bb.common.box.WarehouseBox
clearPurchaseOrderItemReferenceDocOne(String) - Method in interface bb.common.box.ManufacturingBox
clearPurchaseOrderItemReferenceDocOne(String) - Method in interface bb.common.box.PurchasingBox
clearPurchaseOrderItemReferenceDocTwo(String) - Method in interface bb.common.box.ManufacturingBox
clearPurchaseOrderItemReferenceDocTwo(String) - Method in interface bb.common.box.PurchasingBox
clearSalesOrderItemReferenceDocOne(String) - Method in interface bb.common.box.SalesBox
clearSalesOrderItemReferenceDocTwo(String) - Method in interface bb.common.box.SalesBox
clearServerTime() - Static method in class bb.common.BB2TimeFactory
clearWorkOrderItemIssueReferenceDocOne(String) - Method in interface bb.common.box.WorkOrderBox
clearWorkOrderItemReferenceDocOne(String) - Method in interface bb.common.box.WorkOrderBox
clearWorkOrderItemReferenceDocTwo(String) - Method in interface bb.common.box.WorkOrderBox
ClientAutoInvokeMethodsManager - Class in bb.common
ClientAutoInvokeMethodsManager() - Constructor for class bb.common.ClientAutoInvokeMethodsManager
ClientListItem - Class in bb.common
ClientListItem() - Constructor for class bb.common.ClientListItem
clone() - Method in class bb.common.MrpByMonthResult
CLOSE - Static variable in class bb.common.Constant.NoticeAction
CLOSE_DOCUMENT - Static variable in class bb.common.BB2Event
Closed - Static variable in class bb.common.Constant.Status
CLOSED_DEPRECIATE - Static variable in class bb.common.Constant.Depreciation.DepreciateStatus
CLOSED_OBJECT_CAN_NOT_ALLOWED_IF_ITEM_NOT_FINISHED - Static variable in class bb.common.BIZReason
CLOSED_OBJECT_NOT_ALLOW_UPDATE_AGAIN - Static variable in class bb.common.BIZReason
CLOSEDDATE - Static variable in class bb.common.Constant.DateType
closeGeneralLedger() - Method in interface bb.common.box.AccountingBox
CLOSEING_STATEMENT_WRONG - Static variable in class bb.common.BIZReason
closeOperatingInstructions(OperatingInstructionsVO) - Method in interface bb.common.box.ManufacturingBox
CloseOutDate - Static variable in class bb.common.Constant.IrDateType
closePastedQuotes(String[]) - Method in interface bb.common.box.SalesBox
closeProformaInvoices(ArrayList<String>) - Method in interface bb.common.box.WarehouseBox
CLOSING_SATEMENT - Static variable in class bb.common.BizTarget
CLOSING_STATEMENT - Static variable in class bb.common.Constant.MiscDocType
closingEntryMonthly(String) - Method in interface bb.common.box.AccountingBox
ClosingStatementItemResult - Class in bb.common
ClosingStatementItemResult() - Constructor for class bb.common.ClosingStatementItemResult
ClosingStatementResult - Class in bb.common
ClosingStatementResult() - Constructor for class bb.common.ClosingStatementResult
ClosingStatementTotalResult - Class in bb.common
ClosingStatementTotalResult() - Constructor for class bb.common.ClosingStatementTotalResult
CM - Static variable in class bb.common.Constant.Prefix
CMDATE - Static variable in class bb.common.Constant.DateType
CN - Static variable in class bb.common.Constant.LanguageCode
CNSTYLE - Static variable in class bb.common.Constant.GLStyle
collectionToMapByProperty(Collection, String) - Static method in class bb.common.BB2Util
collectionToMapByProperty(Collection, String, boolean) - Static method in class bb.common.BB2Util
commitChangeStdCostWorkSheet(Long) - Method in interface bb.common.box.AccountingBox
commitCycleCount(int) - Method in interface bb.common.box.WarehouseBox
commitPhysicalInventory(int, int) - Method in interface bb.common.box.WarehouseBox
commitRollUpBomStdCostWorkSheet(Long) - Method in interface bb.common.box.AccountingBox
COMMITTED - Static variable in class bb.common.Constant.Status
CommonPrintTemplateVO - Class in bb.common
CommonPrintTemplateVO() - Constructor for class bb.common.CommonPrintTemplateVO
COMPANY_DEFAULT_PA - Static variable in class bb.common.BizTarget
COMPANY_NOT_EXIST - Static variable in class bb.common.BIZReason
COMPANY_SETTING - Static variable in class bb.common.BizTarget
COMPANY_UNIT - Static variable in class bb.common.BizTarget
COMPANY_UNIT_ACCOUNT - Static variable in class bb.common.BizTarget
COMPANY_UNIT_ACCOUNT_ALREADY_EXIST - Static variable in class bb.common.BIZReason
COMPANY_UNIT_ACCOUNT_NOT_EXIST - Static variable in class bb.common.BIZReason
COMPANY_UNIT_ALREADY_EXIST - Static variable in class bb.common.BIZReason
COMPANY_UNIT_DOES_NOT_MATCH - Static variable in class bb.common.BIZReason
COMPANY_UNIT_NOT_EXIST - Static variable in class bb.common.BIZReason
CompanyBox - Interface in bb.common.box
COMPANYSETTINGS - Static variable in class bb.common.Configure.Module
CompanyUnitAccountPK - Class in bb.common
CompanyUnitAccountPK(String, String) - Constructor for class bb.common.CompanyUnitAccountPK
full constructor
CompanyUnitAccountPK() - Constructor for class bb.common.CompanyUnitAccountPK
default constructor
CompanyUnitAccountVO - Class in bb.common
CompanyUnitAccountVO(CompanyUnitAccountPK) - Constructor for class bb.common.CompanyUnitAccountVO
full constructor
CompanyUnitAccountVO() - Constructor for class bb.common.CompanyUnitAccountVO
default constructor
companyUnitId - Variable in class bb.common.ProfitLossStatementResult
CompanyUnitVO - Class in bb.common
CompanyUnitVO() - Constructor for class bb.common.CompanyUnitVO
CompanyVO - Class in bb.common
CompanyVO() - Constructor for class bb.common.CompanyVO
compareDateWithoutTime(Date, Date) - Static method in class bb.common.BB2Util
compareList(List, List, boolean) - Static method in class bb.common.BB2Util
compareTo(Object) - Method in class bb.common.AccountsChartMappingPK
compareTo(AssetAmortizationExpenseAccountVO) - Method in class bb.common.AssetAmortizationExpenseAccountVO
compareTo(Object) - Method in class bb.common.BB2BigDecimalAndString
compareTo(Object) - Method in class bb.common.BB2DoubleString
compareTo(BB2Part) - Method in class bb.common.BB2Part
compareTo(CurrencyExchangePK) - Method in class bb.common.CurrencyExchangePK
compareTo(DisassembleWorkOrderItemPK) - Method in class bb.common.DisassembleWorkOrderItemPK
compareTo(LabelTemplateItemVO) - Method in class bb.common.LabelTemplateItemVO
compareTo(OpCodeShortcutPK) - Method in class bb.common.OpCodeShortcutPK
compareTo(PartPK) - Method in class bb.common.PartPK
compareTo(Object) - Method in class bb.common.PrPackingBoxItemPK
compareTo(Object) - Method in class bb.common.PrPackingBoxItemVO
compareTo(SwapShipperItemPK) - Method in class bb.common.SwapShipperItemPK
compareTo(Object) - Method in class bb.common.VendorPartPK
compareTo(Object) - Method in class bb.common.VendorPartVO
compareTo(Object) - Method in class bb.common.WorkCenterVO
compareTo(WorkOrderItemPK) - Method in class bb.common.WorkOrderItemPK
compareTo(Object) - Method in class bb.common.WorkOrderItemSetupItemAgent
compareTo(ZipcodeTotalsResult) - Method in class bb.common.ZipcodeTotalsResult
concatLocation(String, String, String) - Static method in class bb.common.BB2Util
Configure - Class in bb.common
Configure() - Constructor for class bb.common.Configure
Configure.LoginStatus - Class in bb.common
Configure.LoginStatus() - Constructor for class bb.common.Configure.LoginStatus
Configure.Module - Class in bb.common
Configure.Module() - Constructor for class bb.common.Configure.Module
Configure.Organization - Class in bb.common
Configure.Organization() - Constructor for class bb.common.Configure.Organization
Configure.UpdatePermission - Class in bb.common
Configure.UpdatePermission() - Constructor for class bb.common.Configure.UpdatePermission
Configure.UserLocked - Class in bb.common
Configure.UserLocked() - Constructor for class bb.common.Configure.UserLocked
Configure.UserType - Class in bb.common
Configure.UserType() - Constructor for class bb.common.Configure.UserType
Constant - Class in bb.common
Constant() - Constructor for class bb.common.Constant
Constant.ActiveStatus - Class in bb.common
Constant.ActiveStatus() - Constructor for class bb.common.Constant.ActiveStatus
Constant.AddressType - Class in bb.common
Constant.AddressType() - Constructor for class bb.common.Constant.AddressType
Constant.AgeLevel - Class in bb.common
Constant.AgeLevel() - Constructor for class bb.common.Constant.AgeLevel
Constant.AmountType - Class in bb.common
Constant.AmountType() - Constructor for class bb.common.Constant.AmountType
Constant.ARDiscountMethod - Class in bb.common
Constant.ARDiscountMethod() - Constructor for class bb.common.Constant.ARDiscountMethod
Constant.CategoryReportType - Class in bb.common
Constant.CategoryReportType() - Constructor for class bb.common.Constant.CategoryReportType
Constant.CategoryType - Class in bb.common
Constant.CategoryType() - Constructor for class bb.common.Constant.CategoryType
Constant.ChartOfAccountSubType - Class in bb.common
Constant.ChartOfAccountSubType() - Constructor for class bb.common.Constant.ChartOfAccountSubType
Constant.ChartOfAccountType - Class in bb.common
Constant.ChartOfAccountType() - Constructor for class bb.common.Constant.ChartOfAccountType
Constant.CheckType - Class in bb.common
Constant.CheckType() - Constructor for class bb.common.Constant.CheckType
Constant.CostControl - Class in bb.common
Constant.CostControl() - Constructor for class bb.common.Constant.CostControl
Constant.CustomerVendorMailType - Class in bb.common
Constant.CustomerVendorMailType() - Constructor for class bb.common.Constant.CustomerVendorMailType
Constant.CVAddressType - Class in bb.common
Constant.CVAddressType() - Constructor for class bb.common.Constant.CVAddressType
Constant.CycleCountPeriodUnit - Class in bb.common
Constant.CycleCountPeriodUnit() - Constructor for class bb.common.Constant.CycleCountPeriodUnit
Constant.DataFilterType - Class in bb.common
Constant.DataFilterType() - Constructor for class bb.common.Constant.DataFilterType
Constant.DateType - Class in bb.common
Constant.DateType() - Constructor for class bb.common.Constant.DateType
Constant.DebitOrCredit - Class in bb.common
Constant.DebitOrCredit() - Constructor for class bb.common.Constant.DebitOrCredit
Constant.Depreciation - Class in bb.common
Constant.Depreciation() - Constructor for class bb.common.Constant.Depreciation
Constant.Depreciation.DepreciateStatus - Class in bb.common
Constant.Depreciation.DepreciateStatus() - Constructor for class bb.common.Constant.Depreciation.DepreciateStatus
Constant.Depreciation.DepreciationMethod - Class in bb.common
Constant.Depreciation.DepreciationMethod() - Constructor for class bb.common.Constant.Depreciation.DepreciationMethod
Constant.Depreciation.UsingType - Class in bb.common
Constant.Depreciation.UsingType() - Constructor for class bb.common.Constant.Depreciation.UsingType
Constant.Download - Class in bb.common
Constant.Download() - Constructor for class bb.common.Constant.Download
Constant.DrawingType - Class in bb.common
Constant.DrawingType() - Constructor for class bb.common.Constant.DrawingType
Constant.ECRPriority - Class in bb.common
Constant.ECRPriority() - Constructor for class bb.common.Constant.ECRPriority
Constant.EmployeeSecurityLevel - Class in bb.common
Constant.EmployeeSecurityLevel() - Constructor for class bb.common.Constant.EmployeeSecurityLevel
Constant.EmployeeStatus - Class in bb.common
Constant.EmployeeStatus() - Constructor for class bb.common.Constant.EmployeeStatus
Constant.EngineeringSharingImportDataType - Class in bb.common
Constant.EngineeringSharingImportDataType() - Constructor for class bb.common.Constant.EngineeringSharingImportDataType
Constant.EngineeringSharingImportType - Class in bb.common
Constant.EngineeringSharingImportType() - Constructor for class bb.common.Constant.EngineeringSharingImportType
Constant.EquipmentStatus - Class in bb.common
Constant.EquipmentStatus() - Constructor for class bb.common.Constant.EquipmentStatus
Constant.ExchangeRateType - Class in bb.common
Constant.ExchangeRateType() - Constructor for class bb.common.Constant.ExchangeRateType
Constant.FileExt - Class in bb.common
Constant.FileExt() - Constructor for class bb.common.Constant.FileExt
Constant.GLApprovedType - Class in bb.common
Constant.GLApprovedType() - Constructor for class bb.common.Constant.GLApprovedType
Constant.GLStyle - Class in bb.common
Constant.GLStyle() - Constructor for class bb.common.Constant.GLStyle
Constant.GLType - Class in bb.common
Constant.GLType() - Constructor for class bb.common.Constant.GLType
Constant.InventoryCostMothed - Class in bb.common
Constant.InventoryCostMothed() - Constructor for class bb.common.Constant.InventoryCostMothed
Constant.InventoryWorkSheetOrderBy - Class in bb.common
Constant.InventoryWorkSheetOrderBy() - Constructor for class bb.common.Constant.InventoryWorkSheetOrderBy
Constant.IrDateType - Class in bb.common
Constant.IrDateType() - Constructor for class bb.common.Constant.IrDateType
Constant.IRType - Class in bb.common
Constant.IRType() - Constructor for class bb.common.Constant.IRType
Constant.IssuedFrom - Class in bb.common
Constant.IssuedFrom() - Constructor for class bb.common.Constant.IssuedFrom
Constant.LanguageCode - Class in bb.common
Constant.LanguageCode() - Constructor for class bb.common.Constant.LanguageCode
Constant.LocalSettings - Class in bb.common
Constant.LocalSettings() - Constructor for class bb.common.Constant.LocalSettings
Constant.LoginType - Class in bb.common
Constant.LoginType() - Constructor for class bb.common.Constant.LoginType
Constant.MakeBuy - Class in bb.common
Constant.MakeBuy() - Constructor for class bb.common.Constant.MakeBuy
Constant.MiscDocType - Class in bb.common
Constant.MiscDocType() - Constructor for class bb.common.Constant.MiscDocType
Constant.NaRecTo - Class in bb.common
Constant.NaRecTo() - Constructor for class bb.common.Constant.NaRecTo
Constant.NcrApprovableType - Class in bb.common
Constant.NcrApprovableType() - Constructor for class bb.common.Constant.NcrApprovableType
Constant.NoticeAction - Class in bb.common
Constant.NoticeAction() - Constructor for class bb.common.Constant.NoticeAction
Constant.NoticeType - Class in bb.common
Constant.NoticeType() - Constructor for class bb.common.Constant.NoticeType
Constant.OITypeSerialNumberType - Class in bb.common
Constant.OITypeSerialNumberType() - Constructor for class bb.common.Constant.OITypeSerialNumberType
Constant.OrderType - Class in bb.common
Constant.OrderType() - Constructor for class bb.common.Constant.OrderType
Constant.Package - Class in bb.common
Constant.Package() - Constructor for class bb.common.Constant.Package
Constant.PageCycleCount - Class in bb.common
Constant.PageCycleCount() - Constructor for class bb.common.Constant.PageCycleCount
Constant.PAOffsetType - Class in bb.common
Constant.PAOffsetType() - Constructor for class bb.common.Constant.PAOffsetType
Constant.PartFrom - Class in bb.common
Constant.PartFrom() - Constructor for class bb.common.Constant.PartFrom
Constant.PartNumberGenerateType - Class in bb.common
Constant.PartNumberGenerateType() - Constructor for class bb.common.Constant.PartNumberGenerateType
Constant.PartQtyType - Class in bb.common
Constant.PartQtyType() - Constructor for class bb.common.Constant.PartQtyType
Constant.PayableMethod - Class in bb.common
Constant.PayableMethod() - Constructor for class bb.common.Constant.PayableMethod
Constant.PeriodUnit - Class in bb.common
Constant.PeriodUnit() - Constructor for class bb.common.Constant.PeriodUnit
Constant.PosOrderType - Class in bb.common
Constant.PosOrderType() - Constructor for class bb.common.Constant.PosOrderType
Constant.Prefix - Class in bb.common
Constant.Prefix() - Constructor for class bb.common.Constant.Prefix
Constant.PrintTemplateType - Class in bb.common
Constant.PrintTemplateType() - Constructor for class bb.common.Constant.PrintTemplateType
Constant.ReceiveCondition - Class in bb.common
Constant.ReceiveCondition() - Constructor for class bb.common.Constant.ReceiveCondition
Constant.ReceivedTo - Class in bb.common
Constant.ReceivedTo() - Constructor for class bb.common.Constant.ReceivedTo
Constant.SalesTaxReportType - Class in bb.common
Constant.SalesTaxReportType() - Constructor for class bb.common.Constant.SalesTaxReportType
Constant.SGType - Class in bb.common
Constant.SGType() - Constructor for class bb.common.Constant.SGType
Constant.StatementType - Class in bb.common
Constant.StatementType() - Constructor for class bb.common.Constant.StatementType
Constant.Status - Class in bb.common
Constant.Status() - Constructor for class bb.common.Constant.Status
Constant.SystemUserGroup - Class in bb.common
Constant.SystemUserGroup() - Constructor for class bb.common.Constant.SystemUserGroup
Constant.TaxType - Class in bb.common
Constant.TaxType() - Constructor for class bb.common.Constant.TaxType
Constant.TermsConditonType - Class in bb.common
Constant.TermsConditonType() - Constructor for class bb.common.Constant.TermsConditonType
Constant.TrackingNumberType - Class in bb.common
Constant.TrackingNumberType() - Constructor for class bb.common.Constant.TrackingNumberType
Constant.TransactionType - Class in bb.common
Constant.TransactionType() - Constructor for class bb.common.Constant.TransactionType
Constant.TransferType - Class in bb.common
Constant.TransferType() - Constructor for class bb.common.Constant.TransferType
Constant.Upload - Class in bb.common
Constant.Upload() - Constructor for class bb.common.Constant.Upload
Constant.VendorQualityStatus - Class in bb.common
Constant.VendorQualityStatus() - Constructor for class bb.common.Constant.VendorQualityStatus
Constant.WorkCenterSearchType - Class in bb.common
Constant.WorkCenterSearchType() - Constructor for class bb.common.Constant.WorkCenterSearchType
Constant.WorkCenterType - Class in bb.common
Constant.WorkCenterType() - Constructor for class bb.common.Constant.WorkCenterType
Constant.WorkLevel - Class in bb.common
Constant.WorkLevel() - Constructor for class bb.common.Constant.WorkLevel
Constant.YesNO - Class in bb.common
Constant.YesNO() - Constructor for class bb.common.Constant.YesNO
constructCustomerVendorAddressForCRFQ(String) - Method in interface bb.common.box.AddressBox
constructShipListOwnerAttributes(String, List, List, List) - Method in interface bb.common.box.PlanningBox
contain(PartPK) - Method in class bb.common.BOMTreeRollUPMap
containMethod(String, String) - Static method in class bb.common.ClientAutoInvokeMethodsManager
contains(String) - Method in class bb.common.WorkCenterAgent
continueOperatingInstructions(OperatingInstructionsVO) - Method in interface bb.common.box.ManufacturingBox
CONTRACE_PRICE - Static variable in class bb.common.BizTarget
CONTRACE_PRICE_CUSTOMER - Static variable in class bb.common.BizTarget
CONTRACE_PRICE_ITEM - Static variable in class bb.common.BizTarget
CONTRACT_PRICE_CUSTOMER_HAS_EXIST - Static variable in class bb.common.BIZReason
CONTRACT_PRICE_CUSTOMER_NOT_EXIST - Static variable in class bb.common.BIZReason
CONTRACT_PRICE_HAS_EXIST - Static variable in class bb.common.BIZReason
CONTRACT_PRICE_ITEM_HAS_EXIST - Static variable in class bb.common.BIZReason
CONTRACT_PRICE_ITEM_NOT_EXIST - Static variable in class bb.common.BIZReason
CONTRACT_PRICE_NOT_EXIST - Static variable in class bb.common.BIZReason
ContractPriceCustomerPK - Class in bb.common
ContractPriceCustomerPK(String, String) - Constructor for class bb.common.ContractPriceCustomerPK
full constructor
ContractPriceCustomerPK() - Constructor for class bb.common.ContractPriceCustomerPK
default constructor
ContractPriceCustomerVO - Class in bb.common
ContractPriceCustomerVO() - Constructor for class bb.common.ContractPriceCustomerVO
ContractPriceItemPK - Class in bb.common
ContractPriceItemPK() - Constructor for class bb.common.ContractPriceItemPK
ContractPriceItemPK(String, String, String, String) - Constructor for class bb.common.ContractPriceItemPK
ContractPriceItemVO - Class in bb.common
ContractPriceItemVO() - Constructor for class bb.common.ContractPriceItemVO
ContractPriceVO - Class in bb.common
ContractPriceVO() - Constructor for class bb.common.ContractPriceVO
convertVOClassToPOClass(String) - Static method in class bb.common.BB2Util
copy(Object) - Static method in class bb.common.CopyUtil
copyBill(BillPK, BillPK) - Method in interface bb.common.box.EngineeringBox
copyCVFormCV(CV2CVAgent) - Method in interface bb.common.box.AddressBox
copyEcrToEcn(String) - Method in interface bb.common.box.EngineeringBox
copyPart(PartPK, String, String, String, PartPK, boolean) - Method in interface bb.common.box.EngineeringBox
copyPartMaterial(PartPK, PartMaterialVO) - Method in interface bb.common.box.EngineeringBox
copyPurchaseOrderFromPurchaseOrder(PO2POAgent) - Method in interface bb.common.box.PurchasingBox
copyPurchaseOrderFromSalesOrder(SO2POAgent) - Method in interface bb.common.box.PurchasingBox
copyPurchaseOrderFromSalesOrder(SO2POAgent) - Method in interface bb.common.box.SalesBox
copyQuoteToQuote(Quote2QuoteAgent) - Method in interface bb.common.box.SalesBox
copyQuoteToSalesOrder(String, boolean) - Method in interface bb.common.box.SalesBox
copyRoleToRole(String, String) - Method in interface bb.common.box.SecurityBox
copySalesOrderFromSalesOrder(SO2SOAgent) - Method in interface bb.common.box.SalesBox
copyToAddWorkInstruction(WorkInstructionVO) - Method in interface bb.common.box.ManufacturingBox
copyUserToUser(User2UserAgent) - Method in interface bb.common.box.SecurityBox
CopyUtil - Class in bb.common
CopyUtil() - Constructor for class bb.common.CopyUtil
copyWith(WorkCenterAgent) - Method in class bb.common.WCLoadAgent
copyWorkCenterFromWorkCenter(WC2WCAgent) - Method in interface bb.common.box.ManufacturingBox
copyWorkInstruction(WorkInstructionPK, WorkInstructionPK) - Method in interface bb.common.box.ManufacturingBox
copyWorkOrderFromSalesOrder(SO2WOAgent) - Method in interface bb.common.box.SalesBox
copyWorkOrderFromWorkOrder(WO2WOAgent) - Method in interface bb.common.box.WorkOrderBox
CorrectiveActionRequestVO - Class in bb.common
CorrectiveActionRequestVO() - Constructor for class bb.common.CorrectiveActionRequestVO
default constructor
CORRICTIVE_ACTION_REQUEST - Static variable in class bb.common.BizTarget
cost(BigDecimal, BigDecimal, BigDecimal, BigDecimal, boolean, int) - Static method in class bb.common.BB2Util
COST_CAN_NOT_BE_ZERO - Static variable in class bb.common.BIZReason
CP - Static variable in class bb.common.Constant.Prefix
CPItemFromQuoteResult - Class in bb.common
CPItemFromQuoteResult() - Constructor for class bb.common.CPItemFromQuoteResult
CREATE_DATE - Static variable in class bb.common.Constant.DateType
CREATE_DIRECTORY_FAILED - Static variable in class bb.common.BIZReason
createAppColumn(String, String, String) - Method in interface bb.common.box.CompanyBox
createAppTable(String, String) - Method in interface bb.common.box.CompanyBox
createPO2SOExchange(String) - Method in interface bb.common.box.PurchasingBox
createSalesOrderByExchange(PO2SOExchange) - Method in interface bb.common.box.SalesBox
CREDIT - Static variable in class bb.common.Constant.DebitOrCredit
CREDIT_CARD - Static variable in class bb.common.Constant.PayableMethod
CREDIT_MEMO - Static variable in class bb.common.BizTarget
CREDIT_MEMO_ALREADY_EXIST - Static variable in class bb.common.BIZReason
CREDIT_MEMO_NOT_EXIST - Static variable in class bb.common.BIZReason
CRFQ - Static variable in class bb.common.Constant.Prefix
CRTVItemListResult - Class in bb.common
CRTVItemListResult() - Constructor for class bb.common.CRTVItemListResult
CRTVListResult - Class in bb.common
CRTVListResult() - Constructor for class bb.common.CRTVListResult
CS_ITEM_DOC - Static variable in class bb.common.BizTarget
CS_ITEM_DOC - Static variable in class bb.common.Constant.MiscDocType
CS_ITEM_DOC_NOT_FIND - Static variable in class bb.common.BIZReason
CSRAgent - Class in bb.common
CSRAgent() - Constructor for class bb.common.CSRAgent
CURRENCY - Static variable in class bb.common.BizTarget
CURRENCY_ALREADY_EXIST - Static variable in class bb.common.BIZReason
CURRENCY_EXCHANGE - Static variable in class bb.common.BizTarget
CURRENCY_EXCHANGE_MUST_BE_ONE - Static variable in class bb.common.BIZReason
CURRENCY_EXCHANGE_NOT_EXIST - Static variable in class bb.common.BIZReason
CURRENCY_EXCHANGE_SHOULD_BE_POSITIVE - Static variable in class bb.common.BIZReason
CURRENCY_NOT_EXIST - Static variable in class bb.common.BIZReason
CurrencyAgent - Class in bb.common
CurrencyAgent() - Constructor for class bb.common.CurrencyAgent
CurrencyExchangePK - Class in bb.common
CurrencyExchangePK(String, String) - Constructor for class bb.common.CurrencyExchangePK
full constructor
CurrencyExchangePK() - Constructor for class bb.common.CurrencyExchangePK
default constructor
CurrencyExchangeVO - Class in bb.common
CurrencyExchangeVO() - Constructor for class bb.common.CurrencyExchangeVO
CurrencyVO - Class in bb.common
CurrencyVO() - Constructor for class bb.common.CurrencyVO
CurrentBalanceResult - Class in bb.common
CurrentBalanceResult() - Constructor for class bb.common.CurrentBalanceResult
CustomAssetRecordPK - Class in bb.common
CustomAssetRecordPK() - Constructor for class bb.common.CustomAssetRecordPK
CustomAssetRecordVO - Class in bb.common
CustomAssetRecordVO() - Constructor for class bb.common.CustomAssetRecordVO
default constructor
CustomAssetVO - Class in bb.common
CustomAssetVO() - Constructor for class bb.common.CustomAssetVO
default constructor
CustomCheckUpEmployeeVO - Class in bb.common
CustomCheckUpEmployeeVO() - Constructor for class bb.common.CustomCheckUpEmployeeVO
default constructor
CustomDepartmentVO - Class in bb.common
CustomDepartmentVO() - Constructor for class bb.common.CustomDepartmentVO
CustomEmployeeTrainPK - Class in bb.common
CustomEmployeeTrainPK() - Constructor for class bb.common.CustomEmployeeTrainPK
CustomEmployeeTrainVO - Class in bb.common
CustomEmployeeTrainVO() - Constructor for class bb.common.CustomEmployeeTrainVO
default constructor
CustomEmployeeVO - Class in bb.common
CustomEmployeeVO() - Constructor for class bb.common.CustomEmployeeVO
default constructor
CustomEmployeeWorkExperienceVO - Class in bb.common
CustomEmployeeWorkExperienceVO() - Constructor for class bb.common.CustomEmployeeWorkExperienceVO
default constructor
CUSTOMER - Static variable in class bb.common.BizTarget
CUSTOMER - Static variable in class bb.common.Constant.AddressType
CUSTOMER - Static variable in class bb.common.Constant.CVAddressType
CUSTOMER_CATALOG - Static variable in class bb.common.BizTarget
CUSTOMER_DOC - Static variable in class bb.common.BizTarget
CUSTOMER_DOC - Static variable in class bb.common.Constant.MiscDocType
CUSTOMER_DOC_NOT_FIND - Static variable in class bb.common.BIZReason
CUSTOMER_FEEDBACK - Static variable in class bb.common.BizTarget
CUSTOMER_FEEDBACK_ALREADY_EXIST - Static variable in class bb.common.BIZReason
CUSTOMER_FEEDBACK_ITEM - Static variable in class bb.common.BizTarget
CUSTOMER_FEEDBACK_ITEM_ALREADY_EXIST - Static variable in class bb.common.BIZReason
CUSTOMER_FEEDBACK_ITEM_NOT_EXIST - Static variable in class bb.common.BIZReason
CUSTOMER_FEEDBACK_NOT_EXIST - Static variable in class bb.common.BIZReason
CUSTOMER_NOT_EXIST_TERM - Static variable in class bb.common.BIZReason
CUSTOMER_PART - Static variable in class bb.common.BizTarget
CUSTOMER_PART_CATALOG_ALREADY_EXIST - Static variable in class bb.common.BIZReason
CUSTOMER_PART_CATALOG_NOT_EXIST - Static variable in class bb.common.BIZReason
CUSTOMER_PART_NOT_EXIST - Static variable in class bb.common.BIZReason
CUSTOMER_SERVICE_INCIDENT - Static variable in class bb.common.BizTarget
CUSTOMER_SERVICE_INCIDENT_ALREADY_EXIST - Static variable in class bb.common.BIZReason
CUSTOMER_SERVICE_INCIDENT_ITEM - Static variable in class bb.common.BizTarget
CUSTOMER_SERVICE_INCIDENT_NOT_EXIST - Static variable in class bb.common.BIZReason
CUSTOMER_SERVICE_REQUEST - Static variable in class bb.common.BizTarget
CUSTOMER_SERVICE_REQUEST_NOT_EXIST - Static variable in class bb.common.BIZReason
CUSTOMER_VENDOR_TYPE - Static variable in class bb.common.BizTarget
CUSTOMER_VENDOR_TYPE_ALREADY_EXIST - Static variable in class bb.common.BIZReason
CUSTOMER_VENDOR_TYPE_NOT_EXIST - Static variable in class bb.common.BIZReason
CustomerCLimitResult - Class in bb.common
CustomerCLimitResult() - Constructor for class bb.common.CustomerCLimitResult
CustomerFeedbackVO - Class in bb.common
CustomerFeedbackVO() - Constructor for class bb.common.CustomerFeedbackVO
default constructor
CustomerPrepayStatementListResult - Class in bb.common
CustomerPrepayStatementListResult() - Constructor for class bb.common.CustomerPrepayStatementListResult
CustomerReturnToVendorItemPK - Class in bb.common
CustomerReturnToVendorItemPK(String, String) - Constructor for class bb.common.CustomerReturnToVendorItemPK
CustomerReturnToVendorItemPK() - Constructor for class bb.common.CustomerReturnToVendorItemPK
CustomerReturnToVendorItemVO - Class in bb.common
CustomerReturnToVendorItemVO() - Constructor for class bb.common.CustomerReturnToVendorItemVO
default constructor
CustomerReturnToVendorItemVO(CustomerReturnToVendorItemPK, String, String, String) - Constructor for class bb.common.CustomerReturnToVendorItemVO
minimal constructor
CustomerReturnToVendorVO - Class in bb.common
CustomerReturnToVendorVO() - Constructor for class bb.common.CustomerReturnToVendorVO
CUSTOMERSERVICE - Static variable in class bb.common.Configure.Module
CustomerServiceBox - Interface in bb.common.box
CustomerServiceIncidentItemListResult - Class in bb.common
CustomerServiceIncidentItemListResult() - Constructor for class bb.common.CustomerServiceIncidentItemListResult
CustomerServiceIncidentItemVO - Class in bb.common
CustomerServiceIncidentItemVO() - Constructor for class bb.common.CustomerServiceIncidentItemVO
default constructor
CustomerServiceIncidentListResult - Class in bb.common
CustomerServiceIncidentListResult() - Constructor for class bb.common.CustomerServiceIncidentListResult
CustomerServiceIncidentVO - Class in bb.common
CustomerServiceIncidentVO() - Constructor for class bb.common.CustomerServiceIncidentVO
default constructor
CustomerStatementListResult - Class in bb.common
CustomerStatementListResult() - Constructor for class bb.common.CustomerStatementListResult
CustomerStatementResult - Class in bb.common
CustomerStatementResult() - Constructor for class bb.common.CustomerStatementResult
CustomerStatementTotalResult - Class in bb.common
CustomerStatementTotalResult() - Constructor for class bb.common.CustomerStatementTotalResult
CustomerVendorAddressInfoVO - Class in bb.common
CustomerVendorAddressInfoVO() - Constructor for class bb.common.CustomerVendorAddressInfoVO
CustomerVendorAddressTotalInfo - Class in bb.common
CustomerVendorAddressTotalInfo() - Constructor for class bb.common.CustomerVendorAddressTotalInfo
CustomerVendorAddressVO - Class in bb.common
CustomerVendorAddressVO() - Constructor for class bb.common.CustomerVendorAddressVO
CustomerVendorContactPK - Class in bb.common
CustomerVendorContactPK(String, Short) - Constructor for class bb.common.CustomerVendorContactPK
full constructor
CustomerVendorContactPK() - Constructor for class bb.common.CustomerVendorContactPK
default constructor
CustomerVendorContactVO - Class in bb.common
CustomerVendorContactVO() - Constructor for class bb.common.CustomerVendorContactVO
CustomerVendorDescriptionPK - Class in bb.common
CustomerVendorDescriptionPK(String, String) - Constructor for class bb.common.CustomerVendorDescriptionPK
full constructor
CustomerVendorDescriptionPK() - Constructor for class bb.common.CustomerVendorDescriptionPK
default constructor
CustomerVendorDescriptionVO - Class in bb.common
CustomerVendorDescriptionVO() - Constructor for class bb.common.CustomerVendorDescriptionVO
CustomerVendorTypeVO - Class in bb.common
CustomerVendorTypeVO() - Constructor for class bb.common.CustomerVendorTypeVO
CustomGoodsBreedVO - Class in bb.common
CustomGoodsBreedVO() - Constructor for class bb.common.CustomGoodsBreedVO
CustomGoodsRecordVO - Class in bb.common
CustomGoodsRecordVO() - Constructor for class bb.common.CustomGoodsRecordVO
CUSTOMIZATION - Static variable in class bb.common.Constant.LocalSettings
CustomJobCategoryGoodsPK - Class in bb.common
CustomJobCategoryGoodsPK() - Constructor for class bb.common.CustomJobCategoryGoodsPK
CustomJobCategoryGoodsVO - Class in bb.common
CustomJobCategoryGoodsVO() - Constructor for class bb.common.CustomJobCategoryGoodsVO
CustomJobCategoryVO - Class in bb.common
CustomJobCategoryVO() - Constructor for class bb.common.CustomJobCategoryVO
CustomSearchVO - Class in bb.common
CustomSearchVO() - Constructor for class bb.common.CustomSearchVO
CustomSearchVO(String, String) - Constructor for class bb.common.CustomSearchVO
CustomTranslationVO - Class in bb.common
CustomTranslationVO() - Constructor for class bb.common.CustomTranslationVO
CV2CVAgent - Class in bb.common
CV2CVAgent() - Constructor for class bb.common.CV2CVAgent
CYCLE_WORK_SHEET - Static variable in class bb.common.BizTarget
CYCLE_WORK_SHEET_ALREADY_CLOSED - Static variable in class bb.common.BIZReason
CYCLE_WORK_SHEET_HAS_EXIST - Static variable in class bb.common.BIZReason
CYCLE_WORK_SHEET_NOT_EXIST - Static variable in class bb.common.BIZReason
CYCLE_WORK_SHEET_NUMBER_REQUIRE - Static variable in class bb.common.BIZReason
CYCLE_WORK_SHEET_PAGE_NUMBER - Static variable in class bb.common.BizTarget
CYCLE_WORK_SHEET_PAGE_NUMBER_HAS_EXIST - Static variable in class bb.common.BIZReason
CYCLE_WORK_SHEET_PAGE_NUMBER_NOT_EXIST - Static variable in class bb.common.BIZReason
CycleCountAgent - Class in bb.common
CycleCountAgent() - Constructor for class bb.common.CycleCountAgent
CycleCountListResult - Class in bb.common
CycleCountListResult() - Constructor for class bb.common.CycleCountListResult
CycleCountListTotalResult - Class in bb.common
CycleCountListTotalResult() - Constructor for class bb.common.CycleCountListTotalResult
CycleCountPK - Class in bb.common
CycleCountPK(Integer, Integer, Integer) - Constructor for class bb.common.CycleCountPK
full constructor
CycleCountPK() - Constructor for class bb.common.CycleCountPK
default constructor
CycleCountStatusVO - Class in bb.common
CycleCountStatusVO() - Constructor for class bb.common.CycleCountStatusVO
CycleCountVO - Class in bb.common
CycleCountVO() - Constructor for class bb.common.CycleCountVO
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M N O P Q R S T U V W X Y Z


PREV NEXT FRAMES NO FRAMES

Hierarchy For All Packages

Package Hierarchies:
bb.common, bb.common.box

Class Hierarchy

  • java.lang.Object
    • bb.common.AccountAgingTotalResult (implements java.io.Serializable)
    • bb.common.AccountAuditAgent (implements java.io.Serializable)
    • bb.common.AccountBalanceAgent (implements java.io.Serializable)
    • bb.common.AccountBalanceListResult (implements java.io.Serializable)
    • bb.common.AccountBalanceResult (implements java.io.Serializable)
    • bb.common.AccountCreditDebitPK (implements java.io.Serializable)
    • bb.common.AccountInfoCenterItemResult (implements java.io.Serializable)
    • bb.common.AccountInfoCenterResult (implements java.io.Serializable)
    • bb.common.AccountingBalanceSheetResult (implements java.io.Serializable)
    • bb.common.AccountingTotalMoneyResult (implements java.io.Serializable)
    • bb.common.AccountMonthPK (implements java.io.Serializable)
    • bb.common.AccountPayableInfoWithPrepayResult (implements java.io.Serializable)
    • bb.common.AccountReceivableInfoWithPrepayResult (implements java.io.Serializable)
    • bb.common.AccountsChartMappingPK (implements java.lang.Comparable<T>, java.io.Serializable)
    • bb.common.AccountsChartResult (implements java.io.Serializable)
    • bb.common.AccountsCreditDebitListResult (implements bb.common.Alarmable, java.io.Serializable)
    • bb.common.AccountsPayableItemManufacturerPK (implements java.io.Serializable)
    • bb.common.AccountsPayableItemPK (implements java.io.Serializable)
    • bb.common.AccountsReceivableItemManufacturerPK (implements java.io.Serializable)
    • bb.common.AccountsReceivableItemPK (implements java.io.Serializable)
    • bb.common.AddPayableWithoutReceiverAgent (implements java.io.Serializable)
    • bb.common.AddPhysicalInventoryAgent (implements java.io.Serializable)
    • bb.common.AddProformaReceiverAgent (implements java.io.Serializable)
    • bb.common.AddProformaReceiverItemAgent (implements java.io.Serializable)
    • bb.common.AddressAccountInfo (implements java.io.Serializable)
    • bb.common.AddRTVAgent (implements java.io.Serializable)
    • bb.common.AllBudgetResult (implements java.io.Serializable)
    • bb.common.AllPartDocumentsPK (implements java.io.Serializable)
    • bb.common.AllStatementsListResult (implements java.io.Serializable)
    • bb.common.AmountsStatementResult (implements java.io.Serializable)
    • bb.common.APAuditListResult (implements bb.common.Alarmable, java.io.Serializable)
    • bb.common.ApCheckRunItemAgent (implements java.io.Serializable)
    • bb.common.ApCheckRunListResult (implements java.io.Serializable)
    • bb.common.APItemListResult (implements java.io.Serializable)
      • bb.common.APAgingItemListResult (implements java.io.Serializable)
    • bb.common.APPrepayInfoResult (implements java.io.Serializable)
    • bb.common.ApPrepayItemPK (implements java.io.Serializable)
    • bb.common.ApPrepaymentCheckRunItemAgent (implements java.io.Serializable)
    • bb.common.ApprovedGLResult (implements java.io.Serializable)
    • bb.common.APTaxForZipcodeListResult (implements java.io.Serializable)
    • bb.common.ARAllStatementsListResult (implements java.io.Serializable)
    • bb.common.ARAuditListResult (implements bb.common.Alarmable, java.io.Serializable)
    • bb.common.ArCommissionListResult (implements java.io.Serializable)
    • bb.common.ArCommissionTotalResult (implements java.io.Serializable)
    • bb.common.ArPaymentRunItemAgent (implements java.io.Serializable)
    • bb.common.ARPaymentRunItemPK (implements java.io.Serializable)
    • bb.common.ARPaymentRunListResult (implements java.io.Serializable)
    • bb.common.ARPrepayAllStatementsListResult (implements java.io.Serializable)
    • bb.common.ARPrepayInfoResult (implements java.io.Serializable)
    • bb.common.ArPrepayItemPK (implements java.io.Serializable)
    • bb.common.ArPrepaymentRunItemAgent (implements java.io.Serializable)
    • bb.common.ARPrepaymentWireTransferAgent (implements java.io.Serializable)
    • bb.common.ARTaxForZipcodeListResult (implements java.io.Serializable)
    • bb.common.AssetAddOrDisposalsReport (implements java.io.Serializable)
    • bb.common.AssetAmortizationExpenseAccountPK (implements java.io.Serializable)
    • bb.common.AssetDepreciatePK (implements java.io.Serializable)
    • bb.common.AssetUsagePK (implements java.io.Serializable)
    • bb.common.AuditOnDemandResult (implements java.io.Serializable)
    • bb.common.BalanceSheetSideBySideItemResult (implements java.io.Serializable)
    • bb.common.BalanceSheetSideBySideResult (implements java.io.Serializable)
    • bb.common.BB2AttachFile (implements java.io.Serializable)
    • bb.common.BB2BigDecimalAndString (implements java.lang.Comparable<T>, java.io.Serializable)
    • bb.common.BB2BugNotice (implements java.io.Serializable)
    • bb.common.BB2Document (implements java.io.Serializable)
    • bb.common.BB2DoubleCost (implements java.io.Serializable)
    • bb.common.BB2DoubleString (implements java.lang.Comparable<T>, java.io.Serializable)
    • bb.common.BB2Event (implements java.io.Serializable)
      • bb.common.I18nEvent
    • bb.common.BB2File (implements java.io.Serializable)
      • bb.common.BB2Picture
    • bb.common.BB2FiscalYearDate (implements java.io.Serializable)
    • bb.common.BB2Login (implements java.io.Serializable)
    • bb.common.BB2Notice (implements java.io.Serializable)
    • bb.common.BB2Part (implements java.lang.Comparable<T>, java.io.Serializable)
    • bb.common.BB2PartBasicInfo (implements java.io.Serializable)
      • bb.common.BB2PartInfo (implements java.io.Serializable)
        • bb.common.BB2PartMrpResult (implements java.io.Serializable)
      • bb.common.BB2PartTotalInQADetailResult (implements java.io.Serializable)
      • bb.common.BB2PartTotalInSipDetailResult (implements java.io.Serializable)
      • bb.common.BB2PartTotalInSitDetailResult (implements java.io.Serializable)
      • bb.common.BB2PartTotalInSTODetailResult (implements java.io.Serializable)
      • bb.common.BB2PartTotalInWipDetailResult (implements java.io.Serializable)
      • bb.common.BB2PartTotalOndemandDetailResult (implements java.io.Serializable)
      • bb.common.BB2PartTotalOnhandDetailResult (implements java.io.Serializable)
      • bb.common.BB2PartTotalOnloanDetailResult (implements java.io.Serializable)
      • bb.common.BB2PartTotalOnorderDetailResult (implements java.io.Serializable)
    • bb.common.BB2PartByDateResult (implements java.io.Serializable)
    • bb.common.BB2PartInSipItemResult (implements java.io.Serializable)
    • bb.common.BB2PartInSipOfSoItemResult (implements java.io.Serializable)
    • bb.common.BB2PartInSitItemResult (implements java.io.Serializable)
    • bb.common.BB2PartInSTOItemResult (implements java.io.Serializable)
    • bb.common.BB2PartInventoryResult (implements java.io.Serializable)
    • bb.common.BB2PartOnDemandListResult (implements java.io.Serializable)
    • bb.common.BB2PartOnhandPK (implements java.io.Serializable)
    • bb.common.BB2PartOnLoanItemResult (implements java.io.Serializable)
    • bb.common.BB2QtyAndMoneyMap (implements java.io.Serializable)
    • bb.common.BB2RefdocPK (implements java.io.Serializable)
    • bb.common.BB2Task (implements java.io.Serializable)
    • bb.common.BB2TimeFactory
    • bb.common.BB2tripleString (implements java.io.Serializable)
    • bb.common.BB2Util
    • bb.common.BB2WeightInfoResult (implements java.io.Serializable)
    • bb.common.BB2Zip
    • bb.common.BillDetailCostResult (implements java.io.Serializable)
    • bb.common.BillItemPK (implements java.io.Serializable)
    • bb.common.BillItemSalesResult (implements java.io.Serializable)
    • bb.common.BillItemSalesXResult (implements java.io.Serializable)
    • bb.common.BillItemUsagePathResult (implements java.io.Serializable)
    • bb.common.BillPK (implements java.io.Serializable)
    • bb.common.BillSalesOfCostResult (implements java.io.Serializable)
    • bb.common.BillSalesResult (implements java.io.Serializable)
    • bb.common.BillSalesXResult (implements java.io.Serializable)
    • bb.common.BillWhereUsedItemResult (implements java.io.Serializable)
    • bb.common.BillWhereUsedResult (implements java.io.Serializable)
    • bb.common.BizBoxServer (implements java.io.Serializable)
    • bb.common.BizBoxUserEmployeeResult (implements java.io.Serializable)
    • bb.common.BIZReason
    • bb.common.BizTarget
    • bb.common.BOMCanAssyAgent (implements java.io.Serializable)
    • bb.common.BOMCanAssyListResult (implements java.io.Serializable)
    • bb.common.BomItemWithOEMResult (implements java.io.Serializable)
    • bb.common.BomPickListItemResult (implements java.io.Serializable)
    • bb.common.BomPickListResult (implements java.io.Serializable)
    • bb.common.BOMTreeRollUPMap (implements java.io.Serializable)
    • bb.common.BomWithOEMResult (implements java.io.Serializable)
    • bb.common.BudgetListResult (implements java.io.Serializable)
    • bb.common.CarrierPK (implements java.io.Serializable)
    • bb.common.CashFlowByMonthReportResult (implements java.io.Serializable)
    • bb.common.CashFlowMonthTotalResult (implements java.io.Serializable)
    • bb.common.ChangeStdCostWorkSheetItemPK (implements java.io.Serializable)
    • bb.common.CheckRunItemTotalResult (implements java.io.Serializable)
    • bb.common.ClientAutoInvokeMethodsManager
    • bb.common.ClientListItem (implements java.io.Serializable)
    • bb.common.ClosingStatementItemResult (implements java.io.Serializable)
    • bb.common.ClosingStatementResult (implements java.io.Serializable)
    • bb.common.ClosingStatementTotalResult (implements java.io.Serializable)
    • bb.common.CompanyUnitAccountPK (implements java.io.Serializable)
    • bb.common.Configure
    • bb.common.Configure.LoginStatus
    • bb.common.Configure.Module
    • bb.common.Configure.Organization
    • bb.common.Configure.UpdatePermission
    • bb.common.Configure.UserLocked
    • bb.common.Configure.UserType
    • bb.common.Constant
    • bb.common.Constant.ActiveStatus
    • bb.common.Constant.AddressType
    • bb.common.Constant.AgeLevel
    • bb.common.Constant.AmountType
    • bb.common.Constant.ARDiscountMethod
    • bb.common.Constant.CategoryReportType
    • bb.common.Constant.CategoryType
    • bb.common.Constant.ChartOfAccountSubType
    • bb.common.Constant.ChartOfAccountType
    • bb.common.Constant.CheckType
    • bb.common.Constant.CostControl
    • bb.common.Constant.CustomerVendorMailType
    • bb.common.Constant.CVAddressType
    • bb.common.Constant.CycleCountPeriodUnit
    • bb.common.Constant.DataFilterType
    • bb.common.Constant.DateType
    • bb.common.Constant.DebitOrCredit
    • bb.common.Constant.Depreciation
    • bb.common.Constant.Depreciation.DepreciateStatus
    • bb.common.Constant.Depreciation.DepreciationMethod
    • bb.common.Constant.Depreciation.UsingType
    • bb.common.Constant.Download
    • bb.common.Constant.DrawingType
    • bb.common.Constant.ECRPriority
    • bb.common.Constant.EmployeeSecurityLevel
    • bb.common.Constant.EmployeeStatus
    • bb.common.Constant.EngineeringSharingImportDataType
    • bb.common.Constant.EngineeringSharingImportType
    • bb.common.Constant.EquipmentStatus
    • bb.common.Constant.ExchangeRateType
    • bb.common.Constant.FileExt
    • bb.common.Constant.GLApprovedType
    • bb.common.Constant.GLStyle
    • bb.common.Constant.GLType
    • bb.common.Constant.InventoryCostMothed
    • bb.common.Constant.InventoryWorkSheetOrderBy
    • bb.common.Constant.IrDateType
    • bb.common.Constant.IRType
    • bb.common.Constant.IssuedFrom
    • bb.common.Constant.LanguageCode
    • bb.common.Constant.LocalSettings
    • bb.common.Constant.LoginType
    • bb.common.Constant.MakeBuy
    • bb.common.Constant.MiscDocType
    • bb.common.Constant.NaRecTo
    • bb.common.Constant.NcrApprovableType
    • bb.common.Constant.NoticeAction
    • bb.common.Constant.NoticeType
    • bb.common.Constant.OITypeSerialNumberType
    • bb.common.Constant.OrderType
    • bb.common.Constant.Package
    • bb.common.Constant.PageCycleCount
    • bb.common.Constant.PAOffsetType
    • bb.common.Constant.PartFrom
    • bb.common.Constant.PartNumberGenerateType
    • bb.common.Constant.PartQtyType
    • bb.common.Constant.PayableMethod
    • bb.common.Constant.PeriodUnit
    • bb.common.Constant.PosOrderType
    • bb.common.Constant.Prefix
    • bb.common.Constant.PrintTemplateType
    • bb.common.Constant.ReceiveCondition
    • bb.common.Constant.ReceivedTo
    • bb.common.Constant.SalesTaxReportType
    • bb.common.Constant.SGType
    • bb.common.Constant.StatementType
    • bb.common.Constant.Status
    • bb.common.Constant.SystemUserGroup
    • bb.common.Constant.TaxType
    • bb.common.Constant.TermsConditonType
    • bb.common.Constant.TrackingNumberType
    • bb.common.Constant.TransactionType
    • bb.common.Constant.TransferType
    • bb.common.Constant.Upload
    • bb.common.Constant.VendorQualityStatus
    • bb.common.Constant.WorkCenterSearchType
    • bb.common.Constant.WorkCenterType
    • bb.common.Constant.WorkLevel
    • bb.common.Constant.YesNO
    • bb.common.ContractPriceCustomerPK (implements java.io.Serializable)
    • bb.common.ContractPriceItemPK (implements java.io.Serializable)
    • bb.common.CopyUtil
    • bb.common.CPItemFromQuoteResult (implements java.io.Serializable)
    • bb.common.CRTVItemListResult (implements java.io.Serializable)
    • bb.common.CRTVListResult (implements java.io.Serializable)
    • bb.common.CSRAgent (implements java.io.Serializable)
    • bb.common.CurrencyExchangePK (implements java.io.Serializable)
    • bb.common.CurrentBalanceResult (implements java.io.Serializable)
    • bb.common.CustomAssetRecordPK (implements java.io.Serializable)
    • bb.common.CustomEmployeeTrainPK (implements java.io.Serializable)
    • bb.common.CustomerCLimitResult (implements java.io.Serializable)
    • bb.common.CustomerPrepayStatementListResult (implements java.io.Serializable)
    • bb.common.CustomerReturnToVendorItemPK (implements java.io.Serializable)
    • bb.common.CustomerServiceIncidentItemListResult (implements java.io.Serializable)
    • bb.common.CustomerServiceIncidentListResult (implements java.io.Serializable)
    • bb.common.CustomerStatementListResult (implements java.io.Serializable)
    • bb.common.CustomerStatementResult (implements java.io.Serializable)
    • bb.common.CustomerStatementTotalResult (implements java.io.Serializable)
    • bb.common.CustomerVendorAddressTotalInfo (implements java.io.Serializable)
    • bb.common.CustomerVendorContactPK (implements java.io.Serializable)
    • bb.common.CustomerVendorDescriptionPK (implements java.io.Serializable)
    • bb.common.CustomJobCategoryGoodsPK (implements java.io.Serializable)
    • bb.common.CV2CVAgent (implements java.io.Serializable)
    • bb.common.CycleCountAgent (implements java.io.Serializable)
    • bb.common.CycleCountListResult (implements java.io.Serializable)
    • bb.common.CycleCountListTotalResult (implements java.io.Serializable)
    • bb.common.CycleCountPK (implements java.io.Serializable)
    • bb.common.DBReason
    • bb.common.DebitsCreditsResult (implements java.io.Serializable)
    • bb.common.DepositSummaryResult (implements java.io.Serializable)
    • bb.common.DepreciateMonthlyReport (implements java.io.Serializable)
    • bb.common.DesignControlListResult (implements java.io.Serializable)
    • bb.common.DisassembleWorkOrderIssuingItemResult (implements java.io.Serializable)
    • bb.common.DisassembleWorkOrderIssuingResult (implements java.io.Serializable)
    • bb.common.DisassembleWorkOrderItemListResult (implements java.io.Serializable)
    • bb.common.DisassembleWorkOrderItemPartDetailItemResult (implements java.io.Serializable)
    • bb.common.DisassembleWorkOrderItemPartDetailResult (implements java.io.Serializable)
    • bb.common.DisassembleWorkOrderItemPK (implements java.lang.Comparable<T>, java.io.Serializable)
    • bb.common.DisassembleWorkOrderItemReceiverPK (implements java.io.Serializable)
    • bb.common.DisassembleWorkOrderListResult (implements java.io.Serializable)
    • bb.common.DisassembleWorkOrderReceivingResult (implements java.io.Serializable)
    • bb.common.DocumentAction
    • bb.common.DocumentAction.DwfAndDwgDocAction
    • bb.common.DocumentAction.MiscDocAction
    • bb.common.DocumentAction.PartDocAction
    • bb.common.DocumentInfoAgent (implements java.io.Serializable)
    • bb.common.DuePATotalByVendorResult (implements java.io.Serializable)
    • bb.common.DWOIssueDetail (implements java.io.Serializable)
    • bb.common.DynamicSearchFilter (implements java.io.Serializable)
    • bb.common.EcnCheckOrderResult (implements java.io.Serializable)
    • bb.common.EcnPOOrderResult (implements java.io.Serializable)
    • bb.common.EcnWOOrderResult (implements java.io.Serializable)
    • bb.common.EmployeeEducationPK (implements java.io.Serializable)
    • bb.common.EmployeeLaborAgent (implements java.io.Serializable)
    • bb.common.EmployeePutGoodListResult (implements java.io.Serializable)
    • bb.common.EmployeeTimeCardResult (implements java.io.Serializable)
    • bb.common.EmployeeWorkExperiencePK (implements java.io.Serializable)
    • bb.common.EngGroupUserPK (implements java.io.Serializable)
    • bb.common.EngineeringChangeListResult (implements java.io.Serializable)
    • bb.common.EngineeringChangeRequestListResult (implements java.io.Serializable)
    • bb.common.EngineeringInfoCenterResult (implements java.io.Serializable)
    • bb.common.EngineeringSharingItemPK (implements java.io.Serializable)
    • bb.common.EquipmentListResult (implements java.io.Serializable)
    • bb.common.ExchangeAuditItemResult (implements java.io.Serializable)
    • bb.common.ExchangeAuditResult (implements java.io.Serializable)
    • bb.common.ExpenseItemPK (implements java.io.Serializable)
    • bb.common.ExpenseListResult (implements java.io.Serializable)
    • bb.common.FeedbackAnswerPK (implements java.io.Serializable)
    • bb.common.FeedBackItemPK (implements java.io.Serializable)
    • bb.common.FinishProformaReceiverAgent (implements java.io.Serializable)
    • bb.common.GeneralLedgerByDateListResult (implements java.io.Serializable)
    • bb.common.GeneralLedgerEntry (implements java.io.Serializable)
    • bb.common.GeneralLedgerListResult (implements java.io.Serializable)
      • bb.common.GLDebitCreditListResult (implements java.io.Serializable)
    • bb.common.GeneralLedgerPrintResult (implements java.io.Serializable)
    • bb.common.GeneralLedgerResult (implements java.io.Serializable)
    • bb.common.GLApprovalListResult (implements java.io.Serializable)
    • bb.common.GlBalanceInfoResult (implements java.io.Serializable)
    • bb.common.GLByDateTotalResult (implements java.io.Serializable)
    • bb.common.GLCatAndSequence (implements java.io.Serializable)
    • bb.common.GLCheckRegisterResult (implements java.io.Serializable)
    • bb.common.GLInfoByPeriodResult (implements java.io.Serializable)
    • bb.common.GroupUserPK (implements java.io.Serializable)
    • bb.common.HighUsagePartResult (implements java.io.Serializable)
    • bb.common.HistoricalInventoryTotalResult (implements java.io.Serializable)
    • bb.common.IcrListResult (implements java.io.Serializable)
    • bb.common.IncomeByMonthChartResult (implements java.io.Serializable)
    • bb.common.InfoByFiscalChartResult (implements java.io.Serializable)
    • bb.common.InfoByMonthChartResult (implements java.io.Serializable)
    • bb.common.InfoByMonthResult (implements java.io.Serializable)
    • bb.common.InSipAudittListResult (implements java.io.Serializable)
    • bb.common.InspectionConformanceReportItemCheckPK (implements java.io.Serializable)
    • bb.common.InspectionConformanceReportItemInfo (implements java.io.Serializable)
    • bb.common.InspectionConformanceReportItemPK (implements java.io.Serializable)
    • bb.common.InspectionItemPK (implements java.io.Serializable)
    • bb.common.InspectionReportInspectMethodItemPK (implements java.io.Serializable)
    • bb.common.InspectionReportInspectStandardItemPK (implements java.io.Serializable)
    • bb.common.InspectionReportItemPK (implements java.io.Serializable)
    • bb.common.InspectionReportItemQtyPK (implements java.io.Serializable)
    • bb.common.InspectionTypeItemPK (implements java.io.Serializable)
    • bb.common.InventoryAdjustmentDetailResult (implements java.io.Serializable)
    • bb.common.InventoryAmountByMonth (implements java.io.Serializable)
    • bb.common.InventoryCycleItemResult (implements java.io.Serializable)
    • bb.common.InventoryCycleResult (implements java.io.Serializable)
    • bb.common.InventoryListResult (implements java.io.Serializable)
    • bb.common.InventoryMonthReport (implements java.io.Serializable)
    • bb.common.InventoryNotUsedInMonthsResult (implements java.io.Serializable)
      • bb.common.InventoryNotUsedInMonthsforAppResult
    • bb.common.InventoryNotUsedTotal (implements java.io.Serializable)
    • bb.common.InventoryReportListResult (implements java.io.Serializable)
      • bb.common.InventoryAuditReportResult (implements java.io.Serializable)
    • bb.common.InventoryTotalCostResult (implements java.io.Serializable)
    • bb.common.InventoryTotalResult (implements java.io.Serializable)
    • bb.common.InvoiceItemListResult (implements java.io.Serializable)
      • bb.common.CheckInvoiceItemListResult
      • bb.common.InvoiceAgingItemListResult (implements java.io.Serializable)
    • bb.common.IssuedFromOrderItem (implements java.io.Serializable)
    • bb.common.IssueItemAgent (implements java.io.Serializable)
    • bb.common.IssueItemDetailAgent (implements java.io.Serializable)
    • bb.common.IssuingItemResult (implements java.io.Serializable)
    • bb.common.IssuingResult (implements java.io.Serializable)
    • bb.common.JobProcessSheetItemResult (implements java.io.Serializable)
    • bb.common.JobProcessSheetListResult (implements java.io.Serializable)
    • bb.common.JobProcessSheetResult (implements java.io.Serializable)
    • bb.common.JounalEntryListResult (implements java.io.Serializable)
    • bb.common.LabelTemplateConstant (implements java.io.Serializable)
    • bb.common.LabelTemplateItemPK (implements java.io.Serializable)
    • bb.common.ListCache (implements java.io.Serializable)
    • bb.common.LnShipperItemListResult (implements java.io.Serializable)
    • bb.common.LnShipperListResult (implements java.io.Serializable)
    • bb.common.LocationResult (implements java.io.Serializable)
    • bb.common.LockedCustomerAddressResult (implements bb.common.Alarmable, java.io.Serializable)
    • bb.common.LogInventoryListResult (implements java.io.Serializable)
    • bb.common.LogMethodPK (implements java.io.Serializable)
    • bb.common.MaintenanceItemPK (implements java.io.Serializable)
    • bb.common.MakeAccountPayableAgent (implements java.io.Serializable)
    • bb.common.MakeBillAndHoldInvoiceAgent (implements java.io.Serializable)
    • bb.common.MakeCheckAgent (implements java.io.Serializable)
    • bb.common.MakeCreditMemoAgent (implements java.io.Serializable)
    • bb.common.MakeDebitMemoAgent (implements java.io.Serializable)
    • bb.common.MakeInvoiceAgent (implements java.io.Serializable)
    • bb.common.MakePrepaymentCheckAgent (implements java.io.Serializable)
    • bb.common.ManufacturerContactPK (implements java.io.Serializable)
    • bb.common.ManufacturerDescriptionPK (implements java.io.Serializable)
    • bb.common.MessageAgent (implements java.io.Serializable)
    • bb.common.MfrMpnListResult (implements java.io.Serializable)
    • bb.common.MiscDocAgent (implements java.io.Serializable)
    • bb.common.Money (implements java.io.Serializable)
    • bb.common.MoneyInDrawResult (implements java.io.Serializable)
    • bb.common.MonthBalanceResult (implements java.io.Serializable)
    • bb.common.MonthSoOrArByCustomerResult (implements java.io.Serializable)
    • bb.common.MrpByMonthResult (implements java.lang.Cloneable, java.io.Serializable)
    • bb.common.MrpItemOrderDemandRecordsResult (implements java.io.Serializable)
    • bb.common.MrpItemResult (implements java.io.Serializable)
    • bb.common.MrpReportAgent (implements java.io.Serializable)
    • bb.common.MultiLanguageAccountsChartPK (implements java.io.Serializable)
    • bb.common.MyPrintListPK (implements java.io.Serializable)
    • bb.common.NCQRejectResult (implements java.io.Serializable)
    • bb.common.NcrApprovalPK (implements java.io.Serializable)
    • bb.common.NcrNeedToScrapListResult (implements java.io.Serializable)
    • bb.common.NCRPartOnhandPK
    • bb.common.NCRPictureListResult (implements java.io.Serializable)
    • bb.common.NcrReportListResult (implements java.io.Serializable)
    • bb.common.NcrScrapAgent (implements java.io.Serializable)
    • bb.common.NonConformanceCodeDescriptionPK (implements java.io.Serializable)
    • bb.common.NonConformanceQuantityPK (implements java.io.Serializable)
    • bb.common.NonConformanceReportResult (implements java.io.Serializable)
    • bb.common.NonproductivePickingItemIssuedListResult (implements java.io.Serializable)
    • bb.common.NonproductivePickingItemPK (implements java.io.Serializable)
    • bb.common.NonproductivePickingItemResult (implements java.io.Serializable)
    • bb.common.NonproductivePickingOnDemandResult (implements java.io.Serializable)
    • bb.common.NoticeUserEmployeeListResult (implements java.io.Serializable)
    • bb.common.OnhandQualityResult (implements java.io.Serializable)
    • bb.common.OnLoanItemListResult (implements java.io.Serializable)
    • bb.common.OnLoanItemPK (implements java.io.Serializable)
    • bb.common.OnLoanListResult (implements java.io.Serializable)
    • bb.common.OnloanReceiverItemListResult (implements java.io.Serializable)
    • bb.common.OnloanReceiverItemPK (implements java.io.Serializable)
    • bb.common.OnloanReceiverListResult (implements java.io.Serializable)
    • bb.common.OnloanShipperItemPK (implements java.io.Serializable)
    • bb.common.OnTimeAgent (implements java.io.Serializable)
    • bb.common.OntimeDeliveryRateListResult (implements java.io.Serializable)
    • bb.common.OntimeDeliveryRateResult (implements java.io.Serializable)
    • bb.common.OpCodeShortcutPK (implements java.lang.Comparable<T>, java.io.Serializable)
    • bb.common.OperatingInstructionsInspectMethodItemPK (implements java.io.Serializable)
    • bb.common.OperatingInstructionsInspectResultItemPK (implements java.io.Serializable)
    • bb.common.OperatingInstructionsInspectStandardItemPK (implements java.io.Serializable)
    • bb.common.OperatingInstructionsManualItemPK (implements java.io.Serializable)
    • bb.common.OperatingInstructionsUserStatisticalResult (implements java.io.Serializable)
    • bb.common.OperatingOutputFileItemPK (implements java.io.Serializable)
    • bb.common.OrderBoilerplatePK (implements java.io.Serializable)
    • bb.common.OrderBy (implements java.io.Serializable)
    • bb.common.OrderDemandForReceiverResult (implements java.io.Serializable)
    • bb.common.OrderPK (implements java.io.Serializable)
    • bb.common.OrderVendorItem (implements java.io.Serializable)
    • bb.common.OutputValueByMonthResult (implements java.io.Serializable)
    • bb.common.PackingBoxItemListResult (implements java.io.Serializable)
    • bb.common.PackingBoxItemPK (implements java.io.Serializable)
    • bb.common.PackingBoxPK (implements java.io.Serializable)
    • bb.common.PackingBoxSalesOrderItemAgent (implements java.io.Serializable)
    • bb.common.PackingBoxSalesOrderItemResult (implements java.io.Serializable)
    • bb.common.PartBasicInfo (implements java.io.Serializable)
      • bb.common.BillItemSalesCostResult (implements java.io.Serializable)
      • bb.common.BillItemUsageResult (implements java.io.Serializable)
        • bb.common.BillItemOnHandUsageResult (implements java.io.Serializable)
      • bb.common.BillItemWithPartInfoResult (implements java.io.Serializable)
        • bb.common.BillItemDetailCostWithPartInfoResult (implements java.io.Serializable)
        • bb.common.BillItemOnHandWithPartInfoResult (implements java.io.Serializable)
          • bb.common.MasterWorkOrderTreeItemResult (implements java.io.Serializable)
      • bb.common.BillSalesCostResult (implements java.io.Serializable)
      • bb.common.BillWithPartInfoResult (implements java.io.Serializable)
        • bb.common.BillDetailCostWithPartInfoResult (implements java.io.Serializable)
        • bb.common.BillOnHandWithPartInfoResult (implements java.io.Serializable)
      • bb.common.PartBasicInfoWithNewEngGroup (implements java.io.Serializable)
      • bb.common.PartBasicInfoWithNewListPrice (implements java.io.Serializable)
      • bb.common.PartExportInfo (implements java.io.Serializable)
      • bb.common.PartMaterialListResult (implements java.io.Serializable)
        • bb.common.PartMaterialBomListResult (implements java.io.Serializable)
      • bb.common.PartOnHandWithMfgInfoResult (implements java.io.Serializable)
      • bb.common.PartOnHandWithPartBasicInfoResult (implements java.io.Serializable)
      • bb.common.PartTraceableListResult (implements java.io.Serializable)
      • bb.common.PartTraceableResult (implements java.io.Serializable)
      • bb.common.PartWithOnhandDetailInfoResult (implements java.io.Serializable)
      • bb.common.PartWithoutLocateResult
      • bb.common.ToolBasicInfo (implements java.io.Serializable)
        • bb.common.ToolListItemWithToolInfoResult (implements java.io.Serializable)
          • bb.common.ToolListItemDetailCostWithToolInfoResult (implements java.io.Serializable)
        • bb.common.ToolListWithToolInfoResult (implements java.io.Serializable)
          • bb.common.ToolListDetailCostWithToolInfoResult (implements java.io.Serializable)
    • bb.common.PartCatagoryPK (implements java.io.Serializable)
    • bb.common.PartCatalogAuditResult (implements bb.common.Alarmable, java.io.Serializable)
    • bb.common.PartCatalogPK (implements java.io.Serializable)
    • bb.common.PartCertificateListResult (implements java.io.Serializable)
    • bb.common.PartClassInfoResult (implements java.io.Serializable)
    • bb.common.PartCostVarianceListResult (implements java.io.Serializable)
    • bb.common.PartDescriptionPK (implements java.io.Serializable)
    • bb.common.PartDiscountPK (implements java.io.Serializable)
    • bb.common.PartDocumentPK (implements java.io.Serializable)
    • bb.common.PartDueAddressListResult (implements java.io.Serializable)
    • bb.common.PartDwfAgent (implements java.io.Serializable)
    • bb.common.PartDwfPK (implements java.io.Serializable)
    • bb.common.PartDwfWithPartInfoResult (implements java.io.Serializable)
    • bb.common.PartDwgAgent (implements java.io.Serializable)
    • bb.common.PartDwgPK (implements java.io.Serializable)
    • bb.common.PartDwgWithPartInfoResult (implements java.io.Serializable)
    • bb.common.PartInMrpListResult (implements java.io.Serializable)
    • bb.common.PartInQAAgent (implements java.io.Serializable)
    • bb.common.PartInspectionPK (implements java.io.Serializable)
    • bb.common.PartInspectionResult (implements java.io.Serializable)
    • bb.common.PartInWipForIDListResult (implements java.io.Serializable)
    • bb.common.PartIssueTotalResult (implements java.io.Serializable)
    • bb.common.PartManufacturerAgent
    • bb.common.PartManufacturerPK (implements java.io.Serializable)
    • bb.common.PartMaterialReportAgent (implements java.io.Serializable)
    • bb.common.PartMaterialWhereUsedItemResult (implements java.io.Serializable)
    • bb.common.PartMaterialWhereUsedResult (implements java.io.Serializable)
    • bb.common.PartOnhandAndCostResult (implements java.io.Serializable)
    • bb.common.PartOnHandAuditAgent (implements java.io.Serializable)
    • bb.common.PartOnHandAuditResult (implements bb.common.Alarmable, java.io.Serializable)
    • bb.common.PartOnhandPK (implements java.io.Serializable)
    • bb.common.PartOnhandResult (implements java.io.Serializable)
    • bb.common.PartOnhandWithAverageCostResult (implements java.io.Serializable)
    • bb.common.PartPK (implements java.lang.Comparable<T>, java.io.Serializable)
    • bb.common.PartsToDeleteResult (implements java.io.Serializable)
    • bb.common.PartToAuditFlagResult (implements java.io.Serializable)
    • bb.common.PartTraceableCategoryPK (implements java.io.Serializable)
    • bb.common.PartTraceableInfoResult (implements java.io.Serializable)
    • bb.common.PartTraceableSpecPK (implements java.io.Serializable)
    • bb.common.PartTrackingPK (implements java.io.Serializable)
    • bb.common.PartUnitPK (implements java.io.Serializable)
    • bb.common.partUsedInfoResult (implements java.io.Serializable)
    • bb.common.PartVendorPK (implements java.io.Serializable)
    • bb.common.PartWhereUsedItemResult (implements java.io.Serializable)
    • bb.common.PartWhereUsedResult (implements java.io.Serializable)
    • bb.common.PartWithExcessiveInventoryListResult (implements java.io.Serializable)
    • bb.common.PartWithInventoryInfoListResult (implements java.io.Serializable)
    • bb.common.PartWithManufacturerInfoResult (implements java.io.Serializable)
      • bb.common.ToolWithManufacturerInfoResult (implements java.io.Serializable)
    • bb.common.PartWithOnLoanQtyListResult (implements java.io.Serializable)
    • bb.common.PartWithQAQtyListResult (implements java.io.Serializable)
    • bb.common.PartWithQtyListResult (implements java.io.Serializable)
    • bb.common.PartWithSipQtyListResult (implements java.io.Serializable)
    • bb.common.PartWithSITQtyListResult (implements java.io.Serializable)
    • bb.common.PartWithSTOQtyListResult (implements java.io.Serializable)
    • bb.common.PartWithWipQtyListResult (implements java.io.Serializable)
    • bb.common.PasswordPolicyAgent (implements java.io.Serializable)
    • bb.common.PayableCheckRunItemPK (implements java.io.Serializable)
    • bb.common.PaymentAgent (implements java.io.Serializable)
    • bb.common.PaymentInvoicesResult (implements java.io.Serializable)
    • bb.common.PaymentRunItemTotalResult (implements java.io.Serializable)
    • bb.common.PermissionDescriptionPK (implements java.io.Serializable)
    • bb.common.PermissionListResult (implements java.io.Serializable)
    • bb.common.PermissionMethodPK (implements java.io.Serializable)
    • bb.common.PfReceiverItemPK (implements java.io.Serializable)
    • bb.common.PfReceiverItemWithNumberPK (implements java.io.Serializable)
    • bb.common.PhysicalInventoryListResult (implements java.io.Serializable)
      • bb.common.PhysicalInventoryListWithAppDataResult (implements java.io.Serializable)
    • bb.common.PhysicalInventoryListTotalResult (implements java.io.Serializable)
    • bb.common.PhysicalInventoryPK (implements java.io.Serializable)
    • bb.common.PO2POAgent (implements java.io.Serializable)
    • bb.common.PO2SOExchange (implements java.io.Serializable)
    • bb.common.PO2SOExchangeItem (implements java.io.Serializable)
    • bb.common.PO2SOExchangeItemManufacturer (implements java.io.Serializable)
    • bb.common.POAndWOStatusResult (implements java.io.Serializable)
    • bb.common.POForWISeqAgent (implements java.io.Serializable)
    • bb.common.PoMessageItemPK (implements java.io.Serializable)
    • bb.common.PoMessageListResult (implements java.io.Serializable)
    • bb.common.PoReceiverByDateSummaryResult (implements java.io.Serializable)
    • bb.common.POReceiverItemListResult (implements java.io.Serializable)
    • bb.common.POStatisticsResult (implements java.io.Serializable)
    • bb.common.PostCheckAgent (implements java.io.Serializable)
    • bb.common.POSurveyReportAgent (implements java.io.Serializable)
    • bb.common.POSurveyReportItemPK (implements java.io.Serializable)
    • bb.common.PosZipCodeTaxPK (implements java.io.Serializable)
    • bb.common.PrepayAgent (implements java.io.Serializable)
    • bb.common.PrepaymentWireTransferAgent (implements java.io.Serializable)
    • bb.common.PrepayPaymentAgent (implements java.io.Serializable)
    • bb.common.ProfitAndLossAccountsResult (implements java.io.Serializable)
    • bb.common.ProfitLossStatementItemResult (implements java.io.Serializable)
    • bb.common.ProfitLossStatementResult (implements java.io.Serializable)
    • bb.common.ProformaInvoiceItemListResult (implements java.io.Serializable)
    • bb.common.ProformaInvoiceItemManufacturerPK (implements java.io.Serializable)
    • bb.common.ProformaInvoiceItemPK (implements java.io.Serializable)
    • bb.common.ProformaInvoiceListResult (implements java.io.Serializable)
    • bb.common.ProformaReceiverPackingBoxAgent (implements java.io.Serializable)
    • bb.common.ProformaReceiverPackingBoxItemAgent (implements java.io.Serializable)
    • bb.common.PrPackingBoxItemPK (implements java.lang.Comparable<T>, java.io.Serializable)
    • bb.common.PrPackingBoxPK (implements java.io.Serializable)
    • bb.common.PrReceiverListResult (implements java.io.Serializable)
    • bb.common.PrReceiverWithQualityListResult (implements java.io.Serializable)
    • bb.common.PullFromWorkOrderPartDetailAgent (implements java.io.Serializable)
    • bb.common.PurchaseOnTimeResult (implements java.io.Serializable)
    • bb.common.PurchaseOrderCheckListResult (implements java.io.Serializable)
    • bb.common.PurchaseOrderContractResult (implements java.io.Serializable)
    • bb.common.PurchaseOrderItemListResult (implements java.io.Serializable)
      • bb.common.POItemByRefDoc1ListResult
    • bb.common.PurchaseOrderItemManufacturerPK (implements java.io.Serializable)
    • bb.common.PurchaseOrderItemPK (implements java.io.Serializable)
    • bb.common.PurchaseOrderListResult (implements java.io.Serializable)
    • bb.common.PurchaseOrderOnOrderResult (implements java.io.Serializable)
    • bb.common.PurchaseOrderOnTimeItemResult (implements java.io.Serializable)
    • bb.common.PurchaseOrderOnTimeResult (implements java.io.Serializable)
    • bb.common.PurchaseOrderOpenDueListResult (implements java.io.Serializable)
    • bb.common.PurchaseWorkSheetItemPK (implements java.io.Serializable)
    • bb.common.PurchaseWorkSheetItemWithRelatedInfoResult (implements java.io.Serializable)
    • bb.common.PurchaseWorkSheetPK (implements java.io.Serializable)
    • bb.common.PurchasingInfoCenterResult (implements java.io.Serializable)
    • bb.common.PuttoInQAAgent (implements java.io.Serializable)
    • bb.common.QtyAndMoney (implements java.io.Serializable)
    • bb.common.QtyDetailResult (implements java.io.Serializable)
    • bb.common.QualityGroupPK (implements java.io.Serializable)
    • bb.common.QualityInfoCenterResult (implements java.io.Serializable)
    • bb.common.Quote2QuoteAgent (implements java.io.Serializable)
    • bb.common.QuoteItemListResult (implements java.io.Serializable)
    • bb.common.QuoteItemManufacturerPK (implements java.io.Serializable)
    • bb.common.QuoteItemPK (implements java.io.Serializable)
    • bb.common.QuoteListResult (implements java.io.Serializable)
    • bb.common.Reason (implements java.io.Serializable)
    • bb.common.RebackInQAAgent (implements java.io.Serializable)
    • bb.common.ReceivedToOrderItem (implements java.io.Serializable)
    • bb.common.ReceiverAgent (implements java.io.Serializable)
    • bb.common.ReceiverItemAgent (implements java.io.Serializable)
    • bb.common.ReceiverItemDetailAgent (implements java.io.Serializable)
    • bb.common.ReceiverItemManufacturerPK (implements java.io.Serializable)
    • bb.common.ReceiverItemPK (implements java.io.Serializable)
    • bb.common.ReceiverItemTrackingLogAgent (implements java.io.Serializable)
    • bb.common.ReceiverShipAgent (implements java.io.Serializable)
    • bb.common.ReceivingItemResult (implements java.io.Serializable)
    • bb.common.ReceivingResult (implements java.io.Serializable)
    • bb.common.RecursiveBillPath (implements java.io.Serializable)
    • bb.common.RefdocElement (implements java.io.Serializable)
    • bb.common.RequestForQuoteCheckListResult (implements java.io.Serializable)
    • bb.common.RequestForQuoteItemListResult (implements java.io.Serializable)
    • bb.common.RequestForQuoteItemManufacturerPK (implements java.io.Serializable)
    • bb.common.RequestForQuoteItemPK (implements java.io.Serializable)
    • bb.common.RequestForQuoteListResult (implements java.io.Serializable)
    • bb.common.RequestForRMAItemPK (implements java.io.Serializable)
    • bb.common.ReturnMaterialAuthorizationItemManufacturerPK (implements java.io.Serializable)
    • bb.common.ReturnMaterialAuthorizationItemPK (implements java.io.Serializable)
    • bb.common.ReturnToVendorByDateListResult (implements java.io.Serializable)
    • bb.common.ReturnToVendorCheckListResult (implements java.io.Serializable)
    • bb.common.ReturnToVendorItemListResult (implements java.io.Serializable)
    • bb.common.ReturnToVendorItemManufacturerPK (implements java.io.Serializable)
    • bb.common.ReturnToVendorItemPK (implements java.io.Serializable)
    • bb.common.ReturnToVendorListResult (implements java.io.Serializable)
    • bb.common.RfqMessageItemPK (implements java.io.Serializable)
    • bb.common.RfqMessageListResult (implements java.io.Serializable)
    • bb.common.RMAItemListResult (implements java.io.Serializable)
    • bb.common.RMAListResult (implements java.io.Serializable)
    • bb.common.RMAReceiverItemListResult (implements java.io.Serializable)
    • bb.common.RMAReceiverItemPK (implements java.io.Serializable)
    • bb.common.RMAReceiverListResult (implements java.io.Serializable)
    • bb.common.RMAReceiverResult (implements java.io.Serializable)
    • bb.common.RoleDescriptionPK (implements java.io.Serializable)
    • bb.common.RoleListResult (implements java.io.Serializable)
    • bb.common.RolePermissionPK (implements java.io.Serializable)
    • bb.common.RollUpBomStdCostWorkSheetItemPK (implements java.io.Serializable)
    • bb.common.RollUPPartStandardCostResult (implements java.io.Serializable)
    • bb.common.RRMAItemListResult (implements java.io.Serializable)
    • bb.common.RRMAListResult (implements java.io.Serializable)
    • bb.common.RtvShipperItemListResult (implements java.io.Serializable)
    • bb.common.RtvShipperItemPK (implements java.io.Serializable)
    • bb.common.RtvShipperListResult (implements java.io.Serializable)
    • bb.common.RunningAccountOrderItemPK (implements java.io.Serializable)
    • bb.common.RunTaxPaymentResult (implements java.io.Serializable)
    • bb.common.SalesBomItemResult (implements java.io.Serializable)
    • bb.common.SalesBomResult (implements java.io.Serializable)
    • bb.common.SalesInfoCenter (implements java.io.Serializable)
    • bb.common.SalesInfoCenter.DueSoCount
    • bb.common.SalesInfoCenter.DueSoSum
    • bb.common.SalesInfoCenter.GrossMargin
    • bb.common.SalesInfoCenter.InvoicedSum
    • bb.common.SalesInfoCenter.OpenSoSum
    • bb.common.SalesInfoCenter.SoCount (implements java.io.Serializable)
    • bb.common.SalesInfoCenter.SoCountWithPartsOnhold
    • bb.common.SalesInfoCenter.SoItemCount (implements java.io.Serializable)
    • bb.common.SalesInfoCenter.SoTotalSum (implements java.io.Serializable)
    • bb.common.SalesInfoCenterResult (implements java.io.Serializable)
    • bb.common.SalesMarginListResult (implements java.io.Serializable)
    • bb.common.SalesOnTimeResult (implements java.io.Serializable)
    • bb.common.SalesOrder12MonthMarginResult (implements java.io.Serializable)
    • bb.common.SalesOrderCheckListResult (implements java.io.Serializable)
    • bb.common.SalesOrderItemCostResult (implements java.io.Serializable)
    • bb.common.SalesOrderItemCustomerTotalResult (implements java.io.Serializable)
    • bb.common.SalesOrderItemGroupByPartListResult (implements java.io.Serializable)
    • bb.common.SalesOrderItemListResult (implements java.io.Serializable)
    • bb.common.SalesOrderItemManufacturerPK (implements java.io.Serializable)
    • bb.common.SalesOrderItemPK (implements java.io.Serializable)
    • bb.common.SalesOrderListResult (implements java.io.Serializable)
    • bb.common.SalesOrderOnDemandResult (implements java.io.Serializable)
      • bb.common.SalesOrderOrphanedResult (implements java.io.Serializable)
    • bb.common.SalesOrderOnTimeItemResult (implements java.io.Serializable)
    • bb.common.SalesOrderOnTimeResult (implements java.io.Serializable)
    • bb.common.SalesOrderShipDateListResult (implements java.io.Serializable)
    • bb.common.SalesPartListItemResult (implements java.io.Serializable)
    • bb.common.SalesPartListResult (implements java.io.Serializable)
    • bb.common.SalesTaxListResult (implements java.io.Serializable)
    • bb.common.ScrapAssetAgent (implements java.io.Serializable)
    • bb.common.SerialNumberItemPK (implements java.io.Serializable)
    • bb.common.SerialNumberItemResult (implements java.io.Serializable)
    • bb.common.SerialNumberPK (implements java.io.Serializable)
    • bb.common.SerialNumberResult (implements java.io.Serializable)
    • bb.common.ServerAction (implements java.io.Serializable)
    • bb.common.ServerClientPropertyPK (implements java.io.Serializable)
    • bb.common.SGBillItemPK (implements java.io.Serializable)
    • bb.common.SGBOMItemResult (implements java.io.Serializable)
    • bb.common.SGBOMResult (implements java.io.Serializable)
    • bb.common.SGCartCheckOutResult (implements java.io.Serializable)
    • bb.common.SGCartLogin (implements java.io.Serializable)
    • bb.common.SGClientAccountPK (implements java.io.Serializable)
    • bb.common.SGClientLogin (implements java.io.Serializable)
    • bb.common.SGCompanyPK (implements java.io.Serializable)
    • bb.common.SGCustomerCatalogPK (implements java.io.Serializable)
    • bb.common.SGCustRequestForQuoteItemPK (implements java.io.Serializable)
    • bb.common.SGCustRequestForQuoteItemResult (implements java.io.Serializable)
    • bb.common.SGCustRequestForQuoteListResult (implements java.io.Serializable)
    • bb.common.SGCustRequestForQuoteResult (implements java.io.Serializable)
    • bb.common.SGDocPartPK (implements java.io.Serializable)
    • bb.common.SGDwgPicturePK (implements java.io.Serializable)
    • bb.common.SGPartCartAgent (implements java.io.Serializable)
    • bb.common.SGPartCatalogResult (implements java.io.Serializable)
    • bb.common.SGPartDocFlagResult (implements java.io.Serializable)
    • bb.common.SGPartListItemResult (implements java.io.Serializable)
    • bb.common.SGPartListResult (implements java.io.Serializable)
    • bb.common.SGPicturePK (implements java.io.Serializable)
    • bb.common.SGQuoteAddressResult (implements java.io.Serializable)
    • bb.common.SGQuoteCartListResult (implements java.io.Serializable)
    • bb.common.SGSaleItemAgent (implements java.io.Serializable)
    • bb.common.ShareHoldersEquityResult (implements java.io.Serializable)
    • bb.common.ShipListAgent (implements java.io.Serializable)
    • bb.common.ShipListItemPK (implements java.io.Serializable)
    • bb.common.ShipListItemRelatedDocResult (implements java.io.Serializable)
    • bb.common.ShipListOwnerAttributePK (implements java.io.Serializable)
    • bb.common.ShipperAgent (implements java.io.Serializable)
    • bb.common.ShipperItemAgent (implements java.io.Serializable)
    • bb.common.ShipperItemDetailAgent (implements java.io.Serializable)
    • bb.common.ShipperItemListResult (implements java.io.Serializable)
    • bb.common.ShipperItemManufacturerPK (implements java.io.Serializable)
    • bb.common.ShipperItemPK (implements java.io.Serializable)
    • bb.common.ShipperListResult (implements java.io.Serializable)
    • bb.common.ShippingItemResult (implements java.io.Serializable)
    • bb.common.ShippingResult (implements java.io.Serializable)
    • bb.common.ShoppingCartItem (implements java.io.Serializable)
    • bb.common.SO2POAgent (implements java.io.Serializable)
    • bb.common.SO2SOAgent (implements java.io.Serializable)
    • bb.common.SO2WOAgent (implements java.io.Serializable)
    • bb.common.SoPickListResult (implements java.io.Serializable)
    • bb.common.SOShipperItemListResult (implements java.io.Serializable)
    • bb.common.Spiderman
    • bb.common.StaffWorkingInformationResult (implements java.io.Serializable)
    • bb.common.StockTransactionAdjustmentResult (implements java.io.Serializable)
    • bb.common.StockTransactionPartInfoResult (implements java.io.Serializable)
    • bb.common.StockTransactionPOReceiverResult (implements java.io.Serializable)
    • bb.common.StockTransactionSOShipperResult (implements java.io.Serializable)
    • bb.common.StockTransactionWOReceiverResult (implements java.io.Serializable)
    • bb.common.StockTransactionWOShipperResult (implements java.io.Serializable)
    • bb.common.StringListConvertor
    • bb.common.SubcompanyLoginAgent (implements java.io.Serializable)
    • bb.common.SwapOrderItemListResult (implements java.io.Serializable)
    • bb.common.SwapOrderItemPK (implements java.io.Serializable)
    • bb.common.SwapReceiverItemListResult (implements java.io.Serializable)
    • bb.common.SwapReceiverItemPK (implements java.io.Serializable)
    • bb.common.SwapReceiverListResult (implements java.io.Serializable)
    • bb.common.SwapShipperItemListResult (implements java.io.Serializable)
    • bb.common.SwapShipperItemPK (implements java.lang.Comparable<T>, java.io.Serializable)
    • bb.common.SwapShipperListResult (implements java.io.Serializable)
    • bb.common.SwapShipperOnOrderResult (implements java.io.Serializable)
    • bb.common.TakeCycleCountAgent (implements java.io.Serializable)
    • bb.common.TaskFileResult (implements java.io.Serializable)
    • bb.common.TermAgent (implements java.io.Serializable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • bb.common.BB2ServerException
          • bb.common.AppException
          • bb.common.BB2DocumentException
          • bb.common.BB2MessagingException
          • bb.common.BizException
          • bb.common.DBAccessException
          • bb.common.InvokeException
          • bb.common.LoginException
        • bb.common.PermissionException
        • bb.common.ServerException
    • bb.common.ToolListDetailCostResult (implements java.io.Serializable)
    • bb.common.ToolOnhandWithAverageCostResult (implements java.io.Serializable)
    • bb.common.ToolWhereUsedItemResult (implements java.io.Serializable)
    • bb.common.ToolWhereUsedResult (implements java.io.Serializable)
    • bb.common.TotalByDateResult (implements java.io.Serializable)
    • bb.common.TransferOrderItemListResult (implements java.io.Serializable)
    • bb.common.TransferOrderItemPK (implements java.io.Serializable)
    • bb.common.TransferOrderListResult (implements java.io.Serializable)
    • bb.common.TransferReceiverItemListResult (implements java.io.Serializable)
    • bb.common.TransferReceiverItemPK (implements java.io.Serializable)
    • bb.common.TransferReceiverListResult (implements java.io.Serializable)
    • bb.common.TransferShipperItemListResult (implements java.io.Serializable)
    • bb.common.TransferShipperItemPK (implements java.io.Serializable)
    • bb.common.TransferShipperListResult (implements java.io.Serializable)
    • bb.common.TwelveMonthCashFlowReportResult (implements java.io.Serializable)
    • bb.common.UpdatePhysicalInventoryAgent (implements java.io.Serializable)
    • bb.common.User2UserAgent (implements java.io.Serializable)
    • bb.common.UserRolePK (implements java.io.Serializable)
    • bb.common.VendorContractPriceItemPK (implements java.io.Serializable)
    • bb.common.VendorContractPriceVendorPK (implements java.io.Serializable)
    • bb.common.VendorPartPK (implements java.lang.Comparable<T>, java.io.Serializable)
    • bb.common.VendorPrepayStatementListResult (implements java.io.Serializable)
    • bb.common.VendorPriceAgent
    • bb.common.VendorQtyPricePK (implements java.io.Serializable)
    • bb.common.VendorStatementListResult (implements java.io.Serializable)
    • bb.common.VendorTotalAmountInPO (implements java.io.Serializable)
      • bb.common.TotalAmountInPOByRefDoc (implements java.io.Serializable)
    • bb.common.VersionInformation
    • bb.common.VO (implements java.io.Serializable)
      • bb.common.AccountCreditVO (implements bb.common.Alarmable, java.io.Serializable)
      • bb.common.AccountDebitVO (implements bb.common.Alarmable, java.io.Serializable)
      • bb.common.AccountingConfigurationVO (implements java.io.Serializable)
      • bb.common.AccountingInfoDocumentVO (implements java.io.Serializable)
      • bb.common.AccountingSettingsVO (implements java.io.Serializable)
      • bb.common.AccountingTransactionTypeVO (implements java.io.Serializable)
      • bb.common.AccountPayableCheckRunItemVO (implements java.io.Serializable)
      • bb.common.AccountPayableCheckRunVO (implements java.io.Serializable)
      • bb.common.AccountPayableCheckVO (implements java.io.Serializable)
      • bb.common.AccountReceivablePaymentVO (implements java.io.Serializable)
      • bb.common.AccountsChartAdvanceCategoryVO (implements java.io.Serializable)
      • bb.common.AccountsChartCategoryVO (implements java.io.Serializable)
        • bb.common.AccountsChartCategoryListResult (implements java.io.Serializable)
      • bb.common.AccountsChartMappingVO (implements java.io.Serializable)
      • bb.common.AccountsChartVO (implements java.io.Serializable)
      • bb.common.AccountsPayableInfoVO (implements java.io.Serializable)
      • bb.common.AccountsPayableItemManufacturerVO (implements java.io.Serializable)
      • bb.common.AccountsPayableItemVO (implements java.io.Serializable)
      • bb.common.AccountsPayableVO (implements java.io.Serializable)
      • bb.common.AccountsReceivableInfoVO (implements java.io.Serializable)
      • bb.common.AccountsReceivableItemManufacturerVO (implements java.io.Serializable)
      • bb.common.AccountsReceivableItemVO (implements java.io.Serializable)
        • bb.common.AccountsReceivableItemResult
      • bb.common.AccountsReceivableVO (implements java.io.Serializable)
      • bb.common.AddressQualityDocumentsVO (implements java.io.Serializable)
      • bb.common.AllPartDocumentsVO (implements java.io.Serializable)
      • bb.common.AppColumnVO (implements java.io.Serializable)
      • bb.common.ApPrepayItemVO (implements java.io.Serializable)
      • bb.common.ApPrepayVO (implements java.io.Serializable)
      • bb.common.ARBoilerplateVO (implements java.io.Serializable)
      • bb.common.ARPaymentRunItemVO (implements java.io.Serializable)
      • bb.common.ARPaymentRunVO (implements java.io.Serializable)
      • bb.common.ArPrepayItemVO (implements java.io.Serializable)
      • bb.common.ArPrepayVO (implements java.io.Serializable)
      • bb.common.AssetAmortizationExpenseAccountVO (implements java.lang.Comparable<T>, java.io.Serializable)
      • bb.common.AssetDepreciateDetailReport (implements java.io.Serializable)
      • bb.common.AssetDepreciateVO (implements java.io.Serializable)
      • bb.common.AssetReportSumResult (implements java.io.Serializable)
      • bb.common.AssetTypeVO (implements java.io.Serializable)
      • bb.common.AssetUsageVO (implements java.io.Serializable)
      • bb.common.AssetVO (implements java.io.Serializable)
      • bb.common.AuditLogVO
      • bb.common.AuditPartInQAResult (implements java.io.Serializable)
      • bb.common.BankReconciliationReportVO
      • bb.common.BillItemReplacementVO (implements java.io.Serializable)
      • bb.common.BillItemVO (implements java.io.Serializable)
      • bb.common.BillLogVO (implements java.io.Serializable)
      • bb.common.BillVO (implements java.io.Serializable)
      • bb.common.BizboxBugChangesInfoVO (implements java.io.Serializable)
      • bb.common.BizboxBugChangesVO (implements java.io.Serializable)
      • bb.common.BizboxBugInfoVO (implements java.io.Serializable)
      • bb.common.BizboxBugVO (implements java.io.Serializable)
      • bb.common.BizboxUserListResult (implements java.io.Serializable)
      • bb.common.BizboxUserVO (implements java.io.Serializable)
      • bb.common.BomApprovalVO (implements java.io.Serializable)
      • bb.common.BuyerCodeVO (implements java.io.Serializable)
      • bb.common.CarrierVO (implements java.io.Serializable)
      • bb.common.CashierVO (implements java.io.Serializable)
      • bb.common.CatalogVO (implements java.io.Serializable)
      • bb.common.CertificateDescriptionVO (implements java.io.Serializable)
      • bb.common.ChangeStdCostWorkSheetItemVO (implements java.io.Serializable)
      • bb.common.ChangeStdCostWorkSheetVO (implements java.io.Serializable)
      • bb.common.CommonPrintTemplateVO
      • bb.common.CompanyUnitAccountVO (implements java.io.Serializable)
      • bb.common.CompanyUnitVO (implements java.io.Serializable)
      • bb.common.CompanyVO (implements java.io.Serializable)
      • bb.common.ContractPriceCustomerVO (implements java.io.Serializable)
      • bb.common.ContractPriceItemVO (implements java.io.Serializable)
      • bb.common.ContractPriceVO (implements java.io.Serializable)
      • bb.common.CorrectiveActionRequestVO (implements java.io.Serializable)
      • bb.common.CurrencyAgent (implements java.io.Serializable)
      • bb.common.CurrencyExchangeVO (implements java.io.Serializable)
      • bb.common.CurrencyVO (implements java.io.Serializable)
      • bb.common.CustomAssetRecordVO (implements java.io.Serializable)
      • bb.common.CustomAssetVO (implements java.io.Serializable)
      • bb.common.CustomCheckUpEmployeeVO (implements java.io.Serializable)
      • bb.common.CustomDepartmentVO (implements java.io.Serializable)
      • bb.common.CustomEmployeeTrainVO (implements java.io.Serializable)
      • bb.common.CustomEmployeeVO (implements java.io.Serializable)
      • bb.common.CustomEmployeeWorkExperienceVO (implements java.io.Serializable)
      • bb.common.CustomerFeedbackVO (implements java.io.Serializable)
      • bb.common.CustomerReturnToVendorItemVO (implements java.io.Serializable)
      • bb.common.CustomerReturnToVendorVO (implements java.io.Serializable)
      • bb.common.CustomerServiceIncidentItemVO (implements java.io.Serializable)
      • bb.common.CustomerServiceIncidentVO (implements java.io.Serializable)
      • bb.common.CustomerVendorAddressInfoVO (implements java.io.Serializable)
      • bb.common.CustomerVendorAddressVO (implements java.io.Serializable)
      • bb.common.CustomerVendorContactVO (implements java.io.Serializable)
      • bb.common.CustomerVendorDescriptionVO (implements java.io.Serializable)
      • bb.common.CustomerVendorTypeVO (implements java.io.Serializable)
      • bb.common.CustomGoodsBreedVO (implements java.io.Serializable)
      • bb.common.CustomGoodsRecordVO (implements java.io.Serializable)
      • bb.common.CustomJobCategoryGoodsVO (implements java.io.Serializable)
      • bb.common.CustomJobCategoryVO (implements java.io.Serializable)
      • bb.common.CustomSearchVO (implements java.io.Serializable)
      • bb.common.CustomTranslationVO (implements java.io.Serializable)
      • bb.common.CycleCountStatusVO (implements java.io.Serializable)
      • bb.common.CycleCountVO (implements java.io.Serializable)
      • bb.common.DataFilterVO
      • bb.common.DepartmentLocationForBackflushVO (implements java.io.Serializable)
      • bb.common.DesignControlDocumentVO (implements java.io.Serializable)
      • bb.common.DesignControlInfoVO (implements java.io.Serializable)
      • bb.common.DesignControlVO (implements java.io.Serializable)
      • bb.common.DisassembleWorkOrderApprovalVO (implements java.io.Serializable)
      • bb.common.DisassembleWorkOrderDocumentVO (implements java.io.Serializable)
      • bb.common.DisassembleWorkOrderIssueVO (implements java.io.Serializable)
      • bb.common.DisassembleWorkOrderItemReceiverVO (implements java.io.Serializable)
      • bb.common.DisassembleWorkOrderItemVO (implements java.io.Serializable)
      • bb.common.DisassembleWorkOrderVO (implements java.io.Serializable)
      • bb.common.DocumentLogVO (implements java.io.Serializable)
      • bb.common.DocumentServerVO (implements java.io.Serializable)
      • bb.common.DwfUploadSettingsVO (implements java.io.Serializable)
      • bb.common.DwgUploadSettingsVO (implements java.io.Serializable)
      • bb.common.ECNReviewVO (implements java.io.Serializable)
      • bb.common.ECRReviewVO (implements java.io.Serializable)
      • bb.common.EjbMethodVO (implements java.io.Serializable)
      • bb.common.EmployeeCardVO (implements java.io.Serializable)
      • bb.common.EmployeeEducationVO (implements java.io.Serializable)
        • bb.common.EmployeeEducationResult
      • bb.common.EmployeeHomeVO (implements java.io.Serializable)
      • bb.common.EmployeeJobDescriptionVO (implements java.io.Serializable)
      • bb.common.EmployeeRecordsVO (implements java.io.Serializable)
      • bb.common.EmployeeTrainingVO (implements java.io.Serializable)
      • bb.common.EmployeeWorkExperienceVO (implements java.io.Serializable)
      • bb.common.EngGroupUserVO (implements java.io.Serializable)
      • bb.common.EngGroupVO (implements java.io.Serializable)
      • bb.common.EngineeringChangeDocumentVO (implements java.io.Serializable)
      • bb.common.EngineeringChangeRequestDocumentVO (implements java.io.Serializable)
      • bb.common.EngineeringChangeRequestVO (implements java.io.Serializable)
      • bb.common.EngineeringChangeVO (implements java.io.Serializable)
      • bb.common.EngineeringSharingImportLogVO
      • bb.common.EngineeringSharingItemVO (implements java.io.Serializable)
      • bb.common.EngineeringSharingVO (implements java.io.Serializable)
      • bb.common.EquipmentVO (implements java.io.Serializable)
      • bb.common.ExpenseAccountVO (implements java.io.Serializable)
      • bb.common.ExpenseItemVO (implements java.io.Serializable)
      • bb.common.ExpenseVO (implements java.io.Serializable)
      • bb.common.FeedbackAnswerVO (implements java.io.Serializable)
      • bb.common.FeedbackItemVO (implements java.io.Serializable)
      • bb.common.FeedbackQuestionVO (implements java.io.Serializable)
      • bb.common.FiscalYearSettingsVO (implements java.io.Serializable)
      • bb.common.GeneralLedgerApprovalVO (implements java.io.Serializable)
      • bb.common.GeneralLedgerCategoryVO (implements java.io.Serializable)
      • bb.common.GeneralLedgerSettingsVO (implements java.io.Serializable)
      • bb.common.GeneralLedgerVO (implements java.io.Serializable)
      • bb.common.GLAutoApproveVO (implements java.io.Serializable)
      • bb.common.GlCashFlowBudgetVO (implements java.io.Serializable)
      • bb.common.GlFiscalYearBudgetVO (implements java.io.Serializable)
      • bb.common.GLItemVO
      • bb.common.GlMonthBudgetVO (implements java.io.Serializable)
      • bb.common.GlMonthVO (implements java.io.Serializable)
      • bb.common.GroupUserVO (implements java.io.Serializable)
      • bb.common.HelpServerVO (implements java.io.Serializable)
      • bb.common.HistoricalInventoryVO (implements java.io.Serializable)
      • bb.common.IcrItemListResult (implements java.io.Serializable)
      • bb.common.ImportContractPriceData (implements java.io.Serializable)
      • bb.common.ImportDataVO (implements java.io.Serializable)
      • bb.common.IncotermVO (implements java.io.Serializable)
      • bb.common.InspectionConformanceReportItemCheckVO (implements java.io.Serializable)
      • bb.common.InspectionConformanceReportItemVO (implements java.io.Serializable)
      • bb.common.InspectionConformanceReportVO (implements java.io.Serializable)
      • bb.common.InspectionItemVO (implements java.io.Serializable)
      • bb.common.InspectionReportInfoVO (implements java.io.Serializable)
      • bb.common.InspectionReportInspectMethodItemVO (implements java.io.Serializable)
      • bb.common.InspectionReportInspectMethodVO (implements java.io.Serializable)
      • bb.common.InspectionReportInspectStandardItemVO (implements java.io.Serializable)
      • bb.common.InspectionReportItemQtyVO (implements java.io.Serializable)
      • bb.common.InspectionReportItemVO (implements java.io.Serializable)
      • bb.common.InspectionReportVO (implements java.io.Serializable)
      • bb.common.InspectionTypeItemVO (implements java.io.Serializable)
      • bb.common.InspectionTypeVO (implements java.io.Serializable)
      • bb.common.InventoryAdjustmentVO (implements java.io.Serializable)
        • bb.common.InventoryAdjustmentListResult (implements java.io.Serializable)
      • bb.common.InventoryPartInOutDetailListResult
      • bb.common.IpAddressVO (implements java.io.Serializable)
      • bb.common.LabelTemplateItemVO (implements java.lang.Comparable<T>, java.io.Serializable)
      • bb.common.LabelTemplateVO (implements java.io.Serializable)
      • bb.common.LogInventoryVO (implements java.io.Serializable)
      • bb.common.LogMethodVO (implements java.io.Serializable)
      • bb.common.LogMiscDocumentVO (implements java.io.Serializable)
      • bb.common.LogPartDocumentVO (implements java.io.Serializable)
      • bb.common.LogPartDwfVO (implements java.io.Serializable)
      • bb.common.LogPartDwgVO (implements java.io.Serializable)
      • bb.common.LogTaskVO (implements java.io.Serializable)
      • bb.common.LogTrackingVO (implements java.io.Serializable)
      • bb.common.MaintenanceItemVO (implements java.io.Serializable)
      • bb.common.ManufacturerAddressInfoVO (implements java.io.Serializable)
      • bb.common.ManufacturerAddressVO (implements java.io.Serializable)
      • bb.common.ManufacturerContactVO (implements java.io.Serializable)
      • bb.common.ManufacturerDescriptionVO (implements java.io.Serializable)
      • bb.common.MessageVO (implements java.io.Serializable)
      • bb.common.MiscDocumentSettingVO (implements java.io.Serializable)
      • bb.common.MultiLanguageAccountsChartVO (implements java.io.Serializable)
      • bb.common.MyPrintListVO (implements java.io.Serializable)
      • bb.common.NcrApprovalVO (implements java.io.Serializable)
      • bb.common.NCRPictureVO (implements java.io.Serializable)
      • bb.common.NonConformanceCodeDescriptionVO (implements java.io.Serializable)
      • bb.common.NonConformanceCodeVO (implements java.io.Serializable)
      • bb.common.NonConformanceQuantityVO (implements java.io.Serializable)
      • bb.common.NonConformanceReportVO (implements java.io.Serializable)
      • bb.common.NonproductivePickingApprovalVO (implements java.io.Serializable)
      • bb.common.NonproductivePickingApproveVO (implements java.io.Serializable)
      • bb.common.NonproductivePickingItemIssuedVO (implements java.io.Serializable)
      • bb.common.NonproductivePickingItemVO (implements java.io.Serializable)
      • bb.common.NonproductivePickingTypeVO (implements java.io.Serializable)
      • bb.common.NonproductivePickingVO (implements java.io.Serializable)
      • bb.common.OIPrincipalVO (implements java.io.Serializable)
      • bb.common.OnloanDocumentVO (implements java.io.Serializable)
      • bb.common.OnLoanItemVO (implements java.io.Serializable)
      • bb.common.OnloanReceiverItemVO (implements java.io.Serializable)
      • bb.common.OnloanReceiverVO (implements java.io.Serializable)
      • bb.common.OnloanReviewVO (implements java.io.Serializable)
      • bb.common.OnloanShipperItemVO (implements java.io.Serializable)
      • bb.common.OnloanShipperVO (implements java.io.Serializable)
      • bb.common.OnLoanVO (implements java.io.Serializable)
      • bb.common.OpCodeShortcutVO (implements java.io.Serializable)
      • bb.common.OperatingInstructionsInspectMethodItemVO (implements java.io.Serializable)
      • bb.common.OperatingInstructionsInspectResultItemVO (implements java.io.Serializable)
      • bb.common.OperatingInstructionsInspectStandardItemVO (implements java.io.Serializable)
      • bb.common.OperatingInstructionsInspectStandardVO (implements java.io.Serializable)
      • bb.common.OperatingInstructionsManualItemVO (implements java.io.Serializable)
      • bb.common.OperatingInstructionsManualVO (implements java.io.Serializable)
      • bb.common.OperatingInstructionsTypeVO (implements java.io.Serializable)
      • bb.common.OperatingInstructionsVO (implements java.io.Serializable)
      • bb.common.OperatingOutputFileItemVO (implements java.io.Serializable)
      • bb.common.OperatingOutputFileTypeVO (implements java.io.Serializable)
      • bb.common.OperationLogVO (implements java.io.Serializable)
      • bb.common.OrderApprovalItemsVO (implements java.io.Serializable)
      • bb.common.OrderApprovalVO (implements java.io.Serializable)
      • bb.common.OrderBoilerplateVO (implements java.io.Serializable)
      • bb.common.OrderDocumentVO (implements java.io.Serializable)
      • bb.common.PackingBoxItemVO (implements java.io.Serializable)
      • bb.common.PackingBoxVO (implements java.io.Serializable)
      • bb.common.PartCatagoryVO (implements java.io.Serializable)
      • bb.common.PartCatalogVO (implements java.io.Serializable)
      • bb.common.PartCertificateVO (implements java.io.Serializable)
      • bb.common.PartClassVO (implements java.io.Serializable)
      • bb.common.PartDescriptionVO (implements java.io.Serializable)
      • bb.common.PartDiscountVO (implements java.io.Serializable)
      • bb.common.PartDocumentVO (implements java.io.Serializable)
      • bb.common.PartDwfVO (implements java.io.Serializable)
      • bb.common.PartDwgVO (implements java.io.Serializable)
      • bb.common.PartInQAResult (implements java.io.Serializable)
      • bb.common.PartInQAVO (implements java.io.Serializable)
      • bb.common.PartInspectionVO (implements java.io.Serializable)
      • bb.common.PartInventoryVO (implements java.io.Serializable)
      • bb.common.PartIssuedVO (implements java.io.Serializable)
        • bb.common.PartIssuedListResult (implements java.io.Serializable)
      • bb.common.PartManufacturerVO (implements java.io.Serializable)
      • bb.common.PartMaterialVO (implements java.io.Serializable)
      • bb.common.PartMRPVO (implements java.io.Serializable)
      • bb.common.PartNumberGenerateRuleVO (implements java.io.Serializable)
      • bb.common.PartOnhandCostVO (implements java.io.Serializable)
      • bb.common.PartOnhandVO (implements java.io.Serializable)
      • bb.common.PartPictureVO (implements java.io.Serializable)
      • bb.common.PartReceivedVO (implements java.io.Serializable)
        • bb.common.PartReceivedListResult (implements java.io.Serializable)
      • bb.common.PartSecurityLevelVO (implements java.io.Serializable)
      • bb.common.PartTraceableCategoryVO (implements java.io.Serializable)
      • bb.common.PartTraceableSpecVO (implements java.io.Serializable)
      • bb.common.PartTrackingVO (implements java.io.Serializable)
      • bb.common.PartTypeVO (implements java.io.Serializable)
      • bb.common.PartUnitVO (implements java.io.Serializable)
      • bb.common.PartUseTypeVO (implements java.io.Serializable)
      • bb.common.PartVendorVO (implements java.io.Serializable)
      • bb.common.PartVO (implements java.io.Serializable)
      • bb.common.PartWithOnhandsVO (implements java.io.Serializable)
      • bb.common.PayableMethodVO (implements java.io.Serializable)
      • bb.common.PaymentHistoryVO (implements java.io.Serializable)
      • bb.common.PaymentVO (implements java.io.Serializable)
      • bb.common.PermissionDescriptionVO (implements java.io.Serializable)
      • bb.common.PermissionMethodVO (implements java.io.Serializable)
      • bb.common.PermissionVO (implements java.io.Serializable)
      • bb.common.PfReceiverItemVO (implements java.io.Serializable)
      • bb.common.PfReceiverVO (implements java.io.Serializable)
      • bb.common.PhysicalInventoryStatusVO (implements java.io.Serializable)
      • bb.common.PhysicalInventoryVO (implements java.io.Serializable)
      • bb.common.PointOfSaleVO (implements java.io.Serializable)
      • bb.common.PoMessageItemVO (implements java.io.Serializable)
      • bb.common.PoMessageVO (implements java.io.Serializable)
      • bb.common.PosRefdocVO (implements java.io.Serializable)
      • bb.common.POSurveyReportItemVO (implements java.io.Serializable)
      • bb.common.POSurveyReportVO (implements java.io.Serializable)
      • bb.common.PosZipCodeTaxVO (implements java.io.Serializable)
      • bb.common.PreventiveActionRequestItemVO (implements java.io.Serializable)
      • bb.common.PreventiveActionRequestVO (implements java.io.Serializable)
      • bb.common.PrintLogoVO (implements java.io.Serializable)
      • bb.common.PrintTemplateVO (implements java.io.Serializable)
      • bb.common.ProformaInvoiceItemManufacturerVO (implements java.io.Serializable)
      • bb.common.ProformaInvoiceItemVO (implements java.io.Serializable)
      • bb.common.ProformaInvoiceVO (implements java.io.Serializable)
      • bb.common.ProjectVO (implements java.io.Serializable)
      • bb.common.PrPackingBoxItemVO (implements java.lang.Comparable<T>, java.io.Serializable)
      • bb.common.PrPackingBoxVO (implements java.io.Serializable)
      • bb.common.PurchaseOrderApprovalVO (implements java.io.Serializable)
      • bb.common.PurchaseOrderBoilerplateVO (implements java.io.Serializable)
      • bb.common.PurchaseOrderDocumentVO (implements java.io.Serializable)
      • bb.common.PurchaseOrderItemManufacturerVO (implements java.io.Serializable)
      • bb.common.PurchaseOrderItemVO (implements java.io.Serializable)
      • bb.common.PurchaseOrderVO (implements java.io.Serializable)
      • bb.common.PurchaseWorkSheetItemVO (implements java.io.Serializable)
      • bb.common.PurchaseWorkSheetVO (implements java.io.Serializable)
      • bb.common.QualityGroupVO (implements java.io.Serializable)
      • bb.common.QuoteBoilerplateVO (implements java.io.Serializable)
      • bb.common.QuoteDocumentVO (implements java.io.Serializable)
      • bb.common.QuoteItemManufacturerVO (implements java.io.Serializable)
      • bb.common.QuoteItemVO (implements java.io.Serializable)
      • bb.common.QuoteVO (implements java.io.Serializable)
      • bb.common.ReceiverInfoVO (implements java.io.Serializable)
      • bb.common.ReceiverItemManufacturerVO (implements java.io.Serializable)
      • bb.common.ReceiverItemVO (implements java.io.Serializable)
      • bb.common.ReceiverVO (implements java.io.Serializable)
      • bb.common.RefdocVO (implements java.io.Serializable)
      • bb.common.RequestForQuoteItemManufacturerVO (implements java.io.Serializable)
      • bb.common.RequestForQuoteItemVO (implements java.io.Serializable)
      • bb.common.RequestForQuoteVO (implements java.io.Serializable)
      • bb.common.RequestForRMAItemVO (implements java.io.Serializable)
      • bb.common.RequestForRMAVO (implements java.io.Serializable)
      • bb.common.ReturnMaterialAuthorizationDocumentVO (implements java.io.Serializable)
      • bb.common.ReturnMaterialAuthorizationItemManufacturerVO (implements java.io.Serializable)
      • bb.common.ReturnMaterialAuthorizationItemVO (implements java.io.Serializable)
      • bb.common.ReturnMaterialAuthorizationVO (implements java.io.Serializable)
      • bb.common.ReturnToVendorItemManufacturerVO (implements java.io.Serializable)
      • bb.common.ReturnToVendorItemVO (implements java.io.Serializable)
      • bb.common.ReturnToVendorVO (implements java.io.Serializable)
      • bb.common.RfqMessageItemVO (implements java.io.Serializable)
      • bb.common.RfqMessageVO (implements java.io.Serializable)
      • bb.common.RMAReceiverItemVO (implements java.io.Serializable)
      • bb.common.RMAReceiverVO (implements java.io.Serializable)
      • bb.common.RMAReviewVO (implements java.io.Serializable)
      • bb.common.RoleDescriptionVO (implements java.io.Serializable)
      • bb.common.RolePermissionVO (implements java.io.Serializable)
      • bb.common.RoleVO (implements java.io.Serializable)
      • bb.common.RollUpBomStdCostWorkSheetItemVO (implements java.io.Serializable)
      • bb.common.RollUpBomStdCostWorkSheetVO (implements java.io.Serializable)
      • bb.common.RTVApprovalVO (implements java.io.Serializable)
      • bb.common.RtvShipperInfoVO (implements java.io.Serializable)
      • bb.common.RtvShipperItemVO (implements java.io.Serializable)
      • bb.common.RtvShipperVO (implements java.io.Serializable)
      • bb.common.RunningAccountOrderItemVO (implements java.io.Serializable)
        • bb.common.RunningAccountOrderItemResult (implements java.io.Serializable)
      • bb.common.RunningAccountOrderVO (implements java.io.Serializable)
      • bb.common.SalesCodeVO (implements java.io.Serializable)
        • bb.common.ArSalesCodeTotalListResult (implements java.io.Serializable)
      • bb.common.SalesmanVO (implements java.io.Serializable)
      • bb.common.SalesOrderBoilerplateVO (implements java.io.Serializable)
      • bb.common.SalesOrderDocumentVO (implements java.io.Serializable)
      • bb.common.SalesOrderItemInfoVO (implements java.io.Serializable)
      • bb.common.SalesOrderItemManufacturerVO (implements java.io.Serializable)
      • bb.common.SalesOrderItemVO (implements java.io.Serializable)
      • bb.common.SalesOrderReviewVO (implements java.io.Serializable)
      • bb.common.SalesOrderVO (implements java.io.Serializable)
      • bb.common.ScrapReportVO (implements java.io.Serializable)
      • bb.common.SerialNumberItemVO (implements java.io.Serializable)
      • bb.common.SerialNumberVO (implements java.io.Serializable)
      • bb.common.ServerClientPropertyVO (implements java.io.Serializable)
      • bb.common.SGBillItemVO (implements java.io.Serializable)
      • bb.common.SGClientAccountVO (implements java.io.Serializable)
      • bb.common.SgClientProgramUserVO (implements java.io.Serializable)
      • bb.common.SGCompanyVO (implements java.io.Serializable)
      • bb.common.SGCustomerCatalogVO (implements java.io.Serializable)
      • bb.common.SGCustomerServiceRequestVO (implements java.io.Serializable)
      • bb.common.SGCustRequestForQuoteItemVO (implements java.io.Serializable)
      • bb.common.SGCustRequestForQuoteVO (implements java.io.Serializable)
      • bb.common.SGDocPartVO (implements java.io.Serializable)
      • bb.common.SGDwgPictureVO (implements java.io.Serializable)
      • bb.common.SGLogLoginVO (implements java.io.Serializable)
      • bb.common.SGPictureVO (implements java.io.Serializable)
      • bb.common.SGQuoteAddressVO (implements java.io.Serializable)
      • bb.common.SGQuoteCartVO (implements java.io.Serializable)
      • bb.common.SGQuoteLoginVO (implements java.io.Serializable)
      • bb.common.SGSaleItemVO (implements java.io.Serializable)
      • bb.common.SGWeightUnitVO (implements java.io.Serializable)
      • bb.common.ShipListInfoVO (implements java.io.Serializable)
      • bb.common.ShipListItemVO (implements java.io.Serializable)
        • bb.common.ShipListItemVOResult
      • bb.common.ShipListOwnerAttributeVO (implements java.io.Serializable)
      • bb.common.ShipListOwnerVO (implements java.io.Serializable)
      • bb.common.ShipListVO (implements java.io.Serializable)
      • bb.common.ShipperInfoVO (implements java.io.Serializable)
      • bb.common.ShipperItemManufacturerVO (implements java.io.Serializable)
      • bb.common.ShipperItemVO (implements java.io.Serializable)
      • bb.common.ShipperVO (implements java.io.Serializable)
      • bb.common.SmtpServerVO (implements java.io.Serializable)
      • bb.common.SubcompanyVO (implements java.io.Serializable)
      • bb.common.SwapOrderApprovalVO (implements java.io.Serializable)
      • bb.common.SwapOrderItemVO (implements java.io.Serializable)
      • bb.common.SwapOrderVO (implements java.io.Serializable)
        • bb.common.SwapOrderListResult
      • bb.common.SwapReceiverItemVO (implements java.io.Serializable)
      • bb.common.SwapReceiverVO (implements java.io.Serializable)
      • bb.common.SwapShipperItemVO (implements java.io.Serializable)
      • bb.common.SwapShipperVO (implements java.io.Serializable)
      • bb.common.TaskVO (implements java.io.Serializable)
      • bb.common.TaxAccountVO (implements java.io.Serializable)
      • bb.common.TempArApAgingVO (implements java.io.Serializable)
      • bb.common.TempReceiverWithoutAPInfo (implements java.io.Serializable)
      • bb.common.TermsConditionVO (implements java.io.Serializable)
      • bb.common.TermVO (implements java.io.Serializable)
      • bb.common.ToolCalibrationVO (implements java.io.Serializable)
        • bb.common.ToolCalibrateListResult (implements java.io.Serializable)
      • bb.common.ToolDescriptionVO (implements java.io.Serializable)
      • bb.common.ToolInventoryVO (implements java.io.Serializable)
      • bb.common.ToolListInfoVO (implements java.io.Serializable)
      • bb.common.ToolListItemVO (implements java.io.Serializable)
      • bb.common.ToolListVO (implements java.io.Serializable)
      • bb.common.ToolManufacturerVO (implements java.io.Serializable)
      • bb.common.ToolOnhandVO (implements java.io.Serializable)
      • bb.common.ToolVendorVO (implements java.io.Serializable)
      • bb.common.ToolVO (implements java.io.Serializable)
      • bb.common.ToolWithOnhandsVO (implements java.io.Serializable)
      • bb.common.TraceableCategoriesVO (implements java.io.Serializable)
      • bb.common.TraceableSpecsVO (implements java.io.Serializable)
      • bb.common.TransferOrderApprovalVO (implements java.io.Serializable)
      • bb.common.TransferOrderItemVO (implements java.io.Serializable)
      • bb.common.TransferOrderVO (implements java.io.Serializable)
      • bb.common.TransferReceiverItemVO (implements java.io.Serializable)
      • bb.common.TransferReceiverVO (implements java.io.Serializable)
      • bb.common.TransferShipperItemVO (implements java.io.Serializable)
      • bb.common.TransferShipperVO (implements java.io.Serializable)
      • bb.common.UnitVO (implements java.io.Serializable)
      • bb.common.UserGroupVO (implements java.io.Serializable)
      • bb.common.UserRolePermissionListResult (implements java.io.Serializable)
      • bb.common.UserRoleVO (implements java.io.Serializable)
      • bb.common.VendorCategoriesVO (implements java.io.Serializable)
      • bb.common.VendorContractPriceItemVO (implements java.io.Serializable)
      • bb.common.VendorContractPriceVendorVO (implements java.io.Serializable)
      • bb.common.VendorContractPriceVO (implements java.io.Serializable)
      • bb.common.VendorCriticalLevelVO (implements java.io.Serializable)
      • bb.common.VendorGroupUserVO (implements java.io.Serializable)
      • bb.common.VendorPartVO (implements java.lang.Comparable<T>, java.io.Serializable)
      • bb.common.VendorQtyPriceVO (implements java.io.Serializable)
      • bb.common.WareHousePartPrefixKeeperVO (implements java.io.Serializable)
      • bb.common.WarehouseTransferVO (implements java.io.Serializable)
      • bb.common.WarehouseVO (implements java.io.Serializable)
      • bb.common.WeightUnitVO (implements java.io.Serializable)
      • bb.common.WorkCalendarVO (implements java.io.Serializable)
      • bb.common.WorkCenterGroupItemVO (implements java.io.Serializable)
      • bb.common.WorkCenterVendorVO (implements java.io.Serializable)
      • bb.common.WorkCenterVO (implements java.lang.Comparable<T>, java.io.Serializable)
      • bb.common.WorkFlowVO (implements java.io.Serializable)
      • bb.common.WorkInstructionApprovalVO (implements java.io.Serializable)
      • bb.common.WorkInstructionDocumentVO (implements java.io.Serializable)
      • bb.common.WorkInstructionPictureVO (implements java.io.Serializable)
      • bb.common.WorkInstructionRequestForChangeVO (implements java.io.Serializable)
      • bb.common.WorkInstructionSequenceVO (implements java.io.Serializable)
      • bb.common.WorkInstructionVO (implements java.io.Serializable)
      • bb.common.WorkOrderApprovalVO (implements java.io.Serializable)
      • bb.common.WorkOrderBoilerplateVO (implements java.io.Serializable)
      • bb.common.WorkOrderDocumentVO (implements java.io.Serializable)
      • bb.common.WorkOrderItemIssueVO (implements java.io.Serializable)
      • bb.common.WorkOrderItemPartDetailInWipVO (implements java.io.Serializable)
      • bb.common.WorkOrderItemTimeDetailVO (implements java.io.Serializable)
      • bb.common.WorkOrderItemVO (implements java.io.Serializable)
      • bb.common.WorkOrderReceiverVO (implements java.io.Serializable)
      • bb.common.WorkOrderTimeCardVO (implements java.io.Serializable)
      • bb.common.WorkOrderVO (implements java.io.Serializable)
      • bb.common.WorkOrderWorkInstructionSequenceVO (implements java.io.Serializable)
      • bb.common.WorkOrderWorkInstructionVO (implements java.io.Serializable)
      • bb.common.WorkOrderWorkSheetItemVO (implements java.io.Serializable)
      • bb.common.WorkOrderWorkSheetVO (implements java.io.Serializable)
      • bb.common.WorkPeriodVO (implements java.io.Serializable)
      • bb.common.ZipCodeTaxVO (implements java.io.Serializable)
      • bb.common.ZipCodeVO (implements java.io.Serializable)
    • bb.common.WarehouseTransferPK (implements java.io.Serializable)
    • bb.common.WareHousingInfoCenterResult (implements java.io.Serializable)
    • bb.common.WC2WCAgent (implements java.io.Serializable)
    • bb.common.WCLoadAgent (implements java.io.Serializable)
    • bb.common.WCLoadByDateResult (implements java.io.Serializable)
    • bb.common.WCLoadDetailResult (implements java.io.Serializable)
    • bb.common.WCLoadOnDateResult (implements java.io.Serializable)
    • bb.common.WireTransferAgent (implements java.io.Serializable)
    • bb.common.WO2WOAgent (implements java.io.Serializable)
    • bb.common.WOIssuedByMonthChartResult (implements java.io.Serializable)
    • bb.common.WOIssuedByMonthResult (implements java.io.Serializable)
    • bb.common.WOItemCostControlAgent (implements java.io.Serializable)
    • bb.common.WOItemPartDetailNotIssue (implements java.io.Serializable)
    • bb.common.WoItemPickListItemResult (implements java.io.Serializable)
    • bb.common.WoItemPickListResult (implements java.io.Serializable)
    • bb.common.WoItemWorkInstructionListResult (implements java.io.Serializable)
    • bb.common.WOReceiverDetail (implements java.io.Serializable)
    • bb.common.WorkCenterAgent (implements java.io.Serializable)
      • bb.common.WorkCenterOnDateAgent
    • bb.common.WorkCenterGroupItemPK (implements java.io.Serializable)
    • bb.common.WorkCenterLoadAgent (implements java.io.Serializable)
    • bb.common.WorkCenterLoadListResult (implements java.io.Serializable)
    • bb.common.WorkCenterRunTimeAgent (implements java.io.Serializable)
    • bb.common.WorkCenterRunTimeListResult (implements java.io.Serializable)
    • bb.common.WorkCenterRunTimeTotalResult (implements java.io.Serializable)
    • bb.common.WorkCenterVendorPK (implements java.io.Serializable)
    • bb.common.WorkInstructionListResult (implements java.io.Serializable)
    • bb.common.WorkInstructionPK (implements java.io.Serializable)
    • bb.common.WorkInstructionSeqAuditListResult (implements java.io.Serializable)
    • bb.common.WorkInstructionSequenceListResult (implements java.io.Serializable)
    • bb.common.WorkInstructionSequencePK (implements java.io.Serializable)
    • bb.common.WorkInstructionSummaryItemResult (implements java.io.Serializable)
    • bb.common.WorkInstructionSummaryResult (implements java.io.Serializable)
    • bb.common.WorkOrderCheckListResult (implements java.io.Serializable)
    • bb.common.WorkOrderInfoCenterResult (implements java.io.Serializable)
    • bb.common.WorkOrderInWipResult (implements java.io.Serializable)
    • bb.common.WorkOrderIssuedOrderListResult (implements java.io.Serializable)
    • bb.common.WorkOrderIssueStatisticsResult (implements java.io.Serializable)
    • bb.common.WorkOrderItemAgent (implements java.io.Serializable)
    • bb.common.WorkOrderItemCanAssyAgent (implements java.io.Serializable)
    • bb.common.WorkOrderItemCanAssyResult (implements java.io.Serializable)
    • bb.common.WorkOrderItemInfoResult (implements java.io.Serializable)
    • bb.common.WorkOrderItemInWipListResult (implements java.io.Serializable)
    • bb.common.WorkOrderItemIssuedTotalResult (implements java.io.Serializable)
    • bb.common.WorkOrderItemIssuePK (implements java.io.Serializable)
    • bb.common.WorkOrderItemLaborCostListResult (implements java.io.Serializable)
    • bb.common.WorkOrderItemListResult (implements java.io.Serializable)
    • bb.common.WorkOrderItemPartDetail (implements java.io.Serializable)
    • bb.common.WorkOrderItemPartDetailItemResult (implements java.io.Serializable)
    • bb.common.WorkOrderItemPartDetailResult (implements java.io.Serializable)
    • bb.common.WorkOrderItemPK (implements java.lang.Comparable<T>, java.io.Serializable)
    • bb.common.WorkOrderItemReviewCostResult (implements java.io.Serializable)
    • bb.common.WorkOrderItemSeqWCLoadResult (implements java.io.Serializable)
    • bb.common.WorkOrderItemSetupItemAgent (implements java.lang.Comparable<T>, java.io.Serializable)
    • bb.common.WorkOrderItemTimeDetailResult (implements java.io.Serializable)
    • bb.common.WorkOrderItemToIssueResult (implements java.io.Serializable)
    • bb.common.WorkOrderItemWCLoadResult (implements java.io.Serializable)
    • bb.common.WorkOrderListResult (implements java.io.Serializable)
    • bb.common.WorkOrderOnDemandResult (implements java.io.Serializable)
      • bb.common.WorkOrderNotSetupResult (implements java.io.Serializable)
    • bb.common.WorkOrderOnOrderResult (implements java.io.Serializable)
    • bb.common.WorkOrderOnTimeItemResult (implements java.io.Serializable)
    • bb.common.WorkOrderOnTimeResult (implements java.io.Serializable)
    • bb.common.WorkOrderOverIssueListResult (implements java.io.Serializable)
    • bb.common.WorkOrderQueryInfo (implements java.io.Serializable)
    • bb.common.WorkOrderWorkInstructionListResult (implements java.io.Serializable)
    • bb.common.WorkOrderWorkInstructionPK (implements java.io.Serializable)
    • bb.common.WorkOrderWorkInstructionSequenceDateAgent (implements java.io.Serializable)
    • bb.common.WorkOrderWorkInstructionSequencePK (implements java.io.Serializable)
    • bb.common.WorkOrderWorkItemDateAgent (implements java.io.Serializable)
    • bb.common.WorkOrderWorkSheetItemPK (implements java.io.Serializable)
    • bb.common.WorkOrderWorkSheetItemWithRelatedInfoResult (implements java.io.Serializable)
    • bb.common.WorkOrderWorkSheetPK (implements java.io.Serializable)
    • bb.common.WorkSheetPartAgent (implements java.io.Serializable)
    • bb.common.YearMonthManager
    • bb.common.ZipcodeTotalsResult (implements java.lang.Comparable<T>, java.io.Serializable)
    • bb.common.ZippedByteArray (implements java.io.Serializable)

Interface Hierarchy

  • bb.common.box.AccountingBox
  • bb.common.box.AddressBox
  • bb.common.Alarmable
  • bb.common.box.CompanyBox
  • bb.common.box.CustomerServiceBox
  • bb.common.box.DocumentBox
  • bb.common.box.EngineeringBox
  • bb.common.Facade
  • bb.common.box.HumanResourceBox
  • bb.common.box.LogBox
  • bb.common.box.ManagementBox
  • bb.common.box.ManufacturingBox
  • bb.common.box.PlanningBox
  • bb.common.box.PurchasingBox
  • bb.common.box.QualityBox
  • bb.common.box.SalesBox
  • bb.common.box.SecurityBox
  • bb.common.box.WarehouseBox
  • bb.common.box.WorkOrderBox
Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ClientAutoInvokeMethodsManager

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ClientAutoInvokeMethodsManager

java.lang.Object
    extended by  bb.common.ClientAutoInvokeMethodsManager

public final class ClientAutoInvokeMethodsManager
extends java.lang.Object

Constructor Summary
ClientAutoInvokeMethodsManager()
Method Summary
static boolean containMethod(java.lang.String module, java.lang.String method)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ClientAutoInvokeMethodsManager

public ClientAutoInvokeMethodsManager()
Method Detail

containMethod

public static boolean containMethod(java.lang.String module,
                                    java.lang.String method)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ClientListItem

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ClientListItem

java.lang.Object
    extended by  bb.common.ClientListItem
All Implemented Interfaces:
java.io.Serializable
public class ClientListItem
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ClientListItem()
Method Summary
java.lang.String | getDisplayValue()
java.lang.String | getDisplayValueWithoutIdentifier()
java.lang.String | getIdentifier()
java.lang.String | getStr()
void | setIdentifier(java.lang.String identifier)
void | setStr(java.lang.String str)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ClientListItem

public ClientListItem()
Method Detail

setIdentifier

public void setIdentifier(java.lang.String identifier)

setStr

public void setStr(java.lang.String str)

getIdentifier

public java.lang.String getIdentifier()

getStr

public java.lang.String getStr()

getDisplayValueWithoutIdentifier

public java.lang.String getDisplayValueWithoutIdentifier()

getDisplayValue

public java.lang.String getDisplayValue()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ClosingStatementItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ClosingStatementItemResult

java.lang.Object
    extended by  bb.common.ClosingStatementItemResult
All Implemented Interfaces:
java.io.Serializable
public class ClosingStatementItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ClosingStatementItemResult()
Method Summary
java.lang.String | getAccountDescription()
java.lang.String | getAccountNumber()
java.lang.String | getAccountType()
java.lang.String | getAddOrSubtract()
java.math.BigDecimal | getBalance()
java.math.BigDecimal | getCredit()
java.lang.String | getCreditOrDebit()
java.math.BigDecimal | getDebit()
byte | getItems()
java.lang.String | getLevel()
java.math.BigDecimal | getMonthToDate()
java.lang.String | getUpLevelAccountNumber()
java.math.BigDecimal | getYearToDate()
void | setAccountDescription(java.lang.String accountDescription)
void | setAccountNumber(java.lang.String accountNumber)
void | setAccountType(java.lang.String accountType)
void | setAddOrSubtract(java.lang.String addOrSubtract)
void | setBalance(java.math.BigDecimal balance)
void | setCredit(java.math.BigDecimal credit)
void | setCreditOrDebit(java.lang.String creditOrDebit)
void | setDebit(java.math.BigDecimal debit)
void | setItems(byte items)
void | setLevel(java.lang.String level)
void | setMonthToDate(java.math.BigDecimal monthToDate)
void | setUpLevelAccountNumber(java.lang.String upLevelAccountNumber)
void | setYearToDate(java.math.BigDecimal yearToDate)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ClosingStatementItemResult

public ClosingStatementItemResult()
Method Detail

getUpLevelAccountNumber

public java.lang.String getUpLevelAccountNumber()

getAddOrSubtract

public java.lang.String getAddOrSubtract()

getAccountType

public java.lang.String getAccountType()

getAccountNumber

public java.lang.String getAccountNumber()

getAccountDescription

public java.lang.String getAccountDescription()

getCreditOrDebit

public java.lang.String getCreditOrDebit()

setLevel

public void setLevel(java.lang.String level)

setUpLevelAccountNumber

public void setUpLevelAccountNumber(java.lang.String upLevelAccountNumber)

setAddOrSubtract

public void setAddOrSubtract(java.lang.String addOrSubtract)

setAccountType

public void setAccountType(java.lang.String accountType)

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

setAccountDescription

public void setAccountDescription(java.lang.String accountDescription)

setCreditOrDebit

public void setCreditOrDebit(java.lang.String creditOrDebit)

setDebit

public void setDebit(java.math.BigDecimal debit)

setCredit

public void setCredit(java.math.BigDecimal credit)

setBalance

public void setBalance(java.math.BigDecimal balance)

setYearToDate

public void setYearToDate(java.math.BigDecimal yearToDate)

setMonthToDate

public void setMonthToDate(java.math.BigDecimal monthToDate)

setItems

public void setItems(byte items)

getLevel

public java.lang.String getLevel()

getDebit

public java.math.BigDecimal getDebit()

getCredit

public java.math.BigDecimal getCredit()

getBalance

public java.math.BigDecimal getBalance()

getYearToDate

public java.math.BigDecimal getYearToDate()

getMonthToDate

public java.math.BigDecimal getMonthToDate()

getItems

public byte getItems()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ClosingStatementResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ClosingStatementResult

java.lang.Object
    extended by  bb.common.ClosingStatementResult
All Implemented Interfaces:
java.io.Serializable
public class ClosingStatementResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ClosingStatementResult()
Method Summary
java.lang.String | getCompanyUnitId()
ClosingStatementTotalResult | getCostOfGoodsSold()
java.util.List | getCostOfGoodsSoldItems()
ClosingStatementTotalResult | getCostOfLabor()
java.util.List | getCostOfLaborItems()
java.util.List | getCurrentAssets()
java.util.List | getCurrentLiabilities()
java.util.List | getEquity()
java.util.List | getFixedAssets()
java.util.List | getGeneralLedgerBalance()
ClosingStatementTotalResult | getGrossNetProfit()
ClosingStatementTotalResult | getGrossRevenue()
ClosingStatementTotalResult | getIncomeTax()
java.util.List | getIncomeTaxItems()
java.util.List | getLessDepreciation()
java.util.List | getLongTermLiabilities()
java.lang.String | getMonthYear()
ClosingStatementTotalResult | getNetProfit()
ClosingStatementTotalResult | getNetProfitBeforeOtherIncome()
ClosingStatementTotalResult | getNetProfitBeforeWriteOffs()
ClosingStatementTotalResult | getNetProfiteBeforeIncomeTax()
java.util.List | getOperatingExpenseItems()
ClosingStatementTotalResult | getOperatingExpenses()
java.util.List | getOtherAssets()
java.util.List | getOtherExpenseItemsItems()
ClosingStatementTotalResult | getOtherExpenses()
ClosingStatementTotalResult | getOtherIncome()
java.util.List | getOtherLiabilities()
java.lang.String | getPreviousMonthYear()
ClosingStatementTotalResult | getRetainedEarningTotal()
java.math.BigDecimal | getRetainedEqrning()
java.util.List | getRevenueItems()
ClosingStatementTotalResult | getRevenueTotal()
java.math.BigDecimal | getTotalAssets()
java.math.BigDecimal | getTotalCurrentAssets()
java.math.BigDecimal | getTotalCurrentLiabilities()
java.math.BigDecimal | getTotalDepreciation()
java.math.BigDecimal | getTotalEquity()
java.math.BigDecimal | getTotalFixedAssets()
java.util.TreeMap | getTotalGeneralLedgerBalance()
java.math.BigDecimal | getTotalLiabilityesEquity()
java.math.BigDecimal | getTotalLongTermLiabilities()
java.math.BigDecimal | getTotalOtherAssets()
java.math.BigDecimal | getTotalOtherLiabilities()
java.util.List | getWriteOffExpenseItems()
ClosingStatementTotalResult | getWriteOffExpenses()
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCostOfGoodsSold(ClosingStatementTotalResult costOfGoodsSold)
void | setCostOfGoodsSoldItems(java.util.List costOfGoodsSoldItems)
void | setCostOfLabor(ClosingStatementTotalResult costOfLabor)
void | setCostOfLaborItems(java.util.List costOfLaborItems)
void | setCurrentAssets(java.util.List currentAssets)
void | setCurrentLiabilities(java.util.List currentLiabilities)
void | setEquity(java.util.List equity)
void | setFixedAssets(java.util.List fixedAssets)
void | setGeneralLedgerBalance(java.util.List generalLedgerBalance)
void | setGrossNetProfit(ClosingStatementTotalResult grossNetProfit)
void | setGrossRevenue(ClosingStatementTotalResult grossRevenue)
void | setIncomeTax(ClosingStatementTotalResult incomeTax)
void | setIncomeTaxItems(java.util.List incomeTaxItems)
void | setLessDepreciation(java.util.List lessDepreciation)
void | setLongTermLiabilities(java.util.List longTermLiabilities)
void | setMonthYear(java.lang.String monthYear)
void | setNetProfit(ClosingStatementTotalResult netProfit)
void | setNetProfitBeforeOtherIncome(ClosingStatementTotalResult netProfitBeforeOtherIncome)
void | setNetProfitBeforeWriteOffs(ClosingStatementTotalResult netProfitBeforeWriteOffs)
void | setNetProfiteBeforeIncomeTax(ClosingStatementTotalResult netProfiteBeforeIncomeTax)
void | setOperatingExpenseItems(java.util.List operatingExpenseItems)
void | setOperatingExpenses(ClosingStatementTotalResult operatingExpenses)
void | setOtherAssets(java.util.List otherAssets)
void | setOtherExpenseItemsItems(java.util.List otherExpenseItemsItems)
void | setOtherExpenses(ClosingStatementTotalResult otherExpenses)
void | setOtherIncome(ClosingStatementTotalResult otherIncome)
void | setOtherLiabilities(java.util.List otherLiabilities)
void | setPreviousMonthYear(java.lang.String previousMonthYear)
void | setRetainedEarningTotal(ClosingStatementTotalResult retainedEarningTotal)
void | setRetainedEqrning(java.math.BigDecimal retainedEqrning)
void | setRevenueItems(java.util.List revenueItems)
void | setRevenueTotal(ClosingStatementTotalResult revenueTotal)
void | setTotalAssets(java.math.BigDecimal totalAssets)
void | setTotalCurrentAssets(java.math.BigDecimal totalCurrentAssets)
void | setTotalCurrentLiabilities(java.math.BigDecimal totalCurrentLiabilities)
void | setTotalDepreciation(java.math.BigDecimal totalDepreciation)
void | setTotalEquity(java.math.BigDecimal totalEquity)
void | setTotalFixedAssets(java.math.BigDecimal totalFixedAssets)
void | setTotalGeneralLedgerBalance(java.util.TreeMap totalGeneralLedgerBalance)
void | setTotalLiabilityesEquity(java.math.BigDecimal totalLiabilityesEquity)
void | setTotalLongTermLiabilities(java.math.BigDecimal totalLongTermLiabilities)
void | setTotalOtherAssets(java.math.BigDecimal totalOtherAssets)
void | setTotalOtherLiabilities(java.math.BigDecimal totalOtherLiabilities)
void | setWriteOffExpenseItems(java.util.List writeOffExpenseItems)
void | setWriteOffExpenses(ClosingStatementTotalResult writeOffExpenses)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ClosingStatementResult

public ClosingStatementResult()
Method Detail

getCostOfLabor

public ClosingStatementTotalResult getCostOfLabor()

getGrossNetProfit

public ClosingStatementTotalResult getGrossNetProfit()

getCostOfGoodsSold

public ClosingStatementTotalResult getCostOfGoodsSold()

getNetProfitBeforeWriteOffs

public ClosingStatementTotalResult getNetProfitBeforeWriteOffs()

getNetProfit

public ClosingStatementTotalResult getNetProfit()

getOperatingExpenses

public ClosingStatementTotalResult getOperatingExpenses()

getNetProfiteBeforeIncomeTax

public ClosingStatementTotalResult getNetProfiteBeforeIncomeTax()

getOtherExpenses

public ClosingStatementTotalResult getOtherExpenses()

getNetProfitBeforeOtherIncome

public ClosingStatementTotalResult getNetProfitBeforeOtherIncome()

getGrossRevenue

public ClosingStatementTotalResult getGrossRevenue()

getIncomeTax

public ClosingStatementTotalResult getIncomeTax()

getOtherIncome

public ClosingStatementTotalResult getOtherIncome()

setWriteOffExpenses

public void setWriteOffExpenses(ClosingStatementTotalResult writeOffExpenses)

setCostOfLabor

public void setCostOfLabor(ClosingStatementTotalResult costOfLabor)

setGrossNetProfit

public void setGrossNetProfit(ClosingStatementTotalResult grossNetProfit)

setCostOfGoodsSold

public void setCostOfGoodsSold(ClosingStatementTotalResult costOfGoodsSold)

setNetProfitBeforeWriteOffs

public void setNetProfitBeforeWriteOffs(ClosingStatementTotalResult netProfitBeforeWriteOffs)

setNetProfit

public void setNetProfit(ClosingStatementTotalResult netProfit)

setOperatingExpenses

public void setOperatingExpenses(ClosingStatementTotalResult operatingExpenses)

setNetProfiteBeforeIncomeTax

public void setNetProfiteBeforeIncomeTax(ClosingStatementTotalResult netProfiteBeforeIncomeTax)

setOtherExpenses

public void setOtherExpenses(ClosingStatementTotalResult otherExpenses)

setNetProfitBeforeOtherIncome

public void setNetProfitBeforeOtherIncome(ClosingStatementTotalResult netProfitBeforeOtherIncome)

setGrossRevenue

public void setGrossRevenue(ClosingStatementTotalResult grossRevenue)

setIncomeTax

public void setIncomeTax(ClosingStatementTotalResult incomeTax)

setOtherIncome

public void setOtherIncome(ClosingStatementTotalResult otherIncome)

setCurrentAssets

public void setCurrentAssets(java.util.List currentAssets)

setTotalCurrentAssets

public void setTotalCurrentAssets(java.math.BigDecimal totalCurrentAssets)

setTotalOtherAssets

public void setTotalOtherAssets(java.math.BigDecimal totalOtherAssets)

setTotalFixedAssets

public void setTotalFixedAssets(java.math.BigDecimal totalFixedAssets)

setTotalAssets

public void setTotalAssets(java.math.BigDecimal totalAssets)

setFixedAssets

public void setFixedAssets(java.util.List fixedAssets)

setOtherAssets

public void setOtherAssets(java.util.List otherAssets)

setLessDepreciation

public void setLessDepreciation(java.util.List lessDepreciation)

setTotalDepreciation

public void setTotalDepreciation(java.math.BigDecimal totalDepreciation)

setCurrentLiabilities

public void setCurrentLiabilities(java.util.List currentLiabilities)

setEquity

public void setEquity(java.util.List equity)

setTotalLongTermLiabilities

public void setTotalLongTermLiabilities(java.math.BigDecimal totalLongTermLiabilities)

setLongTermLiabilities

public void setLongTermLiabilities(java.util.List longTermLiabilities)

setTotalCurrentLiabilities

public void setTotalCurrentLiabilities(java.math.BigDecimal totalCurrentLiabilities)

setTotalLiabilityesEquity

public void setTotalLiabilityesEquity(java.math.BigDecimal totalLiabilityesEquity)

setTotalEquity

public void setTotalEquity(java.math.BigDecimal totalEquity)

setRetainedEqrning

public void setRetainedEqrning(java.math.BigDecimal retainedEqrning)

setGeneralLedgerBalance

public void setGeneralLedgerBalance(java.util.List generalLedgerBalance)

setMonthYear

public void setMonthYear(java.lang.String monthYear)

setRevenueTotal

public void setRevenueTotal(ClosingStatementTotalResult revenueTotal)

setCostOfLaborItems

public void setCostOfLaborItems(java.util.List costOfLaborItems)

setIncomeTaxItems

public void setIncomeTaxItems(java.util.List incomeTaxItems)

setRevenueItems

public void setRevenueItems(java.util.List revenueItems)

setOtherExpenseItemsItems

public void setOtherExpenseItemsItems(java.util.List otherExpenseItemsItems)

setCostOfGoodsSoldItems

public void setCostOfGoodsSoldItems(java.util.List costOfGoodsSoldItems)

setOperatingExpenseItems

public void setOperatingExpenseItems(java.util.List operatingExpenseItems)

setWriteOffExpenseItems

public void setWriteOffExpenseItems(java.util.List writeOffExpenseItems)

setRetainedEarningTotal

public void setRetainedEarningTotal(ClosingStatementTotalResult retainedEarningTotal)

setTotalGeneralLedgerBalance

public void setTotalGeneralLedgerBalance(java.util.TreeMap totalGeneralLedgerBalance)

getWriteOffExpenses

public ClosingStatementTotalResult getWriteOffExpenses()

getCurrentAssets

public java.util.List getCurrentAssets()

getTotalCurrentAssets

public java.math.BigDecimal getTotalCurrentAssets()

getTotalOtherAssets

public java.math.BigDecimal getTotalOtherAssets()

getTotalFixedAssets

public java.math.BigDecimal getTotalFixedAssets()

getTotalAssets

public java.math.BigDecimal getTotalAssets()

getFixedAssets

public java.util.List getFixedAssets()

getOtherAssets

public java.util.List getOtherAssets()

getLessDepreciation

public java.util.List getLessDepreciation()

getTotalDepreciation

public java.math.BigDecimal getTotalDepreciation()

getCurrentLiabilities

public java.util.List getCurrentLiabilities()

getEquity

public java.util.List getEquity()

getTotalLongTermLiabilities

public java.math.BigDecimal getTotalLongTermLiabilities()

getLongTermLiabilities

public java.util.List getLongTermLiabilities()

getTotalCurrentLiabilities

public java.math.BigDecimal getTotalCurrentLiabilities()

getTotalLiabilityesEquity

public java.math.BigDecimal getTotalLiabilityesEquity()

getTotalEquity

public java.math.BigDecimal getTotalEquity()

getRetainedEqrning

public java.math.BigDecimal getRetainedEqrning()

getGeneralLedgerBalance

public java.util.List getGeneralLedgerBalance()

getMonthYear

public java.lang.String getMonthYear()

getRevenueTotal

public ClosingStatementTotalResult getRevenueTotal()

getCostOfLaborItems

public java.util.List getCostOfLaborItems()

getIncomeTaxItems

public java.util.List getIncomeTaxItems()

getRevenueItems

public java.util.List getRevenueItems()

getOtherExpenseItemsItems

public java.util.List getOtherExpenseItemsItems()

getCostOfGoodsSoldItems

public java.util.List getCostOfGoodsSoldItems()

getOperatingExpenseItems

public java.util.List getOperatingExpenseItems()

getWriteOffExpenseItems

public java.util.List getWriteOffExpenseItems()

getRetainedEarningTotal

public ClosingStatementTotalResult getRetainedEarningTotal()

getTotalGeneralLedgerBalance

public java.util.TreeMap getTotalGeneralLedgerBalance()

getPreviousMonthYear

public java.lang.String getPreviousMonthYear()

setPreviousMonthYear

public void setPreviousMonthYear(java.lang.String previousMonthYear)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getOtherLiabilities

public java.util.List getOtherLiabilities()

setOtherLiabilities

public void setOtherLiabilities(java.util.List otherLiabilities)

getTotalOtherLiabilities

public java.math.BigDecimal getTotalOtherLiabilities()

setTotalOtherLiabilities

public void setTotalOtherLiabilities(java.math.BigDecimal totalOtherLiabilities)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ClosingStatementTotalResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ClosingStatementTotalResult

java.lang.Object
    extended by  bb.common.ClosingStatementTotalResult
All Implemented Interfaces:
java.io.Serializable
public class ClosingStatementTotalResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ClosingStatementTotalResult()
Method Summary
java.math.BigDecimal | getChangePercent()
java.math.BigDecimal | getMonthToDate()
java.math.BigDecimal | getPreviousMonthTotal()
java.math.BigDecimal | getYearToDate()
void | setChangePercent(java.math.BigDecimal changePercent)
void | setMonthToDate(java.math.BigDecimal monthToDate)
void | setPreviousMonthTotal(java.math.BigDecimal previousMonthTotal)
void | setYearToDate(java.math.BigDecimal yearToDate)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ClosingStatementTotalResult

public ClosingStatementTotalResult()
Method Detail

getChangePercent

public java.math.BigDecimal getChangePercent()

setChangePercent

public void setChangePercent(java.math.BigDecimal changePercent)

getMonthToDate

public java.math.BigDecimal getMonthToDate()

setMonthToDate

public void setMonthToDate(java.math.BigDecimal monthToDate)

getPreviousMonthTotal

public java.math.BigDecimal getPreviousMonthTotal()

setPreviousMonthTotal

public void setPreviousMonthTotal(java.math.BigDecimal previousMonthTotal)

getYearToDate

public java.math.BigDecimal getYearToDate()

setYearToDate

public void setYearToDate(java.math.BigDecimal yearToDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CommonPrintTemplateVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CommonPrintTemplateVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CommonPrintTemplateVO
All Implemented Interfaces:
java.io.Serializable
public class CommonPrintTemplateVO
extends VO

See Also:
Serialized Form

Constructor Summary
CommonPrintTemplateVO()
Method Summary
java.util.Date | getAdate()
int | getId()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getOrigin()
byte[] | getTemplate()
java.lang.String | getTemplateName()
java.lang.Integer | getVersion()
int | getWidth()
void | setAdate(java.util.Date adate)
void | setId(int id)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setOrigin(java.lang.String origin)
void | setTemplate(byte[] template)
void | setTemplateName(java.lang.String templateName)
void | setVersion(java.lang.Integer version)
void | setWidth(int width)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CommonPrintTemplateVO

public CommonPrintTemplateVO()
Method Detail

getId

public int getId()

setId

public void setId(int id)

getTemplateName

public java.lang.String getTemplateName()

setTemplateName

public void setTemplateName(java.lang.String templateName)

getWidth

public int getWidth()

setWidth

public void setWidth(int width)

getTemplate

public byte[] getTemplate()

setTemplate

public void setTemplate(byte[] template)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getVersion

public java.lang.Integer getVersion()

setVersion

public void setVersion(java.lang.Integer version)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CompanyBox

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common.box
Interface CompanyBox

public interface CompanyBox

Method Summary
BuyerCodeVO | addBuyerCode(BuyerCodeVO vo)
CashierVO | addCashier(CashierVO vo)
CommonPrintTemplateVO | addCommonPrintTemplate(CommonPrintTemplateVO vo)
CompanyUnitVO | addCompanyUnit(CompanyUnitVO vo)
CompanyUnitAccountVO | addCompanyUnitAccount(CompanyUnitAccountVO vo)
CurrencyVO | addCurrency(CurrencyVO vo)
void | addCustomColumn(AppColumnVO vo)
void | addCustomSearch(CustomSearchVO vo)
void | addDataFilter(DataFilterVO vo)
DocumentServerVO | addDocumentServerSettings(DocumentServerVO vo)
DwfUploadSettingsVO | addDwfUploadSettings(DwfUploadSettingsVO vo)
DwgUploadSettingsVO | addDwgUploadSettings(DwgUploadSettingsVO vo)
GroupUserVO | addGroupUser(GroupUserVO vo)
HelpServerVO | addHelpServer(HelpServerVO vo)
void | addMessage(MessageAgent agent)
MiscDocumentSettingVO | addMiscDocSetting(MiscDocumentSettingVO vo)
PartTypeVO | addPartType(PartTypeVO vo)
PayableMethodVO | addPayment(PayableMethodVO vo)
PosZipCodeTaxVO | addPosZipCodeTax(PosZipCodeTaxVO vo)
void | addPrintLogo(PrintLogoVO vo)
PrintTemplateVO | addPrintTemplate(PrintTemplateVO vo)
RunningAccountOrderVO | addReturnOrder(RunningAccountOrderVO vo, java.lang.String raoNumber)
RunningAccountOrderVO[] | addRunningAccountOrder(RunningAccountOrderVO vo)
void | addSubcompany(SubcompanyVO vo)
void | addTask(TaskVO vo)
TaxAccountVO | addTaxAccount(TaxAccountVO vo)
TermVO | addTerm(TermAgent agent)
void | addTermsConditions(TermsConditionVO vo)
UserGroupVO | addUserGroup(UserGroupVO vo)
WeightUnitVO | addWeightUnit(WeightUnitVO vo)
void | addWorkFlow(WorkFlowVO workFlowVO)
ZipCodeVO | addZipCode(ZipCodeVO vo)
ZipCodeTaxVO | addZipCodeTax(ZipCodeTaxVO vo)
void | AdjustInventoryByPos(java.util.Collection<RunningAccountOrderItemResult> result)
java.util.Date | changeServerSystemTime(java.util.Date date)
void | createAppColumn(java.lang.String tableName, java.lang.String columnName, java.lang.String content)
void | createAppTable(java.lang.String tableName, java.lang.String contents)
void | dealOldMessage(java.lang.Long id)
void | deleteAllTempBOM()
void | deleteBuyerCode(java.lang.String buyerCode)
void | deleteCashier(CashierVO vo)
void | deleteCommonPrintTemplate(CommonPrintTemplateVO vo)
void | deleteCompanyUnit(java.lang.String id)
void | deleteCompanyUnitAccount(CompanyUnitAccountPK pk)
void | deleteCurrency(java.lang.String currency)
void | deleteCustomColumn(AppColumnVO vo)
void | deleteCustomSearch(CustomSearchVO vo)
void | deleteDataFilter(java.lang.String id)
void | deleteDocumentServerByPk(java.lang.String docType)
void | deleteFTPOrderDoc(MiscDocAgent agent)
void | deleteGroupUser(GroupUserVO vo)
void | deleteGroupUserByUserGroup(java.lang.String userGroup)
void | deleteHelpServer(java.lang.Long pk)
void | deleteMiscDocSetting(MiscDocumentSettingVO vo)
java.util.Collection<PartTypeVO> | deletePartType(java.lang.String partType)
void | deletePayment(PayableMethodVO vo)
void | deletePrintLogo(java.lang.String logoName)
void | deletePrintTemplate(int id)
void | deleteSubcompanyById(java.lang.String addressId)
void | deleteTask(java.lang.Long ii)
void | deleteTaxAccount(TaxAccountVO vo)
void | deleteTempAddress(int ii)
void | deleteTempBOM(int ii)
void | deleteTempEmployee(int ii)
void | deleteTempInventory(int ii)
void | deleteTempManufacture(int ii)
void | deleteTempMaterial(int ii)
void | deleteTempMPN(int ii)
void | deleteTempNccode(int ii)
void | deleteTempPart(int ii)
void | deleteTempTool(int ii)
void | deleteTempToolInventory(int ii)
void | deleteTerm(int ii)
void | deleteTerm(java.lang.String termValue)
void | deleteTermsCondition(int ii)
void | deleteTermsCondition(java.lang.String type)
void | deleteTermsCondition(TermsConditionVO vo)
void | deleteUserGroup(java.lang.String id)
void | deleteUserGroup(UserGroupVO vo)
void | deleteWeightUnit(java.lang.String weightUnit)
void | deleteWorkFlow(java.lang.String workFlowName)
void | deleteZipCode(java.lang.String zipId)
void | deleteZipCodeTax(ZipCodeTaxVO vo)
byte[] | downloadFTPOrderDoc(MiscDocAgent agent)
byte[] | downTaskFileByTaskId(java.lang.Long ii, java.lang.String fileName)
void | dropAppColumn(java.lang.String tableName, java.lang.String columnName)
void | dropAppTable(java.lang.String tableName)
void | executeSql(java.lang.String str)
void | exportEngSharingPart(java.lang.Long ii)
java.util.HashMap<java.lang.String,java.util.ArrayList<AppColumnVO>> | findAllAppColumns()
java.util.Collection<BuyerCodeVO> | findAllBuyerCode(int firstIndex, int maxLength)
java.util.Collection<CashierVO> | findAllCashier(int firstIndex, int maxLength)
java.util.Collection<CompanyUnitVO> | findAllCompanyUnit(int firstIndex, int maxLength)
java.util.Collection<CompanyUnitAccountVO> | findAllCompanyUnitAccount(int firstIndex, int maxLength)
java.util.Collection<CurrencyVO> | findAllCurrency(int firstIndex, int maxLength)
java.util.Collection<CurrencyVO> | findAllCurrentCurrency(int firstIndex, int maxLength)
java.util.Collection<CustomSearchVO> | findAllCustomSearch()
java.util.Collection<CustomTranslationVO> | findAllCustomTranslation()
java.util.Collection<DataFilterVO> | findAllDataFilter(int firstIndex, int maxLength)
java.util.Collection<DocumentServerVO> | findAllDocumentServerSettings(int firstIndex, int maxLength)
java.util.Collection<PartTypeVO> | findAllDocumentType()
java.util.Collection<HelpServerVO> | findAllHelpServers(int firstIndex, int maxLength)
java.util.Collection<MiscDocumentSettingVO> | findAllMiscDocSetting(int firstIndex, int maxLength)
java.util.List | findAllOldMessgeId()
java.util.Collection<PartTypeVO> | findAllPartType(int firstIndex, int maxLength)
java.util.Collection<PrintLogoVO> | findAllPrintLogo()
java.util.Collection<PrintTemplateVO> | findAllPrintTemplate(int firstIndex, int maxLength)
java.util.Collection<TaxAccountVO> | findAllPurchaseTaxAccount(int firstIndex, int maxLength)
java.util.Collection<MessageVO> | findAllReceivedMessages(java.lang.String sendUserName, java.lang.String sendFrom, java.lang.String subject, java.lang.String content, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int length)
java.util.Collection<TaxAccountVO> | findAllSalesTaxAccount(int firstIndex, int maxLength)
java.util.Collection<MessageVO> | findAllSentMessages(java.lang.String receiver, java.lang.String subject, java.lang.String content, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int length)
java.util.Collection<SubcompanyVO> | findAllSubcompanysById(java.lang.String addressId, int firstIndex, int length)
java.util.Collection<TaskVO> | findAllTasks(int firstIndex, int maxLength)
java.util.Collection<TermVO> | findAllTerms(int firstIndex, int maxLength)
java.util.Collection<TermsConditionVO> | findAllTermsConditions()
java.util.Collection<WeightUnitVO> | findAllWeightUnit(int firstIndex, int maxLength)
java.util.Collection<WeightUnitVO> | findAllWeightUnit(java.lang.String weighUnit, int firstIndex, int maxLength)
java.util.Collection<WorkFlowVO> | findAllWorkFlow(int firstIndex, int maxLength)
java.util.Collection<ZipCodeVO> | findAllZipCode(java.lang.String zipId, int firstIndex, int maxLength)
java.util.Collection<ZipCodeTaxVO> | findAllZipCodeTaxByTaxType(java.lang.String taxType, int firstIndex, int maxLength)
java.util.Collection<java.util.Map> | findAppDataBySql(java.lang.String sql, java.util.HashMap parameters, int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | findBOMItemNotPart()
java.util.Collection<ImportDataVO> | findBOMNotPart()
java.util.Collection<BuyerCodeVO> | findBuyerCodeByBuyerCodeLike(java.lang.String buyerCodeReg, int firstIndex, int maxLength)
java.util.Collection<CommonPrintTemplateVO> | findCommonPrintTemplate(int firstIndex, int maxLength)
java.util.Collection<CompanyUnitVO> | findCompanyUnitList(java.lang.String id, java.lang.String name, java.lang.String type, int firstIndex, int maxLength)
java.util.HashMap<java.lang.String,ContractPriceCustomerVO> | findContractPriceCustomerByCustomList(java.lang.String contractNumber, java.util.HashSet<java.lang.String> ids)
java.util.HashMap<PartPK,ContractPriceItemVO> | findContractPriceItemByPartNumberList(java.lang.String contractNumber, java.util.HashSet<PartPK> pks)
java.util.Collection<CurrencyExchangeVO> | findCurrencyExchangeByMonth(java.lang.String monthYear)
java.util.Collection<java.lang.Object> | findCustomSearchResult(java.util.ArrayList<java.lang.String> sqls, java.util.HashMap<java.lang.String,java.lang.Object> map, java.lang.String clazz, int firstIndex, int maxLength)
java.util.Collection | findCustomSearchTotalResult(java.util.ArrayList<java.lang.String> sqls, java.util.HashMap<java.lang.String,java.lang.Object> map, java.lang.String clazz)
java.util.Collection<ImportDataVO> | findDuplicateTempAddress(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | findDuplicateTempBOM(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | findDuplicateTempEmployee(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | findDuplicateTempInventory(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | findDuplicateTempManufacture(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | findDuplicateTempMaterial(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | findDuplicateTempNccode(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | findDuplicateTempPart(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | findDuplicateTempTool(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | findDuplicateTempToolInventory(int firstIndex, int maxLength)
java.util.Collection<CurrencyExchangeVO> | findExchangeByfiscalYear(java.lang.String currency, java.lang.String fiscalYear)
java.util.Collection<ImportDataVO> | findExistAddress(java.lang.String type)
java.util.Collection<ImportDataVO> | findExistBOM()
java.util.Collection<ImportDataVO> | findExistEmployee()
java.util.Collection<ImportDataVO> | findExistInventory()
java.util.Collection<ImportDataVO> | findExistManufacture()
java.util.Collection<ImportDataVO> | findExistMaterial()
java.util.Collection<ImportDataVO> | findExistNccode()
java.util.Collection<ImportDataVO> | findExistPart()
java.util.Collection<ImportDataVO> | findExistTool()
java.util.Collection<ImportDataVO> | findExistToolInventory()
java.util.Collection<UserGroupVO> | findGroupsBySelf(int firstIndex, int maxLength)
java.util.Collection<UserGroupVO> | findGroupsByUserName(java.lang.String userName, int firstIndex, int maxLength)
java.util.Collection<GroupUserVO> | findGroupUserList(java.lang.String userName, java.lang.String userGroup, int firstIndex, int maxLength)
java.util.Collection<LogTaskVO> | findLogTasks(java.lang.String name, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<MessageVO> | findMessages(java.lang.String subject, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int length)
java.util.Collection<LogMiscDocumentVO> | findMiscDocLog(java.lang.String docType, java.lang.String docFileName, java.lang.String action, java.lang.String operator, java.lang.String wanIp, java.lang.String lanIp, java.lang.String macAddress, java.lang.String description, java.lang.String extension, java.lang.String orderNumber, java.util.Date dateFrom, java.util.Date dateTo, int firstIndex, int maxLength)
MiscDocumentSettingVO | findMiscDocSettingByType(java.lang.String docType)
java.util.List<MoneyInDrawResult> | findMoneyInDrawByComputer()
java.util.Collection<NoticeUserEmployeeListResult> | findNoticeUserEmployee(java.lang.String userName, java.lang.String systemUserName, java.lang.String userGroup, int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | findNotPartInventory()
java.util.Collection<ImportDataVO> | findNotPartTempMaterial()
java.util.Collection<ImportDataVO> | findNotToolInventory()
java.util.Collection<OrderDocumentVO> | findOrderDocListByOrderNumber(java.lang.String orderNumber)
java.util.Collection<PartTypeVO> | findPartTypeByTypeLike(java.lang.String partTypeLike, int firstIndex, int maxLength)
java.util.Collection<PayableMethodVO> | findPayment(java.lang.String paymentName)
java.util.Collection<PosZipCodeTaxVO> | findPosZipCodeTaxsList()
java.util.Collection<PrintTemplateVO> | findPrintTemplatebyClazz(java.lang.String clazz, int firstIndex, int maxLength)
AccountingTotalMoneyResult | findRaoTotal(java.lang.String raoNumber, java.lang.String[] includeVendorId, java.lang.String[] excludeVendorId, java.lang.String payableMethod, java.util.Date fromDate, java.util.Date toDate, java.lang.String orderType, boolean isMakeOrder, java.lang.String partNumber, java.lang.String partType, boolean showNegative)
java.util.Collection<ZipcodeTotalsResult> | findReceiptByCustomer(java.util.Date fromDate, java.util.Date toDate)
java.util.Collection<RunningAccountOrderItemResult> | findReceiptItemsByNegativeOnhand(java.lang.String raoNumber, java.lang.String[] includeVendorId, java.lang.String[] excludeVendorId, java.lang.String payableMethod, java.util.Date fromDate, java.util.Date toDate, java.lang.String orderType, boolean isMakeOrder, java.lang.String partNumber, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<RunningAccountOrderVO> | findReceiptOrders(java.lang.String raoNumber, java.lang.String[] includeVendorId, java.lang.String[] excludeVendorId, java.lang.String payableMethod, java.util.Date fromDate, java.util.Date toDate, java.lang.String orderType, boolean isMakeOrder, int firstIndex, int maxLength)
AccountingTotalMoneyResult | findReceiptOrderTotal(java.lang.String raoNumber, java.lang.String[] includeVendorId, java.lang.String[] excludeVendorId, java.lang.String payableMethod, java.util.Date fromDate, java.util.Date toDate, java.lang.String orderType, boolean isMakeOrder)
java.util.Collection<RunningAccountOrderItemResult> | findRunningAccountOrderItems(java.lang.String raoNumber, java.lang.String[] includeVendorId, java.lang.String[] excludeVendorId, java.lang.String payableMethod, java.util.Date fromDate, java.util.Date toDate, java.lang.String orderType, boolean isMakeOrder, java.lang.String partNumber, java.lang.String partType, java.lang.String description, java.lang.String modelNumber, java.lang.String commodityCode, java.lang.String productCode, boolean showNegative, int firstIndex, int maxLength)
java.util.List | findSalesDateNoExistSalesOder()
java.util.Collection<UserGroupVO> | findSystemUserGroup(int firstIndex, int maxLength)
java.util.Collection<java.util.Map> | findTableColumnsByName(java.lang.String tableName, java.lang.String columnName)
java.util.Collection<java.util.Map> | findTablesByName(java.lang.String tableName)
java.util.HashMap<java.lang.String,java.util.List<ZipcodeTotalsResult>> | findTaxComputationByState(java.lang.String state, java.util.Date fromDate, java.util.Date toDate)
java.util.HashMap<java.lang.String,java.util.List<ZipcodeTotalsResult>> | findTaxComputationByZipCode(java.util.Date fromDate, java.util.Date toDate)
java.util.Collection<ZipcodeTotalsResult> | findTaxExemptTotalByCity(java.lang.String city, java.util.Date fromDate, java.util.Date toDate)
java.util.Collection<ZipcodeTotalsResult> | findTaxExemptTotalByCustomerId(java.util.Date fromDate, java.util.Date toDate)
java.util.Collection<ZipcodeTotalsResult> | findTaxExemptTotalByTaxType(java.util.Date fromDate, java.util.Date toDate)
java.util.Collection<ZipcodeTotalsResult> | findTaxTotalByCustomerId(java.util.Date fromDate, java.util.Date toDate)
java.util.Collection<ZipcodeTotalsResult> | findTaxTotalByZipCode(java.util.Date fromDate, java.util.Date toDate)
java.util.Collection<ImportDataVO> | findTempAddress(java.lang.String type, int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | findTempBOM(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | findTempEmployee(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | findTempInventory(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | findTempManufacture(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | findTempMaterial(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | findTempMPN(int firstIndex, int maxLength)
java.util.HashMap<java.lang.Integer,java.lang.String> | findTempMPNDataProblem()
java.util.Collection<ImportDataVO> | findTempNccode(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | findTempPart(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | findTempTool(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | findTempToolInventory(int firstIndex, int maxLength)
java.util.Collection<MessageVO> | findUnreadReceivedMessages(int firstIndex, int length)
java.lang.String | getAccountByCurrency(java.lang.String currency, boolean isAR)
AccountingConfigurationVO | getAccountingConfiguration()
AccountingSettingsVO | getAccountingSettings()
HelpServerVO | getActiveHelpServer()
java.util.List<ZipcodeTotalsResult> | getAddressesNoTaxInfo(java.util.Date fromDate, java.util.Date toDate)
CustomerVendorAddressVO | getAddressOfCompanyID()
java.util.Collection<java.lang.String> | getAllAccountsByCurrency(boolean isAR)
int | getAllBuyerCodeCount()
int | getAllCashierCount()
int | getAllCompanyUnitAccountCount()
int | getAllCompanyUnitCount()
java.util.Map<java.lang.String,java.util.Set<BB2DoubleString>> | getAllCompanyUnitsByAccountNumber()
int | getAllCurrencyCount()
int | getAllCustomSearchCount()
int | getAllDataFilterCount()
int | getAllDocumentServerSettings()
java.util.Collection<TaskFileResult> | getAllFileByTaskId(java.lang.Long ii)
int | getAllHelpServerCount()
int | getAllMiscDocSettingCount()
int | getAllOldMessageCount()
int | getAllPartTypeCount()
int | getAllPrintLogoCount()
int | getAllPrintTemplateCount()
int | getAllPurchaseTaxAccount()
int | getAllReceivedMessagesCount(java.lang.String sendUserName, java.lang.String sendFrom, java.lang.String subject, java.lang.String content, java.util.Date fromDate, java.util.Date toDate)
int | getAllSalesTaxAccount()
int | getAllSentMessagesCount(java.lang.String receiver, java.lang.String subject, java.lang.String content, java.util.Date fromDate, java.util.Date toDate)
java.util.List<java.lang.String> | getAllState()
int | getAllSubcompanysByIdCount(java.lang.String addressId)
int | getAllTasksCount()
java.util.Map<java.lang.String,BB2Task> | getAllTasksList()
java.util.Collection<BB2DoubleString> | getAllTerms()
int | getAllTermsConditionsCount()
int | getAllTermsCount()
int | getAllWeightUnitCount()
int | getAllWeightUnitCount(java.lang.String weighUnit)
int | getAllWorkFlowCount()
int | getAllZipCodeCount(java.lang.String zipId)
int | getAllZipCodeTaxByTaxType(java.lang.String taxType)
AppColumnVO | getAppColumnByTableNameAndColumnName(java.lang.String tableName, java.lang.String columnName)
int | getAppDataCountBySql(java.lang.String sql, java.util.HashMap parameters)
java.lang.String | getAppProperty(java.lang.String id)
java.lang.String | getBB2DatabaseVersion()
BuyerCodeVO | getBuyerCodeByBuyerCode(java.lang.String buyerCode)
int | getBuyerCodeCountByBuyerCodeLike(java.lang.String buyerCodeReg)
RunningAccountOrderVO | getCaneRunningAccountOrder(java.lang.String raoNumber)
CashierVO | getCashier(java.lang.String cashier)
CommonPrintTemplateVO | getCommonPrintTemplate(int id)
int | getCommonPrintTemplateCount()
byte[] | getCompanyHome()
CompanyVO | getCompanySettings()
java.util.Map<java.lang.String,java.util.ArrayList<java.lang.String>> | getCompanyUnitAccountByAccount()
java.util.Collection<CompanyUnitAccountVO> | getCompanyUnitAccountByCompanyUnit(java.lang.String companyUnitId)
CompanyUnitAccountVO | getCompanyUnitAccountByPk(CompanyUnitAccountPK pk)
java.util.Collection<java.lang.String> | getCompanyUnitAccountWithChild(java.lang.String companyUnitId)
CompanyUnitVO | getCompanyUnitByPk(java.lang.String id)
int | getCompanyUnitListCount(java.lang.String id, java.lang.String name, java.lang.String type)
java.util.Collection<java.lang.String> | getCompanyUnitsByAccountNumber(java.lang.String accountNumber)
CurrencyVO | getCurrency(java.lang.String currency, java.lang.String fyNumber)
CurrencyVO | getCurrencyByPk(java.lang.String currency)
java.math.BigDecimal | getCurrencyExchangeRate(java.util.Date date, java.lang.String currency)
CustomSearchVO | getCustomSearch(java.lang.String id)
int | getCustomSearchResultCount(java.util.ArrayList<java.lang.String> sqls, java.util.HashMap<java.lang.String,java.lang.Object> map)
DataFilterVO | getDataFilter(java.lang.String id)
DocumentServerVO | getDocumentServerSettingsByDocType(java.lang.String documentType)
int | getDuplicateTempAddressCount()
int | getDuplicateTempBOMCount()
int | getDuplicateTempEmployeeCount()
int | getDuplicateTempInventoryCount()
int | getDuplicateTempManufactureCount()
int | getDuplicateTempMaterialCount()
int | getDuplicateTempNccodeCount()
int | getDuplicateTempPartCount()
int | getDuplicateTempToolCount()
int | getDuplicateTempToolInventoryCount()
DwfUploadSettingsVO | getDwfUploadSettingsVO(java.lang.String drawingType)
DwgUploadSettingsVO | getDwgUploadSettingsVO(java.lang.String drawingType)
java.lang.String | getEmailForUserSelf()
int | getGroupCountBySelf()
int | getGroupCountByUserName(java.lang.String owner)
int | getGroupUserCount(java.lang.String userName, java.lang.String userGroup)
HelpServerVO | getHelpServerByPk(java.lang.Long pk)
byte[] | getLicense()
int | getLogTasksCount(java.lang.String name, java.util.Date fromDate, java.util.Date toDate)
java.lang.String | getMailTextPreview(java.lang.String text)
MessageVO | getMessage(java.lang.Long ii)
int | getMessagesCount(java.lang.String subject, java.util.Date fromDate, java.util.Date toDate)
int | getMiscDocLogCount(java.lang.String docType, java.lang.String docFileName, java.lang.String action, java.lang.String operator, java.lang.String wanIp, java.lang.String lanIp, java.lang.String macAddress, java.lang.String description, java.lang.String extension, java.lang.String orderNumber, java.util.Date dateFrom, java.util.Date dateTo)
int | getMoneyInDrawByComputerCount()
java.util.List<MoneyInDrawResult> | getMoneyInDrawByComputerTotal()
ServerClientPropertyVO | getMyServerClientProperty(java.lang.String id)
java.lang.String | getMysqlVersion()
int | getNoticeUserEmployeeCount(java.lang.String userName, java.lang.String systemUserName, java.lang.String userGroup)
java.util.Collection<OpCodeShortcutVO> | getOpCodeShortcutByUserName(java.lang.String userName)
PartTypeVO | getPartTypeByID(java.lang.String partType)
int | getPartTypeCountByTypeLike(java.lang.String partTypeLike)
PayableMethodVO | getPayment()
PayableMethodVO | getPaymentById(int paymentId)
PayableMethodVO | getPaymentByName(java.lang.String paymentName)
java.lang.Integer | getPaymentCount(java.lang.String paymentName)
PointOfSaleVO | getPointOfSale()
PosZipCodeTaxVO | getPosZipCodeTaxByPK(PosZipCodeTaxPK pk)
PosZipCodeTaxVO | getPosZipCodeTaxByZipCode(java.lang.String zipCode)
PrintLogoVO | getPrintLogoByName(java.lang.String logoName)
PrintLogoVO | getPrintLogoInfoByName(java.lang.String logoName)
PrintTemplateVO | getPrintTemplate(int id)
int | getPrintTemplatebyClazzCount(java.lang.String clazz)
java.lang.String | getPurchaseTaxAccount(java.math.BigDecimal purchaseTaxRate)
int | getReceiptOrdersCount(java.lang.String raoNumber, java.lang.String[] includeVendorId, java.lang.String[] excludeVendorId, java.lang.String payableMethod, java.util.Date fromDate, java.util.Date toDate, java.lang.String orderType, boolean isMakeOrder)
RunningAccountOrderVO | getRunningAccountOrderById(java.lang.String raoNumber)
RunningAccountOrderItemVO | getRunningAccountOrderItem(RunningAccountOrderItemPK pk)
RunningAccountOrderItemVO | getRunningAccountOrderItemByPartPK(PartPK pk)
RunningAccountOrderItemVO | getRunningAccountOrderItemByPartPK(PartPK pk, java.lang.String customerId, java.lang.String mfgPartNumber)
RunningAccountOrderItemVO | getRunningAccountOrderItemByRaoNumberandPartPK(java.lang.String raoNumber, PartPK pk)
int | getRunningAccountOrderItemCount(java.lang.String raoNumber, java.lang.String[] includeVendorId, java.lang.String[] excludeVendorId, java.lang.String payableMethod, java.util.Date fromDate, java.util.Date toDate, java.lang.String orderType, boolean isMakeOrder, java.lang.String partNumber, java.lang.String partType, java.lang.String description, java.lang.String modelNumber, java.lang.String commodityCode, java.lang.String productCode)
java.lang.String | getSalesTaxAccount(java.math.BigDecimal salesTaxRate)
java.util.Collection<ServerClientPropertyVO> | getServerClientProperties(java.lang.String id)
SmtpServerVO | getSmtpServer()
java.lang.String | getStartNumber()
ZipcodeTotalsResult | getStateTotal(java.lang.String state, java.util.Date fromDate, java.util.Date toDate)
java.util.List<ZipcodeTotalsResult> | getStateTotalDetail(java.lang.String state, java.util.Date fromDate, java.util.Date toDate, java.lang.String type)
SubcompanyVO | getSubcompanyById(java.lang.String addressId)
int | getSystemUserGroupCount()
java.util.Collection<java.util.Map> | getTableAppColumns(java.lang.String tableName)
TaskVO | getTask(java.lang.Long ii)
int | getTaxExemptTotalByCityCount(java.lang.String city, java.util.Date fromDate, java.util.Date toDate)
ZipcodeTotalsResult | getTaxTotal(java.util.Date fromDate, java.util.Date toDate)
int | getTempAddressCount(java.lang.String type)
int | getTempBOMCount()
int | getTempEmployeeCount()
int | getTempInventoryCount()
int | getTempManufactureCount()
int | getTempMaterialCount()
int | getTempMPNCount()
int | getTempNccodeCount()
int | getTempPartCount()
int | getTempToolCount()
int | getTempToolInventoryCount()
TermVO | getTerm(int ii)
TermVO | getTerm(java.lang.String termValue)
BB2File | getTermsConditionFiles(java.lang.String type)
TermsConditionVO | getTermsConditionsByOrderType(java.lang.String type)
TermsConditionVO | getTermsConditionsInfoByOrderType(java.lang.String type)
java.lang.String | getTermUsed(java.lang.String termValue)
int | getUnreadReceivedMessagesCount()
UserGroupVO | getUserGroupByPk(java.lang.String id)
java.util.Collection<BB2DoubleString> | getUserPasswordPairs(java.lang.String userName)
WeightUnitVO | getWeightUnitByPk(java.lang.String weightUnit)
WorkFlowVO | getWorkFlowByName(java.lang.String workFlowName)
ZipCodeVO | getZipCodeByPk(java.lang.String zipId)
ZipCodeTaxVO | getZipCodeTaxByPK(int ii)
java.lang.String | getZipName(java.lang.String zipId)
void | importAddress()
void | importBOM()
void | importContractPrice(java.util.ArrayList<ImportContractPriceData> datas)
void | importCustomer()
void | importDepartment()
void | importEmployee()
void | importInventory()
void | importManufacture()
void | importMaterial()
void | importMPN()
void | importNccode()
void | importPart(boolean update)
void | importPartMinMaxQty(java.util.ArrayList<PartVO> parts)
void | importTempAddress(java.util.ArrayList<CustomerVendorAddressVO> address)
void | importTempBOM(java.util.ArrayList<BillItemVO> bills)
void | importTempCustomer(java.util.ArrayList<CustomerVendorAddressVO> address)
void | importTempDepartment(java.util.ArrayList<CustomerVendorAddressVO> address)
void | importTempEmployee(java.util.ArrayList<EmployeeCardVO> employees)
void | importTempInventory(java.util.ArrayList<PartOnhandWithAverageCostResult> inventorys)
void | importTempManufacture(java.util.ArrayList<ManufacturerAddressVO> address)
void | importTempMaterial(java.util.ArrayList<PartMaterialVO> materials)
void | importTempMPN(java.util.ArrayList<PartManufacturerVO> mpns)
void | importTempNccode(java.util.ArrayList<NonConformanceCodeVO> nccodes)
void | importTempPart(java.util.ArrayList<PartVO> datas)
void | importTempTool(java.util.ArrayList<ToolVO> datas)
void | importTempToolInventory(java.util.ArrayList<ToolOnhandWithAverageCostResult> datas)
void | importTempVendor(java.util.ArrayList<CustomerVendorAddressVO> address)
void | importTool(boolean update)
void | importToolInventory(boolean update)
void | importVendor()
void | initDatabase(java.lang.String languageCode)
java.lang.Object | invokeDaoMethod(java.lang.String daoName, java.lang.String methodName, java.lang.Object[] parameters, java.lang.Class[] parameterTypes)
boolean | isActiveHelpServerExist()
boolean | isAppPropertyExist(java.lang.String id)
boolean | isAppTableColumnExist(java.lang.String tableName, java.lang.String columnName)
boolean | isAppTableExist(java.lang.String tableName)
boolean | isCompanyUnitAccountExistent(CompanyUnitAccountPK pk)
boolean | isCompanyUnitExistent(java.lang.String id)
boolean | isDocumentServerExist(java.lang.String docType)
boolean | isExistCashier(java.lang.String cashier)
boolean | isFileExistent(MiscDocAgent agent, java.lang.String docType)
boolean | isMiscDocExist(java.lang.String docType)
boolean | isParentCompanyUnit(java.lang.String id)
boolean | isPartTypeExist(java.lang.String partType)
boolean | isPosZipCodeTaxExistent(java.lang.String zipCode)
boolean | isPrintTemplateExist(int id)
boolean | isSubcompanyExists(java.lang.String addressId)
boolean | isSystemUserGroup(java.lang.String userGroup)
boolean | isTaskExist(java.lang.Long ii)
boolean | isTaxRateExist(java.lang.String taxType, java.lang.String zip)
boolean | isUserGroupExist(java.lang.String id)
boolean | isWorkFlowExist(java.lang.String workFlowName)
boolean | isZipCodeExist(java.lang.String zipId)
java.lang.String[] | makeAllActionForReceiptFromAdding(RunningAccountOrderVO raVO)
java.lang.String | makeAllActionForReturnFromAdding(RunningAccountOrderVO raVO, java.lang.String originalReceiptNumber)
java.util.List<java.lang.String> | makeReturnMaterialAuthorization(java.util.ArrayList<RunningAccountOrderItemResult> result)
java.util.List<java.lang.String> | makeSalesOrder(java.util.ArrayList<RunningAccountOrderItemResult> result)
java.lang.String | makeSalesOrder(java.util.ArrayList<RunningAccountOrderItemResult> result, boolean onlyInvoice)
void | makeSalesOrderAndShipperAndARAndGL(java.util.Date fromDate, java.util.Date toDate)
void | putServerClientProperty(java.lang.String id, java.lang.String value)
java.lang.Object | queryBySql(java.lang.String sql)
void | readMessage(java.lang.Long ii)
void | reloadServer()
void | removeAppProperty(java.lang.String id)
void | removeMessage(java.lang.Long ii)
void | removeOldMessages(java.util.Date date)
void | replaceBuyerCode(java.lang.String oldBuyerCode, java.lang.String newBuyerCode)
void | sendARStatement(BB2Notice notice)
void | sendBugNotice(BB2BugNotice notice)
void | sendNotice(BB2Notice notice)
void | sendPoNotice(BB2Notice notice)
void | sendQuoteNotice(BB2Notice notice)
void | sendRfqNotice(BB2Notice notice)
void | setAppProperty(java.lang.String id, java.lang.String value)
SmtpServerVO | setSmtpServer(SmtpServerVO vo)
void | showDashboard()
boolean | testSmtpConnect(java.lang.String host, int port, boolean isRequireAuth, java.lang.String userName, java.lang.String password)
AccountingConfigurationVO | updateAccountingConfiguration(AccountingConfigurationVO vo)
void | updateAccountNumber(java.lang.String oldAccountNumber, java.lang.String newAccountNumber)
AccountingSettingsVO | updateAccoutingSettings(AccountingSettingsVO vo)
void | updateAppData(java.util.Collection<java.lang.Object[]> sqls)
void | updateAppData(java.lang.String sql, java.util.HashMap parameters)
BuyerCodeVO | updateBuyerCode(BuyerCodeVO vo)
void | updateBySql(java.lang.String sql)
CashierVO | updateCashier(CashierVO vo)
CommonPrintTemplateVO | updateCommonPrintTemplate(CommonPrintTemplateVO vo)
void | updateCompanyHome(byte[] companyHome)
CompanyVO | updateCompanyId(java.lang.String addressId)
CompanyVO | updateCompanySettings(CompanyVO vo)
CompanyUnitVO | updateCompanyUnit(CompanyUnitVO vo)
void | updateCompanyUnitAccount(CompanyUnitAccountVO vo)
CurrencyVO | updateCurrency(java.lang.String currency, java.lang.String symbol)
void | updateCurrencyById(java.lang.String currency, java.lang.String acc, boolean isAR)
void | updateCurrencyBySql(java.lang.String currency, java.lang.String symbol)
void | updateCustomColumn(AppColumnVO vo)
void | updateCustomSearch(CustomSearchVO vo)
void | updateCustomTranslation(java.util.Set<CustomTranslationVO> customTranslations)
void | updateDataFilter(DataFilterVO vo)
void | updateDocumentServerSettings(DocumentServerVO vo)
void | updateDwfUploadSettings(DwfUploadSettingsVO vo)
void | updateDwgUploadSettings(DwgUploadSettingsVO vo)
void | updateExchangeByfiscalYear(CurrencyAgent agent)
void | updateGroupUser(GroupUserVO vo)
void | updateHelpServer(HelpServerVO vo)
CompanyVO | updateInitStep(java.lang.String initStep)
void | updateLicense(byte[] license)
MiscDocumentSettingVO | updateMiscDocSetting(MiscDocumentSettingVO vo)
void | updateOpCodeShortcut(java.util.ArrayList<OpCodeShortcutVO> opCodeShortcuts, java.lang.String userName)
void | updatePartNumberGenerateRule(java.lang.String nextStartPartNumber)
void | updatePartType(PartTypeVO vo)
java.lang.Boolean | updatePasswordPolicy(PasswordPolicyAgent agent)
PayableMethodVO | updatePayment(PayableMethodVO vo)
PointOfSaleVO | updatePointOfSale(PointOfSaleVO vo)
void | updatePosZipCodeTaxs(java.util.Collection<PosZipCodeTaxVO> list)
void | updatePrintLogo(PrintLogoVO vo)
void | updatePrintTemplate(PrintTemplateVO vo)
void | updateSignature(java.util.List<CheckInvoiceItemListResult> results, byte[] elecSignature)
SmtpServerVO | updateSmtpServer(SmtpServerVO vo)
void | updateSubcompany(SubcompanyVO vo)
void | updateTask(TaskVO vo)
void | updateTaxAccount(TaxAccountVO vo)
void | updateTempAddress(ImportDataVO vo)
void | updateTempBOM(ImportDataVO vo)
void | updateTempEmployee(ImportDataVO vo)
void | updateTempInventory(ImportDataVO vo)
void | updateTempManufacture(ImportDataVO vo)
void | updateTempMaterial(ImportDataVO vo)
void | updateTempMPN(ImportDataVO vo)
void | updateTempNccode(ImportDataVO vo)
void | updateTempPart(ImportDataVO info)
void | updateTempTool(ImportDataVO vo)
void | updateTempToolInventory(ImportDataVO vo)
TermVO | updateTerm(TermVO vo)
void | updateTermsCondition(TermsConditionVO vo)
void | updateUserGroup(UserGroupVO vo)
WeightUnitVO | updateWeightUnit(WeightUnitVO vo)
void | updateWorkFlow(WorkFlowVO workFlowVO)
ZipCodeVO | updateZipCode(ZipCodeVO vo)
ZipCodeTaxVO | updateZipCodeTax(ZipCodeTaxVO vo)
java.util.Collection<OrderDocumentVO> | uploadOrUpdateFTPOrderDoc(MiscDocAgent agent)

Method Detail

getCompanySettings

CompanyVO getCompanySettings()
                             throws java.lang.Exception
Throws:
java.lang.Exception

updateCompanySettings

CompanyVO updateCompanySettings(CompanyVO vo)
                                throws java.lang.Exception
Throws:
java.lang.Exception

updateInitStep

CompanyVO updateInitStep(java.lang.String initStep)
                         throws java.lang.Exception
Throws:
java.lang.Exception

updateCompanyHome

void updateCompanyHome(byte[] companyHome)
                       throws java.lang.Exception
Throws:
java.lang.Exception

getCompanyHome

byte[] getCompanyHome()
                      throws java.lang.Exception
Throws:
java.lang.Exception

updateLicense

void updateLicense(byte[] license)
                   throws java.lang.Exception
Throws:
java.lang.Exception

getLicense

byte[] getLicense()
                  throws java.lang.Exception
Throws:
java.lang.Exception

getBuyerCodeByBuyerCode

BuyerCodeVO getBuyerCodeByBuyerCode(java.lang.String buyerCode)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findAllBuyerCode

java.util.Collection<BuyerCodeVO> findAllBuyerCode(int firstIndex,
                                                   int maxLength)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getAllBuyerCodeCount

int getAllBuyerCodeCount()
                         throws java.lang.Exception
Throws:
java.lang.Exception

findBuyerCodeByBuyerCodeLike

java.util.Collection<BuyerCodeVO> findBuyerCodeByBuyerCodeLike(java.lang.String buyerCodeReg,
                                                               int firstIndex,
                                                               int maxLength)
                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getBuyerCodeCountByBuyerCodeLike

int getBuyerCodeCountByBuyerCodeLike(java.lang.String buyerCodeReg)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

addBuyerCode

BuyerCodeVO addBuyerCode(BuyerCodeVO vo)
                         throws java.lang.Exception
Throws:
java.lang.Exception

updateBuyerCode

BuyerCodeVO updateBuyerCode(BuyerCodeVO vo)
                            throws java.lang.Exception
Throws:
java.lang.Exception

deleteBuyerCode

void deleteBuyerCode(java.lang.String buyerCode)
                     throws java.lang.Exception
Throws:
java.lang.Exception

replaceBuyerCode

void replaceBuyerCode(java.lang.String oldBuyerCode,
                      java.lang.String newBuyerCode)
                      throws java.lang.Exception
Throws:
java.lang.Exception

findAllPartType

java.util.Collection<PartTypeVO> findAllPartType(int firstIndex,
                                                 int maxLength)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getAllPartTypeCount

int getAllPartTypeCount()
                        throws java.lang.Exception
Throws:
java.lang.Exception

findPartTypeByTypeLike

java.util.Collection<PartTypeVO> findPartTypeByTypeLike(java.lang.String partTypeLike,
                                                        int firstIndex,
                                                        int maxLength)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getPartTypeCountByTypeLike

int getPartTypeCountByTypeLike(java.lang.String partTypeLike)
                               throws java.lang.Exception
Throws:
java.lang.Exception

addPartType

PartTypeVO addPartType(PartTypeVO vo)
                       throws java.lang.Exception
Throws:
java.lang.Exception

getPartTypeByID

PartTypeVO getPartTypeByID(java.lang.String partType)
                           throws java.lang.Exception
Throws:
java.lang.Exception

isPartTypeExist

boolean isPartTypeExist(java.lang.String partType)
                        throws java.lang.Exception
Throws:
java.lang.Exception

deletePartType

java.util.Collection<PartTypeVO> deletePartType(java.lang.String partType)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

updatePartType

void updatePartType(PartTypeVO vo)
                    throws java.lang.Exception
Throws:
java.lang.Exception

findAllCurrency

java.util.Collection<CurrencyVO> findAllCurrency(int firstIndex,
                                                 int maxLength)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getAllCurrencyCount

int getAllCurrencyCount()
                        throws java.lang.Exception
Throws:
java.lang.Exception

findAllCurrentCurrency

java.util.Collection<CurrencyVO> findAllCurrentCurrency(int firstIndex,
                                                        int maxLength)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getCurrencyByPk

CurrencyVO getCurrencyByPk(java.lang.String currency)
                           throws java.lang.Exception
Throws:
java.lang.Exception

getCurrency

CurrencyVO getCurrency(java.lang.String currency,
                       java.lang.String fyNumber)
                       throws java.lang.Exception
Throws:
java.lang.Exception

addCurrency

CurrencyVO addCurrency(CurrencyVO vo)
                       throws java.lang.Exception
Throws:
java.lang.Exception

updateCurrency

CurrencyVO updateCurrency(java.lang.String currency,
                          java.lang.String symbol)
                          throws java.lang.Exception
Throws:
java.lang.Exception

deleteCurrency

void deleteCurrency(java.lang.String currency)
                    throws java.lang.Exception
Throws:
java.lang.Exception

updateCurrencyBySql

void updateCurrencyBySql(java.lang.String currency,
                         java.lang.String symbol)
                         throws java.lang.Exception
Throws:
java.lang.Exception

updateCurrencyById

void updateCurrencyById(java.lang.String currency,
                        java.lang.String acc,
                        boolean isAR)
                        throws java.lang.Exception
Throws:
java.lang.Exception

getAllAccountsByCurrency

java.util.Collection<java.lang.String> getAllAccountsByCurrency(boolean isAR)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAccountByCurrency

java.lang.String getAccountByCurrency(java.lang.String currency,
                                      boolean isAR)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findCurrencyExchangeByMonth

java.util.Collection<CurrencyExchangeVO> findCurrencyExchangeByMonth(java.lang.String monthYear)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getCurrencyExchangeRate

java.math.BigDecimal getCurrencyExchangeRate(java.util.Date date,
                                             java.lang.String currency)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findExchangeByfiscalYear

java.util.Collection<CurrencyExchangeVO> findExchangeByfiscalYear(java.lang.String currency,
                                                                  java.lang.String fiscalYear)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

updateExchangeByfiscalYear

void updateExchangeByfiscalYear(CurrencyAgent agent)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findAllWeightUnit

java.util.Collection<WeightUnitVO> findAllWeightUnit(java.lang.String weighUnit,
                                                     int firstIndex,
                                                     int maxLength)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getAllWeightUnitCount

int getAllWeightUnitCount(java.lang.String weighUnit)
                          throws java.lang.Exception
Throws:
java.lang.Exception

findAllWeightUnit

java.util.Collection<WeightUnitVO> findAllWeightUnit(int firstIndex,
                                                     int maxLength)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getAllWeightUnitCount

int getAllWeightUnitCount()
                          throws java.lang.Exception
Throws:
java.lang.Exception

getWeightUnitByPk

WeightUnitVO getWeightUnitByPk(java.lang.String weightUnit)
                               throws java.lang.Exception
Throws:
java.lang.Exception

addWeightUnit

WeightUnitVO addWeightUnit(WeightUnitVO vo)
                           throws java.lang.Exception
Throws:
java.lang.Exception

updateWeightUnit

WeightUnitVO updateWeightUnit(WeightUnitVO vo)
                              throws java.lang.Exception
Throws:
java.lang.Exception

deleteWeightUnit

void deleteWeightUnit(java.lang.String weightUnit)
                      throws java.lang.Exception
Throws:
java.lang.Exception

updateAccoutingSettings

AccountingSettingsVO updateAccoutingSettings(AccountingSettingsVO vo)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

updateAccountNumber

void updateAccountNumber(java.lang.String oldAccountNumber,
                         java.lang.String newAccountNumber)
                         throws java.lang.Exception
Throws:
java.lang.Exception

getAccountingSettings

AccountingSettingsVO getAccountingSettings()
                                           throws java.lang.Exception
Throws:
java.lang.Exception

addTaxAccount

TaxAccountVO addTaxAccount(TaxAccountVO vo)
                           throws java.lang.Exception
Throws:
java.lang.Exception

updateTaxAccount

void updateTaxAccount(TaxAccountVO vo)
                      throws java.lang.Exception
Throws:
java.lang.Exception

deleteTaxAccount

void deleteTaxAccount(TaxAccountVO vo)
                      throws java.lang.Exception
Throws:
java.lang.Exception

findAllSalesTaxAccount

java.util.Collection<TaxAccountVO> findAllSalesTaxAccount(int firstIndex,
                                                          int maxLength)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getAllSalesTaxAccount

int getAllSalesTaxAccount()
                          throws java.lang.Exception
Throws:
java.lang.Exception

findAllPurchaseTaxAccount

java.util.Collection<TaxAccountVO> findAllPurchaseTaxAccount(int firstIndex,
                                                             int maxLength)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getAllPurchaseTaxAccount

int getAllPurchaseTaxAccount()
                             throws java.lang.Exception
Throws:
java.lang.Exception

getSalesTaxAccount

java.lang.String getSalesTaxAccount(java.math.BigDecimal salesTaxRate)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseTaxAccount

java.lang.String getPurchaseTaxAccount(java.math.BigDecimal purchaseTaxRate)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

addZipCodeTax

ZipCodeTaxVO addZipCodeTax(ZipCodeTaxVO vo)
                           throws java.lang.Exception
Throws:
java.lang.Exception

updateZipCodeTax

ZipCodeTaxVO updateZipCodeTax(ZipCodeTaxVO vo)
                              throws java.lang.Exception
Throws:
java.lang.Exception

deleteZipCodeTax

void deleteZipCodeTax(ZipCodeTaxVO vo)
                      throws java.lang.Exception
Throws:
java.lang.Exception

getZipCodeTaxByPK

ZipCodeTaxVO getZipCodeTaxByPK(int ii)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findAllZipCodeTaxByTaxType

java.util.Collection<ZipCodeTaxVO> findAllZipCodeTaxByTaxType(java.lang.String taxType,
                                                              int firstIndex,
                                                              int maxLength)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getAllZipCodeTaxByTaxType

int getAllZipCodeTaxByTaxType(java.lang.String taxType)
                              throws java.lang.Exception
Throws:
java.lang.Exception

isTaxRateExist

boolean isTaxRateExist(java.lang.String taxType,
                       java.lang.String zip)
                       throws java.lang.Exception
Throws:
java.lang.Exception

findAllDocumentServerSettings

java.util.Collection<DocumentServerVO> findAllDocumentServerSettings(int firstIndex,
                                                                     int maxLength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getAllDocumentServerSettings

int getAllDocumentServerSettings()
                                 throws java.lang.Exception
Throws:
java.lang.Exception

addDocumentServerSettings

DocumentServerVO addDocumentServerSettings(DocumentServerVO vo)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

updateDocumentServerSettings

void updateDocumentServerSettings(DocumentServerVO vo)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

getDocumentServerSettingsByDocType

DocumentServerVO getDocumentServerSettingsByDocType(java.lang.String documentType)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

findAllDocumentType

java.util.Collection<PartTypeVO> findAllDocumentType()
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

deleteDocumentServerByPk

void deleteDocumentServerByPk(java.lang.String docType)
                              throws java.lang.Exception
Throws:
java.lang.Exception

isDocumentServerExist

boolean isDocumentServerExist(java.lang.String docType)
                              throws java.lang.Exception
Throws:
java.lang.Exception

isFileExistent

boolean isFileExistent(MiscDocAgent agent,
                       java.lang.String docType)
                       throws java.lang.Exception
Throws:
java.lang.Exception

findAllPrintLogo

java.util.Collection<PrintLogoVO> findAllPrintLogo()
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getAllPrintLogoCount

int getAllPrintLogoCount()
                         throws java.lang.Exception
Throws:
java.lang.Exception

getPrintLogoByName

PrintLogoVO getPrintLogoByName(java.lang.String logoName)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getPrintLogoInfoByName

PrintLogoVO getPrintLogoInfoByName(java.lang.String logoName)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

addPrintLogo

void addPrintLogo(PrintLogoVO vo)
                  throws java.lang.Exception
Throws:
java.lang.Exception

updatePrintLogo

void updatePrintLogo(PrintLogoVO vo)
                     throws java.lang.Exception
Throws:
java.lang.Exception

deletePrintLogo

void deletePrintLogo(java.lang.String logoName)
                     throws java.lang.Exception
Throws:
java.lang.Exception

addTermsConditions

void addTermsConditions(TermsConditionVO vo)
                        throws java.lang.Exception
Throws:
java.lang.Exception

updateTermsCondition

void updateTermsCondition(TermsConditionVO vo)
                          throws java.lang.Exception
Throws:
java.lang.Exception

deleteTermsCondition

void deleteTermsCondition(TermsConditionVO vo)
                          throws java.lang.Exception
Throws:
java.lang.Exception

deleteTermsCondition

void deleteTermsCondition(java.lang.String type)
                          throws java.lang.Exception
Throws:
java.lang.Exception

deleteTermsCondition

void deleteTermsCondition(int ii)
                          throws java.lang.Exception
Throws:
java.lang.Exception

findAllTermsConditions

java.util.Collection<TermsConditionVO> findAllTermsConditions()
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getAllTermsConditionsCount

int getAllTermsConditionsCount()
                               throws java.lang.Exception
Throws:
java.lang.Exception

getTermsConditionsByOrderType

TermsConditionVO getTermsConditionsByOrderType(java.lang.String type)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

getTermsConditionFiles

BB2File getTermsConditionFiles(java.lang.String type)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getTermsConditionsInfoByOrderType

TermsConditionVO getTermsConditionsInfoByOrderType(java.lang.String type)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

sendRfqNotice

void sendRfqNotice(BB2Notice notice)
                   throws java.lang.Exception
Throws:
java.lang.Exception

sendPoNotice

void sendPoNotice(BB2Notice notice)
                  throws java.lang.Exception
Throws:
java.lang.Exception

sendQuoteNotice

void sendQuoteNotice(BB2Notice notice)
                     throws java.lang.Exception
Throws:
java.lang.Exception

sendNotice

void sendNotice(BB2Notice notice)
                throws java.lang.Exception
Throws:
java.lang.Exception

sendARStatement

void sendARStatement(BB2Notice notice)
                     throws java.lang.Exception
Throws:
java.lang.Exception

sendBugNotice

void sendBugNotice(BB2BugNotice notice)
                   throws java.lang.Exception
Throws:
java.lang.Exception

setSmtpServer

SmtpServerVO setSmtpServer(SmtpServerVO vo)
                           throws java.lang.Exception
Throws:
java.lang.Exception

updateSmtpServer

SmtpServerVO updateSmtpServer(SmtpServerVO vo)
                              throws java.lang.Exception
Throws:
java.lang.Exception

getSmtpServer

SmtpServerVO getSmtpServer()
                           throws java.lang.Exception
Throws:
java.lang.Exception

testSmtpConnect

boolean testSmtpConnect(java.lang.String host,
                        int port,
                        boolean isRequireAuth,
                        java.lang.String userName,
                        java.lang.String password)
                        throws java.lang.Exception
Throws:
java.lang.Exception

getMailTextPreview

java.lang.String getMailTextPreview(java.lang.String text)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

getEmailForUserSelf

java.lang.String getEmailForUserSelf()
                                     throws java.lang.Exception
Throws:
java.lang.Exception

changeServerSystemTime

java.util.Date changeServerSystemTime(java.util.Date date)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

addTerm

TermVO addTerm(TermAgent agent)
               throws java.lang.Exception
Throws:
java.lang.Exception

updateTerm

TermVO updateTerm(TermVO vo)
                  throws java.lang.Exception
Throws:
java.lang.Exception

deleteTerm

void deleteTerm(int ii)
                throws java.lang.Exception
Throws:
java.lang.Exception

deleteTerm

void deleteTerm(java.lang.String termValue)
                throws java.lang.Exception
Throws:
java.lang.Exception

getTerm

TermVO getTerm(int ii)
               throws java.lang.Exception
Throws:
java.lang.Exception

getTerm

TermVO getTerm(java.lang.String termValue)
               throws java.lang.Exception
Throws:
java.lang.Exception

getTermUsed

java.lang.String getTermUsed(java.lang.String termValue)
                             throws java.lang.Exception
Throws:
java.lang.Exception

findAllTerms

java.util.Collection<TermVO> findAllTerms(int firstIndex,
                                          int maxLength)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

getAllTermsCount

int getAllTermsCount()
                     throws java.lang.Exception
Throws:
java.lang.Exception

getAllTerms

java.util.Collection<BB2DoubleString> getAllTerms()
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getDwgUploadSettingsVO

DwgUploadSettingsVO getDwgUploadSettingsVO(java.lang.String drawingType)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

updateDwgUploadSettings

void updateDwgUploadSettings(DwgUploadSettingsVO vo)
                             throws java.lang.Exception
Throws:
java.lang.Exception

addDwgUploadSettings

DwgUploadSettingsVO addDwgUploadSettings(DwgUploadSettingsVO vo)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

updatePasswordPolicy

java.lang.Boolean updatePasswordPolicy(PasswordPolicyAgent agent)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

getUserPasswordPairs

java.util.Collection<BB2DoubleString> getUserPasswordPairs(java.lang.String userName)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getDwfUploadSettingsVO

DwfUploadSettingsVO getDwfUploadSettingsVO(java.lang.String drawingType)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

updateDwfUploadSettings

void updateDwfUploadSettings(DwfUploadSettingsVO vo)
                             throws java.lang.Exception
Throws:
java.lang.Exception

addDwfUploadSettings

DwfUploadSettingsVO addDwfUploadSettings(DwfUploadSettingsVO vo)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

isMiscDocExist

boolean isMiscDocExist(java.lang.String docType)
                       throws java.lang.Exception
Throws:
java.lang.Exception

addMiscDocSetting

MiscDocumentSettingVO addMiscDocSetting(MiscDocumentSettingVO vo)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

updateMiscDocSetting

MiscDocumentSettingVO updateMiscDocSetting(MiscDocumentSettingVO vo)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

deleteMiscDocSetting

void deleteMiscDocSetting(MiscDocumentSettingVO vo)
                          throws java.lang.Exception
Throws:
java.lang.Exception

findAllMiscDocSetting

java.util.Collection<MiscDocumentSettingVO> findAllMiscDocSetting(int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getAllMiscDocSettingCount

int getAllMiscDocSettingCount()
                              throws java.lang.Exception
Throws:
java.lang.Exception

findMiscDocSettingByType

MiscDocumentSettingVO findMiscDocSettingByType(java.lang.String docType)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

findMiscDocLog

java.util.Collection<LogMiscDocumentVO> findMiscDocLog(java.lang.String docType,
                                                       java.lang.String docFileName,
                                                       java.lang.String action,
                                                       java.lang.String operator,
                                                       java.lang.String wanIp,
                                                       java.lang.String lanIp,
                                                       java.lang.String macAddress,
                                                       java.lang.String description,
                                                       java.lang.String extension,
                                                       java.lang.String orderNumber,
                                                       java.util.Date dateFrom,
                                                       java.util.Date dateTo,
                                                       int firstIndex,
                                                       int maxLength)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getMiscDocLogCount

int getMiscDocLogCount(java.lang.String docType,
                       java.lang.String docFileName,
                       java.lang.String action,
                       java.lang.String operator,
                       java.lang.String wanIp,
                       java.lang.String lanIp,
                       java.lang.String macAddress,
                       java.lang.String description,
                       java.lang.String extension,
                       java.lang.String orderNumber,
                       java.util.Date dateFrom,
                       java.util.Date dateTo)
                       throws java.lang.Exception
Throws:
java.lang.Exception

findAllZipCode

java.util.Collection<ZipCodeVO> findAllZipCode(java.lang.String zipId,
                                               int firstIndex,
                                               int maxLength)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

getAllZipCodeCount

int getAllZipCodeCount(java.lang.String zipId)
                       throws java.lang.Exception
Throws:
java.lang.Exception

isZipCodeExist

boolean isZipCodeExist(java.lang.String zipId)
                       throws java.lang.Exception
Throws:
java.lang.Exception

getZipName

java.lang.String getZipName(java.lang.String zipId)
                            throws java.lang.Exception
Throws:
java.lang.Exception

getZipCodeByPk

ZipCodeVO getZipCodeByPk(java.lang.String zipId)
                         throws java.lang.Exception
Throws:
java.lang.Exception

addZipCode

ZipCodeVO addZipCode(ZipCodeVO vo)
                     throws java.lang.Exception
Throws:
java.lang.Exception

updateZipCode

ZipCodeVO updateZipCode(ZipCodeVO vo)
                        throws java.lang.Exception
Throws:
java.lang.Exception

deleteZipCode

void deleteZipCode(java.lang.String zipId)
                   throws java.lang.Exception
Throws:
java.lang.Exception

getAllTasksList

java.util.Map<java.lang.String,BB2Task> getAllTasksList()
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

addTask

void addTask(TaskVO vo)
             throws java.lang.Exception
Throws:
java.lang.Exception

updateTask

void updateTask(TaskVO vo)
                throws java.lang.Exception
Throws:
java.lang.Exception

deleteTask

void deleteTask(java.lang.Long ii)
                throws java.lang.Exception
Throws:
java.lang.Exception

isTaskExist

boolean isTaskExist(java.lang.Long ii)
                    throws java.lang.Exception
Throws:
java.lang.Exception

getTask

TaskVO getTask(java.lang.Long ii)
               throws java.lang.Exception
Throws:
java.lang.Exception

findAllTasks

java.util.Collection<TaskVO> findAllTasks(int firstIndex,
                                          int maxLength)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

getAllTasksCount

int getAllTasksCount()
                     throws java.lang.Exception
Throws:
java.lang.Exception

findLogTasks

java.util.Collection<LogTaskVO> findLogTasks(java.lang.String name,
                                             java.util.Date fromDate,
                                             java.util.Date toDate,
                                             int firstIndex,
                                             int maxLength)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

getLogTasksCount

int getLogTasksCount(java.lang.String name,
                     java.util.Date fromDate,
                     java.util.Date toDate)
                     throws java.lang.Exception
Throws:
java.lang.Exception

addMessage

void addMessage(MessageAgent agent)
                throws java.lang.Exception
Throws:
java.lang.Exception

getAllOldMessageCount

int getAllOldMessageCount()
                          throws java.lang.Exception
Throws:
java.lang.Exception

findAllOldMessgeId

java.util.List findAllOldMessgeId()
                                  throws java.lang.Exception
Throws:
java.lang.Exception

dealOldMessage

void dealOldMessage(java.lang.Long id)
                    throws java.lang.Exception
Throws:
java.lang.Exception

readMessage

void readMessage(java.lang.Long ii)
                 throws java.lang.Exception
Throws:
java.lang.Exception

getMessage

MessageVO getMessage(java.lang.Long ii)
                     throws java.lang.Exception
Throws:
java.lang.Exception

removeMessage

void removeMessage(java.lang.Long ii)
                   throws java.lang.Exception
Throws:
java.lang.Exception

removeOldMessages

void removeOldMessages(java.util.Date date)
                       throws java.lang.Exception
Throws:
java.lang.Exception

findMessages

java.util.Collection<MessageVO> findMessages(java.lang.String subject,
                                             java.util.Date fromDate,
                                             java.util.Date toDate,
                                             int firstIndex,
                                             int length)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

getMessagesCount

int getMessagesCount(java.lang.String subject,
                     java.util.Date fromDate,
                     java.util.Date toDate)
                     throws java.lang.Exception
Throws:
java.lang.Exception

findUnreadReceivedMessages

java.util.Collection<MessageVO> findUnreadReceivedMessages(int firstIndex,
                                                           int length)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getUnreadReceivedMessagesCount

int getUnreadReceivedMessagesCount()
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findAllReceivedMessages

java.util.Collection<MessageVO> findAllReceivedMessages(java.lang.String sendUserName,
                                                        java.lang.String sendFrom,
                                                        java.lang.String subject,
                                                        java.lang.String content,
                                                        java.util.Date fromDate,
                                                        java.util.Date toDate,
                                                        int firstIndex,
                                                        int length)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getAllReceivedMessagesCount

int getAllReceivedMessagesCount(java.lang.String sendUserName,
                                java.lang.String sendFrom,
                                java.lang.String subject,
                                java.lang.String content,
                                java.util.Date fromDate,
                                java.util.Date toDate)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findAllSentMessages

java.util.Collection<MessageVO> findAllSentMessages(java.lang.String receiver,
                                                    java.lang.String subject,
                                                    java.lang.String content,
                                                    java.util.Date fromDate,
                                                    java.util.Date toDate,
                                                    int firstIndex,
                                                    int length)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getAllSentMessagesCount

int getAllSentMessagesCount(java.lang.String receiver,
                            java.lang.String subject,
                            java.lang.String content,
                            java.util.Date fromDate,
                            java.util.Date toDate)
                            throws java.lang.Exception
Throws:
java.lang.Exception

addSubcompany

void addSubcompany(SubcompanyVO vo)
                   throws java.lang.Exception
Throws:
java.lang.Exception

updateSubcompany

void updateSubcompany(SubcompanyVO vo)
                      throws java.lang.Exception
Throws:
java.lang.Exception

getSubcompanyById

SubcompanyVO getSubcompanyById(java.lang.String addressId)
                               throws java.lang.Exception
Throws:
java.lang.Exception

deleteSubcompanyById

void deleteSubcompanyById(java.lang.String addressId)
                          throws java.lang.Exception
Throws:
java.lang.Exception

findAllSubcompanysById

java.util.Collection<SubcompanyVO> findAllSubcompanysById(java.lang.String addressId,
                                                          int firstIndex,
                                                          int length)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getAllSubcompanysByIdCount

int getAllSubcompanysByIdCount(java.lang.String addressId)
                               throws java.lang.Exception
Throws:
java.lang.Exception

isSubcompanyExists

boolean isSubcompanyExists(java.lang.String addressId)
                           throws java.lang.Exception
Throws:
java.lang.Exception

updateCompanyId

CompanyVO updateCompanyId(java.lang.String addressId)
                          throws java.lang.Exception
Throws:
java.lang.Exception

addCompanyUnit

CompanyUnitVO addCompanyUnit(CompanyUnitVO vo)
                             throws java.lang.Exception
Throws:
java.lang.Exception

updateCompanyUnit

CompanyUnitVO updateCompanyUnit(CompanyUnitVO vo)
                                throws java.lang.Exception
Throws:
java.lang.Exception

deleteCompanyUnit

void deleteCompanyUnit(java.lang.String id)
                       throws java.lang.Exception
Throws:
java.lang.Exception

isCompanyUnitExistent

boolean isCompanyUnitExistent(java.lang.String id)
                              throws java.lang.Exception
Throws:
java.lang.Exception

getCompanyUnitByPk

CompanyUnitVO getCompanyUnitByPk(java.lang.String id)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findAllCompanyUnit

java.util.Collection<CompanyUnitVO> findAllCompanyUnit(int firstIndex,
                                                       int maxLength)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getAllCompanyUnitCount

int getAllCompanyUnitCount()
                           throws java.lang.Exception
Throws:
java.lang.Exception

isParentCompanyUnit

boolean isParentCompanyUnit(java.lang.String id)
                            throws java.lang.Exception
Throws:
java.lang.Exception

getCompanyUnitListCount

int getCompanyUnitListCount(java.lang.String id,
                            java.lang.String name,
                            java.lang.String type)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findCompanyUnitList

java.util.Collection<CompanyUnitVO> findCompanyUnitList(java.lang.String id,
                                                        java.lang.String name,
                                                        java.lang.String type,
                                                        int firstIndex,
                                                        int maxLength)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

addCompanyUnitAccount

CompanyUnitAccountVO addCompanyUnitAccount(CompanyUnitAccountVO vo)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

updateCompanyUnitAccount

void updateCompanyUnitAccount(CompanyUnitAccountVO vo)
                              throws java.lang.Exception
Throws:
java.lang.Exception

deleteCompanyUnitAccount

void deleteCompanyUnitAccount(CompanyUnitAccountPK pk)
                              throws java.lang.Exception
Throws:
java.lang.Exception

isCompanyUnitAccountExistent

boolean isCompanyUnitAccountExistent(CompanyUnitAccountPK pk)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

getCompanyUnitAccountByPk

CompanyUnitAccountVO getCompanyUnitAccountByPk(CompanyUnitAccountPK pk)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

findAllCompanyUnitAccount

java.util.Collection<CompanyUnitAccountVO> findAllCompanyUnitAccount(int firstIndex,
                                                                     int maxLength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getAllCompanyUnitAccountCount

int getAllCompanyUnitAccountCount()
                                  throws java.lang.Exception
Throws:
java.lang.Exception

getCompanyUnitAccountByCompanyUnit

java.util.Collection<CompanyUnitAccountVO> getCompanyUnitAccountByCompanyUnit(java.lang.String companyUnitId)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getCompanyUnitAccountByAccount

java.util.Map<java.lang.String,java.util.ArrayList<java.lang.String>> getCompanyUnitAccountByAccount()
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getCompanyUnitsByAccountNumber

java.util.Collection<java.lang.String> getCompanyUnitsByAccountNumber(java.lang.String accountNumber)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getAllCompanyUnitsByAccountNumber

java.util.Map<java.lang.String,java.util.Set<BB2DoubleString>> getAllCompanyUnitsByAccountNumber()
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getCompanyUnitAccountWithChild

java.util.Collection<java.lang.String> getCompanyUnitAccountWithChild(java.lang.String companyUnitId)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

addUserGroup

UserGroupVO addUserGroup(UserGroupVO vo)
                         throws java.lang.Exception
Throws:
java.lang.Exception

updateUserGroup

void updateUserGroup(UserGroupVO vo)
                     throws java.lang.Exception
Throws:
java.lang.Exception

getUserGroupByPk

UserGroupVO getUserGroupByPk(java.lang.String id)
                             throws java.lang.Exception
Throws:
java.lang.Exception

deleteUserGroup

void deleteUserGroup(UserGroupVO vo)
                     throws java.lang.Exception
Throws:
java.lang.Exception

deleteUserGroup

void deleteUserGroup(java.lang.String id)
                     throws java.lang.Exception
Throws:
java.lang.Exception

isUserGroupExist

boolean isUserGroupExist(java.lang.String id)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findGroupsByUserName

java.util.Collection<UserGroupVO> findGroupsByUserName(java.lang.String userName,
                                                       int firstIndex,
                                                       int maxLength)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getGroupCountByUserName

int getGroupCountByUserName(java.lang.String owner)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findGroupsBySelf

java.util.Collection<UserGroupVO> findGroupsBySelf(int firstIndex,
                                                   int maxLength)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getGroupCountBySelf

int getGroupCountBySelf()
                        throws java.lang.Exception
Throws:
java.lang.Exception

isSystemUserGroup

boolean isSystemUserGroup(java.lang.String userGroup)
                          throws java.lang.Exception
Throws:
java.lang.Exception

findSystemUserGroup

java.util.Collection<UserGroupVO> findSystemUserGroup(int firstIndex,
                                                      int maxLength)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getSystemUserGroupCount

int getSystemUserGroupCount()
                            throws java.lang.Exception
Throws:
java.lang.Exception

addGroupUser

GroupUserVO addGroupUser(GroupUserVO vo)
                         throws java.lang.Exception
Throws:
java.lang.Exception

updateGroupUser

void updateGroupUser(GroupUserVO vo)
                     throws java.lang.Exception
Throws:
java.lang.Exception

deleteGroupUser

void deleteGroupUser(GroupUserVO vo)
                     throws java.lang.Exception
Throws:
java.lang.Exception

findGroupUserList

java.util.Collection<GroupUserVO> findGroupUserList(java.lang.String userName,
                                                    java.lang.String userGroup,
                                                    int firstIndex,
                                                    int maxLength)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getGroupUserCount

int getGroupUserCount(java.lang.String userName,
                      java.lang.String userGroup)
                      throws java.lang.Exception
Throws:
java.lang.Exception

findNoticeUserEmployee

java.util.Collection<NoticeUserEmployeeListResult> findNoticeUserEmployee(java.lang.String userName,
                                                                          java.lang.String systemUserName,
                                                                          java.lang.String userGroup,
                                                                          int firstIndex,
                                                                          int maxLength)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getNoticeUserEmployeeCount

int getNoticeUserEmployeeCount(java.lang.String userName,
                               java.lang.String systemUserName,
                               java.lang.String userGroup)
                               throws java.lang.Exception
Throws:
java.lang.Exception

deleteGroupUserByUserGroup

void deleteGroupUserByUserGroup(java.lang.String userGroup)
                                throws java.lang.Exception
Throws:
java.lang.Exception

addHelpServer

HelpServerVO addHelpServer(HelpServerVO vo)
                           throws java.lang.Exception
Throws:
java.lang.Exception

updateHelpServer

void updateHelpServer(HelpServerVO vo)
                      throws java.lang.Exception
Throws:
java.lang.Exception

deleteHelpServer

void deleteHelpServer(java.lang.Long pk)
                      throws java.lang.Exception
Throws:
java.lang.Exception

getHelpServerByPk

HelpServerVO getHelpServerByPk(java.lang.Long pk)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getActiveHelpServer

HelpServerVO getActiveHelpServer()
                                 throws java.lang.Exception
Throws:
java.lang.Exception

isActiveHelpServerExist

boolean isActiveHelpServerExist()
                                throws java.lang.Exception
Throws:
java.lang.Exception

findAllHelpServers

java.util.Collection<HelpServerVO> findAllHelpServers(int firstIndex,
                                                      int maxLength)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getAllHelpServerCount

int getAllHelpServerCount()
                          throws java.lang.Exception
Throws:
java.lang.Exception

getOpCodeShortcutByUserName

java.util.Collection<OpCodeShortcutVO> getOpCodeShortcutByUserName(java.lang.String userName)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

updateOpCodeShortcut

void updateOpCodeShortcut(java.util.ArrayList<OpCodeShortcutVO> opCodeShortcuts,
                          java.lang.String userName)
                          throws java.lang.Exception
Throws:
java.lang.Exception

getWorkFlowByName

WorkFlowVO getWorkFlowByName(java.lang.String workFlowName)
                             throws java.lang.Exception
Throws:
java.lang.Exception

findAllWorkFlow

java.util.Collection<WorkFlowVO> findAllWorkFlow(int firstIndex,
                                                 int maxLength)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getAllWorkFlowCount

int getAllWorkFlowCount()
                        throws java.lang.Exception
Throws:
java.lang.Exception

addWorkFlow

void addWorkFlow(WorkFlowVO workFlowVO)
                 throws java.lang.Exception
Throws:
java.lang.Exception

updateWorkFlow

void updateWorkFlow(WorkFlowVO workFlowVO)
                    throws java.lang.Exception
Throws:
java.lang.Exception

isWorkFlowExist

boolean isWorkFlowExist(java.lang.String workFlowName)
                        throws java.lang.Exception
Throws:
java.lang.Exception

deleteWorkFlow

void deleteWorkFlow(java.lang.String workFlowName)
                    throws java.lang.Exception
Throws:
java.lang.Exception

getAccountingConfiguration

AccountingConfigurationVO getAccountingConfiguration()
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

updateAccountingConfiguration

AccountingConfigurationVO updateAccountingConfiguration(AccountingConfigurationVO vo)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

deleteTempPart

void deleteTempPart(int ii)
                    throws java.lang.Exception
Throws:
java.lang.Exception

findDuplicateTempPart

java.util.Collection<ImportDataVO> findDuplicateTempPart(int firstIndex,
                                                         int maxLength)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getDuplicateTempPartCount

int getDuplicateTempPartCount()
                              throws java.lang.Exception
Throws:
java.lang.Exception

findExistPart

java.util.Collection<ImportDataVO> findExistPart()
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findTempPart

java.util.Collection<ImportDataVO> findTempPart(int firstIndex,
                                                int maxLength)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

getTempPartCount

int getTempPartCount()
                     throws java.lang.Exception
Throws:
java.lang.Exception

importTempPart

void importTempPart(java.util.ArrayList<PartVO> datas)
                    throws java.lang.Exception
Throws:
java.lang.Exception

updateTempPart

void updateTempPart(ImportDataVO info)
                    throws java.lang.Exception
Throws:
java.lang.Exception

importPart

void importPart(boolean update)
                throws java.lang.Exception
Throws:
java.lang.Exception

deleteTempBOM

void deleteTempBOM(int ii)
                   throws java.lang.Exception
Throws:
java.lang.Exception

findBOMNotPart

java.util.Collection<ImportDataVO> findBOMNotPart()
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

findBOMItemNotPart

java.util.Collection<ImportDataVO> findBOMItemNotPart()
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

findDuplicateTempBOM

java.util.Collection<ImportDataVO> findDuplicateTempBOM(int firstIndex,
                                                        int maxLength)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getDuplicateTempBOMCount

int getDuplicateTempBOMCount()
                             throws java.lang.Exception
Throws:
java.lang.Exception

findExistBOM

java.util.Collection<ImportDataVO> findExistBOM()
                                                throws java.lang.Exception
Throws:
java.lang.Exception

findTempBOM

java.util.Collection<ImportDataVO> findTempBOM(int firstIndex,
                                               int maxLength)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

getTempBOMCount

int getTempBOMCount()
                    throws java.lang.Exception
Throws:
java.lang.Exception

importBOM

void importBOM()
               throws java.lang.Exception
Throws:
java.lang.Exception

deleteAllTempBOM

void deleteAllTempBOM()
                      throws java.lang.Exception
Throws:
java.lang.Exception

importTempBOM

void importTempBOM(java.util.ArrayList<BillItemVO> bills)
                   throws java.lang.Exception
Throws:
java.lang.Exception

updateTempBOM

void updateTempBOM(ImportDataVO vo)
                   throws java.lang.Exception
Throws:
java.lang.Exception

deleteTempInventory

void deleteTempInventory(int ii)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findDuplicateTempInventory

java.util.Collection<ImportDataVO> findDuplicateTempInventory(int firstIndex,
                                                              int maxLength)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getDuplicateTempInventoryCount

int getDuplicateTempInventoryCount()
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findExistInventory

java.util.Collection<ImportDataVO> findExistInventory()
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

findNotPartInventory

java.util.Collection<ImportDataVO> findNotPartInventory()
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

findTempInventory

java.util.Collection<ImportDataVO> findTempInventory(int firstIndex,
                                                     int maxLength)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getTempInventoryCount

int getTempInventoryCount()
                          throws java.lang.Exception
Throws:
java.lang.Exception

importTempInventory

void importTempInventory(java.util.ArrayList<PartOnhandWithAverageCostResult> inventorys)
                         throws java.lang.Exception
Throws:
java.lang.Exception

updateTempInventory

void updateTempInventory(ImportDataVO vo)
                         throws java.lang.Exception
Throws:
java.lang.Exception

importInventory

void importInventory()
                     throws java.lang.Exception
Throws:
java.lang.Exception

deleteTempMaterial

void deleteTempMaterial(int ii)
                        throws java.lang.Exception
Throws:
java.lang.Exception

findDuplicateTempMaterial

java.util.Collection<ImportDataVO> findDuplicateTempMaterial(int firstIndex,
                                                             int maxLength)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getDuplicateTempMaterialCount

int getDuplicateTempMaterialCount()
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findNotPartTempMaterial

java.util.Collection<ImportDataVO> findNotPartTempMaterial()
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

findExistMaterial

java.util.Collection<ImportDataVO> findExistMaterial()
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

findTempMaterial

java.util.Collection<ImportDataVO> findTempMaterial(int firstIndex,
                                                    int maxLength)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getTempMaterialCount

int getTempMaterialCount()
                         throws java.lang.Exception
Throws:
java.lang.Exception

importMaterial

void importMaterial()
                    throws java.lang.Exception
Throws:
java.lang.Exception

importTempMaterial

void importTempMaterial(java.util.ArrayList<PartMaterialVO> materials)
                        throws java.lang.Exception
Throws:
java.lang.Exception

updateTempMaterial

void updateTempMaterial(ImportDataVO vo)
                        throws java.lang.Exception
Throws:
java.lang.Exception

deleteTempNccode

void deleteTempNccode(int ii)
                      throws java.lang.Exception
Throws:
java.lang.Exception

findDuplicateTempNccode

java.util.Collection<ImportDataVO> findDuplicateTempNccode(int firstIndex,
                                                           int maxLength)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getDuplicateTempNccodeCount

int getDuplicateTempNccodeCount()
                                throws java.lang.Exception
Throws:
java.lang.Exception

findExistNccode

java.util.Collection<ImportDataVO> findExistNccode()
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

findTempNccode

java.util.Collection<ImportDataVO> findTempNccode(int firstIndex,
                                                  int maxLength)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getTempNccodeCount

int getTempNccodeCount()
                       throws java.lang.Exception
Throws:
java.lang.Exception

importNccode

void importNccode()
                  throws java.lang.Exception
Throws:
java.lang.Exception

importTempNccode

void importTempNccode(java.util.ArrayList<NonConformanceCodeVO> nccodes)
                      throws java.lang.Exception
Throws:
java.lang.Exception

updateTempNccode

void updateTempNccode(ImportDataVO vo)
                      throws java.lang.Exception
Throws:
java.lang.Exception

deleteTempAddress

void deleteTempAddress(int ii)
                       throws java.lang.Exception
Throws:
java.lang.Exception

findDuplicateTempAddress

java.util.Collection<ImportDataVO> findDuplicateTempAddress(int firstIndex,
                                                            int maxLength)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getDuplicateTempAddressCount

int getDuplicateTempAddressCount()
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findExistAddress

java.util.Collection<ImportDataVO> findExistAddress(java.lang.String type)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

findTempAddress

java.util.Collection<ImportDataVO> findTempAddress(java.lang.String type,
                                                   int firstIndex,
                                                   int maxLength)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getTempAddressCount

int getTempAddressCount(java.lang.String type)
                        throws java.lang.Exception
Throws:
java.lang.Exception

importAddress

void importAddress()
                   throws java.lang.Exception
Throws:
java.lang.Exception

importCustomer

void importCustomer()
                    throws java.lang.Exception
Throws:
java.lang.Exception

importVendor

void importVendor()
                  throws java.lang.Exception
Throws:
java.lang.Exception

importDepartment

void importDepartment()
                      throws java.lang.Exception
Throws:
java.lang.Exception

importTempAddress

void importTempAddress(java.util.ArrayList<CustomerVendorAddressVO> address)
                       throws java.lang.Exception
Throws:
java.lang.Exception

importTempCustomer

void importTempCustomer(java.util.ArrayList<CustomerVendorAddressVO> address)
                        throws java.lang.Exception
Throws:
java.lang.Exception

importTempVendor

void importTempVendor(java.util.ArrayList<CustomerVendorAddressVO> address)
                      throws java.lang.Exception
Throws:
java.lang.Exception

importTempDepartment

void importTempDepartment(java.util.ArrayList<CustomerVendorAddressVO> address)
                          throws java.lang.Exception
Throws:
java.lang.Exception

updateTempAddress

void updateTempAddress(ImportDataVO vo)
                       throws java.lang.Exception
Throws:
java.lang.Exception

deleteTempManufacture

void deleteTempManufacture(int ii)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findDuplicateTempManufacture

java.util.Collection<ImportDataVO> findDuplicateTempManufacture(int firstIndex,
                                                                int maxLength)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getDuplicateTempManufactureCount

int getDuplicateTempManufactureCount()
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findExistManufacture

java.util.Collection<ImportDataVO> findExistManufacture()
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

findTempManufacture

java.util.Collection<ImportDataVO> findTempManufacture(int firstIndex,
                                                       int maxLength)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getTempManufactureCount

int getTempManufactureCount()
                            throws java.lang.Exception
Throws:
java.lang.Exception

importManufacture

void importManufacture()
                       throws java.lang.Exception
Throws:
java.lang.Exception

importTempManufacture

void importTempManufacture(java.util.ArrayList<ManufacturerAddressVO> address)
                           throws java.lang.Exception
Throws:
java.lang.Exception

updateTempManufacture

void updateTempManufacture(ImportDataVO vo)
                           throws java.lang.Exception
Throws:
java.lang.Exception

deleteTempMPN

void deleteTempMPN(int ii)
                   throws java.lang.Exception
Throws:
java.lang.Exception

findTempMPN

java.util.Collection<ImportDataVO> findTempMPN(int firstIndex,
                                               int maxLength)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

getTempMPNCount

int getTempMPNCount()
                    throws java.lang.Exception
Throws:
java.lang.Exception

importMPN

void importMPN()
               throws java.lang.Exception
Throws:
java.lang.Exception

findTempMPNDataProblem

java.util.HashMap<java.lang.Integer,java.lang.String> findTempMPNDataProblem()
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

importTempMPN

void importTempMPN(java.util.ArrayList<PartManufacturerVO> mpns)
                   throws java.lang.Exception
Throws:
java.lang.Exception

updateTempMPN

void updateTempMPN(ImportDataVO vo)
                   throws java.lang.Exception
Throws:
java.lang.Exception

deleteTempEmployee

void deleteTempEmployee(int ii)
                        throws java.lang.Exception
Throws:
java.lang.Exception

findDuplicateTempEmployee

java.util.Collection<ImportDataVO> findDuplicateTempEmployee(int firstIndex,
                                                             int maxLength)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getDuplicateTempEmployeeCount

int getDuplicateTempEmployeeCount()
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findExistEmployee

java.util.Collection<ImportDataVO> findExistEmployee()
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

findTempEmployee

java.util.Collection<ImportDataVO> findTempEmployee(int firstIndex,
                                                    int maxLength)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getTempEmployeeCount

int getTempEmployeeCount()
                         throws java.lang.Exception
Throws:
java.lang.Exception

importTempEmployee

void importTempEmployee(java.util.ArrayList<EmployeeCardVO> employees)
                        throws java.lang.Exception
Throws:
java.lang.Exception

importEmployee

void importEmployee()
                    throws java.lang.Exception
Throws:
java.lang.Exception

updateTempEmployee

void updateTempEmployee(ImportDataVO vo)
                        throws java.lang.Exception
Throws:
java.lang.Exception

exportEngSharingPart

void exportEngSharingPart(java.lang.Long ii)
                          throws java.lang.Exception
Throws:
java.lang.Exception

getAllFileByTaskId

java.util.Collection<TaskFileResult> getAllFileByTaskId(java.lang.Long ii)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

downTaskFileByTaskId

byte[] downTaskFileByTaskId(java.lang.Long ii,
                            java.lang.String fileName)
                            throws java.lang.Exception
Throws:
java.lang.Exception

importContractPrice

void importContractPrice(java.util.ArrayList<ImportContractPriceData> datas)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findContractPriceItemByPartNumberList

java.util.HashMap<PartPK,ContractPriceItemVO> findContractPriceItemByPartNumberList(java.lang.String contractNumber,
                                                                                java.util.HashSet<PartPK> pks)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findContractPriceCustomerByCustomList

java.util.HashMap<java.lang.String,ContractPriceCustomerVO> findContractPriceCustomerByCustomList(java.lang.String contractNumber,
                                                                                java.util.HashSet<java.lang.String> ids)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

importPartMinMaxQty

void importPartMinMaxQty(java.util.ArrayList<PartVO> parts)
                         throws java.lang.Exception
Throws:
java.lang.Exception

getStartNumber

java.lang.String getStartNumber()
                                throws java.lang.Exception
Throws:
java.lang.Exception

updatePartNumberGenerateRule

void updatePartNumberGenerateRule(java.lang.String nextStartPartNumber)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

addPrintTemplate

PrintTemplateVO addPrintTemplate(PrintTemplateVO vo)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

updatePrintTemplate

void updatePrintTemplate(PrintTemplateVO vo)
                         throws java.lang.Exception
Throws:
java.lang.Exception

getPrintTemplate

PrintTemplateVO getPrintTemplate(int id)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

isPrintTemplateExist

boolean isPrintTemplateExist(int id)
                             throws java.lang.Exception
Throws:
java.lang.Exception

deletePrintTemplate

void deletePrintTemplate(int id)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findAllPrintTemplate

java.util.Collection<PrintTemplateVO> findAllPrintTemplate(int firstIndex,
                                                           int maxLength)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getAllPrintTemplateCount

int getAllPrintTemplateCount()
                             throws java.lang.Exception
Throws:
java.lang.Exception

findCustomSearchTotalResult

java.util.Collection findCustomSearchTotalResult(java.util.ArrayList<java.lang.String> sqls,
                                                 java.util.HashMap<java.lang.String,java.lang.Object> map,
                                                 java.lang.String clazz)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findPrintTemplatebyClazz

java.util.Collection<PrintTemplateVO> findPrintTemplatebyClazz(java.lang.String clazz,
                                                               int firstIndex,
                                                               int maxLength)
                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getPrintTemplatebyClazzCount

int getPrintTemplatebyClazzCount(java.lang.String clazz)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

getPointOfSale

PointOfSaleVO getPointOfSale()
                             throws java.lang.Exception
Throws:
java.lang.Exception

updatePointOfSale

PointOfSaleVO updatePointOfSale(PointOfSaleVO vo)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findPayment

java.util.Collection<PayableMethodVO> findPayment(java.lang.String paymentName)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getPaymentCount

java.lang.Integer getPaymentCount(java.lang.String paymentName)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

getPaymentByName

PayableMethodVO getPaymentByName(java.lang.String paymentName)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

getPaymentById

PayableMethodVO getPaymentById(int paymentId)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getPayment

PayableMethodVO getPayment()
                           throws java.lang.Exception
Throws:
java.lang.Exception

deletePayment

void deletePayment(PayableMethodVO vo)
                   throws java.lang.Exception
Throws:
java.lang.Exception

addPayment

PayableMethodVO addPayment(PayableMethodVO vo)
                           throws java.lang.Exception
Throws:
java.lang.Exception

updatePayment

PayableMethodVO updatePayment(PayableMethodVO vo)
                              throws java.lang.Exception
Throws:
java.lang.Exception

addCashier

CashierVO addCashier(CashierVO vo)
                     throws java.lang.Exception
Throws:
java.lang.Exception

updateCashier

CashierVO updateCashier(CashierVO vo)
                        throws java.lang.Exception
Throws:
java.lang.Exception

deleteCashier

void deleteCashier(CashierVO vo)
                   throws java.lang.Exception
Throws:
java.lang.Exception

findAllCashier

java.util.Collection<CashierVO> findAllCashier(int firstIndex,
                                               int maxLength)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

getAllCashierCount

int getAllCashierCount()
                       throws java.lang.Exception
Throws:
java.lang.Exception

getCashier

CashierVO getCashier(java.lang.String cashier)
                     throws java.lang.Exception
Throws:
java.lang.Exception

isExistCashier

boolean isExistCashier(java.lang.String cashier)
                       throws java.lang.Exception
Throws:
java.lang.Exception

addRunningAccountOrder

RunningAccountOrderVO[] addRunningAccountOrder(RunningAccountOrderVO vo)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

addReturnOrder

RunningAccountOrderVO addReturnOrder(RunningAccountOrderVO vo,
                                     java.lang.String raoNumber)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

AdjustInventoryByPos

void AdjustInventoryByPos(java.util.Collection<RunningAccountOrderItemResult> result)
                          throws java.lang.Exception
Throws:
java.lang.Exception

getRunningAccountOrderItemByPartPK

RunningAccountOrderItemVO getRunningAccountOrderItemByPartPK(PartPK pk)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getRunningAccountOrderItemByPartPK

RunningAccountOrderItemVO getRunningAccountOrderItemByPartPK(PartPK pk,
                                                             java.lang.String customerId,
                                                             java.lang.String mfgPartNumber)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getRunningAccountOrderItemByRaoNumberandPartPK

RunningAccountOrderItemVO getRunningAccountOrderItemByRaoNumberandPartPK(java.lang.String raoNumber,
                                                                         PartPK pk)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

findRunningAccountOrderItems

java.util.Collection<RunningAccountOrderItemResult> findRunningAccountOrderItems(java.lang.String raoNumber,
                                                                                java.lang.String[] includeVendorId,
                                                                                java.lang.String[] excludeVendorId,
                                                                                java.lang.String payableMethod,
                                                                                java.util.Date fromDate,
                                                                                java.util.Date toDate,
                                                                                java.lang.String orderType,
                                                                                boolean isMakeOrder,
                                                                                java.lang.String partNumber,
                                                                                java.lang.String partType,
                                                                                java.lang.String description,
                                                                                java.lang.String modelNumber,
                                                                                java.lang.String commodityCode,
                                                                                java.lang.String productCode,
                                                                                boolean showNegative,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findReceiptItemsByNegativeOnhand

java.util.Collection<RunningAccountOrderItemResult> findReceiptItemsByNegativeOnhand(java.lang.String raoNumber,
                                                                                java.lang.String[] includeVendorId,
                                                                                java.lang.String[] excludeVendorId,
                                                                                java.lang.String payableMethod,
                                                                                java.util.Date fromDate,
                                                                                java.util.Date toDate,
                                                                                java.lang.String orderType,
                                                                                boolean isMakeOrder,
                                                                                java.lang.String partNumber,
                                                                                java.lang.String partType,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getRunningAccountOrderItemCount

int getRunningAccountOrderItemCount(java.lang.String raoNumber,
                                    java.lang.String[] includeVendorId,
                                    java.lang.String[] excludeVendorId,
                                    java.lang.String payableMethod,
                                    java.util.Date fromDate,
                                    java.util.Date toDate,
                                    java.lang.String orderType,
                                    boolean isMakeOrder,
                                    java.lang.String partNumber,
                                    java.lang.String partType,
                                    java.lang.String description,
                                    java.lang.String modelNumber,
                                    java.lang.String commodityCode,
                                    java.lang.String productCode)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findRaoTotal

AccountingTotalMoneyResult findRaoTotal(java.lang.String raoNumber,
                                        java.lang.String[] includeVendorId,
                                        java.lang.String[] excludeVendorId,
                                        java.lang.String payableMethod,
                                        java.util.Date fromDate,
                                        java.util.Date toDate,
                                        java.lang.String orderType,
                                        boolean isMakeOrder,
                                        java.lang.String partNumber,
                                        java.lang.String partType,
                                        boolean showNegative)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findReceiptOrders

java.util.Collection<RunningAccountOrderVO> findReceiptOrders(java.lang.String raoNumber,
                                                              java.lang.String[] includeVendorId,
                                                              java.lang.String[] excludeVendorId,
                                                              java.lang.String payableMethod,
                                                              java.util.Date fromDate,
                                                              java.util.Date toDate,
                                                              java.lang.String orderType,
                                                              boolean isMakeOrder,
                                                              int firstIndex,
                                                              int maxLength)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getReceiptOrdersCount

int getReceiptOrdersCount(java.lang.String raoNumber,
                          java.lang.String[] includeVendorId,
                          java.lang.String[] excludeVendorId,
                          java.lang.String payableMethod,
                          java.util.Date fromDate,
                          java.util.Date toDate,
                          java.lang.String orderType,
                          boolean isMakeOrder)
                          throws java.lang.Exception
Throws:
java.lang.Exception

findReceiptOrderTotal

AccountingTotalMoneyResult findReceiptOrderTotal(java.lang.String raoNumber,
                                                 java.lang.String[] includeVendorId,
                                                 java.lang.String[] excludeVendorId,
                                                 java.lang.String payableMethod,
                                                 java.util.Date fromDate,
                                                 java.util.Date toDate,
                                                 java.lang.String orderType,
                                                 boolean isMakeOrder)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

makeSalesOrderAndShipperAndARAndGL

void makeSalesOrderAndShipperAndARAndGL(java.util.Date fromDate,
                                        java.util.Date toDate)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

makeSalesOrder

java.util.List<java.lang.String> makeSalesOrder(java.util.ArrayList<RunningAccountOrderItemResult> result)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

makeSalesOrder

java.lang.String makeSalesOrder(java.util.ArrayList<RunningAccountOrderItemResult> result,
                                boolean onlyInvoice)
                                throws java.lang.Exception
Throws:
java.lang.Exception

makeAllActionForReceiptFromAdding

java.lang.String[] makeAllActionForReceiptFromAdding(RunningAccountOrderVO raVO)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

makeAllActionForReturnFromAdding

java.lang.String makeAllActionForReturnFromAdding(RunningAccountOrderVO raVO,
                                                  java.lang.String originalReceiptNumber)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

makeReturnMaterialAuthorization

java.util.List<java.lang.String> makeReturnMaterialAuthorization(java.util.ArrayList<RunningAccountOrderItemResult> result)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findSalesDateNoExistSalesOder

java.util.List findSalesDateNoExistSalesOder()
                                             throws java.lang.Exception
Throws:
java.lang.Exception

getRunningAccountOrderById

RunningAccountOrderVO getRunningAccountOrderById(java.lang.String raoNumber)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

updateSignature

void updateSignature(java.util.List<CheckInvoiceItemListResult> results,
                     byte[] elecSignature)
                     throws java.lang.Exception
Throws:
java.lang.Exception

getCaneRunningAccountOrder

RunningAccountOrderVO getCaneRunningAccountOrder(java.lang.String raoNumber)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getRunningAccountOrderItem

RunningAccountOrderItemVO getRunningAccountOrderItem(RunningAccountOrderItemPK pk)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

initDatabase

void initDatabase(java.lang.String languageCode)
                  throws java.lang.Exception
Throws:
java.lang.Exception

getAddressOfCompanyID

CustomerVendorAddressVO getAddressOfCompanyID()
                                              throws java.lang.Exception
Throws:
java.lang.Exception

importTempTool

void importTempTool(java.util.ArrayList<ToolVO> datas)
                    throws java.lang.Exception
Throws:
java.lang.Exception

importTempToolInventory

void importTempToolInventory(java.util.ArrayList<ToolOnhandWithAverageCostResult> datas)
                             throws java.lang.Exception
Throws:
java.lang.Exception

findTempTool

java.util.Collection<ImportDataVO> findTempTool(int firstIndex,
                                                int maxLength)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

getTempToolCount

int getTempToolCount()
                     throws java.lang.Exception
Throws:
java.lang.Exception

importTool

void importTool(boolean update)
                throws java.lang.Exception
Throws:
java.lang.Exception

deleteTempTool

void deleteTempTool(int ii)
                    throws java.lang.Exception
Throws:
java.lang.Exception

updateTempTool

void updateTempTool(ImportDataVO vo)
                    throws java.lang.Exception
Throws:
java.lang.Exception

findDuplicateTempTool

java.util.Collection<ImportDataVO> findDuplicateTempTool(int firstIndex,
                                                         int maxLength)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getDuplicateTempToolCount

int getDuplicateTempToolCount()
                              throws java.lang.Exception
Throws:
java.lang.Exception

findExistTool

java.util.Collection<ImportDataVO> findExistTool()
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findCustomSearchResult

java.util.Collection<java.lang.Object> findCustomSearchResult(java.util.ArrayList<java.lang.String> sqls,
                                                              java.util.HashMap<java.lang.String,java.lang.Object> map,
                                                              java.lang.String clazz,
                                                              int firstIndex,
                                                              int maxLength)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getCustomSearchResultCount

int getCustomSearchResultCount(java.util.ArrayList<java.lang.String> sqls,
                               java.util.HashMap<java.lang.String,java.lang.Object> map)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findTempToolInventory

java.util.Collection<ImportDataVO> findTempToolInventory(int firstIndex,
                                                         int maxLength)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getTempToolInventoryCount

int getTempToolInventoryCount()
                              throws java.lang.Exception
Throws:
java.lang.Exception

importToolInventory

void importToolInventory(boolean update)
                         throws java.lang.Exception
Throws:
java.lang.Exception

deleteTempToolInventory

void deleteTempToolInventory(int ii)
                             throws java.lang.Exception
Throws:
java.lang.Exception

updateTempToolInventory

void updateTempToolInventory(ImportDataVO vo)
                             throws java.lang.Exception
Throws:
java.lang.Exception

findDuplicateTempToolInventory

java.util.Collection<ImportDataVO> findDuplicateTempToolInventory(int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getDuplicateTempToolInventoryCount

int getDuplicateTempToolInventoryCount()
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findExistToolInventory

java.util.Collection<ImportDataVO> findExistToolInventory()
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

findNotToolInventory

java.util.Collection<ImportDataVO> findNotToolInventory()
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getMysqlVersion

java.lang.String getMysqlVersion()
                                 throws java.lang.Exception
Throws:
java.lang.Exception

getBB2DatabaseVersion

java.lang.String getBB2DatabaseVersion()
                                       throws java.lang.Exception
Throws:
java.lang.Exception

updateCustomTranslation

void updateCustomTranslation(java.util.Set<CustomTranslationVO> customTranslations)
                             throws java.lang.Exception
Throws:
java.lang.Exception

findAllCustomTranslation

java.util.Collection<CustomTranslationVO> findAllCustomTranslation()
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getServerClientProperties

java.util.Collection<ServerClientPropertyVO> getServerClientProperties(java.lang.String id)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getMyServerClientProperty

ServerClientPropertyVO getMyServerClientProperty(java.lang.String id)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

putServerClientProperty

void putServerClientProperty(java.lang.String id,
                             java.lang.String value)
                             throws java.lang.Exception
Throws:
java.lang.Exception

updateBySql

void updateBySql(java.lang.String sql)
                 throws java.lang.Exception
Throws:
java.lang.Exception

createAppTable

void createAppTable(java.lang.String tableName,
                    java.lang.String contents)
                    throws java.lang.Exception
Throws:
java.lang.Exception

createAppColumn

void createAppColumn(java.lang.String tableName,
                     java.lang.String columnName,
                     java.lang.String content)
                     throws java.lang.Exception
Throws:
java.lang.Exception

dropAppTable

void dropAppTable(java.lang.String tableName)
                  throws java.lang.Exception
Throws:
java.lang.Exception

dropAppColumn

void dropAppColumn(java.lang.String tableName,
                   java.lang.String columnName)
                   throws java.lang.Exception
Throws:
java.lang.Exception

updateAppData

void updateAppData(java.lang.String sql,
                   java.util.HashMap parameters)
                   throws java.lang.Exception
Throws:
java.lang.Exception

updateAppData

void updateAppData(java.util.Collection<java.lang.Object[]> sqls)
                   throws java.lang.Exception
Throws:
java.lang.Exception

findAppDataBySql

java.util.Collection<java.util.Map> findAppDataBySql(java.lang.String sql,
                                                     java.util.HashMap parameters,
                                                     int firstIndex,
                                                     int maxLength)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getAppDataCountBySql

int getAppDataCountBySql(java.lang.String sql,
                         java.util.HashMap parameters)
                         throws java.lang.Exception
Throws:
java.lang.Exception

isAppTableExist

boolean isAppTableExist(java.lang.String tableName)
                        throws java.lang.Exception
Throws:
java.lang.Exception

isAppTableColumnExist

boolean isAppTableColumnExist(java.lang.String tableName,
                              java.lang.String columnName)
                              throws java.lang.Exception
Throws:
java.lang.Exception

getTableAppColumns

java.util.Collection<java.util.Map> getTableAppColumns(java.lang.String tableName)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

isAppPropertyExist

boolean isAppPropertyExist(java.lang.String id)
                           throws java.lang.Exception
Throws:
java.lang.Exception

setAppProperty

void setAppProperty(java.lang.String id,
                    java.lang.String value)
                    throws java.lang.Exception
Throws:
java.lang.Exception

removeAppProperty

void removeAppProperty(java.lang.String id)
                       throws java.lang.Exception
Throws:
java.lang.Exception

getAppProperty

java.lang.String getAppProperty(java.lang.String id)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findAllAppColumns

java.util.HashMap<java.lang.String,java.util.ArrayList<AppColumnVO>> findAllAppColumns()
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

reloadServer

void reloadServer()
                  throws java.lang.Exception
Throws:
java.lang.Exception

addCustomColumn

void addCustomColumn(AppColumnVO vo)
                     throws java.lang.Exception
Throws:
java.lang.Exception

deleteCustomColumn

void deleteCustomColumn(AppColumnVO vo)
                        throws java.lang.Exception
Throws:
java.lang.Exception

updateCustomColumn

void updateCustomColumn(AppColumnVO vo)
                        throws java.lang.Exception
Throws:
java.lang.Exception

findTablesByName

java.util.Collection<java.util.Map> findTablesByName(java.lang.String tableName)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

findTableColumnsByName

java.util.Collection<java.util.Map> findTableColumnsByName(java.lang.String tableName,
                                                           java.lang.String columnName)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

executeSql

void executeSql(java.lang.String str)
                throws java.lang.Exception
Throws:
java.lang.Exception

queryBySql

java.lang.Object queryBySql(java.lang.String sql)
                            throws java.lang.Exception
Throws:
java.lang.Exception

addCustomSearch

void addCustomSearch(CustomSearchVO vo)
                     throws java.lang.Exception
Throws:
java.lang.Exception

updateCustomSearch

void updateCustomSearch(CustomSearchVO vo)
                        throws java.lang.Exception
Throws:
java.lang.Exception

getCustomSearch

CustomSearchVO getCustomSearch(java.lang.String id)
                               throws java.lang.Exception
Throws:
java.lang.Exception

deleteCustomSearch

void deleteCustomSearch(CustomSearchVO vo)
                        throws java.lang.Exception
Throws:
java.lang.Exception

findAllCustomSearch

java.util.Collection<CustomSearchVO> findAllCustomSearch()
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getAllCustomSearchCount

int getAllCustomSearchCount()
                            throws java.lang.Exception
Throws:
java.lang.Exception

invokeDaoMethod

java.lang.Object invokeDaoMethod(java.lang.String daoName,
                                 java.lang.String methodName,
                                 java.lang.Object[] parameters,
                                 java.lang.Class[] parameterTypes)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

addPosZipCodeTax

PosZipCodeTaxVO addPosZipCodeTax(PosZipCodeTaxVO vo)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findPosZipCodeTaxsList

java.util.Collection<PosZipCodeTaxVO> findPosZipCodeTaxsList()
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getPosZipCodeTaxByPK

PosZipCodeTaxVO getPosZipCodeTaxByPK(PosZipCodeTaxPK pk)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

getPosZipCodeTaxByZipCode

PosZipCodeTaxVO getPosZipCodeTaxByZipCode(java.lang.String zipCode)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

isPosZipCodeTaxExistent

boolean isPosZipCodeTaxExistent(java.lang.String zipCode)
                                throws java.lang.Exception
Throws:
java.lang.Exception

updatePosZipCodeTaxs

void updatePosZipCodeTaxs(java.util.Collection<PosZipCodeTaxVO> list)
                          throws java.lang.Exception
Throws:
java.lang.Exception

findReceiptByCustomer

java.util.Collection<ZipcodeTotalsResult> findReceiptByCustomer(java.util.Date fromDate,
                                                                java.util.Date toDate)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findTaxTotalByZipCode

java.util.Collection<ZipcodeTotalsResult> findTaxTotalByZipCode(java.util.Date fromDate,
                                                                java.util.Date toDate)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findTaxTotalByCustomerId

java.util.Collection<ZipcodeTotalsResult> findTaxTotalByCustomerId(java.util.Date fromDate,
                                                                   java.util.Date toDate)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getTaxTotal

ZipcodeTotalsResult getTaxTotal(java.util.Date fromDate,
                                java.util.Date toDate)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findTaxExemptTotalByCustomerId

java.util.Collection<ZipcodeTotalsResult> findTaxExemptTotalByCustomerId(java.util.Date fromDate,
                                                                         java.util.Date toDate)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

findTaxExemptTotalByTaxType

java.util.Collection<ZipcodeTotalsResult> findTaxExemptTotalByTaxType(java.util.Date fromDate,
                                                                      java.util.Date toDate)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

findTaxComputationByZipCode

java.util.HashMap<java.lang.String,java.util.List<ZipcodeTotalsResult>> findTaxComputationByZipCode(java.util.Date fromDate,
                                                                                java.util.Date toDate)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findTaxExemptTotalByCity

java.util.Collection<ZipcodeTotalsResult> findTaxExemptTotalByCity(java.lang.String city,
                                                                   java.util.Date fromDate,
                                                                   java.util.Date toDate)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getTaxExemptTotalByCityCount

int getTaxExemptTotalByCityCount(java.lang.String city,
                                 java.util.Date fromDate,
                                 java.util.Date toDate)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findMoneyInDrawByComputer

java.util.List<MoneyInDrawResult> findMoneyInDrawByComputer()
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getMoneyInDrawByComputerCount

int getMoneyInDrawByComputerCount()
                                  throws java.lang.Exception
Throws:
java.lang.Exception

getMoneyInDrawByComputerTotal

java.util.List<MoneyInDrawResult> getMoneyInDrawByComputerTotal()
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findAllDataFilter

java.util.Collection<DataFilterVO> findAllDataFilter(int firstIndex,
                                                     int maxLength)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getAllDataFilterCount

int getAllDataFilterCount()
                          throws java.lang.Exception
Throws:
java.lang.Exception

addDataFilter

void addDataFilter(DataFilterVO vo)
                   throws java.lang.Exception
Throws:
java.lang.Exception

updateDataFilter

void updateDataFilter(DataFilterVO vo)
                      throws java.lang.Exception
Throws:
java.lang.Exception

getDataFilter

DataFilterVO getDataFilter(java.lang.String id)
                           throws java.lang.Exception
Throws:
java.lang.Exception

deleteDataFilter

void deleteDataFilter(java.lang.String id)
                      throws java.lang.Exception
Throws:
java.lang.Exception

addCommonPrintTemplate

CommonPrintTemplateVO addCommonPrintTemplate(CommonPrintTemplateVO vo)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

updateCommonPrintTemplate

CommonPrintTemplateVO updateCommonPrintTemplate(CommonPrintTemplateVO vo)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

deleteCommonPrintTemplate

void deleteCommonPrintTemplate(CommonPrintTemplateVO vo)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getCommonPrintTemplate

CommonPrintTemplateVO getCommonPrintTemplate(int id)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findCommonPrintTemplate

java.util.Collection<CommonPrintTemplateVO> findCommonPrintTemplate(int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getCommonPrintTemplateCount

int getCommonPrintTemplateCount()
                                throws java.lang.Exception
Throws:
java.lang.Exception

getAppColumnByTableNameAndColumnName

AppColumnVO getAppColumnByTableNameAndColumnName(java.lang.String tableName,
                                                 java.lang.String columnName)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

uploadOrUpdateFTPOrderDoc

java.util.Collection<OrderDocumentVO> uploadOrUpdateFTPOrderDoc(MiscDocAgent agent)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

deleteFTPOrderDoc

void deleteFTPOrderDoc(MiscDocAgent agent)
                       throws java.lang.Exception
Throws:
java.lang.Exception

findOrderDocListByOrderNumber

java.util.Collection<OrderDocumentVO> findOrderDocListByOrderNumber(java.lang.String orderNumber)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

downloadFTPOrderDoc

byte[] downloadFTPOrderDoc(MiscDocAgent agent)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findTaxComputationByState

java.util.HashMap<java.lang.String,java.util.List<ZipcodeTotalsResult>> findTaxComputationByState(java.lang.String state,
                                                                                java.util.Date fromDate,
                                                                                java.util.Date toDate)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllState

java.util.List<java.lang.String> getAllState()
                                             throws java.lang.Exception
Throws:
java.lang.Exception

getStateTotal

ZipcodeTotalsResult getStateTotal(java.lang.String state,
                                  java.util.Date fromDate,
                                  java.util.Date toDate)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

getStateTotalDetail

java.util.List<ZipcodeTotalsResult> getStateTotalDetail(java.lang.String state,
                                                        java.util.Date fromDate,
                                                        java.util.Date toDate,
                                                        java.lang.String type)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getAddressesNoTaxInfo

java.util.List<ZipcodeTotalsResult> getAddressesNoTaxInfo(java.util.Date fromDate,
                                                          java.util.Date toDate)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

showDashboard

void showDashboard()
                   throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CompanyUnitAccountPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CompanyUnitAccountPK

java.lang.Object
    extended by  bb.common.CompanyUnitAccountPK
All Implemented Interfaces:
java.io.Serializable
public class CompanyUnitAccountPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
CompanyUnitAccountPK()
default constructor
CompanyUnitAccountPK(java.lang.String companyUnitId, java.lang.String accountNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAccountNumber()
java.lang.String | getCompanyUnitId()
int | hashCode()
void | setAccountNumber(java.lang.String accountNumber)
void | setCompanyUnitId(java.lang.String companyUnitId)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CompanyUnitAccountPK

public CompanyUnitAccountPK(java.lang.String companyUnitId,
                            java.lang.String accountNumber)
full constructor

CompanyUnitAccountPK

public CompanyUnitAccountPK()
default constructor

Method Detail

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CompanyUnitAccountVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CompanyUnitAccountVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CompanyUnitAccountVO
All Implemented Interfaces:
java.io.Serializable
public class CompanyUnitAccountVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
CompanyUnitAccountVO()
default constructor
CompanyUnitAccountVO(CompanyUnitAccountPK pk)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
CompanyUnitAccountPK | getPk()
int | hashCode()
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setPk(CompanyUnitAccountPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CompanyUnitAccountVO

public CompanyUnitAccountVO(CompanyUnitAccountPK pk)
full constructor

CompanyUnitAccountVO

public CompanyUnitAccountVO()
default constructor

Method Detail

getPk

public CompanyUnitAccountPK getPk()

setPk

public void setPk(CompanyUnitAccountPK pk)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CompanyUnitVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CompanyUnitVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CompanyUnitVO
All Implemented Interfaces:
java.io.Serializable
public class CompanyUnitVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_ID
static java.lang.String | ORDER_BY_NAME
static java.lang.String | ORDER_BY_TYPE
Constructor Summary
CompanyUnitVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.lang.String | getId()
java.util.Date | getLastChangeDate()
java.lang.Integer | getLastChangeTimes()
java.lang.String | getLastChangeUser()
java.lang.String | getLevel()
java.lang.String | getName()
java.lang.String | getType()
java.lang.String | getUpLevelUnitId()
int | hashCode()
void | setComments(java.lang.String comments)
void | setId(java.lang.String id)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTimes(java.lang.Integer lastChangeTimes)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLevel(java.lang.String level)
void | setName(java.lang.String name)
void | setType(java.lang.String type)
void | setUpLevelUnitId(java.lang.String upLevelUnitId)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ID

public static final java.lang.String ORDER_BY_ID
See Also:
Constant Field Values

ORDER_BY_NAME

public static final java.lang.String ORDER_BY_NAME
See Also:
Constant Field Values

ORDER_BY_TYPE

public static final java.lang.String ORDER_BY_TYPE
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values
Constructor Detail

CompanyUnitVO

public CompanyUnitVO()
Method Detail

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeTimes

public java.lang.Integer getLastChangeTimes()

setLastChangeTimes

public void setLastChangeTimes(java.lang.Integer lastChangeTimes)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getType

public java.lang.String getType()

setType

public void setType(java.lang.String type)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getLevel

public java.lang.String getLevel()

setLevel

public void setLevel(java.lang.String level)

getUpLevelUnitId

public java.lang.String getUpLevelUnitId()

setUpLevelUnitId

public void setUpLevelUnitId(java.lang.String upLevelUnitId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CompanyVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CompanyVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CompanyVO
All Implemented Interfaces:
java.io.Serializable
public class CompanyVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
CompanyVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAddressIdDefaultQaStatus()
byte | getApDigits()
java.lang.String | getApPrefix()
byte | getApPrepayDigits()
java.lang.String | getApPrepayPrefix()
byte | getArDigits()
java.lang.String | getArPrefix()
byte | getArPrepayDigits()
java.lang.String | getArPrepayPrefix()
java.lang.String | getBillToId()
int | getChangeRule()
byte | getCmDigits()
java.lang.String | getCmPrefix()
byte[] | getCompanyHome()
java.lang.String | getCompanyId()
java.lang.String | getCompanyName()
java.lang.String | getCsrReceiverEmail()
java.lang.String | getCurrency()
java.lang.String | getCustomerRFQReceiverEmail()
byte[] | getCustomTree()
java.lang.String | getDataVersion()
java.lang.Short | getDaysCurrent()
java.lang.Byte | getDaysOverdue()
int | getDecimalLength()
java.math.BigDecimal | getDefaultVendorTax()
java.lang.String | getDefaultWOVendorID()
byte | getDmDigits()
java.lang.String | getDmPrefix()
byte | getEdcDigits()
java.lang.String | getEdcPrefix()
byte | getEmployeeIdDigits()
java.lang.String | getEmployeeIdPrefix()
byte | getEngineeringChangeDigits()
java.lang.String | getEngineeringChangePrefix()
byte | getEngineeringChangeRequestDigits()
java.lang.String | getEngineeringChangeRequestPrefix()
java.lang.String | getExchangeRate()
byte | getGlDigits()
java.lang.String | getGlPrefix()
java.lang.String | getHome()
java.lang.String | getId()
java.lang.String | getInitStep()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
java.lang.Integer | getLastChangeTimes()
java.lang.String | getLastChangeUser()
java.util.Date | getLastInventory()
byte[] | getLicense()
byte | getLnReceiverDigits()
java.lang.String | getLnReceiverPrefix()
byte | getLnShipperDigits()
java.lang.String | getLnShipperPrefix()
byte[] | getLogo()
java.lang.String | getMakeBuyForNewPart()
int | getNoticeReceiveGap()
java.lang.String | getPa()
java.lang.String | getPaOffsetType()
int | getPartBigCatagoryLength()
java.lang.String | getPartNumberGenerateType()
byte | getPartNumberMaxLength()
byte | getPartNumberMinLength()
int | getPartNumberSeqLength()
int | getPartSmallCatagoryLength()
java.lang.String | getPartSplitChar()
java.lang.String | getPartUnit()
boolean | getPasswordEncrypt()
int | getPasswordLifetime()
int | getPasswordMinLength()
byte | getPoDigits()
java.lang.String | getPoPrefix()
java.lang.String | getPoweredBy()
byte | getQtDigits()
java.lang.String | getQtPrefix()
byte | getReceiverDigits()
java.lang.String | getReceiverPrefix()
java.lang.String | getRemitAddressId()
java.lang.String | getReportBugEmail()
java.lang.String | getReturnAddressId()
byte | getRfqDigits()
java.lang.String | getRfqPrefix()
byte | getRmaDigits()
java.lang.String | getRmaPrefix()
byte | getRmaReceiverDigits()
java.lang.String | getRmaReceiverPrefix()
byte | getRtvDigits()
java.lang.String | getRtvPrefix()
byte | getRtvShipperDigits()
java.lang.String | getRtvShipperPrefix()
java.lang.String | getSg()
byte | getShipperDigits()
java.lang.String | getShipperPrefix()
java.lang.String | getShippingWeightUnit()
java.lang.String | getShipToId()
byte | getSoDigits()
java.lang.String | getSoPrefix()
byte | getSwoDigits()
java.lang.String | getSwoPrefix()
byte | getSwrDigits()
java.lang.String | getSwrPrefix()
byte | getSwsDigits()
java.lang.String | getSwsPrefix()
java.lang.String | getSystemLanguage()
byte | getTempWorkerDigits()
java.lang.String | getTempWorkerPrefix()
java.lang.String | getTimeZone()
java.lang.String | getToolUnit()
java.lang.String | getUpcaseDescription()
java.lang.String | getUpcaseWorkInstructionSeq()
java.lang.String | getVgAddress()
java.lang.String | getVgPrincipalUserId()
java.lang.String | getVgPrincipalUserName()
java.lang.String | getWarehouseLocationSplitChar()
int | getWiSeqLength()
byte | getWoDigits()
java.lang.String | getWoPrefix()
java.lang.String | getWorkOrderCostControlBy()
java.math.BigDecimal | getWorkOrderCostStart()
java.math.BigDecimal | getWorkOrderOverPercent()
java.lang.String | getWorkTimePeriod()
int | hashCode()
boolean | isAllowEmptyGL()
boolean | isAllowNegativeCreditOrDebit()
boolean | isApproveSubWO()
boolean | isAutoEmployeeId()
boolean | isAutoTempWorderId()
boolean | isDeleteZeroLocation()
boolean | isEnableTracking()
boolean | isEngineeringNewPartForNewPart()
boolean | isIncludePoTax()
boolean | isInitBranchWarehouse()
boolean | isMakeGLWhenReceivingWO()
boolean | isMpnUsedOneTime()
boolean | isNcCodeOnlyOneLetterOrTwoNumber()
boolean | isNeedPassforIssuingWO()
boolean | isNeedPickerforIssuingWO()
boolean | isNonEnglishAllowed()
boolean | isOneGLForBatchPayment()
boolean | isPrintBarCodeForOrder()
boolean | isReceiveNeedIr()
boolean | isReceivingPOZeroCost()
boolean | isRecoil()
boolean | isRefNAPO()
boolean | isSaleableForNewPart()
boolean | isSeparateCostBetweenWarehouse()
boolean | isSeparateCV()
boolean | isSetupInventoryForNewPart()
boolean | isShowNumberTailZero()
boolean | isShowOrgAndLevelForPart()
boolean | isShowTimeZone()
boolean | isUnbilled()
boolean | isUseBomApproval()
boolean | isUseBranchWarehouse()
boolean | isUseEcStartWithYear()
boolean | isUseEngGroupUser()
boolean | isUseIncludeTaxCostforPO()
boolean | isUseMultiQtyforApplying()
boolean | isUseOperationScrap()
boolean | isUseOrderChangeApproval()
boolean | isUsePriceWithTaxAsListPriceInVCP()
boolean | isUsePriceWithTaxDefault()
boolean | isUseUppercaseSystemUserName()
boolean | isUseWorkOrderCostControl()
boolean | isValuationStorage()
boolean | isWarningWhenTwoPartInOneLocation()
void | setAddressIdDefaultQaStatus(java.lang.String addressIdDefaultQaStatus)
void | setAllowEmptyGL(boolean allowEmptyGL)
void | setAllowNegativeCreditOrDebit(boolean allowNegativeCreditOrDebit)
void | setApDigits(byte apDigits)
void | setApPrefix(java.lang.String apPrefix)
void | setApPrepayDigits(byte apPrepayDigits)
void | setApPrepayPrefix(java.lang.String apPrepayPrefix)
void | setApproveSubWO(boolean approveSubWO)
void | setArDigits(byte arDigits)
void | setArPrefix(java.lang.String arPrefix)
void | setArPrepayDigits(byte arPrepayDigits)
void | setArPrepayPrefix(java.lang.String arPrepayPrefix)
void | setAutoEmployeeId(boolean autoEmployeeId)
void | setAutoTempWorderId(boolean autoTempWorderId)
void | setBillToId(java.lang.String billToId)
void | setChangeRule(int changeRule)
void | setCmDigits(byte cmDigits)
void | setCmPrefix(java.lang.String cmPrefix)
void | setCompanyHome(byte[] companyHome)
void | setCompanyId(java.lang.String companyId)
void | setCompanyName(java.lang.String companyName)
void | setCsrReceiverEmail(java.lang.String csrReceiverEmail)
void | setCurrency(java.lang.String currency)
void | setCustomerRFQReceiverEmail(java.lang.String customerRFQReceiverEmail)
void | setCustomTree(byte[] customTree)
void | setDataVersion(java.lang.String dataVersion)
void | setDaysCurrent(java.lang.Short daysCurrent)
void | setDaysOverdue(java.lang.Byte daysOverdue)
void | setDecimalLength(int length)
void | setDefaultVendorTax(java.math.BigDecimal defaultVendorTax)
void | setDefaultWOVendorID(java.lang.String defaultWOVendorID)
void | setDeleteZeroLocation(boolean deleteZeroLocation)
void | setDmDigits(byte dmDigits)
void | setDmPrefix(java.lang.String dmPrefix)
void | setEdcDigits(byte edcDigits)
void | setEdcPrefix(java.lang.String edcPrefix)
void | setEmployeeIdDigits(byte employeeIdDigits)
void | setEmployeeIdPrefix(java.lang.String employeeIdPrefix)
void | setEnableTracking(boolean enableTracking)
void | setEngineeringChangeDigits(byte engineeringChangeDigits)
void | setEngineeringChangePrefix(java.lang.String engineeringChangePrefix)
void | setEngineeringChangeRequestDigits(byte engineeringChangeRequestDigits)
void | setEngineeringChangeRequestPrefix(java.lang.String engineeringChangeRequestPrefix)
void | setEngineeringNewPartForNewPart(boolean engineeringNewPartForNewPart)
void | setExchangeRate(java.lang.String exchangeRate)
void | setGlDigits(byte glDigits)
void | setGlPrefix(java.lang.String glPrefix)
void | setHome(java.lang.String home)
void | setId(java.lang.String id)
void | setIncludePoTax(boolean includePoTax)
void | setInitBranchWarehouse(boolean initBranchWarehouse)
void | setInitStep(java.lang.String initStep)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTimes(java.lang.Integer lastChangeTimes)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLastInventory(java.util.Date lastInventory)
void | setLicense(byte[] license)
void | setLnReceiverDigits(byte lnReceiverDigits)
void | setLnReceiverPrefix(java.lang.String lnReceiverPrefix)
void | setLnShipperDigits(byte lnShipperDigits)
void | setLnShipperPrefix(java.lang.String lnShipperPrefix)
void | setLogo(byte[] logo)
void | setMakeBuyForNewPart(java.lang.String makeBuyForNewPart)
void | setMakeGLWhenReceivingWO(boolean makeGLWhenReceivingWO)
void | setMpnUsedOneTime(boolean mpnUsedOneTime)
void | setNcCodeOnlyOneLetterOrTwoNumber(boolean ncCodeOnlyOneLetterOrTwoNumber)
void | setNeedPassforIssuingWO(boolean needPassforIssuingWO)
void | setNeedPickerforIssuingWO(boolean needPickerforIssuingWO)
void | setNonEnglishAllowed(boolean nonEnglishAllowed)
void | setNoticeReceiveGap(int noticeReceiveGap)
void | setOneGLForBatchPayment(boolean oneGLForBatchPayment)
void | setPa(java.lang.String pa)
void | setPaOffsetType(java.lang.String paOffsetType)
void | setPartBigCatagoryLength(int partBigCatagoryLength)
void | setPartNumberGenerateType(java.lang.String partNumberGenerateType)
void | setPartNumberMaxLength(byte partNumberMaxLength)
void | setPartNumberMinLength(byte partNumberMinLength)
void | setPartNumberSeqLength(int partNumberSeqLength)
void | setPartSmallCatagoryLength(int partSmallCatagoryLength)
void | setPartSplitChar(java.lang.String partSplitChar)
void | setPartUnit(java.lang.String partUnit)
void | setPasswordEncrypt(boolean passwordEncrypt)
void | setPasswordLifetime(int passwordLifetime)
void | setPasswordMinLength(int passwordMinLength)
void | setPoDigits(byte poDigits)
void | setPoPrefix(java.lang.String poPrefix)
void | setPoweredBy(java.lang.String poweredBy)
void | setPrintBarCodeForOrder(boolean printBarCodeForOrder)
void | setQtDigits(byte qtDigits)
void | setQtPrefix(java.lang.String qtPrefix)
void | setReceiveNeedIr(boolean receiveNeedIr)
void | setReceiverDigits(byte receiverDigits)
void | setReceiverPrefix(java.lang.String receiverPrefix)
void | setReceivingPOZeroCost(boolean receivingPOZeroCost)
void | setRecoil(boolean recoil)
void | setRefNAPO(boolean refNAPO)
void | setRemitAddressId(java.lang.String remitAddressId)
void | setReportBugEmail(java.lang.String reportBugEmail)
void | setReturnAddressId(java.lang.String returnAddressId)
void | setRfqDigits(byte rfqDigits)
void | setRfqPrefix(java.lang.String rfqPrefix)
void | setRmaDigits(byte rmaDigits)
void | setRmaPrefix(java.lang.String rmaPrefix)
void | setRmaReceiverDigits(byte rmaReceiverDigits)
void | setRmaReceiverPrefix(java.lang.String rmaReceiverPrefix)
void | setRtvDigits(byte rtvDigits)
void | setRtvPrefix(java.lang.String rtvPrefix)
void | setRtvShipperDigits(byte rtvShipperDigits)
void | setRtvShipperPrefix(java.lang.String rtvShipperPrefix)
void | setSaleableForNewPart(boolean saleableForNewPart)
void | setSeparateCostBetweenWarehouse(boolean separateCostBetweenWarehouse)
void | setSeparateCV(boolean separateCV)
void | setSetupInventoryForNewPart(boolean setupInventoryForNewPart)
void | setSg(java.lang.String sg)
void | setShipperDigits(byte shipperDigits)
void | setShipperPrefix(java.lang.String shipperPrefix)
void | setShippingWeightUnit(java.lang.String shippingWeightUnit)
void | setShipToId(java.lang.String shipToId)
void | setShowNumberTailZero(boolean showNumberTailZero)
void | setShowOrgAndLevelForPart(boolean showOrgAndLevelForPart)
void | setShowTimeZone(boolean showTimeZone)
void | setSoDigits(byte soDigits)
void | setSoPrefix(java.lang.String soPrefix)
void | setSwoDigits(byte swoDigits)
void | setSwoPrefix(java.lang.String swoPrefix)
void | setSwrDigits(byte swrDigits)
void | setSwrPrefix(java.lang.String swrPrefix)
void | setSwsDigits(byte swsDigits)
void | setSwsPrefix(java.lang.String swsPrefix)
void | setSystemLanguage(java.lang.String systemLanguage)
void | setTempWorkerDigits(byte tempWorkerDigits)
void | setTempWorkerPrefix(java.lang.String tempWorkerPrefix)
void | setTimeZone(java.lang.String timeZone)
void | setToolUnit(java.lang.String toolUnit)
void | setUnbilled(boolean unbilled)
void | setUpcaseDescription(java.lang.String upcaseDescription)
void | setUpcaseWorkInstructionSeq(java.lang.String upcaseWorkInstructionSeq)
void | setUseBomApproval(boolean useBomApproval)
void | setUseBranchWarehouse(boolean useBranchWarehouse)
void | setUseEcStartWithYear(boolean useEcStartWithYear)
void | setUseEngGroupUser(boolean useEngGroupUser)
void | setUseIncludeTaxCostforPO(boolean useIncludeTaxCostforPO)
void | setUseMultiQtyforApplying(boolean useMultiQtyforApplying)
void | setUseOperationScrap(boolean useOperationScrap)
void | setUseOrderChangeApproval(boolean useOrderChangeApproval)
void | setUsePriceWithTaxAsListPriceInVCP(boolean usePriceWithTaxAsListPriceInVCP)
void | setUsePriceWithTaxDefault(boolean usePriceWithTaxDefault)
void | setUseUppercaseSystemUserName(boolean useUppercaseSystemUserName)
void | setUseWorkOrderCostControl(boolean useWorkOrderCostControl)
void | setValuationStorage(boolean valuationStorage)
void | setVgAddress(java.lang.String vgAddress)
void | setVgPrincipalUserId(java.lang.String vgPrincipalUserId)
void | setVgPrincipalUserName(java.lang.String vgPrincipalUserName)
void | setWarehouseLocationSplitChar(java.lang.String warehouseLocationSplitChar)
void | setWarningWhenTwoPartInOneLocation(boolean warningWhenTwoPartInOneLocation)
void | setWiSeqLength(int wiSeqLength)
void | setWoDigits(byte woDigits)
void | setWoPrefix(java.lang.String woPrefix)
void | setWorkOrderCostControlBy(java.lang.String workOrderCostControlBy)
void | setWorkOrderCostStart(java.math.BigDecimal workOrderCostStart)
void | setWorkOrderOverPercent(java.math.BigDecimal workOrderOverPercent)
void | setWorkTimePeriod(java.lang.String workTimePeriod)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CompanyVO

public CompanyVO()
Method Detail

isRefNAPO

public boolean isRefNAPO()

setRefNAPO

public void setRefNAPO(boolean refNAPO)

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeTimes

public java.lang.Integer getLastChangeTimes()

setLastChangeTimes

public void setLastChangeTimes(java.lang.Integer lastChangeTimes)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getSystemLanguage

public java.lang.String getSystemLanguage()

setSystemLanguage

public void setSystemLanguage(java.lang.String systemLanguage)

getLogo

public byte[] getLogo()

setLogo

public void setLogo(byte[] logo)

getCompanyName

public java.lang.String getCompanyName()

setCompanyName

public void setCompanyName(java.lang.String companyName)

getDaysOverdue

public java.lang.Byte getDaysOverdue()

setDaysOverdue

public void setDaysOverdue(java.lang.Byte daysOverdue)

getDaysCurrent

public java.lang.Short getDaysCurrent()

setDaysCurrent

public void setDaysCurrent(java.lang.Short daysCurrent)

getEngineeringChangePrefix

public java.lang.String getEngineeringChangePrefix()

setEngineeringChangePrefix

public void setEngineeringChangePrefix(java.lang.String engineeringChangePrefix)

getEngineeringChangeDigits

public byte getEngineeringChangeDigits()

setEngineeringChangeDigits

public void setEngineeringChangeDigits(byte engineeringChangeDigits)

getEngineeringChangeRequestPrefix

public java.lang.String getEngineeringChangeRequestPrefix()

setEngineeringChangeRequestPrefix

public void setEngineeringChangeRequestPrefix(java.lang.String engineeringChangeRequestPrefix)

getEngineeringChangeRequestDigits

public byte getEngineeringChangeRequestDigits()

setEngineeringChangeRequestDigits

public void setEngineeringChangeRequestDigits(byte engineeringChangeRequestDigits)

isUseIncludeTaxCostforPO

public boolean isUseIncludeTaxCostforPO()

setUseIncludeTaxCostforPO

public void setUseIncludeTaxCostforPO(boolean useIncludeTaxCostforPO)

getHome

public java.lang.String getHome()

setHome

public void setHome(java.lang.String home)

getSg

public java.lang.String getSg()

setSg

public void setSg(java.lang.String sg)

getPoweredBy

public java.lang.String getPoweredBy()

setPoweredBy

public void setPoweredBy(java.lang.String poweredBy)

getLastInventory

public java.util.Date getLastInventory()

setLastInventory

public void setLastInventory(java.util.Date lastInventory)

getTimeZone

public java.lang.String getTimeZone()

setTimeZone

public void setTimeZone(java.lang.String timeZone)

getBillToId

public java.lang.String getBillToId()

setBillToId

public void setBillToId(java.lang.String billToId)

getShipToId

public java.lang.String getShipToId()

setShipToId

public void setShipToId(java.lang.String shipToId)

getPa

public java.lang.String getPa()

setPa

public void setPa(java.lang.String pa)

getLastChangeDate

public java.util.Date getLastChangeDate()

getUpcaseDescription

public java.lang.String getUpcaseDescription()

getChangeRule

public int getChangeRule()

getEmployeeIdDigits

public byte getEmployeeIdDigits()

getEmployeeIdPrefix

public java.lang.String getEmployeeIdPrefix()

getPartNumberMinLength

public byte getPartNumberMinLength()

getPartNumberMaxLength

public byte getPartNumberMaxLength()

getVgPrincipalUserId

public java.lang.String getVgPrincipalUserId()

getVgPrincipalUserName

public java.lang.String getVgPrincipalUserName()

getVgAddress

public java.lang.String getVgAddress()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

setUpcaseDescription

public void setUpcaseDescription(java.lang.String upcaseDescription)

setChangeRule

public void setChangeRule(int changeRule)

setEmployeeIdPrefix

public void setEmployeeIdPrefix(java.lang.String employeeIdPrefix)

setEmployeeIdDigits

public void setEmployeeIdDigits(byte employeeIdDigits)

setPartNumberMinLength

public void setPartNumberMinLength(byte partNumberMinLength)

setPartNumberMaxLength

public void setPartNumberMaxLength(byte partNumberMaxLength)

setVgPrincipalUserId

public void setVgPrincipalUserId(java.lang.String vgPrincipalUserId)

setVgPrincipalUserName

public void setVgPrincipalUserName(java.lang.String vgPrincipalUserName)

setVgAddress

public void setVgAddress(java.lang.String vgAddress)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getApDigits

public byte getApDigits()

setApDigits

public void setApDigits(byte apDigits)

getApPrefix

public java.lang.String getApPrefix()

setApPrefix

public void setApPrefix(java.lang.String apPrefix)

getArDigits

public byte getArDigits()

setArDigits

public void setArDigits(byte arDigits)

getArPrefix

public java.lang.String getArPrefix()

setArPrefix

public void setArPrefix(java.lang.String arPrefix)

getCmDigits

public byte getCmDigits()

setCmDigits

public void setCmDigits(byte cmDigits)

getCmPrefix

public java.lang.String getCmPrefix()

setCmPrefix

public void setCmPrefix(java.lang.String cmPrefix)

getDmDigits

public byte getDmDigits()

setDmDigits

public void setDmDigits(byte dmDigits)

getDmPrefix

public java.lang.String getDmPrefix()

setDmPrefix

public void setDmPrefix(java.lang.String dmPrefix)

getPoDigits

public byte getPoDigits()

setPoDigits

public void setPoDigits(byte poDigits)

getPoPrefix

public java.lang.String getPoPrefix()

setPoPrefix

public void setPoPrefix(java.lang.String poPrefix)

getQtDigits

public byte getQtDigits()

setQtDigits

public void setQtDigits(byte qtDigits)

getQtPrefix

public java.lang.String getQtPrefix()

setQtPrefix

public void setQtPrefix(java.lang.String qtPrefix)

getReceiverDigits

public byte getReceiverDigits()

setReceiverDigits

public void setReceiverDigits(byte receiverDigits)

getReceiverPrefix

public java.lang.String getReceiverPrefix()

setReceiverPrefix

public void setReceiverPrefix(java.lang.String receiverPrefix)

getRfqDigits

public byte getRfqDigits()

setRfqDigits

public void setRfqDigits(byte rfqDigits)

getRfqPrefix

public java.lang.String getRfqPrefix()

setRfqPrefix

public void setRfqPrefix(java.lang.String rfqPrefix)

getRmaDigits

public byte getRmaDigits()

setRmaDigits

public void setRmaDigits(byte rmaDigits)

getRmaPrefix

public java.lang.String getRmaPrefix()

setRmaPrefix

public void setRmaPrefix(java.lang.String rmaPrefix)

getRtvDigits

public byte getRtvDigits()

setRtvDigits

public void setRtvDigits(byte rtvDigits)

getRtvPrefix

public java.lang.String getRtvPrefix()

setRtvPrefix

public void setRtvPrefix(java.lang.String rtvPrefix)

getShipperDigits

public byte getShipperDigits()

setShipperDigits

public void setShipperDigits(byte shipperDigits)

getShipperPrefix

public java.lang.String getShipperPrefix()

setShipperPrefix

public void setShipperPrefix(java.lang.String shipperPrefix)

getSoDigits

public byte getSoDigits()

setSoDigits

public void setSoDigits(byte soDigits)

getSoPrefix

public java.lang.String getSoPrefix()

setSoPrefix

public void setSoPrefix(java.lang.String soPrefix)

getReturnAddressId

public java.lang.String getReturnAddressId()

setReturnAddressId

public void setReturnAddressId(java.lang.String returnAddressId)

getWoDigits

public byte getWoDigits()

setWoDigits

public void setWoDigits(byte woDigits)

getWoPrefix

public java.lang.String getWoPrefix()

setWoPrefix

public void setWoPrefix(java.lang.String woPrefix)

isEngineeringNewPartForNewPart

public boolean isEngineeringNewPartForNewPart()

setEngineeringNewPartForNewPart

public void setEngineeringNewPartForNewPart(boolean engineeringNewPartForNewPart)

getMakeBuyForNewPart

public java.lang.String getMakeBuyForNewPart()

setMakeBuyForNewPart

public void setMakeBuyForNewPart(java.lang.String makeBuyForNewPart)

isSaleableForNewPart

public boolean isSaleableForNewPart()

setSaleableForNewPart

public void setSaleableForNewPart(boolean saleableForNewPart)

isSetupInventoryForNewPart

public boolean isSetupInventoryForNewPart()

setSetupInventoryForNewPart

public void setSetupInventoryForNewPart(boolean setupInventoryForNewPart)

getShippingWeightUnit

public java.lang.String getShippingWeightUnit()

setShippingWeightUnit

public void setShippingWeightUnit(java.lang.String shippingWeightUnit)

isAutoEmployeeId

public boolean isAutoEmployeeId()

setAutoEmployeeId

public void setAutoEmployeeId(boolean autoEmployeeId)

isAutoTempWorderId

public boolean isAutoTempWorderId()

setAutoTempWorderId

public void setAutoTempWorderId(boolean autoTempWorderId)

getTempWorkerDigits

public byte getTempWorkerDigits()

setTempWorkerDigits

public void setTempWorkerDigits(byte tempWorkerDigits)

getTempWorkerPrefix

public java.lang.String getTempWorkerPrefix()

setTempWorkerPrefix

public void setTempWorkerPrefix(java.lang.String tempWorkerPrefix)

getCompanyHome

public byte[] getCompanyHome()

setCompanyHome

public void setCompanyHome(byte[] companyHome)

getLicense

public byte[] getLicense()

setLicense

public void setLicense(byte[] license)

getAddressIdDefaultQaStatus

public java.lang.String getAddressIdDefaultQaStatus()

setAddressIdDefaultQaStatus

public void setAddressIdDefaultQaStatus(java.lang.String addressIdDefaultQaStatus)

getUpcaseWorkInstructionSeq

public java.lang.String getUpcaseWorkInstructionSeq()

setUpcaseWorkInstructionSeq

public void setUpcaseWorkInstructionSeq(java.lang.String upcaseWorkInstructionSeq)

getCustomerRFQReceiverEmail

public java.lang.String getCustomerRFQReceiverEmail()

setCustomerRFQReceiverEmail

public void setCustomerRFQReceiverEmail(java.lang.String customerRFQReceiverEmail)

getEdcDigits

public byte getEdcDigits()

setEdcDigits

public void setEdcDigits(byte edcDigits)

getEdcPrefix

public java.lang.String getEdcPrefix()

setEdcPrefix

public void setEdcPrefix(java.lang.String edcPrefix)

getCsrReceiverEmail

public java.lang.String getCsrReceiverEmail()

setCsrReceiverEmail

public void setCsrReceiverEmail(java.lang.String csrReceiverEmail)

getLnShipperDigits

public byte getLnShipperDigits()

setLnShipperDigits

public void setLnShipperDigits(byte lnShipperDigits)

getLnShipperPrefix

public java.lang.String getLnShipperPrefix()

setLnShipperPrefix

public void setLnShipperPrefix(java.lang.String lnShipperPrefix)

getLnReceiverDigits

public byte getLnReceiverDigits()

setLnReceiverDigits

public void setLnReceiverDigits(byte lnReceiverDigits)

getLnReceiverPrefix

public java.lang.String getLnReceiverPrefix()

setLnReceiverPrefix

public void setLnReceiverPrefix(java.lang.String lnReceiverPrefix)

getRmaReceiverDigits

public byte getRmaReceiverDigits()

setRmaReceiverDigits

public void setRmaReceiverDigits(byte rmaReceiverDigits)

getRmaReceiverPrefix

public java.lang.String getRmaReceiverPrefix()

setRmaReceiverPrefix

public void setRmaReceiverPrefix(java.lang.String rmaReceiverPrefix)

getRtvShipperDigits

public byte getRtvShipperDigits()

setRtvShipperDigits

public void setRtvShipperDigits(byte rtvShipperDigits)

getRtvShipperPrefix

public java.lang.String getRtvShipperPrefix()

setRtvShipperPrefix

public void setRtvShipperPrefix(java.lang.String rtvShipperPrefix)

getPasswordEncrypt

public boolean getPasswordEncrypt()

setPasswordEncrypt

public void setPasswordEncrypt(boolean passwordEncrypt)

getPasswordLifetime

public int getPasswordLifetime()

setPasswordLifetime

public void setPasswordLifetime(int passwordLifetime)

getPasswordMinLength

public int getPasswordMinLength()

setPasswordMinLength

public void setPasswordMinLength(int passwordMinLength)

isUseWorkOrderCostControl

public boolean isUseWorkOrderCostControl()

setUseWorkOrderCostControl

public void setUseWorkOrderCostControl(boolean useWorkOrderCostControl)

getWorkOrderCostStart

public java.math.BigDecimal getWorkOrderCostStart()

setWorkOrderCostStart

public void setWorkOrderCostStart(java.math.BigDecimal workOrderCostStart)

getWorkOrderOverPercent

public java.math.BigDecimal getWorkOrderOverPercent()

setWorkOrderOverPercent

public void setWorkOrderOverPercent(java.math.BigDecimal workOrderOverPercent)

getWorkTimePeriod

public java.lang.String getWorkTimePeriod()

setWorkTimePeriod

public void setWorkTimePeriod(java.lang.String workTimePeriod)

getWiSeqLength

public int getWiSeqLength()

setWiSeqLength

public void setWiSeqLength(int wiSeqLength)

getApPrepayDigits

public byte getApPrepayDigits()

setApPrepayDigits

public void setApPrepayDigits(byte apPrepayDigits)

getApPrepayPrefix

public java.lang.String getApPrepayPrefix()

setApPrepayPrefix

public void setApPrepayPrefix(java.lang.String apPrepayPrefix)

getArPrepayDigits

public byte getArPrepayDigits()

setArPrepayDigits

public void setArPrepayDigits(byte arPrepayDigits)

getArPrepayPrefix

public java.lang.String getArPrepayPrefix()

setArPrepayPrefix

public void setArPrepayPrefix(java.lang.String arPrepayPrefix)

getWorkOrderCostControlBy

public java.lang.String getWorkOrderCostControlBy()

setWorkOrderCostControlBy

public void setWorkOrderCostControlBy(java.lang.String workOrderCostControlBy)

isShowOrgAndLevelForPart

public boolean isShowOrgAndLevelForPart()

setShowOrgAndLevelForPart

public void setShowOrgAndLevelForPart(boolean showOrgAndLevelForPart)

getDataVersion

public java.lang.String getDataVersion()

setDataVersion

public void setDataVersion(java.lang.String dataVersion)

getGlDigits

public byte getGlDigits()

setGlDigits

public void setGlDigits(byte glDigits)

getGlPrefix

public java.lang.String getGlPrefix()

setGlPrefix

public void setGlPrefix(java.lang.String glPrefix)

isSeparateCV

public boolean isSeparateCV()

setSeparateCV

public void setSeparateCV(boolean separateCV)

getCustomTree

public byte[] getCustomTree()

setCustomTree

public void setCustomTree(byte[] customTree)

isUseOrderChangeApproval

public boolean isUseOrderChangeApproval()

setUseOrderChangeApproval

public void setUseOrderChangeApproval(boolean useOrderChangeApproval)

isEnableTracking

public boolean isEnableTracking()

setEnableTracking

public void setEnableTracking(boolean enableTracking)

isReceiveNeedIr

public boolean isReceiveNeedIr()

setReceiveNeedIr

public void setReceiveNeedIr(boolean receiveNeedIr)

getReportBugEmail

public java.lang.String getReportBugEmail()

setReportBugEmail

public void setReportBugEmail(java.lang.String reportBugEmail)

isUseBomApproval

public boolean isUseBomApproval()

setUseBomApproval

public void setUseBomApproval(boolean useBomApproval)

isIncludePoTax

public boolean isIncludePoTax()

setIncludePoTax

public void setIncludePoTax(boolean includePoTax)

getDefaultVendorTax

public java.math.BigDecimal getDefaultVendorTax()

setDefaultVendorTax

public void setDefaultVendorTax(java.math.BigDecimal defaultVendorTax)

isNeedPassforIssuingWO

public boolean isNeedPassforIssuingWO()

setNeedPassforIssuingWO

public void setNeedPassforIssuingWO(boolean needPassforIssuingWO)

isSeparateCostBetweenWarehouse

public boolean isSeparateCostBetweenWarehouse()

setSeparateCostBetweenWarehouse

public void setSeparateCostBetweenWarehouse(boolean separateCostBetweenWarehouse)

isUseBranchWarehouse

public boolean isUseBranchWarehouse()

setUseBranchWarehouse

public void setUseBranchWarehouse(boolean useBranchWarehouse)

isUseEngGroupUser

public boolean isUseEngGroupUser()

setUseEngGroupUser

public void setUseEngGroupUser(boolean useEngGroupUser)

getPartNumberGenerateType

public java.lang.String getPartNumberGenerateType()

setPartNumberGenerateType

public void setPartNumberGenerateType(java.lang.String partNumberGenerateType)

getPartNumberSeqLength

public int getPartNumberSeqLength()

setPartNumberSeqLength

public void setPartNumberSeqLength(int partNumberSeqLength)

getPartBigCatagoryLength

public int getPartBigCatagoryLength()

setPartBigCatagoryLength

public void setPartBigCatagoryLength(int partBigCatagoryLength)

getPartSmallCatagoryLength

public int getPartSmallCatagoryLength()

setPartSmallCatagoryLength

public void setPartSmallCatagoryLength(int partSmallCatagoryLength)

getPartSplitChar

public java.lang.String getPartSplitChar()

setPartSplitChar

public void setPartSplitChar(java.lang.String partSplitChar)

isDeleteZeroLocation

public boolean isDeleteZeroLocation()

setDeleteZeroLocation

public void setDeleteZeroLocation(boolean deleteZeroLocation)

isWarningWhenTwoPartInOneLocation

public boolean isWarningWhenTwoPartInOneLocation()

setWarningWhenTwoPartInOneLocation

public void setWarningWhenTwoPartInOneLocation(boolean warningWhenTwoPartInOneLocation)

isApproveSubWO

public boolean isApproveSubWO()

setApproveSubWO

public void setApproveSubWO(boolean approveSubWO)

isInitBranchWarehouse

public boolean isInitBranchWarehouse()

setInitBranchWarehouse

public void setInitBranchWarehouse(boolean initBranchWarehouse)

isPrintBarCodeForOrder

public boolean isPrintBarCodeForOrder()

setPrintBarCodeForOrder

public void setPrintBarCodeForOrder(boolean printBarCodeForOrder)

isMakeGLWhenReceivingWO

public boolean isMakeGLWhenReceivingWO()

setMakeGLWhenReceivingWO

public void setMakeGLWhenReceivingWO(boolean makeGLWhenReceivingWO)

isAllowEmptyGL

public boolean isAllowEmptyGL()

setAllowEmptyGL

public void setAllowEmptyGL(boolean allowEmptyGL)

getCompanyId

public java.lang.String getCompanyId()

setCompanyId

public void setCompanyId(java.lang.String companyId)

getDefaultWOVendorID

public java.lang.String getDefaultWOVendorID()

setDefaultWOVendorID

public void setDefaultWOVendorID(java.lang.String defaultWOVendorID)

isShowTimeZone

public boolean isShowTimeZone()

setShowTimeZone

public void setShowTimeZone(boolean showTimeZone)

getInitStep

public java.lang.String getInitStep()

setInitStep

public void setInitStep(java.lang.String initStep)

isValuationStorage

public boolean isValuationStorage()

setValuationStorage

public void setValuationStorage(boolean valuationStorage)

getExchangeRate

public java.lang.String getExchangeRate()

setExchangeRate

public void setExchangeRate(java.lang.String exchangeRate)

getDecimalLength

public int getDecimalLength()

setDecimalLength

public void setDecimalLength(int length)

isNonEnglishAllowed

public boolean isNonEnglishAllowed()

setNonEnglishAllowed

public void setNonEnglishAllowed(boolean nonEnglishAllowed)

getPartUnit

public java.lang.String getPartUnit()

getToolUnit

public java.lang.String getToolUnit()

setPartUnit

public void setPartUnit(java.lang.String partUnit)

setToolUnit

public void setToolUnit(java.lang.String toolUnit)

getPaOffsetType

public java.lang.String getPaOffsetType()

setPaOffsetType

public void setPaOffsetType(java.lang.String paOffsetType)

getRemitAddressId

public java.lang.String getRemitAddressId()

setRemitAddressId

public void setRemitAddressId(java.lang.String remitAddressId)

getSwoPrefix

public java.lang.String getSwoPrefix()

setSwoPrefix

public void setSwoPrefix(java.lang.String swoPrefix)

getSwoDigits

public byte getSwoDigits()

setSwoDigits

public void setSwoDigits(byte swoDigits)

getSwsPrefix

public java.lang.String getSwsPrefix()

setSwsPrefix

public void setSwsPrefix(java.lang.String swsPrefix)

getSwsDigits

public byte getSwsDigits()

setSwsDigits

public void setSwsDigits(byte swsDigits)

getSwrPrefix

public java.lang.String getSwrPrefix()

setSwrPrefix

public void setSwrPrefix(java.lang.String swrPrefix)

getSwrDigits

public byte getSwrDigits()

setSwrDigits

public void setSwrDigits(byte swrDigits)

isUnbilled

public boolean isUnbilled()

setUnbilled

public void setUnbilled(boolean unbilled)

isReceivingPOZeroCost

public boolean isReceivingPOZeroCost()

setReceivingPOZeroCost

public void setReceivingPOZeroCost(boolean receivingPOZeroCost)

isMpnUsedOneTime

public boolean isMpnUsedOneTime()

setMpnUsedOneTime

public void setMpnUsedOneTime(boolean mpnUsedOneTime)

isShowNumberTailZero

public boolean isShowNumberTailZero()

setShowNumberTailZero

public void setShowNumberTailZero(boolean showNumberTailZero)

isNeedPickerforIssuingWO

public boolean isNeedPickerforIssuingWO()

setNeedPickerforIssuingWO

public void setNeedPickerforIssuingWO(boolean needPickerforIssuingWO)

isRecoil

public boolean isRecoil()

setRecoil

public void setRecoil(boolean recoil)

isAllowNegativeCreditOrDebit

public boolean isAllowNegativeCreditOrDebit()

setAllowNegativeCreditOrDebit

public void setAllowNegativeCreditOrDebit(boolean allowNegativeCreditOrDebit)

getWarehouseLocationSplitChar

public java.lang.String getWarehouseLocationSplitChar()

setWarehouseLocationSplitChar

public void setWarehouseLocationSplitChar(java.lang.String warehouseLocationSplitChar)

isUseOperationScrap

public boolean isUseOperationScrap()

setUseOperationScrap

public void setUseOperationScrap(boolean useOperationScrap)

isOneGLForBatchPayment

public boolean isOneGLForBatchPayment()

setOneGLForBatchPayment

public void setOneGLForBatchPayment(boolean oneGLForBatchPayment)

isUseEcStartWithYear

public boolean isUseEcStartWithYear()

isUsePriceWithTaxDefault

public boolean isUsePriceWithTaxDefault()

getNoticeReceiveGap

public int getNoticeReceiveGap()

setNoticeReceiveGap

public void setNoticeReceiveGap(int noticeReceiveGap)

setUseEcStartWithYear

public void setUseEcStartWithYear(boolean useEcStartWithYear)

setUsePriceWithTaxDefault

public void setUsePriceWithTaxDefault(boolean usePriceWithTaxDefault)

isNcCodeOnlyOneLetterOrTwoNumber

public boolean isNcCodeOnlyOneLetterOrTwoNumber()

setNcCodeOnlyOneLetterOrTwoNumber

public void setNcCodeOnlyOneLetterOrTwoNumber(boolean ncCodeOnlyOneLetterOrTwoNumber)

isUseUppercaseSystemUserName

public boolean isUseUppercaseSystemUserName()

setUseUppercaseSystemUserName

public void setUseUppercaseSystemUserName(boolean useUppercaseSystemUserName)

isUseMultiQtyforApplying

public boolean isUseMultiQtyforApplying()

setUseMultiQtyforApplying

public void setUseMultiQtyforApplying(boolean useMultiQtyforApplying)

isUsePriceWithTaxAsListPriceInVCP

public boolean isUsePriceWithTaxAsListPriceInVCP()

setUsePriceWithTaxAsListPriceInVCP

public void setUsePriceWithTaxAsListPriceInVCP(boolean usePriceWithTaxAsListPriceInVCP)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Configure

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Configure

java.lang.Object
    extended by  bb.common.Configure

public class Configure
extends java.lang.Object

Nested Class Summary
static class | Configure.LoginStatus
static class | Configure.Module
static class | Configure.Organization
static class | Configure.UpdatePermission
static class | Configure.UserLocked
static class | Configure.UserType
Constructor Summary
Configure()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Configure

public Configure()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Configure.LoginStatus

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Configure.LoginStatus

java.lang.Object
    extended by  bb.common.Configure.LoginStatus
Enclosing class:
Configure
public static class Configure.LoginStatus
extends java.lang.Object

Field Summary
static int | INVALID
static int | OFFLINE
static int | ONLINE
Constructor Summary
Configure.LoginStatus()
Method Summary
static boolean legalValue(int value)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

OFFLINE

public static final int OFFLINE
See Also:
Constant Field Values

ONLINE

public static final int ONLINE
See Also:
Constant Field Values

INVALID

public static final int INVALID
See Also:
Constant Field Values
Constructor Detail

Configure.LoginStatus

public Configure.LoginStatus()
Method Detail

legalValue

public static boolean legalValue(int value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Configure.Module

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Configure.Module

java.lang.Object
    extended by  bb.common.Configure.Module
Enclosing class:
Configure
public static class Configure.Module
extends java.lang.Object

Field Summary
static java.lang.String | ACCOUNTING
static java.lang.String | ADDRESS
static java.lang.String | COMPANYSETTINGS
static java.lang.String | CUSTOMERSERVICE
static java.lang.String | DOCUMENT
static java.lang.String | ENGINEERING
static java.lang.String | HUMANRESOURCE
static java.lang.String | LOG
static java.lang.String | MANAGEMENT
static java.lang.String | MANUFACTURING
static java.lang.String | PLANNING
static java.lang.String | PURCHASING
static java.lang.String | QUALITY
static java.lang.String | SALES
static java.lang.String | SECURITY
static java.lang.String | WAREHOUSE
static java.lang.String | WORKORDER
Constructor Summary
Configure.Module()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ACCOUNTING

public static final java.lang.String ACCOUNTING
See Also:
Constant Field Values

WORKORDER

public static final java.lang.String WORKORDER
See Also:
Constant Field Values

MANUFACTURING

public static final java.lang.String MANUFACTURING
See Also:
Constant Field Values

QUALITY

public static final java.lang.String QUALITY
See Also:
Constant Field Values

WAREHOUSE

public static final java.lang.String WAREHOUSE
See Also:
Constant Field Values

ENGINEERING

public static final java.lang.String ENGINEERING
See Also:
Constant Field Values

CUSTOMERSERVICE

public static final java.lang.String CUSTOMERSERVICE
See Also:
Constant Field Values

ADDRESS

public static final java.lang.String ADDRESS
See Also:
Constant Field Values

HUMANRESOURCE

public static final java.lang.String HUMANRESOURCE
See Also:
Constant Field Values

PURCHASING

public static final java.lang.String PURCHASING
See Also:
Constant Field Values

PLANNING

public static final java.lang.String PLANNING
See Also:
Constant Field Values

SALES

public static final java.lang.String SALES
See Also:
Constant Field Values

SECURITY

public static final java.lang.String SECURITY
See Also:
Constant Field Values

COMPANYSETTINGS

public static final java.lang.String COMPANYSETTINGS
See Also:
Constant Field Values

LOG

public static final java.lang.String LOG
See Also:
Constant Field Values

DOCUMENT

public static final java.lang.String DOCUMENT
See Also:
Constant Field Values

MANAGEMENT

public static final java.lang.String MANAGEMENT
See Also:
Constant Field Values
Constructor Detail

Configure.Module

public Configure.Module()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Configure.Organization

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Configure.Organization

java.lang.Object
    extended by  bb.common.Configure.Organization
Enclosing class:
Configure
public static final class Configure.Organization
extends java.lang.Object

Field Summary
static java.util.LinkedHashSet<java.lang.String> | organizations
static java.util.LinkedHashMap<java.lang.String,java.util.LinkedHashSet<java.lang.String>> | serverAndOrg
static java.util.LinkedHashMap<java.lang.String,java.lang.String> | servers
Constructor Summary
Configure.Organization()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

organizations

public static final java.util.LinkedHashSet<java.lang.String> organizations

servers

public static final java.util.LinkedHashMap<java.lang.String,java.lang.String> servers

serverAndOrg

public static final java.util.LinkedHashMap<java.lang.String,java.util.LinkedHashSet<java.lang.String>> serverAndOrg
Constructor Detail

Configure.Organization

public Configure.Organization()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Configure.UpdatePermission

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Configure.UpdatePermission

java.lang.Object
    extended by  bb.common.Configure.UpdatePermission
Enclosing class:
Configure
public static class Configure.UpdatePermission
extends java.lang.Object

Field Summary
static int | CAN
static int | CAN_NOT
static int | INVALID
Constructor Summary
Configure.UpdatePermission()
Method Summary
static boolean legalValue(int value)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CAN

public static final int CAN
See Also:
Constant Field Values

CAN_NOT

public static final int CAN_NOT
See Also:
Constant Field Values

INVALID

public static final int INVALID
See Also:
Constant Field Values
Constructor Detail

Configure.UpdatePermission

public Configure.UpdatePermission()
Method Detail

legalValue

public static boolean legalValue(int value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Configure.UserLocked

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Configure.UserLocked

java.lang.Object
    extended by  bb.common.Configure.UserLocked
Enclosing class:
Configure
public static class Configure.UserLocked
extends java.lang.Object

Field Summary
static int | INVALID
static int | LOCKED
static int | UNLOCKED
Constructor Summary
Configure.UserLocked()
Method Summary
static boolean legalValue(int value)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

UNLOCKED

public static final int UNLOCKED
See Also:
Constant Field Values

LOCKED

public static final int LOCKED
See Also:
Constant Field Values

INVALID

public static final int INVALID
See Also:
Constant Field Values
Constructor Detail

Configure.UserLocked

public Configure.UserLocked()
Method Detail

legalValue

public static boolean legalValue(int value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Configure.UserType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Configure.UserType

java.lang.Object
    extended by  bb.common.Configure.UserType
Enclosing class:
Configure
public static class Configure.UserType
extends java.lang.Object

Field Summary
static int | INVALID
static int | TYPE_CUSTOMER
static int | TYPE_EMPLOYEE
Constructor Summary
Configure.UserType()
Method Summary
static boolean legalValue(int value)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TYPE_EMPLOYEE

public static final int TYPE_EMPLOYEE
See Also:
Constant Field Values

TYPE_CUSTOMER

public static final int TYPE_CUSTOMER
See Also:
Constant Field Values

INVALID

public static final int INVALID
See Also:
Constant Field Values
Constructor Detail

Configure.UserType

public Configure.UserType()
Method Detail

legalValue

public static boolean legalValue(int value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant

java.lang.Object
    extended by  bb.common.Constant

public final class Constant
extends java.lang.Object

Nested Class Summary
static class | Constant.ActiveStatus
static class | Constant.AddressType
static class | Constant.AgeLevel
static class | Constant.AmountType
static class | Constant.ARDiscountMethod
static class | Constant.CategoryReportType
static class | Constant.CategoryType
static class | Constant.ChartOfAccountSubType
static class | Constant.ChartOfAccountType
static class | Constant.CheckType
static class | Constant.CostControl
static class | Constant.CustomerVendorMailType
static class | Constant.CVAddressType
static class | Constant.CycleCountPeriodUnit
static class | Constant.DataFilterType
static class | Constant.DateType
static class | Constant.DebitOrCredit
static class | Constant.Depreciation
static class | Constant.Download
static class | Constant.DrawingType
static class | Constant.ECRPriority
static class | Constant.EmployeeSecurityLevel
static class | Constant.EmployeeStatus
static class | Constant.EngineeringSharingImportDataType
static class | Constant.EngineeringSharingImportType
static class | Constant.EquipmentStatus
static class | Constant.ExchangeRateType
static class | Constant.FileExt
static class | Constant.GLApprovedType
static class | Constant.GLStyle
static class | Constant.GLType
static class | Constant.InventoryCostMothed
static class | Constant.InventoryWorkSheetOrderBy
static class | Constant.IrDateType
static class | Constant.IRType
static class | Constant.IssuedFrom
static class | Constant.LanguageCode
static class | Constant.LocalSettings
static class | Constant.LoginType
static class | Constant.MakeBuy
static class | Constant.MiscDocType
static class | Constant.NaRecTo
static class | Constant.NcrApprovableType
static class | Constant.NoticeAction
static class | Constant.NoticeType
static class | Constant.OITypeSerialNumberType
static class | Constant.OrderType
static class | Constant.Package
static class | Constant.PageCycleCount
static class | Constant.PAOffsetType
static class | Constant.PartFrom
static class | Constant.PartNumberGenerateType
static class | Constant.PartQtyType
static class | Constant.PayableMethod
static class | Constant.PeriodUnit
static class | Constant.PosOrderType
static class | Constant.Prefix
static class | Constant.PrintTemplateType
static class | Constant.ReceiveCondition
static class | Constant.ReceivedTo
static class | Constant.SalesTaxReportType
static class | Constant.SGType
static class | Constant.StatementType
static class | Constant.Status
static class | Constant.SystemUserGroup
static class | Constant.TaxType
static class | Constant.TermsConditonType
static class | Constant.TrackingNumberType
static class | Constant.TransactionType
static class | Constant.TransferType
static class | Constant.Upload
static class | Constant.VendorQualityStatus
static class | Constant.WorkCenterSearchType
static class | Constant.WorkCenterType
static class | Constant.WorkLevel
static class | Constant.YesNO
Field Summary
static java.lang.String | BASE_ROLE
static int | BB2_ROUND_MODE
static java.math.BigDecimal | BB2_ZERO
static double | BB2_ZERO_double_VALUE
static java.lang.String | BOM_PARTS
static java.lang.String | checkOrderExist
static java.lang.String | CHINESE_LOCALE
static byte | DEFAULT_DIGITS
static java.lang.String | DefaultCompanyUnitID
static java.lang.String | DefaultCurrency
static java.lang.String | DefaultLanguage
static java.lang.String | DefaultMakeBuy
static java.lang.String | DefaultNaRecTo
static java.lang.String | DefaultPartFrom
static java.lang.String | DefaultPartType
static java.lang.String | DefaultPartUnit
static java.lang.String | DefaultReceivedTo
static java.lang.String | DefaultRevision
static java.lang.String | DefaultStatus
static java.lang.String | DefaultWorkInstructionSetID
static java.lang.String | EMPTY_LOCATION
static int | EXCHANGE_CALCULATIONAL_LENGHT
static java.lang.String | GL_VOID
static java.lang.String | JNDI_BB2_TOPIC
static int | MaintenanceWarningHrs
static long | MilliSecordsOfEachDay
static java.lang.String | NA
static java.lang.String | NewPart
static int | pageCount
static java.lang.String | PartNumberFormat
static java.lang.String | RecoilLocationSpecial
static java.lang.String | RECURSIVE_BILL
static java.lang.String | SERIAL_NUMBER
static int | WiSequence
Constructor Summary
Constant()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

JNDI_BB2_TOPIC

public static final java.lang.String JNDI_BB2_TOPIC
See Also:
Constant Field Values

MilliSecordsOfEachDay

public static final long MilliSecordsOfEachDay
See Also:
Constant Field Values

DefaultCurrency

public static final java.lang.String DefaultCurrency
See Also:
Constant Field Values

DefaultPartType

public static final java.lang.String DefaultPartType
See Also:
Constant Field Values

DefaultPartFrom

public static final java.lang.String DefaultPartFrom
See Also:
Constant Field Values

DefaultStatus

public static final java.lang.String DefaultStatus
See Also:
Constant Field Values

DefaultMakeBuy

public static final java.lang.String DefaultMakeBuy
See Also:
Constant Field Values

DefaultRevision

public static final java.lang.String DefaultRevision
See Also:
Constant Field Values

DefaultReceivedTo

public static final java.lang.String DefaultReceivedTo
See Also:
Constant Field Values

DefaultNaRecTo

public static final java.lang.String DefaultNaRecTo
See Also:
Constant Field Values

DefaultPartUnit

public static final java.lang.String DefaultPartUnit
See Also:
Constant Field Values

DefaultLanguage

public static final java.lang.String DefaultLanguage
See Also:
Constant Field Values

CHINESE_LOCALE

public static final java.lang.String CHINESE_LOCALE
See Also:
Constant Field Values

DefaultWorkInstructionSetID

public static final java.lang.String DefaultWorkInstructionSetID
See Also:
Constant Field Values

NewPart

public static final java.lang.String NewPart
See Also:
Constant Field Values

NA

public static final java.lang.String NA
See Also:
Constant Field Values

EMPTY_LOCATION

public static final java.lang.String EMPTY_LOCATION
See Also:
Constant Field Values

pageCount

public static final int pageCount
See Also:
Constant Field Values

WiSequence

public static final int WiSequence
See Also:
Constant Field Values

BB2_ZERO_double_VALUE

public static final double BB2_ZERO_double_VALUE
See Also:
Constant Field Values

BB2_ZERO

public static final java.math.BigDecimal BB2_ZERO

MaintenanceWarningHrs

public static final int MaintenanceWarningHrs
See Also:
Constant Field Values

BB2_ROUND_MODE

public static final int BB2_ROUND_MODE
See Also:
Constant Field Values

GL_VOID

public static final java.lang.String GL_VOID
See Also:
Constant Field Values

RECURSIVE_BILL

public static final java.lang.String RECURSIVE_BILL
See Also:
Constant Field Values

BOM_PARTS

public static final java.lang.String BOM_PARTS
See Also:
Constant Field Values

SERIAL_NUMBER

public static final java.lang.String SERIAL_NUMBER
See Also:
Constant Field Values

BASE_ROLE

public static final java.lang.String BASE_ROLE
See Also:
Constant Field Values

DefaultCompanyUnitID

public static final java.lang.String DefaultCompanyUnitID
See Also:
Constant Field Values

checkOrderExist

public static final java.lang.String checkOrderExist
See Also:
Constant Field Values

PartNumberFormat

public static final java.lang.String PartNumberFormat
See Also:
Constant Field Values

DEFAULT_DIGITS

public static final byte DEFAULT_DIGITS
See Also:
Constant Field Values

EXCHANGE_CALCULATIONAL_LENGHT

public static final int EXCHANGE_CALCULATIONAL_LENGHT
See Also:
Constant Field Values

RecoilLocationSpecial

public static final java.lang.String RecoilLocationSpecial
See Also:
Constant Field Values
Constructor Detail

Constant

public Constant()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant Field Values

Contents
  • bb.common.*
bb.common.*

bb.common.AccountBalanceListResult
public static final java.lang.String | ORDER_BY_ACCOUNTDESCRIPTION | "ga.description"
public static final java.lang.String | ORDER_BY_ACCOUNTNUMBER | "temp_gdc.ga"
public static final java.lang.String | ORDER_BY_ADDRESSID | "temp_gdc.id"
public static final java.lang.String | ORDER_BY_ADDRESSNAME | "gl.name"
public static final java.lang.String | ORDER_BY_COMPANYUNITID | "temp_gdc.co_unit_id"

bb.common.AccountBalanceResult
public static final java.lang.String | ORDER_BY_ACCOUNTNUMBER | "level"
public static final java.lang.String | ORDER_BY_ADDRESSID | "accountNumber"
public static final java.lang.String | ORDER_BY_COMPANYUNITID | "items"

bb.common.AccountingInfoDocumentVO
public static final java.lang.String | ORDER_BY_ACCOUNTINGREPORTTYPE | "accountingReportType"
public static final java.lang.String | ORDER_BY_COMMENTS | "comments"
public static final java.lang.String | ORDER_BY_COMPANYUNITID | "companyUnitId"
public static final java.lang.String | ORDER_BY_DOCLENGTH | "docLength"
public static final java.lang.String | ORDER_BY_DOCNAME | "docName"
public static final java.lang.String | ORDER_BY_DOCUMENTDATE | "documentDate"
public static final java.lang.String | ORDER_BY_EXTENSION | "extension"
public static final java.lang.String | ORDER_BY_LASTCHANGEDATE | "lastChangeDate"
public static final java.lang.String | ORDER_BY_LASTUSER | "lastUser"
public static final java.lang.String | ORDER_BY_USERNAME | "userName"
public static final java.lang.String | ORDER_BY_YEARCODE | "yearCode"

bb.common.AccountPayableCheckRunVO
public static final java.lang.String | ORDER_BY_CHECKNUMBER | "checkNumber"
public static final java.lang.String | ORDER_BY_CHECKRUNNUMBER | "checkRunNumber"
public static final java.lang.String | ORDER_BY_DATE1 | "date1"
public static final java.lang.String | ORDER_BY_DATE2 | "date2"
public static final java.lang.String | ORDER_BY_DATEPAID | "datePaid"
public static final java.lang.String | ORDER_BY_STATUS | "status"
public static final java.lang.String | ORDER_BY_TRANSACTIONDATE | "transactionDate"

bb.common.AccountPayableCheckVO
public static final java.lang.String | ORDER_BY_CHECKNUMBER | "checkNumber"
public static final java.lang.String | ORDER_BY_CHECKRUNNUMBER | "checkRunNumber"
public static final java.lang.String | ORDER_BY_NAME | "name"
public static final java.lang.String | ORDER_BY_VENDORID | "vendorId"

bb.common.AccountReceivableInfoWithPrepayResult
public static final java.lang.String | ORDER_BY_companyUnitId | "companyUnitId"
public static final java.lang.String | ORDER_BY_CUSTOMERID | "customerId"
public static final java.lang.String | ORDER_BY_INVOICENUMBER | "invoiceNumber"
public static final java.lang.String | ORDER_BY_NAME | "customerName"
public static final java.lang.String | ORDER_BY_SALESNUMBER | "salesOrderNumber"

bb.common.AccountsChartCategoryVO
public static final java.lang.String | ORDER_BY_CATEGORYNAME | "cat.categoryName"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "cat.description"
public static final java.lang.String | ORDER_BY_INDEX | "cat.index"

bb.common.AccountsCreditDebitListResult
public static final java.lang.String | ORDER_BY_ACCOUNTNUMBER | "gd.accountNumber"
public static final java.lang.String | ORDER_BY_TRANSACTIONDATE | "gd.transactionDate"
public static final java.lang.String | ORDER_BY_TRANSACTIONNO | "gd.pk.transactionNumber"
public static final java.lang.String | ORDER_BY_TRANSACTIONTYPE | "gd.transactionType"

bb.common.AccountsPayableInfoVO
public static final java.lang.String | ORDER_BY_APFREIGHT | "ap.apFreight"
public static final java.lang.String | ORDER_BY_APNET | "ap.apNet"
public static final java.lang.String | ORDER_BY_APNUMBER | "ap.apNumber"
public static final java.lang.String | ORDER_BY_APPAIDRCV | "ap.apPaidRcv"
public static final java.lang.String | ORDER_BY_APTAX | "ap.apTax"
public static final java.lang.String | ORDER_BY_BUYER | "ap.buyer"
public static final java.lang.String | ORDER_BY_COMPANYUNITID | "ap.companyUnitId"
public static final java.lang.String | ORDER_BY_CURRENCY | "ap.currency"
public static final java.lang.String | ORDER_BY_DEBITACCOUNT | "ap.debitAccount"
public static final java.lang.String | ORDER_BY_DUE | "ap.due"
public static final java.lang.String | ORDER_BY_NAME | "ap.customerAddressInfo.name"
public static final java.lang.String | ORDER_BY_PAYDATE | "ap.payDate"
public static final java.lang.String | ORDER_BY_PONUMBER | "ap.poNumber"
public static final java.lang.String | ORDER_BY_RECEIVERNUMBER | "ap.receiverNumber"
public static final java.lang.String | ORDER_BY_STATUS | "ap.status"
public static final java.lang.String | ORDER_BY_VENDORID | "ap.vendorId"
public static final java.lang.String | ORDER_BY_VENDORINVOICE | "ap.vendorInvoice"
public static final java.lang.String | ORDER_BY_VENDORINVOICEDATE | "ap.vendorInvoiceDate"
public static final java.lang.String | ORDER_BY_VENDORPACKAGE | "ap.vendorPackage"
public static final java.lang.String | ORDER_BY_VENDORTOTAL | "ap.vendorTotal"

bb.common.AccountsReceivableInfoVO
public static final java.lang.String | ORDER_BY_AMOUNTDUE | "ar.amountDue"
public static final java.lang.String | ORDER_BY_BILLTO | "ar.billTo"
public static final java.lang.String | ORDER_BY_COMPANYUNITID | "ar.companyUnitId"
public static final java.lang.String | ORDER_BY_CURRENCY | "ar.currency"
public static final java.lang.String | ORDER_BY_CUSTOMERID | "ar.customerId"
public static final java.lang.String | ORDER_BY_CUSTOMERPONUMBER | "ar.customerPoNumber"
public static final java.lang.String | ORDER_BY_DATEINVOICED | "ar.dateInvoiced"
public static final java.lang.String | ORDER_BY_DATESHIPPED | "ar.dateShipped"
public static final java.lang.String | ORDER_BY_GRANDTOTAL | "ar.grandTotal"
public static final java.lang.String | ORDER_BY_INVOICENUMBER | "ar.invoiceNumber"
public static final java.lang.String | ORDER_BY_MARGIN | "ar.margin"
public static final java.lang.String | ORDER_BY_NAME | "ar.customerAddressInfo.name"
public static final java.lang.String | ORDER_BY_PAID | "ar.paid"
public static final java.lang.String | ORDER_BY_PAYDATE | "ar.paydate"
public static final java.lang.String | ORDER_BY_SALESORDERNUMBER | "ar.salesOrderNumber"
public static final java.lang.String | ORDER_BY_SHIPPERNUMBER | "ar.shipperNumber"
public static final java.lang.String | ORDER_BY_SHIPTO | "ar.shipTo"
public static final java.lang.String | ORDER_BY_STATUS | "ar.status"

bb.common.AccountsReceivableItemResult
public static final java.lang.String | ORDER_BY_AVGCOST | "ari.avgCost"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "ari.description"
public static final java.lang.String | ORDER_BY_GRANDTOTAL | "8"
public static final java.lang.String | ORDER_BY_PARTFROM | "ari.partNumber,ari.partType,ari.partFrom"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "ari.partNumber,ari.partType,ari.partFrom"
public static final java.lang.String | ORDER_BY_PARTTYPE | "ari.partNumber,ari.partType,ari.partFrom"
public static final java.lang.String | ORDER_BY_QTYSHIPPED | "ari.qtyShipped"
public static final java.lang.String | ORDER_BY_STDCOST | "ari.stdCost"
public static final java.lang.String | ORDER_BY_SUBTOTAL | "9"

bb.common.AccountsReceivableItemVO
public static final java.lang.String | ORDER_BY_AVGCOST | "ari.avgCost"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "ari.description"
public static final java.lang.String | ORDER_BY_PARTFROM | "ari.partNumber,ari.partType,ari.partFrom"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "ari.partNumber,ari.partType,ari.partFrom"
public static final java.lang.String | ORDER_BY_PARTTYPE | "ari.partNumber,ari.partType,ari.partFrom"
public static final java.lang.String | ORDER_BY_QTYSHIPPED | "ari.qtyShipped"
public static final java.lang.String | ORDER_BY_STDCOST | "ari.stdCost"

bb.common.AllPartDocumentsVO
public static final java.lang.String | ORDER_BY_COMMENTS | "doc.comments"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "doc.description"
public static final java.lang.String | ORDER_BY_DOCUMENTTYPE | "doc.pk.documentType"
public static final java.lang.String | ORDER_BY_LANGUAGE | "doc.pk.language"
public static final java.lang.String | ORDER_BY_LASTCHANGEDATE | "doc.lastChangeDate"
public static final java.lang.String | ORDER_BY_LASTCHANGEUSER | "doc.lastChangeUser"
public static final java.lang.String | ORDER_BY_PK | "doc.pk.partNumber"

bb.common.APAgingItemListResult
public static final java.lang.String | ORDER_BY_APNUMBER | "ap.arApNumber"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "api.partNumber"
public static final java.lang.String | ORDER_BY_PAYDATE | "ap.payDate, ap.customerId, ap.arApNumber"
public static final java.lang.String | ORDER_BY_STATUS | "api.status"
public static final java.lang.String | ORDER_BY_VENDORID | "ap.customerId"
public static final java.lang.String | ORDER_BY_VENDORINVOICEDATE | "ap.arApDate, ap.customerId, ap.arApNumber"

bb.common.APAuditListResult
public static final java.lang.String | ORDER_BY_APNUMBER | "apNumber"
public static final java.lang.String | ORDER_BY_VENDORID | "vendorId"

bb.common.ApCheckRunListResult
public static final java.lang.String | ORDER_BY_AMOUNT | "apc.paid"
public static final java.lang.String | ORDER_BY_APNUMBER | "apc.pk.apNumber"
public static final java.lang.String | ORDER_BY_CHECKNUMBER | "apc.checkNumber"
public static final java.lang.String | ORDER_BY_CHECKRUNNUMBER | "apc.pk.checkRunNumber"
public static final java.lang.String | ORDER_BY_CURRENCY | "apc.currency"
public static final java.lang.String | ORDER_BY_DATECHECKRUNPAID | "apr.datePaid"
public static final java.lang.String | ORDER_BY_PAYDATE | "apc.payDate"
public static final java.lang.String | ORDER_BY_PONUMBER | "apc.poNumber"
public static final java.lang.String | ORDER_BY_TRANSACTIONNUMBER | "gl.transactionNumber"
public static final java.lang.String | ORDER_BY_VENDORID | "apc.vendorId"
public static final java.lang.String | ORDER_BY_VENDORNAME | "apc.customerAddressInfo.name"

bb.common.APItemListResult
public static final java.lang.String | ORDER_BY_APITEMNUMBER | "api.pk.apItemNumber"
public static final java.lang.String | ORDER_BY_APNUMBER | "ap.apNumber"
public static final java.lang.String | ORDER_BY_COMPANYUNITID | "ap.companyUnitId"
public static final java.lang.String | ORDER_BY_DATEPAID | "ap.datePaid"
public static final java.lang.String | ORDER_BY_DATERECEIVED | "ap.dateReceived, ap.vendorId, ap.apNumber"
public static final java.lang.String | ORDER_BY_DEBITACCOUNT | "ap.debitAccount"
public static final java.lang.String | ORDER_BY_OURPONUMBER | "ap.poNumber"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "api.partNumber, api.partType"
public static final java.lang.String | ORDER_BY_PARTTYPE | "api.partNumber, api.partType"
public static final java.lang.String | ORDER_BY_PAYDATE | "ap.payDate, ap.vendorId, ap.apNumber"
public static final java.lang.String | ORDER_BY_PRODUCTCODE | "api.productCode"
public static final java.lang.String | ORDER_BY_STATUS | "api.status"
public static final java.lang.String | ORDER_BY_VENDORID | "ap.vendorId"
public static final java.lang.String | ORDER_BY_VENDORINVOICE | "ap.vendorInvoice"
public static final java.lang.String | ORDER_BY_VENDORINVOICEDATE | "ap.vendorInvoiceDate, ap.vendorId, ap.apNumber"

bb.common.ApPrepayVO
public static final java.lang.String | ORDER_BY_APPDATE | "app.appDate"
public static final java.lang.String | ORDER_BY_APPREPAYNUMBER | "app.apPrepayNumber"
public static final java.lang.String | ORDER_BY_COMPANYUNITID | "app.companyUnitId"
public static final java.lang.String | ORDER_BY_PONUMBER | "app.purchaseOrderNumber"
public static final java.lang.String | ORDER_BY_VENDORID | "app.vendorId"

bb.common.APTaxForZipcodeListResult
public static final java.lang.String | ORDER_BY_VENDORID | "ap.vendorId"
public static final java.lang.String | ORDER_BY_VENDORNAME | "ab.name"
public static final java.lang.String | ORDER_BY_ZIPCODE | "ab.zip"

bb.common.ARAllStatementsListResult
public static final java.lang.String | ORDER_BY_CUSTOMERID | "ar.customerId"
public static final java.lang.String | ORDER_BY_CUSTOMERNAME | "ab.name"

bb.common.ARAuditListResult
public static final java.lang.String | ORDER_BY_ARNUMBER | "invoiceNumber"
public static final java.lang.String | ORDER_BY_CUSTID | "customerId"

bb.common.ARBoilerplateVO
public static final java.lang.String | ORDER_BY_ARBOILERPLATE | "tt.arBoilerplate"
public static final java.lang.String | ORDER_BY_BOILERPLATEID | "tt.boilerplateId"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "tt.description"

bb.common.ArCommissionListResult
public static final java.lang.String | ORDER_BY_ADDRESSID | "code.address_id"
public static final java.lang.String | ORDER_BY_ADDRESSNAME | "code.address_name"
public static final java.lang.String | ORDER_BY_COMMISSIONRATE | "code.commission_rate"
public static final java.lang.String | ORDER_BY_CURRENCY | "ar.currency"
public static final java.lang.String | ORDER_BY_CUSTOMERID | "ar.id"
public static final java.lang.String | ORDER_BY_CUSTOMERPO | "ar.po"
public static final java.lang.String | ORDER_BY_DATEINVOICED | "ar.date_invoiced"
public static final java.lang.String | ORDER_BY_EMPLOYEEID | "code.emp_id"
public static final java.lang.String | ORDER_BY_FREIGHTTOTAL | "ar.ar_freight"
public static final java.lang.String | ORDER_BY_GRANDTOTAL | "ar.ar_total"
public static final java.lang.String | ORDER_BY_INVOICENUMBER | "ar.ar"
public static final java.lang.String | ORDER_BY_PAIDDATE | "ar.date_paid"
public static final java.lang.String | ORDER_BY_PAYDATE | "ar.paydate"
public static final java.lang.String | ORDER_BY_SALESCODEID | "code.id"
public static final java.lang.String | ORDER_BY_SALESCODENAME | "code.name"
public static final java.lang.String | ORDER_BY_SALESORDERNUMBER | "ar.so"
public static final java.lang.String | ORDER_BY_SUBDISCOUNTTOTAL | "ar.ar_disc"
public static final java.lang.String | ORDER_BY_SUBNETTOTAL | "ar.ar_net"
public static final java.lang.String | ORDER_BY_SUBUNITTOTAL | "ar.ar_sub"
public static final java.lang.String | ORDER_BY_TAXTOTAL | "ar.ar_tax"

bb.common.ARPaymentRunListResult
public static final java.lang.String | ORDER_BY_ARNUMBER | "arp.pk.arNumber"
public static final java.lang.String | ORDER_BY_CUSTOMERID | "arp.customerId"
public static final java.lang.String | ORDER_BY_CUSTOMERNAME | "arp.customerAddressInfo.name"
public static final java.lang.String | ORDER_BY_PAYDATE | "arp.payDate"
public static final java.lang.String | ORDER_BY_PAYMENTNUMBER | "arp.paymentNumber"
public static final java.lang.String | ORDER_BY_PAYMENTRUNNUMBER | "arp.pk.paymentRunNumber"
public static final java.lang.String | ORDER_BY_SONUMBER | "arp.soNumber"
public static final java.lang.String | ORDER_BY_TRANSACTIONNUMBER | "gl.transactionNumber"

bb.common.ARPaymentRunVO
public static final java.lang.String | ORDER_BY_DATE1 | "arp.date1"
public static final java.lang.String | ORDER_BY_DATE2 | "arp.date2"
public static final java.lang.String | ORDER_BY_EXCLUDE | "arp.exclude"
public static final java.lang.String | ORDER_BY_GAAR | "arp.gaAr"
public static final java.lang.String | ORDER_BY_GACHECKING | "arp.gaChecking"
public static final java.lang.String | ORDER_BY_INCLUDE | "arp.include"
public static final java.lang.String | ORDER_BY_PAYMENTNUMBER | "arp.paymentNumber"
public static final java.lang.String | ORDER_BY_PAYMENTRUNNUMBER | "arp.paymentRunNumber"
public static final java.lang.String | ORDER_BY_STATUS | "arp.status"
public static final java.lang.String | ORDER_BY_TOTALWIREFEE | "arp.totalWireFee"
public static final java.lang.String | ORDER_BY_TRANSACTIONDATE | "arp.transactionDate"
public static final java.lang.String | ORDER_BY_WIREFEEACCOUNT | "arp.wireFeeAccount"
public static final java.lang.String | ORDER_BY_WIREFEEAPNUMBER | "arp.wireFeeApNumber"

bb.common.ARPrepayAllStatementsListResult
public static final java.lang.String | ORDER_BY_CUSTOMERID | "prepay.customerId"
public static final java.lang.String | ORDER_BY_CUSTOMERNAME | "ab.name"

bb.common.ArPrepayVO
public static final java.lang.String | ORDER_BY_ARPDATE | "arp.arpDate"
public static final java.lang.String | ORDER_BY_ARPREPAYNUMBER | "arp.arPrepayNumber"
public static final java.lang.String | ORDER_BY_COMPANYUNITID | "arp.companyUnitId"
public static final java.lang.String | ORDER_BY_CUSTOMERID | "arp.customerId"
public static final java.lang.String | ORDER_BY_SONUMBER | "arp.salesOrderNumber"

bb.common.ArSalesCodeTotalListResult
public static final java.lang.String | ORDER_BY_ADDRESSID | "code.address_id"
public static final java.lang.String | ORDER_BY_ADDRESSNAME | "code.address_name"
public static final java.lang.String | ORDER_BY_COMMISSIONRATE | "code.commission_rate"
public static final java.lang.String | ORDER_BY_COMMISSIONTOTAL | "totalCommission"
public static final java.lang.String | ORDER_BY_DISCOUNTTOTAL | "subDiscountTotal"
public static final java.lang.String | ORDER_BY_EMPLOYEEID | "code.emp_id"
public static final java.lang.String | ORDER_BY_FREIGHTTOTAL | "freightTotal"
public static final java.lang.String | ORDER_BY_GRANDTOTAL | "grandTotal"
public static final java.lang.String | ORDER_BY_NETTOTAL | "subNetTotal"
public static final java.lang.String | ORDER_BY_SALESCODEID | "code.id"
public static final java.lang.String | ORDER_BY_SALESCODENAME | "code.name"
public static final java.lang.String | ORDER_BY_SUBTOTAL | "subUnitTotal"
public static final java.lang.String | ORDER_BY_TAXTOTAL | "taxTotal"

bb.common.ARTaxForZipcodeListResult
public static final java.lang.String | ORDER_BY_CUSTOMERID | "ar.customerId"
public static final java.lang.String | ORDER_BY_CUSTOMERNAME | "ab.name"
public static final java.lang.String | ORDER_BY_ZIPCODE | "ab.zip"

bb.common.AssetAddOrDisposalsReport
public static final java.lang.String | ORDER_BY_ACCMDEPRECIATECOST | "depreciatedAccm"
public static final java.lang.String | ORDER_BY_ACQUISITIONCOST | "acquisitionCost"
public static final java.lang.String | ORDER_BY_ACQUISITIONDATE | "acquisitionDate"
public static final java.lang.String | ORDER_BY_ASSETNUMBER | "assetNumber"
public static final java.lang.String | ORDER_BY_ASSETTYPE | "assetType"
public static final java.lang.String | ORDER_BY_DEPARTMENTID | "departmentID"
public static final java.lang.String | ORDER_BY_DEPRECIATEENDDATE | "depreciateEndDate"
public static final java.lang.String | ORDER_BY_DEPRECIATESTARTDATE | "depreciateStartDate"
public static final java.lang.String | ORDER_BY_DEPRECIATESTATUS | "depreciateStatus"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "description"
public static final java.lang.String | ORDER_BY_INITIALDEPRECIATECOST | "initialDepreciateCost"
public static final java.lang.String | ORDER_BY_LOCATION | "location"
public static final java.lang.String | ORDER_BY_NETSALVAGE | "netSalvage"
public static final java.lang.String | ORDER_BY_QUANTITY | "quantity"

bb.common.AssetDepreciateDetailReport
public static final java.lang.String | ORDER_BY_ACQUISITIONCOST | "acquisitionCost"
public static final java.lang.String | ORDER_BY_ASSETTYPE | "assetType"
public static final java.lang.String | ORDER_BY_DEPARTMENTID | "departmentID"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "description"
public static final java.lang.String | ORDER_BY_PK | "assetNumber"
public static final java.lang.String | ORDER_BY_QUANTITY | "quantity"

bb.common.AssetDepreciateVO
public static final java.lang.String | ORDER_BY_ACQUISITIONCOST | "asset.acquisitionCost"
public static final java.lang.String | ORDER_BY_amortizationExpenseAccount | "asset.amortizationExpenseAccount"
public static final java.lang.String | ORDER_BY_ASSETTYPE | "asset.assetType"
public static final java.lang.String | ORDER_BY_CURRENTMONTHDEPRECIATE | "asset.currentMonthDepreciate"
public static final java.lang.String | ORDER_BY_DEPARTMENTID | "asset.departmentID"
public static final java.lang.String | ORDER_BY_depreciatedAccm | "asset.depreciatedAccm"
public static final java.lang.String | ORDER_BY_DEPRECIATESTATUS | "asset.depreciateStatus"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "asset.description"
public static final java.lang.String | ORDER_BY_GLCATEGORY | "asset.glCategory,asset.categorySequence"
public static final java.lang.String | ORDER_BY_initialDepreciateCost | "asset.initialDepreciateCost"
public static final java.lang.String | ORDER_BY_LASTMONTHDEPRECIATE | "asset.lastMonthDepreciate"
public static final java.lang.String | ORDER_BY_location | "asset.location"
public static final java.lang.String | ORDER_BY_month | "month"
public static final java.lang.String | ORDER_BY_monthDepreciationRate | "asset.monthDepreciationRate"
public static final java.lang.String | ORDER_BY_netSalvage | "asset.netSalvage"
public static final java.lang.String | ORDER_BY_QUANTITY | "asset.quantity"
public static final java.lang.String | ORDER_BY_USINGSTATUS | "asset.usingStatus"

bb.common.AssetTypeVO
public static final java.lang.String | ORDER_BY_ID | "id"
public static final java.lang.String | ORDER_BY_NAME | "name"

bb.common.AssetVO
public static final java.lang.String | ORDER_BY_ACQUISITIONCOST | "asset.acquisitionCost"
public static final java.lang.String | ORDER_BY_ACQUISITIONDATE | "asset.acquisitionDate"
public static final java.lang.String | ORDER_BY_AMORTIZATIONEXPENSEACCOUNT | "asset.amortizationExpenseAccount"
public static final java.lang.String | ORDER_BY_ANNUALDEPRECIATIONRATE | "asset.annualDepreciationRate"
public static final java.lang.String | ORDER_BY_ASSETNUMBER | "asset.assetNumber"
public static final java.lang.String | ORDER_BY_ASSETTYPE | "asset.assetType"
public static final java.lang.String | ORDER_BY_ASSETTYPE2 | "asset.assetType2"
public static final java.lang.String | ORDER_BY_DEPARTMENTID | "asset.departmentID"
public static final java.lang.String | ORDER_BY_DEPRECIATEDACCM | "asset.depreciatedAccm"
public static final java.lang.String | ORDER_BY_DEPRECIATEDACCMMONTHS | "asset.depreciatedAccmMonths"
public static final java.lang.String | ORDER_BY_DEPRECIATEDDATE | "asset.depreciatedDate"
public static final java.lang.String | ORDER_BY_DEPRECIATEENDDATE | "asset.depreciateEndDate"
public static final java.lang.String | ORDER_BY_DEPRECIATESTARTDATE | "asset.depreciateStartDate"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "asset.description"
public static final java.lang.String | ORDER_BY_ESTIMATENETSALRATE | "asset.estimateNetSalRate"
public static final java.lang.String | ORDER_BY_GLACCOUNTNUMBER | "asset.glAccountNumber"
public static final java.lang.String | ORDER_BY_INITIALDEPRECIATECOST | "asset.initialDepreciateCost"
public static final java.lang.String | ORDER_BY_MONTHDEPRECIATIONRATE | "asset.monthDepreciationRate"

bb.common.AuditOnDemandResult
public static final java.lang.String | ORDER_BY_ONHANDQTY | "pt.onhand"
public static final java.lang.String | ORDER_BY_PARTPK | "pt.pn,pt.pa"

bb.common.BB2Event
public static final java.lang.String | CLOSE_DOCUMENT | "close document"
public static final java.lang.String | DOWNLOAD | "download"
public static final java.lang.String | OPEN_DOCUMENT | "open document"
public static final java.lang.String | SUBMIT_DOCUMENT | "submit document"
public static final java.lang.String | UPLOAD | "upload"

bb.common.BB2PartOnDemandListResult
public static final java.lang.String | ORDER_BY_INSIP | "pt.shipInProcessQty"
public static final java.lang.String | ORDER_BY_INSIT | "pt.shipInTransactionQty"
public static final java.lang.String | ORDER_BY_INWIP | "pt.workInProcessQty"
public static final java.lang.String | ORDER_BY_ONDEMAND | "pt.onDemandQty"
public static final java.lang.String | ORDER_BY_ONHAND | "pt.onhand"
public static final java.lang.String | ORDER_BY_ONORDER | "pt.onOrderQty"
public static final java.lang.String | ORDER_BY_PART | "pt.pk.partNumber"

bb.common.BillLogVO
public static final java.lang.String | ORDER_BY_BILLITEMNUMBER | "billItemNumber"
public static final java.lang.String | ORDER_BY_BILLNUMBER | "billNumber"
public static final java.lang.String | ORDER_BY_BILLTYPE | "billType"
public static final java.lang.String | ORDER_BY_LASTCHANGETIME | "lastChangeTime"
public static final java.lang.String | ORDER_BY_LASTCHANGEUSER | "lastChangeUser"
public static final java.lang.String | ORDER_BY_NEWPARTNUMBER | "newPartNumber"
public static final java.lang.String | ORDER_BY_NEWPARTQUANTITY | "newPartQuantity"
public static final java.lang.String | ORDER_BY_NEWPARTTYPE | "newPartType"
public static final java.lang.String | ORDER_BY_NEWSPAREPART | "newSparePart"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "partNumber"
public static final java.lang.String | ORDER_BY_PARTQUANTITY | "partQuantity"
public static final java.lang.String | ORDER_BY_PARTTYPE | "partType"
public static final java.lang.String | ORDER_BY_SPAREPART | "sparePart"

bb.common.BillOnHandWithPartInfoResult
public static final java.lang.String | ORDER_BY_BILLPK | "bm.pk.billNumber,bm.pk.billType"
public static final java.lang.String | ORDER_BY_LASTCHANGEDATE | "bm.lastChangeDate"
public static final java.lang.String | ORDER_BY_LASTCHANGEUSER | "bm.lastChangeUser"
public static final java.lang.String | ORDER_BY_ONDEMAND | "pt.onDemandQty"
public static final java.lang.String | ORDER_BY_ONHAND | "pt.onhand"
public static final java.lang.String | ORDER_BY_ONORDER | "pt.onOrderQty"

bb.common.BillWithPartInfoResult
public static final java.lang.String | ORDER_BY_BILLPK | "bm.pk.billNumber,bm.pk.billType"
public static final java.lang.String | ORDER_BY_CREATEDDATE | "bm.createdDate"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "ps.description"
public static final java.lang.String | ORDER_BY_DRAWING | "ps.drawing"
public static final java.lang.String | ORDER_BY_LASTCHANGEDATE | "bm.lastChangeDate"
public static final java.lang.String | ORDER_BY_LASTCHANGEUSER | "bm.lastChangeUser"
public static final java.lang.String | ORDER_BY_ORIGIN | "bm.origin"
public static final java.lang.String | ORDER_BY_STATUS | "bm.status"

bb.common.BizBoxServer
public static final java.lang.String | LANGUAGE_CN | "zh_CN"
public static final java.lang.String | LANGUAGE_EN | "en_US"
public static final java.lang.String | PORT_DEFAULT | "80"

bb.common.BizBoxUserEmployeeResult
public static final java.lang.String | ORDER_BY_COMMENT | "user.comment"
public static final java.lang.String | ORDER_BY_DEPARTMENT | "emp.department"
public static final java.lang.String | ORDER_BY_EMAIL | "emp.e_mail"
public static final java.lang.String | ORDER_BY_HOMEPHONE | "emp.home_phone"
public static final java.lang.String | ORDER_BY_MOBILE | "emp.mobile"
public static final java.lang.String | ORDER_BY_PHONE | "emp.phone"
public static final java.lang.String | ORDER_BY_SYSTEMUSERNAME | "emp.user_name"
public static final java.lang.String | ORDER_BY_TYPE | "user.type"
public static final java.lang.String | ORDER_BY_USERNAME | "user.username"

bb.common.BizboxUserListResult
public static final java.lang.String | ORDER_BY_EXPIREDATE | "user.expireDate"
public static final java.lang.String | ORDER_BY_LASTLOGIN | "user.lastLogin"
public static final java.lang.String | ORDER_BY_LOCKED | "user.locked"
public static final java.lang.String | ORDER_BY_REFID | "user.refId"
public static final java.lang.String | ORDER_BY_STATUS | "user.status"
public static final java.lang.String | ORDER_BY_SYSTEMUSERNAME | "user.userName"
public static final java.lang.String | ORDER_BY_TYPE | "user.type"
public static final java.lang.String | ORDER_BY_USERNAME | "user.userName"

bb.common.BizboxUserVO
public static final java.lang.String | ORDER_BY_COMPANYUNITID | "companyUnitId"
public static final java.lang.String | ORDER_BY_IP | "ip"
public static final java.lang.String | ORDER_BY_LANIP | "lanIp"
public static final java.lang.String | ORDER_BY_MACADDRESS | "macAddress"
public static final java.lang.String | ORDER_BY_STATUS | "status"
public static final java.lang.String | ORDER_BY_USERNAME | "userName"

bb.common.BizTarget
public static final java.lang.String | ACCOUNT_CHART | "ACCOUNT_CHART"
public static final java.lang.String | ACCOUNT_CHART_CATEGORY | "ACCOUNT_CHART_CATEGORY"
public static final java.lang.String | ACCOUNT_CHART_MAPPING | "ACCOUNT_CHART_MAPPING"
public static final java.lang.String | ACCOUNT_CHART_NUMBER | "ACCOUNT_CHART_NUMBER"
public static final java.lang.String | ACCOUNT_CHECK_RUN | "ACCOUNT_CHECK_RUN"
public static final java.lang.String | ACCOUNT_CREDIT | "ACCOUNT_CREDIT"
public static final java.lang.String | ACCOUNT_DEBIT | "ACCOUNT_DEBIT"
public static final java.lang.String | ACCOUNT_FISCALYEAR_SETTINGS | "ACCOUNT_FISCALYEAR_SETTINGS"
public static final java.lang.String | ACCOUNT_GENERALlEDGER_SETTTINGS | "ACCOUNT_GENERALlEDGER_SETTTINGS"
public static final java.lang.String | ACCOUNT_PAYABLE | "ACCOUNT_PAYABLE"
public static final java.lang.String | ACCOUNT_PAYABLE_PREPAY | "ACCOUNT_PAYABLE_PREPAY"
public static final java.lang.String | ACCOUNT_PAYMENT_RUN | "ACCOUNT_PAYMENT_RUN"
public static final java.lang.String | ACCOUNT_RECEIVABLE | "ACCOUNT_RECEIVABLE"
public static final java.lang.String | ACCOUNT_RECEIVABLE_PAYMENT | "ACCOUNT_RECEIVABLE_PAYMENT"
public static final java.lang.String | ACCOUNT_RECEIVABLE_PREPAY | "ACCOUNT_RECEIVABLE_PREPAY"
public static final java.lang.String | ACCOUNT_SETTING | "ACCOUNT_SETTING"
public static final java.lang.String | ACCOUNT_TRANSACTION | "ACCOUNT_TRANSACTION"
public static final java.lang.String | ACCOUNT_TRANSACTION_TYPE | "ACCOUNT_TRANSACTION_TYPE"
public static final java.lang.String | ACCOUNTING_INFO_DOC | "ACCOUNTING_INFO_DOC"
public static final java.lang.String | ACCOUNTING_PERIOD | "ACCOUNTING_PERIOD"
public static final java.lang.String | ADDRESS | "ADDRESS"
public static final java.lang.String | ADDRESS_QA_DOC | "ADDRESS_QA_DOC"
public static final java.lang.String | APP | "APP"
public static final java.lang.String | ASSET | "ASSET"
public static final java.lang.String | ASSET_DEPRECIATE | "ASSET_DEPRECIATE"
public static final java.lang.String | ASSET_TYPE | "ASSET_TYPE"
public static final java.lang.String | AUDIT | "AUDIT"
public static final java.lang.String | BACKFLUSH_MATERIAL | "BACKFLUSH_MATERIAL"
public static final java.lang.String | BALANCE_SHEET | "BALANCE_SHEET"
public static final java.lang.String | BANK_RECONCILIATION_REPORT | "BANK_RECONCILIATION_REPORT"
public static final java.lang.String | BIZBOX_USER | "BIZBOX_USER"
public static final java.lang.String | BOM | "BOM"
public static final java.lang.String | BOM_APPROVAL | "BOM_APPROVAL"
public static final java.lang.String | BUDGET | "BUDGET"
public static final java.lang.String | BUYER_CODE | "BUYER_CODE"
public static final java.lang.String | CARRIER | "CARRIER"
public static final java.lang.String | CASH_FLOW_BUDGET | "CASH_FLOW_BUDGET"
public static final java.lang.String | CASHIER | "CASHIER"
public static final java.lang.String | CATALOG | "CATALOG"
public static final java.lang.String | CATEGORY_INDEX | "CATEGORY_INDEX"
public static final java.lang.String | CERTIFICATE_DESCRIPTION | "CERTIFICATE_DESCRIPTION"
public static final java.lang.String | CERTIFICATE_DOC | "CERTIFICATE_DOC"
public static final java.lang.String | CG_CLIENT_PROGRAM_USER | "CG_CLIENT_PROGRAM_USER"
public static final java.lang.String | CG_CUST_RFQ | "CG_CUST_RFQ"
public static final java.lang.String | CG_CUSTOMER_SERVICE_REQUEST | "CG_CUSTOMER_SERVICE_REQUEST"
public static final java.lang.String | CG_PART | "CG_PART"
public static final java.lang.String | CG_QUOTE_ADDRESS | "CG_QUOTE_ADDRESS"
public static final java.lang.String | CG_SALE_ITEM | "CG_SALE_ITEM"
public static final java.lang.String | CHANGE_STD_COST_WORKSHEET | "CHANGE_STD_COST_WORKSHEET"
public static final java.lang.String | CLOSING_SATEMENT | "CLOSING_SATEMENT"
public static final java.lang.String | COMPANY_DEFAULT_PA | "COMPANY_DEFAULT_PA"
public static final java.lang.String | COMPANY_SETTING | "COMPANY_SETTING"
public static final java.lang.String | COMPANY_UNIT | "COMPANY_UNIT"
public static final java.lang.String | COMPANY_UNIT_ACCOUNT | "COMPANY_UNIT_ACCOUNT"
public static final java.lang.String | CONTRACE_PRICE | "CONTRACE_PRICE"
public static final java.lang.String | CONTRACE_PRICE_CUSTOMER | "CONTRACE_PRICE_CUSTOMER"
public static final java.lang.String | CONTRACE_PRICE_ITEM | "CONTRACE_PRICE_ITEM"
public static final java.lang.String | CORRICTIVE_ACTION_REQUEST | "CORRICTIVE_ACTION_REQUEST"
public static final java.lang.String | CREDIT_MEMO | "CREDIT_MEMO"
public static final java.lang.String | CS_ITEM_DOC | "CS_ITEM_DOC"
public static final java.lang.String | CURRENCY | "CURRENCY"
public static final java.lang.String | CURRENCY_EXCHANGE | "CURRENCY_EXCHANGE"
public static final java.lang.String | CUSTOMER | "CUSTOMER"
public static final java.lang.String | CUSTOMER_CATALOG | "CUSTOMER_CATALOG"
public static final java.lang.String | CUSTOMER_DOC | "CUSTOMER_DOC"
public static final java.lang.String | CUSTOMER_FEEDBACK | "CUSTOMER_FEEDBACK"
public static final java.lang.String | CUSTOMER_FEEDBACK_ITEM | "CUSTOMER_FEEDBACK_ITEM"
public static final java.lang.String | CUSTOMER_PART | "CUSTOMER_PART"
public static final java.lang.String | CUSTOMER_SERVICE_INCIDENT | "CUSTOMER_SERVICE_INCIDENT"
public static final java.lang.String | CUSTOMER_SERVICE_INCIDENT_ITEM | "CUSTOMER_SERVICE_INCIDENT_ITEM"
public static final java.lang.String | CUSTOMER_SERVICE_REQUEST | "CUSTOMER_SERVICE_REQUEST"
public static final java.lang.String | CUSTOMER_VENDOR_TYPE | "CUSTOMER_VENDOR_TYPE"
public static final java.lang.String | CYCLE_WORK_SHEET | "CYCLE_WORK_SHEET"
public static final java.lang.String | CYCLE_WORK_SHEET_PAGE_NUMBER | "CYCLE_WORK_SHEET_PAGE_NUMBER"
public static final java.lang.String | DEBIT_MEMO | "DEBIT_MEMO"
public static final java.lang.String | DEPARTMENT_LOCATION_FOR_BACKFLUSH | "DEPARTMENT_LOCATION_FOR_BACKFLUSH"
public static final java.lang.String | DESIGN_CONTROL | "DESIGN_CONTROL"
public static final java.lang.String | DESIGN_CONTROL_DOCUMENT | "DESIGN_CONTROL_DOCUMENT"
public static final java.lang.String | DISASSEMBLE_WORK_ORDER | "DISASSEMBLE_WORK_ORDER"
public static final java.lang.String | DISASSEMBLE_WORK_ORDER_APPROVAL | "DISASSEMBLE_WORK_ORDER_APPROVAL"
public static final java.lang.String | DISASSEMBLE_WORK_ORDER_ITEM | "DISASSEMBLE_WORK_ORDER_ITEM"
public static final java.lang.String | DISASSEMBLE_WORK_ORDER_ITEM_ISSUE | "DISASSEMBLE_WORK_ORDER_ITEM_ISSUE"
public static final java.lang.String | DISASSEMBLE_WORK_ORDER_ITEM_RECEIVER | "DISASSEMBLE_WORK_ORDER_ITEM_RECEIVER"
public static final java.lang.String | DOCUMENT | "DOCUMENT"
public static final java.lang.String | DOCUMENT_SETTINGS | "DOCUMENT_SETTINGS"
public static final java.lang.String | DWF_DRAWING | "DWF_DRAWING"
public static final java.lang.String | DWG_DRAWING | "DWG_DRAWING"
public static final java.lang.String | ECN | "ECN"
public static final java.lang.String | ECN_REVIEW | "ECN_REVIEW"
public static final java.lang.String | ECR | "ECR"
public static final java.lang.String | ECR_APPROVAL | "ECR_APPROVAL"
public static final java.lang.String | EDC_DOC | "EDC_DOC"
public static final java.lang.String | EMP_TRAINING_RECORDS | "EMP_TRAINING_RECORDS"
public static final java.lang.String | EMPLOYEE | "EMPLOYEE"
public static final java.lang.String | EMPLOYEE_TRAINING | "EMPLOYEE_TRAINING"
public static final java.lang.String | ENG_GROUP | "ENG_GROUP"
public static final java.lang.String | ENG_GROUP_USER | "ENG_GROUP_USER"
public static final java.lang.String | ENGINEERING_SHARING | "ENGINEERING_SHARING"
public static final java.lang.String | ENGINEERING_SHARING_ITEM | "ENGINEERING_SHARING_ITEM"
public static final java.lang.String | EQUIPMENT | "EQUIPMENT"
public static final java.lang.String | EXCHANAGE_RATE | "EXCHANAGE_RATE"
public static final java.lang.String | Exchange_Gain_And_Loss_Account | "Exchange_Gain_And_Loss_Account"
public static final java.lang.String | EXPENSE | "EXPENSE"
public static final java.lang.String | EXPENSE_ACCOUNT | "EXPENSE_ACCOUNT"
public static final java.lang.String | FEEDBACK_QUESTION | "FEEDBACK_QUESTION"
public static final java.lang.String | FILE_SYSTEM | "FILE_SYSTEM"
public static final java.lang.String | FISCAL_YEAR | "FISCAL_YEAR"
public static final java.lang.String | FISCAL_YEAR_BUDGET | "FISCAL_YEAR_BUDGET"
public static final java.lang.String | FISCAL_YEAR_SETTINGS | "FISCAL_YEAR_SETTINGS"
public static final java.lang.String | FTP | "FTP"
public static final java.lang.String | GENERAL_LEDGER | "GENERAL_LEDGER"
public static final java.lang.String | GENERAL_LEDGER_APPROVAL | "GENERAL_LEDGER_APPROVAL"
public static final java.lang.String | GL_CLOSED | "GL_CLOSED"
public static final java.lang.String | GL_MONTH | "GL_MONTH"
public static final java.lang.String | GROUP_USER | "GROUP_USER"
public static final java.lang.String | HISTORICAL_INVENTORY | "HISTORICAL_INVENTORY"
public static final java.lang.String | INCOTERM | "INCOTERM"
public static final java.lang.String | INSPECTION_REPORT | "INSPECTION_REPORT"
public static final java.lang.String | INSPECTION_TYPE | "INSPECTION_TYPE"
public static final java.lang.String | INVENTORY_ADJUSTMENT | "INVENTORY_ADJUSTMENT"
public static final java.lang.String | INVOICE | "INVOICE"
public static final java.lang.String | IR | "IR"
public static final java.lang.String | ISSUE_ITEM_AGENT | "ISSUE_ITEM_AGENT"
public static final java.lang.String | ITEM_STATUS | "ITEM_STATUS"
public static final java.lang.String | JOB_CATEGORY | "JOB_CATEGORY"
public static final java.lang.String | LN_RECEIVER | "LN_RECEIVER"
public static final java.lang.String | LN_SHIPPER | "LN_SHIPPER"
public static final java.lang.String | LN_SHIPPER_ITEM | "LNSHIPPER_ITEM"
public static final java.lang.String | MAINTENANCE_ITEM | "MAINTENANCE_ITEM"
public static final java.lang.String | MAKE_CHECK | "MAKE_CHECK"
public static final java.lang.String | MANUFACTURER | "MANUFACTURER"
public static final java.lang.String | MANUFACTURER_PART_NUMBER | "MANUFACTURER_PART_NUMBER"
public static final java.lang.String | MECN | "MECN"
public static final java.lang.String | MESSAGE | "MESSAGE"
public static final java.lang.String | MONTH_YEAR | "MONTH_YEAR"
public static final java.lang.String | MULTI_LANGUAGE_DESCRIPTION | "MULTI_LANGUAGE_DESCRIPTION"
public static final java.lang.String | MY_PRINT_LIST | "MY_PRINT_LIST"
public static final java.lang.String | NCR | "NCR"
public static final java.lang.String | NCR_APPROVAL | "NCR_APPROVAL"
public static final java.lang.String | NON_CONFORMANCE_CODE | "NON_CONFORMANCE_CODE"
public static final java.lang.String | NONPRODUCTIVE_PICKING | "NONPRODUCTIVE_PICKING"
public static final java.lang.String | NONPRODUCTIVE_PICKING_APPROVAL | "NONPRODUCTIVE_PICKING_APPROVAL"
public static final java.lang.String | NONPRODUCTIVE_PICKING_ITEM_ISSUE | "NONPRODUCTIVE_PICKING_ITEM_ISSUE"
public static final java.lang.String | NONPRODUCTIVE_PICKING_TYPE | "NONPRODUCTIVE_PICKING_TYPE"
public static final java.lang.String | NOTICE_USER | "NOTICE_USER"
public static final java.lang.String | ON_LOAN | "ON_LOAN"
public static final java.lang.String | ON_LOAN_ITEM | "ON_LOAN_ITEM"
public static final java.lang.String | ONLOAN_REVIEW | "ONLOAN_REVIEW"
public static final java.lang.String | ONLOAN_SHIPPER | "ONLOAN_SHIPPER"
public static final java.lang.String | OPERATING_INSTRUCTION | "OPERATING_INSTRUCTION"
public static final java.lang.String | OPERATING_INSTRUCTION_TYPE | "OPERATING_INSTRUCTION_TYPE"
public static final java.lang.String | ORDER | "ORDER"
public static final java.lang.String | PA_ACCOUNT | "PA_ACCOUNT"
public static final java.lang.String | PA_VARIANCE_ACCOUNT | "PA_VARIANCE_ACCOUNT"
public static final java.lang.String | PACKING_BOX | "PACKING_BOX"
public static final java.lang.String | PACKING_BOX_ITEM | "PACKING_BOX_ITEM"
public static final java.lang.String | PART | "PART"
public static final java.lang.String | PART_CATALOG | "PART_CATALOG"
public static final java.lang.String | PART_CERTIFICATE | "PART_CERTIFICATE"
public static final java.lang.String | PART_CLASS | "PART_CLASS"
public static final java.lang.String | PART_DESCRIPTION | "PART_DESCRIPTION"
public static final java.lang.String | PART_DISCOUNT | "PART_DISCOUNT"
public static final java.lang.String | PART_IN_QA | "PART_IN_QA"
public static final java.lang.String | PART_INSPECTION | "PART_INSPECTION"
public static final java.lang.String | PART_INVENTORY | "PART_INVENTORY"
public static final java.lang.String | PART_ISSUE | "PART_ISSUE"
public static final java.lang.String | PART_MANUFACTURER | "PART_MANUFACTURER"
public static final java.lang.String | PART_MATERIAL | "PART_MATERIAL"
public static final java.lang.String | PART_ONHAND | "PART_ONHAND"
public static final java.lang.String | PART_PICTURE | "PART_PICTURE"
public static final java.lang.String | PART_SECURITY_LEVEL | "PART_SECURITY_LEVEL"
public static final java.lang.String | PART_SHARE_COMPANY | "PART_SHARE_COMAPNY"
public static final java.lang.String | PART_TRACEABLE | "PART_TRACEABLE"
public static final java.lang.String | PART_TYPE | "PART_TYPE"
public static final java.lang.String | PART_UOM | "PART_UOM"
public static final java.lang.String | PART_VENDOR | "PART_VENDOR"
public static final java.lang.String | PAYABLE_METHOD | "PAYABLE_METHOD"
public static final java.lang.String | PAYMENT | "PAYMENT"
public static final java.lang.String | PAYMENT_RUN | "PAYMENT_RUN"
public static final java.lang.String | PHYSICAL_WORK_SHEET | "PHYSICAL_WORK_SHEET"
public static final java.lang.String | PHYSICAL_WORK_SHEET_PAGE_NUMBER | "PHYSICAL_WORK_SHEET_PAGE_NUMBER"
public static final java.lang.String | PO_NNMBER | "PO_NUMBER"
public static final java.lang.String | POS_SETTING | "POS_SETTING"
public static final java.lang.String | POST_CHECK | "POST_CHECK"
public static final java.lang.String | PREVENTIVE_ACTION_REQUEST | "PREVENTIVEaCTION_REQUEST"
public static final java.lang.String | PREVENTIVE_ACTION_REQUEST_ITEM | "PREVENTIVE_ACTION_REQUEST_ITEM"
public static final java.lang.String | PRINT_TEMPLATE | "PRINT_TEMPLATE"
public static final java.lang.String | PROFORMA_INVOICE | "PROFORMA_INVOICE"
public static final java.lang.String | PROFORMA_RECEIVER | "PROFORMA_RECEIVER"
public static final java.lang.String | PROJECT_CLASS | "PROJECT_CLASS"
public static final java.lang.String | PURCHASE_ORDER | "PURCHASE_ORDER"
public static final java.lang.String | PURCHASE_ORDER_APPROVAL | "PURCHASE_ORDER_APPROVAL"
public static final java.lang.String | PURCHASE_ORDER_ITEM | "PURCHASE_ORDER_ITEM"
public static final java.lang.String | PURCHASE_ORDER_ITEM_MANUFACTURER | "PURCHASE_ORDER_ITEM_MANUFACTURER"
public static final java.lang.String | PURCHASE_ORDER_MESSAGE | "PURCHASE_ORDER_MESSAGE"
public static final java.lang.String | PURCHASE_WORK_SHEET | "PURCHASE_WORK_SHEET"
public static final java.lang.String | PURCHASE_WORK_SHEET_ITEM | "PURCHASE_WORK_SHEET_ITEM"
public static final java.lang.String | QT_DOC | "QT_DOC"
public static final java.lang.String | QUOTE | "QUOTE"
public static final java.lang.String | QUOTE_ITEM | "QUOTE_ITEM"
public static final java.lang.String | QUOTE_ITEM_MFG | "QUOTE_ITEM_MFG"
public static final java.lang.String | RECEIVER | "RECEIVER"
public static final java.lang.String | RECEIVER_ITEM | "RECEIVER_ITEM"
public static final java.lang.String | RECEIVER_ITEM_AGENT | "RECEIVER_ITEM_AGENT"
public static final java.lang.String | RECEIVER_WORK_ORDER | "RECEIVER_WORK_ORDER"
public static final java.lang.String | REFERENCE_DOC | "REFERENCE_DOC"
public static final java.lang.String | REQUEST_FOR_CHANGE | "REQUEST_FOR_CHANGE"
public static final java.lang.String | REQUEST_FOR_QUOTE | "REQUEST_FOR_QUOTE"
public static final java.lang.String | REQUEST_FOR_QUOTE_ITEM | "REQUEST_FOR_QUOTE_ITEM"
public static final java.lang.String | REQUEST_FOR_QUOTE_ITEM_MANUFACTURER | "REQUEST_FOR_QUOTE_ITEM_MANUFACTURER"
public static final java.lang.String | RETURN_MATERIAL_AUTHORIZATION_ITEM_MANUFACTURER | "RETURN_MATERIAL_AUTHORIZATION_ITEM_MANUFACTURER"
public static final java.lang.String | RETURN_TO_VENDOR | "RETURN_TO_VENDOR"
public static final java.lang.String | RETURN_TO_VENDOR_ITEM | "RETURN_TO_VENDOR_ITEM"
public static final java.lang.String | RETURN_TO_VENDOR_ITEM_MANUFACTURER | "RETURN_TO_VENDOR_ITEM_MANUFACTURER"
public static final java.lang.String | RFQ_MESSAGE | "REQUEST_FOR_QUOTE_MESSAGE"
public static final java.lang.String | RFQ_MESSAGE_ITEM | "REQUEST_FOR_QUOTE_MESSAGE_ITEM"
public static final java.lang.String | RMA | "RMA"
public static final java.lang.String | RMA_DOC | "RMA_DOC"
public static final java.lang.String | RMA_ITEM | "RMA_ITEM"
public static final java.lang.String | RMA_RECEIVER | "RMA_RECEIVER"
public static final java.lang.String | RMA_RECEIVER_ITEM | "RMA_RECEIVER_ITEM"
public static final java.lang.String | RMA_REVIEW | "RMA_REVIEW"
public static final java.lang.String | ROLL_UP_BOM_STD_COST_WORKSHEET | "ROLL_UP_BOM_STD_COST_WORKSHEET"
public static final java.lang.String | RRMA | "RRMA"
public static final java.lang.String | RRMA_ITEM | "RRMA_ITEM"
public static final java.lang.String | RTV_APPROVAL | "RTV_APPROVAL"
public static final java.lang.String | RTV_SHIPPER | "RTV_SHIPPER"
public static final java.lang.String | RUNNING_ACCOUNT_ORDER | "RUNNING_ACCOUNT_ORDER"
public static final java.lang.String | SALES_CODE | "SALES_CODE"
public static final java.lang.String | SALES_ORDER | "SALES_ORDER"
public static final java.lang.String | SALES_ORDER_CURRENCY | "SALES_ORDER_CURRENCY"
public static final java.lang.String | SALES_ORDER_ITEM | "SALES_ORDER_ITEM"
public static final java.lang.String | SALES_ORDER_ITEM_MFG | "SALES_ORDER_ITEM_MFG"
public static final java.lang.String | SALES_ORDER_REVIEW | "SALES_ORDER_REVIEW"
public static final java.lang.String | SALESMAN | "SALESMAN"
public static final java.lang.String | SERIAL_NUMBER | "SERIAL_NUMBER"
public static final java.lang.String | SHIP_LIST | "SHIP_LIST"
public static final java.lang.String | SHIP_LIST_ITEM | "SHIP_LIST_ITEM"
public static final java.lang.String | SHIP_LIST_OWNER | "SHIP_LIST_OWNER"
public static final java.lang.String | SHIP_LIST_OWNER_ITEM | "SHIP_LIST_OWNER_ITEM"
public static final java.lang.String | SHIPPER | "SHIPPER"
public static final java.lang.String | SHIPPER_ITEM | "SHIPPER_ITEM"
public static final java.lang.String | SO_DOC | "SO_DOC"
public static final java.lang.String | SR_NUMBER | "SR_NUMBER"
public static final java.lang.String | SWAP_ORDER | "SWAP_ORDER"
public static final java.lang.String | SWAP_ORDER_APPROVAL | "SWAP_ORDER_APPROVAL"
public static final java.lang.String | SWAP_ORDER_ITEM | "SWAP_ORDER_ITEM"
public static final java.lang.String | SWAP_RECEIVER | "SWAP_RECEIVER"
public static final java.lang.String | SWAP_RECEIVER_ITEM | "SWAP_RECEIVER_ITEM"
public static final java.lang.String | SWAP_SHIPPER | "SWAP_SHIPPER"
public static final java.lang.String | SWAP_SHIPPER_ITEM | "SWAP_SHIPPER_ITEM"
public static final java.lang.String | TASK | "TASK"
public static final java.lang.String | TEMPORARYEMPLOYEE | "TEMPORARYEMPLOYEE"
public static final java.lang.String | TERM | "TERM"
public static final java.lang.String | TIME_CARDS | "TIME_CARDS"
public static final java.lang.String | TOO_MUCH_DATA_TO_SEARCH | "TOO_MUCH_DATA_TO_SEARCH"
public static final java.lang.String | TOOL | "TOOL"
public static final java.lang.String | TOOL_CALIBRATION | "TOOL_CALIBRATION"
public static final java.lang.String | TOOL_ONHAND | "TOOL_ONHAND"
public static final java.lang.String | TRACEABLE | "TRACEABLE"
public static final java.lang.String | TRACEABLE_CATEGORIES | "TRACEABLE_CATEGORIES"
public static final java.lang.String | TRACEABLE_SPECIFITIONS | "TRACEABLE_SPECIFITIONS"
public static final java.lang.String | TRACKING | "TRACKING"
public static final java.lang.String | TRANSFER_ORDER | "TRANSFER_ORDER"
public static final java.lang.String | TRANSFER_ORDER_APPROVAL | "TRANSFER_ORDER_APPROVAL"
public static final java.lang.String | TRANSFER_ORDER_ITEM | "TRANSFER_ORDER_ITEM"
public static final java.lang.String | TRANSFER_RECIEVER | "TRANSFER_RECIEVER"
public static final java.lang.String | TRANSFER_RECIEVER_ITEM | "TRANSFER_RECIEVER_ITEM"
public static final java.lang.String | TRANSFER_SHIPPER | "TRANSFER_SHIPPER"
public static final java.lang.String | TRANSFER_SHIPPER_ITEM | "TRANSFER_SHIPPER_ITEM"
public static final java.lang.String | UNBILLED | "UNBILLED"
public static final java.lang.String | USER_GROUP | "USER_GROUP"
public static final java.lang.String | USER_TRUE_NAME | "USER_TRUE_NAME"
public static final java.lang.String | USER_ZIPCODE_TAX | "USER_ZIPCODE_TAX"
public static final java.lang.String | VENDOR | "VENDOR"
public static final java.lang.String | VENDOR_CONTRACE_PRICE | "VENDOR_CONTRACE_PRICE"
public static final java.lang.String | VENDOR_CONTRACE_PRICE_ITEM | "VENDOR_CONTRACE_PRICE_ITEM"
public static final java.lang.String | VENDOR_CONTRACE_PRICE_VENDOR | "VENDOR_CONTRACE_PRICE_VENDOR"
public static final java.lang.String | VENDOR_CRITICAL_LEVEL | "VENDOR_CRITICAL_LEVEL"
public static final java.lang.String | VENDOR_DOC | "VENDOR_DOC"
public static final java.lang.String | VENDOR_GROUP_USER | "VENDOR_GROUP_USER"
public static final java.lang.String | VENDOR_PART | "VENDOR_PART"
public static final java.lang.String | WAREHOUSE | "WAREHOUSE"
public static final java.lang.String | WEIGHT_UNIT | "WEIGHT_UOM"
public static final java.lang.String | WIP_PHYSICAL_WORK_SHEET | "WIP_PHYSICAL_WORK_SHEET"
public static final java.lang.String | WORK_CALENDAR | "WORK_CALENDAR"
public static final java.lang.String | WORK_CENTER | "WORK_CENTER"
public static final java.lang.String | WORK_CENTER_GROUP | "WORK_CENTER_GROUP"
public static final java.lang.String | WORK_INSTRUCTION | "WORK_INSTRUCTION"
public static final java.lang.String | WORK_INSTRUCTION_APPROVAL | "WORK_INSTRUCTION_APPROVAL"
public static final java.lang.String | WORK_INSTRUCTION_DOC | "WORK_INSTRUCTION_DOC"
public static final java.lang.String | WORK_ORDER | "WORK_ORDER"
public static final java.lang.String | WORK_ORDER_APPROVAL | "WORK_ORDER_APPROVAL"
public static final java.lang.String | WORK_ORDER_ITEM | "WORK_ORDER_ITEM"
public static final java.lang.String | WORK_ORDER_ITEM_ISSUE | "WORK_ORDER_ITEM_ISSUE"
public static final java.lang.String | WORK_ORDER_ITEM_PART_DETAIL | "WORK_ORDER_ITEM_PART_DETAIL"
public static final java.lang.String | WORK_ORDER_ITEM_TIME_DETAIL | "WORK_ORDER_ITEM_TIME_DETAIL"
public static final java.lang.String | WORK_ORDER_WORK_INSTRUCTION | "WORK_ORDER_WORK_INSTRUCTION"
public static final java.lang.String | WORK_ORDER_WORK_INSTRUCTION_SEQ | "WORK_ORDER_WORK_INSTRUCTION_SEQ"
public static final java.lang.String | WORK_PERIOD | "WORK_PERIOD"
public static final java.lang.String | WORK_WORK_SHEET | "WORK_WORK_SHEET"
public static final java.lang.String | WORK_WORK_SHEET_ITEM | "WORK_WORK_SHEET_ITEM"

bb.common.BomApprovalVO
public static final java.lang.String | ORDER_BY_CANAPPROVEOWNBOM | "canApproveOwnBom"
public static final java.lang.String | ORDER_BY_COMMENTS | "comments"
public static final java.lang.String | ORDER_BY_EMPLOYEEID | "employeeId"
public static final java.lang.String | ORDER_BY_USERNAME | "userName"

bb.common.BuyerCodeVO
public static final java.lang.String | ORDER_BY_ACTIONTYPE | "actionType"
public static final java.lang.String | ORDER_BY_BUYERCODE | "buyerCode"
public static final java.lang.String | ORDER_BY_BUYERNAME | "buyerName"
public static final java.lang.String | ORDER_BY_COMMENTS | "comments"
public static final java.lang.String | ORDER_BY_DEPARTMENT | "department"
public static final java.lang.String | ORDER_BY_DEPARTMENTID | "departmentId"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "description"

bb.common.CertificateDescriptionVO
public static final java.lang.String | ORDER_BY_DESCRIPTION | "description"
public static final java.lang.String | ORDER_BY_ID | "id"

bb.common.ChangeStdCostWorkSheetItemVO
public static final java.lang.String | ORDER_BY_AVGCOST | "avgCost"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "description"
public static final java.lang.String | ORDER_BY_MAKEBUY | "makeBuy"
public static final java.lang.String | ORDER_BY_NEWSTDCOST | "newStdCost"
public static final java.lang.String | ORDER_BY_ONHAND | "onHand"
public static final java.lang.String | ORDER_BY_PK | "pk.partNumber,pk.partType"
public static final java.lang.String | ORDER_BY_STDCOST | "stdCost"
public static final java.lang.String | ORDER_BY_VARIANCEPERCENT | "variancePercent"

bb.common.ChangeStdCostWorkSheetVO
public static final java.lang.String | ORDER_BY_COMMENTS | "comments"
public static final java.lang.String | ORDER_BY_COMMITTEDBY | "committedBy"
public static final java.lang.String | ORDER_BY_COMMITTEDDATE | "committedDate"
public static final java.lang.String | ORDER_BY_CREATEDBY | "createdBy"
public static final java.lang.String | ORDER_BY_CREATEDDATE | "createdDate"
public static final java.lang.String | ORDER_BY_II | "ii"
public static final java.lang.String | ORDER_BY_ITEMCOUNT | "itemCount"
public static final java.lang.String | ORDER_BY_STATUS | "status"
public static final java.lang.String | ORDER_BY_TRANSACTIONNUMBER | "transactionNumber"
public static final java.lang.String | ORDER_BY_VARIANCEAMOUNT | "varianceAmount"

bb.common.CheckInvoiceItemListResult
public static final java.lang.String | ORDER_BY_CUSTOMERID | "ar.customerId"
public static final java.lang.String | ORDER_BY_DATEINVOICED | "ar.dateInvoiced"
public static final java.lang.String | ORDER_BY_INVOICENUMBER | "ar.invoiceNumber"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "ari.partNumber"

bb.common.CompanyUnitVO
public static final java.lang.String | ORDER_BY_COMMENTS | "comments"
public static final java.lang.String | ORDER_BY_ID | "id"
public static final java.lang.String | ORDER_BY_NAME | "name"
public static final java.lang.String | ORDER_BY_TYPE | "type"

bb.common.Configure.LoginStatus
public static final int | INVALID | -1
public static final int | OFFLINE | 0
public static final int | ONLINE | 1

bb.common.Configure.Module
public static final java.lang.String | ACCOUNTING | "AccountingAccess"
public static final java.lang.String | ADDRESS | "AddressAccess"
public static final java.lang.String | COMPANYSETTINGS | "CompanySettingsAccess"
public static final java.lang.String | CUSTOMERSERVICE | "CustomerServiceAccess"
public static final java.lang.String | DOCUMENT | "DocumentCenter"
public static final java.lang.String | ENGINEERING | "EngineeringAccess"
public static final java.lang.String | HUMANRESOURCE | "HumanResourceAccess"
public static final java.lang.String | LOG | "LogAccess"
public static final java.lang.String | MANAGEMENT | "ManagementAccess"
public static final java.lang.String | MANUFACTURING | "ManufacturingAccess"
public static final java.lang.String | PLANNING | "PlanningAccess"
public static final java.lang.String | PURCHASING | "PurchasingAccess"
public static final java.lang.String | QUALITY | "QualityAccess"
public static final java.lang.String | SALES | "SalesAccess"
public static final java.lang.String | SECURITY | "SecurityAccess"
public static final java.lang.String | WAREHOUSE | "WareHouseAccess"
public static final java.lang.String | WORKORDER | "WorkOrderAccess"

bb.common.Configure.UpdatePermission
public static final int | CAN | 1
public static final int | CAN_NOT | 0
public static final int | INVALID | -1

bb.common.Configure.UserLocked
public static final int | INVALID | -1
public static final int | LOCKED | 1
public static final int | UNLOCKED | 0

bb.common.Configure.UserType
public static final int | INVALID | -1
public static final int | TYPE_CUSTOMER | 1
public static final int | TYPE_EMPLOYEE | 0

bb.common.Constant
public static final java.lang.String | BASE_ROLE | "BASE_ROLE"
public static final int | BB2_ROUND_MODE | 4
public static final double | BB2_ZERO_double_VALUE | 0.01357
public static final java.lang.String | BOM_PARTS | "BOM_PARTS"
public static final java.lang.String | checkOrderExist | "1"
public static final java.lang.String | CHINESE_LOCALE | "zh_CN"
public static final byte | DEFAULT_DIGITS | 6
public static final java.lang.String | DefaultCompanyUnitID | "0"
public static final java.lang.String | DefaultCurrency | "RMB"
public static final java.lang.String | DefaultLanguage | "en_US"
public static final java.lang.String | DefaultMakeBuy | "X"
public static final java.lang.String | DefaultNaRecTo | "REFDOC"
public static final java.lang.String | DefaultPartFrom | "INVENTORY"
public static final java.lang.String | DefaultPartType | "P/A"
public static final java.lang.String | DefaultPartUnit | "EA"
public static final java.lang.String | DefaultReceivedTo | "WAREHOUSE"
public static final java.lang.String | DefaultRevision | "A"
public static final java.lang.String | DefaultStatus | "NOT APPROVED"
public static final java.lang.String | DefaultWorkInstructionSetID | "01"
public static final java.lang.String | EMPTY_LOCATION | "EMPTY_LOCATION"
public static final int | EXCHANGE_CALCULATIONAL_LENGHT | 40
public static final java.lang.String | GL_VOID | "-VOID"
public static final java.lang.String | JNDI_BB2_TOPIC | "bb2Topic"
public static final int | MaintenanceWarningHrs | 24
public static final long | MilliSecordsOfEachDay | 86400000L
public static final java.lang.String | NA | "NA"
public static final java.lang.String | NewPart | "ENGINEERING USE ONLY"
public static final int | pageCount | 25
public static final java.lang.String | PartNumberFormat | "[\\.A-Za-z0-9-/()]+"
public static final java.lang.String | RecoilLocationSpecial | "@_&RLS&_@"
public static final java.lang.String | RECURSIVE_BILL | "RECURSIVE_BILL"
public static final java.lang.String | SERIAL_NUMBER | "SERIAL NUMBER"
public static final int | WiSequence | 3

bb.common.Constant.ActiveStatus
public static final java.lang.String | no | "N"
public static final java.lang.String | yes | "Y"

bb.common.Constant.AddressType
public static final java.lang.String | CUSTOMER | "Customer"
public static final java.lang.String | VENDOR | "Vendor"

bb.common.Constant.AmountType
public static final java.lang.String | ACA | "ACA"
public static final java.lang.String | ADA | "ADA"
public static final java.lang.String | B | "B"
public static final java.lang.String | BB | "BB"
public static final java.lang.String | BCB | "BCB"
public static final java.lang.String | BDB | "BDB"
public static final java.lang.String | CA | "CA"
public static final java.lang.String | CB | "CB"
public static final java.lang.String | DA | "DA"
public static final java.lang.String | DB | "DB"
public static final java.lang.String | PLA | "PLA"
public static final java.lang.String | PLB | "PLB"

bb.common.Constant.ARDiscountMethod
public static final java.lang.String | GrossPrice | "GROSS PRICE"
public static final java.lang.String | NetPrice | "NET PRICE"

bb.common.Constant.CategoryReportType
public static final java.lang.String | BALANCE_SHEET | "BS"
public static final java.lang.String | BALANCE_SHEET_PRE | "BSPRE"
public static final java.lang.String | EBIDTA_DETAIL | "EBIDTA"
public static final java.lang.String | PROFIT_LOSS | "PL"
public static final java.lang.String | PROFIT_LOSS_PRE | "PLPRE"
public static final java.lang.String | TAX_DETAIL | "TAX"
public static final java.lang.String | TAX_DETAIL_PRE | "TAXPRE"

bb.common.Constant.CategoryType
public static final java.lang.String | CATEGORY_ASSETS | "A"
public static final java.lang.String | CATEGORY_EQUITY | "E"
public static final java.lang.String | CATEGORY_LIABILITIES | "L"

bb.common.Constant.ChartOfAccountSubType
public static final java.lang.String | BANK | "BANK"
public static final java.lang.String | CASH | "CASH"
public static final java.lang.String | OTHER | "OTHER"

bb.common.Constant.ChartOfAccountType
public static final java.lang.String | AC | "AC"
public static final java.lang.String | AD | "AD"
public static final java.lang.String | AF | "AF"
public static final java.lang.String | AL | "AL"
public static final java.lang.String | EG | "EG"
public static final java.lang.String | EL | "EL"
public static final java.lang.String | EN | "EN"
public static final java.lang.String | EO | "EO"
public static final java.lang.String | ET | "ET"
public static final java.lang.String | EW | "EW"
public static final java.lang.String | LC | "LC"
public static final java.lang.String | LL | "LL"
public static final java.lang.String | LO | "LO"
public static final java.lang.String | QN | "QN"
public static final java.lang.String | QR | "QR"
public static final java.lang.String | RN | "RN"
public static final java.lang.String | RO | "RO"

bb.common.Constant.CheckType
public static final java.lang.String | ALL | "ALL"
public static final java.lang.String | PAID | "PAID"
public static final java.lang.String | PAID_RECEIVED | "PAID_RECEIVED"
public static final java.lang.String | RECEIVED | "RECEIVED"

bb.common.Constant.CostControl
public static final java.lang.String | AVGCOST | "AVG COST"
public static final java.lang.String | STDCOST | "STD COST"

bb.common.Constant.CustomerVendorMailType
public static final java.lang.String | ACCOUNTING_MAIL | "ACCOUNTING_MAIL"
public static final java.lang.String | PO_MAIL | "PO_MAIL"
public static final java.lang.String | SO_MAIL | "SO_MAIL"

bb.common.Constant.CycleCountPeriodUnit
public static final java.lang.String | HALFYEAR | "HALFYEAR"
public static final java.lang.String | MONTH | "MONTH"
public static final java.lang.String | QUARTER | "QUARTER"
public static final java.lang.String | WEEK | "WEEK"
public static final java.lang.String | YEAR | "YEAR"

bb.common.Constant.DateType
public static final java.lang.String | ARRIVALDATE | "ARRIVAL DATE"
public static final java.lang.String | CFB_DATE | "CFB DATE"
public static final java.lang.String | CHECKRUNDATE | "CHECKRUNDATE"
public static final java.lang.String | CLOSEDDATE | "CLOSED DATE"
public static final java.lang.String | CMDATE | "CM DATE"
public static final java.lang.String | CREATE_DATE | "CREATE DATE"
public static final java.lang.String | DUEDATE | "DUEDATE"
public static final java.lang.String | INVOICEDATE | "INVOICEDATE"
public static final java.lang.String | ISSUEDATE | "ISSUEDATE"
public static final java.lang.String | LAST_DATE | "LAST DATE"
public static final java.lang.String | NCRDATE | "NCR DATE"
public static final java.lang.String | ORIGINALARRIVALDATE | "ORIGINAL ARRIVAL DATE"
public static final java.lang.String | ORIGINALSHIPDATE | "ORIGINAL SHIP DATE"
public static final java.lang.String | PAIDDATE | "DATEPAID"
public static final java.lang.String | PODATE | "PO DATE"
public static final java.lang.String | RECEIVEDDATE | "DATERECEIVED"
public static final java.lang.String | REQUESTDATE | "REQUESTDATE"
public static final java.lang.String | RFQDATE | "RFQ DATE"
public static final java.lang.String | SHIPDATE | "SHIP DATE"
public static final java.lang.String | SODATE | "SO DATE"
public static final java.lang.String | STARTDATE | "STARTDATE"
public static final java.lang.String | SWAPDATE | "SWAP DATE"
public static final java.lang.String | TRANSFERORDERDATE | "TRANSFER ORDER DATE"
public static final java.lang.String | WODATE | "WO DATE"

bb.common.Constant.Depreciation.DepreciateStatus
public static final java.lang.String | CLOSED_DEPRECIATE | "CLOSED_DEPRECIATE"
public static final java.lang.String | IN_DEPRECIATE | "IN_DEPRECIATE"
public static final java.lang.String | UNDEPRECIATE | "UNDEPRECIATE"

bb.common.Constant.Depreciation.DepreciationMethod
public static final java.lang.String | ACCELERATED_DEPRECIATIONMETHODS | "ACCELERATED_DEPRECIATIONMETHODS"
public static final java.lang.String | STRAIGHT_LINEMETHOD | "STRAIGHT_LINEMETHOD"
public static final java.lang.String | WORK_LOADMETHOD | "WORK_LOADMETHOD"

bb.common.Constant.Depreciation.UsingType
public static final java.lang.String | IN_USE | "IN_USE"
public static final java.lang.String | ON_HIRE | "ON_HIRE"
public static final java.lang.String | UNUSE | "UNUSE"

bb.common.Constant.Download
public static final java.lang.String | AthoerException | "Download file fail"
public static final java.lang.String | NoAuthorization | "Can not download file"
public static final java.lang.String | Succeed | "Download file succeed"

bb.common.Constant.DrawingType
public static final java.lang.String | Inventory | "INVENTORY"
public static final java.lang.String | ToolRoom | "TOOL ROOM"

bb.common.Constant.ECRPriority
public static final java.lang.String | ALL | "00"
public static final java.lang.String | FIRST | "1"
public static final java.lang.String | SECOND | "2"
public static final java.lang.String | THIRD | "3"

bb.common.Constant.EmployeeStatus
public static final java.lang.String | FULLTIME | "FULL TIME"
public static final java.lang.String | ONLEAVE | "ON LEAVE"
public static final java.lang.String | PARTTIME | "PART TIME"
public static final java.lang.String | TEMPORARYWORKER | "TEMPORARY WORKER"
public static final java.lang.String | TERMINATED | "TERMINATED"

bb.common.Constant.ExchangeRateType
public static final java.lang.String | DIRECTEXCHANGERATE | "DIRECTEXCHANGERATE"
public static final java.lang.String | INDIRECTEXCHANGERATE | "INDIRECTEXCHANGERATE"

bb.common.Constant.FileExt
public static final java.lang.String | PDF | "PDF"
public static final java.lang.String | ZIP | "ZIP"

bb.common.Constant.InventoryCostMothed
public static final java.lang.String | FIFO | "FIFO"
public static final java.lang.String | STANDARD | "STANDARD"
public static final java.lang.String | WAC | "WAC"

bb.common.Constant.InventoryWorkSheetOrderBy
public static final java.lang.String | LOCATION | "LOCATION"
public static final java.lang.String | PART_NO | "PART_NO"

bb.common.Constant.IssuedFrom
public static final java.lang.String | Other | "OTHER"
public static final java.lang.String | Quality | "QUALITY"
public static final java.lang.String | WareHouse | "WAREHOUSE"

bb.common.Constant.LanguageCode
public static final java.lang.String | CN | "zh_CN"
public static final java.lang.String | EN | "en_US"

bb.common.Constant.LocalSettings
public static final java.lang.String | CHINA | "CHINA"
public static final java.lang.String | CUSTOMIZATION | "CUSTOMIZATION"
public static final java.lang.String | USA | "USA"

bb.common.Constant.MakeBuy
public static final java.lang.String | Buy | "BUY"
public static final java.lang.String | Make | "MAKE"
public static final java.lang.String | X | "X"

bb.common.Constant.MiscDocType
public static final java.lang.String | ADDRESS_QA_DOC | "ADDRESS_QA_DOC"
public static final java.lang.String | BALANCE_SHEET | "BALANCE_SHEET"
public static final java.lang.String | BALANCE_SHEET_SIDE_BY_SIDE | "BALANCE_SHEET_SIDE_BY_SIDE"
public static final java.lang.String | CERTIFICATE_DOC | "CERTIFICATE_DOC"
public static final java.lang.String | CLOSING_STATEMENT | "CLOSING_STATEMENT"
public static final java.lang.String | CS_ITEM_DOC | "CS_ITEM_DOC"
public static final java.lang.String | CUSTOMER_DOC | "CUSTOMER_DOC"
public static final java.lang.String | DWO_DOC | "DWO_DOC"
public static final java.lang.String | ECN_DOC | "ECN_DOC"
public static final java.lang.String | ECR_DOC | "ECR_DOC"
public static final java.lang.String | EDC_DOC | "EDC_DOC"
public static final java.lang.String | EMP_RECORDS_DOC | "EMP_RECORDS_DOC"
public static final java.lang.String | IR_DOC | "IR_DOC"
public static final java.lang.String | NCR_FILE | "NCR_FILE"
public static final java.lang.String | ONLOAN_DOC | "ONLOAN_DOC"
public static final java.lang.String | PAR_ITEM_DOC | "PAR_ITEM_DOC"
public static final java.lang.String | PART_PICTURE | "PART_PICTURE"
public static final java.lang.String | PO_DOC | "PO_DOC"
public static final java.lang.String | PROFIT_LOSS | "PROFIT_LOSS"
public static final java.lang.String | QT_DOC | "QT_DOC"
public static final java.lang.String | RMA_DOC | "RMA_DOC"
public static final java.lang.String | SO_DOC | "SO_DOC"
public static final java.lang.String | VENDOR_DOC | "VENDOR_DOC"
public static final java.lang.String | WI_DOC | "WI_DOC"
public static final java.lang.String | WI_PICTURE | "WI_PICTURE"
public static final java.lang.String | WO_DOC | "WO_DOC"

bb.common.Constant.NaRecTo
public static final java.lang.String | AP | "AP"
public static final java.lang.String | FREIGHT | "FREIGHT"
public static final java.lang.String | REFDOC | "REFDOC"

bb.common.Constant.NoticeAction
public static final java.lang.String | ADD | "ADD"
public static final java.lang.String | APPROVE | "APPROVE"
public static final java.lang.String | CLOSE | "CLOSE"
public static final java.lang.String | DELETE | "DELETE"
public static final java.lang.String | RECIEVE | "RECIEVE"
public static final java.lang.String | REVIEW | "REVIEW"
public static final java.lang.String | SHIP | "SHIP"
public static final java.lang.String | UPDATE | "UPDATE"

bb.common.Constant.NoticeType
public static final java.lang.String | ECN | "ECN"
public static final java.lang.String | NCR | "NCR"
public static final java.lang.String | PO | "PO"
public static final java.lang.String | SO | "SO"

bb.common.Constant.OrderType
public static final java.lang.String | ACCOUNTSPAYABLE | "AccountsPayable"
public static final java.lang.String | ACCOUNTSRECEIVABLE | "AccountsReceivable"
public static final java.lang.String | DISASSEMBLEWORKORDER | "DisassembleWorkOrder"
public static final java.lang.String | PURCHASEORDER | "PurchaseOrder"
public static final java.lang.String | QUOTE | "Quote"
public static final java.lang.String | RECEIVER | "Receiver"
public static final java.lang.String | SALESORDER | "SalesOrder"
public static final java.lang.String | WORKORDER | "WorkOrder"

bb.common.Constant.PageCycleCount
public static final java.lang.String | PERDAY | "PER DAY"
public static final java.lang.String | PERMONTH | "PER MONTH"
public static final java.lang.String | PERWEEK | "PER WEEK"
public static final java.lang.String | PERYEAR | "PER YEAR"

bb.common.Constant.PartFrom
public static final java.lang.String | Inventory | "INVENTORY"
public static final java.lang.String | ToolRoom | "TOOL ROOM"

bb.common.Constant.PartQtyType
public static final java.lang.String | MAXQTY | "MAXQTY"
public static final java.lang.String | MINQTY | "MINQTY"
public static final java.lang.String | ONDEMANDQTY | "ONDEMANDQTY"
public static final java.lang.String | ONORDERQTY | "ONORDERQTY"

bb.common.Constant.PeriodUnit
public static final java.lang.String | DAY | "DAY"
public static final java.lang.String | HALFYEAR | "HALFYEAR"
public static final java.lang.String | HOUR | "HOUR"
public static final java.lang.String | MINUTE | "MINUTE"
public static final java.lang.String | MONTH | "MONTH"
public static final java.lang.String | QUARTER | "QUARTER"
public static final java.lang.String | WEEK | "WEEK"
public static final java.lang.String | YEAR | "YEAR"

bb.common.Constant.Prefix
public static final java.lang.String | A | "A"
public static final java.lang.String | AP | "AP"
public static final java.lang.String | APP | "APP"
public static final java.lang.String | AR | "AR"
public static final java.lang.String | ARP | "ARP"
public static final java.lang.String | CM | "CM"
public static final java.lang.String | CP | "CP"
public static final java.lang.String | CRFQ | "CRFQ"
public static final java.lang.String | DM | "DM"
public static final java.lang.String | DW | "DW"
public static final java.lang.String | E | "E"
public static final java.lang.String | GL | "GL"
public static final java.lang.String | I | "I"
public static final java.lang.String | IR | "IR"
public static final java.lang.String | LNR | "LNR"
public static final java.lang.String | LNSH | "LNSH"
public static final java.lang.String | MP | "MP"
public static final java.lang.String | N | "N"
public static final java.lang.String | NCR | "NCR"
public static final java.lang.String | OI | "OI"
public static final java.lang.String | P | "P"
public static final java.lang.String | PA | "PA"
public static final java.lang.String | PF | "PF"
public static final java.lang.String | PO | "PO"
public static final java.lang.String | PR | "PR"
public static final java.lang.String | R | "R"
public static final java.lang.String | RMA | "RMA"
public static final java.lang.String | RMAR | "RMAR"
public static final java.lang.String | RRMA | "RRMA"
public static final java.lang.String | RT | "RT"
public static final java.lang.String | RTV | "RTV"
public static final java.lang.String | RTVSH | "RTVSH"
public static final java.lang.String | S | "S"
public static final java.lang.String | SH | "SH"
public static final java.lang.String | SO | "SO"
public static final java.lang.String | SW | "SW"
public static final java.lang.String | SWR | "SWR"
public static final java.lang.String | SWS | "SWS"
public static final java.lang.String | T | "T"
public static final java.lang.String | TR | "TR"
public static final java.lang.String | TSH | "TSH"
public static final java.lang.String | VCP | "VCP"
public static final java.lang.String | W | "W"
public static final java.lang.String | WO | "WO"

bb.common.Constant.ReceivedTo
public static final java.lang.String | NCR | "NCR"
public static final java.lang.String | Quality | "QUALITY"
public static final java.lang.String | SalesOrder | "SALESORDER"
public static final java.lang.String | WareHouse | "WAREHOUSE"
public static final java.lang.String | WorkOrder | "WORKORDER"

bb.common.Constant.Status
public static final java.lang.String | Accepted | "ACCEPTED"
public static final java.lang.String | Acknowledged | "Acknowledged"
public static final java.lang.String | ALL | "ALL"
public static final java.lang.String | Approved | "APPROVED"
public static final java.lang.String | CANCELLED | "CANCELLED"
public static final java.lang.String | CLEARED | "CLEARED"
public static final java.lang.String | Closed | "CLOSED"
public static final java.lang.String | COMMITTED | "COMMITTED"
public static final java.lang.String | DoNotUse | "DO NOT USE"
public static final java.lang.String | Error | "ERROR"
public static final java.lang.String | FINISHED | "FINISHED"
public static final java.lang.String | FINISHINSPECTION | "FINISHINSPECTION"
public static final java.lang.String | Hold | "HOLD"
public static final java.lang.String | INPROGRESS | "IN PROGRESS"
public static final java.lang.String | Invoiced | "INVOICED"
public static final java.lang.String | New | "NEW"
public static final java.lang.String | NotAccepted | "NOT ACCEPTED"
public static final java.lang.String | NotAcknowledged | "Not Acknowledged"
public static final java.lang.String | NotApproved | "NOT APPROVED"
public static final java.lang.String | NOTCLEARED | "NOTCLEARED"
public static final java.lang.String | NotReviewed | "NOT REVIEWED"
public static final java.lang.String | NotSetUp | "NOT SETUP"
public static final java.lang.String | NotWriteOffed | "NOTWRITEOFFED"
public static final java.lang.String | OBSOLETE | "OBSOLETE"
public static final java.lang.String | Ok | "OK"
public static final java.lang.String | Open | "OPEN"
public static final java.lang.String | OPEN_OR_RECEIVED | "OPEN or RECEIVED"
public static final java.lang.String | Partial | "PARTIAL"
public static final java.lang.String | PAUSE | "PAUSE"
public static final java.lang.String | Pending | "PENDING"
public static final java.lang.String | PermanentClosed | "PERMANENT CLOSED"
public static final java.lang.String | Prepayed | "PREPAYED"
public static final java.lang.String | Received | "RECEIVED"
public static final java.lang.String | Refused | "REFUSED"
public static final java.lang.String | Reject | "REJECT"
public static final java.lang.String | REQUESTINSPECTION | "REQUESTINSPECTION"
public static final java.lang.String | Reviewed | "REVIEWED"
public static final java.lang.String | Run | "RUN"
public static final java.lang.String | RUNNING | "RUNNING"
public static final java.lang.String | SCRAPPED | "SCRAPPED"
public static final java.lang.String | SetUp | "SETUP"
public static final java.lang.String | Shipped | "SHIPPED"
public static final java.lang.String | Unbilled | "UNBILLED"
public static final java.lang.String | UnUsual | "UNUSUAL"
public static final java.lang.String | VendorApproved | "VENDOR APPROVED"
public static final java.lang.String | VOID | "VOID"
public static final java.lang.String | Waiting | "WAITING"
public static final java.lang.String | WriteOffed | "WRITEOFFED"

bb.common.Constant.TaxType
public static final java.lang.String | PURCHASETAXRATE | "PURCHASE_TAXRATE"
public static final java.lang.String | SALESTAXRATE | "SALES_TAXRATE"

bb.common.Constant.TermsConditonType
public static final java.lang.String | AR | "AR"
public static final java.lang.String | PO | "PO"
public static final java.lang.String | QUOTE | "QT"
public static final java.lang.String | SO | "SO"

bb.common.Constant.TransactionType
public static final java.lang.String | A | "A"
public static final java.lang.String | E | "E"
public static final java.lang.String | F | "F"
public static final java.lang.String | I | "I"
public static final java.lang.String | J | "J"
public static final java.lang.String | M | "M"
public static final java.lang.String | O | "O"
public static final java.lang.String | R | "R"

bb.common.Constant.Upload
public static final java.lang.String | AthoerException | "Upload file fail"
public static final java.lang.String | NoAuthorization | "Can not upload file"
public static final java.lang.String | Succeed | "Upload file succeed"

bb.common.Constant.VendorQualityStatus
public static final java.lang.String | LOCKED | "LOCKED"
public static final java.lang.String | Q_CODE_ONLY | "Q_CODE_ONLY"

bb.common.Constant.WorkCenterType
public static final java.lang.String | LABOR | "Labor"
public static final java.lang.String | MACHINE | "Machine"
public static final java.lang.String | OUTSOURCING | "Outsourcing"

bb.common.Constant.YesNO
public static final java.lang.String | N | "N"
public static final java.lang.String | NO | "NO"
public static final java.lang.String | NONE | ""
public static final java.lang.String | Y | "Y"
public static final java.lang.String | YES | "YES"

bb.common.ContractPriceCustomerVO
public static final java.lang.String | ORDER_BY_CONTRACTNAME | "contractName"
public static final java.lang.String | ORDER_BY_PK | "pk.contractNumber"

bb.common.ContractPriceItemVO
public static final java.lang.String | ORDER_BY_COMMENTS | "comments"
public static final java.lang.String | ORDER_BY_CONTRACTNAME | "contractName"
public static final java.lang.String | ORDER_BY_DISCOUNT | "discount"
public static final java.lang.String | ORDER_BY_LISTPRICE | "listPrice"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "pk.partNumber"
public static final java.lang.String | ORDER_BY_PK | "pk.contractNumber"

bb.common.ContractPriceVO
public static final java.lang.String | ORDER_BY_CONTRACTNUMBER | "contractNumber"
public static final java.lang.String | ORDER_BY_CURRENCY | "currency"
public static final java.lang.String | ORDER_BY_EXPIREDATE | "expireDate"
public static final java.lang.String | ORDER_BY_LASTCHANGEDATE | "lastChangeDate"
public static final java.lang.String | ORDER_BY_LASTCHANGEUSER | "lastChangeUser"
public static final java.lang.String | ORDER_BY_STARTDATE | "startDate"
public static final java.lang.String | ORDER_BY_STATUS | "status"

bb.common.CorrectiveActionRequestVO
public static final java.lang.String | ORDER_BY_CARNUMBER | "carNumber"
public static final java.lang.String | ORDER_BY_DATEENTERED | "dateEntered"
public static final java.lang.String | ORDER_BY_DEPARTMENTID | "departmentId"
public static final java.lang.String | ORDER_BY_DEPARTNAME | "departName"
public static final java.lang.String | ORDER_BY_DUEDATE | "dueDate"
public static final java.lang.String | ORDER_BY_LASTCHANGEDATE | "lastChangeDate"
public static final java.lang.String | ORDER_BY_LASTCHANGEUSER | "lastChangeUser"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "partNumber"
public static final java.lang.String | ORDER_BY_STATUS | "status"

bb.common.CRTVItemListResult
public static final java.lang.String ORDER_BY_CRTVNUMBER "crtvi.pk.crtvNumber"

bb.common.CRTVListResult
public static final java.lang.String | ORDER_BY_CHANGEORDER | "crtv.changeOrder"
public static final java.lang.String | ORDER_BY_COMMENTS | "crtv.comments"
public static final java.lang.String | ORDER_BY_CRTVDATE | "crtv.crtvDate"
public static final java.lang.String | ORDER_BY_CRTVNUMBER | "crtv.crtvNumber"
public static final java.lang.String | ORDER_BY_CUSTOMERID | "crtv.customerId"
public static final java.lang.String | ORDER_BY_INVOICENUMBER | "crtv.invoiceNumber"
public static final java.lang.String | ORDER_BY_PROJECTNAME | "crtv.projectName"
public static final java.lang.String | ORDER_BY_SALESMAN | "crtv.salesman"
public static final java.lang.String | ORDER_BY_SALESORDERNUMBER | "crtv.salesOrderNumber"

bb.common.CurrencyExchangeVO
public static final java.lang.String | ORDER_BY_EXCHANGE | "cu.exchange"
public static final java.lang.String | ORDER_BY_PK | "cu.pk.currency,cu.pk.monthYear"

bb.common.CurrencyVO
public static final java.lang.String ORDER_BY_CURRENCY "cu.currency"

bb.common.CustomAssetVO
public static final java.lang.String | ORDER_BY_ASSETNAME | "asset.assetName"
public static final java.lang.String | ORDER_BY_ASSETNUMBER | "asset.assetNumber"
public static final java.lang.String | ORDER_BY_ASSETORDER | "asset.assetOrder"
public static final java.lang.String | ORDER_BY_BUYDATE | "asset.buyDate"
public static final java.lang.String | ORDER_BY_COMMENTS | "asset.comments"
public static final java.lang.String | ORDER_BY_DEPARTMENT | "records.receiveDepartment"
public static final java.lang.String | ORDER_BY_MANUFACTURE | "asset.manufacture"
public static final java.lang.String | ORDER_BY_MANUFACTUREID | "asset.manufactureId"
public static final java.lang.String | ORDER_BY_MFGDATE | "asset.mfgDate"
public static final java.lang.String | ORDER_BY_MODELNUMBER | "asset.modelNumber"
public static final java.lang.String | ORDER_BY_ORIGINALCOST | "asset.originalCost"
public static final java.lang.String | ORDER_BY_PRINCIPAL | "asset.principal"
public static final java.lang.String | ORDER_BY_RECEIVESIGN | "records.receiveSign"
public static final java.lang.String | ORDER_BY_SERIALNUMBER | "asset.serialNumber"
public static final java.lang.String | ORDER_BY_USINGDATE | "asset.usingDate"

bb.common.CustomCheckUpEmployeeVO
public static final java.lang.String | ORDER_BY_AGE | "check.age"
public static final java.lang.String | ORDER_BY_BLOODPRESSURE | "check.bloodPressure"
public static final java.lang.String | ORDER_BY_BULTRASONIC | "check.bUltrasonic"
public static final java.lang.String | ORDER_BY_CHECKTIME | "check.checkTime"
public static final java.lang.String | ORDER_BY_CLINICALAB | "check.clinicaLab"
public static final java.lang.String | ORDER_BY_COMMENT | "check.comment"
public static final java.lang.String | ORDER_BY_EARNOSETEAR | "check.earNoseTear"
public static final java.lang.String | ORDER_BY_ECG | "check.ecg"
public static final java.lang.String | ORDER_BY_EMPID | "check.empId"
public static final java.lang.String | ORDER_BY_II | "check.ii"
public static final java.lang.String | ORDER_BY_NAME | "check.name"
public static final java.lang.String | ORDER_BY_NUDESIGHRIGHT | "check.nudeSighRight"
public static final java.lang.String | ORDER_BY_NUDESIGHTLEFT | "check.nudeSightLeft"
public static final java.lang.String | ORDER_BY_RECORDER | "check.recorder"
public static final java.lang.String | ORDER_BY_RECTIFYSIGHTLEFT | "check.rectifySightLeft"
public static final java.lang.String | ORDER_BY_RECTIFYSIGHTRIGHT | "check.rectifySightRight"
public static final java.lang.String | ORDER_BY_RIS | "check.ris"
public static final java.lang.String | ORDER_BY_STATURE | "check.stature"

bb.common.CustomDepartmentVO
public static final java.lang.String | ORDER_BY_DESCRIPTION | "description"
public static final java.lang.String | ORDER_BY_ID | "id"
public static final java.lang.String | ORDER_BY_NAME | "name"

bb.common.CustomEmployeeTrainVO
public static final java.lang.String | ORDER_BY_CERTIFICATENAME | "train.certificateName"
public static final java.lang.String | ORDER_BY_CERTIFICATIONID | "train.certificationId"
public static final java.lang.String | ORDER_BY_EXPIREDATE | "train.expireDate"
public static final java.lang.String | ORDER_BY_PK | "train.pk"
public static final java.lang.String | ORDER_BY_PLACE | "train.place"
public static final java.lang.String | ORDER_BY_RECORDER | "train.recorder"
public static final java.lang.String | ORDER_BY_RESULT | "result"
public static final java.lang.String | ORDER_BY_SPEAKER | "train.speaker"
public static final java.lang.String | ORDER_BY_TITLE | "train.title"
public static final java.lang.String | ORDER_BY_TRAINDATE | "train.trainDate"

bb.common.CustomEmployeeVO
public static final java.lang.String | ORDER_BY_BIRTHDATE | "birthDate"
public static final java.lang.String | ORDER_BY_CARDID | "cardId"
public static final java.lang.String | ORDER_BY_COMMENTS | "comments"
public static final java.lang.String | ORDER_BY_CURRENTPOSITION | "currentPosition"
public static final java.lang.String | ORDER_BY_CURRENTPOSITIONLEVEL | "currentPositionLevel"
public static final java.lang.String | ORDER_BY_DEGREE | "degree"
public static final java.lang.String | ORDER_BY_DEPARTMENT | "department"
public static final java.lang.String | ORDER_BY_EDUCATION | "education"
public static final java.lang.String | ORDER_BY_EMPLOYEEAGE | "birthDate"
public static final java.lang.String | ORDER_BY_EMPLOYEEAGELEVEL | "birthDate"
public static final java.lang.String | ORDER_BY_EMPLOYEEWORKAGE | "workTime"
public static final java.lang.String | ORDER_BY_EMPLOYEEWORKAGELEVEL | "workTime"
public static final java.lang.String | ORDER_BY_GENDER | "gender"
public static final java.lang.String | ORDER_BY_GRADUATEDATE | "graduateDate"
public static final java.lang.String | ORDER_BY_GRADUATESCHOOL | "graduateSchool"
public static final java.lang.String | ORDER_BY_JOBID | "jobId"
public static final java.lang.String | ORDER_BY_NAME | "name"
public static final java.lang.String | ORDER_BY_NATIVEPLACE | "nativePlace"
public static final java.lang.String | ORDER_BY_ORIGINALPOSITION | "originalPosition"
public static final java.lang.String | ORDER_BY_POLITYVISAGE | "polityVisage"
public static final java.lang.String | ORDER_BY_POSITION | "position"
public static final java.lang.String | ORDER_BY_SOURCE | "source"
public static final java.lang.String | ORDER_BY_SPECIALTITLE | "specialTitle"
public static final java.lang.String | ORDER_BY_SPECIALTY | "specialty"
public static final java.lang.String | ORDER_BY_SPECIALWORK | "specialWork"
public static final java.lang.String | ORDER_BY_TOCOMPANYTIME | "toCompanyTime"
public static final java.lang.String | ORDER_BY_TOPOSITIONTIME | "toPositionTime"
public static final java.lang.String | ORDER_BY_TRANSFERDATE | "transferDate"
public static final java.lang.String | ORDER_BY_UNIT | "unit"
public static final java.lang.String | ORDER_BY_WORKTIME | "workTime"
public static final java.lang.String | ORDER_BY_WORKTYPE | "workType"
public static final java.lang.String | ORDER_BY_WORKTYPEAFTER | "workTypeAfter"

bb.common.CustomerFeedbackVO
public static final java.lang.String | ORDER_BY_CONTACTDATE | "contactDate"
public static final java.lang.String | ORDER_BY_CUSTOMERID | "customerId"
public static final java.lang.String | ORDER_BY_CUSTOMERSERVICEINCIDENTNUMBER | "customerServiceIncidentNumber"
public static final java.lang.String | ORDER_BY_EMAIL | "email"
public static final java.lang.String | ORDER_BY_FEEDBACKNUMBER | "feedbackNumber"
public static final java.lang.String | ORDER_BY_INVOICEDATE | "invoiceDate"
public static final java.lang.String | ORDER_BY_ORIGINALINVOICENUMBER | "originalInvoiceNumber"
public static final java.lang.String | ORDER_BY_ORIGINALSALESORDERNUMBER | "originalSalesOrderNumber"
public static final java.lang.String | ORDER_BY_ORIGINALWORKORDERNUMBER | "originalWorkOrderNumber"
public static final java.lang.String | ORDER_BY_PURCHASEORDERNUMBER | "purchaseOrderNumber"
public static final java.lang.String | ORDER_BY_REPORTEDBY | "reportedBy"
public static final java.lang.String | ORDER_BY_SHIPTOID | "shipToId"
public static final java.lang.String | ORDER_BY_STATUS | "status"

bb.common.CustomerServiceIncidentItemListResult
public static final java.lang.String | ORDER_BY_CLOSEDDATE | "closedDate"
public static final java.lang.String | ORDER_BY_CSINUMBER | "incidentNumber"
public static final java.lang.String | ORDER_BY_CUSTOMERID | "customerId"
public static final java.lang.String | ORDER_BY_DUEDATE | "dueDate"
public static final java.lang.String | ORDER_BY_OPENDATE | "openDate"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "partNumber"
public static final java.lang.String | ORDER_BY_SALESORDERNUMBER | "originalSalesOrderNumber"
public static final java.lang.String | ORDER_BY_SHIPPERNUMBER | "originalShipperNumber"
public static final java.lang.String | ORDER_BY_WORKORDERNUMBER | "originalWorkOrderNumber"

bb.common.CustomerServiceIncidentListResult
public static final java.lang.String | ORDER_BY_CSINUMBER | "incidentNumber"
public static final java.lang.String | ORDER_BY_CUSTOMERID | "customerId"
public static final java.lang.String | ORDER_BY_DUEDATE | "dueDate"
public static final java.lang.String | ORDER_BY_OPENDATE | "openDate"
public static final java.lang.String | ORDER_BY_PARTFROM | "partFrom"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "partNumber"
public static final java.lang.String | ORDER_BY_PARTTYPE | "partType"

bb.common.CustomerStatementListResult
public static final java.lang.String | ORDER_BY_AMOUNTPAID | "arPaidInvoice"
public static final java.lang.String | ORDER_BY_BALANCEDUE | "amountDue"
public static final java.lang.String | ORDER_BY_CUSTOMERPO | "customerPoNumber"
public static final java.lang.String | ORDER_BY_DATE | "paydate"
public static final java.lang.String | ORDER_BY_DATEINVOICED | "dateInvoiced"
public static final java.lang.String | ORDER_BY_INVOICENUMBER | "invoiceNumber"
public static final java.lang.String | ORDER_BY_TOTALDUE | "grandTotal"

bb.common.CustomerStatementTotalResult
public static final java.lang.String | ORDER_BY_CURRENCY | "currency"
public static final java.lang.String | ORDER_BY_CURRENT | "current"
public static final java.lang.String | ORDER_BY_CUSTOMERID | "customerId"
public static final java.lang.String | ORDER_BY_CUSTOMERNAME | "customerName"
public static final java.lang.String | ORDER_BY_DUE1TO30TOTAL | "due1To30Total"
public static final java.lang.String | ORDER_BY_DUE31TO60TOTAL | "due31To60Total"
public static final java.lang.String | ORDER_BY_DUE61TO90TOTAL | "due61To90Total"
public static final java.lang.String | ORDER_BY_DUE91TOTAL | "due91Total"
public static final java.lang.String | ORDER_BY_TERMS | "ab.terms"
public static final java.lang.String | ORDER_BY_TOTALBALANCE | "totalBalance"

bb.common.CustomerVendorAddressInfoVO
public static final java.lang.String | ORDER_BY_ADDRESS | "addr.address"
public static final java.lang.String | ORDER_BY_ADDRESS2 | "addr.address2"
public static final java.lang.String | ORDER_BY_CITY | "addr.city"
public static final java.lang.String | ORDER_BY_COUNTRY | "addr.country"
public static final java.lang.String | ORDER_BY_CREATEDATE | "addr.createDate"
public static final java.lang.String | ORDER_BY_CRITICALLEVEL | "addr.criticalLevel"
public static final java.lang.String | ORDER_BY_CUSTOMERFLAG | "addr.customerFlag"
public static final java.lang.String | ORDER_BY_CUSTOMERHOLD | "addr.customerHold"
public static final java.lang.String | ORDER_BY_FAX | "addr.fax"
public static final java.lang.String | ORDER_BY_ID | "addr.id"
public static final java.lang.String | ORDER_BY_LASTCHANGEDATE | "addr.lastChangeDate"
public static final java.lang.String | ORDER_BY_NAME | "addr.name"
public static final java.lang.String | ORDER_BY_PHONE | "addr.phone"
public static final java.lang.String | ORDER_BY_QUALITYSTATUS | "addr.qualityStatus"
public static final java.lang.String | ORDER_BY_REGION | "addr.region"
public static final java.lang.String | ORDER_BY_STATE | "addr.state"
public static final java.lang.String | ORDER_BY_VALIDDATE | "addr.validDate"
public static final java.lang.String | ORDER_BY_VENDORCATEGORY | "addr.vendorCategory"
public static final java.lang.String | ORDER_BY_VENDORFLAG | "addr.vendorFlag"
public static final java.lang.String | ORDER_BY_ZIP | "addr.zip"

bb.common.CustomGoodsBreedVO
public static final java.lang.String | ORDER_BY_ACTIVE | "active"
public static final java.lang.String | ORDER_BY_COMMENTS | "comments"
public static final java.lang.String | ORDER_BY_ID | "id"
public static final java.lang.String | ORDER_BY_NAME | "name"
public static final java.lang.String | ORDER_BY_UNIT | "unit"

bb.common.CustomGoodsRecordVO
public static final java.lang.String | ORDER_BY_EMPLOYEEID | "csgoods_record.employeeId"
public static final java.lang.String | ORDER_BY_GOODSID | "csgoods_record.goodsId"

bb.common.CustomJobCategoryVO
public static final java.lang.String | ORDER_BY_COMMENTS | "comments"
public static final java.lang.String | ORDER_BY_ID | "id"
public static final java.lang.String | ORDER_BY_NAME | "name"

bb.common.CycleCountListResult
public static final java.lang.String | ORDER_BY_AVGCOST | "pt.averageCost"
public static final java.lang.String | ORDER_BY_COMMITTED | "pi.committed"
public static final java.lang.String | ORDER_BY_COUNTEDBY | "pi.countedBy"
public static final java.lang.String | ORDER_BY_COUNTEDDATE | "pi.countedDate"
public static final java.lang.String | ORDER_BY_DIFFCOUNT | "pi.diffCount"
public static final java.lang.String | ORDER_BY_LOCATION | "pi.locate"
public static final java.lang.String | ORDER_BY_NEWONHAND | "pi.newOnhand"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "pi.partNumber"
public static final java.lang.String | ORDER_BY_PK | "pi.pk.workSheetNumber"
public static final java.lang.String | ORDER_BY_STARTDATE | "pi.physicalInventoryDate"
public static final java.lang.String | ORDER_BY_SYSTEMONHAND | "pi.onhand"

bb.common.DepartmentLocationForBackflushVO
public static final java.lang.String | ORDER_BY_ID | "id"
public static final java.lang.String | ORDER_BY_LOCATION | "location"

bb.common.DepreciateMonthlyReport
public static final java.lang.String | ORDER_BY_ACQUISITIONCOST | "acquisitionCost"
public static final java.lang.String | ORDER_BY_ASSETTYPE | "assetType"
public static final java.lang.String | ORDER_BY_CURRENTMONTHDEPRECIATE | "currentMonthDepreciate"
public static final java.lang.String | ORDER_BY_DEPARTMENTID | "departmentID"
public static final java.lang.String | ORDER_BY_DEPRECIATESTATUS | "depreciateStatus"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "description"
public static final java.lang.String | ORDER_BY_LASTMONTHDEPRECIATE | "lastMonthDepreciate"
public static final java.lang.String | ORDER_BY_PK | "pk.assetNumber,pk.month"
public static final java.lang.String | ORDER_BY_QUANTITY | "quantity"
public static final java.lang.String | ORDER_BY_USINGSTATUS | "usingStatus"

bb.common.DesignControlListResult
public static final java.lang.String | ORDER_BY_DCNUMBER | "dc.designControlNumber"
public static final java.lang.String | ORDER_BY_DUEDATE | "dc.dueDate"
public static final java.lang.String | ORDER_BY_OPENDATE | "dc.openDate"
public static final java.lang.String | ORDER_BY_PARTDESCRIPTION | "ps.description"
public static final java.lang.String | ORDER_BY_PARTPK | "ps.pk.partNumber"
public static final java.lang.String | ORDER_BY_PROJECTDESCRIPTION | "dc.projectDescription"
public static final java.lang.String | ORDER_BY_PROJECTENGINEER | "dc.projectEngineer"
public static final java.lang.String | ORDER_BY_STATUS | "dc.status"

bb.common.DisassembleWorkOrderItemListResult
public static final java.lang.String | ORDER_BY_ACCOUNTNUMBER | "dwo.dacct1"
public static final java.lang.String | ORDER_BY_COMPANYUNITID | "dwo.co_unit_id"
public static final java.lang.String | ORDER_BY_COSTPERUNIT | "dwoi.cost"
public static final java.lang.String | ORDER_BY_CURRENCY | "dwo.currency"
public static final java.lang.String | ORDER_BY_DISASSEMBLEWORKORDERITEMNUMBER | "dwoi.dwo,dwoi.dwi"
public static final java.lang.String | ORDER_BY_DISASSEMBLEWORKORDERNUMBER | "dwoi.dwo,dwoi.dwi"
public static final java.lang.String | ORDER_BY_DUEDATE | "dwoi.delivery"
public static final java.lang.String | ORDER_BY_EXTENDPRICE | "dwoi.dwo_net"
public static final java.lang.String | ORDER_BY_MFGSTATUS | "dwoi.man_status"
public static final java.lang.String | ORDER_BY_ORDERRELATEDDOC | "dwo.reldoc"
public static final java.lang.String | ORDER_BY_ORIGINATOR | "dwo.originator"
public static final java.lang.String | ORDER_BY_PARTDESC | "description"
public static final java.lang.String | ORDER_BY_PARTPK | "dwoi.pn"
public static final java.lang.String | ORDER_BY_PRIORITY | "dwoi.priority"
public static final java.lang.String | ORDER_BY_PROJECT | "dwo.project"
public static final java.lang.String | ORDER_BY_QTY | "dwoi.qty"
public static final java.lang.String | ORDER_BY_QTY_SHIPPED | "dwoi.qty_ship"
public static final java.lang.String | ORDER_BY_RELATEDDOC | "dwoi.reldoc"
public static final java.lang.String | ORDER_BY_STARTDATE | "dwoi.start_date"
public static final java.lang.String | ORDER_BY_STATUS | "dwoi.status"
public static final java.lang.String | ORDER_BY_VENDORID | "dwo.id"

bb.common.DisassembleWorkOrderListResult
public static final java.lang.String | ORDER_BY_CHANGEORDER | "dwo.changeOrder"
public static final java.lang.String | ORDER_BY_DISASSEMBLEWORKORDERCOMMENTS | "dwo.disassembleWorkOrderComments"
public static final java.lang.String | ORDER_BY_DISASSEMBLEWORKORDERPRIVATENOTES | "dwo.disassembleWorkOrderPrivateNotes"
public static final java.lang.String | ORDER_BY_DWODATE | "dwo.original"
public static final java.lang.String | ORDER_BY_DWONUMBER | "dwo.disassembleWorkOrderNumber"
public static final java.lang.String | ORDER_BY_PROJECT | "dwo.project"
public static final java.lang.String | ORDER_BY_STATUS | "dwo.status"
public static final java.lang.String | ORDER_BY_VENDORID | "dwo.vendorId"
public static final java.lang.String | ORDER_BY_VENDORNAME | "ab.name"

bb.common.DocumentAction
public static final java.lang.String | DOWNLOAD_PDF | "DOWNLOAD_PDF"
public static final java.lang.String | DOWNLOAD_ZIP | "DOWNLOAD_ZIP"

bb.common.DocumentAction.DwfAndDwgDocAction
public static final java.lang.String | DELETE | "DELETE"
public static final java.lang.String | DOWNLOAD | "DOWNLOAD"
public static final java.lang.String | DOWNLOAD_DWG | "DOWNLOAD_DWG"
public static final java.lang.String | UPDATE | "UPDATE"
public static final java.lang.String | UPLOAD | "UPLOAD"

bb.common.DocumentAction.MiscDocAction
public static final java.lang.String | DELETE | "DELETE"
public static final java.lang.String | DOWNLOAD_ADDRESS_QA_DOC | "DOWNLOAD_ADDRESS_QA_DOC"
public static final java.lang.String | DOWNLOAD_BALANCE_SHEET_DOC | "DOWNLOAD_BALANCE_SHEET_DOC"
public static final java.lang.String | DOWNLOAD_BALANCE_SHEET_SIDE_BY_SIDE_DOC | "DOWNLOAD_BALANCE_SHEET_SIDE_BY_SIDE_DOC"
public static final java.lang.String | DOWNLOAD_CERTIFICATE_DOC | "DOWNLOAD_CERTIFICATE_DOC"
public static final java.lang.String | DOWNLOAD_CLOSING_STATEMENT_DOC | "DOWNLOAD_CLOSING_STATEMENT_DOC"
public static final java.lang.String | DOWNLOAD_CS_ITEM_DOC | "DOWNLOAD_CS_ITEM_DOC"
public static final java.lang.String | DOWNLOAD_DWO_DOC | "DOWNLOAD_DWO_DOC"
public static final java.lang.String | DOWNLOAD_ECN_DOC | "DOWNLOAD_ECN_DOC"
public static final java.lang.String | DOWNLOAD_ECR_DOC | "DOWNLOAD_ECR_DOC"
public static final java.lang.String | DOWNLOAD_EDC_DOC | "DOWNLOAD_EDC_DOC"
public static final java.lang.String | DOWNLOAD_EMPLOYEE_RECORDS | "DOWNLOAD_EMPLOYEE_RECORDS"
public static final java.lang.String | DOWNLOAD_NCR_FILE | "DOWNLOAD_NCR_FILE"
public static final java.lang.String | DOWNLOAD_ONLOAN_DOC | "DOWNLOAD_ONLOAN_DOC"
public static final java.lang.String | DOWNLOAD_PAR_ITEM_DOC | "DOWNLOAD_PAR_ITEM_DOC"
public static final java.lang.String | DOWNLOAD_PART_PICTURE | "DOWNLOAD_PART_PICTURE"
public static final java.lang.String | DOWNLOAD_PO_DOC | "DOWNLOAD_PO_DOC"
public static final java.lang.String | DOWNLOAD_PROFIT_LOSS_DOC | "DOWNLOAD_PROFIT_LOSS_DOC"
public static final java.lang.String | DOWNLOAD_QT_DOC | "DOWNLOAD_QT_DOC"
public static final java.lang.String | DOWNLOAD_RMA_DOC | "DOWNLOAD_RMA_DOC"
public static final java.lang.String | DOWNLOAD_SO_DOC | "DOWNLOAD_SO_DOC"
public static final java.lang.String | DOWNLOAD_WI_DOC | "DOWNLOAD_WI_DOC"
public static final java.lang.String | DOWNLOAD_WI_PICTURE | "DOWNLOAD_WI_PICTURE"
public static final java.lang.String | DOWNLOAD_WO_DOC | "DOWNLOAD_WO_DOC"
public static final java.lang.String | UPDATE | "UPDATE"
public static final java.lang.String | UPLOAD | "UPLOAD"

bb.common.DocumentAction.PartDocAction
public static final java.lang.String | DELETE | "DELETE"
public static final java.lang.String | DOWNLOAD | "DOWNLOAD"
public static final java.lang.String | DOWNLOAD_FILE | "DOWNLOAD_FILE"
public static final java.lang.String | UPLOAD | "UPLOAD"

bb.common.DocumentServerVO
public static final java.lang.String | ORDER_BY_DOCUMENTTYPE | "documentType"
public static final java.lang.String | ORDER_BY_FTPPATH | "ftpPath"
public static final java.lang.String | ORDER_BY_LOCALPATH | "localPath"
public static final java.lang.String | ORDER_BY_LOCK | "lock"
public static final java.lang.String | ORDER_BY_REMARKS | "remarks"
public static final java.lang.String | ORDER_BY_SERVERIP | "serverIp"
public static final java.lang.String | ORDER_BY_SERVERPORT | "serverPort"
public static final java.lang.String | ORDER_BY_USERNAME | "userName"

bb.common.DWOIssueDetail
public static final java.lang.String | ORDER_BY_ACCOUNTNUMBER | "dwo.debitAccount"
public static final java.lang.String | ORDER_BY_COMPANYUNITID | "issue.companyUnitId"
public static final java.lang.String | ORDER_BY_DISASSEMBLEWORKORDERITEMNUMBER | "issue.disassembleWorkOrderItemNumber"
public static final java.lang.String | ORDER_BY_DISASSEMBLEWORKORDERNUMBER | "issue.disassembleWorkOrderNumber"
public static final java.lang.String | ORDER_BY_LASTCHANGEUSER | "issue.lastChangeUser"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "issue.partNumber"
public static final java.lang.String | ORDER_BY_VENDORID | "dwo.vendorId"

bb.common.EcnPOOrderResult
public static final java.lang.String | ORDER_BY_DELIVERY | "poi.dateRequired"
public static final java.lang.String | ORDER_BY_POITEMPK | "poi.pk.purchaseOrderNumber,poi.pk.purchaseOrderItemNumber"
public static final java.lang.String | ORDER_BY_VENDORID | "po.vendorId"

bb.common.ECNReviewVO
public static final java.lang.String | ORDER_BY_COMMENTS | "comments"
public static final java.lang.String | ORDER_BY_EMPLOYEEID | "employeeId"
public static final java.lang.String | ORDER_BY_USERNAME | "userName"

bb.common.EcnWOOrderResult
public static final java.lang.String | ORDER_BY_DELIVERY | "woi.dateRequired"
public static final java.lang.String | ORDER_BY_POITEMPK | "woi.pk.workOrderNumber,woi.pk.workOrderItemNumber"
public static final java.lang.String | ORDER_BY_VENDORID | "wo.vendorId"

bb.common.ECRReviewVO
public static final java.lang.String | ORDER_BY_COMMENTS | "comments"
public static final java.lang.String | ORDER_BY_EMPLOYEEID | "employeeId"
public static final java.lang.String | ORDER_BY_USERNAME | "userName"

bb.common.EmployeeCardVO
public static final java.lang.String | ORDER_BY_COMPANYADDRESSBOOKNAME | "emp.companyAddressBookName"
public static final java.lang.String | ORDER_BY_DEPARTMENT | "emp.department"
public static final java.lang.String | ORDER_BY_EMAIL | "emp.email"
public static final java.lang.String | ORDER_BY_EXTENSION | "emp.extension"
public static final java.lang.String | ORDER_BY_FAX | "emp.fax"
public static final java.lang.String | ORDER_BY_FIRSTNAME | "emp.firstName"
public static final java.lang.String | ORDER_BY_HOMEPHONE | "emp.homePhone"
public static final java.lang.String | ORDER_BY_ID | "emp.id"
public static final java.lang.String | ORDER_BY_LASTNAME | "emp.lastName"
public static final java.lang.String | ORDER_BY_MOBILE | "emp.mobile"
public static final java.lang.String | ORDER_BY_PHONE | "emp.phone"
public static final java.lang.String | ORDER_BY_PICTURE | "emp.picture"
public static final java.lang.String | ORDER_BY_POSITION | "emp.position"
public static final java.lang.String | ORDER_BY_SECURITYLEVEL | "emp.securityLevel"
public static final java.lang.String | ORDER_BY_STARTDATE | "emp.startDate"
public static final java.lang.String | ORDER_BY_STATUS | "emp.status"
public static final java.lang.String | ORDER_BY_TERMINATEDDATE | "emp.terminatedDate"
public static final java.lang.String | ORDER_BY_USERNAME | "emp.userName"

bb.common.EmployeePutGoodListResult
public static final java.lang.String | ORDER_BY_EMPLOYEEID | "good.employeeId"
public static final java.lang.String | ORDER_BY_EMPLOYEENAME | "good.employeeName"
public static final java.lang.String | ORDER_BY_GOODSID | "good.goodsId"
public static final java.lang.String | ORDER_BY_GOODSNAME | "good.goodsName"
public static final java.lang.String | ORDER_BY_JOBID | "good.jobId"
public static final java.lang.String | ORDER_BY_JOBNAME | "good.jobName"
public static final java.lang.String | ORDER_BY_PUTDATE | "good.putDate"

bb.common.EmployeeRecordsVO
public static final java.lang.String | ORDER_BY_COMMENTS | "record.comments"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "record.description"
public static final java.lang.String | ORDER_BY_DOCNAME | "record.docName"
public static final java.lang.String | ORDER_BY_EMPLOYEEID | "record.employeeId"
public static final java.lang.String | ORDER_BY_II | "record.ii"

bb.common.EngGroupUserVO
public static final java.lang.String | ORDER_BY_COMMENTS | "comments"
public static final java.lang.String | ORDER_BY_PK | "pk.engGroupId,pk.empId"
public static final java.lang.String | ORDER_BY_USERNAME | "userName"

bb.common.EngGroupVO
public static final java.lang.String | ORDER_BY_ID | "id"
public static final java.lang.String | ORDER_BY_NAME | "name"
public static final java.lang.String | ORDER_BY_PARENTID | "parentId"

bb.common.EngineeringChangeListResult
public static final java.lang.String | ORDER_BY_DUEDATE | "ec.dueDate"
public static final java.lang.String | ORDER_BY_ECNDESCRIPTION | "ec.description"
public static final java.lang.String | ORDER_BY_ECNNUMBER | "ec.engineeringChangeNumber"
public static final java.lang.String | ORDER_BY_ENGINEERINGCHANGEDATE | "ec.engineeringChangeDate"
public static final java.lang.String | ORDER_BY_ORIGINATOR | "ec.originator"
public static final java.lang.String | ORDER_BY_PARTDESCRIPTION | "ps.description"
public static final java.lang.String | ORDER_BY_PARTPK | "ec.partNumber"
public static final java.lang.String | ORDER_BY_STATUS | "ec.status"

bb.common.EngineeringChangeRequestListResult
public static final java.lang.String | ORDER_BY_CLOSEOUTPRIVATENOTES | "ecr.closed_out_private_notes"
public static final java.lang.String | ORDER_BY_DISPOSITIONOFCHANGE | "ecr.disposition_of_change"
public static final java.lang.String | ORDER_BY_DUEDATE | "ecr.due_date"
public static final java.lang.String | ORDER_BY_ECRDESCRIPTION | "ecr.description"
public static final java.lang.String | ORDER_BY_ECRENGINEER | "ecr. ecr_engineer"
public static final java.lang.String | ORDER_BY_ECRNUMBER | "ecr.ecr"
public static final java.lang.String | ORDER_BY_ECRPRIORITY | "ecr.ecr_priority"
public static final java.lang.String | ORDER_BY_ORIGINATOR | "ecr.originator"
public static final java.lang.String | ORDER_BY_PARTDESCRIPTION | "ps.ed"
public static final java.lang.String | ORDER_BY_PARTPK | "ps.pn"
public static final java.lang.String | ORDER_BY_STATUS | "ecr.status"

bb.common.EngineeringSharingItemVO
public static final java.lang.String | ORDER_BY_EDITDATE | "esi.editDate"
public static final java.lang.String | ORDER_BY_OPTWHO | "esi.optWho"
public static final java.lang.String | ORDER_BY_PARTDESCRIPTION | "pd.description"
public static final java.lang.String | ORDER_BY_PK | "esi.pk.partNumber,esi.pk.partType"

bb.common.EquipmentListResult
public static final java.lang.String | ORDER_BY_ASSETNUM | "wc.assetNum"
public static final java.lang.String | ORDER_BY_DEPARTMENTID | "wc.departmentId"
public static final java.lang.String | ORDER_BY_EQUIPMENTID | "wc.equipmentId"
public static final java.lang.String | ORDER_BY_LASTMAINTENANCEDATE | "wc.lastMaintenanceDate"
public static final java.lang.String | ORDER_BY_MANUFACTURERID | "wc.manufacturerId"
public static final java.lang.String | ORDER_BY_NEXTSCHEDULEDMAINTENANCEDATE | "wc.nextScheduledMaintenanceDate"
public static final java.lang.String | ORDER_BY_TYPE | "wc.type"
public static final java.lang.String | ORDER_BY_WORKCENTERID | "wc.workCenterId"

bb.common.ExpenseListResult
public static final java.lang.String | ORDER_BY_DATEFROM | "exps.date1"
public static final java.lang.String | ORDER_BY_DATETO | "exps.date2"
public static final java.lang.String | ORDER_BY_EXPENSESTATEMENT | "exps.expenseStatement"
public static final java.lang.String | ORDER_BY_STATUS | "exps.status"
public static final java.lang.String | ORDER_BY_USERNAME | "exps.userName"

bb.common.FiscalYearSettingsVO
public static final java.lang.String | ORDER_BY_ENDDATE | "tt.endDate"
public static final java.lang.String | ORDER_BY_FY | "tt.fy"
public static final java.lang.String | ORDER_BY_STARTDATE | "tt.startDate"
public static final java.lang.String | ORDER_BY_STATUS | "tt.status"

bb.common.GeneralLedgerApprovalVO
public static final java.lang.String | ORDER_BY_APPROVELIMIT | "approveLimit"
public static final java.lang.String | ORDER_BY_COMMENTS | "comments"
public static final java.lang.String | ORDER_BY_EMPLOYEEID | "employeeId"
public static final java.lang.String | ORDER_BY_USERNAME | "userName"

bb.common.GeneralLedgerByDateListResult
public static final java.lang.String | ORDER_BY_ACCOUNTDESCTIPTION | "ga.description"
public static final java.lang.String | ORDER_BY_ACCOUNTNUMBER | "temp_gdc.accountNumber"
public static final java.lang.String | ORDER_BY_ACCOUNTTYPE | "gl.transactionType"
public static final java.lang.String | ORDER_BY_ADDRESSID | "gl.customerId"
public static final java.lang.String | ORDER_BY_ADDRESSNAME | "gl.name"
public static final java.lang.String | ORDER_BY_APNUMBER | "gl.accountsPayableNumber"
public static final java.lang.String | ORDER_BY_ARNUMBER | "gl.invoiceNumber"
public static final java.lang.String | ORDER_BY_BATCH | "gl.batch"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "gl.description"
public static final java.lang.String | ORDER_BY_GLNUMBER | "temp_gdc.transactionNumber"
public static final java.lang.String | ORDER_BY_PONUMBER | "gl.purchaseOrderNumber"
public static final java.lang.String | ORDER_BY_SONUMBER | "gl.salesOrderNumber"
public static final java.lang.String | ORDER_BY_TRANSACTIONDATE | "gl.transactionDate"
public static final java.lang.String | ORDER_BY_VENDORINVOICE | "gl.vendorInvoice"

bb.common.GeneralLedgerCategoryVO
public static final java.lang.String | ORDER_BY_CREDITACCOUNTS | "creditAccounts"
public static final java.lang.String | ORDER_BY_DEBITACCOUNTS | "debitAccounts"
public static final java.lang.String | ORDER_BY_GLTYPE | "glType"
public static final java.lang.String | ORDER_BY_ID | "id"
public static final java.lang.String | ORDER_BY_NAME | "name"

bb.common.GeneralLedgerListResult
public static final java.lang.String | ORDER_BY_ACCOUNTSPAYABLENUMBER | "gl.accountsPayableNumber"
public static final java.lang.String | ORDER_BY_CHECKNUMBER | "gl.checkNumber"
public static final java.lang.String | ORDER_BY_CUSTOMERID | "gl.customerId"
public static final java.lang.String | ORDER_BY_GLCATEGORY | "gl.glCategory,gl.categorySequence"
public static final java.lang.String | ORDER_BY_INVOICENUMBER | "gl.invoiceNumber"
public static final java.lang.String | ORDER_BY_PURCHASEORDERNUMBER | "gl.purchaseOrderNumber"
public static final java.lang.String | ORDER_BY_SALESORDERNUMBER | "gl.salesOrderNumber"
public static final java.lang.String | ORDER_BY_TRANSACTIONDATE | "gl.transactionDate"
public static final java.lang.String | ORDER_BY_TRANSACTIONNUMBER | "gl.transactionNumber"
public static final java.lang.String | ORDER_BY_TRANSACTIONTYPE | "gl.transactionType"
public static final java.lang.String | ORDER_BY_VENDORINVOICE | "gl.vendorInvoice"

bb.common.GeneralLedgerVO
public static final java.lang.String | ORDER_BY_ACCOUNTSPAYABLENUMBER | "gl.accountsPayableNumber"
public static final java.lang.String | ORDER_BY_CATEGORYSEQUENCE | "gl.categorySequence,gl.glCategory"
public static final java.lang.String | ORDER_BY_CUSTOMERID | "gl.customerId"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "gl.description"
public static final java.lang.String | ORDER_BY_GLCATEGORY | "gl.glCategory,gl.categorySequence"
public static final java.lang.String | ORDER_BY_INVOICENUMBER | "gl.invoiceNumber"
public static final java.lang.String | ORDER_BY_PURCHASEORDERNUMBER | "gl.purchaseOrderNumber"
public static final java.lang.String | ORDER_BY_SALESORDERNUMBER | "gl.salesOrderNumber"
public static final java.lang.String | ORDER_BY_TRANSACTIONDATE | "gl.transactionDate"
public static final java.lang.String | ORDER_BY_TRANSACTIONNUMBER | "gl.transactionNumber"
public static final java.lang.String | ORDER_BY_TRANSACTIONTYPE | "gl.transactionType"

bb.common.GLAutoApproveVO
public static final java.lang.String | ORDER_BY_APPROVEDBY | "approvedBy"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "description"
public static final java.lang.String | ORDER_BY_GLCAT | "glCat"
public static final java.lang.String | ORDER_BY_GLTYPE | "glType"
public static final java.lang.String | ORDER_BY_II | "ii"

bb.common.GLDebitCreditListResult
public static final java.lang.String | ORDER_BY_ACCOUNTNUMBER | "temp_gdc.accountNumber"
public static final java.lang.String | ORDER_BY_ACCOUNTSPAYABLENUMBER | "gl.accountsPayableNumber"
public static final java.lang.String | ORDER_BY_BATCH | "gl.batch"
public static final java.lang.String | ORDER_BY_CHECKNUMBER | "gl.checkNumber"
public static final java.lang.String | ORDER_BY_CREDIT | "temp_gdc.credit"
public static final java.lang.String | ORDER_BY_CUSTOMERID | "gl.customerId"
public static final java.lang.String | ORDER_BY_DEBIT | "temp_gdc.debit"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "gl.description"
public static final java.lang.String | ORDER_BY_GLCATEGORY | "gl.glCategory,gl.categorySequence"
public static final java.lang.String | ORDER_BY_INVOICENUMBER | "gl.invoiceNumber"
public static final java.lang.String | ORDER_BY_NAME | "gl.name"
public static final java.lang.String | ORDER_BY_PURCHASEORDERNUMBER | "gl.purchaseOrderNumber"
public static final java.lang.String | ORDER_BY_RELDOC | "gl.reldoc"
public static final java.lang.String | ORDER_BY_SALESORDERNUMBER | "gl.salesOrderNumber"
public static final java.lang.String | ORDER_BY_TRANSACTIONDATE | "gl.transactionDate"
public static final java.lang.String | ORDER_BY_TRANSACTIONNUMBER | "gl.transactionNumber"
public static final java.lang.String | ORDER_BY_TRANSACTIONTYPE | "gl.transactionType"
public static final java.lang.String | ORDER_BY_VENDORINVOICE | "gl.vendorInvoice"

bb.common.HelpServerVO
public static final java.lang.String | ORDER_BY_actived | "actived"
public static final java.lang.String | ORDER_BY_description | "description"
public static final java.lang.String | ORDER_BY_helpServerIP | "helpServerIP"
public static final java.lang.String | ORDER_BY_helpServerPort | "helpServerPort"
public static final java.lang.String | ORDER_BY_II | "ii"
public static final java.lang.String | ORDER_BY_language | "language"
public static final java.lang.String | ORDER_BY_spaceHomePage | "spaceHomePage"
public static final java.lang.String | ORDER_BY_wikiSpaceName | "wikiSpaceName"

bb.common.HighUsagePartResult
public static final java.lang.String | ORDER_BY_PART | "pn, pa"
public static final java.lang.String | ORDER_BY_QTR1QTY | "q1"
public static final java.lang.String | ORDER_BY_QTR2QTY | "q2"
public static final java.lang.String | ORDER_BY_QTR3QTY | "q3"
public static final java.lang.String | ORDER_BY_QTR4QTY | "q3"
public static final java.lang.String | ORDER_BY_YTRQTY | "qty"

bb.common.HistoricalInventoryVO
public static final java.lang.String | ORDER_BY_CONSIGNEDQTY | "consignedQty"
public static final java.lang.String | ORDER_BY_DATE | "date"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "description"
public static final java.lang.String | ORDER_BY_INQUALITYCHECKINGQTY | "inQualityCheckingQty"
public static final java.lang.String | ORDER_BY_INTO | "inTOQty"
public static final java.lang.String | ORDER_BY_ONDEMANDQTY | "onDemandQty"
public static final java.lang.String | ORDER_BY_ONHAND | "onhand"
public static final java.lang.String | ORDER_BY_ONLOANQTY | "onloanQty"
public static final java.lang.String | ORDER_BY_ONORDERQTY | "onOrderQty"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "partNumber,partType"
public static final java.lang.String | ORDER_BY_SHIPINPROCESSQTY | "shipInProcessQty"
public static final java.lang.String | ORDER_BY_WORKINPROCESSQTY | "workInProcessQty"

bb.common.IcrItemListResult
public static final java.lang.String | ORDER_BY_CLOSEOUTDATE | "icr.closedOutDate"
public static final java.lang.String | ORDER_BY_COMMENTS | "icri.comments"
public static final java.lang.String | ORDER_BY_DATECHECK | "icri.dateCheck"
public static final java.lang.String | ORDER_BY_ICRDATE | "icr.icrDate"
public static final java.lang.String | ORDER_BY_ICRITEMNUMBER | "icri.pk.icrItemNumber"
public static final java.lang.String | ORDER_BY_ICRNUMBER | "icr.icrNumber"
public static final java.lang.String | ORDER_BY_INSPECTOR | "icri.inspector"
public static final java.lang.String | ORDER_BY_PARTDESCRIPTION | "icri.partDescription"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "icri.partNumber,icri.partType"
public static final java.lang.String | ORDER_BY_PARTREVISION | "icri.partRevision"
public static final java.lang.String | ORDER_BY_PURCHASEORDER | "icr.purchaseOrder"
public static final java.lang.String | ORDER_BY_QTYCHECK | "icri.qtyCheck"
public static final java.lang.String | ORDER_BY_QTYQUALIFIED | "icri.qtyQualified"
public static final java.lang.String | ORDER_BY_STATUS | "icri.status"
public static final java.lang.String | ORDER_BY_VENDORID | "icr.vendorId"
public static final java.lang.String | ORDER_BY_VENDORNAME | "ab.name"
public static final java.lang.String | ORDER_BY_WORKORDER | "icr.workOrder"

bb.common.IcrListResult
public static final java.lang.String | ORDER_BY_CLOSEDOUTDATE | "icr.closedOutDate"
public static final java.lang.String | ORDER_BY_COMMENTS | "icr.comments"
public static final java.lang.String | ORDER_BY_ICRDATE | "icr.icrDate"
public static final java.lang.String | ORDER_BY_ICRNUMBER | "icr.icrNumber"
public static final java.lang.String | ORDER_BY_PURCHASEORDER | "icr.purchaseOrder"
public static final java.lang.String | ORDER_BY_STATUS | "icr.status"
public static final java.lang.String | ORDER_BY_VENDORID | "icr.vendorId"
public static final java.lang.String | ORDER_BY_VENDORNAME | "ab.name"
public static final java.lang.String | ORDER_BY_WORKORDER | "icr.workOrder"

bb.common.ImportDataVO
public static final java.lang.String ORDER_BY_COLUMN_NUMBER ""

bb.common.IncotermVO
public static final java.lang.String | ORDER_BY_DESCRIPTION | "description"
public static final java.lang.String | ORDER_BY_ID | "id"
public static final java.lang.String | ORDER_BY_PLACE | "place"

bb.common.InspectionConformanceReportVO
public static final java.lang.String | ORDER_BY_ADATE | "icr.adate"
public static final java.lang.String | ORDER_BY_CLOSEDOUTDATE | "icr.closedOutDate"
public static final java.lang.String | ORDER_BY_COMMENTS | "icr.comments"
public static final java.lang.String | ORDER_BY_ICRNUMBER | "icr.icrNumber"
public static final java.lang.String | ORDER_BY_LASTCHANGEDATE | "icr.lastChangeDate"
public static final java.lang.String | ORDER_BY_LASTCHANGEUSER | "icr.lastChangeUser"
public static final java.lang.String | ORDER_BY_ORIGIN | "icr.origin"
public static final java.lang.String | ORDER_BY_PURCHASEORDER | "icr.purchaseOrder"
public static final java.lang.String | ORDER_BY_STATUS | "icr.status"
public static final java.lang.String | ORDER_BY_VENDORID | "icr.vendorId"
public static final java.lang.String | ORDER_BY_WORKORDER | "icr.workOrder"

bb.common.InspectionItemVO
public static final java.lang.String | ORDER_BY_INSPECTIONDESCRIPTION | "inspectionDescription"
public static final java.lang.String | ORDER_BY_INSPECTIONREQUEST | "inspectionRequest"
public static final java.lang.String | ORDER_BY_PK_ITEMNUMBER | "pk.itemNumber"

bb.common.InspectionReportInfoVO
public static final java.lang.String | ORDER_BY_CHECKEACHOTHER | "checkEachOther"
public static final java.lang.String | ORDER_BY_CLEANWORKER | "cleanWorker"
public static final java.lang.String | ORDER_BY_DRAWINGNUMBER | "drawingNumber"
public static final java.lang.String | ORDER_BY_GOODQTY | "goodQty"
public static final java.lang.String | ORDER_BY_INSPECTIONREPORTDATE | "inspectionReportDate"
public static final java.lang.String | ORDER_BY_INSPECTIONREPORTNUMBER | "inspectionReportNumber"
public static final java.lang.String | ORDER_BY_INSPECTIONRESULT | "inspectionResult"
public static final java.lang.String | ORDER_BY_INSPECTOR | "inspector"
public static final java.lang.String | ORDER_BY_MEASUREWORKER | "measureWorker"
public static final java.lang.String | ORDER_BY_OPERATINGENVIRONMENT | "operatingEnvironment"
public static final java.lang.String | ORDER_BY_OPERATINGINSTRUCTIONSNUMBER | "operatingInstructionsNumber"
public static final java.lang.String | ORDER_BY_OPERATINGINSTRUCTIONSTYPEID | "operatingInstructionsTypeId"
public static final java.lang.String | ORDER_BY_PICKLISTORDERNUMBER | "pickListOrderNumber"
public static final java.lang.String | ORDER_BY_PRINTEDBOARDNUMBER | "printedBoardNumber"
public static final java.lang.String | ORDER_BY_QUANTITY | "quantity"
public static final java.lang.String | ORDER_BY_REJECTQTY | "rejectQty"
public static final java.lang.String | ORDER_BY_REJECTREASON | "rejectReason"
public static final java.lang.String | ORDER_BY_SEALWORKER | "sealWorker"

bb.common.InspectionReportInspectMethodVO
public static final java.lang.String | ORDER_BY_DESCRIPTION | "description"
public static final java.lang.String | ORDER_BY_II | "ii"

bb.common.InventoryAdjustmentListResult
public static final java.lang.String | ORDER_BY_COUNTEDBY | "pti.countedBy"
public static final java.lang.String | ORDER_BY_COUNTEDDATE | "pti.countedDate"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "ps.description"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "pti.partNumber,pti.partType"

bb.common.InventoryAdjustmentVO
public static final java.lang.String | ORDER_BY_AVGCOST | "pt.averageCost"
public static final java.lang.String | ORDER_BY_COMMITTED | "pi.committed"
public static final java.lang.String | ORDER_BY_COUNTEDBY | "pi.countedBy"
public static final java.lang.String | ORDER_BY_COUNTEDDATE | "pi.countedDate"
public static final java.lang.String | ORDER_BY_DIFFCOUNT | "pi.diffCount"
public static final java.lang.String | ORDER_BY_NEWONHAND | "pi.newOnhand"

bb.common.InventoryCycleResult
public static final java.lang.String | ORDER_BY_DESCRIPTION | "ps.description"
public static final java.lang.String | ORDER_BY_PART | "pt.pk.partNumber,pt.pk.partType"

bb.common.InventoryListResult
public static final java.lang.String | ORDER_BY_BUYERCODE | "ps.buyerCode"
public static final java.lang.String | ORDER_BY_COMMODITYCODE | "ps.commodityCode"
public static final java.lang.String | ORDER_BY_COST | "pt.averageCost"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "ps.description"
public static final java.lang.String | ORDER_BY_INQA | "pt.inQualityCheckingQty"
public static final java.lang.String | ORDER_BY_INSIP | "pt.shipInProcessQty"
public static final java.lang.String | ORDER_BY_INSTO | "pt.inSTO"
public static final java.lang.String | ORDER_BY_INWIP | "pt.workInProcessQty"
public static final java.lang.String | ORDER_BY_LASTINDATE | "pt.lastInDate"
public static final java.lang.String | ORDER_BY_LASTOUTDATE | "pt.lastOutDate"
public static final java.lang.String | ORDER_BY_LISTPRICE | "pt.listPrice"
public static final java.lang.String | ORDER_BY_MAXQTY | "pt.maxQty"
public static final java.lang.String | ORDER_BY_MINORDER | "pt.maxQty,pt.minQty"
public static final java.lang.String | ORDER_BY_MINQTY | "pt.minQty"
public static final java.lang.String | ORDER_BY_MODELNUMBER | "ps.modelNumber"
public static final java.lang.String | ORDER_BY_ONHAND | "pt.onhand"
public static final java.lang.String | ORDER_BY_ONLOAN | "pt.onloanQty"
public static final java.lang.String | ORDER_BY_ONORDER | "pt.onOrderQty"
public static final java.lang.String | ORDER_BY_PART | "pt.pk.partNumber,pt.pk.partType"
public static final java.lang.String | ORDER_BY_PRODUCTCODE | "ps.productCode"
public static final java.lang.String | ORDER_BY_SHORTAGE | "pt.minQty,pt.onhand"
public static final java.lang.String | ORDER_BY_STANDARDCOST | "pt.standardCost"

bb.common.InventoryMonthReport
public static final java.lang.String | ORDER_BY_DESCRIPTION | "ps.ed"
public static final java.lang.String | ORDER_BY_ENDAMOUNT | "end_amount"
public static final java.lang.String | ORDER_BY_ENDCOST | "end_cost"
public static final java.lang.String | ORDER_BY_ENDQAAMOUNT | "end_qa_amount"
public static final java.lang.String | ORDER_BY_ENDQAQTY | "end_qa"
public static final java.lang.String | ORDER_BY_ENDQTY | "end_qty"
public static final java.lang.String | ORDER_BY_ENDWIPAMOUNT | "end_wip_amount"
public static final java.lang.String | ORDER_BY_ENDWIPQTY | "end_wip"
public static final java.lang.String | ORDER_BY_INAMOUNT | "in_amount"
public static final java.lang.String | ORDER_BY_INCOST | "in_cost"
public static final java.lang.String | ORDER_BY_INQTY | "in_qty"
public static final java.lang.String | ORDER_BY_LOCATION | "locate"
public static final java.lang.String | ORDER_BY_OUTAMOUNT | "out_amount"
public static final java.lang.String | ORDER_BY_OUTCOST | "out_cost"
public static final java.lang.String | ORDER_BY_OUTQTY | "out_qty"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "report.pn,report.pa"
public static final java.lang.String | ORDER_BY_SHIPPINGWEIGHT | "wt"
public static final java.lang.String | ORDER_BY_SHIPPINGWEIGHTUNIT | "wtu"
public static final java.lang.String | ORDER_BY_STARTAMOUNT | "start_amount"
public static final java.lang.String | ORDER_BY_STARTCOST | "start_cost"
public static final java.lang.String | ORDER_BY_STARTQAAMOUNT | "start_qa_amount"
public static final java.lang.String | ORDER_BY_STARTQAQTY | "start_qa"
public static final java.lang.String | ORDER_BY_STARTQTY | "start_qty"
public static final java.lang.String | ORDER_BY_STARTWIPAMOUNT | "start_wip_amount"
public static final java.lang.String | ORDER_BY_STARTWIPQTY | "start_wip"

bb.common.InventoryNotUsedInMonthsforAppResult
public static final java.lang.String | ORDER_BY_DESCRIPTION | "temp.ed"
public static final java.lang.String | ORDER_BY_LASTINDATE | "temp.last_in_date"
public static final java.lang.String | ORDER_BY_LASTOUTDATE | "temp.last_out_date"
public static final java.lang.String | ORDER_BY_MODELNUMBER | "temp.mn"
public static final java.lang.String | ORDER_BY_ONHAND | "temp.onhand"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "temp.pn,temp.pa"
public static final java.lang.String | ORDER_BY_PARTTYPE | "temp.pn,temp.pa"
public static final java.lang.String | ORDER_BY_SERIALNUMBER | "temp.ii"
public static final java.lang.String | ORDER_BY_STANDARDCOST | "temp.std_cost"
public static final java.lang.String | ORDER_BY_STOCKMONTH | "temp.stock_months"
public static final java.lang.String | ORDER_BY_TOTAL | "temp.total"
public static final java.lang.String | ORDER_BY_UNIT | "temp.unit"

bb.common.InventoryNotUsedInMonthsResult
public static final java.lang.String | ORDER_BY_AVERAGECOST | "pt.averageCost"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "ps.description"
public static final java.lang.String | ORDER_BY_LASTINDATE | "pt.lastInDate"
public static final java.lang.String | ORDER_BY_LASTOUTDATE | "pt.lastOutDate"
public static final java.lang.String | ORDER_BY_LOCATE | "pl.pk.location"
public static final java.lang.String | ORDER_BY_PART | "ps.pk.partNumber, ps.pk.partType"
public static final java.lang.String | ORDER_BY_STANDARDCOST | "pt.standardCost"

bb.common.InventoryReportListResult
public static final java.lang.String | ORDER_BY_PARTDESCRIPTION | "description"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "partNumber,partType"

bb.common.InvoiceAgingItemListResult
public static final java.lang.String | ORDER_BY_CUSTOMERID | "ar.customerId"
public static final java.lang.String | ORDER_BY_DATEINVOICED | "ar.arApDate, ar.customerId"
public static final java.lang.String | ORDER_BY_INVOICENUMBER | "ar.arApNumber"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "ari.partNumber"
public static final java.lang.String | ORDER_BY_PAYDATE | "ar.payDate"

bb.common.InvoiceItemListResult
public static final java.lang.String | ORDER_BY_COMPANYUNITID | "ar.companyUnitId"
public static final java.lang.String | ORDER_BY_CREDITACCOUNT | "ar.creditAccount"
public static final java.lang.String | ORDER_BY_CURRENCY | "ar.currency"
public static final java.lang.String | ORDER_BY_CUSTOMERID | "ar.customerId"
public static final java.lang.String | ORDER_BY_CUSTOMERPO | "ar.customerPoNumber"
public static final java.lang.String | ORDER_BY_CUSTOMERTOCOUNTRY | "ar.customerAddressInfo.country"
public static final java.lang.String | ORDER_BY_CUSTOMERTOSTATE | "ar.customerAddressInfo.state"
public static final java.lang.String | ORDER_BY_DATEINVOICED | "ar.dateInvoiced, ar.customerId"
public static final java.lang.String | ORDER_BY_INVOICENUMBER | "ar.invoiceNumber"
public static final java.lang.String | ORDER_BY_PAIDDATE | "ar.datePaid"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "ari.partNumber"
public static final java.lang.String | ORDER_BY_PAYDATE | "ar.paydate"
public static final java.lang.String | ORDER_BY_PRODUCTCODE | "ari.productCode"
public static final java.lang.String | ORDER_BY_SALESORDERNUMBER | "ari.salesOrderNumber"
public static final java.lang.String | ORDER_BY_SHIPPERNUMBER | "ar.shipperNumber"
public static final java.lang.String | ORDER_BY_SHIPTOCOUNTRY | "ar.shipToAddressInfo.country"
public static final java.lang.String | ORDER_BY_SHIPTOID | "ar.shipTo"
public static final java.lang.String | ORDER_BY_SHIPTOSTATE | "ar.shipToAddressInfo.state"

bb.common.JobProcessSheetListResult
public static final java.lang.String | ORDER_BY_DESCRIPTION | "woi.description"
public static final java.lang.String | ORDER_BY_DUEDATE | "woi.dateRequired"
public static final java.lang.String | ORDER_BY_PARTPK | "woi.partNumber"
public static final java.lang.String | ORDER_BY_REFDOC1 | "woi.referenceDoc1"
public static final java.lang.String | ORDER_BY_REFDOC2 | "woi.referenceDoc2"
public static final java.lang.String | ORDER_BY_SETID | "woi.setId"
public static final java.lang.String | ORDER_BY_STATUS | "woi.status"
public static final java.lang.String | ORDER_BY_WOITEMITEMPK | "woi.pk.workOrderNumber,woi.pk.workOrderItemNumber"

bb.common.LabelTemplateConstant
public static final int | ALIGN_BOTTOM | 3
public static final int | ALIGN_CENTER | 1
public static final int | ALIGN_LEFT | 12
public static final int | ALIGN_RIGHT | 13
public static final int | ALIGN_TOP | 2
public static final java.lang.String | ASSET_ASSETNUMBER | "assetNumber"
public static final java.lang.String | ASSET_ASSETTYPE | "assetType"
public static final java.lang.String | ASSET_ASSETTYPE2 | "assetType2"
public static final java.lang.String | ASSET_CHECKDATE | "checkDate"
public static final java.lang.String | ASSET_DEPARTMENTID | "departmentID"
public static final java.lang.String | ASSET_DESCRIPTION | "description"
public static final java.lang.String | ASSET_LOCATION | "location"
public static final double | FACTOR | 0.8
public static final java.lang.String | FONT_DEFAULT | "Default"
public static final java.lang.String | ISSUING_DATE | "date"
public static final java.lang.String | ISSUING_DESCRIPTION | "description"
public static final java.lang.String | ISSUING_OPERATOR | "operator"
public static final java.lang.String | ISSUING_PART_NUMBER | "partNumber"
public static final java.lang.String | ISSUING_PROJECT | "project"
public static final java.lang.String | ISSUING_QTY_ISSUED | "qtyIssued"
public static final java.lang.String | ISSUING_RELATEDDOC | "relatedDoc"
public static final java.lang.String | ISSUING_UNIT | "unit"
public static final java.lang.String | ISSUING_WO_NUMBER | "workOrderNumber"
public static final java.lang.String | ITEM_BARCODE | "Barcode"
public static final java.lang.String | ITEM_LABEL | "Label"
public static final java.lang.String | ITEM_LINE | "Line"
public static final java.lang.String | ITEM_PROPERTY | "Property"
public static final java.lang.String | ITEM_QR_BARCODE | "QRBarcode"
public static final java.lang.String | ITEM_TABLE | "Table"
public static final java.lang.String | LABEL_ASSET | "Asset"
public static final java.lang.String | LABEL_GL | "GL"
public static final java.lang.String | LABEL_ISSUING | "Issuing"
public static final java.lang.String | LABEL_LOCATION | "Location"
public static final java.lang.String | LABEL_PART | "Part"
public static final java.lang.String | LABEL_POS | "POS"
public static final java.lang.String | LABEL_SHIPPING | "Shipping"
public static final java.lang.String | LOCATION_LOCATION | "location"
public static final java.lang.String | PART_ADDRESS_ID | "addressID"
public static final java.lang.String | PART_ADDRESS_NAME | "addressName"
public static final java.lang.String | PART_DATE | "date"
public static final java.lang.String | PART_DESCRIPTION | "description"
public static final java.lang.String | PART_LOCATION | "location"
public static final java.lang.String | PART_OPERATOR | "operator"
public static final java.lang.String | PART_PART_NUMBER | "partNumber"
public static final java.lang.String | PART_QTY_RECEIVED_OR_SHIPPED | "qtyReceivedOrShipped"
public static final java.lang.String | PART_RELATED_DOC | "relatedDoc"
public static final java.lang.String | PART_UNIT | "unit"
public static final java.lang.String | POS_ACCOUNTSRECEIVABLE | "accountsReceivable"
public static final java.lang.String | POS_AVGCOSTTOTAL | "avgCostTotal"
public static final java.lang.String | POS_CHANGE | "change"
public static final java.lang.String | POS_CHECKNUMBER | "checkNumber"
public static final java.lang.String | POS_CREDITCARDNUMBER | "creditCardNumber"
public static final java.lang.String | POS_CUSTOMERID | "customerId"
public static final java.lang.String | POS_DISCTOTAL | "discTotal"
public static final java.lang.String | POS_DUTYFREENUMBER | "dutyFreeNumber"
public static final java.lang.String | POS_ELECSIGNATURE | "elecSignature"
public static final java.lang.String | POS_FREIGHT | "freight"
public static final java.lang.String | POS_ITEM_AVGCOST | "avgCost"
public static final java.lang.String | POS_ITEM_DESCRIPTION | "description"
public static final java.lang.String | POS_ITEM_DISCOUNT | "discount"
public static final java.lang.String | POS_ITEM_DUTYFREE | "dutyFree"
public static final java.lang.String | POS_ITEM_NETTOTAL | "itemNetTotal"
public static final java.lang.String | POS_ITEM_NUMBER | "receiptItemNumber"
public static final java.lang.String | POS_ITEM_PARTNUMBER | "partNumber"
public static final java.lang.String | POS_ITEM_PARTTYPE | "partType"
public static final java.lang.String | POS_ITEM_PRICE | "price"
public static final java.lang.String | POS_ITEM_PROFIT | "profit"
public static final java.lang.String | POS_ITEM_PROFITBYSTDCOST | "profitByStdCost"
public static final java.lang.String | POS_ITEM_PROFITPERCENT | "profitPercent"
public static final java.lang.String | POS_ITEM_PROFITPERCENTBYSTDCOST | "profitPercentByStdCost"
public static final java.lang.String | POS_ITEM_QUANTITY | "quantity"
public static final java.lang.String | POS_ITEM_REALTIMEONHAND | "realTimeOnhand"
public static final java.lang.String | POS_ITEM_STDCOST | "stdCost"
public static final java.lang.String | POS_ITEM_SUBTOTAL | "subTotal"
public static final java.lang.String | POS_ITEM_TAXTOTAL | "itemTaxTotal"
public static final java.lang.String | POS_NETTOTAL | "netTotal"
public static final java.lang.String | POS_PAYABLEMETHOD | "payableMethod"
public static final java.lang.String | POS_PROFITPERCENTTOTAL | "profitPercentTotal"
public static final java.lang.String | POS_PROFITPERCENTTOTALBYSTDCOST | "profitPercentTotalByStdCost"
public static final java.lang.String | POS_PROFITTOTAL | "profitTotal"
public static final java.lang.String | POS_PROFITTOTALBYSTDCOST | "profitTotalByStdCost"
public static final java.lang.String | POS_RAO_NUMBER | "runningAccountOrderNumber"
public static final java.lang.String | POS_REALRECEIVABLE | "realReceivable"
public static final java.lang.String | POS_SALESDATE | "salesDate"
public static final java.lang.String | POS_SALESMAN | "salesman"
public static final java.lang.String | POS_TAX | "tax"
public static final java.lang.String | POS_TAXRATE | "taxRate"
public static final java.lang.String | POS_TAXTOTAL | "taxTotal"
public static final java.lang.String | SHIPPING_SO_NUMBER | "salesOrderNumber"

bb.common.LabelTemplateVO
public static final java.lang.String | ORDER_BY_ACTIVE | "active"
public static final java.lang.String | ORDER_BY_COMMENTS | "comments"
public static final java.lang.String | ORDER_BY_HEIGHT | "height"
public static final java.lang.String | ORDER_BY_II | "ii"
public static final java.lang.String | ORDER_BY_LABELTYPE | "labelType"
public static final java.lang.String | ORDER_BY_NAME | "name"
public static final java.lang.String | ORDER_BY_PORTRAITORIENTATION | "portraitOrientation"
public static final java.lang.String | ORDER_BY_WIDTH | "width"

bb.common.LnShipperItemListResult
public static final java.lang.String | ORDER_BY_CUSTOMERID | "lns.customerId"
public static final java.lang.String | ORDER_BY_CUSTOMERNAME | "ab.name"
public static final java.lang.String | ORDER_BY_DATESHIPPED | "lnsi.dateShipped"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "lnsi.description"
public static final java.lang.String | ORDER_BY_LISTPRICE | "lnsi.listPrice"
public static final java.lang.String | ORDER_BY_LNSHIPPERNUMBER | "lnsi.pk.lnShipperNumber"
public static final java.lang.String | ORDER_BY_LOANNUMBER | "lnsi.loanNumber"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "lnsi.partNumber"
public static final java.lang.String | ORDER_BY_QUANTITY | "lnsi.loanQuantity"
public static final java.lang.String | ORDER_BY_QUANTITYSHIP | "lnsi.quantityShip"
public static final java.lang.String | ORDER_BY_SERIALNUMBER | "lnsi.serialNumber"
public static final java.lang.String | ORDER_BY_STATUS | "lnsi.status"

bb.common.LnShipperListResult
public static final java.lang.String | ORDER_BY_CUSTOMERID | "lns.customerId"
public static final java.lang.String | ORDER_BY_DATESHIPPED | "lns.dateShipped"
public static final java.lang.String | ORDER_BY_LNSHIPPERNUMBER | "lns.lnShipperNumber"
public static final java.lang.String | ORDER_BY_LOANNUMBER | "lns.loanNumber"
public static final java.lang.String | ORDER_BY_SALESMAN | "lns.salesman"
public static final java.lang.String | ORDER_BY_STATUS | "lns.status"

bb.common.LockedCustomerAddressResult
public static final java.lang.String | ORDER_BY_CITY | "cva.city"
public static final java.lang.String | ORDER_BY_COUNTRY | "cva.country"
public static final java.lang.String | ORDER_BY_CRITICALLEVEL | "cva.critical_level"
public static final java.lang.String | ORDER_BY_CUSTOMERFLAG | "cva.c"
public static final java.lang.String | ORDER_BY_ID | "cva.id"
public static final java.lang.String | ORDER_BY_NAME | "cva.name"
public static final java.lang.String | ORDER_BY_QUALITYSTATUS | "cva.v_lock"
public static final java.lang.String | ORDER_BY_STATE | "cva.state"
public static final java.lang.String | ORDER_BY_VENDORCATEGORY | "cva.v_type"
public static final java.lang.String | ORDER_BY_VENDORFLAG | "cva.v"
public static final java.lang.String | ORDER_BY_ZIP | "cva.zip"

bb.common.LogInventoryListResult
public static final java.lang.String | ORDER_BY_DATE | "log.lastChangeDate"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "ps.description"
public static final java.lang.String | ORDER_BY_EMPLOYEE | "log.lastChangeUser"
public static final java.lang.String | ORDER_BY_INCOST | "log.inCost"
public static final java.lang.String | ORDER_BY_INQTY | "log.inQty"
public static final java.lang.String | ORDER_BY_LOCATION | "log.location"
public static final java.lang.String | ORDER_BY_NEWCOST | "log.newCost"
public static final java.lang.String | ORDER_BY_NEWINQA | "log.newInQA"
public static final java.lang.String | ORDER_BY_NEWINTO | "log.newInTO"
public static final java.lang.String | ORDER_BY_NEWONHAND | "log.newOnhand"
public static final java.lang.String | ORDER_BY_NEWSIP | "log.newSip"
public static final java.lang.String | ORDER_BY_NEWSIT | "log.newSit"
public static final java.lang.String | ORDER_BY_NEWWIP | "log.newWip"
public static final java.lang.String | ORDER_BY_OLDCOST | "log.oldCost"
public static final java.lang.String | ORDER_BY_OLDINQA | "log.oldInQA"
public static final java.lang.String | ORDER_BY_OLDINTO | "log.oldInTO"
public static final java.lang.String | ORDER_BY_OLDONHAND | "log.oldOnhand"
public static final java.lang.String | ORDER_BY_OLDSIP | "log.oldSip"
public static final java.lang.String | ORDER_BY_OLDSIT | "log.oldSit"
public static final java.lang.String | ORDER_BY_OLDWIP | "log.oldWip"
public static final java.lang.String | ORDER_BY_OUTCOST | "log.outCost"
public static final java.lang.String | ORDER_BY_OUTQTY | "log.outQty"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "log.partNumber"
public static final java.lang.String | ORDER_BY_PORELATEDOC | "log.poRelateDoc"
public static final java.lang.String | ORDER_BY_POVENDER | "log.poVender"
public static final java.lang.String | ORDER_BY_REFDOC1 | "log.refDoc1"
public static final java.lang.String | ORDER_BY_REFDOC2 | "log.refDoc2"

bb.common.LogMiscDocumentVO
public static final java.lang.String | ORDER_BY_ACTION | "action"
public static final java.lang.String | ORDER_BY_CONTROLNUMBER | "controlNumber"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "description"
public static final java.lang.String | ORDER_BY_DOCFILENAME | "docFileName"
public static final java.lang.String | ORDER_BY_DOCLENGTH | "docLength"
public static final java.lang.String | ORDER_BY_DOCTYPE | "docType"
public static final java.lang.String | ORDER_BY_EXTENSION | "extension"
public static final java.lang.String | ORDER_BY_LANIP | "lanIp"
public static final java.lang.String | ORDER_BY_LASTCHANGEDATE | "lastchangeDate"
public static final java.lang.String | ORDER_BY_LASTCHANGEUSER | "lastChangeUser"
public static final java.lang.String | ORDER_BY_ORDERITEMNUMBER | "orderItemNumber"
public static final java.lang.String | ORDER_BY_ORDERNUMBER | "orderNumber"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "partNumber"
public static final java.lang.String | ORDER_BY_PARTTYPE | "partType"
public static final java.lang.String | ORDER_BY_RV | "rv"

bb.common.LogPartDocumentVO
public static final java.lang.String | ORDER_BY_ACTION | "log.action"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "log.description"
public static final java.lang.String | ORDER_BY_DOCUMENTLENGTHBYTE | "log.documentLengthByte"
public static final java.lang.String | ORDER_BY_DOCUMENTTYPE | "log.documentType"
public static final java.lang.String | ORDER_BY_DOCVERSION | "log.docVersion"
public static final java.lang.String | ORDER_BY_LANGUAGE | "log.language"
public static final java.lang.String | ORDER_BY_LANIP | "log.lanIp"
public static final java.lang.String | ORDER_BY_LASTCHANGEDATE | "log.lastChangeDate"
public static final java.lang.String | ORDER_BY_LASTCHANGEUSER | "log.lastChangeUser"
public static final java.lang.String | ORDER_BY_MACADDRESS | "log.macAddress"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "log.partNumber"
public static final java.lang.String | ORDER_BY_PUBLICDOC | "log.publicDoc"
public static final java.lang.String | ORDER_BY_WANIP | "log.wanIp"

bb.common.LogPartDwfVO
public static final java.lang.String | ORDER_BY_ACTION | "action"
public static final java.lang.String | ORDER_BY_BB2COUNT | "count"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "description"
public static final java.lang.String | ORDER_BY_DWFEXTENSION | "dwfExtension"
public static final java.lang.String | ORDER_BY_DWFLENGTH | "dwfLength"
public static final java.lang.String | ORDER_BY_DWGLENGTH | "dwgLength"
public static final java.lang.String | ORDER_BY_LANIP | "lanIp"
public static final java.lang.String | ORDER_BY_LASTCHANGEDATE | "lastChangeDate"
public static final java.lang.String | ORDER_BY_LASTCHANGEUSER | "lastChangeUser"
public static final java.lang.String | ORDER_BY_MACADDRESS | "macAddress"
public static final java.lang.String | ORDER_BY_PARTFROM | "partFrom"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "partNumber"
public static final java.lang.String | ORDER_BY_REVISION | "revision"
public static final java.lang.String | ORDER_BY_WANIP | "wanIp"

bb.common.LogPartDwgVO
public static final java.lang.String | ORDER_BY_ACTION | "action"
public static final java.lang.String | ORDER_BY_BB2COUNT | "count"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "description"
public static final java.lang.String | ORDER_BY_DWGEXTENSION | "dwgExtension"
public static final java.lang.String | ORDER_BY_DWGLENGTH | "dwgLength"
public static final java.lang.String | ORDER_BY_LANIP | "lanIp"
public static final java.lang.String | ORDER_BY_LASTCHANGEDATE | "lastChangeDate"
public static final java.lang.String | ORDER_BY_LASTCHANGEUSER | "lastChangeUser"
public static final java.lang.String | ORDER_BY_MACADDRESS | "macAddress"
public static final java.lang.String | ORDER_BY_PARTFROM | "partFrom"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "partNumber"
public static final java.lang.String | ORDER_BY_REVISION | "revision"
public static final java.lang.String | ORDER_BY_WANIP | "wanIp"

bb.common.LogTaskVO
public static final java.lang.String | ORDER_BY_COMMENTS | "comments"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "description"
public static final java.lang.String | ORDER_BY_ENDDATE | "endDate"
public static final java.lang.String | ORDER_BY_NAME | "name"
public static final java.lang.String | ORDER_BY_STARTDATE | "startDate"

bb.common.LogTrackingVO
public static final java.lang.String | ORDER_BY_DESCRIPTION | "(case when pd.description is null then ps.description else pd.description end)"
public static final java.lang.String | ORDER_BY_INQTY | "log.inQty"
public static final java.lang.String | ORDER_BY_LASTCHANGEDATE | "log.lastChangeDate"
public static final java.lang.String | ORDER_BY_LASTCHANGEUSER | "log.lastChangeUser"
public static final java.lang.String | ORDER_BY_LOCATION | "log.location"
public static final java.lang.String | ORDER_BY_OUTQTY | "log.outQty"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "log.partNumber"
public static final java.lang.String | ORDER_BY_PARTTYPE | "log.partType"
public static final java.lang.String | ORDER_BY_REFDOC1 | "log.refDoc1"
public static final java.lang.String | ORDER_BY_REFDOC2 | "log.refDoc2"
public static final java.lang.String | ORDER_BY_TRACKINGNUMBER | "log.trackingNumber"

bb.common.ManufacturerAddressInfoVO
public static final java.lang.String | ORDER_BY_ADDRESS | "pma.addressOne"
public static final java.lang.String | ORDER_BY_CITY | "pma.city"
public static final java.lang.String | ORDER_BY_COUNTRY | "pma.country"
public static final java.lang.String | ORDER_BY_ID | "pma.id"
public static final java.lang.String | ORDER_BY_NAME | "pma.name"
public static final java.lang.String | ORDER_BY_STATE | "pma.state"
public static final java.lang.String | ORDER_BY_ZIP | "pma.zip"

bb.common.MessageVO
public static final java.lang.String | ORDER_BY_RECEIVER | "receiver"
public static final java.lang.String | ORDER_BY_REFID | "refId"
public static final java.lang.String | ORDER_BY_SENDDATE | "sendDate"
public static final java.lang.String | ORDER_BY_SENDFROM | "sendFrom"
public static final java.lang.String | ORDER_BY_SENDUSERNAME | "sendUsername"
public static final java.lang.String | ORDER_BY_SUBJECT | "subject"
public static final int | STATUS_READ | 1
public static final int | STATUS_REMOVED | 2
public static final int | STATUS_UNREAD | 0

bb.common.MiscDocumentSettingVO
public static final java.lang.String | ORDER_BY_DOCUMENTTYPE | "misc_doc_settings.documentType"
public static final java.lang.String | ORDER_BY_FTPPATH | "misc_doc_settings.ftpPath"
public static final java.lang.String | ORDER_BY_LOCALPATH | "misc_doc_settings.localPath"
public static final java.lang.String | ORDER_BY_REMARKS | "misc_doc_settings.remarks"
public static final java.lang.String | ORDER_BY_SERVERIP | "misc_doc_settings.serverIp"
public static final java.lang.String | ORDER_BY_SERVERPORT | "misc_doc_settings.serverPort"
public static final java.lang.String | ORDER_BY_USERNAME | "misc_doc_settings.userName"

bb.common.MrpReportAgent
public static final java.lang.String | NoUsage | "NoUsage"
public static final java.lang.String | QtrUsage | "QtrUsage"
public static final java.lang.String | YrUsage | "YrUsage"

bb.common.NCQRejectResult
public static final java.lang.String ORDER_BY_NONCONFORMANCECODE "ncq.nonConformanceCode"

bb.common.NcrApprovalVO
public static final java.lang.String | ORDER_BY_APPROVETYPE | "pk.approveType"
public static final java.lang.String | ORDER_BY_CANAPPROVEOWN | "canApproveOwn"
public static final java.lang.String | ORDER_BY_COMMENTS | "comments"
public static final java.lang.String | ORDER_BY_EMPLOYEEID | "pk.employeeId"
public static final java.lang.String | ORDER_BY_USERNAME | "userName"

bb.common.NcrNeedToScrapListResult
public static final java.lang.String | ORDER_BY_DATE | "qn.entered"
public static final java.lang.String | ORDER_BY_NCR | "qn.qn"
public static final java.lang.String | ORDER_BY_PART | "qn.pn"
public static final java.lang.String | ORDER_BY_RESPONSIBILITY | "qn.responsibility"
public static final java.lang.String | ORDER_BY_STATUS | "qn.status"

bb.common.NcrReportListResult
public static final java.lang.String | ORDER_BY_APPROVEDOPINIONENG | "ncr.approvedOpinionEng"
public static final java.lang.String | ORDER_BY_APPROVEDOPINIONMFG | "ncr.approvedOpinionMfg"
public static final java.lang.String | ORDER_BY_APPROVEDOPINIONQA | "ncr.approvedOpinionQa"
public static final java.lang.String | ORDER_BY_BUYER | "ncr.buyer"
public static final java.lang.String | ORDER_BY_CLOSEDOUTDATE | "ncr.closedOutDate"
public static final java.lang.String | ORDER_BY_CLOSEDOUTPRIVATENOTES | "ncr.closedOutPrivateNotes"
public static final java.lang.String | ORDER_BY_DUEDATE | "ncr.dueDate"
public static final java.lang.String | ORDER_BY_ENTERBY | "ncr.enteredBy"
public static final java.lang.String | ORDER_BY_NCRDATE | "ncr.ncrDate"
public static final java.lang.String | ORDER_BY_NCRNUMBER | "ncr.ncrNumber"
public static final java.lang.String | ORDER_BY_PART | "ncr.partNumber"
public static final java.lang.String | ORDER_BY_PONUMBER | "ncr.purchaseOrderNumber"
public static final java.lang.String | ORDER_BY_PROBLEMDESCRIPTION | "ncr.problemDescription"
public static final java.lang.String | ORDER_BY_PROBLEMDISPOSITION | "ncr.problemDisposition"
public static final java.lang.String | ORDER_BY_RESPONSIBILITY | "ncr.responsibility"
public static final java.lang.String | ORDER_BY_RTVNUMBER | "ncr.rtvNumber"
public static final java.lang.String | ORDER_BY_SONUMBER | "ncr.salesOrderNumber"
public static final java.lang.String | ORDER_BY_STATUS | "ncr.status"
public static final java.lang.String | ORDER_BY_VENDORID | "ncr.vendorId"
public static final java.lang.String | ORDER_BY_WONUMBER | "ncr.workOrderNumber"

bb.common.NonConformanceCodeVO
public static final java.lang.String | ORDER_BY_CODE | "code"
public static final java.lang.String | ORDER_BY_LASTCHANGEDATE | "lastChangeDate"
public static final java.lang.String | ORDER_BY_LASTCHANGEUSER | "lastChangeUser"
public static final java.lang.String | ORDER_BY_ORIGIN | "origin"

bb.common.NonConformanceReportVO
public static final java.lang.String | ORDER_BY_DUEDATE | "dueDate"
public static final java.lang.String | ORDER_BY_NCRDATE | "ncrDate"
public static final java.lang.String | ORDER_BY_NCRNUMBER | "ncrNumber"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "partNumber"
public static final java.lang.String | ORDER_BY_VENDORID | "vendorId"

bb.common.NonproductivePickingApprovalVO
public static final java.lang.String | ORDER_BY_CANREVIEWOWNNONPROPICKING | "canReviewOwnNonproPicking"
public static final java.lang.String | ORDER_BY_COMMENTS | "comments"
public static final java.lang.String | ORDER_BY_EMPLOYEEID | "employeeId"
public static final java.lang.String | ORDER_BY_USERNAME | "userName"

bb.common.NonproductivePickingApproveVO
public static final java.lang.String | ORDER_BY_CANREVIEWOWNNONPROPICKING | "canReviewOwnNonproPicking"
public static final java.lang.String | ORDER_BY_CURRENCY | "currency"
public static final java.lang.String | ORDER_BY_EMPLOYEEID | "employeeId"
public static final java.lang.String | ORDER_BY_REVIEWLIMIT | "reviewLimit"
public static final java.lang.String | ORDER_BY_USERNAME | "userName"

bb.common.NonproductivePickingItemIssuedListResult
public static final java.lang.String | ORDER_BY_AVGCOST | "npis.cost"
public static final java.lang.String | ORDER_BY_DATEISSUE | "npis.dateIssued"
public static final java.lang.String | ORDER_BY_ORDERTYPE | "np.orderType"
public static final java.lang.String | ORDER_BY_PARTDESC | "npis.description"
public static final java.lang.String | ORDER_BY_PARTPK | "npis.partNumber,npis.partType"
public static final java.lang.String | ORDER_BY_PROJECT | "np.project"
public static final java.lang.String | ORDER_BY_STDCOST | "npis.stdCost"
public static final java.lang.String | ORDER_BY_WORKORDERNUMBER | "npi.pk.pickingNumber,npi.pk.pickingItemNumber"

bb.common.NonproductivePickingItemIssuedVO
public static final java.lang.String | ORDER_BY_DATEISSUED | "npis.dateIssued"
public static final java.lang.String | ORDER_BY_LOCATE | "npis.locate"
public static final java.lang.String | ORDER_BY_OPERATOR | "npis.operator"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "npis.partNumber"
public static final java.lang.String | ORDER_BY_PARTTYPE | "npis.partType"
public static final java.lang.String | ORDER_BY_PICKER | "npis.picker"
public static final java.lang.String | ORDER_BY_PICKINGITEMNUMBER | "npis.pickingItemNumber"
public static final java.lang.String | ORDER_BY_PICKINGNUMBER | "npis.pickingNumber"
public static final java.lang.String | ORDER_BY_QTYISSUED | "npis.qtyIssued"
public static final java.lang.String | ORDER_BY_TRANSACTIONNUMBER | "npis.transactionNumber"
public static final java.lang.String | ORDER_BY_UNIT | "npis.unit"

bb.common.NonproductivePickingItemResult
public static final java.lang.String | ORDER_BY_ACCOUNTNUMBER | "np.accountNumber"
public static final java.lang.String | ORDER_BY_APPROVEDBY | "np.approvedBy"
public static final java.lang.String | ORDER_BY_APPROVEDDATE | "np.approvedDate"
public static final java.lang.String | ORDER_BY_COMPANYUNITID | "np.companyUnitId"
public static final java.lang.String | ORDER_BY_ID | "np.id"
public static final java.lang.String | ORDER_BY_ISSUEDQUANTITY | "npi.issuedQuantity"
public static final java.lang.String | ORDER_BY_ORDERTYPE | "np.orderType"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "npi.partNumber"
public static final java.lang.String | ORDER_BY_PARTTYPE | "npi.partType"
public static final java.lang.String | ORDER_BY_PICKINGNUMBER | "np.pickingNumber"
public static final java.lang.String | ORDER_BY_PROJECT | "np.project"
public static final java.lang.String | ORDER_BY_QUANTITY | "npi.quantity"
public static final java.lang.String | ORDER_BY_UNIT | "npi.unit"

bb.common.NonproductivePickingTypeVO
public static final java.lang.String | ORDER_BY_ACCOUNTNUMBER | "npt.accountNumber"
public static final java.lang.String | ORDER_BY_COMPANYUNITID | "npt.companyUnitId"
public static final java.lang.String | ORDER_BY_NAME | "npt.name"

bb.common.NonproductivePickingVO
public static final java.lang.String | ORDER_BY_ACCOUNTNUMBER | "np.accountNumber"
public static final java.lang.String | ORDER_BY_APPROVEDBY | "np.approvedBy"
public static final java.lang.String | ORDER_BY_APPROVEDDATE | "np.approvedDate"
public static final java.lang.String | ORDER_BY_COMPANYUNITID | "np.companyUnitId"
public static final java.lang.String | ORDER_BY_DEPARTMENTID | "np.departmentId"
public static final java.lang.String | ORDER_BY_ORDERTYPE | "np.orderType"
public static final java.lang.String | ORDER_BY_PICKINGNUMBER | "np.pickingNumber"
public static final java.lang.String | ORDER_BY_PROJECT | "np.project"

bb.common.NoticeUserEmployeeListResult
public static final java.lang.String | ORDER_BY_DEPARTMENT | "emp.department"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "user.description"
public static final java.lang.String | ORDER_BY_EMAIL | "emp.e_mail"
public static final java.lang.String | ORDER_BY_HOMEPHONE | "emp.home_phone"
public static final java.lang.String | ORDER_BY_MOBILE | "emp.mobile"
public static final java.lang.String | ORDER_BY_PHONE | "emp.phone"
public static final java.lang.String | ORDER_BY_SYSTEMUSERNAME | "emp.user_name"
public static final java.lang.String | ORDER_BY_USERNAME | "user.username"

bb.common.OnLoanItemListResult
public static final java.lang.String | ORDER_BY_CUSTOMERID | "ln.customerId"
public static final java.lang.String | ORDER_BY_CUSTOMERPO | "ln.customerPo"
public static final java.lang.String | ORDER_BY_DELIVERYDATE | "lni.delivery"
public static final java.lang.String | ORDER_BY_LOANDATE | "ln.loanDate"
public static final java.lang.String | ORDER_BY_LOANITEMNUMBER | "lni.pk.loanItemNumber"
public static final java.lang.String | ORDER_BY_LOANNUMBER | "lni.pk.loanNumber"
public static final java.lang.String | ORDER_BY_PARTPK | "lni.partNumber,lni.partType,lni.partFrom"
public static final java.lang.String | ORDER_BY_SHIPVIA | "lni.shipVia"
public static final java.lang.String | ORDER_BY_STATUS | "lni.status"

bb.common.OnLoanListResult
public static final java.lang.String | ORDER_BY_CUSTOMERID | "lns.customerId"
public static final java.lang.String | ORDER_BY_CUSTOMERPO | "lns.customerPo"
public static final java.lang.String | ORDER_BY_LOANDATE | "lns.loanDate"
public static final java.lang.String | ORDER_BY_LOANNUMBER | "lns.loanNumber"
public static final java.lang.String | ORDER_BY_PROJECT | "lns.project"
public static final java.lang.String | ORDER_BY_STATUS | "lns.status"

bb.common.OnloanReceiverItemListResult
public static final java.lang.String | ORDER_BY_CUSTID | "lnr.custID"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "lnir.description"
public static final java.lang.String | ORDER_BY_LNSHIPPERNUMBER | "lnir.lnShipperNumber"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "lnir.partNumber,lnir.partType,lnir.partFrom"
public static final java.lang.String | ORDER_BY_PARTTYPE | "lnir.partNumber,lnir.partType,lnir.partFrom"
public static final java.lang.String | ORDER_BY_RECEIVERBY | "lnir.receivedBy"
public static final java.lang.String | ORDER_BY_RECEIVERNUMBER | "lnir.pk.receiverNumber"
public static final java.lang.String | ORDER_BY_STATUS | "lnir.status"

bb.common.OnloanReceiverListResult
public static final java.lang.String | ORDER_BY_DATERECEIVED | "dateReceived"
public static final java.lang.String | ORDER_BY_LNSHIPPERNUMBER | "lnShipperNumber"
public static final java.lang.String | ORDER_BY_PROJECT | "project"
public static final java.lang.String | ORDER_BY_RECEIVEDBY | "receivedBy"
public static final java.lang.String | ORDER_BY_RECEIVERNUMBER | "receiverNumber"
public static final java.lang.String | ORDER_BY_STATUS | "status"

bb.common.OnloanReviewVO
public static final java.lang.String | ORDER_BY_CANREVIEWOWNONLOAN | "canReviewOwnOnloan"
public static final java.lang.String | ORDER_BY_CURRENCY | "currency"
public static final java.lang.String | ORDER_BY_EMPLOYEEID | "employeeId"
public static final java.lang.String | ORDER_BY_REVIEWLIMIT | "reviewLimit"
public static final java.lang.String | ORDER_BY_USERNAME | "userName"

bb.common.OperatingInstructionsInspectStandardVO
public static final java.lang.String | ORDER_BY_DESCRIPTION | "description"
public static final java.lang.String | ORDER_BY_II | "ii"

bb.common.OperatingInstructionsManualVO
public static final java.lang.String | ORDER_BY_DESCRIPTION | "description"
public static final java.lang.String | ORDER_BY_II | "ii"

bb.common.OperatingInstructionsTypeVO
public static final java.lang.String | ORDER_BY_DESCRIPTION | "description"
public static final java.lang.String | ORDER_BY_II | "ii"
public static final java.lang.String | ORDER_BY_SERIALNUMBERTYPE | "serialNumberType"

bb.common.OperatingInstructionsUserStatisticalResult
public static final java.lang.String | ORDER_BY_ELAPSEDTIMEBYHOUR | "elapsedTimeByHour"
public static final java.lang.String | ORDER_BY_ENDDATE | "endDate"
public static final java.lang.String | ORDER_BY_INSPECTIONREPORTNUMBER | "inspectionReportNumber"
public static final java.lang.String | ORDER_BY_OPERATINGINSTRUCTIONSDESCRIPTION | "operatingInstructionsDescription"
public static final java.lang.String | ORDER_BY_OPERATINGINSTRUCTIONSNUMBER | "operatingInstructionsNumber"
public static final java.lang.String | ORDER_BY_OPERATINGINSTRUCTIONSTYPEDESCRIPTION | "opt_ins_type.description"
public static final java.lang.String | ORDER_BY_PAUSEDTIME | "pausedTime"
public static final java.lang.String | ORDER_BY_PAUSEDTIMEBYHOUR | "pausedTimeByHour"
public static final java.lang.String | ORDER_BY_QUANTITY | "quantity"
public static final java.lang.String | ORDER_BY_RESPONSIBILITY | "responsibility"
public static final java.lang.String | ORDER_BY_STAFF | "staff"
public static final java.lang.String | ORDER_BY_STARTDATE | "startDate"
public static final java.lang.String | ORDER_BY_STATUS | "status"

bb.common.OperatingInstructionsVO
public static final java.lang.String | ORDER_BY_DRAWINGNUMBER | "drawingNumber"
public static final java.lang.String | ORDER_BY_ELAPSEDTIMEBYHOUR | "elapsedTimeByHour"
public static final java.lang.String | ORDER_BY_ENDDATE | "endDate"
public static final java.lang.String | ORDER_BY_INSPECTIONREPORTNUMBER | "inspectionReportNumber"
public static final java.lang.String | ORDER_BY_OPERATINGENVIRONMENT | "operatingEnvironment"
public static final java.lang.String | ORDER_BY_OPERATINGINSTRUCTIONSDESCRIPTION | "operatingInstructionsDescription"
public static final java.lang.String | ORDER_BY_OPERATINGINSTRUCTIONSNOTES | "operatingInstructionsNotes"
public static final java.lang.String | ORDER_BY_OPERATINGINSTRUCTIONSNUMBER | "operatingInstructionsNumber"
public static final java.lang.String | ORDER_BY_OPERATINGINSTRUCTIONSTYPE | "operatingInstructionsType.description"
public static final java.lang.String | ORDER_BY_OPERATINGPROCESSNOTES | "operatingProcessNotes"
public static final java.lang.String | ORDER_BY_OPERATINGPROCESSRECORD | "operatingProcessRecord"
public static final java.lang.String | ORDER_BY_PAUSEDTIME | "pausedTime"
public static final java.lang.String | ORDER_BY_PAUSEDTIMEBYHOUR | "pausedTimeByHour"
public static final java.lang.String | ORDER_BY_PICKLISTORDERNUMBER | "pickListOrderNumber"
public static final java.lang.String | ORDER_BY_PROJECT | "project"
public static final java.lang.String | ORDER_BY_QUANTITY | "quantity"
public static final java.lang.String | ORDER_BY_RELATEDINSPECTORSIGN | "relatedInspectorSign"
public static final java.lang.String | ORDER_BY_REQUESTINSPECTIONDATE | "requestInspectionDate"
public static final java.lang.String | ORDER_BY_RESPONSIBILITY | "responsibility"
public static final java.lang.String | ORDER_BY_SERIAL | "serial"
public static final java.lang.String | ORDER_BY_STAFF | "staff"
public static final java.lang.String | ORDER_BY_STAFFSIGN | "staffSign"
public static final java.lang.String | ORDER_BY_STARTDATE | "startDate"
public static final java.lang.String | ORDER_BY_STATUS | "status"
public static final java.lang.String | ORDER_BY_WORKORDERANDITEMNUMBER | "workOrderAndItemNumber"

bb.common.OperatingOutputFileTypeVO
public static final java.lang.String | ORDER_BY_DESCRIPTION | "description"
public static final java.lang.String | ORDER_BY_II | "ii"

bb.common.OperationLogVO
public static final java.lang.String | ORDER_BY_ACTION | "log.action"
public static final java.lang.String | ORDER_BY_ACTIONTIME | "log.actionTime"
public static final java.lang.String | ORDER_BY_COMMENT | "log.comment"
public static final java.lang.String | ORDER_BY_EMPLOYEEID | "log.employeeID"
public static final java.lang.String | ORDER_BY_ID | "log.id"
public static final java.lang.String | ORDER_BY_LANIP | "log.lanIp"
public static final java.lang.String | ORDER_BY_MACADDRESS | "log.macAddress"
public static final java.lang.String | ORDER_BY_PORT | "log.port"
public static final java.lang.String | ORDER_BY_SERVER | "log.server"
public static final java.lang.String | ORDER_BY_SYSTEM | "log.system"
public static final java.lang.String | ORDER_BY_TARGET | "log.target"
public static final java.lang.String | ORDER_BY_TRUENAME | "log.trueName"
public static final java.lang.String | ORDER_BY_TYPE | "log.type"
public static final java.lang.String | ORDER_BY_USERNAME | "log.userName"
public static final java.lang.String | ORDER_BY_WANIP | "log.wanIp"

bb.common.OrderBy
public static final java.lang.String | ASC | "asc"
public static final java.lang.String | DESC | "desc"

bb.common.PackingBoxItemListResult
public static final java.lang.String | ORDER_BY_CUSTOMERID | "pbi.customerId"
public static final java.lang.String | ORDER_BY_PACKINGBOXITEMPK | "pbi.pk.pfInvoiceNumber"
public static final java.lang.String | ORDER_BY_PARTFROM | "pbi.partFrom"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "pbi.partNumber"
public static final java.lang.String | ORDER_BY_PARTTYPE | "pbi.partType"
public static final java.lang.String | ORDER_BY_QUANTITY | "pbi.quantity"
public static final java.lang.String | ORDER_BY_STATUS | "pbi.status"

bb.common.PartBasicInfo
public static final java.lang.String | ORDER_BY_BILL | "ps.bill"
public static final java.lang.String | ORDER_BY_BUYERCODE | "ps.buyerCode"
public static final java.lang.String | ORDER_BY_COMMODITYCODE | "ps.commodityCode"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "ps.description"
public static final java.lang.String | ORDER_BY_DRAWING | "ps.drawing"
public static final java.lang.String | ORDER_BY_HOLD | "ps.hold"
public static final java.lang.String | ORDER_BY_LASTCHANGEDATE | "ps.lastChangeDate"
public static final java.lang.String | ORDER_BY_LASTUSER | "ps.lastUser"
public static final java.lang.String | ORDER_BY_MAKEBUY | "ps.makeBuy"
public static final java.lang.String | ORDER_BY_MODELNUMBER | "ps.modelNumber"
public static final java.lang.String | ORDER_BY_ORGANIZATION | "ps.engGroup"
public static final java.lang.String | ORDER_BY_ORIGIN | "ps.origin"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "ps.pk.partNumber"
public static final java.lang.String | ORDER_BY_PARTTYPE | "ps.pk.partType"
public static final java.lang.String | ORDER_BY_PARTUNIT | "ps.partUnit"
public static final java.lang.String | ORDER_BY_PRODUCTCODE | "ps.productCode"
public static final java.lang.String | ORDER_BY_SECURITYLEVEL | "ps.securityLevel"
public static final java.lang.String | ORDER_BY_WEIGHT | "ps.shippingWeight"

bb.common.PartBasicInfoWithNewEngGroup
public static final java.lang.String | ORDER_BY_AVGCOST | "pt.averageCost"
public static final java.lang.String | ORDER_BY_BUYERCODE | "ps.buyerCode"
public static final java.lang.String | ORDER_BY_COMMODITYCODE | "ps.commodityCode"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "ps.description"
public static final java.lang.String | ORDER_BY_DRAWING | "ps.drawing"
public static final java.lang.String | ORDER_BY_HOLD | "ps.hold"
public static final java.lang.String | ORDER_BY_LISTPRICE | "pt.listPrice"
public static final java.lang.String | ORDER_BY_MODELNUMBER | "ps.modelNumber"
public static final java.lang.String | ORDER_BY_ORGANIZATION | "ps.engGroup"
public static final java.lang.String | ORDER_BY_PARTPK | "ps.pk.partNumber,ps.pk.partType"
public static final java.lang.String | ORDER_BY_PARTUNIT | "ps.partUnit"
public static final java.lang.String | ORDER_BY_SECURITYLEVEL | "ps.securityLevel"
public static final java.lang.String | ORDER_BY_STDCOST | "pt.standardCost"
public static final java.lang.String | ORDER_BY_WEIGHT | "ps.shippingWeight"

bb.common.PartBasicInfoWithNewListPrice
public static final java.lang.String | ORDER_BY_AVGCOST | "pt.averageCost"
public static final java.lang.String | ORDER_BY_BUYERCODE | "ps.buyerCode"
public static final java.lang.String | ORDER_BY_COMMODITYCODE | "ps.commodityCode"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "ps.description"
public static final java.lang.String | ORDER_BY_DRAWING | "ps.drawing"
public static final java.lang.String | ORDER_BY_HOLD | "ps.hold"
public static final java.lang.String | ORDER_BY_LISTPRICE | "pt.listPrice"
public static final java.lang.String | ORDER_BY_MODELNUMBER | "ps.modelNumber"
public static final java.lang.String | ORDER_BY_ORGANIZATION | "ps.engGroup"
public static final java.lang.String | ORDER_BY_PARTPK | "ps.pk.partNumber,ps.pk.partType"
public static final java.lang.String | ORDER_BY_PARTUNIT | "ps.partUnit"
public static final java.lang.String | ORDER_BY_SECURITYLEVEL | "ps.securityLevel"
public static final java.lang.String | ORDER_BY_STDCOST | "pt.standardCost"
public static final java.lang.String | ORDER_BY_WEIGHT | "ps.shippingWeight"

bb.common.PartCertificateListResult
public static final java.lang.String | ORDER_BY_CERTIFICATENUMBER | "cer.certificateNumber"
public static final java.lang.String | ORDER_BY_COMPANYNAME | "cer.companyName"
public static final java.lang.String | ORDER_BY_DOCNAME | "cer.docName"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "cer.partNumber"
public static final java.lang.String | ORDER_BY_PURCHASEORDERNUMBER | "cer.purchaseOrderNumber"
public static final java.lang.String | ORDER_BY_RECEIVERNUMBER | "cer.receiverNumber"
public static final java.lang.String | ORDER_BY_REFERENCENUMBER | "cer.referenceNumber"
public static final java.lang.String | ORDER_BY_SALESORDERNUMBER | "cer.salesOrderNumber"
public static final java.lang.String | ORDER_BY_WORKORDERNUMBER | "cer.workerOrderNumber"

bb.common.PartClassInfoResult
public static final java.lang.String | ORDER_BY_DESCRIPTION | "ps.description"
public static final java.lang.String | ORDER_BY_PART | "ps.pk.partNumber,ps.pk.partType"
public static final java.lang.String | ORDER_BY_PARTCLASS | "pt.partClass"

bb.common.PartClassVO
public static final java.lang.String | ORDER_BY_COMMENTS | "comments"
public static final java.lang.String | ORDER_BY_ID | "id"
public static final java.lang.String | ORDER_BY_LASTCYCLECOUNT | "lastCycleCount"
public static final java.lang.String | ORDER_BY_LOCKED | "locked"
public static final java.lang.String | ORDER_BY_NEXTCYCLECOUNT | "nextCycleCount"
public static final java.lang.String | ORDER_BY_OWNER | "owner"
public static final java.lang.String | ORDER_BY_PERIOD | "period"
public static final java.lang.String | ORDER_BY_PERIODUNIT | "periodUnit"

bb.common.PartCostVarianceListResult
public static final java.lang.String | ORDER_BY_AVERAGECOST | "pt.averageCost"
public static final java.lang.String | ORDER_BY_MAKEBUY | "ps.makeBuy"
public static final java.lang.String | ORDER_BY_PARTDESCRIPTION | "ps.description"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "ps.pk.partNumber,ps.pk.partType"
public static final java.lang.String | ORDER_BY_STANDARDCOST | "pt.standardCost"
public static final java.lang.String | ORDER_BY_VARIANCE | "pt.averageCost-pt.standardCost"
public static final java.lang.String | ORDER_BY_VARIANCEPERCENT | "(pt.averageCost - pt.standardCost)/pt.standardCost*100"

bb.common.PartDwfWithPartInfoResult
public static final java.lang.String | ORDER_BY_DWGEXTENSION | "dwf.dwfExtension"
public static final java.lang.String | ORDER_BY_DWGLENGTH | "dwf.dwfLength"
public static final java.lang.String | ORDER_BY_PARTDESCRIPTION | "ps.description"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "dwf.pk.partNumber"
public static final java.lang.String | ORDER_BY_PARTREVISION | "ps.revision"
public static final java.lang.String | ORDER_BY_REVISION | "dwf.revision"

bb.common.PartDwgWithPartInfoResult
public static final java.lang.String | ORDER_BY_DWGEXTENSION | "dwg.dwgExtension"
public static final java.lang.String | ORDER_BY_DWGLENGTH | "dwg.dwgLength"
public static final java.lang.String | ORDER_BY_PARTDESCRIPTION | "ps.description"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "dwg.pk.partNumber"
public static final java.lang.String | ORDER_BY_PARTREVISION | "ps.revision"
public static final java.lang.String | ORDER_BY_REVISION | "dwg.pk.revision"

bb.common.PartInQAVO
public static final java.lang.String | ORDER_BY_COMMENTS | "comments"
public static final java.lang.String | ORDER_BY_COST | "cost"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "partNumber"
public static final java.lang.String | ORDER_BY_QUANTITY | "quantity"
public static final java.lang.String | ORDER_BY_RECEIVEDBY | "receivedBy"
public static final java.lang.String | ORDER_BY_RECEIVEDDATE | "receivedDate"
public static final java.lang.String | ORDER_BY_RECEIVEDFROM | "receivedFrom"
public static final java.lang.String | ORDER_BY_SERIALNO | "serialNo"

bb.common.PartInspectionResult
public static final java.lang.String | ORDER_BY_INSPECTIONTYPE | "ps.inspectionType"
public static final java.lang.String | ORDER_BY_PARTDESCRIPTION | "ps.description"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "ps.pk.partNumber,ps.pk.partType"

bb.common.PartInspectionVO
public static final java.lang.String | ORDER_BY_INSPECTPROJECT | "inspectProject"
public static final java.lang.String | ORDER_BY_TECHNOLGYSTANDARD | "technolgyStandard"
public static final java.lang.String | ORDER_BY_UNIT | "unit"

bb.common.PartInWipForIDListResult
public static final java.lang.String | ORDER_BY_DESCRIPTION | "woi.description"
public static final java.lang.String | ORDER_BY_PART | "woi.partNumber,woi.partType"
public static final java.lang.String | ORDER_BY_PARTINWIP | "wois.partNumber,wois.partType"
public static final java.lang.String | ORDER_BY_PARTINWIPDESCRIPTION | "part_in_wip_description"
public static final java.lang.String | ORDER_BY_VENDORID | "wo.vendorId"
public static final java.lang.String | ORDER_BY_WORKORDERNUMBER | "wois.pk.workOrderNumber"

bb.common.PartIssuedListResult
public static final java.lang.String | ORDER_BY_CURRENCY | "wo.currency"
public static final java.lang.String | ORDER_BY_DATEISSUED | "pis.dateIssued"
public static final java.lang.String | ORDER_BY_DATEREQUIRED | "woi.dateRequired"
public static final java.lang.String | ORDER_BY_LOCATE | "pis.locate"
public static final java.lang.String | ORDER_BY_ORDERNUMBER | "pis.orderNumber,pis.itemNumber"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "pis.partNumber"
public static final java.lang.String | ORDER_BY_project | "wo.project"
public static final java.lang.String | ORDER_BY_RELATEDDOC | "woi.relatedDoc"
public static final java.lang.String | ORDER_BY_TRANSACTIONNUMBER | "pis.transactionNumber"
public static final java.lang.String | ORDER_BY_VENDORID | "pis.vendorId"
public static final java.lang.String | ORDER_BY_WORKORDERNUMBER | "pis.workOrderNumber,pis.workOrderItemNumber"

bb.common.PartIssuedVO
public static final java.lang.String | ORDER_BY_DATEISSUED | "pis.dateIssued"
public static final java.lang.String | ORDER_BY_LOCATE | "pis.locate"
public static final java.lang.String | ORDER_BY_ORDERNUMBER | "pis.orderNumber,pis.itemNumber"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "pis.partNumber"
public static final java.lang.String | ORDER_BY_PICKER | "pis.picker"
public static final java.lang.String | ORDER_BY_TRANSACTIONNUMBER | "pis.transactionNumber"
public static final java.lang.String | ORDER_BY_VENDORID | "pis.vendorId"
public static final java.lang.String | ORDER_BY_WORKORDERNUMBER | "pis.workOrderNumber,pis.workOrderItemNumber"

bb.common.PartOnhandResult
public static final java.lang.String | ORDER_BY_DESCRIPTION | "ps.description"
public static final java.lang.String | ORDER_BY_INSIP | "pt.shipInProcessQty"
public static final java.lang.String | ORDER_BY_INWIP | "pt.workInProcessQty"
public static final java.lang.String | ORDER_BY_LASTOUTDATE | "pt.lastOutDate"
public static final java.lang.String | ORDER_BY_LOCATE | "p.pk.location, p.pk.partNumber"
public static final java.lang.String | ORDER_BY_ONLOAN | "pt.onloanQty"
public static final java.lang.String | ORDER_BY_PART | "ps.pk.partNumber"
public static final java.lang.String | ORDER_BY_PARTTYPE | "ps.pk.partType"
public static final java.lang.String | ORDER_BY_PARTUNIT | "ps.partUnit"
public static final java.lang.String | ORDER_BY_SHIPPINGWEIGHT | "ps.shippingWeight"

bb.common.PartOnhandVO
public static final java.lang.String | ORDER_BY_LOCATION | "pk.location"
public static final java.lang.String | ORDER_BY_MODELNUMBER | "modelNumber"
public static final java.lang.String | ORDER_BY_ONHANDQUANTITY | "onHandQuantity"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "pk.partNumber"

bb.common.PartOnHandWithMfgInfoResult
public static final java.lang.String | ORDER_BY_AVERAGECOST | "pt.averageCost"
public static final java.lang.String | ORDER_BY_BILL | "ps.bill"
public static final java.lang.String | ORDER_BY_BUYERCODE | "ps.buyerCode"
public static final java.lang.String | ORDER_BY_COMMODITYCODE | "ps.commodityCode"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "ps.description"
public static final java.lang.String | ORDER_BY_DRAWING | "ps.drawing"
public static final java.lang.String | ORDER_BY_HOLD | "ps.hold"
public static final java.lang.String | ORDER_BY_INSIP | "pt.shipInProcessQty"
public static final java.lang.String | ORDER_BY_INSIT | "pt.shipInTransactionQty"
public static final java.lang.String | ORDER_BY_INWIP | "pt.workInProcessQty"
public static final java.lang.String | ORDER_BY_MANUFACTURERID | "pm.manufacturerId"
public static final java.lang.String | ORDER_BY_MANUFACTURERNAME | "pm.manufacturerName"
public static final java.lang.String | ORDER_BY_MANUFACTURERPARTNUMBER | "pm.manufacturerPartNumber"
public static final java.lang.String | ORDER_BY_MODELNUMBER | "ps.modelNumber"
public static final java.lang.String | ORDER_BY_ONDEMAND | "pt.onDemandQty"
public static final java.lang.String | ORDER_BY_ONHAND | "pt.onhand"
public static final java.lang.String | ORDER_BY_ONORDER | "pt.onOrderQty"
public static final java.lang.String | ORDER_BY_ORGANIZATION | "ps.engGroup"
public static final java.lang.String | ORDER_BY_PARTPK | "ps.pk.partNumber,ps.pk.partType"
public static final java.lang.String | ORDER_BY_PARTTYPE | "ps.pk.partType,ps.pk.partNumber"
public static final java.lang.String | ORDER_BY_PARTUNIT | "ps.partUnit"
public static final java.lang.String | ORDER_BY_REVISION | "ps.revision"
public static final java.lang.String | ORDER_BY_SECURITYLEVEL | "ps.securityLevel"
public static final java.lang.String | ORDER_BY_STANDARDCOST | "pt.standardCost"
public static final java.lang.String | ORDER_BY_WEIGHT | "ps.shippingWeight"

bb.common.PartOnHandWithPartBasicInfoResult
public static final java.lang.String | ORDER_BY_BUYERCODE | "ps.buyerCode"
public static final java.lang.String | ORDER_BY_COMMODITYCODE | "ps.commodityCode"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "ps.description"
public static final java.lang.String | ORDER_BY_DRAWING | "ps.drawing"
public static final java.lang.String | ORDER_BY_HOLD | "ps.hold"
public static final java.lang.String | ORDER_BY_MODELNUMBER | "ps.modelNumber"
public static final java.lang.String | ORDER_BY_ONDEMANDQTY | "pt.onDemandQty"
public static final java.lang.String | ORDER_BY_ONHAND | "pt.onhand"
public static final java.lang.String | ORDER_BY_ONORDERQTY | "pt.onOrderQty"
public static final java.lang.String | ORDER_BY_ORGANIZATION | "ps.engGroup"
public static final java.lang.String | ORDER_BY_PARTPK | "ps.pk.partNumber,ps.pk.partType"
public static final java.lang.String | ORDER_BY_PARTUNIT | "ps.partUnit"
public static final java.lang.String | ORDER_BY_SECURITYLEVEL | "ps.securityLevel"
public static final java.lang.String | ORDER_BY_WEIGHT | "ps.shippingWeight"

bb.common.PartReceivedListResult
public static final java.lang.String | ORDER_BY_CURRENCY | "wo.currency"
public static final java.lang.String | ORDER_BY_DATEISSUED | "pre.dateReceived"
public static final java.lang.String | ORDER_BY_ORDERNUMBER | "pre.orderNumber,pre.itemNumber"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "pre.partNumber"
public static final java.lang.String | ORDER_BY_project | "wo.project"
public static final java.lang.String | ORDER_BY_RELATEDDOC | "woi.relatedDoc"
public static final java.lang.String | ORDER_BY_VENDORID | "pre.vendorId"
public static final java.lang.String | ORDER_BY_WORKORDERNUMBER | "pre.disassembleWorkOrderNumber,pre.disassembleWorkOrderItemNumber"

bb.common.PartReceivedVO
public static final java.lang.String | ORDER_BY_DATEISSUED | "pir.dateIssued"
public static final java.lang.String | ORDER_BY_DISASSEMBLEWORKORDERNUMBER | "pir.disassembleWorkOrderNumber"
public static final java.lang.String | ORDER_BY_LOCATE | "pir.locate"
public static final java.lang.String | ORDER_BY_ORDERNUMBER | "pir.orderNumber,pir.itemNumber"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "pir.partNumber"
public static final java.lang.String | ORDER_BY_TRANSACTIONNUMBER | "pir.transactionNumber"
public static final java.lang.String | ORDER_BY_VENDORID | "pir.vendorId"
public static final java.lang.String | ORDER_BY_WORKORDERNUMBER | "pir.disassembleWorkOrderNumber,pis.disassembleWorkOrderItemNumber"

bb.common.PartSecurityLevelVO
public static final java.lang.String | ORDER_BY_LEVELDESCRIPTION | "levelDescription"
public static final java.lang.String | ORDER_BY_LEVELID | "levelId"

bb.common.PartTraceableResult
public static final java.lang.String | ORDER_BY_CATEGORYID | "cat.categoryId"
public static final java.lang.String | ORDER_BY_SPECIFICATIONID | "spec.specificationId"
public static final java.lang.String | ORDER_BY_TRACEABLELEVEL | "ps.traceableLevel"

bb.common.PartTypeVO
public static final java.lang.String | ORDER_BY_DESCRIPTION | "pa.description"
public static final java.lang.String | ORDER_BY_ID | "pa.id"
public static final java.lang.String | ORDER_BY_PARTTYPE | "pa.partType"

bb.common.PartUseTypeVO
public static final java.lang.String | ORDER_BY_DESCRIPTION | "description"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "partNumber,partType"
public static final java.lang.String | ORDER_BY_PARTTYPE | "partType,partNumber"
public static final java.lang.String | ORDER_BY_USETYPE | "useType"

bb.common.PartWithExcessiveInventoryListResult
public static final java.lang.String | ORDER_BY_AVGCOST | "pt.averageCost"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "ps.description"
public static final java.lang.String | ORDER_BY_EXCESSIVEQTY | "pt.onhand+pt.onOrderQty-pt.onDemandQty"
public static final java.lang.String | ORDER_BY_EXCESSIVETOTALAVGCOST | "pt.averageCost*(pt.onhand+pt.onOrderQty-pt.onDemandQty)"
public static final java.lang.String | ORDER_BY_EXCESSIVETOTALSTDCOST | "pt.standardCost*(pt.onhand+pt.onOrderQty-pt.onDemandQty)"
public static final java.lang.String | ORDER_BY_MAXQTY | "pt.maxQty"
public static final java.lang.String | ORDER_BY_MINQTY | "pt.minQty"
public static final java.lang.String | ORDER_BY_ONDEMAND | "pt.onDemandQty"
public static final java.lang.String | ORDER_BY_ONHAND | "pt.onhand"
public static final java.lang.String | ORDER_BY_ONORDER | "pt.onOrderQty"
public static final java.lang.String | ORDER_BY_PARTPK | "pt.pk.partNumber"
public static final java.lang.String | ORDER_BY_QRQTY | "pt.quarterUsage"
public static final java.lang.String | ORDER_BY_STDCOST | "pt.standardCost"
public static final java.lang.String | ORDER_BY_YRQTY | "pt.yearUsage"

bb.common.PartWithInventoryInfoListResult
public static final java.lang.String | ORDER_BY_BUYERCODE | "ps.buyerCode"
public static final java.lang.String | ORDER_BY_INWIP | "pt.workInProcessQty"
public static final java.lang.String | ORDER_BY_ONDEMAND | "pt.onDemandQty"
public static final java.lang.String | ORDER_BY_ONHAND | "pt.onhand"
public static final java.lang.String | ORDER_BY_ONORDER | "pt.onOrderQty"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "ps.pk.partNumber"
public static final java.lang.String | ORDER_BY_PARTTYPE | "ps.pk.partType"
public static final java.lang.String | ORDER_BY_UNIT | "ps.partUnit"

bb.common.PartWithManufacturerInfoResult
public static final java.lang.String | ORDER_BY_BILL | "ps.bill"
public static final java.lang.String | ORDER_BY_MANUFACTURERID | "pm.manufacturerId"
public static final java.lang.String | ORDER_BY_MANUFACTURERNAME | "pm.manufacturerName"
public static final java.lang.String | ORDER_BY_MANUFACTURERPARTNUMBER | "pm.manufacturerPartNumber"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "ps.pk.partNumber"
public static final java.lang.String | ORDER_BY_PARTTYPE | "ps.pk.partType"

bb.common.PartWithOnLoanQtyListResult
public static final java.lang.String | ORDER_BY_AVGCOST | "pt.averageCost"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "ps.description"
public static final java.lang.String | ORDER_BY_ONLOANQTY | "pt.onloanQty"
public static final java.lang.String | ORDER_BY_PARTPK | "ps.pk.partNumber"
public static final java.lang.String | ORDER_BY_STDCOST | "pt.standardCost"
public static final java.lang.String | ORDER_BY_TOTALAVGCOST | "pt.averageCost*pt.onloanQty"
public static final java.lang.String | ORDER_BY_TOTALSTDCOST | "pt.standardCost*pt.onloanQty"

bb.common.PartWithoutLocateResult
public static final java.lang.String | ORDER_BY_BUYERCODE | "ps.buyerCode"
public static final java.lang.String | ORDER_BY_COMMODITYCODE | "ps.commodityCode"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "ps.description"
public static final java.lang.String | ORDER_BY_DRAWING | "ps.drawing"
public static final java.lang.String | ORDER_BY_HOLD | "ps.hold"
public static final java.lang.String | ORDER_BY_MODELNUMBER | "ps.modelNumber"
public static final java.lang.String | ORDER_BY_ONHAND | "ps.partInventory.onhand"
public static final java.lang.String | ORDER_BY_PARTPK | "ps.pk.partNumber,ps.pk.partType"
public static final java.lang.String | ORDER_BY_PARTUNIT | "ps.partUnit"
public static final java.lang.String | ORDER_BY_WEIGHT | "ps.shippingWeight"

bb.common.PartWithQAQtyListResult
public static final java.lang.String | ORDER_BY_AVGCOST | "pt.averageCost"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "ps.description"
public static final java.lang.String | ORDER_BY_INQAQTY | "pt.inQualityCheckingQty"
public static final java.lang.String | ORDER_BY_LISTPRICE | "pt.listPrice"
public static final java.lang.String | ORDER_BY_PARTPK | "ps.pk.partNumber"
public static final java.lang.String | ORDER_BY_STDCOST | "pt.standardCost"

bb.common.PartWithQtyListResult
public static final java.lang.String | ORDER_BY_AVGCOST | "pt.averageCost"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "ps.description"
public static final java.lang.String | ORDER_BY_LISTPRICE | "pt.listPrice"
public static final java.lang.String | ORDER_BY_ONHAND | "pt.onhand"
public static final java.lang.String | ORDER_BY_PARTPK | "ps.pk.partNumber"
public static final java.lang.String | ORDER_BY_STDCOST | "pt.standardCost"

bb.common.PartWithSipQtyListResult
public static final java.lang.String | ORDER_BY_AVGCOST | "pt.averageCost"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "ps.description"
public static final java.lang.String | ORDER_BY_LISTPRICE | "pt.listPrice"
public static final java.lang.String | ORDER_BY_ONHAND | "pt.onhand"
public static final java.lang.String | ORDER_BY_PARTPK | "ps.pk.partNumber"
public static final java.lang.String | ORDER_BY_SHIPINPROCESSQTY | "pt.shipInProcessQty"
public static final java.lang.String | ORDER_BY_STDCOST | "pt.standardCost"

bb.common.PartWithSITQtyListResult
public static final java.lang.String | ORDER_BY_AVGCOST | "pt.averageCost"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "ps.description"
public static final java.lang.String | ORDER_BY_LISTPRICE | "pt.listPrice"
public static final java.lang.String | ORDER_BY_ONHAND | "pt.onhand"
public static final java.lang.String | ORDER_BY_PARTPK | "ps.pk.partNumber"
public static final java.lang.String | ORDER_BY_SHIPINPROCESSQTY | "pt.shipInProcessQty"
public static final java.lang.String | ORDER_BY_STDCOST | "pt.standardCost"

bb.common.PartWithSTOQtyListResult
public static final java.lang.String | ORDER_BY_AVGCOST | "pt.averageCost"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "ps.description"
public static final java.lang.String | ORDER_BY_INQAQTY | "pt.inSTO"
public static final java.lang.String | ORDER_BY_LISTPRICE | "pt.listPrice"
public static final java.lang.String | ORDER_BY_PARTPK | "ps.pk.partNumber"
public static final java.lang.String | ORDER_BY_STDCOST | "pt.standardCost"

bb.common.PartWithWipQtyListResult
public static final java.lang.String | ORDER_BY_AVGCOST | "wois.cost"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "ps.ed"
public static final java.lang.String | ORDER_BY_INWIPQTY | "wip"
public static final java.lang.String | ORDER_BY_LISTPRICE | "pt.list_price"
public static final java.lang.String | ORDER_BY_PARTPK | "ps.pn"
public static final java.lang.String | ORDER_BY_STDCOST | "pt.std_cost"

bb.common.PayableMethodVO
public static final java.lang.String | ORDER_BY_CHECKACCOUNTNUMBER | "checkAccountNumber"
public static final java.lang.String | ORDER_BY_COMPANYUNITID | "companyUnitId"
public static final java.lang.String | ORDER_BY_PAYABLEMETHODID | "payableMethodID"
public static final java.lang.String | ORDER_BY_PAYABLEMETHODNAME | "payableMethodName"

bb.common.PaymentHistoryVO
public static final java.lang.String | ORDER_BY_ADDRESSID | "addressId"
public static final java.lang.String | ORDER_BY_ADDRESSNAME | "addressName"
public static final java.lang.String | ORDER_BY_APDUEDAYS | "apDueDays"
public static final java.lang.String | ORDER_BY_ARDUEDAYS | "arDueDays"
public static final java.lang.String | ORDER_BY_CUSTOMERSALES | "customerSales"
public static final java.lang.String | ORDER_BY_VENDORPURCHASES | "vendorPurchases"

bb.common.PermissionException
public static final java.lang.String INSUFFICIENT_PERMISSION "INSUFFICIENT_PERMISSION"

bb.common.PermissionListResult
public static final java.lang.String | ORDER_BY_DESCRIPTION | "per_des.description"
public static final java.lang.String | ORDER_BY_PERMISSIONID | "per.permissionId"
public static final java.lang.String | ORDER_BY_PERMISSIONNAME | "per_des.permissionName"

bb.common.PermissionVO
public static final java.lang.String ORDER_BY_PERMISSIONID "permissionId"

bb.common.PhysicalInventoryListResult
public static final java.lang.String | ORDER_BY_AVGCOST | "pt.averageCost"
public static final java.lang.String | ORDER_BY_COMMITTED | "pi.committed"
public static final java.lang.String | ORDER_BY_COUNTEDBY | "pi.countedBy"
public static final java.lang.String | ORDER_BY_COUNTEDDATE | "pi.countedDate"
public static final java.lang.String | ORDER_BY_DIFFCOUNT | "pi.diffCount"
public static final java.lang.String | ORDER_BY_INQUALITYCHECKINGQTY | "pi.inQualityCheckingQty"
public static final java.lang.String | ORDER_BY_LOCATION | "pi.locate"
public static final java.lang.String | ORDER_BY_NEWONHAND | "pi.newOnhand"
public static final java.lang.String | ORDER_BY_oldAvgCost | "pi.averageCost"
public static final java.lang.String | ORDER_BY_oldOnloanQty | "pi.onloanQty"
public static final java.lang.String | ORDER_BY_oldSip | "pi.shipInProcessQty"
public static final java.lang.String | ORDER_BY_oldStadCost | "pi.standardCost"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "pi.partNumber"
public static final java.lang.String | ORDER_BY_PK | "pi.pk.workSheetNumber"
public static final java.lang.String | ORDER_BY_STARTDATE | "pi.physicalInventoryDate"
public static final java.lang.String | ORDER_BY_SYSTEMONHAND | "pi.onhand"
public static final java.lang.String | ORDER_BY_TAGNUMBER | "pi.tagNumber"
public static final java.lang.String | ORDER_BY_WORKINPROCESSQTY | "pi.workInProcessQty"

bb.common.PhysicalInventoryListWithAppDataResult
public static final java.lang.String | ORDER_BY_APPDAMAGED | "pi.appDamaged"
public static final java.lang.String | ORDER_BY_APPNORMAL | "pi.appNormal"
public static final java.lang.String | ORDER_BY_APPOBSOLETE | "pi.appObsolete"
public static final java.lang.String | ORDER_BY_APPOTHER | "pi.appOther"
public static final java.lang.String | ORDER_BY_APPSLUGGISH | "pi.appSluggish"
public static final java.lang.String | ORDER_BY_MODELNUMBER | "ps.modelNumber"
public static final java.lang.String | ORDER_BY_NEWAPPDAMAGED | "pi.newAppDamaged"
public static final java.lang.String | ORDER_BY_NEWAPPNORMAL | "pi.newAppNormal"
public static final java.lang.String | ORDER_BY_NEWAPPOBSOLETE | "pi.newAppObsolete"
public static final java.lang.String | ORDER_BY_NEWAPPOTHER | "pi.newAppOther"
public static final java.lang.String | ORDER_BY_NEWAPPSLUGGISH | "pi.newAppSluggish"

bb.common.PhysicalInventoryStatusVO
public static final java.lang.String | ORDER_BY_CREATEDATE | "createDate"
public static final java.lang.String | ORDER_BY_CREATOR | "creator"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "description"
public static final java.lang.String | ORDER_BY_STATUS | "status"
public static final java.lang.String | ORDER_BY_TOTALPAGES | "totalPages"
public static final java.lang.String | ORDER_BY_WORKSHEETNUMBER | "workSheetNumber"

bb.common.PoMessageListResult
public static final java.lang.String | ORDER_BY_POMESSAGENUMBER | "pom.poMessageNumber"
public static final java.lang.String | ORDER_BY_PONUMBER | "pom.poNumber"
public static final java.lang.String | ORDER_BY_STATUS | "pom.status"
public static final java.lang.String | ORDER_BY_VENDORID | "pom.vendorId"

bb.common.POReceiverItemListResult
public static final java.lang.String | ORDER_BY_ACCOUNTNUMBER | "por.debitAccount"
public static final java.lang.String | ORDER_BY_BUYER | "por.buyer"
public static final java.lang.String | ORDER_BY_BUYERCODE | "ps.buyerCode"
public static final java.lang.String | ORDER_BY_COMPANYNUITID | "por.companyUnitId"
public static final java.lang.String | ORDER_BY_COSTPERUNIT | "poir.costPerUnit"
public static final java.lang.String | ORDER_BY_CURRENCY | "por.currency"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "poi.description"
public static final java.lang.String | ORDER_BY_DISCOUNT | "poir.discount"
public static final java.lang.String | ORDER_BY_EXCHANGE | "por.exchange"
public static final java.lang.String | ORDER_BY_EXTENDEDCOST | "poir.extendPrice"
public static final java.lang.String | ORDER_BY_ITEMNUMBER | "poir.pk.receiverItemNumber"
public static final java.lang.String | ORDER_BY_LOCATION | "poir.location"
public static final java.lang.String | ORDER_BY_LOCATIONS | "poir.locations"
public static final java.lang.String | ORDER_BY_ORIGIALSHIPDATE | "poi.original"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "poir.partNumber"
public static final java.lang.String | ORDER_BY_PONUMBER | "poi.pk.purchaseOrderNumber"
public static final java.lang.String | ORDER_BY_PORECEIVED | "poi.quantityReceived"
public static final java.lang.String | ORDER_BY_POSHIPDATE | "poi.dateRequired"
public static final java.lang.String | ORDER_BY_PROJECTNAME | "por.projectName"
public static final java.lang.String | ORDER_BY_QTYORDERED | "poi.quantityOrdered"
public static final java.lang.String | ORDER_BY_QTYRECEIVED | "poir.quantityReceived"
public static final java.lang.String | ORDER_BY_RECEIVEDDATE | "por.dateReceived"
public static final java.lang.String | ORDER_BY_RECEIVERNUMBER | "poir.pk.receiverNumber,poir.pk.receiverItemNumber"
public static final java.lang.String | ORDER_BY_STANDARDCOST | "pi.standardCost"
public static final java.lang.String | ORDER_BY_STATUS | "poir.status"
public static final java.lang.String | ORDER_BY_TAXRATE | "poir.taxRate"
public static final java.lang.String | ORDER_BY_VENDORID | "por.vendorId"
public static final java.lang.String | ORDER_BY_VENDORPACKAGE | "por.vendorPackage"
public static final java.lang.String | ORDER_BY_VENDORSHIPDATE | "por.vendorShipDate"

bb.common.POStatisticsResult
public static final java.lang.String | ORDER_BY_GRANTTOTAL | "po.grantTotal"
public static final java.lang.String | ORDER_BY_PODATE | "po.poDate"
public static final java.lang.String | ORDER_BY_PONUMBER | "po.purchaseOrderNumber"
public static final java.lang.String | ORDER_BY_PROJECT | "po.projectName"
public static final java.lang.String | ORDER_BY_RELATEDDOC | "po.relatedDoc"
public static final java.lang.String | ORDER_BY_TOTALFREIGHT | "po.totalFreight"
public static final java.lang.String | ORDER_BY_TOTALTAX | "po.totalTax"
public static final java.lang.String | ORDER_BY_VENDORID | "po.vendorId"
public static final java.lang.String | ORDER_BY_VENDORNAME | "ab.name"
public static final java.lang.String | ORDER_BY_VENDORSALESORDER | "po.vendorSalesOrder"

bb.common.POSurveyReportVO
public static final java.lang.String | ORDER_BY_CONTRACTNUMBER | "contractNumber"
public static final java.lang.String | ORDER_BY_ENGACCEPTEMPLOYEE | "engAcceptEmployee"
public static final java.lang.String | ORDER_BY_POACCEPTEMPLOYEE | "poAcceptEmployee"
public static final java.lang.String | ORDER_BY_PROJECTNAME | "projectName"
public static final java.lang.String | ORDER_BY_PURCHASEORDERNUMBER | "purchaseOrderNumber"
public static final java.lang.String | ORDER_BY_QAACCEPTEMPLOYEE | "qaAcceptEmployee"
public static final java.lang.String | ORDER_BY_SRNUMBER | "srNumber"
public static final java.lang.String | ORDER_BY_VENDORID | "vendorId"
public static final java.lang.String | ORDER_BY_VENDORNAME | "vendorName"
public static final java.lang.String | ORDER_BY_VENDORSALESORDER | "vendorSalesOrder"
public static final java.lang.String | ORDER_BY_WAREACCEPTEMPLOYEE | "wareAcceptEmployee"

bb.common.PosZipCodeTaxVO
public static final java.lang.String | ORDER_BY_CITYCODE | "zt.cityCode"
public static final java.lang.String | ORDER_BY_COUNTYCODE | "zt.countyCode"
public static final java.lang.String | ORDER_BY_TAX | "zt.tax"
public static final java.lang.String | ORDER_BY_ZIPCODE | "zt.zipCode"

bb.common.PreventiveActionRequestVO
public static final java.lang.String | ORDER_BY_DATEENTERED | "par.dateEntered"
public static final java.lang.String | ORDER_BY_DEPARTMENTID | "par.departmentId"
public static final java.lang.String | ORDER_BY_DEPARTMENTNAME | "par.departmentName"
public static final java.lang.String | ORDER_BY_DUEDATE | "par.dueDate"
public static final java.lang.String | ORDER_BY_LASTCHANGEDATE | "par.lastChangeDate"
public static final java.lang.String | ORDER_BY_LASTCHANGEUSER | "par.lastChangeUser"
public static final java.lang.String | ORDER_BY_PARNUMBER | "par.parNumber"
public static final java.lang.String | ORDER_BY_STATUS | "par.status"

bb.common.PrintLogoVO
public static final java.lang.String | ORDER_BY_EXTENSION | "pl.extension"
public static final java.lang.String | ORDER_BY_LENGTH | "pl.length"
public static final java.lang.String | ORDER_BY_LOGONAME | "pl.logoName"

bb.common.ProformaInvoiceItemListResult
public static final java.lang.String | ORDER_BY_CUSTOMERID | "pfi.customerId"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "pfi.description"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "pfi.partNumber"
public static final java.lang.String | ORDER_BY_PFINVOICENUMBER | "pfi.pk.pfInvoiceNumber,pfi.pfInvoiceItemNumber"
public static final java.lang.String | ORDER_BY_PURCHASEORDERNUMBER | "pfi.purchaseOrderNumber"
public static final java.lang.String | ORDER_BY_SALESORDERNUMBER | "pfi.pk.salesOrderNumber,pfi.pk.salesOrderItem"
public static final java.lang.String | ORDER_BY_STATUS | "pf.status"

bb.common.ProformaInvoiceListResult
public static final java.lang.String | ORDER_BY_BILLTOID | "pf.billTo"
public static final java.lang.String | ORDER_BY_CUSTOMERID | "pf.customerId"
public static final java.lang.String | ORDER_BY_CUSTOMERPO | "pf.customerPO"
public static final java.lang.String | ORDER_BY_DATESHIPPED | "pf.shipped"
public static final java.lang.String | ORDER_BY_GRANTTOTAL | "pf.arTotal"
public static final java.lang.String | ORDER_BY_PFNUMBER | "pf.pfInvoiceNumber"
public static final java.lang.String | ORDER_BY_SHIPTOID | "pf.shipTo"
public static final java.lang.String | ORDER_BY_STATUS | "pf.status"

bb.common.PrReceiverListResult
public static final java.lang.String | ORDER_BY_BUYER | "pr.buyer"
public static final java.lang.String | ORDER_BY_COMMENTS | "pr.comments"
public static final java.lang.String | ORDER_BY_CONTACT | "pr.contact"
public static final java.lang.String | ORDER_BY_DATERECEIVED | "pr.adate"
public static final java.lang.String | ORDER_BY_PRIVATENOTES | "pr.privateNotes"
public static final java.lang.String | ORDER_BY_PRNUMBER | "pr.pfReceiverNumber"
public static final java.lang.String | ORDER_BY_RELATEDDOC | "pr.relatedDoc"
public static final java.lang.String | ORDER_BY_STATUS | "pr.status"
public static final java.lang.String | ORDER_BY_VENDORID | "pr.vendorId"
public static final java.lang.String | ORDER_BY_VENDORNAME | "pr.vendorAddressInfo.name"
public static final java.lang.String | ORDER_BY_VENDORSO | "pr.vendorSO"

bb.common.PurchaseOrderApprovalVO
public static final java.lang.String | ORDER_BY_APPROVELIMIT | "approveLimit"
public static final java.lang.String | ORDER_BY_CANAPPROVEOWNPURCHASEORDER | "canApproveOwnPurchaseOrder"
public static final java.lang.String | ORDER_BY_CURRENCY | "currency"
public static final java.lang.String | ORDER_BY_EMPLOYEEID | "employeeId"
public static final java.lang.String | ORDER_BY_USERNAME | "userName"

bb.common.PurchaseOrderBoilerplateVO
public static final java.lang.String | ORDER_BY_BOILERPLATEID | "tt.boilerplateId"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "tt.description"
public static final java.lang.String | ORDER_BY_POBOILERPLATE | "tt.poBoilerplate"

bb.common.PurchaseOrderCheckListResult
public static final java.lang.String | ORDER_BY_DELIVERY | "po.dateRequired"
public static final java.lang.String | ORDER_BY_PODATE | "po.poDate"
public static final java.lang.String | ORDER_BY_PONUMBER | "po.purchaseOrderNumber"
public static final java.lang.String | ORDER_BY_VENDORID | "po.vendorId"

bb.common.PurchaseOrderItemListResult
public static final java.lang.String | ORDER_BY_ACCOUNTNUMBER | "po.debitAccount"
public static final java.lang.String | ORDER_BY_APOPEN | "poi.apOpen"
public static final java.lang.String | ORDER_BY_APRECEIVED | "poi.apReceived"
public static final java.lang.String | ORDER_BY_ARRIVEDATE | "poi.arriveDate"
public static final java.lang.String | ORDER_BY_BUYER | "po.buyer"
public static final java.lang.String | ORDER_BY_COMPANYNUITID | "po.companyUnitId"
public static final java.lang.String | ORDER_BY_COSTPERUNIT | "poi.costPerUnit"
public static final java.lang.String | ORDER_BY_CURRENCY | "po.currency"
public static final java.lang.String | ORDER_BY_DELEVERYDATE | "poi.dateRequired"
public static final java.lang.String | ORDER_BY_DISCOUNT | "poi.discount"
public static final java.lang.String | ORDER_BY_EXTENDPRICE | "poi.apNet"
public static final java.lang.String | ORDER_BY_LASTRECEIVEDATE | "poi.actual"
public static final java.lang.String | ORDER_BY_ORDERQTY | "poi.quantityOrdered"
public static final java.lang.String | ORDER_BY_PARTPK | "poi.partNumber"
public static final java.lang.String | ORDER_BY_PODATE | "po.poDate"
public static final java.lang.String | ORDER_BY_PONUMBER | "poi.pk.purchaseOrderNumber"
public static final java.lang.String | ORDER_BY_PRODUCTCODE | "poi.productCode"
public static final java.lang.String | ORDER_BY_PROJECT | "po.projectName"
public static final java.lang.String | ORDER_BY_RECEIVEDQTY | "poi.quantityReceived"
public static final java.lang.String | ORDER_BY_RELATEDDOC | "po.relatedDoc"
public static final java.lang.String | ORDER_BY_REQUESTER | "po.requester"
public static final java.lang.String | ORDER_BY_SHIPTO | "po.shipToId"
public static final java.lang.String | ORDER_BY_VENDORID | "po.vendorId"

bb.common.PurchaseOrderListResult
public static final java.lang.String | ORDER_BY_ACKNOWLEDGEDATE | "po.acknowledgeDate"
public static final java.lang.String | ORDER_BY_BUYERNAME | "po.buyer"
public static final java.lang.String | ORDER_BY_COMMENTS | "po.purchaseOrderComments"
public static final java.lang.String | ORDER_BY_PODATE | "po.poDate"
public static final java.lang.String | ORDER_BY_PONUMBER | "po.purchaseOrderNumber"
public static final java.lang.String | ORDER_BY_POSTATUS | "po.status"
public static final java.lang.String | ORDER_BY_PROJECT | "po.projectName"
public static final java.lang.String | ORDER_BY_RELATEDDOC | "po.relatedDoc"
public static final java.lang.String | ORDER_BY_REQUESTER | "po.requester"
public static final java.lang.String | ORDER_BY_VENDORID | "po.vendorId"
public static final java.lang.String | ORDER_BY_VENDORNAME | "ab.name"

bb.common.PurchaseOrderOnTimeItemResult
public static final java.lang.String | FISCAL_YEAR | "Fiscal Year"
public static final java.lang.String | MONTH_12_AVG | "12 Month Avg"
public static final java.lang.String | YEAR_TO_DATE | "Year to Date"

bb.common.PurchaseOrderOpenDueListResult
public static final java.lang.String | ORDER_BY_BUYER | "po.buyer"
public static final java.lang.String | ORDER_BY_DELEVERYDATE | "poi.dateRequired"
public static final java.lang.String | ORDER_BY_DUEDATE | "poi.arriveDate"
public static final java.lang.String | ORDER_BY_PARTPK | "poi.partNumber"
public static final java.lang.String | ORDER_BY_PODATE | "po.poDate"
public static final java.lang.String | ORDER_BY_PONUMBER | "poi.pk.purchaseOrderNumber"
public static final java.lang.String | ORDER_BY_SHIPPINGSTATUS | "poi.shippingStatus"
public static final java.lang.String | ORDER_BY_SHIPVIA | "poi.shipVia"
public static final java.lang.String | ORDER_BY_VENDORID | "po.vendorId"

bb.common.PurchaseWorkSheetVO
public static final java.lang.String | ORDER_BY_COMPANYUNITID | "companyUnitId"
public static final java.lang.String | ORDER_BY_DUEDATE | "dueDate"
public static final java.lang.String | ORDER_BY_EMPLOYEEEMAIL | "employeeEmail"
public static final java.lang.String | ORDER_BY_PK | "pk.workSheetNumber"

bb.common.QuoteBoilerplateVO
public static final java.lang.String | ORDER_BY_BOILERPLATEID | "tt.boilerplateId"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "tt.description"
public static final java.lang.String | ORDER_BY_QTBOILERPLATE | "tt.qtBoilerplate"

bb.common.QuoteItemListResult
public static final java.lang.String | ORDER_BY_CUSTOMERID | "qt.customerId"
public static final java.lang.String | ORDER_BY_CUSTOMERRFQNUMBER | "qt.customerRefNumber"
public static final java.lang.String | ORDER_BY_PARTPK | "qti.partNumber"
public static final java.lang.String | ORDER_BY_QTDATE | "qt.quoteDate"
public static final java.lang.String | ORDER_BY_QTITEMNUMBER | "qti.pk.quoteItemNumber"
public static final java.lang.String | ORDER_BY_QTNUMBER | "qti.pk.quoteNumber"
public static final java.lang.String | ORDER_BY_STATUS | "qti.status"

bb.common.QuoteListResult
public static final java.lang.String | ORDER_BY_CHANGEORDER | "qt.changeOrder"
public static final java.lang.String | ORDER_BY_COMMENTS | "qt.quoteComments"
public static final java.lang.String | ORDER_BY_CUSTOMERID | "qt.customerId"
public static final java.lang.String | ORDER_BY_CUSTOMERREFNUMBER | "qt.customerRefNumber"
public static final java.lang.String | ORDER_BY_OURREFQUOTE | "qt.salesGroutQuoteNumber"
public static final java.lang.String | ORDER_BY_PRIVATENOTE | "qt.quotePrivateNotes"
public static final java.lang.String | ORDER_BY_PROJECT | "qt.projectName"
public static final java.lang.String | ORDER_BY_QTDATE | "qt.quoteDate"
public static final java.lang.String | ORDER_BY_QTNUMBER | "qt.quoteNumber"
public static final java.lang.String | ORDER_BY_SALESMAN | "qt.salesman"
public static final java.lang.String | ORDER_BY_STATUS | "qt.status"
public static final java.lang.String | ORDER_BY_VALIDTHRU | "qt.validThru"

bb.common.ReceiverInfoVO
public static final java.lang.String | ORDER_BY_PURCHASEORDERNUMBER | "por.purchaseOrderNumber"
public static final java.lang.String | ORDER_BY_RECEIVERNUMBER | "por.receiverNumber"
public static final java.lang.String | ORDER_BY_VENDORADDRESSINFO | "por.vendorAddressInfo.name"
public static final java.lang.String | ORDER_BY_VENDORID | "por.vendorId"
public static final java.lang.String | ORDER_BY_VENDORSHIPDATE | "por.vendorShipDate"

bb.common.RequestForQuoteCheckListResult
public static final java.lang.String | ORDER_BY_BUYER | "rfq.buyer"
public static final java.lang.String | ORDER_BY_DELIVERY | "rfq.delivery"
public static final java.lang.String | ORDER_BY_PROJECT | "rfq.projectName"
public static final java.lang.String | ORDER_BY_RFQDATE | "rfq.rfqDate"
public static final java.lang.String | ORDER_BY_RFQNUMBER | "rfq.requestForQuoteNumber"
public static final java.lang.String | ORDER_BY_STATUS | "rfq.status"
public static final java.lang.String | ORDER_BY_VENDORID | "rfq.vendorId"

bb.common.RequestForQuoteItemListResult
public static final java.lang.String | ORDER_BY_BUYER | "rfq.buyer"
public static final java.lang.String | ORDER_BY_COSTPERUNIT | "rfqi.costPerUnit"
public static final java.lang.String | ORDER_BY_DELIVERY | "rfqi.dateRequired"
public static final java.lang.String | ORDER_BY_DISCOUNT | "rfqi.discount"
public static final java.lang.String | ORDER_BY_PARTDESC | "rfqi.description"
public static final java.lang.String | ORDER_BY_PARTPK | "rfqi.partNumber"
public static final java.lang.String | ORDER_BY_RFQDATE | "rfq.rfqDate"
public static final java.lang.String | ORDER_BY_RFQITEMPK | "rfqi.pk.requestForQuoteNumber"
public static final java.lang.String | ORDER_BY_SUBTOTAL | "rfq.subTotal"
public static final java.lang.String | ORDER_BY_VENDORID | "rfq.vendorId"
public static final java.lang.String | ORDER_BY_VENDORNAME | "ab.name"

bb.common.RequestForQuoteListResult
public static final java.lang.String | ORDER_BY_BUYER | "rfq.buyer"
public static final java.lang.String | ORDER_BY_DELIVERY | "rfq.delivery"
public static final java.lang.String | ORDER_BY_PROJECT | "rfq.projectName"
public static final java.lang.String | ORDER_BY_RFQDATE | "rfq.rfqDate"
public static final java.lang.String | ORDER_BY_RFQNUMBER | "rfq.requestForQuoteNumber"
public static final java.lang.String | ORDER_BY_STATUS | "rfq.status"
public static final java.lang.String | ORDER_BY_VENDORID | "rfq.vendorId"

bb.common.ReturnToVendorByDateListResult
public static final java.lang.String | ORDER_BY_APNET | "rtvi.apNet"
public static final java.lang.String | ORDER_BY_BUYER | "rtv.buyer"
public static final java.lang.String | ORDER_BY_COMPANYUNITID | "rtv.companyUnitId"
public static final java.lang.String | ORDER_BY_COSTPERUNIT | "rtvi.costPerUnit"
public static final java.lang.String | ORDER_BY_DATEREQUIRED | "rtvi.delivery"
public static final java.lang.String | ORDER_BY_DEBITACCOUNT | "rtv.debitAccount"
public static final java.lang.String | ORDER_BY_DISCOUNT | "rtvi.discount"
public static final java.lang.String | ORDER_BY_ENTERBY | "rtv.enterBy"
public static final java.lang.String | ORDER_BY_PARTPK | "rtvi.partNumber"
public static final java.lang.String | ORDER_BY_REFDOC2 | "rtvi.refDoc2"
public static final java.lang.String | ORDER_BY_RTVDATE | "rtv.dateEntered"
public static final java.lang.String | ORDER_BY_RTVITEMPK | "rtvi.pk.returnToVendorNumber,rtvi.pk.returnToVendorItemNumber"
public static final java.lang.String | ORDER_BY_STATUS | "rtvi.status"
public static final java.lang.String | ORDER_BY_TAXRATE | "rtvi.taxRate"
public static final java.lang.String | ORDER_BY_VENDORID | "rtv.vendorId"

bb.common.ReturnToVendorCheckListResult
public static final java.lang.String | ORDER_BY_BUYER | "rtv.buyer"
public static final java.lang.String | ORDER_BY_PONUMBER | "rtv.po"
public static final java.lang.String | ORDER_BY_PROJECT | "rtv.project"
public static final java.lang.String | ORDER_BY_RTVNUMBER | "rtv.returnToVendorNumber"
public static final java.lang.String | ORDER_BY_STATUS | "rtv.status"
public static final java.lang.String | ORDER_BY_VENDORID | "rtv.vendorId"

bb.common.ReturnToVendorItemListResult
public static final java.lang.String | ORDER_BY_BUYER | "rtv.buyer"
public static final java.lang.String | ORDER_BY_DELIVERY | "rtvi.delivery"
public static final java.lang.String | ORDER_BY_PARTPK | "rtvi.partNumber"
public static final java.lang.String | ORDER_BY_RTVDATE | "rtv.dateEntered"
public static final java.lang.String | ORDER_BY_RTVITEMPK | "rtvi.pk.returnToVendorNumber,rtvi.pk.returnToVendorItemNumber"
public static final java.lang.String | ORDER_BY_STATUS | "rtvi.status"
public static final java.lang.String | ORDER_BY_VENDORID | "rtv.vendorId"
public static final java.lang.String | ORDER_BY_VENDORNAME | "ab.name"

bb.common.ReturnToVendorListResult
public static final java.lang.String | ORDER_BY_RTVNUMBER | "rtv.returnToVendorNumber"
public static final java.lang.String | ORDER_BY_VENDORID | "rtv.vendorId"

bb.common.RfqMessageListResult
public static final java.lang.String | ORDER_BY_RFQMESSAGENUMBER | "rfqm.rfqMessageNumber"
public static final java.lang.String | ORDER_BY_RFQNUMBER | "rfqm.rfqNumber"
public static final java.lang.String | ORDER_BY_VENDORID | "rfqm.vendorId"

bb.common.RMAItemListResult
public static final java.lang.String | ORDER_BY_COMPANYUNITID | "rma.companyUnitId"
public static final java.lang.String | ORDER_BY_CUSTOMERID | "rma.customerId"
public static final java.lang.String | ORDER_BY_DEBITACCOUNT | "rma.debitAccount"
public static final java.lang.String | ORDER_BY_DELIVERYDATE | "rmai.delivery"
public static final java.lang.String | ORDER_BY_INVOICENUMBER | "rma.invoiceNumber"
public static final java.lang.String | ORDER_BY_ITEMDESCRIPTION | "rmai.description"
public static final java.lang.String | ORDER_BY_NCRNUMBER | "rmai.ncrNumber"
public static final java.lang.String | ORDER_BY_PARTPK | "rmai.partNumber"
public static final java.lang.String | ORDER_BY_RMADATE | "rma.rmaDate"
public static final java.lang.String | ORDER_BY_RMANUMBER | "rmai.pk.rmaNumber,rmai.pk.rmaItemNumber"
public static final java.lang.String | ORDER_BY_SALESORDERNUMBER | "rma.salesOrderNumber"
public static final java.lang.String | ORDER_BY_STATUS | "rmai.status"

bb.common.RMAListResult
public static final java.lang.String | ORDER_BY_CHANGEORDER | "rma.changeOrder"
public static final java.lang.String | ORDER_BY_CUSTOMERID | "rma.customerId"
public static final java.lang.String | ORDER_BY_INVOICENUMBER | "rma.invoiceNumber"
public static final java.lang.String | ORDER_BY_PROJECT | "rma.projectName"
public static final java.lang.String | ORDER_BY_RMADATE | "rma.rmaDate"
public static final java.lang.String | ORDER_BY_RMANUMBER | "rma.rmaNumber"
public static final java.lang.String | ORDER_BY_SALESMAN | "rma.salesman"
public static final java.lang.String | ORDER_BY_SALESORDERNUMBER | "rma.salesOrderNumber"
public static final java.lang.String | ORDER_BY_STATUS | "rma.status"

bb.common.RMAReceiverItemListResult
public static final java.lang.String | ORDER_BY_CUSTID | "rmar.custID"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "rmair.description"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "rmair.partNumber,rmair.partType,rmair.partFrom"
public static final java.lang.String | ORDER_BY_PARTTYPE | "rmair.partNumber,rmair.partType,rmair.partFrom"
public static final java.lang.String | ORDER_BY_RECEIVERBY | "rmair.receivedBy"
public static final java.lang.String | ORDER_BY_RECEIVERNUMBER | "rmair.pk.receiverNumber,rmair.pk.itemNumber"
public static final java.lang.String | ORDER_BY_RMANUMBER | "rmair.rmaNumber"
public static final java.lang.String | ORDER_BY_STATUS | "rmair.status"

bb.common.RMAReceiverListResult
public static final java.lang.String | ORDER_BY_CREDITMEMONUMBER | "creditMemoNumber"
public static final java.lang.String | ORDER_BY_DATERECEIVED | "dateReceived"
public static final java.lang.String | ORDER_BY_PROJECT | "project"
public static final java.lang.String | ORDER_BY_RECEIVEDBY | "receivedBy"
public static final java.lang.String | ORDER_BY_RECEIVERNUMBER | "receiverNumber"
public static final java.lang.String | ORDER_BY_RMANUMBER | "rmaNumber"
public static final java.lang.String | ORDER_BY_STATUS | "status"

bb.common.RMAReviewVO
public static final java.lang.String | ORDER_BY_CANREVIEWOWNRMA | "canReviewOwnRMA"
public static final java.lang.String | ORDER_BY_CURRENCY | "currency"
public static final java.lang.String | ORDER_BY_EMPLOYEEID | "employeeID"
public static final java.lang.String | ORDER_BY_REVIEWLIMIT | "reviewLimit"
public static final java.lang.String | ORDER_BY_USERNAME | "userName"

bb.common.RoleListResult
public static final java.lang.String | ORDER_BY_DESCRIPTION | "role_des.description"
public static final java.lang.String | ORDER_BY_ROLEID | "role.roleId"
public static final java.lang.String | ORDER_BY_ROLENAME | "role_des.roleName"

bb.common.RollUpBomStdCostWorkSheetItemVO
public static final java.lang.String | ORDER_BY_AVGCOST | "avgCost"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "description"
public static final java.lang.String | ORDER_BY_LEVEL | "level"
public static final java.lang.String | ORDER_BY_ONHAND | "onHand"
public static final java.lang.String | ORDER_BY_PK | "pk.billNumber,pk.billType"
public static final java.lang.String | ORDER_BY_ROLLUPCOST | "rollUpCost"
public static final java.lang.String | ORDER_BY_STDCOST | "stdCost"

bb.common.RollUpBomStdCostWorkSheetVO
public static final java.lang.String | ORDER_BY_BOMCOUNT | "bomCount"
public static final java.lang.String | ORDER_BY_COMMITTEDBY | "committedBy"
public static final java.lang.String | ORDER_BY_COMMITTEDDATE | "committedDate"
public static final java.lang.String | ORDER_BY_CREATEDBY | "createdBy"
public static final java.lang.String | ORDER_BY_CREATEDDATE | "createdDate"
public static final java.lang.String | ORDER_BY_ENDDATE | "endDate"
public static final java.lang.String | ORDER_BY_II | "ii"
public static final java.lang.String | ORDER_BY_LOG | "log"
public static final java.lang.String | ORDER_BY_ROLLUPCOUNT | "rollUpCount"
public static final java.lang.String | ORDER_BY_STARTDATE | "startDate"
public static final java.lang.String | ORDER_BY_STATUS | "status"
public static final java.lang.String | ORDER_BY_TRANSACTIONNUMBER | "transactionNumber"
public static final java.lang.String | ORDER_BY_USEAVGCOSTTOROLLUP | "useAvgCostToRollUp"
public static final java.lang.String | ORDER_BY_VARIANCEAMOUNT | "varianceAmount"
public static final java.lang.String | ORDER_BY_VARIANCECOUNT | "varianceCount"

bb.common.RRMAItemListResult
public static final java.lang.String ORDER_BY_CRTVNUMBER "rrmai.pk.rrmaNumber"

bb.common.RRMAListResult
public static final java.lang.String | ORDER_BY_CHANGEORDER | "rrma.changeOrder"
public static final java.lang.String | ORDER_BY_COMMENTS | "rrma.comments"
public static final java.lang.String | ORDER_BY_CRTVDATE | "rrma.rrmaDate"
public static final java.lang.String | ORDER_BY_CRTVNUMBER | "rrma.rrmaNumber"
public static final java.lang.String | ORDER_BY_CUSTOMERID | "rrma.customerId"
public static final java.lang.String | ORDER_BY_INVOICENUMBER | "rrma.invoiceNumber"
public static final java.lang.String | ORDER_BY_PROJECTNAME | "rrma.projectName"
public static final java.lang.String | ORDER_BY_SALESMAN | "rrma.salesman"
public static final java.lang.String | ORDER_BY_SALESORDERNUMBER | "rrma.salesOrderNumber"

bb.common.RTVApprovalVO
public static final java.lang.String | ORDER_BY_APPROVALLIMIT | "approvalLimit"
public static final java.lang.String | ORDER_BY_CANAPPROVEOWNRTV | "canApproveOwnRTV"
public static final java.lang.String | ORDER_BY_CURRENCY | "currency"
public static final java.lang.String | ORDER_BY_EMPLOYEEID | "employeeID"
public static final java.lang.String | ORDER_BY_USERNAME | "userName"

bb.common.RtvShipperInfoVO
public static final java.lang.String | ORDER_BY_CURRENCY | "rtvs.currency"
public static final java.lang.String | ORDER_BY_DATESHIPPED | "rtvs.dateShipped"
public static final java.lang.String | ORDER_BY_PONUMBER | "rtvs.poNumber"
public static final java.lang.String | ORDER_BY_RTVNUMBER | "rtvs.rtvNumber"
public static final java.lang.String | ORDER_BY_RTVSHIPPERNUMBER | "rtvs.rtvShipperNumber"
public static final java.lang.String | ORDER_BY_STATUS | "rtvs.status"
public static final java.lang.String | ORDER_BY_VENDORID | "rtvs.vendorId"

bb.common.RtvShipperItemListResult
public static final java.lang.String | ORDER_BY_apNumber | "rtvs.apNumber"
public static final java.lang.String | ORDER_BY_costPerUnit | "rtvis.listPrice"
public static final java.lang.String | ORDER_BY_dateShipped | "rtvis.dateShipped"
public static final java.lang.String | ORDER_BY_description | "rtvis.description"
public static final java.lang.String | ORDER_BY_partNumber | "rtvis.partNumber"
public static final java.lang.String | ORDER_BY_poNumber | "rtvs.poNumber"
public static final java.lang.String | ORDER_BY_qty | "rtvi.quantity"
public static final java.lang.String | ORDER_BY_qtyShip | "rtvis.qtyShip"
public static final java.lang.String | ORDER_BY_rtvNumber | "rtvis.rtvNumber"
public static final java.lang.String | ORDER_BY_rtvShipperItemNumber | "rtvis.pk.rtvShipperItemNumber"
public static final java.lang.String | ORDER_BY_RTVSHIPPERNUMBER | "rtvis.pk.rtvShipperNumber"
public static final java.lang.String | ORDER_BY_status | "rtvis.status"
public static final java.lang.String | ORDER_BY_vendorId | "rtvs.vendorId"

bb.common.RtvShipperListResult
public static final java.lang.String | ORDER_BY_APNUMBER | "apNumber"
public static final java.lang.String | ORDER_BY_DATESHIPPED | "dateShipped"
public static final java.lang.String | ORDER_BY_PONUMBER | "poNumber"
public static final java.lang.String | ORDER_BY_RTVNUMBER | "rtvNumber"
public static final java.lang.String | ORDER_BY_RTVSHIPPERNUMBER | "rtvShipperNumber"
public static final java.lang.String | ORDER_BY_SHIPPEDBY | "shippedBy"
public static final java.lang.String | ORDER_BY_SHIPPEDDATE | "shippedDate"
public static final java.lang.String | ORDER_BY_SHIPTOID | "shipToId"
public static final java.lang.String | ORDER_BY_SHIPVIA | "shipVia"
public static final java.lang.String | ORDER_BY_STATUS | "status"
public static final java.lang.String | ORDER_BY_VENDORID | "vendorId"

bb.common.SalesCodeVO
public static final java.lang.String | ORDER_BY_ADDRESSID | "code.addressId"
public static final java.lang.String | ORDER_BY_ADDRESSNAME | "code.addressName"
public static final java.lang.String | ORDER_BY_COMMISSIONRATE | "code.commissionRate"
public static final java.lang.String | ORDER_BY_EMPLOYEEID | "code.employeeId"
public static final java.lang.String | ORDER_BY_SALESCODEID | "code.salesCodeId"
public static final java.lang.String | ORDER_BY_SALESCODENAME | "code.salesCodeName"

bb.common.SalesmanVO
public static final java.lang.String | ORDER_BY_COMPANYUNITID | "man.companyUnitId"
public static final java.lang.String | ORDER_BY_DEPARTMENT | "man.department"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "man.description"
public static final java.lang.String | ORDER_BY_FIRSTNAME | "man.firstName"
public static final java.lang.String | ORDER_BY_JOBID | "man.jobId"
public static final java.lang.String | ORDER_BY_LANGUAGE | "man.language"
public static final java.lang.String | ORDER_BY_LASTCHANGEUSER | "man.lastChangeUser"
public static final java.lang.String | ORDER_BY_LASTNAME | "man.lastName"
public static final java.lang.String | ORDER_BY_LEVEL | "man.level"
public static final java.lang.String | ORDER_BY_SALESMANID | "man.salesmanId"
public static final java.lang.String | ORDER_BY_SECURITYLEVEL | "man.securityLevel"
public static final java.lang.String | ORDER_BY_STARTDATE | "man.startDate"
public static final java.lang.String | ORDER_BY_STATUS | "man.status"
public static final java.lang.String | ORDER_BY_USERNAME | "man.userName"

bb.common.SalesMarginListResult
public static final java.lang.String | ORDER_BY_COUNTRY | "ar.customerAddressInfo.country"
public static final java.lang.String | ORDER_BY_CURRENCY | "ar.currency"
public static final java.lang.String | ORDER_BY_CUSTOMERID | "ar.customerId"
public static final java.lang.String | ORDER_BY_CUSTOMERNAME | "ar.customerAddressInfo.name"
public static final java.lang.String | ORDER_BY_STATE | "ar.customerAddressInfo.state"
public static final java.lang.String | ORDER_BY_TOTALCOST | "sum(ari.avgCost*ari.qtyShipped)"
public static final java.lang.String | ORDER_BY_TOTALMARGIN | "sum(ari.margin)"
public static final java.lang.String | ORDER_BY_TOTALNET | "sum(ari.arNet)"
public static final java.lang.String | ORDER_BY_TOTALSALES | "sum(ari.arNet/ar.exchange)"

bb.common.SalesOrder12MonthMarginResult
public static final java.lang.String | ORDER_BY_COST | "cost"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "descript"
public static final java.lang.String | ORDER_BY_GROSSMARGIN | "margin"
public static final java.lang.String | ORDER_BY_INVOICEDTOTAL | "invtotal"
public static final java.lang.String | ORDER_BY_PART | "sois.pn"
public static final java.lang.String | ORDER_BY_PCTMARGIN | "marginpct"
public static final java.lang.String | ORDER_BY_QTY | "totalship"

bb.common.SalesOrderBoilerplateVO
public static final java.lang.String | ORDER_BY_BOILERPLATEID | "tt.boilerplateId"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "tt.description"
public static final java.lang.String | ORDER_BY_SOBOILERPLATE | "tt.soBoilerplate"

bb.common.SalesOrderCheckListResult
public static final java.lang.String | ORDER_BY_CURRENCY | "so.currency"
public static final java.lang.String | ORDER_BY_CUSTOMERID | "so.customerId"
public static final java.lang.String | ORDER_BY_CUSTOMERNAME | "so.customerAddressInfo.name"
public static final java.lang.String | ORDER_BY_SALESMAN | "so.salesman"
public static final java.lang.String | ORDER_BY_SALESMANID | "so.salesmanId"
public static final java.lang.String | ORDER_BY_SODATE | "so.salesOrderDate"
public static final java.lang.String | ORDER_BY_SONUMBER | "so.salesOrderNumber"
public static final java.lang.String | ORDER_BY_STATUS | "so.status"

bb.common.SalesOrderItemCustomerTotalResult
public static final java.lang.String | ORDER_BY_CUSTOMERID | "so.customerId"
public static final java.lang.String | ORDER_BY_NAME | "ab.name"

bb.common.SalesOrderItemGroupByPartListResult
public static final java.lang.String | ORDER_BY_DESCRIPTION | "ps.description"
public static final java.lang.String | ORDER_BY_INSIP | "pt.shipInProcessQty"
public static final java.lang.String | ORDER_BY_INSIPINSO | "soi.sipQty"
public static final java.lang.String | ORDER_BY_NOTSHIPPEDQTY | "soi.quantityOrdered - soi.quantityShipped-soi.sipQty"
public static final java.lang.String | ORDER_BY_ONDEMAND | "pt.onDemandQty"
public static final java.lang.String | ORDER_BY_ONDEMANDINSO | "soi.quantityOrdered"
public static final java.lang.String | ORDER_BY_ONHAND | "pt.onhand"
public static final java.lang.String | ORDER_BY_ONORDER | "pt.onOrderQty"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "soi.partNumber,soi.partType,soi.partFrom"
public static final java.lang.String | ORDER_BY_SHIPPEDQTY | "soi.quantityShipped"

bb.common.SalesOrderItemListResult
public static final java.lang.String | ORDER_BY_ACCOUNTNUMBER | "so.creditAccount"
public static final java.lang.String | ORDER_BY_ARRIVEDATE | "soi.arriveDate"
public static final java.lang.String | ORDER_BY_COMMODITYCODE | "soi.commodityCode"
public static final java.lang.String | ORDER_BY_COMPANYNUITID | "so.companyUnitId"
public static final java.lang.String | ORDER_BY_COUNTRY | "ab.country"
public static final java.lang.String | ORDER_BY_CUSTOMERID | "so.customerId"
public static final java.lang.String | ORDER_BY_CUSTOMERPO | "so.customerPo"
public static final java.lang.String | ORDER_BY_DELIVERYDATE | "soi.deliveryDate"
public static final java.lang.String | ORDER_BY_INCOTERM | "so.incoterm"
public static final java.lang.String | ORDER_BY_INCOTERMPLACEPORT | "so.incotermPlacePort"
public static final java.lang.String | ORDER_BY_ITEMDESCRIPTION | "soi.salesItemDescription"
public static final java.lang.String | ORDER_BY_LASTSHIPPEDDATE | "soi.actual"
public static final java.lang.String | ORDER_BY_ORIGINALDELIVERY | "soi.original"
public static final java.lang.String | ORDER_BY_PARTORASSY | "soi.bill"
public static final java.lang.String | ORDER_BY_PARTPK | "soi.partNumber"
public static final java.lang.String | ORDER_BY_PRODUCTCODE | "soi.productCode"
public static final java.lang.String | ORDER_BY_PROJECTNAME | "so.projectName"
public static final java.lang.String | ORDER_BY_REGINON | "ab.region"
public static final java.lang.String | ORDER_BY_RELATEDDOC | "so.relatedDocument"
public static final java.lang.String | ORDER_BY_SALESCODEID | "so.salesCodeId"
public static final java.lang.String | ORDER_BY_SALESMAN | "so.salesman"
public static final java.lang.String | ORDER_BY_SHIPVIA | "soi.shipVia"
public static final java.lang.String | ORDER_BY_SODATE | "so.salesOrderDate"
public static final java.lang.String | ORDER_BY_SONUMBER | "soi.pk.salesOrderNumber, soi.pk.salesOrderItemNumber"
public static final java.lang.String | ORDER_BY_STATUS | "soi.status"
public static final java.lang.String | ORDER_BY_TERRITORY | "ab.territory"

bb.common.SalesOrderListResult
public static final java.lang.String | ORDER_BY_CURRENCY | "so.currency"
public static final java.lang.String | ORDER_BY_CUSTOMERID | "so.customerId"
public static final java.lang.String | ORDER_BY_CUSTOMERNAME | "ab.name"
public static final java.lang.String | ORDER_BY_CUSTOMERPO | "so.customerPo"
public static final java.lang.String | ORDER_BY_PROJECT | "so.projectName"
public static final java.lang.String | ORDER_BY_RELATEDDOCUMENT | "so.relatedDocument"
public static final java.lang.String | ORDER_BY_SALESMAN | "so.salesman"
public static final java.lang.String | ORDER_BY_SODATE | "so.salesOrderDate"
public static final java.lang.String | ORDER_BY_SONUMBER | "so.salesOrderNumber"
public static final java.lang.String | ORDER_BY_STATUS | "so.status"

bb.common.SalesOrderOnTimeItemResult
public static final java.lang.String | FISCAL_YEAR | "Fiscal Year"
public static final java.lang.String | MONTH_12_AVG | "12 Month Avg"
public static final java.lang.String | YEAR_TO_DATE | "Year to Date"

bb.common.SalesOrderReviewVO
public static final java.lang.String | ORDER_BY_CANREVIEWOWNSALESORDER | "canReviewOwnSalesOrder"
public static final java.lang.String | ORDER_BY_CURRENCY | "currency"
public static final java.lang.String | ORDER_BY_EMPLOYEEID | "employeeId"
public static final java.lang.String | ORDER_BY_REVIEWLIMIT | "reviewLimit"
public static final java.lang.String | ORDER_BY_USERNAME | "userName"

bb.common.SalesOrderShipDateListResult
public static final java.lang.String | ORDER_BY_CUSTID | "so.customerId"
public static final java.lang.String | ORDER_BY_DELIVERYDATE | "soi.deliveryDate"
public static final java.lang.String | ORDER_BY_ORIGINAL | "soi.original"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "soi.partNumber"
public static final java.lang.String | ORDER_BY_PK | "soi.pk.salesOrderNumber,soi.pk.salesOrderItemNumber"
public static final java.lang.String | ORDER_BY_STATUS | "soi.status"

bb.common.SalesTaxListResult
public static final java.lang.String | ORDER_BY_AMOUNTPAID | "ari.paid"
public static final java.lang.String | ORDER_BY_CUSTOMERID | "ar.customerId"
public static final java.lang.String | ORDER_BY_DATEINVOICED | "ar.dateInvoiced"
public static final java.lang.String | ORDER_BY_DATESHIPED | "ari.dateShipped"
public static final java.lang.String | ORDER_BY_INVOICEITEMNUMBER | "ari.pk.invoiceItemNumber"
public static final java.lang.String | ORDER_BY_INVOICENUMBER | "ar.invoiceNumber"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "ari.partNumber"
public static final java.lang.String | ORDER_BY_PARTTYPE | "ari.partType"
public static final java.lang.String | ORDER_BY_PAYDATE | "ar.paydate"
public static final java.lang.String | ORDER_BY_QTYSHIPED | "ari.qtyShipped"
public static final java.lang.String | ORDER_BY_SALESORDERNUMBER | "ar.salesOrderNumber"
public static final java.lang.String | ORDER_BY_SUBNETTOTAL | "ar.subNetTotal"
public static final java.lang.String | ORDER_BY_TAX | "ari.arTax"

bb.common.ServerException
public static final java.lang.String UNKNOWN_EXCEPTION "UNKNOWN_EXCEPTION"

bb.common.SGCustomerServiceRequestVO
public static final java.lang.String | ORDER_BY_APPROVEDBY | "approvedBy"
public static final java.lang.String | ORDER_BY_CSINUMBER | "csiNumber"
public static final java.lang.String | ORDER_BY_CSRDATE | "csrDate"
public static final java.lang.String | ORDER_BY_CSRNUMBER | "csrNumber"
public static final java.lang.String | ORDER_BY_CUSTID | "custID"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "description"
public static final java.lang.String | ORDER_BY_DISPOSALBY | "disposalBy"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "partNumber"
public static final java.lang.String | ORDER_BY_PRIORITY | "priority"
public static final java.lang.String | ORDER_BY_REQUESTOR | "requestor"
public static final java.lang.String | ORDER_BY_REQUIREDATE | "requireDate"
public static final java.lang.String | ORDER_BY_SALESORDERNUMBER | "salesOrderNumber,salesOrderItemNumber"
public static final java.lang.String | ORDER_BY_SERIAL | "serial"
public static final java.lang.String | ORDER_BY_SERVICETYPE | "serviceType"
public static final java.lang.String | ORDER_BY_STATUS | "status"

bb.common.SGCustRequestForQuoteListResult
public static final java.lang.String | ORDER_BY_ADDR1 | "a.address"
public static final java.lang.String | ORDER_BY_CITY | "a.city"
public static final java.lang.String | ORDER_BY_CONTACTNAME | "c.contactName"
public static final java.lang.String | ORDER_BY_COUNTRY | "a.country"
public static final java.lang.String | ORDER_BY_CRFQNUMBER | "c.crfqNumber"
public static final java.lang.String | ORDER_BY_CURRENCY | "a.currency"
public static final java.lang.String | ORDER_BY_CUSTID | "c.custID"
public static final java.lang.String | ORDER_BY_LANGUAGE | "a.language"
public static final java.lang.String | ORDER_BY_NAME | "a.name"
public static final java.lang.String | ORDER_BY_QUOTENUMBER | "c.quoteNumber"
public static final java.lang.String | ORDER_BY_STATE | "a.state"
public static final java.lang.String | ORDER_BY_USEREMAIL | "c.userEmail"

bb.common.SGPartCatalogResult
public static final java.lang.String | ORDER_BY_CATALOG | "pc.catalog"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "ps.description"
public static final java.lang.String | ORDER_BY_NAME | "pc.name"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "ps.pk.partNumber,ps.pk.partType"

bb.common.SGQuoteCartListResult
public static final java.lang.String | ORDER_BY_PARTNUMBER | "c.partNumber"
public static final java.lang.String | ORDER_BY_PARTTYPE | "c.partType"
public static final java.lang.String | ORDER_BY_QTY | "c.qty"
public static final java.lang.String | ORDER_BY_UNIT | "p.unit"
public static final java.lang.String | ORDER_BY_WEIGHT | "p.weight"
public static final java.lang.String | ORDER_BY_WEIGHTUNIT | "p.weightUnit"

bb.common.SGSaleItemVO
public static final java.lang.String | ORDER_BY_CATALOG | "sg.catalog"
public static final java.lang.String | ORDER_BY_CUSTID | "sg.custID"
public static final java.lang.String | ORDER_BY_CUSTPONUMBER | "sg.custPONumber"
public static final java.lang.String | ORDER_BY_DATESHIPPED | "sg.dateShipped"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "sg.description"
public static final java.lang.String | ORDER_BY_MFG | "sg.mfg,sg.mpn"
public static final java.lang.String | ORDER_BY_MPN | "sg.mpn,sg.mfg"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "sg.partNumber,sg.partType,sg.partFrom"
public static final java.lang.String | ORDER_BY_SALESORDERNUMBER | "sg.salesOrderNumber,sg.salesOrderItemNumber"
public static final java.lang.String | ORDER_BY_SERIALNUMBER | "sg.serialNumber"
public static final java.lang.String | ORDER_BY_WORKORDERNUMBER | "sg.workOrderNumber,sg.workOrderItemNumber"

bb.common.ShipListInfoVO
public static final java.lang.String | ORDER_BY_CUSTOMERID | "customerId"
public static final java.lang.String | ORDER_BY_DATE1 | "date1"
public static final java.lang.String | ORDER_BY_DATE2 | "date2"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "description"
public static final java.lang.String | ORDER_BY_LASTUSER | "lastUser"
public static final java.lang.String | ORDER_BY_OWNERNAME | "ownerName"
public static final java.lang.String | ORDER_BY_SHIPLIST | "shipList"
public static final java.lang.String | ORDER_BY_STATUS | "status"

bb.common.ShipListOwnerVO
public static final java.lang.String ORDER_BY_OWNERNAME "ownerName"

bb.common.ShipperItemListResult
public static final java.lang.String | ORDER_BY_ARINVOICENUMBER | "sn.arInvoiceNumber"
public static final java.lang.String | ORDER_BY_AVERAGECOST | "sns.averageCost"
public static final java.lang.String | ORDER_BY_COMPANYNUITID | "sn.companyUnitId"
public static final java.lang.String | ORDER_BY_CUSTOMERID | "sn.customerId"
public static final java.lang.String | ORDER_BY_CUSTOMERNAME | "ab.name"
public static final java.lang.String | ORDER_BY_DATESHIPPED | "sns.dateShipped"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "sns.description"
public static final java.lang.String | ORDER_BY_LISTPRICE | "sns.listPrice"
public static final java.lang.String | ORDER_BY_LOCATION | "sns.locations"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "sns.partNumber"
public static final java.lang.String | ORDER_BY_PROJECT | "sn.project"
public static final java.lang.String | ORDER_BY_QUANTITY | "sns.soQuantity"
public static final java.lang.String | ORDER_BY_QUANTITYSHIP | "sns.quantityShip"
public static final java.lang.String | ORDER_BY_SALESORDERNUMBER | "sns.salesOrder,sns.pk.shipperItemNumber"
public static final java.lang.String | ORDER_BY_SERIALNUMBER | "sns.serialNumber"
public static final java.lang.String | ORDER_BY_SHIPPERNUMBER | "sns.pk.shipperNumber"
public static final java.lang.String | ORDER_BY_STATUS | "sns.status"

bb.common.ShipperListResult
public static final java.lang.String | ORDER_BY_CUSTOMERID | "sn.customerId"
public static final java.lang.String | ORDER_BY_SALESMAN | "sn.salesman"
public static final java.lang.String | ORDER_BY_SALESORDERNUMBER | "sn.salesOrderNumber"
public static final java.lang.String | ORDER_BY_SHIPPERDATE | "sn.dateShipped"
public static final java.lang.String | ORDER_BY_SHIPPERNUMBER | "sn.shipperNumber"
public static final java.lang.String | ORDER_BY_STATUS | "sn.status"

bb.common.SOShipperItemListResult
public static final java.lang.String | ORDER_BY_DATEINVOICED | "sos.invoicedDate"
public static final java.lang.String | ORDER_BY_DATESHIPPED | "sois.dateShipped"
public static final java.lang.String | ORDER_BY_INVOICENUMBER | "sos.arInvoiceNumber"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "sois.partNumber,sois.partType"
public static final java.lang.String | ORDER_BY_QUANTITYSHIPPED | "sois.quantityShip"
public static final java.lang.String | ORDER_BY_SALESORDERNUMBER | "sois.salesOrder"
public static final java.lang.String | ORDER_BY_SHIPPERITEMPK | "sois.pk.shipperNumber,sois.pk.shipperItemNumber"
public static final java.lang.String | ORDER_BY_SOQUANTITY | "sois.soQuantity"
public static final java.lang.String | ORDER_BY_STATUS | "sois.status"

bb.common.SwapOrderApprovalVO
public static final java.lang.String | ORDER_BY_CANAPPROVEOWN | "canApproveOwn"
public static final java.lang.String | ORDER_BY_COMMENTS | "comments"
public static final java.lang.String | ORDER_BY_EMPLOYEEID | "employeeId"
public static final java.lang.String | ORDER_BY_USERNAME | "userName"

bb.common.SwapOrderItemListResult
public static final java.lang.String | ORDER_BY_DESCRIPTION | "swoi.description"
public static final java.lang.String | ORDER_BY_PARTFROM | "swoi.partFrom"
public static final java.lang.String | ORDER_BY_PARTTYPE | "swoi.partType"
public static final java.lang.String | ORDER_BY_SWOITEMNUMBER | "swoi.pk.swapOrderItem"

bb.common.SwapReceiverItemListResult
public static final java.lang.String | ORDER_BY_AVGCOST | "swri.avgCost"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "swri.description"
public static final java.lang.String | ORDER_BY_PARTFROM | "swri.partFrom"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "swri.partNumber"
public static final java.lang.String | ORDER_BY_PARTTYPE | "swri.partType"
public static final java.lang.String | ORDER_BY_RECEIVEDDATE | "swri.receivedDate"
public static final java.lang.String | ORDER_BY_RECEIVEDQTY | "swri.receivedQty"
public static final java.lang.String | ORDER_BY_SHIPPEDQTY | "swri.shippedQty"
public static final java.lang.String | ORDER_BY_STATUS | "swri.status"
public static final java.lang.String | ORDER_BY_STDCOST | "swri.stdCost"
public static final java.lang.String | ORDER_BY_SWAPORDERNUMBER | "swr.swapOrderNumber"
public static final java.lang.String | ORDER_BY_SWAPQTY | "swri.swapQty"
public static final java.lang.String | ORDER_BY_SWAPRECEIVERITEMNUMBER | "swri.pk.swapReceiverItemNumber"
public static final java.lang.String | ORDER_BY_SWAPRECEIVERNUMBER | "swr.swapReceiverNumber"
public static final java.lang.String | ORDER_BY_SWAPSHIPPERNUMBER | "swr.swapShipperNumber"

bb.common.SwapReceiverListResult
public static final java.lang.String | ORDER_BY_ADATE | "swr.adate"
public static final java.lang.String | ORDER_BY_BUYER | "swr.buyer"
public static final java.lang.String | ORDER_BY_BUYERGROUP | "swr.buyerGroup"
public static final java.lang.String | ORDER_BY_CARRIER | "swr.carrier"
public static final java.lang.String | ORDER_BY_CARRIERACCOUNT | "swr.carrierAccount"
public static final java.lang.String | ORDER_BY_COCOMMENTS | "swr.coComments"
public static final java.lang.String | ORDER_BY_CONTACT | "swr.contact"
public static final java.lang.String | ORDER_BY_FREIGHT | "swr.freight"
public static final java.lang.String | ORDER_BY_INCOTERM | "swr.incoterm"
public static final java.lang.String | ORDER_BY_INCOTERMPLACEPORT | "swr.incotermPlacePort"
public static final java.lang.String | ORDER_BY_ORIGIN | "swr.origin"
public static final java.lang.String | ORDER_BY_PROJECTNAME | "swr.projectName"
public static final java.lang.String | ORDER_BY_RECEIVEDBY | "swr.receivedBy"
public static final java.lang.String | ORDER_BY_RECEIVEDDATE | "swr.receivedDate"
public static final java.lang.String | ORDER_BY_RELATEDDOC | "swr.relatedDoc"
public static final java.lang.String | ORDER_BY_SHIPVIA | "swr.shipVia"
public static final java.lang.String | ORDER_BY_STATUS | "swr.status"
public static final java.lang.String | ORDER_BY_SWAPORDERNUMBER | "swr.swapOrderNumber"
public static final java.lang.String | ORDER_BY_SWAPRECEIVERNUMBER | "swr.swapReceiverNumber"
public static final java.lang.String | ORDER_BY_SWAPSHIPPERNUMBER | "swr.swapShipperNumber"
public static final java.lang.String | ORDER_BY_TRACKING | "swr.tracking"
public static final java.lang.String | ORDER_BY_VENDORID | "swr.vendorId"
public static final java.lang.String | ORDER_BY_VENDORNAME | "addr.name"

bb.common.SwapShipperItemListResult
public static final java.lang.String | ORDER_BY_AVGCOST | "swsi.avgCost"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "swsi.description"
public static final java.lang.String | ORDER_BY_ITEMCOMMENTS | "swsi.itemComments"
public static final java.lang.String | ORDER_BY_ITEMPRIVATENOTES | "swsi.itemPrivateNotes"
public static final java.lang.String | ORDER_BY_PARTFROM | "swsi.partFrom"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "swsi.partNumber"
public static final java.lang.String | ORDER_BY_PARTTYPE | "swsi.partType"
public static final java.lang.String | ORDER_BY_RECEIVEDQTY | "swsi.receivedQty"
public static final java.lang.String | ORDER_BY_SHIPPEDATE | "swsi.shippedDate"
public static final java.lang.String | ORDER_BY_SHIPPEDQTY | "swsi.shippedQty"
public static final java.lang.String | ORDER_BY_STATUS | "swsi.status"
public static final java.lang.String | ORDER_BY_STDCOST | "swsi.stdCost"
public static final java.lang.String | ORDER_BY_SWAPORDERNUMBER | "sws.swapOrderNumber"
public static final java.lang.String | ORDER_BY_SWAPQTY | "swsi.swapQty"
public static final java.lang.String | ORDER_BY_SWAPSHIPPERITEMNUMBER | "swsi.pk.swapShipperItemNumber"
public static final java.lang.String | ORDER_BY_SWAPSHIPPERNUMBER | "sws.swapShipperNumber"

bb.common.SwapShipperListResult
public static final java.lang.String | ORDER_BY_ADATE | "sws.adate"
public static final java.lang.String | ORDER_BY_BUYER | "sws.buyer"
public static final java.lang.String | ORDER_BY_BUYERGROUP | "sws.buyerGroup"
public static final java.lang.String | ORDER_BY_CARRIER | "sws.carrier"
public static final java.lang.String | ORDER_BY_CARRIERACCOUNT | "sws.carrierAccount"
public static final java.lang.String | ORDER_BY_COCOMMENTS | "sws.coComments"
public static final java.lang.String | ORDER_BY_CONTACT | "sws.contact"
public static final java.lang.String | ORDER_BY_FREIGHT | "sws.freight"
public static final java.lang.String | ORDER_BY_FREIGHTRATECODE | "sws.freightRateCode"
public static final java.lang.String | ORDER_BY_GROSSWEIGHT | "sws.grossWeight"
public static final java.lang.String | ORDER_BY_INCOTERM | "sws.incoterm"
public static final java.lang.String | ORDER_BY_INCOTERMPLACEPORT | "sws.incotermPlacePort"
public static final java.lang.String | ORDER_BY_PROJECTNAME | "sws.projectName"
public static final java.lang.String | ORDER_BY_RELATEDDOC | "sws.relatedDoc"
public static final java.lang.String | ORDER_BY_SHIPPEDBY | "sws.shippedBy"
public static final java.lang.String | ORDER_BY_SHIPPEDDATE | "sws.shippedDate"
public static final java.lang.String | ORDER_BY_SHIPVIA | "sws.shipVia"
public static final java.lang.String | ORDER_BY_STATUS | "sws.status"
public static final java.lang.String | ORDER_BY_SWAPORDERNUMBER | "sws.swapOrderNumber"
public static final java.lang.String | ORDER_BY_SWAPSHIPPERNUMBER | "sws.swapShipperNumber"
public static final java.lang.String | ORDER_BY_TRACKING | "sws.tracking"
public static final java.lang.String | ORDER_BY_VENDORID | "sws.vendorId"
public static final java.lang.String | ORDER_BY_VENDORNAME | "addr.name"

bb.common.TempArApAgingVO
public static final java.lang.String | ORDER_BY_ARAPDATE | "tap.arApDate"
public static final java.lang.String | ORDER_BY_ARAPNUMBER | "tap.arApNumber"
public static final java.lang.String | ORDER_BY_COMPANYUNITID | "tap.companyUnitId"
public static final java.lang.String | ORDER_BY_CURRENCY | "tap.currency"
public static final java.lang.String | ORDER_BY_CUSTOMERID | "tap.customerId"
public static final java.lang.String | ORDER_BY_CUSTOMERNAME | "tap.customerName"
public static final java.lang.String | ORDER_BY_PAYDATE | "tap.payDate"
public static final java.lang.String | ORDER_BY_PONUMBER | "tap.poNumber"
public static final java.lang.String | ORDER_BY_VENDORINVOICE | "ap.vendorInvoice"

bb.common.TempReceiverWithoutAPInfo
public static final java.lang.String | ORDER_BY_CURRENCY | "temp_por_without_ap.currency"
public static final java.lang.String | ORDER_BY_DATERECEIVED | "temp_por_without_ap.date_received"
public static final java.lang.String | ORDER_BY_DATESAVE | "temp_por_without_ap.date_save"
public static final java.lang.String | ORDER_BY_GRANTTOTAL | "temp_por_without_ap.ap_total"
public static final java.lang.String | ORDER_BY_PURCHASEORDERNUMBER | "temp_por_without_ap.po"
public static final java.lang.String | ORDER_BY_RECEIVEDBY | "temp_por_without_ap.received_by"
public static final java.lang.String | ORDER_BY_RECEIVERNUMBER | "temp_por_without_ap.rn"
public static final java.lang.String | ORDER_BY_SEARCHBUYER | "temp_por_without_ap.search_buyer"
public static final java.lang.String | ORDER_BY_SEARCHCURRENCY | "temp_por_without_ap.search_curreny"
public static final java.lang.String | ORDER_BY_SEARCHDATEFROM | "temp_por_without_ap.search_date_from"
public static final java.lang.String | ORDER_BY_SEARCHDATETO | "temp_por_without_ap.search_date_to"
public static final java.lang.String | ORDER_BY_SEARCHID | "temp_por_without_ap.search_id"
public static final java.lang.String | ORDER_BY_STATUS | "temp_por_without_ap.status"
public static final java.lang.String | ORDER_BY_SUBTOTAL | "temp_por_without_ap.ap_net"
public static final java.lang.String | ORDER_BY_VENDORID | "temp_por_without_ap.id"
public static final java.lang.String | ORDER_BY_VENDORNAME | "temp_por_without_ap.name"

bb.common.TermsConditionVO
public static final java.lang.String | ORDER_BY_EXTENSION | "tc.extension"
public static final java.lang.String | ORDER_BY_LENGTH | "tc.length"
public static final java.lang.String | ORDER_BY_ORDERTYPE | "tc.orderType"
public static final java.lang.String | ORDER_BY_SUMMARY | "tc.summary"

bb.common.TermVO
public static final java.lang.String | ORDER_BY_COMMENTS | "term.comments"
public static final java.lang.String | ORDER_BY_DAYS | "term.days"
public static final java.lang.String | ORDER_BY_II | "term.ii"
public static final java.lang.String | ORDER_BY_TERMVALUE | "term.termValue"

bb.common.ToolCalibrateListResult
public static final java.lang.String | ORDER_BY_ASSIGNEDTO | "tc.assignedTo"
public static final java.lang.String | ORDER_BY_COMMENT | "tc.comment"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "tm.description"
public static final java.lang.String | ORDER_BY_II | "tc.ii"
public static final java.lang.String | ORDER_BY_INSPECTEDBY | "tc.inspectedBy"
public static final java.lang.String | ORDER_BY_INSPECTIONPERIOD | "tc.inspectionPeriod"
public static final java.lang.String | ORDER_BY_LASTINSPECTION | "tc.lastInspection"
public static final java.lang.String | ORDER_BY_LOCATION | "tc.location"
public static final java.lang.String | ORDER_BY_MANUFACTURERNAME | "manufacturerName"
public static final java.lang.String | ORDER_BY_NEXTINSPECTION | " tc.nextInspection"
public static final java.lang.String | ORDER_BY_PK | "tc.partNumber,tc.partType,tc.ii"
public static final java.lang.String | ORDER_BY_SERIALNUMBER | "tc.serialNumber"
public static final java.lang.String | ORDER_BY_STATUS | "status"

bb.common.ToolCalibrationVO
public static final java.lang.String | ORDER_BY_ASSIGNEDTO | "tc.assignedTo"
public static final java.lang.String | ORDER_BY_II | "tc.ii"
public static final java.lang.String | ORDER_BY_INSPECTEDBY | "tc.inspectedBy"
public static final java.lang.String | ORDER_BY_INSPECTIONPERIOD | "tc.inspectionPeriod"
public static final java.lang.String | ORDER_BY_LASTINSPECTION | "tc.lastInspection"
public static final java.lang.String | ORDER_BY_LOCATION | "tc.location"
public static final java.lang.String | ORDER_BY_MANUFACTURERNAME | "manufacturerName"
public static final java.lang.String | ORDER_BY_NEXTINSPECTION | " tc.nextInspection"
public static final java.lang.String | ORDER_BY_PK | "tc.partNumber,tc.partType,tc.ii"
public static final java.lang.String | ORDER_BY_STATUS | "status"

bb.common.ToolListWithToolInfoResult
public static final java.lang.String | ORDER_BY_BILLPK | "bm.pk.billNumber,bm.pk.billType"
public static final java.lang.String | ORDER_BY_LASTCHANGEDATE | "bm.lastChangeDate"
public static final java.lang.String | ORDER_BY_LASTCHANGEUSER | "bm.lastChangeUser"

bb.common.TotalAmountInPOByRefDoc
public static final java.lang.String | ORDER_BY_PROJECT | "po.project"
public static final java.lang.String | ORDER_BY_PROJECTDESCRIPTION | "project.description"
public static final java.lang.String | ORDER_BY_REFDOC | "ref1.forderNumber"
public static final java.lang.String | ORDER_BY_RELATEDDOC | "po.relatedDoc"

bb.common.TransferOrderApprovalVO
public static final java.lang.String | ORDER_BY_CANAPPROVEOWN | "canApproveOwn"
public static final java.lang.String | ORDER_BY_COMMENTS | "comments"
public static final java.lang.String | ORDER_BY_EMPLOYEEID | "employeeId"
public static final java.lang.String | ORDER_BY_USERNAME | "userName"

bb.common.TransferOrderItemListResult
public static final java.lang.String | ORDER_BY_ARRIVEDATE | "toi.arriveDate"
public static final java.lang.String | ORDER_BY_AVGCOST | "toi.avgCost"
public static final java.lang.String | ORDER_BY_DELAYDAYS | "toi.delayDays"
public static final java.lang.String | ORDER_BY_DELIVERYDATE | "toi.deliveryDate"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "toi.description"
public static final java.lang.String | ORDER_BY_DESIREDDATE | "toi.desiredDate"
public static final java.lang.String | ORDER_BY_FROMLOCATION | "toi.fromLocation"
public static final java.lang.String | ORDER_BY_ITEMCOMMENTS | "toi.itemComments"
public static final java.lang.String | ORDER_BY_ITEMPRIVATENOTES | "toi.itemPrivateNotes"
public static final java.lang.String | ORDER_BY_PARTFROM | "toi.partFrom"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "toi.partNumber,toi.partType,toi.partFrom"
public static final java.lang.String | ORDER_BY_PARTTYPE | "toi.partType"
public static final java.lang.String | ORDER_BY_RECEIVEDQTY | "toi.receivedQty"
public static final java.lang.String | ORDER_BY_SHIPPEDQTY | "toi.shippedQty"
public static final java.lang.String | ORDER_BY_STATUS | "toi.status"
public static final java.lang.String | ORDER_BY_STDCOST | "toi.stdCost"
public static final java.lang.String | ORDER_BY_TOLOCATION | "toi.toLocation"
public static final java.lang.String | ORDER_BY_TRANSFERORDERITEMNUMBER | "toi.pk.transferOrderItemNumber"
public static final java.lang.String | ORDER_BY_TRANSFERORDERNUMBER | "toi.pk.transferOrderNumber"
public static final java.lang.String | ORDER_BY_TRANSFERQTY | "toi.transferQty"

bb.common.TransferOrderListResult
public static final java.lang.String | ORDER_BY_ADATE | "adate"
public static final java.lang.String | ORDER_BY_APPROVEDATE | "approveDate"
public static final java.lang.String | ORDER_BY_APPROVEDBY | "approvedBy"
public static final java.lang.String | ORDER_BY_CARRIER | "carrier"
public static final java.lang.String | ORDER_BY_CARRIERACCOUNT | "carrierAccount"
public static final java.lang.String | ORDER_BY_COMMENTS | "comments"
public static final java.lang.String | ORDER_BY_CONTACT | "contact"
public static final java.lang.String | ORDER_BY_CURRENCY | "currency"
public static final java.lang.String | ORDER_BY_FREIGHT | "freight"
public static final java.lang.String | ORDER_BY_FROMADDRESSID | "fromAddressId"
public static final java.lang.String | ORDER_BY_INCOTERM | "incoterm"
public static final java.lang.String | ORDER_BY_INCOTERMPLACEPORT | "incotermPlacePort"
public static final java.lang.String | ORDER_BY_LANGUAGE | "language"
public static final java.lang.String | ORDER_BY_LASTCHANGEDATE | "lastChangeDate"
public static final java.lang.String | ORDER_BY_LASTUSER | "lastUser"
public static final java.lang.String | ORDER_BY_LOCATE | "locate"
public static final java.lang.String | ORDER_BY_ORIGIN | "origin"
public static final java.lang.String | ORDER_BY_PRIVATENOTES | "privateNotes"
public static final java.lang.String | ORDER_BY_RELATEDDOCUMENT | "relatedDocument"
public static final java.lang.String | ORDER_BY_REQUESTER | "requester"
public static final java.lang.String | ORDER_BY_SHIPACCOUT | "shipAccout"
public static final java.lang.String | ORDER_BY_SHIPVIA | "shipVia"
public static final java.lang.String | ORDER_BY_STATUS | "status"
public static final java.lang.String | ORDER_BY_TERMS | "terms"
public static final java.lang.String | ORDER_BY_TOADDRESSID | "toAddressId"
public static final java.lang.String | ORDER_BY_TOTALCOST | "totalCost"
public static final java.lang.String | ORDER_BY_TRANSFERORDERDATE | "transferOrderDate"
public static final java.lang.String | ORDER_BY_TRANSFERORDERNUMBER | "transferOrderNumber"

bb.common.TransferOrderVO
public static final java.lang.String | ORDER_BY_ADATE | "adate"
public static final java.lang.String | ORDER_BY_APPROVEDATE | "approveDate"
public static final java.lang.String | ORDER_BY_APPROVEDBY | "approvedBy"
public static final java.lang.String | ORDER_BY_CARRIER | "carrier"
public static final java.lang.String | ORDER_BY_CARRIERACCOUNT | "carrierAccount"
public static final java.lang.String | ORDER_BY_COMMENTS | "comments"
public static final java.lang.String | ORDER_BY_CONTACT | "contact"
public static final java.lang.String | ORDER_BY_CURRENCY | "currency"
public static final java.lang.String | ORDER_BY_FREIGHT | "freight"
public static final java.lang.String | ORDER_BY_FROMADDRESSID | "fromAddressId"
public static final java.lang.String | ORDER_BY_INCOTERM | "incoterm"
public static final java.lang.String | ORDER_BY_INCOTERMPLACEPORT | "incotermPlacePort"
public static final java.lang.String | ORDER_BY_LANGUAGE | "language"
public static final java.lang.String | ORDER_BY_LASTCHANGEDATE | "lastChangeDate"
public static final java.lang.String | ORDER_BY_LASTUSER | "lastUser"
public static final java.lang.String | ORDER_BY_LOCATE | "locate"
public static final java.lang.String | ORDER_BY_ORIGIN | "origin"
public static final java.lang.String | ORDER_BY_PRIVATENOTES | "privateNotes"
public static final java.lang.String | ORDER_BY_RELATEDDOCUMENT | "relatedDocument"
public static final java.lang.String | ORDER_BY_REQUESTER | "requester"
public static final java.lang.String | ORDER_BY_SHIPACCOUT | "shipAccout"
public static final java.lang.String | ORDER_BY_SHIPVIA | "shipVia"
public static final java.lang.String | ORDER_BY_STATUS | "status"
public static final java.lang.String | ORDER_BY_TERMS | "terms"
public static final java.lang.String | ORDER_BY_TOADDRESSID | "toAddressId"
public static final java.lang.String | ORDER_BY_TOTALCOST | "totalCost"
public static final java.lang.String | ORDER_BY_TRANSFERORDERDATE | "transferOrderDate"
public static final java.lang.String | ORDER_BY_TRANSFERORDERNUMBER | "transferOrderNumber"

bb.common.TransferReceiverItemListResult
public static final java.lang.String | ORDER_BY_AVGCOST | "tri.avgCost"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "tri.description"
public static final java.lang.String | ORDER_BY_DWG | "tri.dwg"
public static final java.lang.String | ORDER_BY_FROMADDRESSID | "tr.fromAddressId"
public static final java.lang.String | ORDER_BY_HQA | "tri.hqa"
public static final java.lang.String | ORDER_BY_ITEMCOMMENTS | "tri.itemComments"
public static final java.lang.String | ORDER_BY_ITEMPRIVATENOTES | "tri.itemPrivateNotes"
public static final java.lang.String | ORDER_BY_MFG | "tri.mfg"
public static final java.lang.String | ORDER_BY_MPN | "tri.mpn"
public static final java.lang.String | ORDER_BY_PARTFROM | "tri.partFrom"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "tri.partNumber"
public static final java.lang.String | ORDER_BY_PARTTYPE | "tri.partType"
public static final java.lang.String | ORDER_BY_RECEIVEDDATE | "tri.receivedDate"
public static final java.lang.String | ORDER_BY_RECEIVEDQTY | "tri.receivedQty"
public static final java.lang.String | ORDER_BY_REFDOC1 | "tri.refDoc1"
public static final java.lang.String | ORDER_BY_REFDOC2 | "tri.refDoc2"
public static final java.lang.String | ORDER_BY_REVISION | "tri.revision"
public static final java.lang.String | ORDER_BY_SHIPPEDQTY | "tri.shippedQty"
public static final java.lang.String | ORDER_BY_SHIPVIA | "tri.shipVia"
public static final java.lang.String | ORDER_BY_STATUS | "tri.status"
public static final java.lang.String | ORDER_BY_STDCOST | "tri.stdCost"
public static final java.lang.String | ORDER_BY_TOADDRESSID | "tr.toAddressId"
public static final java.lang.String | ORDER_BY_TRANSFERQTY | "tri.transferQty"
public static final java.lang.String | ORDER_BY_TRANSFERRECEIVERITEMNUMBER | "tri.pk.transferReceiverItemNumber"
public static final java.lang.String | ORDER_BY_TRANSFERRECEIVERNUMBER | "tri.pk.transferReceiverNumber"
public static final java.lang.String | ORDER_BY_UNIT | "tri.unit"

bb.common.TransferReceiverListResult
public static final java.lang.String | ORDER_BY_ADATE | "tr.adate"
public static final java.lang.String | ORDER_BY_ARFREIGHT | "tr.arFreight"
public static final java.lang.String | ORDER_BY_CARRIER | "tr.carrier"
public static final java.lang.String | ORDER_BY_CARRIERACCOUNT | "tr.carrierAccount"
public static final java.lang.String | ORDER_BY_COCOMMENTS | "tr.coComments"
public static final java.lang.String | ORDER_BY_CURRENCY | "tr.currency"
public static final java.lang.String | ORDER_BY_FROMADDRESSID | "tr.fromAddressId"
public static final java.lang.String | ORDER_BY_INCOTERM | "tr.incoterm"
public static final java.lang.String | ORDER_BY_INCOTERMPLACEPORT | "tr.incotermPlacePort"
public static final java.lang.String | ORDER_BY_LANGUAGE | "tr.language"
public static final java.lang.String | ORDER_BY_LASTCHANGEDATE | "tr.lastChangeDate"
public static final java.lang.String | ORDER_BY_LASTCHANGETIME | "tr.lastChangeTime"
public static final java.lang.String | ORDER_BY_LASTUSER | "tr.lastUser"
public static final java.lang.String | ORDER_BY_LOCATE | "tr.locate"
public static final java.lang.String | ORDER_BY_ORIGIN | "tr.origin"
public static final java.lang.String | ORDER_BY_RECEIVEDBY | "tr.receivedBy"
public static final java.lang.String | ORDER_BY_RECEIVEDDATE | "tr.receivedDate"
public static final java.lang.String | ORDER_BY_RECEIVERCOMMENTS | "tr.receiverComments"
public static final java.lang.String | ORDER_BY_RECEIVERPRIVATENOTES | "tr.receiverPrivateNotes"
public static final java.lang.String | ORDER_BY_RELATEDDOCUMENT | "tr.relatedDocument"
public static final java.lang.String | ORDER_BY_SHIPVIA | "tr.shipVia"
public static final java.lang.String | ORDER_BY_STATUS | "tr.status"
public static final java.lang.String | ORDER_BY_TERMS | "tr.terms"
public static final java.lang.String | ORDER_BY_TOADDRESSID | "tr.toAddressId"
public static final java.lang.String | ORDER_BY_TRACKING | "tr.tracking"
public static final java.lang.String | ORDER_BY_TRANSFERORDERNUMBER | "tr.transferOrderNumber"
public static final java.lang.String | ORDER_BY_TRANSFERRECEIVERNUMBER | "tr.transferReceiverNumber"
public static final java.lang.String | ORDER_BY_TRANSFERSHIPPERNUMBER | "tr.transferShipperNumber"

bb.common.TransferShipperItemListResult
public static final java.lang.String | ORDER_BY_AVGCOST | "tois.avgCost"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "tois.description"
public static final java.lang.String | ORDER_BY_DWG | "tois.dwg"
public static final java.lang.String | ORDER_BY_ITEMCOMMENTS | "tois.itemComments"
public static final java.lang.String | ORDER_BY_ITEMPRIVATENOTES | "tois.itemPrivateNotes"
public static final java.lang.String | ORDER_BY_MFG | "tois.mfg"
public static final java.lang.String | ORDER_BY_MPN | "tois.mpn"
public static final java.lang.String | ORDER_BY_PARTFROM | "tois.partFrom"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "tois.partNumber"
public static final java.lang.String | ORDER_BY_PARTTYPE | "tois.partType"
public static final java.lang.String | ORDER_BY_RECEIVEDQTY | "tois.receivedQty"
public static final java.lang.String | ORDER_BY_REFDOC1 | "tois.refDoc1"
public static final java.lang.String | ORDER_BY_REFDOC2 | "tois.refDoc2"
public static final java.lang.String | ORDER_BY_REVISION | "tois.revision"
public static final java.lang.String | ORDER_BY_SHIPPEDDATE | "tois.shippedDate"
public static final java.lang.String | ORDER_BY_SHIPPEDQTY | "tois.shippedQty"
public static final java.lang.String | ORDER_BY_SHIPVIA | "tois.shipVia"
public static final java.lang.String | ORDER_BY_STATUS | "tois.status"
public static final java.lang.String | ORDER_BY_STDCOST | "tois.stdCost"
public static final java.lang.String | ORDER_BY_TRANSFERQTY | "tois.transferQty"
public static final java.lang.String | ORDER_BY_TRANSFERSHIPPERITEMNUMBER | "tois.pk.transferShipperItemNumber"
public static final java.lang.String | ORDER_BY_TRANSFERSHIPPERNUMBER | "tois.pk.transferShipperNumber"
public static final java.lang.String | ORDER_BY_UNIT | "tois.unit"

bb.common.TransferShipperListResult
public static final java.lang.String | ORDER_BY_ADATE | "tosh.adate"
public static final java.lang.String | ORDER_BY_ARFREIGHT | "tosh.arFreight"
public static final java.lang.String | ORDER_BY_CARRIER | "tosh.carrier"
public static final java.lang.String | ORDER_BY_CARRIERACCOUNT | "tosh.carrierAccount"
public static final java.lang.String | ORDER_BY_COCOMMENTS | "tosh.coComments"
public static final java.lang.String | ORDER_BY_CURRENCY | "tosh.currency"
public static final java.lang.String | ORDER_BY_FREIGHTRATECODE | "tosh.freightRateCode"
public static final java.lang.String | ORDER_BY_FROMADDRESSID | "tosh.fromAddressId"
public static final java.lang.String | ORDER_BY_FROMADDRESSNAME | "fromAddressInfo.name"
public static final java.lang.String | ORDER_BY_GROSSWEIGHT | "tosh.grossWeight"
public static final java.lang.String | ORDER_BY_INCOTERM | "tosh.incoterm"
public static final java.lang.String | ORDER_BY_INCOTERMPLACEPORT | "tosh.incotermPlacePort"
public static final java.lang.String | ORDER_BY_LANGUAGE | "tosh.language"
public static final java.lang.String | ORDER_BY_LASTCHANGEDATE | "tosh.lastChangeDate"
public static final java.lang.String | ORDER_BY_LASTCHANGETIME | "tosh.lastChangeTime"
public static final java.lang.String | ORDER_BY_LASTUSER | "tosh.lastUser"
public static final java.lang.String | ORDER_BY_ORIGIN | "tosh.origin"
public static final java.lang.String | ORDER_BY_RELATEDDOCUMENT | "tosh.relatedDocument"
public static final java.lang.String | ORDER_BY_SHIPACCOUT | "tosh.shipAccout"
public static final java.lang.String | ORDER_BY_SHIPPEDBY | "tosh.shippedBy"
public static final java.lang.String | ORDER_BY_SHIPPEDDATE | "tosh.shippedDate"
public static final java.lang.String | ORDER_BY_SHIPPERCOMMENTS | "tosh.shipperComments"
public static final java.lang.String | ORDER_BY_SHIPPERPRIVATENOTES | "tosh.shipperPrivateNotes"
public static final java.lang.String | ORDER_BY_SHIPVIA | "tosh.shipVia"
public static final java.lang.String | ORDER_BY_STATUS | "tosh.status"
public static final java.lang.String | ORDER_BY_TERMS | "tosh.terms"
public static final java.lang.String | ORDER_BY_TOADDRESSID | "tosh.toAddressId"
public static final java.lang.String | ORDER_BY_TOADDRESSNAME | "toAddressInfo.name"
public static final java.lang.String | ORDER_BY_TOTALCOST | "tosh.totalCost"
public static final java.lang.String | ORDER_BY_TRACKING | "tosh.tracking"
public static final java.lang.String | ORDER_BY_TRANSFERORDERNUMBER | "tosh.transferOrderNumber"
public static final java.lang.String | ORDER_BY_TRANSFERSHIPPERNUMBER | "tosh.transferShipperNumber"

bb.common.UnitVO
public static final java.lang.String | ORDER_BY_ID | "id"
public static final java.lang.String | ORDER_BY_UNITNAME | "unitName"

bb.common.UserRolePermissionListResult
public static final java.lang.String | ORDER_BY_PERMISSIONID | "permission.permissionId"
public static final java.lang.String | ORDER_BY_PERMISSIONNAME | "permissiondes.permissionName"
public static final java.lang.String | ORDER_BY_REFID | "user.refId"
public static final java.lang.String | ORDER_BY_ROLEID | "role.roleId"
public static final java.lang.String | ORDER_BY_ROLENAME | "roledes.roleName"
public static final java.lang.String | ORDER_BY_USERNAME | "user.userName"

bb.common.VendorCategoriesVO
public static final java.lang.String ORDER_BY_VENDORCATEGORY "vc.vendorCategory"

bb.common.VendorContractPriceItemVO
public static final java.lang.String | ORDER_BY_COMMENTS | "pt_contractv.comments"
public static final java.lang.String | ORDER_BY_CONTRACTNAME | "pt_contractv.contractName"
public static final java.lang.String | ORDER_BY_DISCOUNT | "pt_contractv.discount"
public static final java.lang.String | ORDER_BY_LISTPRICE | "pt_contractv.listPrice"
public static final java.lang.String | ORDER_BY_PK | "pt_contractv.pk.contractNumber"

bb.common.VendorContractPriceVendorVO
public static final java.lang.String | ORDER_BY_CONTRACTNAME | "contractName"
public static final java.lang.String | ORDER_BY_PK | "pk.contractNumber"

bb.common.VendorContractPriceVO
public static final java.lang.String | ORDER_BY_CONTRACTNUMBER | "contractNumber"
public static final java.lang.String | ORDER_BY_CURRENCY | "currency"
public static final java.lang.String | ORDER_BY_EXPIREDATE | "expireDate"
public static final java.lang.String | ORDER_BY_LASTCHANGEDATE | "lastChangeDate"
public static final java.lang.String | ORDER_BY_LASTCHANGEUSER | "lastChangeUser"
public static final java.lang.String | ORDER_BY_STARTDATE | "startDate"
public static final java.lang.String | ORDER_BY_STATUS | "status"

bb.common.VendorGroupUserVO
public static final java.lang.String | ORDER_BY_EMAIL | "vg.userEmail"
public static final java.lang.String | ORDER_BY_FAX | "vg.fax"
public static final java.lang.String | ORDER_BY_FULLNAME | "vg.fullName"
public static final java.lang.String | ORDER_BY_ID | "vg.vendorId"
public static final java.lang.String | ORDER_BY_MOBILE | "vg.mobile"
public static final java.lang.String | ORDER_BY_NAME | "vg.userName"

bb.common.VendorPartVO
public static final java.lang.String | ORDER_BY_PARTFROM | "partFrom"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "partNumber"
public static final java.lang.String | ORDER_BY_PARTTYPE | "partType"
public static final java.lang.String | ORDER_BY_PK_VENDORID | "pk.vendorId"
public static final java.lang.String | ORDER_BY_PK_VENDORPARTFROM | "pk.vendorPartFrom"
public static final java.lang.String | ORDER_BY_PK_VENDORPARTNUMBER | "pk.vendorPartNumber"
public static final java.lang.String | ORDER_BY_PK_VENDORPARTTYPE | "pk.vendorPartType"

bb.common.VendorStatementListResult
public static final java.lang.String | ORDER_BY_AMOUNTPAID | "ap.apPaidRcv"
public static final java.lang.String | ORDER_BY_APNUMBER | "ap.apNumber"
public static final java.lang.String | ORDER_BY_BALANCEDUE | "ap.due"
public static final java.lang.String | ORDER_BY_DATE | "ap.payDate"
public static final java.lang.String | ORDER_BY_OURPONUMBER | "ap.poNumber"
public static final java.lang.String | ORDER_BY_TOTALDUE | "ap.apTotal"
public static final java.lang.String | ORDER_BY_VENDORINVOICE | "ap.vendorInvoice"

bb.common.VendorTotalAmountInPO
public static final java.lang.String | ORDER_BY_GRANDTOTAL | "7"
public static final java.lang.String | ORDER_BY_NAME | "ab.name"
public static final java.lang.String | ORDER_BY_SUBTOTAL | "3"
public static final java.lang.String | ORDER_BY_TOTALDISCOUNT | "4"
public static final java.lang.String | ORDER_BY_TOTALFREIGHT | "6"
public static final java.lang.String | ORDER_BY_TOTALOPEN | "9"
public static final java.lang.String | ORDER_BY_TOTALRECEIVED | "8"
public static final java.lang.String | ORDER_BY_TOTALTAX | "5"
public static final java.lang.String | ORDER_BY_VENDORID | "po.vendorId"

bb.common.WarehouseVO
public static final java.lang.String | ORDER_BY_COMMENTS | "comments"
public static final java.lang.String | ORDER_BY_NAME | "name"
public static final java.lang.String | ORDER_BY_WAREHOUSEPREFIX | "warehousePrefix"

bb.common.WeightUnitVO
public static final java.lang.String | ORDER_BY_kg | "wtu.kg"
public static final java.lang.String | ORDER_BY_lbs | "wtu.lbs"
public static final java.lang.String | ORDER_BY_weightUnitName | "wtu.weightUnitName"

bb.common.WOItemPartDetailNotIssue
public static final java.lang.String | ORDER_BY_ASMPART | "woi.partNumber,woi.partType,woi.partFrom"
public static final java.lang.String | ORDER_BY_AVGCOST | "pt.averageCost"
public static final java.lang.String | ORDER_BY_DELIVERYDATE | "woi.dateRequired"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "wois.description"
public static final java.lang.String | ORDER_BY_ISSUEQUANTITY | "wois.issueQuantity"
public static final java.lang.String | ORDER_BY_ONDEMAND | "pt.partInventory.onDemandQty"
public static final java.lang.String | ORDER_BY_ONHAND | "pt.onhand"
public static final java.lang.String | ORDER_BY_ONORDER | "pt.partInventory.onOrderQty"
public static final java.lang.String | ORDER_BY_PART | "wois.partNumber,wois.partType,wois.partFrom"
public static final java.lang.String | ORDER_BY_PARTTYPE | "wois.partType,wois.partNumber,wois.partFrom"
public static final java.lang.String | ORDER_BY_QUANTITY | "wois.quantity"
public static final java.lang.String | ORDER_BY_QUANTITYASM | "woi.quantityAsm"
public static final java.lang.String | ORDER_BY_STARTDATE | "woi.startDate"
public static final java.lang.String | ORDER_BY_STDCOST | "pt.partInventory.standardCost"
public static final java.lang.String | ORDER_BY_WOIQQUANTITY | "woi.quantity"
public static final java.lang.String | ORDER_BY_WORKORDERITEMNUMBER | "woi.pk.workOrderItemNumber"
public static final java.lang.String | ORDER_BY_WORKORDERNUMBER | "woi.pk.workOrderNumber"

bb.common.WoItemWorkInstructionListResult
public static final java.lang.String | ORDER_BY_DUEDATE | "woi.dateRequired"
public static final java.lang.String | ORDER_BY_QTYK | "woi.quantity"
public static final java.lang.String | ORDER_BY_WORKORDERITEMNUMBER | "woi.pk.workOrderItemNumber"
public static final java.lang.String | ORDER_BY_WORKORDERNUMBER | "woi.pk.workOrderNumber"

bb.common.WOReceiverDetail
public static final java.lang.String | ORDER_BY_ACCOUNTNUMBER | "wo.debitAccount"
public static final java.lang.String | ORDER_BY_COMPANYUNITID | "rec.companyUnitId"
public static final java.lang.String | ORDER_BY_LASTCHANGEUSER | "rec.lastChangeUser"
public static final java.lang.String | ORDER_BY_LOCATION | "rec.location"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "rec.partNumber"
public static final java.lang.String | ORDER_BY_PROJECT | "wo.project"
public static final java.lang.String | ORDER_BY_VENDORID | "wo.vendorId"
public static final java.lang.String | ORDER_BY_WORKORDERITEMNUMBER | "rec.workOrderItemNumber"
public static final java.lang.String | ORDER_BY_WORKORDERNUMBER | "rec.workOrderNumber"

bb.common.WorkCenterGroupItemVO
public static final java.lang.String | ORDER_BY_PK | "pk.workCenterGroupId,pk.workCenterGroupItemNumber"
public static final java.lang.String | ORDER_BY_WORKCENTERID | "workCenterId"

bb.common.WorkCenterLoadAgent
public static final int n 6

bb.common.WorkCenterRunTimeListResult
public static final java.lang.String | ORDER_BY_AVGHRS | "avgHours"
public static final java.lang.String | ORDER_BY_AVGSETUP | "avgSetup"
public static final java.lang.String | ORDER_BY_DUEDATE | "delivery"
public static final java.lang.String | ORDER_BY_SEQNUMBER | "seq"
public static final java.lang.String | ORDER_BY_VENDORID | "id"
public static final java.lang.String | ORDER_BY_WORKCENTER | "wc"
public static final java.lang.String | ORDER_BY_WORKORDERITEMNUMBER | "wi"
public static final java.lang.String | ORDER_BY_WORKORDERNUMBER | "wo"

bb.common.WorkCenterVO
public static final java.lang.String | ORDER_BY_DEPARTMENT | "wc.department"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "wc.description"
public static final java.lang.String | ORDER_BY_LASTCHANGEUSER | "wc.lastChangeUser"
public static final java.lang.String | ORDER_BY_WORKCENTERID | "wc.workCenterId"

bb.common.WorkInstructionApprovalVO
public static final java.lang.String | ORDER_BY_CANAPPROVEOWNWORKINSTRUCTION | "canApproveOwnWorkInstruction"
public static final java.lang.String | ORDER_BY_EMPLOYEEID | "employeeId"

bb.common.WorkInstructionListResult
public static final java.lang.String | ORDER_BY_APPROVED | "wistatus.approved"
public static final java.lang.String | ORDER_BY_APPROVEDBY | "wistatus.approvedBy"
public static final java.lang.String | ORDER_BY_AUTHOR | "wistatus.author"
public static final java.lang.String | ORDER_BY_EFFECTIVEDATE | "wistatus.effectiveDate"
public static final java.lang.String | ORDER_BY_ENGINEERINGDESCRIPTION | "ps.description"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "wistatus.pk.partNumber,wistatus.pk.partType,wistatus.pk.partFrom"
public static final java.lang.String | ORDER_BY_PROOFREADER | "wistatus.proofreader"
public static final java.lang.String | ORDER_BY_STATUS | "wistatus.status"
public static final java.lang.String | ORDER_BY_WIDESCRIPTION | "wistatus.description"

bb.common.WorkInstructionRequestForChangeVO
public static final java.lang.String | ORDER_BY_APPROVEDBY | "approvedBy"
public static final java.lang.String | ORDER_BY_APPROVEDDATE | "approvedDate"
public static final java.lang.String | ORDER_BY_DUEDATE | "dueDate"
public static final java.lang.String | ORDER_BY_ORIGINATEDDATE | "originatedDate"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "partNumber"
public static final java.lang.String | ORDER_BY_RFCNUMBER | "rfcNumber"
public static final java.lang.String | ORDER_BY_STATUS | "status"
public static final java.lang.String | ORDER_BY_WISEQUENCE | "wiSequence"
public static final java.lang.String | ORDER_BY_WORKCENTERID | "workCenterId"

bb.common.WorkInstructionSeqAuditListResult
public static final java.lang.String | ORDER_BY_NEWAVGHRS | "t.newAvgHrs"
public static final java.lang.String | ORDER_BY_WISEQPK | "t.partNumber, t.partType, t.partFrom, t.setId, t.sequenceNumber"
public static final java.lang.String | ORDER_BY_WORKCENTER | "t.workCenter"

bb.common.WorkInstructionSequenceListResult
public static final java.lang.String | ORDER_BY_AUTHOR | "wi.author"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "wis.pk.partNumber"
public static final java.lang.String | ORDER_BY_SEQUENCESTATUS | "wis.status"
public static final java.lang.String | ORDER_BY_WISEQUENCENUMBER | "wis.pk.sequenceNumber"
public static final java.lang.String | ORDER_BY_WORKCENTER | "wis.workCenter"
public static final java.lang.String | ORDER_BY_WORKINSTRUCTIONREV | "wi.workInstructionRev"

bb.common.WorkOrderApprovalVO
public static final java.lang.String | ORDER_BY_APPROVELIMIT | "approveLimit"
public static final java.lang.String | ORDER_BY_CANAPPROVEOWNPURCHASEORDER | "canApproveOwnPurchaseOrder"
public static final java.lang.String | ORDER_BY_CURRENCY | "currency"
public static final java.lang.String | ORDER_BY_EMPLOYEEID | "employeeId"
public static final java.lang.String | ORDER_BY_USERNAME | "userName"

bb.common.WorkOrderBoilerplateVO
public static final java.lang.String | ORDER_BY_BOILERPLATEID | "tt.boilerplateId"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "tt.description"
public static final java.lang.String | ORDER_BY_WOBOILERPLATE | "tt.woBoilerplate"

bb.common.WorkOrderCheckListResult
public static final java.lang.String | ORDER_BY_VENDORID | "wo.vendorId"
public static final java.lang.String | ORDER_BY_WODATE | "wo.entered"
public static final java.lang.String | ORDER_BY_WONUMBER | "wo.workOrderNumber"

bb.common.WorkOrderItemCanAssyResult
public static final java.lang.String | ORDER_BY_DATEREQUIRED | "woi.dateRequired"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "woi.description"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "woi.partNumber"
public static final java.lang.String | ORDER_BY_PK | "woi.pk.workOrderNumber,woi.pk.workOrderItemNumber"
public static final java.lang.String | ORDER_BY_STARTDATE | "woi.startDate"

bb.common.WorkOrderItemInfoResult
public static final java.lang.String | ORDER_BY_PARTNUMBER | "woi.partNumber"
public static final java.lang.String | ORDER_BY_PARTTYPE | "woi.partType"
public static final java.lang.String | ORDER_BY_QUANTITY | "woi.quantity "
public static final java.lang.String | ORDER_BY_RELATEDDOC | "woi.relatedDoc"
public static final java.lang.String | ORDER_BY_WORKORDERITEMNUMBER | "woi.pk.workOrderItemNumber"
public static final java.lang.String | ORDER_BY_WORKORDERNUMBER | "woi.pk.workOrderNumber"

bb.common.WorkOrderItemInWipListResult
public static final java.lang.String | ORDER_BY_AVGCOST | "pti.cost"
public static final java.lang.String | ORDER_BY_CURRENCY | "wo.currency"
public static final java.lang.String | ORDER_BY_DATEISSUE | "wois.dateIssued"
public static final java.lang.String | ORDER_BY_ISSUEAVGCOST | "wois.cost"
public static final java.lang.String | ORDER_BY_MFGSTATUS | "woi.mfgStatus"
public static final java.lang.String | ORDER_BY_ORIGINATOR | "wo.originator"
public static final java.lang.String | ORDER_BY_PARTDESC | "wois.description"
public static final java.lang.String | ORDER_BY_PARTPK | "wois.partNumber,wois.partType"
public static final java.lang.String | ORDER_BY_RELATEDDOC | "wois.referenceDoc1"
public static final java.lang.String | ORDER_BY_STDCOST | "pti.stdCost"
public static final java.lang.String | ORDER_BY_WORKORDERNUMBER | "woi.pk.workOrderNumber,woi.pk.workOrderItemNumber"

bb.common.WorkOrderItemIssuedTotalResult
public static final java.lang.String | ORDER_BY_MODELNUMBER | "woii.mn"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "woii.pn, woii.pa"
public static final java.lang.String | ORDER_BY_PARTTYPE | "woii.pn, woii.pa"
public static final java.lang.String | ORDER_BY_RELATEDDOC | "woi.reldoc"
public static final java.lang.String | ORDER_BY_WORKORDERITEMNUMBER | "woi.wo, woi.wi"
public static final java.lang.String | ORDER_BY_WORKORDERNUMBER | "woi.wo, woi.wi"

bb.common.WorkOrderItemListResult
public static final java.lang.String | ORDER_BY_ACCOUNTNUMBER | "wo.dacct1"
public static final java.lang.String | ORDER_BY_ASM | "woi.asm"
public static final java.lang.String | ORDER_BY_COMPANYUNITID | "wo.co_unit_id"
public static final java.lang.String | ORDER_BY_COMPLETEDDATE | "woim.date_made"
public static final java.lang.String | ORDER_BY_COSTPERUNIT | "woi.cost"
public static final java.lang.String | ORDER_BY_CURRENCY | "wo.currency"
public static final java.lang.String | ORDER_BY_DUEDATE | "woi.delivery"
public static final java.lang.String | ORDER_BY_EXTENDPRICE | "woi.wo_net"
public static final java.lang.String | ORDER_BY_MFGSTATUS | "woi.man_status"
public static final java.lang.String | ORDER_BY_ORDERRELATEDDOC | "wo.reldoc"
public static final java.lang.String | ORDER_BY_ORIGINATOR | "wo.originator"
public static final java.lang.String | ORDER_BY_PARTDESC | "description"
public static final java.lang.String | ORDER_BY_PARTPK | "woi.pn"
public static final java.lang.String | ORDER_BY_PRIORITY | "woi.priority"
public static final java.lang.String | ORDER_BY_PROJECT | "wo.project"
public static final java.lang.String | ORDER_BY_QTY | "woi.qty"
public static final java.lang.String | ORDER_BY_RELATEDDOC | "woi.reldoc"
public static final java.lang.String | ORDER_BY_STARTDATE | "woi.start_date"
public static final java.lang.String | ORDER_BY_STATUS | "woi.status"
public static final java.lang.String | ORDER_BY_STDCOST | "woi.std_cost"
public static final java.lang.String | ORDER_BY_TOBEASM | "toBeAsm"
public static final java.lang.String | ORDER_BY_VENDORID | "wo.id"
public static final java.lang.String | ORDER_BY_WORKORDERITEMNUMBER | "woi.wo,woi.wi"
public static final java.lang.String | ORDER_BY_WORKORDERNUMBER | "woi.wo,woi.wi"

bb.common.WorkOrderItemPartDetail
public static final java.lang.String | ORDER_BY_ACTUAL | "woi.actual"
public static final java.lang.String | ORDER_BY_COST | "wois.cost"
public static final java.lang.String | ORDER_BY_ISSUEQUANTITY | "wois.issueQuantity"
public static final java.lang.String | ORDER_BY_PARTDESC | "wois.description"
public static final java.lang.String | ORDER_BY_PARTPK | "temp_ps.pk"
public static final java.lang.String | ORDER_BY_QUANTITY | "wois.quantity"
public static final java.lang.String | ORDER_BY_RELATEDDOC | "woi.relatedDoc"
public static final java.lang.String | ORDER_BY_STATUS | "woi.status"
public static final java.lang.String | ORDER_BY_UNIT | "wois.unit"
public static final java.lang.String | ORDER_BY_WOITEMPK | "woi.pk"

bb.common.WorkOrderItemPartDetailInWipVO
public static final java.lang.String | ORDER_BY_COMPANYUNITID | "companyUnitId"
public static final java.lang.String | ORDER_BY_COST | "cost"
public static final java.lang.String | ORDER_BY_DATEISSUED | "dateIssued"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "description"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "partNumber"
public static final java.lang.String | ORDER_BY_QTYINWIP | "qtyInWip"
public static final java.lang.String | ORDER_BY_STDCOST | "stdCost"
public static final java.lang.String | ORDER_BY_TRANSACTIONNUMBER | "transactionNumber"
public static final java.lang.String | ORDER_BY_WOISCOST | "woisCost"
public static final java.lang.String | ORDER_BY_WOISSTDCOST | "woisStdCost"
public static final java.lang.String | ORDER_BY_WORKORDERNUMBER | "workOrderNumber,workOrderItemNumber"

bb.common.WorkOrderItemReviewCostResult
public static final java.lang.String | ORDER_BY_DATEREQUIRED | "woi.dateRequired"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "woi.description"
public static final java.lang.String | ORDER_BY_OVERPERCENT | "woi.overPercent"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "woi.partNumber"
public static final java.lang.String | ORDER_BY_PK | "woi.pk.workOrderNumber,woi.pk.workOrderItemNumber"
public static final java.lang.String | ORDER_BY_REVIEWDESCRIPTION | "woi.reviewDescription"
public static final java.lang.String | ORDER_BY_REVIEWEDBY | "woi.reviewedBy"
public static final java.lang.String | ORDER_BY_REVIEWEDDATE | "woi.reviewedDate"
public static final java.lang.String | ORDER_BY_STARTDATE | "woi.startDate"
public static final java.lang.String | ORDER_BY_STATUS | "woi.status"
public static final java.lang.String | ORDER_BY_VENDORID | "wo.vendorId"

bb.common.WorkOrderItemTimeDetailVO
public static final java.lang.String | ORDER_BY_EMPLOYEE | "card.employee"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "card.partNumber"
public static final java.lang.String | ORDER_BY_PARTTYPE | "partType"
public static final java.lang.String | ORDER_BY_REVISION | "card.revision"
public static final java.lang.String | ORDER_BY_SERIALNUMBER | "card.serialNumber"
public static final java.lang.String | ORDER_BY_TIMEOFF | "card.timeOff"
public static final java.lang.String | ORDER_BY_TIMEON | "card.timeOn"
public static final java.lang.String | ORDER_BY_VENDORID | "card.vendorId"
public static final java.lang.String | ORDER_BY_WORKCENTER | "card.workCenter"
public static final java.lang.String | ORDER_BY_WORKORDERNUMBER | "card.workOrderNumber,card.workOrderItemNumber,card.workInstructionSequence,card.ii"

bb.common.WorkOrderItemToIssueResult
public static final java.lang.String | ORDER_BY_DELIVERY | "woi.dateRequired"
public static final java.lang.String | ORDER_BY_DESCRIPTION | "woi.description"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "woi.partNumber"
public static final java.lang.String | ORDER_BY_PK | "woi.pk.workOrderNumber, woi.pk.workOrderItemNumber"
public static final java.lang.String | ORDER_BY_STARTDATE | "woi.startDate"
public static final java.lang.String | ORDER_BY_VENDORID | "wo.vendorId"

bb.common.WorkOrderListResult
public static final java.lang.String | ORDER_BY_PROJECT | "wo.project"
public static final java.lang.String | ORDER_BY_STATUS | "wo.status"
public static final java.lang.String | ORDER_BY_VENDORID | "wo.vendorId"
public static final java.lang.String | ORDER_BY_VENDORNAME | "ab.name"
public static final java.lang.String | ORDER_BY_WONUMBER | "wo.workOrderNumber"

bb.common.WorkOrderOnTimeItemResult
public static final java.lang.String | FISCAL_YEAR | "Fiscal Year"
public static final java.lang.String | MONTH_12_AVG | "12 Month Avg"
public static final java.lang.String | YEAR_TO_DATE | "Year to Date"

bb.common.WorkOrderOverIssueListResult
public static final java.lang.String | ORDER_BY_ISSUEQUANTITY | "wois.issueQuantity"
public static final java.lang.String | ORDER_BY_PARTDESCRIPTION | "wois.description"
public static final java.lang.String | ORDER_BY_PARTPK | "wois.partNumber"
public static final java.lang.String | ORDER_BY_VENDORID | "wo.vendorId"
public static final java.lang.String | ORDER_BY_WORKORDERNUMBER | "woi.pk.workOrderNumber,woi.pk.workOrderItemNumber"

bb.common.WorkOrderTimeCardVO
public static final java.lang.String | ORDER_BY_EMPLOYEEID | "card.employeeId"
public static final java.lang.String | ORDER_BY_EMPLOYEENAME | "card.employeeName"
public static final java.lang.String | ORDER_BY_II | "card.ii"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "card.partNumber"
public static final java.lang.String | ORDER_BY_VENDORID | "card.vendorId"
public static final java.lang.String | ORDER_BY_WORKCENTER | "card.workCenter"
public static final java.lang.String | ORDER_BY_WORKINSCTRUCTIONSEQUENCE | "card.workInsctructionSequence"
public static final java.lang.String | ORDER_BY_WORKORDERITEMNUMBER | "card.workOrderItemNumber"
public static final java.lang.String | ORDER_BY_WORKORDERNUMBER | "card.workOrderNumber"

bb.common.WorkOrderWorkInstructionListResult
public static final java.lang.String | ORDER_BY_DESCRIPTION | "woi.description"
public static final java.lang.String | ORDER_BY_PARTNUMBER | "woi.partNumber,woi.partType"
public static final java.lang.String | ORDER_BY_WORKORDERITEMNUMBER | "woi.pk.workOrderItemNumber"
public static final java.lang.String | ORDER_BY_WORKORDERNUMBER | "woi.pk.workOrderNumber"

bb.common.WorkOrderWorkSheetVO
public static final java.lang.String | ORDER_BY_COMPANYUNITID | "ws.companyUnitId"
public static final java.lang.String | ORDER_BY_DUEDATE | "ws.dueDate"
public static final java.lang.String | ORDER_BY_EMPLOYEEEMAIL | "ws.employeeEmail"
public static final java.lang.String | ORDER_BY_PK | "ws.pk.employeeId,ws.pk.workSheetNumber"

bb.common.ZipCodeTaxVO
public static final java.lang.String ORDER_BY_ZIPTO "zipTo"

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Constant.ActiveStatus

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.ActiveStatus

java.lang.Object
    extended by  bb.common.Constant.ActiveStatus
Enclosing class:
Constant
public static final class Constant.ActiveStatus
extends java.lang.Object

Field Summary
static java.lang.String | no
static java.lang.String | yes
Constructor Summary
Constant.ActiveStatus()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

yes

public static final java.lang.String yes
See Also:
Constant Field Values

no

public static final java.lang.String no
See Also:
Constant Field Values
Constructor Detail

Constant.ActiveStatus

public Constant.ActiveStatus()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.AddressType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.AddressType

java.lang.Object
    extended by  bb.common.Constant.AddressType
Enclosing class:
Constant
public static final class Constant.AddressType
extends java.lang.Object

Field Summary
static java.lang.String | CUSTOMER
static java.lang.String | VENDOR
Constructor Summary
Constant.AddressType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CUSTOMER

public static final java.lang.String CUSTOMER
See Also:
Constant Field Values

VENDOR

public static final java.lang.String VENDOR
See Also:
Constant Field Values
Constructor Detail

Constant.AddressType

public Constant.AddressType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.AgeLevel

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.AgeLevel

java.lang.Object
    extended by  bb.common.Constant.AgeLevel
Enclosing class:
Constant
public static final class Constant.AgeLevel
extends java.lang.Object

Field Summary
static java.lang.String | EIGHTLEVEL
static java.lang.String | FIVELEVEL
static java.lang.String | FOURLEVEL
static java.lang.String | NINELEVEL
static java.lang.String | ONELEVEL
static java.lang.String | SEVENLEVEL
static java.lang.String | SIXLEVEL
static java.lang.String | TENLEVEL
static java.lang.String | THREELEVEL
static java.lang.String | TWOLEVEL
Constructor Summary
Constant.AgeLevel()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ONELEVEL

public static java.lang.String ONELEVEL

TWOLEVEL

public static java.lang.String TWOLEVEL

THREELEVEL

public static java.lang.String THREELEVEL

FOURLEVEL

public static java.lang.String FOURLEVEL

FIVELEVEL

public static java.lang.String FIVELEVEL

SIXLEVEL

public static java.lang.String SIXLEVEL

SEVENLEVEL

public static java.lang.String SEVENLEVEL

EIGHTLEVEL

public static java.lang.String EIGHTLEVEL

NINELEVEL

public static java.lang.String NINELEVEL

TENLEVEL

public static java.lang.String TENLEVEL
Constructor Detail

Constant.AgeLevel

public Constant.AgeLevel()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.AmountType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.AmountType

java.lang.Object
    extended by  bb.common.Constant.AmountType
Enclosing class:
Constant
public static final class Constant.AmountType
extends java.lang.Object

Field Summary
static java.lang.String | ACA
static java.lang.String | ADA
static java.lang.String | B
static java.lang.String | BB
static java.lang.String | BCB
static java.lang.String | BDB
static java.lang.String | CA
static java.lang.String | CB
static java.lang.String | DA
static java.lang.String | DB
static java.lang.String | PLA
static java.lang.String | PLB
Constructor Summary
Constant.AmountType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

B

public static final java.lang.String B
See Also:
Constant Field Values

BB

public static final java.lang.String BB
See Also:
Constant Field Values

BDB

public static final java.lang.String BDB
See Also:
Constant Field Values

BCB

public static final java.lang.String BCB
See Also:
Constant Field Values

DA

public static final java.lang.String DA
See Also:
Constant Field Values

CA

public static final java.lang.String CA
See Also:
Constant Field Values

ADA

public static final java.lang.String ADA
See Also:
Constant Field Values

ACA

public static final java.lang.String ACA
See Also:
Constant Field Values

DB

public static final java.lang.String DB
See Also:
Constant Field Values

CB

public static final java.lang.String CB
See Also:
Constant Field Values

PLA

public static final java.lang.String PLA
See Also:
Constant Field Values

PLB

public static final java.lang.String PLB
See Also:
Constant Field Values
Constructor Detail

Constant.AmountType

public Constant.AmountType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.ARDiscountMethod

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.ARDiscountMethod

java.lang.Object
    extended by  bb.common.Constant.ARDiscountMethod
Enclosing class:
Constant
public static final class Constant.ARDiscountMethod
extends java.lang.Object

Field Summary
static java.lang.String | GrossPrice
static java.lang.String | NetPrice
Constructor Summary
Constant.ARDiscountMethod()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

GrossPrice

public static final java.lang.String GrossPrice
See Also:
Constant Field Values

NetPrice

public static final java.lang.String NetPrice
See Also:
Constant Field Values
Constructor Detail

Constant.ARDiscountMethod

public Constant.ARDiscountMethod()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.CategoryReportType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.CategoryReportType

java.lang.Object
    extended by  bb.common.Constant.CategoryReportType
Enclosing class:
Constant
public static final class Constant.CategoryReportType
extends java.lang.Object

Field Summary
static java.lang.String | BALANCE_SHEET
static java.lang.String | BALANCE_SHEET_PRE
static java.lang.String | EBIDTA_DETAIL
static java.lang.String | PROFIT_LOSS
static java.lang.String | PROFIT_LOSS_PRE
static java.lang.String | TAX_DETAIL
static java.lang.String | TAX_DETAIL_PRE
Constructor Summary
Constant.CategoryReportType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

BALANCE_SHEET

public static final java.lang.String BALANCE_SHEET
See Also:
Constant Field Values

PROFIT_LOSS

public static final java.lang.String PROFIT_LOSS
See Also:
Constant Field Values

TAX_DETAIL

public static final java.lang.String TAX_DETAIL
See Also:
Constant Field Values

EBIDTA_DETAIL

public static final java.lang.String EBIDTA_DETAIL
See Also:
Constant Field Values

TAX_DETAIL_PRE

public static final java.lang.String TAX_DETAIL_PRE
See Also:
Constant Field Values

BALANCE_SHEET_PRE

public static final java.lang.String BALANCE_SHEET_PRE
See Also:
Constant Field Values

PROFIT_LOSS_PRE

public static final java.lang.String PROFIT_LOSS_PRE
See Also:
Constant Field Values
Constructor Detail

Constant.CategoryReportType

public Constant.CategoryReportType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.CategoryType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.CategoryType

java.lang.Object
    extended by  bb.common.Constant.CategoryType
Enclosing class:
Constant
public static final class Constant.CategoryType
extends java.lang.Object

Field Summary
static java.lang.String | CATEGORY_ASSETS
static java.lang.String | CATEGORY_EQUITY
static java.lang.String | CATEGORY_LIABILITIES
Constructor Summary
Constant.CategoryType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CATEGORY_ASSETS

public static final java.lang.String CATEGORY_ASSETS
See Also:
Constant Field Values

CATEGORY_LIABILITIES

public static final java.lang.String CATEGORY_LIABILITIES
See Also:
Constant Field Values

CATEGORY_EQUITY

public static final java.lang.String CATEGORY_EQUITY
See Also:
Constant Field Values
Constructor Detail

Constant.CategoryType

public Constant.CategoryType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.ChartOfAccountSubType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.ChartOfAccountSubType

java.lang.Object
    extended by  bb.common.Constant.ChartOfAccountSubType
Enclosing class:
Constant
public static final class Constant.ChartOfAccountSubType
extends java.lang.Object

Field Summary
static java.lang.String | BANK
static java.lang.String | CASH
static java.lang.String | OTHER
Constructor Summary
Constant.ChartOfAccountSubType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CASH

public static final java.lang.String CASH
See Also:
Constant Field Values

BANK

public static final java.lang.String BANK
See Also:
Constant Field Values

OTHER

public static final java.lang.String OTHER
See Also:
Constant Field Values
Constructor Detail

Constant.ChartOfAccountSubType

public Constant.ChartOfAccountSubType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.ChartOfAccountType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.ChartOfAccountType

java.lang.Object
    extended by  bb.common.Constant.ChartOfAccountType
Enclosing class:
Constant
public static final class Constant.ChartOfAccountType
extends java.lang.Object

Field Summary
static java.lang.String | AC
static java.lang.String | AD
static java.lang.String | AF
static java.lang.String | AL
static java.lang.String | EG
static java.lang.String | EL
static java.lang.String | EN
static java.lang.String | EO
static java.lang.String | ET
static java.lang.String | EW
static java.lang.String | LC
static java.lang.String | LL
static java.lang.String | LO
static java.lang.String | QN
static java.lang.String | QR
static java.lang.String | RN
static java.lang.String | RO
Constructor Summary
Constant.ChartOfAccountType()
Method Summary
static java.lang.String[] | getAllBSValues()
static java.lang.String[] | getAllValues()
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

EG

public static final java.lang.String EG
See Also:
Constant Field Values

EL

public static final java.lang.String EL
See Also:
Constant Field Values

EN

public static final java.lang.String EN
See Also:
Constant Field Values

EW

public static final java.lang.String EW
See Also:
Constant Field Values

EO

public static final java.lang.String EO
See Also:
Constant Field Values

ET

public static final java.lang.String ET
See Also:
Constant Field Values

RN

public static final java.lang.String RN
See Also:
Constant Field Values

RO

public static final java.lang.String RO
See Also:
Constant Field Values

QN

public static final java.lang.String QN
See Also:
Constant Field Values

QR

public static final java.lang.String QR
See Also:
Constant Field Values

LC

public static final java.lang.String LC
See Also:
Constant Field Values

LL

public static final java.lang.String LL
See Also:
Constant Field Values

AF

public static final java.lang.String AF
See Also:
Constant Field Values

AC

public static final java.lang.String AC
See Also:
Constant Field Values

AL

public static final java.lang.String AL
See Also:
Constant Field Values

AD

public static final java.lang.String AD
See Also:
Constant Field Values

LO

public static final java.lang.String LO
See Also:
Constant Field Values
Constructor Detail

Constant.ChartOfAccountType

public Constant.ChartOfAccountType()
Method Detail

getAllValues

public static java.lang.String[] getAllValues()

getAllBSValues

public static java.lang.String[] getAllBSValues()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.CheckType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.CheckType

java.lang.Object
    extended by  bb.common.Constant.CheckType
Enclosing class:
Constant
public static final class Constant.CheckType
extends java.lang.Object

Field Summary
static java.lang.String | ALL
static java.lang.String | PAID
static java.lang.String | PAID_RECEIVED
static java.lang.String | RECEIVED
Constructor Summary
Constant.CheckType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ALL

public static final java.lang.String ALL
See Also:
Constant Field Values

PAID

public static final java.lang.String PAID
See Also:
Constant Field Values

RECEIVED

public static final java.lang.String RECEIVED
See Also:
Constant Field Values

PAID_RECEIVED

public static final java.lang.String PAID_RECEIVED
See Also:
Constant Field Values
Constructor Detail

Constant.CheckType

public Constant.CheckType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.CostControl

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.CostControl

java.lang.Object
    extended by  bb.common.Constant.CostControl
Enclosing class:
Constant
public static final class Constant.CostControl
extends java.lang.Object

Field Summary
static java.lang.String | AVGCOST
static java.lang.String | STDCOST
Constructor Summary
Constant.CostControl()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

AVGCOST

public static final java.lang.String AVGCOST
See Also:
Constant Field Values

STDCOST

public static final java.lang.String STDCOST
See Also:
Constant Field Values
Constructor Detail

Constant.CostControl

public Constant.CostControl()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.CustomerVendorMailType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.CustomerVendorMailType

java.lang.Object
    extended by  bb.common.Constant.CustomerVendorMailType
Enclosing class:
Constant
public static final class Constant.CustomerVendorMailType
extends java.lang.Object

Field Summary
static java.lang.String | ACCOUNTING_MAIL
static java.lang.String | PO_MAIL
static java.lang.String | SO_MAIL
Constructor Summary
Constant.CustomerVendorMailType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

PO_MAIL

public static final java.lang.String PO_MAIL
See Also:
Constant Field Values

SO_MAIL

public static final java.lang.String SO_MAIL
See Also:
Constant Field Values

ACCOUNTING_MAIL

public static final java.lang.String ACCOUNTING_MAIL
See Also:
Constant Field Values
Constructor Detail

Constant.CustomerVendorMailType

public Constant.CustomerVendorMailType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.CVAddressType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.CVAddressType

java.lang.Object
    extended by  bb.common.Constant.CVAddressType
Enclosing class:
Constant
public static final class Constant.CVAddressType
extends java.lang.Object

Field Summary
static java.lang.String | ALL
static java.lang.String | CUSTOMER
static java.lang.String | DEPARTMENT
static java.lang.String | VENDOR
Constructor Summary
Constant.CVAddressType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CUSTOMER

public static java.lang.String CUSTOMER

VENDOR

public static java.lang.String VENDOR

DEPARTMENT

public static java.lang.String DEPARTMENT

ALL

public static java.lang.String ALL
Constructor Detail

Constant.CVAddressType

public Constant.CVAddressType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.CycleCountPeriodUnit

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.CycleCountPeriodUnit

java.lang.Object
    extended by  bb.common.Constant.CycleCountPeriodUnit
Enclosing class:
Constant
public static final class Constant.CycleCountPeriodUnit
extends java.lang.Object

Field Summary
static java.lang.String | HALFYEAR
static java.lang.String | MONTH
static java.lang.String | QUARTER
static java.lang.String | WEEK
static java.lang.String | YEAR
Constructor Summary
Constant.CycleCountPeriodUnit()
Method Summary
static java.lang.String | filter(java.lang.String periodUnit)
static java.lang.String[] | getUnits()
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

WEEK

public static final java.lang.String WEEK
See Also:
Constant Field Values

MONTH

public static final java.lang.String MONTH
See Also:
Constant Field Values

QUARTER

public static final java.lang.String QUARTER
See Also:
Constant Field Values

HALFYEAR

public static final java.lang.String HALFYEAR
See Also:
Constant Field Values

YEAR

public static final java.lang.String YEAR
See Also:
Constant Field Values
Constructor Detail

Constant.CycleCountPeriodUnit

public Constant.CycleCountPeriodUnit()
Method Detail

filter

public static java.lang.String filter(java.lang.String periodUnit)

getUnits

public static java.lang.String[] getUnits()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.DataFilterType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.DataFilterType

java.lang.Object
    extended by  bb.common.Constant.DataFilterType
Enclosing class:
Constant
public static final class Constant.DataFilterType
extends java.lang.Object

Field Summary
static java.lang.String | PROPERTY
static java.lang.String | RECORD
Constructor Summary
Constant.DataFilterType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

RECORD

public static java.lang.String RECORD

PROPERTY

public static java.lang.String PROPERTY
Constructor Detail

Constant.DataFilterType

public Constant.DataFilterType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.DateType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.DateType

java.lang.Object
    extended by  bb.common.Constant.DateType
Enclosing class:
Constant
public static final class Constant.DateType
extends java.lang.Object

Field Summary
static java.lang.String | ARRIVALDATE
static java.lang.String | CFB_DATE
static java.lang.String | CHECKRUNDATE
static java.lang.String | CLOSEDDATE
static java.lang.String | CMDATE
static java.lang.String | CREATE_DATE
static java.lang.String | DUEDATE
static java.lang.String | INVOICEDATE
static java.lang.String | ISSUEDATE
static java.lang.String | LAST_DATE
static java.lang.String | NCRDATE
static java.lang.String | ORIGINALARRIVALDATE
static java.lang.String | ORIGINALSHIPDATE
static java.lang.String | PAIDDATE
static java.lang.String | PODATE
static java.lang.String | RECEIVEDDATE
static java.lang.String | REQUESTDATE
static java.lang.String | RFQDATE
static java.lang.String | SHIPDATE
static java.lang.String | SODATE
static java.lang.String | STARTDATE
static java.lang.String | SWAPDATE
static java.lang.String | TRANSFERORDERDATE
static java.lang.String | WODATE
Constructor Summary
Constant.DateType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

PODATE

public static final java.lang.String PODATE
See Also:
Constant Field Values

SODATE

public static final java.lang.String SODATE
See Also:
Constant Field Values

WODATE

public static final java.lang.String WODATE
See Also:
Constant Field Values

CMDATE

public static final java.lang.String CMDATE
See Also:
Constant Field Values

SHIPDATE

public static final java.lang.String SHIPDATE
See Also:
Constant Field Values

ARRIVALDATE

public static final java.lang.String ARRIVALDATE
See Also:
Constant Field Values

ORIGINALARRIVALDATE

public static final java.lang.String ORIGINALARRIVALDATE
See Also:
Constant Field Values

ORIGINALSHIPDATE

public static final java.lang.String ORIGINALSHIPDATE
See Also:
Constant Field Values

DUEDATE

public static final java.lang.String DUEDATE
See Also:
Constant Field Values

STARTDATE

public static final java.lang.String STARTDATE
See Also:
Constant Field Values

CHECKRUNDATE

public static final java.lang.String CHECKRUNDATE
See Also:
Constant Field Values

RECEIVEDDATE

public static final java.lang.String RECEIVEDDATE
See Also:
Constant Field Values

PAIDDATE

public static final java.lang.String PAIDDATE
See Also:
Constant Field Values

INVOICEDATE

public static final java.lang.String INVOICEDATE
See Also:
Constant Field Values

REQUESTDATE

public static final java.lang.String REQUESTDATE
See Also:
Constant Field Values

ISSUEDATE

public static final java.lang.String ISSUEDATE
See Also:
Constant Field Values

CREATE_DATE

public static final java.lang.String CREATE_DATE
See Also:
Constant Field Values

LAST_DATE

public static final java.lang.String LAST_DATE
See Also:
Constant Field Values

CFB_DATE

public static final java.lang.String CFB_DATE
See Also:
Constant Field Values

NCRDATE

public static final java.lang.String NCRDATE
See Also:
Constant Field Values

CLOSEDDATE

public static final java.lang.String CLOSEDDATE
See Also:
Constant Field Values

TRANSFERORDERDATE

public static final java.lang.String TRANSFERORDERDATE
See Also:
Constant Field Values

SWAPDATE

public static final java.lang.String SWAPDATE
See Also:
Constant Field Values

RFQDATE

public static final java.lang.String RFQDATE
See Also:
Constant Field Values
Constructor Detail

Constant.DateType

public Constant.DateType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.DebitOrCredit

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.DebitOrCredit

java.lang.Object
    extended by  bb.common.Constant.DebitOrCredit
Enclosing class:
Constant
public static final class Constant.DebitOrCredit
extends java.lang.Object

Field Summary
static java.lang.String | CREDIT
static java.lang.String | DEBIT
static java.lang.String | EQUITY
Constructor Summary
Constant.DebitOrCredit()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DEBIT

public static java.lang.String DEBIT

EQUITY

public static java.lang.String EQUITY

CREDIT

public static java.lang.String CREDIT
Constructor Detail

Constant.DebitOrCredit

public Constant.DebitOrCredit()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.Depreciation

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.Depreciation

java.lang.Object
    extended by  bb.common.Constant.Depreciation
Enclosing class:
Constant
public static final class Constant.Depreciation
extends java.lang.Object

Nested Class Summary
static class | Constant.Depreciation.DepreciateStatus
static class | Constant.Depreciation.DepreciationMethod
static class | Constant.Depreciation.UsingType
Constructor Summary
Constant.Depreciation()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Constant.Depreciation

public Constant.Depreciation()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.Depreciation.DepreciateStatus

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.Depreciation.DepreciateStatus

java.lang.Object
    extended by  bb.common.Constant.Depreciation.DepreciateStatus
Enclosing class:
Constant.Depreciation
public static final class Constant.Depreciation.DepreciateStatus
extends java.lang.Object

Field Summary
static java.lang.String | CLOSED_DEPRECIATE
static java.lang.String | IN_DEPRECIATE
static java.lang.String | UNDEPRECIATE
Constructor Summary
Constant.Depreciation.DepreciateStatus()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

IN_DEPRECIATE

public static final java.lang.String IN_DEPRECIATE
See Also:
Constant Field Values

UNDEPRECIATE

public static final java.lang.String UNDEPRECIATE
See Also:
Constant Field Values

CLOSED_DEPRECIATE

public static final java.lang.String CLOSED_DEPRECIATE
See Also:
Constant Field Values
Constructor Detail

Constant.Depreciation.DepreciateStatus

public Constant.Depreciation.DepreciateStatus()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.Depreciation.DepreciationMethod

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.Depreciation.DepreciationMethod

java.lang.Object
    extended by  bb.common.Constant.Depreciation.DepreciationMethod
Enclosing class:
Constant.Depreciation
public static final class Constant.Depreciation.DepreciationMethod
extends java.lang.Object

Field Summary
static java.lang.String | ACCELERATED_DEPRECIATIONMETHODS
static java.lang.String | STRAIGHT_LINEMETHOD
static java.lang.String | WORK_LOADMETHOD
Constructor Summary
Constant.Depreciation.DepreciationMethod()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

STRAIGHT_LINEMETHOD

public static final java.lang.String STRAIGHT_LINEMETHOD
See Also:
Constant Field Values

WORK_LOADMETHOD

public static final java.lang.String WORK_LOADMETHOD
See Also:
Constant Field Values

ACCELERATED_DEPRECIATIONMETHODS

public static final java.lang.String ACCELERATED_DEPRECIATIONMETHODS
See Also:
Constant Field Values
Constructor Detail

Constant.Depreciation.DepreciationMethod

public Constant.Depreciation.DepreciationMethod()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.Depreciation.UsingType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.Depreciation.UsingType

java.lang.Object
    extended by  bb.common.Constant.Depreciation.UsingType
Enclosing class:
Constant.Depreciation
public static final class Constant.Depreciation.UsingType
extends java.lang.Object

Field Summary
static java.lang.String | IN_USE
static java.lang.String | ON_HIRE
static java.lang.String | UNUSE
Constructor Summary
Constant.Depreciation.UsingType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

IN_USE

public static final java.lang.String IN_USE
See Also:
Constant Field Values

UNUSE

public static final java.lang.String UNUSE
See Also:
Constant Field Values

ON_HIRE

public static final java.lang.String ON_HIRE
See Also:
Constant Field Values
Constructor Detail

Constant.Depreciation.UsingType

public Constant.Depreciation.UsingType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.Download

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.Download

java.lang.Object
    extended by  bb.common.Constant.Download
Enclosing class:
Constant
public static final class Constant.Download
extends java.lang.Object

Field Summary
static java.lang.String | AthoerException
static java.lang.String | NoAuthorization
static java.lang.String | Succeed
Constructor Summary
Constant.Download()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

NoAuthorization

public static final java.lang.String NoAuthorization
See Also:
Constant Field Values

AthoerException

public static final java.lang.String AthoerException
See Also:
Constant Field Values

Succeed

public static final java.lang.String Succeed
See Also:
Constant Field Values
Constructor Detail

Constant.Download

public Constant.Download()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.DrawingType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.DrawingType

java.lang.Object
    extended by  bb.common.Constant.DrawingType
Enclosing class:
Constant
public static final class Constant.DrawingType
extends java.lang.Object

Field Summary
static java.lang.String | Inventory
static java.lang.String | ToolRoom
Constructor Summary
Constant.DrawingType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ToolRoom

public static final java.lang.String ToolRoom
See Also:
Constant Field Values

Inventory

public static final java.lang.String Inventory
See Also:
Constant Field Values
Constructor Detail

Constant.DrawingType

public Constant.DrawingType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.ECRPriority

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.ECRPriority

java.lang.Object
    extended by  bb.common.Constant.ECRPriority
Enclosing class:
Constant
public static final class Constant.ECRPriority
extends java.lang.Object

Field Summary
static java.lang.String | ALL
static java.lang.String | FIRST
static java.lang.String | SECOND
static java.lang.String | THIRD
Constructor Summary
Constant.ECRPriority()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

FIRST

public static final java.lang.String FIRST
See Also:
Constant Field Values

SECOND

public static final java.lang.String SECOND
See Also:
Constant Field Values

THIRD

public static final java.lang.String THIRD
See Also:
Constant Field Values

ALL

public static final java.lang.String ALL
See Also:
Constant Field Values
Constructor Detail

Constant.ECRPriority

public Constant.ECRPriority()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.EmployeeSecurityLevel

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.EmployeeSecurityLevel

java.lang.Object
    extended by  bb.common.Constant.EmployeeSecurityLevel
Enclosing class:
Constant
public static final class Constant.EmployeeSecurityLevel
extends java.lang.Object

Field Summary
static java.lang.String | LEVEL0
static java.lang.String | LEVEL1
static java.lang.String | LEVEL2
static java.lang.String | LEVEL3
static java.lang.String | LEVEL4
static java.lang.String | LEVEL5
static java.lang.String | TERMINATED
Constructor Summary
Constant.EmployeeSecurityLevel()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LEVEL0

public static java.lang.String LEVEL0

LEVEL1

public static java.lang.String LEVEL1

LEVEL2

public static java.lang.String LEVEL2

LEVEL3

public static java.lang.String LEVEL3

LEVEL4

public static java.lang.String LEVEL4

LEVEL5

public static java.lang.String LEVEL5

TERMINATED

public static java.lang.String TERMINATED
Constructor Detail

Constant.EmployeeSecurityLevel

public Constant.EmployeeSecurityLevel()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.EmployeeStatus

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.EmployeeStatus

java.lang.Object
    extended by  bb.common.Constant.EmployeeStatus
Enclosing class:
Constant
public static final class Constant.EmployeeStatus
extends java.lang.Object

Field Summary
static java.lang.String | FULLTIME
static java.lang.String | ONLEAVE
static java.lang.String | PARTTIME
static java.lang.String | TEMPORARYWORKER
static java.lang.String | TERMINATED
Constructor Summary
Constant.EmployeeStatus()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

FULLTIME

public static final java.lang.String FULLTIME
See Also:
Constant Field Values

PARTTIME

public static final java.lang.String PARTTIME
See Also:
Constant Field Values

TEMPORARYWORKER

public static final java.lang.String TEMPORARYWORKER
See Also:
Constant Field Values

ONLEAVE

public static final java.lang.String ONLEAVE
See Also:
Constant Field Values

TERMINATED

public static final java.lang.String TERMINATED
See Also:
Constant Field Values
Constructor Detail

Constant.EmployeeStatus

public Constant.EmployeeStatus()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.EngineeringSharingImportDataType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.EngineeringSharingImportDataType

java.lang.Object
    extended by  bb.common.Constant.EngineeringSharingImportDataType
Enclosing class:
Constant
public static final class Constant.EngineeringSharingImportDataType
extends java.lang.Object

Field Summary
static java.lang.String | BOM
static java.lang.String | ECN
static java.lang.String | Part
static java.lang.String | PartDescription
Constructor Summary
Constant.EngineeringSharingImportDataType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

Part

public static java.lang.String Part

PartDescription

public static java.lang.String PartDescription

BOM

public static java.lang.String BOM

ECN

public static java.lang.String ECN
Constructor Detail

Constant.EngineeringSharingImportDataType

public Constant.EngineeringSharingImportDataType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.EngineeringSharingImportType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.EngineeringSharingImportType

java.lang.Object
    extended by  bb.common.Constant.EngineeringSharingImportType
Enclosing class:
Constant
public static final class Constant.EngineeringSharingImportType
extends java.lang.Object

Field Summary
static java.lang.String | ADD
static java.lang.String | ADDITEM
static java.lang.String | UPDATE
Constructor Summary
Constant.EngineeringSharingImportType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ADD

public static java.lang.String ADD

UPDATE

public static java.lang.String UPDATE

ADDITEM

public static java.lang.String ADDITEM
Constructor Detail

Constant.EngineeringSharingImportType

public Constant.EngineeringSharingImportType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.EquipmentStatus

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.EquipmentStatus

java.lang.Object
    extended by  bb.common.Constant.EquipmentStatus
Enclosing class:
Constant
public static final class Constant.EquipmentStatus
extends java.lang.Object

Field Summary
static java.lang.String | IDLE
static java.lang.String | MAINTENANCE
static java.lang.String | OK
static java.lang.String | SCRAPPED
Constructor Summary
Constant.EquipmentStatus()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

OK

public static java.lang.String OK

IDLE

public static java.lang.String IDLE

MAINTENANCE

public static java.lang.String MAINTENANCE

SCRAPPED

public static java.lang.String SCRAPPED
Constructor Detail

Constant.EquipmentStatus

public Constant.EquipmentStatus()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.ExchangeRateType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.ExchangeRateType

java.lang.Object
    extended by  bb.common.Constant.ExchangeRateType
Enclosing class:
Constant
public static final class Constant.ExchangeRateType
extends java.lang.Object

Field Summary
static java.lang.String | DIRECTEXCHANGERATE
static java.lang.String | INDIRECTEXCHANGERATE
Constructor Summary
Constant.ExchangeRateType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

INDIRECTEXCHANGERATE

public static final java.lang.String INDIRECTEXCHANGERATE
See Also:
Constant Field Values

DIRECTEXCHANGERATE

public static final java.lang.String DIRECTEXCHANGERATE
See Also:
Constant Field Values
Constructor Detail

Constant.ExchangeRateType

public Constant.ExchangeRateType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.FileExt

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.FileExt

java.lang.Object
    extended by  bb.common.Constant.FileExt
Enclosing class:
Constant
public static final class Constant.FileExt
extends java.lang.Object

Field Summary
static java.lang.String | PDF
static java.lang.String | ZIP
Constructor Summary
Constant.FileExt()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

PDF

public static final java.lang.String PDF
See Also:
Constant Field Values

ZIP

public static final java.lang.String ZIP
See Also:
Constant Field Values
Constructor Detail

Constant.FileExt

public Constant.FileExt()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.GLApprovedType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.GLApprovedType

java.lang.Object
    extended by  bb.common.Constant.GLApprovedType
Enclosing class:
Constant
public static final class Constant.GLApprovedType
extends java.lang.Object

Field Summary
static java.lang.String | APDM
static java.lang.String | ARCM
static java.lang.String | ASSET
static java.lang.String | EXCHANGERATE
static java.lang.String | NCRSCRAP
static java.lang.String | OVERCARRY
static java.lang.String | STDCOST
static java.lang.String | WOREC
Constructor Summary
Constant.GLApprovedType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ARCM

public static java.lang.String ARCM

APDM

public static java.lang.String APDM

WOREC

public static java.lang.String WOREC

NCRSCRAP

public static java.lang.String NCRSCRAP

STDCOST

public static java.lang.String STDCOST

ASSET

public static java.lang.String ASSET

OVERCARRY

public static java.lang.String OVERCARRY

EXCHANGERATE

public static java.lang.String EXCHANGERATE
Constructor Detail

Constant.GLApprovedType

public Constant.GLApprovedType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.GLStyle

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.GLStyle

java.lang.Object
    extended by  bb.common.Constant.GLStyle
Enclosing class:
Constant
public static final class Constant.GLStyle
extends java.lang.Object

Field Summary
static java.lang.String | CNSTYLE
static java.lang.String | ENSTYLE
Constructor Summary
Constant.GLStyle()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CNSTYLE

public static java.lang.String CNSTYLE

ENSTYLE

public static java.lang.String ENSTYLE
Constructor Detail

Constant.GLStyle

public Constant.GLStyle()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.GLType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.GLType

java.lang.Object
    extended by  bb.common.Constant.GLType
Enclosing class:
Constant
public static final class Constant.GLType
extends java.lang.Object

Field Summary
static java.lang.String | PAYABLEGL
static java.lang.String | RECEIVEGL
static java.lang.String | TRANSFERGL
Constructor Summary
Constant.GLType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

RECEIVEGL

public static java.lang.String RECEIVEGL

PAYABLEGL

public static java.lang.String PAYABLEGL

TRANSFERGL

public static java.lang.String TRANSFERGL
Constructor Detail

Constant.GLType

public Constant.GLType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.InventoryCostMothed

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.InventoryCostMothed

java.lang.Object
    extended by  bb.common.Constant.InventoryCostMothed
Enclosing class:
Constant
public static final class Constant.InventoryCostMothed
extends java.lang.Object

Field Summary
static java.lang.String | FIFO
static java.lang.String | STANDARD
static java.lang.String | WAC
Constructor Summary
Constant.InventoryCostMothed()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

WAC

public static final java.lang.String WAC
See Also:
Constant Field Values

FIFO

public static final java.lang.String FIFO
See Also:
Constant Field Values

STANDARD

public static final java.lang.String STANDARD
See Also:
Constant Field Values
Constructor Detail

Constant.InventoryCostMothed

public Constant.InventoryCostMothed()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.InventoryWorkSheetOrderBy

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.InventoryWorkSheetOrderBy

java.lang.Object
    extended by  bb.common.Constant.InventoryWorkSheetOrderBy
Enclosing class:
Constant
public static final class Constant.InventoryWorkSheetOrderBy
extends java.lang.Object

Field Summary
static java.lang.String | LOCATION
static java.lang.String | PART_NO
Constructor Summary
Constant.InventoryWorkSheetOrderBy()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

PART_NO

public static final java.lang.String PART_NO
See Also:
Constant Field Values

LOCATION

public static final java.lang.String LOCATION
See Also:
Constant Field Values
Constructor Detail

Constant.InventoryWorkSheetOrderBy

public Constant.InventoryWorkSheetOrderBy()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.IrDateType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.IrDateType

java.lang.Object
    extended by  bb.common.Constant.IrDateType
Enclosing class:
Constant
public static final class Constant.IrDateType
extends java.lang.Object

Field Summary
static java.lang.String | CloseOutDate
static java.lang.String | IcrDate
Constructor Summary
Constant.IrDateType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

IcrDate

public static java.lang.String IcrDate

CloseOutDate

public static java.lang.String CloseOutDate
Constructor Detail

Constant.IrDateType

public Constant.IrDateType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.IRType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.IRType

java.lang.Object
    extended by  bb.common.Constant.IRType
Enclosing class:
Constant
public static final class Constant.IRType
extends java.lang.Object

Field Summary
static java.lang.String | AllExamines
static java.lang.String | ExemptingFromInspection
static java.lang.String | Spotcheck
Constructor Summary
Constant.IRType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

Spotcheck

public static java.lang.String Spotcheck

AllExamines

public static java.lang.String AllExamines

ExemptingFromInspection

public static java.lang.String ExemptingFromInspection
Constructor Detail

Constant.IRType

public Constant.IRType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.IssuedFrom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.IssuedFrom

java.lang.Object
    extended by  bb.common.Constant.IssuedFrom
Enclosing class:
Constant
public static final class Constant.IssuedFrom
extends java.lang.Object

Field Summary
static java.lang.String | Other
static java.lang.String | Quality
static java.lang.String | WareHouse
Constructor Summary
Constant.IssuedFrom()
Method Summary
static java.lang.String getInternalValue(java.lang.String issusedFrom)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

WareHouse

public static final java.lang.String WareHouse
See Also:
Constant Field Values

Quality

public static final java.lang.String Quality
See Also:
Constant Field Values

Other

public static final java.lang.String Other
See Also:
Constant Field Values
Constructor Detail

Constant.IssuedFrom

public Constant.IssuedFrom()
Method Detail

getInternalValue

public static java.lang.String getInternalValue(java.lang.String issusedFrom)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.LanguageCode

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.LanguageCode

java.lang.Object
    extended by  bb.common.Constant.LanguageCode
Enclosing class:
Constant
public static final class Constant.LanguageCode
extends java.lang.Object

Field Summary
static java.lang.String | CN
static java.lang.String | EN
Constructor Summary
Constant.LanguageCode()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CN

public static final java.lang.String CN
See Also:
Constant Field Values

EN

public static final java.lang.String EN
See Also:
Constant Field Values
Constructor Detail

Constant.LanguageCode

public Constant.LanguageCode()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.LocalSettings

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.LocalSettings

java.lang.Object
    extended by  bb.common.Constant.LocalSettings
Enclosing class:
Constant
public static final class Constant.LocalSettings
extends java.lang.Object

Field Summary
static java.lang.String | CHINA
static java.lang.String | CUSTOMIZATION
static java.lang.String | USA
Constructor Summary
Constant.LocalSettings()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

USA

public static final java.lang.String USA
See Also:
Constant Field Values

CHINA

public static final java.lang.String CHINA
See Also:
Constant Field Values

CUSTOMIZATION

public static final java.lang.String CUSTOMIZATION
See Also:
Constant Field Values
Constructor Detail

Constant.LocalSettings

public Constant.LocalSettings()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.LoginType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.LoginType

java.lang.Object
    extended by  bb.common.Constant.LoginType
Enclosing class:
Constant
public static final class Constant.LoginType
extends java.lang.Object

Field Summary
static java.lang.String | ERP
static java.lang.String | M2
static java.lang.String | Web
Constructor Summary
Constant.LoginType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ERP

public static java.lang.String ERP

M2

public static java.lang.String M2

Web

public static java.lang.String Web
Constructor Detail

Constant.LoginType

public Constant.LoginType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.MakeBuy

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.MakeBuy

java.lang.Object
    extended by  bb.common.Constant.MakeBuy
Enclosing class:
Constant
public static final class Constant.MakeBuy
extends java.lang.Object

Field Summary
static java.lang.String | Buy
static java.lang.String | Make
static java.lang.String | X
Constructor Summary
Constant.MakeBuy()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

X

public static final java.lang.String X
See Also:
Constant Field Values

Buy

public static final java.lang.String Buy
See Also:
Constant Field Values

Make

public static final java.lang.String Make
See Also:
Constant Field Values
Constructor Detail

Constant.MakeBuy

public Constant.MakeBuy()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.MiscDocType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.MiscDocType

java.lang.Object
    extended by  bb.common.Constant.MiscDocType
Enclosing class:
Constant
public static final class Constant.MiscDocType
extends java.lang.Object

Field Summary
static java.lang.String | ADDRESS_QA_DOC
static java.lang.String | BALANCE_SHEET
static java.lang.String | BALANCE_SHEET_SIDE_BY_SIDE
static java.lang.String | CERTIFICATE_DOC
static java.lang.String | CLOSING_STATEMENT
static java.lang.String | CS_ITEM_DOC
static java.lang.String | CUSTOMER_DOC
static java.lang.String | DWO_DOC
static java.lang.String | ECN_DOC
static java.lang.String | ECR_DOC
static java.lang.String | EDC_DOC
static java.lang.String | EMP_RECORDS_DOC
static java.lang.String | IR_DOC
static java.lang.String | NCR_FILE
static java.lang.String | ONLOAN_DOC
static java.lang.String | PAR_ITEM_DOC
static java.lang.String | PART_PICTURE
static java.lang.String | PO_DOC
static java.lang.String | PROFIT_LOSS
static java.lang.String | QT_DOC
static java.lang.String | RMA_DOC
static java.lang.String | SO_DOC
static java.lang.String | VENDOR_DOC
static java.lang.String | WI_DOC
static java.lang.String | WI_PICTURE
static java.lang.String | WO_DOC
Constructor Summary
Constant.MiscDocType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

SO_DOC

public static final java.lang.String SO_DOC
See Also:
Constant Field Values

WO_DOC

public static final java.lang.String WO_DOC
See Also:
Constant Field Values

WI_DOC

public static final java.lang.String WI_DOC
See Also:
Constant Field Values

QT_DOC

public static final java.lang.String QT_DOC
See Also:
Constant Field Values

EDC_DOC

public static final java.lang.String EDC_DOC
See Also:
Constant Field Values

CERTIFICATE_DOC

public static final java.lang.String CERTIFICATE_DOC
See Also:
Constant Field Values

ADDRESS_QA_DOC

public static final java.lang.String ADDRESS_QA_DOC
See Also:
Constant Field Values

CUSTOMER_DOC

public static final java.lang.String CUSTOMER_DOC
See Also:
Constant Field Values

VENDOR_DOC

public static final java.lang.String VENDOR_DOC
See Also:
Constant Field Values

EMP_RECORDS_DOC

public static final java.lang.String EMP_RECORDS_DOC
See Also:
Constant Field Values

CS_ITEM_DOC

public static final java.lang.String CS_ITEM_DOC
See Also:
Constant Field Values

PO_DOC

public static final java.lang.String PO_DOC
See Also:
Constant Field Values

PAR_ITEM_DOC

public static final java.lang.String PAR_ITEM_DOC
See Also:
Constant Field Values

PART_PICTURE

public static final java.lang.String PART_PICTURE
See Also:
Constant Field Values

NCR_FILE

public static final java.lang.String NCR_FILE
See Also:
Constant Field Values

WI_PICTURE

public static final java.lang.String WI_PICTURE
See Also:
Constant Field Values

BALANCE_SHEET

public static final java.lang.String BALANCE_SHEET
See Also:
Constant Field Values

BALANCE_SHEET_SIDE_BY_SIDE

public static final java.lang.String BALANCE_SHEET_SIDE_BY_SIDE
See Also:
Constant Field Values

PROFIT_LOSS

public static final java.lang.String PROFIT_LOSS
See Also:
Constant Field Values

CLOSING_STATEMENT

public static final java.lang.String CLOSING_STATEMENT
See Also:
Constant Field Values

ECN_DOC

public static final java.lang.String ECN_DOC
See Also:
Constant Field Values

ECR_DOC

public static final java.lang.String ECR_DOC
See Also:
Constant Field Values

ONLOAN_DOC

public static final java.lang.String ONLOAN_DOC
See Also:
Constant Field Values

RMA_DOC

public static final java.lang.String RMA_DOC
See Also:
Constant Field Values

DWO_DOC

public static final java.lang.String DWO_DOC
See Also:
Constant Field Values

IR_DOC

public static final java.lang.String IR_DOC
See Also:
Constant Field Values
Constructor Detail

Constant.MiscDocType

public Constant.MiscDocType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.NaRecTo

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.NaRecTo

java.lang.Object
    extended by  bb.common.Constant.NaRecTo
Enclosing class:
Constant
public static final class Constant.NaRecTo
extends java.lang.Object

Field Summary
static java.lang.String | AP
static java.lang.String | FREIGHT
static java.lang.String | REFDOC
Constructor Summary
Constant.NaRecTo()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

REFDOC

public static final java.lang.String REFDOC
See Also:
Constant Field Values

AP

public static final java.lang.String AP
See Also:
Constant Field Values

FREIGHT

public static final java.lang.String FREIGHT
See Also:
Constant Field Values
Constructor Detail

Constant.NaRecTo

public Constant.NaRecTo()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.NcrApprovableType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.NcrApprovableType

java.lang.Object
    extended by  bb.common.Constant.NcrApprovableType
Enclosing class:
Constant
public static final class Constant.NcrApprovableType
extends java.lang.Object

Field Summary
static java.lang.String | ApproveEng
static java.lang.String | ApproveMFG
static java.lang.String | ApproveQA
Constructor Summary
Constant.NcrApprovableType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ApproveQA

public static java.lang.String ApproveQA

ApproveEng

public static java.lang.String ApproveEng

ApproveMFG

public static java.lang.String ApproveMFG
Constructor Detail

Constant.NcrApprovableType

public Constant.NcrApprovableType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.NoticeAction

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.NoticeAction

java.lang.Object
    extended by  bb.common.Constant.NoticeAction
Enclosing class:
Constant
public static final class Constant.NoticeAction
extends java.lang.Object

Field Summary
static java.lang.String | ADD
static java.lang.String | APPROVE
static java.lang.String | CLOSE
static java.lang.String | DELETE
static java.lang.String[] | GENERAL_ACTION
static java.lang.String[] | PO_ACTION
static java.lang.String | RECIEVE
static java.lang.String | REVIEW
static java.lang.String | SHIP
static java.lang.String[] | SO_ACTION
static java.lang.String | UPDATE
Constructor Summary
Constant.NoticeAction()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ADD

public static final java.lang.String ADD
See Also:
Constant Field Values

UPDATE

public static final java.lang.String UPDATE
See Also:
Constant Field Values

DELETE

public static final java.lang.String DELETE
See Also:
Constant Field Values

CLOSE

public static final java.lang.String CLOSE
See Also:
Constant Field Values

APPROVE

public static final java.lang.String APPROVE
See Also:
Constant Field Values

REVIEW

public static final java.lang.String REVIEW
See Also:
Constant Field Values

SHIP

public static final java.lang.String SHIP
See Also:
Constant Field Values

RECIEVE

public static final java.lang.String RECIEVE
See Also:
Constant Field Values

GENERAL_ACTION

public static final java.lang.String[] GENERAL_ACTION

SO_ACTION

public static final java.lang.String[] SO_ACTION

PO_ACTION

public static final java.lang.String[] PO_ACTION
Constructor Detail

Constant.NoticeAction

public Constant.NoticeAction()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.NoticeType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.NoticeType

java.lang.Object
    extended by  bb.common.Constant.NoticeType
Enclosing class:
Constant
public static final class Constant.NoticeType
extends java.lang.Object

Field Summary
static java.lang.String | ECN
static java.lang.String | NCR
static java.lang.String | PO
static java.lang.String | SO
Constructor Summary
Constant.NoticeType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

SO

public static final java.lang.String SO
See Also:
Constant Field Values

PO

public static final java.lang.String PO
See Also:
Constant Field Values

ECN

public static final java.lang.String ECN
See Also:
Constant Field Values

NCR

public static final java.lang.String NCR
See Also:
Constant Field Values
Constructor Detail

Constant.NoticeType

public Constant.NoticeType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.OITypeSerialNumberType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.OITypeSerialNumberType

java.lang.Object
    extended by  bb.common.Constant.OITypeSerialNumberType
Enclosing class:
Constant
public static final class Constant.OITypeSerialNumberType
extends java.lang.Object

Field Summary
static java.lang.String | MULTIPLE
static java.lang.String | SINGLE
static java.lang.String | ZERO
Constructor Summary
Constant.OITypeSerialNumberType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ZERO

public static java.lang.String ZERO

SINGLE

public static java.lang.String SINGLE

MULTIPLE

public static java.lang.String MULTIPLE
Constructor Detail

Constant.OITypeSerialNumberType

public Constant.OITypeSerialNumberType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.OrderType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.OrderType

java.lang.Object
    extended by  bb.common.Constant.OrderType
Enclosing class:
Constant
public static final class Constant.OrderType
extends java.lang.Object

Field Summary
static java.lang.String | ACCOUNTSPAYABLE
static java.lang.String | ACCOUNTSRECEIVABLE
static java.lang.String | DISASSEMBLEWORKORDER
static java.lang.String | PURCHASEORDER
static java.lang.String | QUOTE
static java.lang.String | RECEIVER
static java.lang.String | SALESORDER
static java.lang.String | WORKORDER
Constructor Summary
Constant.OrderType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

PURCHASEORDER

public static final java.lang.String PURCHASEORDER
See Also:
Constant Field Values

SALESORDER

public static final java.lang.String SALESORDER
See Also:
Constant Field Values

WORKORDER

public static final java.lang.String WORKORDER
See Also:
Constant Field Values

DISASSEMBLEWORKORDER

public static final java.lang.String DISASSEMBLEWORKORDER
See Also:
Constant Field Values

RECEIVER

public static final java.lang.String RECEIVER
See Also:
Constant Field Values

ACCOUNTSPAYABLE

public static final java.lang.String ACCOUNTSPAYABLE
See Also:
Constant Field Values

ACCOUNTSRECEIVABLE

public static final java.lang.String ACCOUNTSRECEIVABLE
See Also:
Constant Field Values

QUOTE

public static final java.lang.String QUOTE
See Also:
Constant Field Values
Constructor Detail

Constant.OrderType

public Constant.OrderType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.Package

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.Package

java.lang.Object
    extended by  bb.common.Constant.Package
Enclosing class:
Constant
public static final class Constant.Package
extends java.lang.Object

Field Summary
static java.lang.String | POPackage
static java.lang.String | VOPackage
Constructor Summary
Constant.Package()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

VOPackage

public static java.lang.String VOPackage

POPackage

public static java.lang.String POPackage
Constructor Detail

Constant.Package

public Constant.Package()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.PageCycleCount

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.PageCycleCount

java.lang.Object
    extended by  bb.common.Constant.PageCycleCount
Enclosing class:
Constant
public static final class Constant.PageCycleCount
extends java.lang.Object

Field Summary
static java.lang.String | PERDAY
static java.lang.String | PERMONTH
static java.lang.String | PERWEEK
static java.lang.String | PERYEAR
Constructor Summary
Constant.PageCycleCount()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

PERDAY

public static final java.lang.String PERDAY
See Also:
Constant Field Values

PERWEEK

public static final java.lang.String PERWEEK
See Also:
Constant Field Values

PERMONTH

public static final java.lang.String PERMONTH
See Also:
Constant Field Values

PERYEAR

public static final java.lang.String PERYEAR
See Also:
Constant Field Values
Constructor Detail

Constant.PageCycleCount

public Constant.PageCycleCount()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.PAOffsetType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.PAOffsetType

java.lang.Object
    extended by  bb.common.Constant.PAOffsetType
Enclosing class:
Constant
public static final class Constant.PAOffsetType
extends java.lang.Object

Field Summary
static java.lang.String | NEGATIVE
static java.lang.String | VARIANCE
Constructor Summary
Constant.PAOffsetType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

VARIANCE

public static java.lang.String VARIANCE

NEGATIVE

public static java.lang.String NEGATIVE
Constructor Detail

Constant.PAOffsetType

public Constant.PAOffsetType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.PartFrom

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.PartFrom

java.lang.Object
    extended by  bb.common.Constant.PartFrom
Enclosing class:
Constant
public static final class Constant.PartFrom
extends java.lang.Object

Field Summary
static java.lang.String | Inventory
static java.lang.String | ToolRoom
Constructor Summary
Constant.PartFrom()
Method Summary
static java.lang.String filter(java.lang.Object partFrom)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

Inventory

public static final java.lang.String Inventory
See Also:
Constant Field Values

ToolRoom

public static final java.lang.String ToolRoom
See Also:
Constant Field Values
Constructor Detail

Constant.PartFrom

public Constant.PartFrom()
Method Detail

filter

public static java.lang.String filter(java.lang.Object partFrom)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.PartNumberGenerateType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.PartNumberGenerateType

java.lang.Object
    extended by  bb.common.Constant.PartNumberGenerateType
Enclosing class:
Constant
public static final class Constant.PartNumberGenerateType
extends java.lang.Object

Field Summary
static java.lang.String | CATAGORY
static java.lang.String | MANUAL
static java.lang.String | SEQNO
Constructor Summary
Constant.PartNumberGenerateType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

MANUAL

public static java.lang.String MANUAL

SEQNO

public static java.lang.String SEQNO

CATAGORY

public static java.lang.String CATAGORY
Constructor Detail

Constant.PartNumberGenerateType

public Constant.PartNumberGenerateType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.PartQtyType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.PartQtyType

java.lang.Object
    extended by  bb.common.Constant.PartQtyType
Enclosing class:
Constant
public static final class Constant.PartQtyType
extends java.lang.Object

Field Summary
static java.lang.String | MAXQTY
static java.lang.String | MINQTY
static java.lang.String | ONDEMANDQTY
static java.lang.String | ONORDERQTY
Constructor Summary
Constant.PartQtyType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ONORDERQTY

public static final java.lang.String ONORDERQTY
See Also:
Constant Field Values

ONDEMANDQTY

public static final java.lang.String ONDEMANDQTY
See Also:
Constant Field Values

MINQTY

public static final java.lang.String MINQTY
See Also:
Constant Field Values

MAXQTY

public static final java.lang.String MAXQTY
See Also:
Constant Field Values
Constructor Detail

Constant.PartQtyType

public Constant.PartQtyType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.PayableMethod

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.PayableMethod

java.lang.Object
    extended by  bb.common.Constant.PayableMethod
Enclosing class:
Constant
public static final class Constant.PayableMethod
extends java.lang.Object

Field Summary
static java.lang.String | ALL
static java.lang.String | CASH
static java.lang.String | CHECK
static java.lang.String | CREDIT_CARD
static java.lang.String | INVOICE
Constructor Summary
Constant.PayableMethod()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CASH

public static java.lang.String CASH

CHECK

public static java.lang.String CHECK

CREDIT_CARD

public static java.lang.String CREDIT_CARD

INVOICE

public static java.lang.String INVOICE

ALL

public static java.lang.String ALL
Constructor Detail

Constant.PayableMethod

public Constant.PayableMethod()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.PeriodUnit

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.PeriodUnit

java.lang.Object
    extended by  bb.common.Constant.PeriodUnit
Enclosing class:
Constant
public static final class Constant.PeriodUnit
extends java.lang.Object

Field Summary
static java.lang.String | DAY
static java.lang.String | HALFYEAR
static java.lang.String | HOUR
static java.lang.String | MINUTE
static java.lang.String | MONTH
static java.lang.String | QUARTER
static java.lang.String | WEEK
static java.lang.String | YEAR
Constructor Summary
Constant.PeriodUnit()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

MINUTE

public static final java.lang.String MINUTE
See Also:
Constant Field Values

HOUR

public static final java.lang.String HOUR
See Also:
Constant Field Values

DAY

public static final java.lang.String DAY
See Also:
Constant Field Values

WEEK

public static final java.lang.String WEEK
See Also:
Constant Field Values

MONTH

public static final java.lang.String MONTH
See Also:
Constant Field Values

QUARTER

public static final java.lang.String QUARTER
See Also:
Constant Field Values

HALFYEAR

public static final java.lang.String HALFYEAR
See Also:
Constant Field Values

YEAR

public static final java.lang.String YEAR
See Also:
Constant Field Values
Constructor Detail

Constant.PeriodUnit

public Constant.PeriodUnit()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.PosOrderType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.PosOrderType

java.lang.Object
    extended by  bb.common.Constant.PosOrderType
Enclosing class:
Constant
public static final class Constant.PosOrderType
extends java.lang.Object

Field Summary
static java.lang.String | ALL
static java.lang.String | RECEIPT_ORDER
static java.lang.String | REJECT_ORDER
Constructor Summary
Constant.PosOrderType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

RECEIPT_ORDER

public static java.lang.String RECEIPT_ORDER

REJECT_ORDER

public static java.lang.String REJECT_ORDER

ALL

public static java.lang.String ALL
Constructor Detail

Constant.PosOrderType

public Constant.PosOrderType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.Prefix

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.Prefix

java.lang.Object
    extended by  bb.common.Constant.Prefix
Enclosing class:
Constant
public static final class Constant.Prefix
extends java.lang.Object

Field Summary
static java.lang.String | A
static java.lang.String | AP
static java.lang.String | APP
static java.lang.String | AR
static java.lang.String | ARP
static java.lang.String | CM
static java.lang.String | CP
static java.lang.String | CRFQ
static java.lang.String | DM
static java.lang.String | DW
static java.lang.String | E
static java.lang.String | GL
static java.lang.String | I
static java.lang.String | IR
static java.lang.String | LNR
static java.lang.String | LNSH
static java.lang.String | MP
static java.lang.String | N
static java.lang.String | NCR
static java.lang.String | OI
static java.lang.String | P
static java.lang.String | PA
static java.lang.String | PF
static java.lang.String | PO
static java.lang.String | PR
static java.lang.String | R
static java.lang.String | RMA
static java.lang.String | RMAR
static java.lang.String | RRMA
static java.lang.String | RT
static java.lang.String | RTV
static java.lang.String | RTVSH
static java.lang.String | S
static java.lang.String | SH
static java.lang.String | SO
static java.lang.String | SW
static java.lang.String | SWR
static java.lang.String | SWS
static java.lang.String | T
static java.lang.String | TR
static java.lang.String | TSH
static java.lang.String | VCP
static java.lang.String | W
static java.lang.String | WO
Constructor Summary
Constant.Prefix()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

PO

public static final java.lang.String PO
See Also:
Constant Field Values

SO

public static final java.lang.String SO
See Also:
Constant Field Values

WO

public static final java.lang.String WO
See Also:
Constant Field Values

AP

public static final java.lang.String AP
See Also:
Constant Field Values

AR

public static final java.lang.String AR
See Also:
Constant Field Values

CP

public static final java.lang.String CP
See Also:
Constant Field Values

VCP

public static final java.lang.String VCP
See Also:
Constant Field Values

APP

public static final java.lang.String APP
See Also:
Constant Field Values

ARP

public static final java.lang.String ARP
See Also:
Constant Field Values

RTV

public static final java.lang.String RTV
See Also:
Constant Field Values

NCR

public static final java.lang.String NCR
See Also:
Constant Field Values

CM

public static final java.lang.String CM
See Also:
Constant Field Values

DM

public static final java.lang.String DM
See Also:
Constant Field Values

RMA

public static final java.lang.String RMA
See Also:
Constant Field Values

LNSH

public static final java.lang.String LNSH
See Also:
Constant Field Values

LNR

public static final java.lang.String LNR
See Also:
Constant Field Values

GL

public static final java.lang.String GL
See Also:
Constant Field Values

TSH

public static final java.lang.String TSH
See Also:
Constant Field Values

TR

public static final java.lang.String TR
See Also:
Constant Field Values

I

public static final java.lang.String I
See Also:
Constant Field Values

MP

public static final java.lang.String MP
See Also:
Constant Field Values

PF

public static final java.lang.String PF
See Also:
Constant Field Values

PR

public static final java.lang.String PR
See Also:
Constant Field Values

P

public static final java.lang.String P
See Also:
Constant Field Values

RMAR

public static final java.lang.String RMAR
See Also:
Constant Field Values

RTVSH

public static final java.lang.String RTVSH
See Also:
Constant Field Values

R

public static final java.lang.String R
See Also:
Constant Field Values

SH

public static final java.lang.String SH
See Also:
Constant Field Values

S

public static final java.lang.String S
See Also:
Constant Field Values

W

public static final java.lang.String W
See Also:
Constant Field Values

E

public static final java.lang.String E
See Also:
Constant Field Values

OI

public static final java.lang.String OI
See Also:
Constant Field Values

IR

public static final java.lang.String IR
See Also:
Constant Field Values

PA

public static final java.lang.String PA
See Also:
Constant Field Values

RT

public static final java.lang.String RT
See Also:
Constant Field Values

SW

public static final java.lang.String SW
See Also:
Constant Field Values

SWS

public static final java.lang.String SWS
See Also:
Constant Field Values

SWR

public static final java.lang.String SWR
See Also:
Constant Field Values

T

public static final java.lang.String T
See Also:
Constant Field Values

DW

public static final java.lang.String DW
See Also:
Constant Field Values

N

public static final java.lang.String N
See Also:
Constant Field Values

RRMA

public static final java.lang.String RRMA
See Also:
Constant Field Values

CRFQ

public static final java.lang.String CRFQ
See Also:
Constant Field Values

A

public static final java.lang.String A
See Also:
Constant Field Values
Constructor Detail

Constant.Prefix

public Constant.Prefix()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.PrintTemplateType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.PrintTemplateType

java.lang.Object
    extended by  bb.common.Constant.PrintTemplateType
Enclosing class:
Constant
public static final class Constant.PrintTemplateType
extends java.lang.Object

Field Summary
static java.lang.String | BOM
static java.lang.String | BOM_Cost
static java.lang.String | DC
static java.lang.String | DWO
static java.lang.String | ECN
static java.lang.String | ECR
static java.lang.String | GL
static java.lang.String | ONLOAN
static java.lang.String | ONLOANRECEIVER
static java.lang.String | ONLOANSHIPPER
static java.lang.String | PART
static java.lang.String | PICKLIST
static java.lang.String | PickList_For_BOM
static java.lang.String | PickList_For_SO
static java.lang.String | PO
static java.lang.String | PR
static java.lang.String | PR_Packing_BOX
static java.lang.String | ProformaShipper
static java.lang.String | QUOTE
static java.lang.String | RECEIVER
static java.lang.String | RFQ
static java.lang.String | RMARECEIVER
static java.lang.String | RT
static java.lang.String | RTVSHIPPER
static java.lang.String | SHIPPER
static java.lang.String | SO
static java.lang.String | WO
static java.lang.String | WOWI
Constructor Summary
Constant.PrintTemplateType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

PART

public static java.lang.String PART

SO

public static java.lang.String SO

PO

public static java.lang.String PO

WO

public static java.lang.String WO

QUOTE

public static java.lang.String QUOTE

RFQ

public static java.lang.String RFQ

PICKLIST

public static java.lang.String PICKLIST

RECEIVER

public static java.lang.String RECEIVER

BOM

public static java.lang.String BOM

WOWI

public static java.lang.String WOWI

ONLOANSHIPPER

public static java.lang.String ONLOANSHIPPER

RTVSHIPPER

public static java.lang.String RTVSHIPPER

SHIPPER

public static java.lang.String SHIPPER

ONLOANRECEIVER

public static java.lang.String ONLOANRECEIVER

RMARECEIVER

public static java.lang.String RMARECEIVER

PR

public static java.lang.String PR

PR_Packing_BOX

public static java.lang.String PR_Packing_BOX

PickList_For_BOM

public static java.lang.String PickList_For_BOM

PickList_For_SO

public static java.lang.String PickList_For_SO

ONLOAN

public static java.lang.String ONLOAN

ProformaShipper

public static java.lang.String ProformaShipper

BOM_Cost

public static java.lang.String BOM_Cost

ECN

public static java.lang.String ECN

ECR

public static java.lang.String ECR

DC

public static java.lang.String DC

GL

public static java.lang.String GL

RT

public static java.lang.String RT

DWO

public static java.lang.String DWO
Constructor Detail

Constant.PrintTemplateType

public Constant.PrintTemplateType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.ReceiveCondition

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.ReceiveCondition

java.lang.Object
    extended by  bb.common.Constant.ReceiveCondition
Enclosing class:
Constant
public static final class Constant.ReceiveCondition
extends java.lang.Object

Field Summary
static java.lang.String | NO_DAMAGE_NOTICE
static java.lang.String | NOT_CHECKED
static java.lang.String | OUTSIDE_DAMAGE_NOTICE
static java.lang.String | SENT_TO_QC
Constructor Summary
Constant.ReceiveCondition()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

NOT_CHECKED

public static java.lang.String NOT_CHECKED

NO_DAMAGE_NOTICE

public static java.lang.String NO_DAMAGE_NOTICE

OUTSIDE_DAMAGE_NOTICE

public static java.lang.String OUTSIDE_DAMAGE_NOTICE

SENT_TO_QC

public static java.lang.String SENT_TO_QC
Constructor Detail

Constant.ReceiveCondition

public Constant.ReceiveCondition()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.ReceivedTo

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.ReceivedTo

java.lang.Object
    extended by  bb.common.Constant.ReceivedTo
Enclosing class:
Constant
public static final class Constant.ReceivedTo
extends java.lang.Object

Field Summary
static java.lang.String | NCR
static java.lang.String | Quality
static java.lang.String | SalesOrder
static java.lang.String | WareHouse
static java.lang.String | WorkOrder
Constructor Summary
Constant.ReceivedTo()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

WareHouse

public static final java.lang.String WareHouse
See Also:
Constant Field Values

Quality

public static final java.lang.String Quality
See Also:
Constant Field Values

SalesOrder

public static final java.lang.String SalesOrder
See Also:
Constant Field Values

WorkOrder

public static final java.lang.String WorkOrder
See Also:
Constant Field Values

NCR

public static final java.lang.String NCR
See Also:
Constant Field Values
Constructor Detail

Constant.ReceivedTo

public Constant.ReceivedTo()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.SalesTaxReportType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.SalesTaxReportType

java.lang.Object
    extended by  bb.common.Constant.SalesTaxReportType
Enclosing class:
Constant
public static final class Constant.SalesTaxReportType
extends java.lang.Object

Field Summary
static java.lang.String | ALL_SALES
static java.lang.String | TAXABLE_SALES
Constructor Summary
Constant.SalesTaxReportType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TAXABLE_SALES

public static java.lang.String TAXABLE_SALES

ALL_SALES

public static java.lang.String ALL_SALES
Constructor Detail

Constant.SalesTaxReportType

public Constant.SalesTaxReportType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.SGType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.SGType

java.lang.Object
    extended by  bb.common.Constant.SGType
Enclosing class:
Constant
public static final class Constant.SGType
extends java.lang.Object

Field Summary
static java.lang.String | C
static java.lang.String | D
Constructor Summary
Constant.SGType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

D

public static java.lang.String D

C

public static java.lang.String C
Constructor Detail

Constant.SGType

public Constant.SGType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.StatementType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.StatementType

java.lang.Object
    extended by  bb.common.Constant.StatementType
Enclosing class:
Constant
public static final class Constant.StatementType
extends java.lang.Object

Field Summary
static java.lang.String | DetailStatement
static java.lang.String | SummaryStatement
Constructor Summary
Constant.StatementType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DetailStatement

public static java.lang.String DetailStatement

SummaryStatement

public static java.lang.String SummaryStatement
Constructor Detail

Constant.StatementType

public Constant.StatementType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.Status

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.Status

java.lang.Object
    extended by  bb.common.Constant.Status
Enclosing class:
Constant
public static final class Constant.Status
extends java.lang.Object

Field Summary
static java.lang.String | Accepted
static java.lang.String | Acknowledged
static java.lang.String | ALL
static java.lang.String | Approved
static java.lang.String | CANCELLED
static java.lang.String | CLEARED
static java.lang.String | Closed
static java.lang.String | COMMITTED
static java.lang.String | DoNotUse
static java.lang.String | Error
static java.lang.String | FINISHED
static java.lang.String | FINISHINSPECTION
static java.lang.String | Hold
static java.lang.String | INPROGRESS
static java.lang.String | Invoiced
static java.lang.String | New
static java.lang.String | NotAccepted
static java.lang.String | NotAcknowledged
static java.lang.String | NotApproved
static java.lang.String | NOTCLEARED
static java.lang.String | NotReviewed
static java.lang.String | NotSetUp
static java.lang.String | NotWriteOffed
static java.lang.String | OBSOLETE
static java.lang.String | Ok
static java.lang.String | Open
static java.lang.String | OPEN_OR_RECEIVED
static java.lang.String | Partial
static java.lang.String | PAUSE
static java.lang.String | Pending
static java.lang.String | PermanentClosed
static java.lang.String | Prepayed
static java.lang.String | Received
static java.lang.String | Refused
static java.lang.String | Reject
static java.lang.String | REQUESTINSPECTION
static java.lang.String | Reviewed
static java.lang.String | Run
static java.lang.String | RUNNING
static java.lang.String | SCRAPPED
static java.lang.String | SetUp
static java.lang.String | Shipped
static java.lang.String | Unbilled
static java.lang.String | UnUsual
static java.lang.String | VendorApproved
static java.lang.String | VOID
static java.lang.String | Waiting
static java.lang.String | WriteOffed
Constructor Summary
Constant.Status()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

Prepayed

public static final java.lang.String Prepayed
See Also:
Constant Field Values

Open

public static final java.lang.String Open
See Also:
Constant Field Values

Closed

public static final java.lang.String Closed
See Also:
Constant Field Values

PermanentClosed

public static final java.lang.String PermanentClosed
See Also:
Constant Field Values

NotApproved

public static final java.lang.String NotApproved
See Also:
Constant Field Values

Approved

public static final java.lang.String Approved
See Also:
Constant Field Values

Reject

public static final java.lang.String Reject
See Also:
Constant Field Values

VendorApproved

public static final java.lang.String VendorApproved
See Also:
Constant Field Values

NotReviewed

public static final java.lang.String NotReviewed
See Also:
Constant Field Values

Reviewed

public static final java.lang.String Reviewed
See Also:
Constant Field Values

New

public static final java.lang.String New
See Also:
Constant Field Values

Waiting

public static final java.lang.String Waiting
See Also:
Constant Field Values

Pending

public static final java.lang.String Pending
See Also:
Constant Field Values

Refused

public static final java.lang.String Refused
See Also:
Constant Field Values

Received

public static final java.lang.String Received
See Also:
Constant Field Values

NotSetUp

public static final java.lang.String NotSetUp
See Also:
Constant Field Values

SetUp

public static final java.lang.String SetUp
See Also:
Constant Field Values

Run

public static final java.lang.String Run
See Also:
Constant Field Values

UnUsual

public static final java.lang.String UnUsual
See Also:
Constant Field Values

Hold

public static final java.lang.String Hold
See Also:
Constant Field Values

DoNotUse

public static final java.lang.String DoNotUse
See Also:
Constant Field Values

Accepted

public static final java.lang.String Accepted
See Also:
Constant Field Values

NotAccepted

public static final java.lang.String NotAccepted
See Also:
Constant Field Values

Ok

public static final java.lang.String Ok
See Also:
Constant Field Values

Partial

public static final java.lang.String Partial
See Also:
Constant Field Values

Shipped

public static final java.lang.String Shipped
See Also:
Constant Field Values

Invoiced

public static final java.lang.String Invoiced
See Also:
Constant Field Values

ALL

public static final java.lang.String ALL
See Also:
Constant Field Values

COMMITTED

public static final java.lang.String COMMITTED
See Also:
Constant Field Values

OPEN_OR_RECEIVED

public static final java.lang.String OPEN_OR_RECEIVED
See Also:
Constant Field Values

OBSOLETE

public static final java.lang.String OBSOLETE
See Also:
Constant Field Values

CANCELLED

public static final java.lang.String CANCELLED
See Also:
Constant Field Values

FINISHED

public static final java.lang.String FINISHED
See Also:
Constant Field Values

RUNNING

public static final java.lang.String RUNNING
See Also:
Constant Field Values

REQUESTINSPECTION

public static final java.lang.String REQUESTINSPECTION
See Also:
Constant Field Values

FINISHINSPECTION

public static final java.lang.String FINISHINSPECTION
See Also:
Constant Field Values

PAUSE

public static final java.lang.String PAUSE
See Also:
Constant Field Values

Error

public static final java.lang.String Error
See Also:
Constant Field Values

VOID

public static final java.lang.String VOID
See Also:
Constant Field Values

INPROGRESS

public static final java.lang.String INPROGRESS
See Also:
Constant Field Values

WriteOffed

public static final java.lang.String WriteOffed
See Also:
Constant Field Values

NotWriteOffed

public static final java.lang.String NotWriteOffed
See Also:
Constant Field Values

Unbilled

public static final java.lang.String Unbilled
See Also:
Constant Field Values

SCRAPPED

public static final java.lang.String SCRAPPED
See Also:
Constant Field Values

CLEARED

public static final java.lang.String CLEARED
See Also:
Constant Field Values

Acknowledged

public static final java.lang.String Acknowledged
See Also:
Constant Field Values

NOTCLEARED

public static final java.lang.String NOTCLEARED
See Also:
Constant Field Values

NotAcknowledged

public static final java.lang.String NotAcknowledged
See Also:
Constant Field Values
Constructor Detail

Constant.Status

public Constant.Status()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.SystemUserGroup

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.SystemUserGroup

java.lang.Object
    extended by  bb.common.Constant.SystemUserGroup
Enclosing class:
Constant
public static final class Constant.SystemUserGroup
extends java.lang.Object

Field Summary
static java.lang.String | ADD_ECN
static java.lang.String | ADD_NCR
static java.lang.String | ADD_PO
static java.lang.String | ADD_SO
static java.lang.String | APPROVE_PO
static java.lang.String | REVIEW_SO
static java.lang.String | UPDATE_ECN
static java.lang.String | UPDATE_NCR
static java.lang.String | UPDATE_PO
static java.lang.String | UPDATE_SO
Constructor Summary
Constant.SystemUserGroup()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ADD_SO

public static java.lang.String ADD_SO

UPDATE_SO

public static java.lang.String UPDATE_SO

REVIEW_SO

public static java.lang.String REVIEW_SO

ADD_PO

public static java.lang.String ADD_PO

UPDATE_PO

public static java.lang.String UPDATE_PO

APPROVE_PO

public static java.lang.String APPROVE_PO

ADD_ECN

public static java.lang.String ADD_ECN

UPDATE_ECN

public static java.lang.String UPDATE_ECN

ADD_NCR

public static java.lang.String ADD_NCR

UPDATE_NCR

public static java.lang.String UPDATE_NCR
Constructor Detail

Constant.SystemUserGroup

public Constant.SystemUserGroup()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.TaxType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.TaxType

java.lang.Object
    extended by  bb.common.Constant.TaxType
Enclosing class:
Constant
public static final class Constant.TaxType
extends java.lang.Object

Field Summary
static java.lang.String | PURCHASETAXRATE
static java.lang.String | SALESTAXRATE
Constructor Summary
Constant.TaxType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

SALESTAXRATE

public static final java.lang.String SALESTAXRATE
See Also:
Constant Field Values

PURCHASETAXRATE

public static final java.lang.String PURCHASETAXRATE
See Also:
Constant Field Values
Constructor Detail

Constant.TaxType

public Constant.TaxType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.TermsConditonType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.TermsConditonType

java.lang.Object
    extended by  bb.common.Constant.TermsConditonType
Enclosing class:
Constant
public static final class Constant.TermsConditonType
extends java.lang.Object

Field Summary
static java.lang.String | AR
static java.lang.String | PO
static java.lang.String | QUOTE
static java.lang.String | SO
Constructor Summary
Constant.TermsConditonType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

SO

public static final java.lang.String SO
See Also:
Constant Field Values

PO

public static final java.lang.String PO
See Also:
Constant Field Values

QUOTE

public static final java.lang.String QUOTE
See Also:
Constant Field Values

AR

public static final java.lang.String AR
See Also:
Constant Field Values
Constructor Detail

Constant.TermsConditonType

public Constant.TermsConditonType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.TrackingNumberType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.TrackingNumberType

java.lang.Object
    extended by  bb.common.Constant.TrackingNumberType
Enclosing class:
Constant
public static final class Constant.TrackingNumberType
extends java.lang.Object

Field Summary
static int | ISSUING_DWO
static int | ISSUING_NCR
static int | ISSUING_WO
static int | RECEIVING_DWO
static int | RECEIVING_NCR
static int | RECEIVING_ONLOAN
static int | RECEIVING_PO
static int | RECEIVING_RMA
static int | RECEIVING_SWAP_ORDER
static int | RECEIVING_TRANSFER_ORDER
static int | RECEIVING_WO
static int | SHIPPING_NP
static int | SHIPPING_ONLOAN
static int | SHIPPING_RTV
static int | SHIPPING_SO
static int | SHIPPING_SWAP_ORDER
static int | SHIPPING_TRANSFER_ORDER
Constructor Summary
Constant.TrackingNumberType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

RECEIVING_PO

public static int RECEIVING_PO

ISSUING_WO

public static int ISSUING_WO

RECEIVING_WO

public static int RECEIVING_WO

SHIPPING_SO

public static int SHIPPING_SO

RECEIVING_RMA

public static int RECEIVING_RMA

SHIPPING_RTV

public static int SHIPPING_RTV

SHIPPING_ONLOAN

public static int SHIPPING_ONLOAN

RECEIVING_ONLOAN

public static int RECEIVING_ONLOAN

SHIPPING_TRANSFER_ORDER

public static int SHIPPING_TRANSFER_ORDER

RECEIVING_TRANSFER_ORDER

public static int RECEIVING_TRANSFER_ORDER

SHIPPING_SWAP_ORDER

public static int SHIPPING_SWAP_ORDER

RECEIVING_SWAP_ORDER

public static int RECEIVING_SWAP_ORDER

ISSUING_NCR

public static int ISSUING_NCR

RECEIVING_NCR

public static int RECEIVING_NCR

ISSUING_DWO

public static int ISSUING_DWO

RECEIVING_DWO

public static int RECEIVING_DWO

SHIPPING_NP

public static int SHIPPING_NP
Constructor Detail

Constant.TrackingNumberType

public Constant.TrackingNumberType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.TransactionType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.TransactionType

java.lang.Object
    extended by  bb.common.Constant.TransactionType
Enclosing class:
Constant
public static final class Constant.TransactionType
extends java.lang.Object

Field Summary
static java.lang.String | A
static java.lang.String | E
static java.lang.String | F
static java.lang.String | I
static java.lang.String | J
static java.lang.String | M
static java.lang.String | O
static java.lang.String | R
Constructor Summary
Constant.TransactionType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

E

public static final java.lang.String E
See Also:
Constant Field Values

R

public static final java.lang.String R
See Also:
Constant Field Values

I

public static final java.lang.String I
See Also:
Constant Field Values

O

public static final java.lang.String O
See Also:
Constant Field Values

M

public static final java.lang.String M
See Also:
Constant Field Values

F

public static final java.lang.String F
See Also:
Constant Field Values

A

public static final java.lang.String A
See Also:
Constant Field Values

J

public static final java.lang.String J
See Also:
Constant Field Values
Constructor Detail

Constant.TransactionType

public Constant.TransactionType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.TransferType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.TransferType

java.lang.Object
    extended by  bb.common.Constant.TransferType
Enclosing class:
Constant
public static final class Constant.TransferType
extends java.lang.Object

Field Summary
static java.lang.String | Inner
static java.lang.String | Outer
Constructor Summary
Constant.TransferType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

Inner

public static java.lang.String Inner

Outer

public static java.lang.String Outer
Constructor Detail

Constant.TransferType

public Constant.TransferType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.Upload

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.Upload

java.lang.Object
    extended by  bb.common.Constant.Upload
Enclosing class:
Constant
public static final class Constant.Upload
extends java.lang.Object

Field Summary
static java.lang.String | AthoerException
static java.lang.String | NoAuthorization
static java.lang.String | Succeed
Constructor Summary
Constant.Upload()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

NoAuthorization

public static final java.lang.String NoAuthorization
See Also:
Constant Field Values

AthoerException

public static final java.lang.String AthoerException
See Also:
Constant Field Values

Succeed

public static final java.lang.String Succeed
See Also:
Constant Field Values
Constructor Detail

Constant.Upload

public Constant.Upload()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.VendorQualityStatus

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.VendorQualityStatus

java.lang.Object
    extended by  bb.common.Constant.VendorQualityStatus
Enclosing class:
Constant
public static final class Constant.VendorQualityStatus
extends java.lang.Object

Field Summary
static java.lang.String | LOCKED
static java.lang.String | Q_CODE_ONLY
Constructor Summary
Constant.VendorQualityStatus()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOCKED

public static final java.lang.String LOCKED
See Also:
Constant Field Values

Q_CODE_ONLY

public static final java.lang.String Q_CODE_ONLY
See Also:
Constant Field Values
Constructor Detail

Constant.VendorQualityStatus

public Constant.VendorQualityStatus()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.WorkCenterSearchType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.WorkCenterSearchType

java.lang.Object
    extended by  bb.common.Constant.WorkCenterSearchType
Enclosing class:
Constant
public static final class Constant.WorkCenterSearchType
extends java.lang.Object

Field Summary
static java.lang.String | All
static java.lang.String | WithoutParent
static java.lang.String | WithoutParentAndNotGroup
Constructor Summary
Constant.WorkCenterSearchType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

All

public static java.lang.String All

WithoutParent

public static java.lang.String WithoutParent

WithoutParentAndNotGroup

public static java.lang.String WithoutParentAndNotGroup
Constructor Detail

Constant.WorkCenterSearchType

public Constant.WorkCenterSearchType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.WorkCenterType

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.WorkCenterType

java.lang.Object
    extended by  bb.common.Constant.WorkCenterType
Enclosing class:
Constant
public static final class Constant.WorkCenterType
extends java.lang.Object

Field Summary
static java.lang.String | LABOR
static java.lang.String | MACHINE
static java.lang.String | OUTSOURCING
Constructor Summary
Constant.WorkCenterType()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

MACHINE

public static final java.lang.String MACHINE
See Also:
Constant Field Values

LABOR

public static final java.lang.String LABOR
See Also:
Constant Field Values

OUTSOURCING

public static final java.lang.String OUTSOURCING
See Also:
Constant Field Values
Constructor Detail

Constant.WorkCenterType

public Constant.WorkCenterType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.WorkLevel

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.WorkLevel

java.lang.Object
    extended by  bb.common.Constant.WorkLevel
Enclosing class:
Constant
public static final class Constant.WorkLevel
extends java.lang.Object

Field Summary
static java.lang.String | EIGHTLEVEL
static java.lang.String | FIVELEVEL
static java.lang.String | FOURLEVEL
static java.lang.String | NINELEVEL
static java.lang.String | ONELEVEL
static java.lang.String | SEVENLEVEL
static java.lang.String | SIXLEVEL
static java.lang.String | THREELEVEL
static java.lang.String | TWOLEVEL
Constructor Summary
Constant.WorkLevel()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ONELEVEL

public static java.lang.String ONELEVEL

TWOLEVEL

public static java.lang.String TWOLEVEL

THREELEVEL

public static java.lang.String THREELEVEL

FOURLEVEL

public static java.lang.String FOURLEVEL

FIVELEVEL

public static java.lang.String FIVELEVEL

SIXLEVEL

public static java.lang.String SIXLEVEL

SEVENLEVEL

public static java.lang.String SEVENLEVEL

EIGHTLEVEL

public static java.lang.String EIGHTLEVEL

NINELEVEL

public static java.lang.String NINELEVEL
Constructor Detail

Constant.WorkLevel

public Constant.WorkLevel()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constant.YesNO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Constant.YesNO

java.lang.Object
    extended by  bb.common.Constant.YesNO
Enclosing class:
Constant
public static final class Constant.YesNO
extends java.lang.Object

Field Summary
static java.lang.String | N
static java.lang.String | NO
static java.lang.String | NONE
static java.lang.String | Y
static java.lang.String | YES
Constructor Summary
Constant.YesNO()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

YES

public static final java.lang.String YES
See Also:
Constant Field Values

NO

public static final java.lang.String NO
See Also:
Constant Field Values

Y

public static final java.lang.String Y
See Also:
Constant Field Values

N

public static final java.lang.String N
See Also:
Constant Field Values

NONE

public static final java.lang.String NONE
See Also:
Constant Field Values
Constructor Detail

Constant.YesNO

public Constant.YesNO()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ContractPriceCustomerPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ContractPriceCustomerPK

java.lang.Object
    extended by  bb.common.ContractPriceCustomerPK
All Implemented Interfaces:
java.io.Serializable
public class ContractPriceCustomerPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
ContractPriceCustomerPK()
default constructor
ContractPriceCustomerPK(java.lang.String contractNumber, java.lang.String id)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getContractNumber()
java.lang.String | getId()
int | hashCode()
void | setContractNumber(java.lang.String contractNumber)
void | setId(java.lang.String id)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ContractPriceCustomerPK

public ContractPriceCustomerPK(java.lang.String contractNumber,
                               java.lang.String id)
full constructor

ContractPriceCustomerPK

public ContractPriceCustomerPK()
default constructor

Method Detail

getContractNumber

public java.lang.String getContractNumber()

setContractNumber

public void setContractNumber(java.lang.String contractNumber)

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ContractPriceCustomerVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ContractPriceCustomerVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ContractPriceCustomerVO
All Implemented Interfaces:
java.io.Serializable
public class ContractPriceCustomerVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CONTRACTNAME
static java.lang.String | ORDER_BY_PK
Constructor Summary
ContractPriceCustomerVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getContractName()
CustomerVendorAddressInfoVO | getCustomerInfo()
ContractPriceCustomerPK | getPk()
int | hashCode()
void | setContractName(java.lang.String contractName)
void | setCustomerInfo(CustomerVendorAddressInfoVO customerVendor)
void | setPk(ContractPriceCustomerPK pk)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PK

public static final java.lang.String ORDER_BY_PK
See Also:
Constant Field Values

ORDER_BY_CONTRACTNAME

public static final java.lang.String ORDER_BY_CONTRACTNAME
See Also:
Constant Field Values
Constructor Detail

ContractPriceCustomerVO

public ContractPriceCustomerVO()
Method Detail

getPk

public ContractPriceCustomerPK getPk()

setPk

public void setPk(ContractPriceCustomerPK pk)

getContractName

public java.lang.String getContractName()

setContractName

public void setContractName(java.lang.String contractName)

getCustomerInfo

public CustomerVendorAddressInfoVO getCustomerInfo()

setCustomerInfo

public void setCustomerInfo(CustomerVendorAddressInfoVO customerVendor)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ContractPriceItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ContractPriceItemPK

java.lang.Object
    extended by  bb.common.ContractPriceItemPK
All Implemented Interfaces:
java.io.Serializable
public class ContractPriceItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ContractPriceItemPK()
ContractPriceItemPK(java.lang.String contractNumber, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getContractNumber()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
int | hashCode()
void | setContractNumber(java.lang.String contractNumber)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ContractPriceItemPK

public ContractPriceItemPK()

ContractPriceItemPK

public ContractPriceItemPK(java.lang.String contractNumber,
                           java.lang.String partNumber,
                           java.lang.String partType,
                           java.lang.String partFrom)
Method Detail

getContractNumber

public java.lang.String getContractNumber()

setContractNumber

public void setContractNumber(java.lang.String contractNumber)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

getPartFrom

public java.lang.String getPartFrom()

setPartType

public void setPartType(java.lang.String partType)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ContractPriceItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ContractPriceItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ContractPriceItemVO
All Implemented Interfaces:
java.io.Serializable
public class ContractPriceItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_CONTRACTNAME
static java.lang.String | ORDER_BY_DISCOUNT
static java.lang.String | ORDER_BY_LISTPRICE
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PK
Constructor Summary
ContractPriceItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getBb2AvgCost()
java.math.BigDecimal | getBb2ListPrice()
java.math.BigDecimal | getBb2StdCost()
java.lang.String | getComments()
java.lang.String | getContractName()
java.lang.String | getDescription()
java.math.BigDecimal | getDiscount()
java.math.BigDecimal | getListPrice()
java.lang.String | getMfgPartNumber()
ContractPriceItemPK | getPk()
int | hashCode()
void | setBb2AvgCost(java.math.BigDecimal bb2AvgCost)
void | setBb2ListPrice(java.math.BigDecimal bb2ListPrice)
void | setBb2StdCost(java.math.BigDecimal bb2StdCost)
void | setComments(java.lang.String comments)
void | setContractName(java.lang.String contractName)
void | setDescription(java.lang.String description)
void | setDiscount(java.math.BigDecimal discount)
void | setListPrice(java.math.BigDecimal listPrice)
void | setMfgPartNumber(java.lang.String mfgPartNumber)
void | setPk(ContractPriceItemPK pk)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PK

public static final java.lang.String ORDER_BY_PK
See Also:
Constant Field Values

ORDER_BY_CONTRACTNAME

public static final java.lang.String ORDER_BY_CONTRACTNAME
See Also:
Constant Field Values

ORDER_BY_LISTPRICE

public static final java.lang.String ORDER_BY_LISTPRICE
See Also:
Constant Field Values

ORDER_BY_DISCOUNT

public static final java.lang.String ORDER_BY_DISCOUNT
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values
Constructor Detail

ContractPriceItemVO

public ContractPriceItemVO()
Method Detail

getPk

public ContractPriceItemPK getPk()

setPk

public void setPk(ContractPriceItemPK pk)

getContractName

public java.lang.String getContractName()

setContractName

public void setContractName(java.lang.String contractName)

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getComments

public java.lang.String getComments()

getBb2ListPrice

public java.math.BigDecimal getBb2ListPrice()

getBb2AvgCost

public java.math.BigDecimal getBb2AvgCost()

getBb2StdCost

public java.math.BigDecimal getBb2StdCost()

setComments

public void setComments(java.lang.String comments)

setBb2ListPrice

public void setBb2ListPrice(java.math.BigDecimal bb2ListPrice)

setBb2AvgCost

public void setBb2AvgCost(java.math.BigDecimal bb2AvgCost)

setBb2StdCost

public void setBb2StdCost(java.math.BigDecimal bb2StdCost)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getMfgPartNumber

public java.lang.String getMfgPartNumber()

setMfgPartNumber

public void setMfgPartNumber(java.lang.String mfgPartNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ContractPriceVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ContractPriceVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ContractPriceVO
All Implemented Interfaces:
java.io.Serializable
public class ContractPriceVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CONTRACTNUMBER
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_EXPIREDATE
static java.lang.String | ORDER_BY_LASTCHANGEDATE
static java.lang.String | ORDER_BY_LASTCHANGEUSER
static java.lang.String | ORDER_BY_STARTDATE
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
ContractPriceVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getContractName()
java.lang.String | getContractNumber()
java.util.Date | getCreateDate()
java.lang.String | getCurrency()
java.lang.String | getDescription()
java.util.Date | getExpireDate()
java.util.Date | getLastChangeDate()
int | getLastChangeTimes()
java.lang.String | getLastChangeUser()
java.lang.String | getOrigin()
java.util.Date | getStartDate()
java.lang.String | getStatus()
int | hashCode()
void | setContractName(java.lang.String contractName)
void | setContractNumber(java.lang.String contractNumber)
void | setCreateDate(java.util.Date createDate)
void | setCurrency(java.lang.String currency)
void | setDescription(java.lang.String description)
void | setExpireDate(java.util.Date expireDate)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTimes(int lastChangeTimes)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setOrigin(java.lang.String origin)
void | setStartDate(java.util.Date startDate)
void | setStatus(java.lang.String status)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_CONTRACTNUMBER

public static final java.lang.String ORDER_BY_CONTRACTNUMBER
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEUSER

public static final java.lang.String ORDER_BY_LASTCHANGEUSER
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEDATE

public static final java.lang.String ORDER_BY_LASTCHANGEDATE
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values

ORDER_BY_STARTDATE

public static final java.lang.String ORDER_BY_STARTDATE
See Also:
Constant Field Values

ORDER_BY_EXPIREDATE

public static final java.lang.String ORDER_BY_EXPIREDATE
See Also:
Constant Field Values
Constructor Detail

ContractPriceVO

public ContractPriceVO()
Method Detail

getContractNumber

public java.lang.String getContractNumber()

setContractNumber

public void setContractNumber(java.lang.String contractNumber)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeTimes

public int getLastChangeTimes()

setLastChangeTimes

public void setLastChangeTimes(int lastChangeTimes)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getContractName

public java.lang.String getContractName()

setContractName

public void setContractName(java.lang.String contractName)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getStartDate

public java.util.Date getStartDate()

setStartDate

public void setStartDate(java.util.Date startDate)

getExpireDate

public java.util.Date getExpireDate()

setExpireDate

public void setExpireDate(java.util.Date expireDate)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getCreateDate

public java.util.Date getCreateDate()

setCreateDate

public void setCreateDate(java.util.Date createDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CopyUtil

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CopyUtil

java.lang.Object
    extended by  bb.common.CopyUtil

public class CopyUtil
extends java.lang.Object

Constructor Summary
CopyUtil()
Method Summary
static java.lang.Object copy(java.lang.Object object)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CopyUtil

public CopyUtil()
Method Detail

copy

public static java.lang.Object copy(java.lang.Object object)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CorrectiveActionRequestVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CorrectiveActionRequestVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CorrectiveActionRequestVO
All Implemented Interfaces:
java.io.Serializable
public class CorrectiveActionRequestVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CARNUMBER
static java.lang.String | ORDER_BY_DATEENTERED
static java.lang.String | ORDER_BY_DEPARTMENTID
static java.lang.String | ORDER_BY_DEPARTNAME
static java.lang.String | ORDER_BY_DUEDATE
static java.lang.String | ORDER_BY_LASTCHANGEDATE
static java.lang.String | ORDER_BY_LASTCHANGEUSER
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
CorrectiveActionRequestVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.lang.String | getApprovedBy()
java.lang.String | getCarNumber()
java.lang.String | getClosedOutBy()
java.lang.String | getClosedOutComments()
java.util.Date | getClosedOutDate()
java.lang.String | getClosedOutPrivateNotes()
java.lang.String | getConditionAcknowledgedBy()
java.lang.String | getConditionDescription()
java.lang.String | getConditionNotedBy()
java.util.Date | getDateEntered()
java.lang.String | getDepartmentId()
java.lang.String | getDepartName()
java.lang.String | getDescription()
java.util.Date | getDueDate()
java.lang.String | getEnteredBy()
java.util.Date | getImplementionDue()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getModelNumber()
java.lang.String | getOrigin()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getProposedAction()
java.util.Date | getProposedActionDate()
java.lang.String | getProposedBy()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.lang.String | getResponsibility()
java.lang.String | getRevision()
java.lang.String | getStatus()
java.lang.String | getThirdParty()
java.lang.Integer | getVersion()
int | hashCode()
void | setAdate(java.util.Date adate)
void | setApprovedBy(java.lang.String approvedBy)
void | setCarNumber(java.lang.String carNumber)
void | setClosedOutBy(java.lang.String closedOutBy)
void | setClosedOutComments(java.lang.String closedOutComments)
void | setClosedOutDate(java.util.Date closedOutDate)
void | setClosedOutPrivateNotes(java.lang.String closedOutPrivateNotes)
void | setConditionAcknowledgedBy(java.lang.String conditionAcknowledgedBy)
void | setConditionDescription(java.lang.String conditionDescription)
void | setConditionNotedBy(java.lang.String conditionNotedBy)
void | setDateEntered(java.util.Date dateEntered)
void | setDepartmentId(java.lang.String departmentId)
void | setDepartName(java.lang.String departName)
void | setDescription(java.lang.String description)
void | setDueDate(java.util.Date dueDate)
void | setEnteredBy(java.lang.String enteredBy)
void | setImplementionDue(java.util.Date implementionDue)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setModelNumber(java.lang.String modelNumber)
void | setOrigin(java.lang.String origin)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setProposedAction(java.lang.String proposedAction)
void | setProposedActionDate(java.util.Date proposedActionDate)
void | setProposedBy(java.lang.String proposedBy)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setResponsibility(java.lang.String responsibility)
void | setRevision(java.lang.String revision)
void | setStatus(java.lang.String status)
void | setThirdParty(java.lang.String thirdParty)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_CARNUMBER

public static final java.lang.String ORDER_BY_CARNUMBER
See Also:
Constant Field Values

ORDER_BY_DUEDATE

public static final java.lang.String ORDER_BY_DUEDATE
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEUSER

public static final java.lang.String ORDER_BY_LASTCHANGEUSER
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEDATE

public static final java.lang.String ORDER_BY_LASTCHANGEDATE
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_DEPARTMENTID

public static final java.lang.String ORDER_BY_DEPARTMENTID
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_DEPARTNAME

public static final java.lang.String ORDER_BY_DEPARTNAME
See Also:
Constant Field Values

ORDER_BY_DATEENTERED

public static final java.lang.String ORDER_BY_DATEENTERED
See Also:
Constant Field Values
Constructor Detail

CorrectiveActionRequestVO

public CorrectiveActionRequestVO()
default constructor

Method Detail

getCarNumber

public java.lang.String getCarNumber()

setCarNumber

public void setCarNumber(java.lang.String carNumber)

getDueDate

public java.util.Date getDueDate()

setDueDate

public void setDueDate(java.util.Date dueDate)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getDateEntered

public java.util.Date getDateEntered()

setDateEntered

public void setDateEntered(java.util.Date dateEntered)

getEnteredBy

public java.lang.String getEnteredBy()

setEnteredBy

public void setEnteredBy(java.lang.String enteredBy)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getDepartmentId

public java.lang.String getDepartmentId()

setDepartmentId

public void setDepartmentId(java.lang.String departmentId)

getDepartName

public java.lang.String getDepartName()

setDepartName

public void setDepartName(java.lang.String departName)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getThirdParty

public java.lang.String getThirdParty()

setThirdParty

public void setThirdParty(java.lang.String thirdParty)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getConditionDescription

public java.lang.String getConditionDescription()

setConditionDescription

public void setConditionDescription(java.lang.String conditionDescription)

getConditionNotedBy

public java.lang.String getConditionNotedBy()

setConditionNotedBy

public void setConditionNotedBy(java.lang.String conditionNotedBy)

getConditionAcknowledgedBy

public java.lang.String getConditionAcknowledgedBy()

setConditionAcknowledgedBy

public void setConditionAcknowledgedBy(java.lang.String conditionAcknowledgedBy)

getProposedAction

public java.lang.String getProposedAction()

setProposedAction

public void setProposedAction(java.lang.String proposedAction)

getProposedBy

public java.lang.String getProposedBy()

setProposedBy

public void setProposedBy(java.lang.String proposedBy)

getProposedActionDate

public java.util.Date getProposedActionDate()

setProposedActionDate

public void setProposedActionDate(java.util.Date proposedActionDate)

getApprovedBy

public java.lang.String getApprovedBy()

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)

getImplementionDue

public java.util.Date getImplementionDue()

setImplementionDue

public void setImplementionDue(java.util.Date implementionDue)

getClosedOutBy

public java.lang.String getClosedOutBy()

setClosedOutBy

public void setClosedOutBy(java.lang.String closedOutBy)

getClosedOutDate

public java.util.Date getClosedOutDate()

setClosedOutDate

public void setClosedOutDate(java.util.Date closedOutDate)

getClosedOutComments

public java.lang.String getClosedOutComments()

setClosedOutComments

public void setClosedOutComments(java.lang.String closedOutComments)

getClosedOutPrivateNotes

public java.lang.String getClosedOutPrivateNotes()

getVersion

public java.lang.Integer getVersion()

getPartFrom

public java.lang.String getPartFrom()

setClosedOutPrivateNotes

public void setClosedOutPrivateNotes(java.lang.String closedOutPrivateNotes)

setVersion

public void setVersion(java.lang.Integer version)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getResponsibility

public java.lang.String getResponsibility()

setResponsibility

public void setResponsibility(java.lang.String responsibility)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CPItemFromQuoteResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CPItemFromQuoteResult

java.lang.Object
    extended by  bb.common.CPItemFromQuoteResult
All Implemented Interfaces:
java.io.Serializable
public class CPItemFromQuoteResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CPItemFromQuoteResult()
Method Summary
java.lang.String | getContractNumber()
java.lang.String | getCpiCurrency()
java.math.BigDecimal | getCpiDiscount()
java.math.BigDecimal | getCpiListPrice()
java.lang.String | getCustomerID()
java.lang.String | getDescription()
java.math.BigDecimal | getExchange()
java.util.Collection | getMfgPartNumbers()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getQuoteCurrency()
java.math.BigDecimal | getQuoteDiscount()
java.lang.String | getQuoteItemNumber()
java.math.BigDecimal | getQuoteListPrice()
java.util.Date | getValidThru()
boolean | isHighlight()
void | setContractNumber(java.lang.String contractNumber)
void | setCpiCurrency(java.lang.String cpiCurrency)
void | setCpiDiscount(java.math.BigDecimal cpiDiscount)
void | setCpiListPrice(java.math.BigDecimal cpiListPrice)
void | setCustomerID(java.lang.String customerID)
void | setDescription(java.lang.String description)
void | setExchange(java.math.BigDecimal exchange)
void | setHighlight(boolean highlight)
void | setMfgPartNumbers(java.util.Collection mfgPartNumbers)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setQuoteCurrency(java.lang.String quoteCurrency)
void | setQuoteDiscount(java.math.BigDecimal quoteDiscount)
void | setQuoteItemNumber(java.lang.String quoteItemNumber)
void | setQuoteListPrice(java.math.BigDecimal quoteListPrice)
void | setValidThru(java.util.Date validThru)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CPItemFromQuoteResult

public CPItemFromQuoteResult()
Method Detail

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getCpiDiscount

public java.math.BigDecimal getCpiDiscount()

setCpiDiscount

public void setCpiDiscount(java.math.BigDecimal cpiDiscount)

getCpiListPrice

public java.math.BigDecimal getCpiListPrice()

setCpiListPrice

public void setCpiListPrice(java.math.BigDecimal cpiListPrice)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getQuoteDiscount

public java.math.BigDecimal getQuoteDiscount()

setQuoteDiscount

public void setQuoteDiscount(java.math.BigDecimal quoteDiscount)

getQuoteItemNumber

public java.lang.String getQuoteItemNumber()

setQuoteItemNumber

public void setQuoteItemNumber(java.lang.String quoteItemNumber)

getQuoteListPrice

public java.math.BigDecimal getQuoteListPrice()

setQuoteListPrice

public void setQuoteListPrice(java.math.BigDecimal quoteListPrice)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getValidThru

public java.util.Date getValidThru()

setValidThru

public void setValidThru(java.util.Date validThru)

getCustomerID

public java.lang.String getCustomerID()

setCustomerID

public void setCustomerID(java.lang.String customerID)

getExchange

public java.math.BigDecimal getExchange()

setExchange

public void setExchange(java.math.BigDecimal exchange)

getContractNumber

public java.lang.String getContractNumber()

setContractNumber

public void setContractNumber(java.lang.String contractNumber)

getCpiCurrency

public java.lang.String getCpiCurrency()

setCpiCurrency

public void setCpiCurrency(java.lang.String cpiCurrency)

isHighlight

public boolean isHighlight()

setHighlight

public void setHighlight(boolean highlight)

getQuoteCurrency

public java.lang.String getQuoteCurrency()

setQuoteCurrency

public void setQuoteCurrency(java.lang.String quoteCurrency)

getMfgPartNumbers

public java.util.Collection getMfgPartNumbers()

setMfgPartNumbers

public void setMfgPartNumbers(java.util.Collection mfgPartNumbers)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CRTVItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CRTVItemListResult

java.lang.Object
    extended by  bb.common.CRTVItemListResult
All Implemented Interfaces:
java.io.Serializable
public class CRTVItemListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String ORDER_BY_CRTVNUMBER
Constructor Summary
CRTVItemListResult()
Method Summary
java.lang.String | getCompanyUnitId()
java.math.BigDecimal | getCostPerUnit()
java.util.Date | getCrtvDate()
java.lang.String | getCrtvItemNumber()
java.lang.String | getCrtvNumber()
java.lang.String | getCustomerId()
java.lang.String | getDebitAccount()
java.util.Date | getDeliveryDate()
java.math.BigDecimal | getDiscount()
java.lang.String | getInvoiceNumber()
java.lang.String | getItemDescription()
java.math.BigDecimal | getOnDemandQty()
java.math.BigDecimal | getOnhandQty()
java.math.BigDecimal | getOnorderQty()
java.math.BigDecimal | getOrderedQty()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.lang.String | getSalesman()
java.lang.String | getSalesOrderNumber()
java.lang.String | getStatus()
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCostPerUnit(java.math.BigDecimal costPerUnit)
void | setCrtvDate(java.util.Date crtvDate)
void | setCrtvItemNumber(java.lang.String crtvItemNumber)
void | setCrtvNumber(java.lang.String crtvNumber)
void | setCustomerId(java.lang.String customerId)
void | setDebitAccount(java.lang.String debitAccount)
void | setDeliveryDate(java.util.Date deliveryDate)
void | setDiscount(java.math.BigDecimal discount)
void | setInvoiceNumber(java.lang.String invoiceNumber)
void | setItemDescription(java.lang.String itemDescription)
void | setOnDemandQty(java.math.BigDecimal onDemandQty)
void | setOnhandQty(java.math.BigDecimal onhandQty)
void | setOnorderQty(java.math.BigDecimal onorderQty)
void | setOrderedQty(java.math.BigDecimal orderedQty)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setSalesman(java.lang.String salesman)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setStatus(java.lang.String status)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_CRTVNUMBER

public static final java.lang.String ORDER_BY_CRTVNUMBER
See Also:
Constant Field Values
Constructor Detail

CRTVItemListResult

public CRTVItemListResult()
Method Detail

getCrtvNumber

public java.lang.String getCrtvNumber()

setCrtvNumber

public void setCrtvNumber(java.lang.String crtvNumber)

getCrtvItemNumber

public java.lang.String getCrtvItemNumber()

setCrtvItemNumber

public void setCrtvItemNumber(java.lang.String crtvItemNumber)

getPartPk

public PartPK getPartPk()

setPartPk

public void setPartPk(PartPK partPk)

getItemDescription

public java.lang.String getItemDescription()

setItemDescription

public void setItemDescription(java.lang.String itemDescription)

getCrtvDate

public java.util.Date getCrtvDate()

setCrtvDate

public void setCrtvDate(java.util.Date crtvDate)

getDeliveryDate

public java.util.Date getDeliveryDate()

setDeliveryDate

public void setDeliveryDate(java.util.Date deliveryDate)

getOrderedQty

public java.math.BigDecimal getOrderedQty()

setOrderedQty

public void setOrderedQty(java.math.BigDecimal orderedQty)

getCostPerUnit

public java.math.BigDecimal getCostPerUnit()

setCostPerUnit

public void setCostPerUnit(java.math.BigDecimal costPerUnit)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getInvoiceNumber

public java.lang.String getInvoiceNumber()

setInvoiceNumber

public void setInvoiceNumber(java.lang.String invoiceNumber)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getSalesman

public java.lang.String getSalesman()

setSalesman

public void setSalesman(java.lang.String salesman)

getOnhandQty

public java.math.BigDecimal getOnhandQty()

setOnhandQty

public void setOnhandQty(java.math.BigDecimal onhandQty)

getOnorderQty

public java.math.BigDecimal getOnorderQty()

setOnorderQty

public void setOnorderQty(java.math.BigDecimal onorderQty)

getOnDemandQty

public java.math.BigDecimal getOnDemandQty()

setOnDemandQty

public void setOnDemandQty(java.math.BigDecimal onDemandQty)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getDebitAccount

public java.lang.String getDebitAccount()

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CRTVListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CRTVListResult

java.lang.Object
    extended by  bb.common.CRTVListResult
All Implemented Interfaces:
java.io.Serializable
public class CRTVListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CHANGEORDER
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_CRTVDATE
static java.lang.String | ORDER_BY_CRTVNUMBER
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_INVOICENUMBER
static java.lang.String | ORDER_BY_PROJECTNAME
static java.lang.String | ORDER_BY_SALESMAN
static java.lang.String | ORDER_BY_SALESORDERNUMBER
Constructor Summary
CRTVListResult()
Method Summary
java.lang.String | getChangeOrder()
java.lang.String | getComments()
java.util.Date | getCrtvDate()
java.lang.String | getCrtvNumber()
java.lang.String | getCustomerId()
java.lang.String | getInvoiceNumber()
java.lang.String | getPrivateNote()
java.lang.String | getProject()
java.lang.String | getRequester()
java.lang.String | getSalesman()
java.lang.String | getSalesOrderNumber()
java.lang.String | getStatus()
void | setChangeOrder(java.lang.String changeOrder)
void | setComments(java.lang.String comments)
void | setCrtvDate(java.util.Date crtvDate)
void | setCrtvNumber(java.lang.String crtvmNuber)
void | setCustomerId(java.lang.String customerId)
void | setInvoiceNumber(java.lang.String invoiceNumber)
void | setPrivateNote(java.lang.String privateNote)
void | setProject(java.lang.String project)
void | setRequester(java.lang.String requester)
void | setSalesman(java.lang.String salesman)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setStatus(java.lang.String status)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_CRTVNUMBER

public static final java.lang.String ORDER_BY_CRTVNUMBER
See Also:
Constant Field Values

ORDER_BY_CHANGEORDER

public static final java.lang.String ORDER_BY_CHANGEORDER
See Also:
Constant Field Values

ORDER_BY_CRTVDATE

public static final java.lang.String ORDER_BY_CRTVDATE
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_INVOICENUMBER

public static final java.lang.String ORDER_BY_INVOICENUMBER
See Also:
Constant Field Values

ORDER_BY_SALESORDERNUMBER

public static final java.lang.String ORDER_BY_SALESORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_PROJECTNAME

public static final java.lang.String ORDER_BY_PROJECTNAME
See Also:
Constant Field Values

ORDER_BY_SALESMAN

public static final java.lang.String ORDER_BY_SALESMAN
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values
Constructor Detail

CRTVListResult

public CRTVListResult()
Method Detail

getCrtvNumber

public java.lang.String getCrtvNumber()

setCrtvNumber

public void setCrtvNumber(java.lang.String crtvmNuber)

getCrtvDate

public java.util.Date getCrtvDate()

setCrtvDate

public void setCrtvDate(java.util.Date crtvDate)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getInvoiceNumber

public java.lang.String getInvoiceNumber()

setInvoiceNumber

public void setInvoiceNumber(java.lang.String invoiceNumber)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

getPrivateNote

public java.lang.String getPrivateNote()

setPrivateNote

public void setPrivateNote(java.lang.String privateNote)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getRequester

public java.lang.String getRequester()

setRequester

public void setRequester(java.lang.String requester)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getSalesman

public java.lang.String getSalesman()

setSalesman

public void setSalesman(java.lang.String salesman)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CSRAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CSRAgent

java.lang.Object
    extended by  bb.common.CSRAgent
All Implemented Interfaces:
java.io.Serializable
public class CSRAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CSRAgent()
Method Summary
java.lang.String | getContact()
java.lang.String | getCustID()
java.lang.String | getEmail()
java.lang.String | getEquipCondition()
java.lang.String | getLocation()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getPhone()
java.lang.String | getPriority()
java.lang.String | getReqDescription()
java.lang.String | getRequestor()
java.util.Date | getRequireDate()
java.lang.String | getSalesOrderItemNumber()
java.lang.String | getSalesOrderNumber()
java.lang.String | getSerial()
java.lang.String | getSeriveType()
void | setContact(java.lang.String contact)
void | setCustID(java.lang.String custID)
void | setEmail(java.lang.String email)
void | setEquipCondition(java.lang.String equipCondition)
void | setLocation(java.lang.String location)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPhone(java.lang.String phone)
void | setPriority(java.lang.String priority)
void | setReqDescription(java.lang.String reqDescription)
void | setRequestor(java.lang.String requestor)
void | setRequireDate(java.util.Date requireDate)
void | setSalesOrderItemNumber(java.lang.String salesOrderItemNumber)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setSerial(java.lang.String serial)
void | setSeriveType(java.lang.String seriveType)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CSRAgent

public CSRAgent()
Method Detail

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getCustID

public java.lang.String getCustID()

setCustID

public void setCustID(java.lang.String custID)

getEmail

public java.lang.String getEmail()

setEmail

public void setEmail(java.lang.String email)

getEquipCondition

public java.lang.String getEquipCondition()

setEquipCondition

public void setEquipCondition(java.lang.String equipCondition)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPhone

public java.lang.String getPhone()

setPhone

public void setPhone(java.lang.String phone)

getReqDescription

public java.lang.String getReqDescription()

setReqDescription

public void setReqDescription(java.lang.String reqDescription)

getRequestor

public java.lang.String getRequestor()

setRequestor

public void setRequestor(java.lang.String requestor)

getRequireDate

public java.util.Date getRequireDate()

setRequireDate

public void setRequireDate(java.util.Date requireDate)

getSalesOrderItemNumber

public java.lang.String getSalesOrderItemNumber()

setSalesOrderItemNumber

public void setSalesOrderItemNumber(java.lang.String salesOrderItemNumber)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getSerial

public java.lang.String getSerial()

setSerial

public void setSerial(java.lang.String serial)

getSeriveType

public java.lang.String getSeriveType()

setSeriveType

public void setSeriveType(java.lang.String seriveType)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CurrencyAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CurrencyAgent

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CurrencyAgent
All Implemented Interfaces:
java.io.Serializable
public class CurrencyAgent
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CurrencyAgent()
Method Summary
FiscalYearSettingsVO | getFiscalYearSettingsVO()
CurrencyVO | getVo()
void | setFiscalYearSettingsVO(FiscalYearSettingsVO fiscalYearSettingsVO)
void | setVo(CurrencyVO vo)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CurrencyAgent

public CurrencyAgent()
Method Detail

getFiscalYearSettingsVO

public FiscalYearSettingsVO getFiscalYearSettingsVO()

setFiscalYearSettingsVO

public void setFiscalYearSettingsVO(FiscalYearSettingsVO fiscalYearSettingsVO)

getVo

public CurrencyVO getVo()

setVo

public void setVo(CurrencyVO vo)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CurrencyExchangePK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CurrencyExchangePK

java.lang.Object
    extended by  bb.common.CurrencyExchangePK
All Implemented Interfaces:
java.io.Serializable
public class CurrencyExchangePK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
CurrencyExchangePK()
default constructor
CurrencyExchangePK(java.lang.String monthYear, java.lang.String currency)
full constructor
Method Summary
int | compareTo(CurrencyExchangePK other)
boolean | equals(java.lang.Object other)
java.lang.String | getCurrency()
java.lang.String | getMonthYear()
int | hashCode()
void | setCurrency(java.lang.String currency)
void | setMonthYear(java.lang.String monthYear)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CurrencyExchangePK

public CurrencyExchangePK(java.lang.String monthYear,
                          java.lang.String currency)
full constructor

CurrencyExchangePK

public CurrencyExchangePK()
default constructor

Method Detail

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getMonthYear

public java.lang.String getMonthYear()

setMonthYear

public void setMonthYear(java.lang.String monthYear)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()

compareTo

public int compareTo(CurrencyExchangePK other)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CurrencyExchangeVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CurrencyExchangeVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CurrencyExchangeVO
All Implemented Interfaces:
java.io.Serializable
public class CurrencyExchangeVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_EXCHANGE
static java.lang.String | ORDER_BY_PK
Constructor Summary
CurrencyExchangeVO()
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getAuditExchange()
java.util.Date | getEndMonth()
java.math.BigDecimal | getExchange()
java.math.BigDecimal | getOrgAuditExchange()
CurrencyExchangePK | getPk()
java.util.Date | getStartMonth()
int | hashCode()
void | setAuditExchange(java.math.BigDecimal auditExchange)
void | setEndMonth(java.util.Date endMonth)
void | setExchange(java.math.BigDecimal exchange)
void | setOrgAuditExchange(java.math.BigDecimal orgAuditExchange)
void | setPk(CurrencyExchangePK pk)
void | setStartMonth(java.util.Date startMonth)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PK

public static final java.lang.String ORDER_BY_PK
See Also:
Constant Field Values

ORDER_BY_EXCHANGE

public static final java.lang.String ORDER_BY_EXCHANGE
See Also:
Constant Field Values
Constructor Detail

CurrencyExchangeVO

public CurrencyExchangeVO()
Method Detail

setExchange

public void setExchange(java.math.BigDecimal exchange)

getExchange

public java.math.BigDecimal getExchange()

getAuditExchange

public java.math.BigDecimal getAuditExchange()

setAuditExchange

public void setAuditExchange(java.math.BigDecimal auditExchange)

getPk

public CurrencyExchangePK getPk()

setPk

public void setPk(CurrencyExchangePK pk)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getStartMonth

public java.util.Date getStartMonth()

setStartMonth

public void setStartMonth(java.util.Date startMonth)

getEndMonth

public java.util.Date getEndMonth()

setEndMonth

public void setEndMonth(java.util.Date endMonth)

getOrgAuditExchange

public java.math.BigDecimal getOrgAuditExchange()

setOrgAuditExchange

public void setOrgAuditExchange(java.math.BigDecimal orgAuditExchange)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CurrencyVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CurrencyVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CurrencyVO
All Implemented Interfaces:
java.io.Serializable
public class CurrencyVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String ORDER_BY_CURRENCY
Constructor Summary
CurrencyVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCurrency()
java.math.BigDecimal | getExchange()
java.util.Set | getExchangeRate()
java.lang.String | getSymbol()
int | hashCode()
void | setCurrency(java.lang.String currency)
void | setExchange(java.math.BigDecimal exchange)
void | setExchangeRate(java.util.Set exchangeRate)
void | setSymbol(java.lang.String symbol)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values
Constructor Detail

CurrencyVO

public CurrencyVO()
Method Detail

setCurrency

public void setCurrency(java.lang.String currency)

getCurrency

public java.lang.String getCurrency()

setExchange

public void setExchange(java.math.BigDecimal exchange)

getExchange

public java.math.BigDecimal getExchange()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getSymbol

public java.lang.String getSymbol()

setSymbol

public void setSymbol(java.lang.String symbol)

getExchangeRate

public java.util.Set getExchangeRate()

setExchangeRate

public void setExchangeRate(java.util.Set exchangeRate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CurrentBalanceResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CurrentBalanceResult

java.lang.Object
    extended by  bb.common.CurrentBalanceResult
All Implemented Interfaces:
java.io.Serializable
public class CurrentBalanceResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CurrentBalanceResult()
Method Summary
AccountsChartVO | getAccountVo()
java.math.BigDecimal | getCreditEndingBalance()
java.math.BigDecimal | getCreditMonthTotal()
java.math.BigDecimal | getCreditStartingBalance()
java.math.BigDecimal | getDebitEndingBalance()
java.math.BigDecimal | getDebitMonthTotal()
java.math.BigDecimal | getDebitStartingBalance()
int | getTotalItems()
void | setAccountVo(AccountsChartVO accountVo)
void | setCreditEndingBalance(java.math.BigDecimal creditEndingBalance)
void | setCreditMonthTotal(java.math.BigDecimal creditMonthTotal)
void | setCreditStartingBalance(java.math.BigDecimal creditStartingBalance)
void | setDebitEndingBalance(java.math.BigDecimal debitEndingBalance)
void | setDebitMonthTotal(java.math.BigDecimal debitMonthTotal)
void | setDebitStartingBalance(java.math.BigDecimal debitStartingBalance)
void | setTotalItems(int totalItems)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CurrentBalanceResult

public CurrentBalanceResult()
Method Detail

setAccountVo

public void setAccountVo(AccountsChartVO accountVo)

setCreditEndingBalance

public void setCreditEndingBalance(java.math.BigDecimal creditEndingBalance)

setDebitEndingBalance

public void setDebitEndingBalance(java.math.BigDecimal debitEndingBalance)

setCreditMonthTotal

public void setCreditMonthTotal(java.math.BigDecimal creditMonthTotal)

setDebitMonthTotal

public void setDebitMonthTotal(java.math.BigDecimal debitMonthTotal)

setCreditStartingBalance

public void setCreditStartingBalance(java.math.BigDecimal creditStartingBalance)

setDebitStartingBalance

public void setDebitStartingBalance(java.math.BigDecimal debitStartingBalance)

setTotalItems

public void setTotalItems(int totalItems)

getAccountVo

public AccountsChartVO getAccountVo()

getCreditEndingBalance

public java.math.BigDecimal getCreditEndingBalance()

getDebitEndingBalance

public java.math.BigDecimal getDebitEndingBalance()

getCreditMonthTotal

public java.math.BigDecimal getCreditMonthTotal()

getDebitMonthTotal

public java.math.BigDecimal getDebitMonthTotal()

getCreditStartingBalance

public java.math.BigDecimal getCreditStartingBalance()

getDebitStartingBalance

public java.math.BigDecimal getDebitStartingBalance()

getTotalItems

public int getTotalItems()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomAssetRecordPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomAssetRecordPK

java.lang.Object
    extended by  bb.common.CustomAssetRecordPK
All Implemented Interfaces:
java.io.Serializable
public class CustomAssetRecordPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CustomAssetRecordPK()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAssetNumber()
java.lang.Short | getIi()
int | hashCode()
void | setAssetNumber(java.lang.String assetNumber)
void | setIi(java.lang.Short ii)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CustomAssetRecordPK

public CustomAssetRecordPK()
Method Detail

getAssetNumber

public java.lang.String getAssetNumber()

setAssetNumber

public void setAssetNumber(java.lang.String assetNumber)

getIi

public java.lang.Short getIi()

setIi

public void setIi(java.lang.Short ii)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomAssetRecordVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomAssetRecordVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CustomAssetRecordVO
All Implemented Interfaces:
java.io.Serializable
public class CustomAssetRecordVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CustomAssetRecordVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
CustomDepartmentVO | getCustomReceiveDepartment()
CustomDepartmentVO | getCustomReturnDepartment()
CustomAssetRecordPK | getPk()
java.lang.String | getReceiveComment()
java.util.Date | getReceiveDate()
java.lang.String | getReceiveDepartment()
java.lang.String | getReceiveSign()
java.lang.String | getReturnComment()
java.util.Date | getReturnDate()
java.lang.String | getReturnDepartment()
java.lang.String | getReturnSign()
java.lang.String | getUser()
int | hashCode()
void | setCustomReceiveDepartment(CustomDepartmentVO customReceiveDepartment)
void | setCustomReturnDepartment(CustomDepartmentVO customReturnDepartment)
void | setPk(CustomAssetRecordPK pk)
void | setReceiveComment(java.lang.String receiveComment)
void | setReceiveDate(java.util.Date receiveDate)
void | setReceiveDepartment(java.lang.String receiveDepartment)
void | setReceiveSign(java.lang.String receiveSign)
void | setReturnComment(java.lang.String returnComment)
void | setReturnDate(java.util.Date returnDate)
void | setReturnDepartment(java.lang.String returnDepartment)
void | setReturnSign(java.lang.String returnSign)
void | setUser(java.lang.String user)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CustomAssetRecordVO

public CustomAssetRecordVO()
default constructor

Method Detail

getReceiveDate

public java.util.Date getReceiveDate()

setReceiveDate

public void setReceiveDate(java.util.Date receiveDate)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getReceiveComment

public java.lang.String getReceiveComment()

setReceiveComment

public void setReceiveComment(java.lang.String receiveComment)

getReceiveDepartment

public java.lang.String getReceiveDepartment()

setReceiveDepartment

public void setReceiveDepartment(java.lang.String receiveDepartment)

getReceiveSign

public java.lang.String getReceiveSign()

setReceiveSign

public void setReceiveSign(java.lang.String receiveSign)

getReturnComment

public java.lang.String getReturnComment()

setReturnComment

public void setReturnComment(java.lang.String returnComment)

getReturnDate

public java.util.Date getReturnDate()

setReturnDate

public void setReturnDate(java.util.Date returnDate)

getReturnDepartment

public java.lang.String getReturnDepartment()

setReturnDepartment

public void setReturnDepartment(java.lang.String returnDepartment)

getReturnSign

public java.lang.String getReturnSign()

setReturnSign

public void setReturnSign(java.lang.String returnSign)

getUser

public java.lang.String getUser()

setUser

public void setUser(java.lang.String user)

getPk

public CustomAssetRecordPK getPk()

setPk

public void setPk(CustomAssetRecordPK pk)

getCustomReceiveDepartment

public CustomDepartmentVO getCustomReceiveDepartment()

setCustomReceiveDepartment

public void setCustomReceiveDepartment(CustomDepartmentVO customReceiveDepartment)

getCustomReturnDepartment

public CustomDepartmentVO getCustomReturnDepartment()

setCustomReturnDepartment

public void setCustomReturnDepartment(CustomDepartmentVO customReturnDepartment)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomAssetVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomAssetVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CustomAssetVO
All Implemented Interfaces:
java.io.Serializable
public class CustomAssetVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ASSETNAME
static java.lang.String | ORDER_BY_ASSETNUMBER
static java.lang.String | ORDER_BY_ASSETORDER
static java.lang.String | ORDER_BY_BUYDATE
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_DEPARTMENT
static java.lang.String | ORDER_BY_MANUFACTURE
static java.lang.String | ORDER_BY_MANUFACTUREID
static java.lang.String | ORDER_BY_MFGDATE
static java.lang.String | ORDER_BY_MODELNUMBER
static java.lang.String | ORDER_BY_ORIGINALCOST
static java.lang.String | ORDER_BY_PRINCIPAL
static java.lang.String | ORDER_BY_RECEIVESIGN
static java.lang.String | ORDER_BY_SERIALNUMBER
static java.lang.String | ORDER_BY_USINGDATE
Constructor Summary
CustomAssetVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAssetDate()
java.lang.String | getAssetName()
java.lang.String | getAssetNumber()
java.lang.String | getAssetOrder()
java.util.Set | getAssetRecords()
java.lang.String | getAssetStatus()
java.util.Date | getBuyDate()
java.lang.String | getCertificateStatus()
java.lang.String | getComments()
java.lang.String | getDepartment()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getManufacture()
java.lang.String | getManufactureId()
java.util.Date | getMfgDate()
java.lang.String | getModelNumber()
java.math.BigDecimal | getOriginalCost()
java.lang.String | getPrincipal()
java.lang.String | getProject()
java.lang.String | getReceiveSign()
java.lang.String | getSerialNumber()
java.util.Date | getTnDate()
java.util.Date | getUsingDate()
java.lang.String | getUsingUnit()
int | hashCode()
void | setAssetDate(java.util.Date assetDate)
void | setAssetName(java.lang.String assetName)
void | setAssetNumber(java.lang.String assetNumber)
void | setAssetOrder(java.lang.String assetOrder)
void | setAssetRecords(java.util.Set assetRecords)
void | setAssetStatus(java.lang.String assetStatus)
void | setBuyDate(java.util.Date buyDate)
void | setCertificateStatus(java.lang.String certificateStatus)
void | setComments(java.lang.String comments)
void | setDepartment(java.lang.String department)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setManufacture(java.lang.String manufacture)
void | setManufactureId(java.lang.String manufactureId)
void | setMfgDate(java.util.Date mfgDate)
void | setModelNumber(java.lang.String modelNumber)
void | setOriginalCost(java.math.BigDecimal originalCost)
void | setPrincipal(java.lang.String principal)
void | setProject(java.lang.String project)
void | setReceiveSign(java.lang.String receiveSign)
void | setSerialNumber(java.lang.String serialNumber)
void | setTnDate(java.util.Date tnDate)
void | setUsingDate(java.util.Date usingDate)
void | setUsingUnit(java.lang.String usingUnit)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ASSETNUMBER

public static final java.lang.String ORDER_BY_ASSETNUMBER
See Also:
Constant Field Values

ORDER_BY_ASSETNAME

public static final java.lang.String ORDER_BY_ASSETNAME
See Also:
Constant Field Values

ORDER_BY_MANUFACTURE

public static final java.lang.String ORDER_BY_MANUFACTURE
See Also:
Constant Field Values

ORDER_BY_MODELNUMBER

public static final java.lang.String ORDER_BY_MODELNUMBER
See Also:
Constant Field Values

ORDER_BY_SERIALNUMBER

public static final java.lang.String ORDER_BY_SERIALNUMBER
See Also:
Constant Field Values

ORDER_BY_MANUFACTUREID

public static final java.lang.String ORDER_BY_MANUFACTUREID
See Also:
Constant Field Values

ORDER_BY_ORIGINALCOST

public static final java.lang.String ORDER_BY_ORIGINALCOST
See Also:
Constant Field Values

ORDER_BY_ASSETORDER

public static final java.lang.String ORDER_BY_ASSETORDER
See Also:
Constant Field Values

ORDER_BY_MFGDATE

public static final java.lang.String ORDER_BY_MFGDATE
See Also:
Constant Field Values

ORDER_BY_BUYDATE

public static final java.lang.String ORDER_BY_BUYDATE
See Also:
Constant Field Values

ORDER_BY_USINGDATE

public static final java.lang.String ORDER_BY_USINGDATE
See Also:
Constant Field Values

ORDER_BY_PRINCIPAL

public static final java.lang.String ORDER_BY_PRINCIPAL
See Also:
Constant Field Values

ORDER_BY_DEPARTMENT

public static final java.lang.String ORDER_BY_DEPARTMENT
See Also:
Constant Field Values

ORDER_BY_RECEIVESIGN

public static final java.lang.String ORDER_BY_RECEIVESIGN
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values
Constructor Detail

CustomAssetVO

public CustomAssetVO()
default constructor

Method Detail

getAssetNumber

public java.lang.String getAssetNumber()

setAssetNumber

public void setAssetNumber(java.lang.String assetNumber)

getAssetName

public java.lang.String getAssetName()

setAssetName

public void setAssetName(java.lang.String assetName)

getSerialNumber

public java.lang.String getSerialNumber()

setSerialNumber

public void setSerialNumber(java.lang.String serialNumber)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

getManufacture

public java.lang.String getManufacture()

setManufacture

public void setManufacture(java.lang.String manufacture)

getAssetOrder

public java.lang.String getAssetOrder()

setAssetOrder

public void setAssetOrder(java.lang.String assetOrder)

getManufactureId

public java.lang.String getManufactureId()

setManufactureId

public void setManufactureId(java.lang.String manufactureId)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getAssetDate

public java.util.Date getAssetDate()

setAssetDate

public void setAssetDate(java.util.Date assetDate)

getMfgDate

public java.util.Date getMfgDate()

setMfgDate

public void setMfgDate(java.util.Date mfgDate)

getTnDate

public java.util.Date getTnDate()

setTnDate

public void setTnDate(java.util.Date tnDate)

getBuyDate

public java.util.Date getBuyDate()

setBuyDate

public void setBuyDate(java.util.Date buyDate)

getPrincipal

public java.lang.String getPrincipal()

setPrincipal

public void setPrincipal(java.lang.String principal)

getDepartment

public java.lang.String getDepartment()

setDepartment

public void setDepartment(java.lang.String department)

getAssetStatus

public java.lang.String getAssetStatus()

setAssetStatus

public void setAssetStatus(java.lang.String assetStatus)

getCertificateStatus

public java.lang.String getCertificateStatus()

setCertificateStatus

public void setCertificateStatus(java.lang.String certificateStatus)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getOriginalCost

public java.math.BigDecimal getOriginalCost()

setOriginalCost

public void setOriginalCost(java.math.BigDecimal originalCost)

getUsingDate

public java.util.Date getUsingDate()

setUsingDate

public void setUsingDate(java.util.Date usingDate)

getUsingUnit

public java.lang.String getUsingUnit()

setUsingUnit

public void setUsingUnit(java.lang.String usingUnit)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getAssetRecords

public java.util.Set getAssetRecords()

setAssetRecords

public void setAssetRecords(java.util.Set assetRecords)

getReceiveSign

public java.lang.String getReceiveSign()

setReceiveSign

public void setReceiveSign(java.lang.String receiveSign)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomCheckUpEmployeeVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomCheckUpEmployeeVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CustomCheckUpEmployeeVO
All Implemented Interfaces:
java.io.Serializable
public class CustomCheckUpEmployeeVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AGE
static java.lang.String | ORDER_BY_BLOODPRESSURE
static java.lang.String | ORDER_BY_BULTRASONIC
static java.lang.String | ORDER_BY_CHECKTIME
static java.lang.String | ORDER_BY_CLINICALAB
static java.lang.String | ORDER_BY_COMMENT
static java.lang.String | ORDER_BY_EARNOSETEAR
static java.lang.String | ORDER_BY_ECG
static java.lang.String | ORDER_BY_EMPID
static java.lang.String | ORDER_BY_II
static java.lang.String | ORDER_BY_NAME
static java.lang.String | ORDER_BY_NUDESIGHRIGHT
static java.lang.String | ORDER_BY_NUDESIGHTLEFT
static java.lang.String | ORDER_BY_RECORDER
static java.lang.String | ORDER_BY_RECTIFYSIGHTLEFT
static java.lang.String | ORDER_BY_RECTIFYSIGHTRIGHT
static java.lang.String | ORDER_BY_RIS
static java.lang.String | ORDER_BY_STATURE
Constructor Summary
CustomCheckUpEmployeeVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Integer | getAge()
java.lang.String | getBloodPressure()
java.lang.String | getbUltrasonic()
java.lang.String | getBUltrasonic()
java.util.Date | getCheckTime()
java.lang.String | getClinicaLab()
java.lang.String | getComment()
java.lang.String | getEarNoseTear()
java.lang.String | getEcg()
java.lang.String | getEmpId()
java.lang.Long | getIi()
java.lang.String | getName()
java.math.BigDecimal | getNudeSighRight()
java.math.BigDecimal | getNudeSightLeft()
java.lang.String | getRecorder()
java.math.BigDecimal | getRectifySightLeft()
java.math.BigDecimal | getRectifySightRight()
java.lang.String | getRis()
java.lang.Integer | getStature()
int | hashCode()
void | setAge(int age)
void | setAge(java.lang.Integer age)
void | setBloodPressure(java.lang.String bloodPressure)
void | setbUltrasonic(java.lang.String bUltrasonic)
void | setBUltrasonic(java.lang.String ultrasonic)
void | setCheckTime(java.util.Date checkTime)
void | setClinicaLab(java.lang.String clinicaLab)
void | setComment(java.lang.String comment)
void | setEarNoseTear(java.lang.String earNoseTear)
void | setEcg(java.lang.String ecg)
void | setEmpId(java.lang.String empId)
void | setIi(java.lang.Long ii)
void | setName(java.lang.String name)
void | setNudeSighRight(java.math.BigDecimal nudeSighRight)
void | setNudeSightLeft(java.math.BigDecimal nudeSightLeft)
void | setRecorder(java.lang.String recorder)
void | setRectifySightLeft(java.math.BigDecimal rectifySightLeft)
void | setRectifySightRight(java.math.BigDecimal rectifySightRight)
void | setRis(java.lang.String ris)
void | setStature(int stature)
void | setStature(java.lang.Integer stature)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_II

public static final java.lang.String ORDER_BY_II
See Also:
Constant Field Values

ORDER_BY_EMPID

public static final java.lang.String ORDER_BY_EMPID
See Also:
Constant Field Values

ORDER_BY_NAME

public static final java.lang.String ORDER_BY_NAME
See Also:
Constant Field Values

ORDER_BY_CHECKTIME

public static final java.lang.String ORDER_BY_CHECKTIME
See Also:
Constant Field Values

ORDER_BY_AGE

public static final java.lang.String ORDER_BY_AGE
See Also:
Constant Field Values

ORDER_BY_STATURE

public static final java.lang.String ORDER_BY_STATURE
See Also:
Constant Field Values

ORDER_BY_BLOODPRESSURE

public static final java.lang.String ORDER_BY_BLOODPRESSURE
See Also:
Constant Field Values

ORDER_BY_NUDESIGHTLEFT

public static final java.lang.String ORDER_BY_NUDESIGHTLEFT
See Also:
Constant Field Values

ORDER_BY_RECTIFYSIGHTLEFT

public static final java.lang.String ORDER_BY_RECTIFYSIGHTLEFT
See Also:
Constant Field Values

ORDER_BY_NUDESIGHRIGHT

public static final java.lang.String ORDER_BY_NUDESIGHRIGHT
See Also:
Constant Field Values

ORDER_BY_RECTIFYSIGHTRIGHT

public static final java.lang.String ORDER_BY_RECTIFYSIGHTRIGHT
See Also:
Constant Field Values

ORDER_BY_EARNOSETEAR

public static final java.lang.String ORDER_BY_EARNOSETEAR
See Also:
Constant Field Values

ORDER_BY_ECG

public static final java.lang.String ORDER_BY_ECG
See Also:
Constant Field Values

ORDER_BY_BULTRASONIC

public static final java.lang.String ORDER_BY_BULTRASONIC
See Also:
Constant Field Values

ORDER_BY_RIS

public static final java.lang.String ORDER_BY_RIS
See Also:
Constant Field Values

ORDER_BY_CLINICALAB

public static final java.lang.String ORDER_BY_CLINICALAB
See Also:
Constant Field Values

ORDER_BY_COMMENT

public static final java.lang.String ORDER_BY_COMMENT
See Also:
Constant Field Values

ORDER_BY_RECORDER

public static final java.lang.String ORDER_BY_RECORDER
See Also:
Constant Field Values
Constructor Detail

CustomCheckUpEmployeeVO

public CustomCheckUpEmployeeVO()
default constructor

Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getCheckTime

public java.util.Date getCheckTime()

setCheckTime

public void setCheckTime(java.util.Date checkTime)

getAge

public java.lang.Integer getAge()

setAge

public void setAge(java.lang.Integer age)

getStature

public java.lang.Integer getStature()

setStature

public void setStature(java.lang.Integer stature)

getEarNoseTear

public java.lang.String getEarNoseTear()

setEarNoseTear

public void setEarNoseTear(java.lang.String earNoseTear)

getEcg

public java.lang.String getEcg()

setEcg

public void setEcg(java.lang.String ecg)

getbUltrasonic

public java.lang.String getbUltrasonic()

setbUltrasonic

public void setbUltrasonic(java.lang.String bUltrasonic)

getRis

public java.lang.String getRis()

setRis

public void setRis(java.lang.String ris)

getClinicaLab

public java.lang.String getClinicaLab()

setClinicaLab

public void setClinicaLab(java.lang.String clinicaLab)

getComment

public java.lang.String getComment()

setComment

public void setComment(java.lang.String comment)

getRecorder

public java.lang.String getRecorder()

setRecorder

public void setRecorder(java.lang.String recorder)

getBUltrasonic

public java.lang.String getBUltrasonic()

setBUltrasonic

public void setBUltrasonic(java.lang.String ultrasonic)

getNudeSighRight

public java.math.BigDecimal getNudeSighRight()

setNudeSighRight

public void setNudeSighRight(java.math.BigDecimal nudeSighRight)

getNudeSightLeft

public java.math.BigDecimal getNudeSightLeft()

setNudeSightLeft

public void setNudeSightLeft(java.math.BigDecimal nudeSightLeft)

getRectifySightLeft

public java.math.BigDecimal getRectifySightLeft()

setRectifySightLeft

public void setRectifySightLeft(java.math.BigDecimal rectifySightLeft)

getRectifySightRight

public java.math.BigDecimal getRectifySightRight()

setRectifySightRight

public void setRectifySightRight(java.math.BigDecimal rectifySightRight)

setAge

public void setAge(int age)

setStature

public void setStature(int stature)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getBloodPressure

public java.lang.String getBloodPressure()

setBloodPressure

public void setBloodPressure(java.lang.String bloodPressure)

getEmpId

public java.lang.String getEmpId()

setEmpId

public void setEmpId(java.lang.String empId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomDepartmentVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomDepartmentVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CustomDepartmentVO
All Implemented Interfaces:
java.io.Serializable
public class CustomDepartmentVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_ID
static java.lang.String | ORDER_BY_NAME
Constructor Summary
CustomDepartmentVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDescription()
java.lang.String | getId()
java.lang.String | getName()
int | hashCode()
void | setDescription(java.lang.String description)
void | setId(java.lang.String id)
void | setName(java.lang.String name)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ID

public static final java.lang.String ORDER_BY_ID
See Also:
Constant Field Values

ORDER_BY_NAME

public static final java.lang.String ORDER_BY_NAME
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

CustomDepartmentVO

public CustomDepartmentVO()
Method Detail

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomEmployeeTrainPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomEmployeeTrainPK

java.lang.Object
    extended by  bb.common.CustomEmployeeTrainPK
All Implemented Interfaces:
java.io.Serializable
public class CustomEmployeeTrainPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CustomEmployeeTrainPK()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getId()
java.lang.Short | getIi()
int | hashCode()
void | setId(java.lang.String id)
void | setIi(java.lang.Short ii)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CustomEmployeeTrainPK

public CustomEmployeeTrainPK()
Method Detail

getIi

public java.lang.Short getIi()

setIi

public void setIi(java.lang.Short ii)

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomEmployeeTrainVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomEmployeeTrainVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CustomEmployeeTrainVO
All Implemented Interfaces:
java.io.Serializable
public class CustomEmployeeTrainVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CERTIFICATENAME
static java.lang.String | ORDER_BY_CERTIFICATIONID
static java.lang.String | ORDER_BY_EXPIREDATE
static java.lang.String | ORDER_BY_PK
static java.lang.String | ORDER_BY_PLACE
static java.lang.String | ORDER_BY_RECORDER
static java.lang.String | ORDER_BY_RESULT
static java.lang.String | ORDER_BY_SPEAKER
static java.lang.String | ORDER_BY_TITLE
static java.lang.String | ORDER_BY_TRAINDATE
Constructor Summary
CustomEmployeeTrainVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCertificateName()
java.lang.String | getCertificationId()
java.util.Date | getExpireDate()
CustomEmployeeTrainPK | getPk()
java.lang.String | getPlace()
java.lang.String | getRecorder()
java.lang.String | getResult()
java.lang.String | getSpeaker()
java.lang.String | getTitle()
java.util.Date | getTrainDate()
int | hashCode()
void | setCertificateName(java.lang.String certificateName)
void | setCertificationId(java.lang.String certificationId)
void | setExpireDate(java.util.Date expireDate)
void | setPk(CustomEmployeeTrainPK pk)
void | setPlace(java.lang.String place)
void | setRecorder(java.lang.String recorder)
void | setResult(java.lang.String result)
void | setSpeaker(java.lang.String speaker)
void | setTitle(java.lang.String title)
void | setTrainDate(java.util.Date trainDate)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PK

public static final java.lang.String ORDER_BY_PK
See Also:
Constant Field Values

ORDER_BY_TITLE

public static final java.lang.String ORDER_BY_TITLE
See Also:
Constant Field Values

ORDER_BY_TRAINDATE

public static final java.lang.String ORDER_BY_TRAINDATE
See Also:
Constant Field Values

ORDER_BY_PLACE

public static final java.lang.String ORDER_BY_PLACE
See Also:
Constant Field Values

ORDER_BY_SPEAKER

public static final java.lang.String ORDER_BY_SPEAKER
See Also:
Constant Field Values

ORDER_BY_RESULT

public static final java.lang.String ORDER_BY_RESULT
See Also:
Constant Field Values

ORDER_BY_CERTIFICATENAME

public static final java.lang.String ORDER_BY_CERTIFICATENAME
See Also:
Constant Field Values

ORDER_BY_CERTIFICATIONID

public static final java.lang.String ORDER_BY_CERTIFICATIONID
See Also:
Constant Field Values

ORDER_BY_EXPIREDATE

public static final java.lang.String ORDER_BY_EXPIREDATE
See Also:
Constant Field Values

ORDER_BY_RECORDER

public static final java.lang.String ORDER_BY_RECORDER
See Also:
Constant Field Values
Constructor Detail

CustomEmployeeTrainVO

public CustomEmployeeTrainVO()
default constructor

Method Detail

getTitle

public java.lang.String getTitle()

setTitle

public void setTitle(java.lang.String title)

getTrainDate

public java.util.Date getTrainDate()

setTrainDate

public void setTrainDate(java.util.Date trainDate)

getPlace

public java.lang.String getPlace()

setPlace

public void setPlace(java.lang.String place)

getSpeaker

public java.lang.String getSpeaker()

setSpeaker

public void setSpeaker(java.lang.String speaker)

getResult

public java.lang.String getResult()

setResult

public void setResult(java.lang.String result)

getCertificateName

public java.lang.String getCertificateName()

setCertificateName

public void setCertificateName(java.lang.String certificateName)

getCertificationId

public java.lang.String getCertificationId()

setCertificationId

public void setCertificationId(java.lang.String certificationId)

getExpireDate

public java.util.Date getExpireDate()

setExpireDate

public void setExpireDate(java.util.Date expireDate)

getRecorder

public java.lang.String getRecorder()

setRecorder

public void setRecorder(java.lang.String recorder)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getPk

public CustomEmployeeTrainPK getPk()

setPk

public void setPk(CustomEmployeeTrainPK pk)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomEmployeeVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomEmployeeVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CustomEmployeeVO
All Implemented Interfaces:
java.io.Serializable
public class CustomEmployeeVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_BIRTHDATE
static java.lang.String | ORDER_BY_CARDID
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_CURRENTPOSITION
static java.lang.String | ORDER_BY_CURRENTPOSITIONLEVEL
static java.lang.String | ORDER_BY_DEGREE
static java.lang.String | ORDER_BY_DEPARTMENT
static java.lang.String | ORDER_BY_EDUCATION
static java.lang.String | ORDER_BY_EMPLOYEEAGE
static java.lang.String | ORDER_BY_EMPLOYEEAGELEVEL
static java.lang.String | ORDER_BY_EMPLOYEEWORKAGE
static java.lang.String | ORDER_BY_EMPLOYEEWORKAGELEVEL
static java.lang.String | ORDER_BY_GENDER
static java.lang.String | ORDER_BY_GRADUATEDATE
static java.lang.String | ORDER_BY_GRADUATESCHOOL
static java.lang.String | ORDER_BY_JOBID
static java.lang.String | ORDER_BY_NAME
static java.lang.String | ORDER_BY_NATIVEPLACE
static java.lang.String | ORDER_BY_ORIGINALPOSITION
static java.lang.String | ORDER_BY_POLITYVISAGE
static java.lang.String | ORDER_BY_POSITION
static java.lang.String | ORDER_BY_SOURCE
static java.lang.String | ORDER_BY_SPECIALTITLE
static java.lang.String | ORDER_BY_SPECIALTY
static java.lang.String | ORDER_BY_SPECIALWORK
static java.lang.String | ORDER_BY_TOCOMPANYTIME
static java.lang.String | ORDER_BY_TOPOSITIONTIME
static java.lang.String | ORDER_BY_TRANSFERDATE
static java.lang.String | ORDER_BY_UNIT
static java.lang.String | ORDER_BY_WORKTIME
static java.lang.String | ORDER_BY_WORKTYPE
static java.lang.String | ORDER_BY_WORKTYPEAFTER
Constructor Summary
CustomEmployeeVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
static int | getAge(java.util.Date birthDate)
static int | getAgeLevel(java.util.Date birthDate)
java.util.Date | getBirthDate()
static java.lang.Object[] | getBirthDateRange(int ageLevel)
java.lang.String | getCardId()
java.lang.String | getComments()
static int | getCompanyAge(java.util.Date toCompanyTime)
java.lang.String | getCurrentPosition()
java.lang.String | getCurrentPositionLevel()
CustomDepartmentVO | getCustomDepartment()
java.lang.String | getDegree()
java.lang.String | getDepartment()
java.lang.String | getEducation()
int | getEmployeeAge()
int | getEmployeeAgeLevel()
java.util.Set | getEmployeeTrain()
int | getEmployeeWorkAge()
int | getEmployeeWorkAgeLevel()
java.util.Set | getEmployeeWorkExperience()
java.lang.String | getEnglishAbility()
java.util.Date | getEnterSchool()
java.lang.String | getGender()
java.util.Date | getGraduateDate()
java.lang.String | getGraduateSchool()
java.lang.String | getId()
java.lang.String | getJobId()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getName()
java.lang.String | getNativePlace()
java.lang.String | getOriginalPosition()
java.lang.String | getPolityVisage()
java.lang.String | getPosition()
java.lang.String | getPositionLevel()
java.lang.String | getSource()
java.lang.String | getSpecialTitle()
java.lang.String | getSpecialty()
java.lang.String | getSpecialWork()
java.util.Date | getToCompanyTime()
java.util.Date | getToPositionTime()
java.lang.String | getTrainComments()
java.util.Date | getTransferDate()
java.lang.String | getUnit()
static int | getWorkAge(java.util.Date workTime)
static int | getWorkAgeLevel(java.util.Date workTime)
java.lang.String | getWorkComments()
java.util.Date | getWorkTime()
static java.lang.Object[] | getWorkTimeRange(int workLevel)
java.lang.String | getWorkType()
java.lang.String | getWorkTypeAfter()
int | hashCode()
void | setBirthDate(java.util.Date birthDate)
void | setCardId(java.lang.String cardId)
void | setComments(java.lang.String comments)
void | setCurrentPosition(java.lang.String currentPosition)
void | setCurrentPositionLevel(java.lang.String currentPositionLevel)
void | setCustomDepartment(CustomDepartmentVO customDepartment)
void | setDegree(java.lang.String degree)
void | setDepartment(java.lang.String department)
void | setEducation(java.lang.String education)
void | setEmployeeAge(int employeeAge)
void | setEmployeeAgeLevel(int employeeAgeLevel)
void | setEmployeeTrain(java.util.Set employeeTrain)
void | setEmployeeWorkAge(int employeeWorkAge)
void | setEmployeeWorkAgeLevel(int employeeWorkAgeLevel)
void | setEmployeeWorkExperience(java.util.Set employeeWorkExperience)
void | setEnglishAbility(java.lang.String englishAbility)
void | setEnterSchool(java.util.Date enterSchool)
void | setGender(java.lang.String gender)
void | setGraduateDate(java.util.Date graduateDate)
void | setGraduateSchool(java.lang.String graduateSchool)
void | setId(java.lang.String id)
void | setJobId(java.lang.String jobId)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setName(java.lang.String name)
void | setNativePlace(java.lang.String nativePlace)
void | setOriginalPosition(java.lang.String originalPosition)
void | setPolityVisage(java.lang.String polityVisage)
void | setPosition(java.lang.String position)
void | setPositionLevel(java.lang.String positionLevel)
void | setSource(java.lang.String source)
void | setSpecialTitle(java.lang.String specialTitle)
void | setSpecialty(java.lang.String specialty)
void | setSpecialWork(java.lang.String specialWork)
void | setToCompanyTime(java.util.Date toCompanyTime)
void | setToPositionTime(java.util.Date toPositionTime)
void | setTrainComments(java.lang.String trainComments)
void | setTransferDate(java.util.Date transferDate)
void | setUnit(java.lang.String unit)
void | setWorkComments(java.lang.String workComments)
void | setWorkTime(java.util.Date workTime)
void | setWorkType(java.lang.String workType)
void | setWorkTypeAfter(java.lang.String workTypeAfter)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_UNIT

public static final java.lang.String ORDER_BY_UNIT
See Also:
Constant Field Values

ORDER_BY_DEPARTMENT

public static final java.lang.String ORDER_BY_DEPARTMENT
See Also:
Constant Field Values

ORDER_BY_NAME

public static final java.lang.String ORDER_BY_NAME
See Also:
Constant Field Values

ORDER_BY_GENDER

public static final java.lang.String ORDER_BY_GENDER
See Also:
Constant Field Values

ORDER_BY_CARDID

public static final java.lang.String ORDER_BY_CARDID
See Also:
Constant Field Values

ORDER_BY_BIRTHDATE

public static final java.lang.String ORDER_BY_BIRTHDATE
See Also:
Constant Field Values

ORDER_BY_NATIVEPLACE

public static final java.lang.String ORDER_BY_NATIVEPLACE
See Also:
Constant Field Values

ORDER_BY_POLITYVISAGE

public static final java.lang.String ORDER_BY_POLITYVISAGE
See Also:
Constant Field Values

ORDER_BY_EDUCATION

public static final java.lang.String ORDER_BY_EDUCATION
See Also:
Constant Field Values

ORDER_BY_DEGREE

public static final java.lang.String ORDER_BY_DEGREE
See Also:
Constant Field Values

ORDER_BY_SPECIALTY

public static final java.lang.String ORDER_BY_SPECIALTY
See Also:
Constant Field Values

ORDER_BY_GRADUATESCHOOL

public static final java.lang.String ORDER_BY_GRADUATESCHOOL
See Also:
Constant Field Values

ORDER_BY_GRADUATEDATE

public static final java.lang.String ORDER_BY_GRADUATEDATE
See Also:
Constant Field Values

ORDER_BY_SPECIALTITLE

public static final java.lang.String ORDER_BY_SPECIALTITLE
See Also:
Constant Field Values

ORDER_BY_SPECIALWORK

public static final java.lang.String ORDER_BY_SPECIALWORK
See Also:
Constant Field Values

ORDER_BY_WORKTYPE

public static final java.lang.String ORDER_BY_WORKTYPE
See Also:
Constant Field Values

ORDER_BY_WORKTYPEAFTER

public static final java.lang.String ORDER_BY_WORKTYPEAFTER
See Also:
Constant Field Values

ORDER_BY_JOBID

public static final java.lang.String ORDER_BY_JOBID
See Also:
Constant Field Values

ORDER_BY_WORKTIME

public static final java.lang.String ORDER_BY_WORKTIME
See Also:
Constant Field Values

ORDER_BY_TOCOMPANYTIME

public static final java.lang.String ORDER_BY_TOCOMPANYTIME
See Also:
Constant Field Values

ORDER_BY_TOPOSITIONTIME

public static final java.lang.String ORDER_BY_TOPOSITIONTIME
See Also:
Constant Field Values

ORDER_BY_ORIGINALPOSITION

public static final java.lang.String ORDER_BY_ORIGINALPOSITION
See Also:
Constant Field Values

ORDER_BY_POSITION

public static final java.lang.String ORDER_BY_POSITION
See Also:
Constant Field Values

ORDER_BY_CURRENTPOSITION

public static final java.lang.String ORDER_BY_CURRENTPOSITION
See Also:
Constant Field Values

ORDER_BY_CURRENTPOSITIONLEVEL

public static final java.lang.String ORDER_BY_CURRENTPOSITIONLEVEL
See Also:
Constant Field Values

ORDER_BY_SOURCE

public static final java.lang.String ORDER_BY_SOURCE
See Also:
Constant Field Values

ORDER_BY_TRANSFERDATE

public static final java.lang.String ORDER_BY_TRANSFERDATE
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values

ORDER_BY_EMPLOYEEAGE

public static final java.lang.String ORDER_BY_EMPLOYEEAGE
See Also:
Constant Field Values

ORDER_BY_EMPLOYEEAGELEVEL

public static final java.lang.String ORDER_BY_EMPLOYEEAGELEVEL
See Also:
Constant Field Values

ORDER_BY_EMPLOYEEWORKAGE

public static final java.lang.String ORDER_BY_EMPLOYEEWORKAGE
See Also:
Constant Field Values

ORDER_BY_EMPLOYEEWORKAGELEVEL

public static final java.lang.String ORDER_BY_EMPLOYEEWORKAGELEVEL
See Also:
Constant Field Values
Constructor Detail

CustomEmployeeVO

public CustomEmployeeVO()
default constructor

Method Detail

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getDepartment

public java.lang.String getDepartment()

setDepartment

public void setDepartment(java.lang.String department)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getCardId

public java.lang.String getCardId()

setCardId

public void setCardId(java.lang.String cardId)

getBirthDate

public java.util.Date getBirthDate()

setBirthDate

public void setBirthDate(java.util.Date birthDate)

getNativePlace

public java.lang.String getNativePlace()

setNativePlace

public void setNativePlace(java.lang.String nativePlace)

getPolityVisage

public java.lang.String getPolityVisage()

setPolityVisage

public void setPolityVisage(java.lang.String polityVisage)

getEducation

public java.lang.String getEducation()

setEducation

public void setEducation(java.lang.String education)

getDegree

public java.lang.String getDegree()

setDegree

public void setDegree(java.lang.String degree)

getSpecialty

public java.lang.String getSpecialty()

setSpecialty

public void setSpecialty(java.lang.String specialty)

getGraduateSchool

public java.lang.String getGraduateSchool()

setGraduateSchool

public void setGraduateSchool(java.lang.String graduateSchool)

getGraduateDate

public java.util.Date getGraduateDate()

setGraduateDate

public void setGraduateDate(java.util.Date graduateDate)

getEnterSchool

public java.util.Date getEnterSchool()

setEnterSchool

public void setEnterSchool(java.util.Date enterSchool)

getEnglishAbility

public java.lang.String getEnglishAbility()

setEnglishAbility

public void setEnglishAbility(java.lang.String englishAbility)

getSpecialTitle

public java.lang.String getSpecialTitle()

setSpecialTitle

public void setSpecialTitle(java.lang.String specialTitle)

getSpecialWork

public java.lang.String getSpecialWork()

setSpecialWork

public void setSpecialWork(java.lang.String specialWork)

getWorkType

public java.lang.String getWorkType()

setWorkType

public void setWorkType(java.lang.String workType)

getWorkTypeAfter

public java.lang.String getWorkTypeAfter()

setWorkTypeAfter

public void setWorkTypeAfter(java.lang.String workTypeAfter)

getWorkTime

public java.util.Date getWorkTime()

setWorkTime

public void setWorkTime(java.util.Date workTime)

getToCompanyTime

public java.util.Date getToCompanyTime()

setToCompanyTime

public void setToCompanyTime(java.util.Date toCompanyTime)

getToPositionTime

public java.util.Date getToPositionTime()

setToPositionTime

public void setToPositionTime(java.util.Date toPositionTime)

getOriginalPosition

public java.lang.String getOriginalPosition()

setOriginalPosition

public void setOriginalPosition(java.lang.String originalPosition)

getPosition

public java.lang.String getPosition()

setPosition

public void setPosition(java.lang.String position)

getCurrentPosition

public java.lang.String getCurrentPosition()

setCurrentPosition

public void setCurrentPosition(java.lang.String currentPosition)

getPositionLevel

public java.lang.String getPositionLevel()

setPositionLevel

public void setPositionLevel(java.lang.String positionLevel)

getCurrentPositionLevel

public java.lang.String getCurrentPositionLevel()

setCurrentPositionLevel

public void setCurrentPositionLevel(java.lang.String currentPositionLevel)

getSource

public java.lang.String getSource()

setSource

public void setSource(java.lang.String source)

getTransferDate

public java.util.Date getTransferDate()

setTransferDate

public void setTransferDate(java.util.Date transferDate)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getWorkComments

public java.lang.String getWorkComments()

setWorkComments

public void setWorkComments(java.lang.String workComments)

getTrainComments

public java.lang.String getTrainComments()

setTrainComments

public void setTrainComments(java.lang.String trainComments)

getEmployeeTrain

public java.util.Set getEmployeeTrain()

setEmployeeTrain

public void setEmployeeTrain(java.util.Set employeeTrain)

getEmployeeWorkExperience

public java.util.Set getEmployeeWorkExperience()

setEmployeeWorkExperience

public void setEmployeeWorkExperience(java.util.Set employeeWorkExperience)

getGender

public java.lang.String getGender()

setGender

public void setGender(java.lang.String gender)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getAge

public static int getAge(java.util.Date birthDate)

getAgeLevel

public static int getAgeLevel(java.util.Date birthDate)

getWorkAge

public static int getWorkAge(java.util.Date workTime)

getWorkAgeLevel

public static int getWorkAgeLevel(java.util.Date workTime)

getCompanyAge

public static int getCompanyAge(java.util.Date toCompanyTime)

getBirthDateRange

public static java.lang.Object[] getBirthDateRange(int ageLevel)

getWorkTimeRange

public static java.lang.Object[] getWorkTimeRange(int workLevel)

getEmployeeAge

public int getEmployeeAge()

setEmployeeAge

public void setEmployeeAge(int employeeAge)

getEmployeeAgeLevel

public int getEmployeeAgeLevel()

setEmployeeAgeLevel

public void setEmployeeAgeLevel(int employeeAgeLevel)

getEmployeeWorkAge

public int getEmployeeWorkAge()

setEmployeeWorkAge

public void setEmployeeWorkAge(int employeeWorkAge)

getEmployeeWorkAgeLevel

public int getEmployeeWorkAgeLevel()

setEmployeeWorkAgeLevel

public void setEmployeeWorkAgeLevel(int employeeWorkAgeLevel)

getCustomDepartment

public CustomDepartmentVO getCustomDepartment()

setCustomDepartment

public void setCustomDepartment(CustomDepartmentVO customDepartment)

getJobId

public java.lang.String getJobId()

setJobId

public void setJobId(java.lang.String jobId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomEmployeeWorkExperienceVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomEmployeeWorkExperienceVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CustomEmployeeWorkExperienceVO
All Implemented Interfaces:
java.io.Serializable
public class CustomEmployeeWorkExperienceVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CustomEmployeeWorkExperienceVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAuthenticator()
java.lang.String | getCompanyName()
java.util.Date | getFromDate()
java.lang.String | getJobTitle()
CustomEmployeeTrainPK | getPk()
int | hashCode()
void | setAuthenticator(java.lang.String authenticator)
void | setCompanyName(java.lang.String companyName)
void | setFromDate(java.util.Date fromDate)
void | setJobTitle(java.lang.String jobTitle)
void | setPk(CustomEmployeeTrainPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CustomEmployeeWorkExperienceVO

public CustomEmployeeWorkExperienceVO()
default constructor

Method Detail

getFromDate

public java.util.Date getFromDate()

setFromDate

public void setFromDate(java.util.Date fromDate)

getJobTitle

public java.lang.String getJobTitle()

setJobTitle

public void setJobTitle(java.lang.String jobTitle)

getCompanyName

public java.lang.String getCompanyName()

setCompanyName

public void setCompanyName(java.lang.String companyName)

getAuthenticator

public java.lang.String getAuthenticator()

setAuthenticator

public void setAuthenticator(java.lang.String authenticator)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getPk

public CustomEmployeeTrainPK getPk()

setPk

public void setPk(CustomEmployeeTrainPK pk)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomerCLimitResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomerCLimitResult

java.lang.Object
    extended by  bb.common.CustomerCLimitResult
All Implemented Interfaces:
java.io.Serializable
public class CustomerCLimitResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CustomerCLimitResult()
Method Summary
boolean | isCclimit()
boolean | isCHold()
void | setCclimit(boolean cclimit)
void | setCHold(boolean hold)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CustomerCLimitResult

public CustomerCLimitResult()
Method Detail

isCclimit

public boolean isCclimit()

setCclimit

public void setCclimit(boolean cclimit)

isCHold

public boolean isCHold()

setCHold

public void setCHold(boolean hold)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomerFeedbackVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomerFeedbackVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CustomerFeedbackVO
All Implemented Interfaces:
java.io.Serializable
public class CustomerFeedbackVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CONTACTDATE
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_CUSTOMERSERVICEINCIDENTNUMBER
static java.lang.String | ORDER_BY_EMAIL
static java.lang.String | ORDER_BY_FEEDBACKNUMBER
static java.lang.String | ORDER_BY_INVOICEDATE
static java.lang.String | ORDER_BY_ORIGINALINVOICENUMBER
static java.lang.String | ORDER_BY_ORIGINALSALESORDERNUMBER
static java.lang.String | ORDER_BY_ORIGINALWORKORDERNUMBER
static java.lang.String | ORDER_BY_PURCHASEORDERNUMBER
static java.lang.String | ORDER_BY_REPORTEDBY
static java.lang.String | ORDER_BY_SHIPTOID
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
CustomerFeedbackVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.util.Date | getContactDate()
CustomerVendorAddressInfoVO | getCustomerAddressInfo()
java.lang.String | getCustomerId()
java.lang.String | getCustomerServiceIncidentNumber()
java.lang.String | getEmail()
java.util.Set | getFeedbackItems()
java.lang.String | getFeedbackNumber()
java.util.Date | getInvoiceDate()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getOriginalInvoiceNumber()
java.lang.String | getOriginalSalesOrderNumber()
java.lang.String | getOriginalWorkOrderNumber()
java.lang.String | getPartDescription()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getPurchaseOrderNumber()
java.lang.String | getReportedBy()
java.lang.String | getShipToId()
java.lang.String | getStatus()
java.lang.Integer | getVersion()
int | hashCode()
void | setComments(java.lang.String comments)
void | setContactDate(java.util.Date contactDate)
void | setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | setCustomerId(java.lang.String customerId)
void | setCustomerServiceIncidentNumber(java.lang.String customerServiceIncidentNumber)
void | setEmail(java.lang.String email)
void | setFeedbackItems(java.util.Set feedbackItems)
void | setFeedbackNumber(java.lang.String feedBackNumber)
void | setInvoiceDate(java.util.Date invoiceDate)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setOriginalInvoiceNumber(java.lang.String originalInvoiceNumber)
void | setOriginalSalesOrderNumber(java.lang.String originalSalesOrderNumber)
void | setOriginalWorkOrderNumber(java.lang.String originalWorkOrderNumber)
void | setPartDescription(java.lang.String partDescription)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)
void | setReportedBy(java.lang.String reportedBy)
void | setShipToId(java.lang.String shipToId)
void | setStatus(java.lang.String status)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_FEEDBACKNUMBER

public static final java.lang.String ORDER_BY_FEEDBACKNUMBER
See Also:
Constant Field Values

ORDER_BY_CUSTOMERSERVICEINCIDENTNUMBER

public static final java.lang.String ORDER_BY_CUSTOMERSERVICEINCIDENTNUMBER
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_SHIPTOID

public static final java.lang.String ORDER_BY_SHIPTOID
See Also:
Constant Field Values

ORDER_BY_EMAIL

public static final java.lang.String ORDER_BY_EMAIL
See Also:
Constant Field Values

ORDER_BY_ORIGINALINVOICENUMBER

public static final java.lang.String ORDER_BY_ORIGINALINVOICENUMBER
See Also:
Constant Field Values

ORDER_BY_ORIGINALWORKORDERNUMBER

public static final java.lang.String ORDER_BY_ORIGINALWORKORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_PURCHASEORDERNUMBER

public static final java.lang.String ORDER_BY_PURCHASEORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_REPORTEDBY

public static final java.lang.String ORDER_BY_REPORTEDBY
See Also:
Constant Field Values

ORDER_BY_INVOICEDATE

public static final java.lang.String ORDER_BY_INVOICEDATE
See Also:
Constant Field Values

ORDER_BY_CONTACTDATE

public static final java.lang.String ORDER_BY_CONTACTDATE
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_ORIGINALSALESORDERNUMBER

public static final java.lang.String ORDER_BY_ORIGINALSALESORDERNUMBER
See Also:
Constant Field Values
Constructor Detail

CustomerFeedbackVO

public CustomerFeedbackVO()
default constructor

Method Detail

getFeedbackNumber

public java.lang.String getFeedbackNumber()

setFeedbackNumber

public void setFeedbackNumber(java.lang.String feedBackNumber)

getCustomerServiceIncidentNumber

public java.lang.String getCustomerServiceIncidentNumber()

setCustomerServiceIncidentNumber

public void setCustomerServiceIncidentNumber(java.lang.String customerServiceIncidentNumber)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getShipToId

public java.lang.String getShipToId()

setShipToId

public void setShipToId(java.lang.String shipToId)

getEmail

public java.lang.String getEmail()

setEmail

public void setEmail(java.lang.String email)

getOriginalInvoiceNumber

public java.lang.String getOriginalInvoiceNumber()

setOriginalInvoiceNumber

public void setOriginalInvoiceNumber(java.lang.String originalInvoiceNumber)

getOriginalSalesOrderNumber

public java.lang.String getOriginalSalesOrderNumber()

setOriginalSalesOrderNumber

public void setOriginalSalesOrderNumber(java.lang.String originalSalesOrderNumber)

getOriginalWorkOrderNumber

public java.lang.String getOriginalWorkOrderNumber()

setOriginalWorkOrderNumber

public void setOriginalWorkOrderNumber(java.lang.String originalWorkOrderNumber)

getPurchaseOrderNumber

public java.lang.String getPurchaseOrderNumber()

setPurchaseOrderNumber

public void setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)

getReportedBy

public java.lang.String getReportedBy()

setReportedBy

public void setReportedBy(java.lang.String reportedBy)

getInvoiceDate

public java.util.Date getInvoiceDate()

setInvoiceDate

public void setInvoiceDate(java.util.Date invoiceDate)

getContactDate

public java.util.Date getContactDate()

setContactDate

public void setContactDate(java.util.Date contactDate)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getVersion

public java.lang.Integer getVersion()

getFeedbackItems

public java.util.Set getFeedbackItems()

getCustomerAddressInfo

public CustomerVendorAddressInfoVO getCustomerAddressInfo()

setVersion

public void setVersion(java.lang.Integer version)

setFeedbackItems

public void setFeedbackItems(java.util.Set feedbackItems)

setCustomerAddressInfo

public void setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartDescription

public java.lang.String getPartDescription()

setPartDescription

public void setPartDescription(java.lang.String partDescription)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomerPrepayStatementListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomerPrepayStatementListResult

java.lang.Object
    extended by  bb.common.CustomerPrepayStatementListResult
All Implemented Interfaces:
java.io.Serializable
public class CustomerPrepayStatementListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CustomerPrepayStatementListResult()
Method Summary
java.math.BigDecimal | getAmountPaid()
java.math.BigDecimal | getBalanceDue()
java.lang.String | getCustomerPO()
java.util.Date | getDateRequired()
ArPrepayItemPK | getPk()
java.lang.String | getSalesOrder()
java.math.BigDecimal | getTotalDue()
void | setAmountPaid(java.math.BigDecimal amountPaid)
void | setBalanceDue(java.math.BigDecimal balanceDue)
void | setCustomerPO(java.lang.String customerPO)
void | setDateRequired(java.util.Date dateRequired)
void | setPk(ArPrepayItemPK pk)
void | setSalesOrder(java.lang.String salesOrder)
void | setTotalDue(java.math.BigDecimal totalDue)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CustomerPrepayStatementListResult

public CustomerPrepayStatementListResult()
Method Detail

getAmountPaid

public java.math.BigDecimal getAmountPaid()

setAmountPaid

public void setAmountPaid(java.math.BigDecimal amountPaid)

getBalanceDue

public java.math.BigDecimal getBalanceDue()

setBalanceDue

public void setBalanceDue(java.math.BigDecimal balanceDue)

getDateRequired

public java.util.Date getDateRequired()

setDateRequired

public void setDateRequired(java.util.Date dateRequired)

getPk

public ArPrepayItemPK getPk()

setPk

public void setPk(ArPrepayItemPK pk)

getTotalDue

public java.math.BigDecimal getTotalDue()

setTotalDue

public void setTotalDue(java.math.BigDecimal totalDue)

getCustomerPO

public java.lang.String getCustomerPO()

setCustomerPO

public void setCustomerPO(java.lang.String customerPO)

getSalesOrder

public java.lang.String getSalesOrder()

setSalesOrder

public void setSalesOrder(java.lang.String salesOrder)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomerReturnToVendorItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomerReturnToVendorItemPK

java.lang.Object
    extended by  bb.common.CustomerReturnToVendorItemPK
All Implemented Interfaces:
java.io.Serializable
public class CustomerReturnToVendorItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CustomerReturnToVendorItemPK()
CustomerReturnToVendorItemPK(java.lang.String crtvNumber, java.lang.String crtvItemNumber)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCrtvItemNumber()
java.lang.String | getCrtvNumber()
int | hashCode()
void | setCrtvItemNumber(java.lang.String crtvItemNumber)
void | setCrtvNumber(java.lang.String crtvNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CustomerReturnToVendorItemPK

public CustomerReturnToVendorItemPK(java.lang.String crtvNumber,
                                    java.lang.String crtvItemNumber)

CustomerReturnToVendorItemPK

public CustomerReturnToVendorItemPK()
Method Detail

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getCrtvNumber

public java.lang.String getCrtvNumber()

setCrtvNumber

public void setCrtvNumber(java.lang.String crtvNumber)

getCrtvItemNumber

public java.lang.String getCrtvItemNumber()

setCrtvItemNumber

public void setCrtvItemNumber(java.lang.String crtvItemNumber)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomerReturnToVendorItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomerReturnToVendorItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CustomerReturnToVendorItemVO
All Implemented Interfaces:
java.io.Serializable
public class CustomerReturnToVendorItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CustomerReturnToVendorItemVO()
default constructor
CustomerReturnToVendorItemVO(CustomerReturnToVendorItemPK pk, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom)
minimal constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAccepted()
java.lang.String | getAcceptedBy()
java.util.Date | getActual()
java.math.BigDecimal | getApDiscount()
java.math.BigDecimal | getApOpen()
java.math.BigDecimal | getApReceivd()
java.math.BigDecimal | getApSub()
java.math.BigDecimal | getApTax()
java.math.BigDecimal | getApTotal()
java.lang.String | getChangeMfg()
java.lang.String | getChangeOrder()
java.math.BigDecimal | getCostPerUnit()
java.lang.String | getCrtvItemComments()
java.lang.String | getCrtvItemPrivateNotes()
java.math.BigDecimal | getCurrentCost()
java.math.BigDecimal | getCurrentStdCost()
int | getDelay()
java.util.Date | getDelivery()
java.lang.String | getDescription()
java.math.BigDecimal | getDiscount()
java.lang.String | getDwg()
java.math.BigDecimal | getExtendPrice()
java.lang.String | getLocate()
java.lang.String | getMfg()
java.lang.String | getModelNumber()
java.lang.String | getMpn()
java.util.Date | getOriginal()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
CustomerReturnToVendorItemPK | getPk()
java.lang.String | getPriority()
java.lang.String | getQr()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getReceivedQuantity()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.util.Set | getReturnMaterialAuthorizationItemManufacturer()
java.lang.String | getRevision()
java.math.BigDecimal | getSalesCost()
java.math.BigDecimal | getSalesPrice()
java.math.BigDecimal | getSalesQty()
java.math.BigDecimal | getSalesStdCost()
java.lang.String | getSalesUnit()
java.math.BigDecimal | getShip()
java.lang.String | getShipvia()
java.lang.String | getStatus()
java.math.BigDecimal | getTaxRate()
java.lang.String | getUnit()
int | hashCode()
void | setAccepted(java.util.Date accepted)
void | setAcceptedBy(java.lang.String acceptedBy)
void | setActual(java.util.Date actual)
void | setApDiscount(java.math.BigDecimal apDiscount)
void | setApOpen(java.math.BigDecimal apOpen)
void | setApReceivd(java.math.BigDecimal apReceivd)
void | setApSub(java.math.BigDecimal apSub)
void | setApTax(java.math.BigDecimal apTax)
void | setApTotal(java.math.BigDecimal apTotal)
void | setChangeMfg(java.lang.String changeMfg)
void | setChangeOrder(java.lang.String changeOrder)
void | setCostPerUnit(java.math.BigDecimal costPerUnit)
void | setCrtvItemComments(java.lang.String crtvItemComments)
void | setCrtvItemPrivateNotes(java.lang.String crtvItemPrivateNotes)
void | setCurrentCost(java.math.BigDecimal currentCost)
void | setCurrentStdCost(java.math.BigDecimal currentStdCost)
void | setDelay(int delay)
void | setDelivery(java.util.Date delivery)
void | setDescription(java.lang.String description)
void | setDiscount(java.math.BigDecimal discount)
void | setDwg(java.lang.String dwg)
void | setExtendPrice(java.math.BigDecimal extendPrice)
void | setLocate(java.lang.String locate)
void | setMfg(java.lang.String mfg)
void | setModelNumber(java.lang.String modelNumber)
void | setMpn(java.lang.String mpn)
void | setOriginal(java.util.Date original)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(CustomerReturnToVendorItemPK pk)
void | setPriority(java.lang.String priority)
void | setQr(java.lang.String qr)
void | setQuantity(java.math.BigDecimal quantity)
void | setReceivedQuantity(java.math.BigDecimal receivedQuantity)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setReturnMaterialAuthorizationItemManufacturer(java.util.Set returnMaterialAuthorizationItemManufacturer)
void | setRevision(java.lang.String revision)
void | setSalesCost(java.math.BigDecimal salesCost)
void | setSalesPrice(java.math.BigDecimal salesPrice)
void | setSalesQty(java.math.BigDecimal salesQty)
void | setSalesStdCost(java.math.BigDecimal salesStdCost)
void | setSalesUnit(java.lang.String salesUnit)
void | setShip(java.math.BigDecimal ship)
void | setShipvia(java.lang.String shipvia)
void | setStatus(java.lang.String status)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setUnit(java.lang.String unit)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CustomerReturnToVendorItemVO

public CustomerReturnToVendorItemVO()
default constructor

CustomerReturnToVendorItemVO

public CustomerReturnToVendorItemVO(CustomerReturnToVendorItemPK pk,
                                    java.lang.String partNumber,
                                    java.lang.String partType,
                                    java.lang.String partFrom)
minimal constructor

Method Detail

getPk

public CustomerReturnToVendorItemPK getPk()

setPk

public void setPk(CustomerReturnToVendorItemPK pk)

getApSub

public java.math.BigDecimal getApSub()

setApSub

public void setApSub(java.math.BigDecimal apSub)

getApDiscount

public java.math.BigDecimal getApDiscount()

setApDiscount

public void setApDiscount(java.math.BigDecimal apDiscount)

getExtendPrice

public java.math.BigDecimal getExtendPrice()

setExtendPrice

public void setExtendPrice(java.math.BigDecimal extendPrice)

getApReceivd

public java.math.BigDecimal getApReceivd()

setApReceivd

public void setApReceivd(java.math.BigDecimal apReceivd)

getApOpen

public java.math.BigDecimal getApOpen()

setApOpen

public void setApOpen(java.math.BigDecimal apOpen)

getApTax

public java.math.BigDecimal getApTax()

setApTax

public void setApTax(java.math.BigDecimal apTax)

getApTotal

public java.math.BigDecimal getApTotal()

setApTotal

public void setApTotal(java.math.BigDecimal apTotal)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getQr

public java.lang.String getQr()

setQr

public void setQr(java.lang.String qr)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getAccepted

public java.util.Date getAccepted()

setAccepted

public void setAccepted(java.util.Date accepted)

getAcceptedBy

public java.lang.String getAcceptedBy()

setAcceptedBy

public void setAcceptedBy(java.lang.String acceptedBy)

getDelivery

public java.util.Date getDelivery()

setDelivery

public void setDelivery(java.util.Date delivery)

getDelay

public int getDelay()

setDelay

public void setDelay(int delay)

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getOriginal

public java.util.Date getOriginal()

setOriginal

public void setOriginal(java.util.Date original)

getActual

public java.util.Date getActual()

setActual

public void setActual(java.util.Date actual)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getShipvia

public java.lang.String getShipvia()

setShipvia

public void setShipvia(java.lang.String shipvia)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getDwg

public java.lang.String getDwg()

setDwg

public void setDwg(java.lang.String dwg)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getShip

public java.math.BigDecimal getShip()

setShip

public void setShip(java.math.BigDecimal ship)

getReceivedQuantity

public java.math.BigDecimal getReceivedQuantity()

setReceivedQuantity

public void setReceivedQuantity(java.math.BigDecimal receivedQuantity)

getCostPerUnit

public java.math.BigDecimal getCostPerUnit()

setCostPerUnit

public void setCostPerUnit(java.math.BigDecimal costPerUnit)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getChangeMfg

public java.lang.String getChangeMfg()

setChangeMfg

public void setChangeMfg(java.lang.String changeMfg)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getCrtvItemComments

public java.lang.String getCrtvItemComments()

setCrtvItemComments

public void setCrtvItemComments(java.lang.String crtvItemComments)

getCrtvItemPrivateNotes

public java.lang.String getCrtvItemPrivateNotes()

setCrtvItemPrivateNotes

public void setCrtvItemPrivateNotes(java.lang.String crtvItemPrivateNotes)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getSalesCost

public java.math.BigDecimal getSalesCost()

setSalesCost

public void setSalesCost(java.math.BigDecimal salesCost)

getCurrentCost

public java.math.BigDecimal getCurrentCost()

setCurrentCost

public void setCurrentCost(java.math.BigDecimal currentCost)

getCurrentStdCost

public java.math.BigDecimal getCurrentStdCost()

setCurrentStdCost

public void setCurrentStdCost(java.math.BigDecimal currentStdCost)

getSalesStdCost

public java.math.BigDecimal getSalesStdCost()

setSalesStdCost

public void setSalesStdCost(java.math.BigDecimal salesStdCost)

getReturnMaterialAuthorizationItemManufacturer

public java.util.Set getReturnMaterialAuthorizationItemManufacturer()

setReturnMaterialAuthorizationItemManufacturer

public void setReturnMaterialAuthorizationItemManufacturer(java.util.Set returnMaterialAuthorizationItemManufacturer)

getSalesPrice

public java.math.BigDecimal getSalesPrice()

setSalesPrice

public void setSalesPrice(java.math.BigDecimal salesPrice)

getSalesQty

public java.math.BigDecimal getSalesQty()

setSalesQty

public void setSalesQty(java.math.BigDecimal salesQty)

getSalesUnit

public java.lang.String getSalesUnit()

setSalesUnit

public void setSalesUnit(java.lang.String salesUnit)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomerReturnToVendorVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomerReturnToVendorVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CustomerReturnToVendorVO
All Implemented Interfaces:
java.io.Serializable
public class CustomerReturnToVendorVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CustomerReturnToVendorVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getActual()
java.util.Date | getAdate()
java.math.BigDecimal | getApGl1Recorded()
java.math.BigDecimal | getApGl2Paid()
java.lang.String | getApNetSet()
java.math.BigDecimal | getApOpen()
java.math.BigDecimal | getApPaidGl()
java.math.BigDecimal | getApPaidReceived()
java.lang.String | getApprovedBy()
java.util.Date | getApprovedTime()
java.math.BigDecimal | getApReceived()
java.math.BigDecimal | getApSub()
java.lang.String | getApTaxSet()
CustomerVendorAddressInfoVO | getBillToAddressInfo()
java.lang.String | getBillToId()
java.lang.String | getBp()
java.lang.String | getCarrier()
java.lang.String | getCarrierAcct()
java.lang.String | getChangeOrder()
java.lang.String | getCoComments()
java.lang.String | getComments()
java.lang.String | getCompanyUnitId()
java.lang.String | getContact()
java.util.Date | getCrtvDate()
java.util.Set<CustomerReturnToVendorItemVO> | getCrtvItem()
java.lang.String | getCrtvNumber()
java.lang.String | getCurrency()
CustomerVendorAddressInfoVO | getCustomerAddressInfo()
java.lang.String | getCustomerId()
java.lang.String | getDebitAccount()
byte | getDelay()
java.util.Date | getDelivery()
java.math.BigDecimal | getExchange()
java.math.BigDecimal | getGrantTotal()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getInvoiceNumber()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getLocate()
java.lang.String | getOrigin()
java.util.Date | getOriginal()
java.lang.String | getPriority()
java.lang.String | getPrivateNotes()
java.lang.String | getProjectName()
java.lang.String | getRelatedDoc()
java.lang.String | getRequester()
java.lang.String | getRmaNumber()
java.lang.String | getSalesCodeId()
java.lang.String | getSalesman()
java.lang.String | getSalesOrderNumber()
CustomerVendorAddressInfoVO | getShipToAddressInfo()
java.lang.String | getShipToId()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.math.BigDecimal | getSubTotal()
java.lang.String | getTerms()
java.math.BigDecimal | getTotalDiscount()
java.math.BigDecimal | getTotalFreight()
java.math.BigDecimal | getTotalTax()
java.lang.Integer | getVersion()
int | hashCode()
void | setActual(java.util.Date actual)
void | setAdate(java.util.Date adate)
void | setApGl1Recorded(java.math.BigDecimal apGl1Recorded)
void | setApGl2Paid(java.math.BigDecimal apGl2Paid)
void | setApNetSet(java.lang.String apNetSet)
void | setApOpen(java.math.BigDecimal apOpen)
void | setApPaidGl(java.math.BigDecimal apPaidGl)
void | setApPaidReceived(java.math.BigDecimal apPaidReceived)
void | setApprovedBy(java.lang.String approvedBy)
void | setApprovedTime(java.util.Date approvedTime)
void | setApReceived(java.math.BigDecimal apReceived)
void | setApSub(java.math.BigDecimal apSub)
void | setApTaxSet(java.lang.String apTaxSet)
void | setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | setBillToId(java.lang.String billToId)
void | setBp(java.lang.String bp)
void | setCarrier(java.lang.String carrier)
void | setCarrierAcct(java.lang.String carrierAcct)
void | setChangeOrder(java.lang.String changeOrder)
void | setCoComments(java.lang.String coComments)
void | setComments(java.lang.String comments)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setContact(java.lang.String contact)
void | setCrtvDate(java.util.Date crtvDate)
void | setCrtvItem(java.util.Set<CustomerReturnToVendorItemVO> crtvItem)
void | setCrtvNumber(java.lang.String crtvNumber)
void | setCurrency(java.lang.String currency)
void | setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | setCustomerId(java.lang.String customerId)
void | setDebitAccount(java.lang.String debitAccount)
void | setDelay(byte delay)
void | setDelivery(java.util.Date delivery)
void | setExchange(java.math.BigDecimal exchange)
void | setGrantTotal(java.math.BigDecimal grantTotal)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setInvoiceNumber(java.lang.String invoiceNumber)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLocate(java.lang.String locate)
void | setOrigin(java.lang.String origin)
void | setOriginal(java.util.Date original)
void | setPriority(java.lang.String priority)
void | setPrivateNotes(java.lang.String privateNotes)
void | setProjectName(java.lang.String projectName)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setRequester(java.lang.String requester)
void | setRmaNumber(java.lang.String rmaNumber)
void | setSalesCodeId(java.lang.String salesCodeId)
void | setSalesman(java.lang.String salesman)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | setShipToId(java.lang.String shipToId)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setSubTotal(java.math.BigDecimal subTotal)
void | setTerms(java.lang.String terms)
void | setTotalDiscount(java.math.BigDecimal totalDiscount)
void | setTotalFreight(java.math.BigDecimal totalFreight)
void | setTotalTax(java.math.BigDecimal totalTax)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CustomerReturnToVendorVO

public CustomerReturnToVendorVO()
Method Detail

getCrtvNumber

public java.lang.String getCrtvNumber()

setCrtvNumber

public void setCrtvNumber(java.lang.String crtvNumber)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getApNetSet

public java.lang.String getApNetSet()

setApNetSet

public void setApNetSet(java.lang.String apNetSet)

getApTaxSet

public java.lang.String getApTaxSet()

setApTaxSet

public void setApTaxSet(java.lang.String apTaxSet)

getSubTotal

public java.math.BigDecimal getSubTotal()

setSubTotal

public void setSubTotal(java.math.BigDecimal subTotal)

getTotalDiscount

public java.math.BigDecimal getTotalDiscount()

setTotalDiscount

public void setTotalDiscount(java.math.BigDecimal totalDiscount)

getApReceived

public java.math.BigDecimal getApReceived()

setApReceived

public void setApReceived(java.math.BigDecimal apReceived)

getApOpen

public java.math.BigDecimal getApOpen()

setApOpen

public void setApOpen(java.math.BigDecimal apOpen)

getTotalTax

public java.math.BigDecimal getTotalTax()

setTotalTax

public void setTotalTax(java.math.BigDecimal totalTax)

getTotalFreight

public java.math.BigDecimal getTotalFreight()

setTotalFreight

public void setTotalFreight(java.math.BigDecimal totalFreight)

getGrantTotal

public java.math.BigDecimal getGrantTotal()

setGrantTotal

public void setGrantTotal(java.math.BigDecimal grantTotal)

getApPaidReceived

public java.math.BigDecimal getApPaidReceived()

setApPaidReceived

public void setApPaidReceived(java.math.BigDecimal apPaidReceived)

getApPaidGl

public java.math.BigDecimal getApPaidGl()

setApPaidGl

public void setApPaidGl(java.math.BigDecimal apPaidGl)

getApGl1Recorded

public java.math.BigDecimal getApGl1Recorded()

setApGl1Recorded

public void setApGl1Recorded(java.math.BigDecimal apGl1Recorded)

getApGl2Paid

public java.math.BigDecimal getApGl2Paid()

setApGl2Paid

public void setApGl2Paid(java.math.BigDecimal apGl2Paid)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getBillToId

public java.lang.String getBillToId()

setBillToId

public void setBillToId(java.lang.String billToId)

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getApprovedTime

public java.util.Date getApprovedTime()

setApprovedTime

public void setApprovedTime(java.util.Date approvedTime)

getApprovedBy

public java.lang.String getApprovedBy()

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)

getDelivery

public java.util.Date getDelivery()

setDelivery

public void setDelivery(java.util.Date delivery)

getDelay

public byte getDelay()

setDelay

public void setDelay(byte delay)

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getOriginal

public java.util.Date getOriginal()

setOriginal

public void setOriginal(java.util.Date original)

getActual

public java.util.Date getActual()

setActual

public void setActual(java.util.Date actual)

getShipToId

public java.lang.String getShipToId()

setShipToId

public void setShipToId(java.lang.String shipToId)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAcct

public java.lang.String getCarrierAcct()

setCarrierAcct

public void setCarrierAcct(java.lang.String carrierAcct)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getCrtvDate

public java.util.Date getCrtvDate()

setCrtvDate

public void setCrtvDate(java.util.Date crtvDate)

getSalesman

public java.lang.String getSalesman()

setSalesman

public void setSalesman(java.lang.String salesman)

getProjectName

public java.lang.String getProjectName()

setProjectName

public void setProjectName(java.lang.String projectName)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getDebitAccount

public java.lang.String getDebitAccount()

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

getBp

public java.lang.String getBp()

setBp

public void setBp(java.lang.String bp)

getCustomerAddressInfo

public CustomerVendorAddressInfoVO getCustomerAddressInfo()

setCustomerAddressInfo

public void setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)

getBillToAddressInfo

public CustomerVendorAddressInfoVO getBillToAddressInfo()

setBillToAddressInfo

public void setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)

getShipToAddressInfo

public CustomerVendorAddressInfoVO getShipToAddressInfo()

setShipToAddressInfo

public void setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)

getVersion

public java.lang.Integer getVersion()

getRequester

public java.lang.String getRequester()

getApSub

public java.math.BigDecimal getApSub()

setVersion

public void setVersion(java.lang.Integer version)

setRequester

public void setRequester(java.lang.String requester)

setApSub

public void setApSub(java.math.BigDecimal apSub)

getCoComments

public java.lang.String getCoComments()

setCoComments

public void setCoComments(java.lang.String coComments)

getExchange

public java.math.BigDecimal getExchange()

setExchange

public void setExchange(java.math.BigDecimal exchange)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getSalesCodeId

public java.lang.String getSalesCodeId()

setSalesCodeId

public void setSalesCodeId(java.lang.String salesCodeId)

getCrtvItem

public java.util.Set<CustomerReturnToVendorItemVO> getCrtvItem()

setCrtvItem

public void setCrtvItem(java.util.Set<CustomerReturnToVendorItemVO> crtvItem)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getPrivateNotes

public java.lang.String getPrivateNotes()

setPrivateNotes

public void setPrivateNotes(java.lang.String privateNotes)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getInvoiceNumber

public java.lang.String getInvoiceNumber()

setInvoiceNumber

public void setInvoiceNumber(java.lang.String invoiceNumber)

getRmaNumber

public java.lang.String getRmaNumber()

setRmaNumber

public void setRmaNumber(java.lang.String rmaNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomerServiceBox

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common.box
Interface CustomerServiceBox

public interface CustomerServiceBox

Method Summary
CustomerFeedbackVO | addCustomerFeedback(CustomerFeedbackVO vo)
CustomerFeedbackVO | addCustomerFeedback(java.lang.String invoiceNumber)
CustomerFeedbackVO | addCustomerFeedbackByCustomerId(java.lang.String customerId)
CustomerFeedbackVO | addCustomerFeedbackBySoNumber(java.lang.String soNumber)
java.util.Collection<FeedbackItemVO> | addCustomerFeedbackItem(java.util.ArrayList list)
FeedbackItemVO | addCustomerFeedbackItem(FeedbackItemVO vo)
FeedbackQuestionVO | addFeedbackQuestion(FeedbackQuestionVO vo)
CustomerServiceIncidentVO | addIncident(CustomerServiceIncidentVO vo)
void | deleteCustomerFeedbackItem(FeedBackItemPK pk)
FeedbackQuestionVO | deleteFeedbackQuestion(FeedbackQuestionVO vo)
java.util.Collection<CustomerServiceIncidentItemVO> | deleteIncidentItemDoc(MiscDocAgent agent)
byte[] | downloadIncidentItemDoc(MiscDocAgent agent)
java.util.Collection<CustomerFeedbackVO> | findAllCustomerFeedback(int firstIndex, int maxLength)
java.util.Collection<CustomerServiceIncidentItemVO> | findAllIncidentItem(int firstIndex, int maxLength)
java.util.Collection<CustomerServiceIncidentListResult> | findAllIncidents(int firstIndex, int maxLength)
java.util.Collection<FeedbackQuestionVO> | findAllQuestions(int firstIndex, int maxLength)
java.util.Collection<CustomerFeedbackVO> | findCustomerFeedbackByDate(java.lang.String feedbackNumberLike, java.lang.String customerId, java.lang.String status, java.lang.String csiNumber, java.lang.String comments, boolean isCFBDate, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<CustomerFeedbackVO> | findCustomerFeedbacksByFeedBackNumber(java.lang.String feedbackNumberLike, int firstIndex, int maxLength)
java.util.Collection<CustomerServiceIncidentListResult> | findDueIncidents(int firstIndex, int maxLength)
CustomerServiceIncidentVO | findIncidentByPk(java.lang.String csiNumber)
java.util.Collection<CustomerServiceIncidentItemVO> | findIncidentItemInfosByCsi(java.lang.String csiNumber)
java.util.Collection<CustomerServiceIncidentListResult> | findIncidentsByCsiNumber(java.lang.String csi, int firstIndex, int maxLength)
java.util.Collection<CustomerServiceIncidentListResult> | findIncidentsByCustomerId(java.lang.String customerId, int firstIndex, int maxLength)
java.util.Collection<CustomerServiceIncidentListResult> | findIncidentsByDate(java.lang.String csiNumber, PartPK partPk, java.lang.String customerId, java.lang.String priority, java.lang.String status, boolean isOpenDate, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<CustomerServiceIncidentItemListResult> | findIncidentsByDate(java.lang.String csiNumber, PartPK partPk, java.lang.String customerId, java.lang.String priority, java.lang.String status, java.lang.String shipperNumber, java.lang.String workOrderNumber, java.lang.String salesOrderNumber, boolean isOpenDate, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<CustomerServiceIncidentListResult> | findIncidentsByPartLike(java.lang.String pn, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<CustomerFeedbackVO> | findOpenCustomerFeedback(int firstIndex, int maxLength)
java.util.Collection<CustomerServiceIncidentListResult> | findOpenIncidents(int firstIndex, int maxLength)
java.util.Collection<ClientListItem> | getActiveQuestionList(java.lang.String language)
int | getAllCustomerFeedbackCount()
int | getAllIncidentItemCount()
int | getAllIncidentsCount()
int | getAllQuestionCount()
java.util.Collection<ClientListItem> | getAnswerList(java.lang.String questionId, java.lang.String language)
CustomerFeedbackVO | getCustomerFeedbackById(java.lang.String feedbackNumber)
int | getCustomerFeedbackCountByDate(java.lang.String feedbackNumberLike, java.lang.String customerId, java.lang.String status, java.lang.String csiNumber, java.lang.String comments, boolean isCFBDate, java.util.Date fromDate, java.util.Date toDate)
int | getCustomerFeedbacksCountByFeedBackNumber(java.lang.String feedbackNumberLike)
int | getDueIncidentCount()
int | getIncidentCountByCsiNumber(java.lang.String csi)
int | getIncidentCountByCustomerId(java.lang.String customerId)
int | getIncidentCountByDate(java.lang.String csiNumber, PartPK partPk, java.lang.String customerId, java.lang.String priority, java.lang.String status, boolean isOpenDate, java.util.Date fromDate, java.util.Date toDate)
int | getIncidentCountByDate(java.lang.String csiNumber, PartPK partPk, java.lang.String customerId, java.lang.String priority, java.lang.String status, java.lang.String shipperNumber, java.lang.String workOrderNumber, java.lang.String salesOrderNumber, boolean isOpenDate, java.util.Date fromDate, java.util.Date toDate)
int | getIncidentCountByPartLike(java.lang.String pn, java.lang.String partType)
int | getIncidentItemsCountByCsi(java.lang.String csiNumber)
int | getOpenCustomerFeedbackCount()
int | getOpenIncidentCount()
FeedbackQuestionVO | getQuestionById(java.lang.String questionId)
java.util.Collection<ClientListItem> | getQuestionList(java.lang.String language)
boolean | isCustomerFeedbackExist(java.lang.String customerFeedbackNumber)
boolean | isCustomerServiceIncidentExist(java.lang.String csiNumber)
boolean | isFeedbackQuestionExist(java.lang.String questionId)
CustomerFeedbackVO | updateCustomerFeedback(CustomerFeedbackVO vo)
void | updateCustomerFeedbackItem(java.util.ArrayList list, java.lang.String feedBackNumber)
FeedbackItemVO | updateCustomerFeedbackItem(FeedbackItemVO vo)
FeedbackQuestionVO | updateFeedbackQuestion(FeedbackQuestionVO vo)
CustomerServiceIncidentVO | updateIncident(CustomerServiceIncidentVO vo)
java.util.Collection<CustomerServiceIncidentItemVO> | uploadOrUpdateIncidentItemDoc(CustomerServiceIncidentItemVO vo, MiscDocAgent agent)

Method Detail

addIncident

CustomerServiceIncidentVO addIncident(CustomerServiceIncidentVO vo)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

uploadOrUpdateIncidentItemDoc

java.util.Collection<CustomerServiceIncidentItemVO> uploadOrUpdateIncidentItemDoc(CustomerServiceIncidentItemVO vo,
                                                                                MiscDocAgent agent)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

downloadIncidentItemDoc

byte[] downloadIncidentItemDoc(MiscDocAgent agent)
                               throws java.lang.Exception
Throws:
java.lang.Exception

deleteIncidentItemDoc

java.util.Collection<CustomerServiceIncidentItemVO> deleteIncidentItemDoc(MiscDocAgent agent)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

updateIncident

CustomerServiceIncidentVO updateIncident(CustomerServiceIncidentVO vo)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

findAllIncidents

java.util.Collection<CustomerServiceIncidentListResult> findAllIncidents(int firstIndex,
                                                                         int maxLength)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getAllIncidentsCount

int getAllIncidentsCount()
                         throws java.lang.Exception
Throws:
java.lang.Exception

findIncidentByPk

CustomerServiceIncidentVO findIncidentByPk(java.lang.String csiNumber)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

findIncidentsByCsiNumber

java.util.Collection<CustomerServiceIncidentListResult> findIncidentsByCsiNumber(java.lang.String csi,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getIncidentCountByCsiNumber

int getIncidentCountByCsiNumber(java.lang.String csi)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findIncidentsByPartLike

java.util.Collection<CustomerServiceIncidentListResult> findIncidentsByPartLike(java.lang.String pn,
                                                                                java.lang.String partType,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getIncidentCountByPartLike

int getIncidentCountByPartLike(java.lang.String pn,
                               java.lang.String partType)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findIncidentsByDate

java.util.Collection<CustomerServiceIncidentItemListResult> findIncidentsByDate(java.lang.String csiNumber,
                                                                                PartPK partPk,
                                                                                java.lang.String customerId,
                                                                                java.lang.String priority,
                                                                                java.lang.String status,
                                                                                java.lang.String shipperNumber,
                                                                                java.lang.String workOrderNumber,
                                                                                java.lang.String salesOrderNumber,
                                                                                boolean isOpenDate,
                                                                                java.util.Date fromDate,
                                                                                java.util.Date toDate,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getIncidentCountByDate

int getIncidentCountByDate(java.lang.String csiNumber,
                           PartPK partPk,
                           java.lang.String customerId,
                           java.lang.String priority,
                           java.lang.String status,
                           java.lang.String shipperNumber,
                           java.lang.String workOrderNumber,
                           java.lang.String salesOrderNumber,
                           boolean isOpenDate,
                           java.util.Date fromDate,
                           java.util.Date toDate)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findIncidentsByCustomerId

java.util.Collection<CustomerServiceIncidentListResult> findIncidentsByCustomerId(java.lang.String customerId,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getIncidentCountByCustomerId

int getIncidentCountByCustomerId(java.lang.String customerId)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findOpenIncidents

java.util.Collection<CustomerServiceIncidentListResult> findOpenIncidents(int firstIndex,
                                                                          int maxLength)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getOpenIncidentCount

int getOpenIncidentCount()
                         throws java.lang.Exception
Throws:
java.lang.Exception

findDueIncidents

java.util.Collection<CustomerServiceIncidentListResult> findDueIncidents(int firstIndex,
                                                                         int maxLength)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getDueIncidentCount

int getDueIncidentCount()
                        throws java.lang.Exception
Throws:
java.lang.Exception

findIncidentsByDate

java.util.Collection<CustomerServiceIncidentListResult> findIncidentsByDate(java.lang.String csiNumber,
                                                                            PartPK partPk,
                                                                            java.lang.String customerId,
                                                                            java.lang.String priority,
                                                                            java.lang.String status,
                                                                            boolean isOpenDate,
                                                                            java.util.Date fromDate,
                                                                            java.util.Date toDate,
                                                                            int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getIncidentCountByDate

int getIncidentCountByDate(java.lang.String csiNumber,
                           PartPK partPk,
                           java.lang.String customerId,
                           java.lang.String priority,
                           java.lang.String status,
                           boolean isOpenDate,
                           java.util.Date fromDate,
                           java.util.Date toDate)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findIncidentItemInfosByCsi

java.util.Collection<CustomerServiceIncidentItemVO> findIncidentItemInfosByCsi(java.lang.String csiNumber)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getIncidentItemsCountByCsi

int getIncidentItemsCountByCsi(java.lang.String csiNumber)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findAllIncidentItem

java.util.Collection<CustomerServiceIncidentItemVO> findAllIncidentItem(int firstIndex,
                                                                        int maxLength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getAllIncidentItemCount

int getAllIncidentItemCount()
                            throws java.lang.Exception
Throws:
java.lang.Exception

getQuestionList

java.util.Collection<ClientListItem> getQuestionList(java.lang.String language)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getActiveQuestionList

java.util.Collection<ClientListItem> getActiveQuestionList(java.lang.String language)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getAnswerList

java.util.Collection<ClientListItem> getAnswerList(java.lang.String questionId,
                                                   java.lang.String language)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

findAllQuestions

java.util.Collection<FeedbackQuestionVO> findAllQuestions(int firstIndex,
                                                          int maxLength)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getAllQuestionCount

int getAllQuestionCount()
                        throws java.lang.Exception
Throws:
java.lang.Exception

getQuestionById

FeedbackQuestionVO getQuestionById(java.lang.String questionId)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

addFeedbackQuestion

FeedbackQuestionVO addFeedbackQuestion(FeedbackQuestionVO vo)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

updateFeedbackQuestion

FeedbackQuestionVO updateFeedbackQuestion(FeedbackQuestionVO vo)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

deleteFeedbackQuestion

FeedbackQuestionVO deleteFeedbackQuestion(FeedbackQuestionVO vo)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

isFeedbackQuestionExist

boolean isFeedbackQuestionExist(java.lang.String questionId)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findAllCustomerFeedback

java.util.Collection<CustomerFeedbackVO> findAllCustomerFeedback(int firstIndex,
                                                                 int maxLength)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getAllCustomerFeedbackCount

int getAllCustomerFeedbackCount()
                                throws java.lang.Exception
Throws:
java.lang.Exception

findCustomerFeedbackByDate

java.util.Collection<CustomerFeedbackVO> findCustomerFeedbackByDate(java.lang.String feedbackNumberLike,
                                                                    java.lang.String customerId,
                                                                    java.lang.String status,
                                                                    java.lang.String csiNumber,
                                                                    java.lang.String comments,
                                                                    boolean isCFBDate,
                                                                    java.util.Date fromDate,
                                                                    java.util.Date toDate,
                                                                    int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getCustomerFeedbackCountByDate

int getCustomerFeedbackCountByDate(java.lang.String feedbackNumberLike,
                                   java.lang.String customerId,
                                   java.lang.String status,
                                   java.lang.String csiNumber,
                                   java.lang.String comments,
                                   boolean isCFBDate,
                                   java.util.Date fromDate,
                                   java.util.Date toDate)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findOpenCustomerFeedback

java.util.Collection<CustomerFeedbackVO> findOpenCustomerFeedback(int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getOpenCustomerFeedbackCount

int getOpenCustomerFeedbackCount()
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findCustomerFeedbacksByFeedBackNumber

java.util.Collection<CustomerFeedbackVO> findCustomerFeedbacksByFeedBackNumber(java.lang.String feedbackNumberLike,
                                                                               int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getCustomerFeedbacksCountByFeedBackNumber

int getCustomerFeedbacksCountByFeedBackNumber(java.lang.String feedbackNumberLike)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

isCustomerFeedbackExist

boolean isCustomerFeedbackExist(java.lang.String customerFeedbackNumber)
                                throws java.lang.Exception
Throws:
java.lang.Exception

getCustomerFeedbackById

CustomerFeedbackVO getCustomerFeedbackById(java.lang.String feedbackNumber)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

addCustomerFeedback

CustomerFeedbackVO addCustomerFeedback(CustomerFeedbackVO vo)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

addCustomerFeedback

CustomerFeedbackVO addCustomerFeedback(java.lang.String invoiceNumber)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

addCustomerFeedbackBySoNumber

CustomerFeedbackVO addCustomerFeedbackBySoNumber(java.lang.String soNumber)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

addCustomerFeedbackByCustomerId

CustomerFeedbackVO addCustomerFeedbackByCustomerId(java.lang.String customerId)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

updateCustomerFeedback

CustomerFeedbackVO updateCustomerFeedback(CustomerFeedbackVO vo)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

addCustomerFeedbackItem

FeedbackItemVO addCustomerFeedbackItem(FeedbackItemVO vo)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

addCustomerFeedbackItem

java.util.Collection<FeedbackItemVO> addCustomerFeedbackItem(java.util.ArrayList list)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

updateCustomerFeedbackItem

FeedbackItemVO updateCustomerFeedbackItem(FeedbackItemVO vo)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

updateCustomerFeedbackItem

void updateCustomerFeedbackItem(java.util.ArrayList list,
                                java.lang.String feedBackNumber)
                                throws java.lang.Exception
Throws:
java.lang.Exception

deleteCustomerFeedbackItem

void deleteCustomerFeedbackItem(FeedBackItemPK pk)
                                throws java.lang.Exception
Throws:
java.lang.Exception

isCustomerServiceIncidentExist

boolean isCustomerServiceIncidentExist(java.lang.String csiNumber)
                                       throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomerServiceIncidentItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomerServiceIncidentItemListResult

java.lang.Object
    extended by  bb.common.CustomerServiceIncidentItemListResult
All Implemented Interfaces:
java.io.Serializable
public class CustomerServiceIncidentItemListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CLOSEDDATE
static java.lang.String | ORDER_BY_CSINUMBER
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_DUEDATE
static java.lang.String | ORDER_BY_OPENDATE
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_SALESORDERNUMBER
static java.lang.String | ORDER_BY_SHIPPERNUMBER
static java.lang.String | ORDER_BY_WORKORDERNUMBER
Constructor Summary
CustomerServiceIncidentItemListResult()
Method Summary
java.util.Date | getClosedDate()
java.lang.String | getCsiNumber()
java.lang.String | getCustomerId()
java.lang.String | getDescription()
java.util.Date | getDueDate()
java.util.Date | getOpenDate()
java.lang.String | getOriginalInvoice()
java.lang.String | getOriginalSalesOrderNumber()
java.lang.String | getOriginalShipperNumber()
java.lang.String | getOriginalWorkOrderNumber()
java.lang.String | getPartDescription()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getPriority()
java.lang.String | getReportBy()
java.lang.String | getStatus()
void | setClosedDate(java.util.Date closedDate)
void | setCsiNumber(java.lang.String csiNumber)
void | setCustomerId(java.lang.String customerId)
void | setDescription(java.lang.String description)
void | setDueDate(java.util.Date dueDate)
void | setOpenDate(java.util.Date openDate)
void | setOriginalInvoice(java.lang.String originalInvoice)
void | setOriginalSalesOrderNumber(java.lang.String originalSalesOrderNumber)
void | setOriginalShipperNumber(java.lang.String originalShipperNumber)
void | setOriginalWorkOrderNumber(java.lang.String originalWorkOrderNumber)
void | setPartDescription(java.lang.String partDescription)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPriority(java.lang.String priority)
void | setReportBy(java.lang.String reportBy)
void | setStatus(java.lang.String status)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_CSINUMBER

public static final java.lang.String ORDER_BY_CSINUMBER
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_OPENDATE

public static final java.lang.String ORDER_BY_OPENDATE
See Also:
Constant Field Values

ORDER_BY_DUEDATE

public static final java.lang.String ORDER_BY_DUEDATE
See Also:
Constant Field Values

ORDER_BY_CLOSEDDATE

public static final java.lang.String ORDER_BY_CLOSEDDATE
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_SHIPPERNUMBER

public static final java.lang.String ORDER_BY_SHIPPERNUMBER
See Also:
Constant Field Values

ORDER_BY_WORKORDERNUMBER

public static final java.lang.String ORDER_BY_WORKORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_SALESORDERNUMBER

public static final java.lang.String ORDER_BY_SALESORDERNUMBER
See Also:
Constant Field Values
Constructor Detail

CustomerServiceIncidentItemListResult

public CustomerServiceIncidentItemListResult()
Method Detail

getClosedDate

public java.util.Date getClosedDate()

setClosedDate

public void setClosedDate(java.util.Date closedDate)

getCsiNumber

public java.lang.String getCsiNumber()

setCsiNumber

public void setCsiNumber(java.lang.String csiNumber)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getDueDate

public java.util.Date getDueDate()

setDueDate

public void setDueDate(java.util.Date dueDate)

getOpenDate

public java.util.Date getOpenDate()

setOpenDate

public void setOpenDate(java.util.Date openDate)

getOriginalInvoice

public java.lang.String getOriginalInvoice()

setOriginalInvoice

public void setOriginalInvoice(java.lang.String originalInvoice)

getOriginalSalesOrderNumber

public java.lang.String getOriginalSalesOrderNumber()

setOriginalSalesOrderNumber

public void setOriginalSalesOrderNumber(java.lang.String originalSalesOrderNumber)

getOriginalShipperNumber

public java.lang.String getOriginalShipperNumber()

setOriginalShipperNumber

public void setOriginalShipperNumber(java.lang.String originalShipperNumber)

getOriginalWorkOrderNumber

public java.lang.String getOriginalWorkOrderNumber()

setOriginalWorkOrderNumber

public void setOriginalWorkOrderNumber(java.lang.String originalWorkOrderNumber)

getPartDescription

public java.lang.String getPartDescription()

setPartDescription

public void setPartDescription(java.lang.String partDescription)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getReportBy

public java.lang.String getReportBy()

setReportBy

public void setReportBy(java.lang.String reportBy)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomerServiceIncidentItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomerServiceIncidentItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CustomerServiceIncidentItemVO
All Implemented Interfaces:
java.io.Serializable
public class CustomerServiceIncidentItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CustomerServiceIncidentItemVO()
default constructor
Method Summary
java.lang.String | getAnalysis()
java.lang.String | getDescription()
long | getDocLength()
java.lang.String | getDocName()
java.lang.String | getEmailFrom()
java.util.Date | getEmailSent()
java.lang.String | getEmailTo()
java.lang.String | getExtension()
java.lang.Long | getIi()
java.lang.String | getIncidentNumber()
java.lang.String | getQuestion()
java.lang.String | getResults()
java.lang.String | getStatus()
void | setAnalysis(java.lang.String analysis)
void | setDescription(java.lang.String description)
void | setDocLength(long docLength)
void | setDocName(java.lang.String docName)
void | setEmailFrom(java.lang.String emailFrom)
void | setEmailSent(java.util.Date emailSent)
void | setEmailTo(java.lang.String emailTo)
void | setExtension(java.lang.String extension)
void | setIi(java.lang.Long ii)
void | setIncidentNumber(java.lang.String incidentNumber)
void | setQuestion(java.lang.String question)
void | setResults(java.lang.String results)
void | setStatus(java.lang.String status)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CustomerServiceIncidentItemVO

public CustomerServiceIncidentItemVO()
default constructor

Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getEmailSent

public java.util.Date getEmailSent()

setEmailSent

public void setEmailSent(java.util.Date emailSent)

getEmailFrom

public java.lang.String getEmailFrom()

setEmailFrom

public void setEmailFrom(java.lang.String emailFrom)

getEmailTo

public java.lang.String getEmailTo()

setEmailTo

public void setEmailTo(java.lang.String emailTo)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

getQuestion

public java.lang.String getQuestion()

setQuestion

public void setQuestion(java.lang.String question)

getAnalysis

public java.lang.String getAnalysis()

setAnalysis

public void setAnalysis(java.lang.String analysis)

getResults

public java.lang.String getResults()

setResults

public void setResults(java.lang.String results)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getDocLength

public long getDocLength()

setDocLength

public void setDocLength(long docLength)

getDocName

public java.lang.String getDocName()

setDocName

public void setDocName(java.lang.String docName)

getIncidentNumber

public java.lang.String getIncidentNumber()

setIncidentNumber

public void setIncidentNumber(java.lang.String incidentNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomerServiceIncidentListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomerServiceIncidentListResult

java.lang.Object
    extended by  bb.common.CustomerServiceIncidentListResult
All Implemented Interfaces:
java.io.Serializable
public class CustomerServiceIncidentListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CSINUMBER
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_DUEDATE
static java.lang.String | ORDER_BY_OPENDATE
static java.lang.String | ORDER_BY_PARTFROM
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTTYPE
Constructor Summary
CustomerServiceIncidentListResult()
Method Summary
java.lang.String | getCsiNumber()
java.lang.String | getCustomerId()
java.lang.String | getDescription()
java.util.Date | getDueDate()
java.util.Date | getOpenDate()
java.lang.String | getPartDescription()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getPriority()
java.lang.String | getStatus()
void | setCsiNumber(java.lang.String csiNumber)
void | setCustomerId(java.lang.String customerId)
void | setDescription(java.lang.String description)
void | setDueDate(java.util.Date dueDate)
void | setOpenDate(java.util.Date openDate)
void | setPartDescription(java.lang.String partDescription)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPriority(java.lang.String priority)
void | setStatus(java.lang.String status)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_CSINUMBER

public static final java.lang.String ORDER_BY_CSINUMBER
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_PARTFROM

public static final java.lang.String ORDER_BY_PARTFROM
See Also:
Constant Field Values

ORDER_BY_OPENDATE

public static final java.lang.String ORDER_BY_OPENDATE
See Also:
Constant Field Values

ORDER_BY_DUEDATE

public static final java.lang.String ORDER_BY_DUEDATE
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values
Constructor Detail

CustomerServiceIncidentListResult

public CustomerServiceIncidentListResult()
Method Detail

getStatus

public java.lang.String getStatus()

getPriority

public java.lang.String getPriority()

getDueDate

public java.util.Date getDueDate()

getOpenDate

public java.util.Date getOpenDate()

getPartDescription

public java.lang.String getPartDescription()

getPartFrom

public java.lang.String getPartFrom()

getPartType

public java.lang.String getPartType()

getPartNumber

public java.lang.String getPartNumber()

getDescription

public java.lang.String getDescription()

setCsiNumber

public void setCsiNumber(java.lang.String csiNumber)

setStatus

public void setStatus(java.lang.String status)

setPriority

public void setPriority(java.lang.String priority)

setDueDate

public void setDueDate(java.util.Date dueDate)

setOpenDate

public void setOpenDate(java.util.Date openDate)

setPartDescription

public void setPartDescription(java.lang.String partDescription)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setPartType

public void setPartType(java.lang.String partType)

setPartNumber

public void setPartNumber(java.lang.String partNumber)

setDescription

public void setDescription(java.lang.String description)

setCustomerId

public void setCustomerId(java.lang.String customerId)

getCsiNumber

public java.lang.String getCsiNumber()

getCustomerId

public java.lang.String getCustomerId()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomerServiceIncidentVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomerServiceIncidentVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CustomerServiceIncidentVO
All Implemented Interfaces:
java.io.Serializable
public class CustomerServiceIncidentVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
CustomerServiceIncidentVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getClosedDate()
java.lang.String | getCsEmail()
CustomerVendorAddressInfoVO | getCustomerAddressInfo()
java.lang.String | getCustomerEmail()
java.lang.String | getCustomerId()
java.lang.String | getDescription()
java.lang.String | getDetailDescription()
java.util.Date | getDueDate()
java.util.Set | getIncidentItems()
java.lang.String | getIncidentNumber()
java.lang.String | getIncidentType()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getLocation()
java.util.Date | getOpenDate()
java.lang.String | getOriginalInvoice()
java.lang.String | getOriginalSalesOrderNumber()
java.lang.String | getOriginalShipperNumber()
java.lang.String | getOriginalWorkOrderNumber()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getPriority()
java.lang.String | getProduct()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.lang.String | getReportBy()
java.lang.String | getRevision()
java.lang.String | getSerialNumber()
java.lang.String | getStatus()
java.lang.String | getStepsToReproduce()
java.lang.Integer | getVersion()
int | hashCode()
void | setClosedDate(java.util.Date closedDate)
void | setCsEmail(java.lang.String csEmail)
void | setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | setCustomerEmail(java.lang.String customerEmail)
void | setCustomerId(java.lang.String customerId)
void | setDescription(java.lang.String description)
void | setDetailDescription(java.lang.String detailDescription)
void | setDueDate(java.util.Date dueDate)
void | setIncidentItems(java.util.Set incidentItems)
void | setIncidentNumber(java.lang.String incidentNumber)
void | setIncidentType(java.lang.String incidentType)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLocation(java.lang.String location)
void | setOpenDate(java.util.Date openDate)
void | setOriginalInvoice(java.lang.String originalInvoice)
void | setOriginalSalesOrderNumber(java.lang.String originalSalesOrderNumber)
void | setOriginalShipperNumber(java.lang.String originalShipperNumber)
void | setOriginalWorkOrderNumber(java.lang.String originalWorkOrderNumber)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPriority(java.lang.String priority)
void | setProduct(java.lang.String product)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setReportBy(java.lang.String reportBy)
void | setRevision(java.lang.String revision)
void | setSerialNumber(java.lang.String serialNumber)
void | setStatus(java.lang.String status)
void | setStepsToReproduce(java.lang.String stepsToReproduce)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CustomerServiceIncidentVO

public CustomerServiceIncidentVO()
default constructor

Method Detail

getIncidentNumber

public java.lang.String getIncidentNumber()

setIncidentNumber

public void setIncidentNumber(java.lang.String incidentNumber)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getReportBy

public java.lang.String getReportBy()

setReportBy

public void setReportBy(java.lang.String reportBy)

getIncidentType

public java.lang.String getIncidentType()

setIncidentType

public void setIncidentType(java.lang.String incidentType)

getOpenDate

public java.util.Date getOpenDate()

setOpenDate

public void setOpenDate(java.util.Date openDate)

getDueDate

public java.util.Date getDueDate()

setDueDate

public void setDueDate(java.util.Date dueDate)

getClosedDate

public java.util.Date getClosedDate()

setClosedDate

public void setClosedDate(java.util.Date closedDate)

getProduct

public java.lang.String getProduct()

setProduct

public void setProduct(java.lang.String product)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getOriginalInvoice

public java.lang.String getOriginalInvoice()

setOriginalInvoice

public void setOriginalInvoice(java.lang.String originalInvoice)

getOriginalShipperNumber

public java.lang.String getOriginalShipperNumber()

setOriginalShipperNumber

public void setOriginalShipperNumber(java.lang.String originalShipperNumber)

getOriginalWorkOrderNumber

public java.lang.String getOriginalWorkOrderNumber()

setOriginalWorkOrderNumber

public void setOriginalWorkOrderNumber(java.lang.String originalWorkOrderNumber)

getOriginalSalesOrderNumber

public java.lang.String getOriginalSalesOrderNumber()

setOriginalSalesOrderNumber

public void setOriginalSalesOrderNumber(java.lang.String originalSalesOrderNumber)

getSerialNumber

public java.lang.String getSerialNumber()

setSerialNumber

public void setSerialNumber(java.lang.String serialNumber)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getCustomerEmail

public java.lang.String getCustomerEmail()

setCustomerEmail

public void setCustomerEmail(java.lang.String customerEmail)

getCsEmail

public java.lang.String getCsEmail()

setCsEmail

public void setCsEmail(java.lang.String csEmail)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getDetailDescription

public java.lang.String getDetailDescription()

setDetailDescription

public void setDetailDescription(java.lang.String detailDescription)

getStepsToReproduce

public java.lang.String getStepsToReproduce()

setStepsToReproduce

public void setStepsToReproduce(java.lang.String stepsToReproduce)

getCustomerAddressInfo

public CustomerVendorAddressInfoVO getCustomerAddressInfo()

setCustomerAddressInfo

public void setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)

getIncidentItems

public java.util.Set getIncidentItems()

getVersion

public java.lang.Integer getVersion()

getPartFrom

public java.lang.String getPartFrom()

setIncidentItems

public void setIncidentItems(java.util.Set incidentItems)

setVersion

public void setVersion(java.lang.Integer version)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomerStatementListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomerStatementListResult

java.lang.Object
    extended by  bb.common.CustomerStatementListResult
All Implemented Interfaces:
java.io.Serializable
public class CustomerStatementListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AMOUNTPAID
static java.lang.String | ORDER_BY_BALANCEDUE
static java.lang.String | ORDER_BY_CUSTOMERPO
static java.lang.String | ORDER_BY_DATE
static java.lang.String | ORDER_BY_DATEINVOICED
static java.lang.String | ORDER_BY_INVOICENUMBER
static java.lang.String | ORDER_BY_TOTALDUE
Constructor Summary
CustomerStatementListResult()
Method Summary
java.math.BigDecimal | getAmountPaid()
java.math.BigDecimal | getBalanceDue()
java.lang.String | getCustomerPo()
java.util.Date | getDate()
java.util.Date | getDateInvoiced()
java.lang.String | getInvoiceNumber()
java.lang.String | getSalesOrder()
java.math.BigDecimal | getTotalDue()
void | setAmountPaid(java.math.BigDecimal amountPaid)
void | setBalanceDue(java.math.BigDecimal balanceDue)
void | setCustomerPo(java.lang.String customerPo)
void | setDate(java.util.Date date)
void | setDateInvoiced(java.util.Date dateInvoiced)
void | setInvoiceNumber(java.lang.String invoiceNumber)
void | setSalesOrder(java.lang.String salesOrder)
void | setTotalDue(java.math.BigDecimal totalDue)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_INVOICENUMBER

public static final java.lang.String ORDER_BY_INVOICENUMBER
See Also:
Constant Field Values

ORDER_BY_DATEINVOICED

public static final java.lang.String ORDER_BY_DATEINVOICED
See Also:
Constant Field Values

ORDER_BY_DATE

public static final java.lang.String ORDER_BY_DATE
See Also:
Constant Field Values

ORDER_BY_CUSTOMERPO

public static final java.lang.String ORDER_BY_CUSTOMERPO
See Also:
Constant Field Values

ORDER_BY_TOTALDUE

public static final java.lang.String ORDER_BY_TOTALDUE
See Also:
Constant Field Values

ORDER_BY_AMOUNTPAID

public static final java.lang.String ORDER_BY_AMOUNTPAID
See Also:
Constant Field Values

ORDER_BY_BALANCEDUE

public static final java.lang.String ORDER_BY_BALANCEDUE
See Also:
Constant Field Values
Constructor Detail

CustomerStatementListResult

public CustomerStatementListResult()
Method Detail

getBalanceDue

public java.math.BigDecimal getBalanceDue()

getAmountPaid

public java.math.BigDecimal getAmountPaid()

getTotalDue

public java.math.BigDecimal getTotalDue()

getCustomerPo

public java.lang.String getCustomerPo()

getDate

public java.util.Date getDate()

setInvoiceNumber

public void setInvoiceNumber(java.lang.String invoiceNumber)

setBalanceDue

public void setBalanceDue(java.math.BigDecimal balanceDue)

setAmountPaid

public void setAmountPaid(java.math.BigDecimal amountPaid)

setTotalDue

public void setTotalDue(java.math.BigDecimal totalDue)

setCustomerPo

public void setCustomerPo(java.lang.String customerPo)

setDate

public void setDate(java.util.Date date)

setDateInvoiced

public void setDateInvoiced(java.util.Date dateInvoiced)

getInvoiceNumber

public java.lang.String getInvoiceNumber()

getDateInvoiced

public java.util.Date getDateInvoiced()

getSalesOrder

public java.lang.String getSalesOrder()

setSalesOrder

public void setSalesOrder(java.lang.String salesOrder)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomerStatementResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomerStatementResult

java.lang.Object
    extended by  bb.common.CustomerStatementResult
All Implemented Interfaces:
java.io.Serializable
public class CustomerStatementResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CustomerStatementResult()
Method Summary
CustomerVendorAddressInfoVO | getAddrInfo()
java.util.Collection<CustomerStatementTotalResult> | getArAging()
java.math.BigDecimal | getBalanceDue()
java.math.BigDecimal | getBalanceForward()
java.lang.String | getCurrency()
java.lang.String | getCustomerId()
java.lang.String | getCustomerName()
java.math.BigDecimal | getPaymentAmount()
java.util.List<PaymentInvoicesResult> | getPaymentInvoices()
java.math.BigDecimal | getServiceCharge()
java.math.BigDecimal | getTransactionAmount()
java.util.List<AccountsReceivableVO> | getTransactionInvoices()
boolean | isNullData()
void | setAddrInfo(CustomerVendorAddressInfoVO addrInfo)
void | setArAging(java.util.Collection<CustomerStatementTotalResult> arAging)
void | setBalanceDue(java.math.BigDecimal balanceDue)
void | setBalanceForward(java.math.BigDecimal balanceForward)
void | setCurrency(java.lang.String currency)
void | setCustomerId(java.lang.String customerId)
void | setCustomerName(java.lang.String customerName)
void | setPaymentAmount(java.math.BigDecimal paymentAmount)
void | setPaymentInvoices(java.util.List<PaymentInvoicesResult> paymentInvoices)
void | setServiceCharge(java.math.BigDecimal serviceCharge)
void | setTransactionAmount(java.math.BigDecimal transactionAmount)
void | setTransactionInvoices(java.util.List<AccountsReceivableVO> transactionInvoices)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CustomerStatementResult

public CustomerStatementResult()
Method Detail

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getBalanceForward

public java.math.BigDecimal getBalanceForward()

setBalanceForward

public void setBalanceForward(java.math.BigDecimal balanceForward)

getTransactionAmount

public java.math.BigDecimal getTransactionAmount()

setTransactionAmount

public void setTransactionAmount(java.math.BigDecimal transactionAmount)

getServiceCharge

public java.math.BigDecimal getServiceCharge()

setServiceCharge

public void setServiceCharge(java.math.BigDecimal serviceCharge)

getPaymentAmount

public java.math.BigDecimal getPaymentAmount()

setPaymentAmount

public void setPaymentAmount(java.math.BigDecimal paymentAmount)

getBalanceDue

public java.math.BigDecimal getBalanceDue()

setBalanceDue

public void setBalanceDue(java.math.BigDecimal balanceDue)

getPaymentInvoices

public java.util.List<PaymentInvoicesResult> getPaymentInvoices()

setPaymentInvoices

public void setPaymentInvoices(java.util.List<PaymentInvoicesResult> paymentInvoices)

getTransactionInvoices

public java.util.List<AccountsReceivableVO> getTransactionInvoices()

setTransactionInvoices

public void setTransactionInvoices(java.util.List<AccountsReceivableVO> transactionInvoices)

getArAging

public java.util.Collection<CustomerStatementTotalResult> getArAging()

setArAging

public void setArAging(java.util.Collection<CustomerStatementTotalResult> arAging)

getAddrInfo

public CustomerVendorAddressInfoVO getAddrInfo()

setAddrInfo

public void setAddrInfo(CustomerVendorAddressInfoVO addrInfo)

getCustomerName

public java.lang.String getCustomerName()

setCustomerName

public void setCustomerName(java.lang.String customerName)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

isNullData

public boolean isNullData()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomerStatementTotalResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomerStatementTotalResult

java.lang.Object
    extended by  bb.common.CustomerStatementTotalResult
All Implemented Interfaces:
java.io.Serializable
public class CustomerStatementTotalResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_CURRENT
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_CUSTOMERNAME
static java.lang.String | ORDER_BY_DUE1TO30TOTAL
static java.lang.String | ORDER_BY_DUE31TO60TOTAL
static java.lang.String | ORDER_BY_DUE61TO90TOTAL
static java.lang.String | ORDER_BY_DUE91TOTAL
static java.lang.String | ORDER_BY_TERMS
static java.lang.String | ORDER_BY_TOTALBALANCE
Constructor Summary
CustomerStatementTotalResult()
Method Summary
java.util.Date | getAsOf()
int | getAvgDaysToPay()
java.lang.String | getBillTo()
java.lang.String | getCurrency()
java.math.BigDecimal | getCurrent()
java.math.BigDecimal | getCustomerCreditLimit()
java.lang.String | getCustomerId()
java.lang.String | getCustomerName()
java.math.BigDecimal | getDue1To30Total()
java.math.BigDecimal | getDue31To60Total()
java.math.BigDecimal | getDue61To90Total()
java.math.BigDecimal | getDue91Total()
java.lang.String | getTerms()
java.math.BigDecimal | getTotalBalance()
boolean | isCustomerHold()
void | setAsOf(java.util.Date asOf)
void | setAvgDaysToPay(int avgDaysToPay)
void | setBillTo(java.lang.String billTo)
void | setCurrency(java.lang.String currency)
void | setCurrent(java.math.BigDecimal current)
void | setCustomerCreditLimit(java.math.BigDecimal customerCreditLimit)
void | setCustomerHold(boolean customerHold)
void | setCustomerId(java.lang.String customerId)
void | setCustomerName(java.lang.String customerName)
void | setDue1To30Total(java.math.BigDecimal due1To30Total)
void | setDue31To60Total(java.math.BigDecimal due31To60Total)
void | setDue61To90Total(java.math.BigDecimal due61To90Total)
void | setDue91Total(java.math.BigDecimal due91Total)
void | setTerms(java.lang.String terms)
void | setTotalBalance(java.math.BigDecimal totalBalance)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_CUSTOMERNAME

public static final java.lang.String ORDER_BY_CUSTOMERNAME
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values

ORDER_BY_TERMS

public static final java.lang.String ORDER_BY_TERMS
See Also:
Constant Field Values

ORDER_BY_CURRENT

public static final java.lang.String ORDER_BY_CURRENT
See Also:
Constant Field Values

ORDER_BY_DUE1TO30TOTAL

public static final java.lang.String ORDER_BY_DUE1TO30TOTAL
See Also:
Constant Field Values

ORDER_BY_DUE31TO60TOTAL

public static final java.lang.String ORDER_BY_DUE31TO60TOTAL
See Also:
Constant Field Values

ORDER_BY_DUE61TO90TOTAL

public static final java.lang.String ORDER_BY_DUE61TO90TOTAL
See Also:
Constant Field Values

ORDER_BY_DUE91TOTAL

public static final java.lang.String ORDER_BY_DUE91TOTAL
See Also:
Constant Field Values

ORDER_BY_TOTALBALANCE

public static final java.lang.String ORDER_BY_TOTALBALANCE
See Also:
Constant Field Values
Constructor Detail

CustomerStatementTotalResult

public CustomerStatementTotalResult()
Method Detail

getDue91Total

public java.math.BigDecimal getDue91Total()

getDue61To90Total

public java.math.BigDecimal getDue61To90Total()

getDue31To60Total

public java.math.BigDecimal getDue31To60Total()

getDue1To30Total

public java.math.BigDecimal getDue1To30Total()

getCurrent

public java.math.BigDecimal getCurrent()

getTotalBalance

public java.math.BigDecimal getTotalBalance()

getCurrency

public java.lang.String getCurrency()

getCustomerName

public java.lang.String getCustomerName()

setCustomerId

public void setCustomerId(java.lang.String customerId)

setDue91Total

public void setDue91Total(java.math.BigDecimal due91Total)

setDue61To90Total

public void setDue61To90Total(java.math.BigDecimal due61To90Total)

setDue31To60Total

public void setDue31To60Total(java.math.BigDecimal due31To60Total)

setDue1To30Total

public void setDue1To30Total(java.math.BigDecimal due1To30Total)

setCurrent

public void setCurrent(java.math.BigDecimal current)

setTotalBalance

public void setTotalBalance(java.math.BigDecimal totalBalance)

setCurrency

public void setCurrency(java.lang.String currency)

setCustomerName

public void setCustomerName(java.lang.String customerName)

getCustomerId

public java.lang.String getCustomerId()

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getAvgDaysToPay

public int getAvgDaysToPay()

setAvgDaysToPay

public void setAvgDaysToPay(int avgDaysToPay)

getAsOf

public java.util.Date getAsOf()

setAsOf

public void setAsOf(java.util.Date asOf)

getBillTo

public java.lang.String getBillTo()

setBillTo

public void setBillTo(java.lang.String billTo)

isCustomerHold

public boolean isCustomerHold()

setCustomerHold

public void setCustomerHold(boolean customerHold)

getCustomerCreditLimit

public java.math.BigDecimal getCustomerCreditLimit()

setCustomerCreditLimit

public void setCustomerCreditLimit(java.math.BigDecimal customerCreditLimit)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomerVendorAddressInfoVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomerVendorAddressInfoVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CustomerVendorAddressInfoVO
All Implemented Interfaces:
java.io.Serializable
public class CustomerVendorAddressInfoVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ADDRESS
static java.lang.String | ORDER_BY_ADDRESS2
static java.lang.String | ORDER_BY_CITY
static java.lang.String | ORDER_BY_COUNTRY
static java.lang.String | ORDER_BY_CREATEDATE
static java.lang.String | ORDER_BY_CRITICALLEVEL
static java.lang.String | ORDER_BY_CUSTOMERFLAG
static java.lang.String | ORDER_BY_CUSTOMERHOLD
static java.lang.String | ORDER_BY_FAX
static java.lang.String | ORDER_BY_ID
static java.lang.String | ORDER_BY_LASTCHANGEDATE
static java.lang.String | ORDER_BY_NAME
static java.lang.String | ORDER_BY_PHONE
static java.lang.String | ORDER_BY_QUALITYSTATUS
static java.lang.String | ORDER_BY_REGION
static java.lang.String | ORDER_BY_STATE
static java.lang.String | ORDER_BY_VALIDDATE
static java.lang.String | ORDER_BY_VENDORCATEGORY
static java.lang.String | ORDER_BY_VENDORFLAG
static java.lang.String | ORDER_BY_ZIP
Constructor Summary
CustomerVendorAddressInfoVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAddress()
java.lang.String | getAddress2()
java.lang.String | getBillTo()
java.lang.String | getCity()
java.lang.String | getComments()
java.lang.String | getCountry()
java.lang.String | getCountryCode()
java.util.Date | getCreateDate()
java.lang.String | getCriticalLevel()
java.lang.String | getCurrency()
java.lang.String | getCustomerFlag()
byte | getCustomerShippingDays()
java.lang.String | getDefaultAccount()
java.lang.String | getDepartmentAccount()
java.lang.String | getDepartmentDepositBank()
java.lang.String | getEmail()
java.lang.String | getFax()
java.lang.String | getId()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
int | getLastChangeTimes()
java.lang.String | getLastUser()
java.lang.String | getName()
java.lang.String | getOrigin()
java.lang.String | getParent()
java.lang.String | getPhone()
java.lang.String | getPhone2()
java.lang.String | getQualityStatus()
java.lang.String | getRegion()
java.lang.String | getRemitId()
java.lang.String | getSalesCodeId()
java.lang.String | getSalesTaxNumber()
java.lang.String | getShipTo()
java.lang.String | getState()
java.lang.String | getTaxId()
java.lang.String | getTaxPayerIDCode()
java.lang.String | getTaxType()
java.lang.String | getType()
java.util.Date | getValidDate()
java.lang.String | getVendorCategory()
java.lang.String | getVendorDepositBank()
java.lang.String | getVendorFlag()
java.lang.String | getVendorId()
byte | getVendorShippingDays()
java.lang.String | getWeightUnit()
java.lang.String | getZip()
int | hashCode()
boolean | isByInvoice()
boolean | isCustomerHold()
boolean | isDeleted()
boolean | isDutyFree()
boolean | isPrintInvoice()
boolean | isUseBackflush()
void | setAddress(java.lang.String address)
void | setAddress2(java.lang.String address2)
void | setBillTo(java.lang.String billTo)
void | setByInvoice(boolean byInvoice)
void | setCity(java.lang.String city)
void | setComments(java.lang.String comments)
void | setCountry(java.lang.String country)
void | setCountryCode(java.lang.String countryCode)
void | setCreateDate(java.util.Date createDate)
void | setCriticalLevel(java.lang.String criticalLevel)
void | setCurrency(java.lang.String currency)
void | setCustomerFlag(java.lang.String customerFlag)
void | setCustomerHold(boolean customerHold)
void | setCustomerShippingDays(byte customerShippingDays)
void | setDefaultAccount(java.lang.String defaultAccount)
void | setDeleted(boolean deleted)
void | setDepartmentAccount(java.lang.String departmentAccount)
void | setDepartmentDepositBank(java.lang.String departmentDepositBank)
void | setDutyFree(boolean dutyFree)
void | setEmail(java.lang.String email)
void | setFax(java.lang.String fax)
void | setId(java.lang.String id)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTimes(int lastChangeTimes)
void | setLastUser(java.lang.String lastUser)
void | setName(java.lang.String name)
void | setOrigin(java.lang.String origin)
void | setParent(java.lang.String parent)
void | setPhone(java.lang.String phone)
void | setPhone2(java.lang.String phone2)
void | setPrintInvoice(boolean printInvoice)
void | setQualityStatus(java.lang.String qualityStatus)
void | setRegion(java.lang.String region)
void | setRemitId(java.lang.String remitId)
void | setSalesCodeId(java.lang.String salesCodeId)
void | setSalesTaxNumber(java.lang.String salesTaxNumber)
void | setShipTo(java.lang.String shipTo)
void | setState(java.lang.String state)
void | setTaxId(java.lang.String taxId)
void | setTaxPayerIDCode(java.lang.String taxPayerIDCode)
void | setTaxType(java.lang.String taxType)
void | setType(java.lang.String type)
void | setUseBackflush(boolean useBackflush)
void | setValidDate(java.util.Date validDate)
void | setVendorCategory(java.lang.String vendorCategory)
void | setVendorDepositBank(java.lang.String vendorDepositBank)
void | setVendorFlag(java.lang.String vendorFlag)
void | setVendorId(java.lang.String vendorId)
void | setVendorShippingDays(byte vendorShippingDays)
void | setWeightUnit(java.lang.String weightUnit)
void | setZip(java.lang.String zip)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ID

public static final java.lang.String ORDER_BY_ID
See Also:
Constant Field Values

ORDER_BY_NAME

public static final java.lang.String ORDER_BY_NAME
See Also:
Constant Field Values

ORDER_BY_ADDRESS

public static final java.lang.String ORDER_BY_ADDRESS
See Also:
Constant Field Values

ORDER_BY_ADDRESS2

public static final java.lang.String ORDER_BY_ADDRESS2
See Also:
Constant Field Values

ORDER_BY_PHONE

public static final java.lang.String ORDER_BY_PHONE
See Also:
Constant Field Values

ORDER_BY_FAX

public static final java.lang.String ORDER_BY_FAX
See Also:
Constant Field Values

ORDER_BY_CITY

public static final java.lang.String ORDER_BY_CITY
See Also:
Constant Field Values

ORDER_BY_STATE

public static final java.lang.String ORDER_BY_STATE
See Also:
Constant Field Values

ORDER_BY_ZIP

public static final java.lang.String ORDER_BY_ZIP
See Also:
Constant Field Values

ORDER_BY_COUNTRY

public static final java.lang.String ORDER_BY_COUNTRY
See Also:
Constant Field Values

ORDER_BY_CUSTOMERFLAG

public static final java.lang.String ORDER_BY_CUSTOMERFLAG
See Also:
Constant Field Values

ORDER_BY_VENDORFLAG

public static final java.lang.String ORDER_BY_VENDORFLAG
See Also:
Constant Field Values

ORDER_BY_VENDORCATEGORY

public static final java.lang.String ORDER_BY_VENDORCATEGORY
See Also:
Constant Field Values

ORDER_BY_CRITICALLEVEL

public static final java.lang.String ORDER_BY_CRITICALLEVEL
See Also:
Constant Field Values

ORDER_BY_QUALITYSTATUS

public static final java.lang.String ORDER_BY_QUALITYSTATUS
See Also:
Constant Field Values

ORDER_BY_CREATEDATE

public static final java.lang.String ORDER_BY_CREATEDATE
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEDATE

public static final java.lang.String ORDER_BY_LASTCHANGEDATE
See Also:
Constant Field Values

ORDER_BY_CUSTOMERHOLD

public static final java.lang.String ORDER_BY_CUSTOMERHOLD
See Also:
Constant Field Values

ORDER_BY_VALIDDATE

public static final java.lang.String ORDER_BY_VALIDDATE
See Also:
Constant Field Values

ORDER_BY_REGION

public static final java.lang.String ORDER_BY_REGION
See Also:
Constant Field Values
Constructor Detail

CustomerVendorAddressInfoVO

public CustomerVendorAddressInfoVO()
Method Detail

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getLastUser

public java.lang.String getLastUser()

setLastUser

public void setLastUser(java.lang.String lastUser)

getLastChangeTimes

public int getLastChangeTimes()

setLastChangeTimes

public void setLastChangeTimes(int lastChangeTimes)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getAddress

public java.lang.String getAddress()

setAddress

public void setAddress(java.lang.String address)

getAddress2

public java.lang.String getAddress2()

setAddress2

public void setAddress2(java.lang.String address2)

getCity

public java.lang.String getCity()

setCity

public void setCity(java.lang.String city)

getState

public java.lang.String getState()

setState

public void setState(java.lang.String state)

getZip

public java.lang.String getZip()

setZip

public void setZip(java.lang.String zip)

getCountry

public java.lang.String getCountry()

setCountry

public void setCountry(java.lang.String country)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getWeightUnit

public java.lang.String getWeightUnit()

setWeightUnit

public void setWeightUnit(java.lang.String weightUnit)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getCountryCode

public java.lang.String getCountryCode()

setCountryCode

public void setCountryCode(java.lang.String countryCode)

getPhone

public java.lang.String getPhone()

setPhone

public void setPhone(java.lang.String phone)

getFax

public java.lang.String getFax()

setFax

public void setFax(java.lang.String fax)

getPhone2

public java.lang.String getPhone2()

setPhone2

public void setPhone2(java.lang.String phone2)

getEmail

public java.lang.String getEmail()

setEmail

public void setEmail(java.lang.String email)

getTaxId

public java.lang.String getTaxId()

setTaxId

public void setTaxId(java.lang.String taxId)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getCustomerShippingDays

public byte getCustomerShippingDays()

setCustomerShippingDays

public void setCustomerShippingDays(byte customerShippingDays)

getCustomerFlag

public java.lang.String getCustomerFlag()

setCustomerFlag

public void setCustomerFlag(java.lang.String customerFlag)

getVendorFlag

public java.lang.String getVendorFlag()

setVendorFlag

public void setVendorFlag(java.lang.String vendorFlag)

getLastChangeDate

public java.util.Date getLastChangeDate()

getRemitId

public java.lang.String getRemitId()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

setRemitId

public void setRemitId(java.lang.String remitId)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getCriticalLevel

public java.lang.String getCriticalLevel()

setCriticalLevel

public void setCriticalLevel(java.lang.String criticalLevel)

getQualityStatus

public java.lang.String getQualityStatus()

setQualityStatus

public void setQualityStatus(java.lang.String qualityStatus)

getVendorCategory

public java.lang.String getVendorCategory()

setVendorCategory

public void setVendorCategory(java.lang.String vendorCategory)

getVendorShippingDays

public byte getVendorShippingDays()

setVendorShippingDays

public void setVendorShippingDays(byte vendorShippingDays)

isDeleted

public boolean isDeleted()

setDeleted

public void setDeleted(boolean deleted)

getRegion

public java.lang.String getRegion()

setRegion

public void setRegion(java.lang.String region)

getType

public java.lang.String getType()

setType

public void setType(java.lang.String type)

getSalesCodeId

public java.lang.String getSalesCodeId()

setSalesCodeId

public void setSalesCodeId(java.lang.String salesCodeId)

getCreateDate

public java.util.Date getCreateDate()

setCreateDate

public void setCreateDate(java.util.Date createDate)

isCustomerHold

public boolean isCustomerHold()

setCustomerHold

public void setCustomerHold(boolean customerHold)

getValidDate

public java.util.Date getValidDate()

setValidDate

public void setValidDate(java.util.Date validDate)

isDutyFree

public boolean isDutyFree()

setDutyFree

public void setDutyFree(boolean dutyFree)

getSalesTaxNumber

public java.lang.String getSalesTaxNumber()

setSalesTaxNumber

public void setSalesTaxNumber(java.lang.String salesTaxNumber)

getShipTo

public java.lang.String getShipTo()

setShipTo

public void setShipTo(java.lang.String shipTo)

getBillTo

public java.lang.String getBillTo()

setBillTo

public void setBillTo(java.lang.String billTo)

isPrintInvoice

public boolean isPrintInvoice()

setPrintInvoice

public void setPrintInvoice(boolean printInvoice)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getParent

public java.lang.String getParent()

setParent

public void setParent(java.lang.String parent)

getTaxType

public java.lang.String getTaxType()

setTaxType

public void setTaxType(java.lang.String taxType)

getDepartmentAccount

public java.lang.String getDepartmentAccount()

setDepartmentAccount

public void setDepartmentAccount(java.lang.String departmentAccount)

getDepartmentDepositBank

public java.lang.String getDepartmentDepositBank()

setDepartmentDepositBank

public void setDepartmentDepositBank(java.lang.String departmentDepositBank)

getVendorDepositBank

public java.lang.String getVendorDepositBank()

setVendorDepositBank

public void setVendorDepositBank(java.lang.String vendorDepositBank)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getTaxPayerIDCode

public java.lang.String getTaxPayerIDCode()

setTaxPayerIDCode

public void setTaxPayerIDCode(java.lang.String taxPayerIDCode)

isUseBackflush

public boolean isUseBackflush()

setUseBackflush

public void setUseBackflush(boolean useBackflush)

getDefaultAccount

public java.lang.String getDefaultAccount()

setDefaultAccount

public void setDefaultAccount(java.lang.String defaultAccount)

isByInvoice

public boolean isByInvoice()

setByInvoice

public void setByInvoice(boolean byInvoice)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomerVendorAddressTotalInfo

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomerVendorAddressTotalInfo

java.lang.Object
    extended by  bb.common.CustomerVendorAddressTotalInfo
All Implemented Interfaces:
java.io.Serializable
public class CustomerVendorAddressTotalInfo
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CustomerVendorAddressTotalInfo()
Method Summary
java.math.BigDecimal | getAPCurrentBalance()
java.math.BigDecimal | getAPPaseDueBalance()
java.math.BigDecimal | getAPPaymentDue()
int | getAPPaymentDueDays()
java.math.BigDecimal | getAPPurchaseOrder12Months()
java.math.BigDecimal | getARCurrentBalance()
java.math.BigDecimal | getARPaseDueBalance()
java.math.BigDecimal | getARPaymentDue()
int | getARPaymentDueDays()
java.math.BigDecimal | getARSalesOrder12Months()
java.lang.String | getCurrency()
void | setAPCurrentBalance(java.math.BigDecimal currentBalance)
void | setAPPaseDueBalance(java.math.BigDecimal paseDueBalance)
void | setAPPaymentDue(java.math.BigDecimal paymentDue)
void | setAPPaymentDueDays(int paymentDueDays)
void | setAPPurchaseOrder12Months(java.math.BigDecimal purchaseOrder12Months)
void | setARCurrentBalance(java.math.BigDecimal currentBalance)
void | setARPaseDueBalance(java.math.BigDecimal paseDueBalance)
void | setARPaymentDue(java.math.BigDecimal paymentDue)
void | setARPaymentDueDays(int paymentDueDays)
void | setARSalesOrder12Months(java.math.BigDecimal salesOrder12Months)
void | setCurrency(java.lang.String currency)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CustomerVendorAddressTotalInfo

public CustomerVendorAddressTotalInfo()
Method Detail

getAPCurrentBalance

public java.math.BigDecimal getAPCurrentBalance()

setAPCurrentBalance

public void setAPCurrentBalance(java.math.BigDecimal currentBalance)

getAPPaseDueBalance

public java.math.BigDecimal getAPPaseDueBalance()

setAPPaseDueBalance

public void setAPPaseDueBalance(java.math.BigDecimal paseDueBalance)

getAPPaymentDue

public java.math.BigDecimal getAPPaymentDue()

setAPPaymentDue

public void setAPPaymentDue(java.math.BigDecimal paymentDue)

getAPPaymentDueDays

public int getAPPaymentDueDays()

setAPPaymentDueDays

public void setAPPaymentDueDays(int paymentDueDays)

getAPPurchaseOrder12Months

public java.math.BigDecimal getAPPurchaseOrder12Months()

setAPPurchaseOrder12Months

public void setAPPurchaseOrder12Months(java.math.BigDecimal purchaseOrder12Months)

getARCurrentBalance

public java.math.BigDecimal getARCurrentBalance()

setARCurrentBalance

public void setARCurrentBalance(java.math.BigDecimal currentBalance)

getARPaseDueBalance

public java.math.BigDecimal getARPaseDueBalance()

setARPaseDueBalance

public void setARPaseDueBalance(java.math.BigDecimal paseDueBalance)

getARPaymentDue

public java.math.BigDecimal getARPaymentDue()

setARPaymentDue

public void setARPaymentDue(java.math.BigDecimal paymentDue)

getARPaymentDueDays

public int getARPaymentDueDays()

setARPaymentDueDays

public void setARPaymentDueDays(int paymentDueDays)

getARSalesOrder12Months

public java.math.BigDecimal getARSalesOrder12Months()

setARSalesOrder12Months

public void setARSalesOrder12Months(java.math.BigDecimal salesOrder12Months)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomerVendorAddressVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomerVendorAddressVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CustomerVendorAddressVO
All Implemented Interfaces:
java.io.Serializable
public class CustomerVendorAddressVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CustomerVendorAddressVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAddress()
java.lang.String | getAddress2()
java.util.Set | getAddressQualityDocuments()
java.lang.String | getBillTo()
java.lang.String | getCity()
java.lang.String | getComments()
java.util.Set<CustomerVendorContactVO> | getContacts()
java.lang.String | getCountry()
java.lang.String | getCountryCode()
java.util.Date | getCreateDate()
java.lang.String | getCriticalLevel()
java.lang.String | getCurrency()
java.lang.String | getCustomerAccount()
java.lang.String | getCustomerCarrier()
java.lang.String | getCustomerCarrierAccount()
java.lang.String | getCustomerComments()
java.math.BigDecimal | getCustomerCreditLimit()
java.lang.String | getCustomerDepositBank()
java.math.BigDecimal | getCustomerDiscount()
java.lang.String | getCustomerFlag()
java.lang.String | getCustomerIncoterm()
java.lang.String | getCustomerIncotermPlacePort()
byte | getCustomerShippingDays()
java.lang.String | getCustomerShipVia()
java.lang.String | getCustomerTaxCode()
java.math.BigDecimal | getCustomerTaxRate()
java.lang.String | getCustomerTerms()
java.lang.String | getDefaultAccount()
java.lang.String | getDepartmentAccount()
java.lang.String | getDepartmentDepositBank()
java.lang.String | getEmail()
java.lang.String | getFax()
java.lang.String | getId()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
java.lang.String | getLastUser()
java.util.Set | getMultiDescription()
java.lang.String | getName()
java.lang.String | getOrigin()
java.lang.String | getParent()
java.lang.String | getPassword()
java.lang.String | getPhone()
java.lang.String | getPhone2()
java.lang.String | getQualityStatus()
java.lang.String | getRegion()
java.lang.String | getRemitId()
java.lang.String | getSalesman()
java.lang.String | getSalesTaxNumber()
java.lang.String | getShipTo()
java.lang.String | getSpecialCustomerCode()
java.lang.String | getSpecialVendorCode()
java.lang.String | getState()
java.lang.String | getTaxId()
java.lang.String | getTaxPayerIDCode()
java.lang.String | getTaxType()
java.lang.String | getTerritory()
java.lang.String | getType()
java.util.Date | getValidDate()
java.lang.String | getVendorCarrier()
java.lang.String | getVendorCarrierAccount()
java.lang.String | getVendorCategory()
java.lang.String | getVendorComments()
java.math.BigDecimal | getVendorCreditLimit()
java.lang.String | getVendorDepositBank()
java.math.BigDecimal | getVendorDiscount()
java.lang.String | getVendorFlag()
java.lang.String | getVendorId()
java.lang.String | getVendorIncoterm()
java.lang.String | getVendorIncotermPlacePort()
byte | getVendorShippingDays()
java.lang.String | getVendorShipVia()
java.math.BigDecimal | getVendorTaxRate()
java.lang.String | getVendorTerms()
java.lang.Integer | getVersion()
java.lang.String | getWebSite()
java.lang.String | getWeightUnit()
java.lang.String | getZip()
int | hashCode()
boolean | isByInvoice()
boolean | isCustomerHold()
boolean | isDeleted()
boolean | isDutyFree()
boolean | isPrintInvoice()
boolean | isUseBackflush()
boolean | isUseCTaxRate()
boolean | isUseVTaxRate()
void | setAddress(java.lang.String address)
void | setAddress2(java.lang.String address2)
void | setAddressQualityDocuments(java.util.Set addressQualityDocuments)
void | setBillTo(java.lang.String billTo)
void | setByInvoice(boolean byInvoice)
void | setCity(java.lang.String city)
void | setComments(java.lang.String comments)
void | setContacts(java.util.Set<CustomerVendorContactVO> contacts)
void | setCountry(java.lang.String country)
void | setCountryCode(java.lang.String countryCode)
void | setCreateDate(java.util.Date createDate)
void | setCriticalLevel(java.lang.String criticalLevel)
void | setCurrency(java.lang.String currency)
void | setCustomerAccount(java.lang.String customerAccount)
void | setCustomerCarrier(java.lang.String customerCarrier)
void | setCustomerCarrierAccount(java.lang.String customerCarrierAccount)
void | setCustomerComments(java.lang.String customerComments)
void | setCustomerCreditLimit(java.math.BigDecimal CustomerCreditLimit)
void | setCustomerDepositBank(java.lang.String customerDepositBank)
void | setCustomerDiscount(java.math.BigDecimal customerDiscount)
void | setCustomerFlag(java.lang.String c)
void | setCustomerHold(boolean customerHold)
void | setCustomerIncoterm(java.lang.String customerIncoterm)
void | setCustomerIncotermPlacePort(java.lang.String customerIncotermPlacePort)
void | setCustomerShippingDays(byte customerShippingDays)
void | setCustomerShipVia(java.lang.String customerShipVia)
void | setCustomerTaxCode(java.lang.String customerTaxCode)
void | setCustomerTaxRate(java.math.BigDecimal customerTaxRate)
void | setCustomerTerms(java.lang.String customerTerms)
void | setDefaultAccount(java.lang.String defaultAccount)
void | setDeleted(boolean deleted)
void | setDepartmentAccount(java.lang.String departmentAccount)
void | setDepartmentDepositBank(java.lang.String departmentDepositBank)
void | setDutyFree(boolean dutyFree)
void | setEmail(java.lang.String email)
void | setFax(java.lang.String fax)
void | setId(java.lang.String id)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastUser(java.lang.String lastUser)
void | setMultiDescription(java.util.Set multiDescription)
void | setName(java.lang.String name)
void | setOrigin(java.lang.String origin)
void | setParent(java.lang.String parent)
void | setPassword(java.lang.String password)
void | setPhone(java.lang.String phone)
void | setPhone2(java.lang.String phone2)
void | setPrintInvoice(boolean printInvoice)
void | setQualityStatus(java.lang.String qualityStatus)
void | setRegion(java.lang.String region)
void | setRemitId(java.lang.String remitId)
void | setSalesman(java.lang.String salesman)
void | setSalesTaxNumber(java.lang.String salesTaxNumber)
void | setShipTo(java.lang.String shipTo)
void | setSpecialCustomerCode(java.lang.String specialCustomerCode)
void | setSpecialVendorCode(java.lang.String specialVendorCode)
void | setState(java.lang.String state)
void | setTaxId(java.lang.String taxId)
void | setTaxPayerIDCode(java.lang.String taxPayerIDCode)
void | setTaxType(java.lang.String taxType)
void | setTerritory(java.lang.String territory)
void | setType(java.lang.String type)
void | setUseBackflush(boolean useBackflush)
void | setUseCTaxRate(boolean useCTaxRate)
void | setUseVTaxRate(boolean useVTaxRate)
void | setValidDate(java.util.Date validDate)
void | setVendorCarrier(java.lang.String vendorCarrier)
void | setVendorCarrierAccount(java.lang.String vendorCarrierAccount)
void | setVendorCategory(java.lang.String vendorCategory)
void | setVendorComments(java.lang.String vendorComments)
void | setVendorCreditLimit(java.math.BigDecimal vendorCreditLimit)
void | setVendorDepositBank(java.lang.String vendorDepositBank)
void | setVendorDiscount(java.math.BigDecimal vendorDiscount)
void | setVendorFlag(java.lang.String v)
void | setVendorId(java.lang.String vendorId)
void | setVendorIncoterm(java.lang.String vendorIncoterm)
void | setVendorIncotermPlacePort(java.lang.String vendorIncotermPlacePort)
void | setVendorShippingDays(byte vendorShippingDays)
void | setVendorShipVia(java.lang.String vendorShipVia)
void | setVendorTaxRate(java.math.BigDecimal vendorTaxRate)
void | setVendorTerms(java.lang.String vendorTerms)
void | setVersion(java.lang.Integer version)
void | setWebSite(java.lang.String webSite)
void | setWeightUnit(java.lang.String weightUnit)
void | setZip(java.lang.String zip)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CustomerVendorAddressVO

public CustomerVendorAddressVO()
Method Detail

getVendorDepositBank

public java.lang.String getVendorDepositBank()

setVendorDepositBank

public void setVendorDepositBank(java.lang.String vendorDepositBank)

getCustomerDepositBank

public java.lang.String getCustomerDepositBank()

setCustomerDepositBank

public void setCustomerDepositBank(java.lang.String customerDepositBank)

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getRemitId

public java.lang.String getRemitId()

setRemitId

public void setRemitId(java.lang.String remitId)

getLastUser

public java.lang.String getLastUser()

setLastUser

public void setLastUser(java.lang.String lastUser)

getCreateDate

public java.util.Date getCreateDate()

setCreateDate

public void setCreateDate(java.util.Date createDate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getAddress

public java.lang.String getAddress()

setAddress

public void setAddress(java.lang.String address)

getAddress2

public java.lang.String getAddress2()

setAddress2

public void setAddress2(java.lang.String address2)

getCity

public java.lang.String getCity()

setCity

public void setCity(java.lang.String city)

getState

public java.lang.String getState()

setState

public void setState(java.lang.String state)

getZip

public java.lang.String getZip()

setZip

public void setZip(java.lang.String zip)

getCountry

public java.lang.String getCountry()

setCountry

public void setCountry(java.lang.String country)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getWeightUnit

public java.lang.String getWeightUnit()

setWeightUnit

public void setWeightUnit(java.lang.String weightUnit)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getCountryCode

public java.lang.String getCountryCode()

setCountryCode

public void setCountryCode(java.lang.String countryCode)

getPhone

public java.lang.String getPhone()

setPhone

public void setPhone(java.lang.String phone)

getFax

public java.lang.String getFax()

setFax

public void setFax(java.lang.String fax)

getPhone2

public java.lang.String getPhone2()

setPhone2

public void setPhone2(java.lang.String phone2)

getEmail

public java.lang.String getEmail()

setEmail

public void setEmail(java.lang.String email)

getWebSite

public java.lang.String getWebSite()

setWebSite

public void setWebSite(java.lang.String webSite)

getTaxId

public java.lang.String getTaxId()

setTaxId

public void setTaxId(java.lang.String taxId)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getSalesman

public java.lang.String getSalesman()

setSalesman

public void setSalesman(java.lang.String salesman)

getTerritory

public java.lang.String getTerritory()

setTerritory

public void setTerritory(java.lang.String territory)

getRegion

public java.lang.String getRegion()

setRegion

public void setRegion(java.lang.String region)

getCustomerShippingDays

public byte getCustomerShippingDays()

setCustomerShippingDays

public void setCustomerShippingDays(byte customerShippingDays)

getCustomerFlag

public java.lang.String getCustomerFlag()

setCustomerFlag

public void setCustomerFlag(java.lang.String c)

getCustomerAccount

public java.lang.String getCustomerAccount()

setCustomerAccount

public void setCustomerAccount(java.lang.String customerAccount)

getCustomerShipVia

public java.lang.String getCustomerShipVia()

setCustomerShipVia

public void setCustomerShipVia(java.lang.String customerShipVia)

getCustomerCarrier

public java.lang.String getCustomerCarrier()

setCustomerCarrier

public void setCustomerCarrier(java.lang.String customerCarrier)

getCustomerCarrierAccount

public java.lang.String getCustomerCarrierAccount()

setCustomerCarrierAccount

public void setCustomerCarrierAccount(java.lang.String customerCarrierAccount)

getCustomerIncoterm

public java.lang.String getCustomerIncoterm()

setCustomerIncoterm

public void setCustomerIncoterm(java.lang.String customerIncoterm)

getCustomerIncotermPlacePort

public java.lang.String getCustomerIncotermPlacePort()

setCustomerIncotermPlacePort

public void setCustomerIncotermPlacePort(java.lang.String customerIncotermPlacePort)

getCustomerTerms

public java.lang.String getCustomerTerms()

setCustomerTerms

public void setCustomerTerms(java.lang.String customerTerms)

getCustomerDiscount

public java.math.BigDecimal getCustomerDiscount()

setCustomerDiscount

public void setCustomerDiscount(java.math.BigDecimal customerDiscount)

getCustomerTaxCode

public java.lang.String getCustomerTaxCode()

setCustomerTaxCode

public void setCustomerTaxCode(java.lang.String customerTaxCode)

getCustomerTaxRate

public java.math.BigDecimal getCustomerTaxRate()

setCustomerTaxRate

public void setCustomerTaxRate(java.math.BigDecimal customerTaxRate)

getCustomerCreditLimit

public java.math.BigDecimal getCustomerCreditLimit()

setCustomerCreditLimit

public void setCustomerCreditLimit(java.math.BigDecimal CustomerCreditLimit)

getCustomerComments

public java.lang.String getCustomerComments()

setCustomerComments

public void setCustomerComments(java.lang.String customerComments)

getVendorFlag

public java.lang.String getVendorFlag()

setVendorFlag

public void setVendorFlag(java.lang.String v)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getVendorShipVia

public java.lang.String getVendorShipVia()

setVendorShipVia

public void setVendorShipVia(java.lang.String vendorShipVia)

getVendorCarrier

public java.lang.String getVendorCarrier()

setVendorCarrier

public void setVendorCarrier(java.lang.String vendorCarrier)

getVendorCarrierAccount

public java.lang.String getVendorCarrierAccount()

setVendorCarrierAccount

public void setVendorCarrierAccount(java.lang.String vendorCarrierAccount)

getVendorIncoterm

public java.lang.String getVendorIncoterm()

setVendorIncoterm

public void setVendorIncoterm(java.lang.String vendorIncoterm)

getVendorIncotermPlacePort

public java.lang.String getVendorIncotermPlacePort()

setVendorIncotermPlacePort

public void setVendorIncotermPlacePort(java.lang.String vendorIncotermPlacePort)

getVendorTerms

public java.lang.String getVendorTerms()

setVendorTerms

public void setVendorTerms(java.lang.String vendorTerms)

getVendorDiscount

public java.math.BigDecimal getVendorDiscount()

setVendorDiscount

public void setVendorDiscount(java.math.BigDecimal vendorDiscount)

getVendorTaxRate

public java.math.BigDecimal getVendorTaxRate()

setVendorTaxRate

public void setVendorTaxRate(java.math.BigDecimal vendorTaxRate)

getVendorCreditLimit

public java.math.BigDecimal getVendorCreditLimit()

setVendorCreditLimit

public void setVendorCreditLimit(java.math.BigDecimal vendorCreditLimit)

getVendorComments

public java.lang.String getVendorComments()

setVendorComments

public void setVendorComments(java.lang.String vendorComments)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getContacts

public java.util.Set<CustomerVendorContactVO> getContacts()

setContacts

public void setContacts(java.util.Set<CustomerVendorContactVO> contacts)

getMultiDescription

public java.util.Set getMultiDescription()

getVersion

public java.lang.Integer getVersion()

getSpecialVendorCode

public java.lang.String getSpecialVendorCode()

getSpecialCustomerCode

public java.lang.String getSpecialCustomerCode()

setMultiDescription

public void setMultiDescription(java.util.Set multiDescription)

setVersion

public void setVersion(java.lang.Integer version)

setSpecialVendorCode

public void setSpecialVendorCode(java.lang.String specialVendorCode)

setSpecialCustomerCode

public void setSpecialCustomerCode(java.lang.String specialCustomerCode)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getCriticalLevel

public java.lang.String getCriticalLevel()

setCriticalLevel

public void setCriticalLevel(java.lang.String criticalLevel)

getQualityStatus

public java.lang.String getQualityStatus()

setQualityStatus

public void setQualityStatus(java.lang.String qualityStatus)

getVendorCategory

public java.lang.String getVendorCategory()

setVendorCategory

public void setVendorCategory(java.lang.String vendorCategory)

getVendorShippingDays

public byte getVendorShippingDays()

setVendorShippingDays

public void setVendorShippingDays(byte vendorShippingDays)

isUseCTaxRate

public boolean isUseCTaxRate()

setUseCTaxRate

public void setUseCTaxRate(boolean useCTaxRate)

isUseVTaxRate

public boolean isUseVTaxRate()

setUseVTaxRate

public void setUseVTaxRate(boolean useVTaxRate)

getAddressQualityDocuments

public java.util.Set getAddressQualityDocuments()

setAddressQualityDocuments

public void setAddressQualityDocuments(java.util.Set addressQualityDocuments)

isCustomerHold

public boolean isCustomerHold()

setCustomerHold

public void setCustomerHold(boolean customerHold)

isDeleted

public boolean isDeleted()

setDeleted

public void setDeleted(boolean deleted)

getType

public java.lang.String getType()

setType

public void setType(java.lang.String type)

getPassword

public java.lang.String getPassword()

setPassword

public void setPassword(java.lang.String password)

isDutyFree

public boolean isDutyFree()

setDutyFree

public void setDutyFree(boolean dutyFree)

getValidDate

public java.util.Date getValidDate()

setValidDate

public void setValidDate(java.util.Date validDate)

getSalesTaxNumber

public java.lang.String getSalesTaxNumber()

setSalesTaxNumber

public void setSalesTaxNumber(java.lang.String salesTaxNumber)

getShipTo

public java.lang.String getShipTo()

setShipTo

public void setShipTo(java.lang.String shipTo)

getBillTo

public java.lang.String getBillTo()

setBillTo

public void setBillTo(java.lang.String billTo)

isPrintInvoice

public boolean isPrintInvoice()

setPrintInvoice

public void setPrintInvoice(boolean printInvoice)

getParent

public java.lang.String getParent()

setParent

public void setParent(java.lang.String parent)

getTaxType

public java.lang.String getTaxType()

setTaxType

public void setTaxType(java.lang.String taxType)

getDepartmentAccount

public java.lang.String getDepartmentAccount()

setDepartmentAccount

public void setDepartmentAccount(java.lang.String departmentAccount)

getDepartmentDepositBank

public java.lang.String getDepartmentDepositBank()

setDepartmentDepositBank

public void setDepartmentDepositBank(java.lang.String departmentDepositBank)

getTaxPayerIDCode

public java.lang.String getTaxPayerIDCode()

setTaxPayerIDCode

public void setTaxPayerIDCode(java.lang.String taxPayerIDCode)

isUseBackflush

public boolean isUseBackflush()

setUseBackflush

public void setUseBackflush(boolean useBackflush)

getDefaultAccount

public java.lang.String getDefaultAccount()

setDefaultAccount

public void setDefaultAccount(java.lang.String defaultAccount)

isByInvoice

public boolean isByInvoice()

setByInvoice

public void setByInvoice(boolean byInvoice)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomerVendorContactPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomerVendorContactPK

java.lang.Object
    extended by  bb.common.CustomerVendorContactPK
All Implemented Interfaces:
java.io.Serializable
public class CustomerVendorContactPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
CustomerVendorContactPK()
default constructor
CustomerVendorContactPK(java.lang.String id, java.lang.Short item)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getId()
java.lang.Short | getItem()
int | hashCode()
void | setId(java.lang.String id)
void | setItem(java.lang.Short item)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CustomerVendorContactPK

public CustomerVendorContactPK(java.lang.String id,
                               java.lang.Short item)
full constructor

CustomerVendorContactPK

public CustomerVendorContactPK()
default constructor

Method Detail

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getItem

public java.lang.Short getItem()

setItem

public void setItem(java.lang.Short item)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomerVendorContactVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomerVendorContactVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CustomerVendorContactVO
All Implemented Interfaces:
java.io.Serializable
public class CustomerVendorContactVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CustomerVendorContactVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.lang.String | getEmail()
java.lang.String | getFax()
java.lang.String | getMobile()
java.lang.String | getName()
java.lang.String | getPhone()
CustomerVendorContactPK | getPk()
java.lang.String | getTitle()
java.lang.String | getType()
int | hashCode()
boolean | isAccountingMail()
boolean | isPoMail()
boolean | isQtMail()
boolean | isRfqMail()
boolean | isSoMail()
void | setAccountingMail(boolean accountingMail)
void | setComments(java.lang.String comments)
void | setEmail(java.lang.String email)
void | setFax(java.lang.String fax)
void | setMobile(java.lang.String mobile)
void | setName(java.lang.String name)
void | setPhone(java.lang.String phone)
void | setPk(CustomerVendorContactPK pk)
void | setPoMail(boolean poMail)
void | setQtMail(boolean qtMail)
void | setRfqMail(boolean rfqMail)
void | setSoMail(boolean soMail)
void | setTitle(java.lang.String title)
void | setType(java.lang.String type)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CustomerVendorContactVO

public CustomerVendorContactVO()
Method Detail

isAccountingMail

public boolean isAccountingMail()

setAccountingMail

public void setAccountingMail(boolean accountingMail)

isPoMail

public boolean isPoMail()

setPoMail

public void setPoMail(boolean poMail)

isQtMail

public boolean isQtMail()

setQtMail

public void setQtMail(boolean qtMail)

isRfqMail

public boolean isRfqMail()

setRfqMail

public void setRfqMail(boolean rfqMail)

isSoMail

public boolean isSoMail()

setSoMail

public void setSoMail(boolean soMail)

getPk

public CustomerVendorContactPK getPk()

setPk

public void setPk(CustomerVendorContactPK pk)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getPhone

public java.lang.String getPhone()

setPhone

public void setPhone(java.lang.String phone)

getMobile

public java.lang.String getMobile()

setMobile

public void setMobile(java.lang.String mobile)

getFax

public java.lang.String getFax()

setFax

public void setFax(java.lang.String fax)

getEmail

public java.lang.String getEmail()

setEmail

public void setEmail(java.lang.String email)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getType

public java.lang.String getType()

setType

public void setType(java.lang.String type)

getTitle

public java.lang.String getTitle()

setTitle

public void setTitle(java.lang.String title)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomerVendorDescriptionPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomerVendorDescriptionPK

java.lang.Object
    extended by  bb.common.CustomerVendorDescriptionPK
All Implemented Interfaces:
java.io.Serializable
public class CustomerVendorDescriptionPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
CustomerVendorDescriptionPK()
default constructor
CustomerVendorDescriptionPK(java.lang.String id, java.lang.String language)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getId()
java.lang.String | getLanguage()
int | hashCode()
void | setId(java.lang.String id)
void | setLanguage(java.lang.String language)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CustomerVendorDescriptionPK

public CustomerVendorDescriptionPK(java.lang.String id,
                                   java.lang.String language)
full constructor

CustomerVendorDescriptionPK

public CustomerVendorDescriptionPK()
default constructor

Method Detail

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomerVendorDescriptionVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomerVendorDescriptionVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CustomerVendorDescriptionVO
All Implemented Interfaces:
java.io.Serializable
public class CustomerVendorDescriptionVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CustomerVendorDescriptionVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAddressOne()
java.lang.String | getAddressTwo()
java.lang.String | getCity()
java.lang.String | getCountry()
java.lang.String | getName()
CustomerVendorDescriptionPK | getPk()
java.lang.String | getState()
java.lang.String | getStatus()
java.lang.String | getZip()
int | hashCode()
void | setAddressOne(java.lang.String addressOne)
void | setAddressTwo(java.lang.String addressTwo)
void | setCity(java.lang.String city)
void | setCountry(java.lang.String country)
void | setName(java.lang.String name)
void | setPk(CustomerVendorDescriptionPK pk)
void | setState(java.lang.String state)
void | setStatus(java.lang.String status)
void | setZip(java.lang.String zip)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CustomerVendorDescriptionVO

public CustomerVendorDescriptionVO()
Method Detail

getPk

public CustomerVendorDescriptionPK getPk()

setPk

public void setPk(CustomerVendorDescriptionPK pk)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getAddressOne

public java.lang.String getAddressOne()

setAddressOne

public void setAddressOne(java.lang.String addressOne)

getAddressTwo

public java.lang.String getAddressTwo()

setAddressTwo

public void setAddressTwo(java.lang.String addressTwo)

getCity

public java.lang.String getCity()

setCity

public void setCity(java.lang.String city)

getState

public java.lang.String getState()

setState

public void setState(java.lang.String state)

getZip

public java.lang.String getZip()

setZip

public void setZip(java.lang.String zip)

getCountry

public java.lang.String getCountry()

setCountry

public void setCountry(java.lang.String country)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomerVendorTypeVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomerVendorTypeVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CustomerVendorTypeVO
All Implemented Interfaces:
java.io.Serializable
public class CustomerVendorTypeVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CustomerVendorTypeVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.lang.String | getCustomerType()
java.lang.Integer | getIi()
java.lang.String | getVendorType()
int | hashCode()
void | setComments(java.lang.String comments)
void | setCustomerType(java.lang.String customerType)
void | setIi(java.lang.Integer ii)
void | setVendorType(java.lang.String vendorType)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CustomerVendorTypeVO

public CustomerVendorTypeVO()
Method Detail

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

setIi

public void setIi(java.lang.Integer ii)

getIi

public java.lang.Integer getIi()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getCustomerType

public java.lang.String getCustomerType()

setCustomerType

public void setCustomerType(java.lang.String customerType)

getVendorType

public java.lang.String getVendorType()

setVendorType

public void setVendorType(java.lang.String vendorType)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomGoodsBreedVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomGoodsBreedVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CustomGoodsBreedVO
All Implemented Interfaces:
java.io.Serializable
public class CustomGoodsBreedVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACTIVE
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_ID
static java.lang.String | ORDER_BY_NAME
static java.lang.String | ORDER_BY_UNIT
Constructor Summary
CustomGoodsBreedVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.lang.String | getId()
java.lang.String | getName()
java.lang.String | getUnit()
int | hashCode()
boolean | isActive()
void | setActive(boolean active)
void | setComments(java.lang.String comments)
void | setId(java.lang.String id)
void | setName(java.lang.String name)
void | setUnit(java.lang.String unit)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ID

public static final java.lang.String ORDER_BY_ID
See Also:
Constant Field Values

ORDER_BY_NAME

public static final java.lang.String ORDER_BY_NAME
See Also:
Constant Field Values

ORDER_BY_ACTIVE

public static final java.lang.String ORDER_BY_ACTIVE
See Also:
Constant Field Values

ORDER_BY_UNIT

public static final java.lang.String ORDER_BY_UNIT
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values
Constructor Detail

CustomGoodsBreedVO

public CustomGoodsBreedVO()
Method Detail

isActive

public boolean isActive()

setActive

public void setActive(boolean active)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomGoodsRecordVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomGoodsRecordVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CustomGoodsRecordVO
All Implemented Interfaces:
java.io.Serializable
public class CustomGoodsRecordVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_EMPLOYEEID
static java.lang.String | ORDER_BY_GOODSID
Constructor Summary
CustomGoodsRecordVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getEmployeeId()
java.lang.String | getGoodsId()
java.lang.Long | getIi()
java.util.Date | getPutDate()
int | hashCode()
void | setEmployeeId(java.lang.String employeeId)
void | setGoodsId(java.lang.String goodsId)
void | setIi(java.lang.Long ii)
void | setPutDate(java.util.Date putDate)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_GOODSID

public static final java.lang.String ORDER_BY_GOODSID
See Also:
Constant Field Values

ORDER_BY_EMPLOYEEID

public static final java.lang.String ORDER_BY_EMPLOYEEID
See Also:
Constant Field Values
Constructor Detail

CustomGoodsRecordVO

public CustomGoodsRecordVO()
Method Detail

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getGoodsId

public java.lang.String getGoodsId()

setGoodsId

public void setGoodsId(java.lang.String goodsId)

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getPutDate

public java.util.Date getPutDate()

setPutDate

public void setPutDate(java.util.Date putDate)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomJobCategoryGoodsPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomJobCategoryGoodsPK

java.lang.Object
    extended by  bb.common.CustomJobCategoryGoodsPK
All Implemented Interfaces:
java.io.Serializable
public class CustomJobCategoryGoodsPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CustomJobCategoryGoodsPK()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getGoodsId()
java.lang.String | getJobId()
int | hashCode()
void | setGoodsId(java.lang.String goodsId)
void | setJobId(java.lang.String jobId)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CustomJobCategoryGoodsPK

public CustomJobCategoryGoodsPK()
Method Detail

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getGoodsId

public java.lang.String getGoodsId()

setGoodsId

public void setGoodsId(java.lang.String goodsId)

getJobId

public java.lang.String getJobId()

setJobId

public void setJobId(java.lang.String jobId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomJobCategoryGoodsVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomJobCategoryGoodsVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CustomJobCategoryGoodsVO
All Implemented Interfaces:
java.io.Serializable
public class CustomJobCategoryGoodsVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CustomJobCategoryGoodsVO()
Method Summary
boolean | equals(java.lang.Object other)
int | getFrequency()
CustomJobCategoryGoodsPK | getPk()
int | hashCode()
void | setFrequency(int frequency)
void | setPk(CustomJobCategoryGoodsPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CustomJobCategoryGoodsVO

public CustomJobCategoryGoodsVO()
Method Detail

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getFrequency

public int getFrequency()

setFrequency

public void setFrequency(int frequency)

getPk

public CustomJobCategoryGoodsPK getPk()

setPk

public void setPk(CustomJobCategoryGoodsPK pk)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomJobCategoryVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomJobCategoryVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CustomJobCategoryVO
All Implemented Interfaces:
java.io.Serializable
public class CustomJobCategoryVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_ID
static java.lang.String | ORDER_BY_NAME
Constructor Summary
CustomJobCategoryVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.util.Set | getCustomJobCategoryGoods()
java.lang.String | getId()
java.lang.String | getName()
int | hashCode()
void | setComments(java.lang.String comments)
void | setCustomJobCategoryGoods(java.util.Set customJobCategoryGoods)
void | setId(java.lang.String id)
void | setName(java.lang.String name)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ID

public static final java.lang.String ORDER_BY_ID
See Also:
Constant Field Values

ORDER_BY_NAME

public static final java.lang.String ORDER_BY_NAME
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values
Constructor Detail

CustomJobCategoryVO

public CustomJobCategoryVO()
Method Detail

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getCustomJobCategoryGoods

public java.util.Set getCustomJobCategoryGoods()

setCustomJobCategoryGoods

public void setCustomJobCategoryGoods(java.util.Set customJobCategoryGoods)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomSearchVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomSearchVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CustomSearchVO
All Implemented Interfaces:
java.io.Serializable
public class CustomSearchVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CustomSearchVO()
CustomSearchVO(java.lang.String id, java.lang.String name)
Method Summary
boolean | equals(java.lang.Object obj)
java.lang.String | getId()
java.lang.String | getModule()
java.lang.String | getName()
java.lang.String | getXml()
int | hashCode()
void | setId(java.lang.String id)
void | setModule(java.lang.String module)
void | setName(java.lang.String name)
void | setXml(java.lang.String xml)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CustomSearchVO

public CustomSearchVO()

CustomSearchVO

public CustomSearchVO(java.lang.String id,
                      java.lang.String name)
Method Detail

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getXml

public java.lang.String getXml()

setXml

public void setXml(java.lang.String xml)

getModule

public java.lang.String getModule()

setModule

public void setModule(java.lang.String module)

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomTranslationVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CustomTranslationVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CustomTranslationVO
All Implemented Interfaces:
java.io.Serializable
public class CustomTranslationVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CustomTranslationVO()
Method Summary
boolean | equals(java.lang.Object obj)
java.lang.String | getCustomTranslation()
java.lang.String | getId()
java.lang.String | getOriginalTranslation()
int | hashCode()
void | setCustomTranslation(java.lang.String customTranslation)
void | setId(java.lang.String id)
void | setOriginalTranslation(java.lang.String originalTranslation)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CustomTranslationVO

public CustomTranslationVO()
Method Detail

getCustomTranslation

public java.lang.String getCustomTranslation()

setCustomTranslation

public void setCustomTranslation(java.lang.String customTranslation)

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getOriginalTranslation

public java.lang.String getOriginalTranslation()

setOriginalTranslation

public void setOriginalTranslation(java.lang.String originalTranslation)

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CV2CVAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CV2CVAgent

java.lang.Object
    extended by  bb.common.CV2CVAgent
All Implemented Interfaces:
java.io.Serializable
public class CV2CVAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CV2CVAgent()
Method Summary
java.lang.String | getId()
java.lang.String | getName()
java.lang.String | getOldId()
java.lang.String | getType()
void | setId(java.lang.String id)
void | setName(java.lang.String name)
void | setOldId(java.lang.String oldId)
void | setType(java.lang.String type)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CV2CVAgent

public CV2CVAgent()
Method Detail

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getOldId

public java.lang.String getOldId()

setOldId

public void setOldId(java.lang.String oldId)

getType

public java.lang.String getType()

setType

public void setType(java.lang.String type)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CycleCountAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CycleCountAgent

java.lang.Object
    extended by  bb.common.CycleCountAgent
All Implemented Interfaces:
java.io.Serializable
public class CycleCountAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CycleCountAgent()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getLocation()
java.math.BigDecimal | getPhysicalCount()
CycleCountPK | getPk()
int | hashCode()
void | setLocation(java.lang.String location)
void | setPhysicalCount(java.math.BigDecimal physicalCount)
void | setPk(CycleCountPK pk)
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CycleCountAgent

public CycleCountAgent()
Method Detail

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getPhysicalCount

public java.math.BigDecimal getPhysicalCount()

setPhysicalCount

public void setPhysicalCount(java.math.BigDecimal physicalCount)

getPk

public CycleCountPK getPk()

setPk

public void setPk(CycleCountPK pk)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CycleCountListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CycleCountListResult

java.lang.Object
    extended by  bb.common.CycleCountListResult
All Implemented Interfaces:
java.io.Serializable
public class CycleCountListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AVGCOST
static java.lang.String | ORDER_BY_COMMITTED
static java.lang.String | ORDER_BY_COUNTEDBY
static java.lang.String | ORDER_BY_COUNTEDDATE
static java.lang.String | ORDER_BY_DIFFCOUNT
static java.lang.String | ORDER_BY_LOCATION
static java.lang.String | ORDER_BY_NEWONHAND
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PK
static java.lang.String | ORDER_BY_STARTDATE
static java.lang.String | ORDER_BY_SYSTEMONHAND
Constructor Summary
CycleCountListResult()
Method Summary
java.math.BigDecimal | getAvgCost()
java.lang.String | getCountedBy()
java.util.Date | getCountedDate()
java.lang.String | getDescription()
java.math.BigDecimal | getDiffcount()
java.lang.String | getLocation()
java.lang.String | getNewLocation()
java.math.BigDecimal | getNewOnhand()
java.lang.String | getPartClass()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
CycleCountPK | getPk()
java.util.Date | getStartDate()
java.math.BigDecimal | getSystemOnhand()
java.lang.String | getUnit()
boolean | isCommitted()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setCommitted(boolean committed)
void | setCountedBy(java.lang.String countedBy)
void | setCountedDate(java.util.Date countedDate)
void | setDescription(java.lang.String description)
void | setDiffcount(java.math.BigDecimal diffcount)
void | setLocation(java.lang.String location)
void | setNewLocation(java.lang.String newLocation)
void | setNewOnhand(java.math.BigDecimal newOnhand)
void | setPartClass(java.lang.String partClass)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(CycleCountPK pk)
void | setStartDate(java.util.Date startDate)
void | setSystemOnhand(java.math.BigDecimal systemOnhand)
void | setUnit(java.lang.String unit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PK

public static final java.lang.String ORDER_BY_PK
See Also:
Constant Field Values

ORDER_BY_STARTDATE

public static final java.lang.String ORDER_BY_STARTDATE
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_LOCATION

public static final java.lang.String ORDER_BY_LOCATION
See Also:
Constant Field Values

ORDER_BY_SYSTEMONHAND

public static final java.lang.String ORDER_BY_SYSTEMONHAND
See Also:
Constant Field Values

ORDER_BY_NEWONHAND

public static final java.lang.String ORDER_BY_NEWONHAND
See Also:
Constant Field Values

ORDER_BY_DIFFCOUNT

public static final java.lang.String ORDER_BY_DIFFCOUNT
See Also:
Constant Field Values

ORDER_BY_COMMITTED

public static final java.lang.String ORDER_BY_COMMITTED
See Also:
Constant Field Values

ORDER_BY_AVGCOST

public static final java.lang.String ORDER_BY_AVGCOST
See Also:
Constant Field Values

ORDER_BY_COUNTEDBY

public static final java.lang.String ORDER_BY_COUNTEDBY
See Also:
Constant Field Values

ORDER_BY_COUNTEDDATE

public static final java.lang.String ORDER_BY_COUNTEDDATE
See Also:
Constant Field Values
Constructor Detail

CycleCountListResult

public CycleCountListResult()
Method Detail

setPk

public void setPk(CycleCountPK pk)

getPartClass

public java.lang.String getPartClass()

setPartClass

public void setPartClass(java.lang.String partClass)

setStartDate

public void setStartDate(java.util.Date startDate)

setPartNumber

public void setPartNumber(java.lang.String partNumber)

setPartType

public void setPartType(java.lang.String partType)

setUnit

public void setUnit(java.lang.String unit)

setDescription

public void setDescription(java.lang.String description)

setLocation

public void setLocation(java.lang.String location)

setSystemOnhand

public void setSystemOnhand(java.math.BigDecimal systemOnhand)

setNewOnhand

public void setNewOnhand(java.math.BigDecimal newOnhand)

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

setCountedBy

public void setCountedBy(java.lang.String countedBy)

setCountedDate

public void setCountedDate(java.util.Date countedDate)

getPk

public CycleCountPK getPk()

getStartDate

public java.util.Date getStartDate()

getPartNumber

public java.lang.String getPartNumber()

getPartType

public java.lang.String getPartType()

getUnit

public java.lang.String getUnit()

getDescription

public java.lang.String getDescription()

getLocation

public java.lang.String getLocation()

getSystemOnhand

public java.math.BigDecimal getSystemOnhand()

getNewOnhand

public java.math.BigDecimal getNewOnhand()

getAvgCost

public java.math.BigDecimal getAvgCost()

getCountedBy

public java.lang.String getCountedBy()

getCountedDate

public java.util.Date getCountedDate()

isCommitted

public boolean isCommitted()

setCommitted

public void setCommitted(boolean committed)

getDiffcount

public java.math.BigDecimal getDiffcount()

setDiffcount

public void setDiffcount(java.math.BigDecimal diffcount)

getNewLocation

public java.lang.String getNewLocation()

setNewLocation

public void setNewLocation(java.lang.String newLocation)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CycleCountListTotalResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CycleCountListTotalResult

java.lang.Object
    extended by  bb.common.CycleCountListTotalResult
All Implemented Interfaces:
java.io.Serializable
public class CycleCountListTotalResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CycleCountListTotalResult()
Method Summary
java.math.BigDecimal | getTotNewCost()
java.math.BigDecimal | getTotNewOnhand()
java.math.BigDecimal | getTotSystemCost()
java.math.BigDecimal | getTotSystemOnhand()
void | setTotNewCost(java.math.BigDecimal totNewCost)
void | setTotNewOnhand(java.math.BigDecimal totNewOnhand)
void | setTotSystemCost(java.math.BigDecimal totSystemCost)
void | setTotSystemOnhand(java.math.BigDecimal totSystemOnhand)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CycleCountListTotalResult

public CycleCountListTotalResult()
Method Detail

getTotSystemOnhand

public java.math.BigDecimal getTotSystemOnhand()

setTotSystemOnhand

public void setTotSystemOnhand(java.math.BigDecimal totSystemOnhand)

getTotNewOnhand

public java.math.BigDecimal getTotNewOnhand()

setTotNewOnhand

public void setTotNewOnhand(java.math.BigDecimal totNewOnhand)

getTotSystemCost

public java.math.BigDecimal getTotSystemCost()

setTotSystemCost

public void setTotSystemCost(java.math.BigDecimal totSystemCost)

getTotNewCost

public java.math.BigDecimal getTotNewCost()

setTotNewCost

public void setTotNewCost(java.math.BigDecimal totNewCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CycleCountPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CycleCountPK

java.lang.Object
    extended by  bb.common.CycleCountPK
All Implemented Interfaces:
java.io.Serializable
public class CycleCountPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CycleCountPK()
default constructor
CycleCountPK(java.lang.Integer workSheetNumber, java.lang.Integer pageNumber, java.lang.Integer rowNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Integer | getPageNumber()
java.lang.Integer | getRowNumber()
java.lang.Integer | getWorkSheetNumber()
int | hashCode()
void | setPageNumber(java.lang.Integer pageNumber)
void | setRowNumber(java.lang.Integer rowNumber)
void | setWorkSheetNumber(java.lang.Integer workSheetNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CycleCountPK

public CycleCountPK(java.lang.Integer workSheetNumber,
                    java.lang.Integer pageNumber,
                    java.lang.Integer rowNumber)
full constructor

CycleCountPK

public CycleCountPK()
default constructor

Method Detail

getWorkSheetNumber

public java.lang.Integer getWorkSheetNumber()

setWorkSheetNumber

public void setWorkSheetNumber(java.lang.Integer workSheetNumber)

getPageNumber

public java.lang.Integer getPageNumber()

setPageNumber

public void setPageNumber(java.lang.Integer pageNumber)

getRowNumber

public java.lang.Integer getRowNumber()

setRowNumber

public void setRowNumber(java.lang.Integer rowNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CycleCountStatusVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CycleCountStatusVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CycleCountStatusVO
All Implemented Interfaces:
java.io.Serializable
public class CycleCountStatusVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CycleCountStatusVO()
Method Summary
java.util.Date | getCreateDate()
java.lang.String | getCreator()
java.lang.String | getDescription()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getPartClass()
java.lang.String | getStatus()
int | getTotalPages()
java.lang.Integer | getWorkSheetNumber()
void | setCreateDate(java.util.Date createDate)
void | setCreator(java.lang.String creator)
void | setDescription(java.lang.String description)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setPartClass(java.lang.String partClass)
void | setStatus(java.lang.String status)
void | setTotalPages(int totalPages)
void | setWorkSheetNumber(java.lang.Integer workSheetNumber)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CycleCountStatusVO

public CycleCountStatusVO()
Method Detail

getCreateDate

public java.util.Date getCreateDate()

setCreateDate

public void setCreateDate(java.util.Date createDate)

getCreator

public java.lang.String getCreator()

setCreator

public void setCreator(java.lang.String creator)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getTotalPages

public int getTotalPages()

setTotalPages

public void setTotalPages(int totalPages)

getWorkSheetNumber

public java.lang.Integer getWorkSheetNumber()

setWorkSheetNumber

public void setWorkSheetNumber(java.lang.Integer workSheetNumber)

getPartClass

public java.lang.String getPartClass()

setPartClass

public void setPartClass(java.lang.String partClass)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CycleCountVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class CycleCountVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.CycleCountVO
All Implemented Interfaces:
java.io.Serializable
public class CycleCountVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
CycleCountVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getActive()
java.lang.String | getCountedBy()
java.util.Date | getCountedDate()
java.math.BigDecimal | getDiffCount()
java.lang.String | getLocate()
java.lang.String | getMn()
java.lang.String | getNewLocation()
java.math.BigDecimal | getNewOnhand()
java.math.BigDecimal | getOnhand()
java.lang.String | getPartClass()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.util.Date | getPhysicalInventoryDate()
CycleCountPK | getPk()
int | hashCode()
boolean | isCommitted()
void | setActive(java.lang.String active)
void | setCommitted(boolean committed)
void | setCountedBy(java.lang.String countedBy)
void | setCountedDate(java.util.Date countedDate)
void | setDiffCount(java.math.BigDecimal diffCount)
void | setLocate(java.lang.String locate)
void | setMn(java.lang.String mn)
void | setNewLocation(java.lang.String newLocation)
void | setNewOnhand(java.math.BigDecimal newOnhand)
void | setOnhand(java.math.BigDecimal onhand)
void | setPartClass(java.lang.String partClass)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPhysicalInventoryDate(java.util.Date physicalInventoryDate)
void | setPk(CycleCountPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CycleCountVO

public CycleCountVO()
Method Detail

getPk

public CycleCountPK getPk()

setPk

public void setPk(CycleCountPK pk)

getPartClass

public java.lang.String getPartClass()

setPartClass

public void setPartClass(java.lang.String partClass)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPhysicalInventoryDate

public java.util.Date getPhysicalInventoryDate()

setPhysicalInventoryDate

public void setPhysicalInventoryDate(java.util.Date physicalInventoryDate)

getMn

public java.lang.String getMn()

setMn

public void setMn(java.lang.String mn)

getActive

public java.lang.String getActive()

setActive

public void setActive(java.lang.String active)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getOnhand

public java.math.BigDecimal getOnhand()

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

getNewOnhand

public java.math.BigDecimal getNewOnhand()

setNewOnhand

public void setNewOnhand(java.math.BigDecimal newOnhand)

getCountedBy

public java.lang.String getCountedBy()

setCountedBy

public void setCountedBy(java.lang.String countedBy)

getCountedDate

public java.util.Date getCountedDate()

setCountedDate

public void setCountedDate(java.util.Date countedDate)

isCommitted

public boolean isCommitted()

setCommitted

public void setCommitted(boolean committed)

getDiffCount

public java.math.BigDecimal getDiffCount()

setDiffCount

public void setDiffCount(java.math.BigDecimal diffCount)

getNewLocation

public java.lang.String getNewLocation()

setNewLocation

public void setNewLocation(java.lang.String newLocation)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DataFilterVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DataFilterVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.DataFilterVO
All Implemented Interfaces:
java.io.Serializable
public class DataFilterVO
extends VO

See Also:
Serialized Form

Constructor Summary
DataFilterVO()
Method Summary
java.lang.String | getFilterCondition()
java.lang.String | getFilterPO()
java.lang.String | getFilterSQL()
java.lang.String | getFilterType()
java.lang.String | getId()
java.lang.String | getPoClass()
java.lang.String | getTableName()
java.lang.String | getValidate()
java.lang.String | getWarning()
boolean | isInUse()
void | setFilterCondition(java.lang.String filterCondition)
void | setFilterPO(java.lang.String filterPO)
void | setFilterSQL(java.lang.String filterSQL)
void | setFilterType(java.lang.String filterType)
void | setId(java.lang.String id)
void | setInUse(boolean inUse)
void | setPoClass(java.lang.String poClass)
void | setTableName(java.lang.String tableName)
void | setValidate(java.lang.String validate)
void | setWarning(java.lang.String warning)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DataFilterVO

public DataFilterVO()
Method Detail

getFilterPO

public java.lang.String getFilterPO()

setFilterPO

public void setFilterPO(java.lang.String filterPO)

getFilterSQL

public java.lang.String getFilterSQL()

setFilterSQL

public void setFilterSQL(java.lang.String filterSQL)

getFilterCondition

public java.lang.String getFilterCondition()

setFilterCondition

public void setFilterCondition(java.lang.String filterCondition)

getFilterType

public java.lang.String getFilterType()

setFilterType

public void setFilterType(java.lang.String filterType)

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getPoClass

public java.lang.String getPoClass()

setPoClass

public void setPoClass(java.lang.String poClass)

getTableName

public java.lang.String getTableName()

setTableName

public void setTableName(java.lang.String tableName)

getWarning

public java.lang.String getWarning()

setWarning

public void setWarning(java.lang.String warning)

isInUse

public boolean isInUse()

setInUse

public void setInUse(boolean inUse)

getValidate

public java.lang.String getValidate()

setValidate

public void setValidate(java.lang.String validate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DBAccessException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DBAccessException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  bb.common.BB2ServerException
                extended by  bb.common.DBAccessException
All Implemented Interfaces:
java.io.Serializable
public class DBAccessException
extends BB2ServerException

See Also:
Serialized Form

Field Summary
Fields inherited from class bb.common.BB2ServerException
UNKNOWN_EXCEPTION
Constructor Summary
DBAccessException(java.lang.Exception e)
DBAccessException(java.lang.Exception e, java.lang.Object parameter)
DBAccessException(java.lang.Exception e, Reason reason)
DBAccessException(java.lang.Exception e, Reason reason, java.lang.Object parameter)
DBAccessException(Reason reason)
DBAccessException(Reason reason, java.lang.Object parameter)
DBAccessException(java.lang.String message)
DBAccessException(java.lang.String message, java.lang.Object parameter)
DBAccessException(java.lang.String message, Reason reason)
DBAccessException(java.lang.String message, Reason reason, java.lang.Object parameter)
Method Summary
Methods inherited from class bb.common.BB2ServerException
getParameter, getReason, setParameter
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DBAccessException

public DBAccessException(java.lang.Exception e)

DBAccessException

public DBAccessException(java.lang.Exception e,
                         java.lang.Object parameter)

DBAccessException

public DBAccessException(java.lang.String message)

DBAccessException

public DBAccessException(java.lang.String message,
                         java.lang.Object parameter)

DBAccessException

public DBAccessException(java.lang.Exception e,
                         Reason reason)

DBAccessException

public DBAccessException(java.lang.Exception e,
                         Reason reason,
                         java.lang.Object parameter)

DBAccessException

public DBAccessException(Reason reason)

DBAccessException

public DBAccessException(Reason reason,
                         java.lang.Object parameter)

DBAccessException

public DBAccessException(java.lang.String message,
                         Reason reason)

DBAccessException

public DBAccessException(java.lang.String message,
                         Reason reason,
                         java.lang.Object parameter)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DBReason

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DBReason

java.lang.Object
    extended by  bb.common.DBReason

public class DBReason
extends java.lang.Object

Field Summary
static Reason | DBA_SYS_EXCEPTION
static Reason | DUPLICATE_KEY_EXCEPTION
static Reason | HIBERNATE_EXCEPTION
static Reason | SOME_BODY_ELSE_WORK_ON_IT
Constructor Summary
DBReason()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DUPLICATE_KEY_EXCEPTION

public static final Reason DUPLICATE_KEY_EXCEPTION

HIBERNATE_EXCEPTION

public static final Reason HIBERNATE_EXCEPTION

DBA_SYS_EXCEPTION

public static final Reason DBA_SYS_EXCEPTION

SOME_BODY_ELSE_WORK_ON_IT

public static final Reason SOME_BODY_ELSE_WORK_ON_IT
Constructor Detail

DBReason

public DBReason()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DebitsCreditsResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DebitsCreditsResult

java.lang.Object
    extended by  bb.common.DebitsCreditsResult
All Implemented Interfaces:
java.io.Serializable
public class DebitsCreditsResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
DebitsCreditsResult()
Method Summary
java.util.List<AccountsCreditDebitListResult> | getCredits()
java.lang.String | getCurrency()
java.util.List<AccountsCreditDebitListResult> | getDebits()
java.lang.String | getOrderNumber()
void | setCredits(java.util.List<AccountsCreditDebitListResult> credits)
void | setCurrency(java.lang.String currency)
void | setDebits(java.util.List<AccountsCreditDebitListResult> debits)
void | setOrderNumber(java.lang.String orderNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DebitsCreditsResult

public DebitsCreditsResult()
Method Detail

getCredits

public java.util.List<AccountsCreditDebitListResult> getCredits()

setCredits

public void setCredits(java.util.List<AccountsCreditDebitListResult> credits)

getDebits

public java.util.List<AccountsCreditDebitListResult> getDebits()

setDebits

public void setDebits(java.util.List<AccountsCreditDebitListResult> debits)

getOrderNumber

public java.lang.String getOrderNumber()

setOrderNumber

public void setOrderNumber(java.lang.String orderNumber)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DepartmentLocationForBackflushVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DepartmentLocationForBackflushVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.DepartmentLocationForBackflushVO
All Implemented Interfaces:
java.io.Serializable
public class DepartmentLocationForBackflushVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ID
static java.lang.String | ORDER_BY_LOCATION
Constructor Summary
DepartmentLocationForBackflushVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getId()
java.lang.String | getLocation()
int | hashCode()
void | setId(java.lang.String id)
void | setLocation(java.lang.String location)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ID

public static final java.lang.String ORDER_BY_ID
See Also:
Constant Field Values

ORDER_BY_LOCATION

public static final java.lang.String ORDER_BY_LOCATION
See Also:
Constant Field Values
Constructor Detail

DepartmentLocationForBackflushVO

public DepartmentLocationForBackflushVO()
Method Detail

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DepositSummaryResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DepositSummaryResult

java.lang.Object
    extended by  bb.common.DepositSummaryResult
All Implemented Interfaces:
java.io.Serializable
public class DepositSummaryResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
DepositSummaryResult()
Method Summary
java.lang.String | getAccountDescription()
java.lang.String | getAccountNumber()
java.math.BigDecimal | getActualAmount()
java.math.BigDecimal | getAmount()
java.lang.String | getCheckNumber()
java.lang.String | getCompanyUnitId()
java.lang.String | getCustomerId()
java.lang.String | getCustomerName()
java.lang.String | getDescription()
java.lang.String | getGlNumber()
java.lang.String | getMemo()
java.lang.String | getPmtMethod()
void | setAccountDescription(java.lang.String accountDescription)
void | setAccountNumber(java.lang.String accountNumber)
void | setActualAmount(java.math.BigDecimal actualAmount)
void | setAmount(java.math.BigDecimal amount)
void | setCheckNumber(java.lang.String checkNumber)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCustomerId(java.lang.String customerId)
void | setCustomerName(java.lang.String customerName)
void | setDescription(java.lang.String description)
void | setGlNumber(java.lang.String glNumber)
void | setMemo(java.lang.String memo)
void | setPmtMethod(java.lang.String pmtMethod)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DepositSummaryResult

public DepositSummaryResult()
Method Detail

getCheckNumber

public java.lang.String getCheckNumber()

setCheckNumber

public void setCheckNumber(java.lang.String checkNumber)

getPmtMethod

public java.lang.String getPmtMethod()

setPmtMethod

public void setPmtMethod(java.lang.String pmtMethod)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getCustomerName

public java.lang.String getCustomerName()

setCustomerName

public void setCustomerName(java.lang.String customerName)

getMemo

public java.lang.String getMemo()

setMemo

public void setMemo(java.lang.String memo)

getAmount

public java.math.BigDecimal getAmount()

setAmount

public void setAmount(java.math.BigDecimal amount)

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getAccountDescription

public java.lang.String getAccountDescription()

setAccountDescription

public void setAccountDescription(java.lang.String accountDescription)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getGlNumber

public java.lang.String getGlNumber()

setGlNumber

public void setGlNumber(java.lang.String glNumber)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getActualAmount

public java.math.BigDecimal getActualAmount()

setActualAmount

public void setActualAmount(java.math.BigDecimal actualAmount)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Deprecated List

PREV NEXT FRAMES NO FRAMES

Deprecated API

Contents
Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


DepreciateMonthlyReport

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DepreciateMonthlyReport

java.lang.Object
    extended by  bb.common.DepreciateMonthlyReport
All Implemented Interfaces:
java.io.Serializable
public class DepreciateMonthlyReport
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACQUISITIONCOST
static java.lang.String | ORDER_BY_ASSETTYPE
static java.lang.String | ORDER_BY_CURRENTMONTHDEPRECIATE
static java.lang.String | ORDER_BY_DEPARTMENTID
static java.lang.String | ORDER_BY_DEPRECIATESTATUS
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_LASTMONTHDEPRECIATE
static java.lang.String | ORDER_BY_PK
static java.lang.String | ORDER_BY_QUANTITY
static java.lang.String | ORDER_BY_USINGSTATUS
Constructor Summary
DepreciateMonthlyReport()
default constructor
Method Summary
java.lang.String | getAssetType()
java.lang.String | getCurrency()
java.lang.String | getDepartmentID()
java.lang.String | getDepreciateStatus()
java.math.BigDecimal | getTotCurrentMDepreciate()
java.math.BigDecimal | getTotLastMDepreciate()
java.math.BigDecimal | getTotVarCost()
java.math.BigDecimal | getTotVarDepreciate()
java.lang.String | getUsingStatus()
void | setAssetType(java.lang.String assetType)
void | setCurrency(java.lang.String currency)
void | setDepartmentID(java.lang.String departmentID)
void | setDepreciateStatus(java.lang.String depreciateStatus)
void | setTotCurrentMDepreciate(java.math.BigDecimal totCurrentMDepreciate)
void | setTotLastMDepreciate(java.math.BigDecimal totLastMDepreciate)
void | setTotVarCost(java.math.BigDecimal totVarCost)
void | setTotVarDepreciate(java.math.BigDecimal totVarDepreciate)
void | setUsingStatus(java.lang.String usingStatus)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PK

public static final java.lang.String ORDER_BY_PK
See Also:
Constant Field Values

ORDER_BY_ASSETTYPE

public static final java.lang.String ORDER_BY_ASSETTYPE
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_QUANTITY

public static final java.lang.String ORDER_BY_QUANTITY
See Also:
Constant Field Values

ORDER_BY_USINGSTATUS

public static final java.lang.String ORDER_BY_USINGSTATUS
See Also:
Constant Field Values

ORDER_BY_DEPARTMENTID

public static final java.lang.String ORDER_BY_DEPARTMENTID
See Also:
Constant Field Values

ORDER_BY_DEPRECIATESTATUS

public static final java.lang.String ORDER_BY_DEPRECIATESTATUS
See Also:
Constant Field Values

ORDER_BY_ACQUISITIONCOST

public static final java.lang.String ORDER_BY_ACQUISITIONCOST
See Also:
Constant Field Values

ORDER_BY_LASTMONTHDEPRECIATE

public static final java.lang.String ORDER_BY_LASTMONTHDEPRECIATE
See Also:
Constant Field Values

ORDER_BY_CURRENTMONTHDEPRECIATE

public static final java.lang.String ORDER_BY_CURRENTMONTHDEPRECIATE
See Also:
Constant Field Values
Constructor Detail

DepreciateMonthlyReport

public DepreciateMonthlyReport()
default constructor

Method Detail

getDepreciateStatus

public java.lang.String getDepreciateStatus()

setDepreciateStatus

public void setDepreciateStatus(java.lang.String depreciateStatus)

getUsingStatus

public java.lang.String getUsingStatus()

setUsingStatus

public void setUsingStatus(java.lang.String usingStatus)

getAssetType

public java.lang.String getAssetType()

setAssetType

public void setAssetType(java.lang.String assetType)

getDepartmentID

public java.lang.String getDepartmentID()

setDepartmentID

public void setDepartmentID(java.lang.String departmentID)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getTotCurrentMDepreciate

public java.math.BigDecimal getTotCurrentMDepreciate()

setTotCurrentMDepreciate

public void setTotCurrentMDepreciate(java.math.BigDecimal totCurrentMDepreciate)

getTotLastMDepreciate

public java.math.BigDecimal getTotLastMDepreciate()

setTotLastMDepreciate

public void setTotLastMDepreciate(java.math.BigDecimal totLastMDepreciate)

getTotVarCost

public java.math.BigDecimal getTotVarCost()

setTotVarCost

public void setTotVarCost(java.math.BigDecimal totVarCost)

getTotVarDepreciate

public java.math.BigDecimal getTotVarDepreciate()

setTotVarDepreciate

public void setTotVarDepreciate(java.math.BigDecimal totVarDepreciate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DesignControlDocumentVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DesignControlDocumentVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.DesignControlDocumentVO
All Implemented Interfaces:
java.io.Serializable
public class DesignControlDocumentVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
DesignControlDocumentVO()
default constructor
DesignControlDocumentVO(java.lang.String designControlNumber, java.lang.String sequence, java.lang.String extension)
minimal constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.lang.String | getDescription()
java.lang.String | getDesignControlNumber()
long | getDocLength()
java.lang.String | getDocName()
java.util.Date | getDocumentDate()
java.lang.String | getDt()
java.lang.String | getExtension()
java.lang.Long | getIi()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getSequence()
int | hashCode()
void | setComments(java.lang.String comments)
void | setDescription(java.lang.String description)
void | setDesignControlNumber(java.lang.String designControlNumber)
void | setDocLength(long docLength)
void | setDocName(java.lang.String docName)
void | setDocumentDate(java.util.Date documentDate)
void | setDt(java.lang.String dt)
void | setExtension(java.lang.String extension)
void | setIi(java.lang.Long ii)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setSequence(java.lang.String sequence)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

DesignControlDocumentVO

public DesignControlDocumentVO()
default constructor

DesignControlDocumentVO

public DesignControlDocumentVO(java.lang.String designControlNumber,
                               java.lang.String sequence,
                               java.lang.String extension)
minimal constructor

Method Detail

getDocLength

public long getDocLength()

setDocLength

public void setDocLength(long docLength)

getDocName

public java.lang.String getDocName()

setDocName

public void setDocName(java.lang.String docName)

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getDesignControlNumber

public java.lang.String getDesignControlNumber()

setDesignControlNumber

public void setDesignControlNumber(java.lang.String designControlNumber)

getSequence

public java.lang.String getSequence()

setSequence

public void setSequence(java.lang.String sequence)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getDt

public java.lang.String getDt()

setDt

public void setDt(java.lang.String dt)

getDocumentDate

public java.util.Date getDocumentDate()

setDocumentDate

public void setDocumentDate(java.util.Date documentDate)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DesignControlInfoVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DesignControlInfoVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.DesignControlInfoVO
All Implemented Interfaces:
java.io.Serializable
public class DesignControlInfoVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
DesignControlInfoVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getCloseDate()
java.util.Date | getDate()
java.lang.String | getDd()
java.lang.String | getDepartment()
java.lang.String | getDesignControlNumber()
java.lang.String | getDesignInputDescription()
java.lang.String | getDesignOutputDescription()
java.lang.String | getDesignReviewDescription()
java.lang.String | getDesignValidationDescription()
java.lang.String | getDesignVerificationDescription()
java.util.Date | getDueDate()
java.lang.String | getEc()
java.util.Date | getLastChangeDate()
int | getLastChangeTimes()
java.lang.String | getLastChangeUser()
java.util.Date | getOpenDate()
java.lang.String | getOrigin()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getProjectClass()
java.lang.String | getProjectDescription()
java.lang.String | getProjectEngineer()
java.lang.String | getProjectTeam()
java.lang.String | getSalesOrderNumber()
java.lang.String | getStatus()
java.lang.String | getWorkOrderNumber()
int | hashCode()
void | setCloseDate(java.util.Date closeDate)
void | setDate(java.util.Date date)
void | setDd(java.lang.String dd)
void | setDepartment(java.lang.String department)
void | setDesignControlNumber(java.lang.String designControlNumber)
void | setDesignInputDescription(java.lang.String designInputDescription)
void | setDesignOutputDescription(java.lang.String designOutputDescription)
void | setDesignReviewDescription(java.lang.String designReviewDescription)
void | setDesignValidationDescription(java.lang.String designValidationDescription)
void | setDesignVerificationDescription(java.lang.String designVerificationDescription)
void | setDueDate(java.util.Date dueDate)
void | setEc(java.lang.String ec)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTimes(int lastChangeTimes)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setOpenDate(java.util.Date openDate)
void | setOrigin(java.lang.String origin)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setProjectClass(java.lang.String projectClass)
void | setProjectDescription(java.lang.String projectDescription)
void | setProjectEngineer(java.lang.String projectEngineer)
void | setProjectTeam(java.lang.String projectTeam)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setStatus(java.lang.String status)
void | setWorkOrderNumber(java.lang.String workOrderNumber)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

DesignControlInfoVO

public DesignControlInfoVO()
default constructor

Method Detail

getDesignControlNumber

public java.lang.String getDesignControlNumber()

setDesignControlNumber

public void setDesignControlNumber(java.lang.String designControlNumber)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getDate

public java.util.Date getDate()

setDate

public void setDate(java.util.Date date)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getDd

public java.lang.String getDd()

setDd

public void setDd(java.lang.String dd)

getOpenDate

public java.util.Date getOpenDate()

setOpenDate

public void setOpenDate(java.util.Date openDate)

getDueDate

public java.util.Date getDueDate()

setDueDate

public void setDueDate(java.util.Date dueDate)

getCloseDate

public java.util.Date getCloseDate()

setCloseDate

public void setCloseDate(java.util.Date closeDate)

getProjectClass

public java.lang.String getProjectClass()

setProjectClass

public void setProjectClass(java.lang.String projectClass)

getProjectEngineer

public java.lang.String getProjectEngineer()

setProjectEngineer

public void setProjectEngineer(java.lang.String projectEngineer)

getProjectTeam

public java.lang.String getProjectTeam()

setProjectTeam

public void setProjectTeam(java.lang.String projectTeam)

getDepartment

public java.lang.String getDepartment()

setDepartment

public void setDepartment(java.lang.String department)

getEc

public java.lang.String getEc()

setEc

public void setEc(java.lang.String ec)

getWorkOrderNumber

public java.lang.String getWorkOrderNumber()

setWorkOrderNumber

public void setWorkOrderNumber(java.lang.String workOrderNumber)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getProjectDescription

public java.lang.String getProjectDescription()

setProjectDescription

public void setProjectDescription(java.lang.String projectDescription)

getDesignInputDescription

public java.lang.String getDesignInputDescription()

setDesignInputDescription

public void setDesignInputDescription(java.lang.String designInputDescription)

getDesignOutputDescription

public java.lang.String getDesignOutputDescription()

setDesignOutputDescription

public void setDesignOutputDescription(java.lang.String designOutputDescription)

getDesignReviewDescription

public java.lang.String getDesignReviewDescription()

setDesignReviewDescription

public void setDesignReviewDescription(java.lang.String designReviewDescription)

getDesignValidationDescription

public java.lang.String getDesignValidationDescription()

setDesignValidationDescription

public void setDesignValidationDescription(java.lang.String designValidationDescription)

getDesignVerificationDescription

public java.lang.String getDesignVerificationDescription()

setDesignVerificationDescription

public void setDesignVerificationDescription(java.lang.String designVerificationDescription)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getLastChangeTimes

public int getLastChangeTimes()

setLastChangeTimes

public void setLastChangeTimes(int lastChangeTimes)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DesignControlListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DesignControlListResult

java.lang.Object
    extended by  bb.common.DesignControlListResult
All Implemented Interfaces:
java.io.Serializable
public class DesignControlListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DCNUMBER
static java.lang.String | ORDER_BY_DUEDATE
static java.lang.String | ORDER_BY_OPENDATE
static java.lang.String | ORDER_BY_PARTDESCRIPTION
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_PROJECTDESCRIPTION
static java.lang.String | ORDER_BY_PROJECTENGINEER
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
DesignControlListResult()
Method Summary
java.lang.String | getDcNumber()
java.util.Date | getDueDate()
java.util.Date | getOpenDate()
java.lang.String | getPartDescription()
PartPK | getPartPk()
java.lang.String | getProjectDescription()
java.lang.String | getProjectEngineer()
java.lang.String | getStatus()
void | setDcNumber(java.lang.String dcNumber)
void | setDueDate(java.util.Date dueDate)
void | setOpenDate(java.util.Date openDate)
void | setPartDescription(java.lang.String partDescription)
void | setPartPk(PartPK partPk)
void | setProjectDescription(java.lang.String projectDescription)
void | setProjectEngineer(java.lang.String projectEngineer)
void | setStatus(java.lang.String status)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_DCNUMBER

public static final java.lang.String ORDER_BY_DCNUMBER
See Also:
Constant Field Values

ORDER_BY_OPENDATE

public static final java.lang.String ORDER_BY_OPENDATE
See Also:
Constant Field Values

ORDER_BY_DUEDATE

public static final java.lang.String ORDER_BY_DUEDATE
See Also:
Constant Field Values

ORDER_BY_PROJECTENGINEER

public static final java.lang.String ORDER_BY_PROJECTENGINEER
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_PROJECTDESCRIPTION

public static final java.lang.String ORDER_BY_PROJECTDESCRIPTION
See Also:
Constant Field Values

ORDER_BY_PARTDESCRIPTION

public static final java.lang.String ORDER_BY_PARTDESCRIPTION
See Also:
Constant Field Values
Constructor Detail

DesignControlListResult

public DesignControlListResult()
Method Detail

getStatus

public java.lang.String getStatus()

getProjectEngineer

public java.lang.String getProjectEngineer()

getDueDate

public java.util.Date getDueDate()

getOpenDate

public java.util.Date getOpenDate()

getPartDescription

public java.lang.String getPartDescription()

getProjectDescription

public java.lang.String getProjectDescription()

getDcNumber

public java.lang.String getDcNumber()

setPartPk

public void setPartPk(PartPK partPk)

setStatus

public void setStatus(java.lang.String status)

setProjectEngineer

public void setProjectEngineer(java.lang.String projectEngineer)

setDueDate

public void setDueDate(java.util.Date dueDate)

setOpenDate

public void setOpenDate(java.util.Date openDate)

setPartDescription

public void setPartDescription(java.lang.String partDescription)

setProjectDescription

public void setProjectDescription(java.lang.String projectDescription)

setDcNumber

public void setDcNumber(java.lang.String dcNumber)

getPartPk

public PartPK getPartPk()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DesignControlVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DesignControlVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.DesignControlVO
All Implemented Interfaces:
java.io.Serializable
public class DesignControlVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
DesignControlVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getCloseDate()
java.util.Date | getDate()
java.lang.String | getDd()
java.lang.String | getDepartment()
java.lang.String | getDesignControlNumber()
java.lang.String | getDesignInputDescription()
java.lang.String | getDesignOutputDescription()
java.lang.String | getDesignReviewDescription()
java.lang.String | getDesignValidationDescription()
java.lang.String | getDesignVerificationDescription()
java.util.Date | getDueDate()
java.lang.String | getEc()
java.util.Set | getEdcDocuments()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.util.Date | getOpenDate()
java.lang.String | getOrigin()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getProjectClass()
java.lang.String | getProjectDescription()
java.lang.String | getProjectEngineer()
java.lang.String | getProjectTeam()
java.lang.String | getSalesOrderNumber()
java.lang.String | getStatus()
java.lang.Integer | getVersion()
java.lang.String | getWorkOrderNumber()
int | hashCode()
void | setCloseDate(java.util.Date closeDate)
void | setDate(java.util.Date date)
void | setDd(java.lang.String dd)
void | setDepartment(java.lang.String department)
void | setDesignControlNumber(java.lang.String designControlNumber)
void | setDesignInputDescription(java.lang.String designInputDescription)
void | setDesignOutputDescription(java.lang.String designOutputDescription)
void | setDesignReviewDescription(java.lang.String designReviewDescription)
void | setDesignValidationDescription(java.lang.String designValidationDescription)
void | setDesignVerificationDescription(java.lang.String designVerificationDescription)
void | setDueDate(java.util.Date dueDate)
void | setEc(java.lang.String ec)
void | setEdcDocuments(java.util.Set edcDocuments)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setOpenDate(java.util.Date openDate)
void | setOrigin(java.lang.String origin)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setProjectClass(java.lang.String projectClass)
void | setProjectDescription(java.lang.String projectDescription)
void | setProjectEngineer(java.lang.String projectEngineer)
void | setProjectTeam(java.lang.String projectTeam)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setStatus(java.lang.String status)
void | setVersion(java.lang.Integer version)
void | setWorkOrderNumber(java.lang.String workOrderNumber)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

DesignControlVO

public DesignControlVO()
default constructor

Method Detail

getDesignControlNumber

public java.lang.String getDesignControlNumber()

setDesignControlNumber

public void setDesignControlNumber(java.lang.String designControlNumber)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getDate

public java.util.Date getDate()

setDate

public void setDate(java.util.Date date)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getDd

public java.lang.String getDd()

setDd

public void setDd(java.lang.String dd)

getOpenDate

public java.util.Date getOpenDate()

setOpenDate

public void setOpenDate(java.util.Date openDate)

getDueDate

public java.util.Date getDueDate()

setDueDate

public void setDueDate(java.util.Date dueDate)

getCloseDate

public java.util.Date getCloseDate()

setCloseDate

public void setCloseDate(java.util.Date closeDate)

getProjectClass

public java.lang.String getProjectClass()

setProjectClass

public void setProjectClass(java.lang.String projectClass)

getProjectEngineer

public java.lang.String getProjectEngineer()

setProjectEngineer

public void setProjectEngineer(java.lang.String projectEngineer)

getProjectTeam

public java.lang.String getProjectTeam()

setProjectTeam

public void setProjectTeam(java.lang.String projectTeam)

getDepartment

public java.lang.String getDepartment()

setDepartment

public void setDepartment(java.lang.String department)

getEc

public java.lang.String getEc()

setEc

public void setEc(java.lang.String ec)

getWorkOrderNumber

public java.lang.String getWorkOrderNumber()

setWorkOrderNumber

public void setWorkOrderNumber(java.lang.String workOrderNumber)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getProjectDescription

public java.lang.String getProjectDescription()

setProjectDescription

public void setProjectDescription(java.lang.String projectDescription)

getDesignInputDescription

public java.lang.String getDesignInputDescription()

setDesignInputDescription

public void setDesignInputDescription(java.lang.String designInputDescription)

getDesignOutputDescription

public java.lang.String getDesignOutputDescription()

setDesignOutputDescription

public void setDesignOutputDescription(java.lang.String designOutputDescription)

getDesignReviewDescription

public java.lang.String getDesignReviewDescription()

setDesignReviewDescription

public void setDesignReviewDescription(java.lang.String designReviewDescription)

getDesignValidationDescription

public java.lang.String getDesignValidationDescription()

setDesignValidationDescription

public void setDesignValidationDescription(java.lang.String designValidationDescription)

getDesignVerificationDescription

public java.lang.String getDesignVerificationDescription()

setDesignVerificationDescription

public void setDesignVerificationDescription(java.lang.String designVerificationDescription)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getVersion

public java.lang.Integer getVersion()

setVersion

public void setVersion(java.lang.Integer version)

getEdcDocuments

public java.util.Set getEdcDocuments()

setEdcDocuments

public void setEdcDocuments(java.util.Set edcDocuments)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


D-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M N O P Q R S T U V W X Y Z

D

D - Static variable in class bb.common.Constant.SGType
DA - Static variable in class bb.common.Constant.AmountType
DataFilterVO - Class in bb.common
DataFilterVO() - Constructor for class bb.common.DataFilterVO
DATE_CAN_NOT_BE_NULL - Static variable in class bb.common.BIZReason
DATE_WRONG - Static variable in class bb.common.BIZReason
DAY - Static variable in class bb.common.Constant.PeriodUnit
DB - Static variable in class bb.common.Constant.AmountType
DBA_SYS_EXCEPTION - Static variable in class bb.common.DBReason
DBAccessException - Exception in bb.common
DBAccessException(Exception) - Constructor for exception bb.common.DBAccessException
DBAccessException(Exception, Object) - Constructor for exception bb.common.DBAccessException
DBAccessException(String) - Constructor for exception bb.common.DBAccessException
DBAccessException(String, Object) - Constructor for exception bb.common.DBAccessException
DBAccessException(Exception, Reason) - Constructor for exception bb.common.DBAccessException
DBAccessException(Exception, Reason, Object) - Constructor for exception bb.common.DBAccessException
DBAccessException(Reason) - Constructor for exception bb.common.DBAccessException
DBAccessException(Reason, Object) - Constructor for exception bb.common.DBAccessException
DBAccessException(String, Reason) - Constructor for exception bb.common.DBAccessException
DBAccessException(String, Reason, Object) - Constructor for exception bb.common.DBAccessException
DBReason - Class in bb.common
DBReason() - Constructor for class bb.common.DBReason
DC - Static variable in class bb.common.Constant.PrintTemplateType
dealOldMessage(Long) - Method in interface bb.common.box.CompanyBox
dealWithDirectMaterialVariance(String, BigDecimal) - Method in interface bb.common.box.AccountingBox
dealWithEstimatedPayalbeMaterialVariance(String, BigDecimal) - Method in interface bb.common.box.AccountingBox
DEBIT - Static variable in class bb.common.Constant.DebitOrCredit
DEBIT_MEMO - Static variable in class bb.common.BizTarget
DEBITS_NOT_MATCH_CREDITS - Static variable in class bb.common.BIZReason
DEBITS_OR_CREDIT_DOES_NOT_ZERO - Static variable in class bb.common.BIZReason
DebitsCreditsResult - Class in bb.common
DebitsCreditsResult() - Constructor for class bb.common.DebitsCreditsResult
DEFAULT_DIGITS - Static variable in class bb.common.Constant
DEFAULT_MFG_IS_EMPTY - Static variable in class bb.common.BIZReason
DefaultCompanyUnitID - Static variable in class bb.common.Constant
DefaultCurrency - Static variable in class bb.common.Constant
DefaultLanguage - Static variable in class bb.common.Constant
DefaultMakeBuy - Static variable in class bb.common.Constant
DefaultNaRecTo - Static variable in class bb.common.Constant
DefaultPartFrom - Static variable in class bb.common.Constant
DefaultPartType - Static variable in class bb.common.Constant
DefaultPartUnit - Static variable in class bb.common.Constant
DefaultReceivedTo - Static variable in class bb.common.Constant
DefaultRevision - Static variable in class bb.common.Constant
DefaultStatus - Static variable in class bb.common.Constant
DefaultWorkInstructionSetID - Static variable in class bb.common.Constant
DELETE - Static variable in class bb.common.Constant.NoticeAction
DELETE - Static variable in class bb.common.DocumentAction.DwfAndDwgDocAction
DELETE - Static variable in class bb.common.DocumentAction.MiscDocAction
DELETE - Static variable in class bb.common.DocumentAction.PartDocAction
DELETE_FROM_DB_ERROR - Static variable in class bb.common.BIZReason
DELETE_ON_LOAN_ITEM_ERROR - Static variable in class bb.common.BIZReason
DELETE_PICTURE_FIRST - Static variable in class bb.common.BIZReason
DELETE_QUOTE_ITEM_ERROR - Static variable in class bb.common.BIZReason
DELETE_RMA_ITEM_ERROR - Static variable in class bb.common.BIZReason
DELETE_SALES_ORDER_ITEM_ERROR - Static variable in class bb.common.BIZReason
deleteAccountChart(String) - Method in interface bb.common.box.AccountingBox
deleteAccountPayableCheck(AccountPayableCheckVO) - Method in interface bb.common.box.AccountingBox
deleteAccountReceivablePayment(AccountReceivablePaymentVO) - Method in interface bb.common.box.AccountingBox
deleteAccountsChartCategoryForBalanceSheet(Long) - Method in interface bb.common.box.AccountingBox
deleteAccountsChartCategoryForEbitda(Long) - Method in interface bb.common.box.AccountingBox
deleteAccountsChartCategoryForProfitLoss(Long) - Method in interface bb.common.box.AccountingBox
deleteAccountsChartCategoryForTaxDetail(Long) - Method in interface bb.common.box.AccountingBox
deleteAccountsChartMapping(AccountsChartMappingPK) - Method in interface bb.common.box.AccountingBox
deleteAddressQualityDocuments(MiscDocAgent) - Method in interface bb.common.box.QualityBox
deleteAddressQualityDocuments(Long) - Method in interface bb.common.box.QualityBox
deleteAllAddresWhenInit() - Method in interface bb.common.box.AddressBox
deleteAllEmployeeCardWhenInit() - Method in interface bb.common.box.HumanResourceBox
deleteAllGeneralLedger() - Method in interface bb.common.box.AccountingBox
deleteAllTempBOM() - Method in interface bb.common.box.CompanyBox
deleteAllWorkOrderWorkInstructionSequences(WorkOrderWorkInstructionPK) - Method in interface bb.common.box.WorkOrderBox
deleteAP(AccountsPayableVO) - Method in interface bb.common.box.AccountingBox
deleteAR(AccountsReceivableVO) - Method in interface bb.common.box.AccountingBox
deleteArBP(String) - Method in interface bb.common.box.AccountingBox
deleteARPaymentRun(ARPaymentRunVO) - Method in interface bb.common.box.AccountingBox
deleteAsset(AssetVO) - Method in interface bb.common.box.AccountingBox
deleteAssetType(String) - Method in interface bb.common.box.AccountingBox
deleteAssetUsage(AssetUsagePK) - Method in interface bb.common.box.AccountingBox
deleteBankReconciliationReport(BankReconciliationReportVO) - Method in interface bb.common.box.AccountingBox
deleteBill(BillVO) - Method in interface bb.common.box.EngineeringBox
deleteBillItem(BillItemVO) - Method in interface bb.common.box.EngineeringBox
deleteBillWithoutItems(ArrayList<BillPK>) - Method in interface bb.common.box.EngineeringBox
deleteBomApproval(String) - Method in interface bb.common.box.EngineeringBox
deleteBuyerCode(String) - Method in interface bb.common.box.CompanyBox
deleteCalibration(ToolCalibrationVO) - Method in interface bb.common.box.ManufacturingBox
deleteCar(CorrectiveActionRequestVO) - Method in interface bb.common.box.QualityBox
deleteCarrier(CarrierVO) - Method in interface bb.common.box.AddressBox
deleteCashier(CashierVO) - Method in interface bb.common.box.CompanyBox
deleteCatalog(String) - Method in interface bb.common.box.SalesBox
deleteCertainWorkCalendar(Set<Long>) - Method in interface bb.common.box.ManufacturingBox
deleteCertificateDescription(CertificateDescriptionVO) - Method in interface bb.common.box.QualityBox
deleteChangeStdCostWorkSheetItem(ChangeStdCostWorkSheetItemPK) - Method in interface bb.common.box.AccountingBox
deleteCommonPrintTemplate(CommonPrintTemplateVO) - Method in interface bb.common.box.CompanyBox
deleteCompanyUnit(String) - Method in interface bb.common.box.CompanyBox
deleteCompanyUnitAccount(CompanyUnitAccountPK) - Method in interface bb.common.box.CompanyBox
deleteContractPrice(ContractPriceVO) - Method in interface bb.common.box.SalesBox
deleteContractPriceCustomer(ContractPriceCustomerVO) - Method in interface bb.common.box.SalesBox
deleteContractPriceItem(ContractPriceItemVO) - Method in interface bb.common.box.SalesBox
deleteCurrency(String) - Method in interface bb.common.box.CompanyBox
deleteCustomAsset(String) - Method in interface bb.common.box.HumanResourceBox
deleteCustomAssetRecord(CustomAssetRecordPK) - Method in interface bb.common.box.HumanResourceBox
deleteCustomCheckUpEmployee(Long) - Method in interface bb.common.box.HumanResourceBox
deleteCustomColumn(AppColumnVO) - Method in interface bb.common.box.CompanyBox
deleteCustomDepartment(String) - Method in interface bb.common.box.HumanResourceBox
deleteCustomEmployee(String) - Method in interface bb.common.box.HumanResourceBox
deleteCustomEmployeeTrain(CustomEmployeeTrainPK) - Method in interface bb.common.box.HumanResourceBox
deleteCustomEmployeeWorkExperience(CustomEmployeeTrainPK) - Method in interface bb.common.box.HumanResourceBox
deleteCustomerFeedbackItem(FeedBackItemPK) - Method in interface bb.common.box.CustomerServiceBox
deleteCustomerVendorType(CustomerVendorTypeVO) - Method in interface bb.common.box.AddressBox
deleteCustomGoodsBreed(String) - Method in interface bb.common.box.HumanResourceBox
deleteCustomGoodsRecord(Long) - Method in interface bb.common.box.HumanResourceBox
deleteCustomJobCategory(String) - Method in interface bb.common.box.HumanResourceBox
deleteCustomSearch(CustomSearchVO) - Method in interface bb.common.box.CompanyBox
deleteDataFilter(String) - Method in interface bb.common.box.CompanyBox
deletedBatchEngineeringSharingItem(ArrayList<EngineeringSharingItemPK>) - Method in interface bb.common.box.EngineeringBox
deleteDc(DesignControlVO) - Method in interface bb.common.box.EngineeringBox
deleteDCDoc(MiscDocAgent) - Method in interface bb.common.box.EngineeringBox
deletedEngineeringSharing(String) - Method in interface bb.common.box.EngineeringBox
deletedEngineeringSharingItem(EngineeringSharingItemPK) - Method in interface bb.common.box.EngineeringBox
deleteDepartmentLocationForBackflush(ArrayList<DepartmentLocationForBackflushVO>) - Method in interface bb.common.box.WarehouseBox
deleteDisassembleWorkOrderApproval(DisassembleWorkOrderApprovalVO) - Method in interface bb.common.box.WorkOrderBox
deleteDisassembleWorkOrderApproval(String) - Method in interface bb.common.box.WorkOrderBox
deleteDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemReceiverVO) - Method in interface bb.common.box.WorkOrderBox
deleteDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemReceiverPK) - Method in interface bb.common.box.WorkOrderBox
deleteDisassembleWorkOrderItemReceivers(ArrayList<DisassembleWorkOrderItemReceiverPK>) - Method in interface bb.common.box.WorkOrderBox
deleteDocumentServerByPk(String) - Method in interface bb.common.box.CompanyBox
deleteECNControl(String) - Method in interface bb.common.box.EngineeringBox
deleteECRControl(String) - Method in interface bb.common.box.EngineeringBox
deleteECRequest(EngineeringChangeRequestVO) - Method in interface bb.common.box.EngineeringBox
deleteEjbMethod(EjbMethodVO) - Method in interface bb.common.box.SecurityBox
deleteEmployeeCard(String) - Method in interface bb.common.box.HumanResourceBox
deleteEmployeeEducation(EmployeeEducationPK) - Method in interface bb.common.box.HumanResourceBox
deleteEmployeeRecord(MiscDocAgent) - Method in interface bb.common.box.HumanResourceBox
deleteEmployeeTraining(EmployeeWorkExperiencePK) - Method in interface bb.common.box.HumanResourceBox
deleteEmployeeWorkExperience(EmployeeWorkExperiencePK) - Method in interface bb.common.box.HumanResourceBox
deleteEngGroup(String) - Method in interface bb.common.box.EngineeringBox
deleteEngGroupUser(EngGroupUserPK) - Method in interface bb.common.box.EngineeringBox
deleteEngineeringChange(EngineeringChangeVO) - Method in interface bb.common.box.EngineeringBox
deleteEngineeringSharingItemByCompanyId(String) - Method in interface bb.common.box.EngineeringBox
deleteEquipmentById(String) - Method in interface bb.common.box.ManufacturingBox
deleteFeedbackQuestion(FeedbackQuestionVO) - Method in interface bb.common.box.CustomerServiceBox
deleteFiscalYearSetting(FiscalYearSettingsVO, boolean) - Method in interface bb.common.box.AccountingBox
deleteFtpDocument(DocumentInfoAgent) - Method in interface bb.common.box.DocumentBox
deleteFtpDWF(PartDwfAgent) - Method in interface bb.common.box.EngineeringBox
deleteFtpDWG(PartDwgAgent) - Method in interface bb.common.box.EngineeringBox
deleteFTPDWODoc(MiscDocAgent) - Method in interface bb.common.box.WorkOrderBox
deleteFTPECDoc(MiscDocAgent) - Method in interface bb.common.box.EngineeringBox
deleteFTPECRDoc(MiscDocAgent) - Method in interface bb.common.box.EngineeringBox
deleteFTPOrderDoc(MiscDocAgent) - Method in interface bb.common.box.CompanyBox
deleteFTPRMADoc(MiscDocAgent) - Method in interface bb.common.box.SalesBox
deleteFTPSODoc(MiscDocAgent) - Method in interface bb.common.box.SalesBox
deleteFTPWODoc(MiscDocAgent) - Method in interface bb.common.box.WorkOrderBox
deleteGeneralLedger(GeneralLedgerVO) - Method in interface bb.common.box.AccountingBox
deleteGeneralLedgerApproval(String) - Method in interface bb.common.box.AccountingBox
deleteGLAutoApproveById(Long) - Method in interface bb.common.box.AccountingBox
deleteGLCategoryById(String) - Method in interface bb.common.box.AccountingBox
deleteGroupUser(GroupUserVO) - Method in interface bb.common.box.CompanyBox
deleteGroupUserByUserGroup(String) - Method in interface bb.common.box.CompanyBox
deleteHelpServer(Long) - Method in interface bb.common.box.CompanyBox
deleteIncidentItemDoc(MiscDocAgent) - Method in interface bb.common.box.CustomerServiceBox
deleteIncoterm(IncotermVO) - Method in interface bb.common.box.SalesBox
deleteInspectionItem(InspectionItemPK) - Method in interface bb.common.box.ManufacturingBox
deleteInspectionReportInspectMethod(int) - Method in interface bb.common.box.ManufacturingBox
deleteInspectionType(InspectionTypeVO) - Method in interface bb.common.box.QualityBox
deleteLabelTemplate(int) - Method in interface bb.common.box.WarehouseBox
deleteLogInventory(LogInventoryVO) - Method in interface bb.common.box.WarehouseBox
deleteMaintenanceItem(MaintenanceItemPK) - Method in interface bb.common.box.ManufacturingBox
deleteManufacturerECRequest(EngineeringChangeRequestVO) - Method in interface bb.common.box.ManufacturingBox
deleteManufacturerEngineeringChange(EngineeringChangeVO) - Method in interface bb.common.box.ManufacturingBox
deleteMiscDocSetting(MiscDocumentSettingVO) - Method in interface bb.common.box.CompanyBox
deleteMyPrintList(ArrayList) - Method in interface bb.common.box.AccountingBox
deleteMyPrintList(ArrayList) - Method in interface bb.common.box.PurchasingBox
deleteMyPrintList(ArrayList) - Method in interface bb.common.box.SalesBox
deleteMyReceiverPrintList(List) - Method in interface bb.common.box.WarehouseBox
deleteMyShipperPrintList(List) - Method in interface bb.common.box.WarehouseBox
deleteNCC(NonConformanceCodeVO) - Method in interface bb.common.box.QualityBox
deleteNCR(NonConformanceReportVO) - Method in interface bb.common.box.QualityBox
deleteNcrApproval(NcrApprovalPK) - Method in interface bb.common.box.QualityBox
deleteNCRPicture(MiscDocAgent) - Method in interface bb.common.box.QualityBox
deleteNCRPicture(Long) - Method in interface bb.common.box.QualityBox
deleteNonproductivePickingApproval(NonproductivePickingApprovalVO) - Method in interface bb.common.box.WarehouseBox
deleteNonproductivePickingType(NonproductivePickingTypeVO) - Method in interface bb.common.box.WarehouseBox
deleteOnloanControl(String) - Method in interface bb.common.box.WarehouseBox
deleteOnloanDoc(MiscDocAgent) - Method in interface bb.common.box.ManufacturingBox
deleteOperatingInstructions(String) - Method in interface bb.common.box.ManufacturingBox
deleteOperatingInstructionsInspectStandard(int) - Method in interface bb.common.box.ManufacturingBox
deleteOperatingInstructionsManual(int) - Method in interface bb.common.box.ManufacturingBox
deleteOperatingInstructionsType(int) - Method in interface bb.common.box.ManufacturingBox
deleteOperatingOutputFileType(int) - Method in interface bb.common.box.ManufacturingBox
deleteOrderChangeByID(Long) - Method in interface bb.common.box.WorkOrderBox
deletePackingBox(PackingBoxPK) - Method in interface bb.common.box.WarehouseBox
deletePAR(String) - Method in interface bb.common.box.QualityBox
deletePARDoc(MiscDocAgent) - Method in interface bb.common.box.QualityBox
deletePartCatagory(PartCatagoryPK) - Method in interface bb.common.box.EngineeringBox
deletePartCatagory(String) - Method in interface bb.common.box.EngineeringBox
deletePartCatalog(PartCatalogPK) - Method in interface bb.common.box.SalesBox
deletePartCatalog(ArrayList<PartCatalogPK>) - Method in interface bb.common.box.SalesBox
deletePartCertificate(MiscDocAgent) - Method in interface bb.common.box.QualityBox
deletePartClass(String) - Method in interface bb.common.box.WarehouseBox
deletePartDiscount(PartDiscountVO) - Method in interface bb.common.box.SalesBox
deletePartInspection(PartInspectionPK) - Method in interface bb.common.box.QualityBox
deletePartMaterial(PartPK) - Method in interface bb.common.box.EngineeringBox
deletePartOnhand(PartOnhandVO) - Method in interface bb.common.box.WarehouseBox
deletePartPicture(MiscDocAgent) - Method in interface bb.common.box.EngineeringBox
deletePartPicture(Long) - Method in interface bb.common.box.EngineeringBox
deletePartSecurityLevel(String) - Method in interface bb.common.box.EngineeringBox
deletePartTraceable(PartPK) - Method in interface bb.common.box.EngineeringBox
deletePartTraceableCategories(PartPK) - Method in interface bb.common.box.EngineeringBox
deletePartTraceableCategory(PartTraceableCategoryVO) - Method in interface bb.common.box.EngineeringBox
deletePartTraceableSpec(PartTraceableSpecVO) - Method in interface bb.common.box.EngineeringBox
deletePartTraceableSpec(PartTraceableSpecPK) - Method in interface bb.common.box.EngineeringBox
deletePartTraceableSpecs(PartPK) - Method in interface bb.common.box.EngineeringBox
deletePartType(String) - Method in interface bb.common.box.CompanyBox
deletePartUseType(PartUseTypeVO) - Method in interface bb.common.box.WorkOrderBox
deletePayment(PayableMethodVO) - Method in interface bb.common.box.CompanyBox
deletePermission(PermissionVO) - Method in interface bb.common.box.SecurityBox
deletePermissionMethod(PermissionMethodVO) - Method in interface bb.common.box.SecurityBox
deletePfReceiver(String) - Method in interface bb.common.box.PurchasingBox
deletePODoc(MiscDocAgent) - Method in interface bb.common.box.PurchasingBox
deletePOSurveyReport(String) - Method in interface bb.common.box.QualityBox
deletePrintLogo(String) - Method in interface bb.common.box.CompanyBox
deletePrintTemplate(int) - Method in interface bb.common.box.CompanyBox
deleteProformaInvoice(ProformaInvoiceVO) - Method in interface bb.common.box.WarehouseBox
deleteProject(String) - Method in interface bb.common.box.SalesBox
deletePurchaseOrder(PurchaseOrderVO) - Method in interface bb.common.box.ManufacturingBox
deletePurchaseOrder(PurchaseOrderVO) - Method in interface bb.common.box.PurchasingBox
deletePurchaseOrderApproval(String) - Method in interface bb.common.box.ManufacturingBox
deletePurchaseOrderApproval(String) - Method in interface bb.common.box.PurchasingBox
deletePurchaseOrderBP(String) - Method in interface bb.common.box.PurchasingBox
deletePurchaseOrderItem(PurchaseOrderItemVO) - Method in interface bb.common.box.ManufacturingBox
deletePurchaseOrderItem(PurchaseOrderItemVO) - Method in interface bb.common.box.PurchasingBox
deletePurchaseOrderItems(String) - Method in interface bb.common.box.ManufacturingBox
deletePurchaseOrderItems(String) - Method in interface bb.common.box.PurchasingBox
deletePurchaseWorkSheet(PurchaseWorkSheetVO) - Method in interface bb.common.box.ManufacturingBox
deletePurchaseWorkSheet(PurchaseWorkSheetVO) - Method in interface bb.common.box.PurchasingBox
deletePurchaseWorkSheetItem(PurchaseWorkSheetItemVO) - Method in interface bb.common.box.PurchasingBox
deleteQualityGroup(QualityGroupVO) - Method in interface bb.common.box.QualityBox
deleteQuoteBP(String) - Method in interface bb.common.box.SalesBox
deleteQuoteDocument(MiscDocAgent) - Method in interface bb.common.box.SalesBox
deleteReceiver(ReceiverVO) - Method in interface bb.common.box.WarehouseBox
deleteReceiver(String) - Method in interface bb.common.box.WarehouseBox
deleteReceiverWithoutAPSaveRecords(Date) - Method in interface bb.common.box.AccountingBox
deleteRefdocOne(BB2RefdocPK) - Method in interface bb.common.box.SalesBox
deleteRefdocOne(BB2RefdocPK) - Method in interface bb.common.box.WorkOrderBox
deleteRefdocTwo(BB2RefdocPK) - Method in interface bb.common.box.AccountingBox
deleteRefdocTwo(BB2RefdocPK) - Method in interface bb.common.box.PurchasingBox
deleteRefdocTwo(BB2RefdocPK) - Method in interface bb.common.box.WarehouseBox
deleteRefdocTwo(BB2RefdocPK) - Method in interface bb.common.box.WorkOrderBox
deleteRequestForQuote(RequestForQuoteVO) - Method in interface bb.common.box.ManufacturingBox
deleteRequestForQuote(RequestForQuoteVO) - Method in interface bb.common.box.PurchasingBox
deleteReturnToVendor(ReturnToVendorVO) - Method in interface bb.common.box.ManufacturingBox
deleteReturnToVendor(ReturnToVendorVO) - Method in interface bb.common.box.PurchasingBox
deleteRFC(WorkInstructionRequestForChangeVO) - Method in interface bb.common.box.ManufacturingBox
deleteRMAReview(String) - Method in interface bb.common.box.SalesBox
deleteRole(String) - Method in interface bb.common.box.SecurityBox
deleteRTVApproval(String) - Method in interface bb.common.box.PurchasingBox
deleteSalesCode(String) - Method in interface bb.common.box.SalesBox
deleteSalesman(SalesmanVO) - Method in interface bb.common.box.SalesBox
deleteSalesOrderBP(String) - Method in interface bb.common.box.SalesBox
deleteSalesOrderControl(String) - Method in interface bb.common.box.SalesBox
deleteSerialNumber(String) - Method in interface bb.common.box.QualityBox
deleteSgClientProgramUser(String) - Method in interface bb.common.box.AddressBox
deleteSGCustomerCatalog(ArrayList<SGCustomerCatalogPK>) - Method in interface bb.common.box.SalesBox
deleteSGCustomerCatalog(SGCustomerCatalogPK) - Method in interface bb.common.box.SalesBox
deleteSGSaleItem(int) - Method in interface bb.common.box.SalesBox
deleteShipList(ShipListVO) - Method in interface bb.common.box.PlanningBox
deleteShipListItem(ShipListItemVO) - Method in interface bb.common.box.PlanningBox
deleteShipListOwner(ShipListOwnerVO) - Method in interface bb.common.box.PlanningBox
deleteShipListOwnerAttribute(ShipListOwnerAttributeVO) - Method in interface bb.common.box.PlanningBox
deleteShipper(ShipperVO) - Method in interface bb.common.box.WarehouseBox
deleteSubcompanyById(String) - Method in interface bb.common.box.CompanyBox
deleteSwapOrder(SwapOrderVO) - Method in interface bb.common.box.PurchasingBox
deleteSwapOrderApproval(String) - Method in interface bb.common.box.PurchasingBox
deleteTask(Long) - Method in interface bb.common.box.CompanyBox
deleteTaxAccount(TaxAccountVO) - Method in interface bb.common.box.CompanyBox
deleteTempAddress(int) - Method in interface bb.common.box.CompanyBox
deleteTempBOM(int) - Method in interface bb.common.box.CompanyBox
deleteTempEmployee(int) - Method in interface bb.common.box.CompanyBox
deleteTempInventory(int) - Method in interface bb.common.box.CompanyBox
deleteTempManufacture(int) - Method in interface bb.common.box.CompanyBox
deleteTempMaterial(int) - Method in interface bb.common.box.CompanyBox
deleteTempMPN(int) - Method in interface bb.common.box.CompanyBox
deleteTempNccode(int) - Method in interface bb.common.box.CompanyBox
deleteTempPart(int) - Method in interface bb.common.box.CompanyBox
deleteTempTool(int) - Method in interface bb.common.box.CompanyBox
deleteTempToolInventory(int) - Method in interface bb.common.box.CompanyBox
deleteTerm(int) - Method in interface bb.common.box.CompanyBox
deleteTerm(String) - Method in interface bb.common.box.CompanyBox
deleteTermsCondition(TermsConditionVO) - Method in interface bb.common.box.CompanyBox
deleteTermsCondition(String) - Method in interface bb.common.box.CompanyBox
deleteTermsCondition(int) - Method in interface bb.common.box.CompanyBox
deleteTimeCard(WorkOrderTimeCardVO) - Method in interface bb.common.box.ManufacturingBox
deleteToolList(ToolListVO) - Method in interface bb.common.box.ManufacturingBox
deleteToolListItem(ToolListItemVO) - Method in interface bb.common.box.ManufacturingBox
deleteTraceableCategories(TraceableCategoriesVO) - Method in interface bb.common.box.EngineeringBox
deleteTraceableCategories(String) - Method in interface bb.common.box.EngineeringBox
deleteTraceableSpecs(TraceableSpecsVO) - Method in interface bb.common.box.EngineeringBox
deleteTraceableSpecs(Short) - Method in interface bb.common.box.EngineeringBox
deleteTransactionType(AccountingTransactionTypeVO) - Method in interface bb.common.box.AccountingBox
deleteTransferOrderApproval(String) - Method in interface bb.common.box.WarehouseBox
deleteUnit(UnitVO) - Method in interface bb.common.box.EngineeringBox
deleteUser(String) - Method in interface bb.common.box.SecurityBox
deleteUserGroup(UserGroupVO) - Method in interface bb.common.box.CompanyBox
deleteUserGroup(String) - Method in interface bb.common.box.CompanyBox
deleteVendorCategories(String) - Method in interface bb.common.box.AddressBox
deleteVendorContractPrice(VendorContractPriceVO) - Method in interface bb.common.box.PurchasingBox
deleteVendorContractPriceItem(VendorContractPriceItemVO) - Method in interface bb.common.box.PurchasingBox
deleteVendorContractPriceVendor(VendorContractPriceVendorVO) - Method in interface bb.common.box.PurchasingBox
deleteVendorCriticalLevel(String) - Method in interface bb.common.box.AddressBox
deleteVendorGroupUser(String) - Method in interface bb.common.box.AddressBox
deleteVendorPart(VendorPartPK) - Method in interface bb.common.box.WarehouseBox
deleteVendorQtyPrice(VendorQtyPricePK) - Method in interface bb.common.box.EngineeringBox
deleteVendorQtyPrices(BB2Part, String) - Method in interface bb.common.box.EngineeringBox
deleteWarehouse(String) - Method in interface bb.common.box.WarehouseBox
deleteWeightUnit(String) - Method in interface bb.common.box.CompanyBox
deleteWOReceiver(WorkOrderReceiverVO) - Method in interface bb.common.box.WarehouseBox
deleteWorkCalendar(WorkCalendarVO) - Method in interface bb.common.box.ManufacturingBox
deleteWorkCenter(WorkCenterVO) - Method in interface bb.common.box.ManufacturingBox
deleteWorkFlow(String) - Method in interface bb.common.box.CompanyBox
deleteWorkInstruction(WorkInstructionPK) - Method in interface bb.common.box.ManufacturingBox
deleteWorkInstructionApproval(String) - Method in interface bb.common.box.ManufacturingBox
deleteWorkInstructionDocument(MiscDocAgent) - Method in interface bb.common.box.ManufacturingBox
deleteWorkInstructionPicture(MiscDocAgent) - Method in interface bb.common.box.ManufacturingBox
deleteWorkInstructionPicture(Long) - Method in interface bb.common.box.ManufacturingBox
deleteWorkOrder(WorkOrderVO) - Method in interface bb.common.box.WorkOrderBox
deleteWorkOrderApproval(WorkOrderApprovalVO) - Method in interface bb.common.box.WorkOrderBox
deleteWorkOrderApproval(String) - Method in interface bb.common.box.WorkOrderBox
deleteWorkOrderBP(String) - Method in interface bb.common.box.WorkOrderBox
deleteWorkOrderItemIssue(WorkOrderItemIssueVO) - Method in interface bb.common.box.WorkOrderBox
deleteWorkOrderItemIssue(WorkOrderItemIssuePK) - Method in interface bb.common.box.WorkOrderBox
deleteWorkOrderItemIssue(IssuingItemResult) - Method in interface bb.common.box.WorkOrderBox
deleteWorkOrderItemIssues(ArrayList<WorkOrderItemIssuePK>) - Method in interface bb.common.box.WorkOrderBox
deleteWorkOrderItemTimeDetail(Long) - Method in interface bb.common.box.WorkOrderBox
deleteWorkOrderWorkInstruction(WorkOrderWorkInstructionVO) - Method in interface bb.common.box.WorkOrderBox
deleteWorkOrderWorkInstruction(WorkOrderWorkInstructionPK) - Method in interface bb.common.box.WorkOrderBox
deleteWorkOrderWorkInstructionSequence(WorkOrderWorkInstructionSequenceVO) - Method in interface bb.common.box.WorkOrderBox
deleteWorkOrderWorkSheet(WorkOrderWorkSheetVO) - Method in interface bb.common.box.WorkOrderBox
deleteWorkOrderWorkSheetItem(WorkOrderWorkSheetItemVO) - Method in interface bb.common.box.WorkOrderBox
deleteZipCode(String) - Method in interface bb.common.box.CompanyBox
deleteZipCodeTax(ZipCodeTaxVO) - Method in interface bb.common.box.CompanyBox
DEPARTMENT - Static variable in class bb.common.Constant.CVAddressType
DEPARTMENT_LOCATION_FOR_BACKFLUSH - Static variable in class bb.common.BizTarget
DEPARTMENT_LOCATION_FOR_BACKFLUSH_ALREADY_ADDED - Static variable in class bb.common.BIZReason
DEPARTMENT_LOCATION_FOR_BACKFLUSH_NOT_EXIST - Static variable in class bb.common.BIZReason
DepartmentLocationForBackflushVO - Class in bb.common
DepartmentLocationForBackflushVO() - Constructor for class bb.common.DepartmentLocationForBackflushVO
DepositSummaryResult - Class in bb.common
DepositSummaryResult() - Constructor for class bb.common.DepositSummaryResult
DepreciateMonthlyReport - Class in bb.common
DepreciateMonthlyReport() - Constructor for class bb.common.DepreciateMonthlyReport
default constructor
DESC - Static variable in class bb.common.OrderBy
DESIGN_CONTROL - Static variable in class bb.common.BizTarget
DESIGN_CONTROL_DOCUMENT - Static variable in class bb.common.BizTarget
DESIGN_CONTROL_NOT_EXIST - Static variable in class bb.common.BIZReason
DesignControlDocumentVO - Class in bb.common
DesignControlDocumentVO() - Constructor for class bb.common.DesignControlDocumentVO
default constructor
DesignControlDocumentVO(String, String, String) - Constructor for class bb.common.DesignControlDocumentVO
minimal constructor
DesignControlInfoVO - Class in bb.common
DesignControlInfoVO() - Constructor for class bb.common.DesignControlInfoVO
default constructor
DesignControlListResult - Class in bb.common
DesignControlListResult() - Constructor for class bb.common.DesignControlListResult
DesignControlVO - Class in bb.common
DesignControlVO() - Constructor for class bb.common.DesignControlVO
default constructor
DESTINATION_NOT_EXIST - Static variable in class bb.common.BIZReason
DetailStatement - Static variable in class bb.common.Constant.StatementType
DIRECTEXCHANGERATE - Static variable in class bb.common.Constant.ExchangeRateType
DIRECTORY_NOT_EXIST - Static variable in class bb.common.BIZReason
DISASSEMBLE_WORK_ORDER - Static variable in class bb.common.BizTarget
DISASSEMBLE_WORK_ORDER_ALREADY_SETUP_OR_RUN - Static variable in class bb.common.BIZReason
DISASSEMBLE_WORK_ORDER_APPROVAL - Static variable in class bb.common.BizTarget
DISASSEMBLE_WORK_ORDER_APPROVAL_ALREADY_EXIST - Static variable in class bb.common.BIZReason
DISASSEMBLE_WORK_ORDER_APPROVAL_NOT_EXIST - Static variable in class bb.common.BIZReason
DISASSEMBLE_WORK_ORDER_ITEM - Static variable in class bb.common.BizTarget
DISASSEMBLE_WORK_ORDER_ITEM_GL_HAS_CREATED - Static variable in class bb.common.BIZReason
DISASSEMBLE_WORK_ORDER_ITEM_HAS_CLOSED - Static variable in class bb.common.BIZReason
DISASSEMBLE_WORK_ORDER_ITEM_HAS_NOT_CLOSED - Static variable in class bb.common.BIZReason
DISASSEMBLE_WORK_ORDER_ITEM_ISSUE - Static variable in class bb.common.BizTarget
DISASSEMBLE_WORK_ORDER_ITEM_NOT_EXIST - Static variable in class bb.common.BIZReason
DISASSEMBLE_WORK_ORDER_ITEM_NOT_OPEN - Static variable in class bb.common.BIZReason
DISASSEMBLE_WORK_ORDER_ITEM_RECEIVED_QTY_IS_OVER - Static variable in class bb.common.BIZReason
DISASSEMBLE_WORK_ORDER_ITEM_RECEIVER - Static variable in class bb.common.BizTarget
DISASSEMBLE_WORK_ORDER_ITEM_RECEIVER_NOT_EXIST - Static variable in class bb.common.BIZReason
DISASSEMBLE_WORK_ORDER_NOT_EXIST - Static variable in class bb.common.BIZReason
DISASSEMBLE_WORK_ORDER_NOT_OPEN - Static variable in class bb.common.BIZReason
DISASSEMBLEWORKORDER - Static variable in class bb.common.Constant.OrderType
DisassembleWorkOrderApprovalVO - Class in bb.common
DisassembleWorkOrderApprovalVO(String, String, BigDecimal, String, String) - Constructor for class bb.common.DisassembleWorkOrderApprovalVO
full constructor
DisassembleWorkOrderApprovalVO() - Constructor for class bb.common.DisassembleWorkOrderApprovalVO
default constructor
DisassembleWorkOrderDocumentVO - Class in bb.common
DisassembleWorkOrderDocumentVO(String, String, Date, String, String, Date, String, String, long) - Constructor for class bb.common.DisassembleWorkOrderDocumentVO
full constructor
DisassembleWorkOrderDocumentVO() - Constructor for class bb.common.DisassembleWorkOrderDocumentVO
default constructor
DisassembleWorkOrderDocumentVO(String, String, String, String, long) - Constructor for class bb.common.DisassembleWorkOrderDocumentVO
minimal constructor
DisassembleWorkOrderIssueVO - Class in bb.common
DisassembleWorkOrderIssueVO() - Constructor for class bb.common.DisassembleWorkOrderIssueVO
DisassembleWorkOrderIssuingItemResult - Class in bb.common
DisassembleWorkOrderIssuingItemResult() - Constructor for class bb.common.DisassembleWorkOrderIssuingItemResult
DisassembleWorkOrderIssuingResult - Class in bb.common
DisassembleWorkOrderIssuingResult() - Constructor for class bb.common.DisassembleWorkOrderIssuingResult
DisassembleWorkOrderItemListResult - Class in bb.common
DisassembleWorkOrderItemListResult() - Constructor for class bb.common.DisassembleWorkOrderItemListResult
DisassembleWorkOrderItemPartDetailItemResult - Class in bb.common
DisassembleWorkOrderItemPartDetailItemResult() - Constructor for class bb.common.DisassembleWorkOrderItemPartDetailItemResult
DisassembleWorkOrderItemPartDetailResult - Class in bb.common
DisassembleWorkOrderItemPartDetailResult() - Constructor for class bb.common.DisassembleWorkOrderItemPartDetailResult
DisassembleWorkOrderItemPK - Class in bb.common
DisassembleWorkOrderItemPK(String, String) - Constructor for class bb.common.DisassembleWorkOrderItemPK
DisassembleWorkOrderItemPK() - Constructor for class bb.common.DisassembleWorkOrderItemPK
DisassembleWorkOrderItemReceiverPK - Class in bb.common
DisassembleWorkOrderItemReceiverPK() - Constructor for class bb.common.DisassembleWorkOrderItemReceiverPK
DisassembleWorkOrderItemReceiverPK(String, String, Short) - Constructor for class bb.common.DisassembleWorkOrderItemReceiverPK
DisassembleWorkOrderItemReceiverVO - Class in bb.common
DisassembleWorkOrderItemReceiverVO() - Constructor for class bb.common.DisassembleWorkOrderItemReceiverVO
DisassembleWorkOrderItemVO - Class in bb.common
DisassembleWorkOrderItemVO() - Constructor for class bb.common.DisassembleWorkOrderItemVO
default constructor
DisassembleWorkOrderListResult - Class in bb.common
DisassembleWorkOrderListResult() - Constructor for class bb.common.DisassembleWorkOrderListResult
DisassembleWorkOrderReceivingResult - Class in bb.common
DisassembleWorkOrderReceivingResult() - Constructor for class bb.common.DisassembleWorkOrderReceivingResult
DisassembleWorkOrderVO - Class in bb.common
DisassembleWorkOrderVO(String, String, Date, Date, String, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, String, String, String, String, String, String, Date, String, String, Date, Date, int, String, Date, String, String, String, String, String, String, String, String, Date, String, String, String, String, String, String, String, String, String, boolean, int, CustomerVendorAddressInfoVO, CustomerVendorAddressInfoVO, CustomerVendorAddressInfoVO, Set, Set, String, boolean) - Constructor for class bb.common.DisassembleWorkOrderVO
DisassembleWorkOrderVO() - Constructor for class bb.common.DisassembleWorkOrderVO
distroy() - Method in class bb.common.Spiderman
DM - Static variable in class bb.common.Constant.Prefix
DOCUMENT - Static variable in class bb.common.BizTarget
DOCUMENT - Static variable in class bb.common.Configure.Module
DOCUMENT_NOT_FOUND - Static variable in class bb.common.BIZReason
DOCUMENT_SERVER_SETTINGS_ALREADY_EXIST - Static variable in class bb.common.BIZReason
DOCUMENT_SETTINGS - Static variable in class bb.common.BizTarget
DOCUMENT_SETTINGS_NOT_EXIST - Static variable in class bb.common.BIZReason
DOCUMENT_SETTINGS_NOT_SAVE_TO_FTP - Static variable in class bb.common.BIZReason
DOCUMENT_SETTINGS_WRONG - Static variable in class bb.common.BIZReason
DocumentAction - Class in bb.common
DocumentAction() - Constructor for class bb.common.DocumentAction
DocumentAction.DwfAndDwgDocAction - Class in bb.common
DocumentAction.DwfAndDwgDocAction() - Constructor for class bb.common.DocumentAction.DwfAndDwgDocAction
DocumentAction.MiscDocAction - Class in bb.common
DocumentAction.MiscDocAction() - Constructor for class bb.common.DocumentAction.MiscDocAction
DocumentAction.PartDocAction - Class in bb.common
DocumentAction.PartDocAction() - Constructor for class bb.common.DocumentAction.PartDocAction
DocumentBox - Interface in bb.common.box
DocumentInfoAgent - Class in bb.common
DocumentInfoAgent() - Constructor for class bb.common.DocumentInfoAgent
DocumentLogVO - Class in bb.common
DocumentLogVO(Long, String, Integer, String, String, Timestamp) - Constructor for class bb.common.DocumentLogVO
full constructor
DocumentLogVO() - Constructor for class bb.common.DocumentLogVO
default constructor
DocumentServerVO - Class in bb.common
DocumentServerVO() - Constructor for class bb.common.DocumentServerVO
DOES_NOT_SET_UNBILLED_ACCOUNT - Static variable in class bb.common.BIZReason
DOES_NOT_SET_UNBILLED_INCOME_ACCOUNT - Static variable in class bb.common.BIZReason
DoNotUse - Static variable in class bb.common.Constant.Status
DOWNLOAD - Static variable in class bb.common.BB2Event
downLoad() - Method in interface bb.common.box.DocumentBox
DOWNLOAD - Static variable in class bb.common.DocumentAction.DwfAndDwgDocAction
DOWNLOAD - Static variable in class bb.common.DocumentAction.PartDocAction
DOWNLOAD_ADDRESS_QA_DOC - Static variable in class bb.common.DocumentAction.MiscDocAction
DOWNLOAD_BALANCE_SHEET_DOC - Static variable in class bb.common.DocumentAction.MiscDocAction
DOWNLOAD_BALANCE_SHEET_SIDE_BY_SIDE_DOC - Static variable in class bb.common.DocumentAction.MiscDocAction
DOWNLOAD_CERTIFICATE_DOC - Static variable in class bb.common.DocumentAction.MiscDocAction
DOWNLOAD_CLOSING_STATEMENT_DOC - Static variable in class bb.common.DocumentAction.MiscDocAction
DOWNLOAD_CS_ITEM_DOC - Static variable in class bb.common.DocumentAction.MiscDocAction
DOWNLOAD_DWG - Static variable in class bb.common.DocumentAction.DwfAndDwgDocAction
DOWNLOAD_DWO_DOC - Static variable in class bb.common.DocumentAction.MiscDocAction
DOWNLOAD_ECN_DOC - Static variable in class bb.common.DocumentAction.MiscDocAction
DOWNLOAD_ECR_DOC - Static variable in class bb.common.DocumentAction.MiscDocAction
DOWNLOAD_EDC_DOC - Static variable in class bb.common.DocumentAction.MiscDocAction
DOWNLOAD_EMPLOYEE_RECORDS - Static variable in class bb.common.DocumentAction.MiscDocAction
DOWNLOAD_FILE - Static variable in class bb.common.DocumentAction.PartDocAction
DOWNLOAD_NCR_FILE - Static variable in class bb.common.DocumentAction.MiscDocAction
DOWNLOAD_ONLOAN_DOC - Static variable in class bb.common.DocumentAction.MiscDocAction
DOWNLOAD_PAR_ITEM_DOC - Static variable in class bb.common.DocumentAction.MiscDocAction
DOWNLOAD_PART_PICTURE - Static variable in class bb.common.DocumentAction.MiscDocAction
DOWNLOAD_PDF - Static variable in class bb.common.DocumentAction
DOWNLOAD_PO_DOC - Static variable in class bb.common.DocumentAction.MiscDocAction
DOWNLOAD_PROFIT_LOSS_DOC - Static variable in class bb.common.DocumentAction.MiscDocAction
DOWNLOAD_QT_DOC - Static variable in class bb.common.DocumentAction.MiscDocAction
DOWNLOAD_RMA_DOC - Static variable in class bb.common.DocumentAction.MiscDocAction
DOWNLOAD_SO_DOC - Static variable in class bb.common.DocumentAction.MiscDocAction
DOWNLOAD_WI_DOC - Static variable in class bb.common.DocumentAction.MiscDocAction
DOWNLOAD_WI_PICTURE - Static variable in class bb.common.DocumentAction.MiscDocAction
DOWNLOAD_WO_DOC - Static variable in class bb.common.DocumentAction.MiscDocAction
DOWNLOAD_ZIP - Static variable in class bb.common.DocumentAction
downloadAccInfoDocument(MiscDocAgent) - Method in interface bb.common.box.AccountingBox
downloadAddressQualityDocuments(MiscDocAgent) - Method in interface bb.common.box.QualityBox
downloadAllPartPictureByPk(MiscDocAgent) - Method in interface bb.common.box.EngineeringBox
downloadDCDoc(MiscDocAgent) - Method in interface bb.common.box.EngineeringBox
downLoadDWG(String) - Method in interface bb.common.box.EngineeringBox
downloadEmployeeRecord(MiscDocAgent) - Method in interface bb.common.box.HumanResourceBox
downloadFtpDWF(PartDwfAgent) - Method in interface bb.common.box.EngineeringBox
downloadFtpDWFForView(PartDwfAgent) - Method in interface bb.common.box.EngineeringBox
downloadFTPDWODoc(MiscDocAgent) - Method in interface bb.common.box.WorkOrderBox
downloadFTPECDoc(MiscDocAgent) - Method in interface bb.common.box.EngineeringBox
downloadFTPECRDoc(MiscDocAgent) - Method in interface bb.common.box.EngineeringBox
downloadFTPOrderDoc(MiscDocAgent) - Method in interface bb.common.box.CompanyBox
downloadFTPRMADoc(MiscDocAgent) - Method in interface bb.common.box.SalesBox
downloadFTPSODoc(MiscDocAgent) - Method in interface bb.common.box.SalesBox
downloadFTPWODoc(MiscDocAgent) - Method in interface bb.common.box.WorkOrderBox
downloadIncidentItemDoc(MiscDocAgent) - Method in interface bb.common.box.CustomerServiceBox
downloadMainPartPicture(MiscDocAgent) - Method in interface bb.common.box.EngineeringBox
downLoadNCRPicture(MiscDocAgent) - Method in interface bb.common.box.QualityBox
downloadOnloanDoc(MiscDocAgent) - Method in interface bb.common.box.ManufacturingBox
downloadPARDoc(MiscDocAgent) - Method in interface bb.common.box.QualityBox
downloadPartCertificateFile(MiscDocAgent) - Method in interface bb.common.box.QualityBox
downloadPODoc(MiscDocAgent) - Method in interface bb.common.box.PurchasingBox
downloadQuoteDocument(MiscDocAgent) - Method in interface bb.common.box.SalesBox
downloadWorkInstructionPicture(MiscDocAgent) - Method in interface bb.common.box.ManufacturingBox
downTaskFileByTaskId(Long, String) - Method in interface bb.common.box.CompanyBox
downWorkInstructionDocument(MiscDocAgent) - Method in interface bb.common.box.ManufacturingBox
DRAWING_WAS_DAMEDAGED - Static variable in class bb.common.BIZReason
dropAppColumn(String, String) - Method in interface bb.common.box.CompanyBox
dropAppTable(String) - Method in interface bb.common.box.CompanyBox
DUEDATE - Static variable in class bb.common.Constant.DateType
DuePATotalByVendorResult - Class in bb.common
DuePATotalByVendorResult() - Constructor for class bb.common.DuePATotalByVendorResult
DUPLICATE_ITEM - Static variable in class bb.common.BIZReason
DUPLICATE_KEY_EXCEPTION - Static variable in class bb.common.DBReason
DUPLICATE_KEY_ITEM - Static variable in class bb.common.BIZReason
DUPLICATE_LOGIN - Static variable in class bb.common.BIZReason
DUPLICATE_MPN - Static variable in class bb.common.BIZReason
DUPLICATE_PERIOD_ID - Static variable in class bb.common.BIZReason
DUPLICATE_REVISION_LETTERS - Static variable in class bb.common.BIZReason
duplicateVO(T) - Static method in class bb.common.BB2Util
DW - Static variable in class bb.common.Constant.Prefix
DWF_ACTION - Static variable in class bb.common.DocumentAction.DwfAndDwgDocAction
DWF_DRAWING - Static variable in class bb.common.BizTarget
DwfUploadSettingsVO - Class in bb.common
DwfUploadSettingsVO(String, boolean, String, String, String, String, String, String, String) - Constructor for class bb.common.DwfUploadSettingsVO
full constructor
DwfUploadSettingsVO() - Constructor for class bb.common.DwfUploadSettingsVO
default constructor
DWG_ACTION - Static variable in class bb.common.DocumentAction.DwfAndDwgDocAction
DWG_DRAWING - Static variable in class bb.common.BizTarget
DwgUploadSettingsVO - Class in bb.common
DwgUploadSettingsVO(String, boolean, String, String, String, String, String, String, String) - Constructor for class bb.common.DwgUploadSettingsVO
full constructor
DwgUploadSettingsVO() - Constructor for class bb.common.DwgUploadSettingsVO
default constructor
DWO - Static variable in class bb.common.Constant.PrintTemplateType
DWO_DOC - Static variable in class bb.common.Constant.MiscDocType
DWO_ITEM_RETURN_QTY_IS_OVER - Static variable in class bb.common.BIZReason
DWOIssueDetail - Class in bb.common
DWOIssueDetail() - Constructor for class bb.common.DWOIssueDetail
DynamicSearchFilter - Class in bb.common
DynamicSearchFilter() - Constructor for class bb.common.DynamicSearchFilter
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M N O P Q R S T U V W X Y Z


DisassembleWorkOrderApprovalVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DisassembleWorkOrderApprovalVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.DisassembleWorkOrderApprovalVO
All Implemented Interfaces:
java.io.Serializable
public class DisassembleWorkOrderApprovalVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
DisassembleWorkOrderApprovalVO()
default constructor
DisassembleWorkOrderApprovalVO(java.lang.String employeeId, java.lang.String userName, java.math.BigDecimal approvalLimit, java.lang.String currency, java.lang.String canApproveOwnWorkOrder)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getApprovalLimit()
java.lang.String | getCanApproveOwnWorkOrder()
java.lang.String | getCurrency()
java.lang.String | getEmployeeId()
java.lang.String | getUserName()
int | hashCode()
void | setApprovalLimit(java.math.BigDecimal approvalLimit)
void | setCanApproveOwnWorkOrder(java.lang.String canApproveOwnWorkOrder)
void | setCurrency(java.lang.String currency)
void | setEmployeeId(java.lang.String employeeId)
void | setUserName(java.lang.String userName)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

DisassembleWorkOrderApprovalVO

public DisassembleWorkOrderApprovalVO(java.lang.String employeeId,
                                      java.lang.String userName,
                                      java.math.BigDecimal approvalLimit,
                                      java.lang.String currency,
                                      java.lang.String canApproveOwnWorkOrder)
full constructor

DisassembleWorkOrderApprovalVO

public DisassembleWorkOrderApprovalVO()
default constructor

Method Detail

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getApprovalLimit

public java.math.BigDecimal getApprovalLimit()

setApprovalLimit

public void setApprovalLimit(java.math.BigDecimal approvalLimit)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getCanApproveOwnWorkOrder

public java.lang.String getCanApproveOwnWorkOrder()

setCanApproveOwnWorkOrder

public void setCanApproveOwnWorkOrder(java.lang.String canApproveOwnWorkOrder)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DisassembleWorkOrderDocumentVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DisassembleWorkOrderDocumentVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.DisassembleWorkOrderDocumentVO
All Implemented Interfaces:
java.io.Serializable
public class DisassembleWorkOrderDocumentVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
DisassembleWorkOrderDocumentVO()
default constructor
DisassembleWorkOrderDocumentVO(java.lang.String dwoNumber, java.lang.String docDescription, java.util.Date documentDate, java.lang.String comments, java.lang.String lastChangeUser, java.util.Date lastChangeDate, java.lang.String extension, java.lang.String docFileName, long docLength)
full constructor
DisassembleWorkOrderDocumentVO(java.lang.String dwoNumber, java.lang.String docDescription, java.lang.String extension, java.lang.String docFileName, long docLength)
minimal constructor
Method Summary
java.lang.String | getComments()
java.lang.String | getDocDescription()
java.lang.String | getDocFileName()
long | getDocLength()
java.util.Date | getDocumentDate()
java.lang.String | getDwoNumber()
java.lang.String | getExtension()
java.lang.Long | getIi()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
void | setComments(java.lang.String comments)
void | setDocDescription(java.lang.String docDescription)
void | setDocFileName(java.lang.String docFileName)
void | setDocLength(long docLength)
void | setDocumentDate(java.util.Date documentDate)
void | setDwoNumber(java.lang.String dwoNumber)
void | setExtension(java.lang.String extension)
void | setIi(java.lang.Long ii)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DisassembleWorkOrderDocumentVO

public DisassembleWorkOrderDocumentVO(java.lang.String dwoNumber,
                                      java.lang.String docDescription,
                                      java.util.Date documentDate,
                                      java.lang.String comments,
                                      java.lang.String lastChangeUser,
                                      java.util.Date lastChangeDate,
                                      java.lang.String extension,
                                      java.lang.String docFileName,
                                      long docLength)
full constructor

DisassembleWorkOrderDocumentVO

public DisassembleWorkOrderDocumentVO()
default constructor

DisassembleWorkOrderDocumentVO

public DisassembleWorkOrderDocumentVO(java.lang.String dwoNumber,
                                      java.lang.String docDescription,
                                      java.lang.String extension,
                                      java.lang.String docFileName,
                                      long docLength)
minimal constructor

Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getDwoNumber

public java.lang.String getDwoNumber()

setDwoNumber

public void setDwoNumber(java.lang.String dwoNumber)

getDocDescription

public java.lang.String getDocDescription()

setDocDescription

public void setDocDescription(java.lang.String docDescription)

getDocumentDate

public java.util.Date getDocumentDate()

setDocumentDate

public void setDocumentDate(java.util.Date documentDate)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

getDocFileName

public java.lang.String getDocFileName()

setDocFileName

public void setDocFileName(java.lang.String docFileName)

getDocLength

public long getDocLength()

setDocLength

public void setDocLength(long docLength)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DisassembleWorkOrderIssueVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DisassembleWorkOrderIssueVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.DisassembleWorkOrderIssueVO
All Implemented Interfaces:
java.io.Serializable
public class DisassembleWorkOrderIssueVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
DisassembleWorkOrderIssueVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCompanyUnitId()
java.lang.String | getCondition()
java.math.BigDecimal | getCost()
java.util.Date | getDateMade()
java.lang.String | getDescription()
java.lang.String | getDisassembleWorkOrderItemNumber()
java.lang.String | getDisassembleWorkOrderNumber()
java.math.BigDecimal | getDwoisCost()
java.math.BigDecimal | getDwoisStdCost()
java.lang.Long | getIi()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.util.Map | getLocations()
java.lang.String | getLot()
java.lang.String | getModelNumber()
java.lang.String | getOperator()
java.lang.Long | getOrderNumber()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getPicker()
java.math.BigDecimal | getQtyShip()
java.lang.String | getRefDoc2()
java.lang.String | getRevision()
java.lang.String | getSerial()
java.math.BigDecimal | getStdCost()
java.util.Map | getTrackings()
java.lang.String | getTransactionNumber()
java.lang.String | getUnit()
java.lang.String | getVendorID()
int | hashCode()
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCondition(java.lang.String condition)
void | setCost(java.math.BigDecimal cost)
void | setDateMade(java.util.Date dateMade)
void | setDescription(java.lang.String description)
void | setDisassembleWorkOrderItemNumber(java.lang.String disassembleWorkOrderItemNumber)
void | setDisassembleWorkOrderNumber(java.lang.String disassembleWorkOrderNumber)
void | setDwoisCost(java.math.BigDecimal dwoisCost)
void | setDwoisStdCost(java.math.BigDecimal dwoisStdCost)
void | setIi(java.lang.Long ii)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLocations(java.util.Map locations)
void | setLot(java.lang.String lot)
void | setModelNumber(java.lang.String modelNumber)
void | setOperator(java.lang.String operator)
void | setOrderNumber(java.lang.Long orderNumber)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPicker(java.lang.String picker)
void | setQtyShip(java.math.BigDecimal qtyShip)
void | setRefDoc2(java.lang.String refDoc2)
void | setRevision(java.lang.String revision)
void | setSerial(java.lang.String serial)
void | setStdCost(java.math.BigDecimal stdCost)
void | setTrackings(java.util.Map trackings)
void | setTransactionNumber(java.lang.String transactionNumber)
void | setUnit(java.lang.String unit)
void | setVendorID(java.lang.String vendorID)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

DisassembleWorkOrderIssueVO

public DisassembleWorkOrderIssueVO()
Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getDisassembleWorkOrderNumber

public java.lang.String getDisassembleWorkOrderNumber()

setDisassembleWorkOrderNumber

public void setDisassembleWorkOrderNumber(java.lang.String disassembleWorkOrderNumber)

getDisassembleWorkOrderItemNumber

public java.lang.String getDisassembleWorkOrderItemNumber()

setDisassembleWorkOrderItemNumber

public void setDisassembleWorkOrderItemNumber(java.lang.String disassembleWorkOrderItemNumber)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getDateMade

public java.util.Date getDateMade()

setDateMade

public void setDateMade(java.util.Date dateMade)

getQtyShip

public java.math.BigDecimal getQtyShip()

setQtyShip

public void setQtyShip(java.math.BigDecimal qtyShip)

getCondition

public java.lang.String getCondition()

setCondition

public void setCondition(java.lang.String condition)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getCost

public java.math.BigDecimal getCost()

setCost

public void setCost(java.math.BigDecimal cost)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getSerial

public java.lang.String getSerial()

setSerial

public void setSerial(java.lang.String serial)

getLot

public java.lang.String getLot()

setLot

public void setLot(java.lang.String lot)

getTransactionNumber

public java.lang.String getTransactionNumber()

setTransactionNumber

public void setTransactionNumber(java.lang.String transactionNumber)

getDwoisCost

public java.math.BigDecimal getDwoisCost()

setDwoisCost

public void setDwoisCost(java.math.BigDecimal dwoisCost)

getDwoisStdCost

public java.math.BigDecimal getDwoisStdCost()

setDwoisStdCost

public void setDwoisStdCost(java.math.BigDecimal dwoisStdCost)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getOrderNumber

public java.lang.Long getOrderNumber()

setOrderNumber

public void setOrderNumber(java.lang.Long orderNumber)

getVendorID

public java.lang.String getVendorID()

setVendorID

public void setVendorID(java.lang.String vendorID)

getOperator

public java.lang.String getOperator()

setOperator

public void setOperator(java.lang.String operator)

getPicker

public java.lang.String getPicker()

setPicker

public void setPicker(java.lang.String picker)

getLocations

public java.util.Map getLocations()

setLocations

public void setLocations(java.util.Map locations)

getTrackings

public java.util.Map getTrackings()

setTrackings

public void setTrackings(java.util.Map trackings)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DisassembleWorkOrderIssuingItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DisassembleWorkOrderIssuingItemResult

java.lang.Object
    extended by  bb.common.DisassembleWorkOrderIssuingItemResult
All Implemented Interfaces:
java.io.Serializable
public class DisassembleWorkOrderIssuingItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
DisassembleWorkOrderIssuingItemResult()
Method Summary
java.math.BigDecimal | getAvgCost()
java.lang.String | getComments()
java.math.BigDecimal | getCostPerUnit()
java.lang.String | getDescription()
java.lang.String | getDrawing()
java.math.BigDecimal | getIrTotalRefQty()
java.util.Set | getIssuedToOrderItems()
java.lang.String | getItemNumber()
java.math.BigDecimal | getMaxIssued()
java.lang.String | getMfg()
java.math.BigDecimal | getMinIssued()
java.lang.String | getMpn()
java.lang.String | getOrderNumber()
java.lang.String | getPartFrom()
java.util.Set | getPartLocations()
java.util.Set<PartManufacturerVO> | getPartManufacturers()
PartPK | getPartPk()
java.util.Set<PartTrackingVO> | getPartTracking()
java.lang.String | getPoUnit()
java.math.BigDecimal | getPoUnitQty()
java.lang.String | getPrivateNotes()
java.lang.String | getQCode()
java.math.BigDecimal | getQtyCheck()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getQuantityIssued()
java.lang.String | getRCode()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.lang.String | getRevision()
java.util.Date | getShipDate()
java.lang.String | getStatus()
java.math.BigDecimal | getTotalOnDemand()
java.math.BigDecimal | getTotalOnhand()
java.lang.String | getUnit()
boolean | isTraceable()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setComments(java.lang.String comments)
void | setCostPerUnit(java.math.BigDecimal costPerUnit)
void | setDescription(java.lang.String description)
void | setDrawing(java.lang.String drawing)
void | setIrTotalRefQty(java.math.BigDecimal irTotalRefQty)
void | setIssuedToOrderItems(java.util.Set issuedToOrderItems)
void | setItemNumber(java.lang.String itemNumber)
void | setMaxIssued(java.math.BigDecimal maxIssued)
void | setMfg(java.lang.String mfg)
void | setMinIssued(java.math.BigDecimal minIssued)
void | setMpn(java.lang.String mpn)
void | setOrderNumber(java.lang.String orderNumber)
void | setPartFrom(java.lang.String partFrom)
void | setPartLocations(java.util.Set partLocations)
void | setPartManufacturers(java.util.Set<PartManufacturerVO> partManufacturers)
void | setPartPk(PartPK partPk)
void | setPartTracking(java.util.Set<PartTrackingVO> partTracking)
void | setPoUnit(java.lang.String poUnit)
void | setPoUnitQty(java.math.BigDecimal poUnitQty)
void | setPrivateNotes(java.lang.String privateNotes)
void | setQCode(java.lang.String code)
void | setQtyCheck(java.math.BigDecimal qtyCheck)
void | setQuantity(java.math.BigDecimal quantity)
void | setQuantityIssued(java.math.BigDecimal quantityIssued)
void | setRCode(java.lang.String code)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setRevision(java.lang.String revision)
void | setShipDate(java.util.Date shipDate)
void | setStatus(java.lang.String status)
void | setTotalOnDemand(java.math.BigDecimal totalOnDemand)
void | setTotalOnhand(java.math.BigDecimal totalOnhand)
void | setTraceable(boolean traceable)
void | setUnit(java.lang.String unit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DisassembleWorkOrderIssuingItemResult

public DisassembleWorkOrderIssuingItemResult()
Method Detail

getOrderNumber

public java.lang.String getOrderNumber()

setOrderNumber

public void setOrderNumber(java.lang.String orderNumber)

getItemNumber

public java.lang.String getItemNumber()

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

getPartPk

public PartPK getPartPk()

setPartPk

public void setPartPk(PartPK partPk)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getDrawing

public java.lang.String getDrawing()

setDrawing

public void setDrawing(java.lang.String drawing)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

isTraceable

public boolean isTraceable()

setTraceable

public void setTraceable(boolean traceable)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getPrivateNotes

public java.lang.String getPrivateNotes()

setPrivateNotes

public void setPrivateNotes(java.lang.String privateNotes)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getQCode

public java.lang.String getQCode()

setQCode

public void setQCode(java.lang.String code)

getRCode

public java.lang.String getRCode()

setRCode

public void setRCode(java.lang.String code)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getQuantityIssued

public java.math.BigDecimal getQuantityIssued()

setQuantityIssued

public void setQuantityIssued(java.math.BigDecimal quantityIssued)

getMinIssued

public java.math.BigDecimal getMinIssued()

setMinIssued

public void setMinIssued(java.math.BigDecimal minIssued)

getMaxIssued

public java.math.BigDecimal getMaxIssued()

setMaxIssued

public void setMaxIssued(java.math.BigDecimal maxIssued)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getTotalOnhand

public java.math.BigDecimal getTotalOnhand()

setTotalOnhand

public void setTotalOnhand(java.math.BigDecimal totalOnhand)

getTotalOnDemand

public java.math.BigDecimal getTotalOnDemand()

setTotalOnDemand

public void setTotalOnDemand(java.math.BigDecimal totalOnDemand)

getPartLocations

public java.util.Set getPartLocations()

setPartLocations

public void setPartLocations(java.util.Set partLocations)

getPartTracking

public java.util.Set<PartTrackingVO> getPartTracking()

setPartTracking

public void setPartTracking(java.util.Set<PartTrackingVO> partTracking)

getIssuedToOrderItems

public java.util.Set getIssuedToOrderItems()

setIssuedToOrderItems

public void setIssuedToOrderItems(java.util.Set issuedToOrderItems)

getPoUnit

public java.lang.String getPoUnit()

setPoUnit

public void setPoUnit(java.lang.String poUnit)

getPoUnitQty

public java.math.BigDecimal getPoUnitQty()

setPoUnitQty

public void setPoUnitQty(java.math.BigDecimal poUnitQty)

getShipDate

public java.util.Date getShipDate()

setShipDate

public void setShipDate(java.util.Date shipDate)

getQtyCheck

public java.math.BigDecimal getQtyCheck()

setQtyCheck

public void setQtyCheck(java.math.BigDecimal qtyCheck)

getCostPerUnit

public java.math.BigDecimal getCostPerUnit()

setCostPerUnit

public void setCostPerUnit(java.math.BigDecimal costPerUnit)

getIrTotalRefQty

public java.math.BigDecimal getIrTotalRefQty()

setIrTotalRefQty

public void setIrTotalRefQty(java.math.BigDecimal irTotalRefQty)

getPartManufacturers

public java.util.Set<PartManufacturerVO> getPartManufacturers()

setPartManufacturers

public void setPartManufacturers(java.util.Set<PartManufacturerVO> partManufacturers)

getAvgCost

public java.math.BigDecimal getAvgCost()

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DisassembleWorkOrderIssuingResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DisassembleWorkOrderIssuingResult

java.lang.Object
    extended by  bb.common.DisassembleWorkOrderIssuingResult
All Implemented Interfaces:
java.io.Serializable
public class DisassembleWorkOrderIssuingResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
DisassembleWorkOrderIssuingResult()
Method Summary
java.lang.String | getChangeOrder()
java.lang.String | getCompanyUnitId()
java.lang.String | getDebitAccount()
java.util.Set<DisassembleWorkOrderIssuingItemResult> | getDisassembleIssuingItems()
java.math.BigDecimal | getFreight()
java.util.Date | getIssueDate()
java.lang.String | getOrderNumber()
java.lang.String | getProject()
java.lang.String | getReceiver()
java.lang.String | getRelatedDoc()
java.lang.String | getStatus()
java.lang.String | getUserName()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
boolean | isHold()
void | setChangeOrder(java.lang.String changeOrder)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setDebitAccount(java.lang.String debitAccount)
void | setDisassembleIssuingItems(java.util.Set<DisassembleWorkOrderIssuingItemResult> disassembleIssuingItems)
void | setFreight(java.math.BigDecimal freight)
void | setHold(boolean hold)
void | setIssueDate(java.util.Date issueDate)
void | setOrderNumber(java.lang.String orderNumber)
void | setProject(java.lang.String project)
void | setReceiver(java.lang.String receiver)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setStatus(java.lang.String status)
void | setUserName(java.lang.String userName)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DisassembleWorkOrderIssuingResult

public DisassembleWorkOrderIssuingResult()
Method Detail

getOrderNumber

public java.lang.String getOrderNumber()

setOrderNumber

public void setOrderNumber(java.lang.String orderNumber)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getVendorName

public java.lang.String getVendorName()

setVendorName

public void setVendorName(java.lang.String vendorName)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getDebitAccount

public java.lang.String getDebitAccount()

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

getFreight

public java.math.BigDecimal getFreight()

setFreight

public void setFreight(java.math.BigDecimal freight)

isHold

public boolean isHold()

setHold

public void setHold(boolean hold)

getReceiver

public java.lang.String getReceiver()

setReceiver

public void setReceiver(java.lang.String receiver)

getDisassembleIssuingItems

public java.util.Set<DisassembleWorkOrderIssuingItemResult> getDisassembleIssuingItems()

setDisassembleIssuingItems

public void setDisassembleIssuingItems(java.util.Set<DisassembleWorkOrderIssuingItemResult> disassembleIssuingItems)

getIssueDate

public java.util.Date getIssueDate()

setIssueDate

public void setIssueDate(java.util.Date issueDate)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DisassembleWorkOrderItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DisassembleWorkOrderItemListResult

java.lang.Object
    extended by  bb.common.DisassembleWorkOrderItemListResult
All Implemented Interfaces:
java.io.Serializable
public class DisassembleWorkOrderItemListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACCOUNTNUMBER
static java.lang.String | ORDER_BY_COMPANYUNITID
static java.lang.String | ORDER_BY_COSTPERUNIT
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_DISASSEMBLEWORKORDERITEMNUMBER
static java.lang.String | ORDER_BY_DISASSEMBLEWORKORDERNUMBER
static java.lang.String | ORDER_BY_DUEDATE
static java.lang.String | ORDER_BY_EXTENDPRICE
static java.lang.String | ORDER_BY_MFGSTATUS
static java.lang.String | ORDER_BY_ORDERRELATEDDOC
static java.lang.String | ORDER_BY_ORIGINATOR
static java.lang.String | ORDER_BY_PARTDESC
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_PRIORITY
static java.lang.String | ORDER_BY_PROJECT
static java.lang.String | ORDER_BY_QTY
static java.lang.String | ORDER_BY_QTY_SHIPPED
static java.lang.String | ORDER_BY_RELATEDDOC
static java.lang.String | ORDER_BY_STARTDATE
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_VENDORID
Constructor Summary
DisassembleWorkOrderItemListResult()
Method Summary
java.lang.String | getAccountNumber()
java.lang.String | getComments()
java.lang.String | getCompanyUnitId()
java.util.Date | getCompletedDate()
java.math.BigDecimal | getCostPerUnit()
java.lang.String | getCurrency()
java.util.Date | getDueDate()
DisassembleWorkOrderItemPK | getDwoItemPk()
java.math.BigDecimal | getExtendPrice()
java.math.BigDecimal | getInWIPQty()
java.lang.String | getMfgStatus()
java.math.BigDecimal | getNonIssueQty()
java.lang.String | getNotes()
java.lang.String | getOrderRelatedDoc()
java.lang.String | getOriginator()
java.math.BigDecimal | getPartAvgCost()
java.lang.String | getPartDesc()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.lang.String | getPriority()
java.lang.String | getProject()
java.math.BigDecimal | getQty()
java.math.BigDecimal | getQuantityShipped()
java.util.Set<RefdocElement> | getRefDoc1()
java.util.Set<RefdocElement> | getRefDoc2()
java.util.Set | getRefDocOnes()
java.util.Set | getRefDocTwoes()
java.lang.String | getRelatedDoc()
java.lang.String | getSetId()
java.util.Date | getStartDate()
java.lang.String | getStatus()
java.math.BigDecimal | getTotalIssuedCost()
java.math.BigDecimal | getTotalNonIssueCost()
java.math.BigDecimal | getTotalReceivedCost()
java.lang.String | getUnit()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
java.lang.String | getWoComments()
java.math.BigDecimal | getWowiPartAvgCost()
void | setAccountNumber(java.lang.String accountNumber)
void | setComments(java.lang.String comments)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCompletedDate(java.util.Date completedDate)
void | setCostPerUnit(java.math.BigDecimal costPerUnit)
void | setCurrency(java.lang.String currency)
void | setDueDate(java.util.Date dueDate)
void | setDwoItemPk(DisassembleWorkOrderItemPK dwoItemPk)
void | setExtendPrice(java.math.BigDecimal extendPrice)
void | setInWIPQty(java.math.BigDecimal inWIPQty)
void | setMfgStatus(java.lang.String mfgStatus)
void | setNonIssueQty(java.math.BigDecimal nonIssueQty)
void | setNotes(java.lang.String notes)
void | setOrderRelatedDoc(java.lang.String orderRelatedDoc)
void | setOriginator(java.lang.String originator)
void | setPartAvgCost(java.math.BigDecimal partAvgCost)
void | setPartDesc(java.lang.String partDesc)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setPriority(java.lang.String priority)
void | setProject(java.lang.String project)
void | setQty(java.math.BigDecimal qty)
void | setQuantityShipped(java.math.BigDecimal quantityShipped)
void | setRefDoc1(java.util.Set<RefdocElement> refDoc1)
void | setRefDoc2(java.util.Set<RefdocElement> refDoc2)
void | setRefDocOnes(java.util.Set refDocOnes)
void | setRefDocTwoes(java.util.Set refDocTwoes)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setSetId(java.lang.String setId)
void | setStartDate(java.util.Date startDate)
void | setStatus(java.lang.String status)
void | setTotalIssuedCost(java.math.BigDecimal totalIssuedCost)
void | setTotalNonIssueCost(java.math.BigDecimal totalNonIssueCost)
void | setTotalReceivedCost(java.math.BigDecimal totalReceivedCost)
void | setUnit(java.lang.String unit)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
void | setWoComments(java.lang.String woComments)
void | setWowiPartAvgCost(java.math.BigDecimal wowiPartAvgCost)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_DISASSEMBLEWORKORDERNUMBER

public static final java.lang.String ORDER_BY_DISASSEMBLEWORKORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_DISASSEMBLEWORKORDERITEMNUMBER

public static final java.lang.String ORDER_BY_DISASSEMBLEWORKORDERITEMNUMBER
See Also:
Constant Field Values

ORDER_BY_RELATEDDOC

public static final java.lang.String ORDER_BY_RELATEDDOC
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_DUEDATE

public static final java.lang.String ORDER_BY_DUEDATE
See Also:
Constant Field Values

ORDER_BY_STARTDATE

public static final java.lang.String ORDER_BY_STARTDATE
See Also:
Constant Field Values

ORDER_BY_PARTDESC

public static final java.lang.String ORDER_BY_PARTDESC
See Also:
Constant Field Values

ORDER_BY_ORIGINATOR

public static final java.lang.String ORDER_BY_ORIGINATOR
See Also:
Constant Field Values

ORDER_BY_PRIORITY

public static final java.lang.String ORDER_BY_PRIORITY
See Also:
Constant Field Values

ORDER_BY_PROJECT

public static final java.lang.String ORDER_BY_PROJECT
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_MFGSTATUS

public static final java.lang.String ORDER_BY_MFGSTATUS
See Also:
Constant Field Values

ORDER_BY_COSTPERUNIT

public static final java.lang.String ORDER_BY_COSTPERUNIT
See Also:
Constant Field Values

ORDER_BY_EXTENDPRICE

public static final java.lang.String ORDER_BY_EXTENDPRICE
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values

ORDER_BY_ACCOUNTNUMBER

public static final java.lang.String ORDER_BY_ACCOUNTNUMBER
See Also:
Constant Field Values

ORDER_BY_COMPANYUNITID

public static final java.lang.String ORDER_BY_COMPANYUNITID
See Also:
Constant Field Values

ORDER_BY_QTY

public static final java.lang.String ORDER_BY_QTY
See Also:
Constant Field Values

ORDER_BY_QTY_SHIPPED

public static final java.lang.String ORDER_BY_QTY_SHIPPED
See Also:
Constant Field Values

ORDER_BY_ORDERRELATEDDOC

public static final java.lang.String ORDER_BY_ORDERRELATEDDOC
See Also:
Constant Field Values
Constructor Detail

DisassembleWorkOrderItemListResult

public DisassembleWorkOrderItemListResult()
Method Detail

getDwoItemPk

public DisassembleWorkOrderItemPK getDwoItemPk()

setDwoItemPk

public void setDwoItemPk(DisassembleWorkOrderItemPK dwoItemPk)

getPartPk

public PartPK getPartPk()

setPartPk

public void setPartPk(PartPK partPk)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getPartDesc

public java.lang.String getPartDesc()

setPartDesc

public void setPartDesc(java.lang.String partDesc)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

getQuantityShipped

public java.math.BigDecimal getQuantityShipped()

setQuantityShipped

public void setQuantityShipped(java.math.BigDecimal quantityShipped)

getNonIssueQty

public java.math.BigDecimal getNonIssueQty()

setNonIssueQty

public void setNonIssueQty(java.math.BigDecimal nonIssueQty)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getVendorName

public java.lang.String getVendorName()

setVendorName

public void setVendorName(java.lang.String vendorName)

getStartDate

public java.util.Date getStartDate()

setStartDate

public void setStartDate(java.util.Date startDate)

getDueDate

public java.util.Date getDueDate()

setDueDate

public void setDueDate(java.util.Date dueDate)

getCompletedDate

public java.util.Date getCompletedDate()

setCompletedDate

public void setCompletedDate(java.util.Date completedDate)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getOriginator

public java.lang.String getOriginator()

setOriginator

public void setOriginator(java.lang.String originator)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getNotes

public java.lang.String getNotes()

setNotes

public void setNotes(java.lang.String notes)

getRefDoc1

public java.util.Set<RefdocElement> getRefDoc1()

setRefDoc1

public void setRefDoc1(java.util.Set<RefdocElement> refDoc1)

getRefDoc2

public java.util.Set<RefdocElement> getRefDoc2()

setRefDoc2

public void setRefDoc2(java.util.Set<RefdocElement> refDoc2)

getMfgStatus

public java.lang.String getMfgStatus()

setMfgStatus

public void setMfgStatus(java.lang.String mfgStatus)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getWoComments

public java.lang.String getWoComments()

setWoComments

public void setWoComments(java.lang.String woComments)

getSetId

public java.lang.String getSetId()

setSetId

public void setSetId(java.lang.String setId)

getCostPerUnit

public java.math.BigDecimal getCostPerUnit()

setCostPerUnit

public void setCostPerUnit(java.math.BigDecimal costPerUnit)

getExtendPrice

public java.math.BigDecimal getExtendPrice()

setExtendPrice

public void setExtendPrice(java.math.BigDecimal extendPrice)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getTotalNonIssueCost

public java.math.BigDecimal getTotalNonIssueCost()

setTotalNonIssueCost

public void setTotalNonIssueCost(java.math.BigDecimal totalNonIssueCost)

getTotalIssuedCost

public java.math.BigDecimal getTotalIssuedCost()

setTotalIssuedCost

public void setTotalIssuedCost(java.math.BigDecimal totalIssuedCost)

getPartAvgCost

public java.math.BigDecimal getPartAvgCost()

setPartAvgCost

public void setPartAvgCost(java.math.BigDecimal partAvgCost)

getInWIPQty

public java.math.BigDecimal getInWIPQty()

setInWIPQty

public void setInWIPQty(java.math.BigDecimal inWIPQty)

getWowiPartAvgCost

public java.math.BigDecimal getWowiPartAvgCost()

setWowiPartAvgCost

public void setWowiPartAvgCost(java.math.BigDecimal wowiPartAvgCost)

getOrderRelatedDoc

public java.lang.String getOrderRelatedDoc()

setOrderRelatedDoc

public void setOrderRelatedDoc(java.lang.String orderRelatedDoc)

getRefDocOnes

public java.util.Set getRefDocOnes()

setRefDocOnes

public void setRefDocOnes(java.util.Set refDocOnes)

getRefDocTwoes

public java.util.Set getRefDocTwoes()

setRefDocTwoes

public void setRefDocTwoes(java.util.Set refDocTwoes)

getTotalReceivedCost

public java.math.BigDecimal getTotalReceivedCost()

setTotalReceivedCost

public void setTotalReceivedCost(java.math.BigDecimal totalReceivedCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DisassembleWorkOrderItemPartDetailItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DisassembleWorkOrderItemPartDetailItemResult

java.lang.Object
    extended by  bb.common.DisassembleWorkOrderItemPartDetailItemResult
All Implemented Interfaces:
java.io.Serializable
public class DisassembleWorkOrderItemPartDetailItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
DisassembleWorkOrderItemPartDetailItemResult()
Method Summary
java.math.BigDecimal | getAvgCost()
java.math.BigDecimal | getCost()
java.util.Date | getDateReceived()
java.lang.String | getDescription()
DisassembleWorkOrderItemReceiverPK | getItemReceivePk()
java.lang.String | getLot()
java.math.BigDecimal | getOndemand()
java.math.BigDecimal | getOnhand()
java.math.BigDecimal | getOnorder()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getReceivedQuantity()
DisassembleWorkOrderItemReceiverVO | getReceiveVo()
java.lang.String | getRef()
java.util.Set | getRefDoc1Set()
java.lang.String | getSerial()
java.math.BigDecimal | getStdCost()
java.lang.String | getUnit()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setCost(java.math.BigDecimal cost)
void | setOndemand(java.math.BigDecimal ondemand)
void | setOnhand(java.math.BigDecimal onhand)
void | setOnorder(java.math.BigDecimal onorder)
void | setQuantity(java.math.BigDecimal qty)
void | setReceiveVo(DisassembleWorkOrderItemReceiverVO receiveVo)
void | setRefDoc1Set(java.util.Set refDoc1Set)
void | setStdCost(java.math.BigDecimal stdCost)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DisassembleWorkOrderItemPartDetailItemResult

public DisassembleWorkOrderItemPartDetailItemResult()
Method Detail

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

setRefDoc1Set

public void setRefDoc1Set(java.util.Set refDoc1Set)

getAvgCost

public java.math.BigDecimal getAvgCost()

getOnhand

public java.math.BigDecimal getOnhand()

getRefDoc1Set

public java.util.Set getRefDoc1Set()

getPartPk

public PartPK getPartPk()

getItemReceivePk

public DisassembleWorkOrderItemReceiverPK getItemReceivePk()

getPartFrom

public java.lang.String getPartFrom()

getDescription

public java.lang.String getDescription()

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal qty)

getReceivedQuantity

public java.math.BigDecimal getReceivedQuantity()

getUnit

public java.lang.String getUnit()

getDateReceived

public java.util.Date getDateReceived()

getSerial

public java.lang.String getSerial()

getLot

public java.lang.String getLot()

getRef

public java.lang.String getRef()

getCost

public java.math.BigDecimal getCost()

setCost

public void setCost(java.math.BigDecimal cost)

getOndemand

public java.math.BigDecimal getOndemand()

setOndemand

public void setOndemand(java.math.BigDecimal ondemand)

getOnorder

public java.math.BigDecimal getOnorder()

setOnorder

public void setOnorder(java.math.BigDecimal onorder)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getReceiveVo

public DisassembleWorkOrderItemReceiverVO getReceiveVo()

setReceiveVo

public void setReceiveVo(DisassembleWorkOrderItemReceiverVO receiveVo)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DisassembleWorkOrderItemPartDetailResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DisassembleWorkOrderItemPartDetailResult

java.lang.Object
    extended by  bb.common.DisassembleWorkOrderItemPartDetailResult
All Implemented Interfaces:
java.io.Serializable
public class DisassembleWorkOrderItemPartDetailResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
DisassembleWorkOrderItemPartDetailResult()
Method Summary
java.math.BigDecimal | getBomCost()
java.math.BigDecimal | getBomStdCost()
java.lang.String | getDescription()
java.math.BigDecimal | getDiffCost()
DisassembleWorkOrderItemPK | getDisassembleWorkOrderItemPk()
java.util.Set<DisassembleWorkOrderItemPartDetailItemResult> | getItems()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.math.BigDecimal | getQuantity()
java.util.Date | getReceiveDate()
java.math.BigDecimal | getReceivedCost()
java.util.Date | getReceivedDate()
java.math.BigDecimal | getReceivedStdCost()
java.util.Set | getRefDocTwoes()
java.lang.String | getReviewedBy()
java.util.Date | getReviewedDate()
java.lang.String | getReviewedDesc()
java.math.BigDecimal | getShortageCost()
java.math.BigDecimal | getShortageStdCost()
java.util.Date | getStartDate()
java.lang.String | getStatus()
java.math.BigDecimal | getSumCost()
java.math.BigDecimal | getTotControlCost()
java.math.BigDecimal | getVarianceCost()
java.lang.String | getWiSetId()
boolean | isCostAlarm()
void | setBomCost(java.math.BigDecimal bomCost)
void | setBomStdCost(java.math.BigDecimal bomStdCost)
void | setCostAlarm(boolean costAlarm)
void | setDescription(java.lang.String description)
void | setDiffCost(java.math.BigDecimal diffCost)
void | setDisassembleWorkOrderItemPk(DisassembleWorkOrderItemPK disassembleWorkOrderItemPk)
void | setItems(java.util.Set<DisassembleWorkOrderItemPartDetailItemResult> items)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setQuantity(java.math.BigDecimal quantity)
void | setReceiveDate(java.util.Date receiveDate)
void | setReceivedCost(java.math.BigDecimal receivedCost)
void | setReceivedStdCost(java.math.BigDecimal receivedStdCost)
void | setRefDocTwoes(java.util.Set refDocTwoes)
void | setReviewedBy(java.lang.String reviewedBy)
void | setReviewedDate(java.util.Date reviewedDate)
void | setReviewedDesc(java.lang.String reviewedDesc)
void | setShortageCost(java.math.BigDecimal shortageCost)
void | setShortageStdCost(java.math.BigDecimal shortageStdCost)
void | setStartDate(java.util.Date startDate)
void | setStatus(java.lang.String status)
void | setSumCost(java.math.BigDecimal sumCost)
void | setTotControlCost(java.math.BigDecimal totControlCost)
void | setVarianceCost(java.math.BigDecimal varianceCost)
void | setWiSetId(java.lang.String wiSetId)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DisassembleWorkOrderItemPartDetailResult

public DisassembleWorkOrderItemPartDetailResult()
Method Detail

setDisassembleWorkOrderItemPk

public void setDisassembleWorkOrderItemPk(DisassembleWorkOrderItemPK disassembleWorkOrderItemPk)

setPartPk

public void setPartPk(PartPK partPk)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setDescription

public void setDescription(java.lang.String description)

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

setStartDate

public void setStartDate(java.util.Date startDate)

setReceiveDate

public void setReceiveDate(java.util.Date receiveDate)

setWiSetId

public void setWiSetId(java.lang.String wiSetId)

setStatus

public void setStatus(java.lang.String status)

setItems

public void setItems(java.util.Set<DisassembleWorkOrderItemPartDetailItemResult> items)

setBomCost

public void setBomCost(java.math.BigDecimal bomCost)

setReceivedCost

public void setReceivedCost(java.math.BigDecimal receivedCost)

setShortageCost

public void setShortageCost(java.math.BigDecimal shortageCost)

getDisassembleWorkOrderItemPk

public DisassembleWorkOrderItemPK getDisassembleWorkOrderItemPk()

getPartPk

public PartPK getPartPk()

getPartFrom

public java.lang.String getPartFrom()

getDescription

public java.lang.String getDescription()

getQuantity

public java.math.BigDecimal getQuantity()

getStartDate

public java.util.Date getStartDate()

getReceivedDate

public java.util.Date getReceivedDate()

getWiSetId

public java.lang.String getWiSetId()

getStatus

public java.lang.String getStatus()

getItems

public java.util.Set<DisassembleWorkOrderItemPartDetailItemResult> getItems()

getBomCost

public java.math.BigDecimal getBomCost()

getReceivedCost

public java.math.BigDecimal getReceivedCost()

getShortageCost

public java.math.BigDecimal getShortageCost()

getRefDocTwoes

public java.util.Set getRefDocTwoes()

setRefDocTwoes

public void setRefDocTwoes(java.util.Set refDocTwoes)

isCostAlarm

public boolean isCostAlarm()

setCostAlarm

public void setCostAlarm(boolean costAlarm)

getReviewedBy

public java.lang.String getReviewedBy()

setReviewedBy

public void setReviewedBy(java.lang.String reviewedBy)

getReviewedDate

public java.util.Date getReviewedDate()

setReviewedDate

public void setReviewedDate(java.util.Date reviewedDate)

getReviewedDesc

public java.lang.String getReviewedDesc()

setReviewedDesc

public void setReviewedDesc(java.lang.String reviewedDesc)

getDiffCost

public java.math.BigDecimal getDiffCost()

setDiffCost

public void setDiffCost(java.math.BigDecimal diffCost)

getSumCost

public java.math.BigDecimal getSumCost()

setSumCost

public void setSumCost(java.math.BigDecimal sumCost)

getTotControlCost

public java.math.BigDecimal getTotControlCost()

setTotControlCost

public void setTotControlCost(java.math.BigDecimal totControlCost)

getVarianceCost

public java.math.BigDecimal getVarianceCost()

setVarianceCost

public void setVarianceCost(java.math.BigDecimal varianceCost)

getBomStdCost

public java.math.BigDecimal getBomStdCost()

setBomStdCost

public void setBomStdCost(java.math.BigDecimal bomStdCost)

getReceivedStdCost

public java.math.BigDecimal getReceivedStdCost()

setReceivedStdCost

public void setReceivedStdCost(java.math.BigDecimal receivedStdCost)

getShortageStdCost

public java.math.BigDecimal getShortageStdCost()

setShortageStdCost

public void setShortageStdCost(java.math.BigDecimal shortageStdCost)

getReceiveDate

public java.util.Date getReceiveDate()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DisassembleWorkOrderItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DisassembleWorkOrderItemPK

java.lang.Object
    extended by  bb.common.DisassembleWorkOrderItemPK
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<DisassembleWorkOrderItemPK>
public class DisassembleWorkOrderItemPK
extends java.lang.Object
implements java.io.Serializable, java.lang.Comparable<DisassembleWorkOrderItemPK>

See Also:
Serialized Form

Constructor Summary
DisassembleWorkOrderItemPK()
DisassembleWorkOrderItemPK(java.lang.String disassembleWorkOrderNumber, java.lang.String disassembleWorkOrderItemNumber)
Method Summary
int | compareTo(DisassembleWorkOrderItemPK other)
boolean | equals(java.lang.Object other)
java.lang.String | getDisassembleWorkOrderItemNumber()
java.lang.String | getDisassembleWorkOrderNumber()
int | hashCode()
void | setDisassembleWorkOrderItemNumber(java.lang.String disassembleWorkOrderItemNumber)
void | setDisassembleWorkOrderNumber(java.lang.String disassembleWorkOrderNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

DisassembleWorkOrderItemPK

public DisassembleWorkOrderItemPK(java.lang.String disassembleWorkOrderNumber,
                                  java.lang.String disassembleWorkOrderItemNumber)

DisassembleWorkOrderItemPK

public DisassembleWorkOrderItemPK()
Method Detail

getDisassembleWorkOrderNumber

public java.lang.String getDisassembleWorkOrderNumber()

setDisassembleWorkOrderNumber

public void setDisassembleWorkOrderNumber(java.lang.String disassembleWorkOrderNumber)

getDisassembleWorkOrderItemNumber

public java.lang.String getDisassembleWorkOrderItemNumber()

setDisassembleWorkOrderItemNumber

public void setDisassembleWorkOrderItemNumber(java.lang.String disassembleWorkOrderItemNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

compareTo

public int compareTo(DisassembleWorkOrderItemPK other)
Specified by:
compareTo in interface java.lang.Comparable<DisassembleWorkOrderItemPK>
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DisassembleWorkOrderItemReceiverPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DisassembleWorkOrderItemReceiverPK

java.lang.Object
    extended by  bb.common.DisassembleWorkOrderItemReceiverPK
All Implemented Interfaces:
java.io.Serializable
public class DisassembleWorkOrderItemReceiverPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
DisassembleWorkOrderItemReceiverPK()
DisassembleWorkOrderItemReceiverPK(java.lang.String disassembleWorkOrderNumber, java.lang.String disassembleWorkOrderItemNumber, java.lang.Short itemNumber)
Method Summary
boolean | equals(java.lang.Object obj)
java.lang.String | getDisassembleWorkOrderItemNumber()
java.lang.String | getDisassembleWorkOrderNumber()
java.lang.Short | getItemNumber()
int | hashCode()
void | setDisassembleWorkOrderItemNumber(java.lang.String disassembleWorkOrderItemNumber)
void | setDisassembleWorkOrderNumber(java.lang.String disassembleWorkOrderNumber)
void | setItemNumber(java.lang.Short itemNumber)
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DisassembleWorkOrderItemReceiverPK

public DisassembleWorkOrderItemReceiverPK()

DisassembleWorkOrderItemReceiverPK

public DisassembleWorkOrderItemReceiverPK(java.lang.String disassembleWorkOrderNumber,
                                          java.lang.String disassembleWorkOrderItemNumber,
                                          java.lang.Short itemNumber)
Method Detail

getDisassembleWorkOrderNumber

public java.lang.String getDisassembleWorkOrderNumber()

setDisassembleWorkOrderNumber

public void setDisassembleWorkOrderNumber(java.lang.String disassembleWorkOrderNumber)

getDisassembleWorkOrderItemNumber

public java.lang.String getDisassembleWorkOrderItemNumber()

setDisassembleWorkOrderItemNumber

public void setDisassembleWorkOrderItemNumber(java.lang.String disassembleWorkOrderItemNumber)

getItemNumber

public java.lang.Short getItemNumber()

setItemNumber

public void setItemNumber(java.lang.Short itemNumber)

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DisassembleWorkOrderItemReceiverVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DisassembleWorkOrderItemReceiverVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.DisassembleWorkOrderItemReceiverVO
All Implemented Interfaces:
java.io.Serializable
public class DisassembleWorkOrderItemReceiverVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
DisassembleWorkOrderItemReceiverVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getBc()
byte | getBnIi()
java.lang.String | getBomColor()
java.lang.String | getBomItemNumber()
java.math.BigDecimal | getBomItemQty()
int | getBomLastChangeTimes()
byte | getBomLevel()
java.lang.String | getBomNumber()
java.lang.String | getComments()
java.math.BigDecimal | getCost()
java.util.Date | getDateReceived()
java.lang.String | getDescription()
java.math.BigDecimal | getDwoicCost()
java.math.BigDecimal | getEmployeeLaborCost()
java.lang.String | getIrNumber()
java.util.Date | getLastDate()
java.util.Map | getLocations()
java.lang.String | getLot()
java.lang.String | getModelNumber()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
DisassembleWorkOrderItemReceiverPK | getPk()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getReceivedQuantity()
java.lang.String | getReferenceDoc1()
java.lang.String | getRevision()
java.lang.String | getSerial()
java.util.Map | getTrackings()
java.lang.String | getUnit()
int | hashCode()
void | setBc(java.lang.String bc)
void | setBnIi(byte bnIi)
void | setBomColor(java.lang.String bomColor)
void | setBomItemNumber(java.lang.String bomItemNumber)
void | setBomItemQty(java.math.BigDecimal bomItemQty)
void | setBomLastChangeTimes(int bomLastChangeTimes)
void | setBomLevel(byte bomLevel)
void | setBomNumber(java.lang.String bomNumber)
void | setComments(java.lang.String comments)
void | setCost(java.math.BigDecimal cost)
void | setDateReceived(java.util.Date dateReceived)
void | setDescription(java.lang.String description)
void | setDwoicCost(java.math.BigDecimal dwoicCost)
void | setEmployeeLaborCost(java.math.BigDecimal employeeLaborCost)
void | setIrNumber(java.lang.String irNumber)
void | setLastDate(java.util.Date lastDate)
void | setLocations(java.util.Map locations)
void | setLot(java.lang.String lot)
void | setModelNumber(java.lang.String modelNumber)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(DisassembleWorkOrderItemReceiverPK pk)
void | setQuantity(java.math.BigDecimal quantity)
void | setReceivedQuantity(java.math.BigDecimal receivedQuantity)
void | setReferenceDoc1(java.lang.String referenceDoc1)
void | setRevision(java.lang.String revision)
void | setSerial(java.lang.String serial)
void | setTrackings(java.util.Map trackings)
void | setUnit(java.lang.String unit)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

DisassembleWorkOrderItemReceiverVO

public DisassembleWorkOrderItemReceiverVO()
Method Detail

getPk

public DisassembleWorkOrderItemReceiverPK getPk()

setPk

public void setPk(DisassembleWorkOrderItemReceiverPK pk)

getReferenceDoc1

public java.lang.String getReferenceDoc1()

setReferenceDoc1

public void setReferenceDoc1(java.lang.String referenceDoc1)

getBomLastChangeTimes

public int getBomLastChangeTimes()

setBomLastChangeTimes

public void setBomLastChangeTimes(int bomLastChangeTimes)

getBomColor

public java.lang.String getBomColor()

setBomColor

public void setBomColor(java.lang.String bomColor)

getBomLevel

public byte getBomLevel()

setBomLevel

public void setBomLevel(byte bomLevel)

getBomNumber

public java.lang.String getBomNumber()

setBomNumber

public void setBomNumber(java.lang.String bomNumber)

getBnIi

public byte getBnIi()

setBnIi

public void setBnIi(byte bnIi)

getBomItemQty

public java.math.BigDecimal getBomItemQty()

setBomItemQty

public void setBomItemQty(java.math.BigDecimal bomItemQty)

getBomItemNumber

public java.lang.String getBomItemNumber()

setBomItemNumber

public void setBomItemNumber(java.lang.String bomItemNumber)

getBc

public java.lang.String getBc()

setBc

public void setBc(java.lang.String bc)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getReceivedQuantity

public java.math.BigDecimal getReceivedQuantity()

setReceivedQuantity

public void setReceivedQuantity(java.math.BigDecimal receivedQuantity)

getDateReceived

public java.util.Date getDateReceived()

setDateReceived

public void setDateReceived(java.util.Date dateReceived)

getLastDate

public java.util.Date getLastDate()

setLastDate

public void setLastDate(java.util.Date lastDate)

getCost

public java.math.BigDecimal getCost()

setCost

public void setCost(java.math.BigDecimal cost)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getSerial

public java.lang.String getSerial()

setSerial

public void setSerial(java.lang.String serial)

getLot

public java.lang.String getLot()

setLot

public void setLot(java.lang.String lot)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getDwoicCost

public java.math.BigDecimal getDwoicCost()

setDwoicCost

public void setDwoicCost(java.math.BigDecimal dwoicCost)

getEmployeeLaborCost

public java.math.BigDecimal getEmployeeLaborCost()

setEmployeeLaborCost

public void setEmployeeLaborCost(java.math.BigDecimal employeeLaborCost)

getIrNumber

public java.lang.String getIrNumber()

setIrNumber

public void setIrNumber(java.lang.String irNumber)

getLocations

public java.util.Map getLocations()

setLocations

public void setLocations(java.util.Map locations)

getTrackings

public java.util.Map getTrackings()

setTrackings

public void setTrackings(java.util.Map trackings)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DisassembleWorkOrderItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DisassembleWorkOrderItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.DisassembleWorkOrderItemVO
All Implemented Interfaces:
java.io.Serializable
public class DisassembleWorkOrderItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
DisassembleWorkOrderItemVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getActual()
java.lang.String | getChangeOrder()
java.math.BigDecimal | getCostPerUnit()
java.util.Date | getDateRequired()
int | getDelayDays()
java.lang.String | getDescription()
java.util.Date | getDesired()
java.lang.String | getDisassembleWorkOrderItemComments()
java.lang.String | getDisassembleWorkOrderItemPrivateNotes()
java.math.BigDecimal | getDiscount()
java.lang.String | getDwg()
java.math.BigDecimal | getDwoDisc()
java.math.BigDecimal | getDwoMade()
java.math.BigDecimal | getDwoOpen()
java.math.BigDecimal | getDwoSub()
java.math.BigDecimal | getDwoTax()
java.math.BigDecimal | getDwoTotal()
java.math.BigDecimal | getExtendPrice()
java.math.BigDecimal | getFreight()
java.lang.String | getHold()
java.math.BigDecimal | getHqa()
java.math.BigDecimal | getList()
java.lang.String | getLocation()
java.lang.String | getMfgStatus()
java.lang.String | getModelNumber()
java.util.Date | getOriginal()
java.math.BigDecimal | getOriginalCost()
java.math.BigDecimal | getOverPercent()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getPartUnit()
DisassembleWorkOrderItemPK | getPk()
java.lang.String | getPriority()
java.lang.String | getQr()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getQuantityShip()
java.util.Set | getRefDocOnes()
java.util.Set | getRefDocTwoes()
java.lang.String | getReferenceDoc1()
java.lang.String | getReferenceDoc2()
java.lang.String | getRelatedDoc()
java.lang.String | getReviewDescription()
java.lang.String | getReviewedBy()
java.util.Date | getReviewedDate()
java.lang.String | getRevision()
java.lang.String | getSetId()
java.lang.String | getShipVia()
java.util.Date | getStartDate()
java.lang.String | getStatus()
java.math.BigDecimal | getStdCostPerUnit()
java.math.BigDecimal | getTaxRate()
java.lang.String | getUnit()
java.lang.String | getWiFlag()
int | hashCode()
boolean | isCostAlarm()
boolean | isCreatedGL()
void | setActual(java.util.Date actual)
void | setChangeOrder(java.lang.String changeOrder)
void | setCostAlarm(boolean costAlarm)
void | setCostPerUnit(java.math.BigDecimal costPerUnit)
void | setCreatedGL(boolean createdGL)
void | setDateRequired(java.util.Date dateRequired)
void | setDelayDays(int delayDays)
void | setDescription(java.lang.String description)
void | setDesired(java.util.Date desired)
void | setDisassembleWorkOrderItemComments(java.lang.String disassembleWorkOrderItemComments)
void | setDisassembleWorkOrderItemPrivateNotes(java.lang.String disassembleWorkOrderItemPrivateNotes)
void | setDiscount(java.math.BigDecimal discount)
void | setDwg(java.lang.String dwg)
void | setDwoDisc(java.math.BigDecimal dwoDisc)
void | setDwoMade(java.math.BigDecimal dwoMade)
void | setDwoOpen(java.math.BigDecimal dwoOpen)
void | setDwoSub(java.math.BigDecimal dwoSub)
void | setDwoTax(java.math.BigDecimal dwoTax)
void | setDwoTotal(java.math.BigDecimal dwoTotal)
void | setExtendPrice(java.math.BigDecimal extendPrice)
void | setFreight(java.math.BigDecimal freight)
void | setHold(java.lang.String hold)
void | setHqa(java.math.BigDecimal hqa)
void | setList(java.math.BigDecimal list)
void | setLocation(java.lang.String location)
void | setMfgStatus(java.lang.String mfgStatus)
void | setModelNumber(java.lang.String modelNumber)
void | setOriginal(java.util.Date original)
void | setOriginalCost(java.math.BigDecimal originalCost)
void | setOverPercent(java.math.BigDecimal overPercent)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPartUnit(java.lang.String partUnit)
void | setPk(DisassembleWorkOrderItemPK pk)
void | setPriority(java.lang.String priority)
void | setQr(java.lang.String qr)
void | setQuantity(java.math.BigDecimal quantity)
void | setQuantityShip(java.math.BigDecimal quantityShip)
void | setRefDocOnes(java.util.Set refDocOnes)
void | setRefDocTwoes(java.util.Set refDocTwoes)
void | setReferenceDoc1(java.lang.String referenceDoc1)
void | setReferenceDoc2(java.lang.String referenceDoc2)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setReviewDescription(java.lang.String reviewDescription)
void | setReviewedBy(java.lang.String reviewedBy)
void | setReviewedDate(java.util.Date reviewedDate)
void | setRevision(java.lang.String revision)
void | setSetId(java.lang.String setId)
void | setShipVia(java.lang.String shipVia)
void | setStartDate(java.util.Date startDate)
void | setStatus(java.lang.String status)
void | setStdCostPerUnit(java.math.BigDecimal stdCostPerUnit)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setUnit(java.lang.String unit)
void | setWiFlag(java.lang.String wiFlag)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

DisassembleWorkOrderItemVO

public DisassembleWorkOrderItemVO()
default constructor

Method Detail

getPk

public DisassembleWorkOrderItemPK getPk()

setPk

public void setPk(DisassembleWorkOrderItemPK pk)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getSetId

public java.lang.String getSetId()

setSetId

public void setSetId(java.lang.String setId)

getDwoSub

public java.math.BigDecimal getDwoSub()

setDwoSub

public void setDwoSub(java.math.BigDecimal dwoSub)

getDwoDisc

public java.math.BigDecimal getDwoDisc()

setDwoDisc

public void setDwoDisc(java.math.BigDecimal dwoDisc)

getExtendPrice

public java.math.BigDecimal getExtendPrice()

setExtendPrice

public void setExtendPrice(java.math.BigDecimal extendPrice)

getDwoMade

public java.math.BigDecimal getDwoMade()

setDwoMade

public void setDwoMade(java.math.BigDecimal dwoMade)

getDwoOpen

public java.math.BigDecimal getDwoOpen()

setDwoOpen

public void setDwoOpen(java.math.BigDecimal dwoOpen)

getDwoTax

public java.math.BigDecimal getDwoTax()

setDwoTax

public void setDwoTax(java.math.BigDecimal dwoTax)

getDwoTotal

public java.math.BigDecimal getDwoTotal()

setDwoTotal

public void setDwoTotal(java.math.BigDecimal dwoTotal)

getReferenceDoc1

public java.lang.String getReferenceDoc1()

setReferenceDoc1

public void setReferenceDoc1(java.lang.String referenceDoc1)

getReferenceDoc2

public java.lang.String getReferenceDoc2()

setReferenceDoc2

public void setReferenceDoc2(java.lang.String referenceDoc2)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getQr

public java.lang.String getQr()

setQr

public void setQr(java.lang.String qr)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getMfgStatus

public java.lang.String getMfgStatus()

setMfgStatus

public void setMfgStatus(java.lang.String mfgStatus)

getStartDate

public java.util.Date getStartDate()

setStartDate

public void setStartDate(java.util.Date startDate)

getDateRequired

public java.util.Date getDateRequired()

setDateRequired

public void setDateRequired(java.util.Date dateRequired)

getDesired

public java.util.Date getDesired()

setDesired

public void setDesired(java.util.Date desired)

getDelayDays

public int getDelayDays()

setDelayDays

public void setDelayDays(int delayDays)

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getOriginal

public java.util.Date getOriginal()

setOriginal

public void setOriginal(java.util.Date original)

getActual

public java.util.Date getActual()

setActual

public void setActual(java.util.Date actual)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getFreight

public java.math.BigDecimal getFreight()

setFreight

public void setFreight(java.math.BigDecimal freight)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartUnit

public java.lang.String getPartUnit()

setPartUnit

public void setPartUnit(java.lang.String partUnit)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getDwg

public java.lang.String getDwg()

setDwg

public void setDwg(java.lang.String dwg)

getWiFlag

public java.lang.String getWiFlag()

setWiFlag

public void setWiFlag(java.lang.String wiFlag)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getQuantityShip

public java.math.BigDecimal getQuantityShip()

setQuantityShip

public void setQuantityShip(java.math.BigDecimal quantityShip)

getHqa

public java.math.BigDecimal getHqa()

setHqa

public void setHqa(java.math.BigDecimal hqa)

getCostPerUnit

public java.math.BigDecimal getCostPerUnit()

setCostPerUnit

public void setCostPerUnit(java.math.BigDecimal costPerUnit)

getStdCostPerUnit

public java.math.BigDecimal getStdCostPerUnit()

setStdCostPerUnit

public void setStdCostPerUnit(java.math.BigDecimal stdCostPerUnit)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getList

public java.math.BigDecimal getList()

setList

public void setList(java.math.BigDecimal list)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getDisassembleWorkOrderItemComments

public java.lang.String getDisassembleWorkOrderItemComments()

setDisassembleWorkOrderItemComments

public void setDisassembleWorkOrderItemComments(java.lang.String disassembleWorkOrderItemComments)

getDisassembleWorkOrderItemPrivateNotes

public java.lang.String getDisassembleWorkOrderItemPrivateNotes()

setDisassembleWorkOrderItemPrivateNotes

public void setDisassembleWorkOrderItemPrivateNotes(java.lang.String disassembleWorkOrderItemPrivateNotes)

isCostAlarm

public boolean isCostAlarm()

setCostAlarm

public void setCostAlarm(boolean costAlarm)

getReviewedDate

public java.util.Date getReviewedDate()

setReviewedDate

public void setReviewedDate(java.util.Date reviewedDate)

getReviewedBy

public java.lang.String getReviewedBy()

setReviewedBy

public void setReviewedBy(java.lang.String reviewedBy)

getReviewDescription

public java.lang.String getReviewDescription()

setReviewDescription

public void setReviewDescription(java.lang.String reviewDescription)

getOriginalCost

public java.math.BigDecimal getOriginalCost()

setOriginalCost

public void setOriginalCost(java.math.BigDecimal originalCost)

getOverPercent

public java.math.BigDecimal getOverPercent()

setOverPercent

public void setOverPercent(java.math.BigDecimal overPercent)

getRefDocOnes

public java.util.Set getRefDocOnes()

setRefDocOnes

public void setRefDocOnes(java.util.Set refDocOnes)

getRefDocTwoes

public java.util.Set getRefDocTwoes()

setRefDocTwoes

public void setRefDocTwoes(java.util.Set refDocTwoes)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getHold

public java.lang.String getHold()

setHold

public void setHold(java.lang.String hold)

isCreatedGL

public boolean isCreatedGL()

setCreatedGL

public void setCreatedGL(boolean createdGL)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DisassembleWorkOrderListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DisassembleWorkOrderListResult

java.lang.Object
    extended by  bb.common.DisassembleWorkOrderListResult
All Implemented Interfaces:
java.io.Serializable
public class DisassembleWorkOrderListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CHANGEORDER
static java.lang.String | ORDER_BY_DISASSEMBLEWORKORDERCOMMENTS
static java.lang.String | ORDER_BY_DISASSEMBLEWORKORDERPRIVATENOTES
static java.lang.String | ORDER_BY_DWODATE
static java.lang.String | ORDER_BY_DWONUMBER
static java.lang.String | ORDER_BY_PROJECT
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_VENDORNAME
Constructor Summary
DisassembleWorkOrderListResult()
Method Summary
java.lang.String | getChangeOrder()
java.lang.String | getDisassembleWorkOrderComments()
java.lang.String | getDisassembleWorkOrderPrivateNotes()
java.util.Date | getDwoDate()
java.lang.String | getDwoNumber()
java.math.BigDecimal | getGrantTotal()
java.lang.String | getOriginator()
java.lang.String | getPriority()
java.lang.String | getProject()
java.lang.String | getStatus()
java.math.BigDecimal | getSubTotal()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
void | setChangeOrder(java.lang.String changeOrder)
void | setDisassembleWorkOrderComments(java.lang.String disassembleWorkOrderComments)
void | setDisassembleWorkOrderPrivateNotes(java.lang.String disassembleWorkOrderPrivateNotes)
void | setDwoDate(java.util.Date dwoDate)
void | setDwoNumber(java.lang.String dwoNumber)
void | setGrantTotal(java.math.BigDecimal grantTotal)
void | setOriginator(java.lang.String originator)
void | setPriority(java.lang.String priority)
void | setProject(java.lang.String project)
void | setStatus(java.lang.String status)
void | setSubTotal(java.math.BigDecimal subTotal)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_DWONUMBER

public static final java.lang.String ORDER_BY_DWONUMBER
See Also:
Constant Field Values

ORDER_BY_DWODATE

public static final java.lang.String ORDER_BY_DWODATE
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_VENDORNAME

public static final java.lang.String ORDER_BY_VENDORNAME
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_PROJECT

public static final java.lang.String ORDER_BY_PROJECT
See Also:
Constant Field Values

ORDER_BY_CHANGEORDER

public static final java.lang.String ORDER_BY_CHANGEORDER
See Also:
Constant Field Values

ORDER_BY_DISASSEMBLEWORKORDERCOMMENTS

public static final java.lang.String ORDER_BY_DISASSEMBLEWORKORDERCOMMENTS
See Also:
Constant Field Values

ORDER_BY_DISASSEMBLEWORKORDERPRIVATENOTES

public static final java.lang.String ORDER_BY_DISASSEMBLEWORKORDERPRIVATENOTES
See Also:
Constant Field Values
Constructor Detail

DisassembleWorkOrderListResult

public DisassembleWorkOrderListResult()
Method Detail

getDwoNumber

public java.lang.String getDwoNumber()

setDwoNumber

public void setDwoNumber(java.lang.String dwoNumber)

getDwoDate

public java.util.Date getDwoDate()

setDwoDate

public void setDwoDate(java.util.Date dwoDate)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getVendorName

public java.lang.String getVendorName()

setVendorName

public void setVendorName(java.lang.String vendorName)

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

getSubTotal

public java.math.BigDecimal getSubTotal()

setSubTotal

public void setSubTotal(java.math.BigDecimal subTotal)

getGrantTotal

public java.math.BigDecimal getGrantTotal()

setGrantTotal

public void setGrantTotal(java.math.BigDecimal grantTotal)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getOriginator

public java.lang.String getOriginator()

setOriginator

public void setOriginator(java.lang.String originator)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getDisassembleWorkOrderComments

public java.lang.String getDisassembleWorkOrderComments()

setDisassembleWorkOrderComments

public void setDisassembleWorkOrderComments(java.lang.String disassembleWorkOrderComments)

getDisassembleWorkOrderPrivateNotes

public java.lang.String getDisassembleWorkOrderPrivateNotes()

setDisassembleWorkOrderPrivateNotes

public void setDisassembleWorkOrderPrivateNotes(java.lang.String disassembleWorkOrderPrivateNotes)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DisassembleWorkOrderReceivingResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DisassembleWorkOrderReceivingResult

java.lang.Object
    extended by  bb.common.DisassembleWorkOrderReceivingResult
All Implemented Interfaces:
java.io.Serializable
public class DisassembleWorkOrderReceivingResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
DisassembleWorkOrderReceivingResult()
Method Summary
java.lang.String | getApprovedBy()
java.util.Date | getApprovedDate()
java.lang.String | getBillId()
java.lang.String | getChangeOrder()
java.lang.String | getDescription()
java.util.Set | getDisassembleWorkOrderReceivingItems()
java.lang.String | getDrawing()
java.lang.String | getItemNumber()
java.lang.String | getItemStatus()
java.util.Date | getOrderDate()
java.lang.String | getOrderNumber()
java.lang.String | getOrderStatus()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.lang.String | getProject()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getQuantityShipped()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.util.Date | getRequireDate()
java.lang.String | getRevision()
java.lang.String | getShipId()
java.lang.String | getShipvia()
java.lang.String | getUnit()
java.lang.String | getVendorId()
boolean | isHold()
void | setApprovedBy(java.lang.String approvedBy)
void | setApprovedDate(java.util.Date approvedDate)
void | setBillId(java.lang.String billId)
void | setChangeOrder(java.lang.String changeOrder)
void | setDescription(java.lang.String description)
void | setDisassembleWorkOrderReceivingItems(java.util.Set disassembleWorkOrderReceivingItems)
void | setDrawing(java.lang.String drawing)
void | setHold(boolean isHold)
void | setItemNumber(java.lang.String itemNumber)
void | setItemStatus(java.lang.String itemStatus)
void | setOrderDate(java.util.Date orderDate)
void | setOrderNumber(java.lang.String orderNumber)
void | setOrderStatus(java.lang.String orderStatus)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setProject(java.lang.String project)
void | setQuantity(java.math.BigDecimal quantity)
void | setQuantityShipped(java.math.BigDecimal quantityShipped)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setRequireDate(java.util.Date requireDate)
void | setRevision(java.lang.String revision)
void | setShipId(java.lang.String shipId)
void | setShipvia(java.lang.String shipvia)
void | setUnit(java.lang.String unit)
void | setVendorId(java.lang.String vendorId)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DisassembleWorkOrderReceivingResult

public DisassembleWorkOrderReceivingResult()
Method Detail

getOrderNumber

public java.lang.String getOrderNumber()

setOrderNumber

public void setOrderNumber(java.lang.String orderNumber)

getItemNumber

public java.lang.String getItemNumber()

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

getOrderDate

public java.util.Date getOrderDate()

setOrderDate

public void setOrderDate(java.util.Date orderDate)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getBillId

public java.lang.String getBillId()

setBillId

public void setBillId(java.lang.String billId)

getShipId

public java.lang.String getShipId()

setShipId

public void setShipId(java.lang.String shipId)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

getShipvia

public java.lang.String getShipvia()

setShipvia

public void setShipvia(java.lang.String shipvia)

getOrderStatus

public java.lang.String getOrderStatus()

setOrderStatus

public void setOrderStatus(java.lang.String orderStatus)

getApprovedDate

public java.util.Date getApprovedDate()

setApprovedDate

public void setApprovedDate(java.util.Date approvedDate)

getApprovedBy

public java.lang.String getApprovedBy()

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)

getPartPk

public PartPK getPartPk()

setPartPk

public void setPartPk(PartPK partPk)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getDrawing

public java.lang.String getDrawing()

setDrawing

public void setDrawing(java.lang.String drawing)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getQuantityShipped

public java.math.BigDecimal getQuantityShipped()

setQuantityShipped

public void setQuantityShipped(java.math.BigDecimal quantityShipped)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getRequireDate

public java.util.Date getRequireDate()

setRequireDate

public void setRequireDate(java.util.Date requireDate)

getItemStatus

public java.lang.String getItemStatus()

setItemStatus

public void setItemStatus(java.lang.String itemStatus)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getDisassembleWorkOrderReceivingItems

public java.util.Set getDisassembleWorkOrderReceivingItems()

setDisassembleWorkOrderReceivingItems

public void setDisassembleWorkOrderReceivingItems(java.util.Set disassembleWorkOrderReceivingItems)

isHold

public boolean isHold()

setHold

public void setHold(boolean isHold)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DisassembleWorkOrderVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DisassembleWorkOrderVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.DisassembleWorkOrderVO
All Implemented Interfaces:
java.io.Serializable
public class DisassembleWorkOrderVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
DisassembleWorkOrderVO()
DisassembleWorkOrderVO(java.lang.String disassembleWorkOrderNumber, java.lang.String lastChangeUser, java.util.Date lastChangeDate, java.util.Date adate, java.lang.String origin, java.math.BigDecimal dwoSub, java.math.BigDecimal dwoDisc, java.math.BigDecimal subTotal, java.math.BigDecimal dwoMade, java.math.BigDecimal dwoOpen, java.math.BigDecimal totalTax, java.math.BigDecimal totalFreight, java.math.BigDecimal grantTotal, java.lang.String changeOrder, java.lang.String vendorId, java.lang.String billToId, java.lang.String po, java.lang.String contact, java.lang.String status, java.util.Date approved, java.lang.String approvedBy, java.lang.String originator, java.util.Date delivery, java.util.Date desired, int delay, java.lang.String priority, java.util.Date original, java.lang.String actual, java.lang.String shipToId, java.lang.String shipVia, java.lang.String shippingAccount, java.lang.String location, java.lang.String language, java.lang.String currency, java.lang.String terms, java.util.Date entered, java.lang.String salesman, java.lang.String requestor, java.lang.String project, java.lang.String relatedDoc, java.lang.String debitAccount, java.lang.String bp, java.lang.String disassembleWorkOrderComments, java.lang.String disassembleWorkOrderPrivateNotes, java.lang.String companyUnitId, boolean useWip, int lastChangeTimes, CustomerVendorAddressInfoVO vendorAddressInfo, CustomerVendorAddressInfoVO shipToAddressInfo, CustomerVendorAddressInfoVO billToAddressInfo, java.util.Set disassembleWorkOrderItem, java.util.Set boilerplates, java.lang.String coComments, boolean hold)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getActual()
java.util.Date | getAdate()
java.util.Date | getApproved()
java.lang.String | getApprovedBy()
CustomerVendorAddressInfoVO | getBillToAddressInfo()
java.lang.String | getBillToId()
java.util.Set | getBoilerplates()
java.lang.String | getBp()
java.lang.String | getChangeOrder()
java.lang.String | getCoComments()
java.lang.String | getCompanyUnitId()
java.lang.String | getContact()
java.lang.String | getCurrency()
java.lang.String | getDebitAccount()
int | getDelay()
java.util.Date | getDelivery()
java.util.Date | getDesired()
java.lang.String | getDisassembleWorkOrderComments()
java.util.Set | getDisassembleWorkOrderItem()
java.lang.String | getDisassembleWorkOrderNumber()
java.lang.String | getDisassembleWorkOrderPrivateNotes()
java.math.BigDecimal | getDwoDisc()
java.math.BigDecimal | getDwoMade()
java.math.BigDecimal | getDwoOpen()
java.math.BigDecimal | getDwoSub()
java.util.Date | getEntered()
java.math.BigDecimal | getGrantTotal()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
int | getLastChangeTimes()
java.lang.String | getLastChangeUser()
java.lang.String | getLocation()
java.lang.String | getOrigin()
java.util.Date | getOriginal()
java.lang.String | getOriginator()
java.lang.String | getPo()
java.lang.String | getPriority()
java.lang.String | getProject()
java.lang.String | getRelatedDoc()
java.lang.String | getRequestor()
java.lang.String | getSalesman()
java.lang.String | getShippingAccount()
CustomerVendorAddressInfoVO | getShipToAddressInfo()
java.lang.String | getShipToId()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.math.BigDecimal | getSubTotal()
java.lang.String | getTerms()
java.math.BigDecimal | getTotalFreight()
java.math.BigDecimal | getTotalTax()
CustomerVendorAddressInfoVO | getVendorAddressInfo()
java.lang.String | getVendorId()
int | hashCode()
boolean | isHold()
boolean | isUseWip()
void | setActual(java.lang.String actual)
void | setAdate(java.util.Date adate)
void | setApproved(java.util.Date approved)
void | setApprovedBy(java.lang.String approvedBy)
void | setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | setBillToId(java.lang.String billToId)
void | setBoilerplates(java.util.Set boilerplates)
void | setBp(java.lang.String bp)
void | setChangeOrder(java.lang.String changeOrder)
void | setCoComments(java.lang.String coComments)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setContact(java.lang.String contact)
void | setCurrency(java.lang.String currency)
void | setDebitAccount(java.lang.String debitAccount)
void | setDelay(int delay)
void | setDelivery(java.util.Date delivery)
void | setDesired(java.util.Date desired)
void | setDisassembleWorkOrderComments(java.lang.String disassembleWorkOrderComments)
void | setDisassembleWorkOrderItem(java.util.Set disassembleWorkOrderItem)
void | setDisassembleWorkOrderNumber(java.lang.String disassembleWorkOrderNumber)
void | setDisassembleWorkOrderPrivateNotes(java.lang.String disassembleWorkOrderPrivateNotes)
void | setDwoDisc(java.math.BigDecimal dwoDisc)
void | setDwoMade(java.math.BigDecimal dwoMade)
void | setDwoOpen(java.math.BigDecimal dwoOpen)
void | setDwoSub(java.math.BigDecimal dwoSub)
void | setEntered(java.util.Date entered)
void | setGrantTotal(java.math.BigDecimal grantTotal)
void | setHold(boolean hold)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTimes(int lastChangeTimes)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLocation(java.lang.String location)
void | setOrigin(java.lang.String origin)
void | setOriginal(java.util.Date original)
void | setOriginator(java.lang.String originator)
void | setPo(java.lang.String po)
void | setPriority(java.lang.String priority)
void | setProject(java.lang.String project)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setRequestor(java.lang.String requestor)
void | setSalesman(java.lang.String salesman)
void | setShippingAccount(java.lang.String shippingAccount)
void | setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | setShipToId(java.lang.String shipToId)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setSubTotal(java.math.BigDecimal subTotal)
void | setTerms(java.lang.String terms)
void | setTotalFreight(java.math.BigDecimal totalFreight)
void | setTotalTax(java.math.BigDecimal totalTax)
void | setUseWip(boolean useWip)
void | setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)
void | setVendorId(java.lang.String vendorId)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

DisassembleWorkOrderVO

public DisassembleWorkOrderVO(java.lang.String disassembleWorkOrderNumber,
                              java.lang.String lastChangeUser,
                              java.util.Date lastChangeDate,
                              java.util.Date adate,
                              java.lang.String origin,
                              java.math.BigDecimal dwoSub,
                              java.math.BigDecimal dwoDisc,
                              java.math.BigDecimal subTotal,
                              java.math.BigDecimal dwoMade,
                              java.math.BigDecimal dwoOpen,
                              java.math.BigDecimal totalTax,
                              java.math.BigDecimal totalFreight,
                              java.math.BigDecimal grantTotal,
                              java.lang.String changeOrder,
                              java.lang.String vendorId,
                              java.lang.String billToId,
                              java.lang.String po,
                              java.lang.String contact,
                              java.lang.String status,
                              java.util.Date approved,
                              java.lang.String approvedBy,
                              java.lang.String originator,
                              java.util.Date delivery,
                              java.util.Date desired,
                              int delay,
                              java.lang.String priority,
                              java.util.Date original,
                              java.lang.String actual,
                              java.lang.String shipToId,
                              java.lang.String shipVia,
                              java.lang.String shippingAccount,
                              java.lang.String location,
                              java.lang.String language,
                              java.lang.String currency,
                              java.lang.String terms,
                              java.util.Date entered,
                              java.lang.String salesman,
                              java.lang.String requestor,
                              java.lang.String project,
                              java.lang.String relatedDoc,
                              java.lang.String debitAccount,
                              java.lang.String bp,
                              java.lang.String disassembleWorkOrderComments,
                              java.lang.String disassembleWorkOrderPrivateNotes,
                              java.lang.String companyUnitId,
                              boolean useWip,
                              int lastChangeTimes,
                              CustomerVendorAddressInfoVO vendorAddressInfo,
                              CustomerVendorAddressInfoVO shipToAddressInfo,
                              CustomerVendorAddressInfoVO billToAddressInfo,
                              java.util.Set disassembleWorkOrderItem,
                              java.util.Set boilerplates,
                              java.lang.String coComments,
                              boolean hold)

DisassembleWorkOrderVO

public DisassembleWorkOrderVO()
Method Detail

getDisassembleWorkOrderNumber

public java.lang.String getDisassembleWorkOrderNumber()

setDisassembleWorkOrderNumber

public void setDisassembleWorkOrderNumber(java.lang.String disassembleWorkOrderNumber)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getDwoSub

public java.math.BigDecimal getDwoSub()

setDwoSub

public void setDwoSub(java.math.BigDecimal dwoSub)

getDwoDisc

public java.math.BigDecimal getDwoDisc()

setDwoDisc

public void setDwoDisc(java.math.BigDecimal dwoDisc)

getSubTotal

public java.math.BigDecimal getSubTotal()

setSubTotal

public void setSubTotal(java.math.BigDecimal subTotal)

getDwoMade

public java.math.BigDecimal getDwoMade()

setDwoMade

public void setDwoMade(java.math.BigDecimal dwoMade)

getDwoOpen

public java.math.BigDecimal getDwoOpen()

setDwoOpen

public void setDwoOpen(java.math.BigDecimal dwoOpen)

getTotalTax

public java.math.BigDecimal getTotalTax()

setTotalTax

public void setTotalTax(java.math.BigDecimal totalTax)

getTotalFreight

public java.math.BigDecimal getTotalFreight()

setTotalFreight

public void setTotalFreight(java.math.BigDecimal totalFreight)

getGrantTotal

public java.math.BigDecimal getGrantTotal()

setGrantTotal

public void setGrantTotal(java.math.BigDecimal grantTotal)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getBillToId

public java.lang.String getBillToId()

setBillToId

public void setBillToId(java.lang.String billToId)

getPo

public java.lang.String getPo()

setPo

public void setPo(java.lang.String po)

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getApproved

public java.util.Date getApproved()

setApproved

public void setApproved(java.util.Date approved)

getApprovedBy

public java.lang.String getApprovedBy()

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)

getOriginator

public java.lang.String getOriginator()

setOriginator

public void setOriginator(java.lang.String originator)

getDelivery

public java.util.Date getDelivery()

setDelivery

public void setDelivery(java.util.Date delivery)

getDesired

public java.util.Date getDesired()

setDesired

public void setDesired(java.util.Date desired)

getDelay

public int getDelay()

setDelay

public void setDelay(int delay)

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getOriginal

public java.util.Date getOriginal()

setOriginal

public void setOriginal(java.util.Date original)

getActual

public java.lang.String getActual()

setActual

public void setActual(java.lang.String actual)

getShipToId

public java.lang.String getShipToId()

setShipToId

public void setShipToId(java.lang.String shipToId)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getShippingAccount

public java.lang.String getShippingAccount()

setShippingAccount

public void setShippingAccount(java.lang.String shippingAccount)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getEntered

public java.util.Date getEntered()

setEntered

public void setEntered(java.util.Date entered)

getSalesman

public java.lang.String getSalesman()

setSalesman

public void setSalesman(java.lang.String salesman)

getRequestor

public java.lang.String getRequestor()

setRequestor

public void setRequestor(java.lang.String requestor)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getDebitAccount

public java.lang.String getDebitAccount()

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

getBp

public java.lang.String getBp()

setBp

public void setBp(java.lang.String bp)

getDisassembleWorkOrderComments

public java.lang.String getDisassembleWorkOrderComments()

setDisassembleWorkOrderComments

public void setDisassembleWorkOrderComments(java.lang.String disassembleWorkOrderComments)

getDisassembleWorkOrderPrivateNotes

public java.lang.String getDisassembleWorkOrderPrivateNotes()

setDisassembleWorkOrderPrivateNotes

public void setDisassembleWorkOrderPrivateNotes(java.lang.String disassembleWorkOrderPrivateNotes)

getDisassembleWorkOrderItem

public java.util.Set getDisassembleWorkOrderItem()

setDisassembleWorkOrderItem

public void setDisassembleWorkOrderItem(java.util.Set disassembleWorkOrderItem)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

isUseWip

public boolean isUseWip()

setUseWip

public void setUseWip(boolean useWip)

getLastChangeTimes

public int getLastChangeTimes()

setLastChangeTimes

public void setLastChangeTimes(int lastChangeTimes)

getVendorAddressInfo

public CustomerVendorAddressInfoVO getVendorAddressInfo()

setVendorAddressInfo

public void setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)

getShipToAddressInfo

public CustomerVendorAddressInfoVO getShipToAddressInfo()

setShipToAddressInfo

public void setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)

getBillToAddressInfo

public CustomerVendorAddressInfoVO getBillToAddressInfo()

setBillToAddressInfo

public void setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)

getBoilerplates

public java.util.Set getBoilerplates()

setBoilerplates

public void setBoilerplates(java.util.Set boilerplates)

getCoComments

public java.lang.String getCoComments()

setCoComments

public void setCoComments(java.lang.String coComments)

isHold

public boolean isHold()

setHold

public void setHold(boolean hold)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DocumentAction

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DocumentAction

java.lang.Object
    extended by  bb.common.DocumentAction

public class DocumentAction
extends java.lang.Object

Nested Class Summary
static class | DocumentAction.DwfAndDwgDocAction
static class | DocumentAction.MiscDocAction
static class | DocumentAction.PartDocAction
Field Summary
static java.lang.String | DOWNLOAD_PDF
static java.lang.String | DOWNLOAD_ZIP
Constructor Summary
DocumentAction()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DOWNLOAD_ZIP

public static final java.lang.String DOWNLOAD_ZIP
See Also:
Constant Field Values

DOWNLOAD_PDF

public static final java.lang.String DOWNLOAD_PDF
See Also:
Constant Field Values
Constructor Detail

DocumentAction

public DocumentAction()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DocumentAction.DwfAndDwgDocAction

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DocumentAction.DwfAndDwgDocAction

java.lang.Object
    extended by  bb.common.DocumentAction.DwfAndDwgDocAction
Enclosing class:
DocumentAction
public static final class DocumentAction.DwfAndDwgDocAction
extends java.lang.Object

Field Summary
static java.lang.String | DELETE
static java.lang.String | DOWNLOAD
static java.lang.String | DOWNLOAD_DWG
static java.lang.String[] | DWF_ACTION
static java.lang.String[] | DWG_ACTION
static java.lang.String | UPDATE
static java.lang.String | UPLOAD
Constructor Summary
DocumentAction.DwfAndDwgDocAction()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

UPLOAD

public static final java.lang.String UPLOAD
See Also:
Constant Field Values

DOWNLOAD

public static final java.lang.String DOWNLOAD
See Also:
Constant Field Values

DOWNLOAD_DWG

public static final java.lang.String DOWNLOAD_DWG
See Also:
Constant Field Values

DELETE

public static final java.lang.String DELETE
See Also:
Constant Field Values

UPDATE

public static final java.lang.String UPDATE
See Also:
Constant Field Values

DWF_ACTION

public static final java.lang.String[] DWF_ACTION

DWG_ACTION

public static final java.lang.String[] DWG_ACTION
Constructor Detail

DocumentAction.DwfAndDwgDocAction

public DocumentAction.DwfAndDwgDocAction()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DocumentAction.MiscDocAction

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DocumentAction.MiscDocAction

java.lang.Object
    extended by  bb.common.DocumentAction.MiscDocAction
Enclosing class:
DocumentAction
public static class DocumentAction.MiscDocAction
extends java.lang.Object

Field Summary
static java.lang.String | DELETE
static java.lang.String | DOWNLOAD_ADDRESS_QA_DOC
static java.lang.String | DOWNLOAD_BALANCE_SHEET_DOC
static java.lang.String | DOWNLOAD_BALANCE_SHEET_SIDE_BY_SIDE_DOC
static java.lang.String | DOWNLOAD_CERTIFICATE_DOC
static java.lang.String | DOWNLOAD_CLOSING_STATEMENT_DOC
static java.lang.String | DOWNLOAD_CS_ITEM_DOC
static java.lang.String | DOWNLOAD_DWO_DOC
static java.lang.String | DOWNLOAD_ECN_DOC
static java.lang.String | DOWNLOAD_ECR_DOC
static java.lang.String | DOWNLOAD_EDC_DOC
static java.lang.String | DOWNLOAD_EMPLOYEE_RECORDS
static java.lang.String | DOWNLOAD_NCR_FILE
static java.lang.String | DOWNLOAD_ONLOAN_DOC
static java.lang.String | DOWNLOAD_PAR_ITEM_DOC
static java.lang.String | DOWNLOAD_PART_PICTURE
static java.lang.String | DOWNLOAD_PO_DOC
static java.lang.String | DOWNLOAD_PROFIT_LOSS_DOC
static java.lang.String | DOWNLOAD_QT_DOC
static java.lang.String | DOWNLOAD_RMA_DOC
static java.lang.String | DOWNLOAD_SO_DOC
static java.lang.String | DOWNLOAD_WI_DOC
static java.lang.String | DOWNLOAD_WI_PICTURE
static java.lang.String | DOWNLOAD_WO_DOC
static java.lang.String[] | MISC_DOC_ACTION
static java.lang.String | UPDATE
static java.lang.String | UPLOAD
Constructor Summary
DocumentAction.MiscDocAction()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

UPLOAD

public static final java.lang.String UPLOAD
See Also:
Constant Field Values

DELETE

public static final java.lang.String DELETE
See Also:
Constant Field Values

UPDATE

public static final java.lang.String UPDATE
See Also:
Constant Field Values

DOWNLOAD_SO_DOC

public static final java.lang.String DOWNLOAD_SO_DOC
See Also:
Constant Field Values

DOWNLOAD_PO_DOC

public static final java.lang.String DOWNLOAD_PO_DOC
See Also:
Constant Field Values

DOWNLOAD_QT_DOC

public static final java.lang.String DOWNLOAD_QT_DOC
See Also:
Constant Field Values

DOWNLOAD_EDC_DOC

public static final java.lang.String DOWNLOAD_EDC_DOC
See Also:
Constant Field Values

DOWNLOAD_WO_DOC

public static final java.lang.String DOWNLOAD_WO_DOC
See Also:
Constant Field Values

DOWNLOAD_WI_DOC

public static final java.lang.String DOWNLOAD_WI_DOC
See Also:
Constant Field Values

DOWNLOAD_PAR_ITEM_DOC

public static final java.lang.String DOWNLOAD_PAR_ITEM_DOC
See Also:
Constant Field Values

DOWNLOAD_CERTIFICATE_DOC

public static final java.lang.String DOWNLOAD_CERTIFICATE_DOC
See Also:
Constant Field Values

DOWNLOAD_CS_ITEM_DOC

public static final java.lang.String DOWNLOAD_CS_ITEM_DOC
See Also:
Constant Field Values

DOWNLOAD_ADDRESS_QA_DOC

public static final java.lang.String DOWNLOAD_ADDRESS_QA_DOC
See Also:
Constant Field Values

DOWNLOAD_EMPLOYEE_RECORDS

public static final java.lang.String DOWNLOAD_EMPLOYEE_RECORDS
See Also:
Constant Field Values

DOWNLOAD_WI_PICTURE

public static final java.lang.String DOWNLOAD_WI_PICTURE
See Also:
Constant Field Values

DOWNLOAD_PART_PICTURE

public static final java.lang.String DOWNLOAD_PART_PICTURE
See Also:
Constant Field Values

DOWNLOAD_NCR_FILE

public static final java.lang.String DOWNLOAD_NCR_FILE
See Also:
Constant Field Values

DOWNLOAD_BALANCE_SHEET_DOC

public static final java.lang.String DOWNLOAD_BALANCE_SHEET_DOC
See Also:
Constant Field Values

DOWNLOAD_BALANCE_SHEET_SIDE_BY_SIDE_DOC

public static final java.lang.String DOWNLOAD_BALANCE_SHEET_SIDE_BY_SIDE_DOC
See Also:
Constant Field Values

DOWNLOAD_PROFIT_LOSS_DOC

public static final java.lang.String DOWNLOAD_PROFIT_LOSS_DOC
See Also:
Constant Field Values

DOWNLOAD_CLOSING_STATEMENT_DOC

public static final java.lang.String DOWNLOAD_CLOSING_STATEMENT_DOC
See Also:
Constant Field Values

DOWNLOAD_ECN_DOC

public static final java.lang.String DOWNLOAD_ECN_DOC
See Also:
Constant Field Values

DOWNLOAD_ECR_DOC

public static final java.lang.String DOWNLOAD_ECR_DOC
See Also:
Constant Field Values

DOWNLOAD_ONLOAN_DOC

public static final java.lang.String DOWNLOAD_ONLOAN_DOC
See Also:
Constant Field Values

DOWNLOAD_RMA_DOC

public static final java.lang.String DOWNLOAD_RMA_DOC
See Also:
Constant Field Values

DOWNLOAD_DWO_DOC

public static final java.lang.String DOWNLOAD_DWO_DOC
See Also:
Constant Field Values

MISC_DOC_ACTION

public static final java.lang.String[] MISC_DOC_ACTION
Constructor Detail

DocumentAction.MiscDocAction

public DocumentAction.MiscDocAction()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DocumentAction.PartDocAction

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DocumentAction.PartDocAction

java.lang.Object
    extended by  bb.common.DocumentAction.PartDocAction
Enclosing class:
DocumentAction
public static class DocumentAction.PartDocAction
extends java.lang.Object

Field Summary
static java.lang.String | DELETE
static java.lang.String | DOWNLOAD
static java.lang.String | DOWNLOAD_FILE
static java.lang.String[] | PART_DOC_ACTION
static java.lang.String | UPLOAD
Constructor Summary
DocumentAction.PartDocAction()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

UPLOAD

public static final java.lang.String UPLOAD
See Also:
Constant Field Values

DOWNLOAD

public static final java.lang.String DOWNLOAD
See Also:
Constant Field Values

DELETE

public static final java.lang.String DELETE
See Also:
Constant Field Values

DOWNLOAD_FILE

public static final java.lang.String DOWNLOAD_FILE
See Also:
Constant Field Values

PART_DOC_ACTION

public static final java.lang.String[] PART_DOC_ACTION
Constructor Detail

DocumentAction.PartDocAction

public DocumentAction.PartDocAction()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DocumentBox

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common.box
Interface DocumentBox

public interface DocumentBox

Method Summary
void | deleteFtpDocument(DocumentInfoAgent agent)
void | downLoad()
java.util.Collection<PartDocumentVO> | findAllDocument(int firstIndex, int maxLength)
java.util.Collection<PartDocumentVO> | findAllDocumentByDocumentType(java.lang.String documentType, int firstIndex, int maxLength)
java.util.Collection<AllPartDocumentsVO> | findAllDocuments(java.lang.String pnLike, java.lang.String documentType, java.lang.String language, java.lang.String isPublic, java.lang.String description, java.lang.String comments, boolean isCurrentVersion, int firstIndex, int maxLength)
java.util.Collection<PartDocumentVO> | findPartDocumentByPartNumber(java.lang.String partNumber, int firstIndex, int maxLength)
java.util.Collection<PartDocumentVO> | findPartDocumentByPartNumber(java.lang.String partNumber, java.lang.String documentType, int firstIndex, int maxLength)
java.util.Collection<LogPartDocumentVO> | findPartDocumentLog(java.lang.String partNumber, java.lang.String docType, java.lang.String language, java.lang.String action, java.lang.String operator, java.lang.String wanIp, java.lang.String lanIp, java.lang.String macAddress, java.lang.String isPublicDoc, java.lang.String description, java.util.Date dateFrom, java.util.Date dateTo, int firstIndex, int maxLength)
int | getAllDocumentsCount(java.lang.String pnLike, java.lang.String documentType, java.lang.String language, java.lang.String isPublic, java.lang.String description, java.lang.String comments, boolean isCurrentVersion)
int | getAllPartDocumentsCount()
int | getAllPartDocumentsCountByDocumentType(java.lang.String documentType)
int | getfindPartDocumentLogCount(java.lang.String partNumber, java.lang.String docType, java.lang.String language, java.lang.String action, java.lang.String operator, java.lang.String wanIp, java.lang.String lanIp, java.lang.String macAddress, java.lang.String isPublicDoc, java.lang.String description, java.util.Date dateFrom, java.util.Date dateTo)
PartDocumentVO | getPartDocumentByPk(PartDocumentPK pk)
int | getPartDocumentCountByPartNumber(java.lang.String partNumber)
int | getPartDocumentCountByPartNumber(java.lang.String partNumber, java.lang.String documentType)
AllPartDocumentsVO | getPartDocumentInfo(AllPartDocumentsPK pk)
boolean | isPartDocumentExist(AllPartDocumentsPK pk)
void | upLoad()

Method Detail

deleteFtpDocument

void deleteFtpDocument(DocumentInfoAgent agent)
                       throws java.lang.Exception
Throws:
java.lang.Exception

getAllPartDocumentsCount

int getAllPartDocumentsCount()
                             throws java.lang.Exception
Throws:
java.lang.Exception

findAllDocument

java.util.Collection<PartDocumentVO> findAllDocument(int firstIndex,
                                                     int maxLength)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getAllPartDocumentsCountByDocumentType

int getAllPartDocumentsCountByDocumentType(java.lang.String documentType)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

findAllDocumentByDocumentType

java.util.Collection<PartDocumentVO> findAllDocumentByDocumentType(java.lang.String documentType,
                                                                   int firstIndex,
                                                                   int maxLength)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

isPartDocumentExist

boolean isPartDocumentExist(AllPartDocumentsPK pk)
                            throws java.lang.Exception
Throws:
java.lang.Exception

getPartDocumentByPk

PartDocumentVO getPartDocumentByPk(PartDocumentPK pk)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

getPartDocumentCountByPartNumber

int getPartDocumentCountByPartNumber(java.lang.String partNumber)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findPartDocumentByPartNumber

java.util.Collection<PartDocumentVO> findPartDocumentByPartNumber(java.lang.String partNumber,
                                                                  int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getPartDocumentCountByPartNumber

int getPartDocumentCountByPartNumber(java.lang.String partNumber,
                                     java.lang.String documentType)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findPartDocumentByPartNumber

java.util.Collection<PartDocumentVO> findPartDocumentByPartNumber(java.lang.String partNumber,
                                                                  java.lang.String documentType,
                                                                  int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

upLoad

void upLoad()
            throws java.lang.Exception
Throws:
java.lang.Exception

downLoad

void downLoad()
              throws java.lang.Exception
Throws:
java.lang.Exception

getPartDocumentInfo

AllPartDocumentsVO getPartDocumentInfo(AllPartDocumentsPK pk)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

getAllDocumentsCount

int getAllDocumentsCount(java.lang.String pnLike,
                         java.lang.String documentType,
                         java.lang.String language,
                         java.lang.String isPublic,
                         java.lang.String description,
                         java.lang.String comments,
                         boolean isCurrentVersion)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findAllDocuments

java.util.Collection<AllPartDocumentsVO> findAllDocuments(java.lang.String pnLike,
                                                          java.lang.String documentType,
                                                          java.lang.String language,
                                                          java.lang.String isPublic,
                                                          java.lang.String description,
                                                          java.lang.String comments,
                                                          boolean isCurrentVersion,
                                                          int firstIndex,
                                                          int maxLength)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

findPartDocumentLog

java.util.Collection<LogPartDocumentVO> findPartDocumentLog(java.lang.String partNumber,
                                                            java.lang.String docType,
                                                            java.lang.String language,
                                                            java.lang.String action,
                                                            java.lang.String operator,
                                                            java.lang.String wanIp,
                                                            java.lang.String lanIp,
                                                            java.lang.String macAddress,
                                                            java.lang.String isPublicDoc,
                                                            java.lang.String description,
                                                            java.util.Date dateFrom,
                                                            java.util.Date dateTo,
                                                            int firstIndex,
                                                            int maxLength)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getfindPartDocumentLogCount

int getfindPartDocumentLogCount(java.lang.String partNumber,
                                java.lang.String docType,
                                java.lang.String language,
                                java.lang.String action,
                                java.lang.String operator,
                                java.lang.String wanIp,
                                java.lang.String lanIp,
                                java.lang.String macAddress,
                                java.lang.String isPublicDoc,
                                java.lang.String description,
                                java.util.Date dateFrom,
                                java.util.Date dateTo)
                                throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DocumentInfoAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DocumentInfoAgent

java.lang.Object
    extended by  bb.common.DocumentInfoAgent
All Implemented Interfaces:
java.io.Serializable
public class DocumentInfoAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
DocumentInfoAgent()
Method Summary
java.lang.String | getComments()
AllPartDocumentsPK | getDocumentPk()
java.lang.String | getDocumentType()
java.lang.String | getExtention()
java.lang.String | getFileName()
java.lang.String | getLanguage()
java.lang.String | getLanIp()
java.lang.String | getMacAdd()
java.lang.String | getPartNumber()
java.lang.String | getPartRevision()
java.lang.String | getWanIp()
boolean | isPublic()
void | setComments(java.lang.String comments)
void | setDocumentType(java.lang.String documentType)
void | setExtention(java.lang.String extention)
void | setLanguage(java.lang.String language)
void | setLanIp(java.lang.String lanIp)
void | setMacAdd(java.lang.String macAdd)
void | setPartNumber(java.lang.String partNumber)
void | setPartRevision(java.lang.String partRevision)
void | setPublic(boolean isPublic)
void | setWanIp(java.lang.String wanIp)
java.lang.String | toString()
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DocumentInfoAgent

public DocumentInfoAgent()
Method Detail

getDocumentType

public java.lang.String getDocumentType()

setDocumentType

public void setDocumentType(java.lang.String documentType)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartRevision

public java.lang.String getPartRevision()

setPartRevision

public void setPartRevision(java.lang.String partRevision)

getLanIp

public java.lang.String getLanIp()

setLanIp

public void setLanIp(java.lang.String lanIp)

getMacAdd

public java.lang.String getMacAdd()

setMacAdd

public void setMacAdd(java.lang.String macAdd)

getWanIp

public java.lang.String getWanIp()

setWanIp

public void setWanIp(java.lang.String wanIp)

isPublic

public boolean isPublic()

setPublic

public void setPublic(boolean isPublic)

getFileName

public java.lang.String getFileName()

getDocumentPk

public AllPartDocumentsPK getDocumentPk()

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getExtention

public java.lang.String getExtention()

setExtention

public void setExtention(java.lang.String extention)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DocumentLogVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DocumentLogVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.DocumentLogVO
All Implemented Interfaces:
java.io.Serializable
public class DocumentLogVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
DocumentLogVO()
default constructor
DocumentLogVO(java.lang.Long id, java.lang.String userName, java.lang.Integer action, java.lang.String dir, java.lang.String fileName, java.sql.Timestamp timestamp)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Integer | getAction()
java.lang.String | getDir()
java.lang.String | getFileName()
java.lang.Long | getId()
java.sql.Timestamp | getTimestamp()
java.lang.String | getUserName()
int | hashCode()
void | setAction(java.lang.Integer action)
void | setDir(java.lang.String dir)
void | setFileName(java.lang.String fileName)
void | setId(java.lang.Long id)
void | setTimestamp(java.sql.Timestamp timestamp)
void | setUserName(java.lang.String userName)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

DocumentLogVO

public DocumentLogVO(java.lang.Long id,
                     java.lang.String userName,
                     java.lang.Integer action,
                     java.lang.String dir,
                     java.lang.String fileName,
                     java.sql.Timestamp timestamp)
full constructor

DocumentLogVO

public DocumentLogVO()
default constructor

Method Detail

getId

public java.lang.Long getId()

setId

public void setId(java.lang.Long id)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getAction

public java.lang.Integer getAction()

setAction

public void setAction(java.lang.Integer action)

getDir

public java.lang.String getDir()

setDir

public void setDir(java.lang.String dir)

getFileName

public java.lang.String getFileName()

setFileName

public void setFileName(java.lang.String fileName)

getTimestamp

public java.sql.Timestamp getTimestamp()

setTimestamp

public void setTimestamp(java.sql.Timestamp timestamp)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DocumentServerVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DocumentServerVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.DocumentServerVO
All Implemented Interfaces:
java.io.Serializable
public class DocumentServerVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DOCUMENTTYPE
static java.lang.String | ORDER_BY_FTPPATH
static java.lang.String | ORDER_BY_LOCALPATH
static java.lang.String | ORDER_BY_LOCK
static java.lang.String | ORDER_BY_REMARKS
static java.lang.String | ORDER_BY_SERVERIP
static java.lang.String | ORDER_BY_SERVERPORT
static java.lang.String | ORDER_BY_USERNAME
Constructor Summary
DocumentServerVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDocumentType()
java.lang.String | getFtpPath()
java.lang.String | getLocalPath()
java.lang.String | getLock()
java.lang.String | getRemarks()
java.lang.String | getServerIp()
java.lang.String | getServerPort()
java.lang.String | getUserName()
java.lang.String | getUserPassword()
int | hashCode()
boolean | isSaveToFtp()
void | setDocumentType(java.lang.String documentType)
void | setFtpPath(java.lang.String ftpPath)
void | setLocalPath(java.lang.String localPath)
void | setLock(java.lang.String lock)
void | setRemarks(java.lang.String remarks)
void | setSaveToFtp(boolean saveToFtp)
void | setServerIp(java.lang.String serverIp)
void | setServerPort(java.lang.String serverPort)
void | setUserName(java.lang.String userName)
void | setUserPassword(java.lang.String userPassword)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_DOCUMENTTYPE

public static final java.lang.String ORDER_BY_DOCUMENTTYPE
See Also:
Constant Field Values

ORDER_BY_SERVERIP

public static final java.lang.String ORDER_BY_SERVERIP
See Also:
Constant Field Values

ORDER_BY_SERVERPORT

public static final java.lang.String ORDER_BY_SERVERPORT
See Also:
Constant Field Values

ORDER_BY_USERNAME

public static final java.lang.String ORDER_BY_USERNAME
See Also:
Constant Field Values

ORDER_BY_FTPPATH

public static final java.lang.String ORDER_BY_FTPPATH
See Also:
Constant Field Values

ORDER_BY_LOCALPATH

public static final java.lang.String ORDER_BY_LOCALPATH
See Also:
Constant Field Values

ORDER_BY_LOCK

public static final java.lang.String ORDER_BY_LOCK
See Also:
Constant Field Values

ORDER_BY_REMARKS

public static final java.lang.String ORDER_BY_REMARKS
See Also:
Constant Field Values
Constructor Detail

DocumentServerVO

public DocumentServerVO()
Method Detail

getDocumentType

public java.lang.String getDocumentType()

setDocumentType

public void setDocumentType(java.lang.String documentType)

getServerIp

public java.lang.String getServerIp()

setServerIp

public void setServerIp(java.lang.String serverIp)

getServerPort

public java.lang.String getServerPort()

setServerPort

public void setServerPort(java.lang.String serverPort)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getUserPassword

public java.lang.String getUserPassword()

setUserPassword

public void setUserPassword(java.lang.String userPassword)

getLock

public java.lang.String getLock()

setLock

public void setLock(java.lang.String lock)

getRemarks

public java.lang.String getRemarks()

setRemarks

public void setRemarks(java.lang.String remarks)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getFtpPath

public java.lang.String getFtpPath()

setFtpPath

public void setFtpPath(java.lang.String ftpPath)

getLocalPath

public java.lang.String getLocalPath()

setLocalPath

public void setLocalPath(java.lang.String localPath)

isSaveToFtp

public boolean isSaveToFtp()

setSaveToFtp

public void setSaveToFtp(boolean saveToFtp)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DuePATotalByVendorResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DuePATotalByVendorResult

java.lang.Object
    extended by  bb.common.DuePATotalByVendorResult
All Implemented Interfaces:
java.io.Serializable
public class DuePATotalByVendorResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
DuePATotalByVendorResult()
Method Summary
java.math.BigDecimal | getAmountDue()
java.math.BigDecimal | getAvgMargin()
java.math.BigDecimal | getAvgMarginPercent()
java.lang.String | getCurrency()
java.math.BigDecimal | getDiscountTotal()
java.math.BigDecimal | getFreightTotal()
java.math.BigDecimal | getGrandTotal()
java.math.BigDecimal | getOpenTotal()
java.math.BigDecimal | getShipTotal()
java.math.BigDecimal | getStdMargin()
java.math.BigDecimal | getStdMarginPercent()
java.math.BigDecimal | getSubNetTotal()
java.math.BigDecimal | getTotalNet()
java.math.BigDecimal | getTotalPaid()
java.math.BigDecimal | getTotalTax()
java.math.BigDecimal | getUnitTotal()
void | setAmountDue(java.math.BigDecimal amountDue)
void | setAvgMargin(java.math.BigDecimal avgMargin)
void | setAvgMarginPercent(java.math.BigDecimal avgMarginPercent)
void | setCurrency(java.lang.String currency)
void | setDiscountTotal(java.math.BigDecimal discountTotal)
void | setFreightTotal(java.math.BigDecimal freightTotal)
void | setGrandTotal(java.math.BigDecimal grandTotal)
void | setOpenTotal(java.math.BigDecimal openTotal)
void | setShipTotal(java.math.BigDecimal shipTotal)
void | setStdMargin(java.math.BigDecimal stdMargin)
void | setStdMarginPercent(java.math.BigDecimal stdMarginPercent)
void | setSubNetTotal(java.math.BigDecimal subNetTotal)
void | setTotalNet(java.math.BigDecimal totalNet)
void | setTotalPaid(java.math.BigDecimal totalPaid)
void | setTotalTax(java.math.BigDecimal totalTax)
void | setUnitTotal(java.math.BigDecimal unitTotal)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DuePATotalByVendorResult

public DuePATotalByVendorResult()
Method Detail

getTotalNet

public java.math.BigDecimal getTotalNet()

getFreightTotal

public java.math.BigDecimal getFreightTotal()

getUnitTotal

public java.math.BigDecimal getUnitTotal()

getShipTotal

public java.math.BigDecimal getShipTotal()

getCurrency

public java.lang.String getCurrency()

getTotalTax

public java.math.BigDecimal getTotalTax()

getTotalPaid

public java.math.BigDecimal getTotalPaid()

getOpenTotal

public java.math.BigDecimal getOpenTotal()

getGrandTotal

public java.math.BigDecimal getGrandTotal()

setDiscountTotal

public void setDiscountTotal(java.math.BigDecimal discountTotal)

setTotalNet

public void setTotalNet(java.math.BigDecimal totalNet)

setFreightTotal

public void setFreightTotal(java.math.BigDecimal freightTotal)

setUnitTotal

public void setUnitTotal(java.math.BigDecimal unitTotal)

setShipTotal

public void setShipTotal(java.math.BigDecimal shipTotal)

setCurrency

public void setCurrency(java.lang.String currency)

setTotalTax

public void setTotalTax(java.math.BigDecimal totalTax)

setTotalPaid

public void setTotalPaid(java.math.BigDecimal totalPaid)

setOpenTotal

public void setOpenTotal(java.math.BigDecimal openTotal)

setGrandTotal

public void setGrandTotal(java.math.BigDecimal grandTotal)

setAmountDue

public void setAmountDue(java.math.BigDecimal amountDue)

getDiscountTotal

public java.math.BigDecimal getDiscountTotal()

getAmountDue

public java.math.BigDecimal getAmountDue()

getSubNetTotal

public java.math.BigDecimal getSubNetTotal()

setSubNetTotal

public void setSubNetTotal(java.math.BigDecimal subNetTotal)

getAvgMargin

public java.math.BigDecimal getAvgMargin()

setAvgMargin

public void setAvgMargin(java.math.BigDecimal avgMargin)

getStdMargin

public java.math.BigDecimal getStdMargin()

setStdMargin

public void setStdMargin(java.math.BigDecimal stdMargin)

getAvgMarginPercent

public java.math.BigDecimal getAvgMarginPercent()

setAvgMarginPercent

public void setAvgMarginPercent(java.math.BigDecimal avgMarginPercent)

getStdMarginPercent

public java.math.BigDecimal getStdMarginPercent()

setStdMarginPercent

public void setStdMarginPercent(java.math.BigDecimal stdMarginPercent)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DwfUploadSettingsVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DwfUploadSettingsVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.DwfUploadSettingsVO
All Implemented Interfaces:
java.io.Serializable
public class DwfUploadSettingsVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
DwfUploadSettingsVO()
default constructor
DwfUploadSettingsVO(java.lang.String drawingType, boolean saveToFtp, java.lang.String serverIp, java.lang.String serverPort, java.lang.String userName, java.lang.String userPassword, java.lang.String ftpPath, java.lang.String localPath, java.lang.String remarks)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDrawingType()
java.lang.String | getFtpPath()
java.lang.Integer | getIi()
java.lang.String | getLocalPath()
java.lang.String | getRemarks()
java.lang.String | getServerIp()
java.lang.String | getServerPort()
java.lang.String | getUserName()
java.lang.String | getUserPassword()
int | hashCode()
boolean | isSaveToFtp()
void | setDrawingType(java.lang.String drawingType)
void | setFtpPath(java.lang.String ftpPath)
void | setIi(java.lang.Integer ii)
void | setLocalPath(java.lang.String localPath)
void | setRemarks(java.lang.String remarks)
void | setSaveToFtp(boolean saveToFtp)
void | setServerIp(java.lang.String serverIp)
void | setServerPort(java.lang.String serverPort)
void | setUserName(java.lang.String userName)
void | setUserPassword(java.lang.String userPassword)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

DwfUploadSettingsVO

public DwfUploadSettingsVO(java.lang.String drawingType,
                           boolean saveToFtp,
                           java.lang.String serverIp,
                           java.lang.String serverPort,
                           java.lang.String userName,
                           java.lang.String userPassword,
                           java.lang.String ftpPath,
                           java.lang.String localPath,
                           java.lang.String remarks)
full constructor

DwfUploadSettingsVO

public DwfUploadSettingsVO()
default constructor

Method Detail

getIi

public java.lang.Integer getIi()

setIi

public void setIi(java.lang.Integer ii)

getDrawingType

public java.lang.String getDrawingType()

setDrawingType

public void setDrawingType(java.lang.String drawingType)

isSaveToFtp

public boolean isSaveToFtp()

setSaveToFtp

public void setSaveToFtp(boolean saveToFtp)

getServerIp

public java.lang.String getServerIp()

setServerIp

public void setServerIp(java.lang.String serverIp)

getServerPort

public java.lang.String getServerPort()

setServerPort

public void setServerPort(java.lang.String serverPort)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getUserPassword

public java.lang.String getUserPassword()

setUserPassword

public void setUserPassword(java.lang.String userPassword)

getFtpPath

public java.lang.String getFtpPath()

setFtpPath

public void setFtpPath(java.lang.String ftpPath)

getLocalPath

public java.lang.String getLocalPath()

setLocalPath

public void setLocalPath(java.lang.String localPath)

getRemarks

public java.lang.String getRemarks()

setRemarks

public void setRemarks(java.lang.String remarks)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DwgUploadSettingsVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DwgUploadSettingsVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.DwgUploadSettingsVO
All Implemented Interfaces:
java.io.Serializable
public class DwgUploadSettingsVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
DwgUploadSettingsVO()
default constructor
DwgUploadSettingsVO(java.lang.String drawingType, boolean saveToFtp, java.lang.String serverIp, java.lang.String serverPort, java.lang.String userName, java.lang.String userPassword, java.lang.String ftpPath, java.lang.String localPath, java.lang.String remarks)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDrawingType()
java.lang.String | getFtpPath()
java.lang.Integer | getIi()
java.lang.String | getLocalPath()
java.lang.String | getRemarks()
java.lang.String | getServerIp()
java.lang.String | getServerPort()
java.lang.String | getUserName()
java.lang.String | getUserPassword()
int | hashCode()
boolean | isSaveToFtp()
void | setDrawingType(java.lang.String drawingType)
void | setFtpPath(java.lang.String ftpPath)
void | setIi(java.lang.Integer ii)
void | setLocalPath(java.lang.String localPath)
void | setRemarks(java.lang.String remarks)
void | setSaveToFtp(boolean saveToFtp)
void | setServerIp(java.lang.String serverIp)
void | setServerPort(java.lang.String serverPort)
void | setUserName(java.lang.String userName)
void | setUserPassword(java.lang.String userPassword)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

DwgUploadSettingsVO

public DwgUploadSettingsVO(java.lang.String drawingType,
                           boolean saveToFtp,
                           java.lang.String serverIp,
                           java.lang.String serverPort,
                           java.lang.String userName,
                           java.lang.String userPassword,
                           java.lang.String ftpPath,
                           java.lang.String localPath,
                           java.lang.String remarks)
full constructor

DwgUploadSettingsVO

public DwgUploadSettingsVO()
default constructor

Method Detail

getIi

public java.lang.Integer getIi()

setIi

public void setIi(java.lang.Integer ii)

getDrawingType

public java.lang.String getDrawingType()

setDrawingType

public void setDrawingType(java.lang.String drawingType)

isSaveToFtp

public boolean isSaveToFtp()

setSaveToFtp

public void setSaveToFtp(boolean saveToFtp)

getServerIp

public java.lang.String getServerIp()

setServerIp

public void setServerIp(java.lang.String serverIp)

getServerPort

public java.lang.String getServerPort()

setServerPort

public void setServerPort(java.lang.String serverPort)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getUserPassword

public java.lang.String getUserPassword()

setUserPassword

public void setUserPassword(java.lang.String userPassword)

getFtpPath

public java.lang.String getFtpPath()

setFtpPath

public void setFtpPath(java.lang.String ftpPath)

getLocalPath

public java.lang.String getLocalPath()

setLocalPath

public void setLocalPath(java.lang.String localPath)

getRemarks

public java.lang.String getRemarks()

setRemarks

public void setRemarks(java.lang.String remarks)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DWOIssueDetail

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DWOIssueDetail

java.lang.Object
    extended by  bb.common.DWOIssueDetail
All Implemented Interfaces:
java.io.Serializable
public class DWOIssueDetail
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACCOUNTNUMBER
static java.lang.String | ORDER_BY_COMPANYUNITID
static java.lang.String | ORDER_BY_DISASSEMBLEWORKORDERITEMNUMBER
static java.lang.String | ORDER_BY_DISASSEMBLEWORKORDERNUMBER
static java.lang.String | ORDER_BY_LASTCHANGEUSER
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_VENDORID
Constructor Summary
DWOIssueDetail()
Method Summary
java.lang.String | getAccountNumber()
java.lang.String | getCompanyUnitId()
java.math.BigDecimal | getCostPerUnit()
java.util.Date | getDateMade()
java.util.Date | getDateRequired()
java.lang.String | getDescription()
java.lang.String | getDisassembleWorkOrderItemNumber()
java.lang.String | getDisassembleWorkOrderNumber()
java.lang.String | getLastChangeUser()
java.util.LinkedHashMap | getLocation()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getQtyShipped()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getQuantityShippedTotal()
java.math.BigDecimal | getStandardCost()
java.lang.String | getVendorId()
void | setAccountNumber(java.lang.String accountNumber)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCostPerUnit(java.math.BigDecimal costPerUnit)
void | setDateMade(java.util.Date dateMade)
void | setDateRequired(java.util.Date dateRequired)
void | setDescription(java.lang.String description)
void | setDisassembleWorkOrderItemNumber(java.lang.String disassembleWorkOrderItemNumber)
void | setDisassembleWorkOrderNumber(java.lang.String disassembleWorkOrderNumber)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLocation(java.util.LinkedHashMap location)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setQtyShipped(java.math.BigDecimal qtyShipped)
void | setQuantity(java.math.BigDecimal quantity)
void | setQuantityShippedTotal(java.math.BigDecimal quantityShippedTotal)
void | setStandardCost(java.math.BigDecimal standardCost)
void | setVendorId(java.lang.String vendorId)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_DISASSEMBLEWORKORDERNUMBER

public static final java.lang.String ORDER_BY_DISASSEMBLEWORKORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_DISASSEMBLEWORKORDERITEMNUMBER

public static final java.lang.String ORDER_BY_DISASSEMBLEWORKORDERITEMNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_COMPANYUNITID

public static final java.lang.String ORDER_BY_COMPANYUNITID
See Also:
Constant Field Values

ORDER_BY_ACCOUNTNUMBER

public static final java.lang.String ORDER_BY_ACCOUNTNUMBER
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEUSER

public static final java.lang.String ORDER_BY_LASTCHANGEUSER
See Also:
Constant Field Values
Constructor Detail

DWOIssueDetail

public DWOIssueDetail()
Method Detail

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getQuantityShippedTotal

public java.math.BigDecimal getQuantityShippedTotal()

setQuantityShippedTotal

public void setQuantityShippedTotal(java.math.BigDecimal quantityShippedTotal)

getDateRequired

public java.util.Date getDateRequired()

setDateRequired

public void setDateRequired(java.util.Date dateRequired)

getCostPerUnit

public java.math.BigDecimal getCostPerUnit()

setCostPerUnit

public void setCostPerUnit(java.math.BigDecimal costPerUnit)

getDisassembleWorkOrderNumber

public java.lang.String getDisassembleWorkOrderNumber()

setDisassembleWorkOrderNumber

public void setDisassembleWorkOrderNumber(java.lang.String disassembleWorkOrderNumber)

getDisassembleWorkOrderItemNumber

public java.lang.String getDisassembleWorkOrderItemNumber()

setDisassembleWorkOrderItemNumber

public void setDisassembleWorkOrderItemNumber(java.lang.String disassembleWorkOrderItemNumber)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getQtyShipped

public java.math.BigDecimal getQtyShipped()

setQtyShipped

public void setQtyShipped(java.math.BigDecimal qtyShipped)

getDateMade

public java.util.Date getDateMade()

setDateMade

public void setDateMade(java.util.Date dateMade)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getStandardCost

public java.math.BigDecimal getStandardCost()

setStandardCost

public void setStandardCost(java.math.BigDecimal standardCost)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getLocation

public java.util.LinkedHashMap getLocation()

setLocation

public void setLocation(java.util.LinkedHashMap location)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DynamicSearchFilter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class DynamicSearchFilter

java.lang.Object
    extended by  bb.common.DynamicSearchFilter
All Implemented Interfaces:
java.io.Serializable
public class DynamicSearchFilter
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
DynamicSearchFilter()
Method Summary
java.lang.String | getFilter()
java.lang.String | getMethodName()
java.lang.String | getOrderBy()
void | setFilter(java.lang.String filter)
void | setMethodName(java.lang.String methodName)
void | setOrderBy(java.lang.String orderBy)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DynamicSearchFilter

public DynamicSearchFilter()
Method Detail

getFilter

public java.lang.String getFilter()

setFilter

public void setFilter(java.lang.String filter)

getMethodName

public java.lang.String getMethodName()

setMethodName

public void setMethodName(java.lang.String methodName)

getOrderBy

public java.lang.String getOrderBy()

setOrderBy

public void setOrderBy(java.lang.String orderBy)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EcnCheckOrderResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EcnCheckOrderResult

java.lang.Object
    extended by  bb.common.EcnCheckOrderResult
All Implemented Interfaces:
java.io.Serializable
public class EcnCheckOrderResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
EcnCheckOrderResult()
Method Summary
BB2Part | getPart()
java.util.Set | getPoOrderItems()
java.util.Set | getWoOrderItems()
void | setPart(BB2Part part)
void | setPoOrderItems(java.util.Set poOrderItems)
void | setWoOrderItems(java.util.Set woOrderItems)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EcnCheckOrderResult

public EcnCheckOrderResult()
Method Detail

setWoOrderItems

public void setWoOrderItems(java.util.Set woOrderItems)

setPoOrderItems

public void setPoOrderItems(java.util.Set poOrderItems)

getWoOrderItems

public java.util.Set getWoOrderItems()

getPoOrderItems

public java.util.Set getPoOrderItems()

getPart

public BB2Part getPart()

setPart

public void setPart(BB2Part part)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EcnPOOrderResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EcnPOOrderResult

java.lang.Object
    extended by  bb.common.EcnPOOrderResult
All Implemented Interfaces:
java.io.Serializable
public class EcnPOOrderResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DELIVERY
static java.lang.String | ORDER_BY_POITEMPK
static java.lang.String | ORDER_BY_VENDORID
Constructor Summary
EcnPOOrderResult()
Method Summary
java.util.Date | getDelivery()
java.lang.String | getDescription()
java.math.BigDecimal | getOndemand()
java.math.BigDecimal | getOnhand()
java.math.BigDecimal | getOnorder()
PurchaseOrderItemPK | getPoItemPk()
java.math.BigDecimal | getQty()
java.math.BigDecimal | getRecQty()
java.lang.String | getVendorId()
void | setDelivery(java.util.Date delivery)
void | setDescription(java.lang.String description)
void | setOndemand(java.math.BigDecimal ondemand)
void | setOnhand(java.math.BigDecimal onhand)
void | setOnorder(java.math.BigDecimal onorder)
void | setPoItemPk(PurchaseOrderItemPK poItemPk)
void | setQty(java.math.BigDecimal qty)
void | setRecQty(java.math.BigDecimal recQty)
void | setVendorId(java.lang.String vendorId)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_POITEMPK

public static final java.lang.String ORDER_BY_POITEMPK
See Also:
Constant Field Values

ORDER_BY_DELIVERY

public static final java.lang.String ORDER_BY_DELIVERY
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values
Constructor Detail

EcnPOOrderResult

public EcnPOOrderResult()
Method Detail

setPoItemPk

public void setPoItemPk(PurchaseOrderItemPK poItemPk)

setDelivery

public void setDelivery(java.util.Date delivery)

setDescription

public void setDescription(java.lang.String description)

setQty

public void setQty(java.math.BigDecimal qty)

setRecQty

public void setRecQty(java.math.BigDecimal recQty)

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

setOnorder

public void setOnorder(java.math.BigDecimal onorder)

setOndemand

public void setOndemand(java.math.BigDecimal ondemand)

setVendorId

public void setVendorId(java.lang.String vendorId)

getPoItemPk

public PurchaseOrderItemPK getPoItemPk()

getDelivery

public java.util.Date getDelivery()

getDescription

public java.lang.String getDescription()

getQty

public java.math.BigDecimal getQty()

getRecQty

public java.math.BigDecimal getRecQty()

getOnhand

public java.math.BigDecimal getOnhand()

getOnorder

public java.math.BigDecimal getOnorder()

getOndemand

public java.math.BigDecimal getOndemand()

getVendorId

public java.lang.String getVendorId()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ECNReviewVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ECNReviewVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ECNReviewVO
All Implemented Interfaces:
java.io.Serializable
public class ECNReviewVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_EMPLOYEEID
static java.lang.String | ORDER_BY_USERNAME
Constructor Summary
ECNReviewVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.lang.String | getEmployeeId()
java.lang.String | getUserName()
int | hashCode()
void | setComments(java.lang.String comments)
void | setEmployeeId(java.lang.String employeeId)
void | setUserName(java.lang.String userName)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_EMPLOYEEID

public static final java.lang.String ORDER_BY_EMPLOYEEID
See Also:
Constant Field Values

ORDER_BY_USERNAME

public static final java.lang.String ORDER_BY_USERNAME
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values
Constructor Detail

ECNReviewVO

public ECNReviewVO()
Method Detail

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EcnWOOrderResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EcnWOOrderResult

java.lang.Object
    extended by  bb.common.EcnWOOrderResult
All Implemented Interfaces:
java.io.Serializable
public class EcnWOOrderResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DELIVERY
static java.lang.String | ORDER_BY_POITEMPK
static java.lang.String | ORDER_BY_VENDORID
Constructor Summary
EcnWOOrderResult()
Method Summary
java.math.BigDecimal | getAsm()
java.util.Date | getDelivery()
java.lang.String | getDescription()
java.math.BigDecimal | getOndemand()
java.math.BigDecimal | getOnhand()
java.math.BigDecimal | getOnorder()
java.math.BigDecimal | getQty()
java.lang.String | getVendorId()
WorkOrderItemPK | getWoItemPk()
void | setAsm(java.math.BigDecimal asm)
void | setDelivery(java.util.Date delivery)
void | setDescription(java.lang.String description)
void | setOndemand(java.math.BigDecimal ondemand)
void | setOnhand(java.math.BigDecimal onhand)
void | setOnorder(java.math.BigDecimal onorder)
void | setQty(java.math.BigDecimal qty)
void | setVendorId(java.lang.String vendorId)
void | setWoItemPk(WorkOrderItemPK woItemPk)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_POITEMPK

public static final java.lang.String ORDER_BY_POITEMPK
See Also:
Constant Field Values

ORDER_BY_DELIVERY

public static final java.lang.String ORDER_BY_DELIVERY
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values
Constructor Detail

EcnWOOrderResult

public EcnWOOrderResult()
Method Detail

setWoItemPk

public void setWoItemPk(WorkOrderItemPK woItemPk)

setDelivery

public void setDelivery(java.util.Date delivery)

setDescription

public void setDescription(java.lang.String description)

setVendorId

public void setVendorId(java.lang.String vendorId)

setQty

public void setQty(java.math.BigDecimal qty)

setAsm

public void setAsm(java.math.BigDecimal asm)

setOnorder

public void setOnorder(java.math.BigDecimal onorder)

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

setOndemand

public void setOndemand(java.math.BigDecimal ondemand)

getWoItemPk

public WorkOrderItemPK getWoItemPk()

getDelivery

public java.util.Date getDelivery()

getDescription

public java.lang.String getDescription()

getVendorId

public java.lang.String getVendorId()

getQty

public java.math.BigDecimal getQty()

getAsm

public java.math.BigDecimal getAsm()

getOnorder

public java.math.BigDecimal getOnorder()

getOnhand

public java.math.BigDecimal getOnhand()

getOndemand

public java.math.BigDecimal getOndemand()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ECRReviewVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ECRReviewVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ECRReviewVO
All Implemented Interfaces:
java.io.Serializable
public class ECRReviewVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_EMPLOYEEID
static java.lang.String | ORDER_BY_USERNAME
Constructor Summary
ECRReviewVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.lang.String | getEmployeeId()
java.lang.String | getUserName()
int | hashCode()
void | setComments(java.lang.String comments)
void | setEmployeeId(java.lang.String employeeId)
void | setUserName(java.lang.String userName)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_EMPLOYEEID

public static final java.lang.String ORDER_BY_EMPLOYEEID
See Also:
Constant Field Values

ORDER_BY_USERNAME

public static final java.lang.String ORDER_BY_USERNAME
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values
Constructor Detail

ECRReviewVO

public ECRReviewVO()
Method Detail

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


E-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M N O P Q R S T U V W X Y Z

E

E - Static variable in class bb.common.Constant.Prefix
E - Static variable in class bb.common.Constant.TransactionType
EBIDTA_DETAIL - Static variable in class bb.common.Constant.CategoryReportType
ECN - Static variable in class bb.common.BizTarget
ECN - Static variable in class bb.common.Constant.EngineeringSharingImportDataType
ECN - Static variable in class bb.common.Constant.NoticeType
ECN - Static variable in class bb.common.Constant.PrintTemplateType
ECN_DOC - Static variable in class bb.common.Constant.MiscDocType
ECN_REVIEW - Static variable in class bb.common.BizTarget
ECN_REVIEW_ALREADY_EXIST - Static variable in class bb.common.BIZReason
ECN_REVIEW_NOT_EXIST - Static variable in class bb.common.BIZReason
EcnCheckOrderResult - Class in bb.common
EcnCheckOrderResult() - Constructor for class bb.common.EcnCheckOrderResult
EcnPOOrderResult - Class in bb.common
EcnPOOrderResult() - Constructor for class bb.common.EcnPOOrderResult
ECNReviewVO - Class in bb.common
ECNReviewVO() - Constructor for class bb.common.ECNReviewVO
EcnWOOrderResult - Class in bb.common
EcnWOOrderResult() - Constructor for class bb.common.EcnWOOrderResult
ECR - Static variable in class bb.common.BizTarget
ECR - Static variable in class bb.common.Constant.PrintTemplateType
ECR_APPROVAL - Static variable in class bb.common.BizTarget
ECR_APPROVAL_ALREADY_EXIST - Static variable in class bb.common.BIZReason
ECR_APPROVAL_NOT_EXIST - Static variable in class bb.common.BIZReason
ECR_DOC - Static variable in class bb.common.Constant.MiscDocType
ECRReviewVO - Class in bb.common
ECRReviewVO() - Constructor for class bb.common.ECRReviewVO
EDC_DOC - Static variable in class bb.common.BizTarget
EDC_DOC - Static variable in class bb.common.Constant.MiscDocType
EDC_DOC_NOT_FIND - Static variable in class bb.common.BIZReason
EG - Static variable in class bb.common.Constant.ChartOfAccountType
EIGHTLEVEL - Static variable in class bb.common.Constant.AgeLevel
EIGHTLEVEL - Static variable in class bb.common.Constant.WorkLevel
EJB_INVOKE_FAILED - Static variable in class bb.common.BIZReason
EjbMethodVO - Class in bb.common
EjbMethodVO() - Constructor for class bb.common.EjbMethodVO
default constructor
EL - Static variable in class bb.common.Constant.ChartOfAccountType
EMP_RECORDS_DOC - Static variable in class bb.common.Constant.MiscDocType
EMP_TRAINING_RECORDS - Static variable in class bb.common.BizTarget
EMP_TRAINING_RECORDS_NOT_FIND - Static variable in class bb.common.BIZReason
EMPLOYEE - Static variable in class bb.common.BizTarget
EMPLOYEE_ALREADY_ADDED - Static variable in class bb.common.BIZReason
EMPLOYEE_ALREADY_HAS_BIZBOX_USER_ACCOUNT - Static variable in class bb.common.BIZReason
EMPLOYEE_HAS_NO_BIZBOX_USER_ACCOUNT - Static variable in class bb.common.BIZReason
EMPLOYEE_ID_NOT_EXIST - Static variable in class bb.common.BIZReason
EMPLOYEE_TRAINING - Static variable in class bb.common.BizTarget
EMPLOYEE_TRAINING_ID_HAS_EXIST - Static variable in class bb.common.BIZReason
EMPLOYEE_TRAINING_ID_NOT_EXIST - Static variable in class bb.common.BIZReason
EmployeeCardVO - Class in bb.common
EmployeeCardVO() - Constructor for class bb.common.EmployeeCardVO
EmployeeEducationPK - Class in bb.common
EmployeeEducationPK() - Constructor for class bb.common.EmployeeEducationPK
EmployeeEducationResult - Class in bb.common
EmployeeEducationResult() - Constructor for class bb.common.EmployeeEducationResult
EmployeeEducationVO - Class in bb.common
EmployeeEducationVO() - Constructor for class bb.common.EmployeeEducationVO
EmployeeHomeVO - Class in bb.common
EmployeeHomeVO() - Constructor for class bb.common.EmployeeHomeVO
EmployeeJobDescriptionVO - Class in bb.common
EmployeeJobDescriptionVO(String, String, Blob) - Constructor for class bb.common.EmployeeJobDescriptionVO
full constructor
EmployeeJobDescriptionVO() - Constructor for class bb.common.EmployeeJobDescriptionVO
default constructor
EmployeeJobDescriptionVO(String, String) - Constructor for class bb.common.EmployeeJobDescriptionVO
minimal constructor
EmployeeLaborAgent - Class in bb.common
EmployeeLaborAgent() - Constructor for class bb.common.EmployeeLaborAgent
EmployeePutGoodListResult - Class in bb.common
EmployeePutGoodListResult() - Constructor for class bb.common.EmployeePutGoodListResult
EmployeeRecordsVO - Class in bb.common
EmployeeRecordsVO() - Constructor for class bb.common.EmployeeRecordsVO
EmployeeTimeCardResult - Class in bb.common
EmployeeTimeCardResult() - Constructor for class bb.common.EmployeeTimeCardResult
EmployeeTrainingVO - Class in bb.common
EmployeeTrainingVO() - Constructor for class bb.common.EmployeeTrainingVO
EmployeeWorkExperiencePK - Class in bb.common
EmployeeWorkExperiencePK() - Constructor for class bb.common.EmployeeWorkExperiencePK
EmployeeWorkExperienceVO - Class in bb.common
EmployeeWorkExperienceVO() - Constructor for class bb.common.EmployeeWorkExperienceVO
EMPTY_COLLECTION - Static variable in class bb.common.BIZReason
EMPTY_DOCUMENT - Static variable in class bb.common.BIZReason
EMPTY_GL_OR_ZERO_GL_ITEM - Static variable in class bb.common.BIZReason
EMPTY_ITEM_COLLECTION - Static variable in class bb.common.BIZReason
EMPTY_LOCATION - Static variable in class bb.common.Constant
EN - Static variable in class bb.common.Constant.ChartOfAccountType
EN - Static variable in class bb.common.Constant.LanguageCode
END_DATE_SHOULD_BE_BEFORE_THE_FOLLOW_FISCAL_YEAR_START_DATE - Static variable in class bb.common.BIZReason
END_MONTH_CAN_NOT_BE_EARLIER_THAN_START_MONTH - Static variable in class bb.common.BIZReason
ENG_GROUP - Static variable in class bb.common.BizTarget
ENG_GROUP_USED_IN_ENG_GROUP_USER - Static variable in class bb.common.BIZReason
ENG_GROUP_USED_IN_PART - Static variable in class bb.common.BIZReason
ENG_GROUP_USER - Static variable in class bb.common.BizTarget
EngGroupUserPK - Class in bb.common
EngGroupUserPK() - Constructor for class bb.common.EngGroupUserPK
EngGroupUserVO - Class in bb.common
EngGroupUserVO() - Constructor for class bb.common.EngGroupUserVO
EngGroupVO - Class in bb.common
EngGroupVO() - Constructor for class bb.common.EngGroupVO
ENGINEERING - Static variable in class bb.common.Configure.Module
ENGINEERING_CHANGE_NOTICE_NOT_CLOSED_EXIST_FOR_THIS_PART - Static variable in class bb.common.BIZReason
ENGINEERING_CHANGE_NOTICE_NOT_EXIST - Static variable in class bb.common.BIZReason
ENGINEERING_CHANGE_REQUEST_NOT_EXIST - Static variable in class bb.common.BIZReason
ENGINEERING_SHARING - Static variable in class bb.common.BizTarget
ENGINEERING_SHARING_ALREADY_EXIST - Static variable in class bb.common.BIZReason
ENGINEERING_SHARING_ITEM - Static variable in class bb.common.BizTarget
ENGINEERING_SHARING_ITEM_ALREADY_EXIST - Static variable in class bb.common.BIZReason
ENGINEERING_SHARING_NOT_EXIST - Static variable in class bb.common.BIZReason
EngineeringBox - Interface in bb.common.box
EngineeringChangeDocumentVO - Class in bb.common
EngineeringChangeDocumentVO() - Constructor for class bb.common.EngineeringChangeDocumentVO
default constructor
EngineeringChangeListResult - Class in bb.common
EngineeringChangeListResult() - Constructor for class bb.common.EngineeringChangeListResult
EngineeringChangeRequestDocumentVO - Class in bb.common
EngineeringChangeRequestDocumentVO() - Constructor for class bb.common.EngineeringChangeRequestDocumentVO
default constructor
EngineeringChangeRequestListResult - Class in bb.common
EngineeringChangeRequestListResult() - Constructor for class bb.common.EngineeringChangeRequestListResult
EngineeringChangeRequestVO - Class in bb.common
EngineeringChangeRequestVO() - Constructor for class bb.common.EngineeringChangeRequestVO
default constructor
EngineeringChangeVO - Class in bb.common
EngineeringChangeVO() - Constructor for class bb.common.EngineeringChangeVO
default constructor
EngineeringInfoCenterResult - Class in bb.common
EngineeringInfoCenterResult() - Constructor for class bb.common.EngineeringInfoCenterResult
EngineeringSharingImportLogVO - Class in bb.common
EngineeringSharingImportLogVO() - Constructor for class bb.common.EngineeringSharingImportLogVO
EngineeringSharingItemPK - Class in bb.common
EngineeringSharingItemPK(String, String, String) - Constructor for class bb.common.EngineeringSharingItemPK
full constructor
EngineeringSharingItemPK() - Constructor for class bb.common.EngineeringSharingItemPK
default constructor
EngineeringSharingItemVO - Class in bb.common
EngineeringSharingItemVO() - Constructor for class bb.common.EngineeringSharingItemVO
EngineeringSharingVO - Class in bb.common
EngineeringSharingVO() - Constructor for class bb.common.EngineeringSharingVO
default constructor
ENGROUP_EXIST - Static variable in class bb.common.BIZReason
ENGROUP_HAS_ITEM - Static variable in class bb.common.BIZReason
ENGROUP_NOT_EXIST - Static variable in class bb.common.BIZReason
ENGROUP_USER_EXIST - Static variable in class bb.common.BIZReason
ENGROUP_USER_NOT_EXIST - Static variable in class bb.common.BIZReason
ENSTYLE - Static variable in class bb.common.Constant.GLStyle
EO - Static variable in class bb.common.Constant.ChartOfAccountType
equals(Object) - Method in class bb.common.AccountCreditDebitPK
equals(Object) - Method in class bb.common.AccountCreditVO
equals(Object) - Method in class bb.common.AccountDebitVO
equals(Object) - Method in class bb.common.AccountingConfigurationVO
equals(Object) - Method in class bb.common.AccountingSettingsVO
equals(Object) - Method in class bb.common.AccountingTransactionTypeVO
equals(Object) - Method in class bb.common.AccountMonthPK
equals(Object) - Method in class bb.common.AccountPayableCheckRunItemVO
equals(Object) - Method in class bb.common.AccountPayableCheckRunVO
equals(Object) - Method in class bb.common.AccountsChartCategoryVO
equals(Object) - Method in class bb.common.AccountsChartMappingPK
equals(Object) - Method in class bb.common.AccountsChartMappingVO
equals(Object) - Method in class bb.common.AccountsChartVO
equals(Object) - Method in class bb.common.AccountsPayableInfoVO
equals(Object) - Method in class bb.common.AccountsPayableItemManufacturerPK
equals(Object) - Method in class bb.common.AccountsPayableItemManufacturerVO
equals(Object) - Method in class bb.common.AccountsPayableItemPK
equals(Object) - Method in class bb.common.AccountsPayableItemVO
equals(Object) - Method in class bb.common.AccountsPayableVO
equals(Object) - Method in class bb.common.AccountsReceivableInfoVO
equals(Object) - Method in class bb.common.AccountsReceivableItemManufacturerPK
equals(Object) - Method in class bb.common.AccountsReceivableItemManufacturerVO
equals(Object) - Method in class bb.common.AccountsReceivableItemPK
equals(Object) - Method in class bb.common.AccountsReceivableItemVO
equals(Object) - Method in class bb.common.AccountsReceivableVO
equals(Object) - Method in class bb.common.AddProformaReceiverItemAgent
equals(Object) - Method in class bb.common.AllPartDocumentsPK
equals(Object) - Method in class bb.common.AllPartDocumentsVO
equals(Object) - Method in class bb.common.ApPrepayItemPK
equals(Object) - Method in class bb.common.ApPrepayItemVO
equals(Object) - Method in class bb.common.ApPrepayVO
equals(Object) - Method in class bb.common.ARBoilerplateVO
equals(Object) - Method in class bb.common.ARPaymentRunItemPK
equals(Object) - Method in class bb.common.ARPaymentRunItemVO
equals(Object) - Method in class bb.common.ARPaymentRunVO
equals(Object) - Method in class bb.common.ArPrepayItemPK
equals(Object) - Method in class bb.common.ArPrepayItemVO
equals(Object) - Method in class bb.common.ArPrepayVO
equals(Object) - Method in class bb.common.AssetAmortizationExpenseAccountPK
equals(Object) - Method in class bb.common.AssetAmortizationExpenseAccountVO
equals(Object) - Method in class bb.common.AssetDepreciatePK
equals(Object) - Method in class bb.common.AssetDepreciateVO
equals(Object) - Method in class bb.common.AssetTypeVO
equals(Object) - Method in class bb.common.AssetUsagePK
equals(Object) - Method in class bb.common.AssetVO
equals(Object) - Method in class bb.common.AuditLogVO
equals(Object) - Method in class bb.common.BankReconciliationReportVO
equals(Object) - Method in class bb.common.BB2BigDecimalAndString
equals(Object) - Method in class bb.common.BB2DoubleCost
equals(Object) - Method in class bb.common.BB2DoubleString
equals(Object) - Method in class bb.common.BB2Part
equals(Object) - Method in class bb.common.BB2RefdocPK
equals(Object) - Method in class bb.common.BB2tripleString
equals(Object) - Method in class bb.common.BillItemPK
equals(Object) - Method in class bb.common.BillItemReplacementVO
equals(Object) - Method in class bb.common.BillItemVO
equals(Object) - Method in class bb.common.BillItemWithPartInfoResult
equals(Object) - Method in class bb.common.BillLogVO
equals(Object) - Method in class bb.common.BillPK
equals(Object) - Method in class bb.common.BillVO
equals(Object) - Method in class bb.common.BizboxBugChangesInfoVO
equals(Object) - Method in class bb.common.BizboxBugChangesVO
equals(Object) - Method in class bb.common.BizboxBugInfoVO
equals(Object) - Method in class bb.common.BizboxBugVO
equals(Object) - Method in class bb.common.BizBoxUserEmployeeResult
equals(Object) - Method in class bb.common.BizboxUserVO
equals(Object) - Method in class bb.common.BomApprovalVO
equals(Object) - Method in class bb.common.BuyerCodeVO
equals(Object) - Method in class bb.common.CarrierPK
equals(Object) - Method in class bb.common.CarrierVO
equals(Object) - Method in class bb.common.CatalogVO
equals(Object) - Method in class bb.common.CertificateDescriptionVO
equals(Object) - Method in class bb.common.ChangeStdCostWorkSheetItemPK
equals(Object) - Method in class bb.common.ChangeStdCostWorkSheetItemVO
equals(Object) - Method in class bb.common.ChangeStdCostWorkSheetVO
equals(Object) - Method in class bb.common.CompanyUnitAccountPK
equals(Object) - Method in class bb.common.CompanyUnitAccountVO
equals(Object) - Method in class bb.common.CompanyUnitVO
equals(Object) - Method in class bb.common.CompanyVO
equals(Object) - Method in class bb.common.ContractPriceCustomerPK
equals(Object) - Method in class bb.common.ContractPriceCustomerVO
equals(Object) - Method in class bb.common.ContractPriceItemPK
equals(Object) - Method in class bb.common.ContractPriceItemVO
equals(Object) - Method in class bb.common.ContractPriceVO
equals(Object) - Method in class bb.common.CorrectiveActionRequestVO
equals(Object) - Method in class bb.common.CurrencyExchangePK
equals(Object) - Method in class bb.common.CurrencyExchangeVO
equals(Object) - Method in class bb.common.CurrencyVO
equals(Object) - Method in class bb.common.CustomAssetRecordPK
equals(Object) - Method in class bb.common.CustomAssetRecordVO
equals(Object) - Method in class bb.common.CustomAssetVO
equals(Object) - Method in class bb.common.CustomCheckUpEmployeeVO
equals(Object) - Method in class bb.common.CustomDepartmentVO
equals(Object) - Method in class bb.common.CustomEmployeeTrainPK
equals(Object) - Method in class bb.common.CustomEmployeeTrainVO
equals(Object) - Method in class bb.common.CustomEmployeeVO
equals(Object) - Method in class bb.common.CustomEmployeeWorkExperienceVO
equals(Object) - Method in class bb.common.CustomerFeedbackVO
equals(Object) - Method in class bb.common.CustomerReturnToVendorItemPK
equals(Object) - Method in class bb.common.CustomerReturnToVendorItemVO
equals(Object) - Method in class bb.common.CustomerReturnToVendorVO
equals(Object) - Method in class bb.common.CustomerServiceIncidentVO
equals(Object) - Method in class bb.common.CustomerVendorAddressInfoVO
equals(Object) - Method in class bb.common.CustomerVendorAddressVO
equals(Object) - Method in class bb.common.CustomerVendorContactPK
equals(Object) - Method in class bb.common.CustomerVendorContactVO
equals(Object) - Method in class bb.common.CustomerVendorDescriptionPK
equals(Object) - Method in class bb.common.CustomerVendorDescriptionVO
equals(Object) - Method in class bb.common.CustomerVendorTypeVO
equals(Object) - Method in class bb.common.CustomGoodsBreedVO
equals(Object) - Method in class bb.common.CustomGoodsRecordVO
equals(Object) - Method in class bb.common.CustomJobCategoryGoodsPK
equals(Object) - Method in class bb.common.CustomJobCategoryGoodsVO
equals(Object) - Method in class bb.common.CustomJobCategoryVO
equals(Object) - Method in class bb.common.CustomSearchVO
equals(Object) - Method in class bb.common.CustomTranslationVO
equals(Object) - Method in class bb.common.CycleCountAgent
equals(Object) - Method in class bb.common.CycleCountPK
equals(Object) - Method in class bb.common.CycleCountVO
equals(Object) - Method in class bb.common.DepartmentLocationForBackflushVO
equals(Object) - Method in class bb.common.DesignControlDocumentVO
equals(Object) - Method in class bb.common.DesignControlInfoVO
equals(Object) - Method in class bb.common.DesignControlVO
equals(Object) - Method in class bb.common.DisassembleWorkOrderApprovalVO
equals(Object) - Method in class bb.common.DisassembleWorkOrderIssueVO
equals(Object) - Method in class bb.common.DisassembleWorkOrderItemPK
equals(Object) - Method in class bb.common.DisassembleWorkOrderItemReceiverPK
equals(Object) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO
equals(Object) - Method in class bb.common.DisassembleWorkOrderItemVO
equals(Object) - Method in class bb.common.DisassembleWorkOrderVO
equals(Object) - Method in class bb.common.DocumentLogVO
equals(Object) - Method in class bb.common.DocumentServerVO
equals(Object) - Method in class bb.common.DwfUploadSettingsVO
equals(Object) - Method in class bb.common.DwgUploadSettingsVO
equals(Object) - Method in class bb.common.ECNReviewVO
equals(Object) - Method in class bb.common.ECRReviewVO
equals(Object) - Method in class bb.common.EjbMethodVO
equals(Object) - Method in class bb.common.EmployeeCardVO
equals(Object) - Method in class bb.common.EmployeeEducationPK
equals(Object) - Method in class bb.common.EmployeeJobDescriptionVO
equals(Object) - Method in class bb.common.EmployeeWorkExperiencePK
equals(Object) - Method in class bb.common.EngGroupUserPK
equals(Object) - Method in class bb.common.EngGroupUserVO
equals(Object) - Method in class bb.common.EngGroupVO
equals(Object) - Method in class bb.common.EngineeringChangeDocumentVO
equals(Object) - Method in class bb.common.EngineeringChangeRequestDocumentVO
equals(Object) - Method in class bb.common.EngineeringChangeRequestVO
equals(Object) - Method in class bb.common.EngineeringChangeVO
equals(Object) - Method in class bb.common.EngineeringSharingItemPK
equals(Object) - Method in class bb.common.EngineeringSharingItemVO
equals(Object) - Method in class bb.common.EngineeringSharingVO
equals(Object) - Method in class bb.common.EquipmentVO
equals(Object) - Method in class bb.common.ExpenseAccountVO
equals(Object) - Method in class bb.common.ExpenseItemPK
equals(Object) - Method in class bb.common.ExpenseItemVO
equals(Object) - Method in class bb.common.ExpenseVO
equals(Object) - Method in class bb.common.FeedbackAnswerPK
equals(Object) - Method in class bb.common.FeedbackAnswerVO
equals(Object) - Method in class bb.common.FeedBackItemPK
equals(Object) - Method in class bb.common.FeedbackItemVO
equals(Object) - Method in class bb.common.FeedbackQuestionVO
equals(Object) - Method in class bb.common.FiscalYearSettingsVO
equals(Object) - Method in class bb.common.GeneralLedgerApprovalVO
equals(Object) - Method in class bb.common.GeneralLedgerSettingsVO
equals(Object) - Method in class bb.common.GeneralLedgerVO
equals(Object) - Method in class bb.common.GLAutoApproveVO
equals(Object) - Method in class bb.common.GlCashFlowBudgetVO
equals(Object) - Method in class bb.common.GlFiscalYearBudgetVO
equals(Object) - Method in class bb.common.GLItemVO
equals(Object) - Method in class bb.common.GlMonthBudgetVO
equals(Object) - Method in class bb.common.GlMonthVO
equals(Object) - Method in class bb.common.GroupUserPK
equals(Object) - Method in class bb.common.HelpServerVO
equals(Object) - Method in class bb.common.HistoricalInventoryVO
equals(Object) - Method in class bb.common.ImportDataVO
equals(Object) - Method in class bb.common.IncotermVO
equals(Object) - Method in class bb.common.InspectionConformanceReportItemCheckPK
equals(Object) - Method in class bb.common.InspectionConformanceReportItemCheckVO
equals(Object) - Method in class bb.common.InspectionConformanceReportItemPK
equals(Object) - Method in class bb.common.InspectionConformanceReportItemVO
equals(Object) - Method in class bb.common.InspectionConformanceReportVO
equals(Object) - Method in class bb.common.InspectionItemPK
equals(Object) - Method in class bb.common.InspectionItemVO
equals(Object) - Method in class bb.common.InspectionReportInfoVO
equals(Object) - Method in class bb.common.InspectionReportInspectMethodItemPK
equals(Object) - Method in class bb.common.InspectionReportInspectMethodItemVO
equals(Object) - Method in class bb.common.InspectionReportInspectMethodVO
equals(Object) - Method in class bb.common.InspectionReportInspectStandardItemPK
equals(Object) - Method in class bb.common.InspectionReportInspectStandardItemVO
equals(Object) - Method in class bb.common.InspectionReportItemPK
equals(Object) - Method in class bb.common.InspectionReportItemQtyPK
equals(Object) - Method in class bb.common.InspectionReportItemQtyVO
equals(Object) - Method in class bb.common.InspectionReportItemVO
equals(Object) - Method in class bb.common.InspectionReportVO
equals(Object) - Method in class bb.common.InspectionTypeItemPK
equals(Object) - Method in class bb.common.InspectionTypeItemVO
equals(Object) - Method in class bb.common.InspectionTypeVO
equals(Object) - Method in class bb.common.IpAddressVO
equals(Object) - Method in class bb.common.LabelTemplateItemPK
equals(Object) - Method in class bb.common.LabelTemplateItemVO
equals(Object) - Method in class bb.common.LabelTemplateVO
equals(Object) - Method in class bb.common.LogInventoryVO
equals(Object) - Method in class bb.common.LogMethodPK
equals(Object) - Method in class bb.common.LogMethodVO
equals(Object) - Method in class bb.common.LogPartDocumentVO
equals(Object) - Method in class bb.common.LogTrackingVO
equals(Object) - Method in class bb.common.MaintenanceItemPK
equals(Object) - Method in class bb.common.MaintenanceItemVO
equals(Object) - Method in class bb.common.ManufacturerAddressInfoVO
equals(Object) - Method in class bb.common.ManufacturerAddressVO
equals(Object) - Method in class bb.common.ManufacturerContactPK
equals(Object) - Method in class bb.common.ManufacturerContactVO
equals(Object) - Method in class bb.common.ManufacturerDescriptionPK
equals(Object) - Method in class bb.common.ManufacturerDescriptionVO
equals(Object) - Method in class bb.common.MessageVO
equals(Object) - Method in class bb.common.MultiLanguageAccountsChartPK
equals(Object) - Method in class bb.common.MultiLanguageAccountsChartVO
equals(Object) - Method in class bb.common.MyPrintListPK
equals(Object) - Method in class bb.common.MyPrintListVO
equals(Object) - Method in class bb.common.NcrApprovalPK
equals(Object) - Method in class bb.common.NcrApprovalVO
equals(Object) - Method in class bb.common.NCRPartOnhandPK
equals(Object) - Method in class bb.common.NCRPictureVO
equals(Object) - Method in class bb.common.NonConformanceCodeDescriptionPK
equals(Object) - Method in class bb.common.NonConformanceCodeDescriptionVO
equals(Object) - Method in class bb.common.NonConformanceCodeVO
equals(Object) - Method in class bb.common.NonConformanceQuantityPK
equals(Object) - Method in class bb.common.NonConformanceQuantityVO
equals(Object) - Method in class bb.common.NonConformanceReportVO
equals(Object) - Method in class bb.common.NonproductivePickingItemIssuedVO
equals(Object) - Method in class bb.common.NonproductivePickingItemPK
equals(Object) - Method in class bb.common.NonproductivePickingItemVO
equals(Object) - Method in class bb.common.NonproductivePickingTypeVO
equals(Object) - Method in class bb.common.NonproductivePickingVO
equals(Object) - Method in class bb.common.OnLoanItemPK
equals(Object) - Method in class bb.common.OnLoanItemVO
equals(Object) - Method in class bb.common.OnloanReceiverItemPK
equals(Object) - Method in class bb.common.OnloanReceiverItemVO
equals(Object) - Method in class bb.common.OnloanReceiverVO
equals(Object) - Method in class bb.common.OnloanReviewVO
equals(Object) - Method in class bb.common.OnloanShipperItemPK
equals(Object) - Method in class bb.common.OnloanShipperItemVO
equals(Object) - Method in class bb.common.OnloanShipperVO
equals(Object) - Method in class bb.common.OnLoanVO
equals(Object) - Method in class bb.common.OpCodeShortcutPK
equals(Object) - Method in class bb.common.OperatingInstructionsInspectMethodItemPK
equals(Object) - Method in class bb.common.OperatingInstructionsInspectMethodItemVO
equals(Object) - Method in class bb.common.OperatingInstructionsInspectResultItemPK
equals(Object) - Method in class bb.common.OperatingInstructionsInspectResultItemVO
equals(Object) - Method in class bb.common.OperatingInstructionsInspectStandardItemPK
equals(Object) - Method in class bb.common.OperatingInstructionsInspectStandardItemVO
equals(Object) - Method in class bb.common.OperatingInstructionsInspectStandardVO
equals(Object) - Method in class bb.common.OperatingInstructionsManualItemPK
equals(Object) - Method in class bb.common.OperatingInstructionsManualItemVO
equals(Object) - Method in class bb.common.OperatingInstructionsManualVO
equals(Object) - Method in class bb.common.OperatingInstructionsTypeVO
equals(Object) - Method in class bb.common.OperatingInstructionsVO
equals(Object) - Method in class bb.common.OperatingOutputFileItemPK
equals(Object) - Method in class bb.common.OperatingOutputFileItemVO
equals(Object) - Method in class bb.common.OperatingOutputFileTypeVO
equals(Object) - Method in class bb.common.OperationLogVO
equals(Object) - Method in class bb.common.OrderApprovalItemsVO
equals(Object) - Method in class bb.common.OrderBoilerplatePK
equals(Object) - Method in class bb.common.OrderBoilerplateVO
equals(Object) - Method in class bb.common.OrderPK
equals(Object) - Method in class bb.common.PackingBoxItemPK
equals(Object) - Method in class bb.common.PackingBoxItemVO
equals(Object) - Method in class bb.common.PackingBoxPK
equals(Object) - Method in class bb.common.PackingBoxSalesOrderItemAgent
equals(Object) - Method in class bb.common.PackingBoxVO
equals(Object) - Method in class bb.common.PartBasicInfo
equals(Object) - Method in class bb.common.PartCatagoryPK
equals(Object) - Method in class bb.common.PartCatagoryVO
equals(Object) - Method in class bb.common.PartCatalogAuditResult
equals(Object) - Method in class bb.common.PartCatalogPK
equals(Object) - Method in class bb.common.PartCatalogVO
equals(Object) - Method in class bb.common.PartCertificateVO
equals(Object) - Method in class bb.common.PartClassVO
equals(Object) - Method in class bb.common.PartDescriptionPK
equals(Object) - Method in class bb.common.PartDescriptionVO
equals(Object) - Method in class bb.common.PartDiscountPK
equals(Object) - Method in class bb.common.PartDiscountVO
equals(Object) - Method in class bb.common.PartDocumentPK
equals(Object) - Method in class bb.common.PartDocumentVO
equals(Object) - Method in class bb.common.PartDwfAgent
equals(Object) - Method in class bb.common.PartDwfPK
equals(Object) - Method in class bb.common.PartDwfVO
equals(Object) - Method in class bb.common.PartDwgPK
equals(Object) - Method in class bb.common.PartDwgVO
equals(Object) - Method in class bb.common.PartExportInfo
equals(Object) - Method in class bb.common.PartInQAResult
equals(Object) - Method in class bb.common.PartInQAVO
equals(Object) - Method in class bb.common.PartInspectionPK
equals(Object) - Method in class bb.common.PartInspectionVO
equals(Object) - Method in class bb.common.PartInventoryVO
equals(Object) - Method in class bb.common.PartIssuedVO
equals(Object) - Method in class bb.common.PartManufacturerPK
equals(Object) - Method in class bb.common.PartManufacturerVO
equals(Object) - Method in class bb.common.PartMaterialVO
equals(Object) - Method in class bb.common.PartMRPVO
equals(Object) - Method in class bb.common.PartOnhandPK
equals(Object) - Method in class bb.common.PartOnhandVO
equals(Object) - Method in class bb.common.PartOnhandWithAverageCostResult
equals(Object) - Method in class bb.common.PartPictureVO
equals(Object) - Method in class bb.common.PartPK
equals(Object) - Method in class bb.common.PartReceivedVO
equals(Object) - Method in class bb.common.PartSecurityLevelVO
equals(Object) - Method in class bb.common.PartTraceableCategoryPK
equals(Object) - Method in class bb.common.PartTraceableCategoryVO
equals(Object) - Method in class bb.common.PartTraceableSpecPK
equals(Object) - Method in class bb.common.PartTraceableSpecVO
equals(Object) - Method in class bb.common.PartTrackingPK
equals(Object) - Method in class bb.common.PartTrackingVO
equals(Object) - Method in class bb.common.PartTypeVO
equals(Object) - Method in class bb.common.PartUnitPK
equals(Object) - Method in class bb.common.PartUnitVO
equals(Object) - Method in class bb.common.PartUseTypeVO
equals(Object) - Method in class bb.common.PartVendorPK
equals(Object) - Method in class bb.common.PartVendorVO
equals(Object) - Method in class bb.common.PartVO
equals(Object) - Method in class bb.common.PartWithOnhandsVO
equals(Object) - Method in class bb.common.PartWithoutLocateResult
equals(Object) - Method in class bb.common.PayableCheckRunItemPK
equals(Object) - Method in class bb.common.PayableMethodVO
equals(Object) - Method in class bb.common.PaymentHistoryVO
equals(Object) - Method in class bb.common.PermissionDescriptionPK
equals(Object) - Method in class bb.common.PermissionDescriptionVO
equals(Object) - Method in class bb.common.PermissionMethodPK
equals(Object) - Method in class bb.common.PermissionMethodVO
equals(Object) - Method in class bb.common.PermissionVO
equals(Object) - Method in class bb.common.PfReceiverItemPK
equals(Object) - Method in class bb.common.PfReceiverItemVO
equals(Object) - Method in class bb.common.PfReceiverItemWithNumberPK
equals(Object) - Method in class bb.common.PfReceiverVO
equals(Object) - Method in class bb.common.PhysicalInventoryPK
equals(Object) - Method in class bb.common.PhysicalInventoryVO
equals(Object) - Method in class bb.common.PointOfSaleVO
equals(Object) - Method in class bb.common.PoMessageItemPK
equals(Object) - Method in class bb.common.PoMessageItemVO
equals(Object) - Method in class bb.common.PoMessageVO
equals(Object) - Method in class bb.common.PosRefdocVO
equals(Object) - Method in class bb.common.POSurveyReportItemPK
equals(Object) - Method in class bb.common.POSurveyReportItemVO
equals(Object) - Method in class bb.common.POSurveyReportVO
equals(Object) - Method in class bb.common.PosZipCodeTaxPK
equals(Object) - Method in class bb.common.PosZipCodeTaxVO
equals(Object) - Method in class bb.common.PreventiveActionRequestVO
equals(Object) - Method in class bb.common.PrintLogoVO
equals(Object) - Method in class bb.common.PrintTemplateVO
equals(Object) - Method in class bb.common.ProformaInvoiceItemManufacturerPK
equals(Object) - Method in class bb.common.ProformaInvoiceItemManufacturerVO
equals(Object) - Method in class bb.common.ProformaInvoiceItemPK
equals(Object) - Method in class bb.common.ProformaInvoiceItemVO
equals(Object) - Method in class bb.common.ProformaInvoiceVO
equals(Object) - Method in class bb.common.PrPackingBoxItemPK
equals(Object) - Method in class bb.common.PrPackingBoxItemVO
equals(Object) - Method in class bb.common.PrPackingBoxPK
equals(Object) - Method in class bb.common.PrPackingBoxVO
equals(Object) - Method in class bb.common.PurchaseOrderApprovalVO
equals(Object) - Method in class bb.common.PurchaseOrderBoilerplateVO
equals(Object) - Method in class bb.common.PurchaseOrderItemManufacturerPK
equals(Object) - Method in class bb.common.PurchaseOrderItemManufacturerVO
equals(Object) - Method in class bb.common.PurchaseOrderItemPK
equals(Object) - Method in class bb.common.PurchaseOrderItemVO
equals(Object) - Method in class bb.common.PurchaseOrderVO
equals(Object) - Method in class bb.common.PurchaseWorkSheetItemPK
equals(Object) - Method in class bb.common.PurchaseWorkSheetItemVO
equals(Object) - Method in class bb.common.PurchaseWorkSheetPK
equals(Object) - Method in class bb.common.PurchaseWorkSheetVO
equals(Object) - Method in class bb.common.QualityGroupPK
equals(Object) - Method in class bb.common.QualityGroupVO
equals(Object) - Method in class bb.common.QuoteBoilerplateVO
equals(Object) - Method in class bb.common.QuoteItemManufacturerPK
equals(Object) - Method in class bb.common.QuoteItemManufacturerVO
equals(Object) - Method in class bb.common.QuoteItemPK
equals(Object) - Method in class bb.common.QuoteItemVO
equals(Object) - Method in class bb.common.QuoteVO
equals(Object) - Method in class bb.common.Reason
equals(Object) - Method in class bb.common.ReceiverInfoVO
equals(Object) - Method in class bb.common.ReceiverItemAgent
equals(Object) - Method in class bb.common.ReceiverItemManufacturerPK
equals(Object) - Method in class bb.common.ReceiverItemManufacturerVO
equals(Object) - Method in class bb.common.ReceiverItemPK
equals(Object) - Method in class bb.common.ReceiverItemTrackingLogAgent
equals(Object) - Method in class bb.common.ReceiverItemVO
equals(Object) - Method in class bb.common.ReceiverVO
equals(Object) - Method in class bb.common.RefdocVO
equals(Object) - Method in class bb.common.RequestForQuoteItemManufacturerPK
equals(Object) - Method in class bb.common.RequestForQuoteItemManufacturerVO
equals(Object) - Method in class bb.common.RequestForQuoteItemPK
equals(Object) - Method in class bb.common.RequestForQuoteItemVO
equals(Object) - Method in class bb.common.RequestForQuoteVO
equals(Object) - Method in class bb.common.RequestForRMAItemPK
equals(Object) - Method in class bb.common.RequestForRMAItemVO
equals(Object) - Method in class bb.common.RequestForRMAVO
equals(Object) - Method in class bb.common.ReturnMaterialAuthorizationItemManufacturerPK
equals(Object) - Method in class bb.common.ReturnMaterialAuthorizationItemManufacturerVO
equals(Object) - Method in class bb.common.ReturnMaterialAuthorizationItemPK
equals(Object) - Method in class bb.common.ReturnMaterialAuthorizationItemVO
equals(Object) - Method in class bb.common.ReturnMaterialAuthorizationVO
equals(Object) - Method in class bb.common.ReturnToVendorItemManufacturerPK
equals(Object) - Method in class bb.common.ReturnToVendorItemManufacturerVO
equals(Object) - Method in class bb.common.ReturnToVendorItemPK
equals(Object) - Method in class bb.common.ReturnToVendorItemVO
equals(Object) - Method in class bb.common.ReturnToVendorVO
equals(Object) - Method in class bb.common.RfqMessageItemPK
equals(Object) - Method in class bb.common.RfqMessageItemVO
equals(Object) - Method in class bb.common.RfqMessageVO
equals(Object) - Method in class bb.common.RMAReceiverItemPK
equals(Object) - Method in class bb.common.RMAReceiverItemVO
equals(Object) - Method in class bb.common.RMAReceiverVO
equals(Object) - Method in class bb.common.RMAReviewVO
equals(Object) - Method in class bb.common.RoleDescriptionPK
equals(Object) - Method in class bb.common.RoleDescriptionVO
equals(Object) - Method in class bb.common.RoleListResult
equals(Object) - Method in class bb.common.RolePermissionPK
equals(Object) - Method in class bb.common.RolePermissionVO
equals(Object) - Method in class bb.common.RoleVO
equals(Object) - Method in class bb.common.RollUpBomStdCostWorkSheetItemPK
equals(Object) - Method in class bb.common.RollUpBomStdCostWorkSheetItemVO
equals(Object) - Method in class bb.common.RollUpBomStdCostWorkSheetVO
equals(Object) - Method in class bb.common.RollUPPartStandardCostResult
equals(Object) - Method in class bb.common.RTVApprovalVO
equals(Object) - Method in class bb.common.RtvShipperInfoVO
equals(Object) - Method in class bb.common.RtvShipperItemPK
equals(Object) - Method in class bb.common.RtvShipperItemVO
equals(Object) - Method in class bb.common.RtvShipperVO
equals(Object) - Method in class bb.common.RunningAccountOrderItemPK
equals(Object) - Method in class bb.common.RunningAccountOrderItemVO
equals(Object) - Method in class bb.common.RunningAccountOrderVO
equals(Object) - Method in class bb.common.SalesCodeVO
equals(Object) - Method in class bb.common.SalesmanVO
equals(Object) - Method in class bb.common.SalesOrderBoilerplateVO
equals(Object) - Method in class bb.common.SalesOrderItemInfoVO
equals(Object) - Method in class bb.common.SalesOrderItemManufacturerPK
equals(Object) - Method in class bb.common.SalesOrderItemManufacturerVO
equals(Object) - Method in class bb.common.SalesOrderItemPK
equals(Object) - Method in class bb.common.SalesOrderItemVO
equals(Object) - Method in class bb.common.SalesOrderListResult
equals(Object) - Method in class bb.common.SalesOrderReviewVO
equals(Object) - Method in class bb.common.SalesOrderVO
equals(Object) - Method in class bb.common.ScrapReportVO
equals(Object) - Method in class bb.common.SerialNumberItemPK
equals(Object) - Method in class bb.common.SerialNumberItemVO
equals(Object) - Method in class bb.common.SerialNumberPK
equals(Object) - Method in class bb.common.SerialNumberVO
equals(Object) - Method in class bb.common.ServerClientPropertyPK
equals(Object) - Method in class bb.common.SGBillItemPK
equals(Object) - Method in class bb.common.SGBillItemVO
equals(Object) - Method in class bb.common.SGClientAccountPK
equals(Object) - Method in class bb.common.SGClientAccountVO
equals(Object) - Method in class bb.common.SgClientProgramUserVO
equals(Object) - Method in class bb.common.SGCompanyPK
equals(Object) - Method in class bb.common.SGCompanyVO
equals(Object) - Method in class bb.common.SGCustomerCatalogPK
equals(Object) - Method in class bb.common.SGCustomerCatalogVO
equals(Object) - Method in class bb.common.SGCustomerServiceRequestVO
equals(Object) - Method in class bb.common.SGCustRequestForQuoteItemPK
equals(Object) - Method in class bb.common.SGCustRequestForQuoteItemVO
equals(Object) - Method in class bb.common.SGCustRequestForQuoteVO
equals(Object) - Method in class bb.common.SGDocPartPK
equals(Object) - Method in class bb.common.SGDocPartVO
equals(Object) - Method in class bb.common.SGDwgPicturePK
equals(Object) - Method in class bb.common.SGDwgPictureVO
equals(Object) - Method in class bb.common.SGLogLoginVO
equals(Object) - Method in class bb.common.SGPicturePK
equals(Object) - Method in class bb.common.SGPictureVO
equals(Object) - Method in class bb.common.SGQuoteAddressVO
equals(Object) - Method in class bb.common.SGQuoteCartVO
equals(Object) - Method in class bb.common.SGQuoteLoginVO
equals(Object) - Method in class bb.common.SGSaleItemVO
equals(Object) - Method in class bb.common.SGWeightUnitVO
equals(Object) - Method in class bb.common.ShipListInfoVO
equals(Object) - Method in class bb.common.ShipListItemPK
equals(Object) - Method in class bb.common.ShipListItemVO
equals(Object) - Method in class bb.common.ShipListItemVOResult
equals(Object) - Method in class bb.common.ShipListOwnerAttributePK
equals(Object) - Method in class bb.common.ShipListOwnerAttributeVO
equals(Object) - Method in class bb.common.ShipListOwnerVO
equals(Object) - Method in class bb.common.ShipListVO
equals(Object) - Method in class bb.common.ShipperInfoVO
equals(Object) - Method in class bb.common.ShipperItemManufacturerPK
equals(Object) - Method in class bb.common.ShipperItemManufacturerVO
equals(Object) - Method in class bb.common.ShipperItemPK
equals(Object) - Method in class bb.common.ShipperItemVO
equals(Object) - Method in class bb.common.ShipperVO
equals(Object) - Method in class bb.common.SmtpServerVO
equals(Object) - Method in class bb.common.SubcompanyVO
equals(Object) - Method in class bb.common.SwapOrderApprovalVO
equals(Object) - Method in class bb.common.SwapOrderItemPK
equals(Object) - Method in class bb.common.SwapOrderItemVO
equals(Object) - Method in class bb.common.SwapOrderVO
equals(Object) - Method in class bb.common.SwapReceiverItemPK
equals(Object) - Method in class bb.common.SwapReceiverItemVO
equals(Object) - Method in class bb.common.SwapReceiverVO
equals(Object) - Method in class bb.common.SwapShipperItemPK
equals(Object) - Method in class bb.common.SwapShipperItemVO
equals(Object) - Method in class bb.common.SwapShipperVO
equals(Object) - Method in class bb.common.TaskVO
equals(Object) - Method in class bb.common.TaxAccountVO
equals(Object) - Method in class bb.common.TermsConditionVO
equals(Object) - Method in class bb.common.TermVO
equals(Object) - Method in class bb.common.ToolCalibrationVO
equals(Object) - Method in class bb.common.ToolDescriptionVO
equals(Object) - Method in class bb.common.ToolInventoryVO
equals(Object) - Method in class bb.common.ToolListInfoVO
equals(Object) - Method in class bb.common.ToolListItemVO
equals(Object) - Method in class bb.common.ToolListItemWithToolInfoResult
equals(Object) - Method in class bb.common.ToolListVO
equals(Object) - Method in class bb.common.ToolManufacturerVO
equals(Object) - Method in class bb.common.ToolOnhandVO
equals(Object) - Method in class bb.common.ToolOnhandWithAverageCostResult
equals(Object) - Method in class bb.common.ToolVendorVO
equals(Object) - Method in class bb.common.ToolVO
equals(Object) - Method in class bb.common.ToolWithOnhandsVO
equals(Object) - Method in class bb.common.TraceableCategoriesVO
equals(Object) - Method in class bb.common.TraceableSpecsVO
equals(Object) - Method in class bb.common.TransferOrderApprovalVO
equals(Object) - Method in class bb.common.TransferOrderItemPK
equals(Object) - Method in class bb.common.TransferOrderItemVO
equals(Object) - Method in class bb.common.TransferOrderVO
equals(Object) - Method in class bb.common.TransferReceiverItemPK
equals(Object) - Method in class bb.common.TransferReceiverItemVO
equals(Object) - Method in class bb.common.TransferReceiverVO
equals(Object) - Method in class bb.common.TransferShipperItemPK
equals(Object) - Method in class bb.common.TransferShipperItemVO
equals(Object) - Method in class bb.common.TransferShipperVO
equals(Object) - Method in class bb.common.UnitVO
equals(Object) - Method in class bb.common.UpdatePhysicalInventoryAgent
equals(Object) - Method in class bb.common.UserGroupVO
equals(Object) - Method in class bb.common.UserRolePK
equals(Object) - Method in class bb.common.UserRoleVO
equals(Object) - Method in class bb.common.VendorCategoriesVO
equals(Object) - Method in class bb.common.VendorContractPriceItemPK
equals(Object) - Method in class bb.common.VendorContractPriceItemVO
equals(Object) - Method in class bb.common.VendorContractPriceVendorPK
equals(Object) - Method in class bb.common.VendorContractPriceVendorVO
equals(Object) - Method in class bb.common.VendorContractPriceVO
equals(Object) - Method in class bb.common.VendorCriticalLevelVO
equals(Object) - Method in class bb.common.VendorGroupUserVO
equals(Object) - Method in class bb.common.VendorPartPK
equals(Object) - Method in class bb.common.VendorPartVO
equals(Object) - Method in class bb.common.VendorQtyPricePK
equals(Object) - Method in class bb.common.VendorQtyPriceVO
equals(Object) - Method in class bb.common.WarehouseTransferPK
equals(Object) - Method in class bb.common.WarehouseTransferVO
equals(Object) - Method in class bb.common.WarehouseVO
equals(Object) - Method in class bb.common.WeightUnitVO
equals(Object) - Method in class bb.common.WorkCalendarVO
equals(Object) - Method in class bb.common.WorkCenterAgent
equals(Object) - Method in class bb.common.WorkCenterGroupItemPK
equals(Object) - Method in class bb.common.WorkCenterGroupItemVO
equals(Object) - Method in class bb.common.WorkCenterVendorPK
equals(Object) - Method in class bb.common.WorkCenterVendorVO
equals(Object) - Method in class bb.common.WorkCenterVO
equals(Object) - Method in class bb.common.WorkInstructionApprovalVO
equals(Object) - Method in class bb.common.WorkInstructionPictureVO
equals(Object) - Method in class bb.common.WorkInstructionPK
equals(Object) - Method in class bb.common.WorkInstructionRequestForChangeVO
equals(Object) - Method in class bb.common.WorkInstructionSequencePK
equals(Object) - Method in class bb.common.WorkInstructionSequenceVO
equals(Object) - Method in class bb.common.WorkInstructionVO
equals(Object) - Method in class bb.common.WorkOrderApprovalVO
equals(Object) - Method in class bb.common.WorkOrderBoilerplateVO
equals(Object) - Method in class bb.common.WorkOrderItemAgent
equals(Object) - Method in class bb.common.WorkOrderItemIssuePK
equals(Object) - Method in class bb.common.WorkOrderItemIssueVO
equals(Object) - Method in class bb.common.WorkOrderItemPartDetailInWipVO
equals(Object) - Method in class bb.common.WorkOrderItemPK
equals(Object) - Method in class bb.common.WorkOrderItemSetupItemAgent
equals(Object) - Method in class bb.common.WorkOrderItemVO
equals(Object) - Method in class bb.common.WorkOrderReceiverVO
equals(Object) - Method in class bb.common.WorkOrderVO
equals(Object) - Method in class bb.common.WorkOrderWorkInstructionPK
equals(Object) - Method in class bb.common.WorkOrderWorkInstructionSequenceDateAgent
equals(Object) - Method in class bb.common.WorkOrderWorkInstructionSequencePK
equals(Object) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO
equals(Object) - Method in class bb.common.WorkOrderWorkInstructionVO
equals(Object) - Method in class bb.common.WorkOrderWorkItemDateAgent
equals(Object) - Method in class bb.common.WorkOrderWorkSheetItemPK
equals(Object) - Method in class bb.common.WorkOrderWorkSheetItemVO
equals(Object) - Method in class bb.common.WorkOrderWorkSheetPK
equals(Object) - Method in class bb.common.WorkOrderWorkSheetVO
equals(Object) - Method in class bb.common.WorkSheetPartAgent
equals(Object) - Method in class bb.common.ZipCodeTaxVO
equals(Object) - Method in class bb.common.ZipCodeVO
EQUIPMENT - Static variable in class bb.common.BizTarget
EQUIPMENT_ALREADY_EXIST - Static variable in class bb.common.BIZReason
EQUIPMENT_ALREADY_REF_TO_ASSET - Static variable in class bb.common.BIZReason
EQUIPMENT_ALREADY_USED_IN_WORK_CENTER - Static variable in class bb.common.BIZReason
EQUIPMENT_NOT_EXIST - Static variable in class bb.common.BIZReason
EquipmentListResult - Class in bb.common
EquipmentListResult() - Constructor for class bb.common.EquipmentListResult
EquipmentVO - Class in bb.common
EquipmentVO() - Constructor for class bb.common.EquipmentVO
EQUITY - Static variable in class bb.common.Constant.DebitOrCredit
ERP - Static variable in class bb.common.Constant.LoginType
Error - Static variable in class bb.common.Constant.Status
ERROR_GL_CAN_NOT_POST - Static variable in class bb.common.BIZReason
errorGeneralLedger(String, boolean) - Method in interface bb.common.box.AccountingBox
ET - Static variable in class bb.common.Constant.ChartOfAccountType
EW - Static variable in class bb.common.Constant.ChartOfAccountType
EXCEED_AUTHORIZED_APPROVAL_LIMIT - Static variable in class bb.common.BIZReason
EXCHANAGE_RATE - Static variable in class bb.common.BizTarget
EXCHANGE_CALCULATIONAL_LENGHT - Static variable in class bb.common.Constant
Exchange_Gain_And_Loss_Account - Static variable in class bb.common.BizTarget
EXCHANGE_RATE_IN_FISCAL_YEAR - Static variable in class bb.common.BIZReason
EXCHANGE_RATE_NOT_SETUP - Static variable in class bb.common.BIZReason
ExchangeAuditItemResult - Class in bb.common
ExchangeAuditItemResult() - Constructor for class bb.common.ExchangeAuditItemResult
ExchangeAuditResult - Class in bb.common
ExchangeAuditResult() - Constructor for class bb.common.ExchangeAuditResult
EXCHANGERATE - Static variable in class bb.common.Constant.GLApprovedType
EXCHANGERATE_APPROVED_BY_BY_CAN_NOT_BE_EMPTY - Static variable in class bb.common.BIZReason
EXCHANGERATE_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY - Static variable in class bb.common.BIZReason
execute(String, Object[], Class[]) - Method in interface bb.common.box.PurchasingBox
executeDaoMethod(String, String, Object[], Class[]) - Method in interface bb.common.box.PurchasingBox
executeSql(String) - Method in interface bb.common.box.CompanyBox
ExemptingFromInspection - Static variable in class bb.common.Constant.IRType
EXPENSE - Static variable in class bb.common.BizTarget
EXPENSE_ACCOUNT - Static variable in class bb.common.BizTarget
EXPENSE_ACCOUNT_ALREADY_EXIST - Static variable in class bb.common.BIZReason
EXPENSE_ACCOUNT_NOT_EXIST - Static variable in class bb.common.BIZReason
EXPENSE_ALREADY_EXIST - Static variable in class bb.common.BIZReason
EXPENSE_NOT_EXIST - Static variable in class bb.common.BIZReason
ExpenseAccountVO - Class in bb.common
ExpenseAccountVO() - Constructor for class bb.common.ExpenseAccountVO
ExpenseItemPK - Class in bb.common
ExpenseItemPK(String, Integer) - Constructor for class bb.common.ExpenseItemPK
full constructor
ExpenseItemPK() - Constructor for class bb.common.ExpenseItemPK
default constructor
ExpenseItemVO - Class in bb.common
ExpenseItemVO() - Constructor for class bb.common.ExpenseItemVO
default constructor
ExpenseListResult - Class in bb.common
ExpenseListResult() - Constructor for class bb.common.ExpenseListResult
ExpenseVO - Class in bb.common
ExpenseVO() - Constructor for class bb.common.ExpenseVO
exportEngSharingPart(Long) - Method in interface bb.common.box.CompanyBox
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M N O P Q R S T U V W X Y Z


EjbMethodVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EjbMethodVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.EjbMethodVO
All Implemented Interfaces:
java.io.Serializable
public class EjbMethodVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
EjbMethodVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.lang.String | getEjbName()
java.lang.Long | getMethodId()
java.lang.String | getMethodName()
int | hashCode()
void | setComments(java.lang.String comments)
void | setEjbName(java.lang.String ejbName)
void | setMethodId(java.lang.Long methodId)
void | setMethodName(java.lang.String methodName)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

EjbMethodVO

public EjbMethodVO()
default constructor

Method Detail

getMethodId

public java.lang.Long getMethodId()

setMethodId

public void setMethodId(java.lang.Long methodId)

getEjbName

public java.lang.String getEjbName()

setEjbName

public void setEjbName(java.lang.String ejbName)

getMethodName

public java.lang.String getMethodName()

setMethodName

public void setMethodName(java.lang.String methodName)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EmployeeCardVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EmployeeCardVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.EmployeeCardVO
All Implemented Interfaces:
java.io.Serializable
public class EmployeeCardVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_COMPANYADDRESSBOOKNAME
static java.lang.String | ORDER_BY_DEPARTMENT
static java.lang.String | ORDER_BY_EMAIL
static java.lang.String | ORDER_BY_EXTENSION
static java.lang.String | ORDER_BY_FAX
static java.lang.String | ORDER_BY_FIRSTNAME
static java.lang.String | ORDER_BY_HOMEPHONE
static java.lang.String | ORDER_BY_ID
static java.lang.String | ORDER_BY_LASTNAME
static java.lang.String | ORDER_BY_MOBILE
static java.lang.String | ORDER_BY_PHONE
static java.lang.String | ORDER_BY_PICTURE
static java.lang.String | ORDER_BY_POSITION
static java.lang.String | ORDER_BY_SECURITYLEVEL
static java.lang.String | ORDER_BY_STARTDATE
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_TERMINATEDDATE
static java.lang.String | ORDER_BY_USERNAME
Constructor Summary
EmployeeCardVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getADate()
java.util.Date | getBirthDate()
java.lang.String | getBirthPlace()
java.lang.String | getComments()
java.lang.String | getCompanyAddressBookName()
java.util.Date | getContractExpires()
java.lang.String | getDepartment()
java.lang.String | getEducation()
java.lang.String | getEmail()
java.lang.String | getExtension()
java.lang.String | getExtent()
java.lang.String | getFax()
java.lang.String | getFirstName()
java.lang.String | getHomePhone()
java.lang.String | getId()
java.lang.String | getIdCard()
java.lang.String | getJobId()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getLastName()
java.lang.String | getListInAddressBook()
java.lang.String | getManager()
java.lang.String | getMiddleName()
java.lang.String | getMobile()
java.lang.String | getPhone()
byte[] | getPicture()
java.lang.String | getPosition()
java.lang.String | getSecurityLevel()
java.lang.String | getShowFax()
java.lang.String | getShowHomePhone()
java.lang.String | getShowMobile()
java.lang.String | getSource()
java.util.Date | getStartDate()
java.lang.String | getStatus()
java.util.Date | getTerminatedDate()
java.util.Date | getTransferDate()
java.lang.String | getUserName()
java.lang.Integer | getVersion()
java.lang.String | getWorkAddress()
int | hashCode()
boolean | isGender()
boolean | isTempWorker()
void | setADate(java.util.Date aDate)
void | setBirthDate(java.util.Date birthDate)
void | setBirthPlace(java.lang.String birthPlace)
void | setComments(java.lang.String comments)
void | setCompanyAddressBookName(java.lang.String companyAddressBookName)
void | setContractExpires(java.util.Date contractExpires)
void | setDepartment(java.lang.String department)
void | setEducation(java.lang.String education)
void | setEmail(java.lang.String email)
void | setExtension(java.lang.String extension)
void | setExtent(java.lang.String extent)
void | setFax(java.lang.String fax)
void | setFirstName(java.lang.String firstName)
void | setGender(boolean gender)
void | setHomePhone(java.lang.String homePhone)
void | setId(java.lang.String id)
void | setIdCard(java.lang.String idCard)
void | setJobId(java.lang.String jobId)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLastName(java.lang.String lastName)
void | setListInAddressBook(java.lang.String listInAddressBook)
void | setManager(java.lang.String manager)
void | setMiddleName(java.lang.String middleName)
void | setMobile(java.lang.String mobile)
void | setPhone(java.lang.String phone)
void | setPicture(byte[] picture)
void | setPosition(java.lang.String position)
void | setSecurityLevel(java.lang.String securityLevel)
void | setShowFax(java.lang.String showFax)
void | setShowHomePhone(java.lang.String showHomePhone)
void | setShowMobile(java.lang.String showMobile)
void | setSource(java.lang.String source)
void | setStartDate(java.util.Date startDate)
void | setStatus(java.lang.String status)
void | setTempWorker(boolean tempWorker)
void | setTerminatedDate(java.util.Date terminatedDate)
void | setTransferDate(java.util.Date transferDate)
void | setUserName(java.lang.String userName)
void | setVersion(java.lang.Integer version)
void | setWorkAddress(java.lang.String workAddress)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ID

public static final java.lang.String ORDER_BY_ID
See Also:
Constant Field Values

ORDER_BY_USERNAME

public static final java.lang.String ORDER_BY_USERNAME
See Also:
Constant Field Values

ORDER_BY_LASTNAME

public static final java.lang.String ORDER_BY_LASTNAME
See Also:
Constant Field Values

ORDER_BY_FIRSTNAME

public static final java.lang.String ORDER_BY_FIRSTNAME
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_STARTDATE

public static final java.lang.String ORDER_BY_STARTDATE
See Also:
Constant Field Values

ORDER_BY_TERMINATEDDATE

public static final java.lang.String ORDER_BY_TERMINATEDDATE
See Also:
Constant Field Values

ORDER_BY_SECURITYLEVEL

public static final java.lang.String ORDER_BY_SECURITYLEVEL
See Also:
Constant Field Values

ORDER_BY_POSITION

public static final java.lang.String ORDER_BY_POSITION
See Also:
Constant Field Values

ORDER_BY_DEPARTMENT

public static final java.lang.String ORDER_BY_DEPARTMENT
See Also:
Constant Field Values

ORDER_BY_PICTURE

public static final java.lang.String ORDER_BY_PICTURE
See Also:
Constant Field Values

ORDER_BY_COMPANYADDRESSBOOKNAME

public static final java.lang.String ORDER_BY_COMPANYADDRESSBOOKNAME
See Also:
Constant Field Values

ORDER_BY_EMAIL

public static final java.lang.String ORDER_BY_EMAIL
See Also:
Constant Field Values

ORDER_BY_PHONE

public static final java.lang.String ORDER_BY_PHONE
See Also:
Constant Field Values

ORDER_BY_EXTENSION

public static final java.lang.String ORDER_BY_EXTENSION
See Also:
Constant Field Values

ORDER_BY_MOBILE

public static final java.lang.String ORDER_BY_MOBILE
See Also:
Constant Field Values

ORDER_BY_HOMEPHONE

public static final java.lang.String ORDER_BY_HOMEPHONE
See Also:
Constant Field Values

ORDER_BY_FAX

public static final java.lang.String ORDER_BY_FAX
See Also:
Constant Field Values
Constructor Detail

EmployeeCardVO

public EmployeeCardVO()
Method Detail

setId

public void setId(java.lang.String id)

getId

public java.lang.String getId()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeDate

public java.util.Date getLastChangeDate()

setVersion

public void setVersion(java.lang.Integer version)

getVersion

public java.lang.Integer getVersion()

setADate

public void setADate(java.util.Date aDate)

getADate

public java.util.Date getADate()

setUserName

public void setUserName(java.lang.String userName)

getUserName

public java.lang.String getUserName()

setLastName

public void setLastName(java.lang.String lastName)

getLastName

public java.lang.String getLastName()

setFirstName

public void setFirstName(java.lang.String firstName)

getFirstName

public java.lang.String getFirstName()

setDepartment

public void setDepartment(java.lang.String department)

getDepartment

public java.lang.String getDepartment()

setEmail

public void setEmail(java.lang.String email)

getEmail

public java.lang.String getEmail()

setExtension

public void setExtension(java.lang.String extension)

getExtension

public java.lang.String getExtension()

setExtent

public void setExtent(java.lang.String extent)

getExtent

public java.lang.String getExtent()

setJobId

public void setJobId(java.lang.String jobId)

getJobId

public java.lang.String getJobId()

setPhone

public void setPhone(java.lang.String phone)

getPhone

public java.lang.String getPhone()

setPicture

public void setPicture(byte[] picture)

getPicture

public byte[] getPicture()

setSecurityLevel

public void setSecurityLevel(java.lang.String securityLevel)

getSecurityLevel

public java.lang.String getSecurityLevel()

setStartDate

public void setStartDate(java.util.Date startDate)

getStartDate

public java.util.Date getStartDate()

setStatus

public void setStatus(java.lang.String status)

getStatus

public java.lang.String getStatus()

setWorkAddress

public void setWorkAddress(java.lang.String workAddress)

getWorkAddress

public java.lang.String getWorkAddress()

setCompanyAddressBookName

public void setCompanyAddressBookName(java.lang.String companyAddressBookName)

setFax

public void setFax(java.lang.String fax)

setIdCard

public void setIdCard(java.lang.String idCard)

setListInAddressBook

public void setListInAddressBook(java.lang.String listInAddressBook)

setManager

public void setManager(java.lang.String manager)

setMiddleName

public void setMiddleName(java.lang.String middleName)

setMobile

public void setMobile(java.lang.String mobile)

setPosition

public void setPosition(java.lang.String position)

setShowFax

public void setShowFax(java.lang.String showFax)

setShowHomePhone

public void setShowHomePhone(java.lang.String showHomePhone)

setShowMobile

public void setShowMobile(java.lang.String showMobile)

setHomePhone

public void setHomePhone(java.lang.String homePhone)

getCompanyAddressBookName

public java.lang.String getCompanyAddressBookName()

getFax

public java.lang.String getFax()

getIdCard

public java.lang.String getIdCard()

getListInAddressBook

public java.lang.String getListInAddressBook()

getManager

public java.lang.String getManager()

getMiddleName

public java.lang.String getMiddleName()

getMobile

public java.lang.String getMobile()

getPosition

public java.lang.String getPosition()

getShowFax

public java.lang.String getShowFax()

getShowHomePhone

public java.lang.String getShowHomePhone()

getShowMobile

public java.lang.String getShowMobile()

getHomePhone

public java.lang.String getHomePhone()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

isTempWorker

public boolean isTempWorker()

setTempWorker

public void setTempWorker(boolean tempWorker)

getTerminatedDate

public java.util.Date getTerminatedDate()

setTerminatedDate

public void setTerminatedDate(java.util.Date terminatedDate)

isGender

public boolean isGender()

setGender

public void setGender(boolean gender)

getBirthDate

public java.util.Date getBirthDate()

setBirthDate

public void setBirthDate(java.util.Date birthDate)

getBirthPlace

public java.lang.String getBirthPlace()

setBirthPlace

public void setBirthPlace(java.lang.String birthPlace)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getEducation

public java.lang.String getEducation()

setEducation

public void setEducation(java.lang.String education)

getSource

public java.lang.String getSource()

setSource

public void setSource(java.lang.String source)

getTransferDate

public java.util.Date getTransferDate()

setTransferDate

public void setTransferDate(java.util.Date transferDate)

getContractExpires

public java.util.Date getContractExpires()

setContractExpires

public void setContractExpires(java.util.Date contractExpires)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EmployeeEducationPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EmployeeEducationPK

java.lang.Object
    extended by  bb.common.EmployeeEducationPK
All Implemented Interfaces:
java.io.Serializable
public class EmployeeEducationPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
EmployeeEducationPK()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getEmployeeId()
java.lang.Short | getIi()
int | hashCode()
void | setEmployeeId(java.lang.String employeeId)
void | setIi(java.lang.Short ii)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

EmployeeEducationPK

public EmployeeEducationPK()
Method Detail

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getIi

public java.lang.Short getIi()

setIi

public void setIi(java.lang.Short ii)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EmployeeEducationResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EmployeeEducationResult

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.EmployeeEducationVO
            extended by  bb.common.EmployeeEducationResult
All Implemented Interfaces:
java.io.Serializable
public class EmployeeEducationResult
extends EmployeeEducationVO

See Also:
Serialized Form

Constructor Summary
EmployeeEducationResult()
Method Summary
java.lang.String | getFirstName()
java.lang.String | getLastName()
java.lang.String | getUserName()
void | setFirstName(java.lang.String firstName)
void | setLastName(java.lang.String lastName)
void | setUserName(java.lang.String userName)
Methods inherited from class bb.common.EmployeeEducationVO
getCity, getCollege, getDegree, getDescription, getFromDate, getMajor, getPk, getToDate, setCity, setCollege, setDegree, setDescription, setFromDate, setMajor, setPk, setToDate
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EmployeeEducationResult

public EmployeeEducationResult()
Method Detail

getFirstName

public java.lang.String getFirstName()

setFirstName

public void setFirstName(java.lang.String firstName)

getLastName

public java.lang.String getLastName()

setLastName

public void setLastName(java.lang.String lastName)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EmployeeEducationVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EmployeeEducationVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.EmployeeEducationVO
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
EmployeeEducationResult
public class EmployeeEducationVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
EmployeeEducationVO()
Method Summary
java.lang.String | getCity()
java.lang.String | getCollege()
java.lang.String | getDegree()
java.lang.String | getDescription()
java.util.Date | getFromDate()
java.lang.String | getMajor()
EmployeeEducationPK | getPk()
java.util.Date | getToDate()
void | setCity(java.lang.String city)
void | setCollege(java.lang.String college)
void | setDegree(java.lang.String degree)
void | setDescription(java.lang.String description)
void | setFromDate(java.util.Date fromDate)
void | setMajor(java.lang.String major)
void | setPk(EmployeeEducationPK pk)
void | setToDate(java.util.Date toDate)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EmployeeEducationVO

public EmployeeEducationVO()
Method Detail

getCity

public java.lang.String getCity()

setCity

public void setCity(java.lang.String city)

getCollege

public java.lang.String getCollege()

setCollege

public void setCollege(java.lang.String college)

getDegree

public java.lang.String getDegree()

setDegree

public void setDegree(java.lang.String degree)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getFromDate

public java.util.Date getFromDate()

setFromDate

public void setFromDate(java.util.Date fromDate)

getMajor

public java.lang.String getMajor()

setMajor

public void setMajor(java.lang.String major)

getToDate

public java.util.Date getToDate()

setToDate

public void setToDate(java.util.Date toDate)

getPk

public EmployeeEducationPK getPk()

setPk

public void setPk(EmployeeEducationPK pk)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EmployeeHomeVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EmployeeHomeVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.EmployeeHomeVO
All Implemented Interfaces:
java.io.Serializable
public class EmployeeHomeVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
EmployeeHomeVO()
Method Summary
java.lang.String | getAddressOne()
java.lang.String | getAddressTwo()
java.lang.String | getCity()
java.lang.String | getComment()
java.lang.String | getCountry()
java.lang.String | getEmergencyContact()
java.lang.String | getHomeAddress()
java.lang.String | getHomePhone()
java.lang.String | getId()
java.lang.String | getSpouseName()
java.lang.String | getState()
java.lang.String | getZip()
void | setAddressOne(java.lang.String addressOne)
void | setAddressTwo(java.lang.String addressTwo)
void | setCity(java.lang.String city)
void | setComment(java.lang.String comment)
void | setCountry(java.lang.String country)
void | setEmergencyContact(java.lang.String emergencyContact)
void | setHomeAddress(java.lang.String homeAddress)
void | setHomePhone(java.lang.String homePhone)
void | setId(java.lang.String id)
void | setSpouseName(java.lang.String spouseName)
void | setState(java.lang.String state)
void | setZip(java.lang.String zip)
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EmployeeHomeVO

public EmployeeHomeVO()
Method Detail

setId

public void setId(java.lang.String id)

getId

public java.lang.String getId()

setHomeAddress

public void setHomeAddress(java.lang.String homeAddress)

getHomeAddress

public java.lang.String getHomeAddress()

setAddressOne

public void setAddressOne(java.lang.String addressOne)

getAddressOne

public java.lang.String getAddressOne()

setAddressTwo

public void setAddressTwo(java.lang.String addressTwo)

getAddressTwo

public java.lang.String getAddressTwo()

setCity

public void setCity(java.lang.String city)

getCity

public java.lang.String getCity()

setState

public void setState(java.lang.String state)

getState

public java.lang.String getState()

setZip

public void setZip(java.lang.String zip)

getZip

public java.lang.String getZip()

setCountry

public void setCountry(java.lang.String country)

getCountry

public java.lang.String getCountry()

setSpouseName

public void setSpouseName(java.lang.String spouseName)

getSpouseName

public java.lang.String getSpouseName()

setHomePhone

public void setHomePhone(java.lang.String homePhone)

getHomePhone

public java.lang.String getHomePhone()

setEmergencyContact

public void setEmergencyContact(java.lang.String emergencyContact)

getEmergencyContact

public java.lang.String getEmergencyContact()

setComment

public void setComment(java.lang.String comment)

getComment

public java.lang.String getComment()

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EmployeeJobDescriptionVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EmployeeJobDescriptionVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.EmployeeJobDescriptionVO
All Implemented Interfaces:
java.io.Serializable
public class EmployeeJobDescriptionVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
EmployeeJobDescriptionVO()
default constructor
EmployeeJobDescriptionVO(java.lang.String id, java.lang.String description)
minimal constructor
EmployeeJobDescriptionVO(java.lang.String id, java.lang.String description, java.sql.Blob longDescription)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDescription()
java.lang.String | getId()
java.sql.Blob | getLongDescription()
int | hashCode()
void | setDescription(java.lang.String description)
void | setId(java.lang.String id)
void | setLongDescription(java.sql.Blob longDescription)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

EmployeeJobDescriptionVO

public EmployeeJobDescriptionVO(java.lang.String id,
                                java.lang.String description,
                                java.sql.Blob longDescription)
full constructor

EmployeeJobDescriptionVO

public EmployeeJobDescriptionVO()
default constructor

EmployeeJobDescriptionVO

public EmployeeJobDescriptionVO(java.lang.String id,
                                java.lang.String description)
minimal constructor

Method Detail

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getLongDescription

public java.sql.Blob getLongDescription()

setLongDescription

public void setLongDescription(java.sql.Blob longDescription)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EmployeeLaborAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EmployeeLaborAgent

java.lang.Object
    extended by  bb.common.EmployeeLaborAgent
All Implemented Interfaces:
java.io.Serializable
public class EmployeeLaborAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
EmployeeLaborAgent()
Method Summary
java.lang.String | getComments()
java.math.BigDecimal | getCost()
java.lang.String | getEmployeeId()
java.math.BigDecimal | getHours()
java.math.BigDecimal | getTotal()
java.lang.String | getWorkOrderItemNumber()
java.lang.String | getWorkOrderNumber()
void | setComments(java.lang.String comments)
void | setCost(java.math.BigDecimal cost)
void | setEmployeeId(java.lang.String employeeId)
void | setHours(java.math.BigDecimal hours)
void | setWorkOrderItemNumber(java.lang.String workOrderItemNumber)
void | setWorkOrderNumber(java.lang.String workOrderNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EmployeeLaborAgent

public EmployeeLaborAgent()
Method Detail

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getCost

public java.math.BigDecimal getCost()

setCost

public void setCost(java.math.BigDecimal cost)

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getHours

public java.math.BigDecimal getHours()

setHours

public void setHours(java.math.BigDecimal hours)

getWorkOrderItemNumber

public java.lang.String getWorkOrderItemNumber()

setWorkOrderItemNumber

public void setWorkOrderItemNumber(java.lang.String workOrderItemNumber)

getWorkOrderNumber

public java.lang.String getWorkOrderNumber()

setWorkOrderNumber

public void setWorkOrderNumber(java.lang.String workOrderNumber)

getTotal

public java.math.BigDecimal getTotal()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EmployeePutGoodListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EmployeePutGoodListResult

java.lang.Object
    extended by  bb.common.EmployeePutGoodListResult
All Implemented Interfaces:
java.io.Serializable
public class EmployeePutGoodListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_EMPLOYEEID
static java.lang.String | ORDER_BY_EMPLOYEENAME
static java.lang.String | ORDER_BY_GOODSID
static java.lang.String | ORDER_BY_GOODSNAME
static java.lang.String | ORDER_BY_JOBID
static java.lang.String | ORDER_BY_JOBNAME
static java.lang.String | ORDER_BY_PUTDATE
Constructor Summary
EmployeePutGoodListResult()
Method Summary
java.lang.String | getEmployeeId()
java.lang.String | getEmployeeName()
java.lang.String | getGoodsId()
java.lang.String | getGoodsName()
java.lang.String | getJobId()
java.lang.String | getJobName()
java.util.Date | getPutDate()
void | setEmployeeId(java.lang.String employeeId)
void | setEmployeeName(java.lang.String employeeName)
void | setGoodsId(java.lang.String goodsId)
void | setGoodsName(java.lang.String goodsName)
void | setJobId(java.lang.String jobId)
void | setJobName(java.lang.String jobName)
void | setPutDate(java.util.Date putDate)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_EMPLOYEEID

public static final java.lang.String ORDER_BY_EMPLOYEEID
See Also:
Constant Field Values

ORDER_BY_EMPLOYEENAME

public static final java.lang.String ORDER_BY_EMPLOYEENAME
See Also:
Constant Field Values

ORDER_BY_JOBID

public static final java.lang.String ORDER_BY_JOBID
See Also:
Constant Field Values

ORDER_BY_JOBNAME

public static final java.lang.String ORDER_BY_JOBNAME
See Also:
Constant Field Values

ORDER_BY_GOODSID

public static final java.lang.String ORDER_BY_GOODSID
See Also:
Constant Field Values

ORDER_BY_GOODSNAME

public static final java.lang.String ORDER_BY_GOODSNAME
See Also:
Constant Field Values

ORDER_BY_PUTDATE

public static final java.lang.String ORDER_BY_PUTDATE
See Also:
Constant Field Values
Constructor Detail

EmployeePutGoodListResult

public EmployeePutGoodListResult()
Method Detail

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getEmployeeName

public java.lang.String getEmployeeName()

setEmployeeName

public void setEmployeeName(java.lang.String employeeName)

getGoodsId

public java.lang.String getGoodsId()

setGoodsId

public void setGoodsId(java.lang.String goodsId)

getGoodsName

public java.lang.String getGoodsName()

setGoodsName

public void setGoodsName(java.lang.String goodsName)

getJobId

public java.lang.String getJobId()

setJobId

public void setJobId(java.lang.String jobId)

getJobName

public java.lang.String getJobName()

setJobName

public void setJobName(java.lang.String jobName)

getPutDate

public java.util.Date getPutDate()

setPutDate

public void setPutDate(java.util.Date putDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EmployeeRecordsVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EmployeeRecordsVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.EmployeeRecordsVO
All Implemented Interfaces:
java.io.Serializable
public class EmployeeRecordsVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_DOCNAME
static java.lang.String | ORDER_BY_EMPLOYEEID
static java.lang.String | ORDER_BY_II
Constructor Summary
EmployeeRecordsVO()
Method Summary
java.lang.String | getComments()
java.util.Date | getDate()
java.lang.String | getDescription()
long | getDocLength()
java.lang.String | getDocName()
java.lang.String | getEmployeeId()
java.lang.String | getExtension()
java.lang.Long | getIi()
java.lang.String | getRecordType()
void | setComments(java.lang.String comments)
void | setDate(java.util.Date date)
void | setDescription(java.lang.String description)
void | setDocLength(long docLength)
void | setDocName(java.lang.String docName)
void | setEmployeeId(java.lang.String employeeId)
void | setExtension(java.lang.String extension)
void | setIi(java.lang.Long ii)
void | setRecordType(java.lang.String recordType)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_II

public static final java.lang.String ORDER_BY_II
See Also:
Constant Field Values

ORDER_BY_EMPLOYEEID

public static final java.lang.String ORDER_BY_EMPLOYEEID
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_DOCNAME

public static final java.lang.String ORDER_BY_DOCNAME
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values
Constructor Detail

EmployeeRecordsVO

public EmployeeRecordsVO()
Method Detail

setDescription

public void setDescription(java.lang.String description)

getDescription

public java.lang.String getDescription()

setComments

public void setComments(java.lang.String comments)

getComments

public java.lang.String getComments()

setExtension

public void setExtension(java.lang.String extension)

getExtension

public java.lang.String getExtension()

setDate

public void setDate(java.util.Date date)

getDate

public java.util.Date getDate()

getDocName

public java.lang.String getDocName()

setDocName

public void setDocName(java.lang.String docName)

getDocLength

public long getDocLength()

setDocLength

public void setDocLength(long docLength)

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getRecordType

public java.lang.String getRecordType()

setRecordType

public void setRecordType(java.lang.String recordType)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EmployeeTimeCardResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EmployeeTimeCardResult

java.lang.Object
    extended by  bb.common.EmployeeTimeCardResult
All Implemented Interfaces:
java.io.Serializable
public class EmployeeTimeCardResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
EmployeeTimeCardResult()
Method Summary
java.lang.String | getEmployeeId()
java.lang.String | getEmployeeName()
java.util.List<WorkOrderTimeCardVO> | getTimeCards()
void | setEmployeeId(java.lang.String employeeId)
void | setEmployeeName(java.lang.String employeeName)
void | setTimeCards(java.util.List<WorkOrderTimeCardVO> timeCards)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EmployeeTimeCardResult

public EmployeeTimeCardResult()
Method Detail

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getEmployeeName

public java.lang.String getEmployeeName()

setEmployeeName

public void setEmployeeName(java.lang.String employeeName)

getTimeCards

public java.util.List<WorkOrderTimeCardVO> getTimeCards()

setTimeCards

public void setTimeCards(java.util.List<WorkOrderTimeCardVO> timeCards)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EmployeeTrainingVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EmployeeTrainingVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.EmployeeTrainingVO
All Implemented Interfaces:
java.io.Serializable
public class EmployeeTrainingVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
EmployeeTrainingVO()
Method Summary
java.lang.String | getCertiName()
java.lang.String | getCertiNumber()
java.util.Date | getExpireDate()
EmployeeWorkExperiencePK | getPk()
java.lang.String | getPlace()
java.lang.String | getRecorder()
java.lang.String | getResult()
java.lang.String | getSpeaker()
java.lang.String | getTitle()
java.util.Date | getTrainDate()
void | setCertiName(java.lang.String certiName)
void | setCertiNumber(java.lang.String certiNumber)
void | setExpireDate(java.util.Date expireDate)
void | setPk(EmployeeWorkExperiencePK pk)
void | setPlace(java.lang.String place)
void | setRecorder(java.lang.String recorder)
void | setResult(java.lang.String result)
void | setSpeaker(java.lang.String speaker)
void | setTitle(java.lang.String title)
void | setTrainDate(java.util.Date trainDate)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EmployeeTrainingVO

public EmployeeTrainingVO()
Method Detail

getCertiName

public java.lang.String getCertiName()

setCertiName

public void setCertiName(java.lang.String certiName)

getCertiNumber

public java.lang.String getCertiNumber()

setCertiNumber

public void setCertiNumber(java.lang.String certiNumber)

getExpireDate

public java.util.Date getExpireDate()

setExpireDate

public void setExpireDate(java.util.Date expireDate)

getPk

public EmployeeWorkExperiencePK getPk()

setPk

public void setPk(EmployeeWorkExperiencePK pk)

getPlace

public java.lang.String getPlace()

setPlace

public void setPlace(java.lang.String place)

getRecorder

public java.lang.String getRecorder()

setRecorder

public void setRecorder(java.lang.String recorder)

getResult

public java.lang.String getResult()

setResult

public void setResult(java.lang.String result)

getSpeaker

public java.lang.String getSpeaker()

setSpeaker

public void setSpeaker(java.lang.String speaker)

getTitle

public java.lang.String getTitle()

setTitle

public void setTitle(java.lang.String title)

getTrainDate

public java.util.Date getTrainDate()

setTrainDate

public void setTrainDate(java.util.Date trainDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EmployeeWorkExperiencePK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EmployeeWorkExperiencePK

java.lang.Object
    extended by  bb.common.EmployeeWorkExperiencePK
All Implemented Interfaces:
java.io.Serializable
public class EmployeeWorkExperiencePK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
EmployeeWorkExperiencePK()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getEmployeeId()
java.lang.Short | getIi()
int | hashCode()
void | setEmployeeId(java.lang.String employeeId)
void | setIi(java.lang.Short ii)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

EmployeeWorkExperiencePK

public EmployeeWorkExperiencePK()
Method Detail

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getIi

public java.lang.Short getIi()

setIi

public void setIi(java.lang.Short ii)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EmployeeWorkExperienceVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EmployeeWorkExperienceVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.EmployeeWorkExperienceVO
All Implemented Interfaces:
java.io.Serializable
public class EmployeeWorkExperienceVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
EmployeeWorkExperienceVO()
Method Summary
java.lang.String | getAuthenticator()
java.lang.String | getCompanyName()
java.lang.String | getDescription()
java.util.Date | getFromDate()
java.lang.String | getJobTitle()
java.lang.String | getLocation()
EmployeeWorkExperiencePK | getPk()
java.util.Date | getToDate()
void | setAuthenticator(java.lang.String authenticator)
void | setCompanyName(java.lang.String companyName)
void | setDescription(java.lang.String description)
void | setFromDate(java.util.Date fromDate)
void | setJobTitle(java.lang.String jobTitle)
void | setLocation(java.lang.String location)
void | setPk(EmployeeWorkExperiencePK pk)
void | setToDate(java.util.Date toDate)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EmployeeWorkExperienceVO

public EmployeeWorkExperienceVO()
Method Detail

getCompanyName

public java.lang.String getCompanyName()

setCompanyName

public void setCompanyName(java.lang.String companyName)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getFromDate

public java.util.Date getFromDate()

setFromDate

public void setFromDate(java.util.Date fromDate)

getPk

public EmployeeWorkExperiencePK getPk()

setPk

public void setPk(EmployeeWorkExperiencePK pk)

getJobTitle

public java.lang.String getJobTitle()

setJobTitle

public void setJobTitle(java.lang.String jobTitle)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getToDate

public java.util.Date getToDate()

setToDate

public void setToDate(java.util.Date toDate)

getAuthenticator

public java.lang.String getAuthenticator()

setAuthenticator

public void setAuthenticator(java.lang.String authenticator)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EngGroupUserPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EngGroupUserPK

java.lang.Object
    extended by  bb.common.EngGroupUserPK
All Implemented Interfaces:
java.io.Serializable
public class EngGroupUserPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
EngGroupUserPK()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getEmpId()
java.lang.String | getEngGroupId()
int | hashCode()
void | setEmpId(java.lang.String empId)
void | setEngGroupId(java.lang.String engGroupId)
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EngGroupUserPK

public EngGroupUserPK()
Method Detail

getEmpId

public java.lang.String getEmpId()

setEmpId

public void setEmpId(java.lang.String empId)

getEngGroupId

public java.lang.String getEngGroupId()

setEngGroupId

public void setEngGroupId(java.lang.String engGroupId)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EngGroupUserVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EngGroupUserVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.EngGroupUserVO
All Implemented Interfaces:
java.io.Serializable
public class EngGroupUserVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_PK
static java.lang.String | ORDER_BY_USERNAME
Constructor Summary
EngGroupUserVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
EngGroupUserPK | getPk()
java.lang.String | getUserName()
void | setComments(java.lang.String comments)
void | setPk(EngGroupUserPK pk)
void | setUserName(java.lang.String userName)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PK

public static final java.lang.String ORDER_BY_PK
See Also:
Constant Field Values

ORDER_BY_USERNAME

public static final java.lang.String ORDER_BY_USERNAME
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values
Constructor Detail

EngGroupUserVO

public EngGroupUserVO()
Method Detail

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getPk

public EngGroupUserPK getPk()

setPk

public void setPk(EngGroupUserPK pk)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EngGroupVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EngGroupVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.EngGroupVO
All Implemented Interfaces:
java.io.Serializable
public class EngGroupVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ID
static java.lang.String | ORDER_BY_NAME
static java.lang.String | ORDER_BY_PARENTID
Constructor Summary
EngGroupVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getId()
java.lang.String | getName()
java.lang.String | getParentId()
int | hashCode()
void | setId(java.lang.String id)
void | setName(java.lang.String name)
void | setParentId(java.lang.String parentId)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ID

public static final java.lang.String ORDER_BY_ID
See Also:
Constant Field Values

ORDER_BY_PARENTID

public static final java.lang.String ORDER_BY_PARENTID
See Also:
Constant Field Values

ORDER_BY_NAME

public static final java.lang.String ORDER_BY_NAME
See Also:
Constant Field Values
Constructor Detail

EngGroupVO

public EngGroupVO()
Method Detail

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getParentId

public java.lang.String getParentId()

setParentId

public void setParentId(java.lang.String parentId)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EngineeringBox

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common.box
Interface EngineeringBox

public interface EngineeringBox

Method Summary
BillVO | addBill(BillVO billVO) **************above are EngineeringChange, below about Bill and BillItem
void | addBillItem(BillItemVO itemVO)
BomApprovalVO | addBomApproval(java.lang.String employeeId)
DesignControlVO | addDC(DesignControlVO vo)
ECNReviewVO | addECNControl(java.lang.String employeeId)
ECRReviewVO | addECRControl(java.lang.String employeeId)
EngineeringChangeRequestVO | addECRequest(EngineeringChangeRequestVO ecRequestVO)
EngGroupVO | addEngGroup(EngGroupVO vo)
EngGroupUserVO | addEngGroupUser(EngGroupUserVO vo)
EngineeringChangeVO | addEngineeringChange(EngineeringChangeVO engChangeVO)
EngineeringSharingVO | addEngineeringSharing(EngineeringSharingVO vo)
EngineeringSharingItemVO | addEngineeringSharingItem(EngineeringSharingItemVO vo)
void | addEngineeringSharingItems(java.util.ArrayList<PartPK> pks, java.lang.String id)
void | addEngineeringSharingItemsByPart(java.lang.String fPn, java.lang.String tPn, java.lang.String pType, java.lang.String addressId, java.lang.String engGroup)
PartPK | addPart(PartVO vo)
PartCatagoryVO | addPartCatagory(PartCatagoryVO vo)
PartMaterialVO | addPartMaterial(PartPK partPk)
void | addPartPicture(PartPictureVO vo)
PartSecurityLevelVO | addPartSecurityLevel(PartSecurityLevelVO vo)
PartTraceableCategoryVO | addPartTraceableCategory(PartTraceableCategoryVO partTraceableCategoryVO)
PartTraceableSpecVO | addPartTraceableSpec(PartTraceableSpecVO partTraceableSpecVO)
PartVendorVO | addPartVendor(PartVendorVO vo)
TraceableCategoriesVO | addTraceableCategories(TraceableCategoriesVO traceableCategoriesVO) Traceable****************************************************************
TraceableSpecsVO | addTraceableSpecs(TraceableSpecsVO traceableSpecsVO)
UnitVO | addUnit(UnitVO vo)
void | addVendorQtyPrice(VendorQtyPriceVO vo)
BillVO | approvalBill(BillVO billVO)
EngineeringChangeRequestVO | approvedECR(java.lang.String ecrNumber)
EngineeringChangeVO | approveEngineeringChange(java.lang.String ecNumber)
void | auditPartBomFlag(java.util.HashSet<PartPK> partPKs)
void | auditPartDwgFlag(java.util.HashSet<BB2Part> bb2Parts)
void | auditPartPictureFlag(java.util.HashSet<PartPK> partPKs)
void | auditPartWIFlag(java.util.HashSet<PartPK> partPKs)
void | batchUpdatePartsEngGroup(java.lang.String partNumber, java.lang.String partType, java.lang.String engGroup, java.lang.String newEngGroup)
void | batchUpdatePartsListPrice(java.math.BigDecimal listPricePercent, java.lang.String commodityCodeLike)
void | batchUpdatePartWithOnhands(java.util.Map<PartPK,java.util.HashSet<PartOnhandVO>> allPartWithOnhands)
BillPK | copyBill(BillPK fpk, BillPK tpk)
java.lang.String | copyEcrToEcn(java.lang.String ecrNumber)
PartVO | copyPart(PartPK pk, java.lang.String rev, java.lang.String partUnit, java.lang.String description, PartPK oldPk, boolean onlyChangeParType)
PartMaterialVO | copyPartMaterial(PartPK partPk, PartMaterialVO vo)
void | deleteBill(BillVO billVO)
void | deleteBillItem(BillItemVO billItemVO)
void | deleteBillWithoutItems(java.util.ArrayList<BillPK> set)
void | deleteBomApproval(java.lang.String employeeId)
void | deletedBatchEngineeringSharingItem(java.util.ArrayList<EngineeringSharingItemPK> pkList)
void | deleteDc(DesignControlVO vo)
java.util.Collection<DesignControlDocumentVO> | deleteDCDoc(MiscDocAgent agent)
void | deletedEngineeringSharing(java.lang.String addressId)
void | deletedEngineeringSharingItem(EngineeringSharingItemPK pk)
void | deleteECNControl(java.lang.String employeeId)
void | deleteECRControl(java.lang.String employeeId)
void | deleteECRequest(EngineeringChangeRequestVO ecRequestVO)
void | deleteEngGroup(java.lang.String id)
void | deleteEngGroupUser(EngGroupUserPK pk)
void | deleteEngineeringChange(EngineeringChangeVO engChange)
void | deleteEngineeringSharingItemByCompanyId(java.lang.String addressId)
void | deleteFtpDWF(PartDwfAgent agent)
void | deleteFtpDWG(PartDwgAgent agent)
java.util.Collection<EngineeringChangeDocumentVO> | deleteFTPECDoc(MiscDocAgent agent)
java.util.Collection<EngineeringChangeRequestDocumentVO> | deleteFTPECRDoc(MiscDocAgent agent)
void | deletePartCatagory(PartCatagoryPK pk)
void | deletePartCatagory(java.lang.String bigCatagory)
void | deletePartMaterial(PartPK partPk)
void | deletePartPicture(java.lang.Long ii)
void | deletePartPicture(MiscDocAgent agent)
void | deletePartSecurityLevel(java.lang.String levelId)
void | deletePartTraceable(PartPK pk)
void | deletePartTraceableCategories(PartPK partPk)
void | deletePartTraceableCategory(PartTraceableCategoryVO partTraceableCategoryVO)
void | deletePartTraceableSpec(PartTraceableSpecPK pk)
void | deletePartTraceableSpec(PartTraceableSpecVO partTraceableSpecVO)
void | deletePartTraceableSpecs(PartPK partPk)
void | deleteTraceableCategories(java.lang.String categoryId)
void | deleteTraceableCategories(TraceableCategoriesVO traceableCategoriesVO)
void | deleteTraceableSpecs(java.lang.Short specId)
void | deleteTraceableSpecs(TraceableSpecsVO traceableSpecsVO)
void | deleteUnit(UnitVO vo)
void | deleteVendorQtyPrice(VendorQtyPricePK pk)
void | deleteVendorQtyPrices(BB2Part pk, java.lang.String vendorId)
java.util.Collection<BB2Picture> | downloadAllPartPictureByPk(MiscDocAgent agent)
byte[] | downloadDCDoc(MiscDocAgent agent)
void | downLoadDWG(java.lang.String log)
byte[] | downloadFtpDWF(PartDwfAgent agent)
byte[] | downloadFtpDWFForView(PartDwfAgent agent)
byte[] | downloadFTPECDoc(MiscDocAgent agent)
byte[] | downloadFTPECRDoc(MiscDocAgent agent)
BB2Picture | downloadMainPartPicture(MiscDocAgent agent)
java.util.Collection<java.lang.String> | findAllBigCatagorys()
java.util.Collection<BillWithPartInfoResult> | findAllBillsWithPartInfo(java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<BomApprovalVO> | findAllBomApprovals(int firstIndex, int maxLength)
java.util.Collection<PartOnHandWithMfgInfoResult> | findAllBomItems(java.lang.String[] billNumbers, java.lang.String billType, int firstIndex, int maxLength)
java.util.Collection<BillOnHandWithPartInfoResult> | findAllBomsToDelete(int firstIndex, int maxLength)
java.util.Collection<ECNReviewVO> | findAllECNControl(int firstIndex, int maxLength)
java.util.Collection<ECRReviewVO> | findAllECRControl(int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeRequestListResult> | findAllECRequests(java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngGroupVO> | findAllEngGroup(int firstIndex, int maxLength)
java.util.Collection<java.lang.String> | findAllEngGroupId()
java.util.Collection<java.lang.String> | findAllEngGroupId(boolean containImport)
java.util.Collection<EngineeringChangeListResult> | findAllEngineeringChanges(java.lang.String languageFlag, int firstIndex, int maxLength)
java.util.Collection<PartCatagoryVO> | findAllPartCatagorys()
java.util.Collection<BB2DoubleString> | findAllPartNumbers()
java.util.Collection<BB2DoubleString> | findAllPartNumbers(java.lang.String language, java.lang.String partType)
java.util.Collection<PartBasicInfo> | findAllParts(int firstIndex, int maxLength)
java.util.Collection<PartSecurityLevelVO> | findAllPartSecurityLevel(int firstIndex, int maxLength)
java.util.Collection<PartOnHandWithPartBasicInfoResult> | findAllPartsToDelete(int firstIndex, int maxLength)
java.util.Collection<PartOnHandWithPartBasicInfoResult> | findAllPartsWithOnhandInfo(java.lang.String partNumber, java.lang.String partDescription, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<PartOnHandWithPartBasicInfoResult> | findAllPartsWithOnhandInfo(java.lang.String fPn, java.lang.String tPn, java.lang.String partType, java.lang.String descLike, java.lang.String modelNumLike, java.lang.String commodityCodeLike, java.lang.String productCodeLike, java.lang.String language, java.lang.String makeBuy, boolean posOnhand, boolean onlyShowFlushMaterial, int firstIndex, int maxLength)
java.util.Collection<java.lang.String> | findAllSmallCatagorys(java.lang.String bigCatagory)
java.util.Collection<TraceableCategoriesVO> | findAllTraceableCategories(int firstIndex, int maxLength)
java.util.Collection<TraceableSpecsVO> | findAllTraceableSpecs(int firstIndex, int maxLength)
java.util.Collection<BillItemOnHandWithPartInfoResult> | findBillItemOnHandWithPartInfoByBillPk(BillPK billPk, java.lang.String languageCode, boolean needOnhandLocation, java.lang.String locationPrefix)
java.util.Collection<BillItemWithPartInfoResult> | findBillItemWithPartInfoByBillPk(BillPK billPk, java.lang.String languageCode, boolean needMfg)
java.util.Collection<BillItemWithPartInfoResult> | findBillItemWithPartInfoByBillPk(BillPK billPk, java.lang.String languageCode, boolean needMfg, int firstIndex, int maxLength)
java.util.Collection<BillLogVO> | findBillLog(java.lang.String billNumber, java.lang.String billType, java.lang.String userName, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<BillWithPartInfoResult> | findBillswithPartInfoByBillNumberLike(boolean dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String bnRegex, java.lang.String billType, java.lang.String languageCode, boolean isPFEP, java.lang.String lastChangeUser, java.lang.String origin, java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<DesignControlListResult> | findDCsByDcNumber(java.lang.String dc, int firstIndex, int maxLength)
java.util.Collection<DesignControlListResult> | findDCsByEngineerNameLike(java.lang.String engineerNameLike, int firstIndex, int maxLength)
java.util.Collection<DesignControlListResult> | findDCsByPartLike(java.lang.String pnRegex, java.lang.String partType, java.lang.String projectDescription, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeRequestListResult> | findDueECRequest(java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | findDueEngineerningChange(java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<PartDwfWithPartInfoResult> | findDwfDrawingByPartPk(PartPK pk, java.lang.String partFrom, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | findEcnByConditions(java.lang.String ecNumberLike, java.lang.String partNumber, java.lang.String partType, java.lang.String originator, java.lang.String status, java.lang.String languageCode, java.lang.String importECN, java.lang.String importCompanyId, java.lang.String ecnDescription, java.lang.String dateType, java.util.Date dateFrom, java.util.Date dateTo, int firstIndex, int maxLength)
java.util.Collection<ECNReviewVO> | findECNControlByUserName(java.lang.String userNameLike, int firstIndex, int maxLength)
java.util.Collection<ECRReviewVO> | findECRControlByUserName(java.lang.String userNameLike, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeRequestListResult> | findECRequestByEcrNumberLike(java.lang.String ecrNumberLike, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeRequestListResult> | findECRequestByPartLike(java.lang.String pnRegex, java.lang.String partType, java.lang.String languageCode, java.lang.String description, java.lang.String disposition, java.lang.String notes, java.lang.String status, java.lang.String ecrPriority, java.lang.String originator, int firstIndex, int maxLength)
java.util.Collection<EngGroupVO> | findEngGroupListById(java.lang.String id, int firstIndex, int maxLength)
java.util.Collection<EngGroupUserVO> | findEngGroupUserByEmployeeId(java.lang.String engGroupId, java.lang.String empId, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | findEngineeringChangeByEcnNumberLike(java.lang.String ecRegex, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | findEngineeringChangeByPartLike(java.lang.String pnRegex, java.lang.String partType, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | findEngineeringChangeByPartPk(PartPK partPk, java.lang.String languageFlag, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | findEngineeringChangeByStatus(java.lang.String status, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngineeringSharingImportLogVO> | findEngineeringSharingImportLogs(java.lang.String partNumber, java.lang.String partType, java.util.Date startDate, java.util.Date endDate, java.lang.String status, java.lang.String importType, java.lang.String importDataType, java.lang.String ecnNumber, int firstIndex, int maxLength)
java.util.Collection<EngineeringSharingItemVO> | findEngineeringSharingItemByCompanyId(java.lang.String addressId, java.lang.String partNumber, java.lang.String partType, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngineeringSharingVO> | findEngineeringSharingsByCompanyId(java.lang.String companyId, int firstIndex, int maxLength)
java.util.Collection<EngineeringSharingVO> | findEngineeringSharingsByCompanyName(java.lang.String companyName, int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | findEngSharingPartsByPnAndEngGroup(java.lang.String partFrom, java.lang.String partTo, java.lang.String partType, java.lang.String engGroup, int firstIndex, int maxLength)
java.util.Collection<PartOnHandWithPartBasicInfoResult> | findInBillPartsWithOnhandInfo(java.lang.String partNumber, java.lang.String partDescription, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<PartDwfWithPartInfoResult> | findMismatchedPartDrawingWithPartInfoResults(java.lang.String partFrom, int firstIndex, int maxLength)
java.util.Collection<PartOnHandWithPartBasicInfoResult> | findNotBillPartsWithOnhandInfo(java.lang.String partNumber, java.lang.String partDescription, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<DesignControlListResult> | findOpenDCs(int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeRequestListResult> | findOpenECRequest(java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | findOpenEngineeringChange(java.lang.String languageCode, int firstIndex, int maxLength)
PartVO | findPart(PartPK pk)
java.util.Collection<PartBasicInfo> | findPartBasicInfoToRollUP(java.lang.String bill, int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | findPartBasicInfoToRollUP(java.lang.String bill, java.lang.String bnType, int firstIndex, int maxLength)
java.util.Collection<PartDwfWithPartInfoResult> | findPartDwf(java.lang.String pnLike, java.lang.String partType, java.lang.String partFrom, java.lang.String description, boolean onlyShowMissmatchedDWF, int firstIndex, int maxLength)
java.util.Collection<PartDwfWithPartInfoResult> | findPartDwfFullMatch(java.lang.String pnLike, java.lang.String partType, java.lang.String partFrom, java.lang.String description, boolean onlyShowMissmatchedDWF, int firstIndex, int maxLength)
java.util.Collection<LogPartDwfVO> | findPartDwfLog(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String action, java.lang.String operator, java.lang.String wanIp, java.lang.String lanIp, java.lang.String macAddress, java.lang.String description, java.util.Date dateFrom, java.util.Date dateTo, int firstIndex, int maxLength)
java.util.Collection<PartDwgWithPartInfoResult> | findPartDwg(java.lang.String pnLike, java.lang.String partType, java.lang.String partFrom, java.lang.String description, int firstIndex, int maxLength)
java.util.Collection<LogPartDwgVO> | findPartDwgLog(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String action, java.lang.String operator, java.lang.String wanIp, java.lang.String lanIp, java.lang.String macAddress, java.lang.String description, java.util.Date dateFrom, java.util.Date dateTo, int firstIndex, int maxLength)
java.util.Collection<PartManufacturerVO> | findPartManufacturersByPartPk(PartPK partPk)
java.util.Collection<PartMaterialListResult> | findPartMaterial(PartMaterialReportAgent agent, int firstIndex, int maxLength)
java.util.Collection<PartMaterialBomListResult> | findPartMaterialBomListResults(java.lang.String billNumber, java.lang.String billType, int firstIndex, int maxLength)
java.util.Collection<PartMaterialListResult> | findPartMaterialByPartLike(PartPK partPk, int firstIndex, int maxLength)
java.util.List<PartVO> | findPartPKByMpn(java.lang.String mpn)
java.util.Collection<PartVO> | findPartPKByPartNumber(java.lang.String partNumber)
java.util.Collection<PartBasicInfo> | findPartsByDescriptionAndLang(java.lang.String[] descLike, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | findPartsByDescriptionInside(java.lang.String pnRegex, java.lang.String partType, java.lang.String edRegex, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | findPartsByDescriptionStart(java.lang.String edRegex, int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | findPartsByEngineeringSharingRule(java.lang.String companyId, int firstIndex, int maxLength)
java.util.Collection<PartWithManufacturerInfoResult> | findPartsByManufacturerId(java.lang.String mfgIdRegex, int firstIndex, int maxLength)
java.util.Collection<PartWithManufacturerInfoResult> | findPartsByManufacturerPn(java.lang.String mpnRegex, int firstIndex, int maxLength)
java.util.Collection<PartWithManufacturerInfoResult> | findPartsByManufacturerPnStartWith(java.lang.String mpnRegex, int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | findPartsByPartAndDesc(java.lang.String fPn, java.lang.String tPn, java.lang.String pType, java.lang.String descriptionRegex, java.lang.String modelNumberLike, java.lang.String commodityCode, java.lang.String productCode, java.lang.String language, java.lang.String engGroup, java.lang.String securityLevel, java.lang.String makebuy, int firstIndex, int maxLength)
java.util.Collection<PartBasicInfoWithNewListPrice> | findPartsByPartCommodityCode(java.math.BigDecimal listPricePercent, java.lang.String commodityCodeLike, int firstIndex, int maxLength)
java.util.Collection<PartBasicInfoWithNewEngGroup> | findPartsByPartEngGroup(java.lang.String partNumber, java.lang.String partType, java.lang.String engGroup, java.lang.String newEngGroup, int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | findPartsByPartLike(java.lang.String pnRegex, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<PartVO> | findPartsByPK(PartPK pk, int firstIndex, int maxLength)
java.util.Collection<PartSecurityLevelVO> | findPartSecurityLevelById(java.lang.String levelId, int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | findPartsOnHold(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | findPartsToDeleteInPo(int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | findPartsToDeleteInSo(int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemPartDetail> | findPartsToDeleteInWoItemDetail(int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | findPartsWithBom(int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | findPartsWithDeleted(int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | findPartsWithDrawing(int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | findPartsWithWi(int firstIndex, int maxLength)
PartTraceableInfoResult | findPartTraceableByPk(PartPK pk)
java.util.Collection<PartTraceableListResult> | findPartTraceableListResults(java.lang.String partNumber, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<PartVendorVO> | findPartVendorsByPartPk(PartPK partPk)
PartWhereUsedResult | findPartWhereIsUsed(PartPK pk)
java.util.Collection<DesignControlListResult> | findPastDueDCs(int firstIndex, int maxLength)
java.util.Collection<BillItemSalesCostResult> | findSalesBillItemWithPartInfoByBillPk(BillPK billPk, java.lang.String languageCode, boolean needMfg)
java.util.Collection<PartTraceableResult> | findTraceableCategoriesByPart(java.lang.String partNumber, java.lang.String partType, int traceableLevel, java.lang.String[] categoryIds, java.lang.Short[] specificationIds, int firstIndex, int maxLength)
java.util.Collection<UnitVO> | findUnit(java.lang.String unitName, int firstIndex, int maxLength)
int | getAllBillsWithPartInfoCount()
int | getAllBomApprovalsCount()
int | getAllBomItemsCount(java.lang.String[] billNumbers, java.lang.String billType)
int | getAllBomsToDeleteCount()
int | getAllDCsCount()
int | getAllECNControlCount()
int | getAllECRControlCount()
int | getAllECRequestsCount()
int | getAllEngGroupCount()
int | getAllEngineeringChangesCount()
int | getAllPartsCount()
int | getAllPartSecurityLevelCount()
int | getAllPartsToDeleteCount()
int | getAllPartsWithOnhandInfoCount(java.lang.String partNumber, java.lang.String partDescription, java.lang.String partType)
int | getAllPartsWithOnhandInfoCount(java.lang.String fPn, java.lang.String tPn, java.lang.String partType, java.lang.String descLike, java.lang.String modelNumLike, java.lang.String commodityCodeLike, java.lang.String productCodeLike, java.lang.String language, java.lang.String makeBuy, boolean onlyShowFlushMaterial)
int | getAllTraceableCategoriesCount()
int | getAllTraceableSpecsCount()
java.lang.String | getBB2PartDescription(BB2Part part, java.lang.String language)
BillVO | getBill(BillPK billPk)
BillDetailCostResult | getBillDetailCostResult(BillPK billPk, java.lang.String languageCode)
int | getBillItemCount(BillPK billPk)
java.util.Collection<BillItemOnHandUsageResult> | getBillItemOnHandUsageResults(BillPK pk)
BillItemOnHandWithPartInfoResult | getBillItemOnHandWithPartInfoByBillItemPk(BillItemPK billItemPk, java.lang.String languageCode)
BillItemVO | getBillItems(BillItemPK itemPk)
java.util.Collection<BillItemUsageResult> | getBillItemUsageResults(BillPK pk)
java.util.Collection<BillItemUsageResult> | getBillItemUsageResultsWitCost(BillPK pk)
BillItemWithPartInfoResult | getBillItemWithPartInfoByBillItemPk(BillItemPK billItemPk, java.lang.String languageCode)
int | getBillLogCount(java.lang.String billNumber, java.lang.String billType, java.lang.String userName, java.util.Date fromDate, java.util.Date toDate)
BillOnHandWithPartInfoResult | getBillOnHandWithPartInfoResultByBillPk(BillPK billPk, java.lang.String languageCode, java.lang.String locationPrefix)
java.util.Collection<BillPK> | getBillPKsToRollUP(java.lang.String bill, boolean root)
BillSalesResult | getBillSalesResult(BillPK pk)
BillSalesXResult | getBillSalesXResult(BillPK pk, java.lang.String languageCode)
int | getBillsCountByBillNumberLike(boolean dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String bnRegex, java.lang.String billType, boolean isPFEP, java.lang.String lastChangeUser, java.lang.String origin, java.lang.String status)
BillWhereUsedResult | getBillWhereUsedResult(PartPK pk, BillPK billPk)
java.util.Collection<BillWhereUsedResult> | getBillWhereUsedResults(java.util.ArrayList<PartPK> pkList, BillPK billPk)
java.util.Collection<BillWithPartInfoResult> | getBillWithoutItems(java.lang.String pnLike)
BillWithPartInfoResult | getBillWithPartInfoByBillPk(BillPK billPk, java.lang.String languageCode)
BomApprovalVO | getBomApprovalByEmployeeId(java.lang.String employeeId)
BomWithOEMResult | getBomWithOEMResult(BillPK pk, java.lang.String mfgId)
DesignControlVO | getDCByDcNumber(java.lang.String dcNumber)
int | getDCCountByDcNumber(java.lang.String dcNumberRegex)
int | getDCCountByEngineerNameLike(java.lang.String engineerNameLike)
int | getDCCountByPartLike(java.lang.String pnRegex, java.lang.String partType, java.lang.String projectDescription)
DesignControlDocumentVO | getDCDocByPk(java.lang.Long pk)
int | getDueECRequestsCount()
int | getDueEngineeringChangesCount()
int | getDwfDrawingCountByPartPk(PartPK pk, java.lang.String partFrom)
EcnCheckOrderResult | getEcnCheckOrderResult(BB2Part pk)
ECNReviewVO | getECNControlByBizBoxUserNumber(java.lang.String bizboxUserName)
ECNReviewVO | getECNControlByEmployeeId(java.lang.String employeeId)
ECNReviewVO | getECNControlByUserName(java.lang.String userName)
int | getECNControlCountByUserName(java.lang.String userNameLike)
int | getEcnCountByConditions(java.lang.String ecNumberLike, java.lang.String partNumber, java.lang.String partType, java.lang.String originator, java.lang.String status, java.lang.String importECN, java.lang.String importCompanyId, java.lang.String ecnDescription, java.lang.String dateType, java.util.Date dateFrom, java.util.Date dateTo)
ECRReviewVO | getECRControlByBizBoxUserNumber(java.lang.String bizboxUserName)
ECRReviewVO | getECRControlByEmployeeId(java.lang.String employeeId)
ECRReviewVO | getECRControlByUserName(java.lang.String userName)
int | getECRControlCountByUserName(java.lang.String userNameLike)
EngineeringChangeRequestVO | getECRequest(java.lang.String ecrNumber)
int | getECRequestCountByEcrNumberLike(java.lang.String ecrNumberLike)
int | getECRequestsCountByPartLike(java.lang.String pnRegex, java.lang.String partType, java.lang.String description, java.lang.String disposition, java.lang.String notes, java.lang.String status, java.lang.String originator, java.lang.String ecrPriority) ************above are about bill, below are about EngineeringChangeRequest
EngGroupVO | getEngGroupByPK(java.lang.String id)
int | getEngGroupListCount(java.lang.String id)
EngGroupUserVO | getEngGroupUserByPk(EngGroupUserPK pk)
int | getEngGroupUserCountByEmpoyeeId(java.lang.String engGroupId, java.lang.String empId)
EngineeringChangeVO | getEngineeringChangeById(java.lang.String ec)
EngineeringChangeDocumentVO | getEngineeringChangeDocumentByID(java.lang.Long controlNumber)
EngineeringChangeRequestDocumentVO | getEngineeringChangeRequestDocumentByID(java.lang.Long controlNumber)
int | getEngineeringChangesCountByEcnNumberLike(java.lang.String ecRegex) *****************above are about Part, below are about EngineeringChange
int | getEngineeringChangesCountByPartLike(java.lang.String pnRegex, java.lang.String partType)
int | getEngineeringChangesCountByPartPk(PartPK partPk)
int | getEngineeringChangesCountByStatus(java.lang.String status)
int | getEngineeringSharingByCompanyIdCount(java.lang.String addressId)
int | getEngineeringSharingByCompanyNameCount(java.lang.String companyName)
int | getEngineeringSharingImportLogsCount(java.lang.String partNumber, java.lang.String partType, java.util.Date startDate, java.util.Date endDate, java.lang.String status, java.lang.String importType, java.lang.String importDataType, java.lang.String ecnNumber)
int | getEngineeringSharingItemByCompanyIdCount(java.lang.String addressId, java.lang.String partNumber, java.lang.String partType)
EngineeringSharingItemVO | getEngineeringSharingItemByPk(EngineeringSharingItemPK pk)
EngineeringSharingVO | getEngineeringSharingsById(java.lang.String addressId)
int | getEngSharingPartsCountByPnAndengGroup(java.lang.String partFrom, java.lang.String partTo, java.lang.String partType, java.lang.String engGroup)
BOMTreeRollUPMap | getFullBOMTreeRollUPMap(BillPK pk)
int | getInBillPartsWithOnhandInfoCount(java.lang.String partNumber, java.lang.String partDescription, java.lang.String partType)
PartPictureVO | getMainPartPicture(PartPK pk)
java.lang.String | getManufacturerPartNoMfgExistent(java.lang.String mfgName, PartPK partPk)
java.lang.String | getMfgBillSetupInfo(BillPK billPk)
int | getMismatchedPartDrawingWithPartInfoResultsCount(java.lang.String partFrom)
int | getNotBillPartsWithOnhandInfoCount(java.lang.String partNumber, java.lang.String partDescription, java.lang.String partType)
int | getOpenDCCount()
int | getOpenECRequestsCount()
int | getOpenEngineeringChangesCount()
BillVO | getParentBill(BillItemVO billItemVO)
PartBasicInfo | getPartBasicInfo(PartPK pk)
PartBasicInfo | getPartBasicInfo(PartPK pk, java.lang.String languageCode)
int | getPartBasicInfoToRollUPCount(java.lang.String bill)
int | getPartBasicInfoToRollUPCount(java.lang.String bill, java.lang.String bnType)
PartCatagoryVO | getPartCatagoryByPk(PartCatagoryPK pk)
int | getPartDwfCount(java.lang.String pnLike, java.lang.String partType, java.lang.String partFrom, java.lang.String description, boolean onlyShowMissmatchedDWF)
int | getPartDwfCountFullMatch(java.lang.String pnLike, java.lang.String partType, java.lang.String partFrom, java.lang.String description, boolean onlyShowMissmatchedDWF)
int | getPartDwfLogCount(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String action, java.lang.String operator, java.lang.String wanIp, java.lang.String lanIp, java.lang.String macAddress, java.lang.String description, java.util.Date dateFrom, java.util.Date dateTo)
PartDwfWithPartInfoResult | getPartDwfWithPartInfoResult(PartDwfPK pk)
int | getPartDwgCount(java.lang.String pnLike, java.lang.String partType, java.lang.String partFrom, java.lang.String description)
int | getPartDwgLogCount(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String action, java.lang.String operator, java.lang.String wanIp, java.lang.String lanIp, java.lang.String macAddress, java.lang.String description, java.util.Date dateFrom, java.util.Date dateTo)
PartDwgWithPartInfoResult | getPartDwgWithPartInfoResult(PartDwgPK pk)
PartInventoryVO | getPartInventoryByPk(PartPK partPk)
int | getPartMaterialBomListResultsCount(java.lang.String billNumber, java.lang.String billType)
PartMaterialVO | getPartMaterialByPk(PartPK partPk)
int | getPartMaterialCount(PartMaterialReportAgent agent)
int | getPartMaterialCountByPartLike(PartPK partPk)
PartMaterialListResult | getPartMaterialInfo(PartPK pk)
PartMaterialWhereUsedResult | getPartMaterialWhereUsedResult(PartPK pk)
java.util.Collection<PartPictureVO> | getPartPictureByPk(PartPK pk)
int | getPartPKsCountForRecursiveBill(java.lang.String bill)
int | getPartsByPartCommodityCode(java.math.BigDecimal listPricePercent, java.lang.String commodityCodeLike)
int | getPartsByPartEngGroup(java.lang.String partNumber, java.lang.String partType, java.lang.String engGroup, java.lang.String newEngGroup)
int | getPartsCountByDescriptionInside(java.lang.String pnRegex, java.lang.String partType, java.lang.String descriptionRegex, java.lang.String languageCode)
int | getPartsCountByDescriptionStart(java.lang.String descriptionRegex)
int | getPartsCountByEngineeringSharingRule(java.lang.String companyId)
int | getPartsCountByManufacturerId(java.lang.String IdRegex)
int | getPartsCountByManufacturerPn(java.lang.String mpnRegex)
int | getPartsCountByManufacturerPnStartWith(java.lang.String mpnRegex)
int | getPartsCountByOnHold()
int | getPartsCountByPartAndDesc(java.lang.String fPn, java.lang.String tPn, java.lang.String pType, java.lang.String descriptionRegex, java.lang.String modelNumberLike, java.lang.String commodityCode, java.lang.String productCode, java.lang.String language, java.lang.String organization, java.lang.String securityLevel, java.lang.String makebuy)
int | getPartsCountByPartLike(java.lang.String pnRegex, java.lang.String partType)
int | getPartsCountByPK(PartPK pk)
int | getPartsCountsByDescriptionAndLang(java.lang.String[] descLike, java.lang.String languageCode)
int | getPartSecurityLevelByIdCount(java.lang.String levelId)
PartSecurityLevelVO | getPartSecurityLevelByPk(java.lang.String levelId)
int | getPartsToDeleteInPoCount()
int | getPartsToDeleteInSoCount()
int | getPartsToDeleteInWoItemDetailCount()
java.util.Collection<RollUPPartStandardCostResult> | getPartsToRollUPunder(BillPK pk)
int | getPartsWithBomCount()
int | getPartsWithDeletedCount()
int | getPartsWithDrawingCount()
int | getPartsWithWiCount()
java.util.Collection<PartToAuditFlagResult> | getPartToAuditFlagResultsForBOM(java.lang.String pnLike)
java.util.Collection<PartToAuditFlagResult> | getPartToAuditFlagResultsForDrawing(java.lang.String pnLike)
java.util.Collection<PartToAuditFlagResult> | getPartToAuditFlagResultsForPicture(java.lang.String pnLike)
java.util.Collection<PartToAuditFlagResult> | getPartToAuditFlagResultsForWI(java.lang.String pnLike)
int | getPartTraceabeListResultsCount(java.lang.String partNumber, java.lang.String partType)
PartTraceableCategoryVO | getPartTraceableCategoryByPk(PartTraceableCategoryPK pk)
PartTraceableSpecVO | getPartTraceableSpecByPk(PartTraceableSpecPK pk)
java.util.Map<BillPK,java.util.List> | getPartUseds(java.util.ArrayList<BillPK> list, PartPK oPartPk)
PartWithOnhandsVO | getPartWithOnhands(PartPK pk)
int | getPastDueDCCount()
java.util.Collection<RecursiveBillPath> | getRecursiveBill(PartPK pk)
java.util.Collection<PartPK> | getRecursivePartPKs(java.lang.String bill)
java.util.Collection<PartPK> | getRootBOMPartPKs(java.lang.String bill)
int | getTraceableCategoriesByPartCount(java.lang.String partNumber, java.lang.String partType, int traceableLevel, java.lang.String[] categoryIds, java.lang.Short[] specificationIds)
TraceableCategoriesVO | getTraceableCategoriesByPk(java.lang.String categoryId)
TraceableSpecsVO | getTraceableSpecsByPk(java.lang.Short specId)
UnitVO | getUnitByPk(java.lang.Long id)
int | getUnitsCount(java.lang.String unitName)
VendorQtyPriceVO | getVendorQtyPrice(VendorQtyPricePK pk)
java.util.Collection<VendorQtyPriceVO> | getVendorQtyPrices(BB2Part pk, java.lang.String vendorId)
PartManufacturerVO | InitPartManufacturerVoByAddressId(PartPK partPk, java.lang.String manufacturerId)
void | initPartsToDeleteByPns(java.lang.String[] partNumbers, java.lang.String partType)
PartVendorVO | InitPartVendorVoByAddressId(PartPK partPk, java.lang.String vendorId)
boolean | isBillExistent(BillPK pk)
boolean | isBomApprovalExistent(java.lang.String employeeId)
boolean | isCurrentUserHasEngGroupPermission(PartPK pk)
boolean | isECNControlRecorded(java.lang.String employeeId)
boolean | isECRControlRecorded(java.lang.String employeeId)
boolean | isEngGroupExistent(java.lang.String id)
boolean | isEngGroupUserExist(EngGroupUserPK pk)
boolean | isEngineeringSharingItemExist(EngineeringSharingItemPK pk)
boolean | isExistentNotUniqueMpn()
boolean | isManufacturerPartExistent(java.lang.String mfgName, java.lang.String mpn)
boolean | isPartDwfExist(PartDwfPK pk)
boolean | isPartDwgExist(PartDwgPK pk)
boolean | isPartExist(PartPK pk)
boolean | isPartExistent(PartPK pk)
boolean | isPartMaterialExist(PartPK partPk)
boolean | isTraceableCategoriesIDExist(java.lang.String categoryID)
boolean | isTraceableCategoriesIDUsed(java.lang.String categoryID)
boolean | isTraceableSpecsIDExist(java.lang.Short specID)
boolean | isTraceableSpecsIDUsed(java.lang.Short specID)
boolean | isUnitExist(java.lang.String unitName)
PartPK | replacePartForBOM(java.util.ArrayList<BillPK> list, PartPK oPartPk, PartPK dPartPk)
void | resetBB2PartAvgCost(BB2Part part)
void | resetMainPartPicture(java.lang.Long ii)
void | reviewEngineeringSharingImportLog(EngineeringSharingImportLogVO vo)
java.util.Collection<PartPK> | rollupPartStandardCost(PartPK pk)
void | setParentBill(BillVO billVO, BillItemVO billItemVO)
BillVO | updateBill(BillVO billVO)
void | updateBillItem(BillItemVO billItemVO)
void | updateBomApproval(BomApprovalVO bomApprovalVO)
DesignControlVO | updateDC(DesignControlVO vo)
java.util.Collection<DesignControlDocumentVO> | updateDCDoc(MiscDocAgent agent)
void | updateDeletedFlag(PartPK pk, boolean isDeleted)
void | updateECNControl(ECNReviewVO vo)
void | updateECRControl(ECRReviewVO vo)
EngineeringChangeRequestVO | updateECRequest(EngineeringChangeRequestVO ecRequestVO)
void | updateEngGroup(EngGroupVO vo)
void | updateEngGroupUser(EngGroupUserVO vo)
EngineeringChangeVO | updateEngineeringChange(EngineeringChangeVO engChangeVO)
void | updateEngineeringSharing(EngineeringSharingVO vo)
void | updateEngineeringSharingItem(EngineeringSharingItemVO vo)
PartPK | updatePart(PartVO partVO)
void | updatePartCatagory(PartCatagoryVO vo)
void | updatePartEngGroupAndLevel(PartPK pk, java.lang.String organization, java.lang.String levelId)
PartInventoryVO | updatePartInventory(PartInventoryVO vo)
java.util.Collection<PartManufacturerVO> | updatePartManufacturer(java.util.HashSet partManufacturerSet, PartPK partPk)
PartMaterialVO | updatePartMaterial(PartMaterialVO partMaterialVo)
void | updatePartSecurityLevel(PartSecurityLevelVO vo)
PartTraceableInfoResult | updatePartTraceableInfoResult(PartTraceableInfoResult vo)
PartPK | updatePartType(PartPK oldPartPk, PartPK newPartPk)
java.util.Collection<PartVendorVO> | updatePartVendor(java.util.HashSet partVendorVoSet, PartPK partPk)
PartVendorVO | updatePartVendor(PartVendorVO vo)
void | updatePartWithOnhands(PartWithOnhandsVO vo)
void | updateSaleableFlag(PartPK pk, boolean saleable, boolean salesDWG)
TraceableCategoriesVO | updateTraceableCategories(java.lang.String oldCategoryId, TraceableCategoriesVO traceableCategoriesVO)
TraceableSpecsVO | updateTraceableSpecs(java.lang.Short oldSpecId, TraceableSpecsVO traceableSpecsVO)
UnitVO | updateUnit(UnitVO vo)
void | updateVendorQtyPrice(VendorQtyPriceVO vo)
java.util.Collection<DesignControlDocumentVO> | uploadDCDoc(MiscDocAgent agent)
void | upLoadDWG(java.lang.String partFrom, java.lang.String key)
void | uploadFtpDWF(PartDwfAgent agent)
java.util.Collection<EngineeringChangeDocumentVO> | uploadOrUpdateFTPECDoc(MiscDocAgent agent)
java.util.Collection<EngineeringChangeRequestDocumentVO> | uploadOrUpdateFTPECRDoc(MiscDocAgent agent)
void | uploadPartPicture(MiscDocAgent agent)

Method Detail

addDC

DesignControlVO addDC(DesignControlVO vo)
                      throws java.lang.Exception
Throws:
java.lang.Exception

updateDC

DesignControlVO updateDC(DesignControlVO vo)
                         throws java.lang.Exception
Throws:
java.lang.Exception

deleteDc

void deleteDc(DesignControlVO vo)
              throws java.lang.Exception
Throws:
java.lang.Exception

getAllDCsCount

int getAllDCsCount()
                   throws java.lang.Exception
Throws:
java.lang.Exception

findAllPartNumbers

java.util.Collection<BB2DoubleString> findAllPartNumbers(java.lang.String language,
                                                         java.lang.String partType)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

findAllPartNumbers

java.util.Collection<BB2DoubleString> findAllPartNumbers()
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getDCByDcNumber

DesignControlVO getDCByDcNumber(java.lang.String dcNumber)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findDCsByDcNumber

java.util.Collection<DesignControlListResult> findDCsByDcNumber(java.lang.String dc,
                                                                int firstIndex,
                                                                int maxLength)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getDCCountByDcNumber

int getDCCountByDcNumber(java.lang.String dcNumberRegex)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findDCsByEngineerNameLike

java.util.Collection<DesignControlListResult> findDCsByEngineerNameLike(java.lang.String engineerNameLike,
                                                                        int firstIndex,
                                                                        int maxLength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getDCCountByEngineerNameLike

int getDCCountByEngineerNameLike(java.lang.String engineerNameLike)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findDCsByPartLike

java.util.Collection<DesignControlListResult> findDCsByPartLike(java.lang.String pnRegex,
                                                                java.lang.String partType,
                                                                java.lang.String projectDescription,
                                                                int firstIndex,
                                                                int maxLength)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getDCCountByPartLike

int getDCCountByPartLike(java.lang.String pnRegex,
                         java.lang.String partType,
                         java.lang.String projectDescription)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findOpenDCs

java.util.Collection<DesignControlListResult> findOpenDCs(int firstIndex,
                                                          int maxLength)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getOpenDCCount

int getOpenDCCount()
                   throws java.lang.Exception
Throws:
java.lang.Exception

findPastDueDCs

java.util.Collection<DesignControlListResult> findPastDueDCs(int firstIndex,
                                                             int maxLength)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getPastDueDCCount

int getPastDueDCCount()
                      throws java.lang.Exception
Throws:
java.lang.Exception

uploadDCDoc

java.util.Collection<DesignControlDocumentVO> uploadDCDoc(MiscDocAgent agent)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

updateDCDoc

java.util.Collection<DesignControlDocumentVO> updateDCDoc(MiscDocAgent agent)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

downloadDCDoc

byte[] downloadDCDoc(MiscDocAgent agent)
                     throws java.lang.Exception
Throws:
java.lang.Exception

deleteDCDoc

java.util.Collection<DesignControlDocumentVO> deleteDCDoc(MiscDocAgent agent)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getDCDocByPk

DesignControlDocumentVO getDCDocByPk(java.lang.Long pk)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

getPartWithOnhands

PartWithOnhandsVO getPartWithOnhands(PartPK pk)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

updatePartWithOnhands

void updatePartWithOnhands(PartWithOnhandsVO vo)
                           throws java.lang.Exception
Throws:
java.lang.Exception

batchUpdatePartWithOnhands

void batchUpdatePartWithOnhands(java.util.Map<PartPK,java.util.HashSet<PartOnhandVO>> allPartWithOnhands)
                                throws java.lang.Exception
Throws:
java.lang.Exception

isPartExistent

boolean isPartExistent(PartPK pk)
                       throws java.lang.Exception
Throws:
java.lang.Exception

isPartExist

boolean isPartExist(PartPK pk)
                    throws java.lang.Exception
Throws:
java.lang.Exception

findPartPKByPartNumber

java.util.Collection<PartVO> findPartPKByPartNumber(java.lang.String partNumber)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

findPartsByPK

java.util.Collection<PartVO> findPartsByPK(PartPK pk,
                                           int firstIndex,
                                           int maxLength)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

getPartsCountByPK

int getPartsCountByPK(PartPK pk)
                      throws java.lang.Exception
Throws:
java.lang.Exception

getPartsCountByPartLike

int getPartsCountByPartLike(java.lang.String pnRegex,
                            java.lang.String partType)
                            throws java.lang.Exception
Throws:
java.lang.Exception

getPartsCountByOnHold

int getPartsCountByOnHold()
                          throws java.lang.Exception
Throws:
java.lang.Exception

findPartsByPartCommodityCode

java.util.Collection<PartBasicInfoWithNewListPrice> findPartsByPartCommodityCode(java.math.BigDecimal listPricePercent,
                                                                                java.lang.String commodityCodeLike,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPartsByPartCommodityCode

int getPartsByPartCommodityCode(java.math.BigDecimal listPricePercent,
                                java.lang.String commodityCodeLike)
                                throws java.lang.Exception
Throws:
java.lang.Exception

batchUpdatePartsListPrice

void batchUpdatePartsListPrice(java.math.BigDecimal listPricePercent,
                               java.lang.String commodityCodeLike)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findPartsByPartEngGroup

java.util.Collection<PartBasicInfoWithNewEngGroup> findPartsByPartEngGroup(java.lang.String partNumber,
                                                                           java.lang.String partType,
                                                                           java.lang.String engGroup,
                                                                           java.lang.String newEngGroup,
                                                                           int firstIndex,
                                                                           int maxLength)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getPartsByPartEngGroup

int getPartsByPartEngGroup(java.lang.String partNumber,
                           java.lang.String partType,
                           java.lang.String engGroup,
                           java.lang.String newEngGroup)
                           throws java.lang.Exception
Throws:
java.lang.Exception

batchUpdatePartsEngGroup

void batchUpdatePartsEngGroup(java.lang.String partNumber,
                              java.lang.String partType,
                              java.lang.String engGroup,
                              java.lang.String newEngGroup)
                              throws java.lang.Exception
Throws:
java.lang.Exception

getPartsCountByDescriptionInside

int getPartsCountByDescriptionInside(java.lang.String pnRegex,
                                     java.lang.String partType,
                                     java.lang.String descriptionRegex,
                                     java.lang.String languageCode)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findPartsByDescriptionStart

java.util.Collection<PartBasicInfo> findPartsByDescriptionStart(java.lang.String edRegex,
                                                                int firstIndex,
                                                                int maxLength)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPartsCountByDescriptionStart

int getPartsCountByDescriptionStart(java.lang.String descriptionRegex)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findPartsByPartAndDesc

java.util.Collection<PartBasicInfo> findPartsByPartAndDesc(java.lang.String fPn,
                                                           java.lang.String tPn,
                                                           java.lang.String pType,
                                                           java.lang.String descriptionRegex,
                                                           java.lang.String modelNumberLike,
                                                           java.lang.String commodityCode,
                                                           java.lang.String productCode,
                                                           java.lang.String language,
                                                           java.lang.String engGroup,
                                                           java.lang.String securityLevel,
                                                           java.lang.String makebuy,
                                                           int firstIndex,
                                                           int maxLength)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getPartsCountByPartAndDesc

int getPartsCountByPartAndDesc(java.lang.String fPn,
                               java.lang.String tPn,
                               java.lang.String pType,
                               java.lang.String descriptionRegex,
                               java.lang.String modelNumberLike,
                               java.lang.String commodityCode,
                               java.lang.String productCode,
                               java.lang.String language,
                               java.lang.String organization,
                               java.lang.String securityLevel,
                               java.lang.String makebuy)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findPartsByDescriptionAndLang

java.util.Collection<PartBasicInfo> findPartsByDescriptionAndLang(java.lang.String[] descLike,
                                                                  java.lang.String languageCode,
                                                                  int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getPartsCountsByDescriptionAndLang

int getPartsCountsByDescriptionAndLang(java.lang.String[] descLike,
                                       java.lang.String languageCode)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

getPartsCountByManufacturerPn

int getPartsCountByManufacturerPn(java.lang.String mpnRegex)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

getPartsCountByManufacturerId

int getPartsCountByManufacturerId(java.lang.String IdRegex)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

addPart

PartPK addPart(PartVO vo)
               throws java.lang.Exception
Throws:
java.lang.Exception

updatePart

PartPK updatePart(PartVO partVO)
                  throws java.lang.Exception
Throws:
java.lang.Exception

updatePartType

PartPK updatePartType(PartPK oldPartPk,
                      PartPK newPartPk)
                      throws java.lang.Exception
Throws:
java.lang.Exception

updateSaleableFlag

void updateSaleableFlag(PartPK pk,
                        boolean saleable,
                        boolean salesDWG)
                        throws java.lang.Exception
Throws:
java.lang.Exception

updateDeletedFlag

void updateDeletedFlag(PartPK pk,
                       boolean isDeleted)
                       throws java.lang.Exception
Throws:
java.lang.Exception

initPartsToDeleteByPns

void initPartsToDeleteByPns(java.lang.String[] partNumbers,
                            java.lang.String partType)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findPartsToDeleteInSo

java.util.Collection<SalesOrderItemListResult> findPartsToDeleteInSo(int firstIndex,
                                                                     int maxLength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getPartsToDeleteInSoCount

int getPartsToDeleteInSoCount()
                              throws java.lang.Exception
Throws:
java.lang.Exception

findPartsToDeleteInPo

java.util.Collection<PurchaseOrderItemListResult> findPartsToDeleteInPo(int firstIndex,
                                                                        int maxLength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getPartsToDeleteInPoCount

int getPartsToDeleteInPoCount()
                              throws java.lang.Exception
Throws:
java.lang.Exception

findPartsToDeleteInWoItemDetail

java.util.Collection<WorkOrderItemPartDetail> findPartsToDeleteInWoItemDetail(int firstIndex,
                                                                              int maxLength)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getPartsToDeleteInWoItemDetailCount

int getPartsToDeleteInWoItemDetailCount()
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findAllPartsToDelete

java.util.Collection<PartOnHandWithPartBasicInfoResult> findAllPartsToDelete(int firstIndex,
                                                                             int maxLength)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getAllPartsToDeleteCount

int getAllPartsToDeleteCount()
                             throws java.lang.Exception
Throws:
java.lang.Exception

findAllBomsToDelete

java.util.Collection<BillOnHandWithPartInfoResult> findAllBomsToDelete(int firstIndex,
                                                                       int maxLength)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getAllBomsToDeleteCount

int getAllBomsToDeleteCount()
                            throws java.lang.Exception
Throws:
java.lang.Exception

updatePartInventory

PartInventoryVO updatePartInventory(PartInventoryVO vo)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

updatePartEngGroupAndLevel

void updatePartEngGroupAndLevel(PartPK pk,
                                java.lang.String organization,
                                java.lang.String levelId)
                                throws java.lang.Exception
Throws:
java.lang.Exception

copyPart

PartVO copyPart(PartPK pk,
                java.lang.String rev,
                java.lang.String partUnit,
                java.lang.String description,
                PartPK oldPk,
                boolean onlyChangeParType)
                throws java.lang.Exception
Throws:
java.lang.Exception

findPart

PartVO findPart(PartPK pk)
                throws java.lang.Exception
Throws:
java.lang.Exception

addPartSecurityLevel

PartSecurityLevelVO addPartSecurityLevel(PartSecurityLevelVO vo)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

updatePartSecurityLevel

void updatePartSecurityLevel(PartSecurityLevelVO vo)
                             throws java.lang.Exception
Throws:
java.lang.Exception

deletePartSecurityLevel

void deletePartSecurityLevel(java.lang.String levelId)
                             throws java.lang.Exception
Throws:
java.lang.Exception

getPartSecurityLevelByPk

PartSecurityLevelVO getPartSecurityLevelByPk(java.lang.String levelId)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findPartSecurityLevelById

java.util.Collection<PartSecurityLevelVO> findPartSecurityLevelById(java.lang.String levelId,
                                                                    int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getPartSecurityLevelByIdCount

int getPartSecurityLevelByIdCount(java.lang.String levelId)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findAllPartSecurityLevel

java.util.Collection<PartSecurityLevelVO> findAllPartSecurityLevel(int firstIndex,
                                                                   int maxLength)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getAllPartSecurityLevelCount

int getAllPartSecurityLevelCount()
                                 throws java.lang.Exception
Throws:
java.lang.Exception

addEngGroup

EngGroupVO addEngGroup(EngGroupVO vo)
                       throws java.lang.Exception
Throws:
java.lang.Exception

updateEngGroup

void updateEngGroup(EngGroupVO vo)
                    throws java.lang.Exception
Throws:
java.lang.Exception

deleteEngGroup

void deleteEngGroup(java.lang.String id)
                    throws java.lang.Exception
Throws:
java.lang.Exception

getEngGroupByPK

EngGroupVO getEngGroupByPK(java.lang.String id)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findAllEngGroup

java.util.Collection<EngGroupVO> findAllEngGroup(int firstIndex,
                                                 int maxLength)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getAllEngGroupCount

int getAllEngGroupCount()
                        throws java.lang.Exception
Throws:
java.lang.Exception

findEngGroupListById

java.util.Collection<EngGroupVO> findEngGroupListById(java.lang.String id,
                                                      int firstIndex,
                                                      int maxLength)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getEngGroupListCount

int getEngGroupListCount(java.lang.String id)
                         throws java.lang.Exception
Throws:
java.lang.Exception

isEngGroupExistent

boolean isEngGroupExistent(java.lang.String id)
                           throws java.lang.Exception
Throws:
java.lang.Exception

downloadAllPartPictureByPk

java.util.Collection<BB2Picture> downloadAllPartPictureByPk(MiscDocAgent agent)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

downloadMainPartPicture

BB2Picture downloadMainPartPicture(MiscDocAgent agent)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

uploadPartPicture

void uploadPartPicture(MiscDocAgent agent)
                       throws java.lang.Exception
Throws:
java.lang.Exception

deletePartPicture

void deletePartPicture(MiscDocAgent agent)
                       throws java.lang.Exception
Throws:
java.lang.Exception

getPartPictureByPk

java.util.Collection<PartPictureVO> getPartPictureByPk(PartPK pk)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getMainPartPicture

PartPictureVO getMainPartPicture(PartPK pk)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

addPartPicture

void addPartPicture(PartPictureVO vo)
                    throws java.lang.Exception
Throws:
java.lang.Exception

deletePartPicture

void deletePartPicture(java.lang.Long ii)
                       throws java.lang.Exception
Throws:
java.lang.Exception

resetMainPartPicture

void resetMainPartPicture(java.lang.Long ii)
                          throws java.lang.Exception
Throws:
java.lang.Exception

findAllParts

java.util.Collection<PartBasicInfo> findAllParts(int firstIndex,
                                                 int maxLength)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getAllPartsCount

int getAllPartsCount()
                     throws java.lang.Exception
Throws:
java.lang.Exception

findPartsByPartLike

java.util.Collection<PartBasicInfo> findPartsByPartLike(java.lang.String pnRegex,
                                                        java.lang.String partType,
                                                        int firstIndex,
                                                        int maxLength)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

findPartWhereIsUsed

PartWhereUsedResult findPartWhereIsUsed(PartPK pk)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findPartsOnHold

java.util.Collection<PartBasicInfo> findPartsOnHold(int firstIndex,
                                                    int maxLength)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

findPartsByDescriptionInside

java.util.Collection<PartBasicInfo> findPartsByDescriptionInside(java.lang.String pnRegex,
                                                                 java.lang.String partType,
                                                                 java.lang.String edRegex,
                                                                 java.lang.String languageCode,
                                                                 int firstIndex,
                                                                 int maxLength)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findPartsByManufacturerPn

java.util.Collection<PartWithManufacturerInfoResult> findPartsByManufacturerPn(java.lang.String mpnRegex,
                                                                               int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

findPartsByManufacturerPnStartWith

java.util.Collection<PartWithManufacturerInfoResult> findPartsByManufacturerPnStartWith(java.lang.String mpnRegex,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPartsCountByManufacturerPnStartWith

int getPartsCountByManufacturerPnStartWith(java.lang.String mpnRegex)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

findPartsByManufacturerId

java.util.Collection<PartWithManufacturerInfoResult> findPartsByManufacturerId(java.lang.String mfgIdRegex,
                                                                               int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

findAllPartsWithOnhandInfo

java.util.Collection<PartOnHandWithPartBasicInfoResult> findAllPartsWithOnhandInfo(java.lang.String partNumber,
                                                                                java.lang.String partDescription,
                                                                                java.lang.String partType,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllPartsWithOnhandInfoCount

int getAllPartsWithOnhandInfoCount(java.lang.String partNumber,
                                   java.lang.String partDescription,
                                   java.lang.String partType)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

addTraceableCategories

TraceableCategoriesVO addTraceableCategories(TraceableCategoriesVO traceableCategoriesVO)
                                             throws java.lang.Exception
Traceable****************************************************************

Throws:
java.lang.Exception

updateTraceableCategories

TraceableCategoriesVO updateTraceableCategories(java.lang.String oldCategoryId,
                                                TraceableCategoriesVO traceableCategoriesVO)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

deleteTraceableCategories

void deleteTraceableCategories(TraceableCategoriesVO traceableCategoriesVO)
                               throws java.lang.Exception
Throws:
java.lang.Exception

deleteTraceableCategories

void deleteTraceableCategories(java.lang.String categoryId)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getTraceableCategoriesByPk

TraceableCategoriesVO getTraceableCategoriesByPk(java.lang.String categoryId)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

isTraceableCategoriesIDExist

boolean isTraceableCategoriesIDExist(java.lang.String categoryID)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

isTraceableCategoriesIDUsed

boolean isTraceableCategoriesIDUsed(java.lang.String categoryID)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findAllTraceableCategories

java.util.Collection<TraceableCategoriesVO> findAllTraceableCategories(int firstIndex,
                                                                       int maxLength)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

findTraceableCategoriesByPart

java.util.Collection<PartTraceableResult> findTraceableCategoriesByPart(java.lang.String partNumber,
                                                                        java.lang.String partType,
                                                                        int traceableLevel,
                                                                        java.lang.String[] categoryIds,
                                                                        java.lang.Short[] specificationIds,
                                                                        int firstIndex,
                                                                        int maxLength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getTraceableCategoriesByPartCount

int getTraceableCategoriesByPartCount(java.lang.String partNumber,
                                      java.lang.String partType,
                                      int traceableLevel,
                                      java.lang.String[] categoryIds,
                                      java.lang.Short[] specificationIds)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

getAllTraceableCategoriesCount

int getAllTraceableCategoriesCount()
                                   throws java.lang.Exception
Throws:
java.lang.Exception

addTraceableSpecs

TraceableSpecsVO addTraceableSpecs(TraceableSpecsVO traceableSpecsVO)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

updateTraceableSpecs

TraceableSpecsVO updateTraceableSpecs(java.lang.Short oldSpecId,
                                      TraceableSpecsVO traceableSpecsVO)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

deleteTraceableSpecs

void deleteTraceableSpecs(TraceableSpecsVO traceableSpecsVO)
                          throws java.lang.Exception
Throws:
java.lang.Exception

deleteTraceableSpecs

void deleteTraceableSpecs(java.lang.Short specId)
                          throws java.lang.Exception
Throws:
java.lang.Exception

getTraceableSpecsByPk

TraceableSpecsVO getTraceableSpecsByPk(java.lang.Short specId)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

isTraceableSpecsIDExist

boolean isTraceableSpecsIDExist(java.lang.Short specID)
                                throws java.lang.Exception
Throws:
java.lang.Exception

isTraceableSpecsIDUsed

boolean isTraceableSpecsIDUsed(java.lang.Short specID)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findAllTraceableSpecs

java.util.Collection<TraceableSpecsVO> findAllTraceableSpecs(int firstIndex,
                                                             int maxLength)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getAllTraceableSpecsCount

int getAllTraceableSpecsCount()
                              throws java.lang.Exception
Throws:
java.lang.Exception

addPartTraceableCategory

PartTraceableCategoryVO addPartTraceableCategory(PartTraceableCategoryVO partTraceableCategoryVO)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

deletePartTraceableCategory

void deletePartTraceableCategory(PartTraceableCategoryVO partTraceableCategoryVO)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

getPartTraceableCategoryByPk

PartTraceableCategoryVO getPartTraceableCategoryByPk(PartTraceableCategoryPK pk)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

deletePartTraceableCategories

void deletePartTraceableCategories(PartPK partPk)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

addPartTraceableSpec

PartTraceableSpecVO addPartTraceableSpec(PartTraceableSpecVO partTraceableSpecVO)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

deletePartTraceableSpec

void deletePartTraceableSpec(PartTraceableSpecVO partTraceableSpecVO)
                             throws java.lang.Exception
Throws:
java.lang.Exception

deletePartTraceableSpec

void deletePartTraceableSpec(PartTraceableSpecPK pk)
                             throws java.lang.Exception
Throws:
java.lang.Exception

getPartTraceableSpecByPk

PartTraceableSpecVO getPartTraceableSpecByPk(PartTraceableSpecPK pk)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

deletePartTraceableSpecs

void deletePartTraceableSpecs(PartPK partPk)
                              throws java.lang.Exception
Throws:
java.lang.Exception

updatePartTraceableInfoResult

PartTraceableInfoResult updatePartTraceableInfoResult(PartTraceableInfoResult vo)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

deletePartTraceable

void deletePartTraceable(PartPK pk)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findPartTraceableByPk

PartTraceableInfoResult findPartTraceableByPk(PartPK pk)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

findPartTraceableListResults

java.util.Collection<PartTraceableListResult> findPartTraceableListResults(java.lang.String partNumber,
                                                                           java.lang.String partType,
                                                                           int firstIndex,
                                                                           int maxLength)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getPartTraceabeListResultsCount

int getPartTraceabeListResultsCount(java.lang.String partNumber,
                                    java.lang.String partType)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findPartsWithBom

java.util.Collection<PartBasicInfo> findPartsWithBom(int firstIndex,
                                                     int maxLength)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getPartsWithBomCount

int getPartsWithBomCount()
                         throws java.lang.Exception
Throws:
java.lang.Exception

getAllBomItemsCount

int getAllBomItemsCount(java.lang.String[] billNumbers,
                        java.lang.String billType)
                        throws java.lang.Exception
Throws:
java.lang.Exception

findAllBomItems

java.util.Collection<PartOnHandWithMfgInfoResult> findAllBomItems(java.lang.String[] billNumbers,
                                                                  java.lang.String billType,
                                                                  int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

findBillLog

java.util.Collection<BillLogVO> findBillLog(java.lang.String billNumber,
                                            java.lang.String billType,
                                            java.lang.String userName,
                                            java.util.Date fromDate,
                                            java.util.Date toDate,
                                            int firstIndex,
                                            int maxLength)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

getBillLogCount

int getBillLogCount(java.lang.String billNumber,
                    java.lang.String billType,
                    java.lang.String userName,
                    java.util.Date fromDate,
                    java.util.Date toDate)
                    throws java.lang.Exception
Throws:
java.lang.Exception

findPartsWithDeleted

java.util.Collection<PartBasicInfo> findPartsWithDeleted(int firstIndex,
                                                         int maxLength)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getPartsWithDeletedCount

int getPartsWithDeletedCount()
                             throws java.lang.Exception
Throws:
java.lang.Exception

findPartsWithWi

java.util.Collection<PartBasicInfo> findPartsWithWi(int firstIndex,
                                                    int maxLength)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getPartsWithWiCount

int getPartsWithWiCount()
                        throws java.lang.Exception
Throws:
java.lang.Exception

findPartsWithDrawing

java.util.Collection<PartBasicInfo> findPartsWithDrawing(int firstIndex,
                                                         int maxLength)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getPartsWithDrawingCount

int getPartsWithDrawingCount()
                             throws java.lang.Exception
Throws:
java.lang.Exception

getPartBasicInfo

PartBasicInfo getPartBasicInfo(PartPK pk)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getPartBasicInfo

PartBasicInfo getPartBasicInfo(PartPK pk,
                               java.lang.String languageCode)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getEngineeringChangesCountByEcnNumberLike

int getEngineeringChangesCountByEcnNumberLike(java.lang.String ecRegex)
                                              throws java.lang.Exception
*****************above are about Part, below are about EngineeringChange

Throws:
java.lang.Exception

getEngineeringChangesCountByPartLike

int getEngineeringChangesCountByPartLike(java.lang.String pnRegex,
                                         java.lang.String partType)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

findEngineeringChangeByPartPk

java.util.Collection<EngineeringChangeListResult> findEngineeringChangeByPartPk(PartPK partPk,
                                                                                java.lang.String languageFlag,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getEngineeringChangesCountByPartPk

int getEngineeringChangesCountByPartPk(PartPK partPk)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

getOpenEngineeringChangesCount

int getOpenEngineeringChangesCount()
                                   throws java.lang.Exception
Throws:
java.lang.Exception

getDueEngineeringChangesCount

int getDueEngineeringChangesCount()
                                  throws java.lang.Exception
Throws:
java.lang.Exception

addEngineeringChange

EngineeringChangeVO addEngineeringChange(EngineeringChangeVO engChangeVO)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

getEngineeringChangeById

EngineeringChangeVO getEngineeringChangeById(java.lang.String ec)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findAllEngineeringChanges

java.util.Collection<EngineeringChangeListResult> findAllEngineeringChanges(java.lang.String languageFlag,
                                                                            int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getAllEngineeringChangesCount

int getAllEngineeringChangesCount()
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findEngineeringChangeByEcnNumberLike

java.util.Collection<EngineeringChangeListResult> findEngineeringChangeByEcnNumberLike(java.lang.String ecRegex,
                                                                                java.lang.String languageCode,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findEngineeringChangeByPartLike

java.util.Collection<EngineeringChangeListResult> findEngineeringChangeByPartLike(java.lang.String pnRegex,
                                                                                java.lang.String partType,
                                                                                java.lang.String languageCode,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findOpenEngineeringChange

java.util.Collection<EngineeringChangeListResult> findOpenEngineeringChange(java.lang.String languageCode,
                                                                            int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

findDueEngineerningChange

java.util.Collection<EngineeringChangeListResult> findDueEngineerningChange(java.lang.String languageCode,
                                                                            int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

updateEngineeringChange

EngineeringChangeVO updateEngineeringChange(EngineeringChangeVO engChangeVO)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

deleteEngineeringChange

void deleteEngineeringChange(EngineeringChangeVO engChange)
                             throws java.lang.Exception
Throws:
java.lang.Exception

approveEngineeringChange

EngineeringChangeVO approveEngineeringChange(java.lang.String ecNumber)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

getEcnCheckOrderResult

EcnCheckOrderResult getEcnCheckOrderResult(BB2Part pk)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

findEcnByConditions

java.util.Collection<EngineeringChangeListResult> findEcnByConditions(java.lang.String ecNumberLike,
                                                                      java.lang.String partNumber,
                                                                      java.lang.String partType,
                                                                      java.lang.String originator,
                                                                      java.lang.String status,
                                                                      java.lang.String languageCode,
                                                                      java.lang.String importECN,
                                                                      java.lang.String importCompanyId,
                                                                      java.lang.String ecnDescription,
                                                                      java.lang.String dateType,
                                                                      java.util.Date dateFrom,
                                                                      java.util.Date dateTo,
                                                                      int firstIndex,
                                                                      int maxLength)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getEcnCountByConditions

int getEcnCountByConditions(java.lang.String ecNumberLike,
                            java.lang.String partNumber,
                            java.lang.String partType,
                            java.lang.String originator,
                            java.lang.String status,
                            java.lang.String importECN,
                            java.lang.String importCompanyId,
                            java.lang.String ecnDescription,
                            java.lang.String dateType,
                            java.util.Date dateFrom,
                            java.util.Date dateTo)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findAllECNControl

java.util.Collection<ECNReviewVO> findAllECNControl(int firstIndex,
                                                    int maxLength)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getAllECNControlCount

int getAllECNControlCount()
                          throws java.lang.Exception
Throws:
java.lang.Exception

getECNControlByEmployeeId

ECNReviewVO getECNControlByEmployeeId(java.lang.String employeeId)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

getECNControlByBizBoxUserNumber

ECNReviewVO getECNControlByBizBoxUserNumber(java.lang.String bizboxUserName)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

getECNControlByUserName

ECNReviewVO getECNControlByUserName(java.lang.String userName)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

isECNControlRecorded

boolean isECNControlRecorded(java.lang.String employeeId)
                             throws java.lang.Exception
Throws:
java.lang.Exception

findECNControlByUserName

java.util.Collection<ECNReviewVO> findECNControlByUserName(java.lang.String userNameLike,
                                                           int firstIndex,
                                                           int maxLength)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getECNControlCountByUserName

int getECNControlCountByUserName(java.lang.String userNameLike)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

addECNControl

ECNReviewVO addECNControl(java.lang.String employeeId)
                          throws java.lang.Exception
Throws:
java.lang.Exception

updateECNControl

void updateECNControl(ECNReviewVO vo)
                      throws java.lang.Exception
Throws:
java.lang.Exception

deleteECNControl

void deleteECNControl(java.lang.String employeeId)
                      throws java.lang.Exception
Throws:
java.lang.Exception

addBill

BillVO addBill(BillVO billVO)
               throws java.lang.Exception
**************above are EngineeringChange, below about Bill and BillItem

Throws:
java.lang.Exception

copyBill

BillPK copyBill(BillPK fpk,
                BillPK tpk)
                throws java.lang.Exception
Throws:
java.lang.Exception

approvalBill

BillVO approvalBill(BillVO billVO)
                    throws java.lang.Exception
Throws:
java.lang.Exception

getPartUseds

java.util.Map<BillPK,java.util.List> getPartUseds(java.util.ArrayList<BillPK> list,
                                                  PartPK oPartPk)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

replacePartForBOM

PartPK replacePartForBOM(java.util.ArrayList<BillPK> list,
                         PartPK oPartPk,
                         PartPK dPartPk)
                         throws java.lang.Exception
Throws:
java.lang.Exception

getBill

BillVO getBill(BillPK billPk)
               throws java.lang.Exception
Throws:
java.lang.Exception

getMfgBillSetupInfo

java.lang.String getMfgBillSetupInfo(BillPK billPk)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

isBillExistent

boolean isBillExistent(BillPK pk)
                       throws java.lang.Exception
Throws:
java.lang.Exception

getBillDetailCostResult

BillDetailCostResult getBillDetailCostResult(BillPK billPk,
                                             java.lang.String languageCode)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

getBillWithPartInfoByBillPk

BillWithPartInfoResult getBillWithPartInfoByBillPk(BillPK billPk,
                                                   java.lang.String languageCode)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getBillOnHandWithPartInfoResultByBillPk

BillOnHandWithPartInfoResult getBillOnHandWithPartInfoResultByBillPk(BillPK billPk,
                                                                     java.lang.String languageCode,
                                                                     java.lang.String locationPrefix)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

findAllBillsWithPartInfo

java.util.Collection<BillWithPartInfoResult> findAllBillsWithPartInfo(java.lang.String languageCode,
                                                                      int firstIndex,
                                                                      int maxLength)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getAllBillsWithPartInfoCount

int getAllBillsWithPartInfoCount()
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findBillswithPartInfoByBillNumberLike

java.util.Collection<BillWithPartInfoResult> findBillswithPartInfoByBillNumberLike(boolean dateType,
                                                                                java.util.Date fromDate,
                                                                                java.util.Date toDate,
                                                                                java.lang.String bnRegex,
                                                                                java.lang.String billType,
                                                                                java.lang.String languageCode,
                                                                                boolean isPFEP,
                                                                                java.lang.String lastChangeUser,
                                                                                java.lang.String origin,
                                                                                java.lang.String status,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getBillsCountByBillNumberLike

int getBillsCountByBillNumberLike(boolean dateType,
                                  java.util.Date fromDate,
                                  java.util.Date toDate,
                                  java.lang.String bnRegex,
                                  java.lang.String billType,
                                  boolean isPFEP,
                                  java.lang.String lastChangeUser,
                                  java.lang.String origin,
                                  java.lang.String status)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

updateBill

BillVO updateBill(BillVO billVO)
                  throws java.lang.Exception
Throws:
java.lang.Exception

deleteBill

void deleteBill(BillVO billVO)
                throws java.lang.Exception
Throws:
java.lang.Exception

addBillItem

void addBillItem(BillItemVO itemVO)
                 throws java.lang.Exception
Throws:
java.lang.Exception

setParentBill

void setParentBill(BillVO billVO,
                   BillItemVO billItemVO)
                   throws java.lang.Exception
Throws:
java.lang.Exception

getBillItems

BillItemVO getBillItems(BillItemPK itemPk)
                        throws java.lang.Exception
Throws:
java.lang.Exception

updateBillItem

void updateBillItem(BillItemVO billItemVO)
                    throws java.lang.Exception
Throws:
java.lang.Exception

deleteBillItem

void deleteBillItem(BillItemVO billItemVO)
                    throws java.lang.Exception
Throws:
java.lang.Exception

getParentBill

BillVO getParentBill(BillItemVO billItemVO)
                     throws java.lang.Exception
Throws:
java.lang.Exception

getBillItemCount

int getBillItemCount(BillPK billPk)
                     throws java.lang.Exception
Throws:
java.lang.Exception

findBillItemWithPartInfoByBillPk

java.util.Collection<BillItemWithPartInfoResult> findBillItemWithPartInfoByBillPk(BillPK billPk,
                                                                                java.lang.String languageCode,
                                                                                boolean needMfg)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findBillItemOnHandWithPartInfoByBillPk

java.util.Collection<BillItemOnHandWithPartInfoResult> findBillItemOnHandWithPartInfoByBillPk(BillPK billPk,
                                                                                java.lang.String languageCode,
                                                                                boolean needOnhandLocation,
                                                                                java.lang.String locationPrefix)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getBillItemWithPartInfoByBillItemPk

BillItemWithPartInfoResult getBillItemWithPartInfoByBillItemPk(BillItemPK billItemPk,
                                                               java.lang.String languageCode)
                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getBillItemOnHandWithPartInfoByBillItemPk

BillItemOnHandWithPartInfoResult getBillItemOnHandWithPartInfoByBillItemPk(BillItemPK billItemPk,
                                                                           java.lang.String languageCode)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

findBillItemWithPartInfoByBillPk

java.util.Collection<BillItemWithPartInfoResult> findBillItemWithPartInfoByBillPk(BillPK billPk,
                                                                                java.lang.String languageCode,
                                                                                boolean needMfg,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPartPKsCountForRecursiveBill

int getPartPKsCountForRecursiveBill(java.lang.String bill)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

getRootBOMPartPKs

java.util.Collection<PartPK> getRootBOMPartPKs(java.lang.String bill)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

getRecursiveBill

java.util.Collection<RecursiveBillPath> getRecursiveBill(PartPK pk)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getRecursivePartPKs

java.util.Collection<PartPK> getRecursivePartPKs(java.lang.String bill)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getBillItemUsageResults

java.util.Collection<BillItemUsageResult> getBillItemUsageResults(BillPK pk)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getBillItemUsageResultsWitCost

java.util.Collection<BillItemUsageResult> getBillItemUsageResultsWitCost(BillPK pk)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getBillItemOnHandUsageResults

java.util.Collection<BillItemOnHandUsageResult> getBillItemOnHandUsageResults(BillPK pk)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getBomWithOEMResult

BomWithOEMResult getBomWithOEMResult(BillPK pk,
                                     java.lang.String mfgId)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

getPartToAuditFlagResultsForBOM

java.util.Collection<PartToAuditFlagResult> getPartToAuditFlagResultsForBOM(java.lang.String pnLike)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

auditPartBomFlag

void auditPartBomFlag(java.util.HashSet<PartPK> partPKs)
                      throws java.lang.Exception
Throws:
java.lang.Exception

getPartToAuditFlagResultsForPicture

java.util.Collection<PartToAuditFlagResult> getPartToAuditFlagResultsForPicture(java.lang.String pnLike)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

auditPartPictureFlag

void auditPartPictureFlag(java.util.HashSet<PartPK> partPKs)
                          throws java.lang.Exception
Throws:
java.lang.Exception

getBillWithoutItems

java.util.Collection<BillWithPartInfoResult> getBillWithoutItems(java.lang.String pnLike)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

deleteBillWithoutItems

void deleteBillWithoutItems(java.util.ArrayList<BillPK> set)
                            throws java.lang.Exception
Throws:
java.lang.Exception

addBomApproval

BomApprovalVO addBomApproval(java.lang.String employeeId)
                             throws java.lang.Exception
Throws:
java.lang.Exception

updateBomApproval

void updateBomApproval(BomApprovalVO bomApprovalVO)
                       throws java.lang.Exception
Throws:
java.lang.Exception

deleteBomApproval

void deleteBomApproval(java.lang.String employeeId)
                       throws java.lang.Exception
Throws:
java.lang.Exception

getBomApprovalByEmployeeId

BomApprovalVO getBomApprovalByEmployeeId(java.lang.String employeeId)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

isBomApprovalExistent

boolean isBomApprovalExistent(java.lang.String employeeId)
                              throws java.lang.Exception
Throws:
java.lang.Exception

findAllBomApprovals

java.util.Collection<BomApprovalVO> findAllBomApprovals(int firstIndex,
                                                        int maxLength)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getAllBomApprovalsCount

int getAllBomApprovalsCount()
                            throws java.lang.Exception
Throws:
java.lang.Exception

getECRequestsCountByPartLike

int getECRequestsCountByPartLike(java.lang.String pnRegex,
                                 java.lang.String partType,
                                 java.lang.String description,
                                 java.lang.String disposition,
                                 java.lang.String notes,
                                 java.lang.String status,
                                 java.lang.String originator,
                                 java.lang.String ecrPriority)
                                 throws java.lang.Exception
************above are about bill, below are about EngineeringChangeRequest

Throws:
java.lang.Exception

addECRequest

EngineeringChangeRequestVO addECRequest(EngineeringChangeRequestVO ecRequestVO)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

getECRequest

EngineeringChangeRequestVO getECRequest(java.lang.String ecrNumber)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findAllECRequests

java.util.Collection<EngineeringChangeRequestListResult> findAllECRequests(java.lang.String languageCode,
                                                                           int firstIndex,
                                                                           int maxLength)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getAllECRequestsCount

int getAllECRequestsCount()
                          throws java.lang.Exception
Throws:
java.lang.Exception

findECRequestByPartLike

java.util.Collection<EngineeringChangeRequestListResult> findECRequestByPartLike(java.lang.String pnRegex,
                                                                                java.lang.String partType,
                                                                                java.lang.String languageCode,
                                                                                java.lang.String description,
                                                                                java.lang.String disposition,
                                                                                java.lang.String notes,
                                                                                java.lang.String status,
                                                                                java.lang.String ecrPriority,
                                                                                java.lang.String originator,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findOpenECRequest

java.util.Collection<EngineeringChangeRequestListResult> findOpenECRequest(java.lang.String languageCode,
                                                                           int firstIndex,
                                                                           int maxLength)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getOpenECRequestsCount

int getOpenECRequestsCount()
                           throws java.lang.Exception
Throws:
java.lang.Exception

findDueECRequest

java.util.Collection<EngineeringChangeRequestListResult> findDueECRequest(java.lang.String languageCode,
                                                                          int firstIndex,
                                                                          int maxLength)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getDueECRequestsCount

int getDueECRequestsCount()
                          throws java.lang.Exception
Throws:
java.lang.Exception

findECRequestByEcrNumberLike

java.util.Collection<EngineeringChangeRequestListResult> findECRequestByEcrNumberLike(java.lang.String ecrNumberLike,
                                                                                java.lang.String languageCode,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getECRequestCountByEcrNumberLike

int getECRequestCountByEcrNumberLike(java.lang.String ecrNumberLike)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

updateECRequest

EngineeringChangeRequestVO updateECRequest(EngineeringChangeRequestVO ecRequestVO)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

deleteECRequest

void deleteECRequest(EngineeringChangeRequestVO ecRequestVO)
                     throws java.lang.Exception
Throws:
java.lang.Exception

approvedECR

EngineeringChangeRequestVO approvedECR(java.lang.String ecrNumber)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

copyEcrToEcn

java.lang.String copyEcrToEcn(java.lang.String ecrNumber)
                              throws java.lang.Exception
Throws:
java.lang.Exception

findAllECRControl

java.util.Collection<ECRReviewVO> findAllECRControl(int firstIndex,
                                                    int maxLength)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getAllECRControlCount

int getAllECRControlCount()
                          throws java.lang.Exception
Throws:
java.lang.Exception

getECRControlByEmployeeId

ECRReviewVO getECRControlByEmployeeId(java.lang.String employeeId)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

getECRControlByBizBoxUserNumber

ECRReviewVO getECRControlByBizBoxUserNumber(java.lang.String bizboxUserName)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

getECRControlByUserName

ECRReviewVO getECRControlByUserName(java.lang.String userName)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

isECRControlRecorded

boolean isECRControlRecorded(java.lang.String employeeId)
                             throws java.lang.Exception
Throws:
java.lang.Exception

findECRControlByUserName

java.util.Collection<ECRReviewVO> findECRControlByUserName(java.lang.String userNameLike,
                                                           int firstIndex,
                                                           int maxLength)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getECRControlCountByUserName

int getECRControlCountByUserName(java.lang.String userNameLike)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

addECRControl

ECRReviewVO addECRControl(java.lang.String employeeId)
                          throws java.lang.Exception
Throws:
java.lang.Exception

updateECRControl

void updateECRControl(ECRReviewVO vo)
                      throws java.lang.Exception
Throws:
java.lang.Exception

deleteECRControl

void deleteECRControl(java.lang.String employeeId)
                      throws java.lang.Exception
Throws:
java.lang.Exception

getPartToAuditFlagResultsForDrawing

java.util.Collection<PartToAuditFlagResult> getPartToAuditFlagResultsForDrawing(java.lang.String pnLike)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

auditPartDwgFlag

void auditPartDwgFlag(java.util.HashSet<BB2Part> bb2Parts)
                      throws java.lang.Exception
Throws:
java.lang.Exception

findMismatchedPartDrawingWithPartInfoResults

java.util.Collection<PartDwfWithPartInfoResult> findMismatchedPartDrawingWithPartInfoResults(java.lang.String partFrom,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getMismatchedPartDrawingWithPartInfoResultsCount

int getMismatchedPartDrawingWithPartInfoResultsCount(java.lang.String partFrom)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getPartInventoryByPk

PartInventoryVO getPartInventoryByPk(PartPK partPk)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findPartVendorsByPartPk

java.util.Collection<PartVendorVO> findPartVendorsByPartPk(PartPK partPk)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

InitPartVendorVoByAddressId

PartVendorVO InitPartVendorVoByAddressId(PartPK partPk,
                                         java.lang.String vendorId)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

updatePartVendor

java.util.Collection<PartVendorVO> updatePartVendor(java.util.HashSet partVendorVoSet,
                                                    PartPK partPk)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

addPartVendor

PartVendorVO addPartVendor(PartVendorVO vo)
                           throws java.lang.Exception
Throws:
java.lang.Exception

updatePartVendor

PartVendorVO updatePartVendor(PartVendorVO vo)
                              throws java.lang.Exception
Throws:
java.lang.Exception

InitPartManufacturerVoByAddressId

PartManufacturerVO InitPartManufacturerVoByAddressId(PartPK partPk,
                                                     java.lang.String manufacturerId)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

findPartManufacturersByPartPk

java.util.Collection<PartManufacturerVO> findPartManufacturersByPartPk(PartPK partPk)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

updatePartManufacturer

java.util.Collection<PartManufacturerVO> updatePartManufacturer(java.util.HashSet partManufacturerSet,
                                                                PartPK partPk)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

isManufacturerPartExistent

boolean isManufacturerPartExistent(java.lang.String mfgName,
                                   java.lang.String mpn)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

getManufacturerPartNoMfgExistent

java.lang.String getManufacturerPartNoMfgExistent(java.lang.String mfgName,
                                                  PartPK partPk)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

findPartPKByMpn

java.util.List<PartVO> findPartPKByMpn(java.lang.String mpn)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

addPartMaterial

PartMaterialVO addPartMaterial(PartPK partPk)
                               throws java.lang.Exception
Throws:
java.lang.Exception

updatePartMaterial

PartMaterialVO updatePartMaterial(PartMaterialVO partMaterialVo)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

copyPartMaterial

PartMaterialVO copyPartMaterial(PartPK partPk,
                                PartMaterialVO vo)
                                throws java.lang.Exception
Throws:
java.lang.Exception

getPartMaterialByPk

PartMaterialVO getPartMaterialByPk(PartPK partPk)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

deletePartMaterial

void deletePartMaterial(PartPK partPk)
                        throws java.lang.Exception
Throws:
java.lang.Exception

findPartMaterialByPartLike

java.util.Collection<PartMaterialListResult> findPartMaterialByPartLike(PartPK partPk,
                                                                        int firstIndex,
                                                                        int maxLength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getPartMaterialCountByPartLike

int getPartMaterialCountByPartLike(PartPK partPk)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

isPartMaterialExist

boolean isPartMaterialExist(PartPK partPk)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findPartMaterial

java.util.Collection<PartMaterialListResult> findPartMaterial(PartMaterialReportAgent agent,
                                                              int firstIndex,
                                                              int maxLength)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getPartMaterialCount

int getPartMaterialCount(PartMaterialReportAgent agent)
                         throws java.lang.Exception
Throws:
java.lang.Exception

getPartMaterialInfo

PartMaterialListResult getPartMaterialInfo(PartPK pk)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

findPartMaterialBomListResults

java.util.Collection<PartMaterialBomListResult> findPartMaterialBomListResults(java.lang.String billNumber,
                                                                               java.lang.String billType,
                                                                               int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getPartMaterialBomListResultsCount

int getPartMaterialBomListResultsCount(java.lang.String billNumber,
                                       java.lang.String billType)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

getPartMaterialWhereUsedResult

PartMaterialWhereUsedResult getPartMaterialWhereUsedResult(PartPK pk)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getBillWhereUsedResults

java.util.Collection<BillWhereUsedResult> getBillWhereUsedResults(java.util.ArrayList<PartPK> pkList,
                                                                  BillPK billPk)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getBillWhereUsedResult

BillWhereUsedResult getBillWhereUsedResult(PartPK pk,
                                           BillPK billPk)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

findSalesBillItemWithPartInfoByBillPk

java.util.Collection<BillItemSalesCostResult> findSalesBillItemWithPartInfoByBillPk(BillPK billPk,
                                                                                java.lang.String languageCode,
                                                                                boolean needMfg)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getBillSalesXResult

BillSalesXResult getBillSalesXResult(BillPK pk,
                                     java.lang.String languageCode)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

getBillSalesResult

BillSalesResult getBillSalesResult(BillPK pk)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

getBB2PartDescription

java.lang.String getBB2PartDescription(BB2Part part,
                                       java.lang.String language)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

addVendorQtyPrice

void addVendorQtyPrice(VendorQtyPriceVO vo)
                       throws java.lang.Exception
Throws:
java.lang.Exception

updateVendorQtyPrice

void updateVendorQtyPrice(VendorQtyPriceVO vo)
                          throws java.lang.Exception
Throws:
java.lang.Exception

deleteVendorQtyPrice

void deleteVendorQtyPrice(VendorQtyPricePK pk)
                          throws java.lang.Exception
Throws:
java.lang.Exception

deleteVendorQtyPrices

void deleteVendorQtyPrices(BB2Part pk,
                           java.lang.String vendorId)
                           throws java.lang.Exception
Throws:
java.lang.Exception

getVendorQtyPrice

VendorQtyPriceVO getVendorQtyPrice(VendorQtyPricePK pk)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

getVendorQtyPrices

java.util.Collection<VendorQtyPriceVO> getVendorQtyPrices(BB2Part pk,
                                                          java.lang.String vendorId)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

resetBB2PartAvgCost

void resetBB2PartAvgCost(BB2Part part)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findPartBasicInfoToRollUP

java.util.Collection<PartBasicInfo> findPartBasicInfoToRollUP(java.lang.String bill,
                                                              int firstIndex,
                                                              int maxLength)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

findPartBasicInfoToRollUP

java.util.Collection<PartBasicInfo> findPartBasicInfoToRollUP(java.lang.String bill,
                                                              java.lang.String bnType,
                                                              int firstIndex,
                                                              int maxLength)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getPartBasicInfoToRollUPCount

int getPartBasicInfoToRollUPCount(java.lang.String bill)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

getPartBasicInfoToRollUPCount

int getPartBasicInfoToRollUPCount(java.lang.String bill,
                                  java.lang.String bnType)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

getBillPKsToRollUP

java.util.Collection<BillPK> getBillPKsToRollUP(java.lang.String bill,
                                                boolean root)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

getFullBOMTreeRollUPMap

BOMTreeRollUPMap getFullBOMTreeRollUPMap(BillPK pk)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

getPartsToRollUPunder

java.util.Collection<RollUPPartStandardCostResult> getPartsToRollUPunder(BillPK pk)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

rollupPartStandardCost

java.util.Collection<PartPK> rollupPartStandardCost(PartPK pk)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getPartToAuditFlagResultsForWI

java.util.Collection<PartToAuditFlagResult> getPartToAuditFlagResultsForWI(java.lang.String pnLike)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

auditPartWIFlag

void auditPartWIFlag(java.util.HashSet<PartPK> partPKs)
                     throws java.lang.Exception
Throws:
java.lang.Exception

findPartDwgLog

java.util.Collection<LogPartDwgVO> findPartDwgLog(java.lang.String partNumber,
                                                  java.lang.String partType,
                                                  java.lang.String partFrom,
                                                  java.lang.String action,
                                                  java.lang.String operator,
                                                  java.lang.String wanIp,
                                                  java.lang.String lanIp,
                                                  java.lang.String macAddress,
                                                  java.lang.String description,
                                                  java.util.Date dateFrom,
                                                  java.util.Date dateTo,
                                                  int firstIndex,
                                                  int maxLength)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getPartDwgLogCount

int getPartDwgLogCount(java.lang.String partNumber,
                       java.lang.String partType,
                       java.lang.String partFrom,
                       java.lang.String action,
                       java.lang.String operator,
                       java.lang.String wanIp,
                       java.lang.String lanIp,
                       java.lang.String macAddress,
                       java.lang.String description,
                       java.util.Date dateFrom,
                       java.util.Date dateTo)
                       throws java.lang.Exception
Throws:
java.lang.Exception

isPartDwgExist

boolean isPartDwgExist(PartDwgPK pk)
                       throws java.lang.Exception
Throws:
java.lang.Exception

findPartDwg

java.util.Collection<PartDwgWithPartInfoResult> findPartDwg(java.lang.String pnLike,
                                                            java.lang.String partType,
                                                            java.lang.String partFrom,
                                                            java.lang.String description,
                                                            int firstIndex,
                                                            int maxLength)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getPartDwgCount

int getPartDwgCount(java.lang.String pnLike,
                    java.lang.String partType,
                    java.lang.String partFrom,
                    java.lang.String description)
                    throws java.lang.Exception
Throws:
java.lang.Exception

getPartDwgWithPartInfoResult

PartDwgWithPartInfoResult getPartDwgWithPartInfoResult(PartDwgPK pk)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

upLoadDWG

void upLoadDWG(java.lang.String partFrom,
               java.lang.String key)
               throws java.lang.Exception
Throws:
java.lang.Exception

downLoadDWG

void downLoadDWG(java.lang.String log)
                 throws java.lang.Exception
Throws:
java.lang.Exception

deleteFtpDWG

void deleteFtpDWG(PartDwgAgent agent)
                  throws java.lang.Exception
Throws:
java.lang.Exception

findPartDwfLog

java.util.Collection<LogPartDwfVO> findPartDwfLog(java.lang.String partNumber,
                                                  java.lang.String partType,
                                                  java.lang.String partFrom,
                                                  java.lang.String action,
                                                  java.lang.String operator,
                                                  java.lang.String wanIp,
                                                  java.lang.String lanIp,
                                                  java.lang.String macAddress,
                                                  java.lang.String description,
                                                  java.util.Date dateFrom,
                                                  java.util.Date dateTo,
                                                  int firstIndex,
                                                  int maxLength)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getPartDwfLogCount

int getPartDwfLogCount(java.lang.String partNumber,
                       java.lang.String partType,
                       java.lang.String partFrom,
                       java.lang.String action,
                       java.lang.String operator,
                       java.lang.String wanIp,
                       java.lang.String lanIp,
                       java.lang.String macAddress,
                       java.lang.String description,
                       java.util.Date dateFrom,
                       java.util.Date dateTo)
                       throws java.lang.Exception
Throws:
java.lang.Exception

isPartDwfExist

boolean isPartDwfExist(PartDwfPK pk)
                       throws java.lang.Exception
Throws:
java.lang.Exception

findPartDwf

java.util.Collection<PartDwfWithPartInfoResult> findPartDwf(java.lang.String pnLike,
                                                            java.lang.String partType,
                                                            java.lang.String partFrom,
                                                            java.lang.String description,
                                                            boolean onlyShowMissmatchedDWF,
                                                            int firstIndex,
                                                            int maxLength)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getPartDwfCount

int getPartDwfCount(java.lang.String pnLike,
                    java.lang.String partType,
                    java.lang.String partFrom,
                    java.lang.String description,
                    boolean onlyShowMissmatchedDWF)
                    throws java.lang.Exception
Throws:
java.lang.Exception

getPartDwfWithPartInfoResult

PartDwfWithPartInfoResult getPartDwfWithPartInfoResult(PartDwfPK pk)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

uploadFtpDWF

void uploadFtpDWF(PartDwfAgent agent)
                  throws java.lang.Exception
Throws:
java.lang.Exception

downloadFtpDWF

byte[] downloadFtpDWF(PartDwfAgent agent)
                      throws java.lang.Exception
Throws:
java.lang.Exception

downloadFtpDWFForView

byte[] downloadFtpDWFForView(PartDwfAgent agent)
                             throws java.lang.Exception
Throws:
java.lang.Exception

deleteFtpDWF

void deleteFtpDWF(PartDwfAgent agent)
                  throws java.lang.Exception
Throws:
java.lang.Exception

findDwfDrawingByPartPk

java.util.Collection<PartDwfWithPartInfoResult> findDwfDrawingByPartPk(PartPK pk,
                                                                       java.lang.String partFrom,
                                                                       int firstIndex,
                                                                       int maxLength)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getDwfDrawingCountByPartPk

int getDwfDrawingCountByPartPk(PartPK pk,
                               java.lang.String partFrom)
                               throws java.lang.Exception
Throws:
java.lang.Exception

addUnit

UnitVO addUnit(UnitVO vo)
               throws java.lang.Exception
Throws:
java.lang.Exception

deleteUnit

void deleteUnit(UnitVO vo)
                throws java.lang.Exception
Throws:
java.lang.Exception

updateUnit

UnitVO updateUnit(UnitVO vo)
                  throws java.lang.Exception
Throws:
java.lang.Exception

getUnitByPk

UnitVO getUnitByPk(java.lang.Long id)
                   throws java.lang.Exception
Throws:
java.lang.Exception

isUnitExist

boolean isUnitExist(java.lang.String unitName)
                    throws java.lang.Exception
Throws:
java.lang.Exception

findUnit

java.util.Collection<UnitVO> findUnit(java.lang.String unitName,
                                      int firstIndex,
                                      int maxLength)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

getUnitsCount

int getUnitsCount(java.lang.String unitName)
                  throws java.lang.Exception
Throws:
java.lang.Exception

addEngineeringSharing

EngineeringSharingVO addEngineeringSharing(EngineeringSharingVO vo)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

updateEngineeringSharing

void updateEngineeringSharing(EngineeringSharingVO vo)
                              throws java.lang.Exception
Throws:
java.lang.Exception

deletedEngineeringSharing

void deletedEngineeringSharing(java.lang.String addressId)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getEngineeringSharingsById

EngineeringSharingVO getEngineeringSharingsById(java.lang.String addressId)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

findEngineeringSharingsByCompanyId

java.util.Collection<EngineeringSharingVO> findEngineeringSharingsByCompanyId(java.lang.String companyId,
                                                                              int firstIndex,
                                                                              int maxLength)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getEngineeringSharingByCompanyIdCount

int getEngineeringSharingByCompanyIdCount(java.lang.String addressId)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

findEngineeringSharingsByCompanyName

java.util.Collection<EngineeringSharingVO> findEngineeringSharingsByCompanyName(java.lang.String companyName,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getEngineeringSharingByCompanyNameCount

int getEngineeringSharingByCompanyNameCount(java.lang.String companyName)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

addEngineeringSharingItem

EngineeringSharingItemVO addEngineeringSharingItem(EngineeringSharingItemVO vo)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

addEngineeringSharingItems

void addEngineeringSharingItems(java.util.ArrayList<PartPK> pks,
                                java.lang.String id)
                                throws java.lang.Exception
Throws:
java.lang.Exception

updateEngineeringSharingItem

void updateEngineeringSharingItem(EngineeringSharingItemVO vo)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

deletedEngineeringSharingItem

void deletedEngineeringSharingItem(EngineeringSharingItemPK pk)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

getEngineeringSharingItemByPk

EngineeringSharingItemVO getEngineeringSharingItemByPk(EngineeringSharingItemPK pk)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

findEngineeringSharingItemByCompanyId

java.util.Collection<EngineeringSharingItemVO> findEngineeringSharingItemByCompanyId(java.lang.String addressId,
                                                                                java.lang.String partNumber,
                                                                                java.lang.String partType,
                                                                                java.lang.String languageCode,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getEngineeringSharingItemByCompanyIdCount

int getEngineeringSharingItemByCompanyIdCount(java.lang.String addressId,
                                              java.lang.String partNumber,
                                              java.lang.String partType)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

isEngineeringSharingItemExist

boolean isEngineeringSharingItemExist(EngineeringSharingItemPK pk)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

addEngineeringSharingItemsByPart

void addEngineeringSharingItemsByPart(java.lang.String fPn,
                                      java.lang.String tPn,
                                      java.lang.String pType,
                                      java.lang.String addressId,
                                      java.lang.String engGroup)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

deleteEngineeringSharingItemByCompanyId

void deleteEngineeringSharingItemByCompanyId(java.lang.String addressId)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

deletedBatchEngineeringSharingItem

void deletedBatchEngineeringSharingItem(java.util.ArrayList<EngineeringSharingItemPK> pkList)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findPartsByEngineeringSharingRule

java.util.Collection<PartBasicInfo> findPartsByEngineeringSharingRule(java.lang.String companyId,
                                                                      int firstIndex,
                                                                      int maxLength)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getPartsCountByEngineeringSharingRule

int getPartsCountByEngineeringSharingRule(java.lang.String companyId)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

findAllEngGroupId

java.util.Collection<java.lang.String> findAllEngGroupId()
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

findEngSharingPartsByPnAndEngGroup

java.util.Collection<PartBasicInfo> findEngSharingPartsByPnAndEngGroup(java.lang.String partFrom,
                                                                       java.lang.String partTo,
                                                                       java.lang.String partType,
                                                                       java.lang.String engGroup,
                                                                       int firstIndex,
                                                                       int maxLength)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getEngSharingPartsCountByPnAndengGroup

int getEngSharingPartsCountByPnAndengGroup(java.lang.String partFrom,
                                           java.lang.String partTo,
                                           java.lang.String partType,
                                           java.lang.String engGroup)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

findAllEngGroupId

java.util.Collection<java.lang.String> findAllEngGroupId(boolean containImport)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

addEngGroupUser

EngGroupUserVO addEngGroupUser(EngGroupUserVO vo)
                               throws java.lang.Exception
Throws:
java.lang.Exception

updateEngGroupUser

void updateEngGroupUser(EngGroupUserVO vo)
                        throws java.lang.Exception
Throws:
java.lang.Exception

deleteEngGroupUser

void deleteEngGroupUser(EngGroupUserPK pk)
                        throws java.lang.Exception
Throws:
java.lang.Exception

getEngGroupUserByPk

EngGroupUserVO getEngGroupUserByPk(EngGroupUserPK pk)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

isEngGroupUserExist

boolean isEngGroupUserExist(EngGroupUserPK pk)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findEngGroupUserByEmployeeId

java.util.Collection<EngGroupUserVO> findEngGroupUserByEmployeeId(java.lang.String engGroupId,
                                                                  java.lang.String empId,
                                                                  int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getEngGroupUserCountByEmpoyeeId

int getEngGroupUserCountByEmpoyeeId(java.lang.String engGroupId,
                                    java.lang.String empId)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

isCurrentUserHasEngGroupPermission

boolean isCurrentUserHasEngGroupPermission(PartPK pk)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

uploadOrUpdateFTPECDoc

java.util.Collection<EngineeringChangeDocumentVO> uploadOrUpdateFTPECDoc(MiscDocAgent agent)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

downloadFTPECDoc

byte[] downloadFTPECDoc(MiscDocAgent agent)
                        throws java.lang.Exception
Throws:
java.lang.Exception

deleteFTPECDoc

java.util.Collection<EngineeringChangeDocumentVO> deleteFTPECDoc(MiscDocAgent agent)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getEngineeringChangeDocumentByID

EngineeringChangeDocumentVO getEngineeringChangeDocumentByID(java.lang.Long controlNumber)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

uploadOrUpdateFTPECRDoc

java.util.Collection<EngineeringChangeRequestDocumentVO> uploadOrUpdateFTPECRDoc(MiscDocAgent agent)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

downloadFTPECRDoc

byte[] downloadFTPECRDoc(MiscDocAgent agent)
                         throws java.lang.Exception
Throws:
java.lang.Exception

deleteFTPECRDoc

java.util.Collection<EngineeringChangeRequestDocumentVO> deleteFTPECRDoc(MiscDocAgent agent)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getEngineeringChangeRequestDocumentByID

EngineeringChangeRequestDocumentVO getEngineeringChangeRequestDocumentByID(java.lang.Long controlNumber)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

addPartCatagory

PartCatagoryVO addPartCatagory(PartCatagoryVO vo)
                               throws java.lang.Exception
Throws:
java.lang.Exception

updatePartCatagory

void updatePartCatagory(PartCatagoryVO vo)
                        throws java.lang.Exception
Throws:
java.lang.Exception

deletePartCatagory

void deletePartCatagory(PartCatagoryPK pk)
                        throws java.lang.Exception
Throws:
java.lang.Exception

getPartCatagoryByPk

PartCatagoryVO getPartCatagoryByPk(PartCatagoryPK pk)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

deletePartCatagory

void deletePartCatagory(java.lang.String bigCatagory)
                        throws java.lang.Exception
Throws:
java.lang.Exception

findAllPartCatagorys

java.util.Collection<PartCatagoryVO> findAllPartCatagorys()
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

findAllBigCatagorys

java.util.Collection<java.lang.String> findAllBigCatagorys()
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

findAllSmallCatagorys

java.util.Collection<java.lang.String> findAllSmallCatagorys(java.lang.String bigCatagory)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

findNotBillPartsWithOnhandInfo

java.util.Collection<PartOnHandWithPartBasicInfoResult> findNotBillPartsWithOnhandInfo(java.lang.String partNumber,
                                                                                java.lang.String partDescription,
                                                                                java.lang.String partType,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getNotBillPartsWithOnhandInfoCount

int getNotBillPartsWithOnhandInfoCount(java.lang.String partNumber,
                                       java.lang.String partDescription,
                                       java.lang.String partType)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findInBillPartsWithOnhandInfo

java.util.Collection<PartOnHandWithPartBasicInfoResult> findInBillPartsWithOnhandInfo(java.lang.String partNumber,
                                                                                java.lang.String partDescription,
                                                                                java.lang.String partType,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getInBillPartsWithOnhandInfoCount

int getInBillPartsWithOnhandInfoCount(java.lang.String partNumber,
                                      java.lang.String partDescription,
                                      java.lang.String partType)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

getEngineeringChangesCountByStatus

int getEngineeringChangesCountByStatus(java.lang.String status)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findEngineeringChangeByStatus

java.util.Collection<EngineeringChangeListResult> findEngineeringChangeByStatus(java.lang.String status,
                                                                                java.lang.String languageCode,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findAllPartsWithOnhandInfo

java.util.Collection<PartOnHandWithPartBasicInfoResult> findAllPartsWithOnhandInfo(java.lang.String fPn,
                                                                                java.lang.String tPn,
                                                                                java.lang.String partType,
                                                                                java.lang.String descLike,
                                                                                java.lang.String modelNumLike,
                                                                                java.lang.String commodityCodeLike,
                                                                                java.lang.String productCodeLike,
                                                                                java.lang.String language,
                                                                                java.lang.String makeBuy,
                                                                                boolean posOnhand,
                                                                                boolean onlyShowFlushMaterial,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllPartsWithOnhandInfoCount

int getAllPartsWithOnhandInfoCount(java.lang.String fPn,
                                   java.lang.String tPn,
                                   java.lang.String partType,
                                   java.lang.String descLike,
                                   java.lang.String modelNumLike,
                                   java.lang.String commodityCodeLike,
                                   java.lang.String productCodeLike,
                                   java.lang.String language,
                                   java.lang.String makeBuy,
                                   boolean onlyShowFlushMaterial)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findPartDwfFullMatch

java.util.Collection<PartDwfWithPartInfoResult> findPartDwfFullMatch(java.lang.String pnLike,
                                                                     java.lang.String partType,
                                                                     java.lang.String partFrom,
                                                                     java.lang.String description,
                                                                     boolean onlyShowMissmatchedDWF,
                                                                     int firstIndex,
                                                                     int maxLength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getPartDwfCountFullMatch

int getPartDwfCountFullMatch(java.lang.String pnLike,
                             java.lang.String partType,
                             java.lang.String partFrom,
                             java.lang.String description,
                             boolean onlyShowMissmatchedDWF)
                             throws java.lang.Exception
Throws:
java.lang.Exception

findEngineeringSharingImportLogs

java.util.Collection<EngineeringSharingImportLogVO> findEngineeringSharingImportLogs(java.lang.String partNumber,
                                                                                java.lang.String partType,
                                                                                java.util.Date startDate,
                                                                                java.util.Date endDate,
                                                                                java.lang.String status,
                                                                                java.lang.String importType,
                                                                                java.lang.String importDataType,
                                                                                java.lang.String ecnNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getEngineeringSharingImportLogsCount

int getEngineeringSharingImportLogsCount(java.lang.String partNumber,
                                         java.lang.String partType,
                                         java.util.Date startDate,
                                         java.util.Date endDate,
                                         java.lang.String status,
                                         java.lang.String importType,
                                         java.lang.String importDataType,
                                         java.lang.String ecnNumber)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

reviewEngineeringSharingImportLog

void reviewEngineeringSharingImportLog(EngineeringSharingImportLogVO vo)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

isExistentNotUniqueMpn

boolean isExistentNotUniqueMpn()
                               throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EngineeringChangeDocumentVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EngineeringChangeDocumentVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.EngineeringChangeDocumentVO
All Implemented Interfaces:
java.io.Serializable
public class EngineeringChangeDocumentVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
EngineeringChangeDocumentVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.lang.String | getDocDescription()
java.lang.String | getDocFileName()
long | getDocLength()
java.util.Date | getDocumentDate()
java.lang.String | getEngineeringChangeNumber()
java.lang.String | getExtension()
java.lang.Long | getIi()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
int | hashCode()
void | setComments(java.lang.String comments)
void | setDocDescription(java.lang.String docDescription)
void | setDocFileName(java.lang.String docFileName)
void | setDocLength(long docLength)
void | setDocumentDate(java.util.Date documentDate)
void | setEngineeringChangeNumber(java.lang.String engineeringChangeNumber)
void | setExtension(java.lang.String extension)
void | setIi(java.lang.Long ii)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

EngineeringChangeDocumentVO

public EngineeringChangeDocumentVO()
default constructor

Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getDocDescription

public java.lang.String getDocDescription()

setDocDescription

public void setDocDescription(java.lang.String docDescription)

getDocumentDate

public java.util.Date getDocumentDate()

setDocumentDate

public void setDocumentDate(java.util.Date documentDate)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

getDocFileName

public java.lang.String getDocFileName()

setDocFileName

public void setDocFileName(java.lang.String docFileName)

getDocLength

public long getDocLength()

setDocLength

public void setDocLength(long docLength)

getEngineeringChangeNumber

public java.lang.String getEngineeringChangeNumber()

setEngineeringChangeNumber

public void setEngineeringChangeNumber(java.lang.String engineeringChangeNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EngineeringChangeListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EngineeringChangeListResult

java.lang.Object
    extended by  bb.common.EngineeringChangeListResult
All Implemented Interfaces:
java.io.Serializable
public class EngineeringChangeListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DUEDATE
static java.lang.String | ORDER_BY_ECNDESCRIPTION
static java.lang.String | ORDER_BY_ECNNUMBER
static java.lang.String | ORDER_BY_ENGINEERINGCHANGEDATE
static java.lang.String | ORDER_BY_ORIGINATOR
static java.lang.String | ORDER_BY_PARTDESCRIPTION
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
EngineeringChangeListResult()
Method Summary
java.util.Date | getDueDate()
java.lang.String | getEcnDescription()
java.lang.String | getEcnNumber()
java.util.Date | getEngineeringChangeDate()
java.lang.String | getImportCompanyId()
java.lang.String | getImportEcnNumber()
java.lang.String | getNewRevision()
java.lang.String | getOldRevision()
java.lang.String | getOriginator()
java.lang.String | getPartDescription()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.lang.String | getStatus()
void | setDueDate(java.util.Date dueDate)
void | setEcnDescription(java.lang.String ecnDescription)
void | setEcnNumber(java.lang.String ecnNumber)
void | setEngineeringChangeDate(java.util.Date engineeringChangeDate)
void | setImportCompanyId(java.lang.String importCompanyId)
void | setImportEcnNumber(java.lang.String importEcnNumber)
void | setNewRevision(java.lang.String newRevision)
void | setOldRevision(java.lang.String oldRevision)
void | setOriginator(java.lang.String originator)
void | setPartDescription(java.lang.String partDescription)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setStatus(java.lang.String status)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_ECNNUMBER

public static final java.lang.String ORDER_BY_ECNNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTDESCRIPTION

public static final java.lang.String ORDER_BY_PARTDESCRIPTION
See Also:
Constant Field Values

ORDER_BY_ECNDESCRIPTION

public static final java.lang.String ORDER_BY_ECNDESCRIPTION
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_ORIGINATOR

public static final java.lang.String ORDER_BY_ORIGINATOR
See Also:
Constant Field Values

ORDER_BY_DUEDATE

public static final java.lang.String ORDER_BY_DUEDATE
See Also:
Constant Field Values

ORDER_BY_ENGINEERINGCHANGEDATE

public static final java.lang.String ORDER_BY_ENGINEERINGCHANGEDATE
See Also:
Constant Field Values
Constructor Detail

EngineeringChangeListResult

public EngineeringChangeListResult()
Method Detail

getStatus

public java.lang.String getStatus()

getOldRevision

public java.lang.String getOldRevision()

getNewRevision

public java.lang.String getNewRevision()

getEcnDescription

public java.lang.String getEcnDescription()

getEcnNumber

public java.lang.String getEcnNumber()

getPartDescription

public java.lang.String getPartDescription()

setPartPk

public void setPartPk(PartPK partPk)

setStatus

public void setStatus(java.lang.String status)

setOldRevision

public void setOldRevision(java.lang.String oldRevision)

setNewRevision

public void setNewRevision(java.lang.String newRevision)

setEcnDescription

public void setEcnDescription(java.lang.String ecnDescription)

setEcnNumber

public void setEcnNumber(java.lang.String ecnNumber)

setPartDescription

public void setPartDescription(java.lang.String partDescription)

setDueDate

public void setDueDate(java.util.Date dueDate)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartPk

public PartPK getPartPk()

getDueDate

public java.util.Date getDueDate()

getPartFrom

public java.lang.String getPartFrom()

getOriginator

public java.lang.String getOriginator()

setOriginator

public void setOriginator(java.lang.String originator)

getImportCompanyId

public java.lang.String getImportCompanyId()

setImportCompanyId

public void setImportCompanyId(java.lang.String importCompanyId)

getImportEcnNumber

public java.lang.String getImportEcnNumber()

setImportEcnNumber

public void setImportEcnNumber(java.lang.String importEcnNumber)

getEngineeringChangeDate

public java.util.Date getEngineeringChangeDate()

setEngineeringChangeDate

public void setEngineeringChangeDate(java.util.Date engineeringChangeDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EngineeringChangeRequestDocumentVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EngineeringChangeRequestDocumentVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.EngineeringChangeRequestDocumentVO
All Implemented Interfaces:
java.io.Serializable
public class EngineeringChangeRequestDocumentVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
EngineeringChangeRequestDocumentVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.lang.String | getDocDescription()
java.lang.String | getDocFileName()
long | getDocLength()
java.util.Date | getDocumentDate()
java.lang.String | getEngineeringChangeRequestNumber()
java.lang.String | getExtension()
java.lang.Long | getIi()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
int | hashCode()
void | setComments(java.lang.String comments)
void | setDocDescription(java.lang.String docDescription)
void | setDocFileName(java.lang.String docFileName)
void | setDocLength(long docLength)
void | setDocumentDate(java.util.Date documentDate)
void | setEngineeringChangeRequestNumber(java.lang.String engineeringChangeRequestNumber)
void | setExtension(java.lang.String extension)
void | setIi(java.lang.Long ii)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

EngineeringChangeRequestDocumentVO

public EngineeringChangeRequestDocumentVO()
default constructor

Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getDocDescription

public java.lang.String getDocDescription()

setDocDescription

public void setDocDescription(java.lang.String docDescription)

getDocumentDate

public java.util.Date getDocumentDate()

setDocumentDate

public void setDocumentDate(java.util.Date documentDate)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

getDocFileName

public java.lang.String getDocFileName()

setDocFileName

public void setDocFileName(java.lang.String docFileName)

getDocLength

public long getDocLength()

setDocLength

public void setDocLength(long docLength)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getEngineeringChangeRequestNumber

public java.lang.String getEngineeringChangeRequestNumber()

setEngineeringChangeRequestNumber

public void setEngineeringChangeRequestNumber(java.lang.String engineeringChangeRequestNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EngineeringChangeRequestListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EngineeringChangeRequestListResult

java.lang.Object
    extended by  bb.common.EngineeringChangeRequestListResult
All Implemented Interfaces:
java.io.Serializable
public class EngineeringChangeRequestListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CLOSEOUTPRIVATENOTES
static java.lang.String | ORDER_BY_DISPOSITIONOFCHANGE
static java.lang.String | ORDER_BY_DUEDATE
static java.lang.String | ORDER_BY_ECRDESCRIPTION
static java.lang.String | ORDER_BY_ECRENGINEER
static java.lang.String | ORDER_BY_ECRNUMBER
static java.lang.String | ORDER_BY_ECRPRIORITY
static java.lang.String | ORDER_BY_ORIGINATOR
static java.lang.String | ORDER_BY_PARTDESCRIPTION
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
EngineeringChangeRequestListResult()
Method Summary
java.lang.String | getClosedOutPrivateNotes()
java.lang.String | getDispositionOfChange()
java.util.Date | getDueDate()
java.lang.String | getEcrDescription()
java.lang.String | getEcrEngineer()
java.lang.String | getEcrNumber()
java.lang.String | getEcrPriority()
java.lang.String | getOriginator()
java.lang.String | getPartDescription()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.lang.String | getStatus()
void | setClosedOutPrivateNotes(java.lang.String closedOutPrivateNotes)
void | setDispositionOfChange(java.lang.String dispositionOfChange)
void | setDueDate(java.util.Date dueDate)
void | setEcrDescription(java.lang.String ecrDescription)
void | setEcrEngineer(java.lang.String ecrEngineer)
void | setEcrNumber(java.lang.String ecrNumber)
void | setEcrPriority(java.lang.String ecrPriority)
void | setOriginator(java.lang.String originator)
void | setPartDescription(java.lang.String partDescription)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setStatus(java.lang.String status)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_PARTDESCRIPTION

public static final java.lang.String ORDER_BY_PARTDESCRIPTION
See Also:
Constant Field Values

ORDER_BY_ECRNUMBER

public static final java.lang.String ORDER_BY_ECRNUMBER
See Also:
Constant Field Values

ORDER_BY_ECRDESCRIPTION

public static final java.lang.String ORDER_BY_ECRDESCRIPTION
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_DUEDATE

public static final java.lang.String ORDER_BY_DUEDATE
See Also:
Constant Field Values

ORDER_BY_ECRENGINEER

public static final java.lang.String ORDER_BY_ECRENGINEER
See Also:
Constant Field Values

ORDER_BY_ORIGINATOR

public static final java.lang.String ORDER_BY_ORIGINATOR
See Also:
Constant Field Values

ORDER_BY_CLOSEOUTPRIVATENOTES

public static final java.lang.String ORDER_BY_CLOSEOUTPRIVATENOTES
See Also:
Constant Field Values

ORDER_BY_DISPOSITIONOFCHANGE

public static final java.lang.String ORDER_BY_DISPOSITIONOFCHANGE
See Also:
Constant Field Values

ORDER_BY_ECRPRIORITY

public static final java.lang.String ORDER_BY_ECRPRIORITY
See Also:
Constant Field Values
Constructor Detail

EngineeringChangeRequestListResult

public EngineeringChangeRequestListResult()
Method Detail

getEcrPriority

public java.lang.String getEcrPriority()

setEcrPriority

public void setEcrPriority(java.lang.String ecrPriority)

getClosedOutPrivateNotes

public java.lang.String getClosedOutPrivateNotes()

setClosedOutPrivateNotes

public void setClosedOutPrivateNotes(java.lang.String closedOutPrivateNotes)

getDispositionOfChange

public java.lang.String getDispositionOfChange()

setDispositionOfChange

public void setDispositionOfChange(java.lang.String dispositionOfChange)

getStatus

public java.lang.String getStatus()

getPartDescription

public java.lang.String getPartDescription()

setPartPk

public void setPartPk(PartPK partPk)

setStatus

public void setStatus(java.lang.String status)

setPartDescription

public void setPartDescription(java.lang.String partDescription)

setDueDate

public void setDueDate(java.util.Date dueDate)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setEcrNumber

public void setEcrNumber(java.lang.String ecrNumber)

setEcrDescription

public void setEcrDescription(java.lang.String ecrDescription)

setOriginator

public void setOriginator(java.lang.String originator)

getPartPk

public PartPK getPartPk()

getDueDate

public java.util.Date getDueDate()

getPartFrom

public java.lang.String getPartFrom()

getEcrNumber

public java.lang.String getEcrNumber()

getEcrDescription

public java.lang.String getEcrDescription()

getOriginator

public java.lang.String getOriginator()

getEcrEngineer

public java.lang.String getEcrEngineer()

setEcrEngineer

public void setEcrEngineer(java.lang.String ecrEngineer)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EngineeringChangeRequestVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EngineeringChangeRequestVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.EngineeringChangeRequestVO
All Implemented Interfaces:
java.io.Serializable
public class EngineeringChangeRequestVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
EngineeringChangeRequestVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getApproved()
java.util.Date | getApprovedDate()
java.lang.String | getChangedByEngineer()
java.util.Date | getClosedOutDate()
java.lang.String | getClosedOutPrivateNotes()
java.lang.String | getDescription()
java.lang.String | getDispositionOfChange()
java.util.Date | getDueDate()
java.util.Date | getEcrDate()
java.lang.String | getEcrPriority()
java.lang.String | getEngineeringChangeNoticeNumber()
java.util.Set | getEngineeringChangeRequestDocuments()
java.lang.String | getEngineeringChangeRequestNumber()
java.util.Date | getLastChangeDate()
java.lang.String | getLastUser()
java.lang.String | getOriginator()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getRevision()
java.lang.String | getStatus()
java.lang.Integer | getVersion()
int | hashCode()
void | setApproved(java.lang.String approved)
void | setApprovedDate(java.util.Date approvedDate)
void | setChangedByEngineer(java.lang.String changedByEngineer)
void | setClosedOutDate(java.util.Date closedOutDate)
void | setClosedOutPrivateNotes(java.lang.String closedOutPrivateNotes)
void | setDescription(java.lang.String description)
void | setDispositionOfChange(java.lang.String dispositionOfChange)
void | setDueDate(java.util.Date dueDate)
void | setEcrDate(java.util.Date ecrDate)
void | setEcrPriority(java.lang.String ecrPriority)
void | setEngineeringChangeNoticeNumber(java.lang.String engineeringChangeNoticeNumber)
void | setEngineeringChangeRequestDocuments(java.util.Set engineeringChangeRequestDocuments)
void | setEngineeringChangeRequestNumber(java.lang.String engineeringChangeRequestNumber)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastUser(java.lang.String lastUser)
void | setOriginator(java.lang.String originator)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setRevision(java.lang.String revision)
void | setStatus(java.lang.String status)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

EngineeringChangeRequestVO

public EngineeringChangeRequestVO()
default constructor

Method Detail

getEngineeringChangeRequestNumber

public java.lang.String getEngineeringChangeRequestNumber()

setEngineeringChangeRequestNumber

public void setEngineeringChangeRequestNumber(java.lang.String engineeringChangeRequestNumber)

getDueDate

public java.util.Date getDueDate()

setDueDate

public void setDueDate(java.util.Date dueDate)

getLastUser

public java.lang.String getLastUser()

setLastUser

public void setLastUser(java.lang.String lastUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getEcrDate

public java.util.Date getEcrDate()

setEcrDate

public void setEcrDate(java.util.Date ecrDate)

getOriginator

public java.lang.String getOriginator()

setOriginator

public void setOriginator(java.lang.String originator)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getApproved

public java.lang.String getApproved()

setApproved

public void setApproved(java.lang.String approved)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getChangedByEngineer

public java.lang.String getChangedByEngineer()

setChangedByEngineer

public void setChangedByEngineer(java.lang.String changedByEngineer)

getEngineeringChangeNoticeNumber

public java.lang.String getEngineeringChangeNoticeNumber()

setEngineeringChangeNoticeNumber

public void setEngineeringChangeNoticeNumber(java.lang.String engineeringChangeNoticeNumber)

getClosedOutDate

public java.util.Date getClosedOutDate()

setClosedOutDate

public void setClosedOutDate(java.util.Date closedOutDate)

getClosedOutPrivateNotes

public java.lang.String getClosedOutPrivateNotes()

setClosedOutPrivateNotes

public void setClosedOutPrivateNotes(java.lang.String closedOutPrivateNotes)

getDispositionOfChange

public java.lang.String getDispositionOfChange()

getPartFrom

public java.lang.String getPartFrom()

getVersion

public java.lang.Integer getVersion()

setDispositionOfChange

public void setDispositionOfChange(java.lang.String dispositionOfChange)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setVersion

public void setVersion(java.lang.Integer version)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getEngineeringChangeRequestDocuments

public java.util.Set getEngineeringChangeRequestDocuments()

setEngineeringChangeRequestDocuments

public void setEngineeringChangeRequestDocuments(java.util.Set engineeringChangeRequestDocuments)

getApprovedDate

public java.util.Date getApprovedDate()

setApprovedDate

public void setApprovedDate(java.util.Date approvedDate)

getEcrPriority

public java.lang.String getEcrPriority()

setEcrPriority

public void setEcrPriority(java.lang.String ecrPriority)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EngineeringChangeVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EngineeringChangeVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.EngineeringChangeVO
All Implemented Interfaces:
java.io.Serializable
public class EngineeringChangeVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
EngineeringChangeVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getApproved()
java.util.Date | getApprovedDate()
java.lang.String | getDescription()
java.util.Date | getDrawingRevisedDate()
java.util.Date | getDueDate()
java.util.Date | getEffectiveDate()
java.util.Date | getEngineeringChangeDate()
java.util.Set | getEngineeringChangeDocuments()
java.lang.String | getEngineeringChangeNumber()
java.lang.String | getHaveDrawingRevised()
java.lang.String | getImportComment()
java.lang.String | getImportCompany()
java.lang.String | getImportEc()
java.lang.String | getInventoryAction()
java.lang.String | getInventoryModify()
java.lang.String | getInventoryScrap()
java.lang.String | getInventoryUseAsIs()
java.util.Date | getLastChangeDate()
java.lang.String | getLastUser()
java.lang.String | getModelNumber()
java.lang.String | getNewRev()
java.lang.String | getOldRev()
java.lang.String | getOnorderAction()
java.lang.String | getOnorderModify()
java.lang.String | getOnorderScrap()
java.lang.String | getOnorderUseAsIs()
java.lang.String | getOrigin()
java.lang.String | getOriginator()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.lang.String | getStatus()
java.lang.Integer | getVersion()
int | hashCode()
boolean | isHold()
void | setApproved(java.lang.String approved)
void | setApprovedDate(java.util.Date approvedDate)
void | setDescription(java.lang.String description)
void | setDrawingRevisedDate(java.util.Date drawingRevisedDate)
void | setDueDate(java.util.Date dueDate)
void | setEffectiveDate(java.util.Date effectiveDate)
void | setEngineeringChangeDate(java.util.Date engineeringChangeDate)
void | setEngineeringChangeDocuments(java.util.Set engineeringChangeDocuments)
void | setEngineeringChangeNumber(java.lang.String engineeringChangeNumber)
void | setHaveDrawingRevised(java.lang.String haveDrawingRevised)
void | setHold(boolean hold)
void | setImportComment(java.lang.String importComment)
void | setImportCompany(java.lang.String importCompany)
void | setImportEc(java.lang.String importEc)
void | setInventoryAction(java.lang.String inventoryAction)
void | setInventoryModify(java.lang.String inventoryModify)
void | setInventoryScrap(java.lang.String inventoryScrap)
void | setInventoryUseAsIs(java.lang.String inventoryUseAsIs)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastUser(java.lang.String lastUser)
void | setModelNumber(java.lang.String modelNumber)
void | setNewRev(java.lang.String newRev)
void | setOldRev(java.lang.String oldRev)
void | setOnorderAction(java.lang.String onorderAction)
void | setOnorderModify(java.lang.String onorderModify)
void | setOnorderScrap(java.lang.String onorderScrap)
void | setOnorderUseAsIs(java.lang.String onorderUseAsIs)
void | setOrigin(java.lang.String origin)
void | setOriginator(java.lang.String originator)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setStatus(java.lang.String status)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

EngineeringChangeVO

public EngineeringChangeVO()
default constructor

Method Detail

getEngineeringChangeNumber

public java.lang.String getEngineeringChangeNumber()

setEngineeringChangeNumber

public void setEngineeringChangeNumber(java.lang.String engineeringChangeNumber)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getDueDate

public java.util.Date getDueDate()

setDueDate

public void setDueDate(java.util.Date dueDate)

getLastUser

public java.lang.String getLastUser()

setLastUser

public void setLastUser(java.lang.String lastUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getEngineeringChangeDate

public java.util.Date getEngineeringChangeDate()

setEngineeringChangeDate

public void setEngineeringChangeDate(java.util.Date engineeringChangeDate)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getOldRev

public java.lang.String getOldRev()

setOldRev

public void setOldRev(java.lang.String oldRev)

getNewRev

public java.lang.String getNewRev()

setNewRev

public void setNewRev(java.lang.String newRev)

getEffectiveDate

public java.util.Date getEffectiveDate()

setEffectiveDate

public void setEffectiveDate(java.util.Date effectiveDate)

getHaveDrawingRevised

public java.lang.String getHaveDrawingRevised()

setHaveDrawingRevised

public void setHaveDrawingRevised(java.lang.String haveDrawingRevised)

getDrawingRevisedDate

public java.util.Date getDrawingRevisedDate()

setDrawingRevisedDate

public void setDrawingRevisedDate(java.util.Date drawingRevisedDate)

getOriginator

public java.lang.String getOriginator()

setOriginator

public void setOriginator(java.lang.String originator)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getInventoryAction

public java.lang.String getInventoryAction()

setInventoryAction

public void setInventoryAction(java.lang.String inventoryAction)

getInventoryUseAsIs

public java.lang.String getInventoryUseAsIs()

setInventoryUseAsIs

public void setInventoryUseAsIs(java.lang.String inventoryUseAsIs)

getInventoryModify

public java.lang.String getInventoryModify()

setInventoryModify

public void setInventoryModify(java.lang.String inventoryModify)

getInventoryScrap

public java.lang.String getInventoryScrap()

setInventoryScrap

public void setInventoryScrap(java.lang.String inventoryScrap)

getOnorderAction

public java.lang.String getOnorderAction()

setOnorderAction

public void setOnorderAction(java.lang.String onorderAction)

getOnorderUseAsIs

public java.lang.String getOnorderUseAsIs()

setOnorderUseAsIs

public void setOnorderUseAsIs(java.lang.String onorderUseAsIs)

getOnorderModify

public java.lang.String getOnorderModify()

setOnorderModify

public void setOnorderModify(java.lang.String onorderModify)

getOnorderScrap

public java.lang.String getOnorderScrap()

setOnorderScrap

public void setOnorderScrap(java.lang.String onorderScrap)

getApproved

public java.lang.String getApproved()

setApproved

public void setApproved(java.lang.String approved)

getPartFrom

public java.lang.String getPartFrom()

getVersion

public java.lang.Integer getVersion()

isHold

public boolean isHold()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setVersion

public void setVersion(java.lang.Integer version)

setHold

public void setHold(boolean hold)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getImportEc

public java.lang.String getImportEc()

setImportEc

public void setImportEc(java.lang.String importEc)

getImportComment

public java.lang.String getImportComment()

setImportComment

public void setImportComment(java.lang.String importComment)

getImportCompany

public java.lang.String getImportCompany()

setImportCompany

public void setImportCompany(java.lang.String importCompany)

getEngineeringChangeDocuments

public java.util.Set getEngineeringChangeDocuments()

setEngineeringChangeDocuments

public void setEngineeringChangeDocuments(java.util.Set engineeringChangeDocuments)

getApprovedDate

public java.util.Date getApprovedDate()

setApprovedDate

public void setApprovedDate(java.util.Date approvedDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EngineeringInfoCenterResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EngineeringInfoCenterResult

java.lang.Object
    extended by  bb.common.EngineeringInfoCenterResult
All Implemented Interfaces:
java.io.Serializable
public class EngineeringInfoCenterResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
EngineeringInfoCenterResult()
Method Summary
java.lang.Integer | getCancelledEcnCount()
java.lang.Integer | getDwfAddedCurrentMonthCount()
java.lang.Integer | getDwfAddedLastMonthCount()
java.lang.Integer | getDwfCount()
java.lang.Integer | getNotApproveEcnCount()
java.lang.Integer | getObsoleteEcnCount()
java.lang.Integer | getOpenEcnCount()
java.lang.Integer | getOpenEcrCount()
java.lang.Integer | getOpenEdcCount()
java.lang.Integer | getPartOnholdCount()
java.lang.Integer | getPastDueEcnCount()
void | setCancelledEcnCount(java.lang.Integer cancelledEcnCount)
void | setDwfAddedCurrentMonthCount(java.lang.Integer dwfAddedCurrentMonthCount)
void | setDwfAddedLastMonthCount(java.lang.Integer dwfAddedLastMonthCount)
void | setDwfCount(java.lang.Integer dwfCount)
void | setNotApproveEcnCount(java.lang.Integer notApproveEcnCount)
void | setObsoleteEcnCount(java.lang.Integer obsoleteEcnCount)
void | setOpenEcnCount(java.lang.Integer openEcnCount)
void | setOpenEcrCount(java.lang.Integer openEcrCount)
void | setOpenEdcCount(java.lang.Integer openEdcCount)
void | setPartOnholdCount(java.lang.Integer partOnholdCount)
void | setPastDueEcnCount(java.lang.Integer pastDueEcnCount)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EngineeringInfoCenterResult

public EngineeringInfoCenterResult()
Method Detail

setPastDueEcnCount

public void setPastDueEcnCount(java.lang.Integer pastDueEcnCount)

setOpenEcnCount

public void setOpenEcnCount(java.lang.Integer openEcnCount)

setPartOnholdCount

public void setPartOnholdCount(java.lang.Integer partOnholdCount)

setDwfCount

public void setDwfCount(java.lang.Integer dwfCount)

setDwfAddedCurrentMonthCount

public void setDwfAddedCurrentMonthCount(java.lang.Integer dwfAddedCurrentMonthCount)

setDwfAddedLastMonthCount

public void setDwfAddedLastMonthCount(java.lang.Integer dwfAddedLastMonthCount)

getPastDueEcnCount

public java.lang.Integer getPastDueEcnCount()

getOpenEcnCount

public java.lang.Integer getOpenEcnCount()

getPartOnholdCount

public java.lang.Integer getPartOnholdCount()

getDwfCount

public java.lang.Integer getDwfCount()

getDwfAddedCurrentMonthCount

public java.lang.Integer getDwfAddedCurrentMonthCount()

getDwfAddedLastMonthCount

public java.lang.Integer getDwfAddedLastMonthCount()

getOpenEdcCount

public java.lang.Integer getOpenEdcCount()

setOpenEdcCount

public void setOpenEdcCount(java.lang.Integer openEdcCount)

getOpenEcrCount

public java.lang.Integer getOpenEcrCount()

setOpenEcrCount

public void setOpenEcrCount(java.lang.Integer openEcrCount)

getNotApproveEcnCount

public java.lang.Integer getNotApproveEcnCount()

setNotApproveEcnCount

public void setNotApproveEcnCount(java.lang.Integer notApproveEcnCount)

getCancelledEcnCount

public java.lang.Integer getCancelledEcnCount()

setCancelledEcnCount

public void setCancelledEcnCount(java.lang.Integer cancelledEcnCount)

getObsoleteEcnCount

public java.lang.Integer getObsoleteEcnCount()

setObsoleteEcnCount

public void setObsoleteEcnCount(java.lang.Integer obsoleteEcnCount)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EngineeringSharingImportLogVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EngineeringSharingImportLogVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.EngineeringSharingImportLogVO
All Implemented Interfaces:
java.io.Serializable
public class EngineeringSharingImportLogVO
extends VO

See Also:
Serialized Form

Constructor Summary
EngineeringSharingImportLogVO()
Method Summary
java.lang.String | getContent()
java.lang.String | getEcnNumber()
java.lang.Long | getIi()
java.lang.String | getImportDataType()
java.util.Date | getImportDate()
java.lang.String | getImportKey()
java.lang.String | getImportType()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.util.Date | getReviewed()
java.lang.String | getReviewedBy()
java.lang.String | getStatus()
java.util.Date | isReviewed()
void | setContent(java.lang.String content)
void | setEcnNumber(java.lang.String ecnNumber)
void | setIi(java.lang.Long ii)
void | setImportDataType(java.lang.String importDataType)
void | setImportDate(java.util.Date importDate)
void | setImportKey(java.lang.String importKey)
void | setImportType(java.lang.String importType)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setReviewed(java.util.Date reviewed)
void | setReviewedBy(java.lang.String reviewedBy)
void | setStatus(java.lang.String status)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EngineeringSharingImportLogVO

public EngineeringSharingImportLogVO()
Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getImportType

public java.lang.String getImportType()

setImportType

public void setImportType(java.lang.String importType)

getImportKey

public java.lang.String getImportKey()

setImportKey

public void setImportKey(java.lang.String importKey)

getContent

public java.lang.String getContent()

setContent

public void setContent(java.lang.String content)

setReviewed

public void setReviewed(java.util.Date reviewed)

isReviewed

public java.util.Date isReviewed()

getImportDate

public java.util.Date getImportDate()

setImportDate

public void setImportDate(java.util.Date importDate)

getReviewedBy

public java.lang.String getReviewedBy()

setReviewedBy

public void setReviewedBy(java.lang.String reviewedBy)

getReviewed

public java.util.Date getReviewed()

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getEcnNumber

public java.lang.String getEcnNumber()

setEcnNumber

public void setEcnNumber(java.lang.String ecnNumber)

getImportDataType

public java.lang.String getImportDataType()

setImportDataType

public void setImportDataType(java.lang.String importDataType)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EngineeringSharingItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EngineeringSharingItemPK

java.lang.Object
    extended by  bb.common.EngineeringSharingItemPK
All Implemented Interfaces:
java.io.Serializable
public class EngineeringSharingItemPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
EngineeringSharingItemPK()
default constructor
EngineeringSharingItemPK(java.lang.String companyId, java.lang.String partNumber, java.lang.String partType)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCompanyId()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
int | hashCode()
void | setCompanyId(java.lang.String companyId)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

EngineeringSharingItemPK

public EngineeringSharingItemPK(java.lang.String companyId,
                                java.lang.String partNumber,
                                java.lang.String partType)
full constructor

EngineeringSharingItemPK

public EngineeringSharingItemPK()
default constructor

Method Detail

getCompanyId

public java.lang.String getCompanyId()

setCompanyId

public void setCompanyId(java.lang.String companyId)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EngineeringSharingItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EngineeringSharingItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.EngineeringSharingItemVO
All Implemented Interfaces:
java.io.Serializable
public class EngineeringSharingItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_EDITDATE
static java.lang.String | ORDER_BY_OPTWHO
static java.lang.String | ORDER_BY_PARTDESCRIPTION
static java.lang.String | ORDER_BY_PK
Constructor Summary
EngineeringSharingItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getEditDate()
java.lang.String | getOptWho()
java.lang.String | getPartDescription()
EngineeringSharingItemPK | getPk()
int | hashCode()
void | setEditDate(java.util.Date editDate)
void | setOptWho(java.lang.String optWho)
void | setPartDescription(java.lang.String partDescription)
void | setPk(EngineeringSharingItemPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PK

public static final java.lang.String ORDER_BY_PK
See Also:
Constant Field Values

ORDER_BY_OPTWHO

public static final java.lang.String ORDER_BY_OPTWHO
See Also:
Constant Field Values

ORDER_BY_EDITDATE

public static final java.lang.String ORDER_BY_EDITDATE
See Also:
Constant Field Values

ORDER_BY_PARTDESCRIPTION

public static final java.lang.String ORDER_BY_PARTDESCRIPTION
See Also:
Constant Field Values
Constructor Detail

EngineeringSharingItemVO

public EngineeringSharingItemVO()
Method Detail

getPk

public EngineeringSharingItemPK getPk()

setPk

public void setPk(EngineeringSharingItemPK pk)

getOptWho

public java.lang.String getOptWho()

setOptWho

public void setOptWho(java.lang.String optWho)

getEditDate

public java.util.Date getEditDate()

setEditDate

public void setEditDate(java.util.Date editDate)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getPartDescription

public java.lang.String getPartDescription()

setPartDescription

public void setPartDescription(java.lang.String partDescription)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EngineeringSharingVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EngineeringSharingVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.EngineeringSharingVO
All Implemented Interfaces:
java.io.Serializable
public class EngineeringSharingVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
EngineeringSharingVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.lang.String | getCompanyId()
java.lang.String | getCompanyName()
java.lang.String | getContact()
java.lang.String | getEngineeringSharingRule()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.util.Date | getValidFrom()
java.util.Date | getValidTo()
int | hashCode()
void | setComments(java.lang.String comments)
void | setCompanyId(java.lang.String companyId)
void | setCompanyName(java.lang.String companyName)
void | setContact(java.lang.String contact)
void | setEngineeringSharingRule(java.lang.String engineeringSharingRule)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setValidFrom(java.util.Date validFrom)
void | setValidTo(java.util.Date validTo)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

EngineeringSharingVO

public EngineeringSharingVO()
default constructor

Method Detail

getCompanyId

public java.lang.String getCompanyId()

setCompanyId

public void setCompanyId(java.lang.String companyId)

getCompanyName

public java.lang.String getCompanyName()

setCompanyName

public void setCompanyName(java.lang.String companyName)

getValidFrom

public java.util.Date getValidFrom()

setValidFrom

public void setValidFrom(java.util.Date validFrom)

getValidTo

public java.util.Date getValidTo()

setValidTo

public void setValidTo(java.util.Date validTo)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getEngineeringSharingRule

public java.lang.String getEngineeringSharingRule()

setEngineeringSharingRule

public void setEngineeringSharingRule(java.lang.String engineeringSharingRule)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EquipmentListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EquipmentListResult

java.lang.Object
    extended by  bb.common.EquipmentListResult
All Implemented Interfaces:
java.io.Serializable
public class EquipmentListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ASSETNUM
static java.lang.String | ORDER_BY_DEPARTMENTID
static java.lang.String | ORDER_BY_EQUIPMENTID
static java.lang.String | ORDER_BY_LASTMAINTENANCEDATE
static java.lang.String | ORDER_BY_MANUFACTURERID
static java.lang.String | ORDER_BY_NEXTSCHEDULEDMAINTENANCEDATE
static java.lang.String | ORDER_BY_TYPE
static java.lang.String | ORDER_BY_WORKCENTERID
Constructor Summary
EquipmentListResult()
Method Summary
java.lang.String | getAssetNum()
java.math.BigDecimal | getCurrentRunHours()
java.lang.String | getDepartmentId()
java.lang.String | getDescription()
java.lang.String | getEquipmentId()
java.lang.String | getEquipmentNotes()
java.util.Date | getLastMaintenanceDate()
java.lang.String | getMaintenanceBy()
java.lang.String | getManufacturerId()
java.lang.String | getModel()
java.util.Date | getNextScheduledMaintenanceDate()
java.lang.String | getRef()
java.lang.Integer | getRunHoursLimit()
java.lang.String | getStatus()
java.lang.String | getType()
java.lang.String | getWorkCenterId()
boolean | isWarning()
void | setAssetNum(java.lang.String assetNum)
void | setCurrentRunHours(java.math.BigDecimal currentRunHours)
void | setDepartmentId(java.lang.String departmentId)
void | setDescription(java.lang.String description)
void | setEquipmentId(java.lang.String equipmentId)
void | setEquipmentNotes(java.lang.String equipmentNotes)
void | setLastMaintenanceDate(java.util.Date lastMaintenanceDate)
void | setMaintenanceBy(java.lang.String maintenanceBy)
void | setManufacturerId(java.lang.String manufacturerId)
void | setModel(java.lang.String model)
void | setNextScheduledMaintenanceDate(java.util.Date nextScheduledMaintenanceDate)
void | setRef(java.lang.String ref)
void | setRunHoursLimit(java.lang.Integer runHoursLimit)
void | setStatus(java.lang.String status)
void | setType(java.lang.String type)
void | setWarning(boolean warning)
void | setWorkCenterId(java.lang.String workCenterId)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_EQUIPMENTID

public static final java.lang.String ORDER_BY_EQUIPMENTID
See Also:
Constant Field Values

ORDER_BY_NEXTSCHEDULEDMAINTENANCEDATE

public static final java.lang.String ORDER_BY_NEXTSCHEDULEDMAINTENANCEDATE
See Also:
Constant Field Values

ORDER_BY_DEPARTMENTID

public static final java.lang.String ORDER_BY_DEPARTMENTID
See Also:
Constant Field Values

ORDER_BY_MANUFACTURERID

public static final java.lang.String ORDER_BY_MANUFACTURERID
See Also:
Constant Field Values

ORDER_BY_ASSETNUM

public static final java.lang.String ORDER_BY_ASSETNUM
See Also:
Constant Field Values

ORDER_BY_LASTMAINTENANCEDATE

public static final java.lang.String ORDER_BY_LASTMAINTENANCEDATE
See Also:
Constant Field Values

ORDER_BY_TYPE

public static final java.lang.String ORDER_BY_TYPE
See Also:
Constant Field Values

ORDER_BY_WORKCENTERID

public static final java.lang.String ORDER_BY_WORKCENTERID
See Also:
Constant Field Values
Constructor Detail

EquipmentListResult

public EquipmentListResult()
Method Detail

getAssetNum

public java.lang.String getAssetNum()

setAssetNum

public void setAssetNum(java.lang.String assetNum)

getDepartmentId

public java.lang.String getDepartmentId()

setDepartmentId

public void setDepartmentId(java.lang.String departmentId)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getEquipmentId

public java.lang.String getEquipmentId()

setEquipmentId

public void setEquipmentId(java.lang.String equipmentId)

getEquipmentNotes

public java.lang.String getEquipmentNotes()

setEquipmentNotes

public void setEquipmentNotes(java.lang.String equipmentNotes)

getLastMaintenanceDate

public java.util.Date getLastMaintenanceDate()

setLastMaintenanceDate

public void setLastMaintenanceDate(java.util.Date lastMaintenanceDate)

getMaintenanceBy

public java.lang.String getMaintenanceBy()

setMaintenanceBy

public void setMaintenanceBy(java.lang.String maintenanceBy)

getManufacturerId

public java.lang.String getManufacturerId()

setManufacturerId

public void setManufacturerId(java.lang.String manufacturerId)

getNextScheduledMaintenanceDate

public java.util.Date getNextScheduledMaintenanceDate()

setNextScheduledMaintenanceDate

public void setNextScheduledMaintenanceDate(java.util.Date nextScheduledMaintenanceDate)

getRef

public java.lang.String getRef()

setRef

public void setRef(java.lang.String ref)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getCurrentRunHours

public java.math.BigDecimal getCurrentRunHours()

setCurrentRunHours

public void setCurrentRunHours(java.math.BigDecimal currentRunHours)

getRunHoursLimit

public java.lang.Integer getRunHoursLimit()

setRunHoursLimit

public void setRunHoursLimit(java.lang.Integer runHoursLimit)

isWarning

public boolean isWarning()

setWarning

public void setWarning(boolean warning)

getModel

public java.lang.String getModel()

setModel

public void setModel(java.lang.String model)

getType

public java.lang.String getType()

setType

public void setType(java.lang.String type)

getWorkCenterId

public java.lang.String getWorkCenterId()

setWorkCenterId

public void setWorkCenterId(java.lang.String workCenterId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EquipmentVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class EquipmentVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.EquipmentVO
All Implemented Interfaces:
java.io.Serializable
public class EquipmentVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
EquipmentVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAssetNum()
java.lang.String | getCostCurrency()
java.math.BigDecimal | getCurrentRunHours()
java.lang.String | getDepartmentId()
java.lang.String | getDescription()
java.lang.String | getEquipmentId()
java.lang.String | getEquipmentNotes()
java.lang.Integer | getHrs()
java.util.Date | getInstalledDate()
java.util.Date | getLastMaintenanceDate()
java.lang.String | getMaintenanceBy()
java.util.Set | getMaintenanceItems()
java.lang.Integer | getMaintencePeriod()
java.lang.String | getManufacturerId()
java.lang.String | getModel()
java.util.Date | getNextScheduledMaintenanceDate()
java.math.BigDecimal | getOriginalCost()
java.lang.String | getPeriodUnit()
java.lang.String | getPowerUnit()
java.math.BigDecimal | getRate()
java.lang.String | getRef()
java.lang.Integer | getRunHoursLimit()
java.lang.String | getSerial()
java.lang.String | getStatus()
java.math.BigDecimal | getTotalPower()
java.lang.String | getType()
java.lang.String | getWorkCenterId()
int | hashCode()
void | setAssetNum(java.lang.String assetNum)
void | setCostCurrency(java.lang.String costCurrency)
void | setCurrentRunHours(java.math.BigDecimal currentRunHours)
void | setDepartmentId(java.lang.String departmentId)
void | setDescription(java.lang.String description)
void | setEquipmentId(java.lang.String equipmentId)
void | setEquipmentNotes(java.lang.String equipmentNotes)
void | setHrs(java.lang.Integer hrs)
void | setInstalledDate(java.util.Date installedDate)
void | setLastMaintenanceDate(java.util.Date lastMaintenanceDate)
void | setMaintenanceBy(java.lang.String maintenanceBy)
void | setMaintenanceItems(java.util.Set maintenanceItems)
void | setMaintencePeriod(java.lang.Integer maintencePeriod)
void | setManufacturerId(java.lang.String manufacturerId)
void | setModel(java.lang.String model)
void | setNextScheduledMaintenanceDate(java.util.Date nextScheduledMaintenanceDate)
void | setOriginalCost(java.math.BigDecimal originalCost)
void | setPeriodUnit(java.lang.String periodUnit)
void | setPowerUnit(java.lang.String powerUnit)
void | setRate(java.math.BigDecimal rate)
void | setRef(java.lang.String ref)
void | setRunHoursLimit(java.lang.Integer runHoursLimit)
void | setSerial(java.lang.String serial)
void | setStatus(java.lang.String status)
void | setTotalPower(java.math.BigDecimal totalPower)
void | setType(java.lang.String type)
void | setWorkCenterId(java.lang.String workCenterId)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

EquipmentVO

public EquipmentVO()
Method Detail

getEquipmentId

public java.lang.String getEquipmentId()

setEquipmentId

public void setEquipmentId(java.lang.String equipmentId)

getRef

public java.lang.String getRef()

setRef

public void setRef(java.lang.String ref)

getRate

public java.math.BigDecimal getRate()

setRate

public void setRate(java.math.BigDecimal rate)

getHrs

public java.lang.Integer getHrs()

setHrs

public void setHrs(java.lang.Integer hrs)

getDepartmentId

public java.lang.String getDepartmentId()

setDepartmentId

public void setDepartmentId(java.lang.String departmentId)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getManufacturerId

public java.lang.String getManufacturerId()

setManufacturerId

public void setManufacturerId(java.lang.String manufacturerId)

getModel

public java.lang.String getModel()

setModel

public void setModel(java.lang.String model)

getTotalPower

public java.math.BigDecimal getTotalPower()

setTotalPower

public void setTotalPower(java.math.BigDecimal totalPower)

getPowerUnit

public java.lang.String getPowerUnit()

setPowerUnit

public void setPowerUnit(java.lang.String powerUnit)

getMaintenanceBy

public java.lang.String getMaintenanceBy()

setMaintenanceBy

public void setMaintenanceBy(java.lang.String maintenanceBy)

getAssetNum

public java.lang.String getAssetNum()

setAssetNum

public void setAssetNum(java.lang.String assetNum)

getSerial

public java.lang.String getSerial()

setSerial

public void setSerial(java.lang.String serial)

getInstalledDate

public java.util.Date getInstalledDate()

setInstalledDate

public void setInstalledDate(java.util.Date installedDate)

getOriginalCost

public java.math.BigDecimal getOriginalCost()

setOriginalCost

public void setOriginalCost(java.math.BigDecimal originalCost)

getCostCurrency

public java.lang.String getCostCurrency()

setCostCurrency

public void setCostCurrency(java.lang.String costCurrency)

getCurrentRunHours

public java.math.BigDecimal getCurrentRunHours()

setCurrentRunHours

public void setCurrentRunHours(java.math.BigDecimal currentRunHours)

getMaintencePeriod

public java.lang.Integer getMaintencePeriod()

setMaintencePeriod

public void setMaintencePeriod(java.lang.Integer maintencePeriod)

getPeriodUnit

public java.lang.String getPeriodUnit()

setPeriodUnit

public void setPeriodUnit(java.lang.String periodUnit)

getLastMaintenanceDate

public java.util.Date getLastMaintenanceDate()

setLastMaintenanceDate

public void setLastMaintenanceDate(java.util.Date lastMaintenanceDate)

getNextScheduledMaintenanceDate

public java.util.Date getNextScheduledMaintenanceDate()

setNextScheduledMaintenanceDate

public void setNextScheduledMaintenanceDate(java.util.Date nextScheduledMaintenanceDate)

getEquipmentNotes

public java.lang.String getEquipmentNotes()

setEquipmentNotes

public void setEquipmentNotes(java.lang.String equipmentNotes)

getMaintenanceItems

public java.util.Set getMaintenanceItems()

getStatus

public java.lang.String getStatus()

setMaintenanceItems

public void setMaintenanceItems(java.util.Set maintenanceItems)

setStatus

public void setStatus(java.lang.String status)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getRunHoursLimit

public java.lang.Integer getRunHoursLimit()

setRunHoursLimit

public void setRunHoursLimit(java.lang.Integer runHoursLimit)

getType

public java.lang.String getType()

setType

public void setType(java.lang.String type)

getWorkCenterId

public java.lang.String getWorkCenterId()

setWorkCenterId

public void setWorkCenterId(java.lang.String workCenterId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExchangeAuditItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ExchangeAuditItemResult

java.lang.Object
    extended by  bb.common.ExchangeAuditItemResult
All Implemented Interfaces:
java.io.Serializable
public class ExchangeAuditItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ExchangeAuditItemResult()
Method Summary
java.lang.String | getAccountDescription()
java.lang.String | getAccountNumber()
java.lang.String | getAccountType()
java.lang.String | getAddOrSubtract()
java.lang.String | getAddress()
java.math.BigDecimal | getBalance()
java.math.BigDecimal | getBookBalance()
java.math.BigDecimal | getCredit()
java.lang.String | getCreditOrDebit()
java.lang.String | getCurrency()
java.math.BigDecimal | getDebit()
java.math.BigDecimal | getExchange()
byte | getItems()
java.lang.String | getLevel()
java.math.BigDecimal | getOrgBalance()
java.math.BigDecimal | getOrgCredit()
java.math.BigDecimal | getOrgDebit()
java.lang.String | getUpLevelAccountNumber()
java.math.BigDecimal | getVariance()
void | setAccountDescription(java.lang.String accountDescription)
void | setAccountNumber(java.lang.String accountNumber)
void | setAccountType(java.lang.String accountType)
void | setAddOrSubtract(java.lang.String addOrSubtract)
void | setAddress(java.lang.String address)
void | setBalance(java.math.BigDecimal balance)
void | setBookBalance(java.math.BigDecimal bookBalance)
void | setCredit(java.math.BigDecimal credit)
void | setCreditOrDebit(java.lang.String creditOrDebit)
void | setCurrency(java.lang.String currency)
void | setDebit(java.math.BigDecimal debit)
void | setExchange(java.math.BigDecimal exchange)
void | setItems(byte items)
void | setLevel(java.lang.String level)
void | setOrgBalance(java.math.BigDecimal orgBalance)
void | setOrgCredit(java.math.BigDecimal orgCredit)
void | setOrgDebit(java.math.BigDecimal orgDebit)
void | setUpLevelAccountNumber(java.lang.String upLevelAccountNumber)
void | setVariance(java.math.BigDecimal variance)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ExchangeAuditItemResult

public ExchangeAuditItemResult()
Method Detail

getUpLevelAccountNumber

public java.lang.String getUpLevelAccountNumber()

getAddOrSubtract

public java.lang.String getAddOrSubtract()

getAccountType

public java.lang.String getAccountType()

getAccountNumber

public java.lang.String getAccountNumber()

getAccountDescription

public java.lang.String getAccountDescription()

getCreditOrDebit

public java.lang.String getCreditOrDebit()

setLevel

public void setLevel(java.lang.String level)

setUpLevelAccountNumber

public void setUpLevelAccountNumber(java.lang.String upLevelAccountNumber)

setAddOrSubtract

public void setAddOrSubtract(java.lang.String addOrSubtract)

setAccountType

public void setAccountType(java.lang.String accountType)

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

setAccountDescription

public void setAccountDescription(java.lang.String accountDescription)

setCreditOrDebit

public void setCreditOrDebit(java.lang.String creditOrDebit)

setDebit

public void setDebit(java.math.BigDecimal debit)

setCredit

public void setCredit(java.math.BigDecimal credit)

setBalance

public void setBalance(java.math.BigDecimal balance)

setItems

public void setItems(byte items)

getLevel

public java.lang.String getLevel()

getDebit

public java.math.BigDecimal getDebit()

getCredit

public java.math.BigDecimal getCredit()

getBalance

public java.math.BigDecimal getBalance()

getItems

public byte getItems()

getAddress

public java.lang.String getAddress()

setAddress

public void setAddress(java.lang.String address)

getOrgCredit

public java.math.BigDecimal getOrgCredit()

setOrgCredit

public void setOrgCredit(java.math.BigDecimal orgCredit)

getOrgDebit

public java.math.BigDecimal getOrgDebit()

setOrgDebit

public void setOrgDebit(java.math.BigDecimal orgDebit)

getOrgBalance

public java.math.BigDecimal getOrgBalance()

setOrgBalance

public void setOrgBalance(java.math.BigDecimal orgBalance)

getBookBalance

public java.math.BigDecimal getBookBalance()

setBookBalance

public void setBookBalance(java.math.BigDecimal bookBalance)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getExchange

public java.math.BigDecimal getExchange()

setExchange

public void setExchange(java.math.BigDecimal exchange)

getVariance

public java.math.BigDecimal getVariance()

setVariance

public void setVariance(java.math.BigDecimal variance)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExchangeAuditResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ExchangeAuditResult

java.lang.Object
    extended by  bb.common.ExchangeAuditResult
All Implemented Interfaces:
java.io.Serializable
public class ExchangeAuditResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ExchangeAuditResult()
Method Summary
java.lang.String | getCompanyUnitId()
java.lang.String | getGlSummary()
java.util.List | getList()
java.util.Map<AssetDepreciatePK,AccountCreditVO> | getMap()
java.lang.String | getMonthYear()
java.lang.String | getTransactionNumber()
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setGlSummary(java.lang.String glSummary)
void | setList(java.util.List list)
void | setMap(java.util.Map<AssetDepreciatePK,AccountCreditVO> map)
void | setMonthYear(java.lang.String monthYear)
void | setTransactionNumber(java.lang.String transactionNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ExchangeAuditResult

public ExchangeAuditResult()
Method Detail

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getMonthYear

public java.lang.String getMonthYear()

setMonthYear

public void setMonthYear(java.lang.String monthYear)

getList

public java.util.List getList()

setList

public void setList(java.util.List list)

getTransactionNumber

public java.lang.String getTransactionNumber()

setTransactionNumber

public void setTransactionNumber(java.lang.String transactionNumber)

getMap

public java.util.Map<AssetDepreciatePK,AccountCreditVO> getMap()

setMap

public void setMap(java.util.Map<AssetDepreciatePK,AccountCreditVO> map)

getGlSummary

public java.lang.String getGlSummary()

setGlSummary

public void setGlSummary(java.lang.String glSummary)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExpenseAccountVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ExpenseAccountVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ExpenseAccountVO
All Implemented Interfaces:
java.io.Serializable
public class ExpenseAccountVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
ExpenseAccountVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAccountNumber()
java.lang.String | getCompanyUnitId()
java.lang.String | getDescription()
java.lang.String | getType()
int | hashCode()
void | setAccountNumber(java.lang.String accountNumber)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setDescription(java.lang.String description)
void | setType(java.lang.String type)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ExpenseAccountVO

public ExpenseAccountVO()
Method Detail

getType

public java.lang.String getType()

setType

public void setType(java.lang.String type)

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExpenseItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ExpenseItemPK

java.lang.Object
    extended by  bb.common.ExpenseItemPK
All Implemented Interfaces:
java.io.Serializable
public class ExpenseItemPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
ExpenseItemPK()
default constructor
ExpenseItemPK(java.lang.String expenseStatement, java.lang.Integer ii)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getExpenseStatement()
java.lang.Integer | getIi()
int | hashCode()
void | setExpenseStatement(java.lang.String expenseStatement)
void | setIi(java.lang.Integer ii)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ExpenseItemPK

public ExpenseItemPK(java.lang.String expenseStatement,
                     java.lang.Integer ii)
full constructor

ExpenseItemPK

public ExpenseItemPK()
default constructor

Method Detail

getExpenseStatement

public java.lang.String getExpenseStatement()

setExpenseStatement

public void setExpenseStatement(java.lang.String expenseStatement)

getIi

public java.lang.Integer getIi()

setIi

public void setIi(java.lang.Integer ii)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExpenseItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ExpenseItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ExpenseItemVO
All Implemented Interfaces:
java.io.Serializable
public class ExpenseItemVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
ExpenseItemVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getAmount()
java.lang.String | getComment()
java.lang.String | getCurrency()
java.util.Date | getDateFrom()
java.util.Date | getDateTo()
java.lang.String | getDescription()
java.lang.String | getGa()
ExpenseItemPK | getPk()
java.lang.String | getType()
int | hashCode()
void | setAmount(java.math.BigDecimal amount)
void | setComment(java.lang.String comment)
void | setCurrency(java.lang.String currency)
void | setDateFrom(java.util.Date dateFrom)
void | setDateTo(java.util.Date dateTo)
void | setDescription(java.lang.String description)
void | setGa(java.lang.String ga)
void | setPk(ExpenseItemPK pk)
void | setType(java.lang.String type)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ExpenseItemVO

public ExpenseItemVO()
default constructor

Method Detail

getPk

public ExpenseItemPK getPk()

setPk

public void setPk(ExpenseItemPK pk)

getDateFrom

public java.util.Date getDateFrom()

setDateFrom

public void setDateFrom(java.util.Date dateFrom)

getDateTo

public java.util.Date getDateTo()

setDateTo

public void setDateTo(java.util.Date dateTo)

getType

public java.lang.String getType()

setType

public void setType(java.lang.String type)

getAmount

public java.math.BigDecimal getAmount()

setAmount

public void setAmount(java.math.BigDecimal amount)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getGa

public java.lang.String getGa()

setGa

public void setGa(java.lang.String ga)

getComment

public java.lang.String getComment()

setComment

public void setComment(java.lang.String comment)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExpenseListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ExpenseListResult

java.lang.Object
    extended by  bb.common.ExpenseListResult
All Implemented Interfaces:
java.io.Serializable
public class ExpenseListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DATEFROM
static java.lang.String | ORDER_BY_DATETO
static java.lang.String | ORDER_BY_EXPENSESTATEMENT
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_USERNAME
Constructor Summary
ExpenseListResult()
Method Summary
java.util.Date | getDateFrom()
java.util.Date | getDateTo()
java.lang.String | getExpenseStatement()
java.lang.String | getStatus()
java.lang.String | getUserName()
void | setDateFrom(java.util.Date dateFrom)
void | setDateTo(java.util.Date dateTo)
void | setExpenseStatement(java.lang.String expenseStatement)
void | setStatus(java.lang.String status)
void | setUserName(java.lang.String userName)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_EXPENSESTATEMENT

public static final java.lang.String ORDER_BY_EXPENSESTATEMENT
See Also:
Constant Field Values

ORDER_BY_DATEFROM

public static final java.lang.String ORDER_BY_DATEFROM
See Also:
Constant Field Values

ORDER_BY_DATETO

public static final java.lang.String ORDER_BY_DATETO
See Also:
Constant Field Values

ORDER_BY_USERNAME

public static final java.lang.String ORDER_BY_USERNAME
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values
Constructor Detail

ExpenseListResult

public ExpenseListResult()
Method Detail

getStatus

public java.lang.String getStatus()

getUserName

public java.lang.String getUserName()

getDateTo

public java.util.Date getDateTo()

getDateFrom

public java.util.Date getDateFrom()

setExpenseStatement

public void setExpenseStatement(java.lang.String expenseStatement)

setStatus

public void setStatus(java.lang.String status)

setUserName

public void setUserName(java.lang.String userName)

setDateTo

public void setDateTo(java.util.Date dateTo)

setDateFrom

public void setDateFrom(java.util.Date dateFrom)

getExpenseStatement

public java.lang.String getExpenseStatement()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExpenseVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ExpenseVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ExpenseVO
All Implemented Interfaces:
java.io.Serializable
public class ExpenseVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
ExpenseVO()
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getAdvances()
java.lang.String | getApNumber()
java.util.Date | getApproveDate()
java.lang.String | getApprovedBy()
java.lang.String | getCashCheckReceived()
java.lang.String | getCheckPaid()
java.util.Date | getDate1()
java.util.Date | getDate2()
java.util.Date | getDatePaid()
java.lang.String | getDepartment()
java.lang.String | getEmployeeId()
java.util.Set | getExpensesItems()
java.lang.String | getExpenseStatement()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getManager()
java.math.BigDecimal | getPaymentNeeded()
java.lang.String | getPosition()
java.math.BigDecimal | getReimbursement()
java.lang.String | getStatus()
java.math.BigDecimal | getTotal()
java.lang.String | getUserName()
int | getVersion()
int | hashCode()
void | setAdvances(java.math.BigDecimal advances)
void | setApNumber(java.lang.String apNumber)
void | setApproveDate(java.util.Date approveDate)
void | setApprovedBy(java.lang.String approvedBy)
void | setCashCheckReceived(java.lang.String cashCheckReceived)
void | setCheckPaid(java.lang.String checkPaid)
void | setDate1(java.util.Date date1)
void | setDate2(java.util.Date date2)
void | setDatePaid(java.util.Date datePaid)
void | setDepartment(java.lang.String department)
void | setEmployeeId(java.lang.String employeeId)
void | setExpensesItems(java.util.Set expensesItems)
void | setExpenseStatement(java.lang.String expenseStatement)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setManager(java.lang.String manager)
void | setPaymentNeeded(java.math.BigDecimal paymentNeeded)
void | setPosition(java.lang.String position)
void | setReimbursement(java.math.BigDecimal reimbursement)
void | setStatus(java.lang.String status)
void | setTotal(java.math.BigDecimal total)
void | setUserName(java.lang.String userName)
void | setVersion(int version)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ExpenseVO

public ExpenseVO()
Method Detail

getExpenseStatement

public java.lang.String getExpenseStatement()

setExpenseStatement

public void setExpenseStatement(java.lang.String expenseStatement)

getApNumber

public java.lang.String getApNumber()

setApNumber

public void setApNumber(java.lang.String apNumber)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getDepartment

public java.lang.String getDepartment()

setDepartment

public void setDepartment(java.lang.String department)

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getPosition

public java.lang.String getPosition()

setPosition

public void setPosition(java.lang.String position)

getManager

public java.lang.String getManager()

setManager

public void setManager(java.lang.String manager)

getApproveDate

public java.util.Date getApproveDate()

setApproveDate

public void setApproveDate(java.util.Date approveDate)

getApprovedBy

public java.lang.String getApprovedBy()

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)

getDate1

public java.util.Date getDate1()

setDate1

public void setDate1(java.util.Date date1)

getDate2

public java.util.Date getDate2()

setDate2

public void setDate2(java.util.Date date2)

getTotal

public java.math.BigDecimal getTotal()

setTotal

public void setTotal(java.math.BigDecimal total)

getAdvances

public java.math.BigDecimal getAdvances()

setAdvances

public void setAdvances(java.math.BigDecimal advances)

getReimbursement

public java.math.BigDecimal getReimbursement()

setReimbursement

public void setReimbursement(java.math.BigDecimal reimbursement)

getPaymentNeeded

public java.math.BigDecimal getPaymentNeeded()

setPaymentNeeded

public void setPaymentNeeded(java.math.BigDecimal paymentNeeded)

getCashCheckReceived

public java.lang.String getCashCheckReceived()

setCashCheckReceived

public void setCashCheckReceived(java.lang.String cashCheckReceived)

getCheckPaid

public java.lang.String getCheckPaid()

setCheckPaid

public void setCheckPaid(java.lang.String checkPaid)

getDatePaid

public java.util.Date getDatePaid()

setDatePaid

public void setDatePaid(java.util.Date datePaid)

getVersion

public int getVersion()

setVersion

public void setVersion(int version)

getExpensesItems

public java.util.Set getExpensesItems()

setExpensesItems

public void setExpensesItems(java.util.Set expensesItems)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Facade

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Interface Facade

public interface Facade

Method Summary
long | getServerTime()
java.util.TimeZone | getServerTimeZone()
java.lang.String | getVersionInfo()
java.lang.Object | invoke(ServerAction action)
boolean | login(BB2Login bb2login)
void | logout()

Method Detail

login

boolean login(BB2Login bb2login)
              throws java.lang.Exception
Throws:
java.lang.Exception

logout

void logout()
            throws java.lang.Exception
Throws:
java.lang.Exception

invoke

java.lang.Object invoke(ServerAction action)
                        throws java.lang.Exception
Throws:
java.lang.Exception

getServerTimeZone

java.util.TimeZone getServerTimeZone()
                                     throws java.lang.Exception
Throws:
java.lang.Exception

getServerTime

long getServerTime()
                   throws java.lang.Exception
Throws:
java.lang.Exception

getVersionInfo

java.lang.String getVersionInfo()
                                throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FeedbackAnswerPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class FeedbackAnswerPK

java.lang.Object
    extended by  bb.common.FeedbackAnswerPK
All Implemented Interfaces:
java.io.Serializable
public class FeedbackAnswerPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
FeedbackAnswerPK()
default constructor
FeedbackAnswerPK(java.lang.String questionId, java.lang.String answerItem)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAnswerItem()
java.lang.String | getQuestionId()
int | hashCode()
void | setAnswerItem(java.lang.String answerItem)
void | setQuestionId(java.lang.String questionId)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

FeedbackAnswerPK

public FeedbackAnswerPK(java.lang.String questionId,
                        java.lang.String answerItem)
full constructor

FeedbackAnswerPK

public FeedbackAnswerPK()
default constructor

Method Detail

getQuestionId

public java.lang.String getQuestionId()

setQuestionId

public void setQuestionId(java.lang.String questionId)

getAnswerItem

public java.lang.String getAnswerItem()

setAnswerItem

public void setAnswerItem(java.lang.String answerItem)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FeedbackAnswerVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class FeedbackAnswerVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.FeedbackAnswerVO
All Implemented Interfaces:
java.io.Serializable
public class FeedbackAnswerVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
FeedbackAnswerVO()
default constructor
FeedbackAnswerVO(FeedbackAnswerPK pk, java.lang.String answerEn, java.lang.String answerCn)
minimal constructor
FeedbackAnswerVO(FeedbackAnswerPK pk, java.lang.String answerEn, java.lang.String answerCn, FeedbackQuestionVO feedbackQuestion)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAnswerCn()
java.lang.String | getAnswerEn()
FeedbackQuestionVO | getFeedbackQuestion()
FeedbackAnswerPK | getPk()
int | hashCode()
void | setAnswerCn(java.lang.String answerCn)
void | setAnswerEn(java.lang.String answerEn)
void | setFeedbackQuestion(FeedbackQuestionVO feedbackQuestion)
void | setPk(FeedbackAnswerPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

FeedbackAnswerVO

public FeedbackAnswerVO(FeedbackAnswerPK pk,
                        java.lang.String answerEn,
                        java.lang.String answerCn,
                        FeedbackQuestionVO feedbackQuestion)
full constructor

FeedbackAnswerVO

public FeedbackAnswerVO()
default constructor

FeedbackAnswerVO

public FeedbackAnswerVO(FeedbackAnswerPK pk,
                        java.lang.String answerEn,
                        java.lang.String answerCn)
minimal constructor

Method Detail

getPk

public FeedbackAnswerPK getPk()

setPk

public void setPk(FeedbackAnswerPK pk)

getAnswerEn

public java.lang.String getAnswerEn()

setAnswerEn

public void setAnswerEn(java.lang.String answerEn)

getAnswerCn

public java.lang.String getAnswerCn()

setAnswerCn

public void setAnswerCn(java.lang.String answerCn)

getFeedbackQuestion

public FeedbackQuestionVO getFeedbackQuestion()

setFeedbackQuestion

public void setFeedbackQuestion(FeedbackQuestionVO feedbackQuestion)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FeedBackItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class FeedBackItemPK

java.lang.Object
    extended by  bb.common.FeedBackItemPK
All Implemented Interfaces:
java.io.Serializable
public class FeedBackItemPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
FeedBackItemPK()
default constructor
FeedBackItemPK(java.lang.String feedBackNumber, java.lang.String questionId)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getFeedBackNumber()
java.lang.String | getQuestionId()
int | hashCode()
void | setFeedBackNumber(java.lang.String feedBackNumber)
void | setQuestionId(java.lang.String questionId)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

FeedBackItemPK

public FeedBackItemPK(java.lang.String feedBackNumber,
                      java.lang.String questionId)
full constructor

FeedBackItemPK

public FeedBackItemPK()
default constructor

Method Detail

getFeedBackNumber

public java.lang.String getFeedBackNumber()

setFeedBackNumber

public void setFeedBackNumber(java.lang.String feedBackNumber)

getQuestionId

public java.lang.String getQuestionId()

setQuestionId

public void setQuestionId(java.lang.String questionId)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FeedbackItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class FeedbackItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.FeedbackItemVO
All Implemented Interfaces:
java.io.Serializable
public class FeedbackItemVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
FeedbackItemVO()
default constructor
FeedbackItemVO(FeedBackItemPK pk, java.lang.String answerItem)
minimal constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAnswerItem()
FeedBackItemPK | getPk()
int | hashCode()
void | setAnswerItem(java.lang.String answerItem)
void | setPk(FeedBackItemPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

FeedbackItemVO

public FeedbackItemVO()
default constructor

FeedbackItemVO

public FeedbackItemVO(FeedBackItemPK pk,
                      java.lang.String answerItem)
minimal constructor

Method Detail

getPk

public FeedBackItemPK getPk()

setPk

public void setPk(FeedBackItemPK pk)

getAnswerItem

public java.lang.String getAnswerItem()

setAnswerItem

public void setAnswerItem(java.lang.String answerItem)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FeedbackQuestionVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class FeedbackQuestionVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.FeedbackQuestionVO
All Implemented Interfaces:
java.io.Serializable
public class FeedbackQuestionVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
FeedbackQuestionVO()
default constructor
FeedbackQuestionVO(java.lang.String questionId, java.lang.String questionEn, java.lang.String questionCn, java.util.Set answers)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Set | getAnswers()
java.lang.String | getQuestionCn()
java.lang.String | getQuestionEn()
java.lang.String | getQuestionId()
int | hashCode()
void | setAnswers(java.util.Set answers)
void | setQuestionCn(java.lang.String questionCn)
void | setQuestionEn(java.lang.String questionEn)
void | setQuestionId(java.lang.String questionId)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

FeedbackQuestionVO

public FeedbackQuestionVO(java.lang.String questionId,
                          java.lang.String questionEn,
                          java.lang.String questionCn,
                          java.util.Set answers)
full constructor

FeedbackQuestionVO

public FeedbackQuestionVO()
default constructor

Method Detail

getQuestionId

public java.lang.String getQuestionId()

setQuestionId

public void setQuestionId(java.lang.String questionId)

getQuestionEn

public java.lang.String getQuestionEn()

setQuestionEn

public void setQuestionEn(java.lang.String questionEn)

getQuestionCn

public java.lang.String getQuestionCn()

setQuestionCn

public void setQuestionCn(java.lang.String questionCn)

getAnswers

public java.util.Set getAnswers()

setAnswers

public void setAnswers(java.util.Set answers)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


F-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M N O P Q R S T U V W X Y Z

F

F - Static variable in class bb.common.Constant.TransactionType
Facade - Interface in bb.common
FACTOR - Static variable in class bb.common.LabelTemplateConstant
FAIL_LOGIN - Static variable in class bb.common.BIZReason
FEEDBACK_QUESTION - Static variable in class bb.common.BizTarget
FEEDBACK_QUESTION_ALREADY_EXIST - Static variable in class bb.common.BIZReason
FEEDBACK_QUESTION_IN_USING - Static variable in class bb.common.BIZReason
FEEDBACK_QUESTION_NOT_EXIST - Static variable in class bb.common.BIZReason
FeedbackAnswerPK - Class in bb.common
FeedbackAnswerPK(String, String) - Constructor for class bb.common.FeedbackAnswerPK
full constructor
FeedbackAnswerPK() - Constructor for class bb.common.FeedbackAnswerPK
default constructor
FeedbackAnswerVO - Class in bb.common
FeedbackAnswerVO(FeedbackAnswerPK, String, String, FeedbackQuestionVO) - Constructor for class bb.common.FeedbackAnswerVO
full constructor
FeedbackAnswerVO() - Constructor for class bb.common.FeedbackAnswerVO
default constructor
FeedbackAnswerVO(FeedbackAnswerPK, String, String) - Constructor for class bb.common.FeedbackAnswerVO
minimal constructor
FeedBackItemPK - Class in bb.common
FeedBackItemPK(String, String) - Constructor for class bb.common.FeedBackItemPK
full constructor
FeedBackItemPK() - Constructor for class bb.common.FeedBackItemPK
default constructor
FeedbackItemVO - Class in bb.common
FeedbackItemVO() - Constructor for class bb.common.FeedbackItemVO
default constructor
FeedbackItemVO(FeedBackItemPK, String) - Constructor for class bb.common.FeedbackItemVO
minimal constructor
FeedbackQuestionVO - Class in bb.common
FeedbackQuestionVO(String, String, String, Set) - Constructor for class bb.common.FeedbackQuestionVO
full constructor
FeedbackQuestionVO() - Constructor for class bb.common.FeedbackQuestionVO
default constructor
FIFO - Static variable in class bb.common.Constant.InventoryCostMothed
FILE_ALREADY_EXIST - Static variable in exception bb.common.BB2DocumentException
FILE_IN_PROCESS - Static variable in exception bb.common.BB2DocumentException
FILE_NOT_EXIST - Static variable in exception bb.common.BB2DocumentException
FILE_SYSTEM - Static variable in class bb.common.BizTarget
FILE_SYSTEM_OPERATION_FAILED - Static variable in class bb.common.BIZReason
filter(String) - Static method in class bb.common.Constant.CycleCountPeriodUnit
filter(Object) - Static method in class bb.common.Constant.PartFrom
filtrateLanguage(String) - Static method in class bb.common.BB2Util
FINANCING_EXPENSE_ACCOUNT_NOT_EXIST - Static variable in class bb.common.BIZReason
find1To30PrepayStatementByCustomerId(String, String, String, Date, int, int) - Method in interface bb.common.box.AccountingBox
find1To30PrepayStatementByVendorId(String, String, int, int) - Method in interface bb.common.box.AccountingBox
find1To30StatementByCustomerId(String, String, String, Date, int, int) - Method in interface bb.common.box.AccountingBox
find1To30StatementByVendorId(String, String, int, int) - Method in interface bb.common.box.AccountingBox
find31To60PrepayStatementByCustomerId(String, String, String, Date, int, int) - Method in interface bb.common.box.AccountingBox
find31To60PrepayStatementByVendorId(String, String, int, int) - Method in interface bb.common.box.AccountingBox
find31To60StatementByCustomerId(String, String, String, Date, int, int) - Method in interface bb.common.box.AccountingBox
find31To60StatementByVendorId(String, String, int, int) - Method in interface bb.common.box.AccountingBox
find61To90PrepayStatementByCustomerId(String, String, String, Date, int, int) - Method in interface bb.common.box.AccountingBox
find61To90PrepayStatementByVendorId(String, String, int, int) - Method in interface bb.common.box.AccountingBox
find61To90StatementByCustomerId(String, String, String, Date, int, int) - Method in interface bb.common.box.AccountingBox
find61To90StatementByVendorId(String, String, int, int) - Method in interface bb.common.box.AccountingBox
find90PlusPrepayStatementByCustomerId(String, String, String, Date, int, int) - Method in interface bb.common.box.AccountingBox
find90PlusPrepayStatementByVendorId(String, String, int, int) - Method in interface bb.common.box.AccountingBox
find90PlusStatementByCustomerId(String, String, String, Date, int, int) - Method in interface bb.common.box.AccountingBox
find90PlusStatementByVendorId(String, String, int, int) - Method in interface bb.common.box.AccountingBox
FIND_ACCOUNT_NUMBER_ERROR - Static variable in class bb.common.BIZReason
FIND_ACCOUNTING_SETTINGS_ERROR - Static variable in class bb.common.BIZReason
FIND_ADDRESS_ID_ERROR - Static variable in class bb.common.BIZReason
FIND_AP_CHECK_RUN_ERROR - Static variable in class bb.common.BIZReason
FIND_AP_ERROR - Static variable in class bb.common.BIZReason
FIND_APP_ERROR - Static variable in class bb.common.BIZReason
FIND_APP_ITEM_ERROR - Static variable in class bb.common.BIZReason
FIND_ARP_ERROR - Static variable in class bb.common.BIZReason
FIND_ARP_ITEM_ERROR - Static variable in class bb.common.BIZReason
FIND_BALANCE_SHEET_ERROR - Static variable in class bb.common.BIZReason
FIND_BIZBOX_USER_ERROR - Static variable in class bb.common.BIZReason
FIND_CAR_ERROR - Static variable in class bb.common.BIZReason
FIND_CARRIER_ERROR - Static variable in class bb.common.BIZReason
FIND_COMPANY_SETTINGS_ERROR - Static variable in class bb.common.BIZReason
FIND_CONTRACT_PRICE_ERROR - Static variable in class bb.common.BIZReason
FIND_CREDIT_MEMO_ERROR - Static variable in class bb.common.BIZReason
FIND_CURRENCY_ERROR - Static variable in class bb.common.BIZReason
FIND_DB_ERROR - Static variable in class bb.common.BIZReason
FIND_DEBIT_MEMO_ERROR - Static variable in class bb.common.BIZReason
FIND_EMPLOYEE_ID_ERROR - Static variable in class bb.common.BIZReason
FIND_FISCALYEAR_ERROR - Static variable in class bb.common.BIZReason
FIND_GENERAL_LEDGER_ERROR - Static variable in class bb.common.BIZReason
FIND_GENERAL_LEDGER_SETTINGS - Static variable in class bb.common.BIZReason
FIND_INCOTERMS_ERROR - Static variable in class bb.common.BIZReason
FIND_INSPECTION_TYPE_ERROR - Static variable in class bb.common.BIZReason
FIND_INVOICE_ERROR - Static variable in class bb.common.BIZReason
FIND_MANUFACTURER_ID_ERROR - Static variable in class bb.common.BIZReason
FIND_NCR_ERROR - Static variable in class bb.common.BIZReason
FIND_ON_LOAN_ERROR - Static variable in class bb.common.BIZReason
FIND_ON_LOAN_ITEM_ERROR - Static variable in class bb.common.BIZReason
FIND_PAR_ERROR - Static variable in class bb.common.BIZReason
FIND_PART_DESCRIPTION_ERROR - Static variable in class bb.common.BIZReason
FIND_PART_DISCOUNT_ERROR - Static variable in class bb.common.BIZReason
FIND_PARTPK_ERROR - Static variable in class bb.common.BIZReason
FIND_PAYMENT_RUN_ERROR - Static variable in class bb.common.BIZReason
FIND_POS_ERROR - Static variable in class bb.common.BIZReason
FIND_PURCHASE_ORDER_ERROR - Static variable in class bb.common.BIZReason
FIND_QUOTE_ERROR - Static variable in class bb.common.BIZReason
FIND_QUOTE_ITEM_ERROR - Static variable in class bb.common.BIZReason
FIND_RECEIVER_ERROR - Static variable in class bb.common.BIZReason
FIND_RMA_ERROR - Static variable in class bb.common.BIZReason
FIND_RMA_ITEM_ERROR - Static variable in class bb.common.BIZReason
FIND_RRMA_ERROR - Static variable in class bb.common.BIZReason
FIND_RRMA_ITEM_ERROR - Static variable in class bb.common.BIZReason
FIND_RTV_ERROR - Static variable in class bb.common.BIZReason
FIND_SALES_CODE_ERROR - Static variable in class bb.common.BIZReason
FIND_SALES_ORDER_ERROR - Static variable in class bb.common.BIZReason
FIND_SALES_ORDER_ID_ERROR - Static variable in class bb.common.BIZReason
FIND_SALES_ORDER_ITEM_ERROR - Static variable in class bb.common.BIZReason
FIND_SALESMAN_ERROR - Static variable in class bb.common.BIZReason
FIND_SHIPPER_ERROR - Static variable in class bb.common.BIZReason
FIND_SRUNNING_ACCOUNT_ORDER_ERROR - Static variable in class bb.common.BIZReason
FIND_TEMPORARYEMPLOYEE_ID_ERROR - Static variable in class bb.common.BIZReason
FIND_USER_GROUP_ERROR - Static variable in class bb.common.BIZReason
FIND_USER_ZIPCODE_TAX_ERROR - Static variable in class bb.common.BIZReason
FIND_VENDOR_ID_ERROR - Static variable in class bb.common.BIZReason
FIND_WEIGHT_UNIT_ERROR - Static variable in class bb.common.BIZReason
FIND_WORK_CENTER_ERROR - Static variable in class bb.common.BIZReason
FIND_WORK_INSTRUCTION_ERROR - Static variable in class bb.common.BIZReason
FIND_WORK_ORDER_ERROR - Static variable in class bb.common.BIZReason
findA2PartIssuedByDate(Date, Date, String, String, String, String, String, String, String, String, String, boolean, String[], int, int) - Method in interface bb.common.box.WarehouseBox
findAccountAgingTotalResult(String[], String[], boolean, Date) - Method in interface bb.common.box.AccountingBox
findAccountBalanceById(String, String, String, Date, Date, String, int, int) - Method in interface bb.common.box.AccountingBox
findAccountingInfoDocument(String, String, String, int, int) - Method in interface bb.common.box.AccountingBox
findAccountingTransactionTypeByPk(String) - Method in interface bb.common.box.AccountingBox
findAccountingTransactionTypes() - Method in interface bb.common.box.AccountingBox
findAccountingTransactionTypesByType(String, int, int) - Method in interface bb.common.box.AccountingBox
findAccountPayableChecksByCheckNumber(String, int, int) - Method in interface bb.common.box.AccountingBox
findAccountPayableChecksByCheckRunNumber(String, int, int) - Method in interface bb.common.box.AccountingBox
findAccountsChartCategoryForBalanceSheetByCategoryName(String, int, int) - Method in interface bb.common.box.AccountingBox
findAccountsChartCategoryForBalanceSheetPredefineByCategoryName(String, int, int) - Method in interface bb.common.box.AccountingBox
findAccountsChartCategoryForProfitLossByCategoryName(String, int, int) - Method in interface bb.common.box.AccountingBox
findAccountsChartCategoryForProfitLossPredefineByCategoryName(String, int, int) - Method in interface bb.common.box.AccountingBox
findAccountsChartCategoryForTaxDetailByCategoryName(String, int, int) - Method in interface bb.common.box.AccountingBox
findAccountsChartCategoryForTaxDetailPredefineByCategoryName(String, int, int) - Method in interface bb.common.box.AccountingBox
findAccountsChartMappingBySubcompanyId(String, int, int) - Method in interface bb.common.box.AccountingBox
findAccountsChartsByCompanyUnit(String, String, String, String, int, int) - Method in interface bb.common.box.AccountingBox
findAccountsChartsById(String, int, int) - Method in interface bb.common.box.AccountingBox
findAccountsChartsBySubType(String, String, String, String, int, int) - Method in interface bb.common.box.AccountingBox
findAccountsChartsByType(String, String, String, int, int) - Method in interface bb.common.box.AccountingBox
findAccountsChartsByType(String, String, String, String, int, int) - Method in interface bb.common.box.AccountingBox
findAddressAccountInfo(String, Date, Date, boolean, int, int) - Method in interface bb.common.box.AccountingBox
findAddressContactCount(String, String) - Method in interface bb.common.box.AddressBox
findAddressContactCount(String, String, boolean) - Method in interface bb.common.box.AddressBox
findAddressQualityDocumentsByCategory(String, String) - Method in interface bb.common.box.QualityBox
findAddressQualityDocumentsInfo(String, boolean, int, int) - Method in interface bb.common.box.QualityBox
findAgingAPItems(String[], String[], boolean, Date, int, int) - Method in interface bb.common.box.AccountingBox
findAgingAps(String[], String[], boolean, Date, int, int) - Method in interface bb.common.box.AccountingBox
findAgingARItems(String[], String[], boolean, Date, int, int) - Method in interface bb.common.box.AccountingBox
findAgingARs(String[], String[], boolean, Date, int, int) - Method in interface bb.common.box.AccountingBox
findAllAccountingTransactionTypes(boolean, int, int) - Method in interface bb.common.box.AccountingBox
findAllAccountPayableCheckRuns(int, int) - Method in interface bb.common.box.AccountingBox
findAllAccountPayableChecks(int, int) - Method in interface bb.common.box.AccountingBox
findAllAccountReceivablePayments(int, int) - Method in interface bb.common.box.AccountingBox
findAllAccountsCharts(boolean, int, int) - Method in interface bb.common.box.AccountingBox
findAllAddressContact(String, String, int, int) - Method in interface bb.common.box.AddressBox
findAllAddressContact(String, String, boolean, int, int) - Method in interface bb.common.box.AddressBox
findAllAppColumns() - Method in interface bb.common.box.CompanyBox
findAllAPs(int, int) - Method in interface bb.common.box.AccountingBox
findAllArBP(int, int) - Method in interface bb.common.box.AccountingBox
findAllARInvoicces(int, int) - Method in interface bb.common.box.AccountingBox
findAllARPaymentRuns(int, int) - Method in interface bb.common.box.AccountingBox
findAllARWithoutTracking(int, int) - Method in interface bb.common.box.AccountingBox
findAllAssets(int, int) - Method in interface bb.common.box.AccountingBox
findAllAssetsDepreciationMonths(String, int, int) - Method in interface bb.common.box.AccountingBox
findAllAssetTypes(int, int) - Method in interface bb.common.box.AccountingBox
findAllBankOrCashGLByDate(String, String, String, String, boolean, boolean, int, int) - Method in interface bb.common.box.AccountingBox
findAllBigCatagorys() - Method in interface bb.common.box.EngineeringBox
findAllBillsWithPartInfo(String, int, int) - Method in interface bb.common.box.EngineeringBox
findAllBomApprovals(int, int) - Method in interface bb.common.box.EngineeringBox
findAllBomItems(String[], String, int, int) - Method in interface bb.common.box.EngineeringBox
findAllBomsToDelete(int, int) - Method in interface bb.common.box.EngineeringBox
findAllBuyerCode(int, int) - Method in interface bb.common.box.CompanyBox
findAllCalibrations(int, int) - Method in interface bb.common.box.ManufacturingBox
findAllCanClosedNcrs(String, String, String, Date, Date, boolean, boolean, int, int) - Method in interface bb.common.box.QualityBox
findAllCars(int, int) - Method in interface bb.common.box.QualityBox
findAllCashier(int, int) - Method in interface bb.common.box.CompanyBox
findAllCertificateDescs() - Method in interface bb.common.box.QualityBox
findAllCompanyUnit(int, int) - Method in interface bb.common.box.CompanyBox
findAllCompanyUnitAccount(int, int) - Method in interface bb.common.box.CompanyBox
findAllContracts(int, int) - Method in interface bb.common.box.SalesBox
findAllCurrency(int, int) - Method in interface bb.common.box.CompanyBox
findAllCurrentCurrency(int, int) - Method in interface bb.common.box.CompanyBox
findAllCustomDepartment(int, int) - Method in interface bb.common.box.HumanResourceBox
findAllCustomerFeedback(int, int) - Method in interface bb.common.box.CustomerServiceBox
findAllCustomers(int, int) - Method in interface bb.common.box.AddressBox
findAllCustomerType(int, int) - Method in interface bb.common.box.AddressBox
findAllCustomerVendorAddresses(int, int) - Method in interface bb.common.box.AddressBox
findAllCustomSearch() - Method in interface bb.common.box.CompanyBox
findAllCustomTranslation() - Method in interface bb.common.box.CompanyBox
findAllCVAddress() - Method in interface bb.common.box.AddressBox
findAllDataFilter(int, int) - Method in interface bb.common.box.CompanyBox
findAllDepartmentLocationForBackflushs(int, int) - Method in interface bb.common.box.WarehouseBox
findAllDepartments(int, int) - Method in interface bb.common.box.AddressBox
findAllDetailAccountTransaction(String, String, String, String, boolean, boolean, String, boolean) - Method in interface bb.common.box.AccountingBox
findAllDisassembleWorkOrderApprovals(int, int) - Method in interface bb.common.box.WorkOrderBox
findAllDocument(int, int) - Method in interface bb.common.box.DocumentBox
findAllDocumentByDocumentType(String, int, int) - Method in interface bb.common.box.DocumentBox
findAllDocuments(String, String, String, String, String, String, boolean, int, int) - Method in interface bb.common.box.DocumentBox
findAllDocumentServerSettings(int, int) - Method in interface bb.common.box.CompanyBox
findAllDocumentType() - Method in interface bb.common.box.CompanyBox
findAllDueLoan(int, int) - Method in interface bb.common.box.WarehouseBox
findAllDueRma(int, int) - Method in interface bb.common.box.SalesBox
findAllDueSoItems(int, int) - Method in interface bb.common.box.SalesBox
findAllECNControl(int, int) - Method in interface bb.common.box.EngineeringBox
findAllECRControl(int, int) - Method in interface bb.common.box.EngineeringBox
findAllECRequests(String, int, int) - Method in interface bb.common.box.EngineeringBox
findAllEmployeeCards(int, int) - Method in interface bb.common.box.HumanResourceBox
findAllEmployeeLogs(int, int) - Method in interface bb.common.box.LogBox
findAllEngGroup(int, int) - Method in interface bb.common.box.EngineeringBox
findAllEngGroupId() - Method in interface bb.common.box.EngineeringBox
findAllEngGroupId(boolean) - Method in interface bb.common.box.EngineeringBox
findAllEngineeringChanges(String, int, int) - Method in interface bb.common.box.EngineeringBox
findAllEquipments(int, int) - Method in interface bb.common.box.ManufacturingBox
findAllExpenseAccount(int, int) - Method in interface bb.common.box.AccountingBox
findAllExpenses(int, int) - Method in interface bb.common.box.AccountingBox
findAllExpireDateDoc(String, String, String, Date, Date, String, int, int) - Method in interface bb.common.box.AddressBox
findAllFirstLevelAccountFiscalYearBalance() - Method in interface bb.common.box.AccountingBox
findAllFiscalYearSettings(int, int) - Method in interface bb.common.box.AccountingBox
findAllGeneralLedgerApproval(int, int) - Method in interface bb.common.box.AccountingBox
findAllGeneralLedgers(String, String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.AccountingBox
findAllGLAutoApproves(int, int) - Method in interface bb.common.box.AccountingBox
findAllGLCategories(int, int) - Method in interface bb.common.box.AccountingBox
findAllGlMonth(int, int) - Method in interface bb.common.box.AccountingBox
findAllHelpServers(int, int) - Method in interface bb.common.box.CompanyBox
findAllIncidentItem(int, int) - Method in interface bb.common.box.CustomerServiceBox
findAllIncidents(int, int) - Method in interface bb.common.box.CustomerServiceBox
findAllIncoterms(int, int) - Method in interface bb.common.box.SalesBox
findAllInspectionItem(int, int, int) - Method in interface bb.common.box.ManufacturingBox
findAllInspectionReportInspectMethod(int, int) - Method in interface bb.common.box.ManufacturingBox
findAllLabelTemplate(int, int) - Method in interface bb.common.box.WarehouseBox
findAllLockedCustomer(boolean, int, int) - Method in interface bb.common.box.AddressBox
findAllLogInventory(int, int) - Method in interface bb.common.box.WarehouseBox
findAllLogs(int, int) - Method in interface bb.common.box.LogBox
findAllManufacturerAddresses(int, int) - Method in interface bb.common.box.AddressBox
*********************below is about ManufacturerAddress*********************
findAllManufacturerECRequests(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findAllManufacturerEngineeringChanges(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findAllMasterWorkOrder(String, String, String, String, int, int) - Method in interface bb.common.box.WorkOrderBox
findAllMethod(int, int) - Method in interface bb.common.box.SecurityBox
findAllMiscDocSetting(int, int) - Method in interface bb.common.box.CompanyBox
findAllMPNParts() - Method in interface bb.common.box.PurchasingBox
findAllMyWorkOrderWorkSheet(int, int) - Method in interface bb.common.box.WorkOrderBox
findAllNCCs(int, int) - Method in interface bb.common.box.QualityBox
findAllNCRs(int, int) - Method in interface bb.common.box.QualityBox
findAllNonproductivePickingApprovals(int, int) - Method in interface bb.common.box.WarehouseBox
findAllNonproductivePickingTypes(int, int) - Method in interface bb.common.box.WarehouseBox
findAllNotClosedProformaInvoices(int, int) - Method in interface bb.common.box.WarehouseBox
findAllNotEmployeeLogs(int, int) - Method in interface bb.common.box.LogBox
findAllOldMessgeId() - Method in interface bb.common.box.CompanyBox
findAllOnHandAudit(String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findAllOnlineUsers(int, int) - Method in interface bb.common.box.SecurityBox
findAllOnLoanByAddressId(String, int, int) - Method in interface bb.common.box.WarehouseBox
findAllOnloanControl(int, int) - Method in interface bb.common.box.WarehouseBox
findAllOnLoans(int, int) - Method in interface bb.common.box.WarehouseBox
findAllOnloanShippers(int, int) - Method in interface bb.common.box.WarehouseBox
findAllOpenLoan(int, int) - Method in interface bb.common.box.WarehouseBox
findAllOpenOnLoanByAddressId(String, int, int) - Method in interface bb.common.box.WarehouseBox
findAllOpenQuote(int, int) - Method in interface bb.common.box.SalesBox
findAllOpenRma(int, int) - Method in interface bb.common.box.SalesBox
findAllOpenSoItems(boolean, int, int) - Method in interface bb.common.box.SalesBox
findAllOpenSoItemsByAddressId(String, int, int) - Method in interface bb.common.box.SalesBox
findAllOpenSoItemsByAddressIdandShipVia(String, String, int, int) - Method in interface bb.common.box.SalesBox
findAllOperatingInstructionsInspectStandard(int, int) - Method in interface bb.common.box.ManufacturingBox
findAllOperatingInstructionsManual(int, int) - Method in interface bb.common.box.ManufacturingBox
findAllOperatingInstructionsType(int, int) - Method in interface bb.common.box.ManufacturingBox
findAllOperatingOutputFileType(int, int) - Method in interface bb.common.box.ManufacturingBox
findAllPackingBox(int, int) - Method in interface bb.common.box.WarehouseBox
findAllPars(int, int) - Method in interface bb.common.box.QualityBox
findAllPartCatagorys() - Method in interface bb.common.box.EngineeringBox
findAllPartCertificates(int, int) - Method in interface bb.common.box.QualityBox
findAllPartDiscount(int, int) - Method in interface bb.common.box.SalesBox
findAllPartInQAsToMakeNCR(String, int, int) - Method in interface bb.common.box.QualityBox
findAllPartInQAsWithoutNCR(BB2Part, int, int) - Method in interface bb.common.box.WarehouseBox
findAllPartNumbers(String, String) - Method in interface bb.common.box.EngineeringBox
findAllPartNumbers() - Method in interface bb.common.box.EngineeringBox
findAllPartOnhand(int, int) - Method in interface bb.common.box.WarehouseBox
findAllParts(int, int) - Method in interface bb.common.box.EngineeringBox
findAllPartSecurityLevel(int, int) - Method in interface bb.common.box.EngineeringBox
findAllPartsToDelete(int, int) - Method in interface bb.common.box.EngineeringBox
findAllPartsWithOnhandInfo(String, String, String, int, int) - Method in interface bb.common.box.EngineeringBox
findAllPartsWithOnhandInfo(String, String, String, String, String, String, String, String, String, boolean, boolean, int, int) - Method in interface bb.common.box.EngineeringBox
findAllPartTraceableByPN(String) - Method in interface bb.common.box.PurchasingBox
findAllPartTraceableBySN(String) - Method in interface bb.common.box.SalesBox
findAllPartType(int, int) - Method in interface bb.common.box.CompanyBox
findAllPartUseType() - Method in interface bb.common.box.WorkOrderBox
findAllPastDueLoanByAddressId(String, int, int) - Method in interface bb.common.box.WarehouseBox
findAllPastDueSoItemsByAddressId(String, int, int) - Method in interface bb.common.box.SalesBox
findAllPastedQuotes(int, int) - Method in interface bb.common.box.SalesBox
findAllPermission(boolean, int, int) - Method in interface bb.common.box.SecurityBox
findAllPermissionMethod(int, int) - Method in interface bb.common.box.SecurityBox
findAllPermissionMethodsByUserName(String) - Method in interface bb.common.box.SecurityBox
findAllPermissionWithLanguage(boolean, String, int, int) - Method in interface bb.common.box.SecurityBox
findAllPfReceivers(int, int) - Method in interface bb.common.box.PurchasingBox
findAllPoMessages() - Method in interface bb.common.box.PurchasingBox
findAllPrintLogo() - Method in interface bb.common.box.CompanyBox
findAllPrintTemplate(int, int) - Method in interface bb.common.box.CompanyBox
findAllProformaInvoices(int, int) - Method in interface bb.common.box.WarehouseBox
findAllPurchaseOrderApprovals(int, int) - Method in interface bb.common.box.ManufacturingBox
findAllPurchaseOrderApprovals(int, int) - Method in interface bb.common.box.PurchasingBox
findAllPurchaseOrderBP(int, int) - Method in interface bb.common.box.ManufacturingBox
findAllPurchaseOrderBP(int, int) - Method in interface bb.common.box.PurchasingBox
findAllPurchaseOrderByAddressId(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findAllPurchaseOrderByAddressId(String, int, int) - Method in interface bb.common.box.PurchasingBox
findAllPurchaseOrderCheckListResults(int, int) - Method in interface bb.common.box.ManufacturingBox
findAllPurchaseOrderCheckListResults(int, int) - Method in interface bb.common.box.PurchasingBox
findAllPurchaseOrderItems(int, int) - Method in interface bb.common.box.ManufacturingBox
findAllPurchaseOrderItems(int, int) - Method in interface bb.common.box.PurchasingBox
findAllPurchaseOrderItemsByAddressId(String, String, int, int) - Method in interface bb.common.box.PurchasingBox
findAllPurchaseOrders(int, int) - Method in interface bb.common.box.ManufacturingBox
findAllPurchaseOrders(int, int) - Method in interface bb.common.box.PurchasingBox
findAllPurchaseOrderStatistics(String, String, String, String, String, int, int) - Method in interface bb.common.box.PurchasingBox
findAllPurchaseTaxAccount(int, int) - Method in interface bb.common.box.CompanyBox
findAllPurchaseWorkSheet(int, int) - Method in interface bb.common.box.ManufacturingBox
findAllPurchaseWorkSheet(int, int) - Method in interface bb.common.box.PurchasingBox
findAllQualityGroups(int, int) - Method in interface bb.common.box.QualityBox
findAllQuestions(int, int) - Method in interface bb.common.box.CustomerServiceBox
findAllQuoteBP(int, int) - Method in interface bb.common.box.SalesBox
findAllQuotes(int, int) - Method in interface bb.common.box.SalesBox
findAllReceivedMessages(String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.CompanyBox
findAllRfcs(int, int) - Method in interface bb.common.box.ManufacturingBox
findAllRfqCheckListResults(int, int) - Method in interface bb.common.box.ManufacturingBox
findAllRfqCheckListResults(int, int) - Method in interface bb.common.box.PurchasingBox
findAllRfqMessages() - Method in interface bb.common.box.PurchasingBox
findAllRMAReviews(int, int) - Method in interface bb.common.box.SalesBox
findAllRmas(int, int) - Method in interface bb.common.box.SalesBox
findAllRoles(String, int, int) - Method in interface bb.common.box.SecurityBox
findAllRolesByRoleId(String, String, int, int) - Method in interface bb.common.box.SecurityBox
findAllRTVApprovals(int, int) - Method in interface bb.common.box.PurchasingBox
findAllRtvCheckListResults(int, int) - Method in interface bb.common.box.ManufacturingBox
findAllRtvCheckListResults(int, int) - Method in interface bb.common.box.PurchasingBox
findAllSalesCode(int, int) - Method in interface bb.common.box.SalesBox
findAllSalesCodeName(int, int) - Method in interface bb.common.box.SalesBox
findAllSalesmen(int, int) - Method in interface bb.common.box.SalesBox
findAllSalesOrderBP(int, int) - Method in interface bb.common.box.SalesBox
findAllSalesOrderControl(int, int) - Method in interface bb.common.box.SalesBox
findAllSalesOrders(int, int) - Method in interface bb.common.box.SalesBox
findAllSalesOrdersByAddressId(String, int, int) - Method in interface bb.common.box.SalesBox
findAllSalesTaxAccount(int, int) - Method in interface bb.common.box.CompanyBox
findAllSentMessages(String, String, String, Date, Date, int, int) - Method in interface bb.common.box.CompanyBox
findAllSerialNumbers(int, int) - Method in interface bb.common.box.QualityBox
findAllShipListOwners(int, int) - Method in interface bb.common.box.PlanningBox
findAllShipLists(int, int) - Method in interface bb.common.box.PlanningBox
findAllShippers(int, int) - Method in interface bb.common.box.WarehouseBox
findAllSmallCatagorys(String) - Method in interface bb.common.box.EngineeringBox
findAllSoItemsByAddressId(String, int, int) - Method in interface bb.common.box.SalesBox
findAllSOItemsCanShip(String, Date, Date, int, int) - Method in interface bb.common.box.SalesBox
findAllStatements() - Method in interface bb.common.box.AccountingBox
findAllSubcompanysById(String, int, int) - Method in interface bb.common.box.CompanyBox
findAllSwapOrderApproval(int, int) - Method in interface bb.common.box.PurchasingBox
findAllTasks(int, int) - Method in interface bb.common.box.CompanyBox
findAllTerms(int, int) - Method in interface bb.common.box.CompanyBox
findAllTermsConditions() - Method in interface bb.common.box.CompanyBox
findAllTimeCards(int, int) - Method in interface bb.common.box.ManufacturingBox
findAllToolListsWithToolInfo(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findAllTools(int, int) - Method in interface bb.common.box.ManufacturingBox
findAllTopMasterWorkOrder(Date, Date, String, String, String, String, boolean, boolean, String, String) - Method in interface bb.common.box.WorkOrderBox
findAllTraceableCategories(int, int) - Method in interface bb.common.box.EngineeringBox
findAllTraceableSpecs(int, int) - Method in interface bb.common.box.EngineeringBox
findAllTransferOrderApproval(int, int) - Method in interface bb.common.box.WarehouseBox
findAllUsers(int, int) - Method in interface bb.common.box.SecurityBox
findAllUsersEmployeeInfo(String, String, int, int) - Method in interface bb.common.box.SecurityBox
findAllUsersEmployeeInfo(String, String, boolean, int, int) - Method in interface bb.common.box.SecurityBox
findAllVendorContracts(int, int) - Method in interface bb.common.box.PurchasingBox
findAllVendors(int, int) - Method in interface bb.common.box.AddressBox
findAllVendorType(int, int) - Method in interface bb.common.box.AddressBox
findAllWarehouses(int, int) - Method in interface bb.common.box.WarehouseBox
findAllWeightUnit(String, int, int) - Method in interface bb.common.box.CompanyBox
findAllWeightUnit(int, int) - Method in interface bb.common.box.CompanyBox
findAllWorkCalendar(Date, Date, int, int, int) - Method in interface bb.common.box.ManufacturingBox
findAllWorkFlow(int, int) - Method in interface bb.common.box.CompanyBox
findAllWorkInstructions(int, int) - Method in interface bb.common.box.ManufacturingBox
findAllWorkOrderApprovals(int, int) - Method in interface bb.common.box.WorkOrderBox
findAllWorkOrderBP(int, int) - Method in interface bb.common.box.WorkOrderBox
findAllWorkOrderCheckListResults(int, int) - Method in interface bb.common.box.WorkOrderBox
findAllWorkOrderReceivers(int, int) - Method in interface bb.common.box.WarehouseBox
findAllWorkOrderWorkSheet(int, int) - Method in interface bb.common.box.WorkOrderBox
findAllZipCode(String, int, int) - Method in interface bb.common.box.CompanyBox
findAllZipCodeTaxByTaxType(String, int, int) - Method in interface bb.common.box.CompanyBox
findAP(String, String, String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.AccountingBox
findAPAccountInfo(String, int, int) - Method in interface bb.common.box.AccountingBox
findAPAgingTotalResult(String[], String[], boolean, Date) - Method in interface bb.common.box.AccountingBox
findAPAR(String) - Method in interface bb.common.box.AccountingBox
findAPbyAddressIdSet(String[], String[], boolean, Date, int, int) - Method in interface bb.common.box.AccountingBox
findApByDate(String, String, String, String, String, String, String, String, Date, Date, String, int, int) - Method in interface bb.common.box.AccountingBox
findApByDate(String, String, String, String, String, String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.AccountingBox
findAPByPk(String) - Method in interface bb.common.box.AccountingBox
findAPbyZipcodeTaxList(String, String, String, String, Date, Date) - Method in interface bb.common.box.AccountingBox
findApCheckRunByDate(Date, Date, String, String, String, String, String, int, int) - Method in interface bb.common.box.AccountingBox
findAPCheckRunItemByCheckRunNumber(String) - Method in interface bb.common.box.AccountingBox
findAPCheckRunsByCheckRunNumberLike(String, int, int) - Method in interface bb.common.box.AccountingBox
findAPItemsByApNumber(String) - Method in interface bb.common.box.AccountingBox
findAPItemsByPk(AccountsPayableItemPK) - Method in interface bb.common.box.AccountingBox
findAppDataBySql(String, HashMap, int, int) - Method in interface bb.common.box.CompanyBox
findApPrepay(String, String, String, Date, Date, int, int) - Method in interface bb.common.box.AccountingBox
findAPPrepayToBatchPaymentbyAddressIdSet(String[], String[], String, Date, Date) - Method in interface bb.common.box.AccountingBox
findApPrepayTotal(String, String, String, Date, Date, int, int) - Method in interface bb.common.box.AccountingBox
findAPs(String, String, String, String) - Method in interface bb.common.box.AccountingBox
findAPsByAddressIdAndStatus(String, String, int, int) - Method in interface bb.common.box.AccountingBox
findAPsByApNumber(String, int, int) - Method in interface bb.common.box.AccountingBox
findAPsByVendorId(String, int, int) - Method in interface bb.common.box.AccountingBox
findAPsByVendorInvoice(String, int, int) - Method in interface bb.common.box.AccountingBox
findAPsTotalMoneyByVendorId(String) - Method in interface bb.common.box.AccountingBox
findAPToBatchPaymentbyAddressIdSet(String[], String[], String, String, Date, Date) - Method in interface bb.common.box.AccountingBox
findAPTotalMoneyByDate(String, String, String, String, String, String, String, String, String, Date, Date, String) - Method in interface bb.common.box.AccountingBox
findARAccountInfo(String, int, int) - Method in interface bb.common.box.AccountingBox
findArBPByBPId(String, int, int) - Method in interface bb.common.box.AccountingBox
findARbyAddressIdSet(String[], String[], boolean, Date, int, int) - Method in interface bb.common.box.AccountingBox
findARByPk(String) - Method in interface bb.common.box.AccountingBox
findARbyZipcodeTaxList(String, String, String, String, Date, Date) - Method in interface bb.common.box.AccountingBox
findArCommissionByDate(String, String, String, Date, Date, int, int) - Method in interface bb.common.box.AccountingBox
findARItemByPartAndDate(Date, Date, BB2Part, int, int) - Method in interface bb.common.box.AccountingBox
findARItemsByInvoiceNumber(String) - Method in interface bb.common.box.AccountingBox
findARItemsByPartNumber(String) - Method in interface bb.common.box.AccountingBox
findARItemsByPk(AccountsReceivableItemPK) - Method in interface bb.common.box.AccountingBox
findArPaymentAccounts() - Method in interface bb.common.box.AccountingBox
findArPaymentByDate(Date, Date, String, String, String, String, int, int) - Method in interface bb.common.box.AccountingBox
findARPaymentRunsByPaymentNumberLike(String, int, int) - Method in interface bb.common.box.AccountingBox
findARPaymentsByPaymentNumberLike(String, int, int) - Method in interface bb.common.box.AccountingBox
findARPaymentsByPaymentRunNumber(String, int, int) - Method in interface bb.common.box.AccountingBox
findArPrepay(String, String, String, Date, Date, int, int) - Method in interface bb.common.box.AccountingBox
findARPrepayToBatchReceivebyAddressIdSet(String[], String[], String, Date, Date) - Method in interface bb.common.box.AccountingBox
findArPrepayTotal(String, String, String, Date, Date, int, int) - Method in interface bb.common.box.AccountingBox
findARs(String, Date, Date) - Method in interface bb.common.box.AccountingBox
findArSalesCodeTotalByDate(String, String, String, Date, Date, int, int) - Method in interface bb.common.box.AccountingBox
findARsByCustomerId(String, int, int) - Method in interface bb.common.box.AccountingBox
findARsByDate(String, boolean, boolean, Date, Date, String, int, int) - Method in interface bb.common.box.AccountingBox
findARsByInvoiceNumber(String, String, int, int) - Method in interface bb.common.box.AccountingBox
findARsTotalMoneyByCustomerId(String) - Method in interface bb.common.box.AccountingBox
findARsTotalMoneyByDate(String, boolean, boolean, Date, Date, String) - Method in interface bb.common.box.AccountingBox
findARToBatchReceivebyAddressId(String, String, String, Date, Date) - Method in interface bb.common.box.AccountingBox
findARToBatchReceivebyAddressIdSet(String[], String[], String, String, Date, Date) - Method in interface bb.common.box.AccountingBox
findARTotalMoneyByDate(String, String, boolean, String, String, String, boolean, String, String, String, String, String, boolean, Date, Date, BigDecimal, BigDecimal, boolean, Map) - Method in interface bb.common.box.AccountingBox
findARTotalMoneyByDate(boolean, String, String, boolean, Date, Date) - Method in interface bb.common.box.AccountingBox
findARTotalMoneyByDate(String[]) - Method in interface bb.common.box.AccountingBox
findAssetAdditions(String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.AccountingBox
findAssetByPk(String) - Method in interface bb.common.box.AccountingBox
findAssetDepreciateDetails(String, String, String, String, String, String, String) - Method in interface bb.common.box.AccountingBox
findAssetDepreciates(String, String, String, String, String, String, String, String, int, int) - Method in interface bb.common.box.AccountingBox
findAssetDisposals(String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.AccountingBox
findAssetsByAssetNumber(String, int, int) - Method in interface bb.common.box.AccountingBox
findAssetsList(String, String, String, String, String, String, String, String, String, int, int) - Method in interface bb.common.box.AccountingBox
findAvailablePartsForCGCustomer(String, String, String, String, String, String, boolean, int, int) - Method in interface bb.common.box.SalesBox
findAvailablePartsToSalesCatalog(String, String, String, String, String, int, int) - Method in interface bb.common.box.SalesBox
findBackfulshMaterialPartOnhandResults(String, String, boolean, int, int) - Method in interface bb.common.box.WarehouseBox
findBackOrCashCheckRegister(String, String, String, String, String, String) - Method in interface bb.common.box.AccountingBox
findBackOrCashCheckRegisterDetail(String, String, String, String, String, String, String) - Method in interface bb.common.box.AccountingBox
findBalanceSheet(String) - Method in interface bb.common.box.AccountingBox
findBalanceSheetOfCategory(String) - Method in interface bb.common.box.AccountingBox
findBalanceSheetSBS(String) - Method in interface bb.common.box.AccountingBox
findBankReconciliationReport(String, String, String, int, int) - Method in interface bb.common.box.AccountingBox
findBB2PartInSipItemResults(BB2Part) - Method in interface bb.common.box.WarehouseBox
findBB2PartInventoryResults(HashSet) - Method in interface bb.common.box.WarehouseBox
findBB2PartOnDemandListResultForPart(boolean, int, int) - Method in interface bb.common.box.PurchasingBox
findBillItemOnHandWithPartInfoByBillPk(BillPK, String, boolean, String) - Method in interface bb.common.box.EngineeringBox
findBillItemWithPartInfoByBillPk(BillPK, String, boolean) - Method in interface bb.common.box.EngineeringBox
findBillItemWithPartInfoByBillPk(BillPK, String, boolean, int, int) - Method in interface bb.common.box.EngineeringBox
findBillLog(String, String, String, Date, Date, int, int) - Method in interface bb.common.box.EngineeringBox
findBillswithPartInfoByBillNumberLike(boolean, Date, Date, String, String, String, boolean, String, String, String, int, int) - Method in interface bb.common.box.EngineeringBox
findBOMItemNotPart() - Method in interface bb.common.box.CompanyBox
findBOMNotPart() - Method in interface bb.common.box.CompanyBox
findBuyerCodeByBuyerCodeLike(String, int, int) - Method in interface bb.common.box.CompanyBox
findCalibrationByPart(String, String) - Method in interface bb.common.box.ManufacturingBox
findCalibrationsByAssignedTo(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findCalibrationsByDate(Date, Date, boolean, PartPK, String, int, int) - Method in interface bb.common.box.ManufacturingBox
findCalibrationsByInspectedBy(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findCalibrationsByLocation(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findCalibrationsByNextInspectionInDays(int, int, int) - Method in interface bb.common.box.ManufacturingBox
findCalibrationsDue(int, int) - Method in interface bb.common.box.ManufacturingBox
findCancelledDisassembleWorkOrderListResults(int, int) - Method in interface bb.common.box.WorkOrderBox
findCancelledPurchaseOrderItems(int, int) - Method in interface bb.common.box.PurchasingBox
findCancelledQuoteItem(int, int) - Method in interface bb.common.box.SalesBox
findCancelledRequestForQuoteItemListResults(int, int) - Method in interface bb.common.box.PurchasingBox
findCancelledReturnToVendorItemsListResults(int, int) - Method in interface bb.common.box.PurchasingBox
findCancelledRmaItems(int, int) - Method in interface bb.common.box.SalesBox
findCancelledSwapOrder(int, int) - Method in interface bb.common.box.PurchasingBox
findCarByPk(String) - Method in interface bb.common.box.QualityBox
findCarrierByAddressIds(String[]) - Method in interface bb.common.box.AddressBox
findCarriersByAddressId(String) - Method in interface bb.common.box.AddressBox
findCars(String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.QualityBox
findCarsByCarNumber(String, int, int) - Method in interface bb.common.box.QualityBox
findCarsByPastDue(int, int) - Method in interface bb.common.box.QualityBox
findCarsByPn(String, String, int, int) - Method in interface bb.common.box.QualityBox
findCarsByStatus(String, int, int) - Method in interface bb.common.box.QualityBox
findCashFlowBudget(String, String, String, boolean) - Method in interface bb.common.box.AccountingBox
findCashFlowByMonthReport(String, String, String) - Method in interface bb.common.box.AccountingBox
findCashFlowMonthTotalBudget(String, String, String) - Method in interface bb.common.box.AccountingBox
findCatalogs(String, String, int, int) - Method in interface bb.common.box.SalesBox
findCertificateDescByPk(int) - Method in interface bb.common.box.QualityBox
findCertificateDescs(int, int) - Method in interface bb.common.box.QualityBox
findChangeStdCostWorkSheet(int, int) - Method in interface bb.common.box.AccountingBox
findChangeStdCostWorkSheetItem(Long, int, int) - Method in interface bb.common.box.AccountingBox
findCheckList(int, int) - Method in interface bb.common.box.SalesBox
findCheckList(int, int) - Method in interface bb.common.box.WarehouseBox
findCheckNumberByPOWithApp(String) - Method in interface bb.common.box.AccountingBox
findCheckNumberBySOWithArp(String) - Method in interface bb.common.box.AccountingBox
findCheckRunItemByCheckNo(String, String, String) - Method in interface bb.common.box.AccountingBox
findClosedGlMonth(int, int) - Method in interface bb.common.box.AccountingBox
findCloseTimeCards(String, String, String, Date, Date, String, String, int, int) - Method in interface bb.common.box.ManufacturingBox
findClosingStatement(String, String) - Method in interface bb.common.box.AccountingBox
findCMByDate(String, String, String, String, String, boolean, Date, Date, int, int) - Method in interface bb.common.box.AccountingBox
findCMByDate(String[], int, int) - Method in interface bb.common.box.AccountingBox
findCMItemByDate(String, String, String, String, String, String, boolean, Date, Date, int, int) - Method in interface bb.common.box.AccountingBox
findCMsByCMNumber(String, int, int) - Method in interface bb.common.box.AccountingBox
findCMsByCustomerId(String, int, int) - Method in interface bb.common.box.AccountingBox
findCommitCycleCountListResults(int, boolean, int, int) - Method in interface bb.common.box.WarehouseBox
findCommitPhysicalInventoryListResults(int, boolean, int, int) - Method in interface bb.common.box.WarehouseBox
findCommonPrintTemplate(int, int) - Method in interface bb.common.box.CompanyBox
findCompanyAddressBook(int, int) - Method in interface bb.common.box.HumanResourceBox
findCompanyUnitList(String, String, String, int, int) - Method in interface bb.common.box.CompanyBox
findContractCustomersByContractNumber(String, int, int) - Method in interface bb.common.box.SalesBox
findContractItemFromQuoteItem(String, String) - Method in interface bb.common.box.SalesBox
findContractItemsByContractNumber(String, int, int) - Method in interface bb.common.box.SalesBox
findContractPriceCustomerByCustomList(String, HashSet<String>) - Method in interface bb.common.box.CompanyBox
findContractPriceItemByPartNumberList(String, HashSet<PartPK>) - Method in interface bb.common.box.CompanyBox
findContractsByAddressId(String, int, int) - Method in interface bb.common.box.SalesBox
findContractsByContractNumber(String, int, int) - Method in interface bb.common.box.SalesBox
findContractVendorsByContractNumber(String, int, int) - Method in interface bb.common.box.PurchasingBox
findCreditListByApNumber(String, String, int, int) - Method in interface bb.common.box.AccountingBox
findCreditListByAppNumber(String, int, int) - Method in interface bb.common.box.AccountingBox
findCreditListByArNumber(String, String, int, int) - Method in interface bb.common.box.AccountingBox
findCurrencyExchangeByMonth(String) - Method in interface bb.common.box.CompanyBox
findCurrentAllGlMonth(int, int) - Method in interface bb.common.box.AccountingBox
findCurrentBalanceResult(String, String, String, String, int, int) - Method in interface bb.common.box.AccountingBox
findCurrentFiscalYearARByMonth() - Method in interface bb.common.box.AccountingBox
findCurrentFiscalYearARGrossMarginByMonth() - Method in interface bb.common.box.AccountingBox
findCurrentPrepayStatementByVendorId(String, String, int, int) - Method in interface bb.common.box.AccountingBox
findCurrentStatementByCustomerId(String, String, Date, int, int) - Method in interface bb.common.box.AccountingBox
findCurrentStatementByVendorId(String, String, int, int) - Method in interface bb.common.box.AccountingBox
findCustomAssetByName(String, String, String, String, int, int) - Method in interface bb.common.box.HumanResourceBox
findCustomCheckUpByName(String, String, Date, Date, int, int, int) - Method in interface bb.common.box.HumanResourceBox
findCustomEmployeeByCondition(String, String, int, String, String, String, String, String, String, int, String, String, int, int) - Method in interface bb.common.box.HumanResourceBox
findCustomEmployeeTrain(String, String, String, int, int) - Method in interface bb.common.box.HumanResourceBox
findCustomerAddressesById(String, int, int) - Method in interface bb.common.box.AddressBox
findCustomerAddressesByName(String, String, int, int) - Method in interface bb.common.box.AddressBox
findCustomerFeedbackByDate(String, String, String, String, String, boolean, Date, Date, int, int) - Method in interface bb.common.box.CustomerServiceBox
findCustomerFeedbacksByFeedBackNumber(String, int, int) - Method in interface bb.common.box.CustomerServiceBox
findCustomerOnTimeDeliveryRateByCustomerId(String, Date, Date, String, int, int, String, String, String, String, int, int) - Method in interface bb.common.box.SalesBox
findCustomerPrepayStatementById(String, String, int, int) - Method in interface bb.common.box.AccountingBox
findCustomerPrepayStatementById(String, String, Date, int, int) - Method in interface bb.common.box.AccountingBox
findCustomerPrepayStatementById(String, String, String, Date, int, int) - Method in interface bb.common.box.AccountingBox
findCustomerPrepayStatementsTotal(String, Date, String) - Method in interface bb.common.box.AccountingBox
findCustomerPrepayStatementsTotal(String, String, Date, String) - Method in interface bb.common.box.AccountingBox
findCustomersList(String, String, String, int, int) - Method in interface bb.common.box.AddressBox
findCustomerStatementsTotal(String, Date, String) - Method in interface bb.common.box.AccountingBox
findCustomerStatementsTotal(String, String, Date, String) - Method in interface bb.common.box.AccountingBox
findCustomerStatementTotalByDate(String, Date, Date, String) - Method in interface bb.common.box.AccountingBox
findCustomerVendorAddressesById(String, int, int) - Method in interface bb.common.box.AddressBox
findCustomerVendorAddressesById(String, String, String) - Method in interface bb.common.box.AddressBox
findCustomerVendorAddressesByName(String, String, int, int) - Method in interface bb.common.box.AddressBox
findCustomerVendorbyType(String[], int, int) - Method in interface bb.common.box.AddressBox
findCustomerVendorIDByOrderNumber(String) - Method in interface bb.common.box.QualityBox
findCustomerVendors(String, String, String, String, String, String, String, int, int) - Method in interface bb.common.box.AddressBox
findCustomerVendorsByRegion(String, String, int, int) - Method in interface bb.common.box.AddressBox
findCustomerVendorsByValidDate(Date, int, int) - Method in interface bb.common.box.AddressBox
findCustomGoodsBreedById(String, String, int, int) - Method in interface bb.common.box.HumanResourceBox
findCustomGoodsRecordByDate(String, String, Date, Date, int, int) - Method in interface bb.common.box.HumanResourceBox
findCustomJobCategoryById(String, String, int, int) - Method in interface bb.common.box.HumanResourceBox
findCustomSearchResult(ArrayList<String>, HashMap<String, Object>, String, int, int) - Method in interface bb.common.box.CompanyBox
findCustomSearchTotalResult(ArrayList<String>, HashMap<String, Object>, String) - Method in interface bb.common.box.CompanyBox
findCycleCountListByPartNumber(int, String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findCycleCountListResults(int, int, int, int) - Method in interface bb.common.box.WarehouseBox
findCycleCountListResults(int, int, int) - Method in interface bb.common.box.WarehouseBox
findCycleCountListResultsWithAvgCost(int, int, int, int) - Method in interface bb.common.box.WarehouseBox
findCycleWorkSheetListResults(int, int) - Method in interface bb.common.box.WarehouseBox
findCycleWorkSheetListResults(int, int, int) - Method in interface bb.common.box.WarehouseBox
findDCsByDcNumber(String, int, int) - Method in interface bb.common.box.EngineeringBox
findDCsByEngineerNameLike(String, int, int) - Method in interface bb.common.box.EngineeringBox
findDCsByPartLike(String, String, String, int, int) - Method in interface bb.common.box.EngineeringBox
findDebitListByApNumber(String, String, int, int) - Method in interface bb.common.box.AccountingBox
findDebitListByAppNumber(String, int, int) - Method in interface bb.common.box.AccountingBox
findDebitListByArNumber(String, String, int, int) - Method in interface bb.common.box.AccountingBox
findDeletedCustomersById(String, int, int) - Method in interface bb.common.box.AddressBox
findDeletedCustomerVendorAddressesById(String, int, int) - Method in interface bb.common.box.AddressBox
findDeletedDepartmentsById(String, int, int) - Method in interface bb.common.box.AddressBox
findDeletedManufacturerAddresses(String, String, int, int) - Method in interface bb.common.box.AddressBox
findDeletedVendorsById(String, int, int) - Method in interface bb.common.box.AddressBox
findDepartmentsById(String, int, int) - Method in interface bb.common.box.AddressBox
findDepartmentsByName(String, String, int, int) - Method in interface bb.common.box.AddressBox
findDepartmentsList(String, String, int, int) - Method in interface bb.common.box.AddressBox
findDepositSummary(String[], Date, Date) - Method in interface bb.common.box.AccountingBox
findDisassembleWorkOrderDocumentInfo(String) - Method in interface bb.common.box.WorkOrderBox
findDisassembleWorkOrderListResultById(String, String[], String, int, int) - Method in interface bb.common.box.WorkOrderBox
findDisassembleWorkOrderListResultsByDate(String, Date, Date, String, String, String, String, String, String, String, String, boolean, String, String, int, int) - Method in interface bb.common.box.WorkOrderBox
findDisassembleWorkOrderListResultsByDwoNumber(String, int, int) - Method in interface bb.common.box.WorkOrderBox
findDisassembleWorkOrderListResultsByPN(String, String, int, int) - Method in interface bb.common.box.WorkOrderBox
findDisassembleWorkOrderReceivedDetail(DisassembleWorkOrderItemPK, BB2Part, String, int, int) - Method in interface bb.common.box.WorkOrderBox
findDM(String, String, String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.AccountingBox
findDMAccountInfo(String, int, int) - Method in interface bb.common.box.AccountingBox
findDMByDate(String, String, String, String, String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.AccountingBox
findDMByDate(String, String, String, String, String, String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.AccountingBox
findDMByPk(String) - Method in interface bb.common.box.AccountingBox
findDMTotalMoneyByDate(String, String, String, String, String, String, String, String, String, Date, Date) - Method in interface bb.common.box.AccountingBox
findDueECRequest(String, int, int) - Method in interface bb.common.box.EngineeringBox
findDueEngineerningChange(String, int, int) - Method in interface bb.common.box.EngineeringBox
findDueIncidents(int, int) - Method in interface bb.common.box.CustomerServiceBox
findDueManufacturerECRequest(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findDueManufacturerEngineerningChange(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findDueNCRs(int, int) - Method in interface bb.common.box.QualityBox
findDuePARs(int, int) - Method in interface bb.common.box.QualityBox
findDuePurchaseOrderItemByBuyerCode(String, int, int) - Method in interface bb.common.box.PurchasingBox
findDueRequestForQuoteItemListResults(int, int) - Method in interface bb.common.box.ManufacturingBox
findDueRequestForQuoteItemListResults(int, int) - Method in interface bb.common.box.PurchasingBox
findDueReturnToVendorItemListResults(int, int) - Method in interface bb.common.box.ManufacturingBox
findDueReturnToVendorItemListResults(int, int) - Method in interface bb.common.box.PurchasingBox
findDueSalesOrderItemCustomerTotalResultsByCustomerId(String, int, int) - Method in interface bb.common.box.SalesBox
findDueSalesOrdersByAddressId(String, int, int) - Method in interface bb.common.box.SalesBox
findDueShortageSalesOrderItems(String, String, String, String, int, int) - Method in interface bb.common.box.SalesBox
findDueSoItemsByDateType(String, Date, Date, int, int) - Method in interface bb.common.box.SalesBox
findDueWorkOrderItemListResults(int, int) - Method in interface bb.common.box.WorkOrderBox
findDuplicateTempAddress(int, int) - Method in interface bb.common.box.CompanyBox
findDuplicateTempBOM(int, int) - Method in interface bb.common.box.CompanyBox
findDuplicateTempEmployee(int, int) - Method in interface bb.common.box.CompanyBox
findDuplicateTempInventory(int, int) - Method in interface bb.common.box.CompanyBox
findDuplicateTempManufacture(int, int) - Method in interface bb.common.box.CompanyBox
findDuplicateTempMaterial(int, int) - Method in interface bb.common.box.CompanyBox
findDuplicateTempNccode(int, int) - Method in interface bb.common.box.CompanyBox
findDuplicateTempPart(int, int) - Method in interface bb.common.box.CompanyBox
findDuplicateTempTool(int, int) - Method in interface bb.common.box.CompanyBox
findDuplicateTempToolInventory(int, int) - Method in interface bb.common.box.CompanyBox
findDwfDrawingByPartPk(PartPK, String, int, int) - Method in interface bb.common.box.EngineeringBox
findDWOIssueItems(String, String, String, String, String, Date, Date, String, String, String[], boolean, int, int) - Method in interface bb.common.box.WarehouseBox
findEcnByConditions(String, String, String, String, String, String, String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.EngineeringBox
findECNControlByUserName(String, int, int) - Method in interface bb.common.box.EngineeringBox
findECRControlByUserName(String, int, int) - Method in interface bb.common.box.EngineeringBox
findECRequestByEcrNumberLike(String, String, int, int) - Method in interface bb.common.box.EngineeringBox
findECRequestByPartLike(String, String, String, String, String, String, String, String, String, int, int) - Method in interface bb.common.box.EngineeringBox
findEjbMethodsByPermissionId(String, int, int) - Method in interface bb.common.box.SecurityBox
findEmployeeCards(String, String, String, String[], boolean, boolean, int, int) - Method in interface bb.common.box.HumanResourceBox
findEmployeeCardsByDepartment(String, boolean, int, int) - Method in interface bb.common.box.HumanResourceBox
findEmployeeCardsByEmployeeId(String, boolean, int, int) - Method in interface bb.common.box.HumanResourceBox
findEmployeeCardsByLastName(String, boolean, int, int) - Method in interface bb.common.box.HumanResourceBox
findEmployeeCardsByName(String, boolean, int, int) - Method in interface bb.common.box.HumanResourceBox
findEmployeeDoNotPutGoodsByDate(String, String, Date, Date, int, int) - Method in interface bb.common.box.HumanResourceBox
findEmployeeEducation(boolean, String, int, int) - Method in interface bb.common.box.HumanResourceBox
findEmployeeEducationsAllDegree(boolean, int, int) - Method in interface bb.common.box.HumanResourceBox
findEmployeeRecords(String, String, boolean, int, int) - Method in interface bb.common.box.HumanResourceBox
findEmployeeRecordsType(boolean, int, int) - Method in interface bb.common.box.HumanResourceBox
findEngGroupListById(String, int, int) - Method in interface bb.common.box.EngineeringBox
findEngGroupUserByEmployeeId(String, String, int, int) - Method in interface bb.common.box.EngineeringBox
findEngineeringChangeByEcnNumberLike(String, String, int, int) - Method in interface bb.common.box.EngineeringBox
findEngineeringChangeByPartLike(String, String, String, int, int) - Method in interface bb.common.box.EngineeringBox
findEngineeringChangeByPartPk(PartPK, String, int, int) - Method in interface bb.common.box.EngineeringBox
findEngineeringChangeByStatus(String, String, int, int) - Method in interface bb.common.box.EngineeringBox
findEngineeringSharingImportLogs(String, String, Date, Date, String, String, String, String, int, int) - Method in interface bb.common.box.EngineeringBox
findEngineeringSharingItemByCompanyId(String, String, String, String, int, int) - Method in interface bb.common.box.EngineeringBox
findEngineeringSharingsByCompanyId(String, int, int) - Method in interface bb.common.box.EngineeringBox
findEngineeringSharingsByCompanyName(String, int, int) - Method in interface bb.common.box.EngineeringBox
findEngSharingPartsByPnAndEngGroup(String, String, String, String, int, int) - Method in interface bb.common.box.EngineeringBox
findEP(String, String, String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.AccountingBox
findEPByDate(String, String, String, String, String, String, String, String, Date, Date, String, String, int, int) - Method in interface bb.common.box.AccountingBox
findEPByPk(String) - Method in interface bb.common.box.AccountingBox
findEPTotalMoneyByDate(String, String, String, String, String, String, String, String, String, Date, Date, String, String) - Method in interface bb.common.box.AccountingBox
findEquipmentByWorkCenterId(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findEquipmentsByEquipmentId(String, String, String, String, int, int) - Method in interface bb.common.box.ManufacturingBox
findEquipmentsByHours(int, int, int) - Method in interface bb.common.box.ManufacturingBox
findExchangeByfiscalYear(String, String) - Method in interface bb.common.box.CompanyBox
findExistAddress(String) - Method in interface bb.common.box.CompanyBox
findExistBOM() - Method in interface bb.common.box.CompanyBox
findExistEmployee() - Method in interface bb.common.box.CompanyBox
findExistInventory() - Method in interface bb.common.box.CompanyBox
findExistManufacture() - Method in interface bb.common.box.CompanyBox
findExistMaterial() - Method in interface bb.common.box.CompanyBox
findExistNccode() - Method in interface bb.common.box.CompanyBox
findExistPart() - Method in interface bb.common.box.CompanyBox
findExistTool() - Method in interface bb.common.box.CompanyBox
findExistToolInventory() - Method in interface bb.common.box.CompanyBox
findExpensesByExpenseNumber(String, int, int) - Method in interface bb.common.box.AccountingBox
findFiscalYearBudget(String, String) - Method in interface bb.common.box.AccountingBox
findFiscalYearBudget(String, String, boolean) - Method in interface bb.common.box.AccountingBox
findFiscalYearBudgetAndActualAmountByCharts(String[], String) - Method in interface bb.common.box.AccountingBox
findFiscalYearBudgetByMonth(String, Date, Date, String, boolean) - Method in interface bb.common.box.AccountingBox
findFiscalYearSettingsByDate(Date) - Method in interface bb.common.box.AccountingBox
findFiscalYearSettingsByPk(String) - Method in interface bb.common.box.AccountingBox
findGeneralLedgerApprovalById(String, int, int) - Method in interface bb.common.box.AccountingBox
findGeneralLedgerApprovalByName(String, int, int) - Method in interface bb.common.box.AccountingBox
findGeneralLedgerByDate(String, String, String, Date, Date, String, String[], String[], int, String, int, int) - Method in interface bb.common.box.AccountingBox
findGeneralLedgerByDate(String, String, String, Date, Date, String, String, int, int) - Method in interface bb.common.box.AccountingBox
findGLByConditions(String, String, String, String, String, String, String, Date, Date, BigDecimal, int, int) - Method in interface bb.common.box.AccountingBox
findGLById(String, int, int) - Method in interface bb.common.box.AccountingBox
findGLCreditDebitByConditions(String, String, String, String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.AccountingBox
findGlMonthByFyNumber(String, int, int) - Method in interface bb.common.box.AccountingBox
findGlMonthsByFyNumber(String) - Method in interface bb.common.box.AccountingBox
findGrossMarginByID(Date, Date, int, int) - Method in interface bb.common.box.AccountingBox
findGrossMarginTotalByID(Date, Date) - Method in interface bb.common.box.AccountingBox
findGroupsBySelf(int, int) - Method in interface bb.common.box.CompanyBox
findGroupsByUserName(String, int, int) - Method in interface bb.common.box.CompanyBox
findGroupUserList(String, String, int, int) - Method in interface bb.common.box.CompanyBox
findHighUsagePartResults(int, int) - Method in interface bb.common.box.WarehouseBox
findHistoricalInventoryDates(int, int) - Method in interface bb.common.box.WarehouseBox
findHistoricalInventorys(String, String, Date, boolean, int, int) - Method in interface bb.common.box.WarehouseBox
findHistoricalInventorysTotal(String, String, Date, Date, boolean) - Method in interface bb.common.box.WarehouseBox
findIcrById(String) - Method in interface bb.common.box.QualityBox
findIcrItemByPk(InspectionConformanceReportItemPK) - Method in interface bb.common.box.QualityBox
findIcrItemsByDate(String, String, String, String, String, String, Date, Date, String, String, int, int) - Method in interface bb.common.box.QualityBox
findIcrsById(String, int, int) - Method in interface bb.common.box.QualityBox
findIcrsByVendorId(String, int, int) - Method in interface bb.common.box.QualityBox
findInactiveTool(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findInBillPartsWithOnhandInfo(String, String, String, int, int) - Method in interface bb.common.box.EngineeringBox
findIncidentByPk(String) - Method in interface bb.common.box.CustomerServiceBox
findIncidentItemInfosByCsi(String) - Method in interface bb.common.box.CustomerServiceBox
findIncidentsByCsiNumber(String, int, int) - Method in interface bb.common.box.CustomerServiceBox
findIncidentsByCustomerId(String, int, int) - Method in interface bb.common.box.CustomerServiceBox
findIncidentsByDate(String, PartPK, String, String, String, String, String, String, boolean, Date, Date, int, int) - Method in interface bb.common.box.CustomerServiceBox
findIncidentsByDate(String, PartPK, String, String, String, boolean, Date, Date, int, int) - Method in interface bb.common.box.CustomerServiceBox
findIncidentsByPartLike(String, String, int, int) - Method in interface bb.common.box.CustomerServiceBox
findInSipAuditReport(String, String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findInspectionReport(String, String, int, int) - Method in interface bb.common.box.ManufacturingBox
findInspectionType(String, int, int) - Method in interface bb.common.box.QualityBox
findInventoryAdjustmentRecords(BB2Part, int, int) - Method in interface bb.common.box.WarehouseBox
findInventoryAdjustmentRecords(String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.WarehouseBox
findInventoryCostVarianceCount(String, String, String, BigDecimal, int, int) - Method in interface bb.common.box.WarehouseBox
findInventoryCycleResults(String, int, int) - Method in interface bb.common.box.WarehouseBox
findInventoryListResultGTMaxQty(String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findInventoryListResultOnlyWithMinQty(String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findInventoryListResults(boolean, boolean, boolean, boolean, String, String, String, String, String, String, String, String, String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findInventoryListResultsByCommodityCode(String, String, String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findInventoryListResultWithMinAndMaxQty(int, int) - Method in interface bb.common.box.WarehouseBox
findInventoryListWithMinAndMaxQty(String, Date, Date, int, int) - Method in interface bb.common.box.WarehouseBox
findInventoryMonthReport(Date, Date, String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findInventoryMonthReportTotal(Date, Date, String, String) - Method in interface bb.common.box.WarehouseBox
findInventoryNotUsedInMonthsResults(int, boolean, int, int) - Method in interface bb.common.box.WarehouseBox
findInventoryNotUsedInMonthsResults(Date, boolean, int, int) - Method in interface bb.common.box.WarehouseBox
findInventoryNotUsedInMonthsResultsforApp(Date, int, int) - Method in interface bb.common.box.WarehouseBox
findInventoryReportList(String, String, Date, Date, int, int) - Method in interface bb.common.box.WarehouseBox
findInventoryTotalByProductCode(String, int, int) - Method in interface bb.common.box.WarehouseBox
findInvoiceByDate(String, boolean, String, String, String, String, boolean, String, String, String, String, String, boolean, Date, Date, BigDecimal, BigDecimal, boolean, Map, int, int) - Method in interface bb.common.box.AccountingBox
findInvoiceByDate(boolean, String, String, boolean, Date, Date, int, int) - Method in interface bb.common.box.AccountingBox
findInvoiceByDate(String[], int, int) - Method in interface bb.common.box.AccountingBox
findInvoiceItemsByPartPK(PartPK, int, int) - Method in interface bb.common.box.AccountingBox
findIssuedPartTotal(WorkOrderItemPK, PartPK, String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.WarehouseBox
findJobProcessSheetListResults(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findJobProcessSheetListResultsByLookup(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findLatestOpenFYGlMonth(int, int) - Method in interface bb.common.box.AccountingBox
findLnShipperItemListResults(Date, Date, String, String, String, String, String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findLnShipperItemListResultsByCustomerId(String, int, int) - Method in interface bb.common.box.WarehouseBox
findLnShipperItemListResultsByLnNumber(String, int, int) - Method in interface bb.common.box.WarehouseBox
findLnShipperItemListResultsByPartNumber(String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findLoanItemByPartPk(PartPK, String, int, int) - Method in interface bb.common.box.WarehouseBox
findLocationInventoryReport(Date, Date, String, String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findLocationResultWithoutWarehouse() - Method in interface bb.common.box.WarehouseBox
findLogByPk(Long) - Method in interface bb.common.box.LogBox
findLogInventoryByPart(BB2Part, int, int) - Method in interface bb.common.box.WarehouseBox
findLogInventoryByPartLike(String, String, String, String, String, Date, Date, boolean, int, int) - Method in interface bb.common.box.WarehouseBox
findLogInventorySimpleByPartLike(String, String, String, Date, Date, int, int) - Method in interface bb.common.box.WarehouseBox
findLogs(String, String, boolean, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.LogBox
findLogsByAction(String, int, int) - Method in interface bb.common.box.LogBox
findLogsByLastName(String, int, int) - Method in interface bb.common.box.LogBox
findLogsByTarget(String, int, int) - Method in interface bb.common.box.LogBox
findLogsByTrueName(String, int, int) - Method in interface bb.common.box.LogBox
findLogsByUserName(String, int, int) - Method in interface bb.common.box.LogBox
findLogTasks(String, Date, Date, int, int) - Method in interface bb.common.box.CompanyBox
findLogTrackings(String, String, String, String, String, String, String, Date, Date, int, int, int) - Method in interface bb.common.box.QualityBox
findManufacturerAddressesById(String, int, int) - Method in interface bb.common.box.AddressBox
findManufacturerAddressesByName(String, int, int) - Method in interface bb.common.box.AddressBox
findManufacturerECRequestByEcrNumberLike(String, String, int, int) - Method in interface bb.common.box.ManufacturingBox
findManufacturerECRequestByPartLike(String, String, String, int, int) - Method in interface bb.common.box.ManufacturingBox
findManufacturerEngineeringChangeByEcnNumberLike(String, String, int, int) - Method in interface bb.common.box.ManufacturingBox
findManufacturerEngineeringChangeByPart(PartPK, String, int, int) - Method in interface bb.common.box.ManufacturingBox
findManufacturerEngineeringChangeByPartLike(String, String, String, int, int) - Method in interface bb.common.box.ManufacturingBox
findManufacturerEngineeringChangeByPartPk(PartPK, String, int, int) - Method in interface bb.common.box.ManufacturingBox
findMessages(String, Date, Date, int, int) - Method in interface bb.common.box.CompanyBox
findMethodsByEjbName(String, int, int) - Method in interface bb.common.box.SecurityBox
findMiscDocLog(String, String, String, String, String, String, String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.CompanyBox
findMiscDocSettingByType(String) - Method in interface bb.common.box.CompanyBox
findMismatchedPartDrawingWithPartInfoResults(String, int, int) - Method in interface bb.common.box.EngineeringBox
findMoneyInDrawByComputer() - Method in interface bb.common.box.CompanyBox
findMonthARByCustomer(Date, Date, String, String, boolean, int, int) - Method in interface bb.common.box.AccountingBox
findMonthList(String, String) - Method in interface bb.common.box.AccountingBox
findMonthSOByCustomer(Date, Date, String, String, int, int) - Method in interface bb.common.box.SalesBox
findMyARPrintList() - Method in interface bb.common.box.AccountingBox
findMyPoPrintList() - Method in interface bb.common.box.PurchasingBox
findMyPurchaseWorkSheet(int, int) - Method in interface bb.common.box.ManufacturingBox
findMyPurchaseWorkSheet(int, int) - Method in interface bb.common.box.PurchasingBox
findMySoPrintList() - Method in interface bb.common.box.SalesBox
findNccById(String) - Method in interface bb.common.box.QualityBox
findNCQsByNCCode(String, Date, Date, int, int) - Method in interface bb.common.box.QualityBox
findNCQsByNCCode(String[], Date, Date, int, int) - Method in interface bb.common.box.QualityBox
findNcrApprovals(String, int, int) - Method in interface bb.common.box.QualityBox
findNcrById(String) - Method in interface bb.common.box.QualityBox
findNCRListByNCCode(String, Date, Date, int, int) - Method in interface bb.common.box.QualityBox
findNCRsByDate(String, String, String, String, String, String, String, String, String, Date, Date, String, String, String, String, String, String, String, String, String, String, int, int) - Method in interface bb.common.box.QualityBox
findNCRsByNcrNumber(String, int, int) - Method in interface bb.common.box.QualityBox
findNCRsByPart(PartPK, int, int) - Method in interface bb.common.box.QualityBox
findNCRsToCreateScrapGlByDate(String, String, Date, Date, String, int, int) - Method in interface bb.common.box.QualityBox
findNeedCycleCountParts(ArrayList<AuditOnDemandResult>, int, int) - Method in interface bb.common.box.WarehouseBox
findNeedQuoteSGCustRequestForQuoteListResults(String, int, int) - Method in interface bb.common.box.SalesBox
findNegativePartOnhandResults(String, String, String, boolean, int, int) - Method in interface bb.common.box.WarehouseBox
findNonproductivePickingIssuedItems(Date, Date, String, String, String, String, String, String, String, String[], String, int, int) - Method in interface bb.common.box.WarehouseBox
findNonproductivePickingItemIssuedList(String, int, int) - Method in interface bb.common.box.WarehouseBox
findNonproductivePickingItemResults(String, String, String, String, Date, Date, String, String, String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findNonproductivePickings(String, String, String, String, Date, Date, String, int, int) - Method in interface bb.common.box.WarehouseBox
findNonproductivePickingTypeByKey(int) - Method in interface bb.common.box.WarehouseBox
findNonproductivePickingTypeByName(String) - Method in interface bb.common.box.WarehouseBox
findNotApprovedOperatingInstructions(int, int) - Method in interface bb.common.box.ManufacturingBox
findNotBillPartsWithOnhandInfo(String, String, String, int, int) - Method in interface bb.common.box.EngineeringBox
findNotCreateGlOfDisassembleWorkOrderItem(String, Date, Date, String, String, String, String, String, String, String, String, String) - Method in interface bb.common.box.WorkOrderBox
findNoticeUserEmployee(String, String, String, int, int) - Method in interface bb.common.box.CompanyBox
findNotPartInventory() - Method in interface bb.common.box.CompanyBox
findNotPartTempMaterial() - Method in interface bb.common.box.CompanyBox
findNotReviewedWorkOrderItemReviewCostResults(String, String, String, Date, Date, int, int) - Method in interface bb.common.box.WorkOrderBox
findNotSetupWorkOrderItemListResults(String, int, int) - Method in interface bb.common.box.WorkOrderBox
findNotSetupWorkOrderItemListResults(String, boolean, int, int) - Method in interface bb.common.box.WorkOrderBox
findNotToolInventory() - Method in interface bb.common.box.CompanyBox
findOnhandQualityStatue(Date) - Method in interface bb.common.box.WarehouseBox
findOnlineUsersByUserName(String, int, int) - Method in interface bb.common.box.SecurityBox
findOnloanControlByUserTrueNameLike(String, int, int) - Method in interface bb.common.box.WarehouseBox
findOnLoanItemsByDate(PartPK, String, String, String, boolean, Date, Date, int, int) - Method in interface bb.common.box.WarehouseBox
findOnloanReceiverItemListResultsByCustID(String, int, int) - Method in interface bb.common.box.WarehouseBox
findOnloanReceiverItemListResultsByLnNumber(String, int, int) - Method in interface bb.common.box.WarehouseBox
findOnloanReceiverItemListResultsByLnShipperNumber(String, int, int) - Method in interface bb.common.box.WarehouseBox
findOnloanReceiverItemListResultsByOnloanReceiverNumber(String, int, int) - Method in interface bb.common.box.WarehouseBox
findOnloanReceiverItemListResultsByPartNumber(String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findOnloanReceiverListResultsByCustID(String, int, int) - Method in interface bb.common.box.WarehouseBox
findOnloanReceiverListResultsByLnShipperNumber(String, int, int) - Method in interface bb.common.box.WarehouseBox
findOnloanReceiverListResultsByOnloanReceiverNumber(String, int, int) - Method in interface bb.common.box.WarehouseBox
findOnLoansByLoanNumber(String, int, int) - Method in interface bb.common.box.WarehouseBox
findOnLoansByPoNumber(String, int, int) - Method in interface bb.common.box.WarehouseBox
findOnloanShipperListResultsByCustomerId(String, int, int) - Method in interface bb.common.box.WarehouseBox
findOnloanShipperListResultsByLoanNumber(String, int, int) - Method in interface bb.common.box.WarehouseBox
findOnloanShipperListResultsByOnloanShipperNumber(String, int, int) - Method in interface bb.common.box.WarehouseBox
findOnloanShipperListResultsBySalesman(String, int, int) - Method in interface bb.common.box.WarehouseBox
findOnloanShippersByLn(String, int, int) - Method in interface bb.common.box.WarehouseBox
findOpenAndIssuedWorkOrderItemIssues(String, String, BB2Part) - Method in interface bb.common.box.WorkOrderBox
findOpenAPs(int, int) - Method in interface bb.common.box.AccountingBox
findOpenAPsByApNumber(String, int, int) - Method in interface bb.common.box.AccountingBox
findOpenAPsByVendorId(int, int, String) - Method in interface bb.common.box.AccountingBox
findOpenARs(int, int) - Method in interface bb.common.box.AccountingBox
findOpenARsByVendorId(int, int, String, boolean) - Method in interface bb.common.box.AccountingBox
findOpenCustomerFeedback(int, int) - Method in interface bb.common.box.CustomerServiceBox
findOpenDCs(int, int) - Method in interface bb.common.box.EngineeringBox
findOpenDisassembleWorkOrderItemListResultsByPartPK(PartPK, int, int) - Method in interface bb.common.box.WorkOrderBox
findOpenDisassembleWorkOrderListResultsByDwoNumber(String, int, int) - Method in interface bb.common.box.WorkOrderBox
findOpenDisassembleWorkOrderListResultsByVendorId(String, int, int) - Method in interface bb.common.box.WorkOrderBox
findOpenECRequest(String, int, int) - Method in interface bb.common.box.EngineeringBox
findOpenEngineeringChange(String, int, int) - Method in interface bb.common.box.EngineeringBox
findOpenGlMonth(int, int) - Method in interface bb.common.box.AccountingBox
findOpenIcrs(String, int, int) - Method in interface bb.common.box.QualityBox
findOpenIncidents(int, int) - Method in interface bb.common.box.CustomerServiceBox
findOpenInvoiceItemsByPartPK(PartPK, int, int) - Method in interface bb.common.box.AccountingBox
findOpenManufacturerECRequest(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findOpenManufacturerEngineeringChange(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findOpenNCRs(int, int) - Method in interface bb.common.box.QualityBox
findOpenNCRsByPartPK(PartPK, int, int) - Method in interface bb.common.box.QualityBox
findOpenNotReviewedSalesOrders(String, int, int) - Method in interface bb.common.box.SalesBox
findOpenOnLoansForShipper(String, int, int) - Method in interface bb.common.box.WarehouseBox
findOpenOnloanShipperForReceiver(String, int, int) - Method in interface bb.common.box.WarehouseBox
findOpenOperatingInstructions(int, int) - Method in interface bb.common.box.ManufacturingBox
findOpenPARs(int, int) - Method in interface bb.common.box.QualityBox
findOpenPOReceiverItemsByPartPK(PartPK, int, int) - Method in interface bb.common.box.WarehouseBox
findOpenProformaInvoiceListResults(int, int) - Method in interface bb.common.box.WarehouseBox
findOpenPurchaseOrder(String, int, int) - Method in interface bb.common.box.PurchasingBox
findOpenPurchaseOrderByAddressId(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findOpenPurchaseOrderByAddressId(String, int, int) - Method in interface bb.common.box.PurchasingBox
findOpenPurchaseOrderByBuyer(String, int, int) - Method in interface bb.common.box.PurchasingBox
findOpenPurchaseOrderByProjectLike(String, int, int) - Method in interface bb.common.box.PurchasingBox
findOpenPurchaseOrderByRequesterLike(String, int, int) - Method in interface bb.common.box.PurchasingBox
findOpenPurchaseOrderForReceiver(String, int, int) - Method in interface bb.common.box.PurchasingBox
findOpenPurchaseOrderItemByBuyerCode(String, int, int) - Method in interface bb.common.box.PurchasingBox
findOpenPurchaseOrderItemByShipVia(String, String, int, int) - Method in interface bb.common.box.PurchasingBox
findOpenPurchaseOrderItems(int, int) - Method in interface bb.common.box.ManufacturingBox
findOpenPurchaseOrderItems(int, int) - Method in interface bb.common.box.PurchasingBox
findOpenPurchaseOrderItemsByAddressId(String, String, int, int) - Method in interface bb.common.box.PurchasingBox
findOpenPurchaseOrderItemsByPartPk(PartPK, int, int) - Method in interface bb.common.box.PurchasingBox
findOpenPurchaseOrderNotAcknowledged(int, int) - Method in interface bb.common.box.PurchasingBox
findOpenPurchaseOrderTotal() - Method in interface bb.common.box.PurchasingBox
findOpenPurchaseOrdertRelatedDoc(String, String, int, int) - Method in interface bb.common.box.PurchasingBox
findOpenPurchaseOrderwithPrepay(String, int, int) - Method in interface bb.common.box.PurchasingBox
findOpenQuoteByAddressId(String, int, int) - Method in interface bb.common.box.SalesBox
findOpenQuoteItemByAddressId(String, int, int) - Method in interface bb.common.box.SalesBox
findOpenQuoteItemByPartPk(PartPK, int, int) - Method in interface bb.common.box.SalesBox
findOpenReceiversByRn(String, int, int) - Method in interface bb.common.box.WarehouseBox
findOpenRequestForQuoteItemListResults(int, int) - Method in interface bb.common.box.ManufacturingBox
findOpenRequestForQuoteItemListResults(int, int) - Method in interface bb.common.box.PurchasingBox
findOpenReturnToVendorItemListResults(int, int) - Method in interface bb.common.box.ManufacturingBox
findOpenReturnToVendorItemListResults(int, int) - Method in interface bb.common.box.PurchasingBox
findOpenReturnToVendorListResultsByRtvNumber(String, int, int) - Method in interface bb.common.box.PurchasingBox
findOpenRFCs(int, int) - Method in interface bb.common.box.ManufacturingBox
findOpenRMAs(String, int, int) - Method in interface bb.common.box.SalesBox
findOpenRMAsByPartPk(PartPK, int, int) - Method in interface bb.common.box.SalesBox
findOpenSaleOrderItemByPartPk(PartPK, int, int) - Method in interface bb.common.box.SalesBox
findOpenSalesOrderItemCustomerTotalResultsByCustomerId(String, int, int) - Method in interface bb.common.box.SalesBox
findOpenSalesOrdersByAddressId(String, int, int) - Method in interface bb.common.box.SalesBox
findOpenSalesOrdersForShippingBySoNumber(String, int, int) - Method in interface bb.common.box.SalesBox
findOpenSalesOrderWithPrepay(String, int, int) - Method in interface bb.common.box.SalesBox
findOpenSGCustomerServiceRequests(int, int) - Method in interface bb.common.box.SalesBox
findOpenShipViaSalesOrderItems(String, String, String, String, String, int, int) - Method in interface bb.common.box.SalesBox
findOpenShortageSalesOrderItems(String, String, String, String, int, int) - Method in interface bb.common.box.SalesBox
findOpenSwapOrder(String, int, int) - Method in interface bb.common.box.PurchasingBox
findOpenSwapOrderForShipper(String, int, int) - Method in interface bb.common.box.WarehouseBox
findOpenTimeCardsByEmployeeLike(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findOpenTimeCardsById(String) - Method in interface bb.common.box.ManufacturingBox
findOpenTransferOrderForShipper(String, int, int) - Method in interface bb.common.box.WarehouseBox
findOpenUnHoldWorkOrderItemListResults(String, String, String, boolean, int, int) - Method in interface bb.common.box.WorkOrderBox
findOpenWorkInstructions(int, int) - Method in interface bb.common.box.ManufacturingBox
findOpenWorkOrderByVendorId(String, int, int) - Method in interface bb.common.box.WorkOrderBox
findOpenWorkOrderItemListResults(boolean, int, int) - Method in interface bb.common.box.WorkOrderBox
findOpenWorkOrderItemListResults(String, String, String, int, int) - Method in interface bb.common.box.WorkOrderBox
findOpenWorkOrderItemListResultsByPartPK(PartPK, int, int) - Method in interface bb.common.box.WorkOrderBox
findOpenWorkOrderListResults(String, int, int) - Method in interface bb.common.box.WorkOrderBox
findOpenWorkOrderListResultsByWoNumber(String, int, int) - Method in interface bb.common.box.WorkOrderBox
findOperatingInstructions(String, String, String, String, String, String, String, String, String, int, int) - Method in interface bb.common.box.ManufacturingBox
findOperatingInstructionsCanClose(int, int) - Method in interface bb.common.box.ManufacturingBox
findOperatingInstructionsUserStatistical(String, String, String, int, int) - Method in interface bb.common.box.ManufacturingBox
findOrderApprovalByVO(OrderApprovalVO, int, int) - Method in interface bb.common.box.WorkOrderBox
findOrderDocListByOrderNumber(String) - Method in interface bb.common.box.CompanyBox
findOverIssueItemList(boolean, Date, Date, String, String, String, String, String, int, int) - Method in interface bb.common.box.WorkOrderBox
findPackingBoxesByPfNumber(String, int, int) - Method in interface bb.common.box.WarehouseBox
findPackingBoxItem(String, PartPK, String) - Method in interface bb.common.box.WarehouseBox
findPackingBoxItemListResultsByPfNumbe(String, int, int) - Method in interface bb.common.box.WarehouseBox
findPackingBoxItemListResultsByPfNumbeAndPBNumber(String, int, int, int) - Method in interface bb.common.box.WarehouseBox
findPackingBoxSalesOrderItemResults(String) - Method in interface bb.common.box.WarehouseBox
findPARByPk(String) - Method in interface bb.common.box.QualityBox
findPARItemsByPAR(String) - Method in interface bb.common.box.QualityBox
findPARsByDate(String, String, String, Date, Date, int, int) - Method in interface bb.common.box.QualityBox
findPARsByParNumber(String, int, int) - Method in interface bb.common.box.QualityBox
findPARsByPn(String, String, int, int) - Method in interface bb.common.box.QualityBox
findPart(PartPK) - Method in interface bb.common.box.EngineeringBox
findPartBasicInfoToRollUP(String, int, int) - Method in interface bb.common.box.EngineeringBox
findPartBasicInfoToRollUP(String, String, int, int) - Method in interface bb.common.box.EngineeringBox
findPartByBuyerCode(String, String, int, int) - Method in interface bb.common.box.PurchasingBox
findPartCertificateByCertificateNumber(String, String, String, int, int) - Method in interface bb.common.box.QualityBox
findPartCertificateByPk(int) - Method in interface bb.common.box.QualityBox
findPartCertificatesByCertificateDesc(String, int, int) - Method in interface bb.common.box.QualityBox
findPartCertificatesByCn(String, int, int) - Method in interface bb.common.box.QualityBox
findPartCertificatesByPn(String, String, int, int) - Method in interface bb.common.box.QualityBox
findPartCertificatesByPo(String, int, int) - Method in interface bb.common.box.QualityBox
findPartCertificatesByRef(String, int, int) - Method in interface bb.common.box.QualityBox
findPartCertificatesByRn(String, int, int) - Method in interface bb.common.box.QualityBox
findPartCertificatesByWo(String, int, int) - Method in interface bb.common.box.QualityBox
findPartClasses(int, int) - Method in interface bb.common.box.WarehouseBox
findPartClassInfoResult(String, String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findPartDocumentByPartNumber(String, int, int) - Method in interface bb.common.box.DocumentBox
findPartDocumentByPartNumber(String, String, int, int) - Method in interface bb.common.box.DocumentBox
findPartDocumentLog(String, String, String, String, String, String, String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.DocumentBox
findPartDwf(String, String, String, String, boolean, int, int) - Method in interface bb.common.box.EngineeringBox
findPartDwfFullMatch(String, String, String, String, boolean, int, int) - Method in interface bb.common.box.EngineeringBox
findPartDwfLog(String, String, String, String, String, String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.EngineeringBox
findPartDwg(String, String, String, String, int, int) - Method in interface bb.common.box.EngineeringBox
findPartDwgLog(String, String, String, String, String, String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.EngineeringBox
findPartInMrpListResult(List<PartPK>) - Method in interface bb.common.box.PurchasingBox
findPartInspectionByPartPk(String, String, String, int, int) - Method in interface bb.common.box.QualityBox
findPartInWipForIDListResultsByVendorID(String, String, String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findPartInWorkOrderPartDetail(String, String, String, String, String, boolean, String, Date, Date, int, int) - Method in interface bb.common.box.WorkOrderBox
findPartIssuedByDate(Date, Date, String, String, String, String, String, String, String, String, String, boolean, String[], int, int) - Method in interface bb.common.box.WarehouseBox
findPartLocation(String, int, int) - Method in interface bb.common.box.WarehouseBox
findPartManufacturersByPartPk(PartPK) - Method in interface bb.common.box.EngineeringBox
findPartMaterial(PartMaterialReportAgent, int, int) - Method in interface bb.common.box.EngineeringBox
findPartMaterialBomListResults(String, String, int, int) - Method in interface bb.common.box.EngineeringBox
findPartMaterialByPartLike(PartPK, int, int) - Method in interface bb.common.box.EngineeringBox
findPartOnDemandQtyListResults(int, int) - Method in interface bb.common.box.WarehouseBox
findPartOnHandByLocation(String) - Method in interface bb.common.box.WarehouseBox
findPartOnhandByPk(PartOnhandPK) - Method in interface bb.common.box.WarehouseBox
findPartOnhandByPk(PartPK) - Method in interface bb.common.box.WarehouseBox
findPartOnhandIsZeroByPart(PartPK, int, int) - Method in interface bb.common.box.WarehouseBox
findPartOnhandResultsByLocate(String, String, String, String, boolean, boolean, int, int) - Method in interface bb.common.box.WarehouseBox
findPartOnhandTotalResultsByLocate(String, String, String, String, boolean) - Method in interface bb.common.box.WarehouseBox
findPartOnhandWithoutTracking(String, String, boolean, int, int) - Method in interface bb.common.box.QualityBox
findPartOnLoanQtyListResults(int, int) - Method in interface bb.common.box.WarehouseBox
findPartOnOrderQtyListResults(int, int) - Method in interface bb.common.box.WarehouseBox
findPartPKByMpn(String) - Method in interface bb.common.box.EngineeringBox
findPartPKByPartNumber(String) - Method in interface bb.common.box.EngineeringBox
findPartReceivedByDate(Date, Date, String, String, String, String, String, String, String, String, boolean, String[], int, int) - Method in interface bb.common.box.WarehouseBox
findPartsByDescriptionAndLang(String[], String, int, int) - Method in interface bb.common.box.EngineeringBox
findPartsByDescriptionInside(String, String, String, String, int, int) - Method in interface bb.common.box.EngineeringBox
findPartsByDescriptionStart(String, int, int) - Method in interface bb.common.box.EngineeringBox
findPartsByEngineeringSharingRule(String, int, int) - Method in interface bb.common.box.EngineeringBox
findPartsByManufacturerId(String, int, int) - Method in interface bb.common.box.EngineeringBox
findPartsByManufacturerPn(String, int, int) - Method in interface bb.common.box.EngineeringBox
findPartsByManufacturerPnStartWith(String, int, int) - Method in interface bb.common.box.EngineeringBox
findPartsByPartAndDesc(String, String, String, String, String, String, String, String, String, String, String, int, int) - Method in interface bb.common.box.EngineeringBox
findPartsByPartCommodityCode(BigDecimal, String, int, int) - Method in interface bb.common.box.EngineeringBox
findPartsByPartEngGroup(String, String, String, String, int, int) - Method in interface bb.common.box.EngineeringBox
findPartsByPartLike(String, String, int, int) - Method in interface bb.common.box.EngineeringBox
findPartsByPK(PartPK, int, int) - Method in interface bb.common.box.EngineeringBox
findPartSecurityLevelById(String, int, int) - Method in interface bb.common.box.EngineeringBox
findPartsOnHold(int, int) - Method in interface bb.common.box.EngineeringBox
findPartsToDeleteInPo(int, int) - Method in interface bb.common.box.EngineeringBox
findPartsToDeleteInSo(int, int) - Method in interface bb.common.box.EngineeringBox
findPartsToDeleteInWoItemDetail(int, int) - Method in interface bb.common.box.EngineeringBox
findPartsWithBom(int, int) - Method in interface bb.common.box.EngineeringBox
findPartsWithDeleted(int, int) - Method in interface bb.common.box.EngineeringBox
findPartsWithDrawing(int, int) - Method in interface bb.common.box.EngineeringBox
findPartsWithWi(int, int) - Method in interface bb.common.box.EngineeringBox
findPartTraceableByPk(PartPK) - Method in interface bb.common.box.EngineeringBox
findPartTraceableListResults(String, String, int, int) - Method in interface bb.common.box.EngineeringBox
findPartTracking(PartPK) - Method in interface bb.common.box.QualityBox
findPartTrackingByPk(PartTrackingPK) - Method in interface bb.common.box.QualityBox
findPartTypeByTypeLike(String, int, int) - Method in interface bb.common.box.CompanyBox
findPartUseType(String, String, String, String, int, int) - Method in interface bb.common.box.WorkOrderBox
findPartUseTypeByPK(String) - Method in interface bb.common.box.WorkOrderBox
findPartUseTypeCount(String, String, String, String) - Method in interface bb.common.box.WorkOrderBox
findPartVendorsByPartPk(PartPK) - Method in interface bb.common.box.EngineeringBox
findPartWhereIsUsed(PartPK) - Method in interface bb.common.box.EngineeringBox
findPartWithExcessiveInventoryListResults(boolean, int, int) - Method in interface bb.common.box.WarehouseBox
findPartWithExcessiveInventoryListResults(String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findPartWithInspection(String, String, String, int, int) - Method in interface bb.common.box.QualityBox
findPartWithInspectionType(String, String, String, String, int, int) - Method in interface bb.common.box.QualityBox
findPartWithoutClassInfoResult(String, String, String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findPartWithoutLocationList(PartPK, int, int) - Method in interface bb.common.box.WarehouseBox
findPartWithQAQtyListResults(boolean, int, int) - Method in interface bb.common.box.WarehouseBox
findPartWithSipQtyListResults(boolean, int, int) - Method in interface bb.common.box.WarehouseBox
findPartWithSITQtyListResults(String, String, boolean, boolean, int, int) - Method in interface bb.common.box.WarehouseBox
findPartWithSTOQtyListResults(String, String, boolean, boolean, int, int) - Method in interface bb.common.box.WarehouseBox
findPartWithWipQtyListResults(boolean, int, int) - Method in interface bb.common.box.WarehouseBox
findPartWithWipQtyListResults(String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findPastDueAPs(int, int) - Method in interface bb.common.box.AccountingBox
findPastdueAPsByVendorId(String, int, int) - Method in interface bb.common.box.AccountingBox
findPastDueARs(int, int) - Method in interface bb.common.box.AccountingBox
findPastDueARsByVendor(String, boolean, int, int) - Method in interface bb.common.box.AccountingBox
findPastDueDCs(int, int) - Method in interface bb.common.box.EngineeringBox
findPastDuePurchaseOrderByBuyer(String, int, int) - Method in interface bb.common.box.PurchasingBox
findPastDuePurchaseOrderItemByShipVia(String, String, int, int) - Method in interface bb.common.box.PurchasingBox
findPastDuePurchaseOrderItems(int, int) - Method in interface bb.common.box.ManufacturingBox
findPastDuePurchaseOrderItems(int, int) - Method in interface bb.common.box.PurchasingBox
findPastDuePurchaseOrderItemsByAddressId(String, String, int, int) - Method in interface bb.common.box.PurchasingBox
findPastDuePurchaseOrderTotal() - Method in interface bb.common.box.PurchasingBox
findPastDueRFCs(int, int) - Method in interface bb.common.box.ManufacturingBox
findPausedOperatingInstructions(int, int) - Method in interface bb.common.box.ManufacturingBox
findPayment(String) - Method in interface bb.common.box.CompanyBox
findPaymentHistory(int, int) - Method in interface bb.common.box.AccountingBox
findPaymentRunItemByPaymentNo(String, String, String) - Method in interface bb.common.box.AccountingBox
findPendingSGCustomerServiceRequests(int, int) - Method in interface bb.common.box.SalesBox
findPermissionsById(String, String, int, int) - Method in interface bb.common.box.SecurityBox
findPermissionsByRole(String, int, int) - Method in interface bb.common.box.SecurityBox
findPermissionsBySelf(int, int) - Method in interface bb.common.box.SecurityBox
findPermissionsBySelf() - Method in interface bb.common.box.SecurityBox
findPermissionsByUser(String, int, int) - Method in interface bb.common.box.SecurityBox
findPermissionsByUser(String) - Method in interface bb.common.box.SecurityBox
findPfReceiversByPfNumber(String, int, int) - Method in interface bb.common.box.PurchasingBox
findPfReceiversByVendorId(String, int, int) - Method in interface bb.common.box.PurchasingBox
findPfReceiversOpenByVendorId(String, int, int) - Method in interface bb.common.box.PurchasingBox
findPhysicalInventoryListByPartNumber(int, String, String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findPhysicalInventoryListResults(int, int, int, int) - Method in interface bb.common.box.WarehouseBox
findPhysicalInventoryListResults(int, int, int) - Method in interface bb.common.box.WarehouseBox
findPhysicalInventoryListResults(int, int, String, String, String, String) - Method in interface bb.common.box.WarehouseBox
findPhysicalInventoryListResultsByLocation(int, String) - Method in interface bb.common.box.WarehouseBox
findPhysicalInventoryListResultsForSpecificWarehouse(int, int, String, String, String, String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findPhysicalInventoryListResultsWithAvgCost(int, int, int, int) - Method in interface bb.common.box.WarehouseBox
findPhysicalInventoryPart(String, String, Date, Date) - Method in interface bb.common.box.WarehouseBox
findPhysicalWorkSheetListResults(int, int) - Method in interface bb.common.box.WarehouseBox
findPOAndWOStatus(Date, Date, String) - Method in interface bb.common.box.WorkOrderBox
findPoDueVendors() - Method in interface bb.common.box.PurchasingBox
findPoMessagesByStatusAndID(String[], String, int, int) - Method in interface bb.common.box.PurchasingBox
findPOReceiverItems(String, String, String, String, String, String, Date, Date, String, String, String, String, String[], int, int) - Method in interface bb.common.box.WarehouseBox
findPOReceiverItemsByPartPK(PartPK, int, int) - Method in interface bb.common.box.WarehouseBox
findPoReceiverItemsByPoNumber(String) - Method in interface bb.common.box.WarehouseBox
findPoReceiverItemsByPoNumberWithoutAPorPA(String) - Method in interface bb.common.box.WarehouseBox
findPoReceiverItemWithAPListResultsByDate(String, String, String, String, String, Date, Date, String, String, String, String, String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findPosAdjustLocationResult(String) - Method in interface bb.common.box.WarehouseBox
findPOSurveyReport(String, String, String, int, int) - Method in interface bb.common.box.QualityBox
findPosZipCodeTaxsList() - Method in interface bb.common.box.CompanyBox
findPoTotalByDateResults(String, Date, Date, String, String, String, String, String, String, String, String, String, String, String, String, boolean, String) - Method in interface bb.common.box.PurchasingBox
findPrintTemplatebyClazz(String, int, int) - Method in interface bb.common.box.CompanyBox
findProfitLossOfCategory(String) - Method in interface bb.common.box.AccountingBox
findProfitLossStatement() - Method in interface bb.common.box.AccountingBox
findProfitLossStatement(String, Date, Date, Date, Date) - Method in interface bb.common.box.AccountingBox
findProformaInvoiceItems(Date, Date, String, String, String, String, String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findProformaInvoiceListResultsByCustomerId(String, int, int) - Method in interface bb.common.box.WarehouseBox
findProformaInvoiceListResultsByPfNumber(String, int, int) - Method in interface bb.common.box.WarehouseBox
findProjectById(String, int, int) - Method in interface bb.common.box.SalesBox
findPurchaseContract(Date, Date, String, String) - Method in interface bb.common.box.PurchasingBox
findPurchaseOrderApPrepays(String[]) - Method in interface bb.common.box.PurchasingBox
findPurchaseOrderBPBybpID(String, int, int) - Method in interface bb.common.box.PurchasingBox
findPurchaseOrderByPoNumber(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findPurchaseOrderByPoNumber(String, int, int) - Method in interface bb.common.box.PurchasingBox
findPurchaseOrderByRange(String, String, String, String, int, int) - Method in interface bb.common.box.PurchasingBox
findPurchaseOrderCheckListResults(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findPurchaseOrderCheckListResults(String, int, int) - Method in interface bb.common.box.PurchasingBox
findPurchaseOrderItemByDate(String, Date, Date, String, String, String, String, String, String, String, String, String, String, String, String, int, int) - Method in interface bb.common.box.ManufacturingBox
findPurchaseOrderItemByDate(String, Date, Date, String, String, String, String, String, String, String, String, String, String, String, String, boolean, String, int, int) - Method in interface bb.common.box.PurchasingBox
findPurchaseOrderItemsByPartNumberLike(String, String, int, int) - Method in interface bb.common.box.ManufacturingBox
findPurchaseOrderItemsByPartNumberLike(String, String, int, int) - Method in interface bb.common.box.PurchasingBox
findPurchaseOrderItemsByPartPk(PartPK, int, int) - Method in interface bb.common.box.ManufacturingBox
findPurchaseOrderItemsByPartPk(PartPK, int, int) - Method in interface bb.common.box.PurchasingBox
findPurchaseOrderItemsByPoNumber(String) - Method in interface bb.common.box.ManufacturingBox
findPurchaseOrderItemsByPoNumber(String) - Method in interface bb.common.box.PurchasingBox
findPurchaseOrderItemsByProject(String, String, String, Date, Date, String, int, int) - Method in interface bb.common.box.PurchasingBox
findPurchaseOrderItemsByRefDoc1(String, String, String, Date, Date, String, int, int) - Method in interface bb.common.box.PurchasingBox
findPurchaseOrderItemsByRelatedDoc(String, String, String, Date, Date, String, int, int) - Method in interface bb.common.box.PurchasingBox
findPurchaseOrdersByRefdoc(String, String, String, Date, Date, int, int) - Method in interface bb.common.box.PurchasingBox
findPurchaseOrdersForReceiving(String, String, String, String, int, int) - Method in interface bb.common.box.PurchasingBox
findPurchaseWorkSheetByEmployeeEmailLike(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findPurchaseWorkSheetByEmployeeEmailLike(String, int, int) - Method in interface bb.common.box.PurchasingBox
findPurchaseWorkSheetByEmployeeId(String, boolean, int, int) - Method in interface bb.common.box.ManufacturingBox
findPurchaseWorkSheetByEmployeeId(String, boolean, int, int) - Method in interface bb.common.box.PurchasingBox
findPurchaseWorkSheetItemsByWorkSheetPk(PurchaseWorkSheetPK) - Method in interface bb.common.box.PurchasingBox
findQualityGroupByPk(QualityGroupPK) - Method in interface bb.common.box.QualityBox
findQuoteBPByBPId(String, int, int) - Method in interface bb.common.box.SalesBox
findQuoteByAddressId(String, int, int) - Method in interface bb.common.box.SalesBox
findQuoteByQuoteNumberLike(String, int, int) - Method in interface bb.common.box.SalesBox
findQuoteDocumentInfo(String, int, int) - Method in interface bb.common.box.SalesBox
findQuoteDocumentInfo(String) - Method in interface bb.common.box.SalesBox
findQuoteedSGCustRequestForQuoteListResults(String, String, String, int, int) - Method in interface bb.common.box.SalesBox
findQuoteItemByAddressId(String, int, int) - Method in interface bb.common.box.SalesBox
findQuoteItemByDate(PartPK, String, String, String, String, String, String, Date, Date, String, String, int, int) - Method in interface bb.common.box.SalesBox
findQuoteItemByPartLike(String, String, int, int) - Method in interface bb.common.box.SalesBox
findQuoteItemByPartPk(PartPK, int, int) - Method in interface bb.common.box.SalesBox
findQuoteTotalByDateResults(PartPK, String, String, String, String, String, String, Date, Date, String, String) - Method in interface bb.common.box.SalesBox
findRaoTotal(String, String[], String[], String, Date, Date, String, boolean, String, String, boolean) - Method in interface bb.common.box.CompanyBox
findReceiptByCustomer(Date, Date) - Method in interface bb.common.box.CompanyBox
findReceiptItemsByNegativeOnhand(String, String[], String[], String, Date, Date, String, boolean, String, String, int, int) - Method in interface bb.common.box.CompanyBox
findReceiptOrders(String, String[], String[], String, Date, Date, String, boolean, int, int) - Method in interface bb.common.box.CompanyBox
findReceiptOrderTotal(String, String[], String[], String, Date, Date, String, boolean) - Method in interface bb.common.box.CompanyBox
findReceiverInfoByReceiverNumber(ArrayList) - Method in interface bb.common.box.WarehouseBox
findReceiverItemsWithOutAP(String, String, String, Date, Date, String, int, int) - Method in interface bb.common.box.AccountingBox
findReceiversByBuyerCode(String, int, int) - Method in interface bb.common.box.WarehouseBox
findReceiversByRn(String, int, int) - Method in interface bb.common.box.WarehouseBox
findReceiverWithOutAP(String, String, String, Date, Date, int, int) - Method in interface bb.common.box.AccountingBox
findReceiverWithoutAPSaveRecordDetails(Date, int, int) - Method in interface bb.common.box.AccountingBox
findReceiverWithoutAPSaveRecords(int, int) - Method in interface bb.common.box.AccountingBox
findRequestForQuoteItemListResults(String, String, String, boolean, int, int) - Method in interface bb.common.box.ManufacturingBox
findRequestForQuoteItemListResults(String, String, String, int, int) - Method in interface bb.common.box.ManufacturingBox
findRequestForQuoteItemListResults(String, String, String, boolean, int, int) - Method in interface bb.common.box.PurchasingBox
findRequestForQuoteItemListResults(String, String, String, int, int) - Method in interface bb.common.box.PurchasingBox
findRequestForQuoteItemListResultsByPartNumberAndDateLike(String, String, String, Date, Date, String, String, int, int) - Method in interface bb.common.box.PurchasingBox
findRequestForQuoteItemListResultsByPartNumberAndDateLike(String, String, String, Date, Date, String, boolean, int, int) - Method in interface bb.common.box.PurchasingBox
findRequestForQuoteItemListResultsByPartNumberLike(String, String, int, int) - Method in interface bb.common.box.ManufacturingBox
findRequestForQuoteItemListResultsByPartNumberLike(String, String, int, int) - Method in interface bb.common.box.PurchasingBox
findRequestForQuoteListResults(String, String, String, int, int) - Method in interface bb.common.box.ManufacturingBox
findRequestForQuoteListResults(String, String, String, int, int) - Method in interface bb.common.box.PurchasingBox
findRequestForQuoteListResultsByRfqNumber(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findRequestForQuoteListResultsByRfqNumber(String, int, int) - Method in interface bb.common.box.PurchasingBox
findRequestForQuoteListResultsByVendorId(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findRequestForQuoteListResultsByVendorId(String, int, int) - Method in interface bb.common.box.PurchasingBox
findRequestInspectionOperatingInstructions(int, int) - Method in interface bb.common.box.ManufacturingBox
findReturnToVendorItemListResults(String, String, String, boolean, int, int) - Method in interface bb.common.box.ManufacturingBox
findReturnToVendorItemListResults(String, String, String, int, int) - Method in interface bb.common.box.ManufacturingBox
findReturnToVendorItemListResults(String, String, String, boolean, int, int) - Method in interface bb.common.box.PurchasingBox
findReturnToVendorItemListResults(String, String, String, int, int) - Method in interface bb.common.box.PurchasingBox
findReturnToVendorItemListResultsByPartNumberLike(String, String, int, int) - Method in interface bb.common.box.ManufacturingBox
findReturnToVendorItemListResultsByPartNumberLike(String, String, int, int) - Method in interface bb.common.box.PurchasingBox
findReturnToVendorItemsListResults(String, String, String, String, String, String, String, String, String, boolean, Date, Date, String, String, String, String, String, int, int) - Method in interface bb.common.box.PurchasingBox
findReturnToVendorItemsListResults(String, String, String, String, String, String, String, String, String, boolean, Date, Date, String, String, String, String, String, String, int, int) - Method in interface bb.common.box.PurchasingBox
findReturnToVendorListResults(String, String, String, int, int) - Method in interface bb.common.box.ManufacturingBox
findReturnToVendorListResults(String, String, String, int, int) - Method in interface bb.common.box.PurchasingBox
findReturnToVendorListResultsByRtvNumber(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findReturnToVendorListResultsByRtvNumber(String, int, int) - Method in interface bb.common.box.PurchasingBox
findReturnToVendorListResultsByVendorId(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findReturnToVendorListResultsByVendorId(String, int, int) - Method in interface bb.common.box.PurchasingBox
findRFCByPk(String) - Method in interface bb.common.box.ManufacturingBox
findRFCsByRFC(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findRfqCheckListResults(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findRfqCheckListResults(String, int, int) - Method in interface bb.common.box.PurchasingBox
findRfqMessagesByStatusAndID(String[], String, int, int) - Method in interface bb.common.box.PurchasingBox
findRmaById(String) - Method in interface bb.common.box.SalesBox
findRmaCheckList(int, int) - Method in interface bb.common.box.SalesBox
findRmaItemByCustomerIdLike(String, int, int) - Method in interface bb.common.box.SalesBox
findRmaItemByPartPk(PartPK, int, int) - Method in interface bb.common.box.SalesBox
findRmaItemsByDate(PartPK, String, String, String, String, String, String, String, String, boolean, Date, Date, int, int) - Method in interface bb.common.box.SalesBox
findRMAReceiverItemListResultsByCustID(String, int, int) - Method in interface bb.common.box.WarehouseBox
findRMAReceiverItemListResultsByPartNumber(String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findRMAReceiverItemListResultsByRMAReceiverNumber(String, int, int) - Method in interface bb.common.box.WarehouseBox
findRMAReceiverItemListResultsBySONumber(String, int, int) - Method in interface bb.common.box.WarehouseBox
findRMAReceiverListResultsByCustID(String, int, int) - Method in interface bb.common.box.WarehouseBox
findRMAReceiverListResultsByRMAReceiverNumber(String, int, int) - Method in interface bb.common.box.WarehouseBox
findRMAReceiverWithoutCMListResults(String, int, int) - Method in interface bb.common.box.WarehouseBox
findRMAsByIvoiceNumber(String, int, int) - Method in interface bb.common.box.SalesBox
findRMAsByPartPk(PartPK, int, int) - Method in interface bb.common.box.SalesBox
findRMAsByRmaNumber(String, int, int) - Method in interface bb.common.box.SalesBox
findRMAsBySoNumber(String, int, int) - Method in interface bb.common.box.SalesBox
findRolesByPermission(String, String, int, int) - Method in interface bb.common.box.SecurityBox
findRolesBySelf(String, int, int) - Method in interface bb.common.box.SecurityBox
findRolesByUser(String, String, int, int) - Method in interface bb.common.box.SecurityBox
findRollUpBomStdCostWorkSheet(int, int) - Method in interface bb.common.box.AccountingBox
findRollUpBomStdCostWorkSheetItem(Long, int, int) - Method in interface bb.common.box.AccountingBox
findRRMAItemListResult(PartPK, String, String, String, String, String, String, String, boolean, Date, Date, boolean, int, int) - Method in interface bb.common.box.SalesBox
findRRMAListResult(String, String, String, String, String, String, String, int, int) - Method in interface bb.common.box.SalesBox
findRtvCheckListResults(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findRtvCheckListResults(String, int, int) - Method in interface bb.common.box.PurchasingBox
findRtvShipperItemListResultsByDate(String, String, String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.WarehouseBox
findRtvShipperItemListResultsByPartNumber(String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findRtvShipperItemListResultsByPONumber(String, int, int) - Method in interface bb.common.box.WarehouseBox
findRtvShipperItemListResultsByRTVNumber(String, int, int) - Method in interface bb.common.box.WarehouseBox
findRtvShipperItemListResultsByRTVShipperNumber(String, int, int) - Method in interface bb.common.box.WarehouseBox
findRtvShipperItemListResultsByVendorID(String, int, int) - Method in interface bb.common.box.WarehouseBox
findRtvShipperListResultsByPONumber(String, int, int) - Method in interface bb.common.box.WarehouseBox
findRtvShipperListResultsByRTVNumber(String, int, int) - Method in interface bb.common.box.WarehouseBox
findRtvShipperListResultsByRTVShipperNumber(String, int, int) - Method in interface bb.common.box.WarehouseBox
findRtvShipperListResultsByShippedBy(String, int, int) - Method in interface bb.common.box.WarehouseBox
findRtvShipperListResultsByVendorID(String, int, int) - Method in interface bb.common.box.WarehouseBox
findRTVShipperWithOutDebitMemo(String, String, Date, Date, int, int) - Method in interface bb.common.box.AccountingBox
findRunningAccountOrderItems(String, String[], String[], String, Date, Date, String, boolean, String, String, String, String, String, String, boolean, int, int) - Method in interface bb.common.box.CompanyBox
findSalesBillItemWithPartInfoByBillPk(BillPK, String, boolean) - Method in interface bb.common.box.EngineeringBox
findSalesCodeById(String, String, String, String, BigDecimal, int, int) - Method in interface bb.common.box.SalesBox
findSalesDateNoExistSalesOder() - Method in interface bb.common.box.CompanyBox
findSalesman(String, String, int, int) - Method in interface bb.common.box.SalesBox
findSalesmanById(String, int, int) - Method in interface bb.common.box.SalesBox
findSalesmanByLastName(String, int, int) - Method in interface bb.common.box.SalesBox
findSalesOrder12MonthMarginResults(int, int) - Method in interface bb.common.box.ManagementBox
findSalesOrderArPrepays(String[]) - Method in interface bb.common.box.SalesBox
findSalesOrderBPByBPId(String, int, int) - Method in interface bb.common.box.SalesBox
findSalesOrderControlByUserTrueNameLike(String, int, int) - Method in interface bb.common.box.SalesBox
findSalesOrderItemByPartPk(PartPK, int, int) - Method in interface bb.common.box.SalesBox
findSalesOrderItemGroupByPart(Date, Date, int, int) - Method in interface bb.common.box.SalesBox
findSalesOrderItemGroupByPart(String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.SalesBox
findSalesOrderItemsByCustomerId(String, Date, Date, String, String, String, String, String, int, int) - Method in interface bb.common.box.SalesBox
findSalesOrderItemsByDate(String, String, String, String, String, String, String, String, String, String, String, Date, Date, String, String, String, String, boolean, String, String, int, int) - Method in interface bb.common.box.SalesBox
findSalesOrderItemsByDates(String, String, String, String, String, String, String, String, String, String, String, Date, Date, String, String, String, String, boolean, String, String, int, int) - Method in interface bb.common.box.SalesBox
findSalesOrderItemsByDates(String, String, String, String, String, String, String, String, String, String, String, Date, Date, String, String, String, String, String, int, int) - Method in interface bb.common.box.SalesBox
findSalesOrderItemsBySalesman(String, int, int) - Method in interface bb.common.box.SalesBox
findSalesOrderItemsCost(String, int, int) - Method in interface bb.common.box.SalesBox
findSalesOrderItemsWithoutInvoice(String, String, Date, Date, int, int) - Method in interface bb.common.box.SalesBox
findSalesOrderListResultsforShipList(String, String[], Date, Date, int, int) - Method in interface bb.common.box.PlanningBox
findSalesOrdersByPoNumber(String, int, int) - Method in interface bb.common.box.SalesBox
findSalesOrdersBySalesman(String, int, int) - Method in interface bb.common.box.SalesBox
findSalesOrdersBySoNumber(String, int, int) - Method in interface bb.common.box.SalesBox
findSalesOrderShipDateListResultsByDate(String, String, String, Date, Date, int, int) - Method in interface bb.common.box.WarehouseBox
findSalesTaxByDate(String, Date, Date, String, String, boolean, int, int) - Method in interface bb.common.box.AccountingBox
findSalesTaxTotalMoneyByDate(String, Date, Date, String, boolean) - Method in interface bb.common.box.AccountingBox
findSerialNumberByPk(SerialNumberPK) - Method in interface bb.common.box.QualityBox
findSerialNumberByPn(String, String, int, int) - Method in interface bb.common.box.QualityBox
findSerialNumbersBySerialNumber(String, String, String, String, String, String, String, int, int) - Method in interface bb.common.box.QualityBox
findSgClientProgramUser(String, String, int, int) - Method in interface bb.common.box.AddressBox
findSGClientProgramUsers(String, String, Object[], int, int) - Method in interface bb.common.box.AddressBox
findSGCustomerServiceRequestsByDate(String, String, String, String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.SalesBox
findSGPartCatalogResults(String, String, int, int) - Method in interface bb.common.box.SalesBox
findSGPartCatalogResultsforCustomerID(String, String, int, int) - Method in interface bb.common.box.SalesBox
findSGPartCatalogResultsforCustomerIDAndMultiCondition(String, String, int, int) - Method in interface bb.common.box.SalesBox
findSGPartCatalogResultsforCustomerIDByPart(String, String, int, int) - Method in interface bb.common.box.SalesBox
findSGSaleItems(String, String, String, String, String, String, int, int) - Method in interface bb.common.box.SalesBox
findShipListByShipList(String) - Method in interface bb.common.box.PlanningBox
findShipListItems(String, int, int) - Method in interface bb.common.box.PlanningBox
findShipListOwnersByName(String, int, int) - Method in interface bb.common.box.PlanningBox
findShipLists(String, int, int) - Method in interface bb.common.box.PlanningBox
findShipListsById(String, int, int) - Method in interface bb.common.box.PlanningBox
findShipListsByOwner(String, int, int) - Method in interface bb.common.box.PlanningBox
findShipperItemListResults(Date, Date, String, String, String, String, String, String, String, String, String, String[], int, int) - Method in interface bb.common.box.WarehouseBox
findShipperItemListResultsByCustomerId(String, int, int) - Method in interface bb.common.box.WarehouseBox
findShipperItemListResultsByPartNumber(String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findShipperItemListResultsBySalesOrderNumber(String, int, int) - Method in interface bb.common.box.WarehouseBox
findShipperItemListResultsBySerialNumber(String, String, String, String, String, String, String, String[], int, int) - Method in interface bb.common.box.WarehouseBox
findShipperItemListResultsByShipperNumber(String, int, int) - Method in interface bb.common.box.WarehouseBox
findShipperItemListResultsTotal(Date, Date, String, String, String, String, String, String, String, String, String[]) - Method in interface bb.common.box.WarehouseBox
findShipperListResultsByCustomerId(String, int, int) - Method in interface bb.common.box.WarehouseBox
findShipperListResultsBySalesman(String, int, int) - Method in interface bb.common.box.WarehouseBox
findShipperListResultsBySalesOrderNumber(String, int, int) - Method in interface bb.common.box.WarehouseBox
findShipperListResultsByShipperNumber(String, int, int) - Method in interface bb.common.box.WarehouseBox
findShippersByShipperNumber(String, int, int) - Method in interface bb.common.box.WarehouseBox
findShippersBySo(String, int, int) - Method in interface bb.common.box.WarehouseBox
findShipperWithItemsWithOutInvoice(String, String, String, String, Date, Date, String, int, int) - Method in interface bb.common.box.AccountingBox
findShipperWithItemsWithOutUnbilled(String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.AccountingBox
findShipperWithOutInvoice(String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.AccountingBox
findSoTotalByDateResults(String, String, String, String, String, String, String, String, String, String, String, Date, Date, String, String, String, String, boolean, String, String) - Method in interface bb.common.box.SalesBox
findStatementById(String, String, int, int) - Method in interface bb.common.box.AccountingBox
findStatementById(String, String, Date, int, int) - Method in interface bb.common.box.AccountingBox
findStatementById(String, String, String, Date, int, int) - Method in interface bb.common.box.AccountingBox
findStockTransactionAdjustmentResults(Date, Date, String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findStockTransactionPOReceiverResults(Date, Date, String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findStockTransactionSOShipperResults(Date, Date, String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findStockTransactionWOReceiverResults(Date, Date, String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findStockTransactionWOShipperResults(Date, Date, String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findSwapOrderByDate(String, PartPK, String, Date, Date, String, String, String, String, String, String, int, int) - Method in interface bb.common.box.PurchasingBox
findSwapOrders(String, String, String, String, String, String[], Date, Date, int, int) - Method in interface bb.common.box.PurchasingBox
findSwapReceiverItemByDate(String, String, String, String, String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.WarehouseBox
findSwapReceivers(String, String, String, String, String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.WarehouseBox
findSwapShipperItemsByDate(String, String, String, String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.WarehouseBox
findSwapShippers(String, String, String, String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.WarehouseBox
findSystemUserGroup(int, int) - Method in interface bb.common.box.CompanyBox
findTableColumnsByName(String, String) - Method in interface bb.common.box.CompanyBox
findTablesByName(String) - Method in interface bb.common.box.CompanyBox
findTaxComputationByState(String, Date, Date) - Method in interface bb.common.box.CompanyBox
findTaxComputationByZipCode(Date, Date) - Method in interface bb.common.box.CompanyBox
findTaxExemptTotalByCity(String, Date, Date) - Method in interface bb.common.box.CompanyBox
findTaxExemptTotalByCustomerId(Date, Date) - Method in interface bb.common.box.CompanyBox
findTaxExemptTotalByTaxType(Date, Date) - Method in interface bb.common.box.CompanyBox
findTaxTotalByCustomerId(Date, Date) - Method in interface bb.common.box.CompanyBox
findTaxTotalByZipCode(Date, Date) - Method in interface bb.common.box.CompanyBox
findTempAddress(String, int, int) - Method in interface bb.common.box.CompanyBox
findTempBOM(int, int) - Method in interface bb.common.box.CompanyBox
findTempEmployee(int, int) - Method in interface bb.common.box.CompanyBox
findTempInventory(int, int) - Method in interface bb.common.box.CompanyBox
findTempManufacture(int, int) - Method in interface bb.common.box.CompanyBox
findTempMaterial(int, int) - Method in interface bb.common.box.CompanyBox
findTempMPN(int, int) - Method in interface bb.common.box.CompanyBox
findTempMPNDataProblem() - Method in interface bb.common.box.CompanyBox
findTempNccode(int, int) - Method in interface bb.common.box.CompanyBox
findTempPart(int, int) - Method in interface bb.common.box.CompanyBox
findTempTool(int, int) - Method in interface bb.common.box.CompanyBox
findTempToolInventory(int, int) - Method in interface bb.common.box.CompanyBox
findTimeCardByPk(Long) - Method in interface bb.common.box.ManufacturingBox
findTimeCardsByVendorId(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findTimeCardsByWO(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findToolCalibrationsByPart(PartPK, int, int) - Method in interface bb.common.box.ManufacturingBox
findToolListItemWithToolInfoByBillPk(BillPK, String) - Method in interface bb.common.box.ManufacturingBox
findToolListItemWithToolInfoByBillPk(BillPK, String, int, int) - Method in interface bb.common.box.ManufacturingBox
findToolListswithToolInfoByBillNumberLike(String, String, String, int, int) - Method in interface bb.common.box.ManufacturingBox
findToolManufacturersByPartPk(PartPK) - Method in interface bb.common.box.ManufacturingBox
findToolOnhandByPk(PartPK) - Method in interface bb.common.box.WarehouseBox
findToolsByDescriptionInside(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findToolsByDescriptionStart(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findToolsByManufacturerId(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findToolsByManufacturerPn(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findToolsByToolLike(String, String, String, int, int) - Method in interface bb.common.box.ManufacturingBox
findToolsOnHold(int, int) - Method in interface bb.common.box.ManufacturingBox
findToolsWithDrawing(int, int) - Method in interface bb.common.box.ManufacturingBox
findToolsWithToolList(int, int) - Method in interface bb.common.box.ManufacturingBox
findToolsWithWI(int, int) - Method in interface bb.common.box.ManufacturingBox
findToolVendorsByPartPk(PartPK) - Method in interface bb.common.box.ManufacturingBox
findToolWhereIsUsed(PartPK) - Method in interface bb.common.box.ManufacturingBox
findToolWithExcessiveInventoryListResults(String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findToolWithWipQtyListResults(String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findTotalAuditPartInQA(String, String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findTotalPOByProject(String, String, Date, Date, String, String, int, int) - Method in interface bb.common.box.PurchasingBox
findTotalPOByRelatedDoc(String, String, Date, Date, String, String, int, int) - Method in interface bb.common.box.PurchasingBox
findTotalPOItemByRefDoc1(String, String, Date, Date, String, String, int, int) - Method in interface bb.common.box.PurchasingBox
findTraceableCategoriesByPart(String, String, int, String[], Short[], int, int) - Method in interface bb.common.box.EngineeringBox
findTransactionByAPNumber(String, int, int) - Method in interface bb.common.box.AccountingBox
findTransactionByAppNumber(String, int, int) - Method in interface bb.common.box.AccountingBox
findTransactionByAppNumber(String, boolean, int, int) - Method in interface bb.common.box.AccountingBox
findTransactionByARNumber(String, int, int) - Method in interface bb.common.box.AccountingBox
findTransactionByARNumber(String, boolean, int, int) - Method in interface bb.common.box.AccountingBox
findTransactionByArpNumber(String, int, int) - Method in interface bb.common.box.AccountingBox
findTransactionByArpNumber(String, boolean, int, int) - Method in interface bb.common.box.AccountingBox
findTransactionByDMNumber(String, int, int) - Method in interface bb.common.box.AccountingBox
findTransactionByDMNumber(String, boolean, int, int) - Method in interface bb.common.box.AccountingBox
findTransactionByMPONumber(String, int, int) - Method in interface bb.common.box.AccountingBox
findTransactionByPONumber(String, int, int) - Method in interface bb.common.box.AccountingBox
findTransactionBySONumber(String, int, int) - Method in interface bb.common.box.AccountingBox
findTransferOrderByDate(String, String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.WarehouseBox
findTransferOrderItemsByDate(String, String, String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.WarehouseBox
findTransferReceiverItems(String) - Method in interface bb.common.box.WarehouseBox
findTransferReceiverItemsByDate(String, String, String, String, String, Date, Date, String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findTransferReceiverItemsTotalByDate(String, String, String, String, String, Date, Date, String, String) - Method in interface bb.common.box.WarehouseBox
findTransferReceiverListResultsbyDate(String, String, String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.WarehouseBox
findTransferShipperByDate(String, String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.WarehouseBox
findTransferShipperItems(String) - Method in interface bb.common.box.WarehouseBox
findTransferShipperItemsByDate(String, String, String, String, String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.WarehouseBox
findTransferShipperItemsTotalByDate(String, String, String, String, String, String, String, String, Date, Date) - Method in interface bb.common.box.WarehouseBox
findTrueName(String) - Method in interface bb.common.box.SecurityBox
findTwelveMonthCashFlowReport(String, String, int) - Method in interface bb.common.box.AccountingBox
findUnit(String, int, int) - Method in interface bb.common.box.EngineeringBox
findUnreadReceivedMessages(int, int) - Method in interface bb.common.box.CompanyBox
findUserRoleByPermission(String, String, int, int) - Method in interface bb.common.box.SecurityBox
findUsers(String, int, Date, Date, int, int, int, int) - Method in interface bb.common.box.SecurityBox
findUsersByEmployeeId(String, int, int) - Method in interface bb.common.box.SecurityBox
findUsersByPermission(String, int, int) - Method in interface bb.common.box.SecurityBox
findUsersByRole(String, int, int) - Method in interface bb.common.box.SecurityBox
findUsersByUserName(String, int, int) - Method in interface bb.common.box.SecurityBox
findVendorAddressesById(String, int, int) - Method in interface bb.common.box.AddressBox
findVendorAddressesByName(String, String, int, int) - Method in interface bb.common.box.AddressBox
findVendorCategories(String, int, int) - Method in interface bb.common.box.AddressBox
findVendorContractItemsByContractNumber(String, int, int) - Method in interface bb.common.box.PurchasingBox
findVendorContractsByAddressId(String, int, int) - Method in interface bb.common.box.PurchasingBox
findVendorContractsByContractNumber(String, int, int) - Method in interface bb.common.box.PurchasingBox
findVendorCriticalLevel(String, int, int) - Method in interface bb.common.box.AddressBox
findVendorNotPickRtvShippers(int, int) - Method in interface bb.common.box.WarehouseBox
findVendorOnTimeDeliveryRateByVendorId(String, Date, Date, String, int, int, boolean, int, int) - Method in interface bb.common.box.PurchasingBox
findVendorOnTimeDeliveryRateByVendorId(String, Date, Date, int, int, int, int) - Method in interface bb.common.box.WorkOrderBox
findVendorParts(String, String, String, String, String, String, String, int, int) - Method in interface bb.common.box.WarehouseBox
findVendorPrepayStatementById(String, String, Date, int, int) - Method in interface bb.common.box.AccountingBox
findVendorPrepayStatementById(String, String, int, int) - Method in interface bb.common.box.AccountingBox
findVendorPrepayStatementsTotal(String, String, Date) - Method in interface bb.common.box.AccountingBox
findVendorPrepayStatementsTotal(String, String) - Method in interface bb.common.box.AccountingBox
findVendorPurchaseOrderByDate(String, Date, Date, String, String, int, int) - Method in interface bb.common.box.PurchasingBox
findVendorPurchaseOrderItems(String, Date, Date, String, int, int) - Method in interface bb.common.box.PurchasingBox
findVendorPurchaseOrderItemsByDate(String, Date, Date, String, String, int, int) - Method in interface bb.common.box.PurchasingBox
findVendorsList(String, String, String, String, String, String, int, int) - Method in interface bb.common.box.AddressBox
findVendorsListForSeparate(String, String, String, String, String, String, int, int) - Method in interface bb.common.box.AddressBox
findVendorStatementById(String, String, Date, int, int) - Method in interface bb.common.box.AccountingBox
findVendorStatementById(String, String, int, int) - Method in interface bb.common.box.AccountingBox
findVendorStatementsTotal(String, String, Date) - Method in interface bb.common.box.AccountingBox
findVendorStatementsTotal(String, String) - Method in interface bb.common.box.AccountingBox
findVgUser(String, String, int, int) - Method in interface bb.common.box.AddressBox
findWoiDetailInWipByGlNumber(String, Date, Date, int, int) - Method in interface bb.common.box.WorkOrderBox
findWoItemPickListResultsByDate(String, Date, Date, String, String, String) - Method in interface bb.common.box.WarehouseBox
findWoItemPickListResultsByVendorId(String) - Method in interface bb.common.box.WarehouseBox
findWOItemsCanIssue(String, boolean, Date, Date, boolean, int, int) - Method in interface bb.common.box.WorkOrderBox
findWoItemWorkInstructionListResults(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findWoItemWorkInstructionListResults(Date, Date, int, int) - Method in interface bb.common.box.ManufacturingBox
findWOReceiverByPk(Long) - Method in interface bb.common.box.WarehouseBox
findWOReceiverItems(String, String, String, String, String, String, Date, Date, String, String, String[], boolean, String, int, int) - Method in interface bb.common.box.WarehouseBox
findWOReceiverItemsTotal(String, String, String, String, String, String, Date, Date, String, String, String[], boolean, String) - Method in interface bb.common.box.WarehouseBox
findWorkCenterByWcNumber(String, String, String, int, int) - Method in interface bb.common.box.ManufacturingBox
findWorkCenterByWcNumber(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findWorkCenterLoadResults(WorkCenterLoadAgent, int, int) - Method in interface bb.common.box.ManufacturingBox
findWorkCenterRunTimeListResults(WorkCenterRunTimeAgent, int, int) - Method in interface bb.common.box.ManufacturingBox
findWorkInstructionApprovalByEmployeeID(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findWorkInstructionByAuthor(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findWorkInstructionByStatus(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findWorkInstructionDocInfo(WorkInstructionPK) - Method in interface bb.common.box.ManufacturingBox
findWorkInstructionsByPartLike(String, String, String, String, String, boolean, int, int) - Method in interface bb.common.box.ManufacturingBox
findWorkInstructionsByPartLike(String, String, String, String, String, boolean, int, int, boolean) - Method in interface bb.common.box.ManufacturingBox
findWorkInstructionSeqAuditListResults(String, String, String, String, String, int, int) - Method in interface bb.common.box.ManufacturingBox
findWorkInstructionSeqAuditListResults(int, int) - Method in interface bb.common.box.ManufacturingBox
findWorkInstructionSeqByAuthor(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findWorkInstructionSeqByWorkCenter(String, int, int) - Method in interface bb.common.box.ManufacturingBox
findWorkInstructionSeqOnHold(int, int) - Method in interface bb.common.box.ManufacturingBox
findWorkInstructionSeqWithZeroEstHours(int, int) - Method in interface bb.common.box.ManufacturingBox
findWorkOrderBPByBPId(String, int, int) - Method in interface bb.common.box.WorkOrderBox
findWorkOrderCheckListResults(String, int, int) - Method in interface bb.common.box.WorkOrderBox
findWorkOrderDocumentInfo(String) - Method in interface bb.common.box.WorkOrderBox
findWorkOrderInstructionSeq(String, String, String, String, int, int) - Method in interface bb.common.box.WorkOrderBox
findWorkOrderIssuedDetail(WorkOrderItemPK, BB2Part, String, int, int) - Method in interface bb.common.box.WorkOrderBox
findWorkOrderIssuedOrderList(WorkOrderItemPK) - Method in interface bb.common.box.WarehouseBox
findWorkOrderIssueStatisticsResults(Date, Date, String, String, String, String, int, int) - Method in interface bb.common.box.WorkOrderBox
findWorkOrderItemByVendorId(String, Date, Date, int, int) - Method in interface bb.common.box.WorkOrderBox
findWorkOrderItemInWipList(String, int, int) - Method in interface bb.common.box.WorkOrderBox
findWorkOrderItemIssues(WorkOrderItemPK) - Method in interface bb.common.box.WorkOrderBox
findWorkOrderItemLaborCost(Date, Date, String, String, String, int, int) - Method in interface bb.common.box.WorkOrderBox
findWorkOrderItemListResults(String, String, String, String, boolean, int, int) - Method in interface bb.common.box.WorkOrderBox
findWorkOrderItemListResults(String, String, String, int, int) - Method in interface bb.common.box.WorkOrderBox
findWorkOrderItemListResultsByDate(String, Date, Date, String, String, String, String[], String, String, String, String, String, String, boolean, int, int) - Method in interface bb.common.box.WorkOrderBox
findWorkOrderItemListResultsByDateTotal(String, Date, Date, String, String, String, String[], String, String, String, String, String, String, boolean) - Method in interface bb.common.box.WorkOrderBox
findWorkOrderItemListResultsByPartNumberLike(String, String, int, int) - Method in interface bb.common.box.WorkOrderBox
findWorkOrderItemListResultsWithPartHold(int, int) - Method in interface bb.common.box.WorkOrderBox
findWorkOrderItemPartDetailNotIssues(String, String, Date, Date, int, int) - Method in interface bb.common.box.WorkOrderBox
findWorkOrderItemReviewCostResults(String, String, String, String, Date, Date, int, int) - Method in interface bb.common.box.WorkOrderBox
findWorkOrderItemWithWipIssues(WorkOrderItemPK, Date, Date) - Method in interface bb.common.box.WorkOrderBox
findWorkOrderListResults(String, String[], String, int, int) - Method in interface bb.common.box.WorkOrderBox
findWorkOrderListResultsByVendorId(String, int, int) - Method in interface bb.common.box.WorkOrderBox
findWorkOrderListResultsByWoNumber(String, int, int) - Method in interface bb.common.box.WorkOrderBox
findWorkOrderReceiversByWorkOrderItemPk(WorkOrderItemPK, int, int) - Method in interface bb.common.box.WarehouseBox
findWorkOrderTimeCards(WorkOrderItemPK) - Method in interface bb.common.box.WorkOrderBox
findWorkOrderWorkInstructionSequences(WorkOrderWorkInstructionPK) - Method in interface bb.common.box.WorkOrderBox
findWorkOrderWorkSheetByEmployeeEmailLike(String, int, int) - Method in interface bb.common.box.WorkOrderBox
findWorkOrderWorkSheetByEmployeeId(String, int, int) - Method in interface bb.common.box.WorkOrderBox
findWorkOrderWorkSheetItemsByWorkSheetPk(WorkOrderWorkSheetPK) - Method in interface bb.common.box.WorkOrderBox
FINISHED - Static variable in class bb.common.Constant.Status
FINISHINSPECTION - Static variable in class bb.common.Constant.Status
finishOperatingInstructions(OperatingInstructionsVO) - Method in interface bb.common.box.ManufacturingBox
finishProformaReceiver(String, FinishProformaReceiverAgent) - Method in interface bb.common.box.PurchasingBox
finishProformaReceiver(String, PfReceiverItemVO, HashSet<PrPackingBoxItemVO>, String) - Method in interface bb.common.box.PurchasingBox
FinishProformaReceiverAgent - Class in bb.common
FinishProformaReceiverAgent() - Constructor for class bb.common.FinishProformaReceiverAgent
finishProformaShipper(ProformaInvoiceVO, boolean, boolean) - Method in interface bb.common.box.WarehouseBox
finishWorkOrderWorkInstructionSequence(WorkOrderWorkInstructionSequencePK, boolean) - Method in interface bb.common.box.WorkOrderBox
FIRST - Static variable in class bb.common.Constant.ECRPriority
FISCAL_YEAR - Static variable in class bb.common.BizTarget
FISCAL_YEAR - Static variable in class bb.common.PurchaseOrderOnTimeItemResult
FISCAL_YEAR - Static variable in class bb.common.SalesOrderOnTimeItemResult
FISCAL_YEAR - Static variable in class bb.common.WorkOrderOnTimeItemResult
FISCAL_YEAR_BUDGET - Static variable in class bb.common.BizTarget
FISCAL_YEAR_NOT_EXIST - Static variable in class bb.common.BIZReason
FISCAL_YEAR_SETTINGS - Static variable in class bb.common.BizTarget
FISCAL_YEAR_SETTINGS_ALREADY_EXISTS - Static variable in class bb.common.BIZReason
FISCAL_YEAR_SETTINGS_CAN_NOT_BE_NULL - Static variable in class bb.common.BIZReason
FISCAL_YEAR_SETTINGS_STATUS_AFTER_NEED_TO_CHANGE - Static variable in class bb.common.BIZReason
FISCAL_YEAR_SETTINGS_STATUS_BEFORE_NEED_TO_CHANGE - Static variable in class bb.common.BIZReason
FISCAL_YEAR_SETTINGS_STATUS_SHOULD_BE_OPEN - Static variable in class bb.common.BIZReason
FiscalYearSettingsVO - Class in bb.common
FiscalYearSettingsVO() - Constructor for class bb.common.FiscalYearSettingsVO
default constructor
FIVELEVEL - Static variable in class bb.common.Constant.AgeLevel
FIVELEVEL - Static variable in class bb.common.Constant.WorkLevel
FONT_DEFAULT - Static variable in class bb.common.LabelTemplateConstant
formateIntegerToFixedLengthStirng(int, int) - Static method in class bb.common.BB2Util
formatIntegerNumber(Object, int) - Static method in class bb.common.BB2Util
FOURLEVEL - Static variable in class bb.common.Constant.AgeLevel
FOURLEVEL - Static variable in class bb.common.Constant.WorkLevel
FREIGHT - Static variable in class bb.common.Constant.NaRecTo
FTP - Static variable in class bb.common.BizTarget
FTP_OPERATION_FAILED - Static variable in class bb.common.BIZReason
FULLTIME - Static variable in class bb.common.Constant.EmployeeStatus
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M N O P Q R S T U V W X Y Z


FinishProformaReceiverAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class FinishProformaReceiverAgent

java.lang.Object
    extended by  bb.common.FinishProformaReceiverAgent
All Implemented Interfaces:
java.io.Serializable
public class FinishProformaReceiverAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
FinishProformaReceiverAgent()
Method Summary
boolean | isReceiveAllSo()
boolean | isReceiveAllWo()
void | setReceiveAllSo(boolean receiveAllSo)
void | setReceiveAllWo(boolean receiveAllWo)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FinishProformaReceiverAgent

public FinishProformaReceiverAgent()
Method Detail

isReceiveAllSo

public boolean isReceiveAllSo()

setReceiveAllSo

public void setReceiveAllSo(boolean receiveAllSo)

isReceiveAllWo

public boolean isReceiveAllWo()

setReceiveAllWo

public void setReceiveAllWo(boolean receiveAllWo)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FiscalYearSettingsVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class FiscalYearSettingsVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.FiscalYearSettingsVO
All Implemented Interfaces:
java.io.Serializable
public class FiscalYearSettingsVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ENDDATE
static java.lang.String | ORDER_BY_FY
static java.lang.String | ORDER_BY_STARTDATE
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
FiscalYearSettingsVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Set | getAcctPeriod()
java.util.Date | getEndDate()
java.lang.String | getFy()
java.util.Date | getStartDate()
java.lang.String | getStatus()
int | hashCode()
boolean | isUseAccountPeriod()
void | setAcctPeriod(java.util.Set acctPeriod)
void | setEndDate(java.util.Date endDate)
void | setFy(java.lang.String fy)
void | setStartDate(java.util.Date startDate)
void | setStatus(java.lang.String status)
void | setUseAccountPeriod(boolean useAccountPeriod)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_FY

public static final java.lang.String ORDER_BY_FY
See Also:
Constant Field Values

ORDER_BY_STARTDATE

public static final java.lang.String ORDER_BY_STARTDATE
See Also:
Constant Field Values

ORDER_BY_ENDDATE

public static final java.lang.String ORDER_BY_ENDDATE
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values
Constructor Detail

FiscalYearSettingsVO

public FiscalYearSettingsVO()
default constructor

Method Detail

getFy

public java.lang.String getFy()

setFy

public void setFy(java.lang.String fy)

getStartDate

public java.util.Date getStartDate()

setStartDate

public void setStartDate(java.util.Date startDate)

getEndDate

public java.util.Date getEndDate()

setEndDate

public void setEndDate(java.util.Date endDate)

getStatus

public java.lang.String getStatus()

isUseAccountPeriod

public boolean isUseAccountPeriod()

setUseAccountPeriod

public void setUseAccountPeriod(boolean useAccountPeriod)

setStatus

public void setStatus(java.lang.String status)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getAcctPeriod

public java.util.Set getAcctPeriod()

setAcctPeriod

public void setAcctPeriod(java.util.Set acctPeriod)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GeneralLedgerApprovalVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class GeneralLedgerApprovalVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.GeneralLedgerApprovalVO
All Implemented Interfaces:
java.io.Serializable
public class GeneralLedgerApprovalVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_APPROVELIMIT
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_EMPLOYEEID
static java.lang.String | ORDER_BY_USERNAME
Constructor Summary
GeneralLedgerApprovalVO()
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getApproveLimit()
java.lang.String | getComments()
java.lang.String | getEmployeeId()
java.lang.String | getUserName()
int | hashCode()
void | setApproveLimit(java.math.BigDecimal approveLimit)
void | setComments(java.lang.String comments)
void | setEmployeeId(java.lang.String employeeId)
void | setUserName(java.lang.String userName)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_EMPLOYEEID

public static final java.lang.String ORDER_BY_EMPLOYEEID
See Also:
Constant Field Values

ORDER_BY_USERNAME

public static final java.lang.String ORDER_BY_USERNAME
See Also:
Constant Field Values

ORDER_BY_APPROVELIMIT

public static final java.lang.String ORDER_BY_APPROVELIMIT
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values
Constructor Detail

GeneralLedgerApprovalVO

public GeneralLedgerApprovalVO()
Method Detail

getApproveLimit

public java.math.BigDecimal getApproveLimit()

setApproveLimit

public void setApproveLimit(java.math.BigDecimal approveLimit)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GeneralLedgerByDateListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class GeneralLedgerByDateListResult

java.lang.Object
    extended by  bb.common.GeneralLedgerByDateListResult
All Implemented Interfaces:
java.io.Serializable
public class GeneralLedgerByDateListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACCOUNTDESCTIPTION
static java.lang.String | ORDER_BY_ACCOUNTNUMBER
static java.lang.String | ORDER_BY_ACCOUNTTYPE
static java.lang.String | ORDER_BY_ADDRESSID
static java.lang.String | ORDER_BY_ADDRESSNAME
static java.lang.String | ORDER_BY_APNUMBER
static java.lang.String | ORDER_BY_ARNUMBER
static java.lang.String | ORDER_BY_BATCH
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_GLNUMBER
static java.lang.String | ORDER_BY_PONUMBER
static java.lang.String | ORDER_BY_SONUMBER
static java.lang.String | ORDER_BY_TRANSACTIONDATE
static java.lang.String | ORDER_BY_VENDORINVOICE
Constructor Summary
GeneralLedgerByDateListResult()
Method Summary
java.lang.String | getAccountDesctiption()
java.lang.String | getAccountNumber()
java.lang.String | getAccountType()
java.lang.String | getAddressId()
java.lang.String | getAddressName()
java.lang.String | getApNumber()
java.lang.String | getArNumber()
java.math.BigDecimal | getBalance()
java.lang.String | getBatch()
java.lang.String | getCashier()
java.lang.Integer | getCategorySequence()
java.lang.String | getCheckNumber()
java.lang.String | getCompanyUnitId()
java.math.BigDecimal | getCredit()
java.math.BigDecimal | getDebit()
java.lang.String | getDescription()
java.lang.String | getGlCategory()
java.lang.String | getGlNumber()
java.math.BigDecimal | getPaid()
java.lang.String | getPoNumber()
java.math.BigDecimal | getReceived()
java.lang.String | getSoNumber()
java.lang.String | getSummary()
java.util.Date | getTransactionDate()
java.lang.String | getVendorInvoice()
boolean | isClear()
void | setAccountDesctiption(java.lang.String accountDesctiption)
void | setAccountNumber(java.lang.String accountNumber)
void | setAccountType(java.lang.String accountType)
void | setAddressId(java.lang.String addressId)
void | setAddressName(java.lang.String addressName)
void | setApNumber(java.lang.String apNumber)
void | setArNumber(java.lang.String arNumber)
void | setBalance(java.math.BigDecimal balance)
void | setBatch(java.lang.String batch)
void | setCashier(java.lang.String cashier)
void | setCategorySequence(java.lang.Integer categorySequence)
void | setCheckNumber(java.lang.String checkNumber)
void | setClear(boolean clear)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCredit(java.math.BigDecimal credit)
void | setDebit(java.math.BigDecimal debit)
void | setDescription(java.lang.String description)
void | setGlCategory(java.lang.String glCategory)
void | setGlNumber(java.lang.String glNumber)
void | setPaid(java.math.BigDecimal paid)
void | setPoNumber(java.lang.String poNumber)
void | setReceived(java.math.BigDecimal received)
void | setSoNumber(java.lang.String soNumber)
void | setSummary(java.lang.String summary)
void | setTransactionDate(java.util.Date transactionDate)
void | setVendorInvoice(java.lang.String vendorInvoice)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_GLNUMBER

public static final java.lang.String ORDER_BY_GLNUMBER
See Also:
Constant Field Values

ORDER_BY_ACCOUNTNUMBER

public static final java.lang.String ORDER_BY_ACCOUNTNUMBER
See Also:
Constant Field Values

ORDER_BY_ACCOUNTDESCTIPTION

public static final java.lang.String ORDER_BY_ACCOUNTDESCTIPTION
See Also:
Constant Field Values

ORDER_BY_ACCOUNTTYPE

public static final java.lang.String ORDER_BY_ACCOUNTTYPE
See Also:
Constant Field Values

ORDER_BY_TRANSACTIONDATE

public static final java.lang.String ORDER_BY_TRANSACTIONDATE
See Also:
Constant Field Values

ORDER_BY_ADDRESSID

public static final java.lang.String ORDER_BY_ADDRESSID
See Also:
Constant Field Values

ORDER_BY_PONUMBER

public static final java.lang.String ORDER_BY_PONUMBER
See Also:
Constant Field Values

ORDER_BY_APNUMBER

public static final java.lang.String ORDER_BY_APNUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORINVOICE

public static final java.lang.String ORDER_BY_VENDORINVOICE
See Also:
Constant Field Values

ORDER_BY_BATCH

public static final java.lang.String ORDER_BY_BATCH
See Also:
Constant Field Values

ORDER_BY_SONUMBER

public static final java.lang.String ORDER_BY_SONUMBER
See Also:
Constant Field Values

ORDER_BY_ARNUMBER

public static final java.lang.String ORDER_BY_ARNUMBER
See Also:
Constant Field Values

ORDER_BY_ADDRESSNAME

public static final java.lang.String ORDER_BY_ADDRESSNAME
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

GeneralLedgerByDateListResult

public GeneralLedgerByDateListResult()
Method Detail

getCashier

public java.lang.String getCashier()

getReceived

public java.math.BigDecimal getReceived()

getPaid

public java.math.BigDecimal getPaid()

getCheckNumber

public java.lang.String getCheckNumber()

getArNumber

public java.lang.String getArNumber()

getSoNumber

public java.lang.String getSoNumber()

getApNumber

public java.lang.String getApNumber()

getPoNumber

public java.lang.String getPoNumber()

getAddressName

public java.lang.String getAddressName()

getAddressId

public java.lang.String getAddressId()

getCredit

public java.math.BigDecimal getCredit()

getDebit

public java.math.BigDecimal getDebit()

getTransactionDate

public java.util.Date getTransactionDate()

getAccountType

public java.lang.String getAccountType()

getAccountNumber

public java.lang.String getAccountNumber()

setGlNumber

public void setGlNumber(java.lang.String glNumber)

setCashier

public void setCashier(java.lang.String cashier)

setReceived

public void setReceived(java.math.BigDecimal received)

setPaid

public void setPaid(java.math.BigDecimal paid)

setCheckNumber

public void setCheckNumber(java.lang.String checkNumber)

setArNumber

public void setArNumber(java.lang.String arNumber)

setSoNumber

public void setSoNumber(java.lang.String soNumber)

setApNumber

public void setApNumber(java.lang.String apNumber)

setPoNumber

public void setPoNumber(java.lang.String poNumber)

setAddressName

public void setAddressName(java.lang.String addressName)

setAddressId

public void setAddressId(java.lang.String addressId)

setCredit

public void setCredit(java.math.BigDecimal credit)

setDebit

public void setDebit(java.math.BigDecimal debit)

setTransactionDate

public void setTransactionDate(java.util.Date transactionDate)

setAccountType

public void setAccountType(java.lang.String accountType)

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getGlNumber

public java.lang.String getGlNumber()

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getVendorInvoice

public java.lang.String getVendorInvoice()

setVendorInvoice

public void setVendorInvoice(java.lang.String vendorInvoice)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getAccountDesctiption

public java.lang.String getAccountDesctiption()

setAccountDesctiption

public void setAccountDesctiption(java.lang.String accountDesctiption)

getCategorySequence

public java.lang.Integer getCategorySequence()

setCategorySequence

public void setCategorySequence(java.lang.Integer categorySequence)

getGlCategory

public java.lang.String getGlCategory()

setGlCategory

public void setGlCategory(java.lang.String glCategory)

getSummary

public java.lang.String getSummary()

setSummary

public void setSummary(java.lang.String summary)

getBatch

public java.lang.String getBatch()

setBatch

public void setBatch(java.lang.String batch)

getBalance

public java.math.BigDecimal getBalance()

setBalance

public void setBalance(java.math.BigDecimal balance)

isClear

public boolean isClear()

setClear

public void setClear(boolean clear)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GeneralLedgerCategoryVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class GeneralLedgerCategoryVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.GeneralLedgerCategoryVO
All Implemented Interfaces:
java.io.Serializable
public class GeneralLedgerCategoryVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CREDITACCOUNTS
static java.lang.String | ORDER_BY_DEBITACCOUNTS
static java.lang.String | ORDER_BY_GLTYPE
static java.lang.String | ORDER_BY_ID
static java.lang.String | ORDER_BY_NAME
Constructor Summary
GeneralLedgerCategoryVO()
Method Summary
java.lang.String | getCreditAccounts()
java.lang.String | getDebitAccounts()
java.lang.String | getGlType()
java.lang.String | getId()
java.lang.String | getName()
void | setCreditAccounts(java.lang.String creditAccounts)
void | setDebitAccounts(java.lang.String debitAccounts)
void | setGlType(java.lang.String glType)
void | setId(java.lang.String id)
void | setName(java.lang.String name)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_ID

public static final java.lang.String ORDER_BY_ID
See Also:
Constant Field Values

ORDER_BY_NAME

public static final java.lang.String ORDER_BY_NAME
See Also:
Constant Field Values

ORDER_BY_GLTYPE

public static final java.lang.String ORDER_BY_GLTYPE
See Also:
Constant Field Values

ORDER_BY_DEBITACCOUNTS

public static final java.lang.String ORDER_BY_DEBITACCOUNTS
See Also:
Constant Field Values

ORDER_BY_CREDITACCOUNTS

public static final java.lang.String ORDER_BY_CREDITACCOUNTS
See Also:
Constant Field Values
Constructor Detail

GeneralLedgerCategoryVO

public GeneralLedgerCategoryVO()
Method Detail

getCreditAccounts

public java.lang.String getCreditAccounts()

setCreditAccounts

public void setCreditAccounts(java.lang.String creditAccounts)

getDebitAccounts

public java.lang.String getDebitAccounts()

setDebitAccounts

public void setDebitAccounts(java.lang.String debitAccounts)

getGlType

public java.lang.String getGlType()

setGlType

public void setGlType(java.lang.String glType)

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GeneralLedgerEntry

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class GeneralLedgerEntry

java.lang.Object
    extended by  bb.common.GeneralLedgerEntry
All Implemented Interfaces:
java.io.Serializable
public class GeneralLedgerEntry
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
GeneralLedgerEntry()
Method Summary
java.lang.String | getAccountNumber()
java.lang.String | getAccountNumberDescription()
java.math.BigDecimal | getCredit()
java.math.BigDecimal | getDebit()
java.lang.String | getDescription()
java.math.BigDecimal | getExchange()
java.lang.String | getFirstLevelAccountNumber()
java.lang.String | getFirstLevelAccountNumberDescription()
java.math.BigDecimal | getOriginalCredit()
java.math.BigDecimal | getOriginalDebit()
void | setAccountNumber(java.lang.String accountNumber)
void | setAccountNumberDescription(java.lang.String accountNumberDescription)
void | setCredit(java.math.BigDecimal credit)
void | setDebit(java.math.BigDecimal debit)
void | setDescription(java.lang.String description)
void | setExchange(java.math.BigDecimal exchange)
void | setFirstLevelAccountNumber(java.lang.String firstLevelAccountNumber)
void | setFirstLevelAccountNumberDescription(java.lang.String firstLevelAccountNumberDescription)
void | setOriginalCredit(java.math.BigDecimal originalCredit)
void | setOriginalDebit(java.math.BigDecimal originalDebit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

GeneralLedgerEntry

public GeneralLedgerEntry()
Method Detail

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getCredit

public java.math.BigDecimal getCredit()

setCredit

public void setCredit(java.math.BigDecimal credit)

getDebit

public java.math.BigDecimal getDebit()

setDebit

public void setDebit(java.math.BigDecimal debit)

getExchange

public java.math.BigDecimal getExchange()

setExchange

public void setExchange(java.math.BigDecimal exchange)

getOriginalCredit

public java.math.BigDecimal getOriginalCredit()

setOriginalCredit

public void setOriginalCredit(java.math.BigDecimal originalCredit)

getOriginalDebit

public java.math.BigDecimal getOriginalDebit()

setOriginalDebit

public void setOriginalDebit(java.math.BigDecimal originalDebit)

getAccountNumberDescription

public java.lang.String getAccountNumberDescription()

setAccountNumberDescription

public void setAccountNumberDescription(java.lang.String accountNumberDescription)

getFirstLevelAccountNumber

public java.lang.String getFirstLevelAccountNumber()

setFirstLevelAccountNumber

public void setFirstLevelAccountNumber(java.lang.String firstLevelAccountNumber)

getFirstLevelAccountNumberDescription

public java.lang.String getFirstLevelAccountNumberDescription()

setFirstLevelAccountNumberDescription

public void setFirstLevelAccountNumberDescription(java.lang.String firstLevelAccountNumberDescription)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GeneralLedgerListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class GeneralLedgerListResult

java.lang.Object
    extended by  bb.common.GeneralLedgerListResult
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
GLDebitCreditListResult
public class GeneralLedgerListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACCOUNTSPAYABLENUMBER
static java.lang.String | ORDER_BY_CHECKNUMBER
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_GLCATEGORY
static java.lang.String | ORDER_BY_INVOICENUMBER
static java.lang.String | ORDER_BY_PURCHASEORDERNUMBER
static java.lang.String | ORDER_BY_SALESORDERNUMBER
static java.lang.String | ORDER_BY_TRANSACTIONDATE
static java.lang.String | ORDER_BY_TRANSACTIONNUMBER
static java.lang.String | ORDER_BY_TRANSACTIONTYPE
static java.lang.String | ORDER_BY_VENDORINVOICE
Constructor Summary
GeneralLedgerListResult()
Method Summary
java.lang.String | getAccountsPayableNumber()
java.util.Date | getAdate()
java.lang.String | getBankReconsiled()
java.lang.String | getBatch()
java.lang.Integer | getCategorySequence()
java.lang.String | getCheckNumber()
java.lang.String | getCheckPrinted()
java.lang.String | getComments()
java.math.BigDecimal | getCommission()
java.lang.String | getCurrency()
java.lang.String | getCustomerId()
java.lang.String | getCustomerPo()
java.lang.String | getDescription()
java.math.BigDecimal | getDiscount()
java.math.BigDecimal | getExchange()
java.math.BigDecimal | getFreight()
java.lang.String | getGlCategory()
java.lang.String | getInvoiceNumber()
java.util.Date | getLastChangeDate()
java.lang.Integer | getLastChangeTimes()
java.lang.String | getLastChangeUser()
java.lang.String | getMemo()
java.lang.String | getName()
java.lang.String | getNotes()
java.math.BigDecimal | getPaid()
java.lang.String | getPurchaseOrderNumber()
java.math.BigDecimal | getReceived()
java.lang.String | getReceiverNumber()
java.lang.String | getReldoc()
java.lang.String | getSalesman()
java.lang.String | getSalesOrderNumber()
java.math.BigDecimal | getSalesTax()
java.lang.String | getShipperNumber()
java.util.Date | getTransactionDate()
java.lang.String | getTransactionNumber()
java.lang.String | getTransactionType()
java.lang.String | getTransactionTypeDescription()
java.lang.String | getVendorInvoice()
void | setAccountsPayableNumber(java.lang.String accountsPayableNumber)
void | setAdate(java.util.Date adate)
void | setBankReconsiled(java.lang.String bankReconsiled)
void | setBatch(java.lang.String batch)
void | setCategorySequence(java.lang.Integer categorySequence)
void | setCheckNumber(java.lang.String checkNumber)
void | setCheckPrinted(java.lang.String checkPrinted)
void | setComments(java.lang.String comments)
void | setCommission(java.math.BigDecimal commission)
void | setCurrency(java.lang.String currency)
void | setCustomerId(java.lang.String customerId)
void | setCustomerPo(java.lang.String customerPo)
void | setDescription(java.lang.String description)
void | setDiscount(java.math.BigDecimal discount)
void | setExchange(java.math.BigDecimal exchange)
void | setFreight(java.math.BigDecimal freight)
void | setGlCategory(java.lang.String glCategory)
void | setInvoiceNumber(java.lang.String invoiceNumber)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTimes(java.lang.Integer lastChangeTimes)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setMemo(java.lang.String memo)
void | setName(java.lang.String name)
void | setNotes(java.lang.String notes)
void | setPaid(java.math.BigDecimal paid)
void | setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)
void | setReceived(java.math.BigDecimal received)
void | setReceiverNumber(java.lang.String receiverNumber)
void | setReldoc(java.lang.String reldoc)
void | setSalesman(java.lang.String salesman)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setSalesTax(java.math.BigDecimal salesTax)
void | setShipperNumber(java.lang.String shipperNumber)
void | setTransactionDate(java.util.Date transactionDate)
void | setTransactionNumber(java.lang.String transactionNumber)
void | setTransactionType(java.lang.String transactionType)
void | setTransactionTypeDescription(java.lang.String transactionTypeDescription)
void | setVendorInvoice(java.lang.String vendorInvoice)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_TRANSACTIONNUMBER

public static final java.lang.String ORDER_BY_TRANSACTIONNUMBER
See Also:
Constant Field Values

ORDER_BY_TRANSACTIONTYPE

public static final java.lang.String ORDER_BY_TRANSACTIONTYPE
See Also:
Constant Field Values

ORDER_BY_TRANSACTIONDATE

public static final java.lang.String ORDER_BY_TRANSACTIONDATE
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_PURCHASEORDERNUMBER

public static final java.lang.String ORDER_BY_PURCHASEORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_ACCOUNTSPAYABLENUMBER

public static final java.lang.String ORDER_BY_ACCOUNTSPAYABLENUMBER
See Also:
Constant Field Values

ORDER_BY_SALESORDERNUMBER

public static final java.lang.String ORDER_BY_SALESORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_INVOICENUMBER

public static final java.lang.String ORDER_BY_INVOICENUMBER
See Also:
Constant Field Values

ORDER_BY_CHECKNUMBER

public static final java.lang.String ORDER_BY_CHECKNUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORINVOICE

public static final java.lang.String ORDER_BY_VENDORINVOICE
See Also:
Constant Field Values

ORDER_BY_GLCATEGORY

public static final java.lang.String ORDER_BY_GLCATEGORY
See Also:
Constant Field Values
Constructor Detail

GeneralLedgerListResult

public GeneralLedgerListResult()
Method Detail

getTransactionNumber

public java.lang.String getTransactionNumber()

setTransactionNumber

public void setTransactionNumber(java.lang.String transactionNumber)

getTransactionDate

public java.util.Date getTransactionDate()

setTransactionDate

public void setTransactionDate(java.util.Date transactionDate)

getTransactionType

public java.lang.String getTransactionType()

setTransactionType

public void setTransactionType(java.lang.String transactionType)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getBatch

public java.lang.String getBatch()

setBatch

public void setBatch(java.lang.String batch)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getCheckNumber

public java.lang.String getCheckNumber()

setCheckNumber

public void setCheckNumber(java.lang.String checkNumber)

getCheckPrinted

public java.lang.String getCheckPrinted()

setCheckPrinted

public void setCheckPrinted(java.lang.String checkPrinted)

getBankReconsiled

public java.lang.String getBankReconsiled()

setBankReconsiled

public void setBankReconsiled(java.lang.String bankReconsiled)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeTimes

public java.lang.Integer getLastChangeTimes()

setLastChangeTimes

public void setLastChangeTimes(java.lang.Integer lastChangeTimes)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getReldoc

public java.lang.String getReldoc()

setReldoc

public void setReldoc(java.lang.String reldoc)

getPurchaseOrderNumber

public java.lang.String getPurchaseOrderNumber()

setPurchaseOrderNumber

public void setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)

getReceiverNumber

public java.lang.String getReceiverNumber()

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)

getAccountsPayableNumber

public java.lang.String getAccountsPayableNumber()

setAccountsPayableNumber

public void setAccountsPayableNumber(java.lang.String accountsPayableNumber)

getVendorInvoice

public java.lang.String getVendorInvoice()

setVendorInvoice

public void setVendorInvoice(java.lang.String vendorInvoice)

getPaid

public java.math.BigDecimal getPaid()

setPaid

public void setPaid(java.math.BigDecimal paid)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getShipperNumber

public java.lang.String getShipperNumber()

setShipperNumber

public void setShipperNumber(java.lang.String shipperNumber)

getInvoiceNumber

public java.lang.String getInvoiceNumber()

setInvoiceNumber

public void setInvoiceNumber(java.lang.String invoiceNumber)

getCustomerPo

public java.lang.String getCustomerPo()

setCustomerPo

public void setCustomerPo(java.lang.String customerPo)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getSalesTax

public java.math.BigDecimal getSalesTax()

setSalesTax

public void setSalesTax(java.math.BigDecimal salesTax)

getReceived

public java.math.BigDecimal getReceived()

setReceived

public void setReceived(java.math.BigDecimal received)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getFreight

public java.math.BigDecimal getFreight()

setFreight

public void setFreight(java.math.BigDecimal freight)

getSalesman

public java.lang.String getSalesman()

setSalesman

public void setSalesman(java.lang.String salesman)

getCommission

public java.math.BigDecimal getCommission()

setCommission

public void setCommission(java.math.BigDecimal commission)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getNotes

public java.lang.String getNotes()

setNotes

public void setNotes(java.lang.String notes)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getTransactionTypeDescription

public java.lang.String getTransactionTypeDescription()

getExchange

public java.math.BigDecimal getExchange()

setTransactionTypeDescription

public void setTransactionTypeDescription(java.lang.String transactionTypeDescription)

setExchange

public void setExchange(java.math.BigDecimal exchange)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getMemo

public java.lang.String getMemo()

setMemo

public void setMemo(java.lang.String memo)

getCategorySequence

public java.lang.Integer getCategorySequence()

setCategorySequence

public void setCategorySequence(java.lang.Integer categorySequence)

getGlCategory

public java.lang.String getGlCategory()

setGlCategory

public void setGlCategory(java.lang.String glCategory)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GeneralLedgerPrintResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class GeneralLedgerPrintResult

java.lang.Object
    extended by  bb.common.GeneralLedgerPrintResult
All Implemented Interfaces:
java.io.Serializable
public class GeneralLedgerPrintResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
GeneralLedgerPrintResult()
Method Summary
java.lang.String | getApprovedBy()
java.lang.Integer | getAttachmentNum()
java.lang.String | getCategoryName()
java.lang.Integer | getCategorySequence()
java.util.List<GeneralLedgerEntry> | getEntryList()
java.lang.String | getGlCategory()
java.lang.String | getOrigin()
java.lang.String | getPostedBy()
java.math.BigDecimal | getTotalAmount()
java.util.Date | getTransactionDate()
void | setApprovedBy(java.lang.String approvedBy)
void | setAttachmentNum(java.lang.Integer attachmentNum)
void | setCategoryName(java.lang.String categoryName)
void | setCategorySequence(java.lang.Integer categorySequence)
void | setEntryList(java.util.List<GeneralLedgerEntry> entryList)
void | setGlCategory(java.lang.String glCategory)
void | setOrigin(java.lang.String origin)
void | setPostedBy(java.lang.String postedBy)
void | setTotalAmount(java.math.BigDecimal totalAmount)
void | setTransactionDate(java.util.Date transactionDate)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

GeneralLedgerPrintResult

public GeneralLedgerPrintResult()
Method Detail

getApprovedBy

public java.lang.String getApprovedBy()

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)

getAttachmentNum

public java.lang.Integer getAttachmentNum()

setAttachmentNum

public void setAttachmentNum(java.lang.Integer attachmentNum)

getCategoryName

public java.lang.String getCategoryName()

setCategoryName

public void setCategoryName(java.lang.String categoryName)

getCategorySequence

public java.lang.Integer getCategorySequence()

setCategorySequence

public void setCategorySequence(java.lang.Integer categorySequence)

getEntryList

public java.util.List<GeneralLedgerEntry> getEntryList()

setEntryList

public void setEntryList(java.util.List<GeneralLedgerEntry> entryList)

getGlCategory

public java.lang.String getGlCategory()

setGlCategory

public void setGlCategory(java.lang.String glCategory)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getPostedBy

public java.lang.String getPostedBy()

setPostedBy

public void setPostedBy(java.lang.String postedBy)

getTotalAmount

public java.math.BigDecimal getTotalAmount()

setTotalAmount

public void setTotalAmount(java.math.BigDecimal totalAmount)

getTransactionDate

public java.util.Date getTransactionDate()

setTransactionDate

public void setTransactionDate(java.util.Date transactionDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GeneralLedgerResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class GeneralLedgerResult

java.lang.Object
    extended by  bb.common.GeneralLedgerResult
All Implemented Interfaces:
java.io.Serializable
public class GeneralLedgerResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
GeneralLedgerResult()
Method Summary
java.lang.String | getBankReconciled()
java.lang.String | getBatch()
java.lang.String | getCheck()
java.lang.String | getCheckPrinted()
java.math.BigDecimal | getCommission()
java.lang.String | getCustomerPO()
java.math.BigDecimal | getDiscount()
java.lang.String | getId()
java.lang.String | getInvoiceNumber()
java.lang.String | getName()
java.lang.String | getOurPO()
java.lang.String | getReceiverNumber()
java.lang.String | getSalesOrderNumber()
java.math.BigDecimal | getSalesTax()
java.lang.String | getShipperNumber()
java.util.Date | getTransactionDate()
java.lang.String | getTransactionNumber()
java.lang.String | getTransactionType()
java.lang.String | getVendorInvoice()
void | setBankReconciled(java.lang.String bankReconciled)
void | setBatch(java.lang.String batch)
void | setCheck(java.lang.String check)
void | setCheckPrinted(java.lang.String checkPrinted)
void | setCommission(java.math.BigDecimal commission)
void | setCustomerPO(java.lang.String customerPO)
void | setDiscount(java.math.BigDecimal discount)
void | setId(java.lang.String id)
void | setInvoiceNumber(java.lang.String invoiceNumber)
void | setName(java.lang.String name)
void | setOurPO(java.lang.String ourPO)
void | setReceiverNumber(java.lang.String receiverNumber)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setSalesTax(java.math.BigDecimal salesTax)
void | setShipperNumber(java.lang.String shipperNumber)
void | setTransactionDate(java.util.Date transactionDate)
void | setTransactionNumber(java.lang.String transactionNumber)
void | setTransactionType(java.lang.String transactionType)
void | setVendorInvoice(java.lang.String vendorInvoice)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

GeneralLedgerResult

public GeneralLedgerResult()
Method Detail

getBankReconciled

public java.lang.String getBankReconciled()

setBankReconciled

public void setBankReconciled(java.lang.String bankReconciled)

getBatch

public java.lang.String getBatch()

setBatch

public void setBatch(java.lang.String batch)

getCheck

public java.lang.String getCheck()

setCheck

public void setCheck(java.lang.String check)

getCheckPrinted

public java.lang.String getCheckPrinted()

setCheckPrinted

public void setCheckPrinted(java.lang.String checkPrinted)

getCommission

public java.math.BigDecimal getCommission()

setCommission

public void setCommission(java.math.BigDecimal commission)

getCustomerPO

public java.lang.String getCustomerPO()

setCustomerPO

public void setCustomerPO(java.lang.String customerPO)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getInvoiceNumber

public java.lang.String getInvoiceNumber()

setInvoiceNumber

public void setInvoiceNumber(java.lang.String invoiceNumber)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getOurPO

public java.lang.String getOurPO()

setOurPO

public void setOurPO(java.lang.String ourPO)

getReceiverNumber

public java.lang.String getReceiverNumber()

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getSalesTax

public java.math.BigDecimal getSalesTax()

setSalesTax

public void setSalesTax(java.math.BigDecimal salesTax)

getShipperNumber

public java.lang.String getShipperNumber()

setShipperNumber

public void setShipperNumber(java.lang.String shipperNumber)

getTransactionDate

public java.util.Date getTransactionDate()

setTransactionDate

public void setTransactionDate(java.util.Date transactionDate)

getTransactionNumber

public java.lang.String getTransactionNumber()

setTransactionNumber

public void setTransactionNumber(java.lang.String transactionNumber)

getTransactionType

public java.lang.String getTransactionType()

setTransactionType

public void setTransactionType(java.lang.String transactionType)

getVendorInvoice

public java.lang.String getVendorInvoice()

setVendorInvoice

public void setVendorInvoice(java.lang.String vendorInvoice)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GeneralLedgerSettingsVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class GeneralLedgerSettingsVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.GeneralLedgerSettingsVO
All Implemented Interfaces:
java.io.Serializable
public class GeneralLedgerSettingsVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
GeneralLedgerSettingsVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCm0()
java.lang.String | getCm1()
java.lang.String | getCm2()
java.lang.String | getFm0()
java.lang.String | getFm1()
java.lang.String | getFm2()
java.lang.String | getFy()
int | getFy1()
int | getFy2()
java.lang.String | getId()
java.util.Date | getInitSom()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.util.Date | getLockedTransactionDate()
java.lang.String | getStatus()
java.util.Date | getValidTransactionDate()
int | getVersion()
int | hashCode()
void | setCm0(java.lang.String cm0)
void | setCm1(java.lang.String cm1)
void | setCm2(java.lang.String cm2)
void | setFm0(java.lang.String fm0)
void | setFm1(java.lang.String fm1)
void | setFm2(java.lang.String fm2)
void | setFy(java.lang.String fy)
void | setFy1(int fy1)
void | setFy2(int fy2)
void | setId(java.lang.String id)
void | setInitSom(java.util.Date initSom)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLockedTransactionDate(java.util.Date lockedTransactionDate)
void | setStatus(java.lang.String status)
void | setValidTransactionDate(java.util.Date validTransactionDate)
void | setVersion(int version)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

GeneralLedgerSettingsVO

public GeneralLedgerSettingsVO()
default constructor

Method Detail

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getValidTransactionDate

public java.util.Date getValidTransactionDate()

setValidTransactionDate

public void setValidTransactionDate(java.util.Date validTransactionDate)

getLockedTransactionDate

public java.util.Date getLockedTransactionDate()

setLockedTransactionDate

public void setLockedTransactionDate(java.util.Date lockedTransactionDate)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getInitSom

public java.util.Date getInitSom()

setInitSom

public void setInitSom(java.util.Date initSom)

getCm0

public java.lang.String getCm0()

setCm0

public void setCm0(java.lang.String cm0)

getCm1

public java.lang.String getCm1()

setCm1

public void setCm1(java.lang.String cm1)

getCm2

public java.lang.String getCm2()

setCm2

public void setCm2(java.lang.String cm2)

getFy

public java.lang.String getFy()

setFy

public void setFy(java.lang.String fy)

getFy1

public int getFy1()

setFy1

public void setFy1(int fy1)

getFy2

public int getFy2()

setFy2

public void setFy2(int fy2)

getFm0

public java.lang.String getFm0()

setFm0

public void setFm0(java.lang.String fm0)

getFm1

public java.lang.String getFm1()

setFm1

public void setFm1(java.lang.String fm1)

getFm2

public java.lang.String getFm2()

setFm2

public void setFm2(java.lang.String fm2)

getVersion

public int getVersion()

setVersion

public void setVersion(int version)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GeneralLedgerVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class GeneralLedgerVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.GeneralLedgerVO
All Implemented Interfaces:
java.io.Serializable
public class GeneralLedgerVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACCOUNTSPAYABLENUMBER
static java.lang.String | ORDER_BY_CATEGORYSEQUENCE
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_GLCATEGORY
static java.lang.String | ORDER_BY_INVOICENUMBER
static java.lang.String | ORDER_BY_PURCHASEORDERNUMBER
static java.lang.String | ORDER_BY_SALESORDERNUMBER
static java.lang.String | ORDER_BY_TRANSACTIONDATE
static java.lang.String | ORDER_BY_TRANSACTIONNUMBER
static java.lang.String | ORDER_BY_TRANSACTIONTYPE
Constructor Summary
GeneralLedgerVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Set | getAccountCredit()
java.util.Set | getAccountDebit()
java.lang.String | getAccountsPayableNumber()
java.util.Date | getAdate()
java.lang.String | getAppItemNumber()
java.lang.String | getAppNumber()
java.util.Map | getApPrepayApplys()
java.lang.String | getApprovalStatus()
java.lang.String | getApprovedBy()
java.util.Date | getApprovedDate()
java.lang.String | getArpItemNumber()
java.lang.String | getArpNumber()
java.util.Map | getArPrepayApplys()
java.lang.Integer | getAttachmentNum()
java.lang.String | getBankReconsiled()
java.lang.String | getBatch()
java.lang.Integer | getCategorySequence()
java.lang.String | getCheckNumber()
java.lang.String | getCheckPrinted()
java.lang.String | getCheckRunNumber()
java.lang.String | getComments()
java.math.BigDecimal | getCommission()
java.lang.String | getCurrency()
java.lang.String | getCustomerId()
java.lang.String | getCustomerPo()
java.lang.String | getDescription()
java.math.BigDecimal | getDiscount()
java.math.BigDecimal | getExchange()
java.math.BigDecimal | getFreight()
java.lang.String | getGlCategory()
java.lang.String | getInvoiceNumber()
java.util.Date | getLastChangeDate()
java.lang.Integer | getLastChangeTimes()
java.lang.String | getLastChangeUser()
java.lang.String | getMemo()
java.lang.String | getName()
java.lang.String | getNotes()
java.lang.String | getOrigin()
java.math.BigDecimal | getPaid()
java.lang.String | getPostedBy()
java.lang.String | getPurchaseOrderNumber()
java.math.BigDecimal | getReceived()
java.lang.String | getReceiverNumber()
java.util.Date | getReconciledDate()
java.lang.String | getReldoc()
java.lang.String | getSalesman()
java.lang.String | getSalesOrderNumber()
java.math.BigDecimal | getSalesTax()
java.lang.String | getShipperNumber()
java.util.Date | getTransactionDate()
java.lang.String | getTransactionNumber()
java.lang.String | getTransactionType()
AccountingTransactionTypeVO | getTransactionTypeDescription()
java.lang.String | getVendorInvoice()
int | hashCode()
boolean | isClear()
boolean | isDeposit()
boolean | isOverCarryPL()
boolean | isPosted()
void | setAccountCredit(java.util.Set accountCredit)
void | setAccountDebit(java.util.Set accountDebit)
void | setAccountsPayableNumber(java.lang.String accountsPayableNumber)
void | setAdate(java.util.Date adate)
void | setAppItemNumber(java.lang.String appItemNumber)
void | setAppNumber(java.lang.String appNumber)
void | setApPrepayApplys(java.util.Map apPrepayApplys)
void | setApprovalStatus(java.lang.String approvalStatus)
void | setApprovedBy(java.lang.String approvedBy)
void | setApprovedDate(java.util.Date approvedDate)
void | setArpItemNumber(java.lang.String arpItemNumber)
void | setArpNumber(java.lang.String arpNumber)
void | setArPrepayApplys(java.util.Map arPrepayApplys)
void | setAttachmentNum(java.lang.Integer attachmentNum)
void | setBankReconsiled(java.lang.String bankReconsiled)
void | setBatch(java.lang.String batch)
void | setCategorySequence(java.lang.Integer categorySequence)
void | setCheckNumber(java.lang.String checkNumber)
void | setCheckPrinted(java.lang.String checkPrinted)
void | setCheckRunNumber(java.lang.String checkRunNumber)
void | setClear(boolean clear)
void | setComments(java.lang.String comments)
void | setCommission(java.math.BigDecimal commission)
void | setCurrency(java.lang.String currency)
void | setCustomerId(java.lang.String customerId)
void | setCustomerPo(java.lang.String customerPo)
void | setDeposit(boolean deposit)
void | setDescription(java.lang.String description)
void | setDiscount(java.math.BigDecimal discount)
void | setExchange(java.math.BigDecimal exchange)
void | setFreight(java.math.BigDecimal freight)
void | setGlCategory(java.lang.String glCategory)
void | setInvoiceNumber(java.lang.String invoiceNumber)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTimes(java.lang.Integer lastChangeTimes)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setMemo(java.lang.String memo)
void | setName(java.lang.String name)
void | setNotes(java.lang.String notes)
void | setOrigin(java.lang.String origin)
void | setOverCarryPL(boolean overCarryPL)
void | setPaid(java.math.BigDecimal paid)
void | setPosted(boolean posted)
void | setPostedBy(java.lang.String postedBy)
void | setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)
void | setReceived(java.math.BigDecimal received)
void | setReceiverNumber(java.lang.String receiverNumber)
void | setReconciledDate(java.util.Date reconciledDate)
void | setReldoc(java.lang.String reldoc)
void | setSalesman(java.lang.String salesman)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setSalesTax(java.math.BigDecimal salesTax)
void | setShipperNumber(java.lang.String shipperNumber)
void | setTransactionDate(java.util.Date transactionDate)
void | setTransactionNumber(java.lang.String transactionNumber)
void | setTransactionType(java.lang.String transactionType)
void | setTransactionTypeDescription(AccountingTransactionTypeVO transactionTypeDescription)
void | setVendorInvoice(java.lang.String vendorInvoice)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_TRANSACTIONNUMBER

public static final java.lang.String ORDER_BY_TRANSACTIONNUMBER
See Also:
Constant Field Values

ORDER_BY_TRANSACTIONTYPE

public static final java.lang.String ORDER_BY_TRANSACTIONTYPE
See Also:
Constant Field Values

ORDER_BY_TRANSACTIONDATE

public static final java.lang.String ORDER_BY_TRANSACTIONDATE
See Also:
Constant Field Values

ORDER_BY_GLCATEGORY

public static final java.lang.String ORDER_BY_GLCATEGORY
See Also:
Constant Field Values

ORDER_BY_CATEGORYSEQUENCE

public static final java.lang.String ORDER_BY_CATEGORYSEQUENCE
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_PURCHASEORDERNUMBER

public static final java.lang.String ORDER_BY_PURCHASEORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_ACCOUNTSPAYABLENUMBER

public static final java.lang.String ORDER_BY_ACCOUNTSPAYABLENUMBER
See Also:
Constant Field Values

ORDER_BY_SALESORDERNUMBER

public static final java.lang.String ORDER_BY_SALESORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_INVOICENUMBER

public static final java.lang.String ORDER_BY_INVOICENUMBER
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

GeneralLedgerVO

public GeneralLedgerVO()
Method Detail

getTransactionNumber

public java.lang.String getTransactionNumber()

setTransactionNumber

public void setTransactionNumber(java.lang.String transactionNumber)

getTransactionDate

public java.util.Date getTransactionDate()

setTransactionDate

public void setTransactionDate(java.util.Date transactionDate)

getTransactionType

public java.lang.String getTransactionType()

setTransactionType

public void setTransactionType(java.lang.String transactionType)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getBatch

public java.lang.String getBatch()

setBatch

public void setBatch(java.lang.String batch)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getCheckNumber

public java.lang.String getCheckNumber()

setCheckNumber

public void setCheckNumber(java.lang.String checkNumber)

getCheckPrinted

public java.lang.String getCheckPrinted()

setCheckPrinted

public void setCheckPrinted(java.lang.String checkPrinted)

getBankReconsiled

public java.lang.String getBankReconsiled()

setBankReconsiled

public void setBankReconsiled(java.lang.String bankReconsiled)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeTimes

public java.lang.Integer getLastChangeTimes()

setLastChangeTimes

public void setLastChangeTimes(java.lang.Integer lastChangeTimes)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getReldoc

public java.lang.String getReldoc()

setReldoc

public void setReldoc(java.lang.String reldoc)

getPurchaseOrderNumber

public java.lang.String getPurchaseOrderNumber()

setPurchaseOrderNumber

public void setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)

getReceiverNumber

public java.lang.String getReceiverNumber()

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)

getAccountsPayableNumber

public java.lang.String getAccountsPayableNumber()

setAccountsPayableNumber

public void setAccountsPayableNumber(java.lang.String accountsPayableNumber)

getVendorInvoice

public java.lang.String getVendorInvoice()

setVendorInvoice

public void setVendorInvoice(java.lang.String vendorInvoice)

getPaid

public java.math.BigDecimal getPaid()

setPaid

public void setPaid(java.math.BigDecimal paid)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getShipperNumber

public java.lang.String getShipperNumber()

setShipperNumber

public void setShipperNumber(java.lang.String shipperNumber)

getInvoiceNumber

public java.lang.String getInvoiceNumber()

setInvoiceNumber

public void setInvoiceNumber(java.lang.String invoiceNumber)

getCustomerPo

public java.lang.String getCustomerPo()

setCustomerPo

public void setCustomerPo(java.lang.String customerPo)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getSalesTax

public java.math.BigDecimal getSalesTax()

setSalesTax

public void setSalesTax(java.math.BigDecimal salesTax)

getReceived

public java.math.BigDecimal getReceived()

setReceived

public void setReceived(java.math.BigDecimal received)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getFreight

public java.math.BigDecimal getFreight()

setFreight

public void setFreight(java.math.BigDecimal freight)

getSalesman

public java.lang.String getSalesman()

setSalesman

public void setSalesman(java.lang.String salesman)

getCommission

public java.math.BigDecimal getCommission()

setCommission

public void setCommission(java.math.BigDecimal commission)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getNotes

public java.lang.String getNotes()

setNotes

public void setNotes(java.lang.String notes)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getTransactionTypeDescription

public AccountingTransactionTypeVO getTransactionTypeDescription()

getMemo

public java.lang.String getMemo()

getExchange

public java.math.BigDecimal getExchange()

getAccountDebit

public java.util.Set getAccountDebit()

getAccountCredit

public java.util.Set getAccountCredit()

setTransactionTypeDescription

public void setTransactionTypeDescription(AccountingTransactionTypeVO transactionTypeDescription)

setMemo

public void setMemo(java.lang.String memo)

setExchange

public void setExchange(java.math.BigDecimal exchange)

setAccountDebit

public void setAccountDebit(java.util.Set accountDebit)

setAccountCredit

public void setAccountCredit(java.util.Set accountCredit)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getCheckRunNumber

public java.lang.String getCheckRunNumber()

setCheckRunNumber

public void setCheckRunNumber(java.lang.String checkRunNumber)

getAppNumber

public java.lang.String getAppNumber()

setAppNumber

public void setAppNumber(java.lang.String appNumber)

getArpNumber

public java.lang.String getArpNumber()

setArpNumber

public void setArpNumber(java.lang.String arpNumber)

getAppItemNumber

public java.lang.String getAppItemNumber()

setAppItemNumber

public void setAppItemNumber(java.lang.String appItemNumber)

getArpItemNumber

public java.lang.String getArpItemNumber()

setArpItemNumber

public void setArpItemNumber(java.lang.String arpItemNumber)

getApprovalStatus

public java.lang.String getApprovalStatus()

setApprovalStatus

public void setApprovalStatus(java.lang.String approvalStatus)

getApprovedBy

public java.lang.String getApprovedBy()

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)

getApprovedDate

public java.util.Date getApprovedDate()

setApprovedDate

public void setApprovedDate(java.util.Date approvedDate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

isPosted

public boolean isPosted()

setPosted

public void setPosted(boolean posted)

getAttachmentNum

public java.lang.Integer getAttachmentNum()

setAttachmentNum

public void setAttachmentNum(java.lang.Integer attachmentNum)

getCategorySequence

public java.lang.Integer getCategorySequence()

setCategorySequence

public void setCategorySequence(java.lang.Integer categorySequence)

getGlCategory

public java.lang.String getGlCategory()

setGlCategory

public void setGlCategory(java.lang.String glCategory)

getPostedBy

public java.lang.String getPostedBy()

setPostedBy

public void setPostedBy(java.lang.String postedBy)

isOverCarryPL

public boolean isOverCarryPL()

setOverCarryPL

public void setOverCarryPL(boolean overCarryPL)

setApPrepayApplys

public void setApPrepayApplys(java.util.Map apPrepayApplys)

getApPrepayApplys

public java.util.Map getApPrepayApplys()

getArPrepayApplys

public java.util.Map getArPrepayApplys()

setArPrepayApplys

public void setArPrepayApplys(java.util.Map arPrepayApplys)

isClear

public boolean isClear()

setClear

public void setClear(boolean clear)

isDeposit

public boolean isDeposit()

setDeposit

public void setDeposit(boolean deposit)

getReconciledDate

public java.util.Date getReconciledDate()

setReconciledDate

public void setReconciledDate(java.util.Date reconciledDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Generated Documentation (Untitled)

Frame Alert

This document is designed to be viewed using the frames feature. If you see this message, you are using a non-frame-capable web client.
Link toNon-frame version.


G-Index

Overview

Package

Class

Use

Tree

Deprecated

Index

Help

PREV LETTER NEXT LETTER

FRAMES NO FRAMES

A B C D E F G H I J L M N O P Q R S T U V W X Y Z

G

GENERAL_ACTION - Static variable in class bb.common.Constant.NoticeAction

GENERAL_LEDGER - Static variable in class bb.common.BizTarget

GENERAL_LEDGER_ALREADY_APPROVED - Static variable in class bb.common.BIZReason

GENERAL_LEDGER_ALREADY_EXIST - Static variable in class bb.common.BIZReason

GENERAL_LEDGER_APPROVAL - Static variable in class bb.common.BizTarget

GENERAL_LEDGER_APPROVAL_ALREADY_EXIST - Static variable in class bb.common.BIZReason

GENERAL_LEDGER_APPROVAL_NOT_EXIST - Static variable in class bb.common.BIZReason

GENERAL_LEDGER_BEEN_LOCKED - Static variable in class bb.common.BIZReason

GENERAL_LEDGER_CREDIT_DESRIPTION_IS_NULL - Static variable in class bb.common.BIZReason

GENERAL_LEDGER_DEBIT_DESRIPTION_IS_NULL - Static variable in class bb.common.BIZReason

GENERAL_LEDGER_NOT_BEEN_LOCKED - Static variable in class bb.common.BIZReason

GENERAL_LEDGER_NOT_EXIST - Static variable in class bb.common.BIZReason

GENERAL_LEDGER_SEQUENCE_ALREADY_EXIST - Static variable in class bb.common.BIZReason

GENERAL_LEDGER_SEQUENCE_CAN_NOT_BE_EMPTY - Static variable in class bb.common.BIZReason

GENERAL_LEDGER_SEQUENCE_NOT_EXIST - Static variable in class bb.common.BIZReason

GeneralLedgerApprovalVO - Class in bb.common

GeneralLedgerApprovalVO() - Constructor for class bb.common.GeneralLedgerApprovalVO

GeneralLedgerByDateListResult - Class in bb.common

GeneralLedgerByDateListResult() - Constructor for class bb.common.GeneralLedgerByDateListResult

GeneralLedgerCategoryVO - Class in bb.common

GeneralLedgerCategoryVO() - Constructor for class bb.common.GeneralLedgerCategoryVO

GeneralLedgerEntry - Class in bb.common

GeneralLedgerEntry() - Constructor for class bb.common.GeneralLedgerEntry

GeneralLedgerListResult - Class in bb.common

GeneralLedgerListResult() - Constructor for class bb.common.GeneralLedgerListResult

GeneralLedgerPrintResult - Class in bb.common

GeneralLedgerPrintResult() - Constructor for class bb.common.GeneralLedgerPrintResult

GeneralLedgerResult - Class in bb.common

GeneralLedgerResult() - Constructor for class bb.common.GeneralLedgerResult

GeneralLedgerSettingsVO - Class in bb.common

GeneralLedgerSettingsVO() - Constructor for class bb.common.GeneralLedgerSettingsVO
default constructor
GeneralLedgerVO - Class in bb.common

GeneralLedgerVO() - Constructor for class bb.common.GeneralLedgerVO

get(String) - Method in class bb.common.BB2QtyAndMoneyMap

get15MonthYear() - Method in interface bb.common.box.AccountingBox

GET_AP_PREPAY_ERROR - Static variable in class bb.common.BIZReason

GET_AR_PREPAY_ERROR - Static variable in class bb.common.BIZReason

GET_CG_CSRNUMBER_FAIL - Static variable in class bb.common.BIZReason

GET_CG_CUST_RFQNUMBER_FAIL - Static variable in class bb.common.BIZReason

GET_CUSTOMER_PART_ERROR - Static variable in class bb.common.BIZReason

GET_DISASSEMBLE_WORK_ORDER_APPROVAL_ERROR - Static variable in class bb.common.BIZReason

GET_ENGINEERING_CHANGE_REQUEST_WRONG - Static variable in class bb.common.BIZReason

GET_NEW_PURCHASE_WORK_SHEET_NUMBER_ERROR - Static variable in class bb.common.BIZReason

GET_ONLOAN_REVIEW_ERROR - Static variable in class bb.common.BIZReason

GET_ORDER_ITEM_ERROR - Static variable in class bb.common.BIZReason

GET_PART_STANDARD_COST_ERROR - Static variable in class bb.common.BIZReason

GET_PART_VERSION_ERROR - Static variable in class bb.common.BIZReason

GET_PROFORMA_RECEIVER_ERROR - Static variable in class bb.common.BIZReason

GET_PURCHASE_ORDER_APPROVAL_ERROR - Static variable in class bb.common.BIZReason

GET_PURCHASE_ORDER_ERROR - Static variable in class bb.common.BIZReason

GET_PURCHASE_WORK_SHEET_ERROR - Static variable in class bb.common.BIZReason

GET_REQUEST_FOR_QUOTE_ERROR - Static variable in class bb.common.BIZReason

GET_RETURN_TO_VENDOR_APPROVAL_ERROR - Static variable in class bb.common.BIZReason

GET_RETURN_TO_VENDOR_ERROR - Static variable in class bb.common.BIZReason

GET_RFQ_MESSAGE_ERROR - Static variable in class bb.common.BIZReason

GET_RMA_REVIEW_ERROR - Static variable in class bb.common.BIZReason

GET_SALES_ORDER_REVIEW_ERROR - Static variable in class bb.common.BIZReason

GET_USER_TRUENAME_WRONG - Static variable in class bb.common.BIZReason

GET_VENDOR_ERROR - Static variable in class bb.common.BIZReason

GET_VENDOR_PART_ERROR - Static variable in class bb.common.BIZReason

GET_VERSION_ERROR - Static variable in class bb.common.BIZReason

GET_WORK_ORDER_APPROVAL_ERROR - Static variable in class bb.common.BIZReason

GET_WORK_ORDER_ERROR - Static variable in class bb.common.BIZReason

GET_WORK_WORK_SHEET_ERROR - Static variable in class bb.common.BIZReason

getA2PartIssuedCountByDate(Date, Date, String, String, String, String, String, String, String, String, String, String[]) - Method in interface bb.common.box.WarehouseBox

getAccepted() - Method in class bb.common.CustomerReturnToVendorItemVO

getAccepted() - Method in class bb.common.RequestForRMAItemVO

getAccepted() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getAccepted() - Method in class bb.common.ReturnToVendorItemVO

getAcceptedBy() - Method in class bb.common.CustomerReturnToVendorItemVO

getAcceptedBy() - Method in class bb.common.PurchaseOrderItemVO

getAcceptedBy() - Method in class bb.common.RequestForRMAItemVO

getAcceptedBy() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getAcceptedBy() - Method in class bb.common.ReturnToVendorItemVO

getAcceptedDate() - Method in class bb.common.PurchaseOrderItemVO

getAccessPassword() - Method in class bb.common.SubcompanyVO

getAccessUserName() - Method in class bb.common.SubcompanyVO

getAccInfoDocumentByID(String, String, String) - Method in interface bb.common.box.AccountingBox

getAccmDepreciateCost() - Method in class bb.common.AssetAddOrDisposalsReport

getAccount() - Method in class bb.common.AssetAmortizationExpenseAccountVO

getAccountAgingTotalResultCount(String[], String[], boolean, Date) - Method in interface bb.common.box.AccountingBox

getAccountBalance(String, String, String, boolean) - Method in interface bb.common.box.AccountingBox

getAccountBalanceCountById(String, String, Date, Date, String) - Method in interface bb.common.box.AccountingBox

getAccountByCurrency(String, boolean) - Method in interface bb.common.box.CompanyBox

getAccountChartBalanceSheetAdvanceCategoryByPk() - Method in interface bb.common.box.AccountingBox

getAccountChartBalanceSheetAdvanceCategoryReportByPk(String) - Method in interface bb.common.box.AccountingBox

getAccountChartProfitLossAdvanceCategoryByPk() - Method in interface bb.common.box.AccountingBox

getAccountChartProfitLossAdvanceCategoryReportByPk(String) - Method in interface bb.common.box.AccountingBox

getAccountChartTaxPayableAdvanceCategoryByPk() - Method in interface bb.common.box.AccountingBox

getAccountChartTaxPayableAdvanceCategoryReportByPk(String) - Method in interface bb.common.box.AccountingBox

getAccountCredit() - Method in class bb.common.GeneralLedgerVO

getAccountDebit() - Method in class bb.common.GeneralLedgerVO

getAccountDescription() - Method in class bb.common.AccountBalanceListResult

getAccountDescription() - Method in class bb.common.BalanceSheetSideBySideItemResult

getAccountDescription() - Method in class bb.common.ClosingStatementItemResult

getAccountDescription() - Method in class bb.common.DepositSummaryResult

getAccountDescription() - Method in class bb.common.ExchangeAuditItemResult

getAccountDescription() - Method in class bb.common.GLCheckRegisterResult

getAccountDescription() - Method in class bb.common.ShareHoldersEquityResult

getAccountDesctiption() - Method in class bb.common.GeneralLedgerByDateListResult

getAccountInfoCenterResult() - Method in interface bb.common.box.ManagementBox

getAccountInfoDashBoardResult() - Method in interface bb.common.box.ManagementBox

getAccountingConfiguration() - Method in interface bb.common.box.CompanyBox

getAccountingInfoDocument(String, String, String) - Method in interface bb.common.box.AccountingBox

getAccountingReportType() - Method in class bb.common.AccountingInfoDocumentVO

getAccountingSettings() - Method in interface bb.common.box.CompanyBox

getAccountingTransactionTypesCountByType(String) - Method in interface bb.common.box.AccountingBox

getAccountNumber() - Method in class bb.common.AccountBalanceListResult

getAccountNumber() - Method in class bb.common.AccountBalanceResult

getAccountNumber() - Method in class bb.common.AccountCreditVO

getAccountNumber() - Method in class bb.common.AccountDebitVO

getAccountNumber() - Method in class bb.common.AccountMonthPK

getAccountNumber() - Method in class bb.common.AccountPayableCheckVO

getAccountNumber() - Method in class bb.common.AccountsChartVO

getAccountNumber() - Method in class bb.common.AccountsCreditDebitListResult

getAccountNumber() - Method in class bb.common.AccountsPayableItemVO

getAccountNumber() - Method in class bb.common.AccountsReceivableItemVO

getAccountNumber() - Method in class bb.common.AddressAccountInfo

getAccountNumber() - Method in class bb.common.AmountsStatementResult

getAccountNumber() - Method in class bb.common.BalanceSheetSideBySideItemResult

getAccountNumber() - Method in class bb.common.BB2tripleString

getAccountNumber() - Method in class bb.common.BudgetListResult

getAccountNumber() - Method in class bb.common.ClosingStatementItemResult

getAccountNumber() - Method in class bb.common.CompanyUnitAccountPK

getAccountNumber() - Method in class bb.common.DepositSummaryResult

getAccountNumber() - Method in class bb.common.DisassembleWorkOrderItemListResult

getAccountNumber() - Method in class bb.common.DWOIssueDetail

getAccountNumber() - Method in class bb.common.ExchangeAuditItemResult

getAccountNumber() - Method in class bb.common.ExpenseAccountVO

getAccountNumber() - Method in class bb.common.GeneralLedgerByDateListResult

getAccountNumber() - Method in class bb.common.GeneralLedgerEntry

getAccountNumber() - Method in class bb.common.GLCheckRegisterResult

getAccountNumber() - Method in class bb.common.GLDebitCreditListResult

getAccountNumber() - Method in class bb.common.GLItemVO

getAccountNumber() - Method in class bb.common.MakeCheckAgent

getAccountNumber() - Method in class bb.common.MakePrepaymentCheckAgent

getAccountNumber() - Method in class bb.common.MultiLanguageAccountsChartPK

getAccountNumber() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getAccountNumber() - Method in class bb.common.NonproductivePickingItemResult

getAccountNumber() - Method in class bb.common.NonproductivePickingTypeVO

getAccountNumber() - Method in class bb.common.NonproductivePickingVO

getAccountNumber() - Method in class bb.common.PaymentAgent

getAccountNumber() - Method in class bb.common.POReceiverItemListResult

getAccountNumber() - Method in class bb.common.PrepayPaymentAgent

getAccountNumber() - Method in class bb.common.ProfitAndLossAccountsResult

getAccountNumber() - Method in class bb.common.ProfitLossStatementItemResult

getAccountNumber() - Method in class bb.common.PurchaseOrderItemListResult

getAccountNumber() - Method in class bb.common.SalesOrderItemListResult

getAccountNumber() - Method in class bb.common.ShareHoldersEquityResult

getAccountNumber() - Method in class bb.common.ShipperItemListResult

getAccountNumber() - Method in class bb.common.TaxAccountVO

getAccountNumber() - Method in class bb.common.WOReceiverDetail

getAccountNumber() - Method in class bb.common.WorkOrderItemListResult

getAccountNumberDescription() - Method in class bb.common.GeneralLedgerEntry

getAccountPayableCheckByCheckNo(String) - Method in interface bb.common.box.AccountingBox

getAccountPayableCheckRunByPk(String) - Method in interface bb.common.box.AccountingBox

getAccountPayableChecksCountByCheckNumber(String) - Method in interface bb.common.box.AccountingBox

getAccountPayableChecksCountByCheckRunNumber(String) - Method in interface bb.common.box.AccountingBox

getAccountPayableNumber() - Method in class bb.common.OnloanReceiverVO

getAccountPayableNumber() - Method in class bb.common.ReceiverInfoVO

getAccountPayableNumber() - Method in class bb.common.ReceiverItemVO

getAccountPayableNumber() - Method in class bb.common.ReceiverVO

getAccountReceivableDiscount() - Method in class bb.common.QuoteItemVO

getAccountReceivableDiscount() - Method in class bb.common.SalesOrderItemInfoVO

getAccountReceivableDiscount() - Method in class bb.common.SalesOrderItemVO

getAccountReceivableOpen() - Method in class bb.common.SalesOrderItemInfoVO

getAccountReceivableOpen() - Method in class bb.common.SalesOrderItemListResult

getAccountReceivableOpen() - Method in class bb.common.SalesOrderItemVO

getAccountReceivableShip() - Method in class bb.common.SalesOrderItemInfoVO

getAccountReceivableShip() - Method in class bb.common.SalesOrderItemListResult

getAccountReceivableShip() - Method in class bb.common.SalesOrderItemVO

getAccountReceivableSub() - Method in class bb.common.QuoteItemVO

getAccountReceivableSub() - Method in class bb.common.SalesOrderItemInfoVO

getAccountReceivableSub() - Method in class bb.common.SalesOrderItemVO

getAccountReceivableTax() - Method in class bb.common.QuoteItemVO

getAccountReceivableTax() - Method in class bb.common.SalesOrderItemInfoVO

getAccountReceivableTax() - Method in class bb.common.SalesOrderItemVO

getAccountReceivableTotal() - Method in class bb.common.QuoteItemVO

getAccountsChart() - Method in class bb.common.AccountCreditVO

getAccountsChart() - Method in class bb.common.AccountDebitVO

getAccountsChart() - Method in class bb.common.GLItemVO

getAccountsChartByPk(String) - Method in interface bb.common.box.AccountingBox

getAccountsChartCategoryForBalanceSheetByPk(Long) - Method in interface bb.common.box.AccountingBox

getAccountsChartCategoryForEbitdaByPk(Long) - Method in interface bb.common.box.AccountingBox

getAccountsChartCategoryForProfitLossByPk(Long) - Method in interface bb.common.box.AccountingBox

getAccountsChartCategoryForTaxDetailByPk(Long) - Method in interface bb.common.box.AccountingBox

getAccountsChartCategoryReport(String) - Method in interface bb.common.box.AccountingBox

getAccountsChartMappingBySubcompanyIdCount(String) - Method in interface bb.common.box.AccountingBox

getAccountsChartsByIdCount(String) - Method in interface bb.common.box.AccountingBox

getAccountsChartsBySubTypeCount(String, String, String, String) - Method in interface bb.common.box.AccountingBox

getAccountsChartsByTypeCount(String, String, String) - Method in interface bb.common.box.AccountingBox

getAccountsChartsByTypeCount(String, String, String, String) - Method in interface bb.common.box.AccountingBox

getAccountsChartsCountByCompanyUnit(String, String, String, String) - Method in interface bb.common.box.AccountingBox

getAccountsChartVO() - Method in class bb.common.AccountsChartResult

getAccountsChartVO() - Method in class bb.common.MonthBalanceResult

getAccountsPayable() - Method in class bb.common.AccountingBalanceSheetResult

getAccountsPayableItemManufacturer() - Method in class bb.common.AccountsPayableItemVO

getAccountsPayableItems() - Method in class bb.common.AccountsPayableVO

getAccountsPayableNumber() - Method in class bb.common.GeneralLedgerListResult

getAccountsPayableNumber() - Method in class bb.common.GeneralLedgerVO

getAccountsReceivable() - Method in class bb.common.RunningAccountOrderVO

getAccountsReceivableItemManufacturer() - Method in class bb.common.AccountsReceivableItemVO

getAccountsReceivableItems() - Method in class bb.common.AccountsReceivableVO

getAccountSubType() - Method in class bb.common.AccountsChartVO

getAccountType() - Method in class bb.common.AccountBalanceResult

getAccountType() - Method in class bb.common.AccountsChartVO

getAccountType() - Method in class bb.common.AmountsStatementResult

getAccountType() - Method in class bb.common.BalanceSheetSideBySideItemResult

getAccountType() - Method in class bb.common.BudgetListResult

getAccountType() - Method in class bb.common.ClosingStatementItemResult

getAccountType() - Method in class bb.common.ExchangeAuditItemResult

getAccountType() - Method in class bb.common.GeneralLedgerByDateListResult

getAccountType() - Method in class bb.common.GlCashFlowBudgetVO

getAccountType() - Method in class bb.common.GlFiscalYearBudgetVO

getAccountType() - Method in class bb.common.ProfitLossStatementItemResult

getAccountVo() - Method in class bb.common.CurrentBalanceResult

getAccressQualityDocumentsCount(String, boolean) - Method in interface bb.common.box.QualityBox

getAcctPeriod() - Method in class bb.common.FiscalYearSettingsVO

getAccumulatedDeprAccount() - Method in class bb.common.AssetDepreciateVO

getAccumulatedDeprAccount() - Method in class bb.common.AssetVO

getAcknowledgeDate() - Method in class bb.common.PurchaseOrderListResult

getAcknowledgeDate() - Method in class bb.common.PurchaseOrderVO

getAcknowledgedBy() - Method in class bb.common.PreventiveActionRequestVO

getAcount() - Method in class bb.common.APTaxForZipcodeListResult

getAcount() - Method in class bb.common.ARTaxForZipcodeListResult

getAcquisitionCost() - Method in class bb.common.AssetAddOrDisposalsReport

getAcquisitionCost() - Method in class bb.common.AssetDepreciateDetailReport

getAcquisitionCost() - Method in class bb.common.AssetDepreciateVO

getAcquisitionCost() - Method in class bb.common.AssetReportSumResult

getAcquisitionCost() - Method in class bb.common.AssetVO

getAcquisitionDate() - Method in class bb.common.AssetAddOrDisposalsReport

getAcquisitionDate() - Method in class bb.common.AssetVO

getAction() - Method in class bb.common.BB2Event

getAction() - Method in class bb.common.BizboxBugChangesInfoVO

getAction() - Method in class bb.common.BizboxBugChangesVO

getAction() - Method in class bb.common.DocumentLogVO

getAction() - Method in class bb.common.LogMiscDocumentVO

getAction() - Method in class bb.common.LogPartDocumentVO

getAction() - Method in class bb.common.LogPartDwfVO

getAction() - Method in class bb.common.LogPartDwgVO

getAction() - Method in class bb.common.OperationLogVO

getAction() - Method in class bb.common.OrderApprovalItemsVO

getAction() - Method in class bb.common.OrderApprovalVO

getActionI18nKey() - Method in class bb.common.I18nEvent

getActionI18nParams() - Method in class bb.common.I18nEvent

getActionTime() - Method in class bb.common.OperationLogVO

getActionType() - Method in class bb.common.BuyerCodeVO

getActive() - Method in class bb.common.CycleCountVO

getActive() - Method in class bb.common.PartInventoryVO

getActive() - Method in class bb.common.PartOnhandVO

getActive() - Method in class bb.common.PhysicalInventoryVO

getActive() - Method in class bb.common.ToolInventoryVO

getActive() - Method in class bb.common.ToolOnhandVO

getActiveHelpServer() - Method in interface bb.common.box.CompanyBox

getActiveLabelTemplateByType(String) - Method in interface bb.common.box.WarehouseBox

getActiveQuestionList(String) - Method in interface bb.common.box.CustomerServiceBox

getActual() - Method in class bb.common.BudgetListResult

getActual() - Method in class bb.common.CustomerReturnToVendorItemVO

getActual() - Method in class bb.common.CustomerReturnToVendorVO

getActual() - Method in class bb.common.DisassembleWorkOrderItemVO

getActual() - Method in class bb.common.DisassembleWorkOrderVO

getActual() - Method in class bb.common.NonproductivePickingItemVO

getActual() - Method in class bb.common.OnLoanItemVO

getActual() - Method in class bb.common.OnLoanVO

getActual() - Method in class bb.common.PurchaseOrderItemVO

getActual() - Method in class bb.common.PurchaseOrderVO

getActual() - Method in class bb.common.RequestForQuoteItemVO

getActual() - Method in class bb.common.RequestForQuoteVO

getActual() - Method in class bb.common.RequestForRMAItemVO

getActual() - Method in class bb.common.RequestForRMAVO

getActual() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getActual() - Method in class bb.common.ReturnMaterialAuthorizationVO

getActual() - Method in class bb.common.ReturnToVendorItemVO

getActual() - Method in class bb.common.ReturnToVendorVO

getActual() - Method in class bb.common.SalesOrderItemInfoVO

getActual() - Method in class bb.common.SalesOrderItemVO

getActual() - Method in class bb.common.SalesOrderVO

getActual() - Method in class bb.common.WorkOrderItemPartDetail

getActual() - Method in class bb.common.WorkOrderItemVO

getActual() - Method in class bb.common.WorkOrderVO

getActualAccountsChart() - Method in class bb.common.AccountsChartResult

getActualAmount() - Method in class bb.common.DepositSummaryResult

getActualEndDate() - Method in class bb.common.WorkOrderItemSeqWCLoadResult

getActualEndDate() - Method in class bb.common.WorkOrderWorkInstructionSequenceDateAgent

getActualResult() - Method in class bb.common.InspectionConformanceReportItemCheckVO

getActualShipDate() - Method in class bb.common.WorkOrderWorkInstructionListResult

getActualStartDate() - Method in class bb.common.WorkOrderItemSeqWCLoadResult

getActualStartDate() - Method in class bb.common.WorkOrderWorkInstructionSequenceDateAgent

getActualTotal() - Method in class bb.common.BudgetListResult

getActualTotleMap() - Method in class bb.common.BudgetListResult

getActualYTD() - Method in class bb.common.BudgetListResult

getAdate() - Method in class bb.common.AccountsChartVO

getAdate() - Method in class bb.common.AccountsPayableInfoVO

getAdate() - Method in class bb.common.AccountsPayableVO

getAdate() - Method in class bb.common.AccountsReceivableInfoVO

getAdate() - Method in class bb.common.AccountsReceivableVO

getAdate() - Method in class bb.common.AssetVO

getAdate() - Method in class bb.common.CommonPrintTemplateVO

getAdate() - Method in class bb.common.CorrectiveActionRequestVO

getAdate() - Method in class bb.common.CustomerReturnToVendorVO

getAdate() - Method in class bb.common.DisassembleWorkOrderVO

getADate() - Method in class bb.common.EmployeeCardVO

getAdate() - Method in class bb.common.GeneralLedgerListResult

getAdate() - Method in class bb.common.GeneralLedgerVO

getAdate() - Method in class bb.common.InspectionConformanceReportVO

getAdate() - Method in class bb.common.InspectionReportInfoVO

getAdate() - Method in class bb.common.InspectionReportVO

getAdate() - Method in class bb.common.LabelTemplateVO

getADate() - Method in class bb.common.ManufacturerAddressInfoVO

getADate() - Method in class bb.common.ManufacturerAddressVO

getAdate() - Method in class bb.common.NcrNeedToScrapListResult

getAdate() - Method in class bb.common.NonConformanceCodeVO

getAdate() - Method in class bb.common.NonConformanceReportVO

getAdate() - Method in class bb.common.NonproductivePickingOnDemandResult

getAdate() - Method in class bb.common.NonproductivePickingVO

getAdate() - Method in class bb.common.OnloanReceiverVO

getAdate() - Method in class bb.common.OnloanShipperVO

getAdate() - Method in class bb.common.OnLoanVO

getAdate() - Method in class bb.common.OperatingInstructionsVO

getAdate() - Method in class bb.common.PaymentInvoicesResult

getAdate() - Method in class bb.common.PfReceiverVO

getAdate() - Method in class bb.common.POSurveyReportVO

getAdate() - Method in class bb.common.PreventiveActionRequestVO

getAdate() - Method in class bb.common.PrintTemplateVO

getAdate() - Method in class bb.common.ProformaInvoiceVO

getAdate() - Method in class bb.common.PurchaseOrderVO

getADate() - Method in class bb.common.QuoteVO

getAdate() - Method in class bb.common.ReceiverInfoVO

getAdate() - Method in class bb.common.ReceiverVO

getAdate() - Method in class bb.common.RequestForQuoteVO

getAdate() - Method in class bb.common.RequestForRMAVO

getAdate() - Method in class bb.common.ReturnMaterialAuthorizationVO

getAdate() - Method in class bb.common.ReturnToVendorVO

getAdate() - Method in class bb.common.RMAReceiverVO

getAdate() - Method in class bb.common.RtvShipperInfoVO

getAdate() - Method in class bb.common.RtvShipperVO

getAdate() - Method in class bb.common.SalesmanVO

getAdate() - Method in class bb.common.SalesOrderVO

getAdate() - Method in class bb.common.ShipperInfoVO

getAdate() - Method in class bb.common.ShipperVO

getAdate() - Method in class bb.common.SwapOrderListResult

getAdate() - Method in class bb.common.SwapOrderVO

getAdate() - Method in class bb.common.SwapReceiverListResult

getAdate() - Method in class bb.common.SwapReceiverVO

getAdate() - Method in class bb.common.SwapShipperListResult

getAdate() - Method in class bb.common.SwapShipperVO

getAdate() - Method in class bb.common.TransferOrderListResult

getAdate() - Method in class bb.common.TransferOrderVO

getAdate() - Method in class bb.common.TransferReceiverListResult

getAdate() - Method in class bb.common.TransferReceiverVO

getAdate() - Method in class bb.common.TransferShipperListResult

getAdate() - Method in class bb.common.TransferShipperVO

getAdate() - Method in class bb.common.WarehouseVO

getAdate() - Method in class bb.common.WorkInstructionRequestForChangeVO

getAdate() - Method in class bb.common.WorkInstructionVO

getAdate() - Method in class bb.common.WorkOrderVO

getAdate() - Method in class bb.common.WorkOrderWorkInstructionVO

getAddId() - Method in class bb.common.QualityGroupPK

getAddOrSubtract() - Method in class bb.common.ClosingStatementItemResult

getAddOrSubtract() - Method in class bb.common.ExchangeAuditItemResult

getAddr1() - Method in class bb.common.AccountReceivablePaymentVO

getAddr1() - Method in class bb.common.SGCartCheckOutResult

getAddr1() - Method in class bb.common.SGCustRequestForQuoteListResult

getAddr1() - Method in class bb.common.SGCustRequestForQuoteResult

getAddr1() - Method in class bb.common.SGQuoteAddressResult

getAddr1() - Method in class bb.common.SGQuoteAddressVO

getAddr2() - Method in class bb.common.AccountReceivablePaymentVO

getAddr2() - Method in class bb.common.SGCartCheckOutResult

getAddr2() - Method in class bb.common.SGCustRequestForQuoteListResult

getAddr2() - Method in class bb.common.SGCustRequestForQuoteResult

getAddr2() - Method in class bb.common.SGQuoteAddressResult

getAddr2() - Method in class bb.common.SGQuoteAddressVO

getAddress() - Method in class bb.common.CustomerVendorAddressInfoVO

getAddress() - Method in class bb.common.CustomerVendorAddressVO

getAddress() - Method in class bb.common.ExchangeAuditItemResult

getAddress1() - Method in class bb.common.AccountPayableCheckVO

getAddress1() - Method in class bb.common.SalesmanVO

getAddress1() - Method in class bb.common.ZipcodeTotalsResult

getAddress2() - Method in class bb.common.AccountPayableCheckVO

getAddress2() - Method in class bb.common.CustomerVendorAddressInfoVO

getAddress2() - Method in class bb.common.CustomerVendorAddressVO

getAddress2() - Method in class bb.common.SalesmanVO

getAddress2() - Method in class bb.common.ZipcodeTotalsResult

getAddressAccountInfoCount(String, Date, Date, boolean) - Method in interface bb.common.box.AccountingBox

getAddressesNoTaxInfo(Date, Date) - Method in interface bb.common.box.CompanyBox

getAddressId() - Method in class bb.common.AccountBalanceListResult

getAddressId() - Method in class bb.common.AccountCreditVO

getAddressId() - Method in class bb.common.AccountDebitVO

getAddressId() - Method in class bb.common.AddressQualityDocumentsVO

getAddressId() - Method in class bb.common.ArCommissionListResult

getAddressId() - Method in class bb.common.BB2tripleString

getAddressId() - Method in class bb.common.CarrierPK

getAddressId() - Method in class bb.common.GeneralLedgerByDateListResult

getAddressId() - Method in class bb.common.GLItemVO

getAddressId() - Method in class bb.common.LogTrackingVO

getAddressId() - Method in class bb.common.PartDueAddressListResult

getAddressId() - Method in class bb.common.PaymentAgent

getAddressId() - Method in class bb.common.PaymentHistoryVO

getAddressId() - Method in class bb.common.PrepayPaymentAgent

getAddressId() - Method in class bb.common.SalesCodeVO

getAddressID() - Method in class bb.common.SubcompanyVO

getAddressIdDefaultQaStatus() - Method in class bb.common.CompanyVO

getAddressIDLike() - Method in class bb.common.AccountAuditAgent

getAddressInfo() - Method in class bb.common.NonproductivePickingVO

getAddressInfo() - Method in class bb.common.OntimeDeliveryRateResult

getAddressName() - Method in class bb.common.AccountBalanceListResult

getAddressName() - Method in class bb.common.ArCommissionListResult

getAddressName() - Method in class bb.common.GeneralLedgerByDateListResult

getAddressName() - Method in class bb.common.LogTrackingVO

getAddressName() - Method in class bb.common.PartDueAddressListResult

getAddressName() - Method in class bb.common.PaymentHistoryVO

getAddressName() - Method in class bb.common.SalesCodeVO

getAddressOfCompanyID() - Method in interface bb.common.box.CompanyBox

getAddressOne() - Method in class bb.common.CustomerVendorDescriptionVO

getAddressOne() - Method in class bb.common.EmployeeHomeVO

getAddressOne() - Method in class bb.common.ManufacturerAddressInfoVO

getAddressOne() - Method in class bb.common.ManufacturerAddressVO

getAddressOne() - Method in class bb.common.ManufacturerDescriptionVO

getAddressQualityDocument(Long) - Method in interface bb.common.box.QualityBox

getAddressQualityDocumentInfo(Long) - Method in interface bb.common.box.QualityBox

getAddressQualityDocuments() - Method in class bb.common.CustomerVendorAddressVO

getAddressTwo() - Method in class bb.common.CustomerVendorDescriptionVO

getAddressTwo() - Method in class bb.common.EmployeeHomeVO

getAddressTwo() - Method in class bb.common.ManufacturerAddressInfoVO

getAddressTwo() - Method in class bb.common.ManufacturerAddressVO

getAddressTwo() - Method in class bb.common.ManufacturerDescriptionVO

getAddrInfo() - Method in class bb.common.CustomerStatementResult

getAdjustedQty() - Method in class bb.common.StockTransactionAdjustmentResult

getAdvances() - Method in class bb.common.ExpenseVO

getAge() - Method in class bb.common.CustomCheckUpEmployeeVO

getAge(Date) - Static method in class bb.common.CustomEmployeeVO

getAgeLevel(Date) - Static method in class bb.common.CustomEmployeeVO

getAgentsArray() - Method in class bb.common.WorkCenterAgent

getAgingAPItemsCount(String[], String[], boolean, Date) - Method in interface bb.common.box.AccountingBox

getAgingApsCount(String[], String[], boolean, Date) - Method in interface bb.common.box.AccountingBox

getAgingARItemsCount(String[], String[], boolean, Date) - Method in interface bb.common.box.AccountingBox

getAgingARsCount(String[], String[], boolean, Date) - Method in interface bb.common.box.AccountingBox

getAlarmValue() - Method in class bb.common.AccountCreditVO

getAlarmValue() - Method in class bb.common.AccountDebitVO

getAlarmValue() - Method in class bb.common.AccountsCreditDebitListResult

getAlarmValue() - Method in interface bb.common.Alarmable

getAlarmValue() - Method in class bb.common.APAuditListResult

getAlarmValue() - Method in class bb.common.ARAuditListResult

getAlarmValue() - Method in class bb.common.GLItemVO

getAlarmValue() - Method in class bb.common.LockedCustomerAddressResult

getAlarmValue() - Method in class bb.common.PartCatalogAuditResult

getAlarmValue() - Method in class bb.common.PartOnHandAuditResult

getAllAccountingTransactionTypesCount() - Method in interface bb.common.box.AccountingBox

getAllAccountPayableCheckRunsCount() - Method in interface bb.common.box.AccountingBox

getAllAccountPayableChecksCount() - Method in interface bb.common.box.AccountingBox

getAllAccountReceivablePaymentsCount() - Method in interface bb.common.box.AccountingBox

getAllAccountsByCurrency(boolean) - Method in interface bb.common.box.CompanyBox

getAllAccountsChartBalanceByMonth(String) - Method in interface bb.common.box.AccountingBox

getAllAccountsChartCategoryForBalanceSheetCountByCategoryName(String) - Method in interface bb.common.box.AccountingBox

getAllAccountsChartCategoryForBalanceSheetPredefineCountByCategoryName(String) - Method in interface bb.common.box.AccountingBox

getAllAccountsChartCategoryForProfitLossCountByCategoryName(String) - Method in interface bb.common.box.AccountingBox

getAllAccountsChartCategoryForProfitLossPredefineCountByCategoryName(String) - Method in interface bb.common.box.AccountingBox

getAllAccountsChartCategoryForTaxDetailCountByCategoryName(String) - Method in interface bb.common.box.AccountingBox

getAllAccountsChartCategoryForTaxDetailPredefineCountByCategoryName(String) - Method in interface bb.common.box.AccountingBox

getAllAccountsChartsCount(boolean) - Method in interface bb.common.box.AccountingBox

getAllAccountsReceivablesCount() - Method in interface bb.common.box.AccountingBox

getAllAPCount() - Method in interface bb.common.box.AccountingBox

getAllArBPCount() - Method in interface bb.common.box.AccountingBox

getAllARInvoicesCount() - Method in interface bb.common.box.AccountingBox

getAllARPaymentRunsCount() - Method in interface bb.common.box.AccountingBox

getAllARWithoutTrackingCount() - Method in interface bb.common.box.AccountingBox

getAllAssetsCount() - Method in interface bb.common.box.AccountingBox

getAllAssetsDepreciationMonthsCount(String) - Method in interface bb.common.box.AccountingBox

getAllAssetTypesCount() - Method in interface bb.common.box.AccountingBox

getAllBankOrCashGLByDateCount(String, String, String, String, boolean) - Method in interface bb.common.box.AccountingBox

getAllBillsWithPartInfoCount() - Method in interface bb.common.box.EngineeringBox

getAllBomApprovalsCount() - Method in interface bb.common.box.EngineeringBox

getAllBomItemsCount(String[], String) - Method in interface bb.common.box.EngineeringBox

getAllBomsToDeleteCount() - Method in interface bb.common.box.EngineeringBox

getAllBSValues() - Static method in class bb.common.Constant.ChartOfAccountType

getAllBuyerCodeCount() - Method in interface bb.common.box.CompanyBox

getAllCalibrationsCount() - Method in interface bb.common.box.ManufacturingBox

getAllCanClosedNcrsCount(String, String, String, Date, Date, boolean, boolean) - Method in interface bb.common.box.QualityBox

getAllCarsCount() - Method in interface bb.common.box.QualityBox

getAllCashierCount() - Method in interface bb.common.box.CompanyBox

getAllCatalogsId() - Method in interface bb.common.box.SalesBox

getAllCertificateDescsCount() - Method in interface bb.common.box.QualityBox

getAllCompanyUnitAccountCount() - Method in interface bb.common.box.CompanyBox

getAllCompanyUnitCount() - Method in interface bb.common.box.CompanyBox

getAllCompanyUnitsByAccountNumber() - Method in interface bb.common.box.CompanyBox

getAllContractsCount() - Method in interface bb.common.box.SalesBox

getAllCurrencyCount() - Method in interface bb.common.box.CompanyBox

getAllCustomAssetRecordByAssetNumber(String) - Method in interface bb.common.box.HumanResourceBox

getAllCustomDepartmentCount() - Method in interface bb.common.box.HumanResourceBox

getAllCustomerFeedbackCount() - Method in interface bb.common.box.CustomerServiceBox

getAllCustomersCount() - Method in interface bb.common.box.AddressBox

getAllCustomerTypeCount() - Method in interface bb.common.box.AddressBox

getAllCustomerVendorAddressCount() - Method in interface bb.common.box.AddressBox

getAllCustomSearchCount() - Method in interface bb.common.box.CompanyBox

getAllDataFilterCount() - Method in interface bb.common.box.CompanyBox

getAllDCsCount() - Method in interface bb.common.box.EngineeringBox

getAllDepartmentLocationForBackflushsCount() - Method in interface bb.common.box.WarehouseBox

getAllDepartmentsCount() - Method in interface bb.common.box.AddressBox

getAllDisassembleWorkOrderApprovalsCount() - Method in interface bb.common.box.WorkOrderBox

getAllDocumentsCount(String, String, String, String, String, String, boolean) - Method in interface bb.common.box.DocumentBox

getAllDocumentServerSettings() - Method in interface bb.common.box.CompanyBox

getAllDueLoanCount() - Method in interface bb.common.box.WarehouseBox

getAllDueRmaCount() - Method in interface bb.common.box.SalesBox

getAllDueSalesOrdersTotalMoneyValue(String) - Method in interface bb.common.box.SalesBox

getAllDueSalesOrdersTotalMoneyValue() - Method in interface bb.common.box.SalesBox

getAllDueSoItemsCount() - Method in interface bb.common.box.SalesBox

getAllECNControlCount() - Method in interface bb.common.box.EngineeringBox

getAllECRControlCount() - Method in interface bb.common.box.EngineeringBox

getAllECRequestsCount() - Method in interface bb.common.box.EngineeringBox

getAllEmployeeCardCount() - Method in interface bb.common.box.HumanResourceBox

getAllEmployeeDepartment() - Method in interface bb.common.box.HumanResourceBox

getAllEmployeeIDs() - Method in interface bb.common.box.HumanResourceBox

getAllEmployeeLogsCount() - Method in interface bb.common.box.LogBox

getAllEmployeeStatus() - Method in interface bb.common.box.HumanResourceBox

getAllEngGroupCount() - Method in interface bb.common.box.EngineeringBox

getAllEngineeringChangesCount() - Method in interface bb.common.box.EngineeringBox

getAllEquipmentsCount() - Method in interface bb.common.box.ManufacturingBox

getAllExpenseAccountCount() - Method in interface bb.common.box.AccountingBox

getAllExpensesCount() - Method in interface bb.common.box.AccountingBox

getAllExpireDateDocCount(String, String, String, Date, Date, String) - Method in interface bb.common.box.AddressBox

getAllFileByTaskId(Long) - Method in interface bb.common.box.CompanyBox

getAllFirstLevelAccountBalanceByMonth(String) - Method in interface bb.common.box.AccountingBox

getAllFirstLevelAccountCharts() - Method in interface bb.common.box.AccountingBox

getAllFiscalYearSettingsCount() - Method in interface bb.common.box.AccountingBox

getAllGeneralLedgerApprovalCount() - Method in interface bb.common.box.AccountingBox

getAllGeneralLedgersCount(String, String, String, String, String, Date, Date) - Method in interface bb.common.box.AccountingBox

getAllGLAutoApproves() - Method in interface bb.common.box.AccountingBox

getAllGlCategories() - Method in interface bb.common.box.AccountingBox

getAllGlMonthCount() - Method in interface bb.common.box.AccountingBox

getAllHelpServerCount() - Method in interface bb.common.box.CompanyBox

getAllIncidentItemCount() - Method in interface bb.common.box.CustomerServiceBox

getAllIncidentsCount() - Method in interface bb.common.box.CustomerServiceBox

getAllIncotermsCount() - Method in interface bb.common.box.SalesBox

getAllInspectionItemCount(int) - Method in interface bb.common.box.ManufacturingBox

getAllInspectionReportInspectMethodCount() - Method in interface bb.common.box.ManufacturingBox

getAllInspectionType() - Method in interface bb.common.box.QualityBox

getAllLabelTemplateCount() - Method in interface bb.common.box.WarehouseBox

getAllLockedCustomerCount(boolean) - Method in interface bb.common.box.AddressBox

getAllLogInventoryCount() - Method in interface bb.common.box.WarehouseBox

getAllLogsCount() - Method in interface bb.common.box.LogBox

getAllManufacturerAddressesCount() - Method in interface bb.common.box.AddressBox

getAllManufacturerECRequestsCount() - Method in interface bb.common.box.ManufacturingBox

getAllManufacturerEngineeringChangesCount() - Method in interface bb.common.box.ManufacturingBox

getAllMasterWorkOrderCount(String, String, String, String) - Method in interface bb.common.box.WorkOrderBox

getAllMethodsCount() - Method in interface bb.common.box.SecurityBox

getAllMiscDocSettingCount() - Method in interface bb.common.box.CompanyBox

getAllMyWorkOrderWorkSheetCount() - Method in interface bb.common.box.WorkOrderBox

getAllNCCsCount() - Method in interface bb.common.box.QualityBox

getAllNCRsCount() - Method in interface bb.common.box.QualityBox

getAllNonproductivePickingApprovalsCount() - Method in interface bb.common.box.WarehouseBox

getAllNonproductivePickingTypesCount() - Method in interface bb.common.box.WarehouseBox

getAllNotClosedPFNumbers() - Method in interface bb.common.box.WarehouseBox

getAllNotClosedProformaInvoicesCount() - Method in interface bb.common.box.WarehouseBox

getAllNotEmployeeLogsCount() - Method in interface bb.common.box.LogBox

getAllOldMessageCount() - Method in interface bb.common.box.CompanyBox

getAllOnHandAuditCount(String, String) - Method in interface bb.common.box.WarehouseBox

getAllOnlineUsersCount() - Method in interface bb.common.box.SecurityBox

getAllOnloanControlCount() - Method in interface bb.common.box.WarehouseBox

getAllOnLoanCount() - Method in interface bb.common.box.WarehouseBox

getAllOnLoanCountByAddressId(String) - Method in interface bb.common.box.WarehouseBox

getAllOnloanShippersCount() - Method in interface bb.common.box.WarehouseBox

getAllOpenLoanCount() - Method in interface bb.common.box.WarehouseBox

getAllOpenOnLoanCountByAddressId(String) - Method in interface bb.common.box.WarehouseBox

getAllOpenQuotesCount() - Method in interface bb.common.box.SalesBox

getAllOpenRmaCount() - Method in interface bb.common.box.SalesBox

getAllOpenSalesOrdersTotalMoneyValue(String) - Method in interface bb.common.box.SalesBox

getAllOpenSalesOrdersTotalMoneyValue() - Method in interface bb.common.box.SalesBox

getAllOpenSoItemsCount() - Method in interface bb.common.box.SalesBox

getAllOpenSoItemsCountByAddressId(String) - Method in interface bb.common.box.SalesBox

getAllOpenSoItemsCountByAddressIdandShipVia(String, String) - Method in interface bb.common.box.SalesBox

getAllOperatingInstructionsInspectStandardCount() - Method in interface bb.common.box.ManufacturingBox

getAllOperatingInstructionsManualCount() - Method in interface bb.common.box.ManufacturingBox

getAllOperatingInstructionsTypeCount() - Method in interface bb.common.box.ManufacturingBox

getAllOperatingOutputFileTypeCount() - Method in interface bb.common.box.ManufacturingBox

getAllPackingBoxsCount() - Method in interface bb.common.box.WarehouseBox

getAllPARsCount() - Method in interface bb.common.box.QualityBox

getAllPartCertificatesCount() - Method in interface bb.common.box.QualityBox

getAllPartdiscount() - Method in interface bb.common.box.SalesBox

getAllPartDocumentsCount() - Method in interface bb.common.box.DocumentBox

getAllPartDocumentsCountByDocumentType(String) - Method in interface bb.common.box.DocumentBox

getAllPartInQAsfor(BB2Part, String) - Method in interface bb.common.box.WarehouseBox

getAllPartInQAsToMakeNCRCount(String) - Method in interface bb.common.box.QualityBox

getAllPartInQAsWithoutNCR(BB2Part) - Method in interface bb.common.box.WarehouseBox

getAllPartInQAsWithoutNCRCount(BB2Part) - Method in interface bb.common.box.WarehouseBox

getAllPartOnhandCount() - Method in interface bb.common.box.WarehouseBox

getAllPartsCount() - Method in interface bb.common.box.EngineeringBox

getAllPartSecurityLevelCount() - Method in interface bb.common.box.EngineeringBox

getAllPartsToDeleteCount() - Method in interface bb.common.box.EngineeringBox

getAllPartsWithOnhandInfoCount(String, String, String) - Method in interface bb.common.box.EngineeringBox

getAllPartsWithOnhandInfoCount(String, String, String, String, String, String, String, String, String, boolean) - Method in interface bb.common.box.EngineeringBox

getAllPartTypeCount() - Method in interface bb.common.box.CompanyBox

getAllPastDueLoanCountByAddressId(String) - Method in interface bb.common.box.WarehouseBox

getAllPastDueSoItemsCountByAddressId(String) - Method in interface bb.common.box.SalesBox

getAllPastedQuotesCount() - Method in interface bb.common.box.SalesBox

getAllPermissionCount(boolean) - Method in interface bb.common.box.SecurityBox

getAllPermissionMethodCount() - Method in interface bb.common.box.SecurityBox

getAllPfReceiversCount() - Method in interface bb.common.box.PurchasingBox

getAllPoMessageCount() - Method in interface bb.common.box.PurchasingBox

getAllPrintLogoCount() - Method in interface bb.common.box.CompanyBox

getAllPrintTemplateCount() - Method in interface bb.common.box.CompanyBox

getAllProfitAndLossAccounts() - Method in interface bb.common.box.AccountingBox

getAllProformaInvoicesCount() - Method in interface bb.common.box.WarehouseBox

getAllPurchaseOrderApprovalsCount() - Method in interface bb.common.box.ManufacturingBox

getAllPurchaseOrderApprovalsCount() - Method in interface bb.common.box.PurchasingBox

getAllPurchaseOrderBPCount() - Method in interface bb.common.box.PurchasingBox

getAllPurchaseOrderCheckListResultsCount() - Method in interface bb.common.box.ManufacturingBox

getAllPurchaseOrderCheckListResultsCount() - Method in interface bb.common.box.PurchasingBox

getAllPurchaseOrderCountByAddressId(String) - Method in interface bb.common.box.ManufacturingBox

getAllPurchaseOrderCountByAddressId(String) - Method in interface bb.common.box.PurchasingBox

getAllPurchaseOrderItemsCount() - Method in interface bb.common.box.ManufacturingBox

getAllPurchaseOrderItemsCount() - Method in interface bb.common.box.PurchasingBox

getAllPurchaseOrderItemsCountByAddressId(String, String) - Method in interface bb.common.box.PurchasingBox

getAllPurchaseOrdersCount() - Method in interface bb.common.box.ManufacturingBox

getAllPurchaseOrdersCount() - Method in interface bb.common.box.PurchasingBox

getAllPurchaseOrderStatisticsCount(String, String, String, String, String) - Method in interface bb.common.box.PurchasingBox

getAllPurchaseOrderStatisticsTotal(String, String, String, String, String) - Method in interface bb.common.box.PurchasingBox

getAllPurchaseTaxAccount() - Method in interface bb.common.box.CompanyBox

getAllPurchaseWorkSheetCount() - Method in interface bb.common.box.ManufacturingBox

getAllPurchaseWorkSheetCount() - Method in interface bb.common.box.PurchasingBox

getAllQualityGroupsCount() - Method in interface bb.common.box.QualityBox

getAllQuestionCount() - Method in interface bb.common.box.CustomerServiceBox

getAllQuoteBPCount() - Method in interface bb.common.box.SalesBox

getAllQuoteCount() - Method in interface bb.common.box.SalesBox

getAllReceivedMessagesCount(String, String, String, String, Date, Date) - Method in interface bb.common.box.CompanyBox

getAllReceiver() - Method in class bb.common.MessageVO

getAllReceiversCount() - Method in interface bb.common.box.WarehouseBox

getAllRFCsCount() - Method in interface bb.common.box.ManufacturingBox

getAllRfqCheckListResultsCount() - Method in interface bb.common.box.ManufacturingBox

getAllRfqCheckListResultsCount() - Method in interface bb.common.box.PurchasingBox

getAllRfqMessageCount() - Method in interface bb.common.box.PurchasingBox

getAllRMAReviewsCount() - Method in interface bb.common.box.SalesBox

getAllRmasCount() - Method in interface bb.common.box.SalesBox

getAllRolesByRoleIdCount(String, String) - Method in interface bb.common.box.SecurityBox

getAllRolesCount(String) - Method in interface bb.common.box.SecurityBox

getAllRTVApprovalsCount() - Method in interface bb.common.box.PurchasingBox

getAllRtvCheckListResultsCount() - Method in interface bb.common.box.ManufacturingBox

getAllRtvCheckListResultsCount() - Method in interface bb.common.box.PurchasingBox

getAllSalesCodeCount() - Method in interface bb.common.box.SalesBox

getAllSalesCodeNameCount() - Method in interface bb.common.box.SalesBox

getAllSalesmanCount() - Method in interface bb.common.box.SalesBox

getAllSalesOrderBPCount() - Method in interface bb.common.box.SalesBox

getAllSalesOrderControlCount() - Method in interface bb.common.box.SalesBox

getAllSalesOrderCount() - Method in interface bb.common.box.SalesBox

getAllSalesOrdersCountByAddressId(String) - Method in interface bb.common.box.SalesBox

getAllSalesTaxAccount() - Method in interface bb.common.box.CompanyBox

getAllSentMessagesCount(String, String, String, Date, Date) - Method in interface bb.common.box.CompanyBox

getAllSerialNumberCount() - Method in interface bb.common.box.QualityBox

getAllShipListOwnersCount() - Method in interface bb.common.box.PlanningBox

getAllShipListsCount() - Method in interface bb.common.box.PlanningBox

getAllShippersCount() - Method in interface bb.common.box.WarehouseBox

getAllSOItemsCanShipCount(String, Date, Date) - Method in interface bb.common.box.SalesBox

getAllSoItemsCountByAddressId(String) - Method in interface bb.common.box.SalesBox

getAllState() - Method in interface bb.common.box.CompanyBox

getAllSubcompanysByIdCount(String) - Method in interface bb.common.box.CompanyBox

getAllSwapOrderApprovalCount() - Method in interface bb.common.box.PurchasingBox

getAllTasksCount() - Method in interface bb.common.box.CompanyBox

getAllTasksList() - Method in interface bb.common.box.CompanyBox

getAllTaxType() - Method in interface bb.common.box.AddressBox

getAllTerms() - Method in interface bb.common.box.CompanyBox

getAllTermsConditionsCount() - Method in interface bb.common.box.CompanyBox

getAllTermsCount() - Method in interface bb.common.box.CompanyBox

getAllTimeCardsCount() - Method in interface bb.common.box.ManufacturingBox

getAllToolListsWithToolInfoCount() - Method in interface bb.common.box.ManufacturingBox

getAllToolsCount() - Method in interface bb.common.box.ManufacturingBox

getAllTraceableCategoriesCount() - Method in interface bb.common.box.EngineeringBox

getAllTraceableSpecsCount() - Method in interface bb.common.box.EngineeringBox

getAllTransferOrderApprovalCount() - Method in interface bb.common.box.WarehouseBox

getAllUsersCount() - Method in interface bb.common.box.SecurityBox

getAllUsersEmployeeInfoCount(String, String) - Method in interface bb.common.box.SecurityBox

getAllUsersEmployeeInfoCount(String, String, boolean) - Method in interface bb.common.box.SecurityBox

getAllValues() - Static method in class bb.common.Constant.ChartOfAccountType

getAllVendorContractsCount() - Method in interface bb.common.box.PurchasingBox

getAllVendorsCount() - Method in interface bb.common.box.AddressBox

getAllVendorTypeCount() - Method in interface bb.common.box.AddressBox

getAllWarehousesCount() - Method in interface bb.common.box.WarehouseBox

getAllWeightUnitCount(String) - Method in interface bb.common.box.CompanyBox

getAllWeightUnitCount() - Method in interface bb.common.box.CompanyBox

getAllWorkCalendar(Date, Date, int) - Method in interface bb.common.box.ManufacturingBox

getAllWorkFlowCount() - Method in interface bb.common.box.CompanyBox

getAllWorkInstructionsCount() - Method in interface bb.common.box.ManufacturingBox

getAllWorkOrderApprovalsCount() - Method in interface bb.common.box.WorkOrderBox

getAllWorkOrderBPCount() - Method in interface bb.common.box.WorkOrderBox

getAllWorkOrderCheckListResultsCount() - Method in interface bb.common.box.WorkOrderBox

getAllWorkOrderReceiversCount() - Method in interface bb.common.box.WarehouseBox

getAllWorkOrderWorkSheetCount() - Method in interface bb.common.box.WorkOrderBox

getAllZipCodeCount(String) - Method in interface bb.common.box.CompanyBox

getAllZipCodeTaxByTaxType(String) - Method in interface bb.common.box.CompanyBox

getAmortizationExpenseAccount() - Method in class bb.common.AssetDepreciateVO

getAmortizationExpenseAccount() - Method in class bb.common.AssetVO

getAmortizationExpenseAccounts() - Method in class bb.common.AssetDepreciateVO

getAmortizationExpenseAccounts() - Method in class bb.common.AssetVO

getAmount() - Method in class bb.common.ApCheckRunListResult

getAmount() - Method in class bb.common.ARPaymentRunListResult

getAmount() - Method in class bb.common.DepositSummaryResult

getAmount() - Method in class bb.common.ExpenseItemVO

getAmount() - Method in class bb.common.ShareHoldersEquityResult

getAmountDue() - Method in class bb.common.AccountingTotalMoneyResult

getAmountDue() - Method in class bb.common.AccountReceivableInfoWithPrepayResult

getAmountDue() - Method in class bb.common.AccountsReceivableInfoVO

getAmountDue() - Method in class bb.common.AccountsReceivableVO

getAmountDue() - Method in class bb.common.DuePATotalByVendorResult

getAmountPaid() - Method in class bb.common.ARAllStatementsListResult

getAmountPaid() - Method in class bb.common.ARPrepayAllStatementsListResult

getAmountPaid() - Method in class bb.common.CustomerPrepayStatementListResult

getAmountPaid() - Method in class bb.common.CustomerStatementListResult

getAmountPaid() - Method in class bb.common.SalesTaxListResult

getAmountPaid() - Method in class bb.common.VendorPrepayStatementListResult

getAmountPaid() - Method in class bb.common.VendorStatementListResult

getAnalysis() - Method in class bb.common.CustomerServiceIncidentItemVO

getAnnualDepreciationRate() - Method in class bb.common.AssetVO

getAnswerCn() - Method in class bb.common.FeedbackAnswerVO

getAnswerEn() - Method in class bb.common.FeedbackAnswerVO

getAnswerItem() - Method in class bb.common.FeedbackAnswerPK

getAnswerItem() - Method in class bb.common.FeedbackItemVO

getAnswerList(String, String) - Method in interface bb.common.box.CustomerServiceBox

getAnswers() - Method in class bb.common.FeedbackQuestionVO

getAp() - Method in class bb.common.CashFlowByMonthReportResult

getAp() - Method in class bb.common.TwelveMonthCashFlowReportResult

getAPAccountInfoCount(String) - Method in interface bb.common.box.AccountingBox

getAPAgingTotalResultCount(String[], String[], boolean, Date) - Method in interface bb.common.box.AccountingBox

getApAmount() - Method in class bb.common.AddressAccountInfo

getAPAuditListResults(ArrayList<String>, String) - Method in interface bb.common.box.AccountingBox

getApBatch() - Method in class bb.common.AccountingSettingsVO

getApByDateCount(String, String, String, String, String, String, String, String, Date, Date, String) - Method in interface bb.common.box.AccountingBox

getApByDateCount(String, String, String, String, String, String, String, String, String, Date, Date) - Method in interface bb.common.box.AccountingBox

getApCheckRunCountByDate(Date, Date, String, String, String, String, String) - Method in interface bb.common.box.AccountingBox

getAPCheckRunsCountByCheckRunNumberLike(String) - Method in interface bb.common.box.AccountingBox

getAPCount(String, String, String, String, String, String, Date, Date) - Method in interface bb.common.box.AccountingBox

getAPCountByAddressIdSet(String[], String[], String, String, Date, Date) - Method in interface bb.common.box.AccountingBox

getAPCountByAddressIdSet(String[], String[], boolean, Date) - Method in interface bb.common.box.AccountingBox

getAPCurrentBalance() - Method in class bb.common.CustomerVendorAddressTotalInfo

getApDate() - Method in class bb.common.AccountsPayableInfoVO

getApDate() - Method in class bb.common.AccountsPayableVO

getApDigits() - Method in class bb.common.CompanyVO

getApDisc() - Method in class bb.common.PfReceiverItemVO

getApDisc() - Method in class bb.common.PfReceiverVO

getApDisc() - Method in class bb.common.ReturnToVendorItemVO

getApDisc() - Method in class bb.common.ReturnToVendorVO

getApDisc() - Method in class bb.common.RtvShipperItemVO

getApDiscount() - Method in class bb.common.AccountsPayableInfoVO

getApDiscount() - Method in class bb.common.AccountsPayableItemVO

getApDiscount() - Method in class bb.common.AccountsPayableVO

getApDiscount() - Method in class bb.common.CustomerReturnToVendorItemVO

getApDiscount() - Method in class bb.common.OnloanReceiverItemVO

getApDiscount() - Method in class bb.common.ReceiverItemVO

getApDiscount() - Method in class bb.common.RequestForQuoteItemVO

getApDiscount() - Method in class bb.common.RequestForQuoteVO

getApDiscount() - Method in class bb.common.RequestForRMAItemVO

getApDiscount() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getApDiscount() - Method in class bb.common.RtvShipperInfoVO

getApDiscount() - Method in class bb.common.RtvShipperVO

getApDiscountAccount() - Method in class bb.common.AccountingSettingsVO

getApDiscountMethod() - Method in class bb.common.AccountingSettingsVO

getApDue() - Method in class bb.common.APAuditListResult

getApDueDays() - Method in class bb.common.PaymentHistoryVO

getApDueItems() - Method in class bb.common.AccountInfoCenterResult

getAPDueTotal(String) - Method in interface bb.common.box.AccountingBox

getApEndBalance() - Method in class bb.common.AddressAccountInfo

getApFreight() - Method in class bb.common.AccountsPayableInfoVO

getApFreight() - Method in class bb.common.AccountsPayableVO

getApFreight() - Method in class bb.common.APAuditListResult

getApFreight() - Method in class bb.common.PfReceiverVO

getApFreight() - Method in class bb.common.RtvShipperInfoVO

getApFreight() - Method in class bb.common.RtvShipperVO

getApGl1Recorded() - Method in class bb.common.AccountsPayableInfoVO

getApGl1Recorded() - Method in class bb.common.AccountsPayableVO

getApGl1Recorded() - Method in class bb.common.CustomerReturnToVendorVO

getApGl1Recorded() - Method in class bb.common.OnloanReceiverVO

getApGl1Recorded() - Method in class bb.common.PurchaseOrderVO

getApGl1Recorded() - Method in class bb.common.ReceiverInfoVO

getApGl1Recorded() - Method in class bb.common.ReceiverVO

getApGl1Recorded() - Method in class bb.common.RequestForRMAVO

getApGl1Recorded() - Method in class bb.common.ReturnMaterialAuthorizationVO

getApGl1Recorded() - Method in class bb.common.ReturnToVendorVO

getApGl1Recorded() - Method in class bb.common.RtvShipperInfoVO

getApGl1Recorded() - Method in class bb.common.RtvShipperVO

getApGl2Paid() - Method in class bb.common.AccountsPayableInfoVO

getApGl2Paid() - Method in class bb.common.AccountsPayableVO

getApGl2Paid() - Method in class bb.common.CustomerReturnToVendorVO

getApGl2Paid() - Method in class bb.common.OnloanReceiverVO

getApGl2Paid() - Method in class bb.common.PurchaseOrderVO

getApGl2Paid() - Method in class bb.common.ReceiverInfoVO

getApGl2Paid() - Method in class bb.common.ReceiverVO

getApGl2Paid() - Method in class bb.common.RequestForRMAVO

getApGl2Paid() - Method in class bb.common.ReturnMaterialAuthorizationVO

getApGl2Paid() - Method in class bb.common.ReturnToVendorVO

getApGl2Paid() - Method in class bb.common.RtvShipperInfoVO

getApGl2Paid() - Method in class bb.common.RtvShipperVO

getApGLDate() - Method in class bb.common.AccountsPayableVO

getAPGLDate() - Method in class bb.common.AddPayableWithoutReceiverAgent

getApGLDate() - Method in class bb.common.MakeAccountPayableAgent

getApItemNumber() - Method in class bb.common.AccountsPayableItemPK

getApItemNumber() - Method in class bb.common.APItemListResult

getApItemNumber() - Method in class bb.common.POReceiverItemListResult

getAPItemsCountByApNumber(String) - Method in interface bb.common.box.AccountingBox

getApItemStatus() - Method in class bb.common.POReceiverItemListResult

getApNet() - Method in class bb.common.AccountPayableInfoWithPrepayResult

getApNet() - Method in class bb.common.AccountsPayableInfoVO

getApNet() - Method in class bb.common.AccountsPayableItemVO

getApNet() - Method in class bb.common.AccountsPayableVO

getApNet() - Method in class bb.common.APAuditListResult

getApNet() - Method in class bb.common.PfReceiverItemVO

getApNet() - Method in class bb.common.PfReceiverVO

getApNet() - Method in class bb.common.PoMessageItemVO

getApNet() - Method in class bb.common.PoMessageVO

getApNet() - Method in class bb.common.PurchaseOrderItemVO

getApNet() - Method in class bb.common.PurchaseOrderVO

getApNet() - Method in class bb.common.RequestForQuoteVO

getApNet() - Method in class bb.common.ReturnToVendorByDateListResult

getApNet() - Method in class bb.common.ReturnToVendorItemVO

getApNet() - Method in class bb.common.ReturnToVendorVO

getApNet() - Method in class bb.common.RtvShipperInfoVO

getApNet() - Method in class bb.common.RtvShipperItemVO

getApNet() - Method in class bb.common.RtvShipperVO

getApNetSet() - Method in class bb.common.AccountsPayableInfoVO

getApNetSet() - Method in class bb.common.AccountsPayableVO

getApNetSet() - Method in class bb.common.CustomerReturnToVendorVO

getApNetSet() - Method in class bb.common.OnloanReceiverVO

getApNetSet() - Method in class bb.common.PurchaseOrderVO

getApNetSet() - Method in class bb.common.ReceiverVO

getApNetSet() - Method in class bb.common.RequestForRMAVO

getApNetSet() - Method in class bb.common.ReturnMaterialAuthorizationVO

getApNetSet() - Method in class bb.common.ReturnToVendorVO

getApNetSet() - Method in class bb.common.RtvShipperInfoVO

getApNetSet() - Method in class bb.common.RtvShipperVO

getApNumber() - Method in class bb.common.AccountPayableInfoWithPrepayResult

getApNumber() - Method in class bb.common.AccountsPayableInfoVO

getApNumber() - Method in class bb.common.AccountsPayableItemManufacturerPK

getApNumber() - Method in class bb.common.AccountsPayableItemPK

getApNumber() - Method in class bb.common.AccountsPayableVO

getApNumber() - Method in class bb.common.APAuditListResult

getApNumber() - Method in class bb.common.ApCheckRunItemAgent

getApNumber() - Method in class bb.common.ApCheckRunListResult

getApNumber() - Method in class bb.common.APItemListResult

getApNumber() - Method in class bb.common.ExpenseVO

getApNumber() - Method in class bb.common.GeneralLedgerByDateListResult

getApNumber() - Method in class bb.common.MakeCheckAgent

getApNumber() - Method in class bb.common.PayableCheckRunItemPK

getApNumber() - Method in class bb.common.PfReceiverItemVO

getApNumber() - Method in class bb.common.POReceiverItemListResult

getApNumber() - Method in class bb.common.RtvShipperInfoVO

getApNumber() - Method in class bb.common.RtvShipperItemListResult

getApNumber() - Method in class bb.common.RtvShipperListResult

getApNumber() - Method in class bb.common.RtvShipperVO

getApNumber() - Method in class bb.common.VendorStatementListResult

getAPNumbers(AccountAuditAgent) - Method in interface bb.common.box.AccountingBox

getApOpen() - Method in class bb.common.AccountsPayableInfoVO

getApOpen() - Method in class bb.common.AccountsPayableItemVO

getApOpen() - Method in class bb.common.AccountsPayableVO

getApOpen() - Method in class bb.common.CustomerReturnToVendorItemVO

getApOpen() - Method in class bb.common.CustomerReturnToVendorVO

getApOpen() - Method in class bb.common.OnloanReceiverItemVO

getApOpen() - Method in class bb.common.OnloanReceiverVO

getApOpen() - Method in class bb.common.PfReceiverItemVO

getApOpen() - Method in class bb.common.PfReceiverVO

getApOpen() - Method in class bb.common.PoMessageItemVO

getApOpen() - Method in class bb.common.PoMessageVO

getApOpen() - Method in class bb.common.PurchaseOrderItemListResult

getApOpen() - Method in class bb.common.PurchaseOrderItemVO

getApOpen() - Method in class bb.common.PurchaseOrderVO

getApOpen() - Method in class bb.common.ReceiverInfoVO

getApOpen() - Method in class bb.common.ReceiverItemVO

getApOpen() - Method in class bb.common.ReceiverVO

getApOpen() - Method in class bb.common.RequestForQuoteItemVO

getApOpen() - Method in class bb.common.RequestForQuoteVO

getApOpen() - Method in class bb.common.RequestForRMAItemVO

getApOpen() - Method in class bb.common.RequestForRMAVO

getApOpen() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getApOpen() - Method in class bb.common.ReturnMaterialAuthorizationVO

getApOpen() - Method in class bb.common.ReturnToVendorItemVO

getApOpen() - Method in class bb.common.ReturnToVendorVO

getApOpen() - Method in class bb.common.RtvShipperInfoVO

getApOpen() - Method in class bb.common.RtvShipperItemVO

getApOpen() - Method in class bb.common.RtvShipperVO

getAPOpenByVendorIdTotal(String) - Method in interface bb.common.box.AccountingBox

getApOpenItems() - Method in class bb.common.AccountInfoCenterResult

getApOrdmApprovedBy() - Method in class bb.common.AccountingConfigurationVO

getApOriginalAmount() - Method in class bb.common.AddressAccountInfo

getApPaid() - Method in class bb.common.APAuditListResult

getApPaid() - Method in class bb.common.PaymentHistoryVO

getApPaidGl() - Method in class bb.common.AccountsPayableInfoVO

getApPaidGl() - Method in class bb.common.AccountsPayableVO

getApPaidGl() - Method in class bb.common.CustomerReturnToVendorVO

getApPaidGl() - Method in class bb.common.OnloanReceiverVO

getApPaidGl() - Method in class bb.common.PurchaseOrderVO

getApPaidGl() - Method in class bb.common.ReceiverInfoVO

getApPaidGl() - Method in class bb.common.ReceiverVO

getApPaidGl() - Method in class bb.common.RequestForRMAVO

getApPaidGl() - Method in class bb.common.ReturnMaterialAuthorizationVO

getApPaidGl() - Method in class bb.common.ReturnToVendorVO

getApPaidGl() - Method in class bb.common.RtvShipperInfoVO

getApPaidGl() - Method in class bb.common.RtvShipperVO

getApPaidInv() - Method in class bb.common.RtvShipperInfoVO

getApPaidInv() - Method in class bb.common.RtvShipperVO

getApPaidRcv() - Method in class bb.common.AccountsPayableInfoVO

getApPaidRcv() - Method in class bb.common.AccountsPayableVO

getApPaidRcv() - Method in class bb.common.ReturnToVendorVO

getApPaidReceived() - Method in class bb.common.CustomerReturnToVendorVO

getApPaidReceived() - Method in class bb.common.OnloanReceiverVO

getApPaidReceived() - Method in class bb.common.PurchaseOrderVO

getApPaidReceived() - Method in class bb.common.ReceiverInfoVO

getApPaidReceived() - Method in class bb.common.ReceiverVO

getApPaidReceived() - Method in class bb.common.RequestForRMAVO

getApPaidReceived() - Method in class bb.common.ReturnMaterialAuthorizationVO

getAppAmount() - Method in class bb.common.AddressAccountInfo

getAPPaseDueBalance() - Method in class bb.common.CustomerVendorAddressTotalInfo

getApPastDue() - Method in class bb.common.CashFlowByMonthReportResult

getAPPaymentDue() - Method in class bb.common.CustomerVendorAddressTotalInfo

getAPPaymentDueDays() - Method in class bb.common.CustomerVendorAddressTotalInfo

getAppColumnByTableNameAndColumnName(String, String) - Method in interface bb.common.box.CompanyBox

getAppDataCountBySql(String, HashMap) - Method in interface bb.common.box.CompanyBox

getAppDate() - Method in class bb.common.ApPrepayVO

getAppEndBalance() - Method in class bb.common.AddressAccountInfo

getAppiPk() - Method in class bb.common.ApPrepaymentCheckRunItemAgent

getAppiPk() - Method in class bb.common.PrepaymentWireTransferAgent

getAppiPrepay() - Method in class bb.common.APPrepayInfoResult

getAppiPrepay() - Method in class bb.common.ApPrepayItemVO

getAppiPrepayDue() - Method in class bb.common.APPrepayInfoResult

getAppiPrepayDue() - Method in class bb.common.ApPrepayItemVO

getAppiPrepayGl() - Method in class bb.common.APPrepayInfoResult

getAppiPrepayGl() - Method in class bb.common.ApPrepayItemVO

getAppItem() - Method in class bb.common.MakeCheckAgent

getAppItemNumber() - Method in class bb.common.GeneralLedgerVO

getApplyBy() - Method in class bb.common.OrderApprovalVO

getApplyDate() - Method in class bb.common.OrderApprovalVO

getAppNumber() - Method in class bb.common.AccountPayableInfoWithPrepayResult

getAppNumber() - Method in class bb.common.GeneralLedgerVO

getAppNumber() - Method in class bb.common.MakePrepaymentCheckAgent

getAppNumber() - Method in class bb.common.PurchaseOrderVO

getAppOriginalAmount() - Method in class bb.common.AddressAccountInfo

getAppProperty(String) - Method in interface bb.common.box.CompanyBox

getApPrefix() - Method in class bb.common.CompanyVO

getApPrepay() - Method in class bb.common.AccountPayableInfoWithPrepayResult

getApPrepay() - Method in class bb.common.ApPrepayVO

getApPrepay() - Method in class bb.common.CashFlowByMonthReportResult

getApPrepay() - Method in class bb.common.PurchaseOrderListResult

getApPrepay() - Method in class bb.common.PurchaseOrderVO

getApPrepayApply() - Method in class bb.common.AccountPayableInfoWithPrepayResult

getApPrepayApply() - Method in class bb.common.ApPrepayVO

getApPrepayApply() - Method in class bb.common.PurchaseOrderVO

getApPrepayApplys() - Method in class bb.common.GeneralLedgerVO

getApPrepayByPK(String) - Method in interface bb.common.box.AccountingBox

getApPrepayCount(String, String, String, Date, Date) - Method in interface bb.common.box.AccountingBox

getApPrepayDigits() - Method in class bb.common.CompanyVO

getApPrepayDue() - Method in class bb.common.AccountPayableInfoWithPrepayResult

getApPrepayDue() - Method in class bb.common.ApPrepayVO

getApPrepayDue() - Method in class bb.common.PurchaseOrderVO

getApPrepayGl() - Method in class bb.common.AccountPayableInfoWithPrepayResult

getApPrepayGl() - Method in class bb.common.ApPrepayVO

getApPrepayGl() - Method in class bb.common.PurchaseOrderListResult

getApPrepayGl() - Method in class bb.common.PurchaseOrderVO

getApPrepayItem() - Method in class bb.common.ApPrepayVO

getApPrepayItemNumber() - Method in class bb.common.ApPrepayItemPK

getApPrepayNumber() - Method in class bb.common.ApPrepayItemPK

getApPrepayNumber() - Method in class bb.common.ApPrepayVO

getApPrepayPastDue() - Method in class bb.common.CashFlowByMonthReportResult

getApPrepayPrefix() - Method in class bb.common.CompanyVO

getApprovableType() - Method in class bb.common.NcrApprovalPK

getApprovalBy() - Method in class bb.common.ScrapReportVO

getApprovalDate() - Method in class bb.common.ScrapReportVO

getApprovalLimit() - Method in class bb.common.DisassembleWorkOrderApprovalVO

getApprovalLimit() - Method in class bb.common.RTVApprovalVO

getApprovalLimit() - Method in class bb.common.WorkOrderApprovalVO

getApprovalStatus() - Method in class bb.common.GeneralLedgerVO

getApprovalStatus() - Method in class bb.common.GLApprovalListResult

getApproved() - Method in class bb.common.DisassembleWorkOrderVO

getApproved() - Method in class bb.common.EngineeringChangeRequestVO

getApproved() - Method in class bb.common.EngineeringChangeVO

getApproved() - Method in class bb.common.SGCustomerServiceRequestVO

getApproved() - Method in class bb.common.WorkInstructionListResult

getApproved() - Method in class bb.common.WorkInstructionVO

getApproved() - Method in class bb.common.WorkOrderVO

getApproved() - Method in class bb.common.WorkOrderWorkInstructionVO

getApproveDate() - Method in class bb.common.ExpenseVO

getApproveDate() - Method in class bb.common.TransferOrderListResult

getApproveDate() - Method in class bb.common.TransferOrderVO

getApprovedBy() - Method in class bb.common.BillVO

getApprovedBy() - Method in class bb.common.BillWithPartInfoResult

getApprovedBy() - Method in class bb.common.CorrectiveActionRequestVO

getApprovedBy() - Method in class bb.common.CustomerReturnToVendorVO

getApprovedBy() - Method in class bb.common.DisassembleWorkOrderReceivingResult

getApprovedBy() - Method in class bb.common.DisassembleWorkOrderVO

getApprovedBy() - Method in class bb.common.ExpenseVO

getApprovedBy() - Method in class bb.common.GeneralLedgerPrintResult

getApprovedBy() - Method in class bb.common.GeneralLedgerVO

getApprovedBy() - Method in class bb.common.GLApprovalListResult

getApprovedBy() - Method in class bb.common.GLAutoApproveVO

getApprovedBy() - Method in class bb.common.IssuingResult

getApprovedBy() - Method in class bb.common.NonproductivePickingItemResult

getApprovedBy() - Method in class bb.common.NonproductivePickingVO

getApprovedBy() - Method in class bb.common.OrderApprovalVO

getApprovedBy() - Method in class bb.common.PreventiveActionRequestVO

getApprovedBy() - Method in class bb.common.PurchaseOrderVO

getApprovedBy() - Method in class bb.common.RequestForQuoteVO

getApprovedBy() - Method in class bb.common.RequestForRMAVO

getApprovedBy() - Method in class bb.common.ReturnMaterialAuthorizationVO

getApprovedBy() - Method in class bb.common.ReturnToVendorVO

getApprovedBy() - Method in class bb.common.SGCustomerServiceRequestVO

getApprovedBy() - Method in class bb.common.SwapOrderListResult

getApprovedBy() - Method in class bb.common.SwapOrderVO

getApprovedBy() - Method in class bb.common.TransferOrderListResult

getApprovedBy() - Method in class bb.common.TransferOrderVO

getApprovedBy() - Method in class bb.common.WorkInstructionListResult

getApprovedBy() - Method in class bb.common.WorkInstructionRequestForChangeVO

getApprovedBy() - Method in class bb.common.WorkInstructionVO

getApprovedBy() - Method in class bb.common.WorkOrderVO

getApprovedBy() - Method in class bb.common.WorkOrderWorkInstructionVO

getApprovedDate() - Method in class bb.common.BillVO

getApprovedDate() - Method in class bb.common.BillWithPartInfoResult

getApprovedDate() - Method in class bb.common.DisassembleWorkOrderReceivingResult

getApprovedDate() - Method in class bb.common.EngineeringChangeRequestVO

getApprovedDate() - Method in class bb.common.EngineeringChangeVO

getApprovedDate() - Method in class bb.common.GeneralLedgerVO

getApprovedDate() - Method in class bb.common.IssuingResult

getApprovedDate() - Method in class bb.common.NonproductivePickingItemResult

getApprovedDate() - Method in class bb.common.NonproductivePickingVO

getApprovedDate() - Method in class bb.common.OrderApprovalVO

getApprovedDate() - Method in class bb.common.PurchaseOrderVO

getApprovedDate() - Method in class bb.common.RequestForQuoteVO

getApprovedDate() - Method in class bb.common.ReturnToVendorVO

getApprovedDate() - Method in class bb.common.SwapOrderListResult

getApprovedDate() - Method in class bb.common.SwapOrderVO

getApprovedDate() - Method in class bb.common.WorkInstructionRequestForChangeVO

getApprovedErrorList() - Method in class bb.common.ApprovedGLResult

getApprovedGLList() - Method in class bb.common.ApprovedGLResult

getApprovedOpinionEng() - Method in class bb.common.NcrReportListResult

getApprovedOpinionEng() - Method in class bb.common.NonConformanceReportVO

getApprovedOpinionMfg() - Method in class bb.common.NcrReportListResult

getApprovedOpinionMfg() - Method in class bb.common.NonConformanceReportVO

getApprovedOpinionQa() - Method in class bb.common.NcrReportListResult

getApprovedOpinionQa() - Method in class bb.common.NonConformanceReportVO

getApprovedTime() - Method in class bb.common.CustomerReturnToVendorVO

getApprovedTime() - Method in class bb.common.RequestForRMAVO

getApprovedTime() - Method in class bb.common.ReturnMaterialAuthorizationVO

getApproveLimit() - Method in class bb.common.GeneralLedgerApprovalVO

getApproveLimit() - Method in class bb.common.PurchaseOrderApprovalVO

getApproveSuccessGL() - Method in class bb.common.ApprovedGLResult

getApproveSuccessGLList() - Method in class bb.common.ApprovedGLResult

getAppStartBalance() - Method in class bb.common.AddressAccountInfo

getAPPurchaseOrder12Months() - Method in class bb.common.CustomerVendorAddressTotalInfo

getApRcvd() - Method in class bb.common.ReturnToVendorItemVO

getApRcvd() - Method in class bb.common.ReturnToVendorVO

getApReceivd() - Method in class bb.common.CustomerReturnToVendorItemVO

getApReceivd() - Method in class bb.common.RequestForRMAItemVO

getApReceivd() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getApReceived() - Method in class bb.common.AccountsPayableItemVO

getApReceived() - Method in class bb.common.CustomerReturnToVendorVO

getApReceived() - Method in class bb.common.OnloanReceiverItemVO

getApReceived() - Method in class bb.common.OnloanReceiverVO

getApReceived() - Method in class bb.common.PfReceiverItemVO

getApReceived() - Method in class bb.common.PfReceiverVO

getApReceived() - Method in class bb.common.PoMessageItemVO

getApReceived() - Method in class bb.common.PoMessageVO

getApReceived() - Method in class bb.common.PurchaseOrderItemListResult

getApReceived() - Method in class bb.common.PurchaseOrderItemVO

getApReceived() - Method in class bb.common.PurchaseOrderVO

getApReceived() - Method in class bb.common.ReceiverInfoVO

getApReceived() - Method in class bb.common.ReceiverItemVO

getApReceived() - Method in class bb.common.ReceiverVO

getApReceived() - Method in class bb.common.RequestForQuoteItemVO

getApReceived() - Method in class bb.common.RequestForQuoteVO

getApReceived() - Method in class bb.common.RequestForRMAVO

getApReceived() - Method in class bb.common.ReturnMaterialAuthorizationVO

getApRecieved() - Method in class bb.common.AccountsPayableInfoVO

getApRecieved() - Method in class bb.common.AccountsPayableVO

getAPsByAddressIdAndStatus(String, String) - Method in interface bb.common.box.AccountingBox

getAPsByVendorIdCount(String) - Method in interface bb.common.box.AccountingBox

getAPsCountByApNumber(String) - Method in interface bb.common.box.AccountingBox

getAPsCountByVendorInvoice(String) - Method in interface bb.common.box.AccountingBox

getApShip() - Method in class bb.common.RtvShipperInfoVO

getApShip() - Method in class bb.common.RtvShipperItemVO

getApShip() - Method in class bb.common.RtvShipperVO

getApStartBalance() - Method in class bb.common.AddressAccountInfo

getApStatus() - Method in class bb.common.AccountPayableCheckRunItemVO

getApSub() - Method in class bb.common.AccountsPayableInfoVO

getApSub() - Method in class bb.common.AccountsPayableItemVO

getApSub() - Method in class bb.common.AccountsPayableVO

getApSub() - Method in class bb.common.CustomerReturnToVendorItemVO

getApSub() - Method in class bb.common.CustomerReturnToVendorVO

getApSub() - Method in class bb.common.OnloanReceiverItemVO

getApSub() - Method in class bb.common.OnloanReceiverVO

getApSub() - Method in class bb.common.PfReceiverItemVO

getApSub() - Method in class bb.common.PfReceiverVO

getApSub() - Method in class bb.common.ReceiverInfoVO

getApSub() - Method in class bb.common.ReceiverItemVO

getApSub() - Method in class bb.common.ReceiverVO

getApSub() - Method in class bb.common.RequestForQuoteItemVO

getApSub() - Method in class bb.common.RequestForRMAItemVO

getApSub() - Method in class bb.common.RequestForRMAVO

getApSub() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getApSub() - Method in class bb.common.ReturnMaterialAuthorizationVO

getApSub() - Method in class bb.common.ReturnToVendorItemVO

getApSub() - Method in class bb.common.RtvShipperInfoVO

getApSub() - Method in class bb.common.RtvShipperItemVO

getApSub() - Method in class bb.common.RtvShipperVO

getApTax() - Method in class bb.common.AccountsPayableInfoVO

getApTax() - Method in class bb.common.AccountsPayableItemVO

getApTax() - Method in class bb.common.AccountsPayableVO

getApTax() - Method in class bb.common.APAuditListResult

getApTax() - Method in class bb.common.CustomerReturnToVendorItemVO

getApTax() - Method in class bb.common.OnloanReceiverItemVO

getApTax() - Method in class bb.common.PfReceiverItemVO

getApTax() - Method in class bb.common.PfReceiverVO

getApTax() - Method in class bb.common.ReceiverItemVO

getApTax() - Method in class bb.common.RequestForQuoteItemVO

getApTax() - Method in class bb.common.RequestForRMAItemVO

getApTax() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getApTax() - Method in class bb.common.ReturnToVendorItemVO

getApTax() - Method in class bb.common.RtvShipperInfoVO

getApTax() - Method in class bb.common.RtvShipperItemVO

getApTax() - Method in class bb.common.RtvShipperVO

getApTaxSet() - Method in class bb.common.AccountsPayableInfoVO

getApTaxSet() - Method in class bb.common.AccountsPayableVO

getApTaxSet() - Method in class bb.common.CustomerReturnToVendorVO

getApTaxSet() - Method in class bb.common.OnloanReceiverVO

getApTaxSet() - Method in class bb.common.PurchaseOrderVO

getApTaxSet() - Method in class bb.common.ReceiverVO

getApTaxSet() - Method in class bb.common.RequestForRMAVO

getApTaxSet() - Method in class bb.common.ReturnMaterialAuthorizationVO

getApTaxSet() - Method in class bb.common.ReturnToVendorVO

getApTaxSet() - Method in class bb.common.RtvShipperInfoVO

getApTaxSet() - Method in class bb.common.RtvShipperVO

getApTotal() - Method in class bb.common.AccountPayableCheckRunItemVO

getApTotal() - Method in class bb.common.AccountsPayableInfoVO

getApTotal() - Method in class bb.common.AccountsPayableItemVO

getApTotal() - Method in class bb.common.AccountsPayableVO

getApTotal() - Method in class bb.common.APAuditListResult

getAPTotal(String, String, String, String, String, String, Date, Date) - Method in interface bb.common.box.AccountingBox

getApTotal() - Method in class bb.common.CheckRunItemTotalResult

getApTotal() - Method in class bb.common.CustomerReturnToVendorItemVO

getApTotal() - Method in class bb.common.OnloanReceiverItemVO

getApTotal() - Method in class bb.common.PfReceiverItemVO

getApTotal() - Method in class bb.common.PfReceiverVO

getApTotal() - Method in class bb.common.PoMessageItemVO

getApTotal() - Method in class bb.common.PurchaseOrderCheckListResult

getApTotal() - Method in class bb.common.PurchaseOrderItemVO

getApTotal() - Method in class bb.common.ReceiverItemVO

getApTotal() - Method in class bb.common.RequestForQuoteCheckListResult

getApTotal() - Method in class bb.common.RequestForQuoteItemVO

getApTotal() - Method in class bb.common.RequestForRMAItemVO

getApTotal() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getApTotal() - Method in class bb.common.ReturnToVendorCheckListResult

getApTotal() - Method in class bb.common.ReturnToVendorItemVO

getApTotal() - Method in class bb.common.RtvShipperInfoVO

getApTotal() - Method in class bb.common.RtvShipperItemVO

getApTotal() - Method in class bb.common.RtvShipperVO

getApTotal() - Method in class bb.common.WorkOrderCheckListResult

getAr() - Method in class bb.common.CashFlowByMonthReportResult

getAr() - Method in class bb.common.ProformaInvoiceItemVO

getAr() - Method in class bb.common.TwelveMonthCashFlowReportResult

getARAccountInfoCount(String) - Method in interface bb.common.box.AccountingBox

getArAging() - Method in class bb.common.CustomerStatementResult

getArAmount() - Method in class bb.common.AddressAccountInfo

getArAmountPaid() - Method in class bb.common.AllStatementsListResult

getArApDate() - Method in class bb.common.TempArApAgingVO

getArApNumber() - Method in class bb.common.PaymentAgent

getArApNumber() - Method in class bb.common.TempArApAgingVO

getArApNumber() - Method in class bb.common.WireTransferAgent

getArApTotal() - Method in class bb.common.TempArApAgingVO

getARAuditListResults(ArrayList<String>, String) - Method in interface bb.common.box.AccountingBox

getArBalenceDue() - Method in class bb.common.AllStatementsListResult

getArBoilerplate() - Method in class bb.common.ARBoilerplateVO

getArBPByPk(String) - Method in interface bb.common.box.AccountingBox

getArBPCountByBPId(String) - Method in interface bb.common.box.AccountingBox

getArCommissionCountByDate(String, String, String, Date, Date) - Method in interface bb.common.box.AccountingBox

getArCommissionTotalAmountByDate(String, String, String, Date, Date) - Method in interface bb.common.box.AccountingBox

getARCountByAddressIdSet(String[], String[], String, String, Date, Date) - Method in interface bb.common.box.AccountingBox

getARCountByAddressIdSet(String[], String[], boolean, Date) - Method in interface bb.common.box.AccountingBox

getArCurrency() - Method in class bb.common.AllStatementsListResult

getARCurrentBalance() - Method in class bb.common.CustomerVendorAddressTotalInfo

getArDigits() - Method in class bb.common.CompanyVO

getArDisc() - Method in class bb.common.AccountsReceivableItemVO

getArDisc() - Method in class bb.common.OnLoanItemVO

getArDisc() - Method in class bb.common.OnLoanVO

getArDisc() - Method in class bb.common.ProformaInvoiceItemVO

getArDisc() - Method in class bb.common.ProformaInvoiceVO

getArDiscount() - Method in class bb.common.OnloanShipperItemVO

getArDiscount() - Method in class bb.common.OnloanShipperVO

getArDiscount() - Method in class bb.common.ShipperInfoVO

getArDiscount() - Method in class bb.common.ShipperItemVO

getArDiscount() - Method in class bb.common.ShipperVO

getArDiscountAccount() - Method in class bb.common.AccountingSettingsVO

getArDiscountMethod() - Method in class bb.common.AccountingSettingsVO

getArDue() - Method in class bb.common.ARAuditListResult

getArDueDays() - Method in class bb.common.PaymentHistoryVO

getArDueItems() - Method in class bb.common.AccountInfoCenterResult

getArEndBalance() - Method in class bb.common.AddressAccountInfo

getArFreight() - Method in class bb.common.ARAuditListResult

getArFreight() - Method in class bb.common.MakeCreditMemoAgent

getArFreight() - Method in class bb.common.OnloanShipperVO

getArFreight() - Method in class bb.common.OnLoanVO

getArFreight() - Method in class bb.common.ProformaInvoiceVO

getArFreight() - Method in class bb.common.ShipperAgent

getArFreight() - Method in class bb.common.ShipperInfoVO

getArFreight() - Method in class bb.common.ShipperVO

getArFreight() - Method in class bb.common.TransferReceiverListResult

getArFreight() - Method in class bb.common.TransferReceiverVO

getArFreight() - Method in class bb.common.TransferShipperListResult

getArFreight() - Method in class bb.common.TransferShipperVO

getArGl1Recorded() - Method in class bb.common.AccountsReceivableInfoVO

getArGl1Recorded() - Method in class bb.common.AccountsReceivableVO

getArGl1Recorded() - Method in class bb.common.OnloanShipperVO

getArGl1Recorded() - Method in class bb.common.OnLoanVO

getArGl1Recorded() - Method in class bb.common.ProformaInvoiceVO

getArGl1Recorded() - Method in class bb.common.SalesOrderVO

getArGl1Recorded() - Method in class bb.common.ShipperInfoVO

getArGl1Recorded() - Method in class bb.common.ShipperVO

getArGl2Paid() - Method in class bb.common.AccountsReceivableInfoVO

getArGl2Paid() - Method in class bb.common.AccountsReceivableVO

getArGl2Paid() - Method in class bb.common.OnloanShipperVO

getArGl2Paid() - Method in class bb.common.OnLoanVO

getArGl2Paid() - Method in class bb.common.ProformaInvoiceVO

getArGl2Paid() - Method in class bb.common.SalesOrderVO

getArGl2Paid() - Method in class bb.common.ShipperInfoVO

getArGl2Paid() - Method in class bb.common.ShipperVO

getArInvoiceNumber() - Method in class bb.common.OnloanShipperVO

getArInvoiceNumber() - Method in class bb.common.SalesOrderItemVO

getArInvoiceNumber() - Method in class bb.common.ShipperInfoVO

getArInvoiceNumber() - Method in class bb.common.ShipperItemListResult

getArInvoiceNumber() - Method in class bb.common.ShipperVO

getARItemCountByPartAndDate(Date, Date, BB2Part) - Method in interface bb.common.box.AccountingBox

getARItemsCountByInvoiceNumber(String) - Method in interface bb.common.box.AccountingBox

getARItemsCountByPartNumber(String) - Method in interface bb.common.box.AccountingBox

getArNet() - Method in class bb.common.AccountsReceivableItemVO

getArNet() - Method in class bb.common.ARAuditListResult

getArNet() - Method in class bb.common.MakeCreditMemoAgent

getArNet() - Method in class bb.common.OnLoanItemVO

getArNet() - Method in class bb.common.OnloanShipperItemVO

getArNet() - Method in class bb.common.OnloanShipperVO

getArNet() - Method in class bb.common.OnLoanVO

getArNet() - Method in class bb.common.ProformaInvoiceItemVO

getArNet() - Method in class bb.common.ProformaInvoiceVO

getArNet() - Method in class bb.common.ShipperInfoVO

getArNet() - Method in class bb.common.ShipperItemVO

getArNet() - Method in class bb.common.ShipperVO

getArNetSet() - Method in class bb.common.AccountsReceivableInfoVO

getArNetSet() - Method in class bb.common.AccountsReceivableVO

getArNetSet() - Method in class bb.common.OnloanShipperVO

getArNetSet() - Method in class bb.common.OnLoanVO

getArNetSet() - Method in class bb.common.QuoteVO

getArNetSet() - Method in class bb.common.SalesOrderVO

getArNetSet() - Method in class bb.common.ShipperVO

getArNumber() - Method in class bb.common.ARAuditListResult

getArNumber() - Method in class bb.common.ArPaymentRunItemAgent

getArNumber() - Method in class bb.common.ARPaymentRunItemPK

getArNumber() - Method in class bb.common.ARPaymentRunListResult

getArNumber() - Method in class bb.common.GeneralLedgerByDateListResult

getARNumbers(AccountAuditAgent) - Method in interface bb.common.box.AccountingBox

getArOpen() - Method in class bb.common.AccountsReceivableInfoVO

getArOpen() - Method in class bb.common.AccountsReceivableItemVO

getArOpen() - Method in class bb.common.AccountsReceivableVO

getArOpen() - Method in class bb.common.OnLoanItemVO

getArOpen() - Method in class bb.common.OnloanShipperItemVO

getArOpen() - Method in class bb.common.OnloanShipperVO

getArOpen() - Method in class bb.common.OnLoanVO

getArOpen() - Method in class bb.common.ProformaInvoiceItemVO

getArOpen() - Method in class bb.common.ProformaInvoiceVO

getArOpen() - Method in class bb.common.SalesOrderVO

getArOpen() - Method in class bb.common.ShipperInfoVO

getArOpen() - Method in class bb.common.ShipperItemVO

getArOpen() - Method in class bb.common.ShipperVO

getArOpenItems() - Method in class bb.common.AccountInfoCenterResult

getArOrcmApprovedBy() - Method in class bb.common.AccountingConfigurationVO

getArOriginalAmount() - Method in class bb.common.AddressAccountInfo

getArPaid() - Method in class bb.common.ARAuditListResult

getArPaid() - Method in class bb.common.ProformaInvoiceVO

getArPaidGl() - Method in class bb.common.AccountsReceivableInfoVO

getArPaidGl() - Method in class bb.common.AccountsReceivableVO

getArPaidGl() - Method in class bb.common.OnloanShipperVO

getArPaidGl() - Method in class bb.common.OnLoanVO

getArPaidGl() - Method in class bb.common.ProformaInvoiceVO

getArPaidGl() - Method in class bb.common.SalesOrderVO

getArPaidGl() - Method in class bb.common.ShipperInfoVO

getArPaidGl() - Method in class bb.common.ShipperVO

getArPaidInv() - Method in class bb.common.OnLoanVO

getArPaidInv() - Method in class bb.common.ProformaInvoiceVO

getArPaidInvoice() - Method in class bb.common.AccountsReceivableInfoVO

getArPaidInvoice() - Method in class bb.common.AccountsReceivableVO

getArPaidInvoice() - Method in class bb.common.OnloanShipperVO

getArPaidInvoice() - Method in class bb.common.ShipperInfoVO

getArPaidInvoice() - Method in class bb.common.ShipperVO

getArpAmount() - Method in class bb.common.AddressAccountInfo

getARPaseDueBalance() - Method in class bb.common.CustomerVendorAddressTotalInfo

getArPastDue() - Method in class bb.common.CashFlowByMonthReportResult

getArPaymentByDateTotal(Date, Date, String, String, String, String) - Method in interface bb.common.box.AccountingBox

getARPaymentByPk(Long) - Method in interface bb.common.box.AccountingBox

getArPaymentCountByDate(Date, Date, String, String, String, String) - Method in interface bb.common.box.AccountingBox

getARPaymentDue() - Method in class bb.common.CustomerVendorAddressTotalInfo

getARPaymentDueDays() - Method in class bb.common.CustomerVendorAddressTotalInfo

getARPaymentRunByPk(String) - Method in interface bb.common.box.AccountingBox

getARPaymentRunsCountByPaymentNumberLike(String) - Method in interface bb.common.box.AccountingBox

getARPaymentsCountByPaymentNumberLike(String) - Method in interface bb.common.box.AccountingBox

getARPaymentsCountByPaymentRunNumber(String) - Method in interface bb.common.box.AccountingBox

getArpDate() - Method in class bb.common.ArPrepayVO

getArpEndBalance() - Method in class bb.common.AddressAccountInfo

getArpiNumber() - Method in class bb.common.ArPrepaymentRunItemAgent

getArpiPk() - Method in class bb.common.ARPrepaymentWireTransferAgent

getArpiPrepay() - Method in class bb.common.ARPrepayInfoResult

getArpiPrepay() - Method in class bb.common.ArPrepayItemVO

getArpiPrepayDue() - Method in class bb.common.ARPrepayInfoResult

getArpiPrepayDue() - Method in class bb.common.ArPrepayItemVO

getArpiPrepayGl() - Method in class bb.common.ARPrepayInfoResult

getArpiPrepayGl() - Method in class bb.common.ArPrepayItemVO

getArpItemNumber() - Method in class bb.common.GeneralLedgerVO

getArpNumber() - Method in class bb.common.AccountReceivableInfoWithPrepayResult

getArpNumber() - Method in class bb.common.GeneralLedgerVO

getArpNumber() - Method in class bb.common.SalesOrderVO

getArpOriginalAmount() - Method in class bb.common.AddressAccountInfo

getArPrefix() - Method in class bb.common.CompanyVO

getArPrepay() - Method in class bb.common.AccountReceivableInfoWithPrepayResult

getArPrepay() - Method in class bb.common.ArPrepayVO

getArPrepay() - Method in class bb.common.CashFlowByMonthReportResult

getArPrepay() - Method in class bb.common.SalesOrderListResult

getArPrepay() - Method in class bb.common.SalesOrderVO

getArPrepay() - Method in class bb.common.ShippingResult

getArPrepayApply() - Method in class bb.common.AccountReceivableInfoWithPrepayResult

getArPrepayApply() - Method in class bb.common.ArPrepayVO

getArPrepayApply() - Method in class bb.common.SalesOrderVO

getArPrepayApplys() - Method in class bb.common.GeneralLedgerVO

getArPrepayByPK(String) - Method in interface bb.common.box.AccountingBox

getArPrepayCount(String, String, String, Date, Date) - Method in interface bb.common.box.AccountingBox

getArPrepayDigits() - Method in class bb.common.CompanyVO

getArPrepayDue() - Method in class bb.common.AccountReceivableInfoWithPrepayResult

getArPrepayDue() - Method in class bb.common.ArPrepayVO

getArPrepayDue() - Method in class bb.common.SalesOrderVO

getArPrepayGl() - Method in class bb.common.AccountReceivableInfoWithPrepayResult

getArPrepayGl() - Method in class bb.common.ArPrepayVO

getArPrepayGl() - Method in class bb.common.SalesOrderListResult

getArPrepayGl() - Method in class bb.common.SalesOrderVO

getArPrepayGl() - Method in class bb.common.ShippingResult

getArPrepayItem() - Method in class bb.common.ArPrepayVO

getArPrepayItemNumber() - Method in class bb.common.ArPrepayItemPK

getArPrepayNumber() - Method in class bb.common.ArPrepayItemPK

getArPrepayNumber() - Method in class bb.common.ArPrepayVO

getArPrepayPastDue() - Method in class bb.common.CashFlowByMonthReportResult

getArPrepayPrefix() - Method in class bb.common.CompanyVO

getArpStartBalance() - Method in class bb.common.AddressAccountInfo

getArReceived() - Method in class bb.common.PaymentHistoryVO

getArrivalDate() - Method in class bb.common.BB2PartInSitItemResult

getArrivalDate() - Method in class bb.common.PfReceiverVO

getArrivalDate() - Method in class bb.common.PurchaseOrderContractResult

getArrivalStatus() - Method in class bb.common.PurchaseOrderContractResult

getArriveDate() - Method in class bb.common.NonproductivePickingItemVO

getArriveDate() - Method in class bb.common.NonproductivePickingOnDemandResult

getArriveDate() - Method in class bb.common.OrderVendorItem

getArriveDate() - Method in class bb.common.PO2POAgent

getArriveDate() - Method in class bb.common.PurchaseOrderItemListResult

getArriveDate() - Method in class bb.common.PurchaseOrderItemVO

getArriveDate() - Method in class bb.common.PurchaseOrderOnOrderResult

getArriveDate() - Method in class bb.common.SalesOrderItemListResult

getArriveDate() - Method in class bb.common.SalesOrderItemVO

getArriveDate() - Method in class bb.common.SalesOrderOnDemandResult

getArriveDate() - Method in class bb.common.SO2SOAgent

getArriveDate() - Method in class bb.common.SwapOrderItemListResult

getArriveDate() - Method in class bb.common.SwapOrderItemVO

getArriveDate() - Method in class bb.common.TransferOrderItemListResult

getArriveDate() - Method in class bb.common.TransferOrderItemVO

getArriveDate() - Method in class bb.common.WorkOrderOnDemandResult

getArriveDate() - Method in class bb.common.WorkOrderOnOrderResult

getArSalesCodeTotalCountByDate(String, String, String, Date, Date) - Method in interface bb.common.box.AccountingBox

getARSalesOrder12Months() - Method in class bb.common.CustomerVendorAddressTotalInfo

getARsByCustomerIdCount(String) - Method in interface bb.common.box.AccountingBox

getARsCountByDate(String, boolean, boolean, Date, Date, String) - Method in interface bb.common.box.AccountingBox

getARsCountByInvoiceNumber(String, String) - Method in interface bb.common.box.AccountingBox

getArShip() - Method in class bb.common.AccountsReceivableInfoVO

getArShip() - Method in class bb.common.AccountsReceivableItemVO

getArShip() - Method in class bb.common.AccountsReceivableVO

getArShip() - Method in class bb.common.OnLoanItemVO

getArShip() - Method in class bb.common.OnloanShipperItemVO

getArShip() - Method in class bb.common.OnloanShipperVO

getArShip() - Method in class bb.common.OnLoanVO

getArShip() - Method in class bb.common.ProformaInvoiceItemVO

getArShip() - Method in class bb.common.ProformaInvoiceVO

getArShip() - Method in class bb.common.SalesOrderVO

getArShip() - Method in class bb.common.ShipperInfoVO

getArShip() - Method in class bb.common.ShipperItemVO

getArShip() - Method in class bb.common.ShipperVO

getArStartBalance() - Method in class bb.common.AddressAccountInfo

getArStatus() - Method in class bb.common.ARPaymentRunItemVO

getArSub() - Method in class bb.common.AccountsReceivableItemVO

getArSub() - Method in class bb.common.OnLoanItemVO

getArSub() - Method in class bb.common.OnloanShipperItemVO

getArSub() - Method in class bb.common.OnloanShipperVO

getArSub() - Method in class bb.common.OnLoanVO

getArSub() - Method in class bb.common.ProformaInvoiceItemListResult

getArSub() - Method in class bb.common.ProformaInvoiceItemVO

getArSub() - Method in class bb.common.ProformaInvoiceVO

getArSub() - Method in class bb.common.QuoteVO

getArSub() - Method in class bb.common.SalesOrderVO

getArSub() - Method in class bb.common.ShipperInfoVO

getArSub() - Method in class bb.common.ShipperItemVO

getArSub() - Method in class bb.common.ShipperVO

getArTax() - Method in class bb.common.AccountsReceivableItemVO

getArTax() - Method in class bb.common.ARAuditListResult

getArTax() - Method in class bb.common.MakeCreditMemoAgent

getArTax() - Method in class bb.common.OnLoanItemVO

getArTax() - Method in class bb.common.OnloanShipperItemVO

getArTax() - Method in class bb.common.OnloanShipperVO

getArTax() - Method in class bb.common.OnLoanVO

getArTax() - Method in class bb.common.ProformaInvoiceItemVO

getArTax() - Method in class bb.common.ProformaInvoiceVO

getArTax() - Method in class bb.common.ShipperInfoVO

getArTax() - Method in class bb.common.ShipperItemVO

getArTax() - Method in class bb.common.ShipperVO

getArTaxSet() - Method in class bb.common.AccountsReceivableInfoVO

getArTaxSet() - Method in class bb.common.AccountsReceivableVO

getArTaxSet() - Method in class bb.common.OnloanShipperVO

getArTaxSet() - Method in class bb.common.OnLoanVO

getArTaxSet() - Method in class bb.common.QuoteVO

getArTaxSet() - Method in class bb.common.SalesOrderVO

getArTaxSet() - Method in class bb.common.ShipperVO

getArTotal() - Method in class bb.common.AccountsReceivableItemVO

getArTotal() - Method in class bb.common.ARAuditListResult

getArTotal() - Method in class bb.common.ARPaymentRunItemVO

getArTotal() - Method in class bb.common.OnLoanItemVO

getArTotal() - Method in class bb.common.OnloanShipperItemVO

getArTotal() - Method in class bb.common.OnloanShipperVO

getArTotal() - Method in class bb.common.OnLoanVO

getArTotal() - Method in class bb.common.PaymentRunItemTotalResult

getArTotal() - Method in class bb.common.ProformaInvoiceItemVO

getArTotal() - Method in class bb.common.ProformaInvoiceVO

getArTotal() - Method in class bb.common.SalesOrderCheckListResult

getArTotal() - Method in class bb.common.SalesOrderItemInfoVO

getArTotal() - Method in class bb.common.SalesOrderItemVO

getArTotal() - Method in class bb.common.ShipperInfoVO

getArTotal() - Method in class bb.common.ShipperItemVO

getArTotal() - Method in class bb.common.ShipperVO

getArTotalDue() - Method in class bb.common.AllStatementsListResult

getArWireFeeAccount() - Method in class bb.common.AccountingSettingsVO

getAsm() - Method in class bb.common.EcnWOOrderResult

getAsm() - Method in class bb.common.WorkOrderItemCanAssyResult

getAsm() - Method in class bb.common.WorkOrderItemListResult

getAsm() - Method in class bb.common.WorkOrderItemToIssueResult

getAsmPart() - Method in class bb.common.WOItemPartDetailNotIssue

getAsmSequenceNo() - Method in class bb.common.BillItemReplacementVO

getAsmSequenceNo() - Method in class bb.common.BillItemVO

getAsmSequenceNo() - Method in class bb.common.BillItemWithPartInfoResult

getAsmSequenceNo() - Method in class bb.common.WorkOrderItemSetupItemAgent

getAsOf() - Method in class bb.common.CustomerStatementTotalResult

getAssetAccount() - Method in class bb.common.ScrapAssetAgent

getAssetAdditionsCount(String, String, String, String, Date, Date) - Method in interface bb.common.box.AccountingBox

getAssetAdditionsSum(String, String, String, String, Date, Date) - Method in interface bb.common.box.AccountingBox

getAssetApprovedBy() - Method in class bb.common.AccountingConfigurationVO

getAssetDate() - Method in class bb.common.CustomAssetVO

getAssetDeprCreditAccount() - Method in class bb.common.AccountingSettingsVO

getAssetDepreciatesCount(String, String, String, String, String, String, String, String) - Method in interface bb.common.box.AccountingBox

getAssetDepreciatesSum(String, String, String, String, String, String, String, String) - Method in interface bb.common.box.AccountingBox

getAssetDisposalsCount(String, String, String, String, Date, Date) - Method in interface bb.common.box.AccountingBox

getAssetDisposalsSum(String, String, String, String, Date, Date) - Method in interface bb.common.box.AccountingBox

getAssetLiquidationAccount() - Method in class bb.common.ScrapAssetAgent

getAssetName() - Method in class bb.common.CustomAssetVO

getAssetNum() - Method in class bb.common.EquipmentListResult

getAssetNum() - Method in class bb.common.EquipmentVO

getAssetNumber() - Method in class bb.common.AssetAddOrDisposalsReport

getAssetNumber() - Method in class bb.common.AssetAmortizationExpenseAccountPK

getAssetNumber() - Method in class bb.common.AssetDepreciateDetailReport

getAssetNumber() - Method in class bb.common.AssetDepreciatePK

getAssetNumber() - Method in class bb.common.AssetUsagePK

getAssetNumber() - Method in class bb.common.AssetVO

getAssetNumber() - Method in class bb.common.CustomAssetRecordPK

getAssetNumber() - Method in class bb.common.CustomAssetVO

getAssetOrder() - Method in class bb.common.CustomAssetVO

getAssetRecords() - Method in class bb.common.CustomAssetVO

getAssetsCount(String, String, String, String, String, String, String, String, String) - Method in interface bb.common.box.AccountingBox

getAssetsCountByAssetNumber(String) - Method in interface bb.common.box.AccountingBox

getAssetStatus() - Method in class bb.common.AssetVO

getAssetStatus() - Method in class bb.common.CustomAssetVO

getAssetType() - Method in class bb.common.AssetAddOrDisposalsReport

getAssetType() - Method in class bb.common.AssetDepreciateDetailReport

getAssetType() - Method in class bb.common.AssetDepreciateVO

getAssetType() - Method in class bb.common.AssetVO

getAssetType(String) - Method in interface bb.common.box.AccountingBox

getAssetType() - Method in class bb.common.DepreciateMonthlyReport

getAssetType2() - Method in class bb.common.AssetVO

getAssetUsageById(String) - Method in interface bb.common.box.AccountingBox

getAssetUsagebyPk(AssetUsagePK) - Method in interface bb.common.box.AccountingBox

getAssignedTo() - Method in class bb.common.ToolCalibrationVO

getAssignTo() - Method in class bb.common.AssetVO

getAttach() - Method in class bb.common.BB2BugNotice

getAttach() - Method in class bb.common.BB2Notice

getAttachment() - Method in class bb.common.BizboxBugChangesVO

getAttachment() - Method in class bb.common.BizboxBugVO

getAttachmentNum() - Method in class bb.common.GeneralLedgerPrintResult

getAttachmentNum() - Method in class bb.common.GeneralLedgerVO

getAuditBy() - Method in class bb.common.AuditLogVO

getAuditExchange() - Method in class bb.common.CurrencyExchangeVO

getAuditInventoryReport(PartPK, Date, Date) - Method in interface bb.common.box.WarehouseBox

getAuditLog() - Method in interface bb.common.box.PurchasingBox

getAuditOndemand() - Method in class bb.common.AuditOnDemandResult

getAuditOnhandQty() - Method in class bb.common.AuditOnDemandResult

getAuditOnorder() - Method in class bb.common.AuditOnDemandResult

getAuditPartInQA(String, String, String) - Method in interface bb.common.box.WarehouseBox

getAuditQtrUsage() - Method in class bb.common.AuditOnDemandResult

getAuditResults() - Method in interface bb.common.box.PurchasingBox

getAuditSip() - Method in class bb.common.PartOnHandAuditResult

getAuditTime() - Method in class bb.common.AuditLogVO

getAuditWip() - Method in class bb.common.AuditOnDemandResult

getAuditYrUsage() - Method in class bb.common.AuditOnDemandResult

getAuthenticator() - Method in class bb.common.CustomEmployeeWorkExperienceVO

getAuthenticator() - Method in class bb.common.EmployeeWorkExperienceVO

getAuthor() - Method in class bb.common.WorkInstructionListResult

getAuthor() - Method in class bb.common.WorkInstructionSequenceListResult

getAuthor() - Method in class bb.common.WorkInstructionVO

getAuthor() - Method in class bb.common.WorkOrderWorkInstructionVO

getAutoApprovalBy() - Method in class bb.common.PointOfSaleVO

getAvailablePartsForCGCustomerCount(String, String, String, String, String, String, boolean) - Method in interface bb.common.box.SalesBox

getAvailablePartsToSalesCatalogCount(String, String, String, String, String) - Method in interface bb.common.box.SalesBox

getAvailQty() - Method in class bb.common.IssuedFromOrderItem

getAvailQty() - Method in class bb.common.MrpByMonthResult

getAverageCost() - Method in class bb.common.BillDetailCostResult

getAverageCost() - Method in class bb.common.BillDetailCostWithPartInfoResult

getAverageCost() - Method in class bb.common.BillItemDetailCostWithPartInfoResult

getAverageCost() - Method in class bb.common.BillItemSalesCostResult

getAverageCost() - Method in class bb.common.BillItemSalesXResult

getAverageCost() - Method in class bb.common.BillItemUsageResult

getAverageCost() - Method in class bb.common.BillSalesCostResult

getAverageCost() - Method in class bb.common.BillSalesXResult

getAverageCost() - Method in class bb.common.HistoricalInventoryVO

getAverageCost() - Method in class bb.common.NonConformanceReportResult

getAverageCost() - Method in class bb.common.OnloanShipperItemVO

getAverageCost() - Method in class bb.common.PartCostVarianceListResult

getAverageCost() - Method in class bb.common.PartInventoryVO

getAverageCost() - Method in class bb.common.PartOnhandVO

getAverageCost() - Method in class bb.common.PartOnhandWithAverageCostResult

getAverageCost() - Method in class bb.common.PartOnHandWithMfgInfoResult

getAverageCost() - Method in class bb.common.PhysicalInventoryVO

getAverageCost() - Method in class bb.common.SalesOrderItemCostResult

getAverageCost() - Method in class bb.common.ShipperItemListResult

getAverageCost() - Method in class bb.common.ShipperItemVO

getAverageCost() - Method in class bb.common.ToolInventoryVO

getAverageCost() - Method in class bb.common.ToolListDetailCostResult

getAverageCost() - Method in class bb.common.ToolListDetailCostWithToolInfoResult

getAverageCost() - Method in class bb.common.ToolListItemDetailCostWithToolInfoResult

getAverageCost() - Method in class bb.common.ToolOnhandVO

getAverageCost() - Method in class bb.common.ToolOnhandWithAverageCostResult

getAverageCostResultList() - Method in class bb.common.InventoryAdjustmentDetailResult

getAveragePerMonth() - Method in class bb.common.SalesInfoCenter.DueSoCount

getAveragePerMonth() - Method in class bb.common.SalesInfoCenter.DueSoSum

getAveragePerMonth() - Method in class bb.common.SalesInfoCenter.GrossMargin

getAveragePerMonth() - Method in class bb.common.SalesInfoCenter.InvoicedSum

getAveragePerMonth() - Method in class bb.common.SalesInfoCenter.OpenSoSum

getAveragePerMonth() - Method in class bb.common.SalesInfoCenter.SoCount

getAveragePerMonth() - Method in class bb.common.SalesInfoCenter.SoCountWithPartsOnhold

getAveragePerMonth() - Method in class bb.common.SalesInfoCenter.SoItemCount

getAveragePerMonth() - Method in class bb.common.SalesInfoCenter.SoTotalSum

getAvgAmount() - Method in class bb.common.BB2DoubleCost

getAvgCost() - Method in class bb.common.AccountsReceivableItemVO

getAvgcost() - Method in class bb.common.BB2PartInventoryResult

getAvgCost() - Method in class bb.common.ChangeStdCostWorkSheetItemVO

getAvgCost() - Method in class bb.common.CycleCountListResult

getAvgCost() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getAvgCost() - Method in class bb.common.DisassembleWorkOrderItemPartDetailItemResult

getAvgCost() - Method in class bb.common.InSipAudittListResult

getAvgCost() - Method in class bb.common.InventoryAmountByMonth

getAvgCost() - Method in class bb.common.InventoryNotUsedInMonthsResult

getAvgCost() - Method in class bb.common.IssueItemAgent

getAvgCost() - Method in class bb.common.IssuingItemResult

getAvgCost() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getAvgCost() - Method in class bb.common.OrderApprovalItemsVO

getAvgCost() - Method in class bb.common.PartBasicInfoWithNewListPrice

getAvgCost() - Method in class bb.common.PartInWipForIDListResult

getAvgCost() - Method in class bb.common.PartOnhandAndCostResult

getAvgCost() - Method in class bb.common.PartOnhandResult

getAvgCost() - Method in class bb.common.PartWithExcessiveInventoryListResult

getAvgCost() - Method in class bb.common.PartWithOnLoanQtyListResult

getAvgCost() - Method in class bb.common.PartWithQAQtyListResult

getAvgCost() - Method in class bb.common.PartWithQtyListResult

getAvgCost() - Method in class bb.common.PartWithSipQtyListResult

getAvgCost() - Method in class bb.common.PartWithSITQtyListResult

getAvgCost() - Method in class bb.common.PartWithSTOQtyListResult

getAvgCost() - Method in class bb.common.PartWithWipQtyListResult

getAvgCost() - Method in class bb.common.PfReceiverItemVO

getAvgCost() - Method in class bb.common.PhysicalInventoryListResult

getAvgCost() - Method in class bb.common.ProformaInvoiceItemVO

getAvgCost() - Method in class bb.common.RollUpBomStdCostWorkSheetItemVO

getAvgCost() - Method in class bb.common.RtvShipperItemVO

getAvgCost() - Method in class bb.common.RunningAccountOrderItemVO

getAvgCost() - Method in class bb.common.SalesOrderItemCostResult

getAvgCost() - Method in class bb.common.ShipperItemAgent

getAvgCost() - Method in class bb.common.ShippingItemResult

getAvgCost() - Method in class bb.common.SwapOrderItemListResult

getAvgCost() - Method in class bb.common.SwapOrderItemVO

getAvgCost() - Method in class bb.common.SwapReceiverItemListResult

getAvgCost() - Method in class bb.common.SwapReceiverItemVO

getAvgCost() - Method in class bb.common.SwapShipperItemListResult

getAvgCost() - Method in class bb.common.SwapShipperItemVO

getAvgCost() - Method in class bb.common.TransferOrderItemListResult

getAvgCost() - Method in class bb.common.TransferOrderItemVO

getAvgCost() - Method in class bb.common.TransferReceiverItemListResult

getAvgCost() - Method in class bb.common.TransferReceiverItemVO

getAvgCost() - Method in class bb.common.TransferShipperItemListResult

getAvgCost() - Method in class bb.common.TransferShipperItemVO

getAvgCost() - Method in class bb.common.WOItemPartDetailNotIssue

getAvgCost() - Method in class bb.common.WorkOrderItemInWipListResult

getAvgCost() - Method in class bb.common.WorkOrderItemPartDetailItemResult

getAvgCostTotal() - Method in class bb.common.RunningAccountOrderVO

getAvgDaysToPay() - Method in class bb.common.CustomerStatementTotalResult

getAvgFyPoAddedCount() - Method in class bb.common.PurchasingInfoCenterResult

getAvgFyPoiAddedCount() - Method in class bb.common.PurchasingInfoCenterResult

getAvgFyPurchaserAccount() - Method in class bb.common.PurchasingInfoCenterResult

getAvgFyReceiverAccount() - Method in class bb.common.PurchasingInfoCenterResult

getAvgFyReceiverCount() - Method in class bb.common.PurchasingInfoCenterResult

getAvgFyReceiverItemCount() - Method in class bb.common.PurchasingInfoCenterResult

getAvgHours() - Method in class bb.common.WorkInstructionSequenceVO

getAvgHoursH() - Method in class bb.common.WorkInstructionSequenceVO

getAvgHoursM() - Method in class bb.common.WorkInstructionSequenceVO

getAvgHoursS() - Method in class bb.common.WorkInstructionSequenceVO

getAvgHrs() - Method in class bb.common.WorkCenterRunTimeListResult

getAvgHrs() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getAvgHrsH() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getAvgHrsM() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getAvgHrsS() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getAvgMargin() - Method in class bb.common.AccountingTotalMoneyResult

getAvgMargin() - Method in class bb.common.DuePATotalByVendorResult

getAvgMarginPercent() - Method in class bb.common.AccountingTotalMoneyResult

getAvgMarginPercent() - Method in class bb.common.DuePATotalByVendorResult

getAvgRunHrs() - Method in class bb.common.WorkInstructionSummaryItemResult

getAvgSetup() - Method in class bb.common.WorkCenterRunTimeListResult

getAvgSetup() - Method in class bb.common.WorkInstructionSequenceVO

getAvgSetup() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getAvgSetupH() - Method in class bb.common.WorkInstructionSequenceVO

getAvgSetupH() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getAvgSetupHrs() - Method in class bb.common.WorkInstructionSummaryItemResult

getAvgSetupM() - Method in class bb.common.WorkInstructionSequenceVO

getAvgSetupM() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getAvgSetupS() - Method in class bb.common.WorkInstructionSequenceVO

getAvgSetupS() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getAvgTotal() - Method in class bb.common.NonproductivePickingItemVO

getAvgTotal() - Method in class bb.common.NonproductivePickingVO

getAvgTotalAmount() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getAvgTotalAmount() - Method in class bb.common.WorkOrderItemInWipListResult

getAvialQty() - Method in class bb.common.WorkOrderItemCanAssyResult

getBackflushMaterialPartOnhandResultsCount(String, String, boolean) - Method in interface bb.common.box.WarehouseBox

getBalance() - Method in class bb.common.AccountBalanceListResult

getBalance() - Method in class bb.common.AccountBalanceResult

getBalance() - Method in class bb.common.AccountsChartCategoryListResult

getBalance() - Method in class bb.common.BalanceSheetSideBySideItemResult

getBalance() - Method in class bb.common.ClosingStatementItemResult

getBalance() - Method in class bb.common.ExchangeAuditItemResult

getBalance() - Method in class bb.common.GeneralLedgerByDateListResult

getBalance() - Method in class bb.common.JounalEntryListResult

getBalanceDue() - Method in class bb.common.ARPrepayAllStatementsListResult

getBalanceDue() - Method in class bb.common.CustomerPrepayStatementListResult

getBalanceDue() - Method in class bb.common.CustomerStatementListResult

getBalanceDue() - Method in class bb.common.CustomerStatementResult

getBalanceDue() - Method in class bb.common.VendorPrepayStatementListResult

getBalanceDue() - Method in class bb.common.VendorStatementListResult

getBalanceForward() - Method in class bb.common.CustomerStatementResult

getBalenceDue() - Method in class bb.common.ARAllStatementsListResult

getBankReconciled() - Method in class bb.common.GeneralLedgerResult

getBankReconciliationReportCount(String, String, String) - Method in interface bb.common.box.AccountingBox

getBankReconsiled() - Method in class bb.common.GeneralLedgerListResult

getBankReconsiled() - Method in class bb.common.GeneralLedgerVO

getBankTransferFeeAccount() - Method in class bb.common.ARPrepaymentWireTransferAgent

getBankTransferFeeAccount() - Method in class bb.common.PrepaymentWireTransferAgent

getBankTransferFeeAccount() - Method in class bb.common.WireTransferAgent

getBatch() - Method in class bb.common.AccountsPayableInfoVO

getBatch() - Method in class bb.common.AccountsPayableVO

getBatch() - Method in class bb.common.GeneralLedgerByDateListResult

getBatch() - Method in class bb.common.GeneralLedgerListResult

getBatch() - Method in class bb.common.GeneralLedgerResult

getBatch() - Method in class bb.common.GeneralLedgerVO

getBatch() - Method in class bb.common.OnloanReceiverVO

getBatch() - Method in class bb.common.OnloanShipperVO

getBatch() - Method in class bb.common.ReceiverInfoVO

getBatch() - Method in class bb.common.ReceiverVO

getBatch() - Method in class bb.common.RMAReceiverVO

getBatch() - Method in class bb.common.RtvShipperInfoVO

getBatch() - Method in class bb.common.RtvShipperVO

getBatch() - Method in class bb.common.ShipperVO

getBatchNumber() - Method in class bb.common.AccountsReceivableInfoVO

getBatchNumber() - Method in class bb.common.AccountsReceivableVO

getBatchNumber() - Method in class bb.common.AddPayableWithoutReceiverAgent

getBatchNumber() - Method in class bb.common.MakeAccountPayableAgent

getBatchNumber() - Method in class bb.common.MakeCreditMemoAgent

getBatchNumber() - Method in class bb.common.MakeDebitMemoAgent

getBatchRunNumber() - Method in class bb.common.PaymentAgent

getBatchRunNumber() - Method in class bb.common.PrepayPaymentAgent

getBb2AvgCost() - Method in class bb.common.ContractPriceItemVO

getBb2AvgCost() - Method in class bb.common.VendorContractPriceItemVO

getBb2BackOrderQty() - Method in class bb.common.ShipperItemVO

getBB2DatabaseVersion() - Method in interface bb.common.box.CompanyBox

getBb2description() - Method in class bb.common.PartOnhandVO

getBb2FeedBackNumber() - Method in class bb.common.AccountsReceivableVO

getBb2HavePic() - Method in class bb.common.SGSaleItemVO

getBb2HaveSalesDwg() - Method in class bb.common.SGSaleItemVO

getBb2ListPrice() - Method in class bb.common.ContractPriceItemVO

getBb2ListPrice() - Method in class bb.common.VendorContractPriceItemVO
nullable persistent field
getBB2Part() - Method in class bb.common.OrderDemandForReceiverResult

getBB2PartDescription(BB2Part, String) - Method in interface bb.common.box.EngineeringBox

getBB2PartDescription(BB2Part, String) - Method in interface bb.common.box.QualityBox

getBB2PartFromOrderItem(Object) - Static method in class bb.common.BB2Util

getBB2PartOnDemandListResultForPart(boolean) - Method in interface bb.common.box.PurchasingBox

getBb2PoRecQty() - Method in class bb.common.ReceiverItemVO

getBb2RmaReceiverItems() - Method in class bb.common.ReturnMaterialAuthorizationVO

getBb2ShipperItems() - Method in class bb.common.ReturnToVendorVO

getBb2ShipTo() - Method in class bb.common.PackingBoxVO

getBb2ShipToName() - Method in class bb.common.PackingBoxVO

getBb2ShipVia() - Method in class bb.common.PackingBoxVO

getBb2SoShippedQty() - Method in class bb.common.ShipperItemVO

getBb2StdCost() - Method in class bb.common.ContractPriceItemVO

getBb2StdCost() - Method in class bb.common.VendorContractPriceItemVO

getBB2Time() - Static method in class bb.common.BB2TimeFactory

getBB2Time(Date) - Static method in class bb.common.BB2TimeFactory

getBc() - Method in class bb.common.BillItemVO

getBc() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

getBc() - Method in class bb.common.SGBillItemVO

getBc() - Method in class bb.common.ToolListItemVO

getBc() - Method in class bb.common.WorkOrderItemIssueVO

getBeforeDate() - Method in class bb.common.MrpItemResult

getBeginBalance() - Method in class bb.common.GLInfoByPeriodResult

getBeginCost(int) - Method in class bb.common.InventoryReportListResult

getBeginDate() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getBeginPeriodBalance() - Method in class bb.common.AccountBalanceResult

getBigCatagory() - Method in class bb.common.PartCatagoryPK

getBigDecimal(Object) - Static method in class bb.common.BB2Util

getBill() - Method in class bb.common.BillItemSalesCostResult

getBill() - Method in class bb.common.BillItemSalesXResult

getBill() - Method in class bb.common.BillWhereUsedItemResult

getBill(BillPK) - Method in interface bb.common.box.EngineeringBox

getBill() - Method in class bb.common.InventoryNotUsedInMonthsResult

getBill() - Method in class bb.common.PartBasicInfo

getBill() - Method in class bb.common.PartMaterialWhereUsedItemResult

getBill() - Method in class bb.common.PartVO

getBill() - Method in class bb.common.PartWhereUsedItemResult

getBill() - Method in class bb.common.PartWithInventoryInfoListResult

getBill() - Method in class bb.common.PartWithManufacturerInfoResult

getBill() - Method in class bb.common.PartWithOnhandsVO

getBill() - Method in class bb.common.RollUPPartStandardCostResult

getBill() - Method in class bb.common.SalesBomItemResult

getBill() - Method in class bb.common.SalesOrderItemVO

getBill() - Method in class bb.common.SGBOMItemResult

getBill() - Method in class bb.common.SGPartCatalogResult

getBill() - Method in class bb.common.StockTransactionPartInfoResult

getBill() - Method in class bb.common.ToolVO

getBill() - Method in class bb.common.ToolWhereUsedItemResult

getBill() - Method in class bb.common.ToolWithOnhandsVO

getBillAndHold() - Method in class bb.common.AccountsReceivableVO

getBillDetailCostResult(BillPK, String) - Method in interface bb.common.box.EngineeringBox

getBillId() - Method in class bb.common.DisassembleWorkOrderReceivingResult

getBillId() - Method in class bb.common.IssuingResult

getBillInfo() - Method in class bb.common.BillDetailCostResult

getBillItem() - Method in class bb.common.BillVO

getBillItemCount(BillPK) - Method in interface bb.common.box.EngineeringBox

getBillItemNumber() - Method in class bb.common.BillItemPK

getBillItemNumber() - Method in class bb.common.BillLogVO

getBillItemNumber() - Method in class bb.common.SGBOMItemResult

getBillItemOnHandUsageResults(BillPK) - Method in interface bb.common.box.EngineeringBox

getBillItemOnHandWithPartInfoByBillItemPk(BillItemPK, String) - Method in interface bb.common.box.EngineeringBox

getBillItemPk() - Method in class bb.common.BillItemSalesCostResult

getBillItemPk() - Method in class bb.common.BillItemSalesResult

getBillItemPk() - Method in class bb.common.BillItemSalesXResult

getBillItemPk() - Method in class bb.common.BillItemWithPartInfoResult

getBillItemPk() - Method in class bb.common.BillWhereUsedItemResult

getBillItemPk() - Method in class bb.common.BomItemWithOEMResult

getBillItemPk() - Method in class bb.common.BomPickListItemResult

getBillItemPk() - Method in class bb.common.PartMaterialWhereUsedItemResult

getBillItemPk() - Method in class bb.common.SalesBomItemResult

getBillItemPk() - Method in class bb.common.SalesPartListItemResult

getBillItemPk() - Method in class bb.common.ToolListItemWithToolInfoResult

getBillItemReplacements() - Method in class bb.common.BillItemVO

getBillItemReplacements() - Method in class bb.common.BillItemWithPartInfoResult

getBillItems() - Method in class bb.common.BillDetailCostResult

getBillItems(BillItemPK) - Method in interface bb.common.box.EngineeringBox

getBillItemUsageResults(BillPK) - Method in interface bb.common.box.EngineeringBox

getBillItemUsageResultsWitCost(BillPK) - Method in interface bb.common.box.EngineeringBox

getBillItemWithPartInfoByBillItemPk(BillItemPK, String) - Method in interface bb.common.box.EngineeringBox

getBillLogCount(String, String, String, Date, Date) - Method in interface bb.common.box.EngineeringBox

getBillNumber() - Method in class bb.common.BillItemPK

getBillNumber() - Method in class bb.common.BillItemReplacementVO

getBillNumber() - Method in class bb.common.BillLogVO

getBillNumber() - Method in class bb.common.BillPK

getBillNumber() - Method in class bb.common.BOMCanAssyAgent

getBillNumber() - Method in class bb.common.RollUpBomStdCostWorkSheetItemPK

getBillNumber() - Method in class bb.common.SGBillItemPK

getBillNumber() - Method in class bb.common.SGPartListItemResult

getBillOfLading() - Method in class bb.common.PfReceiverVO

getBillOfLading() - Method in class bb.common.ProformaInvoiceVO

getBillOnHandWithPartInfoResultByBillPk(BillPK, String, String) - Method in interface bb.common.box.EngineeringBox

getBillPartFrom() - Method in class bb.common.SalesBomItemResult

getBillPartFrom() - Method in class bb.common.SalesBomResult

getBillPartFrom() - Method in class bb.common.SalesPartListItemResult

getBillPartFrom() - Method in class bb.common.SalesPartListResult

getBillPk() - Method in class bb.common.BillSalesCostResult

getBillPk() - Method in class bb.common.BillWithPartInfoResult

getBillPk() - Method in class bb.common.BomPickListResult

getBillPk() - Method in class bb.common.BomWithOEMResult

getBillPk() - Method in class bb.common.MrpReportAgent

getBillPk() - Method in class bb.common.SalesBomResult

getBillPk() - Method in class bb.common.SalesPartListResult

getBillPk() - Method in class bb.common.ToolListWithToolInfoResult

getBillPKsToRollUP(String, boolean) - Method in interface bb.common.box.EngineeringBox

getBillSalesResult(BillPK) - Method in interface bb.common.box.EngineeringBox

getBillSalesXResult(BillPK, String) - Method in interface bb.common.box.EngineeringBox

getBillsCountByBillNumberLike(boolean, Date, Date, String, String, boolean, String, String, String) - Method in interface bb.common.box.EngineeringBox

getBillTo() - Method in class bb.common.AccountsReceivableInfoVO

getBillTo() - Method in class bb.common.AccountsReceivableVO

getBillTo() - Method in class bb.common.AllStatementsListResult

getBillTo() - Method in class bb.common.CustomerStatementTotalResult

getBillTo() - Method in class bb.common.CustomerVendorAddressInfoVO

getBillTo() - Method in class bb.common.CustomerVendorAddressVO

getBillTo() - Method in class bb.common.ProformaInvoiceVO

getBillTo() - Method in class bb.common.RunningAccountOrderItemResult

getBillTo() - Method in class bb.common.RunningAccountOrderVO

getBillToAddressInfo() - Method in class bb.common.AccountsReceivableVO

getBillToAddressInfo() - Method in class bb.common.ArPrepayVO

getBillToAddressInfo() - Method in class bb.common.CustomerReturnToVendorVO

getBillToAddressInfo() - Method in class bb.common.DisassembleWorkOrderVO

getBillToAddressInfo() - Method in class bb.common.OnloanShipperVO

getBillToAddressInfo() - Method in class bb.common.OnLoanVO

getBillToAddressInfo() - Method in class bb.common.ProformaInvoiceVO

getBillToAddressInfo() - Method in class bb.common.PurchaseOrderVO

getBillToAddressInfo() - Method in class bb.common.QuoteVO

getBillToAddressInfo() - Method in class bb.common.RequestForQuoteVO

getBillToAddressInfo() - Method in class bb.common.RequestForRMAVO

getBillToAddressInfo() - Method in class bb.common.ReturnMaterialAuthorizationVO

getBillToAddressInfo() - Method in class bb.common.ReturnToVendorVO

getBillToAddressInfo() - Method in class bb.common.RtvShipperInfoVO

getBillToAddressInfo() - Method in class bb.common.RtvShipperVO

getBillToAddressInfo() - Method in class bb.common.SalesOrderVO

getBillToAddressInfo() - Method in class bb.common.ShipperInfoVO

getBillToAddressInfo() - Method in class bb.common.ShipperVO

getBillToAddressInfo() - Method in class bb.common.WorkOrderVO

getBillToId() - Method in class bb.common.ArPrepayVO

getBillToId() - Method in class bb.common.CompanyVO

getBillToId() - Method in class bb.common.CustomerReturnToVendorVO

getBillToId() - Method in class bb.common.DisassembleWorkOrderVO

getBillToId() - Method in class bb.common.MakeBillAndHoldInvoiceAgent

getBillToId() - Method in class bb.common.MakeInvoiceAgent

getBillToId() - Method in class bb.common.OnloanShipperVO

getBilltoId() - Method in class bb.common.OnLoanVO

getBilltoId() - Method in class bb.common.PO2SOExchange

getBillToId() - Method in class bb.common.ProformaInvoiceListResult

getBillToId() - Method in class bb.common.PurchaseOrderVO

getBillToId() - Method in class bb.common.Quote2QuoteAgent

getBillToId() - Method in class bb.common.QuoteVO

getBillToId() - Method in class bb.common.RequestForQuoteVO

getBillToId() - Method in class bb.common.RequestForRMAVO

getBillToId() - Method in class bb.common.ReturnMaterialAuthorizationVO

getBillToId() - Method in class bb.common.ReturnToVendorByDateListResult

getBillToId() - Method in class bb.common.ReturnToVendorVO

getBillToId() - Method in class bb.common.RMAReceiverResult

getBillToId() - Method in class bb.common.RMAReceiverVO

getBilltoId() - Method in class bb.common.RtvShipperInfoVO

getBilltoId() - Method in class bb.common.RtvShipperVO

getBillToId() - Method in class bb.common.SalesOrderVO

getBillToId() - Method in class bb.common.ShipperInfoVO

getBillToId() - Method in class bb.common.ShipperVO

getBillToId() - Method in class bb.common.SO2SOAgent

getBillToId() - Method in class bb.common.WorkOrderVO

getBillToInfo() - Method in class bb.common.RMAReceiverVO

getBilltoName() - Method in class bb.common.PO2SOExchange

getBillType() - Method in class bb.common.BillItemPK

getBillType() - Method in class bb.common.BillItemReplacementVO

getBillType() - Method in class bb.common.BillLogVO

getBillType() - Method in class bb.common.BillPK

getBillType() - Method in class bb.common.RollUpBomStdCostWorkSheetItemPK

getBillType() - Method in class bb.common.SGBillItemPK

getBillType() - Method in class bb.common.SGPartListItemResult

getBillWhereUsedResult(PartPK, BillPK) - Method in interface bb.common.box.EngineeringBox

getBillWhereUsedResults(ArrayList<PartPK>, BillPK) - Method in interface bb.common.box.EngineeringBox

getBillWithoutItems(String) - Method in interface bb.common.box.EngineeringBox

getBillWithPartInfoByBillPk(BillPK, String) - Method in interface bb.common.box.EngineeringBox

getBirthDate() - Method in class bb.common.CustomEmployeeVO

getBirthDate() - Method in class bb.common.EmployeeCardVO

getBirthDateRange(int) - Static method in class bb.common.CustomEmployeeVO

getBirthPlace() - Method in class bb.common.EmployeeCardVO

getBizBoxUserPairString(String, String) - Static method in class bb.common.BB2Util

getBizException(DBAccessException, String, Reason) - Static method in exception bb.common.BizException

getBloodPressure() - Method in class bb.common.CustomCheckUpEmployeeVO

getBnIi() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

getBnIi() - Method in class bb.common.WorkOrderItemIssueVO

getBoilerplateId() - Method in class bb.common.ARBoilerplateVO

getBoilerplateId() - Method in class bb.common.PurchaseOrderBoilerplateVO

getBoilerplateId() - Method in class bb.common.QuoteBoilerplateVO

getBoilerplateId() - Method in class bb.common.SalesOrderBoilerplateVO

getBoilerplateId() - Method in class bb.common.WorkOrderBoilerplateVO

getBoilerplates() - Method in class bb.common.AccountsReceivableVO

getBoilerplates() - Method in class bb.common.DisassembleWorkOrderVO

getBoilerplates() - Method in class bb.common.PurchaseOrderVO

getBoilerplates() - Method in class bb.common.QuoteVO

getBoilerplates() - Method in class bb.common.SalesOrderVO

getBoilerplates() - Method in class bb.common.WorkOrderVO

getBom() - Method in class bb.common.BB2PartInfo

getBom() - Method in class bb.common.BomItemWithOEMResult

getBom() - Method in class bb.common.BomPickListItemResult

getBom() - Method in class bb.common.SGBOMResult

getBomApprovalByEmployeeId(String) - Method in interface bb.common.box.EngineeringBox

getBOMCanAssyListResult(PartPK) - Method in interface bb.common.box.WorkOrderBox

getBOMCanAssyListResults(ArrayList<PartPK>) - Method in interface bb.common.box.WorkOrderBox

getBomColor() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

getBomColor() - Method in class bb.common.WorkOrderItemIssueVO

getBomCost() - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

getBomCost() - Method in class bb.common.WorkOrderItemPartDetailResult

getBomCount() - Method in class bb.common.RollUpBomStdCostWorkSheetVO

getBomItemNumber() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

getBomItemNumber() - Method in class bb.common.WorkOrderItemIssueVO

getBomItemNumber() - Method in class bb.common.WorkOrderItemPartDetail

getBomItemQty() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

getBomItemQty() - Method in class bb.common.WorkOrderItemIssueVO

getBomLastChangeTimes() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

getBomLastChangeTimes() - Method in class bb.common.WorkOrderItemIssueVO

getBomLevel() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

getBomLevel() - Method in class bb.common.WorkOrderItemIssueVO

getBomNumber() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

getBomNumber() - Method in class bb.common.WorkOrderItemIssueVO

getBomNumber() - Method in class bb.common.WorkOrderItemPartDetail

getBomPickList(BillPK, BigDecimal) - Method in interface bb.common.box.WarehouseBox

getBomQty() - Method in class bb.common.WorkOrderOverIssueListResult

getBomScrapQty() - Method in class bb.common.WorkOrderItemIssueVO

getBomStdCost() - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

getBomStdCost() - Method in class bb.common.WorkOrderItemPartDetailResult

getBomToDeletedNotUsed() - Method in class bb.common.PartsToDeleteResult

getBomWithOEMResult(BillPK, String) - Method in interface bb.common.box.EngineeringBox

getBookBalance() - Method in class bb.common.ExchangeAuditItemResult

getBoughtQty() - Method in class bb.common.RunningAccountOrderItemVO

getBoxNumber() - Method in class bb.common.ShipperItemDetailAgent

getBp() - Method in class bb.common.AccountsPayableInfoVO

getBp() - Method in class bb.common.AccountsPayableVO

getBp() - Method in class bb.common.AccountsReceivableInfoVO

getBp() - Method in class bb.common.AccountsReceivableVO

getBp() - Method in class bb.common.CustomerReturnToVendorVO

getBp() - Method in class bb.common.DisassembleWorkOrderVO

getBp() - Method in class bb.common.MakeAccountPayableAgent

getBp() - Method in class bb.common.MakeCreditMemoAgent

getBp() - Method in class bb.common.OnloanReceiverVO

getBp() - Method in class bb.common.OnloanShipperVO

getBp() - Method in class bb.common.OnLoanVO

getBp() - Method in class bb.common.PfReceiverVO

getBp() - Method in class bb.common.ProformaInvoiceVO

getBp() - Method in class bb.common.PurchaseOrderVO

getBp() - Method in class bb.common.QuoteVO

getBp() - Method in class bb.common.ReceiverInfoVO

getBp() - Method in class bb.common.ReceiverVO

getBp() - Method in class bb.common.RequestForQuoteVO

getBp() - Method in class bb.common.RequestForRMAVO

getBp() - Method in class bb.common.ReturnMaterialAuthorizationVO

getBp() - Method in class bb.common.ReturnToVendorVO

getBp() - Method in class bb.common.RMAReceiverVO

getBp() - Method in class bb.common.RtvShipperInfoVO

getBp() - Method in class bb.common.RtvShipperVO

getBp() - Method in class bb.common.SalesOrderVO

getBp() - Method in class bb.common.ShipperInfoVO

getBp() - Method in class bb.common.ShipperVO

getBp() - Method in class bb.common.WorkOrderVO

getBpId() - Method in class bb.common.OrderBoilerplateVO

getBplate() - Method in class bb.common.OrderBoilerplateVO

getBreakPoint() - Method in class bb.common.PartOnHandAuditResult

getBudget() - Method in class bb.common.BudgetListResult

getBudget() - Method in class bb.common.GlCashFlowBudgetVO

getBudget() - Method in class bb.common.GlFiscalYearBudgetVO

getBudget() - Method in class bb.common.ProfitLossStatementItemResult

getBudgetAccountsChart() - Method in class bb.common.AccountsChartResult

getBudgetAmount() - Method in class bb.common.PurchaseOrderContractResult

getBudgetAmount() - Method in class bb.common.PurchaseOrderVO

getBudgetForExpenseListResult() - Method in class bb.common.AllBudgetResult

getBudgetForRevenueListResult() - Method in class bb.common.AllBudgetResult

getBudgetTotal() - Method in class bb.common.BudgetListResult

getBudgetYTD() - Method in class bb.common.BudgetListResult

getBugDescription() - Method in class bb.common.BizboxBugInfoVO

getBugDescription() - Method in class bb.common.BizboxBugVO

getBugId() - Method in class bb.common.BizboxBugChangesInfoVO

getBugId() - Method in class bb.common.BizboxBugChangesVO

getBugTitle() - Method in class bb.common.BizboxBugInfoVO

getBugTitle() - Method in class bb.common.BizboxBugVO

getbUltrasonic() - Method in class bb.common.CustomCheckUpEmployeeVO

getBUltrasonic() - Method in class bb.common.CustomCheckUpEmployeeVO

getBuyDate() - Method in class bb.common.CustomAssetVO

getBuyer() - Method in class bb.common.AccountPayableInfoWithPrepayResult

getBuyer() - Method in class bb.common.AccountsPayableInfoVO

getBuyer() - Method in class bb.common.AccountsPayableVO

getBuyer() - Method in class bb.common.NcrReportListResult

getBuyer() - Method in class bb.common.NonConformanceReportVO

getBuyer() - Method in class bb.common.OnloanReceiverVO

getBuyer() - Method in class bb.common.PfReceiverVO

getBuyer() - Method in class bb.common.POReceiverItemListResult

getBuyer() - Method in class bb.common.PrReceiverListResult

getBuyer() - Method in class bb.common.PurchaseOrderCheckListResult

getBuyer() - Method in class bb.common.PurchaseOrderContractResult

getBuyer() - Method in class bb.common.PurchaseOrderItemListResult

getBuyer() - Method in class bb.common.PurchaseOrderOpenDueListResult

getBuyer() - Method in class bb.common.PurchaseOrderVO

getBuyer() - Method in class bb.common.ReceiverInfoVO

getBuyer() - Method in class bb.common.ReceiverVO

getBuyer() - Method in class bb.common.RequestForQuoteCheckListResult

getBuyer() - Method in class bb.common.RequestForQuoteItemListResult

getBuyer() - Method in class bb.common.RequestForQuoteListResult

getBuyer() - Method in class bb.common.RequestForQuoteVO

getBuyer() - Method in class bb.common.ReturnToVendorByDateListResult

getBuyer() - Method in class bb.common.ReturnToVendorCheckListResult

getBuyer() - Method in class bb.common.ReturnToVendorItemListResult

getBuyer() - Method in class bb.common.ReturnToVendorListResult

getBuyer() - Method in class bb.common.ReturnToVendorVO

getBuyer() - Method in class bb.common.SwapOrderItemListResult

getBuyer() - Method in class bb.common.SwapOrderListResult

getBuyer() - Method in class bb.common.SwapOrderVO

getBuyer() - Method in class bb.common.SwapReceiverListResult

getBuyer() - Method in class bb.common.SwapReceiverVO

getBuyer() - Method in class bb.common.SwapShipperListResult

getBuyer() - Method in class bb.common.SwapShipperVO

getBuyerCode() - Method in class bb.common.BuyerCodeVO

getBuyercode() - Method in class bb.common.InventoryListResult

getBuyerCode() - Method in class bb.common.MrpReportAgent

getBuyerCode() - Method in class bb.common.PartBasicInfo

getBuyerCode() - Method in class bb.common.PartVO

getBuyerCode() - Method in class bb.common.PartWithInventoryInfoListResult

getBuyerCode() - Method in class bb.common.PartWithOnhandsVO

getBuyerCode() - Method in class bb.common.POReceiverItemListResult

getBuyerCode() - Method in class bb.common.ToolVO

getBuyerCode() - Method in class bb.common.ToolWithOnhandsVO

getBuyerCodeByBuyerCode(String) - Method in interface bb.common.box.CompanyBox

getBuyerCodeCountByBuyerCodeLike(String) - Method in interface bb.common.box.CompanyBox

getBuyerGroup() - Method in class bb.common.PurchaseOrderVO

getBuyerGroup() - Method in class bb.common.SwapOrderItemListResult

getBuyerGroup() - Method in class bb.common.SwapOrderListResult

getBuyerGroup() - Method in class bb.common.SwapOrderVO

getBuyerGroup() - Method in class bb.common.SwapReceiverListResult

getBuyerGroup() - Method in class bb.common.SwapReceiverVO

getBuyerGroup() - Method in class bb.common.SwapShipperListResult

getBuyerGroup() - Method in class bb.common.SwapShipperVO

getBuyerName() - Method in class bb.common.BuyerCodeVO

getBuyerName() - Method in class bb.common.PurchaseOrderListResult

getBuyor() - Method in class bb.common.ReturnToVendorVO

getBuyor() - Method in class bb.common.RMAReceiverVO

getBuyorGroup() - Method in class bb.common.ReturnToVendorVO

getByteArray() - Method in class bb.common.ZippedByteArray

getByteArrayFromImageIcon(ImageIcon) - Static method in class bb.common.BB2Util

getBytes() - Method in class bb.common.BB2Document

getC7() - Method in class bb.common.GlMonthBudgetVO

getC7() - Method in class bb.common.GlMonthVO

getCacct1() - Method in class bb.common.ProformaInvoiceVO

getCalcLoad() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getCalcNet() - Method in class bb.common.APAuditListResult

getCalcNet() - Method in class bb.common.ARAuditListResult

getCalibration() - Method in class bb.common.ToolBasicInfo

getCalibration() - Method in class bb.common.ToolVO

getCalibration() - Method in class bb.common.ToolWithManufacturerInfoResult

getCalibration() - Method in class bb.common.ToolWithOnhandsVO

getCalibrationsByAssignedToCount(String) - Method in interface bb.common.box.ManufacturingBox

getCalibrationsByNextInspectionInDaysCount(int) - Method in interface bb.common.box.ManufacturingBox

getCalibrationsCountByDate(Date, Date, boolean, PartPK, String) - Method in interface bb.common.box.ManufacturingBox

getCalibrationsCountByInspectedBy(String) - Method in interface bb.common.box.ManufacturingBox

getCalibrationsCountByLocation(String) - Method in interface bb.common.box.ManufacturingBox

getCalibrationsDueCount() - Method in interface bb.common.box.ManufacturingBox

getCanApproveOwnPurchaseOrder() - Method in class bb.common.PurchaseOrderApprovalVO

getCanApproveOwnRTV() - Method in class bb.common.RTVApprovalVO

getCanApproveOwnWorkOrder() - Method in class bb.common.DisassembleWorkOrderApprovalVO

getCanApproveOwnWorkOrder() - Method in class bb.common.WorkOrderApprovalVO

getCanAsm() - Method in class bb.common.WorkOrderItemListResult

getCancelledDisassembleWorkOrderListResultsCount() - Method in interface bb.common.box.WorkOrderBox

getCancelledEcnCount() - Method in class bb.common.EngineeringInfoCenterResult

getCancelledPurchaseOrderItemsCount() - Method in interface bb.common.box.PurchasingBox

getCancelledQuoteItemCount() - Method in interface bb.common.box.SalesBox

getCancelledRequestForQuoteItemListResultsCount() - Method in interface bb.common.box.PurchasingBox

getCancelledReturnToVendorItemsListResultsCount() - Method in interface bb.common.box.PurchasingBox

getCancelledRmaItemsCount() - Method in interface bb.common.box.SalesBox

getCancelledSwapOrderCount() - Method in interface bb.common.box.PurchasingBox

getCaneRunningAccountOrder(String) - Method in interface bb.common.box.CompanyBox

getCanReviewOwnNonproPicking() - Method in class bb.common.NonproductivePickingApproveVO

getCanReviewOwnOnloan() - Method in class bb.common.OnloanReviewVO

getCanReviewOwnRMA() - Method in class bb.common.RMAReviewVO

getCanReviewOwnSalesOrder() - Method in class bb.common.SalesOrderReviewVO

getCanUpdateAnything() - Method in class bb.common.BizboxUserListResult

getCanUpdateAnything() - Method in class bb.common.BizboxUserVO

getCardId() - Method in class bb.common.CustomEmployeeVO

getCarNumber() - Method in class bb.common.CorrectiveActionRequestVO

getCarrier() - Method in class bb.common.AccountsPayableInfoVO

getCarrier() - Method in class bb.common.AccountsPayableVO

getCarrier() - Method in class bb.common.AccountsReceivableInfoVO

getCarrier() - Method in class bb.common.AccountsReceivableVO

getCarrier() - Method in class bb.common.CarrierVO

getCarrier() - Method in class bb.common.CustomerReturnToVendorVO

getCarrier() - Method in class bb.common.OnloanReceiverVO

getCarrier() - Method in class bb.common.OnloanShipperVO

getCarrier() - Method in class bb.common.OnLoanVO

getCarrier() - Method in class bb.common.PfReceiverVO

getCarrier() - Method in class bb.common.PO2SOExchange

getCarrier() - Method in class bb.common.ProformaInvoiceVO

getCarrier() - Method in class bb.common.PurchaseOrderVO

getCarrier() - Method in class bb.common.QuoteVO

getCarrier() - Method in class bb.common.ReceiverInfoVO

getCarrier() - Method in class bb.common.ReceiverVO

getCarrier() - Method in class bb.common.RequestForQuoteVO

getCarrier() - Method in class bb.common.RequestForRMAVO

getCarrier() - Method in class bb.common.ReturnMaterialAuthorizationVO

getCarrier() - Method in class bb.common.ReturnToVendorVO

getCarrier() - Method in class bb.common.RMAReceiverVO

getCarrier() - Method in class bb.common.RtvShipperInfoVO

getCarrier() - Method in class bb.common.RtvShipperVO

getCarrier() - Method in class bb.common.SalesOrderVO

getCarrier() - Method in class bb.common.ShipperAgent

getCarrier() - Method in class bb.common.ShipperInfoVO

getCarrier() - Method in class bb.common.ShipperVO

getCarrier() - Method in class bb.common.SwapOrderListResult

getCarrier() - Method in class bb.common.SwapOrderVO

getCarrier() - Method in class bb.common.SwapReceiverListResult

getCarrier() - Method in class bb.common.SwapReceiverVO

getCarrier() - Method in class bb.common.SwapShipperListResult

getCarrier() - Method in class bb.common.SwapShipperVO

getCarrier() - Method in class bb.common.TransferOrderListResult

getCarrier() - Method in class bb.common.TransferOrderVO

getCarrier() - Method in class bb.common.TransferReceiverListResult

getCarrier() - Method in class bb.common.TransferReceiverVO

getCarrier() - Method in class bb.common.TransferShipperListResult

getCarrier() - Method in class bb.common.TransferShipperVO

getCarrierAccount() - Method in class bb.common.AccountsPayableInfoVO

getCarrierAccount() - Method in class bb.common.AccountsPayableVO

getCarrierAccount() - Method in class bb.common.CarrierVO

getCarrierAccount() - Method in class bb.common.MakeInvoiceAgent

getCarrierAccount() - Method in class bb.common.OnloanReceiverVO

getCarrierAccount() - Method in class bb.common.OnloanShipperVO

getCarrierAccount() - Method in class bb.common.PfReceiverVO

getCarrierAccount() - Method in class bb.common.ProformaInvoiceVO

getCarrierAccount() - Method in class bb.common.PurchaseOrderVO

getCarrierAccount() - Method in class bb.common.QuoteVO

getCarrierAccount() - Method in class bb.common.ReceiverInfoVO

getCarrierAccount() - Method in class bb.common.ReceiverVO

getCarrierAccount() - Method in class bb.common.ReturnToVendorVO

getCarrierAccount() - Method in class bb.common.RtvShipperInfoVO

getCarrierAccount() - Method in class bb.common.RtvShipperVO

getCarrierAccount() - Method in class bb.common.SalesOrderVO

getCarrierAccount() - Method in class bb.common.ShipperInfoVO

getCarrierAccount() - Method in class bb.common.ShipperVO

getCarrierAccount() - Method in class bb.common.SwapOrderListResult

getCarrierAccount() - Method in class bb.common.SwapOrderVO

getCarrierAccount() - Method in class bb.common.SwapReceiverListResult

getCarrierAccount() - Method in class bb.common.SwapReceiverVO

getCarrierAccount() - Method in class bb.common.SwapShipperListResult

getCarrierAccount() - Method in class bb.common.SwapShipperVO

getCarrierAccount() - Method in class bb.common.TransferOrderListResult

getCarrierAccount() - Method in class bb.common.TransferOrderVO

getCarrierAccount() - Method in class bb.common.TransferReceiverListResult

getCarrierAccount() - Method in class bb.common.TransferReceiverVO

getCarrierAccount() - Method in class bb.common.TransferShipperListResult

getCarrierAccount() - Method in class bb.common.TransferShipperVO

getCarrierAcct() - Method in class bb.common.AccountsReceivableInfoVO

getCarrierAcct() - Method in class bb.common.AccountsReceivableVO

getCarrierAcct() - Method in class bb.common.CustomerReturnToVendorVO

getCarrierAcct() - Method in class bb.common.OnLoanVO

getCarrierAcct() - Method in class bb.common.RequestForQuoteVO

getCarrierAcct() - Method in class bb.common.RequestForRMAVO

getCarrierAcct() - Method in class bb.common.ReturnMaterialAuthorizationVO

getCarrierAcct() - Method in class bb.common.RMAReceiverVO

getCarrierByPk(CarrierPK) - Method in interface bb.common.box.AddressBox

getCarriersCountByAddressId(String) - Method in interface bb.common.box.AddressBox

getCarsCount(String, String, String, String, Date, Date) - Method in interface bb.common.box.QualityBox

getCarsCountByCarNumber(String) - Method in interface bb.common.box.QualityBox

getCarsCountByPastDue() - Method in interface bb.common.box.QualityBox

getCarsCountByPn(String, String) - Method in interface bb.common.box.QualityBox

getCarsCountByStatus(String) - Method in interface bb.common.box.QualityBox

getCartType() - Method in class bb.common.PurchaseWorkSheetItemPK

getCartType() - Method in class bb.common.PurchaseWorkSheetPK

getCartType() - Method in class bb.common.WorkOrderWorkSheetItemPK

getCartType() - Method in class bb.common.WorkOrderWorkSheetPK

getCash() - Method in class bb.common.AccountingBalanceSheetResult

getCashCheckReceived() - Method in class bb.common.ExpenseVO

getCashEndPosition() - Method in class bb.common.TwelveMonthCashFlowReportResult

getCashier(String) - Method in interface bb.common.box.CompanyBox

getCashier() - Method in class bb.common.CashierVO

getCashier() - Method in class bb.common.GeneralLedgerByDateListResult

getCashPosition() - Method in class bb.common.TwelveMonthCashFlowReportResult

getCashTotal() - Method in class bb.common.MoneyInDrawResult

getCatalog(String) - Method in interface bb.common.box.SalesBox

getCatalog() - Method in class bb.common.PartCatalogAuditResult

getCatalog() - Method in class bb.common.PartCatalogVO

getCatalog() - Method in class bb.common.PartVO

getCatalog() - Method in class bb.common.PartWithOnhandsVO

getCatalog() - Method in class bb.common.SGDocPartVO

getCatalog() - Method in class bb.common.SGPartCatalogResult

getCatalog() - Method in class bb.common.SGSaleItemVO

getCatalogID() - Method in class bb.common.CatalogVO

getCatalogRev() - Method in class bb.common.SGDocPartVO

getCatalogsCount(String, String) - Method in interface bb.common.box.SalesBox

getCategory() - Method in class bb.common.AddressQualityDocumentsVO

getCategory() - Method in class bb.common.MiscDocAgent

getCategory() - Method in class bb.common.PartTraceableInfoResult

getCategoryDescription() - Method in class bb.common.PartTraceableCategoryVO

getCategoryId() - Method in class bb.common.AccountsChartVO

getCategoryId() - Method in class bb.common.JounalEntryListResult

getCategoryId() - Method in class bb.common.PartTraceableCategoryVO

getCategoryId() - Method in class bb.common.PartTraceableResult

getCategoryId() - Method in class bb.common.TraceableCategoriesVO

getCategoryName() - Method in class bb.common.AccountsChartCategoryVO

getCategoryName() - Method in class bb.common.GeneralLedgerPrintResult

getCategorySequence() - Method in class bb.common.AssetDepreciateVO

getCategorySequence() - Method in class bb.common.GeneralLedgerByDateListResult

getCategorySequence() - Method in class bb.common.GeneralLedgerListResult

getCategorySequence() - Method in class bb.common.GeneralLedgerPrintResult

getCategorySequence() - Method in class bb.common.GeneralLedgerVO

getCategorySequence() - Method in class bb.common.GLApprovalListResult

getCategorySequence() - Method in class bb.common.GLCatAndSequence

getCategorySequence() - Method in class bb.common.JounalEntryListResult

getCategoryType() - Method in class bb.common.AccountsChartCategoryVO

getCatTest() - Method in class bb.common.SGDocPartVO

getCatTestRv() - Method in class bb.common.SGDocPartVO

getCause() - Method in class bb.common.AccountCreditVO

getCause() - Method in class bb.common.AccountDebitVO

getCause() - Method in class bb.common.AccountsCreditDebitListResult

getCause() - Method in interface bb.common.Alarmable

getCause() - Method in class bb.common.APAuditListResult

getCause() - Method in class bb.common.ARAuditListResult

getCause() - Method in class bb.common.GLItemVO

getCause() - Method in class bb.common.LockedCustomerAddressResult

getCause() - Method in class bb.common.PartCatalogAuditResult

getCause() - Method in class bb.common.PartOnHandAuditResult

getCCode() - Method in class bb.common.PartInventoryVO

getCCode() - Method in class bb.common.ToolInventoryVO

getCcTotal() - Method in class bb.common.MoneyInDrawResult

getCertificateDate() - Method in class bb.common.PartCertificateVO

getCertificateDate() - Method in class bb.common.SerialNumberResult

getCertificateDescription() - Method in class bb.common.PartCertificateListResult

getCertificateDescription() - Method in class bb.common.PartCertificateVO

getCertificateName() - Method in class bb.common.CustomEmployeeTrainVO

getCertificateNumber() - Method in class bb.common.PartCertificateListResult

getCertificateNumber() - Method in class bb.common.PartCertificateVO

getCertificateNumber() - Method in class bb.common.SerialNumberItemVO

getCertificateStatus() - Method in class bb.common.CustomAssetVO

getCertificationId() - Method in class bb.common.CustomEmployeeTrainVO

getCertificationNumber() - Method in class bb.common.ToolCalibrationVO

getCertiName() - Method in class bb.common.EmployeeTrainingVO

getCertiNumber() - Method in class bb.common.EmployeeTrainingVO

getCf() - Method in class bb.common.GlCashFlowBudgetVO

getChangedByEngineer() - Method in class bb.common.EngineeringChangeRequestVO

getChangeMfg() - Method in class bb.common.CustomerReturnToVendorItemVO

getChangeMfg() - Method in class bb.common.PurchaseOrderItemVO

getChangeMfg() - Method in class bb.common.RequestForRMAItemVO

getChangeMfg() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getChangeMfg() - Method in class bb.common.ReturnToVendorItemVO

getChangeNote() - Method in class bb.common.RunningAccountOrderVO

getChangeOrder() - Method in class bb.common.AccountsPayableInfoVO

getChangeOrder() - Method in class bb.common.AccountsPayableVO

getChangeOrder() - Method in class bb.common.AccountsReceivableInfoVO

getChangeOrder() - Method in class bb.common.AccountsReceivableVO

getChangeOrder() - Method in class bb.common.CRTVListResult

getChangeOrder() - Method in class bb.common.CustomerReturnToVendorItemVO

getChangeOrder() - Method in class bb.common.CustomerReturnToVendorVO

getChangeOrder() - Method in class bb.common.DisassembleWorkOrderIssuingResult

getChangeOrder() - Method in class bb.common.DisassembleWorkOrderItemVO

getChangeOrder() - Method in class bb.common.DisassembleWorkOrderListResult

getChangeOrder() - Method in class bb.common.DisassembleWorkOrderReceivingResult

getChangeOrder() - Method in class bb.common.DisassembleWorkOrderVO

getChangeOrder() - Method in class bb.common.IssuingResult

getChangeOrder() - Method in class bb.common.LnShipperListResult

getChangeOrder() - Method in class bb.common.OnLoanItemVO

getChangeOrder() - Method in class bb.common.OnLoanListResult

getChangeOrder() - Method in class bb.common.OnloanReceiverVO

getChangeOrder() - Method in class bb.common.OnloanShipperVO

getChangeOrder() - Method in class bb.common.OnLoanVO

getChangeOrder() - Method in class bb.common.PfReceiverVO

getChangeOrder() - Method in class bb.common.PrepayAgent

getChangeOrder() - Method in class bb.common.ProformaInvoiceVO

getChangeOrder() - Method in class bb.common.PurchaseOrderItemVO

getChangeOrder() - Method in class bb.common.PurchaseOrderListResult

getChangeOrder() - Method in class bb.common.PurchaseOrderVO

getChangeOrder() - Method in class bb.common.QuoteItemVO

getChangeOrder() - Method in class bb.common.QuoteListResult

getChangeOrder() - Method in class bb.common.QuoteVO

getChangeOrder() - Method in class bb.common.ReceiverInfoVO

getChangeOrder() - Method in class bb.common.ReceiverVO

getChangeOrder() - Method in class bb.common.ReceivingResult

getChangeOrder() - Method in class bb.common.RequestForQuoteListResult

getChangeOrder() - Method in class bb.common.RequestForQuoteVO

getChangeOrder() - Method in class bb.common.RequestForRMAItemVO

getChangeOrder() - Method in class bb.common.RequestForRMAVO

getChangeOrder() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getChangeOrder() - Method in class bb.common.ReturnMaterialAuthorizationVO

getChangeOrder() - Method in class bb.common.ReturnToVendorItemVO

getChangeOrder() - Method in class bb.common.ReturnToVendorVO

getChangeOrder() - Method in class bb.common.RMAListResult

getChangeOrder() - Method in class bb.common.RMAReceiverVO

getChangeOrder() - Method in class bb.common.RRMAListResult

getChangeOrder() - Method in class bb.common.RtvShipperInfoVO

getChangeOrder() - Method in class bb.common.RtvShipperVO

getChangeOrder() - Method in class bb.common.SalesOrderItemInfoVO

getChangeOrder() - Method in class bb.common.SalesOrderItemVO

getChangeOrder() - Method in class bb.common.SalesOrderListResult

getChangeOrder() - Method in class bb.common.SalesOrderVO

getChangeOrder() - Method in class bb.common.ShipperInfoVO

getChangeOrder() - Method in class bb.common.ShipperListResult

getChangeOrder() - Method in class bb.common.ShipperVO

getChangeOrder() - Method in class bb.common.WoItemPickListResult

getChangeOrder() - Method in class bb.common.WorkOrderItemVO

getChangeOrder() - Method in class bb.common.WorkOrderListResult

getChangeOrder() - Method in class bb.common.WorkOrderVO

getChangePercent() - Method in class bb.common.ClosingStatementTotalResult

getChangePercent() - Method in class bb.common.ProfitLossStatementItemResult

getChangePercentOfBudget() - Method in class bb.common.ProfitLossStatementItemResult

getChangeRule() - Method in class bb.common.CompanyVO

getChanges() - Method in class bb.common.BizboxBugInfoVO

getChangeStdCostWorkSheet(Long) - Method in interface bb.common.box.AccountingBox

getChangeStdCostWorkSheetCount() - Method in interface bb.common.box.AccountingBox

getChangeStdCostWorkSheetItemCount(Long) - Method in interface bb.common.box.AccountingBox

getChangOrder() - Method in class bb.common.ShippingResult

getCheck() - Method in class bb.common.ApPrepayVO

getCheck() - Method in class bb.common.ArPrepayVO

getCheck() - Method in class bb.common.GeneralLedgerResult

getCheckAccountNumber() - Method in class bb.common.PayableMethodVO

getCheckAccountNumber() - Method in class bb.common.PaymentVO

getCheckAmount() - Method in class bb.common.PostCheckAgent

getChecked() - Method in class bb.common.AccountPayableCheckRunVO

getChecked() - Method in class bb.common.ARPaymentRunVO

getCheckedItem() - Method in class bb.common.BudgetListResult

getCheckListCount() - Method in interface bb.common.box.SalesBox

getCheckListCount() - Method in interface bb.common.box.WarehouseBox

getCheckNo() - Method in class bb.common.AccountsReceivableInfoVO

getCheckNo() - Method in class bb.common.AccountsReceivableVO

getCheckNo() - Method in class bb.common.OnloanReceiverVO

getCheckNo() - Method in class bb.common.ProformaInvoiceVO

getCheckNo() - Method in class bb.common.ReceiverInfoVO

getCheckNo() - Method in class bb.common.ReceiverVO

getCheckNo() - Method in class bb.common.RMAReceiverItemVO

getCheckNo() - Method in class bb.common.RMAReceiverVO

getCheckNo() - Method in class bb.common.RtvShipperItemVO

getCheckNumber() - Method in class bb.common.AccountPayableCheckRunItemVO

getCheckNumber() - Method in class bb.common.AccountPayableCheckRunVO

getCheckNumber() - Method in class bb.common.AccountPayableCheckVO

getCheckNumber() - Method in class bb.common.AccountsPayableInfoVO

getCheckNumber() - Method in class bb.common.AccountsPayableItemVO

getCheckNumber() - Method in class bb.common.AccountsPayableVO

getCheckNumber() - Method in class bb.common.AccountsReceivableItemVO

getCheckNumber() - Method in class bb.common.ApCheckRunListResult

getCheckNumber() - Method in class bb.common.DepositSummaryResult

getCheckNumber() - Method in class bb.common.GeneralLedgerByDateListResult

getCheckNumber() - Method in class bb.common.GeneralLedgerListResult

getCheckNumber() - Method in class bb.common.GeneralLedgerVO

getCheckNumber() - Method in class bb.common.MakeCheckAgent

getCheckNumber() - Method in class bb.common.MakePrepaymentCheckAgent

getCheckNumber() - Method in class bb.common.OnloanReceiverItemVO

getCheckNumber() - Method in class bb.common.OnloanShipperItemVO

getCheckNumber() - Method in class bb.common.OnloanShipperVO

getCheckNumber() - Method in class bb.common.PaymentAgent

getCheckNumber() - Method in class bb.common.PaymentInvoicesResult

getCheckNumber() - Method in class bb.common.PostCheckAgent

getCheckNumber() - Method in class bb.common.PrepayPaymentAgent

getCheckNumber() - Method in class bb.common.ReceiverItemVO

getCheckNumber() - Method in class bb.common.RtvShipperInfoVO

getCheckNumber() - Method in class bb.common.RtvShipperVO

getCheckNumber() - Method in class bb.common.RunningAccountOrderItemResult

getCheckNumber() - Method in class bb.common.RunningAccountOrderVO

getCheckNumber() - Method in class bb.common.ShipperInfoVO

getCheckNumber() - Method in class bb.common.ShipperItemVO

getCheckNumber() - Method in class bb.common.ShipperVO

getCheckNumberInt() - Method in class bb.common.AccountPayableCheckVO

getCheckPaid() - Method in class bb.common.ExpenseVO

getCheckPrintAdjust() - Method in class bb.common.AccountingSettingsVO

getCheckPrintAdjustX() - Method in class bb.common.AccountingSettingsVO

getCheckPrintAdjustY() - Method in class bb.common.AccountingSettingsVO

getCheckPrinted() - Method in class bb.common.GeneralLedgerListResult

getCheckPrinted() - Method in class bb.common.GeneralLedgerResult

getCheckPrinted() - Method in class bb.common.GeneralLedgerVO

getCheckRunItems() - Method in class bb.common.AccountPayableCheckRunVO

getCheckRunItemTotal(String) - Method in interface bb.common.box.AccountingBox

getCheckRunNumber() - Method in class bb.common.AccountPayableCheckRunVO

getCheckRunNumber() - Method in class bb.common.AccountPayableCheckVO

getCheckRunNumber() - Method in class bb.common.ApCheckRunListResult

getCheckRunNumber() - Method in class bb.common.GeneralLedgerVO

getCheckRunNumber() - Method in class bb.common.PayableCheckRunItemPK

getCheckRunNumber() - Method in class bb.common.PaymentInvoicesResult

getCheckTime() - Method in class bb.common.CustomCheckUpEmployeeVO

getCheckTotal() - Method in class bb.common.AccountPayableCheckRunItemVO

getCheckTotal() - Method in class bb.common.MoneyInDrawResult

getCheckType() - Method in class bb.common.GLCheckRegisterResult

getCity() - Method in class bb.common.AccountPayableCheckVO

getCity() - Method in class bb.common.AccountReceivablePaymentVO

getCity() - Method in class bb.common.CustomerVendorAddressInfoVO

getCity() - Method in class bb.common.CustomerVendorAddressVO

getCity() - Method in class bb.common.CustomerVendorDescriptionVO

getCity() - Method in class bb.common.EmployeeEducationVO

getCity() - Method in class bb.common.EmployeeHomeVO

getCity() - Method in class bb.common.IpAddressVO

getCity() - Method in class bb.common.LockedCustomerAddressResult

getCity() - Method in class bb.common.ManufacturerAddressInfoVO

getCity() - Method in class bb.common.ManufacturerAddressVO

getCity() - Method in class bb.common.ManufacturerDescriptionVO

getCity() - Method in class bb.common.SalesmanVO

getCity() - Method in class bb.common.SGCartCheckOutResult

getCity() - Method in class bb.common.SGCustRequestForQuoteListResult

getCity() - Method in class bb.common.SGCustRequestForQuoteResult

getCity() - Method in class bb.common.SGQuoteAddressResult

getCity() - Method in class bb.common.SGQuoteAddressVO

getCityCode() - Method in class bb.common.PosZipCodeTaxVO

getCityName() - Method in class bb.common.PosZipCodeTaxVO

getCityName() - Method in class bb.common.ZipcodeTotalsResult

getCityOrCountyCode() - Method in class bb.common.ZipcodeTotalsResult

getCityTaxRate() - Method in class bb.common.PosZipCodeTaxVO

getClazzName() - Method in class bb.common.PrintTemplateVO

getCleanWorker() - Method in class bb.common.InspectionReportInfoVO

getCleanWorker() - Method in class bb.common.InspectionReportVO

getClient() - Method in class bb.common.SGClientAccountPK

getClient() - Method in class bb.common.SGClientLogin

getClient() - Method in class bb.common.SGCompanyPK

getClient() - Method in class bb.common.SGCustRequestForQuoteVO

getClient() - Method in class bb.common.SGLogLoginVO

getClient() - Method in class bb.common.SGQuoteAddressVO

getClient() - Method in class bb.common.SGQuoteLoginVO

getClientIP() - Method in class bb.common.BB2Login

getClientMAC() - Method in class bb.common.BB2Login

getClientProperties() - Method in class bb.common.VO

getClientWanIp() - Method in class bb.common.BB2Login

getClinicaLab() - Method in class bb.common.CustomCheckUpEmployeeVO

getCloseDate() - Method in class bb.common.DesignControlInfoVO

getCloseDate() - Method in class bb.common.DesignControlVO

getClosedDate() - Method in class bb.common.CustomerServiceIncidentItemListResult

getClosedDate() - Method in class bb.common.CustomerServiceIncidentVO

getClosedOutApproval() - Method in class bb.common.NonConformanceReportVO

getClosedOutApproval() - Method in class bb.common.PreventiveActionRequestVO

getClosedOutBy() - Method in class bb.common.CorrectiveActionRequestVO

getClosedOutComments() - Method in class bb.common.CorrectiveActionRequestVO

getClosedOutComments() - Method in class bb.common.PreventiveActionRequestVO

getClosedOutDate() - Method in class bb.common.CorrectiveActionRequestVO

getClosedOutDate() - Method in class bb.common.EngineeringChangeRequestVO

getClosedOutDate() - Method in class bb.common.IcrItemListResult

getClosedOutDate() - Method in class bb.common.IcrListResult

getClosedOutDate() - Method in class bb.common.InspectionConformanceReportVO

getClosedOutDate() - Method in class bb.common.NcrReportListResult

getClosedOutDate() - Method in class bb.common.NonConformanceReportVO

getClosedOutDate() - Method in class bb.common.PreventiveActionRequestVO

getClosedOutPrivateNotes() - Method in class bb.common.CorrectiveActionRequestVO

getClosedOutPrivateNotes() - Method in class bb.common.EngineeringChangeRequestListResult

getClosedOutPrivateNotes() - Method in class bb.common.EngineeringChangeRequestVO

getClosedOutPrivateNotes() - Method in class bb.common.NcrReportListResult

getClosedOutPrivateNotes() - Method in class bb.common.NonConformanceReportVO

getClosedOutPrivateNotes() - Method in class bb.common.PreventiveActionRequestVO

getCloseTimeCardsCount(String, String, String, Date, Date, String, String) - Method in interface bb.common.box.ManufacturingBox

getCm() - Method in class bb.common.RMAReceiverItemListResult

getCm0() - Method in class bb.common.GeneralLedgerSettingsVO

getCm1() - Method in class bb.common.GeneralLedgerSettingsVO

getCm2() - Method in class bb.common.GeneralLedgerSettingsVO

getCMByDateCount(String, String, String, String, String, boolean, Date, Date) - Method in interface bb.common.box.AccountingBox

getCMByDateCount(String[]) - Method in interface bb.common.box.AccountingBox

getCMByPk(String) - Method in interface bb.common.box.AccountingBox

getCmDigits() - Method in class bb.common.CompanyVO

getCmDisc() - Method in class bb.common.RMAReceiverItemVO

getCmDisc() - Method in class bb.common.RMAReceiverVO

getCmFreight() - Method in class bb.common.RMAReceiverVO

getCmGl1Recorded() - Method in class bb.common.RMAReceiverVO

getCmGl2Paid() - Method in class bb.common.RMAReceiverVO

getCMItemByDateCount(String, String, String, String, String, String, boolean, Date, Date) - Method in interface bb.common.box.AccountingBox

getCmNet() - Method in class bb.common.RMAReceiverItemVO

getCmNet() - Method in class bb.common.RMAReceiverVO

getCmNetSet() - Method in class bb.common.RMAReceiverVO

getCmOpen() - Method in class bb.common.RMAReceiverItemVO

getCmOpen() - Method in class bb.common.RMAReceiverVO

getCmPaidGl() - Method in class bb.common.RMAReceiverVO

getCmPaidRcv() - Method in class bb.common.RMAReceiverVO

getCmPrefix() - Method in class bb.common.CompanyVO

getCmRcvd() - Method in class bb.common.RMAReceiverItemVO

getCmRcvd() - Method in class bb.common.RMAReceiverVO

getCMsByCustomerIdCount(String) - Method in interface bb.common.box.AccountingBox

getCMsCountByCMNumber(String) - Method in interface bb.common.box.AccountingBox

getCmSub() - Method in class bb.common.RMAReceiverItemVO

getCmSub() - Method in class bb.common.RMAReceiverVO

getCmTax() - Method in class bb.common.RMAReceiverItemVO

getCmTax() - Method in class bb.common.RMAReceiverVO

getCmTaxSet() - Method in class bb.common.RMAReceiverVO

getCmTotal() - Method in class bb.common.RMAReceiverItemVO

getCmTotal() - Method in class bb.common.RMAReceiverVO

getCoComments() - Method in class bb.common.AccountsPayableVO

getCoComments() - Method in class bb.common.AccountsReceivableVO

getCoComments() - Method in class bb.common.CustomerReturnToVendorVO

getCoComments() - Method in class bb.common.DisassembleWorkOrderVO

getCoComments() - Method in class bb.common.OnloanReceiverVO

getCoComments() - Method in class bb.common.OnloanShipperVO

getCoComments() - Method in class bb.common.PurchaseOrderVO

getCoComments() - Method in class bb.common.QuoteVO

getCoComments() - Method in class bb.common.ReceiverVO

getCoComments() - Method in class bb.common.RequestForQuoteVO

getCoComments() - Method in class bb.common.RequestForRMAVO

getCoComments() - Method in class bb.common.ReturnMaterialAuthorizationVO

getCoComments() - Method in class bb.common.ReturnToVendorVO

getCoComments() - Method in class bb.common.RMAReceiverVO

getCoComments() - Method in class bb.common.RtvShipperInfoVO

getCoComments() - Method in class bb.common.RtvShipperVO

getCoComments() - Method in class bb.common.SalesOrderVO

getCoComments() - Method in class bb.common.ShipperVO

getCoComments() - Method in class bb.common.SwapReceiverListResult

getCoComments() - Method in class bb.common.SwapReceiverVO

getCoComments() - Method in class bb.common.SwapShipperListResult

getCoComments() - Method in class bb.common.SwapShipperVO

getCoComments() - Method in class bb.common.TransferReceiverListResult

getCoComments() - Method in class bb.common.TransferReceiverVO

getCoComments() - Method in class bb.common.TransferShipperListResult

getCoComments() - Method in class bb.common.TransferShipperVO

getCoComments() - Method in class bb.common.WorkOrderVO

getCode() - Method in class bb.common.NonConformanceCodeDescriptionPK

getCode() - Method in class bb.common.NonConformanceCodeVO

getCollect() - Method in class bb.common.AccountsPayableInfoVO

getCollect() - Method in class bb.common.AccountsPayableVO

getCollect() - Method in class bb.common.OnloanReceiverVO

getCollect() - Method in class bb.common.ReceiverInfoVO

getCollect() - Method in class bb.common.ReceiverVO

getCollect() - Method in class bb.common.RMAReceiverVO

getCollectionFieldGenericType(Field) - Static method in class bb.common.BB2Util

getCollege() - Method in class bb.common.EmployeeEducationVO

getColumns() - Method in class bb.common.TwelveMonthCashFlowReportResult

getCommanyName() - Method in class bb.common.SerialNumberItemPK

getCommanyName() - Method in class bb.common.SerialNumberPK

getComment() - Method in class bb.common.AccountPayableCheckVO

getComment() - Method in class bb.common.BizBoxUserEmployeeResult

getComment() - Method in class bb.common.BizboxUserListResult

getComment() - Method in class bb.common.BizboxUserVO

getComment() - Method in class bb.common.CustomCheckUpEmployeeVO

getComment() - Method in class bb.common.EmployeeHomeVO

getComment() - Method in class bb.common.ExpenseItemVO

getComment() - Method in class bb.common.OperationLogVO

getComment() - Method in class bb.common.PartVO

getComment() - Method in class bb.common.PartWithOnhandsVO

getComment() - Method in class bb.common.PurchaseOrderContractResult

getComment() - Method in class bb.common.SalesOrderItemListResult

getComment() - Method in class bb.common.ShipperItemAgent

getComment() - Method in class bb.common.ToolCalibrationVO

getComment() - Method in class bb.common.ToolVO

getComment() - Method in class bb.common.ToolWithOnhandsVO

getComment() - Method in class bb.common.WorkCalendarVO

getComment() - Method in class bb.common.WorkInstructionVO

getComment() - Method in class bb.common.WorkOrderWorkInstructionVO

getComments() - Method in class bb.common.AccountingInfoDocumentVO

getComments() - Method in class bb.common.AccountsChartMappingVO

getComments() - Method in class bb.common.AccountsPayableInfoVO

getComments() - Method in class bb.common.AccountsPayableItemVO

getComments() - Method in class bb.common.AccountsPayableVO

getComments() - Method in class bb.common.AllPartDocumentsVO

getComments() - Method in class bb.common.ApPrepayItemVO

getComments() - Method in class bb.common.ArPrepayItemVO

getComments() - Method in class bb.common.AssetVO

getComments() - Method in class bb.common.BB2Document

getComments() - Method in class bb.common.BillItemVO

getComments() - Method in class bb.common.BillItemWithPartInfoResult

getComments() - Method in class bb.common.BomApprovalVO

getComments() - Method in class bb.common.BuyerCodeVO

getComments() - Method in class bb.common.ChangeStdCostWorkSheetVO

getComments() - Method in class bb.common.CompanyUnitVO

getComments() - Method in class bb.common.ContractPriceItemVO

getComments() - Method in class bb.common.CRTVListResult

getComments() - Method in class bb.common.CustomAssetVO

getComments() - Method in class bb.common.CustomEmployeeVO

getComments() - Method in class bb.common.CustomerFeedbackVO

getComments() - Method in class bb.common.CustomerReturnToVendorVO

getComments() - Method in class bb.common.CustomerVendorAddressInfoVO

getComments() - Method in class bb.common.CustomerVendorAddressVO

getComments() - Method in class bb.common.CustomerVendorContactVO

getComments() - Method in class bb.common.CustomerVendorTypeVO

getComments() - Method in class bb.common.CustomGoodsBreedVO

getComments() - Method in class bb.common.CustomJobCategoryVO

getComments() - Method in class bb.common.DesignControlDocumentVO

getComments() - Method in class bb.common.DisassembleWorkOrderDocumentVO

getComments() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getComments() - Method in class bb.common.DisassembleWorkOrderItemListResult

getComments() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

getComments() - Method in class bb.common.DocumentInfoAgent

getComments() - Method in class bb.common.ECNReviewVO

getComments() - Method in class bb.common.ECRReviewVO

getComments() - Method in class bb.common.EjbMethodVO

getComments() - Method in class bb.common.EmployeeCardVO

getComments() - Method in class bb.common.EmployeeLaborAgent

getComments() - Method in class bb.common.EmployeeRecordsVO

getComments() - Method in class bb.common.EngGroupUserVO

getComments() - Method in class bb.common.EngineeringChangeDocumentVO

getComments() - Method in class bb.common.EngineeringChangeRequestDocumentVO

getComments() - Method in class bb.common.EngineeringSharingVO

getComments() - Method in class bb.common.GeneralLedgerApprovalVO

getComments() - Method in class bb.common.GeneralLedgerListResult

getComments() - Method in class bb.common.GeneralLedgerVO

getComments() - Method in class bb.common.IcrItemListResult

getComments() - Method in class bb.common.IcrListResult

getComments() - Method in class bb.common.InspectionConformanceReportItemVO

getComments() - Method in class bb.common.InspectionConformanceReportVO

getComments() - Method in class bb.common.InventoryAdjustmentVO

getComments() - Method in class bb.common.InventoryPartInOutDetailListResult

getComments() - Method in class bb.common.LabelTemplateVO

getComments() - Method in class bb.common.LnShipperListResult

getComments() - Method in class bb.common.LockedCustomerAddressResult

getComments() - Method in class bb.common.LogTaskVO

getComments() - Method in class bb.common.ManufacturerAddressInfoVO

getComments() - Method in class bb.common.ManufacturerAddressVO

getComments() - Method in class bb.common.ManufacturerContactVO

getComments() - Method in class bb.common.MiscDocAgent

getComments() - Method in class bb.common.NcrApprovalVO

getComments() - Method in class bb.common.NCRPictureListResult

getComments() - Method in class bb.common.NCRPictureVO

getComments() - Method in class bb.common.NonproductivePickingApprovalVO

getComments() - Method in class bb.common.NonproductivePickingItemResult

getComments() - Method in class bb.common.NonproductivePickingItemVO

getComments() - Method in class bb.common.NonproductivePickingVO

getComments() - Method in class bb.common.OnloanDocumentVO

getComments() - Method in class bb.common.OnLoanListResult

getComments() - Method in class bb.common.OnloanReceiverItemListResult

getComments() - Method in class bb.common.OnloanReceiverItemVO

getComments() - Method in class bb.common.OnloanReceiverListResult

getComments() - Method in class bb.common.OnloanReceiverVO

getComments() - Method in class bb.common.OrderDocumentVO

getComments() - Method in class bb.common.PartCatalogVO

getComments() - Method in class bb.common.PartCertificateVO

getComments() - Method in class bb.common.PartClassVO

getComments() - Method in class bb.common.PartDiscountVO

getComments() - Method in class bb.common.PartDocumentVO

getComments() - Method in class bb.common.PartInQAAgent

getComments() - Method in class bb.common.PartInQAResult

getComments() - Method in class bb.common.PartInQAVO

getComments() - Method in class bb.common.PaymentAgent

getComments() - Method in class bb.common.PfReceiverVO

getComments() - Method in class bb.common.PO2SOExchange

getComments() - Method in class bb.common.PoMessageItemVO

getComments() - Method in class bb.common.PoMessageListResult

getComments() - Method in class bb.common.PoMessageVO

getComments() - Method in class bb.common.POStatisticsResult

getComments() - Method in class bb.common.POSurveyReportVO

getComments() - Method in class bb.common.PrepayPaymentAgent

getComments() - Method in class bb.common.PrintTemplateVO

getComments() - Method in class bb.common.ProformaInvoiceListResult

getComments() - Method in class bb.common.ProformaInvoiceVO

getComments() - Method in class bb.common.PrReceiverListResult

getComments() - Method in class bb.common.PrReceiverWithQualityListResult

getComments() - Method in class bb.common.PurchaseOrderApprovalVO

getComments() - Method in class bb.common.PurchaseOrderCheckListResult

getComments() - Method in class bb.common.PurchaseOrderDocumentVO

getComments() - Method in class bb.common.PurchaseOrderListResult

getComments() - Method in class bb.common.PurchaseWorkSheetItemVO

getComments() - Method in class bb.common.QuoteDocumentVO

getComments() - Method in class bb.common.QuoteListResult

getComments() - Method in class bb.common.ReceiverItemAgent

getComments() - Method in class bb.common.ReceiverItemVO

getComments() - Method in class bb.common.ReceiverVO

getComments() - Method in class bb.common.ReceivingItemResult

getComments() - Method in class bb.common.RequestForQuoteCheckListResult

getComments() - Method in class bb.common.RequestForQuoteItemListResult

getComments() - Method in class bb.common.RequestForQuoteListResult

getComments() - Method in class bb.common.RequestForRMAVO

getComments() - Method in class bb.common.ReturnMaterialAuthorizationDocumentVO

getComments() - Method in class bb.common.ReturnToVendorCheckListResult

getComments() - Method in class bb.common.ReturnToVendorItemListResult

getComments() - Method in class bb.common.ReturnToVendorListResult

getComments() - Method in class bb.common.RfqMessageItemVO

getComments() - Method in class bb.common.RfqMessageListResult

getComments() - Method in class bb.common.RfqMessageVO

getComments() - Method in class bb.common.RMAListResult

getComments() - Method in class bb.common.RMAReceiverItemListResult

getComments() - Method in class bb.common.RMAReceiverItemVO

getComments() - Method in class bb.common.RMAReceiverListResult

getComments() - Method in class bb.common.RMAReceiverVO

getComments() - Method in class bb.common.RMAReviewVO

getComments() - Method in class bb.common.RRMAListResult

getComments() - Method in class bb.common.RTVApprovalVO

getComments() - Method in class bb.common.RtvShipperInfoVO

getComments() - Method in class bb.common.RtvShipperItemListResult

getComments() - Method in class bb.common.RtvShipperItemVO

getComments() - Method in class bb.common.RtvShipperListResult

getComments() - Method in class bb.common.RtvShipperVO

getComments() - Method in class bb.common.RunningAccountOrderItemResult

getComments() - Method in class bb.common.RunningAccountOrderVO

getComments() - Method in class bb.common.SalesCodeVO

getComments() - Method in class bb.common.SalesmanVO

getComments() - Method in class bb.common.SalesOrderDocumentVO

getComments() - Method in class bb.common.SalesOrderListResult

getComments() - Method in class bb.common.SerialNumberResult

getComments() - Method in class bb.common.SGCustomerCatalogVO

getComments() - Method in class bb.common.SGCustRequestForQuoteListResult

getComments() - Method in class bb.common.SGCustRequestForQuoteResult

getComments() - Method in class bb.common.SGCustRequestForQuoteVO

getComments() - Method in class bb.common.SGPartCatalogResult

getComments() - Method in class bb.common.SGSaleItemVO

getComments() - Method in class bb.common.ShipListInfoVO

getComments() - Method in class bb.common.ShipListItemVO

getComments() - Method in class bb.common.ShipListVO

getComments() - Method in class bb.common.ShipperListResult

getComments() - Method in class bb.common.ShippingItemResult

getComments() - Method in class bb.common.SmtpServerVO

getComments() - Method in class bb.common.StockTransactionAdjustmentResult

getComments() - Method in class bb.common.SwapOrderApprovalVO

getComments() - Method in class bb.common.SwapOrderListResult

getComments() - Method in class bb.common.SwapOrderVO

getComments() - Method in class bb.common.SwapReceiverListResult

getComments() - Method in class bb.common.SwapReceiverVO

getComments() - Method in class bb.common.SwapShipperListResult

getComments() - Method in class bb.common.SwapShipperVO

getComments() - Method in class bb.common.TaskVO

getComments() - Method in class bb.common.TermAgent

getComments() - Method in class bb.common.TermVO

getComments() - Method in class bb.common.TransferOrderApprovalVO

getComments() - Method in class bb.common.TransferOrderListResult

getComments() - Method in class bb.common.TransferOrderVO

getComments() - Method in class bb.common.User2UserAgent

getComments() - Method in class bb.common.VendorContractPriceItemVO

getComments() - Method in class bb.common.WarehouseVO

getComments() - Method in class bb.common.WoItemPickListItemResult

getComments() - Method in class bb.common.WOReceiverDetail

getComments() - Method in class bb.common.WorkInstructionApprovalVO

getComments() - Method in class bb.common.WorkInstructionDocumentVO

getComments() - Method in class bb.common.WorkOrderCheckListResult

getComments() - Method in class bb.common.WorkOrderDocumentVO

getComments() - Method in class bb.common.WorkOrderItemIssueVO

getComments() - Method in class bb.common.WorkOrderItemListResult

getComments() - Method in class bb.common.WorkOrderItemPartDetailItemResult

getComments() - Method in class bb.common.WorkOrderItemTimeDetailVO

getComments() - Method in class bb.common.WorkOrderListResult

getComments() - Method in class bb.common.WorkOrderWorkSheetItemVO

getCommission() - Method in class bb.common.GeneralLedgerListResult

getCommission() - Method in class bb.common.GeneralLedgerResult

getCommission() - Method in class bb.common.GeneralLedgerVO

getCommission() - Method in class bb.common.SalesmanVO

getCommissionRate() - Method in class bb.common.ArCommissionListResult

getCommissionRate() - Method in class bb.common.SalesCodeVO

getCommissionTotal() - Method in class bb.common.ArCommissionTotalResult

getCommissionTotal() - Method in class bb.common.ArSalesCodeTotalListResult

getCommitCycleCountListResultsCount(int, boolean) - Method in interface bb.common.box.WarehouseBox

getCommitPhysicalInventoryListResultsCount(int, boolean) - Method in interface bb.common.box.WarehouseBox

getCommittedBy() - Method in class bb.common.ChangeStdCostWorkSheetVO

getCommittedBy() - Method in class bb.common.RollUpBomStdCostWorkSheetVO

getCommittedDate() - Method in class bb.common.ChangeStdCostWorkSheetVO

getCommittedDate() - Method in class bb.common.RollUpBomStdCostWorkSheetVO

getCommodityCode() - Method in class bb.common.InventoryListResult

getCommodityCode() - Method in class bb.common.MrpReportAgent

getCommodityCode() - Method in class bb.common.PartBasicInfo

getCommodityCode() - Method in class bb.common.PartVO

getCommodityCode() - Method in class bb.common.PartWithOnhandsVO

getCommodityCode() - Method in class bb.common.PurchaseOrderItemVO

getCommodityCode() - Method in class bb.common.RunningAccountOrderItemVO

getCommodityCode() - Method in class bb.common.SalesOrderItemGroupByPartListResult

getCommodityCode() - Method in class bb.common.SalesOrderItemListResult

getCommodityCode() - Method in class bb.common.SalesOrderItemVO

getCommodityCode() - Method in class bb.common.SGPartCatalogResult

getCommodityCode() - Method in class bb.common.ToolVO

getCommodityCode() - Method in class bb.common.ToolWithOnhandsVO

getCommonPrintTemplate(int) - Method in interface bb.common.box.CompanyBox

getCommonPrintTemplateCount() - Method in interface bb.common.box.CompanyBox

getCompany() - Method in class bb.common.RequestForQuoteItemVO

getCompany() - Method in class bb.common.SalesmanVO

getCompanyAddressBookCount() - Method in interface bb.common.box.HumanResourceBox

getCompanyAddressBookName() - Method in class bb.common.EmployeeCardVO

getCompanyAge(Date) - Static method in class bb.common.CustomEmployeeVO

getCompanyHome() - Method in interface bb.common.box.CompanyBox

getCompanyHome() - Method in class bb.common.CompanyVO

getCompanyHomes() - Method in class bb.common.SGDocPartVO

getCompanyHomesRev() - Method in class bb.common.SGDocPartVO

getCompanyId() - Method in class bb.common.CompanyVO

getCompanyId() - Method in class bb.common.EngineeringSharingItemPK

getCompanyId() - Method in class bb.common.EngineeringSharingVO

getCompanyName() - Method in class bb.common.CompanyVO

getCompanyName() - Method in class bb.common.CustomEmployeeWorkExperienceVO

getCompanyName() - Method in class bb.common.EmployeeWorkExperienceVO

getCompanyName() - Method in class bb.common.EngineeringSharingVO

getCompanyName() - Method in class bb.common.PartCertificateListResult

getCompanyName() - Method in class bb.common.PartCertificateVO

getCompanyName() - Method in class bb.common.SerialNumberItemResult

getCompanyName() - Method in class bb.common.SerialNumberResult

getCompanyName() - Method in class bb.common.SubcompanyVO

getCompanySettings() - Method in interface bb.common.box.CompanyBox

getCompanyUnit() - Method in class bb.common.AssetAmortizationExpenseAccountVO

getCompanyUnit() - Method in class bb.common.GLCheckRegisterResult

getCompanyUnitAccountByAccount() - Method in interface bb.common.box.CompanyBox

getCompanyUnitAccountByCompanyUnit(String) - Method in interface bb.common.box.CompanyBox

getCompanyUnitAccountByPk(CompanyUnitAccountPK) - Method in interface bb.common.box.CompanyBox

getCompanyUnitAccountWithChild(String) - Method in interface bb.common.box.CompanyBox

getCompanyUnitByPk(String) - Method in interface bb.common.box.CompanyBox

getCompanyUnitId() - Method in class bb.common.AccountBalanceListResult

getCompanyUnitId() - Method in class bb.common.AccountCreditVO

getCompanyUnitId() - Method in class bb.common.AccountDebitVO

getCompanyUnitId() - Method in class bb.common.AccountingInfoDocumentVO

getCompanyUnitId() - Method in class bb.common.AccountMonthPK

getCompanyUnitId() - Method in class bb.common.AccountPayableCheckVO

getCompanyUnitId() - Method in class bb.common.AccountPayableInfoWithPrepayResult

getCompanyUnitId() - Method in class bb.common.AccountReceivableInfoWithPrepayResult

getCompanyUnitId() - Method in class bb.common.AccountsPayableInfoVO

getCompanyUnitId() - Method in class bb.common.AccountsPayableVO

getCompanyUnitId() - Method in class bb.common.AccountsReceivableInfoVO

getCompanyUnitId() - Method in class bb.common.AccountsReceivableVO

getCompanyUnitId() - Method in class bb.common.AddPayableWithoutReceiverAgent

getCompanyUnitId() - Method in class bb.common.APItemListResult

getCompanyUnitId() - Method in class bb.common.APPrepayInfoResult

getCompanyUnitId() - Method in class bb.common.ApPrepayVO

getCompanyUnitId() - Method in class bb.common.ARPrepayInfoResult

getCompanyUnitId() - Method in class bb.common.ArPrepayVO

getCompanyUnitId() - Method in class bb.common.BizboxUserVO

getCompanyUnitId() - Method in class bb.common.ClosingStatementResult

getCompanyUnitId() - Method in class bb.common.CompanyUnitAccountPK

getCompanyUnitId() - Method in class bb.common.CRTVItemListResult

getCompanyUnitId() - Method in class bb.common.CustomerReturnToVendorVO

getCompanyUnitId() - Method in class bb.common.DepositSummaryResult

getCompanyUnitId() - Method in class bb.common.DisassembleWorkOrderIssueVO

getCompanyUnitId() - Method in class bb.common.DisassembleWorkOrderIssuingResult

getCompanyUnitId() - Method in class bb.common.DisassembleWorkOrderItemListResult

getCompanyUnitId() - Method in class bb.common.DisassembleWorkOrderVO

getCompanyUnitId() - Method in class bb.common.DWOIssueDetail

getCompanyUnitId() - Method in class bb.common.ExchangeAuditResult

getCompanyUnitId() - Method in class bb.common.ExpenseAccountVO

getCompanyUnitId() - Method in class bb.common.GeneralLedgerByDateListResult

getCompanyUnitId() - Method in class bb.common.GLItemVO

getCompanyUnitId() - Method in class bb.common.InvoiceItemListResult

getCompanyUnitId() - Method in class bb.common.LogMiscDocumentVO

getCompanyUnitId() - Method in class bb.common.MakeBillAndHoldInvoiceAgent

getCompanyUnitId() - Method in class bb.common.MakeCreditMemoAgent

getCompanyUnitId() - Method in class bb.common.MakeDebitMemoAgent

getCompanyUnitId() - Method in class bb.common.MakeInvoiceAgent

getCompanyUnitId() - Method in class bb.common.MiscDocAgent

getCompanyUnitId() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getCompanyUnitId() - Method in class bb.common.NonproductivePickingItemResult

getCompanyUnitId() - Method in class bb.common.NonproductivePickingTypeVO

getCompanyUnitId() - Method in class bb.common.NonproductivePickingVO

getCompanyUnitId() - Method in class bb.common.OnloanReceiverVO

getCompanyUnitId() - Method in class bb.common.OnloanShipperVO

getCompanyUnitId() - Method in class bb.common.OnLoanVO

getCompanyUnitId() - Method in class bb.common.PayableMethodVO

getCompanyUnitId() - Method in class bb.common.PaymentAgent

getCompanyUnitId() - Method in class bb.common.POReceiverItemListResult

getCompanyUnitId() - Method in class bb.common.PrepayPaymentAgent

getCompanyUnitId() - Method in class bb.common.ProfitLossStatementResult

getCompanyUnitId() - Method in class bb.common.PurchaseOrderItemListResult

getCompanyUnitId() - Method in class bb.common.PurchaseOrderVO

getCompanyUnitId() - Method in class bb.common.PurchaseWorkSheetVO

getCompanyUnitId() - Method in class bb.common.QuoteVO

getCompanyUnitId() - Method in class bb.common.ReceiverVO

getCompanyUnitId() - Method in class bb.common.ReceivingResult

getCompanyUnitId() - Method in class bb.common.RequestForQuoteVO

getCompanyUnitId() - Method in class bb.common.RequestForRMAVO

getCompanyUnitId() - Method in class bb.common.ReturnMaterialAuthorizationVO

getCompanyUnitId() - Method in class bb.common.ReturnToVendorByDateListResult

getCompanyUnitId() - Method in class bb.common.ReturnToVendorVO

getCompanyUnitId() - Method in class bb.common.RMAItemListResult

getCompanyUnitId() - Method in class bb.common.RMAReceiverVO

getCompanyUnitId() - Method in class bb.common.RRMAItemListResult

getCompanyUnitId() - Method in class bb.common.RtvShipperVO

getCompanyUnitId() - Method in class bb.common.SalesmanVO

getCompanyUnitId() - Method in class bb.common.SalesOrderItemListResult

getCompanyUnitId() - Method in class bb.common.SalesOrderVO

getCompanyUnitId() - Method in class bb.common.ShipperItemListResult

getCompanyUnitId() - Method in class bb.common.ShipperVO

getCompanyUnitId() - Method in class bb.common.TempArApAgingVO

getCompanyUnitId() - Method in class bb.common.WOReceiverDetail

getCompanyUnitId() - Method in class bb.common.WorkOrderItemListResult

getCompanyUnitId() - Method in class bb.common.WorkOrderItemPartDetailInWipVO

getCompanyUnitId() - Method in class bb.common.WorkOrderReceiverVO

getCompanyUnitId() - Method in class bb.common.WorkOrderVO

getCompanyUnitId() - Method in class bb.common.WorkOrderWorkSheetVO

getCompanyUnitIDBySalesman(String) - Method in interface bb.common.box.SalesBox

getCompanyUnitListCount(String, String, String) - Method in interface bb.common.box.CompanyBox

getCompanyUnitOfAcc() - Method in class bb.common.MakeCheckAgent

getCompanyUnitOfAcc() - Method in class bb.common.MakePrepaymentCheckAgent

getCompanyUnitOfAmorExpenseAcc() - Method in class bb.common.AssetDepreciateVO

getCompanyUnitOfAmorExpenseAcc() - Method in class bb.common.AssetVO

getCompanyUnitOfCreditAcc() - Method in class bb.common.ARPrepaymentWireTransferAgent

getCompanyUnitOfCreditAcc() - Method in class bb.common.PostCheckAgent

getCompanyUnitOfCreditAcc() - Method in class bb.common.PrepaymentWireTransferAgent

getCompanyUnitOfDebitAcc() - Method in class bb.common.ARPrepaymentWireTransferAgent

getCompanyUnitOfDebitAcc() - Method in class bb.common.MakeAccountPayableAgent

getCompanyUnitOfDebitAcc() - Method in class bb.common.MakeCheckAgent

getCompanyUnitOfDebitAcc() - Method in class bb.common.PostCheckAgent

getCompanyUnitOfDebitAcc() - Method in class bb.common.PrepaymentWireTransferAgent

getCompanyUnitOfGaAp() - Method in class bb.common.AccountPayableCheckRunVO

getCompanyUnitOfGaAr() - Method in class bb.common.ARPaymentRunVO

getCompanyUnitOfGaChecking() - Method in class bb.common.AccountPayableCheckRunVO

getCompanyUnitOfGaChecking() - Method in class bb.common.AccountReceivablePaymentVO

getCompanyUnitOfGaChecking() - Method in class bb.common.ARPaymentRunVO

getCompanyUnitOfGlAcc() - Method in class bb.common.AssetVO

getCompanyUnitOfTransferFeeAcc() - Method in class bb.common.ARPrepaymentWireTransferAgent

getCompanyUnitOfTransferFeeAcc() - Method in class bb.common.PrepaymentWireTransferAgent

getCompanyUnitOfTransferFeeAcc() - Method in class bb.common.WireTransferAgent

getCompanyUnitOfWireFeeAcc() - Method in class bb.common.ARPaymentRunVO

getCompanyUnitsByAccountNumber(String) - Method in interface bb.common.box.CompanyBox

getCompletedDate() - Method in class bb.common.DisassembleWorkOrderItemListResult

getCompletedDate() - Method in class bb.common.WorkOrderItemListResult

getCompletePercent() - Method in class bb.common.WorkOrderItemSeqWCLoadResult

getCompletePercent() - Method in class bb.common.WorkOrderWorkInstructionSequenceDateAgent

getComputerId() - Method in class bb.common.MoneyInDrawResult

getComputerId() - Method in class bb.common.RunningAccountOrderVO

getCondition() - Method in class bb.common.AccountsPayableItemVO

getCondition() - Method in class bb.common.DisassembleWorkOrderIssueVO

getCondition() - Method in class bb.common.OnloanReceiverItemVO

getCondition() - Method in class bb.common.ReceiverItemAgent

getCondition() - Method in class bb.common.ReceiverItemVO

getCondition() - Method in class bb.common.RMAReceiverItemVO

getCondition() - Method in class bb.common.WorkOrderReceiverVO

getConditionAcknowledgedBy() - Method in class bb.common.CorrectiveActionRequestVO

getConditionDes() - Method in class bb.common.SGCustomerCatalogVO

getConditionDes() - Method in class bb.common.SGPartCatalogResult

getConditionDescription() - Method in class bb.common.CorrectiveActionRequestVO

getConditionDescription() - Method in class bb.common.PreventiveActionRequestVO

getConditionNotedBy() - Method in class bb.common.CorrectiveActionRequestVO

getConsignedQty() - Method in class bb.common.HistoricalInventoryVO

getConsignedQty() - Method in class bb.common.PartInventoryVO

getConsignedQty() - Method in class bb.common.ToolInventoryVO

getContact() - Method in class bb.common.AccountsReceivableInfoVO

getContact() - Method in class bb.common.AccountsReceivableVO

getContact() - Method in class bb.common.CSRAgent

getContact() - Method in class bb.common.CustomerReturnToVendorVO

getContact() - Method in class bb.common.DisassembleWorkOrderVO

getContact() - Method in class bb.common.EngineeringSharingVO

getContact() - Method in class bb.common.OnLoanVO

getContact() - Method in class bb.common.PfReceiverVO

getContact() - Method in class bb.common.PO2SOExchange

getContact() - Method in class bb.common.POStatisticsResult

getContact() - Method in class bb.common.ProformaInvoiceVO

getContact() - Method in class bb.common.PrReceiverListResult

getContact() - Method in class bb.common.PurchaseOrderVO

getContact() - Method in class bb.common.QuoteVO

getContact() - Method in class bb.common.RequestForQuoteVO

getContact() - Method in class bb.common.RequestForRMAVO

getContact() - Method in class bb.common.ReturnMaterialAuthorizationVO

getContact() - Method in class bb.common.ReturnToVendorVO

getContact() - Method in class bb.common.RunningAccountOrderItemResult

getContact() - Method in class bb.common.RunningAccountOrderVO

getContact() - Method in class bb.common.SalesOrderVO

getContact() - Method in class bb.common.SGCustomerServiceRequestVO

getContact() - Method in class bb.common.SO2SOAgent

getContact() - Method in class bb.common.SwapOrderListResult

getContact() - Method in class bb.common.SwapOrderVO

getContact() - Method in class bb.common.SwapReceiverListResult

getContact() - Method in class bb.common.SwapReceiverVO

getContact() - Method in class bb.common.SwapShipperListResult

getContact() - Method in class bb.common.SwapShipperVO

getContact() - Method in class bb.common.TransferOrderListResult

getContact() - Method in class bb.common.TransferOrderVO

getContact() - Method in class bb.common.TransferShipperVO

getContact() - Method in class bb.common.WorkOrderVO

getContactDate() - Method in class bb.common.CustomerFeedbackVO

getContactName() - Method in class bb.common.SGCartCheckOutResult

getContactName() - Method in class bb.common.SGCustRequestForQuoteListResult

getContactName() - Method in class bb.common.SGCustRequestForQuoteResult

getContactName() - Method in class bb.common.SGCustRequestForQuoteVO

getContactName() - Method in class bb.common.SGQuoteAddressResult

getContactName() - Method in class bb.common.SGQuoteAddressVO

getContactPerson() - Method in class bb.common.SubcompanyVO

getContacts() - Method in class bb.common.AllStatementsListResult

getContacts() - Method in class bb.common.CustomerVendorAddressVO

getContacts() - Method in class bb.common.ManufacturerAddressVO

getContainerNumber() - Method in class bb.common.PfReceiverVO

getContainerNumber() - Method in class bb.common.ProformaInvoiceVO

getContainerSealNumber() - Method in class bb.common.PfReceiverVO

getContainerSealNumber() - Method in class bb.common.ProformaInvoiceVO

getContent() - Method in class bb.common.BB2BugNotice

getContent() - Method in class bb.common.EngineeringSharingImportLogVO

getContext() - Method in class bb.common.BB2File

getContext() - Method in class bb.common.MessageAgent

getContext() - Method in class bb.common.MessageVO

getContract() - Method in class bb.common.PurchaseOrderContractResult

getContractAmount() - Method in class bb.common.PurchaseOrderContractResult

getContractCustomersCountByContractNumber(String) - Method in interface bb.common.box.SalesBox

getContractDate() - Method in class bb.common.PurchaseOrderContractResult

getContractDate() - Method in class bb.common.PurchaseOrderVO

getContractExpires() - Method in class bb.common.EmployeeCardVO

getContractItemsCountByContractNumber(String) - Method in interface bb.common.box.SalesBox

getContractName() - Method in class bb.common.ContractPriceCustomerVO

getContractName() - Method in class bb.common.ContractPriceItemVO

getContractName() - Method in class bb.common.ContractPriceVO

getContractName() - Method in class bb.common.VendorContractPriceItemVO

getContractName() - Method in class bb.common.VendorContractPriceVendorVO

getContractName() - Method in class bb.common.VendorContractPriceVO

getContractNumber() - Method in class bb.common.ContractPriceCustomerPK

getContractNumber() - Method in class bb.common.ContractPriceItemPK

getContractNumber() - Method in class bb.common.ContractPriceVO

getContractNumber() - Method in class bb.common.CPItemFromQuoteResult

getContractNumber() - Method in class bb.common.POSurveyReportAgent

getContractNumber() - Method in class bb.common.POSurveyReportVO

getContractNumber() - Method in class bb.common.VendorContractPriceItemPK

getContractNumber() - Method in class bb.common.VendorContractPriceVendorPK

getContractNumber() - Method in class bb.common.VendorContractPriceVO

getContractPeriod() - Method in class bb.common.PurchaseOrderContractResult

getContractPrice() - Method in class bb.common.ImportContractPriceData

getContractPriceById(String) - Method in interface bb.common.box.SalesBox

getContractPriceCustomer(ContractPriceCustomerPK) - Method in interface bb.common.box.SalesBox

getContractPriceItem(ContractPriceItemPK) - Method in interface bb.common.box.SalesBox

getContractsByAddressIdCount(String) - Method in interface bb.common.box.SalesBox

getContractsCountByContractNumber(String) - Method in interface bb.common.box.SalesBox

getContractVendorsCountByContractNumber(String) - Method in interface bb.common.box.PurchasingBox

getControl() - Method in class bb.common.SerialNumberItemResult

getControl() - Method in class bb.common.SerialNumberResult

getControlNumber() - Method in class bb.common.LogMiscDocumentVO

getControlNumber() - Method in class bb.common.MiscDocAgent

getControlNumber() - Method in class bb.common.PartCertificateListResult

getCopyTo() - Method in class bb.common.BB2Notice

getCost() - Method in class bb.common.AccountsPayableItemVO

getCost() - Method in class bb.common.APItemListResult

getCost() - Method in class bb.common.DisassembleWorkOrderIssueVO

getCost() - Method in class bb.common.DisassembleWorkOrderItemPartDetailItemResult

getCost() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

getCost() - Method in class bb.common.EmployeeLaborAgent

getCost() - Method in class bb.common.InventoryListResult

getCost() - Method in class bb.common.IssuedFromOrderItem

getCost() - Method in class bb.common.IssueItemDetailAgent

getCost() - Method in class bb.common.IssuingItemResult

getCost() - Method in class bb.common.LogInventoryListResult

getCost() - Method in class bb.common.NonproductivePickingItemIssuedVO

getCost() - Method in class bb.common.NonproductivePickingItemVO

getCost() - Method in class bb.common.OnLoanItemVO

getCost() - Method in class bb.common.PartInQAAgent

getCost() - Method in class bb.common.PartInQAResult

getCost() - Method in class bb.common.PartInQAVO

getCost() - Method in class bb.common.PartIssuedVO

getCost() - Method in class bb.common.PartReceivedVO

getCost() - Method in class bb.common.partUsedInfoResult

getCost() - Method in class bb.common.PullFromWorkOrderPartDetailAgent

getCost() - Method in class bb.common.PuttoInQAAgent

getCost() - Method in class bb.common.QuoteItemVO

getCost() - Method in class bb.common.RebackInQAAgent

getCost() - Method in class bb.common.ReceiverItemAgent

getCost() - Method in class bb.common.ReceiverItemDetailAgent

getCost() - Method in class bb.common.ReturnToVendorItemListResult

getCost() - Method in class bb.common.SalesOrder12MonthMarginResult

getCost() - Method in class bb.common.SalesOrderItemInfoVO

getCost() - Method in class bb.common.SalesOrderItemVO

getCost() - Method in class bb.common.ScrapReportVO

getCost() - Method in class bb.common.ShipperItemDetailAgent

getCost() - Method in class bb.common.WorkOrderItemIssuedTotalResult

getCost() - Method in class bb.common.WorkOrderItemIssueVO

getCost() - Method in class bb.common.WorkOrderItemPartDetail

getCost() - Method in class bb.common.WorkOrderItemPartDetailInWipVO

getCost() - Method in class bb.common.WorkOrderItemPartDetailItemResult

getCost() - Method in class bb.common.WorkOrderItemSetupItemAgent

getCost() - Method in class bb.common.WorkOrderItemTimeDetailVO

getCost() - Method in class bb.common.WorkOrderReceiverVO

getCostCenter() - Method in class bb.common.WorkCenterVO

getCostControlAgent() - Method in class bb.common.IssuingResult

getCostCurrency() - Method in class bb.common.EquipmentVO

getCostOfGoodsSold() - Method in class bb.common.ClosingStatementResult

getCostOfGoodsSoldItems() - Method in class bb.common.ClosingStatementResult

getCostOfLabor() - Method in class bb.common.ClosingStatementResult

getCostOfLaborItems() - Method in class bb.common.ClosingStatementResult

getCostOfSales() - Method in class bb.common.ProfitLossStatementResult

getCostPerUnit() - Method in class bb.common.CRTVItemListResult

getCostPerUnit() - Method in class bb.common.CustomerReturnToVendorItemVO

getCostPerUnit() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getCostPerUnit() - Method in class bb.common.DisassembleWorkOrderItemListResult

getCostPerUnit() - Method in class bb.common.DisassembleWorkOrderItemVO

getCostPerUnit() - Method in class bb.common.DWOIssueDetail

getCostPerUnit() - Method in class bb.common.InventoryPartInOutDetailListResult

getCostPerUnit() - Method in class bb.common.OnloanReceiverItemVO

getCostPerUnit() - Method in class bb.common.PartOnhandCostVO

getCostPerUnit() - Method in class bb.common.PoMessageItemVO

getCostPerUnit() - Method in class bb.common.POReceiverItemListResult

getCostPerUnit() - Method in class bb.common.PurchaseOrderItemListResult

getCostPerUnit() - Method in class bb.common.PurchaseOrderItemVO

getCostPerUnit() - Method in class bb.common.ReceiverItemVO

getCostPerUnit() - Method in class bb.common.ReceivingItemResult

getCostPerUnit() - Method in class bb.common.RequestForQuoteItemListResult

getCostPerUnit() - Method in class bb.common.RequestForQuoteItemVO

getCostPerUnit() - Method in class bb.common.RequestForRMAItemVO

getCostPerUnit() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getCostPerUnit() - Method in class bb.common.ReturnToVendorByDateListResult

getCostPerUnit() - Method in class bb.common.ReturnToVendorItemVO

getCostPerUnit() - Method in class bb.common.RfqMessageItemVO

getCostPerUnit() - Method in class bb.common.RMAItemListResult

getCostPerUnit() - Method in class bb.common.RRMAItemListResult

getCostPerUnit() - Method in class bb.common.RtvShipperItemListResult

getCostPerUnit() - Method in class bb.common.WOReceiverDetail

getCostPerUnit() - Method in class bb.common.WorkOrderItemListResult

getCostPerUnit() - Method in class bb.common.WorkOrderItemVO

getCostPerUnitWithTax() - Method in class bb.common.PurchaseOrderItemVO

getCostPerUnitWithTax() - Method in class bb.common.SalesOrderItemVO

getCostUnit() - Method in class bb.common.PO2SOExchangeItem

getCoUnitOfAccumulatedDeprAcc() - Method in class bb.common.AssetDepreciateVO

getCoUnitOfAccumulatedDeprAcc() - Method in class bb.common.AssetVO

getCount() - Method in class bb.common.AccountInfoCenterItemResult

getCount() - Method in class bb.common.InventoryCycleItemResult

getCount() - Method in class bb.common.LogPartDwfVO

getCount() - Method in class bb.common.LogPartDwgVO

getCounted() - Method in class bb.common.StockTransactionAdjustmentResult

getCountedBy() - Method in class bb.common.CycleCountListResult

getCountedBy() - Method in class bb.common.CycleCountVO

getCountedBy() - Method in class bb.common.InventoryAdjustmentVO

getCountedBy() - Method in class bb.common.PhysicalInventoryListResult

getCountedBy() - Method in class bb.common.PhysicalInventoryVO

getCountedBy() - Method in class bb.common.StockTransactionAdjustmentResult

getCountedDate() - Method in class bb.common.CycleCountListResult

getCountedDate() - Method in class bb.common.CycleCountVO

getCountedDate() - Method in class bb.common.InventoryAdjustmentVO

getCountedDate() - Method in class bb.common.PhysicalInventoryListResult

getCountedDate() - Method in class bb.common.PhysicalInventoryVO

getCountry() - Method in class bb.common.AccountPayableCheckVO

getCountry() - Method in class bb.common.AccountReceivablePaymentVO

getCountry() - Method in class bb.common.CustomerVendorAddressInfoVO

getCountry() - Method in class bb.common.CustomerVendorAddressVO

getCountry() - Method in class bb.common.CustomerVendorDescriptionVO

getCountry() - Method in class bb.common.EmployeeHomeVO

getCountry() - Method in class bb.common.IpAddressVO

getCountry() - Method in class bb.common.LockedCustomerAddressResult

getCountry() - Method in class bb.common.ManufacturerAddressInfoVO

getCountry() - Method in class bb.common.ManufacturerAddressVO

getCountry() - Method in class bb.common.ManufacturerDescriptionVO

getCountry() - Method in class bb.common.SalesmanVO

getCountry() - Method in class bb.common.SalesMarginListResult

getCountry() - Method in class bb.common.SalesOrderItemListResult

getCountry() - Method in class bb.common.SGCartCheckOutResult

getCountry() - Method in class bb.common.SGCustRequestForQuoteListResult

getCountry() - Method in class bb.common.SGCustRequestForQuoteResult

getCountry() - Method in class bb.common.SGQuoteAddressResult

getCountry() - Method in class bb.common.SGQuoteAddressVO

getCountryCode() - Method in class bb.common.CustomerVendorAddressInfoVO

getCountryCode() - Method in class bb.common.CustomerVendorAddressVO

getCountryCode() - Method in class bb.common.ManufacturerAddressInfoVO

getCountryCode() - Method in class bb.common.ManufacturerAddressVO

getCountryCode() - Method in class bb.common.SGQuoteAddressVO

getCountryOrigin() - Method in class bb.common.AccountsReceivableItemVO

getCountryOrigin() - Method in class bb.common.PartBasicInfo

getCountryOrigin() - Method in class bb.common.PartVO

getCountyCode() - Method in class bb.common.PosZipCodeTaxVO

getCountyName() - Method in class bb.common.PosZipCodeTaxVO

getCountyTaxRate() - Method in class bb.common.PosZipCodeTaxVO

getCpiCurrency() - Method in class bb.common.CPItemFromQuoteResult

getCpiDiscount() - Method in class bb.common.CPItemFromQuoteResult

getCpiListPrice() - Method in class bb.common.CPItemFromQuoteResult

getCreateBy() - Method in class bb.common.WorkFlowVO

getCreateDate() - Method in class bb.common.ContractPriceVO

getCreateDate() - Method in class bb.common.CustomerVendorAddressInfoVO

getCreateDate() - Method in class bb.common.CustomerVendorAddressVO

getCreateDate() - Method in class bb.common.CycleCountStatusVO

getCreateDate() - Method in class bb.common.PhysicalInventoryStatusVO

getCreateDate() - Method in class bb.common.ServerClientPropertyVO

getCreateDate() - Method in class bb.common.SubcompanyVO

getCreatedBy() - Method in class bb.common.ChangeStdCostWorkSheetVO

getCreatedBy() - Method in class bb.common.RollUpBomStdCostWorkSheetVO

getCreatedDate() - Method in class bb.common.AccountsChartMappingVO

getCreatedDate() - Method in class bb.common.BillVO

getCreatedDate() - Method in class bb.common.BillWithPartInfoResult

getCreatedDate() - Method in class bb.common.ChangeStdCostWorkSheetVO

getCreatedDate() - Method in class bb.common.PartExportInfo

getCreatedDate() - Method in class bb.common.PartVO

getCreatedDate() - Method in class bb.common.PartWithOnhandsVO

getCreatedDate() - Method in class bb.common.RollUpBomStdCostWorkSheetVO

getCreatedDate() - Method in class bb.common.ToolVO

getCreatedDate() - Method in class bb.common.ToolWithOnhandsVO

getCreateTime() - Method in class bb.common.BizboxUserListResult

getCreateTime() - Method in class bb.common.BizboxUserVO

getCreateTime() - Method in class bb.common.QualityGroupVO

getCreator() - Method in class bb.common.CycleCountStatusVO

getCreator() - Method in class bb.common.PhysicalInventoryStatusVO

getCredit() - Method in class bb.common.AccountBalanceListResult

getCredit() - Method in class bb.common.AccountCreditVO

getCredit() - Method in class bb.common.ClosingStatementItemResult

getCredit() - Method in class bb.common.ExchangeAuditItemResult

getCredit() - Method in class bb.common.GeneralLedgerByDateListResult

getCredit() - Method in class bb.common.GeneralLedgerEntry

getCredit() - Method in class bb.common.GLDebitCreditListResult

getCredit() - Method in class bb.common.GLItemVO

getCredit() - Method in class bb.common.NcrScrapAgent

getCreditAccount() - Method in class bb.common.AccountsReceivableInfoVO

getCreditAccount() - Method in class bb.common.AccountsReceivableVO

getCreditAccount() - Method in class bb.common.ARPrepaymentWireTransferAgent

getCreditAccount() - Method in class bb.common.InvoiceItemListResult

getCreditAccount() - Method in class bb.common.JounalEntryListResult

getCreditAccount() - Method in class bb.common.MakeCreditMemoAgent

getCreditAccount() - Method in class bb.common.PostCheckAgent

getCreditAccount() - Method in class bb.common.PrepaymentWireTransferAgent

getCreditAccount() - Method in class bb.common.QuoteVO

getCreditAccount() - Method in class bb.common.SalesOrderVO

getCreditAccount() - Method in class bb.common.ScrapReportVO

getCreditAccount() - Method in class bb.common.WireTransferAgent

getCreditAccountBalance() - Method in class bb.common.AccountBalanceAgent

getCreditAccounts() - Method in class bb.common.GeneralLedgerCategoryVO

getCreditAmount() - Method in class bb.common.AccountBalanceResult

getCreditAmount() - Method in class bb.common.JounalEntryListResult

getCreditBalance() - Method in class bb.common.MonthBalanceResult

getCreditBeginPeriodBalance() - Method in class bb.common.AccountBalanceResult

getCreditCardNumber() - Method in class bb.common.RunningAccountOrderVO

getCreditDebit() - Method in class bb.common.AccountsCreditDebitListResult

getCreditEndingBalance() - Method in class bb.common.CurrentBalanceResult

getCreditEndPeriodBalance() - Method in class bb.common.AccountBalanceResult

getCreditListCountByApNumber(String) - Method in interface bb.common.box.AccountingBox

getCreditListCountByAppNumber(String) - Method in interface bb.common.box.AccountingBox

getCreditListCountByArNumber(String) - Method in interface bb.common.box.AccountingBox

getCreditMemoComments() - Method in class bb.common.MakeCreditMemoAgent

getCreditMemoNotes() - Method in class bb.common.MakeCreditMemoAgent

getCreditMemoNumber() - Method in class bb.common.RMAReceiverListResult

getCreditMemoNumber() - Method in class bb.common.RMAReceiverVO

getCreditMonthTotal() - Method in class bb.common.CurrentBalanceResult

getCreditOrDebit() - Method in class bb.common.BalanceSheetSideBySideItemResult

getCreditOrDebit() - Method in class bb.common.ClosingStatementItemResult

getCreditOrDebit() - Method in class bb.common.ExchangeAuditItemResult

getCredits() - Method in class bb.common.DebitsCreditsResult

getCreditStartingBalance() - Method in class bb.common.CurrentBalanceResult

getCreditText() - Method in class bb.common.NcrScrapAgent

getCrfqDate() - Method in class bb.common.SGCustRequestForQuoteListResult

getCrfqDate() - Method in class bb.common.SGCustRequestForQuoteVO

getCrfqItemNumber() - Method in class bb.common.SGCustRequestForQuoteItemPK

getCrfqNumber() - Method in class bb.common.SGCustRequestForQuoteItemPK

getCrfqNumber() - Method in class bb.common.SGCustRequestForQuoteListResult

getCrfqNumber() - Method in class bb.common.SGCustRequestForQuoteResult

getCrfqNumber() - Method in class bb.common.SGCustRequestForQuoteVO

getCriticalityCategory() - Method in class bb.common.PartTraceableResult

getCriticalityCategory() - Method in class bb.common.TraceableCategoriesVO

getCriticalLevel() - Method in class bb.common.CustomerVendorAddressInfoVO

getCriticalLevel() - Method in class bb.common.CustomerVendorAddressVO

getCriticalLevel() - Method in class bb.common.LockedCustomerAddressResult

getCriticalLevel() - Method in class bb.common.VendorCriticalLevelVO

getCrtvDate() - Method in class bb.common.CRTVItemListResult

getCrtvDate() - Method in class bb.common.CRTVListResult

getCrtvDate() - Method in class bb.common.CustomerReturnToVendorVO

getCrtvItem() - Method in class bb.common.CustomerReturnToVendorVO

getCrtvItemComments() - Method in class bb.common.CustomerReturnToVendorItemVO

getCrtvItemNumber() - Method in class bb.common.CRTVItemListResult

getCrtvItemNumber() - Method in class bb.common.CustomerReturnToVendorItemPK

getCrtvItemPrivateNotes() - Method in class bb.common.CustomerReturnToVendorItemVO

getCrtvNumber() - Method in class bb.common.CRTVItemListResult

getCrtvNumber() - Method in class bb.common.CRTVListResult

getCrtvNumber() - Method in class bb.common.CustomerReturnToVendorItemPK

getCrtvNumber() - Method in class bb.common.CustomerReturnToVendorVO

getCrtvNumber() - Method in class bb.common.ReturnMaterialAuthorizationVO

getCsEmail() - Method in class bb.common.CustomerServiceIncidentVO

getCsiNumber() - Method in class bb.common.CustomerServiceIncidentItemListResult

getCsiNumber() - Method in class bb.common.CustomerServiceIncidentListResult

getCsiNumber() - Method in class bb.common.SGCustomerServiceRequestVO

getCsrDate() - Method in class bb.common.SGCustomerServiceRequestVO

getCsrNumber() - Method in class bb.common.SGCustomerServiceRequestVO

getCsrReceiverEmail() - Method in class bb.common.CompanyVO

getCurrency() - Method in class bb.common.AccountAgingTotalResult

getCurrency() - Method in class bb.common.AccountAuditAgent

getCurrency() - Method in class bb.common.AccountCreditVO

getCurrency() - Method in class bb.common.AccountDebitVO

getCurrency() - Method in class bb.common.AccountInfoCenterItemResult

getCurrency() - Method in class bb.common.AccountingTotalMoneyResult

getCurrency() - Method in class bb.common.AccountPayableCheckRunItemVO

getCurrency() - Method in class bb.common.AccountPayableCheckVO

getCurrency() - Method in class bb.common.AccountReceivablePaymentVO

getCurrency() - Method in class bb.common.AccountsPayableInfoVO

getCurrency() - Method in class bb.common.AccountsPayableVO

getCurrency() - Method in class bb.common.AccountsReceivableInfoVO

getCurrency() - Method in class bb.common.AccountsReceivableVO

getCurrency() - Method in class bb.common.AddressAccountInfo

getCurrency() - Method in class bb.common.APAuditListResult

getCurrency() - Method in class bb.common.ApCheckRunItemAgent

getCurrency() - Method in class bb.common.ApCheckRunListResult

getCurrency() - Method in class bb.common.ApPrepayVO

getCurrency() - Method in class bb.common.APTaxForZipcodeListResult

getCurrency() - Method in class bb.common.ARAllStatementsListResult

getCurrency() - Method in class bb.common.ARAuditListResult

getCurrency() - Method in class bb.common.ArCommissionListResult

getCurrency() - Method in class bb.common.ArCommissionTotalResult

getCurrency() - Method in class bb.common.ARPaymentRunItemVO

getCurrency() - Method in class bb.common.ARPaymentRunListResult

getCurrency() - Method in class bb.common.ARPrepayAllStatementsListResult

getCurrency() - Method in class bb.common.ArPrepayVO

getCurrency() - Method in class bb.common.ARTaxForZipcodeListResult

getCurrency() - Method in class bb.common.BB2PartByDateResult

getCurrency() - Method in class bb.common.BB2tripleString

getCurrency(String, String) - Method in interface bb.common.box.CompanyBox

getCurrency() - Method in class bb.common.CompanyVO

getCurrency() - Method in class bb.common.ContractPriceVO

getCurrency() - Method in class bb.common.CurrencyExchangePK

getCurrency() - Method in class bb.common.CurrencyVO

getCurrency() - Method in class bb.common.CustomerReturnToVendorVO

getCurrency() - Method in class bb.common.CustomerStatementResult

getCurrency() - Method in class bb.common.CustomerStatementTotalResult

getCurrency() - Method in class bb.common.CustomerVendorAddressInfoVO

getCurrency() - Method in class bb.common.CustomerVendorAddressTotalInfo

getCurrency() - Method in class bb.common.CustomerVendorAddressVO

getCurrency() - Method in class bb.common.DebitsCreditsResult

getCurrency() - Method in class bb.common.DepreciateMonthlyReport

getCurrency() - Method in class bb.common.DisassembleWorkOrderApprovalVO

getCurrency() - Method in class bb.common.DisassembleWorkOrderItemListResult

getCurrency() - Method in class bb.common.DisassembleWorkOrderVO

getCurrency() - Method in class bb.common.DuePATotalByVendorResult

getCurrency() - Method in class bb.common.ExchangeAuditItemResult

getCurrency() - Method in class bb.common.ExpenseItemVO

getCurrency() - Method in class bb.common.GeneralLedgerListResult

getCurrency() - Method in class bb.common.GeneralLedgerVO

getCurrency() - Method in class bb.common.GLItemVO

getCurrency() - Method in class bb.common.InvoiceItemListResult

getCurrency() - Method in class bb.common.JounalEntryListResult

getCurrency() - Method in class bb.common.MakeAccountPayableAgent

getCurrency() - Method in class bb.common.MakeBillAndHoldInvoiceAgent

getCurrency() - Method in class bb.common.MakeCreditMemoAgent

getCurrency() - Method in class bb.common.MakeDebitMemoAgent

getCurrency() - Method in class bb.common.MakeInvoiceAgent

getCurrency() - Method in class bb.common.Money

getCurrency() - Method in class bb.common.NonproductivePickingApproveVO

getCurrency() - Method in class bb.common.OnloanReceiverVO

getCurrency() - Method in class bb.common.OnloanReviewVO

getCurrency() - Method in class bb.common.OnloanShipperVO

getCurrency() - Method in class bb.common.OnLoanVO

getCurrency() - Method in class bb.common.PartIssuedListResult

getCurrency() - Method in class bb.common.PartReceivedListResult

getCurrency() - Method in class bb.common.PfReceiverVO

getCurrency() - Method in class bb.common.PO2SOExchange

getCurrency() - Method in class bb.common.POReceiverItemListResult

getCurrency() - Method in class bb.common.POStatisticsResult

getCurrency() - Method in class bb.common.PrepayAgent

getCurrency() - Method in class bb.common.ProformaInvoiceVO

getCurrency() - Method in class bb.common.PurchaseOnTimeResult

getCurrency() - Method in class bb.common.PurchaseOrderApprovalVO

getCurrency() - Method in class bb.common.PurchaseOrderCheckListResult

getCurrency() - Method in class bb.common.PurchaseOrderItemListResult

getCurrency() - Method in class bb.common.PurchaseOrderOnTimeResult

getCurrency() - Method in class bb.common.PurchaseOrderVO

getCurrency() - Method in class bb.common.QuoteItemListResult

getCurrency() - Method in class bb.common.QuoteVO

getCurrency() - Method in class bb.common.ReceiverInfoVO

getCurrency() - Method in class bb.common.ReceiverVO

getCurrency() - Method in class bb.common.RequestForQuoteCheckListResult

getCurrency() - Method in class bb.common.RequestForQuoteVO

getCurrency() - Method in class bb.common.RequestForRMAVO

getCurrency() - Method in class bb.common.ReturnMaterialAuthorizationVO

getCurrency() - Method in class bb.common.ReturnToVendorByDateListResult

getCurrency() - Method in class bb.common.ReturnToVendorCheckListResult

getCurrency() - Method in class bb.common.ReturnToVendorVO

getCurrency() - Method in class bb.common.RMAReceiverVO

getCurrency() - Method in class bb.common.RMAReviewVO

getCurrency() - Method in class bb.common.RTVApprovalVO

getCurrency() - Method in class bb.common.RtvShipperInfoVO

getCurrency() - Method in class bb.common.RtvShipperVO

getCurrency() - Method in class bb.common.RunningAccountOrderVO

getCurrency() - Method in class bb.common.SalesInfoCenterResult

getCurrency() - Method in class bb.common.SalesMarginListResult

getCurrency() - Method in class bb.common.SalesOnTimeResult

getCurrency() - Method in class bb.common.SalesOrder12MonthMarginResult

getCurrency() - Method in class bb.common.SalesOrderCheckListResult

getCurrency() - Method in class bb.common.SalesOrderItemCostResult

getCurrency() - Method in class bb.common.SalesOrderItemCustomerTotalResult

getCurrency() - Method in class bb.common.SalesOrderItemListResult

getCurrency() - Method in class bb.common.SalesOrderListResult

getCurrency() - Method in class bb.common.SalesOrderOnTimeResult

getCurrency() - Method in class bb.common.SalesOrderReviewVO

getCurrency() - Method in class bb.common.SalesOrderVO

getCurrency() - Method in class bb.common.SGCompanyVO

getCurrency() - Method in class bb.common.SGCustRequestForQuoteListResult

getCurrency() - Method in class bb.common.SGCustRequestForQuoteResult

getCurrency() - Method in class bb.common.SGCustRequestForQuoteVO

getCurrency() - Method in class bb.common.SGQuoteAddressVO

getCurrency() - Method in class bb.common.ShipperInfoVO

getCurrency() - Method in class bb.common.ShipperItemListResult

getCurrency() - Method in class bb.common.ShipperVO

getCurrency() - Method in class bb.common.TempArApAgingVO

getCurrency() - Method in class bb.common.TempReceiverWithoutAPInfo

getCurrency() - Method in class bb.common.TotalByDateResult

getCurrency() - Method in class bb.common.TransferOrderListResult

getCurrency() - Method in class bb.common.TransferOrderVO

getCurrency() - Method in class bb.common.TransferReceiverListResult

getCurrency() - Method in class bb.common.TransferReceiverVO

getCurrency() - Method in class bb.common.TransferShipperListResult

getCurrency() - Method in class bb.common.TransferShipperVO

getCurrency() - Method in class bb.common.VendorContractPriceVO

getCurrency() - Method in class bb.common.VendorQtyPriceVO

getCurrency() - Method in class bb.common.WireTransferAgent

getCurrency() - Method in class bb.common.WorkOrderApprovalVO

getCurrency() - Method in class bb.common.WorkOrderCheckListResult

getCurrency() - Method in class bb.common.WorkOrderItemInWipListResult

getCurrency() - Method in class bb.common.WorkOrderItemListResult

getCurrency() - Method in class bb.common.WorkOrderOnTimeResult

getCurrency() - Method in class bb.common.WorkOrderVO

getCurrencyByPk(String) - Method in interface bb.common.box.CompanyBox

getCurrencyExchangeRate(Date, String) - Method in interface bb.common.box.CompanyBox

getCurrent() - Method in class bb.common.AccountAgingTotalResult

getCurrent() - Method in class bb.common.CustomerStatementTotalResult

getCurrentAllGlMonthCount() - Method in interface bb.common.box.AccountingBox

getCurrentAssets() - Method in class bb.common.BalanceSheetSideBySideResult

getCurrentAssets() - Method in class bb.common.ClosingStatementResult

getCurrentBalanceCount(String, String, String) - Method in interface bb.common.box.AccountingBox

getCurrentBalanceResult(String, String, String) - Method in interface bb.common.box.AccountingBox

getCurrentCost() - Method in class bb.common.CustomerReturnToVendorItemVO

getCurrentCost() - Method in class bb.common.RequestForRMAItemVO

getCurrentCost() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getCurrentCost() - Method in class bb.common.RMAReceiverItemVO

getCurrentFiscalYearSettings() - Method in interface bb.common.box.AccountingBox

getCurrentLiabilities() - Method in class bb.common.ClosingStatementResult

getCurrentLiability() - Method in class bb.common.BalanceSheetSideBySideResult

getCurrentMonthDepreciate() - Method in class bb.common.AssetDepreciateVO

getCurrentMonthDepreciate() - Method in class bb.common.AssetReportSumResult

getCurrentMonthEndDate() - Static method in class bb.common.BB2Util

getCurrentMonthInvoicedAccount() - Method in class bb.common.SalesInfoCenterResult

getCurrentMonthInvoiceGrossMargin() - Method in class bb.common.SalesInfoCenterResult

getCurrentMonthPoAddedCount() - Method in class bb.common.PurchasingInfoCenterResult

getCurrentMonthPoiAddedCount() - Method in class bb.common.PurchasingInfoCenterResult

getCurrentMonthPurchaseAccount() - Method in class bb.common.PurchasingInfoCenterResult

getCurrentMonthReceiverAccount() - Method in class bb.common.PurchasingInfoCenterResult

getCurrentMonthReceiverCount() - Method in class bb.common.PurchasingInfoCenterResult

getCurrentMonthReceiverCount() - Method in class bb.common.WareHousingInfoCenterResult

getCurrentMonthReceiverItemCount() - Method in class bb.common.PurchasingInfoCenterResult

getCurrentMonthReceiverItemCount() - Method in class bb.common.WareHousingInfoCenterResult

getCurrentMonthRejectQty() - Method in class bb.common.QualityInfoCenterResult

getCurrentMonthSalesItemCount() - Method in class bb.common.SalesInfoCenterResult

getCurrentMonthSalesOrderAccount() - Method in class bb.common.SalesInfoCenterResult

getCurrentMonthSalesOrderCount() - Method in class bb.common.SalesInfoCenterResult

getCurrentMonthShipperCount() - Method in class bb.common.WareHousingInfoCenterResult

getCurrentMonthShipperItemCount() - Method in class bb.common.WareHousingInfoCenterResult

getCurrentMonthStartDate() - Static method in class bb.common.BB2Util

getCurrentMonthYear() - Method in interface bb.common.box.AccountingBox

getCurrentOnhand() - Method in class bb.common.PartIssuedListResult

getCurrentOnhand() - Method in class bb.common.PartReceivedListResult

getCurrentPeriod() - Method in class bb.common.ProfitLossStatementItemResult

getCurrentPeriodFrom() - Method in class bb.common.AccountingInfoDocumentVO

getCurrentPeriodFrom() - Method in class bb.common.MiscDocAgent

getCurrentPeriodFrom() - Method in class bb.common.ProfitLossStatementResult

getCurrentPeriodTo() - Method in class bb.common.AccountingInfoDocumentVO

getCurrentPeriodTo() - Method in class bb.common.MiscDocAgent

getCurrentPeriodTo() - Method in class bb.common.ProfitLossStatementResult

getCurrentPosition() - Method in class bb.common.CustomEmployeeVO

getCurrentPositionLevel() - Method in class bb.common.CustomEmployeeVO

getCurrentRetainedEarning() - Method in class bb.common.AccountingSettingsVO

getCurrentRunHours() - Method in class bb.common.EquipmentListResult

getCurrentRunHours() - Method in class bb.common.EquipmentVO

getCurrentStdCost() - Method in class bb.common.CustomerReturnToVendorItemVO

getCurrentStdCost() - Method in class bb.common.RequestForRMAItemVO

getCurrentStdCost() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getCurrentStdCost() - Method in class bb.common.RMAReceiverItemVO

getCurrentUserApprovalInfo() - Method in interface bb.common.box.AccountingBox

getCurrentYearDepreciateTotal() - Method in class bb.common.AssetDepreciateDetailReport

getCurrentYearDepreciationAccm() - Method in class bb.common.AssetDepreciateDetailReport

getCurrentYearFirstDate() - Static method in class bb.common.BB2Util

getCurrentYearLastDate() - Static method in class bb.common.BB2Util

getCurrentYearMonth() - Method in class bb.common.AccountingSettingsVO

getCusInvoice() - Method in class bb.common.OnloanReceiverVO

getCusInvoiceDate() - Method in class bb.common.OnloanReceiverVO

getCusPackage() - Method in class bb.common.OnloanReceiverVO

getCusShipDate() - Method in class bb.common.OnloanReceiverVO

getCustID() - Method in class bb.common.ARAuditListResult

getCustID() - Method in class bb.common.CSRAgent

getCustID() - Method in class bb.common.OnloanReceiverItemListResult

getCustID() - Method in class bb.common.OnloanReceiverListResult

getCustID() - Method in class bb.common.OnloanReceiverVO

getCustID() - Method in class bb.common.RMAReceiverItemListResult

getCustID() - Method in class bb.common.RMAReceiverListResult

getCustID() - Method in class bb.common.RMAReceiverVO

getCustID() - Method in class bb.common.SalesOrderShipDateListResult

getCustID() - Method in class bb.common.SgClientProgramUserVO

getCustID() - Method in class bb.common.SGCustomerServiceRequestVO

getCustID() - Method in class bb.common.SGCustRequestForQuoteListResult

getCustID() - Method in class bb.common.SGCustRequestForQuoteResult

getCustID() - Method in class bb.common.SGCustRequestForQuoteVO

getCustID() - Method in class bb.common.SGPartCatalogResult

getCustID() - Method in class bb.common.SGSaleItemVO

getCustId() - Method in class bb.common.ShipListItemVOResult

getCustomAssetByPk(String) - Method in interface bb.common.box.HumanResourceBox

getCustomAssetCountByName(String, String, String, String) - Method in interface bb.common.box.HumanResourceBox

getCustomAssetRecordByPk(CustomAssetRecordPK) - Method in interface bb.common.box.HumanResourceBox

getCustomCheckUpCountByName(String, String, Date, Date, int) - Method in interface bb.common.box.HumanResourceBox

getCustomCheckUpEmployee(Long) - Method in interface bb.common.box.HumanResourceBox

getCustomDepartment() - Method in class bb.common.CustomEmployeeVO

getCustomDepartmentByPk(String) - Method in interface bb.common.box.HumanResourceBox

getCustomEmployeeByCondition(String, String, int, String, String, String, String, String, String, int, String, String) - Method in interface bb.common.box.HumanResourceBox

getCustomEmployeeByPk(String) - Method in interface bb.common.box.HumanResourceBox

getCustomEmployeeTrainCount(String, String, String) - Method in interface bb.common.box.HumanResourceBox

getCustomer() - Method in class bb.common.SGCustomerCatalogPK

getCustomerAccount() - Method in class bb.common.CustomerVendorAddressVO

getCustomerAddressesByIdCount(String) - Method in interface bb.common.box.AddressBox

getCustomerAddressesByNameCount(String) - Method in interface bb.common.box.AddressBox

getCustomerAddressInfo() - Method in class bb.common.AccountPayableCheckRunItemVO

getCustomerAddressInfo() - Method in class bb.common.AccountsPayableInfoVO

getCustomerAddressInfo() - Method in class bb.common.AccountsPayableVO

getCustomerAddressInfo() - Method in class bb.common.AccountsReceivableInfoVO

getCustomerAddressInfo() - Method in class bb.common.AccountsReceivableVO

getCustomerAddressInfo() - Method in class bb.common.ARPaymentRunItemVO

getCustomerAddressInfo() - Method in class bb.common.ArPrepayVO

getCustomerAddressInfo() - Method in class bb.common.CustomerFeedbackVO

getCustomerAddressInfo() - Method in class bb.common.CustomerReturnToVendorVO

getCustomerAddressInfo() - Method in class bb.common.CustomerServiceIncidentVO

getCustomerAddressInfo() - Method in class bb.common.OnloanReceiverVO

getCustomerAddressInfo() - Method in class bb.common.OnloanShipperVO

getCustomerAddressInfo() - Method in class bb.common.OnLoanVO

getCustomerAddressInfo() - Method in class bb.common.ProformaInvoiceVO

getCustomerAddressInfo() - Method in class bb.common.QuoteVO

getCustomerAddressInfo() - Method in class bb.common.RequestForRMAVO

getCustomerAddressInfo() - Method in class bb.common.ReturnMaterialAuthorizationVO

getCustomerAddressInfo() - Method in class bb.common.RMAReceiverVO

getCustomerAddressInfo() - Method in class bb.common.RunningAccountOrderVO

getCustomerAddressInfo() - Method in class bb.common.SalesOrderVO

getCustomerAddressInfo() - Method in class bb.common.SgClientProgramUserVO

getCustomerAddressInfo() - Method in class bb.common.ShipperVO

getCustomerAddressInfo() - Method in class bb.common.VendorGroupUserVO

getCustomerById(String) - Method in interface bb.common.box.AddressBox

getCustomerCarrier() - Method in class bb.common.CustomerVendorAddressVO

getCustomerCarrierAccount() - Method in class bb.common.CustomerVendorAddressVO

getCustomerComments() - Method in class bb.common.CustomerVendorAddressVO

getCustomerCreditLimit() - Method in class bb.common.CustomerStatementTotalResult

getCustomerCreditLimit() - Method in class bb.common.CustomerVendorAddressVO

getCustomerDepositBank() - Method in class bb.common.CustomerVendorAddressVO

getCustomerDiscount() - Method in class bb.common.CustomerVendorAddressVO

getCustomerDm() - Method in class bb.common.RMAReceiverVO

getCustomerDmDate() - Method in class bb.common.RMAReceiverVO

getCustomerDmTotal() - Method in class bb.common.RMAReceiverVO

getCustomerEmail() - Method in class bb.common.AccountsReceivableInfoVO

getCustomerEmail() - Method in class bb.common.AccountsReceivableVO

getCustomerEmail() - Method in class bb.common.CustomerServiceIncidentVO

getCustomerEmail() - Method in class bb.common.OnLoanVO

getCustomerEmail() - Method in class bb.common.ProformaInvoiceVO

getCustomerEmail() - Method in class bb.common.SalesOrderVO

getCustomerFeedbackById(String) - Method in interface bb.common.box.CustomerServiceBox

getCustomerFeedbackCountByDate(String, String, String, String, String, boolean, Date, Date) - Method in interface bb.common.box.CustomerServiceBox

getCustomerFeedbacksCountByFeedBackNumber(String) - Method in interface bb.common.box.CustomerServiceBox

getCustomerFlag() - Method in class bb.common.CustomerVendorAddressInfoVO

getCustomerFlag() - Method in class bb.common.CustomerVendorAddressVO

getCustomerFlag() - Method in class bb.common.LockedCustomerAddressResult

getCustomerId() - Method in class bb.common.AccountReceivableInfoWithPrepayResult

getCustomerId() - Method in class bb.common.AccountReceivablePaymentVO

getCustomerId() - Method in class bb.common.AccountsReceivableInfoVO

getCustomerId() - Method in class bb.common.AccountsReceivableVO

getCustomerId() - Method in class bb.common.AllStatementsListResult

getCustomerId() - Method in class bb.common.ARAllStatementsListResult

getCustomerId() - Method in class bb.common.ArCommissionListResult

getCustomerId() - Method in class bb.common.ARPaymentRunItemVO

getCustomerId() - Method in class bb.common.ARPaymentRunListResult

getCustomerId() - Method in class bb.common.ARPrepayAllStatementsListResult

getCustomerId() - Method in class bb.common.ARPrepayInfoResult

getCustomerId() - Method in class bb.common.ArPrepayVO

getCustomerId() - Method in class bb.common.ARTaxForZipcodeListResult

getCustomerId() - Method in class bb.common.BB2PartInSipItemResult

getCustomerId() - Method in class bb.common.BB2PartInSipOfSoItemResult

getCustomerId() - Method in class bb.common.BB2PartOnLoanItemResult

getCustomerID() - Method in class bb.common.CPItemFromQuoteResult

getCustomerId() - Method in class bb.common.CRTVItemListResult

getCustomerId() - Method in class bb.common.CRTVListResult

getCustomerId() - Method in class bb.common.CustomerFeedbackVO

getCustomerId() - Method in class bb.common.CustomerReturnToVendorVO

getCustomerId() - Method in class bb.common.CustomerServiceIncidentItemListResult

getCustomerId() - Method in class bb.common.CustomerServiceIncidentListResult

getCustomerId() - Method in class bb.common.CustomerServiceIncidentVO

getCustomerId() - Method in class bb.common.CustomerStatementResult

getCustomerId() - Method in class bb.common.CustomerStatementTotalResult

getCustomerId() - Method in class bb.common.DepositSummaryResult

getCustomerId() - Method in class bb.common.GeneralLedgerListResult

getCustomerId() - Method in class bb.common.GeneralLedgerVO

getCustomerId() - Method in class bb.common.InvoiceItemListResult

getCustomerId() - Method in class bb.common.LnShipperItemListResult

getCustomerId() - Method in class bb.common.LnShipperListResult

getCustomerId() - Method in class bb.common.MonthSoOrArByCustomerResult

getCustomerId() - Method in class bb.common.MrpReportAgent

getCustomerId() - Method in class bb.common.OnLoanItemListResult

getCustomerId() - Method in class bb.common.OnLoanListResult

getCustomerId() - Method in class bb.common.OnloanShipperVO

getCustomerId() - Method in class bb.common.OnLoanVO

getCustomerId() - Method in class bb.common.PackingBoxItemListResult

getCustomerId() - Method in class bb.common.PackingBoxItemVO

getCustomerId() - Method in class bb.common.PackingBoxVO

getCustomerID() - Method in class bb.common.PointOfSaleVO

getCustomerId() - Method in class bb.common.PostCheckAgent

getCustomerId() - Method in class bb.common.ProformaInvoiceItemListResult

getCustomerId() - Method in class bb.common.ProformaInvoiceItemVO

getCustomerId() - Method in class bb.common.ProformaInvoiceListResult

getCustomerId() - Method in class bb.common.ProformaInvoiceVO

getCustomerId() - Method in class bb.common.Quote2QuoteAgent

getCustomerId() - Method in class bb.common.QuoteItemListResult

getCustomerId() - Method in class bb.common.QuoteListResult

getCustomerId() - Method in class bb.common.QuoteVO

getCustomerId() - Method in class bb.common.RequestForRMAVO

getCustomerId() - Method in class bb.common.ReturnMaterialAuthorizationVO

getCustomerId() - Method in class bb.common.RMAItemListResult

getCustomerId() - Method in class bb.common.RMAListResult

getCustomerId() - Method in class bb.common.RMAReceiverResult

getCustomerId() - Method in class bb.common.RRMAItemListResult

getCustomerId() - Method in class bb.common.RRMAListResult

getCustomerId() - Method in class bb.common.RunningAccountOrderItemResult

getCustomerId() - Method in class bb.common.RunningAccountOrderVO

getCustomerId() - Method in class bb.common.RunTaxPaymentResult

getCustomerId() - Method in class bb.common.SalesMarginListResult

getCustomerId() - Method in class bb.common.SalesOrderCheckListResult

getCustomerId() - Method in class bb.common.SalesOrderItemCustomerTotalResult

getCustomerId() - Method in class bb.common.SalesOrderItemListResult

getCustomerId() - Method in class bb.common.SalesOrderListResult

getCustomerId() - Method in class bb.common.SalesOrderOnDemandResult

getCustomerId() - Method in class bb.common.SalesOrderVO

getCustomerId() - Method in class bb.common.SalesTaxListResult

getCustomerId() - Method in class bb.common.ShipListInfoVO

getCustomerId() - Method in class bb.common.ShipListOwnerAttributeVO

getCustomerId() - Method in class bb.common.ShipListVO

getCustomerId() - Method in class bb.common.ShipperInfoVO

getCustomerId() - Method in class bb.common.ShipperItemListResult

getCustomerId() - Method in class bb.common.ShipperListResult

getCustomerId() - Method in class bb.common.ShipperVO

getCustomerId() - Method in class bb.common.ShippingResult

getCustomerId() - Method in class bb.common.SO2SOAgent

getCustomerId() - Method in class bb.common.StockTransactionSOShipperResult

getCustomerId() - Method in class bb.common.StockTransactionWOShipperResult

getCustomerId() - Method in class bb.common.TempArApAgingVO

getCustomerId() - Method in class bb.common.WorkOrderQueryInfo

getCustomerID() - Method in class bb.common.ZipcodeTotalsResult

getCustomerIncoterm() - Method in class bb.common.CustomerVendorAddressVO

getCustomerIncotermPlacePort() - Method in class bb.common.CustomerVendorAddressVO

getCustomerInfo() - Method in class bb.common.ContractPriceCustomerVO

getCustomerInvoiceDate() - Method in class bb.common.MakeCreditMemoAgent

getCustomerInvoiceNumber() - Method in class bb.common.MakeCreditMemoAgent

getCustomerInvoiceTotal() - Method in class bb.common.MakeCreditMemoAgent

getCustomerName() - Method in class bb.common.AccountReceivableInfoWithPrepayResult

getCustomerName() - Method in class bb.common.AllStatementsListResult

getCustomerName() - Method in class bb.common.ARAllStatementsListResult

getCustomerName() - Method in class bb.common.ARPaymentRunListResult

getCustomerName() - Method in class bb.common.ARPrepayAllStatementsListResult

getCustomerName() - Method in class bb.common.ARPrepayInfoResult

getCustomerName() - Method in class bb.common.ARTaxForZipcodeListResult

getCustomerName() - Method in class bb.common.CustomerStatementResult

getCustomerName() - Method in class bb.common.CustomerStatementTotalResult

getCustomerName() - Method in class bb.common.DepositSummaryResult

getCustomerName() - Method in class bb.common.LnShipperItemListResult

getCustomerName() - Method in class bb.common.LnShipperListResult

getCustomerName() - Method in class bb.common.MonthSoOrArByCustomerResult

getCustomerName() - Method in class bb.common.SalesMarginListResult

getCustomerName() - Method in class bb.common.SalesOrderCheckListResult

getCustomerName() - Method in class bb.common.SalesOrderListResult

getCustomerName() - Method in class bb.common.ShipperItemListResult

getCustomerName() - Method in class bb.common.ShipperListResult

getCustomerName() - Method in class bb.common.ShippingResult

getCustomerName() - Method in class bb.common.TempArApAgingVO

getCustomerName() - Method in class bb.common.ZipcodeTotalsResult

getCustomerOnTimeDeliveryRate(String, Date, Date, String, int, int, String, String, String, String) - Method in interface bb.common.box.SalesBox

getCustomerOnTimeDeliveryRateCountByCustomerId(String, Date, Date, String, int, int, String, String, String, String) - Method in interface bb.common.box.SalesBox

getCustomerParentId() - Method in class bb.common.AllStatementsListResult

getCustomerPO() - Method in class bb.common.ArCommissionListResult

getCustomerPO() - Method in class bb.common.ArPrepayVO

getCustomerPO() - Method in class bb.common.CustomerPrepayStatementListResult

getCustomerPo() - Method in class bb.common.CustomerStatementListResult

getCustomerPo() - Method in class bb.common.GeneralLedgerListResult

getCustomerPO() - Method in class bb.common.GeneralLedgerResult

getCustomerPo() - Method in class bb.common.GeneralLedgerVO

getCustomerPo() - Method in class bb.common.InvoiceItemListResult

getCustomerPo() - Method in class bb.common.OnLoanItemListResult

getCustomerPo() - Method in class bb.common.OnLoanListResult

getCustomerPo() - Method in class bb.common.OnloanShipperVO

getCustomerPo() - Method in class bb.common.OnLoanVO

getCustomerPo() - Method in class bb.common.ProformaInvoiceListResult

getCustomerPO() - Method in class bb.common.ProformaInvoiceVO

getCustomerPo() - Method in class bb.common.SalesOrderItemListResult

getCustomerPo() - Method in class bb.common.SalesOrderListResult

getCustomerPo() - Method in class bb.common.SalesOrderOnDemandResult

getCustomerPo() - Method in class bb.common.SalesOrderVO

getCustomerPo() - Method in class bb.common.ShipListItemVOResult

getCustomerPo() - Method in class bb.common.ShipperInfoVO

getCustomerPo() - Method in class bb.common.ShipperVO

getCustomerPo() - Method in class bb.common.SO2SOAgent

getCustomerPoNumber() - Method in class bb.common.AccountsReceivableInfoVO

getCustomerPoNumber() - Method in class bb.common.AccountsReceivableVO

getCustomerPrepayStatementCountById(String, String) - Method in interface bb.common.box.AccountingBox

getCustomerRefNumber() - Method in class bb.common.QuoteItemListResult

getCustomerRefNumber() - Method in class bb.common.QuoteListResult

getCustomerRefNumber() - Method in class bb.common.QuoteVO

getCustomerRfqNumber() - Method in class bb.common.QuoteItemListResult

getCustomerRFQReceiverEmail() - Method in class bb.common.CompanyVO

getCustomers() - Method in class bb.common.ImportContractPriceData

getCustomerSales() - Method in class bb.common.PaymentHistoryVO

getCustomerServiceIncidentNumber() - Method in class bb.common.CustomerFeedbackVO

getCustomerSet() - Method in class bb.common.ShipListAgent

getCustomerShipper() - Method in class bb.common.RMAReceiverVO

getCustomerShipperDate() - Method in class bb.common.RMAReceiverVO

getCustomerShippingDays() - Method in class bb.common.CustomerVendorAddressInfoVO

getCustomerShippingDays() - Method in class bb.common.CustomerVendorAddressVO

getCustomerShipVia() - Method in class bb.common.CustomerVendorAddressVO

getCustomersListCount(String, String, String) - Method in interface bb.common.box.AddressBox

getCustomerStatementByDate(String, Date, Date, String) - Method in interface bb.common.box.AccountingBox

getCustomerStatementTotalResult(String) - Method in interface bb.common.box.AccountingBox

getCustomerTaxCode() - Method in class bb.common.CustomerVendorAddressVO

getCustomerTaxRate() - Method in class bb.common.CustomerVendorAddressVO

getCustomerTerms() - Method in class bb.common.CustomerVendorAddressVO

getCustomerToCountry() - Method in class bb.common.InvoiceItemListResult

getCustomerTostate() - Method in class bb.common.InvoiceItemListResult

getCustomerTotalInfo(String) - Method in interface bb.common.box.AddressBox

getCustomerType() - Method in class bb.common.CustomerVendorTypeVO

getCustomerType() - Method in class bb.common.PartDiscountPK

getCustomerTypeByType(String) - Method in interface bb.common.box.AddressBox

getCustomerVendorAddressById(String) - Method in interface bb.common.box.AddressBox

getCustomerVendorbyTypeCount(String[]) - Method in interface bb.common.box.AddressBox

getCustomerVendorInfoVoById(String, String) - Method in interface bb.common.box.AddressBox

getCustomerVendorInfoVoById(String) - Method in interface bb.common.box.AddressBox

getCustomerVendorsByRegionCount(String, String) - Method in interface bb.common.box.AddressBox

getCustomerVendorsCount(String, String, String, String, String, String, String) - Method in interface bb.common.box.AddressBox

getCustomerVendorsCountById(String) - Method in interface bb.common.box.AddressBox

getCustomerVendorsCountByName(String) - Method in interface bb.common.box.AddressBox

getCustomerVendorsCountByValidDate(Date) - Method in interface bb.common.box.AddressBox

getCustomerVendorTypeByID(int) - Method in interface bb.common.box.AddressBox

getCustomGoodsBreedByIdCount(String, String) - Method in interface bb.common.box.HumanResourceBox

getCustomGoodsBreedByPk(String) - Method in interface bb.common.box.HumanResourceBox

getCustomGoodsRecordByDateCount(String, String, Date, Date) - Method in interface bb.common.box.HumanResourceBox

getCustomGoodsRecordByPk(Long) - Method in interface bb.common.box.HumanResourceBox

getCustomId() - Method in class bb.common.MakeBillAndHoldInvoiceAgent

getCustomId() - Method in class bb.common.MakeInvoiceAgent

getCustomJobCategoryByIdCount(String, String) - Method in interface bb.common.box.HumanResourceBox

getCustomJobCategoryByPk(String) - Method in interface bb.common.box.HumanResourceBox

getCustomJobCategoryGoods() - Method in class bb.common.CustomJobCategoryVO

getCustomProperties() - Method in class bb.common.PhysicalInventoryListWithAppDataResult

getCustomProperties() - Method in class bb.common.UpdatePhysicalInventoryAgent

getCustomProperties() - Method in class bb.common.VO

getCustomReceiveDepartment() - Method in class bb.common.CustomAssetRecordVO

getCustomReturnDepartment() - Method in class bb.common.CustomAssetRecordVO

getCustomSearch(String) - Method in interface bb.common.box.CompanyBox

getCustomSearchResultCount(ArrayList<String>, HashMap<String, Object>) - Method in interface bb.common.box.CompanyBox

getCustomTranslation() - Method in class bb.common.CustomTranslationVO

getCustomTree() - Method in class bb.common.CompanyVO

getCusTotal() - Method in class bb.common.OnloanReceiverVO

getCustPONumber() - Method in class bb.common.SGSaleItemVO

getCustQuoteMailto() - Method in class bb.common.SGCompanyVO

getCustQuotePriceMailto() - Method in class bb.common.SGCompanyVO

getCustRfqMailto() - Method in class bb.common.SGCompanyVO

getCustSaleMailto() - Method in class bb.common.SGCompanyVO

getCVAddressTotalInfo(String) - Method in interface bb.common.box.AddressBox

getCycleCount() - Method in class bb.common.PartInventoryVO

getCycleCountListByPartNumberCount(int, String, String) - Method in interface bb.common.box.WarehouseBox

getCycleCountListResultsCount(int, int) - Method in interface bb.common.box.WarehouseBox

getCycleCountListResultsCount(int) - Method in interface bb.common.box.WarehouseBox

getCycleCountListResultsWithAvgCostCount(int, int) - Method in interface bb.common.box.WarehouseBox

getCycleCountListTotalResultWithAvgCost(int, int) - Method in interface bb.common.box.WarehouseBox

getCycleCountStatusVO(int) - Method in interface bb.common.box.WarehouseBox

getCycleCountTotalResultWithAvgCost(int) - Method in interface bb.common.box.WarehouseBox

getCycleWorkSheetListResultsCount() - Method in interface bb.common.box.WarehouseBox

getCycleWorkSheetListResultsCount(int) - Method in interface bb.common.box.WarehouseBox

getCycleWorkSheetTotalPagesNumber(int) - Method in interface bb.common.box.WarehouseBox

getD01_30() - Method in class bb.common.AccountAgingTotalResult

getD31_60() - Method in class bb.common.AccountAgingTotalResult

getD61_90() - Method in class bb.common.AccountAgingTotalResult

getD90_plus() - Method in class bb.common.AccountAgingTotalResult

getDailyList() - Method in class bb.common.GLInfoByPeriodResult

getData() - Method in class bb.common.AccountsChartAdvanceCategoryVO

getData() - Method in class bb.common.ImportDataVO

getDataFilter(String) - Method in interface bb.common.box.CompanyBox

getDataVersion() - Method in class bb.common.CompanyVO

getDate() - Method in class bb.common.CustomerStatementListResult

getDate() - Method in class bb.common.DesignControlInfoVO

getDate() - Method in class bb.common.DesignControlVO

getDate() - Method in class bb.common.EmployeeRecordsVO

getDate() - Method in class bb.common.HistoricalInventoryTotalResult

getDate() - Method in class bb.common.HistoricalInventoryVO

getDate() - Method in class bb.common.InventoryTotalCostResult

getDate() - Method in class bb.common.LogInventoryListResult

getDate() - Method in class bb.common.MrpByMonthResult

getDate() - Method in class bb.common.VendorStatementListResult

getDate() - Method in class bb.common.WOIssuedByMonthResult

getDate() - Method in class bb.common.WorkCalendarVO

getDate() - Method in class bb.common.WorkCenterOnDateAgent

getDate() - Method in class bb.common.ZipcodeTotalsResult

getDate1() - Method in class bb.common.AccountPayableCheckRunVO

getDate1() - Method in class bb.common.ARPaymentRunVO

getDate1() - Method in class bb.common.ExpenseVO

getDate1() - Method in class bb.common.ShipListInfoVO

getDate1() - Method in class bb.common.ShipListVO

getDate2() - Method in class bb.common.AccountPayableCheckRunVO

getDate2() - Method in class bb.common.ARPaymentRunVO

getDate2() - Method in class bb.common.ExpenseVO

getDate2() - Method in class bb.common.ShipListInfoVO

getDate2() - Method in class bb.common.ShipListVO

getDate30Due() - Method in interface bb.common.box.AccountingBox

getDate60Due() - Method in interface bb.common.box.AccountingBox

getDate90_Due() - Method in interface bb.common.box.AccountingBox

getDate90Due() - Method in interface bb.common.box.AccountingBox

getDateAfter(Date, int) - Static method in class bb.common.BB2Util

getDateAfter(Date, int, int) - Static method in class bb.common.BB2Util

getDateAfter(int) - Static method in class bb.common.BB2Util

getDateAfter(int, int) - Static method in class bb.common.BB2Util

getDateApprovedEng() - Method in class bb.common.NonConformanceReportVO

getDateApprovedMfg() - Method in class bb.common.NonConformanceReportVO

getDateApprovedQa() - Method in class bb.common.NonConformanceReportVO

getDateCheck() - Method in class bb.common.IcrItemListResult

getDateCheck() - Method in class bb.common.InspectionConformanceReportItemVO

getDateCheckPaid() - Method in class bb.common.ApCheckRunListResult

getDateCheckRunPaid() - Method in class bb.common.ApCheckRunListResult

getDateEntered() - Method in class bb.common.CorrectiveActionRequestVO

getDateEntered() - Method in class bb.common.PreventiveActionRequestVO

getDateEntered() - Method in class bb.common.ReturnToVendorVO

getDateFrom() - Method in class bb.common.ExpenseItemVO

getDateFrom() - Method in class bb.common.ExpenseListResult

getDateFrom() - Method in class bb.common.InventoryReportListResult

getDateFrom() - Method in class bb.common.WorkPeriodVO

getDateInvoice() - Method in class bb.common.MakeCreditMemoAgent

getDateInvoiced() - Method in class bb.common.AccountsReceivableInfoVO

getDateInvoiced() - Method in class bb.common.AccountsReceivableItemVO

getDateInvoiced() - Method in class bb.common.AccountsReceivableVO

getDateInvoiced() - Method in class bb.common.ArCommissionListResult

getDateInvoiced() - Method in class bb.common.ARPaymentRunItemVO

getDateInvoiced() - Method in class bb.common.CustomerStatementListResult

getDateInvoiced() - Method in class bb.common.InvoiceItemListResult

getDateInvoiced() - Method in class bb.common.MakeBillAndHoldInvoiceAgent

getDateInvoiced() - Method in class bb.common.MakeInvoiceAgent

getDateInvoiced() - Method in class bb.common.OnloanShipperItemVO

getDateInvoiced() - Method in class bb.common.OnloanShipperVO

getDateInvoiced() - Method in class bb.common.PfReceiverItemVO

getDateInvoiced() - Method in class bb.common.ProformaInvoiceItemVO

getDateInvoiced() - Method in class bb.common.ProformaInvoiceVO

getDateInvoiced() - Method in class bb.common.RtvShipperInfoVO

getDateInvoiced() - Method in class bb.common.RtvShipperItemVO

getDateInvoiced() - Method in class bb.common.RtvShipperVO

getDateInvoiced() - Method in class bb.common.SalesTaxListResult

getDateInvoiced() - Method in class bb.common.ShipperInfoVO

getDateInvoiced() - Method in class bb.common.ShipperItemVO

getDateInvoiced() - Method in class bb.common.ShipperVO

getDateInvoiced() - Method in class bb.common.SOShipperItemListResult

getDateIssue() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getDateIssue() - Method in class bb.common.WorkOrderItemInWipListResult

getDateIssued() - Method in class bb.common.NonproductivePickingItemIssuedVO

getDateIssued() - Method in class bb.common.PartIssuedVO

getDateIssued() - Method in class bb.common.WorkOrderIssuedOrderListResult

getDateIssued() - Method in class bb.common.WorkOrderItemIssueVO

getDateIssued() - Method in class bb.common.WorkOrderItemPartDetail

getDateIssued() - Method in class bb.common.WorkOrderItemPartDetailInWipVO

getDateIssued() - Method in class bb.common.WorkOrderItemPartDetailItemResult

getDateLocalString(Date) - Static method in class bb.common.BB2Util

getDateMade() - Method in class bb.common.DisassembleWorkOrderIssueVO

getDateMade() - Method in class bb.common.DWOIssueDetail

getDateMade() - Method in class bb.common.WOReceiverDetail

getDateMade() - Method in class bb.common.WorkOrderReceiverVO

getDatePaid() - Method in class bb.common.AccountPayableCheckRunVO

getDatePaid() - Method in class bb.common.AccountPayableCheckVO

getDatePaid() - Method in class bb.common.AccountReceivablePaymentVO

getDatePaid() - Method in class bb.common.AccountsPayableInfoVO

getDatePaid() - Method in class bb.common.AccountsPayableItemVO

getDatePaid() - Method in class bb.common.AccountsPayableVO

getDatePaid() - Method in class bb.common.AccountsReceivableInfoVO

getDatePaid() - Method in class bb.common.AccountsReceivableItemVO

getDatePaid() - Method in class bb.common.AccountsReceivableVO

getDatePaid() - Method in class bb.common.APItemListResult

getDatePaid() - Method in class bb.common.ARPaymentRunVO

getDatePaid() - Method in class bb.common.AssetDepreciateDetailReport

getDatePaid() - Method in class bb.common.AssetVO

getDatePaid() - Method in class bb.common.ExpenseVO

getDatePaid() - Method in class bb.common.OnloanReceiverItemVO

getDatePaid() - Method in class bb.common.OnloanReceiverVO

getDatePaid() - Method in class bb.common.OnloanShipperItemVO

getDatePaid() - Method in class bb.common.OnloanShipperVO

getDatePaid() - Method in class bb.common.PaymentAgent

getDatePaid() - Method in class bb.common.PrepayPaymentAgent

getDatePaid() - Method in class bb.common.ProformaInvoiceVO

getDatePaid() - Method in class bb.common.ReceiverInfoVO

getDatePaid() - Method in class bb.common.ReceiverItemVO

getDatePaid() - Method in class bb.common.ReceiverVO

getDatePaid() - Method in class bb.common.RMAReceiverItemVO

getDatePaid() - Method in class bb.common.RMAReceiverVO

getDatePaid() - Method in class bb.common.RtvShipperInfoVO

getDatePaid() - Method in class bb.common.RtvShipperItemVO

getDatePaid() - Method in class bb.common.RtvShipperVO

getDatePaid() - Method in class bb.common.ShipperInfoVO

getDatePaid() - Method in class bb.common.ShipperItemVO

getDatePaid() - Method in class bb.common.ShipperVO

getDateReceived() - Method in class bb.common.AccountsPayableInfoVO

getDateReceived() - Method in class bb.common.AccountsPayableVO

getDateReceived() - Method in class bb.common.APItemListResult

getDateReceived() - Method in class bb.common.DisassembleWorkOrderItemPartDetailItemResult

getDateReceived() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

getDateReceived() - Method in class bb.common.OnloanReceiverItemListResult

getDateReceived() - Method in class bb.common.OnloanReceiverListResult

getDateReceived() - Method in class bb.common.OnloanReceiverVO

getDateReceived() - Method in class bb.common.PartReceivedVO

getDateReceived() - Method in class bb.common.PfReceiverVO

getDateReceived() - Method in class bb.common.PrReceiverListResult

getDateReceived() - Method in class bb.common.ReceiverInfoVO

getDateReceived() - Method in class bb.common.ReceiverVO

getDateReceived() - Method in class bb.common.RMAReceiverItemListResult

getDateReceived() - Method in class bb.common.RMAReceiverListResult

getDateReceived() - Method in class bb.common.RMAReceiverVO

getDateReceived() - Method in class bb.common.TempReceiverWithoutAPInfo

getDateRequired() - Method in class bb.common.ApPrepayItemVO

getDateRequired() - Method in class bb.common.ArPrepayItemVO

getDateRequired() - Method in class bb.common.CustomerPrepayStatementListResult

getDateRequired() - Method in class bb.common.DisassembleWorkOrderItemVO

getDateRequired() - Method in class bb.common.DWOIssueDetail

getDateRequired() - Method in class bb.common.PartIssuedListResult

getDateRequired() - Method in class bb.common.PartReceivedListResult

getDateRequired() - Method in class bb.common.PoMessageItemVO

getDateRequired() - Method in class bb.common.PurchaseOrderItemVO

getDateRequired() - Method in class bb.common.PurchaseOrderVO

getDateRequired() - Method in class bb.common.RequestForQuoteItemVO

getDateRequired() - Method in class bb.common.ReturnToVendorByDateListResult

getDateRequired() - Method in class bb.common.ReturnToVendorVO

getDateRequired() - Method in class bb.common.ShoppingCartItem

getDateRequired() - Method in class bb.common.VendorPrepayStatementListResult

getDateRequired() - Method in class bb.common.WO2WOAgent

getDateRequired() - Method in class bb.common.WoItemPickListResult

getDateRequired() - Method in class bb.common.WOReceiverDetail

getDateRequired() - Method in class bb.common.WorkOrderItemCanAssyResult

getDateRequired() - Method in class bb.common.WorkOrderItemReviewCostResult

getDateRequired() - Method in class bb.common.WorkOrderItemVO

getDateRequired() - Method in class bb.common.WorkOrderOverIssueListResult

getDateRequired() - Method in class bb.common.WorkOrderWorkItemDateAgent

getDateRequited() - Method in class bb.common.ShipListItemVOResult

getDateSave() - Method in class bb.common.TempReceiverWithoutAPInfo

getDateShiped() - Method in class bb.common.SalesTaxListResult

getDateShipped() - Method in class bb.common.AccountsReceivableInfoVO

getDateShipped() - Method in class bb.common.AccountsReceivableItemVO

getDateShipped() - Method in class bb.common.AccountsReceivableVO

getDateShipped() - Method in class bb.common.LnShipperItemListResult

getDateShipped() - Method in class bb.common.LnShipperListResult

getDateShipped() - Method in class bb.common.OnloanShipperItemVO

getDateShipped() - Method in class bb.common.OnloanShipperVO

getDateShipped() - Method in class bb.common.PfReceiverItemVO

getDateShipped() - Method in class bb.common.ProformaInvoiceItemListResult

getDateShipped() - Method in class bb.common.ProformaInvoiceItemVO

getDateShipped() - Method in class bb.common.ProformaInvoiceListResult

getDateShipped() - Method in class bb.common.ProformaInvoiceVO

getDateShipped() - Method in class bb.common.RtvShipperInfoVO

getDateShipped() - Method in class bb.common.RtvShipperItemListResult

getDateShipped() - Method in class bb.common.RtvShipperItemVO

getDateShipped() - Method in class bb.common.RtvShipperListResult

getDateShipped() - Method in class bb.common.RtvShipperVO

getDateShipped() - Method in class bb.common.SGSaleItemVO

getDateShipped() - Method in class bb.common.ShipperInfoVO

getDateShipped() - Method in class bb.common.ShipperItemListResult

getDateShipped() - Method in class bb.common.ShipperItemVO

getDateShipped() - Method in class bb.common.ShipperVO

getDateShipped() - Method in class bb.common.SOShipperItemListResult

getDateTimeLocalString(Date) - Static method in class bb.common.BB2Util

getDateTo() - Method in class bb.common.ExpenseItemVO

getDateTo() - Method in class bb.common.ExpenseListResult

getDateTo() - Method in class bb.common.InventoryReportListResult

getDateTo() - Method in class bb.common.WorkPeriodVO

getDateUsed() - Method in class bb.common.partUsedInfoResult

getDateWithMaxTime(Date) - Static method in class bb.common.BB2Util

getDateWithMinTime(Date) - Static method in class bb.common.BB2Util

getDateWithoutTime(Date) - Static method in class bb.common.BB2Util

getDay() - Method in class bb.common.WorkCalendarVO

getDay1() - Method in class bb.common.OnTimeAgent

getDay1() - Method in class bb.common.PurchaseOnTimeResult

getDay1() - Method in class bb.common.SalesOnTimeResult

getDay1() - Method in class bb.common.WorkOrderOnTimeResult

getDay2() - Method in class bb.common.OnTimeAgent

getDay2() - Method in class bb.common.PurchaseOnTimeResult

getDay2() - Method in class bb.common.SalesOnTimeResult

getDay2() - Method in class bb.common.WorkOrderOnTimeResult

getDayMatchTime(String, String) - Static method in class bb.common.BB2Util

getDays() - Method in class bb.common.PurchaseOrderOnTimeItemResult

getDays() - Method in class bb.common.SalesOrderOnTimeItemResult

getDays() - Method in class bb.common.TermAgent

getDays() - Method in class bb.common.TermVO

getDays() - Method in class bb.common.WorkOrderOnTimeItemResult

getDaysCurrent() - Method in class bb.common.CompanyVO

getDaysOverdue() - Method in class bb.common.CompanyVO

getDaysPerWeek() - Method in class bb.common.WorkCenterVO

getDCByDcNumber(String) - Method in interface bb.common.box.EngineeringBox

getDCCountByDcNumber(String) - Method in interface bb.common.box.EngineeringBox

getDCCountByEngineerNameLike(String) - Method in interface bb.common.box.EngineeringBox

getDCCountByPartLike(String, String, String) - Method in interface bb.common.box.EngineeringBox

getDCDocByPk(Long) - Method in interface bb.common.box.EngineeringBox

getDcNumber() - Method in class bb.common.DesignControlListResult

getDcode() - Method in class bb.common.OnLoanItemVO

getDCode() - Method in class bb.common.PartDiscountPK

getDCode() - Method in class bb.common.PartInventoryVO

getDCode() - Method in class bb.common.ToolInventoryVO

getDd() - Method in class bb.common.DesignControlInfoVO

getDd() - Method in class bb.common.DesignControlVO

getDebit() - Method in class bb.common.AccountBalanceListResult

getDebit() - Method in class bb.common.AccountDebitVO

getDebit() - Method in class bb.common.ClosingStatementItemResult

getDebit() - Method in class bb.common.ExchangeAuditItemResult

getDebit() - Method in class bb.common.GeneralLedgerByDateListResult

getDebit() - Method in class bb.common.GeneralLedgerEntry

getDebit() - Method in class bb.common.GLDebitCreditListResult

getDebit() - Method in class bb.common.GLItemVO

getDebit() - Method in class bb.common.NcrScrapAgent

getDebitAccount() - Method in class bb.common.AccountsPayableInfoVO

getDebitAccount() - Method in class bb.common.AccountsPayableVO

getDebitAccount() - Method in class bb.common.AddPayableWithoutReceiverAgent

getDebitAccount() - Method in class bb.common.APItemListResult

getDebitAccount() - Method in class bb.common.ARPrepaymentWireTransferAgent

getDebitAccount() - Method in class bb.common.CRTVItemListResult

getDebitAccount() - Method in class bb.common.CustomerReturnToVendorVO

getDebitAccount() - Method in class bb.common.DisassembleWorkOrderIssuingResult

getDebitAccount() - Method in class bb.common.DisassembleWorkOrderVO

getDebitAccount() - Method in class bb.common.JounalEntryListResult

getDebitAccount() - Method in class bb.common.MakeAccountPayableAgent

getDebitAccount() - Method in class bb.common.MakeBillAndHoldInvoiceAgent

getDebitAccount() - Method in class bb.common.MakeCheckAgent

getDebitAccount() - Method in class bb.common.MakeDebitMemoAgent

getDebitAccount() - Method in class bb.common.MakeInvoiceAgent

getDebitAccount() - Method in class bb.common.OnloanReceiverVO

getDebitAccount() - Method in class bb.common.OnloanShipperVO

getDebitAccount() - Method in class bb.common.OnLoanVO

getDebitAccount() - Method in class bb.common.PostCheckAgent

getDebitAccount() - Method in class bb.common.PrepaymentWireTransferAgent

getDebitAccount() - Method in class bb.common.PurchaseOrderVO

getDebitAccount() - Method in class bb.common.PurchaseWorkSheetVO

getDebitAccount() - Method in class bb.common.ReceiverInfoVO

getDebitAccount() - Method in class bb.common.ReceiverVO

getDebitAccount() - Method in class bb.common.ReceivingResult

getDebitAccount() - Method in class bb.common.RequestForQuoteVO

getDebitAccount() - Method in class bb.common.RequestForRMAVO

getDebitAccount() - Method in class bb.common.ReturnMaterialAuthorizationVO

getDebitAccount() - Method in class bb.common.ReturnToVendorByDateListResult

getDebitAccount() - Method in class bb.common.ReturnToVendorVO

getDebitAccount() - Method in class bb.common.RMAItemListResult

getDebitAccount() - Method in class bb.common.RMAReceiverVO

getDebitAccount() - Method in class bb.common.RRMAItemListResult

getDebitAccount() - Method in class bb.common.RtvShipperInfoVO

getDebitAccount() - Method in class bb.common.RtvShipperVO

getDebitAccount() - Method in class bb.common.ScrapReportVO

getDebitAccount() - Method in class bb.common.ShipperInfoVO

getDebitAccount() - Method in class bb.common.ShipperVO

getDebitAccount() - Method in class bb.common.WireTransferAgent

getDebitAccount() - Method in class bb.common.WorkOrderVO

getDebitAccount() - Method in class bb.common.WorkOrderWorkSheetVO

getDebitAccountBalance() - Method in class bb.common.AccountBalanceAgent

getDebitAccounts() - Method in class bb.common.GeneralLedgerCategoryVO

getDebitAmount() - Method in class bb.common.AccountBalanceResult

getDebitAmount() - Method in class bb.common.JounalEntryListResult

getDebitBalance() - Method in class bb.common.MonthBalanceResult

getDebitBeginPeriodBalance() - Method in class bb.common.AccountBalanceResult

getDebitEndingBalance() - Method in class bb.common.CurrentBalanceResult

getDebitEndPeriodBalance() - Method in class bb.common.AccountBalanceResult

getDebitListCountByApNumber(String) - Method in interface bb.common.box.AccountingBox

getDebitListCountByAppNumber(String) - Method in interface bb.common.box.AccountingBox

getDebitListCountByArNumber(String) - Method in interface bb.common.box.AccountingBox

getDebitMemoComments() - Method in class bb.common.MakeDebitMemoAgent

getDebitMemoNotes() - Method in class bb.common.MakeDebitMemoAgent

getDebitMonthTotal() - Method in class bb.common.CurrentBalanceResult

getDebitOrCredit() - Method in class bb.common.AccountBalanceResult

getDebitOrCredit() - Method in class bb.common.AccountsChartVO

getDebitOrCredit() - Method in class bb.common.AddressAccountInfo

getDebitOrCredit() - Method in class bb.common.AmountsStatementResult

getDebitOrCredit() - Method in class bb.common.GLInfoByPeriodResult

getDebitOrCredit() - Method in class bb.common.JounalEntryListResult

getDebitOrCredit() - Method in class bb.common.ShareHoldersEquityResult

getDebits() - Method in class bb.common.DebitsCreditsResult

getDebitsCreditsResultForAP(String, String) - Method in interface bb.common.box.AccountingBox

getDebitsCreditsResultForApp(String) - Method in interface bb.common.box.AccountingBox

getDebitsCreditsResultForAR(String, String) - Method in interface bb.common.box.AccountingBox

getDebitsCreditsResultForArp(String) - Method in interface bb.common.box.AccountingBox

getDebitsCreditsResultForDM(String, String) - Method in interface bb.common.box.AccountingBox

getDebitStartingBalance() - Method in class bb.common.CurrentBalanceResult

getDebitText() - Method in class bb.common.NcrScrapAgent

getDecimalLength() - Method in class bb.common.CompanyVO

getDeductable() - Method in class bb.common.AccountBalanceResult

getDeductable() - Method in class bb.common.AccountsChartVO

getDefaultAccount() - Method in class bb.common.CustomerVendorAddressInfoVO

getDefaultAccount() - Method in class bb.common.CustomerVendorAddressVO

getDefaultMFG() - Method in class bb.common.PointOfSaleVO

getDefaultVendor() - Method in class bb.common.WorkCenterVendorVO

getDefaultVendorTax() - Method in class bb.common.CompanyVO

getDefaultWi() - Method in class bb.common.WorkInstructionListResult

getDefaultWi() - Method in class bb.common.WorkInstructionVO

getDefaultWi() - Method in class bb.common.WorkOrderWorkInstructionVO

getDefaultWISetId(BB2Part) - Method in interface bb.common.box.ManufacturingBox

getDefaultWorkInstructionByPartPk(BB2Part) - Method in interface bb.common.box.ManufacturingBox

getDefaultWOVendorID() - Method in class bb.common.CompanyVO

getDegree() - Method in class bb.common.CustomEmployeeVO

getDegree() - Method in class bb.common.EmployeeEducationVO

getDelay() - Method in class bb.common.CustomerReturnToVendorItemVO

getDelay() - Method in class bb.common.CustomerReturnToVendorVO

getDelay() - Method in class bb.common.DisassembleWorkOrderVO

getDelay() - Method in class bb.common.OnLoanItemVO

getDelay() - Method in class bb.common.OnLoanVO

getDelay() - Method in class bb.common.PoMessageItemVO

getDelay() - Method in class bb.common.QuoteVO

getDelay() - Method in class bb.common.RequestForQuoteItemVO

getDelay() - Method in class bb.common.RequestForQuoteVO

getDelay() - Method in class bb.common.RequestForRMAItemVO

getDelay() - Method in class bb.common.RequestForRMAVO

getDelay() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getDelay() - Method in class bb.common.ReturnMaterialAuthorizationVO

getDelay() - Method in class bb.common.ReturnToVendorItemVO

getDelay() - Method in class bb.common.RfqMessageItemVO

getDelay() - Method in class bb.common.SalesOrderVO

getDelay() - Method in class bb.common.WorkOrderVO

getDelayDays() - Method in class bb.common.DisassembleWorkOrderItemVO

getDelayDays() - Method in class bb.common.NonproductivePickingItemVO

getDelayDays() - Method in class bb.common.NonproductivePickingOnDemandResult

getDelayDays() - Method in class bb.common.OrderApprovalItemsVO

getDelayDays() - Method in class bb.common.PO2POAgent

getDelayDays() - Method in class bb.common.PO2SOExchangeItem

getDelayDays() - Method in class bb.common.POStatisticsResult

getDelayDays() - Method in class bb.common.PurchaseOrderContractResult

getDelayDays() - Method in class bb.common.PurchaseOrderItemListResult

getDelayDays() - Method in class bb.common.PurchaseOrderItemVO

getDelayDays() - Method in class bb.common.PurchaseOrderOnOrderResult

getDelayDays() - Method in class bb.common.PurchaseOrderOpenDueListResult

getDelayDays() - Method in class bb.common.PurchaseOrderVO

getDelayDays() - Method in class bb.common.QuoteItemVO

getDelayDays() - Method in class bb.common.ReturnToVendorVO

getDelayDays() - Method in class bb.common.SalesOrderItemInfoVO

getDelayDays() - Method in class bb.common.SalesOrderItemListResult

getDelayDays() - Method in class bb.common.SalesOrderItemVO

getDelayDays() - Method in class bb.common.SalesOrderOnDemandResult

getDelayDays() - Method in class bb.common.SO2SOAgent

getDelayDays() - Method in class bb.common.SwapOrderItemListResult

getDelayDays() - Method in class bb.common.SwapOrderItemVO

getDelayDays() - Method in class bb.common.TransferOrderItemListResult

getDelayDays() - Method in class bb.common.TransferOrderItemVO

getDelayDays() - Method in class bb.common.WorkOrderInWipResult

getDelayDays() - Method in class bb.common.WorkOrderItemVO

getDelayDays() - Method in class bb.common.WorkOrderOnDemandResult

getDelayDays() - Method in class bb.common.WorkOrderOnOrderResult

getDeletedCustomersCountById(String) - Method in interface bb.common.box.AddressBox

getDeletedCustomerVendorAddressesByIdCount(String) - Method in interface bb.common.box.AddressBox

getDeletedDepartmentsCountById(String) - Method in interface bb.common.box.AddressBox

getDeletedManufacturerAddressesCount(String, String) - Method in interface bb.common.box.AddressBox

getDeletedVendorsCountById(String) - Method in interface bb.common.box.AddressBox

getDeleveryDate() - Method in class bb.common.PurchaseOrderItemListResult

getDeleveryDate() - Method in class bb.common.PurchaseOrderOpenDueListResult

getDeliveredTo() - Method in class bb.common.AccountsPayableInfoVO

getDeliveredTo() - Method in class bb.common.AccountsPayableVO

getDeliveredTo() - Method in class bb.common.OnloanReceiverVO

getDeliveredTo() - Method in class bb.common.ReceiverInfoVO

getDeliveredTo() - Method in class bb.common.ReceiverVO

getDeliveredTo() - Method in class bb.common.RMAReceiverVO

getDelivery() - Method in class bb.common.CustomerReturnToVendorItemVO

getDelivery() - Method in class bb.common.CustomerReturnToVendorVO

getDelivery() - Method in class bb.common.DisassembleWorkOrderVO

getDelivery() - Method in class bb.common.EcnPOOrderResult

getDelivery() - Method in class bb.common.EcnWOOrderResult

getDelivery() - Method in class bb.common.OnLoanItemVO

getDelivery() - Method in class bb.common.OnLoanVO

getDelivery() - Method in class bb.common.PurchaseOrderCheckListResult

getDelivery() - Method in class bb.common.PurchaseWorkSheetItemVO

getDelivery() - Method in class bb.common.QuoteItemListResult

getDelivery() - Method in class bb.common.QuoteItemVO

getDelivery() - Method in class bb.common.QuoteVO

getDelivery() - Method in class bb.common.RequestForQuoteCheckListResult

getDelivery() - Method in class bb.common.RequestForQuoteItemListResult

getDelivery() - Method in class bb.common.RequestForQuoteListResult

getDelivery() - Method in class bb.common.RequestForQuoteVO

getDelivery() - Method in class bb.common.RequestForRMAItemVO

getDelivery() - Method in class bb.common.RequestForRMAVO

getDelivery() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getDelivery() - Method in class bb.common.ReturnMaterialAuthorizationVO

getDelivery() - Method in class bb.common.ReturnToVendorCheckListResult

getDelivery() - Method in class bb.common.ReturnToVendorItemListResult

getDelivery() - Method in class bb.common.ReturnToVendorItemVO

getDelivery() - Method in class bb.common.ReturnToVendorListResult

getDelivery() - Method in class bb.common.RMAReceiverResult

getDelivery() - Method in class bb.common.SalesOrderVO

getDelivery() - Method in class bb.common.WCLoadDetailResult

getDelivery() - Method in class bb.common.WorkOrderItemToIssueResult

getDelivery() - Method in class bb.common.WorkOrderItemWCLoadResult

getDelivery() - Method in class bb.common.WorkOrderListResult

getDelivery() - Method in class bb.common.WorkOrderVO

getDelivery() - Method in class bb.common.WorkOrderWorkSheetItemVO

getDelivery() - Method in class bb.common.WorkSheetPartAgent

getDeliveryDate() - Method in class bb.common.BB2PartInSipItemResult

getDeliveryDate() - Method in class bb.common.BB2PartInSipOfSoItemResult

getDeliveryDate() - Method in class bb.common.BB2PartInSitItemResult

getDeliveryDate() - Method in class bb.common.CRTVItemListResult

getDeliveryDate() - Method in class bb.common.NonproductivePickingItemVO

getDeliveryDate() - Method in class bb.common.NonproductivePickingOnDemandResult

getDeliveryDate() - Method in class bb.common.OnLoanItemListResult

getDeliveryDate() - Method in class bb.common.PurchaseOrderOnOrderResult

getDeliveryDate() - Method in class bb.common.RMAItemListResult

getDeliveryDate() - Method in class bb.common.RRMAItemListResult

getDeliveryDate() - Method in class bb.common.SalesOrderItemInfoVO

getDeliveryDate() - Method in class bb.common.SalesOrderItemListResult

getDeliveryDate() - Method in class bb.common.SalesOrderItemVO

getDeliveryDate() - Method in class bb.common.SalesOrderOnDemandResult

getDeliveryDate() - Method in class bb.common.SalesOrderShipDateListResult

getDeliveryDate() - Method in class bb.common.ShipListItemRelatedDocResult

getDeliveryDate() - Method in class bb.common.ShipperItemListResult

getDeliveryDate() - Method in class bb.common.SwapOrderItemListResult

getDeliveryDate() - Method in class bb.common.SwapOrderItemVO

getDeliveryDate() - Method in class bb.common.TransferOrderItemListResult

getDeliveryDate() - Method in class bb.common.TransferOrderItemVO

getDeliveryDate() - Method in class bb.common.WOItemPartDetailNotIssue

getDeliveryDate() - Method in class bb.common.WorkOrderInWipResult

getDeliveryDate() - Method in class bb.common.WorkOrderItemPartDetailResult

getDeliveryDate() - Method in class bb.common.WorkOrderItemTimeDetailResult

getDeliveryDate() - Method in class bb.common.WorkOrderOnDemandResult

getDeliveryDate() - Method in class bb.common.WorkOrderOnOrderResult

getDemand() - Method in class bb.common.OrderDemandForReceiverResult

getDemand() - Method in class bb.common.ShippingItemResult

getDepartment() - Method in class bb.common.BizBoxUserEmployeeResult

getDepartment() - Method in class bb.common.BizboxUserListResult

getDepartment() - Method in class bb.common.BuyerCodeVO

getDepartment() - Method in class bb.common.CustomAssetVO

getDepartment() - Method in class bb.common.CustomEmployeeVO

getDepartment() - Method in class bb.common.DesignControlInfoVO

getDepartment() - Method in class bb.common.DesignControlVO

getDepartment() - Method in class bb.common.EmployeeCardVO

getDepartment() - Method in class bb.common.ExpenseVO

getDepartment() - Method in class bb.common.NoticeUserEmployeeListResult

getDepartment() - Method in class bb.common.SalesmanVO

getDepartment() - Method in class bb.common.WorkCenterLoadListResult

getDepartment() - Method in class bb.common.WorkCenterVO

getDepartmentAccount() - Method in class bb.common.CustomerVendorAddressInfoVO

getDepartmentAccount() - Method in class bb.common.CustomerVendorAddressVO

getDepartmentById(String) - Method in interface bb.common.box.AddressBox

getDepartmentDepositBank() - Method in class bb.common.CustomerVendorAddressInfoVO

getDepartmentDepositBank() - Method in class bb.common.CustomerVendorAddressVO

getDepartmentID() - Method in class bb.common.AssetAddOrDisposalsReport

getDepartmentID() - Method in class bb.common.AssetDepreciateDetailReport

getDepartmentID() - Method in class bb.common.AssetDepreciateVO

getDepartmentID() - Method in class bb.common.AssetVO

getDepartmentId() - Method in class bb.common.BuyerCodeVO

getDepartmentId() - Method in class bb.common.CorrectiveActionRequestVO

getDepartmentID() - Method in class bb.common.DepreciateMonthlyReport

getDepartmentId() - Method in class bb.common.EquipmentListResult

getDepartmentId() - Method in class bb.common.EquipmentVO

getDepartmentId() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getDepartmentId() - Method in class bb.common.NonproductivePickingItemIssuedVO

getDepartmentId() - Method in class bb.common.NonproductivePickingVO

getDepartmentId() - Method in class bb.common.PreventiveActionRequestVO

getDepartmentId() - Method in class bb.common.WorkInstructionRequestForChangeVO

getDepartmentLike() - Method in class bb.common.WorkCenterLoadAgent

getDepartmentList() - Method in interface bb.common.box.HumanResourceBox

getDepartmentLocationForBackflushByPk(String) - Method in interface bb.common.box.WarehouseBox

getDepartmentName() - Method in class bb.common.PreventiveActionRequestVO

getDepartmentsCountById(String) - Method in interface bb.common.box.AddressBox

getDepartmentsCountByName(String) - Method in interface bb.common.box.AddressBox

getDepartmentsListCount(String, String) - Method in interface bb.common.box.AddressBox

getDepartmentTotalInfo(String) - Method in interface bb.common.box.AddressBox

getDepartName() - Method in class bb.common.CorrectiveActionRequestVO

getDepreciate() - Method in class bb.common.AssetDepreciateDetailReport

getDepreciatedAccm() - Method in class bb.common.AssetDepreciateDetailReport

getDepreciatedAccm() - Method in class bb.common.AssetDepreciateVO

getDepreciatedAccm() - Method in class bb.common.AssetReportSumResult

getDepreciatedAccm() - Method in class bb.common.AssetVO

getDepreciatedAccm(String) - Method in interface bb.common.box.AccountingBox

getDepreciatedAccmMonths() - Method in class bb.common.AssetVO

getDepreciateDate() - Method in class bb.common.AssetDepreciateVO

getDepreciatedCost() - Method in class bb.common.AssetVO

getDepreciateEndDate() - Method in class bb.common.AssetAddOrDisposalsReport

getDepreciateEndDate() - Method in class bb.common.AssetDepreciateDetailReport

getDepreciateEndDate() - Method in class bb.common.AssetVO

getDepreciateStartDate() - Method in class bb.common.AssetAddOrDisposalsReport

getDepreciateStartDate() - Method in class bb.common.AssetDepreciateDetailReport

getDepreciateStartDate() - Method in class bb.common.AssetVO

getDepreciateStatus() - Method in class bb.common.AssetAddOrDisposalsReport

getDepreciateStatus() - Method in class bb.common.AssetDepreciateVO

getDepreciateStatus() - Method in class bb.common.AssetVO

getDepreciateStatus() - Method in class bb.common.DepreciateMonthlyReport

getDepreciations() - Method in class bb.common.AssetVO

getDepreciationType() - Method in class bb.common.AssetVO

getDepricateAccount() - Method in class bb.common.ScrapAssetAgent

getDesc() - Method in class bb.common.BB2BigDecimalAndString

getDesc() - Method in class bb.common.InventoryPartInOutDetailListResult

getDesc() - Method in class bb.common.RunningAccountOrderItemVO

getDescripiton() - Method in class bb.common.BillItemUsagePathResult

getDescripiton() - Method in class bb.common.SGBOMItemResult

getDescription() - Method in class bb.common.AccountBalanceResult

getDescription() - Method in class bb.common.AccountCreditVO

getDescription() - Method in class bb.common.AccountDebitVO

getDescription() - Method in class bb.common.AccountingTransactionTypeVO

getDescription() - Method in class bb.common.AccountsChartVO

getDescription() - Method in class bb.common.AccountsCreditDebitListResult

getDescription() - Method in class bb.common.AccountsPayableItemVO

getDescription() - Method in class bb.common.AccountsReceivableItemVO

getDescription() - Method in class bb.common.AddPayableWithoutReceiverAgent

getDescription() - Method in class bb.common.AddressAccountInfo

getDescription() - Method in class bb.common.AllPartDocumentsVO

getDescription() - Method in class bb.common.AmountsStatementResult

getDescription() - Method in class bb.common.APItemListResult

getDescription() - Method in class bb.common.ARBoilerplateVO

getDescription() - Method in class bb.common.AssetAddOrDisposalsReport

getDescription() - Method in class bb.common.AssetDepreciateDetailReport

getDescription() - Method in class bb.common.AssetDepreciateVO

getDescription() - Method in class bb.common.AssetVO

getDescription() - Method in class bb.common.AuditOnDemandResult

getDescription() - Method in class bb.common.BB2DoubleString

getDescription() - Method in class bb.common.BB2PartBasicInfo

getDescription() - Method in class bb.common.BB2PartOnDemandListResult

getDescription() - Method in class bb.common.BB2Task

getDescription() - Method in class bb.common.BillItemSalesCostResult

getDescription() - Method in class bb.common.BillItemSalesResult

getDescription() - Method in class bb.common.BillItemSalesXResult

getDescription() - Method in class bb.common.BillSalesCostResult

getDescription() - Method in class bb.common.BillSalesResult

getDescription() - Method in class bb.common.BillSalesXResult

getDescription() - Method in class bb.common.BillWhereUsedItemResult

getDescription() - Method in class bb.common.BillWhereUsedResult

getDescription() - Method in class bb.common.BizboxBugChangesInfoVO

getDescription() - Method in class bb.common.BizboxBugChangesVO

getDescription() - Method in class bb.common.BOMCanAssyListResult

getDescription() - Method in class bb.common.BomItemWithOEMResult

getDescription() - Method in class bb.common.BomPickListItemResult

getDescription() - Method in class bb.common.BomPickListResult

getDescription() - Method in class bb.common.BomWithOEMResult

getDescription() - Method in class bb.common.BudgetListResult

getDescription() - Method in class bb.common.BuyerCodeVO

getDescription() - Method in class bb.common.CatalogVO

getDescription() - Method in class bb.common.CertificateDescriptionVO

getDescription() - Method in class bb.common.ChangeStdCostWorkSheetItemVO

getDescription() - Method in class bb.common.ContractPriceItemVO

getDescription() - Method in class bb.common.ContractPriceVO

getDescription() - Method in class bb.common.CorrectiveActionRequestVO

getDescription() - Method in class bb.common.CPItemFromQuoteResult

getDescription() - Method in class bb.common.CustomDepartmentVO

getDescription() - Method in class bb.common.CustomerReturnToVendorItemVO

getDescription() - Method in class bb.common.CustomerServiceIncidentItemListResult

getDescription() - Method in class bb.common.CustomerServiceIncidentItemVO

getDescription() - Method in class bb.common.CustomerServiceIncidentListResult

getDescription() - Method in class bb.common.CustomerServiceIncidentVO

getDescription() - Method in class bb.common.CycleCountListResult

getDescription() - Method in class bb.common.CycleCountStatusVO

getDescription() - Method in class bb.common.DepositSummaryResult

getDescription() - Method in class bb.common.DesignControlDocumentVO

getDescription() - Method in class bb.common.DisassembleWorkOrderIssueVO

getDescription() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getDescription() - Method in class bb.common.DisassembleWorkOrderItemPartDetailItemResult

getDescription() - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

getDescription() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

getDescription() - Method in class bb.common.DisassembleWorkOrderItemVO

getDescription() - Method in class bb.common.DisassembleWorkOrderReceivingResult

getDescription() - Method in class bb.common.DWOIssueDetail

getDescription() - Method in class bb.common.EcnPOOrderResult

getDescription() - Method in class bb.common.EcnWOOrderResult

getDescription() - Method in class bb.common.EmployeeEducationVO

getDescription() - Method in class bb.common.EmployeeJobDescriptionVO

getDescription() - Method in class bb.common.EmployeeRecordsVO

getDescription() - Method in class bb.common.EmployeeWorkExperienceVO

getDescription() - Method in class bb.common.EngineeringChangeRequestVO

getDescription() - Method in class bb.common.EngineeringChangeVO

getDescription() - Method in class bb.common.EquipmentListResult

getDescription() - Method in class bb.common.EquipmentVO

getDescription() - Method in class bb.common.ExpenseAccountVO

getDescription() - Method in class bb.common.ExpenseItemVO

getDescription() - Method in class bb.common.GeneralLedgerByDateListResult

getDescription() - Method in class bb.common.GeneralLedgerEntry

getDescription() - Method in class bb.common.GeneralLedgerListResult

getDescription() - Method in class bb.common.GeneralLedgerVO

getDescription() - Method in class bb.common.GLApprovalListResult

getDescription() - Method in class bb.common.GLAutoApproveVO

getDescription() - Method in class bb.common.GLItemVO

getDescription() - Method in class bb.common.GroupUserVO

getDescription() - Method in class bb.common.HelpServerVO

getDescription() - Method in class bb.common.HighUsagePartResult

getDescription() - Method in class bb.common.HistoricalInventoryVO

getDescription() - Method in class bb.common.IncotermVO

getDescription() - Method in class bb.common.InspectionReportInspectMethodVO

getDescription() - Method in class bb.common.InventoryAdjustmentListResult

getDescription() - Method in class bb.common.InventoryCycleResult

getDescription() - Method in class bb.common.InventoryListResult

getDescription() - Method in class bb.common.InventoryMonthReport

getDescription() - Method in class bb.common.InventoryNotUsedInMonthsResult

getDescription() - Method in class bb.common.InvoiceItemListResult

getDescription() - Method in class bb.common.IssuingItemResult

getDescription() - Method in class bb.common.IssuingResult

getDescription() - Method in class bb.common.JobProcessSheetListResult

getDescription() - Method in class bb.common.JobProcessSheetResult

getDescription() - Method in class bb.common.JounalEntryListResult

getDescription() - Method in class bb.common.LnShipperItemListResult

getDescription() - Method in class bb.common.LogInventoryListResult

getDescription() - Method in class bb.common.LogMiscDocumentVO

getDescription() - Method in class bb.common.LogPartDocumentVO

getDescription() - Method in class bb.common.LogPartDwfVO

getDescription() - Method in class bb.common.LogPartDwgVO

getDescription() - Method in class bb.common.LogTaskVO

getDescription() - Method in class bb.common.LogTrackingVO

getDescription() - Method in class bb.common.MultiLanguageAccountsChartVO

getDescription() - Method in class bb.common.NonConformanceCodeDescriptionVO

getDescription() - Method in class bb.common.NonproductivePickingItemIssuedVO

getDescription() - Method in class bb.common.NonproductivePickingItemResult

getDescription() - Method in class bb.common.NonproductivePickingItemVO

getDescription() - Method in class bb.common.NonproductivePickingOnDemandResult

getDescription() - Method in class bb.common.NoticeUserEmployeeListResult

getDescription() - Method in class bb.common.OnLoanItemVO

getDescription() - Method in class bb.common.OnloanReceiverItemListResult

getDescription() - Method in class bb.common.OnloanReceiverItemVO

getDescription() - Method in class bb.common.OnloanShipperItemVO

getDescription() - Method in class bb.common.OperatingInstructionsInspectStandardVO

getDescription() - Method in class bb.common.OperatingInstructionsManualVO

getDescription() - Method in class bb.common.OperatingInstructionsTypeVO

getDescription() - Method in class bb.common.OperatingOutputFileTypeVO

getDescription() - Method in class bb.common.OrderApprovalItemsVO

getDescription() - Method in class bb.common.OrderApprovalVO

getDescription() - Method in class bb.common.PackingBoxItemListResult

getDescription() - Method in class bb.common.PackingBoxItemVO

getDescription() - Method in class bb.common.PackingBoxSalesOrderItemResult

getDescription() - Method in class bb.common.PartBasicInfo

getDescription() - Method in class bb.common.PartCatalogAuditResult

getDescription() - Method in class bb.common.PartClassInfoResult

getDescription() - Method in class bb.common.PartDescriptionVO

getDescription() - Method in class bb.common.PartDocumentVO

getDescription() - Method in class bb.common.PartInMrpListResult

getDescription() - Method in class bb.common.PartInspectionResult

getDescription() - Method in class bb.common.PartInWipForIDListResult

getDescription() - Method in class bb.common.PartIssuedVO

getDescription() - Method in class bb.common.PartMaterialWhereUsedItemResult

getDescription() - Method in class bb.common.PartMaterialWhereUsedResult

getDescription() - Method in class bb.common.PartOnHandAuditResult

getDescription() - Method in class bb.common.PartOnhandResult

getDescription() - Method in class bb.common.PartReceivedVO

getDescription() - Method in class bb.common.PartToAuditFlagResult

getDescription() - Method in class bb.common.PartTypeVO

getDescription() - Method in class bb.common.PartUseTypeVO

getDescription() - Method in class bb.common.PartVO

getDescription() - Method in class bb.common.PartWhereUsedItemResult

getDescription() - Method in class bb.common.PartWithExcessiveInventoryListResult

getDescription() - Method in class bb.common.PartWithInventoryInfoListResult

getDescription() - Method in class bb.common.PartWithManufacturerInfoResult

getDescription() - Method in class bb.common.PartWithOnhandsVO

getDescription() - Method in class bb.common.PartWithOnLoanQtyListResult

getDescription() - Method in class bb.common.PartWithQAQtyListResult

getDescription() - Method in class bb.common.PartWithQtyListResult

getDescription() - Method in class bb.common.PartWithSipQtyListResult

getDescription() - Method in class bb.common.PartWithSITQtyListResult

getDescription() - Method in class bb.common.PartWithSTOQtyListResult

getDescription() - Method in class bb.common.PartWithWipQtyListResult

getDescription() - Method in class bb.common.PermissionDescriptionVO

getDescription() - Method in class bb.common.PermissionListResult

getDescription() - Method in class bb.common.PfReceiverItemVO

getDescription() - Method in class bb.common.PhysicalInventoryListResult

getDescription() - Method in class bb.common.PhysicalInventoryStatusVO

getDescription() - Method in class bb.common.POReceiverItemListResult

getDescription() - Method in class bb.common.POSurveyReportItemVO

getDescription() - Method in class bb.common.PosZipCodeTaxVO

getDescription() - Method in class bb.common.PreventiveActionRequestItemVO

getDescription() - Method in class bb.common.PreventiveActionRequestVO

getDescription() - Method in class bb.common.ProfitAndLossAccountsResult

getDescription() - Method in class bb.common.ProfitLossStatementItemResult

getDescription() - Method in class bb.common.ProformaInvoiceItemListResult

getDescription() - Method in class bb.common.ProformaInvoiceItemVO

getDescription() - Method in class bb.common.ProjectVO

getDescription() - Method in class bb.common.PrPackingBoxItemVO

getDescription() - Method in class bb.common.PrReceiverWithQualityListResult

getDescription() - Method in class bb.common.PurchaseOrderBoilerplateVO

getDescription() - Method in class bb.common.PurchaseOrderContractResult

getDescription() - Method in class bb.common.PurchaseOrderItemVO

getDescription() - Method in class bb.common.PurchaseOrderOnOrderResult

getDescription() - Method in class bb.common.PurchaseWorkSheetVO

getDescription() - Method in class bb.common.QuoteBoilerplateVO

getDescription() - Method in class bb.common.QuoteItemVO

getDescription() - Method in class bb.common.ReceiverItemAgent

getDescription() - Method in class bb.common.ReceiverItemVO

getDescription() - Method in class bb.common.ReceivingItemResult

getDescription() - Method in class bb.common.RequestForQuoteItemVO

getDescription() - Method in class bb.common.RequestForRMAItemVO

getDescription() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getDescription() - Method in class bb.common.ReturnToVendorByDateListResult

getDescription() - Method in class bb.common.ReturnToVendorItemVO

getDescription() - Method in class bb.common.RMAReceiverItemListResult

getDescription() - Method in class bb.common.RMAReceiverItemVO

getDescription() - Method in class bb.common.RMAReceiverResult

getDescription() - Method in class bb.common.RoleDescriptionVO

getDescription() - Method in class bb.common.RoleListResult

getDescription() - Method in class bb.common.RollUpBomStdCostWorkSheetItemVO

getDescription() - Method in class bb.common.RollUPPartStandardCostResult

getDescription() - Method in class bb.common.RtvShipperItemListResult

getDescription() - Method in class bb.common.RtvShipperItemVO

getDescription() - Method in class bb.common.SalesBomItemResult

getDescription() - Method in class bb.common.SalesBomResult

getDescription() - Method in class bb.common.SalesmanVO

getDescription() - Method in class bb.common.SalesOrder12MonthMarginResult

getDescription() - Method in class bb.common.SalesOrderBoilerplateVO

getDescription() - Method in class bb.common.SalesOrderItemGroupByPartListResult

getDescription() - Method in class bb.common.SalesOrderOnDemandResult

getDescription() - Method in class bb.common.SalesPartListItemResult

getDescription() - Method in class bb.common.SalesPartListResult

getDescription() - Method in class bb.common.SalesTaxListResult

getDescription() - Method in class bb.common.ScrapAssetAgent

getDescription() - Method in class bb.common.ScrapReportVO

getDescription() - Method in class bb.common.SerialNumberItemResult

getDescription() - Method in class bb.common.SerialNumberResult

getDescription() - Method in class bb.common.SGCustomerServiceRequestVO

getDescription() - Method in class bb.common.SGCustRequestForQuoteItemResult

getDescription() - Method in class bb.common.SGCustRequestForQuoteItemVO

getDescription() - Method in class bb.common.SGPartCatalogResult

getDescription() - Method in class bb.common.SGPartListItemResult

getDescription() - Method in class bb.common.SGPartListResult

getDescription() - Method in class bb.common.SGQuoteCartListResult

getDescription() - Method in class bb.common.SGSaleItemVO

getDescription() - Method in class bb.common.ShipListInfoVO

getDescription() - Method in class bb.common.ShipListItemRelatedDocResult

getDescription() - Method in class bb.common.ShipListItemVOResult

getDescription() - Method in class bb.common.ShipListOwnerVO

getDescription() - Method in class bb.common.ShipListVO

getDescription() - Method in class bb.common.ShipperItemListResult

getDescription() - Method in class bb.common.ShipperItemVO

getDescription() - Method in class bb.common.ShippingItemResult

getDescription() - Method in class bb.common.ShoppingCartItem

getDescription() - Method in class bb.common.StockTransactionPartInfoResult

getDescription() - Method in class bb.common.SubcompanyVO

getDescription() - Method in class bb.common.SwapOrderItemListResult

getDescription() - Method in class bb.common.SwapOrderItemVO

getDescription() - Method in class bb.common.SwapReceiverItemListResult

getDescription() - Method in class bb.common.SwapReceiverItemVO

getDescription() - Method in class bb.common.SwapShipperItemListResult

getDescription() - Method in class bb.common.SwapShipperItemVO

getDescription() - Method in class bb.common.SwapShipperOnOrderResult

getDescription() - Method in class bb.common.TakeCycleCountAgent

getDescription() - Method in class bb.common.TaskVO

getDescription() - Method in class bb.common.ToolDescriptionVO

getDescription() - Method in class bb.common.ToolVO

getDescription() - Method in class bb.common.ToolWhereUsedItemResult

getDescription() - Method in class bb.common.ToolWithOnhandsVO

getDescription() - Method in class bb.common.TransferOrderItemListResult

getDescription() - Method in class bb.common.TransferOrderItemVO

getDescription() - Method in class bb.common.TransferReceiverItemListResult

getDescription() - Method in class bb.common.TransferReceiverItemVO

getDescription() - Method in class bb.common.TransferShipperItemListResult

getDescription() - Method in class bb.common.TransferShipperItemVO

getDescription() - Method in class bb.common.UserGroupVO

getDescription() - Method in class bb.common.VendorCategoriesVO

getDescription() - Method in class bb.common.VendorContractPriceItemVO

getDescription() - Method in class bb.common.VendorContractPriceVO

getDescription() - Method in class bb.common.VendorCriticalLevelVO

getDescription() - Method in class bb.common.WareHousePartPrefixKeeperVO

getDescription() - Method in class bb.common.WC2WCAgent

getDescription() - Method in class bb.common.WCLoadByDateResult

getDescription() - Method in class bb.common.WCLoadDetailResult

getDescription() - Method in class bb.common.WOItemPartDetailNotIssue

getDescription() - Method in class bb.common.WoItemPickListItemResult

getDescription() - Method in class bb.common.WoItemPickListResult

getDescription() - Method in class bb.common.WoItemWorkInstructionListResult

getDescription() - Method in class bb.common.WOReceiverDetail

getDescription() - Method in class bb.common.WorkCenterLoadListResult

getDescription() - Method in class bb.common.WorkCenterRunTimeListResult

getDescription() - Method in class bb.common.WorkCenterVO

getDescription() - Method in class bb.common.WorkFlowVO

getDescription() - Method in class bb.common.WorkInstructionSequenceVO

getDescription() - Method in class bb.common.WorkInstructionSummaryResult

getDescription() - Method in class bb.common.WorkInstructionVO

getDescription() - Method in class bb.common.WorkOrderBoilerplateVO

getDescription() - Method in class bb.common.WorkOrderIssueStatisticsResult

getDescription() - Method in class bb.common.WorkOrderItemCanAssyResult

getDescription() - Method in class bb.common.WorkOrderItemInfoResult

getDescription() - Method in class bb.common.WorkOrderItemIssuedTotalResult

getDescription() - Method in class bb.common.WorkOrderItemIssueVO

getDescription() - Method in class bb.common.WorkOrderItemLaborCostListResult

getDescription() - Method in class bb.common.WorkOrderItemPartDetailInWipVO

getDescription() - Method in class bb.common.WorkOrderItemPartDetailItemResult

getDescription() - Method in class bb.common.WorkOrderItemPartDetailResult

getDescription() - Method in class bb.common.WorkOrderItemReviewCostResult

getDescription() - Method in class bb.common.WorkOrderItemTimeDetailResult

getDescription() - Method in class bb.common.WorkOrderItemTimeDetailVO

getDescription() - Method in class bb.common.WorkOrderItemToIssueResult

getDescription() - Method in class bb.common.WorkOrderItemVO

getDescription() - Method in class bb.common.WorkOrderItemWCLoadResult

getDescription() - Method in class bb.common.WorkOrderOnDemandResult

getDescription() - Method in class bb.common.WorkOrderOnOrderResult

getDescription() - Method in class bb.common.WorkOrderQueryInfo

getDescription() - Method in class bb.common.WorkOrderReceiverVO

getDescription() - Method in class bb.common.WorkOrderWorkInstructionListResult

getDescription() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getDescription() - Method in class bb.common.WorkOrderWorkInstructionVO

getDescription() - Method in class bb.common.WorkOrderWorkSheetVO

getDescription() - Method in class bb.common.ZipcodeTotalsResult

getDescription2() - Method in class bb.common.WorkInstructionSequenceVO

getDescription2() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getDescription3() - Method in class bb.common.WorkInstructionSequenceVO

getDescription3() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getDescriptionOfChange() - Method in class bb.common.WorkInstructionRequestForChangeVO

getDescriptions() - Method in class bb.common.NonConformanceCodeVO

getDesignControlNumber() - Method in class bb.common.DesignControlDocumentVO

getDesignControlNumber() - Method in class bb.common.DesignControlInfoVO

getDesignControlNumber() - Method in class bb.common.DesignControlVO

getDesignInputDescription() - Method in class bb.common.DesignControlInfoVO

getDesignInputDescription() - Method in class bb.common.DesignControlVO

getDesignOutputDescription() - Method in class bb.common.DesignControlInfoVO

getDesignOutputDescription() - Method in class bb.common.DesignControlVO

getDesignReviewDescription() - Method in class bb.common.DesignControlInfoVO

getDesignReviewDescription() - Method in class bb.common.DesignControlVO

getDesignValidationDescription() - Method in class bb.common.DesignControlInfoVO

getDesignValidationDescription() - Method in class bb.common.DesignControlVO

getDesignVerificationDescription() - Method in class bb.common.DesignControlInfoVO

getDesignVerificationDescription() - Method in class bb.common.DesignControlVO

getDesired() - Method in class bb.common.DisassembleWorkOrderItemVO

getDesired() - Method in class bb.common.DisassembleWorkOrderVO

getDesired() - Method in class bb.common.OnLoanItemVO

getDesired() - Method in class bb.common.OnLoanVO

getDesired() - Method in class bb.common.QuoteVO

getDesired() - Method in class bb.common.SalesOrderVO

getDesired() - Method in class bb.common.WorkOrderItemVO

getDesired() - Method in class bb.common.WorkOrderVO

getDesiredDate() - Method in class bb.common.NonproductivePickingItemVO

getDesiredDate() - Method in class bb.common.QuoteItemVO

getDesiredDate() - Method in class bb.common.SalesOrderItemInfoVO

getDesiredDate() - Method in class bb.common.SalesOrderItemVO

getDesiredDate() - Method in class bb.common.SwapOrderItemListResult

getDesiredDate() - Method in class bb.common.SwapOrderItemVO

getDesiredDate() - Method in class bb.common.TransferOrderItemListResult

getDesiredDate() - Method in class bb.common.TransferOrderItemVO

getDetailDescription() - Method in class bb.common.CustomerServiceIncidentVO

getDetails() - Method in class bb.common.BB2PartTotalInQADetailResult

getDetails() - Method in class bb.common.BB2PartTotalInSipDetailResult

getDetails() - Method in class bb.common.BB2PartTotalInSitDetailResult

getDetails() - Method in class bb.common.BB2PartTotalInSTODetailResult

getDetails() - Method in class bb.common.BB2PartTotalInWipDetailResult

getDetails() - Method in class bb.common.BB2PartTotalOnhandDetailResult

getDetails() - Method in class bb.common.BB2PartTotalOnloanDetailResult

getDetails() - Method in class bb.common.PartWithOnhandDetailInfoResult

getDetectionStandard() - Method in class bb.common.PartBasicInfo

getDetectionStandard() - Method in class bb.common.PartVO

getDicount() - Method in class bb.common.InvoiceItemListResult

getDiffCost() - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

getDiffCost() - Method in class bb.common.WOItemCostControlAgent

getDiffCost() - Method in class bb.common.WorkOrderItemPartDetailResult

getDiffCost() - Method in class bb.common.WorkOrderItemReviewCostResult

getDiffcount() - Method in class bb.common.CycleCountListResult

getDiffCount() - Method in class bb.common.CycleCountVO

getDiffcount() - Method in class bb.common.PhysicalInventoryListResult

getDiffCount() - Method in class bb.common.PhysicalInventoryVO

getDimension() - Method in class bb.common.PackingBoxVO

getDimension() - Method in class bb.common.PrPackingBoxVO

getDir() - Method in class bb.common.DocumentLogVO

getDirectMaterialPriceVarianceAccount() - Method in class bb.common.AccountingSettingsVO

getDirectMaterialUsageVarianceAccount() - Method in class bb.common.AccountingSettingsVO

getDisassembleIssuingItems() - Method in class bb.common.DisassembleWorkOrderIssuingResult

getDisassembleWorkOrderApprovalByEmployeeId(String) - Method in interface bb.common.box.WorkOrderBox

getDisassembleWorkOrderApprovalByUserNumber(String) - Method in interface bb.common.box.WorkOrderBox

getDisassembleWorkOrderByDwo(String) - Method in interface bb.common.box.WorkOrderBox

getDisassembleWorkOrderComments() - Method in class bb.common.DisassembleWorkOrderListResult

getDisassembleWorkOrderComments() - Method in class bb.common.DisassembleWorkOrderVO

getDisassembleWorkOrderDocumentByID(Long) - Method in interface bb.common.box.WorkOrderBox

getDisassembleWorkOrderItem() - Method in class bb.common.DisassembleWorkOrderVO

getDisassembleWorkOrderItemById(DisassembleWorkOrderItemPK) - Method in interface bb.common.box.WorkOrderBox

getDisassembleWorkOrderItemComments() - Method in class bb.common.DisassembleWorkOrderItemVO

getDisassembleWorkOrderItemIssuingResult(String) - Method in interface bb.common.box.WarehouseBox

getDisassembleWorkOrderItemNumber() - Method in class bb.common.DisassembleWorkOrderIssueVO

getDisassembleWorkOrderItemNumber() - Method in class bb.common.DisassembleWorkOrderItemPK

getDisassembleWorkOrderItemNumber() - Method in class bb.common.DisassembleWorkOrderItemReceiverPK

getDisassembleWorkOrderItemNumber() - Method in class bb.common.DWOIssueDetail

getDisassembleWorkOrderItemNumber() - Method in class bb.common.PartReceivedVO

getDisassembleWorkOrderItemPartDetailItemResult(DisassembleWorkOrderItemReceiverPK) - Method in interface bb.common.box.WorkOrderBox

getDisassembleWorkOrderItemPk() - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

getDisassembleWorkOrderItemPrivateNotes() - Method in class bb.common.DisassembleWorkOrderItemVO

getDisassembleWorkOrderListResultByIdCount(String, String[], String) - Method in interface bb.common.box.WorkOrderBox

getDisassembleWorkOrderListResultsByDateCount(String, Date, Date, String, String, String, String, String, String, String, String, boolean, String, String) - Method in interface bb.common.box.WorkOrderBox

getDisassembleWorkOrderListResultsByPNCount(String, String) - Method in interface bb.common.box.WorkOrderBox

getDisassembleWorkOrderListResultsCountByDwoNumber(String) - Method in interface bb.common.box.WorkOrderBox

getDisassembleWorkOrderNumber() - Method in class bb.common.DisassembleWorkOrderIssueVO

getDisassembleWorkOrderNumber() - Method in class bb.common.DisassembleWorkOrderItemPK

getDisassembleWorkOrderNumber() - Method in class bb.common.DisassembleWorkOrderItemReceiverPK

getDisassembleWorkOrderNumber() - Method in class bb.common.DisassembleWorkOrderVO

getDisassembleWorkOrderNumber() - Method in class bb.common.DWOIssueDetail

getDisassembleWorkOrderNumber() - Method in class bb.common.PartReceivedVO

getDisassembleWorkOrderPrivateNotes() - Method in class bb.common.DisassembleWorkOrderListResult

getDisassembleWorkOrderPrivateNotes() - Method in class bb.common.DisassembleWorkOrderVO

getDisassembleWorkOrderReceivedDetail(DisassembleWorkOrderItemPK, BB2Part, String) - Method in interface bb.common.box.WorkOrderBox

getDisassembleWorkOrderReceivedDetailTotal(DisassembleWorkOrderItemPK, BB2Part, String) - Method in interface bb.common.box.WorkOrderBox

getDisassembleWorkOrderReceivingItems() - Method in class bb.common.DisassembleWorkOrderReceivingResult

getDisassembleWorkOrderReceivingResult(DisassembleWorkOrderItemPK, boolean) - Method in interface bb.common.box.WarehouseBox

getDisassembleWorkOrderWithOrderApplyByDwo(Long) - Method in interface bb.common.box.WorkOrderBox

getDiscount() - Method in class bb.common.AccountsPayableItemVO

getDiscount() - Method in class bb.common.AccountsReceivableItemVO

getDiscount() - Method in class bb.common.APItemListResult

getDiscount() - Method in class bb.common.ContractPriceItemVO

getDiscount() - Method in class bb.common.CRTVItemListResult

getDiscount() - Method in class bb.common.CustomerReturnToVendorItemVO

getDiscount() - Method in class bb.common.DisassembleWorkOrderItemVO

getDiscount() - Method in class bb.common.GeneralLedgerListResult

getDiscount() - Method in class bb.common.GeneralLedgerResult

getDiscount() - Method in class bb.common.GeneralLedgerVO

getDiscount() - Method in class bb.common.OnLoanItemListResult

getDiscount() - Method in class bb.common.OnLoanItemVO

getDiscount() - Method in class bb.common.OnloanReceiverItemVO

getDiscount() - Method in class bb.common.OnloanShipperItemVO

getDiscount() - Method in class bb.common.OrderApprovalItemsVO

getDiscount() - Method in class bb.common.PfReceiverItemVO

getDiscount() - Method in class bb.common.PO2SOExchangeItem

getDiscount() - Method in class bb.common.PoMessageItemVO

getDiscount() - Method in class bb.common.POReceiverItemListResult

getDiscount() - Method in class bb.common.ProformaInvoiceItemVO

getDiscount() - Method in class bb.common.PurchaseOrderItemListResult

getDiscount() - Method in class bb.common.PurchaseOrderItemVO

getDiscount() - Method in class bb.common.QuoteItemListResult

getDiscount() - Method in class bb.common.QuoteItemVO

getDiscount() - Method in class bb.common.ReceiverItemVO

getDiscount() - Method in class bb.common.RequestForQuoteItemListResult

getDiscount() - Method in class bb.common.RequestForQuoteItemVO

getDiscount() - Method in class bb.common.RequestForRMAItemVO

getDiscount() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getDiscount() - Method in class bb.common.ReturnToVendorByDateListResult

getDiscount() - Method in class bb.common.ReturnToVendorItemListResult

getDiscount() - Method in class bb.common.ReturnToVendorItemVO

getDiscount() - Method in class bb.common.RfqMessageItemVO

getDiscount() - Method in class bb.common.RMAItemListResult

getDiscount() - Method in class bb.common.RMAReceiverItemVO

getDiscount() - Method in class bb.common.RRMAItemListResult

getDiscount() - Method in class bb.common.RtvShipperItemVO

getDiscount() - Method in class bb.common.RunningAccountOrderItemVO

getDiscount() - Method in class bb.common.SalesOrderItemInfoVO

getDiscount() - Method in class bb.common.SalesOrderItemListResult

getDiscount() - Method in class bb.common.SalesOrderItemVO

getDiscount() - Method in class bb.common.ShipperItemVO

getDiscount() - Method in class bb.common.TermAgent

getDiscount() - Method in class bb.common.TermVO

getDiscount() - Method in class bb.common.VendorContractPriceItemVO

getDiscount() - Method in class bb.common.VendorPriceAgent

getDiscount() - Method in class bb.common.VendorQtyPriceVO

getDiscount() - Method in class bb.common.WorkOrderItemVO

getDiscountCode() - Method in class bb.common.SalesOrderItemInfoVO

getDiscountCode() - Method in class bb.common.SalesOrderItemVO

getDiscountRate() - Method in class bb.common.PartDiscountVO

getDiscountTotal() - Method in class bb.common.AccountingTotalMoneyResult

getDiscountTotal() - Method in class bb.common.ArCommissionTotalResult

getDiscountTotal() - Method in class bb.common.ArSalesCodeTotalListResult

getDiscountTotal() - Method in class bb.common.DuePATotalByVendorResult

getDiscountTotal() - Method in class bb.common.SalesTaxListResult

getDiscRate() - Method in class bb.common.ShipperItemListResult

getDiscTotal() - Method in class bb.common.RunningAccountOrderVO

getDisplayName() - Method in class bb.common.AppColumnVO

getDisplayName() - Method in class bb.common.SmtpServerVO

getDisplayValue() - Method in class bb.common.ClientListItem

getDisplayValueWithoutIdentifier() - Method in class bb.common.ClientListItem

getDisposalBy() - Method in class bb.common.SGCustomerServiceRequestVO

getDisposalDescription() - Method in class bb.common.SGCustomerServiceRequestVO

getDispositionApprovedEng() - Method in class bb.common.NonConformanceReportVO

getDispositionApprovedMfg() - Method in class bb.common.NonConformanceReportVO

getDispositionApprovedQa() - Method in class bb.common.NonConformanceReportVO

getDispositionDate() - Method in class bb.common.NonConformanceReportVO

getDispositionOfChange() - Method in class bb.common.EngineeringChangeRequestListResult

getDispositionOfChange() - Method in class bb.common.EngineeringChangeRequestVO

getDistrict() - Method in class bb.common.WareHousePartPrefixKeeperVO

getDivision() - Method in class bb.common.SGCompanyPK

getDivision() - Method in class bb.common.SGCustRequestForQuoteVO

getDivision() - Method in class bb.common.SGLogLoginVO

getDivision() - Method in class bb.common.SGQuoteAddressVO

getDivision() - Method in class bb.common.SGQuoteLoginVO

getDMByDateCount(String, String, String, String, String, String, String, String, Date, Date) - Method in interface bb.common.box.AccountingBox

getDMByDateCount(String, String, String, String, String, String, String, String, String, Date, Date) - Method in interface bb.common.box.AccountingBox

getDMCount(String, String, String, String, String, String, Date, Date) - Method in interface bb.common.box.AccountingBox

getDmDigits() - Method in class bb.common.CompanyVO

getDmPrefix() - Method in class bb.common.CompanyVO

getDMTotal(String, String, String, String, String, String, Date, Date) - Method in interface bb.common.box.AccountingBox

getDocDescription() - Method in class bb.common.DisassembleWorkOrderDocumentVO

getDocDescription() - Method in class bb.common.EngineeringChangeDocumentVO

getDocDescription() - Method in class bb.common.EngineeringChangeRequestDocumentVO

getDocDescription() - Method in class bb.common.MiscDocAgent

getDocDescription() - Method in class bb.common.OnloanDocumentVO

getDocDescription() - Method in class bb.common.OrderDocumentVO

getDocDescription() - Method in class bb.common.PurchaseOrderDocumentVO

getDocDescription() - Method in class bb.common.SalesOrderDocumentVO

getDocDescription() - Method in class bb.common.WorkInstructionDocumentVO

getDocDescription() - Method in class bb.common.WorkOrderDocumentVO

getDocFileName() - Method in class bb.common.DisassembleWorkOrderDocumentVO

getDocFileName() - Method in class bb.common.EngineeringChangeDocumentVO

getDocFileName() - Method in class bb.common.EngineeringChangeRequestDocumentVO

getDocFileName() - Method in class bb.common.LogMiscDocumentVO

getDocFileName() - Method in class bb.common.OnloanDocumentVO

getDocFileName() - Method in class bb.common.OrderDocumentVO

getDocFileName() - Method in class bb.common.PurchaseOrderDocumentVO

getDocFileName() - Method in class bb.common.SalesOrderDocumentVO

getDocFileName() - Method in class bb.common.WorkInstructionDocumentVO

getDocFileName() - Method in class bb.common.WorkOrderDocumentVO

getDocFlags() - Method in class bb.common.SGPartListResult

getDocLength() - Method in class bb.common.AccountingInfoDocumentVO

getDocLength() - Method in class bb.common.CustomerServiceIncidentItemVO

getDocLength() - Method in class bb.common.DesignControlDocumentVO

getDocLength() - Method in class bb.common.DisassembleWorkOrderDocumentVO

getDocLength() - Method in class bb.common.EmployeeRecordsVO

getDocLength() - Method in class bb.common.EngineeringChangeDocumentVO

getDocLength() - Method in class bb.common.EngineeringChangeRequestDocumentVO

getDocLength() - Method in class bb.common.LogMiscDocumentVO

getDocLength() - Method in class bb.common.MiscDocAgent

getDocLength() - Method in class bb.common.OnloanDocumentVO

getDocLength() - Method in class bb.common.OrderDocumentVO

getDocLength() - Method in class bb.common.PartCertificateListResult

getDocLength() - Method in class bb.common.PartCertificateVO

getDocLength() - Method in class bb.common.PreventiveActionRequestItemVO

getDocLength() - Method in class bb.common.PurchaseOrderDocumentVO

getDocLength() - Method in class bb.common.QuoteDocumentVO

getDocLength() - Method in class bb.common.ReturnMaterialAuthorizationDocumentVO

getDocLength() - Method in class bb.common.SalesOrderDocumentVO

getDocLength() - Method in class bb.common.WorkInstructionDocumentVO

getDocLength() - Method in class bb.common.WorkOrderDocumentVO

getDocName() - Method in class bb.common.AccountingInfoDocumentVO

getDocName() - Method in class bb.common.AddressQualityDocumentsVO

getDocName() - Method in class bb.common.CustomerServiceIncidentItemVO

getDocName() - Method in class bb.common.DesignControlDocumentVO

getDocName() - Method in class bb.common.EmployeeRecordsVO

getDocName() - Method in class bb.common.MiscDocAgent

getDocName() - Method in class bb.common.PartCertificateListResult

getDocName() - Method in class bb.common.PartCertificateVO

getDocName() - Method in class bb.common.PreventiveActionRequestItemVO

getDocName() - Method in class bb.common.QuoteDocumentVO

getDocName() - Method in class bb.common.ReturnMaterialAuthorizationDocumentVO

getDocType() - Method in class bb.common.AddressQualityDocumentsVO

getDocType() - Method in class bb.common.LogMiscDocumentVO

getDocType() - Method in class bb.common.MiscDocAgent

getDocType() - Method in class bb.common.OrderDocumentVO

getDocument() - Method in class bb.common.AccountingInfoDocumentVO

getDocument() - Method in class bb.common.MiscDocAgent

getDocument() - Method in class bb.common.TermsConditionVO

getDocumentDate() - Method in class bb.common.AccountingInfoDocumentVO

getDocumentDate() - Method in class bb.common.DesignControlDocumentVO

getDocumentDate() - Method in class bb.common.DisassembleWorkOrderDocumentVO

getDocumentDate() - Method in class bb.common.EngineeringChangeDocumentVO

getDocumentDate() - Method in class bb.common.EngineeringChangeRequestDocumentVO

getDocumentDate() - Method in class bb.common.MiscDocAgent

getDocumentDate() - Method in class bb.common.OnloanDocumentVO

getDocumentDate() - Method in class bb.common.OrderDocumentVO

getDocumentDate() - Method in class bb.common.PurchaseOrderDocumentVO

getDocumentDate() - Method in class bb.common.QuoteDocumentVO

getDocumentDate() - Method in class bb.common.ReturnMaterialAuthorizationDocumentVO

getDocumentDate() - Method in class bb.common.SalesOrderDocumentVO

getDocumentDate() - Method in class bb.common.WorkInstructionDocumentVO

getDocumentDate() - Method in class bb.common.WorkOrderDocumentVO

getDocumentDescription() - Method in class bb.common.AddressQualityDocumentsVO

getDocumentDescription() - Method in class bb.common.QuoteDocumentVO

getDocumentDescription() - Method in class bb.common.ReturnMaterialAuthorizationDocumentVO

getDocumentExtension() - Method in class bb.common.AddressQualityDocumentsVO

getDocumentLength() - Method in class bb.common.AddressQualityDocumentsVO

getDocumentLengthByte() - Method in class bb.common.AllPartDocumentsVO

getDocumentLengthByte() - Method in class bb.common.LogPartDocumentVO

getDocumentLengthByte() - Method in class bb.common.PartDocumentVO

getDocumentPk() - Method in class bb.common.DocumentInfoAgent

getDocumentServerSettingsByDocType(String) - Method in interface bb.common.box.CompanyBox

getDocumentType() - Method in class bb.common.AllPartDocumentsPK

getDocumentType() - Method in class bb.common.BB2Document

getDocumentType() - Method in class bb.common.DocumentInfoAgent

getDocumentType() - Method in class bb.common.DocumentServerVO

getDocumentType() - Method in class bb.common.LogPartDocumentVO

getDocumentType() - Method in class bb.common.MiscDocumentSettingVO

getDocumentType() - Method in class bb.common.PartDocumentPK

getDocVersion() - Method in class bb.common.AllPartDocumentsPK

getDocVersion() - Method in class bb.common.LogPartDocumentVO

getDocVersion() - Method in class bb.common.PartDocumentVO

getDoNotIssueToWo() - Method in class bb.common.PartMRPVO

getDoNotKeepInInventory() - Method in class bb.common.PartMRPVO

getDoNotUseInMrp() - Method in class bb.common.PartMRPVO

getDrawing() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getDrawing() - Method in class bb.common.DisassembleWorkOrderReceivingResult

getDrawing() - Method in class bb.common.IssuingResult

getDrawing() - Method in class bb.common.NonConformanceReportVO

getDrawing() - Method in class bb.common.PartBasicInfo

getDrawing() - Method in class bb.common.PartDwfAgent

getDrawing() - Method in class bb.common.PartVO

getDrawing() - Method in class bb.common.PartWhereUsedItemResult

getDrawing() - Method in class bb.common.PartWithManufacturerInfoResult

getDrawing() - Method in class bb.common.PartWithOnhandsVO

getDrawing() - Method in class bb.common.ReceivingItemResult

getDrawing() - Method in class bb.common.SalesBomItemResult

getDrawing() - Method in class bb.common.SalesBomResult

getDrawing() - Method in class bb.common.SGPartCatalogResult

getDrawing() - Method in class bb.common.ShippingItemResult

getDrawing() - Method in class bb.common.ToolVO

getDrawing() - Method in class bb.common.ToolWhereUsedItemResult

getDrawing() - Method in class bb.common.ToolWithOnhandsVO

getDrawingNumber() - Method in class bb.common.InspectionReportInfoVO

getDrawingNumber() - Method in class bb.common.InspectionReportVO

getDrawingNumber() - Method in class bb.common.OperatingInstructionsVO

getDrawingNumber() - Method in class bb.common.PartVO

getDrawingNumber() - Method in class bb.common.PartWithOnhandsVO

getDrawingRev() - Method in class bb.common.PartVO

getDrawingRev() - Method in class bb.common.PartWithOnhandsVO

getDrawingRevisedDate() - Method in class bb.common.EngineeringChangeVO

getDrawingRevision() - Method in class bb.common.PartDwfAgent

getDrawingType() - Method in class bb.common.DwfUploadSettingsVO

getDrawingType() - Method in class bb.common.DwgUploadSettingsVO

getDt() - Method in class bb.common.DesignControlDocumentVO

getDt() - Method in class bb.common.QuoteDocumentVO

getDue() - Method in class bb.common.AccountPayableCheckRunItemVO

getDue() - Method in class bb.common.AccountPayableInfoWithPrepayResult

getDue() - Method in class bb.common.AccountsPayableInfoVO

getDue() - Method in class bb.common.AccountsPayableItemVO

getDue() - Method in class bb.common.AccountsPayableVO

getDue() - Method in class bb.common.AccountsReceivableItemVO

getDue() - Method in class bb.common.APItemListResult

getDue() - Method in class bb.common.ARPaymentRunItemVO

getDue() - Method in class bb.common.InvoiceItemListResult

getDue() - Method in class bb.common.OnloanReceiverItemVO

getDue() - Method in class bb.common.OnloanReceiverVO

getDue() - Method in class bb.common.OnloanShipperItemVO

getDue() - Method in class bb.common.OnloanShipperVO

getDue() - Method in class bb.common.ProformaInvoiceVO

getDue() - Method in class bb.common.ReceiverInfoVO

getDue() - Method in class bb.common.ReceiverItemVO

getDue() - Method in class bb.common.ReceiverVO

getDue() - Method in class bb.common.RMAReceiverItemVO

getDue() - Method in class bb.common.RMAReceiverVO

getDue() - Method in class bb.common.RtvShipperInfoVO

getDue() - Method in class bb.common.RtvShipperItemVO

getDue() - Method in class bb.common.RtvShipperVO

getDue() - Method in class bb.common.ShipperInfoVO

getDue() - Method in class bb.common.ShipperItemVO

getDue() - Method in class bb.common.ShipperVO

getDue() - Method in class bb.common.TempArApAgingVO

getDue1To30Total() - Method in class bb.common.CustomerStatementTotalResult

getDue31To60Total() - Method in class bb.common.CustomerStatementTotalResult

getDue61To90Total() - Method in class bb.common.CustomerStatementTotalResult

getDue91Total() - Method in class bb.common.CustomerStatementTotalResult

getDueDate() - Method in class bb.common.CorrectiveActionRequestVO

getDueDate() - Method in class bb.common.CustomerServiceIncidentItemListResult

getDueDate() - Method in class bb.common.CustomerServiceIncidentListResult

getDueDate() - Method in class bb.common.CustomerServiceIncidentVO

getDueDate() - Method in class bb.common.DesignControlInfoVO

getDueDate() - Method in class bb.common.DesignControlListResult

getDueDate() - Method in class bb.common.DesignControlVO

getDueDate() - Method in class bb.common.DisassembleWorkOrderItemListResult

getDueDate() - Method in class bb.common.EngineeringChangeListResult

getDueDate() - Method in class bb.common.EngineeringChangeRequestListResult

getDueDate() - Method in class bb.common.EngineeringChangeRequestVO

getDueDate() - Method in class bb.common.EngineeringChangeVO

getDueDate() - Method in class bb.common.JobProcessSheetListResult

getDueDate() - Method in class bb.common.JobProcessSheetResult

getDueDate() - Method in class bb.common.NcrNeedToScrapListResult

getDueDate() - Method in class bb.common.NcrReportListResult

getDueDate() - Method in class bb.common.NonConformanceReportVO

getDueDate() - Method in class bb.common.PartTrackingVO

getDueDate() - Method in class bb.common.PreventiveActionRequestVO

getDueDate() - Method in class bb.common.PurchaseOrderOpenDueListResult

getDueDate() - Method in class bb.common.PurchaseWorkSheetVO

getDueDate() - Method in class bb.common.ReceiverItemTrackingLogAgent

getDueDate() - Method in class bb.common.WoItemWorkInstructionListResult

getDueDate() - Method in class bb.common.WorkCenterRunTimeListResult

getDueDate() - Method in class bb.common.WorkInstructionRequestForChangeVO

getDueDate() - Method in class bb.common.WorkOrderCheckListResult

getDueDate() - Method in class bb.common.WorkOrderItemListResult

getDueDate() - Method in class bb.common.WorkOrderQueryInfo

getDueDate() - Method in class bb.common.WorkOrderWorkSheetVO

getDueECRequestsCount() - Method in interface bb.common.box.EngineeringBox

getDueEngineeringChangesCount() - Method in interface bb.common.box.EngineeringBox

getDueIncidentCount() - Method in interface bb.common.box.CustomerServiceBox

getDueManufacturerECRequestsCount() - Method in interface bb.common.box.ManufacturingBox

getDueManufacturerEngineeringChangesCount() - Method in interface bb.common.box.ManufacturingBox

getDueNCRsCount() - Method in interface bb.common.box.QualityBox

getDueOriginalPromisePurchaseAccount() - Method in class bb.common.PurchasingInfoCenterResult

getDueOriginalPromiseSalesAccount() - Method in class bb.common.SalesInfoCenterResult

getDuePARsCount() - Method in interface bb.common.box.QualityBox

getDuePOItemOf12MonthAvg() - Method in class bb.common.PurchaseOrderOnTimeResult

getDuePOItemOfFiscalYear() - Method in class bb.common.PurchaseOrderOnTimeResult

getDuePOItemOfLastMonth() - Method in class bb.common.PurchaseOrderOnTimeResult

getDuePOItemOfThisMonth() - Method in class bb.common.PurchaseOrderOnTimeResult

getDuePOItemOfYtd() - Method in class bb.common.PurchaseOrderOnTimeResult

getDuePOTotalof12MonthAvg() - Method in class bb.common.PurchaseOrderOnTimeResult

getDuePOTotalofFiscalYear() - Method in class bb.common.PurchaseOrderOnTimeResult

getDuePOTotalofLastMonth() - Method in class bb.common.PurchaseOrderOnTimeResult

getDuePOTotalofThisMonth() - Method in class bb.common.PurchaseOrderOnTimeResult

getDuePOTotalofYtd() - Method in class bb.common.PurchaseOrderOnTimeResult

getDuePurchaseAccount() - Method in class bb.common.PurchasingInfoCenterResult

getDuePurchaseCount() - Method in class bb.common.PurchasingInfoCenterResult

getDuePurchaseOrderItemCountByBuyerCode(String) - Method in interface bb.common.box.PurchasingBox

getDueRequestForQuoteItemListResultsCount() - Method in interface bb.common.box.ManufacturingBox

getDueRequestForQuoteItemListResultsCount() - Method in interface bb.common.box.PurchasingBox

getDueReturnToVendorItemListResultsCount() - Method in interface bb.common.box.ManufacturingBox

getDueReturnToVendorItemListResultsCount() - Method in interface bb.common.box.PurchasingBox

getDueSalesOrderItemCustomerTotalResultsByCustomerId(String) - Method in interface bb.common.box.SalesBox

getDueSalesOrdersCountByAddressId(String) - Method in interface bb.common.box.SalesBox

getDueSalesOrdersTotalMoneyValueByDate(String, Date, Date) - Method in interface bb.common.box.SalesBox

getDueShortageSalesOrderItemsCount(String, String, String, String) - Method in interface bb.common.box.SalesBox

getDueSoCount() - Method in class bb.common.SalesInfoCenter

getDueSOCount() - Method in class bb.common.WareHousingInfoCenterResult

getDueSoItemsCountByDateType(String, Date, Date) - Method in interface bb.common.box.SalesBox

getDueSoSum() - Method in class bb.common.SalesInfoCenter

getDueWorkOrderItemListResultsCount() - Method in interface bb.common.box.WorkOrderBox

getDuplicateTempAddressCount() - Method in interface bb.common.box.CompanyBox

getDuplicateTempBOMCount() - Method in interface bb.common.box.CompanyBox

getDuplicateTempEmployeeCount() - Method in interface bb.common.box.CompanyBox

getDuplicateTempInventoryCount() - Method in interface bb.common.box.CompanyBox

getDuplicateTempManufactureCount() - Method in interface bb.common.box.CompanyBox

getDuplicateTempMaterialCount() - Method in interface bb.common.box.CompanyBox

getDuplicateTempNccodeCount() - Method in interface bb.common.box.CompanyBox

getDuplicateTempPartCount() - Method in interface bb.common.box.CompanyBox

getDuplicateTempToolCount() - Method in interface bb.common.box.CompanyBox

getDuplicateTempToolInventoryCount() - Method in interface bb.common.box.CompanyBox

getDutyFreeNumber() - Method in class bb.common.RunningAccountOrderVO

getDwfAddedCurrentMonthCount() - Method in class bb.common.EngineeringInfoCenterResult

getDwfAddedLastMonthCount() - Method in class bb.common.EngineeringInfoCenterResult

getDwfCount() - Method in class bb.common.EngineeringInfoCenterResult

getDwfDrawingCountByPartPk(PartPK, String) - Method in interface bb.common.box.EngineeringBox

getDwfExtension() - Method in class bb.common.LogPartDwfVO

getDwfExtension() - Method in class bb.common.PartDwfWithPartInfoResult

getDwfLength() - Method in class bb.common.LogPartDwfVO

getDwfLength() - Method in class bb.common.PartDwfWithPartInfoResult

getDwfUploadSettingsVO(String) - Method in interface bb.common.box.CompanyBox

getDwg() - Method in class bb.common.BB2PartInfo

getDwg() - Method in class bb.common.BillItemSalesXResult

getDwg() - Method in class bb.common.BillSalesXResult

getDwg() - Method in class bb.common.BomItemWithOEMResult

getDwg() - Method in class bb.common.BomPickListItemResult

getDwg() - Method in class bb.common.BomWithOEMResult

getDwg() - Method in class bb.common.CustomerReturnToVendorItemVO

getDwg() - Method in class bb.common.DisassembleWorkOrderItemVO

getDwg() - Method in class bb.common.InventoryNotUsedInMonthsResult

getDwg() - Method in class bb.common.NonproductivePickingItemVO

getDwg() - Method in class bb.common.OnLoanItemVO

getDwg() - Method in class bb.common.OrderApprovalItemsVO

getDwg() - Method in class bb.common.PartWithInventoryInfoListResult

getDwg() - Method in class bb.common.POSurveyReportItemVO

getDwg() - Method in class bb.common.PurchaseOrderItemVO

getDwg() - Method in class bb.common.QuoteItemVO

getDwg() - Method in class bb.common.RequestForQuoteItemVO

getDwg() - Method in class bb.common.RequestForRMAItemVO

getDwg() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getDwg() - Method in class bb.common.ReturnToVendorItemVO

getDwg() - Method in class bb.common.SalesOrderItemInfoVO

getDwg() - Method in class bb.common.SalesOrderItemVO

getDwg() - Method in class bb.common.SGBOMItemResult

getDwg() - Method in class bb.common.StockTransactionPartInfoResult

getDwg() - Method in class bb.common.SwapOrderItemVO

getDwg() - Method in class bb.common.SwapReceiverItemVO

getDwg() - Method in class bb.common.SwapShipperItemVO

getDwg() - Method in class bb.common.TransferOrderItemVO

getDwg() - Method in class bb.common.TransferReceiverItemListResult

getDwg() - Method in class bb.common.TransferReceiverItemVO

getDwg() - Method in class bb.common.TransferShipperItemListResult

getDwg() - Method in class bb.common.WorkOrderItemVO

getDwgExtension() - Method in class bb.common.LogPartDwgVO

getDwgExtension() - Method in class bb.common.PartDwfVO

getDwgExtension() - Method in class bb.common.PartDwgVO

getDwgExtension() - Method in class bb.common.PartDwgWithPartInfoResult

getDwgLength() - Method in class bb.common.LogPartDwgVO

getDwgLength() - Method in class bb.common.PartDwfVO

getDwgLength() - Method in class bb.common.PartDwgAgent

getDwgLength() - Method in class bb.common.PartDwgVO

getDwgLength() - Method in class bb.common.PartDwgWithPartInfoResult

getDwgUploadSettingsVO(String) - Method in interface bb.common.box.CompanyBox

getDWIPartDetailTotalReceivedCost(DisassembleWorkOrderItemPK) - Method in interface bb.common.box.WorkOrderBox

getDwoDate() - Method in class bb.common.DisassembleWorkOrderListResult

getDwoDetails() - Method in class bb.common.BB2PartTotalInWipDetailResult

getDwoDetails() - Method in class bb.common.BB2PartTotalOndemandDetailResult

getDwoDetails() - Method in class bb.common.BB2PartTotalOnorderDetailResult

getDwoDisc() - Method in class bb.common.DisassembleWorkOrderItemVO

getDwoDisc() - Method in class bb.common.DisassembleWorkOrderVO

getDwoicCost() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

getDwoisCost() - Method in class bb.common.DisassembleWorkOrderIssueVO

getDwoisStdCost() - Method in class bb.common.DisassembleWorkOrderIssueVO

getDWOIssueItemsCount(String, String, String, String, String, Date, Date, String, String, String[], boolean) - Method in interface bb.common.box.WarehouseBox

getDWOIssueListResultsByDwoNumber(String, int, int) - Method in interface bb.common.box.WarehouseBox

getDWOIssueListResultsCountByDwoNumber(String) - Method in interface bb.common.box.WarehouseBox

getDwoItemPk() - Method in class bb.common.DisassembleWorkOrderItemListResult

getDwoMade() - Method in class bb.common.DisassembleWorkOrderItemVO

getDwoMade() - Method in class bb.common.DisassembleWorkOrderVO

getDwoNumber() - Method in class bb.common.DisassembleWorkOrderDocumentVO

getDwoNumber() - Method in class bb.common.DisassembleWorkOrderListResult

getDwoOnDemandList() - Method in class bb.common.MrpItemResult

getDwoOnOrderList() - Method in class bb.common.MrpItemResult

getDwoOpen() - Method in class bb.common.DisassembleWorkOrderItemVO

getDwoOpen() - Method in class bb.common.DisassembleWorkOrderVO

getDwoPartDetailResult(DisassembleWorkOrderItemPK) - Method in interface bb.common.box.WorkOrderBox

getDWOReceiverListResultsByDwoNumber(String, int, int) - Method in interface bb.common.box.WarehouseBox

getDWOReceiverListResultsCountByDwoNumber(String) - Method in interface bb.common.box.WarehouseBox

getdWorkOrderIssueStatisticsResultsCount(Date, Date, String, String, String, String) - Method in interface bb.common.box.WorkOrderBox

getDWOShipperItemListResultsOfDisassembleWorkOrder(String) - Method in interface bb.common.box.WorkOrderBox

getDwoSub() - Method in class bb.common.DisassembleWorkOrderItemVO

getDwoSub() - Method in class bb.common.DisassembleWorkOrderVO

getDwoTax() - Method in class bb.common.DisassembleWorkOrderItemVO

getDwoTotal() - Method in class bb.common.DisassembleWorkOrderItemVO

getDynamicSearchFilter() - Method in class bb.common.ServerAction

getEAccounts() - Method in class bb.common.TwelveMonthCashFlowReportResult

getEachMonthInvoiceAvgAccount() - Method in class bb.common.SalesInfoCenterResult

getEachMonthInvoiceAvgGrossMargin() - Method in class bb.common.SalesInfoCenterResult

getEachMonthSalesItemAvgCount() - Method in class bb.common.SalesInfoCenterResult

getEachMonthSalesOrderAvgAccount() - Method in class bb.common.SalesInfoCenterResult

getEachMonthSalesOrderAvgCount() - Method in class bb.common.SalesInfoCenterResult

getEarNoseTear() - Method in class bb.common.CustomCheckUpEmployeeVO

getEc() - Method in class bb.common.DesignControlInfoVO

getEc() - Method in class bb.common.DesignControlVO

getEcg() - Method in class bb.common.CustomCheckUpEmployeeVO

getEcnCheckOrderResult(BB2Part) - Method in interface bb.common.box.EngineeringBox

getECNControlByBizBoxUserNumber(String) - Method in interface bb.common.box.EngineeringBox

getECNControlByEmployeeId(String) - Method in interface bb.common.box.EngineeringBox

getECNControlByUserName(String) - Method in interface bb.common.box.EngineeringBox

getECNControlCountByUserName(String) - Method in interface bb.common.box.EngineeringBox

getEcnCountByConditions(String, String, String, String, String, String, String, String, String, Date, Date) - Method in interface bb.common.box.EngineeringBox

getEcnDescription() - Method in class bb.common.EngineeringChangeListResult

getEcnList() - Method in class bb.common.BillItemWithPartInfoResult

getEcnList() - Method in class bb.common.BillWithPartInfoResult

getEcnNumber() - Method in class bb.common.EngineeringChangeListResult

getEcnNumber() - Method in class bb.common.EngineeringSharingImportLogVO

getECode() - Method in class bb.common.PartInventoryVO

getECode() - Method in class bb.common.ToolInventoryVO

getECRControlByBizBoxUserNumber(String) - Method in interface bb.common.box.EngineeringBox

getECRControlByEmployeeId(String) - Method in interface bb.common.box.EngineeringBox

getECRControlByUserName(String) - Method in interface bb.common.box.EngineeringBox

getECRControlCountByUserName(String) - Method in interface bb.common.box.EngineeringBox

getEcrDate() - Method in class bb.common.EngineeringChangeRequestVO

getEcrDescription() - Method in class bb.common.EngineeringChangeRequestListResult

getEcrEngineer() - Method in class bb.common.EngineeringChangeRequestListResult

getECRequest(String) - Method in interface bb.common.box.EngineeringBox

getECRequestCountByEcrNumberLike(String) - Method in interface bb.common.box.EngineeringBox

getECRequestsCountByPartLike(String, String, String, String, String, String, String, String) - Method in interface bb.common.box.EngineeringBox
************above are about bill, below are about EngineeringChangeRequest
getEcrNumber() - Method in class bb.common.EngineeringChangeRequestListResult

getEcrPriority() - Method in class bb.common.EngineeringChangeRequestListResult

getEcrPriority() - Method in class bb.common.EngineeringChangeRequestVO

getEdcDigits() - Method in class bb.common.CompanyVO

getEdcDocuments() - Method in class bb.common.DesignControlVO

getEdcPrefix() - Method in class bb.common.CompanyVO

getEditDate() - Method in class bb.common.EngineeringSharingItemVO

getEducation() - Method in class bb.common.CustomEmployeeVO

getEducation() - Method in class bb.common.EmployeeCardVO

getEEByEmployeeId(String) - Method in interface bb.common.box.HumanResourceBox

getEffectiveDate() - Method in class bb.common.EngineeringChangeVO

getEffectiveDate() - Method in class bb.common.PartVendorVO

getEffectiveDate() - Method in class bb.common.ToolVendorVO

getEffectiveDate() - Method in class bb.common.WorkInstructionListResult

getEffectiveDate() - Method in class bb.common.WorkInstructionRequestForChangeVO

getEffectiveDate() - Method in class bb.common.WorkInstructionVO

getEffectiveDate() - Method in class bb.common.WorkOrderWorkInstructionVO

getEjbMethod() - Method in class bb.common.PermissionMethodVO

getEjbMethodsByPermissionIdCount(String) - Method in interface bb.common.box.SecurityBox

getEjbName() - Method in class bb.common.EjbMethodVO

getEjbName() - Method in class bb.common.LogMethodPK

getElapsedTimeByHour() - Method in class bb.common.OperatingInstructionsUserStatisticalResult

getElapsedTimeByHour() - Method in class bb.common.OperatingInstructionsVO

getElecSignature() - Method in class bb.common.RunningAccountOrderVO

getEmail() - Method in class bb.common.AllStatementsListResult

getEmail() - Method in class bb.common.ARAllStatementsListResult

getEmail() - Method in class bb.common.ARPrepayAllStatementsListResult

getEmail() - Method in class bb.common.BizBoxUserEmployeeResult

getEmail() - Method in class bb.common.CSRAgent

getEmail() - Method in class bb.common.CustomerFeedbackVO

getEmail() - Method in class bb.common.CustomerVendorAddressInfoVO

getEmail() - Method in class bb.common.CustomerVendorAddressVO

getEmail() - Method in class bb.common.CustomerVendorContactVO

getEmail() - Method in class bb.common.EmployeeCardVO

getEmail() - Method in class bb.common.ManufacturerAddressInfoVO

getEmail() - Method in class bb.common.ManufacturerAddressVO

getEmail() - Method in class bb.common.ManufacturerContactVO

getEmail() - Method in class bb.common.NoticeUserEmployeeListResult

getEmail() - Method in class bb.common.QualityGroupVO

getEmail() - Method in class bb.common.SalesmanVO

getEmail() - Method in class bb.common.SGCustomerServiceRequestVO

getEmailForUserSelf() - Method in interface bb.common.box.CompanyBox

getEmailFrom() - Method in class bb.common.CustomerServiceIncidentItemVO

getEmails() - Method in class bb.common.AllStatementsListResult

getEmailSent() - Method in class bb.common.CustomerServiceIncidentItemVO

getEmailTo() - Method in class bb.common.CustomerServiceIncidentItemVO

getEmailto() - Method in class bb.common.TaskVO

getEmergencyContact() - Method in class bb.common.EmployeeHomeVO

getEmergencyContact() - Method in class bb.common.SalesmanVO

getEmpId() - Method in class bb.common.CustomCheckUpEmployeeVO

getEmpId() - Method in class bb.common.EngGroupUserPK

getEmployee() - Method in class bb.common.AccountsPayableInfoVO

getEmployee() - Method in class bb.common.AccountsPayableVO

getEmployee() - Method in class bb.common.LogInventoryListResult

getEmployee() - Method in class bb.common.WorkOrderItemTimeDetailVO

getEmployeeAge() - Method in class bb.common.CustomEmployeeVO

getEmployeeAgeLevel() - Method in class bb.common.CustomEmployeeVO

getEmployeeBasicInfoAndPic(String) - Method in interface bb.common.box.HumanResourceBox

getEmployeeCardById(String) - Method in interface bb.common.box.HumanResourceBox

getEmployeeCardById(String, boolean) - Method in interface bb.common.box.HumanResourceBox

getEmployeeCardsByDepartmentCount(String, boolean) - Method in interface bb.common.box.HumanResourceBox

getEmployeeCardsByLastNameCount(String, boolean) - Method in interface bb.common.box.HumanResourceBox

getEmployeeCardsByNameCount(String, boolean) - Method in interface bb.common.box.HumanResourceBox

getEmployeeCardsCountByEmployeeId(String, boolean) - Method in interface bb.common.box.HumanResourceBox

getEmployeeCount(String, String, String, String[], boolean, boolean) - Method in interface bb.common.box.HumanResourceBox

getEmployeeDoNotPutGoodsCountByDate(String, String, Date, Date) - Method in interface bb.common.box.HumanResourceBox

getEmployeeEducationByPK(EmployeeEducationPK) - Method in interface bb.common.box.HumanResourceBox

getEmployeeEducationCount(boolean, String) - Method in interface bb.common.box.HumanResourceBox

getEmployeeEducationsAllDegreeCount(boolean) - Method in interface bb.common.box.HumanResourceBox

getEmployeeEmail() - Method in class bb.common.PurchaseWorkSheetVO

getEmployeeEmail() - Method in class bb.common.WorkOrderWorkSheetVO

getEmployeeHomeByPk(String) - Method in interface bb.common.box.HumanResourceBox

getEmployeeId() - Method in class bb.common.ArCommissionListResult

getEmployeeId() - Method in class bb.common.BomApprovalVO

getEmployeeId() - Method in class bb.common.CustomGoodsRecordVO

getEmployeeId() - Method in class bb.common.DisassembleWorkOrderApprovalVO

getEmployeeId() - Method in class bb.common.ECNReviewVO

getEmployeeId() - Method in class bb.common.ECRReviewVO

getEmployeeId() - Method in class bb.common.EmployeeEducationPK

getEmployeeId() - Method in class bb.common.EmployeeLaborAgent

getEmployeeId() - Method in class bb.common.EmployeePutGoodListResult

getEmployeeId() - Method in class bb.common.EmployeeRecordsVO

getEmployeeId() - Method in class bb.common.EmployeeTimeCardResult

getEmployeeId() - Method in class bb.common.EmployeeWorkExperiencePK

getEmployeeId() - Method in class bb.common.ExpenseVO

getEmployeeId() - Method in class bb.common.GeneralLedgerApprovalVO

getEmployeeId() - Method in class bb.common.GroupUserVO

getEmployeeId() - Method in class bb.common.NcrApprovalPK

getEmployeeId() - Method in class bb.common.NonproductivePickingApprovalVO

getEmployeeId() - Method in class bb.common.NonproductivePickingApproveVO

getEmployeeId() - Method in class bb.common.NoticeUserEmployeeListResult

getEmployeeId() - Method in class bb.common.OnloanReviewVO

getEmployeeID() - Method in class bb.common.OperationLogVO

getEmployeeId() - Method in class bb.common.PurchaseOrderApprovalVO

getEmployeeId() - Method in class bb.common.PurchaseWorkSheetItemPK

getEmployeeId() - Method in class bb.common.PurchaseWorkSheetPK

getEmployeeID() - Method in class bb.common.RMAReviewVO

getEmployeeID() - Method in class bb.common.RTVApprovalVO

getEmployeeId() - Method in class bb.common.SalesCodeVO

getEmployeeId() - Method in class bb.common.SalesOrderReviewVO

getEmployeeId() - Method in class bb.common.SwapOrderApprovalVO

getEmployeeId() - Method in class bb.common.TransferOrderApprovalVO

getEmployeeId() - Method in class bb.common.WorkInstructionApprovalVO

getEmployeeId() - Method in class bb.common.WorkOrderApprovalVO

getEmployeeId() - Method in class bb.common.WorkOrderItemTimeDetailVO

getEmployeeId() - Method in class bb.common.WorkOrderTimeCardVO

getEmployeeId() - Method in class bb.common.WorkOrderWorkSheetItemPK

getEmployeeId() - Method in class bb.common.WorkOrderWorkSheetPK

getEmployeeIdDigits() - Method in class bb.common.CompanyVO

getEmployeeIdPrefix() - Method in class bb.common.CompanyVO

getEmployeeLaborCost() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

getEmployeeLaborCost() - Method in class bb.common.WorkOrderReceiverVO

getEmployeeName() - Method in class bb.common.EmployeePutGoodListResult

getEmployeeName() - Method in class bb.common.EmployeeTimeCardResult

getEmployeeName() - Method in class bb.common.WorkOrderTimeCardVO

getEmployeeRecordsCount(String, String, boolean) - Method in interface bb.common.box.HumanResourceBox

getEmployeeRecordsOfEmployee(String) - Method in interface bb.common.box.HumanResourceBox

getEmployeeRecordsTypeCount(boolean) - Method in interface bb.common.box.HumanResourceBox

getEmployeeSelf() - Method in interface bb.common.box.HumanResourceBox

getEmployeeTrain() - Method in class bb.common.CustomEmployeeVO

getEmployeeTrainingById(String) - Method in interface bb.common.box.HumanResourceBox

getEmployeeTrainingbyPk(EmployeeWorkExperiencePK) - Method in interface bb.common.box.HumanResourceBox

getEmployeeWorkAge() - Method in class bb.common.CustomEmployeeVO

getEmployeeWorkAgeLevel() - Method in class bb.common.CustomEmployeeVO

getEmployeeWorkExperience(EmployeeWorkExperiencePK) - Method in interface bb.common.box.HumanResourceBox

getEmployeeWorkExperience() - Method in class bb.common.CustomEmployeeVO

getEndAmount() - Method in class bb.common.InventoryMonthReport

getEndCost() - Method in class bb.common.InventoryMonthReport

getEndCost(int) - Method in class bb.common.InventoryReportListResult

getEndDate() - Method in class bb.common.BB2FiscalYearDate

getEndDate() - Method in class bb.common.FiscalYearSettingsVO

getEndDate() - Method in class bb.common.LogTaskVO

getEndDate() - Method in class bb.common.OperatingInstructionsUserStatisticalResult

getEndDate() - Method in class bb.common.OperatingInstructionsVO

getEndDate() - Method in class bb.common.OrderApprovalItemsVO

getEndDate() - Method in class bb.common.RollUpBomStdCostWorkSheetVO

getEndDate() - Method in class bb.common.ShipListAgent

getEndDate() - Method in class bb.common.TaskVO

getEndDate() - Method in class bb.common.WCLoadByDateResult

getEndDate() - Method in class bb.common.WorkCenterOnDateAgent

getEndDate() - Method in class bb.common.WorkOrderItemSeqWCLoadResult

getEndDate() - Method in class bb.common.WorkOrderWorkInstructionSequenceDateAgent

getEndDate() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getEndingBalanceCredit() - Method in class bb.common.GLByDateTotalResult

getEndingBalanceDebit() - Method in class bb.common.GLByDateTotalResult

getEndMonth() - Method in class bb.common.CurrencyExchangeVO

getEndMonth() - Method in class bb.common.GlMonthBudgetVO

getEndMonth() - Method in class bb.common.GlMonthVO

getEndMonthBudget() - Method in class bb.common.CashFlowMonthTotalResult

getEndQaAmount() - Method in class bb.common.InventoryMonthReport

getEndQaQty() - Method in class bb.common.InventoryMonthReport

getEndQty() - Method in class bb.common.InventoryMonthReport

getEndWipAmount() - Method in class bb.common.InventoryMonthReport

getEndWipQty() - Method in class bb.common.InventoryMonthReport

getEngAcceptEmployee() - Method in class bb.common.POSurveyReportVO

getEngGroup() - Method in class bb.common.PartBasicInfo

getEngGroup() - Method in class bb.common.PartVO

getEngGroup() - Method in class bb.common.PartWithOnhandsVO

getEngGroupByPK(String) - Method in interface bb.common.box.EngineeringBox

getEngGroupId() - Method in class bb.common.EngGroupUserPK

getEngGroupListCount(String) - Method in interface bb.common.box.EngineeringBox

getEngGroupUserByPk(EngGroupUserPK) - Method in interface bb.common.box.EngineeringBox

getEngGroupUserCountByEmpoyeeId(String, String) - Method in interface bb.common.box.EngineeringBox

getEngineeringChangeById(String) - Method in interface bb.common.box.EngineeringBox

getEngineeringChangeDate() - Method in class bb.common.EngineeringChangeListResult

getEngineeringChangeDate() - Method in class bb.common.EngineeringChangeVO

getEngineeringChangeDigits() - Method in class bb.common.CompanyVO

getEngineeringChangeDocumentByID(Long) - Method in interface bb.common.box.EngineeringBox

getEngineeringChangeDocuments() - Method in class bb.common.EngineeringChangeVO

getEngineeringChangeNoticeNumber() - Method in class bb.common.EngineeringChangeRequestVO

getEngineeringChangeNumber() - Method in class bb.common.EngineeringChangeDocumentVO

getEngineeringChangeNumber() - Method in class bb.common.EngineeringChangeVO

getEngineeringChangePrefix() - Method in class bb.common.CompanyVO

getEngineeringChangeRequestDigits() - Method in class bb.common.CompanyVO

getEngineeringChangeRequestDocumentByID(Long) - Method in interface bb.common.box.EngineeringBox

getEngineeringChangeRequestDocuments() - Method in class bb.common.EngineeringChangeRequestVO

getEngineeringChangeRequestNumber() - Method in class bb.common.EngineeringChangeRequestDocumentVO

getEngineeringChangeRequestNumber() - Method in class bb.common.EngineeringChangeRequestVO

getEngineeringChangeRequestPrefix() - Method in class bb.common.CompanyVO

getEngineeringChangesCountByEcnNumberLike(String) - Method in interface bb.common.box.EngineeringBox
*****************above are about Part, below are about EngineeringChange
getEngineeringChangesCountByPartLike(String, String) - Method in interface bb.common.box.EngineeringBox

getEngineeringChangesCountByPartPk(PartPK) - Method in interface bb.common.box.EngineeringBox

getEngineeringChangesCountByStatus(String) - Method in interface bb.common.box.EngineeringBox

getEngineeringDescription() - Method in class bb.common.WorkInstructionListResult

getEngineeringInfoCenterResult() - Method in interface bb.common.box.ManagementBox

getEngineeringSharingByCompanyIdCount(String) - Method in interface bb.common.box.EngineeringBox

getEngineeringSharingByCompanyNameCount(String) - Method in interface bb.common.box.EngineeringBox

getEngineeringSharingImportLogsCount(String, String, Date, Date, String, String, String, String) - Method in interface bb.common.box.EngineeringBox

getEngineeringSharingItemByCompanyIdCount(String, String, String) - Method in interface bb.common.box.EngineeringBox

getEngineeringSharingItemByPk(EngineeringSharingItemPK) - Method in interface bb.common.box.EngineeringBox

getEngineeringSharingRule() - Method in class bb.common.EngineeringSharingVO

getEngineeringSharingsById(String) - Method in interface bb.common.box.EngineeringBox

getEnglishAbility() - Method in class bb.common.CustomEmployeeVO

getEngSharingPartsCountByPnAndengGroup(String, String, String, String) - Method in interface bb.common.box.EngineeringBox

getEnterBy() - Method in class bb.common.NcrReportListResult

getEnterBy() - Method in class bb.common.ReturnToVendorByDateListResult

getEnterBy() - Method in class bb.common.ReturnToVendorVO

getEnterBy() - Method in class bb.common.ScrapReportVO

getEntered() - Method in class bb.common.DisassembleWorkOrderVO

getEntered() - Method in class bb.common.WorkOrderItemLaborCostListResult

getEntered() - Method in class bb.common.WorkOrderVO

getEnteredBy() - Method in class bb.common.CorrectiveActionRequestVO

getEnteredBy() - Method in class bb.common.NonConformanceReportVO

getEnteredBy() - Method in class bb.common.PreventiveActionRequestVO

getEnterSchool() - Method in class bb.common.CustomEmployeeVO

getEntryList() - Method in class bb.common.GeneralLedgerPrintResult

getEPByDateCount(String, String, String, String, String, String, String, String, Date, Date, String, String) - Method in interface bb.common.box.AccountingBox

getEPCount(String, String, String, String, String, String, Date, Date) - Method in interface bb.common.box.AccountingBox

getEPTotal(String, String, String, String, String, String, Date, Date) - Method in interface bb.common.box.AccountingBox

getEquimentId() - Method in class bb.common.MaintenanceItemPK

getEquipCondition() - Method in class bb.common.CSRAgent

getEquipCondition() - Method in class bb.common.SGCustomerServiceRequestVO

getEquipment() - Method in class bb.common.WorkCenterVO

getEquipmentByEquipmentIdCount(String, String, String, String) - Method in interface bb.common.box.ManufacturingBox

getEquipmentByHours(int) - Method in interface bb.common.box.ManufacturingBox

getEquipmentById(String) - Method in interface bb.common.box.ManufacturingBox

getEquipmentByWorkCenterIdCount(String) - Method in interface bb.common.box.ManufacturingBox

getEquipmentId() - Method in class bb.common.EquipmentListResult

getEquipmentId() - Method in class bb.common.EquipmentVO

getEquipmentID() - Method in class bb.common.WorkCenterVO

getEquipmentNotes() - Method in class bb.common.EquipmentListResult

getEquipmentNotes() - Method in class bb.common.EquipmentVO

getEquity() - Method in class bb.common.ClosingStatementResult

getErrorGL() - Method in class bb.common.ApprovedGLResult

getErrorGLList() - Method in class bb.common.ApprovedGLResult

getErrorMsg() - Method in class bb.common.ImportDataVO

getEstHours() - Method in class bb.common.WorkInstructionSequenceVO

getEstHours() - Method in class bb.common.WorkOrderItemTimeDetailVO

getEstHoursH() - Method in class bb.common.WorkInstructionSequenceVO

getEstHoursM() - Method in class bb.common.WorkInstructionSequenceVO

getEstHoursS() - Method in class bb.common.WorkInstructionSequenceVO

getEstHrs() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getEstHrsH() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getEstHrsM() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getEstHrsS() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getEstimatedArrival() - Method in class bb.common.ProformaInvoiceVO

getEstimateDepreciate() - Method in class bb.common.AssetDepreciateDetailReport

getEstimateNetSalRate() - Method in class bb.common.AssetDepreciateVO

getEstimateNetSalRate() - Method in class bb.common.AssetVO

getEstRunHrs() - Method in class bb.common.WorkInstructionSummaryItemResult

getEstSetup() - Method in class bb.common.WCLoadByDateResult

getEstSetup() - Method in class bb.common.WorkInstructionSequenceVO

getEstSetup() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getEstSetupH() - Method in class bb.common.WorkInstructionSequenceVO

getEstSetupH() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getEstSetupHrs() - Method in class bb.common.WorkInstructionSummaryItemResult

getEstSetupM() - Method in class bb.common.WorkInstructionSequenceVO

getEstSetupM() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getEstSetupS() - Method in class bb.common.WorkInstructionSequenceVO

getEstSetupS() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getETotalBudget() - Method in class bb.common.CashFlowMonthTotalResult

getEtran() - Method in class bb.common.AccountsPayableInfoVO

getEtran() - Method in class bb.common.AccountsPayableVO

getEtran() - Method in class bb.common.OnloanReceiverVO

getEtran() - Method in class bb.common.ReceiverInfoVO

getEtran() - Method in class bb.common.ReceiverVO

getEtran() - Method in class bb.common.RMAReceiverVO

getEWEByEmployeeId(String) - Method in interface bb.common.box.HumanResourceBox

getExcessiveQty() - Method in class bb.common.PartWithExcessiveInventoryListResult

getExcessiveTotalAvgCost() - Method in class bb.common.PartWithExcessiveInventoryListResult

getExcessiveTotalStdCost() - Method in class bb.common.PartWithExcessiveInventoryListResult

getExchange() - Method in class bb.common.AccountCreditVO

getExchange() - Method in class bb.common.AccountDebitVO

getExchange() - Method in class bb.common.AccountPayableCheckRunItemVO

getExchange() - Method in class bb.common.AccountPayableCheckVO

getExchange() - Method in class bb.common.AccountReceivablePaymentVO

getExchange() - Method in class bb.common.AccountsPayableInfoVO

getExchange() - Method in class bb.common.AccountsPayableVO

getExchange() - Method in class bb.common.AccountsReceivableInfoVO

getExchange() - Method in class bb.common.AccountsReceivableVO

getExchange() - Method in class bb.common.AddressAccountInfo

getExchange() - Method in class bb.common.APAuditListResult

getExchange() - Method in class bb.common.ApPrepayVO

getExchange() - Method in class bb.common.ARAuditListResult

getExchange() - Method in class bb.common.ARPaymentRunItemVO

getExchange() - Method in class bb.common.ArPrepayVO

getExchange() - Method in class bb.common.CPItemFromQuoteResult

getExchange() - Method in class bb.common.CurrencyExchangeVO

getExchange() - Method in class bb.common.CurrencyVO

getExchange() - Method in class bb.common.CustomerReturnToVendorVO

getExchange() - Method in class bb.common.ExchangeAuditItemResult

getExchange() - Method in class bb.common.GeneralLedgerEntry

getExchange() - Method in class bb.common.GeneralLedgerListResult

getExchange() - Method in class bb.common.GeneralLedgerVO

getExchange() - Method in class bb.common.GLItemVO

getExchange() - Method in class bb.common.JounalEntryListResult

getExchange() - Method in class bb.common.MakePrepaymentCheckAgent

getExchange() - Method in class bb.common.OnloanReceiverVO

getExchange() - Method in class bb.common.PrepayPaymentAgent

getExchange() - Method in class bb.common.PurchaseOrderVO

getExchange() - Method in class bb.common.QuoteVO

getExchange() - Method in class bb.common.ReceiverVO

getExchange() - Method in class bb.common.RequestForRMAVO

getExchange() - Method in class bb.common.ReturnMaterialAuthorizationVO

getExchange() - Method in class bb.common.RMAReceiverVO

getExchange() - Method in class bb.common.RunningAccountOrderVO

getExchange() - Method in class bb.common.SalesMarginListResult

getExchange() - Method in class bb.common.SalesOrderVO

getExchange() - Method in class bb.common.TempArApAgingVO

getExchangeRate() - Method in class bb.common.CompanyVO

getExchangeRate() - Method in class bb.common.CurrencyVO

getExchangeRate() - Method in class bb.common.PartOnhandCostVO

getExchangeRate() - Method in class bb.common.PaymentAgent

getExchangeRate() - Method in class bb.common.POReceiverItemListResult

getExchangeRatePreview(String, Map) - Method in interface bb.common.box.AccountingBox

getExclude() - Method in class bb.common.AccountPayableCheckRunVO

getExclude() - Method in class bb.common.ARPaymentRunVO

getExcludeVendorId() - Method in class bb.common.ApCheckRunItemAgent

getExcludeVendorId() - Method in class bb.common.ApPrepaymentCheckRunItemAgent

getExcludeVendorId() - Method in class bb.common.ArPaymentRunItemAgent

getExcludeVendorId() - Method in class bb.common.ArPrepaymentRunItemAgent

getExcludeVendorId() - Method in class bb.common.ARPrepaymentWireTransferAgent

getExcludeVendorId() - Method in class bb.common.PrepaymentWireTransferAgent

getExcludeVendorId() - Method in class bb.common.WireTransferAgent

getExpectDeliveryDate() - Method in class bb.common.PurchaseOrderContractResult

getExpenseAccountByPk(String) - Method in interface bb.common.box.AccountingBox

getExpenseByPk(String) - Method in interface bb.common.box.AccountingBox

getExpensesCountByExpenseNumber(String) - Method in interface bb.common.box.AccountingBox

getExpensesItems() - Method in class bb.common.ExpenseVO

getExpenseStatement() - Method in class bb.common.ExpenseItemPK

getExpenseStatement() - Method in class bb.common.ExpenseListResult

getExpenseStatement() - Method in class bb.common.ExpenseVO

getExpireDate() - Method in class bb.common.AddressQualityDocumentsVO

getExpireDate() - Method in class bb.common.BizboxUserListResult

getExpireDate() - Method in class bb.common.BizboxUserVO

getExpireDate() - Method in class bb.common.ContractPriceVO

getExpireDate() - Method in class bb.common.CustomEmployeeTrainVO

getExpireDate() - Method in class bb.common.EmployeeTrainingVO

getExpireDate() - Method in class bb.common.MiscDocAgent

getExpireDate() - Method in class bb.common.VendorContractPriceVO

getExt() - Method in class bb.common.BB2File

getExtAvgCost() - Method in class bb.common.InventoryNotUsedInMonthsResult

getExtendedCost() - Method in class bb.common.POReceiverItemListResult

getExtendPrice() - Method in class bb.common.CustomerReturnToVendorItemVO

getExtendPrice() - Method in class bb.common.DisassembleWorkOrderItemListResult

getExtendPrice() - Method in class bb.common.DisassembleWorkOrderItemVO

getExtendPrice() - Method in class bb.common.OnloanReceiverItemVO

getExtendPrice() - Method in class bb.common.OrderApprovalItemsVO

getExtendPrice() - Method in class bb.common.PurchaseOrderItemListResult

getExtendPrice() - Method in class bb.common.QuoteItemVO

getExtendPrice() - Method in class bb.common.ReceiverItemVO

getExtendPrice() - Method in class bb.common.RequestForRMAItemVO

getExtendPrice() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getExtendPrice() - Method in class bb.common.SalesOrderItemInfoVO

getExtendPrice() - Method in class bb.common.SalesOrderItemListResult

getExtendPrice() - Method in class bb.common.SalesOrderItemVO

getExtendPrice() - Method in class bb.common.WorkOrderItemListResult

getExtendPrice() - Method in class bb.common.WorkOrderItemVO

getExtendsPrice() - Method in class bb.common.QuoteItemListResult

getExtension() - Method in class bb.common.AccountingInfoDocumentVO

getExtension() - Method in class bb.common.AllPartDocumentsVO

getExtension() - Method in class bb.common.BizboxBugChangesInfoVO

getExtension() - Method in class bb.common.BizboxBugChangesVO

getExtension() - Method in class bb.common.BizboxBugInfoVO

getExtension() - Method in class bb.common.BizboxBugVO

getExtension() - Method in class bb.common.CustomerServiceIncidentItemVO

getExtension() - Method in class bb.common.DesignControlDocumentVO

getExtension() - Method in class bb.common.DisassembleWorkOrderDocumentVO

getExtension() - Method in class bb.common.EmployeeCardVO

getExtension() - Method in class bb.common.EmployeeRecordsVO

getExtension() - Method in class bb.common.EngineeringChangeDocumentVO

getExtension() - Method in class bb.common.EngineeringChangeRequestDocumentVO

getExtension() - Method in class bb.common.LogMiscDocumentVO

getExtension() - Method in class bb.common.LogPartDocumentVO

getExtension() - Method in class bb.common.MiscDocAgent

getExtension() - Method in class bb.common.NCRPictureListResult

getExtension() - Method in class bb.common.NCRPictureVO

getExtension() - Method in class bb.common.OnloanDocumentVO

getExtension() - Method in class bb.common.OrderDocumentVO

getExtension() - Method in class bb.common.PartCertificateListResult

getExtension() - Method in class bb.common.PartCertificateVO

getExtension() - Method in class bb.common.PartDocumentVO

getExtension() - Method in class bb.common.PartDwfAgent

getExtension() - Method in class bb.common.PartDwgAgent

getExtension() - Method in class bb.common.PartDwgPK

getExtension() - Method in class bb.common.PartPictureVO

getExtension() - Method in class bb.common.PreventiveActionRequestItemVO

getExtension() - Method in class bb.common.PrintLogoVO

getExtension() - Method in class bb.common.PurchaseOrderDocumentVO

getExtension() - Method in class bb.common.QuoteDocumentVO

getExtension() - Method in class bb.common.ReturnMaterialAuthorizationDocumentVO

getExtension() - Method in class bb.common.SalesmanVO

getExtension() - Method in class bb.common.SalesOrderDocumentVO

getExtension() - Method in class bb.common.SGDwgPictureVO

getExtension() - Method in class bb.common.SGPictureVO

getExtension() - Method in class bb.common.TaskFileResult

getExtension() - Method in class bb.common.TermsConditionVO

getExtension() - Method in class bb.common.WorkInstructionDocumentVO

getExtension() - Method in class bb.common.WorkInstructionPictureVO

getExtension() - Method in class bb.common.WorkOrderDocumentVO

getExtent() - Method in class bb.common.EmployeeCardVO

getExtention() - Method in class bb.common.DocumentInfoAgent

getExtentPrice() - Method in class bb.common.RequestForQuoteItemVO

getExtPrice() - Method in class bb.common.APItemListResult

getExtPrice() - Method in class bb.common.InvoiceItemListResult

getExtPrice() - Method in class bb.common.ReturnToVendorItemListResult

getExtPrice() - Method in class bb.common.ShipperItemListResult

getExtStdCost() - Method in class bb.common.InventoryNotUsedInMonthsResult

getFailEmailto() - Method in class bb.common.TaskVO

getFailNoticeReceivers() - Method in class bb.common.TaskVO

getFailRepeat() - Method in class bb.common.TaskVO

getFax() - Method in class bb.common.CustomerVendorAddressInfoVO

getFax() - Method in class bb.common.CustomerVendorAddressVO

getFax() - Method in class bb.common.CustomerVendorContactVO

getFax() - Method in class bb.common.EmployeeCardVO

getFax() - Method in class bb.common.ManufacturerAddressInfoVO

getFax() - Method in class bb.common.ManufacturerAddressVO

getFax() - Method in class bb.common.ManufacturerContactVO

getFax() - Method in class bb.common.SGCartCheckOutResult

getFax() - Method in class bb.common.SgClientProgramUserVO

getFax() - Method in class bb.common.SGCustRequestForQuoteListResult

getFax() - Method in class bb.common.SGCustRequestForQuoteResult

getFax() - Method in class bb.common.SGCustRequestForQuoteVO

getFax() - Method in class bb.common.SGQuoteAddressResult

getFax() - Method in class bb.common.SGQuoteAddressVO

getFax() - Method in class bb.common.VendorGroupUserVO

getFDate() - Method in class bb.common.WCLoadAgent

getFeedbackItems() - Method in class bb.common.CustomerFeedbackVO

getFeedbackNumber() - Method in class bb.common.CustomerFeedbackVO

getFeedBackNumber() - Method in class bb.common.FeedBackItemPK

getFeedbackQuestion() - Method in class bb.common.FeedbackAnswerVO

getFifoDate() - Method in class bb.common.PartOnhandCostVO

getFifoOnhand() - Method in class bb.common.PartOnhandCostVO

getFile() - Method in class bb.common.BB2AttachFile

getFile() - Method in class bb.common.PrintTemplateVO

getFileDate() - Method in class bb.common.TaskFileResult

getFilename() - Method in class bb.common.BB2AttachFile

getFileName() - Method in class bb.common.BB2Document

getFilename() - Method in class bb.common.BB2File

getFileName() - Method in class bb.common.DocumentInfoAgent

getFileName() - Method in class bb.common.DocumentLogVO

getFileName() - Method in class bb.common.PartDwfAgent

getFileName() - Method in class bb.common.PartDwgAgent

getFileName() - Method in class bb.common.PrintTemplateVO

getFileName() - Method in class bb.common.TaskFileResult

getFileNames() - Method in class bb.common.PartDwfAgent

getFilter() - Method in class bb.common.DynamicSearchFilter

getFilterCondition() - Method in class bb.common.DataFilterVO

getFilterPO() - Method in class bb.common.DataFilterVO

getFilterSQL() - Method in class bb.common.DataFilterVO

getFilterType() - Method in class bb.common.DataFilterVO

getFinancingExpensesAccount() - Method in class bb.common.AccountingSettingsVO

getFindInactiveToolCount(String) - Method in interface bb.common.box.ManufacturingBox

getfindPartDocumentLogCount(String, String, String, String, String, String, String, String, String, String, Date, Date) - Method in interface bb.common.box.DocumentBox

getFinishDateOfSeqWithPOBefore() - Method in class bb.common.WCLoadDetailResult

getFinishedDate() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getFinishPercent() - Method in class bb.common.WCLoadDetailResult

getFinishPercent() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getFirstInCost() - Method in class bb.common.PartInventoryVO

getFirstInCost() - Method in class bb.common.ToolInventoryVO

getFirstLevelAccountNumber() - Method in class bb.common.GeneralLedgerEntry

getFirstLevelAccountNumberDescription() - Method in class bb.common.GeneralLedgerEntry

getFirstMonthYearByDate(Date, Date) - Method in interface bb.common.box.AccountingBox

getFirstName() - Method in class bb.common.BizBoxUserEmployeeResult

getFirstName() - Method in class bb.common.CashierVO

getFirstName() - Method in class bb.common.EmployeeCardVO

getFirstName() - Method in class bb.common.EmployeeEducationResult

getFirstName() - Method in class bb.common.GroupUserVO

getFirstName() - Method in class bb.common.NoticeUserEmployeeListResult

getFirstName() - Method in class bb.common.SalesmanVO

getFirstOpenMonth() - Method in interface bb.common.box.AccountingBox

getFiscalYear() - Method in class bb.common.SalesInfoCenter.DueSoCount

getFiscalYear() - Method in class bb.common.SalesInfoCenter.DueSoSum

getFiscalYear() - Method in class bb.common.SalesInfoCenter.GrossMargin

getFiscalYear() - Method in class bb.common.SalesInfoCenter.InvoicedSum

getFiscalYear() - Method in class bb.common.SalesInfoCenter.OpenSoSum

getFiscalYear() - Method in class bb.common.SalesInfoCenter.SoCount

getFiscalYear() - Method in class bb.common.SalesInfoCenter.SoCountWithPartsOnhold

getFiscalYear() - Method in class bb.common.SalesInfoCenter.SoItemCount

getFiscalYear() - Method in class bb.common.SalesInfoCenter.SoTotalSum

getFiscalYearInvoiceAccount() - Method in class bb.common.SalesInfoCenterResult

getFiscalYearInvoiceGrossMargin() - Method in class bb.common.SalesInfoCenterResult

getFiscalYearOutputValue() - Method in interface bb.common.box.ManagementBox

getFiscalYearSalesItemCount() - Method in class bb.common.SalesInfoCenterResult

getFiscalYearSalesOrderAccount() - Method in class bb.common.SalesInfoCenterResult

getFiscalYearSalesOrderCount() - Method in class bb.common.SalesInfoCenterResult

getFiscalYearSettingsVO() - Method in class bb.common.CurrencyAgent

getFitemNumber() - Method in class bb.common.BB2RefdocPK

getFitemNumber() - Method in class bb.common.PosRefdocVO

getFitemNumber() - Method in class bb.common.RefdocVO

getFItemPK(RefdocVO, Class<?>) - Static method in class bb.common.BB2Util

getFixedAssets() - Method in class bb.common.BalanceSheetSideBySideResult

getFixedAssets() - Method in class bb.common.ClosingStatementResult

getFixedBy() - Method in class bb.common.BizboxBugChangesInfoVO

getFixedBy() - Method in class bb.common.BizboxBugChangesVO

getFixedDate() - Method in class bb.common.BizboxBugChangesInfoVO

getFixedDate() - Method in class bb.common.BizboxBugChangesVO

getFixedQty() - Method in class bb.common.BillItemUsageResult

getFlagString() - Method in class bb.common.PartToAuditFlagResult

getFloorStock() - Method in class bb.common.PartMRPVO

getFm0() - Method in class bb.common.GeneralLedgerSettingsVO

getFm1() - Method in class bb.common.GeneralLedgerSettingsVO

getFm2() - Method in class bb.common.GeneralLedgerSettingsVO

getFMonthYear() - Method in class bb.common.GLCheckRegisterResult

getFob() - Method in class bb.common.AccountsReceivableInfoVO

getFob() - Method in class bb.common.AccountsReceivableVO

getFob() - Method in class bb.common.OnLoanItemVO

getFob() - Method in class bb.common.OnLoanVO

getFont() - Method in class bb.common.LabelTemplateItemVO

getFontSize() - Method in class bb.common.LabelTemplateItemVO

getForderNumber() - Method in class bb.common.BB2RefdocPK

getForderNumber() - Method in class bb.common.PosRefdocVO

getForderNumber() - Method in class bb.common.RefdocVO

getForeignCost() - Method in class bb.common.PartOnhandCostVO

getForeignCurrency() - Method in class bb.common.AssetVO

getForeignCurrency() - Method in class bb.common.PartOnhandCostVO

getForeignCurrencyCost() - Method in class bb.common.AssetVO

getFormula() - Method in class bb.common.AccountsChartCategoryVO

getFormula() - Method in class bb.common.AppColumnVO

getFRefDocString(RefdocVO) - Static method in class bb.common.BB2Util

getFreight() - Method in class bb.common.DisassembleWorkOrderIssuingResult

getFreight() - Method in class bb.common.DisassembleWorkOrderItemVO

getFreight() - Method in class bb.common.GeneralLedgerListResult

getFreight() - Method in class bb.common.GeneralLedgerVO

getFreight() - Method in class bb.common.MakeAccountPayableAgent

getFreight() - Method in class bb.common.MakeBillAndHoldInvoiceAgent

getFreight() - Method in class bb.common.MakeInvoiceAgent

getFreight() - Method in class bb.common.ReceiverAgent

getFreight() - Method in class bb.common.ReceiverItemAgent

getFreight() - Method in class bb.common.ReceiverShipAgent

getFreight() - Method in class bb.common.ReceivingResult

getFreight() - Method in class bb.common.RequestForQuoteItemVO

getFreight() - Method in class bb.common.RfqMessageItemVO

getFreight() - Method in class bb.common.RunningAccountOrderItemResult

getFreight() - Method in class bb.common.RunningAccountOrderItemVO

getFreight() - Method in class bb.common.RunningAccountOrderVO

getFreight() - Method in class bb.common.ShippingResult

getFreight() - Method in class bb.common.SwapOrderListResult

getFreight() - Method in class bb.common.SwapOrderVO

getFreight() - Method in class bb.common.SwapReceiverListResult

getFreight() - Method in class bb.common.SwapReceiverVO

getFreight() - Method in class bb.common.SwapShipperListResult

getFreight() - Method in class bb.common.SwapShipperVO

getFreight() - Method in class bb.common.TransferOrderListResult

getFreight() - Method in class bb.common.TransferOrderVO

getFreight() - Method in class bb.common.WorkOrderItemVO

getFreightBill() - Method in class bb.common.AccountsPayableInfoVO

getFreightBill() - Method in class bb.common.AccountsPayableVO

getFreightBill() - Method in class bb.common.AccountsReceivableInfoVO

getFreightBill() - Method in class bb.common.AccountsReceivableVO

getFreightBill() - Method in class bb.common.OnloanReceiverVO

getFreightBill() - Method in class bb.common.OnloanShipperVO

getFreightBill() - Method in class bb.common.ProformaInvoiceVO

getFreightBill() - Method in class bb.common.ReceiverInfoVO

getFreightBill() - Method in class bb.common.ReceiverVO

getFreightBill() - Method in class bb.common.RMAReceiverVO

getFreightBill() - Method in class bb.common.RtvShipperInfoVO

getFreightBill() - Method in class bb.common.RtvShipperVO

getFreightBill() - Method in class bb.common.ShipperInfoVO

getFreightBill() - Method in class bb.common.ShipperVO

getFreightRateCode() - Method in class bb.common.MakeInvoiceAgent

getFreightRateCode() - Method in class bb.common.OnloanShipperVO

getFreightRateCode() - Method in class bb.common.RtvShipperInfoVO

getFreightRateCode() - Method in class bb.common.RtvShipperVO

getFreightRateCode() - Method in class bb.common.ShipperAgent

getFreightRateCode() - Method in class bb.common.ShipperInfoVO

getFreightRateCode() - Method in class bb.common.ShipperVO

getFreightRateCode() - Method in class bb.common.SwapShipperListResult

getFreightRateCode() - Method in class bb.common.SwapShipperVO

getFreightRateCode() - Method in class bb.common.TransferShipperListResult

getFreightRateCode() - Method in class bb.common.TransferShipperVO

getFreightTotal() - Method in class bb.common.AccountingTotalMoneyResult

getFreightTotal() - Method in class bb.common.AccountsReceivableInfoVO

getFreightTotal() - Method in class bb.common.AccountsReceivableVO

getFreightTotal() - Method in class bb.common.ArCommissionListResult

getFreightTotal() - Method in class bb.common.ArCommissionTotalResult

getFreightTotal() - Method in class bb.common.ArSalesCodeTotalListResult

getFreightTotal() - Method in class bb.common.DuePATotalByVendorResult

getFreightWho() - Method in class bb.common.AccountsPayableInfoVO

getFreightWho() - Method in class bb.common.AccountsPayableVO

getFreightWho() - Method in class bb.common.AccountsReceivableInfoVO

getFreightWho() - Method in class bb.common.AccountsReceivableVO

getFreightWho() - Method in class bb.common.OnLoanItemVO

getFreightWho() - Method in class bb.common.OnLoanVO

getFrequency() - Method in class bb.common.CustomJobCategoryGoodsVO

getFrom() - Method in class bb.common.BB2Document

getFromAddressId() - Method in class bb.common.TransferOrderListResult

getFromAddressId() - Method in class bb.common.TransferOrderVO

getFromAddressId() - Method in class bb.common.TransferReceiverItemListResult

getFromAddressId() - Method in class bb.common.TransferReceiverListResult

getFromAddressId() - Method in class bb.common.TransferReceiverVO

getFromAddressId() - Method in class bb.common.TransferShipperListResult

getFromAddressId() - Method in class bb.common.TransferShipperVO

getFromAddressInfo() - Method in class bb.common.TransferOrderVO

getFromAddressInfo() - Method in class bb.common.TransferReceiverVO

getFromAddressInfo() - Method in class bb.common.TransferShipperVO

getFromAddressName() - Method in class bb.common.TransferShipperListResult

getFromDate() - Method in class bb.common.ApCheckRunItemAgent

getFromDate() - Method in class bb.common.ApPrepaymentCheckRunItemAgent

getFromDate() - Method in class bb.common.ArPaymentRunItemAgent

getFromDate() - Method in class bb.common.ArPrepaymentRunItemAgent

getFromDate() - Method in class bb.common.ARPrepaymentWireTransferAgent

getFromDate() - Method in class bb.common.CustomEmployeeWorkExperienceVO

getFromDate() - Method in class bb.common.EmployeeEducationVO

getFromDate() - Method in class bb.common.EmployeeWorkExperienceVO

getFromDate() - Method in class bb.common.POAndWOStatusResult

getFromDate() - Method in class bb.common.PrepaymentWireTransferAgent

getFromDate() - Method in class bb.common.WireTransferAgent

getFromDate() - Method in class bb.common.WorkCenterLoadAgent

getFromDate() - Method in class bb.common.WorkCenterRunTimeAgent

getFromDate() - Method in class bb.common.WorkCenterRunTimeTotalResult

getFromLocation() - Method in class bb.common.TransferOrderItemListResult

getFromLocation() - Method in class bb.common.TransferOrderItemVO

getFromQty() - Method in class bb.common.VendorQtyPriceVO

getFtpPath() - Method in class bb.common.DocumentServerVO

getFtpPath() - Method in class bb.common.DwfUploadSettingsVO

getFtpPath() - Method in class bb.common.DwgUploadSettingsVO

getFtpPath() - Method in class bb.common.MiscDocumentSettingVO

getFullBOMTreeRollUPMap(BillPK) - Method in interface bb.common.box.EngineeringBox

getFullName() - Method in class bb.common.BizBoxUserEmployeeResult

getFullName() - Method in class bb.common.NoticeUserEmployeeListResult

getFullName() - Method in class bb.common.SgClientProgramUserVO

getFullName() - Method in class bb.common.VendorGroupUserVO

getFullYear(String) - Static method in class bb.common.YearMonthManager

getFy() - Method in class bb.common.FiscalYearSettingsVO

getFy() - Method in class bb.common.GeneralLedgerSettingsVO

getFy() - Method in class bb.common.GlMonthVO

getFy1() - Method in class bb.common.GeneralLedgerSettingsVO

getFy2() - Method in class bb.common.GeneralLedgerSettingsVO

getFyPoAddedCount() - Method in class bb.common.PurchasingInfoCenterResult

getFyPoiAddedCount() - Method in class bb.common.PurchasingInfoCenterResult

getFyPurchaserAccount() - Method in class bb.common.PurchasingInfoCenterResult

getFyReceiverAccount() - Method in class bb.common.PurchasingInfoCenterResult

getFyReceiverCount() - Method in class bb.common.PurchasingInfoCenterResult

getFyReceiverCount() - Method in class bb.common.WareHousingInfoCenterResult

getFyReceiverItemCount() - Method in class bb.common.PurchasingInfoCenterResult

getFyShippperCount() - Method in class bb.common.WareHousingInfoCenterResult

getGa() - Method in class bb.common.ExpenseItemVO

getGa() - Method in class bb.common.PartInventoryVO

getGa() - Method in class bb.common.ToolInventoryVO

getGaAp() - Method in class bb.common.AccountingSettingsVO

getGaAp() - Method in class bb.common.AccountPayableCheckRunVO

getGaAr() - Method in class bb.common.AccountingSettingsVO

getGaAr() - Method in class bb.common.ARPaymentRunVO

getGaBusinessIncome() - Method in class bb.common.AccountingSettingsVO

getGaChecking() - Method in class bb.common.AccountingSettingsVO

getGaChecking() - Method in class bb.common.AccountPayableCheckRunVO

getGaChecking() - Method in class bb.common.AccountReceivablePaymentVO

getGaChecking() - Method in class bb.common.ARPaymentRunVO

getGaCheckNo() - Method in class bb.common.AccountingSettingsVO

getGaCogs() - Method in class bb.common.AccountingSettingsVO

getGaCogsContra() - Method in class bb.common.AccountingSettingsVO

getGaDep() - Method in class bb.common.AccountingSettingsVO

getGaEmployeeLabor() - Method in class bb.common.AccountingSettingsVO

getGaExchangeGainsAndLoss() - Method in class bb.common.AccountingSettingsVO

getGageSet() - Method in class bb.common.ToolCalibrationVO

getGaInboundFreight() - Method in class bb.common.AccountingSettingsVO

getGaOutboundFreight() - Method in class bb.common.AccountingSettingsVO

getGaProfitForCurrentYear() - Method in class bb.common.AccountingSettingsVO

getGaPurchaseDiscount() - Method in class bb.common.AccountingSettingsVO

getGaScrap() - Method in class bb.common.AccountingSettingsVO

getGaWip() - Method in class bb.common.AccountingSettingsVO

getGaWoic() - Method in class bb.common.AccountingSettingsVO

getGaZero() - Method in class bb.common.AccountingSettingsVO

getGender() - Method in class bb.common.CustomEmployeeVO

getGeneralAdmin() - Method in class bb.common.ProfitLossStatementResult

getGeneralDocument() - Method in class bb.common.SGDocPartVO

getGeneralDocumentRev() - Method in class bb.common.SGDocPartVO

getGeneralLedgerApprovalByIdCount(String) - Method in interface bb.common.box.AccountingBox

getGeneralLedgerApprovalByNameCount(String) - Method in interface bb.common.box.AccountingBox

getGeneralLedgerApprovalByPk(String) - Method in interface bb.common.box.AccountingBox

getGeneralLedgerBalance() - Method in class bb.common.ClosingStatementResult

getGeneralLedgerByPk(String) - Method in interface bb.common.box.AccountingBox

getGeneralLedgerCountByDate(String, String, Date, Date, String, String[], String[], String) - Method in interface bb.common.box.AccountingBox

getGeneralLedgerCountByDate(String, String, Date, Date, String, String) - Method in interface bb.common.box.AccountingBox

getGeneralLedgerResult(String) - Method in interface bb.common.box.AccountingBox

getGeneralLedgerTotalByDate(String, String, Date, Date, String, String[], String[], String) - Method in interface bb.common.box.AccountingBox

getGeneralLedgerTotalByDate(String, String, Date, Date, String, String) - Method in interface bb.common.box.AccountingBox

getGlAccountNumber() - Method in class bb.common.AssetVO

getGLAutoApproveByGlType(String) - Method in interface bb.common.box.AccountingBox

getGLAutoApproveById(Long) - Method in interface bb.common.box.AccountingBox

getGlCat() - Method in class bb.common.GLAutoApproveVO

getGlCategory() - Method in class bb.common.AssetDepreciateVO

getGlCategory() - Method in class bb.common.GeneralLedgerByDateListResult

getGlCategory() - Method in class bb.common.GeneralLedgerListResult

getGlCategory() - Method in class bb.common.GeneralLedgerPrintResult

getGlCategory() - Method in class bb.common.GeneralLedgerVO

getGlCategory() - Method in class bb.common.GLApprovalListResult

getGlCategory() - Method in class bb.common.GLCatAndSequence

getGLCategoryById(String) - Method in interface bb.common.box.AccountingBox

getGLCountByConditions(String, String, String, String, String, String, String, Date, Date, BigDecimal) - Method in interface bb.common.box.AccountingBox

getGLCountById(String) - Method in interface bb.common.box.AccountingBox

getGLCreditDebitByConditionsTotal(String, String, String, String, String, String, String, Date, Date) - Method in interface bb.common.box.AccountingBox

getGLCreditDebitCountByConditions(String, String, String, String, String, String, String, Date, Date) - Method in interface bb.common.box.AccountingBox

getGlDigits() - Method in class bb.common.CompanyVO

getGlMonthByFyNumberCount(String) - Method in interface bb.common.box.AccountingBox

getGlNdaysOk() - Method in class bb.common.AccountingSettingsVO

getGlNumber() - Method in class bb.common.DepositSummaryResult

getGlNumber() - Method in class bb.common.GeneralLedgerByDateListResult

getGlNumber() - Method in class bb.common.GLApprovalListResult

getGlNumber() - Method in class bb.common.GLCatAndSequence

getGlNumber() - Method in class bb.common.ShipperItemVO

getGlNumber() - Method in class bb.common.TransferShipperVO

getGlPrefix() - Method in class bb.common.CompanyVO

getGLPrintByGlCategory(String, int) - Method in interface bb.common.box.AccountingBox

getGlStyle() - Method in class bb.common.AccountingConfigurationVO

getGlSummary() - Method in class bb.common.AccountBalanceAgent

getGlSummary() - Method in class bb.common.AddPayableWithoutReceiverAgent

getGlSummary() - Method in class bb.common.ExchangeAuditResult

getGlSummary() - Method in class bb.common.MakeAccountPayableAgent

getGlSummary() - Method in class bb.common.MakeBillAndHoldInvoiceAgent

getGlSummary() - Method in class bb.common.MakeCheckAgent

getGlSummary() - Method in class bb.common.MakeCreditMemoAgent

getGlSummary() - Method in class bb.common.MakeDebitMemoAgent

getGlSummary() - Method in class bb.common.MakeInvoiceAgent

getGlSummary() - Method in class bb.common.MakePrepaymentCheckAgent

getGlSummary() - Method in class bb.common.NcrScrapAgent

getGlSummary() - Method in class bb.common.PaymentAgent

getGlSummary() - Method in class bb.common.PostCheckAgent

getGlSummary() - Method in class bb.common.PrepayPaymentAgent

getGlSummary() - Method in class bb.common.ReceiverAgent

getGlType() - Method in class bb.common.GeneralLedgerCategoryVO

getGlType() - Method in class bb.common.GLAutoApproveVO

getGoodQty() - Method in class bb.common.InspectionReportInfoVO

getGoodQty() - Method in class bb.common.InspectionReportVO

getGoodQty() - Method in class bb.common.JobProcessSheetItemResult

getGoodsId() - Method in class bb.common.CustomGoodsRecordVO

getGoodsId() - Method in class bb.common.CustomJobCategoryGoodsPK

getGoodsId() - Method in class bb.common.EmployeePutGoodListResult

getGoodsName() - Method in class bb.common.EmployeePutGoodListResult

getGotoCatalog() - Method in class bb.common.SGCompanyVO

getGotoManual() - Method in class bb.common.SGCompanyVO

getGotoOverview() - Method in class bb.common.SGCompanyVO

getGotoPic() - Method in class bb.common.SGCompanyVO

getGotoTechSheet() - Method in class bb.common.SGCompanyVO

getGotoTroubleshooting() - Method in class bb.common.SGCompanyVO

getGraduateDate() - Method in class bb.common.CustomEmployeeVO

getGraduateSchool() - Method in class bb.common.CustomEmployeeVO

getGrandTotal() - Method in class bb.common.AccountingTotalMoneyResult

getGrandTotal() - Method in class bb.common.AccountReceivableInfoWithPrepayResult

getGrandTotal() - Method in class bb.common.AccountsReceivableInfoVO

getGrandTotal() - Method in class bb.common.AccountsReceivableItemResult

getGrandTotal() - Method in class bb.common.AccountsReceivableVO

getGrandTotal() - Method in class bb.common.ArCommissionListResult

getGrandTotal() - Method in class bb.common.ArCommissionTotalResult

getGrandTotal() - Method in class bb.common.ArSalesCodeTotalListResult

getGrandTotal() - Method in class bb.common.DuePATotalByVendorResult

getGrandTotal() - Method in class bb.common.SalesTaxListResult

getGrandTotal() - Method in class bb.common.TotalByDateResult

getGrandTotal() - Method in class bb.common.VendorTotalAmountInPO

getGrandTotal() - Method in class bb.common.ZipcodeTotalsResult

getGrantTotal() - Method in class bb.common.CustomerReturnToVendorVO

getGrantTotal() - Method in class bb.common.DisassembleWorkOrderListResult

getGrantTotal() - Method in class bb.common.DisassembleWorkOrderVO

getGrantTotal() - Method in class bb.common.OnloanReceiverVO

getGrantTotal() - Method in class bb.common.PoMessageVO

getGrantTotal() - Method in class bb.common.POStatisticsResult

getGrantTotal() - Method in class bb.common.ProformaInvoiceListResult

getGrantTotal() - Method in class bb.common.PurchaseOrderVO

getGrantTotal() - Method in class bb.common.QuoteVO

getGrantTotal() - Method in class bb.common.ReceiverInfoVO

getGrantTotal() - Method in class bb.common.ReceiverVO

getGrantTotal() - Method in class bb.common.RequestForQuoteVO

getGrantTotal() - Method in class bb.common.RequestForRMAVO

getGrantTotal() - Method in class bb.common.ReturnMaterialAuthorizationVO

getGrantTotal() - Method in class bb.common.ReturnToVendorVO

getGrantTotal() - Method in class bb.common.SalesOrderListResult

getGrantTotal() - Method in class bb.common.SalesOrderVO

getGrantTotal() - Method in class bb.common.TempReceiverWithoutAPInfo

getGrantTotal() - Method in class bb.common.WorkOrderVO

getGrossMargin() - Method in class bb.common.ProfitLossStatementResult

getGrossMargin() - Method in class bb.common.SalesInfoCenter

getGrossMargin() - Method in class bb.common.SalesOrder12MonthMarginResult

getGrossMarginCountByID(Date, Date) - Method in interface bb.common.box.AccountingBox

getGrossMarginPct12MonthAvg() - Method in class bb.common.SalesOrderOnTimeResult

getGrossMarginPctFysical() - Method in class bb.common.SalesOrderOnTimeResult

getGrossMarginPctLastMonth() - Method in class bb.common.SalesOrderOnTimeResult

getGrossMarginPctThisMonth() - Method in class bb.common.SalesOrderOnTimeResult

getGrossMarginPctYtd() - Method in class bb.common.SalesOrderOnTimeResult

getGrossMarginShippedOnTime12MonthAvg() - Method in class bb.common.SalesOrderOnTimeResult

getGrossMarginShippedOnTimeFysical() - Method in class bb.common.SalesOrderOnTimeResult

getGrossMarginShippedOnTimeLastMonth() - Method in class bb.common.SalesOrderOnTimeResult

getGrossMarginShippedOnTimeThisMonth() - Method in class bb.common.SalesOrderOnTimeResult

getGrossMarginShippedOnTimeYtd() - Method in class bb.common.SalesOrderOnTimeResult

getGrossNetProfit() - Method in class bb.common.ClosingStatementResult

getGrossProfit() - Method in class bb.common.ProfitLossStatementResult

getGrossRevenue() - Method in class bb.common.ClosingStatementResult

getGrossWeight() - Method in class bb.common.OnloanShipperVO

getGrossWeight() - Method in class bb.common.PackingBoxVO

getGrossWeight() - Method in class bb.common.PrPackingBoxVO

getGrossWeight() - Method in class bb.common.RtvShipperInfoVO

getGrossWeight() - Method in class bb.common.RtvShipperVO

getGrossWeight() - Method in class bb.common.ShipperAgent

getGrossWeight() - Method in class bb.common.ShipperInfoVO

getGrossWeight() - Method in class bb.common.ShipperVO

getGrossWeight() - Method in class bb.common.SwapShipperListResult

getGrossWeight() - Method in class bb.common.SwapShipperVO

getGrossWeight() - Method in class bb.common.TransferShipperListResult

getGrossWeight() - Method in class bb.common.TransferShipperVO

getGroup() - Method in class bb.common.SubcompanyVO

getGroupCountBySelf() - Method in interface bb.common.box.CompanyBox

getGroupCountByUserName(String) - Method in interface bb.common.box.CompanyBox

getGroupUserCount(String, String) - Method in interface bb.common.box.CompanyBox

getGS() - Method in interface bb.common.box.AccountingBox

getHasPicture() - Method in class bb.common.SGBOMItemResult

getHaveDrawingRevised() - Method in class bb.common.EngineeringChangeVO

getHavePicture() - Method in class bb.common.PartBasicInfo

getHavePicture() - Method in class bb.common.PartVO

getHavePicture() - Method in class bb.common.PartWithOnhandsVO

getHavePicture() - Method in class bb.common.SGPartCatalogResult

getHeight() - Method in class bb.common.BB2Picture

getHeight() - Method in class bb.common.LabelTemplateItemVO

getHeight() - Method in class bb.common.LabelTemplateVO

getHeight() - Method in class bb.common.MiscDocAgent

getHeight() - Method in class bb.common.PartPictureVO

getHeight() - Method in class bb.common.SGPicturePK

getHeight() - Method in class bb.common.WorkInstructionPictureVO

getHelpServerByPk(Long) - Method in interface bb.common.box.CompanyBox

getHelpServerIP() - Method in class bb.common.HelpServerVO

getHelpServerPort() - Method in class bb.common.HelpServerVO

getHighestCost() - Method in class bb.common.SalesOrderItemCostResult

getHighUsagePartResultsCount() - Method in interface bb.common.box.WarehouseBox

getHistoricalInventoryDatesCount() - Method in interface bb.common.box.WarehouseBox

getHistoricalInventorysCount(String, String, Date, boolean) - Method in interface bb.common.box.WarehouseBox

getHistoricalInventoryTotalResults(String, String, Date, Date) - Method in interface bb.common.box.WarehouseBox

getHold() - Method in class bb.common.BB2PartInfo

getHold() - Method in class bb.common.BillItemSalesCostResult

getHold() - Method in class bb.common.BillItemSalesXResult

getHold() - Method in class bb.common.BillSalesCostResult

getHold() - Method in class bb.common.BillSalesXResult

getHold() - Method in class bb.common.DisassembleWorkOrderItemVO

getHold() - Method in class bb.common.PartBasicInfo

getHold() - Method in class bb.common.PartVO

getHold() - Method in class bb.common.PartWhereUsedItemResult

getHold() - Method in class bb.common.PartWithInventoryInfoListResult

getHold() - Method in class bb.common.PartWithManufacturerInfoResult

getHold() - Method in class bb.common.PartWithOnhandsVO

getHold() - Method in class bb.common.SalesBomItemResult

getHold() - Method in class bb.common.SalesBomResult

getHold() - Method in class bb.common.StockTransactionPartInfoResult

getHold() - Method in class bb.common.ToolVO

getHold() - Method in class bb.common.ToolWhereUsedItemResult

getHold() - Method in class bb.common.ToolWithOnhandsVO

getHold() - Method in class bb.common.WorkOrderItemVO

getHome() - Method in class bb.common.CompanyVO

getHome() - Method in class bb.common.SGCompanyVO

getHomeAddress() - Method in class bb.common.EmployeeHomeVO

getHomeAddress() - Method in class bb.common.SalesmanVO

getHomePhone() - Method in class bb.common.BizBoxUserEmployeeResult

getHomePhone() - Method in class bb.common.EmployeeCardVO

getHomePhone() - Method in class bb.common.EmployeeHomeVO

getHomePhone() - Method in class bb.common.NoticeUserEmployeeListResult

getHomePhone() - Method in class bb.common.SalesmanVO

getHost() - Method in class bb.common.SGCompanyVO

getHost() - Method in class bb.common.SmtpServerVO

getHostName() - Method in class bb.common.BB2Notice

getHours() - Method in class bb.common.EmployeeLaborAgent

getHours() - Method in class bb.common.WCLoadDetailResult

getHours() - Method in class bb.common.WorkOrderItemSeqWCLoadResult

getHours() - Method in class bb.common.WorkOrderItemTimeDetailVO

getHours() - Method in class bb.common.WorkOrderWorkInstructionSequenceDateAgent

getHqa() - Method in class bb.common.DisassembleWorkOrderItemVO

getHqa() - Method in class bb.common.OnLoanItemVO

getHqa() - Method in class bb.common.PurchaseOrderItemVO

getHqa() - Method in class bb.common.QuoteItemVO

getHqa() - Method in class bb.common.RequestForQuoteItemVO

getHqa() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getHqa() - Method in class bb.common.ReturnToVendorItemVO

getHqa() - Method in class bb.common.RMAReceiverItemVO

getHqa() - Method in class bb.common.SalesOrderItemInfoVO

getHqa() - Method in class bb.common.SalesOrderItemVO

getHqa() - Method in class bb.common.TransferReceiverItemListResult

getHqa() - Method in class bb.common.TransferReceiverItemVO

getHqa() - Method in class bb.common.WorkOrderItemVO

getHrs() - Method in class bb.common.EquipmentVO

getIcrDate() - Method in class bb.common.IcrItemListResult

getIcrDate() - Method in class bb.common.IcrListResult

getIcrDate() - Method in class bb.common.InspectionConformanceReportVO

getIcrDocuments() - Method in class bb.common.InspectionConformanceReportVO

getIcrItemChecks() - Method in class bb.common.InspectionConformanceReportItemVO

getIcrItemInfoByPk(InspectionConformanceReportItemPK) - Method in interface bb.common.box.QualityBox

getIcrItemNumber() - Method in class bb.common.IcrItemListResult

getIcrItemNumber() - Method in class bb.common.InspectionConformanceReportItemCheckPK

getIcrItemNumber() - Method in class bb.common.InspectionConformanceReportItemPK

getIcrItems() - Method in class bb.common.InspectionConformanceReportVO

getIcrItemsCountByDate(String, String, String, String, String, String, Date, Date, String, String) - Method in interface bb.common.box.QualityBox

getIcrNumber() - Method in class bb.common.IcrItemListResult

getIcrNumber() - Method in class bb.common.IcrListResult

getIcrNumber() - Method in class bb.common.InspectionConformanceReportItemCheckPK

getIcrNumber() - Method in class bb.common.InspectionConformanceReportItemPK

getIcrNumber() - Method in class bb.common.InspectionConformanceReportVO

getIcrsCountById(String) - Method in interface bb.common.box.QualityBox

getIcrsCountByVendorId(String) - Method in interface bb.common.box.QualityBox

getId() - Method in class bb.common.AccountingConfigurationVO

getId() - Method in class bb.common.AccountingSettingsVO

getId() - Method in class bb.common.AddressAccountInfo

getId() - Method in class bb.common.AssetTypeVO

getId() - Method in class bb.common.BB2BigDecimalAndString

getId() - Method in class bb.common.BB2Picture

getId() - Method in class bb.common.BizboxBugChangesInfoVO

getId() - Method in class bb.common.BizboxBugChangesVO

getId() - Method in class bb.common.BizboxBugInfoVO

getId() - Method in class bb.common.BizboxBugVO

getId() - Method in class bb.common.BuyerCodeVO

getId() - Method in class bb.common.CertificateDescriptionVO

getId() - Method in class bb.common.CommonPrintTemplateVO

getId() - Method in class bb.common.CompanyUnitVO

getId() - Method in class bb.common.CompanyVO

getId() - Method in class bb.common.ContractPriceCustomerPK

getId() - Method in class bb.common.CustomDepartmentVO

getId() - Method in class bb.common.CustomEmployeeTrainPK

getId() - Method in class bb.common.CustomEmployeeVO

getId() - Method in class bb.common.CustomerVendorAddressInfoVO

getId() - Method in class bb.common.CustomerVendorAddressVO

getId() - Method in class bb.common.CustomerVendorContactPK

getId() - Method in class bb.common.CustomerVendorDescriptionPK

getId() - Method in class bb.common.CustomGoodsBreedVO

getId() - Method in class bb.common.CustomJobCategoryVO

getId() - Method in class bb.common.CustomSearchVO

getId() - Method in class bb.common.CustomTranslationVO

getId() - Method in class bb.common.CV2CVAgent

getId() - Method in class bb.common.DataFilterVO

getId() - Method in class bb.common.DepartmentLocationForBackflushVO

getId() - Method in class bb.common.DocumentLogVO

getId() - Method in class bb.common.EmployeeCardVO

getId() - Method in class bb.common.EmployeeHomeVO

getId() - Method in class bb.common.EmployeeJobDescriptionVO

getId() - Method in class bb.common.EngGroupVO

getId() - Method in class bb.common.GeneralLedgerCategoryVO

getId() - Method in class bb.common.GeneralLedgerResult

getId() - Method in class bb.common.GeneralLedgerSettingsVO

getId() - Method in class bb.common.GLCheckRegisterResult

getId() - Method in class bb.common.IncotermVO

getId() - Method in class bb.common.IpAddressVO

getId() - Method in class bb.common.LockedCustomerAddressResult

getId() - Method in class bb.common.ManufacturerAddressInfoVO

getId() - Method in class bb.common.ManufacturerAddressVO

getId() - Method in class bb.common.ManufacturerContactPK

getId() - Method in class bb.common.ManufacturerDescriptionPK

getId() - Method in class bb.common.MessageVO

getId() - Method in class bb.common.NonproductivePickingItemResult

getId() - Method in class bb.common.NonproductivePickingOnDemandResult

getId() - Method in class bb.common.OIPrincipalVO

getId() - Method in class bb.common.OntimeDeliveryRateListResult

getId() - Method in class bb.common.OperationLogVO

getId() - Method in class bb.common.PartClassVO

getId() - Method in class bb.common.PartTypeVO

getId() - Method in class bb.common.PointOfSaleVO

getId() - Method in class bb.common.PostCheckAgent

getId() - Method in class bb.common.ProjectVO

getId() - Method in class bb.common.ServerAction

getId() - Method in class bb.common.ServerClientPropertyPK

getId() - Method in class bb.common.UnitVO

getId() - Method in class bb.common.UserGroupVO

getId() - Method in class bb.common.VendorContractPriceVendorPK

getId() - Method in class bb.common.WorkOrderInWipResult

getId() - Method in class bb.common.WorkOrderOnDemandResult

getId() - Method in class bb.common.WorkOrderOnOrderResult

getIdCard() - Method in class bb.common.EmployeeCardVO

getIdentifer() - Method in class bb.common.SGQuoteCartVO

getIdentifier() - Method in class bb.common.BB2DoubleString

getIdentifier() - Method in class bb.common.ClientListItem

getIdentifier() - Method in class bb.common.SGLogLoginVO

getIdentifier() - Method in class bb.common.SGQuoteLoginVO

getIi() - Method in class bb.common.AccountingInfoDocumentVO

getIi() - Method in class bb.common.AccountPayableCheckVO

getIi() - Method in class bb.common.AccountReceivablePaymentVO

getIi() - Method in class bb.common.AccountsChartCategoryVO

getIi() - Method in class bb.common.AccountsReceivableItemManufacturerPK

getIi() - Method in class bb.common.AddressQualityDocumentsVO

getIi() - Method in class bb.common.AssetUsagePK

getIi() - Method in class bb.common.AuditLogVO

getIi() - Method in class bb.common.BillItemReplacementVO

getIi() - Method in class bb.common.BillLogVO

getIi() - Method in class bb.common.ChangeStdCostWorkSheetItemPK

getIi() - Method in class bb.common.ChangeStdCostWorkSheetVO

getIi() - Method in class bb.common.CustomAssetRecordPK

getIi() - Method in class bb.common.CustomCheckUpEmployeeVO

getIi() - Method in class bb.common.CustomEmployeeTrainPK

getIi() - Method in class bb.common.CustomerServiceIncidentItemVO

getIi() - Method in class bb.common.CustomerVendorTypeVO

getIi() - Method in class bb.common.CustomGoodsRecordVO

getIi() - Method in class bb.common.DesignControlDocumentVO

getIi() - Method in class bb.common.DisassembleWorkOrderDocumentVO

getIi() - Method in class bb.common.DisassembleWorkOrderIssueVO

getIi() - Method in class bb.common.DwfUploadSettingsVO

getIi() - Method in class bb.common.DwgUploadSettingsVO

getIi() - Method in class bb.common.EmployeeEducationPK

getIi() - Method in class bb.common.EmployeeRecordsVO

getIi() - Method in class bb.common.EmployeeWorkExperiencePK

getIi() - Method in class bb.common.EngineeringChangeDocumentVO

getIi() - Method in class bb.common.EngineeringChangeRequestDocumentVO

getIi() - Method in class bb.common.EngineeringSharingImportLogVO

getIi() - Method in class bb.common.ExpenseItemPK

getIi() - Method in class bb.common.GLAutoApproveVO

getIi() - Method in class bb.common.HelpServerVO

getIi() - Method in class bb.common.HistoricalInventoryVO

getIi() - Method in class bb.common.ImportDataVO

getIi() - Method in class bb.common.InspectionReportInspectMethodItemPK

getIi() - Method in class bb.common.InspectionReportInspectMethodVO

getIi() - Method in class bb.common.InspectionReportInspectStandardItemPK

getIi() - Method in class bb.common.InspectionReportItemQtyPK

getIi() - Method in class bb.common.InventoryAdjustmentVO

getIi() - Method in class bb.common.LabelTemplateItemPK

getIi() - Method in class bb.common.LabelTemplateVO

getIi() - Method in class bb.common.LogInventoryVO

getIi() - Method in class bb.common.LogMiscDocumentVO

getIi() - Method in class bb.common.LogPartDocumentVO

getIi() - Method in class bb.common.LogPartDwfVO

getIi() - Method in class bb.common.LogPartDwgVO

getIi() - Method in class bb.common.LogTaskVO

getIi() - Method in class bb.common.LogTrackingVO

getIi() - Method in class bb.common.MaintenanceItemPK

getIi() - Method in class bb.common.MiscDocumentSettingVO

getIi() - Method in class bb.common.MrpByMonthResult

getIi() - Method in class bb.common.NCRPartOnhandPK

getIi() - Method in class bb.common.NCRPictureListResult

getIi() - Method in class bb.common.NCRPictureVO

getIi() - Method in class bb.common.NonConformanceQuantityPK

getIi() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getIi() - Method in class bb.common.NonproductivePickingItemIssuedVO

getIi() - Method in class bb.common.NonproductivePickingTypeVO

getIi() - Method in class bb.common.OnloanDocumentVO

getIi() - Method in class bb.common.OperatingInstructionsInspectMethodItemPK

getIi() - Method in class bb.common.OperatingInstructionsInspectResultItemPK

getIi() - Method in class bb.common.OperatingInstructionsInspectStandardItemPK

getIi() - Method in class bb.common.OperatingInstructionsInspectStandardVO

getIi() - Method in class bb.common.OperatingInstructionsManualItemPK

getIi() - Method in class bb.common.OperatingInstructionsManualVO

getIi() - Method in class bb.common.OperatingInstructionsTypeVO

getIi() - Method in class bb.common.OperatingOutputFileItemPK

getIi() - Method in class bb.common.OperatingOutputFileTypeVO

getIi() - Method in class bb.common.OrderApprovalItemsVO

getIi() - Method in class bb.common.OrderApprovalVO

getIi() - Method in class bb.common.OrderBoilerplatePK

getIi() - Method in class bb.common.OrderDocumentVO

getIi() - Method in class bb.common.PartCertificateVO

getIi() - Method in class bb.common.PartInQAAgent

getIi() - Method in class bb.common.PartInQAResult

getIi() - Method in class bb.common.PartInQAVO

getIi() - Method in class bb.common.PartIssuedVO

getIi() - Method in class bb.common.PartNumberGenerateRuleVO

getIi() - Method in class bb.common.PartOnhandCostVO

getIi() - Method in class bb.common.PartPictureVO

getIi() - Method in class bb.common.PartReceivedVO

getIi() - Method in class bb.common.PosRefdocVO

getIi() - Method in class bb.common.PrintTemplateVO

getIi() - Method in class bb.common.ProformaInvoiceItemManufacturerPK

getIi() - Method in class bb.common.PurchaseOrderDocumentVO

getIi() - Method in class bb.common.QuoteDocumentVO

getIi() - Method in class bb.common.QuoteItemManufacturerPK

getIi() - Method in class bb.common.RebackInQAAgent

getIi() - Method in class bb.common.ReceiverItemManufacturerPK

getIi() - Method in class bb.common.RefdocVO

getIi() - Method in class bb.common.RequestForQuoteItemManufacturerPK

getIi() - Method in class bb.common.ReturnMaterialAuthorizationDocumentVO

getIi() - Method in class bb.common.RollUpBomStdCostWorkSheetItemPK

getIi() - Method in class bb.common.RollUpBomStdCostWorkSheetVO

getIi() - Method in class bb.common.SalesOrderDocumentVO

getIi() - Method in class bb.common.SalesOrderItemManufacturerPK

getIi() - Method in class bb.common.SGSaleItemVO

getIi() - Method in class bb.common.ShipListOwnerAttributePK

getIi() - Method in class bb.common.ShipperItemManufacturerPK

getIi() - Method in class bb.common.SmtpServerVO

getIi() - Method in class bb.common.TaskFileResult

getIi() - Method in class bb.common.TaskVO

getIi() - Method in class bb.common.TaxAccountVO

getIi() - Method in class bb.common.TempArApAgingVO

getIi() - Method in class bb.common.TermsConditionVO

getIi() - Method in class bb.common.TermVO

getIi() - Method in class bb.common.ToolCalibrationVO

getIi() - Method in class bb.common.WorkInstructionDocumentVO

getIi() - Method in class bb.common.WorkInstructionPictureVO

getIi() - Method in class bb.common.WorkOrderDocumentVO

getIi() - Method in class bb.common.WorkOrderItemPartDetailInWipVO

getIi() - Method in class bb.common.WorkOrderItemTimeDetailVO

getIi() - Method in class bb.common.WorkOrderReceiverVO

getIi() - Method in class bb.common.WorkOrderTimeCardVO

getIi() - Method in class bb.common.WorkPeriodVO

getIi() - Method in class bb.common.ZipCodeTaxVO

getIllegalSettingReason() - Method in class bb.common.ReceiverAgent

getImageIconFromByteArray(byte[]) - Static method in class bb.common.BB2Util

getImplementionDue() - Method in class bb.common.CorrectiveActionRequestVO

getImplementionDue() - Method in class bb.common.PreventiveActionRequestVO

getImportComment() - Method in class bb.common.EngineeringChangeVO

getImportCompany() - Method in class bb.common.EngineeringChangeVO

getImportCompanyId() - Method in class bb.common.EngineeringChangeListResult

getImportDataType() - Method in class bb.common.EngineeringSharingImportLogVO

getImportDate() - Method in class bb.common.EngineeringSharingImportLogVO

getImportEc() - Method in class bb.common.EngineeringChangeVO

getImportEcnNumber() - Method in class bb.common.EngineeringChangeListResult

getImportKey() - Method in class bb.common.EngineeringSharingImportLogVO

getImportType() - Method in class bb.common.EngineeringSharingImportLogVO

getInAmount() - Method in class bb.common.InventoryMonthReport

getInBillPartsWithOnhandInfoCount(String, String, String) - Method in interface bb.common.box.EngineeringBox

getIncidentCountByCsiNumber(String) - Method in interface bb.common.box.CustomerServiceBox

getIncidentCountByCustomerId(String) - Method in interface bb.common.box.CustomerServiceBox

getIncidentCountByDate(String, PartPK, String, String, String, String, String, String, boolean, Date, Date) - Method in interface bb.common.box.CustomerServiceBox

getIncidentCountByDate(String, PartPK, String, String, String, boolean, Date, Date) - Method in interface bb.common.box.CustomerServiceBox

getIncidentCountByPartLike(String, String) - Method in interface bb.common.box.CustomerServiceBox

getIncidentItems() - Method in class bb.common.CustomerServiceIncidentVO

getIncidentItemsCountByCsi(String) - Method in interface bb.common.box.CustomerServiceBox

getIncidentNumber() - Method in class bb.common.CustomerServiceIncidentItemVO

getIncidentNumber() - Method in class bb.common.CustomerServiceIncidentVO

getIncidentType() - Method in class bb.common.CustomerServiceIncidentVO

getInclude() - Method in class bb.common.AccountPayableCheckRunVO

getInclude() - Method in class bb.common.ARPaymentRunVO

getIncludeVendorId() - Method in class bb.common.ApCheckRunItemAgent

getIncludeVendorId() - Method in class bb.common.ApPrepaymentCheckRunItemAgent

getIncludeVendorId() - Method in class bb.common.ArPaymentRunItemAgent

getIncludeVendorId() - Method in class bb.common.ArPrepaymentRunItemAgent

getIncludeVendorId() - Method in class bb.common.ARPrepaymentWireTransferAgent

getIncludeVendorId() - Method in class bb.common.PrepaymentWireTransferAgent

getIncludeVendorId() - Method in class bb.common.WireTransferAgent

getIncomeFromOperating() - Method in class bb.common.ProfitLossStatementResult

getIncomeTax() - Method in class bb.common.ClosingStatementResult

getIncomeTaxItems() - Method in class bb.common.ClosingStatementResult

getInCost() - Method in class bb.common.InventoryMonthReport

getInCost() - Method in class bb.common.LogInventoryListResult

getInCost() - Method in class bb.common.LogInventoryVO

getIncoterm() - Method in class bb.common.AccountsPayableInfoVO

getIncoterm() - Method in class bb.common.AccountsPayableVO

getIncoterm() - Method in class bb.common.AccountsReceivableInfoVO

getIncoterm() - Method in class bb.common.AccountsReceivableVO

getIncoterm() - Method in class bb.common.CustomerReturnToVendorVO

getIncoterm() - Method in class bb.common.OnloanReceiverVO

getIncoterm() - Method in class bb.common.OnloanShipperVO

getIncoterm() - Method in class bb.common.OnLoanVO

getIncoterm() - Method in class bb.common.PfReceiverVO

getIncoterm() - Method in class bb.common.PO2SOExchange

getIncoterm() - Method in class bb.common.ProformaInvoiceVO

getIncoterm() - Method in class bb.common.PurchaseOrderVO

getIncoterm() - Method in class bb.common.QuoteVO

getIncoterm() - Method in class bb.common.ReceiverInfoVO

getIncoterm() - Method in class bb.common.ReceiverVO

getIncoterm() - Method in class bb.common.RequestForQuoteVO

getIncoterm() - Method in class bb.common.RequestForRMAVO

getIncoterm() - Method in class bb.common.ReturnMaterialAuthorizationVO

getIncoterm() - Method in class bb.common.ReturnToVendorVO

getIncoterm() - Method in class bb.common.RMAReceiverVO

getIncoterm() - Method in class bb.common.RtvShipperInfoVO

getIncoterm() - Method in class bb.common.RtvShipperVO

getIncoterm() - Method in class bb.common.SalesOrderItemListResult

getIncoterm() - Method in class bb.common.SalesOrderVO

getIncoterm() - Method in class bb.common.ShipperInfoVO

getIncoterm() - Method in class bb.common.ShipperVO

getIncoterm() - Method in class bb.common.ShippingResult

getIncoterm() - Method in class bb.common.SwapOrderListResult

getIncoterm() - Method in class bb.common.SwapOrderVO

getIncoterm() - Method in class bb.common.SwapReceiverListResult

getIncoterm() - Method in class bb.common.SwapReceiverVO

getIncoterm() - Method in class bb.common.SwapShipperListResult

getIncoterm() - Method in class bb.common.SwapShipperVO

getIncoterm() - Method in class bb.common.TransferOrderListResult

getIncoterm() - Method in class bb.common.TransferOrderVO

getIncoterm() - Method in class bb.common.TransferReceiverListResult

getIncoterm() - Method in class bb.common.TransferReceiverVO

getIncoterm() - Method in class bb.common.TransferShipperListResult

getIncoterm() - Method in class bb.common.TransferShipperVO

getIncotermById(String) - Method in interface bb.common.box.SalesBox

getIncotermPlacePort() - Method in class bb.common.AccountsPayableInfoVO

getIncotermPlacePort() - Method in class bb.common.AccountsPayableVO

getIncotermPlacePort() - Method in class bb.common.AccountsReceivableInfoVO

getIncotermPlacePort() - Method in class bb.common.AccountsReceivableVO

getIncotermPlacePort() - Method in class bb.common.CustomerReturnToVendorVO

getIncotermPlacePort() - Method in class bb.common.OnloanReceiverVO

getIncotermPlacePort() - Method in class bb.common.OnloanShipperVO

getIncotermPlacePort() - Method in class bb.common.OnLoanVO

getIncotermPlacePort() - Method in class bb.common.PfReceiverVO

getIncotermPlacePort() - Method in class bb.common.ProformaInvoiceVO

getIncotermPlacePort() - Method in class bb.common.PurchaseOrderVO

getIncotermPlacePort() - Method in class bb.common.QuoteVO

getIncotermPlacePort() - Method in class bb.common.ReceiverInfoVO

getIncotermPlacePort() - Method in class bb.common.ReceiverVO

getIncotermPlacePort() - Method in class bb.common.RequestForQuoteVO

getIncotermPlacePort() - Method in class bb.common.RequestForRMAVO

getIncotermPlacePort() - Method in class bb.common.ReturnMaterialAuthorizationVO

getIncotermPlacePort() - Method in class bb.common.ReturnToVendorVO

getIncotermPlacePort() - Method in class bb.common.RMAReceiverVO

getIncotermPlacePort() - Method in class bb.common.RtvShipperInfoVO

getIncotermPlacePort() - Method in class bb.common.RtvShipperVO

getIncotermPlacePort() - Method in class bb.common.SalesOrderItemListResult

getIncotermPlacePort() - Method in class bb.common.SalesOrderVO

getIncotermPlacePort() - Method in class bb.common.ShipperInfoVO

getIncotermPlacePort() - Method in class bb.common.ShipperVO

getIncotermPlacePort() - Method in class bb.common.SwapOrderListResult

getIncotermPlacePort() - Method in class bb.common.SwapOrderVO

getIncotermPlacePort() - Method in class bb.common.SwapReceiverListResult

getIncotermPlacePort() - Method in class bb.common.SwapReceiverVO

getIncotermPlacePort() - Method in class bb.common.SwapShipperListResult

getIncotermPlacePort() - Method in class bb.common.SwapShipperVO

getIncotermPlacePort() - Method in class bb.common.TransferOrderListResult

getIncotermPlacePort() - Method in class bb.common.TransferOrderVO

getIncotermPlacePort() - Method in class bb.common.TransferReceiverListResult

getIncotermPlacePort() - Method in class bb.common.TransferReceiverVO

getIncotermPlacePort() - Method in class bb.common.TransferShipperListResult

getIncotermPlacePort() - Method in class bb.common.TransferShipperVO

getIndex() - Method in class bb.common.AccountsChartCategoryVO

getInfoByMonthMap() - Method in class bb.common.IncomeByMonthChartResult

getInfoByMonthMap() - Method in class bb.common.InfoByFiscalChartResult

getInfoByMonthMap() - Method in class bb.common.InfoByMonthChartResult

getInfoTotalMap() - Method in class bb.common.InfoByFiscalChartResult

getInfoTotalMap() - Method in class bb.common.InfoByMonthChartResult

getInitDefaultCostPerUnit(BB2Part, String) - Method in interface bb.common.box.PurchasingBox

getInitDefaultPricePerUnit(BB2Part, String) - Method in interface bb.common.box.SalesBox

getInitialDepreciateCost() - Method in class bb.common.AssetAddOrDisposalsReport

getInitialDepreciateCost() - Method in class bb.common.AssetDepreciateDetailReport

getInitialDepreciateCost() - Method in class bb.common.AssetDepreciateVO

getInitialDepreciateCost() - Method in class bb.common.AssetReportSumResult

getInitialDepreciateCost() - Method in class bb.common.AssetVO

getInitSom() - Method in class bb.common.GeneralLedgerSettingsVO

getInitStep() - Method in class bb.common.CompanyVO

getInnerDiameter() - Method in class bb.common.PartMaterialListResult

getInnerDiameter() - Method in class bb.common.PartMaterialReportAgent

getInnerDiameter() - Method in class bb.common.PartMaterialVO

getInnerDiameter() - Method in class bb.common.PartMaterialWhereUsedItemResult

getInnerDiameterUnit() - Method in class bb.common.PartMaterialListResult

getInnerDiameterUnit() - Method in class bb.common.PartMaterialVO

getInnerDiameterUnit() - Method in class bb.common.PartMaterialWhereUsedItemResult

getInnerOperator() - Method in class bb.common.PartMaterialReportAgent

getInnerUnit() - Method in class bb.common.PartMaterialReportAgent

getInQa() - Method in class bb.common.InventoryListResult

getInQAQty() - Method in class bb.common.AuditPartInQAResult

getInQAQty() - Method in class bb.common.PartWithQAQtyListResult

getInQty() - Method in class bb.common.InventoryMonthReport

getInQty() - Method in class bb.common.InventoryPartInOutDetailListResult

getInQty() - Method in class bb.common.LogInventoryListResult

getInQty() - Method in class bb.common.LogInventoryVO

getInQty() - Method in class bb.common.LogTrackingVO

getInQualityCheckingQty() - Method in class bb.common.HistoricalInventoryVO

getInQualityCheckingQty() - Method in class bb.common.PartInventoryVO

getInQualityCheckingQty() - Method in class bb.common.PhysicalInventoryListResult

getInQualityCheckingQty() - Method in class bb.common.PhysicalInventoryVO

getInQualityCheckingQty() - Method in class bb.common.ToolInventoryVO

getInSip() - Method in class bb.common.BB2PartInfo

getInsip() - Method in class bb.common.BB2PartOnDemandListResult

getInSip() - Method in class bb.common.BillItemOnHandUsageResult

getInSip() - Method in class bb.common.BillItemOnHandWithPartInfoResult

getInSip() - Method in class bb.common.BillOnHandWithPartInfoResult

getInSip() - Method in class bb.common.InventoryListResult

getInSIP() - Method in class bb.common.PartOnhandResult

getInSip() - Method in class bb.common.PartOnHandWithMfgInfoResult

getInSIP() - Method in class bb.common.SalesOrderItemGroupByPartListResult

getInSipCount() - Method in class bb.common.WareHousingInfoCenterResult

getInSIPInSO() - Method in class bb.common.SalesOrderItemGroupByPartListResult

getInSipQty() - Method in class bb.common.PartWithSipQtyListResult

getInSipTotal() - Method in class bb.common.WareHousingInfoCenterResult

getInSit() - Method in class bb.common.BB2PartInfo

getInsit() - Method in class bb.common.BB2PartOnDemandListResult

getInSit() - Method in class bb.common.BillItemOnHandUsageResult

getInSit() - Method in class bb.common.BillItemOnHandWithPartInfoResult

getInSit() - Method in class bb.common.BillOnHandWithPartInfoResult

getInSit() - Method in class bb.common.PartOnHandWithMfgInfoResult

getInSitCount() - Method in class bb.common.WareHousingInfoCenterResult

getInSITQty() - Method in class bb.common.PartWithSITQtyListResult

getInSitTotal() - Method in class bb.common.WareHousingInfoCenterResult

getInspectedBy() - Method in class bb.common.JobProcessSheetItemResult

getInspectedBy() - Method in class bb.common.ToolCalibrationVO

getInspectedDate() - Method in class bb.common.JobProcessSheetItemResult

getInspectedQty() - Method in class bb.common.NcrNeedToScrapListResult

getInspectedQty() - Method in class bb.common.NonConformanceReportVO

getInspectionContent() - Method in class bb.common.OperatingInstructionsVO

getInspectionDate() - Method in class bb.common.OperatingInstructionsInspectResultItemVO

getInspectionDescription() - Method in class bb.common.InspectionItemVO

getInspectionItem(InspectionItemPK) - Method in interface bb.common.box.ManufacturingBox

getInspectionOutputFileNumber() - Method in class bb.common.OperatingInstructionsVO

getInspectionPeriod() - Method in class bb.common.ToolCalibrationVO

getInspectionPeriodUnit() - Method in class bb.common.ToolCalibrationVO

getInspectionReport(String) - Method in interface bb.common.box.ManufacturingBox

getInspectionReportCount(String, String) - Method in interface bb.common.box.ManufacturingBox

getInspectionReportDate() - Method in class bb.common.InspectionReportInfoVO

getInspectionReportDate() - Method in class bb.common.InspectionReportVO

getInspectionReportInspectMethod(int) - Method in interface bb.common.box.ManufacturingBox

getInspectionReportInspectMethod() - Method in class bb.common.InspectionReportInspectMethodItemVO

getInspectionReportInspectMethodItems() - Method in class bb.common.InspectionReportVO

getInspectionReportInspectStandard() - Method in class bb.common.InspectionReportInspectStandardItemVO

getInspectionReportInspectStandardItems() - Method in class bb.common.InspectionReportVO

getInspectionReportItems() - Method in class bb.common.InspectionReportVO

getInspectionReportNumber() - Method in class bb.common.InspectionReportInfoVO

getInspectionReportNumber() - Method in class bb.common.InspectionReportInspectMethodItemPK

getInspectionReportNumber() - Method in class bb.common.InspectionReportInspectStandardItemPK

getInspectionReportNumber() - Method in class bb.common.InspectionReportItemPK

getInspectionReportNumber() - Method in class bb.common.InspectionReportItemQtyPK

getInspectionReportNumber() - Method in class bb.common.InspectionReportVO

getInspectionReportNumber() - Method in class bb.common.OperatingInstructionsInspectResultItemVO

getInspectionReportNumber() - Method in class bb.common.OperatingInstructionsVO

getInspectionRequest() - Method in class bb.common.InspectionItemVO

getInspectionResult() - Method in class bb.common.InspectionReportInfoVO

getInspectionResult() - Method in class bb.common.InspectionReportVO

getInspectionResult() - Method in class bb.common.OperatingInstructionsInspectResultItemVO

getInspectionResult() - Method in class bb.common.OperatingInstructionsVO

getInspectionResultSign() - Method in class bb.common.OperatingInstructionsInspectResultItemVO

getInspectionResultSign() - Method in class bb.common.OperatingInstructionsVO

getInspections() - Method in class bb.common.PartInspectionResult

getInspections() - Method in class bb.common.ToolVO

getInspectionType(String) - Method in interface bb.common.box.QualityBox

getInspectionType() - Method in class bb.common.InspectionTypeItemPK

getInspectionType() - Method in class bb.common.InspectionTypeVO

getInspectionType() - Method in class bb.common.PartInspectionResult

getInspectionType() - Method in class bb.common.PartVO

getInspectionType() - Method in class bb.common.ToolVO

getInspectionTypeCount(String) - Method in interface bb.common.box.QualityBox

getInspectionTypeItems() - Method in class bb.common.InspectionTypeVO

getInspector() - Method in class bb.common.IcrItemListResult

getInspector() - Method in class bb.common.InspectionConformanceReportItemVO

getInspector() - Method in class bb.common.InspectionReportInfoVO

getInspector() - Method in class bb.common.InspectionReportVO

getInspectProject() - Method in class bb.common.InspectionConformanceReportItemCheckVO

getInspectProject() - Method in class bb.common.InspectionTypeItemVO

getInspectProject() - Method in class bb.common.PartInspectionVO

getInstalledDate() - Method in class bb.common.EquipmentVO

getInstance(String) - Static method in class bb.common.Reason

getInstance() - Static method in class bb.common.StringListConvertor

getInSTO() - Method in class bb.common.InventoryListResult

getInSTO() - Method in class bb.common.PartInventoryVO

getInSTO() - Method in class bb.common.ToolInventoryVO

getInternalSalesMailto() - Method in class bb.common.SGCompanyVO

getInternalValue(String) - Static method in class bb.common.Constant.IssuedFrom

getInTOQty() - Method in class bb.common.HistoricalInventoryVO

getInTOQty() - Method in class bb.common.PartWithSTOQtyListResult

getInTotalCost() - Method in class bb.common.InventoryPartInOutDetailListResult

getInventory() - Method in class bb.common.AccountingBalanceSheetResult

getInventoryAction() - Method in class bb.common.EngineeringChangeVO

getInventoryAdjustment(Long) - Method in interface bb.common.box.WarehouseBox

getInventoryAdjustmentDetail(BB2Part) - Method in interface bb.common.box.WarehouseBox

getInventoryAdjustmentListResult(BB2Part) - Method in interface bb.common.box.WarehouseBox

getInventoryAdjustmentRecordsCount(BB2Part) - Method in interface bb.common.box.WarehouseBox

getInventoryAdjustmentRecordsCount(String, String, String, String, Date, Date) - Method in interface bb.common.box.WarehouseBox

getInventoryAmountByDate(Date, Date) - Method in interface bb.common.box.ManagementBox

getInventoryByBB2Part(BB2Part) - Method in interface bb.common.box.WarehouseBox

getInventoryCostVarianceCount(String, String, String, BigDecimal) - Method in interface bb.common.box.WarehouseBox

getInventoryCycleResults(String) - Method in interface bb.common.box.WarehouseBox

getInventoryListResultCountOnlyWithMinAndMaxQty(String) - Method in interface bb.common.box.WarehouseBox

getInventoryListResultCountOnlyWithMinQty(String, String) - Method in interface bb.common.box.WarehouseBox

getInventoryListResultGTMaxQtyCount(String, String) - Method in interface bb.common.box.WarehouseBox

getInventoryListResultsCost(boolean, boolean, boolean, boolean, String, String, String, String, String, String, String, String, String) - Method in interface bb.common.box.WarehouseBox

getInventoryListResultsCount(boolean, boolean, boolean, boolean, String, String, String, String, String, String, String, String, String, String) - Method in interface bb.common.box.WarehouseBox

getInventoryListResultsCountByCommodityCode(String, String, String, String) - Method in interface bb.common.box.WarehouseBox

getInventoryListResultWithMinAndMaxQtyCount() - Method in interface bb.common.box.WarehouseBox

getInventoryModify() - Method in class bb.common.EngineeringChangeVO

getInventoryMonthReportCount(Date, Date, String, String) - Method in interface bb.common.box.WarehouseBox

getInventoryNotUsedCostInMonths(int) - Method in interface bb.common.box.WarehouseBox

getInventoryNotUsedCostInMonths(Date) - Method in interface bb.common.box.WarehouseBox

getInventoryNotUsedInMonthsResultsCount(int, boolean) - Method in interface bb.common.box.WarehouseBox

getInventoryNotUsedInMonthsResultsCount(Date, boolean) - Method in interface bb.common.box.WarehouseBox

getInventoryNotUsedInMonthsResultsforAppCount(Date) - Method in interface bb.common.box.WarehouseBox

getInventoryReportListCount(String, String, Date, Date) - Method in interface bb.common.box.WarehouseBox

getInventoryScrap() - Method in class bb.common.EngineeringChangeVO

getInventoryTotalCountByProductCode(String) - Method in interface bb.common.box.WarehouseBox

getInventoryTotalResult() - Method in interface bb.common.box.WarehouseBox

getInventoryUseAsIs() - Method in class bb.common.EngineeringChangeVO

getInventoryValuation() - Method in class bb.common.AccountingSettingsVO

getInvoiceBoilerplate() - Method in class bb.common.AccountsReceivableInfoVO

getInvoiceBoilerplate() - Method in class bb.common.AccountsReceivableVO

getInvoiceByDateCount(String, boolean, String, String, String, String, boolean, String, String, String, String, String, boolean, Date, Date, BigDecimal, BigDecimal, boolean, Map) - Method in interface bb.common.box.AccountingBox

getInvoiceByDateCount(boolean, String, String, boolean, Date, Date) - Method in interface bb.common.box.AccountingBox

getInvoiceByDateCount(String[]) - Method in interface bb.common.box.AccountingBox

getInvoiceComments() - Method in class bb.common.AccountsReceivableInfoVO

getInvoiceComments() - Method in class bb.common.AccountsReceivableItemVO

getInvoiceComments() - Method in class bb.common.AccountsReceivableVO

getInvoiceDate() - Method in class bb.common.AddPayableWithoutReceiverAgent

getInvoiceDate() - Method in class bb.common.CustomerFeedbackVO

getInvoicedBy() - Method in class bb.common.AccountsReceivableInfoVO

getInvoicedBy() - Method in class bb.common.AccountsReceivableVO

getInvoicedBy() - Method in class bb.common.OnloanShipperVO

getInvoicedBy() - Method in class bb.common.ProformaInvoiceVO

getInvoicedBy() - Method in class bb.common.RtvShipperInfoVO

getInvoicedBy() - Method in class bb.common.RtvShipperVO

getInvoicedBy() - Method in class bb.common.ShipperInfoVO

getInvoicedBy() - Method in class bb.common.ShipperVO

getInvoicedDate() - Method in class bb.common.AccountsReceivableInfoVO

getInvoicedDate() - Method in class bb.common.AccountsReceivableVO

getInvoicedDate() - Method in class bb.common.OnloanShipperVO

getInvoicedDate() - Method in class bb.common.ProformaInvoiceVO

getInvoicedDate() - Method in class bb.common.RtvShipperInfoVO

getInvoicedDate() - Method in class bb.common.RtvShipperVO

getInvoicedDate() - Method in class bb.common.ShipperInfoVO

getInvoicedDate() - Method in class bb.common.ShipperVO

getInvoicedSum() - Method in class bb.common.SalesInfoCenter

getInvoicedTotal() - Method in class bb.common.SalesOrder12MonthMarginResult

getInvoiceItemNumber() - Method in class bb.common.AccountsReceivableItemPK

getInvoiceItemNumber() - Method in class bb.common.InvoiceItemListResult

getInvoiceItemNumber() - Method in class bb.common.SalesTaxListResult

getInvoiceItemsByPartPKCount(PartPK) - Method in interface bb.common.box.AccountingBox

getInvoiceNotes() - Method in class bb.common.AccountsReceivableInfoVO

getInvoiceNotes() - Method in class bb.common.AccountsReceivableVO

getInvoiceNumber() - Method in class bb.common.AccountReceivableInfoWithPrepayResult

getInvoiceNumber() - Method in class bb.common.AccountsReceivableInfoVO

getInvoiceNumber() - Method in class bb.common.AccountsReceivableItemManufacturerPK

getInvoiceNumber() - Method in class bb.common.AccountsReceivableItemPK

getInvoiceNumber() - Method in class bb.common.AccountsReceivableVO

getInvoiceNumber() - Method in class bb.common.AddProformaReceiverItemAgent

getInvoiceNumber() - Method in class bb.common.ArCommissionListResult

getInvoiceNumber() - Method in class bb.common.CRTVItemListResult

getInvoiceNumber() - Method in class bb.common.CRTVListResult

getInvoiceNumber() - Method in class bb.common.CustomerReturnToVendorVO

getInvoiceNumber() - Method in class bb.common.CustomerStatementListResult

getInvoiceNumber() - Method in class bb.common.GeneralLedgerListResult

getInvoiceNumber() - Method in class bb.common.GeneralLedgerResult

getInvoiceNumber() - Method in class bb.common.GeneralLedgerVO

getInvoiceNumber() - Method in class bb.common.InvoiceItemListResult

getInvoiceNumber() - Method in class bb.common.PostCheckAgent

getInvoiceNumber() - Method in class bb.common.RequestForRMAVO

getInvoiceNumber() - Method in class bb.common.ReturnMaterialAuthorizationVO

getInvoiceNumber() - Method in class bb.common.RMAItemListResult

getInvoiceNumber() - Method in class bb.common.RMAListResult

getInvoiceNumber() - Method in class bb.common.RRMAItemListResult

getInvoiceNumber() - Method in class bb.common.RRMAListResult

getInvoiceNumber() - Method in class bb.common.RunningAccountOrderVO

getInvoiceNumber() - Method in class bb.common.SalesTaxListResult

getInvoiceNumber() - Method in class bb.common.ShipperItemVO

getInvoiceNumber() - Method in class bb.common.SOShipperItemListResult

getInvoicePrivateNotes() - Method in class bb.common.AccountsReceivableItemVO

getInvoicesInfoByFiscalYear(String) - Method in interface bb.common.box.ManagementBox

getInvoicesInfoByMonth(int) - Method in interface bb.common.box.ManagementBox

getInvoiceStatus() - Method in class bb.common.SalesOrderItemListResult

getInvoiceTotal() - Method in class bb.common.MoneyInDrawResult

getInWip() - Method in class bb.common.BB2PartInfo

getInwip() - Method in class bb.common.BB2PartOnDemandListResult

getInWip() - Method in class bb.common.BillItemOnHandUsageResult

getInWip() - Method in class bb.common.BillItemOnHandWithPartInfoResult

getInWip() - Method in class bb.common.BillOnHandWithPartInfoResult

getInWip() - Method in class bb.common.InventoryListResult

getInWIP() - Method in class bb.common.PartOnhandResult

getInWip() - Method in class bb.common.PartOnHandWithMfgInfoResult

getInwip() - Method in class bb.common.PartWithInventoryInfoListResult

getInWip() - Method in class bb.common.StockTransactionPartInfoResult

getInWip() - Method in class bb.common.WorkOrderItemIssueVO

getInWIPQty() - Method in class bb.common.DisassembleWorkOrderItemListResult

getInWipQty() - Method in class bb.common.PartInWipForIDListResult

getInWipQty() - Method in class bb.common.PartWithWipQtyListResult

getInWIPQty() - Method in class bb.common.WorkOrderItemListResult

getIp() - Method in class bb.common.BizboxUserListResult

getIp() - Method in class bb.common.BizboxUserVO

getIp1() - Method in class bb.common.IpAddressVO

getIp2() - Method in class bb.common.IpAddressVO

getIpAddr() - Method in class bb.common.RunningAccountOrderVO

getIpAddress() - Method in class bb.common.SubcompanyVO

getIpAddressInfo(String) - Method in interface bb.common.box.LogBox

getIrNumber() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

getIrNumber() - Method in class bb.common.ReceiverItemAgent

getIrNumber() - Method in class bb.common.ReceivingItemResult

getIrNumber() - Method in class bb.common.WorkOrderReceiverVO

getIrTotalRefQty() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getIrTotalRefQty() - Method in class bb.common.ReceivingItemResult

getIrType() - Method in class bb.common.PartVO

getIrType() - Method in class bb.common.ToolVO

getIsActivePart() - Method in class bb.common.PartVO

getIsActivePart() - Method in class bb.common.PartWithOnhandsVO

getIsGroup() - Method in class bb.common.IssueItemAgent

getIsGroup() - Method in class bb.common.IssuingItemResult

getIsGroup() - Method in class bb.common.ReceivedToOrderItem

getIsGroup() - Method in class bb.common.ReceiverItemDetailAgent

getIssueAvgCost() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getIssueAvgCost() - Method in class bb.common.WorkOrderItemInWipListResult

getIssueCost() - Method in class bb.common.WOIssuedByMonthResult

getIssueDate() - Method in class bb.common.DisassembleWorkOrderIssuingResult

getIssuedByMonthList() - Method in class bb.common.WOIssuedByMonthChartResult

getIssuedCost() - Method in class bb.common.WorkOrderItemPartDetailResult

getIssuedDate() - Method in class bb.common.StockTransactionWOShipperResult

getIssuedFrom() - Method in class bb.common.IssuedFromOrderItem

getIssuedFrom() - Method in class bb.common.IssueItemDetailAgent

getIssuedFrom() - Method in class bb.common.ShipperItemDetailAgent

getIssuedLocate() - Method in class bb.common.IssuedFromOrderItem

getIssuedPartTotalCount(WorkOrderItemPK, PartPK, String, String, String, String, Date, Date) - Method in interface bb.common.box.WarehouseBox

getIssuedQty() - Method in class bb.common.IssueItemDetailAgent

getIssuedQty() - Method in class bb.common.MasterWorkOrderTreeItemResult

getIssuedQty() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getIssuedQty() - Method in class bb.common.PartInWipForIDListResult

getIssuedQty() - Method in class bb.common.StockTransactionWOShipperResult

getIssuedQty() - Method in class bb.common.WorkOrderItemInWipListResult

getIssuedQuantity() - Method in class bb.common.NonproductivePickingItemResult

getIssuedQuantity() - Method in class bb.common.NonproductivePickingItemVO

getIssuedRate() - Method in class bb.common.WCLoadDetailResult

getIssuedStdCost() - Method in class bb.common.WorkOrderItemPartDetailResult

getIssuedToOrderItems() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getIssuedTotal() - Method in class bb.common.WorkOrderItemIssuedTotalResult

getIssueItemDetails() - Method in class bb.common.IssueItemAgent

getIssueQuantity() - Method in class bb.common.WOIssuedByMonthResult

getIssueQuantity() - Method in class bb.common.WOItemPartDetailNotIssue

getIssueQuantity() - Method in class bb.common.WorkOrderItemIssuedTotalResult

getIssueQuantity() - Method in class bb.common.WorkOrderItemIssueVO

getIssueQuantity() - Method in class bb.common.WorkOrderItemPartDetail

getIssueQuantity() - Method in class bb.common.WorkOrderOverIssueListResult

getIssueVo() - Method in class bb.common.WorkOrderItemPartDetailItemResult

getIssuingItemResultForWorkOrderItem(WorkOrderItemPK) - Method in interface bb.common.box.WarehouseBox

getIssuingItems() - Method in class bb.common.IssuingResult

getItem() - Method in class bb.common.AssetAmortizationExpenseAccountPK

getItem() - Method in class bb.common.CustomerVendorContactPK

getItem() - Method in class bb.common.InspectionConformanceReportItemInfo

getItem() - Method in class bb.common.ManufacturerContactPK

getItem() - Method in class bb.common.ZipcodeTotalsResult

getItemAndQuantity() - Method in class bb.common.PurchaseOrderContractResult

getItemComments() - Method in class bb.common.BillItemReplacementVO

getItemComments() - Method in class bb.common.BillItemUsagePathResult

getItemComments() - Method in class bb.common.JobProcessSheetResult

getItemComments() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getItemComments() - Method in class bb.common.OnLoanItemVO

getItemComments() - Method in class bb.common.OrderApprovalItemsVO

getItemComments() - Method in class bb.common.PfReceiverItemVO

getItemComments() - Method in class bb.common.PO2SOExchangeItem

getItemComments() - Method in class bb.common.ProformaInvoiceItemVO

getItemComments() - Method in class bb.common.PurchaseOrderItemVO

getItemComments() - Method in class bb.common.ReturnToVendorItemVO

getItemComments() - Method in class bb.common.SGCustRequestForQuoteItemVO

getItemComments() - Method in class bb.common.SwapOrderItemListResult

getItemComments() - Method in class bb.common.SwapOrderItemVO

getItemComments() - Method in class bb.common.SwapReceiverItemListResult

getItemComments() - Method in class bb.common.SwapReceiverItemVO

getItemComments() - Method in class bb.common.SwapShipperItemListResult

getItemComments() - Method in class bb.common.SwapShipperItemVO

getItemComments() - Method in class bb.common.TransferOrderItemListResult

getItemComments() - Method in class bb.common.TransferOrderItemVO

getItemComments() - Method in class bb.common.TransferReceiverItemListResult

getItemComments() - Method in class bb.common.TransferReceiverItemVO

getItemComments() - Method in class bb.common.TransferShipperItemListResult

getItemComments() - Method in class bb.common.TransferShipperItemVO

getItemComments() - Method in class bb.common.WorkOrderItemLaborCostListResult

getItemCount() - Method in class bb.common.ChangeStdCostWorkSheetVO

getItemCounts() - Method in class bb.common.POStatisticsResult

getItemDescription() - Method in class bb.common.CRTVItemListResult

getItemDescription() - Method in class bb.common.OnLoanItemListResult

getItemDescription() - Method in class bb.common.PurchaseOrderItemListResult

getItemDescription() - Method in class bb.common.QuoteItemListResult

getItemDescription() - Method in class bb.common.RMAItemListResult

getItemDescription() - Method in class bb.common.RRMAItemListResult

getItemDescription() - Method in class bb.common.SalesOrderItemListResult

getItemGrandTotal() - Method in class bb.common.ReceiverItemVO

getItemGrandTotal() - Method in class bb.common.ReturnToVendorItemVO

getItemGrandTotal() - Method in class bb.common.RtvShipperItemVO

getItemIssuePk() - Method in class bb.common.WorkOrderItemPartDetailItemResult

getItemManf() - Method in class bb.common.PO2SOExchangeItem

getItemNotes() - Method in class bb.common.OnLoanItemVO

getItemNotes() - Method in class bb.common.PurchaseWorkSheetItemVO

getItemNumber() - Method in class bb.common.AccountCreditDebitPK

getItemNumber() - Method in class bb.common.AccountsPayableItemManufacturerPK

getItemNumber() - Method in class bb.common.BillItemUsagePathResult

getItemNumber() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getItemNumber() - Method in class bb.common.DisassembleWorkOrderItemReceiverPK

getItemNumber() - Method in class bb.common.DisassembleWorkOrderReceivingResult

getItemNumber() - Method in class bb.common.InspectionConformanceReportItemCheckPK

getItemNumber() - Method in class bb.common.InspectionItemPK

getItemNumber() - Method in class bb.common.InspectionReportItemPK

getItemNumber() - Method in class bb.common.InspectionReportItemQtyPK

getItemNumber() - Method in class bb.common.InspectionTypeItemPK

getItemNumber() - Method in class bb.common.IssuedFromOrderItem

getItemNumber() - Method in class bb.common.IssueItemAgent

getItemNumber() - Method in class bb.common.IssuingItemResult

getItemNumber() - Method in class bb.common.IssuingResult

getItemNumber() - Method in class bb.common.LabelTemplateItemPK

getItemNumber() - Method in class bb.common.MakePrepaymentCheckAgent

getItemNumber() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getItemNumber() - Method in class bb.common.NonproductivePickingItemIssuedVO

getItemNumber() - Method in class bb.common.OrderDemandForReceiverResult

getItemNumber() - Method in class bb.common.OrderPK

getItemNumber() - Method in class bb.common.PartInspectionPK

getItemNumber() - Method in class bb.common.PartIssuedVO

getItemNumber() - Method in class bb.common.PartReceivedVO

getItemNumber() - Method in class bb.common.PO2SOExchangeItem

getItemNumber() - Method in class bb.common.PO2SOExchangeItemManufacturer

getItemNumber() - Method in class bb.common.PoMessageItemPK

getItemNumber() - Method in class bb.common.POReceiverItemListResult

getItemNumber() - Method in class bb.common.PurchaseOrderContractResult

getItemNumber() - Method in class bb.common.PurchaseOrderItemManufacturerPK

getItemNumber() - Method in class bb.common.PurchaseWorkSheetItemPK

getItemNumber() - Method in class bb.common.ReceivedToOrderItem

getItemNumber() - Method in class bb.common.ReceiverItemAgent

getItemNumber() - Method in class bb.common.ReceiverItemDetailAgent

getItemNumber() - Method in class bb.common.ReceivingItemResult

getItemNumber() - Method in class bb.common.RefdocElement

getItemNumber() - Method in class bb.common.ReturnMaterialAuthorizationItemManufacturerPK

getItemNumber() - Method in class bb.common.ReturnToVendorItemManufacturerPK

getItemNumber() - Method in class bb.common.RfqMessageItemPK

getItemNumber() - Method in class bb.common.RMAReceiverItemListResult

getItemNumber() - Method in class bb.common.RMAReceiverItemPK

getItemNumber() - Method in class bb.common.SerialNumberItemResult

getItemNumber() - Method in class bb.common.SGBillItemPK

getItemNumber() - Method in class bb.common.SGPartListItemResult

getItemNumber() - Method in class bb.common.ShipperItemAgent

getItemNumber() - Method in class bb.common.ShippingItemResult

getItemNumber() - Method in class bb.common.StockTransactionPOReceiverResult

getItemNumber() - Method in class bb.common.StockTransactionSOShipperResult

getItemNumber() - Method in class bb.common.StockTransactionWOReceiverResult

getItemNumber() - Method in class bb.common.StockTransactionWOShipperResult

getItemNumber() - Method in class bb.common.WCLoadDetailResult

getItemNumber() - Method in class bb.common.WorkInstructionPictureVO

getItemNumber() - Method in class bb.common.WorkOrderItemInWipListResult

getItemNumber() - Method in class bb.common.WorkOrderItemIssuePK

getItemNumber() - Method in class bb.common.WorkOrderItemPartDetailInWipVO

getItemNumber() - Method in class bb.common.WorkOrderWorkSheetItemPK

getItemPrincipal() - Method in class bb.common.OIPrincipalVO

getItemPrivateNotes() - Method in class bb.common.OrderApprovalItemsVO

getItemPrivateNotes() - Method in class bb.common.PfReceiverItemVO

getItemPrivateNotes() - Method in class bb.common.ProformaInvoiceItemVO

getItemPrivateNotes() - Method in class bb.common.PurchaseOrderItemVO

getItemPrivateNotes() - Method in class bb.common.ReturnToVendorItemVO

getItemPrivateNotes() - Method in class bb.common.SwapOrderItemVO

getItemPrivateNotes() - Method in class bb.common.SwapReceiverItemListResult

getItemPrivateNotes() - Method in class bb.common.SwapReceiverItemVO

getItemPrivateNotes() - Method in class bb.common.SwapShipperItemListResult

getItemPrivateNotes() - Method in class bb.common.SwapShipperItemVO

getItemPrivateNotes() - Method in class bb.common.TransferOrderItemListResult

getItemPrivateNotes() - Method in class bb.common.TransferOrderItemVO

getItemPrivateNotes() - Method in class bb.common.TransferReceiverItemListResult

getItemPrivateNotes() - Method in class bb.common.TransferReceiverItemVO

getItemPrivateNotes() - Method in class bb.common.TransferShipperItemListResult

getItemPrivateNotes() - Method in class bb.common.TransferShipperItemVO

getItemQty() - Method in class bb.common.BillItemUsagePathResult

getItemQty() - Method in class bb.common.POStatisticsResult

getItemQty() - Method in class bb.common.SGBillItemVO

getItemReceivePk() - Method in class bb.common.DisassembleWorkOrderItemPartDetailItemResult

getItems() - Method in class bb.common.AccountBalanceResult

getItems() - Method in class bb.common.AccountsChartVO

getItems() - Method in class bb.common.AddProformaReceiverAgent

getItems() - Method in class bb.common.BalanceSheetSideBySideItemResult

getItems() - Method in class bb.common.BillItemUsageResult

getItems() - Method in class bb.common.BillSalesResult

getItems() - Method in class bb.common.BillSalesXResult

getItems() - Method in class bb.common.BillWhereUsedResult

getItems() - Method in class bb.common.BomPickListResult

getItems() - Method in class bb.common.BomWithOEMResult

getItems() - Method in class bb.common.BudgetListResult

getItems() - Method in class bb.common.ClosingStatementItemResult

getItems() - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

getItems() - Method in class bb.common.ExchangeAuditItemResult

getItems() - Method in class bb.common.ImportContractPriceData

getItems() - Method in class bb.common.InspectionReportItemVO

getItems() - Method in class bb.common.InventoryCycleResult

getItems() - Method in class bb.common.LabelTemplateVO

getItems() - Method in class bb.common.OrderApprovalVO

getItems() - Method in class bb.common.PartMaterialBomListResult

getItems() - Method in class bb.common.PartMaterialWhereUsedResult

getItems() - Method in class bb.common.PfReceiverVO

getItems() - Method in class bb.common.PO2SOExchange

getItems() - Method in class bb.common.PoMessageVO

getItems() - Method in class bb.common.ProfitLossStatementItemResult

getItems() - Method in class bb.common.PurchaseOnTimeResult

getItems() - Method in class bb.common.ReceiverAgent

getItems() - Method in class bb.common.RfqMessageVO

getItems() - Method in class bb.common.RMAReceiverVO

getItems() - Method in class bb.common.SalesBomResult

getItems() - Method in class bb.common.SalesOnTimeResult

getItems() - Method in class bb.common.SalesPartListResult

getItems() - Method in class bb.common.SerialNumberResult

getItems() - Method in class bb.common.SGBOMResult

getItems() - Method in class bb.common.SGCartCheckOutResult

getItems() - Method in class bb.common.SGCustRequestForQuoteResult

getItems() - Method in class bb.common.SGCustRequestForQuoteVO

getItems() - Method in class bb.common.SGPartListResult

getItems() - Method in class bb.common.ShipListItemRelatedDocResult

getItems() - Method in class bb.common.ShipperAgent

getItems() - Method in class bb.common.SoPickListResult

getItems() - Method in class bb.common.ToolListVO

getItems() - Method in class bb.common.WarehouseVO

getItems() - Method in class bb.common.WCLoadAgent

getItems() - Method in class bb.common.WoItemPickListResult

getItems() - Method in class bb.common.WorkInstructionSummaryResult

getItems() - Method in class bb.common.WorkOrderItemPartDetailResult

getItems() - Method in class bb.common.WorkOrderItemTimeDetailResult

getItems() - Method in class bb.common.WorkOrderItemWCLoadResult

getItems() - Method in class bb.common.WorkOrderOnTimeResult

getItemStatus() - Method in class bb.common.DisassembleWorkOrderReceivingResult

getItemStatus() - Method in class bb.common.IssuingResult

getItemStatus() - Method in class bb.common.SwapOrderItemListResult

getItemSubTotal() - Method in class bb.common.PoMessageItemVO

getItemSubTotal() - Method in class bb.common.PurchaseOrderItemVO

getItemTotalCount() - Method in class bb.common.InfoByMonthResult

getItemTotalDiscount() - Method in class bb.common.PoMessageItemVO

getItemTotalDiscount() - Method in class bb.common.PurchaseOrderItemVO

getItemTotalTax() - Method in class bb.common.PoMessageItemVO

getItemTotalTax() - Method in class bb.common.PurchaseOrderItemListResult

getItemTotalTax() - Method in class bb.common.PurchaseOrderItemVO

getItemType() - Method in class bb.common.LabelTemplateItemVO

getItran() - Method in class bb.common.AccountsPayableInfoVO

getItran() - Method in class bb.common.AccountsPayableVO

getItran() - Method in class bb.common.OnloanReceiverVO

getItran() - Method in class bb.common.ReceiverInfoVO

getItran() - Method in class bb.common.ReceiverVO

getItran() - Method in class bb.common.RMAReceiverVO

getJj() - Method in class bb.common.VendorQtyPricePK

getJobId() - Method in class bb.common.CustomEmployeeVO

getJobId() - Method in class bb.common.CustomJobCategoryGoodsPK

getJobId() - Method in class bb.common.EmployeeCardVO

getJobId() - Method in class bb.common.EmployeePutGoodListResult

getJobId() - Method in class bb.common.SalesmanVO

getJobName() - Method in class bb.common.EmployeePutGoodListResult

getJobProcessSheetListResultsCount(String) - Method in interface bb.common.box.ManufacturingBox

getJobProcessSheetListResultsCountByLookup(String) - Method in interface bb.common.box.ManufacturingBox

getJobProcessSheetResult(PartPK, boolean, String) - Method in interface bb.common.box.ManufacturingBox

getJobTitle() - Method in class bb.common.CustomEmployeeWorkExperienceVO

getJobTitle() - Method in class bb.common.EmployeeWorkExperienceVO

getJreVersion() - Method in class bb.common.BizboxBugInfoVO

getJreVersion() - Method in class bb.common.BizboxBugVO

getKeeper() - Method in class bb.common.WareHousePartPrefixKeeperVO

getKey() - Method in class bb.common.PartDwgAgent

getKg() - Method in class bb.common.SGWeightUnitVO

getKg() - Method in class bb.common.WeightUnitVO

getKitNumber() - Method in class bb.common.BillItemVO

getKitNumber() - Method in class bb.common.BillItemWithPartInfoResult

getLabelPosition() - Method in class bb.common.LabelTemplateItemVO

getLabelTemplate(int) - Method in interface bb.common.box.WarehouseBox

getLabelType() - Method in class bb.common.LabelTemplateVO

getLanguage() - Method in class bb.common.AccountPayableCheckRunItemVO

getLanguage() - Method in class bb.common.AccountPayableCheckVO

getLanguage() - Method in class bb.common.AccountReceivablePaymentVO

getLanguage() - Method in class bb.common.AccountsReceivableInfoVO

getLanguage() - Method in class bb.common.AccountsReceivableVO

getLanguage() - Method in class bb.common.AllPartDocumentsPK

getLanguage() - Method in class bb.common.ARPaymentRunItemVO

getLanguage() - Method in class bb.common.BB2Document

getLanguage() - Method in class bb.common.BB2Login

getLanguage() - Method in class bb.common.CompanyVO

getLanguage() - Method in class bb.common.CustomerReturnToVendorVO

getLanguage() - Method in class bb.common.CustomerVendorAddressInfoVO

getLanguage() - Method in class bb.common.CustomerVendorAddressVO

getLanguage() - Method in class bb.common.CustomerVendorDescriptionPK

getLanguage() - Method in class bb.common.DisassembleWorkOrderVO

getLanguage() - Method in class bb.common.DocumentInfoAgent

getLanguage() - Method in class bb.common.HelpServerVO

getLanguage() - Method in class bb.common.LogPartDocumentVO

getLanguage() - Method in class bb.common.LogPartDwfVO

getLanguage() - Method in class bb.common.ManufacturerDescriptionPK

getLanguage() - Method in class bb.common.MiscDocAgent

getLanguage() - Method in class bb.common.MultiLanguageAccountsChartPK

getLanguage() - Method in class bb.common.NonConformanceCodeDescriptionPK

getLanguage() - Method in class bb.common.OnloanShipperVO

getLanguage() - Method in class bb.common.OnLoanVO

getLanguage() - Method in class bb.common.PartDocumentPK

getLanguage() - Method in class bb.common.PartDwfAgent

getLanguage() - Method in class bb.common.PartDwfPK

getLanguage() - Method in class bb.common.PartDwfWithPartInfoResult

getLanguage() - Method in class bb.common.PermissionDescriptionPK

getLanguage() - Method in class bb.common.ProformaInvoiceVO

getLanguage() - Method in class bb.common.PurchaseOrderVO

getLanguage() - Method in class bb.common.QuoteVO

getLanguage() - Method in class bb.common.RequestForQuoteVO

getLanguage() - Method in class bb.common.RequestForRMAVO

getLanguage() - Method in class bb.common.ReturnMaterialAuthorizationVO

getLanguage() - Method in class bb.common.ReturnToVendorVO

getLanguage() - Method in class bb.common.RMAReceiverVO

getLanguage() - Method in class bb.common.RoleDescriptionPK

getLanguage() - Method in class bb.common.RtvShipperInfoVO

getLanguage() - Method in class bb.common.RtvShipperVO

getLanguage() - Method in class bb.common.SalesmanVO

getLanguage() - Method in class bb.common.SalesOrderVO

getLanguage() - Method in class bb.common.SgClientProgramUserVO

getLanguage() - Method in class bb.common.SGCustRequestForQuoteListResult

getLanguage() - Method in class bb.common.SGCustRequestForQuoteResult

getLanguage() - Method in class bb.common.SGDocPartPK

getLanguage() - Method in class bb.common.SGDwgPicturePK

getLanguage() - Method in class bb.common.SGPartDocFlagResult

getLanguage() - Method in class bb.common.SGQuoteAddressVO

getLanguage() - Method in class bb.common.ShipperInfoVO

getLanguage() - Method in class bb.common.ShipperVO

getLanguage() - Method in class bb.common.SwapOrderListResult

getLanguage() - Method in class bb.common.SwapOrderVO

getLanguage() - Method in class bb.common.SwapReceiverListResult

getLanguage() - Method in class bb.common.SwapReceiverVO

getLanguage() - Method in class bb.common.SwapShipperListResult

getLanguage() - Method in class bb.common.SwapShipperVO

getLanguage() - Method in class bb.common.TransferOrderListResult

getLanguage() - Method in class bb.common.TransferOrderVO

getLanguage() - Method in class bb.common.TransferReceiverListResult

getLanguage() - Method in class bb.common.TransferReceiverVO

getLanguage() - Method in class bb.common.TransferShipperListResult

getLanguage() - Method in class bb.common.TransferShipperVO

getLanguage() - Method in class bb.common.VendorGroupUserVO

getLanguage() - Method in class bb.common.WorkOrderVO

getLanguage2() - Method in class bb.common.WorkInstructionSequenceVO

getLanguage2() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getLanguage3() - Method in class bb.common.WorkInstructionSequenceVO

getLanguage3() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getLanguageCode() - Method in class bb.common.BizBoxServer

getLanguageCode() - Method in class bb.common.PartDescriptionPK

getLanguageCode() - Method in class bb.common.SubcompanyLoginAgent

getLanIp() - Method in class bb.common.BizboxUserVO

getLanIp() - Method in class bb.common.DocumentInfoAgent

getLanIp() - Method in class bb.common.LogMiscDocumentVO

getLanIp() - Method in class bb.common.LogPartDocumentVO

getLanIp() - Method in class bb.common.LogPartDwfVO

getLanIp() - Method in class bb.common.LogPartDwgVO

getLanIp() - Method in class bb.common.MiscDocAgent

getLanIp() - Method in class bb.common.OperationLogVO

getLanIp() - Method in class bb.common.PartDwfAgent

getLanIp() - Method in class bb.common.PartDwgAgent

getLast12MonthOntimeDeliveryRate(String, String, int, int) - Method in interface bb.common.box.PurchasingBox

getLast12MonthOntimeDeliveryRate(String, String, int, int, String, String, String, String) - Method in interface bb.common.box.SalesBox

getLast12MonthOntimeDeliveryRate(String, int, int) - Method in interface bb.common.box.WorkOrderBox

getLastAdjustment() - Method in class bb.common.InventoryAdjustmentDetailResult

getLastBy() - Method in class bb.common.WorkFlowVO

getLastCahgeDate() - Method in class bb.common.ShipListInfoVO

getLastCahgeDate() - Method in class bb.common.ShipListVO

getLastChangeBy() - Method in class bb.common.SubcompanyVO

getLastChangeDate() - Method in class bb.common.AccountingConfigurationVO

getLastChangeDate() - Method in class bb.common.AccountingInfoDocumentVO

getLastChangeDate() - Method in class bb.common.AccountingSettingsVO

getLastChangeDate() - Method in class bb.common.AccountPayableCheckRunItemVO

getLastChangeDate() - Method in class bb.common.AccountPayableCheckVO

getLastChangeDate() - Method in class bb.common.AccountReceivablePaymentVO

getLastChangeDate() - Method in class bb.common.AccountsChartMappingVO

getLastChangeDate() - Method in class bb.common.AccountsChartVO

getLastChangeDate() - Method in class bb.common.AccountsPayableInfoVO

getLastChangeDate() - Method in class bb.common.AccountsPayableVO

getLastChangeDate() - Method in class bb.common.AccountsReceivableInfoVO

getLastChangeDate() - Method in class bb.common.AccountsReceivableVO

getLastChangeDate() - Method in class bb.common.AddressQualityDocumentsVO

getLastChangeDate() - Method in class bb.common.AllPartDocumentsVO

getLastChangeDate() - Method in class bb.common.ApPrepayVO

getLastChangeDate() - Method in class bb.common.ARPaymentRunItemVO

getLastChangeDate() - Method in class bb.common.ArPrepayVO

getLastChangeDate() - Method in class bb.common.AssetTypeVO

getLastChangeDate() - Method in class bb.common.AssetVO

getLastChangeDate() - Method in class bb.common.BillSalesCostResult

getLastChangeDate() - Method in class bb.common.BillVO

getLastChangeDate() - Method in class bb.common.BillWithPartInfoResult

getLastChangeDate() - Method in class bb.common.CommonPrintTemplateVO

getLastChangeDate() - Method in class bb.common.CompanyUnitAccountVO

getLastChangeDate() - Method in class bb.common.CompanyUnitVO

getLastChangeDate() - Method in class bb.common.CompanyVO

getLastChangeDate() - Method in class bb.common.ContractPriceVO

getLastChangeDate() - Method in class bb.common.CorrectiveActionRequestVO

getLastChangeDate() - Method in class bb.common.CustomAssetVO

getLastChangeDate() - Method in class bb.common.CustomEmployeeVO

getLastChangeDate() - Method in class bb.common.CustomerFeedbackVO

getLastChangeDate() - Method in class bb.common.CustomerReturnToVendorVO

getLastChangeDate() - Method in class bb.common.CustomerServiceIncidentVO

getLastChangeDate() - Method in class bb.common.CustomerVendorAddressInfoVO

getLastChangeDate() - Method in class bb.common.CustomerVendorAddressVO

getLastChangeDate() - Method in class bb.common.CycleCountStatusVO

getLastChangeDate() - Method in class bb.common.DesignControlDocumentVO

getLastChangeDate() - Method in class bb.common.DesignControlInfoVO

getLastChangeDate() - Method in class bb.common.DesignControlVO

getLastChangeDate() - Method in class bb.common.DisassembleWorkOrderDocumentVO

getLastChangeDate() - Method in class bb.common.DisassembleWorkOrderIssueVO

getLastChangeDate() - Method in class bb.common.DisassembleWorkOrderVO

getLastChangeDate() - Method in class bb.common.EmployeeCardVO

getLastChangeDate() - Method in class bb.common.EngineeringChangeDocumentVO

getLastChangeDate() - Method in class bb.common.EngineeringChangeRequestDocumentVO

getLastChangeDate() - Method in class bb.common.EngineeringChangeRequestVO

getLastChangeDate() - Method in class bb.common.EngineeringChangeVO

getLastChangeDate() - Method in class bb.common.EngineeringSharingVO

getLastChangeDate() - Method in class bb.common.ExpenseVO

getLastChangeDate() - Method in class bb.common.GeneralLedgerListResult

getLastChangeDate() - Method in class bb.common.GeneralLedgerSettingsVO

getLastChangeDate() - Method in class bb.common.GeneralLedgerVO

getLastChangeDate() - Method in class bb.common.InspectionConformanceReportVO

getLastChangeDate() - Method in class bb.common.InspectionReportInfoVO

getLastChangeDate() - Method in class bb.common.InspectionReportVO

getLastChangeDate() - Method in class bb.common.InventoryAdjustmentVO

getLastChangeDate() - Method in class bb.common.LabelTemplateVO

getLastChangeDate() - Method in class bb.common.LogInventoryVO

getLastchangeDate() - Method in class bb.common.LogMiscDocumentVO

getLastChangeDate() - Method in class bb.common.LogPartDocumentVO

getLastChangeDate() - Method in class bb.common.LogPartDwfVO

getLastChangeDate() - Method in class bb.common.LogPartDwgVO

getLastChangeDate() - Method in class bb.common.LogTrackingVO

getLastChangeDate() - Method in class bb.common.ManufacturerAddressInfoVO

getLastChangeDate() - Method in class bb.common.ManufacturerAddressVO

getLastChangeDate() - Method in class bb.common.MyPrintListVO

getLastChangeDate() - Method in class bb.common.NcrNeedToScrapListResult

getLastChangeDate() - Method in class bb.common.NonConformanceCodeVO

getLastChangeDate() - Method in class bb.common.NonConformanceReportVO

getLastChangeDate() - Method in class bb.common.NonproductivePickingVO

getLastChangeDate() - Method in class bb.common.OnloanDocumentVO

getLastChangeDate() - Method in class bb.common.OnloanReceiverVO

getLastChangedate() - Method in class bb.common.OnloanShipperVO

getLastChangeDate() - Method in class bb.common.OnLoanVO

getLastChangeDate() - Method in class bb.common.OperatingInstructionsVO

getLastChangeDate() - Method in class bb.common.OrderBoilerplateVO

getLastChangeDate() - Method in class bb.common.OrderDocumentVO

getLastChangeDate() - Method in class bb.common.PartBasicInfo

getLastChangeDate() - Method in class bb.common.PartCertificateVO

getLastChangeDate() - Method in class bb.common.PartDocumentVO

getLastChangeDate() - Method in class bb.common.PartDwfVO

getLastChangeDate() - Method in class bb.common.PartDwfWithPartInfoResult

getLastChangeDate() - Method in class bb.common.PartDwgVO

getLastChangeDate() - Method in class bb.common.PartDwgWithPartInfoResult

getLastChangeDate() - Method in class bb.common.PartPictureVO

getLastChangeDate() - Method in class bb.common.PartTrackingVO

getLastChangeDate() - Method in class bb.common.PartVO

getLastChangeDate() - Method in class bb.common.PartWithOnhandsVO

getLastChangeDate() - Method in class bb.common.PaymentHistoryVO

getLastChangeDate() - Method in class bb.common.PfReceiverVO

getLastChangeDate() - Method in class bb.common.PhysicalInventoryStatusVO

getLastChangeDate() - Method in class bb.common.PointOfSaleVO

getLastChangeDate() - Method in class bb.common.PosRefdocVO

getLastChangeDate() - Method in class bb.common.POSurveyReportVO

getLastChangeDate() - Method in class bb.common.PreventiveActionRequestVO

getLastChangeDate() - Method in class bb.common.PrintLogoVO

getLastChangeDate() - Method in class bb.common.PrintTemplateVO

getLastChangeDate() - Method in class bb.common.ProformaInvoiceVO

getLastChangeDate() - Method in class bb.common.PurchaseOrderDocumentVO

getLastChangeDate() - Method in class bb.common.PurchaseOrderVO

getLastChangeDate() - Method in class bb.common.PurchaseWorkSheetItemVO

getLastChangeDate() - Method in class bb.common.QuoteDocumentVO

getLastChangeDate() - Method in class bb.common.QuoteVO

getLastChangeDate() - Method in class bb.common.ReceiverInfoVO

getLastChangeDate() - Method in class bb.common.ReceiverVO

getLastChangeDate() - Method in class bb.common.RefdocVO

getLastChangeDate() - Method in class bb.common.RequestForQuoteVO

getLastChangeDate() - Method in class bb.common.RequestForRMAVO

getLastChangeDate() - Method in class bb.common.ReturnMaterialAuthorizationDocumentVO

getLastChangeDate() - Method in class bb.common.ReturnMaterialAuthorizationVO

getLastChangeDate() - Method in class bb.common.ReturnToVendorVO

getLastChangeDate() - Method in class bb.common.RMAReceiverVO

getLastChangeDate() - Method in class bb.common.RtvShipperInfoVO

getLastChangeDate() - Method in class bb.common.RtvShipperVO

getLastChangeDate() - Method in class bb.common.SalesCodeVO

getLastChangeDate() - Method in class bb.common.SalesmanVO

getLastChangeDate() - Method in class bb.common.SalesOrderDocumentVO

getLastChangeDate() - Method in class bb.common.SalesOrderVO

getLastChangeDate() - Method in class bb.common.ScrapReportVO

getLastChangeDate() - Method in class bb.common.SerialNumberVO

getLastChangeDate() - Method in class bb.common.ServerClientPropertyVO

getLastChangeDate() - Method in class bb.common.SGCompanyVO

getLastChangeDate() - Method in class bb.common.SGCustomerServiceRequestVO

getLastChangeDate() - Method in class bb.common.SGCustRequestForQuoteVO

getLastChangeDate() - Method in class bb.common.SGDocPartVO

getLastChangeDate() - Method in class bb.common.SGDwgPictureVO

getLastChangeDate() - Method in class bb.common.SGLogLoginVO

getLastChangeDate() - Method in class bb.common.SGPictureVO

getLastChangeDate() - Method in class bb.common.SGQuoteCartVO

getLastChangeDate() - Method in class bb.common.SGQuoteLoginVO

getLastChangeDate() - Method in class bb.common.ShipListOwnerVO

getLastChangedate() - Method in class bb.common.ShipperInfoVO

getLastChangedate() - Method in class bb.common.ShipperVO

getLastChangeDate() - Method in class bb.common.SubcompanyVO

getLastChangeDate() - Method in class bb.common.SwapOrderListResult

getLastChangeDate() - Method in class bb.common.SwapOrderVO

getLastChangeDate() - Method in class bb.common.SwapReceiverListResult

getLastChangeDate() - Method in class bb.common.SwapReceiverVO

getLastChangeDate() - Method in class bb.common.SwapShipperListResult

getLastChangeDate() - Method in class bb.common.SwapShipperVO

getLastChangeDate() - Method in class bb.common.TempArApAgingVO

getLastChangeDate() - Method in class bb.common.TermsConditionVO

getLastChangeDate() - Method in class bb.common.ToolListInfoVO

getLastChangeDate() - Method in class bb.common.ToolListVO

getLastChangeDate() - Method in class bb.common.ToolListWithToolInfoResult

getLastChangeDate() - Method in class bb.common.ToolVO

getLastChangeDate() - Method in class bb.common.ToolWithOnhandsVO

getLastChangeDate() - Method in class bb.common.TransferOrderListResult

getLastChangeDate() - Method in class bb.common.TransferOrderVO

getLastChangeDate() - Method in class bb.common.TransferReceiverListResult

getLastChangeDate() - Method in class bb.common.TransferReceiverVO

getLastChangeDate() - Method in class bb.common.TransferShipperListResult

getLastChangeDate() - Method in class bb.common.TransferShipperVO

getLastChangeDate() - Method in class bb.common.VendorContractPriceVO

getLastChangeDate() - Method in class bb.common.WarehouseVO

getLastChangeDate() - Method in class bb.common.WorkCenterVO

getLastChangeDate() - Method in class bb.common.WorkFlowVO

getLastChangeDate() - Method in class bb.common.WorkInstructionDocumentVO

getLastChangeDate() - Method in class bb.common.WorkInstructionRequestForChangeVO

getLastChangeDate() - Method in class bb.common.WorkInstructionVO

getLastChangeDate() - Method in class bb.common.WorkOrderDocumentVO

getLastChangeDate() - Method in class bb.common.WorkOrderItemPartDetailInWipVO

getLastChangeDate() - Method in class bb.common.WorkOrderItemTimeDetailVO

getLastChangeDate() - Method in class bb.common.WorkOrderReceiverVO

getLastChangeDate() - Method in class bb.common.WorkOrderVO

getLastChangeDate() - Method in class bb.common.WorkOrderWorkInstructionVO

getLastChangeDate() - Method in class bb.common.WorkOrderWorkSheetItemVO

getLastChangePassword() - Method in class bb.common.BizboxUserVO

getLastChangeTime() - Method in class bb.common.BillLogVO

getLastChangeTime() - Method in class bb.common.OnloanShipperVO

getLastChangeTime() - Method in class bb.common.PosRefdocVO

getLastChangeTime() - Method in class bb.common.RefdocVO

getLastChangeTime() - Method in class bb.common.SGCompanyVO

getLastChangeTime() - Method in class bb.common.SGLogLoginVO

getLastChangeTime() - Method in class bb.common.ShipperVO

getLastChangeTime() - Method in class bb.common.TransferReceiverListResult

getLastChangeTime() - Method in class bb.common.TransferReceiverVO

getLastChangeTime() - Method in class bb.common.TransferShipperListResult

getLastChangeTime() - Method in class bb.common.TransferShipperVO

getLastChangeTimes() - Method in class bb.common.AccountsChartVO

getLastChangeTimes() - Method in class bb.common.AssetDepreciateVO

getLastChangeTimes() - Method in class bb.common.AssetTypeVO

getLastChangeTimes() - Method in class bb.common.AssetVO

getLastChangeTimes() - Method in class bb.common.CompanyUnitVO

getLastChangeTimes() - Method in class bb.common.CompanyVO

getLastChangeTimes() - Method in class bb.common.ContractPriceVO

getLastChangeTimes() - Method in class bb.common.CustomerVendorAddressInfoVO

getLastChangeTimes() - Method in class bb.common.DesignControlInfoVO

getLastChangeTimes() - Method in class bb.common.DisassembleWorkOrderVO

getLastChangeTimes() - Method in class bb.common.GeneralLedgerListResult

getLastChangeTimes() - Method in class bb.common.GeneralLedgerVO

getLastChangeTimes() - Method in class bb.common.MakeAccountPayableAgent

getLastChangeTimes() - Method in class bb.common.MakeBillAndHoldInvoiceAgent

getLastChangeTimes() - Method in class bb.common.MakeCreditMemoAgent

getLastChangeTimes() - Method in class bb.common.MakeInvoiceAgent

getLastChangeTimes() - Method in class bb.common.ManufacturerAddressInfoVO

getLastChangeTimes() - Method in class bb.common.OnloanReceiverVO

getLastChangeTimes() - Method in class bb.common.PfReceiverVO

getLastChangeTimes() - Method in class bb.common.PointOfSaleVO

getLastChangeTimes() - Method in class bb.common.POSurveyReportVO

getLastChangeTimes() - Method in class bb.common.ProformaInvoiceVO

getLastChangeTimes() - Method in class bb.common.PurchaseOrderVO

getLastChangeTimes() - Method in class bb.common.ReceiverInfoVO

getLastChangeTimes() - Method in class bb.common.ReceiverVO

getLastChangeTimes() - Method in class bb.common.RequestForQuoteVO

getLastChangeTimes() - Method in class bb.common.ReturnToVendorVO

getLastChangeTimes() - Method in class bb.common.SalesCodeVO

getLastChangeTimes() - Method in class bb.common.SalesmanVO

getLastChangeTimes() - Method in class bb.common.ScrapReportVO

getLastChangeTimes() - Method in class bb.common.ShipListInfoVO

getLastChangeTimes() - Method in class bb.common.VendorContractPriceVO

getLastChangeTimes() - Method in class bb.common.WarehouseVO

getLastChangeTimes() - Method in class bb.common.WorkInstructionRequestForChangeVO

getLastChangeTimes() - Method in class bb.common.WorkOrderVO

getLastChangeUser() - Method in class bb.common.AccountingConfigurationVO

getLastChangeUser() - Method in class bb.common.AccountingSettingsVO

getLastChangeUser() - Method in class bb.common.AccountPayableCheckRunItemVO

getLastChangeUser() - Method in class bb.common.AccountPayableCheckVO

getLastChangeUser() - Method in class bb.common.AccountReceivablePaymentVO

getLastChangeUser() - Method in class bb.common.AccountsChartMappingVO

getLastChangeUser() - Method in class bb.common.AccountsChartVO

getLastChangeUser() - Method in class bb.common.AccountsPayableInfoVO

getLastChangeUser() - Method in class bb.common.AccountsPayableVO

getLastChangeUser() - Method in class bb.common.AccountsReceivableInfoVO

getLastChangeUser() - Method in class bb.common.AccountsReceivableVO

getLastChangeUser() - Method in class bb.common.AddressQualityDocumentsVO

getLastChangeUser() - Method in class bb.common.AllPartDocumentsVO

getLastChangeUser() - Method in class bb.common.ApPrepayVO

getLastChangeUser() - Method in class bb.common.ARPaymentRunItemVO

getLastChangeUser() - Method in class bb.common.ArPrepayVO

getLastChangeUser() - Method in class bb.common.AssetTypeVO

getLastChangeUser() - Method in class bb.common.AssetVO

getLastChangeUser() - Method in class bb.common.BillLogVO

getLastChangeUser() - Method in class bb.common.BillSalesCostResult

getLastChangeUser() - Method in class bb.common.BillVO

getLastChangeUser() - Method in class bb.common.BillWithPartInfoResult

getLastChangeUser() - Method in class bb.common.CommonPrintTemplateVO

getLastChangeUser() - Method in class bb.common.CompanyUnitAccountVO

getLastChangeUser() - Method in class bb.common.CompanyUnitVO

getLastChangeUser() - Method in class bb.common.CompanyVO

getLastChangeUser() - Method in class bb.common.ContractPriceVO

getLastChangeUser() - Method in class bb.common.CorrectiveActionRequestVO

getLastChangeUser() - Method in class bb.common.CustomAssetVO

getLastChangeUser() - Method in class bb.common.CustomEmployeeVO

getLastChangeUser() - Method in class bb.common.CustomerFeedbackVO

getLastChangeUser() - Method in class bb.common.CustomerReturnToVendorVO

getLastChangeUser() - Method in class bb.common.CustomerServiceIncidentVO

getLastChangeUser() - Method in class bb.common.CycleCountStatusVO

getLastChangeUser() - Method in class bb.common.DesignControlDocumentVO

getLastChangeUser() - Method in class bb.common.DesignControlInfoVO

getLastChangeUser() - Method in class bb.common.DesignControlVO

getLastChangeUser() - Method in class bb.common.DisassembleWorkOrderDocumentVO

getLastChangeUser() - Method in class bb.common.DisassembleWorkOrderIssueVO

getLastChangeUser() - Method in class bb.common.DisassembleWorkOrderVO

getLastChangeUser() - Method in class bb.common.DWOIssueDetail

getLastChangeUser() - Method in class bb.common.EmployeeCardVO

getLastChangeUser() - Method in class bb.common.EngineeringChangeDocumentVO

getLastChangeUser() - Method in class bb.common.EngineeringChangeRequestDocumentVO

getLastChangeUser() - Method in class bb.common.EngineeringSharingVO

getLastChangeUser() - Method in class bb.common.ExpenseVO

getLastChangeUser() - Method in class bb.common.GeneralLedgerListResult

getLastChangeUser() - Method in class bb.common.GeneralLedgerSettingsVO

getLastChangeUser() - Method in class bb.common.GeneralLedgerVO

getLastChangeUser() - Method in class bb.common.InspectionConformanceReportItemInfo

getLastChangeUser() - Method in class bb.common.InspectionConformanceReportVO

getLastChangeUser() - Method in class bb.common.InspectionReportInfoVO

getLastChangeUser() - Method in class bb.common.InspectionReportVO

getLastChangeUser() - Method in class bb.common.InventoryAdjustmentVO

getLastChangeUser() - Method in class bb.common.LabelTemplateVO

getLastChangeUser() - Method in class bb.common.LogInventoryVO

getLastChangeUser() - Method in class bb.common.LogMiscDocumentVO

getLastChangeUser() - Method in class bb.common.LogPartDocumentVO

getLastChangeUser() - Method in class bb.common.LogPartDwfVO

getLastChangeUser() - Method in class bb.common.LogPartDwgVO

getLastChangeUser() - Method in class bb.common.LogTrackingVO

getLastChangeUser() - Method in class bb.common.ManufacturerAddressInfoVO

getLastChangeUser() - Method in class bb.common.ManufacturerAddressVO

getLastChangeUser() - Method in class bb.common.NcrNeedToScrapListResult

getLastChangeUser() - Method in class bb.common.NonConformanceCodeVO

getLastChangeUser() - Method in class bb.common.NonConformanceReportVO

getLastChangeUser() - Method in class bb.common.OnloanDocumentVO

getLastChangeUser() - Method in class bb.common.OnloanReceiverVO

getLastChangeUser() - Method in class bb.common.OnloanShipperVO

getLastChangeUser() - Method in class bb.common.OnLoanVO

getLastChangeUser() - Method in class bb.common.OperatingInstructionsVO

getLastChangeUser() - Method in class bb.common.OrderDocumentVO

getLastChangeUser() - Method in class bb.common.PartCertificateVO

getLastChangeUser() - Method in class bb.common.PartDocumentVO

getLastChangeUser() - Method in class bb.common.PartDwfVO

getLastChangeUser() - Method in class bb.common.PartDwfWithPartInfoResult

getLastChangeUser() - Method in class bb.common.PartDwgVO

getLastChangeUser() - Method in class bb.common.PartDwgWithPartInfoResult

getLastChangeUser() - Method in class bb.common.PartPictureVO

getLastChangeUser() - Method in class bb.common.PfReceiverVO

getLastChangeUser() - Method in class bb.common.PhysicalInventoryStatusVO

getLastChangeUser() - Method in class bb.common.PointOfSaleVO

getLastChangeUser() - Method in class bb.common.PosRefdocVO

getLastChangeUser() - Method in class bb.common.POSurveyReportVO

getLastChangeUser() - Method in class bb.common.PreventiveActionRequestVO

getLastChangeUser() - Method in class bb.common.PrintTemplateVO

getLastChangeUser() - Method in class bb.common.ProformaInvoiceVO

getLastChangeUser() - Method in class bb.common.PurchaseOrderDocumentVO

getLastChangeUser() - Method in class bb.common.PurchaseOrderVO

getLastChangeUser() - Method in class bb.common.PurchaseWorkSheetItemVO

getLastChangeUser() - Method in class bb.common.ReceiverInfoVO

getLastChangeUser() - Method in class bb.common.ReceiverVO

getLastChangeUser() - Method in class bb.common.RefdocVO

getLastChangeUser() - Method in class bb.common.RequestForQuoteVO

getLastChangeUser() - Method in class bb.common.RequestForRMAVO

getLastChangeUser() - Method in class bb.common.ReturnMaterialAuthorizationVO

getLastChangeUser() - Method in class bb.common.ReturnToVendorVO

getLastChangeUser() - Method in class bb.common.RMAReceiverVO

getLastChangeUser() - Method in class bb.common.RtvShipperInfoVO

getLastChangeUser() - Method in class bb.common.RtvShipperVO

getLastChangeUser() - Method in class bb.common.SalesCodeVO

getLastChangeUser() - Method in class bb.common.SalesmanVO

getLastChangeUser() - Method in class bb.common.SalesOrderDocumentVO

getLastChangeUser() - Method in class bb.common.ScrapReportVO

getLastChangeUser() - Method in class bb.common.SerialNumberVO

getLastChangeUser() - Method in class bb.common.ServerClientPropertyVO

getLastChangeUser() - Method in class bb.common.SGCustomerServiceRequestVO

getLastChangeUser() - Method in class bb.common.ShipListOwnerVO

getLastChangeUser() - Method in class bb.common.ShipperInfoVO

getLastChangeUser() - Method in class bb.common.ShipperVO

getLastChangeUser() - Method in class bb.common.SwapOrderListResult

getLastChangeUser() - Method in class bb.common.SwapOrderVO

getLastChangeUser() - Method in class bb.common.SwapReceiverListResult

getLastChangeUser() - Method in class bb.common.SwapReceiverVO

getLastChangeUser() - Method in class bb.common.SwapShipperListResult

getLastChangeUser() - Method in class bb.common.SwapShipperVO

getLastChangeUser() - Method in class bb.common.ToolListInfoVO

getLastChangeUser() - Method in class bb.common.ToolListVO

getLastChangeUser() - Method in class bb.common.ToolListWithToolInfoResult

getLastChangeUser() - Method in class bb.common.VendorContractPriceVO

getLastChangeUser() - Method in class bb.common.WarehouseVO

getLastChangeUser() - Method in class bb.common.WOReceiverDetail

getLastChangeUser() - Method in class bb.common.WorkCenterVO

getLastChangeUser() - Method in class bb.common.WorkInstructionDocumentVO

getLastChangeUser() - Method in class bb.common.WorkInstructionPictureVO

getLastChangeUser() - Method in class bb.common.WorkInstructionRequestForChangeVO

getLastChangeUser() - Method in class bb.common.WorkInstructionVO

getLastChangeUser() - Method in class bb.common.WorkOrderDocumentVO

getLastChangeUser() - Method in class bb.common.WorkOrderItemPartDetailInWipVO

getLastChangeUser() - Method in class bb.common.WorkOrderItemTimeDetailVO

getLastChangeUser() - Method in class bb.common.WorkOrderReceiverVO

getLastChangeUser() - Method in class bb.common.WorkOrderVO

getLastChangeUser() - Method in class bb.common.WorkOrderWorkInstructionVO

getLastChangeUser() - Method in class bb.common.WorkOrderWorkSheetItemVO

getLastCount() - Method in class bb.common.PartInventoryVO

getLastCycleCount() - Method in class bb.common.PartClassVO

getLastDate() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

getLastDate() - Method in class bb.common.WoItemPickListItemResult

getLastDate() - Method in class bb.common.WorkOrderItemIssueVO

getLastDate() - Method in class bb.common.WorkOrderItemPartDetail

getLastFiscalYearInvoiceAccount() - Method in class bb.common.SalesInfoCenterResult

getLastFiscalYearSalesAccount() - Method in class bb.common.SalesInfoCenterResult

getLastInDate() - Method in class bb.common.HistoricalInventoryVO

getLastInDate() - Method in class bb.common.InventoryListResult

getLastInDate() - Method in class bb.common.InventoryNotUsedInMonthsResult

getLastInDate() - Method in class bb.common.PartInventoryVO

getLastInspection() - Method in class bb.common.ToolCalibrationVO

getLastInventory() - Method in class bb.common.CompanyVO

getLastInvoiceNumber() - Method in class bb.common.SalesOrderItemListResult

getLastLogin() - Method in class bb.common.BizboxUserListResult

getLastLogin() - Method in class bb.common.BizboxUserVO

getLastLogout() - Method in class bb.common.BizboxUserListResult

getLastLogout() - Method in class bb.common.BizboxUserVO

getLastMaintenanceDate() - Method in class bb.common.EquipmentListResult

getLastMaintenanceDate() - Method in class bb.common.EquipmentVO

getLastMonth() - Method in class bb.common.SalesInfoCenter.DueSoCount

getLastMonth() - Method in class bb.common.SalesInfoCenter.DueSoSum

getLastMonth() - Method in class bb.common.SalesInfoCenter.GrossMargin

getLastMonth() - Method in class bb.common.SalesInfoCenter.InvoicedSum

getLastMonth() - Method in class bb.common.SalesInfoCenter.OpenSoSum

getLastMonth() - Method in class bb.common.SalesInfoCenter.SoCount

getLastMonth() - Method in class bb.common.SalesInfoCenter.SoCountWithPartsOnhold

getLastMonth() - Method in class bb.common.SalesInfoCenter.SoItemCount

getLastMonth() - Method in class bb.common.SalesInfoCenter.SoTotalSum

getLastMonthInvoiceAccount() - Method in class bb.common.SalesInfoCenterResult

getLastMonthInvoiceGrossMargin() - Method in class bb.common.SalesInfoCenterResult

getLastMonthPoAddedCount() - Method in class bb.common.PurchasingInfoCenterResult

getLastMonthPoiAddedCount() - Method in class bb.common.PurchasingInfoCenterResult

getLastMonthPurchaseAccount() - Method in class bb.common.PurchasingInfoCenterResult

getLastMonthReceiverAccount() - Method in class bb.common.PurchasingInfoCenterResult

getLastMonthReceiverCount() - Method in class bb.common.PurchasingInfoCenterResult

getLastMonthReceiverItemCount() - Method in class bb.common.PurchasingInfoCenterResult

getLastMonthRejectQty() - Method in class bb.common.QualityInfoCenterResult

getLastMonthSalesItemCount() - Method in class bb.common.SalesInfoCenterResult

getLastMonthSalesOrderAccount() - Method in class bb.common.SalesInfoCenterResult

getLastMonthSalesOrderCount() - Method in class bb.common.SalesInfoCenterResult

getLastMonthYearByDate(Date, Date) - Method in interface bb.common.box.AccountingBox

getLastMonthYearMonth(String) - Static method in class bb.common.YearMonthManager

getLastName() - Method in class bb.common.BizBoxUserEmployeeResult

getLastName() - Method in class bb.common.CashierVO

getLastName() - Method in class bb.common.EmployeeCardVO

getLastName() - Method in class bb.common.EmployeeEducationResult

getLastName() - Method in class bb.common.GroupUserVO

getLastName() - Method in class bb.common.NoticeUserEmployeeListResult

getLastName() - Method in class bb.common.SalesmanVO

getLastOutDate() - Method in class bb.common.HistoricalInventoryVO

getLastOutDate() - Method in class bb.common.InventoryListResult

getLastOutDate() - Method in class bb.common.InventoryNotUsedInMonthsResult

getLastOutDate() - Method in class bb.common.PartInventoryVO

getLastOutDate() - Method in class bb.common.PartOnhandCostVO

getLastOutDate() - Method in class bb.common.PartOnhandResult

getLastPurchaseCost() - Method in class bb.common.PartInventoryVO

getLastPurchaseCost() - Method in class bb.common.PartVendorVO

getLastPurchaseCost() - Method in class bb.common.ToolInventoryVO

getLastPurchaseCost() - Method in class bb.common.ToolVendorVO

getLastPurchaseOrderItemNumber() - Method in class bb.common.PartInventoryVO

getLastPurchaseOrderItemNumber() - Method in class bb.common.PartVendorVO

getLastPurchaseOrderItemNumber() - Method in class bb.common.ToolInventoryVO

getLastPurchaseOrderItemNumber() - Method in class bb.common.ToolVendorVO

getLastPurchaseOrderNumber() - Method in class bb.common.PartInventoryVO

getLastPurchaseOrderNumber() - Method in class bb.common.PartVendorVO

getLastPurchaseOrderNumber() - Method in class bb.common.ToolInventoryVO

getLastPurchaseOrderNumber() - Method in class bb.common.ToolVendorVO

getLastPurchaseOrderNumberAndItemNumber() - Method in class bb.common.PartCostVarianceListResult

getLastPurchaseOrderVendorID() - Method in class bb.common.PartCostVarianceListResult

getLastPurchaseOrderVendorName() - Method in class bb.common.PartCostVarianceListResult

getLastPurchasePrice() - Method in class bb.common.PartCostVarianceListResult

getLastReceiveDate() - Method in class bb.common.PurchaseOrderItemListResult

getLastShippedDate() - Method in class bb.common.SalesOrderItemListResult

getLastSOPrice() - Method in class bb.common.RunningAccountOrderItemVO

getLastSyncDate() - Method in class bb.common.SubcompanyVO

getLastTwevMonthsTotalSalesGrossMargin() - Method in class bb.common.SalesInfoCenterResult

getLastUsedDate() - Method in class bb.common.InventoryNotUsedInMonthsResult

getLastUser() - Method in class bb.common.AccountingInfoDocumentVO

getLastUser() - Method in class bb.common.CustomerVendorAddressInfoVO

getLastUser() - Method in class bb.common.CustomerVendorAddressVO

getLastUser() - Method in class bb.common.EngineeringChangeRequestVO

getLastUser() - Method in class bb.common.EngineeringChangeVO

getLastUser() - Method in class bb.common.NonproductivePickingVO

getLastUser() - Method in class bb.common.PartBasicInfo

getLastUser() - Method in class bb.common.PartVO

getLastUser() - Method in class bb.common.PartWithOnhandsVO

getLastUser() - Method in class bb.common.QuoteDocumentVO

getLastUser() - Method in class bb.common.QuoteVO

getLastUser() - Method in class bb.common.ReturnMaterialAuthorizationDocumentVO

getLastUser() - Method in class bb.common.SalesOrderVO

getLastUser() - Method in class bb.common.ShipListInfoVO

getLastUser() - Method in class bb.common.ShipListVO

getLastUser() - Method in class bb.common.ToolVO

getLastUser() - Method in class bb.common.ToolWithOnhandsVO

getLastUser() - Method in class bb.common.TransferOrderListResult

getLastUser() - Method in class bb.common.TransferOrderVO

getLastUser() - Method in class bb.common.TransferReceiverListResult

getLastUser() - Method in class bb.common.TransferReceiverVO

getLastUser() - Method in class bb.common.TransferShipperListResult

getLastUser() - Method in class bb.common.TransferShipperVO

getLastUserName() - Method in class bb.common.SGCompanyVO

getLastUserName() - Method in class bb.common.SGCustRequestForQuoteVO

getLastUserName() - Method in class bb.common.SGDocPartVO

getLastUserName() - Method in class bb.common.SGDwgPictureVO

getLastUserName() - Method in class bb.common.SGPictureVO

getLastYeardepreciatedAccm() - Method in class bb.common.AssetDepreciateVO

getLastYearDepreciationAccm() - Method in class bb.common.AssetDepreciateDetailReport

getLastYearEndDateByYearMonth(String) - Static method in class bb.common.YearMonthManager

getLateItemPk() - Method in class bb.common.MrpItemResult

getLatestReceiverDate() - Method in class bb.common.POStatisticsResult

getLatestShipDate() - Method in class bb.common.POStatisticsResult

getLbs() - Method in class bb.common.SGWeightUnitVO

getLbs() - Method in class bb.common.WeightUnitVO

getLdate() - Method in class bb.common.WorkInstructionPictureVO

getLeadtime() - Method in class bb.common.BB2PartInfo

getLeadTime() - Method in class bb.common.PartBasicInfo

getLeadTime() - Method in class bb.common.PartInventoryVO

getLeadTime() - Method in class bb.common.PurchaseOrderItemVO

getLeadTime() - Method in class bb.common.RequestForQuoteItemVO

getLeadTime() - Method in class bb.common.RfqMessageItemVO

getLeadTime() - Method in class bb.common.ToolInventoryVO

getLeadTime() - Method in class bb.common.WorkOrderItemVO

getLeadTimeFrom() - Method in class bb.common.MrpReportAgent

getLeadTimeTo() - Method in class bb.common.MrpReportAgent

getLendTime() - Method in class bb.common.StockTransactionPartInfoResult

getLength() - Method in class bb.common.BizboxBugChangesInfoVO

getLength() - Method in class bb.common.BizboxBugInfoVO

getLength() - Method in class bb.common.PartMaterialListResult

getLength() - Method in class bb.common.PartMaterialReportAgent

getLength() - Method in class bb.common.PartMaterialVO

getLength() - Method in class bb.common.PartMaterialWhereUsedItemResult

getLength() - Method in class bb.common.PrintLogoVO

getLength() - Method in class bb.common.SerialNumberItemResult

getLength() - Method in class bb.common.SerialNumberResult

getLength() - Method in class bb.common.TermsConditionVO

getLengthOperator() - Method in class bb.common.PartMaterialReportAgent

getLengthUnit() - Method in class bb.common.PartMaterialListResult

getLengthUnit() - Method in class bb.common.PartMaterialReportAgent

getLengthUnit() - Method in class bb.common.PartMaterialVO

getLengthUnit() - Method in class bb.common.PartMaterialWhereUsedItemResult

getLessDepreciation() - Method in class bb.common.ClosingStatementResult

getLevel() - Method in class bb.common.AccountBalanceResult

getLevel() - Method in class bb.common.AccountsChartVO

getLevel() - Method in class bb.common.BalanceSheetSideBySideItemResult

getLevel() - Method in class bb.common.BudgetListResult

getLevel() - Method in class bb.common.ClosingStatementItemResult

getLevel() - Method in class bb.common.CompanyUnitVO

getLevel() - Method in class bb.common.ExchangeAuditItemResult

getLevel() - Method in class bb.common.MrpReportAgent

getLevel() - Method in class bb.common.PermissionVO

getLevel() - Method in class bb.common.ProfitLossStatementItemResult

getLevel() - Method in class bb.common.RollUpBomStdCostWorkSheetItemVO

getLevel() - Method in class bb.common.SalesmanVO

getLevel() - Method in class bb.common.SGClientAccountVO

getLevel() - Method in class bb.common.SGLogLoginVO

getLevel() - Method in class bb.common.SGQuoteAddressVO

getLevel() - Method in class bb.common.SGQuoteLoginVO

getLevelDescription() - Method in class bb.common.PartSecurityLevelVO

getLevelId() - Method in class bb.common.PartSecurityLevelVO

getLevels() - Method in class bb.common.PartVO

getLevels() - Method in class bb.common.PartWithOnhandsVO

getLicense() - Method in interface bb.common.box.CompanyBox

getLicense() - Method in class bb.common.CompanyVO

getLine() - Method in class bb.common.OnhandQualityResult

getLinkOrRef() - Method in class bb.common.PosRefdocVO

getLinkOrRef() - Method in class bb.common.RefdocVO

getList() - Method in class bb.common.DisassembleWorkOrderItemVO

getList() - Method in class bb.common.ExchangeAuditResult

getList() - Method in class bb.common.WorkOrderItemVO

getListCost() - Method in class bb.common.BillDetailCostResult

getListCost() - Method in class bb.common.ToolListDetailCostResult

getListInAddressBook() - Method in class bb.common.EmployeeCardVO

getListPrice() - Method in class bb.common.AccountsReceivableItemVO

getListPrice() - Method in class bb.common.BillDetailCostWithPartInfoResult

getListPrice() - Method in class bb.common.BillItemDetailCostWithPartInfoResult

getListPrice() - Method in class bb.common.BillItemSalesCostResult

getListPrice() - Method in class bb.common.BillItemSalesXResult

getListPrice() - Method in class bb.common.BillItemUsageResult

getListPrice() - Method in class bb.common.BillItemWithPartInfoResult

getListPrice() - Method in class bb.common.BillSalesCostResult

getListPrice() - Method in class bb.common.BillSalesXResult

getListPrice() - Method in class bb.common.BomItemWithOEMResult

getListPrice() - Method in class bb.common.BomWithOEMResult

getListPrice() - Method in class bb.common.ContractPriceItemVO

getListPrice() - Method in class bb.common.HistoricalInventoryVO

getListPrice() - Method in class bb.common.InventoryListResult

getListPrice() - Method in class bb.common.LnShipperItemListResult

getListPrice() - Method in class bb.common.OnloanShipperItemVO

getListPrice() - Method in class bb.common.PartBasicInfoWithNewListPrice

getListPrice() - Method in class bb.common.PartInventoryVO

getListPrice() - Method in class bb.common.PartOnHandWithPartBasicInfoResult

getListPrice() - Method in class bb.common.PartUnitVO

getListPrice() - Method in class bb.common.PartWithQAQtyListResult

getListPrice() - Method in class bb.common.PartWithQtyListResult

getListPrice() - Method in class bb.common.PartWithSipQtyListResult

getListPrice() - Method in class bb.common.PartWithSITQtyListResult

getListPrice() - Method in class bb.common.PartWithSTOQtyListResult

getListPrice() - Method in class bb.common.PartWithWipQtyListResult

getListPrice() - Method in class bb.common.PfReceiverItemVO

getListPrice() - Method in class bb.common.ProformaInvoiceItemListResult

getListPrice() - Method in class bb.common.ProformaInvoiceItemVO

getListPrice() - Method in class bb.common.RtvShipperItemVO

getListPrice() - Method in class bb.common.SalesOrderItemCostResult

getListPrice() - Method in class bb.common.ShipperItemListResult

getListPrice() - Method in class bb.common.ShipperItemVO

getListPrice() - Method in class bb.common.ToolInventoryVO

getListPrice() - Method in class bb.common.ToolListDetailCostWithToolInfoResult

getListPrice() - Method in class bb.common.ToolListItemDetailCostWithToolInfoResult

getListPrice() - Method in class bb.common.VendorContractPriceItemVO

getListUsage() - Method in class bb.common.MrpReportAgent

getLnNumber() - Method in class bb.common.OnloanReceiverItemListResult

getLnReceiverDigits() - Method in class bb.common.CompanyVO

getLnReceiverPrefix() - Method in class bb.common.CompanyVO

getLnShipperDigits() - Method in class bb.common.CompanyVO

getLnShipperItemListResultsCount(Date, Date, String, String, String, String, String, String) - Method in interface bb.common.box.WarehouseBox

getLnShipperItemListResultsCountByCustomerId(String) - Method in interface bb.common.box.WarehouseBox

getLnShipperItemListResultsCountByPartNumber(String, String) - Method in interface bb.common.box.WarehouseBox

getLnShipperItemNumber() - Method in class bb.common.LnShipperItemListResult

getLnShipperItemNumber() - Method in class bb.common.OnloanShipperItemPK

getLnShipperNumber() - Method in class bb.common.LnShipperItemListResult

getLnShipperNumber() - Method in class bb.common.LnShipperListResult

getLnShipperNumber() - Method in class bb.common.OnloanReceiverItemListResult

getLnShipperNumber() - Method in class bb.common.OnloanReceiverItemVO

getLnShipperNumber() - Method in class bb.common.OnloanReceiverListResult

getLnShipperNumber() - Method in class bb.common.OnloanReceiverVO

getLnShipperNumber() - Method in class bb.common.OnloanShipperItemPK

getLnShipperNumber() - Method in class bb.common.OnloanShipperVO

getLnShipperPrefix() - Method in class bb.common.CompanyVO

getLoadDetailList() - Method in class bb.common.WorkCenterLoadListResult

getLoadHrs() - Method in class bb.common.WorkCenterLoadListResult

getLoanComments() - Method in class bb.common.OnLoanVO

getLoanDate() - Method in class bb.common.OnLoanItemListResult

getLoanDate() - Method in class bb.common.OnLoanListResult

getLoanDate() - Method in class bb.common.OnLoanVO

getLoanItemByPartPkCount(PartPK, String) - Method in interface bb.common.box.WarehouseBox

getLoanItemNumber() - Method in class bb.common.OnLoanItemListResult

getLoanItemNumber() - Method in class bb.common.OnLoanItemPK

getLoanNotes() - Method in class bb.common.OnLoanVO

getLoanNumber() - Method in class bb.common.LnShipperItemListResult

getLoanNumber() - Method in class bb.common.LnShipperListResult

getLoanNumber() - Method in class bb.common.OnLoanItemListResult

getLoanNumber() - Method in class bb.common.OnLoanItemPK

getLoanNumber() - Method in class bb.common.OnLoanListResult

getLoanNumber() - Method in class bb.common.OnloanShipperItemVO

getLoanNumber() - Method in class bb.common.OnloanShipperVO

getLoanNumber() - Method in class bb.common.OnLoanVO

getLoanQty() - Method in class bb.common.OnLoanItemListResult

getLoanQuantity() - Method in class bb.common.OnLoanItemVO

getLoanQuantity() - Method in class bb.common.OnloanShipperItemVO

getLocalCurrency() - Method in class bb.common.PartOnhandCostVO

getLocalDescription() - Method in class bb.common.NonConformanceCodeVO

getLocalPath() - Method in class bb.common.DocumentServerVO

getLocalPath() - Method in class bb.common.DwfUploadSettingsVO

getLocalPath() - Method in class bb.common.DwgUploadSettingsVO

getLocalPath() - Method in class bb.common.MiscDocumentSettingVO

getLocalSettings() - Method in class bb.common.AccountingConfigurationVO

getLocate() - Method in class bb.common.AccountsReceivableItemVO

getLocate() - Method in class bb.common.CustomerReturnToVendorItemVO

getLocate() - Method in class bb.common.CustomerReturnToVendorVO

getLocate() - Method in class bb.common.CycleCountVO

getLocate() - Method in class bb.common.InventoryNotUsedInMonthsResult

getLocate() - Method in class bb.common.IssueItemDetailAgent

getLocate() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getLocate() - Method in class bb.common.OnLoanVO

getLocate() - Method in class bb.common.PartIssuedVO

getLocate() - Method in class bb.common.PartReceivedVO

getLocate() - Method in class bb.common.PhysicalInventoryVO

getLocate() - Method in class bb.common.ProformaInvoiceItemVO

getLocate() - Method in class bb.common.PurchaseOrderItemVO

getLocate() - Method in class bb.common.PurchaseOrderVO

getLocate() - Method in class bb.common.PuttoInQAAgent

getLocate() - Method in class bb.common.QuoteItemVO

getLocate() - Method in class bb.common.QuoteVO

getLocate() - Method in class bb.common.RebackInQAAgent

getLocate() - Method in class bb.common.RequestForRMAItemVO

getLocate() - Method in class bb.common.RequestForRMAVO

getLocate() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getLocate() - Method in class bb.common.ReturnMaterialAuthorizationVO

getLocate() - Method in class bb.common.ReturnToVendorItemVO

getLocate() - Method in class bb.common.ReturnToVendorVO

getLocate() - Method in class bb.common.RMAReceiverItemVO

getLocate() - Method in class bb.common.RtvShipperItemVO

getLocate() - Method in class bb.common.SalesOrderItemInfoVO

getLocate() - Method in class bb.common.SalesOrderItemVO

getLocate() - Method in class bb.common.SalesOrderVO

getLocate() - Method in class bb.common.ShipperItemDetailAgent

getLocate() - Method in class bb.common.TransferOrderListResult

getLocate() - Method in class bb.common.TransferOrderVO

getLocate() - Method in class bb.common.TransferReceiverListResult

getLocate() - Method in class bb.common.TransferReceiverVO

getLocates() - Method in class bb.common.PartOnhandResult

getLocation() - Method in class bb.common.AccountsPayableItemVO

getLocation() - Method in class bb.common.AddPhysicalInventoryAgent

getLocation() - Method in class bb.common.AssetAddOrDisposalsReport

getLocation() - Method in class bb.common.AssetDepreciateVO

getLocation() - Method in class bb.common.AssetVO

getLocation() - Method in class bb.common.BomPickListItemResult

getLocation() - Method in class bb.common.CSRAgent

getLocation() - Method in class bb.common.CustomerServiceIncidentVO

getLocation() - Method in class bb.common.CycleCountAgent

getLocation() - Method in class bb.common.CycleCountListResult

getLocation() - Method in class bb.common.DepartmentLocationForBackflushVO

getLocation() - Method in class bb.common.DisassembleWorkOrderItemVO

getLocation() - Method in class bb.common.DisassembleWorkOrderVO

getLocation() - Method in class bb.common.DWOIssueDetail

getLocation() - Method in class bb.common.EmployeeWorkExperienceVO

getLocation() - Method in class bb.common.InventoryCycleItemResult

getLocation() - Method in class bb.common.InventoryListResult

getLocation() - Method in class bb.common.InventoryMonthReport

getLocation() - Method in class bb.common.LocationResult

getLocation() - Method in class bb.common.LogInventoryListResult

getLocation() - Method in class bb.common.LogInventoryVO

getLocation() - Method in class bb.common.LogTrackingVO

getLocation() - Method in class bb.common.OnLoanItemVO

getLocation() - Method in class bb.common.OnloanReceiverItemVO

getLocation() - Method in class bb.common.OnloanShipperItemVO

getLocation() - Method in class bb.common.PartOnhandCostVO

getLocation() - Method in class bb.common.PartOnhandPK

getLocation() - Method in class bb.common.PhysicalInventoryListResult

getLocation() - Method in class bb.common.POReceiverItemListResult

getLocation() - Method in class bb.common.ReceiverItemDetailAgent

getLocation() - Method in class bb.common.ReceiverItemVO

getLocation(String) - Method in class bb.common.ReceiverShipAgent

getLocation() - Method in class bb.common.RequestForQuoteItemVO

getLocation() - Method in class bb.common.RequestForQuoteVO

getLocation() - Method in class bb.common.SGCustomerServiceRequestVO

getLocation() - Method in class bb.common.ShipperItemListResult

getLocation() - Method in class bb.common.ShipperItemVO

getLocation() - Method in class bb.common.SwapReceiverItemVO

getLocation() - Method in class bb.common.SwapShipperItemVO

getLocation() - Method in class bb.common.ToolCalibrationVO

getLocation() - Method in class bb.common.TransferReceiverItemVO

getLocation() - Method in class bb.common.TransferShipperItemVO

getLocation() - Method in class bb.common.UpdatePhysicalInventoryAgent

getLocation() - Method in class bb.common.WoItemPickListItemResult

getLocation() - Method in class bb.common.WOReceiverDetail

getLocation() - Method in class bb.common.WorkOrderItemVO

getLocation() - Method in class bb.common.WorkOrderReceiverVO

getLocation() - Method in class bb.common.WorkOrderVO

getLocationCount() - Method in class bb.common.LocationResult

getLocationForReturnMaterial() - Method in class bb.common.PointOfSaleVO

getLocationInventoryReportCount(Date, Date, String, String, String) - Method in interface bb.common.box.WarehouseBox

getLocationInventoryReportTotal(Date, Date, String, String, String) - Method in interface bb.common.box.WarehouseBox

getLocationOnhand() - Method in class bb.common.BillOnHandWithPartInfoResult

getLocationPrefix() - Method in class bb.common.WoItemPickListResult

getLocations() - Method in class bb.common.DisassembleWorkOrderIssueVO

getLocations() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

getLocations() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getLocations() - Method in class bb.common.NonproductivePickingItemIssuedVO

getLocations() - Method in class bb.common.NonproductivePickingOnDemandResult

getLocations() - Method in class bb.common.OnloanReceiverItemVO

getLocations() - Method in class bb.common.OnloanShipperItemVO

getLocations() - Method in class bb.common.PackingBoxItemVO

getLocations() - Method in class bb.common.PackingBoxSalesOrderItemAgent

getLocations() - Method in class bb.common.PackingBoxSalesOrderItemResult

getLocations() - Method in class bb.common.POReceiverItemListResult

getLocations() - Method in class bb.common.ReceiverItemVO

getLocations() - Method in class bb.common.ReceiverShipAgent

getLocations() - Method in class bb.common.RMAReceiverItemVO

getLocations() - Method in class bb.common.RMAReceiverResult

getLocations() - Method in class bb.common.RtvShipperItemVO

getLocations() - Method in class bb.common.SalesOrderOnDemandResult

getLocations() - Method in class bb.common.ShipperItemListResult

getLocations() - Method in class bb.common.ShipperItemVO

getLocations() - Method in class bb.common.SwapReceiverItemVO

getLocations() - Method in class bb.common.SwapShipperItemVO

getLocations() - Method in class bb.common.TransferReceiverItemVO

getLocations() - Method in class bb.common.TransferShipperItemVO

getLocations() - Method in class bb.common.WorkOrderOnDemandResult

getLocationsMap() - Method in class bb.common.PackingBoxSalesOrderItemAgent

getLocatoins() - Method in class bb.common.ReceiverItemAgent

getLocatoins() - Method in class bb.common.ShipperItemAgent

getLock() - Method in class bb.common.DocumentServerVO

getLockedTransactionDate() - Method in class bb.common.GeneralLedgerSettingsVO

getLog() - Method in class bb.common.RollUpBomStdCostWorkSheetVO

getLoginName() - Method in class bb.common.SGClientLogin

getLoginType() - Method in class bb.common.BB2Login

getLogInventoryByPk(Long) - Method in interface bb.common.box.WarehouseBox

getLogInventoryCountByPart(BB2Part) - Method in interface bb.common.box.WarehouseBox

getLogInventoryCountByPartLike(String, String, String, String, String, Date, Date, boolean) - Method in interface bb.common.box.WarehouseBox

getLogInventoryCountSimpleByPartLike(String, String, String, Date, Date) - Method in interface bb.common.box.WarehouseBox

getLogo() - Method in class bb.common.CompanyVO

getLogo() - Method in class bb.common.PointOfSaleVO

getLogo() - Method in class bb.common.PrintLogoVO

getLogo() - Method in class bb.common.SGCompanyVO

getLogoName() - Method in class bb.common.PrintLogoVO

getLogsCount(String, String, boolean, String, String, String, Date, Date) - Method in interface bb.common.box.LogBox

getLogsCountByAction(String) - Method in interface bb.common.box.LogBox

getLogsCountByLastName(String) - Method in interface bb.common.box.LogBox

getLogsCountByTarget(String) - Method in interface bb.common.box.LogBox

getLogsCountByTrueName(String) - Method in interface bb.common.box.LogBox

getLogsCountByUserName(String) - Method in interface bb.common.box.LogBox

getLogTasksCount(String, Date, Date) - Method in interface bb.common.box.CompanyBox

getLogTrackingsCount(String, String, String, String, String, String, String, Date, Date, int) - Method in interface bb.common.box.QualityBox

getLongDescription() - Method in class bb.common.EmployeeJobDescriptionVO

getLongTermAssets() - Method in class bb.common.AccountingBalanceSheetResult

getLongTermLiabilities() - Method in class bb.common.ClosingStatementResult

getLot() - Method in class bb.common.DisassembleWorkOrderIssueVO

getLot() - Method in class bb.common.DisassembleWorkOrderItemPartDetailItemResult

getLot() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

getLot() - Method in class bb.common.IssueItemAgent

getLot() - Method in class bb.common.IssuingItemResult

getLot() - Method in class bb.common.PartIssuedVO

getLot() - Method in class bb.common.PartOnhandCostVO

getLot() - Method in class bb.common.PartReceivedVO

getLot() - Method in class bb.common.ReceiverItemAgent

getLot() - Method in class bb.common.WorkOrderItemIssueVO

getLot() - Method in class bb.common.WorkOrderItemPartDetailItemResult

getLot() - Method in class bb.common.WorkOrderItemTimeDetailVO

getLot() - Method in class bb.common.WorkOrderReceiverVO

getLowestCost() - Method in class bb.common.SalesOrderItemCostResult

getMacAdd() - Method in class bb.common.DocumentInfoAgent

getMacAdd() - Method in class bb.common.MiscDocAgent

getMacAdd() - Method in class bb.common.PartDwfAgent

getMacAdd() - Method in class bb.common.PartDwgAgent

getMacAddress() - Method in class bb.common.BizboxUserVO

getMacAddress() - Method in class bb.common.LogMiscDocumentVO

getMacAddress() - Method in class bb.common.LogPartDocumentVO

getMacAddress() - Method in class bb.common.LogPartDwfVO

getMacAddress() - Method in class bb.common.LogPartDwgVO

getMacAddress() - Method in class bb.common.OperationLogVO

getMachineCost() - Method in class bb.common.WorkOrderItemLaborCostListResult

getMachineHoursPerDay() - Method in class bb.common.WorkCenterVO

getMachinePay() - Method in class bb.common.WorkCenterVO

getMachinePerformance() - Method in class bb.common.WorkCenterVO

getMachineQty() - Method in class bb.common.WorkCenterVO

getMadeBy() - Method in class bb.common.AccountPayableCheckRunVO

getMadeBy() - Method in class bb.common.ARPaymentRunVO

getMailTextPreview(String) - Method in interface bb.common.box.CompanyBox

getMainPartPicture(PartPK) - Method in interface bb.common.box.EngineeringBox

getMaintemanceBy() - Method in class bb.common.MaintenanceItemVO

getMaintemanceNotes() - Method in class bb.common.MaintenanceItemVO

getMaintenanceBy() - Method in class bb.common.EquipmentListResult

getMaintenanceBy() - Method in class bb.common.EquipmentVO

getMaintenanceDate() - Method in class bb.common.MaintenanceItemVO

getMaintenanceItems() - Method in class bb.common.EquipmentVO

getMaintencePeriod() - Method in class bb.common.EquipmentVO

getMajor() - Method in class bb.common.EmployeeEducationVO

getMakeBuy() - Method in class bb.common.BillItemSalesXResult

getMakeBuy() - Method in class bb.common.BillWhereUsedResult

getMakeBuy() - Method in class bb.common.ChangeStdCostWorkSheetItemVO

getMakeBuy() - Method in class bb.common.MrpReportAgent

getMakeBuy() - Method in class bb.common.PartBasicInfo

getMakeBuy() - Method in class bb.common.PartCostVarianceListResult

getMakeBuy() - Method in class bb.common.PartMRPVO

getMakeBuy() - Method in class bb.common.PartVO

getMakeBuy() - Method in class bb.common.PartWithOnhandsVO

getMakeBuy() - Method in class bb.common.ToolVO

getMakeBuy() - Method in class bb.common.ToolWithOnhandsVO

getMakeBuyForNewPart() - Method in class bb.common.CompanyVO

getMakeDate() - Method in class bb.common.MakeCheckAgent

getMakeDate() - Method in class bb.common.MakePrepaymentCheckAgent

getMakeDate() - Method in class bb.common.PostCheckAgent

getMakePo() - Method in class bb.common.PurchaseWorkSheetItemVO

getMakeRfq() - Method in class bb.common.PurchaseWorkSheetItemVO

getMakeRfq() - Method in class bb.common.WorkOrderWorkSheetItemVO

getMakeWo() - Method in class bb.common.WorkOrderWorkSheetItemVO

getManager() - Method in class bb.common.EmployeeCardVO

getManager() - Method in class bb.common.ExpenseVO

getManual() - Method in class bb.common.SGDocPartVO

getManualRev() - Method in class bb.common.SGDocPartVO

getManufacture() - Method in class bb.common.CustomAssetVO

getManufactureId() - Method in class bb.common.CustomAssetVO

getManufacturerAddressById(String) - Method in interface bb.common.box.AddressBox

getManufacturerAddressById(String, String) - Method in interface bb.common.box.AddressBox

getManufacturerAddressesCountById(String) - Method in interface bb.common.box.AddressBox

getManufacturerAddressesCountByName(String) - Method in interface bb.common.box.AddressBox

getManufacturerECRequestCountByEcrNumberLike(String) - Method in interface bb.common.box.ManufacturingBox

getManufacturerECRequestsCountByPartLike(String, String) - Method in interface bb.common.box.ManufacturingBox

getManufacturerEngineeringChangeById(String) - Method in interface bb.common.box.ManufacturingBox

getManufacturerEngineeringChangesCountByMecnNumberLike(String) - Method in interface bb.common.box.ManufacturingBox

getManufacturerEngineeringChangesCountByPart(PartPK) - Method in interface bb.common.box.ManufacturingBox

getManufacturerEngineeringChangesCountByPartLike(String, String) - Method in interface bb.common.box.ManufacturingBox

getManufacturerEngineeringChangesCountByPartPk(PartPK) - Method in interface bb.common.box.ManufacturingBox

getManufacturerId() - Method in class bb.common.EquipmentListResult

getManufacturerId() - Method in class bb.common.EquipmentVO

getManufacturerId() - Method in class bb.common.PartManufacturerVO

getManufacturerId() - Method in class bb.common.PartOnHandWithMfgInfoResult

getManufacturerId() - Method in class bb.common.PartWithManufacturerInfoResult

getManufacturerId() - Method in class bb.common.ToolManufacturerVO

getManufacturerItem() - Method in class bb.common.PartManufacturerPK

getManufacturerItem() - Method in class bb.common.PartWithManufacturerInfoResult

getManufacturerName() - Method in class bb.common.AccountsPayableItemManufacturerVO

getManufacturerName() - Method in class bb.common.AccountsReceivableItemManufacturerVO

getManufacturerName() - Method in class bb.common.PartManufacturerVO

getManufacturerName() - Method in class bb.common.PartOnHandWithMfgInfoResult

getManufacturerName() - Method in class bb.common.PartWithManufacturerInfoResult

getManufacturerName() - Method in class bb.common.PO2SOExchangeItemManufacturer

getManufacturerName() - Method in class bb.common.ProformaInvoiceItemManufacturerVO

getManufacturerName() - Method in class bb.common.PurchaseOrderItemManufacturerVO

getManufacturerName() - Method in class bb.common.QuoteItemManufacturerVO

getManufacturerName() - Method in class bb.common.ReceiverItemManufacturerVO

getManufacturerName() - Method in class bb.common.RequestForQuoteItemManufacturerVO

getManufacturerName() - Method in class bb.common.ReturnMaterialAuthorizationItemManufacturerVO

getManufacturerName() - Method in class bb.common.ReturnToVendorItemManufacturerVO

getManufacturerName() - Method in class bb.common.SalesOrderItemManufacturerVO

getManufacturerName() - Method in class bb.common.ShipperItemManufacturerVO

getManufacturerName() - Method in class bb.common.ToolCalibrationVO

getManufacturerName() - Method in class bb.common.ToolManufacturerVO

getManufacturerPartNoMfgExistent(String, PartPK) - Method in interface bb.common.box.EngineeringBox

getManufacturerPartNumber() - Method in class bb.common.AccountsPayableItemManufacturerVO

getManufacturerPartNumber() - Method in class bb.common.AccountsReceivableItemManufacturerVO

getManufacturerPartNumber() - Method in class bb.common.PartManufacturerVO

getManufacturerPartNumber() - Method in class bb.common.PartOnHandWithMfgInfoResult

getManufacturerPartNumber() - Method in class bb.common.PartWithManufacturerInfoResult

getManufacturerPartNumber() - Method in class bb.common.ProformaInvoiceItemManufacturerVO

getManufacturerPartNumber() - Method in class bb.common.PurchaseOrderItemManufacturerVO

getManufacturerPartNumber() - Method in class bb.common.QuoteItemManufacturerVO

getManufacturerPartNumber() - Method in class bb.common.ReceiverItemManufacturerVO

getManufacturerPartNumber() - Method in class bb.common.RequestForQuoteItemManufacturerVO

getManufacturerPartNumber() - Method in class bb.common.ReturnMaterialAuthorizationItemManufacturerVO

getManufacturerPartNumber() - Method in class bb.common.ReturnToVendorItemManufacturerVO

getManufacturerPartNumber() - Method in class bb.common.SalesOrderItemManufacturerVO

getManufacturerPartNumber() - Method in class bb.common.ShipperItemManufacturerVO

getManufacturerPartNumber() - Method in class bb.common.ToolManufacturerVO

getManufacturerPartRev() - Method in class bb.common.PartManufacturerVO

getManufacturerPartRev() - Method in class bb.common.ToolManufacturerVO

getManufacturerPN() - Method in class bb.common.PO2SOExchangeItemManufacturer

getManufacturers() - Method in class bb.common.PartVO

getManufacturers() - Method in class bb.common.ToolVO

getManWorkInstructionByWoItemPk(BB2Part, String) - Method in interface bb.common.box.WorkOrderBox

getMap() - Method in class bb.common.ExchangeAuditResult

getMap() - Method in class bb.common.OnhandQualityResult

getMap() - Method in class bb.common.PurchaseOrderContractResult

getMap() - Method in class bb.common.WorkOrderIssueStatisticsResult

getMargin() - Method in class bb.common.AccountsReceivableInfoVO

getMargin() - Method in class bb.common.AccountsReceivableItemVO

getMargin() - Method in class bb.common.AccountsReceivableVO

getMargin() - Method in class bb.common.InvoiceItemListResult

getMargin() - Method in class bb.common.QuoteItemVO

getMargin() - Method in class bb.common.QuoteVO

getMargin() - Method in class bb.common.SalesOrderItemVO

getMargin() - Method in class bb.common.SalesOrderVO

getMarginByStdCost() - Method in class bb.common.AccountsReceivableInfoVO

getMarginByStdCost() - Method in class bb.common.AccountsReceivableItemVO

getMarginByStdCost() - Method in class bb.common.AccountsReceivableVO

getMarginByStdCost() - Method in class bb.common.QuoteItemVO

getMarginByStdCost() - Method in class bb.common.QuoteVO

getMarginByStdCost() - Method in class bb.common.SalesOrderItemVO

getMarginByStdCost() - Method in class bb.common.SalesOrderVO

getMarginPercent() - Method in class bb.common.AccountsReceivableInfoVO

getMarginPercent() - Method in class bb.common.AccountsReceivableItemVO

getMarginPercent() - Method in class bb.common.AccountsReceivableVO

getMarginPercent() - Method in class bb.common.InvoiceItemListResult

getMarginPercent() - Method in class bb.common.QuoteItemVO

getMarginPercent() - Method in class bb.common.QuoteVO

getMarginPercent() - Method in class bb.common.SalesOrderItemVO

getMarginPercent() - Method in class bb.common.SalesOrderVO

getMarginPercentByStdCost() - Method in class bb.common.AccountsReceivableInfoVO

getMarginPercentByStdCost() - Method in class bb.common.AccountsReceivableItemVO

getMarginPercentByStdCost() - Method in class bb.common.AccountsReceivableVO

getMarginPercentByStdCost() - Method in class bb.common.QuoteItemVO

getMarginPercentByStdCost() - Method in class bb.common.QuoteVO

getMarginPercentByStdCost() - Method in class bb.common.SalesOrderItemVO

getMarginPercentByStdCost() - Method in class bb.common.SalesOrderVO

getMasterWorkOrderTreeItem(BillPK, WorkOrderItemPK, BigDecimal, boolean, String) - Method in interface bb.common.box.WorkOrderBox

getMaterial() - Method in class bb.common.PartBasicInfo

getMaterial() - Method in class bb.common.PartMaterialListResult

getMaterial() - Method in class bb.common.PartMaterialReportAgent

getMaterial() - Method in class bb.common.PartMaterialVO

getMaterial() - Method in class bb.common.PartVO

getMaterial() - Method in class bb.common.PartWithOnhandsVO

getMaterialShare() - Method in class bb.common.WorkOrderIssueStatisticsResult

getMaterialValuationStorageVarianceAccount() - Method in class bb.common.AccountingSettingsVO

getMaxAssyQty() - Method in class bb.common.WorkOrderItemCanAssyResult

getMaxDate() - Method in class bb.common.WorkCenterAgent

getMaxIssued() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getMaxIssued() - Method in class bb.common.IssuingItemResult

getMaxLoad() - Method in class bb.common.WorkCenterLoadListResult

getMaxPackagingBoxNum() - Method in class bb.common.ShipperItemAgent

getMaxQty() - Method in class bb.common.BB2PartInfo

getMaxQty() - Method in class bb.common.BB2PartTotalOnhandDetailResult

getMaxQty() - Method in class bb.common.InventoryListResult

getMaxQty() - Method in class bb.common.PartInventoryVO

getMaxQty() - Method in class bb.common.PartWithExcessiveInventoryListResult

getMaxQty() - Method in class bb.common.PartWithOnhandDetailInfoResult

getMaxQty() - Method in class bb.common.StockTransactionPartInfoResult

getMaxQty() - Method in class bb.common.ToolInventoryVO

getMaxQtyByAvgCost() - Method in class bb.common.InventoryTotalResult

getMaxQtyByStdCost() - Method in class bb.common.InventoryTotalResult

getMaxReceived() - Method in class bb.common.ReceivingItemResult

getMaxSeqByCategoryId(String, Date) - Method in interface bb.common.box.AccountingBox

getMeasureWorker() - Method in class bb.common.InspectionReportInfoVO

getMeasureWorker() - Method in class bb.common.InspectionReportVO

getMECRequest(String) - Method in interface bb.common.box.ManufacturingBox

getMemo() - Method in class bb.common.AccountPayableCheckRunItemVO

getMemo() - Method in class bb.common.AccountPayableCheckVO

getMemo() - Method in class bb.common.AccountReceivablePaymentVO

getMemo() - Method in class bb.common.ARPaymentRunItemVO

getMemo() - Method in class bb.common.DepositSummaryResult

getMemo() - Method in class bb.common.GeneralLedgerListResult

getMemo() - Method in class bb.common.GeneralLedgerVO

getMemo() - Method in class bb.common.MakeCheckAgent

getMemo() - Method in class bb.common.MakePrepaymentCheckAgent

getMemo() - Method in class bb.common.PostCheckAgent

getMemo() - Method in class bb.common.TraceableSpecsVO

getMessage() - Method in class bb.common.BB2Event

getMessage(Long) - Method in interface bb.common.box.CompanyBox

getMessageI18nKey() - Method in class bb.common.I18nEvent

getMessageI18nParams() - Method in class bb.common.I18nEvent

getMessageNumber() - Method in class bb.common.BB2Notice

getMessagesCount(String, Date, Date) - Method in interface bb.common.box.CompanyBox

getMethod() - Method in class bb.common.ServerAction

getMethodId() - Method in class bb.common.EjbMethodVO

getMethodId() - Method in class bb.common.PermissionMethodPK

getMethodName() - Method in class bb.common.DynamicSearchFilter

getMethodName() - Method in class bb.common.EjbMethodVO

getMethodName() - Method in class bb.common.LogMethodPK

getMethodsCountByEjbName(String) - Method in interface bb.common.box.SecurityBox

getMfg() - Method in class bb.common.AccountsPayableItemVO

getMfg() - Method in class bb.common.AccountsReceivableItemVO

getMfg() - Method in class bb.common.CustomerReturnToVendorItemVO

getMfg() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getMfg() - Method in class bb.common.OnLoanItemVO

getMfg() - Method in class bb.common.OnloanReceiverItemVO

getMfg() - Method in class bb.common.OnloanShipperItemVO

getMfg() - Method in class bb.common.OrderApprovalItemsVO

getMfg() - Method in class bb.common.PartManufacturerAgent

getMfg() - Method in class bb.common.PfReceiverItemVO

getMfg() - Method in class bb.common.ProformaInvoiceItemVO

getMfg() - Method in class bb.common.PurchaseOrderItemVO

getMfg() - Method in class bb.common.QuoteItemVO

getMfg() - Method in class bb.common.ReceiverItemVO

getMfg() - Method in class bb.common.ReceivingItemResult

getMfg() - Method in class bb.common.RequestForQuoteItemVO

getMfg() - Method in class bb.common.RequestForRMAItemVO

getMfg() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getMfg() - Method in class bb.common.ReturnToVendorItemVO

getMfg() - Method in class bb.common.RMAReceiverItemVO

getMfg() - Method in class bb.common.RtvShipperItemVO

getMfg() - Method in class bb.common.SalesOrderItemInfoVO

getMfg() - Method in class bb.common.SalesOrderItemListResult

getMfg() - Method in class bb.common.SalesOrderItemVO

getMfg() - Method in class bb.common.SGSaleItemVO

getMfg() - Method in class bb.common.ShipperItemVO

getMfg() - Method in class bb.common.ShippingItemResult

getMfg() - Method in class bb.common.SwapOrderItemVO

getMfg() - Method in class bb.common.SwapReceiverItemVO

getMfg() - Method in class bb.common.SwapShipperItemVO

getMfg() - Method in class bb.common.TransferOrderItemVO

getMfg() - Method in class bb.common.TransferReceiverItemListResult

getMfg() - Method in class bb.common.TransferReceiverItemVO

getMfg() - Method in class bb.common.TransferShipperItemListResult

getMfg() - Method in class bb.common.TransferShipperItemVO

getMfg() - Method in class bb.common.WorkOrderItemIssueVO

getMfg() - Method in class bb.common.WorkOrderItemVO

getMfgBillSetupInfo() - Method in class bb.common.BillVO

getMfgBillSetupInfo(BillPK) - Method in interface bb.common.box.EngineeringBox

getMfgCode() - Method in class bb.common.AssetVO

getMfgDate() - Method in class bb.common.CustomAssetVO

getMfgID() - Method in class bb.common.AssetVO

getMfgID() - Method in class bb.common.BomItemWithOEMResult

getMfgID() - Method in class bb.common.BomWithOEMResult

getMfgId() - Method in class bb.common.PurchaseWorkSheetItemVO

getMfgId() - Method in class bb.common.WorkOrderWorkSheetItemVO

getMfgIds() - Method in class bb.common.PurchaseWorkSheetItemVO

getMfgIds() - Method in class bb.common.WorkOrderWorkSheetItemVO

getMfgPartNumber() - Method in class bb.common.ContractPriceItemVO

getMfgPartNumber() - Method in class bb.common.ReceiverItemAgent

getMfgPartNumber() - Method in class bb.common.RunningAccountOrderItemVO

getMfgPartNumbers() - Method in class bb.common.CPItemFromQuoteResult

getMfgStatus() - Method in class bb.common.DisassembleWorkOrderItemListResult

getMfgStatus() - Method in class bb.common.DisassembleWorkOrderItemVO

getMfgStatus() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getMfgStatus() - Method in class bb.common.WorkOrderItemCanAssyResult

getMfgStatus() - Method in class bb.common.WorkOrderItemInWipListResult

getMfgStatus() - Method in class bb.common.WorkOrderItemListResult

getMfgStatus() - Method in class bb.common.WorkOrderItemPartDetail

getMfgStatus() - Method in class bb.common.WorkOrderItemVO

getMfrMpnListResultsFor(PurchaseOrderItemPK) - Method in interface bb.common.box.WarehouseBox

getMfrMpnListResultsFor(SalesOrderItemPK) - Method in interface bb.common.box.WarehouseBox

getMfrName() - Method in class bb.common.MfrMpnListResult

getMiddleName() - Method in class bb.common.BizBoxUserEmployeeResult

getMiddleName() - Method in class bb.common.CashierVO

getMiddleName() - Method in class bb.common.EmployeeCardVO

getMiddleName() - Method in class bb.common.GroupUserVO

getMiddleName() - Method in class bb.common.NoticeUserEmployeeListResult

getMinDate() - Method in class bb.common.WorkCenterAgent

getMinIssued() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getMinIssued() - Method in class bb.common.IssuingItemResult

getMinite(BigDecimal) - Static method in class bb.common.WorkOrderWorkInstructionSequenceVO

getMinOrder() - Method in class bb.common.InventoryListResult

getMinQty() - Method in class bb.common.BB2PartInfo

getMinQty() - Method in class bb.common.BB2PartTotalOnhandDetailResult

getMinQty() - Method in class bb.common.InventoryListResult

getMinQty() - Method in class bb.common.PartInventoryVO

getMinQty() - Method in class bb.common.PartWithExcessiveInventoryListResult

getMinQty() - Method in class bb.common.PartWithOnhandDetailInfoResult

getMinQty() - Method in class bb.common.StockTransactionPartInfoResult

getMinQty() - Method in class bb.common.ToolInventoryVO

getMinQtyByAvgCost() - Method in class bb.common.InventoryTotalResult

getMinQtyByStdCost() - Method in class bb.common.InventoryTotalResult

getMinReceived() - Method in class bb.common.ReceivingItemResult

getMiscDocLogCount(String, String, String, String, String, String, String, String, String, String, Date, Date) - Method in interface bb.common.box.CompanyBox

getMismatchedPartDrawingWithPartInfoResultsCount(String) - Method in interface bb.common.box.EngineeringBox

getMissingItems() - Method in class bb.common.BillDetailCostResult

getMissingItems() - Method in class bb.common.BillSalesOfCostResult

getMissingItems() - Method in class bb.common.BillSalesXResult

getMissingItems() - Method in class bb.common.ToolListDetailCostResult

getMn() - Method in class bb.common.CycleCountVO

getMn() - Method in class bb.common.PhysicalInventoryVO

getMobile() - Method in class bb.common.BizBoxUserEmployeeResult

getMobile() - Method in class bb.common.CustomerVendorContactVO

getMobile() - Method in class bb.common.EmployeeCardVO

getMobile() - Method in class bb.common.ManufacturerContactVO

getMobile() - Method in class bb.common.NoticeUserEmployeeListResult

getMobile() - Method in class bb.common.SgClientProgramUserVO

getMobile() - Method in class bb.common.SGCustRequestForQuoteVO

getMobile() - Method in class bb.common.VendorGroupUserVO

getModel() - Method in class bb.common.EquipmentListResult

getModel() - Method in class bb.common.EquipmentVO

getModel() - Method in class bb.common.InventoryPartInOutDetailListResult

getModel() - Method in class bb.common.RMAReceiverItemVO

getModelNO() - Method in class bb.common.AssetVO

getModelNumber() - Method in class bb.common.AccountsReceivableItemVO

getModelNumber() - Method in class bb.common.CorrectiveActionRequestVO

getModelNumber() - Method in class bb.common.CustomAssetVO

getModelNumber() - Method in class bb.common.CustomerReturnToVendorItemVO

getModelNumber() - Method in class bb.common.DisassembleWorkOrderIssueVO

getModelNumber() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

getModelNumber() - Method in class bb.common.DisassembleWorkOrderItemVO

getModelNumber() - Method in class bb.common.EngineeringChangeVO

getModelNumber() - Method in class bb.common.InventoryListResult

getModelNumber() - Method in class bb.common.InventoryNotUsedInMonthsforAppResult

getModelNumber() - Method in class bb.common.NonConformanceReportVO

getModelNumber() - Method in class bb.common.OnLoanItemVO

getModelNumber() - Method in class bb.common.OnloanReceiverItemVO

getModelNumber() - Method in class bb.common.OnloanShipperItemVO

getModelNumber() - Method in class bb.common.PartBasicInfo

getModelNumber() - Method in class bb.common.PartInventoryVO

getModelNumber() - Method in class bb.common.PartOnhandVO

getModelNumber() - Method in class bb.common.PartVO

getModelNumber() - Method in class bb.common.PartWithOnhandsVO

getModelNumber() - Method in class bb.common.PfReceiverItemVO

getModelNumber() - Method in class bb.common.PhysicalInventoryListWithAppDataResult

getModelNumber() - Method in class bb.common.PreventiveActionRequestVO

getModelNumber() - Method in class bb.common.ProformaInvoiceItemVO

getModelNumber() - Method in class bb.common.PurchaseOrderItemVO

getModelNumber() - Method in class bb.common.QuoteItemVO

getModelNumber() - Method in class bb.common.ReceiverItemVO

getModelNumber() - Method in class bb.common.RequestForQuoteItemVO

getModelNumber() - Method in class bb.common.RequestForRMAItemVO

getModelNumber() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getModelNumber() - Method in class bb.common.ReturnToVendorItemVO

getModelNumber() - Method in class bb.common.RunningAccountOrderItemVO

getModelNumber() - Method in class bb.common.SalesOrderItemInfoVO

getModelNumber() - Method in class bb.common.SalesOrderItemVO

getModelNumber() - Method in class bb.common.SGSaleItemVO

getModelNumber() - Method in class bb.common.ShipperItemVO

getModelNumber() - Method in class bb.common.ToolCalibrationVO

getModelNumber() - Method in class bb.common.ToolInventoryVO

getModelNumber() - Method in class bb.common.ToolOnhandVO

getModelNumber() - Method in class bb.common.ToolVO

getModelNumber() - Method in class bb.common.ToolWithOnhandsVO

getModelNumber() - Method in class bb.common.WorkOrderItemIssuedTotalResult

getModelNumber() - Method in class bb.common.WorkOrderItemIssueVO

getModelNumber() - Method in class bb.common.WorkOrderItemTimeDetailVO

getModelNumber() - Method in class bb.common.WorkOrderItemVO

getModelNumber() - Method in class bb.common.WorkOrderReceiverVO

getModule() - Method in class bb.common.CustomSearchVO

getModuleName() - Method in class bb.common.BizboxBugInfoVO

getModuleName() - Method in class bb.common.BizboxBugVO

getModuleName() - Method in class bb.common.ServerAction

getMoldeNumber() - Method in class bb.common.AccountsPayableItemVO

getMoldNumber() - Method in class bb.common.RtvShipperItemVO

getMoney() - Method in class bb.common.QtyAndMoney

getMoneyInDrawByComputerCount() - Method in interface bb.common.box.CompanyBox

getMoneyInDrawByComputerTotal() - Method in interface bb.common.box.CompanyBox

getMonth() - Method in class bb.common.AccountMonthPK

getMonth() - Method in class bb.common.AssetDepreciatePK

getMonth() - Method in class bb.common.CashFlowMonthTotalResult

getMonth() - Method in class bb.common.PurchaseOrderOnTimeItemResult

getMonth() - Method in class bb.common.SalesOrderOnTimeItemResult

getMonth() - Method in class bb.common.WorkOrderOnTimeItemResult

getMonthAmountMap() - Method in class bb.common.MonthSoOrArByCustomerResult

getMonthARByCustomerCount(Date, Date, String, String, boolean) - Method in interface bb.common.box.AccountingBox

getMonthARByCustomerSum(Date, Date, String, String, boolean) - Method in interface bb.common.box.AccountingBox

getMonthCount() - Method in class bb.common.BB2FiscalYearDate

getMonthDepreciation() - Method in class bb.common.AssetVO

getMonthDepreciationRate() - Method in class bb.common.AssetDepreciateDetailReport

getMonthDepreciationRate() - Method in class bb.common.AssetDepreciateVO

getMonthDepreciationRate() - Method in class bb.common.AssetVO

getMonthEndDate(int, int) - Static method in class bb.common.BB2Util

getMonthEndDate(String) - Method in interface bb.common.box.AccountingBox

getMonthEndDate(String) - Static method in class bb.common.YearMonthManager

getMonthFirstDate(Date) - Static method in class bb.common.BB2Util

getMonthFirstDate(String) - Method in interface bb.common.box.AccountingBox

getMonthFirstDate(String) - Static method in class bb.common.YearMonthManager

getMonthFirstDateMinTime(Date) - Static method in class bb.common.BB2Util

getMonthLastDate(Date) - Static method in class bb.common.BB2Util

getMonthLastDateMaxTime(Date) - Static method in class bb.common.BB2Util

getMonthName() - Method in class bb.common.MrpByMonthResult

getMonthName(int) - Static method in class bb.common.YearMonthManager

getMonthName(Date) - Static method in class bb.common.YearMonthManager

getMonthName(String) - Static method in class bb.common.YearMonthManager

getMonthNumber(String) - Static method in class bb.common.YearMonthManager

getMonthOffset(Date, Date) - Static method in class bb.common.BB2Util

getMonthOutputValues() - Method in class bb.common.OutputValueByMonthResult

getMonthQty() - Method in class bb.common.PurchaseWorkSheetItemVO

getMonthQty() - Method in class bb.common.WorkOrderWorkSheetItemVO

getMonths() - Method in class bb.common.OnTimeAgent

getMonths() - Method in class bb.common.PurchaseWorkSheetItemVO

getMonths() - Method in class bb.common.WorkOrderWorkSheetItemVO

getMonths() - Method in class bb.common.WorkSheetPartAgent

getMonthsInfo() - Method in class bb.common.MrpItemResult

getMonthSOByCustomerCount(Date, Date, String, String) - Method in interface bb.common.box.SalesBox

getMonthSOByCustomerSum(Date, Date, String, String) - Method in interface bb.common.box.SalesBox

getMonthStartDate(int, int) - Static method in class bb.common.BB2Util

getMonthToDate() - Method in class bb.common.ClosingStatementItemResult

getMonthToDate() - Method in class bb.common.ClosingStatementTotalResult

getMonthYear() - Method in class bb.common.AccountBalanceAgent

getMonthYear() - Method in class bb.common.AccountsChartAdvanceCategoryVO

getMonthYear() - Method in class bb.common.BalanceSheetSideBySideResult

getMonthYear() - Method in class bb.common.ClosingStatementResult

getMonthYear() - Method in class bb.common.CurrencyExchangePK

getMonthYear() - Method in class bb.common.ExchangeAuditResult

getMonthYear() - Method in class bb.common.GlMonthBudgetVO

getMonthYear() - Method in class bb.common.GlMonthVO

getMonthYearAfter12Month() - Method in interface bb.common.box.AccountingBox

getMothedParm() - Method in class bb.common.TempArApAgingVO

getMpn() - Method in class bb.common.AccountsPayableItemVO

getMpn() - Method in class bb.common.AccountsReceivableItemVO

getMpn() - Method in class bb.common.BomItemWithOEMResult

getMpn() - Method in class bb.common.BomWithOEMResult

getMpn() - Method in class bb.common.CustomerReturnToVendorItemVO

getMpn() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getMpn() - Method in class bb.common.MfrMpnListResult

getMpn() - Method in class bb.common.OnLoanItemVO

getMpn() - Method in class bb.common.OnloanReceiverItemVO

getMpn() - Method in class bb.common.OnloanShipperItemVO

getMpn() - Method in class bb.common.OrderApprovalItemsVO

getMpn() - Method in class bb.common.PartManufacturerAgent

getMpn() - Method in class bb.common.PfReceiverItemVO

getMpn() - Method in class bb.common.ProformaInvoiceItemVO

getMpn() - Method in class bb.common.PurchaseOrderItemVO

getMpn() - Method in class bb.common.QuoteItemVO

getMpn() - Method in class bb.common.ReceiverItemVO

getMpn() - Method in class bb.common.ReceivingItemResult

getMpn() - Method in class bb.common.RequestForQuoteItemVO

getMpn() - Method in class bb.common.RequestForRMAItemVO

getMpn() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getMpn() - Method in class bb.common.ReturnToVendorItemVO

getMpn() - Method in class bb.common.RMAReceiverItemVO

getMpn() - Method in class bb.common.RtvShipperItemVO

getMpn() - Method in class bb.common.SalesOrderItemInfoVO

getMpn() - Method in class bb.common.SalesOrderItemListResult

getMpn() - Method in class bb.common.SalesOrderItemVO

getMpn() - Method in class bb.common.SGSaleItemVO

getMpn() - Method in class bb.common.ShipperItemVO

getMpn() - Method in class bb.common.ShippingItemResult

getMpn() - Method in class bb.common.SwapOrderItemVO

getMpn() - Method in class bb.common.SwapReceiverItemVO

getMpn() - Method in class bb.common.SwapShipperItemVO

getMpn() - Method in class bb.common.TransferOrderItemVO

getMpn() - Method in class bb.common.TransferReceiverItemListResult

getMpn() - Method in class bb.common.TransferReceiverItemVO

getMpn() - Method in class bb.common.TransferShipperItemListResult

getMpn() - Method in class bb.common.TransferShipperItemVO

getMpn() - Method in class bb.common.WorkOrderItemIssueVO

getMpn() - Method in class bb.common.WorkOrderItemVO

getMpnRev() - Method in class bb.common.PartManufacturerAgent

getMpnRev() - Method in class bb.common.WorkOrderItemVO

getMpoDebitAccount() - Method in class bb.common.AccountingSettingsVO

getMrpItemOrderDemandRecordsResult(PartPK, MrpReportAgent) - Method in interface bb.common.box.PurchasingBox

getMrpItemResult(PartPK, boolean, boolean) - Method in interface bb.common.box.PurchasingBox

getMrpItemResult(PartPK, MrpReportAgent) - Method in interface bb.common.box.PurchasingBox

getMrpResult(BB2Part) - Method in interface bb.common.box.ManufacturingBox

getMrpResult(BB2Part) - Method in interface bb.common.box.PurchasingBox

getMrpResult(BB2Part) - Method in interface bb.common.box.WarehouseBox

getMultiCompanyUnit() - Method in class bb.common.BizboxUserVO

getMultiDescription() - Method in class bb.common.CustomerVendorAddressVO

getMultiDescription() - Method in class bb.common.ManufacturerAddressVO

getMultiLanguage() - Method in class bb.common.PartVO

getMultiLanguage() - Method in class bb.common.PartWithOnhandsVO

getMultiLanguage() - Method in class bb.common.PermissionVO

getMultiLanguage() - Method in class bb.common.RoleVO

getMultiLanguage() - Method in class bb.common.ToolVO

getMultiLanguage() - Method in class bb.common.ToolWithOnhandsVO

getMultiLanuageDescription() - Method in class bb.common.AccountsChartVO

getMultiplier() - Method in class bb.common.PartUnitVO

getMultiQtyforApplying() - Method in class bb.common.BillItemWithPartInfoResult

getMultiQtyforApplying() - Method in class bb.common.PartVO

getMultiQtyforApplying() - Method in class bb.common.WorkOrderItemSetupItemAgent

getMustOrder() - Method in class bb.common.MrpItemResult

getMustOrderBefore() - Method in class bb.common.MrpItemResult

getMyPurchaseWorkSheetByCount() - Method in interface bb.common.box.ManufacturingBox

getMyPurchaseWorkSheetByCount() - Method in interface bb.common.box.PurchasingBox

getMyReceiverPrintList() - Method in interface bb.common.box.WarehouseBox

getMyServerClientProperty(String) - Method in interface bb.common.box.CompanyBox

getMyShipperPrintList() - Method in interface bb.common.box.WarehouseBox

getMysqlVersion() - Method in interface bb.common.box.CompanyBox

getName() - Method in class bb.common.AccountPayableCheckVO

getName() - Method in class bb.common.AccountReceivablePaymentVO

getName() - Method in class bb.common.AddressAccountInfo

getName() - Method in class bb.common.AppColumnVO

getName() - Method in class bb.common.AssetTypeVO

getName() - Method in class bb.common.BB2Task

getName() - Method in class bb.common.CompanyUnitVO

getName() - Method in class bb.common.CustomCheckUpEmployeeVO

getName() - Method in class bb.common.CustomDepartmentVO

getName() - Method in class bb.common.CustomEmployeeVO

getName() - Method in class bb.common.CustomerVendorAddressInfoVO

getName() - Method in class bb.common.CustomerVendorAddressVO

getName() - Method in class bb.common.CustomerVendorContactVO

getName() - Method in class bb.common.CustomerVendorDescriptionVO

getName() - Method in class bb.common.CustomGoodsBreedVO

getName() - Method in class bb.common.CustomJobCategoryVO

getName() - Method in class bb.common.CustomSearchVO

getName() - Method in class bb.common.CV2CVAgent

getName() - Method in class bb.common.EngGroupVO

getName() - Method in class bb.common.GeneralLedgerCategoryVO

getName() - Method in class bb.common.GeneralLedgerListResult

getName() - Method in class bb.common.GeneralLedgerResult

getName() - Method in class bb.common.GeneralLedgerVO

getName() - Method in class bb.common.LabelTemplateItemVO

getName() - Method in class bb.common.LabelTemplateVO

getName() - Method in class bb.common.LockedCustomerAddressResult

getName() - Method in class bb.common.LogTaskVO

getName() - Method in class bb.common.MakeCheckAgent

getName() - Method in class bb.common.ManufacturerAddressInfoVO

getName() - Method in class bb.common.ManufacturerAddressVO

getName() - Method in class bb.common.ManufacturerContactVO

getName() - Method in class bb.common.ManufacturerDescriptionVO

getName() - Method in class bb.common.NonproductivePickingTypeVO

getName() - Method in class bb.common.OntimeDeliveryRateListResult

getName() - Method in class bb.common.PartCatagoryVO

getName() - Method in class bb.common.PartCatalogAuditResult

getName() - Method in class bb.common.PartCatalogVO

getName() - Method in class bb.common.SalesOrderItemCustomerTotalResult

getName() - Method in class bb.common.SGCartCheckOutResult

getName() - Method in class bb.common.SGCompanyVO

getName() - Method in class bb.common.SGCustRequestForQuoteListResult

getName() - Method in class bb.common.SGCustRequestForQuoteResult

getName() - Method in class bb.common.SGPartCatalogResult

getName() - Method in class bb.common.SGQuoteAddressResult

getName() - Method in class bb.common.SGQuoteAddressVO

getName() - Method in class bb.common.TaskVO

getName() - Method in class bb.common.VendorTotalAmountInPO

getName() - Method in class bb.common.WarehouseVO

getName() - Method in class bb.common.WorkInstructionApprovalVO

getNaRecTo() - Method in class bb.common.ReceiverItemAgent

getNativePlace() - Method in class bb.common.CustomEmployeeVO

getNcode() - Method in class bb.common.NcrReportListResult

getNCQsByNCCodeCount(String, Date, Date) - Method in interface bb.common.box.QualityBox

getNcr() - Method in class bb.common.NCRPartOnhandPK

getNcr() - Method in class bb.common.ReturnToVendorByDateListResult

getNcr() - Method in class bb.common.WorkOrderOverIssueListResult

getNcrApprovalByEmployeeId(NcrApprovalPK) - Method in interface bb.common.box.QualityBox

getNcrApprovalsCount(String) - Method in interface bb.common.box.QualityBox

getNcrDate() - Method in class bb.common.NcrNeedToScrapListResult

getNcrDate() - Method in class bb.common.NcrReportListResult

getNcrDate() - Method in class bb.common.NonConformanceReportVO

getNCRListByNCCodeCount(String, Date, Date) - Method in interface bb.common.box.QualityBox

getNcrNumber() - Method in class bb.common.AuditPartInQAResult

getNcrNumber() - Method in class bb.common.NcrNeedToScrapListResult

getNcrNumber() - Method in class bb.common.NCRPictureListResult

getNcrNumber() - Method in class bb.common.NCRPictureVO

getNcrNumber() - Method in class bb.common.NcrReportListResult

getNcrNumber() - Method in class bb.common.NcrScrapAgent

getNcrNumber() - Method in class bb.common.NonConformanceQuantityPK

getNcrNumber() - Method in class bb.common.NonConformanceReportVO

getNcrNumber() - Method in class bb.common.PartInQAAgent

getNcrNumber() - Method in class bb.common.PartInQAResult

getNcrNumber() - Method in class bb.common.PartInQAVO

getNcrNumber() - Method in class bb.common.RebackInQAAgent

getNcrNumber() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getNcrNumber() - Method in class bb.common.ReturnToVendorItemVO

getNcrNumber() - Method in class bb.common.RMAItemListResult

getNcrNumber() - Method in class bb.common.ScrapReportVO

getNcrNumber() - Method in class bb.common.ShipperItemDetailAgent

getNcrNumber() - Method in class bb.common.ShippingItemResult

getNCRPicture(Long) - Method in interface bb.common.box.QualityBox

getNCRPictureListResults(String) - Method in interface bb.common.box.QualityBox

getNcrPictures() - Method in class bb.common.NonConformanceReportVO

getNCRsCountByDate(String, String, String, String, String, String, String, String, String, Date, Date, String, String, String, String, String, String, String, String, String, String) - Method in interface bb.common.box.QualityBox

getNCRsCountByNcrNumber(String) - Method in interface bb.common.box.QualityBox

getNCRSCountByPart(PartPK) - Method in interface bb.common.box.QualityBox

getNcrScrapApprovedBy() - Method in class bb.common.AccountingConfigurationVO

getNcrStatus() - Method in class bb.common.AuditPartInQAResult

getNCRsToCreateScrapGlByDateCount(String, String, Date, Date, String) - Method in interface bb.common.box.QualityBox

getNdays() - Method in class bb.common.WCLoadAgent

getNdays() - Method in class bb.common.WorkCenterLoadAgent

getNeedCycleCountPartsCount(ArrayList<AuditOnDemandResult>) - Method in interface bb.common.box.WarehouseBox

getNeedQuoteSGCustRequestForQuoteListResultsCount(String) - Method in interface bb.common.box.SalesBox

getNeedtoApproveGL(String, String) - Method in interface bb.common.box.AccountingBox

getNeedtoCancelApprovedGL(String, String) - Method in interface bb.common.box.AccountingBox

getNeedtoCancelPostGL(String, String, String, String) - Method in interface bb.common.box.AccountingBox

getNeedtoPostGL(String, String, String, String) - Method in interface bb.common.box.AccountingBox

getNegativePartOnhandResultsCount(String, String, String) - Method in interface bb.common.box.WarehouseBox

getNetBookValue() - Method in class bb.common.AssetAddOrDisposalsReport

getNetProfit() - Method in class bb.common.ClosingStatementResult

getNetProfit() - Method in class bb.common.ProfitLossStatementResult

getNetProfitBeforeOtherIncome() - Method in class bb.common.ClosingStatementResult

getNetProfitBeforeWriteOffs() - Method in class bb.common.ClosingStatementResult

getNetProfiteBeforeIncomeTax() - Method in class bb.common.ClosingStatementResult

getNetSalvage() - Method in class bb.common.AssetAddOrDisposalsReport

getNetSalvage() - Method in class bb.common.AssetDepreciateDetailReport

getNetSalvage() - Method in class bb.common.AssetDepreciateVO

getNetSalvage() - Method in class bb.common.AssetReportSumResult

getNetSalvage() - Method in class bb.common.AssetVO

getNetTaxableSales() - Method in class bb.common.ZipcodeTotalsResult

getNetTotal() - Method in class bb.common.ArCommissionTotalResult

getNetTotal() - Method in class bb.common.ArSalesCodeTotalListResult

getNetTotal() - Method in class bb.common.RunningAccountOrderItemVO

getNetTotal() - Method in class bb.common.RunningAccountOrderVO

getNetValue() - Method in class bb.common.AssetVO

getNetWeight() - Method in class bb.common.PackingBoxVO

getNetWeight() - Method in class bb.common.PrPackingBoxVO

getNewAvgHrs() - Method in class bb.common.WorkInstructionSeqAuditListResult

getNewCost() - Method in class bb.common.InventoryAdjustmentVO

getNewCost() - Method in class bb.common.LogInventoryListResult

getNewCost() - Method in class bb.common.LogInventoryVO

getNewEngGroup() - Method in class bb.common.PartBasicInfoWithNewEngGroup

getNewInQA() - Method in class bb.common.LogInventoryListResult

getNewInQA() - Method in class bb.common.LogInventoryVO

getNewInTO() - Method in class bb.common.LogInventoryListResult

getNewListPrice() - Method in class bb.common.PartBasicInfoWithNewListPrice

getNewLnQty() - Method in class bb.common.InventoryReportListResult

getNewLocation() - Method in class bb.common.CycleCountListResult

getNewLocation() - Method in class bb.common.CycleCountVO

getNewLocation() - Method in class bb.common.PhysicalInventoryListResult

getNewLocation() - Method in class bb.common.PhysicalInventoryVO

getNewOnhand() - Method in class bb.common.AddPhysicalInventoryAgent

getNewOnhand() - Method in class bb.common.BB2PartByDateResult

getNewOnhand() - Method in class bb.common.CycleCountListResult

getNewOnhand() - Method in class bb.common.CycleCountVO

getNewOnhand() - Method in class bb.common.LogInventoryListResult

getNewOnhand() - Method in class bb.common.LogInventoryVO

getNewOnhand() - Method in class bb.common.PhysicalInventoryListResult

getNewOnhand() - Method in class bb.common.PhysicalInventoryVO

getNewOnhand() - Method in class bb.common.StockTransactionAdjustmentResult

getNewOnhandQty() - Method in class bb.common.InventoryAdjustmentVO

getNewPart() - Method in class bb.common.PartTraceableListResult

getNewPart() - Method in class bb.common.PartVO

getNewPart() - Method in class bb.common.PartWithOnhandsVO

getNewPartNumber() - Method in class bb.common.BillLogVO

getNewPartQuantity() - Method in class bb.common.BillLogVO

getNewPartType() - Method in class bb.common.BillLogVO

getNewQaQty() - Method in class bb.common.InventoryReportListResult

getNewQtyPicked() - Method in class bb.common.PartTrackingVO

getNewQuoteItemNumber(String) - Method in interface bb.common.box.SalesBox

getNewRev() - Method in class bb.common.EngineeringChangeVO

getNewRevision() - Method in class bb.common.EngineeringChangeListResult

getNewSalesOrderItemNumber(String) - Method in interface bb.common.box.SalesBox

getNewShipListDescription() - Method in class bb.common.ShipListAgent

getNewSip() - Method in class bb.common.LogInventoryListResult

getNewSip() - Method in class bb.common.LogInventoryVO

getNewSipQty() - Method in class bb.common.InventoryReportListResult

getNewSit() - Method in class bb.common.LogInventoryListResult

getNewSit() - Method in class bb.common.LogInventoryVO

getNewSitQty() - Method in class bb.common.InventoryReportListResult

getNewSparePart() - Method in class bb.common.BillLogVO

getNewStdCost() - Method in class bb.common.ChangeStdCostWorkSheetItemVO

getNewTotal() - Method in class bb.common.PhysicalInventoryListWithAppDataResult

getNewTotalCost() - Method in class bb.common.BB2PartByDateResult

getNewWip() - Method in class bb.common.LogInventoryListResult

getNewWip() - Method in class bb.common.LogInventoryVO

getNext12MonthPoShipAmount() - Method in interface bb.common.box.PurchasingBox

getNext12MonthSoShipAmount() - Method in interface bb.common.box.SalesBox

getNextCycleCount() - Method in class bb.common.PartClassVO

getNextCycleWorkSheetNumber() - Method in interface bb.common.box.WarehouseBox

getNextEmployeeId(boolean) - Method in interface bb.common.box.HumanResourceBox

getNextInspection() - Method in class bb.common.ToolCalibrationVO

getNextItemNumber(String, int, boolean) - Static method in class bb.common.BB2Util

getNextMonthYearMonth(String) - Static method in class bb.common.YearMonthManager

getNextPackingBoxNumber(ProformaInvoiceVO) - Method in interface bb.common.box.WarehouseBox

getNextPhysicalWorkSheetNumber() - Method in interface bb.common.box.WarehouseBox

getNextScheduledMaintenanceDate() - Method in class bb.common.EquipmentListResult

getNextScheduledMaintenanceDate() - Method in class bb.common.EquipmentVO

getNextWorkOrderItemIssueItemNumber(WorkOrderItemPK) - Method in interface bb.common.box.WorkOrderBox

getNextWorkOrderWorkSheetItemNumber(WorkOrderWorkSheetVO) - Method in interface bb.common.box.WorkOrderBox

getNextWorkOrderWorkSheetNumber(String) - Method in interface bb.common.box.WorkOrderBox

getNnAr() - Method in class bb.common.AccountReceivablePaymentVO

getNonConformanceCode() - Method in class bb.common.NCQRejectResult

getNonConformanceCode() - Method in class bb.common.NonConformanceQuantityVO

getNonConformanceCodeName() - Method in class bb.common.NonConformanceQuantityVO

getNonConformanceQuantity() - Method in class bb.common.NonConformanceReportVO

getNonConformanceReport() - Method in class bb.common.NonConformanceQuantityVO

getNonIssueQty() - Method in class bb.common.DisassembleWorkOrderItemListResult

getNonIssueQty() - Method in class bb.common.WorkOrderItemListResult

getNonproductivePickingApprovalByPk(String) - Method in interface bb.common.box.WarehouseBox

getNonproductivePickingByPk(String) - Method in interface bb.common.box.WarehouseBox

getNonproductivePickingIssuedItemsCount(Date, Date, String, String, String, String, String, String, String, String[], String) - Method in interface bb.common.box.WarehouseBox

getNonproductivePickingIssueTotalResult(Date, Date, String, String, String, String, String, String, String[], String) - Method in interface bb.common.box.WarehouseBox

getNonproductivePickingItemIssuedTotal(String) - Method in interface bb.common.box.WarehouseBox

getNonproductivePickingItemResultsCount(String, String, String, String, Date, Date, String, String, String, String) - Method in interface bb.common.box.WarehouseBox

getNonproductivePickingsCount(String, String, String, String, Date, Date, String) - Method in interface bb.common.box.WarehouseBox

getNonproductivePickingShippingResult(String) - Method in interface bb.common.box.WarehouseBox

getNonproPickingOnDemandList() - Method in class bb.common.MrpItemResult

getNoPayAmount() - Method in class bb.common.PurchaseOrderContractResult

getNormalSubInQuery(String) - Static method in class bb.common.BB2Util

getNoStorageAmount() - Method in class bb.common.PurchaseOrderContractResult

getNotApprovedOperatingInstructionsCount() - Method in interface bb.common.box.ManufacturingBox

getNotApproveEcnCount() - Method in class bb.common.EngineeringInfoCenterResult

getNotAsmQty() - Method in class bb.common.WCLoadDetailResult

getNotBillPartsWithOnhandInfoCount(String, String, String) - Method in interface bb.common.box.EngineeringBox

getNotCompletedQty() - Method in class bb.common.WorkCenterRunTimeListResult

getNotCompletedSeqBefore() - Method in class bb.common.WCLoadDetailResult

getNotCompletedSeqWithPOBefore() - Method in class bb.common.WCLoadDetailResult

getNote() - Method in class bb.common.InspectionTypeVO

getNote() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getNote() - Method in class bb.common.NonproductivePickingItemIssuedVO

getNote() - Method in class bb.common.PartIssuedVO

getNote() - Method in class bb.common.PartReceivedVO

getNotedBy() - Method in class bb.common.PreventiveActionRequestVO

getNotes() - Method in class bb.common.AccountsPayableInfoVO

getNotes() - Method in class bb.common.AccountsPayableItemVO

getNotes() - Method in class bb.common.AccountsPayableVO

getNotes() - Method in class bb.common.DisassembleWorkOrderItemListResult

getNotes() - Method in class bb.common.GeneralLedgerListResult

getNotes() - Method in class bb.common.GeneralLedgerVO

getNotes() - Method in class bb.common.NonproductivePickingItemResult

getNotes() - Method in class bb.common.NonproductivePickingItemVO

getNotes() - Method in class bb.common.NonproductivePickingVO

getNotes() - Method in class bb.common.OnloanReceiverItemListResult

getNotes() - Method in class bb.common.OnloanReceiverListResult

getNotes() - Method in class bb.common.PosZipCodeTaxVO

getNotes() - Method in class bb.common.ProformaInvoiceVO

getNotes() - Method in class bb.common.PurchaseOrderOnOrderResult

getNotes() - Method in class bb.common.RMAReceiverItemListResult

getNotes() - Method in class bb.common.RMAReceiverItemVO

getNotes() - Method in class bb.common.RMAReceiverListResult

getNotes() - Method in class bb.common.RMAReceiverVO

getNotes() - Method in class bb.common.RtvShipperInfoVO

getNotes() - Method in class bb.common.RtvShipperItemListResult

getNotes() - Method in class bb.common.RtvShipperItemVO

getNotes() - Method in class bb.common.RtvShipperListResult

getNotes() - Method in class bb.common.RtvShipperVO

getNotes() - Method in class bb.common.RunningAccountOrderItemResult

getNotes() - Method in class bb.common.RunningAccountOrderVO

getNotes() - Method in class bb.common.SwapOrderListResult

getNotes() - Method in class bb.common.SwapOrderVO

getNotes() - Method in class bb.common.SwapReceiverListResult

getNotes() - Method in class bb.common.SwapReceiverVO

getNotes() - Method in class bb.common.SwapShipperListResult

getNotes() - Method in class bb.common.SwapShipperVO

getNotes() - Method in class bb.common.WorkOrderItemListResult

getNoticeReceiveGap() - Method in class bb.common.CompanyVO

getNoticeReceivers() - Method in class bb.common.TaskVO

getNoticeText() - Method in class bb.common.BB2Notice

getNoticeUserEmployeeCount(String, String, String) - Method in interface bb.common.box.CompanyBox

getNotRecItemsOnTimeQty() - Method in class bb.common.PurchaseOrderOnTimeItemResult

getNotRecItemsOnTimeQty() - Method in class bb.common.WorkOrderOnTimeItemResult

getNotRecTotalOnTime() - Method in class bb.common.PurchaseOrderOnTimeItemResult

getNotRecTotalOnTime() - Method in class bb.common.WorkOrderOnTimeItemResult

getNotReviewedOnDemandQty() - Method in class bb.common.MrpItemResult

getNotReviewedOnOrderQty() - Method in class bb.common.MrpItemResult

getNotReviewedWorkOrderItemReviewCostResultsCount(String, String, String, Date, Date) - Method in interface bb.common.box.WorkOrderBox

getNotSetupWorkOrderItemListResultsCount(String) - Method in interface bb.common.box.WorkOrderBox

getNotSetupWorkOrderItemListResultsCount(String, boolean) - Method in interface bb.common.box.WorkOrderBox

getNotShippedOnTimeQty() - Method in class bb.common.SalesOrderOnTimeItemResult

getNotShippedOnTimeTotal() - Method in class bb.common.SalesOrderOnTimeItemResult

getNotShippedQty() - Method in class bb.common.SalesOrderItemGroupByPartListResult

getNpDetails() - Method in class bb.common.BB2PartTotalOndemandDetailResult

getNudeSighRight() - Method in class bb.common.CustomCheckUpEmployeeVO

getNudeSightLeft() - Method in class bb.common.CustomCheckUpEmployeeVO

getNumberOfAPs() - Method in class bb.common.AccountPayableCheckVO

getNumberString(Object) - Static method in class bb.common.BB2Util

getNumOfItems() - Method in class bb.common.PartIssueTotalResult

getNumOfItems() - Method in class bb.common.SalesOrderItemCustomerTotalResult

getNumOfMissingItems() - Method in class bb.common.SalesOrderItemCostResult

getObjectBeanValue(Object, String) - Static method in class bb.common.BB2Util

getObjectBeanValue(Class, String) - Static method in class bb.common.BB2Util

getObjectParam(String) - Static method in class bb.common.BB2Util

getObsoleteEcnCount() - Method in class bb.common.EngineeringInfoCenterResult

getOCode() - Method in class bb.common.PartInventoryVO

getOCode() - Method in class bb.common.ToolInventoryVO

getOfBoxNumber() - Method in class bb.common.ShipperItemDetailAgent

getOffsetUnbilledGLNumber() - Method in class bb.common.ShipperItemVO

getOIPrincipal() - Method in interface bb.common.box.ManufacturingBox

getOldAvgCost() - Method in class bb.common.PhysicalInventoryListResult

getOldAvgHrs() - Method in class bb.common.WorkInstructionSeqAuditListResult

getOldCost() - Method in class bb.common.InventoryAdjustmentVO

getOldCost() - Method in class bb.common.LogInventoryListResult

getOldCost() - Method in class bb.common.LogInventoryVO

getOldFileName() - Method in class bb.common.PartDwfAgent

getOldId() - Method in class bb.common.CV2CVAgent

getOldInQA() - Method in class bb.common.LogInventoryListResult

getOldInQA() - Method in class bb.common.LogInventoryVO

getOldInTO() - Method in class bb.common.LogInventoryListResult

getOldLnQty() - Method in class bb.common.InventoryReportListResult

getOldOnhand() - Method in class bb.common.BB2PartByDateResult

getOldOnhand() - Method in class bb.common.LogInventoryListResult

getOldOnhand() - Method in class bb.common.LogInventoryVO

getOldOnhand() - Method in class bb.common.StockTransactionAdjustmentResult

getOldOnhandQty() - Method in class bb.common.InventoryAdjustmentVO

getOldOnloanQty() - Method in class bb.common.PhysicalInventoryListResult

getOldQaQty() - Method in class bb.common.InventoryReportListResult

getOldRev() - Method in class bb.common.EngineeringChangeVO

getOldRevision() - Method in class bb.common.EngineeringChangeListResult

getOldSip() - Method in class bb.common.LogInventoryListResult

getOldSip() - Method in class bb.common.LogInventoryVO

getOldSip() - Method in class bb.common.PhysicalInventoryListResult

getOldSipQty() - Method in class bb.common.InventoryReportListResult

getOldSit() - Method in class bb.common.LogInventoryListResult

getOldSit() - Method in class bb.common.LogInventoryVO

getOldSitQty() - Method in class bb.common.InventoryReportListResult

getOldStadCost() - Method in class bb.common.PhysicalInventoryListResult

getOldTotalCost() - Method in class bb.common.BB2PartByDateResult

getOldWip() - Method in class bb.common.LogInventoryListResult

getOldWip() - Method in class bb.common.LogInventoryVO

getOldWorkCenterId() - Method in class bb.common.WC2WCAgent

getOndemand() - Method in class bb.common.BB2PartInfo

getOndemand() - Method in class bb.common.BB2PartOnDemandListResult

getOndemand() - Method in class bb.common.BillItemOnHandUsageResult

getOndemand() - Method in class bb.common.BillItemOnHandWithPartInfoResult

getOndemand() - Method in class bb.common.BillOnHandWithPartInfoResult

getOndemand() - Method in class bb.common.BillWhereUsedResult

getOndemand() - Method in class bb.common.BOMCanAssyListResult

getOndemand() - Method in class bb.common.DisassembleWorkOrderItemPartDetailItemResult

getOndemand() - Method in class bb.common.EcnPOOrderResult

getOndemand() - Method in class bb.common.EcnWOOrderResult

getOnDemand() - Method in class bb.common.InventoryListResult

getOndemand() - Method in class bb.common.IssuingItemResult

getOndemand() - Method in class bb.common.PartOnHandWithMfgInfoResult

getOnDemand() - Method in class bb.common.PartWhereUsedItemResult

getOnDemand() - Method in class bb.common.PartWithExcessiveInventoryListResult

getOndemand() - Method in class bb.common.PartWithInventoryInfoListResult

getOnDemand() - Method in class bb.common.SalesOrderItemGroupByPartListResult

getOndemand() - Method in class bb.common.StockTransactionPartInfoResult

getOndemand() - Method in class bb.common.WOItemPartDetailNotIssue

getOndemand() - Method in class bb.common.WorkOrderItemPartDetailItemResult

getOndemandByAvgCost() - Method in class bb.common.InventoryTotalResult

getOndemandByStdCost() - Method in class bb.common.InventoryTotalResult

getOnDemandInSO() - Method in class bb.common.SalesOrderItemGroupByPartListResult

getOnDemandQty() - Method in class bb.common.BB2PartInventoryResult

getOnDemandQty() - Method in class bb.common.CRTVItemListResult

getOnDemandQty() - Method in class bb.common.HistoricalInventoryVO

getOnDemandQty() - Method in class bb.common.MrpItemResult

getOnDemandQty() - Method in class bb.common.OnLoanItemListResult

getOnDemandQty() - Method in class bb.common.PartInventoryVO

getOnDemandQty() - Method in class bb.common.PartOnHandWithPartBasicInfoResult

getOnDemandQty() - Method in class bb.common.PurchaseOrderItemListResult

getOnDemandQty() - Method in class bb.common.PurchaseOrderOpenDueListResult

getOnDemandQty() - Method in class bb.common.QuoteItemListResult

getOnDemandQty() - Method in class bb.common.RMAItemListResult

getOnDemandQty() - Method in class bb.common.RRMAItemListResult

getOnDemandQty() - Method in class bb.common.SalesOrderItemListResult

getOnDemandQty() - Method in class bb.common.ToolInventoryVO

getOneLocations() - Method in class bb.common.ReceiverItemAgent

getOneLocations() - Method in class bb.common.ShipperItemAgent

getOnhand() - Method in class bb.common.BB2PartInfo

getOnhand() - Method in class bb.common.BB2PartInventoryResult

getOnhand() - Method in class bb.common.BB2PartOnDemandListResult

getOnhand() - Method in class bb.common.BillItemOnHandUsageResult

getOnhand() - Method in class bb.common.BillItemOnHandWithPartInfoResult

getOnHand() - Method in class bb.common.BillItemReplacementVO

getOnhand() - Method in class bb.common.BillOnHandWithPartInfoResult

getOnhand() - Method in class bb.common.BillWhereUsedItemResult

getOnhand() - Method in class bb.common.BillWhereUsedResult

getOnhand() - Method in class bb.common.BOMCanAssyListResult

getOnhand() - Method in class bb.common.BomPickListItemResult

getOnHand() - Method in class bb.common.ChangeStdCostWorkSheetItemVO

getOnhand() - Method in class bb.common.CycleCountVO

getOnhand() - Method in class bb.common.DisassembleWorkOrderItemPartDetailItemResult

getOnhand() - Method in class bb.common.EcnPOOrderResult

getOnhand() - Method in class bb.common.EcnWOOrderResult

getOnhand() - Method in class bb.common.HistoricalInventoryVO

getOnhand() - Method in class bb.common.InSipAudittListResult

getOnhand() - Method in class bb.common.InventoryCycleItemResult

getOnhand() - Method in class bb.common.InventoryListResult

getOnhand() - Method in class bb.common.InventoryNotUsedInMonthsResult

getOnhand() - Method in class bb.common.PartInventoryVO

getOnhand() - Method in class bb.common.PartMaterialWhereUsedItemResult

getOnhand() - Method in class bb.common.PartOnHandAuditResult

getOnhand() - Method in class bb.common.PartOnhandCostVO

getOnhand(String) - Method in class bb.common.PartOnhandResult

getOnhand() - Method in class bb.common.PartOnHandWithMfgInfoResult

getOnhand() - Method in class bb.common.PartOnHandWithPartBasicInfoResult

getOnhand() - Method in class bb.common.PartWhereUsedItemResult

getOnHand() - Method in class bb.common.PartWithExcessiveInventoryListResult

getOnhand() - Method in class bb.common.PartWithInventoryInfoListResult

getOnhand() - Method in class bb.common.PartWithoutLocateResult

getOnHand() - Method in class bb.common.PartWithQAQtyListResult

getOnHand() - Method in class bb.common.PartWithQtyListResult

getOnHand() - Method in class bb.common.PartWithSipQtyListResult

getOnHand() - Method in class bb.common.PartWithSITQtyListResult

getOnHand() - Method in class bb.common.PartWithSTOQtyListResult

getOnHand() - Method in class bb.common.PartWithWipQtyListResult

getOnhand() - Method in class bb.common.PhysicalInventoryVO

getOnHand() - Method in class bb.common.RollUpBomStdCostWorkSheetItemVO

getOnhand() - Method in class bb.common.SalesOrderItemGroupByPartListResult

getOnhand() - Method in class bb.common.SGBOMItemResult

getOnhand() - Method in class bb.common.ShipListItemRelatedDocResult

getOnhand() - Method in class bb.common.ShippingItemResult

getOnhand() - Method in class bb.common.StockTransactionPartInfoResult

getOnhand() - Method in class bb.common.ToolInventoryVO

getOnhand() - Method in class bb.common.ToolWhereUsedItemResult

getOnhand() - Method in class bb.common.WOItemPartDetailNotIssue

getOnhand() - Method in class bb.common.WoItemPickListItemResult

getOnhand() - Method in class bb.common.WorkOrderItemPartDetailItemResult

getOnhandLocation() - Method in class bb.common.BillItemOnHandUsageResult

getOnhandLocation() - Method in class bb.common.BillItemOnHandWithPartInfoResult

getOnHandLocations() - Method in class bb.common.PartWithOnhandsVO

getOnHandLocations() - Method in class bb.common.ToolWithOnhandsVO

getOnhandQty() - Method in class bb.common.AuditOnDemandResult

getOnhandQty() - Method in class bb.common.CRTVItemListResult

getOnhandQty() - Method in class bb.common.OnLoanItemListResult

getOnHandQty() - Method in class bb.common.PurchaseOrderItemListResult

getOnhandQty() - Method in class bb.common.PurchaseOrderOpenDueListResult

getOnhandQty() - Method in class bb.common.QuoteItemListResult

getOnhandQty() - Method in class bb.common.RMAItemListResult

getOnhandQty() - Method in class bb.common.RRMAItemListResult

getOnHandQty() - Method in class bb.common.SalesOrderItemListResult

getOnHandQuantity() - Method in class bb.common.PartOnhandVO

getOnHandQuantity() - Method in class bb.common.ToolOnhandVO

getOnhandTotal() - Method in class bb.common.PartOnHandAuditResult

getOnlineUsersCountByUserName(String) - Method in interface bb.common.box.SecurityBox

getOnLoan() - Method in class bb.common.InventoryListResult

getOnLoan() - Method in class bb.common.PartOnhandResult

getOnLoanByLoanNumber(String) - Method in interface bb.common.box.WarehouseBox

getOnloanControlByEmoloyeeTrueName(String) - Method in interface bb.common.box.WarehouseBox

getOnloanControlByEmployeeId(String) - Method in interface bb.common.box.WarehouseBox

getOnloanControlCountByUserTrueNameLike(String) - Method in interface bb.common.box.WarehouseBox

getOnloanDocumentByID(Long) - Method in interface bb.common.box.ManufacturingBox

getOnLoanDocuments() - Method in class bb.common.OnLoanVO

getOnLoanItems() - Method in class bb.common.OnLoanVO

getOnLoanItemsCountByDate(PartPK, String, String, String, boolean, Date, Date) - Method in interface bb.common.box.WarehouseBox

getOnloanNumber() - Method in class bb.common.OnloanDocumentVO

getOnloanQty() - Method in class bb.common.HistoricalInventoryVO

getOnloanQty() - Method in class bb.common.PartInventoryVO

getOnLoanQty() - Method in class bb.common.PartWithOnLoanQtyListResult

getOnloanQty() - Method in class bb.common.PhysicalInventoryVO

getOnloanQty() - Method in class bb.common.ToolInventoryVO

getOnloanReceiver(String) - Method in interface bb.common.box.WarehouseBox

getOnloanReceiverItemByPk(OnloanReceiverItemPK) - Method in interface bb.common.box.WarehouseBox

getOnloanReceiverItemListResultsCountByCustID(String) - Method in interface bb.common.box.WarehouseBox

getOnloanReceiverItemListResultsCountByLnShipperNumber(String) - Method in interface bb.common.box.WarehouseBox

getOnloanReceiverItemListResultsCountByOnloanReceiverNumber(String) - Method in interface bb.common.box.WarehouseBox

getOnloanReceiverItemListResultsCountByPartNumber(String, String) - Method in interface bb.common.box.WarehouseBox

getOnloanReceiverListResultsCountByCustID(String) - Method in interface bb.common.box.WarehouseBox

getOnloanReceiverListResultsCountByLnShipperNumber(String) - Method in interface bb.common.box.WarehouseBox

getOnloanReceiverListResultsCountByOnloanReceiverNumber(String) - Method in interface bb.common.box.WarehouseBox

getOnloanReceiversByLn(String) - Method in interface bb.common.box.WarehouseBox

getOnloanReceivingResult(String) - Method in interface bb.common.box.WarehouseBox

getOnLoansByLoanNumberCount(String) - Method in interface bb.common.box.WarehouseBox

getOnLoansByPoNumberCount(String) - Method in interface bb.common.box.WarehouseBox

getOnloanShipperById(String) - Method in interface bb.common.box.WarehouseBox

getOnloanShipperItemByPK(OnloanShipperItemPK) - Method in interface bb.common.box.WarehouseBox

getOnloanShipperItems() - Method in class bb.common.OnloanShipperVO

getOnloanShipperListResultsCountByCustomerId(String) - Method in interface bb.common.box.WarehouseBox

getOnloanShipperListResultsCountByLoanNumber(String) - Method in interface bb.common.box.WarehouseBox

getOnloanShipperListResultsCountByOnloanShipperNumber(String) - Method in interface bb.common.box.WarehouseBox

getOnloanShipperListResultsCountBySalesman(String) - Method in interface bb.common.box.WarehouseBox

getOnloanShippersCountByLn(String) - Method in interface bb.common.box.WarehouseBox

getOnLoanShippingResult(String) - Method in interface bb.common.box.WarehouseBox

getOnorder() - Method in class bb.common.BB2PartInfo

getOnorder() - Method in class bb.common.BB2PartOnDemandListResult

getOnorder() - Method in class bb.common.BillItemOnHandUsageResult

getOnorder() - Method in class bb.common.BillItemOnHandWithPartInfoResult

getOnorder() - Method in class bb.common.BillOnHandWithPartInfoResult

getOnorder() - Method in class bb.common.BillWhereUsedResult

getOnOrder() - Method in class bb.common.BOMCanAssyListResult

getOnorder() - Method in class bb.common.DisassembleWorkOrderItemPartDetailItemResult

getOnorder() - Method in class bb.common.EcnPOOrderResult

getOnorder() - Method in class bb.common.EcnWOOrderResult

getOnOrder() - Method in class bb.common.InventoryListResult

getOnorder() - Method in class bb.common.PartOnHandWithMfgInfoResult

getOnOrder() - Method in class bb.common.PartWhereUsedItemResult

getOnOrder() - Method in class bb.common.PartWithExcessiveInventoryListResult

getOnorder() - Method in class bb.common.PartWithInventoryInfoListResult

getOnOrder() - Method in class bb.common.SalesOrderItemGroupByPartListResult

getOnorder() - Method in class bb.common.StockTransactionPartInfoResult

getOnorder() - Method in class bb.common.WOItemPartDetailNotIssue

getOnorder() - Method in class bb.common.WorkOrderItemPartDetailItemResult

getOnorderAction() - Method in class bb.common.EngineeringChangeVO

getOnorderByAvgCost() - Method in class bb.common.InventoryTotalResult

getOnorderByStdCost() - Method in class bb.common.InventoryTotalResult

getOnorderModify() - Method in class bb.common.EngineeringChangeVO

getOnOrderQty() - Method in class bb.common.BB2PartInventoryResult

getOnorderQty() - Method in class bb.common.CRTVItemListResult

getOnOrderQty() - Method in class bb.common.HistoricalInventoryVO

getOnorderQty() - Method in class bb.common.OnLoanItemListResult

getOnOrderQty() - Method in class bb.common.PartInventoryVO

getOnOrderQty() - Method in class bb.common.PartOnHandWithPartBasicInfoResult

getOnOrderQty() - Method in class bb.common.PurchaseOrderItemListResult

getOnOrderQty() - Method in class bb.common.PurchaseOrderOpenDueListResult

getOnorderQty() - Method in class bb.common.QuoteItemListResult

getOnorderQty() - Method in class bb.common.RMAItemListResult

getOnorderQty() - Method in class bb.common.RRMAItemListResult

getOnOrderQty() - Method in class bb.common.SalesOrderItemListResult

getOnOrderQty() - Method in class bb.common.ToolInventoryVO

getOnorderScrap() - Method in class bb.common.EngineeringChangeVO

getOnorderUseAsIs() - Method in class bb.common.EngineeringChangeVO

getOnTimeDelivedItemCount() - Method in class bb.common.OntimeDeliveryRateListResult

getOnTimeDelivedItemCount() - Method in class bb.common.OntimeDeliveryRateResult

getOnTimeDeliveryRate() - Method in class bb.common.OntimeDeliveryRateListResult

getOnTimeDeliveryRate() - Method in class bb.common.OntimeDeliveryRateResult

getOntimeReceiverItemsof12MonthAvg() - Method in class bb.common.PurchaseOrderOnTimeResult

getOntimeReceiverItemsofFiscalYear() - Method in class bb.common.PurchaseOrderOnTimeResult

getOntimeReceiverItemsofLastMonth() - Method in class bb.common.PurchaseOrderOnTimeResult

getOntimeReceiverItemsofThisMonth() - Method in class bb.common.PurchaseOrderOnTimeResult

getOntimeReceiverItemsofYtd() - Method in class bb.common.PurchaseOrderOnTimeResult

getOntimeReceiverTotalOf12MonthAvg() - Method in class bb.common.PurchaseOrderOnTimeResult

getOntimeReceiverTotalOfFiscalYear() - Method in class bb.common.PurchaseOrderOnTimeResult

getOntimeReceiverTotalOfLastMonth() - Method in class bb.common.PurchaseOrderOnTimeResult

getOntimeReceiverTotalOfThisMonth() - Method in class bb.common.PurchaseOrderOnTimeResult

getOntimeReceiverTotalOfYtd() - Method in class bb.common.PurchaseOrderOnTimeResult

getOpCodeShortcutByUserName(String) - Method in interface bb.common.box.CompanyBox

getOpCodeShortcutPK() - Method in class bb.common.OpCodeShortcutVO

getOpenAPsByVendorIdCount(String) - Method in interface bb.common.box.AccountingBox

getOpenAPsCount() - Method in interface bb.common.box.AccountingBox

getOpenAPsCountByApNumber(String) - Method in interface bb.common.box.AccountingBox

getOpenARsByVendorIdCount(String, boolean) - Method in interface bb.common.box.AccountingBox

getOpenARsCount() - Method in interface bb.common.box.AccountingBox

getOpenARsTotalMoneyByVendor(String, boolean) - Method in interface bb.common.box.AccountingBox

getOpenCustomerFeedbackCount() - Method in interface bb.common.box.CustomerServiceBox

getOpenDate() - Method in class bb.common.CustomerServiceIncidentItemListResult

getOpenDate() - Method in class bb.common.CustomerServiceIncidentListResult

getOpenDate() - Method in class bb.common.CustomerServiceIncidentVO

getOpenDate() - Method in class bb.common.DesignControlInfoVO

getOpenDate() - Method in class bb.common.DesignControlListResult

getOpenDate() - Method in class bb.common.DesignControlVO

getOpenDCCount() - Method in interface bb.common.box.EngineeringBox

getOpenDisassembleWorkOrderItemListResultsByPartPkCount(PartPK) - Method in interface bb.common.box.WorkOrderBox

getOpenDisassembleWorkOrderListResultsByDwoNumberCount(String) - Method in interface bb.common.box.WorkOrderBox

getOpenDisassembleWorkOrderListResultsByVendorIdCount(String) - Method in interface bb.common.box.WorkOrderBox

getOpenEcnCount() - Method in class bb.common.EngineeringInfoCenterResult

getOpenEcrCount() - Method in class bb.common.EngineeringInfoCenterResult

getOpenECRequestsCount() - Method in interface bb.common.box.EngineeringBox

getOpenEdcCount() - Method in class bb.common.EngineeringInfoCenterResult

getOpenEngineeringChangesCount() - Method in interface bb.common.box.EngineeringBox

getOpenGlMonthCount() - Method in interface bb.common.box.AccountingBox

getOpenIcrsCount(String) - Method in interface bb.common.box.QualityBox

getOpenIncidentCount() - Method in interface bb.common.box.CustomerServiceBox

getOpenInvoiceItemsByPartPKCount(PartPK) - Method in interface bb.common.box.AccountingBox

getOpenManufacturerECRequestsCount() - Method in interface bb.common.box.ManufacturingBox

getOpenManufacturerEngineeringChangesCount() - Method in interface bb.common.box.ManufacturingBox

getOpenNcrCount() - Method in class bb.common.QualityInfoCenterResult

getOpenNCRsCount() - Method in interface bb.common.box.QualityBox

getOpenNCRsCountByPartPK(PartPK) - Method in interface bb.common.box.QualityBox

getOpenNotReviewedSalesOrdersCount(String) - Method in interface bb.common.box.SalesBox

getOpenOnLoansForShipperCount(String) - Method in interface bb.common.box.WarehouseBox

getOpenOnloanShipperForReceiverCount(String) - Method in interface bb.common.box.WarehouseBox

getOpenOperatingInstructionsCount() - Method in interface bb.common.box.ManufacturingBox

getOpenPARsCount() - Method in interface bb.common.box.QualityBox

getOpenPARsCountByDate(String, String, String, Date, Date) - Method in interface bb.common.box.QualityBox

getOpenPo() - Method in class bb.common.CashFlowByMonthReportResult

getOpenPOReceiverItemsCountByPartPK(PartPK) - Method in interface bb.common.box.WarehouseBox

getOpenPos() - Method in class bb.common.TwelveMonthCashFlowReportResult

getOpenProformaInvoiceListResultsCountByPfNumber() - Method in interface bb.common.box.WarehouseBox

getOpenPurchaseAccount() - Method in class bb.common.PurchasingInfoCenterResult

getOpenPurchaseOrderCount(String) - Method in interface bb.common.box.PurchasingBox

getOpenPurchaseOrderCountByAddressId(String) - Method in interface bb.common.box.ManufacturingBox

getOpenPurchaseOrderCountByAddressId(String) - Method in interface bb.common.box.PurchasingBox

getOpenPurchaseOrderCountByBuyer(String) - Method in interface bb.common.box.PurchasingBox

getOpenPurchaseOrderCountsByProjectLike(String) - Method in interface bb.common.box.PurchasingBox

getOpenPurchaseOrderCountsByRequesterLike(String) - Method in interface bb.common.box.PurchasingBox

getOpenPurchaseOrderForReceiverCount(String) - Method in interface bb.common.box.PurchasingBox

getOpenPurchaseOrderItemByShipVia(String, String) - Method in interface bb.common.box.PurchasingBox

getOpenPurchaseOrderItemByShipViaTotal(String, String) - Method in interface bb.common.box.PurchasingBox

getOpenPurchaseOrderItemCount() - Method in interface bb.common.box.ManufacturingBox

getOpenPurchaseOrderItemCount() - Method in interface bb.common.box.PurchasingBox

getOpenPurchaseOrderItemCountByBuyerCode(String) - Method in interface bb.common.box.PurchasingBox

getOpenPurchaseOrderItemCountByPartPk(PartPK) - Method in interface bb.common.box.PurchasingBox

getOpenPurchaseOrderItemsCountByAddressId(String, String) - Method in interface bb.common.box.PurchasingBox

getOpenPurchaseOrderNotAcknowledged() - Method in interface bb.common.box.PurchasingBox

getOpenPurchaseOrdertRelatedDocCount(String, String) - Method in interface bb.common.box.PurchasingBox

getOpenPurchaseOrderwithPrepayCount(String) - Method in interface bb.common.box.PurchasingBox

getOpenQuoteItemCountByAddressId(String) - Method in interface bb.common.box.SalesBox

getOpenQuoteItemCountByPartPk(PartPK) - Method in interface bb.common.box.SalesBox

getOpenQuotesCountByAddressId(String) - Method in interface bb.common.box.SalesBox

getOpenReceiversCountByRn(String) - Method in interface bb.common.box.WarehouseBox

getOpenRequestForQuoteItemListResultsCount() - Method in interface bb.common.box.ManufacturingBox

getOpenRequestForQuoteItemListResultsCount() - Method in interface bb.common.box.PurchasingBox

getOpenReturnToVendorItemListResultsCount() - Method in interface bb.common.box.ManufacturingBox

getOpenReturnToVendorItemListResultsCount() - Method in interface bb.common.box.PurchasingBox

getOpenReturnToVendorListResultsCountByRtvNumber(String) - Method in interface bb.common.box.PurchasingBox

getOpenRFCCount() - Method in interface bb.common.box.ManufacturingBox

getOpenRMAsCount(String) - Method in interface bb.common.box.SalesBox

getOpenRMAsCountByPartPk(PartPK) - Method in interface bb.common.box.SalesBox

getOpenSaleOrderItemByPartPkCount(PartPK) - Method in interface bb.common.box.SalesBox

getOpenSalesAccount() - Method in class bb.common.SalesInfoCenterResult

getOpenSalesOrderItemCustomerTotalResultsByCustomerId(String) - Method in interface bb.common.box.SalesBox

getOpenSalesOrdersCountByAddressId(String) - Method in interface bb.common.box.SalesBox

getOpenSalesOrdersForShippingCountBySoNumber(String) - Method in interface bb.common.box.SalesBox

getOpenSalesOrderWithPrepayCount(String) - Method in interface bb.common.box.SalesBox

getOpenSGCustomerServiceRequestsCount() - Method in interface bb.common.box.SalesBox

getOpenShipViaSalesOrderItemsCount(String, String, String, String, String) - Method in interface bb.common.box.SalesBox

getOpenShortageSalesOrderItemsCount(String, String, String, String) - Method in interface bb.common.box.SalesBox

getOpenSo() - Method in class bb.common.CashFlowByMonthReportResult

getOpenSo() - Method in class bb.common.TwelveMonthCashFlowReportResult

getOpenSoSum() - Method in class bb.common.SalesInfoCenter

getOpenSwapOrderCount(String) - Method in interface bb.common.box.PurchasingBox

getOpenSwapOrderForShipperCount(String) - Method in interface bb.common.box.WarehouseBox

getOpenTimeCardsCountByEmployeeLike(String) - Method in interface bb.common.box.ManufacturingBox

getOpenTimeCardsCountById(String) - Method in interface bb.common.box.ManufacturingBox

getOpenTotal() - Method in class bb.common.AccountingTotalMoneyResult

getOpenTotal() - Method in class bb.common.DuePATotalByVendorResult

getOpenTransferOrderForShipperCount(String) - Method in interface bb.common.box.WarehouseBox

getOpenUnHoldWorkOrderItemListResultsCount(String, String, String, boolean) - Method in interface bb.common.box.WorkOrderBox

getOpenWOAccount() - Method in class bb.common.WorkOrderInfoCenterResult

getOpenWOCount() - Method in class bb.common.WorkOrderInfoCenterResult

getOpenWorkInstructionsCount() - Method in interface bb.common.box.ManufacturingBox

getOpenWorkOrderCountByVendorId(String) - Method in interface bb.common.box.WorkOrderBox

getOpenWorkOrderItemListResultsByPartPkCount(PartPK) - Method in interface bb.common.box.WorkOrderBox

getOpenWorkOrderItemListResultsCount() - Method in interface bb.common.box.WorkOrderBox

getOpenWorkOrderItemListResultsCount(String, String, String) - Method in interface bb.common.box.WorkOrderBox

getOpenWorkOrderListResultsByWoNumberCount(String) - Method in interface bb.common.box.WorkOrderBox

getOpenWorkOrderListResultsCount(String) - Method in interface bb.common.box.WorkOrderBox

getOperateCode() - Method in class bb.common.OpCodeShortcutPK

getOperatingExpenseItems() - Method in class bb.common.ClosingStatementResult

getOperatingExpenses() - Method in class bb.common.ClosingStatementResult

getOperatingInstructions(String) - Method in interface bb.common.box.ManufacturingBox

getOperatingInstructionsCanCloseCount() - Method in interface bb.common.box.ManufacturingBox

getOperatingInstructionsCount(String, String, String, String, String, String, String, String, String) - Method in interface bb.common.box.ManufacturingBox

getOperatingInstructionsDescription() - Method in class bb.common.OperatingInstructionsUserStatisticalResult

getOperatingInstructionsDescription() - Method in class bb.common.OperatingInstructionsVO

getOperatingInstructionsInspectMethod() - Method in class bb.common.OperatingInstructionsInspectMethodItemVO

getOperatingInstructionsInspectMethodItems() - Method in class bb.common.OperatingInstructionsVO

getOperatingInstructionsInspectResultItems() - Method in class bb.common.OperatingInstructionsVO

getOperatingInstructionsInspectStandard(int) - Method in interface bb.common.box.ManufacturingBox

getOperatingInstructionsInspectStandard() - Method in class bb.common.OperatingInstructionsInspectStandardItemVO

getOperatingInstructionsInspectStandardItems() - Method in class bb.common.OperatingInstructionsVO

getOperatingInstructionsManual(int) - Method in interface bb.common.box.ManufacturingBox

getOperatingInstructionsManual() - Method in class bb.common.OperatingInstructionsManualItemVO

getOperatingInstructionsManuals() - Method in class bb.common.OperatingInstructionsVO

getOperatingInstructionsNotes() - Method in class bb.common.OperatingInstructionsVO

getOperatingInstructionsNumber() - Method in class bb.common.InspectionReportInfoVO

getOperatingInstructionsNumber() - Method in class bb.common.InspectionReportVO

getOperatingInstructionsNumber() - Method in class bb.common.OperatingInstructionsInspectMethodItemPK

getOperatingInstructionsNumber() - Method in class bb.common.OperatingInstructionsInspectResultItemPK

getOperatingInstructionsNumber() - Method in class bb.common.OperatingInstructionsInspectStandardItemPK

getOperatingInstructionsNumber() - Method in class bb.common.OperatingInstructionsManualItemPK

getOperatingInstructionsNumber() - Method in class bb.common.OperatingInstructionsUserStatisticalResult

getOperatingInstructionsNumber() - Method in class bb.common.OperatingInstructionsVO

getOperatingInstructionsNumber() - Method in class bb.common.OperatingOutputFileItemPK

getOperatingInstructionsType(int) - Method in interface bb.common.box.ManufacturingBox

getOperatingInstructionsType() - Method in class bb.common.InspectionReportInfoVO

getOperatingInstructionsType() - Method in class bb.common.InspectionReportVO

getOperatingInstructionsType() - Method in class bb.common.OperatingInstructionsVO

getOperatingInstructionsTypeDescription() - Method in class bb.common.OperatingInstructionsUserStatisticalResult

getOperatingInstructionsTypeId() - Method in class bb.common.InspectionItemPK

getOperatingInstructionsTypeId() - Method in class bb.common.InspectionReportInfoVO

getOperatingInstructionsTypeId() - Method in class bb.common.InspectionReportVO

getOperatingInstructionsTypeId() - Method in class bb.common.OperatingInstructionsVO

getOperatingInstructionsUserStatisticalCount(String, String, String) - Method in interface bb.common.box.ManufacturingBox

getOperatingOutputFiles() - Method in class bb.common.OperatingInstructionsVO

getOperatingOutputFileType(int) - Method in interface bb.common.box.ManufacturingBox

getOperatingOutputFileType() - Method in class bb.common.OperatingOutputFileItemVO

getOperatingProcessNotes() - Method in class bb.common.OperatingInstructionsVO

getOperatingProcessRecord() - Method in class bb.common.OperatingInstructionsVO

getOperationType() - Method in class bb.common.LogTrackingVO

getOperator() - Method in class bb.common.DisassembleWorkOrderIssueVO

getOperator() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getOperator() - Method in class bb.common.NonproductivePickingItemIssuedVO

getOperator() - Method in class bb.common.PartIssuedVO

getOperator() - Method in class bb.common.PartReceivedVO

getOperator() - Method in class bb.common.WorkOrderIssuedOrderListResult

getOpinion() - Method in class bb.common.SalesOrderVO

getOptWho() - Method in class bb.common.EngineeringSharingItemVO

getOrderApproval() - Method in class bb.common.OrderApprovalItemsVO

getOrderApprovalByOrder(String) - Method in interface bb.common.box.WorkOrderBox

getOrderApprovalID() - Method in class bb.common.OrderApprovalItemsVO

getOrderBy() - Method in class bb.common.DynamicSearchFilter

getOrderBy() - Method in class bb.common.OrderBy

getOrderBy() - Method in class bb.common.PurchaseWorkSheetVO

getOrderBy() - Method in class bb.common.ServerAction

getOrderBy() - Method in class bb.common.TakeCycleCountAgent

getOrderDate() - Method in class bb.common.DisassembleWorkOrderReceivingResult

getOrderDate() - Method in class bb.common.IssuingResult

getOrderedQty() - Method in class bb.common.CRTVItemListResult

getOrderedQty() - Method in class bb.common.QuoteItemListResult

getOrderedQty() - Method in class bb.common.RMAItemListResult

getOrderedQty() - Method in class bb.common.RRMAItemListResult

getOrderedQty() - Method in class bb.common.SalesOrderItemListResult

getOrderItemNumber() - Method in class bb.common.LogMiscDocumentVO

getOrderItemNumber() - Method in class bb.common.MiscDocAgent

getOrderItemNumber() - Method in class bb.common.ReceiverItemAgent

getOrderItemNumber() - Method in class bb.common.ReceivingItemResult

getOrderNumber() - Method in class bb.common.BB2Notice

getOrderNumber() - Method in class bb.common.DebitsCreditsResult

getOrderNumber() - Method in class bb.common.DisassembleWorkOrderIssueVO

getOrderNumber() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getOrderNumber() - Method in class bb.common.DisassembleWorkOrderIssuingResult

getOrderNumber() - Method in class bb.common.DisassembleWorkOrderReceivingResult

getOrderNumber() - Method in class bb.common.InventoryPartInOutDetailListResult

getOrderNumber() - Method in class bb.common.IssuedFromOrderItem

getOrderNumber() - Method in class bb.common.IssueItemDetailAgent

getOrderNumber() - Method in class bb.common.IssuingResult

getOrderNumber() - Method in class bb.common.LogMiscDocumentVO

getOrderNumber() - Method in class bb.common.MiscDocAgent

getOrderNumber() - Method in class bb.common.MyPrintListPK

getOrderNumber() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getOrderNumber() - Method in class bb.common.NonproductivePickingItemIssuedVO

getOrderNumber() - Method in class bb.common.OrderApprovalVO

getOrderNumber() - Method in class bb.common.OrderBoilerplatePK

getOrderNumber() - Method in class bb.common.OrderDemandForReceiverResult

getOrderNumber() - Method in class bb.common.OrderDocumentVO

getOrderNumber() - Method in class bb.common.OrderPK

getOrderNumber() - Method in class bb.common.PartIssuedVO

getOrderNumber() - Method in class bb.common.PartReceivedVO

getOrderNumber() - Method in class bb.common.PrepayAgent

getOrderNumber() - Method in class bb.common.ReceiverAgent

getOrderNumber() - Method in class bb.common.ReceiverItemAgent

getOrderNumber() - Method in class bb.common.ReceiverShipAgent

getOrderNumber() - Method in class bb.common.ReceivingItemResult

getOrderNumber() - Method in class bb.common.ReceivingResult

getOrderNumber() - Method in class bb.common.RefdocElement

getOrderNumber() - Method in class bb.common.ShipperAgent

getOrderNumber() - Method in class bb.common.ShippingItemResult

getOrderNumber() - Method in class bb.common.ShippingResult

getOrderNumber() - Method in class bb.common.WorkOrderIssuedOrderListResult

getOrderNumber() - Method in class bb.common.ZipcodeTotalsResult

getOrderNumLike() - Method in class bb.common.AccountAuditAgent

getOrderPk() - Method in class bb.common.IssueItemAgent

getOrderPkFromRefDoc(String) - Static method in class bb.common.BB2Util

getOrderQty() - Method in class bb.common.MasterWorkOrderTreeItemResult

getOrderQty() - Method in class bb.common.MrpByMonthResult

getOrderQty() - Method in class bb.common.PurchaseOrderItemListResult

getOrderRelatedDoc() - Method in class bb.common.DisassembleWorkOrderItemListResult

getOrderRelatedDoc() - Method in class bb.common.WorkOrderItemListResult

getOrderStatus() - Method in class bb.common.DisassembleWorkOrderReceivingResult

getOrderStatus() - Method in class bb.common.IssuingResult

getOrderType() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getOrderType() - Method in class bb.common.NonproductivePickingItemResult

getOrderType() - Method in class bb.common.NonproductivePickingVO

getOrderType() - Method in class bb.common.OrderApprovalVO

getOrderType() - Method in class bb.common.TermsConditionVO

getOrderUsageQty() - Method in class bb.common.MrpByMonthResult

getOrgAuditExchange() - Method in class bb.common.CurrencyExchangeVO

getOrgBalance() - Method in class bb.common.ExchangeAuditItemResult

getOrgCredit() - Method in class bb.common.ExchangeAuditItemResult

getOrgCreditAccountBalance() - Method in class bb.common.AccountBalanceAgent

getOrgCreditBalance() - Method in class bb.common.MonthBalanceResult

getOrgDebit() - Method in class bb.common.ExchangeAuditItemResult

getOrgDebitAccountBalance() - Method in class bb.common.AccountBalanceAgent

getOrgDebitBalance() - Method in class bb.common.MonthBalanceResult

getOrigialShipDate() - Method in class bb.common.POReceiverItemListResult

getOrigin() - Method in class bb.common.AccountPayableCheckVO

getOrigin() - Method in class bb.common.AccountReceivablePaymentVO

getOrigin() - Method in class bb.common.AccountsChartMappingVO

getOrigin() - Method in class bb.common.AccountsChartVO

getOrigin() - Method in class bb.common.AccountsPayableInfoVO

getOrigin() - Method in class bb.common.AccountsPayableVO

getOrigin() - Method in class bb.common.AccountsReceivableInfoVO

getOrigin() - Method in class bb.common.AccountsReceivableVO

getOrigin() - Method in class bb.common.AssetVO

getOrigin() - Method in class bb.common.BillVO

getOrigin() - Method in class bb.common.CommonPrintTemplateVO

getOrigin() - Method in class bb.common.ContractPriceVO

getOrigin() - Method in class bb.common.CorrectiveActionRequestVO

getOrigin() - Method in class bb.common.CustomerReturnToVendorVO

getOrigin() - Method in class bb.common.CustomerVendorAddressInfoVO

getOrigin() - Method in class bb.common.CustomerVendorAddressVO

getOrigin() - Method in class bb.common.DesignControlInfoVO

getOrigin() - Method in class bb.common.DesignControlVO

getOrigin() - Method in class bb.common.DisassembleWorkOrderVO

getOrigin() - Method in class bb.common.EngineeringChangeVO

getOrigin() - Method in class bb.common.GeneralLedgerPrintResult

getOrigin() - Method in class bb.common.GeneralLedgerVO

getOrigin() - Method in class bb.common.GLApprovalListResult

getOrigin() - Method in class bb.common.InspectionConformanceReportVO

getOrigin() - Method in class bb.common.InspectionReportInfoVO

getOrigin() - Method in class bb.common.InspectionReportVO

getOrigin() - Method in class bb.common.LabelTemplateVO

getOrigin() - Method in class bb.common.ManufacturerAddressInfoVO

getOrigin() - Method in class bb.common.ManufacturerAddressVO

getOrigin() - Method in class bb.common.NonConformanceCodeVO

getOrigin() - Method in class bb.common.NonConformanceReportVO

getOrigin() - Method in class bb.common.NonproductivePickingVO

getOrigin() - Method in class bb.common.OnloanReceiverVO

getOrigin() - Method in class bb.common.OnloanShipperVO

getOrigin() - Method in class bb.common.OnLoanVO

getOrigin() - Method in class bb.common.OperatingInstructionsVO

getOrigin() - Method in class bb.common.PartBasicInfo

getOrigin() - Method in class bb.common.PartVO

getOrigin() - Method in class bb.common.PartWithOnhandsVO

getOrigin() - Method in class bb.common.PfReceiverVO

getOrigin() - Method in class bb.common.POSurveyReportVO

getOrigin() - Method in class bb.common.PreventiveActionRequestVO

getOrigin() - Method in class bb.common.PrintTemplateVO

getOrigin() - Method in class bb.common.ProformaInvoiceVO

getOrigin() - Method in class bb.common.PurchaseOrderVO

getOrigin() - Method in class bb.common.QuoteVO

getOrigin() - Method in class bb.common.ReceiverInfoVO

getOrigin() - Method in class bb.common.ReceiverVO

getOrigin() - Method in class bb.common.RequestForRMAVO

getOrigin() - Method in class bb.common.ReturnMaterialAuthorizationVO

getOrigin() - Method in class bb.common.ReturnToVendorVO

getOrigin() - Method in class bb.common.RMAReceiverVO

getOrigin() - Method in class bb.common.RtvShipperInfoVO

getOrigin() - Method in class bb.common.RtvShipperVO

getOrigin() - Method in class bb.common.SalesOrderVO

getOrigin() - Method in class bb.common.ShipperInfoVO

getOrigin() - Method in class bb.common.ShipperVO

getOrigin() - Method in class bb.common.SwapOrderListResult

getOrigin() - Method in class bb.common.SwapOrderVO

getOrigin() - Method in class bb.common.SwapReceiverListResult

getOrigin() - Method in class bb.common.SwapReceiverVO

getOrigin() - Method in class bb.common.SwapShipperListResult

getOrigin() - Method in class bb.common.SwapShipperVO

getOrigin() - Method in class bb.common.ToolListVO

getOrigin() - Method in class bb.common.ToolVO

getOrigin() - Method in class bb.common.ToolWithOnhandsVO

getOrigin() - Method in class bb.common.TransferOrderListResult

getOrigin() - Method in class bb.common.TransferOrderVO

getOrigin() - Method in class bb.common.TransferReceiverListResult

getOrigin() - Method in class bb.common.TransferReceiverVO

getOrigin() - Method in class bb.common.TransferShipperListResult

getOrigin() - Method in class bb.common.TransferShipperVO

getOrigin() - Method in class bb.common.VendorContractPriceVO

getOrigin() - Method in class bb.common.WarehouseVO

getOrigin() - Method in class bb.common.WorkCenterVO

getOrigin() - Method in class bb.common.WorkInstructionRequestForChangeVO

getOrigin() - Method in class bb.common.WorkOrderVO

getOriginal() - Method in class bb.common.CustomerReturnToVendorItemVO

getOriginal() - Method in class bb.common.CustomerReturnToVendorVO

getOriginal() - Method in class bb.common.DisassembleWorkOrderItemVO

getOriginal() - Method in class bb.common.DisassembleWorkOrderVO

getOriginal() - Method in class bb.common.NonproductivePickingItemVO

getOriginal() - Method in class bb.common.OnLoanItemVO

getOriginal() - Method in class bb.common.OnLoanVO

getOriginal() - Method in class bb.common.OrderApprovalItemsVO

getOriginal() - Method in class bb.common.PurchaseOrderItemVO

getOriginal() - Method in class bb.common.PurchaseOrderVO

getOriginal() - Method in class bb.common.QuoteItemVO

getOriginal() - Method in class bb.common.QuoteVO

getOriginal() - Method in class bb.common.RequestForQuoteItemVO

getOriginal() - Method in class bb.common.RequestForQuoteVO

getOriginal() - Method in class bb.common.RequestForRMAItemVO

getOriginal() - Method in class bb.common.RequestForRMAVO

getOriginal() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getOriginal() - Method in class bb.common.ReturnMaterialAuthorizationVO

getOriginal() - Method in class bb.common.ReturnToVendorItemVO

getOriginal() - Method in class bb.common.ReturnToVendorVO

getOriginal() - Method in class bb.common.SalesOrderItemInfoVO

getOriginal() - Method in class bb.common.SalesOrderItemVO

getOriginal() - Method in class bb.common.SalesOrderShipDateListResult

getOriginal() - Method in class bb.common.SalesOrderVO

getOriginal() - Method in class bb.common.WorkOrderItemPartDetail

getOriginal() - Method in class bb.common.WorkOrderItemVO

getOriginal() - Method in class bb.common.WorkOrderVO

getOriginalAvgCost() - Method in class bb.common.OrderApprovalItemsVO

getOriginalBalance() - Method in class bb.common.JounalEntryListResult

getOriginalCost() - Method in class bb.common.CustomAssetVO

getOriginalCost() - Method in class bb.common.DisassembleWorkOrderItemVO

getOriginalCost() - Method in class bb.common.EquipmentVO

getOriginalCost() - Method in class bb.common.WorkOrderItemReviewCostResult

getOriginalCost() - Method in class bb.common.WorkOrderItemVO

getOriginalCredit() - Method in class bb.common.AccountCreditVO

getOriginalCredit() - Method in class bb.common.GeneralLedgerEntry

getOriginalCredit() - Method in class bb.common.GLItemVO

getOriginalCreditAmount() - Method in class bb.common.JounalEntryListResult

getOriginalDate() - Method in class bb.common.PO2POAgent

getOriginalDate() - Method in class bb.common.SO2SOAgent

getOriginalDebit() - Method in class bb.common.AccountDebitVO

getOriginalDebit() - Method in class bb.common.GeneralLedgerEntry

getOriginalDebit() - Method in class bb.common.GLItemVO

getOriginalDebitAmount() - Method in class bb.common.JounalEntryListResult

getOriginalDelivery() - Method in class bb.common.SalesOrderItemListResult

getOriginalDiscount() - Method in class bb.common.OrderApprovalItemsVO

getOriginalEndDate() - Method in class bb.common.OrderApprovalItemsVO

getOriginalExtendPrice() - Method in class bb.common.OrderApprovalItemsVO

getOriginalInvoice() - Method in class bb.common.CustomerServiceIncidentItemListResult

getOriginalInvoice() - Method in class bb.common.CustomerServiceIncidentVO

getOriginalInvoiceNumber() - Method in class bb.common.CustomerFeedbackVO

getOriginalNumber() - Method in class bb.common.RunningAccountOrderVO

getOriginalOrderItem() - Method in class bb.common.OrderApprovalItemsVO

getOriginalPartDesc() - Method in class bb.common.OrderApprovalItemsVO

getOriginalPartNumber() - Method in class bb.common.OrderApprovalItemsVO

getOriginalPartType() - Method in class bb.common.OrderApprovalItemsVO

getOriginalPoQty() - Method in class bb.common.OrderApprovalItemsVO

getOriginalPosition() - Method in class bb.common.CustomEmployeeVO

getOriginalQty() - Method in class bb.common.OrderApprovalItemsVO

getOriginalSalesOrderNumber() - Method in class bb.common.CustomerFeedbackVO

getOriginalSalesOrderNumber() - Method in class bb.common.CustomerServiceIncidentItemListResult

getOriginalSalesOrderNumber() - Method in class bb.common.CustomerServiceIncidentVO

getOriginalShipperNumber() - Method in class bb.common.CustomerServiceIncidentItemListResult

getOriginalShipperNumber() - Method in class bb.common.CustomerServiceIncidentVO

getOriginalStartDate() - Method in class bb.common.OrderApprovalItemsVO

getOriginalStatus() - Method in class bb.common.OrderApprovalItemsVO

getOriginalStdCost() - Method in class bb.common.OrderApprovalItemsVO

getOriginalTaxRate() - Method in class bb.common.OrderApprovalItemsVO

getOriginalTranslation() - Method in class bb.common.CustomTranslationVO

getOriginalUserName() - Method in class bb.common.User2UserAgent

getOriginalWorkOrderNumber() - Method in class bb.common.CustomerFeedbackVO

getOriginalWorkOrderNumber() - Method in class bb.common.CustomerServiceIncidentItemListResult

getOriginalWorkOrderNumber() - Method in class bb.common.CustomerServiceIncidentVO

getOriginatedDate() - Method in class bb.common.WorkInstructionRequestForChangeVO

getOriginator() - Method in class bb.common.DisassembleWorkOrderItemListResult

getOriginator() - Method in class bb.common.DisassembleWorkOrderListResult

getOriginator() - Method in class bb.common.DisassembleWorkOrderVO

getOriginator() - Method in class bb.common.EngineeringChangeListResult

getOriginator() - Method in class bb.common.EngineeringChangeRequestListResult

getOriginator() - Method in class bb.common.EngineeringChangeRequestVO

getOriginator() - Method in class bb.common.EngineeringChangeVO

getOriginator() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getOriginator() - Method in class bb.common.WorkInstructionRequestForChangeVO

getOriginator() - Method in class bb.common.WorkOrderCheckListResult

getOriginator() - Method in class bb.common.WorkOrderItemInWipListResult

getOriginator() - Method in class bb.common.WorkOrderItemListResult

getOriginator() - Method in class bb.common.WorkOrderListResult

getOriginator() - Method in class bb.common.WorkOrderVO

getOrphanedSoOnDemandList() - Method in class bb.common.MrpItemOrderDemandRecordsResult

getOrphanedSoOnDemandList() - Method in class bb.common.MrpItemResult

getOrphanedWoOnDemandList() - Method in class bb.common.MrpItemOrderDemandRecordsResult

getOrphanedWoOnDemandList() - Method in class bb.common.MrpItemResult

getOsType() - Method in class bb.common.BizboxBugInfoVO

getOsType() - Method in class bb.common.BizboxBugVO

getOtherAssets() - Method in class bb.common.BalanceSheetSideBySideResult

getOtherAssets() - Method in class bb.common.ClosingStatementResult

getOtherCurrentAssets() - Method in class bb.common.AccountingBalanceSheetResult

getOtherExpenseItemsItems() - Method in class bb.common.ClosingStatementResult

getOtherExpenses() - Method in class bb.common.ClosingStatementResult

getOtherIncome() - Method in class bb.common.ClosingStatementResult

getOtherIncome() - Method in class bb.common.ProfitLossStatementResult

getOtherLiabilities() - Method in class bb.common.ClosingStatementResult

getOtherLiability() - Method in class bb.common.BalanceSheetSideBySideResult

getOtherLocations() - Method in class bb.common.PartOnhandResult

getOthersLocations() - Method in class bb.common.IssuingItemResult

getOthersLocations() - Method in class bb.common.ShippingItemResult

getOtran() - Method in class bb.common.AccountsReceivableInfoVO

getOtran() - Method in class bb.common.AccountsReceivableVO

getOTran() - Method in class bb.common.OnloanShipperVO

getOtran() - Method in class bb.common.ProformaInvoiceVO

getOtran() - Method in class bb.common.RtvShipperInfoVO

getOtran() - Method in class bb.common.RtvShipperVO

getOTran() - Method in class bb.common.ShipperInfoVO

getOTran() - Method in class bb.common.ShipperVO

getOurPO() - Method in class bb.common.GeneralLedgerResult

getOurPoNumber() - Method in class bb.common.APItemListResult

getOurPoNumber() - Method in class bb.common.VendorPrepayStatementListResult

getOurPoNumber() - Method in class bb.common.VendorStatementListResult

getOurRefQuote() - Method in class bb.common.QuoteListResult

getOutAmount() - Method in class bb.common.InventoryMonthReport

getOutCost() - Method in class bb.common.InventoryMonthReport

getOutCost() - Method in class bb.common.LogInventoryListResult

getOutCost() - Method in class bb.common.LogInventoryVO

getOuterDiameter() - Method in class bb.common.PartMaterialListResult

getOuterDiameter() - Method in class bb.common.PartMaterialReportAgent

getOuterDiameter() - Method in class bb.common.PartMaterialVO

getOuterDiameter() - Method in class bb.common.PartMaterialWhereUsedItemResult

getOuterDiameterUnit() - Method in class bb.common.PartMaterialListResult

getOuterDiameterUnit() - Method in class bb.common.PartMaterialVO

getOuterDiameterUnit() - Method in class bb.common.PartMaterialWhereUsedItemResult

getOuterUnit() - Method in class bb.common.PartMaterialReportAgent

getOutQty() - Method in class bb.common.InventoryMonthReport

getOutQty() - Method in class bb.common.InventoryPartInOutDetailListResult

getOutQty() - Method in class bb.common.LogInventoryListResult

getOutQty() - Method in class bb.common.LogInventoryVO

getOutQty() - Method in class bb.common.LogTrackingVO

getOutSourcing() - Method in class bb.common.WorkInstructionSequenceVO

getOutSourcing() - Method in class bb.common.WorkOrderItemSeqWCLoadResult

getOutSourcing() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getOutterOperator() - Method in class bb.common.PartMaterialReportAgent

getOutTotalCost() - Method in class bb.common.InventoryPartInOutDetailListResult

getOverageAmount() - Method in class bb.common.InventoryMonthReport

getOverageAmount() - Method in class bb.common.InventoryPartInOutDetailListResult

getOverageQty() - Method in class bb.common.InventoryMonthReport

getOverageQty() - Method in class bb.common.InventoryPartInOutDetailListResult

getOverageQty() - Method in class bb.common.PhysicalInventoryListWithAppDataResult

getOverageTotal() - Method in class bb.common.PhysicalInventoryListWithAppDataResult

getOverdueDate() - Method in class bb.common.PartVendorVO

getOverdueDate() - Method in class bb.common.ToolVendorVO

getOverdueList() - Method in class bb.common.ApprovedGLResult

getOverIssueItemByMonth(int) - Method in interface bb.common.box.ManagementBox

getOverIssueItemListCount(boolean, Date, Date, String, String, String, String, String) - Method in interface bb.common.box.WorkOrderBox

getOverPercent() - Method in class bb.common.DisassembleWorkOrderItemVO

getOverPercent() - Method in class bb.common.WorkOrderItemReviewCostResult

getOverPercent() - Method in class bb.common.WorkOrderItemVO

getOverview() - Method in class bb.common.SGDocPartVO

getOverviewRev() - Method in class bb.common.SGDocPartVO

getOwner() - Method in class bb.common.PartClassVO

getOwner() - Method in class bb.common.PartExportInfo

getOwner() - Method in class bb.common.PartVO

getOwner() - Method in class bb.common.PartWithOnhandsVO

getOwner() - Method in class bb.common.ServerClientPropertyPK

getOwner() - Method in class bb.common.ToolVO

getOwner() - Method in class bb.common.ToolWithOnhandsVO

getOwner() - Method in class bb.common.UserGroupVO

getOwnerName() - Method in class bb.common.ShipListAgent

getOwnerName() - Method in class bb.common.ShipListInfoVO

getOwnerName() - Method in class bb.common.ShipListOwnerAttributePK

getOwnerName() - Method in class bb.common.ShipListOwnerVO

getOwnerName() - Method in class bb.common.ShipListVO

getOwnersEquity() - Method in class bb.common.BalanceSheetSideBySideResult

getOwnershipPercent() - Method in class bb.common.SubcompanyVO

getPa() - Method in class bb.common.CompanyVO

getPackBoxItemPk() - Method in class bb.common.BB2PartInSipItemResult

getPackBoxItemPk() - Method in class bb.common.BB2PartInSitItemResult

getPackCondition() - Method in class bb.common.POSurveyReportItemVO

getPackingBoxByPk(PackingBoxPK) - Method in interface bb.common.box.WarehouseBox

getPackingBoxes() - Method in class bb.common.ProformaInvoiceVO

getPackingBoxesCountByPfNumber(String) - Method in interface bb.common.box.WarehouseBox

getPackingBoxItemListResultsCountByPfNumbe(String) - Method in interface bb.common.box.WarehouseBox

getPackingBoxItemListResultsCountByPfNumbeAndPBNumber(String, int) - Method in interface bb.common.box.WarehouseBox

getPackingBoxItemPk() - Method in class bb.common.PackingBoxItemListResult

getPackingBoxItems() - Method in class bb.common.PackingBoxVO

getPackingBoxItems() - Method in class bb.common.PrPackingBoxVO

getPackingBoxNumber() - Method in class bb.common.AddProformaReceiverItemAgent

getPackingBoxNumber() - Method in class bb.common.PackingBoxItemPK

getPackingBoxNumber() - Method in class bb.common.PackingBoxPK

getPackingBoxNumber() - Method in class bb.common.PrPackingBoxItemPK

getPackingBoxNumber() - Method in class bb.common.PrPackingBoxPK

getPackingBoxNumbers() - Method in class bb.common.PfReceiverVO

getPackingBoxNumbers() - Method in class bb.common.ProformaInvoiceVO

getPackingBoxPk() - Method in class bb.common.PackingBoxSalesOrderItemAgent

getPageNumber() - Method in class bb.common.AddPhysicalInventoryAgent

getPageNumber() - Method in class bb.common.CycleCountPK

getPageNumber() - Method in class bb.common.PhysicalInventoryPK

getPageNumberInWorkSheetByPart(PartPK, String, int, String) - Method in interface bb.common.box.WarehouseBox

getPaid() - Method in class bb.common.AccountPayableCheckRunItemVO

getPaid() - Method in class bb.common.AccountPayableCheckVO

getPaid() - Method in class bb.common.AccountReceivablePaymentVO

getPaid() - Method in class bb.common.AccountsPayableInfoVO

getPaid() - Method in class bb.common.AccountsPayableItemVO

getPaid() - Method in class bb.common.AccountsPayableVO

getPaid() - Method in class bb.common.AccountsReceivableInfoVO

getPaid() - Method in class bb.common.AccountsReceivableItemVO

getPaid() - Method in class bb.common.AccountsReceivableVO

getPaid() - Method in class bb.common.ARPaymentRunItemVO

getPaid() - Method in class bb.common.GeneralLedgerByDateListResult

getPaid() - Method in class bb.common.GeneralLedgerListResult

getPaid() - Method in class bb.common.GeneralLedgerVO

getPaid() - Method in class bb.common.OnloanReceiverItemVO

getPaid() - Method in class bb.common.OnloanReceiverVO

getPaid() - Method in class bb.common.OnloanShipperItemVO

getPaid() - Method in class bb.common.OnloanShipperVO

getPaid() - Method in class bb.common.ProformaInvoiceVO

getPaid() - Method in class bb.common.ReceiverInfoVO

getPaid() - Method in class bb.common.ReceiverItemVO

getPaid() - Method in class bb.common.ReceiverVO

getPaid() - Method in class bb.common.RMAReceiverItemVO

getPaid() - Method in class bb.common.RMAReceiverVO

getPaid() - Method in class bb.common.RtvShipperInfoVO

getPaid() - Method in class bb.common.RtvShipperItemVO

getPaid() - Method in class bb.common.RtvShipperVO

getPaid() - Method in class bb.common.ShipperInfoVO

getPaid() - Method in class bb.common.ShipperItemVO

getPaid() - Method in class bb.common.ShipperVO

getPaid() - Method in class bb.common.TempArApAgingVO

getPaidDate() - Method in class bb.common.ArCommissionListResult

getPaidDate() - Method in class bb.common.InvoiceItemListResult

getPaidExactly() - Method in class bb.common.AccountPayableCheckVO

getPaidExactly() - Method in class bb.common.AccountReceivablePaymentVO

getPaidToDate() - Method in class bb.common.ARPaymentRunItemVO

getPaOffsetType() - Method in class bb.common.CompanyVO

getParameter() - Method in exception bb.common.BB2ServerException

getParameter() - Method in exception bb.common.BizException

getParams() - Method in class bb.common.BB2Task

getParams() - Method in class bb.common.ServerAction

getParams() - Method in class bb.common.TaskVO

getParamTypes() - Method in class bb.common.ServerAction

getParent() - Method in class bb.common.CustomerVendorAddressInfoVO

getParent() - Method in class bb.common.CustomerVendorAddressVO

getParent() - Method in class bb.common.WorkOrderItemSetupItemAgent

getParentBill(BillItemVO) - Method in interface bb.common.box.EngineeringBox

getParentCategory() - Method in class bb.common.AccountsChartCategoryVO

getParentId() - Method in class bb.common.EngGroupVO

getParentId() - Method in class bb.common.PermissionVO

getParentName() - Method in class bb.common.ZipcodeTotalsResult

getParentOrder(String, String) - Method in interface bb.common.box.WorkOrderBox

getParentToolList(ToolListItemVO) - Method in interface bb.common.box.ManufacturingBox

getParentWorkCenter() - Method in class bb.common.WorkCenterVO

getParItemNumber() - Method in class bb.common.PreventiveActionRequestItemVO

getPARItemsByPAR(String) - Method in interface bb.common.box.QualityBox

getParNumber() - Method in class bb.common.PreventiveActionRequestItemVO

getParNumber() - Method in class bb.common.PreventiveActionRequestVO

getPARsCountByParNumber(String) - Method in interface bb.common.box.QualityBox

getPARsCountByPn(String, String) - Method in interface bb.common.box.QualityBox

getPart() - Method in class bb.common.BB2PartBasicInfo

getPart() - Method in class bb.common.BB2PartByDateResult

getPart() - Method in class bb.common.BB2PartInventoryResult

getPart() - Method in class bb.common.BB2PartOnDemandListResult

getPart() - Method in class bb.common.BB2WeightInfoResult

getPart() - Method in class bb.common.EcnCheckOrderResult

getPart() - Method in class bb.common.HighUsagePartResult

getPart() - Method in class bb.common.InventoryCycleResult

getPart() - Method in class bb.common.InventoryListResult

getPart() - Method in class bb.common.InventoryNotUsedInMonthsResult

getPart() - Method in class bb.common.MrpItemOrderDemandRecordsResult

getPart() - Method in class bb.common.MrpItemResult

getPart() - Method in class bb.common.NcrReportListResult

getPart() - Method in class bb.common.OnloanReceiverItemVO

getPart() - Method in class bb.common.PartClassInfoResult

getPart() - Method in class bb.common.PartInQAAgent

getPart() - Method in class bb.common.PartInWipForIDListResult

getPart() - Method in class bb.common.PartOnhandResult

getPart() - Method in class bb.common.PrReceiverWithQualityListResult

getPart() - Method in class bb.common.PullFromWorkOrderPartDetailAgent

getPart() - Method in class bb.common.PuttoInQAAgent

getPart() - Method in class bb.common.RebackInQAAgent

getPart() - Method in class bb.common.ReceiverItemAgent

getPart() - Method in class bb.common.ReceiverItemVO

getPart() - Method in class bb.common.SalesOrder12MonthMarginResult

getPart() - Method in class bb.common.SerialNumberItemResult

getPart() - Method in class bb.common.SerialNumberResult

getPart() - Method in class bb.common.SGPartCatalogResult

getPart() - Method in class bb.common.ShipListItemRelatedDocResult

getPart() - Method in class bb.common.StockTransactionAdjustmentResult

getPart() - Method in class bb.common.StockTransactionPartInfoResult

getPart() - Method in class bb.common.StockTransactionPOReceiverResult

getPart() - Method in class bb.common.StockTransactionSOShipperResult

getPart() - Method in class bb.common.StockTransactionWOReceiverResult

getPart() - Method in class bb.common.StockTransactionWOShipperResult

getPart() - Method in class bb.common.WCLoadByDateResult

getPart() - Method in class bb.common.WOItemCostControlAgent

getPart() - Method in class bb.common.WOItemPartDetailNotIssue

getPart() - Method in class bb.common.WoItemWorkInstructionListResult

getPart() - Method in class bb.common.WorkCenterRunTimeListResult

getPart() - Method in class bb.common.WorkInstructionSummaryResult

getPart() - Method in class bb.common.WorkOrderItemWCLoadResult

getPartAvgCost() - Method in class bb.common.DisassembleWorkOrderItemListResult

getPartAvgCost() - Method in class bb.common.WorkOrderItemIssueVO

getPartAvgCost() - Method in class bb.common.WorkOrderItemListResult

getPartBasicInfo(PartPK) - Method in interface bb.common.box.EngineeringBox

getPartBasicInfo(PartPK, String) - Method in interface bb.common.box.EngineeringBox

getPartBasicInfo() - Method in class bb.common.MrpItemResult

getPartBasicInfo() - Method in class bb.common.PartTraceableInfoResult

getPartBasicInfo() - Method in class bb.common.PartWhereUsedResult

getPartBasicInfo() - Method in class bb.common.PurchaseWorkSheetItemWithRelatedInfoResult

getPartBasicInfo() - Method in class bb.common.WorkOrderWorkSheetItemWithRelatedInfoResult

getPartBasicInfoToRollUPCount(String) - Method in interface bb.common.box.EngineeringBox

getPartBasicInfoToRollUPCount(String, String) - Method in interface bb.common.box.EngineeringBox

getPartBigCatagoryLength() - Method in class bb.common.CompanyVO

getPartByBuyerCodeCount(String, String) - Method in interface bb.common.box.PurchasingBox

getPartCanAssy(BOMCanAssyAgent) - Method in interface bb.common.box.WorkOrderBox

getPartCatagoryByPk(PartCatagoryPK) - Method in interface bb.common.box.EngineeringBox

getPartCatalogAuditResults(String) - Method in interface bb.common.box.SalesBox

getPartCatalogPK() - Method in class bb.common.SGPartCatalogResult

getPartCatalogs(String) - Method in interface bb.common.box.SalesBox

getPartCatalogVO() - Method in class bb.common.SGPartCatalogResult

getPartCertificateByCertificateNumber(String) - Method in interface bb.common.box.QualityBox

getPartCertificateByCertificateNumberCount(String, String, String) - Method in interface bb.common.box.QualityBox

getPartCertificatesCountByCertificateDesc(String) - Method in interface bb.common.box.QualityBox

getPartCertificatesCountByCn(String) - Method in interface bb.common.box.QualityBox

getPartCertificatesCountByPn(String, String) - Method in interface bb.common.box.QualityBox

getPartCertificatesCountByPo(String) - Method in interface bb.common.box.QualityBox

getPartCertificatesCountByRef(String) - Method in interface bb.common.box.QualityBox

getPartCertificatesCountByRn(String) - Method in interface bb.common.box.QualityBox

getPartCertificatesCountByWo(String) - Method in interface bb.common.box.QualityBox

getPartClass() - Method in class bb.common.CycleCountListResult

getPartClass() - Method in class bb.common.CycleCountStatusVO

getPartClass() - Method in class bb.common.CycleCountVO

getPartClass() - Method in class bb.common.PartClassInfoResult

getPartClass() - Method in class bb.common.PartInventoryVO

getPartClass() - Method in class bb.common.TakeCycleCountAgent

getPartClassByID(String) - Method in interface bb.common.box.WarehouseBox

getPartClassesCount() - Method in interface bb.common.box.WarehouseBox

getPartClassesList() - Method in interface bb.common.box.WarehouseBox

getPartClassesToAlarm() - Method in interface bb.common.box.WarehouseBox

getPartClassInfoResultCount(String, String, String) - Method in interface bb.common.box.WarehouseBox

getPartDesc() - Method in class bb.common.DisassembleWorkOrderItemListResult

getPartDesc() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getPartDesc() - Method in class bb.common.RequestForQuoteItemListResult

getPartDesc() - Method in class bb.common.ReturnToVendorItemListResult

getPartDesc() - Method in class bb.common.WorkInstructionSeqAuditListResult

getPartDesc() - Method in class bb.common.WorkOrderItemInWipListResult

getPartDesc() - Method in class bb.common.WorkOrderItemListResult

getPartDesc() - Method in class bb.common.WorkOrderItemPartDetail

getPartDescription() - Method in class bb.common.CustomerFeedbackVO

getPartDescription() - Method in class bb.common.CustomerServiceIncidentItemListResult

getPartDescription() - Method in class bb.common.CustomerServiceIncidentListResult

getPartDescription() - Method in class bb.common.DesignControlListResult

getPartDescription() - Method in class bb.common.EngineeringChangeListResult

getPartDescription() - Method in class bb.common.EngineeringChangeRequestListResult

getPartDescription() - Method in class bb.common.EngineeringSharingItemVO

getPartDescription() - Method in class bb.common.IcrItemListResult

getPartDescription() - Method in class bb.common.InSipAudittListResult

getPartDescription() - Method in class bb.common.InspectionConformanceReportItemVO

getPartDescription() - Method in class bb.common.InventoryReportListResult

getPartDescription() - Method in class bb.common.NcrReportListResult

getPartDescription() - Method in class bb.common.NonConformanceReportVO

getPartDescription() - Method in class bb.common.PartCertificateListResult

getPartDescription() - Method in class bb.common.PartCostVarianceListResult

getPartDescription() - Method in class bb.common.PartDwfWithPartInfoResult

getPartDescription() - Method in class bb.common.PartDwgWithPartInfoResult

getPartDescription() - Method in class bb.common.PartInQAResult

getPartDescription() - Method in class bb.common.PO2SOExchangeItem

getPartDescription() - Method in class bb.common.SerialNumberItemResult

getPartDescription() - Method in class bb.common.SerialNumberResult

getPartDescription() - Method in class bb.common.SOShipperItemListResult

getPartDescription() - Method in class bb.common.WorkInstructionSequenceListResult

getPartDescription() - Method in class bb.common.WorkOrderOverIssueListResult

getPartDetailResult(WorkOrderItemPK) - Method in interface bb.common.box.WorkOrderBox

getPartDetailResultNoNA(WorkOrderItemPK) - Method in interface bb.common.box.WorkOrderBox

getPartDiscountVOByPk(PartDiscountPK) - Method in interface bb.common.box.SalesBox

getPartDocumentByPk(PartDocumentPK) - Method in interface bb.common.box.DocumentBox

getPartDocumentCountByPartNumber(String) - Method in interface bb.common.box.DocumentBox

getPartDocumentCountByPartNumber(String, String) - Method in interface bb.common.box.DocumentBox

getPartDocumentInfo(AllPartDocumentsPK) - Method in interface bb.common.box.DocumentBox

getPartDwfCount(String, String, String, String, boolean) - Method in interface bb.common.box.EngineeringBox

getPartDwfCountFullMatch(String, String, String, String, boolean) - Method in interface bb.common.box.EngineeringBox

getPartDwfLogCount(String, String, String, String, String, String, String, String, String, Date, Date) - Method in interface bb.common.box.EngineeringBox

getPartDwfPk() - Method in class bb.common.PartDwfAgent

getPartDwfWithPartInfoResult(PartDwfPK) - Method in interface bb.common.box.EngineeringBox

getPartDwgCount(String, String, String, String) - Method in interface bb.common.box.EngineeringBox

getPartDwgLogCount(String, String, String, String, String, String, String, String, String, Date, Date) - Method in interface bb.common.box.EngineeringBox

getPartDwgPk() - Method in class bb.common.PartDwgAgent

getPartDwgWithPartInfoResult(PartDwgPK) - Method in interface bb.common.box.EngineeringBox

getPartFrom() - Method in class bb.common.AccountsPayableItemVO

getPartFrom() - Method in class bb.common.AccountsReceivableItemVO

getPartFrom() - Method in class bb.common.APItemListResult

getPartFrom() - Method in class bb.common.AuditPartInQAResult

getPartFrom() - Method in class bb.common.BB2Part

getPartFrom() - Method in class bb.common.BB2PartOnhandPK

getPartFrom(boolean) - Static method in class bb.common.BB2Util

getPartFrom() - Method in class bb.common.BomPickListItemResult

getPartFrom() - Method in class bb.common.BomPickListResult

getPartFrom() - Method in class bb.common.ContractPriceItemPK

getPartFrom() - Method in class bb.common.CorrectiveActionRequestVO

getPartFrom() - Method in class bb.common.CPItemFromQuoteResult

getPartFrom() - Method in class bb.common.CRTVItemListResult

getPartFrom() - Method in class bb.common.CSRAgent

getPartFrom() - Method in class bb.common.CustomerFeedbackVO

getPartFrom() - Method in class bb.common.CustomerReturnToVendorItemVO

getPartFrom() - Method in class bb.common.CustomerServiceIncidentItemListResult

getPartFrom() - Method in class bb.common.CustomerServiceIncidentListResult

getPartFrom() - Method in class bb.common.CustomerServiceIncidentVO

getPartFrom() - Method in class bb.common.DisassembleWorkOrderIssueVO

getPartFrom() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getPartFrom() - Method in class bb.common.DisassembleWorkOrderItemListResult

getPartFrom() - Method in class bb.common.DisassembleWorkOrderItemPartDetailItemResult

getPartFrom() - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

getPartFrom() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

getPartFrom() - Method in class bb.common.DisassembleWorkOrderItemVO

getPartFrom() - Method in class bb.common.DisassembleWorkOrderReceivingResult

getPartFrom() - Method in class bb.common.DWOIssueDetail

getPartFrom() - Method in class bb.common.EngineeringChangeListResult

getPartFrom() - Method in class bb.common.EngineeringChangeRequestListResult

getPartFrom() - Method in class bb.common.EngineeringChangeRequestVO

getPartFrom() - Method in class bb.common.EngineeringChangeVO

getPartFrom() - Method in class bb.common.IcrItemListResult

getPartFrom() - Method in class bb.common.InSipAudittListResult

getPartFrom() - Method in class bb.common.InspectionConformanceReportItemVO

getPartFrom() - Method in class bb.common.InventoryAdjustmentDetailResult

getPartFrom() - Method in class bb.common.InventoryAdjustmentVO

getPartFrom() - Method in class bb.common.InventoryPartInOutDetailListResult

getPartFrom() - Method in class bb.common.InvoiceItemListResult

getPartFrom() - Method in class bb.common.IssueItemAgent

getPartFrom() - Method in class bb.common.IssuingItemResult

getPartFrom() - Method in class bb.common.IssuingResult

getPartFrom() - Method in class bb.common.JobProcessSheetListResult

getPartFrom() - Method in class bb.common.JobProcessSheetResult

getPartFrom() - Method in class bb.common.LnShipperItemListResult

getPartFrom() - Method in class bb.common.LogInventoryListResult

getPartFrom() - Method in class bb.common.LogInventoryVO

getPartFrom() - Method in class bb.common.LogMiscDocumentVO

getPartFrom() - Method in class bb.common.LogPartDwfVO

getPartFrom() - Method in class bb.common.LogPartDwgVO

getPartFrom() - Method in class bb.common.MiscDocAgent

getPartFrom() - Method in class bb.common.NcrNeedToScrapListResult

getPartFrom() - Method in class bb.common.NonConformanceReportVO

getPartFrom() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getPartFrom() - Method in class bb.common.NonproductivePickingItemIssuedVO

getPartFrom() - Method in class bb.common.NonproductivePickingItemResult

getPartFrom() - Method in class bb.common.NonproductivePickingItemVO

getPartFrom() - Method in class bb.common.NonproductivePickingOnDemandResult

getPartFrom() - Method in class bb.common.OnLoanItemListResult

getPartFrom() - Method in class bb.common.OnLoanItemVO

getPartFrom() - Method in class bb.common.OnloanReceiverItemListResult

getPartFrom() - Method in class bb.common.OnloanReceiverItemVO

getPartFrom() - Method in class bb.common.OnloanShipperItemVO

getPartFrom() - Method in class bb.common.OrderDemandForReceiverResult

getPartFrom() - Method in class bb.common.PackingBoxItemListResult

getPartFrom() - Method in class bb.common.PackingBoxItemVO

getPartFrom() - Method in class bb.common.PackingBoxSalesOrderItemResult

getPartFrom() - Method in class bb.common.PartCatalogAuditResult

getPartFrom() - Method in class bb.common.PartCatalogPK

getPartFrom() - Method in class bb.common.PartCertificateListResult

getPartFrom() - Method in class bb.common.PartCertificateVO

getPartFrom() - Method in class bb.common.PartDwfAgent

getPartFrom() - Method in class bb.common.PartDwfPK

getPartFrom() - Method in class bb.common.PartDwfWithPartInfoResult

getPartFrom() - Method in class bb.common.PartDwgAgent

getPartFrom() - Method in class bb.common.PartDwgPK

getPartFrom() - Method in class bb.common.PartDwgWithPartInfoResult

getPartFrom() - Method in class bb.common.PartInQAResult

getPartFrom() - Method in class bb.common.PartInQAVO

getPartFrom() - Method in class bb.common.PartInspectionPK

getPartFrom() - Method in class bb.common.PartInspectionResult

getPartFrom() - Method in class bb.common.PartIssuedVO

getPartFrom() - Method in class bb.common.PartOnhandCostVO

getPartFrom() - Method in class bb.common.PartReceivedVO

getPartFrom() - Method in class bb.common.PartToAuditFlagResult

getPartFrom() - Method in class bb.common.PartUseTypeVO

getPartFrom() - Method in class bb.common.PartWithExcessiveInventoryListResult

getPartFrom() - Method in class bb.common.PartWithInventoryInfoListResult

getPartFrom() - Method in class bb.common.PartWithQAQtyListResult

getPartFrom() - Method in class bb.common.PartWithQtyListResult

getPartFrom() - Method in class bb.common.PartWithSipQtyListResult

getPartFrom() - Method in class bb.common.PartWithSITQtyListResult

getPartFrom() - Method in class bb.common.PartWithSTOQtyListResult

getPartFrom() - Method in class bb.common.PartWithWipQtyListResult

getPartFrom() - Method in class bb.common.PfReceiverItemVO

getPartFrom() - Method in class bb.common.PO2SOExchangeItem

getPartFrom() - Method in class bb.common.POReceiverItemListResult

getPartFrom() - Method in class bb.common.POSurveyReportItemVO

getPartFrom() - Method in class bb.common.PreventiveActionRequestVO

getPartFrom() - Method in class bb.common.ProformaInvoiceItemListResult

getPartFrom() - Method in class bb.common.ProformaInvoiceItemVO

getPartFrom() - Method in class bb.common.PrPackingBoxItemVO

getPartFrom() - Method in class bb.common.PurchaseOrderItemVO

getPartFrom() - Method in class bb.common.PurchaseOrderOnOrderResult

getPartFrom() - Method in class bb.common.QuoteItemListResult

getPartFrom() - Method in class bb.common.QuoteItemVO

getPartFrom() - Method in class bb.common.ReceiverItemVO

getPartFrom() - Method in class bb.common.ReceivingItemResult

getPartFrom() - Method in class bb.common.RequestForQuoteItemListResult

getPartFrom() - Method in class bb.common.RequestForQuoteItemVO

getPartFrom() - Method in class bb.common.RequestForRMAItemVO

getPartFrom() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getPartFrom() - Method in class bb.common.ReturnToVendorItemListResult

getPartFrom() - Method in class bb.common.ReturnToVendorItemVO

getPartFrom() - Method in class bb.common.RMAItemListResult

getPartFrom() - Method in class bb.common.RMAReceiverItemListResult

getPartFrom() - Method in class bb.common.RMAReceiverItemVO

getPartFrom() - Method in class bb.common.RRMAItemListResult

getPartFrom() - Method in class bb.common.RtvShipperItemListResult

getPartFrom() - Method in class bb.common.RtvShipperItemVO

getPartFrom() - Method in class bb.common.SalesBomItemResult

getPartFrom() - Method in class bb.common.SalesOrderItemGroupByPartListResult

getPartFrom() - Method in class bb.common.SalesOrderItemInfoVO

getPartFrom() - Method in class bb.common.SalesOrderItemListResult

getPartFrom() - Method in class bb.common.SalesOrderItemVO

getPartFrom() - Method in class bb.common.SalesOrderOnDemandResult

getPartFrom() - Method in class bb.common.SalesOrderShipDateListResult

getPartFrom() - Method in class bb.common.SalesPartListItemResult

getPartFrom() - Method in class bb.common.SalesTaxListResult

getPartFrom() - Method in class bb.common.ScrapReportVO

getPartFrom() - Method in class bb.common.SGBOMItemResult

getPartFrom() - Method in class bb.common.SGCustomerCatalogPK

getPartFrom() - Method in class bb.common.SGCustomerServiceRequestVO

getPartFrom() - Method in class bb.common.SGCustRequestForQuoteItemVO

getPartFrom() - Method in class bb.common.SGSaleItemVO

getPartFrom() - Method in class bb.common.ShipListItemVOResult

getPartFrom() - Method in class bb.common.ShipperItemListResult

getPartFrom() - Method in class bb.common.ShipperItemVO

getPartFrom() - Method in class bb.common.ShippingItemResult

getPartFrom() - Method in class bb.common.ShoppingCartItem

getPartFrom() - Method in class bb.common.SwapOrderItemListResult

getPartFrom() - Method in class bb.common.SwapOrderItemVO

getPartFrom() - Method in class bb.common.SwapReceiverItemListResult

getPartFrom() - Method in class bb.common.SwapReceiverItemVO

getPartFrom() - Method in class bb.common.SwapShipperItemListResult

getPartFrom() - Method in class bb.common.SwapShipperItemVO

getPartFrom() - Method in class bb.common.SwapShipperOnOrderResult

getPartFrom() - Method in class bb.common.TransferOrderItemListResult

getPartFrom() - Method in class bb.common.TransferOrderItemVO

getPartFrom() - Method in class bb.common.TransferReceiverItemListResult

getPartFrom() - Method in class bb.common.TransferReceiverItemVO

getPartFrom() - Method in class bb.common.TransferShipperItemListResult

getPartFrom() - Method in class bb.common.TransferShipperItemVO

getPartFrom() - Method in class bb.common.VendorContractPriceItemPK

getPartFrom() - Method in class bb.common.VendorPartVO

getPartFrom() - Method in class bb.common.VendorQtyPricePK

getPartFrom() - Method in class bb.common.WCLoadDetailResult

getPartFrom() - Method in class bb.common.WoItemPickListItemResult

getPartFrom() - Method in class bb.common.WoItemPickListResult

getPartFrom() - Method in class bb.common.WOReceiverDetail

getPartFrom() - Method in class bb.common.WorkInstructionDocumentVO

getPartFrom() - Method in class bb.common.WorkInstructionListResult

getPartFrom() - Method in class bb.common.WorkInstructionPictureVO

getPartFrom() - Method in class bb.common.WorkInstructionPK

getPartFrom() - Method in class bb.common.WorkInstructionRequestForChangeVO

getPartFrom() - Method in class bb.common.WorkInstructionSequenceListResult

getPartFrom() - Method in class bb.common.WorkInstructionSequencePK

getPartFrom() - Method in class bb.common.WorkOrderInWipResult

getPartFrom() - Method in class bb.common.WorkOrderIssueStatisticsResult

getPartFrom() - Method in class bb.common.WorkOrderItemAgent

getPartFrom() - Method in class bb.common.WorkOrderItemCanAssyResult

getPartFrom() - Method in class bb.common.WorkOrderItemInWipListResult

getPartFrom() - Method in class bb.common.WorkOrderItemIssuedTotalResult

getPartFrom() - Method in class bb.common.WorkOrderItemIssueVO

getPartFrom() - Method in class bb.common.WorkOrderItemLaborCostListResult

getPartFrom() - Method in class bb.common.WorkOrderItemListResult

getPartFrom() - Method in class bb.common.WorkOrderItemPartDetail

getPartFrom() - Method in class bb.common.WorkOrderItemPartDetailInWipVO

getPartFrom() - Method in class bb.common.WorkOrderItemPartDetailItemResult

getPartFrom() - Method in class bb.common.WorkOrderItemPartDetailResult

getPartFrom() - Method in class bb.common.WorkOrderItemReviewCostResult

getPartFrom() - Method in class bb.common.WorkOrderItemSetupItemAgent

getPartFrom() - Method in class bb.common.WorkOrderItemTimeDetailResult

getPartFrom() - Method in class bb.common.WorkOrderItemTimeDetailVO

getPartFrom() - Method in class bb.common.WorkOrderItemToIssueResult

getPartFrom() - Method in class bb.common.WorkOrderItemVO

getPartFrom() - Method in class bb.common.WorkOrderOnDemandResult

getPartFrom() - Method in class bb.common.WorkOrderOnOrderResult

getPartFrom() - Method in class bb.common.WorkOrderOverIssueListResult

getPartFrom() - Method in class bb.common.WorkOrderReceiverVO

getPartFrom() - Method in class bb.common.WorkOrderTimeCardVO

getPartFrom() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getPartFrom() - Method in class bb.common.WorkOrderWorkInstructionVO

getPartInfo() - Method in class bb.common.InventoryAdjustmentDetailResult

getPartInQAII() - Method in class bb.common.IssuedFromOrderItem

getPartInQAII() - Method in class bb.common.ShipperItemDetailAgent

getPartInqaItems() - Method in class bb.common.PartInQAResult

getPartInspection(PartInspectionPK) - Method in interface bb.common.box.QualityBox

getPartInspection(PartInspectionResult) - Method in interface bb.common.box.QualityBox

getPartInspectionCountByPartPK(String, String, String) - Method in interface bb.common.box.QualityBox

getPartInventory() - Method in class bb.common.MrpItemResult

getPartInventory() - Method in class bb.common.PartVO

getPartInventory() - Method in class bb.common.PartWithOnhandsVO

getPartInventory() - Method in class bb.common.ToolVO

getPartInventory() - Method in class bb.common.ToolWithOnhandsVO

getPartInventoryByPk(PartPK) - Method in interface bb.common.box.EngineeringBox

getPartInventoryInfo() - Method in class bb.common.InventoryAdjustmentDetailResult

getPartInventoryVO() - Method in class bb.common.PurchaseWorkSheetItemWithRelatedInfoResult

getPartInventoryVO() - Method in class bb.common.WorkOrderWorkSheetItemWithRelatedInfoResult

getPartInWip() - Method in class bb.common.PartInWipForIDListResult

getPartInWipDescription() - Method in class bb.common.PartInWipForIDListResult

getPartInWipForIDListResultsCountByVendorID(String, String, String, String) - Method in interface bb.common.box.WarehouseBox

getPartInWipForIDListResultsTotalByVendorID(String, String, String, String) - Method in interface bb.common.box.WarehouseBox

getPartInWorkOrderPartDetailCount(String, String, String, String, String, boolean, String, Date, Date) - Method in interface bb.common.box.WorkOrderBox

getPartIssuedCountByDate(Date, Date, String, String, String, String, String, String, String, String, String, String[]) - Method in interface bb.common.box.WarehouseBox

getPartIssueTotalResult(Date, Date, String, String, String, String, String, String, String, String, String, String[]) - Method in interface bb.common.box.WarehouseBox

getPartLocationCount(String) - Method in interface bb.common.box.WarehouseBox

getPartLocations() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getPartLocations() - Method in class bb.common.IssuingItemResult

getPartLocations() - Method in class bb.common.ReceivingItemResult

getPartLocations() - Method in class bb.common.ShipListItemVOResult

getPartManufacturer() - Method in class bb.common.BillItemSalesCostResult

getPartManufacturer() - Method in class bb.common.BillItemWithPartInfoResult

getPartManufacturer() - Method in class bb.common.BillWithPartInfoResult

getPartManufacturers() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getPartManufacturers() - Method in class bb.common.PurchaseWorkSheetItemWithRelatedInfoResult

getPartManufacturers() - Method in class bb.common.ReceivingItemResult

getPartManufacturers() - Method in class bb.common.WorkOrderWorkSheetItemWithRelatedInfoResult

getPartMaterialBomListResultsCount(String, String) - Method in interface bb.common.box.EngineeringBox

getPartMaterialByPk(PartPK) - Method in interface bb.common.box.EngineeringBox

getPartMaterialCount(PartMaterialReportAgent) - Method in interface bb.common.box.EngineeringBox

getPartMaterialCountByPartLike(PartPK) - Method in interface bb.common.box.EngineeringBox

getPartMaterialInfo(PartPK) - Method in interface bb.common.box.EngineeringBox

getPartMaterialWhereUsedResult(PartPK) - Method in interface bb.common.box.EngineeringBox

getPartNumber() - Method in class bb.common.AccountsPayableItemVO

getPartNumber() - Method in class bb.common.AccountsReceivableItemVO

getPartNumber() - Method in class bb.common.AllPartDocumentsPK

getPartNumber() - Method in class bb.common.APItemListResult

getPartNumber() - Method in class bb.common.AuditPartInQAResult

getPartNumber() - Method in class bb.common.BB2Document

getPartNumber() - Method in class bb.common.BB2Part

getPartNumber() - Method in class bb.common.BB2PartOnhandPK

getPartNumber() - Method in class bb.common.BillItemSalesResult

getPartNumber() - Method in class bb.common.BillItemSalesXResult

getPartNumber() - Method in class bb.common.BillItemVO

getPartNumber() - Method in class bb.common.BillLogVO

getPartNumber() - Method in class bb.common.ChangeStdCostWorkSheetItemPK

getPartNumber() - Method in class bb.common.ContractPriceItemPK

getPartNumber() - Method in class bb.common.CorrectiveActionRequestVO

getPartNumber() - Method in class bb.common.CPItemFromQuoteResult

getPartNumber() - Method in class bb.common.CSRAgent

getPartNumber() - Method in class bb.common.CustomerFeedbackVO

getPartNumber() - Method in class bb.common.CustomerReturnToVendorItemVO

getPartNumber() - Method in class bb.common.CustomerServiceIncidentItemListResult

getPartNumber() - Method in class bb.common.CustomerServiceIncidentListResult

getPartNumber() - Method in class bb.common.CustomerServiceIncidentVO

getPartNumber() - Method in class bb.common.CycleCountListResult

getPartNumber() - Method in class bb.common.CycleCountVO

getPartNumber() - Method in class bb.common.DesignControlInfoVO

getPartNumber() - Method in class bb.common.DesignControlVO

getPartNumber() - Method in class bb.common.DisassembleWorkOrderIssueVO

getPartNumber() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

getPartNumber() - Method in class bb.common.DisassembleWorkOrderItemVO

getPartNumber() - Method in class bb.common.DocumentInfoAgent

getPartNumber() - Method in class bb.common.DWOIssueDetail

getPartNumber() - Method in class bb.common.EngineeringChangeRequestVO

getPartNumber() - Method in class bb.common.EngineeringChangeVO

getPartNumber() - Method in class bb.common.EngineeringSharingImportLogVO

getPartNumber() - Method in class bb.common.EngineeringSharingItemPK

getPartNumber() - Method in class bb.common.HistoricalInventoryVO

getPartNumber() - Method in class bb.common.IcrItemListResult

getPartNumber() - Method in class bb.common.InspectionConformanceReportItemVO

getPartNumber() - Method in class bb.common.InventoryAdjustmentVO

getPartNumber() - Method in class bb.common.InventoryMonthReport

getPartNumber() - Method in class bb.common.InventoryNotUsedInMonthsforAppResult

getPartNumber() - Method in class bb.common.InventoryPartInOutDetailListResult

getPartNumber() - Method in class bb.common.InventoryReportListResult

getPartNumber() - Method in class bb.common.InvoiceItemListResult

getPartNumber() - Method in class bb.common.LnShipperItemListResult

getPartNumber() - Method in class bb.common.LogInventoryListResult

getPartNumber() - Method in class bb.common.LogInventoryVO

getPartNumber() - Method in class bb.common.LogMiscDocumentVO

getPartNumber() - Method in class bb.common.LogPartDocumentVO

getPartNumber() - Method in class bb.common.LogPartDwfVO

getPartNumber() - Method in class bb.common.LogPartDwgVO

getPartNumber() - Method in class bb.common.LogTrackingVO

getPartNumber() - Method in class bb.common.MiscDocAgent

getPartNumber() - Method in class bb.common.NcrNeedToScrapListResult

getPartNumber() - Method in class bb.common.NonConformanceReportVO

getPartNumber() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getPartNumber() - Method in class bb.common.NonproductivePickingItemIssuedVO

getPartNumber() - Method in class bb.common.NonproductivePickingItemResult

getPartNumber() - Method in class bb.common.NonproductivePickingItemVO

getPartNumber() - Method in class bb.common.OnLoanItemVO

getPartNumber() - Method in class bb.common.OnloanReceiverItemListResult

getPartNumber() - Method in class bb.common.OnloanReceiverItemVO

getPartNumber() - Method in class bb.common.OnloanShipperItemVO

getPartNumber() - Method in class bb.common.OrderApprovalItemsVO

getPartNumber() - Method in class bb.common.OrderDemandForReceiverResult

getPartNumber() - Method in class bb.common.PackingBoxItemListResult

getPartNumber() - Method in class bb.common.PackingBoxItemVO

getPartNumber() - Method in class bb.common.PackingBoxSalesOrderItemResult

getPartNumber() - Method in class bb.common.PartCatalogAuditResult

getPartNumber() - Method in class bb.common.PartCatalogPK

getPartNumber() - Method in class bb.common.PartCertificateListResult

getPartNumber() - Method in class bb.common.PartCertificateVO

getPartNumber() - Method in class bb.common.PartCostVarianceListResult

getPartNumber() - Method in class bb.common.PartDescriptionPK

getPartNumber() - Method in class bb.common.PartDocumentPK

getPartNumber() - Method in class bb.common.PartDwfAgent

getPartNumber() - Method in class bb.common.PartDwfPK

getPartNumber() - Method in class bb.common.PartDwfWithPartInfoResult

getPartNumber() - Method in class bb.common.PartDwgAgent

getPartNumber() - Method in class bb.common.PartDwgPK

getPartNumber() - Method in class bb.common.PartDwgWithPartInfoResult

getPartNumber() - Method in class bb.common.PartInQAResult

getPartNumber() - Method in class bb.common.PartInQAVO

getPartNumber() - Method in class bb.common.PartInspectionPK

getPartNumber() - Method in class bb.common.PartInspectionResult

getPartNumber() - Method in class bb.common.PartIssuedVO

getPartNumber() - Method in class bb.common.PartManufacturerPK

getPartNumber() - Method in class bb.common.PartOnHandAuditAgent

getPartNumber() - Method in class bb.common.PartOnhandCostVO

getPartNumber() - Method in class bb.common.PartOnhandPK

getPartNumber() - Method in class bb.common.PartPictureVO

getPartNumber() - Method in class bb.common.PartPK

getPartNumber() - Method in class bb.common.PartReceivedVO

getPartNumber() - Method in class bb.common.PartTraceableCategoryPK

getPartNumber() - Method in class bb.common.PartTraceableSpecPK

getPartNumber() - Method in class bb.common.PartTrackingPK

getPartNumber() - Method in class bb.common.PartUnitPK

getPartNumber() - Method in class bb.common.partUsedInfoResult

getPartNumber() - Method in class bb.common.PartUseTypeVO

getPartNumber() - Method in class bb.common.PartVendorPK

getPartNumber() - Method in class bb.common.PartWithInventoryInfoListResult

getPartNumber() - Method in class bb.common.PartWithManufacturerInfoResult

getPartNumber() - Method in class bb.common.PfReceiverItemVO

getPartNumber() - Method in class bb.common.PhysicalInventoryListResult

getPartNumber() - Method in class bb.common.PhysicalInventoryVO

getPartNumber() - Method in class bb.common.POReceiverItemListResult

getPartNumber() - Method in class bb.common.POSurveyReportItemVO

getPartNumber() - Method in class bb.common.PreventiveActionRequestVO

getPartNumber() - Method in class bb.common.ProformaInvoiceItemListResult

getPartNumber() - Method in class bb.common.ProformaInvoiceItemVO

getPartNumber() - Method in class bb.common.PrPackingBoxItemVO

getPartNumber() - Method in class bb.common.PurchaseOrderContractResult

getPartNumber() - Method in class bb.common.PurchaseOrderItemVO

getPartNumber() - Method in class bb.common.PurchaseWorkSheetItemVO

getPartNumber() - Method in class bb.common.QuoteItemVO

getPartNumber() - Method in class bb.common.ReceiverItemVO

getPartNumber() - Method in class bb.common.RequestForQuoteItemVO

getPartNumber() - Method in class bb.common.RequestForRMAItemVO

getPartNumber() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getPartNumber() - Method in class bb.common.ReturnToVendorItemVO

getPartNumber() - Method in class bb.common.RMAReceiverItemListResult

getPartNumber() - Method in class bb.common.RMAReceiverItemVO

getPartNumber() - Method in class bb.common.RtvShipperItemListResult

getPartNumber() - Method in class bb.common.RtvShipperItemVO

getPartNumber() - Method in class bb.common.RunningAccountOrderItemVO

getPartNumber() - Method in class bb.common.SalesOrderItemGroupByPartListResult

getPartNumber() - Method in class bb.common.SalesOrderItemInfoVO

getPartNumber() - Method in class bb.common.SalesOrderItemVO

getPartNumber() - Method in class bb.common.SalesOrderShipDateListResult

getPartNumber() - Method in class bb.common.SalesTaxListResult

getPartNumber() - Method in class bb.common.ScrapReportVO

getPartNumber() - Method in class bb.common.SGBillItemVO

getPartNumber() - Method in class bb.common.SGBOMItemResult

getPartNumber() - Method in class bb.common.SGCustomerCatalogPK

getPartNumber() - Method in class bb.common.SGCustomerServiceRequestVO

getPartNumber() - Method in class bb.common.SGCustRequestForQuoteItemResult

getPartNumber() - Method in class bb.common.SGCustRequestForQuoteItemVO

getPartNumber() - Method in class bb.common.SGDocPartPK

getPartNumber() - Method in class bb.common.SGDwgPicturePK

getPartNumber() - Method in class bb.common.SGPartCartAgent

getPartNumber() - Method in class bb.common.SGPartCatalogResult

getPartNumber() - Method in class bb.common.SGPartDocFlagResult

getPartNumber() - Method in class bb.common.SGPartListItemResult

getPartNumber() - Method in class bb.common.SGPartListResult

getPartNumber() - Method in class bb.common.SGPicturePK

getPartNumber() - Method in class bb.common.SGQuoteCartListResult

getPartNumber() - Method in class bb.common.SGQuoteCartVO

getPartNumber() - Method in class bb.common.SGSaleItemVO

getPartNumber() - Method in class bb.common.ShipListItemVOResult

getPartNumber() - Method in class bb.common.ShipperItemListResult

getPartNumber() - Method in class bb.common.ShipperItemVO

getPartNumber() - Method in class bb.common.ShoppingCartItem

getPartNumber() - Method in class bb.common.SOShipperItemListResult

getPartNumber() - Method in class bb.common.SwapOrderItemListResult

getPartNumber() - Method in class bb.common.SwapOrderItemVO

getPartNumber() - Method in class bb.common.SwapReceiverItemListResult

getPartNumber() - Method in class bb.common.SwapReceiverItemVO

getPartNumber() - Method in class bb.common.SwapShipperItemListResult

getPartNumber() - Method in class bb.common.SwapShipperItemVO

getPartNumber() - Method in class bb.common.ToolCalibrationVO

getPartNumber() - Method in class bb.common.ToolListItemVO

getPartNumber() - Method in class bb.common.TransferOrderItemListResult

getPartNumber() - Method in class bb.common.TransferOrderItemVO

getPartNumber() - Method in class bb.common.TransferReceiverItemListResult

getPartNumber() - Method in class bb.common.TransferReceiverItemVO

getPartNumber() - Method in class bb.common.TransferShipperItemListResult

getPartNumber() - Method in class bb.common.TransferShipperItemVO

getPartNumber() - Method in class bb.common.VendorContractPriceItemPK

getPartNumber() - Method in class bb.common.VendorPartVO

getPartNumber() - Method in class bb.common.VendorQtyPricePK

getPartNumber() - Method in class bb.common.WCLoadDetailResult

getPartNumber() - Method in class bb.common.WOReceiverDetail

getPartNumber() - Method in class bb.common.WorkInstructionDocumentVO

getPartNumber() - Method in class bb.common.WorkInstructionListResult

getPartNumber() - Method in class bb.common.WorkInstructionPictureVO

getPartNumber() - Method in class bb.common.WorkInstructionPK

getPartNumber() - Method in class bb.common.WorkInstructionRequestForChangeVO

getPartNumber() - Method in class bb.common.WorkInstructionSequenceListResult

getPartNumber() - Method in class bb.common.WorkInstructionSequencePK

getPartNumber() - Method in class bb.common.WorkOrderIssueStatisticsResult

getPartNumber() - Method in class bb.common.WorkOrderItemCanAssyAgent

getPartNumber() - Method in class bb.common.WorkOrderItemCanAssyResult

getPartNumber() - Method in class bb.common.WorkOrderItemInfoResult

getPartNumber() - Method in class bb.common.WorkOrderItemInWipListResult

getPartNumber() - Method in class bb.common.WorkOrderItemIssuedTotalResult

getPartNumber() - Method in class bb.common.WorkOrderItemIssueVO

getPartNumber() - Method in class bb.common.WorkOrderItemLaborCostListResult

getPartNumber() - Method in class bb.common.WorkOrderItemPartDetailInWipVO

getPartNumber() - Method in class bb.common.WorkOrderItemReviewCostResult

getPartNumber() - Method in class bb.common.WorkOrderItemTimeDetailVO

getPartNumber() - Method in class bb.common.WorkOrderItemToIssueResult

getPartNumber() - Method in class bb.common.WorkOrderItemVO

getPartNumber() - Method in class bb.common.WorkOrderQueryInfo

getPartNumber() - Method in class bb.common.WorkOrderReceiverVO

getPartNumber() - Method in class bb.common.WorkOrderTimeCardVO

getPartNumber() - Method in class bb.common.WorkOrderWorkInstructionListResult

getPartNumber() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getPartNumber() - Method in class bb.common.WorkOrderWorkInstructionVO

getPartNumber() - Method in class bb.common.WorkOrderWorkSheetItemVO

getPartNumberFrom() - Method in class bb.common.MrpReportAgent

getPartNumberGenerateType() - Method in class bb.common.CompanyVO

getPartNumberMaxLength() - Method in class bb.common.CompanyVO

getPartNumberMinLength() - Method in class bb.common.CompanyVO

getPartNumbers() - Method in class bb.common.MrpReportAgent

getPartNumberSeqLength() - Method in class bb.common.CompanyVO

getPartNumberTo() - Method in class bb.common.MrpReportAgent

getPartNumPrefix(int, String, Date) - Method in interface bb.common.box.WarehouseBox

getPartNums() - Method in class bb.common.BOMCanAssyAgent

getPartOnDemandQtyListResultsCount() - Method in interface bb.common.box.WarehouseBox

getPartOnDemandTotalAmount() - Method in interface bb.common.box.WarehouseBox

getPartOnhand() - Method in class bb.common.PartInQAResult

getPartOnhand() - Method in class bb.common.RunningAccountOrderItemVO

getPartOnHandAuditResult(PartPK, Date) - Method in interface bb.common.box.WarehouseBox

getPartOnhandDetailInfoByPartPk(BB2Part) - Method in interface bb.common.box.WarehouseBox

getPartOnhandIsZeroByPartCount(PartPK) - Method in interface bb.common.box.WarehouseBox

getPartOnhandLocations() - Method in class bb.common.ShippingItemResult

getPartOnhandResultsCountByLocate(String, String, String, String, boolean) - Method in interface bb.common.box.WarehouseBox

getPartOnhands() - Method in class bb.common.WoItemPickListItemResult

getPartOnhandVo() - Method in class bb.common.PartOnhandWithAverageCostResult

getPartOnhandWithoutTrackingCount(String, String, boolean) - Method in interface bb.common.box.QualityBox

getPartOnholdCount() - Method in class bb.common.EngineeringInfoCenterResult

getPartOnLoanQtyListResultsCount() - Method in interface bb.common.box.WarehouseBox

getPartOnLoanTotalAmount() - Method in interface bb.common.box.WarehouseBox

getPartOnOrderQtyListResultsCount() - Method in interface bb.common.box.WarehouseBox

getPartOnOrderTotalAmount() - Method in interface bb.common.box.WarehouseBox

getPartOrAssy() - Method in class bb.common.SalesOrderItemListResult

getPartPictureByPk(PartPK) - Method in interface bb.common.box.EngineeringBox

getPartPk() - Method in class bb.common.AddPhysicalInventoryAgent

getPartPk() - Method in class bb.common.AuditOnDemandResult

getPartPk() - Method in class bb.common.BB2Part

getPartPk() - Method in class bb.common.BillSalesResult

getPartPk() - Method in class bb.common.BillSalesXResult

getPartPk() - Method in class bb.common.BillWhereUsedResult

getPartPk() - Method in class bb.common.BomItemWithOEMResult

getPartPk() - Method in class bb.common.BomPickListItemResult

getPartPk() - Method in class bb.common.CRTVItemListResult

getPartPk() - Method in class bb.common.DesignControlListResult

getPartPk() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getPartPk() - Method in class bb.common.DisassembleWorkOrderItemListResult

getPartPk() - Method in class bb.common.DisassembleWorkOrderItemPartDetailItemResult

getPartPk() - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

getPartPk() - Method in class bb.common.DisassembleWorkOrderReceivingResult

getPartPk() - Method in class bb.common.EngineeringChangeListResult

getPartPk() - Method in class bb.common.EngineeringChangeRequestListResult

getPartPK() - Method in class bb.common.InventoryReportListResult

getPartPk() - Method in class bb.common.IssueItemAgent

getPartPk() - Method in class bb.common.IssuingItemResult

getPartPk() - Method in class bb.common.IssuingResult

getPartPk() - Method in class bb.common.JobProcessSheetListResult

getPartPK() - Method in class bb.common.JobProcessSheetResult

getPartPk() - Method in class bb.common.NonproductivePickingOnDemandResult

getPartPk() - Method in class bb.common.OnLoanItemListResult

getPartPk() - Method in class bb.common.OrderDemandForReceiverResult

getPartPk() - Method in class bb.common.PartBasicInfo

getPartPk() - Method in class bb.common.PartInMrpListResult

getPartPk() - Method in class bb.common.PartMaterialReportAgent

getPartPk() - Method in class bb.common.PartMaterialWhereUsedResult

getPartPk() - Method in class bb.common.PartWithExcessiveInventoryListResult

getPartPk() - Method in class bb.common.PartWithOnLoanQtyListResult

getPartPk() - Method in class bb.common.PartWithQAQtyListResult

getPartPk() - Method in class bb.common.PartWithQtyListResult

getPartPk() - Method in class bb.common.PartWithSipQtyListResult

getPartPk() - Method in class bb.common.PartWithSITQtyListResult

getPartPk() - Method in class bb.common.PartWithSTOQtyListResult

getPartPk() - Method in class bb.common.PartWithWipQtyListResult

getPartPK() - Method in class bb.common.PO2SOExchangeItem

getPartPk() - Method in class bb.common.PurchaseOrderItemListResult

getPartPk() - Method in class bb.common.PurchaseOrderOnOrderResult

getPartPk() - Method in class bb.common.PurchaseOrderOpenDueListResult

getPartPk() - Method in class bb.common.QuoteItemListResult

getPartPk() - Method in class bb.common.ReceivingItemResult

getPartPk() - Method in class bb.common.RequestForQuoteItemListResult

getPartPk() - Method in class bb.common.ReturnToVendorByDateListResult

getPartPk() - Method in class bb.common.ReturnToVendorItemListResult

getPartPk() - Method in class bb.common.RMAItemListResult

getPartPk() - Method in class bb.common.RRMAItemListResult

getPartPk() - Method in class bb.common.SalesBomItemResult

getPartPk() - Method in class bb.common.SalesOrderItemListResult

getPartPk() - Method in class bb.common.SalesOrderOnDemandResult

getPartPk() - Method in class bb.common.SalesPartListItemResult

getPartPk() - Method in class bb.common.ShippingItemResult

getPartPk() - Method in class bb.common.SwapShipperOnOrderResult

getPartPk() - Method in class bb.common.UpdatePhysicalInventoryAgent

getPartPk() - Method in class bb.common.WoItemPickListItemResult

getPartPk() - Method in class bb.common.WoItemPickListResult

getPartPk() - Method in class bb.common.WorkOrderInWipResult

getPartPk() - Method in class bb.common.WorkOrderItemAgent

getPartPk() - Method in class bb.common.WorkOrderItemListResult

getPartPk() - Method in class bb.common.WorkOrderItemPartDetail

getPartPk() - Method in class bb.common.WorkOrderItemPartDetailItemResult

getPartPk() - Method in class bb.common.WorkOrderItemPartDetailResult

getPartPk() - Method in class bb.common.WorkOrderItemSetupItemAgent

getPartPk() - Method in class bb.common.WorkOrderItemTimeDetailResult

getPartPk() - Method in class bb.common.WorkOrderOnDemandResult

getPartPk() - Method in class bb.common.WorkOrderOnOrderResult

getPartPk() - Method in class bb.common.WorkOrderOverIssueListResult

getPartPk() - Method in class bb.common.WorkSheetPartAgent

getPartPKList(MrpReportAgent) - Method in interface bb.common.box.PurchasingBox

getPartPKs() - Method in class bb.common.BOMTreeRollUPMap

getPartPKsCountForRecursiveBill(String) - Method in interface bb.common.box.EngineeringBox

getPartPKsToAudit(String, Date) - Method in interface bb.common.box.WarehouseBox

getPartPKsToAuditCount(String, Date) - Method in interface bb.common.box.WarehouseBox

getPartPoUnit() - Method in class bb.common.PartVO

getPartPoUnit() - Method in class bb.common.PartWithOnhandsVO

getPartPoUnitRate() - Method in class bb.common.PartVO

getPartPoUnitRate() - Method in class bb.common.PartWithOnhandsVO

getPartPrefix() - Method in class bb.common.WareHousePartPrefixKeeperVO

getPartPutBackToStock() - Method in class bb.common.NcrNeedToScrapListResult

getPartPutBackToStock() - Method in class bb.common.NcrReportListResult

getPartPutBackToStock() - Method in class bb.common.NonConformanceReportResult

getPartPutBackToStock() - Method in class bb.common.NonConformanceReportVO

getPartPutBackToStockDate() - Method in class bb.common.NonConformanceReportVO

getPartQuantity() - Method in class bb.common.BillItemVO

getPartQuantity() - Method in class bb.common.BillItemWithPartInfoResult

getPartQuantity() - Method in class bb.common.BillLogVO

getPartQuantity() - Method in class bb.common.PartWhereUsedItemResult

getPartQuantity() - Method in class bb.common.ToolListItemVO

getPartQuantity() - Method in class bb.common.ToolListItemWithToolInfoResult

getPartQuantity() - Method in class bb.common.ToolWhereUsedItemResult

getPartReceivedCountByDate(Date, Date, String, String, String, String, String, String, String, String, String[]) - Method in interface bb.common.box.WarehouseBox

getPartReceivedTotalResult(Date, Date, String, String, String, String, String, String, String, String, String[]) - Method in interface bb.common.box.WarehouseBox

getPartRev() - Method in class bb.common.WorkInstructionListResult

getPartRevision() - Method in class bb.common.DocumentInfoAgent

getPartRevision() - Method in class bb.common.IcrItemListResult

getPartRevision() - Method in class bb.common.InspectionConformanceReportItemVO

getPartRevision() - Method in class bb.common.NonConformanceReportVO

getPartRevision() - Method in class bb.common.PartDwfWithPartInfoResult

getPartRevision() - Method in class bb.common.PartDwgWithPartInfoResult

getPartsByHistoricalInventorys(String, String, Date, Date) - Method in interface bb.common.box.WarehouseBox

getPartsByPartCommodityCode(BigDecimal, String) - Method in interface bb.common.box.EngineeringBox

getPartsByPartEngGroup(String, String, String, String) - Method in interface bb.common.box.EngineeringBox

getPartsCountByDescriptionInside(String, String, String, String) - Method in interface bb.common.box.EngineeringBox

getPartsCountByDescriptionStart(String) - Method in interface bb.common.box.EngineeringBox

getPartsCountByEngineeringSharingRule(String) - Method in interface bb.common.box.EngineeringBox

getPartsCountByManufacturerId(String) - Method in interface bb.common.box.EngineeringBox

getPartsCountByManufacturerPn(String) - Method in interface bb.common.box.EngineeringBox

getPartsCountByManufacturerPnStartWith(String) - Method in interface bb.common.box.EngineeringBox

getPartsCountByOnHold() - Method in interface bb.common.box.EngineeringBox

getPartsCountByPartAndDesc(String, String, String, String, String, String, String, String, String, String, String) - Method in interface bb.common.box.EngineeringBox

getPartsCountByPartLike(String, String) - Method in interface bb.common.box.EngineeringBox

getPartsCountByPK(PartPK) - Method in interface bb.common.box.EngineeringBox

getPartsCountsByDescriptionAndLang(String[], String) - Method in interface bb.common.box.EngineeringBox

getPartSecurityLevelByIdCount(String) - Method in interface bb.common.box.EngineeringBox

getPartSecurityLevelByPk(String) - Method in interface bb.common.box.EngineeringBox

getPartSerialNumber() - Method in class bb.common.NonConformanceReportVO

getPartsInQAsWithoutNCR(BB2Part) - Method in interface bb.common.box.WarehouseBox

getPartSmallCatagoryLength() - Method in class bb.common.CompanyVO

getPartSplitChar() - Method in class bb.common.CompanyVO

getPartsPulledFromStock() - Method in class bb.common.NcrNeedToScrapListResult

getPartsPulledFromStock() - Method in class bb.common.NcrReportListResult

getPartsPulledFromStock() - Method in class bb.common.NonConformanceReportResult

getPartsPulledFromStock() - Method in class bb.common.NonConformanceReportVO

getPartsPulledFromStockDate() - Method in class bb.common.NonConformanceReportVO

getPartsToDeletedNotUsed() - Method in class bb.common.PartsToDeleteResult

getPartsToDeleteInPO() - Method in class bb.common.PartsToDeleteResult

getPartsToDeleteInPoCount() - Method in interface bb.common.box.EngineeringBox

getPartsToDeleteInSO() - Method in class bb.common.PartsToDeleteResult

getPartsToDeleteInSoCount() - Method in interface bb.common.box.EngineeringBox

getPartsToDeleteInWO() - Method in class bb.common.PartsToDeleteResult

getPartsToDeleteInWOItemDetail() - Method in class bb.common.PartsToDeleteResult

getPartsToDeleteInWoItemDetailCount() - Method in interface bb.common.box.EngineeringBox

getPartsToRollUPunder(BillPK) - Method in interface bb.common.box.EngineeringBox

getPartsWithBomCount() - Method in interface bb.common.box.EngineeringBox

getPartsWithDeletedCount() - Method in interface bb.common.box.EngineeringBox

getPartsWithDrawingCount() - Method in interface bb.common.box.EngineeringBox

getPartsWithWiCount() - Method in interface bb.common.box.EngineeringBox

getPartToAuditFlagResultsForBOM(String) - Method in interface bb.common.box.EngineeringBox

getPartToAuditFlagResultsForDrawing(String) - Method in interface bb.common.box.EngineeringBox

getPartToAuditFlagResultsForPicture(String) - Method in interface bb.common.box.EngineeringBox

getPartToAuditFlagResultsForWI(String) - Method in interface bb.common.box.EngineeringBox

getPartTraceabeListResultsCount(String, String) - Method in interface bb.common.box.EngineeringBox

getPartTraceableCategoryByPk(PartTraceableCategoryPK) - Method in interface bb.common.box.EngineeringBox

getPartTraceableSpecByPk(PartTraceableSpecPK) - Method in interface bb.common.box.EngineeringBox

getPartTraceableSpecItem() - Method in class bb.common.PartTraceableSpecPK

getPartTracking() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getPartTracking() - Method in class bb.common.IssuingItemResult

getPartTracking() - Method in class bb.common.ReceivingItemResult

getPartTracking() - Method in class bb.common.ShippingItemResult

getPartType() - Method in class bb.common.AccountsPayableItemVO

getPartType() - Method in class bb.common.AccountsReceivableItemVO

getPartType() - Method in class bb.common.APItemListResult

getPartType() - Method in class bb.common.AuditPartInQAResult

getPartType() - Method in class bb.common.BB2Part

getPartType() - Method in class bb.common.BB2PartOnhandPK

getPartType() - Method in class bb.common.BillItemSalesResult

getPartType() - Method in class bb.common.BillItemSalesXResult

getPartType() - Method in class bb.common.BillItemVO

getPartType() - Method in class bb.common.BillLogVO

getPartType() - Method in class bb.common.ChangeStdCostWorkSheetItemPK

getPartType() - Method in class bb.common.ContractPriceItemPK

getPartType() - Method in class bb.common.CorrectiveActionRequestVO

getPartType() - Method in class bb.common.CPItemFromQuoteResult

getPartType() - Method in class bb.common.CSRAgent

getPartType() - Method in class bb.common.CustomerFeedbackVO

getPartType() - Method in class bb.common.CustomerReturnToVendorItemVO

getPartType() - Method in class bb.common.CustomerServiceIncidentItemListResult

getPartType() - Method in class bb.common.CustomerServiceIncidentListResult

getPartType() - Method in class bb.common.CustomerServiceIncidentVO

getPartType() - Method in class bb.common.CycleCountListResult

getPartType() - Method in class bb.common.CycleCountVO

getPartType() - Method in class bb.common.DesignControlInfoVO

getPartType() - Method in class bb.common.DesignControlVO

getPartType() - Method in class bb.common.DisassembleWorkOrderIssueVO

getPartType() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

getPartType() - Method in class bb.common.DisassembleWorkOrderItemVO

getPartType() - Method in class bb.common.DWOIssueDetail

getPartType() - Method in class bb.common.EngineeringChangeRequestVO

getPartType() - Method in class bb.common.EngineeringChangeVO

getPartType() - Method in class bb.common.EngineeringSharingImportLogVO

getPartType() - Method in class bb.common.EngineeringSharingItemPK

getPartType() - Method in class bb.common.HistoricalInventoryVO

getPartType() - Method in class bb.common.IcrItemListResult

getPartType() - Method in class bb.common.InspectionConformanceReportItemVO

getPartType() - Method in class bb.common.InventoryAdjustmentVO

getPartType() - Method in class bb.common.InventoryMonthReport

getPartType() - Method in class bb.common.InventoryNotUsedInMonthsforAppResult

getPartType() - Method in class bb.common.InventoryPartInOutDetailListResult

getPartType() - Method in class bb.common.InventoryReportListResult

getPartType() - Method in class bb.common.InvoiceItemListResult

getPartType() - Method in class bb.common.LnShipperItemListResult

getPartType() - Method in class bb.common.LogInventoryListResult

getPartType() - Method in class bb.common.LogInventoryVO

getPartType() - Method in class bb.common.LogMiscDocumentVO

getPartType() - Method in class bb.common.LogPartDwfVO

getPartType() - Method in class bb.common.LogPartDwgVO

getPartType() - Method in class bb.common.LogTrackingVO

getPartType() - Method in class bb.common.MiscDocAgent

getPartType() - Method in class bb.common.MrpReportAgent

getPartType() - Method in class bb.common.NcrNeedToScrapListResult

getPartType() - Method in class bb.common.NonConformanceReportVO

getPartType() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getPartType() - Method in class bb.common.NonproductivePickingItemIssuedVO

getPartType() - Method in class bb.common.NonproductivePickingItemResult

getPartType() - Method in class bb.common.NonproductivePickingItemVO

getPartType() - Method in class bb.common.OnLoanItemVO

getPartType() - Method in class bb.common.OnloanReceiverItemListResult

getPartType() - Method in class bb.common.OnloanReceiverItemVO

getPartType() - Method in class bb.common.OnloanShipperItemVO

getPartType() - Method in class bb.common.OrderApprovalItemsVO

getPartType() - Method in class bb.common.OrderDemandForReceiverResult

getPartType() - Method in class bb.common.PackingBoxItemListResult

getPartType() - Method in class bb.common.PackingBoxItemVO

getPartType() - Method in class bb.common.PackingBoxSalesOrderItemResult

getPartType() - Method in class bb.common.PartCatalogAuditResult

getPartType() - Method in class bb.common.PartCatalogPK

getPartType() - Method in class bb.common.PartCertificateListResult

getPartType() - Method in class bb.common.PartCertificateVO

getPartType() - Method in class bb.common.PartCostVarianceListResult

getPartType() - Method in class bb.common.PartDescriptionPK

getPartType() - Method in class bb.common.PartDwfAgent

getPartType() - Method in class bb.common.PartDwfPK

getPartType() - Method in class bb.common.PartDwfWithPartInfoResult

getPartType() - Method in class bb.common.PartDwgAgent

getPartType() - Method in class bb.common.PartDwgPK

getPartType() - Method in class bb.common.PartDwgWithPartInfoResult

getPartType() - Method in class bb.common.PartInQAResult

getPartType() - Method in class bb.common.PartInQAVO

getPartType() - Method in class bb.common.PartInspectionPK

getPartType() - Method in class bb.common.PartInspectionResult

getPartType() - Method in class bb.common.PartIssuedVO

getPartType() - Method in class bb.common.PartManufacturerPK

getPartType() - Method in class bb.common.PartOnhandCostVO

getPartType() - Method in class bb.common.PartOnhandPK

getPartType() - Method in class bb.common.PartPictureVO

getPartType() - Method in class bb.common.PartPK

getPartType() - Method in class bb.common.PartReceivedVO

getPartType() - Method in class bb.common.PartTraceableCategoryPK

getPartType() - Method in class bb.common.PartTraceableSpecPK

getPartType() - Method in class bb.common.PartTrackingPK

getPartType() - Method in class bb.common.PartTypeVO

getPartType() - Method in class bb.common.PartUnitPK

getPartType() - Method in class bb.common.PartUseTypeVO

getPartType() - Method in class bb.common.PartVendorPK

getPartType() - Method in class bb.common.PartWithInventoryInfoListResult

getPartType() - Method in class bb.common.PartWithManufacturerInfoResult

getPartType() - Method in class bb.common.PfReceiverItemVO

getPartType() - Method in class bb.common.PhysicalInventoryListResult

getPartType() - Method in class bb.common.PhysicalInventoryVO

getPartType() - Method in class bb.common.POReceiverItemListResult

getPartType() - Method in class bb.common.POSurveyReportItemVO

getPartType() - Method in class bb.common.PreventiveActionRequestVO

getPartType() - Method in class bb.common.ProformaInvoiceItemListResult

getPartType() - Method in class bb.common.ProformaInvoiceItemVO

getPartType() - Method in class bb.common.PrPackingBoxItemVO

getPartType() - Method in class bb.common.PurchaseOrderContractResult

getPartType() - Method in class bb.common.PurchaseOrderItemVO

getPartType() - Method in class bb.common.PurchaseWorkSheetItemVO

getPartType() - Method in class bb.common.QuoteItemVO

getPartType() - Method in class bb.common.ReceiverItemVO

getPartType() - Method in class bb.common.RequestForQuoteItemVO

getPartType() - Method in class bb.common.RequestForRMAItemVO

getPartType() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getPartType() - Method in class bb.common.ReturnToVendorItemVO

getPartType() - Method in class bb.common.RMAReceiverItemListResult

getPartType() - Method in class bb.common.RMAReceiverItemVO

getPartType() - Method in class bb.common.RtvShipperItemListResult

getPartType() - Method in class bb.common.RtvShipperItemVO

getPartType() - Method in class bb.common.RunningAccountOrderItemVO

getPartType() - Method in class bb.common.SalesOrderItemGroupByPartListResult

getPartType() - Method in class bb.common.SalesOrderItemInfoVO

getPartType() - Method in class bb.common.SalesOrderItemVO

getPartType() - Method in class bb.common.SalesOrderShipDateListResult

getPartType() - Method in class bb.common.SalesTaxListResult

getPartType() - Method in class bb.common.ScrapReportVO

getPartType() - Method in class bb.common.SGBillItemVO

getPartType() - Method in class bb.common.SGBOMItemResult

getPartType() - Method in class bb.common.SGCustomerCatalogPK

getPartType() - Method in class bb.common.SGCustomerServiceRequestVO

getPartType() - Method in class bb.common.SGCustRequestForQuoteItemResult

getPartType() - Method in class bb.common.SGCustRequestForQuoteItemVO

getPartType() - Method in class bb.common.SGPartCartAgent

getPartType() - Method in class bb.common.SGPartCatalogResult

getPartType() - Method in class bb.common.SGPartListItemResult

getPartType() - Method in class bb.common.SGPartListResult

getPartType() - Method in class bb.common.SGQuoteCartListResult

getPartType() - Method in class bb.common.SGQuoteCartVO

getPartType() - Method in class bb.common.SGSaleItemVO

getPartType() - Method in class bb.common.ShipListItemVOResult

getPartType() - Method in class bb.common.ShipperItemListResult

getPartType() - Method in class bb.common.ShipperItemVO

getPartType() - Method in class bb.common.ShoppingCartItem

getPartType() - Method in class bb.common.SOShipperItemListResult

getPartType() - Method in class bb.common.SwapOrderItemListResult

getPartType() - Method in class bb.common.SwapOrderItemVO

getPartType() - Method in class bb.common.SwapReceiverItemListResult

getPartType() - Method in class bb.common.SwapReceiverItemVO

getPartType() - Method in class bb.common.SwapShipperItemListResult

getPartType() - Method in class bb.common.SwapShipperItemVO

getPartType() - Method in class bb.common.ToolCalibrationVO

getPartType() - Method in class bb.common.ToolListItemVO

getPartType() - Method in class bb.common.TransferOrderItemListResult

getPartType() - Method in class bb.common.TransferOrderItemVO

getPartType() - Method in class bb.common.TransferReceiverItemListResult

getPartType() - Method in class bb.common.TransferReceiverItemVO

getPartType() - Method in class bb.common.TransferShipperItemListResult

getPartType() - Method in class bb.common.TransferShipperItemVO

getPartType() - Method in class bb.common.VendorContractPriceItemPK

getPartType() - Method in class bb.common.VendorPartVO

getPartType() - Method in class bb.common.VendorQtyPricePK

getPartType() - Method in class bb.common.WCLoadDetailResult

getPartType() - Method in class bb.common.WOReceiverDetail

getPartType() - Method in class bb.common.WorkInstructionDocumentVO

getPartType() - Method in class bb.common.WorkInstructionListResult

getPartType() - Method in class bb.common.WorkInstructionPictureVO

getPartType() - Method in class bb.common.WorkInstructionPK

getPartType() - Method in class bb.common.WorkInstructionRequestForChangeVO

getPartType() - Method in class bb.common.WorkInstructionSequenceListResult

getPartType() - Method in class bb.common.WorkInstructionSequencePK

getPartType() - Method in class bb.common.WorkOrderIssueStatisticsResult

getPartType() - Method in class bb.common.WorkOrderItemCanAssyResult

getPartType() - Method in class bb.common.WorkOrderItemInfoResult

getPartType() - Method in class bb.common.WorkOrderItemInWipListResult

getPartType() - Method in class bb.common.WorkOrderItemIssuedTotalResult

getPartType() - Method in class bb.common.WorkOrderItemIssueVO

getPartType() - Method in class bb.common.WorkOrderItemLaborCostListResult

getPartType() - Method in class bb.common.WorkOrderItemPartDetailInWipVO

getPartType() - Method in class bb.common.WorkOrderItemReviewCostResult

getPartType() - Method in class bb.common.WorkOrderItemTimeDetailVO

getPartType() - Method in class bb.common.WorkOrderItemToIssueResult

getPartType() - Method in class bb.common.WorkOrderItemVO

getPartType() - Method in class bb.common.WorkOrderReceiverVO

getPartType() - Method in class bb.common.WorkOrderTimeCardVO

getPartType() - Method in class bb.common.WorkOrderWorkInstructionListResult

getPartType() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getPartType() - Method in class bb.common.WorkOrderWorkInstructionVO

getPartType() - Method in class bb.common.WorkOrderWorkSheetItemVO

getPartTypeByID(String) - Method in interface bb.common.box.CompanyBox

getPartTypeCountByTypeLike(String) - Method in interface bb.common.box.CompanyBox

getPartUnit() - Method in class bb.common.BomPickListItemResult

getPartUnit() - Method in class bb.common.CompanyVO

getPartUnit() - Method in class bb.common.DisassembleWorkOrderItemVO

getPartUnit() - Method in class bb.common.InventoryCycleResult

getPartUnit() - Method in class bb.common.PartBasicInfo

getPartUnit() - Method in class bb.common.PartInMrpListResult

getPartUnit() - Method in class bb.common.PartOnhandResult

getPartUnit() - Method in class bb.common.PartVO

getPartUnit() - Method in class bb.common.PartWithOnhandsVO

getPartUnit() - Method in class bb.common.ToolVO

getPartUnit() - Method in class bb.common.ToolWithOnhandsVO

getPartUnit() - Method in class bb.common.WoItemPickListItemResult

getPartUnit() - Method in class bb.common.WoItemPickListResult

getPartUnit() - Method in class bb.common.WorkOrderItemVO

getPartUseds(ArrayList<BillPK>, PartPK) - Method in interface bb.common.box.EngineeringBox

getPartVendors() - Method in class bb.common.PurchaseWorkSheetItemWithRelatedInfoResult

getPartVendors() - Method in class bb.common.WorkOrderWorkSheetItemWithRelatedInfoResult

getPartWhereUsedItemResult() - Method in class bb.common.PartWhereUsedResult

getPartWithExcessiveInventoryListResultsCount(boolean) - Method in interface bb.common.box.WarehouseBox

getPartWithExcessiveInventoryListResultsCount(String, String) - Method in interface bb.common.box.WarehouseBox

getPartWithExcessiveInventoryTotal(boolean) - Method in interface bb.common.box.WarehouseBox

getPartWithInspectionCount(String, String, String) - Method in interface bb.common.box.QualityBox

getPartWithInspectionTypeCount(String, String, String, String) - Method in interface bb.common.box.QualityBox

getPartWithMaxQtyTotalAmount() - Method in interface bb.common.box.WarehouseBox

getPartWithMinQtyTotalAmount() - Method in interface bb.common.box.WarehouseBox

getPartWithOnhands(PartPK) - Method in interface bb.common.box.EngineeringBox

getPartWithoutClassInfoResultCount(String, String, String, String) - Method in interface bb.common.box.WarehouseBox

getPartWithoutLocationCount(PartPK) - Method in interface bb.common.box.WarehouseBox

getPartWithQAQtyListResultsCount() - Method in interface bb.common.box.WarehouseBox

getPartWithQAQtyTotal() - Method in interface bb.common.box.WarehouseBox

getPartWithSipQtyListResultsCount() - Method in interface bb.common.box.WarehouseBox

getPartWithSipQtyTotal() - Method in interface bb.common.box.WarehouseBox

getPartWithSITQtyListResultsCount(String, String, boolean) - Method in interface bb.common.box.WarehouseBox

getPartWithSITQtyTotal(String, String, boolean) - Method in interface bb.common.box.WarehouseBox

getPartWithSTOQtyListResultsCount(String, String, boolean) - Method in interface bb.common.box.WarehouseBox

getPartWithSTOQtyTotal(String, String, boolean) - Method in interface bb.common.box.WarehouseBox

getPartWithWipQtyListResultsCount() - Method in interface bb.common.box.WarehouseBox

getPartWithWipQtyListResultsCount(String, String) - Method in interface bb.common.box.WarehouseBox

getPartWithWipQtyTotal() - Method in interface bb.common.box.WarehouseBox

getPassword() - Method in class bb.common.BB2Login

getPassword() - Method in class bb.common.BizBoxServer

getPassword() - Method in class bb.common.BizboxUserVO

getPassword() - Method in class bb.common.CashierVO

getPassword() - Method in class bb.common.CustomerVendorAddressVO

getPassword() - Method in class bb.common.QualityGroupVO

getPassword() - Method in class bb.common.SalesmanVO

getPassword() - Method in class bb.common.SGCartLogin

getPassword() - Method in class bb.common.SGClientAccountVO

getPassword() - Method in class bb.common.SGClientLogin

getPassword() - Method in class bb.common.SgClientProgramUserVO

getPassword() - Method in class bb.common.SGQuoteAddressVO

getPassword() - Method in class bb.common.SmtpServerVO

getPassword() - Method in class bb.common.SubcompanyLoginAgent

getPassword() - Method in class bb.common.User2UserAgent

getPassword() - Method in class bb.common.VendorGroupUserVO

getPasswordEncrypt() - Method in class bb.common.CompanyVO

getPasswordEncrypt() - Method in class bb.common.PasswordPolicyAgent

getPasswordLifetime() - Method in class bb.common.CompanyVO

getPasswordLifetime() - Method in class bb.common.PasswordPolicyAgent

getPasswordMinLength() - Method in class bb.common.CompanyVO

getPasswordMinLength() - Method in class bb.common.PasswordPolicyAgent

getPastDueAmount() - Method in class bb.common.IncomeByMonthChartResult

getPastDueAPsCount() - Method in interface bb.common.box.AccountingBox

getPastDueAPsCountByVendorId(String) - Method in interface bb.common.box.AccountingBox

getPastDueARsCount() - Method in interface bb.common.box.AccountingBox

getPastDueARsCountByVendor(String, boolean) - Method in interface bb.common.box.AccountingBox

getPastDueARsTotalMoney() - Method in interface bb.common.box.AccountingBox

getPastDueARsTotalMoneyByVendor(String, boolean) - Method in interface bb.common.box.AccountingBox

getPastDueDCCount() - Method in interface bb.common.box.EngineeringBox

getPastDueEcnCount() - Method in class bb.common.EngineeringInfoCenterResult

getPastDueNcrCount() - Method in class bb.common.QualityInfoCenterResult

getPastDuePurchaseOrderCountByBuyer(String) - Method in interface bb.common.box.PurchasingBox

getPastDuePurchaseOrderItemByShipVia(String, String) - Method in interface bb.common.box.PurchasingBox

getPastDuePurchaseOrderItemByShipViaTotal(String, String) - Method in interface bb.common.box.PurchasingBox

getPastDuePurchaseOrderItemCount() - Method in interface bb.common.box.ManufacturingBox

getPastDuePurchaseOrderItemCount() - Method in interface bb.common.box.PurchasingBox

getPastDuePurchaseOrderItemsCountByAddressId(String, String) - Method in interface bb.common.box.PurchasingBox

getPastDueRFCCount() - Method in interface bb.common.box.ManufacturingBox

getPastDueSalesAccount() - Method in class bb.common.SalesInfoCenterResult

getPastDueSalesCount() - Method in class bb.common.SalesInfoCenterResult

getPastDueWOAccount() - Method in class bb.common.WorkOrderInfoCenterResult

getPastDueWOCount() - Method in class bb.common.WorkOrderInfoCenterResult

getPath() - Method in class bb.common.TaskFileResult

getPaths() - Method in class bb.common.RecursiveBillPath

getPausedOperatingInstructionsCount() - Method in interface bb.common.box.ManufacturingBox

getPausedTime() - Method in class bb.common.OperatingInstructionsUserStatisticalResult

getPausedTime() - Method in class bb.common.OperatingInstructionsVO

getPausedTimeByHour() - Method in class bb.common.OperatingInstructionsUserStatisticalResult

getPausedTimeByHour() - Method in class bb.common.OperatingInstructionsVO

getPayableMethod() - Method in class bb.common.RunningAccountOrderItemResult

getPayableMethod() - Method in class bb.common.RunningAccountOrderVO

getPayableMethodID() - Method in class bb.common.PayableMethodVO

getPayableMethodName() - Method in class bb.common.PayableMethodVO

getPayAmount() - Method in class bb.common.PurchaseOrderContractResult

getPayDate() - Method in class bb.common.AccountPayableCheckRunItemVO

getPayDate() - Method in class bb.common.AccountPayableInfoWithPrepayResult

getPayDate() - Method in class bb.common.AccountReceivableInfoWithPrepayResult

getPayDate() - Method in class bb.common.AccountsPayableInfoVO

getPayDate() - Method in class bb.common.AccountsPayableVO

getPaydate() - Method in class bb.common.AccountsReceivableInfoVO

getPaydate() - Method in class bb.common.AccountsReceivableVO

getPayDate() - Method in class bb.common.ApCheckRunListResult

getPayDate() - Method in class bb.common.APItemListResult

getPayDate() - Method in class bb.common.APPrepayInfoResult

getPayDate() - Method in class bb.common.ArCommissionListResult

getPayDate() - Method in class bb.common.ARPaymentRunItemVO

getPayDate() - Method in class bb.common.ARPaymentRunListResult

getPayDate() - Method in class bb.common.ARPrepayInfoResult

getPayDate() - Method in class bb.common.InvoiceItemListResult

getPaydate() - Method in class bb.common.OnloanReceiverVO

getPayDate() - Method in class bb.common.OnloanShipperVO

getPaydate() - Method in class bb.common.ProformaInvoiceVO

getPayDate() - Method in class bb.common.PurchaseOrderContractResult

getPaydate() - Method in class bb.common.ReceiverInfoVO

getPaydate() - Method in class bb.common.ReceiverVO

getPaydate() - Method in class bb.common.RMAReceiverVO

getPaydate() - Method in class bb.common.RtvShipperInfoVO

getPaydate() - Method in class bb.common.RtvShipperVO

getPayDate() - Method in class bb.common.SalesTaxListResult

getPayDate() - Method in class bb.common.ShipperInfoVO

getPayDate() - Method in class bb.common.ShipperVO

getPayDate() - Method in class bb.common.TempArApAgingVO

getPayment() - Method in interface bb.common.box.CompanyBox

getPaymentAmount() - Method in class bb.common.CustomerStatementResult

getPaymentById(int) - Method in interface bb.common.box.CompanyBox

getPaymentByName(String) - Method in interface bb.common.box.CompanyBox

getPaymentCount(String) - Method in interface bb.common.box.CompanyBox

getPaymentHistoryCount() - Method in interface bb.common.box.AccountingBox

getPaymentID() - Method in class bb.common.PaymentVO

getPaymentInvoices() - Method in class bb.common.CustomerStatementResult

getPaymentInvoices() - Method in class bb.common.PaymentInvoicesResult

getPaymentName() - Method in class bb.common.PaymentVO

getPaymentNeeded() - Method in class bb.common.ExpenseVO

getPaymentNoInt() - Method in class bb.common.AccountReceivablePaymentVO

getPaymentNumber() - Method in class bb.common.AccountReceivablePaymentVO

getPaymentNumber() - Method in class bb.common.ARPaymentRunItemVO

getPaymentNumber() - Method in class bb.common.ARPaymentRunListResult

getPaymentNumber() - Method in class bb.common.ARPaymentRunVO

getPaymentRunItems() - Method in class bb.common.ARPaymentRunVO

getPaymentRunItemTotal(String) - Method in interface bb.common.box.AccountingBox

getPaymentRunNumber() - Method in class bb.common.AccountReceivablePaymentVO

getPaymentRunNumber() - Method in class bb.common.ARPaymentRunItemPK

getPaymentRunNumber() - Method in class bb.common.ARPaymentRunListResult

getPaymentRunNumber() - Method in class bb.common.ARPaymentRunVO

getPaymentVariance() - Method in class bb.common.AccountsPayableVO

getPaymentVariance() - Method in class bb.common.AccountsReceivableVO

getPaymentVarianceGL() - Method in class bb.common.AccountsReceivableVO

getPayMethod() - Method in class bb.common.PointOfSaleVO

getPayThisTotal() - Method in class bb.common.MakeAccountPayableAgent

getPayThisTotal() - Method in class bb.common.MakeDebitMemoAgent

getPBItem() - Method in class bb.common.ProformaReceiverPackingBoxItemAgent

getPbItems() - Method in class bb.common.ProformaReceiverPackingBoxAgent

getPbs() - Method in class bb.common.ProformaReceiverPackingBoxAgent

getPCode() - Method in class bb.common.PartInventoryVO

getPcode() - Method in class bb.common.RollUPPartStandardCostResult

getPCode() - Method in class bb.common.ToolInventoryVO

getPctMargin() - Method in class bb.common.SalesOrder12MonthMarginResult

getPendingSGCustomerServiceRequestsCount() - Method in interface bb.common.box.SalesBox

getPercent() - Method in class bb.common.AssetAmortizationExpenseAccountVO

getPercent(int) - Method in class bb.common.WorkCenterLoadListResult

getPercentage() - Method in class bb.common.BalanceSheetSideBySideItemResult

getPerDayDiffAccount() - Method in class bb.common.PointOfSaleVO

getPeriod() - Method in class bb.common.PartClassVO

getPeriodBalance() - Method in class bb.common.GlBalanceInfoResult

getPeriodBalance() - Method in class bb.common.GLInfoByPeriodResult

getPeriodCreditAmount() - Method in class bb.common.GlBalanceInfoResult

getPeriodDC() - Method in class bb.common.GlBalanceInfoResult

getPeriodDebitAmount() - Method in class bb.common.GlBalanceInfoResult

getPeriodNumber() - Method in class bb.common.InventoryPartInOutDetailListResult

getPeriodTotalCost() - Method in class bb.common.InventoryPartInOutDetailListResult

getPeriodUnit() - Method in class bb.common.EquipmentVO

getPeriodUnit() - Method in class bb.common.PartClassVO

getPermissionByPK(String) - Method in interface bb.common.box.SecurityBox

getPermissionId() - Method in class bb.common.PermissionDescriptionPK

getPermissionId() - Method in class bb.common.PermissionListResult

getPermissionId() - Method in class bb.common.PermissionMethodPK

getPermissionId() - Method in class bb.common.PermissionVO

getPermissionId() - Method in class bb.common.RolePermissionPK

getPermissionId() - Method in class bb.common.UserRolePermissionListResult

getPermissionMethodByPk(PermissionMethodPK) - Method in interface bb.common.box.SecurityBox

getPermissionName() - Method in class bb.common.PermissionDescriptionVO

getPermissionName() - Method in class bb.common.PermissionListResult

getPermissionName() - Method in class bb.common.UserRolePermissionListResult

getPermissionsByIdCount(String) - Method in interface bb.common.box.SecurityBox

getPermissionsCountByRole(String) - Method in interface bb.common.box.SecurityBox

getPermissionsCountBySelf() - Method in interface bb.common.box.SecurityBox

getPermissionsCountByUser(String) - Method in interface bb.common.box.SecurityBox

getPFInvoiceByPFNumber(String) - Method in interface bb.common.box.WarehouseBox

getPfInvoiceItemNumber() - Method in class bb.common.ProformaInvoiceItemListResult

getPfInvoiceItemNumber() - Method in class bb.common.ProformaInvoiceItemVO

getPfInvoiceNumber() - Method in class bb.common.AccountsReceivableInfoVO

getPfInvoiceNumber() - Method in class bb.common.AccountsReceivableVO

getPfInvoiceNumber() - Method in class bb.common.PackingBoxItemPK

getPfInvoiceNumber() - Method in class bb.common.PackingBoxPK

getPfInvoiceNumber() - Method in class bb.common.ProformaInvoiceItemListResult

getPfInvoiceNumber() - Method in class bb.common.ProformaInvoiceItemManufacturerPK

getPfInvoiceNumber() - Method in class bb.common.ProformaInvoiceItemPK

getPfInvoiceNumber() - Method in class bb.common.ProformaInvoiceVO

getPfInvoiceNumber() - Method in class bb.common.ShipperVO

getPfnumber() - Method in class bb.common.ProformaInvoiceListResult

getPfReceiver(String) - Method in interface bb.common.box.PurchasingBox

getPfReceiverItemNumber() - Method in class bb.common.PfReceiverItemVO

getPfReceiverItemNumber() - Method in class bb.common.PfReceiverItemWithNumberPK

getPfReceiverNumber() - Method in class bb.common.PfReceiverItemPK

getPfReceiverNumber() - Method in class bb.common.PfReceiverVO

getPfReceiverNumber() - Method in class bb.common.PrPackingBoxItemPK

getPfReceiverNumber() - Method in class bb.common.PrPackingBoxPK

getPfReceiversCountByPfNumber(String) - Method in interface bb.common.box.PurchasingBox

getPfReceiversCountByVendorId(String) - Method in interface bb.common.box.PurchasingBox

getPfReceiversOpenCountByVendorId(String) - Method in interface bb.common.box.PurchasingBox

getPfVo() - Method in class bb.common.ProformaReceiverPackingBoxAgent

getPhone() - Method in class bb.common.BizBoxUserEmployeeResult

getPhone() - Method in class bb.common.CSRAgent

getPhone() - Method in class bb.common.CustomerVendorAddressInfoVO

getPhone() - Method in class bb.common.CustomerVendorAddressVO

getPhone() - Method in class bb.common.CustomerVendorContactVO

getPhone() - Method in class bb.common.EmployeeCardVO

getPhone() - Method in class bb.common.ManufacturerAddressInfoVO

getPhone() - Method in class bb.common.ManufacturerAddressVO

getPhone() - Method in class bb.common.ManufacturerContactVO

getPhone() - Method in class bb.common.NoticeUserEmployeeListResult

getPhone() - Method in class bb.common.SalesmanVO

getPhone() - Method in class bb.common.SGCartCheckOutResult

getPhone() - Method in class bb.common.SgClientProgramUserVO

getPhone() - Method in class bb.common.SGCustomerServiceRequestVO

getPhone() - Method in class bb.common.SGCustRequestForQuoteListResult

getPhone() - Method in class bb.common.SGCustRequestForQuoteResult

getPhone() - Method in class bb.common.SGCustRequestForQuoteVO

getPhone() - Method in class bb.common.SGQuoteAddressResult

getPhone() - Method in class bb.common.SGQuoteAddressVO

getPhone() - Method in class bb.common.VendorGroupUserVO

getPhone2() - Method in class bb.common.CustomerVendorAddressInfoVO

getPhone2() - Method in class bb.common.CustomerVendorAddressVO

getPhone2() - Method in class bb.common.ManufacturerAddressInfoVO

getPhone2() - Method in class bb.common.ManufacturerAddressVO

getPhoneExtension() - Method in class bb.common.SalesmanVO

getPhysicalCount() - Method in class bb.common.CycleCountAgent

getPhysicalCount() - Method in class bb.common.UpdatePhysicalInventoryAgent

getPhysicalInventoryDate() - Method in class bb.common.CycleCountVO

getPhysicalInventoryDate() - Method in class bb.common.PhysicalInventoryVO

getPhysicalInventoryListByPartNumberCount(int, String, String, String) - Method in interface bb.common.box.WarehouseBox

getPhysicalInventoryListResultsCount(int, int) - Method in interface bb.common.box.WarehouseBox

getPhysicalInventoryListResultsCount(int) - Method in interface bb.common.box.WarehouseBox

getPhysicalInventoryListResultsWithAvgCostCount(int, int) - Method in interface bb.common.box.WarehouseBox

getPhysicalInventoryListTotalResultWithAvgCost(int, int) - Method in interface bb.common.box.WarehouseBox

getPhysicalInventoryStatusVO(int) - Method in interface bb.common.box.WarehouseBox

getPhysicalInventoryTotalResultWithAvgCost(int) - Method in interface bb.common.box.WarehouseBox

getPhysicalWorkSheetListResultsCount() - Method in interface bb.common.box.WarehouseBox

getPhysicalWorkSheetTotalPagesNumber(int) - Method in interface bb.common.box.WarehouseBox

getPi() - Method in class bb.common.ReturnToVendorItemVO

getPicker() - Method in class bb.common.DisassembleWorkOrderIssueVO

getPicker() - Method in class bb.common.IssueItemAgent

getPicker() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getPicker() - Method in class bb.common.NonproductivePickingItemIssuedVO

getPicker() - Method in class bb.common.PartIssuedVO

getPickingItemNumber() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getPickingItemNumber() - Method in class bb.common.NonproductivePickingItemIssuedVO

getPickingItemNumber() - Method in class bb.common.NonproductivePickingItemPK

getPickingItemNumber() - Method in class bb.common.NonproductivePickingItemResult

getPickingItems() - Method in class bb.common.NonproductivePickingVO

getPickingNumber() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getPickingNumber() - Method in class bb.common.NonproductivePickingItemIssuedVO

getPickingNumber() - Method in class bb.common.NonproductivePickingItemPK

getPickingNumber() - Method in class bb.common.NonproductivePickingItemResult

getPickingNumber() - Method in class bb.common.NonproductivePickingVO

getPickListOrderNumber() - Method in class bb.common.InspectionReportInfoVO

getPickListOrderNumber() - Method in class bb.common.InspectionReportVO

getPickListOrderNumber() - Method in class bb.common.OperatingInstructionsVO

getPicture() - Method in class bb.common.EmployeeCardVO

getPicture() - Method in class bb.common.MiscDocAgent

getPicture() - Method in class bb.common.PartDwfAgent

getPicture() - Method in class bb.common.PartDwfVO

getPicture() - Method in class bb.common.PartDwfWithPartInfoResult

getPicture() - Method in class bb.common.PartDwgAgent

getPicture() - Method in class bb.common.PartDwgVO

getPicture() - Method in class bb.common.PartDwgWithPartInfoResult

getPicture() - Method in class bb.common.PartPictureVO

getPicture() - Method in class bb.common.SalesmanVO

getPicture() - Method in class bb.common.SGDwgPictureVO

getPicture() - Method in class bb.common.SGPictureVO

getPicture() - Method in class bb.common.WorkInstructionPictureVO

getPictureLength() - Method in class bb.common.NCRPictureVO

getPictureName() - Method in class bb.common.NCRPictureVO

getPk() - Method in class bb.common.AccountCreditVO

getPk() - Method in class bb.common.AccountDebitVO

getPk() - Method in class bb.common.AccountPayableCheckRunItemVO

getPk() - Method in class bb.common.AccountsChartMappingVO

getPk() - Method in class bb.common.AccountsPayableItemManufacturerVO

getPk() - Method in class bb.common.AccountsPayableItemVO

getPk() - Method in class bb.common.AccountsReceivableItemManufacturerVO

getPk() - Method in class bb.common.AccountsReceivableItemVO

getPk() - Method in class bb.common.AddProformaReceiverItemAgent

getPk() - Method in class bb.common.AllPartDocumentsVO

getPk() - Method in class bb.common.APPrepayInfoResult

getPk() - Method in class bb.common.ApPrepayItemVO

getPk() - Method in class bb.common.ARPaymentRunItemVO

getPk() - Method in class bb.common.ARPrepayInfoResult

getPk() - Method in class bb.common.ArPrepayItemVO

getPk() - Method in class bb.common.AssetAmortizationExpenseAccountVO

getPk() - Method in class bb.common.AssetDepreciateVO

getPk() - Method in class bb.common.AssetUsageVO

getPk() - Method in class bb.common.BankReconciliationReportVO

getPk() - Method in class bb.common.BB2PartInSipOfSoItemResult

getPk() - Method in class bb.common.BB2PartInSTOItemResult

getPk() - Method in class bb.common.BB2PartOnhandPK

getPk() - Method in class bb.common.BB2PartOnLoanItemResult

getPk() - Method in class bb.common.BillItemUsagePathResult

getPk() - Method in class bb.common.BillItemVO

getPk() - Method in class bb.common.BillVO

getPk() - Method in class bb.common.BOMCanAssyListResult

getPk() - Method in class bb.common.CarrierVO

getPk() - Method in class bb.common.ChangeStdCostWorkSheetItemVO

getPk() - Method in class bb.common.CompanyUnitAccountVO

getPk() - Method in class bb.common.ContractPriceCustomerVO

getPk() - Method in class bb.common.ContractPriceItemVO

getPk() - Method in class bb.common.CurrencyExchangeVO

getPk() - Method in class bb.common.CustomAssetRecordVO

getPk() - Method in class bb.common.CustomEmployeeTrainVO

getPk() - Method in class bb.common.CustomEmployeeWorkExperienceVO

getPk() - Method in class bb.common.CustomerPrepayStatementListResult

getPk() - Method in class bb.common.CustomerReturnToVendorItemVO

getPk() - Method in class bb.common.CustomerVendorContactVO

getPk() - Method in class bb.common.CustomerVendorDescriptionVO

getPk() - Method in class bb.common.CustomJobCategoryGoodsVO

getPk() - Method in class bb.common.CycleCountAgent

getPk() - Method in class bb.common.CycleCountListResult

getPk() - Method in class bb.common.CycleCountVO

getPk() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

getPk() - Method in class bb.common.DisassembleWorkOrderItemVO

getPk() - Method in class bb.common.EmployeeEducationVO

getPk() - Method in class bb.common.EmployeeTrainingVO

getPk() - Method in class bb.common.EmployeeWorkExperienceVO

getPk() - Method in class bb.common.EngGroupUserVO

getPk() - Method in class bb.common.EngineeringSharingItemVO

getPk() - Method in class bb.common.ExpenseItemVO

getPk() - Method in class bb.common.FeedbackAnswerVO

getPk() - Method in class bb.common.FeedbackItemVO

getPk() - Method in class bb.common.GlCashFlowBudgetVO

getPk() - Method in class bb.common.GlFiscalYearBudgetVO

getPk() - Method in class bb.common.GLItemVO

getPk() - Method in class bb.common.GroupUserVO

getPk() - Method in class bb.common.InSipAudittListResult

getPk() - Method in class bb.common.InspectionConformanceReportItemCheckVO

getPk() - Method in class bb.common.InspectionConformanceReportItemVO

getPk() - Method in class bb.common.InspectionItemVO

getPk() - Method in class bb.common.InspectionReportInspectMethodItemVO

getPk() - Method in class bb.common.InspectionReportInspectStandardItemVO

getPk() - Method in class bb.common.InspectionReportItemQtyVO

getPk() - Method in class bb.common.InspectionReportItemVO

getPk() - Method in class bb.common.InspectionTypeItemVO

getPk() - Method in class bb.common.LabelTemplateItemVO

getPk() - Method in class bb.common.LogMethodVO

getPk() - Method in class bb.common.MaintenanceItemVO

getPk() - Method in class bb.common.ManufacturerContactVO

getPk() - Method in class bb.common.ManufacturerDescriptionVO

getPk() - Method in class bb.common.MultiLanguageAccountsChartVO

getPk() - Method in class bb.common.MyPrintListVO

getPk() - Method in class bb.common.NcrApprovalVO

getPk() - Method in class bb.common.NCRPartOnhandPK

getPk() - Method in class bb.common.NonConformanceCodeDescriptionVO

getPk() - Method in class bb.common.NonConformanceQuantityVO

getPk() - Method in class bb.common.NonproductivePickingItemVO

getPk() - Method in class bb.common.NonproductivePickingOnDemandResult

getPk() - Method in class bb.common.OnLoanItemVO

getPk() - Method in class bb.common.OnloanReceiverItemVO

getPk() - Method in class bb.common.OnloanShipperItemVO

getPk() - Method in class bb.common.OperatingInstructionsInspectMethodItemVO

getPk() - Method in class bb.common.OperatingInstructionsInspectResultItemVO

getPk() - Method in class bb.common.OperatingInstructionsInspectStandardItemVO

getPk() - Method in class bb.common.OperatingInstructionsManualItemVO

getPk() - Method in class bb.common.OperatingOutputFileItemVO

getPk() - Method in class bb.common.OrderBoilerplateVO

getPk() - Method in class bb.common.OrderVendorItem

getPk() - Method in class bb.common.PackingBoxItemVO

getPk() - Method in class bb.common.PackingBoxVO

getPk() - Method in class bb.common.PartCatagoryVO

getPk() - Method in class bb.common.PartCatalogVO

getPk() - Method in class bb.common.PartDescriptionVO

getPk() - Method in class bb.common.PartDiscountVO

getPk() - Method in class bb.common.PartDocumentVO

getPk() - Method in class bb.common.PartDwfVO

getPk() - Method in class bb.common.PartDwgVO

getPk() - Method in class bb.common.PartInspectionVO

getPk() - Method in class bb.common.PartInventoryVO

getPk() - Method in class bb.common.PartManufacturerVO

getPk() - Method in class bb.common.PartMaterialVO

getPk() - Method in class bb.common.PartMRPVO

getPk() - Method in class bb.common.PartOnHandAuditResult

getPk() - Method in class bb.common.PartOnhandVO

getPk() - Method in class bb.common.PartToAuditFlagResult

getPk() - Method in class bb.common.PartTraceableCategoryVO

getPk() - Method in class bb.common.PartTraceableSpecVO

getPk() - Method in class bb.common.PartTrackingVO

getPk() - Method in class bb.common.PartUnitVO

getPk() - Method in class bb.common.PartVendorVO

getPk() - Method in class bb.common.PartVO

getPk() - Method in class bb.common.PartWhereUsedItemResult

getPk() - Method in class bb.common.PartWithOnhandsVO

getPk() - Method in class bb.common.PermissionDescriptionVO

getPk() - Method in class bb.common.PermissionMethodVO

getPk() - Method in class bb.common.PfReceiverItemVO

getPk() - Method in class bb.common.PfReceiverItemWithNumberPK

getPk() - Method in class bb.common.PhysicalInventoryListResult

getPk() - Method in class bb.common.PhysicalInventoryVO

getPk() - Method in class bb.common.POForWISeqAgent

getPk() - Method in class bb.common.PoMessageItemVO

getPk() - Method in class bb.common.POSurveyReportItemVO

getPk() - Method in class bb.common.PosZipCodeTaxVO

getPk() - Method in class bb.common.ProformaInvoiceItemManufacturerVO

getPk() - Method in class bb.common.ProformaInvoiceItemVO

getPk() - Method in class bb.common.PrPackingBoxItemVO

getPk() - Method in class bb.common.PrPackingBoxVO

getPk() - Method in class bb.common.PullFromWorkOrderPartDetailAgent

getPk() - Method in class bb.common.PurchaseOrderItemManufacturerVO

getPk() - Method in class bb.common.PurchaseOrderItemVO

getPk() - Method in class bb.common.PurchaseWorkSheetItemVO

getPk() - Method in class bb.common.PurchaseWorkSheetVO

getPk() - Method in class bb.common.QualityGroupVO

getPk() - Method in class bb.common.QuoteItemManufacturerVO

getPk() - Method in class bb.common.QuoteItemVO

getPk() - Method in class bb.common.ReceiverItemManufacturerVO

getPk() - Method in class bb.common.ReceiverItemVO

getPk() - Method in class bb.common.RecursiveBillPath

getPk() - Method in class bb.common.RequestForQuoteItemManufacturerVO

getPk() - Method in class bb.common.RequestForQuoteItemVO

getPk() - Method in class bb.common.RequestForRMAItemVO

getPk() - Method in class bb.common.ReturnMaterialAuthorizationItemManufacturerVO

getPk() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getPk() - Method in class bb.common.ReturnToVendorItemManufacturerVO

getPk() - Method in class bb.common.ReturnToVendorItemVO

getPk() - Method in class bb.common.RfqMessageItemVO

getPk() - Method in class bb.common.RMAReceiverItemVO

getPk() - Method in class bb.common.RMAReceiverResult

getPk() - Method in class bb.common.RoleDescriptionVO

getPk() - Method in class bb.common.RolePermissionVO

getPk() - Method in class bb.common.RollUpBomStdCostWorkSheetItemVO

getPk() - Method in class bb.common.RollUPPartStandardCostResult

getPk() - Method in class bb.common.RtvShipperItemVO

getPk() - Method in class bb.common.RunningAccountOrderItemVO

getPk() - Method in class bb.common.SalesOrderItemInfoVO

getPk() - Method in class bb.common.SalesOrderItemManufacturerVO

getPk() - Method in class bb.common.SalesOrderItemVO

getPk() - Method in class bb.common.SalesOrderShipDateListResult

getPk() - Method in class bb.common.SerialNumberItemVO

getPk() - Method in class bb.common.SerialNumberVO

getPk() - Method in class bb.common.ServerClientPropertyVO

getPk() - Method in class bb.common.SGBillItemVO

getPk() - Method in class bb.common.SGClientAccountVO

getPk() - Method in class bb.common.SGCompanyVO

getPk() - Method in class bb.common.SGCustomerCatalogVO

getPk() - Method in class bb.common.SGCustRequestForQuoteItemResult

getPk() - Method in class bb.common.SGCustRequestForQuoteItemVO

getPk() - Method in class bb.common.SGDocPartVO

getPk() - Method in class bb.common.SGDwgPictureVO

getPk() - Method in class bb.common.SGPictureVO

getPk() - Method in class bb.common.ShipListItemRelatedDocResult

getPk() - Method in class bb.common.ShipListItemVO

getPk() - Method in class bb.common.ShipListItemVOResult

getPk() - Method in class bb.common.ShipListOwnerAttributeVO

getPk() - Method in class bb.common.ShipperItemManufacturerVO

getPk() - Method in class bb.common.ShipperItemVO

getPk() - Method in class bb.common.SwapOrderItemVO

getPk() - Method in class bb.common.SwapReceiverItemVO

getPk() - Method in class bb.common.SwapShipperItemVO

getPk() - Method in class bb.common.ToolDescriptionVO

getPk() - Method in class bb.common.ToolInventoryVO

getPk() - Method in class bb.common.ToolListInfoVO

getPk() - Method in class bb.common.ToolListItemVO

getPk() - Method in class bb.common.ToolListVO

getPk() - Method in class bb.common.ToolManufacturerVO

getPk() - Method in class bb.common.ToolOnhandVO

getPk() - Method in class bb.common.ToolVendorVO

getPk() - Method in class bb.common.ToolVO

getPk() - Method in class bb.common.ToolWhereUsedItemResult

getPk() - Method in class bb.common.ToolWithOnhandsVO

getPk() - Method in class bb.common.TransferOrderItemVO

getPk() - Method in class bb.common.TransferReceiverItemVO

getPk() - Method in class bb.common.TransferShipperItemVO

getPk() - Method in class bb.common.UpdatePhysicalInventoryAgent

getPk() - Method in class bb.common.UserRoleVO

getPk() - Method in class bb.common.VendorContractPriceItemVO

getPk() - Method in class bb.common.VendorContractPriceVendorVO

getPk() - Method in class bb.common.VendorPartVO

getPk() - Method in class bb.common.VendorPrepayStatementListResult

getPk() - Method in class bb.common.VendorQtyPriceVO

getPk() - Method in class bb.common.WarehouseTransferVO

getPk() - Method in class bb.common.WCLoadByDateResult

getPk() - Method in class bb.common.WOItemCostControlAgent

getPk() - Method in class bb.common.WorkCenterGroupItemVO

getPk() - Method in class bb.common.WorkCenterVendorVO

getPk() - Method in class bb.common.WorkInstructionSequenceVO

getPk() - Method in class bb.common.WorkInstructionVO

getPk() - Method in class bb.common.WorkOrderItemCanAssyResult

getPk() - Method in class bb.common.WorkOrderItemIssueVO

getPk() - Method in class bb.common.WorkOrderItemReviewCostResult

getPk() - Method in class bb.common.WorkOrderItemSeqWCLoadResult

getPk() - Method in class bb.common.WorkOrderItemToIssueResult

getPk() - Method in class bb.common.WorkOrderItemVO

getPk() - Method in class bb.common.WorkOrderItemWCLoadResult

getPk() - Method in class bb.common.WorkOrderWorkInstructionSequenceDateAgent

getPk() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getPk() - Method in class bb.common.WorkOrderWorkInstructionVO

getPk() - Method in class bb.common.WorkOrderWorkItemDateAgent

getPk() - Method in class bb.common.WorkOrderWorkSheetItemVO

getPk() - Method in class bb.common.WorkOrderWorkSheetVO

getPlAccountNumber() - Method in class bb.common.ProfitAndLossAccountsResult

getPlace() - Method in class bb.common.CustomEmployeeTrainVO

getPlace() - Method in class bb.common.EmployeeTrainingVO

getPlace() - Method in class bb.common.IncotermVO

getPlacePort() - Method in class bb.common.ShippingResult

getPlDescription() - Method in class bb.common.ProfitAndLossAccountsResult

getPleaseRespondBy() - Method in class bb.common.RequestForQuoteVO

getPmList() - Method in class bb.common.WOItemPartDetailNotIssue

getPmtMethod() - Method in class bb.common.DepositSummaryResult

getPo() - Method in class bb.common.DisassembleWorkOrderVO

getPo() - Method in class bb.common.ReturnToVendorByDateListResult

getPo() - Method in class bb.common.ReturnToVendorVO

getPo() - Method in class bb.common.WorkOrderVO

getPoAcceptEmployee() - Method in class bb.common.POSurveyReportVO

getPoBoilerplate() - Method in class bb.common.PurchaseOrderBoilerplateVO

getPoBoilerplate() - Method in class bb.common.PurchaseOrderVO

getPoClass() - Method in class bb.common.AppColumnVO

getPoClass() - Method in class bb.common.DataFilterVO

getPoDate() - Method in class bb.common.PO2SOExchange

getPoDate() - Method in class bb.common.POStatisticsResult

getPoDate() - Method in class bb.common.PurchaseOrderCheckListResult

getPoDate() - Method in class bb.common.PurchaseOrderItemListResult

getPoDate() - Method in class bb.common.PurchaseOrderListResult

getPoDate() - Method in class bb.common.PurchaseOrderOpenDueListResult

getPoDate() - Method in class bb.common.PurchaseOrderVO

getPoDebitAccount() - Method in class bb.common.AccountingSettingsVO

getPoDetails() - Method in class bb.common.BB2PartTotalOnorderDetailResult

getPoDigits() - Method in class bb.common.CompanyVO

getPOFiscalYearInfoCenter() - Method in interface bb.common.box.ManagementBox

getPoGrandTotal() - Method in class bb.common.AccountsPayableVO

getPointOfSale() - Method in interface bb.common.box.CompanyBox

getPoItem() - Method in class bb.common.PoMessageItemVO

getPoItemDescription() - Method in class bb.common.PurchaseOrderOpenDueListResult

getPoItemNumber() - Method in class bb.common.POReceiverItemListResult

getPoItemNumber() - Method in class bb.common.PrReceiverWithQualityListResult

getPoItemNumber() - Method in class bb.common.PurchaseOrderItemListResult

getPoItemNumber() - Method in class bb.common.PurchaseOrderOpenDueListResult

getPoItemNumber() - Method in class bb.common.ReceiverItemVO

getPoItemNumber() - Method in class bb.common.ReturnToVendorItemListResult

getPoItemPk() - Method in class bb.common.AddRTVAgent

getPoItemPk() - Method in class bb.common.EcnPOOrderResult

getPOItems() - Method in class bb.common.ProformaReceiverPackingBoxItemAgent

getPOItemsforRtv(String) - Method in interface bb.common.box.PurchasingBox

getPoItemShipDate() - Method in class bb.common.ReceivingItemResult

getPoItemStatus() - Method in class bb.common.PurchaseOrderItemListResult

getPolityVisage() - Method in class bb.common.CustomEmployeeVO

getPoMessage(String) - Method in interface bb.common.box.PurchasingBox

getPoMessageByPoNumber(String) - Method in interface bb.common.box.PurchasingBox

getPoMessageCountByStatusAndID(String[], String) - Method in interface bb.common.box.PurchasingBox

getPoMessageDate() - Method in class bb.common.PoMessageListResult

getPoMessageDate() - Method in class bb.common.PoMessageVO

getPoMessageNumber() - Method in class bb.common.PoMessageItemPK

getPoMessageNumber() - Method in class bb.common.PoMessageListResult

getPoMessageNumber() - Method in class bb.common.PoMessageVO

getPoMessageStatus(String) - Method in interface bb.common.box.ManufacturingBox

getPoMessageStatus(String) - Method in interface bb.common.box.PurchasingBox

getPoNotApprovedOnOrderList() - Method in class bb.common.MrpItemResult

getPoNumber() - Method in class bb.common.AccountPayableCheckRunItemVO

getPoNumber() - Method in class bb.common.AccountPayableInfoWithPrepayResult

getPoNumber() - Method in class bb.common.AccountsPayableInfoVO

getPoNumber() - Method in class bb.common.AccountsPayableItemVO

getPoNumber() - Method in class bb.common.AccountsPayableVO

getPoNumber() - Method in class bb.common.ApCheckRunListResult

getPoNumber() - Method in class bb.common.APPrepayInfoResult

getPoNumber() - Method in class bb.common.ApPrepayItemVO

getPoNumber() - Method in class bb.common.ARPaymentRunItemVO

getPoNumber() - Method in class bb.common.GeneralLedgerByDateListResult

getPoNumber() - Method in class bb.common.MakeCheckAgent

getPoNumber() - Method in class bb.common.MiscDocAgent

getPoNumber() - Method in class bb.common.NcrReportListResult

getPoNumber() - Method in class bb.common.PO2POAgent

getPoNumber() - Method in class bb.common.PoMessageItemVO

getPoNumber() - Method in class bb.common.PoMessageListResult

getPoNumber() - Method in class bb.common.PoMessageVO

getPoNumber() - Method in class bb.common.POReceiverItemListResult

getPoNumber() - Method in class bb.common.POStatisticsResult

getPoNumber() - Method in class bb.common.POSurveyReportAgent

getPoNumber() - Method in class bb.common.PrReceiverWithQualityListResult

getPoNumber() - Method in class bb.common.PurchaseOrderCheckListResult

getPoNumber() - Method in class bb.common.PurchaseOrderDocumentVO

getPoNumber() - Method in class bb.common.PurchaseOrderItemListResult

getPoNumber() - Method in class bb.common.PurchaseOrderListResult

getPoNumber() - Method in class bb.common.PurchaseOrderOpenDueListResult

getPoNumber() - Method in class bb.common.ReturnToVendorCheckListResult

getPoNumber() - Method in class bb.common.ReturnToVendorListResult

getPoNumber() - Method in class bb.common.RtvShipperInfoVO

getPoNumber() - Method in class bb.common.RtvShipperItemListResult

getPoNumber() - Method in class bb.common.RtvShipperListResult

getPoNumber() - Method in class bb.common.RtvShipperVO

getPoNumber() - Method in class bb.common.RunningAccountOrderItemResult

getPoNumber() - Method in class bb.common.RunningAccountOrderVO

getPoNumber() - Method in class bb.common.ScrapReportVO

getPoNumber() - Method in class bb.common.SerialNumberResult

getPoNumber() - Method in class bb.common.StockTransactionPOReceiverResult

getPoNumber() - Method in class bb.common.TempArApAgingVO

getPoOnOrderList() - Method in class bb.common.MrpItemOrderDemandRecordsResult

getPoOnOrderList() - Method in class bb.common.MrpItemResult

getPoOrderItems() - Method in class bb.common.EcnCheckOrderResult

getPoPastDue() - Method in class bb.common.CashFlowByMonthReportResult

getPoPrefix() - Method in class bb.common.CompanyVO

getPoPrice() - Method in class bb.common.RunningAccountOrderItemVO

getPoPriceProfit() - Method in class bb.common.RunningAccountOrderItemVO

getPoPriceProfitPercent() - Method in class bb.common.RunningAccountOrderItemVO

getPoQty() - Method in class bb.common.OrderApprovalItemsVO

getPoQty() - Method in class bb.common.PartVendorVO

getPoQty() - Method in class bb.common.PurchaseOrderOpenDueListResult

getPoQty() - Method in class bb.common.ToolVendorVO

getPoReceived() - Method in class bb.common.POReceiverItemListResult

getPoReceiverByDateSummaryResult(String, String, String, Date, Date, String) - Method in interface bb.common.box.WarehouseBox

getPOReceiverItemsCount(String, String, String, String, String, String, Date, Date, String, String, String, String, String[]) - Method in interface bb.common.box.WarehouseBox

getPOReceiverItemsCountByPartPK(PartPK) - Method in interface bb.common.box.WarehouseBox

getPoReceiverItemWithAPListResultByDateCount(String, String, String, String, String, Date, Date, String, String, String, String, String, String) - Method in interface bb.common.box.WarehouseBox

getPoRecQty() - Method in class bb.common.AccountsPayableItemVO

getPoRecQty(AccountsPayableItemPK) - Method in interface bb.common.box.AccountingBox

getPoRelateDoc() - Method in class bb.common.LogInventoryListResult

getPoRequestionNumber() - Method in class bb.common.PurchaseOrderVO

getPort() - Method in class bb.common.BizBoxServer

getPort() - Method in class bb.common.OperationLogVO

getPort() - Method in class bb.common.SmtpServerVO

getPort() - Method in class bb.common.SubcompanyLoginAgent

getPort() - Method in class bb.common.SubcompanyVO

getPoShipDate() - Method in class bb.common.POReceiverItemListResult

getPosition() - Method in class bb.common.CustomEmployeeVO

getPosition() - Method in class bb.common.EmployeeCardVO

getPosition() - Method in class bb.common.ExpenseVO

getPositionLevel() - Method in class bb.common.CustomEmployeeVO

getPosOnhand() - Method in class bb.common.PartOnHandWithPartBasicInfoResult

getPoStatus() - Method in class bb.common.POAndWOStatusResult

getPoStatus() - Method in class bb.common.PurchaseOrderListResult

getPostedBy() - Method in class bb.common.GeneralLedgerPrintResult

getPostedBy() - Method in class bb.common.GeneralLedgerVO

getPOSurveyReport(String) - Method in interface bb.common.box.QualityBox

getPOSurveyReportCount(String, String, String) - Method in interface bb.common.box.QualityBox

getPoSurveyReportItem() - Method in class bb.common.POSurveyReportAgent

getPoSurveyReportItem() - Method in class bb.common.POSurveyReportVO

getPosZipCodeTaxByPK(PosZipCodeTaxPK) - Method in interface bb.common.box.CompanyBox

getPosZipCodeTaxByZipCode(String) - Method in interface bb.common.box.CompanyBox

getPoTotal() - Method in class bb.common.ApPrepayVO

getPOTotalByAPPNumber(String) - Method in interface bb.common.box.AccountingBox

getPoType() - Method in class bb.common.PurchaseOrderVO

getPoUnit() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getPoUnit() - Method in class bb.common.OrderApprovalItemsVO

getPoUnit() - Method in class bb.common.PartVendorVO

getPoUnit() - Method in class bb.common.PurchaseOrderItemVO

getPoUnit() - Method in class bb.common.ReceivingItemResult

getPoUnit() - Method in class bb.common.ReturnToVendorItemVO

getPoUnit() - Method in class bb.common.ShippingItemResult

getPoUnit() - Method in class bb.common.ToolVendorVO

getPoUnitQty() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getPoUnitQty() - Method in class bb.common.PurchaseOrderItemVO

getPoUnitQty() - Method in class bb.common.ReceivingItemResult

getPoUnitQty() - Method in class bb.common.ReturnToVendorItemVO

getPoUnitQty() - Method in class bb.common.ShippingItemResult

getPoUnitRate() - Method in class bb.common.OrderApprovalItemsVO

getPoUnitRate() - Method in class bb.common.PurchaseOrderItemVO

getPoVAT() - Method in class bb.common.AccountingSettingsVO

getPoVender() - Method in class bb.common.LogInventoryListResult

getPoweredBy() - Method in class bb.common.CompanyVO

getPoweredBy() - Method in class bb.common.SGCompanyVO

getPowerUnit() - Method in class bb.common.EquipmentVO

getPp() - Method in class bb.common.AccountReceivablePaymentVO

getPqty() - Method in class bb.common.WorkOrderItemTimeDetailVO

getPrapayItemNumber() - Method in class bb.common.PrepayPaymentAgent

getPrDate() - Method in class bb.common.AddProformaReceiverAgent

getPrDate() - Method in class bb.common.PfReceiverVO

getPrepayAmountPaid() - Method in class bb.common.AllStatementsListResult

getPrepayApply() - Method in class bb.common.AllStatementsListResult

getPrepayApplyPoNumbers() - Method in class bb.common.MakeAccountPayableAgent

getPrepayApplySoNumbers() - Method in class bb.common.MakeInvoiceAgent

getPrepayBalenceDue() - Method in class bb.common.AllStatementsListResult

getPrepayCurrency() - Method in class bb.common.AllStatementsListResult

getPrepayNumber() - Method in class bb.common.PrepayPaymentAgent

getPrepayTotalDue() - Method in class bb.common.AllStatementsListResult

getPreventiveActionRequestItems() - Method in class bb.common.PreventiveActionRequestVO

getPreviousInspection() - Method in class bb.common.ToolCalibrationVO

getPreviousMonthTotal() - Method in class bb.common.ClosingStatementTotalResult

getPreviousMonthYear() - Method in class bb.common.ClosingStatementResult

getPrice(WorkOrderWorkInstructionSequencePK) - Method in class bb.common.POForWISeqAgent

getPrice() - Method in class bb.common.RMAReceiverItemVO

getPrice() - Method in class bb.common.RunningAccountOrderItemVO

getPrice() - Method in class bb.common.VendorPriceAgent

getPrice() - Method in class bb.common.VendorQtyPriceVO

getPricePerUnit() - Method in class bb.common.OnLoanItemListResult

getPricePerUnit() - Method in class bb.common.OnLoanItemVO

getPricePerUnit() - Method in class bb.common.QuoteItemListResult

getPricePerUnit() - Method in class bb.common.QuoteItemVO

getPricePerUnit() - Method in class bb.common.SalesOrderItemInfoVO

getPricePerUnit() - Method in class bb.common.SalesOrderItemListResult

getPricePerUnit() - Method in class bb.common.SalesOrderItemVO

getPrincipal() - Method in class bb.common.CustomAssetVO

getPrintAmount() - Method in class bb.common.PointOfSaleVO

getPrintedBoardNumber() - Method in class bb.common.InspectionReportInfoVO

getPrintedBoardNumber() - Method in class bb.common.InspectionReportVO

getPrintLogoByName(String) - Method in interface bb.common.box.CompanyBox

getPrintLogoInfoByName(String) - Method in interface bb.common.box.CompanyBox

getPrintReturnNumber() - Method in class bb.common.RunningAccountOrderVO

getPrintTemplate(int) - Method in interface bb.common.box.CompanyBox

getPrintTemplatebyClazzCount(String) - Method in interface bb.common.box.CompanyBox

getPriority() - Method in class bb.common.BizboxBugInfoVO

getPriority() - Method in class bb.common.BizboxBugVO

getPriority() - Method in class bb.common.CSRAgent

getPriority() - Method in class bb.common.CustomerReturnToVendorItemVO

getPriority() - Method in class bb.common.CustomerReturnToVendorVO

getPriority() - Method in class bb.common.CustomerServiceIncidentItemListResult

getPriority() - Method in class bb.common.CustomerServiceIncidentListResult

getPriority() - Method in class bb.common.CustomerServiceIncidentVO

getPriority() - Method in class bb.common.DisassembleWorkOrderItemListResult

getPriority() - Method in class bb.common.DisassembleWorkOrderItemVO

getPriority() - Method in class bb.common.DisassembleWorkOrderListResult

getPriority() - Method in class bb.common.DisassembleWorkOrderVO

getPriority() - Method in class bb.common.OnLoanItemVO

getPriority() - Method in class bb.common.OnLoanVO

getPriority() - Method in class bb.common.PurchaseOrderItemVO

getPriority() - Method in class bb.common.PurchaseOrderVO

getPriority() - Method in class bb.common.QuoteItemVO

getPriority() - Method in class bb.common.QuoteVO

getPriority() - Method in class bb.common.RequestForQuoteItemVO

getPriority() - Method in class bb.common.RequestForQuoteVO

getPriority() - Method in class bb.common.RequestForRMAItemVO

getPriority() - Method in class bb.common.RequestForRMAVO

getPriority() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getPriority() - Method in class bb.common.ReturnMaterialAuthorizationVO

getPriority() - Method in class bb.common.ReturnToVendorItemVO

getPriority() - Method in class bb.common.ReturnToVendorVO

getPriority() - Method in class bb.common.SalesOrderItemInfoVO

getPriority() - Method in class bb.common.SalesOrderItemVO

getPriority() - Method in class bb.common.SalesOrderVO

getPriority() - Method in class bb.common.SGCustomerServiceRequestVO

getPriority() - Method in class bb.common.WorkOrderCheckListResult

getPriority() - Method in class bb.common.WorkOrderItemListResult

getPriority() - Method in class bb.common.WorkOrderItemVO

getPriority() - Method in class bb.common.WorkOrderListResult

getPriority() - Method in class bb.common.WorkOrderVO

getPriorPeriod() - Method in class bb.common.ProfitLossStatementItemResult

getPriorPeriodFrom() - Method in class bb.common.AccountingInfoDocumentVO

getPriorPeriodFrom() - Method in class bb.common.MiscDocAgent

getPriorPeriodFrom() - Method in class bb.common.ProfitLossStatementResult

getPriorPeriodTo() - Method in class bb.common.AccountingInfoDocumentVO

getPriorPeriodTo() - Method in class bb.common.MiscDocAgent

getPriorPeriodTo() - Method in class bb.common.ProfitLossStatementResult

getPrItemNumber() - Method in class bb.common.PrReceiverWithQualityListResult

getPrivateNote() - Method in class bb.common.CRTVListResult

getPrivateNote() - Method in class bb.common.OnLoanListResult

getPrivateNote() - Method in class bb.common.QuoteListResult

getPrivateNote() - Method in class bb.common.RMAListResult

getPrivateNote() - Method in class bb.common.RRMAListResult

getPrivateNote() - Method in class bb.common.SalesOrderListResult

getPrivateNotes() - Method in class bb.common.CustomerReturnToVendorVO

getPrivateNotes() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getPrivateNotes() - Method in class bb.common.OnloanReceiverItemVO

getPrivateNotes() - Method in class bb.common.OnloanReceiverVO

getPrivateNotes() - Method in class bb.common.PfReceiverVO

getPrivateNotes() - Method in class bb.common.ProformaInvoiceListResult

getPrivateNotes() - Method in class bb.common.PrReceiverListResult

getPrivateNotes() - Method in class bb.common.PurchaseOrderListResult

getPrivateNotes() - Method in class bb.common.ReceiverItemVO

getPrivateNotes() - Method in class bb.common.ReceiverVO

getPrivateNotes() - Method in class bb.common.ReceivingItemResult

getPrivateNotes() - Method in class bb.common.RequestForRMAVO

getPrivateNotes() - Method in class bb.common.ShippingItemResult

getPrivateNotes() - Method in class bb.common.TransferOrderListResult

getPrivateNotes() - Method in class bb.common.TransferOrderVO

getPrivateNotes() - Method in class bb.common.WorkOrderWorkSheetItemVO

getPrNumber() - Method in class bb.common.PrReceiverListResult

getPrNumber() - Method in class bb.common.PrReceiverWithQualityListResult

getProblemDescription() - Method in class bb.common.NcrReportListResult

getProblemDescription() - Method in class bb.common.NonConformanceReportVO

getProblemDescription() - Method in class bb.common.ScrapReportVO

getProblemDisposition() - Method in class bb.common.NcrReportListResult

getProblemDisposition() - Method in class bb.common.NonConformanceReportVO

getProduct() - Method in class bb.common.CustomerServiceIncidentVO

getProductCode() - Method in class bb.common.AccountsPayableItemVO

getProductCode() - Method in class bb.common.AccountsReceivableItemVO

getProductCode() - Method in class bb.common.APItemListResult

getProductCode() - Method in class bb.common.InventoryListResult

getProductCode() - Method in class bb.common.InvoiceItemListResult

getProductCode() - Method in class bb.common.PartBasicInfo

getProductCode() - Method in class bb.common.PartVO

getProductCode() - Method in class bb.common.PartWithOnhandsVO

getProductCode() - Method in class bb.common.PurchaseOrderItemListResult

getProductCode() - Method in class bb.common.PurchaseOrderItemVO

getProductCode() - Method in class bb.common.ReceiverItemVO

getProductCode() - Method in class bb.common.RunningAccountOrderItemVO

getProductCode() - Method in class bb.common.SalesOrderItemListResult

getProductCode() - Method in class bb.common.SalesOrderItemVO

getProductCode() - Method in class bb.common.SGPartCatalogResult

getProductCode() - Method in class bb.common.ShipperItemVO

getProfit() - Method in class bb.common.RunningAccountOrderItemVO

getProfitByStdCost() - Method in class bb.common.RunningAccountOrderItemVO

getProfitMarginByAvgCost() - Method in class bb.common.InventoryListResult

getProfitPercent() - Method in class bb.common.RunningAccountOrderItemVO

getProfitPercentByStdCost() - Method in class bb.common.RunningAccountOrderItemVO

getProfitPercentTotal() - Method in class bb.common.RunningAccountOrderVO

getProfitPercentTotalByStdCost() - Method in class bb.common.RunningAccountOrderVO

getProfitTotal() - Method in class bb.common.RunningAccountOrderVO

getProfitTotalByStdCost() - Method in class bb.common.RunningAccountOrderVO

getProformaInvoiceItemManufacturer() - Method in class bb.common.ProformaInvoiceItemVO

getProformaInvoiceItems() - Method in class bb.common.ProformaInvoiceVO

getProformaInvoiceItemsCount(Date, Date, String, String, String, String, String, String) - Method in interface bb.common.box.WarehouseBox

getProformaInvoiceListResults(ArrayList<String>) - Method in interface bb.common.box.WarehouseBox

getProformaInvoiceListResultsCountByCustomerId(String) - Method in interface bb.common.box.WarehouseBox

getProformaInvoiceListResultsCountByPfNumber(String) - Method in interface bb.common.box.WarehouseBox

getProject() - Method in class bb.common.AccountsPayableInfoVO

getProject() - Method in class bb.common.AccountsPayableVO

getProject() - Method in class bb.common.AssetVO

getProject() - Method in class bb.common.CRTVListResult

getProject() - Method in class bb.common.CustomAssetVO

getProject() - Method in class bb.common.DisassembleWorkOrderIssuingResult

getProject() - Method in class bb.common.DisassembleWorkOrderItemListResult

getProject() - Method in class bb.common.DisassembleWorkOrderListResult

getProject() - Method in class bb.common.DisassembleWorkOrderReceivingResult

getProject() - Method in class bb.common.DisassembleWorkOrderVO

getProject() - Method in class bb.common.IssuingResult

getProject() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getProject() - Method in class bb.common.NonproductivePickingItemResult

getProject() - Method in class bb.common.NonproductivePickingVO

getProject() - Method in class bb.common.OnhandQualityResult

getProject() - Method in class bb.common.OnLoanListResult

getProject() - Method in class bb.common.OnloanReceiverListResult

getProject() - Method in class bb.common.OnLoanVO

getProject() - Method in class bb.common.OperatingInstructionsVO

getProject() - Method in class bb.common.PartIssuedListResult

getProject() - Method in class bb.common.PartReceivedListResult

getProject() - Method in class bb.common.POAndWOStatusResult

getProject() - Method in class bb.common.POStatisticsResult

getProject() - Method in class bb.common.PurchaseOrderCheckListResult

getProject() - Method in class bb.common.PurchaseOrderItemListResult

getProject() - Method in class bb.common.PurchaseOrderListResult

getProject() - Method in class bb.common.QuoteListResult

getProject() - Method in class bb.common.ReceivingResult

getProject() - Method in class bb.common.RequestForQuoteCheckListResult

getProject() - Method in class bb.common.RequestForQuoteListResult

getProject() - Method in class bb.common.ReturnToVendorByDateListResult

getProject() - Method in class bb.common.ReturnToVendorCheckListResult

getProject() - Method in class bb.common.ReturnToVendorListResult

getProject() - Method in class bb.common.ReturnToVendorVO

getProject() - Method in class bb.common.RMAListResult

getProject() - Method in class bb.common.RMAReceiverListResult

getProject() - Method in class bb.common.RMAReceiverVO

getProject() - Method in class bb.common.RRMAListResult

getProject() - Method in class bb.common.SalesOrderListResult

getProject() - Method in class bb.common.ShipperItemListResult

getProject() - Method in class bb.common.ShipperVO

getProject() - Method in class bb.common.TotalAmountInPOByRefDoc

getProject() - Method in class bb.common.WoItemPickListResult

getProject() - Method in class bb.common.WOReceiverDetail

getProject() - Method in class bb.common.WorkOrderCheckListResult

getProject() - Method in class bb.common.WorkOrderIssueStatisticsResult

getProject() - Method in class bb.common.WorkOrderItemListResult

getProject() - Method in class bb.common.WorkOrderListResult

getProject() - Method in class bb.common.WorkOrderVO

getProjectByID(String) - Method in interface bb.common.box.SalesBox

getProjectByIdCount(String) - Method in interface bb.common.box.SalesBox

getProjectClass() - Method in class bb.common.DesignControlInfoVO

getProjectClass() - Method in class bb.common.DesignControlVO

getProjectDescription() - Method in class bb.common.DesignControlInfoVO

getProjectDescription() - Method in class bb.common.DesignControlListResult

getProjectDescription() - Method in class bb.common.DesignControlVO

getProjectDescription() - Method in class bb.common.TotalAmountInPOByRefDoc

getProjectEngineer() - Method in class bb.common.DesignControlInfoVO

getProjectEngineer() - Method in class bb.common.DesignControlListResult

getProjectEngineer() - Method in class bb.common.DesignControlVO

getProjectName() - Method in class bb.common.CustomerReturnToVendorVO

getProjectName() - Method in class bb.common.OnloanReceiverVO

getProjectName() - Method in class bb.common.PfReceiverVO

getProjectName() - Method in class bb.common.POReceiverItemListResult

getProjectName() - Method in class bb.common.POSurveyReportAgent

getProjectName() - Method in class bb.common.POSurveyReportVO

getProjectName() - Method in class bb.common.PurchaseOrderVO

getProjectName() - Method in class bb.common.QuoteVO

getProjectName() - Method in class bb.common.ReceiverInfoVO

getProjectName() - Method in class bb.common.ReceiverVO

getProjectName() - Method in class bb.common.RequestForQuoteVO

getProjectName() - Method in class bb.common.RequestForRMAVO

getProjectName() - Method in class bb.common.ReturnMaterialAuthorizationVO

getProjectName() - Method in class bb.common.SalesOrderItemListResult

getProjectName() - Method in class bb.common.SalesOrderVO

getProjectName() - Method in class bb.common.SwapOrderItemListResult

getProjectName() - Method in class bb.common.SwapOrderListResult

getProjectName() - Method in class bb.common.SwapOrderVO

getProjectName() - Method in class bb.common.SwapReceiverListResult

getProjectName() - Method in class bb.common.SwapReceiverVO

getProjectName() - Method in class bb.common.SwapShipperListResult

getProjectName() - Method in class bb.common.SwapShipperVO

getProjectNumber() - Method in class bb.common.PurchaseOrderContractResult

getProjectTeam() - Method in class bb.common.DesignControlInfoVO

getProjectTeam() - Method in class bb.common.DesignControlVO

getProofreader() - Method in class bb.common.WorkInstructionListResult

getProofreader() - Method in class bb.common.WorkInstructionVO

getProofreader() - Method in class bb.common.WorkOrderWorkInstructionVO

getPropertyEquipments() - Method in class bb.common.AccountingBalanceSheetResult

getProposedAction() - Method in class bb.common.CorrectiveActionRequestVO

getProposedAction() - Method in class bb.common.PreventiveActionRequestVO

getProposedActionDate() - Method in class bb.common.CorrectiveActionRequestVO

getProposedActionDate() - Method in class bb.common.PreventiveActionRequestVO

getProposedBy() - Method in class bb.common.CorrectiveActionRequestVO

getProposedBy() - Method in class bb.common.PreventiveActionRequestVO

getPrPackingBox(PrPackingBoxPK) - Method in interface bb.common.box.PurchasingBox

getPrPackingBoxes() - Method in class bb.common.PfReceiverVO

getPrPBItem() - Method in class bb.common.ProformaReceiverPackingBoxItemAgent

getPtOnhand() - Method in class bb.common.PackingBoxSalesOrderItemResult

getPtSipQty() - Method in class bb.common.PackingBoxSalesOrderItemResult

getPublicToUser() - Method in class bb.common.PurchaseWorkSheetVO

getPublicToUser() - Method in class bb.common.WorkOrderWorkSheetVO

getPurchaerName() - Method in class bb.common.PO2SOExchange

getPurchaseContent() - Method in class bb.common.PurchaseOrderContractResult

getPurchaseCost() - Method in class bb.common.PartInventoryVO

getPurchaseCost() - Method in class bb.common.ToolInventoryVO

getPurchaseInfoByFiscalYear() - Method in interface bb.common.box.ManagementBox

getPurchaseInfoByMonth(int) - Method in interface bb.common.box.ManagementBox

getPurchaseMethod() - Method in class bb.common.PurchaseOrderContractResult

getPurchaseMethod() - Method in class bb.common.PurchaseOrderVO

getPurchaseOnTimeResult(OnTimeAgent) - Method in interface bb.common.box.ManagementBox

getPurchaseOrder() - Method in class bb.common.IcrItemListResult

getPurchaseOrder() - Method in class bb.common.IcrListResult

getPurchaseOrder() - Method in class bb.common.InspectionConformanceReportItemInfo

getPurchaseOrder() - Method in class bb.common.InspectionConformanceReportVO

getPurchaseOrderApPrepayApply(String) - Method in interface bb.common.box.PurchasingBox

getPurchaseOrderApPrepayPaid(String) - Method in interface bb.common.box.PurchasingBox

getPurchaseOrderApprovalByEmployeeId(String) - Method in interface bb.common.box.ManufacturingBox

getPurchaseOrderApprovalByEmployeeId(String) - Method in interface bb.common.box.PurchasingBox

getPurchaseOrderApprovalByUserNumber(String) - Method in interface bb.common.box.ManufacturingBox

getPurchaseOrderApprovalByUserNumber(String) - Method in interface bb.common.box.PurchasingBox

getPurchaseOrderBacklogInfoByMonth(int) - Method in interface bb.common.box.ManagementBox

getPurchaseOrderBPByPk(String) - Method in interface bb.common.box.PurchasingBox

getPurchaseOrderBPCountBybpID(String) - Method in interface bb.common.box.PurchasingBox

getPurchaseOrderByPoNumber(String) - Method in interface bb.common.box.ManufacturingBox

getPurchaseOrderByPoNumber(String) - Method in interface bb.common.box.PurchasingBox

getPurchaseOrderByPoNumberForIR(String) - Method in interface bb.common.box.QualityBox

getPurchaseOrderCheckListResultsCount(String) - Method in interface bb.common.box.ManufacturingBox

getPurchaseOrderCheckListResultsCount(String) - Method in interface bb.common.box.PurchasingBox

getPurchaseOrderComments() - Method in class bb.common.PurchaseOrderVO

getPurchaseOrderCountByPoNumber(String) - Method in interface bb.common.box.ManufacturingBox

getPurchaseOrderCountByPoNumber(String) - Method in interface bb.common.box.PurchasingBox

getPurchaseOrderCountByRange(String, String, String, String) - Method in interface bb.common.box.PurchasingBox

getPurchaseOrderDocumentByID(Long) - Method in interface bb.common.box.PurchasingBox

getPurchaseOrderDocuments() - Method in class bb.common.PurchaseOrderVO

getPurchaseOrderItem() - Method in class bb.common.PurchaseOrderVO

getPurchaseOrderItemByPk(PurchaseOrderItemPK) - Method in interface bb.common.box.PurchasingBox

getPurchaseOrderItemCountByDate(String, Date, Date, String, String, String, String, String, String, String, String, String, String, String, String) - Method in interface bb.common.box.ManufacturingBox

getPurchaseOrderItemCountByDate(String, Date, Date, String, String, String, String, String, String, String, String, String, String, String, String, boolean, String) - Method in interface bb.common.box.PurchasingBox

getPurchaseOrderItemCountByPartNumberLike(String, String) - Method in interface bb.common.box.ManufacturingBox

getPurchaseOrderItemCountByPartNumberLike(String, String) - Method in interface bb.common.box.PurchasingBox

getPurchaseOrderItemCountByPartPk(PartPK) - Method in interface bb.common.box.ManufacturingBox

getPurchaseOrderItemCountByPartPk(PartPK) - Method in interface bb.common.box.PurchasingBox

getPurchaseOrderItemCountByPoNumber(String) - Method in interface bb.common.box.ManufacturingBox

getPurchaseOrderItemCountByPoNumber(String) - Method in interface bb.common.box.PurchasingBox

getPurchaseOrderItemCountByProject(String, String, String, Date, Date, String) - Method in interface bb.common.box.PurchasingBox

getPurchaseOrderItemCountByRefDoc1(String, String, String, Date, Date, String) - Method in interface bb.common.box.PurchasingBox

getPurchaseOrderItemCountByRelatedDoc(String, String, String, Date, Date, String) - Method in interface bb.common.box.PurchasingBox

getPurchaseOrderItemDwf(String) - Method in interface bb.common.box.PurchasingBox

getPurchaseOrderItemManufacturer() - Method in class bb.common.PurchaseOrderItemVO

getPurchaseOrderItemNumber() - Method in class bb.common.AccountsPayableItemManufacturerPK

getPurchaseOrderItemNumber() - Method in class bb.common.PfReceiverItemPK

getPurchaseOrderItemNumber() - Method in class bb.common.PrPackingBoxItemPK

getPurchaseOrderItemNumber() - Method in class bb.common.PurchaseOrderItemManufacturerPK

getPurchaseOrderItemNumber() - Method in class bb.common.PurchaseOrderItemPK

getPurchaseOrderItemNumber() - Method in class bb.common.ReceiverItemManufacturerPK

getPurchaseOrderItemPk() - Method in class bb.common.PurchaseOrderOnOrderResult

getPurchaseOrderNumber() - Method in class bb.common.ApPrepayVO

getPurchaseOrderNumber() - Method in class bb.common.AssetVO

getPurchaseOrderNumber() - Method in class bb.common.CustomerFeedbackVO

getPurchaseOrderNumber() - Method in class bb.common.GeneralLedgerListResult

getPurchaseOrderNumber() - Method in class bb.common.GeneralLedgerVO

getPurchaseOrderNumber() - Method in class bb.common.NcrNeedToScrapListResult

getPurchaseOrderNumber() - Method in class bb.common.NonConformanceReportVO

getPurchaseOrderNumber() - Method in class bb.common.PackingBoxItemVO

getPurchaseOrderNumber() - Method in class bb.common.PartCertificateListResult

getPurchaseOrderNumber() - Method in class bb.common.PartCertificateVO

getPurchaseOrderNumber() - Method in class bb.common.PfReceiverItemPK

getPurchaseOrderNumber() - Method in class bb.common.PO2SOExchange

getPurchaseOrderNumber() - Method in class bb.common.POSurveyReportVO

getPurchaseOrderNumber() - Method in class bb.common.ProformaInvoiceItemListResult

getPurchaseOrderNumber() - Method in class bb.common.ProformaInvoiceItemVO

getPurchaseOrderNumber() - Method in class bb.common.PrPackingBoxItemPK

getPurchaseOrderNumber() - Method in class bb.common.PurchaseOrderContractResult

getPurchaseOrderNumber() - Method in class bb.common.PurchaseOrderItemManufacturerPK

getPurchaseOrderNumber() - Method in class bb.common.PurchaseOrderItemPK

getPurchaseOrderNumber() - Method in class bb.common.PurchaseOrderVO

getPurchaseOrderNumber() - Method in class bb.common.ReceiverInfoVO

getPurchaseOrderNumber() - Method in class bb.common.ReceiverItemVO

getPurchaseOrderNumber() - Method in class bb.common.ReceiverVO

getPurchaseOrderNumber() - Method in class bb.common.TempReceiverWithoutAPInfo

getPurchaseOrderOnOrderResult() - Method in class bb.common.BB2PartMrpResult

getPurchaseOrderOnTimeResult() - Method in interface bb.common.box.ManagementBox

getPurchaseOrderPrepay() - Method in class bb.common.AccountingSettingsVO

getPurchaseOrderPrivateNotes() - Method in class bb.common.PurchaseOrderVO

getPurchaseOrderReceivingResult(String) - Method in interface bb.common.box.WarehouseBox

getPurchaseOrdersCountByByRefdoc(String, String, String, Date, Date) - Method in interface bb.common.box.PurchasingBox

getPurchaseOrdersForReceivingCount(String, String, String, String) - Method in interface bb.common.box.PurchasingBox

getPurchaseOrderStatus(String) - Method in interface bb.common.box.ManufacturingBox

getPurchaseOrderStatus(String) - Method in interface bb.common.box.PurchasingBox

getPurchaseOrderTotalResultByRelatedDoc(String, String, String, Date, Date, String) - Method in interface bb.common.box.PurchasingBox

getPurchaseOrderUnit() - Method in class bb.common.PartInventoryVO

getPurchaseOrderUnit() - Method in class bb.common.ToolInventoryVO

getPurchaseOrderWithOrderApplyByID(Long) - Method in interface bb.common.box.ManufacturingBox

getPurchaseRefdoc() - Method in class bb.common.PurchaseWorkSheetItemVO

getPurchaseRequestNumber() - Method in class bb.common.PurchaseOrderContractResult

getPurchaserId() - Method in class bb.common.PO2SOExchange

getPurchaseTaxAccount(BigDecimal) - Method in interface bb.common.box.CompanyBox

getPurchaseTaxRate() - Method in class bb.common.TaxAccountVO

getPurchaseWithPartOnHoldCount() - Method in class bb.common.PurchasingInfoCenterResult

getPurchaseWorkSheetByCountByEmployeeId(String) - Method in interface bb.common.box.ManufacturingBox

getPurchaseWorkSheetByCountByEmployeeId(String) - Method in interface bb.common.box.PurchasingBox

getPurchaseWorkSheetByPk(PurchaseWorkSheetPK) - Method in interface bb.common.box.ManufacturingBox

getPurchaseWorkSheetByPk(PurchaseWorkSheetPK) - Method in interface bb.common.box.PurchasingBox

getPurchaseWorkSheetCountByEmployeeEmailLike(String) - Method in interface bb.common.box.ManufacturingBox

getPurchaseWorkSheetCountByEmployeeEmailLike(String) - Method in interface bb.common.box.PurchasingBox

getPurchaseWorkSheetItem() - Method in class bb.common.PurchaseWorkSheetVO

getPurchasingInfoCenterResult() - Method in interface bb.common.box.ManagementBox

getPurItemCount() - Method in class bb.common.PurchaseOrderOnTimeItemResult

getPurTotal() - Method in class bb.common.PurchaseOrderOnTimeItemResult

getPutDate() - Method in class bb.common.CustomGoodsRecordVO

getPutDate() - Method in class bb.common.EmployeePutGoodListResult

getQaAcceptEmployee() - Method in class bb.common.POSurveyReportVO

getQc() - Method in class bb.common.NonConformanceReportVO

getQCode() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getQCode() - Method in class bb.common.ReceivingItemResult

getQCPrincipal() - Method in class bb.common.OIPrincipalVO

getQr() - Method in class bb.common.AccountsPayableItemVO

getQr() - Method in class bb.common.CustomerReturnToVendorItemVO

getQr() - Method in class bb.common.DisassembleWorkOrderItemVO

getQr() - Method in class bb.common.NonConformanceReportVO

getQr() - Method in class bb.common.OnLoanItemVO

getQr() - Method in class bb.common.OnloanReceiverItemVO

getQr() - Method in class bb.common.PurchaseOrderItemVO

getQr() - Method in class bb.common.QuoteItemVO

getQr() - Method in class bb.common.ReceiverItemVO

getQr() - Method in class bb.common.RequestForQuoteItemVO

getQr() - Method in class bb.common.RequestForRMAItemVO

getQr() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getQr() - Method in class bb.common.ReturnToVendorItemVO

getQr() - Method in class bb.common.RMAReceiverItemVO

getQr() - Method in class bb.common.SalesOrderItemInfoVO

getQr() - Method in class bb.common.SalesOrderItemVO

getQr() - Method in class bb.common.WorkOrderItemVO

getQrQty() - Method in class bb.common.PartWithExcessiveInventoryListResult

getQt() - Method in class bb.common.OnLoanVO

getQtBoilerplate() - Method in class bb.common.QuoteBoilerplateVO

getQtDate() - Method in class bb.common.QuoteItemListResult

getQtDate() - Method in class bb.common.QuoteListResult

getQtDigits() - Method in class bb.common.CompanyVO

getQtItemNumber() - Method in class bb.common.QuoteItemListResult

getQtNumber() - Method in class bb.common.QuoteItemListResult

getQtNumber() - Method in class bb.common.QuoteListResult

getQtPrefix() - Method in class bb.common.CompanyVO

getQtr1Qty() - Method in class bb.common.HighUsagePartResult

getQtr2Qty() - Method in class bb.common.HighUsagePartResult

getQtr3Qty() - Method in class bb.common.HighUsagePartResult

getQtr4Qty() - Method in class bb.common.HighUsagePartResult

getQtrUsage() - Method in class bb.common.BB2PartInfo

getQtrUsage() - Method in class bb.common.BB2PartTotalOnhandDetailResult

getQtrUsage() - Method in class bb.common.PartMaterialListResult

getQtrUsage() - Method in class bb.common.PartMaterialWhereUsedItemResult

getQtrUsage() - Method in class bb.common.StockTransactionPartInfoResult

getQty() - Method in class bb.common.AddProformaReceiverItemAgent

getQty() - Method in class bb.common.AssetReportSumResult

getQty() - Method in class bb.common.BB2PartInSTOItemResult

getQty() - Method in class bb.common.BB2PartOnLoanItemResult

getQty() - Method in class bb.common.BillItemSalesCostResult

getQty() - Method in class bb.common.BillItemSalesResult

getQty() - Method in class bb.common.BillItemSalesXResult

getQty() - Method in class bb.common.BillWhereUsedItemResult

getQty() - Method in class bb.common.BOMCanAssyListResult

getQty() - Method in class bb.common.BomItemWithOEMResult

getQty() - Method in class bb.common.DisassembleWorkOrderItemListResult

getQty() - Method in class bb.common.EcnPOOrderResult

getQty() - Method in class bb.common.EcnWOOrderResult

getQty() - Method in class bb.common.JobProcessSheetResult

getQty() - Method in class bb.common.LogInventoryListResult

getQty() - Method in class bb.common.NcrScrapAgent

getQty() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getQty() - Method in class bb.common.OrderApprovalItemsVO

getQty() - Method in class bb.common.PackingBoxSalesOrderItemAgent

getQty(String) - Method in class bb.common.PackingBoxSalesOrderItemAgent

getQty() - Method in class bb.common.PackingBoxSalesOrderItemResult

getQty(String) - Method in class bb.common.PackingBoxSalesOrderItemResult

getQty() - Method in class bb.common.PartInQAAgent

getQty() - Method in class bb.common.PartMaterialWhereUsedItemResult

getQty() - Method in class bb.common.PartOnhandAndCostResult

getQty() - Method in class bb.common.PartTrackingVO

getQty() - Method in class bb.common.partUsedInfoResult

getQty() - Method in class bb.common.PartWithQtyListResult

getQty() - Method in class bb.common.PosRefdocVO

getQty() - Method in class bb.common.PullFromWorkOrderPartDetailAgent

getQty() - Method in class bb.common.PuttoInQAAgent

getQty() - Method in class bb.common.QtyAndMoney

getQty() - Method in class bb.common.QtyDetailResult

getQty() - Method in class bb.common.ReceiverItemTrackingLogAgent

getQty() - Method in class bb.common.RefdocElement

getQty() - Method in class bb.common.RefdocVO

getQty() - Method in class bb.common.RequestForQuoteItemListResult

getQty() - Method in class bb.common.ReturnToVendorItemListResult

getQty() - Method in class bb.common.RtvShipperItemListResult

getQty() - Method in class bb.common.RtvShipperItemVO

getQty() - Method in class bb.common.SalesOrder12MonthMarginResult

getQty() - Method in class bb.common.SGBOMItemResult

getQty() - Method in class bb.common.SGCustRequestForQuoteItemResult

getQty() - Method in class bb.common.SGCustRequestForQuoteItemVO

getQty() - Method in class bb.common.SGPartCartAgent

getQty() - Method in class bb.common.SGPartListItemResult

getQty() - Method in class bb.common.SGPartListResult

getQty() - Method in class bb.common.SGQuoteCartListResult

getQty() - Method in class bb.common.SGQuoteCartVO

getQty() - Method in class bb.common.ShipListItemRelatedDocResult

getQty() - Method in class bb.common.WOItemCostControlAgent

getQty() - Method in class bb.common.WoItemWorkInstructionListResult

getQty() - Method in class bb.common.WorkCenterVO

getQty() - Method in class bb.common.WorkOrderItemAgent

getQty() - Method in class bb.common.WorkOrderItemCanAssyResult

getQty() - Method in class bb.common.WorkOrderItemInWipListResult

getQty() - Method in class bb.common.WorkOrderItemListResult

getQty() - Method in class bb.common.WorkOrderItemSetupItemAgent

getQty() - Method in class bb.common.WorkOrderItemTimeDetailVO

getQty() - Method in class bb.common.WorkOrderItemToIssueResult

getQty() - Method in class bb.common.WorkOrderItemWCLoadResult

getQty() - Method in class bb.common.WorkOrderWorkInstructionVO

getQty() - Method in class bb.common.WorkSheetPartAgent

getQtyAsm() - Method in class bb.common.WoItemPickListResult

getQtyAssy() - Method in class bb.common.WOReceiverDetail

getQtyAssy() - Method in class bb.common.WorkOrderReceiverVO

getQtyCheck() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getQtyCheck() - Method in class bb.common.IcrItemListResult

getQtyCheck() - Method in class bb.common.InspectionConformanceReportItemVO

getQtyCheck() - Method in class bb.common.ReceivingItemResult

getQtyInSip() - Method in class bb.common.BB2PartInSipItemResult

getQtyInSip() - Method in class bb.common.BB2PartInSipOfSoItemResult

getQtyInSit() - Method in class bb.common.BB2PartInSitItemResult

getQtyInspected() - Method in class bb.common.NcrReportListResult

getQtyInWip() - Method in class bb.common.WorkOrderItemPartDetailInWipVO

getQtyIssued() - Method in class bb.common.NonproductivePickingItemIssuedVO

getQtyIssued() - Method in class bb.common.PartIssuedVO

getQtyIssued() - Method in class bb.common.WoItemPickListItemResult

getQtyMonths() - Method in class bb.common.WorkSheetPartAgent

getQtyNeedtoScrap() - Method in class bb.common.NcrNeedToScrapListResult

getQtyOrdered() - Method in class bb.common.AccountsReceivableItemVO

getQtyOrdered() - Method in class bb.common.APItemListResult

getQtyOrdered() - Method in class bb.common.BB2PartInSipOfSoItemResult

getQtyOrdered() - Method in class bb.common.InvoiceItemListResult

getQtyOrdered() - Method in class bb.common.PO2SOExchangeItem

getQtyOrdered() - Method in class bb.common.POReceiverItemListResult

getQtyOrdered() - Method in class bb.common.PrReceiverWithQualityListResult

getQtyPicked() - Method in class bb.common.BomPickListItemResult

getQtyPicked() - Method in class bb.common.WoItemPickListItemResult

getQtyQualified() - Method in class bb.common.IcrItemListResult

getQtyQualified() - Method in class bb.common.InspectionConformanceReportItemVO

getQtyQualified() - Method in class bb.common.ReceivingItemResult

getQtyReceived() - Method in class bb.common.AccountsPayableItemVO

getQtyReceived() - Method in class bb.common.APItemListResult

getQtyReceived() - Method in class bb.common.PartReceivedVO

getQtyReceived() - Method in class bb.common.PfReceiverItemVO

getQtyReceived() - Method in class bb.common.POReceiverItemListResult

getQtyReceived() - Method in class bb.common.PrReceiverWithQualityListResult

getQtyRegrade() - Method in class bb.common.NcrNeedToScrapListResult

getQtyRegrade() - Method in class bb.common.NonConformanceReportVO

getQtyReject() - Method in class bb.common.InspectionConformanceReportItemVO

getQtyReject() - Method in class bb.common.NcrNeedToScrapListResult

getQtyReject() - Method in class bb.common.NonConformanceReportVO

getQtyRejected() - Method in class bb.common.NcrReportListResult

getQtyRequested() - Method in class bb.common.BomPickListItemResult

getQtyRequired() - Method in class bb.common.WoItemPickListItemResult

getQtyRework() - Method in class bb.common.NcrNeedToScrapListResult

getQtyRework() - Method in class bb.common.NonConformanceReportVO

getQtyScrap() - Method in class bb.common.NcrNeedToScrapListResult

getQtyScrap() - Method in class bb.common.NonConformanceReportVO

getQtyScraped() - Method in class bb.common.NcrNeedToScrapListResult

getQtyScraped() - Method in class bb.common.NcrReportListResult

getQtyShip() - Method in class bb.common.DisassembleWorkOrderIssueVO

getQtyShip() - Method in class bb.common.RtvShipperItemListResult

getQtyShip() - Method in class bb.common.RtvShipperItemVO

getQtyShip() - Method in class bb.common.TransferOrderItemVO

getQtyShiped() - Method in class bb.common.SalesTaxListResult

getQtyShipped() - Method in class bb.common.AccountsReceivableItemVO

getQtyShipped() - Method in class bb.common.BB2PartInSipOfSoItemResult

getQtyShipped() - Method in class bb.common.DWOIssueDetail

getQtyShipped() - Method in class bb.common.InvoiceItemListResult

getQtyShipped() - Method in class bb.common.PfReceiverItemVO

getQtyShipped() - Method in class bb.common.ProformaInvoiceItemListResult

getQtyShipped() - Method in class bb.common.ProformaInvoiceItemVO

getQtyShipped() - Method in class bb.common.ReceivedToOrderItem

getQtySit() - Method in class bb.common.PrReceiverWithQualityListResult

getQtyToAsm() - Method in class bb.common.WCLoadDetailResult

getQtyTraced() - Method in class bb.common.AccountsPayableItemVO

getQtyWaiver() - Method in class bb.common.NcrNeedToScrapListResult

getQtyWaiver() - Method in class bb.common.NonConformanceReportVO

getQualityCode() - Method in class bb.common.PartManufacturerVO

getQualityCode() - Method in class bb.common.PartVendorVO

getQualityCode() - Method in class bb.common.ToolManufacturerVO

getQualityCode() - Method in class bb.common.ToolVendorVO

getQualityId() - Method in class bb.common.TraceableSpecsVO

getQualityInfoCenterResult() - Method in interface bb.common.box.ManagementBox

getQualitySpecification() - Method in class bb.common.PartTraceableResult

getQualitySpecification() - Method in class bb.common.TraceableSpecsVO

getQualityStatus() - Method in class bb.common.CustomerVendorAddressInfoVO

getQualityStatus() - Method in class bb.common.CustomerVendorAddressVO

getQualityStatus() - Method in class bb.common.LockedCustomerAddressResult

getQuantituInSip() - Method in class bb.common.SalesOrderOnDemandResult

getQuantity() - Method in class bb.common.AccountsPayableItemVO

getQuantity() - Method in class bb.common.AssetAddOrDisposalsReport

getQuantity() - Method in class bb.common.AssetDepreciateDetailReport

getQuantity() - Method in class bb.common.AssetVO

getQuantity() - Method in class bb.common.AuditPartInQAResult

getQuantity() - Method in class bb.common.BomPickListResult

getQuantity() - Method in class bb.common.CustomerReturnToVendorItemVO

getQuantity() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getQuantity() - Method in class bb.common.DisassembleWorkOrderItemPartDetailItemResult

getQuantity() - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

getQuantity() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

getQuantity() - Method in class bb.common.DisassembleWorkOrderItemVO

getQuantity() - Method in class bb.common.DisassembleWorkOrderReceivingResult

getQuantity() - Method in class bb.common.DWOIssueDetail

getQuantity() - Method in class bb.common.InspectionReportInfoVO

getQuantity() - Method in class bb.common.InspectionReportVO

getQuantity() - Method in class bb.common.IssuingItemResult

getQuantity() - Method in class bb.common.IssuingResult

getQuantity() - Method in class bb.common.JobProcessSheetListResult

getQuantity() - Method in class bb.common.LnShipperItemListResult

getQuantity() - Method in class bb.common.NonproductivePickingItemResult

getQuantity() - Method in class bb.common.NonproductivePickingItemVO

getQuantity() - Method in class bb.common.NonproductivePickingOnDemandResult

getQuantity() - Method in class bb.common.OnloanReceiverItemListResult

getQuantity() - Method in class bb.common.OnloanReceiverItemVO

getQuantity() - Method in class bb.common.OperatingInstructionsUserStatisticalResult

getQuantity() - Method in class bb.common.OperatingInstructionsVO

getQuantity() - Method in class bb.common.PackingBoxItemListResult

getQuantity() - Method in class bb.common.PackingBoxItemVO

getQuantity() - Method in class bb.common.PartInQAResult

getQuantity() - Method in class bb.common.PartInQAVO

getQuantity() - Method in class bb.common.PfReceiverItemVO

getQuantity() - Method in class bb.common.ProformaInvoiceItemListResult

getQuantity() - Method in class bb.common.ProformaInvoiceItemVO

getQuantity() - Method in class bb.common.PrPackingBoxItemVO

getQuantity() - Method in class bb.common.PurchaseWorkSheetItemVO

getQuantity() - Method in class bb.common.RebackInQAAgent

getQuantity() - Method in class bb.common.ReceiverItemVO

getQuantity() - Method in class bb.common.ReceivingItemResult

getQuantity() - Method in class bb.common.RequestForQuoteItemVO

getQuantity() - Method in class bb.common.RequestForRMAItemVO

getQuantity() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getQuantity() - Method in class bb.common.ReturnToVendorByDateListResult

getQuantity() - Method in class bb.common.ReturnToVendorItemVO

getQuantity() - Method in class bb.common.RMAReceiverItemListResult

getQuantity() - Method in class bb.common.RMAReceiverItemVO

getQuantity() - Method in class bb.common.RMAReceiverResult

getQuantity() - Method in class bb.common.RunningAccountOrderItemVO

getQuantity() - Method in class bb.common.SalesBomItemResult

getQuantity() - Method in class bb.common.SalesPartListItemResult

getQuantity() - Method in class bb.common.SGSaleItemAgent

getQuantity() - Method in class bb.common.SGSaleItemVO

getQuantity() - Method in class bb.common.ShipperItemListResult

getQuantity() - Method in class bb.common.ShippingItemResult

getQuantity() - Method in class bb.common.ShoppingCartItem

getQuantity() - Method in class bb.common.WOItemPartDetailNotIssue

getQuantity() - Method in class bb.common.WoItemPickListItemResult

getQuantity() - Method in class bb.common.WoItemPickListResult

getQuantity() - Method in class bb.common.WOReceiverDetail

getQuantity() - Method in class bb.common.WorkOrderItemInfoResult

getQuantity() - Method in class bb.common.WorkOrderItemIssuedTotalResult

getQuantity() - Method in class bb.common.WorkOrderItemIssueVO

getQuantity() - Method in class bb.common.WorkOrderItemPartDetail

getQuantity() - Method in class bb.common.WorkOrderItemPartDetailItemResult

getQuantity() - Method in class bb.common.WorkOrderItemPartDetailResult

getQuantity() - Method in class bb.common.WorkOrderItemReviewCostResult

getQuantity() - Method in class bb.common.WorkOrderItemTimeDetailResult

getQuantity() - Method in class bb.common.WorkOrderItemVO

getQuantity() - Method in class bb.common.WorkOrderQueryInfo

getQuantity() - Method in class bb.common.WorkOrderTimeCardVO

getQuantity() - Method in class bb.common.WorkOrderWorkSheetItemVO

getQuantityAsm() - Method in class bb.common.IssuingResult

getQuantityAsm() - Method in class bb.common.JobProcessSheetListResult

getQuantityAsm() - Method in class bb.common.WOItemPartDetailNotIssue

getQuantityAsm() - Method in class bb.common.WOReceiverDetail

getQuantityAsm() - Method in class bb.common.WorkOrderItemInfoResult

getQuantityAsm() - Method in class bb.common.WorkOrderItemReviewCostResult

getQuantityAsm() - Method in class bb.common.WorkOrderItemVO

getQuantityAsm() - Method in class bb.common.WorkOrderOnDemandResult

getQuantityAsm() - Method in class bb.common.WorkOrderOnOrderResult

getQuantityAsm() - Method in class bb.common.WorkOrderQueryInfo

getQuantityDemanded() - Method in class bb.common.WorkOrderInWipResult

getQuantityDemanded() - Method in class bb.common.WorkOrderOnDemandResult

getQuantityInWip() - Method in class bb.common.WorkOrderInWipResult

getQuantityIssued() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getQuantityIssued() - Method in class bb.common.IssuingItemResult

getQuantityIssued() - Method in class bb.common.NonproductivePickingOnDemandResult

getQuantityIssued() - Method in class bb.common.WorkOrderInWipResult

getQuantityIssued() - Method in class bb.common.WorkOrderItemPartDetailItemResult

getQuantityIssued() - Method in class bb.common.WorkOrderOnDemandResult

getQuantityNotAsm() - Method in class bb.common.WorkOrderOnDemandResult

getQuantityNotShipped() - Method in class bb.common.SalesOrderOrphanedResult

getQuantityOnDemand() - Method in class bb.common.NonproductivePickingOnDemandResult

getQuantityOnDemand() - Method in class bb.common.SalesOrderOnDemandResult

getQuantityOnDemand() - Method in class bb.common.WorkOrderOnDemandResult

getQuantityOnOrder() - Method in class bb.common.PurchaseOrderOnOrderResult

getQuantityOnOrder() - Method in class bb.common.SwapShipperOnOrderResult

getQuantityOnOrder() - Method in class bb.common.WorkOrderOnOrderResult

getQuantityOrdered() - Method in class bb.common.POSurveyReportItemVO

getQuantityOrdered() - Method in class bb.common.PurchaseOrderItemVO

getQuantityOrdered() - Method in class bb.common.PurchaseOrderOnOrderResult

getQuantityOrdered() - Method in class bb.common.SalesOrderItemGroupByPartListResult

getQuantityOrdered() - Method in class bb.common.SalesOrderItemInfoVO

getQuantityOrdered() - Method in class bb.common.SalesOrderItemVO

getQuantityOrdered() - Method in class bb.common.SalesOrderOnDemandResult

getQuantityOrdered() - Method in class bb.common.SalesOrderShipDateListResult

getQuantityOrdered() - Method in class bb.common.WorkOrderOnOrderResult

getQuantityQualified() - Method in class bb.common.POSurveyReportItemVO

getQuantityRcv() - Method in class bb.common.RMAReceiverItemListResult

getQuantityRcv() - Method in class bb.common.RMAReceiverItemVO

getQuantityRec() - Method in class bb.common.OnloanShipperItemVO

getQuantityReceived() - Method in class bb.common.OnloanReceiverItemListResult

getQuantityReceived() - Method in class bb.common.OnloanReceiverItemVO

getQuantityReceived() - Method in class bb.common.POSurveyReportItemVO

getQuantityReceived() - Method in class bb.common.PurchaseOrderItemVO

getQuantityReceived() - Method in class bb.common.PurchaseOrderOnOrderResult

getQuantityReceived() - Method in class bb.common.PurchaseOrderOpenDueListResult

getQuantityReceived() - Method in class bb.common.ReceiverItemVO

getQuantityReceived() - Method in class bb.common.ReceivingItemResult

getQuantityShip() - Method in class bb.common.DisassembleWorkOrderItemVO

getQuantityShip() - Method in class bb.common.LnShipperItemListResult

getQuantityShip() - Method in class bb.common.OnloanShipperItemVO

getQuantityShip() - Method in class bb.common.ShipperItemListResult

getQuantityShip() - Method in class bb.common.ShipperItemVO

getQuantityShip() - Method in class bb.common.ShippingItemResult

getQuantityShipped() - Method in class bb.common.DisassembleWorkOrderItemListResult

getQuantityShipped() - Method in class bb.common.DisassembleWorkOrderReceivingResult

getQuantityShipped() - Method in class bb.common.PurchaseOrderItemVO

getQuantityShipped() - Method in class bb.common.QuoteItemVO

getQuantityShipped() - Method in class bb.common.SalesOrderItemGroupByPartListResult

getQuantityShipped() - Method in class bb.common.SalesOrderItemInfoVO

getQuantityShipped() - Method in class bb.common.SalesOrderItemVO

getQuantityShipped() - Method in class bb.common.SalesOrderOnDemandResult

getQuantityShipped() - Method in class bb.common.SalesOrderShipDateListResult

getQuantityShipped() - Method in class bb.common.SOShipperItemListResult

getQuantityShippedTotal() - Method in class bb.common.DWOIssueDetail

getQuantitySip() - Method in class bb.common.ShippingItemResult

getQuantityTraced() - Method in class bb.common.OnloanReceiverItemVO

getQuantityTraced() - Method in class bb.common.ReceiverItemVO

getQuantityTraced() - Method in class bb.common.RMAReceiverItemVO

getQuarterUsage() - Method in class bb.common.PartInventoryVO

getQuarterUsage() - Method in class bb.common.PartWithOnhandDetailInfoResult

getQuarterUsage() - Method in class bb.common.ToolInventoryVO

getQuestion() - Method in class bb.common.CustomerServiceIncidentItemVO

getQuestionById(String) - Method in interface bb.common.box.CustomerServiceBox

getQuestionCn() - Method in class bb.common.FeedbackQuestionVO

getQuestionEn() - Method in class bb.common.FeedbackQuestionVO

getQuestionId() - Method in class bb.common.FeedbackAnswerPK

getQuestionId() - Method in class bb.common.FeedBackItemPK

getQuestionId() - Method in class bb.common.FeedbackQuestionVO

getQuestionList(String) - Method in interface bb.common.box.CustomerServiceBox

getQuoteBPByPk(String) - Method in interface bb.common.box.SalesBox

getQuoteBPCountByBPId(String) - Method in interface bb.common.box.SalesBox

getQuoteById(String) - Method in interface bb.common.box.SalesBox

getQuoteByQuoteNumberLike(String) - Method in interface bb.common.box.SalesBox

getQuoteComments() - Method in class bb.common.QuoteVO

getQuoteCurrency() - Method in class bb.common.CPItemFromQuoteResult

getQuoteDate() - Method in class bb.common.QuoteVO

getQuoteDiscount() - Method in class bb.common.CPItemFromQuoteResult

getQuoteDocumentByID(Long) - Method in interface bb.common.box.SalesBox

getQuoteDocuments() - Method in class bb.common.QuoteVO

getQuoteedSGCustRequestForQuoteListResultsCount(String, String, String) - Method in interface bb.common.box.SalesBox

getQuoteItemComments() - Method in class bb.common.QuoteItemVO

getQuoteItemCountByAddressId(String) - Method in interface bb.common.box.SalesBox

getQuoteItemCountByDate(PartPK, String, String, String, String, String, String, Date, Date, String, String) - Method in interface bb.common.box.SalesBox

getQuoteItemCountByPartLike(String, String) - Method in interface bb.common.box.SalesBox

getQuoteItemCountByPartPK(PartPK) - Method in interface bb.common.box.SalesBox

getQuoteItemManufacturer() - Method in class bb.common.QuoteItemVO

getQuoteItemNumber() - Method in class bb.common.CPItemFromQuoteResult

getQuoteItemNumber() - Method in class bb.common.QuoteItemManufacturerPK

getQuoteItemNumber() - Method in class bb.common.QuoteItemPK

getQuoteItemPrivateNotes() - Method in class bb.common.QuoteItemVO

getQuoteItems() - Method in class bb.common.QuoteVO

getQuoteItemVo(QuoteItemPK) - Method in interface bb.common.box.SalesBox

getQuoteListPrice() - Method in class bb.common.CPItemFromQuoteResult

getQuoteNumber() - Method in class bb.common.Quote2QuoteAgent

getQuoteNumber() - Method in class bb.common.QuoteDocumentVO

getQuoteNumber() - Method in class bb.common.QuoteItemManufacturerPK

getQuoteNumber() - Method in class bb.common.QuoteItemPK

getQuoteNumber() - Method in class bb.common.QuoteVO

getQuoteNumber() - Method in class bb.common.SalesOrderVO

getQuoteNumber() - Method in class bb.common.SGCustRequestForQuoteListResult

getQuoteNumber() - Method in class bb.common.SGCustRequestForQuoteResult

getQuoteNumber() - Method in class bb.common.SGCustRequestForQuoteVO

getQuotePrivateNotes() - Method in class bb.common.QuoteVO

getQuoteQuantity() - Method in class bb.common.QuoteItemVO

getQuotesCountByAddressId(String) - Method in interface bb.common.box.SalesBox

getRAccounts() - Method in class bb.common.TwelveMonthCashFlowReportResult

getRaoiNumber() - Method in class bb.common.RunningAccountOrderItemResult

getRaoNumber() - Method in class bb.common.CheckInvoiceItemListResult

getRaoNumber() - Method in class bb.common.RunningAccountOrderItemResult

getRate() - Method in class bb.common.EquipmentVO

getRatingCode() - Method in class bb.common.PartManufacturerVO

getRatingCode() - Method in class bb.common.PartVendorVO

getRatingCode() - Method in class bb.common.ToolManufacturerVO

getRatingCode() - Method in class bb.common.ToolVendorVO

getRatio() - Method in class bb.common.BillItemReplacementVO

getRbFlag() - Method in class bb.common.BillVO

getRCode() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getRCode() - Method in class bb.common.ReceivingItemResult

getRealReceivable() - Method in class bb.common.RunningAccountOrderVO

getRealTimeOnhand() - Method in class bb.common.RunningAccountOrderItemVO

getReason() - Method in exception bb.common.BB2ServerException

getReason() - Method in exception bb.common.PermissionException

getReason() - Method in class bb.common.Reason

getReason() - Method in exception bb.common.ServerException

getReCalSubTotal() - Method in class bb.common.MakeAccountPayableAgent

getReCalSubTotal() - Method in class bb.common.MakeBillAndHoldInvoiceAgent

getReCalSubTotal() - Method in class bb.common.MakeDebitMemoAgent

getReCalSubTotal() - Method in class bb.common.MakeInvoiceAgent

getReCalTax() - Method in class bb.common.MakeAccountPayableAgent

getReCalTax() - Method in class bb.common.MakeBillAndHoldInvoiceAgent

getReCalTax() - Method in class bb.common.MakeDebitMemoAgent

getReCalTax() - Method in class bb.common.MakeInvoiceAgent

getRecCost() - Method in class bb.common.WOIssuedByMonthResult

getReceiptNumber() - Method in class bb.common.ReturnMaterialAuthorizationVO

getReceiptNumber() - Method in class bb.common.SalesOrderVO

getReceiptOrdersCount(String, String[], String[], String, Date, Date, String, boolean) - Method in interface bb.common.box.CompanyBox

getReceiptTemplateID() - Method in class bb.common.PointOfSaleVO

getReceiveAll() - Method in class bb.common.ReceiverShipAgent

getReceiveAllSo() - Method in class bb.common.ReceiverShipAgent

getReceiveAllWo() - Method in class bb.common.ReceiverShipAgent

getReceiveComment() - Method in class bb.common.AssetUsageVO

getReceiveComment() - Method in class bb.common.CustomAssetRecordVO

getReceived() - Method in class bb.common.GeneralLedgerByDateListResult

getReceived() - Method in class bb.common.GeneralLedgerListResult

getReceived() - Method in class bb.common.GeneralLedgerVO

getReceived() - Method in class bb.common.PaymentInvoicesResult

getReceiveDate() - Method in class bb.common.AssetUsageVO

getReceiveDate() - Method in class bb.common.AssetVO

getReceiveDate() - Method in class bb.common.CustomAssetRecordVO

getReceiveDate() - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

getReceivedBy() - Method in class bb.common.AccountsPayableInfoVO

getReceivedBy() - Method in class bb.common.AccountsPayableItemVO

getReceivedBy() - Method in class bb.common.AccountsPayableVO

getReceivedBy() - Method in class bb.common.OnloanReceiverItemListResult

getReceivedBy() - Method in class bb.common.OnloanReceiverItemVO

getReceivedBy() - Method in class bb.common.OnloanReceiverListResult

getReceivedBy() - Method in class bb.common.OnloanReceiverVO

getReceivedBy() - Method in class bb.common.PartInQAResult

getReceivedBy() - Method in class bb.common.PartInQAVO

getReceivedBy() - Method in class bb.common.PfReceiverVO

getReceivedBy() - Method in class bb.common.ReceiverInfoVO

getReceivedBy() - Method in class bb.common.ReceiverItemVO

getReceivedBy() - Method in class bb.common.ReceiverVO

getReceivedBy() - Method in class bb.common.RMAReceiverItemListResult

getReceivedBy() - Method in class bb.common.RMAReceiverItemVO

getReceivedBy() - Method in class bb.common.RMAReceiverListResult

getReceivedBy() - Method in class bb.common.RMAReceiverVO

getReceivedBy() - Method in class bb.common.StockTransactionPOReceiverResult

getReceivedBy() - Method in class bb.common.SwapReceiverListResult

getReceivedBy() - Method in class bb.common.SwapReceiverVO

getReceivedBy() - Method in class bb.common.TempReceiverWithoutAPInfo

getReceivedBy() - Method in class bb.common.TransferReceiverListResult

getReceivedBy() - Method in class bb.common.TransferReceiverVO

getReceivedCost() - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

getReceivedDate() - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

getReceivedDate() - Method in class bb.common.PartInQAResult

getReceivedDate() - Method in class bb.common.PartInQAVO

getReceivedDate() - Method in class bb.common.PartOnhandCostVO

getReceivedDate() - Method in class bb.common.POReceiverItemListResult

getReceivedDate() - Method in class bb.common.ReceiverAgent

getReceivedDate() - Method in class bb.common.ReceiverShipAgent

getReceivedDate() - Method in class bb.common.StockTransactionPOReceiverResult

getReceivedDate() - Method in class bb.common.StockTransactionWOReceiverResult

getReceivedDate() - Method in class bb.common.SwapReceiverItemListResult

getReceivedDate() - Method in class bb.common.SwapReceiverItemVO

getReceivedDate() - Method in class bb.common.SwapReceiverListResult

getReceivedDate() - Method in class bb.common.SwapReceiverVO

getReceivedDate() - Method in class bb.common.TransferReceiverItemListResult

getReceivedDate() - Method in class bb.common.TransferReceiverItemVO

getReceivedDate() - Method in class bb.common.TransferReceiverListResult

getReceivedDate() - Method in class bb.common.TransferReceiverVO

getReceiveDepartment() - Method in class bb.common.AssetUsageVO

getReceiveDepartment() - Method in class bb.common.CustomAssetRecordVO

getReceivedFrom() - Method in class bb.common.PartInQAAgent

getReceivedFrom() - Method in class bb.common.PartInQAResult

getReceivedFrom() - Method in class bb.common.PartInQAVO

getReceivedQty() - Method in class bb.common.OnLoanItemListResult

getReceivedQty() - Method in class bb.common.PartInventoryVO

getReceivedQty() - Method in class bb.common.PartOnhandCostVO

getReceivedQty() - Method in class bb.common.PurchaseOrderItemListResult

getReceivedQty() - Method in class bb.common.ReceiverItemDetailAgent

getReceivedQty() - Method in class bb.common.ReturnToVendorItemVO

getReceivedQty() - Method in class bb.common.RMAItemListResult

getReceivedQty() - Method in class bb.common.SwapOrderItemListResult

getReceivedQty() - Method in class bb.common.SwapOrderItemVO

getReceivedQty() - Method in class bb.common.SwapReceiverItemListResult

getReceivedQty() - Method in class bb.common.SwapReceiverItemVO

getReceivedQty() - Method in class bb.common.SwapShipperItemListResult

getReceivedQty() - Method in class bb.common.SwapShipperItemVO

getReceivedQty() - Method in class bb.common.SwapShipperOnOrderResult

getReceivedQty() - Method in class bb.common.ToolInventoryVO

getReceivedQty() - Method in class bb.common.TransferOrderItemListResult

getReceivedQty() - Method in class bb.common.TransferOrderItemVO

getReceivedQty() - Method in class bb.common.TransferReceiverItemListResult

getReceivedQty() - Method in class bb.common.TransferReceiverItemVO

getReceivedQty() - Method in class bb.common.TransferShipperItemListResult

getReceivedQty() - Method in class bb.common.TransferShipperItemVO

getReceivedQuantity() - Method in class bb.common.CustomerReturnToVendorItemVO

getReceivedQuantity() - Method in class bb.common.DisassembleWorkOrderItemPartDetailItemResult

getReceivedQuantity() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

getReceivedQuantity() - Method in class bb.common.OnLoanItemVO

getReceivedQuantity() - Method in class bb.common.RequestForQuoteItemVO

getReceivedQuantity() - Method in class bb.common.RequestForRMAItemVO

getReceivedQuantity() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getReceivedQuantity() - Method in class bb.common.RMAReceiverResult

getReceivedStdCost() - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

getReceivedTo() - Method in class bb.common.ReceivedToOrderItem

getReceivedTo() - Method in class bb.common.ReceiverItemDetailAgent

getReceivedToDetails() - Method in class bb.common.ReceiverItemAgent

getReceivedToOrderItems() - Method in class bb.common.ReceivingItemResult

getReceiver() - Method in class bb.common.DisassembleWorkOrderIssuingResult

getReceiver() - Method in class bb.common.MessageVO

getReceiver() - Method in class bb.common.PartReceivedVO

getReceiver() - Method in class bb.common.PfReceiverItemVO

getReceiver() - Method in class bb.common.ReceivingResult

getReceiver() - Method in class bb.common.SgClientProgramUserVO

getReceiverById(String) - Method in interface bb.common.box.WarehouseBox

getReceiverComments() - Method in class bb.common.MakeAccountPayableAgent

getReceiverComments() - Method in class bb.common.ReceiverInfoVO

getReceiverComments() - Method in class bb.common.TransferReceiverListResult

getReceiverComments() - Method in class bb.common.TransferReceiverVO

getReceiverDigits() - Method in class bb.common.CompanyVO

getReceiverInfoCountByReceiverNumber(ArrayList) - Method in interface bb.common.box.WarehouseBox

getReceiverItem() - Method in class bb.common.OnloanReceiverVO

getReceiverItem() - Method in class bb.common.ReceiverVO

getReceiverItemByPK(ReceiverItemPK) - Method in interface bb.common.box.WarehouseBox

getReceiverItemManufacturer() - Method in class bb.common.ReceiverItemVO

getReceiverItemNumber() - Method in class bb.common.AccountsPayableItemVO

getReceiverItemNumber() - Method in class bb.common.OnloanReceiverItemListResult

getReceiverItemNumber() - Method in class bb.common.OnloanReceiverItemPK

getReceiverItemNumber() - Method in class bb.common.ReceiverItemPK

getReceiverItems() - Method in class bb.common.MakeAccountPayableAgent

getReceiverNotes() - Method in class bb.common.MakeAccountPayableAgent

getReceiverNumber() - Method in class bb.common.AccountPayableCheckRunItemVO

getReceiverNumber() - Method in class bb.common.AccountPayableInfoWithPrepayResult

getReceiverNumber() - Method in class bb.common.AccountsPayableInfoVO

getReceiverNumber() - Method in class bb.common.AccountsPayableItemVO

getReceiverNumber() - Method in class bb.common.AccountsPayableVO

getReceiverNumber() - Method in class bb.common.APItemListResult

getReceiverNumber() - Method in class bb.common.GeneralLedgerListResult

getReceiverNumber() - Method in class bb.common.GeneralLedgerResult

getReceiverNumber() - Method in class bb.common.GeneralLedgerVO

getReceiverNumber() - Method in class bb.common.MakeAccountPayableAgent

getReceiverNumber() - Method in class bb.common.NcrNeedToScrapListResult

getReceiverNumber() - Method in class bb.common.NonConformanceReportVO

getReceiverNumber() - Method in class bb.common.OnloanReceiverItemListResult

getReceiverNumber() - Method in class bb.common.OnloanReceiverItemPK

getReceiverNumber() - Method in class bb.common.OnloanReceiverListResult

getReceiverNumber() - Method in class bb.common.OnloanReceiverVO

getReceiverNumber() - Method in class bb.common.PartCertificateListResult

getReceiverNumber() - Method in class bb.common.PartCertificateVO

getReceiverNumber() - Method in class bb.common.PartInQAVO

getReceiverNumber() - Method in class bb.common.POReceiverItemListResult

getReceiverNumber() - Method in class bb.common.ReceiverInfoVO

getReceiverNumber() - Method in class bb.common.ReceiverItemAgent

getReceiverNumber() - Method in class bb.common.ReceiverItemManufacturerPK

getReceiverNumber() - Method in class bb.common.ReceiverItemPK

getReceiverNumber() - Method in class bb.common.ReceiverVO

getReceiverNumber() - Method in class bb.common.RMAReceiverItemListResult

getReceiverNumber() - Method in class bb.common.RMAReceiverItemPK

getReceiverNumber() - Method in class bb.common.RMAReceiverListResult

getReceiverNumber() - Method in class bb.common.RMAReceiverVO

getReceiverNumber() - Method in class bb.common.StockTransactionPOReceiverResult

getReceiverNumber() - Method in class bb.common.TempReceiverWithoutAPInfo

getReceiverPrefix() - Method in class bb.common.CompanyVO

getReceiverPrivateNotes() - Method in class bb.common.ReceiverInfoVO

getReceiverPrivateNotes() - Method in class bb.common.TransferReceiverListResult

getReceiverPrivateNotes() - Method in class bb.common.TransferReceiverVO

getReceivers() - Method in class bb.common.MessageAgent

getReceiversByBuyerCodeCount(String) - Method in interface bb.common.box.WarehouseBox

getReceiversCountByRn(String) - Method in interface bb.common.box.WarehouseBox

getReceiversInfoByFiscalYear() - Method in interface bb.common.box.ManagementBox

getReceiversInfoByMonth(int) - Method in interface bb.common.box.ManagementBox

getReceiverUserName() - Method in class bb.common.MessageVO

getReceiverWithOutApCount(String, String, String, Date, Date) - Method in interface bb.common.box.AccountingBox

getReceiverWithoutAPSaveRecordDetailsCount(Date) - Method in interface bb.common.box.AccountingBox

getReceiverWithoutAPSaveRecordsCount() - Method in interface bb.common.box.AccountingBox

getReceiverWithOutApTotals(String, String, String, Date, Date) - Method in interface bb.common.box.AccountingBox

getReceiveSign() - Method in class bb.common.AssetUsageVO

getReceiveSign() - Method in class bb.common.CustomAssetRecordVO

getReceiveSign() - Method in class bb.common.CustomAssetVO

getReceiveVo() - Method in class bb.common.DisassembleWorkOrderItemPartDetailItemResult

getReceivingItems() - Method in class bb.common.ReceivingResult

getReceNumber() - Method in class bb.common.SerialNumberResult

getRecItemsOnTimeCount() - Method in class bb.common.PurchaseOrderOnTimeItemResult

getRecItemsOnTimeCount() - Method in class bb.common.WorkOrderOnTimeItemResult

getRecNumber() - Method in class bb.common.MiscDocAgent

getReconciledDate() - Method in class bb.common.GeneralLedgerVO

getRecorder() - Method in class bb.common.CustomCheckUpEmployeeVO

getRecorder() - Method in class bb.common.CustomEmployeeTrainVO

getRecorder() - Method in class bb.common.EmployeeTrainingVO

getRecordNumber() - Method in class bb.common.OperatingOutputFileItemVO

getRecordType() - Method in class bb.common.EmployeeRecordsVO

getRecordType() - Method in class bb.common.MiscDocAgent

getRecostedDate() - Method in class bb.common.PartInventoryVO

getRecQty() - Method in class bb.common.EcnPOOrderResult

getRecQty() - Method in class bb.common.StockTransactionPOReceiverResult

getRecQty() - Method in class bb.common.StockTransactionWOReceiverResult

getRecQuantity() - Method in class bb.common.WOIssuedByMonthResult

getRectifySightLeft() - Method in class bb.common.CustomCheckUpEmployeeVO

getRectifySightRight() - Method in class bb.common.CustomCheckUpEmployeeVO

getRecTotalOnTime() - Method in class bb.common.PurchaseOrderOnTimeItemResult

getRecTotalOnTime() - Method in class bb.common.WorkOrderOnTimeItemResult

getRecursiveBill(PartPK) - Method in interface bb.common.box.EngineeringBox

getRecursivePartPKs(String) - Method in interface bb.common.box.EngineeringBox

getRecWoApprovedBy() - Method in class bb.common.AccountingConfigurationVO

getRef() - Method in class bb.common.DisassembleWorkOrderItemPartDetailItemResult

getRef() - Method in class bb.common.EquipmentListResult

getRef() - Method in class bb.common.EquipmentVO

getRef() - Method in class bb.common.WorkInstructionSequenceVO

getRef() - Method in class bb.common.WorkOrderItemPartDetailItemResult

getRef() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getRefAcct() - Method in class bb.common.NonConformanceReportVO

getRefDoc() - Method in class bb.common.PartInQAAgent

getRefDoc() - Method in class bb.common.PartInQAVO

getRefDoc() - Method in class bb.common.PartOnhandCostVO

getRefdoc() - Method in class bb.common.PurchaseWorkSheetItemVO

getRefDoc() - Method in class bb.common.RunningAccountOrderItemVO

getRefdoc() - Method in class bb.common.TotalAmountInPOByRefDoc

getRefDoc() - Method in class bb.common.WorkOrderWorkInstructionListResult

getRefDoc1() - Method in class bb.common.AccountsPayableItemVO

getRefDoc1() - Method in class bb.common.AccountsReceivableItemVO

getRefDoc1() - Method in class bb.common.AssetVO

getRefDoc1() - Method in class bb.common.CorrectiveActionRequestVO

getRefDoc1() - Method in class bb.common.CustomerReturnToVendorItemVO

getRefDoc1() - Method in class bb.common.CustomerServiceIncidentVO

getRefDoc1() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getRefDoc1() - Method in class bb.common.DisassembleWorkOrderItemListResult

getRefDoc1() - Method in class bb.common.DisassembleWorkOrderReceivingResult

getRefDoc1() - Method in class bb.common.EngineeringChangeVO

getRefDoc1() - Method in class bb.common.IssuingResult

getRefDoc1() - Method in class bb.common.JobProcessSheetListResult

getRefDoc1() - Method in class bb.common.LogInventoryListResult

getRefDoc1() - Method in class bb.common.LogInventoryVO

getRefDoc1() - Method in class bb.common.LogTrackingVO

getRefDoc1() - Method in class bb.common.NonConformanceReportVO

getRefDoc1() - Method in class bb.common.OnLoanItemVO

getRefDoc1() - Method in class bb.common.POItemByRefDoc1ListResult

getRefDoc1() - Method in class bb.common.PreventiveActionRequestVO

getRefDoc1() - Method in class bb.common.ProformaInvoiceItemVO

getRefDoc1() - Method in class bb.common.PurchaseOrderOnOrderResult

getRefDoc1() - Method in class bb.common.ReceivingItemResult

getRefDoc1() - Method in class bb.common.RequestForQuoteItemListResult

getRefDoc1() - Method in class bb.common.RequestForRMAItemVO

getRefDoc1() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getRefDoc1() - Method in class bb.common.ReturnToVendorItemListResult

getRefDoc1() - Method in class bb.common.ReturnToVendorItemVO

getRefDoc1() - Method in class bb.common.RMAReceiverItemVO

getRefDoc1() - Method in class bb.common.RtvShipperItemVO

getRefDoc1() - Method in class bb.common.SalesOrderOnDemandResult

getRefDoc1() - Method in class bb.common.ShippingItemResult

getRefDoc1() - Method in class bb.common.SwapOrderItemVO

getRefDoc1() - Method in class bb.common.SwapReceiverItemVO

getRefDoc1() - Method in class bb.common.SwapShipperItemVO

getRefDoc1() - Method in class bb.common.TransferOrderItemVO

getRefDoc1() - Method in class bb.common.TransferReceiverItemListResult

getRefDoc1() - Method in class bb.common.TransferReceiverItemVO

getRefDoc1() - Method in class bb.common.TransferShipperItemListResult

getRefDoc1() - Method in class bb.common.TransferShipperItemVO

getRefDoc1() - Method in class bb.common.WorkOrderItemListResult

getRefDoc1() - Method in class bb.common.WorkOrderOnDemandResult

getRefDoc1() - Method in class bb.common.WorkOrderOnOrderResult

getRefDoc1Set() - Method in class bb.common.DisassembleWorkOrderItemPartDetailItemResult

getRefDoc1Set() - Method in class bb.common.WorkOrderItemPartDetailItemResult

getRefDoc2() - Method in class bb.common.AccountsPayableItemVO

getRefDoc2() - Method in class bb.common.AccountsReceivableItemVO

getRefDoc2() - Method in class bb.common.AssetVO

getRefDoc2() - Method in class bb.common.CorrectiveActionRequestVO

getRefDoc2() - Method in class bb.common.CustomerReturnToVendorItemVO

getRefDoc2() - Method in class bb.common.CustomerServiceIncidentVO

getRefDoc2() - Method in class bb.common.DisassembleWorkOrderIssueVO

getRefDoc2() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getRefDoc2() - Method in class bb.common.DisassembleWorkOrderItemListResult

getRefDoc2() - Method in class bb.common.DisassembleWorkOrderReceivingResult

getRefDoc2() - Method in class bb.common.EngineeringChangeVO

getRefDoc2() - Method in class bb.common.IssuingResult

getRefDoc2() - Method in class bb.common.JobProcessSheetListResult

getRefDoc2() - Method in class bb.common.LogInventoryListResult

getRefDoc2() - Method in class bb.common.LogInventoryVO

getRefDoc2() - Method in class bb.common.LogTrackingVO

getRefDoc2() - Method in class bb.common.NonConformanceReportVO

getRefDoc2() - Method in class bb.common.OnLoanItemVO

getRefDoc2() - Method in class bb.common.PreventiveActionRequestVO

getRefDoc2() - Method in class bb.common.ProformaInvoiceItemVO

getRefDoc2() - Method in class bb.common.PurchaseOrderOnOrderResult

getRefDoc2() - Method in class bb.common.ReceivingItemResult

getRefDoc2() - Method in class bb.common.RequestForQuoteItemListResult

getRefDoc2() - Method in class bb.common.RequestForRMAItemVO

getRefDoc2() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getRefDoc2() - Method in class bb.common.ReturnToVendorByDateListResult

getRefDoc2() - Method in class bb.common.ReturnToVendorItemListResult

getRefDoc2() - Method in class bb.common.ReturnToVendorItemVO

getRefDoc2() - Method in class bb.common.RMAReceiverItemVO

getRefDoc2() - Method in class bb.common.RtvShipperItemVO

getRefDoc2() - Method in class bb.common.SalesOrderOnDemandResult

getRefDoc2() - Method in class bb.common.ShippingItemResult

getRefDoc2() - Method in class bb.common.SwapOrderItemVO

getRefDoc2() - Method in class bb.common.SwapReceiverItemVO

getRefDoc2() - Method in class bb.common.SwapShipperItemVO

getRefDoc2() - Method in class bb.common.TransferOrderItemVO

getRefDoc2() - Method in class bb.common.TransferReceiverItemListResult

getRefDoc2() - Method in class bb.common.TransferReceiverItemVO

getRefDoc2() - Method in class bb.common.TransferShipperItemListResult

getRefDoc2() - Method in class bb.common.TransferShipperItemVO

getRefDoc2() - Method in class bb.common.WorkOrderItemListResult

getRefDoc2() - Method in class bb.common.WorkOrderOnDemandResult

getRefDoc2() - Method in class bb.common.WorkOrderOnOrderResult

getRefDoc2() - Method in class bb.common.WorkOrderReceiverVO

getRefDocDetails() - Method in class bb.common.PartWithQAQtyListResult

getRefDocDetails() - Method in class bb.common.PartWithQtyListResult

getRefDocDetails() - Method in class bb.common.PartWithSipQtyListResult

getRefDocDetails() - Method in class bb.common.PartWithSITQtyListResult

getRefDocDetails() - Method in class bb.common.PartWithSTOQtyListResult

getRefDocDetails() - Method in class bb.common.PartWithWipQtyListResult

getRefDocOnes() - Method in class bb.common.AccountsPayableItemVO

getRefDocOnes() - Method in class bb.common.AccountsReceivableItemVO

getRefDocOnes() - Method in class bb.common.DisassembleWorkOrderItemListResult

getRefDocOnes() - Method in class bb.common.DisassembleWorkOrderItemVO

getRefDocOnes() - Method in class bb.common.InspectionConformanceReportItemVO

getRefDocOnes() - Method in class bb.common.PurchaseOrderItemListResult

getRefDocOnes() - Method in class bb.common.PurchaseOrderItemVO

getRefDocOnes() - Method in class bb.common.QuoteItemVO

getRefDocOnes() - Method in class bb.common.ReceiverItemVO

getRefDocOnes() - Method in class bb.common.RtvShipperItemVO

getRefDocOnes() - Method in class bb.common.SalesOrderItemListResult

getRefDocOnes() - Method in class bb.common.SalesOrderItemVO

getRefDocOnes() - Method in class bb.common.ShipperItemVO

getRefDocOnes() - Method in class bb.common.WorkOrderItemListResult

getRefDocOnes() - Method in class bb.common.WorkOrderItemVO

getRefDocReceiver() - Method in class bb.common.PartOnhandCostVO

getRefDocString(String, String) - Static method in class bb.common.BB2Util

getRefDocString() - Method in class bb.common.OrderPK

getRefDocString() - Method in class bb.common.RefdocElement

getRefDocTwo(RefdocVO) - Static method in class bb.common.BB2Util

getRefDocTwoes() - Method in class bb.common.AccountsPayableItemVO

getRefDocTwoes() - Method in class bb.common.AccountsReceivableItemVO

getRefDocTwoes() - Method in class bb.common.DisassembleWorkOrderItemListResult

getRefDocTwoes() - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

getRefDocTwoes() - Method in class bb.common.DisassembleWorkOrderItemVO

getRefDocTwoes() - Method in class bb.common.InspectionConformanceReportItemVO

getRefDocTwoes() - Method in class bb.common.PurchaseOrderItemListResult

getRefDocTwoes() - Method in class bb.common.PurchaseOrderItemVO

getRefDocTwoes() - Method in class bb.common.QuoteItemVO

getRefDocTwoes() - Method in class bb.common.ReceiverItemVO

getRefDocTwoes() - Method in class bb.common.RtvShipperItemVO

getRefDocTwoes() - Method in class bb.common.SalesOrderItemListResult

getRefDocTwoes() - Method in class bb.common.SalesOrderItemVO

getRefDocTwoes() - Method in class bb.common.ShipperItemVO

getRefDocTwoes() - Method in class bb.common.SwapOrderItemVO

getRefDocTwoes() - Method in class bb.common.SwapReceiverItemVO

getRefDocTwoes() - Method in class bb.common.SwapShipperItemVO

getRefDocTwoes() - Method in class bb.common.TransferOrderItemVO

getRefDocTwoes() - Method in class bb.common.TransferShipperItemVO

getRefDocTwoes() - Method in class bb.common.WoItemPickListResult

getRefDocTwoes() - Method in class bb.common.WorkOrderItemListResult

getRefDocTwoes() - Method in class bb.common.WorkOrderItemPartDetailResult

getRefDocTwoes() - Method in class bb.common.WorkOrderItemVO

getReferenceDoc1() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

getReferenceDoc1() - Method in class bb.common.DisassembleWorkOrderItemVO

getReferenceDoc1() - Method in class bb.common.OnloanReceiverItemVO

getReferenceDoc1() - Method in class bb.common.OnloanShipperItemVO

getReferenceDoc1() - Method in class bb.common.OrderApprovalItemsVO

getReferenceDoc1() - Method in class bb.common.PurchaseOrderItemVO

getReferenceDoc1() - Method in class bb.common.QuoteItemVO

getReferenceDoc1() - Method in class bb.common.ReceiverItemVO

getReferenceDoc1() - Method in class bb.common.RequestForQuoteItemVO

getReferenceDoc1() - Method in class bb.common.SalesOrderItemInfoVO

getReferenceDoc1() - Method in class bb.common.SalesOrderItemVO

getReferenceDoc1() - Method in class bb.common.ShipperItemVO

getReferenceDoc1() - Method in class bb.common.WorkOrderItemIssueVO

getReferenceDoc1() - Method in class bb.common.WorkOrderItemVO

getReferenceDoc2() - Method in class bb.common.DisassembleWorkOrderItemVO

getReferenceDoc2() - Method in class bb.common.OnloanReceiverItemVO

getReferenceDoc2() - Method in class bb.common.OnloanShipperItemVO

getReferenceDoc2() - Method in class bb.common.OrderApprovalItemsVO

getReferenceDoc2() - Method in class bb.common.PurchaseOrderItemVO

getReferenceDoc2() - Method in class bb.common.QuoteItemVO

getReferenceDoc2() - Method in class bb.common.ReceiverItemVO

getReferenceDoc2() - Method in class bb.common.RequestForQuoteItemVO

getReferenceDoc2() - Method in class bb.common.SalesOrderItemInfoVO

getReferenceDoc2() - Method in class bb.common.SalesOrderItemVO

getReferenceDoc2() - Method in class bb.common.ShipperItemVO

getReferenceDoc2() - Method in class bb.common.WorkOrderItemVO

getReferenceNumber() - Method in class bb.common.PartCertificateListResult

getReferenceNumber() - Method in class bb.common.PartCertificateVO

getReferenceSalesOrder() - Method in class bb.common.SalesOrderVO

getReferer() - Method in class bb.common.SGQuoteLoginVO

getRefId() - Method in class bb.common.BizBoxUserEmployeeResult

getRefId() - Method in class bb.common.BizboxUserListResult

getRefId() - Method in class bb.common.BizboxUserVO

getRefId() - Method in class bb.common.MessageAgent

getRefId() - Method in class bb.common.MessageVO

getRefId() - Method in class bb.common.User2UserAgent

getRefId() - Method in class bb.common.UserRolePermissionListResult

getRefNumber() - Method in class bb.common.MiscDocAgent

getRefNumber() - Method in class bb.common.SerialNumberResult

getRegion() - Method in class bb.common.CustomerVendorAddressInfoVO

getRegion() - Method in class bb.common.CustomerVendorAddressVO

getRegion() - Method in class bb.common.SalesOrderItemListResult

getReimbursement() - Method in class bb.common.ExpenseVO

getReject() - Method in class bb.common.WorkOrderItemTimeDetailVO

getRejectPercent() - Method in class bb.common.NCQRejectResult

getRejectQty() - Method in class bb.common.InspectionReportInfoVO

getRejectQty() - Method in class bb.common.InspectionReportVO

getRejectQty() - Method in class bb.common.JobProcessSheetItemResult

getRejectQty() - Method in class bb.common.WorkOrderTimeCardVO

getRejectQuantity() - Method in class bb.common.NCQRejectResult

getRejectQuantity() - Method in class bb.common.NonConformanceQuantityVO

getRejectReason() - Method in class bb.common.InspectionReportInfoVO

getRejectReason() - Method in class bb.common.InspectionReportVO

getRelatedDoc() - Method in class bb.common.CustomerReturnToVendorVO

getRelatedDoc() - Method in class bb.common.DisassembleWorkOrderIssuingResult

getRelatedDoc() - Method in class bb.common.DisassembleWorkOrderItemListResult

getRelatedDoc() - Method in class bb.common.DisassembleWorkOrderItemVO

getRelatedDoc() - Method in class bb.common.DisassembleWorkOrderVO

getRelatedDoc() - Method in class bb.common.OnloanReceiverVO

getRelatedDoc() - Method in class bb.common.OnloanShipperVO

getRelatedDoc() - Method in class bb.common.PartIssuedListResult

getRelatedDoc() - Method in class bb.common.PartReceivedListResult

getRelatedDoc() - Method in class bb.common.PfReceiverVO

getRelatedDoc() - Method in class bb.common.POStatisticsResult

getRelatedDoc() - Method in class bb.common.PrReceiverListResult

getRelatedDoc() - Method in class bb.common.PurchaseOrderItemListResult

getRelatedDoc() - Method in class bb.common.PurchaseOrderListResult

getRelatedDoc() - Method in class bb.common.PurchaseOrderVO

getRelatedDoc() - Method in class bb.common.ReceiverInfoVO

getRelatedDoc() - Method in class bb.common.ReceiverVO

getRelatedDoc() - Method in class bb.common.ReceivingResult

getRelatedDoc() - Method in class bb.common.RequestForQuoteVO

getRelatedDoc() - Method in class bb.common.RequestForRMAVO

getRelatedDoc() - Method in class bb.common.ReturnMaterialAuthorizationVO

getRelatedDoc() - Method in class bb.common.SalesOrderItemListResult

getRelatedDoc() - Method in class bb.common.ShipperInfoVO

getRelatedDoc() - Method in class bb.common.ShipperVO

getRelatedDoc() - Method in class bb.common.SwapOrderItemListResult

getRelatedDoc() - Method in class bb.common.SwapOrderListResult

getRelatedDoc() - Method in class bb.common.SwapOrderVO

getRelatedDoc() - Method in class bb.common.SwapReceiverListResult

getRelatedDoc() - Method in class bb.common.SwapReceiverVO

getRelatedDoc() - Method in class bb.common.SwapShipperListResult

getRelatedDoc() - Method in class bb.common.SwapShipperVO

getRelatedDoc() - Method in class bb.common.TotalAmountInPOByRefDoc

getRelatedDoc() - Method in class bb.common.WorkOrderItemInfoResult

getRelatedDoc() - Method in class bb.common.WorkOrderItemInWipListResult

getRelatedDoc() - Method in class bb.common.WorkOrderItemIssuedTotalResult

getRelatedDoc() - Method in class bb.common.WorkOrderItemListResult

getRelatedDoc() - Method in class bb.common.WorkOrderItemPartDetail

getRelatedDoc() - Method in class bb.common.WorkOrderItemVO

getRelatedDoc() - Method in class bb.common.WorkOrderQueryInfo

getRelatedDoc() - Method in class bb.common.WorkOrderVO

getRelatedDocument() - Method in class bb.common.QuoteVO

getRelatedDocument() - Method in class bb.common.SalesOrderListResult

getRelatedDocument() - Method in class bb.common.SalesOrderVO

getRelatedDocument() - Method in class bb.common.TransferOrderListResult

getRelatedDocument() - Method in class bb.common.TransferOrderVO

getRelatedDocument() - Method in class bb.common.TransferReceiverListResult

getRelatedDocument() - Method in class bb.common.TransferReceiverVO

getRelatedDocument() - Method in class bb.common.TransferShipperListResult

getRelatedDocument() - Method in class bb.common.TransferShipperVO

getRelatedGL(String, String, String, String, String, String, String) - Method in interface bb.common.box.AccountingBox

getRelatedInspectorSign() - Method in class bb.common.OperatingInstructionsVO

getReldoc() - Method in class bb.common.AccountsPayableInfoVO

getReldoc() - Method in class bb.common.AccountsPayableVO

getReldoc() - Method in class bb.common.AccountsReceivableInfoVO

getReldoc() - Method in class bb.common.AccountsReceivableVO

getReldoc() - Method in class bb.common.GeneralLedgerListResult

getReldoc() - Method in class bb.common.GeneralLedgerVO

getReldoc() - Method in class bb.common.OnLoanVO

getReldoc() - Method in class bb.common.ProformaInvoiceVO

getReldoc() - Method in class bb.common.ReturnToVendorVO

getReldoc() - Method in class bb.common.RMAReceiverVO

getReldoc() - Method in class bb.common.RtvShipperInfoVO

getReldoc() - Method in class bb.common.RtvShipperVO

getRelevantAccount() - Method in class bb.common.JounalEntryListResult

getRelevantAccountDescription() - Method in class bb.common.JounalEntryListResult

getRemarks() - Method in class bb.common.CarrierVO

getRemarks() - Method in class bb.common.DocumentServerVO

getRemarks() - Method in class bb.common.DwfUploadSettingsVO

getRemarks() - Method in class bb.common.DwgUploadSettingsVO

getRemarks() - Method in class bb.common.MiscDocumentSettingVO

getRemarks() - Method in class bb.common.PartManufacturerVO

getRemarks() - Method in class bb.common.PartVendorVO

getRemarks() - Method in class bb.common.ToolManufacturerVO

getRemarks() - Method in class bb.common.ToolVendorVO

getRemitAddressId() - Method in class bb.common.CompanyVO

getRemitId() - Method in class bb.common.AccountPayableCheckVO

getRemitId() - Method in class bb.common.AccountReceivablePaymentVO

getRemitId() - Method in class bb.common.AccountsReceivableInfoVO

getRemitId() - Method in class bb.common.AccountsReceivableVO

getRemitId() - Method in class bb.common.CustomerVendorAddressInfoVO

getRemitId() - Method in class bb.common.CustomerVendorAddressVO

getRemitId() - Method in class bb.common.OnloanShipperVO

getRemitId() - Method in class bb.common.ProformaInvoiceVO

getRemitId() - Method in class bb.common.RtvShipperInfoVO

getRemitId() - Method in class bb.common.RtvShipperVO

getRemitId() - Method in class bb.common.ShipperInfoVO

getRemitId() - Method in class bb.common.ShipperVO

getRemovedItem() - Method in class bb.common.SalesBomItemResult

getRepeatDelay() - Method in class bb.common.TaskVO

getReplaceDesc() - Method in class bb.common.BillItemReplacementVO

getReplacedItem() - Method in class bb.common.WorkOrderItemIssueVO

getReplacedItem() - Method in class bb.common.WorkOrderItemSetupItemAgent

getReplaceItem() - Method in class bb.common.WorkOrderItemSetupItemAgent

getReplacePartNumber() - Method in class bb.common.BillItemReplacementVO

getReplacePartType() - Method in class bb.common.BillItemReplacementVO

getReportBugEmail() - Method in class bb.common.CompanyVO

getReportBy() - Method in class bb.common.BizboxBugInfoVO

getReportBy() - Method in class bb.common.BizboxBugVO

getReportBy() - Method in class bb.common.CustomerServiceIncidentItemListResult

getReportBy() - Method in class bb.common.CustomerServiceIncidentVO

getReportDate() - Method in class bb.common.BizboxBugInfoVO

getReportDate() - Method in class bb.common.BizboxBugVO

getReportedBy() - Method in class bb.common.CustomerFeedbackVO

getReportType() - Method in class bb.common.AccountsChartCategoryVO

getReqDescription() - Method in class bb.common.CSRAgent

getReqDescription() - Method in class bb.common.SGCustomerServiceRequestVO

getRequester() - Method in class bb.common.ApPrepayVO

getRequester() - Method in class bb.common.ArPrepayVO

getRequester() - Method in class bb.common.CRTVListResult

getRequester() - Method in class bb.common.CustomerReturnToVendorVO

getRequester() - Method in class bb.common.OnloanReceiverVO

getRequester() - Method in class bb.common.PfReceiverVO

getRequester() - Method in class bb.common.POStatisticsResult

getRequester() - Method in class bb.common.PurchaseOrderContractResult

getRequester() - Method in class bb.common.PurchaseOrderItemListResult

getRequester() - Method in class bb.common.PurchaseOrderListResult

getRequester() - Method in class bb.common.PurchaseOrderVO

getRequester() - Method in class bb.common.QuoteVO

getRequester() - Method in class bb.common.ReceiverInfoVO

getRequester() - Method in class bb.common.ReceiverVO

getRequester() - Method in class bb.common.RequestForQuoteVO

getRequester() - Method in class bb.common.RequestForRMAVO

getRequester() - Method in class bb.common.ReturnMaterialAuthorizationVO

getRequester() - Method in class bb.common.RMAListResult

getRequester() - Method in class bb.common.RRMAListResult

getRequester() - Method in class bb.common.SalesOrderVO

getRequester() - Method in class bb.common.TransferOrderListResult

getRequester() - Method in class bb.common.TransferOrderVO

getRequestForQuote() - Method in class bb.common.PartVendorVO

getRequestForQuote() - Method in class bb.common.ToolVendorVO

getRequestForQuoteByRfqNumber(String) - Method in interface bb.common.box.ManufacturingBox

getRequestForQuoteByRfqNumber(String) - Method in interface bb.common.box.PurchasingBox

getRequestForQuoteItem() - Method in class bb.common.RequestForQuoteVO

getRequestForQuoteItemListResultsCount(String, String, String, boolean) - Method in interface bb.common.box.ManufacturingBox

getRequestForQuoteItemListResultsCount(String, String, String) - Method in interface bb.common.box.ManufacturingBox

getRequestForQuoteItemListResultsCount(String, String, String, boolean) - Method in interface bb.common.box.PurchasingBox

getRequestForQuoteItemListResultsCount(String, String, String) - Method in interface bb.common.box.PurchasingBox

getRequestForQuoteItemListResultsCountByPartNumberAndDateLike(String, String, String, Date, Date, String, String) - Method in interface bb.common.box.PurchasingBox

getRequestForQuoteItemListResultsCountByPartNumberAndDateLike(String, String, String, Date, Date, String, boolean) - Method in interface bb.common.box.PurchasingBox

getRequestForQuoteItemListResultsCountByPartNumberLike(String, String) - Method in interface bb.common.box.ManufacturingBox

getRequestForQuoteItemListResultsCountByPartNumberLike(String, String) - Method in interface bb.common.box.PurchasingBox

getRequestForQuoteItemManufacturer() - Method in class bb.common.RequestForQuoteItemVO

getRequestForQuoteItemNumber() - Method in class bb.common.RequestForQuoteItemManufacturerPK

getRequestForQuoteItemNumber() - Method in class bb.common.RequestForQuoteItemPK

getRequestForQuoteListResultsCount(String, String, String) - Method in interface bb.common.box.ManufacturingBox

getRequestForQuoteListResultsCount(String, String, String) - Method in interface bb.common.box.PurchasingBox

getRequestForQuoteListResultsCountByRfqNumber(String) - Method in interface bb.common.box.ManufacturingBox

getRequestForQuoteListResultsCountByRfqNumber(String) - Method in interface bb.common.box.PurchasingBox

getRequestForQuoteListResultsCountByVendorId(String) - Method in interface bb.common.box.ManufacturingBox

getRequestForQuoteListResultsCountByVendorId(String) - Method in interface bb.common.box.PurchasingBox

getRequestForQuoteNumber() - Method in class bb.common.RequestForQuoteItemManufacturerPK

getRequestForQuoteNumber() - Method in class bb.common.RequestForQuoteItemPK

getRequestForQuoteNumber() - Method in class bb.common.RequestForQuoteVO

getRequestForQuoteStatus(String) - Method in interface bb.common.box.ManufacturingBox

getRequestForQuoteStatus(String) - Method in interface bb.common.box.PurchasingBox

getRequestInspectionDate() - Method in class bb.common.OperatingInstructionsVO

getRequestInspectionOperatingInstructionsCount() - Method in interface bb.common.box.ManufacturingBox

getRequestor() - Method in class bb.common.AccountsPayableInfoVO

getRequestor() - Method in class bb.common.AccountsPayableVO

getRequestor() - Method in class bb.common.AccountsReceivableInfoVO

getRequestor() - Method in class bb.common.AccountsReceivableVO

getRequestor() - Method in class bb.common.CSRAgent

getRequestor() - Method in class bb.common.DisassembleWorkOrderVO

getRequestor() - Method in class bb.common.OnLoanVO

getRequestor() - Method in class bb.common.ReturnToVendorByDateListResult

getRequestor() - Method in class bb.common.ReturnToVendorVO

getRequestor() - Method in class bb.common.RMAReceiverVO

getRequestor() - Method in class bb.common.SGCustomerServiceRequestVO

getRequestor() - Method in class bb.common.WorkOrderVO

getRequireDate() - Method in class bb.common.CSRAgent

getRequireDate() - Method in class bb.common.DisassembleWorkOrderReceivingResult

getRequireDate() - Method in class bb.common.IssuingResult

getRequireDate(WorkOrderWorkInstructionSequencePK) - Method in class bb.common.POForWISeqAgent

getRequireDate() - Method in class bb.common.SGCustomerServiceRequestVO

getRequireDate() - Method in class bb.common.SGCustRequestForQuoteItemVO

getRequiredDate() - Method in class bb.common.JobProcessSheetItemResult

getRequiredDate() - Method in class bb.common.WorkOrderWorkInstructionListResult

getRequiredQty() - Method in class bb.common.ShipListItemVOResult

getResearchDevelopment() - Method in class bb.common.ProfitLossStatementResult

getResolveResult() - Method in class bb.common.OperatingInstructionsVO

getResolveResultSign() - Method in class bb.common.OperatingInstructionsVO

getRespondDate() - Method in class bb.common.RequestForQuoteListResult

getResponsibility() - Method in class bb.common.CorrectiveActionRequestVO

getResponsibility() - Method in class bb.common.NcrNeedToScrapListResult

getResponsibility() - Method in class bb.common.NcrReportListResult

getResponsibility() - Method in class bb.common.NonConformanceReportVO

getResponsibility() - Method in class bb.common.OperatingInstructionsUserStatisticalResult

getResponsibility() - Method in class bb.common.OperatingInstructionsVO

getResult() - Method in class bb.common.CustomEmployeeTrainVO

getResult() - Method in class bb.common.EmployeeTrainingVO

getResults() - Method in class bb.common.CustomerServiceIncidentItemVO

getResults() - Method in class bb.common.GLCheckRegisterResult

getRetainedEarnings() - Method in class bb.common.AccountingBalanceSheetResult

getRetainedEarningTotal() - Method in class bb.common.ClosingStatementResult

getRetainedEqrning() - Method in class bb.common.ClosingStatementResult

getReturnAddressId() - Method in class bb.common.CompanyVO

getReturnComment() - Method in class bb.common.AssetUsageVO

getReturnComment() - Method in class bb.common.CustomAssetRecordVO

getReturnDate() - Method in class bb.common.AssetUsageVO

getReturnDate() - Method in class bb.common.CustomAssetRecordVO

getReturnDepartment() - Method in class bb.common.AssetUsageVO

getReturnDepartment() - Method in class bb.common.CustomAssetRecordVO

getReturnMaterialAuthorizationItemManufacturer() - Method in class bb.common.CustomerReturnToVendorItemVO

getReturnMaterialAuthorizationItemManufacturer() - Method in class bb.common.RequestForRMAItemVO

getReturnMaterialAuthorizationItemManufacturer() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getReturnOnSales() - Method in class bb.common.ProfitLossStatementResult

getReturnSign() - Method in class bb.common.AssetUsageVO

getReturnSign() - Method in class bb.common.CustomAssetRecordVO

getReturnTemplateID() - Method in class bb.common.PointOfSaleVO

getReturnToVendorByRtvNumber(String) - Method in interface bb.common.box.ManufacturingBox

getReturnToVendorByRtvNumber(String) - Method in interface bb.common.box.PurchasingBox

getReturnToVendorItemListResultsCount(String, String, String, boolean) - Method in interface bb.common.box.ManufacturingBox

getReturnToVendorItemListResultsCount(String, String, String) - Method in interface bb.common.box.ManufacturingBox

getReturnToVendorItemListResultsCount(String, String, String, boolean) - Method in interface bb.common.box.PurchasingBox

getReturnToVendorItemListResultsCount(String, String, String) - Method in interface bb.common.box.PurchasingBox

getReturnToVendorItemListResultsCountByPartNumberLike(String, String) - Method in interface bb.common.box.ManufacturingBox

getReturnToVendorItemListResultsCountByPartNumberLike(String, String) - Method in interface bb.common.box.PurchasingBox

getReturnToVendorItemManufacturer() - Method in class bb.common.ReturnToVendorItemVO

getReturnToVendorItemNumber() - Method in class bb.common.ReturnToVendorItemManufacturerPK

getReturnToVendorItemNumber() - Method in class bb.common.ReturnToVendorItemPK

getReturnToVendorItemsListResultsCount(String, String, String, String, String, String, String, String, String, boolean, Date, Date, String, String, String, String, String) - Method in interface bb.common.box.PurchasingBox

getReturnToVendorItemsListResultsCount(String, String, String, String, String, String, String, String, String, boolean, Date, Date, String, String, String, String, String, String) - Method in interface bb.common.box.PurchasingBox

getReturnToVendorListResultsCount(String, String, String) - Method in interface bb.common.box.ManufacturingBox

getReturnToVendorListResultsCount(String, String, String) - Method in interface bb.common.box.PurchasingBox

getReturnToVendorListResultsCountByRtvNumber(String) - Method in interface bb.common.box.ManufacturingBox

getReturnToVendorListResultsCountByRtvNumber(String) - Method in interface bb.common.box.PurchasingBox

getReturnToVendorListResultsCountByVendorId(String) - Method in interface bb.common.box.ManufacturingBox

getReturnToVendorListResultsCountByVendorId(String) - Method in interface bb.common.box.PurchasingBox

getReturnToVendorNumber() - Method in class bb.common.ReturnToVendorItemManufacturerPK

getReturnToVendorNumber() - Method in class bb.common.ReturnToVendorItemPK

getReturnToVendorNumber() - Method in class bb.common.ReturnToVendorVO

getReturnToVendorStatus(String) - Method in interface bb.common.box.ManufacturingBox

getReturnToVendorStatus(String) - Method in interface bb.common.box.PurchasingBox

getRev() - Method in class bb.common.BB2PartInfo

getRev() - Method in class bb.common.BillItemSalesResult

getRev() - Method in class bb.common.BillItemSalesXResult

getRev() - Method in class bb.common.BillSalesResult

getRev() - Method in class bb.common.BillSalesXResult

getRev() - Method in class bb.common.BomItemWithOEMResult

getRev() - Method in class bb.common.BomWithOEMResult

getRev() - Method in class bb.common.InventoryNotUsedInMonthsResult

getRev() - Method in class bb.common.PartWithInventoryInfoListResult

getRev() - Method in class bb.common.SGCustRequestForQuoteItemVO

getRev() - Method in class bb.common.ShoppingCartItem

getRev() - Method in class bb.common.StockTransactionPartInfoResult

getRev() - Method in class bb.common.WorkInstructionSummaryResult

getRev() - Method in class bb.common.WorkOrderItemCanAssyResult

getRevenueItems() - Method in class bb.common.ClosingStatementResult

getRevenueTotal() - Method in class bb.common.ClosingStatementResult

getReviewDescription() - Method in class bb.common.DisassembleWorkOrderItemVO

getReviewDescription() - Method in class bb.common.WorkOrderItemReviewCostResult

getReviewDescription() - Method in class bb.common.WorkOrderItemVO

getReviewed() - Method in class bb.common.EngineeringSharingImportLogVO

getReviewed() - Method in class bb.common.OnLoanVO

getReviewed() - Method in class bb.common.QuoteVO

getReviewedBy() - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

getReviewedBy() - Method in class bb.common.DisassembleWorkOrderItemVO

getReviewedBy() - Method in class bb.common.EngineeringSharingImportLogVO

getReviewedBy() - Method in class bb.common.OnLoanVO

getReviewedBy() - Method in class bb.common.QuoteVO

getReviewedBy() - Method in class bb.common.SalesOrderVO

getReviewedBy() - Method in class bb.common.WOItemCostControlAgent

getReviewedBy() - Method in class bb.common.WorkOrderItemPartDetailResult

getReviewedBy() - Method in class bb.common.WorkOrderItemReviewCostResult

getReviewedBy() - Method in class bb.common.WorkOrderItemVO

getReviewedDate() - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

getReviewedDate() - Method in class bb.common.DisassembleWorkOrderItemVO

getReviewedDate() - Method in class bb.common.SalesOrderVO

getReviewedDate() - Method in class bb.common.WOItemCostControlAgent

getReviewedDate() - Method in class bb.common.WorkOrderItemPartDetailResult

getReviewedDate() - Method in class bb.common.WorkOrderItemReviewCostResult

getReviewedDate() - Method in class bb.common.WorkOrderItemVO

getReviewedDesc() - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

getReviewedDesc() - Method in class bb.common.WOItemCostControlAgent

getReviewedDesc() - Method in class bb.common.WorkOrderItemPartDetailResult

getReviewLimit() - Method in class bb.common.NonproductivePickingApproveVO

getReviewLimit() - Method in class bb.common.OnloanReviewVO

getReviewLimit() - Method in class bb.common.RMAReviewVO

getReviewLimit() - Method in class bb.common.SalesOrderReviewVO

getRevision() - Method in class bb.common.AccountsPayableItemVO

getRevision() - Method in class bb.common.AccountsReceivableItemVO

getRevision() - Method in class bb.common.BomPickListItemResult

getRevision() - Method in class bb.common.CorrectiveActionRequestVO

getRevision() - Method in class bb.common.CustomerReturnToVendorItemVO

getRevision() - Method in class bb.common.CustomerServiceIncidentVO

getRevision() - Method in class bb.common.DisassembleWorkOrderIssueVO

getRevision() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getRevision() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

getRevision() - Method in class bb.common.DisassembleWorkOrderItemVO

getRevision() - Method in class bb.common.DisassembleWorkOrderReceivingResult

getRevision() - Method in class bb.common.EngineeringChangeRequestVO

getRevision() - Method in class bb.common.IssuingItemResult

getRevision() - Method in class bb.common.IssuingResult

getRevision() - Method in class bb.common.LogPartDwfVO

getRevision() - Method in class bb.common.LogPartDwgVO

getRevision() - Method in class bb.common.MiscDocAgent

getRevision() - Method in class bb.common.NonproductivePickingItemVO

getRevision() - Method in class bb.common.OnLoanItemVO

getRevision() - Method in class bb.common.OnloanReceiverItemVO

getRevision() - Method in class bb.common.OnloanShipperItemVO

getRevision() - Method in class bb.common.OrderApprovalItemsVO

getRevision() - Method in class bb.common.PackingBoxSalesOrderItemResult

getRevision() - Method in class bb.common.PartBasicInfo

getRevision() - Method in class bb.common.PartCertificateVO

getRevision() - Method in class bb.common.PartDwfVO

getRevision() - Method in class bb.common.PartDwfWithPartInfoResult

getRevision() - Method in class bb.common.PartDwgAgent

getRevision() - Method in class bb.common.PartDwgPK

getRevision() - Method in class bb.common.PartDwgWithPartInfoResult

getRevision() - Method in class bb.common.PartVO

getRevision() - Method in class bb.common.PartWithOnhandsVO

getRevision() - Method in class bb.common.PfReceiverItemVO

getRevision() - Method in class bb.common.PreventiveActionRequestVO

getRevision() - Method in class bb.common.ProformaInvoiceItemVO

getRevision() - Method in class bb.common.PurchaseOrderItemVO

getRevision() - Method in class bb.common.QuoteItemVO

getRevision() - Method in class bb.common.ReceiverItemVO

getRevision() - Method in class bb.common.ReceivingItemResult

getRevision() - Method in class bb.common.RequestForQuoteItemVO

getRevision() - Method in class bb.common.RequestForRMAItemVO

getRevision() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getRevision() - Method in class bb.common.ReturnToVendorItemVO

getRevision() - Method in class bb.common.RMAReceiverItemVO

getRevision() - Method in class bb.common.RtvShipperItemVO

getRevision() - Method in class bb.common.SalesBomItemResult

getRevision() - Method in class bb.common.SalesBomResult

getRevision() - Method in class bb.common.SalesOrderItemInfoVO

getRevision() - Method in class bb.common.SalesOrderItemVO

getRevision() - Method in class bb.common.SalesOrderShipDateListResult

getRevision() - Method in class bb.common.SalesPartListItemResult

getRevision() - Method in class bb.common.SalesPartListResult

getRevision() - Method in class bb.common.SerialNumberResult

getRevision() - Method in class bb.common.SGBOMItemResult

getRevision() - Method in class bb.common.SGDwgPictureVO

getRevision() - Method in class bb.common.SGPartCatalogResult

getRevision() - Method in class bb.common.SGSaleItemVO

getRevision() - Method in class bb.common.ShipperItemVO

getRevision() - Method in class bb.common.ShippingItemResult

getRevision() - Method in class bb.common.SwapOrderItemVO

getRevision() - Method in class bb.common.SwapReceiverItemVO

getRevision() - Method in class bb.common.SwapShipperItemVO

getRevision() - Method in class bb.common.ToolVO

getRevision() - Method in class bb.common.ToolWithOnhandsVO

getRevision() - Method in class bb.common.TransferOrderItemVO

getRevision() - Method in class bb.common.TransferReceiverItemListResult

getRevision() - Method in class bb.common.TransferReceiverItemVO

getRevision() - Method in class bb.common.TransferShipperItemListResult

getRevision() - Method in class bb.common.TransferShipperItemVO

getRevision() - Method in class bb.common.WoItemPickListItemResult

getRevision() - Method in class bb.common.WoItemPickListResult

getRevision() - Method in class bb.common.WorkOrderItemIssueVO

getRevision() - Method in class bb.common.WorkOrderItemTimeDetailVO

getRevision() - Method in class bb.common.WorkOrderItemVO

getRevision() - Method in class bb.common.WorkOrderReceiverVO

getRevision() - Method in class bb.common.WorkOrderTimeCardVO

getRevisionDate() - Method in class bb.common.PartExportInfo

getRevisionDate() - Method in class bb.common.PartVO

getRevisionDate() - Method in class bb.common.PartWithOnhandsVO

getRevisionDate() - Method in class bb.common.SGPartCatalogResult

getRevisionDate() - Method in class bb.common.ToolVO

getRevisionDate() - Method in class bb.common.ToolWithOnhandsVO

getRevsion() - Method in class bb.common.SGCustomerServiceRequestVO

getRFCCountByRFC(String) - Method in interface bb.common.box.ManufacturingBox

getRfcNumber() - Method in class bb.common.WorkInstructionRequestForChangeVO

getRfqCheckListResultsCount(String) - Method in interface bb.common.box.ManufacturingBox

getRfqCheckListResultsCount(String) - Method in interface bb.common.box.PurchasingBox

getRfqComments() - Method in class bb.common.RequestForQuoteVO

getRfqDate() - Method in class bb.common.RequestForQuoteCheckListResult

getRfqDate() - Method in class bb.common.RequestForQuoteItemListResult

getRfqDate() - Method in class bb.common.RequestForQuoteListResult

getRfqDate() - Method in class bb.common.RequestForQuoteVO

getRfqDigits() - Method in class bb.common.CompanyVO

getRfqIds() - Method in class bb.common.PurchaseWorkSheetItemVO

getRfqIds() - Method in class bb.common.WorkOrderWorkSheetItemVO

getRfqIdWritein() - Method in class bb.common.PurchaseWorkSheetItemVO

getRfqIdWritein() - Method in class bb.common.WorkOrderWorkSheetItemVO

getRfqItem() - Method in class bb.common.RfqMessageItemVO

getRfqItemComments() - Method in class bb.common.RequestForQuoteItemVO

getRfqItemPk() - Method in class bb.common.RequestForQuoteItemListResult

getRfqItemPrivateNotes() - Method in class bb.common.RequestForQuoteItemVO

getRfqMessage(String) - Method in interface bb.common.box.PurchasingBox

getRfqMessageByRfqNumber(String) - Method in interface bb.common.box.PurchasingBox

getRfqMessageCountByStatusAndID(String[], String) - Method in interface bb.common.box.PurchasingBox

getRfqMessageDate() - Method in class bb.common.RfqMessageListResult

getRfqMessageDate() - Method in class bb.common.RfqMessageVO

getRfqMessageNumber() - Method in class bb.common.RfqMessageItemPK

getRfqMessageNumber() - Method in class bb.common.RfqMessageListResult

getRfqMessageNumber() - Method in class bb.common.RfqMessageVO

getRfqMessageStatus(String) - Method in interface bb.common.box.PurchasingBox

getRfqNumber() - Method in class bb.common.RequestForQuoteCheckListResult

getRfqNumber() - Method in class bb.common.RequestForQuoteListResult

getRfqNumber() - Method in class bb.common.RfqMessageItemVO

getRfqNumber() - Method in class bb.common.RfqMessageListResult

getRfqNumber() - Method in class bb.common.RfqMessageVO

getRfqOrderItemDwf(String) - Method in interface bb.common.box.PurchasingBox

getRfqPrefix() - Method in class bb.common.CompanyVO

getRfqPrivateNotes() - Method in class bb.common.RequestForQuoteVO

getRis() - Method in class bb.common.CustomCheckUpEmployeeVO

getRmaCheckListCount() - Method in interface bb.common.box.SalesBox

getRmaComments() - Method in class bb.common.ReturnMaterialAuthorizationVO

getRmaDate() - Method in class bb.common.ReturnMaterialAuthorizationVO

getRmaDate() - Method in class bb.common.RMAItemListResult

getRmaDate() - Method in class bb.common.RMAListResult

getRmaDebitAccount() - Method in class bb.common.PointOfSaleVO

getRmaDetails() - Method in class bb.common.BB2PartTotalOndemandDetailResult

getRmaDigits() - Method in class bb.common.CompanyVO

getRmaDocment() - Method in class bb.common.ReturnMaterialAuthorizationVO

getRmaItem() - Method in class bb.common.ReturnMaterialAuthorizationVO

getRmaItemByPartPkCount(PartPK) - Method in interface bb.common.box.SalesBox

getRmaItemComments() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getRmaItemCountByCustomerIdLike(String) - Method in interface bb.common.box.SalesBox

getRmaItemNumber() - Method in class bb.common.ReturnMaterialAuthorizationItemManufacturerPK

getRmaItemNumber() - Method in class bb.common.ReturnMaterialAuthorizationItemPK

getRmaItemNumber() - Method in class bb.common.RMAItemListResult

getRmaItemPrivateNotes() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getRmaItemsCountByDate(PartPK, String, String, String, String, String, String, String, String, boolean, Date, Date) - Method in interface bb.common.box.SalesBox

getRmaNumber() - Method in class bb.common.CustomerReturnToVendorVO

getRmaNumber() - Method in class bb.common.NcrNeedToScrapListResult

getRmaNumber() - Method in class bb.common.NonConformanceReportVO

getRmaNumber() - Method in class bb.common.RequestForRMAVO

getRmaNumber() - Method in class bb.common.ReturnMaterialAuthorizationDocumentVO

getRmaNumber() - Method in class bb.common.ReturnMaterialAuthorizationItemManufacturerPK

getRmaNumber() - Method in class bb.common.ReturnMaterialAuthorizationItemPK

getRmaNumber() - Method in class bb.common.ReturnMaterialAuthorizationVO

getRmaNumber() - Method in class bb.common.RMAItemListResult

getRmaNumber() - Method in class bb.common.RMAListResult

getRmaNumber() - Method in class bb.common.RMAReceiverItemListResult

getRmaNumber() - Method in class bb.common.RMAReceiverItemVO

getRmaNumber() - Method in class bb.common.RMAReceiverListResult

getRmaNumber() - Method in class bb.common.RMAReceiverVO

getRmaPrefix() - Method in class bb.common.CompanyVO

getRmaPrivateNotes() - Method in class bb.common.ReturnMaterialAuthorizationVO

getRMAReceiver(String) - Method in interface bb.common.box.WarehouseBox

getRmaReceiverBySoNumber(String) - Method in interface bb.common.box.SalesBox

getRmaReceiverDigits() - Method in class bb.common.CompanyVO

getRMAReceiverItemByPk(RMAReceiverItemPK) - Method in interface bb.common.box.WarehouseBox

getRMAReceiverItemListResultsCountByCustID(String) - Method in interface bb.common.box.WarehouseBox

getRMAReceiverItemListResultsCountByPartNumber(String, String) - Method in interface bb.common.box.WarehouseBox

getRMAReceiverItemListResultsCountByRMAReceiverNumber(String) - Method in interface bb.common.box.WarehouseBox

getRMAReceiverItemListResultsCountBySONumber(String) - Method in interface bb.common.box.WarehouseBox

getRMAReceiverItemsforRMANumber(String) - Method in interface bb.common.box.WarehouseBox

getRMAReceiverListResultsCountByCustID(String) - Method in interface bb.common.box.WarehouseBox

getRMAReceiverListResultsCountByRMAReceiverNumber(String) - Method in interface bb.common.box.WarehouseBox

getRmaReceiverNumber() - Method in class bb.common.MakeCreditMemoAgent

getRmaReceiverPrefix() - Method in class bb.common.CompanyVO

getRMAReceiverWithoutCMListResultsCount(String) - Method in interface bb.common.box.WarehouseBox

getRmaReceivingResult(String) - Method in interface bb.common.box.WarehouseBox

getRMAReview(String) - Method in interface bb.common.box.SalesBox

getRMAsCountByInvoiceNumber(String) - Method in interface bb.common.box.SalesBox

getRMAsCountByPartPk(PartPK) - Method in interface bb.common.box.SalesBox

getRMAsCountByRmaNumber(String) - Method in interface bb.common.box.SalesBox

getRMAsCountBySoNumber(String) - Method in interface bb.common.box.SalesBox

getRoleByPk(String) - Method in interface bb.common.box.SecurityBox

getRoleId() - Method in class bb.common.RoleDescriptionPK

getRoleId() - Method in class bb.common.RoleListResult

getRoleId() - Method in class bb.common.RolePermissionPK

getRoleId() - Method in class bb.common.RoleVO

getRoleId() - Method in class bb.common.UserRolePermissionListResult

getRoleId() - Method in class bb.common.UserRolePK

getRoleName() - Method in class bb.common.RoleDescriptionVO

getRoleName() - Method in class bb.common.RoleListResult

getRoleName() - Method in class bb.common.UserRolePermissionListResult

getRolePermissions() - Method in class bb.common.RoleVO

getRolesCountByPermission(String, String) - Method in interface bb.common.box.SecurityBox

getRolesCountBySelf(String) - Method in interface bb.common.box.SecurityBox

getRolesCountByUser(String, String) - Method in interface bb.common.box.SecurityBox

getRollUpBomStdCostWorkSheet(Long) - Method in interface bb.common.box.AccountingBox

getRollUpBomStdCostWorkSheetCount() - Method in interface bb.common.box.AccountingBox

getRollUpBomStdCostWorkSheetItemCount(Long) - Method in interface bb.common.box.AccountingBox

getRollUPCost(PartPK) - Method in class bb.common.BOMTreeRollUPMap

getRollUpCost() - Method in class bb.common.RollUpBomStdCostWorkSheetItemVO

getRollUpCount() - Method in class bb.common.RollUpBomStdCostWorkSheetVO

getRollupStdCost() - Method in class bb.common.RollUPPartStandardCostResult

getRootBOMPartPKs(String) - Method in interface bb.common.box.EngineeringBox

getRowNumber() - Method in class bb.common.CycleCountPK

getRowNumber() - Method in class bb.common.PhysicalInventoryPK

getRRMAById(String) - Method in interface bb.common.box.SalesBox

getRrmaDate() - Method in class bb.common.RequestForRMAVO

getRrmaDate() - Method in class bb.common.RRMAItemListResult

getRrmaDate() - Method in class bb.common.RRMAListResult

getRrmaItem() - Method in class bb.common.RequestForRMAVO

getRRMAItemByPk(RequestForRMAItemPK) - Method in interface bb.common.box.SalesBox

getRrmaItemComments() - Method in class bb.common.RequestForRMAItemVO

getRRMAItemListResultCount(PartPK, String, String, String, String, String, String, String, boolean, Date, Date) - Method in interface bb.common.box.SalesBox

getRrmaItemNumber() - Method in class bb.common.RequestForRMAItemPK

getRrmaItemNumber() - Method in class bb.common.RRMAItemListResult

getRrmaItemPrivateNotes() - Method in class bb.common.RequestForRMAItemVO

getRRMAListResultCount(String, String, String, String, String, String, String) - Method in interface bb.common.box.SalesBox

getRrmaNumber() - Method in class bb.common.RequestForRMAItemPK

getRrmaNumber() - Method in class bb.common.RequestForRMAVO

getRrmaNumber() - Method in class bb.common.RRMAItemListResult

getRrmaNumber() - Method in class bb.common.RRMAListResult

getRTotalBudget() - Method in class bb.common.CashFlowMonthTotalResult

getRtran() - Method in class bb.common.AccountsReceivableInfoVO

getRtran() - Method in class bb.common.AccountsReceivableVO

getRTran() - Method in class bb.common.OnloanShipperVO

getRtran() - Method in class bb.common.ProformaInvoiceVO

getRtran() - Method in class bb.common.RtvShipperInfoVO

getRtran() - Method in class bb.common.RtvShipperVO

getRTran() - Method in class bb.common.ShipperInfoVO

getRTran() - Method in class bb.common.ShipperVO

getRTVApproval(String) - Method in interface bb.common.box.PurchasingBox

getRtvCheckListResultsCount(String) - Method in interface bb.common.box.ManufacturingBox

getRtvCheckListResultsCount(String) - Method in interface bb.common.box.PurchasingBox

getRtvComments() - Method in class bb.common.ReturnToVendorByDateListResult

getRtvComments() - Method in class bb.common.ReturnToVendorVO

getRtvDate() - Method in class bb.common.ReturnToVendorByDateListResult

getRtvDate() - Method in class bb.common.ReturnToVendorCheckListResult

getRtvDate() - Method in class bb.common.ReturnToVendorItemListResult

getRtvDate() - Method in class bb.common.ReturnToVendorListResult

getRtvDigits() - Method in class bb.common.CompanyVO

getRtvistatus() - Method in class bb.common.ReturnToVendorByDateListResult

getRtvItemPk() - Method in class bb.common.ReturnToVendorByDateListResult

getRtvItemPk() - Method in class bb.common.ReturnToVendorItemListResult

getRtvItems() - Method in class bb.common.ReturnToVendorVO

getRtvNumber() - Method in class bb.common.NcrNeedToScrapListResult

getRtvNumber() - Method in class bb.common.NcrReportListResult

getRtvNumber() - Method in class bb.common.NonConformanceReportVO

getRtvNumber() - Method in class bb.common.ReturnToVendorCheckListResult

getRtvNumber() - Method in class bb.common.ReturnToVendorListResult

getRtvNumber() - Method in class bb.common.RtvShipperInfoVO

getRtvNumber() - Method in class bb.common.RtvShipperItemListResult

getRtvNumber() - Method in class bb.common.RtvShipperItemVO

getRtvNumber() - Method in class bb.common.RtvShipperListResult

getRtvNumber() - Method in class bb.common.RtvShipperVO

getRtvPrefix() - Method in class bb.common.CompanyVO

getRtvPrivateNotes() - Method in class bb.common.ReturnToVendorVO

getRtvShipperById(String) - Method in interface bb.common.box.WarehouseBox

getRtvShipperByPoNumber(String) - Method in interface bb.common.box.ManufacturingBox

getRtvShipperByPoNumber(String) - Method in interface bb.common.box.PurchasingBox

getRtvShipperDigits() - Method in class bb.common.CompanyVO

getRtvShipperItemByPk(RtvShipperItemPK) - Method in interface bb.common.box.WarehouseBox

getRtvShipperItemListResultsCountByDate(String, String, String, String, String, String, Date, Date) - Method in interface bb.common.box.WarehouseBox

getRtvShipperItemListResultsCountByPartNumber(String, String) - Method in interface bb.common.box.WarehouseBox

getRtvShipperItemListResultsCountByPONumber(String) - Method in interface bb.common.box.WarehouseBox

getRtvShipperItemListResultsCountByRTVNumber(String) - Method in interface bb.common.box.WarehouseBox

getRtvShipperItemListResultsCountByRTVShipperNumber(String) - Method in interface bb.common.box.WarehouseBox

getRtvShipperItemListResultsCountByVendorID(String) - Method in interface bb.common.box.WarehouseBox

getRtvShipperItemListResultsOfRtv(String) - Method in interface bb.common.box.WarehouseBox

getRtvShipperItemNumber() - Method in class bb.common.RtvShipperItemListResult

getRtvShipperItemNumber() - Method in class bb.common.RtvShipperItemPK

getRtvShipperItems() - Method in class bb.common.RtvShipperVO

getRtvShipperListResultsCountByPONumber(String) - Method in interface bb.common.box.WarehouseBox

getRtvShipperListResultsCountByRTVNumber(String) - Method in interface bb.common.box.WarehouseBox

getRtvShipperListResultsCountByRTVShipperNumber(String) - Method in interface bb.common.box.WarehouseBox

getRtvShipperListResultsCountByShippedBy(String) - Method in interface bb.common.box.WarehouseBox

getRtvShipperListResultsCountByVendorID(String) - Method in interface bb.common.box.WarehouseBox

getRtvShipperNumber() - Method in class bb.common.MakeDebitMemoAgent

getRtvShipperNumber() - Method in class bb.common.RtvShipperInfoVO

getRtvShipperNumber() - Method in class bb.common.RtvShipperItemListResult

getRtvShipperNumber() - Method in class bb.common.RtvShipperItemPK

getRtvShipperNumber() - Method in class bb.common.RtvShipperListResult

getRtvShipperNumber() - Method in class bb.common.RtvShipperVO

getRtvShipperPrefix() - Method in class bb.common.CompanyVO

getRTVShipperWithOutDebitMemoCount(String, String, Date, Date) - Method in interface bb.common.box.AccountingBox

getRtvShippingResult(String) - Method in interface bb.common.box.WarehouseBox

getRunHoursLimit() - Method in class bb.common.EquipmentListResult

getRunHoursLimit() - Method in class bb.common.EquipmentVO

getRunningAccountNumber() - Method in class bb.common.ZipcodeTotalsResult

getRunningAccountOrderById(String) - Method in interface bb.common.box.CompanyBox

getRunningAccountOrderItem(RunningAccountOrderItemPK) - Method in interface bb.common.box.CompanyBox

getRunningAccountOrderItemByPartPK(PartPK) - Method in interface bb.common.box.CompanyBox

getRunningAccountOrderItemByPartPK(PartPK, String, String) - Method in interface bb.common.box.CompanyBox

getRunningAccountOrderItemByRaoNumberandPartPK(String, PartPK) - Method in interface bb.common.box.CompanyBox

getRunningAccountOrderItemCount(String, String[], String[], String, Date, Date, String, boolean, String, String, String, String, String, String) - Method in interface bb.common.box.CompanyBox

getRunningAccountOrderItemNumber() - Method in class bb.common.RunningAccountOrderItemPK

getRunningAccountOrderItems() - Method in class bb.common.RunningAccountOrderVO

getRunningAccountOrderNumber() - Method in class bb.common.RunningAccountOrderItemPK

getRunningAccountOrderNumber() - Method in class bb.common.RunningAccountOrderVO

getRunningAccountOrderNumber() - Method in class bb.common.RunTaxPaymentResult

getRv() - Method in class bb.common.LogMiscDocumentVO

getSaleable() - Method in class bb.common.BillSalesCostResult

getSaleable() - Method in class bb.common.PartBasicInfo

getSaleable() - Method in class bb.common.PartCatalogAuditResult

getSaleable() - Method in class bb.common.PartVO

getSaleable() - Method in class bb.common.PartWithOnhandsVO

getSaleable() - Method in class bb.common.SalesBomItemResult

getSaleable() - Method in class bb.common.SalesBomResult

getSaleable() - Method in class bb.common.ToolVO

getSaleable() - Method in class bb.common.ToolWithOnhandsVO

getSaleOrderDocumentByID(Long) - Method in interface bb.common.box.SalesBox

getSalesable() - Method in class bb.common.BillItemSalesCostResult

getSalesable() - Method in class bb.common.BillItemSalesXResult

getSalesable() - Method in class bb.common.BillSalesXResult

getSalesBomResult(BillPK, String) - Method in interface bb.common.box.SalesBox

getSalesCodeByAddressId(String) - Method in interface bb.common.box.SalesBox

getSalesCodeByPk(String) - Method in interface bb.common.box.SalesBox

getSalesCodeCountById(String, String, String, String, BigDecimal) - Method in interface bb.common.box.SalesBox

getSalesCodeCustomerByAddressIds(List) - Method in interface bb.common.box.SalesBox

getSalesCodeId() - Method in class bb.common.AccountsReceivableInfoVO

getSalesCodeId() - Method in class bb.common.AccountsReceivableVO

getSalesCodeId() - Method in class bb.common.ArCommissionListResult

getSalesCodeId() - Method in class bb.common.CustomerReturnToVendorVO

getSalesCodeId() - Method in class bb.common.CustomerVendorAddressInfoVO

getSalesCodeId() - Method in class bb.common.RequestForRMAVO

getSalesCodeId() - Method in class bb.common.ReturnMaterialAuthorizationVO

getSalesCodeId() - Method in class bb.common.SalesCodeVO

getSalesCodeId() - Method in class bb.common.SalesOrderItemListResult

getSalesCodeId() - Method in class bb.common.SalesOrderVO

getSalesCodeIds() - Method in class bb.common.SalesCodeVO

getSalesCodeName() - Method in class bb.common.ArCommissionListResult

getSalesCodeName() - Method in class bb.common.SalesCodeVO

getSalesCost() - Method in class bb.common.CustomerReturnToVendorItemVO

getSalesCost() - Method in class bb.common.RequestForRMAItemVO

getSalesCost() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getSalesCost() - Method in class bb.common.RMAReceiverItemListResult

getSalesCost() - Method in class bb.common.RMAReceiverItemVO

getSalesCountWithPartOnHold() - Method in class bb.common.SalesInfoCenterResult

getSalesDate() - Method in class bb.common.RunningAccountOrderItemResult

getSalesDate() - Method in class bb.common.RunningAccountOrderVO

getSalesDrawing() - Method in class bb.common.PartBasicInfo

getSalesDrawing() - Method in class bb.common.PartVO

getSalesDrawing() - Method in class bb.common.PartWithOnhandsVO

getSalesGroutQuoteNumber() - Method in class bb.common.QuoteVO

getSalesInfoByFiscalYear(String) - Method in interface bb.common.box.ManagementBox

getSalesInfoByMonth(int, boolean) - Method in interface bb.common.box.ManagementBox

getSalesInfoCenterResult() - Method in interface bb.common.box.ManagementBox

getSalesInfoDashBoardByFiscalYear() - Method in interface bb.common.box.ManagementBox

getSalesItemCount() - Method in class bb.common.SalesOrderOnTimeItemResult

getSalesItemDescription() - Method in class bb.common.SalesOrderItemInfoVO

getSalesItemDescription() - Method in class bb.common.SalesOrderItemVO

getSalesItemDescription() - Method in class bb.common.SalesOrderShipDateListResult

getSalesItemPks() - Method in class bb.common.MakeBillAndHoldInvoiceAgent

getSalesItemPks() - Method in class bb.common.MakeInvoiceAgent

getSalesman() - Method in class bb.common.AccountsReceivableInfoVO

getSalesman() - Method in class bb.common.AccountsReceivableVO

getSalesman() - Method in class bb.common.CRTVItemListResult

getSalesman() - Method in class bb.common.CRTVListResult

getSalesman() - Method in class bb.common.CustomerReturnToVendorVO

getSalesman() - Method in class bb.common.CustomerVendorAddressVO

getSalesman() - Method in class bb.common.DisassembleWorkOrderVO

getSalesman() - Method in class bb.common.GeneralLedgerListResult

getSalesman() - Method in class bb.common.GeneralLedgerVO

getSalesman() - Method in class bb.common.LnShipperListResult

getSalesman() - Method in class bb.common.OnloanShipperVO

getSalesman() - Method in class bb.common.OnLoanVO

getSalesman() - Method in class bb.common.ProformaInvoiceVO

getSalesman() - Method in class bb.common.QuoteListResult

getSalesman() - Method in class bb.common.QuoteVO

getSalesman() - Method in class bb.common.RequestForRMAVO

getSalesman() - Method in class bb.common.ReturnMaterialAuthorizationVO

getSalesman() - Method in class bb.common.RMAItemListResult

getSalesman() - Method in class bb.common.RMAListResult

getSalesman() - Method in class bb.common.RRMAItemListResult

getSalesman() - Method in class bb.common.RRMAListResult

getSalesman() - Method in class bb.common.RtvShipperInfoVO

getSalesman() - Method in class bb.common.RtvShipperVO

getSalesman() - Method in class bb.common.RunningAccountOrderItemResult

getSalesman() - Method in class bb.common.RunningAccountOrderVO

getSalesman() - Method in class bb.common.RunTaxPaymentResult

getSalesMan() - Method in class bb.common.SalesOrderCheckListResult

getSalesman() - Method in class bb.common.SalesOrderItemListResult

getSalesman() - Method in class bb.common.SalesOrderListResult

getSalesman() - Method in class bb.common.SalesOrderVO

getSalesman() - Method in class bb.common.ShipperInfoVO

getSalesman() - Method in class bb.common.ShipperListResult

getSalesman() - Method in class bb.common.ShipperVO

getSalesman() - Method in class bb.common.WorkOrderVO

getSalesmanByPk(int) - Method in interface bb.common.box.SalesBox

getSalesmanCount(String, String) - Method in interface bb.common.box.SalesBox

getSalesmanCountById(String) - Method in interface bb.common.box.SalesBox

getSalesmanCountByLastName(String) - Method in interface bb.common.box.SalesBox

getSalesmanId() - Method in class bb.common.OnLoanVO

getSalesmanId() - Method in class bb.common.QuoteVO

getSalesmanId() - Method in class bb.common.SalesmanVO

getSalesManId() - Method in class bb.common.SalesOrderCheckListResult

getSalesmanId() - Method in class bb.common.SalesOrderVO

getSalesMarginPct() - Method in class bb.common.SalesOrderOnTimeItemResult

getSalesMarketing() - Method in class bb.common.ProfitLossStatementResult

getSalesOnTimeResult(OnTimeAgent) - Method in interface bb.common.box.ManagementBox

getSalesOrder() - Method in class bb.common.CustomerPrepayStatementListResult

getSalesOrder() - Method in class bb.common.CustomerStatementListResult

getSalesOrder() - Method in class bb.common.RunningAccountOrderItemResult

getSalesOrder() - Method in class bb.common.RunningAccountOrderVO

getSalesOrder() - Method in class bb.common.ShipperItemVO

getSalesOrder12MonthMarginResultsCount() - Method in interface bb.common.box.ManagementBox

getSalesOrderArPrepayApply(String) - Method in interface bb.common.box.SalesBox

getSalesOrderArPrepayPaid(String) - Method in interface bb.common.box.SalesBox

getSalesOrderBacklogInfoByMonth(int) - Method in interface bb.common.box.ManagementBox

getSalesOrderBoilerplate() - Method in class bb.common.SalesOrderVO

getSalesOrderBPByPk(String) - Method in interface bb.common.box.SalesBox

getSalesOrderBPCountByBPId(String) - Method in interface bb.common.box.SalesBox

getSalesOrderById(String) - Method in interface bb.common.box.SalesBox

getSalesOrderByIdForPrintSOLabel(String) - Method in interface bb.common.box.SalesBox

getSalesOrderComments() - Method in class bb.common.SalesOrderVO

getSalesOrderControlByEmoloyeeTrueName(String) - Method in interface bb.common.box.SalesBox

getSalesOrderControlByEmployeeId(String) - Method in interface bb.common.box.SalesBox

getSalesOrderControlCountByUserTrueNameLike(String) - Method in interface bb.common.box.SalesBox

getSalesOrderDate() - Method in class bb.common.SalesOrderVO

getSalesOrderDocuments() - Method in class bb.common.SalesOrderVO

getSalesOrderItem() - Method in class bb.common.ProformaInvoiceItemListResult

getSalesOrderItem() - Method in class bb.common.ProformaInvoiceItemPK

getSalesOrderItemByPartPkCount(PartPK) - Method in interface bb.common.box.SalesBox

getSalesOrderItemByPk(SalesOrderItemPK) - Method in interface bb.common.box.SalesBox

getSalesOrderItemComments() - Method in class bb.common.SalesOrderItemInfoVO

getSalesOrderItemComments() - Method in class bb.common.SalesOrderItemVO

getSalesOrderItemCostResult(String) - Method in interface bb.common.box.SalesBox

getSalesOrderItemGroupByPartCount(String, String, String, String, Date, Date) - Method in interface bb.common.box.SalesBox

getSalesOrderItemGroupByPartCount(Date, Date) - Method in interface bb.common.box.SalesBox

getSalesOrderItemManufacturer() - Method in class bb.common.SalesOrderItemVO

getSalesOrderItemNumber() - Method in class bb.common.AccountsReceivableItemManufacturerPK

getSalesOrderItemNumber() - Method in class bb.common.AccountsReceivableItemVO

getSalesOrderItemNumber() - Method in class bb.common.CSRAgent

getSalesOrderItemNumber() - Method in class bb.common.PackingBoxItemPK

getSalesOrderItemNumber() - Method in class bb.common.PackingBoxSalesOrderItemResult

getSalesOrderItemNumber() - Method in class bb.common.ProformaInvoiceItemManufacturerPK

getSalesOrderItemNumber() - Method in class bb.common.SalesOrderItemManufacturerPK

getSalesOrderItemNumber() - Method in class bb.common.SalesOrderItemPK

getSalesOrderItemNumber() - Method in class bb.common.SGCustomerServiceRequestVO

getSalesOrderItemNumber() - Method in class bb.common.SGSaleItemAgent

getSalesOrderItemNumber() - Method in class bb.common.SGSaleItemVO

getSalesOrderItemNumber() - Method in class bb.common.ShipListItemPK

getSalesOrderItemNumber() - Method in class bb.common.ShipListItemVOResult

getSalesOrderItemNumber() - Method in class bb.common.ShipperItemListResult

getSalesOrderItemNumber() - Method in class bb.common.ShipperItemManufacturerPK

getSalesOrderItemPk() - Method in class bb.common.SalesOrderOnDemandResult

getSalesOrderItemPrivateNotes() - Method in class bb.common.SalesOrderItemInfoVO

getSalesOrderItemPrivateNotes() - Method in class bb.common.SalesOrderItemVO

getSalesOrderItems() - Method in class bb.common.SalesOrderVO

getSalesOrderItemsByCustomerIdCount(String, Date, Date, String, String, String, String, String) - Method in interface bb.common.box.SalesBox

getSalesOrderItemsCost(String) - Method in interface bb.common.box.SalesBox

getSalesOrderItemsCountByDate(String, String, String, String, String, String, String, String, String, String, String, Date, Date, String, String, String, String, boolean, String, String) - Method in interface bb.common.box.SalesBox

getSalesOrderItemsCountByDates(String, String, String, String, String, String, String, String, String, String, String, Date, Date, String, String, String, String, boolean, String) - Method in interface bb.common.box.SalesBox

getSalesOrderItemsCountByDates(String, String, String, String, String, String, String, String, String, String, String, Date, Date, String, String, String, String, String) - Method in interface bb.common.box.SalesBox

getSalesOrderItemsCountBySalesman(String) - Method in interface bb.common.box.SalesBox

getSalesOrderListResultsforShipListCount(String, String[], Date, Date) - Method in interface bb.common.box.PlanningBox

getSalesOrderNumber() - Method in class bb.common.AccountReceivableInfoWithPrepayResult

getSalesOrderNumber() - Method in class bb.common.AccountsReceivableInfoVO

getSalesOrderNumber() - Method in class bb.common.AccountsReceivableItemVO

getSalesOrderNumber() - Method in class bb.common.AccountsReceivableVO

getSalesOrderNumber() - Method in class bb.common.ArCommissionListResult

getSalesOrderNumber() - Method in class bb.common.ARPrepayInfoResult

getSalesOrderNumber() - Method in class bb.common.ArPrepayVO

getSalesOrderNumber() - Method in class bb.common.CRTVItemListResult

getSalesOrderNumber() - Method in class bb.common.CRTVListResult

getSalesOrderNumber() - Method in class bb.common.CSRAgent

getSalesOrderNumber() - Method in class bb.common.CustomerReturnToVendorVO

getSalesOrderNumber() - Method in class bb.common.DesignControlInfoVO

getSalesOrderNumber() - Method in class bb.common.DesignControlVO

getSalesOrderNumber() - Method in class bb.common.GeneralLedgerListResult

getSalesOrderNumber() - Method in class bb.common.GeneralLedgerResult

getSalesOrderNumber() - Method in class bb.common.GeneralLedgerVO

getSalesOrderNumber() - Method in class bb.common.InvoiceItemListResult

getSalesOrderNumber() - Method in class bb.common.MrpReportAgent

getSalesOrderNumber() - Method in class bb.common.NcrNeedToScrapListResult

getSalesOrderNumber() - Method in class bb.common.NonConformanceReportVO

getSalesOrderNumber() - Method in class bb.common.PackingBoxItemPK

getSalesOrderNumber() - Method in class bb.common.PackingBoxSalesOrderItemResult

getSalesOrderNumber() - Method in class bb.common.PartCertificateListResult

getSalesOrderNumber() - Method in class bb.common.PartCertificateVO

getSalesOrderNumber() - Method in class bb.common.PfReceiverItemVO

getSalesOrderNumber() - Method in class bb.common.ProformaInvoiceItemListResult

getSalesOrderNumber() - Method in class bb.common.ProformaInvoiceItemManufacturerPK

getSalesOrderNumber() - Method in class bb.common.ProformaInvoiceItemPK

getSalesOrderNumber() - Method in class bb.common.PrPackingBoxItemVO

getSalesOrderNumber() - Method in class bb.common.PurchaseOrderVO

getSalesOrderNumber() - Method in class bb.common.RequestForQuoteVO

getSalesOrderNumber() - Method in class bb.common.RequestForRMAVO

getSalesOrderNumber() - Method in class bb.common.ReturnMaterialAuthorizationVO

getSalesOrderNumber() - Method in class bb.common.RMAItemListResult

getSalesOrderNumber() - Method in class bb.common.RMAListResult

getSalesOrderNumber() - Method in class bb.common.RRMAItemListResult

getSalesOrderNumber() - Method in class bb.common.RRMAListResult

getSalesOrderNumber() - Method in class bb.common.SalesOrderItemManufacturerPK

getSalesOrderNumber() - Method in class bb.common.SalesOrderItemPK

getSalesOrderNumber() - Method in class bb.common.SalesOrderVO

getSalesOrderNumber() - Method in class bb.common.SalesTaxListResult

getSalesOrderNumber() - Method in class bb.common.SGCustomerServiceRequestVO

getSalesOrderNumber() - Method in class bb.common.SGSaleItemAgent

getSalesOrderNumber() - Method in class bb.common.SGSaleItemVO

getSalesOrderNumber() - Method in class bb.common.ShipListItemPK

getSalesOrderNumber() - Method in class bb.common.ShipListItemVOResult

getSalesOrderNumber() - Method in class bb.common.ShipperInfoVO

getSalesOrderNumber() - Method in class bb.common.ShipperItemListResult

getSalesOrderNumber() - Method in class bb.common.ShipperListResult

getSalesOrderNumber() - Method in class bb.common.ShipperVO

getSalesOrderNumber() - Method in class bb.common.SoPickListResult

getSalesOrderNumber() - Method in class bb.common.SOShipperItemListResult

getSalesOrderOnDemandResult() - Method in class bb.common.BB2PartMrpResult

getSalesOrderOnTimeResult() - Method in interface bb.common.box.ManagementBox

getSalesOrderOrphanedResult() - Method in class bb.common.BB2PartMrpResult

getSalesOrderPrepay() - Method in class bb.common.AccountingSettingsVO

getSalesOrderPrivateNotes() - Method in class bb.common.SalesOrderVO

getSalesOrdersByPoNumberCount(String) - Method in interface bb.common.box.SalesBox

getSalesOrdersBySoNumberCount(String) - Method in interface bb.common.box.SalesBox

getSalesOrdersCountBySalesman(String) - Method in interface bb.common.box.SalesBox

getSalesOrderSet() - Method in class bb.common.ShipListAgent

getSalesOrderShipDateListResultsCountByDate(String, String, String, Date, Date) - Method in interface bb.common.box.WarehouseBox

getSalesOrderShippingResult(String) - Method in interface bb.common.box.WarehouseBox

getSalesOrderUnit() - Method in class bb.common.PartInventoryVO

getSalesOrderUnit() - Method in class bb.common.ToolInventoryVO

getSalesOrderWithOrderApplyByWo(Long) - Method in interface bb.common.box.SalesBox

getSalesPartListResult(BillPK, String) - Method in interface bb.common.box.SalesBox

getSalesPercent() - Method in class bb.common.ProfitLossStatementItemResult

getSalesPrice() - Method in class bb.common.CustomerReturnToVendorItemVO

getSalesPrice() - Method in class bb.common.RequestForRMAItemVO

getSalesPrice() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getSalesPrice() - Method in class bb.common.RunningAccountOrderItemVO

getSalesPrice() - Method in class bb.common.SalesOrderItemVO

getSalesQty() - Method in class bb.common.CustomerReturnToVendorItemVO

getSalesQty() - Method in class bb.common.RequestForRMAItemVO

getSalesQty() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getSalesQty() - Method in class bb.common.SalesOrderItemVO

getSalesRevenue() - Method in class bb.common.ProfitLossStatementResult

getSalesStdCost() - Method in class bb.common.CustomerReturnToVendorItemVO

getSalesStdCost() - Method in class bb.common.RequestForRMAItemVO

getSalesStdCost() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getSalesStdCost() - Method in class bb.common.RMAReceiverItemVO

getSalesTax() - Method in class bb.common.GeneralLedgerListResult

getSalesTax() - Method in class bb.common.GeneralLedgerResult

getSalesTax() - Method in class bb.common.GeneralLedgerVO

getSalesTaxAccount(BigDecimal) - Method in interface bb.common.box.CompanyBox

getSalesTaxByDateCount(String, Date, Date, String, boolean) - Method in interface bb.common.box.AccountingBox

getSalesTaxNumber() - Method in class bb.common.CustomerVendorAddressInfoVO

getSalesTaxNumber() - Method in class bb.common.CustomerVendorAddressVO

getSalesTaxRate() - Method in class bb.common.TaxAccountVO

getSalesTotal() - Method in class bb.common.SalesOrderOnTimeItemResult

getSalesUnit() - Method in class bb.common.CustomerReturnToVendorItemVO

getSalesUnit() - Method in class bb.common.RequestForRMAItemVO

getSalesUnit() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getSalesUnit() - Method in class bb.common.SalesOrderItemVO

getScannerPrefix() - Method in class bb.common.PointOfSaleVO

getScannerSuffix() - Method in class bb.common.PointOfSaleVO

getScrapQty() - Method in class bb.common.BillItemWithPartInfoResult

getScrapQty() - Method in class bb.common.IssuingItemResult

getScrapQty() - Method in class bb.common.ScrapReportVO

getScrapQty() - Method in class bb.common.WorkOrderItemIssueVO

getScrapQty() - Method in class bb.common.WorkOrderItemSetupItemAgent

getScrapRate() - Method in class bb.common.BillItemReplacementVO

getScrapRate() - Method in class bb.common.BillItemVO

getScrapRate() - Method in class bb.common.BillItemWithPartInfoResult

getScrapRate() - Method in class bb.common.WorkOrderItemSetupItemAgent

getScreenSize() - Method in class bb.common.BizboxBugInfoVO

getScreenSize() - Method in class bb.common.BizboxBugVO

getSealWorker() - Method in class bb.common.InspectionReportInfoVO

getSealWorker() - Method in class bb.common.InspectionReportVO

getSearchBuyer() - Method in class bb.common.TempReceiverWithoutAPInfo

getSearchCurrency() - Method in class bb.common.TempReceiverWithoutAPInfo

getSearchDateFrom() - Method in class bb.common.TempReceiverWithoutAPInfo

getSearchDateTo() - Method in class bb.common.TempReceiverWithoutAPInfo

getSearchId() - Method in class bb.common.TempReceiverWithoutAPInfo

getSecond(BigDecimal) - Static method in class bb.common.WorkOrderWorkInstructionSequenceVO

getSecurityLevel() - Method in class bb.common.EmployeeCardVO

getSecurityLevel() - Method in class bb.common.PartBasicInfo

getSecurityLevel() - Method in class bb.common.PartVO

getSecurityLevel() - Method in class bb.common.PartWithOnhandsVO

getSecurityLevel() - Method in class bb.common.SalesmanVO

getSellerId() - Method in class bb.common.PO2SOExchange

getSellerName() - Method in class bb.common.PO2SOExchange

getSendDate() - Method in class bb.common.MessageVO

getSendFrom() - Method in class bb.common.BB2BugNotice

getSendFrom() - Method in class bb.common.BB2Notice

getSendFrom() - Method in class bb.common.MessageVO

getSendFrom() - Method in class bb.common.SmtpServerVO

getSendTo() - Method in class bb.common.BB2BugNotice

getSendUsername() - Method in class bb.common.MessageVO

getSentTo() - Method in class bb.common.AccountsPayableItemVO

getSentTo() - Method in class bb.common.BB2Notice

getSentTo() - Method in class bb.common.OnloanReceiverItemVO

getSentTo() - Method in class bb.common.ReceiverItemVO

getSentTo() - Method in class bb.common.RMAReceiverItemVO

getSeq() - Method in class bb.common.CarrierPK

getSeqActualBeginDate() - Method in class bb.common.WCLoadDetailResult

getSeqActualFinishedDate() - Method in class bb.common.WCLoadDetailResult

getSeqEndDate() - Method in class bb.common.WCLoadDetailResult

getSeqNumber() - Method in class bb.common.JobProcessSheetItemResult

getSeqNumber() - Method in class bb.common.WCLoadDetailResult

getSeqNumber() - Method in class bb.common.WorkCenterRunTimeListResult

getSeqNumber() - Method in class bb.common.WorkInstructionSummaryItemResult

getSeqNumber() - Method in class bb.common.WorkOrderItemSeqWCLoadResult

getSeqPKs(String) - Method in class bb.common.POForWISeqAgent

getSeqPKs() - Method in class bb.common.POForWISeqAgent

getSeqRev() - Method in class bb.common.WorkInstructionSummaryItemResult

getSeqs() - Method in class bb.common.JobProcessSheetResult

getSeqStartDate() - Method in class bb.common.WCLoadDetailResult

getSequanceRev() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getSequence() - Method in class bb.common.DesignControlDocumentVO

getSequence() - Method in class bb.common.MiscDocAgent

getSequence() - Method in class bb.common.WorkOrderItemIssuedTotalResult

getSequenceNumber() - Method in class bb.common.WorkInstructionPictureVO

getSequenceNumber() - Method in class bb.common.WorkInstructionSequencePK

getSequenceRev() - Method in class bb.common.WorkInstructionSequenceVO

getSequences() - Method in class bb.common.WorkInstructionVO

getSequences() - Method in class bb.common.WorkOrderWorkInstructionListResult

getSequences() - Method in class bb.common.WorkOrderWorkInstructionVO

getSequenceStatus() - Method in class bb.common.WorkInstructionSequenceListResult

getSeqWC() - Method in class bb.common.WCLoadDetailResult

getSer() - Method in class bb.common.InventoryPartInOutDetailListResult

getSerial() - Method in class bb.common.AccountsPayableItemVO

getSerial() - Method in class bb.common.AccountsReceivableItemVO

getSerial() - Method in class bb.common.CSRAgent

getSerial() - Method in class bb.common.DisassembleWorkOrderIssueVO

getSerial() - Method in class bb.common.DisassembleWorkOrderItemPartDetailItemResult

getSerial() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

getSerial() - Method in class bb.common.EquipmentVO

getSerial() - Method in class bb.common.IssueItemAgent

getSerial() - Method in class bb.common.IssuingItemResult

getSerial() - Method in class bb.common.LogInventoryVO

getSerial() - Method in class bb.common.OnloanReceiverItemVO

getSerial() - Method in class bb.common.OperatingInstructionsVO

getSerial() - Method in class bb.common.PartIssuedVO

getSerial() - Method in class bb.common.PartReceivedVO

getSerial() - Method in class bb.common.PfReceiverItemVO

getSerial() - Method in class bb.common.ProformaInvoiceItemVO

getSerial() - Method in class bb.common.ReceiverItemAgent

getSerial() - Method in class bb.common.ReceiverItemVO

getSerial(String) - Method in class bb.common.ReceiverShipAgent

getSerial() - Method in class bb.common.RMAReceiverItemVO

getSerial() - Method in class bb.common.RtvShipperItemVO

getSerial() - Method in class bb.common.SGCustomerServiceRequestVO

getSerial() - Method in class bb.common.ShipperItemAgent

getSerial() - Method in class bb.common.WorkOrderItemIssueVO

getSerial() - Method in class bb.common.WorkOrderItemPartDetailItemResult

getSerial() - Method in class bb.common.WorkOrderReceiverVO

getSerialNo() - Method in class bb.common.PartInQAAgent

getSerialNo() - Method in class bb.common.PartInQAVO

getSerialNubmer() - Method in class bb.common.SerialNumberResult

getSerialNumber() - Method in class bb.common.AssetVO

getSerialNumber() - Method in class bb.common.CustomAssetVO

getSerialNumber() - Method in class bb.common.CustomerServiceIncidentVO

getSerialNumber() - Method in class bb.common.InventoryNotUsedInMonthsforAppResult

getSerialNumber() - Method in class bb.common.LnShipperItemListResult

getSerialNumber() - Method in class bb.common.OnloanShipperItemVO

getSerialNumber() - Method in class bb.common.PartOnhandCostVO

getSerialNumber() - Method in class bb.common.SerialNumberItemPK

getSerialNumber() - Method in class bb.common.SerialNumberItemResult

getSerialNumber() - Method in class bb.common.SerialNumberPK

getSerialNumber() - Method in class bb.common.SGSaleItemAgent

getSerialNumber() - Method in class bb.common.SGSaleItemVO

getSerialNumber() - Method in class bb.common.ShipperItemListResult

getSerialNumber() - Method in class bb.common.ShipperItemVO

getSerialNumber() - Method in class bb.common.ToolCalibrationVO

getSerialNumber() - Method in class bb.common.WorkOrderItemTimeDetailVO

getSerialNumberItemNumber() - Method in class bb.common.SerialNumberItemPK

getSerialNumberItems() - Method in class bb.common.SerialNumberVO

getSerialNumberResult(SerialNumberPK) - Method in interface bb.common.box.QualityBox

getSerialNumbersCountByPn(String, String) - Method in interface bb.common.box.QualityBox

getSerialNumbersCountBySerialNumber(String, String, String, String, String, String, String) - Method in interface bb.common.box.QualityBox

getSerialNumberType() - Method in class bb.common.OperatingInstructionsTypeVO

getSerials() - Method in class bb.common.ReceiverShipAgent

getSeriveType() - Method in class bb.common.CSRAgent

getServer() - Method in class bb.common.BizBoxServer

getServer() - Method in class bb.common.OperationLogVO

getServer() - Method in class bb.common.SubcompanyLoginAgent

getServerAccountNumber() - Method in class bb.common.AccountsChartMappingPK

getServerClientProperties(String) - Method in interface bb.common.box.CompanyBox

getServerIp() - Method in class bb.common.DocumentServerVO

getServerIp() - Method in class bb.common.DwfUploadSettingsVO

getServerIp() - Method in class bb.common.DwgUploadSettingsVO

getServerIp() - Method in class bb.common.MiscDocumentSettingVO

getServerLocation() - Method in class bb.common.SubcompanyVO

getServerPort() - Method in class bb.common.DocumentServerVO

getServerPort() - Method in class bb.common.DwfUploadSettingsVO

getServerPort() - Method in class bb.common.DwgUploadSettingsVO

getServerPort() - Method in class bb.common.MiscDocumentSettingVO

getServerTime() - Method in interface bb.common.Facade

getServerTime() - Method in class bb.common.Spiderman

getServerTimeZone() - Method in interface bb.common.Facade

getServerTimeZone() - Method in class bb.common.Spiderman

getServiceCharge() - Method in class bb.common.CustomerStatementResult

getServiceType() - Method in class bb.common.SGCustomerServiceRequestVO

getSessionId() - Method in class bb.common.SGLogLoginVO

getSessionId() - Method in class bb.common.SGQuoteLoginVO

getSet() - Method in class bb.common.WCLoadOnDateResult

getSetId() - Method in class bb.common.DisassembleWorkOrderItemListResult

getSetId() - Method in class bb.common.DisassembleWorkOrderItemVO

getSetId() - Method in class bb.common.JobProcessSheetListResult

getSetId() - Method in class bb.common.JobProcessSheetResult

getSetId() - Method in class bb.common.MiscDocAgent

getSetId() - Method in class bb.common.WorkInstructionDocumentVO

getSetId() - Method in class bb.common.WorkInstructionListResult

getSetId() - Method in class bb.common.WorkInstructionPictureVO

getSetId() - Method in class bb.common.WorkInstructionPK

getSetId() - Method in class bb.common.WorkInstructionRequestForChangeVO

getSetId() - Method in class bb.common.WorkInstructionSequenceListResult

getSetId() - Method in class bb.common.WorkInstructionSequencePK

getSetId() - Method in class bb.common.WorkInstructionSummaryResult

getSetId() - Method in class bb.common.WorkOrderItemListResult

getSetId() - Method in class bb.common.WorkOrderItemVO

getSetId() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getSetId() - Method in class bb.common.WorkOrderWorkInstructionVO

getSetup() - Method in class bb.common.WCLoadDetailResult

getSetupHrs() - Method in class bb.common.WorkCenterLoadListResult

getSetupQty() - Method in class bb.common.MasterWorkOrderTreeItemResult

getSetupQty() - Method in class bb.common.WorkOrderOverIssueListResult

getSeverity() - Method in class bb.common.BizboxBugInfoVO

getSeverity() - Method in class bb.common.BizboxBugVO

getSg() - Method in class bb.common.CompanyVO

getSgClientProgramUser(String) - Method in interface bb.common.box.AddressBox

getSgClientProgramUserCount(String, String) - Method in interface bb.common.box.AddressBox

getSGClientProgramUsersCount(String, String, Object[]) - Method in interface bb.common.box.AddressBox

getSGCustomerCatalog(SGCustomerCatalogPK) - Method in interface bb.common.box.SalesBox

getSGCustomerCatalogByPN(String, String) - Method in interface bb.common.box.SalesBox

getSGCustomerCatalogPK() - Method in class bb.common.SGPartCatalogResult

getSGCustomerCatalogVO() - Method in class bb.common.SGPartCatalogResult

getSGCustomerServiceRequest(String) - Method in interface bb.common.box.SalesBox

getSGCustomerServiceRequestsCountByDate(String, String, String, String, String, String, String, Date, Date) - Method in interface bb.common.box.SalesBox

getSGCustRequestForQuoteResult(String) - Method in interface bb.common.box.SalesBox

getSGPartCatalogConditionDescForCustomerID(String) - Method in interface bb.common.box.SalesBox

getSGPartCatalogCountByCustomerID(String) - Method in interface bb.common.box.SalesBox

getSGPartCatalogCountByCustomerIDAndMultiCondition(String, String) - Method in interface bb.common.box.SalesBox

getSGPartCatalogResults(String) - Method in interface bb.common.box.SalesBox

getSGPartCatalogResultsCount(String, String) - Method in interface bb.common.box.SalesBox

getSGPartCatalogResultsforCustomerID(String, String) - Method in interface bb.common.box.SalesBox

getSGPartCatalogResultsforCustomerID(String, int, int) - Method in interface bb.common.box.SalesBox

getSGPartCatalogResultsforCustomerIDByPartCount(String, String) - Method in interface bb.common.box.SalesBox

getSGPartCatalogResultsforCustomerIDCount(String, String) - Method in interface bb.common.box.SalesBox

getSGPartCatalogResultsNotforCustomerID(String, String) - Method in interface bb.common.box.SalesBox

getSGSaleItem(int) - Method in interface bb.common.box.SalesBox

getSGSaleItemsCount(String, String, String, String, String, String) - Method in interface bb.common.box.SalesBox

getSgSo() - Method in class bb.common.OnLoanVO

getSgUserName(SgClientProgramUserVO) - Static method in class bb.common.BB2Util

getShareholders() - Method in class bb.common.AccountingBalanceSheetResult

getShBplate() - Method in class bb.common.RtvShipperInfoVO

getShBplate() - Method in class bb.common.RtvShipperVO

getShip() - Method in class bb.common.CustomerReturnToVendorItemVO

getShip() - Method in class bb.common.RequestForRMAItemVO

getShip() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getShip() - Method in class bb.common.ReturnToVendorByDateListResult

getShip() - Method in class bb.common.ReturnToVendorItemVO

getShipAccount() - Method in class bb.common.RequestForQuoteVO

getShipAccount() - Method in class bb.common.ReturnToVendorVO

getShipAccout() - Method in class bb.common.SalesOrderVO

getShipAccout() - Method in class bb.common.TransferOrderListResult

getShipAccout() - Method in class bb.common.TransferOrderVO

getShipAccout() - Method in class bb.common.TransferShipperListResult

getShipAccout() - Method in class bb.common.TransferShipperVO

getShipAcct() - Method in class bb.common.OnLoanVO

getShipDate() - Method in class bb.common.AddProformaReceiverItemAgent

getShipDate() - Method in class bb.common.BB2PartInSTOItemResult

getShipDate() - Method in class bb.common.BB2PartOnLoanItemResult

getShipDate() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getShipDate() - Method in class bb.common.PfReceiverVO

getShipDate() - Method in class bb.common.PO2POAgent

getShipDate() - Method in class bb.common.PO2SOExchangeItem

getShipDate() - Method in class bb.common.ShippingItemResult

getShipDate() - Method in class bb.common.SO2SOAgent

getShipDate() - Method in class bb.common.WorkOrderWorkInstructionListResult

getShipFromAddressInfo() - Method in class bb.common.ProformaInvoiceVO

getShipFromId() - Method in class bb.common.ProformaInvoiceVO

getShipId() - Method in class bb.common.DisassembleWorkOrderReceivingResult

getShipId() - Method in class bb.common.IssuingResult

getShipInProcessQty() - Method in class bb.common.BB2PartInventoryResult

getShipInProcessQty() - Method in class bb.common.HistoricalInventoryVO

getShipInProcessQty() - Method in class bb.common.PartInventoryVO

getShipInProcessQty() - Method in class bb.common.PartOnHandWithPartBasicInfoResult

getShipInProcessQty() - Method in class bb.common.PhysicalInventoryVO

getShipInProcessQty() - Method in class bb.common.ToolInventoryVO

getShipInTransactionQty() - Method in class bb.common.BB2PartInventoryResult

getShipInTransactionQty() - Method in class bb.common.HistoricalInventoryVO

getShipInTransactionQty() - Method in class bb.common.PartInventoryVO

getShipInTransactionQty() - Method in class bb.common.PartOnHandWithPartBasicInfoResult

getShipInTransactionQty() - Method in class bb.common.ToolInventoryVO

getShipList() - Method in class bb.common.ShipListInfoVO

getShipList() - Method in class bb.common.ShipListVO

getShipListByShipListNumber(String) - Method in interface bb.common.box.PlanningBox

getShipListItemRelatedDocResult(SalesOrderItemPK) - Method in interface bb.common.box.PlanningBox

getShipListItems(String) - Method in interface bb.common.box.PlanningBox

getShipListItems() - Method in class bb.common.ShipListVO

getShipListItemVO() - Method in class bb.common.ShipListItemVOResult

getShipListNumber() - Method in class bb.common.ShipListItemPK

getShipListOwner() - Method in class bb.common.ShipListOwnerAttributeVO

getShipListOwnerAttributes() - Method in class bb.common.ShipListOwnerVO

getShipListOwnerByName(String) - Method in interface bb.common.box.PlanningBox

getShipListOwnersCountByName(String) - Method in interface bb.common.box.PlanningBox

getShipListsCountById(String) - Method in interface bb.common.box.PlanningBox

getShipListsCountByOwer(String) - Method in interface bb.common.box.PlanningBox

getShipped() - Method in class bb.common.AccountsReceivableInfoVO

getShipped() - Method in class bb.common.AccountsReceivableVO

getShipped() - Method in class bb.common.ProformaInvoiceVO

getShipped() - Method in class bb.common.ReturnToVendorItemListResult

getShippedBy() - Method in class bb.common.AccountsReceivableInfoVO

getShippedBy() - Method in class bb.common.AccountsReceivableVO

getShippedBy() - Method in class bb.common.OnloanShipperVO

getShippedBy() - Method in class bb.common.ProformaInvoiceVO

getShippedBy() - Method in class bb.common.RtvShipperInfoVO

getShippedBy() - Method in class bb.common.RtvShipperListResult

getShippedBy() - Method in class bb.common.RtvShipperVO

getShippedBy() - Method in class bb.common.ShipperInfoVO

getShippedBy() - Method in class bb.common.ShipperVO

getShippedBy() - Method in class bb.common.StockTransactionSOShipperResult

getShippedBy() - Method in class bb.common.SwapShipperListResult

getShippedBy() - Method in class bb.common.SwapShipperVO

getShippedBy() - Method in class bb.common.TransferShipperListResult

getShippedBy() - Method in class bb.common.TransferShipperVO

getShippedDate() - Method in class bb.common.OnloanShipperVO

getShippedDate() - Method in class bb.common.RtvShipperInfoVO

getShippedDate() - Method in class bb.common.RtvShipperListResult

getShippedDate() - Method in class bb.common.RtvShipperVO

getShippedDate() - Method in class bb.common.SalesOrderShipDateListResult

getShippedDate() - Method in class bb.common.ShipperInfoVO

getShippedDate() - Method in class bb.common.ShipperVO

getShippedDate() - Method in class bb.common.StockTransactionSOShipperResult

getShippedDate() - Method in class bb.common.SwapShipperItemListResult

getShippedDate() - Method in class bb.common.SwapShipperItemVO

getShippedDate() - Method in class bb.common.SwapShipperListResult

getShippedDate() - Method in class bb.common.SwapShipperOnOrderResult

getShippedDate() - Method in class bb.common.SwapShipperVO

getShippedDate() - Method in class bb.common.TransferShipperItemListResult

getShippedDate() - Method in class bb.common.TransferShipperItemVO

getShippedDate() - Method in class bb.common.TransferShipperListResult

getShippedDate() - Method in class bb.common.TransferShipperVO

getShippedItemCount() - Method in class bb.common.SalesOrderOnTimeItemResult

getShippedMarginPct() - Method in class bb.common.SalesOrderOnTimeItemResult

getShippedQty() - Method in class bb.common.OnLoanItemListResult

getShippedQty() - Method in class bb.common.PartInventoryVO

getShippedQty() - Method in class bb.common.SalesOrderItemGroupByPartListResult

getShippedQty() - Method in class bb.common.SalesOrderItemListResult

getShippedQty() - Method in class bb.common.ShipperItemDetailAgent

getShippedQty() - Method in class bb.common.StockTransactionSOShipperResult

getShippedQty() - Method in class bb.common.SwapOrderItemListResult

getShippedQty() - Method in class bb.common.SwapOrderItemVO

getShippedQty() - Method in class bb.common.SwapReceiverItemListResult

getShippedQty() - Method in class bb.common.SwapReceiverItemVO

getShippedQty() - Method in class bb.common.SwapShipperItemListResult

getShippedQty() - Method in class bb.common.SwapShipperItemVO

getShippedQty() - Method in class bb.common.SwapShipperOnOrderResult

getShippedQty() - Method in class bb.common.ToolInventoryVO

getShippedQty() - Method in class bb.common.TransferOrderItemListResult

getShippedQty() - Method in class bb.common.TransferOrderItemVO

getShippedQty() - Method in class bb.common.TransferReceiverItemListResult

getShippedQty() - Method in class bb.common.TransferReceiverItemVO

getShippedQty() - Method in class bb.common.TransferShipperItemListResult

getShippedQty() - Method in class bb.common.TransferShipperItemVO

getShippedQuantity() - Method in class bb.common.OnLoanItemVO

getShippedTotalOnTime() - Method in class bb.common.SalesOrderOnTimeItemResult

getShippedVia() - Method in class bb.common.AccountsPayableInfoVO

getShippedVia() - Method in class bb.common.AccountsPayableVO

getShippedVia() - Method in class bb.common.OnloanReceiverVO

getShippedVia() - Method in class bb.common.PfReceiverVO

getShippedVia() - Method in class bb.common.ReceiverInfoVO

getShippedVia() - Method in class bb.common.ReceiverVO

getShippedVia() - Method in class bb.common.RMAReceiverVO

getShipperBp() - Method in class bb.common.OnloanShipperVO

getShipperBp() - Method in class bb.common.ShipperVO

getShipperById(String) - Method in interface bb.common.box.WarehouseBox

getShipperComments() - Method in class bb.common.OnloanShipperVO

getShipperComments() - Method in class bb.common.ShipperInfoVO

getShipperComments() - Method in class bb.common.ShipperVO

getShipperComments() - Method in class bb.common.TransferShipperListResult

getShipperComments() - Method in class bb.common.TransferShipperVO

getShipperDate() - Method in class bb.common.ShipperListResult

getShipperDigits() - Method in class bb.common.CompanyVO

getShipperItemByPK(ShipperItemPK) - Method in interface bb.common.box.WarehouseBox

getShipperItemComments() - Method in class bb.common.OnloanShipperItemVO

getShipperItemComments() - Method in class bb.common.ShipperItemVO

getShipperItemDetails() - Method in class bb.common.ShipperItemAgent

getShipperItemListResultsCount(Date, Date, String, String, String, String, String, String, String, String, String, String[]) - Method in interface bb.common.box.WarehouseBox

getShipperItemListResultsCountByCustomerId(String) - Method in interface bb.common.box.WarehouseBox

getShipperItemListResultsCountByPartNumber(String, String) - Method in interface bb.common.box.WarehouseBox

getShipperItemListResultsCountBySalesOrderNumber(String) - Method in interface bb.common.box.WarehouseBox

getShipperItemListResultsCountBySerialNumber(String, String, String, String, String, String, String, String[]) - Method in interface bb.common.box.WarehouseBox

getShipperItemListResultsCountByShipperNumber(String) - Method in interface bb.common.box.WarehouseBox

getShipperItemManufacturer() - Method in class bb.common.OnloanShipperItemVO

getShipperItemManufacturer() - Method in class bb.common.ShipperItemVO

getShipperItemNumber() - Method in class bb.common.AccountsReceivableItemVO

getShipperItemNumber() - Method in class bb.common.ShipperItemListResult

getShipperItemNumber() - Method in class bb.common.ShipperItemPK

getShipperItemPk() - Method in class bb.common.SOShipperItemListResult

getShipperItemPks() - Method in class bb.common.MakeInvoiceAgent

getShipperItemPrivateNotes() - Method in class bb.common.OnloanShipperItemVO

getShipperItemPrivateNotes() - Method in class bb.common.ShipperItemVO

getShipperItems() - Method in class bb.common.ShipperVO

getShipperListResultsCountByCustomerId(String) - Method in interface bb.common.box.WarehouseBox

getShipperListResultsCountBySalesman(String) - Method in interface bb.common.box.WarehouseBox

getShipperListResultsCountBySalesOrderNumber(String) - Method in interface bb.common.box.WarehouseBox

getShipperListResultsCountByShipperNumber(String) - Method in interface bb.common.box.WarehouseBox

getShipperNumber() - Method in class bb.common.AccountsReceivableInfoVO

getShipperNumber() - Method in class bb.common.AccountsReceivableItemVO

getShipperNumber() - Method in class bb.common.AccountsReceivableVO

getShipperNumber() - Method in class bb.common.GeneralLedgerListResult

getShipperNumber() - Method in class bb.common.GeneralLedgerResult

getShipperNumber() - Method in class bb.common.GeneralLedgerVO

getShipperNumber() - Method in class bb.common.InvoiceItemListResult

getShipperNumber() - Method in class bb.common.MakeBillAndHoldInvoiceAgent

getShipperNumber() - Method in class bb.common.MakeInvoiceAgent

getShipperNumber() - Method in class bb.common.ProformaInvoiceItemVO

getShipperNumber() - Method in class bb.common.ReceivedToOrderItem

getShipperNumber() - Method in class bb.common.ReceiverItemDetailAgent

getShipperNumber(String) - Method in class bb.common.ReceiverShipAgent

getShipperNumber() - Method in class bb.common.SalesOrderShipDateListResult

getShipperNumber() - Method in class bb.common.ShipperInfoVO

getShipperNumber() - Method in class bb.common.ShipperItemAgent

getShipperNumber() - Method in class bb.common.ShipperItemListResult

getShipperNumber() - Method in class bb.common.ShipperItemManufacturerPK

getShipperNumber() - Method in class bb.common.ShipperItemPK

getShipperNumber() - Method in class bb.common.ShipperListResult

getShipperNumber() - Method in class bb.common.ShipperVO

getShipperNumber() - Method in class bb.common.StockTransactionSOShipperResult

getShipperNumbers() - Method in class bb.common.ReceiverShipAgent

getShipperPrefix() - Method in class bb.common.CompanyVO

getShipperPrivateNotes() - Method in class bb.common.OnloanShipperVO

getShipperPrivateNotes() - Method in class bb.common.ShipperInfoVO

getShipperPrivateNotes() - Method in class bb.common.ShipperVO

getShipperPrivateNotes() - Method in class bb.common.TransferShipperListResult

getShipperPrivateNotes() - Method in class bb.common.TransferShipperVO

getShippersCountByShipperNumber(String) - Method in interface bb.common.box.WarehouseBox

getShippersCountBySo(String) - Method in interface bb.common.box.WarehouseBox

getShipperWithOutInvoiceCount(String, String, String, String, Date, Date) - Method in interface bb.common.box.AccountingBox

getShippingAccount() - Method in class bb.common.DisassembleWorkOrderVO

getShippingAccount() - Method in class bb.common.WorkOrderVO

getShippingDepth() - Method in class bb.common.PartVO

getShippingDepth() - Method in class bb.common.PartWithOnhandsVO

getShippingDepth() - Method in class bb.common.ToolVO

getShippingDepth() - Method in class bb.common.ToolWithOnhandsVO

getShippingItemResult(SalesOrderItemPK) - Method in interface bb.common.box.WarehouseBox

getShippingItems() - Method in class bb.common.ShippingResult

getShippingLength() - Method in class bb.common.PartVO

getShippingLength() - Method in class bb.common.PartWithOnhandsVO

getShippingLength() - Method in class bb.common.ToolVO

getShippingLength() - Method in class bb.common.ToolWithOnhandsVO

getShippingMark() - Method in class bb.common.PfReceiverVO

getShippingMark() - Method in class bb.common.ProformaInvoiceVO

getShippingStatus() - Method in class bb.common.PackingBoxSalesOrderItemResult

getShippingStatus() - Method in class bb.common.PurchaseOrderItemVO

getShippingStatus() - Method in class bb.common.PurchaseOrderOpenDueListResult

getShippingStatus() - Method in class bb.common.PurchaseOrderVO

getShippingStatus() - Method in class bb.common.SalesOrderItemInfoVO

getShippingStatus() - Method in class bb.common.SalesOrderItemVO

getShippingStatus() - Method in class bb.common.SalesOrderVO

getShippingWeight() - Method in class bb.common.InventoryMonthReport

getShippingWeight() - Method in class bb.common.PartExportInfo

getShippingWeight() - Method in class bb.common.PartOnhandResult

getShippingWeight() - Method in class bb.common.PartVO

getShippingWeight() - Method in class bb.common.PartWithOnhandsVO

getShippingWeight() - Method in class bb.common.ShipListItemVOResult

getShippingWeight() - Method in class bb.common.ToolVO

getShippingWeight() - Method in class bb.common.ToolWithOnhandsVO

getShippingWeightUnit() - Method in class bb.common.CompanyVO

getShippingWeightUnit() - Method in class bb.common.InventoryMonthReport

getShippingWeightUnit() - Method in class bb.common.PartExportInfo

getShippingWeightUnit() - Method in class bb.common.PartOnhandResult

getShippingWeightUnit() - Method in class bb.common.PartVO

getShippingWeightUnit() - Method in class bb.common.PartWithOnhandsVO

getShippingWeightUnit() - Method in class bb.common.ToolVO

getShippingWeightUnit() - Method in class bb.common.ToolWithOnhandsVO

getShippingWidth() - Method in class bb.common.PartVO

getShippingWidth() - Method in class bb.common.PartWithOnhandsVO

getShippingWidth() - Method in class bb.common.ToolVO

getShippingWidth() - Method in class bb.common.ToolWithOnhandsVO

getShipQty() - Method in class bb.common.PackingBoxSalesOrderItemResult

getShipQuantity() - Method in class bb.common.RequestForQuoteItemVO

getShipTo() - Method in class bb.common.AccountsReceivableInfoVO

getShipTo() - Method in class bb.common.AccountsReceivableItemVO

getShipTo() - Method in class bb.common.AccountsReceivableVO

getShipTo() - Method in class bb.common.CustomerVendorAddressInfoVO

getShipTo() - Method in class bb.common.CustomerVendorAddressVO

getShipTo() - Method in class bb.common.PackingBoxItemVO

getShipTo() - Method in class bb.common.ProformaInvoiceItemVO

getShipTo() - Method in class bb.common.ProformaInvoiceVO

getShipto() - Method in class bb.common.PurchaseOrderItemListResult

getShipTo() - Method in class bb.common.ReturnToVendorByDateListResult

getShipTo() - Method in class bb.common.ReturnToVendorVO

getShipto() - Method in class bb.common.RtvShipperItemVO

getShipTo() - Method in class bb.common.RunningAccountOrderItemResult

getShipTo() - Method in class bb.common.RunningAccountOrderVO

getShipTo() - Method in class bb.common.ShipListItemVOResult

getShipToAddressInfo() - Method in class bb.common.AccountsReceivableVO

getShipToAddressInfo() - Method in class bb.common.ArPrepayVO

getShipToAddressInfo() - Method in class bb.common.CustomerReturnToVendorVO

getShipToAddressInfo() - Method in class bb.common.DisassembleWorkOrderVO

getShipToAddressInfo() - Method in class bb.common.OnloanShipperVO

getShipToAddressInfo() - Method in class bb.common.OnLoanVO

getShipToAddressInfo() - Method in class bb.common.ProformaInvoiceVO

getShipToAddressInfo() - Method in class bb.common.PurchaseOrderVO

getShipToAddressInfo() - Method in class bb.common.QuoteVO

getShipToAddressInfo() - Method in class bb.common.RequestForQuoteVO

getShipToAddressInfo() - Method in class bb.common.RequestForRMAVO

getShipToAddressInfo() - Method in class bb.common.ReturnMaterialAuthorizationVO

getShipToAddressInfo() - Method in class bb.common.ReturnToVendorVO

getShipToAddressInfo() - Method in class bb.common.RtvShipperInfoVO

getShipToAddressInfo() - Method in class bb.common.RtvShipperVO

getShipToAddressInfo() - Method in class bb.common.SalesOrderVO

getShipToAddressInfo() - Method in class bb.common.ShipperInfoVO

getShipToAddressInfo() - Method in class bb.common.ShipperVO

getShipToAddressInfo() - Method in class bb.common.WorkOrderVO

getShipToCountry() - Method in class bb.common.InvoiceItemListResult

getShipToId() - Method in class bb.common.ArPrepayVO

getShipToId() - Method in class bb.common.BB2PartInSitItemResult

getShipToId() - Method in class bb.common.CompanyVO

getShipToId() - Method in class bb.common.CustomerFeedbackVO

getShipToId() - Method in class bb.common.CustomerReturnToVendorVO

getShipToId() - Method in class bb.common.DisassembleWorkOrderVO

getShipToId() - Method in class bb.common.InvoiceItemListResult

getShipToId() - Method in class bb.common.MakeBillAndHoldInvoiceAgent

getShipToId() - Method in class bb.common.MakeInvoiceAgent

getShipToId() - Method in class bb.common.OnloanShipperItemVO

getShipToId() - Method in class bb.common.OnloanShipperVO

getShiptoId() - Method in class bb.common.OnLoanVO

getShiptoId() - Method in class bb.common.PO2SOExchange

getShipToId() - Method in class bb.common.ProformaInvoiceListResult

getShipToId() - Method in class bb.common.PurchaseOrderOnOrderResult

getShipToId() - Method in class bb.common.PurchaseOrderVO

getShipToId() - Method in class bb.common.Quote2QuoteAgent

getShipToId() - Method in class bb.common.QuoteVO

getShipToId() - Method in class bb.common.RequestForQuoteVO

getShipToId() - Method in class bb.common.RequestForRMAVO

getShipToId() - Method in class bb.common.ReturnMaterialAuthorizationVO

getShipToId() - Method in class bb.common.RMAReceiverResult

getShipToId() - Method in class bb.common.RMAReceiverVO

getShipToId() - Method in class bb.common.RtvShipperInfoVO

getShipToId() - Method in class bb.common.RtvShipperListResult

getShipToId() - Method in class bb.common.RtvShipperVO

getShipToId() - Method in class bb.common.SalesOrderVO

getShipToId() - Method in class bb.common.ShipperInfoVO

getShipToId() - Method in class bb.common.ShipperItemVO

getShipToId() - Method in class bb.common.ShipperVO

getShipToId() - Method in class bb.common.SO2SOAgent

getShipToId() - Method in class bb.common.WorkOrderOnOrderResult

getShipToId() - Method in class bb.common.WorkOrderVO

getShipToID() - Method in class bb.common.ZipcodeTotalsResult

getShipToInfo() - Method in class bb.common.RMAReceiverVO

getShiptoName() - Method in class bb.common.PO2SOExchange

getShipToName() - Method in class bb.common.ZipcodeTotalsResult

getShipToState() - Method in class bb.common.InvoiceItemListResult

getShipTotal() - Method in class bb.common.AccountingTotalMoneyResult

getShipTotal() - Method in class bb.common.DuePATotalByVendorResult

getShipVia() - Method in class bb.common.AccountsReceivableInfoVO

getShipVia() - Method in class bb.common.AccountsReceivableItemVO

getShipVia() - Method in class bb.common.AccountsReceivableVO

getShipvia() - Method in class bb.common.CustomerReturnToVendorItemVO

getShipVia() - Method in class bb.common.CustomerReturnToVendorVO

getShipVia() - Method in class bb.common.DisassembleWorkOrderItemVO

getShipvia() - Method in class bb.common.DisassembleWorkOrderReceivingResult

getShipVia() - Method in class bb.common.DisassembleWorkOrderVO

getShipvia() - Method in class bb.common.IssuingResult

getShipVia() - Method in class bb.common.MakeBillAndHoldInvoiceAgent

getShipVia() - Method in class bb.common.MakeInvoiceAgent

getShipVia() - Method in class bb.common.NonproductivePickingOnDemandResult

getShipVia() - Method in class bb.common.OnLoanItemListResult

getShipVia() - Method in class bb.common.OnLoanItemVO

getShipVia() - Method in class bb.common.OnloanShipperItemVO

getShipVia() - Method in class bb.common.OnloanShipperVO

getShipVia() - Method in class bb.common.OnLoanVO

getShipVia() - Method in class bb.common.OrderApprovalItemsVO

getShipVia() - Method in class bb.common.PackingBoxItemVO

getShipVia() - Method in class bb.common.PfReceiverItemVO

getShipVia() - Method in class bb.common.PO2SOExchangeItem

getShipVia() - Method in class bb.common.PoMessageItemVO

getShipVia() - Method in class bb.common.ProformaInvoiceItemVO

getShipVia() - Method in class bb.common.ProformaInvoiceVO

getShipVia() - Method in class bb.common.PrPackingBoxItemVO

getShipVia() - Method in class bb.common.PurchaseOrderItemVO

getShipVia() - Method in class bb.common.PurchaseOrderOpenDueListResult

getShipVia() - Method in class bb.common.PurchaseOrderVO

getShipVia() - Method in class bb.common.QuoteItemListResult

getShipVia() - Method in class bb.common.QuoteItemVO

getShipVia() - Method in class bb.common.QuoteVO

getShipVia() - Method in class bb.common.RequestForQuoteItemVO

getShipVia() - Method in class bb.common.RequestForQuoteVO

getShipvia() - Method in class bb.common.RequestForRMAItemVO

getShipVia() - Method in class bb.common.RequestForRMAVO

getShipvia() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getShipVia() - Method in class bb.common.ReturnMaterialAuthorizationVO

getShipVia() - Method in class bb.common.ReturnToVendorItemVO

getShipVia() - Method in class bb.common.ReturnToVendorVO

getShipVia() - Method in class bb.common.RfqMessageItemVO

getShipVia() - Method in class bb.common.RtvShipperInfoVO

getShipvia() - Method in class bb.common.RtvShipperItemListResult

getShipvia() - Method in class bb.common.RtvShipperItemVO

getShipVia() - Method in class bb.common.RtvShipperListResult

getShipVia() - Method in class bb.common.RtvShipperVO

getShipVia() - Method in class bb.common.SalesOrderItemInfoVO

getShipVia() - Method in class bb.common.SalesOrderItemListResult

getShipVia() - Method in class bb.common.SalesOrderItemVO

getShipVia() - Method in class bb.common.SalesOrderOnDemandResult

getShipVia() - Method in class bb.common.SalesOrderVO

getShipVia() - Method in class bb.common.ShipListItemVOResult

getShipVia() - Method in class bb.common.ShipperAgent

getShipVia() - Method in class bb.common.ShipperInfoVO

getShipVia() - Method in class bb.common.ShipperItemVO

getShipVia() - Method in class bb.common.ShipperVO

getShipVia() - Method in class bb.common.SO2POAgent

getShipVia() - Method in class bb.common.SwapOrderListResult

getShipVia() - Method in class bb.common.SwapOrderVO

getShipVia() - Method in class bb.common.SwapReceiverListResult

getShipVia() - Method in class bb.common.SwapReceiverVO

getShipVia() - Method in class bb.common.SwapShipperListResult

getShipVia() - Method in class bb.common.SwapShipperVO

getShipVia() - Method in class bb.common.TransferOrderListResult

getShipVia() - Method in class bb.common.TransferOrderVO

getShipVia() - Method in class bb.common.TransferReceiverItemListResult

getShipVia() - Method in class bb.common.TransferReceiverItemVO

getShipVia() - Method in class bb.common.TransferReceiverListResult

getShipVia() - Method in class bb.common.TransferReceiverVO

getShipVia() - Method in class bb.common.TransferShipperItemListResult

getShipVia() - Method in class bb.common.TransferShipperItemVO

getShipVia() - Method in class bb.common.TransferShipperListResult

getShipVia() - Method in class bb.common.TransferShipperVO

getShipVia() - Method in class bb.common.WorkOrderItemVO

getShipVia() - Method in class bb.common.WorkOrderVO

getShortage() - Method in class bb.common.InventoryListResult

getShortageAmount() - Method in class bb.common.InventoryMonthReport

getShortageAmount() - Method in class bb.common.InventoryPartInOutDetailListResult

getShortageCost() - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

getShortageCost() - Method in class bb.common.WorkOrderItemPartDetailResult

getShortageQty() - Method in class bb.common.InventoryMonthReport

getShortageQty() - Method in class bb.common.InventoryPartInOutDetailListResult

getShortageQty() - Method in class bb.common.PhysicalInventoryListWithAppDataResult

getShortAgeQty() - Method in class bb.common.SalesOrderItemListResult

getShortageStdCost() - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

getShortageStdCost() - Method in class bb.common.WorkOrderItemPartDetailResult

getShortageTotal() - Method in class bb.common.PhysicalInventoryListWithAppDataResult

getShortcut() - Method in class bb.common.OpCodeShortcutVO

getShortDescription() - Method in class bb.common.WorkInstructionSummaryItemResult

getShortItemPk() - Method in class bb.common.MrpItemResult

getShortQty() - Method in class bb.common.MrpByMonthResult

getShortQty() - Method in class bb.common.OrderVendorItem

getShortQty() - Method in class bb.common.PackingBoxSalesOrderItemResult

getShortQty() - Method in class bb.common.WorkOrderItemCanAssyResult

getShortQuantity() - Method in class bb.common.ReceivedToOrderItem

getShowFax() - Method in class bb.common.EmployeeCardVO

getShowHomePhone() - Method in class bb.common.EmployeeCardVO

getShowMobile() - Method in class bb.common.EmployeeCardVO

getSignature() - Method in class bb.common.AccountsReceivableVO

getSignature() - Method in class bb.common.CheckInvoiceItemListResult

getSip() - Method in class bb.common.PartOnHandAuditResult

getSipQty() - Method in class bb.common.PackingBoxSalesOrderItemResult

getSipQty() - Method in class bb.common.PurchaseOrderItemListResult

getSipQty() - Method in class bb.common.QuoteItemListResult

getSipQty() - Method in class bb.common.SalesOrderItemInfoVO

getSipQty() - Method in class bb.common.SalesOrderItemListResult

getSipQty() - Method in class bb.common.SalesOrderItemVO

getSitQty() - Method in class bb.common.PurchaseOrderItemListResult

getSitQty() - Method in class bb.common.PurchaseOrderItemVO

getSitQty() - Method in class bb.common.PurchaseOrderOnOrderResult

getSitQty() - Method in class bb.common.SalesOrderItemListResult

getSize() - Method in class bb.common.TaskFileResult

getSmallCatagory() - Method in class bb.common.PartCatagoryPK

getSmtpServer() - Method in interface bb.common.box.CompanyBox

getSn() - Method in class bb.common.ARPaymentRunItemVO

getSoBoilerplate() - Method in class bb.common.SalesOrderBoilerplateVO

getSoComments() - Method in class bb.common.ShipListItemVOResult

getSoCount() - Method in class bb.common.SalesInfoCenter

getSoCountPerMonth(int) - Method in interface bb.common.box.SalesBox

getSoCountWithPartsOnhold() - Method in class bb.common.SalesInfoCenter

getSoCreditAccount() - Method in class bb.common.AccountingSettingsVO

getSoDate() - Method in class bb.common.SalesOrderCheckListResult

getSoDate() - Method in class bb.common.SalesOrderItemListResult

getSoDate() - Method in class bb.common.SalesOrderListResult

getSoDetails() - Method in class bb.common.BB2PartTotalOndemandDetailResult

getSoDetails() - Method in class bb.common.PartInMrpListResult

getSoDigits() - Method in class bb.common.CompanyVO

getSoDueItems12MonthAvg() - Method in class bb.common.SalesOrderOnTimeResult

getSoDueItemsFysical() - Method in class bb.common.SalesOrderOnTimeResult

getSoDueItemsLastMonth() - Method in class bb.common.SalesOrderOnTimeResult

getSoDueItemsThisMonth() - Method in class bb.common.SalesOrderOnTimeResult

getSoDueItemsYtd() - Method in class bb.common.SalesOrderOnTimeResult

getSoDueTotal12MonthAvg() - Method in class bb.common.SalesOrderOnTimeResult

getSoDueTotalFysical() - Method in class bb.common.SalesOrderOnTimeResult

getSoDueTotalLastMonth() - Method in class bb.common.SalesOrderOnTimeResult

getSoDueTotalThisMonth() - Method in class bb.common.SalesOrderOnTimeResult

getSoDueTotalYtd() - Method in class bb.common.SalesOrderOnTimeResult

getSoItemCount() - Method in class bb.common.SalesInfoCenter

getSoItemNumber() - Method in class bb.common.SalesOrderItemListResult

getSoItemPk() - Method in class bb.common.PackingBoxSalesOrderItemAgent

getSold() - Method in class bb.common.InventoryListResult

getSoNotReviewedOnDemandList() - Method in class bb.common.MrpItemResult

getSoNumber() - Method in class bb.common.ARPaymentRunItemVO

getSoNumber() - Method in class bb.common.ARPaymentRunListResult

getSoNumber() - Method in class bb.common.ArPrepayItemVO

getSoNumber() - Method in class bb.common.GeneralLedgerByDateListResult

getSoNumber() - Method in class bb.common.MiscDocAgent

getSoNumber() - Method in class bb.common.NcrReportListResult

getSoNumber() - Method in class bb.common.PostCheckAgent

getSoNumber() - Method in class bb.common.RMAReceiverItemListResult

getSoNumber() - Method in class bb.common.SalesOrderCheckListResult

getSoNumber() - Method in class bb.common.SalesOrderDocumentVO

getSoNumber() - Method in class bb.common.SalesOrderItemListResult

getSoNumber() - Method in class bb.common.SalesOrderListResult

getSoNumber() - Method in class bb.common.SerialNumberResult

getSoNumber() - Method in class bb.common.SO2POAgent

getSoNumber() - Method in class bb.common.SO2SOAgent

getSoNumber() - Method in class bb.common.SO2WOAgent

getSoNumber() - Method in class bb.common.StockTransactionSOShipperResult

getSoOnDemandList() - Method in class bb.common.MrpItemOrderDemandRecordsResult

getSoOnDemandList() - Method in class bb.common.MrpItemResult

getSoPastDue() - Method in class bb.common.CashFlowByMonthReportResult

getSoPickListResult(String) - Method in interface bb.common.box.WarehouseBox

getSoPrefix() - Method in class bb.common.CompanyVO

getSoQuantity() - Method in class bb.common.ShipperItemVO

getSoQuantity() - Method in class bb.common.SOShipperItemListResult

getSoShippedItemOntime12MonthAvg() - Method in class bb.common.SalesOrderOnTimeResult

getSoShippedItemOntimeFysical() - Method in class bb.common.SalesOrderOnTimeResult

getSoShippedItemOntimeLastMonth() - Method in class bb.common.SalesOrderOnTimeResult

getSoShippedItemOntimeThisMonth() - Method in class bb.common.SalesOrderOnTimeResult

getSoShippedItemOntimeYtd() - Method in class bb.common.SalesOrderOnTimeResult

getSoShippedTotalOntime12MonthAvg() - Method in class bb.common.SalesOrderOnTimeResult

getSoShippedTotalOntimeFysical() - Method in class bb.common.SalesOrderOnTimeResult

getSoShippedTotalOntimeLastMonth() - Method in class bb.common.SalesOrderOnTimeResult

getSoShippedTotalOntimeThisMonth() - Method in class bb.common.SalesOrderOnTimeResult

getSoShippedTotalOntimeYtd() - Method in class bb.common.SalesOrderOnTimeResult

getSOShipperItemListResultsOfSalesOrder(String) - Method in interface bb.common.box.SalesBox

getSoSip() - Method in class bb.common.PartOnHandAuditResult

getSoSipQty() - Method in class bb.common.SalesOrderItemListResult

getSoTotal() - Method in class bb.common.ArPrepayVO

getSOTotalByARPNumber(String) - Method in interface bb.common.box.AccountingBox

getSoTotalSum() - Method in class bb.common.SalesInfoCenter

getSource() - Method in class bb.common.BB2Event

getSource() - Method in class bb.common.CustomEmployeeVO

getSource() - Method in class bb.common.EmployeeCardVO

getSoVAT() - Method in class bb.common.AccountingSettingsVO

getSoWithPartOnHoldCount() - Method in class bb.common.WareHousingInfoCenterResult

getSpaceHomePage() - Method in class bb.common.HelpServerVO

getSparePart() - Method in class bb.common.BillItemSalesCostResult

getSparePart() - Method in class bb.common.BillItemSalesResult

getSparePart() - Method in class bb.common.BillItemSalesXResult

getSparePart() - Method in class bb.common.BillItemUsagePathResult

getSparePart() - Method in class bb.common.BillItemVO

getSparePart() - Method in class bb.common.BillItemWithPartInfoResult

getSparePart() - Method in class bb.common.BillLogVO

getSparePart() - Method in class bb.common.SalesBomItemResult

getSpareQty() - Method in class bb.common.BillItemUsageResult

getSpareSaleableParts(String, String) - Method in interface bb.common.box.SalesBox

getSpeaker() - Method in class bb.common.CustomEmployeeTrainVO

getSpeaker() - Method in class bb.common.EmployeeTrainingVO

getSpec() - Method in class bb.common.PartTraceableInfoResult

getSpecialCustomerCode() - Method in class bb.common.CustomerVendorAddressVO

getSpecialProcess() - Method in class bb.common.WorkInstructionSequenceVO

getSpecialProcess() - Method in class bb.common.WorkOrderTimeCardVO

getSpecialProcess() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getSpecialTitle() - Method in class bb.common.CustomEmployeeVO

getSpecialty() - Method in class bb.common.CustomEmployeeVO

getSpecialVendorCode() - Method in class bb.common.CustomerVendorAddressVO

getSpecialWork() - Method in class bb.common.CustomEmployeeVO

getSpecification() - Method in class bb.common.PartTraceableSpecVO

getSpecification() - Method in class bb.common.POSurveyReportItemVO

getSpecificationId() - Method in class bb.common.PartTraceableResult

getSpecificationId() - Method in class bb.common.PartTraceableSpecVO

getSpouseName() - Method in class bb.common.EmployeeHomeVO

getSrDate() - Method in class bb.common.ScrapReportVO

getSrItemNumber() - Method in class bb.common.POSurveyReportItemPK

getSrNumber() - Method in class bb.common.POSurveyReportItemPK

getSrNumber() - Method in class bb.common.POSurveyReportVO

getSrNumber() - Method in class bb.common.ScrapReportVO

getSrResult() - Method in class bb.common.POSurveyReportItemVO

getStaff() - Method in class bb.common.OperatingInstructionsUserStatisticalResult

getStaff() - Method in class bb.common.OperatingInstructionsVO

getStaff() - Method in class bb.common.StaffWorkingInformationResult

getStaffSign() - Method in class bb.common.OperatingInstructionsVO

getStandardCost() - Method in class bb.common.BillDetailCostResult

getStandardCost() - Method in class bb.common.BillDetailCostWithPartInfoResult

getStandardCost() - Method in class bb.common.BillItemDetailCostWithPartInfoResult

getStandardCost() - Method in class bb.common.BillItemSalesCostResult

getStandardCost() - Method in class bb.common.BillItemSalesXResult

getStandardCost() - Method in class bb.common.BillItemUsageResult

getStandardCost() - Method in class bb.common.BillSalesCostResult

getStandardCost() - Method in class bb.common.BillSalesXResult

getStandardCost() - Method in class bb.common.DWOIssueDetail

getStandardCost() - Method in class bb.common.HistoricalInventoryVO

getStandardCost() - Method in class bb.common.InventoryListResult

getStandardCost() - Method in class bb.common.PartCostVarianceListResult

getStandardCost() - Method in class bb.common.PartInventoryVO

getStandardCost() - Method in class bb.common.PartOnHandWithMfgInfoResult

getStandardCost() - Method in class bb.common.PhysicalInventoryVO

getStandardCost() - Method in class bb.common.POReceiverItemListResult

getStandardCost() - Method in class bb.common.RollUPPartStandardCostResult

getStandardCost() - Method in class bb.common.ToolInventoryVO

getStandardCost() - Method in class bb.common.ToolListDetailCostResult

getStandardCost() - Method in class bb.common.ToolListDetailCostWithToolInfoResult

getStandardCost() - Method in class bb.common.ToolListItemDetailCostWithToolInfoResult

getStandardCost() - Method in class bb.common.WOReceiverDetail

getStandardCost() - Method in class bb.common.WorkOrderItemListResult

getStandardExtendedCost() - Method in class bb.common.POReceiverItemListResult

getStartAmount() - Method in class bb.common.InventoryMonthReport

getStartCost() - Method in class bb.common.InventoryMonthReport

getStartDate() - Method in class bb.common.AccountAuditAgent

getStartDate() - Method in class bb.common.BB2FiscalYearDate

getStartDate() - Method in class bb.common.ContractPriceVO

getStartDate() - Method in class bb.common.CycleCountListResult

getStartDate() - Method in class bb.common.DisassembleWorkOrderItemListResult

getStartDate() - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

getStartDate() - Method in class bb.common.DisassembleWorkOrderItemVO

getStartDate() - Method in class bb.common.EmployeeCardVO

getStartDate() - Method in class bb.common.FiscalYearSettingsVO

getStartDate() - Method in class bb.common.LogTaskVO

getStartDate() - Method in class bb.common.OperatingInstructionsUserStatisticalResult

getStartDate() - Method in class bb.common.OperatingInstructionsVO

getStartDate() - Method in class bb.common.OrderApprovalItemsVO

getStartDate() - Method in class bb.common.PartOnHandAuditAgent

getStartDate() - Method in class bb.common.PhysicalInventoryListResult

getStartDate() - Method in class bb.common.RollUpBomStdCostWorkSheetVO

getStartDate() - Method in class bb.common.SalesmanVO

getStartDate() - Method in class bb.common.ShipListAgent

getStartDate() - Method in class bb.common.TaskVO

getStartDate() - Method in class bb.common.VendorContractPriceVO

getStartDate() - Method in class bb.common.WCLoadByDateResult

getStartDate() - Method in class bb.common.WCLoadDetailResult

getStartDate() - Method in class bb.common.WO2WOAgent

getStartDate() - Method in class bb.common.WOItemPartDetailNotIssue

getStartDate() - Method in class bb.common.WoItemPickListResult

getStartDate() - Method in class bb.common.WorkOrderItemCanAssyResult

getStartDate() - Method in class bb.common.WorkOrderItemListResult

getStartDate() - Method in class bb.common.WorkOrderItemPartDetailResult

getStartDate() - Method in class bb.common.WorkOrderItemReviewCostResult

getStartDate() - Method in class bb.common.WorkOrderItemSeqWCLoadResult

getStartDate() - Method in class bb.common.WorkOrderItemTimeDetailResult

getStartDate() - Method in class bb.common.WorkOrderItemToIssueResult

getStartDate() - Method in class bb.common.WorkOrderItemVO

getStartDate() - Method in class bb.common.WorkOrderItemWCLoadResult

getStartDate() - Method in class bb.common.WorkOrderOnDemandResult

getStartDate() - Method in class bb.common.WorkOrderOverIssueListResult

getStartDate() - Method in class bb.common.WorkOrderQueryInfo

getStartDate() - Method in class bb.common.WorkOrderWorkInstructionSequenceDateAgent

getStartDate() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getStartDate() - Method in class bb.common.WorkOrderWorkItemDateAgent

getStartingBalanceCredit() - Method in class bb.common.GLByDateTotalResult

getStartingBalanceDebit() - Method in class bb.common.GLByDateTotalResult

getStartMonth() - Method in class bb.common.CurrencyExchangeVO

getStartMonth() - Method in class bb.common.GlMonthBudgetVO

getStartMonth() - Method in class bb.common.GlMonthVO

getStartMonthBudget() - Method in class bb.common.CashFlowMonthTotalResult

getStartNumber() - Method in interface bb.common.box.CompanyBox

getStartNumberForSeq() - Method in class bb.common.PartNumberGenerateRuleVO

getStartQaAmount() - Method in class bb.common.InventoryMonthReport

getStartQaQty() - Method in class bb.common.InventoryMonthReport

getStartQty() - Method in class bb.common.InventoryMonthReport

getStartWipAmount() - Method in class bb.common.InventoryMonthReport

getStartWipDate() - Method in class bb.common.AccountingSettingsVO

getStartWipQty() - Method in class bb.common.InventoryMonthReport

getState() - Method in class bb.common.AccountPayableCheckVO

getState() - Method in class bb.common.AccountReceivablePaymentVO

getState() - Method in class bb.common.CustomerVendorAddressInfoVO

getState() - Method in class bb.common.CustomerVendorAddressVO

getState() - Method in class bb.common.CustomerVendorDescriptionVO

getState() - Method in class bb.common.EmployeeHomeVO

getState() - Method in class bb.common.LockedCustomerAddressResult

getState() - Method in class bb.common.ManufacturerAddressInfoVO

getState() - Method in class bb.common.ManufacturerAddressVO

getState() - Method in class bb.common.ManufacturerDescriptionVO

getState() - Method in class bb.common.SalesmanVO

getState() - Method in class bb.common.SalesMarginListResult

getState() - Method in class bb.common.SalesOrderItemListResult

getState() - Method in class bb.common.SGCartCheckOutResult

getState() - Method in class bb.common.SGCustRequestForQuoteListResult

getState() - Method in class bb.common.SGCustRequestForQuoteResult

getState() - Method in class bb.common.SGQuoteAddressResult

getState() - Method in class bb.common.SGQuoteAddressVO

getStateName() - Method in class bb.common.PosZipCodeTaxVO

getStateTaxRate() - Method in class bb.common.PosZipCodeTaxVO

getStateTotal(String, Date, Date) - Method in interface bb.common.box.CompanyBox

getStateTotalDetail(String, Date, Date, String) - Method in interface bb.common.box.CompanyBox

getStature() - Method in class bb.common.CustomCheckUpEmployeeVO

getStatus() - Method in class bb.common.AccountPayableCheckRunItemVO

getStatus() - Method in class bb.common.AccountPayableCheckRunVO

getStatus() - Method in class bb.common.AccountPayableCheckVO

getStatus() - Method in class bb.common.AccountPayableInfoWithPrepayResult

getStatus() - Method in class bb.common.AccountReceivablePaymentVO

getStatus() - Method in class bb.common.AccountsPayableInfoVO

getStatus() - Method in class bb.common.AccountsPayableItemVO

getStatus() - Method in class bb.common.AccountsPayableVO

getStatus() - Method in class bb.common.AccountsReceivableInfoVO

getStatus() - Method in class bb.common.AccountsReceivableItemVO

getStatus() - Method in class bb.common.AccountsReceivableVO

getStatus() - Method in class bb.common.APAuditListResult

getStatus() - Method in class bb.common.APItemListResult

getStatus() - Method in class bb.common.ApPrepayItemVO

getStatus() - Method in class bb.common.ApPrepayVO

getStatus() - Method in class bb.common.ARAuditListResult

getStatus() - Method in class bb.common.ArCommissionListResult

getStatus() - Method in class bb.common.ARPaymentRunItemVO

getStatus() - Method in class bb.common.ARPaymentRunVO

getStatus() - Method in class bb.common.ArPrepayItemVO

getStatus() - Method in class bb.common.ArPrepayVO

getStatus() - Method in class bb.common.AssetDepreciateDetailReport

getStatus() - Method in class bb.common.AssetVO

getStatus() - Method in class bb.common.BankReconciliationReportVO

getStatus() - Method in class bb.common.BB2PartInSTOItemResult

getStatus() - Method in class bb.common.BB2PartOnLoanItemResult

getStatus() - Method in class bb.common.BillVO

getStatus() - Method in class bb.common.BillWithPartInfoResult

getStatus() - Method in class bb.common.BizboxBugChangesInfoVO

getStatus() - Method in class bb.common.BizboxBugChangesVO

getStatus() - Method in class bb.common.BizboxBugInfoVO

getStatus() - Method in class bb.common.BizboxBugVO

getStatus() - Method in class bb.common.BizboxUserListResult

getStatus() - Method in class bb.common.BizboxUserVO

getStatus() - Method in class bb.common.ChangeStdCostWorkSheetVO

getStatus() - Method in class bb.common.ContractPriceVO

getStatus() - Method in class bb.common.CorrectiveActionRequestVO

getStatus() - Method in class bb.common.CRTVItemListResult

getStatus() - Method in class bb.common.CRTVListResult

getStatus() - Method in class bb.common.CustomerFeedbackVO

getStatus() - Method in class bb.common.CustomerReturnToVendorItemVO

getStatus() - Method in class bb.common.CustomerReturnToVendorVO

getStatus() - Method in class bb.common.CustomerServiceIncidentItemListResult

getStatus() - Method in class bb.common.CustomerServiceIncidentItemVO

getStatus() - Method in class bb.common.CustomerServiceIncidentListResult

getStatus() - Method in class bb.common.CustomerServiceIncidentVO

getStatus() - Method in class bb.common.CustomerVendorDescriptionVO

getStatus() - Method in class bb.common.CycleCountStatusVO

getStatus() - Method in class bb.common.DesignControlInfoVO

getStatus() - Method in class bb.common.DesignControlListResult

getStatus() - Method in class bb.common.DesignControlVO

getStatus() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getStatus() - Method in class bb.common.DisassembleWorkOrderIssuingResult

getStatus() - Method in class bb.common.DisassembleWorkOrderItemListResult

getStatus() - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

getStatus() - Method in class bb.common.DisassembleWorkOrderItemVO

getStatus() - Method in class bb.common.DisassembleWorkOrderListResult

getStatus() - Method in class bb.common.DisassembleWorkOrderVO

getStatus() - Method in class bb.common.EmployeeCardVO

getStatus() - Method in class bb.common.EngineeringChangeListResult

getStatus() - Method in class bb.common.EngineeringChangeRequestListResult

getStatus() - Method in class bb.common.EngineeringChangeRequestVO

getStatus() - Method in class bb.common.EngineeringChangeVO

getStatus() - Method in class bb.common.EngineeringSharingImportLogVO

getStatus() - Method in class bb.common.EquipmentListResult

getStatus() - Method in class bb.common.EquipmentVO

getStatus() - Method in class bb.common.ExpenseListResult

getStatus() - Method in class bb.common.ExpenseVO

getStatus() - Method in class bb.common.FiscalYearSettingsVO

getStatus() - Method in class bb.common.GeneralLedgerSettingsVO

getStatus() - Method in class bb.common.GlMonthBudgetVO

getStatus() - Method in class bb.common.GlMonthVO

getStatus() - Method in class bb.common.IcrItemListResult

getStatus() - Method in class bb.common.IcrListResult

getStatus() - Method in class bb.common.InspectionConformanceReportItemVO

getStatus() - Method in class bb.common.InspectionConformanceReportVO

getStatus() - Method in class bb.common.InvoiceItemListResult

getStatus() - Method in class bb.common.JobProcessSheetListResult

getStatus() - Method in class bb.common.LnShipperItemListResult

getStatus() - Method in class bb.common.LnShipperListResult

getStatus() - Method in class bb.common.ManufacturerDescriptionVO

getStatus() - Method in class bb.common.MessageVO

getStatus() - Method in class bb.common.MiscDocAgent

getStatus() - Method in class bb.common.NcrNeedToScrapListResult

getStatus() - Method in class bb.common.NcrReportListResult

getStatus() - Method in class bb.common.NonConformanceReportVO

getStatus() - Method in class bb.common.NonproductivePickingItemResult

getStatus() - Method in class bb.common.NonproductivePickingItemVO

getStatus() - Method in class bb.common.NonproductivePickingVO

getStatus() - Method in class bb.common.OnLoanItemListResult

getStatus() - Method in class bb.common.OnLoanItemVO

getStatus() - Method in class bb.common.OnLoanListResult

getStatus() - Method in class bb.common.OnloanReceiverItemListResult

getStatus() - Method in class bb.common.OnloanReceiverItemVO

getStatus() - Method in class bb.common.OnloanReceiverListResult

getStatus() - Method in class bb.common.OnloanReceiverVO

getStatus() - Method in class bb.common.OnloanShipperItemVO

getStatus() - Method in class bb.common.OnloanShipperVO

getStatus() - Method in class bb.common.OnLoanVO

getStatus() - Method in class bb.common.OperatingInstructionsUserStatisticalResult

getStatus() - Method in class bb.common.OperatingInstructionsVO

getStatus() - Method in class bb.common.OrderApprovalItemsVO

getStatus() - Method in class bb.common.OrderApprovalVO

getStatus() - Method in class bb.common.PackingBoxItemListResult

getStatus() - Method in class bb.common.PackingBoxItemVO

getStatus() - Method in class bb.common.PackingBoxSalesOrderItemResult

getStatus() - Method in class bb.common.PackingBoxVO

getStatus() - Method in class bb.common.PartDescriptionVO

getStatus() - Method in class bb.common.PfReceiverItemVO

getStatus() - Method in class bb.common.PfReceiverVO

getStatus() - Method in class bb.common.PhysicalInventoryStatusVO

getStatus() - Method in class bb.common.PoMessageItemVO

getStatus() - Method in class bb.common.PoMessageListResult

getStatus() - Method in class bb.common.PoMessageVO

getStatus() - Method in class bb.common.POReceiverItemListResult

getStatus() - Method in class bb.common.POStatisticsResult

getStatus() - Method in class bb.common.PreventiveActionRequestItemVO

getStatus() - Method in class bb.common.PreventiveActionRequestVO

getStatus() - Method in class bb.common.ProformaInvoiceItemListResult

getStatus() - Method in class bb.common.ProformaInvoiceItemVO

getStatus() - Method in class bb.common.ProformaInvoiceListResult

getStatus() - Method in class bb.common.ProformaInvoiceVO

getStatus() - Method in class bb.common.PrPackingBoxItemVO

getStatus() - Method in class bb.common.PrPackingBoxVO

getStatus() - Method in class bb.common.PrReceiverListResult

getStatus() - Method in class bb.common.PurchaseOrderCheckListResult

getStatus() - Method in class bb.common.PurchaseOrderItemVO

getStatus() - Method in class bb.common.PurchaseOrderVO

getStatus() - Method in class bb.common.QuoteItemListResult

getStatus() - Method in class bb.common.QuoteItemVO

getStatus() - Method in class bb.common.QuoteListResult

getStatus() - Method in class bb.common.QuoteVO

getStatus() - Method in class bb.common.ReceiverInfoVO

getStatus() - Method in class bb.common.ReceiverItemVO

getStatus() - Method in class bb.common.ReceiverVO

getStatus() - Method in class bb.common.ReceivingItemResult

getStatus() - Method in class bb.common.RequestForQuoteCheckListResult

getStatus() - Method in class bb.common.RequestForQuoteItemListResult

getStatus() - Method in class bb.common.RequestForQuoteItemVO

getStatus() - Method in class bb.common.RequestForQuoteListResult

getStatus() - Method in class bb.common.RequestForQuoteVO

getStatus() - Method in class bb.common.RequestForRMAItemVO

getStatus() - Method in class bb.common.RequestForRMAVO

getStatus() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getStatus() - Method in class bb.common.ReturnMaterialAuthorizationVO

getStatus() - Method in class bb.common.ReturnToVendorCheckListResult

getStatus() - Method in class bb.common.ReturnToVendorItemListResult

getStatus() - Method in class bb.common.ReturnToVendorItemVO

getStatus() - Method in class bb.common.ReturnToVendorListResult

getStatus() - Method in class bb.common.ReturnToVendorVO

getStatus() - Method in class bb.common.RfqMessageItemVO

getStatus() - Method in class bb.common.RfqMessageListResult

getStatus() - Method in class bb.common.RfqMessageVO

getStatus() - Method in class bb.common.RMAItemListResult

getStatus() - Method in class bb.common.RMAListResult

getStatus() - Method in class bb.common.RMAReceiverItemListResult

getStatus() - Method in class bb.common.RMAReceiverItemVO

getStatus() - Method in class bb.common.RMAReceiverListResult

getStatus() - Method in class bb.common.RMAReceiverVO

getStatus() - Method in class bb.common.RollUpBomStdCostWorkSheetVO

getStatus() - Method in class bb.common.RRMAItemListResult

getStatus() - Method in class bb.common.RRMAListResult

getStatus() - Method in class bb.common.RtvShipperInfoVO

getStatus() - Method in class bb.common.RtvShipperItemListResult

getStatus() - Method in class bb.common.RtvShipperItemVO

getStatus() - Method in class bb.common.RtvShipperListResult

getStatus() - Method in class bb.common.RtvShipperVO

getStatus() - Method in class bb.common.SalesmanVO

getStatus() - Method in class bb.common.SalesOrderCheckListResult

getStatus() - Method in class bb.common.SalesOrderItemInfoVO

getStatus() - Method in class bb.common.SalesOrderItemListResult

getStatus() - Method in class bb.common.SalesOrderItemVO

getStatus() - Method in class bb.common.SalesOrderListResult

getStatus() - Method in class bb.common.SalesOrderShipDateListResult

getStatus() - Method in class bb.common.SalesOrderVO

getStatus() - Method in class bb.common.ScrapReportVO

getStatus() - Method in class bb.common.SGCustomerServiceRequestVO

getStatus() - Method in class bb.common.SGCustRequestForQuoteVO

getStatus() - Method in class bb.common.ShipListInfoVO

getStatus() - Method in class bb.common.ShipListItemVO

getStatus() - Method in class bb.common.ShipListVO

getStatus() - Method in class bb.common.ShipperInfoVO

getStatus() - Method in class bb.common.ShipperItemListResult

getStatus() - Method in class bb.common.ShipperItemVO

getStatus() - Method in class bb.common.ShipperListResult

getStatus() - Method in class bb.common.ShipperVO

getStatus() - Method in class bb.common.ShippingItemResult

getStatus() - Method in class bb.common.SoPickListResult

getStatus() - Method in class bb.common.SOShipperItemListResult

getStatus() - Method in class bb.common.SwapOrderItemVO

getStatus() - Method in class bb.common.SwapOrderListResult

getStatus() - Method in class bb.common.SwapOrderVO

getStatus() - Method in class bb.common.SwapReceiverItemListResult

getStatus() - Method in class bb.common.SwapReceiverItemVO

getStatus() - Method in class bb.common.SwapReceiverListResult

getStatus() - Method in class bb.common.SwapReceiverVO

getStatus() - Method in class bb.common.SwapShipperItemListResult

getStatus() - Method in class bb.common.SwapShipperItemVO

getStatus() - Method in class bb.common.SwapShipperListResult

getStatus() - Method in class bb.common.SwapShipperVO

getStatus() - Method in class bb.common.TempArApAgingVO

getStatus() - Method in class bb.common.TempReceiverWithoutAPInfo

getStatus() - Method in class bb.common.ToolCalibrationVO

getStatus() - Method in class bb.common.ToolDescriptionVO

getStatus() - Method in class bb.common.TransferOrderItemListResult

getStatus() - Method in class bb.common.TransferOrderItemVO

getStatus() - Method in class bb.common.TransferOrderListResult

getStatus() - Method in class bb.common.TransferOrderVO

getStatus() - Method in class bb.common.TransferReceiverItemListResult

getStatus() - Method in class bb.common.TransferReceiverItemVO

getStatus() - Method in class bb.common.TransferReceiverListResult

getStatus() - Method in class bb.common.TransferReceiverVO

getStatus() - Method in class bb.common.TransferShipperItemListResult

getStatus() - Method in class bb.common.TransferShipperItemVO

getStatus() - Method in class bb.common.TransferShipperListResult

getStatus() - Method in class bb.common.TransferShipperVO

getStatus() - Method in class bb.common.VendorContractPriceVO

getStatus() - Method in class bb.common.WorkInstructionListResult

getStatus() - Method in class bb.common.WorkInstructionRequestForChangeVO

getStatus() - Method in class bb.common.WorkInstructionSequenceVO

getStatus() - Method in class bb.common.WorkInstructionSummaryItemResult

getStatus() - Method in class bb.common.WorkInstructionVO

getStatus() - Method in class bb.common.WorkOrderCheckListResult

getStatus() - Method in class bb.common.WorkOrderItemListResult

getStatus() - Method in class bb.common.WorkOrderItemPartDetail

getStatus() - Method in class bb.common.WorkOrderItemPartDetailResult

getStatus() - Method in class bb.common.WorkOrderItemReviewCostResult

getStatus() - Method in class bb.common.WorkOrderItemTimeDetailResult

getStatus() - Method in class bb.common.WorkOrderItemVO

getStatus() - Method in class bb.common.WorkOrderListResult

getStatus() - Method in class bb.common.WorkOrderQueryInfo

getStatus() - Method in class bb.common.WorkOrderTimeCardVO

getStatus() - Method in class bb.common.WorkOrderVO

getStatus() - Method in class bb.common.WorkOrderWorkInstructionListResult

getStatus() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getStatus() - Method in class bb.common.WorkOrderWorkInstructionVO

getStdAmount() - Method in class bb.common.BB2DoubleCost

getStdCost() - Method in class bb.common.AccountsPayableItemVO

getStdCost() - Method in class bb.common.AccountsReceivableItemVO

getStdCost(PartPK) - Method in class bb.common.BOMTreeRollUPMap

getStdCost() - Method in class bb.common.ChangeStdCostWorkSheetItemVO

getStdCost() - Method in class bb.common.DisassembleWorkOrderIssueVO

getStdCost() - Method in class bb.common.DisassembleWorkOrderItemPartDetailItemResult

getStdCost() - Method in class bb.common.InSipAudittListResult

getStdCost() - Method in class bb.common.InventoryAmountByMonth

getStdCost() - Method in class bb.common.InventoryMonthReport

getStdCost() - Method in class bb.common.InventoryNotUsedInMonthsResult

getStdCost() - Method in class bb.common.LogInventoryVO

getStdCost() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getStdCost() - Method in class bb.common.NonproductivePickingItemIssuedVO

getStdCost() - Method in class bb.common.NonproductivePickingItemVO

getStdCost() - Method in class bb.common.OrderApprovalItemsVO

getStdCost() - Method in class bb.common.PartBasicInfoWithNewListPrice

getStdCost() - Method in class bb.common.PartInWipForIDListResult

getStdCost() - Method in class bb.common.PartIssuedVO

getStdCost() - Method in class bb.common.PartOnhandAndCostResult

getStdCost() - Method in class bb.common.PartOnhandResult

getStdCost() - Method in class bb.common.PartReceivedVO

getStdCost() - Method in class bb.common.PartWithExcessiveInventoryListResult

getStdCost() - Method in class bb.common.PartWithOnLoanQtyListResult

getStdCost() - Method in class bb.common.PartWithQAQtyListResult

getStdCost() - Method in class bb.common.PartWithQtyListResult

getStdCost() - Method in class bb.common.PartWithSipQtyListResult

getStdCost() - Method in class bb.common.PartWithSITQtyListResult

getStdCost() - Method in class bb.common.PartWithSTOQtyListResult

getStdCost() - Method in class bb.common.PartWithWipQtyListResult

getStdCost() - Method in class bb.common.QuoteItemVO

getStdCost() - Method in class bb.common.ReceiverItemVO

getStdCost() - Method in class bb.common.RollUpBomStdCostWorkSheetItemVO

getStdCost() - Method in class bb.common.RtvShipperItemVO

getStdCost() - Method in class bb.common.RunningAccountOrderItemVO

getStdCost() - Method in class bb.common.SalesOrderItemCostResult

getStdCost() - Method in class bb.common.SalesOrderItemVO

getStdCost() - Method in class bb.common.ShipperItemVO

getStdCost() - Method in class bb.common.SwapOrderItemListResult

getStdCost() - Method in class bb.common.SwapOrderItemVO

getStdCost() - Method in class bb.common.SwapReceiverItemListResult

getStdCost() - Method in class bb.common.SwapReceiverItemVO

getStdCost() - Method in class bb.common.SwapShipperItemListResult

getStdCost() - Method in class bb.common.SwapShipperItemVO

getStdCost() - Method in class bb.common.TransferOrderItemListResult

getStdCost() - Method in class bb.common.TransferOrderItemVO

getStdCost() - Method in class bb.common.TransferReceiverItemListResult

getStdCost() - Method in class bb.common.TransferReceiverItemVO

getStdCost() - Method in class bb.common.TransferShipperItemListResult

getStdCost() - Method in class bb.common.TransferShipperItemVO

getStdCost() - Method in class bb.common.WOItemPartDetailNotIssue

getStdCost() - Method in class bb.common.WorkOrderItemInWipListResult

getStdCost() - Method in class bb.common.WorkOrderItemPartDetailInWipVO

getStdCost() - Method in class bb.common.WorkOrderItemPartDetailItemResult

getStdCost() - Method in class bb.common.WorkOrderReceiverVO

getStdCostApprovedBy() - Method in class bb.common.AccountingConfigurationVO

getStdCostPerUnit() - Method in class bb.common.DisassembleWorkOrderItemVO

getStdCostPerUnit() - Method in class bb.common.WorkOrderItemVO

getStdCostSubTotal(int) - Method in class bb.common.PartIssuedListResult

getStdCostSubTotal() - Method in class bb.common.PartIssuedListResult

getStdCostSubTotal(int) - Method in class bb.common.PartIssuedVO

getStdHours() - Method in class bb.common.WorkInstructionSequenceVO

getStdHoursH() - Method in class bb.common.WorkInstructionSequenceVO

getStdHoursM() - Method in class bb.common.WorkInstructionSequenceVO

getStdHoursS() - Method in class bb.common.WorkInstructionSequenceVO

getStdHrs() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getStdHrsH() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getStdHrsM() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getStdHrsS() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getStdMargin() - Method in class bb.common.AccountingTotalMoneyResult

getStdMargin() - Method in class bb.common.DuePATotalByVendorResult

getStdMarginPercent() - Method in class bb.common.AccountingTotalMoneyResult

getStdMarginPercent() - Method in class bb.common.DuePATotalByVendorResult

getStdSetup() - Method in class bb.common.WorkInstructionSequenceVO

getStdSetup() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getStdSetupH() - Method in class bb.common.WorkInstructionSequenceVO

getStdSetupH() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getStdSetupM() - Method in class bb.common.WorkInstructionSequenceVO

getStdSetupM() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getStdSetupS() - Method in class bb.common.WorkInstructionSequenceVO

getStdSetupS() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getStdTotal() - Method in class bb.common.NonproductivePickingItemVO

getStdTotal() - Method in class bb.common.NonproductivePickingVO

getStdTotalAmount() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getStdTotalAmount() - Method in class bb.common.WorkOrderItemInWipListResult

getStepsToReproduce() - Method in class bb.common.CustomerServiceIncidentVO

getStockMonth() - Method in class bb.common.InventoryNotUsedInMonthsforAppResult

getStockOnDemandList() - Method in class bb.common.MrpItemOrderDemandRecordsResult

getStockOnDemandList() - Method in class bb.common.MrpItemResult

getStockTransactionAdjustmentResultsCount(Date, Date, String, String) - Method in interface bb.common.box.WarehouseBox

getStockTransactionPartInfoResultByPartPk(PartPK) - Method in interface bb.common.box.WarehouseBox

getStockTransactionPOReceiverResultsCount(Date, Date, String, String) - Method in interface bb.common.box.WarehouseBox

getStockTransactionSOShipperResultsCount(Date, Date, String, String) - Method in interface bb.common.box.WarehouseBox

getStockTransactionWOReceiverResultsCount(Date, Date, String, String) - Method in interface bb.common.box.WarehouseBox

getStockTransactionWOShipperResultsCount(Date, Date, String, String) - Method in interface bb.common.box.WarehouseBox

getStorageDate() - Method in class bb.common.PurchaseOrderContractResult

getStr() - Method in class bb.common.ClientListItem

getStr() - Method in class bb.common.QtyDetailResult

getStringNumber(String) - Static method in class bb.common.BB2Util

getSubAccountNumber() - Method in class bb.common.AccountsChartMappingPK

getSubcompanyById(String) - Method in interface bb.common.box.CompanyBox

getSubcompanyId() - Method in class bb.common.AccountsChartMappingPK

getSubDiscountTotal() - Method in class bb.common.AccountsReceivableInfoVO

getSubDiscountTotal() - Method in class bb.common.AccountsReceivableVO

getSubDiscountTotal() - Method in class bb.common.ArCommissionListResult

getSubInQuery(String, String) - Static method in class bb.common.BB2Util

getSubject() - Method in class bb.common.BB2BugNotice

getSubject() - Method in class bb.common.BB2Notice

getSubject() - Method in class bb.common.MessageAgent

getSubject() - Method in class bb.common.MessageVO

getSubmitDate() - Method in class bb.common.PurchaseOrderContractResult

getSubmitDate() - Method in class bb.common.PurchaseOrderVO

getSubNetTotal() - Method in class bb.common.AccountingTotalMoneyResult

getSubNetTotal() - Method in class bb.common.AccountsReceivableInfoVO

getSubNetTotal() - Method in class bb.common.AccountsReceivableVO

getSubNetTotal() - Method in class bb.common.ArCommissionListResult

getSubNetTotal() - Method in class bb.common.DuePATotalByVendorResult

getSubNetTotal() - Method in class bb.common.SalesTaxListResult

getSubOrders(String, String) - Method in interface bb.common.box.WorkOrderBox

getSubTotal() - Method in class bb.common.AccountsReceivableItemResult

getSubTotal() - Method in class bb.common.ArCommissionTotalResult

getSubTotal() - Method in class bb.common.ArSalesCodeTotalListResult

getSubTotal() - Method in class bb.common.CustomerReturnToVendorVO

getSubTotal() - Method in class bb.common.DisassembleWorkOrderListResult

getSubTotal() - Method in class bb.common.DisassembleWorkOrderVO

getSubTotal() - Method in class bb.common.MakeAccountPayableAgent

getSubTotal() - Method in class bb.common.MakeBillAndHoldInvoiceAgent

getSubTotal() - Method in class bb.common.MakeInvoiceAgent

getSubTotal() - Method in class bb.common.OnloanReceiverVO

getSubTotal() - Method in class bb.common.PoMessageVO

getSubTotal() - Method in class bb.common.PurchaseOrderVO

getSubTotal() - Method in class bb.common.QuoteVO

getSubTotal() - Method in class bb.common.ReceiverInfoVO

getSubTotal() - Method in class bb.common.ReceiverVO

getSubTotal() - Method in class bb.common.RequestForQuoteItemListResult

getSubTotal() - Method in class bb.common.RequestForQuoteVO

getSubTotal() - Method in class bb.common.RequestForRMAVO

getSubTotal() - Method in class bb.common.ReturnMaterialAuthorizationVO

getSubTotal() - Method in class bb.common.ReturnToVendorVO

getSubTotal() - Method in class bb.common.RunningAccountOrderItemVO

getSubTotal() - Method in class bb.common.RunningAccountOrderVO

getSubTotal() - Method in class bb.common.SalesOrderItemListResult

getSubTotal() - Method in class bb.common.SalesOrderVO

getSubTotal() - Method in class bb.common.SalesTaxListResult

getSubTotal() - Method in class bb.common.TempReceiverWithoutAPInfo

getSubTotal() - Method in class bb.common.TotalByDateResult

getSubTotal() - Method in class bb.common.VendorTotalAmountInPO

getSubTotal() - Method in class bb.common.WorkOrderIssueStatisticsResult

getSubTotal() - Method in class bb.common.WorkOrderVO

getSubUnitTotal() - Method in class bb.common.AccountsReceivableInfoVO

getSubUnitTotal() - Method in class bb.common.AccountsReceivableVO

getSubUnitTotal() - Method in class bb.common.ArCommissionListResult

getSubWorkOrderByWorkOrderItemPK(WorkOrderItemPK) - Method in interface bb.common.box.WorkOrderBox

getSumCost() - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

getSumCost() - Method in class bb.common.WOItemCostControlAgent

getSumCost() - Method in class bb.common.WorkOrderItemPartDetailResult

getSumCost() - Method in class bb.common.WorkOrderItemReviewCostResult

getSumHrs() - Method in class bb.common.WorkCenterRunTimeListResult

getSummary() - Method in class bb.common.GeneralLedgerByDateListResult

getSummary() - Method in class bb.common.JounalEntryListResult

getSummary() - Method in class bb.common.TermsConditionVO

getSumRunTime() - Method in class bb.common.WorkCenterRunTimeTotalResult

getSumSetup() - Method in class bb.common.WorkCenterRunTimeListResult

getSumSetupTime() - Method in class bb.common.WorkCenterRunTimeTotalResult

getSumTime() - Method in class bb.common.WorkCenterRunTimeListResult

getSumTime() - Method in class bb.common.WorkCenterRunTimeTotalResult

getSwapDate() - Method in class bb.common.SwapOrderItemListResult

getSwapDate() - Method in class bb.common.SwapOrderListResult

getSwapDate() - Method in class bb.common.SwapOrderVO

getSwapOrder() - Method in class bb.common.SwapOrderItemPK

getSwapOrderApprovalByEmployeeId(String) - Method in interface bb.common.box.PurchasingBox

getSwapOrderCountByDate(String, PartPK, String, Date, Date, String, String, String, String, String, String) - Method in interface bb.common.box.PurchasingBox

getSwapOrderItem() - Method in class bb.common.SwapOrderItemPK

getSwapOrderItems() - Method in class bb.common.SwapOrderVO

getSwapOrderNumber() - Method in class bb.common.SwapOrderListResult

getSwapOrderNumber() - Method in class bb.common.SwapOrderVO

getSwapOrderNumber() - Method in class bb.common.SwapReceiverItemListResult

getSwapOrderNumber() - Method in class bb.common.SwapReceiverListResult

getSwapOrderNumber() - Method in class bb.common.SwapReceiverVO

getSwapOrderNumber() - Method in class bb.common.SwapShipperItemListResult

getSwapOrderNumber() - Method in class bb.common.SwapShipperListResult

getSwapOrderNumber() - Method in class bb.common.SwapShipperVO

getSwapOrdersCount(String, String, String, String, String, String[], Date, Date) - Method in interface bb.common.box.PurchasingBox

getSwapOrderShippingResult(String) - Method in interface bb.common.box.WarehouseBox

getSwapOrderVOBySwapNumber(String) - Method in interface bb.common.box.PurchasingBox

getSwapQty() - Method in class bb.common.SwapOrderItemListResult

getSwapQty() - Method in class bb.common.SwapOrderItemVO

getSwapQty() - Method in class bb.common.SwapReceiverItemListResult

getSwapQty() - Method in class bb.common.SwapReceiverItemVO

getSwapQty() - Method in class bb.common.SwapShipperItemListResult

getSwapQty() - Method in class bb.common.SwapShipperItemVO

getSwapQty() - Method in class bb.common.SwapShipperOnOrderResult

getSwapReceiverItemByDateCount(String, String, String, String, String, String, String, String, Date, Date) - Method in interface bb.common.box.WarehouseBox

getSwapReceiverItemByPk(SwapReceiverItemPK) - Method in interface bb.common.box.WarehouseBox

getSwapReceiverItemNumber() - Method in class bb.common.SwapReceiverItemListResult

getSwapReceiverItemNumber() - Method in class bb.common.SwapReceiverItemPK

getSwapReceiverItems() - Method in class bb.common.SwapReceiverVO

getSwapReceiverNumber() - Method in class bb.common.SwapReceiverItemListResult

getSwapReceiverNumber() - Method in class bb.common.SwapReceiverItemPK

getSwapReceiverNumber() - Method in class bb.common.SwapReceiverListResult

getSwapReceiverNumber() - Method in class bb.common.SwapReceiverVO

getSwapReceiversCount(String, String, String, String, String, String, String, String, Date, Date) - Method in interface bb.common.box.WarehouseBox

getSwapReceiverVO(String) - Method in interface bb.common.box.WarehouseBox

getSwapReceivingResult(String) - Method in interface bb.common.box.WarehouseBox

getSwapShipperItemByPk(SwapShipperItemPK) - Method in interface bb.common.box.WarehouseBox

getSwapShipperItemNumber() - Method in class bb.common.SwapShipperItemListResult

getSwapShipperItemNumber() - Method in class bb.common.SwapShipperItemPK

getSwapShipperItemPk() - Method in class bb.common.SwapShipperOnOrderResult

getSwapShipperItems() - Method in class bb.common.SwapShipperVO

getSwapShipperItemsByDateCount(String, String, String, String, String, String, String, Date, Date) - Method in interface bb.common.box.WarehouseBox

getSwapShipperNumber() - Method in class bb.common.SwapReceiverItemListResult

getSwapShipperNumber() - Method in class bb.common.SwapReceiverListResult

getSwapShipperNumber() - Method in class bb.common.SwapReceiverVO

getSwapShipperNumber() - Method in class bb.common.SwapShipperItemListResult

getSwapShipperNumber() - Method in class bb.common.SwapShipperItemPK

getSwapShipperNumber() - Method in class bb.common.SwapShipperListResult

getSwapShipperNumber() - Method in class bb.common.SwapShipperVO

getSwapShippersCount(String, String, String, String, String, String, String, Date, Date) - Method in interface bb.common.box.WarehouseBox

getSwapShipperVO(String) - Method in interface bb.common.box.WarehouseBox

getSwoDigits() - Method in class bb.common.CompanyVO

getSwoItemNumber() - Method in class bb.common.SwapOrderItemListResult

getSwoNumber() - Method in class bb.common.SwapOrderItemListResult

getSwoPrefix() - Method in class bb.common.CompanyVO

getSwrDigits() - Method in class bb.common.CompanyVO

getSwrPrefix() - Method in class bb.common.CompanyVO

getSwsDetails() - Method in class bb.common.BB2PartTotalOnorderDetailResult

getSwsDigits() - Method in class bb.common.CompanyVO

getSwsOnOrderList() - Method in class bb.common.MrpItemResult

getSwsPrefix() - Method in class bb.common.CompanyVO

getSymbol() - Method in class bb.common.CurrencyVO

getSystem() - Method in class bb.common.BB2Login

getSystem() - Method in class bb.common.BizBoxServer

getSystem() - Method in class bb.common.OperationLogVO

getSystem() - Method in class bb.common.SubcompanyLoginAgent

getSystem() - Method in class bb.common.SubcompanyVO

getSystemLanguage() - Method in class bb.common.CompanyVO

getSystemName() - Method in class bb.common.UserRolePermissionListResult

getSystemOndemand() - Method in class bb.common.AuditOnDemandResult

getSystemOnhand() - Method in class bb.common.CycleCountListResult

getSystemOnhand() - Method in class bb.common.PhysicalInventoryListResult

getSystemOnorder() - Method in class bb.common.AuditOnDemandResult

getSystemQtrUsage() - Method in class bb.common.AuditOnDemandResult

getSystemTotal() - Method in class bb.common.PhysicalInventoryListWithAppDataResult

getSystemUserGroupCount() - Method in interface bb.common.box.CompanyBox

getSystemUserName() - Method in class bb.common.BizBoxUserEmployeeResult

getSystemUserName() - Method in class bb.common.BizboxUserListResult

getSystemUserName() - Method in class bb.common.NoticeUserEmployeeListResult

getSystemWip() - Method in class bb.common.AuditOnDemandResult

getSystemYrUsage() - Method in class bb.common.AuditOnDemandResult

getTableAppColumns(String) - Method in interface bb.common.box.CompanyBox

getTableName() - Method in class bb.common.AppColumnVO

getTableName() - Method in class bb.common.DataFilterVO

getTagNumber() - Method in class bb.common.AddPhysicalInventoryAgent

getTagNumber() - Method in class bb.common.PhysicalInventoryListResult

getTagNumber() - Method in class bb.common.PhysicalInventoryVO

getTagNumber() - Method in class bb.common.UpdatePhysicalInventoryAgent

getTarget() - Method in exception bb.common.BB2DocumentException

getTarget() - Method in exception bb.common.BizException

getTarget() - Method in class bb.common.OperationLogVO

getTask(Long) - Method in interface bb.common.box.CompanyBox

getTaskClass() - Method in class bb.common.BB2Task

getTaskId() - Method in class bb.common.LogTaskVO

getTax() - Method in class bb.common.MakeAccountPayableAgent

getTax() - Method in class bb.common.MakeBillAndHoldInvoiceAgent

getTax() - Method in class bb.common.MakeInvoiceAgent

getTax() - Method in class bb.common.PO2SOExchangeItem

getTax() - Method in class bb.common.ProfitLossStatementResult

getTax() - Method in class bb.common.RunningAccountOrderItemVO

getTax() - Method in class bb.common.RunningAccountOrderVO

getTax() - Method in class bb.common.SalesTaxListResult

getTaxExemptTotalByCityCount(String, Date, Date) - Method in interface bb.common.box.CompanyBox

getTaxId() - Method in class bb.common.CustomerVendorAddressInfoVO

getTaxId() - Method in class bb.common.CustomerVendorAddressVO

getTaxNumber() - Method in class bb.common.ZipcodeTotalsResult

getTaxOfCategory(String) - Method in interface bb.common.box.AccountingBox

getTaxPayerIDCode() - Method in class bb.common.CustomerVendorAddressInfoVO

getTaxPayerIDCode() - Method in class bb.common.CustomerVendorAddressVO

getTaxr() - Method in class bb.common.RMAReceiverItemVO

getTaxRate() - Method in class bb.common.AccountsPayableItemVO

getTaxRate() - Method in class bb.common.AccountsReceivableItemVO

getTaxRate() - Method in class bb.common.AddPayableWithoutReceiverAgent

getTaxRate() - Method in class bb.common.APItemListResult

getTaxRate() - Method in class bb.common.CustomerReturnToVendorItemVO

getTaxRate() - Method in class bb.common.DisassembleWorkOrderItemVO

getTaxRate() - Method in class bb.common.InvoiceItemListResult

getTaxRate() - Method in class bb.common.OnLoanItemVO

getTaxRate() - Method in class bb.common.OnloanReceiverItemVO

getTaxRate() - Method in class bb.common.OnloanShipperItemVO

getTaxRate() - Method in class bb.common.OrderApprovalItemsVO

getTaxRate() - Method in class bb.common.PfReceiverItemVO

getTaxRate() - Method in class bb.common.PoMessageItemVO

getTaxRate() - Method in class bb.common.POReceiverItemListResult

getTaxRate() - Method in class bb.common.PosZipCodeTaxVO

getTaxRate() - Method in class bb.common.ProformaInvoiceItemVO

getTaxRate() - Method in class bb.common.PurchaseOrderItemVO

getTaxRate() - Method in class bb.common.QuoteItemVO

getTaxRate() - Method in class bb.common.ReceiverItemVO

getTaxRate() - Method in class bb.common.RequestForQuoteItemVO

getTaxRate() - Method in class bb.common.RequestForQuoteVO

getTaxRate() - Method in class bb.common.RequestForRMAItemVO

getTaxRate() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getTaxRate() - Method in class bb.common.ReturnToVendorByDateListResult

getTaxRate() - Method in class bb.common.ReturnToVendorItemVO

getTaxRate() - Method in class bb.common.RfqMessageItemVO

getTaxRate() - Method in class bb.common.RtvShipperItemVO

getTaxRate() - Method in class bb.common.RunningAccountOrderItemResult

getTaxRate() - Method in class bb.common.RunningAccountOrderVO

getTaxRate() - Method in class bb.common.SalesOrderItemInfoVO

getTaxRate() - Method in class bb.common.SalesOrderItemVO

getTaxRate() - Method in class bb.common.ShipperItemListResult

getTaxRate() - Method in class bb.common.ShipperItemVO

getTaxRate() - Method in class bb.common.WorkOrderItemVO

getTaxRate() - Method in class bb.common.ZipCodeTaxVO

getTaxRate() - Method in class bb.common.ZipcodeTotalsResult

getTaxTotal() - Method in class bb.common.AccountsReceivableInfoVO

getTaxTotal() - Method in class bb.common.AccountsReceivableVO

getTaxTotal() - Method in class bb.common.ArCommissionListResult

getTaxTotal() - Method in class bb.common.ArCommissionTotalResult

getTaxTotal() - Method in class bb.common.ArSalesCodeTotalListResult

getTaxTotal(Date, Date) - Method in interface bb.common.box.CompanyBox

getTaxTotal() - Method in class bb.common.RunningAccountOrderItemVO

getTaxTotal() - Method in class bb.common.RunningAccountOrderVO

getTaxTotal() - Method in class bb.common.RunTaxPaymentResult

getTaxType() - Method in class bb.common.CustomerVendorAddressInfoVO

getTaxType() - Method in class bb.common.CustomerVendorAddressVO

getTaxType() - Method in class bb.common.RunningAccountOrderVO

getTaxType() - Method in class bb.common.ZipCodeTaxVO

getTaxType() - Method in class bb.common.ZipcodeTotalsResult

getTDate() - Method in class bb.common.MrpReportAgent

getTdate() - Method in class bb.common.TaskVO

getTDate() - Method in class bb.common.WCLoadAgent

getTday() - Method in class bb.common.TaskVO

getTechnolgyStandard() - Method in class bb.common.InspectionConformanceReportItemCheckVO

getTechnolgyStandard() - Method in class bb.common.InspectionTypeItemVO

getTechnolgyStandard() - Method in class bb.common.PartInspectionVO

getTechRev() - Method in class bb.common.SGDocPartVO

getTechSheet() - Method in class bb.common.SGDocPartVO

getTempAddressCount(String) - Method in interface bb.common.box.CompanyBox

getTempBOMCount() - Method in interface bb.common.box.CompanyBox

getTempEmployeeCount() - Method in interface bb.common.box.CompanyBox

getTempInventoryCount() - Method in interface bb.common.box.CompanyBox

getTemplate() - Method in class bb.common.CommonPrintTemplateVO

getTemplateName() - Method in class bb.common.CommonPrintTemplateVO

getTemplateName() - Method in class bb.common.PrintTemplateVO

getTempManufactureCount() - Method in interface bb.common.box.CompanyBox

getTempMaterialCount() - Method in interface bb.common.box.CompanyBox

getTempMPNCount() - Method in interface bb.common.box.CompanyBox

getTempNccodeCount() - Method in interface bb.common.box.CompanyBox

getTempOnhand() - Method in class bb.common.RunningAccountOrderItemVO

getTempPartCount() - Method in interface bb.common.box.CompanyBox

getTempToolCount() - Method in interface bb.common.box.CompanyBox

getTempToolInventoryCount() - Method in interface bb.common.box.CompanyBox

getTempWorkerDigits() - Method in class bb.common.CompanyVO

getTempWorkerPrefix() - Method in class bb.common.CompanyVO

getTerm(int, BigDecimal, int) - Static method in class bb.common.BB2Util

getTerm(int) - Method in interface bb.common.box.CompanyBox

getTerm(String) - Method in interface bb.common.box.CompanyBox

getTerm() - Method in class bb.common.TermAgent

getTerm() - Method in class bb.common.TermVO

getTermAlias() - Method in class bb.common.TermAgent

getTermAlias() - Method in class bb.common.TermVO

getTermDiscount(String) - Static method in class bb.common.BB2Util

getTermDiscountDays(String) - Static method in class bb.common.BB2Util

getTerminatedDate() - Method in class bb.common.EmployeeCardVO

getTermNumber(String) - Static method in class bb.common.BB2Util

getTerms() - Method in class bb.common.AccountsPayableInfoVO

getTerms() - Method in class bb.common.AccountsPayableVO

getTerms() - Method in class bb.common.AccountsReceivableInfoVO

getTerms() - Method in class bb.common.AccountsReceivableVO

getTerms() - Method in class bb.common.APItemListResult

getTerms() - Method in class bb.common.CustomerReturnToVendorVO

getTerms() - Method in class bb.common.CustomerStatementTotalResult

getTerms() - Method in class bb.common.DisassembleWorkOrderVO

getTerms() - Method in class bb.common.MakeAccountPayableAgent

getTerms() - Method in class bb.common.MakeBillAndHoldInvoiceAgent

getTerms() - Method in class bb.common.MakeCreditMemoAgent

getTerms() - Method in class bb.common.MakeDebitMemoAgent

getTerms() - Method in class bb.common.MakeInvoiceAgent

getTerms() - Method in class bb.common.OnloanReceiverVO

getTerms() - Method in class bb.common.OnloanShipperVO

getTerms() - Method in class bb.common.OnLoanVO

getTerms() - Method in class bb.common.PfReceiverVO

getTerms() - Method in class bb.common.PO2SOExchange

getTerms() - Method in class bb.common.ProformaInvoiceVO

getTerms() - Method in class bb.common.PurchaseOrderVO

getTerms() - Method in class bb.common.QuoteVO

getTerms() - Method in class bb.common.ReceiverInfoVO

getTerms() - Method in class bb.common.ReceiverVO

getTerms() - Method in class bb.common.RequestForQuoteVO

getTerms() - Method in class bb.common.RequestForRMAVO

getTerms() - Method in class bb.common.ReturnMaterialAuthorizationVO

getTerms() - Method in class bb.common.ReturnToVendorVO

getTerms() - Method in class bb.common.RMAReceiverVO

getTerms() - Method in class bb.common.RtvShipperInfoVO

getTerms() - Method in class bb.common.RtvShipperVO

getTerms() - Method in class bb.common.SalesOrderVO

getTerms() - Method in class bb.common.ShipperInfoVO

getTerms() - Method in class bb.common.ShipperVO

getTerms() - Method in class bb.common.TransferOrderListResult

getTerms() - Method in class bb.common.TransferOrderVO

getTerms() - Method in class bb.common.TransferReceiverListResult

getTerms() - Method in class bb.common.TransferReceiverVO

getTerms() - Method in class bb.common.TransferShipperListResult

getTerms() - Method in class bb.common.TransferShipperVO

getTerms() - Method in class bb.common.WorkOrderVO

getTermsConditionFiles(String) - Method in interface bb.common.box.CompanyBox

getTermsConditionsByOrderType(String) - Method in interface bb.common.box.CompanyBox

getTermsConditionsInfoByOrderType(String) - Method in interface bb.common.box.CompanyBox

getTermsDiscount() - Method in class bb.common.AccountsPayableInfoVO

getTermsDiscount() - Method in class bb.common.AccountsPayableVO

getTermsDiscountDay() - Method in class bb.common.AccountsPayableInfoVO

getTermsDiscountDay() - Method in class bb.common.AccountsPayableVO

getTermsDiscountPercent() - Method in class bb.common.AccountsPayableInfoVO

getTermsDiscountPercent() - Method in class bb.common.AccountsPayableVO

getTermUsed(String) - Method in interface bb.common.box.CompanyBox

getTermValue() - Method in class bb.common.TermAgent

getTermValue() - Method in class bb.common.TermVO

getTerritory() - Method in class bb.common.CustomerVendorAddressVO

getTerritory() - Method in class bb.common.SalesOrderItemListResult

getTestingMailto() - Method in class bb.common.SGCompanyVO

getTestReport() - Method in class bb.common.POSurveyReportItemVO

getThirdParty() - Method in class bb.common.CorrectiveActionRequestVO

getThirdParty() - Method in class bb.common.PreventiveActionRequestVO

getThisMonth() - Method in class bb.common.SalesInfoCenter.DueSoCount

getThisMonth() - Method in class bb.common.SalesInfoCenter.DueSoSum

getThisMonth() - Method in class bb.common.SalesInfoCenter.GrossMargin

getThisMonth() - Method in class bb.common.SalesInfoCenter.InvoicedSum

getThisMonth() - Method in class bb.common.SalesInfoCenter.OpenSoSum

getThisMonth() - Method in class bb.common.SalesInfoCenter.SoCount

getThisMonth() - Method in class bb.common.SalesInfoCenter.SoCountWithPartsOnhold

getThisMonth() - Method in class bb.common.SalesInfoCenter.SoItemCount

getThisMonth() - Method in class bb.common.SalesInfoCenter.SoTotalSum

getThrs() - Method in class bb.common.TaskVO

getTimeCards() - Method in class bb.common.EmployeeTimeCardResult

getTimeCardsByVendorId(String) - Method in interface bb.common.box.ManufacturingBox

getTimeCardsCountByWO(String) - Method in interface bb.common.box.ManufacturingBox

getTimeDetailResult(WorkOrderItemPK) - Method in interface bb.common.box.WorkOrderBox

getTimeOff() - Method in class bb.common.WorkOrderItemTimeDetailVO

getTimeOff() - Method in class bb.common.WorkOrderTimeCardVO

getTimeOn() - Method in class bb.common.WorkOrderItemTimeDetailVO

getTimeOn() - Method in class bb.common.WorkOrderTimeCardVO

getTimePeriod() - Method in class bb.common.WCLoadByDateResult

getTimePeriod() - Method in class bb.common.WCLoadOnDateResult

getTimePeriod() - Method in class bb.common.WorkCalendarVO

getTimestamp() - Method in class bb.common.DocumentLogVO

getTimezero() - Method in class bb.common.SGCompanyVO

getTimeZone() - Method in class bb.common.CompanyVO

getTimeZoneString(boolean) - Static method in class bb.common.BB2Util

getTitemNumber() - Method in class bb.common.BB2RefdocPK

getTitemNumber() - Method in class bb.common.PosRefdocVO

getTitemNumber() - Method in class bb.common.RefdocVO

getTItemPK(RefdocVO, Class<?>) - Static method in class bb.common.BB2Util

getTitle() - Method in class bb.common.CustomEmployeeTrainVO

getTitle() - Method in class bb.common.CustomerVendorContactVO

getTitle() - Method in class bb.common.EmployeeTrainingVO

getTitle() - Method in class bb.common.ManufacturerContactVO

getTmin() - Method in class bb.common.TaskVO

getTmonth() - Method in class bb.common.TaskVO

getTMonthYear() - Method in class bb.common.GLCheckRegisterResult

getTn1() - Method in class bb.common.AccountPayableCheckVO

getTn1() - Method in class bb.common.AccountReceivablePaymentVO

getTn2() - Method in class bb.common.AccountPayableCheckVO

getTn2() - Method in class bb.common.AccountReceivablePaymentVO

getTnDate() - Method in class bb.common.CustomAssetVO

getToAddressId() - Method in class bb.common.BB2PartInSTOItemResult

getToAddressId() - Method in class bb.common.TransferOrderListResult

getToAddressId() - Method in class bb.common.TransferOrderVO

getToAddressId() - Method in class bb.common.TransferReceiverItemListResult

getToAddressId() - Method in class bb.common.TransferReceiverListResult

getToAddressId() - Method in class bb.common.TransferReceiverVO

getToAddressId() - Method in class bb.common.TransferShipperListResult

getToAddressId() - Method in class bb.common.TransferShipperVO

getToAddressInfo() - Method in class bb.common.TransferOrderVO

getToAddressInfo() - Method in class bb.common.TransferReceiverVO

getToAddressInfo() - Method in class bb.common.TransferShipperVO

getToAddressName() - Method in class bb.common.TransferShipperListResult

getToBeAsm() - Method in class bb.common.WorkOrderItemListResult

getToBePaid() - Method in class bb.common.AccountPayableCheckRunItemVO

getToCompanyTime() - Method in class bb.common.CustomEmployeeVO

getToDate() - Method in class bb.common.ApCheckRunItemAgent

getToDate() - Method in class bb.common.ApPrepaymentCheckRunItemAgent

getToDate() - Method in class bb.common.ArPaymentRunItemAgent

getToDate() - Method in class bb.common.ArPrepaymentRunItemAgent

getToDate() - Method in class bb.common.ARPrepaymentWireTransferAgent

getToDate() - Method in class bb.common.EmployeeEducationVO

getToDate() - Method in class bb.common.EmployeeWorkExperienceVO

getToDate() - Method in class bb.common.POAndWOStatusResult

getToDate() - Method in class bb.common.PrepaymentWireTransferAgent

getToDate() - Method in class bb.common.WireTransferAgent

getToDate() - Method in class bb.common.WorkCenterLoadAgent

getToDate() - Method in class bb.common.WorkCenterRunTimeAgent

getToDate() - Method in class bb.common.WorkCenterRunTimeTotalResult

getToDate() - Method in class bb.common.WorkOrderItemCanAssyAgent

getToItemNumber() - Method in class bb.common.ReceivedToOrderItem

getToItemNumber() - Method in class bb.common.ReceiverItemDetailAgent

getToLocation() - Method in class bb.common.TransferOrderItemListResult

getToLocation() - Method in class bb.common.TransferOrderItemVO

getTool() - Method in class bb.common.ToolListInfoVO

getToolBasicInfo(PartPK) - Method in interface bb.common.box.ManufacturingBox

getToolBasicInfo(PartPK, String) - Method in interface bb.common.box.ManufacturingBox

getToolBasicInfo() - Method in class bb.common.PurchaseWorkSheetItemWithRelatedInfoResult

getToolBasicInfo() - Method in class bb.common.ToolWhereUsedResult

getToolBasicInfo() - Method in class bb.common.WorkOrderWorkSheetItemWithRelatedInfoResult

getToolByPk(PartPK) - Method in interface bb.common.box.ManufacturingBox

getToolCalibrationsByPartCount(PartPK) - Method in interface bb.common.box.ManufacturingBox

getToolDescription() - Method in class bb.common.ToolCalibrateListResult

getToolInfo() - Method in class bb.common.InventoryAdjustmentDetailResult

getToolInventoryByPk(PartPK) - Method in interface bb.common.box.ManufacturingBox

getToolInventoryInfo() - Method in class bb.common.InventoryAdjustmentDetailResult

getToolInventoryVO() - Method in class bb.common.PurchaseWorkSheetItemWithRelatedInfoResult

getToolInventoryVO() - Method in class bb.common.WorkOrderWorkSheetItemWithRelatedInfoResult

getToolList(BillPK) - Method in interface bb.common.box.ManufacturingBox

getToolListDetailCostResult(BillPK, String) - Method in interface bb.common.box.ManufacturingBox

getToolListInfo() - Method in class bb.common.ToolListDetailCostResult

getToolListInfo() - Method in class bb.common.ToolListItemVO

getToolListItemCount(BillPK) - Method in interface bb.common.box.ManufacturingBox

getToolListItems(BillItemPK) - Method in interface bb.common.box.ManufacturingBox

getToolListItems() - Method in class bb.common.ToolListDetailCostResult

getToolListItemWithToolInfoByBillItemPk(BillItemPK, String) - Method in interface bb.common.box.ManufacturingBox

getToolListsCountByBillNumberLike(String, String) - Method in interface bb.common.box.ManufacturingBox

getToolListsPickList(BillPK, BigDecimal) - Method in interface bb.common.box.WarehouseBox

getToolListWithToolInfoByBillPk(BillPK, String) - Method in interface bb.common.box.ManufacturingBox

getToolNumber() - Method in class bb.common.WorkInstructionSequenceVO

getToolNumber() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getToolOnhands(PartPK) - Method in interface bb.common.box.ManufacturingBox

getToolOnhandVo() - Method in class bb.common.ToolOnhandWithAverageCostResult

getToolsCountByDescriptionInside(String) - Method in interface bb.common.box.ManufacturingBox

getToolsCountByDescriptionStart(String) - Method in interface bb.common.box.ManufacturingBox

getToolsCountByManufacturerId(String) - Method in interface bb.common.box.ManufacturingBox

getToolsCountByManufacturerPn(String) - Method in interface bb.common.box.ManufacturingBox

getToolsCountByOnHold() - Method in interface bb.common.box.ManufacturingBox

getToolsCountByToolLike(String, String, String) - Method in interface bb.common.box.ManufacturingBox

getToolsWithDrawingCount() - Method in interface bb.common.box.ManufacturingBox

getToolsWithToolListCount() - Method in interface bb.common.box.ManufacturingBox

getToolsWithWICount() - Method in interface bb.common.box.ManufacturingBox

getToolUnit() - Method in class bb.common.CompanyVO

getToolWhereUsedItemResult() - Method in class bb.common.ToolWhereUsedResult

getToolWithExcessiveInventoryListResultsCount(String, String) - Method in interface bb.common.box.WarehouseBox

getToolWithWipQtyListResultsCount(String, String) - Method in interface bb.common.box.WarehouseBox

getToOrderNumber() - Method in class bb.common.ReceivedToOrderItem

getToOrderNumber() - Method in class bb.common.ReceiverItemDetailAgent

getTopOrder() - Method in class bb.common.WoItemPickListResult

getToPositionTime() - Method in class bb.common.CustomEmployeeVO

getToQty() - Method in class bb.common.VendorQtyPriceVO

getTorderNumber() - Method in class bb.common.BB2RefdocPK

getTorderNumber() - Method in class bb.common.PosRefdocVO

getTorderNumber() - Method in class bb.common.RefdocVO

getTotal() - Method in class bb.common.AccountInfoCenterItemResult

getTotal() - Method in class bb.common.BudgetListResult

getTotal() - Method in class bb.common.EmployeeLaborAgent

getTotal() - Method in class bb.common.ExpenseVO

getTotal() - Method in class bb.common.MoneyInDrawResult

getTotal() - Method in class bb.common.OnhandQualityResult

getTotal() - Method in class bb.common.PrepayAgent

getTotal() - Method in class bb.common.SalesOrderItemCustomerTotalResult

getTotal() - Method in class bb.common.WCLoadDetailResult

getTotal() - Method in class bb.common.WorkOrderItemTimeDetailResult

getTotalAdjustMoney() - Method in class bb.common.InventoryAuditReportResult

getTotalAdjustQty() - Method in class bb.common.InventoryAuditReportResult

getTotalAmount() - Method in class bb.common.AmountsStatementResult

getTotalAmount() - Method in class bb.common.GeneralLedgerPrintResult

getTotalAmount() - Method in class bb.common.IncomeByMonthChartResult

getTotalApply() - Method in class bb.common.ARPrepayAllStatementsListResult

getTotalAsmStandardCost() - Method in class bb.common.WorkOrderItemListResult

getTotalAsmWeight() - Method in class bb.common.WorkOrderItemListResult

getTotalAssets() - Method in class bb.common.AccountingBalanceSheetResult

getTotalAssets() - Method in class bb.common.BalanceSheetSideBySideResult

getTotalAssets() - Method in class bb.common.ClosingStatementResult

getTotalAuditPartInQACount(String, String, String) - Method in interface bb.common.box.WarehouseBox

getTotalaverageCost() - Method in class bb.common.BillSalesOfCostResult

getTotalaverageCost() - Method in class bb.common.BillSalesXResult

getTotalAvgCost() - Method in class bb.common.BillItemSalesCostResult

getTotalAvgCost() - Method in class bb.common.InventoryNotUsedTotal

getTotalAvgCost() - Method in class bb.common.PartOnhandResult

getTotalAvgCost() - Method in class bb.common.PartWithOnLoanQtyListResult

getTotalAvgCost() - Method in class bb.common.PartWithQtyListResult

getTotalAvgCost() - Method in class bb.common.PoReceiverByDateSummaryResult

getTotalBalance() - Method in class bb.common.CustomerStatementTotalResult

getTotalByAvgCost() - Method in class bb.common.HistoricalInventoryTotalResult

getTotalByStdCost() - Method in class bb.common.HistoricalInventoryTotalResult

getTotalCashAvailiable() - Method in class bb.common.TwelveMonthCashFlowReportResult

getTotalCheck() - Method in class bb.common.PaymentRunItemTotalResult

getTotalCommission() - Method in class bb.common.ArCommissionListResult

getTotalCost() - Method in class bb.common.AccountsReceivableInfoVO

getTotalCost() - Method in class bb.common.AccountsReceivableVO

getTotalCost() - Method in class bb.common.InventoryPartInOutDetailListResult

getTotalCost() - Method in class bb.common.QuoteVO

getTotalCost() - Method in class bb.common.SalesMarginListResult

getTotalCost() - Method in class bb.common.SalesOrderVO

getTotalCost() - Method in class bb.common.ScrapReportVO

getTotalCost() - Method in class bb.common.TransferOrderListResult

getTotalCost() - Method in class bb.common.TransferOrderVO

getTotalCost() - Method in class bb.common.TransferReceiverVO

getTotalCost() - Method in class bb.common.TransferShipperListResult

getTotalCost() - Method in class bb.common.TransferShipperVO

getTotalCost() - Method in class bb.common.WorkOrderItemListResult

getTotalCost() - Method in class bb.common.WorkOrderItemTimeDetailResult

getTotalCostOfSales() - Method in class bb.common.ProfitLossStatementResult

getTotalCount() - Method in class bb.common.InfoByMonthResult

getTotalCountOnhandQty() - Method in class bb.common.InventoryAuditReportResult

getTotalCredit() - Method in class bb.common.GLApprovalListResult

getTotalCredit() - Method in class bb.common.GLByDateTotalResult

getTotalCurrentAssets() - Method in class bb.common.AccountingBalanceSheetResult

getTotalCurrentAssets() - Method in class bb.common.BalanceSheetSideBySideResult

getTotalCurrentAssets() - Method in class bb.common.ClosingStatementResult

getTotalCurrentLiabilities() - Method in class bb.common.AccountingBalanceSheetResult

getTotalCurrentLiabilities() - Method in class bb.common.ClosingStatementResult

getTotalCurrentLiability() - Method in class bb.common.BalanceSheetSideBySideResult

getTotalDebit() - Method in class bb.common.GLApprovalListResult

getTotalDebit() - Method in class bb.common.GLByDateTotalResult

getTotalDepreciation() - Method in class bb.common.ClosingStatementResult

getTotalDiscount() - Method in class bb.common.CustomerReturnToVendorVO

getTotalDiscount() - Method in class bb.common.OnloanReceiverVO

getTotalDiscount() - Method in class bb.common.PoMessageVO

getTotalDiscount() - Method in class bb.common.PurchaseOrderVO

getTotalDiscount() - Method in class bb.common.QuoteVO

getTotalDiscount() - Method in class bb.common.ReceiverInfoVO

getTotalDiscount() - Method in class bb.common.ReceiverVO

getTotalDiscount() - Method in class bb.common.RequestForRMAVO

getTotalDiscount() - Method in class bb.common.ReturnMaterialAuthorizationVO

getTotalDiscount() - Method in class bb.common.SalesOrderVO

getTotalDiscount() - Method in class bb.common.TotalByDateResult

getTotalDiscount() - Method in class bb.common.VendorTotalAmountInPO

getTotalDue() - Method in class bb.common.AccountAgingTotalResult

getTotalDue() - Method in class bb.common.ARAllStatementsListResult

getTotalDue() - Method in class bb.common.ARPrepayAllStatementsListResult

getTotalDue() - Method in interface bb.common.box.AccountingBox

getTotalDue() - Method in class bb.common.CheckRunItemTotalResult

getTotalDue() - Method in class bb.common.CustomerPrepayStatementListResult

getTotalDue() - Method in class bb.common.CustomerStatementListResult

getTotalDue() - Method in class bb.common.PaymentRunItemTotalResult

getTotalDue() - Method in class bb.common.TotalAmountInPOByRefDoc

getTotalDue() - Method in class bb.common.VendorPrepayStatementListResult

getTotalDue() - Method in class bb.common.VendorStatementListResult

getTotalE() - Method in class bb.common.APAuditListResult

getTotalEquity() - Method in class bb.common.ClosingStatementResult

getTotalExemptions() - Method in class bb.common.ZipcodeTotalsResult

getTotalFixedAssets() - Method in class bb.common.BalanceSheetSideBySideResult

getTotalFixedAssets() - Method in class bb.common.ClosingStatementResult

getTotalFreight() - Method in class bb.common.CustomerReturnToVendorVO

getTotalFreight() - Method in class bb.common.DisassembleWorkOrderVO

getTotalFreight() - Method in class bb.common.OnloanReceiverVO

getTotalFreight() - Method in class bb.common.PoMessageVO

getTotalFreight() - Method in class bb.common.POStatisticsResult

getTotalFreight() - Method in class bb.common.PurchaseOrderVO

getTotalFreight() - Method in class bb.common.QuoteVO

getTotalFreight() - Method in class bb.common.ReceiverInfoVO

getTotalFreight() - Method in class bb.common.ReceiverVO

getTotalFreight() - Method in class bb.common.RequestForQuoteVO

getTotalFreight() - Method in class bb.common.RequestForRMAVO

getTotalFreight() - Method in class bb.common.ReturnMaterialAuthorizationVO

getTotalFreight() - Method in class bb.common.ReturnToVendorVO

getTotalFreight() - Method in class bb.common.SalesOrderVO

getTotalFreight() - Method in class bb.common.TotalByDateResult

getTotalFreight() - Method in class bb.common.VendorTotalAmountInPO

getTotalFreight() - Method in class bb.common.WorkOrderVO

getTotalGeneralAdmin() - Method in class bb.common.ProfitLossStatementResult

getTotalGeneralLedgerBalance() - Method in class bb.common.ClosingStatementResult

getTotalGL() - Method in class bb.common.ApprovedGLResult

getTotalHrs() - Method in class bb.common.WorkCenterLoadListResult

getTotalI() - Method in class bb.common.APAuditListResult

getTotalIncomeFromOperating() - Method in class bb.common.ProfitLossStatementResult

getTotalInQA() - Method in class bb.common.BB2PartTotalInQADetailResult

getTotalInQaAvgCost() - Method in class bb.common.InventoryTotalCostResult

getTotalInQaByAvgCost() - Method in class bb.common.InventoryTotalResult

getTotalInQaByCost() - Method in class bb.common.QualityInfoCenterResult

getTotalInQaByStdCost() - Method in class bb.common.InventoryTotalResult

getTotalInQaListPrice() - Method in class bb.common.InventoryTotalCostResult

getTotalInQAResult(BB2Part) - Method in interface bb.common.box.WarehouseBox

getTotalInQaStdCost() - Method in class bb.common.InventoryTotalCostResult

getTotalInShippingNotArByAvgCost() - Method in class bb.common.InventoryTotalResult

getTotalInShippingNotArByStdCost() - Method in class bb.common.InventoryTotalResult

getTotalInSip() - Method in class bb.common.BB2PartTotalInSipDetailResult

getTotalInSipAvgCost() - Method in class bb.common.InventoryTotalCostResult

getTotalInSipDetail(BB2Part) - Method in interface bb.common.box.WarehouseBox

getTotalInSipListPrice() - Method in class bb.common.InventoryTotalCostResult

getTotalInSipStdCost() - Method in class bb.common.InventoryTotalCostResult

getTotalInSit() - Method in class bb.common.BB2PartTotalInSitDetailResult

getTotalInSitDetail(BB2Part) - Method in interface bb.common.box.WarehouseBox

getTotalInSTO() - Method in class bb.common.BB2PartTotalInSTODetailResult

getTotalInSTOAvgCost() - Method in class bb.common.InventoryTotalCostResult

getTotalInSTODetail(BB2Part) - Method in interface bb.common.box.WarehouseBox

getTotalInSTOListPrice() - Method in class bb.common.InventoryTotalCostResult

getTotalInSTOStdCost() - Method in class bb.common.InventoryTotalCostResult

getTotalInventory() - Method in class bb.common.InventoryListResult

getTotalInventoryAvgCost() - Method in class bb.common.InventoryTotalCostResult

getTotalInventoryListPrice() - Method in class bb.common.InventoryTotalCostResult

getTotalInventoryStdCost() - Method in class bb.common.InventoryTotalCostResult

getTotalInWareHouseByAvgCost() - Method in class bb.common.InventoryTotalResult

getTotalInWareHouseByStdCost() - Method in class bb.common.InventoryTotalResult

getTotalInWip() - Method in class bb.common.BB2PartTotalInWipDetailResult

getTotalInWipAvgCost() - Method in class bb.common.InventoryTotalCostResult

getTotalInWipByAvgCost() - Method in class bb.common.InventoryTotalResult

getTotalInWipByStdCost() - Method in class bb.common.InventoryTotalResult

getTotalInWipDetail(BB2Part) - Method in interface bb.common.box.WarehouseBox

getTotalInWipListPrice() - Method in class bb.common.InventoryTotalCostResult

getTotalInWipStdCost() - Method in class bb.common.InventoryTotalCostResult

getTotalIssue() - Method in class bb.common.WorkOrderIssueStatisticsResult

getTotalIssued() - Method in class bb.common.InventoryReportListResult

getTotalIssued() - Method in class bb.common.PartIssuedListResult

getTotalIssued() - Method in class bb.common.WOIssuedByMonthChartResult

getTotalIssuedCost() - Method in class bb.common.BB2PartByDateResult

getTotalIssuedCost() - Method in class bb.common.DisassembleWorkOrderItemListResult

getTotalIssuedCost(int) - Method in class bb.common.IssueItemAgent

getTotalIssuedCost() - Method in class bb.common.WOIssuedByMonthChartResult

getTotalIssuedCost() - Method in class bb.common.WorkOrderIssuedOrderListResult

getTotalIssuedCost() - Method in class bb.common.WorkOrderItemListResult

getTotalIssuedMoney() - Method in class bb.common.InventoryReportListResult

getTotalIssuedQty() - Method in class bb.common.BB2PartByDateResult

getTotalIssuedQty() - Method in class bb.common.IssueItemAgent

getTotalItemCount() - Method in class bb.common.OntimeDeliveryRateListResult

getTotalItemCount() - Method in class bb.common.OntimeDeliveryRateResult

getTotalItems() - Method in class bb.common.CurrentBalanceResult

getTotalItems() - Method in class bb.common.PartDueAddressListResult

getTotalLabor() - Method in class bb.common.WorkOrderItemTimeDetailResult

getTotalLiabilities() - Method in class bb.common.AccountingBalanceSheetResult

getTotalLiability() - Method in class bb.common.BalanceSheetSideBySideResult

getTotalLiabilityEquity() - Method in class bb.common.BalanceSheetSideBySideResult

getTotalLiabilityesEquity() - Method in class bb.common.AccountingBalanceSheetResult

getTotalLiabilityesEquity() - Method in class bb.common.ClosingStatementResult

getTotallistCost() - Method in class bb.common.BillSalesOfCostResult

getTotallistCost() - Method in class bb.common.BillSalesXResult

getTotalListPrice() - Method in class bb.common.BillItemSalesCostResult

getTotalLocateQty() - Method in class bb.common.PartOnhandResult

getTotalLongTermLiabilities() - Method in class bb.common.ClosingStatementResult

getTotalMargin() - Method in class bb.common.SalesMarginListResult

getTotalMfgTime() - Method in class bb.common.WorkOrderItemLaborCostListResult

getTotalMoney() - Method in class bb.common.InfoByMonthResult

getTotalMoney() - Method in class bb.common.SalesOrderItemCostResult

getTotalNet() - Method in class bb.common.AccountingTotalMoneyResult

getTotalNet() - Method in class bb.common.DuePATotalByVendorResult

getTotalNet() - Method in class bb.common.SalesMarginListResult

getTotalNewCost() - Method in class bb.common.InventoryReportListResult

getTotalNewOnhand() - Method in class bb.common.InventoryReportListResult

getTotalNewOnhand() - Method in class bb.common.PhysicalInventoryListResult

getTotalNewOnhand() - Method in class bb.common.PhysicalInventoryVO

getTotalNonIssueCost() - Method in class bb.common.DisassembleWorkOrderItemListResult

getTotalNonIssueCost() - Method in class bb.common.WorkOrderItemListResult

getTotalNotCompletedSeqBefore() - Method in class bb.common.WCLoadDetailResult

getTotalO() - Method in class bb.common.ARAuditListResult

getTotalOldCost() - Method in class bb.common.InventoryReportListResult

getTotalOldOnhand() - Method in class bb.common.InventoryReportListResult

getTotalOnconsignmentByAvgCost() - Method in class bb.common.InventoryTotalResult

getTotalOnconsignmentByStdCost() - Method in class bb.common.InventoryTotalResult

getTotalOndemand() - Method in class bb.common.BB2PartTotalOndemandDetailResult

getTotalOnDemand() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getTotalOndemand() - Method in class bb.common.PartInMrpListResult

getTotalOnDemand() - Method in class bb.common.ReceivingItemResult

getTotalOndemand() - Method in class bb.common.ShipListItemVOResult

getTotalOndemandDetail(BB2Part) - Method in interface bb.common.box.WarehouseBox

getTotalOnhand() - Method in class bb.common.BB2PartTotalOnhandDetailResult

getTotalOnhand() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getTotalOnhand() - Method in class bb.common.InventoryAdjustmentDetailResult

getTotalOnhand() - Method in class bb.common.IssuingItemResult

getTotalOnhand() - Method in class bb.common.PartOnhandResult

getTotalOnhand() - Method in class bb.common.PartWithOnhandDetailInfoResult

getTotalOnhand() - Method in class bb.common.ReceivingItemResult

getTotalOnhand() - Method in class bb.common.ShipListItemVOResult

getTotalOnhandAvgCost() - Method in class bb.common.InventoryTotalCostResult

getTotalOnhandDetail(BB2Part) - Method in interface bb.common.box.WarehouseBox

getTotalOnhandListPrice() - Method in class bb.common.InventoryTotalCostResult

getTotalOnhandStdCost() - Method in class bb.common.InventoryTotalCostResult

getTotalOnloan() - Method in class bb.common.BB2PartTotalOnloanDetailResult

getTotalOnLoanAvgCost() - Method in class bb.common.InventoryTotalCostResult

getTotalOnloanByAvgCost() - Method in class bb.common.InventoryTotalResult

getTotalOnloanByStdCost() - Method in class bb.common.InventoryTotalResult

getTotalOnLoanListPrice() - Method in class bb.common.InventoryTotalCostResult

getTotalOnLoanResult(BB2Part) - Method in interface bb.common.box.WarehouseBox

getTotalOnLoanStdCost() - Method in class bb.common.InventoryTotalCostResult

getTotalOnorder() - Method in class bb.common.BB2PartTotalOnorderDetailResult

getTotalOnorderDetail(BB2Part) - Method in interface bb.common.box.WarehouseBox

getTotalOpen() - Method in class bb.common.TotalByDateResult

getTotalOpen() - Method in class bb.common.VendorTotalAmountInPO

getTotalOperatingExpense() - Method in class bb.common.ProfitLossStatementResult

getTotalOtherAssets() - Method in class bb.common.BalanceSheetSideBySideResult

getTotalOtherAssets() - Method in class bb.common.ClosingStatementResult

getTotalOtherIncome() - Method in class bb.common.ProfitLossStatementResult

getTotalOtherLiabilities() - Method in class bb.common.ClosingStatementResult

getTotalOtherLiability() - Method in class bb.common.BalanceSheetSideBySideResult

getTotalOutputValue() - Method in class bb.common.OutputValueByMonthResult

getTotalOwnersEquity() - Method in class bb.common.BalanceSheetSideBySideResult

getTotalPages() - Method in class bb.common.CycleCountStatusVO

getTotalPages() - Method in class bb.common.PhysicalInventoryStatusVO

getTotalPaid() - Method in class bb.common.AccountingTotalMoneyResult

getTotalPaid() - Method in class bb.common.CheckRunItemTotalResult

getTotalPaid() - Method in class bb.common.DuePATotalByVendorResult

getTotalPaid() - Method in class bb.common.PaymentAgent

getTotalPaid() - Method in class bb.common.PaymentRunItemTotalResult

getTotalPaid() - Method in class bb.common.PrepayPaymentAgent

getTotalPaidInvoice() - Method in class bb.common.SalesOrderVO

getTotalPaidMap() - Method in class bb.common.PaymentAgent

getTotalPartToAuditCount(String, Date) - Method in interface bb.common.box.WarehouseBox

getTotalPartWithWipQtyCost() - Method in interface bb.common.box.WarehouseBox

getTotalPayOut() - Method in class bb.common.TwelveMonthCashFlowReportResult

getTotalPOByProjectCount(String, String, Date, Date, String, String) - Method in interface bb.common.box.PurchasingBox

getTotalPOByRelatedDocCount(String, String, Date, Date, String, String) - Method in interface bb.common.box.PurchasingBox

getTotalPOItemByRefDoc1Count(String, String, Date, Date, String, String) - Method in interface bb.common.box.PurchasingBox

getTotalPOReceiverResult(String, String, String, String, String, String, Date, Date, String, String, String, String, String[]) - Method in interface bb.common.box.WarehouseBox

getTotalPower() - Method in class bb.common.EquipmentVO

getTotalQty() - Method in class bb.common.AuditPartInQAResult

getTotalQty() - Method in class bb.common.BillItemUsageResult

getTotalQty() - Method in class bb.common.BillWhereUsedResult

getTotalQty() - Method in class bb.common.InventoryPartInOutDetailListResult

getTotalQtyShip() - Method in class bb.common.ShipperItemListResult

getTotalR() - Method in class bb.common.ARAuditListResult

getTotalRec() - Method in class bb.common.WOIssuedByMonthChartResult

getTotalRecCost() - Method in class bb.common.WOIssuedByMonthChartResult

getTotalReceipts() - Method in class bb.common.TwelveMonthCashFlowReportResult

getTotalReceived() - Method in class bb.common.InventoryReportListResult

getTotalReceived() - Method in class bb.common.PartReceivedListResult

getTotalReceived() - Method in class bb.common.VendorTotalAmountInPO

getTotalReceivedCost() - Method in class bb.common.BB2PartByDateResult

getTotalReceivedCost() - Method in class bb.common.DisassembleWorkOrderItemListResult

getTotalReceivedQty() - Method in class bb.common.ReceiverItemAgent

getTotalReceiveQty() - Method in class bb.common.BB2PartByDateResult

getTotalRecMoney() - Method in class bb.common.InventoryReportListResult

getTotalRecOrShip() - Method in class bb.common.TotalByDateResult

getTotalResearchDevelopment() - Method in class bb.common.ProfitLossStatementResult

getTotalReturainedEarnings() - Method in class bb.common.BalanceSheetSideBySideResult

getTotalSales() - Method in class bb.common.SalesMarginListResult

getTotalSales() - Method in class bb.common.ZipcodeTotalsResult

getTotalSalesMarketing() - Method in class bb.common.ProfitLossStatementResult

getTotalSalesRevenue() - Method in class bb.common.ProfitLossStatementResult

getTotalShareholdersEquity() - Method in class bb.common.AccountingBalanceSheetResult

getTotalShippedQty() - Method in class bb.common.ShipperItemAgent

getTotalSOInSipDetail(BB2Part) - Method in interface bb.common.box.SalesBox

getTotalstandardCost() - Method in class bb.common.BillSalesOfCostResult

getTotalstandardCost() - Method in class bb.common.BillSalesXResult

getTotalStandardCost() - Method in class bb.common.TotalByDateResult

getTotalStdCost() - Method in class bb.common.AccountsReceivableInfoVO

getTotalStdCost() - Method in class bb.common.AccountsReceivableVO

getTotalStdCost() - Method in class bb.common.BillItemSalesCostResult

getTotalStdCost() - Method in class bb.common.InventoryNotUsedTotal

getTotalStdCost() - Method in class bb.common.PartOnhandResult

getTotalStdCost() - Method in class bb.common.PartWithOnLoanQtyListResult

getTotalStdCost() - Method in class bb.common.PartWithQtyListResult

getTotalStdCost() - Method in class bb.common.PoReceiverByDateSummaryResult

getTotalStdCost() - Method in class bb.common.QuoteVO

getTotalStdCost() - Method in class bb.common.SalesOrderVO

getTotalTax() - Method in class bb.common.AccountingTotalMoneyResult

getTotaltax() - Method in class bb.common.APTaxForZipcodeListResult

getTotaltax() - Method in class bb.common.ARTaxForZipcodeListResult

getTotalTax() - Method in class bb.common.CustomerReturnToVendorVO

getTotalTax() - Method in class bb.common.DisassembleWorkOrderVO

getTotalTax() - Method in class bb.common.DuePATotalByVendorResult

getTotalTax() - Method in class bb.common.OnloanReceiverVO

getTotalTax() - Method in class bb.common.PoMessageVO

getTotalTax() - Method in class bb.common.POStatisticsResult

getTotalTax() - Method in class bb.common.ProfitLossStatementResult

getTotalTax() - Method in class bb.common.PurchaseOrderVO

getTotalTax() - Method in class bb.common.QuoteVO

getTotalTax() - Method in class bb.common.ReceiverInfoVO

getTotalTax() - Method in class bb.common.ReceiverVO

getTotalTax() - Method in class bb.common.RequestForQuoteVO

getTotalTax() - Method in class bb.common.RequestForRMAVO

getTotalTax() - Method in class bb.common.ReturnMaterialAuthorizationVO

getTotalTax() - Method in class bb.common.ReturnToVendorVO

getTotalTax() - Method in class bb.common.SalesOrderVO

getTotalTax() - Method in class bb.common.TotalByDateResult

getTotalTax() - Method in class bb.common.VendorTotalAmountInPO

getTotalTax() - Method in class bb.common.WorkOrderVO

getTotalTax() - Method in class bb.common.ZipcodeTotalsResult

getTotalToBeAsmStandardCost() - Method in class bb.common.WorkOrderItemListResult

getTotalToBeAsmWeight() - Method in class bb.common.WorkOrderItemListResult

getTotalToBePaid() - Method in class bb.common.CheckRunItemTotalResult

getTotalToPaid() - Method in class bb.common.MakeCheckAgent

getTotalToPaid() - Method in class bb.common.MakePrepaymentCheckAgent

getTotalUsageDetail(BB2Part, boolean) - Method in interface bb.common.box.WarehouseBox

getTotalVarOnhandQty() - Method in class bb.common.InventoryAuditReportResult

getTotalWageLabor() - Method in class bb.common.ProfitLossStatementResult

getTotalWeight() - Method in class bb.common.WOReceiverDetail

getTotalWeight() - Method in class bb.common.WorkOrderItemListResult

getTotalWireFee() - Method in class bb.common.ARPaymentRunVO

getTotalWorkOrderInstructionSeq(String, String, String, String) - Method in interface bb.common.box.WorkOrderBox

getTotControlCost() - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

getTotControlCost() - Method in class bb.common.WOItemCostControlAgent

getTotControlCost() - Method in class bb.common.WorkOrderItemPartDetailResult

getTotControlCost() - Method in class bb.common.WorkOrderItemReviewCostResult

getTotCurrentMDepreciate() - Method in class bb.common.DepreciateMonthlyReport

getTotInSIPQty() - Method in class bb.common.InSipAudittListResult

getTotIssued() - Method in class bb.common.PartIssueTotalResult

getTotIssuedAvgCost() - Method in class bb.common.PartIssueTotalResult

getTotIssuedStdCost() - Method in class bb.common.PartIssueTotalResult

getTotLastMDepreciate() - Method in class bb.common.DepreciateMonthlyReport

getTotNewCost() - Method in class bb.common.CycleCountListTotalResult

getTotNewCost() - Method in class bb.common.PhysicalInventoryListTotalResult

getTotNewOnhand() - Method in class bb.common.CycleCountListTotalResult

getTotNewOnhand() - Method in class bb.common.PhysicalInventoryListTotalResult

getTotOnhand() - Method in class bb.common.InventoryCycleResult

getTotPackingBoxNumber() - Method in class bb.common.ShipperAgent

getTotPFSIPQty() - Method in class bb.common.InSipAudittListResult

getTotSoSIPQty() - Method in class bb.common.InSipAudittListResult

getTotSystemCost() - Method in class bb.common.CycleCountListTotalResult

getTotSystemCost() - Method in class bb.common.PhysicalInventoryListTotalResult

getTotSystemOnhand() - Method in class bb.common.CycleCountListTotalResult

getTotSystemOnhand() - Method in class bb.common.PhysicalInventoryListTotalResult

getTotVarCost() - Method in class bb.common.DepreciateMonthlyReport

getTotVarDepreciate() - Method in class bb.common.DepreciateMonthlyReport

getTraceable() - Method in class bb.common.BomItemWithOEMResult

getTraceable() - Method in class bb.common.PartBasicInfo

getTraceable() - Method in class bb.common.PartVO

getTraceable() - Method in class bb.common.PartWhereUsedItemResult

getTraceable() - Method in class bb.common.PartWithManufacturerInfoResult

getTraceable() - Method in class bb.common.PartWithOnhandsVO

getTraceable() - Method in class bb.common.PurchaseOrderItemVO

getTraceable() - Method in class bb.common.SalesOrderItemVO

getTraceableCategoriesByPartCount(String, String, int, String[], Short[]) - Method in interface bb.common.box.EngineeringBox

getTraceableCategoriesByPk(String) - Method in interface bb.common.box.EngineeringBox

getTraceableCategoryItem() - Method in class bb.common.PartTraceableCategoryPK

getTraceableLevel() - Method in class bb.common.BillItemWithPartInfoResult

getTraceableLevel() - Method in class bb.common.BillWithPartInfoResult

getTraceableLevel() - Method in class bb.common.PartTraceableInfoResult

getTraceableLevel() - Method in class bb.common.PartTraceableListResult

getTraceableLevel() - Method in class bb.common.PartTraceableResult

getTraceableLevel() - Method in class bb.common.PartVO

getTraceableLevel() - Method in class bb.common.PartWhereUsedItemResult

getTraceableLevel() - Method in class bb.common.PartWithOnhandDetailInfoResult

getTraceableLevel() - Method in class bb.common.PartWithOnhandsVO

getTraceableLevel() - Method in class bb.common.PurchaseOrderItemVO

getTraceableLevel() - Method in class bb.common.SalesOrderItemVO

getTraceableSpecsByPk(Short) - Method in interface bb.common.box.EngineeringBox

getTracking() - Method in class bb.common.AccountsPayableInfoVO

getTracking() - Method in class bb.common.AccountsPayableVO

getTracking() - Method in class bb.common.AccountsReceivableInfoVO

getTracking() - Method in class bb.common.AccountsReceivableVO

getTracking() - Method in class bb.common.MakeInvoiceAgent

getTracking() - Method in class bb.common.OnloanReceiverVO

getTracking() - Method in class bb.common.OnloanShipperVO

getTracking() - Method in class bb.common.PfReceiverVO

getTracking() - Method in class bb.common.ProformaInvoiceVO

getTracking() - Method in class bb.common.ReceiverInfoVO

getTracking() - Method in class bb.common.ReceiverVO

getTracking() - Method in class bb.common.RMAReceiverVO

getTracking() - Method in class bb.common.RtvShipperInfoVO

getTracking() - Method in class bb.common.RtvShipperVO

getTracking() - Method in class bb.common.ShipperAgent

getTracking() - Method in class bb.common.ShipperInfoVO

getTracking() - Method in class bb.common.ShipperVO

getTracking() - Method in class bb.common.SwapReceiverListResult

getTracking() - Method in class bb.common.SwapReceiverVO

getTracking() - Method in class bb.common.SwapShipperListResult

getTracking() - Method in class bb.common.SwapShipperVO

getTracking() - Method in class bb.common.TransferReceiverListResult

getTracking() - Method in class bb.common.TransferReceiverVO

getTracking() - Method in class bb.common.TransferShipperListResult

getTracking() - Method in class bb.common.TransferShipperVO

getTrackingLog() - Method in class bb.common.IssueItemDetailAgent

getTrackingLog() - Method in class bb.common.PuttoInQAAgent

getTrackingLog() - Method in class bb.common.RebackInQAAgent

getTrackingLog() - Method in class bb.common.ReceiverItemAgent

getTrackingLog() - Method in class bb.common.ReceiverItemDetailAgent

getTrackingLog() - Method in class bb.common.ShipperItemAgent

getTrackingLog() - Method in class bb.common.ShipperItemDetailAgent

getTrackingNumber() - Method in class bb.common.LogTrackingVO

getTrackingNumber() - Method in class bb.common.PartTrackingPK

getTrackingNumber() - Method in class bb.common.ReceiverAgent

getTrackingNumber() - Method in class bb.common.ReceiverItemTrackingLogAgent

getTrackings() - Method in class bb.common.DisassembleWorkOrderIssueVO

getTrackings() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

getTrackings() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getTrackings() - Method in class bb.common.NonproductivePickingItemIssuedVO

getTrackings() - Method in class bb.common.OnloanReceiverItemVO

getTrackings() - Method in class bb.common.OnloanShipperItemVO

getTrackings() - Method in class bb.common.PackingBoxItemVO

getTrackings() - Method in class bb.common.PackingBoxSalesOrderItemAgent

getTrackings() - Method in class bb.common.PartIssuedVO

getTrackings() - Method in class bb.common.PartReceivedVO

getTrackings() - Method in class bb.common.ReceiverItemDetailAgent

getTrackings() - Method in class bb.common.ReceiverItemVO

getTrackings() - Method in class bb.common.RMAReceiverItemVO

getTrackings() - Method in class bb.common.RtvShipperItemVO

getTrackings() - Method in class bb.common.ShipperItemDetailAgent

getTrackings() - Method in class bb.common.ShipperItemVO

getTrackings() - Method in class bb.common.SwapReceiverItemVO

getTrackings() - Method in class bb.common.SwapShipperItemVO

getTrackings() - Method in class bb.common.TransferReceiverItemVO

getTrackings() - Method in class bb.common.TransferShipperItemVO

getTrackings() - Method in class bb.common.WorkOrderReceiverVO

getTradeAccount() - Method in class bb.common.AccountingBalanceSheetResult

getTrainComments() - Method in class bb.common.CustomEmployeeVO

getTrainDate() - Method in class bb.common.CustomEmployeeTrainVO

getTrainDate() - Method in class bb.common.EmployeeTrainingVO

getTransactionAmount() - Method in class bb.common.CustomerStatementResult

getTransactionByNCRNumber(String) - Method in interface bb.common.box.QualityBox

getTransactionCountByAPNumber(String) - Method in interface bb.common.box.AccountingBox

getTransactionCountByAppNumber(String) - Method in interface bb.common.box.AccountingBox

getTransactionCountByARNumber(String) - Method in interface bb.common.box.AccountingBox

getTransactionCountByArpNumber(String) - Method in interface bb.common.box.AccountingBox

getTransactionCountByDMNumber(String) - Method in interface bb.common.box.AccountingBox

getTransactionCountByPONumber(String) - Method in interface bb.common.box.AccountingBox

getTransactionCountBySONumber(String) - Method in interface bb.common.box.AccountingBox

getTransactionDate() - Method in class bb.common.AccountCreditVO

getTransactionDate() - Method in class bb.common.AccountDebitVO

getTransactionDate() - Method in class bb.common.AccountPayableCheckRunVO

getTransactionDate() - Method in class bb.common.AccountsCreditDebitListResult

getTransactionDate() - Method in class bb.common.AddPayableWithoutReceiverAgent

getTransactionDate() - Method in class bb.common.ARPaymentRunVO

getTransactionDate() - Method in class bb.common.ARPrepaymentWireTransferAgent

getTransactionDate() - Method in class bb.common.GeneralLedgerByDateListResult

getTransactionDate() - Method in class bb.common.GeneralLedgerListResult

getTransactionDate() - Method in class bb.common.GeneralLedgerPrintResult

getTransactionDate() - Method in class bb.common.GeneralLedgerResult

getTransactionDate() - Method in class bb.common.GeneralLedgerVO

getTransactionDate() - Method in class bb.common.GLApprovalListResult

getTransactionDate() - Method in class bb.common.GLItemVO

getTransactionDate() - Method in class bb.common.JounalEntryListResult

getTransactionDate() - Method in class bb.common.PrepaymentWireTransferAgent

getTransactionDate() - Method in class bb.common.WireTransferAgent

getTransactionEDate() - Method in class bb.common.APAuditListResult

getTransactionIDate() - Method in class bb.common.APAuditListResult

getTransactionInvoices() - Method in class bb.common.CustomerStatementResult

getTransactionNo() - Method in class bb.common.AccountPayableCheckRunItemVO

getTransactionNo() - Method in class bb.common.AccountsCreditDebitListResult

getTransactionNo() - Method in class bb.common.ARPaymentRunItemVO

getTransactionNumber() - Method in class bb.common.AccountCreditDebitPK

getTransactionNumber() - Method in class bb.common.ApCheckRunListResult

getTransactionNumber() - Method in class bb.common.ARPaymentRunListResult

getTransactionNumber() - Method in class bb.common.AssetDepreciateVO

getTransactionNumber() - Method in class bb.common.ChangeStdCostWorkSheetVO

getTransactionNumber() - Method in class bb.common.DisassembleWorkOrderIssueVO

getTransactionNumber() - Method in class bb.common.ExchangeAuditResult

getTransactionNumber() - Method in class bb.common.GeneralLedgerListResult

getTransactionNumber() - Method in class bb.common.GeneralLedgerResult

getTransactionNumber() - Method in class bb.common.GeneralLedgerVO

getTransactionNumber() - Method in class bb.common.JounalEntryListResult

getTransactionNumber() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getTransactionNumber() - Method in class bb.common.NonproductivePickingItemIssuedVO

getTransactionNumber() - Method in class bb.common.NonproductivePickingItemVO

getTransactionNumber() - Method in class bb.common.PartIssuedVO

getTransactionNumber() - Method in class bb.common.PartReceivedVO

getTransactionNumber() - Method in class bb.common.RollUpBomStdCostWorkSheetVO

getTransactionNumber() - Method in class bb.common.ScrapReportVO

getTransactionNumber() - Method in class bb.common.WorkOrderItemPartDetailInWipVO

getTransactionNumber() - Method in class bb.common.WorkOrderReceiverVO

getTransactionODate() - Method in class bb.common.ARAuditListResult

getTransactionRDate() - Method in class bb.common.ARAuditListResult

getTransactionType() - Method in class bb.common.AccountCreditVO

getTransactionType() - Method in class bb.common.AccountDebitVO

getTransactionType() - Method in class bb.common.AccountingTransactionTypeVO

getTransactionType() - Method in class bb.common.AccountsCreditDebitListResult

getTransactionType() - Method in class bb.common.GeneralLedgerListResult

getTransactionType() - Method in class bb.common.GeneralLedgerResult

getTransactionType() - Method in class bb.common.GeneralLedgerVO

getTransactionType() - Method in class bb.common.GLItemVO

getTransactionTypeDescription() - Method in class bb.common.GeneralLedgerListResult

getTransactionTypeDescription() - Method in class bb.common.GeneralLedgerVO

getTransferDate() - Method in class bb.common.CustomEmployeeVO

getTransferDate() - Method in class bb.common.EmployeeCardVO

getTransferOrderApprovalByEmployeeId(String) - Method in interface bb.common.box.WarehouseBox

getTransferOrderByDateCount(String, String, String, String, String, Date, Date) - Method in interface bb.common.box.WarehouseBox

getTransferOrderByPk(String) - Method in interface bb.common.box.WarehouseBox

getTransferOrderDate() - Method in class bb.common.TransferOrderListResult

getTransferOrderDate() - Method in class bb.common.TransferOrderVO

getTransferOrderItemNumber() - Method in class bb.common.TransferOrderItemListResult

getTransferOrderItemNumber() - Method in class bb.common.TransferOrderItemPK

getTransferOrderItems() - Method in class bb.common.TransferOrderVO

getTransferOrderItemsByDateCount(String, String, String, String, String, String, Date, Date) - Method in interface bb.common.box.WarehouseBox

getTransferOrderNumber() - Method in class bb.common.TransferOrderItemListResult

getTransferOrderNumber() - Method in class bb.common.TransferOrderItemPK

getTransferOrderNumber() - Method in class bb.common.TransferOrderListResult

getTransferOrderNumber() - Method in class bb.common.TransferOrderVO

getTransferOrderNumber() - Method in class bb.common.TransferReceiverListResult

getTransferOrderNumber() - Method in class bb.common.TransferReceiverVO

getTransferOrderNumber() - Method in class bb.common.TransferShipperListResult

getTransferOrderNumber() - Method in class bb.common.TransferShipperVO

getTransferOrderShippingResult(String) - Method in interface bb.common.box.WarehouseBox

getTransferQty() - Method in class bb.common.TransferOrderItemListResult

getTransferQty() - Method in class bb.common.TransferOrderItemVO

getTransferQty() - Method in class bb.common.TransferReceiverItemListResult

getTransferQty() - Method in class bb.common.TransferReceiverItemVO

getTransferQty() - Method in class bb.common.TransferShipperItemListResult

getTransferQty() - Method in class bb.common.TransferShipperItemVO

getTransferReceiverById(String) - Method in interface bb.common.box.WarehouseBox

getTransferReceiverItemByPk(TransferReceiverItemPK) - Method in interface bb.common.box.WarehouseBox

getTransferReceiverItemNumber() - Method in class bb.common.TransferReceiverItemListResult

getTransferReceiverItemNumber() - Method in class bb.common.TransferReceiverItemPK

getTransferReceiverItems() - Method in class bb.common.TransferReceiverVO

getTransferReceiverItemsByDate(String, String, String, String, String, Date, Date, String, String) - Method in interface bb.common.box.WarehouseBox

getTransferReceiverListResultsbyDateCount(String, String, String, String, String, String, Date, Date) - Method in interface bb.common.box.WarehouseBox

getTransferReceiverNumber() - Method in class bb.common.TransferReceiverItemListResult

getTransferReceiverNumber() - Method in class bb.common.TransferReceiverItemPK

getTransferReceiverNumber() - Method in class bb.common.TransferReceiverListResult

getTransferReceiverNumber() - Method in class bb.common.TransferReceiverVO

getTransferReceivingResult(String) - Method in interface bb.common.box.WarehouseBox

getTransferShipper(String) - Method in interface bb.common.box.WarehouseBox

getTransferShipperByDateCount(String, String, String, String, String, Date, Date) - Method in interface bb.common.box.WarehouseBox

getTransferShipperItemByPk(TransferShipperItemPK) - Method in interface bb.common.box.WarehouseBox

getTransferShipperItemNumber() - Method in class bb.common.TransferShipperItemListResult

getTransferShipperItemNumber() - Method in class bb.common.TransferShipperItemPK

getTransferShipperItems() - Method in class bb.common.TransferShipperVO

getTransferShipperItemsByDateCount(String, String, String, String, String, String, String, String, Date, Date) - Method in interface bb.common.box.WarehouseBox

getTransferShipperNumber() - Method in class bb.common.InspectionConformanceReportVO

getTransferShipperNumber() - Method in class bb.common.TransferReceiverListResult

getTransferShipperNumber() - Method in class bb.common.TransferReceiverVO

getTransferShipperNumber() - Method in class bb.common.TransferShipperItemListResult

getTransferShipperNumber() - Method in class bb.common.TransferShipperItemPK

getTransferShipperNumber() - Method in class bb.common.TransferShipperListResult

getTransferShipperNumber() - Method in class bb.common.TransferShipperVO

getTransferType() - Method in class bb.common.TransferOrderVO

getTRefDocString(RefdocVO) - Static method in class bb.common.BB2Util

getTroubleRev() - Method in class bb.common.SGDocPartVO

getTroubleshooting() - Method in class bb.common.SGDocPartVO

getTrueName() - Method in class bb.common.OperationLogVO

getType() - Method in class bb.common.AccountsChartAdvanceCategoryVO

getType() - Method in class bb.common.AccountsChartVO

getType() - Method in class bb.common.AppColumnVO

getType() - Method in class bb.common.BizBoxUserEmployeeResult

getType() - Method in class bb.common.BizboxUserListResult

getType() - Method in class bb.common.BizboxUserVO

getType() - Method in class bb.common.CompanyUnitVO

getType() - Method in class bb.common.CustomerVendorAddressInfoVO

getType() - Method in class bb.common.CustomerVendorAddressVO

getType() - Method in class bb.common.CustomerVendorContactVO

getType() - Method in class bb.common.CV2CVAgent

getType() - Method in class bb.common.EquipmentListResult

getType() - Method in class bb.common.EquipmentVO

getType() - Method in class bb.common.ExpenseAccountVO

getType() - Method in class bb.common.ExpenseItemVO

getType() - Method in class bb.common.MaintenanceItemVO

getType() - Method in class bb.common.OperationLogVO

getType() - Method in class bb.common.PartMaterialListResult

getType() - Method in class bb.common.PartMaterialReportAgent

getType() - Method in class bb.common.PartMaterialVO

getType() - Method in class bb.common.ProfitLossStatementItemResult

getType() - Method in class bb.common.PurchaseOrderContractResult

getType() - Method in class bb.common.SgClientProgramUserVO

getType() - Method in class bb.common.User2UserAgent

getUnbilledAccount() - Method in class bb.common.AccountingSettingsVO

getUnbilledExchange() - Method in class bb.common.ShipperItemVO

getUnbilledIncomeAccount() - Method in class bb.common.AccountingSettingsVO

getUnDepreciatedAccm() - Method in class bb.common.AssetDepreciateVO

getUndepreciatedBalance() - Method in class bb.common.AssetDepreciateDetailReport

getUndepreciatedBalance() - Method in class bb.common.AssetDepreciateVO

getUnit() - Method in class bb.common.AccountsPayableItemVO

getUnit() - Method in class bb.common.AccountsReceivableItemVO

getUnit() - Method in class bb.common.BB2PartByDateResult

getUnit() - Method in class bb.common.BB2PartTotalOnhandDetailResult

getUnit() - Method in class bb.common.BillItemSalesResult

getUnit() - Method in class bb.common.BillItemSalesXResult

getUnit() - Method in class bb.common.BillSalesResult

getUnit() - Method in class bb.common.BillSalesXResult

getUnit() - Method in class bb.common.BomItemWithOEMResult

getUnit() - Method in class bb.common.BomWithOEMResult

getUnit() - Method in class bb.common.CustomEmployeeVO

getUnit() - Method in class bb.common.CustomerReturnToVendorItemVO

getUnit() - Method in class bb.common.CustomGoodsBreedVO

getUnit() - Method in class bb.common.CycleCountListResult

getUnit() - Method in class bb.common.DisassembleWorkOrderIssueVO

getUnit() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

getUnit() - Method in class bb.common.DisassembleWorkOrderItemListResult

getUnit() - Method in class bb.common.DisassembleWorkOrderItemPartDetailItemResult

getUnit() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

getUnit() - Method in class bb.common.DisassembleWorkOrderItemVO

getUnit() - Method in class bb.common.DisassembleWorkOrderReceivingResult

getUnit() - Method in class bb.common.InspectionConformanceReportItemCheckVO

getUnit() - Method in class bb.common.InspectionTypeItemVO

getUnit() - Method in class bb.common.InventoryNotUsedInMonthsforAppResult

getUnit() - Method in class bb.common.InventoryPartInOutDetailListResult

getUnit() - Method in class bb.common.IssuingResult

getUnit() - Method in class bb.common.NonproductivePickingItemIssuedListResult

getUnit() - Method in class bb.common.NonproductivePickingItemIssuedVO

getUnit() - Method in class bb.common.NonproductivePickingItemResult

getUnit() - Method in class bb.common.NonproductivePickingItemVO

getUnit() - Method in class bb.common.OnLoanItemVO

getUnit() - Method in class bb.common.OnloanReceiverItemListResult

getUnit() - Method in class bb.common.OnloanReceiverItemVO

getUnit() - Method in class bb.common.OnloanShipperItemVO

getUnit() - Method in class bb.common.OrderApprovalItemsVO

getUnit() - Method in class bb.common.OrderDemandForReceiverResult

getUnit() - Method in class bb.common.PartInspectionVO

getUnit() - Method in class bb.common.PartIssuedVO

getUnit() - Method in class bb.common.PartManufacturerVO

getUnit() - Method in class bb.common.PartOnhandCostVO

getUnit() - Method in class bb.common.PartReceivedVO

getUnit() - Method in class bb.common.PartUnitPK

getUnit() - Method in class bb.common.PartWithInventoryInfoListResult

getUnit() - Method in class bb.common.PfReceiverItemVO

getUnit() - Method in class bb.common.PhysicalInventoryListResult

getUnit() - Method in class bb.common.POSurveyReportItemVO

getUnit() - Method in class bb.common.ProformaInvoiceItemListResult

getUnit() - Method in class bb.common.ProformaInvoiceItemVO

getUnit() - Method in class bb.common.PurchaseOrderItemListResult

getUnit() - Method in class bb.common.PurchaseOrderItemVO

getUnit() - Method in class bb.common.QuoteItemListResult

getUnit() - Method in class bb.common.QuoteItemVO

getUnit() - Method in class bb.common.ReceiverItemVO

getUnit() - Method in class bb.common.ReceivingItemResult

getUnit() - Method in class bb.common.RequestForQuoteItemListResult

getUnit() - Method in class bb.common.RequestForQuoteItemVO

getUnit() - Method in class bb.common.RequestForRMAItemVO

getUnit() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getUnit() - Method in class bb.common.ReturnToVendorByDateListResult

getUnit() - Method in class bb.common.ReturnToVendorItemListResult

getUnit() - Method in class bb.common.ReturnToVendorItemVO

getUnit() - Method in class bb.common.RMAReceiverItemListResult

getUnit() - Method in class bb.common.RMAReceiverItemVO

getUnit() - Method in class bb.common.RtvShipperItemVO

getUnit() - Method in class bb.common.RunningAccountOrderItemVO

getUnit() - Method in class bb.common.SalesBomItemResult

getUnit() - Method in class bb.common.SalesBomResult

getUnit() - Method in class bb.common.SalesOrderItemInfoVO

getUnit() - Method in class bb.common.SalesOrderItemListResult

getUnit() - Method in class bb.common.SalesOrderItemVO

getUnit() - Method in class bb.common.SalesOrderShipDateListResult

getUnit() - Method in class bb.common.SalesPartListItemResult

getUnit() - Method in class bb.common.SalesPartListResult

getUnit() - Method in class bb.common.SGBOMItemResult

getUnit() - Method in class bb.common.SGCustRequestForQuoteItemResult

getUnit() - Method in class bb.common.SGPartCatalogResult

getUnit() - Method in class bb.common.SGPartListItemResult

getUnit() - Method in class bb.common.SGPartListResult

getUnit() - Method in class bb.common.SGQuoteCartListResult

getUnit() - Method in class bb.common.SGSaleItemVO

getUnit() - Method in class bb.common.ShipperItemVO

getUnit() - Method in class bb.common.ShippingItemResult

getUnit() - Method in class bb.common.SwapOrderItemVO

getUnit() - Method in class bb.common.SwapReceiverItemVO

getUnit() - Method in class bb.common.SwapShipperItemVO

getUnit() - Method in class bb.common.TransferOrderItemVO

getUnit() - Method in class bb.common.TransferReceiverItemListResult

getUnit() - Method in class bb.common.TransferReceiverItemVO

getUnit() - Method in class bb.common.TransferShipperItemListResult

getUnit() - Method in class bb.common.TransferShipperItemVO

getUnit() - Method in class bb.common.WorkOrderItemIssuedTotalResult

getUnit() - Method in class bb.common.WorkOrderItemIssueVO

getUnit() - Method in class bb.common.WorkOrderItemListResult

getUnit() - Method in class bb.common.WorkOrderItemPartDetail

getUnit() - Method in class bb.common.WorkOrderItemPartDetailItemResult

getUnit() - Method in class bb.common.WorkOrderItemTimeDetailVO

getUnit() - Method in class bb.common.WorkOrderItemVO

getUnit() - Method in class bb.common.WorkOrderReceiverVO

getUnitByPk(Long) - Method in interface bb.common.box.EngineeringBox

getUnitName() - Method in class bb.common.UnitVO

getUnitPrice() - Method in class bb.common.InvoiceItemListResult

getUnitPrice() - Method in class bb.common.RunningAccountOrderItemVO

getUnitQty() - Method in class bb.common.RunningAccountOrderItemVO

getUnits() - Static method in class bb.common.Constant.CycleCountPeriodUnit

getUnits() - Method in class bb.common.PartVO

getUnits() - Method in class bb.common.RunningAccountOrderItemVO

getUnitsCount(String) - Method in interface bb.common.box.EngineeringBox

getUnitTotal() - Method in class bb.common.AccountingTotalMoneyResult

getUnitTotal() - Method in class bb.common.DuePATotalByVendorResult

getUnixHome() - Method in class bb.common.SGCompanyVO

getUnreadReceivedMessagesCount() - Method in interface bb.common.box.CompanyBox

getUpcaseDescription() - Method in class bb.common.CompanyVO

getUpcaseWorkInstructionSeq() - Method in class bb.common.CompanyVO

getUpLevelAccount() - Method in class bb.common.AccountBalanceResult

getUpLevelAccount() - Method in class bb.common.AccountsChartVO

getUpLevelAccount() - Method in class bb.common.BudgetListResult

getUpLevelAccountNumber() - Method in class bb.common.BalanceSheetSideBySideItemResult

getUpLevelAccountNumber() - Method in class bb.common.ClosingStatementItemResult

getUpLevelAccountNumber() - Method in class bb.common.ExchangeAuditItemResult

getUpLevelAccountNumber() - Method in class bb.common.ProfitLossStatementItemResult

getUpLevelUnitId() - Method in class bb.common.CompanyUnitVO

getUploadDate() - Method in class bb.common.AddressQualityDocumentsVO

getUploadTime() - Method in class bb.common.NCRPictureVO

getUsageQty() - Method in class bb.common.BillItemUsagePathResult

getUsageQty() - Method in class bb.common.MrpByMonthResult

getUsedDate() - Method in class bb.common.BOMCanAssyAgent

getUser() - Method in class bb.common.AssetUsageVO

getUser() - Method in class bb.common.CustomAssetRecordVO

getUser() - Method in class bb.common.SGClientAccountPK

getUser() - Method in class bb.common.SGLogLoginVO

getUser() - Method in class bb.common.TempArApAgingVO

getUserByPk(String) - Method in interface bb.common.box.SecurityBox

getUserBySelf() - Method in interface bb.common.box.SecurityBox

getUserCompany() - Method in class bb.common.SGClientAccountVO

getUserCompany() - Method in class bb.common.SGLogLoginVO

getUserEmail(String) - Method in interface bb.common.box.SalesBox

getUserEmail() - Method in class bb.common.SGCartCheckOutResult

getUserEmail() - Method in class bb.common.SGCartLogin

getUserEmail() - Method in class bb.common.SgClientProgramUserVO

getUserEmail() - Method in class bb.common.SGCustRequestForQuoteListResult

getUserEmail() - Method in class bb.common.SGCustRequestForQuoteResult

getUserEmail() - Method in class bb.common.SGCustRequestForQuoteVO

getUserEmail() - Method in class bb.common.SGQuoteAddressResult

getUserEmail() - Method in class bb.common.SGQuoteAddressVO

getUserEmail() - Method in class bb.common.SGQuoteCartVO

getUserEmail() - Method in class bb.common.SGQuoteLoginVO

getUserEmail() - Method in class bb.common.VendorGroupUserVO

getUserGroup() - Method in class bb.common.GroupUserPK

getUserGroupByPk(String) - Method in interface bb.common.box.CompanyBox

getUserIp() - Method in class bb.common.SGLogLoginVO

getUserIp() - Method in class bb.common.SGQuoteLoginVO

getUserLanguage() - Method in class bb.common.SGLogLoginVO

getUserName() - Method in class bb.common.AccountingInfoDocumentVO

getUserName() - Method in class bb.common.BB2Login

getUsername() - Method in class bb.common.BizBoxServer

getUserName() - Method in class bb.common.BizBoxUserEmployeeResult

getUserName() - Method in class bb.common.BizboxUserListResult

getUserName() - Method in class bb.common.BizboxUserVO

getUserName() - Method in class bb.common.BomApprovalVO

getUserName() - Method in class bb.common.DisassembleWorkOrderApprovalVO

getUserName() - Method in class bb.common.DisassembleWorkOrderIssuingResult

getUserName() - Method in class bb.common.DocumentLogVO

getUserName() - Method in class bb.common.DocumentServerVO

getUserName() - Method in class bb.common.DwfUploadSettingsVO

getUserName() - Method in class bb.common.DwgUploadSettingsVO

getUserName() - Method in class bb.common.ECNReviewVO

getUserName() - Method in class bb.common.ECRReviewVO

getUserName() - Method in class bb.common.EmployeeCardVO

getUserName() - Method in class bb.common.EmployeeEducationResult

getUserName() - Method in class bb.common.EngGroupUserVO

getUserName() - Method in class bb.common.ExpenseListResult

getUserName() - Method in class bb.common.ExpenseVO

getUserName() - Method in class bb.common.GeneralLedgerApprovalVO

getUserName() - Method in class bb.common.GroupUserPK

getUserName() - Method in class bb.common.MiscDocumentSettingVO

getUserName() - Method in class bb.common.MyPrintListPK

getUserName() - Method in class bb.common.NcrApprovalVO

getUserName() - Method in class bb.common.NonproductivePickingApprovalVO

getUserName() - Method in class bb.common.NonproductivePickingApproveVO

getUserName() - Method in class bb.common.NoticeUserEmployeeListResult

getUserName() - Method in class bb.common.OnloanReviewVO

getUserName() - Method in class bb.common.OpCodeShortcutPK

getUserName() - Method in class bb.common.OperationLogVO

getUserName() - Method in class bb.common.PurchaseOrderApprovalVO

getUserName() - Method in class bb.common.QualityGroupPK

getUserName() - Method in class bb.common.ReceivingResult

getUserName() - Method in class bb.common.RMAReviewVO

getUserName() - Method in class bb.common.RTVApprovalVO

getUserName() - Method in class bb.common.SalesmanVO

getUserName() - Method in class bb.common.SalesOrderReviewVO

getUserName() - Method in class bb.common.SGClientAccountVO

getUserName() - Method in class bb.common.SgClientProgramUserVO

getUserName() - Method in class bb.common.SGLogLoginVO

getUserName() - Method in class bb.common.SmtpServerVO

getUserName() - Method in class bb.common.SubcompanyLoginAgent

getUserName() - Method in class bb.common.SwapOrderApprovalVO

getUserName() - Method in class bb.common.TransferOrderApprovalVO

getUserName() - Method in class bb.common.User2UserAgent

getUserName() - Method in class bb.common.UserRolePermissionListResult

getUserName() - Method in class bb.common.UserRolePK

getUserName() - Method in class bb.common.VendorGroupUserVO

getUserName() - Method in class bb.common.WorkOrderApprovalVO

getUserPassword() - Method in class bb.common.DocumentServerVO

getUserPassword() - Method in class bb.common.DwfUploadSettingsVO

getUserPassword() - Method in class bb.common.DwgUploadSettingsVO

getUserPassword() - Method in class bb.common.MiscDocumentSettingVO

getUserPasswordPairs(String) - Method in interface bb.common.box.CompanyBox

getUserRoleCountByPermission(String) - Method in interface bb.common.box.SecurityBox

getUsersByEmployeeIdCount(String) - Method in interface bb.common.box.SecurityBox

getUsersCount(String, int, Date, Date, int, int) - Method in interface bb.common.box.SecurityBox

getUsersCountByPermission(String) - Method in interface bb.common.box.SecurityBox

getUsersCountByRole(String) - Method in interface bb.common.box.SecurityBox

getUsersCountByUserName(String) - Method in interface bb.common.box.SecurityBox

getUsersMultiCompanyUnit(String) - Method in interface bb.common.box.SecurityBox

getUseType() - Method in class bb.common.PartUseTypeVO

getUsingDate() - Method in class bb.common.CustomAssetVO

getUsingDepartmentList() - Method in interface bb.common.box.AccountingBox

getUsingLife() - Method in class bb.common.AssetDepreciateDetailReport

getUsingLife() - Method in class bb.common.AssetDepreciateVO

getUsingLife() - Method in class bb.common.AssetVO

getUsingStatus() - Method in class bb.common.AssetDepreciateVO

getUsingStatus() - Method in class bb.common.AssetVO

getUsingStatus() - Method in class bb.common.DepreciateMonthlyReport

getUsingUnit() - Method in class bb.common.CustomAssetVO

getValidate() - Method in class bb.common.DataFilterVO

getValidateCode() - Method in class bb.common.BB2Notice

getValidateCode() - Method in class bb.common.PoMessageListResult

getValidateCode() - Method in class bb.common.PoMessageVO

getValidateCode() - Method in class bb.common.RfqMessageListResult

getValidateCode() - Method in class bb.common.RfqMessageVO

getValidDate() - Method in class bb.common.CustomerVendorAddressInfoVO

getValidDate() - Method in class bb.common.CustomerVendorAddressVO

getValidDate() - Method in class bb.common.RunningAccountOrderVO

getValidDate() - Method in class bb.common.ZipcodeTotalsResult

getValidFrom() - Method in class bb.common.EngineeringSharingVO

getValidThru() - Method in class bb.common.CPItemFromQuoteResult

getValidThru() - Method in class bb.common.QuoteListResult

getValidThru() - Method in class bb.common.QuoteVO

getValidTo() - Method in class bb.common.EngineeringSharingVO

getValidTransactionDate() - Method in class bb.common.GeneralLedgerSettingsVO

getValuationStorageAccount() - Method in class bb.common.AccountingSettingsVO

getValue() - Method in class bb.common.AddRTVAgent

getValue() - Method in class bb.common.Money

getValue() - Method in class bb.common.ServerClientPropertyVO

getValueOfCustomField(String) - Method in class bb.common.VO

getVariance() - Method in class bb.common.ExchangeAuditItemResult

getVariance() - Method in class bb.common.PartCostVarianceListResult

getVarianceAmount() - Method in class bb.common.ChangeStdCostWorkSheetVO

getVarianceAmount() - Method in class bb.common.RollUpBomStdCostWorkSheetVO

getVarianceAMT() - Method in class bb.common.BudgetListResult

getVarianceAMTTotal() - Method in class bb.common.BudgetListResult

getVarianceAMTYTD() - Method in class bb.common.BudgetListResult

getVarianceCost() - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

getVarianceCost() - Method in class bb.common.PartInventoryVO

getVarianceCost() - Method in class bb.common.WOItemCostControlAgent

getVarianceCost() - Method in class bb.common.WorkOrderItemPartDetailResult

getVarianceCost() - Method in class bb.common.WorkOrderItemReviewCostResult

getVarianceCount() - Method in class bb.common.RollUpBomStdCostWorkSheetVO

getVariancePercent() - Method in class bb.common.ChangeStdCostWorkSheetItemVO

getVariancePercent() - Method in class bb.common.PartCostVarianceListResult

getVariancePercentage() - Method in class bb.common.BudgetListResult

getVariancePercentageTotal() - Method in class bb.common.BudgetListResult

getVariancePercentageYTD() - Method in class bb.common.BudgetListResult

getVendId() - Method in class bb.common.PurchaseWorkSheetItemVO

getVendId() - Method in class bb.common.WorkOrderWorkSheetItemVO

getVendIdWritein() - Method in class bb.common.PurchaseWorkSheetItemVO

getVendIdWritein() - Method in class bb.common.WorkOrderWorkSheetItemVO

getVendor() - Method in class bb.common.PurchaseOrderContractResult

getVendorAcknowledge() - Method in class bb.common.PurchaseOrderVO

getVendorAddressesByIdCount(String) - Method in interface bb.common.box.AddressBox

getVendorAddressesByNameCount(String) - Method in interface bb.common.box.AddressBox

getVendorAddressInfo() - Method in class bb.common.ApPrepayVO

getVendorAddressInfo() - Method in class bb.common.DisassembleWorkOrderVO

getVendorAddressInfo() - Method in class bb.common.InspectionConformanceReportVO

getVendorAddressInfo() - Method in class bb.common.PfReceiverVO

getVendorAddressInfo() - Method in class bb.common.PurchaseOrderVO

getVendorAddressInfo() - Method in class bb.common.ReceiverVO

getVendorAddressInfo() - Method in class bb.common.RequestForQuoteVO

getVendorAddressInfo() - Method in class bb.common.ReturnToVendorVO

getVendorAddressInfo() - Method in class bb.common.RtvShipperVO

getVendorAddressInfo() - Method in class bb.common.SwapOrderVO

getVendorAddressInfo() - Method in class bb.common.SwapReceiverVO

getVendorAddressInfo() - Method in class bb.common.SwapShipperVO

getVendorAddressInfo() - Method in class bb.common.WorkOrderVO

getVendorAddressInfoVO() - Method in class bb.common.ReceiverInfoVO

getVendorAmount() - Method in class bb.common.AddPayableWithoutReceiverAgent

getVendorApproved() - Method in class bb.common.PoMessageVO

getVendorApprovedBy() - Method in class bb.common.PoMessageVO

getVendorAverageCost() - Method in class bb.common.BillDetailCostResult

getVendorAverageCost() - Method in class bb.common.BillSalesOfCostResult

getVendorAverageCost() - Method in class bb.common.BillSalesXResult

getVendorAverageCost() - Method in class bb.common.ToolListDetailCostResult

getVendorById(String) - Method in interface bb.common.box.AddressBox

getVendorCarrier() - Method in class bb.common.CustomerVendorAddressVO

getVendorCarrierAccount() - Method in class bb.common.CustomerVendorAddressVO

getVendorCategoriesById(String) - Method in interface bb.common.box.AddressBox

getVendorCategoriesCount(String) - Method in interface bb.common.box.AddressBox

getVendorCategory() - Method in class bb.common.CustomerVendorAddressInfoVO

getVendorCategory() - Method in class bb.common.CustomerVendorAddressVO

getVendorCategory() - Method in class bb.common.LockedCustomerAddressResult

getVendorCategory() - Method in class bb.common.VendorCategoriesVO

getVendorComments() - Method in class bb.common.CustomerVendorAddressVO

getVendorContractItemsCountByContractNumber(String) - Method in interface bb.common.box.PurchasingBox

getVendorContractPriceById(String) - Method in interface bb.common.box.PurchasingBox

getVendorContractPriceItem(VendorContractPriceItemPK) - Method in interface bb.common.box.PurchasingBox

getVendorContractPriceVendor(VendorContractPriceVendorPK) - Method in interface bb.common.box.PurchasingBox

getVendorContractsByAddressIdCount(String) - Method in interface bb.common.box.PurchasingBox

getVendorContractsCountByContractNumber(String) - Method in interface bb.common.box.PurchasingBox

getVendorCreditLimit() - Method in class bb.common.CustomerVendorAddressVO

getVendorCriticalLevelById(String) - Method in interface bb.common.box.AddressBox

getVendorCriticalLevelCount(String) - Method in interface bb.common.box.AddressBox

getVendorCurrency() - Method in class bb.common.PartVendorVO

getVendorCurrency() - Method in class bb.common.ToolVendorVO

getVendorDepositBank() - Method in class bb.common.CustomerVendorAddressInfoVO

getVendorDepositBank() - Method in class bb.common.CustomerVendorAddressVO

getVendorDiscount() - Method in class bb.common.CustomerVendorAddressVO

getVendorEmail() - Method in class bb.common.PfReceiverVO

getVendorFlag() - Method in class bb.common.CustomerVendorAddressInfoVO

getVendorFlag() - Method in class bb.common.CustomerVendorAddressVO

getVendorFlag() - Method in class bb.common.LockedCustomerAddressResult

getVendorForWorkOrder(String) - Method in interface bb.common.box.WorkOrderBox

getVendorGroupUser(String) - Method in interface bb.common.box.AddressBox

getVendorHighestCost() - Method in class bb.common.BillDetailCostResult

getVendorHighestCost() - Method in class bb.common.BillSalesOfCostResult

getVendorHighestCost() - Method in class bb.common.BillSalesXResult

getVendorHighestCost() - Method in class bb.common.ToolListDetailCostResult

getVendorId() - Method in class bb.common.AccountPayableCheckRunItemVO

getVendorId() - Method in class bb.common.AccountPayableCheckVO

getVendorId() - Method in class bb.common.AccountPayableInfoWithPrepayResult

getVendorId() - Method in class bb.common.AccountsPayableInfoVO

getVendorId() - Method in class bb.common.AccountsPayableVO

getVendorId() - Method in class bb.common.AddPayableWithoutReceiverAgent

getVendorId() - Method in class bb.common.AddProformaReceiverAgent

getVendorID() - Method in class bb.common.APAuditListResult

getVendorId() - Method in class bb.common.ApCheckRunListResult

getVendorId() - Method in class bb.common.APItemListResult

getVendorId() - Method in class bb.common.APPrepayInfoResult

getVendorId() - Method in class bb.common.ApPrepayVO

getVendorId() - Method in class bb.common.APTaxForZipcodeListResult

getVendorId() - Method in class bb.common.BB2PartInSitItemResult

getVendorId() - Method in class bb.common.CustomerVendorAddressInfoVO

getVendorId() - Method in class bb.common.CustomerVendorAddressVO

getVendorID() - Method in class bb.common.DisassembleWorkOrderIssueVO

getVendorId() - Method in class bb.common.DisassembleWorkOrderIssuingResult

getVendorId() - Method in class bb.common.DisassembleWorkOrderItemListResult

getVendorId() - Method in class bb.common.DisassembleWorkOrderListResult

getVendorId() - Method in class bb.common.DisassembleWorkOrderReceivingResult

getVendorId() - Method in class bb.common.DisassembleWorkOrderVO

getVendorId() - Method in class bb.common.DWOIssueDetail

getVendorId() - Method in class bb.common.EcnPOOrderResult

getVendorId() - Method in class bb.common.EcnWOOrderResult

getVendorId() - Method in class bb.common.IcrItemListResult

getVendorId() - Method in class bb.common.IcrListResult

getVendorId() - Method in class bb.common.InspectionConformanceReportItemInfo

getVendorId() - Method in class bb.common.InspectionConformanceReportVO

getVendorId() - Method in class bb.common.IssuingResult

getVendorId() - Method in class bb.common.JobProcessSheetListResult

getVendorId() - Method in class bb.common.JobProcessSheetResult

getVendorId() - Method in class bb.common.MakeAccountPayableAgent

getVendorId() - Method in class bb.common.MakeCheckAgent

getVendorId() - Method in class bb.common.NcrReportListResult

getVendorId() - Method in class bb.common.NonConformanceReportVO

getVendorID() - Method in class bb.common.OrderVendorItem

getVendorId() - Method in class bb.common.PartInWipForIDListResult

getVendorId() - Method in class bb.common.PartIssuedVO

getVendorId() - Method in class bb.common.PartOnhandCostVO

getVendorId() - Method in class bb.common.PartReceivedVO

getVendorId() - Method in class bb.common.PartVendorVO

getVendorId() - Method in class bb.common.PfReceiverItemVO

getVendorId() - Method in class bb.common.PfReceiverVO

getVendorId() - Method in class bb.common.PO2POAgent

getVendorId() - Method in class bb.common.PoMessageListResult

getVendorId() - Method in class bb.common.PoMessageVO

getVendorId() - Method in class bb.common.POReceiverItemListResult

getVendorId() - Method in class bb.common.POStatisticsResult

getVendorId() - Method in class bb.common.POSurveyReportAgent

getVendorId() - Method in class bb.common.POSurveyReportVO

getVendorId() - Method in class bb.common.PrepayAgent

getVendorId() - Method in class bb.common.ProformaReceiverPackingBoxAgent

getVendorId() - Method in class bb.common.PrPackingBoxItemVO

getVendorId() - Method in class bb.common.PrPackingBoxVO

getVendorId() - Method in class bb.common.PrReceiverListResult

getVendorId() - Method in class bb.common.PurchaseOrderCheckListResult

getVendorId() - Method in class bb.common.PurchaseOrderItemListResult

getVendorId() - Method in class bb.common.PurchaseOrderListResult

getVendorId() - Method in class bb.common.PurchaseOrderOnOrderResult

getVendorId() - Method in class bb.common.PurchaseOrderOpenDueListResult

getVendorId() - Method in class bb.common.PurchaseOrderVO

getVendorId() - Method in class bb.common.ReceiverInfoVO

getVendorId() - Method in class bb.common.ReceiverVO

getVendorId() - Method in class bb.common.ReceivingResult

getVendorId() - Method in class bb.common.RequestForQuoteCheckListResult

getVendorId() - Method in class bb.common.RequestForQuoteItemListResult

getVendorId() - Method in class bb.common.RequestForQuoteListResult

getVendorId() - Method in class bb.common.RequestForQuoteVO

getVendorId() - Method in class bb.common.ReturnToVendorByDateListResult

getVendorId() - Method in class bb.common.ReturnToVendorCheckListResult

getVendorId() - Method in class bb.common.ReturnToVendorItemListResult

getVendorId() - Method in class bb.common.ReturnToVendorListResult

getVendorId() - Method in class bb.common.ReturnToVendorVO

getVendorId() - Method in class bb.common.RfqMessageListResult

getVendorId() - Method in class bb.common.RfqMessageVO

getVendorId() - Method in class bb.common.RtvShipperInfoVO

getVendorId() - Method in class bb.common.RtvShipperItemListResult

getVendorId() - Method in class bb.common.RtvShipperListResult

getVendorId() - Method in class bb.common.RtvShipperVO

getVendorId() - Method in class bb.common.ShipListOwnerAttributeVO

getVendorId() - Method in class bb.common.SO2POAgent

getVendorId() - Method in class bb.common.SO2WOAgent

getVendorId() - Method in class bb.common.StockTransactionPOReceiverResult

getVendorId() - Method in class bb.common.StockTransactionWOReceiverResult

getVendorId() - Method in class bb.common.SwapOrderItemListResult

getVendorId() - Method in class bb.common.SwapOrderListResult

getVendorId() - Method in class bb.common.SwapOrderVO

getVendorId() - Method in class bb.common.SwapReceiverListResult

getVendorId() - Method in class bb.common.SwapReceiverVO

getVendorId() - Method in class bb.common.SwapShipperListResult

getVendorId() - Method in class bb.common.SwapShipperOnOrderResult

getVendorId() - Method in class bb.common.SwapShipperVO

getVendorId() - Method in class bb.common.TempReceiverWithoutAPInfo

getVendorId() - Method in class bb.common.ToolVendorVO

getVendorId() - Method in class bb.common.VendorGroupUserVO

getVendorId() - Method in class bb.common.VendorPartPK

getVendorId() - Method in class bb.common.VendorQtyPricePK

getVendorId() - Method in class bb.common.VendorTotalAmountInPO

getVendorId() - Method in class bb.common.WO2WOAgent

getVendorId() - Method in class bb.common.WoItemPickListResult

getVendorId() - Method in class bb.common.WOReceiverDetail

getVendorId() - Method in class bb.common.WorkCenterRunTimeListResult

getVendorId() - Method in class bb.common.WorkCenterVendorPK

getVendorId() - Method in class bb.common.WorkOrderCheckListResult

getVendorID() - Method in class bb.common.WorkOrderItemCanAssyAgent

getVendorId() - Method in class bb.common.WorkOrderItemLaborCostListResult

getVendorId() - Method in class bb.common.WorkOrderItemListResult

getVendorId() - Method in class bb.common.WorkOrderItemReviewCostResult

getVendorId() - Method in class bb.common.WorkOrderItemTimeDetailVO

getVendorID() - Method in class bb.common.WorkOrderItemToIssueResult

getVendorId() - Method in class bb.common.WorkOrderListResult

getVendorId() - Method in class bb.common.WorkOrderOverIssueListResult

getVendorId() - Method in class bb.common.WorkOrderTimeCardVO

getVendorId() - Method in class bb.common.WorkOrderVO

getVendorIncoterm() - Method in class bb.common.CustomerVendorAddressVO

getVendorIncotermPlacePort() - Method in class bb.common.CustomerVendorAddressVO

getVendorInfo() - Method in class bb.common.VendorContractPriceVendorVO

getVendorInvoice() - Method in class bb.common.AccountPayableCheckRunItemVO

getVendorInvoice() - Method in class bb.common.AccountPayableCheckVO

getVendorInvoice() - Method in class bb.common.AccountPayableInfoWithPrepayResult

getVendorInvoice() - Method in class bb.common.AccountsPayableInfoVO

getVendorInvoice() - Method in class bb.common.AccountsPayableVO

getVendorInvoice() - Method in class bb.common.AddPayableWithoutReceiverAgent

getVendorInvoice() - Method in class bb.common.APItemListResult

getVendorInvoice() - Method in class bb.common.ApPrepayVO

getVendorInvoice() - Method in class bb.common.GeneralLedgerByDateListResult

getVendorInvoice() - Method in class bb.common.GeneralLedgerListResult

getVendorInvoice() - Method in class bb.common.GeneralLedgerResult

getVendorInvoice() - Method in class bb.common.GeneralLedgerVO

getVendorInvoice() - Method in class bb.common.ReceiverAgent

getVendorInvoice() - Method in class bb.common.ReceiverInfoVO

getVendorInvoice() - Method in class bb.common.ReceiverShipAgent

getVendorInvoice() - Method in class bb.common.ReceiverVO

getVendorInvoice() - Method in class bb.common.TempArApAgingVO

getVendorInvoice() - Method in class bb.common.VendorStatementListResult

getVendorInvoiceDate() - Method in class bb.common.AccountPayableCheckRunItemVO

getVendorInvoiceDate() - Method in class bb.common.AccountsPayableInfoVO

getVendorInvoiceDate() - Method in class bb.common.AccountsPayableVO

getVendorInvoiceDate() - Method in class bb.common.APAgingItemListResult

getVendorInvoiceDate() - Method in class bb.common.APItemListResult

getVendorInvoiceDate() - Method in class bb.common.MakeAccountPayableAgent

getVendorInvoiceDate() - Method in class bb.common.MakeDebitMemoAgent

getVendorInvoiceDate() - Method in class bb.common.ReceiverAgent

getVendorInvoiceDate() - Method in class bb.common.ReceiverInfoVO

getVendorInvoiceDate() - Method in class bb.common.ReceiverShipAgent

getVendorInvoiceDate() - Method in class bb.common.ReceiverVO

getVendorInvoiceNumber() - Method in class bb.common.MakeAccountPayableAgent

getVendorInvoiceNumber() - Method in class bb.common.MakeDebitMemoAgent

getVendorInvoiceNumber() - Method in class bb.common.PfReceiverItemVO

getVendorInvoiceTotal() - Method in class bb.common.ApPrepayVO

getVendorInvoiceTotal() - Method in class bb.common.MakeAccountPayableAgent

getVendorInvoiceTotal() - Method in class bb.common.MakeDebitMemoAgent

getVendorItem() - Method in class bb.common.PartVendorPK

getVendorItems() - Method in class bb.common.ShipListItemVOResult

getVendorLeadTime() - Method in class bb.common.PartVendorVO

getVendorLeadTime() - Method in class bb.common.ToolVendorVO

getVendorLowestCost() - Method in class bb.common.BillDetailCostResult

getVendorLowestCost() - Method in class bb.common.BillSalesOfCostResult

getVendorLowestCost() - Method in class bb.common.BillSalesXResult

getVendorLowestCost() - Method in class bb.common.ToolListDetailCostResult

getVendorName() - Method in class bb.common.AccountPayableInfoWithPrepayResult

getVendorName() - Method in class bb.common.ApCheckRunListResult

getVendorName() - Method in class bb.common.APPrepayInfoResult

getVendorName() - Method in class bb.common.APTaxForZipcodeListResult

getVendorName() - Method in class bb.common.DisassembleWorkOrderIssuingResult

getVendorName() - Method in class bb.common.DisassembleWorkOrderItemListResult

getVendorName() - Method in class bb.common.DisassembleWorkOrderListResult

getVendorName() - Method in class bb.common.IcrItemListResult

getVendorName() - Method in class bb.common.IcrListResult

getVendorName() - Method in class bb.common.InspectionConformanceReportItemInfo

getVendorName() - Method in class bb.common.PartVendorVO

getVendorName() - Method in class bb.common.POStatisticsResult

getVendorName() - Method in class bb.common.POSurveyReportAgent

getVendorName() - Method in class bb.common.POSurveyReportVO

getVendorName() - Method in class bb.common.PrepayAgent

getVendorName() - Method in class bb.common.PrReceiverListResult

getVendorName() - Method in class bb.common.PurchaseOrderCheckListResult

getVendorName() - Method in class bb.common.PurchaseOrderListResult

getVendorName() - Method in class bb.common.ReceivingResult

getVendorName() - Method in class bb.common.RequestForQuoteCheckListResult

getVendorName() - Method in class bb.common.RequestForQuoteItemListResult

getVendorName() - Method in class bb.common.RequestForQuoteListResult

getVendorName() - Method in class bb.common.ReturnToVendorCheckListResult

getVendorName() - Method in class bb.common.ReturnToVendorItemListResult

getVendorName() - Method in class bb.common.ReturnToVendorListResult

getVendorName() - Method in class bb.common.SwapOrderListResult

getVendorName() - Method in class bb.common.SwapReceiverListResult

getVendorName() - Method in class bb.common.SwapShipperListResult

getVendorName() - Method in class bb.common.TempReceiverWithoutAPInfo

getVendorName() - Method in class bb.common.ToolVendorVO

getVendorName() - Method in class bb.common.WoItemPickListResult

getVendorName() - Method in class bb.common.WorkCenterVendorVO

getVendorName() - Method in class bb.common.WorkOrderCheckListResult

getVendorName() - Method in class bb.common.WorkOrderItemListResult

getVendorName() - Method in class bb.common.WorkOrderListResult

getVendorNotPickRtvShippersCount() - Method in interface bb.common.box.WarehouseBox

getVendorOnTimeDeliveryRate(String, Date, Date, String, int, int, boolean) - Method in interface bb.common.box.PurchasingBox

getVendorOnTimeDeliveryRate(String, Date, Date, int, int) - Method in interface bb.common.box.WorkOrderBox

getVendorOnTimeDeliveryRateCountByVendorId(String, Date, Date, String, int, int, boolean) - Method in interface bb.common.box.PurchasingBox

getVendorOnTimeDeliveryRateCountByVendorId(String, Date, Date, int, int) - Method in interface bb.common.box.WorkOrderBox

getVendorPackage() - Method in class bb.common.AccountsPayableInfoVO

getVendorPackage() - Method in class bb.common.AccountsPayableVO

getVendorPackage() - Method in class bb.common.POReceiverItemListResult

getVendorPackage() - Method in class bb.common.ReceiverInfoVO

getVendorPackage() - Method in class bb.common.ReceiverVO

getVendorPart(VendorPartPK) - Method in interface bb.common.box.WarehouseBox

getVendorPartFrom() - Method in class bb.common.VendorPartPK

getVendorPartNumber() - Method in class bb.common.VendorPartPK

getVendorPartsCount(String, String, String, String, String, String, String) - Method in interface bb.common.box.WarehouseBox

getVendorPartType() - Method in class bb.common.VendorPartPK

getVendorPaymentVarianceAccount() - Method in class bb.common.AccountingSettingsVO

getVendorPrice() - Method in class bb.common.PartVendorVO

getVendorPrice() - Method in class bb.common.ToolVendorVO

getVendorPurchaseOrderByDateCount(String, Date, Date, String, String) - Method in interface bb.common.box.PurchasingBox

getVendorPurchaseOrderItemCount(String, Date, Date, String) - Method in interface bb.common.box.PurchasingBox

getVendorPurchaseOrderItemCountByDate(String, Date, Date, String, String) - Method in interface bb.common.box.PurchasingBox

getVendorPurchases() - Method in class bb.common.PaymentHistoryVO

getVendorQtyPrice(VendorQtyPricePK) - Method in interface bb.common.box.EngineeringBox

getVendorQtyPrices(BB2Part, String) - Method in interface bb.common.box.EngineeringBox

getVendors() - Method in class bb.common.HighUsagePartResult

getVendors() - Method in class bb.common.PartVO

getVendors() - Method in class bb.common.POForWISeqAgent

getVendors() - Method in class bb.common.ToolVO

getVendorSalesOrder() - Method in class bb.common.POStatisticsResult

getVendorSalesOrder() - Method in class bb.common.POSurveyReportAgent

getVendorSalesOrder() - Method in class bb.common.POSurveyReportVO

getVendorSalesOrder() - Method in class bb.common.PurchaseOrderVO

getVendorSet() - Method in class bb.common.ShipListAgent

getVendorShipDate() - Method in class bb.common.POReceiverItemListResult

getVendorShipDate() - Method in class bb.common.ReceiverAgent

getVendorShipDate() - Method in class bb.common.ReceiverInfoVO

getVendorShipDate() - Method in class bb.common.ReceiverVO

getVendorShipper() - Method in class bb.common.MakeAccountPayableAgent

getVendorShipperNumber() - Method in class bb.common.PfReceiverItemVO

getVendorShipperNumber() - Method in class bb.common.ReceiverAgent

getVendorShipperNumber() - Method in class bb.common.ReceiverShipAgent

getVendorShippingDays() - Method in class bb.common.CustomerVendorAddressInfoVO

getVendorShippingDays() - Method in class bb.common.CustomerVendorAddressVO

getVendorShipVia() - Method in class bb.common.CustomerVendorAddressVO

getVendorsListCount(String, String, String, String, String, String) - Method in interface bb.common.box.AddressBox

getVendorsListForSeparateCount(String, String, String, String, String, String) - Method in interface bb.common.box.AddressBox

getVendorSO() - Method in class bb.common.ApPrepayVO

getVendorSO() - Method in class bb.common.PfReceiverVO

getVendorSO() - Method in class bb.common.PrReceiverListResult

getVendorSO() - Method in class bb.common.PrReceiverWithQualityListResult

getVendorSO() - Method in class bb.common.PurchaseOrderContractResult

getVendorSO() - Method in class bb.common.PurchaseOrderListResult

getVendorTaxRate() - Method in class bb.common.CustomerVendorAddressVO

getVendorTerms() - Method in class bb.common.CustomerVendorAddressVO

getVendorTotal() - Method in class bb.common.AccountPayableCheckRunItemVO

getVendorTotal() - Method in class bb.common.AccountPayableInfoWithPrepayResult

getVendorTotal() - Method in class bb.common.AccountsPayableInfoVO

getVendorTotal() - Method in class bb.common.AccountsPayableVO

getVendorTotal() - Method in class bb.common.APAuditListResult

getVendorTotal() - Method in class bb.common.CheckRunItemTotalResult

getVendorTotal() - Method in class bb.common.ReceiverInfoVO

getVendorTotal() - Method in class bb.common.ReceiverVO

getVendorTotalInfo(String) - Method in interface bb.common.box.AddressBox

getVendorType() - Method in class bb.common.CustomerVendorTypeVO

getVendorTypeByType(String) - Method in interface bb.common.box.AddressBox

getVersion() - Method in class bb.common.AccountingSettingsVO

getVersion() - Method in class bb.common.AccountPayableCheckRunItemVO

getVersion() - Method in class bb.common.AccountPayableCheckVO

getVersion() - Method in class bb.common.AccountReceivablePaymentVO

getVersion() - Method in class bb.common.AccountsPayableInfoVO

getVersion() - Method in class bb.common.AccountsPayableVO

getVersion() - Method in class bb.common.AccountsReceivableInfoVO

getVersion() - Method in class bb.common.AccountsReceivableVO

getVersion() - Method in class bb.common.ARPaymentRunItemVO

getVersion() - Method in class bb.common.BB2Document

getVersion() - Method in class bb.common.BillVO

getVersion() - Method in class bb.common.CommonPrintTemplateVO

getVersion() - Method in class bb.common.CorrectiveActionRequestVO

getVersion() - Method in class bb.common.CustomerFeedbackVO

getVersion() - Method in class bb.common.CustomerReturnToVendorVO

getVersion() - Method in class bb.common.CustomerServiceIncidentVO

getVersion() - Method in class bb.common.CustomerVendorAddressVO

getVersion() - Method in class bb.common.DesignControlVO

getVersion() - Method in class bb.common.EmployeeCardVO

getVersion() - Method in class bb.common.EngineeringChangeRequestVO

getVersion() - Method in class bb.common.EngineeringChangeVO

getVersion() - Method in class bb.common.ExpenseVO

getVersion() - Method in class bb.common.GeneralLedgerSettingsVO

getVersion() - Method in class bb.common.InspectionConformanceReportVO

getVersion() - Method in class bb.common.InspectionReportInfoVO

getVersion() - Method in class bb.common.InspectionReportVO

getVersion() - Method in class bb.common.InventoryAdjustmentVO

getVersion() - Method in class bb.common.LabelTemplateVO

getVersion() - Method in class bb.common.ManufacturerAddressVO

getVersion() - Method in class bb.common.NonConformanceCodeVO

getVersion() - Method in class bb.common.NonConformanceReportVO

getVersion() - Method in class bb.common.NonproductivePickingVO

getVersion() - Method in class bb.common.OnLoanItemVO

getVersion() - Method in class bb.common.OnLoanVO

getVersion() - Method in class bb.common.OperatingInstructionsVO

getVersion() - Method in class bb.common.PartCertificateVO

getVersion() - Method in class bb.common.PartDescriptionVO

getVersion() - Method in class bb.common.PartInventoryVO

getVersion() - Method in class bb.common.PartManufacturerVO

getVersion() - Method in class bb.common.PartVendorVO

getVersion() - Method in class bb.common.PartVO

getVersion() - Method in class bb.common.PartWithOnhandsVO

getVersion() - Method in class bb.common.PreventiveActionRequestVO

getVersion() - Method in class bb.common.PrintTemplateVO

getVersion() - Method in class bb.common.QuoteVO

getVersion() - Method in class bb.common.RequestForRMAVO

getVersion() - Method in class bb.common.ReturnMaterialAuthorizationItemVO

getVersion() - Method in class bb.common.ReturnMaterialAuthorizationVO

getVersion() - Method in class bb.common.RMAReceiverVO

getVersion() - Method in class bb.common.RtvShipperInfoVO

getVersion() - Method in class bb.common.RtvShipperVO

getVersion() - Method in class bb.common.SalesOrderItemInfoVO

getVersion() - Method in class bb.common.SalesOrderItemVO

getVersion() - Method in class bb.common.SalesOrderVO

getVersion() - Method in class bb.common.SerialNumberVO

getVersion() - Method in class bb.common.ShipListOwnerVO

getVersion() - Method in class bb.common.ShipListVO

getVersion() - Method in class bb.common.SwapReceiverListResult

getVersion() - Method in class bb.common.SwapReceiverVO

getVersion() - Method in class bb.common.SwapShipperListResult

getVersion() - Method in class bb.common.SwapShipperVO

getVersion() - Method in class bb.common.ToolDescriptionVO

getVersion() - Method in class bb.common.ToolInventoryVO

getVersion() - Method in class bb.common.ToolListVO

getVersion() - Method in class bb.common.ToolManufacturerVO

getVersion() - Method in class bb.common.ToolVendorVO

getVersion() - Method in class bb.common.ToolVO

getVersion() - Method in class bb.common.ToolWithOnhandsVO

getVersion() - Method in class bb.common.TransferOrderVO

getVersion() - Method in class bb.common.WorkInstructionVO

getVersion() - Method in class bb.common.WorkOrderWorkInstructionVO

getVersionInfo() - Method in interface bb.common.Facade

getVersionInfo() - Method in class bb.common.Spiderman

getVersionInfo() - Static method in class bb.common.VersionInformation

getVersionString() - Static method in class bb.common.VersionInformation
the current 2bizbox version string.
getVgAddress() - Method in class bb.common.CompanyVO

getVgPrincipalUserId() - Method in class bb.common.CompanyVO

getVgPrincipalUserName() - Method in class bb.common.CompanyVO

getVgUserCount(String, String) - Method in interface bb.common.box.AddressBox

getVo() - Method in class bb.common.CurrencyAgent

getVolume() - Method in class bb.common.BB2WeightInfoResult

getVolume() - Method in class bb.common.PartBasicInfo

getVolume() - Method in class bb.common.PartVO

getVolume() - Method in class bb.common.PartWithOnhandsVO

getVolume() - Method in class bb.common.SGBOMItemResult

getVolume() - Method in class bb.common.ToolVO

getVolume() - Method in class bb.common.ToolWithOnhandsVO

getVolumeUnit() - Method in class bb.common.BB2WeightInfoResult

getVolumeUnit() - Method in class bb.common.PartBasicInfo

getVolumeUnit() - Method in class bb.common.PartVO

getVolumeUnit() - Method in class bb.common.PartWithOnhandsVO

getVolumeUnit() - Method in class bb.common.SGBOMItemResult

getVolumeUnit() - Method in class bb.common.ToolVO

getVolumeUnit() - Method in class bb.common.ToolWithOnhandsVO

getWageLabor() - Method in class bb.common.ProfitLossStatementResult

getWallDiameter() - Method in class bb.common.PartMaterialReportAgent

getWallOperator() - Method in class bb.common.PartMaterialReportAgent

getWanIp() - Method in class bb.common.DocumentInfoAgent

getWanIp() - Method in class bb.common.LogMiscDocumentVO

getWanIp() - Method in class bb.common.LogPartDocumentVO

getWanIp() - Method in class bb.common.LogPartDwfVO

getWanIp() - Method in class bb.common.LogPartDwgVO

getWanIp() - Method in class bb.common.MiscDocAgent

getWanIp() - Method in class bb.common.OperationLogVO

getWanIp() - Method in class bb.common.PartDwfAgent

getWanIp() - Method in class bb.common.PartDwgAgent

getWareAcceptEmployee() - Method in class bb.common.POSurveyReportVO

getWarehouse() - Method in class bb.common.PartOnhandVO

getWareHouse() - Method in class bb.common.ReceiverAgent

getWareHouse() - Method in class bb.common.ReceiverShipAgent

getWarehouse() - Method in class bb.common.ToolOnhandVO

getWarehouseByPK(String) - Method in interface bb.common.box.WarehouseBox

getWarehouseFromLocation(String, String) - Static method in class bb.common.BB2Util

getWarehouseLocationSplitChar() - Method in class bb.common.CompanyVO

getWarehouseName() - Method in class bb.common.WareHousePartPrefixKeeperVO

getWarehousePrefix() - Method in class bb.common.WarehouseTransferPK

getWarehousePrefix() - Method in class bb.common.WarehouseVO

getWarehousePrefix() - Method in class bb.common.WoItemPickListItemResult

getWarehousePrefixTransferTo() - Method in class bb.common.WarehouseTransferPK

getWareHousingInfoCenterResult() - Method in interface bb.common.box.ManagementBox

getWarning() - Method in class bb.common.DataFilterVO

getWasWiRevised() - Method in class bb.common.WorkInstructionRequestForChangeVO

getWcActivity() - Method in class bb.common.WorkOrderItemTimeDetailVO

getWcDesc() - Method in class bb.common.WorkInstructionSeqAuditListResult

getWcDescription() - Method in class bb.common.JobProcessSheetItemResult

getWcDescription() - Method in class bb.common.WorkInstructionSummaryItemResult

getWcID() - Method in class bb.common.WorkCenterAgent

getWCLoadDetailResults(WCLoadAgent) - Method in interface bb.common.box.ManufacturingBox

getWCLoadDetailResults(String) - Method in interface bb.common.box.ManufacturingBox

getWCLoadDetailResultsforWOItem(WorkOrderItemPK) - Method in interface bb.common.box.ManufacturingBox

getWCLoadIDs(String, String) - Method in interface bb.common.box.ManufacturingBox

getWCLoadOnDate(WorkCenterOnDateAgent) - Method in interface bb.common.box.ManufacturingBox

getWebSite() - Method in class bb.common.CustomerVendorAddressVO

getWebSite() - Method in class bb.common.ManufacturerAddressInfoVO

getWebSite() - Method in class bb.common.ManufacturerAddressVO

getWeight() - Method in class bb.common.BB2PartTotalOnhandDetailResult

getWeight() - Method in class bb.common.BB2WeightInfoResult

getWeight() - Method in class bb.common.PackingBoxItemVO

getWeight() - Method in class bb.common.PartBasicInfo

getWeight() - Method in class bb.common.PartWithOnhandDetailInfoResult

getWeight() - Method in class bb.common.SGBOMItemResult

getWeight() - Method in class bb.common.SGCustRequestForQuoteItemResult

getWeight() - Method in class bb.common.SGPartCatalogResult

getWeight() - Method in class bb.common.SGQuoteCartListResult

getWeight() - Method in class bb.common.WOReceiverDetail

getWeight() - Method in class bb.common.WorkOrderItemListResult

getWeightInfo(HashSet<BB2Part>) - Method in interface bb.common.box.SalesBox

getWeightUnit() - Method in class bb.common.BB2PartTotalOnhandDetailResult

getWeightUnit() - Method in class bb.common.BB2WeightInfoResult

getWeightUnit() - Method in class bb.common.CustomerVendorAddressInfoVO

getWeightUnit() - Method in class bb.common.CustomerVendorAddressVO

getWeightUnit() - Method in class bb.common.PackingBoxVO

getWeightUnit() - Method in class bb.common.PartBasicInfo

getWeightUnit() - Method in class bb.common.PartWithOnhandDetailInfoResult

getWeightUnit() - Method in class bb.common.PrPackingBoxVO

getWeightUnit() - Method in class bb.common.SGBOMItemResult

getWeightUnit() - Method in class bb.common.SGCustRequestForQuoteItemResult

getWeightUnit() - Method in class bb.common.SGPartCatalogResult

getWeightUnit() - Method in class bb.common.SGQuoteCartListResult

getWeightUnit() - Method in class bb.common.SGQuoteCartVO

getWeightUnit() - Method in class bb.common.SGWeightUnitVO

getWeightUnit() - Method in class bb.common.WOReceiverDetail

getWeightUnit() - Method in class bb.common.WorkOrderItemListResult

getWeightUnitByPk(String) - Method in interface bb.common.box.CompanyBox

getWeightUnitName() - Method in class bb.common.WeightUnitVO

getWhatsNew() - Static method in class bb.common.VersionInformation
Get the "what's new" information of this version.
getWhatsNewAdderss() - Static method in class bb.common.VersionInformation
Get the "what's new" address information of this version.
getWi() - Method in class bb.common.BomItemWithOEMResult

getWi() - Method in class bb.common.PartBasicInfo

getWi() - Method in class bb.common.PartVO

getWi() - Method in class bb.common.PartWhereUsedItemResult

getWi() - Method in class bb.common.PartWithInventoryInfoListResult

getWi() - Method in class bb.common.PartWithOnhandsVO

getWi() - Method in class bb.common.ToolVO

getWi() - Method in class bb.common.ToolWhereUsedItemResult

getWi() - Method in class bb.common.ToolWithOnhandsVO

getWI() - Method in class bb.common.WorkOrderQueryInfo

getWiDescription() - Method in class bb.common.WorkInstructionListResult

getWiDescription() - Method in class bb.common.WorkInstructionRequestForChangeVO

getWidth() - Method in class bb.common.BB2Picture

getWidth() - Method in class bb.common.CommonPrintTemplateVO

getWidth() - Method in class bb.common.LabelTemplateItemVO

getWidth() - Method in class bb.common.LabelTemplateVO

getWidth() - Method in class bb.common.MiscDocAgent

getWidth() - Method in class bb.common.PartPictureVO

getWidth() - Method in class bb.common.SGPicturePK

getWidth() - Method in class bb.common.WorkInstructionPictureVO

getWifeName() - Method in class bb.common.SalesmanVO

getWiFlag() - Method in class bb.common.DisassembleWorkOrderItemVO

getWiFlag() - Method in class bb.common.WorkOrderItemVO

getWikiSpaceName() - Method in class bb.common.HelpServerVO

getWiNumber() - Method in class bb.common.WorkInstructionListResult

getWiNumber() - Method in class bb.common.WorkInstructionSequenceListResult

getWipQty() - Method in class bb.common.PurchaseOrderItemListResult

getWipQty() - Method in class bb.common.QuoteItemListResult

getWipQty() - Method in class bb.common.SalesOrderItemListResult

getWireFeeAccount() - Method in class bb.common.ARPaymentRunVO

getWireFeeApNumber() - Method in class bb.common.ARPaymentRunVO

getWireTransferNo() - Method in class bb.common.ARPrepaymentWireTransferAgent

getWireTransferNo() - Method in class bb.common.PrepaymentWireTransferAgent

getWireTransferNo() - Method in class bb.common.WireTransferAgent

getWiRevisedDate() - Method in class bb.common.WorkInstructionRequestForChangeVO

getWiSeqLength() - Method in class bb.common.CompanyVO

getWiSeqPk() - Method in class bb.common.WorkInstructionSeqAuditListResult

getWiSequence() - Method in class bb.common.WorkInstructionRequestForChangeVO

getWiSequenceNumber() - Method in class bb.common.WorkInstructionSequenceListResult

getWiSetId() - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

getWiSetId() - Method in class bb.common.WorkOrderItemPartDetailResult

getWiSetId() - Method in class bb.common.WorkOrderItemTimeDetailResult

getWISetIDs(BB2Part) - Method in interface bb.common.box.WorkOrderBox

getWithPartHoldWOCount() - Method in class bb.common.WorkOrderInfoCenterResult

getWO() - Method in class bb.common.WorkOrderQueryInfo

getWoBoilerplate() - Method in class bb.common.WorkOrderBoilerplateVO

getWoComments() - Method in class bb.common.DisassembleWorkOrderItemListResult

getWoComments() - Method in class bb.common.JobProcessSheetResult

getWoComments() - Method in class bb.common.WorkOrderItemListResult

getWoDate() - Method in class bb.common.WoItemPickListResult

getWoDate() - Method in class bb.common.WorkOrderCheckListResult

getWoDate() - Method in class bb.common.WorkOrderListResult

getWoDebitAccount() - Method in class bb.common.AccountingSettingsVO

getWoDetails() - Method in class bb.common.BB2PartTotalOndemandDetailResult

getWoDetails() - Method in class bb.common.BB2PartTotalOnorderDetailResult

getWoDetails() - Method in class bb.common.PartInMrpListResult

getWoDigits() - Method in class bb.common.CompanyVO

getWoDisc() - Method in class bb.common.WorkOrderItemVO

getWoDisc() - Method in class bb.common.WorkOrderVO

getWoicCost() - Method in class bb.common.WorkOrderReceiverVO

getWoicItem() - Method in class bb.common.WorkOrderTimeCardVO

getWoiDetailInWipCountByGlNumber(String, Date, Date) - Method in interface bb.common.box.WorkOrderBox

getWOInfoByFiscalYear() - Method in interface bb.common.box.ManagementBox

getWOInfoByMonth(int) - Method in interface bb.common.box.ManagementBox

getWoiQquantity() - Method in class bb.common.WOItemPartDetailNotIssue

getWoiQty() - Method in class bb.common.WorkOrderInWipResult

getWoiQtyAsm() - Method in class bb.common.WorkOrderInWipResult

getWoisCost() - Method in class bb.common.WorkOrderItemPartDetailInWipVO

getWoisCost() - Method in class bb.common.WorkOrderReceiverVO

getWoisii() - Method in class bb.common.PartIssuedVO

getWoisItem() - Method in class bb.common.WorkOrderTimeCardVO

getWoisStdCost() - Method in class bb.common.WorkOrderItemPartDetailInWipVO

getWoisStdCost() - Method in class bb.common.WorkOrderReceiverVO

getWoItemCount() - Method in class bb.common.WorkOrderOnTimeItemResult

getWoItemIssuePk() - Method in class bb.common.WoItemPickListItemResult

getWoItemItemPk() - Method in class bb.common.JobProcessSheetListResult

getWoItemNumber() - Method in class bb.common.JobProcessSheetResult

getWoItemPickListResult(WorkOrderItemPK, BigDecimal, String) - Method in interface bb.common.box.WarehouseBox

getWoItemPk() - Method in class bb.common.EcnWOOrderResult

getWoItemPk() - Method in class bb.common.WoItemPickListResult

getWoItemPk() - Method in class bb.common.WorkOrderItemListResult

getWoItemPk() - Method in class bb.common.WorkOrderItemPartDetail

getWoItemPk() - Method in class bb.common.WorkOrderItemPartDetailResult

getWoItemPk() - Method in class bb.common.WorkOrderItemTimeDetailResult

getWoItems() - Method in class bb.common.WOItemPartDetailNotIssue

getWOItemsCanIssueCount(String, boolean, Date, Date, boolean) - Method in interface bb.common.box.WorkOrderBox

getWoItemStatus() - Method in class bb.common.WoItemPickListResult

getWoItemWorkInstructionListResultsCount(String) - Method in interface bb.common.box.ManufacturingBox

getWoItemWorkInstructionListResultsCount(Date, Date) - Method in interface bb.common.box.ManufacturingBox

getWoMade() - Method in class bb.common.WorkOrderItemVO

getWoMade() - Method in class bb.common.WorkOrderVO

getWoNotApprovedOnOrderList() - Method in class bb.common.MrpItemResult

getWoNumber() - Method in class bb.common.JobProcessSheetResult

getWoNumber() - Method in class bb.common.MiscDocAgent

getWoNumber() - Method in class bb.common.NcrReportListResult

getWoNumber() - Method in class bb.common.ScrapReportVO

getWoNumber() - Method in class bb.common.SerialNumberResult

getWoNumber() - Method in class bb.common.StockTransactionWOReceiverResult

getWoNumber() - Method in class bb.common.StockTransactionWOShipperResult

getWoNumber() - Method in class bb.common.WCLoadDetailResult

getWoNumber() - Method in class bb.common.WO2WOAgent

getWoNumber() - Method in class bb.common.WorkOrderCheckListResult

getWoNumber() - Method in class bb.common.WorkOrderDocumentVO

getWoNumber() - Method in class bb.common.WorkOrderItemCanAssyAgent

getWoNumber() - Method in class bb.common.WorkOrderListResult

getWoOnOrderList() - Method in class bb.common.MrpItemOrderDemandRecordsResult

getWoOnOrderList() - Method in class bb.common.MrpItemResult

getWoOpen() - Method in class bb.common.WorkOrderItemVO

getWoOpen() - Method in class bb.common.WorkOrderVO

getWoOrderItems() - Method in class bb.common.EcnCheckOrderResult

getWoPrefix() - Method in class bb.common.CompanyVO

getWoProject() - Method in class bb.common.MrpReportAgent

getWOReceiverItemListResultsOfWorkOrder(String) - Method in interface bb.common.box.WorkOrderBox

getWOReceiverItemsCount(String, String, String, String, String, String, Date, Date, String, String, String[], boolean, String) - Method in interface bb.common.box.WarehouseBox

getWoRequireDate() - Method in class bb.common.WorkOrderWorkInstructionVO

getWorkAddress() - Method in class bb.common.EmployeeCardVO

getWorkAddress() - Method in class bb.common.SalesmanVO

getWorkAge(Date) - Static method in class bb.common.CustomEmployeeVO

getWorkAgeLevel(Date) - Static method in class bb.common.CustomEmployeeVO

getWorkCalendarByPK(Long) - Method in interface bb.common.box.ManufacturingBox

getWorkCenter() - Method in class bb.common.JobProcessSheetItemResult

getWorkCenter() - Method in class bb.common.WCLoadDetailResult

getWorkCenter() - Method in class bb.common.WorkCenterGroupItemVO

getWorkCenter() - Method in class bb.common.WorkCenterLoadListResult

getWorkCenter() - Method in class bb.common.WorkCenterRunTimeAgent

getWorkCenter() - Method in class bb.common.WorkCenterRunTimeListResult

getWorkCenter() - Method in class bb.common.WorkCenterRunTimeTotalResult

getWorkCenter() - Method in class bb.common.WorkInstructionSeqAuditListResult

getWorkCenter() - Method in class bb.common.WorkInstructionSequenceListResult

getWorkCenter() - Method in class bb.common.WorkInstructionSequenceVO

getWorkCenter() - Method in class bb.common.WorkInstructionSummaryItemResult

getWorkCenter() - Method in class bb.common.WorkOrderItemSeqWCLoadResult

getWorkCenter() - Method in class bb.common.WorkOrderItemTimeDetailVO

getWorkCenter() - Method in class bb.common.WorkOrderTimeCardVO

getWorkCenterAgent() - Method in class bb.common.WCLoadAgent

getWorkCenterAgent(String) - Method in class bb.common.WCLoadAgent

getWorkCenterById(String) - Method in interface bb.common.box.ManufacturingBox

getWorkCenterById(String, boolean) - Method in interface bb.common.box.ManufacturingBox

getWorkCenterByWcNumber(String, String, String) - Method in interface bb.common.box.ManufacturingBox

getWorkCenterByWcNumber(String) - Method in interface bb.common.box.ManufacturingBox

getWorkCenterGroupFlag() - Method in class bb.common.WorkCenterVO

getWorkCenterGroupId() - Method in class bb.common.WorkCenterGroupItemPK

getWorkCenterGroupId() - Method in class bb.common.WorkCenterVO

getWorkCenterGroupItemNumber() - Method in class bb.common.WorkCenterGroupItemPK

getWorkCenterId() - Method in class bb.common.EquipmentListResult

getWorkCenterId() - Method in class bb.common.EquipmentVO

getWorkCenterId() - Method in class bb.common.ShipListOwnerAttributeVO

getWorkCenterId() - Method in class bb.common.WC2WCAgent

getWorkCenterId() - Method in class bb.common.WCLoadByDateResult

getWorkCenterId() - Method in class bb.common.WorkCenterGroupItemVO

getWorkCenterId() - Method in class bb.common.WorkCenterVendorPK

getWorkCenterId() - Method in class bb.common.WorkCenterVO

getWorkCenterId() - Method in class bb.common.WorkInstructionRequestForChangeVO

getWorkCenterId() - Method in class bb.common.WorkOrderItemLaborCostListResult

getWorkCenterId() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getWorkCenterItem() - Method in class bb.common.WorkOrderItemSeqWCLoadResult

getWorkCenterItem() - Method in class bb.common.WorkOrderWorkInstructionSequenceDateAgent

getWorkCenterItem() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

getWorkCenterItems() - Method in class bb.common.WorkCenterVO

getWorkCenterLike() - Method in class bb.common.WorkCenterLoadAgent

getWorkCenterLoadListResult(WCLoadAgent) - Method in interface bb.common.box.ManufacturingBox

getWorkCenterLoadResultsCount(WorkCenterLoadAgent) - Method in interface bb.common.box.ManufacturingBox

getWorkCenterOrGroupById(String) - Method in interface bb.common.box.ManufacturingBox

getWorkCenterRunTimeListResultsCount(WorkCenterRunTimeAgent) - Method in interface bb.common.box.ManufacturingBox

getWorkCenterRunTimeTotalResult(WorkCenterRunTimeAgent) - Method in interface bb.common.box.ManufacturingBox

getWorkCenterSet() - Method in class bb.common.ShipListAgent

getWorkCenterType() - Method in class bb.common.WorkCenterVO

getWorkCenterVendors() - Method in class bb.common.WorkCenterVO

getWorkComments() - Method in class bb.common.CustomEmployeeVO

getWorkDate() - Method in class bb.common.WorkCalendarVO

getWorkDate() - Method in class bb.common.WorkPeriodVO

getWorkerCost() - Method in class bb.common.WorkOrderItemLaborCostListResult

getWorkerHoursPerDay() - Method in class bb.common.WorkCenterVO

getWorkerOrderNumber() - Method in class bb.common.PartCertificateVO

getWorkerPay() - Method in class bb.common.WorkCenterVO

getWorkerPerformance() - Method in class bb.common.WorkCenterVO

getWorkerQty() - Method in class bb.common.WorkCenterVO

getWorkFlowByName(String) - Method in interface bb.common.box.CompanyBox

getWorkFlowData() - Method in class bb.common.WorkFlowVO

getWorkFlowName() - Method in class bb.common.WorkFlowVO

getWorkingInfo() - Method in class bb.common.StaffWorkingInformationResult

getWorkInProcessQty() - Method in class bb.common.BB2PartInventoryResult

getWorkInProcessQty() - Method in class bb.common.HistoricalInventoryVO

getWorkInProcessQty() - Method in class bb.common.PartInventoryVO

getWorkInProcessQty() - Method in class bb.common.PartOnHandWithPartBasicInfoResult

getWorkInProcessQty() - Method in class bb.common.PhysicalInventoryListResult

getWorkInProcessQty() - Method in class bb.common.PhysicalInventoryVO

getWorkInProcessQty() - Method in class bb.common.ToolInventoryVO

getWorkInsctructionSequence() - Method in class bb.common.WorkOrderTimeCardVO

getWorkInstructionApprovalByEmployeeID(String) - Method in interface bb.common.box.ManufacturingBox

getWorkInstructionApprovalByEmployeeIDCount(String) - Method in interface bb.common.box.ManufacturingBox

getWorkInstructionByPart(BB2Part, String) - Method in interface bb.common.box.ManufacturingBox

getWorkInstructionByPk(WorkInstructionPK) - Method in interface bb.common.box.ManufacturingBox

getWorkInstructionCountByAuthor(String) - Method in interface bb.common.box.ManufacturingBox

getWorkInstructionCountByStatus(String) - Method in interface bb.common.box.ManufacturingBox

getWorkInstructionDocByID(Long) - Method in interface bb.common.box.ManufacturingBox

getWorkInstructionPictures() - Method in class bb.common.WorkInstructionSequenceVO

getWorkInstructionRev() - Method in class bb.common.WorkInstructionListResult

getWorkInstructionRev() - Method in class bb.common.WorkInstructionSequenceListResult

getWorkInstructionRev() - Method in class bb.common.WorkInstructionVO

getWorkInstructionRev() - Method in class bb.common.WorkOrderWorkInstructionVO

getWorkInstructionsCountByPartLike(String, String, String, String, String, boolean) - Method in interface bb.common.box.ManufacturingBox

getWorkInstructionSeqAuditListResultsCount(String, String, String, String, String) - Method in interface bb.common.box.ManufacturingBox

getWorkInstructionSeqAuditListResultsCount() - Method in interface bb.common.box.ManufacturingBox

getWorkInstructionSeqCountByAuthor(String) - Method in interface bb.common.box.ManufacturingBox

getWorkInstructionSeqCountByWorkCenter(String) - Method in interface bb.common.box.ManufacturingBox

getWorkInstructionSeqCountOnHold() - Method in interface bb.common.box.ManufacturingBox

getWorkInstructionSequence(WorkOrderItemPK, String) - Method in interface bb.common.box.ManufacturingBox

getWorkInstructionSequence() - Method in class bb.common.WorkOrderItemTimeDetailVO

getWorkInstructionSequence() - Method in class bb.common.WorkOrderWorkInstructionSequencePK

getWorkInstructionSeqWithZeroEstHoursCount() - Method in interface bb.common.box.ManufacturingBox

getWorkInstructionSummaryResult(BB2Part, String) - Method in interface bb.common.box.ManufacturingBox

getWorkLoad() - Method in class bb.common.WorkCenterVO

getWorkOrder() - Method in class bb.common.IcrItemListResult

getWorkOrder() - Method in class bb.common.IcrListResult

getWorkOrder() - Method in class bb.common.InspectionConformanceReportItemInfo

getWorkOrder() - Method in class bb.common.InspectionConformanceReportVO

getWorkOrder() - Method in class bb.common.WorkCenterAgent

getWorkOrderAndItemNumber() - Method in class bb.common.OperatingInstructionsUserStatisticalResult

getWorkOrderAndItemNumber() - Method in class bb.common.OperatingInstructionsVO

getWorkOrderApprovalByEmployeeId(String) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderApprovalByUserNumber(String) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderBPByPk(String) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderBPCountByBPId(String) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderByWo(String) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderByWoForIR(String) - Method in interface bb.common.box.QualityBox

getWorkOrderCheckListResultsCount(String) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderComments() - Method in class bb.common.WorkOrderVO

getWorkOrderCostControlBy() - Method in class bb.common.CompanyVO

getWorkOrderCostStart() - Method in class bb.common.CompanyVO

getWorkOrderDocumentByID(Long) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderInfoCenterResult() - Method in interface bb.common.box.ManagementBox

getWorkOrderInstructionSeqCount(String, String, String, String) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderIssuedDetail(WorkOrderItemPK, BB2Part, String) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderIssuedDetailTotal(WorkOrderItemPK, BB2Part, String) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderIssuedOrderCount(WorkOrderItemPK) - Method in interface bb.common.box.WarehouseBox

getWorkOrderItem() - Method in class bb.common.WorkOrderVO

getWorkOrderItemById(WorkOrderItemPK) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderItemByIdForWOLabel(WorkOrderItemPK) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderItemByVendorIdCount(String, Date, Date) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderItemCanAssyResults(WorkOrderItemCanAssyAgent) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderItemComments() - Method in class bb.common.WoItemPickListResult

getWorkOrderItemComments() - Method in class bb.common.WorkOrderItemIssuedTotalResult

getWorkOrderItemComments() - Method in class bb.common.WorkOrderItemVO

getWorkOrderItemInWipListCount(String) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderItemIssueByPk(WorkOrderItemIssuePK) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderItemIssuesCount(WorkOrderItemPK) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderItemIssuingResult(WorkOrderItemPK, boolean) - Method in interface bb.common.box.WarehouseBox

getWorkOrderItemLaborCostCount(Date, Date, String, String, String) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderItemListResultsCount(String, String, String, String, boolean) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderItemListResultsCount(String, String, String) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderItemListResultsCountByDate(String, Date, Date, String, String, String, String[], String, String, String, String, String, String, boolean) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderItemListResultsCountByPartNumberLike(String, String) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderItemListResultsWithoutLikeCount(String, String, String) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderItemListResultsWithPartHoldCount() - Method in interface bb.common.box.WorkOrderBox

getWorkOrderItemMaxReceivableQty(WorkOrderItemPK) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderItemNumber() - Method in class bb.common.EmployeeLaborAgent

getWorkorderItemNumber() - Method in class bb.common.PartInWipForIDListResult

getWorkOrderItemNumber() - Method in class bb.common.PartIssuedVO

getWorkOrderItemNumber() - Method in class bb.common.SGSaleItemVO

getWorkOrderItemNumber() - Method in class bb.common.WOItemPartDetailNotIssue

getWorkOrderItemNumber() - Method in class bb.common.WoItemWorkInstructionListResult

getWorkOrderItemNumber() - Method in class bb.common.WOReceiverDetail

getWorkOrderItemNumber() - Method in class bb.common.WorkCenterRunTimeListResult

getWorkOrderItemNumber() - Method in class bb.common.WorkOrderIssuedOrderListResult

getWorkOrderItemNumber() - Method in class bb.common.WorkOrderItemInfoResult

getWorkOrderItemNumber() - Method in class bb.common.WorkOrderItemInWipListResult

getWorkOrderItemNumber() - Method in class bb.common.WorkOrderItemIssuedTotalResult

getWorkOrderItemNumber() - Method in class bb.common.WorkOrderItemIssuePK

getWorkOrderItemNumber() - Method in class bb.common.WorkOrderItemLaborCostListResult

getWorkOrderItemNumber() - Method in class bb.common.WorkOrderItemPartDetailInWipVO

getWorkOrderItemNumber() - Method in class bb.common.WorkOrderItemPK

getWorkOrderItemNumber() - Method in class bb.common.WorkOrderItemTimeDetailVO

getWorkOrderItemNumber() - Method in class bb.common.WorkOrderOverIssueListResult

getWorkOrderItemNumber() - Method in class bb.common.WorkOrderReceiverVO

getWorkOrderItemNumber() - Method in class bb.common.WorkOrderTimeCardVO

getWorkOrderItemNumber() - Method in class bb.common.WorkOrderWorkInstructionListResult

getWorkOrderItemNumber() - Method in class bb.common.WorkOrderWorkInstructionPK

getWorkOrderItemNumber() - Method in class bb.common.WorkOrderWorkInstructionSequencePK

getWorkOrderItemPartDetailItemResult(WorkOrderItemIssuePK) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderItemPartDetailNotIssuesCount(String, String, Date, Date) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderItemPartInWipTotal(String) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderItemPk() - Method in class bb.common.IssueItemAgent

getWorkOrderItemPK() - Method in class bb.common.IssuingItemResult

getWorkOrderItemPk() - Method in class bb.common.WorkOrderInWipResult

getWorkOrderItemPk() - Method in class bb.common.WorkOrderOnDemandResult

getWorkOrderItemPk() - Method in class bb.common.WorkOrderOnOrderResult

getWorkOrderItemPrivateNotes() - Method in class bb.common.WoItemPickListResult

getWorkOrderItemPrivateNotes() - Method in class bb.common.WorkOrderItemVO

getWorkOrderItemQuantity() - Method in class bb.common.WorkOrderOnDemandResult

getWorkOrderItemReviewCostResultsCount(String, String, String, String, Date, Date) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderItemTimeDetailByPk(Long) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderItemTimeDetailsCount(WorkOrderItemPK) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderItemWCLoadResults(WorkCenterAgent) - Method in interface bb.common.box.ManufacturingBox

getWorkOrderItemWithWIById(WorkOrderItemPK, Date, Date) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderItemWorkCenterSumCost(WorkOrderItemPK) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderListResultsCount(String, String[], String) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderListResultsCountByVendorId(String) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderListResultsCountByWoNumber(String) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderMaxReceivableQty(String) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderNumber() - Method in class bb.common.DesignControlInfoVO

getWorkOrderNumber() - Method in class bb.common.DesignControlVO

getWorkOrderNumber() - Method in class bb.common.EmployeeLaborAgent

getWorkOrderNumber() - Method in class bb.common.MrpReportAgent

getWorkOrderNumber() - Method in class bb.common.NcrNeedToScrapListResult

getWorkOrderNumber() - Method in class bb.common.NonConformanceReportVO

getWorkOrderNumber() - Method in class bb.common.PartCertificateListResult

getWorkOrderNumber() - Method in class bb.common.PartInWipForIDListResult

getWorkOrderNumber() - Method in class bb.common.PartIssuedVO

getWorkOrderNumber() - Method in class bb.common.SGSaleItemVO

getWorkOrderNumber() - Method in class bb.common.WOItemPartDetailNotIssue

getWorkOrderNumber() - Method in class bb.common.WoItemWorkInstructionListResult

getWorkOrderNumber() - Method in class bb.common.WOReceiverDetail

getWorkOrderNumber() - Method in class bb.common.WorkCenterRunTimeListResult

getWorkOrderNumber() - Method in class bb.common.WorkOrderIssuedOrderListResult

getWorkOrderNumber() - Method in class bb.common.WorkOrderItemInfoResult

getWorkOrderNumber() - Method in class bb.common.WorkOrderItemInWipListResult

getWorkOrderNumber() - Method in class bb.common.WorkOrderItemIssuedTotalResult

getWorkOrderNumber() - Method in class bb.common.WorkOrderItemIssuePK

getWorkOrderNumber() - Method in class bb.common.WorkOrderItemLaborCostListResult

getWorkOrderNumber() - Method in class bb.common.WorkOrderItemPartDetailInWipVO

getWorkOrderNumber() - Method in class bb.common.WorkOrderItemPK

getWorkOrderNumber() - Method in class bb.common.WorkOrderItemTimeDetailVO

getWorkOrderNumber() - Method in class bb.common.WorkOrderOverIssueListResult

getWorkOrderNumber() - Method in class bb.common.WorkOrderReceiverVO

getWorkOrderNumber() - Method in class bb.common.WorkOrderTimeCardVO

getWorkOrderNumber() - Method in class bb.common.WorkOrderVO

getWorkOrderNumber() - Method in class bb.common.WorkOrderWorkInstructionListResult

getWorkOrderNumber() - Method in class bb.common.WorkOrderWorkInstructionPK

getWorkOrderNumber() - Method in class bb.common.WorkOrderWorkInstructionSequencePK

getWorkOrderOnDemandResult() - Method in class bb.common.BB2PartMrpResult

getWorkOrderOnOrderResult() - Method in class bb.common.BB2PartMrpResult

getWorkOrderOverPercent() - Method in class bb.common.CompanyVO

getWorkOrderPrivateNotes() - Method in class bb.common.WorkOrderVO

getWorkOrderReceiversCountByWorkOrderItemPk(WorkOrderItemPK) - Method in interface bb.common.box.WarehouseBox

getWorkOrderReceivingResult(String) - Method in interface bb.common.box.WarehouseBox

getWorkOrderVendorIDByWo(String) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderWithOrderApplyByWo(Long) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderWorkInstructionByPk(WorkOrderWorkInstructionPK) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderWorkInstructionByWoItemPk(WorkOrderItemPK) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderWorkInstructionSequenceByPk(WorkOrderWorkInstructionSequencePK) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderWorkInstructionSequencesCount(WorkOrderWorkInstructionPK) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderWorkSheetByCountByEmployeeId(String) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderWorkSheetByPk(WorkOrderWorkSheetPK) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderWorkSheetCountByEmployeeEmailLike(String) - Method in interface bb.common.box.WorkOrderBox

getWorkOrderWorkSheetItem() - Method in class bb.common.WorkOrderWorkSheetVO

getWorkSheetItem() - Method in class bb.common.PurchaseWorkSheetItemWithRelatedInfoResult

getWorkSheetItem() - Method in class bb.common.WorkOrderWorkSheetItemWithRelatedInfoResult

getWorkSheetNumber() - Method in class bb.common.AddPhysicalInventoryAgent

getWorkSheetNumber() - Method in class bb.common.CycleCountPK

getWorkSheetNumber() - Method in class bb.common.CycleCountStatusVO

getWorkSheetNumber() - Method in class bb.common.PhysicalInventoryPK

getWorkSheetNumber() - Method in class bb.common.PhysicalInventoryStatusVO

getWorkSheetNumber() - Method in class bb.common.PurchaseWorkSheetItemPK

getWorkSheetNumber() - Method in class bb.common.PurchaseWorkSheetPK

getWorkSheetNumber() - Method in class bb.common.TakeCycleCountAgent

getWorkSheetNumber() - Method in class bb.common.WorkOrderWorkSheetItemPK

getWorkSheetNumber() - Method in class bb.common.WorkOrderWorkSheetPK

getWorkTime() - Method in class bb.common.CustomEmployeeVO

getWorkTime() - Method in class bb.common.WCLoadOnDateResult

getWorkTimePeriod() - Method in class bb.common.CompanyVO

getWorkTimeRange(int) - Static method in class bb.common.CustomEmployeeVO

getWorkType() - Method in class bb.common.CustomEmployeeVO

getWorkTypeAfter() - Method in class bb.common.CustomEmployeeVO

getWoStartDate() - Method in class bb.common.WorkOrderWorkInstructionVO

getWoStatus() - Method in class bb.common.POAndWOStatusResult

getWoStatus() - Method in class bb.common.WoItemPickListResult

getWoSub() - Method in class bb.common.WorkOrderItemVO

getWoSub() - Method in class bb.common.WorkOrderVO

getWoTax() - Method in class bb.common.WorkOrderItemVO

getWoTotal() - Method in class bb.common.WorkOrderItemVO

getWoTotal() - Method in class bb.common.WorkOrderOnTimeItemResult

getWowiCurrentInstrucationSeq() - Method in class bb.common.WorkOrderItemListResult

getWowiCurrentInstrucationSeq() - Method in class bb.common.WorkOrderItemVO

getWowiCurrentInstrucationSeqWC() - Method in class bb.common.WorkOrderItemListResult

getWowiCurrentInstrucationSeqWC() - Method in class bb.common.WorkOrderItemVO

getWowiCurrentInstrucationSeqWCDesc() - Method in class bb.common.WorkOrderItemListResult

getWowiCurrentInstrucationSeqWCDesc() - Method in class bb.common.WorkOrderItemVO

getWowiPartAvgCost() - Method in class bb.common.DisassembleWorkOrderItemListResult

getWowiPartAvgCost() - Method in class bb.common.WorkOrderItemListResult

getWOWISeqDescription(WorkOrderWorkInstructionSequencePK) - Method in interface bb.common.box.WorkOrderBox

getWriteOffExpenseItems() - Method in class bb.common.ClosingStatementResult

getWriteOffExpenses() - Method in class bb.common.ClosingStatementResult

getX() - Method in class bb.common.LabelTemplateItemVO

getXml() - Method in class bb.common.CustomSearchVO

getXregrade() - Method in class bb.common.NonConformanceReportVO

getXreject() - Method in class bb.common.NonConformanceReportVO

getXrework() - Method in class bb.common.NonConformanceReportVO

getXscrap() - Method in class bb.common.NonConformanceReportVO

getXwaiver() - Method in class bb.common.NonConformanceReportVO

getY() - Method in class bb.common.LabelTemplateItemVO

getYearBalance() - Method in class bb.common.AccountsChartCategoryListResult

getYearBalance() - Method in class bb.common.GlBalanceInfoResult

getYearBalanceFormula() - Method in class bb.common.AccountsChartCategoryVO

getYearCode() - Method in class bb.common.AccountingInfoDocumentVO

getYearCode() - Method in class bb.common.LogMiscDocumentVO

getYearCode() - Method in class bb.common.MiscDocAgent

getYearCreditAmount() - Method in class bb.common.GlBalanceInfoResult

getYearDC() - Method in class bb.common.GlBalanceInfoResult

getYearDebitAmount() - Method in class bb.common.GlBalanceInfoResult

getYearFirstDate(Date) - Static method in class bb.common.BB2Util

getYearLastDate(Date) - Static method in class bb.common.BB2Util

getYearMonth(Date) - Static method in class bb.common.BB2Util

getYearMonth(Date) - Method in interface bb.common.box.AccountingBox

getYearMonth(Date, boolean) - Static method in class bb.common.YearMonthManager

getYearMonth(Date) - Static method in class bb.common.YearMonthManager

getYearMonthLocalString(Date) - Static method in class bb.common.BB2Util

getYearMonths(Date, Date) - Static method in class bb.common.BB2Util

getYearMonths(Date, Date) - Method in interface bb.common.box.AccountingBox

getYearMonths(Date, Date) - Static method in class bb.common.YearMonthManager

getYearStorageAmount() - Method in class bb.common.PurchaseOrderContractResult

getYearToDate() - Method in class bb.common.ClosingStatementItemResult

getYearToDate() - Method in class bb.common.ClosingStatementTotalResult

getYearUsage() - Method in class bb.common.PartInventoryVO

getYearUsage() - Method in class bb.common.PartWithOnhandDetailInfoResult

getYearUsage() - Method in class bb.common.PurchaseOrderOpenDueListResult

getYearUsage() - Method in class bb.common.ToolInventoryVO

getYrQty() - Method in class bb.common.PartWithExcessiveInventoryListResult

getYrUsage() - Method in class bb.common.BB2PartInfo

getYrUsage() - Method in class bb.common.BB2PartTotalOnhandDetailResult

getYrUsage() - Method in class bb.common.PartMaterialListResult

getYrUsage() - Method in class bb.common.PartMaterialWhereUsedItemResult

getYtdReceiverCount() - Method in class bb.common.WareHousingInfoCenterResult

getYtdShipperCount() - Method in class bb.common.WareHousingInfoCenterResult

getYtrQty() - Method in class bb.common.HighUsagePartResult

getYUsage() - Method in class bb.common.StockTransactionPartInfoResult

getZip() - Method in class bb.common.AccountPayableCheckVO

getZip() - Method in class bb.common.AccountReceivablePaymentVO

getZip() - Method in class bb.common.CustomerVendorAddressInfoVO

getZip() - Method in class bb.common.CustomerVendorAddressVO

getZip() - Method in class bb.common.CustomerVendorDescriptionVO

getZip() - Method in class bb.common.EmployeeHomeVO

getZip() - Method in class bb.common.LockedCustomerAddressResult

getZip() - Method in class bb.common.ManufacturerAddressInfoVO

getZip() - Method in class bb.common.ManufacturerAddressVO

getZip() - Method in class bb.common.ManufacturerDescriptionVO

getZip() - Method in class bb.common.SalesmanVO

getZip() - Method in class bb.common.SGCartCheckOutResult

getZip() - Method in class bb.common.SGCustRequestForQuoteListResult

getZip() - Method in class bb.common.SGCustRequestForQuoteResult

getZip() - Method in class bb.common.SGQuoteAddressResult

getZip() - Method in class bb.common.SGQuoteAddressVO

getZipcode() - Method in class bb.common.APTaxForZipcodeListResult

getZipcode() - Method in class bb.common.ARTaxForZipcodeListResult

getZipCode() - Method in class bb.common.ZipcodeTotalsResult

getZipCodeByPk(String) - Method in interface bb.common.box.CompanyBox

getZipCodeEnd() - Method in class bb.common.PosZipCodeTaxPK

getZipCodeFrom() - Method in class bb.common.ZipcodeTotalsResult

getZipCodeStart() - Method in class bb.common.PosZipCodeTaxPK

getZipCodeTaxByPK(int) - Method in interface bb.common.box.CompanyBox

getZipCodeTo() - Method in class bb.common.ZipcodeTotalsResult

getZipId() - Method in class bb.common.ZipCodeVO

getZipName(String) - Method in interface bb.common.box.CompanyBox

getZipName() - Method in class bb.common.ZipCodeVO

getZipTo() - Method in class bb.common.ZipCodeTaxVO

GL - Static variable in class bb.common.Constant.Prefix

GL - Static variable in class bb.common.Constant.PrintTemplateType

GL_CLOSED - Static variable in class bb.common.BizTarget

GL_IN_FISCAL_YEAR - Static variable in class bb.common.BIZReason

GL_LOCKED_DATE_SHOULD_BE_AFTER_FY_END_DATE - Static variable in class bb.common.BIZReason

GL_MONTH - Static variable in class bb.common.BizTarget

GL_MONTH_ALREADY_CLOSED - Static variable in class bb.common.BIZReason

GL_MONTH_NOT_EXIST - Static variable in class bb.common.BIZReason

GL_VOID - Static variable in class bb.common.Constant

GLApprovalListResult - Class in bb.common

GLApprovalListResult() - Constructor for class bb.common.GLApprovalListResult

GLAutoApproveVO - Class in bb.common

GLAutoApproveVO() - Constructor for class bb.common.GLAutoApproveVO

GlBalanceInfoResult - Class in bb.common

GlBalanceInfoResult() - Constructor for class bb.common.GlBalanceInfoResult

GLByDateTotalResult - Class in bb.common

GLByDateTotalResult() - Constructor for class bb.common.GLByDateTotalResult

GlCashFlowBudgetVO - Class in bb.common

GlCashFlowBudgetVO() - Constructor for class bb.common.GlCashFlowBudgetVO
default constructor
GLCatAndSequence - Class in bb.common

GLCatAndSequence(String, Integer, String) - Constructor for class bb.common.GLCatAndSequence

GLCheckRegisterResult - Class in bb.common

GLCheckRegisterResult() - Constructor for class bb.common.GLCheckRegisterResult

GLDebitCreditListResult - Class in bb.common

GLDebitCreditListResult() - Constructor for class bb.common.GLDebitCreditListResult

GlFiscalYearBudgetVO - Class in bb.common

GlFiscalYearBudgetVO() - Constructor for class bb.common.GlFiscalYearBudgetVO
default constructor
GLInfoByPeriodResult - Class in bb.common

GLInfoByPeriodResult() - Constructor for class bb.common.GLInfoByPeriodResult

GLItemVO - Class in bb.common

GLItemVO() - Constructor for class bb.common.GLItemVO
default constructor
GlMonthBudgetVO - Class in bb.common

GlMonthBudgetVO(String, Date, Date, String, String) - Constructor for class bb.common.GlMonthBudgetVO
full constructor
GlMonthBudgetVO() - Constructor for class bb.common.GlMonthBudgetVO
default constructor
GlMonthBudgetVO(String, Date, Date, String) - Constructor for class bb.common.GlMonthBudgetVO
minimal constructor
GlMonthVO - Class in bb.common

GlMonthVO() - Constructor for class bb.common.GlMonthVO
default constructor
GrossPrice - Static variable in class bb.common.Constant.ARDiscountMethod

GROUP_USER - Static variable in class bb.common.BizTarget

GroupUserPK - Class in bb.common

GroupUserPK() - Constructor for class bb.common.GroupUserPK

GroupUserPK(String, String) - Constructor for class bb.common.GroupUserPK

GroupUserVO - Class in bb.common

GroupUserVO() - Constructor for class bb.common.GroupUserVO

GroupUserVO(GroupUserPK, String, String) - Constructor for class bb.common.GroupUserVO

Overview

Package

Class

Use

Tree

Deprecated

Index

Help

PREV LETTER NEXT LETTER

FRAMES NO FRAMES

A B C D E F G H I J L M N O P Q R S T U V W X Y Z


GLApprovalListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class GLApprovalListResult

java.lang.Object
    extended by  bb.common.GLApprovalListResult
All Implemented Interfaces:
java.io.Serializable
public class GLApprovalListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
GLApprovalListResult()
Method Summary
java.lang.String | getApprovalStatus()
java.lang.String | getApprovedBy()
java.lang.Integer | getCategorySequence()
java.lang.String | getDescription()
java.lang.String | getGlCategory()
java.lang.String | getGlNumber()
java.lang.String | getOrigin()
java.math.BigDecimal | getTotalCredit()
java.math.BigDecimal | getTotalDebit()
java.util.Date | getTransactionDate()
void | setApprovalStatus(java.lang.String approvalStatus)
void | setApprovedBy(java.lang.String approvedBy)
void | setCategorySequence(java.lang.Integer categorySequence)
void | setDescription(java.lang.String description)
void | setGlCategory(java.lang.String glCategory)
void | setGlNumber(java.lang.String glNumber)
void | setOrigin(java.lang.String origin)
void | setTotalCredit(java.math.BigDecimal totalCredit)
void | setTotalDebit(java.math.BigDecimal totalDebit)
void | setTransactionDate(java.util.Date transactionDate)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

GLApprovalListResult

public GLApprovalListResult()
Method Detail

getApprovedBy

public java.lang.String getApprovedBy()

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)

getApprovalStatus

public java.lang.String getApprovalStatus()

setApprovalStatus

public void setApprovalStatus(java.lang.String approvalStatus)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getGlNumber

public java.lang.String getGlNumber()

setGlNumber

public void setGlNumber(java.lang.String glNumber)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getTotalCredit

public java.math.BigDecimal getTotalCredit()

setTotalCredit

public void setTotalCredit(java.math.BigDecimal totalCredit)

getTotalDebit

public java.math.BigDecimal getTotalDebit()

setTotalDebit

public void setTotalDebit(java.math.BigDecimal totalDebit)

getTransactionDate

public java.util.Date getTransactionDate()

setTransactionDate

public void setTransactionDate(java.util.Date transactionDate)

getCategorySequence

public java.lang.Integer getCategorySequence()

setCategorySequence

public void setCategorySequence(java.lang.Integer categorySequence)

getGlCategory

public java.lang.String getGlCategory()

setGlCategory

public void setGlCategory(java.lang.String glCategory)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GLAutoApproveVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class GLAutoApproveVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.GLAutoApproveVO
All Implemented Interfaces:
java.io.Serializable
public class GLAutoApproveVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_APPROVEDBY
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_GLCAT
static java.lang.String | ORDER_BY_GLTYPE
static java.lang.String | ORDER_BY_II
Constructor Summary
GLAutoApproveVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getApprovedBy()
java.lang.String | getDescription()
java.lang.String | getGlCat()
java.lang.String | getGlType()
java.lang.Long | getIi()
int | hashCode()
boolean | isAutoApprove()
void | setApprovedBy(java.lang.String approvedBy)
void | setAutoApprove(boolean autoApprove)
void | setDescription(java.lang.String description)
void | setGlCat(java.lang.String glCat)
void | setGlType(java.lang.String glType)
void | setIi(java.lang.Long ii)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_II

public static final java.lang.String ORDER_BY_II
See Also:
Constant Field Values

ORDER_BY_GLTYPE

public static final java.lang.String ORDER_BY_GLTYPE
See Also:
Constant Field Values

ORDER_BY_APPROVEDBY

public static final java.lang.String ORDER_BY_APPROVEDBY
See Also:
Constant Field Values

ORDER_BY_GLCAT

public static final java.lang.String ORDER_BY_GLCAT
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

GLAutoApproveVO

public GLAutoApproveVO()
Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getGlType

public java.lang.String getGlType()

setGlType

public void setGlType(java.lang.String glType)

getApprovedBy

public java.lang.String getApprovedBy()

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)

getGlCat

public java.lang.String getGlCat()

setGlCat

public void setGlCat(java.lang.String glCat)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

isAutoApprove

public boolean isAutoApprove()

setAutoApprove

public void setAutoApprove(boolean autoApprove)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GlBalanceInfoResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class GlBalanceInfoResult

java.lang.Object
    extended by  bb.common.GlBalanceInfoResult
All Implemented Interfaces:
java.io.Serializable
public class GlBalanceInfoResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
GlBalanceInfoResult()
Method Summary
java.math.BigDecimal | getPeriodBalance()
java.math.BigDecimal | getPeriodCreditAmount()
java.lang.String | getPeriodDC()
java.math.BigDecimal | getPeriodDebitAmount()
java.math.BigDecimal | getYearBalance()
java.math.BigDecimal | getYearCreditAmount()
java.lang.String | getYearDC()
java.math.BigDecimal | getYearDebitAmount()
void | setPeriodBalance(java.math.BigDecimal periodBalance)
void | setPeriodCreditAmount(java.math.BigDecimal periodCreditAmount)
void | setPeriodDC(java.lang.String periodDC)
void | setPeriodDebitAmount(java.math.BigDecimal periodDebitAmount)
void | setYearBalance(java.math.BigDecimal yearBalance)
void | setYearCreditAmount(java.math.BigDecimal yearCreditAmount)
void | setYearDC(java.lang.String yearDC)
void | setYearDebitAmount(java.math.BigDecimal yearDebitAmount)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

GlBalanceInfoResult

public GlBalanceInfoResult()
Method Detail

getPeriodBalance

public java.math.BigDecimal getPeriodBalance()

setPeriodBalance

public void setPeriodBalance(java.math.BigDecimal periodBalance)

getPeriodCreditAmount

public java.math.BigDecimal getPeriodCreditAmount()

setPeriodCreditAmount

public void setPeriodCreditAmount(java.math.BigDecimal periodCreditAmount)

getPeriodDC

public java.lang.String getPeriodDC()

setPeriodDC

public void setPeriodDC(java.lang.String periodDC)

getPeriodDebitAmount

public java.math.BigDecimal getPeriodDebitAmount()

setPeriodDebitAmount

public void setPeriodDebitAmount(java.math.BigDecimal periodDebitAmount)

getYearBalance

public java.math.BigDecimal getYearBalance()

setYearBalance

public void setYearBalance(java.math.BigDecimal yearBalance)

getYearCreditAmount

public java.math.BigDecimal getYearCreditAmount()

setYearCreditAmount

public void setYearCreditAmount(java.math.BigDecimal yearCreditAmount)

getYearDC

public java.lang.String getYearDC()

setYearDC

public void setYearDC(java.lang.String yearDC)

getYearDebitAmount

public java.math.BigDecimal getYearDebitAmount()

setYearDebitAmount

public void setYearDebitAmount(java.math.BigDecimal yearDebitAmount)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GLByDateTotalResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class GLByDateTotalResult

java.lang.Object
    extended by  bb.common.GLByDateTotalResult
All Implemented Interfaces:
java.io.Serializable
public class GLByDateTotalResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
GLByDateTotalResult()
Method Summary
java.math.BigDecimal | getEndingBalanceCredit()
java.math.BigDecimal | getEndingBalanceDebit()
java.math.BigDecimal | getStartingBalanceCredit()
java.math.BigDecimal | getStartingBalanceDebit()
java.math.BigDecimal | getTotalCredit()
java.math.BigDecimal | getTotalDebit()
void | setEndingBalanceCredit(java.math.BigDecimal endingBalanceCredit)
void | setEndingBalanceDebit(java.math.BigDecimal endingBalanceDebit)
void | setStartingBalanceCredit(java.math.BigDecimal startingBalanceCredit)
void | setStartingBalanceDebit(java.math.BigDecimal startingBalanceDebit)
void | setTotalCredit(java.math.BigDecimal totalCredit)
void | setTotalDebit(java.math.BigDecimal totalDebit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

GLByDateTotalResult

public GLByDateTotalResult()
Method Detail

setStartingBalanceCredit

public void setStartingBalanceCredit(java.math.BigDecimal startingBalanceCredit)

setStartingBalanceDebit

public void setStartingBalanceDebit(java.math.BigDecimal startingBalanceDebit)

setTotalDebit

public void setTotalDebit(java.math.BigDecimal totalDebit)

setTotalCredit

public void setTotalCredit(java.math.BigDecimal totalCredit)

setEndingBalanceCredit

public void setEndingBalanceCredit(java.math.BigDecimal endingBalanceCredit)

setEndingBalanceDebit

public void setEndingBalanceDebit(java.math.BigDecimal endingBalanceDebit)

getStartingBalanceCredit

public java.math.BigDecimal getStartingBalanceCredit()

getStartingBalanceDebit

public java.math.BigDecimal getStartingBalanceDebit()

getTotalDebit

public java.math.BigDecimal getTotalDebit()

getTotalCredit

public java.math.BigDecimal getTotalCredit()

getEndingBalanceCredit

public java.math.BigDecimal getEndingBalanceCredit()

getEndingBalanceDebit

public java.math.BigDecimal getEndingBalanceDebit()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GlCashFlowBudgetVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class GlCashFlowBudgetVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.GlCashFlowBudgetVO
All Implemented Interfaces:
java.io.Serializable
public class GlCashFlowBudgetVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
GlCashFlowBudgetVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAccountType()
java.math.BigDecimal | getBudget()
java.lang.String | getCf()
AccountMonthPK | getPk()
int | hashCode()
boolean | isChecked()
void | setAccountType(java.lang.String accountType)
void | setBudget(java.math.BigDecimal budget)
void | setCf(java.lang.String cf)
void | setChecked(boolean checked)
void | setPk(AccountMonthPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

GlCashFlowBudgetVO

public GlCashFlowBudgetVO()
default constructor

Method Detail

getPk

public AccountMonthPK getPk()

setPk

public void setPk(AccountMonthPK pk)

getAccountType

public java.lang.String getAccountType()

setAccountType

public void setAccountType(java.lang.String accountType)

getCf

public java.lang.String getCf()

setCf

public void setCf(java.lang.String cf)

getBudget

public java.math.BigDecimal getBudget()

setBudget

public void setBudget(java.math.BigDecimal budget)

isChecked

public boolean isChecked()

setChecked

public void setChecked(boolean checked)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GLCatAndSequence

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class GLCatAndSequence

java.lang.Object
    extended by  bb.common.GLCatAndSequence
All Implemented Interfaces:
java.io.Serializable
public class GLCatAndSequence
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
GLCatAndSequence(java.lang.String glCategory, java.lang.Integer categorySequence, java.lang.String glNumber)
Method Summary
java.lang.Integer | getCategorySequence()
java.lang.String | getGlCategory()
java.lang.String | getGlNumber()
void | setCategorySequence(java.lang.Integer categorySequence)
void | setGlCategory(java.lang.String glCategory)
void | setGlNumber(java.lang.String glNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

GLCatAndSequence

public GLCatAndSequence(java.lang.String glCategory,
                        java.lang.Integer categorySequence,
                        java.lang.String glNumber)
Method Detail

getCategorySequence

public java.lang.Integer getCategorySequence()

setCategorySequence

public void setCategorySequence(java.lang.Integer categorySequence)

getGlCategory

public java.lang.String getGlCategory()

setGlCategory

public void setGlCategory(java.lang.String glCategory)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getGlNumber

public java.lang.String getGlNumber()

setGlNumber

public void setGlNumber(java.lang.String glNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GLCheckRegisterResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class GLCheckRegisterResult

java.lang.Object
    extended by  bb.common.GLCheckRegisterResult
All Implemented Interfaces:
java.io.Serializable
public class GLCheckRegisterResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
GLCheckRegisterResult()
Method Summary
java.lang.String | getAccountDescription()
java.lang.String | getAccountNumber()
java.lang.String | getCheckType()
java.lang.String | getCompanyUnit()
java.lang.String | getFMonthYear()
java.lang.String | getId()
java.util.Collection<GeneralLedgerByDateListResult> | getResults()
java.lang.String | getTMonthYear()
void | setAccountDescription(java.lang.String accountDescription)
void | setAccountNumber(java.lang.String accountNumber)
void | setCheckType(java.lang.String checkType)
void | setCompanyUnit(java.lang.String companyUnit)
void | setFMonthYear(java.lang.String monthYear)
void | setId(java.lang.String id)
void | setResults(java.util.Collection<GeneralLedgerByDateListResult> results)
void | setTMonthYear(java.lang.String monthYear)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

GLCheckRegisterResult

public GLCheckRegisterResult()
Method Detail

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getAccountDescription

public java.lang.String getAccountDescription()

setAccountDescription

public void setAccountDescription(java.lang.String accountDescription)

getCompanyUnit

public java.lang.String getCompanyUnit()

setCompanyUnit

public void setCompanyUnit(java.lang.String companyUnit)

getFMonthYear

public java.lang.String getFMonthYear()

setFMonthYear

public void setFMonthYear(java.lang.String monthYear)

getTMonthYear

public java.lang.String getTMonthYear()

setTMonthYear

public void setTMonthYear(java.lang.String monthYear)

getResults

public java.util.Collection<GeneralLedgerByDateListResult> getResults()

setResults

public void setResults(java.util.Collection<GeneralLedgerByDateListResult> results)

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getCheckType

public java.lang.String getCheckType()

setCheckType

public void setCheckType(java.lang.String checkType)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GLDebitCreditListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class GLDebitCreditListResult

java.lang.Object
    extended by  bb.common.GeneralLedgerListResult
        extended by  bb.common.GLDebitCreditListResult
All Implemented Interfaces:
java.io.Serializable
public class GLDebitCreditListResult
extends GeneralLedgerListResult
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACCOUNTNUMBER
static java.lang.String | ORDER_BY_ACCOUNTSPAYABLENUMBER
static java.lang.String | ORDER_BY_BATCH
static java.lang.String | ORDER_BY_CHECKNUMBER
static java.lang.String | ORDER_BY_CREDIT
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_DEBIT
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_GLCATEGORY
static java.lang.String | ORDER_BY_INVOICENUMBER
static java.lang.String | ORDER_BY_NAME
static java.lang.String | ORDER_BY_PURCHASEORDERNUMBER
static java.lang.String | ORDER_BY_RELDOC
static java.lang.String | ORDER_BY_SALESORDERNUMBER
static java.lang.String | ORDER_BY_TRANSACTIONDATE
static java.lang.String | ORDER_BY_TRANSACTIONNUMBER
static java.lang.String | ORDER_BY_TRANSACTIONTYPE
static java.lang.String | ORDER_BY_VENDORINVOICE
Constructor Summary
GLDebitCreditListResult()
Method Summary
java.lang.String | getAccountNumber()
java.math.BigDecimal | getCredit()
java.math.BigDecimal | getDebit()
void | setAccountNumber(java.lang.String accountNumber)
void | setCredit(java.math.BigDecimal credit)
void | setDebit(java.math.BigDecimal debit)
Methods inherited from class bb.common.GeneralLedgerListResult
getAccountsPayableNumber, getAdate, getBankReconsiled, getBatch, getCategorySequence, getCheckNumber, getCheckPrinted, getComments, getCommission, getCurrency, getCustomerId, getCustomerPo, getDescription, getDiscount, getExchange, getFreight, getGlCategory, getInvoiceNumber, getLastChangeDate, getLastChangeTimes, getLastChangeUser, getMemo, getName, getNotes, getPaid, getPurchaseOrderNumber, getReceived, getReceiverNumber, getReldoc, getSalesman, getSalesOrderNumber, getSalesTax, getShipperNumber, getTransactionDate, getTransactionNumber, getTransactionType, getTransactionTypeDescription, getVendorInvoice, setAccountsPayableNumber, setAdate, setBankReconsiled, setBatch, setCategorySequence, setCheckNumber, setCheckPrinted, setComments, setCommission, setCurrency, setCustomerId, setCustomerPo, setDescription, setDiscount, setExchange, setFreight, setGlCategory, setInvoiceNumber, setLastChangeDate, setLastChangeTimes, setLastChangeUser, setMemo, setName, setNotes, setPaid, setPurchaseOrderNumber, setReceived, setReceiverNumber, setReldoc, setSalesman, setSalesOrderNumber, setSalesTax, setShipperNumber, setTransactionDate, setTransactionNumber, setTransactionType, setTransactionTypeDescription, setVendorInvoice
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_TRANSACTIONNUMBER

public static final java.lang.String ORDER_BY_TRANSACTIONNUMBER
See Also:
Constant Field Values

ORDER_BY_NAME

public static final java.lang.String ORDER_BY_NAME
See Also:
Constant Field Values

ORDER_BY_BATCH

public static final java.lang.String ORDER_BY_BATCH
See Also:
Constant Field Values

ORDER_BY_RELDOC

public static final java.lang.String ORDER_BY_RELDOC
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_TRANSACTIONTYPE

public static final java.lang.String ORDER_BY_TRANSACTIONTYPE
See Also:
Constant Field Values

ORDER_BY_TRANSACTIONDATE

public static final java.lang.String ORDER_BY_TRANSACTIONDATE
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_PURCHASEORDERNUMBER

public static final java.lang.String ORDER_BY_PURCHASEORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_ACCOUNTSPAYABLENUMBER

public static final java.lang.String ORDER_BY_ACCOUNTSPAYABLENUMBER
See Also:
Constant Field Values

ORDER_BY_SALESORDERNUMBER

public static final java.lang.String ORDER_BY_SALESORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_INVOICENUMBER

public static final java.lang.String ORDER_BY_INVOICENUMBER
See Also:
Constant Field Values

ORDER_BY_CHECKNUMBER

public static final java.lang.String ORDER_BY_CHECKNUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORINVOICE

public static final java.lang.String ORDER_BY_VENDORINVOICE
See Also:
Constant Field Values

ORDER_BY_ACCOUNTNUMBER

public static final java.lang.String ORDER_BY_ACCOUNTNUMBER
See Also:
Constant Field Values

ORDER_BY_DEBIT

public static final java.lang.String ORDER_BY_DEBIT
See Also:
Constant Field Values

ORDER_BY_CREDIT

public static final java.lang.String ORDER_BY_CREDIT
See Also:
Constant Field Values

ORDER_BY_GLCATEGORY

public static final java.lang.String ORDER_BY_GLCATEGORY
See Also:
Constant Field Values
Constructor Detail

GLDebitCreditListResult

public GLDebitCreditListResult()
Method Detail

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getCredit

public java.math.BigDecimal getCredit()

setCredit

public void setCredit(java.math.BigDecimal credit)

getDebit

public java.math.BigDecimal getDebit()

setDebit

public void setDebit(java.math.BigDecimal debit)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GlFiscalYearBudgetVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class GlFiscalYearBudgetVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.GlFiscalYearBudgetVO
All Implemented Interfaces:
java.io.Serializable
public class GlFiscalYearBudgetVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
GlFiscalYearBudgetVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAccountType()
java.math.BigDecimal | getBudget()
AccountMonthPK | getPk()
int | hashCode()
void | setAccountType(java.lang.String accountType)
void | setBudget(java.math.BigDecimal budget)
void | setPk(AccountMonthPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

GlFiscalYearBudgetVO

public GlFiscalYearBudgetVO()
default constructor

Method Detail

getPk

public AccountMonthPK getPk()

setPk

public void setPk(AccountMonthPK pk)

getAccountType

public java.lang.String getAccountType()

setAccountType

public void setAccountType(java.lang.String accountType)

getBudget

public java.math.BigDecimal getBudget()

setBudget

public void setBudget(java.math.BigDecimal budget)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GLInfoByPeriodResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class GLInfoByPeriodResult

java.lang.Object
    extended by  bb.common.GLInfoByPeriodResult
All Implemented Interfaces:
java.io.Serializable
public class GLInfoByPeriodResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
GLInfoByPeriodResult()
Method Summary
java.math.BigDecimal | getBeginBalance()
java.util.Map<java.lang.String,java.util.Map<JounalEntryListResult,java.util.Collection<JounalEntryListResult>>> | getDailyList()
java.lang.String | getDebitOrCredit()
java.util.Map<java.lang.String,GlBalanceInfoResult> | getPeriodBalance()
boolean | isShowOriginal()
void | setBeginBalance(java.math.BigDecimal beginBalance)
void | setDailyList(java.util.Map<java.lang.String,java.util.Map<JounalEntryListResult,java.util.Collection<JounalEntryListResult>>> dailyList)
void | setDebitOrCredit(java.lang.String debitOrCredit)
void | setPeriodBalance(java.util.Map<java.lang.String,GlBalanceInfoResult> periodBalance)
void | setShowOriginal(boolean showOriginal)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

GLInfoByPeriodResult

public GLInfoByPeriodResult()
Method Detail

getBeginBalance

public java.math.BigDecimal getBeginBalance()

setBeginBalance

public void setBeginBalance(java.math.BigDecimal beginBalance)

getDebitOrCredit

public java.lang.String getDebitOrCredit()

setDebitOrCredit

public void setDebitOrCredit(java.lang.String debitOrCredit)

getDailyList

public java.util.Map<java.lang.String,java.util.Map<JounalEntryListResult,java.util.Collection<JounalEntryListResult>>> getDailyList()

setDailyList

public void setDailyList(java.util.Map<java.lang.String,java.util.Map<JounalEntryListResult,java.util.Collection<JounalEntryListResult>>> dailyList)

getPeriodBalance

public java.util.Map<java.lang.String,GlBalanceInfoResult> getPeriodBalance()

setPeriodBalance

public void setPeriodBalance(java.util.Map<java.lang.String,GlBalanceInfoResult> periodBalance)

isShowOriginal

public boolean isShowOriginal()

setShowOriginal

public void setShowOriginal(boolean showOriginal)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GLItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class GLItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.GLItemVO
All Implemented Interfaces:
java.io.Serializable
public class GLItemVO
extends VO

See Also:
Serialized Form

Constructor Summary
GLItemVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAccountNumber()
AccountsChartVO | getAccountsChart()
java.lang.String | getAddressId()
boolean | getAlarmValue()
java.lang.String | getCause()
java.lang.String | getCompanyUnitId()
java.math.BigDecimal | getCredit()
java.lang.String | getCurrency()
java.math.BigDecimal | getDebit()
java.lang.String | getDescription()
java.math.BigDecimal | getExchange()
java.math.BigDecimal | getOriginalCredit()
java.math.BigDecimal | getOriginalDebit()
AccountCreditDebitPK | getPk()
java.util.Date | getTransactionDate()
java.lang.String | getTransactionType()
int | hashCode()
void | setAccountNumber(java.lang.String accountNumber)
void | setAccountsChart(AccountsChartVO accountsChart)
void | setAddressId(java.lang.String addressId)
void | setAlarmValue(boolean alarmValue)
void | setCause(java.lang.String cause)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCredit(java.math.BigDecimal credit)
void | setCurrency(java.lang.String currency)
void | setDebit(java.math.BigDecimal debit)
void | setDescription(java.lang.String description)
void | setExchange(java.math.BigDecimal exchange)
void | setOriginalCredit(java.math.BigDecimal originalCredit)
void | setOriginalDebit(java.math.BigDecimal originalDebit)
void | setPk(AccountCreditDebitPK pk)
void | setTransactionDate(java.util.Date transactionDate)
void | setTransactionType(java.lang.String transactionType)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

GLItemVO

public GLItemVO()
default constructor

Method Detail

getPk

public AccountCreditDebitPK getPk()

setPk

public void setPk(AccountCreditDebitPK pk)

getTransactionDate

public java.util.Date getTransactionDate()

setTransactionDate

public void setTransactionDate(java.util.Date transactionDate)

getTransactionType

public java.lang.String getTransactionType()

setTransactionType

public void setTransactionType(java.lang.String transactionType)

getAddressId

public java.lang.String getAddressId()

setAddressId

public void setAddressId(java.lang.String addressId)

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getCredit

public java.math.BigDecimal getCredit()

getAccountsChart

public AccountsChartVO getAccountsChart()

setCredit

public void setCredit(java.math.BigDecimal credit)

setAccountsChart

public void setAccountsChart(AccountsChartVO accountsChart)

getAlarmValue

public boolean getAlarmValue()

setAlarmValue

public void setAlarmValue(boolean alarmValue)

getCause

public java.lang.String getCause()

setCause

public void setCause(java.lang.String cause)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getExchange

public java.math.BigDecimal getExchange()

setExchange

public void setExchange(java.math.BigDecimal exchange)

getOriginalCredit

public java.math.BigDecimal getOriginalCredit()

setOriginalCredit

public void setOriginalCredit(java.math.BigDecimal originalCredit)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getDebit

public java.math.BigDecimal getDebit()

setDebit

public void setDebit(java.math.BigDecimal debit)

getOriginalDebit

public java.math.BigDecimal getOriginalDebit()

setOriginalDebit

public void setOriginalDebit(java.math.BigDecimal originalDebit)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GlMonthBudgetVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class GlMonthBudgetVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.GlMonthBudgetVO
All Implemented Interfaces:
java.io.Serializable
public class GlMonthBudgetVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
GlMonthBudgetVO()
default constructor
GlMonthBudgetVO(java.lang.String monthYear, java.util.Date startMonth, java.util.Date endMonth, java.lang.String c7)
minimal constructor
GlMonthBudgetVO(java.lang.String monthYear, java.util.Date startMonth, java.util.Date endMonth, java.lang.String status, java.lang.String c7)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getC7()
java.util.Date | getEndMonth()
java.lang.String | getMonthYear()
java.util.Date | getStartMonth()
java.lang.String | getStatus()
int | hashCode()
void | setC7(java.lang.String c7)
void | setEndMonth(java.util.Date endMonth)
void | setMonthYear(java.lang.String monthYear)
void | setStartMonth(java.util.Date startMonth)
void | setStatus(java.lang.String status)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

GlMonthBudgetVO

public GlMonthBudgetVO(java.lang.String monthYear,
                       java.util.Date startMonth,
                       java.util.Date endMonth,
                       java.lang.String status,
                       java.lang.String c7)
full constructor

GlMonthBudgetVO

public GlMonthBudgetVO()
default constructor

GlMonthBudgetVO

public GlMonthBudgetVO(java.lang.String monthYear,
                       java.util.Date startMonth,
                       java.util.Date endMonth,
                       java.lang.String c7)
minimal constructor

Method Detail

getMonthYear

public java.lang.String getMonthYear()

setMonthYear

public void setMonthYear(java.lang.String monthYear)

getStartMonth

public java.util.Date getStartMonth()

setStartMonth

public void setStartMonth(java.util.Date startMonth)

getEndMonth

public java.util.Date getEndMonth()

setEndMonth

public void setEndMonth(java.util.Date endMonth)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getC7

public java.lang.String getC7()

setC7

public void setC7(java.lang.String c7)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GlMonthVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class GlMonthVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.GlMonthVO
All Implemented Interfaces:
java.io.Serializable
public class GlMonthVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
GlMonthVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getC7()
java.util.Date | getEndMonth()
java.lang.String | getFy()
java.lang.String | getMonthYear()
java.util.Date | getStartMonth()
java.lang.String | getStatus()
int | hashCode()
void | setC7(java.lang.String c7)
void | setEndMonth(java.util.Date endMonth)
void | setFy(java.lang.String fy)
void | setMonthYear(java.lang.String monthYear)
void | setStartMonth(java.util.Date startMonth)
void | setStatus(java.lang.String status)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

GlMonthVO

public GlMonthVO()
default constructor

Method Detail

getMonthYear

public java.lang.String getMonthYear()

setMonthYear

public void setMonthYear(java.lang.String monthYear)

getStartMonth

public java.util.Date getStartMonth()

setStartMonth

public void setStartMonth(java.util.Date startMonth)

getEndMonth

public java.util.Date getEndMonth()

setEndMonth

public void setEndMonth(java.util.Date endMonth)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getC7

public java.lang.String getC7()

setC7

public void setC7(java.lang.String c7)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getFy

public java.lang.String getFy()

setFy

public void setFy(java.lang.String fy)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GroupUserPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class GroupUserPK

java.lang.Object
    extended by  bb.common.GroupUserPK
All Implemented Interfaces:
java.io.Serializable
public class GroupUserPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
GroupUserPK()
GroupUserPK(java.lang.String userName, java.lang.String userGroup)
Method Summary
boolean | equals(java.lang.Object obj)
java.lang.String | getUserGroup()
java.lang.String | getUserName()
int | hashCode()
void | setUserGroup(java.lang.String userGroup)
void | setUserName(java.lang.String userName)
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

GroupUserPK

public GroupUserPK()

GroupUserPK

public GroupUserPK(java.lang.String userName,
                   java.lang.String userGroup)
Method Detail

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getUserGroup

public java.lang.String getUserGroup()

setUserGroup

public void setUserGroup(java.lang.String userGroup)

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GroupUserVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class GroupUserVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.GroupUserVO
All Implemented Interfaces:
java.io.Serializable
public class GroupUserVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
GroupUserVO()
GroupUserVO(GroupUserPK pk, java.lang.String description, java.lang.String employeeId)
Method Summary
java.lang.String | getDescription()
java.lang.String | getEmployeeId()
java.lang.String | getFirstName()
java.lang.String | getLastName()
java.lang.String | getMiddleName()
GroupUserPK | getPk()
void | setDescription(java.lang.String description)
void | setEmployeeId(java.lang.String employeeId)
void | setFirstName(java.lang.String firstName)
void | setLastName(java.lang.String lastName)
void | setMiddleName(java.lang.String middleName)
void | setPk(GroupUserPK pk)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

GroupUserVO

public GroupUserVO()

GroupUserVO

public GroupUserVO(GroupUserPK pk,
                   java.lang.String description,
                   java.lang.String employeeId)
Method Detail

getPk

public GroupUserPK getPk()

setPk

public void setPk(GroupUserPK pk)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getFirstName

public java.lang.String getFirstName()

setFirstName

public void setFirstName(java.lang.String firstName)

getLastName

public java.lang.String getLastName()

setLastName

public void setLastName(java.lang.String lastName)

getMiddleName

public java.lang.String getMiddleName()

setMiddleName

public void setMiddleName(java.lang.String middleName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HelpServerVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class HelpServerVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.HelpServerVO
All Implemented Interfaces:
java.io.Serializable
public class HelpServerVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_actived
static java.lang.String | ORDER_BY_description
static java.lang.String | ORDER_BY_helpServerIP
static java.lang.String | ORDER_BY_helpServerPort
static java.lang.String | ORDER_BY_II
static java.lang.String | ORDER_BY_language
static java.lang.String | ORDER_BY_spaceHomePage
static java.lang.String | ORDER_BY_wikiSpaceName
Constructor Summary
HelpServerVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDescription()
java.lang.String | getHelpServerIP()
java.lang.String | getHelpServerPort()
java.lang.Long | getIi()
java.lang.String | getLanguage()
java.lang.String | getSpaceHomePage()
java.lang.String | getWikiSpaceName()
int | hashCode()
boolean | isActived()
void | setActived(boolean actived)
void | setDescription(java.lang.String description)
void | setHelpServerIP(java.lang.String helpServerIP)
void | setHelpServerPort(java.lang.String helpServerPort)
void | setIi(java.lang.Long ii)
void | setLanguage(java.lang.String language)
void | setSpaceHomePage(java.lang.String spaceHomePage)
void | setWikiSpaceName(java.lang.String wikiSpaceName)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_II

public static final java.lang.String ORDER_BY_II
See Also:
Constant Field Values

ORDER_BY_helpServerIP

public static final java.lang.String ORDER_BY_helpServerIP
See Also:
Constant Field Values

ORDER_BY_helpServerPort

public static final java.lang.String ORDER_BY_helpServerPort
See Also:
Constant Field Values

ORDER_BY_wikiSpaceName

public static final java.lang.String ORDER_BY_wikiSpaceName
See Also:
Constant Field Values

ORDER_BY_spaceHomePage

public static final java.lang.String ORDER_BY_spaceHomePage
See Also:
Constant Field Values

ORDER_BY_language

public static final java.lang.String ORDER_BY_language
See Also:
Constant Field Values

ORDER_BY_actived

public static final java.lang.String ORDER_BY_actived
See Also:
Constant Field Values

ORDER_BY_description

public static final java.lang.String ORDER_BY_description
See Also:
Constant Field Values
Constructor Detail

HelpServerVO

public HelpServerVO()
Method Detail

isActived

public boolean isActived()

setActived

public void setActived(boolean actived)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getHelpServerIP

public java.lang.String getHelpServerIP()

setHelpServerIP

public void setHelpServerIP(java.lang.String helpServerIP)

getHelpServerPort

public java.lang.String getHelpServerPort()

setHelpServerPort

public void setHelpServerPort(java.lang.String helpServerPort)

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getSpaceHomePage

public java.lang.String getSpaceHomePage()

setSpaceHomePage

public void setSpaceHomePage(java.lang.String spaceHomePage)

getWikiSpaceName

public java.lang.String getWikiSpaceName()

setWikiSpaceName

public void setWikiSpaceName(java.lang.String wikiSpaceName)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HighUsagePartResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class HighUsagePartResult

java.lang.Object
    extended by  bb.common.HighUsagePartResult
All Implemented Interfaces:
java.io.Serializable
public class HighUsagePartResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_PART
static java.lang.String | ORDER_BY_QTR1QTY
static java.lang.String | ORDER_BY_QTR2QTY
static java.lang.String | ORDER_BY_QTR3QTY
static java.lang.String | ORDER_BY_QTR4QTY
static java.lang.String | ORDER_BY_YTRQTY
Constructor Summary
HighUsagePartResult()
Method Summary
java.lang.String | getDescription()
BB2Part | getPart()
java.math.BigDecimal | getQtr1Qty()
java.math.BigDecimal | getQtr2Qty()
java.math.BigDecimal | getQtr3Qty()
java.math.BigDecimal | getQtr4Qty()
java.util.List<java.lang.String> | getVendors()
java.math.BigDecimal | getYtrQty()
void | setDescription(java.lang.String description)
void | setPart(BB2Part part)
void | setQtr1Qty(java.math.BigDecimal qtr1Qty)
void | setQtr2Qty(java.math.BigDecimal qtr2Qty)
void | setQtr3Qty(java.math.BigDecimal qtr3Qty)
void | setQtr4Qty(java.math.BigDecimal qtr4Qty)
void | setVendors(java.util.List<java.lang.String> vendors)
void | setYtrQty(java.math.BigDecimal ytrQty)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PART

public static final java.lang.String ORDER_BY_PART
See Also:
Constant Field Values

ORDER_BY_YTRQTY

public static final java.lang.String ORDER_BY_YTRQTY
See Also:
Constant Field Values

ORDER_BY_QTR1QTY

public static final java.lang.String ORDER_BY_QTR1QTY
See Also:
Constant Field Values

ORDER_BY_QTR2QTY

public static final java.lang.String ORDER_BY_QTR2QTY
See Also:
Constant Field Values

ORDER_BY_QTR3QTY

public static final java.lang.String ORDER_BY_QTR3QTY
See Also:
Constant Field Values

ORDER_BY_QTR4QTY

public static final java.lang.String ORDER_BY_QTR4QTY
See Also:
Constant Field Values
Constructor Detail

HighUsagePartResult

public HighUsagePartResult()
Method Detail

getPart

public BB2Part getPart()

setPart

public void setPart(BB2Part part)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getYtrQty

public java.math.BigDecimal getYtrQty()

setYtrQty

public void setYtrQty(java.math.BigDecimal ytrQty)

getQtr1Qty

public java.math.BigDecimal getQtr1Qty()

setQtr1Qty

public void setQtr1Qty(java.math.BigDecimal qtr1Qty)

getQtr2Qty

public java.math.BigDecimal getQtr2Qty()

setQtr2Qty

public void setQtr2Qty(java.math.BigDecimal qtr2Qty)

getQtr3Qty

public java.math.BigDecimal getQtr3Qty()

setQtr3Qty

public void setQtr3Qty(java.math.BigDecimal qtr3Qty)

getQtr4Qty

public java.math.BigDecimal getQtr4Qty()

setQtr4Qty

public void setQtr4Qty(java.math.BigDecimal qtr4Qty)

getVendors

public java.util.List<java.lang.String> getVendors()

setVendors

public void setVendors(java.util.List<java.lang.String> vendors)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


H-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M N O P Q R S T U V W X Y Z

H

HALFYEAR - Static variable in class bb.common.Constant.CycleCountPeriodUnit
HALFYEAR - Static variable in class bb.common.Constant.PeriodUnit
hashCode() - Method in class bb.common.AccountCreditDebitPK
hashCode() - Method in class bb.common.AccountCreditVO
hashCode() - Method in class bb.common.AccountDebitVO
hashCode() - Method in class bb.common.AccountingConfigurationVO
hashCode() - Method in class bb.common.AccountingSettingsVO
hashCode() - Method in class bb.common.AccountingTransactionTypeVO
hashCode() - Method in class bb.common.AccountMonthPK
hashCode() - Method in class bb.common.AccountPayableCheckRunItemVO
hashCode() - Method in class bb.common.AccountPayableCheckRunVO
hashCode() - Method in class bb.common.AccountReceivablePaymentVO
hashCode() - Method in class bb.common.AccountsChartCategoryVO
hashCode() - Method in class bb.common.AccountsChartMappingPK
hashCode() - Method in class bb.common.AccountsChartMappingVO
hashCode() - Method in class bb.common.AccountsChartVO
hashCode() - Method in class bb.common.AccountsPayableInfoVO
hashCode() - Method in class bb.common.AccountsPayableItemManufacturerPK
hashCode() - Method in class bb.common.AccountsPayableItemManufacturerVO
hashCode() - Method in class bb.common.AccountsPayableItemPK
hashCode() - Method in class bb.common.AccountsPayableItemVO
hashCode() - Method in class bb.common.AccountsPayableVO
hashCode() - Method in class bb.common.AccountsReceivableInfoVO
hashCode() - Method in class bb.common.AccountsReceivableItemManufacturerPK
hashCode() - Method in class bb.common.AccountsReceivableItemManufacturerVO
hashCode() - Method in class bb.common.AccountsReceivableItemPK
hashCode() - Method in class bb.common.AccountsReceivableItemVO
hashCode() - Method in class bb.common.AccountsReceivableVO
hashCode() - Method in class bb.common.AddProformaReceiverItemAgent
hashCode() - Method in class bb.common.AllPartDocumentsPK
hashCode() - Method in class bb.common.AllPartDocumentsVO
hashCode() - Method in class bb.common.ApPrepayItemPK
hashCode() - Method in class bb.common.ApPrepayItemVO
hashCode() - Method in class bb.common.ApPrepayVO
hashCode() - Method in class bb.common.ARBoilerplateVO
hashCode() - Method in class bb.common.ARPaymentRunItemPK
hashCode() - Method in class bb.common.ARPaymentRunItemVO
hashCode() - Method in class bb.common.ARPaymentRunVO
hashCode() - Method in class bb.common.ArPrepayItemPK
hashCode() - Method in class bb.common.ArPrepayItemVO
hashCode() - Method in class bb.common.ArPrepayVO
hashCode() - Method in class bb.common.AssetAmortizationExpenseAccountPK
hashCode() - Method in class bb.common.AssetAmortizationExpenseAccountVO
hashCode() - Method in class bb.common.AssetDepreciatePK
hashCode() - Method in class bb.common.AssetDepreciateVO
hashCode() - Method in class bb.common.AssetTypeVO
hashCode() - Method in class bb.common.AssetUsagePK
hashCode() - Method in class bb.common.AssetVO
hashCode() - Method in class bb.common.AuditLogVO
hashCode() - Method in class bb.common.BankReconciliationReportVO
hashCode() - Method in class bb.common.BB2BigDecimalAndString
hashCode() - Method in class bb.common.BB2DoubleCost
hashCode() - Method in class bb.common.BB2DoubleString
hashCode() - Method in class bb.common.BB2Part
hashCode() - Method in class bb.common.BB2RefdocPK
hashCode() - Method in class bb.common.BB2tripleString
hashCode() - Method in class bb.common.BillItemPK
hashCode() - Method in class bb.common.BillItemReplacementVO
hashCode() - Method in class bb.common.BillItemVO
hashCode() - Method in class bb.common.BillItemWithPartInfoResult
hashCode() - Method in class bb.common.BillLogVO
hashCode() - Method in class bb.common.BillPK
hashCode() - Method in class bb.common.BillVO
hashCode() - Method in class bb.common.BizboxBugChangesInfoVO
hashCode() - Method in class bb.common.BizboxBugChangesVO
hashCode() - Method in class bb.common.BizboxBugInfoVO
hashCode() - Method in class bb.common.BizboxBugVO
hashCode() - Method in class bb.common.BizBoxUserEmployeeResult
hashCode() - Method in class bb.common.BizboxUserVO
hashCode() - Method in class bb.common.BomApprovalVO
hashCode() - Method in class bb.common.BuyerCodeVO
hashCode() - Method in class bb.common.CarrierPK
hashCode() - Method in class bb.common.CarrierVO
hashCode() - Method in class bb.common.CatalogVO
hashCode() - Method in class bb.common.CertificateDescriptionVO
hashCode() - Method in class bb.common.ChangeStdCostWorkSheetItemPK
hashCode() - Method in class bb.common.ChangeStdCostWorkSheetItemVO
hashCode() - Method in class bb.common.ChangeStdCostWorkSheetVO
hashCode() - Method in class bb.common.CompanyUnitAccountPK
hashCode() - Method in class bb.common.CompanyUnitAccountVO
hashCode() - Method in class bb.common.CompanyUnitVO
hashCode() - Method in class bb.common.CompanyVO
hashCode() - Method in class bb.common.ContractPriceCustomerPK
hashCode() - Method in class bb.common.ContractPriceCustomerVO
hashCode() - Method in class bb.common.ContractPriceItemPK
hashCode() - Method in class bb.common.ContractPriceItemVO
hashCode() - Method in class bb.common.ContractPriceVO
hashCode() - Method in class bb.common.CorrectiveActionRequestVO
hashCode() - Method in class bb.common.CurrencyExchangePK
hashCode() - Method in class bb.common.CurrencyExchangeVO
hashCode() - Method in class bb.common.CurrencyVO
hashCode() - Method in class bb.common.CustomAssetRecordPK
hashCode() - Method in class bb.common.CustomAssetRecordVO
hashCode() - Method in class bb.common.CustomAssetVO
hashCode() - Method in class bb.common.CustomCheckUpEmployeeVO
hashCode() - Method in class bb.common.CustomDepartmentVO
hashCode() - Method in class bb.common.CustomEmployeeTrainPK
hashCode() - Method in class bb.common.CustomEmployeeTrainVO
hashCode() - Method in class bb.common.CustomEmployeeVO
hashCode() - Method in class bb.common.CustomEmployeeWorkExperienceVO
hashCode() - Method in class bb.common.CustomerFeedbackVO
hashCode() - Method in class bb.common.CustomerReturnToVendorItemPK
hashCode() - Method in class bb.common.CustomerReturnToVendorItemVO
hashCode() - Method in class bb.common.CustomerReturnToVendorVO
hashCode() - Method in class bb.common.CustomerServiceIncidentVO
hashCode() - Method in class bb.common.CustomerVendorAddressInfoVO
hashCode() - Method in class bb.common.CustomerVendorAddressVO
hashCode() - Method in class bb.common.CustomerVendorContactPK
hashCode() - Method in class bb.common.CustomerVendorContactVO
hashCode() - Method in class bb.common.CustomerVendorDescriptionPK
hashCode() - Method in class bb.common.CustomerVendorDescriptionVO
hashCode() - Method in class bb.common.CustomerVendorTypeVO
hashCode() - Method in class bb.common.CustomGoodsBreedVO
hashCode() - Method in class bb.common.CustomGoodsRecordVO
hashCode() - Method in class bb.common.CustomJobCategoryGoodsPK
hashCode() - Method in class bb.common.CustomJobCategoryGoodsVO
hashCode() - Method in class bb.common.CustomJobCategoryVO
hashCode() - Method in class bb.common.CustomSearchVO
hashCode() - Method in class bb.common.CustomTranslationVO
hashCode() - Method in class bb.common.CycleCountAgent
hashCode() - Method in class bb.common.CycleCountPK
hashCode() - Method in class bb.common.CycleCountVO
hashCode() - Method in class bb.common.DepartmentLocationForBackflushVO
hashCode() - Method in class bb.common.DesignControlDocumentVO
hashCode() - Method in class bb.common.DesignControlInfoVO
hashCode() - Method in class bb.common.DesignControlVO
hashCode() - Method in class bb.common.DisassembleWorkOrderApprovalVO
hashCode() - Method in class bb.common.DisassembleWorkOrderIssueVO
hashCode() - Method in class bb.common.DisassembleWorkOrderItemPK
hashCode() - Method in class bb.common.DisassembleWorkOrderItemReceiverPK
hashCode() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO
hashCode() - Method in class bb.common.DisassembleWorkOrderItemVO
hashCode() - Method in class bb.common.DisassembleWorkOrderVO
hashCode() - Method in class bb.common.DocumentLogVO
hashCode() - Method in class bb.common.DocumentServerVO
hashCode() - Method in class bb.common.DwfUploadSettingsVO
hashCode() - Method in class bb.common.DwgUploadSettingsVO
hashCode() - Method in class bb.common.ECNReviewVO
hashCode() - Method in class bb.common.ECRReviewVO
hashCode() - Method in class bb.common.EjbMethodVO
hashCode() - Method in class bb.common.EmployeeCardVO
hashCode() - Method in class bb.common.EmployeeEducationPK
hashCode() - Method in class bb.common.EmployeeJobDescriptionVO
hashCode() - Method in class bb.common.EmployeeWorkExperiencePK
hashCode() - Method in class bb.common.EngGroupUserPK
hashCode() - Method in class bb.common.EngGroupVO
hashCode() - Method in class bb.common.EngineeringChangeDocumentVO
hashCode() - Method in class bb.common.EngineeringChangeRequestDocumentVO
hashCode() - Method in class bb.common.EngineeringChangeRequestVO
hashCode() - Method in class bb.common.EngineeringChangeVO
hashCode() - Method in class bb.common.EngineeringSharingItemPK
hashCode() - Method in class bb.common.EngineeringSharingItemVO
hashCode() - Method in class bb.common.EngineeringSharingVO
hashCode() - Method in class bb.common.EquipmentVO
hashCode() - Method in class bb.common.ExpenseAccountVO
hashCode() - Method in class bb.common.ExpenseItemPK
hashCode() - Method in class bb.common.ExpenseItemVO
hashCode() - Method in class bb.common.ExpenseVO
hashCode() - Method in class bb.common.FeedbackAnswerPK
hashCode() - Method in class bb.common.FeedbackAnswerVO
hashCode() - Method in class bb.common.FeedBackItemPK
hashCode() - Method in class bb.common.FeedbackItemVO
hashCode() - Method in class bb.common.FeedbackQuestionVO
hashCode() - Method in class bb.common.FiscalYearSettingsVO
hashCode() - Method in class bb.common.GeneralLedgerApprovalVO
hashCode() - Method in class bb.common.GeneralLedgerSettingsVO
hashCode() - Method in class bb.common.GeneralLedgerVO
hashCode() - Method in class bb.common.GLAutoApproveVO
hashCode() - Method in class bb.common.GlCashFlowBudgetVO
hashCode() - Method in class bb.common.GlFiscalYearBudgetVO
hashCode() - Method in class bb.common.GLItemVO
hashCode() - Method in class bb.common.GlMonthBudgetVO
hashCode() - Method in class bb.common.GlMonthVO
hashCode() - Method in class bb.common.GroupUserPK
hashCode() - Method in class bb.common.HelpServerVO
hashCode() - Method in class bb.common.HistoricalInventoryVO
hashCode() - Method in class bb.common.ImportDataVO
hashCode() - Method in class bb.common.IncotermVO
hashCode() - Method in class bb.common.InspectionConformanceReportItemCheckPK
hashCode() - Method in class bb.common.InspectionConformanceReportItemCheckVO
hashCode() - Method in class bb.common.InspectionConformanceReportItemPK
hashCode() - Method in class bb.common.InspectionConformanceReportItemVO
hashCode() - Method in class bb.common.InspectionConformanceReportVO
hashCode() - Method in class bb.common.InspectionItemPK
hashCode() - Method in class bb.common.InspectionItemVO
hashCode() - Method in class bb.common.InspectionReportInfoVO
hashCode() - Method in class bb.common.InspectionReportInspectMethodItemPK
hashCode() - Method in class bb.common.InspectionReportInspectMethodItemVO
hashCode() - Method in class bb.common.InspectionReportInspectMethodVO
hashCode() - Method in class bb.common.InspectionReportInspectStandardItemPK
hashCode() - Method in class bb.common.InspectionReportInspectStandardItemVO
hashCode() - Method in class bb.common.InspectionReportItemPK
hashCode() - Method in class bb.common.InspectionReportItemQtyPK
hashCode() - Method in class bb.common.InspectionReportItemQtyVO
hashCode() - Method in class bb.common.InspectionReportItemVO
hashCode() - Method in class bb.common.InspectionReportVO
hashCode() - Method in class bb.common.InspectionTypeItemPK
hashCode() - Method in class bb.common.InspectionTypeItemVO
hashCode() - Method in class bb.common.InspectionTypeVO
hashCode() - Method in class bb.common.IpAddressVO
hashCode() - Method in class bb.common.LabelTemplateItemPK
hashCode() - Method in class bb.common.LabelTemplateItemVO
hashCode() - Method in class bb.common.LabelTemplateVO
hashCode() - Method in class bb.common.LogInventoryVO
hashCode() - Method in class bb.common.LogMethodPK
hashCode() - Method in class bb.common.LogMethodVO
hashCode() - Method in class bb.common.LogPartDocumentVO
hashCode() - Method in class bb.common.LogTrackingVO
hashCode() - Method in class bb.common.MaintenanceItemPK
hashCode() - Method in class bb.common.MaintenanceItemVO
hashCode() - Method in class bb.common.ManufacturerAddressInfoVO
hashCode() - Method in class bb.common.ManufacturerAddressVO
hashCode() - Method in class bb.common.ManufacturerContactPK
hashCode() - Method in class bb.common.ManufacturerContactVO
hashCode() - Method in class bb.common.ManufacturerDescriptionPK
hashCode() - Method in class bb.common.ManufacturerDescriptionVO
hashCode() - Method in class bb.common.MessageVO
hashCode() - Method in class bb.common.MultiLanguageAccountsChartPK
hashCode() - Method in class bb.common.MultiLanguageAccountsChartVO
hashCode() - Method in class bb.common.MyPrintListPK
hashCode() - Method in class bb.common.MyPrintListVO
hashCode() - Method in class bb.common.NcrApprovalPK
hashCode() - Method in class bb.common.NcrApprovalVO
hashCode() - Method in class bb.common.NCRPartOnhandPK
hashCode() - Method in class bb.common.NCRPictureVO
hashCode() - Method in class bb.common.NonConformanceCodeDescriptionPK
hashCode() - Method in class bb.common.NonConformanceCodeDescriptionVO
hashCode() - Method in class bb.common.NonConformanceCodeVO
hashCode() - Method in class bb.common.NonConformanceQuantityPK
hashCode() - Method in class bb.common.NonConformanceQuantityVO
hashCode() - Method in class bb.common.NonConformanceReportVO
hashCode() - Method in class bb.common.NonproductivePickingItemIssuedVO
hashCode() - Method in class bb.common.NonproductivePickingItemPK
hashCode() - Method in class bb.common.NonproductivePickingItemVO
hashCode() - Method in class bb.common.NonproductivePickingTypeVO
hashCode() - Method in class bb.common.NonproductivePickingVO
hashCode() - Method in class bb.common.OnLoanItemPK
hashCode() - Method in class bb.common.OnLoanItemVO
hashCode() - Method in class bb.common.OnloanReceiverItemPK
hashCode() - Method in class bb.common.OnloanReceiverItemVO
hashCode() - Method in class bb.common.OnloanReceiverVO
hashCode() - Method in class bb.common.OnloanReviewVO
hashCode() - Method in class bb.common.OnloanShipperItemPK
hashCode() - Method in class bb.common.OnloanShipperItemVO
hashCode() - Method in class bb.common.OnloanShipperVO
hashCode() - Method in class bb.common.OnLoanVO
hashCode() - Method in class bb.common.OpCodeShortcutPK
hashCode() - Method in class bb.common.OperatingInstructionsInspectMethodItemPK
hashCode() - Method in class bb.common.OperatingInstructionsInspectMethodItemVO
hashCode() - Method in class bb.common.OperatingInstructionsInspectResultItemPK
hashCode() - Method in class bb.common.OperatingInstructionsInspectResultItemVO
hashCode() - Method in class bb.common.OperatingInstructionsInspectStandardItemPK
hashCode() - Method in class bb.common.OperatingInstructionsInspectStandardItemVO
hashCode() - Method in class bb.common.OperatingInstructionsInspectStandardVO
hashCode() - Method in class bb.common.OperatingInstructionsManualItemPK
hashCode() - Method in class bb.common.OperatingInstructionsManualItemVO
hashCode() - Method in class bb.common.OperatingInstructionsManualVO
hashCode() - Method in class bb.common.OperatingInstructionsTypeVO
hashCode() - Method in class bb.common.OperatingInstructionsVO
hashCode() - Method in class bb.common.OperatingOutputFileItemPK
hashCode() - Method in class bb.common.OperatingOutputFileItemVO
hashCode() - Method in class bb.common.OperatingOutputFileTypeVO
hashCode() - Method in class bb.common.OperationLogVO
hashCode() - Method in class bb.common.OrderApprovalItemsVO
hashCode() - Method in class bb.common.OrderBoilerplatePK
hashCode() - Method in class bb.common.OrderBoilerplateVO
hashCode() - Method in class bb.common.OrderPK
hashCode() - Method in class bb.common.PackingBoxItemPK
hashCode() - Method in class bb.common.PackingBoxItemVO
hashCode() - Method in class bb.common.PackingBoxPK
hashCode() - Method in class bb.common.PackingBoxSalesOrderItemAgent
hashCode() - Method in class bb.common.PackingBoxVO
hashCode() - Method in class bb.common.PartBasicInfo
hashCode() - Method in class bb.common.PartCatagoryPK
hashCode() - Method in class bb.common.PartCatagoryVO
hashCode() - Method in class bb.common.PartCatalogAuditResult
hashCode() - Method in class bb.common.PartCatalogPK
hashCode() - Method in class bb.common.PartCatalogVO
hashCode() - Method in class bb.common.PartCertificateVO
hashCode() - Method in class bb.common.PartClassVO
hashCode() - Method in class bb.common.PartDescriptionPK
hashCode() - Method in class bb.common.PartDescriptionVO
hashCode() - Method in class bb.common.PartDiscountPK
hashCode() - Method in class bb.common.PartDiscountVO
hashCode() - Method in class bb.common.PartDocumentPK
hashCode() - Method in class bb.common.PartDocumentVO
hashCode() - Method in class bb.common.PartDwfPK
hashCode() - Method in class bb.common.PartDwfVO
hashCode() - Method in class bb.common.PartDwgPK
hashCode() - Method in class bb.common.PartDwgVO
hashCode() - Method in class bb.common.PartExportInfo
hashCode() - Method in class bb.common.PartInQAResult
hashCode() - Method in class bb.common.PartInQAVO
hashCode() - Method in class bb.common.PartInspectionPK
hashCode() - Method in class bb.common.PartInspectionVO
hashCode() - Method in class bb.common.PartInventoryVO
hashCode() - Method in class bb.common.PartIssuedVO
hashCode() - Method in class bb.common.PartManufacturerPK
hashCode() - Method in class bb.common.PartManufacturerVO
hashCode() - Method in class bb.common.PartMaterialVO
hashCode() - Method in class bb.common.PartMRPVO
hashCode() - Method in class bb.common.PartOnhandPK
hashCode() - Method in class bb.common.PartOnhandVO
hashCode() - Method in class bb.common.PartOnhandWithAverageCostResult
hashCode() - Method in class bb.common.PartPictureVO
hashCode() - Method in class bb.common.PartPK
hashCode() - Method in class bb.common.PartReceivedVO
hashCode() - Method in class bb.common.PartSecurityLevelVO
hashCode() - Method in class bb.common.PartTraceableCategoryPK
hashCode() - Method in class bb.common.PartTraceableCategoryVO
hashCode() - Method in class bb.common.PartTraceableSpecPK
hashCode() - Method in class bb.common.PartTraceableSpecVO
hashCode() - Method in class bb.common.PartTrackingPK
hashCode() - Method in class bb.common.PartTrackingVO
hashCode() - Method in class bb.common.PartTypeVO
hashCode() - Method in class bb.common.PartUnitPK
hashCode() - Method in class bb.common.PartUnitVO
hashCode() - Method in class bb.common.PartUseTypeVO
hashCode() - Method in class bb.common.PartVendorPK
hashCode() - Method in class bb.common.PartVendorVO
hashCode() - Method in class bb.common.PartVO
hashCode() - Method in class bb.common.PartWithOnhandsVO
hashCode() - Method in class bb.common.PartWithoutLocateResult
hashCode() - Method in class bb.common.PayableCheckRunItemPK
hashCode() - Method in class bb.common.PayableMethodVO
hashCode() - Method in class bb.common.PaymentHistoryVO
hashCode() - Method in class bb.common.PermissionDescriptionPK
hashCode() - Method in class bb.common.PermissionDescriptionVO
hashCode() - Method in class bb.common.PermissionMethodPK
hashCode() - Method in class bb.common.PermissionMethodVO
hashCode() - Method in class bb.common.PermissionVO
hashCode() - Method in class bb.common.PfReceiverItemPK
hashCode() - Method in class bb.common.PfReceiverItemVO
hashCode() - Method in class bb.common.PfReceiverItemWithNumberPK
hashCode() - Method in class bb.common.PfReceiverVO
hashCode() - Method in class bb.common.PhysicalInventoryPK
hashCode() - Method in class bb.common.PhysicalInventoryVO
hashCode() - Method in class bb.common.PointOfSaleVO
hashCode() - Method in class bb.common.PoMessageItemPK
hashCode() - Method in class bb.common.PoMessageItemVO
hashCode() - Method in class bb.common.PoMessageVO
hashCode() - Method in class bb.common.PosRefdocVO
hashCode() - Method in class bb.common.POSurveyReportItemPK
hashCode() - Method in class bb.common.POSurveyReportItemVO
hashCode() - Method in class bb.common.POSurveyReportVO
hashCode() - Method in class bb.common.PosZipCodeTaxPK
hashCode() - Method in class bb.common.PosZipCodeTaxVO
hashCode() - Method in class bb.common.PreventiveActionRequestVO
hashCode() - Method in class bb.common.PrintLogoVO
hashCode() - Method in class bb.common.PrintTemplateVO
hashCode() - Method in class bb.common.ProformaInvoiceItemManufacturerPK
hashCode() - Method in class bb.common.ProformaInvoiceItemManufacturerVO
hashCode() - Method in class bb.common.ProformaInvoiceItemPK
hashCode() - Method in class bb.common.ProformaInvoiceItemVO
hashCode() - Method in class bb.common.ProformaInvoiceVO
hashCode() - Method in class bb.common.PrPackingBoxItemPK
hashCode() - Method in class bb.common.PrPackingBoxItemVO
hashCode() - Method in class bb.common.PrPackingBoxPK
hashCode() - Method in class bb.common.PrPackingBoxVO
hashCode() - Method in class bb.common.PurchaseOrderApprovalVO
hashCode() - Method in class bb.common.PurchaseOrderBoilerplateVO
hashCode() - Method in class bb.common.PurchaseOrderItemManufacturerPK
hashCode() - Method in class bb.common.PurchaseOrderItemManufacturerVO
hashCode() - Method in class bb.common.PurchaseOrderItemPK
hashCode() - Method in class bb.common.PurchaseOrderItemVO
hashCode() - Method in class bb.common.PurchaseOrderVO
hashCode() - Method in class bb.common.PurchaseWorkSheetItemPK
hashCode() - Method in class bb.common.PurchaseWorkSheetItemVO
hashCode() - Method in class bb.common.PurchaseWorkSheetPK
hashCode() - Method in class bb.common.PurchaseWorkSheetVO
hashCode() - Method in class bb.common.QualityGroupPK
hashCode() - Method in class bb.common.QualityGroupVO
hashCode() - Method in class bb.common.QuoteBoilerplateVO
hashCode() - Method in class bb.common.QuoteItemManufacturerPK
hashCode() - Method in class bb.common.QuoteItemManufacturerVO
hashCode() - Method in class bb.common.QuoteItemPK
hashCode() - Method in class bb.common.QuoteItemVO
hashCode() - Method in class bb.common.QuoteVO
hashCode() - Method in class bb.common.ReceiverInfoVO
hashCode() - Method in class bb.common.ReceiverItemAgent
hashCode() - Method in class bb.common.ReceiverItemManufacturerPK
hashCode() - Method in class bb.common.ReceiverItemManufacturerVO
hashCode() - Method in class bb.common.ReceiverItemPK
hashCode() - Method in class bb.common.ReceiverItemTrackingLogAgent
hashCode() - Method in class bb.common.ReceiverItemVO
hashCode() - Method in class bb.common.ReceiverVO
hashCode() - Method in class bb.common.RefdocVO
hashCode() - Method in class bb.common.RequestForQuoteItemManufacturerPK
hashCode() - Method in class bb.common.RequestForQuoteItemManufacturerVO
hashCode() - Method in class bb.common.RequestForQuoteItemPK
hashCode() - Method in class bb.common.RequestForQuoteItemVO
hashCode() - Method in class bb.common.RequestForQuoteVO
hashCode() - Method in class bb.common.RequestForRMAItemPK
hashCode() - Method in class bb.common.RequestForRMAItemVO
hashCode() - Method in class bb.common.RequestForRMAVO
hashCode() - Method in class bb.common.ReturnMaterialAuthorizationItemManufacturerPK
hashCode() - Method in class bb.common.ReturnMaterialAuthorizationItemManufacturerVO
hashCode() - Method in class bb.common.ReturnMaterialAuthorizationItemPK
hashCode() - Method in class bb.common.ReturnMaterialAuthorizationItemVO
hashCode() - Method in class bb.common.ReturnMaterialAuthorizationVO
hashCode() - Method in class bb.common.ReturnToVendorItemManufacturerPK
hashCode() - Method in class bb.common.ReturnToVendorItemManufacturerVO
hashCode() - Method in class bb.common.ReturnToVendorItemPK
hashCode() - Method in class bb.common.ReturnToVendorItemVO
hashCode() - Method in class bb.common.ReturnToVendorVO
hashCode() - Method in class bb.common.RfqMessageItemPK
hashCode() - Method in class bb.common.RfqMessageItemVO
hashCode() - Method in class bb.common.RfqMessageVO
hashCode() - Method in class bb.common.RMAReceiverItemPK
hashCode() - Method in class bb.common.RMAReceiverItemVO
hashCode() - Method in class bb.common.RMAReceiverVO
hashCode() - Method in class bb.common.RMAReviewVO
hashCode() - Method in class bb.common.RoleDescriptionPK
hashCode() - Method in class bb.common.RoleDescriptionVO
hashCode() - Method in class bb.common.RolePermissionPK
hashCode() - Method in class bb.common.RolePermissionVO
hashCode() - Method in class bb.common.RoleVO
hashCode() - Method in class bb.common.RollUpBomStdCostWorkSheetItemPK
hashCode() - Method in class bb.common.RollUpBomStdCostWorkSheetItemVO
hashCode() - Method in class bb.common.RollUpBomStdCostWorkSheetVO
hashCode() - Method in class bb.common.RollUPPartStandardCostResult
hashCode() - Method in class bb.common.RTVApprovalVO
hashCode() - Method in class bb.common.RtvShipperInfoVO
hashCode() - Method in class bb.common.RtvShipperItemPK
hashCode() - Method in class bb.common.RtvShipperItemVO
hashCode() - Method in class bb.common.RtvShipperVO
hashCode() - Method in class bb.common.RunningAccountOrderItemPK
hashCode() - Method in class bb.common.RunningAccountOrderItemVO
hashCode() - Method in class bb.common.RunningAccountOrderVO
hashCode() - Method in class bb.common.SalesCodeVO
hashCode() - Method in class bb.common.SalesmanVO
hashCode() - Method in class bb.common.SalesOrderBoilerplateVO
hashCode() - Method in class bb.common.SalesOrderItemInfoVO
hashCode() - Method in class bb.common.SalesOrderItemManufacturerPK
hashCode() - Method in class bb.common.SalesOrderItemManufacturerVO
hashCode() - Method in class bb.common.SalesOrderItemPK
hashCode() - Method in class bb.common.SalesOrderItemVO
hashCode() - Method in class bb.common.SalesOrderListResult
hashCode() - Method in class bb.common.SalesOrderReviewVO
hashCode() - Method in class bb.common.SalesOrderVO
hashCode() - Method in class bb.common.ScrapReportVO
hashCode() - Method in class bb.common.SerialNumberItemPK
hashCode() - Method in class bb.common.SerialNumberItemVO
hashCode() - Method in class bb.common.SerialNumberPK
hashCode() - Method in class bb.common.SerialNumberVO
hashCode() - Method in class bb.common.ServerClientPropertyPK
hashCode() - Method in class bb.common.SGBillItemPK
hashCode() - Method in class bb.common.SGBillItemVO
hashCode() - Method in class bb.common.SGClientAccountPK
hashCode() - Method in class bb.common.SGClientAccountVO
hashCode() - Method in class bb.common.SgClientProgramUserVO
hashCode() - Method in class bb.common.SGCompanyPK
hashCode() - Method in class bb.common.SGCompanyVO
hashCode() - Method in class bb.common.SGCustomerCatalogPK
hashCode() - Method in class bb.common.SGCustomerCatalogVO
hashCode() - Method in class bb.common.SGCustomerServiceRequestVO
hashCode() - Method in class bb.common.SGCustRequestForQuoteItemPK
hashCode() - Method in class bb.common.SGCustRequestForQuoteItemVO
hashCode() - Method in class bb.common.SGCustRequestForQuoteVO
hashCode() - Method in class bb.common.SGDocPartPK
hashCode() - Method in class bb.common.SGDocPartVO
hashCode() - Method in class bb.common.SGDwgPicturePK
hashCode() - Method in class bb.common.SGDwgPictureVO
hashCode() - Method in class bb.common.SGLogLoginVO
hashCode() - Method in class bb.common.SGPicturePK
hashCode() - Method in class bb.common.SGPictureVO
hashCode() - Method in class bb.common.SGQuoteAddressVO
hashCode() - Method in class bb.common.SGQuoteCartVO
hashCode() - Method in class bb.common.SGQuoteLoginVO
hashCode() - Method in class bb.common.SGSaleItemVO
hashCode() - Method in class bb.common.SGWeightUnitVO
hashCode() - Method in class bb.common.ShipListInfoVO
hashCode() - Method in class bb.common.ShipListItemPK
hashCode() - Method in class bb.common.ShipListItemVO
hashCode() - Method in class bb.common.ShipListOwnerAttributePK
hashCode() - Method in class bb.common.ShipListOwnerAttributeVO
hashCode() - Method in class bb.common.ShipListOwnerVO
hashCode() - Method in class bb.common.ShipListVO
hashCode() - Method in class bb.common.ShipperInfoVO
hashCode() - Method in class bb.common.ShipperItemManufacturerPK
hashCode() - Method in class bb.common.ShipperItemManufacturerVO
hashCode() - Method in class bb.common.ShipperItemPK
hashCode() - Method in class bb.common.ShipperItemVO
hashCode() - Method in class bb.common.ShipperVO
hashCode() - Method in class bb.common.SmtpServerVO
hashCode() - Method in class bb.common.SubcompanyVO
hashCode() - Method in class bb.common.SwapOrderApprovalVO
hashCode() - Method in class bb.common.SwapOrderItemPK
hashCode() - Method in class bb.common.SwapOrderItemVO
hashCode() - Method in class bb.common.SwapOrderVO
hashCode() - Method in class bb.common.SwapReceiverItemPK
hashCode() - Method in class bb.common.SwapReceiverItemVO
hashCode() - Method in class bb.common.SwapReceiverVO
hashCode() - Method in class bb.common.SwapShipperItemPK
hashCode() - Method in class bb.common.SwapShipperItemVO
hashCode() - Method in class bb.common.SwapShipperVO
hashCode() - Method in class bb.common.TaskVO
hashCode() - Method in class bb.common.TaxAccountVO
hashCode() - Method in class bb.common.TermsConditionVO
hashCode() - Method in class bb.common.TermVO
hashCode() - Method in class bb.common.ToolCalibrationVO
hashCode() - Method in class bb.common.ToolDescriptionVO
hashCode() - Method in class bb.common.ToolInventoryVO
hashCode() - Method in class bb.common.ToolListInfoVO
hashCode() - Method in class bb.common.ToolListItemVO
hashCode() - Method in class bb.common.ToolListItemWithToolInfoResult
hashCode() - Method in class bb.common.ToolListVO
hashCode() - Method in class bb.common.ToolManufacturerVO
hashCode() - Method in class bb.common.ToolOnhandVO
hashCode() - Method in class bb.common.ToolOnhandWithAverageCostResult
hashCode() - Method in class bb.common.ToolVendorVO
hashCode() - Method in class bb.common.ToolVO
hashCode() - Method in class bb.common.ToolWithOnhandsVO
hashCode() - Method in class bb.common.TraceableCategoriesVO
hashCode() - Method in class bb.common.TraceableSpecsVO
hashCode() - Method in class bb.common.TransferOrderApprovalVO
hashCode() - Method in class bb.common.TransferOrderItemPK
hashCode() - Method in class bb.common.TransferOrderItemVO
hashCode() - Method in class bb.common.TransferOrderVO
hashCode() - Method in class bb.common.TransferReceiverItemPK
hashCode() - Method in class bb.common.TransferReceiverItemVO
hashCode() - Method in class bb.common.TransferReceiverVO
hashCode() - Method in class bb.common.TransferShipperItemPK
hashCode() - Method in class bb.common.TransferShipperItemVO
hashCode() - Method in class bb.common.TransferShipperVO
hashCode() - Method in class bb.common.UnitVO
hashCode() - Method in class bb.common.UpdatePhysicalInventoryAgent
hashCode() - Method in class bb.common.UserGroupVO
hashCode() - Method in class bb.common.UserRolePK
hashCode() - Method in class bb.common.UserRoleVO
hashCode() - Method in class bb.common.VendorCategoriesVO
hashCode() - Method in class bb.common.VendorContractPriceItemPK
hashCode() - Method in class bb.common.VendorContractPriceItemVO
hashCode() - Method in class bb.common.VendorContractPriceVendorPK
hashCode() - Method in class bb.common.VendorContractPriceVendorVO
hashCode() - Method in class bb.common.VendorContractPriceVO
hashCode() - Method in class bb.common.VendorCriticalLevelVO
hashCode() - Method in class bb.common.VendorGroupUserVO
hashCode() - Method in class bb.common.VendorPartPK
hashCode() - Method in class bb.common.VendorPartVO
hashCode() - Method in class bb.common.VendorQtyPricePK
hashCode() - Method in class bb.common.VendorQtyPriceVO
hashCode() - Method in class bb.common.WarehouseTransferPK
hashCode() - Method in class bb.common.WarehouseTransferVO
hashCode() - Method in class bb.common.WarehouseVO
hashCode() - Method in class bb.common.WeightUnitVO
hashCode() - Method in class bb.common.WorkCalendarVO
hashCode() - Method in class bb.common.WorkCenterAgent
hashCode() - Method in class bb.common.WorkCenterGroupItemPK
hashCode() - Method in class bb.common.WorkCenterGroupItemVO
hashCode() - Method in class bb.common.WorkCenterVendorPK
hashCode() - Method in class bb.common.WorkCenterVendorVO
hashCode() - Method in class bb.common.WorkCenterVO
hashCode() - Method in class bb.common.WorkInstructionApprovalVO
hashCode() - Method in class bb.common.WorkInstructionPictureVO
hashCode() - Method in class bb.common.WorkInstructionPK
hashCode() - Method in class bb.common.WorkInstructionRequestForChangeVO
hashCode() - Method in class bb.common.WorkInstructionSequencePK
hashCode() - Method in class bb.common.WorkInstructionSequenceVO
hashCode() - Method in class bb.common.WorkInstructionVO
hashCode() - Method in class bb.common.WorkOrderApprovalVO
hashCode() - Method in class bb.common.WorkOrderBoilerplateVO
hashCode() - Method in class bb.common.WorkOrderItemAgent
hashCode() - Method in class bb.common.WorkOrderItemIssuePK
hashCode() - Method in class bb.common.WorkOrderItemIssueVO
hashCode() - Method in class bb.common.WorkOrderItemPartDetailInWipVO
hashCode() - Method in class bb.common.WorkOrderItemPK
hashCode() - Method in class bb.common.WorkOrderItemSetupItemAgent
hashCode() - Method in class bb.common.WorkOrderItemVO
hashCode() - Method in class bb.common.WorkOrderReceiverVO
hashCode() - Method in class bb.common.WorkOrderVO
hashCode() - Method in class bb.common.WorkOrderWorkInstructionPK
hashCode() - Method in class bb.common.WorkOrderWorkInstructionSequenceDateAgent
hashCode() - Method in class bb.common.WorkOrderWorkInstructionSequencePK
hashCode() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO
hashCode() - Method in class bb.common.WorkOrderWorkInstructionVO
hashCode() - Method in class bb.common.WorkOrderWorkItemDateAgent
hashCode() - Method in class bb.common.WorkOrderWorkSheetItemPK
hashCode() - Method in class bb.common.WorkOrderWorkSheetItemVO
hashCode() - Method in class bb.common.WorkOrderWorkSheetPK
hashCode() - Method in class bb.common.WorkOrderWorkSheetVO
hashCode() - Method in class bb.common.WorkSheetPartAgent
hashCode() - Method in class bb.common.ZipCodeTaxVO
hashCode() - Method in class bb.common.ZipCodeVO
hasToolList(PartPK) - Method in interface bb.common.box.ManufacturingBox
HAVE_CALIBRATION_RECORDS - Static variable in class bb.common.BIZReason
HAVE_ITEMS_NOT_CLOSED - Static variable in class bb.common.BIZReason
HAVE_NO_CALIBRATION_RECORDS - Static variable in class bb.common.BIZReason
HAVE_NOT_ENOUGH_QTY_TO_REC_IN_IR - Static variable in class bb.common.BIZReason
HAVE_NOT_INVENTORY - Static variable in class bb.common.BIZReason
HelpServerVO - Class in bb.common
HelpServerVO() - Constructor for class bb.common.HelpServerVO
HIBERNATE_EXCEPTION - Static variable in class bb.common.DBReason
HighUsagePartResult - Class in bb.common
HighUsagePartResult() - Constructor for class bb.common.HighUsagePartResult
HISTORICAL_INVENTORY - Static variable in class bb.common.BizTarget
HistoricalInventoryTotalResult - Class in bb.common
HistoricalInventoryTotalResult() - Constructor for class bb.common.HistoricalInventoryTotalResult
HistoricalInventoryVO - Class in bb.common
HistoricalInventoryVO() - Constructor for class bb.common.HistoricalInventoryVO
Hold - Static variable in class bb.common.Constant.Status
HOUR - Static variable in class bb.common.Constant.PeriodUnit
HUMANRESOURCE - Static variable in class bb.common.Configure.Module
HumanResourceBox - Interface in bb.common.box
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M N O P Q R S T U V W X Y Z


HistoricalInventoryTotalResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class HistoricalInventoryTotalResult

java.lang.Object
    extended by  bb.common.HistoricalInventoryTotalResult
All Implemented Interfaces:
java.io.Serializable
public class HistoricalInventoryTotalResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
HistoricalInventoryTotalResult()
Method Summary
java.util.Date | getDate()
java.math.BigDecimal | getTotalByAvgCost()
java.math.BigDecimal | getTotalByStdCost()
void | setDate(java.util.Date date)
void | setTotalByAvgCost(java.math.BigDecimal totalByAvgCost)
void | setTotalByStdCost(java.math.BigDecimal totalByStdCost)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HistoricalInventoryTotalResult

public HistoricalInventoryTotalResult()
Method Detail

getDate

public java.util.Date getDate()

setDate

public void setDate(java.util.Date date)

getTotalByAvgCost

public java.math.BigDecimal getTotalByAvgCost()

setTotalByAvgCost

public void setTotalByAvgCost(java.math.BigDecimal totalByAvgCost)

getTotalByStdCost

public java.math.BigDecimal getTotalByStdCost()

setTotalByStdCost

public void setTotalByStdCost(java.math.BigDecimal totalByStdCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HistoricalInventoryVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class HistoricalInventoryVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.HistoricalInventoryVO
All Implemented Interfaces:
java.io.Serializable
public class HistoricalInventoryVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CONSIGNEDQTY
static java.lang.String | ORDER_BY_DATE
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_INQUALITYCHECKINGQTY
static java.lang.String | ORDER_BY_INTO
static java.lang.String | ORDER_BY_ONDEMANDQTY
static java.lang.String | ORDER_BY_ONHAND
static java.lang.String | ORDER_BY_ONLOANQTY
static java.lang.String | ORDER_BY_ONORDERQTY
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_SHIPINPROCESSQTY
static java.lang.String | ORDER_BY_WORKINPROCESSQTY
Constructor Summary
HistoricalInventoryVO()
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getAverageCost()
java.math.BigDecimal | getConsignedQty()
java.util.Date | getDate()
java.lang.String | getDescription()
java.lang.Long | getIi()
java.math.BigDecimal | getInQualityCheckingQty()
java.math.BigDecimal | getInTOQty()
java.util.Date | getLastInDate()
java.util.Date | getLastOutDate()
java.math.BigDecimal | getListPrice()
java.math.BigDecimal | getOnDemandQty()
java.math.BigDecimal | getOnhand()
java.math.BigDecimal | getOnloanQty()
java.math.BigDecimal | getOnOrderQty()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getShipInProcessQty()
java.math.BigDecimal | getShipInTransactionQty()
java.math.BigDecimal | getStandardCost()
java.math.BigDecimal | getWorkInProcessQty()
int | hashCode()
void | setAverageCost(java.math.BigDecimal averageCost)
void | setConsignedQty(java.math.BigDecimal consignedQty)
void | setDate(java.util.Date date)
void | setDescription(java.lang.String description)
void | setIi(java.lang.Long ii)
void | setInQualityCheckingQty(java.math.BigDecimal inQualityCheckingQty)
void | setInTOQty(java.math.BigDecimal inTOQty)
void | setLastInDate(java.util.Date lastInDate)
void | setLastOutDate(java.util.Date lastOutDate)
void | setListPrice(java.math.BigDecimal listPrice)
void | setOnDemandQty(java.math.BigDecimal onDemandQty)
void | setOnhand(java.math.BigDecimal onhand)
void | setOnloanQty(java.math.BigDecimal onloanQty)
void | setOnOrderQty(java.math.BigDecimal onOrderQty)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setShipInProcessQty(java.math.BigDecimal shipInProcessQty)
void | setShipInTransactionQty(java.math.BigDecimal shipInTransactionQty)
void | setStandardCost(java.math.BigDecimal standardCost)
void | setWorkInProcessQty(java.math.BigDecimal workInProcessQty)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_DATE

public static final java.lang.String ORDER_BY_DATE
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_ONHAND

public static final java.lang.String ORDER_BY_ONHAND
See Also:
Constant Field Values

ORDER_BY_WORKINPROCESSQTY

public static final java.lang.String ORDER_BY_WORKINPROCESSQTY
See Also:
Constant Field Values

ORDER_BY_SHIPINPROCESSQTY

public static final java.lang.String ORDER_BY_SHIPINPROCESSQTY
See Also:
Constant Field Values

ORDER_BY_INTO

public static final java.lang.String ORDER_BY_INTO
See Also:
Constant Field Values

ORDER_BY_ONLOANQTY

public static final java.lang.String ORDER_BY_ONLOANQTY
See Also:
Constant Field Values

ORDER_BY_CONSIGNEDQTY

public static final java.lang.String ORDER_BY_CONSIGNEDQTY
See Also:
Constant Field Values

ORDER_BY_INQUALITYCHECKINGQTY

public static final java.lang.String ORDER_BY_INQUALITYCHECKINGQTY
See Also:
Constant Field Values

ORDER_BY_ONDEMANDQTY

public static final java.lang.String ORDER_BY_ONDEMANDQTY
See Also:
Constant Field Values

ORDER_BY_ONORDERQTY

public static final java.lang.String ORDER_BY_ONORDERQTY
See Also:
Constant Field Values
Constructor Detail

HistoricalInventoryVO

public HistoricalInventoryVO()
Method Detail

getAverageCost

public java.math.BigDecimal getAverageCost()

setAverageCost

public void setAverageCost(java.math.BigDecimal averageCost)

getConsignedQty

public java.math.BigDecimal getConsignedQty()

setConsignedQty

public void setConsignedQty(java.math.BigDecimal consignedQty)

getDate

public java.util.Date getDate()

setDate

public void setDate(java.util.Date date)

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getInQualityCheckingQty

public java.math.BigDecimal getInQualityCheckingQty()

setInQualityCheckingQty

public void setInQualityCheckingQty(java.math.BigDecimal inQualityCheckingQty)

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

getOnDemandQty

public java.math.BigDecimal getOnDemandQty()

setOnDemandQty

public void setOnDemandQty(java.math.BigDecimal onDemandQty)

getOnhand

public java.math.BigDecimal getOnhand()

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

getOnloanQty

public java.math.BigDecimal getOnloanQty()

setOnloanQty

public void setOnloanQty(java.math.BigDecimal onloanQty)

getOnOrderQty

public java.math.BigDecimal getOnOrderQty()

setOnOrderQty

public void setOnOrderQty(java.math.BigDecimal onOrderQty)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getShipInProcessQty

public java.math.BigDecimal getShipInProcessQty()

setShipInProcessQty

public void setShipInProcessQty(java.math.BigDecimal shipInProcessQty)

getShipInTransactionQty

public java.math.BigDecimal getShipInTransactionQty()

setShipInTransactionQty

public void setShipInTransactionQty(java.math.BigDecimal shipInTransactionQty)

getInTOQty

public java.math.BigDecimal getInTOQty()

setInTOQty

public void setInTOQty(java.math.BigDecimal inTOQty)

getStandardCost

public java.math.BigDecimal getStandardCost()

setStandardCost

public void setStandardCost(java.math.BigDecimal standardCost)

getWorkInProcessQty

public java.math.BigDecimal getWorkInProcessQty()

setWorkInProcessQty

public void setWorkInProcessQty(java.math.BigDecimal workInProcessQty)

getLastInDate

public java.util.Date getLastInDate()

setLastInDate

public void setLastInDate(java.util.Date lastInDate)

getLastOutDate

public java.util.Date getLastOutDate()

setLastOutDate

public void setLastOutDate(java.util.Date lastOutDate)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HumanResourceBox

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common.box
Interface HumanResourceBox

public interface HumanResourceBox

Method Summary
CustomAssetVO | addCustomAsset(CustomAssetVO vo)
CustomAssetRecordVO | addCustomAssetRecord(CustomAssetRecordVO vo)
CustomCheckUpEmployeeVO | addCustomCheckUpEmployee(CustomCheckUpEmployeeVO vo)
CustomDepartmentVO | addCustomDepartment(CustomDepartmentVO vo)
CustomEmployeeVO | addCustomEmployee(CustomEmployeeVO vo)
CustomEmployeeTrainVO | addCustomEmployeeTrain(CustomEmployeeTrainVO vo)
CustomEmployeeWorkExperienceVO | addCustomEmployeeWorkExperience(CustomEmployeeWorkExperienceVO vo)
CustomGoodsBreedVO | addCustomGoodsBreed(CustomGoodsBreedVO vo)
CustomGoodsRecordVO | addCustomGoodsRecord(CustomGoodsRecordVO vo)
CustomJobCategoryVO | addCustomJobCategory(CustomJobCategoryVO vo)
java.lang.String | addEmployeeCard(EmployeeCardVO vo, boolean autoEmployeeId)
java.lang.String | addEmployeeCardToTemp(java.lang.String originalEmployeeId, java.lang.String employeeId)
java.util.Collection<EmployeeEducationVO> | addEmployeeEducation(EmployeeEducationVO vo)
EmployeeHomeVO | addEmployeeHome(EmployeeHomeVO vo)
java.util.List<EmployeeTrainingVO> | addEmployeeTraining(EmployeeTrainingVO vo)
java.util.Collection<EmployeeWorkExperienceVO> | addEmployeeWorkExperience(EmployeeWorkExperienceVO vo)
java.lang.String | addTemporaryEmployee(EmployeeCardVO vo)
java.lang.String | addTempToEmployeeCard(EmployeeCardVO vo, java.lang.String employeeId)
void | deleteAllEmployeeCardWhenInit()
void | deleteCustomAsset(java.lang.String assetNumber)
void | deleteCustomAssetRecord(CustomAssetRecordPK pk)
void | deleteCustomCheckUpEmployee(java.lang.Long ii)
void | deleteCustomDepartment(java.lang.String id)
void | deleteCustomEmployee(java.lang.String id)
void | deleteCustomEmployeeTrain(CustomEmployeeTrainPK pk)
void | deleteCustomEmployeeWorkExperience(CustomEmployeeTrainPK pk)
void | deleteCustomGoodsBreed(java.lang.String id)
void | deleteCustomGoodsRecord(java.lang.Long ii)
void | deleteCustomJobCategory(java.lang.String id)
void | deleteEmployeeCard(java.lang.String employeeId)
void | deleteEmployeeEducation(EmployeeEducationPK pk)
java.util.Collection<EmployeeRecordsVO> | deleteEmployeeRecord(MiscDocAgent agent)
void | deleteEmployeeTraining(EmployeeWorkExperiencePK pk)
void | deleteEmployeeWorkExperience(EmployeeWorkExperiencePK pk)
byte[] | downloadEmployeeRecord(MiscDocAgent agent)
java.util.Collection<CustomDepartmentVO> | findAllCustomDepartment(int firstIndex, int maxLength)
java.util.Collection<EmployeeCardVO> | findAllEmployeeCards(int firstIndex, int maxLength)
java.util.Collection<EmployeeCardVO> | findCompanyAddressBook(int firstIndex, int maxLength)
java.util.Collection<CustomAssetVO> | findCustomAssetByName(java.lang.String assetName, java.lang.String assetNumber, java.lang.String department, java.lang.String receiveSign, int firstIndex, int maxLength)
java.util.Collection<CustomCheckUpEmployeeVO> | findCustomCheckUpByName(java.lang.String id, java.lang.String userName, java.util.Date fromDate, java.util.Date toDate, int ageLevel, int firstIndex, int maxLength)
java.util.Collection<CustomEmployeeVO> | findCustomEmployeeByCondition(java.lang.String id, java.lang.String gender, int ageLevel, java.lang.String polityVisage, java.lang.String education, java.lang.String specialTitle, java.lang.String specialWork, java.lang.String workType, java.lang.String workTypeAfter, int workAgeLevel, java.lang.String fromPostion, java.lang.String toPosition, int firstIndex, int maxLength)
java.util.Collection<CustomEmployeeTrainVO> | findCustomEmployeeTrain(java.lang.String title, java.lang.String certificateName, java.lang.String certificationId, int firstIndex, int maxLength)
java.util.Collection<CustomGoodsBreedVO> | findCustomGoodsBreedById(java.lang.String id, java.lang.String name, int firstIndex, int maxLength)
java.util.Collection<CustomGoodsRecordVO> | findCustomGoodsRecordByDate(java.lang.String employeeId, java.lang.String goodsId, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<CustomJobCategoryVO> | findCustomJobCategoryById(java.lang.String id, java.lang.String name, int firstIndex, int maxLength)
java.util.Collection<EmployeeCardVO> | findEmployeeCards(java.lang.String employeeIdExp, java.lang.String lastName, java.lang.String departmentExp, java.lang.String[] status, boolean listInAddressBook, boolean tempworker, int firstIndex, int maxLength)
java.util.Collection<EmployeeCardVO> | findEmployeeCardsByDepartment(java.lang.String department, boolean tempworker, int firstIndex, int maxLength)
java.util.Collection<EmployeeCardVO> | findEmployeeCardsByEmployeeId(java.lang.String employeeIdLike, boolean tempworker, int firstIndex, int maxLength)
java.util.Collection<EmployeeCardVO> | findEmployeeCardsByLastName(java.lang.String lastName, boolean tempworker, int firstIndex, int maxLength)
java.util.Collection<EmployeeCardVO> | findEmployeeCardsByName(java.lang.String name, boolean tempworker, int firstIndex, int maxLength)
java.util.Collection<EmployeePutGoodListResult> | findEmployeeDoNotPutGoodsByDate(java.lang.String employee, java.lang.String goodsId, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<EmployeeEducationResult> | findEmployeeEducation(boolean isTempWork, java.lang.String degree, int firstIndex, int maxLength)
java.util.Collection<java.lang.String> | findEmployeeEducationsAllDegree(boolean isTempWork, int firstIndex, int maxLength)
java.util.Collection<EmployeeRecordsVO> | findEmployeeRecords(java.lang.String employeeId, java.lang.String recordType, boolean isTempWork, int firstIndex, int maxLength)
java.util.Collection<java.lang.String> | findEmployeeRecordsType(boolean isTempWork, int firstIndex, int maxLength)
java.util.Collection | getAllCustomAssetRecordByAssetNumber(java.lang.String assetNumber)
int | getAllCustomDepartmentCount()
int | getAllEmployeeCardCount()
java.util.Collection<java.lang.String> | getAllEmployeeDepartment()
java.util.Collection<BB2DoubleString> | getAllEmployeeIDs()
java.util.Collection<java.lang.String> | getAllEmployeeStatus()
int | getCompanyAddressBookCount()
CustomAssetVO | getCustomAssetByPk(java.lang.String assetNumber)
int | getCustomAssetCountByName(java.lang.String assetName, java.lang.String assetNumber, java.lang.String department, java.lang.String receiveSign)
CustomAssetRecordVO | getCustomAssetRecordByPk(CustomAssetRecordPK pk)
int | getCustomCheckUpCountByName(java.lang.String id, java.lang.String userName, java.util.Date fromDate, java.util.Date toDate, int ageLevel)
CustomCheckUpEmployeeVO | getCustomCheckUpEmployee(java.lang.Long ii)
CustomDepartmentVO | getCustomDepartmentByPk(java.lang.String id)
int | getCustomEmployeeByCondition(java.lang.String id, java.lang.String gender, int ageLevel, java.lang.String polityVisage, java.lang.String education, java.lang.String specialTitle, java.lang.String specialWork, java.lang.String workType, java.lang.String workTypeAfter, int workAgeLevel, java.lang.String fromPostion, java.lang.String toPosition)
CustomEmployeeVO | getCustomEmployeeByPk(java.lang.String id)
int | getCustomEmployeeTrainCount(java.lang.String title, java.lang.String certificateName, java.lang.String certificationId)
int | getCustomGoodsBreedByIdCount(java.lang.String id, java.lang.String name)
CustomGoodsBreedVO | getCustomGoodsBreedByPk(java.lang.String id)
int | getCustomGoodsRecordByDateCount(java.lang.String employeeId, java.lang.String goodsId, java.util.Date fromDate, java.util.Date toDate)
CustomGoodsRecordVO | getCustomGoodsRecordByPk(java.lang.Long ii)
int | getCustomJobCategoryByIdCount(java.lang.String id, java.lang.String name)
CustomJobCategoryVO | getCustomJobCategoryByPk(java.lang.String id)
java.util.Collection<java.lang.String> | getDepartmentList()
java.util.Collection<EmployeeEducationVO> | getEEByEmployeeId(java.lang.String employeeId)
EmployeeCardVO | getEmployeeBasicInfoAndPic(java.lang.String employeeID)
EmployeeCardVO | getEmployeeCardById(java.lang.String id)
EmployeeCardVO | getEmployeeCardById(java.lang.String employeeId, boolean tempworker)
int | getEmployeeCardsByDepartmentCount(java.lang.String department, boolean tempworker)
int | getEmployeeCardsByLastNameCount(java.lang.String lastName, boolean tempworker)
int | getEmployeeCardsByNameCount(java.lang.String name, boolean tempworker)
int | getEmployeeCardsCountByEmployeeId(java.lang.String employeeIdLike, boolean tempworker)
int | getEmployeeCount(java.lang.String employeeIdExp, java.lang.String lastName, java.lang.String departmentExp, java.lang.String[] status, boolean listInAddressBook, boolean tempworker)
int | getEmployeeDoNotPutGoodsCountByDate(java.lang.String employee, java.lang.String goodsId, java.util.Date fromDate, java.util.Date toDate)
EmployeeEducationVO | getEmployeeEducationByPK(EmployeeEducationPK pk)
int | getEmployeeEducationCount(boolean isTempWork, java.lang.String degree)
int | getEmployeeEducationsAllDegreeCount(boolean isTempWork)
EmployeeHomeVO | getEmployeeHomeByPk(java.lang.String employeeId)
int | getEmployeeRecordsCount(java.lang.String employeeId, java.lang.String recordType, boolean isTempWork)
java.util.Collection<EmployeeRecordsVO> | getEmployeeRecordsOfEmployee(java.lang.String employeeId)
int | getEmployeeRecordsTypeCount(boolean isTempWork)
EmployeeCardVO | getEmployeeSelf()
java.util.List<EmployeeTrainingVO> | getEmployeeTrainingById(java.lang.String employeeId)
EmployeeTrainingVO | getEmployeeTrainingbyPk(EmployeeWorkExperiencePK pk)
EmployeeWorkExperienceVO | getEmployeeWorkExperience(EmployeeWorkExperiencePK pk)
java.util.Collection<EmployeeWorkExperienceVO> | getEWEByEmployeeId(java.lang.String employeeId)
java.lang.String | getNextEmployeeId(boolean isTempWorker)
boolean | isCustomAssetExist(java.lang.String assetNumber)
boolean | isCustomDepartmentExist(java.lang.String id)
boolean | isCustomEmployeeExist(java.lang.String id)
boolean | isCustomGoodsBreedExist(java.lang.String id)
boolean | isCustomGoodsRecordExist(java.lang.Long ii)
boolean | isCustomJobCategoryExist(java.lang.String id)
boolean | isEmployeeExistent(java.lang.String employeeId)
void | updateCustomAsset(CustomAssetVO vo)
void | updateCustomAssetRecord(CustomAssetRecordVO vo)
void | updateCustomCheckUpEmployee(CustomCheckUpEmployeeVO vo)
void | updateCustomDepartment(CustomDepartmentVO vo)
void | updateCustomEmployee(CustomEmployeeVO vo)
void | updateCustomEmployeeTrain(CustomEmployeeTrainVO vo)
void | updateCustomEmployeeWorkExperience(CustomEmployeeWorkExperienceVO vo)
void | updateCustomGoodsBreed(CustomGoodsBreedVO vo)
void | updateCustomGoodsRecord(CustomGoodsRecordVO vo)
void | updateCustomJobCategory(CustomJobCategoryVO vo)
java.lang.String | updateEmployeeCard(EmployeeCardVO vo)
void | updateEmployeeEducation(EmployeeEducationVO vo)
void | updateEmployeeHome(EmployeeHomeVO vo)
void | updateEmployeeTraining(EmployeeTrainingVO vo)
void | updateEmployeeWorkExperience(EmployeeWorkExperienceVO vo)
java.lang.String | updateTemporaryEmployee(EmployeeCardVO vo)
java.util.Collection<EmployeeRecordsVO> | uploadOrUpdateEmployeeRecord(MiscDocAgent agent)

Method Detail

addEmployeeCard

java.lang.String addEmployeeCard(EmployeeCardVO vo,
                                 boolean autoEmployeeId)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

updateEmployeeCard

java.lang.String updateEmployeeCard(EmployeeCardVO vo)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

deleteEmployeeCard

void deleteEmployeeCard(java.lang.String employeeId)
                        throws java.lang.Exception
Throws:
java.lang.Exception

deleteAllEmployeeCardWhenInit

void deleteAllEmployeeCardWhenInit()
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findAllEmployeeCards

java.util.Collection<EmployeeCardVO> findAllEmployeeCards(int firstIndex,
                                                          int maxLength)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getAllEmployeeCardCount

int getAllEmployeeCardCount()
                            throws java.lang.Exception
Throws:
java.lang.Exception

getAllEmployeeDepartment

java.util.Collection<java.lang.String> getAllEmployeeDepartment()
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllEmployeeStatus

java.util.Collection<java.lang.String> getAllEmployeeStatus()
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getEmployeeCardById

EmployeeCardVO getEmployeeCardById(java.lang.String id)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

isEmployeeExistent

boolean isEmployeeExistent(java.lang.String employeeId)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findEmployeeCardsByEmployeeId

java.util.Collection<EmployeeCardVO> findEmployeeCardsByEmployeeId(java.lang.String employeeIdLike,
                                                                   boolean tempworker,
                                                                   int firstIndex,
                                                                   int maxLength)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getEmployeeCardsCountByEmployeeId

int getEmployeeCardsCountByEmployeeId(java.lang.String employeeIdLike,
                                      boolean tempworker)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findEmployeeCards

java.util.Collection<EmployeeCardVO> findEmployeeCards(java.lang.String employeeIdExp,
                                                       java.lang.String lastName,
                                                       java.lang.String departmentExp,
                                                       java.lang.String[] status,
                                                       boolean listInAddressBook,
                                                       boolean tempworker,
                                                       int firstIndex,
                                                       int maxLength)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getEmployeeCount

int getEmployeeCount(java.lang.String employeeIdExp,
                     java.lang.String lastName,
                     java.lang.String departmentExp,
                     java.lang.String[] status,
                     boolean listInAddressBook,
                     boolean tempworker)
                     throws java.lang.Exception
Throws:
java.lang.Exception

addTemporaryEmployee

java.lang.String addTemporaryEmployee(EmployeeCardVO vo)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

getEmployeeSelf

EmployeeCardVO getEmployeeSelf()
                               throws java.lang.Exception
Throws:
java.lang.Exception

getEmployeeCardById

EmployeeCardVO getEmployeeCardById(java.lang.String employeeId,
                                   boolean tempworker)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

updateTemporaryEmployee

java.lang.String updateTemporaryEmployee(EmployeeCardVO vo)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

addTempToEmployeeCard

java.lang.String addTempToEmployeeCard(EmployeeCardVO vo,
                                       java.lang.String employeeId)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

addEmployeeCardToTemp

java.lang.String addEmployeeCardToTemp(java.lang.String originalEmployeeId,
                                       java.lang.String employeeId)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

getNextEmployeeId

java.lang.String getNextEmployeeId(boolean isTempWorker)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findEmployeeCardsByLastName

java.util.Collection<EmployeeCardVO> findEmployeeCardsByLastName(java.lang.String lastName,
                                                                 boolean tempworker,
                                                                 int firstIndex,
                                                                 int maxLength)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findEmployeeCardsByName

java.util.Collection<EmployeeCardVO> findEmployeeCardsByName(java.lang.String name,
                                                             boolean tempworker,
                                                             int firstIndex,
                                                             int maxLength)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

findEmployeeCardsByDepartment

java.util.Collection<EmployeeCardVO> findEmployeeCardsByDepartment(java.lang.String department,
                                                                   boolean tempworker,
                                                                   int firstIndex,
                                                                   int maxLength)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getEmployeeCardsByLastNameCount

int getEmployeeCardsByLastNameCount(java.lang.String lastName,
                                    boolean tempworker)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

getEmployeeCardsByNameCount

int getEmployeeCardsByNameCount(java.lang.String name,
                                boolean tempworker)
                                throws java.lang.Exception
Throws:
java.lang.Exception

getEmployeeCardsByDepartmentCount

int getEmployeeCardsByDepartmentCount(java.lang.String department,
                                      boolean tempworker)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

addEmployeeHome

EmployeeHomeVO addEmployeeHome(EmployeeHomeVO vo)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getEmployeeHomeByPk

EmployeeHomeVO getEmployeeHomeByPk(java.lang.String employeeId)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

updateEmployeeHome

void updateEmployeeHome(EmployeeHomeVO vo)
                        throws java.lang.Exception
Throws:
java.lang.Exception

addEmployeeEducation

java.util.Collection<EmployeeEducationVO> addEmployeeEducation(EmployeeEducationVO vo)
                                                               throws java.lang.Exception
Throws:
java.lang.Exception

updateEmployeeEducation

void updateEmployeeEducation(EmployeeEducationVO vo)
                             throws java.lang.Exception
Throws:
java.lang.Exception

deleteEmployeeEducation

void deleteEmployeeEducation(EmployeeEducationPK pk)
                             throws java.lang.Exception
Throws:
java.lang.Exception

getEmployeeEducationByPK

EmployeeEducationVO getEmployeeEducationByPK(EmployeeEducationPK pk)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

getEEByEmployeeId

java.util.Collection<EmployeeEducationVO> getEEByEmployeeId(java.lang.String employeeId)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

addEmployeeWorkExperience

java.util.Collection<EmployeeWorkExperienceVO> addEmployeeWorkExperience(EmployeeWorkExperienceVO vo)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

updateEmployeeWorkExperience

void updateEmployeeWorkExperience(EmployeeWorkExperienceVO vo)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

deleteEmployeeWorkExperience

void deleteEmployeeWorkExperience(EmployeeWorkExperiencePK pk)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

getEmployeeWorkExperience

EmployeeWorkExperienceVO getEmployeeWorkExperience(EmployeeWorkExperiencePK pk)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getEWEByEmployeeId

java.util.Collection<EmployeeWorkExperienceVO> getEWEByEmployeeId(java.lang.String employeeId)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

addEmployeeTraining

java.util.List<EmployeeTrainingVO> addEmployeeTraining(EmployeeTrainingVO vo)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

deleteEmployeeTraining

void deleteEmployeeTraining(EmployeeWorkExperiencePK pk)
                            throws java.lang.Exception
Throws:
java.lang.Exception

updateEmployeeTraining

void updateEmployeeTraining(EmployeeTrainingVO vo)
                            throws java.lang.Exception
Throws:
java.lang.Exception

getEmployeeTrainingbyPk

EmployeeTrainingVO getEmployeeTrainingbyPk(EmployeeWorkExperiencePK pk)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

getEmployeeTrainingById

java.util.List<EmployeeTrainingVO> getEmployeeTrainingById(java.lang.String employeeId)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

uploadOrUpdateEmployeeRecord

java.util.Collection<EmployeeRecordsVO> uploadOrUpdateEmployeeRecord(MiscDocAgent agent)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

downloadEmployeeRecord

byte[] downloadEmployeeRecord(MiscDocAgent agent)
                              throws java.lang.Exception
Throws:
java.lang.Exception

deleteEmployeeRecord

java.util.Collection<EmployeeRecordsVO> deleteEmployeeRecord(MiscDocAgent agent)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getEmployeeRecordsOfEmployee

java.util.Collection<EmployeeRecordsVO> getEmployeeRecordsOfEmployee(java.lang.String employeeId)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

findEmployeeRecords

java.util.Collection<EmployeeRecordsVO> findEmployeeRecords(java.lang.String employeeId,
                                                            java.lang.String recordType,
                                                            boolean isTempWork,
                                                            int firstIndex,
                                                            int maxLength)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getEmployeeRecordsCount

int getEmployeeRecordsCount(java.lang.String employeeId,
                            java.lang.String recordType,
                            boolean isTempWork)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findEmployeeEducation

java.util.Collection<EmployeeEducationResult> findEmployeeEducation(boolean isTempWork,
                                                                    java.lang.String degree,
                                                                    int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getEmployeeEducationCount

int getEmployeeEducationCount(boolean isTempWork,
                              java.lang.String degree)
                              throws java.lang.Exception
Throws:
java.lang.Exception

findEmployeeEducationsAllDegree

java.util.Collection<java.lang.String> findEmployeeEducationsAllDegree(boolean isTempWork,
                                                                       int firstIndex,
                                                                       int maxLength)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getEmployeeEducationsAllDegreeCount

int getEmployeeEducationsAllDegreeCount(boolean isTempWork)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findEmployeeRecordsType

java.util.Collection<java.lang.String> findEmployeeRecordsType(boolean isTempWork,
                                                               int firstIndex,
                                                               int maxLength)
                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getEmployeeRecordsTypeCount

int getEmployeeRecordsTypeCount(boolean isTempWork)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findCompanyAddressBook

java.util.Collection<EmployeeCardVO> findCompanyAddressBook(int firstIndex,
                                                            int maxLength)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getCompanyAddressBookCount

int getCompanyAddressBookCount()
                               throws java.lang.Exception
Throws:
java.lang.Exception

getEmployeeBasicInfoAndPic

EmployeeCardVO getEmployeeBasicInfoAndPic(java.lang.String employeeID)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

getAllEmployeeIDs

java.util.Collection<BB2DoubleString> getAllEmployeeIDs()
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getDepartmentList

java.util.Collection<java.lang.String> getDepartmentList()
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

addCustomAsset

CustomAssetVO addCustomAsset(CustomAssetVO vo)
                             throws java.lang.Exception
Throws:
java.lang.Exception

updateCustomAsset

void updateCustomAsset(CustomAssetVO vo)
                       throws java.lang.Exception
Throws:
java.lang.Exception

deleteCustomAsset

void deleteCustomAsset(java.lang.String assetNumber)
                       throws java.lang.Exception
Throws:
java.lang.Exception

getCustomAssetByPk

CustomAssetVO getCustomAssetByPk(java.lang.String assetNumber)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

isCustomAssetExist

boolean isCustomAssetExist(java.lang.String assetNumber)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findCustomAssetByName

java.util.Collection<CustomAssetVO> findCustomAssetByName(java.lang.String assetName,
                                                          java.lang.String assetNumber,
                                                          java.lang.String department,
                                                          java.lang.String receiveSign,
                                                          int firstIndex,
                                                          int maxLength)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getCustomAssetCountByName

int getCustomAssetCountByName(java.lang.String assetName,
                              java.lang.String assetNumber,
                              java.lang.String department,
                              java.lang.String receiveSign)
                              throws java.lang.Exception
Throws:
java.lang.Exception

addCustomAssetRecord

CustomAssetRecordVO addCustomAssetRecord(CustomAssetRecordVO vo)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

updateCustomAssetRecord

void updateCustomAssetRecord(CustomAssetRecordVO vo)
                             throws java.lang.Exception
Throws:
java.lang.Exception

deleteCustomAssetRecord

void deleteCustomAssetRecord(CustomAssetRecordPK pk)
                             throws java.lang.Exception
Throws:
java.lang.Exception

getCustomAssetRecordByPk

CustomAssetRecordVO getCustomAssetRecordByPk(CustomAssetRecordPK pk)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

getAllCustomAssetRecordByAssetNumber

java.util.Collection getAllCustomAssetRecordByAssetNumber(java.lang.String assetNumber)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

addCustomEmployee

CustomEmployeeVO addCustomEmployee(CustomEmployeeVO vo)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

updateCustomEmployee

void updateCustomEmployee(CustomEmployeeVO vo)
                          throws java.lang.Exception
Throws:
java.lang.Exception

deleteCustomEmployee

void deleteCustomEmployee(java.lang.String id)
                          throws java.lang.Exception
Throws:
java.lang.Exception

getCustomEmployeeByPk

CustomEmployeeVO getCustomEmployeeByPk(java.lang.String id)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

isCustomEmployeeExist

boolean isCustomEmployeeExist(java.lang.String id)
                              throws java.lang.Exception
Throws:
java.lang.Exception

findCustomEmployeeByCondition

java.util.Collection<CustomEmployeeVO> findCustomEmployeeByCondition(java.lang.String id,
                                                                     java.lang.String gender,
                                                                     int ageLevel,
                                                                     java.lang.String polityVisage,
                                                                     java.lang.String education,
                                                                     java.lang.String specialTitle,
                                                                     java.lang.String specialWork,
                                                                     java.lang.String workType,
                                                                     java.lang.String workTypeAfter,
                                                                     int workAgeLevel,
                                                                     java.lang.String fromPostion,
                                                                     java.lang.String toPosition,
                                                                     int firstIndex,
                                                                     int maxLength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getCustomEmployeeByCondition

int getCustomEmployeeByCondition(java.lang.String id,
                                 java.lang.String gender,
                                 int ageLevel,
                                 java.lang.String polityVisage,
                                 java.lang.String education,
                                 java.lang.String specialTitle,
                                 java.lang.String specialWork,
                                 java.lang.String workType,
                                 java.lang.String workTypeAfter,
                                 int workAgeLevel,
                                 java.lang.String fromPostion,
                                 java.lang.String toPosition)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

addCustomEmployeeTrain

CustomEmployeeTrainVO addCustomEmployeeTrain(CustomEmployeeTrainVO vo)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

updateCustomEmployeeTrain

void updateCustomEmployeeTrain(CustomEmployeeTrainVO vo)
                               throws java.lang.Exception
Throws:
java.lang.Exception

deleteCustomEmployeeTrain

void deleteCustomEmployeeTrain(CustomEmployeeTrainPK pk)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findCustomEmployeeTrain

java.util.Collection<CustomEmployeeTrainVO> findCustomEmployeeTrain(java.lang.String title,
                                                                    java.lang.String certificateName,
                                                                    java.lang.String certificationId,
                                                                    int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getCustomEmployeeTrainCount

int getCustomEmployeeTrainCount(java.lang.String title,
                                java.lang.String certificateName,
                                java.lang.String certificationId)
                                throws java.lang.Exception
Throws:
java.lang.Exception

addCustomEmployeeWorkExperience

CustomEmployeeWorkExperienceVO addCustomEmployeeWorkExperience(CustomEmployeeWorkExperienceVO vo)
                                                               throws java.lang.Exception
Throws:
java.lang.Exception

updateCustomEmployeeWorkExperience

void updateCustomEmployeeWorkExperience(CustomEmployeeWorkExperienceVO vo)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

deleteCustomEmployeeWorkExperience

void deleteCustomEmployeeWorkExperience(CustomEmployeeTrainPK pk)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

addCustomCheckUpEmployee

CustomCheckUpEmployeeVO addCustomCheckUpEmployee(CustomCheckUpEmployeeVO vo)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

updateCustomCheckUpEmployee

void updateCustomCheckUpEmployee(CustomCheckUpEmployeeVO vo)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

deleteCustomCheckUpEmployee

void deleteCustomCheckUpEmployee(java.lang.Long ii)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

getCustomCheckUpEmployee

CustomCheckUpEmployeeVO getCustomCheckUpEmployee(java.lang.Long ii)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findCustomCheckUpByName

java.util.Collection<CustomCheckUpEmployeeVO> findCustomCheckUpByName(java.lang.String id,
                                                                      java.lang.String userName,
                                                                      java.util.Date fromDate,
                                                                      java.util.Date toDate,
                                                                      int ageLevel,
                                                                      int firstIndex,
                                                                      int maxLength)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getCustomCheckUpCountByName

int getCustomCheckUpCountByName(java.lang.String id,
                                java.lang.String userName,
                                java.util.Date fromDate,
                                java.util.Date toDate,
                                int ageLevel)
                                throws java.lang.Exception
Throws:
java.lang.Exception

addCustomDepartment

CustomDepartmentVO addCustomDepartment(CustomDepartmentVO vo)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

updateCustomDepartment

void updateCustomDepartment(CustomDepartmentVO vo)
                            throws java.lang.Exception
Throws:
java.lang.Exception

deleteCustomDepartment

void deleteCustomDepartment(java.lang.String id)
                            throws java.lang.Exception
Throws:
java.lang.Exception

getCustomDepartmentByPk

CustomDepartmentVO getCustomDepartmentByPk(java.lang.String id)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

isCustomDepartmentExist

boolean isCustomDepartmentExist(java.lang.String id)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findAllCustomDepartment

java.util.Collection<CustomDepartmentVO> findAllCustomDepartment(int firstIndex,
                                                                 int maxLength)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getAllCustomDepartmentCount

int getAllCustomDepartmentCount()
                                throws java.lang.Exception
Throws:
java.lang.Exception

addCustomJobCategory

CustomJobCategoryVO addCustomJobCategory(CustomJobCategoryVO vo)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

updateCustomJobCategory

void updateCustomJobCategory(CustomJobCategoryVO vo)
                             throws java.lang.Exception
Throws:
java.lang.Exception

deleteCustomJobCategory

void deleteCustomJobCategory(java.lang.String id)
                             throws java.lang.Exception
Throws:
java.lang.Exception

getCustomJobCategoryByPk

CustomJobCategoryVO getCustomJobCategoryByPk(java.lang.String id)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

isCustomJobCategoryExist

boolean isCustomJobCategoryExist(java.lang.String id)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findCustomJobCategoryById

java.util.Collection<CustomJobCategoryVO> findCustomJobCategoryById(java.lang.String id,
                                                                    java.lang.String name,
                                                                    int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getCustomJobCategoryByIdCount

int getCustomJobCategoryByIdCount(java.lang.String id,
                                  java.lang.String name)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

addCustomGoodsBreed

CustomGoodsBreedVO addCustomGoodsBreed(CustomGoodsBreedVO vo)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

updateCustomGoodsBreed

void updateCustomGoodsBreed(CustomGoodsBreedVO vo)
                            throws java.lang.Exception
Throws:
java.lang.Exception

deleteCustomGoodsBreed

void deleteCustomGoodsBreed(java.lang.String id)
                            throws java.lang.Exception
Throws:
java.lang.Exception

getCustomGoodsBreedByPk

CustomGoodsBreedVO getCustomGoodsBreedByPk(java.lang.String id)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

isCustomGoodsBreedExist

boolean isCustomGoodsBreedExist(java.lang.String id)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findCustomGoodsBreedById

java.util.Collection<CustomGoodsBreedVO> findCustomGoodsBreedById(java.lang.String id,
                                                                  java.lang.String name,
                                                                  int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getCustomGoodsBreedByIdCount

int getCustomGoodsBreedByIdCount(java.lang.String id,
                                 java.lang.String name)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

addCustomGoodsRecord

CustomGoodsRecordVO addCustomGoodsRecord(CustomGoodsRecordVO vo)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

updateCustomGoodsRecord

void updateCustomGoodsRecord(CustomGoodsRecordVO vo)
                             throws java.lang.Exception
Throws:
java.lang.Exception

deleteCustomGoodsRecord

void deleteCustomGoodsRecord(java.lang.Long ii)
                             throws java.lang.Exception
Throws:
java.lang.Exception

getCustomGoodsRecordByPk

CustomGoodsRecordVO getCustomGoodsRecordByPk(java.lang.Long ii)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

isCustomGoodsRecordExist

boolean isCustomGoodsRecordExist(java.lang.Long ii)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findCustomGoodsRecordByDate

java.util.Collection<CustomGoodsRecordVO> findCustomGoodsRecordByDate(java.lang.String employeeId,
                                                                      java.lang.String goodsId,
                                                                      java.util.Date fromDate,
                                                                      java.util.Date toDate,
                                                                      int firstIndex,
                                                                      int maxLength)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getCustomGoodsRecordByDateCount

int getCustomGoodsRecordByDateCount(java.lang.String employeeId,
                                    java.lang.String goodsId,
                                    java.util.Date fromDate,
                                    java.util.Date toDate)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findEmployeeDoNotPutGoodsByDate

java.util.Collection<EmployeePutGoodListResult> findEmployeeDoNotPutGoodsByDate(java.lang.String employee,
                                                                                java.lang.String goodsId,
                                                                                java.util.Date fromDate,
                                                                                java.util.Date toDate,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getEmployeeDoNotPutGoodsCountByDate

int getEmployeeDoNotPutGoodsCountByDate(java.lang.String employee,
                                        java.lang.String goodsId,
                                        java.util.Date fromDate,
                                        java.util.Date toDate)
                                        throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


I18nEvent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class I18nEvent

java.lang.Object
    extended by  bb.common.BB2Event
        extended by  bb.common.I18nEvent
All Implemented Interfaces:
java.io.Serializable
public class I18nEvent
extends BB2Event

See Also:
Serialized Form

Field Summary
Fields inherited from class bb.common.BB2Event
CLOSE_DOCUMENT, DOWNLOAD, OPEN_DOCUMENT, SUBMIT_DOCUMENT, UPLOAD
Constructor Summary
I18nEvent(java.lang.String source)
Method Summary
java.lang.String | getActionI18nKey()
java.lang.String[] | getActionI18nParams()
java.lang.String | getMessageI18nKey()
java.lang.String[] | getMessageI18nParams()
void | setActionI18nKey(java.lang.String actionI18nKey)
void | setActionI18nParams(java.lang.String[] actionI18nParams)
void | setMessageI18nKey(java.lang.String messageI18nKey)
void | setMessageI18nParams(java.lang.String[] messageI18nParams)
Methods inherited from class bb.common.BB2Event
getAction, getMessage, getSource, isPopup, setPopup, toString
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

I18nEvent

public I18nEvent(java.lang.String source)
Method Detail

setActionI18nKey

public void setActionI18nKey(java.lang.String actionI18nKey)

setMessageI18nKey

public void setMessageI18nKey(java.lang.String messageI18nKey)

setActionI18nParams

public void setActionI18nParams(java.lang.String[] actionI18nParams)

setMessageI18nParams

public void setMessageI18nParams(java.lang.String[] messageI18nParams)

getActionI18nKey

public java.lang.String getActionI18nKey()

getMessageI18nKey

public java.lang.String getMessageI18nKey()

getActionI18nParams

public java.lang.String[] getActionI18nParams()

getMessageI18nParams

public java.lang.String[] getMessageI18nParams()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IcrItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class IcrItemListResult

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.IcrItemListResult
All Implemented Interfaces:
java.io.Serializable
public class IcrItemListResult
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CLOSEOUTDATE
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_DATECHECK
static java.lang.String | ORDER_BY_ICRDATE
static java.lang.String | ORDER_BY_ICRITEMNUMBER
static java.lang.String | ORDER_BY_ICRNUMBER
static java.lang.String | ORDER_BY_INSPECTOR
static java.lang.String | ORDER_BY_PARTDESCRIPTION
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTREVISION
static java.lang.String | ORDER_BY_PURCHASEORDER
static java.lang.String | ORDER_BY_QTYCHECK
static java.lang.String | ORDER_BY_QTYQUALIFIED
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_VENDORNAME
static java.lang.String | ORDER_BY_WORKORDER
Constructor Summary
IcrItemListResult()
default constructor
Method Summary
java.util.Date | getClosedOutDate()
java.lang.String | getComments()
java.util.Date | getDateCheck()
java.util.Date | getIcrDate()
java.lang.String | getIcrItemNumber()
java.lang.String | getIcrNumber()
java.lang.String | getInspector()
java.lang.String | getPartDescription()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartRevision()
java.lang.String | getPartType()
java.lang.String | getPurchaseOrder()
java.math.BigDecimal | getQtyCheck()
java.math.BigDecimal | getQtyQualified()
java.lang.String | getStatus()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
java.lang.String | getWorkOrder()
void | setClosedOutDate(java.util.Date closedOutDate)
void | setComments(java.lang.String comments)
void | setDateCheck(java.util.Date dateCheck)
void | setIcrDate(java.util.Date icrDate)
void | setIcrItemNumber(java.lang.String icrItemNumber)
void | setIcrNumber(java.lang.String icrNumber)
void | setInspector(java.lang.String inspector)
void | setPartDescription(java.lang.String partDescription)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartRevision(java.lang.String partRevision)
void | setPartType(java.lang.String partType)
void | setPurchaseOrder(java.lang.String purchaseOrder)
void | setQtyCheck(java.math.BigDecimal qtyCheck)
void | setQtyQualified(java.math.BigDecimal qtyQualified)
void | setStatus(java.lang.String status)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
void | setWorkOrder(java.lang.String workOrder)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_ICRNUMBER

public static final java.lang.String ORDER_BY_ICRNUMBER
See Also:
Constant Field Values

ORDER_BY_ICRITEMNUMBER

public static final java.lang.String ORDER_BY_ICRITEMNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_ICRDATE

public static final java.lang.String ORDER_BY_ICRDATE
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_VENDORNAME

public static final java.lang.String ORDER_BY_VENDORNAME
See Also:
Constant Field Values

ORDER_BY_PARTREVISION

public static final java.lang.String ORDER_BY_PARTREVISION
See Also:
Constant Field Values

ORDER_BY_PARTDESCRIPTION

public static final java.lang.String ORDER_BY_PARTDESCRIPTION
See Also:
Constant Field Values

ORDER_BY_QTYCHECK

public static final java.lang.String ORDER_BY_QTYCHECK
See Also:
Constant Field Values

ORDER_BY_QTYQUALIFIED

public static final java.lang.String ORDER_BY_QTYQUALIFIED
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_INSPECTOR

public static final java.lang.String ORDER_BY_INSPECTOR
See Also:
Constant Field Values

ORDER_BY_DATECHECK

public static final java.lang.String ORDER_BY_DATECHECK
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values

ORDER_BY_PURCHASEORDER

public static final java.lang.String ORDER_BY_PURCHASEORDER
See Also:
Constant Field Values

ORDER_BY_WORKORDER

public static final java.lang.String ORDER_BY_WORKORDER
See Also:
Constant Field Values

ORDER_BY_CLOSEOUTDATE

public static final java.lang.String ORDER_BY_CLOSEOUTDATE
See Also:
Constant Field Values
Constructor Detail

IcrItemListResult

public IcrItemListResult()
default constructor

Method Detail

getPartRevision

public java.lang.String getPartRevision()

setPartRevision

public void setPartRevision(java.lang.String partRevision)

getPartDescription

public java.lang.String getPartDescription()

setPartDescription

public void setPartDescription(java.lang.String partDescription)

getQtyCheck

public java.math.BigDecimal getQtyCheck()

setQtyCheck

public void setQtyCheck(java.math.BigDecimal qtyCheck)

getQtyQualified

public java.math.BigDecimal getQtyQualified()

setQtyQualified

public void setQtyQualified(java.math.BigDecimal qtyQualified)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getDateCheck

public java.util.Date getDateCheck()

setDateCheck

public void setDateCheck(java.util.Date dateCheck)

getInspector

public java.lang.String getInspector()

setInspector

public void setInspector(java.lang.String inspector)

getIcrItemNumber

public java.lang.String getIcrItemNumber()

setIcrItemNumber

public void setIcrItemNumber(java.lang.String icrItemNumber)

getIcrNumber

public java.lang.String getIcrNumber()

setIcrNumber

public void setIcrNumber(java.lang.String icrNumber)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getVendorName

public java.lang.String getVendorName()

setVendorName

public void setVendorName(java.lang.String vendorName)

getPurchaseOrder

public java.lang.String getPurchaseOrder()

setPurchaseOrder

public void setPurchaseOrder(java.lang.String purchaseOrder)

getWorkOrder

public java.lang.String getWorkOrder()

setWorkOrder

public void setWorkOrder(java.lang.String workOrder)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getIcrDate

public java.util.Date getIcrDate()

setIcrDate

public void setIcrDate(java.util.Date icrDate)

getClosedOutDate

public java.util.Date getClosedOutDate()

setClosedOutDate

public void setClosedOutDate(java.util.Date closedOutDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IcrListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class IcrListResult

java.lang.Object
    extended by  bb.common.IcrListResult
All Implemented Interfaces:
java.io.Serializable
public class IcrListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CLOSEDOUTDATE
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_ICRDATE
static java.lang.String | ORDER_BY_ICRNUMBER
static java.lang.String | ORDER_BY_PURCHASEORDER
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_VENDORNAME
static java.lang.String | ORDER_BY_WORKORDER
Constructor Summary
IcrListResult()
Method Summary
java.util.Date | getClosedOutDate()
java.lang.String | getComments()
java.util.Date | getIcrDate()
java.lang.String | getIcrNumber()
java.lang.String | getPurchaseOrder()
java.lang.String | getStatus()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
java.lang.String | getWorkOrder()
void | setClosedOutDate(java.util.Date closedOutDate)
void | setComments(java.lang.String comments)
void | setIcrDate(java.util.Date icrDate)
void | setIcrNumber(java.lang.String icrNumber)
void | setPurchaseOrder(java.lang.String purchaseOrder)
void | setStatus(java.lang.String status)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
void | setWorkOrder(java.lang.String workOrder)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_ICRNUMBER

public static final java.lang.String ORDER_BY_ICRNUMBER
See Also:
Constant Field Values

ORDER_BY_ICRDATE

public static final java.lang.String ORDER_BY_ICRDATE
See Also:
Constant Field Values

ORDER_BY_PURCHASEORDER

public static final java.lang.String ORDER_BY_PURCHASEORDER
See Also:
Constant Field Values

ORDER_BY_WORKORDER

public static final java.lang.String ORDER_BY_WORKORDER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_VENDORNAME

public static final java.lang.String ORDER_BY_VENDORNAME
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_CLOSEDOUTDATE

public static final java.lang.String ORDER_BY_CLOSEDOUTDATE
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values
Constructor Detail

IcrListResult

public IcrListResult()
Method Detail

getClosedOutDate

public java.util.Date getClosedOutDate()

setClosedOutDate

public void setClosedOutDate(java.util.Date closedOutDate)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getIcrNumber

public java.lang.String getIcrNumber()

setIcrNumber

public void setIcrNumber(java.lang.String icrNumber)

getPurchaseOrder

public java.lang.String getPurchaseOrder()

setPurchaseOrder

public void setPurchaseOrder(java.lang.String purchaseOrder)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getVendorName

public java.lang.String getVendorName()

setVendorName

public void setVendorName(java.lang.String vendorName)

getWorkOrder

public java.lang.String getWorkOrder()

setWorkOrder

public void setWorkOrder(java.lang.String workOrder)

getIcrDate

public java.util.Date getIcrDate()

setIcrDate

public void setIcrDate(java.util.Date icrDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


I-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M N O P Q R S T U V W X Y Z

I

I - Static variable in class bb.common.Constant.Prefix
I - Static variable in class bb.common.Constant.TransactionType
I18nEvent - Class in bb.common
I18nEvent(String) - Constructor for class bb.common.I18nEvent
IcrDate - Static variable in class bb.common.Constant.IrDateType
IcrItemListResult - Class in bb.common
IcrItemListResult() - Constructor for class bb.common.IcrItemListResult
default constructor
IcrListResult - Class in bb.common
IcrListResult() - Constructor for class bb.common.IcrListResult
IDLE - Static variable in class bb.common.Constant.EquipmentStatus
ILEGAL_CREDIT_MEMO - Static variable in class bb.common.BIZReason
ILLEGAL_ACCOUNT_NUMBER - Static variable in class bb.common.BIZReason
ILLEGAL_CARRIER_ID - Static variable in class bb.common.BIZReason
ILLEGAL_CATEGORY_ID - Static variable in class bb.common.BIZReason
ILLEGAL_CCODE - Static variable in class bb.common.BIZReason
ILLEGAL_CONTRACT_PRICE_NUMBER - Static variable in class bb.common.BIZReason
ILLEGAL_DCODE - Static variable in class bb.common.BIZReason
ILLEGAL_DESIGN_CONTROL_DOCUMENT_EXTENSION - Static variable in class bb.common.BIZReason
ILLEGAL_DESIGN_CONTROL_DOCUMENT_SEQUENCE - Static variable in class bb.common.BIZReason
ILLEGAL_DRAWING_EXTENSION - Static variable in class bb.common.BIZReason
ILLEGAL_ECODE - Static variable in class bb.common.BIZReason
ILLEGAL_EDC_NUMBER - Static variable in class bb.common.BIZReason
ILLEGAL_ENGINEERING_CHANGE_REQUEST - Static variable in class bb.common.BIZReason
ILLEGAL_INCOTERM_ID - Static variable in class bb.common.BIZReason
ILLEGAL_MAKE_BUY_X - Static variable in class bb.common.BIZReason
ILLEGAL_OCODE - Static variable in class bb.common.BIZReason
ILLEGAL_PART_NUMBER_FORMAT - Static variable in class bb.common.BIZReason
ILLEGAL_PART_REVISION - Static variable in class bb.common.BIZReason
ILLEGAL_PCODE - Static variable in class bb.common.BIZReason
ILLEGAL_PO_MESSAGE_NUMBER - Static variable in class bb.common.BIZReason
ILLEGAL_PROFORMA_INVOICE_NUMBER - Static variable in class bb.common.BIZReason
ILLEGAL_PURCHASE_ORDER_ITEM_NUMBER - Static variable in class bb.common.BIZReason
ILLEGAL_PURCHASE_ORDER_MESSAGE_ITEM_NUMBER - Static variable in class bb.common.BIZReason
ILLEGAL_PURCHASE_ORDER_NUMBER - Static variable in class bb.common.BIZReason
ILLEGAL_QUOTE_ITEM_NUMBER - Static variable in class bb.common.BIZReason
ILLEGAL_REQUEST_FOR_QUOTE_ITEM_NUMBER - Static variable in class bb.common.BIZReason
ILLEGAL_REQUEST_FOR_QUOTE_NUMBER - Static variable in class bb.common.BIZReason
ILLEGAL_RETURN_TO_VENDOR_ITEM_NUMBER - Static variable in class bb.common.BIZReason
ILLEGAL_RETURN_TO_VENDOR_NUMBER - Static variable in class bb.common.BIZReason
ILLEGAL_REVISION_NUMBER_FORMAT - Static variable in class bb.common.BIZReason
ILLEGAL_RFQ_MESSAGE_ITEM_NUMBER - Static variable in class bb.common.BIZReason
ILLEGAL_RFQ_MESSAGE_NUMBER - Static variable in class bb.common.BIZReason
ILLEGAL_SALES_ORDER_ITEM_NUMBER - Static variable in class bb.common.BIZReason
ILLEGAL_SHIP_LIST_NUMBER - Static variable in class bb.common.BIZReason
ILLEGAL_SHIPPER_NUMBER - Static variable in class bb.common.BIZReason
ILLEGAL_SPECIFICATION_ID - Static variable in class bb.common.BIZReason
ILLEGAL_UNIT_NAME - Static variable in class bb.common.BIZReason
ILLEGAL_WORK_INSTRUCTION_SEQUENCE_NUMBER - Static variable in class bb.common.BIZReason
ILLEGAL_WORK_INSTRUCTION_SET_NUMBER - Static variable in class bb.common.BIZReason
ILLEGAL_WORK_ORDER_ITEM_NUMBER - Static variable in class bb.common.BIZReason
ILLEGAL_WORK_ORDER_NUMBER - Static variable in class bb.common.BIZReason
importAddress() - Method in interface bb.common.box.CompanyBox
importBOM() - Method in interface bb.common.box.CompanyBox
importContractPrice(ArrayList<ImportContractPriceData>) - Method in interface bb.common.box.CompanyBox
ImportContractPriceData - Class in bb.common
ImportContractPriceData() - Constructor for class bb.common.ImportContractPriceData
ImportContractPriceData(String, HashSet<ContractPriceItemVO>, HashSet<ContractPriceCustomerVO>) - Constructor for class bb.common.ImportContractPriceData
importCustomer() - Method in interface bb.common.box.CompanyBox
ImportDataVO - Class in bb.common
ImportDataVO() - Constructor for class bb.common.ImportDataVO
importDepartment() - Method in interface bb.common.box.CompanyBox
importEmployee() - Method in interface bb.common.box.CompanyBox
importInventory() - Method in interface bb.common.box.CompanyBox
importManufacture() - Method in interface bb.common.box.CompanyBox
importMaterial() - Method in interface bb.common.box.CompanyBox
importMPN() - Method in interface bb.common.box.CompanyBox
importNccode() - Method in interface bb.common.box.CompanyBox
importPart(boolean) - Method in interface bb.common.box.CompanyBox
importPartMinMaxQty(ArrayList<PartVO>) - Method in interface bb.common.box.CompanyBox
importTaxDetailCategoryFromPredefine() - Method in interface bb.common.box.AccountingBox
importTempAddress(ArrayList<CustomerVendorAddressVO>) - Method in interface bb.common.box.CompanyBox
importTempBOM(ArrayList<BillItemVO>) - Method in interface bb.common.box.CompanyBox
importTempCustomer(ArrayList<CustomerVendorAddressVO>) - Method in interface bb.common.box.CompanyBox
importTempDepartment(ArrayList<CustomerVendorAddressVO>) - Method in interface bb.common.box.CompanyBox
importTempEmployee(ArrayList<EmployeeCardVO>) - Method in interface bb.common.box.CompanyBox
importTempInventory(ArrayList<PartOnhandWithAverageCostResult>) - Method in interface bb.common.box.CompanyBox
importTempManufacture(ArrayList<ManufacturerAddressVO>) - Method in interface bb.common.box.CompanyBox
importTempMaterial(ArrayList<PartMaterialVO>) - Method in interface bb.common.box.CompanyBox
importTempMPN(ArrayList<PartManufacturerVO>) - Method in interface bb.common.box.CompanyBox
importTempMpn(Collection<Map>) - Method in interface bb.common.box.PurchasingBox
importTempNccode(ArrayList<NonConformanceCodeVO>) - Method in interface bb.common.box.CompanyBox
importTempPart(ArrayList<PartVO>) - Method in interface bb.common.box.CompanyBox
importTempTool(ArrayList<ToolVO>) - Method in interface bb.common.box.CompanyBox
importTempToolInventory(ArrayList<ToolOnhandWithAverageCostResult>) - Method in interface bb.common.box.CompanyBox
importTempVendor(ArrayList<CustomerVendorAddressVO>) - Method in interface bb.common.box.CompanyBox
importTool(boolean) - Method in interface bb.common.box.CompanyBox
importToolInventory(boolean) - Method in interface bb.common.box.CompanyBox
importVendor() - Method in interface bb.common.box.CompanyBox
IN_DEPRECIATE - Static variable in class bb.common.Constant.Depreciation.DepreciateStatus
IN_USE - Static variable in class bb.common.Constant.Depreciation.UsingType
INCLUDE_BOM_SELF - Static variable in class bb.common.BIZReason
IncomeByMonthChartResult - Class in bb.common
IncomeByMonthChartResult() - Constructor for class bb.common.IncomeByMonthChartResult
INCOTERM - Static variable in class bb.common.BizTarget
INCOTERM_ALREADY_EXIST - Static variable in class bb.common.BIZReason
INCOTERM_NOT_EXIST - Static variable in class bb.common.BIZReason
INCOTERM_USING_BY_PO - Static variable in class bb.common.BIZReason
INCOTERM_USING_BY_RMA - Static variable in class bb.common.BIZReason
INCOTERM_USING_BY_RTV - Static variable in class bb.common.BIZReason
INCOTERM_USING_BY_SO - Static variable in class bb.common.BIZReason
IncotermVO - Class in bb.common
IncotermVO() - Constructor for class bb.common.IncotermVO
INDIRECTEXCHANGERATE - Static variable in class bb.common.Constant.ExchangeRateType
InfoByFiscalChartResult - Class in bb.common
InfoByFiscalChartResult() - Constructor for class bb.common.InfoByFiscalChartResult
InfoByMonthChartResult - Class in bb.common
InfoByMonthChartResult() - Constructor for class bb.common.InfoByMonthChartResult
InfoByMonthResult - Class in bb.common
InfoByMonthResult() - Constructor for class bb.common.InfoByMonthResult
initAccountsReceivableItemVO(AccountsReceivableVO, BB2Part, BigDecimal) - Method in interface bb.common.box.AccountingBox
initAssetDepreciate(String, String, String, String, String, String, String, boolean, int, int) - Method in interface bb.common.box.AccountingBox
initAssetDepreciateCount(String, String, String, String, String, String, String, boolean) - Method in interface bb.common.box.AccountingBox
initDatabase(String) - Method in interface bb.common.box.CompanyBox
initDisassembleWorkOrderItem(String, String, PartPK, BigDecimal, String, String) - Method in interface bb.common.box.WorkOrderBox
initMessageStatus(String) - Static method in class bb.common.BB2Util
InitNonproductivePickingItem(NonproductivePickingVO, BB2Part, BigDecimal) - Method in interface bb.common.box.WarehouseBox
initOnLoanItem(OnLoanVO, PartPK, BigDecimal, boolean) - Method in interface bb.common.box.WarehouseBox
initPackingBoxItemVO(PackingBoxPK, SalesOrderItemPK, BigDecimal) - Method in interface bb.common.box.WarehouseBox
InitPartManufacturerVoByAddressId(PartPK, String) - Method in interface bb.common.box.EngineeringBox
initPartsToDeleteByPns(String[], String) - Method in interface bb.common.box.EngineeringBox
InitPartVendorVoByAddressId(PartPK, String) - Method in interface bb.common.box.EngineeringBox
initProformaReceiverPackingBoxs(ProformaInvoiceVO, String) - Method in interface bb.common.box.PurchasingBox
initPurchaseOrderItemForPart(String, String, PartPK, BigDecimal) - Method in interface bb.common.box.PurchasingBox
initPurchaseOrderItemForTool(String, String, PartPK, BigDecimal) - Method in interface bb.common.box.ManufacturingBox
initPurchaseWorkSheetItemForPart(PurchaseWorkSheetPK, String, PartPK, BigDecimal) - Method in interface bb.common.box.PurchasingBox
initPurchaseWorkSheetItemForTool(PurchaseWorkSheetPK, String, PartPK, BigDecimal) - Method in interface bb.common.box.ManufacturingBox
initQuoteItem(QuoteVO, PartPK, BigDecimal, boolean) - Method in interface bb.common.box.SalesBox
initRequestForQuoteItemForPart(String, String, PartPK, BigDecimal, String) - Method in interface bb.common.box.PurchasingBox
initRequestForQuoteItemForTool(String, String, PartPK, BigDecimal, String) - Method in interface bb.common.box.ManufacturingBox
initRequestForQuoteItemForTool(String, String, PartPK, BigDecimal, String) - Method in interface bb.common.box.PurchasingBox
initReturnToVendorItemForPart(String, String, PartPK, BigDecimal) - Method in interface bb.common.box.ManufacturingBox
initReturnToVendorItemForPart(String, String, PartPK, BigDecimal) - Method in interface bb.common.box.PurchasingBox
initReturnToVendorItemForTool(String, String, PartPK, BigDecimal) - Method in interface bb.common.box.ManufacturingBox
initReturnToVendorItemForTool(String, String, PartPK, BigDecimal) - Method in interface bb.common.box.PurchasingBox
initRmaItem(ReturnMaterialAuthorizationVO, PartPK, BigDecimal, boolean) - Method in interface bb.common.box.SalesBox
initRmaItem(ReturnMaterialAuthorizationVO, PartPK, BigDecimal, boolean, boolean) - Method in interface bb.common.box.SalesBox
initSalesOrderItem(SalesOrderVO, PartPK, BigDecimal, boolean) - Method in interface bb.common.box.SalesBox
initSalesOrderItem(SalesOrderVO, PartPK, BigDecimal, boolean, boolean) - Method in interface bb.common.box.SalesBox
initServerTime(long) - Static method in class bb.common.BB2TimeFactory
initShipListItem(String, SalesOrderItemPK) - Method in interface bb.common.box.PlanningBox
initSOItemsToshiplist(String, String, Date, Date, List, List, boolean, List, List) - Method in interface bb.common.box.PlanningBox
initSwapOrderItem(SwapOrderVO, PartPK, BigDecimal, boolean) - Method in interface bb.common.box.PurchasingBox
initToolListItemWithToolInfo(PartPK, BillItemPK, BigDecimal) - Method in interface bb.common.box.ManufacturingBox
InitToolManufacturerVoByAddressId(PartPK, String) - Method in interface bb.common.box.ManufacturingBox
InitToolVendorVoByAddressId(PartPK, String) - Method in interface bb.common.box.ManufacturingBox
initTransferOrderItem(TransferOrderVO, PartPK, BigDecimal, boolean) - Method in interface bb.common.box.WarehouseBox
initWarehouse(String, String, String) - Method in interface bb.common.box.WarehouseBox
initWorkOrderItemForNA(String, String, String, BigDecimal) - Method in interface bb.common.box.WorkOrderBox
initWorkOrderItemForPart(String, String, PartPK, BigDecimal) - Method in interface bb.common.box.WorkOrderBox
initWorkOrderItemForTool(String, String, PartPK, BigDecimal) - Method in interface bb.common.box.WorkOrderBox
initWorkOrderWorkSheetItemForPart(WorkOrderWorkSheetPK, String, PartPK, BigDecimal) - Method in interface bb.common.box.WorkOrderBox
initWorkOrderWorkSheetItemForTool(WorkOrderWorkSheetPK, String, PartPK, BigDecimal) - Method in interface bb.common.box.WorkOrderBox
Inner - Static variable in class bb.common.Constant.TransferType
INPROGRESS - Static variable in class bb.common.Constant.Status
INPUT_CAN_NOT_BE_EMPTY_STRING - Static variable in class bb.common.BIZReason
INPUT_MUST_BE_EMPTY_STRING - Static variable in class bb.common.BIZReason
INQA_ALREADY_CREATE_NCR - Static variable in class bb.common.BIZReason
INSIP - Static variable in class bb.common.BB2QtyAndMoneyMap
InSipAudittListResult - Class in bb.common
InSipAudittListResult() - Constructor for class bb.common.InSipAudittListResult
INSIT - Static variable in class bb.common.BB2QtyAndMoneyMap
INSPECTION_REPORT - Static variable in class bb.common.BizTarget
INSPECTION_REPORT_NOT_EXIST - Static variable in class bb.common.BIZReason
INSPECTION_TYPE - Static variable in class bb.common.BizTarget
INSPECTION_TYPE_IS_EXISTENT - Static variable in class bb.common.BIZReason
INSPECTION_TYPE_IS_NOT_EXISTENT - Static variable in class bb.common.BIZReason
INSPECTION_TYPE_IS_USED - Static variable in class bb.common.BIZReason
InspectionConformanceReportItemCheckPK - Class in bb.common
InspectionConformanceReportItemCheckPK() - Constructor for class bb.common.InspectionConformanceReportItemCheckPK
InspectionConformanceReportItemCheckVO - Class in bb.common
InspectionConformanceReportItemCheckVO() - Constructor for class bb.common.InspectionConformanceReportItemCheckVO
InspectionConformanceReportItemInfo - Class in bb.common
InspectionConformanceReportItemInfo() - Constructor for class bb.common.InspectionConformanceReportItemInfo
InspectionConformanceReportItemPK - Class in bb.common
InspectionConformanceReportItemPK() - Constructor for class bb.common.InspectionConformanceReportItemPK
InspectionConformanceReportItemPK(String, String) - Constructor for class bb.common.InspectionConformanceReportItemPK
InspectionConformanceReportItemVO - Class in bb.common
InspectionConformanceReportItemVO() - Constructor for class bb.common.InspectionConformanceReportItemVO
default constructor
InspectionConformanceReportVO - Class in bb.common
InspectionConformanceReportVO() - Constructor for class bb.common.InspectionConformanceReportVO
default constructor
InspectionItemPK - Class in bb.common
InspectionItemPK() - Constructor for class bb.common.InspectionItemPK
InspectionItemVO - Class in bb.common
InspectionItemVO() - Constructor for class bb.common.InspectionItemVO
InspectionReportInfoVO - Class in bb.common
InspectionReportInfoVO() - Constructor for class bb.common.InspectionReportInfoVO
InspectionReportInspectMethodItemPK - Class in bb.common
InspectionReportInspectMethodItemPK() - Constructor for class bb.common.InspectionReportInspectMethodItemPK
InspectionReportInspectMethodItemVO - Class in bb.common
InspectionReportInspectMethodItemVO() - Constructor for class bb.common.InspectionReportInspectMethodItemVO
InspectionReportInspectMethodVO - Class in bb.common
InspectionReportInspectMethodVO() - Constructor for class bb.common.InspectionReportInspectMethodVO
InspectionReportInspectStandardItemPK - Class in bb.common
InspectionReportInspectStandardItemPK() - Constructor for class bb.common.InspectionReportInspectStandardItemPK
InspectionReportInspectStandardItemVO - Class in bb.common
InspectionReportInspectStandardItemVO() - Constructor for class bb.common.InspectionReportInspectStandardItemVO
InspectionReportItemPK - Class in bb.common
InspectionReportItemPK() - Constructor for class bb.common.InspectionReportItemPK
InspectionReportItemQtyPK - Class in bb.common
InspectionReportItemQtyPK() - Constructor for class bb.common.InspectionReportItemQtyPK
InspectionReportItemQtyVO - Class in bb.common
InspectionReportItemQtyVO() - Constructor for class bb.common.InspectionReportItemQtyVO
InspectionReportItemVO - Class in bb.common
InspectionReportItemVO() - Constructor for class bb.common.InspectionReportItemVO
InspectionReportVO - Class in bb.common
InspectionReportVO() - Constructor for class bb.common.InspectionReportVO
InspectionTypeItemPK - Class in bb.common
InspectionTypeItemPK() - Constructor for class bb.common.InspectionTypeItemPK
InspectionTypeItemPK(String, String) - Constructor for class bb.common.InspectionTypeItemPK
InspectionTypeItemVO - Class in bb.common
InspectionTypeItemVO() - Constructor for class bb.common.InspectionTypeItemVO
InspectionTypeVO - Class in bb.common
InspectionTypeVO() - Constructor for class bb.common.InspectionTypeVO
inStrings(String, String, String) - Static method in class bb.common.BB2Util
INSUFFICIENT_PERMISSION - Static variable in exception bb.common.PermissionException
INTERNAL_COMPANY_EMPLOYID_CAN_NOT_BE_NULL - Static variable in class bb.common.BIZReason
interval(Date, Date) - Static method in class bb.common.BB2Util
intervalAbs(Date, Date) - Static method in class bb.common.BB2Util
INVALID - Static variable in class bb.common.Configure.LoginStatus
INVALID - Static variable in class bb.common.Configure.UpdatePermission
INVALID - Static variable in class bb.common.Configure.UserLocked
INVALID - Static variable in class bb.common.Configure.UserType
INVALID_ARGUMENT - Static variable in class bb.common.BIZReason
INVALID_PAY_DATE - Static variable in class bb.common.BIZReason
INVALID_USER - Static variable in class bb.common.BIZReason
Inventory - Static variable in class bb.common.Constant.DrawingType
Inventory - Static variable in class bb.common.Constant.PartFrom
INVENTORY_ADJUSTMENT - Static variable in class bb.common.BizTarget
InventoryAdjustmentDetailResult - Class in bb.common
InventoryAdjustmentDetailResult() - Constructor for class bb.common.InventoryAdjustmentDetailResult
InventoryAdjustmentListResult - Class in bb.common
InventoryAdjustmentListResult() - Constructor for class bb.common.InventoryAdjustmentListResult
InventoryAdjustmentVO - Class in bb.common
InventoryAdjustmentVO() - Constructor for class bb.common.InventoryAdjustmentVO
default constructor
InventoryAmountByMonth - Class in bb.common
InventoryAmountByMonth() - Constructor for class bb.common.InventoryAmountByMonth
InventoryAuditReportResult - Class in bb.common
InventoryAuditReportResult() - Constructor for class bb.common.InventoryAuditReportResult
InventoryCycleItemResult - Class in bb.common
InventoryCycleItemResult() - Constructor for class bb.common.InventoryCycleItemResult
InventoryCycleResult - Class in bb.common
InventoryCycleResult() - Constructor for class bb.common.InventoryCycleResult
InventoryListResult - Class in bb.common
InventoryListResult() - Constructor for class bb.common.InventoryListResult
InventoryMonthReport - Class in bb.common
InventoryMonthReport() - Constructor for class bb.common.InventoryMonthReport
InventoryNotUsedInMonthsforAppResult - Class in bb.common
InventoryNotUsedInMonthsforAppResult() - Constructor for class bb.common.InventoryNotUsedInMonthsforAppResult
InventoryNotUsedInMonthsResult - Class in bb.common
InventoryNotUsedInMonthsResult() - Constructor for class bb.common.InventoryNotUsedInMonthsResult
InventoryNotUsedTotal - Class in bb.common
InventoryNotUsedTotal() - Constructor for class bb.common.InventoryNotUsedTotal
InventoryPartInOutDetailListResult - Class in bb.common
InventoryPartInOutDetailListResult() - Constructor for class bb.common.InventoryPartInOutDetailListResult
InventoryReportListResult - Class in bb.common
InventoryReportListResult() - Constructor for class bb.common.InventoryReportListResult
InventoryTotalCostResult - Class in bb.common
InventoryTotalCostResult() - Constructor for class bb.common.InventoryTotalCostResult
InventoryTotalResult - Class in bb.common
InventoryTotalResult() - Constructor for class bb.common.InventoryTotalResult
INVOICE - Static variable in class bb.common.BizTarget
INVOICE - Static variable in class bb.common.Constant.PayableMethod
INVOICE_NOT_CONSISTENT - Static variable in class bb.common.BIZReason
INVOICE_NOT_EXIST - Static variable in class bb.common.BIZReason
InvoiceAgingItemListResult - Class in bb.common
InvoiceAgingItemListResult() - Constructor for class bb.common.InvoiceAgingItemListResult
Invoiced - Static variable in class bb.common.Constant.Status
INVOICEDATE - Static variable in class bb.common.Constant.DateType
InvoiceItemListResult - Class in bb.common
InvoiceItemListResult() - Constructor for class bb.common.InvoiceItemListResult
invoiceStatus - Variable in class bb.common.SalesOrderItemListResult
invoke(ServerAction) - Method in interface bb.common.Facade
invoke(ServerAction) - Method in class bb.common.Spiderman
INVOKE_FAILED - Static variable in class bb.common.BIZReason
invokeDaoMethod(String, String, Object[], Class[]) - Method in interface bb.common.box.CompanyBox
InvokeException - Exception in bb.common
InvokeException(Exception) - Constructor for exception bb.common.InvokeException
InvokeException(String) - Constructor for exception bb.common.InvokeException
InvokeException(Exception, Reason) - Constructor for exception bb.common.InvokeException
InvokeException(Reason) - Constructor for exception bb.common.InvokeException
InvokeException(String, Reason) - Constructor for exception bb.common.InvokeException
IpAddressVO - Class in bb.common
IpAddressVO() - Constructor for class bb.common.IpAddressVO
default constructor
IR - Static variable in class bb.common.BizTarget
IR - Static variable in class bb.common.Constant.Prefix
IR_ALREADY_EXIST - Static variable in class bb.common.BIZReason
IR_DOC - Static variable in class bb.common.Constant.MiscDocType
IR_NOT_EXIST - Static variable in class bb.common.BIZReason
IRNUMBER_HAS_BEEN_USED - Static variable in class bb.common.BIZReason
IRNUMBER_IS_NOT_FOR_THIS_PURCHASE_ORDER_ITEM - Static variable in class bb.common.BIZReason
IRNUMBER_IS_NOT_FOR_THIS_WORK_ORDER_ITEM - Static variable in class bb.common.BIZReason
IRNUMBER_NOT_EXIST - Static variable in class bb.common.BIZReason
IRNUMBER_NOT_MATCH_PURCHASE_ORDER - Static variable in class bb.common.BIZReason
IRNUMBER_NOT_MATCH_WORK_ORDER - Static variable in class bb.common.BIZReason
isAccountingMail() - Method in class bb.common.CustomerVendorContactVO
isAccountNumberHasChild(String, String) - Method in interface bb.common.box.AccountingBox
isAccountsExist(String) - Method in interface bb.common.box.AccountingBox
isActive() - Method in class bb.common.AccountsChartVO
isActive() - Method in class bb.common.BudgetListResult
isActive() - Method in class bb.common.CustomGoodsBreedVO
isActive() - Method in class bb.common.LabelTemplateVO
isActived() - Method in class bb.common.HelpServerVO
isActiveHelpServerExist() - Method in interface bb.common.box.CompanyBox
isAddressDeleted(String) - Method in interface bb.common.box.AddressBox
isAddressExistent(String) - Method in interface bb.common.box.AddressBox
isAllowEmptyGL() - Method in class bb.common.CompanyVO
isAllowNegativeCreditOrDebit() - Method in class bb.common.CompanyVO
isAlreadySetup() - Method in class bb.common.MasterWorkOrderTreeItemResult
isAPExist(String) - Method in interface bb.common.box.AccountingBox
isAppPropertyExist(String) - Method in interface bb.common.box.CompanyBox
isApproveSubWO() - Method in class bb.common.CompanyVO
isAppTableColumnExist(String, String) - Method in interface bb.common.box.CompanyBox
isAppTableExist(String) - Method in interface bb.common.box.CompanyBox
isArBoilerplateExist(String) - Method in interface bb.common.box.AccountingBox
isARInMyPrintList(String) - Method in interface bb.common.box.AccountingBox
isAudit() - Method in class bb.common.WorkInstructionSeqAuditListResult
isAuditForeignCurrency() - Method in class bb.common.AccountsChartVO
isAutoApprove() - Method in class bb.common.GLAutoApproveVO
isAutoEmployeeId() - Method in class bb.common.CompanyVO
isAutoTempWorderId() - Method in class bb.common.CompanyVO
isBackflushMaterial() - Method in class bb.common.BillItemWithPartInfoResult
isBalanceSheetDocumentExist(String, String) - Method in interface bb.common.box.AccountingBox
isBankReconciliationReportExistent(AccountMonthPK) - Method in interface bb.common.box.AccountingBox
isBillExistent(BillPK) - Method in interface bb.common.box.EngineeringBox
isBizBoxUserExistByUserName(String) - Method in interface bb.common.box.SecurityBox
isBomApprovalExistent(String) - Method in interface bb.common.box.EngineeringBox
isByInvoice() - Method in class bb.common.CustomerVendorAddressInfoVO
isByInvoice() - Method in class bb.common.CustomerVendorAddressVO
isByOnHand() - Method in class bb.common.WorkOrderItemCanAssyAgent
isByPos() - Method in class bb.common.ReturnMaterialAuthorizationVO
isByPos() - Method in class bb.common.SalesOrderVO
isByShipTOID() - Method in class bb.common.ShipListAgent
isByVendor() - Method in class bb.common.AddRTVAgent
isCanApproveOwn() - Method in class bb.common.NcrApprovalVO
isCanApproveOwn() - Method in class bb.common.SwapOrderApprovalVO
isCanApproveOwn() - Method in class bb.common.TransferOrderApprovalVO
isCanApproveOwnBom() - Method in class bb.common.BomApprovalVO
isCanApproveOwnWorkInstruction() - Method in class bb.common.WorkInstructionApprovalVO
isCanReviewOwnNonproPicking() - Method in class bb.common.NonproductivePickingApprovalVO
isCategoryUsedInAccountsChart(Long) - Method in interface bb.common.box.AccountingBox
isCclimit() - Method in class bb.common.CustomerCLimitResult
isCertificateNumberExist(String) - Method in interface bb.common.box.QualityBox
isChangePasswordEncrypt() - Method in class bb.common.PasswordPolicyAgent
isChangePasswordLifetime() - Method in class bb.common.PasswordPolicyAgent
isChangePasswordMinLength() - Method in class bb.common.PasswordPolicyAgent
isChangeStdCostWorkSheetItemExistent(ChangeStdCostWorkSheetItemPK) - Method in interface bb.common.box.AccountingBox
isCheckEachOther() - Method in class bb.common.InspectionReportInfoVO
isCheckEachOther() - Method in class bb.common.InspectionReportVO
isChecked() - Method in class bb.common.BudgetListResult
isChecked() - Method in class bb.common.GlCashFlowBudgetVO
isChecked() - Method in class bb.common.PackingBoxSalesOrderItemResult
isCheckReturn() - Method in class bb.common.RunningAccountOrderItemResult
isCheckReturn() - Method in class bb.common.RunningAccountOrderVO
isCHold() - Method in class bb.common.CustomerCLimitResult
isClear() - Method in class bb.common.GeneralLedgerByDateListResult
isClear() - Method in class bb.common.GeneralLedgerVO
isCloseAR() - Method in class bb.common.PaymentAgent
isClosingStatementDocumentExist(String, String) - Method in interface bb.common.box.AccountingBox
isCommitted() - Method in class bb.common.CycleCountListResult
isCommitted() - Method in class bb.common.CycleCountVO
isCommitted() - Method in class bb.common.PhysicalInventoryListResult
isCommitted() - Method in class bb.common.PhysicalInventoryVO
isCompanyUnitAccountExistent(CompanyUnitAccountPK) - Method in interface bb.common.box.CompanyBox
isCompanyUnitExistent(String) - Method in interface bb.common.box.CompanyBox
isComputeOrpSOWO() - Method in class bb.common.MrpReportAgent
isConsiderInSTO() - Method in class bb.common.MrpReportAgent
isContainTax() - Method in class bb.common.SalesCodeVO
isContractPriceCustomerExistent(ContractPriceCustomerPK) - Method in interface bb.common.box.SalesBox
isContractPriceExistent(String) - Method in interface bb.common.box.SalesBox
isContractPriceItemExistent(ContractPriceItemPK) - Method in interface bb.common.box.SalesBox
isCopyMpn() - Method in class bb.common.SO2WOAgent
isCostAlarm() - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult
isCostAlarm() - Method in class bb.common.DisassembleWorkOrderItemVO
isCostAlarm() - Method in class bb.common.WOItemCostControlAgent
isCostAlarm() - Method in class bb.common.WorkOrderItemPartDetailResult
isCostAlarm() - Method in class bb.common.WorkOrderItemVO
isCreatedGL() - Method in class bb.common.DisassembleWorkOrderItemVO
isCurrentFYUseAccountingPeriod() - Method in interface bb.common.box.AccountingBox
isCurrentUserHasApproveGLPermission() - Method in interface bb.common.box.AccountingBox
isCurrentUserHasEngGroupPermission(PartPK) - Method in interface bb.common.box.EngineeringBox
isCustomAssetExist(String) - Method in interface bb.common.box.HumanResourceBox
isCustomDepartmentExist(String) - Method in interface bb.common.box.HumanResourceBox
isCustomEmployeeExist(String) - Method in interface bb.common.box.HumanResourceBox
isCustomer(String) - Method in interface bb.common.box.AddressBox
isCustomerExist(String) - Method in interface bb.common.box.AddressBox
isCustomerFeedbackExist(String) - Method in interface bb.common.box.CustomerServiceBox
isCustomerHold(String) - Method in interface bb.common.box.AddressBox
isCustomerHold() - Method in class bb.common.CustomerStatementTotalResult
isCustomerHold() - Method in class bb.common.CustomerVendorAddressInfoVO
isCustomerHold() - Method in class bb.common.CustomerVendorAddressVO
isCustomerServiceIncidentExist(String) - Method in interface bb.common.box.CustomerServiceBox
isCustomGoodsBreedExist(String) - Method in interface bb.common.box.HumanResourceBox
isCustomGoodsRecordExist(Long) - Method in interface bb.common.box.HumanResourceBox
isCustomJobCategoryExist(String) - Method in interface bb.common.box.HumanResourceBox
isCycleCount() - Method in class bb.common.PhysicalInventoryStatusVO
isCycleWorkSheetExist(int) - Method in interface bb.common.box.WarehouseBox
isCycleWorkSheetPageExist(int, int) - Method in interface bb.common.box.WarehouseBox
isDefaultPartUnit() - Method in class bb.common.PartUnitVO
isDeleted() - Method in class bb.common.CustomerVendorAddressInfoVO
isDeleted() - Method in class bb.common.CustomerVendorAddressVO
isDeleted() - Method in class bb.common.ManufacturerAddressInfoVO
isDeleted() - Method in class bb.common.ManufacturerAddressVO
isDeleted() - Method in class bb.common.PartVO
isDeleted() - Method in class bb.common.PartWithOnhandsVO
isDeleteZeroLocation() - Method in class bb.common.CompanyVO
isDepartmentExist(String) - Method in interface bb.common.box.AddressBox
isDeposit() - Method in class bb.common.GeneralLedgerVO
isDirectlyPrintAR() - Method in class bb.common.PointOfSaleVO
isDisassembleWorkOrderApprovalExistent(String) - Method in interface bb.common.box.WorkOrderBox
isDisassembleWorkOrderItemExist(DisassembleWorkOrderItemPK) - Method in interface bb.common.box.WorkOrderBox
isDiscountable() - Method in class bb.common.PartVO
isDiscountable() - Method in class bb.common.RunningAccountOrderItemVO
isDocType() - Method in class bb.common.PartTypeVO
isDocumentServerExist(String) - Method in interface bb.common.box.CompanyBox
isDoubleDigit(String, boolean) - Static method in class bb.common.BB2Util
isDrawing() - Method in class bb.common.SGPartListResult
isDutyFree() - Method in class bb.common.CustomerVendorAddressInfoVO
isDutyFree() - Method in class bb.common.CustomerVendorAddressVO
isDutyFree() - Method in class bb.common.RunningAccountOrderItemVO
isECNControlRecorded(String) - Method in interface bb.common.box.EngineeringBox
isECRControlRecorded(String) - Method in interface bb.common.box.EngineeringBox
isEditable() - Method in class bb.common.AppColumnVO
isEmailAddressValid(String) - Static method in class bb.common.BB2Util
isEmployeeExistent(String) - Method in interface bb.common.box.HumanResourceBox
isEmployeeIdUsedByOther(String) - Method in interface bb.common.box.SecurityBox
isEmployeeLaborCost() - Method in class bb.common.WorkOrderItemTimeDetailVO
isEmpty() - Method in class bb.common.BOMTreeRollUPMap
isEmpty() - Method in class bb.common.POForWISeqAgent
isEmpty(String) - Method in class bb.common.POForWISeqAgent
isEmpty() - Method in class bb.common.WCLoadAgent
isEmpty() - Method in class bb.common.WorkCenterAgent
isEmptyString(String) - Static method in class bb.common.BB2Util
isEnableTracking() - Method in class bb.common.CompanyVO
isEngGroupExistent(String) - Method in interface bb.common.box.EngineeringBox
isEngGroupUserExist(EngGroupUserPK) - Method in interface bb.common.box.EngineeringBox
isEngineeringNewPartForNewPart() - Method in class bb.common.CompanyVO
isEngineeringSharingItemExist(EngineeringSharingItemPK) - Method in interface bb.common.box.EngineeringBox
isExistCashier(String) - Method in interface bb.common.box.CompanyBox
isExistentNotUniqueMpn() - Method in interface bb.common.box.EngineeringBox
isExistPartInUseType(PartPK) - Method in interface bb.common.box.WorkOrderBox
isExtCustomerArTotalDue(String) - Method in interface bb.common.box.AddressBox
isFeedbackQuestionExist(String) - Method in interface bb.common.box.CustomerServiceBox
isFileExistent(MiscDocAgent, String) - Method in interface bb.common.box.CompanyBox
isFinish() - Method in class bb.common.WorkOrderItemSeqWCLoadResult
isFinishable() - Method in class bb.common.WorkOrderItemWCLoadResult
isFinished() - Method in class bb.common.WCLoadDetailResult
isFinished() - Method in class bb.common.WorkOrderTimeCardVO
isFinished() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO
isFiscalYearSettingsExist(String) - Method in interface bb.common.box.AccountingBox
isFiscalYearUsed(String) - Method in interface bb.common.box.AccountingBox
isFlushLocation() - Method in class bb.common.PartOnhandVO
isFocusWC() - Method in class bb.common.WorkOrderItemSeqWCLoadResult
isForeignCurrencyAcc() - Method in class bb.common.AccountsChartVO
isForeignCurrencyAcc(String) - Method in interface bb.common.box.AccountingBox
isFullload() - Method in class bb.common.WorkCenterLoadAgent
isGender() - Method in class bb.common.EmployeeCardVO
isGLApprovedExsitByUserName(String) - Method in interface bb.common.box.AccountingBox
isGLAutoApproveExist(String) - Method in interface bb.common.box.AccountingBox
isGLCategoryExist(String) - Method in interface bb.common.box.AccountingBox
isGLCategoryUsed(String) - Method in interface bb.common.box.AccountingBox
isGlMonthExist(String) - Method in interface bb.common.box.AccountingBox
isGlobal() - Method in class bb.common.UserGroupVO
isGroup() - Method in class bb.common.WorkCenterAgent
isGroup() - Method in class bb.common.WorkCenterLoadListResult
isHighlight() - Method in class bb.common.CPItemFromQuoteResult
isHold() - Method in class bb.common.DisassembleWorkOrderIssuingResult
isHold() - Method in class bb.common.DisassembleWorkOrderReceivingResult
isHold() - Method in class bb.common.DisassembleWorkOrderVO
isHold() - Method in class bb.common.EngineeringChangeVO
isHold() - Method in class bb.common.PurchaseOrderVO
isHold() - Method in class bb.common.ReceivingResult
isHold() - Method in class bb.common.SalesOrderVO
isHold() - Method in class bb.common.ShippingResult
isHold() - Method in class bb.common.WorkOrderVO
isIcrExist(String) - Method in interface bb.common.box.QualityBox
isIcrFinishedInspection(String, String) - Method in interface bb.common.box.QualityBox
isIcrRequiredWhenReceiverNa() - Method in class bb.common.OrderApprovalItemsVO
isIcrRequiredWhenReceiverNa() - Method in class bb.common.PurchaseOrderItemVO
isIcrRequiredWhenReceiverNa() - Method in class bb.common.ReceivingItemResult
isIcrRequiredWhenReceiverNa() - Method in class bb.common.WorkOrderItemVO
isInactive() - Method in class bb.common.ToolVO
isIncludeAssembly() - Method in class bb.common.MrpReportAgent
isIncludeMPNs() - Method in class bb.common.SO2POAgent
isIncludePoTax() - Method in class bb.common.CompanyVO
isIncludeToleranceQty() - Method in class bb.common.MrpReportAgent
isInitBranchWarehouse() - Method in class bb.common.CompanyVO
isInspectionItemExist(InspectionItemPK) - Method in interface bb.common.box.ManufacturingBox
isInspectionOutputFile() - Method in class bb.common.OperatingInstructionsVO
isInspectionReportExist(String) - Method in interface bb.common.box.ManufacturingBox
isInspectionReportInspectMethodExist(int) - Method in interface bb.common.box.ManufacturingBox
isInteger(String, boolean) - Static method in class bb.common.BB2Util
isInUse() - Method in class bb.common.DataFilterVO
isInvoiceExist(String) - Method in interface bb.common.box.AccountingBox
isItalic() - Method in class bb.common.LabelTemplateItemVO
isItemReceivable() - Method in class bb.common.ReceivingItemResult
isItemReceivableAll() - Method in class bb.common.ReceivingItemResult
isLabelTemplateExist(int) - Method in interface bb.common.box.WarehouseBox
isLabelVisible() - Method in class bb.common.LabelTemplateItemVO
isLaborCost() - Method in class bb.common.AccountingSettingsVO
isLastMonthYear() - Method in interface bb.common.box.AccountingBox
isLeadTime() - Method in class bb.common.MrpReportAgent
isLegalTerms(String) - Static method in class bb.common.BB2Util
isList12MonthAvg() - Method in class bb.common.OnTimeAgent
isListAllDemand() - Method in class bb.common.MrpReportAgent
isListAllPart() - Method in class bb.common.MrpReportAgent
isListBOM() - Method in class bb.common.BOMCanAssyAgent
isListFiscalYear() - Method in class bb.common.OnTimeAgent
isListPastDue() - Method in class bb.common.MrpReportAgent
isListSO() - Method in class bb.common.BOMCanAssyAgent
isListWO() - Method in class bb.common.BOMCanAssyAgent
isListYearToDate() - Method in class bb.common.OnTimeAgent
isListZeroNeedBefore() - Method in class bb.common.MrpReportAgent
isLocationExist(String) - Method in interface bb.common.box.WarehouseBox
isLocked() - Method in class bb.common.BizBoxUserEmployeeResult
isLocked() - Method in class bb.common.BizboxUserListResult
isLocked() - Method in class bb.common.BizboxUserVO
isLocked(String, String) - Method in interface bb.common.box.SecurityBox
isLocked() - Method in class bb.common.MiscDocumentSettingVO
isLocked() - Method in class bb.common.PartClassVO
isLogin(String, String) - Method in interface bb.common.box.SecurityBox
isMachineCost() - Method in class bb.common.AccountingSettingsVO
isMadeGL() - Method in class bb.common.PhysicalInventoryVO
isMainPicture() - Method in class bb.common.BB2Picture
isMainPicture() - Method in class bb.common.MiscDocAgent
isMainPicture() - Method in class bb.common.PartPictureVO
isMakeGLWhenReceivingWO() - Method in class bb.common.CompanyVO
isMakeNcr(BB2Part, String) - Method in interface bb.common.box.WarehouseBox
isMandatory() - Static method in class bb.common.VersionInformation
This indicate whether force the GUI to get the update before login system.
isManual() - Method in class bb.common.SGPartDocFlagResult
isManufacturerIdExist(String) - Method in interface bb.common.box.AddressBox
isManufacturerPartExistent(String, String) - Method in interface bb.common.box.EngineeringBox
isMasterWorkOrder() - Method in class bb.common.WorkOrderItemInfoResult
isMasterWorkOrder() - Method in class bb.common.WorkOrderItemVO
isMinQty() - Method in class bb.common.MrpReportAgent
isMiscDocExist(String) - Method in interface bb.common.box.CompanyBox
isMpnUsedOneTime() - Method in class bb.common.CompanyVO
isMyPasswordExpired() - Method in interface bb.common.box.SecurityBox
isNcCodeOnlyOneLetterOrTwoNumber() - Method in class bb.common.CompanyVO
isNCRExist(String) - Method in interface bb.common.box.QualityBox
isNeedLog() - Method in class bb.common.LogMethodVO
isNeedLog() - Method in class bb.common.TaskVO
isNeedPassforIssuingWO() - Method in class bb.common.CompanyVO
isNeedPickerforIssuingWO() - Method in class bb.common.CompanyVO
isNeedReply() - Method in class bb.common.BB2Notice
isNeedToSetFLAG() - Method in class bb.common.PartToAuditFlagResult
isNesedBOM() - Method in class bb.common.RecursiveBillPath
isNonEnglishAllowed() - Method in class bb.common.CompanyVO
isNotAllString(String) - Static method in class bb.common.BB2Util
isNotEmptyString(String) - Static method in class bb.common.BB2Util
isNullData() - Method in class bb.common.CustomerStatementResult
isOneGLForBatchPayment() - Method in class bb.common.CompanyVO
isOnloanControlRecorded(String) - Method in interface bb.common.box.WarehouseBox
isOnLoanItemExist(OnLoanItemPK) - Method in interface bb.common.box.WarehouseBox
isOnloanReceiverExist(String) - Method in interface bb.common.box.WarehouseBox
isOperatingEnvironment() - Method in class bb.common.InspectionReportInfoVO
isOperatingEnvironment() - Method in class bb.common.InspectionReportVO
isOperatingEnvironment() - Method in class bb.common.OperatingInstructionsVO
isOperatingInstructionsExist(String) - Method in interface bb.common.box.ManufacturingBox
isOperatingInstructionsInspectStandardExist(int) - Method in interface bb.common.box.ManufacturingBox
isOperatingInstructionsManualExist(int) - Method in interface bb.common.box.ManufacturingBox
isOperatingInstructionsTypeExist(int) - Method in interface bb.common.box.ManufacturingBox
isOperatingOutputFileTypeExist(int) - Method in interface bb.common.box.ManufacturingBox
isOrderHaveParentOrder(String, String) - Method in interface bb.common.box.WorkOrderBox
isOrderHaveSubOrders(String, String) - Method in interface bb.common.box.WorkOrderBox
isOriginalIcrRequiredWhenReceiverNa() - Method in class bb.common.OrderApprovalItemsVO
isOrphan() - Method in class bb.common.MasterWorkOrderTreeItemResult
isOverCarryPL() - Method in class bb.common.GeneralLedgerVO
isOverview() - Method in class bb.common.SGPartDocFlagResult
isParent(String) - Method in interface bb.common.box.AddressBox
isParentCompanyUnit(String) - Method in interface bb.common.box.CompanyBox
isPartDocumentExist(AllPartDocumentsPK) - Method in interface bb.common.box.DocumentBox
isPartDwfExist(PartDwfPK) - Method in interface bb.common.box.EngineeringBox
isPartDwgExist(PartDwgPK) - Method in interface bb.common.box.EngineeringBox
isPartExist(PartPK) - Method in interface bb.common.box.EngineeringBox
isPartExist() - Method in class bb.common.ProformaReceiverPackingBoxItemAgent
isPartExistent(PartPK) - Method in interface bb.common.box.EngineeringBox
isPartInspectionExist(PartInspectionPK) - Method in interface bb.common.box.QualityBox
isPartMaterialExist(PartPK) - Method in interface bb.common.box.EngineeringBox
isPartTaxExempt() - Method in class bb.common.RunningAccountOrderItemVO
isPartTypeExist(String) - Method in interface bb.common.box.CompanyBox
isPaybyVendorInvoiceTotal() - Method in class bb.common.APAuditListResult
isPermission() - Method in class bb.common.PermissionVO
isPFFinished(String) - Method in interface bb.common.box.WarehouseBox
isPfReceiverExistent(String) - Method in interface bb.common.box.PurchasingBox
isPFSOHoldByPFNumber(String) - Method in interface bb.common.box.WarehouseBox
isPhysicalWorkSheetExist(int) - Method in interface bb.common.box.WarehouseBox
isPhysicalWorkSheetPageExist(int, int) - Method in interface bb.common.box.WarehouseBox
isPicture() - Method in class bb.common.SGPartListItemResult
isPicture() - Method in class bb.common.SGPartListResult
isPoMail() - Method in class bb.common.CustomerVendorContactVO
isPoMessageExistent(String) - Method in interface bb.common.box.PurchasingBox
isPopup() - Method in class bb.common.BB2Event
isPortraitOrientation() - Method in class bb.common.LabelTemplateVO
isPosted() - Method in class bb.common.GeneralLedgerVO
isPosted() - Method in class bb.common.JounalEntryListResult
isPOSurveyReportExist(String) - Method in interface bb.common.box.QualityBox
isPosZipCodeTaxExistent(String) - Method in interface bb.common.box.CompanyBox
isPredefined() - Method in class bb.common.AccountsChartCategoryVO
isPreferred() - Method in class bb.common.PartVendorVO
isPreferred() - Method in class bb.common.ToolVendorVO
isPreferredPo() - Method in class bb.common.PartManufacturerVO
isPreferredPo() - Method in class bb.common.ToolManufacturerVO
isPreferredSo() - Method in class bb.common.PartManufacturerVO
isPreferredSo() - Method in class bb.common.ToolManufacturerVO
isPrepayApply() - Method in class bb.common.MakeAccountPayableAgent
isPrepayApply() - Method in class bb.common.MakeBillAndHoldInvoiceAgent
isPrepayApply() - Method in class bb.common.MakeInvoiceAgent
isPrintBarCodeForOrder() - Method in class bb.common.CompanyVO
isPrintInvoice() - Method in class bb.common.CustomerVendorAddressInfoVO
isPrintInvoice() - Method in class bb.common.CustomerVendorAddressVO
isPrintTemplateExist(int) - Method in interface bb.common.box.CompanyBox
isProcessInspection() - Method in class bb.common.InspectionConformanceReportVO
isProfitLossDocumentExist(String, Date, Date, Date, Date) - Method in interface bb.common.box.AccountingBox
isPublic() - Method in class bb.common.DocumentInfoAgent
isPublicDoc() - Method in class bb.common.AllPartDocumentsVO
isPublicDoc() - Method in class bb.common.LogPartDocumentVO
isPublicDoc() - Method in class bb.common.PartDocumentVO
isPublicToEvery() - Method in class bb.common.PurchaseWorkSheetVO
isPublicToEvery() - Method in class bb.common.WorkOrderWorkSheetVO
isPublicWorkSheet() - Method in class bb.common.PurchaseWorkSheetVO
isPublicWorkSheet() - Method in class bb.common.WorkOrderWorkSheetVO
isPurchaseOrderApprovalExistent(String) - Method in interface bb.common.box.ManufacturingBox
isPurchaseOrderApprovalExistent(String) - Method in interface bb.common.box.PurchasingBox
isPurchaseOrderBoilerplateExist(String) - Method in interface bb.common.box.PurchasingBox
isPurchaseOrderExistent(String) - Method in interface bb.common.box.ManufacturingBox
isPurchaseOrderExistent(String) - Method in interface bb.common.box.PurchasingBox
isPurchaseOrderInMyPrintList(String) - Method in interface bb.common.box.ManufacturingBox
isPurchaseOrderInMyPrintList(String) - Method in interface bb.common.box.PurchasingBox
isPurchaseOrderItemExistent(PurchaseOrderItemPK) - Method in interface bb.common.box.ManufacturingBox
isPurchaseOrderItemExistent(PurchaseOrderItemPK) - Method in interface bb.common.box.PurchasingBox
isPurchaseOrderUnit() - Method in class bb.common.PartUnitVO
isPurchaseWorkSheetExistent(PurchaseWorkSheetPK) - Method in interface bb.common.box.ManufacturingBox
isPurchaseWorkSheetExistent(PurchaseWorkSheetPK) - Method in interface bb.common.box.PurchasingBox
isQtMail() - Method in class bb.common.CustomerVendorContactVO
isQualityGroupExist(String, String) - Method in interface bb.common.box.QualityBox
isQuoteBoilerplateExist(String) - Method in interface bb.common.box.SalesBox
isQuoteExist(String) - Method in interface bb.common.box.SalesBox
isRead(String) - Method in class bb.common.MessageVO
isReCalcSubTotal() - Method in class bb.common.AccountsPayableVO
isReCalcTax() - Method in class bb.common.AccountsPayableVO
isReceiveAllSo() - Method in class bb.common.FinishProformaReceiverAgent
isReceiveAllWo() - Method in class bb.common.FinishProformaReceiverAgent
isReceiveNeedIr() - Method in class bb.common.CompanyVO
isReceiverExist(String) - Method in interface bb.common.box.WarehouseBox
isReceiverInMyPrintList(String) - Method in interface bb.common.box.WarehouseBox
isReceivingPOZeroCost() - Method in class bb.common.CompanyVO
isRecoil() - Method in class bb.common.CompanyVO
isRecoil() - Method in class bb.common.PartVO
isRecoil() - Method in class bb.common.PartWithOnhandsVO
isRefNAPO() - Method in class bb.common.CompanyVO
isRegulared() - Method in class bb.common.InspectionConformanceReportItemCheckVO
isRemoved() - Method in class bb.common.MessageVO
isRequestForQuoteExistent(String) - Method in interface bb.common.box.ManufacturingBox
isRequestForQuoteExistent(String) - Method in interface bb.common.box.PurchasingBox
isRequestForQuoteOPEN(String) - Method in interface bb.common.box.ManufacturingBox
isRequestForQuoteOPEN(String) - Method in interface bb.common.box.PurchasingBox
isRequireAuth() - Method in class bb.common.SmtpServerVO
isRequiredDateExpired(WorkInstructionPK, Date, Date) - Method in interface bb.common.box.WorkOrderBox
isReSend() - Method in class bb.common.AccountingInfoDocumentVO
isReturnToVendorExistent(String) - Method in interface bb.common.box.ManufacturingBox
isReturnToVendorExistent(String) - Method in interface bb.common.box.PurchasingBox
isReviewed() - Method in class bb.common.EngineeringSharingImportLogVO
isRfqMail() - Method in class bb.common.CustomerVendorContactVO
isRfqMessageExistent(String) - Method in interface bb.common.box.PurchasingBox
isRFQMessageItemExist(RequestForQuoteItemPK) - Method in interface bb.common.box.PurchasingBox
isRole(String) - Method in interface bb.common.box.SecurityBox
isRoleExist(String) - Method in interface bb.common.box.SecurityBox
isRootBOM() - Method in class bb.common.BOMCanAssyAgent
isRoundToIntForSetup() - Method in class bb.common.BillItemVO
isRrmaExist(String) - Method in interface bb.common.box.SalesBox
isRrmaItemExist(RequestForRMAItemPK) - Method in interface bb.common.box.SalesBox
isRunning() - Method in class bb.common.WCLoadDetailResult
isSaleableForNewPart() - Method in class bb.common.CompanyVO
isSalesOrderAndSoItemOpen(SalesOrderItemPK) - Method in interface bb.common.box.SalesBox
isSalesOrderBoilerplateExist(String) - Method in interface bb.common.box.SalesBox
isSalesOrderControlRecorded(String) - Method in interface bb.common.box.SalesBox
isSalesOrderExist(String) - Method in interface bb.common.box.SalesBox
isSalesOrderInMyPrintList(String) - Method in interface bb.common.box.SalesBox
isSalesOrderItemExist(SalesOrderItemPK) - Method in interface bb.common.box.SalesBox
isSalesOrderUnit() - Method in class bb.common.PartUnitVO
isSaveToFtp() - Method in class bb.common.DocumentServerVO
isSaveToFtp() - Method in class bb.common.DwfUploadSettingsVO
isSaveToFtp() - Method in class bb.common.DwgUploadSettingsVO
isSaveToFtp() - Method in class bb.common.MiscDocumentSettingVO
isSendNotice() - Method in class bb.common.TaskVO
isSeparateCostBetweenWarehouse() - Method in class bb.common.CompanyVO
isSeparateCV() - Method in class bb.common.CompanyVO
isSerialNumberExist(String) - Method in interface bb.common.box.QualityBox
isSetupInventoryForNewPart() - Method in class bb.common.CompanyVO
isSgClientProgramUserExistent(String) - Method in interface bb.common.box.AddressBox
isShipListOwnerExistent(String) - Method in interface bb.common.box.PlanningBox
isShipperExist(String) - Method in interface bb.common.box.WarehouseBox
isShipperInMyPrintList(String) - Method in interface bb.common.box.WarehouseBox
isShowNotReviewOrder() - Method in class bb.common.MrpReportAgent
isShowNumberTailZero() - Method in class bb.common.CompanyVO
isShowOnDemand() - Method in class bb.common.MrpReportAgent
isShowOnOrder() - Method in class bb.common.MrpReportAgent
isShowOrgAndLevelForPart() - Method in class bb.common.CompanyVO
isShowOriginal() - Method in class bb.common.GLInfoByPeriodResult
isShowTimeZone() - Method in class bb.common.CompanyVO
isShowZeroMustOrder() - Method in class bb.common.MrpReportAgent
isSoMail() - Method in class bb.common.CustomerVendorContactVO
isStrikeThrough() - Method in class bb.common.LabelTemplateItemVO
isSubcompanyExists(String) - Method in interface bb.common.box.CompanyBox
isSuccess() - Method in class bb.common.LogTaskVO
ISSUE_ITEM_AGENT - Static variable in class bb.common.BizTarget
ISSUED_QTY_IS_OVER_THAN_WO_ITEM_PART_DETAIL_QTY - Static variable in class bb.common.BIZReason
ISSUEDATE - Static variable in class bb.common.Constant.DateType
IssuedFromOrderItem - Class in bb.common
IssuedFromOrderItem() - Constructor for class bb.common.IssuedFromOrderItem
IssueItemAgent - Class in bb.common
IssueItemAgent() - Constructor for class bb.common.IssueItemAgent
IssueItemDetailAgent - Class in bb.common
IssueItemDetailAgent() - Constructor for class bb.common.IssueItemDetailAgent
issuePartsToDisassembleWorkOrder(IssueItemAgent) - Method in interface bb.common.box.WarehouseBox
issuePartsToDisassembleWorkOrder(ArrayList) - Method in interface bb.common.box.WarehouseBox
issuePartsToWorkOrderItem(IssueItemAgent) - Method in interface bb.common.box.WarehouseBox
issuePartsToWorkOrderItem(ArrayList) - Method in interface bb.common.box.WarehouseBox
ISSUING_DATE - Static variable in class bb.common.LabelTemplateConstant
ISSUING_DESCRIPTION - Static variable in class bb.common.LabelTemplateConstant
ISSUING_DWO - Static variable in class bb.common.Constant.TrackingNumberType
ISSUING_NCR - Static variable in class bb.common.Constant.TrackingNumberType
ISSUING_OPERATOR - Static variable in class bb.common.LabelTemplateConstant
ISSUING_PART_NUMBER - Static variable in class bb.common.LabelTemplateConstant
ISSUING_PROJECT - Static variable in class bb.common.LabelTemplateConstant
ISSUING_QTY_ISSUED - Static variable in class bb.common.LabelTemplateConstant
ISSUING_RELATEDDOC - Static variable in class bb.common.LabelTemplateConstant
ISSUING_UNIT - Static variable in class bb.common.LabelTemplateConstant
ISSUING_WO - Static variable in class bb.common.Constant.TrackingNumberType
ISSUING_WO_NUMBER - Static variable in class bb.common.LabelTemplateConstant
IssuingItemResult - Class in bb.common
IssuingItemResult() - Constructor for class bb.common.IssuingItemResult
IssuingResult - Class in bb.common
IssuingResult() - Constructor for class bb.common.IssuingResult
isSuppressPartOnorderEqualOrLargeOndemand() - Method in class bb.common.MrpReportAgent
isSystem() - Method in class bb.common.RoleListResult
isSystem() - Method in class bb.common.RoleVO
isSystemRole(String) - Method in interface bb.common.box.SecurityBox
isSystemUserGroup(String) - Method in interface bb.common.box.CompanyBox
isTaskExist(Long) - Method in interface bb.common.box.CompanyBox
isTaxExempt() - Method in class bb.common.PartVO
isTaxExempt() - Method in class bb.common.ZipcodeTotalsResult
isTaxRateExist(String, String) - Method in interface bb.common.box.CompanyBox
isTechSheet() - Method in class bb.common.SGPartDocFlagResult
isTempWorker() - Method in class bb.common.EmployeeCardVO
isToolExistent(PartPK) - Method in interface bb.common.box.ManufacturingBox
isToolListExistent(BillPK) - Method in interface bb.common.box.ManufacturingBox
isTraceable() - Method in class bb.common.DisassembleWorkOrderIssuingItemResult
isTraceable() - Method in class bb.common.IssuingItemResult
isTraceable() - Method in class bb.common.ReceivingItemResult
isTraceable() - Method in class bb.common.ShippingItemResult
isTraceableCategoriesIDExist(String) - Method in interface bb.common.box.EngineeringBox
isTraceableCategoriesIDUsed(String) - Method in interface bb.common.box.EngineeringBox
isTraceableSpecsIDExist(Short) - Method in interface bb.common.box.EngineeringBox
isTraceableSpecsIDUsed(Short) - Method in interface bb.common.box.EngineeringBox
isTransactionExist(String) - Method in interface bb.common.box.AccountingBox
isTransactionTypeExist(String) - Method in interface bb.common.box.AccountingBox
isTransferOrderApprovalExist(String) - Method in interface bb.common.box.WarehouseBox
isTroubleshooting() - Method in class bb.common.SGPartDocFlagResult
isUnbilled() - Method in class bb.common.CompanyVO
isUnderline() - Method in class bb.common.LabelTemplateItemVO
isUnitExist(String) - Method in interface bb.common.box.EngineeringBox
isUseAccountPeriod() - Method in class bb.common.FiscalYearSettingsVO
isUseApprovalGl() - Method in class bb.common.AccountingConfigurationVO
isUseAutoApprovalGl() - Method in class bb.common.AccountingConfigurationVO
isUseAutoApprovalGL() - Method in class bb.common.PointOfSaleVO
isUseAutoCreateOrder() - Method in class bb.common.PointOfSaleVO
isUseAvgCostToRollUp() - Method in class bb.common.RollUpBomStdCostWorkSheetVO
isUseBackflush() - Method in class bb.common.CustomerVendorAddressInfoVO
isUseBackflush() - Method in class bb.common.CustomerVendorAddressVO
isUseBackflush() - Method in class bb.common.PartVO
isUseBackflush() - Method in class bb.common.PartWithOnhandsVO
isUseBomApproval() - Method in class bb.common.CompanyVO
isUseBranchWarehouse() - Method in class bb.common.CompanyVO
isUseCarryOverPL() - Method in class bb.common.AccountingConfigurationVO
isUseCloseEntry() - Method in class bb.common.AccountingConfigurationVO
isUseCTaxRate() - Method in class bb.common.CustomerVendorAddressVO
isUseEcStartWithYear() - Method in class bb.common.CompanyVO
isUseEngGroupUser() - Method in class bb.common.CompanyVO
isUseIncludeTaxCostforPO() - Method in class bb.common.CompanyVO
isUseJournalAccount() - Method in class bb.common.AccountingConfigurationVO
isUseMultiQtyforApplying() - Method in class bb.common.CompanyVO
isUseOperationScrap() - Method in class bb.common.CompanyVO
isUseOrderChangeApproval() - Method in class bb.common.CompanyVO
isUsePOSReceive() - Method in class bb.common.PointOfSaleVO
isUsePostGl() - Method in class bb.common.AccountingConfigurationVO
isUsePriceWithTax() - Method in class bb.common.PurchaseOrderItemVO
isUsePriceWithTax() - Method in class bb.common.SalesOrderItemVO
isUsePriceWithTaxAsListPriceInVCP() - Method in class bb.common.CompanyVO
isUsePriceWithTaxDefault() - Method in class bb.common.CompanyVO
isUserGroupExist(String) - Method in interface bb.common.box.CompanyBox
isUserRoleExist(String, String) - Method in interface bb.common.box.SecurityBox
isUseTaxReport() - Method in class bb.common.AccountingConfigurationVO
isUseUppercaseSystemUserName() - Method in class bb.common.CompanyVO
isUseVTaxRate() - Method in class bb.common.CustomerVendorAddressVO
isUseWip() - Method in class bb.common.DisassembleWorkOrderVO
isUseWip() - Method in class bb.common.WorkOrderVO
isUseWorkOrderCostControl() - Method in class bb.common.CompanyVO
isUseZipCode() - Method in class bb.common.AccountingSettingsVO
isValuationStorage() - Method in class bb.common.CompanyVO
isVendor(String) - Method in interface bb.common.box.AddressBox
isVendorContractPriceExistent(String) - Method in interface bb.common.box.PurchasingBox
isVendorContractPriceItemExistent(VendorContractPriceItemPK) - Method in interface bb.common.box.PurchasingBox
isVendorContractPriceVendorExistent(VendorContractPriceVendorPK) - Method in interface bb.common.box.PurchasingBox
isVendorExist(String) - Method in interface bb.common.box.AddressBox
isVendorGroupUserExistent(String) - Method in interface bb.common.box.AddressBox
isVendorPartExistent(VendorPartPK) - Method in interface bb.common.box.WarehouseBox
isVendorPicked() - Method in class bb.common.RtvShipperInfoVO
isVendorPicked() - Method in class bb.common.RtvShipperVO
isVendPartExist() - Method in class bb.common.ProformaReceiverPackingBoxItemAgent
isVisibleInReport() - Method in class bb.common.AccountsChartCategoryVO
isWarehouseExist(String) - Method in interface bb.common.box.WarehouseBox
isWarehouseUsing(String) - Method in interface bb.common.box.WarehouseBox
isWarning() - Method in class bb.common.EquipmentListResult
isWarning() - Method in class bb.common.PartOnhandResult
isWarningWhenTwoPartInOneLocation() - Method in class bb.common.CompanyVO
isWorkCalendarExist(Long) - Method in interface bb.common.box.ManufacturingBox
isWorkCenterExist(String) - Method in interface bb.common.box.ManufacturingBox
isWorkFlowExist(String) - Method in interface bb.common.box.CompanyBox
isWorking() - Method in class bb.common.StaffWorkingInformationResult
isWorkInstructionApprovalExistent(String) - Method in interface bb.common.box.ManufacturingBox
isWorkInstructionExist(WorkInstructionPK) - Method in interface bb.common.box.ManufacturingBox
isWorkInstructionExist(WorkOrderItemPK, WorkInstructionPK) - Method in interface bb.common.box.WorkOrderBox
isWorkOrderApprovalExistent(String) - Method in interface bb.common.box.WorkOrderBox
isWorkOrderBoilerplateExist(String) - Method in interface bb.common.box.WorkOrderBox
isWorkOrderExist(String) - Method in interface bb.common.box.WorkOrderBox
isWorkOrderItemExist(WorkOrderItemPK) - Method in interface bb.common.box.WorkOrderBox
isWorkOrderWorkInstructionExist(WorkOrderWorkInstructionPK) - Method in interface bb.common.box.WorkOrderBox
isWorkOrderWorkInstructionSequencesFinished(WorkOrderWorkInstructionSequencePK) - Method in interface bb.common.box.WorkOrderBox
isWorkOrderWorkSheetExistent(WorkOrderWorkSheetPK) - Method in interface bb.common.box.WorkOrderBox
isZerolocation() - Method in class bb.common.TakeCycleCountAgent
isZipCodeExist(String) - Method in interface bb.common.box.CompanyBox
IT_HAS_NO_GL_TO_OVER_CARRY - Static variable in class bb.common.BIZReason
ITEM_BARCODE - Static variable in class bb.common.LabelTemplateConstant
ITEM_LABEL - Static variable in class bb.common.LabelTemplateConstant
ITEM_LINE - Static variable in class bb.common.LabelTemplateConstant
ITEM_PROPERTY - Static variable in class bb.common.LabelTemplateConstant
ITEM_QR_BARCODE - Static variable in class bb.common.LabelTemplateConstant
ITEM_QTY_IS_NOT_RIGHT - Static variable in class bb.common.BIZReason
ITEM_STATUS - Static variable in class bb.common.BizTarget
ITEM_STATUS_IS_FORBIDDEN_TO_CHANGE_CURRENTLY - Static variable in class bb.common.BIZReason
ITEM_TABLE - Static variable in class bb.common.LabelTemplateConstant
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M N O P Q R S T U V W X Y Z


ImportContractPriceData

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ImportContractPriceData

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ImportContractPriceData
All Implemented Interfaces:
java.io.Serializable
public class ImportContractPriceData
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ImportContractPriceData()
ImportContractPriceData(java.lang.String contractPrice, java.util.HashSet<ContractPriceItemVO> items, java.util.HashSet<ContractPriceCustomerVO> customers)
Method Summary
java.lang.String | getContractPrice()
java.util.HashSet<ContractPriceCustomerVO> | getCustomers()
java.util.HashSet<ContractPriceItemVO> | getItems()
void | setContractPrice(java.lang.String contractPrice)
void | setCustomers(java.util.HashSet<ContractPriceCustomerVO> customers)
void | setItems(java.util.HashSet<ContractPriceItemVO> items)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ImportContractPriceData

public ImportContractPriceData()

ImportContractPriceData

public ImportContractPriceData(java.lang.String contractPrice,
                               java.util.HashSet<ContractPriceItemVO> items,
                               java.util.HashSet<ContractPriceCustomerVO> customers)
Method Detail

getContractPrice

public java.lang.String getContractPrice()

setContractPrice

public void setContractPrice(java.lang.String contractPrice)

getItems

public java.util.HashSet<ContractPriceItemVO> getItems()

setItems

public void setItems(java.util.HashSet<ContractPriceItemVO> items)

getCustomers

public java.util.HashSet<ContractPriceCustomerVO> getCustomers()

setCustomers

public void setCustomers(java.util.HashSet<ContractPriceCustomerVO> customers)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ImportDataVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ImportDataVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ImportDataVO
All Implemented Interfaces:
java.io.Serializable
public class ImportDataVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String ORDER_BY_COLUMN_NUMBER
Constructor Summary
ImportDataVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Object | getData()
java.lang.String | getErrorMsg()
int | getIi()
int | hashCode()
void | setData(java.lang.Object data)
void | setErrorMsg(java.lang.String errorMsg)
void | setIi(int ii)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_COLUMN_NUMBER

public static final java.lang.String ORDER_BY_COLUMN_NUMBER
See Also:
Constant Field Values
Constructor Detail

ImportDataVO

public ImportDataVO()
Method Detail

setIi

public void setIi(int ii)

getIi

public int getIi()

setData

public void setData(java.lang.Object data)

getData

public java.lang.Object getData()

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getErrorMsg

public java.lang.String getErrorMsg()

setErrorMsg

public void setErrorMsg(java.lang.String errorMsg)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IncomeByMonthChartResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class IncomeByMonthChartResult

java.lang.Object
    extended by  bb.common.IncomeByMonthChartResult
All Implemented Interfaces:
java.io.Serializable
public class IncomeByMonthChartResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
IncomeByMonthChartResult()
Method Summary
java.util.Map<java.util.Date,java.math.BigDecimal> | getInfoByMonthMap()
java.math.BigDecimal | getPastDueAmount()
java.math.BigDecimal | getTotalAmount()
void | setInfoByMonthMap(java.util.Map<java.util.Date,java.math.BigDecimal> infoByMonthMap)
void | setPastDueAmount(java.math.BigDecimal pastDueAmount)
void | setTotalAmount(java.math.BigDecimal totalAmount)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

IncomeByMonthChartResult

public IncomeByMonthChartResult()
Method Detail

getInfoByMonthMap

public java.util.Map<java.util.Date,java.math.BigDecimal> getInfoByMonthMap()

setInfoByMonthMap

public void setInfoByMonthMap(java.util.Map<java.util.Date,java.math.BigDecimal> infoByMonthMap)

getPastDueAmount

public java.math.BigDecimal getPastDueAmount()

setPastDueAmount

public void setPastDueAmount(java.math.BigDecimal pastDueAmount)

getTotalAmount

public java.math.BigDecimal getTotalAmount()

setTotalAmount

public void setTotalAmount(java.math.BigDecimal totalAmount)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IncotermVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class IncotermVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.IncotermVO
All Implemented Interfaces:
java.io.Serializable
public class IncotermVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_ID
static java.lang.String | ORDER_BY_PLACE
Constructor Summary
IncotermVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDescription()
java.lang.String | getId()
java.lang.String | getPlace()
int | hashCode()
void | setDescription(java.lang.String description)
void | setId(java.lang.String id)
void | setPlace(java.lang.String place)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ID

public static final java.lang.String ORDER_BY_ID
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_PLACE

public static final java.lang.String ORDER_BY_PLACE
See Also:
Constant Field Values
Constructor Detail

IncotermVO

public IncotermVO()
Method Detail

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getPlace

public java.lang.String getPlace()

setPlace

public void setPlace(java.lang.String place)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InfoByFiscalChartResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InfoByFiscalChartResult

java.lang.Object
    extended by  bb.common.InfoByFiscalChartResult
All Implemented Interfaces:
java.io.Serializable
public class InfoByFiscalChartResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
InfoByFiscalChartResult()
Method Summary
java.util.Map<java.lang.String,java.util.HashMap<java.util.Date,java.math.BigDecimal>> | getInfoByMonthMap()
java.util.Map<java.lang.String,java.math.BigDecimal> | getInfoTotalMap()
void | setInfoByMonthMap(java.util.Map<java.lang.String,java.util.HashMap<java.util.Date,java.math.BigDecimal>> infoByMonthMap)
void | setInfoTotalMap(java.util.Map<java.lang.String,java.math.BigDecimal> infoTotalMap)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InfoByFiscalChartResult

public InfoByFiscalChartResult()
Method Detail

getInfoTotalMap

public java.util.Map<java.lang.String,java.math.BigDecimal> getInfoTotalMap()

setInfoTotalMap

public void setInfoTotalMap(java.util.Map<java.lang.String,java.math.BigDecimal> infoTotalMap)

getInfoByMonthMap

public java.util.Map<java.lang.String,java.util.HashMap<java.util.Date,java.math.BigDecimal>> getInfoByMonthMap()

setInfoByMonthMap

public void setInfoByMonthMap(java.util.Map<java.lang.String,java.util.HashMap<java.util.Date,java.math.BigDecimal>> infoByMonthMap)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InfoByMonthChartResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InfoByMonthChartResult

java.lang.Object
    extended by  bb.common.InfoByMonthChartResult
All Implemented Interfaces:
java.io.Serializable
public class InfoByMonthChartResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
InfoByMonthChartResult()
Method Summary
java.util.Map<java.lang.String,java.util.HashMap<java.util.Date,InfoByMonthResult>> | getInfoByMonthMap()
java.util.Map<java.lang.String,java.math.BigDecimal> | getInfoTotalMap()
void | setInfoByMonthMap(java.util.Map<java.lang.String,java.util.HashMap<java.util.Date,InfoByMonthResult>> infoByMonthMap)
void | setInfoTotalMap(java.util.Map<java.lang.String,java.math.BigDecimal> infoTotalMap)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InfoByMonthChartResult

public InfoByMonthChartResult()
Method Detail

getInfoByMonthMap

public java.util.Map<java.lang.String,java.util.HashMap<java.util.Date,InfoByMonthResult>> getInfoByMonthMap()

setInfoByMonthMap

public void setInfoByMonthMap(java.util.Map<java.lang.String,java.util.HashMap<java.util.Date,InfoByMonthResult>> infoByMonthMap)

getInfoTotalMap

public java.util.Map<java.lang.String,java.math.BigDecimal> getInfoTotalMap()

setInfoTotalMap

public void setInfoTotalMap(java.util.Map<java.lang.String,java.math.BigDecimal> infoTotalMap)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InfoByMonthResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InfoByMonthResult

java.lang.Object
    extended by  bb.common.InfoByMonthResult
All Implemented Interfaces:
java.io.Serializable
public class InfoByMonthResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
InfoByMonthResult()
Method Summary
java.lang.Integer | getItemTotalCount()
java.lang.Integer | getTotalCount()
java.math.BigDecimal | getTotalMoney()
void | setItemTotalCount(java.lang.Integer itemTotalCount)
void | setTotalCount(java.lang.Integer totalCount)
void | setTotalMoney(java.math.BigDecimal totalMoney)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InfoByMonthResult

public InfoByMonthResult()
Method Detail

getItemTotalCount

public java.lang.Integer getItemTotalCount()

setItemTotalCount

public void setItemTotalCount(java.lang.Integer itemTotalCount)

getTotalCount

public java.lang.Integer getTotalCount()

setTotalCount

public void setTotalCount(java.lang.Integer totalCount)

getTotalMoney

public java.math.BigDecimal getTotalMoney()

setTotalMoney

public void setTotalMoney(java.math.BigDecimal totalMoney)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InSipAudittListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InSipAudittListResult

java.lang.Object
    extended by  bb.common.InSipAudittListResult
All Implemented Interfaces:
java.io.Serializable
public class InSipAudittListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
InSipAudittListResult()
Method Summary
java.math.BigDecimal | getAvgCost()
java.math.BigDecimal | getOnhand()
java.lang.String | getPartDescription()
java.lang.String | getPartFrom()
PartPK | getPk()
java.math.BigDecimal | getStdCost()
java.math.BigDecimal | getTotInSIPQty()
java.math.BigDecimal | getTotPFSIPQty()
java.math.BigDecimal | getTotSoSIPQty()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setOnhand(java.math.BigDecimal onhand)
void | setPartDescription(java.lang.String partDescription)
void | setPartFrom(java.lang.String partFrom)
void | setPk(PartPK pk)
void | setStdCost(java.math.BigDecimal stdCost)
void | setTotInSIPQty(java.math.BigDecimal totInSIPQty)
void | setTotPFSIPQty(java.math.BigDecimal totPFSIPQty)
void | setTotSoSIPQty(java.math.BigDecimal totSoSIPQty)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InSipAudittListResult

public InSipAudittListResult()
Method Detail

getPartDescription

public java.lang.String getPartDescription()

setPartDescription

public void setPartDescription(java.lang.String partDescription)

getAvgCost

public java.math.BigDecimal getAvgCost()

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

getOnhand

public java.math.BigDecimal getOnhand()

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getTotInSIPQty

public java.math.BigDecimal getTotInSIPQty()

setTotInSIPQty

public void setTotInSIPQty(java.math.BigDecimal totInSIPQty)

getTotPFSIPQty

public java.math.BigDecimal getTotPFSIPQty()

setTotPFSIPQty

public void setTotPFSIPQty(java.math.BigDecimal totPFSIPQty)

getTotSoSIPQty

public java.math.BigDecimal getTotSoSIPQty()

setTotSoSIPQty

public void setTotSoSIPQty(java.math.BigDecimal totSoSIPQty)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPk

public PartPK getPk()

setPk

public void setPk(PartPK pk)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InspectionConformanceReportItemCheckPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InspectionConformanceReportItemCheckPK

java.lang.Object
    extended by  bb.common.InspectionConformanceReportItemCheckPK
All Implemented Interfaces:
java.io.Serializable
public class InspectionConformanceReportItemCheckPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
InspectionConformanceReportItemCheckPK()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getIcrItemNumber()
java.lang.String | getIcrNumber()
java.lang.String | getItemNumber()
int | hashCode()
void | setIcrItemNumber(java.lang.String icrItemNumber)
void | setIcrNumber(java.lang.String icrNumber)
void | setItemNumber(java.lang.String itemNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

InspectionConformanceReportItemCheckPK

public InspectionConformanceReportItemCheckPK()
Method Detail

getIcrNumber

public java.lang.String getIcrNumber()

setIcrNumber

public void setIcrNumber(java.lang.String icrNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getItemNumber

public java.lang.String getItemNumber()

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

getIcrItemNumber

public java.lang.String getIcrItemNumber()

setIcrItemNumber

public void setIcrItemNumber(java.lang.String icrItemNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InspectionConformanceReportItemCheckVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InspectionConformanceReportItemCheckVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.InspectionConformanceReportItemCheckVO
All Implemented Interfaces:
java.io.Serializable
public class InspectionConformanceReportItemCheckVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
InspectionConformanceReportItemCheckVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getActualResult()
java.lang.String | getInspectProject()
InspectionConformanceReportItemCheckPK | getPk()
java.lang.String | getTechnolgyStandard()
java.lang.String | getUnit()
int | hashCode()
boolean | isRegulared()
void | setActualResult(java.lang.String actualResult)
void | setInspectProject(java.lang.String inspectProject)
void | setPk(InspectionConformanceReportItemCheckPK pk)
void | setRegulared(boolean regulared)
void | setTechnolgyStandard(java.lang.String technolgyStandard)
void | setUnit(java.lang.String unit)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

InspectionConformanceReportItemCheckVO

public InspectionConformanceReportItemCheckVO()
Method Detail

getActualResult

public java.lang.String getActualResult()

setActualResult

public void setActualResult(java.lang.String actualResult)

getInspectProject

public java.lang.String getInspectProject()

setInspectProject

public void setInspectProject(java.lang.String inspectProject)

getPk

public InspectionConformanceReportItemCheckPK getPk()

setPk

public void setPk(InspectionConformanceReportItemCheckPK pk)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

isRegulared

public boolean isRegulared()

setRegulared

public void setRegulared(boolean regulared)

getTechnolgyStandard

public java.lang.String getTechnolgyStandard()

setTechnolgyStandard

public void setTechnolgyStandard(java.lang.String technolgyStandard)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InspectionConformanceReportItemInfo

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InspectionConformanceReportItemInfo

java.lang.Object
    extended by  bb.common.InspectionConformanceReportItemInfo
All Implemented Interfaces:
java.io.Serializable
public class InspectionConformanceReportItemInfo
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
InspectionConformanceReportItemInfo()
Method Summary
InspectionConformanceReportItemVO | getItem()
java.lang.String | getLastChangeUser()
java.lang.String | getPurchaseOrder()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
java.lang.String | getWorkOrder()
void | setItem(InspectionConformanceReportItemVO item)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setPurchaseOrder(java.lang.String purchaseOrder)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
void | setWorkOrder(java.lang.String workOrder)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InspectionConformanceReportItemInfo

public InspectionConformanceReportItemInfo()
Method Detail

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getPurchaseOrder

public java.lang.String getPurchaseOrder()

setPurchaseOrder

public void setPurchaseOrder(java.lang.String purchaseOrder)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getVendorName

public java.lang.String getVendorName()

setVendorName

public void setVendorName(java.lang.String vendorName)

getWorkOrder

public java.lang.String getWorkOrder()

setWorkOrder

public void setWorkOrder(java.lang.String workOrder)

getItem

public InspectionConformanceReportItemVO getItem()

setItem

public void setItem(InspectionConformanceReportItemVO item)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InspectionConformanceReportItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InspectionConformanceReportItemPK

java.lang.Object
    extended by  bb.common.InspectionConformanceReportItemPK
All Implemented Interfaces:
java.io.Serializable
public class InspectionConformanceReportItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
InspectionConformanceReportItemPK()
InspectionConformanceReportItemPK(java.lang.String icrNumber, java.lang.String icrItemNumber)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getIcrItemNumber()
java.lang.String | getIcrNumber()
int | hashCode()
void | setIcrItemNumber(java.lang.String icrItemNumber)
void | setIcrNumber(java.lang.String icrNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

InspectionConformanceReportItemPK

public InspectionConformanceReportItemPK()

InspectionConformanceReportItemPK

public InspectionConformanceReportItemPK(java.lang.String icrNumber,
                                         java.lang.String icrItemNumber)
Method Detail

getIcrNumber

public java.lang.String getIcrNumber()

setIcrNumber

public void setIcrNumber(java.lang.String icrNumber)

getIcrItemNumber

public java.lang.String getIcrItemNumber()

setIcrItemNumber

public void setIcrItemNumber(java.lang.String icrItemNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InspectionConformanceReportItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InspectionConformanceReportItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.InspectionConformanceReportItemVO
All Implemented Interfaces:
java.io.Serializable
public class InspectionConformanceReportItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
InspectionConformanceReportItemVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.util.Date | getDateCheck()
java.util.Set | getIcrItemChecks()
java.lang.String | getInspector()
java.lang.String | getPartDescription()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartRevision()
java.lang.String | getPartType()
InspectionConformanceReportItemPK | getPk()
java.math.BigDecimal | getQtyCheck()
java.math.BigDecimal | getQtyQualified()
java.math.BigDecimal | getQtyReject()
java.util.Set | getRefDocOnes()
java.util.Set | getRefDocTwoes()
java.lang.String | getStatus()
int | hashCode()
void | setComments(java.lang.String comments)
void | setDateCheck(java.util.Date dateCheck)
void | setIcrItemChecks(java.util.Set icrItemChecks)
void | setInspector(java.lang.String inspector)
void | setPartDescription(java.lang.String partDescription)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartRevision(java.lang.String partRevision)
void | setPartType(java.lang.String partType)
void | setPk(InspectionConformanceReportItemPK pk)
void | setQtyCheck(java.math.BigDecimal qtyCheck)
void | setQtyQualified(java.math.BigDecimal qtyQualified)
void | setQtyReject(java.math.BigDecimal qtyReject)
void | setRefDocOnes(java.util.Set refDocOnes)
void | setRefDocTwoes(java.util.Set refDocTwoes)
void | setStatus(java.lang.String status)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

InspectionConformanceReportItemVO

public InspectionConformanceReportItemVO()
default constructor

Method Detail

getQtyReject

public java.math.BigDecimal getQtyReject()

setQtyReject

public void setQtyReject(java.math.BigDecimal qtyReject)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartRevision

public java.lang.String getPartRevision()

setPartRevision

public void setPartRevision(java.lang.String partRevision)

getPartDescription

public java.lang.String getPartDescription()

setPartDescription

public void setPartDescription(java.lang.String partDescription)

getQtyCheck

public java.math.BigDecimal getQtyCheck()

setQtyCheck

public void setQtyCheck(java.math.BigDecimal qtyCheck)

getQtyQualified

public java.math.BigDecimal getQtyQualified()

setQtyQualified

public void setQtyQualified(java.math.BigDecimal qtyQualified)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getPk

public InspectionConformanceReportItemPK getPk()

setPk

public void setPk(InspectionConformanceReportItemPK pk)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getDateCheck

public java.util.Date getDateCheck()

setDateCheck

public void setDateCheck(java.util.Date dateCheck)

getInspector

public java.lang.String getInspector()

setInspector

public void setInspector(java.lang.String inspector)

getRefDocOnes

public java.util.Set getRefDocOnes()

setRefDocOnes

public void setRefDocOnes(java.util.Set refDocOnes)

getRefDocTwoes

public java.util.Set getRefDocTwoes()

setRefDocTwoes

public void setRefDocTwoes(java.util.Set refDocTwoes)

getIcrItemChecks

public java.util.Set getIcrItemChecks()

setIcrItemChecks

public void setIcrItemChecks(java.util.Set icrItemChecks)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InspectionConformanceReportVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InspectionConformanceReportVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.InspectionConformanceReportVO
All Implemented Interfaces:
java.io.Serializable
public class InspectionConformanceReportVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ADATE
static java.lang.String | ORDER_BY_CLOSEDOUTDATE
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_ICRNUMBER
static java.lang.String | ORDER_BY_LASTCHANGEDATE
static java.lang.String | ORDER_BY_LASTCHANGEUSER
static java.lang.String | ORDER_BY_ORIGIN
static java.lang.String | ORDER_BY_PURCHASEORDER
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_WORKORDER
Constructor Summary
InspectionConformanceReportVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.util.Date | getClosedOutDate()
java.lang.String | getComments()
java.util.Date | getIcrDate()
java.util.Set<OrderDocumentVO> | getIcrDocuments()
java.util.Set | getIcrItems()
java.lang.String | getIcrNumber()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getOrigin()
java.lang.String | getPurchaseOrder()
java.lang.String | getStatus()
java.lang.String | getTransferShipperNumber()
CustomerVendorAddressInfoVO | getVendorAddressInfo()
java.lang.String | getVendorId()
java.lang.Integer | getVersion()
java.lang.String | getWorkOrder()
int | hashCode()
boolean | isProcessInspection()
void | setAdate(java.util.Date adate)
void | setClosedOutDate(java.util.Date closedOutDate)
void | setComments(java.lang.String comments)
void | setIcrDate(java.util.Date icrDate)
void | setIcrDocuments(java.util.Set<OrderDocumentVO> icrDocuments)
void | setIcrItems(java.util.Set icrItems)
void | setIcrNumber(java.lang.String icrNumber)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setOrigin(java.lang.String origin)
void | setProcessInspection(boolean processInspection)
void | setPurchaseOrder(java.lang.String purchaseOrder)
void | setStatus(java.lang.String status)
void | setTransferShipperNumber(java.lang.String transferShipperNumber)
void | setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)
void | setVendorId(java.lang.String vendorId)
void | setVersion(java.lang.Integer version)
void | setWorkOrder(java.lang.String workOrder)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ICRNUMBER

public static final java.lang.String ORDER_BY_ICRNUMBER
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEUSER

public static final java.lang.String ORDER_BY_LASTCHANGEUSER
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEDATE

public static final java.lang.String ORDER_BY_LASTCHANGEDATE
See Also:
Constant Field Values

ORDER_BY_ADATE

public static final java.lang.String ORDER_BY_ADATE
See Also:
Constant Field Values

ORDER_BY_ORIGIN

public static final java.lang.String ORDER_BY_ORIGIN
See Also:
Constant Field Values

ORDER_BY_PURCHASEORDER

public static final java.lang.String ORDER_BY_PURCHASEORDER
See Also:
Constant Field Values

ORDER_BY_WORKORDER

public static final java.lang.String ORDER_BY_WORKORDER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_CLOSEDOUTDATE

public static final java.lang.String ORDER_BY_CLOSEDOUTDATE
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values
Constructor Detail

InspectionConformanceReportVO

public InspectionConformanceReportVO()
default constructor

Method Detail

getIcrNumber

public java.lang.String getIcrNumber()

setIcrNumber

public void setIcrNumber(java.lang.String icrNumber)

getPurchaseOrder

public java.lang.String getPurchaseOrder()

setPurchaseOrder

public void setPurchaseOrder(java.lang.String purchaseOrder)

getWorkOrder

public java.lang.String getWorkOrder()

setWorkOrder

public void setWorkOrder(java.lang.String workOrder)

getTransferShipperNumber

public java.lang.String getTransferShipperNumber()

setTransferShipperNumber

public void setTransferShipperNumber(java.lang.String transferShipperNumber)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getVersion

public java.lang.Integer getVersion()

setVersion

public void setVersion(java.lang.Integer version)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getClosedOutDate

public java.util.Date getClosedOutDate()

setClosedOutDate

public void setClosedOutDate(java.util.Date closedOutDate)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getVendorAddressInfo

public CustomerVendorAddressInfoVO getVendorAddressInfo()

setVendorAddressInfo

public void setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)

getIcrItems

public java.util.Set getIcrItems()

setIcrItems

public void setIcrItems(java.util.Set icrItems)

getIcrDate

public java.util.Date getIcrDate()

setIcrDate

public void setIcrDate(java.util.Date icrDate)

getIcrDocuments

public java.util.Set<OrderDocumentVO> getIcrDocuments()

setIcrDocuments

public void setIcrDocuments(java.util.Set<OrderDocumentVO> icrDocuments)

isProcessInspection

public boolean isProcessInspection()

setProcessInspection

public void setProcessInspection(boolean processInspection)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InspectionItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InspectionItemPK

java.lang.Object
    extended by  bb.common.InspectionItemPK
All Implemented Interfaces:
java.io.Serializable
public class InspectionItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
InspectionItemPK()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getItemNumber()
java.lang.Integer | getOperatingInstructionsTypeId()
int | hashCode()
void | setItemNumber(java.lang.String itemNumber)
void | setOperatingInstructionsTypeId(java.lang.Integer operatingInstructionsTypeId)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

InspectionItemPK

public InspectionItemPK()
Method Detail

getItemNumber

public java.lang.String getItemNumber()

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

getOperatingInstructionsTypeId

public java.lang.Integer getOperatingInstructionsTypeId()

setOperatingInstructionsTypeId

public void setOperatingInstructionsTypeId(java.lang.Integer operatingInstructionsTypeId)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InspectionItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InspectionItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.InspectionItemVO
All Implemented Interfaces:
java.io.Serializable
public class InspectionItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_INSPECTIONDESCRIPTION
static java.lang.String | ORDER_BY_INSPECTIONREQUEST
static java.lang.String | ORDER_BY_PK_ITEMNUMBER
Constructor Summary
InspectionItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getInspectionDescription()
java.lang.String | getInspectionRequest()
InspectionItemPK | getPk()
int | hashCode()
void | setInspectionDescription(java.lang.String inspectionDescription)
void | setInspectionRequest(java.lang.String inspectionRequest)
void | setPk(InspectionItemPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PK_ITEMNUMBER

public static final java.lang.String ORDER_BY_PK_ITEMNUMBER
See Also:
Constant Field Values

ORDER_BY_INSPECTIONDESCRIPTION

public static final java.lang.String ORDER_BY_INSPECTIONDESCRIPTION
See Also:
Constant Field Values

ORDER_BY_INSPECTIONREQUEST

public static final java.lang.String ORDER_BY_INSPECTIONREQUEST
See Also:
Constant Field Values
Constructor Detail

InspectionItemVO

public InspectionItemVO()
Method Detail

getInspectionDescription

public java.lang.String getInspectionDescription()

setInspectionDescription

public void setInspectionDescription(java.lang.String inspectionDescription)

getInspectionRequest

public java.lang.String getInspectionRequest()

setInspectionRequest

public void setInspectionRequest(java.lang.String inspectionRequest)

getPk

public InspectionItemPK getPk()

setPk

public void setPk(InspectionItemPK pk)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InspectionReportInfoVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InspectionReportInfoVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.InspectionReportInfoVO
All Implemented Interfaces:
java.io.Serializable
public class InspectionReportInfoVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CHECKEACHOTHER
static java.lang.String | ORDER_BY_CLEANWORKER
static java.lang.String | ORDER_BY_DRAWINGNUMBER
static java.lang.String | ORDER_BY_GOODQTY
static java.lang.String | ORDER_BY_INSPECTIONREPORTDATE
static java.lang.String | ORDER_BY_INSPECTIONREPORTNUMBER
static java.lang.String | ORDER_BY_INSPECTIONRESULT
static java.lang.String | ORDER_BY_INSPECTOR
static java.lang.String | ORDER_BY_MEASUREWORKER
static java.lang.String | ORDER_BY_OPERATINGENVIRONMENT
static java.lang.String | ORDER_BY_OPERATINGINSTRUCTIONSNUMBER
static java.lang.String | ORDER_BY_OPERATINGINSTRUCTIONSTYPEID
static java.lang.String | ORDER_BY_PICKLISTORDERNUMBER
static java.lang.String | ORDER_BY_PRINTEDBOARDNUMBER
static java.lang.String | ORDER_BY_QUANTITY
static java.lang.String | ORDER_BY_REJECTQTY
static java.lang.String | ORDER_BY_REJECTREASON
static java.lang.String | ORDER_BY_SEALWORKER
Constructor Summary
InspectionReportInfoVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.lang.String | getCleanWorker()
java.lang.String | getDrawingNumber()
java.math.BigDecimal | getGoodQty()
java.util.Date | getInspectionReportDate()
java.lang.String | getInspectionReportNumber()
java.lang.String | getInspectionResult()
java.lang.String | getInspector()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getMeasureWorker()
java.lang.String | getOperatingInstructionsNumber()
OperatingInstructionsTypeVO | getOperatingInstructionsType()
java.lang.Integer | getOperatingInstructionsTypeId()
java.lang.String | getOrigin()
java.lang.String | getPickListOrderNumber()
java.lang.String | getPrintedBoardNumber()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getRejectQty()
java.lang.String | getRejectReason()
java.lang.String | getSealWorker()
java.lang.Integer | getVersion()
int | hashCode()
boolean | isCheckEachOther()
boolean | isOperatingEnvironment()
void | setAdate(java.util.Date adate)
void | setCheckEachOther(boolean checkEachOther)
void | setCleanWorker(java.lang.String cleanWorker)
void | setDrawingNumber(java.lang.String drawingNumber)
void | setGoodQty(java.math.BigDecimal goodQty)
void | setInspectionReportDate(java.util.Date inspectionReportDate)
void | setInspectionReportNumber(java.lang.String inspectionReportNumber)
void | setInspectionResult(java.lang.String inspectionResult)
void | setInspector(java.lang.String inspector)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setMeasureWorker(java.lang.String measureWorker)
void | setOperatingEnvironment(boolean operatingEnvironment)
void | setOperatingInstructionsNumber(java.lang.String operatingInstructionsNumber)
void | setOperatingInstructionsType(OperatingInstructionsTypeVO operatingInstructionsType)
void | setOperatingInstructionsTypeId(java.lang.Integer operatingInstructionsTypeId)
void | setOrigin(java.lang.String origin)
void | setPickListOrderNumber(java.lang.String pickListOrderNumber)
void | setPrintedBoardNumber(java.lang.String printedBoardNumber)
void | setQuantity(java.math.BigDecimal quantity)
void | setRejectQty(java.math.BigDecimal rejectQty)
void | setRejectReason(java.lang.String rejectReason)
void | setSealWorker(java.lang.String sealWorker)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_INSPECTIONREPORTNUMBER

public static final java.lang.String ORDER_BY_INSPECTIONREPORTNUMBER
See Also:
Constant Field Values

ORDER_BY_PRINTEDBOARDNUMBER

public static final java.lang.String ORDER_BY_PRINTEDBOARDNUMBER
See Also:
Constant Field Values

ORDER_BY_DRAWINGNUMBER

public static final java.lang.String ORDER_BY_DRAWINGNUMBER
See Also:
Constant Field Values

ORDER_BY_OPERATINGENVIRONMENT

public static final java.lang.String ORDER_BY_OPERATINGENVIRONMENT
See Also:
Constant Field Values

ORDER_BY_PICKLISTORDERNUMBER

public static final java.lang.String ORDER_BY_PICKLISTORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_QUANTITY

public static final java.lang.String ORDER_BY_QUANTITY
See Also:
Constant Field Values

ORDER_BY_SEALWORKER

public static final java.lang.String ORDER_BY_SEALWORKER
See Also:
Constant Field Values

ORDER_BY_MEASUREWORKER

public static final java.lang.String ORDER_BY_MEASUREWORKER
See Also:
Constant Field Values

ORDER_BY_CLEANWORKER

public static final java.lang.String ORDER_BY_CLEANWORKER
See Also:
Constant Field Values

ORDER_BY_CHECKEACHOTHER

public static final java.lang.String ORDER_BY_CHECKEACHOTHER
See Also:
Constant Field Values

ORDER_BY_GOODQTY

public static final java.lang.String ORDER_BY_GOODQTY
See Also:
Constant Field Values

ORDER_BY_REJECTQTY

public static final java.lang.String ORDER_BY_REJECTQTY
See Also:
Constant Field Values

ORDER_BY_REJECTREASON

public static final java.lang.String ORDER_BY_REJECTREASON
See Also:
Constant Field Values

ORDER_BY_INSPECTIONRESULT

public static final java.lang.String ORDER_BY_INSPECTIONRESULT
See Also:
Constant Field Values

ORDER_BY_INSPECTOR

public static final java.lang.String ORDER_BY_INSPECTOR
See Also:
Constant Field Values

ORDER_BY_INSPECTIONREPORTDATE

public static final java.lang.String ORDER_BY_INSPECTIONREPORTDATE
See Also:
Constant Field Values

ORDER_BY_OPERATINGINSTRUCTIONSNUMBER

public static final java.lang.String ORDER_BY_OPERATINGINSTRUCTIONSNUMBER
See Also:
Constant Field Values

ORDER_BY_OPERATINGINSTRUCTIONSTYPEID

public static final java.lang.String ORDER_BY_OPERATINGINSTRUCTIONSTYPEID
See Also:
Constant Field Values
Constructor Detail

InspectionReportInfoVO

public InspectionReportInfoVO()
Method Detail

isCheckEachOther

public boolean isCheckEachOther()

setCheckEachOther

public void setCheckEachOther(boolean checkEachOther)

getCleanWorker

public java.lang.String getCleanWorker()

setCleanWorker

public void setCleanWorker(java.lang.String cleanWorker)

getDrawingNumber

public java.lang.String getDrawingNumber()

setDrawingNumber

public void setDrawingNumber(java.lang.String drawingNumber)

getGoodQty

public java.math.BigDecimal getGoodQty()

setGoodQty

public void setGoodQty(java.math.BigDecimal goodQty)

getInspectionReportDate

public java.util.Date getInspectionReportDate()

setInspectionReportDate

public void setInspectionReportDate(java.util.Date inspectionReportDate)

getInspectionReportNumber

public java.lang.String getInspectionReportNumber()

setInspectionReportNumber

public void setInspectionReportNumber(java.lang.String inspectionReportNumber)

getInspectionResult

public java.lang.String getInspectionResult()

setInspectionResult

public void setInspectionResult(java.lang.String inspectionResult)

getInspector

public java.lang.String getInspector()

setInspector

public void setInspector(java.lang.String inspector)

getMeasureWorker

public java.lang.String getMeasureWorker()

setMeasureWorker

public void setMeasureWorker(java.lang.String measureWorker)

isOperatingEnvironment

public boolean isOperatingEnvironment()

setOperatingEnvironment

public void setOperatingEnvironment(boolean operatingEnvironment)

getOperatingInstructionsNumber

public java.lang.String getOperatingInstructionsNumber()

setOperatingInstructionsNumber

public void setOperatingInstructionsNumber(java.lang.String operatingInstructionsNumber)

getOperatingInstructionsTypeId

public java.lang.Integer getOperatingInstructionsTypeId()

setOperatingInstructionsTypeId

public void setOperatingInstructionsTypeId(java.lang.Integer operatingInstructionsTypeId)

getPickListOrderNumber

public java.lang.String getPickListOrderNumber()

setPickListOrderNumber

public void setPickListOrderNumber(java.lang.String pickListOrderNumber)

getPrintedBoardNumber

public java.lang.String getPrintedBoardNumber()

setPrintedBoardNumber

public void setPrintedBoardNumber(java.lang.String printedBoardNumber)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getRejectQty

public java.math.BigDecimal getRejectQty()

setRejectQty

public void setRejectQty(java.math.BigDecimal rejectQty)

getRejectReason

public java.lang.String getRejectReason()

setRejectReason

public void setRejectReason(java.lang.String rejectReason)

getSealWorker

public java.lang.String getSealWorker()

setSealWorker

public void setSealWorker(java.lang.String sealWorker)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getVersion

public java.lang.Integer getVersion()

setVersion

public void setVersion(java.lang.Integer version)

getOperatingInstructionsType

public OperatingInstructionsTypeVO getOperatingInstructionsType()

setOperatingInstructionsType

public void setOperatingInstructionsType(OperatingInstructionsTypeVO operatingInstructionsType)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InspectionReportInspectMethodItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InspectionReportInspectMethodItemPK

java.lang.Object
    extended by  bb.common.InspectionReportInspectMethodItemPK
All Implemented Interfaces:
java.io.Serializable
public class InspectionReportInspectMethodItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
InspectionReportInspectMethodItemPK()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Integer | getIi()
java.lang.String | getInspectionReportNumber()
int | hashCode()
void | setIi(java.lang.Integer ii)
void | setInspectionReportNumber(java.lang.String inspectionReportNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

InspectionReportInspectMethodItemPK

public InspectionReportInspectMethodItemPK()
Method Detail

getIi

public java.lang.Integer getIi()

setIi

public void setIi(java.lang.Integer ii)

getInspectionReportNumber

public java.lang.String getInspectionReportNumber()

setInspectionReportNumber

public void setInspectionReportNumber(java.lang.String inspectionReportNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InspectionReportInspectMethodItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InspectionReportInspectMethodItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.InspectionReportInspectMethodItemVO
All Implemented Interfaces:
java.io.Serializable
public class InspectionReportInspectMethodItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
InspectionReportInspectMethodItemVO()
Method Summary
boolean | equals(java.lang.Object other)
InspectionReportInspectMethodVO | getInspectionReportInspectMethod()
InspectionReportInspectMethodItemPK | getPk()
int | hashCode()
void | setInspectionReportInspectMethod(InspectionReportInspectMethodVO inspectionReportInspectMethod)
void | setPk(InspectionReportInspectMethodItemPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

InspectionReportInspectMethodItemVO

public InspectionReportInspectMethodItemVO()
Method Detail

getPk

public InspectionReportInspectMethodItemPK getPk()

setPk

public void setPk(InspectionReportInspectMethodItemPK pk)

getInspectionReportInspectMethod

public InspectionReportInspectMethodVO getInspectionReportInspectMethod()

setInspectionReportInspectMethod

public void setInspectionReportInspectMethod(InspectionReportInspectMethodVO inspectionReportInspectMethod)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InspectionReportInspectMethodVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InspectionReportInspectMethodVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.InspectionReportInspectMethodVO
All Implemented Interfaces:
java.io.Serializable
public class InspectionReportInspectMethodVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_II
Constructor Summary
InspectionReportInspectMethodVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDescription()
java.lang.Integer | getIi()
int | hashCode()
void | setDescription(java.lang.String description)
void | setIi(java.lang.Integer ii)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_II

public static final java.lang.String ORDER_BY_II
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

InspectionReportInspectMethodVO

public InspectionReportInspectMethodVO()
Method Detail

getIi

public java.lang.Integer getIi()

setIi

public void setIi(java.lang.Integer ii)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InspectionReportInspectStandardItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InspectionReportInspectStandardItemPK

java.lang.Object
    extended by  bb.common.InspectionReportInspectStandardItemPK
All Implemented Interfaces:
java.io.Serializable
public class InspectionReportInspectStandardItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
InspectionReportInspectStandardItemPK()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Integer | getIi()
java.lang.String | getInspectionReportNumber()
int | hashCode()
void | setIi(java.lang.Integer ii)
void | setInspectionReportNumber(java.lang.String inspectionReportNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

InspectionReportInspectStandardItemPK

public InspectionReportInspectStandardItemPK()
Method Detail

getIi

public java.lang.Integer getIi()

setIi

public void setIi(java.lang.Integer ii)

getInspectionReportNumber

public java.lang.String getInspectionReportNumber()

setInspectionReportNumber

public void setInspectionReportNumber(java.lang.String inspectionReportNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InspectionReportInspectStandardItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InspectionReportInspectStandardItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.InspectionReportInspectStandardItemVO
All Implemented Interfaces:
java.io.Serializable
public class InspectionReportInspectStandardItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
InspectionReportInspectStandardItemVO()
Method Summary
boolean | equals(java.lang.Object other)
OperatingInstructionsInspectStandardVO | getInspectionReportInspectStandard()
InspectionReportInspectStandardItemPK | getPk()
int | hashCode()
void | setInspectionReportInspectStandard(OperatingInstructionsInspectStandardVO inspectionReportInspectStandard)
void | setPk(InspectionReportInspectStandardItemPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

InspectionReportInspectStandardItemVO

public InspectionReportInspectStandardItemVO()
Method Detail

getPk

public InspectionReportInspectStandardItemPK getPk()

setPk

public void setPk(InspectionReportInspectStandardItemPK pk)

getInspectionReportInspectStandard

public OperatingInstructionsInspectStandardVO getInspectionReportInspectStandard()

setInspectionReportInspectStandard

public void setInspectionReportInspectStandard(OperatingInstructionsInspectStandardVO inspectionReportInspectStandard)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InspectionReportItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InspectionReportItemPK

java.lang.Object
    extended by  bb.common.InspectionReportItemPK
All Implemented Interfaces:
java.io.Serializable
public class InspectionReportItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
InspectionReportItemPK()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getInspectionReportNumber()
java.lang.String | getItemNumber()
int | hashCode()
void | setInspectionReportNumber(java.lang.String inspectionReportNumber)
void | setItemNumber(java.lang.String itemNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

InspectionReportItemPK

public InspectionReportItemPK()
Method Detail

getInspectionReportNumber

public java.lang.String getInspectionReportNumber()

setInspectionReportNumber

public void setInspectionReportNumber(java.lang.String inspectionReportNumber)

getItemNumber

public java.lang.String getItemNumber()

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InspectionReportItemQtyPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InspectionReportItemQtyPK

java.lang.Object
    extended by  bb.common.InspectionReportItemQtyPK
All Implemented Interfaces:
java.io.Serializable
public class InspectionReportItemQtyPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
InspectionReportItemQtyPK()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Byte | getIi()
java.lang.String | getInspectionReportNumber()
java.lang.String | getItemNumber()
int | hashCode()
void | setIi(java.lang.Byte ii)
void | setInspectionReportNumber(java.lang.String inspectionReportNumber)
void | setItemNumber(java.lang.String itemNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

InspectionReportItemQtyPK

public InspectionReportItemQtyPK()
Method Detail

getInspectionReportNumber

public java.lang.String getInspectionReportNumber()

setInspectionReportNumber

public void setInspectionReportNumber(java.lang.String inspectionReportNumber)

getItemNumber

public java.lang.String getItemNumber()

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

getIi

public java.lang.Byte getIi()

setIi

public void setIi(java.lang.Byte ii)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InspectionReportItemQtyVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InspectionReportItemQtyVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.InspectionReportItemQtyVO
All Implemented Interfaces:
java.io.Serializable
public class InspectionReportItemQtyVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
InspectionReportItemQtyVO()
Method Summary
boolean | equals(java.lang.Object other)
InspectionReportItemQtyPK | getPk()
int | hashCode()
void | setPk(InspectionReportItemQtyPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

InspectionReportItemQtyVO

public InspectionReportItemQtyVO()
Method Detail

getPk

public InspectionReportItemQtyPK getPk()

setPk

public void setPk(InspectionReportItemQtyPK pk)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InspectionReportItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InspectionReportItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.InspectionReportItemVO
All Implemented Interfaces:
java.io.Serializable
public class InspectionReportItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
InspectionReportItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Set<InspectionReportItemQtyVO> | getItems()
InspectionReportItemPK | getPk()
int | hashCode()
void | setItems(java.util.Set<InspectionReportItemQtyVO> items)
void | setPk(InspectionReportItemPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

InspectionReportItemVO

public InspectionReportItemVO()
Method Detail

getPk

public InspectionReportItemPK getPk()

setPk

public void setPk(InspectionReportItemPK pk)

getItems

public java.util.Set<InspectionReportItemQtyVO> getItems()

setItems

public void setItems(java.util.Set<InspectionReportItemQtyVO> items)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InspectionReportVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InspectionReportVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.InspectionReportVO
All Implemented Interfaces:
java.io.Serializable
public class InspectionReportVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
InspectionReportVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.lang.String | getCleanWorker()
java.lang.String | getDrawingNumber()
java.math.BigDecimal | getGoodQty()
java.util.Date | getInspectionReportDate()
java.util.Set<InspectionReportInspectMethodItemVO> | getInspectionReportInspectMethodItems()
java.util.Set<InspectionReportInspectStandardItemVO> | getInspectionReportInspectStandardItems()
java.util.Set<InspectionReportItemVO> | getInspectionReportItems()
java.lang.String | getInspectionReportNumber()
java.lang.String | getInspectionResult()
java.lang.String | getInspector()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getMeasureWorker()
java.lang.String | getOperatingInstructionsNumber()
OperatingInstructionsTypeVO | getOperatingInstructionsType()
java.lang.Integer | getOperatingInstructionsTypeId()
java.lang.String | getOrigin()
java.lang.String | getPickListOrderNumber()
java.lang.String | getPrintedBoardNumber()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getRejectQty()
java.lang.String | getRejectReason()
java.lang.String | getSealWorker()
java.lang.Integer | getVersion()
int | hashCode()
boolean | isCheckEachOther()
boolean | isOperatingEnvironment()
void | setAdate(java.util.Date adate)
void | setCheckEachOther(boolean checkEachOther)
void | setCleanWorker(java.lang.String cleanWorker)
void | setDrawingNumber(java.lang.String drawingNumber)
void | setGoodQty(java.math.BigDecimal goodQty)
void | setInspectionReportDate(java.util.Date inspectionReportDate)
void | setInspectionReportInspectMethodItems(java.util.Set<InspectionReportInspectMethodItemVO> inspectionReportInspectMethodItems)
void | setInspectionReportInspectStandardItems(java.util.Set<InspectionReportInspectStandardItemVO> inspectionReportInspectStandardItems)
void | setInspectionReportItems(java.util.Set<InspectionReportItemVO> inspectionReportItems)
void | setInspectionReportNumber(java.lang.String inspectionReportNumber)
void | setInspectionResult(java.lang.String inspectionResult)
void | setInspector(java.lang.String inspector)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setMeasureWorker(java.lang.String measureWorker)
void | setOperatingEnvironment(boolean operatingEnvironment)
void | setOperatingInstructionsNumber(java.lang.String operatingInstructionsNumber)
void | setOperatingInstructionsType(OperatingInstructionsTypeVO operatingInstructionsType)
void | setOperatingInstructionsTypeId(java.lang.Integer operatingInstructionsTypeId)
void | setOrigin(java.lang.String origin)
void | setPickListOrderNumber(java.lang.String pickListOrderNumber)
void | setPrintedBoardNumber(java.lang.String printedBoardNumber)
void | setQuantity(java.math.BigDecimal quantity)
void | setRejectQty(java.math.BigDecimal rejectQty)
void | setRejectReason(java.lang.String rejectReason)
void | setSealWorker(java.lang.String sealWorker)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

InspectionReportVO

public InspectionReportVO()
Method Detail

isCheckEachOther

public boolean isCheckEachOther()

setCheckEachOther

public void setCheckEachOther(boolean checkEachOther)

getCleanWorker

public java.lang.String getCleanWorker()

setCleanWorker

public void setCleanWorker(java.lang.String cleanWorker)

getDrawingNumber

public java.lang.String getDrawingNumber()

setDrawingNumber

public void setDrawingNumber(java.lang.String drawingNumber)

getGoodQty

public java.math.BigDecimal getGoodQty()

setGoodQty

public void setGoodQty(java.math.BigDecimal goodQty)

getInspectionReportDate

public java.util.Date getInspectionReportDate()

setInspectionReportDate

public void setInspectionReportDate(java.util.Date inspectionReportDate)

getInspectionReportInspectMethodItems

public java.util.Set<InspectionReportInspectMethodItemVO> getInspectionReportInspectMethodItems()

setInspectionReportInspectMethodItems

public void setInspectionReportInspectMethodItems(java.util.Set<InspectionReportInspectMethodItemVO> inspectionReportInspectMethodItems)

getInspectionReportInspectStandardItems

public java.util.Set<InspectionReportInspectStandardItemVO> getInspectionReportInspectStandardItems()

setInspectionReportInspectStandardItems

public void setInspectionReportInspectStandardItems(java.util.Set<InspectionReportInspectStandardItemVO> inspectionReportInspectStandardItems)

getInspectionReportItems

public java.util.Set<InspectionReportItemVO> getInspectionReportItems()

setInspectionReportItems

public void setInspectionReportItems(java.util.Set<InspectionReportItemVO> inspectionReportItems)

getInspectionReportNumber

public java.lang.String getInspectionReportNumber()

setInspectionReportNumber

public void setInspectionReportNumber(java.lang.String inspectionReportNumber)

getInspectionResult

public java.lang.String getInspectionResult()

setInspectionResult

public void setInspectionResult(java.lang.String inspectionResult)

getInspector

public java.lang.String getInspector()

setInspector

public void setInspector(java.lang.String inspector)

getMeasureWorker

public java.lang.String getMeasureWorker()

setMeasureWorker

public void setMeasureWorker(java.lang.String measureWorker)

isOperatingEnvironment

public boolean isOperatingEnvironment()

setOperatingEnvironment

public void setOperatingEnvironment(boolean operatingEnvironment)

getOperatingInstructionsNumber

public java.lang.String getOperatingInstructionsNumber()

setOperatingInstructionsNumber

public void setOperatingInstructionsNumber(java.lang.String operatingInstructionsNumber)

getOperatingInstructionsTypeId

public java.lang.Integer getOperatingInstructionsTypeId()

setOperatingInstructionsTypeId

public void setOperatingInstructionsTypeId(java.lang.Integer operatingInstructionsTypeId)

getPickListOrderNumber

public java.lang.String getPickListOrderNumber()

setPickListOrderNumber

public void setPickListOrderNumber(java.lang.String pickListOrderNumber)

getPrintedBoardNumber

public java.lang.String getPrintedBoardNumber()

setPrintedBoardNumber

public void setPrintedBoardNumber(java.lang.String printedBoardNumber)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getRejectQty

public java.math.BigDecimal getRejectQty()

setRejectQty

public void setRejectQty(java.math.BigDecimal rejectQty)

getRejectReason

public java.lang.String getRejectReason()

setRejectReason

public void setRejectReason(java.lang.String rejectReason)

getSealWorker

public java.lang.String getSealWorker()

setSealWorker

public void setSealWorker(java.lang.String sealWorker)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getVersion

public java.lang.Integer getVersion()

setVersion

public void setVersion(java.lang.Integer version)

getOperatingInstructionsType

public OperatingInstructionsTypeVO getOperatingInstructionsType()

setOperatingInstructionsType

public void setOperatingInstructionsType(OperatingInstructionsTypeVO operatingInstructionsType)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InspectionTypeItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InspectionTypeItemPK

java.lang.Object
    extended by  bb.common.InspectionTypeItemPK
All Implemented Interfaces:
java.io.Serializable
public class InspectionTypeItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
InspectionTypeItemPK()
InspectionTypeItemPK(java.lang.String inspectionType, java.lang.String itemNumber)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getInspectionType()
java.lang.String | getItemNumber()
int | hashCode()
void | setInspectionType(java.lang.String inspectionType)
void | setItemNumber(java.lang.String itemNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

InspectionTypeItemPK

public InspectionTypeItemPK()

InspectionTypeItemPK

public InspectionTypeItemPK(java.lang.String inspectionType,
                            java.lang.String itemNumber)
Method Detail

getInspectionType

public java.lang.String getInspectionType()

setInspectionType

public void setInspectionType(java.lang.String inspectionType)

getItemNumber

public java.lang.String getItemNumber()

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InspectionTypeItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InspectionTypeItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.InspectionTypeItemVO
All Implemented Interfaces:
java.io.Serializable
public class InspectionTypeItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
InspectionTypeItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getInspectProject()
InspectionTypeItemPK | getPk()
java.lang.String | getTechnolgyStandard()
java.lang.String | getUnit()
int | hashCode()
void | setInspectProject(java.lang.String inspectProject)
void | setPk(InspectionTypeItemPK pk)
void | setTechnolgyStandard(java.lang.String technolgyStandard)
void | setUnit(java.lang.String unit)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InspectionTypeItemVO

public InspectionTypeItemVO()
Method Detail

getPk

public InspectionTypeItemPK getPk()

setPk

public void setPk(InspectionTypeItemPK pk)

getInspectProject

public java.lang.String getInspectProject()

setInspectProject

public void setInspectProject(java.lang.String inspectProject)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getTechnolgyStandard

public java.lang.String getTechnolgyStandard()

setTechnolgyStandard

public void setTechnolgyStandard(java.lang.String technolgyStandard)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InspectionTypeVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InspectionTypeVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.InspectionTypeVO
All Implemented Interfaces:
java.io.Serializable
public class InspectionTypeVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
InspectionTypeVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getInspectionType()
java.util.Set | getInspectionTypeItems()
java.lang.String | getNote()
int | hashCode()
void | setInspectionType(java.lang.String inspectionType)
void | setInspectionTypeItems(java.util.Set inspectionTypeItems)
void | setNote(java.lang.String note)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InspectionTypeVO

public InspectionTypeVO()
Method Detail

getInspectionType

public java.lang.String getInspectionType()

setInspectionType

public void setInspectionType(java.lang.String inspectionType)

getNote

public java.lang.String getNote()

setNote

public void setNote(java.lang.String note)

getInspectionTypeItems

public java.util.Set getInspectionTypeItems()

setInspectionTypeItems

public void setInspectionTypeItems(java.util.Set inspectionTypeItems)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InventoryAdjustmentDetailResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InventoryAdjustmentDetailResult

java.lang.Object
    extended by  bb.common.InventoryAdjustmentDetailResult
All Implemented Interfaces:
java.io.Serializable
public class InventoryAdjustmentDetailResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
InventoryAdjustmentDetailResult()
Method Summary
java.util.List | getAverageCostResultList()
InventoryAdjustmentVO | getLastAdjustment()
java.lang.String | getPartFrom()
PartBasicInfo | getPartInfo()
PartInventoryVO | getPartInventoryInfo()
ToolBasicInfo | getToolInfo()
ToolInventoryVO | getToolInventoryInfo()
java.math.BigDecimal | getTotalOnhand()
void | setAverageCostResultList(java.util.List averageCostResultList)
void | setLastAdjustment(InventoryAdjustmentVO lastAdjustment)
void | setPartFrom(java.lang.String partFrom)
void | setPartInfo(PartBasicInfo partInfo)
void | setPartInventoryInfo(PartInventoryVO partInventoryInfo)
void | setToolInfo(ToolBasicInfo toolInfo)
void | setToolInventoryInfo(ToolInventoryVO toolInventoryInfo)
void | setTotalOnhand(java.math.BigDecimal totalOnhand)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InventoryAdjustmentDetailResult

public InventoryAdjustmentDetailResult()
Method Detail

setLastAdjustment

public void setLastAdjustment(InventoryAdjustmentVO lastAdjustment)

setTotalOnhand

public void setTotalOnhand(java.math.BigDecimal totalOnhand)

setPartInventoryInfo

public void setPartInventoryInfo(PartInventoryVO partInventoryInfo)

setPartInfo

public void setPartInfo(PartBasicInfo partInfo)

getLastAdjustment

public InventoryAdjustmentVO getLastAdjustment()

getTotalOnhand

public java.math.BigDecimal getTotalOnhand()

getPartInventoryInfo

public PartInventoryVO getPartInventoryInfo()

getPartInfo

public PartBasicInfo getPartInfo()

getAverageCostResultList

public java.util.List getAverageCostResultList()

setAverageCostResultList

public void setAverageCostResultList(java.util.List averageCostResultList)

getToolInventoryInfo

public ToolInventoryVO getToolInventoryInfo()

setToolInventoryInfo

public void setToolInventoryInfo(ToolInventoryVO toolInventoryInfo)

getToolInfo

public ToolBasicInfo getToolInfo()

setToolInfo

public void setToolInfo(ToolBasicInfo toolInfo)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InventoryAdjustmentListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InventoryAdjustmentListResult

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.InventoryAdjustmentVO
            extended by  bb.common.InventoryAdjustmentListResult
All Implemented Interfaces:
java.io.Serializable
public class InventoryAdjustmentListResult
extends InventoryAdjustmentVO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_COUNTEDBY
static java.lang.String | ORDER_BY_COUNTEDDATE
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_PARTNUMBER
Fields inherited from class bb.common.InventoryAdjustmentVO
ORDER_BY_AVGCOST, ORDER_BY_COMMITTED, ORDER_BY_DIFFCOUNT, ORDER_BY_NEWONHAND
Constructor Summary
InventoryAdjustmentListResult()
Method Summary
java.lang.String | getDescription()
void | setDescription(java.lang.String description)
Methods inherited from class bb.common.InventoryAdjustmentVO
getComments, getCountedBy, getCountedDate, getIi, getLastChangeDate, getLastChangeUser, getNewCost, getNewOnhandQty, getOldCost, getOldOnhandQty, getPartFrom, getPartNumber, getPartType, getVersion, setComments, setCountedBy, setCountedDate, setIi, setLastChangeDate, setLastChangeUser, setNewCost, setNewOnhandQty, setOldCost, setOldOnhandQty, setPartFrom, setPartNumber, setPartType, setVersion
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_COUNTEDDATE

public static final java.lang.String ORDER_BY_COUNTEDDATE
See Also:
Constant Field Values

ORDER_BY_COUNTEDBY

public static final java.lang.String ORDER_BY_COUNTEDBY
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

InventoryAdjustmentListResult

public InventoryAdjustmentListResult()
Method Detail

setDescription

public void setDescription(java.lang.String description)

getDescription

public java.lang.String getDescription()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InventoryAdjustmentVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InventoryAdjustmentVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.InventoryAdjustmentVO
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
InventoryAdjustmentListResult
public class InventoryAdjustmentVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AVGCOST
static java.lang.String | ORDER_BY_COMMITTED
static java.lang.String | ORDER_BY_COUNTEDBY
static java.lang.String | ORDER_BY_COUNTEDDATE
static java.lang.String | ORDER_BY_DIFFCOUNT
static java.lang.String | ORDER_BY_NEWONHAND
Constructor Summary
InventoryAdjustmentVO()
default constructor
Method Summary
java.lang.String | getComments()
java.lang.String | getCountedBy()
java.util.Date | getCountedDate()
java.lang.Long | getIi()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.math.BigDecimal | getNewCost()
java.math.BigDecimal | getNewOnhandQty()
java.math.BigDecimal | getOldCost()
java.math.BigDecimal | getOldOnhandQty()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.Integer | getVersion()
void | setComments(java.lang.String comments)
void | setCountedBy(java.lang.String countedBy)
void | setCountedDate(java.util.Date countedDate)
void | setIi(java.lang.Long ii)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setNewCost(java.math.BigDecimal newCost)
void | setNewOnhandQty(java.math.BigDecimal newOnhandQty)
void | setOldCost(java.math.BigDecimal oldCost)
void | setOldOnhandQty(java.math.BigDecimal oldOnhandQty)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setVersion(java.lang.Integer version)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_NEWONHAND

public static final java.lang.String ORDER_BY_NEWONHAND
See Also:
Constant Field Values

ORDER_BY_DIFFCOUNT

public static final java.lang.String ORDER_BY_DIFFCOUNT
See Also:
Constant Field Values

ORDER_BY_COMMITTED

public static final java.lang.String ORDER_BY_COMMITTED
See Also:
Constant Field Values

ORDER_BY_AVGCOST

public static final java.lang.String ORDER_BY_AVGCOST
See Also:
Constant Field Values

ORDER_BY_COUNTEDBY

public static final java.lang.String ORDER_BY_COUNTEDBY
See Also:
Constant Field Values

ORDER_BY_COUNTEDDATE

public static final java.lang.String ORDER_BY_COUNTEDDATE
See Also:
Constant Field Values
Constructor Detail

InventoryAdjustmentVO

public InventoryAdjustmentVO()
default constructor

Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getCountedDate

public java.util.Date getCountedDate()

setCountedDate

public void setCountedDate(java.util.Date countedDate)

getCountedBy

public java.lang.String getCountedBy()

setCountedBy

public void setCountedBy(java.lang.String countedBy)

getOldOnhandQty

public java.math.BigDecimal getOldOnhandQty()

setOldOnhandQty

public void setOldOnhandQty(java.math.BigDecimal oldOnhandQty)

getNewOnhandQty

public java.math.BigDecimal getNewOnhandQty()

setNewOnhandQty

public void setNewOnhandQty(java.math.BigDecimal newOnhandQty)

getOldCost

public java.math.BigDecimal getOldCost()

setOldCost

public void setOldCost(java.math.BigDecimal oldCost)

getNewCost

public java.math.BigDecimal getNewCost()

setNewCost

public void setNewCost(java.math.BigDecimal newCost)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getVersion

public java.lang.Integer getVersion()

setVersion

public void setVersion(java.lang.Integer version)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InventoryAmountByMonth

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InventoryAmountByMonth

java.lang.Object
    extended by  bb.common.InventoryAmountByMonth
All Implemented Interfaces:
java.io.Serializable
public class InventoryAmountByMonth
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
InventoryAmountByMonth()
Method Summary
java.util.Map<java.lang.String,java.math.BigDecimal> | getAvgCost()
java.util.Map<java.lang.String,java.math.BigDecimal> | getStdCost()
void | setAvgCost(java.util.Map<java.lang.String,java.math.BigDecimal> avgCost)
void | setStdCost(java.util.Map<java.lang.String,java.math.BigDecimal> stdCost)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InventoryAmountByMonth

public InventoryAmountByMonth()
Method Detail

getAvgCost

public java.util.Map<java.lang.String,java.math.BigDecimal> getAvgCost()

setAvgCost

public void setAvgCost(java.util.Map<java.lang.String,java.math.BigDecimal> avgCost)

getStdCost

public java.util.Map<java.lang.String,java.math.BigDecimal> getStdCost()

setStdCost

public void setStdCost(java.util.Map<java.lang.String,java.math.BigDecimal> stdCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InventoryAuditReportResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InventoryAuditReportResult

java.lang.Object
    extended by  bb.common.InventoryReportListResult
        extended by  bb.common.InventoryAuditReportResult
All Implemented Interfaces:
java.io.Serializable
public class InventoryAuditReportResult
extends InventoryReportListResult
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
Fields inherited from class bb.common.InventoryReportListResult
ORDER_BY_PARTDESCRIPTION, ORDER_BY_PARTNUMBER
Constructor Summary
InventoryAuditReportResult()
Method Summary
java.math.BigDecimal | getTotalAdjustMoney()
java.math.BigDecimal | getTotalAdjustQty()
java.math.BigDecimal | getTotalCountOnhandQty()
java.math.BigDecimal | getTotalVarOnhandQty()
void | setTotalAdjustMoney(java.math.BigDecimal totalAdjustMoney)
void | setTotalAdjustQty(java.math.BigDecimal totalAdjustQty)
void | setTotalCountOnhandQty(java.math.BigDecimal totalCountOnhandQty)
void | setTotalVarOnhandQty(java.math.BigDecimal totalVarOnhandQty)
Methods inherited from class bb.common.InventoryReportListResult
getBeginCost, getDateFrom, getDateTo, getEndCost, getNewLnQty, getNewQaQty, getNewSipQty, getNewSitQty, getOldLnQty, getOldQaQty, getOldSipQty, getOldSitQty, getPartDescription, getPartNumber, getPartPK, getPartType, getTotalIssued, getTotalIssuedMoney, getTotalNewCost, getTotalNewOnhand, getTotalOldCost, getTotalOldOnhand, getTotalReceived, getTotalRecMoney, setDateFrom, setDateTo, setNewLnQty, setNewQaQty, setNewSipQty, setNewSitQty, setOldLnQty, setOldQaQty, setOldSipQty, setOldSitQty, setPartDescription, setPartNumber, setPartType, setTotalIssued, setTotalIssuedMoney, setTotalNewCost, setTotalNewOnhand, setTotalOldCost, setTotalOldOnhand, setTotalReceived, setTotalRecMoney
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InventoryAuditReportResult

public InventoryAuditReportResult()
Method Detail

getTotalAdjustMoney

public java.math.BigDecimal getTotalAdjustMoney()

setTotalAdjustMoney

public void setTotalAdjustMoney(java.math.BigDecimal totalAdjustMoney)

getTotalAdjustQty

public java.math.BigDecimal getTotalAdjustQty()

setTotalAdjustQty

public void setTotalAdjustQty(java.math.BigDecimal totalAdjustQty)

getTotalCountOnhandQty

public java.math.BigDecimal getTotalCountOnhandQty()

setTotalCountOnhandQty

public void setTotalCountOnhandQty(java.math.BigDecimal totalCountOnhandQty)

getTotalVarOnhandQty

public java.math.BigDecimal getTotalVarOnhandQty()

setTotalVarOnhandQty

public void setTotalVarOnhandQty(java.math.BigDecimal totalVarOnhandQty)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InventoryCycleItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InventoryCycleItemResult

java.lang.Object
    extended by  bb.common.InventoryCycleItemResult
All Implemented Interfaces:
java.io.Serializable
public class InventoryCycleItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
InventoryCycleItemResult()
Method Summary
java.lang.Integer | getCount()
java.lang.String | getLocation()
java.math.BigDecimal | getOnhand()
void | setCount(java.lang.Integer count)
void | setLocation(java.lang.String location)
void | setOnhand(java.math.BigDecimal onhand)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InventoryCycleItemResult

public InventoryCycleItemResult()
Method Detail

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

setLocation

public void setLocation(java.lang.String location)

setCount

public void setCount(java.lang.Integer count)

getOnhand

public java.math.BigDecimal getOnhand()

getLocation

public java.lang.String getLocation()

getCount

public java.lang.Integer getCount()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InventoryCycleResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InventoryCycleResult

java.lang.Object
    extended by  bb.common.InventoryCycleResult
All Implemented Interfaces:
java.io.Serializable
public class InventoryCycleResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_PART
Constructor Summary
InventoryCycleResult()
Method Summary
java.lang.String | getDescription()
java.util.Set | getItems()
BB2Part | getPart()
java.lang.String | getPartUnit()
java.math.BigDecimal | getTotOnhand()
void | setDescription(java.lang.String description)
void | setItems(java.util.Set items)
void | setPart(BB2Part part)
void | setPartUnit(java.lang.String partUnit)
void | setTotOnhand(java.math.BigDecimal totOnhand)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PART

public static final java.lang.String ORDER_BY_PART
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

InventoryCycleResult

public InventoryCycleResult()
Method Detail

getPartUnit

public java.lang.String getPartUnit()

setPartUnit

public void setPartUnit(java.lang.String partUnit)

setPart

public void setPart(BB2Part part)

setDescription

public void setDescription(java.lang.String description)

setTotOnhand

public void setTotOnhand(java.math.BigDecimal totOnhand)

setItems

public void setItems(java.util.Set items)

getPart

public BB2Part getPart()

getDescription

public java.lang.String getDescription()

getTotOnhand

public java.math.BigDecimal getTotOnhand()

getItems

public java.util.Set getItems()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InventoryListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InventoryListResult

java.lang.Object
    extended by  bb.common.InventoryListResult
All Implemented Interfaces:
java.io.Serializable
public class InventoryListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_BUYERCODE
static java.lang.String | ORDER_BY_COMMODITYCODE
static java.lang.String | ORDER_BY_COST
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_INQA
static java.lang.String | ORDER_BY_INSIP
static java.lang.String | ORDER_BY_INSTO
static java.lang.String | ORDER_BY_INWIP
static java.lang.String | ORDER_BY_LASTINDATE
static java.lang.String | ORDER_BY_LASTOUTDATE
static java.lang.String | ORDER_BY_LISTPRICE
static java.lang.String | ORDER_BY_MAXQTY
static java.lang.String | ORDER_BY_MINORDER
static java.lang.String | ORDER_BY_MINQTY
static java.lang.String | ORDER_BY_MODELNUMBER
static java.lang.String | ORDER_BY_ONHAND
static java.lang.String | ORDER_BY_ONLOAN
static java.lang.String | ORDER_BY_ONORDER
static java.lang.String | ORDER_BY_PART
static java.lang.String | ORDER_BY_PRODUCTCODE
static java.lang.String | ORDER_BY_SHORTAGE
static java.lang.String | ORDER_BY_STANDARDCOST
Constructor Summary
InventoryListResult()
Method Summary
java.lang.String | getBuyercode()
java.lang.String | getCommodityCode()
java.math.BigDecimal | getCost()
java.lang.String | getDescription()
java.math.BigDecimal | getInQa()
java.math.BigDecimal | getInSip()
java.math.BigDecimal | getInSTO()
java.math.BigDecimal | getInWip()
java.util.Date | getLastInDate()
java.util.Date | getLastOutDate()
java.math.BigDecimal | getListPrice()
java.lang.String | getLocation()
java.math.BigDecimal | getMaxQty()
java.math.BigDecimal | getMinOrder()
java.math.BigDecimal | getMinQty()
java.lang.String | getModelNumber()
java.math.BigDecimal | getOnDemand()
java.math.BigDecimal | getOnhand()
java.math.BigDecimal | getOnLoan()
java.math.BigDecimal | getOnOrder()
BB2Part | getPart()
java.lang.String | getProductCode()
java.math.BigDecimal | getProfitMarginByAvgCost()
java.math.BigDecimal | getShortage()
java.math.BigDecimal | getSold()
java.math.BigDecimal | getStandardCost()
java.math.BigDecimal | getTotalInventory()
void | setBuyercode(java.lang.String buycode)
void | setCommodityCode(java.lang.String commodityCode)
void | setCost(java.math.BigDecimal cost)
void | setDescription(java.lang.String description)
void | setInQa(java.math.BigDecimal inQa)
void | setInSip(java.math.BigDecimal inSip)
void | setInSTO(java.math.BigDecimal inSTO)
void | setInWip(java.math.BigDecimal inWip)
void | setLastInDate(java.util.Date lastInDate)
void | setLastOutDate(java.util.Date lastOutDate)
void | setListPrice(java.math.BigDecimal listPrice)
void | setLocation(java.lang.String location)
void | setMaxQty(java.math.BigDecimal maxQty)
void | setMinOrder(java.math.BigDecimal minOrder)
void | setMinQty(java.math.BigDecimal minQty)
void | setModelNumber(java.lang.String modelNumber)
void | setOnDemand(java.math.BigDecimal onDemand)
void | setOnhand(java.math.BigDecimal onhand)
void | setOnLoan(java.math.BigDecimal onLoan)
void | setOnOrder(java.math.BigDecimal onOrder)
void | setPart(BB2Part part)
void | setProductCode(java.lang.String productCode)
void | setProfitMarginByAvgCost(java.math.BigDecimal profitMarginByAvgCost)
void | setShortage(java.math.BigDecimal shortage)
void | setSold(java.math.BigDecimal sold)
void | setStandardCost(java.math.BigDecimal standardCost)
void | setTotalInventory(java.math.BigDecimal totalInventory)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PART

public static final java.lang.String ORDER_BY_PART
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_ONHAND

public static final java.lang.String ORDER_BY_ONHAND
See Also:
Constant Field Values

ORDER_BY_INWIP

public static final java.lang.String ORDER_BY_INWIP
See Also:
Constant Field Values

ORDER_BY_ONLOAN

public static final java.lang.String ORDER_BY_ONLOAN
See Also:
Constant Field Values

ORDER_BY_COST

public static final java.lang.String ORDER_BY_COST
See Also:
Constant Field Values

ORDER_BY_STANDARDCOST

public static final java.lang.String ORDER_BY_STANDARDCOST
See Also:
Constant Field Values

ORDER_BY_COMMODITYCODE

public static final java.lang.String ORDER_BY_COMMODITYCODE
See Also:
Constant Field Values

ORDER_BY_BUYERCODE

public static final java.lang.String ORDER_BY_BUYERCODE
See Also:
Constant Field Values

ORDER_BY_INSIP

public static final java.lang.String ORDER_BY_INSIP
See Also:
Constant Field Values

ORDER_BY_MINQTY

public static final java.lang.String ORDER_BY_MINQTY
See Also:
Constant Field Values

ORDER_BY_LASTINDATE

public static final java.lang.String ORDER_BY_LASTINDATE
See Also:
Constant Field Values

ORDER_BY_LASTOUTDATE

public static final java.lang.String ORDER_BY_LASTOUTDATE
See Also:
Constant Field Values

ORDER_BY_INQA

public static final java.lang.String ORDER_BY_INQA
See Also:
Constant Field Values

ORDER_BY_LISTPRICE

public static final java.lang.String ORDER_BY_LISTPRICE
See Also:
Constant Field Values

ORDER_BY_MODELNUMBER

public static final java.lang.String ORDER_BY_MODELNUMBER
See Also:
Constant Field Values

ORDER_BY_PRODUCTCODE

public static final java.lang.String ORDER_BY_PRODUCTCODE
See Also:
Constant Field Values

ORDER_BY_INSTO

public static final java.lang.String ORDER_BY_INSTO
See Also:
Constant Field Values

ORDER_BY_MAXQTY

public static final java.lang.String ORDER_BY_MAXQTY
See Also:
Constant Field Values

ORDER_BY_ONORDER

public static final java.lang.String ORDER_BY_ONORDER
See Also:
Constant Field Values

ORDER_BY_SHORTAGE

public static final java.lang.String ORDER_BY_SHORTAGE
See Also:
Constant Field Values

ORDER_BY_MINORDER

public static final java.lang.String ORDER_BY_MINORDER
See Also:
Constant Field Values
Constructor Detail

InventoryListResult

public InventoryListResult()
Method Detail

setPart

public void setPart(BB2Part part)

setDescription

public void setDescription(java.lang.String description)

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

setInWip

public void setInWip(java.math.BigDecimal inWip)

setCost

public void setCost(java.math.BigDecimal cost)

setLocation

public void setLocation(java.lang.String location)

setCommodityCode

public void setCommodityCode(java.lang.String commodityCode)

getPart

public BB2Part getPart()

getDescription

public java.lang.String getDescription()

getOnhand

public java.math.BigDecimal getOnhand()

getInWip

public java.math.BigDecimal getInWip()

getCost

public java.math.BigDecimal getCost()

getLocation

public java.lang.String getLocation()

getCommodityCode

public java.lang.String getCommodityCode()

getBuyercode

public java.lang.String getBuyercode()

setBuyercode

public void setBuyercode(java.lang.String buycode)

getStandardCost

public java.math.BigDecimal getStandardCost()

setStandardCost

public void setStandardCost(java.math.BigDecimal standardCost)

getInSip

public java.math.BigDecimal getInSip()

setInSip

public void setInSip(java.math.BigDecimal inSip)

getMinQty

public java.math.BigDecimal getMinQty()

setMinQty

public void setMinQty(java.math.BigDecimal minQty)

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

getInQa

public java.math.BigDecimal getInQa()

setInQa

public void setInQa(java.math.BigDecimal inQa)

getTotalInventory

public java.math.BigDecimal getTotalInventory()

setTotalInventory

public void setTotalInventory(java.math.BigDecimal totalInventory)

getOnOrder

public java.math.BigDecimal getOnOrder()

setOnOrder

public void setOnOrder(java.math.BigDecimal onOrder)

getOnDemand

public java.math.BigDecimal getOnDemand()

setOnDemand

public void setOnDemand(java.math.BigDecimal onDemand)

getMaxQty

public java.math.BigDecimal getMaxQty()

setMaxQty

public void setMaxQty(java.math.BigDecimal maxQty)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getLastInDate

public java.util.Date getLastInDate()

setLastInDate

public void setLastInDate(java.util.Date lastInDate)

getLastOutDate

public java.util.Date getLastOutDate()

setLastOutDate

public void setLastOutDate(java.util.Date lastOutDate)

getOnLoan

public java.math.BigDecimal getOnLoan()

setOnLoan

public void setOnLoan(java.math.BigDecimal onLoan)

getProductCode

public java.lang.String getProductCode()

setProductCode

public void setProductCode(java.lang.String productCode)

getInSTO

public java.math.BigDecimal getInSTO()

setInSTO

public void setInSTO(java.math.BigDecimal inSTO)

getShortage

public java.math.BigDecimal getShortage()

setShortage

public void setShortage(java.math.BigDecimal shortage)

getMinOrder

public java.math.BigDecimal getMinOrder()

setMinOrder

public void setMinOrder(java.math.BigDecimal minOrder)

getSold

public java.math.BigDecimal getSold()

setSold

public void setSold(java.math.BigDecimal sold)

getProfitMarginByAvgCost

public java.math.BigDecimal getProfitMarginByAvgCost()

setProfitMarginByAvgCost

public void setProfitMarginByAvgCost(java.math.BigDecimal profitMarginByAvgCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InventoryMonthReport

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InventoryMonthReport

java.lang.Object
    extended by  bb.common.InventoryMonthReport
All Implemented Interfaces:
java.io.Serializable
public class InventoryMonthReport
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_ENDAMOUNT
static java.lang.String | ORDER_BY_ENDCOST
static java.lang.String | ORDER_BY_ENDQAAMOUNT
static java.lang.String | ORDER_BY_ENDQAQTY
static java.lang.String | ORDER_BY_ENDQTY
static java.lang.String | ORDER_BY_ENDWIPAMOUNT
static java.lang.String | ORDER_BY_ENDWIPQTY
static java.lang.String | ORDER_BY_INAMOUNT
static java.lang.String | ORDER_BY_INCOST
static java.lang.String | ORDER_BY_INQTY
static java.lang.String | ORDER_BY_LOCATION
static java.lang.String | ORDER_BY_OUTAMOUNT
static java.lang.String | ORDER_BY_OUTCOST
static java.lang.String | ORDER_BY_OUTQTY
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_SHIPPINGWEIGHT
static java.lang.String | ORDER_BY_SHIPPINGWEIGHTUNIT
static java.lang.String | ORDER_BY_STARTAMOUNT
static java.lang.String | ORDER_BY_STARTCOST
static java.lang.String | ORDER_BY_STARTQAAMOUNT
static java.lang.String | ORDER_BY_STARTQAQTY
static java.lang.String | ORDER_BY_STARTQTY
static java.lang.String | ORDER_BY_STARTWIPAMOUNT
static java.lang.String | ORDER_BY_STARTWIPQTY
Constructor Summary
InventoryMonthReport()
Method Summary
java.lang.String | getDescription()
java.math.BigDecimal | getEndAmount()
java.math.BigDecimal | getEndCost()
java.math.BigDecimal | getEndQaAmount()
java.math.BigDecimal | getEndQaQty()
java.math.BigDecimal | getEndQty()
java.math.BigDecimal | getEndWipAmount()
java.math.BigDecimal | getEndWipQty()
java.math.BigDecimal | getInAmount()
java.math.BigDecimal | getInCost()
java.math.BigDecimal | getInQty()
java.lang.String | getLocation()
java.math.BigDecimal | getOutAmount()
java.math.BigDecimal | getOutCost()
java.math.BigDecimal | getOutQty()
java.math.BigDecimal | getOverageAmount()
java.math.BigDecimal | getOverageQty()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getShippingWeight()
java.lang.String | getShippingWeightUnit()
java.math.BigDecimal | getShortageAmount()
java.math.BigDecimal | getShortageQty()
java.math.BigDecimal | getStartAmount()
java.math.BigDecimal | getStartCost()
java.math.BigDecimal | getStartQaAmount()
java.math.BigDecimal | getStartQaQty()
java.math.BigDecimal | getStartQty()
java.math.BigDecimal | getStartWipAmount()
java.math.BigDecimal | getStartWipQty()
java.math.BigDecimal | getStdCost()
void | setDescription(java.lang.String description)
void | setEndAmount(java.math.BigDecimal endAmount)
void | setEndCost(java.math.BigDecimal endCost)
void | setEndQaAmount(java.math.BigDecimal endQaAmount)
void | setEndQaQty(java.math.BigDecimal endQaQty)
void | setEndQty(java.math.BigDecimal endQty)
void | setEndWipAmount(java.math.BigDecimal endWipAmount)
void | setEndWipQty(java.math.BigDecimal endWipQty)
void | setInAmount(java.math.BigDecimal inAmount)
void | setInCost(java.math.BigDecimal inCost)
void | setInQty(java.math.BigDecimal inQty)
void | setLocation(java.lang.String location)
void | setOutAmount(java.math.BigDecimal outAmount)
void | setOutCost(java.math.BigDecimal outCost)
void | setOutQty(java.math.BigDecimal outQty)
void | setOverageAmount(java.math.BigDecimal overageAmount)
void | setOverageQty(java.math.BigDecimal overageQty)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setShippingWeight(java.math.BigDecimal shippingWeight)
void | setShippingWeightUnit(java.lang.String shippingWeightUnit)
void | setShortageAmount(java.math.BigDecimal shortageAmount)
void | setShortageQty(java.math.BigDecimal shortageQty)
void | setStartAmount(java.math.BigDecimal startAmount)
void | setStartCost(java.math.BigDecimal startCost)
void | setStartQaAmount(java.math.BigDecimal startQaAmount)
void | setStartQaQty(java.math.BigDecimal startQaQty)
void | setStartQty(java.math.BigDecimal startQty)
void | setStartWipAmount(java.math.BigDecimal startWipAmount)
void | setStartWipQty(java.math.BigDecimal startWipQty)
void | setStdCost(java.math.BigDecimal stdCost)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_STARTQTY

public static final java.lang.String ORDER_BY_STARTQTY
See Also:
Constant Field Values

ORDER_BY_STARTCOST

public static final java.lang.String ORDER_BY_STARTCOST
See Also:
Constant Field Values

ORDER_BY_STARTAMOUNT

public static final java.lang.String ORDER_BY_STARTAMOUNT
See Also:
Constant Field Values

ORDER_BY_INQTY

public static final java.lang.String ORDER_BY_INQTY
See Also:
Constant Field Values

ORDER_BY_INCOST

public static final java.lang.String ORDER_BY_INCOST
See Also:
Constant Field Values

ORDER_BY_INAMOUNT

public static final java.lang.String ORDER_BY_INAMOUNT
See Also:
Constant Field Values

ORDER_BY_OUTQTY

public static final java.lang.String ORDER_BY_OUTQTY
See Also:
Constant Field Values

ORDER_BY_OUTCOST

public static final java.lang.String ORDER_BY_OUTCOST
See Also:
Constant Field Values

ORDER_BY_OUTAMOUNT

public static final java.lang.String ORDER_BY_OUTAMOUNT
See Also:
Constant Field Values

ORDER_BY_ENDQTY

public static final java.lang.String ORDER_BY_ENDQTY
See Also:
Constant Field Values

ORDER_BY_ENDCOST

public static final java.lang.String ORDER_BY_ENDCOST
See Also:
Constant Field Values

ORDER_BY_ENDAMOUNT

public static final java.lang.String ORDER_BY_ENDAMOUNT
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_STARTQAQTY

public static final java.lang.String ORDER_BY_STARTQAQTY
See Also:
Constant Field Values

ORDER_BY_STARTWIPQTY

public static final java.lang.String ORDER_BY_STARTWIPQTY
See Also:
Constant Field Values

ORDER_BY_STARTQAAMOUNT

public static final java.lang.String ORDER_BY_STARTQAAMOUNT
See Also:
Constant Field Values

ORDER_BY_STARTWIPAMOUNT

public static final java.lang.String ORDER_BY_STARTWIPAMOUNT
See Also:
Constant Field Values

ORDER_BY_ENDQAQTY

public static final java.lang.String ORDER_BY_ENDQAQTY
See Also:
Constant Field Values

ORDER_BY_ENDWIPQTY

public static final java.lang.String ORDER_BY_ENDWIPQTY
See Also:
Constant Field Values

ORDER_BY_ENDQAAMOUNT

public static final java.lang.String ORDER_BY_ENDQAAMOUNT
See Also:
Constant Field Values

ORDER_BY_ENDWIPAMOUNT

public static final java.lang.String ORDER_BY_ENDWIPAMOUNT
See Also:
Constant Field Values

ORDER_BY_LOCATION

public static final java.lang.String ORDER_BY_LOCATION
See Also:
Constant Field Values

ORDER_BY_SHIPPINGWEIGHT

public static final java.lang.String ORDER_BY_SHIPPINGWEIGHT
See Also:
Constant Field Values

ORDER_BY_SHIPPINGWEIGHTUNIT

public static final java.lang.String ORDER_BY_SHIPPINGWEIGHTUNIT
See Also:
Constant Field Values
Constructor Detail

InventoryMonthReport

public InventoryMonthReport()
Method Detail

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getEndAmount

public java.math.BigDecimal getEndAmount()

setEndAmount

public void setEndAmount(java.math.BigDecimal endAmount)

getEndCost

public java.math.BigDecimal getEndCost()

setEndCost

public void setEndCost(java.math.BigDecimal endCost)

getEndQty

public java.math.BigDecimal getEndQty()

setEndQty

public void setEndQty(java.math.BigDecimal endQty)

getInCost

public java.math.BigDecimal getInCost()

setInCost

public void setInCost(java.math.BigDecimal inCost)

getInAmount

public java.math.BigDecimal getInAmount()

setInAmount

public void setInAmount(java.math.BigDecimal inAmount)

getInQty

public java.math.BigDecimal getInQty()

setInQty

public void setInQty(java.math.BigDecimal inQty)

getOutAmount

public java.math.BigDecimal getOutAmount()

setOutAmount

public void setOutAmount(java.math.BigDecimal outAmount)

getOutCost

public java.math.BigDecimal getOutCost()

setOutCost

public void setOutCost(java.math.BigDecimal outCost)

getOutQty

public java.math.BigDecimal getOutQty()

setOutQty

public void setOutQty(java.math.BigDecimal outQty)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getStartAmount

public java.math.BigDecimal getStartAmount()

setStartAmount

public void setStartAmount(java.math.BigDecimal startAmount)

getStartCost

public java.math.BigDecimal getStartCost()

setStartCost

public void setStartCost(java.math.BigDecimal startCost)

getStartQty

public java.math.BigDecimal getStartQty()

setStartQty

public void setStartQty(java.math.BigDecimal startQty)

getEndQaAmount

public java.math.BigDecimal getEndQaAmount()

setEndQaAmount

public void setEndQaAmount(java.math.BigDecimal endQaAmount)

getEndQaQty

public java.math.BigDecimal getEndQaQty()

setEndQaQty

public void setEndQaQty(java.math.BigDecimal endQaQty)

getEndWipAmount

public java.math.BigDecimal getEndWipAmount()

setEndWipAmount

public void setEndWipAmount(java.math.BigDecimal endWipAmount)

getEndWipQty

public java.math.BigDecimal getEndWipQty()

setEndWipQty

public void setEndWipQty(java.math.BigDecimal endWipQty)

getStartQaAmount

public java.math.BigDecimal getStartQaAmount()

setStartQaAmount

public void setStartQaAmount(java.math.BigDecimal startQaAmount)

getStartQaQty

public java.math.BigDecimal getStartQaQty()

setStartQaQty

public void setStartQaQty(java.math.BigDecimal startQaQty)

getStartWipAmount

public java.math.BigDecimal getStartWipAmount()

setStartWipAmount

public void setStartWipAmount(java.math.BigDecimal startWipAmount)

getStartWipQty

public java.math.BigDecimal getStartWipQty()

setStartWipQty

public void setStartWipQty(java.math.BigDecimal startWipQty)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getShippingWeight

public java.math.BigDecimal getShippingWeight()

setShippingWeight

public void setShippingWeight(java.math.BigDecimal shippingWeight)

getShippingWeightUnit

public java.lang.String getShippingWeightUnit()

setShippingWeightUnit

public void setShippingWeightUnit(java.lang.String shippingWeightUnit)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getOverageQty

public java.math.BigDecimal getOverageQty()

setOverageQty

public void setOverageQty(java.math.BigDecimal overageQty)

getOverageAmount

public java.math.BigDecimal getOverageAmount()

setOverageAmount

public void setOverageAmount(java.math.BigDecimal overageAmount)

getShortageQty

public java.math.BigDecimal getShortageQty()

setShortageQty

public void setShortageQty(java.math.BigDecimal shortageQty)

getShortageAmount

public java.math.BigDecimal getShortageAmount()

setShortageAmount

public void setShortageAmount(java.math.BigDecimal shortageAmount)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InventoryNotUsedInMonthsforAppResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InventoryNotUsedInMonthsforAppResult

java.lang.Object
    extended by  bb.common.InventoryNotUsedInMonthsResult
        extended by  bb.common.InventoryNotUsedInMonthsforAppResult
All Implemented Interfaces:
java.io.Serializable
public class InventoryNotUsedInMonthsforAppResult
extends InventoryNotUsedInMonthsResult

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_LASTINDATE
static java.lang.String | ORDER_BY_LASTOUTDATE
static java.lang.String | ORDER_BY_MODELNUMBER
static java.lang.String | ORDER_BY_ONHAND
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_SERIALNUMBER
static java.lang.String | ORDER_BY_STANDARDCOST
static java.lang.String | ORDER_BY_STOCKMONTH
static java.lang.String | ORDER_BY_TOTAL
static java.lang.String | ORDER_BY_UNIT
Fields inherited from class bb.common.InventoryNotUsedInMonthsResult
ORDER_BY_AVERAGECOST, ORDER_BY_LOCATE, ORDER_BY_PART
Constructor Summary
InventoryNotUsedInMonthsforAppResult()
Method Summary
java.lang.String | getModelNumber()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
int | getSerialNumber()
java.lang.Integer | getStockMonth()
java.lang.String | getUnit()
void | setModelNumber(java.lang.String modelNumber)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setSerialNumber(int serialNumber)
void | setStockMonth(java.lang.Integer stockMonth)
void | setUnit(java.lang.String unit)
Methods inherited from class bb.common.InventoryNotUsedInMonthsResult
getAvgCost, getBill, getDescription, getDwg, getExtAvgCost, getExtStdCost, getLastInDate, getLastOutDate, getLastUsedDate, getLocate, getOnhand, getPart, getRev, getStdCost, setAvgCost, setBill, setDescription, setDwg, setExtAvgCost, setExtStdCost, setLastInDate, setLastOutDate, setLastUsedDate, setLocate, setOnhand, setPart, setRev, setStdCost
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_ONHAND

public static final java.lang.String ORDER_BY_ONHAND
See Also:
Constant Field Values

ORDER_BY_UNIT

public static final java.lang.String ORDER_BY_UNIT
See Also:
Constant Field Values

ORDER_BY_MODELNUMBER

public static final java.lang.String ORDER_BY_MODELNUMBER
See Also:
Constant Field Values

ORDER_BY_STANDARDCOST

public static final java.lang.String ORDER_BY_STANDARDCOST
See Also:
Constant Field Values

ORDER_BY_TOTAL

public static final java.lang.String ORDER_BY_TOTAL
See Also:
Constant Field Values

ORDER_BY_STOCKMONTH

public static final java.lang.String ORDER_BY_STOCKMONTH
See Also:
Constant Field Values

ORDER_BY_LASTOUTDATE

public static final java.lang.String ORDER_BY_LASTOUTDATE
See Also:
Constant Field Values

ORDER_BY_LASTINDATE

public static final java.lang.String ORDER_BY_LASTINDATE
See Also:
Constant Field Values

ORDER_BY_SERIALNUMBER

public static final java.lang.String ORDER_BY_SERIALNUMBER
See Also:
Constant Field Values
Constructor Detail

InventoryNotUsedInMonthsforAppResult

public InventoryNotUsedInMonthsforAppResult()
Method Detail

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getStockMonth

public java.lang.Integer getStockMonth()

setStockMonth

public void setStockMonth(java.lang.Integer stockMonth)

getSerialNumber

public int getSerialNumber()

setSerialNumber

public void setSerialNumber(int serialNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InventoryNotUsedInMonthsResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InventoryNotUsedInMonthsResult

java.lang.Object
    extended by  bb.common.InventoryNotUsedInMonthsResult
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
InventoryNotUsedInMonthsforAppResult
public class InventoryNotUsedInMonthsResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AVERAGECOST
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_LASTINDATE
static java.lang.String | ORDER_BY_LASTOUTDATE
static java.lang.String | ORDER_BY_LOCATE
static java.lang.String | ORDER_BY_PART
static java.lang.String | ORDER_BY_STANDARDCOST
Constructor Summary
InventoryNotUsedInMonthsResult()
Method Summary
java.math.BigDecimal | getAvgCost()
java.lang.String | getBill()
java.lang.String | getDescription()
java.lang.String | getDwg()
java.math.BigDecimal | getExtAvgCost()
java.math.BigDecimal | getExtStdCost()
java.util.Date | getLastInDate()
java.util.Date | getLastOutDate()
java.util.Date | getLastUsedDate()
java.lang.String | getLocate()
java.math.BigDecimal | getOnhand()
BB2Part | getPart()
java.lang.String | getRev()
java.math.BigDecimal | getStdCost()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setBill(java.lang.String bill)
void | setDescription(java.lang.String description)
void | setDwg(java.lang.String dwg)
void | setExtAvgCost(java.math.BigDecimal extAvgCost)
void | setExtStdCost(java.math.BigDecimal extStdCost)
void | setLastInDate(java.util.Date lastInDate)
void | setLastOutDate(java.util.Date lastOutDate)
void | setLastUsedDate(java.util.Date lastUsedDate)
void | setLocate(java.lang.String locate)
void | setOnhand(java.math.BigDecimal onhand)
void | setPart(BB2Part part)
void | setRev(java.lang.String rev)
void | setStdCost(java.math.BigDecimal stdCost)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PART

public static final java.lang.String ORDER_BY_PART
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_LOCATE

public static final java.lang.String ORDER_BY_LOCATE
See Also:
Constant Field Values

ORDER_BY_LASTOUTDATE

public static final java.lang.String ORDER_BY_LASTOUTDATE
See Also:
Constant Field Values

ORDER_BY_LASTINDATE

public static final java.lang.String ORDER_BY_LASTINDATE
See Also:
Constant Field Values

ORDER_BY_STANDARDCOST

public static final java.lang.String ORDER_BY_STANDARDCOST
See Also:
Constant Field Values

ORDER_BY_AVERAGECOST

public static final java.lang.String ORDER_BY_AVERAGECOST
See Also:
Constant Field Values
Constructor Detail

InventoryNotUsedInMonthsResult

public InventoryNotUsedInMonthsResult()
Method Detail

setPart

public void setPart(BB2Part part)

setRev

public void setRev(java.lang.String rev)

setDwg

public void setDwg(java.lang.String dwg)

setBill

public void setBill(java.lang.String bill)

setDescription

public void setDescription(java.lang.String description)

setLocate

public void setLocate(java.lang.String locate)

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

setExtAvgCost

public void setExtAvgCost(java.math.BigDecimal extAvgCost)

setLastUsedDate

public void setLastUsedDate(java.util.Date lastUsedDate)

getPart

public BB2Part getPart()

getRev

public java.lang.String getRev()

getDwg

public java.lang.String getDwg()

getBill

public java.lang.String getBill()

getDescription

public java.lang.String getDescription()

getLocate

public java.lang.String getLocate()

getOnhand

public java.math.BigDecimal getOnhand()

getAvgCost

public java.math.BigDecimal getAvgCost()

getExtAvgCost

public java.math.BigDecimal getExtAvgCost()

getLastUsedDate

public java.util.Date getLastUsedDate()

getLastInDate

public java.util.Date getLastInDate()

setLastInDate

public void setLastInDate(java.util.Date lastInDate)

getLastOutDate

public java.util.Date getLastOutDate()

setLastOutDate

public void setLastOutDate(java.util.Date lastOutDate)

getExtStdCost

public java.math.BigDecimal getExtStdCost()

setExtStdCost

public void setExtStdCost(java.math.BigDecimal extStdCost)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InventoryNotUsedTotal

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InventoryNotUsedTotal

java.lang.Object
    extended by  bb.common.InventoryNotUsedTotal
All Implemented Interfaces:
java.io.Serializable
public class InventoryNotUsedTotal
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
InventoryNotUsedTotal()
Method Summary
java.math.BigDecimal | getTotalAvgCost()
java.math.BigDecimal | getTotalStdCost()
void | setTotalAvgCost(java.math.BigDecimal totalAvgCost)
void | setTotalStdCost(java.math.BigDecimal totalStdCost)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InventoryNotUsedTotal

public InventoryNotUsedTotal()
Method Detail

getTotalAvgCost

public java.math.BigDecimal getTotalAvgCost()

setTotalAvgCost

public void setTotalAvgCost(java.math.BigDecimal totalAvgCost)

getTotalStdCost

public java.math.BigDecimal getTotalStdCost()

setTotalStdCost

public void setTotalStdCost(java.math.BigDecimal totalStdCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InventoryPartInOutDetailListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InventoryPartInOutDetailListResult

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.InventoryPartInOutDetailListResult
All Implemented Interfaces:
java.io.Serializable
public class InventoryPartInOutDetailListResult
extends VO

See Also:
Serialized Form

Constructor Summary
InventoryPartInOutDetailListResult()
Method Summary
java.lang.String | getComments()
java.math.BigDecimal | getCostPerUnit()
java.lang.String | getDesc()
java.math.BigDecimal | getInQty()
java.math.BigDecimal | getInTotalCost()
java.lang.String | getModel()
java.lang.String | getOrderNumber()
java.math.BigDecimal | getOutQty()
java.math.BigDecimal | getOutTotalCost()
java.math.BigDecimal | getOverageAmount()
java.math.BigDecimal | getOverageQty()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getPeriodNumber()
java.math.BigDecimal | getPeriodTotalCost()
int | getSer()
java.math.BigDecimal | getShortageAmount()
java.math.BigDecimal | getShortageQty()
java.math.BigDecimal | getTotalCost()
java.math.BigDecimal | getTotalQty()
java.lang.String | getUnit()
void | setComments(java.lang.String comments)
void | setCostPerUnit(java.math.BigDecimal costPerUnit)
void | setDesc(java.lang.String desc)
void | setInQty(java.math.BigDecimal inQty)
void | setInTotalCost(java.math.BigDecimal inTotalCost)
void | setModel(java.lang.String model)
void | setOrderNumber(java.lang.String orderNumber)
void | setOutQty(java.math.BigDecimal outQty)
void | setOutTotalCost(java.math.BigDecimal outTotalCost)
void | setOverageAmount(java.math.BigDecimal overageAmount)
void | setOverageQty(java.math.BigDecimal overageQty)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPeriodNumber(java.math.BigDecimal periodNumber)
void | setPeriodTotalCost(java.math.BigDecimal periodTotalCost)
void | setSer(int ser)
void | setShortageAmount(java.math.BigDecimal shortageAmount)
void | setShortageQty(java.math.BigDecimal shortageQty)
void | setTotalCost(java.math.BigDecimal totalCost)
void | setTotalQty(java.math.BigDecimal totalQty)
void | setUnit(java.lang.String unit)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InventoryPartInOutDetailListResult

public InventoryPartInOutDetailListResult()
Method Detail

getSer

public int getSer()

setSer

public void setSer(int ser)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getOrderNumber

public java.lang.String getOrderNumber()

setOrderNumber

public void setOrderNumber(java.lang.String orderNumber)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getModel

public java.lang.String getModel()

setModel

public void setModel(java.lang.String model)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getCostPerUnit

public java.math.BigDecimal getCostPerUnit()

setCostPerUnit

public void setCostPerUnit(java.math.BigDecimal costPerUnit)

getPeriodNumber

public java.math.BigDecimal getPeriodNumber()

setPeriodNumber

public void setPeriodNumber(java.math.BigDecimal periodNumber)

getPeriodTotalCost

public java.math.BigDecimal getPeriodTotalCost()

setPeriodTotalCost

public void setPeriodTotalCost(java.math.BigDecimal periodTotalCost)

getInQty

public java.math.BigDecimal getInQty()

setInQty

public void setInQty(java.math.BigDecimal inQty)

getInTotalCost

public java.math.BigDecimal getInTotalCost()

setInTotalCost

public void setInTotalCost(java.math.BigDecimal inTotalCost)

getOutQty

public java.math.BigDecimal getOutQty()

setOutQty

public void setOutQty(java.math.BigDecimal outQty)

getOutTotalCost

public java.math.BigDecimal getOutTotalCost()

setOutTotalCost

public void setOutTotalCost(java.math.BigDecimal outTotalCost)

getTotalQty

public java.math.BigDecimal getTotalQty()

setTotalQty

public void setTotalQty(java.math.BigDecimal totalQty)

getTotalCost

public java.math.BigDecimal getTotalCost()

setTotalCost

public void setTotalCost(java.math.BigDecimal totalCost)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getDesc

public java.lang.String getDesc()

setDesc

public void setDesc(java.lang.String desc)

getOverageQty

public java.math.BigDecimal getOverageQty()

setOverageQty

public void setOverageQty(java.math.BigDecimal overageQty)

getOverageAmount

public java.math.BigDecimal getOverageAmount()

setOverageAmount

public void setOverageAmount(java.math.BigDecimal overageAmount)

getShortageQty

public java.math.BigDecimal getShortageQty()

setShortageQty

public void setShortageQty(java.math.BigDecimal shortageQty)

getShortageAmount

public java.math.BigDecimal getShortageAmount()

setShortageAmount

public void setShortageAmount(java.math.BigDecimal shortageAmount)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InventoryReportListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InventoryReportListResult

java.lang.Object
    extended by  bb.common.InventoryReportListResult
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
InventoryAuditReportResult
public class InventoryReportListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_PARTDESCRIPTION
static java.lang.String | ORDER_BY_PARTNUMBER
Constructor Summary
InventoryReportListResult()
Method Summary
java.math.BigDecimal | getBeginCost(int length)
java.util.Date | getDateFrom()
java.util.Date | getDateTo()
java.math.BigDecimal | getEndCost(int length)
java.math.BigDecimal | getNewLnQty()
java.math.BigDecimal | getNewQaQty()
java.math.BigDecimal | getNewSipQty()
java.math.BigDecimal | getNewSitQty()
java.math.BigDecimal | getOldLnQty()
java.math.BigDecimal | getOldQaQty()
java.math.BigDecimal | getOldSipQty()
java.math.BigDecimal | getOldSitQty()
java.lang.String | getPartDescription()
java.lang.String | getPartNumber()
PartPK | getPartPK()
java.lang.String | getPartType()
java.math.BigDecimal | getTotalIssued()
java.math.BigDecimal | getTotalIssuedMoney()
java.math.BigDecimal | getTotalNewCost()
java.math.BigDecimal | getTotalNewOnhand()
java.math.BigDecimal | getTotalOldCost()
java.math.BigDecimal | getTotalOldOnhand()
java.math.BigDecimal | getTotalReceived()
java.math.BigDecimal | getTotalRecMoney()
void | setDateFrom(java.util.Date dateFrom)
void | setDateTo(java.util.Date dateTo)
void | setNewLnQty(java.math.BigDecimal newLnQty)
void | setNewQaQty(java.math.BigDecimal newQaQty)
void | setNewSipQty(java.math.BigDecimal newSipQty)
void | setNewSitQty(java.math.BigDecimal newSitQty)
void | setOldLnQty(java.math.BigDecimal oldLnQty)
void | setOldQaQty(java.math.BigDecimal oldQaQty)
void | setOldSipQty(java.math.BigDecimal oldSipQty)
void | setOldSitQty(java.math.BigDecimal oldSitQty)
void | setPartDescription(java.lang.String partDescription)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setTotalIssued(java.math.BigDecimal totalIssued)
void | setTotalIssuedMoney(java.math.BigDecimal totalIssuedMoney)
void | setTotalNewCost(java.math.BigDecimal totalNewCost)
void | setTotalNewOnhand(java.math.BigDecimal totalNewOnhand)
void | setTotalOldCost(java.math.BigDecimal totalOldCost)
void | setTotalOldOnhand(java.math.BigDecimal totalOldOnhand)
void | setTotalReceived(java.math.BigDecimal totalReceived)
void | setTotalRecMoney(java.math.BigDecimal totalRecMoney)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTDESCRIPTION

public static final java.lang.String ORDER_BY_PARTDESCRIPTION
See Also:
Constant Field Values
Constructor Detail

InventoryReportListResult

public InventoryReportListResult()
Method Detail

getDateFrom

public java.util.Date getDateFrom()

setDateFrom

public void setDateFrom(java.util.Date dateFrom)

getDateTo

public java.util.Date getDateTo()

setDateTo

public void setDateTo(java.util.Date dateTo)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartDescription

public java.lang.String getPartDescription()

setPartDescription

public void setPartDescription(java.lang.String partDescription)

getNewLnQty

public java.math.BigDecimal getNewLnQty()

setNewLnQty

public void setNewLnQty(java.math.BigDecimal newLnQty)

getNewQaQty

public java.math.BigDecimal getNewQaQty()

setNewQaQty

public void setNewQaQty(java.math.BigDecimal newQaQty)

getNewSipQty

public java.math.BigDecimal getNewSipQty()

setNewSipQty

public void setNewSipQty(java.math.BigDecimal newSipQty)

getNewSitQty

public java.math.BigDecimal getNewSitQty()

setNewSitQty

public void setNewSitQty(java.math.BigDecimal newSitQty)

getOldLnQty

public java.math.BigDecimal getOldLnQty()

setOldLnQty

public void setOldLnQty(java.math.BigDecimal oldLnQty)

getOldQaQty

public java.math.BigDecimal getOldQaQty()

setOldQaQty

public void setOldQaQty(java.math.BigDecimal oldQaQty)

getOldSipQty

public java.math.BigDecimal getOldSipQty()

setOldSipQty

public void setOldSipQty(java.math.BigDecimal oldSipQty)

getOldSitQty

public java.math.BigDecimal getOldSitQty()

setOldSitQty

public void setOldSitQty(java.math.BigDecimal oldSitQty)

getTotalIssued

public java.math.BigDecimal getTotalIssued()

setTotalIssued

public void setTotalIssued(java.math.BigDecimal totalIssued)

getTotalIssuedMoney

public java.math.BigDecimal getTotalIssuedMoney()

setTotalIssuedMoney

public void setTotalIssuedMoney(java.math.BigDecimal totalIssuedMoney)

getTotalNewCost

public java.math.BigDecimal getTotalNewCost()

setTotalNewCost

public void setTotalNewCost(java.math.BigDecimal totalNewCost)

getTotalNewOnhand

public java.math.BigDecimal getTotalNewOnhand()

setTotalNewOnhand

public void setTotalNewOnhand(java.math.BigDecimal totalNewOnhand)

getTotalOldCost

public java.math.BigDecimal getTotalOldCost()

setTotalOldCost

public void setTotalOldCost(java.math.BigDecimal totalOldCost)

getTotalOldOnhand

public java.math.BigDecimal getTotalOldOnhand()

setTotalOldOnhand

public void setTotalOldOnhand(java.math.BigDecimal totalOldOnhand)

getTotalReceived

public java.math.BigDecimal getTotalReceived()

setTotalReceived

public void setTotalReceived(java.math.BigDecimal totalReceived)

getTotalRecMoney

public java.math.BigDecimal getTotalRecMoney()

setTotalRecMoney

public void setTotalRecMoney(java.math.BigDecimal totalRecMoney)

getBeginCost

public java.math.BigDecimal getBeginCost(int length)

getEndCost

public java.math.BigDecimal getEndCost(int length)

getPartPK

public PartPK getPartPK()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InventoryTotalCostResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InventoryTotalCostResult

java.lang.Object
    extended by  bb.common.InventoryTotalCostResult
All Implemented Interfaces:
java.io.Serializable
public class InventoryTotalCostResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
InventoryTotalCostResult()
Method Summary
java.util.Date | getDate()
java.math.BigDecimal | getTotalInQaAvgCost()
java.math.BigDecimal | getTotalInQaListPrice()
java.math.BigDecimal | getTotalInQaStdCost()
java.math.BigDecimal | getTotalInSipAvgCost()
java.math.BigDecimal | getTotalInSipListPrice()
java.math.BigDecimal | getTotalInSipStdCost()
java.math.BigDecimal | getTotalInSTOAvgCost()
java.math.BigDecimal | getTotalInSTOListPrice()
java.math.BigDecimal | getTotalInSTOStdCost()
java.math.BigDecimal | getTotalInventoryAvgCost()
java.math.BigDecimal | getTotalInventoryListPrice()
java.math.BigDecimal | getTotalInventoryStdCost()
java.math.BigDecimal | getTotalInWipAvgCost()
java.math.BigDecimal | getTotalInWipListPrice()
java.math.BigDecimal | getTotalInWipStdCost()
java.math.BigDecimal | getTotalOnhandAvgCost()
java.math.BigDecimal | getTotalOnhandListPrice()
java.math.BigDecimal | getTotalOnhandStdCost()
java.math.BigDecimal | getTotalOnLoanAvgCost()
java.math.BigDecimal | getTotalOnLoanListPrice()
java.math.BigDecimal | getTotalOnLoanStdCost()
void | setDate(java.util.Date date)
void | setTotalInQaAvgCost(java.math.BigDecimal totalInQaAvgCost)
void | setTotalInQaListPrice(java.math.BigDecimal totalInQaListPrice)
void | setTotalInQaStdCost(java.math.BigDecimal totalInQaStdCost)
void | setTotalInSipAvgCost(java.math.BigDecimal totalInSipAvgCost)
void | setTotalInSipListPrice(java.math.BigDecimal totalInSipListPrice)
void | setTotalInSipStdCost(java.math.BigDecimal totalInSipStdCost)
void | setTotalInSTOAvgCost(java.math.BigDecimal totalInSTOAvgCost)
void | setTotalInSTOListPrice(java.math.BigDecimal totalInSTOListPrice)
void | setTotalInSTOStdCost(java.math.BigDecimal totalInSTOStdCost)
void | setTotalInventoryAvgCost(java.math.BigDecimal totalInventoryAvgCost)
void | setTotalInventoryListPrice(java.math.BigDecimal totalInventoryListPrice)
void | setTotalInventoryStdCost(java.math.BigDecimal totalInventoryStdCost)
void | setTotalInWipAvgCost(java.math.BigDecimal totalInWipAvgCost)
void | setTotalInWipListPrice(java.math.BigDecimal totalInWipListPrice)
void | setTotalInWipStdCost(java.math.BigDecimal totalInWipStdCost)
void | setTotalOnhandAvgCost(java.math.BigDecimal totalOnhandAvgCost)
void | setTotalOnhandListPrice(java.math.BigDecimal totalOnhandListPrice)
void | setTotalOnhandStdCost(java.math.BigDecimal totalOnhandStdCost)
void | setTotalOnLoanAvgCost(java.math.BigDecimal totalOnLoanAvgCost)
void | setTotalOnLoanListPrice(java.math.BigDecimal totalOnLoanListPrice)
void | setTotalOnLoanStdCost(java.math.BigDecimal totalOnLoanStdCost)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InventoryTotalCostResult

public InventoryTotalCostResult()
Method Detail

getTotalInQaAvgCost

public java.math.BigDecimal getTotalInQaAvgCost()

setTotalInQaAvgCost

public void setTotalInQaAvgCost(java.math.BigDecimal totalInQaAvgCost)

getTotalInQaListPrice

public java.math.BigDecimal getTotalInQaListPrice()

setTotalInQaListPrice

public void setTotalInQaListPrice(java.math.BigDecimal totalInQaListPrice)

getTotalInQaStdCost

public java.math.BigDecimal getTotalInQaStdCost()

setTotalInQaStdCost

public void setTotalInQaStdCost(java.math.BigDecimal totalInQaStdCost)

getTotalInSipAvgCost

public java.math.BigDecimal getTotalInSipAvgCost()

setTotalInSipAvgCost

public void setTotalInSipAvgCost(java.math.BigDecimal totalInSipAvgCost)

getTotalInSipListPrice

public java.math.BigDecimal getTotalInSipListPrice()

setTotalInSipListPrice

public void setTotalInSipListPrice(java.math.BigDecimal totalInSipListPrice)

getTotalInSipStdCost

public java.math.BigDecimal getTotalInSipStdCost()

setTotalInSipStdCost

public void setTotalInSipStdCost(java.math.BigDecimal totalInSipStdCost)

getTotalInventoryAvgCost

public java.math.BigDecimal getTotalInventoryAvgCost()

setTotalInventoryAvgCost

public void setTotalInventoryAvgCost(java.math.BigDecimal totalInventoryAvgCost)

getTotalInventoryListPrice

public java.math.BigDecimal getTotalInventoryListPrice()

setTotalInventoryListPrice

public void setTotalInventoryListPrice(java.math.BigDecimal totalInventoryListPrice)

getTotalInventoryStdCost

public java.math.BigDecimal getTotalInventoryStdCost()

setTotalInventoryStdCost

public void setTotalInventoryStdCost(java.math.BigDecimal totalInventoryStdCost)

getTotalInWipAvgCost

public java.math.BigDecimal getTotalInWipAvgCost()

setTotalInWipAvgCost

public void setTotalInWipAvgCost(java.math.BigDecimal totalInWipAvgCost)

getTotalInWipListPrice

public java.math.BigDecimal getTotalInWipListPrice()

setTotalInWipListPrice

public void setTotalInWipListPrice(java.math.BigDecimal totalInWipListPrice)

getTotalInWipStdCost

public java.math.BigDecimal getTotalInWipStdCost()

setTotalInWipStdCost

public void setTotalInWipStdCost(java.math.BigDecimal totalInWipStdCost)

getTotalOnhandAvgCost

public java.math.BigDecimal getTotalOnhandAvgCost()

setTotalOnhandAvgCost

public void setTotalOnhandAvgCost(java.math.BigDecimal totalOnhandAvgCost)

getTotalOnhandListPrice

public java.math.BigDecimal getTotalOnhandListPrice()

setTotalOnhandListPrice

public void setTotalOnhandListPrice(java.math.BigDecimal totalOnhandListPrice)

getTotalOnhandStdCost

public java.math.BigDecimal getTotalOnhandStdCost()

setTotalOnhandStdCost

public void setTotalOnhandStdCost(java.math.BigDecimal totalOnhandStdCost)

getDate

public java.util.Date getDate()

setDate

public void setDate(java.util.Date date)

getTotalOnLoanAvgCost

public java.math.BigDecimal getTotalOnLoanAvgCost()

setTotalOnLoanAvgCost

public void setTotalOnLoanAvgCost(java.math.BigDecimal totalOnLoanAvgCost)

getTotalOnLoanListPrice

public java.math.BigDecimal getTotalOnLoanListPrice()

setTotalOnLoanListPrice

public void setTotalOnLoanListPrice(java.math.BigDecimal totalOnLoanListPrice)

getTotalOnLoanStdCost

public java.math.BigDecimal getTotalOnLoanStdCost()

setTotalOnLoanStdCost

public void setTotalOnLoanStdCost(java.math.BigDecimal totalOnLoanStdCost)

getTotalInSTOAvgCost

public java.math.BigDecimal getTotalInSTOAvgCost()

setTotalInSTOAvgCost

public void setTotalInSTOAvgCost(java.math.BigDecimal totalInSTOAvgCost)

getTotalInSTOListPrice

public java.math.BigDecimal getTotalInSTOListPrice()

setTotalInSTOListPrice

public void setTotalInSTOListPrice(java.math.BigDecimal totalInSTOListPrice)

getTotalInSTOStdCost

public java.math.BigDecimal getTotalInSTOStdCost()

setTotalInSTOStdCost

public void setTotalInSTOStdCost(java.math.BigDecimal totalInSTOStdCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InventoryTotalResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InventoryTotalResult

java.lang.Object
    extended by  bb.common.InventoryTotalResult
All Implemented Interfaces:
java.io.Serializable
public class InventoryTotalResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
InventoryTotalResult()
Method Summary
java.math.BigDecimal | getMaxQtyByAvgCost()
java.math.BigDecimal | getMaxQtyByStdCost()
java.math.BigDecimal | getMinQtyByAvgCost()
java.math.BigDecimal | getMinQtyByStdCost()
java.math.BigDecimal | getOndemandByAvgCost()
java.math.BigDecimal | getOndemandByStdCost()
java.math.BigDecimal | getOnorderByAvgCost()
java.math.BigDecimal | getOnorderByStdCost()
java.math.BigDecimal | getTotalInQaByAvgCost()
java.math.BigDecimal | getTotalInQaByStdCost()
java.math.BigDecimal | getTotalInShippingNotArByAvgCost()
java.math.BigDecimal | getTotalInShippingNotArByStdCost()
java.math.BigDecimal | getTotalInWareHouseByAvgCost()
java.math.BigDecimal | getTotalInWareHouseByStdCost()
java.math.BigDecimal | getTotalInWipByAvgCost()
java.math.BigDecimal | getTotalInWipByStdCost()
java.math.BigDecimal | getTotalOnconsignmentByAvgCost()
java.math.BigDecimal | getTotalOnconsignmentByStdCost()
java.math.BigDecimal | getTotalOnloanByAvgCost()
java.math.BigDecimal | getTotalOnloanByStdCost()
void | setMaxQtyByAvgCost(java.math.BigDecimal maxQtyByAvgCost)
void | setMaxQtyByStdCost(java.math.BigDecimal maxQtyByStdCost)
void | setMinQtyByAvgCost(java.math.BigDecimal minQtyByAvgCost)
void | setMinQtyByStdCost(java.math.BigDecimal minQtyByStdCost)
void | setOndemandByAvgCost(java.math.BigDecimal ondemandByAvgCost)
void | setOndemandByStdCost(java.math.BigDecimal ondemandByStdCost)
void | setOnorderByAvgCost(java.math.BigDecimal onorderByAvgCost)
void | setOnorderByStdCost(java.math.BigDecimal onorderByStdCost)
void | setTotalInQaByAvgCost(java.math.BigDecimal totalInQaByAvgCost)
void | setTotalInQaByStdCost(java.math.BigDecimal totalInQaByStdCost)
void | setTotalInShippingNotArByAvgCost(java.math.BigDecimal totalInShippingNotArByAvgCost)
void | setTotalInShippingNotArByStdCost(java.math.BigDecimal totalInShippingNotArByStdCost)
void | setTotalInWareHouseByAvgCost(java.math.BigDecimal totalInWareHouseByAvgCost)
void | setTotalInWareHouseByStdCost(java.math.BigDecimal totalInWareHouseByStdCost)
void | setTotalInWipByAvgCost(java.math.BigDecimal totalInWipByAvgCost)
void | setTotalInWipByStdCost(java.math.BigDecimal totalInWipByStdCost)
void | setTotalOnconsignmentByAvgCost(java.math.BigDecimal totalOnconsignmentByAvgCost)
void | setTotalOnconsignmentByStdCost(java.math.BigDecimal totalOnconsignmentByStdCost)
void | setTotalOnloanByAvgCost(java.math.BigDecimal totalOnloanByAvgCost)
void | setTotalOnloanByStdCost(java.math.BigDecimal totalOnloanByStdCost)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InventoryTotalResult

public InventoryTotalResult()
Method Detail

getMaxQtyByAvgCost

public java.math.BigDecimal getMaxQtyByAvgCost()

setMaxQtyByAvgCost

public void setMaxQtyByAvgCost(java.math.BigDecimal maxQtyByAvgCost)

getMaxQtyByStdCost

public java.math.BigDecimal getMaxQtyByStdCost()

setMaxQtyByStdCost

public void setMaxQtyByStdCost(java.math.BigDecimal maxQtyByStdCost)

getMinQtyByAvgCost

public java.math.BigDecimal getMinQtyByAvgCost()

setMinQtyByAvgCost

public void setMinQtyByAvgCost(java.math.BigDecimal minQtyByAvgCost)

getMinQtyByStdCost

public java.math.BigDecimal getMinQtyByStdCost()

setMinQtyByStdCost

public void setMinQtyByStdCost(java.math.BigDecimal minQtyByStdCost)

getOndemandByAvgCost

public java.math.BigDecimal getOndemandByAvgCost()

setOndemandByAvgCost

public void setOndemandByAvgCost(java.math.BigDecimal ondemandByAvgCost)

getOndemandByStdCost

public java.math.BigDecimal getOndemandByStdCost()

setOndemandByStdCost

public void setOndemandByStdCost(java.math.BigDecimal ondemandByStdCost)

getOnorderByAvgCost

public java.math.BigDecimal getOnorderByAvgCost()

setOnorderByAvgCost

public void setOnorderByAvgCost(java.math.BigDecimal onorderByAvgCost)

getOnorderByStdCost

public java.math.BigDecimal getOnorderByStdCost()

setOnorderByStdCost

public void setOnorderByStdCost(java.math.BigDecimal onorderByStdCost)

getTotalInQaByAvgCost

public java.math.BigDecimal getTotalInQaByAvgCost()

setTotalInQaByAvgCost

public void setTotalInQaByAvgCost(java.math.BigDecimal totalInQaByAvgCost)

getTotalInQaByStdCost

public java.math.BigDecimal getTotalInQaByStdCost()

setTotalInQaByStdCost

public void setTotalInQaByStdCost(java.math.BigDecimal totalInQaByStdCost)

getTotalInShippingNotArByAvgCost

public java.math.BigDecimal getTotalInShippingNotArByAvgCost()

setTotalInShippingNotArByAvgCost

public void setTotalInShippingNotArByAvgCost(java.math.BigDecimal totalInShippingNotArByAvgCost)

getTotalInShippingNotArByStdCost

public java.math.BigDecimal getTotalInShippingNotArByStdCost()

setTotalInShippingNotArByStdCost

public void setTotalInShippingNotArByStdCost(java.math.BigDecimal totalInShippingNotArByStdCost)

getTotalInWareHouseByAvgCost

public java.math.BigDecimal getTotalInWareHouseByAvgCost()

setTotalInWareHouseByAvgCost

public void setTotalInWareHouseByAvgCost(java.math.BigDecimal totalInWareHouseByAvgCost)

getTotalInWareHouseByStdCost

public java.math.BigDecimal getTotalInWareHouseByStdCost()

setTotalInWareHouseByStdCost

public void setTotalInWareHouseByStdCost(java.math.BigDecimal totalInWareHouseByStdCost)

getTotalInWipByAvgCost

public java.math.BigDecimal getTotalInWipByAvgCost()

setTotalInWipByAvgCost

public void setTotalInWipByAvgCost(java.math.BigDecimal totalInWipByAvgCost)

getTotalInWipByStdCost

public java.math.BigDecimal getTotalInWipByStdCost()

setTotalInWipByStdCost

public void setTotalInWipByStdCost(java.math.BigDecimal totalInWipByStdCost)

getTotalOnconsignmentByAvgCost

public java.math.BigDecimal getTotalOnconsignmentByAvgCost()

setTotalOnconsignmentByAvgCost

public void setTotalOnconsignmentByAvgCost(java.math.BigDecimal totalOnconsignmentByAvgCost)

getTotalOnconsignmentByStdCost

public java.math.BigDecimal getTotalOnconsignmentByStdCost()

setTotalOnconsignmentByStdCost

public void setTotalOnconsignmentByStdCost(java.math.BigDecimal totalOnconsignmentByStdCost)

getTotalOnloanByAvgCost

public java.math.BigDecimal getTotalOnloanByAvgCost()

setTotalOnloanByAvgCost

public void setTotalOnloanByAvgCost(java.math.BigDecimal totalOnloanByAvgCost)

getTotalOnloanByStdCost

public java.math.BigDecimal getTotalOnloanByStdCost()

setTotalOnloanByStdCost

public void setTotalOnloanByStdCost(java.math.BigDecimal totalOnloanByStdCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InvoiceAgingItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InvoiceAgingItemListResult

java.lang.Object
    extended by  bb.common.InvoiceItemListResult
        extended by  bb.common.InvoiceAgingItemListResult
All Implemented Interfaces:
java.io.Serializable
public class InvoiceAgingItemListResult
extends InvoiceItemListResult
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_DATEINVOICED
static java.lang.String | ORDER_BY_INVOICENUMBER
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PAYDATE
Fields inherited from class bb.common.InvoiceItemListResult
ORDER_BY_COMPANYUNITID, ORDER_BY_CREDITACCOUNT, ORDER_BY_CURRENCY, ORDER_BY_CUSTOMERPO, ORDER_BY_CUSTOMERTOCOUNTRY, ORDER_BY_CUSTOMERTOSTATE, ORDER_BY_PAIDDATE, ORDER_BY_PRODUCTCODE, ORDER_BY_SALESORDERNUMBER, ORDER_BY_SHIPPERNUMBER, ORDER_BY_SHIPTOCOUNTRY, ORDER_BY_SHIPTOID, ORDER_BY_SHIPTOSTATE
Constructor Summary
InvoiceAgingItemListResult()
Method Summary
Methods inherited from class bb.common.InvoiceItemListResult
getCompanyUnitId, getCreditAccount, getCurrency, getCustomerId, getCustomerPo, getCustomerToCountry, getCustomerTostate, getDateInvoiced, getDescription, getDicount, getDue, getExtPrice, getInvoiceItemNumber, getInvoiceNumber, getMargin, getMarginPercent, getPaidDate, getPartFrom, getPartNumber, getPartType, getPayDate, getProductCode, getQtyOrdered, getQtyShipped, getSalesOrderNumber, getShipperNumber, getShipToCountry, getShipToId, getShipToState, getStatus, getTaxRate, getUnitPrice, setCompanyUnitId, setCreditAccount, setCurrency, setCustomerId, setCustomerPo, setCustomerToCountry, setCustomerTostate, setDateInvoiced, setDescription, setDicount, setDue, setExtPrice, setInvoiceItemNumber, setInvoiceNumber, setMargin, setMarginPercent, setPaidDate, setPartFrom, setPartNumber, setPartType, setPayDate, setProductCode, setQtyOrdered, setQtyShipped, setSalesOrderNumber, setShipperNumber, setShipToCountry, setShipToId, setShipToState, setStatus, setTaxRate, setUnitPrice
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PAYDATE

public static final java.lang.String ORDER_BY_PAYDATE
See Also:
Constant Field Values

ORDER_BY_INVOICENUMBER

public static final java.lang.String ORDER_BY_INVOICENUMBER
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_DATEINVOICED

public static final java.lang.String ORDER_BY_DATEINVOICED
See Also:
Constant Field Values
Constructor Detail

InvoiceAgingItemListResult

public InvoiceAgingItemListResult()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InvoiceItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InvoiceItemListResult

java.lang.Object
    extended by  bb.common.InvoiceItemListResult
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
CheckInvoiceItemListResult, InvoiceAgingItemListResult
public class InvoiceItemListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_COMPANYUNITID
static java.lang.String | ORDER_BY_CREDITACCOUNT
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_CUSTOMERPO
static java.lang.String | ORDER_BY_CUSTOMERTOCOUNTRY
static java.lang.String | ORDER_BY_CUSTOMERTOSTATE
static java.lang.String | ORDER_BY_DATEINVOICED
static java.lang.String | ORDER_BY_INVOICENUMBER
static java.lang.String | ORDER_BY_PAIDDATE
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PAYDATE
static java.lang.String | ORDER_BY_PRODUCTCODE
static java.lang.String | ORDER_BY_SALESORDERNUMBER
static java.lang.String | ORDER_BY_SHIPPERNUMBER
static java.lang.String | ORDER_BY_SHIPTOCOUNTRY
static java.lang.String | ORDER_BY_SHIPTOID
static java.lang.String | ORDER_BY_SHIPTOSTATE
Constructor Summary
InvoiceItemListResult()
Method Summary
java.lang.String | getCompanyUnitId()
java.lang.String | getCreditAccount()
java.lang.String | getCurrency()
java.lang.String | getCustomerId()
java.lang.String | getCustomerPo()
java.lang.String | getCustomerToCountry()
java.lang.String | getCustomerTostate()
java.util.Date | getDateInvoiced()
java.lang.String | getDescription()
java.math.BigDecimal | getDicount()
java.math.BigDecimal | getDue()
java.math.BigDecimal | getExtPrice()
java.lang.String | getInvoiceItemNumber()
java.lang.String | getInvoiceNumber()
java.math.BigDecimal | getMargin()
java.math.BigDecimal | getMarginPercent()
java.util.Date | getPaidDate()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.util.Date | getPayDate()
java.lang.String | getProductCode()
java.math.BigDecimal | getQtyOrdered()
java.math.BigDecimal | getQtyShipped()
java.lang.String | getSalesOrderNumber()
java.lang.String | getShipperNumber()
java.lang.String | getShipToCountry()
java.lang.String | getShipToId()
java.lang.String | getShipToState()
java.lang.String | getStatus()
java.math.BigDecimal | getTaxRate()
java.math.BigDecimal | getUnitPrice()
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCreditAccount(java.lang.String creditAccount)
void | setCurrency(java.lang.String currency)
void | setCustomerId(java.lang.String customerId)
void | setCustomerPo(java.lang.String customerPo)
void | setCustomerToCountry(java.lang.String customerToCountry)
void | setCustomerTostate(java.lang.String customerTostate)
void | setDateInvoiced(java.util.Date dateInvoiced)
void | setDescription(java.lang.String description)
void | setDicount(java.math.BigDecimal dicount)
void | setDue(java.math.BigDecimal due)
void | setExtPrice(java.math.BigDecimal extPrice)
void | setInvoiceItemNumber(java.lang.String invoiceItemNumber)
void | setInvoiceNumber(java.lang.String invoiceNumber)
void | setMargin(java.math.BigDecimal margin)
void | setMarginPercent(java.math.BigDecimal marginPercent)
void | setPaidDate(java.util.Date paidDate)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPayDate(java.util.Date payDate)
void | setProductCode(java.lang.String productCode)
void | setQtyOrdered(java.math.BigDecimal qtyOrdered)
void | setQtyShipped(java.math.BigDecimal qtyShipped)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setShipperNumber(java.lang.String shipperNumber)
void | setShipToCountry(java.lang.String shipToCountry)
void | setShipToId(java.lang.String shipToId)
void | setShipToState(java.lang.String shipToState)
void | setStatus(java.lang.String status)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setUnitPrice(java.math.BigDecimal unitPrice)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PAYDATE

public static final java.lang.String ORDER_BY_PAYDATE
See Also:
Constant Field Values

ORDER_BY_INVOICENUMBER

public static final java.lang.String ORDER_BY_INVOICENUMBER
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_DATEINVOICED

public static final java.lang.String ORDER_BY_DATEINVOICED
See Also:
Constant Field Values

ORDER_BY_PAIDDATE

public static final java.lang.String ORDER_BY_PAIDDATE
See Also:
Constant Field Values

ORDER_BY_SALESORDERNUMBER

public static final java.lang.String ORDER_BY_SALESORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_CUSTOMERPO

public static final java.lang.String ORDER_BY_CUSTOMERPO
See Also:
Constant Field Values

ORDER_BY_SHIPTOID

public static final java.lang.String ORDER_BY_SHIPTOID
See Also:
Constant Field Values

ORDER_BY_SHIPTOSTATE

public static final java.lang.String ORDER_BY_SHIPTOSTATE
See Also:
Constant Field Values

ORDER_BY_SHIPTOCOUNTRY

public static final java.lang.String ORDER_BY_SHIPTOCOUNTRY
See Also:
Constant Field Values

ORDER_BY_COMPANYUNITID

public static final java.lang.String ORDER_BY_COMPANYUNITID
See Also:
Constant Field Values

ORDER_BY_CREDITACCOUNT

public static final java.lang.String ORDER_BY_CREDITACCOUNT
See Also:
Constant Field Values

ORDER_BY_SHIPPERNUMBER

public static final java.lang.String ORDER_BY_SHIPPERNUMBER
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values

ORDER_BY_PRODUCTCODE

public static final java.lang.String ORDER_BY_PRODUCTCODE
See Also:
Constant Field Values

ORDER_BY_CUSTOMERTOSTATE

public static final java.lang.String ORDER_BY_CUSTOMERTOSTATE
See Also:
Constant Field Values

ORDER_BY_CUSTOMERTOCOUNTRY

public static final java.lang.String ORDER_BY_CUSTOMERTOCOUNTRY
See Also:
Constant Field Values
Constructor Detail

InvoiceItemListResult

public InvoiceItemListResult()
Method Detail

getProductCode

public java.lang.String getProductCode()

setProductCode

public void setProductCode(java.lang.String productCode)

getStatus

public java.lang.String getStatus()

getCreditAccount

public java.lang.String getCreditAccount()

getCustomerPo

public java.lang.String getCustomerPo()

getCustomerId

public java.lang.String getCustomerId()

getShipperNumber

public java.lang.String getShipperNumber()

setShipperNumber

public void setShipperNumber(java.lang.String shipperNumber)

getExtPrice

public java.math.BigDecimal getExtPrice()

getDicount

public java.math.BigDecimal getDicount()

getTaxRate

public java.math.BigDecimal getTaxRate()

getUnitPrice

public java.math.BigDecimal getUnitPrice()

getQtyShipped

public java.math.BigDecimal getQtyShipped()

getQtyOrdered

public java.math.BigDecimal getQtyOrdered()

getDescription

public java.lang.String getDescription()

getPartFrom

public java.lang.String getPartFrom()

getPartType

public java.lang.String getPartType()

getPartNumber

public java.lang.String getPartNumber()

getInvoiceItemNumber

public java.lang.String getInvoiceItemNumber()

getInvoiceNumber

public java.lang.String getInvoiceNumber()

getPayDate

public java.util.Date getPayDate()

setDateInvoiced

public void setDateInvoiced(java.util.Date dateInvoiced)

setStatus

public void setStatus(java.lang.String status)

setCreditAccount

public void setCreditAccount(java.lang.String creditAccount)

setCustomerPo

public void setCustomerPo(java.lang.String customerPo)

setCustomerId

public void setCustomerId(java.lang.String customerId)

setExtPrice

public void setExtPrice(java.math.BigDecimal extPrice)

setDicount

public void setDicount(java.math.BigDecimal dicount)

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

setUnitPrice

public void setUnitPrice(java.math.BigDecimal unitPrice)

setQtyShipped

public void setQtyShipped(java.math.BigDecimal qtyShipped)

setQtyOrdered

public void setQtyOrdered(java.math.BigDecimal qtyOrdered)

setDescription

public void setDescription(java.lang.String description)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setPartType

public void setPartType(java.lang.String partType)

setPartNumber

public void setPartNumber(java.lang.String partNumber)

setInvoiceItemNumber

public void setInvoiceItemNumber(java.lang.String invoiceItemNumber)

setInvoiceNumber

public void setInvoiceNumber(java.lang.String invoiceNumber)

setPayDate

public void setPayDate(java.util.Date payDate)

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

setDue

public void setDue(java.math.BigDecimal due)

setMargin

public void setMargin(java.math.BigDecimal margin)

setMarginPercent

public void setMarginPercent(java.math.BigDecimal marginPercent)

getDateInvoiced

public java.util.Date getDateInvoiced()

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

getDue

public java.math.BigDecimal getDue()

getMargin

public java.math.BigDecimal getMargin()

getMarginPercent

public java.math.BigDecimal getMarginPercent()

getPaidDate

public java.util.Date getPaidDate()

setPaidDate

public void setPaidDate(java.util.Date paidDate)

getShipToCountry

public java.lang.String getShipToCountry()

setShipToCountry

public void setShipToCountry(java.lang.String shipToCountry)

getShipToId

public java.lang.String getShipToId()

setShipToId

public void setShipToId(java.lang.String shipToId)

getShipToState

public java.lang.String getShipToState()

setShipToState

public void setShipToState(java.lang.String shipToState)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getCustomerTostate

public java.lang.String getCustomerTostate()

setCustomerTostate

public void setCustomerTostate(java.lang.String customerTostate)

getCustomerToCountry

public java.lang.String getCustomerToCountry()

setCustomerToCountry

public void setCustomerToCountry(java.lang.String customerToCountry)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InvokeException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class InvokeException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  bb.common.BB2ServerException
                extended by  bb.common.InvokeException
All Implemented Interfaces:
java.io.Serializable
public class InvokeException
extends BB2ServerException

See Also:
Serialized Form

Field Summary
Fields inherited from class bb.common.BB2ServerException
UNKNOWN_EXCEPTION
Constructor Summary
InvokeException(java.lang.Exception e)
InvokeException(java.lang.Exception e, Reason reason)
InvokeException(Reason reason)
InvokeException(java.lang.String message)
InvokeException(java.lang.String message, Reason reason)
Method Summary
Methods inherited from class bb.common.BB2ServerException
getParameter, getReason, setParameter
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvokeException

public InvokeException(java.lang.Exception e)

InvokeException

public InvokeException(java.lang.String message)

InvokeException

public InvokeException(java.lang.Exception e,
                       Reason reason)

InvokeException

public InvokeException(Reason reason)

InvokeException

public InvokeException(java.lang.String message,
                       Reason reason)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IpAddressVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class IpAddressVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.IpAddressVO
All Implemented Interfaces:
java.io.Serializable
public class IpAddressVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
IpAddressVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCity()
java.lang.String | getCountry()
java.lang.Long | getId()
java.lang.Long | getIp1()
java.lang.Long | getIp2()
int | hashCode()
void | setCity(java.lang.String city)
void | setCountry(java.lang.String country)
void | setId(java.lang.Long id)
void | setIp1(java.lang.Long ip1)
void | setIp2(java.lang.Long ip2)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

IpAddressVO

public IpAddressVO()
default constructor

Method Detail

getId

public java.lang.Long getId()

setId

public void setId(java.lang.Long id)

getIp1

public java.lang.Long getIp1()

setIp1

public void setIp1(java.lang.Long ip1)

getIp2

public java.lang.Long getIp2()

setIp2

public void setIp2(java.lang.Long ip2)

getCountry

public java.lang.String getCountry()

setCountry

public void setCountry(java.lang.String country)

getCity

public java.lang.String getCity()

setCity

public void setCity(java.lang.String city)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IssuedFromOrderItem

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class IssuedFromOrderItem

java.lang.Object
    extended by  bb.common.IssuedFromOrderItem
All Implemented Interfaces:
java.io.Serializable
public class IssuedFromOrderItem
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
IssuedFromOrderItem()
Method Summary
java.math.BigDecimal | getAvailQty()
java.math.BigDecimal | getCost()
java.lang.String | getIssuedFrom()
java.lang.String | getIssuedLocate()
java.lang.String | getItemNumber()
java.lang.String | getOrderNumber()
int | getPartInQAII()
void | setAvailQty(java.math.BigDecimal availQty)
void | setCost(java.math.BigDecimal cost)
void | setIssuedFrom(java.lang.String issuedFrom)
void | setIssuedLocate(java.lang.String issuedLocate)
void | setItemNumber(java.lang.String itemNumber)
void | setOrderNumber(java.lang.String orderNumber)
void | setPartInQAII(int partInQAII)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

IssuedFromOrderItem

public IssuedFromOrderItem()
Method Detail

getCost

public java.math.BigDecimal getCost()

setCost

public void setCost(java.math.BigDecimal cost)

getAvailQty

public java.math.BigDecimal getAvailQty()

setAvailQty

public void setAvailQty(java.math.BigDecimal availQty)

getIssuedFrom

public java.lang.String getIssuedFrom()

setIssuedFrom

public void setIssuedFrom(java.lang.String issuedFrom)

getItemNumber

public java.lang.String getItemNumber()

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

getOrderNumber

public java.lang.String getOrderNumber()

setOrderNumber

public void setOrderNumber(java.lang.String orderNumber)

getIssuedLocate

public java.lang.String getIssuedLocate()

setIssuedLocate

public void setIssuedLocate(java.lang.String issuedLocate)

getPartInQAII

public int getPartInQAII()

setPartInQAII

public void setPartInQAII(int partInQAII)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IssueItemAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class IssueItemAgent

java.lang.Object
    extended by  bb.common.IssueItemAgent
All Implemented Interfaces:
java.io.Serializable
public class IssueItemAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
IssueItemAgent()
Method Summary
java.math.BigDecimal | getAvgCost()
java.lang.Boolean | getIsGroup()
java.util.Set<IssueItemDetailAgent> | getIssueItemDetails()
java.lang.Short | getItemNumber()
java.lang.String | getLot()
OrderPK | getOrderPk()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.lang.String | getPicker()
java.lang.String | getSerial()
java.math.BigDecimal | getTotalIssuedCost(int length)
java.math.BigDecimal | getTotalIssuedQty()
WorkOrderItemPK | getWorkOrderItemPk()
void | refresh(int length)
void | setIsGroup(java.lang.Boolean isGroup)
void | setIssueItemDetails(java.util.Set issueItemDetails)
void | setItemNumber(java.lang.Short itemNumber)
void | setLot(java.lang.String lot)
void | setOrderPk(OrderPK orderPk)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setPicker(java.lang.String picker)
void | setSerial(java.lang.String serial)
void | setWorkOrderItemPk(WorkOrderItemPK workOrderItemPk)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

IssueItemAgent

public IssueItemAgent()
Method Detail

getWorkOrderItemPk

public WorkOrderItemPK getWorkOrderItemPk()

getOrderPk

public OrderPK getOrderPk()

setOrderPk

public void setOrderPk(OrderPK orderPk)

getItemNumber

public java.lang.Short getItemNumber()

getIsGroup

public java.lang.Boolean getIsGroup()

getPartPk

public PartPK getPartPk()

getPartFrom

public java.lang.String getPartFrom()

getTotalIssuedQty

public java.math.BigDecimal getTotalIssuedQty()

getSerial

public java.lang.String getSerial()

getLot

public java.lang.String getLot()

getAvgCost

public java.math.BigDecimal getAvgCost()

getIssueItemDetails

public java.util.Set<IssueItemDetailAgent> getIssueItemDetails()

setWorkOrderItemPk

public void setWorkOrderItemPk(WorkOrderItemPK workOrderItemPk)

setItemNumber

public void setItemNumber(java.lang.Short itemNumber)

setIsGroup

public void setIsGroup(java.lang.Boolean isGroup)

setPartPk

public void setPartPk(PartPK partPk)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setSerial

public void setSerial(java.lang.String serial)

setLot

public void setLot(java.lang.String lot)

setIssueItemDetails

public void setIssueItemDetails(java.util.Set issueItemDetails)

refresh

public void refresh(int length)

getPicker

public java.lang.String getPicker()

setPicker

public void setPicker(java.lang.String picker)

getTotalIssuedCost

public java.math.BigDecimal getTotalIssuedCost(int length)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IssueItemDetailAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class IssueItemDetailAgent

java.lang.Object
    extended by  bb.common.IssueItemDetailAgent
All Implemented Interfaces:
java.io.Serializable
public class IssueItemDetailAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
IssueItemDetailAgent()
Method Summary
java.math.BigDecimal | getCost()
java.lang.String | getIssuedFrom()
java.math.BigDecimal | getIssuedQty()
java.lang.String | getLocate()
java.lang.String | getOrderNumber()
java.util.Set<ReceiverItemTrackingLogAgent> | getTrackingLog()
void | setCost(java.math.BigDecimal cost)
void | setIssuedFrom(java.lang.String issuedFrom)
void | setIssuedQty(java.math.BigDecimal issuedQty)
void | setLocate(java.lang.String locate)
void | setOrderNumber(java.lang.String orderNumber)
void | setTrackingLog(java.util.Set<ReceiverItemTrackingLogAgent> trackingLog)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

IssueItemDetailAgent

public IssueItemDetailAgent()
Method Detail

getIssuedFrom

public java.lang.String getIssuedFrom()

setIssuedFrom

public void setIssuedFrom(java.lang.String issuedFrom)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

setIssuedQty

public void setIssuedQty(java.math.BigDecimal issuedQty)

setCost

public void setCost(java.math.BigDecimal cost)

getIssuedQty

public java.math.BigDecimal getIssuedQty()

getCost

public java.math.BigDecimal getCost()

getTrackingLog

public java.util.Set<ReceiverItemTrackingLogAgent> getTrackingLog()

setTrackingLog

public void setTrackingLog(java.util.Set<ReceiverItemTrackingLogAgent> trackingLog)

getOrderNumber

public java.lang.String getOrderNumber()

setOrderNumber

public void setOrderNumber(java.lang.String orderNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IssuingItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class IssuingItemResult

java.lang.Object
    extended by  bb.common.IssuingItemResult
All Implemented Interfaces:
java.io.Serializable
public class IssuingItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
IssuingItemResult()
Method Summary
java.math.BigDecimal | getAvgCost()
java.math.BigDecimal | getCost()
java.lang.String | getDescription()
java.lang.Boolean | getIsGroup()
java.lang.Short | getItemNumber()
java.lang.String | getLot()
java.math.BigDecimal | getMaxIssued()
java.math.BigDecimal | getMinIssued()
java.math.BigDecimal | getOndemand()
java.util.Set | getOthersLocations()
java.lang.String | getPartFrom()
java.util.Set | getPartLocations()
PartPK | getPartPk()
java.util.Set<PartTrackingVO> | getPartTracking()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getQuantityIssued()
java.lang.String | getRevision()
java.math.BigDecimal | getScrapQty()
java.lang.String | getSerial()
java.math.BigDecimal | getTotalOnhand()
WorkOrderItemPK | getWorkOrderItemPK()
boolean | isTraceable()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setCost(java.math.BigDecimal cost)
void | setDescription(java.lang.String description)
void | setIsGroup(java.lang.Boolean isGroup)
void | setItemNumber(java.lang.Short itemNumber)
void | setLot(java.lang.String lot)
void | setMaxIssued(java.math.BigDecimal maxIssued)
void | setMinIssued(java.math.BigDecimal minIssued)
void | setOndemand(java.math.BigDecimal ondemand)
void | setOthersLocations(java.util.Set othersLocations)
void | setPartFrom(java.lang.String partFrom)
void | setPartLocations(java.util.Set partLocations)
void | setPartPk(PartPK partPk)
void | setPartTracking(java.util.Set<PartTrackingVO> partTracking)
void | setQuantity(java.math.BigDecimal quantity)
void | setQuantityIssued(java.math.BigDecimal quantityIssued)
void | setRevision(java.lang.String revision)
void | setScrapQty(java.math.BigDecimal scrapQty)
void | setSerial(java.lang.String serial)
void | setTotalOnhand(java.math.BigDecimal totalOnhand)
void | setTraceable(boolean traceable)
void | setWorkOrderItemPK(WorkOrderItemPK workOrderItemPK)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

IssuingItemResult

public IssuingItemResult()
Method Detail

getMaxIssued

public java.math.BigDecimal getMaxIssued()

setMaxIssued

public void setMaxIssued(java.math.BigDecimal maxIssued)

getMinIssued

public java.math.BigDecimal getMinIssued()

setMinIssued

public void setMinIssued(java.math.BigDecimal minIssued)

getWorkOrderItemPK

public WorkOrderItemPK getWorkOrderItemPK()

getItemNumber

public java.lang.Short getItemNumber()

getIsGroup

public java.lang.Boolean getIsGroup()

getPartPk

public PartPK getPartPk()

getPartFrom

public java.lang.String getPartFrom()

getRevision

public java.lang.String getRevision()

getDescription

public java.lang.String getDescription()

getQuantity

public java.math.BigDecimal getQuantity()

getQuantityIssued

public java.math.BigDecimal getQuantityIssued()

getSerial

public java.lang.String getSerial()

getLot

public java.lang.String getLot()

getCost

public java.math.BigDecimal getCost()

getAvgCost

public java.math.BigDecimal getAvgCost()

getPartLocations

public java.util.Set getPartLocations()

getTotalOnhand

public java.math.BigDecimal getTotalOnhand()

getOndemand

public java.math.BigDecimal getOndemand()

setWorkOrderItemPK

public void setWorkOrderItemPK(WorkOrderItemPK workOrderItemPK)

setItemNumber

public void setItemNumber(java.lang.Short itemNumber)

setIsGroup

public void setIsGroup(java.lang.Boolean isGroup)

setPartPk

public void setPartPk(PartPK partPk)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setRevision

public void setRevision(java.lang.String revision)

setDescription

public void setDescription(java.lang.String description)

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

setQuantityIssued

public void setQuantityIssued(java.math.BigDecimal quantityIssued)

setSerial

public void setSerial(java.lang.String serial)

setLot

public void setLot(java.lang.String lot)

setCost

public void setCost(java.math.BigDecimal cost)

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

setPartLocations

public void setPartLocations(java.util.Set partLocations)

setTotalOnhand

public void setTotalOnhand(java.math.BigDecimal totalOnhand)

setOndemand

public void setOndemand(java.math.BigDecimal ondemand)

getOthersLocations

public java.util.Set getOthersLocations()

setOthersLocations

public void setOthersLocations(java.util.Set othersLocations)

isTraceable

public boolean isTraceable()

setTraceable

public void setTraceable(boolean traceable)

getPartTracking

public java.util.Set<PartTrackingVO> getPartTracking()

setPartTracking

public void setPartTracking(java.util.Set<PartTrackingVO> partTracking)

getScrapQty

public java.math.BigDecimal getScrapQty()

setScrapQty

public void setScrapQty(java.math.BigDecimal scrapQty)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IssuingResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class IssuingResult

java.lang.Object
    extended by  bb.common.IssuingResult
All Implemented Interfaces:
java.io.Serializable
public class IssuingResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
IssuingResult()
Method Summary
boolean | checkIfOverControl(java.math.BigDecimal newCost)
java.lang.String | getApprovedBy()
java.util.Date | getApprovedDate()
java.lang.String | getBillId()
java.lang.String | getChangeOrder()
WOItemCostControlAgent | getCostControlAgent()
java.lang.String | getDescription()
java.lang.String | getDrawing()
java.util.Set | getIssuingItems()
java.lang.String | getItemNumber()
java.lang.String | getItemStatus()
java.util.Date | getOrderDate()
java.lang.String | getOrderNumber()
java.lang.String | getOrderStatus()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.lang.String | getProject()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getQuantityAsm()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.util.Date | getRequireDate()
java.lang.String | getRevision()
java.lang.String | getShipId()
java.lang.String | getShipvia()
java.lang.String | getUnit()
java.lang.String | getVendorId()
void | setApprovedBy(java.lang.String approvedBy)
void | setApprovedDate(java.util.Date approvedDate)
void | setBillId(java.lang.String billId)
void | setChangeOrder(java.lang.String changeOrder)
void | setCostControlAgent(WOItemCostControlAgent costControlAgent)
void | setDescription(java.lang.String description)
void | setDrawing(java.lang.String drawing)
void | setIssuingItems(java.util.Set issuingItems)
void | setItemNumber(java.lang.String itemNumber)
void | setItemStatus(java.lang.String itemStatus)
void | setOrderDate(java.util.Date orderDate)
void | setOrderNumber(java.lang.String orderNumber)
void | setOrderStatus(java.lang.String orderStatus)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setProject(java.lang.String project)
void | setQuantity(java.math.BigDecimal quantity)
void | setQuantityAsm(java.math.BigDecimal quantityAsm)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setRequireDate(java.util.Date requireDate)
void | setRevision(java.lang.String revision)
void | setShipId(java.lang.String shipId)
void | setShipvia(java.lang.String shipvia)
void | setUnit(java.lang.String unit)
void | setVendorId(java.lang.String vendorId)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

IssuingResult

public IssuingResult()
Method Detail

setOrderNumber

public void setOrderNumber(java.lang.String orderNumber)

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

setOrderDate

public void setOrderDate(java.util.Date orderDate)

setVendorId

public void setVendorId(java.lang.String vendorId)

setBillId

public void setBillId(java.lang.String billId)

setShipId

public void setShipId(java.lang.String shipId)

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

setProject

public void setProject(java.lang.String project)

setShipvia

public void setShipvia(java.lang.String shipvia)

setOrderStatus

public void setOrderStatus(java.lang.String orderStatus)

setApprovedDate

public void setApprovedDate(java.util.Date approvedDate)

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)

setPartPk

public void setPartPk(PartPK partPk)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setRevision

public void setRevision(java.lang.String revision)

setDrawing

public void setDrawing(java.lang.String drawing)

setDescription

public void setDescription(java.lang.String description)

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

setQuantityAsm

public void setQuantityAsm(java.math.BigDecimal quantityAsm)

setUnit

public void setUnit(java.lang.String unit)

setRequireDate

public void setRequireDate(java.util.Date requireDate)

setItemStatus

public void setItemStatus(java.lang.String itemStatus)

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

setIssuingItems

public void setIssuingItems(java.util.Set issuingItems)

getOrderNumber

public java.lang.String getOrderNumber()

getItemNumber

public java.lang.String getItemNumber()

getOrderDate

public java.util.Date getOrderDate()

getVendorId

public java.lang.String getVendorId()

getBillId

public java.lang.String getBillId()

getShipId

public java.lang.String getShipId()

getChangeOrder

public java.lang.String getChangeOrder()

getProject

public java.lang.String getProject()

getShipvia

public java.lang.String getShipvia()

getOrderStatus

public java.lang.String getOrderStatus()

getApprovedDate

public java.util.Date getApprovedDate()

getApprovedBy

public java.lang.String getApprovedBy()

getPartPk

public PartPK getPartPk()

getPartFrom

public java.lang.String getPartFrom()

getRevision

public java.lang.String getRevision()

getDrawing

public java.lang.String getDrawing()

getDescription

public java.lang.String getDescription()

getQuantity

public java.math.BigDecimal getQuantity()

getQuantityAsm

public java.math.BigDecimal getQuantityAsm()

getUnit

public java.lang.String getUnit()

getRequireDate

public java.util.Date getRequireDate()

getItemStatus

public java.lang.String getItemStatus()

getRefDoc1

public java.lang.String getRefDoc1()

getRefDoc2

public java.lang.String getRefDoc2()

getIssuingItems

public java.util.Set getIssuingItems()

getCostControlAgent

public WOItemCostControlAgent getCostControlAgent()

setCostControlAgent

public void setCostControlAgent(WOItemCostControlAgent costControlAgent)

checkIfOverControl

public boolean checkIfOverControl(java.math.BigDecimal newCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


J-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M N O P Q R S T U V W X Y Z

J

J - Static variable in class bb.common.Constant.TransactionType
JNDI_BB2_TOPIC - Static variable in class bb.common.Constant
JOB_CATEGORY - Static variable in class bb.common.BizTarget
JOB_CATEGORY_IS_USED - Static variable in class bb.common.BIZReason
JobProcessSheetItemResult - Class in bb.common
JobProcessSheetItemResult() - Constructor for class bb.common.JobProcessSheetItemResult
JobProcessSheetListResult - Class in bb.common
JobProcessSheetListResult() - Constructor for class bb.common.JobProcessSheetListResult
JobProcessSheetResult - Class in bb.common
JobProcessSheetResult() - Constructor for class bb.common.JobProcessSheetResult
JounalEntryListResult - Class in bb.common
JounalEntryListResult() - Constructor for class bb.common.JounalEntryListResult
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M N O P Q R S T U V W X Y Z


JobProcessSheetItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class JobProcessSheetItemResult

java.lang.Object
    extended by  bb.common.JobProcessSheetItemResult
All Implemented Interfaces:
java.io.Serializable
public class JobProcessSheetItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
JobProcessSheetItemResult()
Method Summary
java.math.BigDecimal | getGoodQty()
java.lang.String | getInspectedBy()
java.util.Date | getInspectedDate()
java.math.BigDecimal | getRejectQty()
java.util.Date | getRequiredDate()
java.lang.String | getSeqNumber()
java.lang.String | getWcDescription()
java.lang.String | getWorkCenter()
void | setGoodQty(java.math.BigDecimal goodQty)
void | setInspectedBy(java.lang.String inspectedBy)
void | setInspectedDate(java.util.Date inspectedDate)
void | setRejectQty(java.math.BigDecimal rejectQty)
void | setRequiredDate(java.util.Date requiredDate)
void | setSeqNumber(java.lang.String seqNumber)
void | setWcDescription(java.lang.String wcDescription)
void | setWorkCenter(java.lang.String workCenter)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JobProcessSheetItemResult

public JobProcessSheetItemResult()
Method Detail

setSeqNumber

public void setSeqNumber(java.lang.String seqNumber)

setWorkCenter

public void setWorkCenter(java.lang.String workCenter)

setWcDescription

public void setWcDescription(java.lang.String wcDescription)

setGoodQty

public void setGoodQty(java.math.BigDecimal goodQty)

setRejectQty

public void setRejectQty(java.math.BigDecimal rejectQty)

setInspectedDate

public void setInspectedDate(java.util.Date inspectedDate)

setInspectedBy

public void setInspectedBy(java.lang.String inspectedBy)

getSeqNumber

public java.lang.String getSeqNumber()

getWorkCenter

public java.lang.String getWorkCenter()

getWcDescription

public java.lang.String getWcDescription()

getGoodQty

public java.math.BigDecimal getGoodQty()

getRejectQty

public java.math.BigDecimal getRejectQty()

getInspectedDate

public java.util.Date getInspectedDate()

getInspectedBy

public java.lang.String getInspectedBy()

getRequiredDate

public java.util.Date getRequiredDate()

setRequiredDate

public void setRequiredDate(java.util.Date requiredDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JobProcessSheetListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class JobProcessSheetListResult

java.lang.Object
    extended by  bb.common.JobProcessSheetListResult
All Implemented Interfaces:
java.io.Serializable
public class JobProcessSheetListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_DUEDATE
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_REFDOC1
static java.lang.String | ORDER_BY_REFDOC2
static java.lang.String | ORDER_BY_SETID
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_WOITEMITEMPK
Constructor Summary
JobProcessSheetListResult()
Method Summary
java.lang.String | getDescription()
java.util.Date | getDueDate()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getQuantityAsm()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.lang.String | getSetId()
java.lang.String | getStatus()
java.lang.String | getVendorId()
WorkOrderItemPK | getWoItemItemPk()
void | setDescription(java.lang.String description)
void | setDueDate(java.util.Date dueDate)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setQuantity(java.math.BigDecimal quantity)
void | setQuantityAsm(java.math.BigDecimal quantityAsm)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setSetId(java.lang.String setId)
void | setStatus(java.lang.String status)
void | setVendorId(java.lang.String vendorId)
void | setWoItemItemPk(WorkOrderItemPK woItemItemPk)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_WOITEMITEMPK

public static final java.lang.String ORDER_BY_WOITEMITEMPK
See Also:
Constant Field Values

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_SETID

public static final java.lang.String ORDER_BY_SETID
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_DUEDATE

public static final java.lang.String ORDER_BY_DUEDATE
See Also:
Constant Field Values

ORDER_BY_REFDOC1

public static final java.lang.String ORDER_BY_REFDOC1
See Also:
Constant Field Values

ORDER_BY_REFDOC2

public static final java.lang.String ORDER_BY_REFDOC2
See Also:
Constant Field Values
Constructor Detail

JobProcessSheetListResult

public JobProcessSheetListResult()
Method Detail

setWoItemItemPk

public void setWoItemItemPk(WorkOrderItemPK woItemItemPk)

setPartPk

public void setPartPk(PartPK partPk)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setDescription

public void setDescription(java.lang.String description)

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

setQuantityAsm

public void setQuantityAsm(java.math.BigDecimal quantityAsm)

setDueDate

public void setDueDate(java.util.Date dueDate)

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

setStatus

public void setStatus(java.lang.String status)

setVendorId

public void setVendorId(java.lang.String vendorId)

setSetId

public void setSetId(java.lang.String setId)

getWoItemItemPk

public WorkOrderItemPK getWoItemItemPk()

getPartPk

public PartPK getPartPk()

getPartFrom

public java.lang.String getPartFrom()

getDescription

public java.lang.String getDescription()

getQuantity

public java.math.BigDecimal getQuantity()

getQuantityAsm

public java.math.BigDecimal getQuantityAsm()

getDueDate

public java.util.Date getDueDate()

getRefDoc1

public java.lang.String getRefDoc1()

getRefDoc2

public java.lang.String getRefDoc2()

getStatus

public java.lang.String getStatus()

getVendorId

public java.lang.String getVendorId()

getSetId

public java.lang.String getSetId()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JobProcessSheetResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class JobProcessSheetResult

java.lang.Object
    extended by  bb.common.JobProcessSheetResult
All Implemented Interfaces:
java.io.Serializable
public class JobProcessSheetResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
JobProcessSheetResult()
Method Summary
java.lang.String | getDescription()
java.util.Date | getDueDate()
java.lang.String | getItemComments()
java.lang.String | getPartFrom()
PartPK | getPartPK()
java.math.BigDecimal | getQty()
java.util.Set | getSeqs()
java.lang.String | getSetId()
java.lang.String | getVendorId()
java.lang.String | getWoComments()
java.lang.String | getWoItemNumber()
java.lang.String | getWoNumber()
void | setDescription(java.lang.String description)
void | setDueDate(java.util.Date dueDate)
void | setItemComments(java.lang.String itemComments)
void | setPartFrom(java.lang.String partFrom)
void | setPartPK(PartPK partPK)
void | setQty(java.math.BigDecimal qty)
void | setSeqs(java.util.Set seqs)
void | setSetId(java.lang.String setId)
void | setVendorId(java.lang.String vendorId)
void | setWoComments(java.lang.String woComments)
void | setWoItemNumber(java.lang.String woItemNumber)
void | setWoNumber(java.lang.String woNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JobProcessSheetResult

public JobProcessSheetResult()
Method Detail

setWoNumber

public void setWoNumber(java.lang.String woNumber)

setWoItemNumber

public void setWoItemNumber(java.lang.String woItemNumber)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setDescription

public void setDescription(java.lang.String description)

setPartPK

public void setPartPK(PartPK partPK)

setQty

public void setQty(java.math.BigDecimal qty)

setDueDate

public void setDueDate(java.util.Date dueDate)

setSeqs

public void setSeqs(java.util.Set seqs)

setSetId

public void setSetId(java.lang.String setId)

setVendorId

public void setVendorId(java.lang.String vendorId)

setWoComments

public void setWoComments(java.lang.String woComments)

setItemComments

public void setItemComments(java.lang.String itemComments)

getWoNumber

public java.lang.String getWoNumber()

getWoItemNumber

public java.lang.String getWoItemNumber()

getPartFrom

public java.lang.String getPartFrom()

getDescription

public java.lang.String getDescription()

getPartPK

public PartPK getPartPK()

getQty

public java.math.BigDecimal getQty()

getDueDate

public java.util.Date getDueDate()

getSeqs

public java.util.Set getSeqs()

getSetId

public java.lang.String getSetId()

getVendorId

public java.lang.String getVendorId()

getWoComments

public java.lang.String getWoComments()

getItemComments

public java.lang.String getItemComments()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JounalEntryListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class JounalEntryListResult

java.lang.Object
    extended by  bb.common.JounalEntryListResult
All Implemented Interfaces:
java.io.Serializable
public class JounalEntryListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
JounalEntryListResult()
Method Summary
java.math.BigDecimal | getBalance()
java.lang.String | getCategoryId()
int | getCategorySequence()
java.lang.String | getCreditAccount()
java.math.BigDecimal | getCreditAmount()
java.lang.String | getCurrency()
java.lang.String | getDebitAccount()
java.math.BigDecimal | getDebitAmount()
java.lang.String | getDebitOrCredit()
java.lang.String | getDescription()
java.math.BigDecimal | getExchange()
java.math.BigDecimal | getOriginalBalance()
java.math.BigDecimal | getOriginalCreditAmount()
java.math.BigDecimal | getOriginalDebitAmount()
java.lang.String | getRelevantAccount()
java.lang.String | getRelevantAccountDescription()
java.lang.String | getSummary()
java.util.Date | getTransactionDate()
java.lang.String | getTransactionNumber()
boolean | isPosted()
void | setBalance(java.math.BigDecimal balance)
void | setCategoryId(java.lang.String categoryId)
void | setCategorySequence(int categorySequence)
void | setCategorySequence(java.lang.Integer categorySequence)
void | setCreditAccount(java.lang.String creditAccount)
void | setCreditAmount(java.math.BigDecimal creditAmount)
void | setCurrency(java.lang.String currency)
void | setDebitAccount(java.lang.String debitAccount)
void | setDebitAmount(java.math.BigDecimal debitAmount)
void | setDebitOrCredit(java.lang.String debitOrCredit)
void | setDescription(java.lang.String description)
void | setExchange(java.math.BigDecimal exchange)
void | setOriginalBalance(java.math.BigDecimal originalBalance)
void | setOriginalCreditAmount(java.math.BigDecimal originalCreditAmount)
void | setOriginalDebitAmount(java.math.BigDecimal originalDebitAmount)
void | setPosted(boolean posted)
void | setRelevantAccount(java.lang.String relevantAccount)
void | setRelevantAccountDescription(java.lang.String relevantAccountDescription)
void | setSummary(java.lang.String summary)
void | setTransactionDate(java.util.Date transactionDate)
void | setTransactionNumber(java.lang.String transactionNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JounalEntryListResult

public JounalEntryListResult()
Method Detail

getDebitAmount

public java.math.BigDecimal getDebitAmount()

setDebitAmount

public void setDebitAmount(java.math.BigDecimal debitAmount)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getTransactionDate

public java.util.Date getTransactionDate()

setTransactionDate

public void setTransactionDate(java.util.Date transactionDate)

getTransactionNumber

public java.lang.String getTransactionNumber()

setTransactionNumber

public void setTransactionNumber(java.lang.String transactionNumber)

getCreditAccount

public java.lang.String getCreditAccount()

setCreditAccount

public void setCreditAccount(java.lang.String creditAccount)

getDebitAccount

public java.lang.String getDebitAccount()

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

getRelevantAccount

public java.lang.String getRelevantAccount()

setRelevantAccount

public void setRelevantAccount(java.lang.String relevantAccount)

getCreditAmount

public java.math.BigDecimal getCreditAmount()

setCreditAmount

public void setCreditAmount(java.math.BigDecimal creditAmount)

getBalance

public java.math.BigDecimal getBalance()

setBalance

public void setBalance(java.math.BigDecimal balance)

getDebitOrCredit

public java.lang.String getDebitOrCredit()

setDebitOrCredit

public void setDebitOrCredit(java.lang.String debitOrCredit)

getCategoryId

public java.lang.String getCategoryId()

setCategoryId

public void setCategoryId(java.lang.String categoryId)

getCategorySequence

public int getCategorySequence()

setCategorySequence

public void setCategorySequence(int categorySequence)

setCategorySequence

public void setCategorySequence(java.lang.Integer categorySequence)

getSummary

public java.lang.String getSummary()

setSummary

public void setSummary(java.lang.String summary)

getRelevantAccountDescription

public java.lang.String getRelevantAccountDescription()

setRelevantAccountDescription

public void setRelevantAccountDescription(java.lang.String relevantAccountDescription)

isPosted

public boolean isPosted()

setPosted

public void setPosted(boolean posted)

getExchange

public java.math.BigDecimal getExchange()

setExchange

public void setExchange(java.math.BigDecimal exchange)

getOriginalCreditAmount

public java.math.BigDecimal getOriginalCreditAmount()

setOriginalCreditAmount

public void setOriginalCreditAmount(java.math.BigDecimal originalCreditAmount)

getOriginalDebitAmount

public java.math.BigDecimal getOriginalDebitAmount()

setOriginalDebitAmount

public void setOriginalDebitAmount(java.math.BigDecimal originalDebitAmount)

getOriginalBalance

public java.math.BigDecimal getOriginalBalance()

setOriginalBalance

public void setOriginalBalance(java.math.BigDecimal originalBalance)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LabelTemplateConstant

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class LabelTemplateConstant

java.lang.Object
    extended by  bb.common.LabelTemplateConstant
All Implemented Interfaces:
java.io.Serializable
public class LabelTemplateConstant
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static int | ALIGN_BOTTOM
static int | ALIGN_CENTER
static int | ALIGN_LEFT
static int | ALIGN_RIGHT
static int | ALIGN_TOP
static java.lang.String | ASSET_ASSETNUMBER
static java.lang.String | ASSET_ASSETTYPE
static java.lang.String | ASSET_ASSETTYPE2
static java.lang.String | ASSET_CHECKDATE
static java.lang.String | ASSET_DEPARTMENTID
static java.lang.String | ASSET_DESCRIPTION
static java.lang.String | ASSET_LOCATION
static double | FACTOR
static java.lang.String | FONT_DEFAULT
static java.lang.String | ISSUING_DATE
static java.lang.String | ISSUING_DESCRIPTION
static java.lang.String | ISSUING_OPERATOR
static java.lang.String | ISSUING_PART_NUMBER
static java.lang.String | ISSUING_PROJECT
static java.lang.String | ISSUING_QTY_ISSUED
static java.lang.String | ISSUING_RELATEDDOC
static java.lang.String | ISSUING_UNIT
static java.lang.String | ISSUING_WO_NUMBER
static java.lang.String | ITEM_BARCODE
static java.lang.String | ITEM_LABEL
static java.lang.String | ITEM_LINE
static java.lang.String | ITEM_PROPERTY
static java.lang.String | ITEM_QR_BARCODE
static java.lang.String | ITEM_TABLE
static java.lang.String | LABEL_ASSET
static java.lang.String | LABEL_GL
static java.lang.String | LABEL_ISSUING
static java.lang.String | LABEL_LOCATION
static java.lang.String | LABEL_PART
static java.lang.String | LABEL_POS
static java.lang.String | LABEL_SHIPPING
static java.lang.String | LOCATION_LOCATION
static java.lang.String | PART_ADDRESS_ID
static java.lang.String | PART_ADDRESS_NAME
static java.lang.String | PART_DATE
static java.lang.String | PART_DESCRIPTION
static java.lang.String | PART_LOCATION
static java.lang.String | PART_OPERATOR
static java.lang.String | PART_PART_NUMBER
static java.lang.String | PART_QTY_RECEIVED_OR_SHIPPED
static java.lang.String | PART_RELATED_DOC
static java.lang.String | PART_UNIT
static java.lang.String | POS_ACCOUNTSRECEIVABLE
static java.lang.String | POS_AVGCOSTTOTAL
static java.lang.String | POS_CHANGE
static java.lang.String | POS_CHECKNUMBER
static java.lang.String | POS_CREDITCARDNUMBER
static java.lang.String | POS_CUSTOMERID
static java.lang.String | POS_DISCTOTAL
static java.lang.String | POS_DUTYFREENUMBER
static java.lang.String | POS_ELECSIGNATURE
static java.lang.String | POS_FREIGHT
static java.lang.String | POS_ITEM_AVGCOST
static java.lang.String | POS_ITEM_DESCRIPTION
static java.lang.String | POS_ITEM_DISCOUNT
static java.lang.String | POS_ITEM_DUTYFREE
static java.lang.String | POS_ITEM_NETTOTAL
static java.lang.String | POS_ITEM_NUMBER
static java.lang.String | POS_ITEM_PARTNUMBER
static java.lang.String | POS_ITEM_PARTTYPE
static java.lang.String | POS_ITEM_PRICE
static java.lang.String | POS_ITEM_PROFIT
static java.lang.String | POS_ITEM_PROFITBYSTDCOST
static java.lang.String | POS_ITEM_PROFITPERCENT
static java.lang.String | POS_ITEM_PROFITPERCENTBYSTDCOST
static java.lang.String | POS_ITEM_QUANTITY
static java.lang.String | POS_ITEM_REALTIMEONHAND
static java.lang.String | POS_ITEM_STDCOST
static java.lang.String | POS_ITEM_SUBTOTAL
static java.lang.String | POS_ITEM_TAXTOTAL
static java.lang.String | POS_NETTOTAL
static java.lang.String | POS_PAYABLEMETHOD
static java.lang.String | POS_PROFITPERCENTTOTAL
static java.lang.String | POS_PROFITPERCENTTOTALBYSTDCOST
static java.lang.String | POS_PROFITTOTAL
static java.lang.String | POS_PROFITTOTALBYSTDCOST
static java.lang.String | POS_RAO_NUMBER
static java.lang.String | POS_REALRECEIVABLE
static java.lang.String | POS_SALESDATE
static java.lang.String | POS_SALESMAN
static java.lang.String | POS_TAX
static java.lang.String | POS_TAXRATE
static java.lang.String | POS_TAXTOTAL
static java.lang.String | SHIPPING_SO_NUMBER
Constructor Summary
LabelTemplateConstant()
Method Summary
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ALIGN_CENTER

public static final int ALIGN_CENTER
See Also:
Constant Field Values

ALIGN_TOP

public static final int ALIGN_TOP
See Also:
Constant Field Values

ALIGN_BOTTOM

public static final int ALIGN_BOTTOM
See Also:
Constant Field Values

ALIGN_LEFT

public static final int ALIGN_LEFT
See Also:
Constant Field Values

ALIGN_RIGHT

public static final int ALIGN_RIGHT
See Also:
Constant Field Values

LABEL_PART

public static final java.lang.String LABEL_PART
See Also:
Constant Field Values

LABEL_LOCATION

public static final java.lang.String LABEL_LOCATION
See Also:
Constant Field Values

LABEL_SHIPPING

public static final java.lang.String LABEL_SHIPPING
See Also:
Constant Field Values

LABEL_ISSUING

public static final java.lang.String LABEL_ISSUING
See Also:
Constant Field Values

LABEL_GL

public static final java.lang.String LABEL_GL
See Also:
Constant Field Values

LABEL_ASSET

public static final java.lang.String LABEL_ASSET
See Also:
Constant Field Values

LABEL_POS

public static final java.lang.String LABEL_POS
See Also:
Constant Field Values

ITEM_LABEL

public static final java.lang.String ITEM_LABEL
See Also:
Constant Field Values

ITEM_PROPERTY

public static final java.lang.String ITEM_PROPERTY
See Also:
Constant Field Values

ITEM_BARCODE

public static final java.lang.String ITEM_BARCODE
See Also:
Constant Field Values

ITEM_QR_BARCODE

public static final java.lang.String ITEM_QR_BARCODE
See Also:
Constant Field Values

ITEM_LINE

public static final java.lang.String ITEM_LINE
See Also:
Constant Field Values

ITEM_TABLE

public static final java.lang.String ITEM_TABLE
See Also:
Constant Field Values

FONT_DEFAULT

public static final java.lang.String FONT_DEFAULT
See Also:
Constant Field Values

PART_PART_NUMBER

public static final java.lang.String PART_PART_NUMBER
See Also:
Constant Field Values

PART_DESCRIPTION

public static final java.lang.String PART_DESCRIPTION
See Also:
Constant Field Values

PART_RELATED_DOC

public static final java.lang.String PART_RELATED_DOC
See Also:
Constant Field Values

PART_ADDRESS_NAME

public static final java.lang.String PART_ADDRESS_NAME
See Also:
Constant Field Values

PART_QTY_RECEIVED_OR_SHIPPED

public static final java.lang.String PART_QTY_RECEIVED_OR_SHIPPED
See Also:
Constant Field Values

PART_DATE

public static final java.lang.String PART_DATE
See Also:
Constant Field Values

PART_OPERATOR

public static final java.lang.String PART_OPERATOR
See Also:
Constant Field Values

PART_UNIT

public static final java.lang.String PART_UNIT
See Also:
Constant Field Values

PART_ADDRESS_ID

public static final java.lang.String PART_ADDRESS_ID
See Also:
Constant Field Values

PART_LOCATION

public static final java.lang.String PART_LOCATION
See Also:
Constant Field Values

ASSET_ASSETNUMBER

public static final java.lang.String ASSET_ASSETNUMBER
See Also:
Constant Field Values

ASSET_ASSETTYPE

public static final java.lang.String ASSET_ASSETTYPE
See Also:
Constant Field Values

ASSET_ASSETTYPE2

public static final java.lang.String ASSET_ASSETTYPE2
See Also:
Constant Field Values

ASSET_DESCRIPTION

public static final java.lang.String ASSET_DESCRIPTION
See Also:
Constant Field Values

ASSET_LOCATION

public static final java.lang.String ASSET_LOCATION
See Also:
Constant Field Values

ASSET_DEPARTMENTID

public static final java.lang.String ASSET_DEPARTMENTID
See Also:
Constant Field Values

ASSET_CHECKDATE

public static final java.lang.String ASSET_CHECKDATE
See Also:
Constant Field Values

LOCATION_LOCATION

public static final java.lang.String LOCATION_LOCATION
See Also:
Constant Field Values

SHIPPING_SO_NUMBER

public static final java.lang.String SHIPPING_SO_NUMBER
See Also:
Constant Field Values

ISSUING_WO_NUMBER

public static final java.lang.String ISSUING_WO_NUMBER
See Also:
Constant Field Values

ISSUING_PROJECT

public static final java.lang.String ISSUING_PROJECT
See Also:
Constant Field Values

ISSUING_RELATEDDOC

public static final java.lang.String ISSUING_RELATEDDOC
See Also:
Constant Field Values

ISSUING_PART_NUMBER

public static final java.lang.String ISSUING_PART_NUMBER
See Also:
Constant Field Values

ISSUING_DESCRIPTION

public static final java.lang.String ISSUING_DESCRIPTION
See Also:
Constant Field Values

ISSUING_QTY_ISSUED

public static final java.lang.String ISSUING_QTY_ISSUED
See Also:
Constant Field Values

ISSUING_UNIT

public static final java.lang.String ISSUING_UNIT
See Also:
Constant Field Values

ISSUING_DATE

public static final java.lang.String ISSUING_DATE
See Also:
Constant Field Values

ISSUING_OPERATOR

public static final java.lang.String ISSUING_OPERATOR
See Also:
Constant Field Values

FACTOR

public static final double FACTOR
See Also:
Constant Field Values

POS_RAO_NUMBER

public static final java.lang.String POS_RAO_NUMBER
See Also:
Constant Field Values

POS_SALESMAN

public static final java.lang.String POS_SALESMAN
See Also:
Constant Field Values

POS_SALESDATE

public static final java.lang.String POS_SALESDATE
See Also:
Constant Field Values

POS_NETTOTAL

public static final java.lang.String POS_NETTOTAL
See Also:
Constant Field Values

POS_TAXTOTAL

public static final java.lang.String POS_TAXTOTAL
See Also:
Constant Field Values

POS_DISCTOTAL

public static final java.lang.String POS_DISCTOTAL
See Also:
Constant Field Values

POS_AVGCOSTTOTAL

public static final java.lang.String POS_AVGCOSTTOTAL
See Also:
Constant Field Values

POS_PROFITTOTAL

public static final java.lang.String POS_PROFITTOTAL
See Also:
Constant Field Values

POS_PROFITPERCENTTOTAL

public static final java.lang.String POS_PROFITPERCENTTOTAL
See Also:
Constant Field Values

POS_PROFITTOTALBYSTDCOST

public static final java.lang.String POS_PROFITTOTALBYSTDCOST
See Also:
Constant Field Values

POS_PROFITPERCENTTOTALBYSTDCOST

public static final java.lang.String POS_PROFITPERCENTTOTALBYSTDCOST
See Also:
Constant Field Values

POS_ACCOUNTSRECEIVABLE

public static final java.lang.String POS_ACCOUNTSRECEIVABLE
See Also:
Constant Field Values

POS_REALRECEIVABLE

public static final java.lang.String POS_REALRECEIVABLE
See Also:
Constant Field Values

POS_CHANGE

public static final java.lang.String POS_CHANGE
See Also:
Constant Field Values

POS_CUSTOMERID

public static final java.lang.String POS_CUSTOMERID
See Also:
Constant Field Values

POS_FREIGHT

public static final java.lang.String POS_FREIGHT
See Also:
Constant Field Values

POS_TAXRATE

public static final java.lang.String POS_TAXRATE
See Also:
Constant Field Values

POS_TAX

public static final java.lang.String POS_TAX
See Also:
Constant Field Values

POS_ELECSIGNATURE

public static final java.lang.String POS_ELECSIGNATURE
See Also:
Constant Field Values

POS_PAYABLEMETHOD

public static final java.lang.String POS_PAYABLEMETHOD
See Also:
Constant Field Values

POS_CHECKNUMBER

public static final java.lang.String POS_CHECKNUMBER
See Also:
Constant Field Values

POS_CREDITCARDNUMBER

public static final java.lang.String POS_CREDITCARDNUMBER
See Also:
Constant Field Values

POS_DUTYFREENUMBER

public static final java.lang.String POS_DUTYFREENUMBER
See Also:
Constant Field Values

POS_ITEM_NUMBER

public static final java.lang.String POS_ITEM_NUMBER
See Also:
Constant Field Values

POS_ITEM_PARTNUMBER

public static final java.lang.String POS_ITEM_PARTNUMBER
See Also:
Constant Field Values

POS_ITEM_PARTTYPE

public static final java.lang.String POS_ITEM_PARTTYPE
See Also:
Constant Field Values

POS_ITEM_DESCRIPTION

public static final java.lang.String POS_ITEM_DESCRIPTION
See Also:
Constant Field Values

POS_ITEM_QUANTITY

public static final java.lang.String POS_ITEM_QUANTITY
See Also:
Constant Field Values

POS_ITEM_PRICE

public static final java.lang.String POS_ITEM_PRICE
See Also:
Constant Field Values

POS_ITEM_DISCOUNT

public static final java.lang.String POS_ITEM_DISCOUNT
See Also:
Constant Field Values

POS_ITEM_REALTIMEONHAND

public static final java.lang.String POS_ITEM_REALTIMEONHAND
See Also:
Constant Field Values

POS_ITEM_SUBTOTAL

public static final java.lang.String POS_ITEM_SUBTOTAL
See Also:
Constant Field Values

POS_ITEM_NETTOTAL

public static final java.lang.String POS_ITEM_NETTOTAL
See Also:
Constant Field Values

POS_ITEM_TAXTOTAL

public static final java.lang.String POS_ITEM_TAXTOTAL
See Also:
Constant Field Values

POS_ITEM_AVGCOST

public static final java.lang.String POS_ITEM_AVGCOST
See Also:
Constant Field Values

POS_ITEM_STDCOST

public static final java.lang.String POS_ITEM_STDCOST
See Also:
Constant Field Values

POS_ITEM_PROFIT

public static final java.lang.String POS_ITEM_PROFIT
See Also:
Constant Field Values

POS_ITEM_PROFITPERCENT

public static final java.lang.String POS_ITEM_PROFITPERCENT
See Also:
Constant Field Values

POS_ITEM_PROFITBYSTDCOST

public static final java.lang.String POS_ITEM_PROFITBYSTDCOST
See Also:
Constant Field Values

POS_ITEM_PROFITPERCENTBYSTDCOST

public static final java.lang.String POS_ITEM_PROFITPERCENTBYSTDCOST
See Also:
Constant Field Values

POS_ITEM_DUTYFREE

public static final java.lang.String POS_ITEM_DUTYFREE
See Also:
Constant Field Values
Constructor Detail

LabelTemplateConstant

public LabelTemplateConstant()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LabelTemplateItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class LabelTemplateItemPK

java.lang.Object
    extended by  bb.common.LabelTemplateItemPK
All Implemented Interfaces:
java.io.Serializable
public class LabelTemplateItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
LabelTemplateItemPK()
LabelTemplateItemPK(java.lang.Integer ii, java.lang.String itemNumber)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Integer | getIi()
java.lang.String | getItemNumber()
int | hashCode()
void | setIi(java.lang.Integer ii)
void | setItemNumber(java.lang.String itemNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

LabelTemplateItemPK

public LabelTemplateItemPK()

LabelTemplateItemPK

public LabelTemplateItemPK(java.lang.Integer ii,
                           java.lang.String itemNumber)
Method Detail

getIi

public java.lang.Integer getIi()

setIi

public void setIi(java.lang.Integer ii)

getItemNumber

public java.lang.String getItemNumber()

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LabelTemplateItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class LabelTemplateItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.LabelTemplateItemVO
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<LabelTemplateItemVO>
public class LabelTemplateItemVO
extends VO
implements java.io.Serializable, java.lang.Comparable<LabelTemplateItemVO>

See Also:
Serialized Form

Constructor Summary
LabelTemplateItemVO()
Method Summary
int | compareTo(LabelTemplateItemVO o)
boolean | equals(java.lang.Object other)
java.lang.String | getFont()
int | getFontSize()
int | getHeight()
java.lang.String | getItemType()
int | getLabelPosition()
java.lang.String | getName()
LabelTemplateItemPK | getPk()
int | getWidth()
int | getX()
int | getY()
int | hashCode()
boolean | isItalic()
boolean | isLabelVisible()
boolean | isStrikeThrough()
boolean | isUnderline()
void | setFont(java.lang.String font)
void | setFontSize(int fontSize)
void | setHeight(int height)
void | setItalic(boolean italic)
void | setItemType(java.lang.String itemType)
void | setLabelPosition(int labelPosition)
void | setLabelVisible(boolean labelVisible)
void | setName(java.lang.String name)
void | setPk(LabelTemplateItemPK pk)
void | setStrikeThrough(boolean strikeThrough)
void | setUnderline(boolean underline)
void | setWidth(int width)
void | setX(int x)
void | setY(int y)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

LabelTemplateItemVO

public LabelTemplateItemVO()
Method Detail

getPk

public LabelTemplateItemPK getPk()

setPk

public void setPk(LabelTemplateItemPK pk)

getItemType

public java.lang.String getItemType()

setItemType

public void setItemType(java.lang.String itemType)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

isLabelVisible

public boolean isLabelVisible()

setLabelVisible

public void setLabelVisible(boolean labelVisible)

getLabelPosition

public int getLabelPosition()

setLabelPosition

public void setLabelPosition(int labelPosition)

getX

public int getX()

setX

public void setX(int x)

getY

public int getY()

setY

public void setY(int y)

getWidth

public int getWidth()

setWidth

public void setWidth(int width)

getHeight

public int getHeight()

setHeight

public void setHeight(int height)

getFont

public java.lang.String getFont()

setFont

public void setFont(java.lang.String font)

getFontSize

public int getFontSize()

setFontSize

public void setFontSize(int fontSize)

isItalic

public boolean isItalic()

setItalic

public void setItalic(boolean italic)

isStrikeThrough

public boolean isStrikeThrough()

setStrikeThrough

public void setStrikeThrough(boolean strikeThrough)

isUnderline

public boolean isUnderline()

setUnderline

public void setUnderline(boolean underline)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

compareTo

public int compareTo(LabelTemplateItemVO o)
Specified by:
compareTo in interface java.lang.Comparable<LabelTemplateItemVO>
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LabelTemplateVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class LabelTemplateVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.LabelTemplateVO
All Implemented Interfaces:
java.io.Serializable
public class LabelTemplateVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACTIVE
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_HEIGHT
static java.lang.String | ORDER_BY_II
static java.lang.String | ORDER_BY_LABELTYPE
static java.lang.String | ORDER_BY_NAME
static java.lang.String | ORDER_BY_PORTRAITORIENTATION
static java.lang.String | ORDER_BY_WIDTH
Constructor Summary
LabelTemplateVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.lang.String | getComments()
int | getHeight()
java.lang.Integer | getIi()
java.util.Set<LabelTemplateItemVO> | getItems()
java.lang.String | getLabelType()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getName()
java.lang.String | getOrigin()
java.lang.Integer | getVersion()
int | getWidth()
int | hashCode()
boolean | isActive()
boolean | isPortraitOrientation()
void | setActive(boolean active)
void | setAdate(java.util.Date adate)
void | setComments(java.lang.String comments)
void | setHeight(int height)
void | setIi(java.lang.Integer ii)
void | setItems(java.util.Set<LabelTemplateItemVO> items)
void | setLabelType(java.lang.String labelType)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setName(java.lang.String name)
void | setOrigin(java.lang.String origin)
void | setPortraitOrientation(boolean portraitOrientation)
void | setVersion(java.lang.Integer version)
void | setWidth(int width)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_II

public static final java.lang.String ORDER_BY_II
See Also:
Constant Field Values

ORDER_BY_LABELTYPE

public static final java.lang.String ORDER_BY_LABELTYPE
See Also:
Constant Field Values

ORDER_BY_ACTIVE

public static final java.lang.String ORDER_BY_ACTIVE
See Also:
Constant Field Values

ORDER_BY_NAME

public static final java.lang.String ORDER_BY_NAME
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values

ORDER_BY_WIDTH

public static final java.lang.String ORDER_BY_WIDTH
See Also:
Constant Field Values

ORDER_BY_HEIGHT

public static final java.lang.String ORDER_BY_HEIGHT
See Also:
Constant Field Values

ORDER_BY_PORTRAITORIENTATION

public static final java.lang.String ORDER_BY_PORTRAITORIENTATION
See Also:
Constant Field Values
Constructor Detail

LabelTemplateVO

public LabelTemplateVO()
Method Detail

getIi

public java.lang.Integer getIi()

setIi

public void setIi(java.lang.Integer ii)

isActive

public boolean isActive()

setActive

public void setActive(boolean active)

getLabelType

public java.lang.String getLabelType()

setLabelType

public void setLabelType(java.lang.String labelType)

getWidth

public int getWidth()

setWidth

public void setWidth(int width)

getHeight

public int getHeight()

setHeight

public void setHeight(int height)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getItems

public java.util.Set<LabelTemplateItemVO> getItems()

setItems

public void setItems(java.util.Set<LabelTemplateItemVO> items)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getVersion

public java.lang.Integer getVersion()

setVersion

public void setVersion(java.lang.Integer version)

isPortraitOrientation

public boolean isPortraitOrientation()

setPortraitOrientation

public void setPortraitOrientation(boolean portraitOrientation)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


L-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M N O P Q R S T U V W X Y Z

L

LABEL_ASSET - Static variable in class bb.common.LabelTemplateConstant
LABEL_GL - Static variable in class bb.common.LabelTemplateConstant
LABEL_ISSUING - Static variable in class bb.common.LabelTemplateConstant
LABEL_LOCATION - Static variable in class bb.common.LabelTemplateConstant
LABEL_PART - Static variable in class bb.common.LabelTemplateConstant
LABEL_POS - Static variable in class bb.common.LabelTemplateConstant
LABEL_SHIPPING - Static variable in class bb.common.LabelTemplateConstant
LabelTemplateConstant - Class in bb.common
LabelTemplateConstant() - Constructor for class bb.common.LabelTemplateConstant
LabelTemplateItemPK - Class in bb.common
LabelTemplateItemPK() - Constructor for class bb.common.LabelTemplateItemPK
LabelTemplateItemPK(Integer, String) - Constructor for class bb.common.LabelTemplateItemPK
LabelTemplateItemVO - Class in bb.common
LabelTemplateItemVO() - Constructor for class bb.common.LabelTemplateItemVO
LabelTemplateVO - Class in bb.common
LabelTemplateVO() - Constructor for class bb.common.LabelTemplateVO
LABOR - Static variable in class bb.common.Constant.WorkCenterType
LANGUAGE_CN - Static variable in class bb.common.BizBoxServer
LANGUAGE_EN - Static variable in class bb.common.BizBoxServer
LAST_DATE - Static variable in class bb.common.Constant.DateType
LAST_PACKING_BOX_IS_EMPTY - Static variable in class bb.common.BIZReason
lastInvoiceNumber - Variable in class bb.common.SalesOrderItemListResult
LC - Static variable in class bb.common.Constant.ChartOfAccountType
leftTrim(String, String) - Static method in class bb.common.BB2Util
legalValue(int) - Static method in class bb.common.Configure.LoginStatus
legalValue(int) - Static method in class bb.common.Configure.UpdatePermission
legalValue(int) - Static method in class bb.common.Configure.UserLocked
legalValue(int) - Static method in class bb.common.Configure.UserType
LEVEL0 - Static variable in class bb.common.Constant.EmployeeSecurityLevel
LEVEL1 - Static variable in class bb.common.Constant.EmployeeSecurityLevel
LEVEL2 - Static variable in class bb.common.Constant.EmployeeSecurityLevel
LEVEL3 - Static variable in class bb.common.Constant.EmployeeSecurityLevel
LEVEL4 - Static variable in class bb.common.Constant.EmployeeSecurityLevel
LEVEL5 - Static variable in class bb.common.Constant.EmployeeSecurityLevel
LEVEL_OR_UP_ACCOUNT_NUMBER_WRONG - Static variable in class bb.common.BIZReason
LINED_QTY_IS_OVER - Static variable in class bb.common.BIZReason
LINKED_ITEM_NOT_EXIST - Static variable in class bb.common.BIZReason
LINKED_ITEM_STATUS_IS_CLOSED - Static variable in class bb.common.BIZReason
linkNCRtoPartInQA(HashSet<Integer>, String) - Method in interface bb.common.box.WarehouseBox
ListCache - Class in bb.common
ListCache(boolean) - Constructor for class bb.common.ListCache
listToStr(List) - Method in class bb.common.StringListConvertor
LL - Static variable in class bb.common.Constant.ChartOfAccountType
LN_RECEIVER - Static variable in class bb.common.BizTarget
LN_RECEIVER_NOT_EXIST - Static variable in class bb.common.BIZReason
LN_SHIPPER - Static variable in class bb.common.BizTarget
LN_SHIPPER_EXIST - Static variable in class bb.common.BIZReason
LN_SHIPPER_ITEM - Static variable in class bb.common.BizTarget
LN_SHIPPER_ITEM_NOT_EXIST - Static variable in class bb.common.BIZReason
LN_SHIPPER_NOT_EXIST - Static variable in class bb.common.BIZReason
LNR - Static variable in class bb.common.Constant.Prefix
LNSH - Static variable in class bb.common.Constant.Prefix
LnShipperItemListResult - Class in bb.common
LnShipperItemListResult() - Constructor for class bb.common.LnShipperItemListResult
LnShipperListResult - Class in bb.common
LnShipperListResult() - Constructor for class bb.common.LnShipperListResult
LO - Static variable in class bb.common.Constant.ChartOfAccountType
LOCATE_ALREADY_EXIST - Static variable in class bb.common.BIZReason
LOCATION - Static variable in class bb.common.Constant.InventoryWorkSheetOrderBy
LOCATION_FOR_RETURN_MASTERIAL_IS_NOT_CONFIGURED - Static variable in class bb.common.BIZReason
LOCATION_LOCATION - Static variable in class bb.common.LabelTemplateConstant
LOCATION_OF_DEPARTMENT_LOCATION_FOR_BACKFLUSH_ALREADY_ADDED - Static variable in class bb.common.BIZReason
LocationResult - Class in bb.common
LocationResult() - Constructor for class bb.common.LocationResult
LOCKED - Static variable in class bb.common.Configure.UserLocked
LOCKED - Static variable in class bb.common.Constant.VendorQualityStatus
LockedCustomerAddressResult - Class in bb.common
LockedCustomerAddressResult() - Constructor for class bb.common.LockedCustomerAddressResult
lockUser(String) - Method in interface bb.common.box.SecurityBox
lockUserByEmployeeId(String) - Method in interface bb.common.box.SecurityBox
LOG - Static variable in class bb.common.Configure.Module
LogBox - Interface in bb.common.box
login(BB2Login) - Method in interface bb.common.Facade
login(BB2Login) - Method in class bb.common.Spiderman
LOGIN_DATA_NOT_COMPLETED - Static variable in class bb.common.BIZReason
LoginException - Exception in bb.common
LoginException(Exception) - Constructor for exception bb.common.LoginException
LoginException(String) - Constructor for exception bb.common.LoginException
LoginException(Exception, Reason) - Constructor for exception bb.common.LoginException
LoginException(Reason) - Constructor for exception bb.common.LoginException
LoginException(Reason, Object) - Constructor for exception bb.common.LoginException
LoginException(String, Reason) - Constructor for exception bb.common.LoginException
LogInventoryListResult - Class in bb.common
LogInventoryListResult() - Constructor for class bb.common.LogInventoryListResult
LogInventoryVO - Class in bb.common
LogInventoryVO(String, String, String, String, Date, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, String, String, String, String) - Constructor for class bb.common.LogInventoryVO
full constructor
LogInventoryVO() - Constructor for class bb.common.LogInventoryVO
default constructor
LogInventoryVO(String, String, String, String, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, String, String, String) - Constructor for class bb.common.LogInventoryVO
minimal constructor
LogMethodPK - Class in bb.common
LogMethodPK() - Constructor for class bb.common.LogMethodPK
LogMethodPK(String, String) - Constructor for class bb.common.LogMethodPK
LogMethodVO - Class in bb.common
LogMethodVO() - Constructor for class bb.common.LogMethodVO
LogMiscDocumentVO - Class in bb.common
LogMiscDocumentVO() - Constructor for class bb.common.LogMiscDocumentVO
logOffTimeCard(WorkOrderTimeCardVO) - Method in interface bb.common.box.ManufacturingBox
logOffTimeCard(ArrayList) - Method in interface bb.common.box.ManufacturingBox
logout() - Method in interface bb.common.Facade
logoutUser(String, String) - Method in interface bb.common.box.SecurityBox
LogPartDocumentVO - Class in bb.common
LogPartDocumentVO(String, String, String, String, String, Date, String, String, String, String, boolean, String, Long) - Constructor for class bb.common.LogPartDocumentVO
full constructor
LogPartDocumentVO() - Constructor for class bb.common.LogPartDocumentVO
default constructor
LogPartDocumentVO(String, String, String, String, String, String, String, String, boolean, String, Long) - Constructor for class bb.common.LogPartDocumentVO
minimal constructor
LogPartDwfVO - Class in bb.common
LogPartDwfVO() - Constructor for class bb.common.LogPartDwfVO
LogPartDwgVO - Class in bb.common
LogPartDwgVO(String, String, String, String, String, String, Date, String, String, String, String, String, long) - Constructor for class bb.common.LogPartDwgVO
full constructor
LogPartDwgVO() - Constructor for class bb.common.LogPartDwgVO
default constructor
LogPartDwgVO(String, String, String, String, String, String, String, String, String, String, String, long) - Constructor for class bb.common.LogPartDwgVO
minimal constructor
LogTaskVO - Class in bb.common
LogTaskVO() - Constructor for class bb.common.LogTaskVO
LogTrackingVO - Class in bb.common
LogTrackingVO() - Constructor for class bb.common.LogTrackingVO
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M N O P Q R S T U V W X Y Z


ListCache

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ListCache

java.lang.Object
    extended by  bb.common.ListCache
All Implemented Interfaces:
java.io.Serializable
public class ListCache
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ListCache(boolean shift)
Method Summary
boolean | addList(java.util.List<java.lang.Object> list)
void | clear()
void | removeList(java.util.List<java.lang.Object> list)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ListCache

public ListCache(boolean shift)
Method Detail

addList

public boolean addList(java.util.List<java.lang.Object> list)

clear

public void clear()

removeList

public void removeList(java.util.List<java.lang.Object> list)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LnShipperItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class LnShipperItemListResult

java.lang.Object
    extended by  bb.common.LnShipperItemListResult
All Implemented Interfaces:
java.io.Serializable
public class LnShipperItemListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_CUSTOMERNAME
static java.lang.String | ORDER_BY_DATESHIPPED
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_LISTPRICE
static java.lang.String | ORDER_BY_LNSHIPPERNUMBER
static java.lang.String | ORDER_BY_LOANNUMBER
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_QUANTITY
static java.lang.String | ORDER_BY_QUANTITYSHIP
static java.lang.String | ORDER_BY_SERIALNUMBER
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
LnShipperItemListResult()
Method Summary
java.lang.String | getCustomerId()
java.lang.String | getCustomerName()
java.util.Date | getDateShipped()
java.lang.String | getDescription()
java.math.BigDecimal | getListPrice()
java.lang.String | getLnShipperItemNumber()
java.lang.String | getLnShipperNumber()
java.lang.String | getLoanNumber()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getQuantityShip()
java.lang.String | getSerialNumber()
java.lang.String | getStatus()
void | setCustomerId(java.lang.String customerId)
void | setCustomerName(java.lang.String customerName)
void | setDateShipped(java.util.Date dateShipped)
void | setDescription(java.lang.String description)
void | setListPrice(java.math.BigDecimal listPrice)
void | setLnShipperItemNumber(java.lang.String lnShipperItemNumber)
void | setLnShipperNumber(java.lang.String lnShipperNumber)
void | setLoanNumber(java.lang.String loanNumber)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setQuantity(java.math.BigDecimal quantity)
void | setQuantityShip(java.math.BigDecimal quantityShip)
void | setSerialNumber(java.lang.String serialNumber)
void | setStatus(java.lang.String status)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_LNSHIPPERNUMBER

public static final java.lang.String ORDER_BY_LNSHIPPERNUMBER
See Also:
Constant Field Values

ORDER_BY_LOANNUMBER

public static final java.lang.String ORDER_BY_LOANNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_SERIALNUMBER

public static final java.lang.String ORDER_BY_SERIALNUMBER
See Also:
Constant Field Values

ORDER_BY_QUANTITY

public static final java.lang.String ORDER_BY_QUANTITY
See Also:
Constant Field Values

ORDER_BY_QUANTITYSHIP

public static final java.lang.String ORDER_BY_QUANTITYSHIP
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_DATESHIPPED

public static final java.lang.String ORDER_BY_DATESHIPPED
See Also:
Constant Field Values

ORDER_BY_LISTPRICE

public static final java.lang.String ORDER_BY_LISTPRICE
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_CUSTOMERNAME

public static final java.lang.String ORDER_BY_CUSTOMERNAME
See Also:
Constant Field Values
Constructor Detail

LnShipperItemListResult

public LnShipperItemListResult()
Method Detail

getPartNumber

public java.lang.String getPartNumber()

getPartType

public java.lang.String getPartType()

getPartFrom

public java.lang.String getPartFrom()

getDescription

public java.lang.String getDescription()

getQuantity

public java.math.BigDecimal getQuantity()

getQuantityShip

public java.math.BigDecimal getQuantityShip()

getCustomerId

public java.lang.String getCustomerId()

getDateShipped

public java.util.Date getDateShipped()

getListPrice

public java.math.BigDecimal getListPrice()

getStatus

public java.lang.String getStatus()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

setPartType

public void setPartType(java.lang.String partType)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setDescription

public void setDescription(java.lang.String description)

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

setQuantityShip

public void setQuantityShip(java.math.BigDecimal quantityShip)

setCustomerId

public void setCustomerId(java.lang.String customerId)

setDateShipped

public void setDateShipped(java.util.Date dateShipped)

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

setStatus

public void setStatus(java.lang.String status)

getCustomerName

public java.lang.String getCustomerName()

setCustomerName

public void setCustomerName(java.lang.String customerName)

getSerialNumber

public java.lang.String getSerialNumber()

setSerialNumber

public void setSerialNumber(java.lang.String serialNumber)

getLnShipperItemNumber

public java.lang.String getLnShipperItemNumber()

setLnShipperItemNumber

public void setLnShipperItemNumber(java.lang.String lnShipperItemNumber)

getLnShipperNumber

public java.lang.String getLnShipperNumber()

setLnShipperNumber

public void setLnShipperNumber(java.lang.String lnShipperNumber)

getLoanNumber

public java.lang.String getLoanNumber()

setLoanNumber

public void setLoanNumber(java.lang.String loanNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LnShipperListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class LnShipperListResult

java.lang.Object
    extended by  bb.common.LnShipperListResult
All Implemented Interfaces:
java.io.Serializable
public class LnShipperListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_DATESHIPPED
static java.lang.String | ORDER_BY_LNSHIPPERNUMBER
static java.lang.String | ORDER_BY_LOANNUMBER
static java.lang.String | ORDER_BY_SALESMAN
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
LnShipperListResult()
Method Summary
java.lang.String | getChangeOrder()
java.lang.String | getComments()
java.lang.String | getCustomerId()
java.lang.String | getCustomerName()
java.util.Date | getDateShipped()
java.lang.String | getLnShipperNumber()
java.lang.String | getLoanNumber()
java.lang.String | getSalesman()
java.lang.String | getStatus()
void | setChangeOrder(java.lang.String changeOrder)
void | setComments(java.lang.String comments)
void | setCustomerId(java.lang.String customerId)
void | setCustomerName(java.lang.String customerName)
void | setDateShipped(java.util.Date dateShipped)
void | setLnShipperNumber(java.lang.String lnShipperNumber)
void | setLoanNumber(java.lang.String loanNumber)
void | setSalesman(java.lang.String salesman)
void | setStatus(java.lang.String status)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_LNSHIPPERNUMBER

public static final java.lang.String ORDER_BY_LNSHIPPERNUMBER
See Also:
Constant Field Values

ORDER_BY_DATESHIPPED

public static final java.lang.String ORDER_BY_DATESHIPPED
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_LOANNUMBER

public static final java.lang.String ORDER_BY_LOANNUMBER
See Also:
Constant Field Values

ORDER_BY_SALESMAN

public static final java.lang.String ORDER_BY_SALESMAN
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values
Constructor Detail

LnShipperListResult

public LnShipperListResult()
Method Detail

getCustomerId

public java.lang.String getCustomerId()

getSalesman

public java.lang.String getSalesman()

getComments

public java.lang.String getComments()

getStatus

public java.lang.String getStatus()

getCustomerName

public java.lang.String getCustomerName()

getChangeOrder

public java.lang.String getChangeOrder()

setCustomerId

public void setCustomerId(java.lang.String customerId)

setSalesman

public void setSalesman(java.lang.String salesman)

setComments

public void setComments(java.lang.String comments)

setStatus

public void setStatus(java.lang.String status)

setCustomerName

public void setCustomerName(java.lang.String customerName)

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getDateShipped

public java.util.Date getDateShipped()

setDateShipped

public void setDateShipped(java.util.Date dateShipped)

getLnShipperNumber

public java.lang.String getLnShipperNumber()

setLnShipperNumber

public void setLnShipperNumber(java.lang.String lnShipperNumber)

getLoanNumber

public java.lang.String getLoanNumber()

setLoanNumber

public void setLoanNumber(java.lang.String loanNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LocationResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class LocationResult

java.lang.Object
    extended by  bb.common.LocationResult
All Implemented Interfaces:
java.io.Serializable
public class LocationResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
LocationResult()
Method Summary
java.lang.String | getLocation()
java.lang.Integer | getLocationCount()
void | setLocation(java.lang.String location)
void | setLocationCount(java.lang.Integer locationCount)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

LocationResult

public LocationResult()
Method Detail

getLocationCount

public java.lang.Integer getLocationCount()

setLocationCount

public void setLocationCount(java.lang.Integer locationCount)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LockedCustomerAddressResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class LockedCustomerAddressResult

java.lang.Object
    extended by  bb.common.LockedCustomerAddressResult
All Implemented Interfaces:
Alarmable, java.io.Serializable
public class LockedCustomerAddressResult
extends java.lang.Object
implements Alarmable, java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CITY
static java.lang.String | ORDER_BY_COUNTRY
static java.lang.String | ORDER_BY_CRITICALLEVEL
static java.lang.String | ORDER_BY_CUSTOMERFLAG
static java.lang.String | ORDER_BY_ID
static java.lang.String | ORDER_BY_NAME
static java.lang.String | ORDER_BY_QUALITYSTATUS
static java.lang.String | ORDER_BY_STATE
static java.lang.String | ORDER_BY_VENDORCATEGORY
static java.lang.String | ORDER_BY_VENDORFLAG
static java.lang.String | ORDER_BY_ZIP
Constructor Summary
LockedCustomerAddressResult()
Method Summary
boolean | getAlarmValue()
java.lang.String | getCause()
java.lang.String | getCity()
java.lang.String | getComments()
java.lang.String | getCountry()
java.lang.String | getCriticalLevel()
java.lang.String | getCustomerFlag()
java.lang.String | getId()
java.lang.String | getName()
java.lang.String | getQualityStatus()
java.lang.String | getState()
java.lang.String | getVendorCategory()
java.lang.String | getVendorFlag()
java.lang.String | getZip()
void | setAlarmValue(boolean alarmValue)
void | setCause(java.lang.String cause)
void | setCity(java.lang.String city)
void | setComments(java.lang.String comments)
void | setCountry(java.lang.String country)
void | setCriticalLevel(java.lang.String criticalLevel)
void | setCustomerFlag(java.lang.String customerFlag)
void | setId(java.lang.String id)
void | setName(java.lang.String name)
void | setQualityStatus(java.lang.String qualityStatus)
void | setState(java.lang.String state)
void | setVendorCategory(java.lang.String vendorCategory)
void | setVendorFlag(java.lang.String vendorFlag)
void | setZip(java.lang.String zip)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_ID

public static final java.lang.String ORDER_BY_ID
See Also:
Constant Field Values

ORDER_BY_NAME

public static final java.lang.String ORDER_BY_NAME
See Also:
Constant Field Values

ORDER_BY_CITY

public static final java.lang.String ORDER_BY_CITY
See Also:
Constant Field Values

ORDER_BY_STATE

public static final java.lang.String ORDER_BY_STATE
See Also:
Constant Field Values

ORDER_BY_ZIP

public static final java.lang.String ORDER_BY_ZIP
See Also:
Constant Field Values

ORDER_BY_COUNTRY

public static final java.lang.String ORDER_BY_COUNTRY
See Also:
Constant Field Values

ORDER_BY_CUSTOMERFLAG

public static final java.lang.String ORDER_BY_CUSTOMERFLAG
See Also:
Constant Field Values

ORDER_BY_VENDORFLAG

public static final java.lang.String ORDER_BY_VENDORFLAG
See Also:
Constant Field Values

ORDER_BY_VENDORCATEGORY

public static final java.lang.String ORDER_BY_VENDORCATEGORY
See Also:
Constant Field Values

ORDER_BY_CRITICALLEVEL

public static final java.lang.String ORDER_BY_CRITICALLEVEL
See Also:
Constant Field Values

ORDER_BY_QUALITYSTATUS

public static final java.lang.String ORDER_BY_QUALITYSTATUS
See Also:
Constant Field Values
Constructor Detail

LockedCustomerAddressResult

public LockedCustomerAddressResult()
Method Detail

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getCustomerFlag

public java.lang.String getCustomerFlag()

setCustomerFlag

public void setCustomerFlag(java.lang.String customerFlag)

getVendorFlag

public java.lang.String getVendorFlag()

setVendorFlag

public void setVendorFlag(java.lang.String vendorFlag)

getVendorCategory

public java.lang.String getVendorCategory()

setVendorCategory

public void setVendorCategory(java.lang.String vendorCategory)

getCriticalLevel

public java.lang.String getCriticalLevel()

setCriticalLevel

public void setCriticalLevel(java.lang.String criticalLevel)

getQualityStatus

public java.lang.String getQualityStatus()

setQualityStatus

public void setQualityStatus(java.lang.String qualityStatus)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getCity

public java.lang.String getCity()

setCity

public void setCity(java.lang.String city)

getState

public java.lang.String getState()

setState

public void setState(java.lang.String state)

getZip

public java.lang.String getZip()

setZip

public void setZip(java.lang.String zip)

getCountry

public java.lang.String getCountry()

setCountry

public void setCountry(java.lang.String country)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getAlarmValue

public boolean getAlarmValue()
Specified by:
getAlarmValue in interface Alarmable

setAlarmValue

public void setAlarmValue(boolean alarmValue)
Specified by:
setAlarmValue in interface Alarmable

getCause

public java.lang.String getCause()
Specified by:
getCause in interface Alarmable

setCause

public void setCause(java.lang.String cause)
Specified by:
setCause in interface Alarmable
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LogBox

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common.box
Interface LogBox

public interface LogBox

Method Summary
java.util.Collection<OperationLogVO> | findAllEmployeeLogs(int firstIndex, int maxLength)
java.util.Collection<OperationLogVO> | findAllLogs(int firstIndex, int maxLength)
java.util.Collection<OperationLogVO> | findAllNotEmployeeLogs(int firstIndex, int maxLength)
OperationLogVO | findLogByPk(java.lang.Long pk)
java.util.Collection<OperationLogVO> | findLogs(java.lang.String userName, java.lang.String trueName, boolean isEmployee, java.lang.String action, java.lang.String target, java.lang.String comment, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<OperationLogVO> | findLogsByAction(java.lang.String action, int firstIndex, int maxLength)
java.util.Collection<OperationLogVO> | findLogsByLastName(java.lang.String lastName, int firstIndex, int maxLength)
java.util.Collection<OperationLogVO> | findLogsByTarget(java.lang.String target, int firstIndex, int maxLength)
java.util.Collection<OperationLogVO> | findLogsByTrueName(java.lang.String trueName, int firstIndex, int maxLength)
java.util.Collection<OperationLogVO> | findLogsByUserName(java.lang.String userName, int firstIndex, int maxLength)
int | getAllEmployeeLogsCount()
int | getAllLogsCount()
int | getAllNotEmployeeLogsCount()
IpAddressVO | getIpAddressInfo(java.lang.String ipv4Address)
int | getLogsCount(java.lang.String userName, java.lang.String trueName, boolean isEmployee, java.lang.String action, java.lang.String target, java.lang.String comment, java.util.Date fromDate, java.util.Date toDate)
int | getLogsCountByAction(java.lang.String action)
int | getLogsCountByLastName(java.lang.String lastName)
int | getLogsCountByTarget(java.lang.String target)
int | getLogsCountByTrueName(java.lang.String trueName)
int | getLogsCountByUserName(java.lang.String userName)

Method Detail

getAllLogsCount

int getAllLogsCount()
                    throws java.lang.Exception
Throws:
java.lang.Exception

findAllLogs

java.util.Collection<OperationLogVO> findAllLogs(int firstIndex,
                                                 int maxLength)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findLogByPk

OperationLogVO findLogByPk(java.lang.Long pk)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findLogs

java.util.Collection<OperationLogVO> findLogs(java.lang.String userName,
                                              java.lang.String trueName,
                                              boolean isEmployee,
                                              java.lang.String action,
                                              java.lang.String target,
                                              java.lang.String comment,
                                              java.util.Date fromDate,
                                              java.util.Date toDate,
                                              int firstIndex,
                                              int maxLength)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

getLogsCount

int getLogsCount(java.lang.String userName,
                 java.lang.String trueName,
                 boolean isEmployee,
                 java.lang.String action,
                 java.lang.String target,
                 java.lang.String comment,
                 java.util.Date fromDate,
                 java.util.Date toDate)
                 throws java.lang.Exception
Throws:
java.lang.Exception

findLogsByUserName

java.util.Collection<OperationLogVO> findLogsByUserName(java.lang.String userName,
                                                        int firstIndex,
                                                        int maxLength)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getLogsCountByUserName

int getLogsCountByUserName(java.lang.String userName)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findLogsByTrueName

java.util.Collection<OperationLogVO> findLogsByTrueName(java.lang.String trueName,
                                                        int firstIndex,
                                                        int maxLength)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getLogsCountByTrueName

int getLogsCountByTrueName(java.lang.String trueName)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findLogsByLastName

java.util.Collection<OperationLogVO> findLogsByLastName(java.lang.String lastName,
                                                        int firstIndex,
                                                        int maxLength)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getLogsCountByLastName

int getLogsCountByLastName(java.lang.String lastName)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findAllEmployeeLogs

java.util.Collection<OperationLogVO> findAllEmployeeLogs(int firstIndex,
                                                         int maxLength)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getAllEmployeeLogsCount

int getAllEmployeeLogsCount()
                            throws java.lang.Exception
Throws:
java.lang.Exception

findAllNotEmployeeLogs

java.util.Collection<OperationLogVO> findAllNotEmployeeLogs(int firstIndex,
                                                            int maxLength)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getAllNotEmployeeLogsCount

int getAllNotEmployeeLogsCount()
                               throws java.lang.Exception
Throws:
java.lang.Exception

findLogsByAction

java.util.Collection<OperationLogVO> findLogsByAction(java.lang.String action,
                                                      int firstIndex,
                                                      int maxLength)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getLogsCountByAction

int getLogsCountByAction(java.lang.String action)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findLogsByTarget

java.util.Collection<OperationLogVO> findLogsByTarget(java.lang.String target,
                                                      int firstIndex,
                                                      int maxLength)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getLogsCountByTarget

int getLogsCountByTarget(java.lang.String target)
                         throws java.lang.Exception
Throws:
java.lang.Exception

getIpAddressInfo

IpAddressVO getIpAddressInfo(java.lang.String ipv4Address)
                             throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LoginException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class LoginException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  bb.common.BB2ServerException
                extended by  bb.common.LoginException
All Implemented Interfaces:
java.io.Serializable
public class LoginException
extends BB2ServerException

See Also:
Serialized Form

Field Summary
Fields inherited from class bb.common.BB2ServerException
UNKNOWN_EXCEPTION
Constructor Summary
LoginException(java.lang.Exception e)
LoginException(java.lang.Exception e, Reason reason)
LoginException(Reason reason)
LoginException(Reason reason, java.lang.Object parameter)
LoginException(java.lang.String message)
LoginException(java.lang.String message, Reason reason)
Method Summary
Methods inherited from class bb.common.BB2ServerException
getParameter, getReason, setParameter
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

LoginException

public LoginException(java.lang.Exception e)

LoginException

public LoginException(java.lang.String message)

LoginException

public LoginException(java.lang.Exception e,
                      Reason reason)

LoginException

public LoginException(Reason reason)

LoginException

public LoginException(Reason reason,
                      java.lang.Object parameter)

LoginException

public LoginException(java.lang.String message,
                      Reason reason)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LogInventoryListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class LogInventoryListResult

java.lang.Object
    extended by  bb.common.LogInventoryListResult
All Implemented Interfaces:
java.io.Serializable
public class LogInventoryListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DATE
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_EMPLOYEE
static java.lang.String | ORDER_BY_INCOST
static java.lang.String | ORDER_BY_INQTY
static java.lang.String | ORDER_BY_LOCATION
static java.lang.String | ORDER_BY_NEWCOST
static java.lang.String | ORDER_BY_NEWINQA
static java.lang.String | ORDER_BY_NEWINTO
static java.lang.String | ORDER_BY_NEWONHAND
static java.lang.String | ORDER_BY_NEWSIP
static java.lang.String | ORDER_BY_NEWSIT
static java.lang.String | ORDER_BY_NEWWIP
static java.lang.String | ORDER_BY_OLDCOST
static java.lang.String | ORDER_BY_OLDINQA
static java.lang.String | ORDER_BY_OLDINTO
static java.lang.String | ORDER_BY_OLDONHAND
static java.lang.String | ORDER_BY_OLDSIP
static java.lang.String | ORDER_BY_OLDSIT
static java.lang.String | ORDER_BY_OLDWIP
static java.lang.String | ORDER_BY_OUTCOST
static java.lang.String | ORDER_BY_OUTQTY
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PORELATEDOC
static java.lang.String | ORDER_BY_POVENDER
static java.lang.String | ORDER_BY_REFDOC1
static java.lang.String | ORDER_BY_REFDOC2
Constructor Summary
LogInventoryListResult()
Method Summary
java.math.BigDecimal | getCost()
java.util.Date | getDate()
java.lang.String | getDescription()
java.lang.String | getEmployee()
java.math.BigDecimal | getInCost()
java.math.BigDecimal | getInQty()
java.lang.String | getLocation()
java.math.BigDecimal | getNewCost()
java.math.BigDecimal | getNewInQA()
java.math.BigDecimal | getNewInTO()
java.math.BigDecimal | getNewOnhand()
java.math.BigDecimal | getNewSip()
java.math.BigDecimal | getNewSit()
java.math.BigDecimal | getNewWip()
java.math.BigDecimal | getOldCost()
java.math.BigDecimal | getOldInQA()
java.math.BigDecimal | getOldInTO()
java.math.BigDecimal | getOldOnhand()
java.math.BigDecimal | getOldSip()
java.math.BigDecimal | getOldSit()
java.math.BigDecimal | getOldWip()
java.math.BigDecimal | getOutCost()
java.math.BigDecimal | getOutQty()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getPoRelateDoc()
java.lang.String | getPoVender()
java.math.BigDecimal | getQty()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
void | setDate(java.util.Date date)
void | setDescription(java.lang.String description)
void | setEmployee(java.lang.String employee)
void | setInCost(java.math.BigDecimal inCost)
void | setInQty(java.math.BigDecimal inQty)
void | setLocation(java.lang.String location)
void | setNewCost(java.math.BigDecimal newCost)
void | setNewInQA(java.math.BigDecimal newInQA)
void | setNewInTO(java.math.BigDecimal newInTO)
void | setNewOnhand(java.math.BigDecimal newOnhand)
void | setNewSip(java.math.BigDecimal newSip)
void | setNewSit(java.math.BigDecimal newSit)
void | setNewWip(java.math.BigDecimal newWip)
void | setOldCost(java.math.BigDecimal oldCost)
void | setOldInQA(java.math.BigDecimal oldInQA)
void | setOldInTO(java.math.BigDecimal oldInTO)
void | setOldOnhand(java.math.BigDecimal oldOnhand)
void | setOldSip(java.math.BigDecimal oldSip)
void | setOldSit(java.math.BigDecimal oldSit)
void | setOldWip(java.math.BigDecimal oldWip)
void | setOutCost(java.math.BigDecimal outCost)
void | setOutQty(java.math.BigDecimal outQty)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPoRelateDoc(java.lang.String poRelateDoc)
void | setPoVender(java.lang.String poVender)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_DATE

public static final java.lang.String ORDER_BY_DATE
See Also:
Constant Field Values

ORDER_BY_EMPLOYEE

public static final java.lang.String ORDER_BY_EMPLOYEE
See Also:
Constant Field Values

ORDER_BY_INQTY

public static final java.lang.String ORDER_BY_INQTY
See Also:
Constant Field Values

ORDER_BY_INCOST

public static final java.lang.String ORDER_BY_INCOST
See Also:
Constant Field Values

ORDER_BY_OUTQTY

public static final java.lang.String ORDER_BY_OUTQTY
See Also:
Constant Field Values

ORDER_BY_OUTCOST

public static final java.lang.String ORDER_BY_OUTCOST
See Also:
Constant Field Values

ORDER_BY_NEWONHAND

public static final java.lang.String ORDER_BY_NEWONHAND
See Also:
Constant Field Values

ORDER_BY_OLDONHAND

public static final java.lang.String ORDER_BY_OLDONHAND
See Also:
Constant Field Values

ORDER_BY_NEWINQA

public static final java.lang.String ORDER_BY_NEWINQA
See Also:
Constant Field Values

ORDER_BY_OLDINQA

public static final java.lang.String ORDER_BY_OLDINQA
See Also:
Constant Field Values

ORDER_BY_NEWSIP

public static final java.lang.String ORDER_BY_NEWSIP
See Also:
Constant Field Values

ORDER_BY_OLDSIP

public static final java.lang.String ORDER_BY_OLDSIP
See Also:
Constant Field Values

ORDER_BY_NEWSIT

public static final java.lang.String ORDER_BY_NEWSIT
See Also:
Constant Field Values

ORDER_BY_OLDSIT

public static final java.lang.String ORDER_BY_OLDSIT
See Also:
Constant Field Values

ORDER_BY_NEWWIP

public static final java.lang.String ORDER_BY_NEWWIP
See Also:
Constant Field Values

ORDER_BY_OLDWIP

public static final java.lang.String ORDER_BY_OLDWIP
See Also:
Constant Field Values

ORDER_BY_NEWINTO

public static final java.lang.String ORDER_BY_NEWINTO
See Also:
Constant Field Values

ORDER_BY_OLDINTO

public static final java.lang.String ORDER_BY_OLDINTO
See Also:
Constant Field Values

ORDER_BY_NEWCOST

public static final java.lang.String ORDER_BY_NEWCOST
See Also:
Constant Field Values

ORDER_BY_OLDCOST

public static final java.lang.String ORDER_BY_OLDCOST
See Also:
Constant Field Values

ORDER_BY_REFDOC1

public static final java.lang.String ORDER_BY_REFDOC1
See Also:
Constant Field Values

ORDER_BY_REFDOC2

public static final java.lang.String ORDER_BY_REFDOC2
See Also:
Constant Field Values

ORDER_BY_LOCATION

public static final java.lang.String ORDER_BY_LOCATION
See Also:
Constant Field Values

ORDER_BY_PORELATEDOC

public static final java.lang.String ORDER_BY_PORELATEDOC
See Also:
Constant Field Values

ORDER_BY_POVENDER

public static final java.lang.String ORDER_BY_POVENDER
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

LogInventoryListResult

public LogInventoryListResult()
Method Detail

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getEmployee

public java.lang.String getEmployee()

setEmployee

public void setEmployee(java.lang.String employee)

getDate

public java.util.Date getDate()

setDate

public void setDate(java.util.Date date)

getInQty

public java.math.BigDecimal getInQty()

setInQty

public void setInQty(java.math.BigDecimal inQty)

getInCost

public java.math.BigDecimal getInCost()

setInCost

public void setInCost(java.math.BigDecimal inCost)

getOutQty

public java.math.BigDecimal getOutQty()

setOutQty

public void setOutQty(java.math.BigDecimal outQty)

getOutCost

public java.math.BigDecimal getOutCost()

setOutCost

public void setOutCost(java.math.BigDecimal outCost)

getNewOnhand

public java.math.BigDecimal getNewOnhand()

setNewOnhand

public void setNewOnhand(java.math.BigDecimal newOnhand)

getOldOnhand

public java.math.BigDecimal getOldOnhand()

setOldOnhand

public void setOldOnhand(java.math.BigDecimal oldOnhand)

getNewCost

public java.math.BigDecimal getNewCost()

setNewCost

public void setNewCost(java.math.BigDecimal newCost)

getOldCost

public java.math.BigDecimal getOldCost()

setOldCost

public void setOldCost(java.math.BigDecimal oldCost)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

getDescription

public java.lang.String getDescription()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

setDescription

public void setDescription(java.lang.String description)

getNewInQA

public java.math.BigDecimal getNewInQA()

setNewInQA

public void setNewInQA(java.math.BigDecimal newInQA)

getOldInQA

public java.math.BigDecimal getOldInQA()

setOldInQA

public void setOldInQA(java.math.BigDecimal oldInQA)

getNewSip

public java.math.BigDecimal getNewSip()

setNewSip

public void setNewSip(java.math.BigDecimal newSip)

getOldSip

public java.math.BigDecimal getOldSip()

setOldSip

public void setOldSip(java.math.BigDecimal oldSip)

getNewSit

public java.math.BigDecimal getNewSit()

setNewSit

public void setNewSit(java.math.BigDecimal newSit)

getOldSit

public java.math.BigDecimal getOldSit()

setOldSit

public void setOldSit(java.math.BigDecimal oldSit)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getPoRelateDoc

public java.lang.String getPoRelateDoc()

setPoRelateDoc

public void setPoRelateDoc(java.lang.String poRelateDoc)

getPoVender

public java.lang.String getPoVender()

setPoVender

public void setPoVender(java.lang.String poVender)

getQty

public java.math.BigDecimal getQty()

getCost

public java.math.BigDecimal getCost()

getNewWip

public java.math.BigDecimal getNewWip()

setNewWip

public void setNewWip(java.math.BigDecimal newWip)

getOldWip

public java.math.BigDecimal getOldWip()

setOldWip

public void setOldWip(java.math.BigDecimal oldWip)

getNewInTO

public java.math.BigDecimal getNewInTO()

setNewInTO

public void setNewInTO(java.math.BigDecimal newInTO)

getOldInTO

public java.math.BigDecimal getOldInTO()

setOldInTO

public void setOldInTO(java.math.BigDecimal oldInTO)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LogInventoryVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class LogInventoryVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.LogInventoryVO
All Implemented Interfaces:
java.io.Serializable
public class LogInventoryVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
LogInventoryVO()
default constructor
LogInventoryVO(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String lastChangeUser, java.math.BigDecimal inQty, java.math.BigDecimal newOnhand, java.math.BigDecimal oldOnhand, java.math.BigDecimal newCost, java.math.BigDecimal oldCost, java.lang.String refDoc1, java.lang.String refDoc2, java.lang.String serial)
minimal constructor
LogInventoryVO(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String lastChangeUser, java.util.Date lastChangeDate, java.math.BigDecimal inQty, java.math.BigDecimal inCost, java.math.BigDecimal outQty, java.math.BigDecimal newOnhand, java.math.BigDecimal oldOnhand, java.math.BigDecimal newCost, java.math.BigDecimal oldCost, java.lang.String refDoc1, java.lang.String refDoc2, java.lang.String serial, java.lang.String location)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Long | getIi()
java.math.BigDecimal | getInCost()
java.math.BigDecimal | getInQty()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getLocation()
java.math.BigDecimal | getNewCost()
java.math.BigDecimal | getNewInQA()
java.math.BigDecimal | getNewOnhand()
java.math.BigDecimal | getNewSip()
java.math.BigDecimal | getNewSit()
java.math.BigDecimal | getNewWip()
java.math.BigDecimal | getOldCost()
java.math.BigDecimal | getOldInQA()
java.math.BigDecimal | getOldOnhand()
java.math.BigDecimal | getOldSip()
java.math.BigDecimal | getOldSit()
java.math.BigDecimal | getOldWip()
java.math.BigDecimal | getOutCost()
java.math.BigDecimal | getOutQty()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.lang.String | getSerial()
java.math.BigDecimal | getStdCost()
int | hashCode()
void | setIi(java.lang.Long ii)
void | setInCost(java.math.BigDecimal inCost)
void | setInQty(java.math.BigDecimal inQty)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLocation(java.lang.String location)
void | setNewCost(java.math.BigDecimal newCost)
void | setNewInQA(java.math.BigDecimal newInQA)
void | setNewOnhand(java.math.BigDecimal newOnhand)
void | setNewSip(java.math.BigDecimal newSip)
void | setNewSit(java.math.BigDecimal newSit)
void | setNewWip(java.math.BigDecimal newWip)
void | setOldCost(java.math.BigDecimal oldCost)
void | setOldInQA(java.math.BigDecimal oldInQA)
void | setOldOnhand(java.math.BigDecimal oldOnhand)
void | setOldSip(java.math.BigDecimal oldSip)
void | setOldSit(java.math.BigDecimal oldSit)
void | setOldWip(java.math.BigDecimal oldWip)
void | setOutCost(java.math.BigDecimal outCost)
void | setOutQty(java.math.BigDecimal outQty)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setSerial(java.lang.String serial)
void | setStdCost(java.math.BigDecimal stdCost)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

LogInventoryVO

public LogInventoryVO(java.lang.String partNumber,
                      java.lang.String partType,
                      java.lang.String partFrom,
                      java.lang.String lastChangeUser,
                      java.util.Date lastChangeDate,
                      java.math.BigDecimal inQty,
                      java.math.BigDecimal inCost,
                      java.math.BigDecimal outQty,
                      java.math.BigDecimal newOnhand,
                      java.math.BigDecimal oldOnhand,
                      java.math.BigDecimal newCost,
                      java.math.BigDecimal oldCost,
                      java.lang.String refDoc1,
                      java.lang.String refDoc2,
                      java.lang.String serial,
                      java.lang.String location)
full constructor

LogInventoryVO

public LogInventoryVO()
default constructor

LogInventoryVO

public LogInventoryVO(java.lang.String partNumber,
                      java.lang.String partType,
                      java.lang.String partFrom,
                      java.lang.String lastChangeUser,
                      java.math.BigDecimal inQty,
                      java.math.BigDecimal newOnhand,
                      java.math.BigDecimal oldOnhand,
                      java.math.BigDecimal newCost,
                      java.math.BigDecimal oldCost,
                      java.lang.String refDoc1,
                      java.lang.String refDoc2,
                      java.lang.String serial)
minimal constructor

Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getInQty

public java.math.BigDecimal getInQty()

setInQty

public void setInQty(java.math.BigDecimal inQty)

getInCost

public java.math.BigDecimal getInCost()

setInCost

public void setInCost(java.math.BigDecimal inCost)

getOutQty

public java.math.BigDecimal getOutQty()

setOutQty

public void setOutQty(java.math.BigDecimal outQty)

getNewOnhand

public java.math.BigDecimal getNewOnhand()

setNewOnhand

public void setNewOnhand(java.math.BigDecimal newOnhand)

getOldOnhand

public java.math.BigDecimal getOldOnhand()

setOldOnhand

public void setOldOnhand(java.math.BigDecimal oldOnhand)

getNewCost

public java.math.BigDecimal getNewCost()

setNewCost

public void setNewCost(java.math.BigDecimal newCost)

getOldCost

public java.math.BigDecimal getOldCost()

setOldCost

public void setOldCost(java.math.BigDecimal oldCost)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getSerial

public java.lang.String getSerial()

getOutCost

public java.math.BigDecimal getOutCost()

setSerial

public void setSerial(java.lang.String serial)

setOutCost

public void setOutCost(java.math.BigDecimal outCost)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getNewInQA

public java.math.BigDecimal getNewInQA()

setNewInQA

public void setNewInQA(java.math.BigDecimal newInQA)

getOldInQA

public java.math.BigDecimal getOldInQA()

setOldInQA

public void setOldInQA(java.math.BigDecimal oldInQA)

getNewSip

public java.math.BigDecimal getNewSip()

setNewSip

public void setNewSip(java.math.BigDecimal newSip)

getOldSip

public java.math.BigDecimal getOldSip()

setOldSip

public void setOldSip(java.math.BigDecimal oldSip)

getNewSit

public java.math.BigDecimal getNewSit()

setNewSit

public void setNewSit(java.math.BigDecimal newSit)

getOldSit

public java.math.BigDecimal getOldSit()

setOldSit

public void setOldSit(java.math.BigDecimal oldSit)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getNewWip

public java.math.BigDecimal getNewWip()

setNewWip

public void setNewWip(java.math.BigDecimal newWip)

getOldWip

public java.math.BigDecimal getOldWip()

setOldWip

public void setOldWip(java.math.BigDecimal oldWip)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LogMethodPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class LogMethodPK

java.lang.Object
    extended by  bb.common.LogMethodPK
All Implemented Interfaces:
java.io.Serializable
public class LogMethodPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
LogMethodPK()
LogMethodPK(java.lang.String ejbName, java.lang.String methodName)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getEjbName()
java.lang.String | getMethodName()
int | hashCode()
void | setEjbName(java.lang.String ejbName)
void | setMethodName(java.lang.String methodName)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

LogMethodPK

public LogMethodPK()

LogMethodPK

public LogMethodPK(java.lang.String ejbName,
                   java.lang.String methodName)
Method Detail

getEjbName

public java.lang.String getEjbName()

setEjbName

public void setEjbName(java.lang.String ejbName)

getMethodName

public java.lang.String getMethodName()

setMethodName

public void setMethodName(java.lang.String methodName)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LogMethodVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class LogMethodVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.LogMethodVO
All Implemented Interfaces:
java.io.Serializable
public class LogMethodVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
LogMethodVO()
Method Summary
boolean | equals(java.lang.Object other)
LogMethodPK | getPk()
int | hashCode()
boolean | isNeedLog()
void | setNeedLog(boolean needLog)
void | setPk(LogMethodPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

LogMethodVO

public LogMethodVO()
Method Detail

isNeedLog

public boolean isNeedLog()

setNeedLog

public void setNeedLog(boolean needLog)

getPk

public LogMethodPK getPk()

setPk

public void setPk(LogMethodPK pk)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LogMiscDocumentVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class LogMiscDocumentVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.LogMiscDocumentVO
All Implemented Interfaces:
java.io.Serializable
public class LogMiscDocumentVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACTION
static java.lang.String | ORDER_BY_CONTROLNUMBER
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_DOCFILENAME
static java.lang.String | ORDER_BY_DOCLENGTH
static java.lang.String | ORDER_BY_DOCTYPE
static java.lang.String | ORDER_BY_EXTENSION
static java.lang.String | ORDER_BY_LANIP
static java.lang.String | ORDER_BY_LASTCHANGEDATE
static java.lang.String | ORDER_BY_LASTCHANGEUSER
static java.lang.String | ORDER_BY_ORDERITEMNUMBER
static java.lang.String | ORDER_BY_ORDERNUMBER
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_RV
Constructor Summary
LogMiscDocumentVO()
Method Summary
java.lang.String | getAction()
java.lang.String | getCompanyUnitId()
long | getControlNumber()
java.lang.String | getDescription()
java.lang.String | getDocFileName()
long | getDocLength()
java.lang.String | getDocType()
java.lang.String | getExtension()
java.lang.Long | getIi()
java.lang.String | getLanIp()
java.util.Date | getLastchangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getMacAddress()
java.lang.String | getOrderItemNumber()
java.lang.String | getOrderNumber()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getRv()
java.lang.String | getWanIp()
java.lang.String | getYearCode()
void | setAction(java.lang.String action)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setControlNumber(long controlNumber)
void | setDescription(java.lang.String description)
void | setDocFileName(java.lang.String docFileName)
void | setDocLength(long docLength)
void | setDocType(java.lang.String docType)
void | setExtension(java.lang.String extension)
void | setIi(java.lang.Long ii)
void | setLanIp(java.lang.String lanIp)
void | setLastchangeDate(java.util.Date lastchangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setMacAddress(java.lang.String macAddress)
void | setOrderItemNumber(java.lang.String orderItemNumber)
void | setOrderNumber(java.lang.String orderNumber)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setRv(java.lang.String rv)
void | setWanIp(java.lang.String wanIp)
void | setYearCode(java.lang.String yearCode)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_DOCTYPE

public static final java.lang.String ORDER_BY_DOCTYPE
See Also:
Constant Field Values

ORDER_BY_ORDERNUMBER

public static final java.lang.String ORDER_BY_ORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_ORDERITEMNUMBER

public static final java.lang.String ORDER_BY_ORDERITEMNUMBER
See Also:
Constant Field Values

ORDER_BY_CONTROLNUMBER

public static final java.lang.String ORDER_BY_CONTROLNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_RV

public static final java.lang.String ORDER_BY_RV
See Also:
Constant Field Values

ORDER_BY_ACTION

public static final java.lang.String ORDER_BY_ACTION
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEUSER

public static final java.lang.String ORDER_BY_LASTCHANGEUSER
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEDATE

public static final java.lang.String ORDER_BY_LASTCHANGEDATE
See Also:
Constant Field Values

ORDER_BY_LANIP

public static final java.lang.String ORDER_BY_LANIP
See Also:
Constant Field Values

ORDER_BY_DOCFILENAME

public static final java.lang.String ORDER_BY_DOCFILENAME
See Also:
Constant Field Values

ORDER_BY_EXTENSION

public static final java.lang.String ORDER_BY_EXTENSION
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_DOCLENGTH

public static final java.lang.String ORDER_BY_DOCLENGTH
See Also:
Constant Field Values
Constructor Detail

LogMiscDocumentVO

public LogMiscDocumentVO()
Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getDocType

public java.lang.String getDocType()

setDocType

public void setDocType(java.lang.String docType)

getOrderNumber

public java.lang.String getOrderNumber()

setOrderNumber

public void setOrderNumber(java.lang.String orderNumber)

getOrderItemNumber

public java.lang.String getOrderItemNumber()

setOrderItemNumber

public void setOrderItemNumber(java.lang.String orderItemNumber)

getControlNumber

public long getControlNumber()

setControlNumber

public void setControlNumber(long controlNumber)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getRv

public java.lang.String getRv()

setRv

public void setRv(java.lang.String rv)

getAction

public java.lang.String getAction()

setAction

public void setAction(java.lang.String action)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastchangeDate

public java.util.Date getLastchangeDate()

setLastchangeDate

public void setLastchangeDate(java.util.Date lastchangeDate)

getWanIp

public java.lang.String getWanIp()

setWanIp

public void setWanIp(java.lang.String wanIp)

getLanIp

public java.lang.String getLanIp()

setLanIp

public void setLanIp(java.lang.String lanIp)

getMacAddress

public java.lang.String getMacAddress()

setMacAddress

public void setMacAddress(java.lang.String macAddress)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getDocFileName

public java.lang.String getDocFileName()

setDocFileName

public void setDocFileName(java.lang.String docFileName)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

getDocLength

public long getDocLength()

setDocLength

public void setDocLength(long docLength)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getYearCode

public java.lang.String getYearCode()

setYearCode

public void setYearCode(java.lang.String yearCode)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LogPartDocumentVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class LogPartDocumentVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.LogPartDocumentVO
All Implemented Interfaces:
java.io.Serializable
public class LogPartDocumentVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACTION
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_DOCUMENTLENGTHBYTE
static java.lang.String | ORDER_BY_DOCUMENTTYPE
static java.lang.String | ORDER_BY_DOCVERSION
static java.lang.String | ORDER_BY_LANGUAGE
static java.lang.String | ORDER_BY_LANIP
static java.lang.String | ORDER_BY_LASTCHANGEDATE
static java.lang.String | ORDER_BY_LASTCHANGEUSER
static java.lang.String | ORDER_BY_MACADDRESS
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PUBLICDOC
static java.lang.String | ORDER_BY_WANIP
Constructor Summary
LogPartDocumentVO()
default constructor
LogPartDocumentVO(java.lang.String partNumber, java.lang.String documentType, java.lang.String language, java.lang.String docVersion, java.lang.String action, java.util.Date lastChangeDate, java.lang.String lastChangeUser, java.lang.String wanIp, java.lang.String lanIp, java.lang.String macAddress, boolean publicDoc, java.lang.String description, java.lang.Long documentLengthByte)
full constructor
LogPartDocumentVO(java.lang.String partNumber, java.lang.String language, java.lang.String docVersion, java.lang.String action, java.lang.String lastChangeUser, java.lang.String wanIp, java.lang.String lanIp, java.lang.String macAddress, boolean publicDoc, java.lang.String description, java.lang.Long documentLengthByte)
minimal constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAction()
java.lang.String | getDescription()
java.lang.Long | getDocumentLengthByte()
java.lang.String | getDocumentType()
java.lang.String | getDocVersion()
java.lang.String | getExtension()
java.lang.Long | getIi()
java.lang.String | getLanguage()
java.lang.String | getLanIp()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getMacAddress()
java.lang.String | getPartNumber()
java.lang.String | getWanIp()
int | hashCode()
boolean | isPublicDoc()
void | setAction(java.lang.String action)
void | setDescription(java.lang.String description)
void | setDocumentLengthByte(java.lang.Long documentLengthByte)
void | setDocumentType(java.lang.String documentType)
void | setDocVersion(java.lang.String docVersion)
void | setExtension(java.lang.String extension)
void | setIi(java.lang.Long ii)
void | setLanguage(java.lang.String language)
void | setLanIp(java.lang.String lanIp)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setMacAddress(java.lang.String macAddress)
void | setPartNumber(java.lang.String partNumber)
void | setPublicDoc(boolean publicDoc)
void | setWanIp(java.lang.String wanIp)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_DOCUMENTTYPE

public static final java.lang.String ORDER_BY_DOCUMENTTYPE
See Also:
Constant Field Values

ORDER_BY_LANGUAGE

public static final java.lang.String ORDER_BY_LANGUAGE
See Also:
Constant Field Values

ORDER_BY_DOCVERSION

public static final java.lang.String ORDER_BY_DOCVERSION
See Also:
Constant Field Values

ORDER_BY_ACTION

public static final java.lang.String ORDER_BY_ACTION
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEDATE

public static final java.lang.String ORDER_BY_LASTCHANGEDATE
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEUSER

public static final java.lang.String ORDER_BY_LASTCHANGEUSER
See Also:
Constant Field Values

ORDER_BY_WANIP

public static final java.lang.String ORDER_BY_WANIP
See Also:
Constant Field Values

ORDER_BY_LANIP

public static final java.lang.String ORDER_BY_LANIP
See Also:
Constant Field Values

ORDER_BY_MACADDRESS

public static final java.lang.String ORDER_BY_MACADDRESS
See Also:
Constant Field Values

ORDER_BY_PUBLICDOC

public static final java.lang.String ORDER_BY_PUBLICDOC
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_DOCUMENTLENGTHBYTE

public static final java.lang.String ORDER_BY_DOCUMENTLENGTHBYTE
See Also:
Constant Field Values
Constructor Detail

LogPartDocumentVO

public LogPartDocumentVO(java.lang.String partNumber,
                         java.lang.String documentType,
                         java.lang.String language,
                         java.lang.String docVersion,
                         java.lang.String action,
                         java.util.Date lastChangeDate,
                         java.lang.String lastChangeUser,
                         java.lang.String wanIp,
                         java.lang.String lanIp,
                         java.lang.String macAddress,
                         boolean publicDoc,
                         java.lang.String description,
                         java.lang.Long documentLengthByte)
full constructor

LogPartDocumentVO

public LogPartDocumentVO()
default constructor

LogPartDocumentVO

public LogPartDocumentVO(java.lang.String partNumber,
                         java.lang.String language,
                         java.lang.String docVersion,
                         java.lang.String action,
                         java.lang.String lastChangeUser,
                         java.lang.String wanIp,
                         java.lang.String lanIp,
                         java.lang.String macAddress,
                         boolean publicDoc,
                         java.lang.String description,
                         java.lang.Long documentLengthByte)
minimal constructor

Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getDocumentType

public java.lang.String getDocumentType()

setDocumentType

public void setDocumentType(java.lang.String documentType)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getDocVersion

public java.lang.String getDocVersion()

setDocVersion

public void setDocVersion(java.lang.String docVersion)

getAction

public java.lang.String getAction()

setAction

public void setAction(java.lang.String action)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getWanIp

public java.lang.String getWanIp()

setWanIp

public void setWanIp(java.lang.String wanIp)

getLanIp

public java.lang.String getLanIp()

setLanIp

public void setLanIp(java.lang.String lanIp)

getMacAddress

public java.lang.String getMacAddress()

setMacAddress

public void setMacAddress(java.lang.String macAddress)

isPublicDoc

public boolean isPublicDoc()

setPublicDoc

public void setPublicDoc(boolean publicDoc)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getDocumentLengthByte

public java.lang.Long getDocumentLengthByte()

setDocumentLengthByte

public void setDocumentLengthByte(java.lang.Long documentLengthByte)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LogPartDwfVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class LogPartDwfVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.LogPartDwfVO
All Implemented Interfaces:
java.io.Serializable
public class LogPartDwfVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACTION
static java.lang.String | ORDER_BY_BB2COUNT
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_DWFEXTENSION
static java.lang.String | ORDER_BY_DWFLENGTH
static java.lang.String | ORDER_BY_DWGLENGTH
static java.lang.String | ORDER_BY_LANIP
static java.lang.String | ORDER_BY_LASTCHANGEDATE
static java.lang.String | ORDER_BY_LASTCHANGEUSER
static java.lang.String | ORDER_BY_MACADDRESS
static java.lang.String | ORDER_BY_PARTFROM
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_REVISION
static java.lang.String | ORDER_BY_WANIP
Constructor Summary
LogPartDwfVO()
Method Summary
java.lang.String | getAction()
java.lang.Integer | getCount()
java.lang.String | getDescription()
java.lang.String | getDwfExtension()
long | getDwfLength()
java.lang.Long | getIi()
java.lang.String | getLanguage()
java.lang.String | getLanIp()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getMacAddress()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getRevision()
java.lang.String | getWanIp()
void | setAction(java.lang.String action)
void | setCount(java.lang.Integer count)
void | setDescription(java.lang.String description)
void | setDwfExtension(java.lang.String dwfExtension)
void | setDwfLength(long dwfLength)
void | setIi(java.lang.Long ii)
void | setLanguage(java.lang.String language)
void | setLanIp(java.lang.String lanIp)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setMacAddress(java.lang.String macAddress)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setRevision(java.lang.String revision)
void | setWanIp(java.lang.String wanIp)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_BB2COUNT

public static final java.lang.String ORDER_BY_BB2COUNT
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTFROM

public static final java.lang.String ORDER_BY_PARTFROM
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEUSER

public static final java.lang.String ORDER_BY_LASTCHANGEUSER
See Also:
Constant Field Values

ORDER_BY_DWGLENGTH

public static final java.lang.String ORDER_BY_DWGLENGTH
See Also:
Constant Field Values

ORDER_BY_ACTION

public static final java.lang.String ORDER_BY_ACTION
See Also:
Constant Field Values

ORDER_BY_WANIP

public static final java.lang.String ORDER_BY_WANIP
See Also:
Constant Field Values

ORDER_BY_LANIP

public static final java.lang.String ORDER_BY_LANIP
See Also:
Constant Field Values

ORDER_BY_MACADDRESS

public static final java.lang.String ORDER_BY_MACADDRESS
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_DWFEXTENSION

public static final java.lang.String ORDER_BY_DWFEXTENSION
See Also:
Constant Field Values

ORDER_BY_DWFLENGTH

public static final java.lang.String ORDER_BY_DWFLENGTH
See Also:
Constant Field Values

ORDER_BY_REVISION

public static final java.lang.String ORDER_BY_REVISION
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEDATE

public static final java.lang.String ORDER_BY_LASTCHANGEDATE
See Also:
Constant Field Values
Constructor Detail

LogPartDwfVO

public LogPartDwfVO()
Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getAction

public java.lang.String getAction()

setAction

public void setAction(java.lang.String action)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getWanIp

public java.lang.String getWanIp()

setWanIp

public void setWanIp(java.lang.String wanIp)

getLanIp

public java.lang.String getLanIp()

setLanIp

public void setLanIp(java.lang.String lanIp)

getMacAddress

public java.lang.String getMacAddress()

setMacAddress

public void setMacAddress(java.lang.String macAddress)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getDwfExtension

public java.lang.String getDwfExtension()

setDwfExtension

public void setDwfExtension(java.lang.String dwfExtension)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getCount

public java.lang.Integer getCount()

setCount

public void setCount(java.lang.Integer count)

getDwfLength

public long getDwfLength()

setDwfLength

public void setDwfLength(long dwfLength)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LogPartDwgVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class LogPartDwgVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.LogPartDwgVO
All Implemented Interfaces:
java.io.Serializable
public class LogPartDwgVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACTION
static java.lang.String | ORDER_BY_BB2COUNT
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_DWGEXTENSION
static java.lang.String | ORDER_BY_DWGLENGTH
static java.lang.String | ORDER_BY_LANIP
static java.lang.String | ORDER_BY_LASTCHANGEDATE
static java.lang.String | ORDER_BY_LASTCHANGEUSER
static java.lang.String | ORDER_BY_MACADDRESS
static java.lang.String | ORDER_BY_PARTFROM
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_REVISION
static java.lang.String | ORDER_BY_WANIP
Constructor Summary
LogPartDwgVO()
default constructor
LogPartDwgVO(java.lang.String partNumber, java.lang.String partType, java.lang.String revision, java.lang.String partFrom, java.lang.String action, java.lang.String lastChangeUser, java.util.Date lastChangeDate, java.lang.String wanIp, java.lang.String lanIp, java.lang.String macAddress, java.lang.String description, java.lang.String dwgExtension, long dwgLength)
full constructor
LogPartDwgVO(java.lang.String partNumber, java.lang.String partType, java.lang.String revision, java.lang.String partFrom, java.lang.String action, java.lang.String lastChangeUser, java.lang.String wanIp, java.lang.String lanIp, java.lang.String macAddress, java.lang.String description, java.lang.String dwgExtension, long dwgLength)
minimal constructor
Method Summary
java.lang.String | getAction()
java.lang.Integer | getCount()
java.lang.String | getDescription()
java.lang.String | getDwgExtension()
long | getDwgLength()
java.lang.Long | getIi()
java.lang.String | getLanIp()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getMacAddress()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getRevision()
java.lang.String | getWanIp()
void | setAction(java.lang.String action)
void | setCount(java.lang.Integer count)
void | setDescription(java.lang.String description)
void | setDwgExtension(java.lang.String dwgExtension)
void | setDwgLength(long dwgLength)
void | setIi(java.lang.Long ii)
void | setLanIp(java.lang.String lanIp)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setMacAddress(java.lang.String macAddress)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setRevision(java.lang.String revision)
void | setWanIp(java.lang.String wanIp)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_BB2COUNT

public static final java.lang.String ORDER_BY_BB2COUNT
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTFROM

public static final java.lang.String ORDER_BY_PARTFROM
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEUSER

public static final java.lang.String ORDER_BY_LASTCHANGEUSER
See Also:
Constant Field Values

ORDER_BY_DWGLENGTH

public static final java.lang.String ORDER_BY_DWGLENGTH
See Also:
Constant Field Values

ORDER_BY_ACTION

public static final java.lang.String ORDER_BY_ACTION
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEDATE

public static final java.lang.String ORDER_BY_LASTCHANGEDATE
See Also:
Constant Field Values

ORDER_BY_WANIP

public static final java.lang.String ORDER_BY_WANIP
See Also:
Constant Field Values

ORDER_BY_LANIP

public static final java.lang.String ORDER_BY_LANIP
See Also:
Constant Field Values

ORDER_BY_MACADDRESS

public static final java.lang.String ORDER_BY_MACADDRESS
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_DWGEXTENSION

public static final java.lang.String ORDER_BY_DWGEXTENSION
See Also:
Constant Field Values

ORDER_BY_REVISION

public static final java.lang.String ORDER_BY_REVISION
See Also:
Constant Field Values
Constructor Detail

LogPartDwgVO

public LogPartDwgVO(java.lang.String partNumber,
                    java.lang.String partType,
                    java.lang.String revision,
                    java.lang.String partFrom,
                    java.lang.String action,
                    java.lang.String lastChangeUser,
                    java.util.Date lastChangeDate,
                    java.lang.String wanIp,
                    java.lang.String lanIp,
                    java.lang.String macAddress,
                    java.lang.String description,
                    java.lang.String dwgExtension,
                    long dwgLength)
full constructor

LogPartDwgVO

public LogPartDwgVO()
default constructor

LogPartDwgVO

public LogPartDwgVO(java.lang.String partNumber,
                    java.lang.String partType,
                    java.lang.String revision,
                    java.lang.String partFrom,
                    java.lang.String action,
                    java.lang.String lastChangeUser,
                    java.lang.String wanIp,
                    java.lang.String lanIp,
                    java.lang.String macAddress,
                    java.lang.String description,
                    java.lang.String dwgExtension,
                    long dwgLength)
minimal constructor

Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getAction

public java.lang.String getAction()

setAction

public void setAction(java.lang.String action)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getWanIp

public java.lang.String getWanIp()

setWanIp

public void setWanIp(java.lang.String wanIp)

getLanIp

public java.lang.String getLanIp()

setLanIp

public void setLanIp(java.lang.String lanIp)

getMacAddress

public java.lang.String getMacAddress()

setMacAddress

public void setMacAddress(java.lang.String macAddress)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getDwgExtension

public java.lang.String getDwgExtension()

setDwgExtension

public void setDwgExtension(java.lang.String dwgExtension)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getCount

public java.lang.Integer getCount()

setCount

public void setCount(java.lang.Integer count)

getDwgLength

public long getDwgLength()

setDwgLength

public void setDwgLength(long dwgLength)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LogTaskVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class LogTaskVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.LogTaskVO
All Implemented Interfaces:
java.io.Serializable
public class LogTaskVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_ENDDATE
static java.lang.String | ORDER_BY_NAME
static java.lang.String | ORDER_BY_STARTDATE
Constructor Summary
LogTaskVO()
Method Summary
java.lang.String | getComments()
java.lang.String | getDescription()
java.util.Date | getEndDate()
java.lang.Long | getIi()
java.lang.String | getName()
java.util.Date | getStartDate()
java.lang.Long | getTaskId()
boolean | isSuccess()
void | setComments(java.lang.String comments)
void | setDescription(java.lang.String description)
void | setEndDate(java.util.Date endDate)
void | setIi(java.lang.Long ii)
void | setName(java.lang.String name)
void | setStartDate(java.util.Date startDate)
void | setSuccess(boolean success)
void | setTaskId(java.lang.Long taskId)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_NAME

public static final java.lang.String ORDER_BY_NAME
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_STARTDATE

public static final java.lang.String ORDER_BY_STARTDATE
See Also:
Constant Field Values

ORDER_BY_ENDDATE

public static final java.lang.String ORDER_BY_ENDDATE
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values
Constructor Detail

LogTaskVO

public LogTaskVO()
Method Detail

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getEndDate

public java.util.Date getEndDate()

setEndDate

public void setEndDate(java.util.Date endDate)

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getStartDate

public java.util.Date getStartDate()

setStartDate

public void setStartDate(java.util.Date startDate)

isSuccess

public boolean isSuccess()

setSuccess

public void setSuccess(boolean success)

getTaskId

public java.lang.Long getTaskId()

setTaskId

public void setTaskId(java.lang.Long taskId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LogTrackingVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class LogTrackingVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.LogTrackingVO
All Implemented Interfaces:
java.io.Serializable
public class LogTrackingVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_INQTY
static java.lang.String | ORDER_BY_LASTCHANGEDATE
static java.lang.String | ORDER_BY_LASTCHANGEUSER
static java.lang.String | ORDER_BY_LOCATION
static java.lang.String | ORDER_BY_OUTQTY
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_REFDOC1
static java.lang.String | ORDER_BY_REFDOC2
static java.lang.String | ORDER_BY_TRACKINGNUMBER
Constructor Summary
LogTrackingVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAddressId()
java.lang.String | getAddressName()
java.lang.String | getDescription()
java.lang.Long | getIi()
java.math.BigDecimal | getInQty()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getLocation()
int | getOperationType()
java.math.BigDecimal | getOutQty()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.lang.String | getTrackingNumber()
int | hashCode()
void | setAddressId(java.lang.String addressId)
void | setAddressName(java.lang.String addressName)
void | setDescription(java.lang.String description)
void | setIi(java.lang.Long ii)
void | setInQty(java.math.BigDecimal inQty)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLocation(java.lang.String location)
void | setOperationType(int operationType)
void | setOutQty(java.math.BigDecimal outQty)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setTrackingNumber(java.lang.String trackingNumber)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEUSER

public static final java.lang.String ORDER_BY_LASTCHANGEUSER
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEDATE

public static final java.lang.String ORDER_BY_LASTCHANGEDATE
See Also:
Constant Field Values

ORDER_BY_INQTY

public static final java.lang.String ORDER_BY_INQTY
See Also:
Constant Field Values

ORDER_BY_OUTQTY

public static final java.lang.String ORDER_BY_OUTQTY
See Also:
Constant Field Values

ORDER_BY_TRACKINGNUMBER

public static final java.lang.String ORDER_BY_TRACKINGNUMBER
See Also:
Constant Field Values

ORDER_BY_REFDOC1

public static final java.lang.String ORDER_BY_REFDOC1
See Also:
Constant Field Values

ORDER_BY_REFDOC2

public static final java.lang.String ORDER_BY_REFDOC2
See Also:
Constant Field Values

ORDER_BY_LOCATION

public static final java.lang.String ORDER_BY_LOCATION
See Also:
Constant Field Values
Constructor Detail

LogTrackingVO

public LogTrackingVO()
Method Detail

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getInQty

public java.math.BigDecimal getInQty()

setInQty

public void setInQty(java.math.BigDecimal inQty)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getOutQty

public java.math.BigDecimal getOutQty()

setOutQty

public void setOutQty(java.math.BigDecimal outQty)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getTrackingNumber

public java.lang.String getTrackingNumber()

setTrackingNumber

public void setTrackingNumber(java.lang.String trackingNumber)

getOperationType

public int getOperationType()

setOperationType

public void setOperationType(int operationType)

getAddressId

public java.lang.String getAddressId()

setAddressId

public void setAddressId(java.lang.String addressId)

getAddressName

public java.lang.String getAddressName()

setAddressName

public void setAddressName(java.lang.String addressName)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MaintenanceItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class MaintenanceItemPK

java.lang.Object
    extended by  bb.common.MaintenanceItemPK
All Implemented Interfaces:
java.io.Serializable
public class MaintenanceItemPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
MaintenanceItemPK()
default constructor
MaintenanceItemPK(java.lang.String equimentId, java.lang.Integer ii)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getEquimentId()
java.lang.Integer | getIi()
int | hashCode()
void | setEquimentId(java.lang.String equimentId)
void | setIi(java.lang.Integer ii)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

MaintenanceItemPK

public MaintenanceItemPK(java.lang.String equimentId,
                         java.lang.Integer ii)
full constructor

MaintenanceItemPK

public MaintenanceItemPK()
default constructor

Method Detail

getEquimentId

public java.lang.String getEquimentId()

setEquimentId

public void setEquimentId(java.lang.String equimentId)

getIi

public java.lang.Integer getIi()

setIi

public void setIi(java.lang.Integer ii)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MaintenanceItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class MaintenanceItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.MaintenanceItemVO
All Implemented Interfaces:
java.io.Serializable
public class MaintenanceItemVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
MaintenanceItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getMaintemanceBy()
java.lang.String | getMaintemanceNotes()
java.util.Date | getMaintenanceDate()
MaintenanceItemPK | getPk()
java.lang.String | getType()
int | hashCode()
void | setMaintemanceBy(java.lang.String maintemanceBy)
void | setMaintemanceNotes(java.lang.String maintemanceNotes)
void | setMaintenanceDate(java.util.Date maintenanceDate)
void | setPk(MaintenanceItemPK pk)
void | setType(java.lang.String type)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

MaintenanceItemVO

public MaintenanceItemVO()
Method Detail

getPk

public MaintenanceItemPK getPk()

setPk

public void setPk(MaintenanceItemPK pk)

getMaintenanceDate

public java.util.Date getMaintenanceDate()

setMaintenanceDate

public void setMaintenanceDate(java.util.Date maintenanceDate)

getType

public java.lang.String getType()

setType

public void setType(java.lang.String type)

getMaintemanceBy

public java.lang.String getMaintemanceBy()

setMaintemanceBy

public void setMaintemanceBy(java.lang.String maintemanceBy)

getMaintemanceNotes

public java.lang.String getMaintemanceNotes()

setMaintemanceNotes

public void setMaintemanceNotes(java.lang.String maintemanceNotes)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MakeAccountPayableAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class MakeAccountPayableAgent

java.lang.Object
    extended by  bb.common.MakeAccountPayableAgent
All Implemented Interfaces:
java.io.Serializable
public class MakeAccountPayableAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
MakeAccountPayableAgent()
Method Summary
java.util.Date | getApGLDate()
java.lang.String | getBatchNumber()
java.lang.String | getBp()
java.lang.String | getCompanyUnitOfDebitAcc()
java.lang.String | getCurrency()
java.lang.String | getDebitAccount()
java.math.BigDecimal | getFreight()
java.lang.String | getGlSummary()
int | getLastChangeTimes()
java.math.BigDecimal | getPayThisTotal()
java.util.ArrayList<java.lang.String> | getPrepayApplyPoNumbers()
java.lang.Boolean | getReCalSubTotal()
java.lang.Boolean | getReCalTax()
java.lang.String | getReceiverComments()
java.util.ArrayList<ReceiverItemPK> | getReceiverItems()
java.lang.String | getReceiverNotes()
java.lang.String | getReceiverNumber()
java.math.BigDecimal | getSubTotal()
java.math.BigDecimal | getTax()
java.lang.String | getTerms()
java.lang.String | getVendorId()
java.util.Date | getVendorInvoiceDate()
java.lang.String | getVendorInvoiceNumber()
java.math.BigDecimal | getVendorInvoiceTotal()
java.lang.String | getVendorShipper()
boolean | isPrepayApply()
void | setApGLDate(java.util.Date apGLDate)
void | setBatchNumber(java.lang.String batchNumber)
void | setBp(java.lang.String bp)
void | setCompanyUnitOfDebitAcc(java.lang.String companyUnitOfDebitAcc)
void | setCurrency(java.lang.String currency)
void | setDebitAccount(java.lang.String debitAccount)
void | setFreight(java.math.BigDecimal freight)
void | setGlSummary(java.lang.String glSummary)
void | setLastChangeTimes(int lastChangeTimes)
void | setPayThisTotal(java.math.BigDecimal payThisTotal)
void | setPrepayApply(boolean prepayApply)
void | setPrepayApplyPoNumbers(java.util.ArrayList<java.lang.String> prepayApplyPoNumbers)
void | setReCalSubTotal(java.lang.Boolean reCalSubTotal)
void | setReCalTax(java.lang.Boolean reCalTax)
void | setReceiverComments(java.lang.String receiverComments)
void | setReceiverItems(java.util.ArrayList<ReceiverItemPK> receiverItemPKs)
void | setReceiverNotes(java.lang.String receiverNotes)
void | setReceiverNumber(java.lang.String receiverNumber)
void | setSubTotal(java.math.BigDecimal subTotal)
void | setTax(java.math.BigDecimal tax)
void | setTerms(java.lang.String terms)
void | setVendorId(java.lang.String vendorId)
void | setVendorInvoiceDate(java.util.Date vendorInvoiceDate)
void | setVendorInvoiceNumber(java.lang.String vendorInvoiceNumber)
void | setVendorInvoiceTotal(java.math.BigDecimal vendorInvoiceTotal)
void | setVendorShipper(java.lang.String vendorShipper)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MakeAccountPayableAgent

public MakeAccountPayableAgent()
Method Detail

getReceiverNotes

public java.lang.String getReceiverNotes()

getReceiverComments

public java.lang.String getReceiverComments()

getFreight

public java.math.BigDecimal getFreight()

getTax

public java.math.BigDecimal getTax()

getSubTotal

public java.math.BigDecimal getSubTotal()

getTerms

public java.lang.String getTerms()

getDebitAccount

public java.lang.String getDebitAccount()

getCurrency

public java.lang.String getCurrency()

getBatchNumber

public java.lang.String getBatchNumber()

getVendorShipper

public java.lang.String getVendorShipper()

getVendorInvoiceTotal

public java.math.BigDecimal getVendorInvoiceTotal()

getVendorInvoiceDate

public java.util.Date getVendorInvoiceDate()

setVendorInvoiceNumber

public void setVendorInvoiceNumber(java.lang.String vendorInvoiceNumber)

setReceiverNotes

public void setReceiverNotes(java.lang.String receiverNotes)

setReceiverComments

public void setReceiverComments(java.lang.String receiverComments)

setFreight

public void setFreight(java.math.BigDecimal freight)

setTax

public void setTax(java.math.BigDecimal tax)

setSubTotal

public void setSubTotal(java.math.BigDecimal subTotal)

setTerms

public void setTerms(java.lang.String terms)

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

setCurrency

public void setCurrency(java.lang.String currency)

setBatchNumber

public void setBatchNumber(java.lang.String batchNumber)

setVendorShipper

public void setVendorShipper(java.lang.String vendorShipper)

setVendorInvoiceTotal

public void setVendorInvoiceTotal(java.math.BigDecimal vendorInvoiceTotal)

setVendorInvoiceDate

public void setVendorInvoiceDate(java.util.Date vendorInvoiceDate)

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)

setPayThisTotal

public void setPayThisTotal(java.math.BigDecimal payThisTotal)

setLastChangeTimes

public void setLastChangeTimes(int lastChangeTimes)

setReCalSubTotal

public void setReCalSubTotal(java.lang.Boolean reCalSubTotal)

setReCalTax

public void setReCalTax(java.lang.Boolean reCalTax)

setVendorId

public void setVendorId(java.lang.String vendorId)

getVendorInvoiceNumber

public java.lang.String getVendorInvoiceNumber()

getReceiverNumber

public java.lang.String getReceiverNumber()

getPayThisTotal

public java.math.BigDecimal getPayThisTotal()

getLastChangeTimes

public int getLastChangeTimes()

getReCalSubTotal

public java.lang.Boolean getReCalSubTotal()

getReCalTax

public java.lang.Boolean getReCalTax()

getVendorId

public java.lang.String getVendorId()

getCompanyUnitOfDebitAcc

public java.lang.String getCompanyUnitOfDebitAcc()

setCompanyUnitOfDebitAcc

public void setCompanyUnitOfDebitAcc(java.lang.String companyUnitOfDebitAcc)

isPrepayApply

public boolean isPrepayApply()

setPrepayApply

public void setPrepayApply(boolean prepayApply)

getBp

public java.lang.String getBp()

setBp

public void setBp(java.lang.String bp)

getGlSummary

public java.lang.String getGlSummary()

setGlSummary

public void setGlSummary(java.lang.String glSummary)

getReceiverItems

public java.util.ArrayList<ReceiverItemPK> getReceiverItems()

setReceiverItems

public void setReceiverItems(java.util.ArrayList<ReceiverItemPK> receiverItemPKs)

getApGLDate

public java.util.Date getApGLDate()

setApGLDate

public void setApGLDate(java.util.Date apGLDate)

getPrepayApplyPoNumbers

public java.util.ArrayList<java.lang.String> getPrepayApplyPoNumbers()

setPrepayApplyPoNumbers

public void setPrepayApplyPoNumbers(java.util.ArrayList<java.lang.String> prepayApplyPoNumbers)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MakeBillAndHoldInvoiceAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class MakeBillAndHoldInvoiceAgent

java.lang.Object
    extended by  bb.common.MakeBillAndHoldInvoiceAgent
All Implemented Interfaces:
java.io.Serializable
public class MakeBillAndHoldInvoiceAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
MakeBillAndHoldInvoiceAgent()
Method Summary
java.lang.String | getBillToId()
java.lang.String | getCompanyUnitId()
java.lang.String | getCurrency()
java.lang.String | getCustomId()
java.util.Date | getDateInvoiced()
java.lang.String | getDebitAccount()
java.math.BigDecimal | getFreight()
java.lang.String | getGlSummary()
int | getLastChangeTimes()
java.lang.Boolean | getReCalSubTotal()
java.lang.Boolean | getReCalTax()
java.util.ArrayList<SalesOrderItemPK> | getSalesItemPks()
java.lang.String | getShipperNumber()
java.lang.String | getShipToId()
java.lang.String | getShipVia()
java.math.BigDecimal | getSubTotal()
java.math.BigDecimal | getTax()
java.lang.String | getTerms()
boolean | isPrepayApply()
void | setBillToId(java.lang.String billToId)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCurrency(java.lang.String currency)
void | setCustomId(java.lang.String customId)
void | setDateInvoiced(java.util.Date dateInvoiced)
void | setDebitAccount(java.lang.String debitAccount)
void | setFreight(java.math.BigDecimal freight)
void | setGlSummary(java.lang.String glSummary)
void | setLastChangeTimes(int lastChangeTimes)
void | setPrepayApply(boolean prepayApply)
void | setReCalSubTotal(java.lang.Boolean reCalSubTotal)
void | setReCalTax(java.lang.Boolean reCalTax)
void | setSalesItemPks(java.util.ArrayList<SalesOrderItemPK> salesItemPks)
void | setShipperNumber(java.lang.String shipperNumber)
void | setShipToId(java.lang.String shipToId)
void | setShipVia(java.lang.String shipVia)
void | setSubTotal(java.math.BigDecimal subTotal)
void | setTax(java.math.BigDecimal tax)
void | setTerms(java.lang.String terms)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MakeBillAndHoldInvoiceAgent

public MakeBillAndHoldInvoiceAgent()
Method Detail

getTerms

public java.lang.String getTerms()

getDebitAccount

public java.lang.String getDebitAccount()

getCurrency

public java.lang.String getCurrency()

setDateInvoiced

public void setDateInvoiced(java.util.Date dateInvoiced)

setTerms

public void setTerms(java.lang.String terms)

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

setCurrency

public void setCurrency(java.lang.String currency)

setTax

public void setTax(java.math.BigDecimal tax)

setFreight

public void setFreight(java.math.BigDecimal freight)

setSubTotal

public void setSubTotal(java.math.BigDecimal subTotal)

setShipperNumber

public void setShipperNumber(java.lang.String shipperNumber)

setLastChangeTimes

public void setLastChangeTimes(int lastChangeTimes)

setReCalSubTotal

public void setReCalSubTotal(java.lang.Boolean reCalSubTotal)

setReCalTax

public void setReCalTax(java.lang.Boolean reCalTax)

getDateInvoiced

public java.util.Date getDateInvoiced()

getTax

public java.math.BigDecimal getTax()

getFreight

public java.math.BigDecimal getFreight()

getSubTotal

public java.math.BigDecimal getSubTotal()

getShipperNumber

public java.lang.String getShipperNumber()

getLastChangeTimes

public int getLastChangeTimes()

getReCalSubTotal

public java.lang.Boolean getReCalSubTotal()

getReCalTax

public java.lang.Boolean getReCalTax()

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

isPrepayApply

public boolean isPrepayApply()

setPrepayApply

public void setPrepayApply(boolean prepayApply)

getGlSummary

public java.lang.String getGlSummary()

setGlSummary

public void setGlSummary(java.lang.String glSummary)

getCustomId

public java.lang.String getCustomId()

setCustomId

public void setCustomId(java.lang.String customId)

getBillToId

public java.lang.String getBillToId()

setBillToId

public void setBillToId(java.lang.String billToId)

getShipToId

public java.lang.String getShipToId()

setShipToId

public void setShipToId(java.lang.String shipToId)

getSalesItemPks

public java.util.ArrayList<SalesOrderItemPK> getSalesItemPks()

setSalesItemPks

public void setSalesItemPks(java.util.ArrayList<SalesOrderItemPK> salesItemPks)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MakeCheckAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class MakeCheckAgent

java.lang.Object
    extended by  bb.common.MakeCheckAgent
All Implemented Interfaces:
java.io.Serializable
public class MakeCheckAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
MakeCheckAgent()
Method Summary
java.lang.String | getAccountNumber()
java.lang.String | getApNumber()
java.lang.String | getAppItem()
java.lang.String | getCheckNumber()
java.lang.String | getCompanyUnitOfAcc()
java.lang.String | getCompanyUnitOfDebitAcc()
java.lang.String | getDebitAccount()
java.lang.String | getGlSummary()
java.util.Date | getMakeDate()
java.lang.String | getMemo()
java.lang.String | getName()
java.lang.String | getPoNumber()
java.math.BigDecimal | getTotalToPaid()
java.lang.String | getVendorId()
void | setAccountNumber(java.lang.String accountNumber)
void | setApNumber(java.lang.String apNumber)
void | setAppItem(java.lang.String appItem)
void | setCheckNumber(java.lang.String checkNumber)
void | setCompanyUnitOfAcc(java.lang.String companyUnitOfAcc)
void | setCompanyUnitOfDebitAcc(java.lang.String companyUnitOfDebitAcc)
void | setDebitAccount(java.lang.String debitAccount)
void | setGlSummary(java.lang.String glSummary)
void | setMakeDate(java.util.Date makeDate)
void | setMemo(java.lang.String memo)
void | setName(java.lang.String name)
void | setPoNumber(java.lang.String poNumber)
void | setTotalToPaid(java.math.BigDecimal totalToPaid)
void | setVendorId(java.lang.String vendorId)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MakeCheckAgent

public MakeCheckAgent()
Method Detail

getMemo

public java.lang.String getMemo()

getTotalToPaid

public java.math.BigDecimal getTotalToPaid()

getDebitAccount

public java.lang.String getDebitAccount()

getMakeDate

public java.util.Date getMakeDate()

getCheckNumber

public java.lang.String getCheckNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

setMemo

public void setMemo(java.lang.String memo)

setTotalToPaid

public void setTotalToPaid(java.math.BigDecimal totalToPaid)

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

setMakeDate

public void setMakeDate(java.util.Date makeDate)

setCheckNumber

public void setCheckNumber(java.lang.String checkNumber)

setName

public void setName(java.lang.String name)

setVendorId

public void setVendorId(java.lang.String vendorId)

setPoNumber

public void setPoNumber(java.lang.String poNumber)

setApNumber

public void setApNumber(java.lang.String apNumber)

getAccountNumber

public java.lang.String getAccountNumber()

getName

public java.lang.String getName()

getVendorId

public java.lang.String getVendorId()

getPoNumber

public java.lang.String getPoNumber()

getApNumber

public java.lang.String getApNumber()

getCompanyUnitOfAcc

public java.lang.String getCompanyUnitOfAcc()

setCompanyUnitOfAcc

public void setCompanyUnitOfAcc(java.lang.String companyUnitOfAcc)

getCompanyUnitOfDebitAcc

public java.lang.String getCompanyUnitOfDebitAcc()

setCompanyUnitOfDebitAcc

public void setCompanyUnitOfDebitAcc(java.lang.String companyUnitOfDebitAcc)

getAppItem

public java.lang.String getAppItem()

setAppItem

public void setAppItem(java.lang.String appItem)

getGlSummary

public java.lang.String getGlSummary()

setGlSummary

public void setGlSummary(java.lang.String glSummary)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MakeCreditMemoAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class MakeCreditMemoAgent

java.lang.Object
    extended by  bb.common.MakeCreditMemoAgent
All Implemented Interfaces:
java.io.Serializable
public class MakeCreditMemoAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
MakeCreditMemoAgent()
Method Summary
java.math.BigDecimal | getArFreight()
java.math.BigDecimal | getArNet()
java.math.BigDecimal | getArTax()
java.lang.String | getBatchNumber()
java.lang.String | getBp()
java.lang.String | getCompanyUnitId()
java.lang.String | getCreditAccount()
java.lang.String | getCreditMemoComments()
java.lang.String | getCreditMemoNotes()
java.lang.String | getCurrency()
java.util.Date | getCustomerInvoiceDate()
java.lang.String | getCustomerInvoiceNumber()
java.math.BigDecimal | getCustomerInvoiceTotal()
java.util.Date | getDateInvoice()
java.lang.String | getGlSummary()
int | getLastChangeTimes()
java.lang.String | getRmaReceiverNumber()
java.lang.String | getTerms()
void | setArFreight(java.math.BigDecimal arFreight)
void | setArNet(java.math.BigDecimal arNet)
void | setArTax(java.math.BigDecimal arTax)
void | setBatchNumber(java.lang.String batchNumber)
void | setBp(java.lang.String bp)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCreditAccount(java.lang.String creditAccount)
void | setCreditMemoComments(java.lang.String creditMemoComments)
void | setCreditMemoNotes(java.lang.String creditMemoNotes)
void | setCurrency(java.lang.String currency)
void | setCustomerInvoiceDate(java.util.Date customerInvoiceDate)
void | setCustomerInvoiceNumber(java.lang.String customerInvoiceNumber)
void | setCustomerInvoiceTotal(java.math.BigDecimal customerInvoiceTotal)
void | setDateInvoice(java.util.Date dateInvoice)
void | setGlSummary(java.lang.String glSummary)
void | setLastChangeTimes(int lastChangeTimes)
void | setRmaReceiverNumber(java.lang.String rmaReceiverNumber)
void | setTerms(java.lang.String terms)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MakeCreditMemoAgent

public MakeCreditMemoAgent()
Method Detail

getLastChangeTimes

public int getLastChangeTimes()

setLastChangeTimes

public void setLastChangeTimes(int lastChangeTimes)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getRmaReceiverNumber

public java.lang.String getRmaReceiverNumber()

setRmaReceiverNumber

public void setRmaReceiverNumber(java.lang.String rmaReceiverNumber)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getBatchNumber

public java.lang.String getBatchNumber()

setBatchNumber

public void setBatchNumber(java.lang.String batchNumber)

getCreditAccount

public java.lang.String getCreditAccount()

setCreditAccount

public void setCreditAccount(java.lang.String creditAccount)

getCreditMemoComments

public java.lang.String getCreditMemoComments()

setCreditMemoComments

public void setCreditMemoComments(java.lang.String creditMemoComments)

getCreditMemoNotes

public java.lang.String getCreditMemoNotes()

setCreditMemoNotes

public void setCreditMemoNotes(java.lang.String creditMemoNotes)

getArFreight

public java.math.BigDecimal getArFreight()

setArFreight

public void setArFreight(java.math.BigDecimal arFreight)

getArNet

public java.math.BigDecimal getArNet()

setArNet

public void setArNet(java.math.BigDecimal arNet)

getArTax

public java.math.BigDecimal getArTax()

setArTax

public void setArTax(java.math.BigDecimal arTax)

getDateInvoice

public java.util.Date getDateInvoice()

setDateInvoice

public void setDateInvoice(java.util.Date dateInvoice)

getCustomerInvoiceDate

public java.util.Date getCustomerInvoiceDate()

setCustomerInvoiceDate

public void setCustomerInvoiceDate(java.util.Date customerInvoiceDate)

getCustomerInvoiceNumber

public java.lang.String getCustomerInvoiceNumber()

setCustomerInvoiceNumber

public void setCustomerInvoiceNumber(java.lang.String customerInvoiceNumber)

getCustomerInvoiceTotal

public java.math.BigDecimal getCustomerInvoiceTotal()

setCustomerInvoiceTotal

public void setCustomerInvoiceTotal(java.math.BigDecimal customerInvoiceTotal)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getBp

public java.lang.String getBp()

setBp

public void setBp(java.lang.String bp)

getGlSummary

public java.lang.String getGlSummary()

setGlSummary

public void setGlSummary(java.lang.String glSummary)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MakeDebitMemoAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class MakeDebitMemoAgent

java.lang.Object
    extended by  bb.common.MakeDebitMemoAgent
All Implemented Interfaces:
java.io.Serializable
public class MakeDebitMemoAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
MakeDebitMemoAgent()
Method Summary
java.lang.String | getBatchNumber()
java.lang.String | getCompanyUnitId()
java.lang.String | getCurrency()
java.lang.String | getDebitAccount()
java.lang.String | getDebitMemoComments()
java.lang.String | getDebitMemoNotes()
java.lang.String | getGlSummary()
java.math.BigDecimal | getPayThisTotal()
java.lang.Boolean | getReCalSubTotal()
java.lang.Boolean | getReCalTax()
java.lang.String | getRtvShipperNumber()
java.lang.String | getTerms()
java.util.Date | getVendorInvoiceDate()
java.lang.String | getVendorInvoiceNumber()
java.math.BigDecimal | getVendorInvoiceTotal()
void | setBatchNumber(java.lang.String batchNumber)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCurrency(java.lang.String currency)
void | setDebitAccount(java.lang.String debitAccount)
void | setDebitMemoComments(java.lang.String debitMemoComments)
void | setDebitMemoNotes(java.lang.String debitMemoNotes)
void | setGlSummary(java.lang.String glSummary)
void | setPayThisTotal(java.math.BigDecimal payThisTotal)
void | setReCalSubTotal(java.lang.Boolean reCalSubTotal)
void | setReCalTax(java.lang.Boolean reCalTax)
void | setRtvShipperNumber(java.lang.String rtvShipperNumber)
void | setTerms(java.lang.String terms)
void | setVendorInvoiceDate(java.util.Date vendorInvoiceDate)
void | setVendorInvoiceNumber(java.lang.String vendorInvoiceNumber)
void | setVendorInvoiceTotal(java.math.BigDecimal vendorInvoiceTotal)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MakeDebitMemoAgent

public MakeDebitMemoAgent()
Method Detail

getBatchNumber

public java.lang.String getBatchNumber()

setBatchNumber

public void setBatchNumber(java.lang.String batchNumber)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getDebitAccount

public java.lang.String getDebitAccount()

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

getDebitMemoComments

public java.lang.String getDebitMemoComments()

setDebitMemoComments

public void setDebitMemoComments(java.lang.String debitMemoComments)

getDebitMemoNotes

public java.lang.String getDebitMemoNotes()

setDebitMemoNotes

public void setDebitMemoNotes(java.lang.String debitMemoNotes)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getRtvShipperNumber

public java.lang.String getRtvShipperNumber()

setRtvShipperNumber

public void setRtvShipperNumber(java.lang.String rtvShipperNumber)

getVendorInvoiceDate

public java.util.Date getVendorInvoiceDate()

setVendorInvoiceDate

public void setVendorInvoiceDate(java.util.Date vendorInvoiceDate)

getVendorInvoiceNumber

public java.lang.String getVendorInvoiceNumber()

setVendorInvoiceNumber

public void setVendorInvoiceNumber(java.lang.String vendorInvoiceNumber)

getReCalSubTotal

public java.lang.Boolean getReCalSubTotal()

setReCalSubTotal

public void setReCalSubTotal(java.lang.Boolean reCalSubTotal)

getReCalTax

public java.lang.Boolean getReCalTax()

setReCalTax

public void setReCalTax(java.lang.Boolean reCalTax)

getVendorInvoiceTotal

public java.math.BigDecimal getVendorInvoiceTotal()

setVendorInvoiceTotal

public void setVendorInvoiceTotal(java.math.BigDecimal vendorInvoiceTotal)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getGlSummary

public java.lang.String getGlSummary()

setGlSummary

public void setGlSummary(java.lang.String glSummary)

getPayThisTotal

public java.math.BigDecimal getPayThisTotal()

setPayThisTotal

public void setPayThisTotal(java.math.BigDecimal payThisTotal)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MakeInvoiceAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class MakeInvoiceAgent

java.lang.Object
    extended by  bb.common.MakeInvoiceAgent
All Implemented Interfaces:
java.io.Serializable
public class MakeInvoiceAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
MakeInvoiceAgent()
Method Summary
java.lang.String | getBillToId()
java.lang.String | getCarrierAccount()
java.lang.String | getCompanyUnitId()
java.lang.String | getCurrency()
java.lang.String | getCustomId()
java.util.Date | getDateInvoiced()
java.lang.String | getDebitAccount()
java.math.BigDecimal | getFreight()
java.lang.String | getFreightRateCode()
java.lang.String | getGlSummary()
int | getLastChangeTimes()
java.util.ArrayList<java.lang.String> | getPrepayApplySoNumbers()
java.lang.Boolean | getReCalSubTotal()
java.lang.Boolean | getReCalTax()
java.util.ArrayList<SalesOrderItemPK> | getSalesItemPks()
java.util.ArrayList<ShipperItemPK> | getShipperItemPks()
java.lang.String | getShipperNumber()
java.lang.String | getShipToId()
java.lang.String | getShipVia()
java.math.BigDecimal | getSubTotal()
java.math.BigDecimal | getTax()
java.lang.String | getTerms()
java.lang.String | getTracking()
boolean | isPrepayApply()
void | setBillToId(java.lang.String billToId)
void | setCarrierAccount(java.lang.String carrierAccount)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCurrency(java.lang.String currency)
void | setCustomId(java.lang.String customId)
void | setDateInvoiced(java.util.Date dateInvoiced)
void | setDebitAccount(java.lang.String debitAccount)
void | setFreight(java.math.BigDecimal freight)
void | setFreightRateCode(java.lang.String freightRateCode)
void | setGlSummary(java.lang.String glSummary)
void | setLastChangeTimes(int lastChangeTimes)
void | setPrepayApply(boolean prepayApply)
void | setPrepayApplySoNumbers(java.util.ArrayList<java.lang.String> prepayApplySoNumbers)
void | setReCalSubTotal(java.lang.Boolean reCalSubTotal)
void | setReCalTax(java.lang.Boolean reCalTax)
void | setSalesItemPks(java.util.ArrayList<SalesOrderItemPK> salesItemPks)
void | setShipperItemPks(java.util.ArrayList<ShipperItemPK> shipperItemPks)
void | setShipperNumber(java.lang.String shipperNumber)
void | setShipToId(java.lang.String shipToId)
void | setShipVia(java.lang.String shipVia)
void | setSubTotal(java.math.BigDecimal subTotal)
void | setTax(java.math.BigDecimal tax)
void | setTerms(java.lang.String terms)
void | setTracking(java.lang.String tracking)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MakeInvoiceAgent

public MakeInvoiceAgent()
Method Detail

getTerms

public java.lang.String getTerms()

getDebitAccount

public java.lang.String getDebitAccount()

getCurrency

public java.lang.String getCurrency()

setDateInvoiced

public void setDateInvoiced(java.util.Date dateInvoiced)

setTerms

public void setTerms(java.lang.String terms)

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

setCurrency

public void setCurrency(java.lang.String currency)

setTax

public void setTax(java.math.BigDecimal tax)

setFreight

public void setFreight(java.math.BigDecimal freight)

setSubTotal

public void setSubTotal(java.math.BigDecimal subTotal)

setShipperNumber

public void setShipperNumber(java.lang.String shipperNumber)

setLastChangeTimes

public void setLastChangeTimes(int lastChangeTimes)

setReCalSubTotal

public void setReCalSubTotal(java.lang.Boolean reCalSubTotal)

setReCalTax

public void setReCalTax(java.lang.Boolean reCalTax)

getDateInvoiced

public java.util.Date getDateInvoiced()

getTax

public java.math.BigDecimal getTax()

getFreight

public java.math.BigDecimal getFreight()

getSubTotal

public java.math.BigDecimal getSubTotal()

getShipperNumber

public java.lang.String getShipperNumber()

getLastChangeTimes

public int getLastChangeTimes()

getReCalSubTotal

public java.lang.Boolean getReCalSubTotal()

getReCalTax

public java.lang.Boolean getReCalTax()

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

isPrepayApply

public boolean isPrepayApply()

setPrepayApply

public void setPrepayApply(boolean prepayApply)

getGlSummary

public java.lang.String getGlSummary()

setGlSummary

public void setGlSummary(java.lang.String glSummary)

getShipperItemPks

public java.util.ArrayList<ShipperItemPK> getShipperItemPks()

setShipperItemPks

public void setShipperItemPks(java.util.ArrayList<ShipperItemPK> shipperItemPks)

getCustomId

public java.lang.String getCustomId()

setCustomId

public void setCustomId(java.lang.String customId)

getBillToId

public java.lang.String getBillToId()

setBillToId

public void setBillToId(java.lang.String billToId)

getShipToId

public java.lang.String getShipToId()

setShipToId

public void setShipToId(java.lang.String shipToId)

getSalesItemPks

public java.util.ArrayList<SalesOrderItemPK> getSalesItemPks()

setSalesItemPks

public void setSalesItemPks(java.util.ArrayList<SalesOrderItemPK> salesItemPks)

getCarrierAccount

public java.lang.String getCarrierAccount()

setCarrierAccount

public void setCarrierAccount(java.lang.String carrierAccount)

getFreightRateCode

public java.lang.String getFreightRateCode()

setFreightRateCode

public void setFreightRateCode(java.lang.String freightRateCode)

getTracking

public java.lang.String getTracking()

setTracking

public void setTracking(java.lang.String tracking)

getPrepayApplySoNumbers

public java.util.ArrayList<java.lang.String> getPrepayApplySoNumbers()

setPrepayApplySoNumbers

public void setPrepayApplySoNumbers(java.util.ArrayList<java.lang.String> prepayApplySoNumbers)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MakePrepaymentCheckAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class MakePrepaymentCheckAgent

java.lang.Object
    extended by  bb.common.MakePrepaymentCheckAgent
All Implemented Interfaces:
java.io.Serializable
public class MakePrepaymentCheckAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
MakePrepaymentCheckAgent()
Method Summary
java.lang.String | getAccountNumber()
java.lang.String | getAppNumber()
java.lang.String | getCheckNumber()
java.lang.String | getCompanyUnitOfAcc()
java.math.BigDecimal | getExchange()
java.lang.String | getGlSummary()
java.lang.String | getItemNumber()
java.util.Date | getMakeDate()
java.lang.String | getMemo()
java.math.BigDecimal | getTotalToPaid()
void | setAccountNumber(java.lang.String accountNumber)
void | setAppNumber(java.lang.String appNumber)
void | setCheckNumber(java.lang.String checkNumber)
void | setCompanyUnitOfAcc(java.lang.String companyUnitOfAcc)
void | setExchange(java.math.BigDecimal exchange)
void | setGlSummary(java.lang.String glSummary)
void | setItemNumber(java.lang.String itemNumber)
void | setMakeDate(java.util.Date makeDate)
void | setMemo(java.lang.String memo)
void | setTotalToPaid(java.math.BigDecimal totalToPaid)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MakePrepaymentCheckAgent

public MakePrepaymentCheckAgent()
Method Detail

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getAppNumber

public java.lang.String getAppNumber()

setAppNumber

public void setAppNumber(java.lang.String appNumber)

getCheckNumber

public java.lang.String getCheckNumber()

setCheckNumber

public void setCheckNumber(java.lang.String checkNumber)

getCompanyUnitOfAcc

public java.lang.String getCompanyUnitOfAcc()

setCompanyUnitOfAcc

public void setCompanyUnitOfAcc(java.lang.String companyUnitOfAcc)

getItemNumber

public java.lang.String getItemNumber()

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

getMakeDate

public java.util.Date getMakeDate()

setMakeDate

public void setMakeDate(java.util.Date makeDate)

getMemo

public java.lang.String getMemo()

setMemo

public void setMemo(java.lang.String memo)

getTotalToPaid

public java.math.BigDecimal getTotalToPaid()

setTotalToPaid

public void setTotalToPaid(java.math.BigDecimal totalToPaid)

getGlSummary

public java.lang.String getGlSummary()

setGlSummary

public void setGlSummary(java.lang.String glSummary)

getExchange

public java.math.BigDecimal getExchange()

setExchange

public void setExchange(java.math.BigDecimal exchange)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ManagementBox

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common.box
Interface ManagementBox

public interface ManagementBox

Method Summary
java.util.Collection<SalesOrder12MonthMarginResult> | findSalesOrder12MonthMarginResults(int firstIndex, int maxLength)
AccountInfoCenterResult | getAccountInfoCenterResult()
AccountInfoCenterResult | getAccountInfoDashBoardResult()
EngineeringInfoCenterResult | getEngineeringInfoCenterResult()
OutputValueByMonthResult | getFiscalYearOutputValue()
InventoryAmountByMonth | getInventoryAmountByDate(java.util.Date startDate, java.util.Date endDate)
InfoByMonthChartResult | getInvoicesInfoByFiscalYear(java.lang.String fyNumber)
InfoByMonthChartResult | getInvoicesInfoByMonth(int monthCount)
WOIssuedByMonthChartResult | getOverIssueItemByMonth(int monthCount)
InfoByFiscalChartResult | getPOFiscalYearInfoCenter()
InfoByMonthChartResult | getPurchaseInfoByFiscalYear()
InfoByMonthChartResult | getPurchaseInfoByMonth(int monthCount)
PurchaseOnTimeResult | getPurchaseOnTimeResult(OnTimeAgent agent)
InfoByMonthChartResult | getPurchaseOrderBacklogInfoByMonth(int monthCount)
PurchaseOrderOnTimeResult | getPurchaseOrderOnTimeResult()
PurchasingInfoCenterResult | getPurchasingInfoCenterResult()
QualityInfoCenterResult | getQualityInfoCenterResult()
InfoByMonthChartResult | getReceiversInfoByFiscalYear()
InfoByMonthChartResult | getReceiversInfoByMonth(int monthCount)
InfoByMonthChartResult | getSalesInfoByFiscalYear(java.lang.String fyNumber)
InfoByMonthChartResult | getSalesInfoByMonth(int monthCount, boolean includeCancel)
SalesInfoCenterResult | getSalesInfoCenterResult()
InfoByMonthChartResult | getSalesInfoDashBoardByFiscalYear()
SalesOnTimeResult | getSalesOnTimeResult(OnTimeAgent agent)
int | getSalesOrder12MonthMarginResultsCount()
InfoByMonthChartResult | getSalesOrderBacklogInfoByMonth(int monthCount)
SalesOrderOnTimeResult | getSalesOrderOnTimeResult()
WareHousingInfoCenterResult | getWareHousingInfoCenterResult()
InfoByMonthChartResult | getWOInfoByFiscalYear()
InfoByMonthChartResult | getWOInfoByMonth(int monthCount)
WorkOrderInfoCenterResult | getWorkOrderInfoCenterResult()

Method Detail

getSalesInfoCenterResult

SalesInfoCenterResult getSalesInfoCenterResult()
                                               throws java.lang.Exception
Throws:
java.lang.Exception

getSalesInfoByMonth

InfoByMonthChartResult getSalesInfoByMonth(int monthCount,
                                           boolean includeCancel)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOrderBacklogInfoByMonth

InfoByMonthChartResult getSalesOrderBacklogInfoByMonth(int monthCount)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderBacklogInfoByMonth

InfoByMonthChartResult getPurchaseOrderBacklogInfoByMonth(int monthCount)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getSalesInfoByFiscalYear

InfoByMonthChartResult getSalesInfoByFiscalYear(java.lang.String fyNumber)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

getSalesInfoDashBoardByFiscalYear

InfoByMonthChartResult getSalesInfoDashBoardByFiscalYear()
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getInvoicesInfoByFiscalYear

InfoByMonthChartResult getInvoicesInfoByFiscalYear(java.lang.String fyNumber)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getInvoicesInfoByMonth

InfoByMonthChartResult getInvoicesInfoByMonth(int monthCount)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

getEngineeringInfoCenterResult

EngineeringInfoCenterResult getEngineeringInfoCenterResult()
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getQualityInfoCenterResult

QualityInfoCenterResult getQualityInfoCenterResult()
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getAccountInfoCenterResult

AccountInfoCenterResult getAccountInfoCenterResult()
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getAccountInfoDashBoardResult

AccountInfoCenterResult getAccountInfoDashBoardResult()
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getWareHousingInfoCenterResult

WareHousingInfoCenterResult getWareHousingInfoCenterResult()
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getPurchasingInfoCenterResult

PurchasingInfoCenterResult getPurchasingInfoCenterResult()
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseInfoByFiscalYear

InfoByMonthChartResult getPurchaseInfoByFiscalYear()
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseInfoByMonth

InfoByMonthChartResult getPurchaseInfoByMonth(int monthCount)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

getReceiversInfoByFiscalYear

InfoByMonthChartResult getReceiversInfoByFiscalYear()
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getReceiversInfoByMonth

InfoByMonthChartResult getReceiversInfoByMonth(int monthCount)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderInfoCenterResult

WorkOrderInfoCenterResult getWorkOrderInfoCenterResult()
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getWOInfoByMonth

InfoByMonthChartResult getWOInfoByMonth(int monthCount)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

getWOInfoByFiscalYear

InfoByMonthChartResult getWOInfoByFiscalYear()
                                             throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOrderOnTimeResult

SalesOrderOnTimeResult getSalesOrderOnTimeResult()
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOnTimeResult

SalesOnTimeResult getSalesOnTimeResult(OnTimeAgent agent)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderOnTimeResult

PurchaseOrderOnTimeResult getPurchaseOrderOnTimeResult()
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOnTimeResult

PurchaseOnTimeResult getPurchaseOnTimeResult(OnTimeAgent agent)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findSalesOrder12MonthMarginResults

java.util.Collection<SalesOrder12MonthMarginResult> findSalesOrder12MonthMarginResults(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOrder12MonthMarginResultsCount

int getSalesOrder12MonthMarginResultsCount()
                                           throws java.lang.Exception
Throws:
java.lang.Exception

getOverIssueItemByMonth

WOIssuedByMonthChartResult getOverIssueItemByMonth(int monthCount)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getFiscalYearOutputValue

OutputValueByMonthResult getFiscalYearOutputValue()
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getPOFiscalYearInfoCenter

InfoByFiscalChartResult getPOFiscalYearInfoCenter()
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getInventoryAmountByDate

InventoryAmountByMonth getInventoryAmountByDate(java.util.Date startDate,
                                                java.util.Date endDate)
                                                throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ManufacturerAddressInfoVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ManufacturerAddressInfoVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ManufacturerAddressInfoVO
All Implemented Interfaces:
java.io.Serializable
public class ManufacturerAddressInfoVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ADDRESS
static java.lang.String | ORDER_BY_CITY
static java.lang.String | ORDER_BY_COUNTRY
static java.lang.String | ORDER_BY_ID
static java.lang.String | ORDER_BY_NAME
static java.lang.String | ORDER_BY_STATE
static java.lang.String | ORDER_BY_ZIP
Constructor Summary
ManufacturerAddressInfoVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getADate()
java.lang.String | getAddressOne()
java.lang.String | getAddressTwo()
java.lang.String | getCity()
java.lang.String | getComments()
java.lang.String | getCountry()
java.lang.String | getCountryCode()
java.lang.String | getEmail()
java.lang.String | getFax()
java.lang.String | getId()
java.util.Date | getLastChangeDate()
int | getLastChangeTimes()
java.lang.String | getLastChangeUser()
java.lang.String | getName()
java.lang.String | getOrigin()
java.lang.String | getPhone()
java.lang.String | getPhone2()
java.lang.String | getState()
java.lang.String | getWebSite()
java.lang.String | getZip()
int | hashCode()
boolean | isDeleted()
void | setADate(java.util.Date aDate)
void | setAddressOne(java.lang.String addressOne)
void | setAddressTwo(java.lang.String addressTwo)
void | setCity(java.lang.String city)
void | setComments(java.lang.String comments)
void | setCountry(java.lang.String country)
void | setCountryCode(java.lang.String countryCode)
void | setDeleted(boolean deleted)
void | setEmail(java.lang.String email)
void | setFax(java.lang.String fax)
void | setId(java.lang.String id)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTimes(int lastChangeTimes)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setName(java.lang.String name)
void | setOrigin(java.lang.String origin)
void | setPhone(java.lang.String phone)
void | setPhone2(java.lang.String phone2)
void | setState(java.lang.String state)
void | setWebSite(java.lang.String webSite)
void | setZip(java.lang.String zip)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ID

public static final java.lang.String ORDER_BY_ID
See Also:
Constant Field Values

ORDER_BY_NAME

public static final java.lang.String ORDER_BY_NAME
See Also:
Constant Field Values

ORDER_BY_ADDRESS

public static final java.lang.String ORDER_BY_ADDRESS
See Also:
Constant Field Values

ORDER_BY_CITY

public static final java.lang.String ORDER_BY_CITY
See Also:
Constant Field Values

ORDER_BY_STATE

public static final java.lang.String ORDER_BY_STATE
See Also:
Constant Field Values

ORDER_BY_ZIP

public static final java.lang.String ORDER_BY_ZIP
See Also:
Constant Field Values

ORDER_BY_COUNTRY

public static final java.lang.String ORDER_BY_COUNTRY
See Also:
Constant Field Values
Constructor Detail

ManufacturerAddressInfoVO

public ManufacturerAddressInfoVO()
Method Detail

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeTimes

public int getLastChangeTimes()

setLastChangeTimes

public void setLastChangeTimes(int lastChangeTimes)

getADate

public java.util.Date getADate()

setADate

public void setADate(java.util.Date aDate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getAddressOne

public java.lang.String getAddressOne()

setAddressOne

public void setAddressOne(java.lang.String addressOne)

getAddressTwo

public java.lang.String getAddressTwo()

setAddressTwo

public void setAddressTwo(java.lang.String addressTwo)

getCity

public java.lang.String getCity()

setCity

public void setCity(java.lang.String city)

getState

public java.lang.String getState()

setState

public void setState(java.lang.String state)

getZip

public java.lang.String getZip()

setZip

public void setZip(java.lang.String zip)

getCountry

public java.lang.String getCountry()

setCountry

public void setCountry(java.lang.String country)

getCountryCode

public java.lang.String getCountryCode()

setCountryCode

public void setCountryCode(java.lang.String countryCode)

getPhone

public java.lang.String getPhone()

setPhone

public void setPhone(java.lang.String phone)

getFax

public java.lang.String getFax()

setFax

public void setFax(java.lang.String fax)

getPhone2

public java.lang.String getPhone2()

setPhone2

public void setPhone2(java.lang.String phone2)

getEmail

public java.lang.String getEmail()

setEmail

public void setEmail(java.lang.String email)

getWebSite

public java.lang.String getWebSite()

setWebSite

public void setWebSite(java.lang.String webSite)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

isDeleted

public boolean isDeleted()

setDeleted

public void setDeleted(boolean deleted)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ManufacturerAddressVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ManufacturerAddressVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ManufacturerAddressVO
All Implemented Interfaces:
java.io.Serializable
public class ManufacturerAddressVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ManufacturerAddressVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getADate()
java.lang.String | getAddressOne()
java.lang.String | getAddressTwo()
java.lang.String | getCity()
java.lang.String | getComments()
java.util.Set | getContacts()
java.lang.String | getCountry()
java.lang.String | getCountryCode()
java.lang.String | getEmail()
java.lang.String | getFax()
java.lang.String | getId()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.util.Set | getMultiDescription()
java.lang.String | getName()
java.lang.String | getOrigin()
java.lang.String | getPhone()
java.lang.String | getPhone2()
java.lang.String | getState()
java.lang.Integer | getVersion()
java.lang.String | getWebSite()
java.lang.String | getZip()
int | hashCode()
boolean | isDeleted()
void | setADate(java.util.Date aDate)
void | setAddressOne(java.lang.String addressOne)
void | setAddressTwo(java.lang.String addressTwo)
void | setCity(java.lang.String city)
void | setComments(java.lang.String comments)
void | setContacts(java.util.Set contacts)
void | setCountry(java.lang.String country)
void | setCountryCode(java.lang.String countryCode)
void | setDeleted(boolean deleted)
void | setEmail(java.lang.String email)
void | setFax(java.lang.String fax)
void | setId(java.lang.String id)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setMultiDescription(java.util.Set multiDescription)
void | setName(java.lang.String name)
void | setOrigin(java.lang.String origin)
void | setPhone(java.lang.String phone)
void | setPhone2(java.lang.String phone2)
void | setState(java.lang.String state)
void | setVersion(java.lang.Integer version)
void | setWebSite(java.lang.String webSite)
void | setZip(java.lang.String zip)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ManufacturerAddressVO

public ManufacturerAddressVO()
Method Detail

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getADate

public java.util.Date getADate()

setADate

public void setADate(java.util.Date aDate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getAddressOne

public java.lang.String getAddressOne()

setAddressOne

public void setAddressOne(java.lang.String addressOne)

getAddressTwo

public java.lang.String getAddressTwo()

setAddressTwo

public void setAddressTwo(java.lang.String addressTwo)

getCity

public java.lang.String getCity()

setCity

public void setCity(java.lang.String city)

getState

public java.lang.String getState()

setState

public void setState(java.lang.String state)

getZip

public java.lang.String getZip()

setZip

public void setZip(java.lang.String zip)

getCountry

public java.lang.String getCountry()

setCountry

public void setCountry(java.lang.String country)

getCountryCode

public java.lang.String getCountryCode()

setCountryCode

public void setCountryCode(java.lang.String countryCode)

getPhone

public java.lang.String getPhone()

setPhone

public void setPhone(java.lang.String phone)

getFax

public java.lang.String getFax()

setFax

public void setFax(java.lang.String fax)

getPhone2

public java.lang.String getPhone2()

setPhone2

public void setPhone2(java.lang.String phone2)

getEmail

public java.lang.String getEmail()

setEmail

public void setEmail(java.lang.String email)

getWebSite

public java.lang.String getWebSite()

setWebSite

public void setWebSite(java.lang.String webSite)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getContacts

public java.util.Set getContacts()

getVersion

public java.lang.Integer getVersion()

setContacts

public void setContacts(java.util.Set contacts)

setVersion

public void setVersion(java.lang.Integer version)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getMultiDescription

public java.util.Set getMultiDescription()

setMultiDescription

public void setMultiDescription(java.util.Set multiDescription)

isDeleted

public boolean isDeleted()

setDeleted

public void setDeleted(boolean deleted)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ManufacturerContactPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ManufacturerContactPK

java.lang.Object
    extended by  bb.common.ManufacturerContactPK
All Implemented Interfaces:
java.io.Serializable
public class ManufacturerContactPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ManufacturerContactPK()
ManufacturerContactPK(java.lang.String id, java.lang.Short item)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getId()
java.lang.Short | getItem()
int | hashCode()
void | setId(java.lang.String id)
void | setItem(java.lang.Short item)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ManufacturerContactPK

public ManufacturerContactPK()

ManufacturerContactPK

public ManufacturerContactPK(java.lang.String id,
                             java.lang.Short item)
Method Detail

setId

public void setId(java.lang.String id)

getId

public java.lang.String getId()

setItem

public void setItem(java.lang.Short item)

getItem

public java.lang.Short getItem()

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ManufacturerContactVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ManufacturerContactVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ManufacturerContactVO
All Implemented Interfaces:
java.io.Serializable
public class ManufacturerContactVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ManufacturerContactVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.lang.String | getEmail()
java.lang.String | getFax()
java.lang.String | getMobile()
java.lang.String | getName()
java.lang.String | getPhone()
ManufacturerContactPK | getPk()
java.lang.String | getTitle()
int | hashCode()
void | setComments(java.lang.String comments)
void | setEmail(java.lang.String email)
void | setFax(java.lang.String fax)
void | setMobile(java.lang.String mobile)
void | setName(java.lang.String name)
void | setPhone(java.lang.String phone)
void | setPk(ManufacturerContactPK pk)
void | setTitle(java.lang.String title)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ManufacturerContactVO

public ManufacturerContactVO()
Method Detail

getTitle

public java.lang.String getTitle()

setTitle

public void setTitle(java.lang.String title)

setPk

public void setPk(ManufacturerContactPK pk)

getPk

public ManufacturerContactPK getPk()

setName

public void setName(java.lang.String name)

getName

public java.lang.String getName()

setPhone

public void setPhone(java.lang.String phone)

getPhone

public java.lang.String getPhone()

setMobile

public void setMobile(java.lang.String mobile)

getMobile

public java.lang.String getMobile()

setFax

public void setFax(java.lang.String fax)

getFax

public java.lang.String getFax()

setEmail

public void setEmail(java.lang.String email)

getEmail

public java.lang.String getEmail()

setComments

public void setComments(java.lang.String comments)

getComments

public java.lang.String getComments()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ManufacturerDescriptionPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ManufacturerDescriptionPK

java.lang.Object
    extended by  bb.common.ManufacturerDescriptionPK
All Implemented Interfaces:
java.io.Serializable
public class ManufacturerDescriptionPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
ManufacturerDescriptionPK()
default constructor
ManufacturerDescriptionPK(java.lang.String id, java.lang.String language)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getId()
java.lang.String | getLanguage()
int | hashCode()
void | setId(java.lang.String id)
void | setLanguage(java.lang.String language)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ManufacturerDescriptionPK

public ManufacturerDescriptionPK(java.lang.String id,
                                 java.lang.String language)
full constructor

ManufacturerDescriptionPK

public ManufacturerDescriptionPK()
default constructor

Method Detail

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ManufacturerDescriptionVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ManufacturerDescriptionVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ManufacturerDescriptionVO
All Implemented Interfaces:
java.io.Serializable
public class ManufacturerDescriptionVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ManufacturerDescriptionVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAddressOne()
java.lang.String | getAddressTwo()
java.lang.String | getCity()
java.lang.String | getCountry()
java.lang.String | getName()
ManufacturerDescriptionPK | getPk()
java.lang.String | getState()
java.lang.String | getStatus()
java.lang.String | getZip()
int | hashCode()
void | setAddressOne(java.lang.String addressOne)
void | setAddressTwo(java.lang.String addressTwo)
void | setCity(java.lang.String city)
void | setCountry(java.lang.String country)
void | setName(java.lang.String name)
void | setPk(ManufacturerDescriptionPK pk)
void | setState(java.lang.String state)
void | setStatus(java.lang.String status)
void | setZip(java.lang.String zip)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ManufacturerDescriptionVO

public ManufacturerDescriptionVO()
Method Detail

getPk

public ManufacturerDescriptionPK getPk()

setPk

public void setPk(ManufacturerDescriptionPK pk)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getAddressOne

public java.lang.String getAddressOne()

setAddressOne

public void setAddressOne(java.lang.String addressOne)

getAddressTwo

public java.lang.String getAddressTwo()

setAddressTwo

public void setAddressTwo(java.lang.String addressTwo)

getCity

public java.lang.String getCity()

setCity

public void setCity(java.lang.String city)

getState

public java.lang.String getState()

setState

public void setState(java.lang.String state)

getZip

public java.lang.String getZip()

setZip

public void setZip(java.lang.String zip)

getCountry

public java.lang.String getCountry()

setCountry

public void setCountry(java.lang.String country)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ManufacturingBox

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common.box
Interface ManufacturingBox

public interface ManufacturingBox

Method Summary
EquipmentVO | addEquipment(EquipmentVO vo)
InspectionItemVO | addInspectionItem(InspectionItemVO vo)
InspectionReportVO | addInspectionReport(InspectionReportVO vo)
InspectionReportInspectMethodVO | addInspectionReportInspectMethod(InspectionReportInspectMethodVO vo)
MaintenanceItemVO | addMaintenanceItem(MaintenanceItemVO vo)
EngineeringChangeVO | addManufacturerEngineeringChange(EngineeringChangeVO engChangeVO)
EngineeringChangeRequestVO | addMECRequest(EngineeringChangeRequestVO ecRequestVO)
EngineeringChangeRequestVO | addMECRequest(PartPK pk)
OIPrincipalVO | addOIPrincipal(OIPrincipalVO vo)
OperatingInstructionsVO | addOperatingInstructions(OperatingInstructionsVO vo)
OperatingInstructionsInspectStandardVO | addOperatingInstructionsInspectStandard(OperatingInstructionsInspectStandardVO vo)
OperatingInstructionsManualVO | addOperatingInstructionsManual(OperatingInstructionsManualVO vo)
OperatingInstructionsTypeVO | addOperatingInstructionsType(OperatingInstructionsTypeVO vo)
OperatingOutputFileTypeVO | addOperatingOutputFileType(OperatingOutputFileTypeVO vo)
PurchaseOrderVO | addPurchaseOrder(java.lang.String vendorId)
PurchaseOrderApprovalVO | addPurchaseOrderApproval(java.lang.String approvalUserName)
PurchaseOrderVO | addPurchaseOrderFromRequestForQuote(java.lang.String rfqNumber)
java.util.Collection<java.lang.String> | addPurchaseOrderFromWISeq(POForWISeqAgent agent)
PurchaseOrderItemVO | addPurchaseOrderItem(PurchaseOrderItemVO purItemVO)
PurchaseWorkSheetVO | addPurchaseWorkSheet()
PurchaseWorkSheetVO | addPurchaseWorkSheet(PurchaseWorkSheetVO pwsVO)
RequestForQuoteVO | addRequestForQuote(java.lang.String vendorId)
ReturnToVendorVO | addReturnToVendor(java.lang.String vendorID)
WorkInstructionRequestForChangeVO | addRFC(WorkInstructionRequestForChangeVO vo)
WorkOrderTimeCardVO | addTimeCard(WorkOrderTimeCardVO vo)
WorkOrderTimeCardVO | addTimeCard(WorkOrderTimeCardVO vo, boolean unFinished)
ToolVO | addTool(ToolVO vo)
ToolCalibrationVO | addToolCalibration(PartPK partPk, java.lang.String serialNumber)
ToolListVO | addToolList(ToolListVO billVO)
void | addToolListItem(ToolListItemVO itemVO)
WorkCalendarVO | addWorkCalendar(WorkCalendarVO vo)
WorkCenterVO | addWorkCenter(WorkCenterVO vo)
WorkInstructionVO | addWorkInstruction(WorkInstructionPK pk)
WorkInstructionApprovalVO | addWorkInstructionApproval(java.lang.String employeeId)
WorkInstructionPictureVO | addWorkInstructionPicture(WorkInstructionPictureVO vo)
void | approveOperatingInstructions(OperatingInstructionsVO vo)
PurchaseOrderVO | approvePurchaseOrder(PurchaseOrderVO purVO)
PurchaseOrderVO | approvePurchaseOrder(java.lang.String purchaseOrderNumber)
RequestForQuoteVO | approveRequestForQuote(RequestForQuoteVO rfqVo)
RequestForQuoteVO | approveRequestForQuote(java.lang.String rfqNumber)
ReturnToVendorVO | approveReturnToVendor(ReturnToVendorVO rtvVO)
ReturnToVendorVO | approveReturnToVendor(java.lang.String rtvNumber)
WorkInstructionVO | approveWorkInstruction(WorkInstructionVO vo)
void | auditingWorkInstructionAvgHrs(java.util.HashMap maps)
void | cancelFinishOperatingInstructions(OperatingInstructionsVO vo)
void | changeOperatingInstructionsStatusToCancel(OperatingInstructionsVO vo)
void | clearAllReferenceDocOnesToPurchaseOrderItem(PurchaseOrderItemPK pk)
void | clearAllReferenceDocTwoesToPurchaseOrderItem(PurchaseOrderItemPK pk)
void | clearPurchaseOrderItemReferenceDocOne(java.lang.String referenceDoc)
void | clearPurchaseOrderItemReferenceDocTwo(java.lang.String referenceDoc)
void | closeOperatingInstructions(OperatingInstructionsVO vo)
void | continueOperatingInstructions(OperatingInstructionsVO vo)
WorkInstructionVO | copyToAddWorkInstruction(WorkInstructionVO vo)
WorkCenterVO | copyWorkCenterFromWorkCenter(WC2WCAgent agent)
WorkInstructionVO | copyWorkInstruction(WorkInstructionPK oldPk, WorkInstructionPK newPk)
void | deleteCalibration(ToolCalibrationVO vo)
void | deleteCertainWorkCalendar(java.util.Set<java.lang.Long> set)
void | deleteEquipmentById(java.lang.String id)
void | deleteInspectionItem(InspectionItemPK pk)
void | deleteInspectionReportInspectMethod(int ii)
void | deleteMaintenanceItem(MaintenanceItemPK pk)
void | deleteManufacturerECRequest(EngineeringChangeRequestVO ecRequestVO)
void | deleteManufacturerEngineeringChange(EngineeringChangeVO engChange)
java.util.Collection<OnloanDocumentVO> | deleteOnloanDoc(MiscDocAgent agent)
void | deleteOperatingInstructions(java.lang.String operatingInstructionsNumber)
void | deleteOperatingInstructionsInspectStandard(int ii)
void | deleteOperatingInstructionsManual(int ii)
void | deleteOperatingInstructionsType(int ii)
void | deleteOperatingOutputFileType(int ii)
void | deletePurchaseOrder(PurchaseOrderVO purVO)
void | deletePurchaseOrderApproval(java.lang.String employeeId)
void | deletePurchaseOrderItem(PurchaseOrderItemVO purItemVO)
void | deletePurchaseOrderItems(java.lang.String purchaseNumber)
void | deletePurchaseWorkSheet(PurchaseWorkSheetVO pwsVO)
void | deleteRequestForQuote(RequestForQuoteVO rfqVO)
void | deleteReturnToVendor(ReturnToVendorVO rtvVO)
void | deleteRFC(WorkInstructionRequestForChangeVO vo)
void | deleteTimeCard(WorkOrderTimeCardVO vo)
void | deleteToolList(ToolListVO billVO)
void | deleteToolListItem(ToolListItemVO billItemVO)
void | deleteWorkCalendar(WorkCalendarVO vo)
void | deleteWorkCenter(WorkCenterVO vo)
void | deleteWorkInstruction(WorkInstructionPK pk)
void | deleteWorkInstructionApproval(java.lang.String employeeId)
void | deleteWorkInstructionDocument(MiscDocAgent agent)
void | deleteWorkInstructionPicture(java.lang.Long ii)
void | deleteWorkInstructionPicture(MiscDocAgent agent)
BB2File | downloadOnloanDoc(MiscDocAgent agent)
BB2Picture | downloadWorkInstructionPicture(MiscDocAgent agent)
byte[] | downWorkInstructionDocument(MiscDocAgent agent)
java.util.Collection<ToolCalibrateListResult> | findAllCalibrations(int firstIndex, int maxLength)
java.util.Collection<EquipmentListResult> | findAllEquipments(int firstIndex, int maxLength)
java.util.Collection<InspectionItemVO> | findAllInspectionItem(int operatingInstructionsTypeId, int firstIndex, int maxLength)
java.util.Collection<InspectionReportInspectMethodVO> | findAllInspectionReportInspectMethod(int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeRequestListResult> | findAllManufacturerECRequests(java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | findAllManufacturerEngineeringChanges(java.lang.String languageFlag, int firstIndex, int maxLength)
java.util.Collection<OperatingInstructionsInspectStandardVO> | findAllOperatingInstructionsInspectStandard(int firstIndex, int maxLength)
java.util.Collection<OperatingInstructionsManualVO> | findAllOperatingInstructionsManual(int firstIndex, int maxLength)
java.util.Collection<OperatingInstructionsTypeVO> | findAllOperatingInstructionsType(int firstIndex, int maxLength)
java.util.Collection<OperatingOutputFileTypeVO> | findAllOperatingOutputFileType(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderApprovalVO> | findAllPurchaseOrderApprovals(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderBoilerplateVO> | findAllPurchaseOrderBP(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | findAllPurchaseOrderByAddressId(java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderCheckListResult> | findAllPurchaseOrderCheckListResults(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | findAllPurchaseOrderItems(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | findAllPurchaseOrders(int firstIndex, int maxLength)
java.util.Collection<PurchaseWorkSheetVO> | findAllPurchaseWorkSheet(int firstIndex, int maxLength)
java.util.Collection<WorkInstructionRequestForChangeVO> | findAllRfcs(int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteCheckListResult> | findAllRfqCheckListResults(int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorCheckListResult> | findAllRtvCheckListResults(int firstIndex, int maxLength)
java.util.Collection<WorkOrderTimeCardVO> | findAllTimeCards(int firstIndex, int maxLength)
java.util.Collection<ToolListWithToolInfoResult> | findAllToolListsWithToolInfo(java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<ToolBasicInfo> | findAllTools(int firstIndex, int maxLength)
java.util.Collection<WorkCalendarVO> | findAllWorkCalendar(java.util.Date dateFrom, java.util.Date dateTo, int work, int firstIndex, int maxLength)
java.util.Collection<WorkInstructionListResult> | findAllWorkInstructions(int firstIndex, int maxLength)
java.util.Collection<ToolCalibrationVO> | findCalibrationByPart(java.lang.String pnLike, java.lang.String partType)
java.util.Collection<ToolCalibrateListResult> | findCalibrationsByAssignedTo(java.lang.String assignedTo, int firstIndex, int maxLength)
java.util.Collection<ToolCalibrateListResult> | findCalibrationsByDate(java.util.Date fromDate, java.util.Date toDate, boolean isLast, PartPK partPk, java.lang.String assign, int firstIndex, int maxLength)
java.util.Collection<ToolCalibrateListResult> | findCalibrationsByInspectedBy(java.lang.String inspectedBy, int firstIndex, int maxLength)
java.util.Collection<ToolCalibrateListResult> | findCalibrationsByLocation(java.lang.String location, int firstIndex, int maxLength)
java.util.Collection<ToolCalibrateListResult> | findCalibrationsByNextInspectionInDays(int day, int firstIndex, int maxLength)
java.util.Collection<ToolCalibrateListResult> | findCalibrationsDue(int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemTimeDetailVO> | findCloseTimeCards(java.lang.String employeeId, java.lang.String wo, java.lang.String itemNumberNumber, java.util.Date fromDate, java.util.Date toDate, java.lang.String department, java.lang.String workCenter, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeRequestListResult> | findDueManufacturerECRequest(java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | findDueManufacturerEngineerningChange(java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteItemListResult> | findDueRequestForQuoteItemListResults(int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorItemListResult> | findDueReturnToVendorItemListResults(int firstIndex, int maxLength)
java.util.Collection<EquipmentListResult> | findEquipmentByWorkCenterId(java.lang.String workCenterId, int firstIndex, int maxLength)
java.util.Collection<EquipmentListResult> | findEquipmentsByEquipmentId(java.lang.String equipmentId, java.lang.String type, java.lang.String workCenterId, java.lang.String maintenanceBy, int firstIndex, int maxLength)
java.util.Collection<EquipmentListResult> | findEquipmentsByHours(int hours, int firstIndex, int maxLength)
java.util.Collection<ToolBasicInfo> | findInactiveTool(java.lang.String toolNumber, int firstIndex, int maxLength)
java.util.Collection<InspectionReportInfoVO> | findInspectionReport(java.lang.String irNumber, java.lang.String oiNumber, int firstIndex, int maxLength)
java.util.Collection<JobProcessSheetListResult> | findJobProcessSheetListResults(java.lang.String woNumberLike, int firstIndex, int maxLength)
java.util.Collection<JobProcessSheetListResult> | findJobProcessSheetListResultsByLookup(java.lang.String woNumber, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeRequestListResult> | findManufacturerECRequestByEcrNumberLike(java.lang.String ecrNumberLike, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeRequestListResult> | findManufacturerECRequestByPartLike(java.lang.String pnRegex, java.lang.String partType, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | findManufacturerEngineeringChangeByEcnNumberLike(java.lang.String ecRegex, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | findManufacturerEngineeringChangeByPart(PartPK partPk, java.lang.String languageFlag, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | findManufacturerEngineeringChangeByPartLike(java.lang.String pnRegex, java.lang.String partType, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | findManufacturerEngineeringChangeByPartPk(PartPK partPk, java.lang.String languageFlag, int firstIndex, int maxLength)
java.util.Collection<PurchaseWorkSheetVO> | findMyPurchaseWorkSheet(int firstIndex, int maxLength)
java.util.Collection<OperatingInstructionsVO> | findNotApprovedOperatingInstructions(int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeRequestListResult> | findOpenManufacturerECRequest(java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | findOpenManufacturerEngineeringChange(java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<OperatingInstructionsVO> | findOpenOperatingInstructions(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | findOpenPurchaseOrderByAddressId(java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderOpenDueListResult> | findOpenPurchaseOrderItems(int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteItemListResult> | findOpenRequestForQuoteItemListResults(int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorItemListResult> | findOpenReturnToVendorItemListResults(int firstIndex, int maxLength)
java.util.Collection<WorkInstructionRequestForChangeVO> | findOpenRFCs(int firstIndex, int maxLength)
java.util.Collection<WorkOrderTimeCardVO> | findOpenTimeCardsByEmployeeLike(java.lang.String employeeId, int firstIndex, int maxLength)
EmployeeTimeCardResult | findOpenTimeCardsById(java.lang.String employeeId)
java.util.Collection<WorkInstructionVO> | findOpenWorkInstructions(int firstIndex, int maxLength)
java.util.Collection<OperatingInstructionsVO> | findOperatingInstructions(java.lang.String oiNumber, java.lang.String woAndItemNumber, java.lang.String type, java.lang.String responsibility, java.lang.String project, java.lang.String serial, java.lang.String staff, java.lang.String status, java.lang.String irNumber, int firstIndex, int maxLength)
java.util.Collection<OperatingInstructionsVO> | findOperatingInstructionsCanClose(int firstIndex, int maxLength)
java.util.Collection<OperatingInstructionsVO> | findOperatingInstructionsUserStatistical(java.lang.String userName, java.lang.String type, java.lang.String responsibility, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderOpenDueListResult> | findPastDuePurchaseOrderItems(int firstIndex, int maxLength)
java.util.Collection<WorkInstructionRequestForChangeVO> | findPastDueRFCs(int firstIndex, int maxLength)
java.util.Collection<OperatingInstructionsVO> | findPausedOperatingInstructions(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | findPurchaseOrderByPoNumber(java.lang.String poNumber, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderCheckListResult> | findPurchaseOrderCheckListResults(java.lang.String startWith, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | findPurchaseOrderItemByDate(java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String status, java.lang.String partNumberLike, java.lang.String partType, java.lang.String shipto, java.lang.String vendorId, java.lang.String project, java.lang.String requester, java.lang.String buyer, java.lang.String currency, java.lang.String relatedDoc, java.lang.String accountNumber, java.lang.String companyUnitId, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | findPurchaseOrderItemsByPartNumberLike(java.lang.String partNumberReg, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | findPurchaseOrderItemsByPartPk(PartPK pk, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemVO> | findPurchaseOrderItemsByPoNumber(java.lang.String poNumber)
java.util.Collection<PurchaseWorkSheetVO> | findPurchaseWorkSheetByEmployeeEmailLike(java.lang.String employeeEmailLike, int firstIndex, int maxLength)
java.util.Collection<PurchaseWorkSheetVO> | findPurchaseWorkSheetByEmployeeId(java.lang.String employeeId, boolean isMfrPurchaseWorkSheet, int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteItemListResult> | findRequestForQuoteItemListResults(java.lang.String partNumberLike, java.lang.String partType, java.lang.String status, boolean isDue, int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteItemListResult> | findRequestForQuoteItemListResults(java.lang.String partNumberLike, java.lang.String partType, java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteItemListResult> | findRequestForQuoteItemListResultsByPartNumberLike(java.lang.String partNumberLike, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteListResult> | findRequestForQuoteListResults(java.lang.String rfqNumber, java.lang.String status, java.lang.String vendId, int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteListResult> | findRequestForQuoteListResultsByRfqNumber(java.lang.String rfqNumber, int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteListResult> | findRequestForQuoteListResultsByVendorId(java.lang.String vendorId, int firstIndex, int maxLength)
java.util.Collection<OperatingInstructionsVO> | findRequestInspectionOperatingInstructions(int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorItemListResult> | findReturnToVendorItemListResults(java.lang.String partNumberLike, java.lang.String partType, java.lang.String status, boolean isDue, int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorItemListResult> | findReturnToVendorItemListResults(java.lang.String partNumberLike, java.lang.String partType, java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorItemListResult> | findReturnToVendorItemListResultsByPartNumberLike(java.lang.String partNumberLike, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorListResult> | findReturnToVendorListResults(java.lang.String rtvNumber, java.lang.String status, java.lang.String vendId, int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorListResult> | findReturnToVendorListResultsByRtvNumber(java.lang.String rtvNumber, int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorListResult> | findReturnToVendorListResultsByVendorId(java.lang.String vendorId, int firstIndex, int maxLength)
WorkInstructionRequestForChangeVO | findRFCByPk(java.lang.String pk)
java.util.Collection<WorkInstructionRequestForChangeVO> | findRFCsByRFC(java.lang.String rfc, int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteCheckListResult> | findRfqCheckListResults(java.lang.String startWith, int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorCheckListResult> | findRtvCheckListResults(java.lang.String startWith, int firstIndex, int maxLength)
WorkOrderTimeCardVO | findTimeCardByPk(java.lang.Long pk)
java.util.Collection<WorkOrderTimeCardVO> | findTimeCardsByVendorId(java.lang.String vendorId, int firstIndex, int maxLength)
java.util.Collection<WorkOrderTimeCardVO> | findTimeCardsByWO(java.lang.String workOrder, int firstIndex, int maxLength)
java.util.Collection<ToolCalibrateListResult> | findToolCalibrationsByPart(PartPK partPk, int firstIndex, int maxLength)
java.util.Collection<ToolListItemWithToolInfoResult> | findToolListItemWithToolInfoByBillPk(BillPK billPk, java.lang.String languageCode)
java.util.Collection<ToolListItemWithToolInfoResult> | findToolListItemWithToolInfoByBillPk(BillPK billPk, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<ToolListWithToolInfoResult> | findToolListswithToolInfoByBillNumberLike(java.lang.String bnRegex, java.lang.String billType, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<ToolManufacturerVO> | findToolManufacturersByPartPk(PartPK partPk)
java.util.Collection<ToolBasicInfo> | findToolsByDescriptionInside(java.lang.String edRegex, int firstIndex, int maxLength)
java.util.Collection<ToolBasicInfo> | findToolsByDescriptionStart(java.lang.String edRegex, int firstIndex, int maxLength)
java.util.Collection<ToolWithManufacturerInfoResult> | findToolsByManufacturerId(java.lang.String mfgIdRegex, int firstIndex, int maxLength)
java.util.Collection<ToolWithManufacturerInfoResult> | findToolsByManufacturerPn(java.lang.String mpnRegex, int firstIndex, int maxLength)
java.util.Collection<ToolBasicInfo> | findToolsByToolLike(java.lang.String partNum, java.lang.String toolDes, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<ToolBasicInfo> | findToolsOnHold(int firstIndex, int maxLength)
java.util.Collection<ToolBasicInfo> | findToolsWithDrawing(int firstIndex, int maxLength)
java.util.Collection<ToolBasicInfo> | findToolsWithToolList(int firstIndex, int maxLength)
java.util.Collection<ToolBasicInfo> | findToolsWithWI(int firstIndex, int maxLength)
java.util.Collection<ToolVendorVO> | findToolVendorsByPartPk(PartPK partPk)
ToolWhereUsedResult | findToolWhereIsUsed(PartPK pk)
java.util.Collection<WoItemWorkInstructionListResult> | findWoItemWorkInstructionListResults(java.util.Date from, java.util.Date to, int firstIndex, int maxLength)
java.util.Collection<WoItemWorkInstructionListResult> | findWoItemWorkInstructionListResults(java.lang.String woNumberLike, int firstIndex, int maxLength)
java.util.Collection<WorkCenterVO> | findWorkCenterByWcNumber(java.lang.String wcNumber, int firstIndex, int maxLength)
java.util.List | findWorkCenterByWcNumber(java.lang.String wcNumber, java.lang.String description, java.lang.String workCenterSearchType, int firstIndex, int maxLength)
java.util.Collection<WorkCenterLoadListResult> | findWorkCenterLoadResults(WorkCenterLoadAgent agent, int firstIndex, int maxLength)
java.util.Collection<WorkCenterRunTimeListResult> | findWorkCenterRunTimeListResults(WorkCenterRunTimeAgent agent, int firstIndex, int maxLength)
java.util.Collection<WorkInstructionApprovalVO> | findWorkInstructionApprovalByEmployeeID(java.lang.String employeeId, int firstIndex, int maxLength)
java.util.Collection<WorkInstructionListResult> | findWorkInstructionByAuthor(java.lang.String author, int firstIndex, int maxLength)
java.util.Collection<WorkInstructionListResult> | findWorkInstructionByStatus(java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<WorkInstructionDocumentVO> | findWorkInstructionDocInfo(WorkInstructionPK pk)
java.util.Collection<WorkInstructionListResult> | findWorkInstructionsByPartLike(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String setID, java.lang.String status, boolean revMismatched, int firstIndex, int maxLength)
java.util.Collection<WorkInstructionListResult> | findWorkInstructionsByPartLike(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String setID, java.lang.String status, boolean revMismatched, int firstIndex, int maxLength, boolean isLike)
java.util.Collection<WorkInstructionSeqAuditListResult> | findWorkInstructionSeqAuditListResults(int firstIndex, int maxLength)
java.util.Collection<WorkInstructionSeqAuditListResult> | findWorkInstructionSeqAuditListResults(java.lang.String pnLike, java.lang.String partType, java.lang.String setId, java.lang.String seqNum, java.lang.String wcLike, int firstIndex, int maxLength)
java.util.Collection<WorkInstructionSequenceListResult> | findWorkInstructionSeqByAuthor(java.lang.String author, int firstIndex, int maxLength)
java.util.Collection<WorkInstructionSequenceListResult> | findWorkInstructionSeqByWorkCenter(java.lang.String workCenter, int firstIndex, int maxLength)
java.util.Collection<WorkInstructionSequenceListResult> | findWorkInstructionSeqOnHold(int firstIndex, int maxLength)
java.util.Collection<WorkInstructionSequenceListResult> | findWorkInstructionSeqWithZeroEstHours(int firstIndex, int maxLength)
void | finishOperatingInstructions(OperatingInstructionsVO vo)
int | getAllCalibrationsCount()
int | getAllEquipmentsCount()
int | getAllInspectionItemCount(int operatingInstructionsTypeId)
int | getAllInspectionReportInspectMethodCount()
int | getAllManufacturerECRequestsCount()
int | getAllManufacturerEngineeringChangesCount()
int | getAllOperatingInstructionsInspectStandardCount()
int | getAllOperatingInstructionsManualCount()
int | getAllOperatingInstructionsTypeCount()
int | getAllOperatingOutputFileTypeCount()
int | getAllPurchaseOrderApprovalsCount()
int | getAllPurchaseOrderCheckListResultsCount()
int | getAllPurchaseOrderCountByAddressId(java.lang.String addressId)
int | getAllPurchaseOrderItemsCount()
int | getAllPurchaseOrdersCount()
int | getAllPurchaseWorkSheetCount()
int | getAllRFCsCount()
int | getAllRfqCheckListResultsCount()
int | getAllRtvCheckListResultsCount()
int | getAllTimeCardsCount()
int | getAllToolListsWithToolInfoCount()
int | getAllToolsCount()
int | getAllWorkCalendar(java.util.Date dateFrom, java.util.Date dateTo, int work)
int | getAllWorkInstructionsCount()
int | getCalibrationsByAssignedToCount(java.lang.String assignedTo)
int | getCalibrationsByNextInspectionInDaysCount(int day)
int | getCalibrationsCountByDate(java.util.Date fromDate, java.util.Date toDate, boolean isLast, PartPK partPk, java.lang.String assign)
int | getCalibrationsCountByInspectedBy(java.lang.String inspectedBy)
int | getCalibrationsCountByLocation(java.lang.String location)
int | getCalibrationsDueCount()
int | getCloseTimeCardsCount(java.lang.String employeeId, java.lang.String workOrder, java.lang.String itemNumberNumber, java.util.Date fromDate, java.util.Date toDate, java.lang.String department, java.lang.String workCenter)
java.lang.String | getDefaultWISetId(BB2Part part)
WorkInstructionVO | getDefaultWorkInstructionByPartPk(BB2Part part)
int | getDueManufacturerECRequestsCount()
int | getDueManufacturerEngineeringChangesCount()
int | getDueRequestForQuoteItemListResultsCount()
int | getDueReturnToVendorItemListResultsCount()
int | getEquipmentByEquipmentIdCount(java.lang.String equipmentId, java.lang.String type, java.lang.String workCenterId, java.lang.String maintenanceBy)
int | getEquipmentByHours(int hours)
EquipmentVO | getEquipmentById(java.lang.String id)
int | getEquipmentByWorkCenterIdCount(java.lang.String workCenterId)
int | getFindInactiveToolCount(java.lang.String toolNumber)
InspectionItemVO | getInspectionItem(InspectionItemPK pk)
InspectionReportVO | getInspectionReport(java.lang.String inspectionReportNumber)
int | getInspectionReportCount(java.lang.String irNumber, java.lang.String oiNumber)
InspectionReportInspectMethodVO | getInspectionReportInspectMethod(int ii)
int | getJobProcessSheetListResultsCount(java.lang.String woNumberLike)
int | getJobProcessSheetListResultsCountByLookup(java.lang.String woNumber)
JobProcessSheetResult | getJobProcessSheetResult(PartPK partPk, boolean isTool, java.lang.String setId)
int | getManufacturerECRequestCountByEcrNumberLike(java.lang.String ecrNumberLike)
int | getManufacturerECRequestsCountByPartLike(java.lang.String pnRegex, java.lang.String partType)
EngineeringChangeVO | getManufacturerEngineeringChangeById(java.lang.String ec)
int | getManufacturerEngineeringChangesCountByMecnNumberLike(java.lang.String ecRegex)
int | getManufacturerEngineeringChangesCountByPart(PartPK partPk)
int | getManufacturerEngineeringChangesCountByPartLike(java.lang.String pnRegex, java.lang.String partType)
int | getManufacturerEngineeringChangesCountByPartPk(PartPK partPk)
EngineeringChangeRequestVO | getMECRequest(java.lang.String mecrNumber)
BB2PartMrpResult | getMrpResult(BB2Part part)
int | getMyPurchaseWorkSheetByCount()
int | getNotApprovedOperatingInstructionsCount()
OIPrincipalVO | getOIPrincipal()
OnloanDocumentVO | getOnloanDocumentByID(java.lang.Long controlNumber)
int | getOpenManufacturerECRequestsCount()
int | getOpenManufacturerEngineeringChangesCount()
int | getOpenOperatingInstructionsCount()
int | getOpenPurchaseOrderCountByAddressId(java.lang.String addressId)
int | getOpenPurchaseOrderItemCount()
int | getOpenRequestForQuoteItemListResultsCount()
int | getOpenReturnToVendorItemListResultsCount()
int | getOpenRFCCount()
int | getOpenTimeCardsCountByEmployeeLike(java.lang.String employeeId)
int | getOpenTimeCardsCountById(java.lang.String employeeId)
int | getOpenWorkInstructionsCount()
OperatingInstructionsVO | getOperatingInstructions(java.lang.String operatingInstructionsNumber)
int | getOperatingInstructionsCanCloseCount()
int | getOperatingInstructionsCount(java.lang.String oiNumber, java.lang.String woAndItemNumber, java.lang.String type, java.lang.String responsibility, java.lang.String project, java.lang.String serial, java.lang.String staff, java.lang.String status, java.lang.String irNumber)
OperatingInstructionsInspectStandardVO | getOperatingInstructionsInspectStandard(int ii)
OperatingInstructionsManualVO | getOperatingInstructionsManual(int ii)
OperatingInstructionsTypeVO | getOperatingInstructionsType(int ii)
int | getOperatingInstructionsUserStatisticalCount(java.lang.String userName, java.lang.String type, java.lang.String responsibility)
OperatingOutputFileTypeVO | getOperatingOutputFileType(int ii)
ToolListVO | getParentToolList(ToolListItemVO billItemVO)
int | getPastDuePurchaseOrderItemCount()
int | getPastDueRFCCount()
int | getPausedOperatingInstructionsCount()
java.lang.String | getPoMessageStatus(java.lang.String poNumber)
PurchaseOrderApprovalVO | getPurchaseOrderApprovalByEmployeeId(java.lang.String employeeId)
PurchaseOrderApprovalVO | getPurchaseOrderApprovalByUserNumber(java.lang.String userName)
PurchaseOrderVO | getPurchaseOrderByPoNumber(java.lang.String poNumber)
int | getPurchaseOrderCheckListResultsCount(java.lang.String startWith)
int | getPurchaseOrderCountByPoNumber(java.lang.String poNumber)
int | getPurchaseOrderItemCountByDate(java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String status, java.lang.String partNumberLike, java.lang.String partType, java.lang.String shipto, java.lang.String vendorId, java.lang.String project, java.lang.String requester, java.lang.String buyer, java.lang.String currency, java.lang.String relatedDoc, java.lang.String accountNumber, java.lang.String companyUnitId)
int | getPurchaseOrderItemCountByPartNumberLike(java.lang.String partNumberReg, java.lang.String partType)
int | getPurchaseOrderItemCountByPartPk(PartPK pk)
int | getPurchaseOrderItemCountByPoNumber(java.lang.String poNumber)
java.lang.String | getPurchaseOrderStatus(java.lang.String poNumber)
PurchaseOrderVO | getPurchaseOrderWithOrderApplyByID(java.lang.Long ID)
int | getPurchaseWorkSheetByCountByEmployeeId(java.lang.String employeeId)
PurchaseWorkSheetVO | getPurchaseWorkSheetByPk(PurchaseWorkSheetPK pk)
int | getPurchaseWorkSheetCountByEmployeeEmailLike(java.lang.String employeeEmailLike)
RequestForQuoteVO | getRequestForQuoteByRfqNumber(java.lang.String rfqNumber)
int | getRequestForQuoteItemListResultsCount(java.lang.String partNumberLike, java.lang.String partType, java.lang.String status)
int | getRequestForQuoteItemListResultsCount(java.lang.String partNumberLike, java.lang.String partType, java.lang.String status, boolean isDue)
int | getRequestForQuoteItemListResultsCountByPartNumberLike(java.lang.String partNumberLike, java.lang.String partType)
int | getRequestForQuoteListResultsCount(java.lang.String rfqNumber, java.lang.String status, java.lang.String vendId)
int | getRequestForQuoteListResultsCountByRfqNumber(java.lang.String rfqNumber)
int | getRequestForQuoteListResultsCountByVendorId(java.lang.String vendorId)
java.lang.String | getRequestForQuoteStatus(java.lang.String requestForQuoteNumber)
int | getRequestInspectionOperatingInstructionsCount()
ReturnToVendorVO | getReturnToVendorByRtvNumber(java.lang.String rtvNumber)
int | getReturnToVendorItemListResultsCount(java.lang.String partNumberLike, java.lang.String partType, java.lang.String status)
int | getReturnToVendorItemListResultsCount(java.lang.String partNumberLike, java.lang.String partType, java.lang.String status, boolean isDue)
int | getReturnToVendorItemListResultsCountByPartNumberLike(java.lang.String partNumberLike, java.lang.String partType)
int | getReturnToVendorListResultsCount(java.lang.String rtvNumber, java.lang.String status, java.lang.String vendId)
int | getReturnToVendorListResultsCountByRtvNumber(java.lang.String rtvNumber)
int | getReturnToVendorListResultsCountByVendorId(java.lang.String vendorId)
java.lang.String | getReturnToVendorStatus(java.lang.String returnToVendorNumber)
int | getRFCCountByRFC(java.lang.String rfc)
int | getRfqCheckListResultsCount(java.lang.String startWith)
int | getRtvCheckListResultsCount(java.lang.String startWith)
java.util.Collection<RtvShipperItemListResult> | getRtvShipperByPoNumber(java.lang.String poNumber)
int | getTimeCardsByVendorId(java.lang.String vendorId)
int | getTimeCardsCountByWO(java.lang.String workOrderNumber)
ToolBasicInfo | getToolBasicInfo(PartPK pk)
ToolBasicInfo | getToolBasicInfo(PartPK pk, java.lang.String languageCode)
ToolVO | getToolByPk(PartPK pk)
int | getToolCalibrationsByPartCount(PartPK partPk)
ToolInventoryVO | getToolInventoryByPk(PartPK partPk)
ToolListVO | getToolList(BillPK billPk)
ToolListDetailCostResult | getToolListDetailCostResult(BillPK billPk, java.lang.String languageCode)
int | getToolListItemCount(BillPK billPk)
ToolListItemVO | getToolListItems(BillItemPK itemPk)
ToolListItemWithToolInfoResult | getToolListItemWithToolInfoByBillItemPk(BillItemPK billItemPk, java.lang.String languageCode)
int | getToolListsCountByBillNumberLike(java.lang.String bnRegex, java.lang.String billType)
ToolListWithToolInfoResult | getToolListWithToolInfoByBillPk(BillPK billPk, java.lang.String languageCode)
ToolWithOnhandsVO | getToolOnhands(PartPK pk)
int | getToolsCountByDescriptionInside(java.lang.String descriptionRegex)
int | getToolsCountByDescriptionStart(java.lang.String descriptionRegex)
int | getToolsCountByManufacturerId(java.lang.String IdRegex)
int | getToolsCountByManufacturerPn(java.lang.String mpnRegex)
int | getToolsCountByOnHold()
int | getToolsCountByToolLike(java.lang.String partNum, java.lang.String partDescription, java.lang.String partType)
int | getToolsWithDrawingCount()
int | getToolsWithToolListCount()
int | getToolsWithWICount()
java.util.Collection<WCLoadDetailResult> | getWCLoadDetailResults(java.lang.String wcID)
java.util.Collection<WCLoadDetailResult> | getWCLoadDetailResults(WCLoadAgent agnet)
java.util.Collection<WCLoadDetailResult> | getWCLoadDetailResultsforWOItem(WorkOrderItemPK pk)
java.util.Collection<WorkCenterAgent> | getWCLoadIDs(java.lang.String wcLike, java.lang.String departLike)
WCLoadOnDateResult | getWCLoadOnDate(WorkCenterOnDateAgent agent)
int | getWoItemWorkInstructionListResultsCount(java.util.Date from, java.util.Date to)
int | getWoItemWorkInstructionListResultsCount(java.lang.String woNumberLike)
WorkCalendarVO | getWorkCalendarByPK(java.lang.Long workDate)
WorkCenterVO | getWorkCenterById(java.lang.String id)
WorkCenterVO | getWorkCenterById(java.lang.String id, boolean isGroup)
int | getWorkCenterByWcNumber(java.lang.String wcNumber)
int | getWorkCenterByWcNumber(java.lang.String wcNumber, java.lang.String description, java.lang.String workCenterSearchType)
java.util.Collection<WorkCenterLoadListResult> | getWorkCenterLoadListResult(WCLoadAgent cAgent)
int | getWorkCenterLoadResultsCount(WorkCenterLoadAgent agent)
WorkCenterVO | getWorkCenterOrGroupById(java.lang.String id)
int | getWorkCenterRunTimeListResultsCount(WorkCenterRunTimeAgent agent)
WorkCenterRunTimeTotalResult | getWorkCenterRunTimeTotalResult(WorkCenterRunTimeAgent agent)
WorkInstructionApprovalVO | getWorkInstructionApprovalByEmployeeID(java.lang.String employeeId)
int | getWorkInstructionApprovalByEmployeeIDCount(java.lang.String employeeId)
WorkInstructionVO | getWorkInstructionByPart(BB2Part part, java.lang.String setId)
WorkInstructionVO | getWorkInstructionByPk(WorkInstructionPK pk)
int | getWorkInstructionCountByAuthor(java.lang.String author)
int | getWorkInstructionCountByStatus(java.lang.String status)
WorkInstructionDocumentVO | getWorkInstructionDocByID(java.lang.Long controlNumber)
int | getWorkInstructionsCountByPartLike(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String setID, java.lang.String status, boolean revMismatched)
int | getWorkInstructionSeqAuditListResultsCount()
int | getWorkInstructionSeqAuditListResultsCount(java.lang.String pnLike, java.lang.String partType, java.lang.String setId, java.lang.String seqNum, java.lang.String wcLike)
int | getWorkInstructionSeqCountByAuthor(java.lang.String author)
int | getWorkInstructionSeqCountByWorkCenter(java.lang.String workCenter)
int | getWorkInstructionSeqCountOnHold()
WorkInstructionSequenceVO | getWorkInstructionSequence(WorkOrderItemPK itemPk, java.lang.String seqNumber)
int | getWorkInstructionSeqWithZeroEstHoursCount()
WorkInstructionSummaryResult | getWorkInstructionSummaryResult(BB2Part part, java.lang.String setId)
java.util.Collection<WorkOrderItemWCLoadResult> | getWorkOrderItemWCLoadResults(WorkCenterAgent agent)
boolean | hasToolList(PartPK partPk)
PurchaseOrderItemVO | initPurchaseOrderItemForTool(java.lang.String purchaseOrderNumber, java.lang.String itemNumber, PartPK partPk, java.math.BigDecimal qty)
PurchaseWorkSheetItemWithRelatedInfoResult | initPurchaseWorkSheetItemForTool(PurchaseWorkSheetPK pk, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
RequestForQuoteItemVO | initRequestForQuoteItemForTool(java.lang.String requestForQuoteNumber, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty, java.lang.String languageCode)
ReturnToVendorItemVO | initReturnToVendorItemForPart(java.lang.String rtvNumber, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
ReturnToVendorItemVO | initReturnToVendorItemForTool(java.lang.String rtvNumber, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
ToolListItemWithToolInfoResult | initToolListItemWithToolInfo(PartPK partPk, BillItemPK pk, java.math.BigDecimal qty)
ToolManufacturerVO | InitToolManufacturerVoByAddressId(PartPK partPk, java.lang.String manufacturerId)
ToolVendorVO | InitToolVendorVoByAddressId(PartPK partPk, java.lang.String vendorId)
boolean | isInspectionItemExist(InspectionItemPK pk)
boolean | isInspectionReportExist(java.lang.String inspectionReportNumber)
boolean | isInspectionReportInspectMethodExist(int ii)
boolean | isOperatingInstructionsExist(java.lang.String operatingInstructionsNumber)
boolean | isOperatingInstructionsInspectStandardExist(int ii)
boolean | isOperatingInstructionsManualExist(int ii)
boolean | isOperatingInstructionsTypeExist(int ii)
boolean | isOperatingOutputFileTypeExist(int ii)
boolean | isPurchaseOrderApprovalExistent(java.lang.String approvalUserName)
boolean | isPurchaseOrderExistent(java.lang.String purchaseOrderNumber)
boolean | isPurchaseOrderInMyPrintList(java.lang.String purchaseOrderNumber)
boolean | isPurchaseOrderItemExistent(PurchaseOrderItemPK pk)
boolean | isPurchaseWorkSheetExistent(PurchaseWorkSheetPK pk)
boolean | isRequestForQuoteExistent(java.lang.String requestForQuoteNumber)
boolean | isRequestForQuoteOPEN(java.lang.String requestForQuoteNumber)
boolean | isReturnToVendorExistent(java.lang.String returnToVendorNumber)
boolean | isToolExistent(PartPK pk)
boolean | isToolListExistent(BillPK pk)
boolean | isWorkCalendarExist(java.lang.Long workDate)
boolean | isWorkCenterExist(java.lang.String wcNumber)
boolean | isWorkInstructionApprovalExistent(java.lang.String employeeId)
boolean | isWorkInstructionExist(WorkInstructionPK pk)
void | logOffTimeCard(java.util.ArrayList list)
void | logOffTimeCard(WorkOrderTimeCardVO vo)
java.util.Collection<PurchaseOrderListResult> | makePurchaseOrders(PurchaseWorkSheetVO pwsVO)
java.util.Collection<RequestForQuoteListResult> | makeRequestForQuotes(PurchaseWorkSheetVO pwsVO)
java.lang.Long | makeToolCalibration(PartPK partPk)
void | pauseOperatingInstructions(OperatingInstructionsVO vo)
void | requestInspectionForOperatingInstructions(OperatingInstructionsVO vo)
void | reverseRelatedInspectorSign(java.lang.String operatingInstructionsNumber, java.lang.String relatedInspectorSign)
void | reverseResultSign(java.lang.String operatingInstructionsNumber)
void | reverseStaffSign(java.lang.String operatingInstructionsNumber, java.lang.String staffSign)
void | setParentToolList(ToolListVO billVO, ToolListItemVO billItemVO)
void | setPurchaseOrderItemReferenceDocOne(PurchaseOrderItemPK pk, java.lang.String referenceDoc)
void | setPurchaseOrderItemReferenceDocTwo(PurchaseOrderItemPK pk, java.lang.String referenceDoc)
void | setToDefaultWorkInstruction(WorkInstructionPK wiPk)
void | updateDefaultStatus(WorkInstructionVO vo)
EquipmentVO | updateEquipment(EquipmentVO vo)
void | updateInactiveTool(PartPK pk, boolean inactive)
void | updateInspectionItem(InspectionItemVO vo)
void | updateInspectionReport(InspectionReportVO vo)
void | updateInspectionReportInspectMethod(InspectionReportInspectMethodVO vo)
MaintenanceItemVO | updateMaintenanceItem(MaintenanceItemVO vo)
EngineeringChangeRequestVO | updateManufacturerECRequest(EngineeringChangeRequestVO ecRequestVO)
EngineeringChangeVO | updateManufacturerEngineeringChange(EngineeringChangeVO engChange)
void | updateOIPrincipal(OIPrincipalVO vo)
void | updateOperatingInstructions(OperatingInstructionsVO vo)
void | updateOperatingInstructionsInspectStandard(OperatingInstructionsInspectStandardVO vo)
void | updateOperatingInstructionsManual(OperatingInstructionsManualVO vo)
void | updateOperatingInstructionsType(OperatingInstructionsTypeVO vo)
void | updateOperatingOutputFileType(OperatingOutputFileTypeVO vo)
java.lang.String | updatePurchaseOrder(PurchaseOrderVO purVO)
PurchaseOrderApprovalVO | updatePurchaseOrderApproval(PurchaseOrderApprovalVO purApprovalVO)
void | updatePurchaseOrderItem(PurchaseOrderItemVO purItemVO)
PurchaseWorkSheetVO | updatePurchaseWorkSheet(PurchaseWorkSheetVO pwsVO)
RequestForQuoteVO | updateRequestForQuote(RequestForQuoteVO rfqVO)
ReturnToVendorVO | updateReturnToVendor(ReturnToVendorVO rtvVO)
WorkInstructionRequestForChangeVO | updateRFC(WorkInstructionRequestForChangeVO vo)
void | updateTimeCard(java.util.ArrayList list)
WorkOrderTimeCardVO | updateTimeCard(WorkOrderTimeCardVO vo)
ToolVO | updateTool(ToolVO toolVO)
java.util.Collection<ToolCalibrateListResult> | updateToolCalibration(java.util.ArrayList toolCalibrationList, PartPK partPk)
ToolListVO | updateToolList(ToolListVO billVO)
void | updateToolListItem(ToolListItemVO billItemVO)
ToolManufacturerVO | updateToolManufacturer(java.util.Set partManufacturerSet, PartPK partPk)
ToolVendorVO | updateToolVendor(java.util.Set partVendorVoSet, PartPK partPk)
void | updateToolWithOnhands(ToolWithOnhandsVO vo)
WorkCalendarVO | updateWorkCalendar(WorkCalendarVO vo)
WorkCenterVO | updateWorkCenter(WorkCenterVO vo)
WorkInstructionPK | updateWorkInstruction(WorkInstructionVO vo)
WorkInstructionApprovalVO | updateWorkInstructionApproval(WorkInstructionApprovalVO vo)
java.util.Collection<OnloanDocumentVO> | uploadOrUpdateOnloanDoc(MiscDocAgent agent)
java.util.Collection<WorkInstructionDocumentVO> | uploadWorkInstructionDocument(MiscDocAgent agent)
WorkInstructionPictureVO | uploadWorkInstructionPicture(MiscDocAgent agent)

Method Detail

addTimeCard

WorkOrderTimeCardVO addTimeCard(WorkOrderTimeCardVO vo)
                                throws java.lang.Exception
Throws:
java.lang.Exception

addTimeCard

WorkOrderTimeCardVO addTimeCard(WorkOrderTimeCardVO vo,
                                boolean unFinished)
                                throws java.lang.Exception
Throws:
java.lang.Exception

deleteTimeCard

void deleteTimeCard(WorkOrderTimeCardVO vo)
                    throws java.lang.Exception
Throws:
java.lang.Exception

findTimeCardByPk

WorkOrderTimeCardVO findTimeCardByPk(java.lang.Long pk)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findTimeCardsByWO

java.util.Collection<WorkOrderTimeCardVO> findTimeCardsByWO(java.lang.String workOrder,
                                                            int firstIndex,
                                                            int maxLength)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getTimeCardsCountByWO

int getTimeCardsCountByWO(java.lang.String workOrderNumber)
                          throws java.lang.Exception
Throws:
java.lang.Exception

findTimeCardsByVendorId

java.util.Collection<WorkOrderTimeCardVO> findTimeCardsByVendorId(java.lang.String vendorId,
                                                                  int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getTimeCardsByVendorId

int getTimeCardsByVendorId(java.lang.String vendorId)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findCloseTimeCards

java.util.Collection<WorkOrderItemTimeDetailVO> findCloseTimeCards(java.lang.String employeeId,
                                                                   java.lang.String wo,
                                                                   java.lang.String itemNumberNumber,
                                                                   java.util.Date fromDate,
                                                                   java.util.Date toDate,
                                                                   java.lang.String department,
                                                                   java.lang.String workCenter,
                                                                   int firstIndex,
                                                                   int maxLength)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getCloseTimeCardsCount

int getCloseTimeCardsCount(java.lang.String employeeId,
                           java.lang.String workOrder,
                           java.lang.String itemNumberNumber,
                           java.util.Date fromDate,
                           java.util.Date toDate,
                           java.lang.String department,
                           java.lang.String workCenter)
                           throws java.lang.Exception
Throws:
java.lang.Exception

updateTimeCard

WorkOrderTimeCardVO updateTimeCard(WorkOrderTimeCardVO vo)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

logOffTimeCard

void logOffTimeCard(WorkOrderTimeCardVO vo)
                    throws java.lang.Exception
Throws:
java.lang.Exception

updateTimeCard

void updateTimeCard(java.util.ArrayList list)
                    throws java.lang.Exception
Throws:
java.lang.Exception

logOffTimeCard

void logOffTimeCard(java.util.ArrayList list)
                    throws java.lang.Exception
Throws:
java.lang.Exception

findAllTimeCards

java.util.Collection<WorkOrderTimeCardVO> findAllTimeCards(int firstIndex,
                                                           int maxLength)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getAllTimeCardsCount

int getAllTimeCardsCount()
                         throws java.lang.Exception
Throws:
java.lang.Exception

findOpenTimeCardsById

EmployeeTimeCardResult findOpenTimeCardsById(java.lang.String employeeId)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

getOpenTimeCardsCountById

int getOpenTimeCardsCountById(java.lang.String employeeId)
                              throws java.lang.Exception
Throws:
java.lang.Exception

findOpenTimeCardsByEmployeeLike

java.util.Collection<WorkOrderTimeCardVO> findOpenTimeCardsByEmployeeLike(java.lang.String employeeId,
                                                                          int firstIndex,
                                                                          int maxLength)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getOpenTimeCardsCountByEmployeeLike

int getOpenTimeCardsCountByEmployeeLike(java.lang.String employeeId)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

addWorkCenter

WorkCenterVO addWorkCenter(WorkCenterVO vo)
                           throws java.lang.Exception
Throws:
java.lang.Exception

updateWorkCenter

WorkCenterVO updateWorkCenter(WorkCenterVO vo)
                              throws java.lang.Exception
Throws:
java.lang.Exception

deleteWorkCenter

void deleteWorkCenter(WorkCenterVO vo)
                      throws java.lang.Exception
Throws:
java.lang.Exception

copyWorkCenterFromWorkCenter

WorkCenterVO copyWorkCenterFromWorkCenter(WC2WCAgent agent)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

getWorkCenterById

WorkCenterVO getWorkCenterById(java.lang.String id)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getWorkCenterById

WorkCenterVO getWorkCenterById(java.lang.String id,
                               boolean isGroup)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getWorkCenterOrGroupById

WorkCenterVO getWorkCenterOrGroupById(java.lang.String id)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

isWorkCenterExist

boolean isWorkCenterExist(java.lang.String wcNumber)
                          throws java.lang.Exception
Throws:
java.lang.Exception

findWorkCenterByWcNumber

java.util.List findWorkCenterByWcNumber(java.lang.String wcNumber,
                                        java.lang.String description,
                                        java.lang.String workCenterSearchType,
                                        int firstIndex,
                                        int maxLength)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

getWorkCenterByWcNumber

int getWorkCenterByWcNumber(java.lang.String wcNumber,
                            java.lang.String description,
                            java.lang.String workCenterSearchType)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findWorkCenterByWcNumber

java.util.Collection<WorkCenterVO> findWorkCenterByWcNumber(java.lang.String wcNumber,
                                                            int firstIndex,
                                                            int maxLength)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getWorkCenterByWcNumber

int getWorkCenterByWcNumber(java.lang.String wcNumber)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findWorkCenterLoadResults

java.util.Collection<WorkCenterLoadListResult> findWorkCenterLoadResults(WorkCenterLoadAgent agent,
                                                                         int firstIndex,
                                                                         int maxLength)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getWorkCenterLoadResultsCount

int getWorkCenterLoadResultsCount(WorkCenterLoadAgent agent)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

getWCLoadIDs

java.util.Collection<WorkCenterAgent> getWCLoadIDs(java.lang.String wcLike,
                                                   java.lang.String departLike)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getWorkCenterLoadListResult

java.util.Collection<WorkCenterLoadListResult> getWorkCenterLoadListResult(WCLoadAgent cAgent)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getWCLoadDetailResults

java.util.Collection<WCLoadDetailResult> getWCLoadDetailResults(WCLoadAgent agnet)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getWCLoadDetailResults

java.util.Collection<WCLoadDetailResult> getWCLoadDetailResults(java.lang.String wcID)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getWCLoadDetailResultsforWOItem

java.util.Collection<WCLoadDetailResult> getWCLoadDetailResultsforWOItem(WorkOrderItemPK pk)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getWCLoadOnDate

WCLoadOnDateResult getWCLoadOnDate(WorkCenterOnDateAgent agent)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

addToolCalibration

ToolCalibrationVO addToolCalibration(PartPK partPk,
                                     java.lang.String serialNumber)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

updateToolCalibration

java.util.Collection<ToolCalibrateListResult> updateToolCalibration(java.util.ArrayList toolCalibrationList,
                                                                    PartPK partPk)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

makeToolCalibration

java.lang.Long makeToolCalibration(PartPK partPk)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

deleteCalibration

void deleteCalibration(ToolCalibrationVO vo)
                       throws java.lang.Exception
Throws:
java.lang.Exception

findAllCalibrations

java.util.Collection<ToolCalibrateListResult> findAllCalibrations(int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getAllCalibrationsCount

int getAllCalibrationsCount()
                            throws java.lang.Exception
Throws:
java.lang.Exception

findCalibrationByPart

java.util.Collection<ToolCalibrationVO> findCalibrationByPart(java.lang.String pnLike,
                                                              java.lang.String partType)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

findCalibrationsByLocation

java.util.Collection<ToolCalibrateListResult> findCalibrationsByLocation(java.lang.String location,
                                                                         int firstIndex,
                                                                         int maxLength)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

findCalibrationsByNextInspectionInDays

java.util.Collection<ToolCalibrateListResult> findCalibrationsByNextInspectionInDays(int day,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findCalibrationsDue

java.util.Collection<ToolCalibrateListResult> findCalibrationsDue(int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getCalibrationsDueCount

int getCalibrationsDueCount()
                            throws java.lang.Exception
Throws:
java.lang.Exception

getCalibrationsByNextInspectionInDaysCount

int getCalibrationsByNextInspectionInDaysCount(int day)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

findCalibrationsByDate

java.util.Collection<ToolCalibrateListResult> findCalibrationsByDate(java.util.Date fromDate,
                                                                     java.util.Date toDate,
                                                                     boolean isLast,
                                                                     PartPK partPk,
                                                                     java.lang.String assign,
                                                                     int firstIndex,
                                                                     int maxLength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getCalibrationsCountByDate

int getCalibrationsCountByDate(java.util.Date fromDate,
                               java.util.Date toDate,
                               boolean isLast,
                               PartPK partPk,
                               java.lang.String assign)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findToolCalibrationsByPart

java.util.Collection<ToolCalibrateListResult> findToolCalibrationsByPart(PartPK partPk,
                                                                         int firstIndex,
                                                                         int maxLength)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getToolCalibrationsByPartCount

int getToolCalibrationsByPartCount(PartPK partPk)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findCalibrationsByAssignedTo

java.util.Collection<ToolCalibrateListResult> findCalibrationsByAssignedTo(java.lang.String assignedTo,
                                                                           int firstIndex,
                                                                           int maxLength)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getCalibrationsByAssignedToCount

int getCalibrationsByAssignedToCount(java.lang.String assignedTo)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

getCalibrationsCountByLocation

int getCalibrationsCountByLocation(java.lang.String location)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findCalibrationsByInspectedBy

java.util.Collection<ToolCalibrateListResult> findCalibrationsByInspectedBy(java.lang.String inspectedBy,
                                                                            int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getCalibrationsCountByInspectedBy

int getCalibrationsCountByInspectedBy(java.lang.String inspectedBy)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

addWorkInstructionApproval

WorkInstructionApprovalVO addWorkInstructionApproval(java.lang.String employeeId)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

deleteWorkInstruction

void deleteWorkInstruction(WorkInstructionPK pk)
                           throws java.lang.Exception
Throws:
java.lang.Exception

deleteWorkInstructionApproval

void deleteWorkInstructionApproval(java.lang.String employeeId)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

updateWorkInstructionApproval

WorkInstructionApprovalVO updateWorkInstructionApproval(WorkInstructionApprovalVO vo)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

isWorkInstructionApprovalExistent

boolean isWorkInstructionApprovalExistent(java.lang.String employeeId)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

getWorkInstructionApprovalByEmployeeID

WorkInstructionApprovalVO getWorkInstructionApprovalByEmployeeID(java.lang.String employeeId)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findWorkInstructionApprovalByEmployeeID

java.util.Collection<WorkInstructionApprovalVO> findWorkInstructionApprovalByEmployeeID(java.lang.String employeeId,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getWorkInstructionApprovalByEmployeeIDCount

int getWorkInstructionApprovalByEmployeeIDCount(java.lang.String employeeId)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

addWorkInstruction

WorkInstructionVO addWorkInstruction(WorkInstructionPK pk)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

updateWorkInstruction

WorkInstructionPK updateWorkInstruction(WorkInstructionVO vo)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

approveWorkInstruction

WorkInstructionVO approveWorkInstruction(WorkInstructionVO vo)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

copyToAddWorkInstruction

WorkInstructionVO copyToAddWorkInstruction(WorkInstructionVO vo)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

copyWorkInstruction

WorkInstructionVO copyWorkInstruction(WorkInstructionPK oldPk,
                                      WorkInstructionPK newPk)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

setToDefaultWorkInstruction

void setToDefaultWorkInstruction(WorkInstructionPK wiPk)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

isWorkInstructionExist

boolean isWorkInstructionExist(WorkInstructionPK pk)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getAllWorkInstructionsCount

int getAllWorkInstructionsCount()
                                throws java.lang.Exception
Throws:
java.lang.Exception

getWorkInstructionByPk

WorkInstructionVO getWorkInstructionByPk(WorkInstructionPK pk)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

getWorkInstructionByPart

WorkInstructionVO getWorkInstructionByPart(BB2Part part,
                                           java.lang.String setId)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

getDefaultWorkInstructionByPartPk

WorkInstructionVO getDefaultWorkInstructionByPartPk(BB2Part part)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

findWorkInstructionsByPartLike

java.util.Collection<WorkInstructionListResult> findWorkInstructionsByPartLike(java.lang.String partNumber,
                                                                               java.lang.String partType,
                                                                               java.lang.String partFrom,
                                                                               java.lang.String setID,
                                                                               java.lang.String status,
                                                                               boolean revMismatched,
                                                                               int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

findWorkInstructionsByPartLike

java.util.Collection<WorkInstructionListResult> findWorkInstructionsByPartLike(java.lang.String partNumber,
                                                                               java.lang.String partType,
                                                                               java.lang.String partFrom,
                                                                               java.lang.String setID,
                                                                               java.lang.String status,
                                                                               boolean revMismatched,
                                                                               int firstIndex,
                                                                               int maxLength,
                                                                               boolean isLike)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getWorkInstructionsCountByPartLike

int getWorkInstructionsCountByPartLike(java.lang.String partNumber,
                                       java.lang.String partType,
                                       java.lang.String partFrom,
                                       java.lang.String setID,
                                       java.lang.String status,
                                       boolean revMismatched)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findWorkInstructionByAuthor

java.util.Collection<WorkInstructionListResult> findWorkInstructionByAuthor(java.lang.String author,
                                                                            int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getWorkInstructionCountByAuthor

int getWorkInstructionCountByAuthor(java.lang.String author)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findWorkInstructionByStatus

java.util.Collection<WorkInstructionListResult> findWorkInstructionByStatus(java.lang.String status,
                                                                            int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getWorkInstructionCountByStatus

int getWorkInstructionCountByStatus(java.lang.String status)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findWorkInstructionSeqByWorkCenter

java.util.Collection<WorkInstructionSequenceListResult> findWorkInstructionSeqByWorkCenter(java.lang.String workCenter,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getWorkInstructionSeqCountByWorkCenter

int getWorkInstructionSeqCountByWorkCenter(java.lang.String workCenter)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

findWorkInstructionSeqByAuthor

java.util.Collection<WorkInstructionSequenceListResult> findWorkInstructionSeqByAuthor(java.lang.String author,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getWorkInstructionSeqCountByAuthor

int getWorkInstructionSeqCountByAuthor(java.lang.String author)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findWorkInstructionSeqOnHold

java.util.Collection<WorkInstructionSequenceListResult> findWorkInstructionSeqOnHold(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getWorkInstructionSeqCountOnHold

int getWorkInstructionSeqCountOnHold()
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findWoItemWorkInstructionListResults

java.util.Collection<WoItemWorkInstructionListResult> findWoItemWorkInstructionListResults(java.lang.String woNumberLike,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getWoItemWorkInstructionListResultsCount

int getWoItemWorkInstructionListResultsCount(java.lang.String woNumberLike)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findWoItemWorkInstructionListResults

java.util.Collection<WoItemWorkInstructionListResult> findWoItemWorkInstructionListResults(java.util.Date from,
                                                                                java.util.Date to,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getWoItemWorkInstructionListResultsCount

int getWoItemWorkInstructionListResultsCount(java.util.Date from,
                                             java.util.Date to)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

uploadWorkInstructionPicture

WorkInstructionPictureVO uploadWorkInstructionPicture(MiscDocAgent agent)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

deleteWorkInstructionPicture

void deleteWorkInstructionPicture(MiscDocAgent agent)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

downloadWorkInstructionPicture

BB2Picture downloadWorkInstructionPicture(MiscDocAgent agent)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

addWorkInstructionPicture

WorkInstructionPictureVO addWorkInstructionPicture(WorkInstructionPictureVO vo)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

deleteWorkInstructionPicture

void deleteWorkInstructionPicture(java.lang.Long ii)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

addRFC

WorkInstructionRequestForChangeVO addRFC(WorkInstructionRequestForChangeVO vo)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

getWorkInstructionSequence

WorkInstructionSequenceVO getWorkInstructionSequence(WorkOrderItemPK itemPk,
                                                     java.lang.String seqNumber)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

deleteRFC

void deleteRFC(WorkInstructionRequestForChangeVO vo)
               throws java.lang.Exception
Throws:
java.lang.Exception

findAllRfcs

java.util.Collection<WorkInstructionRequestForChangeVO> findAllRfcs(int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getAllRFCsCount

int getAllRFCsCount()
                    throws java.lang.Exception
Throws:
java.lang.Exception

findRFCByPk

WorkInstructionRequestForChangeVO findRFCByPk(java.lang.String pk)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

updateRFC

WorkInstructionRequestForChangeVO updateRFC(WorkInstructionRequestForChangeVO vo)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

getRFCCountByRFC

int getRFCCountByRFC(java.lang.String rfc)
                     throws java.lang.Exception
Throws:
java.lang.Exception

findRFCsByRFC

java.util.Collection<WorkInstructionRequestForChangeVO> findRFCsByRFC(java.lang.String rfc,
                                                                      int firstIndex,
                                                                      int maxLength)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getOpenRFCCount

int getOpenRFCCount()
                    throws java.lang.Exception
Throws:
java.lang.Exception

findOpenRFCs

java.util.Collection<WorkInstructionRequestForChangeVO> findOpenRFCs(int firstIndex,
                                                                     int maxLength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getPastDueRFCCount

int getPastDueRFCCount()
                       throws java.lang.Exception
Throws:
java.lang.Exception

findPastDueRFCs

java.util.Collection<WorkInstructionRequestForChangeVO> findPastDueRFCs(int firstIndex,
                                                                        int maxLength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

findOpenWorkInstructions

java.util.Collection<WorkInstructionVO> findOpenWorkInstructions(int firstIndex,
                                                                 int maxLength)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getOpenWorkInstructionsCount

int getOpenWorkInstructionsCount()
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findWorkInstructionSeqWithZeroEstHours

java.util.Collection<WorkInstructionSequenceListResult> findWorkInstructionSeqWithZeroEstHours(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getWorkInstructionSeqWithZeroEstHoursCount

int getWorkInstructionSeqWithZeroEstHoursCount()
                                               throws java.lang.Exception
Throws:
java.lang.Exception

findAllWorkInstructions

java.util.Collection<WorkInstructionListResult> findAllWorkInstructions(int firstIndex,
                                                                        int maxLength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

auditingWorkInstructionAvgHrs

void auditingWorkInstructionAvgHrs(java.util.HashMap maps)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

getWorkInstructionDocByID

WorkInstructionDocumentVO getWorkInstructionDocByID(java.lang.Long controlNumber)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

uploadWorkInstructionDocument

java.util.Collection<WorkInstructionDocumentVO> uploadWorkInstructionDocument(MiscDocAgent agent)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

downWorkInstructionDocument

byte[] downWorkInstructionDocument(MiscDocAgent agent)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

deleteWorkInstructionDocument

void deleteWorkInstructionDocument(MiscDocAgent agent)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findWorkInstructionDocInfo

java.util.Collection<WorkInstructionDocumentVO> findWorkInstructionDocInfo(WorkInstructionPK pk)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getToolOnhands

ToolWithOnhandsVO getToolOnhands(PartPK pk)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

updateToolWithOnhands

void updateToolWithOnhands(ToolWithOnhandsVO vo)
                           throws java.lang.Exception
Throws:
java.lang.Exception

isToolExistent

boolean isToolExistent(PartPK pk)
                       throws java.lang.Exception
Throws:
java.lang.Exception

addTool

ToolVO addTool(ToolVO vo)
               throws java.lang.Exception
Throws:
java.lang.Exception

updateTool

ToolVO updateTool(ToolVO toolVO)
                  throws java.lang.Exception
Throws:
java.lang.Exception

getToolByPk

ToolVO getToolByPk(PartPK pk)
                   throws java.lang.Exception
Throws:
java.lang.Exception

findAllTools

java.util.Collection<ToolBasicInfo> findAllTools(int firstIndex,
                                                 int maxLength)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getAllToolsCount

int getAllToolsCount()
                     throws java.lang.Exception
Throws:
java.lang.Exception

findToolsByToolLike

java.util.Collection<ToolBasicInfo> findToolsByToolLike(java.lang.String partNum,
                                                        java.lang.String toolDes,
                                                        java.lang.String partType,
                                                        int firstIndex,
                                                        int maxLength)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getToolsCountByToolLike

int getToolsCountByToolLike(java.lang.String partNum,
                            java.lang.String partDescription,
                            java.lang.String partType)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findToolsOnHold

java.util.Collection<ToolBasicInfo> findToolsOnHold(int firstIndex,
                                                    int maxLength)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getToolsCountByOnHold

int getToolsCountByOnHold()
                          throws java.lang.Exception
Throws:
java.lang.Exception

findToolsByDescriptionInside

java.util.Collection<ToolBasicInfo> findToolsByDescriptionInside(java.lang.String edRegex,
                                                                 int firstIndex,
                                                                 int maxLength)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getToolsCountByDescriptionInside

int getToolsCountByDescriptionInside(java.lang.String descriptionRegex)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findToolsByDescriptionStart

java.util.Collection<ToolBasicInfo> findToolsByDescriptionStart(java.lang.String edRegex,
                                                                int firstIndex,
                                                                int maxLength)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getToolsCountByDescriptionStart

int getToolsCountByDescriptionStart(java.lang.String descriptionRegex)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findToolsByManufacturerPn

java.util.Collection<ToolWithManufacturerInfoResult> findToolsByManufacturerPn(java.lang.String mpnRegex,
                                                                               int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getToolsCountByManufacturerPn

int getToolsCountByManufacturerPn(java.lang.String mpnRegex)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findToolsByManufacturerId

java.util.Collection<ToolWithManufacturerInfoResult> findToolsByManufacturerId(java.lang.String mfgIdRegex,
                                                                               int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getToolsCountByManufacturerId

int getToolsCountByManufacturerId(java.lang.String IdRegex)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findToolsWithDrawing

java.util.Collection<ToolBasicInfo> findToolsWithDrawing(int firstIndex,
                                                         int maxLength)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getToolsWithDrawingCount

int getToolsWithDrawingCount()
                             throws java.lang.Exception
Throws:
java.lang.Exception

findToolsWithWI

java.util.Collection<ToolBasicInfo> findToolsWithWI(int firstIndex,
                                                    int maxLength)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getToolsWithWICount

int getToolsWithWICount()
                        throws java.lang.Exception
Throws:
java.lang.Exception

findToolsWithToolList

java.util.Collection<ToolBasicInfo> findToolsWithToolList(int firstIndex,
                                                          int maxLength)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getToolsWithToolListCount

int getToolsWithToolListCount()
                              throws java.lang.Exception
Throws:
java.lang.Exception

getToolBasicInfo

ToolBasicInfo getToolBasicInfo(PartPK pk)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getToolBasicInfo

ToolBasicInfo getToolBasicInfo(PartPK pk,
                               java.lang.String languageCode)
                               throws java.lang.Exception
Throws:
java.lang.Exception

hasToolList

boolean hasToolList(PartPK partPk)
                    throws java.lang.Exception
Throws:
java.lang.Exception

findInactiveTool

java.util.Collection<ToolBasicInfo> findInactiveTool(java.lang.String toolNumber,
                                                     int firstIndex,
                                                     int maxLength)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getFindInactiveToolCount

int getFindInactiveToolCount(java.lang.String toolNumber)
                             throws java.lang.Exception
Throws:
java.lang.Exception

addToolList

ToolListVO addToolList(ToolListVO billVO)
                       throws java.lang.Exception
Throws:
java.lang.Exception

updateToolList

ToolListVO updateToolList(ToolListVO billVO)
                          throws java.lang.Exception
Throws:
java.lang.Exception

deleteToolList

void deleteToolList(ToolListVO billVO)
                    throws java.lang.Exception
Throws:
java.lang.Exception

addToolListItem

void addToolListItem(ToolListItemVO itemVO)
                     throws java.lang.Exception
Throws:
java.lang.Exception

getToolList

ToolListVO getToolList(BillPK billPk)
                       throws java.lang.Exception
Throws:
java.lang.Exception

isToolListExistent

boolean isToolListExistent(BillPK pk)
                           throws java.lang.Exception
Throws:
java.lang.Exception

getToolListDetailCostResult

ToolListDetailCostResult getToolListDetailCostResult(BillPK billPk,
                                                     java.lang.String languageCode)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getToolListWithToolInfoByBillPk

ToolListWithToolInfoResult getToolListWithToolInfoByBillPk(BillPK billPk,
                                                           java.lang.String languageCode)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

findAllToolListsWithToolInfo

java.util.Collection<ToolListWithToolInfoResult> findAllToolListsWithToolInfo(java.lang.String languageCode,
                                                                              int firstIndex,
                                                                              int maxLength)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getAllToolListsWithToolInfoCount

int getAllToolListsWithToolInfoCount()
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findToolListswithToolInfoByBillNumberLike

java.util.Collection<ToolListWithToolInfoResult> findToolListswithToolInfoByBillNumberLike(java.lang.String bnRegex,
                                                                                java.lang.String billType,
                                                                                java.lang.String languageCode,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getToolListsCountByBillNumberLike

int getToolListsCountByBillNumberLike(java.lang.String bnRegex,
                                      java.lang.String billType)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

setParentToolList

void setParentToolList(ToolListVO billVO,
                       ToolListItemVO billItemVO)
                       throws java.lang.Exception
Throws:
java.lang.Exception

getToolListItems

ToolListItemVO getToolListItems(BillItemPK itemPk)
                                throws java.lang.Exception
Throws:
java.lang.Exception

updateToolListItem

void updateToolListItem(ToolListItemVO billItemVO)
                        throws java.lang.Exception
Throws:
java.lang.Exception

deleteToolListItem

void deleteToolListItem(ToolListItemVO billItemVO)
                        throws java.lang.Exception
Throws:
java.lang.Exception

getParentToolList

ToolListVO getParentToolList(ToolListItemVO billItemVO)
                             throws java.lang.Exception
Throws:
java.lang.Exception

getToolListItemCount

int getToolListItemCount(BillPK billPk)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findToolListItemWithToolInfoByBillPk

java.util.Collection<ToolListItemWithToolInfoResult> findToolListItemWithToolInfoByBillPk(BillPK billPk,
                                                                                java.lang.String languageCode)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findToolWhereIsUsed

ToolWhereUsedResult findToolWhereIsUsed(PartPK pk)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

getToolListItemWithToolInfoByBillItemPk

ToolListItemWithToolInfoResult getToolListItemWithToolInfoByBillItemPk(BillItemPK billItemPk,
                                                                       java.lang.String languageCode)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

initToolListItemWithToolInfo

ToolListItemWithToolInfoResult initToolListItemWithToolInfo(PartPK partPk,
                                                            BillItemPK pk,
                                                            java.math.BigDecimal qty)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

findToolListItemWithToolInfoByBillPk

java.util.Collection<ToolListItemWithToolInfoResult> findToolListItemWithToolInfoByBillPk(BillPK billPk,
                                                                                java.lang.String languageCode,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getToolInventoryByPk

ToolInventoryVO getToolInventoryByPk(PartPK partPk)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findToolVendorsByPartPk

java.util.Collection<ToolVendorVO> findToolVendorsByPartPk(PartPK partPk)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

InitToolVendorVoByAddressId

ToolVendorVO InitToolVendorVoByAddressId(PartPK partPk,
                                         java.lang.String vendorId)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

updateToolVendor

ToolVendorVO updateToolVendor(java.util.Set partVendorVoSet,
                              PartPK partPk)
                              throws java.lang.Exception
Throws:
java.lang.Exception

InitToolManufacturerVoByAddressId

ToolManufacturerVO InitToolManufacturerVoByAddressId(PartPK partPk,
                                                     java.lang.String manufacturerId)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

findToolManufacturersByPartPk

java.util.Collection<ToolManufacturerVO> findToolManufacturersByPartPk(PartPK partPk)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

updateToolManufacturer

ToolManufacturerVO updateToolManufacturer(java.util.Set partManufacturerSet,
                                          PartPK partPk)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

addManufacturerEngineeringChange

EngineeringChangeVO addManufacturerEngineeringChange(EngineeringChangeVO engChangeVO)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getManufacturerEngineeringChangeById

EngineeringChangeVO getManufacturerEngineeringChangeById(java.lang.String ec)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

findAllManufacturerEngineeringChanges

java.util.Collection<EngineeringChangeListResult> findAllManufacturerEngineeringChanges(java.lang.String languageFlag,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllManufacturerEngineeringChangesCount

int getAllManufacturerEngineeringChangesCount()
                                              throws java.lang.Exception
Throws:
java.lang.Exception

findManufacturerEngineeringChangeByEcnNumberLike

java.util.Collection<EngineeringChangeListResult> findManufacturerEngineeringChangeByEcnNumberLike(java.lang.String ecRegex,
                                                                                java.lang.String languageCode,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getManufacturerEngineeringChangesCountByMecnNumberLike

int getManufacturerEngineeringChangesCountByMecnNumberLike(java.lang.String ecRegex)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

findManufacturerEngineeringChangeByPartLike

java.util.Collection<EngineeringChangeListResult> findManufacturerEngineeringChangeByPartLike(java.lang.String pnRegex,
                                                                                java.lang.String partType,
                                                                                java.lang.String languageCode,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getManufacturerEngineeringChangesCountByPartLike

int getManufacturerEngineeringChangesCountByPartLike(java.lang.String pnRegex,
                                                     java.lang.String partType)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

findManufacturerEngineeringChangeByPartPk

java.util.Collection<EngineeringChangeListResult> findManufacturerEngineeringChangeByPartPk(PartPK partPk,
                                                                                java.lang.String languageFlag,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getManufacturerEngineeringChangesCountByPartPk

int getManufacturerEngineeringChangesCountByPartPk(PartPK partPk)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

findOpenManufacturerEngineeringChange

java.util.Collection<EngineeringChangeListResult> findOpenManufacturerEngineeringChange(java.lang.String languageCode,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOpenManufacturerEngineeringChangesCount

int getOpenManufacturerEngineeringChangesCount()
                                               throws java.lang.Exception
Throws:
java.lang.Exception

findDueManufacturerEngineerningChange

java.util.Collection<EngineeringChangeListResult> findDueManufacturerEngineerningChange(java.lang.String languageCode,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getDueManufacturerEngineeringChangesCount

int getDueManufacturerEngineeringChangesCount()
                                              throws java.lang.Exception
Throws:
java.lang.Exception

updateManufacturerEngineeringChange

EngineeringChangeVO updateManufacturerEngineeringChange(EngineeringChangeVO engChange)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

findManufacturerECRequestByEcrNumberLike

java.util.Collection<EngineeringChangeRequestListResult> findManufacturerECRequestByEcrNumberLike(java.lang.String ecrNumberLike,
                                                                                java.lang.String languageCode,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getManufacturerECRequestCountByEcrNumberLike

int getManufacturerECRequestCountByEcrNumberLike(java.lang.String ecrNumberLike)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

deleteManufacturerEngineeringChange

void deleteManufacturerEngineeringChange(EngineeringChangeVO engChange)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

addMECRequest

EngineeringChangeRequestVO addMECRequest(EngineeringChangeRequestVO ecRequestVO)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

addMECRequest

EngineeringChangeRequestVO addMECRequest(PartPK pk)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

getMECRequest

EngineeringChangeRequestVO getMECRequest(java.lang.String mecrNumber)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

findAllManufacturerECRequests

java.util.Collection<EngineeringChangeRequestListResult> findAllManufacturerECRequests(java.lang.String languageCode,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllManufacturerECRequestsCount

int getAllManufacturerECRequestsCount()
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findManufacturerECRequestByPartLike

java.util.Collection<EngineeringChangeRequestListResult> findManufacturerECRequestByPartLike(java.lang.String pnRegex,
                                                                                java.lang.String partType,
                                                                                java.lang.String languageCode,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getManufacturerECRequestsCountByPartLike

int getManufacturerECRequestsCountByPartLike(java.lang.String pnRegex,
                                             java.lang.String partType)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findOpenManufacturerECRequest

java.util.Collection<EngineeringChangeRequestListResult> findOpenManufacturerECRequest(java.lang.String languageCode,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOpenManufacturerECRequestsCount

int getOpenManufacturerECRequestsCount()
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findDueManufacturerECRequest

java.util.Collection<EngineeringChangeRequestListResult> findDueManufacturerECRequest(java.lang.String languageCode,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getDueManufacturerECRequestsCount

int getDueManufacturerECRequestsCount()
                                      throws java.lang.Exception
Throws:
java.lang.Exception

updateManufacturerECRequest

EngineeringChangeRequestVO updateManufacturerECRequest(EngineeringChangeRequestVO ecRequestVO)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

deleteManufacturerECRequest

void deleteManufacturerECRequest(EngineeringChangeRequestVO ecRequestVO)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

addEquipment

EquipmentVO addEquipment(EquipmentVO vo)
                         throws java.lang.Exception
Throws:
java.lang.Exception

updateEquipment

EquipmentVO updateEquipment(EquipmentVO vo)
                            throws java.lang.Exception
Throws:
java.lang.Exception

addMaintenanceItem

MaintenanceItemVO addMaintenanceItem(MaintenanceItemVO vo)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

updateMaintenanceItem

MaintenanceItemVO updateMaintenanceItem(MaintenanceItemVO vo)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

deleteMaintenanceItem

void deleteMaintenanceItem(MaintenanceItemPK pk)
                           throws java.lang.Exception
Throws:
java.lang.Exception

getEquipmentById

EquipmentVO getEquipmentById(java.lang.String id)
                             throws java.lang.Exception
Throws:
java.lang.Exception

deleteEquipmentById

void deleteEquipmentById(java.lang.String id)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findAllEquipments

java.util.Collection<EquipmentListResult> findAllEquipments(int firstIndex,
                                                            int maxLength)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getAllEquipmentsCount

int getAllEquipmentsCount()
                          throws java.lang.Exception
Throws:
java.lang.Exception

findEquipmentsByEquipmentId

java.util.Collection<EquipmentListResult> findEquipmentsByEquipmentId(java.lang.String equipmentId,
                                                                      java.lang.String type,
                                                                      java.lang.String workCenterId,
                                                                      java.lang.String maintenanceBy,
                                                                      int firstIndex,
                                                                      int maxLength)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getEquipmentByEquipmentIdCount

int getEquipmentByEquipmentIdCount(java.lang.String equipmentId,
                                   java.lang.String type,
                                   java.lang.String workCenterId,
                                   java.lang.String maintenanceBy)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findEquipmentsByHours

java.util.Collection<EquipmentListResult> findEquipmentsByHours(int hours,
                                                                int firstIndex,
                                                                int maxLength)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getEquipmentByHours

int getEquipmentByHours(int hours)
                        throws java.lang.Exception
Throws:
java.lang.Exception

findEquipmentByWorkCenterId

java.util.Collection<EquipmentListResult> findEquipmentByWorkCenterId(java.lang.String workCenterId,
                                                                      int firstIndex,
                                                                      int maxLength)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getEquipmentByWorkCenterIdCount

int getEquipmentByWorkCenterIdCount(java.lang.String workCenterId)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

addPurchaseOrder

PurchaseOrderVO addPurchaseOrder(java.lang.String vendorId)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

addPurchaseOrderFromRequestForQuote

PurchaseOrderVO addPurchaseOrderFromRequestForQuote(java.lang.String rfqNumber)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

addPurchaseOrderFromWISeq

java.util.Collection<java.lang.String> addPurchaseOrderFromWISeq(POForWISeqAgent agent)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

updatePurchaseOrder

java.lang.String updatePurchaseOrder(PurchaseOrderVO purVO)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

approvePurchaseOrder

PurchaseOrderVO approvePurchaseOrder(PurchaseOrderVO purVO)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

approvePurchaseOrder

PurchaseOrderVO approvePurchaseOrder(java.lang.String purchaseOrderNumber)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

deletePurchaseOrder

void deletePurchaseOrder(PurchaseOrderVO purVO)
                         throws java.lang.Exception
Throws:
java.lang.Exception

isPurchaseOrderExistent

boolean isPurchaseOrderExistent(java.lang.String purchaseOrderNumber)
                                throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderStatus

java.lang.String getPurchaseOrderStatus(java.lang.String poNumber)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findAllPurchaseOrders

java.util.Collection<PurchaseOrderListResult> findAllPurchaseOrders(int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

findAllPurchaseOrderBP

java.util.Collection<PurchaseOrderBoilerplateVO> findAllPurchaseOrderBP(int firstIndex,
                                                                        int maxLength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getPoMessageStatus

java.lang.String getPoMessageStatus(java.lang.String poNumber)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

isPurchaseOrderInMyPrintList

boolean isPurchaseOrderInMyPrintList(java.lang.String purchaseOrderNumber)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

getRtvShipperByPoNumber

java.util.Collection<RtvShipperItemListResult> getRtvShipperByPoNumber(java.lang.String poNumber)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getAllPurchaseOrdersCount

int getAllPurchaseOrdersCount()
                              throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderByPoNumber

PurchaseOrderVO getPurchaseOrderByPoNumber(java.lang.String poNumber)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderWithOrderApplyByID

PurchaseOrderVO getPurchaseOrderWithOrderApplyByID(java.lang.Long ID)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

findAllPurchaseOrderItems

java.util.Collection<PurchaseOrderItemListResult> findAllPurchaseOrderItems(int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getAllPurchaseOrderItemsCount

int getAllPurchaseOrderItemsCount()
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findAllPurchaseOrderCheckListResults

java.util.Collection<PurchaseOrderCheckListResult> findAllPurchaseOrderCheckListResults(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllPurchaseOrderCheckListResultsCount

int getAllPurchaseOrderCheckListResultsCount()
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findPurchaseOrderCheckListResults

java.util.Collection<PurchaseOrderCheckListResult> findPurchaseOrderCheckListResults(java.lang.String startWith,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderCheckListResultsCount

int getPurchaseOrderCheckListResultsCount(java.lang.String startWith)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

findPurchaseOrderItemsByPartPk

java.util.Collection<PurchaseOrderItemListResult> findPurchaseOrderItemsByPartPk(PartPK pk,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderItemCountByPartPk

int getPurchaseOrderItemCountByPartPk(PartPK pk)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

initPurchaseOrderItemForTool

PurchaseOrderItemVO initPurchaseOrderItemForTool(java.lang.String purchaseOrderNumber,
                                                 java.lang.String itemNumber,
                                                 PartPK partPk,
                                                 java.math.BigDecimal qty)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findPurchaseOrderItemsByPartNumberLike

java.util.Collection<PurchaseOrderItemListResult> findPurchaseOrderItemsByPartNumberLike(java.lang.String partNumberReg,
                                                                                java.lang.String partType,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderItemCountByPartNumberLike

int getPurchaseOrderItemCountByPartNumberLike(java.lang.String partNumberReg,
                                              java.lang.String partType)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

findPurchaseOrderByPoNumber

java.util.Collection<PurchaseOrderListResult> findPurchaseOrderByPoNumber(java.lang.String poNumber,
                                                                          int firstIndex,
                                                                          int maxLength)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderCountByPoNumber

int getPurchaseOrderCountByPoNumber(java.lang.String poNumber)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderItemCountByDate

int getPurchaseOrderItemCountByDate(java.lang.String dateType,
                                    java.util.Date fromDate,
                                    java.util.Date toDate,
                                    java.lang.String status,
                                    java.lang.String partNumberLike,
                                    java.lang.String partType,
                                    java.lang.String shipto,
                                    java.lang.String vendorId,
                                    java.lang.String project,
                                    java.lang.String requester,
                                    java.lang.String buyer,
                                    java.lang.String currency,
                                    java.lang.String relatedDoc,
                                    java.lang.String accountNumber,
                                    java.lang.String companyUnitId)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findPurchaseOrderItemByDate

java.util.Collection<PurchaseOrderItemListResult> findPurchaseOrderItemByDate(java.lang.String dateType,
                                                                              java.util.Date fromDate,
                                                                              java.util.Date toDate,
                                                                              java.lang.String status,
                                                                              java.lang.String partNumberLike,
                                                                              java.lang.String partType,
                                                                              java.lang.String shipto,
                                                                              java.lang.String vendorId,
                                                                              java.lang.String project,
                                                                              java.lang.String requester,
                                                                              java.lang.String buyer,
                                                                              java.lang.String currency,
                                                                              java.lang.String relatedDoc,
                                                                              java.lang.String accountNumber,
                                                                              java.lang.String companyUnitId,
                                                                              int firstIndex,
                                                                              int maxLength)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

findOpenPurchaseOrderItems

java.util.Collection<PurchaseOrderOpenDueListResult> findOpenPurchaseOrderItems(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOpenPurchaseOrderItemCount

int getOpenPurchaseOrderItemCount()
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findPurchaseOrderItemsByPoNumber

java.util.Collection<PurchaseOrderItemVO> findPurchaseOrderItemsByPoNumber(java.lang.String poNumber)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderItemCountByPoNumber

int getPurchaseOrderItemCountByPoNumber(java.lang.String poNumber)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

isPurchaseOrderItemExistent

boolean isPurchaseOrderItemExistent(PurchaseOrderItemPK pk)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

addPurchaseOrderItem

PurchaseOrderItemVO addPurchaseOrderItem(PurchaseOrderItemVO purItemVO)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

updatePurchaseOrderItem

void updatePurchaseOrderItem(PurchaseOrderItemVO purItemVO)
                             throws java.lang.Exception
Throws:
java.lang.Exception

deletePurchaseOrderItem

void deletePurchaseOrderItem(PurchaseOrderItemVO purItemVO)
                             throws java.lang.Exception
Throws:
java.lang.Exception

deletePurchaseOrderItems

void deletePurchaseOrderItems(java.lang.String purchaseNumber)
                              throws java.lang.Exception
Throws:
java.lang.Exception

setPurchaseOrderItemReferenceDocOne

void setPurchaseOrderItemReferenceDocOne(PurchaseOrderItemPK pk,
                                         java.lang.String referenceDoc)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

setPurchaseOrderItemReferenceDocTwo

void setPurchaseOrderItemReferenceDocTwo(PurchaseOrderItemPK pk,
                                         java.lang.String referenceDoc)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

clearPurchaseOrderItemReferenceDocOne

void clearPurchaseOrderItemReferenceDocOne(java.lang.String referenceDoc)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

clearPurchaseOrderItemReferenceDocTwo

void clearPurchaseOrderItemReferenceDocTwo(java.lang.String referenceDoc)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

clearAllReferenceDocOnesToPurchaseOrderItem

void clearAllReferenceDocOnesToPurchaseOrderItem(PurchaseOrderItemPK pk)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

clearAllReferenceDocTwoesToPurchaseOrderItem

void clearAllReferenceDocTwoesToPurchaseOrderItem(PurchaseOrderItemPK pk)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

findPastDuePurchaseOrderItems

java.util.Collection<PurchaseOrderOpenDueListResult> findPastDuePurchaseOrderItems(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPastDuePurchaseOrderItemCount

int getPastDuePurchaseOrderItemCount()
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findAllPurchaseOrderByAddressId

java.util.Collection<PurchaseOrderListResult> findAllPurchaseOrderByAddressId(java.lang.String addressId,
                                                                              int firstIndex,
                                                                              int maxLength)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getAllPurchaseOrderCountByAddressId

int getAllPurchaseOrderCountByAddressId(java.lang.String addressId)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findOpenPurchaseOrderByAddressId

java.util.Collection<PurchaseOrderListResult> findOpenPurchaseOrderByAddressId(java.lang.String addressId,
                                                                               int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getOpenPurchaseOrderCountByAddressId

int getOpenPurchaseOrderCountByAddressId(java.lang.String addressId)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

addPurchaseOrderApproval

PurchaseOrderApprovalVO addPurchaseOrderApproval(java.lang.String approvalUserName)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

updatePurchaseOrderApproval

PurchaseOrderApprovalVO updatePurchaseOrderApproval(PurchaseOrderApprovalVO purApprovalVO)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

deletePurchaseOrderApproval

void deletePurchaseOrderApproval(java.lang.String employeeId)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderApprovalByUserNumber

PurchaseOrderApprovalVO getPurchaseOrderApprovalByUserNumber(java.lang.String userName)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderApprovalByEmployeeId

PurchaseOrderApprovalVO getPurchaseOrderApprovalByEmployeeId(java.lang.String employeeId)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

isPurchaseOrderApprovalExistent

boolean isPurchaseOrderApprovalExistent(java.lang.String approvalUserName)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findAllPurchaseOrderApprovals

java.util.Collection<PurchaseOrderApprovalVO> findAllPurchaseOrderApprovals(int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getAllPurchaseOrderApprovalsCount

int getAllPurchaseOrderApprovalsCount()
                                      throws java.lang.Exception
Throws:
java.lang.Exception

addRequestForQuote

RequestForQuoteVO addRequestForQuote(java.lang.String vendorId)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

updateRequestForQuote

RequestForQuoteVO updateRequestForQuote(RequestForQuoteVO rfqVO)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

approveRequestForQuote

RequestForQuoteVO approveRequestForQuote(RequestForQuoteVO rfqVo)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

approveRequestForQuote

RequestForQuoteVO approveRequestForQuote(java.lang.String rfqNumber)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

deleteRequestForQuote

void deleteRequestForQuote(RequestForQuoteVO rfqVO)
                           throws java.lang.Exception
Throws:
java.lang.Exception

isRequestForQuoteExistent

boolean isRequestForQuoteExistent(java.lang.String requestForQuoteNumber)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

getRequestForQuoteStatus

java.lang.String getRequestForQuoteStatus(java.lang.String requestForQuoteNumber)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

isRequestForQuoteOPEN

boolean isRequestForQuoteOPEN(java.lang.String requestForQuoteNumber)
                              throws java.lang.Exception
Throws:
java.lang.Exception

findRequestForQuoteItemListResults

java.util.Collection<RequestForQuoteItemListResult> findRequestForQuoteItemListResults(java.lang.String partNumberLike,
                                                                                java.lang.String partType,
                                                                                java.lang.String status,
                                                                                boolean isDue,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getRequestForQuoteItemListResultsCount

int getRequestForQuoteItemListResultsCount(java.lang.String partNumberLike,
                                           java.lang.String partType,
                                           java.lang.String status,
                                           boolean isDue)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

findRequestForQuoteItemListResults

java.util.Collection<RequestForQuoteItemListResult> findRequestForQuoteItemListResults(java.lang.String partNumberLike,
                                                                                java.lang.String partType,
                                                                                java.lang.String status,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getRequestForQuoteItemListResultsCount

int getRequestForQuoteItemListResultsCount(java.lang.String partNumberLike,
                                           java.lang.String partType,
                                           java.lang.String status)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

findRequestForQuoteItemListResultsByPartNumberLike

java.util.Collection<RequestForQuoteItemListResult> findRequestForQuoteItemListResultsByPartNumberLike(java.lang.String partNumberLike,
                                                                                java.lang.String partType,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getRequestForQuoteItemListResultsCountByPartNumberLike

int getRequestForQuoteItemListResultsCountByPartNumberLike(java.lang.String partNumberLike,
                                                           java.lang.String partType)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

findOpenRequestForQuoteItemListResults

java.util.Collection<RequestForQuoteItemListResult> findOpenRequestForQuoteItemListResults(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOpenRequestForQuoteItemListResultsCount

int getOpenRequestForQuoteItemListResultsCount()
                                               throws java.lang.Exception
Throws:
java.lang.Exception

findDueRequestForQuoteItemListResults

java.util.Collection<RequestForQuoteItemListResult> findDueRequestForQuoteItemListResults(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getDueRequestForQuoteItemListResultsCount

int getDueRequestForQuoteItemListResultsCount()
                                              throws java.lang.Exception
Throws:
java.lang.Exception

initRequestForQuoteItemForTool

RequestForQuoteItemVO initRequestForQuoteItemForTool(java.lang.String requestForQuoteNumber,
                                                     java.lang.String itemNum,
                                                     PartPK partPk,
                                                     java.math.BigDecimal qty,
                                                     java.lang.String languageCode)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getRequestForQuoteByRfqNumber

RequestForQuoteVO getRequestForQuoteByRfqNumber(java.lang.String rfqNumber)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

findRequestForQuoteListResults

java.util.Collection<RequestForQuoteListResult> findRequestForQuoteListResults(java.lang.String rfqNumber,
                                                                               java.lang.String status,
                                                                               java.lang.String vendId,
                                                                               int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getRequestForQuoteListResultsCount

int getRequestForQuoteListResultsCount(java.lang.String rfqNumber,
                                       java.lang.String status,
                                       java.lang.String vendId)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findRequestForQuoteListResultsByRfqNumber

java.util.Collection<RequestForQuoteListResult> findRequestForQuoteListResultsByRfqNumber(java.lang.String rfqNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getRequestForQuoteListResultsCountByRfqNumber

int getRequestForQuoteListResultsCountByRfqNumber(java.lang.String rfqNumber)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

findRequestForQuoteListResultsByVendorId

java.util.Collection<RequestForQuoteListResult> findRequestForQuoteListResultsByVendorId(java.lang.String vendorId,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getRequestForQuoteListResultsCountByVendorId

int getRequestForQuoteListResultsCountByVendorId(java.lang.String vendorId)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findReturnToVendorItemListResults

java.util.Collection<ReturnToVendorItemListResult> findReturnToVendorItemListResults(java.lang.String partNumberLike,
                                                                                java.lang.String partType,
                                                                                java.lang.String status,
                                                                                boolean isDue,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getReturnToVendorItemListResultsCount

int getReturnToVendorItemListResultsCount(java.lang.String partNumberLike,
                                          java.lang.String partType,
                                          java.lang.String status,
                                          boolean isDue)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

findReturnToVendorItemListResults

java.util.Collection<ReturnToVendorItemListResult> findReturnToVendorItemListResults(java.lang.String partNumberLike,
                                                                                java.lang.String partType,
                                                                                java.lang.String status,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getReturnToVendorItemListResultsCount

int getReturnToVendorItemListResultsCount(java.lang.String partNumberLike,
                                          java.lang.String partType,
                                          java.lang.String status)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

findReturnToVendorItemListResultsByPartNumberLike

java.util.Collection<ReturnToVendorItemListResult> findReturnToVendorItemListResultsByPartNumberLike(java.lang.String partNumberLike,
                                                                                java.lang.String partType,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getReturnToVendorItemListResultsCountByPartNumberLike

int getReturnToVendorItemListResultsCountByPartNumberLike(java.lang.String partNumberLike,
                                                          java.lang.String partType)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

findOpenReturnToVendorItemListResults

java.util.Collection<ReturnToVendorItemListResult> findOpenReturnToVendorItemListResults(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOpenReturnToVendorItemListResultsCount

int getOpenReturnToVendorItemListResultsCount()
                                              throws java.lang.Exception
Throws:
java.lang.Exception

findDueReturnToVendorItemListResults

java.util.Collection<ReturnToVendorItemListResult> findDueReturnToVendorItemListResults(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getDueReturnToVendorItemListResultsCount

int getDueReturnToVendorItemListResultsCount()
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findAllRfqCheckListResults

java.util.Collection<RequestForQuoteCheckListResult> findAllRfqCheckListResults(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllRfqCheckListResultsCount

int getAllRfqCheckListResultsCount()
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findRfqCheckListResults

java.util.Collection<RequestForQuoteCheckListResult> findRfqCheckListResults(java.lang.String startWith,
                                                                             int firstIndex,
                                                                             int maxLength)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getRfqCheckListResultsCount

int getRfqCheckListResultsCount(java.lang.String startWith)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findReturnToVendorListResults

java.util.Collection<ReturnToVendorListResult> findReturnToVendorListResults(java.lang.String rtvNumber,
                                                                             java.lang.String status,
                                                                             java.lang.String vendId,
                                                                             int firstIndex,
                                                                             int maxLength)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getReturnToVendorListResultsCount

int getReturnToVendorListResultsCount(java.lang.String rtvNumber,
                                      java.lang.String status,
                                      java.lang.String vendId)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findReturnToVendorListResultsByRtvNumber

java.util.Collection<ReturnToVendorListResult> findReturnToVendorListResultsByRtvNumber(java.lang.String rtvNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getReturnToVendorListResultsCountByRtvNumber

int getReturnToVendorListResultsCountByRtvNumber(java.lang.String rtvNumber)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findReturnToVendorListResultsByVendorId

java.util.Collection<ReturnToVendorListResult> findReturnToVendorListResultsByVendorId(java.lang.String vendorId,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getReturnToVendorListResultsCountByVendorId

int getReturnToVendorListResultsCountByVendorId(java.lang.String vendorId)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

findAllRtvCheckListResults

java.util.Collection<ReturnToVendorCheckListResult> findAllRtvCheckListResults(int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getAllRtvCheckListResultsCount

int getAllRtvCheckListResultsCount()
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findRtvCheckListResults

java.util.Collection<ReturnToVendorCheckListResult> findRtvCheckListResults(java.lang.String startWith,
                                                                            int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getRtvCheckListResultsCount

int getRtvCheckListResultsCount(java.lang.String startWith)
                                throws java.lang.Exception
Throws:
java.lang.Exception

addReturnToVendor

ReturnToVendorVO addReturnToVendor(java.lang.String vendorID)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

updateReturnToVendor

ReturnToVendorVO updateReturnToVendor(ReturnToVendorVO rtvVO)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

approveReturnToVendor

ReturnToVendorVO approveReturnToVendor(ReturnToVendorVO rtvVO)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

approveReturnToVendor

ReturnToVendorVO approveReturnToVendor(java.lang.String rtvNumber)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

deleteReturnToVendor

void deleteReturnToVendor(ReturnToVendorVO rtvVO)
                          throws java.lang.Exception
Throws:
java.lang.Exception

isReturnToVendorExistent

boolean isReturnToVendorExistent(java.lang.String returnToVendorNumber)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

getReturnToVendorStatus

java.lang.String getReturnToVendorStatus(java.lang.String returnToVendorNumber)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

getReturnToVendorByRtvNumber

ReturnToVendorVO getReturnToVendorByRtvNumber(java.lang.String rtvNumber)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

initReturnToVendorItemForPart

ReturnToVendorItemVO initReturnToVendorItemForPart(java.lang.String rtvNumber,
                                                   java.lang.String itemNum,
                                                   PartPK partPk,
                                                   java.math.BigDecimal qty)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

initReturnToVendorItemForTool

ReturnToVendorItemVO initReturnToVendorItemForTool(java.lang.String rtvNumber,
                                                   java.lang.String itemNum,
                                                   PartPK partPk,
                                                   java.math.BigDecimal qty)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getMrpResult

BB2PartMrpResult getMrpResult(BB2Part part)
                              throws java.lang.Exception
Throws:
java.lang.Exception

addPurchaseWorkSheet

PurchaseWorkSheetVO addPurchaseWorkSheet()
                                         throws java.lang.Exception
Throws:
java.lang.Exception

addPurchaseWorkSheet

PurchaseWorkSheetVO addPurchaseWorkSheet(PurchaseWorkSheetVO pwsVO)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

updatePurchaseWorkSheet

PurchaseWorkSheetVO updatePurchaseWorkSheet(PurchaseWorkSheetVO pwsVO)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

deletePurchaseWorkSheet

void deletePurchaseWorkSheet(PurchaseWorkSheetVO pwsVO)
                             throws java.lang.Exception
Throws:
java.lang.Exception

isPurchaseWorkSheetExistent

boolean isPurchaseWorkSheetExistent(PurchaseWorkSheetPK pk)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseWorkSheetByPk

PurchaseWorkSheetVO getPurchaseWorkSheetByPk(PurchaseWorkSheetPK pk)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

makePurchaseOrders

java.util.Collection<PurchaseOrderListResult> makePurchaseOrders(PurchaseWorkSheetVO pwsVO)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

makeRequestForQuotes

java.util.Collection<RequestForQuoteListResult> makeRequestForQuotes(PurchaseWorkSheetVO pwsVO)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

findAllPurchaseWorkSheet

java.util.Collection<PurchaseWorkSheetVO> findAllPurchaseWorkSheet(int firstIndex,
                                                                   int maxLength)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getAllPurchaseWorkSheetCount

int getAllPurchaseWorkSheetCount()
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findMyPurchaseWorkSheet

java.util.Collection<PurchaseWorkSheetVO> findMyPurchaseWorkSheet(int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getMyPurchaseWorkSheetByCount

int getMyPurchaseWorkSheetByCount()
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findPurchaseWorkSheetByEmployeeId

java.util.Collection<PurchaseWorkSheetVO> findPurchaseWorkSheetByEmployeeId(java.lang.String employeeId,
                                                                            boolean isMfrPurchaseWorkSheet,
                                                                            int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseWorkSheetByCountByEmployeeId

int getPurchaseWorkSheetByCountByEmployeeId(java.lang.String employeeId)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

findPurchaseWorkSheetByEmployeeEmailLike

java.util.Collection<PurchaseWorkSheetVO> findPurchaseWorkSheetByEmployeeEmailLike(java.lang.String employeeEmailLike,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseWorkSheetCountByEmployeeEmailLike

int getPurchaseWorkSheetCountByEmployeeEmailLike(java.lang.String employeeEmailLike)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

initPurchaseWorkSheetItemForTool

PurchaseWorkSheetItemWithRelatedInfoResult initPurchaseWorkSheetItemForTool(PurchaseWorkSheetPK pk,
                                                                            java.lang.String itemNum,
                                                                            PartPK partPk,
                                                                            java.math.BigDecimal qty)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

findJobProcessSheetListResultsByLookup

java.util.Collection<JobProcessSheetListResult> findJobProcessSheetListResultsByLookup(java.lang.String woNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getJobProcessSheetListResultsCountByLookup

int getJobProcessSheetListResultsCountByLookup(java.lang.String woNumber)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

findJobProcessSheetListResults

java.util.Collection<JobProcessSheetListResult> findJobProcessSheetListResults(java.lang.String woNumberLike,
                                                                               int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getJobProcessSheetListResultsCount

int getJobProcessSheetListResultsCount(java.lang.String woNumberLike)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

getJobProcessSheetResult

JobProcessSheetResult getJobProcessSheetResult(PartPK partPk,
                                               boolean isTool,
                                               java.lang.String setId)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

getWorkInstructionSummaryResult

WorkInstructionSummaryResult getWorkInstructionSummaryResult(BB2Part part,
                                                             java.lang.String setId)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

findWorkInstructionSeqAuditListResults

java.util.Collection<WorkInstructionSeqAuditListResult> findWorkInstructionSeqAuditListResults(java.lang.String pnLike,
                                                                                java.lang.String partType,
                                                                                java.lang.String setId,
                                                                                java.lang.String seqNum,
                                                                                java.lang.String wcLike,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getWorkInstructionSeqAuditListResultsCount

int getWorkInstructionSeqAuditListResultsCount(java.lang.String pnLike,
                                               java.lang.String partType,
                                               java.lang.String setId,
                                               java.lang.String seqNum,
                                               java.lang.String wcLike)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

findWorkInstructionSeqAuditListResults

java.util.Collection<WorkInstructionSeqAuditListResult> findWorkInstructionSeqAuditListResults(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getWorkInstructionSeqAuditListResultsCount

int getWorkInstructionSeqAuditListResultsCount()
                                               throws java.lang.Exception
Throws:
java.lang.Exception

getWorkCenterRunTimeTotalResult

WorkCenterRunTimeTotalResult getWorkCenterRunTimeTotalResult(WorkCenterRunTimeAgent agent)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

findWorkCenterRunTimeListResults

java.util.Collection<WorkCenterRunTimeListResult> findWorkCenterRunTimeListResults(WorkCenterRunTimeAgent agent,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getWorkCenterRunTimeListResultsCount

int getWorkCenterRunTimeListResultsCount(WorkCenterRunTimeAgent agent)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderItemWCLoadResults

java.util.Collection<WorkOrderItemWCLoadResult> getWorkOrderItemWCLoadResults(WorkCenterAgent agent)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

addWorkCalendar

WorkCalendarVO addWorkCalendar(WorkCalendarVO vo)
                               throws java.lang.Exception
Throws:
java.lang.Exception

updateWorkCalendar

WorkCalendarVO updateWorkCalendar(WorkCalendarVO vo)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

deleteWorkCalendar

void deleteWorkCalendar(WorkCalendarVO vo)
                        throws java.lang.Exception
Throws:
java.lang.Exception

deleteCertainWorkCalendar

void deleteCertainWorkCalendar(java.util.Set<java.lang.Long> set)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getWorkCalendarByPK

WorkCalendarVO getWorkCalendarByPK(java.lang.Long workDate)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findAllWorkCalendar

java.util.Collection<WorkCalendarVO> findAllWorkCalendar(java.util.Date dateFrom,
                                                         java.util.Date dateTo,
                                                         int work,
                                                         int firstIndex,
                                                         int maxLength)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getAllWorkCalendar

int getAllWorkCalendar(java.util.Date dateFrom,
                       java.util.Date dateTo,
                       int work)
                       throws java.lang.Exception
Throws:
java.lang.Exception

isWorkCalendarExist

boolean isWorkCalendarExist(java.lang.Long workDate)
                            throws java.lang.Exception
Throws:
java.lang.Exception

addOperatingInstructionsType

OperatingInstructionsTypeVO addOperatingInstructionsType(OperatingInstructionsTypeVO vo)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

updateOperatingInstructionsType

void updateOperatingInstructionsType(OperatingInstructionsTypeVO vo)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

getOperatingInstructionsType

OperatingInstructionsTypeVO getOperatingInstructionsType(int ii)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

isOperatingInstructionsTypeExist

boolean isOperatingInstructionsTypeExist(int ii)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

deleteOperatingInstructionsType

void deleteOperatingInstructionsType(int ii)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findAllOperatingInstructionsType

java.util.Collection<OperatingInstructionsTypeVO> findAllOperatingInstructionsType(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllOperatingInstructionsTypeCount

int getAllOperatingInstructionsTypeCount()
                                         throws java.lang.Exception
Throws:
java.lang.Exception

addOperatingInstructionsManual

OperatingInstructionsManualVO addOperatingInstructionsManual(OperatingInstructionsManualVO vo)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

updateOperatingInstructionsManual

void updateOperatingInstructionsManual(OperatingInstructionsManualVO vo)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

getOperatingInstructionsManual

OperatingInstructionsManualVO getOperatingInstructionsManual(int ii)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

isOperatingInstructionsManualExist

boolean isOperatingInstructionsManualExist(int ii)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

deleteOperatingInstructionsManual

void deleteOperatingInstructionsManual(int ii)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findAllOperatingInstructionsManual

java.util.Collection<OperatingInstructionsManualVO> findAllOperatingInstructionsManual(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllOperatingInstructionsManualCount

int getAllOperatingInstructionsManualCount()
                                           throws java.lang.Exception
Throws:
java.lang.Exception

addOperatingOutputFileType

OperatingOutputFileTypeVO addOperatingOutputFileType(OperatingOutputFileTypeVO vo)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

updateOperatingOutputFileType

void updateOperatingOutputFileType(OperatingOutputFileTypeVO vo)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

getOperatingOutputFileType

OperatingOutputFileTypeVO getOperatingOutputFileType(int ii)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

isOperatingOutputFileTypeExist

boolean isOperatingOutputFileTypeExist(int ii)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

deleteOperatingOutputFileType

void deleteOperatingOutputFileType(int ii)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findAllOperatingOutputFileType

java.util.Collection<OperatingOutputFileTypeVO> findAllOperatingOutputFileType(int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getAllOperatingOutputFileTypeCount

int getAllOperatingOutputFileTypeCount()
                                       throws java.lang.Exception
Throws:
java.lang.Exception

addOperatingInstructionsInspectStandard

OperatingInstructionsInspectStandardVO addOperatingInstructionsInspectStandard(OperatingInstructionsInspectStandardVO vo)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

updateOperatingInstructionsInspectStandard

void updateOperatingInstructionsInspectStandard(OperatingInstructionsInspectStandardVO vo)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOperatingInstructionsInspectStandard

OperatingInstructionsInspectStandardVO getOperatingInstructionsInspectStandard(int ii)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

isOperatingInstructionsInspectStandardExist

boolean isOperatingInstructionsInspectStandardExist(int ii)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

deleteOperatingInstructionsInspectStandard

void deleteOperatingInstructionsInspectStandard(int ii)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

findAllOperatingInstructionsInspectStandard

java.util.Collection<OperatingInstructionsInspectStandardVO> findAllOperatingInstructionsInspectStandard(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllOperatingInstructionsInspectStandardCount

int getAllOperatingInstructionsInspectStandardCount()
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

addInspectionReportInspectMethod

InspectionReportInspectMethodVO addInspectionReportInspectMethod(InspectionReportInspectMethodVO vo)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

updateInspectionReportInspectMethod

void updateInspectionReportInspectMethod(InspectionReportInspectMethodVO vo)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

getInspectionReportInspectMethod

InspectionReportInspectMethodVO getInspectionReportInspectMethod(int ii)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

isInspectionReportInspectMethodExist

boolean isInspectionReportInspectMethodExist(int ii)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

deleteInspectionReportInspectMethod

void deleteInspectionReportInspectMethod(int ii)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

findAllInspectionReportInspectMethod

java.util.Collection<InspectionReportInspectMethodVO> findAllInspectionReportInspectMethod(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllInspectionReportInspectMethodCount

int getAllInspectionReportInspectMethodCount()
                                             throws java.lang.Exception
Throws:
java.lang.Exception

addInspectionItem

InspectionItemVO addInspectionItem(InspectionItemVO vo)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

updateInspectionItem

void updateInspectionItem(InspectionItemVO vo)
                          throws java.lang.Exception
Throws:
java.lang.Exception

getInspectionItem

InspectionItemVO getInspectionItem(InspectionItemPK pk)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

isInspectionItemExist

boolean isInspectionItemExist(InspectionItemPK pk)
                              throws java.lang.Exception
Throws:
java.lang.Exception

deleteInspectionItem

void deleteInspectionItem(InspectionItemPK pk)
                          throws java.lang.Exception
Throws:
java.lang.Exception

findAllInspectionItem

java.util.Collection<InspectionItemVO> findAllInspectionItem(int operatingInstructionsTypeId,
                                                             int firstIndex,
                                                             int maxLength)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getAllInspectionItemCount

int getAllInspectionItemCount(int operatingInstructionsTypeId)
                              throws java.lang.Exception
Throws:
java.lang.Exception

addInspectionReport

InspectionReportVO addInspectionReport(InspectionReportVO vo)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

updateInspectionReport

void updateInspectionReport(InspectionReportVO vo)
                            throws java.lang.Exception
Throws:
java.lang.Exception

getInspectionReport

InspectionReportVO getInspectionReport(java.lang.String inspectionReportNumber)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

isInspectionReportExist

boolean isInspectionReportExist(java.lang.String inspectionReportNumber)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findInspectionReport

java.util.Collection<InspectionReportInfoVO> findInspectionReport(java.lang.String irNumber,
                                                                  java.lang.String oiNumber,
                                                                  int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getInspectionReportCount

int getInspectionReportCount(java.lang.String irNumber,
                             java.lang.String oiNumber)
                             throws java.lang.Exception
Throws:
java.lang.Exception

addOperatingInstructions

OperatingInstructionsVO addOperatingInstructions(OperatingInstructionsVO vo)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

updateOperatingInstructions

void updateOperatingInstructions(OperatingInstructionsVO vo)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

getOperatingInstructions

OperatingInstructionsVO getOperatingInstructions(java.lang.String operatingInstructionsNumber)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

deleteOperatingInstructions

void deleteOperatingInstructions(java.lang.String operatingInstructionsNumber)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

isOperatingInstructionsExist

boolean isOperatingInstructionsExist(java.lang.String operatingInstructionsNumber)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findOperatingInstructions

java.util.Collection<OperatingInstructionsVO> findOperatingInstructions(java.lang.String oiNumber,
                                                                        java.lang.String woAndItemNumber,
                                                                        java.lang.String type,
                                                                        java.lang.String responsibility,
                                                                        java.lang.String project,
                                                                        java.lang.String serial,
                                                                        java.lang.String staff,
                                                                        java.lang.String status,
                                                                        java.lang.String irNumber,
                                                                        int firstIndex,
                                                                        int maxLength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getOperatingInstructionsCount

int getOperatingInstructionsCount(java.lang.String oiNumber,
                                  java.lang.String woAndItemNumber,
                                  java.lang.String type,
                                  java.lang.String responsibility,
                                  java.lang.String project,
                                  java.lang.String serial,
                                  java.lang.String staff,
                                  java.lang.String status,
                                  java.lang.String irNumber)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findNotApprovedOperatingInstructions

java.util.Collection<OperatingInstructionsVO> findNotApprovedOperatingInstructions(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getNotApprovedOperatingInstructionsCount

int getNotApprovedOperatingInstructionsCount()
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findOpenOperatingInstructions

java.util.Collection<OperatingInstructionsVO> findOpenOperatingInstructions(int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getOpenOperatingInstructionsCount

int getOpenOperatingInstructionsCount()
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findPausedOperatingInstructions

java.util.Collection<OperatingInstructionsVO> findPausedOperatingInstructions(int firstIndex,
                                                                              int maxLength)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getPausedOperatingInstructionsCount

int getPausedOperatingInstructionsCount()
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findRequestInspectionOperatingInstructions

java.util.Collection<OperatingInstructionsVO> findRequestInspectionOperatingInstructions(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getRequestInspectionOperatingInstructionsCount

int getRequestInspectionOperatingInstructionsCount()
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

changeOperatingInstructionsStatusToCancel

void changeOperatingInstructionsStatusToCancel(OperatingInstructionsVO vo)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

findOperatingInstructionsCanClose

java.util.Collection<OperatingInstructionsVO> findOperatingInstructionsCanClose(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOperatingInstructionsCanCloseCount

int getOperatingInstructionsCanCloseCount()
                                          throws java.lang.Exception
Throws:
java.lang.Exception

approveOperatingInstructions

void approveOperatingInstructions(OperatingInstructionsVO vo)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

pauseOperatingInstructions

void pauseOperatingInstructions(OperatingInstructionsVO vo)
                                throws java.lang.Exception
Throws:
java.lang.Exception

continueOperatingInstructions

void continueOperatingInstructions(OperatingInstructionsVO vo)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

finishOperatingInstructions

void finishOperatingInstructions(OperatingInstructionsVO vo)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

cancelFinishOperatingInstructions

void cancelFinishOperatingInstructions(OperatingInstructionsVO vo)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

requestInspectionForOperatingInstructions

void requestInspectionForOperatingInstructions(OperatingInstructionsVO vo)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

closeOperatingInstructions

void closeOperatingInstructions(OperatingInstructionsVO vo)
                                throws java.lang.Exception
Throws:
java.lang.Exception

reverseRelatedInspectorSign

void reverseRelatedInspectorSign(java.lang.String operatingInstructionsNumber,
                                 java.lang.String relatedInspectorSign)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

reverseStaffSign

void reverseStaffSign(java.lang.String operatingInstructionsNumber,
                      java.lang.String staffSign)
                      throws java.lang.Exception
Throws:
java.lang.Exception

reverseResultSign

void reverseResultSign(java.lang.String operatingInstructionsNumber)
                       throws java.lang.Exception
Throws:
java.lang.Exception

updateDefaultStatus

void updateDefaultStatus(WorkInstructionVO vo)
                         throws java.lang.Exception
Throws:
java.lang.Exception

getDefaultWISetId

java.lang.String getDefaultWISetId(BB2Part part)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

uploadOrUpdateOnloanDoc

java.util.Collection<OnloanDocumentVO> uploadOrUpdateOnloanDoc(MiscDocAgent agent)
                                                               throws java.lang.Exception
Throws:
java.lang.Exception

downloadOnloanDoc

BB2File downloadOnloanDoc(MiscDocAgent agent)
                          throws java.lang.Exception
Throws:
java.lang.Exception

deleteOnloanDoc

java.util.Collection<OnloanDocumentVO> deleteOnloanDoc(MiscDocAgent agent)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getOIPrincipal

OIPrincipalVO getOIPrincipal()
                             throws java.lang.Exception
Throws:
java.lang.Exception

updateOIPrincipal

void updateOIPrincipal(OIPrincipalVO vo)
                       throws java.lang.Exception
Throws:
java.lang.Exception

addOIPrincipal

OIPrincipalVO addOIPrincipal(OIPrincipalVO vo)
                             throws java.lang.Exception
Throws:
java.lang.Exception

getOnloanDocumentByID

OnloanDocumentVO getOnloanDocumentByID(java.lang.Long controlNumber)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findOperatingInstructionsUserStatistical

java.util.Collection<OperatingInstructionsVO> findOperatingInstructionsUserStatistical(java.lang.String userName,
                                                                                java.lang.String type,
                                                                                java.lang.String responsibility,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOperatingInstructionsUserStatisticalCount

int getOperatingInstructionsUserStatisticalCount(java.lang.String userName,
                                                 java.lang.String type,
                                                 java.lang.String responsibility)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

updateInactiveTool

void updateInactiveTool(PartPK pk,
                        boolean inactive)
                        throws java.lang.Exception
Throws:
java.lang.Exception

getManufacturerEngineeringChangesCountByPart

int getManufacturerEngineeringChangesCountByPart(PartPK partPk)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findManufacturerEngineeringChangeByPart

java.util.Collection<EngineeringChangeListResult> findManufacturerEngineeringChangeByPart(PartPK partPk,
                                                                                java.lang.String languageFlag,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MasterWorkOrderTreeItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class MasterWorkOrderTreeItemResult

java.lang.Object
    extended by  bb.common.PartBasicInfo
        extended by  bb.common.BillItemWithPartInfoResult
            extended by  bb.common.BillItemOnHandWithPartInfoResult
                extended by  bb.common.MasterWorkOrderTreeItemResult
All Implemented Interfaces:
java.io.Serializable
public class MasterWorkOrderTreeItemResult
extends BillItemOnHandWithPartInfoResult
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
Fields inherited from class bb.common.PartBasicInfo
ORDER_BY_BILL, ORDER_BY_BUYERCODE, ORDER_BY_COMMODITYCODE, ORDER_BY_DESCRIPTION, ORDER_BY_DRAWING, ORDER_BY_HOLD, ORDER_BY_LASTCHANGEDATE, ORDER_BY_LASTUSER, ORDER_BY_MAKEBUY, ORDER_BY_MODELNUMBER, ORDER_BY_ORGANIZATION, ORDER_BY_ORIGIN, ORDER_BY_PARTNUMBER, ORDER_BY_PARTTYPE, ORDER_BY_PARTUNIT, ORDER_BY_PRODUCTCODE, ORDER_BY_SECURITYLEVEL, ORDER_BY_WEIGHT
Constructor Summary
MasterWorkOrderTreeItemResult()
MasterWorkOrderTreeItemResult(BillItemOnHandWithPartInfoResult superResult)
Method Summary
java.math.BigDecimal | getIssuedQty()
java.math.BigDecimal | getOrderQty()
java.math.BigDecimal | getSetupQty()
boolean | isAlreadySetup()
boolean | isOrphan()
void | setAlreadySetup(boolean alreadySetup)
void | setIssuedQty(java.math.BigDecimal issuedQty)
void | setOrderQty(java.math.BigDecimal orderQty)
void | setOrphan(boolean orphan)
void | setSetupQty(java.math.BigDecimal setupQty)
Methods inherited from class bb.common.BillItemOnHandWithPartInfoResult
getInSip, getInSit, getInWip, getOndemand, getOnhand, getOnhandLocation, getOnorder, setInSip, setInSit, setInWip, setOndemand, setOnhand, setOnhandLocation, setOnorder
Methods inherited from class bb.common.BillItemWithPartInfoResult
equals, getAsmSequenceNo, getBillItemPk, getBillItemReplacements, getComments, getEcnList, getKitNumber, getListPrice, getMultiQtyforApplying, getPartManufacturer, getPartQuantity, getScrapQty, getScrapRate, getSparePart, getTraceableLevel, hashCode, isBackflushMaterial, setAsmSequenceNo, setBackflushMaterial, setBillItemPk, setBillItemReplacements, setComments, setEcnList, setKitNumber, setListPrice, setMultiQtyforApplying, setPartManufacturer, setPartQuantity, setScrapQty, setScrapRate, setSparePart, setTraceableLevel, toString
Methods inherited from class bb.common.PartBasicInfo
getBill, getBuyerCode, getCommodityCode, getCountryOrigin, getDescription, getDetectionStandard, getDrawing, getEngGroup, getHavePicture, getHold, getLastChangeDate, getLastUser, getLeadTime, getMakeBuy, getMaterial, getModelNumber, getOrigin, getPartPk, getPartUnit, getProductCode, getRevision, getSaleable, getSalesDrawing, getSecurityLevel, getTraceable, getVolume, getVolumeUnit, getWeight, getWeightUnit, getWi, setBill, setBuyerCode, setCommodityCode, setCountryOrigin, setDescription, setDetectionStandard, setDrawing, setEngGroup, setHavePicture, setHold, setLastChangeDate, setLastUser, setLeadTime, setMakeBuy, setMaterial, setModelNumber, setOrigin, setPartPk, setPartUnit, setProductCode, setRevision, setSaleable, setSalesDrawing, setSecurityLevel, setTraceable, setVolume, setVolumeUnit, setWeight, setWeightUnit, setWi
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

MasterWorkOrderTreeItemResult

public MasterWorkOrderTreeItemResult()

MasterWorkOrderTreeItemResult

public MasterWorkOrderTreeItemResult(BillItemOnHandWithPartInfoResult superResult)
Method Detail

isAlreadySetup

public boolean isAlreadySetup()

setAlreadySetup

public void setAlreadySetup(boolean alreadySetup)

getOrderQty

public java.math.BigDecimal getOrderQty()

setOrderQty

public void setOrderQty(java.math.BigDecimal orderQty)

getSetupQty

public java.math.BigDecimal getSetupQty()

setSetupQty

public void setSetupQty(java.math.BigDecimal setupQty)

getIssuedQty

public java.math.BigDecimal getIssuedQty()

setIssuedQty

public void setIssuedQty(java.math.BigDecimal issuedQty)

isOrphan

public boolean isOrphan()

setOrphan

public void setOrphan(boolean orphan)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MessageAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class MessageAgent

java.lang.Object
    extended by  bb.common.MessageAgent
All Implemented Interfaces:
java.io.Serializable
public class MessageAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
MessageAgent()
Method Summary
java.lang.String | getContext()
java.lang.String | getReceivers()
java.lang.Long | getRefId()
java.lang.String | getSubject()
void | setContext(java.lang.String context)
void | setReceivers(java.lang.String receivers)
void | setRefId(java.lang.Long refId)
void | setSubject(java.lang.String subject)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MessageAgent

public MessageAgent()
Method Detail

getContext

public java.lang.String getContext()

setContext

public void setContext(java.lang.String context)

getSubject

public java.lang.String getSubject()

setSubject

public void setSubject(java.lang.String subject)

getReceivers

public java.lang.String getReceivers()

setReceivers

public void setReceivers(java.lang.String receivers)

getRefId

public java.lang.Long getRefId()

setRefId

public void setRefId(java.lang.Long refId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MessageVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class MessageVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.MessageVO
All Implemented Interfaces:
java.io.Serializable
public class MessageVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_RECEIVER
static java.lang.String | ORDER_BY_REFID
static java.lang.String | ORDER_BY_SENDDATE
static java.lang.String | ORDER_BY_SENDFROM
static java.lang.String | ORDER_BY_SENDUSERNAME
static java.lang.String | ORDER_BY_SUBJECT
static int | STATUS_READ
static int | STATUS_REMOVED
static int | STATUS_UNREAD
Constructor Summary
MessageVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAllReceiver()
java.lang.String | getContext()
java.lang.Long | getId()
java.lang.String | getReceiver()
java.lang.String | getReceiverUserName()
java.lang.Long | getRefId()
java.util.Date | getSendDate()
java.lang.String | getSendFrom()
java.lang.String | getSendUsername()
java.lang.String | getStatus()
java.lang.String | getSubject()
int | hashCode()
boolean | isRead(java.lang.String userName)
boolean | isRemoved()
void | read(java.lang.String userName)
void | setAllReceiver(java.lang.String allReceiver)
void | setContext(java.lang.String context)
void | setId(java.lang.Long id)
void | setReceiver(java.lang.String receiver)
void | setReceiverUserName(java.lang.String receiverUserName)
void | setRefId(java.lang.Long refId)
void | setRemoved(boolean removed)
void | setSendDate(java.util.Date sendDate)
void | setSendFrom(java.lang.String sendFrom)
void | setSendUsername(java.lang.String sendUsername)
void | setStatus(java.lang.String status)
void | setSubject(java.lang.String subject)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

STATUS_READ

public static final int STATUS_READ
See Also:
Constant Field Values

STATUS_UNREAD

public static final int STATUS_UNREAD
See Also:
Constant Field Values

STATUS_REMOVED

public static final int STATUS_REMOVED
See Also:
Constant Field Values

ORDER_BY_RECEIVER

public static final java.lang.String ORDER_BY_RECEIVER
See Also:
Constant Field Values

ORDER_BY_SENDUSERNAME

public static final java.lang.String ORDER_BY_SENDUSERNAME
See Also:
Constant Field Values

ORDER_BY_SUBJECT

public static final java.lang.String ORDER_BY_SUBJECT
See Also:
Constant Field Values

ORDER_BY_SENDFROM

public static final java.lang.String ORDER_BY_SENDFROM
See Also:
Constant Field Values

ORDER_BY_SENDDATE

public static final java.lang.String ORDER_BY_SENDDATE
See Also:
Constant Field Values

ORDER_BY_REFID

public static final java.lang.String ORDER_BY_REFID
See Also:
Constant Field Values
Constructor Detail

MessageVO

public MessageVO()
Method Detail

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getId

public java.lang.Long getId()

setId

public void setId(java.lang.Long id)

getSendFrom

public java.lang.String getSendFrom()

setSendFrom

public void setSendFrom(java.lang.String sendFrom)

getSendDate

public java.util.Date getSendDate()

setSendDate

public void setSendDate(java.util.Date sendDate)

getContext

public java.lang.String getContext()

setContext

public void setContext(java.lang.String context)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getRefId

public java.lang.Long getRefId()

setRefId

public void setRefId(java.lang.Long refId)

getSendUsername

public java.lang.String getSendUsername()

setSendUsername

public void setSendUsername(java.lang.String sendUsername)

getSubject

public java.lang.String getSubject()

setSubject

public void setSubject(java.lang.String subject)

getReceiver

public java.lang.String getReceiver()

setReceiver

public void setReceiver(java.lang.String receiver)

getAllReceiver

public java.lang.String getAllReceiver()

setAllReceiver

public void setAllReceiver(java.lang.String allReceiver)

getReceiverUserName

public java.lang.String getReceiverUserName()

setReceiverUserName

public void setReceiverUserName(java.lang.String receiverUserName)

isRead

public boolean isRead(java.lang.String userName)

read

public void read(java.lang.String userName)

isRemoved

public boolean isRemoved()

setRemoved

public void setRemoved(boolean removed)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MfrMpnListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class MfrMpnListResult

java.lang.Object
    extended by  bb.common.MfrMpnListResult
All Implemented Interfaces:
java.io.Serializable
public class MfrMpnListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
MfrMpnListResult(java.lang.String mfrName, java.lang.String mpn)
Method Summary
java.lang.String | getMfrName()
java.lang.String | getMpn()
void | setMfrName(java.lang.String mfrName)
void | setMpn(java.lang.String mpn)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MfrMpnListResult

public MfrMpnListResult(java.lang.String mfrName,
                        java.lang.String mpn)
Method Detail

getMfrName

public java.lang.String getMfrName()

getMpn

public java.lang.String getMpn()

setMfrName

public void setMfrName(java.lang.String mfrName)

setMpn

public void setMpn(java.lang.String mpn)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


M-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M N O P Q R S T U V W X Y Z

M

M - Static variable in class bb.common.Constant.TransactionType
M2 - Static variable in class bb.common.Constant.LoginType
MACHINE - Static variable in class bb.common.Constant.WorkCenterType
main(String[]) - Static method in class bb.common.BB2Zip
main(String[]) - Static method in class bb.common.Spiderman
MAINTENANCE - Static variable in class bb.common.Constant.EquipmentStatus
MAINTENANCE_ITEM - Static variable in class bb.common.BizTarget
MAINTENANCE_ITEM_ALREADY_EXIST - Static variable in class bb.common.BIZReason
MAINTENANCE_ITEM_NOT_EXIST - Static variable in class bb.common.BIZReason
MaintenanceItemPK - Class in bb.common
MaintenanceItemPK(String, Integer) - Constructor for class bb.common.MaintenanceItemPK
full constructor
MaintenanceItemPK() - Constructor for class bb.common.MaintenanceItemPK
default constructor
MaintenanceItemVO - Class in bb.common
MaintenanceItemVO() - Constructor for class bb.common.MaintenanceItemVO
MaintenanceWarningHrs - Static variable in class bb.common.Constant
Make - Static variable in class bb.common.Constant.MakeBuy
MAKE_CHECK - Static variable in class bb.common.BizTarget
MakeAccountPayableAgent - Class in bb.common
MakeAccountPayableAgent() - Constructor for class bb.common.MakeAccountPayableAgent
makeAllActionForReceiptFromAdding(RunningAccountOrderVO) - Method in interface bb.common.box.CompanyBox
makeAllActionForReturnFromAdding(RunningAccountOrderVO, String) - Method in interface bb.common.box.CompanyBox
makeAuditInventoryByPhyInventory(PartPK, Date, Date) - Method in interface bb.common.box.WarehouseBox
MakeBillAndHoldInvoiceAgent - Class in bb.common
MakeBillAndHoldInvoiceAgent() - Constructor for class bb.common.MakeBillAndHoldInvoiceAgent
makeBillAndHoldInvoiceWithSOItems(MakeInvoiceAgent) - Method in interface bb.common.box.AccountingBox
MakeCheckAgent - Class in bb.common
MakeCheckAgent() - Constructor for class bb.common.MakeCheckAgent
MakeCreditMemoAgent - Class in bb.common
MakeCreditMemoAgent() - Constructor for class bb.common.MakeCreditMemoAgent
makeCreditMemoWithRMAReceiver(MakeCreditMemoAgent) - Method in interface bb.common.box.AccountingBox
MakeDebitMemoAgent - Class in bb.common
MakeDebitMemoAgent() - Constructor for class bb.common.MakeDebitMemoAgent
makeDebitMemoWithRtvShipper(MakeDebitMemoAgent) - Method in interface bb.common.box.AccountingBox
makeDepositGL(List<DepositSummaryResult>, ArrayList<PaymentAgent>) - Method in interface bb.common.box.AccountingBox
makeDisassembleWorkOrderReceiver(Set<ReceiverItemAgent>) - Method in interface bb.common.box.WarehouseBox
makeDocumentDir(String) - Static method in class bb.common.BB2Util
makeExchangeRateAudit(ExchangeAuditResult) - Method in interface bb.common.box.AccountingBox
MakeInvoiceAgent - Class in bb.common
MakeInvoiceAgent() - Constructor for class bb.common.MakeInvoiceAgent
makeNcrScrapGl(NcrScrapAgent) - Method in interface bb.common.box.QualityBox
makeNonproductivePickingGl(String, String, ArrayList<NonproductivePickingItemIssuedListResult>, String) - Method in interface bb.common.box.AccountingBox
makeNonproductivePickingShipper(ShipperAgent) - Method in interface bb.common.box.WarehouseBox
makeOnloanReceiver(ReceiverAgent) - Method in interface bb.common.box.WarehouseBox
makeOnLoanShipper(ShipperAgent) - Method in interface bb.common.box.WarehouseBox
makePhysicalInventoryGL(BigDecimal, ArrayList<PhysicalInventoryListResult>, String, String[], String[]) - Method in interface bb.common.box.WarehouseBox
MakePrepaymentCheckAgent - Class in bb.common
MakePrepaymentCheckAgent() - Constructor for class bb.common.MakePrepaymentCheckAgent
makePurchaseOrderPrepayNumber(PrepayAgent) - Method in interface bb.common.box.AccountingBox
makePurchaseOrderReceiver(ReceiverAgent) - Method in interface bb.common.box.WarehouseBox
makePurchaseOrderReceiver(ReceiverShipAgent) - Method in interface bb.common.box.WarehouseBox
makePurchaseOrders(PurchaseWorkSheetVO) - Method in interface bb.common.box.ManufacturingBox
makePurchaseOrders(PurchaseWorkSheetVO) - Method in interface bb.common.box.PurchasingBox
makeRequestForQuotes(PurchaseWorkSheetVO) - Method in interface bb.common.box.ManufacturingBox
makeRequestForQuotes(PurchaseWorkSheetVO) - Method in interface bb.common.box.PurchasingBox
makeReturnMaterialAuthorization(ArrayList<RunningAccountOrderItemResult>) - Method in interface bb.common.box.CompanyBox
makeRMAFromRRMANumber(String) - Method in interface bb.common.box.SalesBox
makeRmaReceiver(ReceiverAgent) - Method in interface bb.common.box.WarehouseBox
makeRtvShipper(ShipperAgent) - Method in interface bb.common.box.WarehouseBox
makeSaleOrderShipper(ShipperAgent) - Method in interface bb.common.box.WarehouseBox
makeSalesOrder(ArrayList<RunningAccountOrderItemResult>) - Method in interface bb.common.box.CompanyBox
makeSalesOrder(ArrayList<RunningAccountOrderItemResult>, boolean) - Method in interface bb.common.box.CompanyBox
makeSalesOrderAndShipperAndARAndGL(Date, Date) - Method in interface bb.common.box.CompanyBox
makeSalesOrderPrepayNumber(PrepayAgent) - Method in interface bb.common.box.AccountingBox
makeSwapOrderShipper(ShipperAgent) - Method in interface bb.common.box.WarehouseBox
makeSwapReceiver(ReceiverAgent) - Method in interface bb.common.box.WarehouseBox
makeToolCalibration(PartPK) - Method in interface bb.common.box.ManufacturingBox
makeTransferOrderShipper(ShipperAgent) - Method in interface bb.common.box.WarehouseBox
makeTransferReceiver(ReceiverAgent) - Method in interface bb.common.box.WarehouseBox
makeUnbilledWithShipperItems(MakeInvoiceAgent) - Method in interface bb.common.box.AccountingBox
makeWorkOrderInWipGlByMonth(String) - Method in interface bb.common.box.AccountingBox
makeWorkOrderReceiver(ReceiverAgent) - Method in interface bb.common.box.WarehouseBox
makeWorkOrders(WorkOrderWorkSheetVO) - Method in interface bb.common.box.WorkOrderBox
MANAGEMENT - Static variable in class bb.common.Configure.Module
ManagementBox - Interface in bb.common.box
MANUAL - Static variable in class bb.common.Constant.PartNumberGenerateType
MANUFACTURE_ENGINEERING_CHANGE_NOTICE_NOT_CLOSED_EXIST_FOR_THIS_PART - Static variable in class bb.common.BIZReason
MANUFACTURER - Static variable in class bb.common.BizTarget
MANUFACTURER_ID_ALREADY_EXIST - Static variable in class bb.common.BIZReason
MANUFACTURER_ID_IS_DELETED - Static variable in class bb.common.BIZReason
MANUFACTURER_ID_NOT_EXIST - Static variable in class bb.common.BIZReason
MANUFACTURER_ID_USED_IN_PART - Static variable in class bb.common.BIZReason
MANUFACTURER_PART_NUMBER - Static variable in class bb.common.BizTarget
MANUFACTURER_PART_NUMBER_NOT_EXIST - Static variable in class bb.common.BIZReason
ManufacturerAddressInfoVO - Class in bb.common
ManufacturerAddressInfoVO() - Constructor for class bb.common.ManufacturerAddressInfoVO
ManufacturerAddressVO - Class in bb.common
ManufacturerAddressVO() - Constructor for class bb.common.ManufacturerAddressVO
ManufacturerContactPK - Class in bb.common
ManufacturerContactPK() - Constructor for class bb.common.ManufacturerContactPK
ManufacturerContactPK(String, Short) - Constructor for class bb.common.ManufacturerContactPK
ManufacturerContactVO - Class in bb.common
ManufacturerContactVO() - Constructor for class bb.common.ManufacturerContactVO
ManufacturerDescriptionPK - Class in bb.common
ManufacturerDescriptionPK(String, String) - Constructor for class bb.common.ManufacturerDescriptionPK
full constructor
ManufacturerDescriptionPK() - Constructor for class bb.common.ManufacturerDescriptionPK
default constructor
ManufacturerDescriptionVO - Class in bb.common
ManufacturerDescriptionVO() - Constructor for class bb.common.ManufacturerDescriptionVO
MANUFACTURING - Static variable in class bb.common.Configure.Module
ManufacturingBox - Interface in bb.common.box
MasterWorkOrderTreeItemResult - Class in bb.common
MasterWorkOrderTreeItemResult() - Constructor for class bb.common.MasterWorkOrderTreeItemResult
MasterWorkOrderTreeItemResult(BillItemOnHandWithPartInfoResult) - Constructor for class bb.common.MasterWorkOrderTreeItemResult
MAXQTY - Static variable in class bb.common.Constant.PartQtyType
MECN - Static variable in class bb.common.BizTarget
mergeNumberMap(Map<String, Object>, Map<String, Object>) - Static method in class bb.common.BB2Util
MESSAGE - Static variable in class bb.common.BizTarget
MESSAGE_ALREADY_READ_BY_RECEIVER - Static variable in class bb.common.BIZReason
MESSAGE_IN_MONTH_NEED_REMAIN - Static variable in class bb.common.BIZReason
MESSAGE_NOT_EXIST - Static variable in class bb.common.BIZReason
MessageAgent - Class in bb.common
MessageAgent() - Constructor for class bb.common.MessageAgent
MessageVO - Class in bb.common
MessageVO() - Constructor for class bb.common.MessageVO
METHOD_NOT_EXIST - Static variable in class bb.common.BIZReason
MfrMpnListResult - Class in bb.common
MfrMpnListResult(String, String) - Constructor for class bb.common.MfrMpnListResult
MilliSecordsOfEachDay - Static variable in class bb.common.Constant
MINQTY - Static variable in class bb.common.Constant.PartQtyType
MINUTE - Static variable in class bb.common.Constant.PeriodUnit
MISC_DOC_ACTION - Static variable in class bb.common.DocumentAction.MiscDocAction
MiscDocAgent - Class in bb.common
MiscDocAgent() - Constructor for class bb.common.MiscDocAgent
MiscDocumentSettingVO - Class in bb.common
MiscDocumentSettingVO() - Constructor for class bb.common.MiscDocumentSettingVO
MISSING_OR_WRONG_ACCOUNT_FOR_RETAINED_ERANINGS - Static variable in class bb.common.BIZReason
MODIFY_ONHAND_INQA_ERROR - Static variable in class bb.common.BIZReason
Money - Class in bb.common
Money() - Constructor for class bb.common.Money
Money(String, BigDecimal) - Constructor for class bb.common.Money
MoneyInDrawResult - Class in bb.common
MoneyInDrawResult() - Constructor for class bb.common.MoneyInDrawResult
MONTH - Static variable in class bb.common.Constant.CycleCountPeriodUnit
MONTH - Static variable in class bb.common.Constant.PeriodUnit
MONTH_12_AVG - Static variable in class bb.common.PurchaseOrderOnTimeItemResult
MONTH_12_AVG - Static variable in class bb.common.SalesOrderOnTimeItemResult
MONTH_12_AVG - Static variable in class bb.common.WorkOrderOnTimeItemResult
MONTH_YEAR - Static variable in class bb.common.BizTarget
MonthBalanceResult - Class in bb.common
MonthBalanceResult() - Constructor for class bb.common.MonthBalanceResult
MonthSoOrArByCustomerResult - Class in bb.common
MonthSoOrArByCustomerResult() - Constructor for class bb.common.MonthSoOrArByCustomerResult
moveWarehouse(String, String) - Method in interface bb.common.box.WarehouseBox
MP - Static variable in class bb.common.Constant.Prefix
MrpByMonthResult - Class in bb.common
MrpByMonthResult() - Constructor for class bb.common.MrpByMonthResult
MrpItemOrderDemandRecordsResult - Class in bb.common
MrpItemOrderDemandRecordsResult() - Constructor for class bb.common.MrpItemOrderDemandRecordsResult
MrpItemResult - Class in bb.common
MrpItemResult() - Constructor for class bb.common.MrpItemResult
MrpReportAgent - Class in bb.common
MrpReportAgent() - Constructor for class bb.common.MrpReportAgent
MULTI_LANGUAGE_DESCRIPTION - Static variable in class bb.common.BizTarget
MultiLanguageAccountsChartPK - Class in bb.common
MultiLanguageAccountsChartPK() - Constructor for class bb.common.MultiLanguageAccountsChartPK
MultiLanguageAccountsChartPK(String, String) - Constructor for class bb.common.MultiLanguageAccountsChartPK
MultiLanguageAccountsChartVO - Class in bb.common
MultiLanguageAccountsChartVO() - Constructor for class bb.common.MultiLanguageAccountsChartVO
MultiLanguageAccountsChartVO(MultiLanguageAccountsChartPK, String) - Constructor for class bb.common.MultiLanguageAccountsChartVO
MULTIPLE - Static variable in class bb.common.Constant.OITypeSerialNumberType
MUST_NULL_OR_EMPTY - Static variable in class bb.common.BIZReason
MY_PRINT_LIST - Static variable in class bb.common.BizTarget
MyPrintListPK - Class in bb.common
MyPrintListPK(String, String) - Constructor for class bb.common.MyPrintListPK
full constructor
MyPrintListPK() - Constructor for class bb.common.MyPrintListPK
default constructor
MyPrintListVO - Class in bb.common
MyPrintListVO() - Constructor for class bb.common.MyPrintListVO
default constructor
MYSELF_CAN_NOT_BE_REMOVED - Static variable in class bb.common.BIZReason
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M N O P Q R S T U V W X Y Z


MiscDocAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class MiscDocAgent

java.lang.Object
    extended by  bb.common.MiscDocAgent
All Implemented Interfaces:
java.io.Serializable
public class MiscDocAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
MiscDocAgent()
Method Summary
java.lang.String | getCategory()
java.lang.String | getComments()
java.lang.String | getCompanyUnitId()
java.lang.Long | getControlNumber()
java.util.Date | getCurrentPeriodFrom()
java.util.Date | getCurrentPeriodTo()
java.lang.String | getDocDescription()
long | getDocLength()
java.lang.String | getDocName()
java.lang.String | getDocType()
byte[] | getDocument()
java.util.Date | getDocumentDate()
java.util.Date | getExpireDate()
java.lang.String | getExtension()
java.lang.Short | getHeight()
java.lang.String | getLanguage()
java.lang.String | getLanIp()
java.lang.String | getMacAdd()
java.lang.String | getOrderItemNumber()
java.lang.String | getOrderNumber()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
byte[] | getPicture()
java.lang.String | getPoNumber()
java.util.Date | getPriorPeriodFrom()
java.util.Date | getPriorPeriodTo()
java.lang.String | getRecNumber()
java.lang.String | getRecordType()
java.lang.String | getRefNumber()
java.lang.String | getRevision()
java.lang.String | getSequence()
java.lang.String | getSetId()
java.lang.String | getSoNumber()
java.lang.String | getStatus()
java.lang.String | getWanIp()
java.lang.Short | getWidth()
java.lang.String | getWoNumber()
java.lang.String | getYearCode()
boolean | isMainPicture()
void | setCategory(java.lang.String category)
void | setComments(java.lang.String comments)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setControlNumber(java.lang.Long controlNumber)
void | setCurrentPeriodFrom(java.util.Date currentPeriodFrom)
void | setCurrentPeriodTo(java.util.Date currentPeriodTo)
void | setDocDescription(java.lang.String docDescription)
void | setDocLength(long docLength)
void | setDocName(java.lang.String docName)
void | setDocType(java.lang.String docType)
void | setDocument(byte[] document)
void | setDocumentDate(java.util.Date documentDate)
void | setExpireDate(java.util.Date expireDate)
void | setExtension(java.lang.String extension)
void | setHeight(java.lang.Short height)
void | setLanguage(java.lang.String language)
void | setLanIp(java.lang.String lanIp)
void | setMacAdd(java.lang.String macAdd)
void | setMainPicture(boolean isMainPicture)
void | setOrderItemNumber(java.lang.String orderItemNumber)
void | setOrderNumber(java.lang.String orderNumber)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPicture(byte[] picture)
void | setPoNumber(java.lang.String poNumber)
void | setPriorPeriodFrom(java.util.Date priorPeriodFrom)
void | setPriorPeriodTo(java.util.Date priorPeriodTo)
void | setRecNumber(java.lang.String recNumber)
void | setRecordType(java.lang.String recordType)
void | setRefNumber(java.lang.String refNumber)
void | setRevision(java.lang.String revision)
void | setSequence(java.lang.String sequence)
void | setSetId(java.lang.String setId)
void | setSoNumber(java.lang.String soNumber)
void | setStatus(java.lang.String status)
void | setWanIp(java.lang.String wanIp)
void | setWidth(java.lang.Short width)
void | setWoNumber(java.lang.String woNumber)
void | setYearCode(java.lang.String yearCode)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MiscDocAgent

public MiscDocAgent()
Method Detail

getCategory

public java.lang.String getCategory()

setCategory

public void setCategory(java.lang.String category)

getExpireDate

public java.util.Date getExpireDate()

setExpireDate

public void setExpireDate(java.util.Date expireDate)

getPoNumber

public java.lang.String getPoNumber()

setPoNumber

public void setPoNumber(java.lang.String poNumber)

getRecNumber

public java.lang.String getRecNumber()

setRecNumber

public void setRecNumber(java.lang.String recNumber)

getRefNumber

public java.lang.String getRefNumber()

setRefNumber

public void setRefNumber(java.lang.String refNumber)

getSoNumber

public java.lang.String getSoNumber()

setSoNumber

public void setSoNumber(java.lang.String soNumber)

getWoNumber

public java.lang.String getWoNumber()

setWoNumber

public void setWoNumber(java.lang.String woNumber)

getDocName

public java.lang.String getDocName()

setDocName

public void setDocName(java.lang.String docName)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getDocDescription

public java.lang.String getDocDescription()

setDocDescription

public void setDocDescription(java.lang.String docDescription)

getDocLength

public long getDocLength()

setDocLength

public void setDocLength(long docLength)

getDocument

public byte[] getDocument()

setDocument

public void setDocument(byte[] document)

getDocumentDate

public java.util.Date getDocumentDate()

setDocumentDate

public void setDocumentDate(java.util.Date documentDate)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

getLanIp

public java.lang.String getLanIp()

setLanIp

public void setLanIp(java.lang.String lanIp)

getMacAdd

public java.lang.String getMacAdd()

setMacAdd

public void setMacAdd(java.lang.String macAdd)

getWanIp

public java.lang.String getWanIp()

setWanIp

public void setWanIp(java.lang.String wanIp)

getControlNumber

public java.lang.Long getControlNumber()

setControlNumber

public void setControlNumber(java.lang.Long controlNumber)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getOrderItemNumber

public java.lang.String getOrderItemNumber()

setOrderItemNumber

public void setOrderItemNumber(java.lang.String orderItemNumber)

getOrderNumber

public java.lang.String getOrderNumber()

setOrderNumber

public void setOrderNumber(java.lang.String orderNumber)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getDocType

public java.lang.String getDocType()

setDocType

public void setDocType(java.lang.String docType)

getSequence

public java.lang.String getSequence()

setSequence

public void setSequence(java.lang.String sequence)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getHeight

public java.lang.Short getHeight()

setHeight

public void setHeight(java.lang.Short height)

isMainPicture

public boolean isMainPicture()

setMainPicture

public void setMainPicture(boolean isMainPicture)

getWidth

public java.lang.Short getWidth()

setWidth

public void setWidth(java.lang.Short width)

getPicture

public byte[] getPicture()

setPicture

public void setPicture(byte[] picture)

getSetId

public java.lang.String getSetId()

setSetId

public void setSetId(java.lang.String setId)

getRecordType

public java.lang.String getRecordType()

setRecordType

public void setRecordType(java.lang.String recordType)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getYearCode

public java.lang.String getYearCode()

setYearCode

public void setYearCode(java.lang.String yearCode)

getCurrentPeriodFrom

public java.util.Date getCurrentPeriodFrom()

setCurrentPeriodFrom

public void setCurrentPeriodFrom(java.util.Date currentPeriodFrom)

getCurrentPeriodTo

public java.util.Date getCurrentPeriodTo()

setCurrentPeriodTo

public void setCurrentPeriodTo(java.util.Date currentPeriodTo)

getPriorPeriodFrom

public java.util.Date getPriorPeriodFrom()

setPriorPeriodFrom

public void setPriorPeriodFrom(java.util.Date priorPeriodFrom)

getPriorPeriodTo

public java.util.Date getPriorPeriodTo()

setPriorPeriodTo

public void setPriorPeriodTo(java.util.Date priorPeriodTo)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MiscDocumentSettingVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class MiscDocumentSettingVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.MiscDocumentSettingVO
All Implemented Interfaces:
java.io.Serializable
public class MiscDocumentSettingVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DOCUMENTTYPE
static java.lang.String | ORDER_BY_FTPPATH
static java.lang.String | ORDER_BY_LOCALPATH
static java.lang.String | ORDER_BY_REMARKS
static java.lang.String | ORDER_BY_SERVERIP
static java.lang.String | ORDER_BY_SERVERPORT
static java.lang.String | ORDER_BY_USERNAME
Constructor Summary
MiscDocumentSettingVO()
Method Summary
java.lang.String | getDocumentType()
java.lang.String | getFtpPath()
java.lang.Integer | getIi()
java.lang.String | getLocalPath()
java.lang.String | getRemarks()
java.lang.String | getServerIp()
java.lang.String | getServerPort()
java.lang.String | getUserName()
java.lang.String | getUserPassword()
boolean | isLocked()
boolean | isSaveToFtp()
void | setDocumentType(java.lang.String documentType)
void | setFtpPath(java.lang.String ftpPath)
void | setIi(java.lang.Integer ii)
void | setLocalPath(java.lang.String localPath)
void | setLocked(boolean locked)
void | setRemarks(java.lang.String remarks)
void | setSaveToFtp(boolean saveToFtp)
void | setServerIp(java.lang.String serverIp)
void | setServerPort(java.lang.String serverPort)
void | setUserName(java.lang.String userName)
void | setUserPassword(java.lang.String userPassword)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_DOCUMENTTYPE

public static final java.lang.String ORDER_BY_DOCUMENTTYPE
See Also:
Constant Field Values

ORDER_BY_SERVERIP

public static final java.lang.String ORDER_BY_SERVERIP
See Also:
Constant Field Values

ORDER_BY_SERVERPORT

public static final java.lang.String ORDER_BY_SERVERPORT
See Also:
Constant Field Values

ORDER_BY_USERNAME

public static final java.lang.String ORDER_BY_USERNAME
See Also:
Constant Field Values

ORDER_BY_FTPPATH

public static final java.lang.String ORDER_BY_FTPPATH
See Also:
Constant Field Values

ORDER_BY_LOCALPATH

public static final java.lang.String ORDER_BY_LOCALPATH
See Also:
Constant Field Values

ORDER_BY_REMARKS

public static final java.lang.String ORDER_BY_REMARKS
See Also:
Constant Field Values
Constructor Detail

MiscDocumentSettingVO

public MiscDocumentSettingVO()
Method Detail

getIi

public java.lang.Integer getIi()

setIi

public void setIi(java.lang.Integer ii)

getDocumentType

public java.lang.String getDocumentType()

setDocumentType

public void setDocumentType(java.lang.String documentType)

isSaveToFtp

public boolean isSaveToFtp()

setSaveToFtp

public void setSaveToFtp(boolean saveToFtp)

getServerIp

public java.lang.String getServerIp()

setServerIp

public void setServerIp(java.lang.String serverIp)

getServerPort

public java.lang.String getServerPort()

setServerPort

public void setServerPort(java.lang.String serverPort)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getUserPassword

public java.lang.String getUserPassword()

setUserPassword

public void setUserPassword(java.lang.String userPassword)

getFtpPath

public java.lang.String getFtpPath()

setFtpPath

public void setFtpPath(java.lang.String ftpPath)

getLocalPath

public java.lang.String getLocalPath()

setLocalPath

public void setLocalPath(java.lang.String localPath)

isLocked

public boolean isLocked()

setLocked

public void setLocked(boolean locked)

getRemarks

public java.lang.String getRemarks()

setRemarks

public void setRemarks(java.lang.String remarks)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Money

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Money

java.lang.Object
    extended by  bb.common.Money
All Implemented Interfaces:
java.io.Serializable
public class Money
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
Money()
Money(java.lang.String currency, java.math.BigDecimal value)
Method Summary
java.lang.String | getCurrency()
java.math.BigDecimal | getValue()
void | setCurrency(java.lang.String currency)
void | setValue(java.math.BigDecimal value)
java.lang.String | toString()
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Money

public Money()

Money

public Money(java.lang.String currency,
             java.math.BigDecimal value)
Method Detail

setCurrency

public void setCurrency(java.lang.String currency)

setValue

public void setValue(java.math.BigDecimal value)

getCurrency

public java.lang.String getCurrency()

getValue

public java.math.BigDecimal getValue()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MoneyInDrawResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class MoneyInDrawResult

java.lang.Object
    extended by  bb.common.MoneyInDrawResult
All Implemented Interfaces:
java.io.Serializable
public class MoneyInDrawResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
MoneyInDrawResult()
Method Summary
java.math.BigDecimal | getCashTotal()
java.math.BigDecimal | getCcTotal()
java.math.BigDecimal | getCheckTotal()
java.lang.String | getComputerId()
java.math.BigDecimal | getInvoiceTotal()
java.math.BigDecimal | getTotal()
void | setCashTotal(java.math.BigDecimal cashTotal)
void | setCcTotal(java.math.BigDecimal ccTotal)
void | setCheckTotal(java.math.BigDecimal checkTotal)
void | setComputerId(java.lang.String computerId)
void | setInvoiceTotal(java.math.BigDecimal invoiceTotal)
void | setTotal(java.math.BigDecimal total)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MoneyInDrawResult

public MoneyInDrawResult()
Method Detail

getCashTotal

public java.math.BigDecimal getCashTotal()

setCashTotal

public void setCashTotal(java.math.BigDecimal cashTotal)

getCheckTotal

public java.math.BigDecimal getCheckTotal()

setCheckTotal

public void setCheckTotal(java.math.BigDecimal checkTotal)

getCcTotal

public java.math.BigDecimal getCcTotal()

setCcTotal

public void setCcTotal(java.math.BigDecimal ccTotal)

getInvoiceTotal

public java.math.BigDecimal getInvoiceTotal()

setInvoiceTotal

public void setInvoiceTotal(java.math.BigDecimal invoiceTotal)

getTotal

public java.math.BigDecimal getTotal()

setTotal

public void setTotal(java.math.BigDecimal total)

getComputerId

public java.lang.String getComputerId()

setComputerId

public void setComputerId(java.lang.String computerId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MonthBalanceResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class MonthBalanceResult

java.lang.Object
    extended by  bb.common.MonthBalanceResult
All Implemented Interfaces:
java.io.Serializable
public class MonthBalanceResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
MonthBalanceResult()
Method Summary
AccountsChartVO | getAccountsChartVO()
java.math.BigDecimal | getCreditBalance()
java.math.BigDecimal | getDebitBalance()
java.math.BigDecimal | getOrgCreditBalance()
java.math.BigDecimal | getOrgDebitBalance()
void | setAccountsChartVO(AccountsChartVO accountsChartVO)
void | setCreditBalance(java.math.BigDecimal creditBalance)
void | setDebitBalance(java.math.BigDecimal debitBalance)
void | setOrgCreditBalance(java.math.BigDecimal orgCreditBalance)
void | setOrgDebitBalance(java.math.BigDecimal orgDebitBalance)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MonthBalanceResult

public MonthBalanceResult()
Method Detail

getCreditBalance

public java.math.BigDecimal getCreditBalance()

setCreditBalance

public void setCreditBalance(java.math.BigDecimal creditBalance)

getDebitBalance

public java.math.BigDecimal getDebitBalance()

setDebitBalance

public void setDebitBalance(java.math.BigDecimal debitBalance)

getAccountsChartVO

public AccountsChartVO getAccountsChartVO()

setAccountsChartVO

public void setAccountsChartVO(AccountsChartVO accountsChartVO)

getOrgCreditBalance

public java.math.BigDecimal getOrgCreditBalance()

setOrgCreditBalance

public void setOrgCreditBalance(java.math.BigDecimal orgCreditBalance)

getOrgDebitBalance

public java.math.BigDecimal getOrgDebitBalance()

setOrgDebitBalance

public void setOrgDebitBalance(java.math.BigDecimal orgDebitBalance)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MonthSoOrArByCustomerResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class MonthSoOrArByCustomerResult

java.lang.Object
    extended by  bb.common.MonthSoOrArByCustomerResult
All Implemented Interfaces:
java.io.Serializable
public class MonthSoOrArByCustomerResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
MonthSoOrArByCustomerResult()
Method Summary
java.lang.String | getCustomerId()
java.lang.String | getCustomerName()
java.util.Map<java.lang.String,java.math.BigDecimal> | getMonthAmountMap()
void | setCustomerId(java.lang.String customerId)
void | setCustomerName(java.lang.String customerName)
void | setMonthAmountMap(java.util.Map<java.lang.String,java.math.BigDecimal> monthAmountMap)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MonthSoOrArByCustomerResult

public MonthSoOrArByCustomerResult()
Method Detail

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getCustomerName

public java.lang.String getCustomerName()

setCustomerName

public void setCustomerName(java.lang.String customerName)

getMonthAmountMap

public java.util.Map<java.lang.String,java.math.BigDecimal> getMonthAmountMap()

setMonthAmountMap

public void setMonthAmountMap(java.util.Map<java.lang.String,java.math.BigDecimal> monthAmountMap)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MrpByMonthResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class MrpByMonthResult

java.lang.Object
    extended by  bb.common.MrpByMonthResult
All Implemented Interfaces:
java.io.Serializable, java.lang.Cloneable
public class MrpByMonthResult
extends java.lang.Object
implements java.io.Serializable, java.lang.Cloneable

See Also:
Serialized Form

Constructor Summary
MrpByMonthResult()
Method Summary
java.lang.Object | clone()
java.math.BigDecimal | getAvailQty()
java.util.Date | getDate()
int | getIi()
java.lang.String | getMonthName()
java.math.BigDecimal | getOrderQty()
java.math.BigDecimal | getOrderUsageQty()
java.math.BigDecimal | getShortQty()
java.math.BigDecimal | getUsageQty()
void | setAvailQty(java.math.BigDecimal availQty)
void | setDate(java.util.Date Date)
void | setIi(int ii)
void | setMonthName(java.lang.String monthName)
void | setOrderQty(java.math.BigDecimal orderQty)
void | setOrderUsageQty(java.math.BigDecimal orderUsageQty)
void | setShortQty(java.math.BigDecimal shortQty)
void | setUsageQty(java.math.BigDecimal usageQty)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MrpByMonthResult

public MrpByMonthResult()
Method Detail

getOrderQty

public java.math.BigDecimal getOrderQty()

getAvailQty

public java.math.BigDecimal getAvailQty()

getUsageQty

public java.math.BigDecimal getUsageQty()

getShortQty

public java.math.BigDecimal getShortQty()

getMonthName

public java.lang.String getMonthName()

setIi

public void setIi(int ii)

setOrderQty

public void setOrderQty(java.math.BigDecimal orderQty)

setAvailQty

public void setAvailQty(java.math.BigDecimal availQty)

setUsageQty

public void setUsageQty(java.math.BigDecimal usageQty)

setShortQty

public void setShortQty(java.math.BigDecimal shortQty)

getOrderUsageQty

public java.math.BigDecimal getOrderUsageQty()

setOrderUsageQty

public void setOrderUsageQty(java.math.BigDecimal orderUsageQty)

setMonthName

public void setMonthName(java.lang.String monthName)

setDate

public void setDate(java.util.Date Date)

getIi

public int getIi()

getDate

public java.util.Date getDate()

clone

public java.lang.Object clone()
                       throws java.lang.CloneNotSupportedException
Overrides:
clone in class java.lang.Object
Throws:
java.lang.CloneNotSupportedException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MrpItemOrderDemandRecordsResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class MrpItemOrderDemandRecordsResult

java.lang.Object
    extended by  bb.common.MrpItemOrderDemandRecordsResult
All Implemented Interfaces:
java.io.Serializable
public class MrpItemOrderDemandRecordsResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
MrpItemOrderDemandRecordsResult()
Method Summary
java.util.ArrayList | getOrphanedSoOnDemandList()
java.util.ArrayList | getOrphanedWoOnDemandList()
PartPK | getPart()
java.util.ArrayList | getPoOnOrderList()
java.util.ArrayList | getSoOnDemandList()
java.util.ArrayList | getStockOnDemandList()
java.util.ArrayList | getWoOnOrderList()
void | setOrphanedSoOnDemandList(java.util.ArrayList orphanedSoOnDemandList)
void | setOrphanedWoOnDemandList(java.util.ArrayList orphanedWoOnDemandList)
void | setPart(PartPK part)
void | setPoOnOrderList(java.util.ArrayList poOnOrderList)
void | setSoOnDemandList(java.util.ArrayList soOnDemandList)
void | setStockOnDemandList(java.util.ArrayList stockOnDemandList)
void | setWoOnOrderList(java.util.ArrayList woOnOrderList)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MrpItemOrderDemandRecordsResult

public MrpItemOrderDemandRecordsResult()
Method Detail

setPart

public void setPart(PartPK part)

setPoOnOrderList

public void setPoOnOrderList(java.util.ArrayList poOnOrderList)

setWoOnOrderList

public void setWoOnOrderList(java.util.ArrayList woOnOrderList)

setSoOnDemandList

public void setSoOnDemandList(java.util.ArrayList soOnDemandList)

setStockOnDemandList

public void setStockOnDemandList(java.util.ArrayList stockOnDemandList)

setOrphanedSoOnDemandList

public void setOrphanedSoOnDemandList(java.util.ArrayList orphanedSoOnDemandList)

setOrphanedWoOnDemandList

public void setOrphanedWoOnDemandList(java.util.ArrayList orphanedWoOnDemandList)

getPart

public PartPK getPart()

getPoOnOrderList

public java.util.ArrayList getPoOnOrderList()

getWoOnOrderList

public java.util.ArrayList getWoOnOrderList()

getSoOnDemandList

public java.util.ArrayList getSoOnDemandList()

getStockOnDemandList

public java.util.ArrayList getStockOnDemandList()

getOrphanedSoOnDemandList

public java.util.ArrayList getOrphanedSoOnDemandList()

getOrphanedWoOnDemandList

public java.util.ArrayList getOrphanedWoOnDemandList()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MrpItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class MrpItemResult

java.lang.Object
    extended by  bb.common.MrpItemResult
All Implemented Interfaces:
java.io.Serializable
public class MrpItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
MrpItemResult()
Method Summary
java.util.Date | getBeforeDate()
java.util.ArrayList | getDwoOnDemandList()
java.util.ArrayList | getDwoOnOrderList()
OrderPK | getLateItemPk()
java.util.LinkedList | getMonthsInfo()
java.math.BigDecimal | getMustOrder()
java.math.BigDecimal | getMustOrderBefore()
java.util.ArrayList | getNonproPickingOnDemandList()
java.math.BigDecimal | getNotReviewedOnDemandQty()
java.math.BigDecimal | getNotReviewedOnOrderQty()
java.math.BigDecimal | getOnDemandQty()
java.util.ArrayList | getOrphanedSoOnDemandList()
java.util.ArrayList | getOrphanedWoOnDemandList()
PartPK | getPart()
PartBasicInfo | getPartBasicInfo()
PartInventoryVO | getPartInventory()
java.util.ArrayList | getPoNotApprovedOnOrderList()
java.util.ArrayList | getPoOnOrderList()
OrderPK | getShortItemPk()
java.util.ArrayList | getSoNotReviewedOnDemandList()
java.util.ArrayList | getSoOnDemandList()
java.util.ArrayList | getStockOnDemandList()
java.util.ArrayList | getSwsOnOrderList()
java.util.ArrayList | getWoNotApprovedOnOrderList()
java.util.ArrayList | getWoOnOrderList()
void | setBeforeDate(java.util.Date beforeDate)
void | setDwoOnDemandList(java.util.ArrayList dwoOnDemandList)
void | setDwoOnOrderList(java.util.ArrayList dwoOnOrderList)
void | setLateItemPk(OrderPK lateItemPk)
void | setMonthsInfo(java.util.LinkedList monthsInfo)
void | setMustOrder(java.math.BigDecimal mustOrder)
void | setMustOrderBefore(java.math.BigDecimal mustOrderBefore)
void | setNonproPickingOnDemandList(java.util.ArrayList nonproPickingOnDemandList)
void | setNotReviewedOnDemandQty(java.math.BigDecimal notReviewedOnDemandQty)
void | setNotReviewedOnOrderQty(java.math.BigDecimal notReviewedOnOrderQty)
void | setOnDemandQty(java.math.BigDecimal onDemandQty)
void | setOrphanedSoOnDemandList(java.util.ArrayList orphanedSoOnDemandList)
void | setOrphanedWoOnDemandList(java.util.ArrayList orphanedWoOnDemandList)
void | setPart(PartPK part)
void | setPartBasicInfo(PartBasicInfo partBasicInfo)
void | setPartInventory(PartInventoryVO partInventory)
void | setPoNotApprovedOnOrderList(java.util.ArrayList poNotApprovedOnOrderList)
void | setPoOnOrderList(java.util.ArrayList poOnOrderList)
void | setShortItemPk(OrderPK shortItemPk)
void | setSoNotReviewedOnDemandList(java.util.ArrayList soNotReviewedOnDemandList)
void | setSoOnDemandList(java.util.ArrayList soOnDemandList)
void | setStockOnDemandList(java.util.ArrayList stockOnDemandList)
void | setSwsOnOrderList(java.util.ArrayList swsOnOrderList)
void | setWoNotApprovedOnOrderList(java.util.ArrayList woNotApprovedOnOrderList)
void | setWoOnOrderList(java.util.ArrayList woOnOrderList)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MrpItemResult

public MrpItemResult()
Method Detail

setPart

public void setPart(PartPK part)

setPoOnOrderList

public void setPoOnOrderList(java.util.ArrayList poOnOrderList)

setWoOnOrderList

public void setWoOnOrderList(java.util.ArrayList woOnOrderList)

setSoOnDemandList

public void setSoOnDemandList(java.util.ArrayList soOnDemandList)

setStockOnDemandList

public void setStockOnDemandList(java.util.ArrayList stockOnDemandList)

setOrphanedSoOnDemandList

public void setOrphanedSoOnDemandList(java.util.ArrayList orphanedSoOnDemandList)

setOrphanedWoOnDemandList

public void setOrphanedWoOnDemandList(java.util.ArrayList orphanedWoOnDemandList)

getPart

public PartPK getPart()

getPoOnOrderList

public java.util.ArrayList getPoOnOrderList()

getWoOnOrderList

public java.util.ArrayList getWoOnOrderList()

getSoOnDemandList

public java.util.ArrayList getSoOnDemandList()

getStockOnDemandList

public java.util.ArrayList getStockOnDemandList()

getOrphanedSoOnDemandList

public java.util.ArrayList getOrphanedSoOnDemandList()

getOrphanedWoOnDemandList

public java.util.ArrayList getOrphanedWoOnDemandList()

setMustOrder

public void setMustOrder(java.math.BigDecimal mustOrder)

setMonthsInfo

public void setMonthsInfo(java.util.LinkedList monthsInfo)

setShortItemPk

public void setShortItemPk(OrderPK shortItemPk)

setLateItemPk

public void setLateItemPk(OrderPK lateItemPk)

setPartBasicInfo

public void setPartBasicInfo(PartBasicInfo partBasicInfo)

setPartInventory

public void setPartInventory(PartInventoryVO partInventory)

getMustOrder

public java.math.BigDecimal getMustOrder()

getMonthsInfo

public java.util.LinkedList getMonthsInfo()

getShortItemPk

public OrderPK getShortItemPk()

getLateItemPk

public OrderPK getLateItemPk()

getPartBasicInfo

public PartBasicInfo getPartBasicInfo()

getPartInventory

public PartInventoryVO getPartInventory()

getMustOrderBefore

public java.math.BigDecimal getMustOrderBefore()

setMustOrderBefore

public void setMustOrderBefore(java.math.BigDecimal mustOrderBefore)

getBeforeDate

public java.util.Date getBeforeDate()

setBeforeDate

public void setBeforeDate(java.util.Date beforeDate)

getNotReviewedOnDemandQty

public java.math.BigDecimal getNotReviewedOnDemandQty()

setNotReviewedOnDemandQty

public void setNotReviewedOnDemandQty(java.math.BigDecimal notReviewedOnDemandQty)

getNotReviewedOnOrderQty

public java.math.BigDecimal getNotReviewedOnOrderQty()

setNotReviewedOnOrderQty

public void setNotReviewedOnOrderQty(java.math.BigDecimal notReviewedOnOrderQty)

getPoNotApprovedOnOrderList

public java.util.ArrayList getPoNotApprovedOnOrderList()

setPoNotApprovedOnOrderList

public void setPoNotApprovedOnOrderList(java.util.ArrayList poNotApprovedOnOrderList)

getSoNotReviewedOnDemandList

public java.util.ArrayList getSoNotReviewedOnDemandList()

setSoNotReviewedOnDemandList

public void setSoNotReviewedOnDemandList(java.util.ArrayList soNotReviewedOnDemandList)

getWoNotApprovedOnOrderList

public java.util.ArrayList getWoNotApprovedOnOrderList()

setWoNotApprovedOnOrderList

public void setWoNotApprovedOnOrderList(java.util.ArrayList woNotApprovedOnOrderList)

getSwsOnOrderList

public java.util.ArrayList getSwsOnOrderList()

setSwsOnOrderList

public void setSwsOnOrderList(java.util.ArrayList swsOnOrderList)

getOnDemandQty

public java.math.BigDecimal getOnDemandQty()

setOnDemandQty

public void setOnDemandQty(java.math.BigDecimal onDemandQty)

getDwoOnOrderList

public java.util.ArrayList getDwoOnOrderList()

setDwoOnOrderList

public void setDwoOnOrderList(java.util.ArrayList dwoOnOrderList)

getDwoOnDemandList

public java.util.ArrayList getDwoOnDemandList()

setDwoOnDemandList

public void setDwoOnDemandList(java.util.ArrayList dwoOnDemandList)

getNonproPickingOnDemandList

public java.util.ArrayList getNonproPickingOnDemandList()

setNonproPickingOnDemandList

public void setNonproPickingOnDemandList(java.util.ArrayList nonproPickingOnDemandList)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MrpReportAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class MrpReportAgent

java.lang.Object
    extended by  bb.common.MrpReportAgent
All Implemented Interfaces:
java.io.Serializable
public class MrpReportAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | NoUsage
static java.lang.String | QtrUsage
static java.lang.String | YrUsage
Constructor Summary
MrpReportAgent()
Method Summary
BillPK | getBillPk()
java.lang.String | getBuyerCode()
java.lang.String | getCommodityCode()
java.lang.String | getCustomerId()
java.math.BigDecimal | getLeadTimeFrom()
java.math.BigDecimal | getLeadTimeTo()
int | getLevel()
java.lang.String | getListUsage()
java.lang.String | getMakeBuy()
java.lang.String | getPartNumberFrom()
java.lang.String[] | getPartNumbers()
java.lang.String | getPartNumberTo()
java.lang.String | getPartType()
java.lang.String | getSalesOrderNumber()
java.util.Date | getTDate()
java.lang.String | getWoProject()
java.lang.String | getWorkOrderNumber()
boolean | isComputeOrpSOWO()
boolean | isConsiderInSTO()
boolean | isIncludeAssembly()
boolean | isIncludeToleranceQty()
boolean | isLeadTime()
boolean | isListAllDemand()
boolean | isListAllPart()
boolean | isListPastDue()
boolean | isListZeroNeedBefore()
boolean | isMinQty()
boolean | isShowNotReviewOrder()
boolean | isShowOnDemand()
boolean | isShowOnOrder()
boolean | isShowZeroMustOrder()
boolean | isSuppressPartOnorderEqualOrLargeOndemand()
void | setBillPk(BillPK billPk)
void | setBuyerCode(java.lang.String buyerCode)
void | setCommodityCode(java.lang.String commodityCode)
void | setComputeOrpSOWO(boolean computeOrpSOWO)
void | setConsiderInSTO(boolean considerInSTO)
void | setCustomerId(java.lang.String customerId)
void | setIncludeAssembly(boolean includeAssembly)
void | setIncludeToleranceQty(boolean includeToleranceQty)
void | setLeadTime(boolean leadTime)
void | setLeadTimeFrom(java.math.BigDecimal leadTimeFrom)
void | setLeadTimeTo(java.math.BigDecimal leadTimeTo)
void | setLevel(int level)
void | setListAllDemand(boolean listAllDemand)
void | setListAllPart(boolean listAllPart)
void | setListPastDue(boolean listPastDue)
void | setListUsage(java.lang.String listUsage)
void | setListZeroNeedBefore(boolean listZeroNeedBefore)
void | setMakeBuy(java.lang.String makeBuy)
void | setMinQty(boolean minQty)
void | setPartNumberFrom(java.lang.String partNumberFrom)
void | setPartNumbers(java.lang.String[] partNumbers)
void | setPartNumberTo(java.lang.String partNumberTo)
void | setPartType(java.lang.String partType)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setShowNotReviewOrder(boolean showNotReviewOrder)
void | setShowOnDemand(boolean showOnDemand)
void | setShowOnOrder(boolean showOnOrder)
void | setShowZeroMustOrder(boolean showZeroMustOrder)
void | setSuppressPartOnorderEqualOrLargeOndemand(boolean suppressPartOnorderEqualOrLargeOndemand)
void | setTDate(java.util.Date date)
void | setWoProject(java.lang.String woProject)
void | setWorkOrderNumber(java.lang.String workOrderNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

QtrUsage

public static final java.lang.String QtrUsage
See Also:
Constant Field Values

YrUsage

public static final java.lang.String YrUsage
See Also:
Constant Field Values

NoUsage

public static final java.lang.String NoUsage
See Also:
Constant Field Values
Constructor Detail

MrpReportAgent

public MrpReportAgent()
Method Detail

isListZeroNeedBefore

public boolean isListZeroNeedBefore()

setListZeroNeedBefore

public void setListZeroNeedBefore(boolean listZeroNeedBefore)

getTDate

public java.util.Date getTDate()

setTDate

public void setTDate(java.util.Date date)

isShowOnOrder

public boolean isShowOnOrder()

isShowOnDemand

public boolean isShowOnDemand()

isLeadTime

public boolean isLeadTime()

isMinQty

public boolean isMinQty()

getCustomerId

public java.lang.String getCustomerId()

getCommodityCode

public java.lang.String getCommodityCode()

getMakeBuy

public java.lang.String getMakeBuy()

getPartNumberTo

public java.lang.String getPartNumberTo()

getPartNumberFrom

public java.lang.String getPartNumberFrom()

isIncludeAssembly

public boolean isIncludeAssembly()

getWorkOrderNumber

public java.lang.String getWorkOrderNumber()

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setBuyerCode

public void setBuyerCode(java.lang.String buyerCode)

setShowOnOrder

public void setShowOnOrder(boolean showOnOrder)

setShowOnDemand

public void setShowOnDemand(boolean showOnDemand)

setLeadTime

public void setLeadTime(boolean leadTime)

setMinQty

public void setMinQty(boolean minQty)

setCustomerId

public void setCustomerId(java.lang.String customerId)

setCommodityCode

public void setCommodityCode(java.lang.String commodityCode)

setMakeBuy

public void setMakeBuy(java.lang.String makeBuy)

setPartNumberTo

public void setPartNumberTo(java.lang.String partNumberTo)

setPartNumberFrom

public void setPartNumberFrom(java.lang.String partNumberFrom)

setIncludeAssembly

public void setIncludeAssembly(boolean includeAssembly)

setWorkOrderNumber

public void setWorkOrderNumber(java.lang.String workOrderNumber)

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

setListAllDemand

public void setListAllDemand(boolean listAllDemand)

setListPastDue

public void setListPastDue(boolean listPastDue)

setSuppressPartOnorderEqualOrLargeOndemand

public void setSuppressPartOnorderEqualOrLargeOndemand(boolean suppressPartOnorderEqualOrLargeOndemand)

setComputeOrpSOWO

public void setComputeOrpSOWO(boolean computeOrpSOWO)

setListUsage

public void setListUsage(java.lang.String listUsage)

setListAllPart

public void setListAllPart(boolean listAllPart)

getBuyerCode

public java.lang.String getBuyerCode()

isListAllDemand

public boolean isListAllDemand()

isListPastDue

public boolean isListPastDue()

isSuppressPartOnorderEqualOrLargeOndemand

public boolean isSuppressPartOnorderEqualOrLargeOndemand()

isComputeOrpSOWO

public boolean isComputeOrpSOWO()

getListUsage

public java.lang.String getListUsage()

isListAllPart

public boolean isListAllPart()

getBillPk

public BillPK getBillPk()

setBillPk

public void setBillPk(BillPK billPk)

getLevel

public int getLevel()

setLevel

public void setLevel(int level)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

isShowNotReviewOrder

public boolean isShowNotReviewOrder()

setShowNotReviewOrder

public void setShowNotReviewOrder(boolean showNotReviewOrder)

getWoProject

public java.lang.String getWoProject()

setWoProject

public void setWoProject(java.lang.String woProject)

getPartNumbers

public java.lang.String[] getPartNumbers()

setPartNumbers

public void setPartNumbers(java.lang.String[] partNumbers)

isShowZeroMustOrder

public boolean isShowZeroMustOrder()

setShowZeroMustOrder

public void setShowZeroMustOrder(boolean showZeroMustOrder)

isConsiderInSTO

public boolean isConsiderInSTO()

setConsiderInSTO

public void setConsiderInSTO(boolean considerInSTO)

isIncludeToleranceQty

public boolean isIncludeToleranceQty()

setIncludeToleranceQty

public void setIncludeToleranceQty(boolean includeToleranceQty)

getLeadTimeFrom

public java.math.BigDecimal getLeadTimeFrom()

setLeadTimeFrom

public void setLeadTimeFrom(java.math.BigDecimal leadTimeFrom)

getLeadTimeTo

public java.math.BigDecimal getLeadTimeTo()

setLeadTimeTo

public void setLeadTimeTo(java.math.BigDecimal leadTimeTo)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MultiLanguageAccountsChartPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class MultiLanguageAccountsChartPK

java.lang.Object
    extended by  bb.common.MultiLanguageAccountsChartPK
All Implemented Interfaces:
java.io.Serializable
public class MultiLanguageAccountsChartPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
MultiLanguageAccountsChartPK()
MultiLanguageAccountsChartPK(java.lang.String accountNumber, java.lang.String language)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAccountNumber()
java.lang.String | getLanguage()
int | hashCode()
void | setAccountNumber(java.lang.String accountNumber)
void | setLanguage(java.lang.String language)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

MultiLanguageAccountsChartPK

public MultiLanguageAccountsChartPK()

MultiLanguageAccountsChartPK

public MultiLanguageAccountsChartPK(java.lang.String accountNumber,
                                    java.lang.String language)
Method Detail

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MultiLanguageAccountsChartVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class MultiLanguageAccountsChartVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.MultiLanguageAccountsChartVO
All Implemented Interfaces:
java.io.Serializable
public class MultiLanguageAccountsChartVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
MultiLanguageAccountsChartVO()
MultiLanguageAccountsChartVO(MultiLanguageAccountsChartPK pk, java.lang.String description)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDescription()
MultiLanguageAccountsChartPK | getPk()
int | hashCode()
void | setDescription(java.lang.String description)
void | setPk(MultiLanguageAccountsChartPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

MultiLanguageAccountsChartVO

public MultiLanguageAccountsChartVO()

MultiLanguageAccountsChartVO

public MultiLanguageAccountsChartVO(MultiLanguageAccountsChartPK pk,
                                    java.lang.String description)
Method Detail

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getPk

public MultiLanguageAccountsChartPK getPk()

setPk

public void setPk(MultiLanguageAccountsChartPK pk)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MyPrintListPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class MyPrintListPK

java.lang.Object
    extended by  bb.common.MyPrintListPK
All Implemented Interfaces:
java.io.Serializable
public class MyPrintListPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
MyPrintListPK()
default constructor
MyPrintListPK(java.lang.String userName, java.lang.String orderNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getOrderNumber()
java.lang.String | getUserName()
int | hashCode()
void | setOrderNumber(java.lang.String orderNumber)
void | setUserName(java.lang.String userName)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

MyPrintListPK

public MyPrintListPK(java.lang.String userName,
                     java.lang.String orderNumber)
full constructor

MyPrintListPK

public MyPrintListPK()
default constructor

Method Detail

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getOrderNumber

public java.lang.String getOrderNumber()

setOrderNumber

public void setOrderNumber(java.lang.String orderNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MyPrintListVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class MyPrintListVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.MyPrintListVO
All Implemented Interfaces:
java.io.Serializable
public class MyPrintListVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
MyPrintListVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getLastChangeDate()
MyPrintListPK | getPk()
int | hashCode()
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setPk(MyPrintListPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

MyPrintListVO

public MyPrintListVO()
default constructor

Method Detail

getPk

public MyPrintListPK getPk()

setPk

public void setPk(MyPrintListPK pk)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NCQRejectResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class NCQRejectResult

java.lang.Object
    extended by  bb.common.NCQRejectResult
All Implemented Interfaces:
java.io.Serializable
public class NCQRejectResult
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String ORDER_BY_NONCONFORMANCECODE
Constructor Summary
NCQRejectResult()
default constructor
Method Summary
java.lang.String | getNonConformanceCode()
java.math.BigDecimal | getRejectPercent()
java.math.BigDecimal | getRejectQuantity()
void | setNonConformanceCode(java.lang.String nonConformanceCode)
void | setRejectPercent(java.math.BigDecimal rejectPercent)
void | setRejectQuantity(java.math.BigDecimal rejectQuantity)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_NONCONFORMANCECODE

public static final java.lang.String ORDER_BY_NONCONFORMANCECODE
See Also:
Constant Field Values
Constructor Detail

NCQRejectResult

public NCQRejectResult()
default constructor

Method Detail

getRejectQuantity

public java.math.BigDecimal getRejectQuantity()

setRejectQuantity

public void setRejectQuantity(java.math.BigDecimal rejectQuantity)

getNonConformanceCode

public java.lang.String getNonConformanceCode()

setNonConformanceCode

public void setNonConformanceCode(java.lang.String nonConformanceCode)

getRejectPercent

public java.math.BigDecimal getRejectPercent()

setRejectPercent

public void setRejectPercent(java.math.BigDecimal rejectPercent)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NcrApprovalPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class NcrApprovalPK

java.lang.Object
    extended by  bb.common.NcrApprovalPK
All Implemented Interfaces:
java.io.Serializable
public class NcrApprovalPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
NcrApprovalPK()
NcrApprovalPK(java.lang.String employeeId, java.lang.String approvableType)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getApprovableType()
java.lang.String | getEmployeeId()
int | hashCode()
void | setApprovableType(java.lang.String approvableType)
void | setEmployeeId(java.lang.String employeeId)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

NcrApprovalPK

public NcrApprovalPK()

NcrApprovalPK

public NcrApprovalPK(java.lang.String employeeId,
                     java.lang.String approvableType)
Method Detail

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getApprovableType

public java.lang.String getApprovableType()

setApprovableType

public void setApprovableType(java.lang.String approvableType)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NcrApprovalVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class NcrApprovalVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.NcrApprovalVO
All Implemented Interfaces:
java.io.Serializable
public class NcrApprovalVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_APPROVETYPE
static java.lang.String | ORDER_BY_CANAPPROVEOWN
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_EMPLOYEEID
static java.lang.String | ORDER_BY_USERNAME
Constructor Summary
NcrApprovalVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
NcrApprovalPK | getPk()
java.lang.String | getUserName()
int | hashCode()
boolean | isCanApproveOwn()
void | setCanApproveOwn(boolean canApproveOwn)
void | setComments(java.lang.String comments)
void | setPk(NcrApprovalPK pk)
void | setUserName(java.lang.String userName)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_EMPLOYEEID

public static final java.lang.String ORDER_BY_EMPLOYEEID
See Also:
Constant Field Values

ORDER_BY_USERNAME

public static final java.lang.String ORDER_BY_USERNAME
See Also:
Constant Field Values

ORDER_BY_CANAPPROVEOWN

public static final java.lang.String ORDER_BY_CANAPPROVEOWN
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values

ORDER_BY_APPROVETYPE

public static final java.lang.String ORDER_BY_APPROVETYPE
See Also:
Constant Field Values
Constructor Detail

NcrApprovalVO

public NcrApprovalVO()
Method Detail

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

isCanApproveOwn

public boolean isCanApproveOwn()

setCanApproveOwn

public void setCanApproveOwn(boolean canApproveOwn)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getPk

public NcrApprovalPK getPk()

setPk

public void setPk(NcrApprovalPK pk)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NcrNeedToScrapListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class NcrNeedToScrapListResult

java.lang.Object
    extended by  bb.common.NcrNeedToScrapListResult
All Implemented Interfaces:
java.io.Serializable
public class NcrNeedToScrapListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DATE
static java.lang.String | ORDER_BY_NCR
static java.lang.String | ORDER_BY_PART
static java.lang.String | ORDER_BY_RESPONSIBILITY
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
NcrNeedToScrapListResult()
Method Summary
java.util.Date | getAdate()
java.util.Date | getDueDate()
java.math.BigDecimal | getInspectedQty()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.util.Date | getNcrDate()
java.lang.String | getNcrNumber()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.math.BigDecimal | getPartPutBackToStock()
java.math.BigDecimal | getPartsPulledFromStock()
java.lang.String | getPartType()
java.lang.String | getPurchaseOrderNumber()
java.math.BigDecimal | getQtyNeedtoScrap()
java.math.BigDecimal | getQtyRegrade()
java.math.BigDecimal | getQtyReject()
java.math.BigDecimal | getQtyRework()
java.math.BigDecimal | getQtyScrap()
java.math.BigDecimal | getQtyScraped()
java.math.BigDecimal | getQtyWaiver()
java.lang.String | getReceiverNumber()
java.lang.String | getResponsibility()
java.lang.String | getRmaNumber()
java.lang.String | getRtvNumber()
java.lang.String | getSalesOrderNumber()
java.lang.String | getStatus()
java.lang.String | getWorkOrderNumber()
void | setAdate(java.util.Date adate)
void | setDueDate(java.util.Date dueDate)
void | setInspectedQty(java.math.BigDecimal inspectedQty)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setNcrDate(java.util.Date ncrDate)
void | setNcrNumber(java.lang.String ncrNumber)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartPutBackToStock(java.math.BigDecimal partPutBackToStock)
void | setPartsPulledFromStock(java.math.BigDecimal partsPulledFromStock)
void | setPartType(java.lang.String partType)
void | setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)
void | setQtyNeedtoScrap(java.math.BigDecimal qtyNeedtoScrap)
void | setQtyRegrade(java.math.BigDecimal qtyRegrade)
void | setQtyReject(java.math.BigDecimal qtyReject)
void | setQtyRework(java.math.BigDecimal qtyRework)
void | setQtyScrap(java.math.BigDecimal qtyScrap)
void | setQtyScraped(java.math.BigDecimal qtyScraped)
void | setQtyWaiver(java.math.BigDecimal qtyWaiver)
void | setReceiverNumber(java.lang.String receiverNumber)
void | setResponsibility(java.lang.String responsibility)
void | setRmaNumber(java.lang.String rmaNumber)
void | setRtvNumber(java.lang.String rtvNumber)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setStatus(java.lang.String status)
void | setWorkOrderNumber(java.lang.String workOrderNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_NCR

public static final java.lang.String ORDER_BY_NCR
See Also:
Constant Field Values

ORDER_BY_DATE

public static final java.lang.String ORDER_BY_DATE
See Also:
Constant Field Values

ORDER_BY_RESPONSIBILITY

public static final java.lang.String ORDER_BY_RESPONSIBILITY
See Also:
Constant Field Values

ORDER_BY_PART

public static final java.lang.String ORDER_BY_PART
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values
Constructor Detail

NcrNeedToScrapListResult

public NcrNeedToScrapListResult()
Method Detail

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getDueDate

public java.util.Date getDueDate()

setDueDate

public void setDueDate(java.util.Date dueDate)

getInspectedQty

public java.math.BigDecimal getInspectedQty()

setInspectedQty

public void setInspectedQty(java.math.BigDecimal inspectedQty)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getNcrDate

public java.util.Date getNcrDate()

setNcrDate

public void setNcrDate(java.util.Date ncrDate)

getNcrNumber

public java.lang.String getNcrNumber()

setNcrNumber

public void setNcrNumber(java.lang.String ncrNumber)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartPutBackToStock

public java.math.BigDecimal getPartPutBackToStock()

setPartPutBackToStock

public void setPartPutBackToStock(java.math.BigDecimal partPutBackToStock)

getPartsPulledFromStock

public java.math.BigDecimal getPartsPulledFromStock()

setPartsPulledFromStock

public void setPartsPulledFromStock(java.math.BigDecimal partsPulledFromStock)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPurchaseOrderNumber

public java.lang.String getPurchaseOrderNumber()

setPurchaseOrderNumber

public void setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)

getQtyNeedtoScrap

public java.math.BigDecimal getQtyNeedtoScrap()

setQtyNeedtoScrap

public void setQtyNeedtoScrap(java.math.BigDecimal qtyNeedtoScrap)

getQtyRegrade

public java.math.BigDecimal getQtyRegrade()

setQtyRegrade

public void setQtyRegrade(java.math.BigDecimal qtyRegrade)

getQtyReject

public java.math.BigDecimal getQtyReject()

setQtyReject

public void setQtyReject(java.math.BigDecimal qtyReject)

getQtyRework

public java.math.BigDecimal getQtyRework()

setQtyRework

public void setQtyRework(java.math.BigDecimal qtyRework)

getQtyScrap

public java.math.BigDecimal getQtyScrap()

setQtyScrap

public void setQtyScrap(java.math.BigDecimal qtyScrap)

getQtyScraped

public java.math.BigDecimal getQtyScraped()

setQtyScraped

public void setQtyScraped(java.math.BigDecimal qtyScraped)

getQtyWaiver

public java.math.BigDecimal getQtyWaiver()

setQtyWaiver

public void setQtyWaiver(java.math.BigDecimal qtyWaiver)

getReceiverNumber

public java.lang.String getReceiverNumber()

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)

getResponsibility

public java.lang.String getResponsibility()

setResponsibility

public void setResponsibility(java.lang.String responsibility)

getRmaNumber

public java.lang.String getRmaNumber()

setRmaNumber

public void setRmaNumber(java.lang.String rmaNumber)

getRtvNumber

public java.lang.String getRtvNumber()

setRtvNumber

public void setRtvNumber(java.lang.String rtvNumber)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getWorkOrderNumber

public java.lang.String getWorkOrderNumber()

setWorkOrderNumber

public void setWorkOrderNumber(java.lang.String workOrderNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NCRPartOnhandPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class NCRPartOnhandPK

java.lang.Object
    extended by  bb.common.NCRPartOnhandPK

public class NCRPartOnhandPK
extends java.lang.Object

Constructor Summary
NCRPartOnhandPK()
NCRPartOnhandPK(PartOnhandPK pk, java.lang.String ncr)
NCRPartOnhandPK(PartOnhandPK pk, java.lang.String ncr, int ii)
Method Summary
boolean | equals(java.lang.Object other)
int | getIi()
java.lang.String | getNcr()
PartOnhandPK | getPk()
int | hashCode()
void | setIi(int ii)
void | setNcr(java.lang.String ncr)
void | setPk(PartOnhandPK pk)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

NCRPartOnhandPK

public NCRPartOnhandPK()

NCRPartOnhandPK

public NCRPartOnhandPK(PartOnhandPK pk,
                       java.lang.String ncr)

NCRPartOnhandPK

public NCRPartOnhandPK(PartOnhandPK pk,
                       java.lang.String ncr,
                       int ii)
Method Detail

getPk

public PartOnhandPK getPk()

setPk

public void setPk(PartOnhandPK pk)

getNcr

public java.lang.String getNcr()

setNcr

public void setNcr(java.lang.String ncr)

setIi

public void setIi(int ii)

getIi

public int getIi()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NCRPictureListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class NCRPictureListResult

java.lang.Object
    extended by  bb.common.NCRPictureListResult
All Implemented Interfaces:
java.io.Serializable
public class NCRPictureListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
NCRPictureListResult()
Method Summary
java.lang.String | getComments()
java.lang.String | getExtension()
java.lang.Long | getIi()
java.lang.String | getNcrNumber()
void | setComments(java.lang.String comments)
void | setExtension(java.lang.String extension)
void | setIi(java.lang.Long ii)
void | setNcrNumber(java.lang.String ncrNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NCRPictureListResult

public NCRPictureListResult()
Method Detail

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getNcrNumber

public java.lang.String getNcrNumber()

setNcrNumber

public void setNcrNumber(java.lang.String ncrNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NCRPictureVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class NCRPictureVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.NCRPictureVO
All Implemented Interfaces:
java.io.Serializable
public class NCRPictureVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
NCRPictureVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.lang.String | getExtension()
java.lang.Long | getIi()
java.lang.String | getNcrNumber()
long | getPictureLength()
java.lang.String | getPictureName()
java.util.Date | getUploadTime()
int | hashCode()
void | setComments(java.lang.String comments)
void | setExtension(java.lang.String extension)
void | setIi(java.lang.Long ii)
void | setNcrNumber(java.lang.String ncrNumber)
void | setPictureLength(long pictureLength)
void | setPictureName(java.lang.String pictureName)
void | setUploadTime(java.util.Date uploadTime)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

NCRPictureVO

public NCRPictureVO()
Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getNcrNumber

public java.lang.String getNcrNumber()

setNcrNumber

public void setNcrNumber(java.lang.String ncrNumber)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getPictureLength

public long getPictureLength()

setPictureLength

public void setPictureLength(long pictureLength)

getPictureName

public java.lang.String getPictureName()

setPictureName

public void setPictureName(java.lang.String pictureName)

getUploadTime

public java.util.Date getUploadTime()

setUploadTime

public void setUploadTime(java.util.Date uploadTime)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NcrReportListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class NcrReportListResult

java.lang.Object
    extended by  bb.common.NcrReportListResult
All Implemented Interfaces:
java.io.Serializable
public class NcrReportListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_APPROVEDOPINIONENG
static java.lang.String | ORDER_BY_APPROVEDOPINIONMFG
static java.lang.String | ORDER_BY_APPROVEDOPINIONQA
static java.lang.String | ORDER_BY_BUYER
static java.lang.String | ORDER_BY_CLOSEDOUTDATE
static java.lang.String | ORDER_BY_CLOSEDOUTPRIVATENOTES
static java.lang.String | ORDER_BY_DUEDATE
static java.lang.String | ORDER_BY_ENTERBY
static java.lang.String | ORDER_BY_NCRDATE
static java.lang.String | ORDER_BY_NCRNUMBER
static java.lang.String | ORDER_BY_PART
static java.lang.String | ORDER_BY_PONUMBER
static java.lang.String | ORDER_BY_PROBLEMDESCRIPTION
static java.lang.String | ORDER_BY_PROBLEMDISPOSITION
static java.lang.String | ORDER_BY_RESPONSIBILITY
static java.lang.String | ORDER_BY_RTVNUMBER
static java.lang.String | ORDER_BY_SONUMBER
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_WONUMBER
Constructor Summary
NcrReportListResult()
Method Summary
java.lang.String | getApprovedOpinionEng()
java.lang.String | getApprovedOpinionMfg()
java.lang.String | getApprovedOpinionQa()
java.lang.String | getBuyer()
java.util.Date | getClosedOutDate()
java.lang.String | getClosedOutPrivateNotes()
java.util.Date | getDueDate()
java.lang.String | getEnterBy()
java.lang.String | getNcode()
java.util.Date | getNcrDate()
java.lang.String | getNcrNumber()
BB2Part | getPart()
java.lang.String | getPartDescription()
java.math.BigDecimal | getPartPutBackToStock()
java.math.BigDecimal | getPartsPulledFromStock()
java.lang.String | getPoNumber()
java.lang.String | getProblemDescription()
java.lang.String | getProblemDisposition()
java.math.BigDecimal | getQtyInspected()
java.math.BigDecimal | getQtyRejected()
java.math.BigDecimal | getQtyScraped()
java.lang.String | getResponsibility()
java.lang.String | getRtvNumber()
java.lang.String | getSoNumber()
java.lang.String | getStatus()
java.lang.String | getVendorId()
java.lang.String | getWoNumber()
void | setApprovedOpinionEng(java.lang.String approvedOpinionEng)
void | setApprovedOpinionMfg(java.lang.String approvedOpinionMfg)
void | setApprovedOpinionQa(java.lang.String approvedOpinionQa)
void | setBuyer(java.lang.String buyer)
void | setClosedOutDate(java.util.Date closedOutDate)
void | setClosedOutPrivateNotes(java.lang.String closedOutPrivateNotes)
void | setDueDate(java.util.Date dueDate)
void | setEnterBy(java.lang.String enterBy)
void | setNcode(java.lang.String ncode)
void | setNcrDate(java.util.Date ncrDate)
void | setNcrNumber(java.lang.String ncrNumber)
void | setPart(BB2Part part)
void | setPartDescription(java.lang.String partDescription)
void | setPartPutBackToStock(java.math.BigDecimal partPutBackToStock)
void | setPartsPulledFromStock(java.math.BigDecimal partsPulledFromStock)
void | setPoNumber(java.lang.String poNumber)
void | setProblemDescription(java.lang.String problemDescription)
void | setProblemDisposition(java.lang.String problemDisposition)
void | setQtyInspected(java.math.BigDecimal qtyInspected)
void | setQtyRejected(java.math.BigDecimal qtyRejected)
void | setQtyScraped(java.math.BigDecimal qtyScraped)
void | setResponsibility(java.lang.String responsibility)
void | setRtvNumber(java.lang.String rtvNumber)
void | setSoNumber(java.lang.String soNumber)
void | setStatus(java.lang.String status)
void | setVendorId(java.lang.String vendorId)
void | setWoNumber(java.lang.String woNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_NCRNUMBER

public static final java.lang.String ORDER_BY_NCRNUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_PART

public static final java.lang.String ORDER_BY_PART
See Also:
Constant Field Values

ORDER_BY_NCRDATE

public static final java.lang.String ORDER_BY_NCRDATE
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_PONUMBER

public static final java.lang.String ORDER_BY_PONUMBER
See Also:
Constant Field Values

ORDER_BY_WONUMBER

public static final java.lang.String ORDER_BY_WONUMBER
See Also:
Constant Field Values

ORDER_BY_SONUMBER

public static final java.lang.String ORDER_BY_SONUMBER
See Also:
Constant Field Values

ORDER_BY_ENTERBY

public static final java.lang.String ORDER_BY_ENTERBY
See Also:
Constant Field Values

ORDER_BY_RESPONSIBILITY

public static final java.lang.String ORDER_BY_RESPONSIBILITY
See Also:
Constant Field Values

ORDER_BY_DUEDATE

public static final java.lang.String ORDER_BY_DUEDATE
See Also:
Constant Field Values

ORDER_BY_CLOSEDOUTDATE

public static final java.lang.String ORDER_BY_CLOSEDOUTDATE
See Also:
Constant Field Values

ORDER_BY_PROBLEMDESCRIPTION

public static final java.lang.String ORDER_BY_PROBLEMDESCRIPTION
See Also:
Constant Field Values

ORDER_BY_PROBLEMDISPOSITION

public static final java.lang.String ORDER_BY_PROBLEMDISPOSITION
See Also:
Constant Field Values

ORDER_BY_CLOSEDOUTPRIVATENOTES

public static final java.lang.String ORDER_BY_CLOSEDOUTPRIVATENOTES
See Also:
Constant Field Values

ORDER_BY_RTVNUMBER

public static final java.lang.String ORDER_BY_RTVNUMBER
See Also:
Constant Field Values

ORDER_BY_BUYER

public static final java.lang.String ORDER_BY_BUYER
See Also:
Constant Field Values

ORDER_BY_APPROVEDOPINIONQA

public static final java.lang.String ORDER_BY_APPROVEDOPINIONQA
See Also:
Constant Field Values

ORDER_BY_APPROVEDOPINIONENG

public static final java.lang.String ORDER_BY_APPROVEDOPINIONENG
See Also:
Constant Field Values

ORDER_BY_APPROVEDOPINIONMFG

public static final java.lang.String ORDER_BY_APPROVEDOPINIONMFG
See Also:
Constant Field Values
Constructor Detail

NcrReportListResult

public NcrReportListResult()
Method Detail

setNcrNumber

public void setNcrNumber(java.lang.String ncrNumber)

setVendorId

public void setVendorId(java.lang.String vendorId)

setWoNumber

public void setWoNumber(java.lang.String woNumber)

setSoNumber

public void setSoNumber(java.lang.String soNumber)

setPoNumber

public void setPoNumber(java.lang.String poNumber)

setNcode

public void setNcode(java.lang.String ncode)

setPart

public void setPart(BB2Part part)

setQtyInspected

public void setQtyInspected(java.math.BigDecimal qtyInspected)

setQtyScraped

public void setQtyScraped(java.math.BigDecimal qtyScraped)

setQtyRejected

public void setQtyRejected(java.math.BigDecimal qtyRejected)

setNcrDate

public void setNcrDate(java.util.Date ncrDate)

setEnterBy

public void setEnterBy(java.lang.String enterBy)

setStatus

public void setStatus(java.lang.String status)

getNcrNumber

public java.lang.String getNcrNumber()

getVendorId

public java.lang.String getVendorId()

getWoNumber

public java.lang.String getWoNumber()

getSoNumber

public java.lang.String getSoNumber()

getPoNumber

public java.lang.String getPoNumber()

getNcode

public java.lang.String getNcode()

getPart

public BB2Part getPart()

getQtyInspected

public java.math.BigDecimal getQtyInspected()

getQtyScraped

public java.math.BigDecimal getQtyScraped()

getQtyRejected

public java.math.BigDecimal getQtyRejected()

getNcrDate

public java.util.Date getNcrDate()

getEnterBy

public java.lang.String getEnterBy()

getStatus

public java.lang.String getStatus()

getResponsibility

public java.lang.String getResponsibility()

setResponsibility

public void setResponsibility(java.lang.String responsibility)

getClosedOutDate

public java.util.Date getClosedOutDate()

setClosedOutDate

public void setClosedOutDate(java.util.Date closedOutDate)

getDueDate

public java.util.Date getDueDate()

setDueDate

public void setDueDate(java.util.Date dueDate)

getPartsPulledFromStock

public java.math.BigDecimal getPartsPulledFromStock()

setPartsPulledFromStock

public void setPartsPulledFromStock(java.math.BigDecimal partsPulledFromStock)

getPartPutBackToStock

public java.math.BigDecimal getPartPutBackToStock()

setPartPutBackToStock

public void setPartPutBackToStock(java.math.BigDecimal partPutBackToStock)

getPartDescription

public java.lang.String getPartDescription()

setPartDescription

public void setPartDescription(java.lang.String partDescription)

getRtvNumber

public java.lang.String getRtvNumber()

setRtvNumber

public void setRtvNumber(java.lang.String rtvNumber)

getClosedOutPrivateNotes

public java.lang.String getClosedOutPrivateNotes()

setClosedOutPrivateNotes

public void setClosedOutPrivateNotes(java.lang.String closedOutPrivateNotes)

getProblemDescription

public java.lang.String getProblemDescription()

setProblemDescription

public void setProblemDescription(java.lang.String problemDescription)

getProblemDisposition

public java.lang.String getProblemDisposition()

setProblemDisposition

public void setProblemDisposition(java.lang.String problemDisposition)

getBuyer

public java.lang.String getBuyer()

setBuyer

public void setBuyer(java.lang.String buyer)

getApprovedOpinionEng

public java.lang.String getApprovedOpinionEng()

setApprovedOpinionEng

public void setApprovedOpinionEng(java.lang.String approvedOpinionEng)

getApprovedOpinionMfg

public java.lang.String getApprovedOpinionMfg()

setApprovedOpinionMfg

public void setApprovedOpinionMfg(java.lang.String approvedOpinionMfg)

getApprovedOpinionQa

public java.lang.String getApprovedOpinionQa()

setApprovedOpinionQa

public void setApprovedOpinionQa(java.lang.String approvedOpinionQa)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NcrScrapAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class NcrScrapAgent

java.lang.Object
    extended by  bb.common.NcrScrapAgent
All Implemented Interfaces:
java.io.Serializable
public class NcrScrapAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
NcrScrapAgent()
Method Summary
java.lang.String | getCredit()
java.lang.String | getCreditText()
java.lang.String | getDebit()
java.lang.String | getDebitText()
java.lang.String | getGlSummary()
java.lang.String | getNcrNumber()
java.math.BigDecimal | getQty()
void | setCredit(java.lang.String credit)
void | setCreditText(java.lang.String creditText)
void | setDebit(java.lang.String debit)
void | setDebitText(java.lang.String debitText)
void | setGlSummary(java.lang.String glSummary)
void | setNcrNumber(java.lang.String ncrNumber)
void | setQty(java.math.BigDecimal qty)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NcrScrapAgent

public NcrScrapAgent()
Method Detail

getCredit

public java.lang.String getCredit()

setCredit

public void setCredit(java.lang.String credit)

getDebit

public java.lang.String getDebit()

setDebit

public void setDebit(java.lang.String debit)

getGlSummary

public java.lang.String getGlSummary()

setGlSummary

public void setGlSummary(java.lang.String glSummary)

getNcrNumber

public java.lang.String getNcrNumber()

setNcrNumber

public void setNcrNumber(java.lang.String ncrNumber)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

getDebitText

public java.lang.String getDebitText()

setDebitText

public void setDebitText(java.lang.String debitText)

getCreditText

public java.lang.String getCreditText()

setCreditText

public void setCreditText(java.lang.String creditText)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


N-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M N O P Q R S T U V W X Y Z

N

N - Static variable in class bb.common.Constant.Prefix
N - Static variable in class bb.common.Constant.YesNO
n - Static variable in class bb.common.WorkCenterLoadAgent
NA - Static variable in class bb.common.Constant
NA_PART_NUMBER_CAN_NOT_ALLOW - Static variable in class bb.common.BIZReason
NCQRejectResult - Class in bb.common
NCQRejectResult() - Constructor for class bb.common.NCQRejectResult
default constructor
NCR - Static variable in class bb.common.BizTarget
NCR - Static variable in class bb.common.Constant.NoticeType
NCR - Static variable in class bb.common.Constant.Prefix
NCR - Static variable in class bb.common.Constant.ReceivedTo
NCR_ALREADY_EXIST - Static variable in class bb.common.BIZReason
NCR_APPROVAL - Static variable in class bb.common.BizTarget
NCR_APPROVAL_ALREADY_EXIST - Static variable in class bb.common.BIZReason
NCR_APPROVAL_ENG_ALREADY_EXIST - Static variable in class bb.common.BIZReason
NCR_APPROVAL_MFG_ALREADY_EXIST - Static variable in class bb.common.BIZReason
NCR_APPROVAL_NOT_EXIST - Static variable in class bb.common.BIZReason
NCR_APPROVAL_QA_ALREADY_EXIST - Static variable in class bb.common.BIZReason
NCR_APPROVED_BY_CAN_NOT_BE_EMPTY - Static variable in class bb.common.BIZReason
NCR_FILE - Static variable in class bb.common.Constant.MiscDocType
NCR_HAS_NO_IN_QA_QTY_TO_SCRAP - Static variable in class bb.common.BIZReason
NCR_IN_QA_COST_CAN_NOT_BE_ZERO - Static variable in class bb.common.BIZReason
NCR_NOT_EXIST - Static variable in class bb.common.BIZReason
NCR_PART_IN_DEAL_QTY_ALREADY_BIGGER_THAN_TOTAL_QTY - Static variable in class bb.common.BIZReason
NCR_PARTNUMBER_CANNOT_BE_CHANGED - Static variable in class bb.common.BIZReason
NCR_SCRAP_QTY_CAN_NOT_BE_ZERO - Static variable in class bb.common.BIZReason
NCR_SCRAP_QTY_MORE_THAN_IN_QA_QTY - Static variable in class bb.common.BIZReason
NCR_SCRAP_QTY_MORE_THAN_PULLED_QTY - Static variable in class bb.common.BIZReason
NCR_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY - Static variable in class bb.common.BIZReason
NcrApprovalPK - Class in bb.common
NcrApprovalPK() - Constructor for class bb.common.NcrApprovalPK
NcrApprovalPK(String, String) - Constructor for class bb.common.NcrApprovalPK
NcrApprovalVO - Class in bb.common
NcrApprovalVO() - Constructor for class bb.common.NcrApprovalVO
NCRDATE - Static variable in class bb.common.Constant.DateType
NcrNeedToScrapListResult - Class in bb.common
NcrNeedToScrapListResult() - Constructor for class bb.common.NcrNeedToScrapListResult
NCRPartOnhandPK - Class in bb.common
NCRPartOnhandPK() - Constructor for class bb.common.NCRPartOnhandPK
NCRPartOnhandPK(PartOnhandPK, String) - Constructor for class bb.common.NCRPartOnhandPK
NCRPartOnhandPK(PartOnhandPK, String, int) - Constructor for class bb.common.NCRPartOnhandPK
NCRPictureListResult - Class in bb.common
NCRPictureListResult() - Constructor for class bb.common.NCRPictureListResult
NCRPictureVO - Class in bb.common
NCRPictureVO() - Constructor for class bb.common.NCRPictureVO
NcrReportListResult - Class in bb.common
NcrReportListResult() - Constructor for class bb.common.NcrReportListResult
NCRSCRAP - Static variable in class bb.common.Constant.GLApprovedType
NcrScrapAgent - Class in bb.common
NcrScrapAgent() - Constructor for class bb.common.NcrScrapAgent
NEED_TO_CREATE_NEXT_FISCAL_YEAR - Static variable in class bb.common.BIZReason
NEGATIVE - Static variable in class bb.common.Constant.PAOffsetType
NetPrice - Static variable in class bb.common.Constant.ARDiscountMethod
New - Static variable in class bb.common.Constant.Status
NEW_FISCAL_YEAR_SETTINGS_CLOSED - Static variable in class bb.common.BIZReason
NEW_QTY_RECEIVED_IS_MORE_THAN_QTY_SHORTAGE - Static variable in class bb.common.BIZReason
NEW_TRANSACTION_ARE_FUTURE_DATE - Static variable in class bb.common.BIZReason
NEW_TRANSACTION_DATE_LOCKED - Static variable in class bb.common.BIZReason
NEW_TRANSACTION_DATE_OVER_GL_NDAYS_OK_OLD - Static variable in class bb.common.BIZReason
NewPart - Static variable in class bb.common.Constant
NINELEVEL - Static variable in class bb.common.Constant.AgeLevel
NINELEVEL - Static variable in class bb.common.Constant.WorkLevel
no - Static variable in class bb.common.Constant.ActiveStatus
NO - Static variable in class bb.common.Constant.YesNO
NO_CUSTOMER_IS_CHOISE - Static variable in class bb.common.BIZReason
NO_DAMAGE_NOTICE - Static variable in class bb.common.Constant.ReceiveCondition
NO_ITEM_TO_TRANSFER - Static variable in class bb.common.BIZReason
NO_OPEN_SALES_ORDER_FOUND - Static variable in class bb.common.BIZReason
NO_PERMISSION_TO_UPDATE_CLOSED_ORDER - Static variable in class bb.common.BIZReason
NO_RECEIVERS - Static variable in class bb.common.BIZReason
NO_RIGHT_WORK_INSTRUCTION_SET_ID - Static variable in class bb.common.BIZReason
NO_SELECT_OBJECT - Static variable in class bb.common.BIZReason
NO_SUCH_ORDER - Static variable in class bb.common.BIZReason
NO_WAREHOUSE_FOR_LOCATION - Static variable in class bb.common.BIZReason
NO_WORK_INSTRUCTION_SEQUENCES - Static variable in class bb.common.BIZReason
NoAuthorization - Static variable in class bb.common.Constant.Download
NoAuthorization - Static variable in class bb.common.Constant.Upload
NON_CONFORMANCE_CODE - Static variable in class bb.common.BizTarget
NON_CONFORMANCE_CODE_ALREADY_EXIST - Static variable in class bb.common.BIZReason
NON_CONFORMANCE_CODE_DESCRIPTION_CANNOT_BE_EMPTY - Static variable in class bb.common.BIZReason
NON_CONFORMANCE_CODE_NOT_EXIST - Static variable in class bb.common.BIZReason
NonConformanceCodeDescriptionPK - Class in bb.common
NonConformanceCodeDescriptionPK() - Constructor for class bb.common.NonConformanceCodeDescriptionPK
NonConformanceCodeDescriptionPK(String, String) - Constructor for class bb.common.NonConformanceCodeDescriptionPK
NonConformanceCodeDescriptionVO - Class in bb.common
NonConformanceCodeDescriptionVO() - Constructor for class bb.common.NonConformanceCodeDescriptionVO
default constructor
NonConformanceCodeDescriptionVO(NonConformanceCodeDescriptionPK, String) - Constructor for class bb.common.NonConformanceCodeDescriptionVO
minimal constructor
NonConformanceCodeVO - Class in bb.common
NonConformanceCodeVO() - Constructor for class bb.common.NonConformanceCodeVO
default constructor
NonConformanceCodeVO(String, String, String) - Constructor for class bb.common.NonConformanceCodeVO
minimal constructor
NonConformanceQuantityPK - Class in bb.common
NonConformanceQuantityPK(String, Integer) - Constructor for class bb.common.NonConformanceQuantityPK
full constructor
NonConformanceQuantityPK() - Constructor for class bb.common.NonConformanceQuantityPK
default constructor
NonConformanceQuantityVO - Class in bb.common
NonConformanceQuantityVO(NonConformanceQuantityPK, BigDecimal, String, NonConformanceCodeVO, NonConformanceReportVO) - Constructor for class bb.common.NonConformanceQuantityVO
full constructor
NonConformanceQuantityVO() - Constructor for class bb.common.NonConformanceQuantityVO
default constructor
NonConformanceQuantityVO(NonConformanceQuantityPK, BigDecimal, String) - Constructor for class bb.common.NonConformanceQuantityVO
minimal constructor
NonConformanceReportResult - Class in bb.common
NonConformanceReportResult() - Constructor for class bb.common.NonConformanceReportResult
default constructor
NonConformanceReportVO - Class in bb.common
NonConformanceReportVO() - Constructor for class bb.common.NonConformanceReportVO
default constructor
NonConformanceReportVO(String, Date, String, String, Date, String, String, String, BigDecimal, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Date, String, String, String, BigDecimal, Date, BigDecimal, Date, String, String, Date, String, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, Set) - Constructor for class bb.common.NonConformanceReportVO
minimal constructor
NONE - Static variable in class bb.common.Constant.YesNO
NONPRODUCTIVE_PICKING - Static variable in class bb.common.BizTarget
NONPRODUCTIVE_PICKING_APPROVAL - Static variable in class bb.common.BizTarget
NONPRODUCTIVE_PICKING_APPROVAL_ALREADY_ADDED - Static variable in class bb.common.BIZReason
NONPRODUCTIVE_PICKING_APPROVAL_NOT_EXIST - Static variable in class bb.common.BIZReason
NONPRODUCTIVE_PICKING_ITEM_ISSUE - Static variable in class bb.common.BizTarget
NONPRODUCTIVE_PICKING_NOT_EXIST - Static variable in class bb.common.BIZReason
NONPRODUCTIVE_PICKING_NOT_OPEN - Static variable in class bb.common.BIZReason
NONPRODUCTIVE_PICKING_TYPE - Static variable in class bb.common.BizTarget
NONPRODUCTIVE_PICKING_TYPE_ALREADY_ADDED - Static variable in class bb.common.BIZReason
NONPRODUCTIVE_PICKING_TYPE_CAN_BE_DELETE - Static variable in class bb.common.BIZReason
NONPRODUCTIVE_PICKING_TYPE_IS_USED - Static variable in class bb.common.BIZReason
NONPRODUCTIVE_PICKING_TYPE_NOT_EXIST - Static variable in class bb.common.BIZReason
NonproductivePickingApprovalVO - Class in bb.common
NonproductivePickingApprovalVO() - Constructor for class bb.common.NonproductivePickingApprovalVO
NonproductivePickingApproveVO - Class in bb.common
NonproductivePickingApproveVO() - Constructor for class bb.common.NonproductivePickingApproveVO
NonproductivePickingItemIssuedListResult - Class in bb.common
NonproductivePickingItemIssuedListResult() - Constructor for class bb.common.NonproductivePickingItemIssuedListResult
NonproductivePickingItemIssuedVO - Class in bb.common
NonproductivePickingItemIssuedVO() - Constructor for class bb.common.NonproductivePickingItemIssuedVO
NonproductivePickingItemPK - Class in bb.common
NonproductivePickingItemPK() - Constructor for class bb.common.NonproductivePickingItemPK
NonproductivePickingItemPK(String, String) - Constructor for class bb.common.NonproductivePickingItemPK
NonproductivePickingItemResult - Class in bb.common
NonproductivePickingItemResult() - Constructor for class bb.common.NonproductivePickingItemResult
NonproductivePickingItemVO - Class in bb.common
NonproductivePickingItemVO() - Constructor for class bb.common.NonproductivePickingItemVO
NonproductivePickingOnDemandResult - Class in bb.common
NonproductivePickingOnDemandResult() - Constructor for class bb.common.NonproductivePickingOnDemandResult
NonproductivePickingTypeVO - Class in bb.common
NonproductivePickingTypeVO() - Constructor for class bb.common.NonproductivePickingTypeVO
NonproductivePickingVO - Class in bb.common
NonproductivePickingVO() - Constructor for class bb.common.NonproductivePickingVO
NOT_APPROVED_GL_CAN_NOT_POST - Static variable in class bb.common.BIZReason
NOT_APPROVED_GL_TO_CANCEL - Static variable in class bb.common.BIZReason
NOT_APPROVED_OBJECT_ONLY_ALLOW_UPDATE - Static variable in class bb.common.BIZReason
NOT_APPROVED_REQUEST_FOR_QUOTE_IS_NOT_ALLOWED_TO_PURCHASE_ORDER - Static variable in class bb.common.BIZReason
NOT_APPROVED_WORK_ORDER_ITEM_WILL_BE_SETUP - Static variable in class bb.common.BIZReason
NOT_AUTHORIZED_APPROVER - Static variable in class bb.common.BIZReason
NOT_AUTHORIZED_APPROVER_TO_APPROVE_SELF - Static variable in class bb.common.BIZReason
NOT_CHARACTER - Static variable in class bb.common.BIZReason
NOT_CHECKED - Static variable in class bb.common.Constant.ReceiveCondition
NOT_DIGDECIMAL - Static variable in class bb.common.BIZReason
NOT_ENOUGH_ONHAND - Static variable in class bb.common.BIZReason
NOT_EQUALS - Static variable in class bb.common.BIZReason
NOT_EXIST_ITEM_TO_RECEIVE_OR_SHIP - Static variable in class bb.common.BIZReason
NOT_FOUND_APPROVED_BY_IN_SETTINGS - Static variable in class bb.common.BIZReason
NOT_FOUND_TAX_RATE_ACCOUNT - Static variable in class bb.common.BIZReason
NOT_GROUP_ISSUE_ITEM_AGENT_ITEM_NUMBER_NOT_RIGHT - Static variable in class bb.common.BIZReason
NOT_IDENTITY_EMPLOYEE_ID - Static variable in class bb.common.BIZReason
NOT_INVOICE_NUMBER - Static variable in class bb.common.BIZReason
NOT_LETTER - Static variable in class bb.common.BIZReason
NOT_MATCH_BIZBOX_USER_EXIST - Static variable in class bb.common.BIZReason
NOT_MATCH_EMPLOYEE_ID_WITH_BIZBOX_USER - Static variable in class bb.common.BIZReason
NOT_MATCH_OWNER_NAME_WITH_SHIP_LIST_OWNER - Static variable in class bb.common.BIZReason
NOT_MATCH_PART_WiTH_SALES_ORDER_ITEM - Static variable in class bb.common.BIZReason
NOT_MATCH_PART_WiTH_WORK_ORDER_ITEM - Static variable in class bb.common.BIZReason
NOT_MATCH_SHIP_LIST_NUMBER_WITH_SHIP_LIST - Static variable in class bb.common.BIZReason
NOT_NUMBER - Static variable in class bb.common.BIZReason
NOT_NUMBER_STRING - Static variable in class bb.common.BIZReason
NOT_OBJECT_TO_APPROVED - Static variable in class bb.common.BIZReason
NOT_OPEN_NCR_TO_SHIP - Static variable in class bb.common.BIZReason
NOT_OPEN_SALES_ORDER_ITEM_ADD_TO_SHIPPER - Static variable in class bb.common.BIZReason
NOT_OPEN_SALES_ORDER_ITEM_TO_SHIP - Static variable in class bb.common.BIZReason
NOT_OPEN_SALES_ORDER_TO_MAKE_SHIPPER - Static variable in class bb.common.BIZReason
NOT_OPEN_SALES_ORDER_TO_SHIP - Static variable in class bb.common.BIZReason
NOT_OPEN_WORK_ORDER_ITEM_TO_ISSUE_PART - Static variable in class bb.common.BIZReason
NOT_OPEN_WORK_ORDER_TO_ISSUE_PART - Static variable in class bb.common.BIZReason
NOT_RIGHT_AP_PREPAY_ITEM - Static variable in class bb.common.BIZReason
NOT_RIGHT_AR_PREPAY_ITEM - Static variable in class bb.common.BIZReason
NOT_RIGHT_BOM_ITEM - Static variable in class bb.common.BIZReason
NOT_RIGHT_DESIGN_CONTROL_NUMBER_OF_DOCUMENT - Static variable in class bb.common.BIZReason
NOT_RIGHT_MANUFACTURERS_GROUP_FORMAT - Static variable in class bb.common.BIZReason
NOT_RIGHT_PACKING_BOX_NUMBER - Static variable in class bb.common.BIZReason
NOT_RIGHT_PART_TRACEABLE_CATEGORY_ITEM - Static variable in class bb.common.BIZReason
NOT_RIGHT_PART_TRACEABLE_SPECIFICATION_ITEM - Static variable in class bb.common.BIZReason
NOT_RIGHT_PROFORMA_INVOICE_NUMBER - Static variable in class bb.common.BIZReason
NOT_RIGHT_PURCHASE_ORDER_ITEM - Static variable in class bb.common.BIZReason
NOT_RIGHT_PURCHASE_ORDER_ITEM_MANUFACTURER - Static variable in class bb.common.BIZReason
NOT_RIGHT_PURCHASE_ORDER_MESSAGE_ITEM - Static variable in class bb.common.BIZReason
NOT_RIGHT_PURCHASE_WORK_SHEET_ITEM - Static variable in class bb.common.BIZReason
NOT_RIGHT_REQUEST_FOR_QUOTE_ITEM - Static variable in class bb.common.BIZReason
NOT_RIGHT_REQUEST_FOR_QUOTE_ITEM_MANUFACTURER - Static variable in class bb.common.BIZReason
NOT_RIGHT_RETURN_MATERIAL_AUTHORIZATION_ITEM_MANUFACTURER - Static variable in class bb.common.BIZReason
NOT_RIGHT_RETURN_TO_VENDOR_ITEM - Static variable in class bb.common.BIZReason
NOT_RIGHT_RETURN_TO_VENDOR_ITEM_MANUFACTURER - Static variable in class bb.common.BIZReason
NOT_RIGHT_RFQ_MESSAGE_ITEM - Static variable in class bb.common.BIZReason
NOT_RIGHT_SALES_ORDER_ADD_TO_SHIPPER - Static variable in class bb.common.BIZReason
NOT_RIGHT_SALES_ORDER_ITEM_ADD_TO_SHIPPER - Static variable in class bb.common.BIZReason
NOT_RIGHT_SPECIFY_FOR_WHAT_TO_ADD_TYPE - Static variable in class bb.common.BIZReason
NOT_RIGHT_VENDORS_GROUP_FORMAT - Static variable in class bb.common.BIZReason
NOT_RIGHT_WORK_ORDER_ITEM - Static variable in class bb.common.BIZReason
NOT_RIGHT_WORK_ORDER_WORK_INSTRUCTION_SEQUENCE - Static variable in class bb.common.BIZReason
NOT_RIGHT_WORK_WORK_SHEET_ITEM - Static variable in class bb.common.BIZReason
NOT_SAME_ADDRESS_ID_WITH_PROFROMA_INVOICE - Static variable in class bb.common.BIZReason
NOT_SAME_PART_FROM - Static variable in class bb.common.BIZReason
NOT_STRING - Static variable in class bb.common.BIZReason
NotAccepted - Static variable in class bb.common.Constant.Status
NotAcknowledged - Static variable in class bb.common.Constant.Status
NotApproved - Static variable in class bb.common.Constant.Status
NOTCLEARED - Static variable in class bb.common.Constant.Status
NOTICE_USER - Static variable in class bb.common.BizTarget
NOTICE_USER_EXIST - Static variable in class bb.common.BIZReason
NOTICE_USER_NOT_EXIST - Static variable in class bb.common.BIZReason
NoticeUserEmployeeListResult - Class in bb.common
NoticeUserEmployeeListResult() - Constructor for class bb.common.NoticeUserEmployeeListResult
NotReviewed - Static variable in class bb.common.Constant.Status
NotSetUp - Static variable in class bb.common.Constant.Status
NotWriteOffed - Static variable in class bb.common.Constant.Status
NoUsage - Static variable in class bb.common.MrpReportAgent
NUMBER_CAN_NOT_BE_ZERO - Static variable in class bb.common.BIZReason
NUMBER_CAN_NOT_LESS_THEN_ZERO - Static variable in class bb.common.BIZReason
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M N O P Q R S T U V W X Y Z


NonConformanceCodeDescriptionPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class NonConformanceCodeDescriptionPK

java.lang.Object
    extended by  bb.common.NonConformanceCodeDescriptionPK
All Implemented Interfaces:
java.io.Serializable
public class NonConformanceCodeDescriptionPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
NonConformanceCodeDescriptionPK()
NonConformanceCodeDescriptionPK(java.lang.String code, java.lang.String language)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCode()
java.lang.String | getLanguage()
int | hashCode()
void | setCode(java.lang.String code)
void | setLanguage(java.lang.String language)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

NonConformanceCodeDescriptionPK

public NonConformanceCodeDescriptionPK()

NonConformanceCodeDescriptionPK

public NonConformanceCodeDescriptionPK(java.lang.String code,
                                       java.lang.String language)
Method Detail

getCode

public java.lang.String getCode()

setCode

public void setCode(java.lang.String code)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NonConformanceCodeDescriptionVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class NonConformanceCodeDescriptionVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.NonConformanceCodeDescriptionVO
All Implemented Interfaces:
java.io.Serializable
public class NonConformanceCodeDescriptionVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
NonConformanceCodeDescriptionVO()
default constructor
NonConformanceCodeDescriptionVO(NonConformanceCodeDescriptionPK pk, java.lang.String description)
minimal constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDescription()
NonConformanceCodeDescriptionPK | getPk()
int | hashCode()
void | setDescription(java.lang.String description)
void | setPk(NonConformanceCodeDescriptionPK pk)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NonConformanceCodeDescriptionVO

public NonConformanceCodeDescriptionVO()
default constructor

NonConformanceCodeDescriptionVO

public NonConformanceCodeDescriptionVO(NonConformanceCodeDescriptionPK pk,
                                       java.lang.String description)
minimal constructor

Method Detail

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getPk

public NonConformanceCodeDescriptionPK getPk()

setPk

public void setPk(NonConformanceCodeDescriptionPK pk)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NonConformanceCodeVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class NonConformanceCodeVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.NonConformanceCodeVO
All Implemented Interfaces:
java.io.Serializable
public class NonConformanceCodeVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CODE
static java.lang.String | ORDER_BY_LASTCHANGEDATE
static java.lang.String | ORDER_BY_LASTCHANGEUSER
static java.lang.String | ORDER_BY_ORIGIN
Constructor Summary
NonConformanceCodeVO()
default constructor
NonConformanceCodeVO(java.lang.String code, java.lang.String lastChangeUser, java.lang.String origin)
minimal constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.lang.String | getCode()
java.util.Set<NonConformanceCodeDescriptionVO> | getDescriptions()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getLocalDescription()
java.lang.String | getOrigin()
java.lang.Integer | getVersion()
int | hashCode()
void | setAdate(java.util.Date adate)
void | setCode(java.lang.String code)
void | setDescriptions(java.util.Set<NonConformanceCodeDescriptionVO> descriptions)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLocalDescription(java.lang.String localDescription)
void | setOrigin(java.lang.String origin)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_CODE

public static final java.lang.String ORDER_BY_CODE
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEDATE

public static final java.lang.String ORDER_BY_LASTCHANGEDATE
See Also:
Constant Field Values

ORDER_BY_ORIGIN

public static final java.lang.String ORDER_BY_ORIGIN
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEUSER

public static final java.lang.String ORDER_BY_LASTCHANGEUSER
See Also:
Constant Field Values
Constructor Detail

NonConformanceCodeVO

public NonConformanceCodeVO()
default constructor

NonConformanceCodeVO

public NonConformanceCodeVO(java.lang.String code,
                            java.lang.String lastChangeUser,
                            java.lang.String origin)
minimal constructor

Method Detail

getCode

public java.lang.String getCode()

setCode

public void setCode(java.lang.String code)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

setVersion

public void setVersion(java.lang.Integer version)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getDescriptions

public java.util.Set<NonConformanceCodeDescriptionVO> getDescriptions()

setDescriptions

public void setDescriptions(java.util.Set<NonConformanceCodeDescriptionVO> descriptions)

getLocalDescription

public java.lang.String getLocalDescription()

setLocalDescription

public void setLocalDescription(java.lang.String localDescription)

getVersion

public java.lang.Integer getVersion()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NonConformanceQuantityPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class NonConformanceQuantityPK

java.lang.Object
    extended by  bb.common.NonConformanceQuantityPK
All Implemented Interfaces:
java.io.Serializable
public class NonConformanceQuantityPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
NonConformanceQuantityPK()
default constructor
NonConformanceQuantityPK(java.lang.String ncrNumber, java.lang.Integer ii)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Integer | getIi()
java.lang.String | getNcrNumber()
int | hashCode()
void | setIi(java.lang.Integer ii)
void | setNcrNumber(java.lang.String ncrNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

NonConformanceQuantityPK

public NonConformanceQuantityPK(java.lang.String ncrNumber,
                                java.lang.Integer ii)
full constructor

NonConformanceQuantityPK

public NonConformanceQuantityPK()
default constructor

Method Detail

getNcrNumber

public java.lang.String getNcrNumber()

setNcrNumber

public void setNcrNumber(java.lang.String ncrNumber)

getIi

public java.lang.Integer getIi()

setIi

public void setIi(java.lang.Integer ii)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NonConformanceQuantityVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class NonConformanceQuantityVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.NonConformanceQuantityVO
All Implemented Interfaces:
java.io.Serializable
public class NonConformanceQuantityVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
NonConformanceQuantityVO()
default constructor
NonConformanceQuantityVO(NonConformanceQuantityPK pk, java.math.BigDecimal rejectQuantity, java.lang.String nonConformanceCode)
minimal constructor
NonConformanceQuantityVO(NonConformanceQuantityPK pk, java.math.BigDecimal rejectQuantity, java.lang.String nonConformanceCode, NonConformanceCodeVO nonConformanceCodeNameVO, NonConformanceReportVO nonConformanceReportVO)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getNonConformanceCode()
NonConformanceCodeVO | getNonConformanceCodeName()
NonConformanceReportVO | getNonConformanceReport()
NonConformanceQuantityPK | getPk()
java.math.BigDecimal | getRejectQuantity()
int | hashCode()
void | setNonConformanceCode(java.lang.String nonConformanceCode)
void | setNonConformanceCodeName(NonConformanceCodeVO nonConformanceCodeNameVO)
void | setNonConformanceReport(NonConformanceReportVO nonConformanceReportVO)
void | setPk(NonConformanceQuantityPK pk)
void | setRejectQuantity(java.math.BigDecimal rejectQuantity)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

NonConformanceQuantityVO

public NonConformanceQuantityVO(NonConformanceQuantityPK pk,
                                java.math.BigDecimal rejectQuantity,
                                java.lang.String nonConformanceCode,
                                NonConformanceCodeVO nonConformanceCodeNameVO,
                                NonConformanceReportVO nonConformanceReportVO)
full constructor

NonConformanceQuantityVO

public NonConformanceQuantityVO()
default constructor

NonConformanceQuantityVO

public NonConformanceQuantityVO(NonConformanceQuantityPK pk,
                                java.math.BigDecimal rejectQuantity,
                                java.lang.String nonConformanceCode)
minimal constructor

Method Detail

getPk

public NonConformanceQuantityPK getPk()

setPk

public void setPk(NonConformanceQuantityPK pk)

getRejectQuantity

public java.math.BigDecimal getRejectQuantity()

setRejectQuantity

public void setRejectQuantity(java.math.BigDecimal rejectQuantity)

getNonConformanceCode

public java.lang.String getNonConformanceCode()

setNonConformanceCode

public void setNonConformanceCode(java.lang.String nonConformanceCode)

getNonConformanceCodeName

public NonConformanceCodeVO getNonConformanceCodeName()

setNonConformanceCodeName

public void setNonConformanceCodeName(NonConformanceCodeVO nonConformanceCodeNameVO)

getNonConformanceReport

public NonConformanceReportVO getNonConformanceReport()

setNonConformanceReport

public void setNonConformanceReport(NonConformanceReportVO nonConformanceReportVO)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NonConformanceReportResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class NonConformanceReportResult

java.lang.Object
    extended by  bb.common.NonConformanceReportResult
All Implemented Interfaces:
java.io.Serializable
public class NonConformanceReportResult
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
NonConformanceReportResult()
default constructor
Method Summary
java.math.BigDecimal | getAverageCost()
java.math.BigDecimal | getPartPutBackToStock()
java.math.BigDecimal | getPartsPulledFromStock()
void | setAverageCost(java.math.BigDecimal averageCost)
void | setPartPutBackToStock(java.math.BigDecimal partPutBackToStock)
void | setPartsPulledFromStock(java.math.BigDecimal partsPulledFromStock)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NonConformanceReportResult

public NonConformanceReportResult()
default constructor

Method Detail

getPartPutBackToStock

public java.math.BigDecimal getPartPutBackToStock()

setPartPutBackToStock

public void setPartPutBackToStock(java.math.BigDecimal partPutBackToStock)

getAverageCost

public java.math.BigDecimal getAverageCost()

setAverageCost

public void setAverageCost(java.math.BigDecimal averageCost)

getPartsPulledFromStock

public java.math.BigDecimal getPartsPulledFromStock()

setPartsPulledFromStock

public void setPartsPulledFromStock(java.math.BigDecimal partsPulledFromStock)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NonConformanceReportVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class NonConformanceReportVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.NonConformanceReportVO
All Implemented Interfaces:
java.io.Serializable
public class NonConformanceReportVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DUEDATE
static java.lang.String | ORDER_BY_NCRDATE
static java.lang.String | ORDER_BY_NCRNUMBER
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_VENDORID
Constructor Summary
NonConformanceReportVO()
default constructor
NonConformanceReportVO(java.lang.String ncrNumber, java.util.Date dueDate, java.lang.String lastChangeUser, java.lang.String origin, java.util.Date ncrDate, java.lang.String enteredBy, java.lang.String status, java.lang.String vendorId, java.math.BigDecimal inspectedQty, java.lang.String partNumber, java.lang.String partType, java.lang.String modelNumber, java.lang.String partRevision, java.lang.String partDescription, java.lang.String partSerialNumber, java.lang.String purchaseOrderNumber, java.lang.String qr, java.lang.String receiverNumber, java.lang.String workOrderNumber, java.lang.String salesOrderNumber, java.lang.String rtvNumber, java.lang.String rmaNumber, java.lang.String refDoc1, java.lang.String refDoc2, java.lang.String refAcct, java.lang.String problemDescription, java.lang.String xrework, java.lang.String xwaiver, java.lang.String xregrade, java.lang.String xreject, java.lang.String xscrap, java.util.Date dispositionDate, java.lang.String dispositionApprovedQa, java.lang.String dispositionApprovedEng, java.lang.String dispositionApprovedMfg, java.math.BigDecimal partsPulledFromStock, java.util.Date partsPulledFromStockDate, java.math.BigDecimal partPutBackToStock, java.util.Date partPutBackToStockDate, java.lang.String qc, java.lang.String closedOutApproval, java.util.Date closedOutDate, java.lang.String closedOutPrivateNotes, java.math.BigDecimal qtyRework, java.math.BigDecimal qtyWaiver, java.math.BigDecimal qtyRegrade, java.math.BigDecimal qtyReject, java.math.BigDecimal qtyScrap, java.util.Set nonConformanceQuantity)
minimal constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.lang.String | getApprovedOpinionEng()
java.lang.String | getApprovedOpinionMfg()
java.lang.String | getApprovedOpinionQa()
java.lang.String | getBuyer()
java.lang.String | getClosedOutApproval()
java.util.Date | getClosedOutDate()
java.lang.String | getClosedOutPrivateNotes()
java.util.Date | getDateApprovedEng()
java.util.Date | getDateApprovedMfg()
java.util.Date | getDateApprovedQa()
java.lang.String | getDispositionApprovedEng()
java.lang.String | getDispositionApprovedMfg()
java.lang.String | getDispositionApprovedQa()
java.util.Date | getDispositionDate()
java.lang.String | getDrawing()
java.util.Date | getDueDate()
java.lang.String | getEnteredBy()
java.math.BigDecimal | getInspectedQty()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getModelNumber()
java.util.Date | getNcrDate()
java.lang.String | getNcrNumber()
java.util.Set | getNcrPictures()
java.util.Set | getNonConformanceQuantity()
java.lang.String | getOrigin()
java.lang.String | getPartDescription()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.math.BigDecimal | getPartPutBackToStock()
java.util.Date | getPartPutBackToStockDate()
java.lang.String | getPartRevision()
java.lang.String | getPartSerialNumber()
java.math.BigDecimal | getPartsPulledFromStock()
java.util.Date | getPartsPulledFromStockDate()
java.lang.String | getPartType()
java.lang.String | getProblemDescription()
java.lang.String | getProblemDisposition()
java.lang.String | getPurchaseOrderNumber()
java.lang.String | getQc()
java.lang.String | getQr()
java.math.BigDecimal | getQtyRegrade()
java.math.BigDecimal | getQtyReject()
java.math.BigDecimal | getQtyRework()
java.math.BigDecimal | getQtyScrap()
java.math.BigDecimal | getQtyWaiver()
java.lang.String | getReceiverNumber()
java.lang.String | getRefAcct()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.lang.String | getResponsibility()
java.lang.String | getRmaNumber()
java.lang.String | getRtvNumber()
java.lang.String | getSalesOrderNumber()
java.lang.String | getStatus()
java.lang.String | getVendorId()
java.lang.Integer | getVersion()
java.lang.String | getWorkOrderNumber()
java.lang.String | getXregrade()
java.lang.String | getXreject()
java.lang.String | getXrework()
java.lang.String | getXscrap()
java.lang.String | getXwaiver()
int | hashCode()
void | setAdate(java.util.Date adate)
void | setApprovedOpinionEng(java.lang.String approvedOpinionEng)
void | setApprovedOpinionMfg(java.lang.String approvedOpinionMfg)
void | setApprovedOpinionQa(java.lang.String approvedOpinionQa)
void | setBuyer(java.lang.String buyer)
void | setClosedOutApproval(java.lang.String closedOutApproval)
void | setClosedOutDate(java.util.Date closedOutDate)
void | setClosedOutPrivateNotes(java.lang.String closedOutPrivateNotes)
void | setDateApprovedEng(java.util.Date dateApprovedEng)
void | setDateApprovedMfg(java.util.Date dateApprovedMfg)
void | setDateApprovedQa(java.util.Date dateApprovedQa)
void | setDispositionApprovedEng(java.lang.String dispositionApprovedEng)
void | setDispositionApprovedMfg(java.lang.String dispositionApprovedMfg)
void | setDispositionApprovedQa(java.lang.String dispositionApprovedQa)
void | setDispositionDate(java.util.Date dispositionDate)
void | setDrawing(java.lang.String drawing)
void | setDueDate(java.util.Date dueDate)
void | setEnteredBy(java.lang.String enteredBy)
void | setInspectedQty(java.math.BigDecimal inspectedQty)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setModelNumber(java.lang.String modelNumber)
void | setNcrDate(java.util.Date ncrDate)
void | setNcrNumber(java.lang.String ncrNumber)
void | setNcrPictures(java.util.Set ncrPictures)
void | setNonConformanceQuantity(java.util.Set nonConformanceQuantity)
void | setOrigin(java.lang.String origin)
void | setPartDescription(java.lang.String partDescription)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartPutBackToStock(java.math.BigDecimal partPutBackToStock)
void | setPartPutBackToStockDate(java.util.Date partPutBackToStockDate)
void | setPartRevision(java.lang.String partRevision)
void | setPartSerialNumber(java.lang.String partSerialNumber)
void | setPartsPulledFromStock(java.math.BigDecimal partsPulledFromStock)
void | setPartsPulledFromStockDate(java.util.Date partsPulledFromStockDate)
void | setPartType(java.lang.String partType)
void | setProblemDescription(java.lang.String problemDescription)
void | setProblemDisposition(java.lang.String problemDisposition)
void | setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)
void | setQc(java.lang.String qc)
void | setQr(java.lang.String qr)
void | setQtyRegrade(java.math.BigDecimal qtyRegrade)
void | setQtyReject(java.math.BigDecimal qtyReject)
void | setQtyRework(java.math.BigDecimal qtyRework)
void | setQtyScrap(java.math.BigDecimal qtyScrap)
void | setQtyWaiver(java.math.BigDecimal qtyWaiver)
void | setReceiverNumber(java.lang.String receiverNumber)
void | setRefAcct(java.lang.String refAcct)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setResponsibility(java.lang.String responsibility)
void | setRmaNumber(java.lang.String rmaNumber)
void | setRtvNumber(java.lang.String rtvNumber)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setStatus(java.lang.String status)
void | setVendorId(java.lang.String vendorId)
void | setVersion(java.lang.Integer version)
void | setWorkOrderNumber(java.lang.String workOrderNumber)
void | setXregrade(java.lang.String xregrade)
void | setXreject(java.lang.String xreject)
void | setXrework(java.lang.String xrework)
void | setXscrap(java.lang.String xscrap)
void | setXwaiver(java.lang.String xwaiver)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_NCRNUMBER

public static final java.lang.String ORDER_BY_NCRNUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_DUEDATE

public static final java.lang.String ORDER_BY_DUEDATE
See Also:
Constant Field Values

ORDER_BY_NCRDATE

public static final java.lang.String ORDER_BY_NCRDATE
See Also:
Constant Field Values
Constructor Detail

NonConformanceReportVO

public NonConformanceReportVO()
default constructor

NonConformanceReportVO

public NonConformanceReportVO(java.lang.String ncrNumber,
                              java.util.Date dueDate,
                              java.lang.String lastChangeUser,
                              java.lang.String origin,
                              java.util.Date ncrDate,
                              java.lang.String enteredBy,
                              java.lang.String status,
                              java.lang.String vendorId,
                              java.math.BigDecimal inspectedQty,
                              java.lang.String partNumber,
                              java.lang.String partType,
                              java.lang.String modelNumber,
                              java.lang.String partRevision,
                              java.lang.String partDescription,
                              java.lang.String partSerialNumber,
                              java.lang.String purchaseOrderNumber,
                              java.lang.String qr,
                              java.lang.String receiverNumber,
                              java.lang.String workOrderNumber,
                              java.lang.String salesOrderNumber,
                              java.lang.String rtvNumber,
                              java.lang.String rmaNumber,
                              java.lang.String refDoc1,
                              java.lang.String refDoc2,
                              java.lang.String refAcct,
                              java.lang.String problemDescription,
                              java.lang.String xrework,
                              java.lang.String xwaiver,
                              java.lang.String xregrade,
                              java.lang.String xreject,
                              java.lang.String xscrap,
                              java.util.Date dispositionDate,
                              java.lang.String dispositionApprovedQa,
                              java.lang.String dispositionApprovedEng,
                              java.lang.String dispositionApprovedMfg,
                              java.math.BigDecimal partsPulledFromStock,
                              java.util.Date partsPulledFromStockDate,
                              java.math.BigDecimal partPutBackToStock,
                              java.util.Date partPutBackToStockDate,
                              java.lang.String qc,
                              java.lang.String closedOutApproval,
                              java.util.Date closedOutDate,
                              java.lang.String closedOutPrivateNotes,
                              java.math.BigDecimal qtyRework,
                              java.math.BigDecimal qtyWaiver,
                              java.math.BigDecimal qtyRegrade,
                              java.math.BigDecimal qtyReject,
                              java.math.BigDecimal qtyScrap,
                              java.util.Set nonConformanceQuantity)
minimal constructor

Method Detail

getNcrNumber

public java.lang.String getNcrNumber()

setNcrNumber

public void setNcrNumber(java.lang.String ncrNumber)

getDueDate

public java.util.Date getDueDate()

setDueDate

public void setDueDate(java.util.Date dueDate)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getNcrDate

public java.util.Date getNcrDate()

setNcrDate

public void setNcrDate(java.util.Date ncrDate)

getEnteredBy

public java.lang.String getEnteredBy()

setEnteredBy

public void setEnteredBy(java.lang.String enteredBy)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getInspectedQty

public java.math.BigDecimal getInspectedQty()

setInspectedQty

public void setInspectedQty(java.math.BigDecimal inspectedQty)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getPartRevision

public java.lang.String getPartRevision()

setPartRevision

public void setPartRevision(java.lang.String partRevision)

getPartDescription

public java.lang.String getPartDescription()

setPartDescription

public void setPartDescription(java.lang.String partDescription)

getPartSerialNumber

public java.lang.String getPartSerialNumber()

setPartSerialNumber

public void setPartSerialNumber(java.lang.String partSerialNumber)

getPurchaseOrderNumber

public java.lang.String getPurchaseOrderNumber()

setPurchaseOrderNumber

public void setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)

getQr

public java.lang.String getQr()

setQr

public void setQr(java.lang.String qr)

getReceiverNumber

public java.lang.String getReceiverNumber()

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)

getWorkOrderNumber

public java.lang.String getWorkOrderNumber()

setWorkOrderNumber

public void setWorkOrderNumber(java.lang.String workOrderNumber)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getRefAcct

public java.lang.String getRefAcct()

setRefAcct

public void setRefAcct(java.lang.String refAcct)

getProblemDescription

public java.lang.String getProblemDescription()

setProblemDescription

public void setProblemDescription(java.lang.String problemDescription)

getXrework

public java.lang.String getXrework()

setXrework

public void setXrework(java.lang.String xrework)

getXwaiver

public java.lang.String getXwaiver()

setXwaiver

public void setXwaiver(java.lang.String xwaiver)

getXregrade

public java.lang.String getXregrade()

setXregrade

public void setXregrade(java.lang.String xregrade)

getXreject

public java.lang.String getXreject()

setXreject

public void setXreject(java.lang.String xreject)

getXscrap

public java.lang.String getXscrap()

setXscrap

public void setXscrap(java.lang.String xscrap)

getDispositionDate

public java.util.Date getDispositionDate()

setDispositionDate

public void setDispositionDate(java.util.Date dispositionDate)

getProblemDisposition

public java.lang.String getProblemDisposition()

setProblemDisposition

public void setProblemDisposition(java.lang.String problemDisposition)

getDispositionApprovedQa

public java.lang.String getDispositionApprovedQa()

setDispositionApprovedQa

public void setDispositionApprovedQa(java.lang.String dispositionApprovedQa)

getDispositionApprovedEng

public java.lang.String getDispositionApprovedEng()

setDispositionApprovedEng

public void setDispositionApprovedEng(java.lang.String dispositionApprovedEng)

getDispositionApprovedMfg

public java.lang.String getDispositionApprovedMfg()

setDispositionApprovedMfg

public void setDispositionApprovedMfg(java.lang.String dispositionApprovedMfg)

getPartsPulledFromStock

public java.math.BigDecimal getPartsPulledFromStock()

setPartsPulledFromStock

public void setPartsPulledFromStock(java.math.BigDecimal partsPulledFromStock)

getPartsPulledFromStockDate

public java.util.Date getPartsPulledFromStockDate()

setPartsPulledFromStockDate

public void setPartsPulledFromStockDate(java.util.Date partsPulledFromStockDate)

getPartPutBackToStock

public java.math.BigDecimal getPartPutBackToStock()

setPartPutBackToStock

public void setPartPutBackToStock(java.math.BigDecimal partPutBackToStock)

getPartPutBackToStockDate

public java.util.Date getPartPutBackToStockDate()

setPartPutBackToStockDate

public void setPartPutBackToStockDate(java.util.Date partPutBackToStockDate)

getQc

public java.lang.String getQc()

setQc

public void setQc(java.lang.String qc)

getClosedOutApproval

public java.lang.String getClosedOutApproval()

setClosedOutApproval

public void setClosedOutApproval(java.lang.String closedOutApproval)

getClosedOutDate

public java.util.Date getClosedOutDate()

setClosedOutDate

public void setClosedOutDate(java.util.Date closedOutDate)

getClosedOutPrivateNotes

public java.lang.String getClosedOutPrivateNotes()

setClosedOutPrivateNotes

public void setClosedOutPrivateNotes(java.lang.String closedOutPrivateNotes)

getQtyRework

public java.math.BigDecimal getQtyRework()

setQtyRework

public void setQtyRework(java.math.BigDecimal qtyRework)

getQtyWaiver

public java.math.BigDecimal getQtyWaiver()

setQtyWaiver

public void setQtyWaiver(java.math.BigDecimal qtyWaiver)

getQtyRegrade

public java.math.BigDecimal getQtyRegrade()

setQtyRegrade

public void setQtyRegrade(java.math.BigDecimal qtyRegrade)

getQtyReject

public java.math.BigDecimal getQtyReject()

setQtyReject

public void setQtyReject(java.math.BigDecimal qtyReject)

getQtyScrap

public java.math.BigDecimal getQtyScrap()

setQtyScrap

public void setQtyScrap(java.math.BigDecimal qtyScrap)

getNonConformanceQuantity

public java.util.Set getNonConformanceQuantity()

getPartFrom

public java.lang.String getPartFrom()

getVersion

public java.lang.Integer getVersion()

getDrawing

public java.lang.String getDrawing()

setNonConformanceQuantity

public void setNonConformanceQuantity(java.util.Set nonConformanceQuantity)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setVersion

public void setVersion(java.lang.Integer version)

setDrawing

public void setDrawing(java.lang.String drawing)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getResponsibility

public java.lang.String getResponsibility()

setResponsibility

public void setResponsibility(java.lang.String responsibility)

getNcrPictures

public java.util.Set getNcrPictures()

setNcrPictures

public void setNcrPictures(java.util.Set ncrPictures)

getDateApprovedEng

public java.util.Date getDateApprovedEng()

setDateApprovedEng

public void setDateApprovedEng(java.util.Date dateApprovedEng)

getDateApprovedMfg

public java.util.Date getDateApprovedMfg()

setDateApprovedMfg

public void setDateApprovedMfg(java.util.Date dateApprovedMfg)

getDateApprovedQa

public java.util.Date getDateApprovedQa()

setDateApprovedQa

public void setDateApprovedQa(java.util.Date dateApprovedQa)

getRmaNumber

public java.lang.String getRmaNumber()

setRmaNumber

public void setRmaNumber(java.lang.String rmaNumber)

getRtvNumber

public java.lang.String getRtvNumber()

setRtvNumber

public void setRtvNumber(java.lang.String rtvNumber)

getBuyer

public java.lang.String getBuyer()

setBuyer

public void setBuyer(java.lang.String buyer)

getApprovedOpinionQa

public java.lang.String getApprovedOpinionQa()

setApprovedOpinionQa

public void setApprovedOpinionQa(java.lang.String approvedOpinionQa)

getApprovedOpinionEng

public java.lang.String getApprovedOpinionEng()

setApprovedOpinionEng

public void setApprovedOpinionEng(java.lang.String approvedOpinionEng)

getApprovedOpinionMfg

public java.lang.String getApprovedOpinionMfg()

setApprovedOpinionMfg

public void setApprovedOpinionMfg(java.lang.String approvedOpinionMfg)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NonproductivePickingApprovalVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class NonproductivePickingApprovalVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.NonproductivePickingApprovalVO
All Implemented Interfaces:
java.io.Serializable
public class NonproductivePickingApprovalVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CANREVIEWOWNNONPROPICKING
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_EMPLOYEEID
static java.lang.String | ORDER_BY_USERNAME
Constructor Summary
NonproductivePickingApprovalVO()
Method Summary
java.lang.String | getComments()
java.lang.String | getEmployeeId()
java.lang.String | getUserName()
boolean | isCanReviewOwnNonproPicking()
void | setCanReviewOwnNonproPicking(boolean canReviewOwnNonproPicking)
void | setComments(java.lang.String comments)
void | setEmployeeId(java.lang.String employeeId)
void | setUserName(java.lang.String userName)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_EMPLOYEEID

public static final java.lang.String ORDER_BY_EMPLOYEEID
See Also:
Constant Field Values

ORDER_BY_USERNAME

public static final java.lang.String ORDER_BY_USERNAME
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values

ORDER_BY_CANREVIEWOWNNONPROPICKING

public static final java.lang.String ORDER_BY_CANREVIEWOWNNONPROPICKING
See Also:
Constant Field Values
Constructor Detail

NonproductivePickingApprovalVO

public NonproductivePickingApprovalVO()
Method Detail

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

isCanReviewOwnNonproPicking

public boolean isCanReviewOwnNonproPicking()

setCanReviewOwnNonproPicking

public void setCanReviewOwnNonproPicking(boolean canReviewOwnNonproPicking)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NonproductivePickingApproveVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class NonproductivePickingApproveVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.NonproductivePickingApproveVO
All Implemented Interfaces:
java.io.Serializable
public class NonproductivePickingApproveVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CANREVIEWOWNNONPROPICKING
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_EMPLOYEEID
static java.lang.String | ORDER_BY_REVIEWLIMIT
static java.lang.String | ORDER_BY_USERNAME
Constructor Summary
NonproductivePickingApproveVO()
Method Summary
java.lang.String | getCanReviewOwnNonproPicking()
java.lang.String | getCurrency()
java.lang.String | getEmployeeId()
java.math.BigDecimal | getReviewLimit()
java.lang.String | getUserName()
void | setCanReviewOwnNonproPicking(java.lang.String canReviewOwnNonproPicking)
void | setCurrency(java.lang.String currency)
void | setEmployeeId(java.lang.String employeeId)
void | setReviewLimit(java.math.BigDecimal reviewLimit)
void | setUserName(java.lang.String userName)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_EMPLOYEEID

public static final java.lang.String ORDER_BY_EMPLOYEEID
See Also:
Constant Field Values

ORDER_BY_USERNAME

public static final java.lang.String ORDER_BY_USERNAME
See Also:
Constant Field Values

ORDER_BY_REVIEWLIMIT

public static final java.lang.String ORDER_BY_REVIEWLIMIT
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values

ORDER_BY_CANREVIEWOWNNONPROPICKING

public static final java.lang.String ORDER_BY_CANREVIEWOWNNONPROPICKING
See Also:
Constant Field Values
Constructor Detail

NonproductivePickingApproveVO

public NonproductivePickingApproveVO()
Method Detail

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getReviewLimit

public java.math.BigDecimal getReviewLimit()

setReviewLimit

public void setReviewLimit(java.math.BigDecimal reviewLimit)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getCanReviewOwnNonproPicking

public java.lang.String getCanReviewOwnNonproPicking()

setCanReviewOwnNonproPicking

public void setCanReviewOwnNonproPicking(java.lang.String canReviewOwnNonproPicking)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NonproductivePickingItemIssuedListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class NonproductivePickingItemIssuedListResult

java.lang.Object
    extended by  bb.common.NonproductivePickingItemIssuedListResult
All Implemented Interfaces:
java.io.Serializable
public class NonproductivePickingItemIssuedListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AVGCOST
static java.lang.String | ORDER_BY_DATEISSUE
static java.lang.String | ORDER_BY_ORDERTYPE
static java.lang.String | ORDER_BY_PARTDESC
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_PROJECT
static java.lang.String | ORDER_BY_STDCOST
static java.lang.String | ORDER_BY_WORKORDERNUMBER
Constructor Summary
NonproductivePickingItemIssuedListResult()
Method Summary
java.lang.String | getAccountNumber()
java.math.BigDecimal | getAvgCost()
java.math.BigDecimal | getAvgTotalAmount()
java.lang.String | getCompanyUnitId()
java.util.Date | getDateIssue()
java.lang.String | getDepartmentId()
java.lang.Integer | getIi()
java.math.BigDecimal | getIssueAvgCost()
java.math.BigDecimal | getIssuedQty()
java.lang.String | getItemComments()
java.lang.Short | getItemNumber()
java.lang.String | getLocate()
java.util.Map | getLocations()
java.lang.String | getMfgStatus()
java.lang.String | getNote()
java.lang.String | getOperator()
java.lang.Integer | getOrderNumber()
java.lang.String | getOrderType()
java.lang.String | getOriginator()
java.lang.String | getPartDesc()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getPicker()
java.lang.String | getPickingItemNumber()
java.lang.String | getPickingNumber()
java.lang.String | getProject()
java.math.BigDecimal | getQty()
java.math.BigDecimal | getStdCost()
java.math.BigDecimal | getStdTotalAmount()
java.util.Map | getTrackings()
java.lang.String | getTransactionNumber()
java.lang.String | getUnit()
void | setAccountNumber(java.lang.String accountNumber)
void | setAvgCost(java.math.BigDecimal avgCost)
void | setAvgTotalAmount(java.math.BigDecimal avgTotalAmount)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setDateIssue(java.util.Date dateIssue)
void | setDepartmentId(java.lang.String departmentId)
void | setIi(java.lang.Integer ii)
void | setIssueAvgCost(java.math.BigDecimal issueAvgCost)
void | setIssuedQty(java.math.BigDecimal issuedQty)
void | setItemComments(java.lang.String itemComments)
void | setItemNumber(java.lang.Short itemNumber)
void | setLocate(java.lang.String locate)
void | setLocations(java.util.Map locations)
void | setMfgStatus(java.lang.String mfgStatus)
void | setNote(java.lang.String note)
void | setOperator(java.lang.String operator)
void | setOrderNumber(java.lang.Integer orderNumber)
void | setOrderType(java.lang.String orderType)
void | setOriginator(java.lang.String originator)
void | setPartDesc(java.lang.String partDesc)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPicker(java.lang.String picker)
void | setPickingItemNumber(java.lang.String pickingItemNumber)
void | setPickingNumber(java.lang.String pickingNumber)
void | setProject(java.lang.String project)
void | setQty(java.math.BigDecimal qty)
void | setStdCost(java.math.BigDecimal stdCost)
void | setStdTotalAmount(java.math.BigDecimal stdTotalAmount)
void | setTrackings(java.util.Map trackings)
void | setTransactionNumber(java.lang.String transactionNumber)
void | setUnit(java.lang.String unit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_WORKORDERNUMBER

public static final java.lang.String ORDER_BY_WORKORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_PARTDESC

public static final java.lang.String ORDER_BY_PARTDESC
See Also:
Constant Field Values

ORDER_BY_AVGCOST

public static final java.lang.String ORDER_BY_AVGCOST
See Also:
Constant Field Values

ORDER_BY_STDCOST

public static final java.lang.String ORDER_BY_STDCOST
See Also:
Constant Field Values

ORDER_BY_DATEISSUE

public static final java.lang.String ORDER_BY_DATEISSUE
See Also:
Constant Field Values

ORDER_BY_ORDERTYPE

public static final java.lang.String ORDER_BY_ORDERTYPE
See Also:
Constant Field Values

ORDER_BY_PROJECT

public static final java.lang.String ORDER_BY_PROJECT
See Also:
Constant Field Values
Constructor Detail

NonproductivePickingItemIssuedListResult

public NonproductivePickingItemIssuedListResult()
Method Detail

getPickingNumber

public java.lang.String getPickingNumber()

setPickingNumber

public void setPickingNumber(java.lang.String pickingNumber)

getPickingItemNumber

public java.lang.String getPickingItemNumber()

setPickingItemNumber

public void setPickingItemNumber(java.lang.String pickingItemNumber)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartDesc

public java.lang.String getPartDesc()

setPartDesc

public void setPartDesc(java.lang.String partDesc)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

getIssuedQty

public java.math.BigDecimal getIssuedQty()

setIssuedQty

public void setIssuedQty(java.math.BigDecimal issuedQty)

getOriginator

public java.lang.String getOriginator()

setOriginator

public void setOriginator(java.lang.String originator)

getMfgStatus

public java.lang.String getMfgStatus()

setMfgStatus

public void setMfgStatus(java.lang.String mfgStatus)

getAvgCost

public java.math.BigDecimal getAvgCost()

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getIssueAvgCost

public java.math.BigDecimal getIssueAvgCost()

setIssueAvgCost

public void setIssueAvgCost(java.math.BigDecimal issueAvgCost)

getDateIssue

public java.util.Date getDateIssue()

setDateIssue

public void setDateIssue(java.util.Date dateIssue)

getAvgTotalAmount

public java.math.BigDecimal getAvgTotalAmount()

setAvgTotalAmount

public void setAvgTotalAmount(java.math.BigDecimal avgTotalAmount)

getStdTotalAmount

public java.math.BigDecimal getStdTotalAmount()

setStdTotalAmount

public void setStdTotalAmount(java.math.BigDecimal stdTotalAmount)

getOrderType

public java.lang.String getOrderType()

setOrderType

public void setOrderType(java.lang.String orderType)

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getItemComments

public java.lang.String getItemComments()

setItemComments

public void setItemComments(java.lang.String itemComments)

getIi

public java.lang.Integer getIi()

setIi

public void setIi(java.lang.Integer ii)

getOrderNumber

public java.lang.Integer getOrderNumber()

setOrderNumber

public void setOrderNumber(java.lang.Integer orderNumber)

getItemNumber

public java.lang.Short getItemNumber()

setItemNumber

public void setItemNumber(java.lang.Short itemNumber)

getOperator

public java.lang.String getOperator()

setOperator

public void setOperator(java.lang.String operator)

getPicker

public java.lang.String getPicker()

setPicker

public void setPicker(java.lang.String picker)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getNote

public java.lang.String getNote()

setNote

public void setNote(java.lang.String note)

getTransactionNumber

public java.lang.String getTransactionNumber()

setTransactionNumber

public void setTransactionNumber(java.lang.String transactionNumber)

getDepartmentId

public java.lang.String getDepartmentId()

setDepartmentId

public void setDepartmentId(java.lang.String departmentId)

getLocations

public java.util.Map getLocations()

setLocations

public void setLocations(java.util.Map locations)

getTrackings

public java.util.Map getTrackings()

setTrackings

public void setTrackings(java.util.Map trackings)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NonproductivePickingItemIssuedVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class NonproductivePickingItemIssuedVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.NonproductivePickingItemIssuedVO
All Implemented Interfaces:
java.io.Serializable
public class NonproductivePickingItemIssuedVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DATEISSUED
static java.lang.String | ORDER_BY_LOCATE
static java.lang.String | ORDER_BY_OPERATOR
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_PICKER
static java.lang.String | ORDER_BY_PICKINGITEMNUMBER
static java.lang.String | ORDER_BY_PICKINGNUMBER
static java.lang.String | ORDER_BY_QTYISSUED
static java.lang.String | ORDER_BY_TRANSACTIONNUMBER
static java.lang.String | ORDER_BY_UNIT
Constructor Summary
NonproductivePickingItemIssuedVO()
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getCost()
java.util.Date | getDateIssued()
java.lang.String | getDepartmentId()
java.lang.String | getDescription()
java.lang.Integer | getIi()
java.lang.Short | getItemNumber()
java.util.Map | getLocations()
java.lang.String | getNote()
java.lang.String | getOperator()
java.lang.Integer | getOrderNumber()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getPicker()
java.lang.String | getPickingItemNumber()
java.lang.String | getPickingNumber()
java.math.BigDecimal | getQtyIssued()
java.math.BigDecimal | getStdCost()
java.util.Map | getTrackings()
java.lang.String | getTransactionNumber()
java.lang.String | getUnit()
int | hashCode()
void | setCost(java.math.BigDecimal cost)
void | setDateIssued(java.util.Date dateIssued)
void | setDepartmentId(java.lang.String departmentId)
void | setDescription(java.lang.String description)
void | setIi(java.lang.Integer ii)
void | setItemNumber(java.lang.Short itemNumber)
void | setLocations(java.util.Map locations)
void | setNote(java.lang.String note)
void | setOperator(java.lang.String operator)
void | setOrderNumber(java.lang.Integer orderNumber)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPicker(java.lang.String picker)
void | setPickingItemNumber(java.lang.String pickingItemNumber)
void | setPickingNumber(java.lang.String pickingNumber)
void | setQtyIssued(java.math.BigDecimal qtyIssued)
void | setStdCost(java.math.BigDecimal stdCost)
void | setTrackings(java.util.Map trackings)
void | setTransactionNumber(java.lang.String transactionNumber)
void | setUnit(java.lang.String unit)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PICKINGNUMBER

public static final java.lang.String ORDER_BY_PICKINGNUMBER
See Also:
Constant Field Values

ORDER_BY_PICKINGITEMNUMBER

public static final java.lang.String ORDER_BY_PICKINGITEMNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_QTYISSUED

public static final java.lang.String ORDER_BY_QTYISSUED
See Also:
Constant Field Values

ORDER_BY_DATEISSUED

public static final java.lang.String ORDER_BY_DATEISSUED
See Also:
Constant Field Values

ORDER_BY_OPERATOR

public static final java.lang.String ORDER_BY_OPERATOR
See Also:
Constant Field Values

ORDER_BY_PICKER

public static final java.lang.String ORDER_BY_PICKER
See Also:
Constant Field Values

ORDER_BY_UNIT

public static final java.lang.String ORDER_BY_UNIT
See Also:
Constant Field Values

ORDER_BY_LOCATE

public static final java.lang.String ORDER_BY_LOCATE
See Also:
Constant Field Values

ORDER_BY_TRANSACTIONNUMBER

public static final java.lang.String ORDER_BY_TRANSACTIONNUMBER
See Also:
Constant Field Values
Constructor Detail

NonproductivePickingItemIssuedVO

public NonproductivePickingItemIssuedVO()
Method Detail

getCost

public java.math.BigDecimal getCost()

setCost

public void setCost(java.math.BigDecimal cost)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getIi

public java.lang.Integer getIi()

setIi

public void setIi(java.lang.Integer ii)

getPickingNumber

public java.lang.String getPickingNumber()

setPickingNumber

public void setPickingNumber(java.lang.String pickingNumber)

getPickingItemNumber

public java.lang.String getPickingItemNumber()

setPickingItemNumber

public void setPickingItemNumber(java.lang.String pickingItemNumber)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getQtyIssued

public java.math.BigDecimal getQtyIssued()

setQtyIssued

public void setQtyIssued(java.math.BigDecimal qtyIssued)

getDateIssued

public java.util.Date getDateIssued()

setDateIssued

public void setDateIssued(java.util.Date dateIssued)

getOperator

public java.lang.String getOperator()

setOperator

public void setOperator(java.lang.String operator)

getPicker

public java.lang.String getPicker()

setPicker

public void setPicker(java.lang.String picker)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getNote

public java.lang.String getNote()

setNote

public void setNote(java.lang.String note)

getTransactionNumber

public java.lang.String getTransactionNumber()

setTransactionNumber

public void setTransactionNumber(java.lang.String transactionNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

getOrderNumber

public java.lang.Integer getOrderNumber()

setOrderNumber

public void setOrderNumber(java.lang.Integer orderNumber)

getItemNumber

public java.lang.Short getItemNumber()

setItemNumber

public void setItemNumber(java.lang.Short itemNumber)

getDepartmentId

public java.lang.String getDepartmentId()

setDepartmentId

public void setDepartmentId(java.lang.String departmentId)

getLocations

public java.util.Map getLocations()

setLocations

public void setLocations(java.util.Map locations)

getTrackings

public java.util.Map getTrackings()

setTrackings

public void setTrackings(java.util.Map trackings)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NonproductivePickingItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class NonproductivePickingItemPK

java.lang.Object
    extended by  bb.common.NonproductivePickingItemPK
All Implemented Interfaces:
java.io.Serializable
public class NonproductivePickingItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
NonproductivePickingItemPK()
NonproductivePickingItemPK(java.lang.String pickingNumber, java.lang.String pickingItemNumber)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getPickingItemNumber()
java.lang.String | getPickingNumber()
int | hashCode()
void | setPickingItemNumber(java.lang.String pickingItemNumber)
void | setPickingNumber(java.lang.String pickingNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

NonproductivePickingItemPK

public NonproductivePickingItemPK()

NonproductivePickingItemPK

public NonproductivePickingItemPK(java.lang.String pickingNumber,
                                  java.lang.String pickingItemNumber)
Method Detail

getPickingNumber

public java.lang.String getPickingNumber()

setPickingNumber

public void setPickingNumber(java.lang.String pickingNumber)

getPickingItemNumber

public java.lang.String getPickingItemNumber()

setPickingItemNumber

public void setPickingItemNumber(java.lang.String pickingItemNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NonproductivePickingItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class NonproductivePickingItemResult

java.lang.Object
    extended by  bb.common.NonproductivePickingItemResult
All Implemented Interfaces:
java.io.Serializable
public class NonproductivePickingItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACCOUNTNUMBER
static java.lang.String | ORDER_BY_APPROVEDBY
static java.lang.String | ORDER_BY_APPROVEDDATE
static java.lang.String | ORDER_BY_COMPANYUNITID
static java.lang.String | ORDER_BY_ID
static java.lang.String | ORDER_BY_ISSUEDQUANTITY
static java.lang.String | ORDER_BY_ORDERTYPE
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_PICKINGNUMBER
static java.lang.String | ORDER_BY_PROJECT
static java.lang.String | ORDER_BY_QUANTITY
static java.lang.String | ORDER_BY_UNIT
Constructor Summary
NonproductivePickingItemResult()
Method Summary
java.lang.String | getAccountNumber()
java.lang.String | getApprovedBy()
java.util.Date | getApprovedDate()
java.lang.String | getComments()
java.lang.String | getCompanyUnitId()
java.lang.String | getDescription()
java.lang.String | getId()
java.math.BigDecimal | getIssuedQuantity()
java.lang.String | getNotes()
java.lang.String | getOrderType()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getPickingItemNumber()
java.lang.String | getPickingNumber()
java.lang.String | getProject()
java.math.BigDecimal | getQuantity()
java.lang.String | getStatus()
java.lang.String | getUnit()
void | setAccountNumber(java.lang.String accountNumber)
void | setApprovedBy(java.lang.String approvedBy)
void | setApprovedDate(java.util.Date approvedDate)
void | setComments(java.lang.String comments)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setDescription(java.lang.String description)
void | setId(java.lang.String id)
void | setIssuedQuantity(java.math.BigDecimal issuedQuantity)
void | setNotes(java.lang.String notes)
void | setOrderType(java.lang.String orderType)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPickingItemNumber(java.lang.String pickingItemNumber)
void | setPickingNumber(java.lang.String pickingNumber)
void | setProject(java.lang.String project)
void | setQuantity(java.math.BigDecimal quantity)
void | setStatus(java.lang.String status)
void | setUnit(java.lang.String unit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_QUANTITY

public static final java.lang.String ORDER_BY_QUANTITY
See Also:
Constant Field Values

ORDER_BY_ISSUEDQUANTITY

public static final java.lang.String ORDER_BY_ISSUEDQUANTITY
See Also:
Constant Field Values

ORDER_BY_UNIT

public static final java.lang.String ORDER_BY_UNIT
See Also:
Constant Field Values

ORDER_BY_PICKINGNUMBER

public static final java.lang.String ORDER_BY_PICKINGNUMBER
See Also:
Constant Field Values

ORDER_BY_APPROVEDDATE

public static final java.lang.String ORDER_BY_APPROVEDDATE
See Also:
Constant Field Values

ORDER_BY_APPROVEDBY

public static final java.lang.String ORDER_BY_APPROVEDBY
See Also:
Constant Field Values

ORDER_BY_ID

public static final java.lang.String ORDER_BY_ID
See Also:
Constant Field Values

ORDER_BY_ACCOUNTNUMBER

public static final java.lang.String ORDER_BY_ACCOUNTNUMBER
See Also:
Constant Field Values

ORDER_BY_COMPANYUNITID

public static final java.lang.String ORDER_BY_COMPANYUNITID
See Also:
Constant Field Values

ORDER_BY_ORDERTYPE

public static final java.lang.String ORDER_BY_ORDERTYPE
See Also:
Constant Field Values

ORDER_BY_PROJECT

public static final java.lang.String ORDER_BY_PROJECT
See Also:
Constant Field Values
Constructor Detail

NonproductivePickingItemResult

public NonproductivePickingItemResult()
Method Detail

getPickingNumber

public java.lang.String getPickingNumber()

setPickingNumber

public void setPickingNumber(java.lang.String pickingNumber)

getPickingItemNumber

public java.lang.String getPickingItemNumber()

setPickingItemNumber

public void setPickingItemNumber(java.lang.String pickingItemNumber)

getApprovedDate

public java.util.Date getApprovedDate()

setApprovedDate

public void setApprovedDate(java.util.Date approvedDate)

getApprovedBy

public java.lang.String getApprovedBy()

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)

getOrderType

public java.lang.String getOrderType()

setOrderType

public void setOrderType(java.lang.String orderType)

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getIssuedQuantity

public java.math.BigDecimal getIssuedQuantity()

setIssuedQuantity

public void setIssuedQuantity(java.math.BigDecimal issuedQuantity)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getNotes

public java.lang.String getNotes()

setNotes

public void setNotes(java.lang.String notes)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NonproductivePickingItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class NonproductivePickingItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.NonproductivePickingItemVO
All Implemented Interfaces:
java.io.Serializable
public class NonproductivePickingItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
NonproductivePickingItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getActual()
java.util.Date | getArriveDate()
java.math.BigDecimal | getAvgTotal()
java.lang.String | getComments()
java.math.BigDecimal | getCost()
int | getDelayDays()
java.util.Date | getDeliveryDate()
java.lang.String | getDescription()
java.util.Date | getDesiredDate()
java.lang.String | getDwg()
java.math.BigDecimal | getIssuedQuantity()
java.lang.String | getNotes()
java.util.Date | getOriginal()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
NonproductivePickingItemPK | getPk()
java.math.BigDecimal | getQuantity()
java.lang.String | getRevision()
java.lang.String | getStatus()
java.math.BigDecimal | getStdCost()
java.math.BigDecimal | getStdTotal()
java.lang.String | getTransactionNumber()
java.lang.String | getUnit()
int | hashCode()
void | setActual(java.util.Date actual)
void | setArriveDate(java.util.Date arriveDate)
void | setAvgTotal(java.math.BigDecimal avgTotal)
void | setComments(java.lang.String comments)
void | setCost(java.math.BigDecimal cost)
void | setDelayDays(int delayDays)
void | setDeliveryDate(java.util.Date deliveryDate)
void | setDescription(java.lang.String description)
void | setDesiredDate(java.util.Date desiredDate)
void | setDwg(java.lang.String dwg)
void | setIssuedQuantity(java.math.BigDecimal issuedQuantity)
void | setNotes(java.lang.String notes)
void | setOriginal(java.util.Date original)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(NonproductivePickingItemPK pk)
void | setQuantity(java.math.BigDecimal quantity)
void | setRevision(java.lang.String revision)
void | setStatus(java.lang.String status)
void | setStdCost(java.math.BigDecimal stdCost)
void | setStdTotal(java.math.BigDecimal stdTotal)
void | setTransactionNumber(java.lang.String transactionNumber)
void | setUnit(java.lang.String unit)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

NonproductivePickingItemVO

public NonproductivePickingItemVO()
Method Detail

getPk

public NonproductivePickingItemPK getPk()

setPk

public void setPk(NonproductivePickingItemPK pk)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getIssuedQuantity

public java.math.BigDecimal getIssuedQuantity()

setIssuedQuantity

public void setIssuedQuantity(java.math.BigDecimal issuedQuantity)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getNotes

public java.lang.String getNotes()

setNotes

public void setNotes(java.lang.String notes)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

getTransactionNumber

public java.lang.String getTransactionNumber()

setTransactionNumber

public void setTransactionNumber(java.lang.String transactionNumber)

getDeliveryDate

public java.util.Date getDeliveryDate()

setDeliveryDate

public void setDeliveryDate(java.util.Date deliveryDate)

getDesiredDate

public java.util.Date getDesiredDate()

setDesiredDate

public void setDesiredDate(java.util.Date desiredDate)

getDelayDays

public int getDelayDays()

setDelayDays

public void setDelayDays(int delayDays)

getArriveDate

public java.util.Date getArriveDate()

setArriveDate

public void setArriveDate(java.util.Date arriveDate)

getOriginal

public java.util.Date getOriginal()

setOriginal

public void setOriginal(java.util.Date original)

getActual

public java.util.Date getActual()

setActual

public void setActual(java.util.Date actual)

getCost

public java.math.BigDecimal getCost()

setCost

public void setCost(java.math.BigDecimal cost)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getDwg

public java.lang.String getDwg()

setDwg

public void setDwg(java.lang.String dwg)

getAvgTotal

public java.math.BigDecimal getAvgTotal()

setAvgTotal

public void setAvgTotal(java.math.BigDecimal avgTotal)

getStdTotal

public java.math.BigDecimal getStdTotal()

setStdTotal

public void setStdTotal(java.math.BigDecimal stdTotal)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NonproductivePickingOnDemandResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class NonproductivePickingOnDemandResult

java.lang.Object
    extended by  bb.common.NonproductivePickingOnDemandResult
All Implemented Interfaces:
java.io.Serializable
public class NonproductivePickingOnDemandResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
NonproductivePickingOnDemandResult()
Method Summary
java.util.Date | getAdate()
java.util.Date | getArriveDate()
int | getDelayDays()
java.util.Date | getDeliveryDate()
java.lang.String | getDescription()
java.lang.String | getId()
java.util.Map<java.lang.String,java.math.BigDecimal> | getLocations()
java.lang.String | getPartFrom()
PartPK | getPartPk()
NonproductivePickingItemPK | getPk()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getQuantityIssued()
java.math.BigDecimal | getQuantityOnDemand()
java.lang.String | getShipVia()
void | setAdate(java.util.Date adate)
void | setArriveDate(java.util.Date arriveDate)
void | setDelayDays(int delayDays)
void | setDeliveryDate(java.util.Date deliveryDate)
void | setDescription(java.lang.String description)
void | setId(java.lang.String id)
void | setLocations(java.util.Map<java.lang.String,java.math.BigDecimal> locations)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setPk(NonproductivePickingItemPK pk)
void | setQuantity(java.math.BigDecimal quantity)
void | setQuantityIssued(java.math.BigDecimal quantityIssued)
void | setQuantityOnDemand(java.math.BigDecimal quantityOnDemand)
void | setShipVia(java.lang.String shipVia)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NonproductivePickingOnDemandResult

public NonproductivePickingOnDemandResult()
Method Detail

getPartPk

public PartPK getPartPk()

setPartPk

public void setPartPk(PartPK partPk)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPk

public NonproductivePickingItemPK getPk()

setPk

public void setPk(NonproductivePickingItemPK pk)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getQuantityIssued

public java.math.BigDecimal getQuantityIssued()

setQuantityIssued

public void setQuantityIssued(java.math.BigDecimal quantityIssued)

getQuantityOnDemand

public java.math.BigDecimal getQuantityOnDemand()

setQuantityOnDemand

public void setQuantityOnDemand(java.math.BigDecimal quantityOnDemand)

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getDeliveryDate

public java.util.Date getDeliveryDate()

setDeliveryDate

public void setDeliveryDate(java.util.Date deliveryDate)

getArriveDate

public java.util.Date getArriveDate()

setArriveDate

public void setArriveDate(java.util.Date arriveDate)

getDelayDays

public int getDelayDays()

setDelayDays

public void setDelayDays(int delayDays)

getLocations

public java.util.Map<java.lang.String,java.math.BigDecimal> getLocations()

setLocations

public void setLocations(java.util.Map<java.lang.String,java.math.BigDecimal> locations)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NonproductivePickingTypeVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class NonproductivePickingTypeVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.NonproductivePickingTypeVO
All Implemented Interfaces:
java.io.Serializable
public class NonproductivePickingTypeVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACCOUNTNUMBER
static java.lang.String | ORDER_BY_COMPANYUNITID
static java.lang.String | ORDER_BY_NAME
Constructor Summary
NonproductivePickingTypeVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAccountNumber()
java.lang.String | getCompanyUnitId()
int | getIi()
java.lang.String | getName()
int | hashCode()
void | setAccountNumber(java.lang.String accountNumber)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setIi(int ii)
void | setName(java.lang.String name)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_NAME

public static final java.lang.String ORDER_BY_NAME
See Also:
Constant Field Values

ORDER_BY_ACCOUNTNUMBER

public static final java.lang.String ORDER_BY_ACCOUNTNUMBER
See Also:
Constant Field Values

ORDER_BY_COMPANYUNITID

public static final java.lang.String ORDER_BY_COMPANYUNITID
See Also:
Constant Field Values
Constructor Detail

NonproductivePickingTypeVO

public NonproductivePickingTypeVO()
Method Detail

getIi

public int getIi()

setIi

public void setIi(int ii)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NonproductivePickingVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class NonproductivePickingVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.NonproductivePickingVO
All Implemented Interfaces:
java.io.Serializable
public class NonproductivePickingVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACCOUNTNUMBER
static java.lang.String | ORDER_BY_APPROVEDBY
static java.lang.String | ORDER_BY_APPROVEDDATE
static java.lang.String | ORDER_BY_COMPANYUNITID
static java.lang.String | ORDER_BY_DEPARTMENTID
static java.lang.String | ORDER_BY_ORDERTYPE
static java.lang.String | ORDER_BY_PICKINGNUMBER
static java.lang.String | ORDER_BY_PROJECT
Constructor Summary
NonproductivePickingVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAccountNumber()
java.util.Date | getAdate()
CustomerVendorAddressInfoVO | getAddressInfo()
java.lang.String | getApprovedBy()
java.util.Date | getApprovedDate()
java.math.BigDecimal | getAvgTotal()
java.lang.String | getComments()
java.lang.String | getCompanyUnitId()
java.lang.String | getDepartmentId()
java.util.Date | getLastChangeDate()
java.lang.String | getLastUser()
java.lang.String | getNotes()
java.lang.String | getOrderType()
java.lang.String | getOrigin()
java.util.Set<NonproductivePickingItemVO> | getPickingItems()
java.lang.String | getPickingNumber()
java.lang.String | getProject()
java.lang.String | getStatus()
java.math.BigDecimal | getStdTotal()
java.lang.Integer | getVersion()
int | hashCode()
void | setAccountNumber(java.lang.String accountNumber)
void | setAdate(java.util.Date adate)
void | setAddressInfo(CustomerVendorAddressInfoVO addressInfo)
void | setApprovedBy(java.lang.String approvedBy)
void | setApprovedDate(java.util.Date approvedDate)
void | setAvgTotal(java.math.BigDecimal avgTotal)
void | setComments(java.lang.String comments)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setDepartmentId(java.lang.String departmentId)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastUser(java.lang.String lastUser)
void | setNotes(java.lang.String notes)
void | setOrderType(java.lang.String orderType)
void | setOrigin(java.lang.String origin)
void | setPickingItems(java.util.Set<NonproductivePickingItemVO> pickingItems)
void | setPickingNumber(java.lang.String pickingNumber)
void | setProject(java.lang.String project)
void | setStatus(java.lang.String status)
void | setStdTotal(java.math.BigDecimal stdTotal)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PICKINGNUMBER

public static final java.lang.String ORDER_BY_PICKINGNUMBER
See Also:
Constant Field Values

ORDER_BY_APPROVEDDATE

public static final java.lang.String ORDER_BY_APPROVEDDATE
See Also:
Constant Field Values

ORDER_BY_APPROVEDBY

public static final java.lang.String ORDER_BY_APPROVEDBY
See Also:
Constant Field Values

ORDER_BY_DEPARTMENTID

public static final java.lang.String ORDER_BY_DEPARTMENTID
See Also:
Constant Field Values

ORDER_BY_ACCOUNTNUMBER

public static final java.lang.String ORDER_BY_ACCOUNTNUMBER
See Also:
Constant Field Values

ORDER_BY_COMPANYUNITID

public static final java.lang.String ORDER_BY_COMPANYUNITID
See Also:
Constant Field Values

ORDER_BY_ORDERTYPE

public static final java.lang.String ORDER_BY_ORDERTYPE
See Also:
Constant Field Values

ORDER_BY_PROJECT

public static final java.lang.String ORDER_BY_PROJECT
See Also:
Constant Field Values
Constructor Detail

NonproductivePickingVO

public NonproductivePickingVO()
Method Detail

getPickingNumber

public java.lang.String getPickingNumber()

setPickingNumber

public void setPickingNumber(java.lang.String pickingNumber)

getVersion

public java.lang.Integer getVersion()

setVersion

public void setVersion(java.lang.Integer version)

getLastUser

public java.lang.String getLastUser()

setLastUser

public void setLastUser(java.lang.String lastUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getApprovedDate

public java.util.Date getApprovedDate()

setApprovedDate

public void setApprovedDate(java.util.Date approvedDate)

getApprovedBy

public java.lang.String getApprovedBy()

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)

getOrderType

public java.lang.String getOrderType()

setOrderType

public void setOrderType(java.lang.String orderType)

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getNotes

public java.lang.String getNotes()

setNotes

public void setNotes(java.lang.String notes)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

getPickingItems

public java.util.Set<NonproductivePickingItemVO> getPickingItems()

setPickingItems

public void setPickingItems(java.util.Set<NonproductivePickingItemVO> pickingItems)

getAddressInfo

public CustomerVendorAddressInfoVO getAddressInfo()

setAddressInfo

public void setAddressInfo(CustomerVendorAddressInfoVO addressInfo)

getDepartmentId

public java.lang.String getDepartmentId()

setDepartmentId

public void setDepartmentId(java.lang.String departmentId)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

getAvgTotal

public java.math.BigDecimal getAvgTotal()

setAvgTotal

public void setAvgTotal(java.math.BigDecimal avgTotal)

getStdTotal

public java.math.BigDecimal getStdTotal()

setStdTotal

public void setStdTotal(java.math.BigDecimal stdTotal)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NoticeUserEmployeeListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class NoticeUserEmployeeListResult

java.lang.Object
    extended by  bb.common.NoticeUserEmployeeListResult
All Implemented Interfaces:
java.io.Serializable
public class NoticeUserEmployeeListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DEPARTMENT
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_EMAIL
static java.lang.String | ORDER_BY_HOMEPHONE
static java.lang.String | ORDER_BY_MOBILE
static java.lang.String | ORDER_BY_PHONE
static java.lang.String | ORDER_BY_SYSTEMUSERNAME
static java.lang.String | ORDER_BY_USERNAME
Constructor Summary
NoticeUserEmployeeListResult()
Method Summary
java.lang.String | getDepartment()
java.lang.String | getDescription()
java.lang.String | getEmail()
java.lang.String | getEmployeeId()
java.lang.String | getFirstName()
java.lang.String | getFullName()
java.lang.String | getHomePhone()
java.lang.String | getLastName()
java.lang.String | getMiddleName()
java.lang.String | getMobile()
java.lang.String | getPhone()
java.lang.String | getSystemUserName()
java.lang.String | getUserName()
void | setDepartment(java.lang.String department)
void | setDescription(java.lang.String description)
void | setEmail(java.lang.String email)
void | setEmployeeId(java.lang.String employeeId)
void | setFirstName(java.lang.String firstName)
void | setFullName(java.lang.String fullName)
void | setHomePhone(java.lang.String homePhone)
void | setLastName(java.lang.String lastName)
void | setMiddleName(java.lang.String middleName)
void | setMobile(java.lang.String mobile)
void | setPhone(java.lang.String phone)
void | setSystemUserName(java.lang.String systemUserName)
void | setUserName(java.lang.String userName)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_USERNAME

public static final java.lang.String ORDER_BY_USERNAME
See Also:
Constant Field Values

ORDER_BY_SYSTEMUSERNAME

public static final java.lang.String ORDER_BY_SYSTEMUSERNAME
See Also:
Constant Field Values

ORDER_BY_DEPARTMENT

public static final java.lang.String ORDER_BY_DEPARTMENT
See Also:
Constant Field Values

ORDER_BY_PHONE

public static final java.lang.String ORDER_BY_PHONE
See Also:
Constant Field Values

ORDER_BY_EMAIL

public static final java.lang.String ORDER_BY_EMAIL
See Also:
Constant Field Values

ORDER_BY_MOBILE

public static final java.lang.String ORDER_BY_MOBILE
See Also:
Constant Field Values

ORDER_BY_HOMEPHONE

public static final java.lang.String ORDER_BY_HOMEPHONE
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

NoticeUserEmployeeListResult

public NoticeUserEmployeeListResult()
Method Detail

getFirstName

public java.lang.String getFirstName()

setFirstName

public void setFirstName(java.lang.String firstName)

getMiddleName

public java.lang.String getMiddleName()

setMiddleName

public void setMiddleName(java.lang.String middleName)

getLastName

public java.lang.String getLastName()

setLastName

public void setLastName(java.lang.String lastName)

getFullName

public java.lang.String getFullName()

setFullName

public void setFullName(java.lang.String fullName)

getDepartment

public java.lang.String getDepartment()

setDepartment

public void setDepartment(java.lang.String department)

getEmail

public java.lang.String getEmail()

setEmail

public void setEmail(java.lang.String email)

getHomePhone

public java.lang.String getHomePhone()

setHomePhone

public void setHomePhone(java.lang.String homePhone)

getMobile

public java.lang.String getMobile()

setMobile

public void setMobile(java.lang.String mobile)

getPhone

public java.lang.String getPhone()

setPhone

public void setPhone(java.lang.String phone)

getSystemUserName

public java.lang.String getSystemUserName()

setSystemUserName

public void setSystemUserName(java.lang.String systemUserName)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


O-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M N O P Q R S T U V W X Y Z

O

O - Static variable in class bb.common.Constant.TransactionType
OBJECT_ALREADY_APPROVED - Static variable in class bb.common.BIZReason
OBSOLETE - Static variable in class bb.common.Constant.Status
OFFLINE - Static variable in class bb.common.Configure.LoginStatus
offsetARWithCM(List<AccountReceivableInfoWithPrepayResult>, List<AccountReceivableInfoWithPrepayResult>, Object[]) - Method in interface bb.common.box.AccountingBox
OI - Static variable in class bb.common.Constant.Prefix
OIPrincipalVO - Class in bb.common
OIPrincipalVO() - Constructor for class bb.common.OIPrincipalVO
OK - Static variable in class bb.common.Constant.EquipmentStatus
Ok - Static variable in class bb.common.Constant.Status
OLD_FISCAL_YEAR_SETTINGS_CLOSED - Static variable in class bb.common.BIZReason
OLD_TRANSACTION_DATE_LOCKED - Static variable in class bb.common.BIZReason
ON_HIRE - Static variable in class bb.common.Constant.Depreciation.UsingType
ON_LOAN - Static variable in class bb.common.BizTarget
ON_LOAN_ALREADY_EXIST - Static variable in class bb.common.BIZReason
ON_LOAN_ALREADY_REVIEWED - Static variable in class bb.common.BIZReason
ON_LOAN_ITEM - Static variable in class bb.common.BizTarget
ON_lOAN_ITEM_ALREADY_EXIST - Static variable in class bb.common.BIZReason
ON_LOAN_ITEM_NOT_EXIST - Static variable in class bb.common.BIZReason
ON_LOAN_ITEM_PK_ERROR - Static variable in class bb.common.BIZReason
ON_LOAN_NOT_EXIST - Static variable in class bb.common.BIZReason
ONDEMANDQTY - Static variable in class bb.common.Constant.PartQtyType
ONELEVEL - Static variable in class bb.common.Constant.AgeLevel
ONELEVEL - Static variable in class bb.common.Constant.WorkLevel
ONHAND_IS_NOT_ENOUGH - Static variable in class bb.common.BIZReason
OnhandQualityResult - Class in bb.common
OnhandQualityResult() - Constructor for class bb.common.OnhandQualityResult
OnhandQualityResult(String) - Constructor for class bb.common.OnhandQualityResult
OnhandQualityResult(String, int, BigDecimal) - Constructor for class bb.common.OnhandQualityResult
ONLEAVE - Static variable in class bb.common.Constant.EmployeeStatus
ONLINE - Static variable in class bb.common.Configure.LoginStatus
ONLINE_USER_CAN_NOT_BE_REMOVED - Static variable in class bb.common.BIZReason
ONLOAN - Static variable in class bb.common.Constant.PrintTemplateType
ONLOAN_DOC - Static variable in class bb.common.Constant.MiscDocType
ONLOAN_REVIEW - Static variable in class bb.common.BizTarget
ONLOAN_REVIEW_ALREADY_EXIST - Static variable in class bb.common.BIZReason
ONLOAN_REVIEW_NOT_EXIST - Static variable in class bb.common.BIZReason
ONLOAN_SHIPPER - Static variable in class bb.common.BizTarget
OnloanDocumentVO - Class in bb.common
OnloanDocumentVO() - Constructor for class bb.common.OnloanDocumentVO
OnLoanItemListResult - Class in bb.common
OnLoanItemListResult() - Constructor for class bb.common.OnLoanItemListResult
OnLoanItemPK - Class in bb.common
OnLoanItemPK(String, String) - Constructor for class bb.common.OnLoanItemPK
full constructor
OnLoanItemPK() - Constructor for class bb.common.OnLoanItemPK
default constructor
OnLoanItemVO - Class in bb.common
OnLoanItemVO() - Constructor for class bb.common.OnLoanItemVO
default constructor
OnLoanListResult - Class in bb.common
OnLoanListResult() - Constructor for class bb.common.OnLoanListResult
ONLOANRECEIVER - Static variable in class bb.common.Constant.PrintTemplateType
OnloanReceiverItemListResult - Class in bb.common
OnloanReceiverItemListResult() - Constructor for class bb.common.OnloanReceiverItemListResult
OnloanReceiverItemPK - Class in bb.common
OnloanReceiverItemPK() - Constructor for class bb.common.OnloanReceiverItemPK
OnloanReceiverItemPK(String, String) - Constructor for class bb.common.OnloanReceiverItemPK
OnloanReceiverItemVO - Class in bb.common
OnloanReceiverItemVO(OnloanReceiverItemPK, String, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, String, String, String, String, String, String, String, String, String, String, String, String, String, BigDecimal, BigDecimal, BigDecimal, BigDecimal, String, BigDecimal, BigDecimal, String, String, String, String, String, String) - Constructor for class bb.common.OnloanReceiverItemVO
full constructor
OnloanReceiverItemVO() - Constructor for class bb.common.OnloanReceiverItemVO
default constructor
OnloanReceiverItemVO(OnloanReceiverItemPK, String, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, String, String, String, String, String, String, String, String, String, String, String, String, String, BigDecimal, BigDecimal, BigDecimal, BigDecimal, String, BigDecimal, BigDecimal, String, String, String, String) - Constructor for class bb.common.OnloanReceiverItemVO
minimal constructor
OnloanReceiverListResult - Class in bb.common
OnloanReceiverListResult() - Constructor for class bb.common.OnloanReceiverListResult
OnloanReceiverVO - Class in bb.common
OnloanReceiverVO(String, String, String, String, String, Date, Date, String, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, String, String, String, String, Date, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, BigDecimal, String, String, BigDecimal, Date, Date, Date, String, BigDecimal, String, String, int, CustomerVendorAddressInfoVO, Set) - Constructor for class bb.common.OnloanReceiverVO
full constructor
OnloanReceiverVO() - Constructor for class bb.common.OnloanReceiverVO
default constructor
OnloanReceiverVO(String, String) - Constructor for class bb.common.OnloanReceiverVO
minimal constructor
OnloanReviewVO - Class in bb.common
OnloanReviewVO(String, String, BigDecimal, String, String) - Constructor for class bb.common.OnloanReviewVO
full constructor
OnloanReviewVO() - Constructor for class bb.common.OnloanReviewVO
default constructor
ONLOANSHIPPER - Static variable in class bb.common.Constant.PrintTemplateType
OnloanShipperItemPK - Class in bb.common
OnloanShipperItemPK() - Constructor for class bb.common.OnloanShipperItemPK
OnloanShipperItemPK(String, String) - Constructor for class bb.common.OnloanShipperItemPK
OnloanShipperItemVO - Class in bb.common
OnloanShipperItemVO(OnloanShipperItemPK, String, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, String, String, Date, Date, String, String, String, String, String, String, String, String, String, BigDecimal, BigDecimal, BigDecimal, BigDecimal, String, BigDecimal, BigDecimal, String, String, String, String, String, String) - Constructor for class bb.common.OnloanShipperItemVO
full constructor
OnloanShipperItemVO() - Constructor for class bb.common.OnloanShipperItemVO
default constructor
OnloanShipperItemVO(OnloanShipperItemPK, String, String, String, String, String) - Constructor for class bb.common.OnloanShipperItemVO
minimal constructor
OnloanShipperVO - Class in bb.common
OnloanShipperVO() - Constructor for class bb.common.OnloanShipperVO
OnLoanVO - Class in bb.common
OnLoanVO() - Constructor for class bb.common.OnLoanVO
default constructor
ONLY_APP_COLUMN_CAN_BE_DROP - Static variable in class bb.common.BIZReason
ONLY_APP_TABLE_CAN_BE_DROP - Static variable in class bb.common.BIZReason
ONLY_ONE_PRIMARY_KEY_PERMITTED - Static variable in class bb.common.BIZReason
ONORDERQTY - Static variable in class bb.common.Constant.PartQtyType
OnTimeAgent - Class in bb.common
OnTimeAgent() - Constructor for class bb.common.OnTimeAgent
OntimeDeliveryRateListResult - Class in bb.common
OntimeDeliveryRateListResult() - Constructor for class bb.common.OntimeDeliveryRateListResult
OntimeDeliveryRateResult - Class in bb.common
OntimeDeliveryRateResult() - Constructor for class bb.common.OntimeDeliveryRateResult
OpCodeShortcutPK - Class in bb.common
OpCodeShortcutPK() - Constructor for class bb.common.OpCodeShortcutPK
OpCodeShortcutPK(String, String) - Constructor for class bb.common.OpCodeShortcutPK
OpCodeShortcutVO - Class in bb.common
OpCodeShortcutVO() - Constructor for class bb.common.OpCodeShortcutVO
Open - Static variable in class bb.common.Constant.Status
OPEN_DOCUMENT - Static variable in class bb.common.BB2Event
OPEN_OR_RECEIVED - Static variable in class bb.common.Constant.Status
OPERATING_INSTRUCTION - Static variable in class bb.common.BizTarget
OPERATING_INSTRUCTION_NOT_EXIST - Static variable in class bb.common.BIZReason
OPERATING_INSTRUCTION_TYPE - Static variable in class bb.common.BizTarget
OPERATING_INSTRUCTION_TYPE_NOT_EXIST - Static variable in class bb.common.BIZReason
OperatingInstructionsInspectMethodItemPK - Class in bb.common
OperatingInstructionsInspectMethodItemPK() - Constructor for class bb.common.OperatingInstructionsInspectMethodItemPK
OperatingInstructionsInspectMethodItemVO - Class in bb.common
OperatingInstructionsInspectMethodItemVO() - Constructor for class bb.common.OperatingInstructionsInspectMethodItemVO
OperatingInstructionsInspectResultItemPK - Class in bb.common
OperatingInstructionsInspectResultItemPK() - Constructor for class bb.common.OperatingInstructionsInspectResultItemPK
OperatingInstructionsInspectResultItemVO - Class in bb.common
OperatingInstructionsInspectResultItemVO() - Constructor for class bb.common.OperatingInstructionsInspectResultItemVO
OperatingInstructionsInspectStandardItemPK - Class in bb.common
OperatingInstructionsInspectStandardItemPK() - Constructor for class bb.common.OperatingInstructionsInspectStandardItemPK
OperatingInstructionsInspectStandardItemVO - Class in bb.common
OperatingInstructionsInspectStandardItemVO() - Constructor for class bb.common.OperatingInstructionsInspectStandardItemVO
OperatingInstructionsInspectStandardVO - Class in bb.common
OperatingInstructionsInspectStandardVO() - Constructor for class bb.common.OperatingInstructionsInspectStandardVO
OperatingInstructionsManualItemPK - Class in bb.common
OperatingInstructionsManualItemPK() - Constructor for class bb.common.OperatingInstructionsManualItemPK
OperatingInstructionsManualItemVO - Class in bb.common
OperatingInstructionsManualItemVO() - Constructor for class bb.common.OperatingInstructionsManualItemVO
OperatingInstructionsManualVO - Class in bb.common
OperatingInstructionsManualVO() - Constructor for class bb.common.OperatingInstructionsManualVO
OperatingInstructionsTypeVO - Class in bb.common
OperatingInstructionsTypeVO() - Constructor for class bb.common.OperatingInstructionsTypeVO
OperatingInstructionsUserStatisticalResult - Class in bb.common
OperatingInstructionsUserStatisticalResult() - Constructor for class bb.common.OperatingInstructionsUserStatisticalResult
OperatingInstructionsVO - Class in bb.common
OperatingInstructionsVO() - Constructor for class bb.common.OperatingInstructionsVO
OperatingOutputFileItemPK - Class in bb.common
OperatingOutputFileItemPK() - Constructor for class bb.common.OperatingOutputFileItemPK
OperatingOutputFileItemVO - Class in bb.common
OperatingOutputFileItemVO() - Constructor for class bb.common.OperatingOutputFileItemVO
OperatingOutputFileTypeVO - Class in bb.common
OperatingOutputFileTypeVO() - Constructor for class bb.common.OperatingOutputFileTypeVO
OperationLogVO - Class in bb.common
OperationLogVO(String, String, String, String) - Constructor for class bb.common.OperationLogVO
OperationLogVO() - Constructor for class bb.common.OperationLogVO
ORDER - Static variable in class bb.common.BizTarget
ORDER_ALREADY_IN_MY_PRINTLIST - Static variable in class bb.common.BIZReason
ORDER_BY_ACCMDEPRECIATECOST - Static variable in class bb.common.AssetAddOrDisposalsReport
ORDER_BY_ACCOUNTDESCRIPTION - Static variable in class bb.common.AccountBalanceListResult
ORDER_BY_ACCOUNTDESCTIPTION - Static variable in class bb.common.GeneralLedgerByDateListResult
ORDER_BY_ACCOUNTINGREPORTTYPE - Static variable in class bb.common.AccountingInfoDocumentVO
ORDER_BY_ACCOUNTNUMBER - Static variable in class bb.common.AccountBalanceListResult
ORDER_BY_ACCOUNTNUMBER - Static variable in class bb.common.AccountBalanceResult
ORDER_BY_ACCOUNTNUMBER - Static variable in class bb.common.AccountsCreditDebitListResult
ORDER_BY_ACCOUNTNUMBER - Static variable in class bb.common.DisassembleWorkOrderItemListResult
ORDER_BY_ACCOUNTNUMBER - Static variable in class bb.common.DWOIssueDetail
ORDER_BY_ACCOUNTNUMBER - Static variable in class bb.common.GeneralLedgerByDateListResult
ORDER_BY_ACCOUNTNUMBER - Static variable in class bb.common.GLDebitCreditListResult
ORDER_BY_ACCOUNTNUMBER - Static variable in class bb.common.NonproductivePickingItemResult
ORDER_BY_ACCOUNTNUMBER - Static variable in class bb.common.NonproductivePickingTypeVO
ORDER_BY_ACCOUNTNUMBER - Static variable in class bb.common.NonproductivePickingVO
ORDER_BY_ACCOUNTNUMBER - Static variable in class bb.common.POReceiverItemListResult
ORDER_BY_ACCOUNTNUMBER - Static variable in class bb.common.PurchaseOrderItemListResult
ORDER_BY_ACCOUNTNUMBER - Static variable in class bb.common.SalesOrderItemListResult
ORDER_BY_ACCOUNTNUMBER - Static variable in class bb.common.WOReceiverDetail
ORDER_BY_ACCOUNTNUMBER - Static variable in class bb.common.WorkOrderItemListResult
ORDER_BY_ACCOUNTSPAYABLENUMBER - Static variable in class bb.common.GeneralLedgerListResult
ORDER_BY_ACCOUNTSPAYABLENUMBER - Static variable in class bb.common.GeneralLedgerVO
ORDER_BY_ACCOUNTSPAYABLENUMBER - Static variable in class bb.common.GLDebitCreditListResult
ORDER_BY_ACCOUNTTYPE - Static variable in class bb.common.GeneralLedgerByDateListResult
ORDER_BY_ACKNOWLEDGEDATE - Static variable in class bb.common.PurchaseOrderListResult
ORDER_BY_ACQUISITIONCOST - Static variable in class bb.common.AssetAddOrDisposalsReport
ORDER_BY_ACQUISITIONCOST - Static variable in class bb.common.AssetDepreciateDetailReport
ORDER_BY_ACQUISITIONCOST - Static variable in class bb.common.AssetDepreciateVO
ORDER_BY_ACQUISITIONCOST - Static variable in class bb.common.AssetVO
ORDER_BY_ACQUISITIONCOST - Static variable in class bb.common.DepreciateMonthlyReport
ORDER_BY_ACQUISITIONDATE - Static variable in class bb.common.AssetAddOrDisposalsReport
ORDER_BY_ACQUISITIONDATE - Static variable in class bb.common.AssetVO
ORDER_BY_ACTION - Static variable in class bb.common.LogMiscDocumentVO
ORDER_BY_ACTION - Static variable in class bb.common.LogPartDocumentVO
ORDER_BY_ACTION - Static variable in class bb.common.LogPartDwfVO
ORDER_BY_ACTION - Static variable in class bb.common.LogPartDwgVO
ORDER_BY_ACTION - Static variable in class bb.common.OperationLogVO
ORDER_BY_ACTIONTIME - Static variable in class bb.common.OperationLogVO
ORDER_BY_ACTIONTYPE - Static variable in class bb.common.BuyerCodeVO
ORDER_BY_ACTIVE - Static variable in class bb.common.CustomGoodsBreedVO
ORDER_BY_ACTIVE - Static variable in class bb.common.LabelTemplateVO
ORDER_BY_actived - Static variable in class bb.common.HelpServerVO
ORDER_BY_ACTUAL - Static variable in class bb.common.WorkOrderItemPartDetail
ORDER_BY_ADATE - Static variable in class bb.common.InspectionConformanceReportVO
ORDER_BY_ADATE - Static variable in class bb.common.SwapReceiverListResult
ORDER_BY_ADATE - Static variable in class bb.common.SwapShipperListResult
ORDER_BY_ADATE - Static variable in class bb.common.TransferOrderListResult
ORDER_BY_ADATE - Static variable in class bb.common.TransferOrderVO
ORDER_BY_ADATE - Static variable in class bb.common.TransferReceiverListResult
ORDER_BY_ADATE - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_ADDR1 - Static variable in class bb.common.SGCustRequestForQuoteListResult
ORDER_BY_ADDRESS - Static variable in class bb.common.CustomerVendorAddressInfoVO
ORDER_BY_ADDRESS - Static variable in class bb.common.ManufacturerAddressInfoVO
ORDER_BY_ADDRESS2 - Static variable in class bb.common.CustomerVendorAddressInfoVO
ORDER_BY_ADDRESSID - Static variable in class bb.common.AccountBalanceListResult
ORDER_BY_ADDRESSID - Static variable in class bb.common.AccountBalanceResult
ORDER_BY_ADDRESSID - Static variable in class bb.common.ArCommissionListResult
ORDER_BY_ADDRESSID - Static variable in class bb.common.ArSalesCodeTotalListResult
ORDER_BY_ADDRESSID - Static variable in class bb.common.GeneralLedgerByDateListResult
ORDER_BY_ADDRESSID - Static variable in class bb.common.PaymentHistoryVO
ORDER_BY_ADDRESSID - Static variable in class bb.common.SalesCodeVO
ORDER_BY_ADDRESSNAME - Static variable in class bb.common.AccountBalanceListResult
ORDER_BY_ADDRESSNAME - Static variable in class bb.common.ArCommissionListResult
ORDER_BY_ADDRESSNAME - Static variable in class bb.common.ArSalesCodeTotalListResult
ORDER_BY_ADDRESSNAME - Static variable in class bb.common.GeneralLedgerByDateListResult
ORDER_BY_ADDRESSNAME - Static variable in class bb.common.PaymentHistoryVO
ORDER_BY_ADDRESSNAME - Static variable in class bb.common.SalesCodeVO
ORDER_BY_AGE - Static variable in class bb.common.CustomCheckUpEmployeeVO
ORDER_BY_amortizationExpenseAccount - Static variable in class bb.common.AssetDepreciateVO
ORDER_BY_AMORTIZATIONEXPENSEACCOUNT - Static variable in class bb.common.AssetVO
ORDER_BY_AMOUNT - Static variable in class bb.common.ApCheckRunListResult
ORDER_BY_AMOUNTDUE - Static variable in class bb.common.AccountsReceivableInfoVO
ORDER_BY_AMOUNTPAID - Static variable in class bb.common.CustomerStatementListResult
ORDER_BY_AMOUNTPAID - Static variable in class bb.common.SalesTaxListResult
ORDER_BY_AMOUNTPAID - Static variable in class bb.common.VendorStatementListResult
ORDER_BY_ANNUALDEPRECIATIONRATE - Static variable in class bb.common.AssetVO
ORDER_BY_APDUEDAYS - Static variable in class bb.common.PaymentHistoryVO
ORDER_BY_APFREIGHT - Static variable in class bb.common.AccountsPayableInfoVO
ORDER_BY_APITEMNUMBER - Static variable in class bb.common.APItemListResult
ORDER_BY_APNET - Static variable in class bb.common.AccountsPayableInfoVO
ORDER_BY_APNET - Static variable in class bb.common.ReturnToVendorByDateListResult
ORDER_BY_APNUMBER - Static variable in class bb.common.AccountsPayableInfoVO
ORDER_BY_APNUMBER - Static variable in class bb.common.APAgingItemListResult
ORDER_BY_APNUMBER - Static variable in class bb.common.APAuditListResult
ORDER_BY_APNUMBER - Static variable in class bb.common.ApCheckRunListResult
ORDER_BY_APNUMBER - Static variable in class bb.common.APItemListResult
ORDER_BY_APNUMBER - Static variable in class bb.common.GeneralLedgerByDateListResult
ORDER_BY_apNumber - Static variable in class bb.common.RtvShipperItemListResult
ORDER_BY_APNUMBER - Static variable in class bb.common.RtvShipperListResult
ORDER_BY_APNUMBER - Static variable in class bb.common.VendorStatementListResult
ORDER_BY_APOPEN - Static variable in class bb.common.PurchaseOrderItemListResult
ORDER_BY_APPAIDRCV - Static variable in class bb.common.AccountsPayableInfoVO
ORDER_BY_APPDAMAGED - Static variable in class bb.common.PhysicalInventoryListWithAppDataResult
ORDER_BY_APPDATE - Static variable in class bb.common.ApPrepayVO
ORDER_BY_APPNORMAL - Static variable in class bb.common.PhysicalInventoryListWithAppDataResult
ORDER_BY_APPOBSOLETE - Static variable in class bb.common.PhysicalInventoryListWithAppDataResult
ORDER_BY_APPOTHER - Static variable in class bb.common.PhysicalInventoryListWithAppDataResult
ORDER_BY_APPREPAYNUMBER - Static variable in class bb.common.ApPrepayVO
ORDER_BY_APPROVALLIMIT - Static variable in class bb.common.RTVApprovalVO
ORDER_BY_APPROVED - Static variable in class bb.common.WorkInstructionListResult
ORDER_BY_APPROVEDATE - Static variable in class bb.common.TransferOrderListResult
ORDER_BY_APPROVEDATE - Static variable in class bb.common.TransferOrderVO
ORDER_BY_APPROVEDBY - Static variable in class bb.common.GLAutoApproveVO
ORDER_BY_APPROVEDBY - Static variable in class bb.common.NonproductivePickingItemResult
ORDER_BY_APPROVEDBY - Static variable in class bb.common.NonproductivePickingVO
ORDER_BY_APPROVEDBY - Static variable in class bb.common.SGCustomerServiceRequestVO
ORDER_BY_APPROVEDBY - Static variable in class bb.common.TransferOrderListResult
ORDER_BY_APPROVEDBY - Static variable in class bb.common.TransferOrderVO
ORDER_BY_APPROVEDBY - Static variable in class bb.common.WorkInstructionListResult
ORDER_BY_APPROVEDBY - Static variable in class bb.common.WorkInstructionRequestForChangeVO
ORDER_BY_APPROVEDDATE - Static variable in class bb.common.NonproductivePickingItemResult
ORDER_BY_APPROVEDDATE - Static variable in class bb.common.NonproductivePickingVO
ORDER_BY_APPROVEDDATE - Static variable in class bb.common.WorkInstructionRequestForChangeVO
ORDER_BY_APPROVEDOPINIONENG - Static variable in class bb.common.NcrReportListResult
ORDER_BY_APPROVEDOPINIONMFG - Static variable in class bb.common.NcrReportListResult
ORDER_BY_APPROVEDOPINIONQA - Static variable in class bb.common.NcrReportListResult
ORDER_BY_APPROVELIMIT - Static variable in class bb.common.GeneralLedgerApprovalVO
ORDER_BY_APPROVELIMIT - Static variable in class bb.common.PurchaseOrderApprovalVO
ORDER_BY_APPROVELIMIT - Static variable in class bb.common.WorkOrderApprovalVO
ORDER_BY_APPROVETYPE - Static variable in class bb.common.NcrApprovalVO
ORDER_BY_APPSLUGGISH - Static variable in class bb.common.PhysicalInventoryListWithAppDataResult
ORDER_BY_APRECEIVED - Static variable in class bb.common.PurchaseOrderItemListResult
ORDER_BY_APTAX - Static variable in class bb.common.AccountsPayableInfoVO
ORDER_BY_ARAPDATE - Static variable in class bb.common.TempArApAgingVO
ORDER_BY_ARAPNUMBER - Static variable in class bb.common.TempArApAgingVO
ORDER_BY_ARBOILERPLATE - Static variable in class bb.common.ARBoilerplateVO
ORDER_BY_ARDUEDAYS - Static variable in class bb.common.PaymentHistoryVO
ORDER_BY_ARFREIGHT - Static variable in class bb.common.TransferReceiverListResult
ORDER_BY_ARFREIGHT - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_ARINVOICENUMBER - Static variable in class bb.common.ShipperItemListResult
ORDER_BY_ARNUMBER - Static variable in class bb.common.ARAuditListResult
ORDER_BY_ARNUMBER - Static variable in class bb.common.ARPaymentRunListResult
ORDER_BY_ARNUMBER - Static variable in class bb.common.GeneralLedgerByDateListResult
ORDER_BY_ARPDATE - Static variable in class bb.common.ArPrepayVO
ORDER_BY_ARPREPAYNUMBER - Static variable in class bb.common.ArPrepayVO
ORDER_BY_ARRIVEDATE - Static variable in class bb.common.PurchaseOrderItemListResult
ORDER_BY_ARRIVEDATE - Static variable in class bb.common.SalesOrderItemListResult
ORDER_BY_ARRIVEDATE - Static variable in class bb.common.TransferOrderItemListResult
ORDER_BY_ASM - Static variable in class bb.common.WorkOrderItemListResult
ORDER_BY_ASMPART - Static variable in class bb.common.WOItemPartDetailNotIssue
ORDER_BY_ASSETNAME - Static variable in class bb.common.CustomAssetVO
ORDER_BY_ASSETNUM - Static variable in class bb.common.EquipmentListResult
ORDER_BY_ASSETNUMBER - Static variable in class bb.common.AssetAddOrDisposalsReport
ORDER_BY_ASSETNUMBER - Static variable in class bb.common.AssetVO
ORDER_BY_ASSETNUMBER - Static variable in class bb.common.CustomAssetVO
ORDER_BY_ASSETORDER - Static variable in class bb.common.CustomAssetVO
ORDER_BY_ASSETTYPE - Static variable in class bb.common.AssetAddOrDisposalsReport
ORDER_BY_ASSETTYPE - Static variable in class bb.common.AssetDepreciateDetailReport
ORDER_BY_ASSETTYPE - Static variable in class bb.common.AssetDepreciateVO
ORDER_BY_ASSETTYPE - Static variable in class bb.common.AssetVO
ORDER_BY_ASSETTYPE - Static variable in class bb.common.DepreciateMonthlyReport
ORDER_BY_ASSETTYPE2 - Static variable in class bb.common.AssetVO
ORDER_BY_ASSIGNEDTO - Static variable in class bb.common.ToolCalibrateListResult
ORDER_BY_ASSIGNEDTO - Static variable in class bb.common.ToolCalibrationVO
ORDER_BY_AUTHOR - Static variable in class bb.common.WorkInstructionListResult
ORDER_BY_AUTHOR - Static variable in class bb.common.WorkInstructionSequenceListResult
ORDER_BY_AVERAGECOST - Static variable in class bb.common.InventoryNotUsedInMonthsResult
ORDER_BY_AVERAGECOST - Static variable in class bb.common.PartCostVarianceListResult
ORDER_BY_AVERAGECOST - Static variable in class bb.common.PartOnHandWithMfgInfoResult
ORDER_BY_AVERAGECOST - Static variable in class bb.common.ShipperItemListResult
ORDER_BY_AVGCOST - Static variable in class bb.common.AccountsReceivableItemResult
ORDER_BY_AVGCOST - Static variable in class bb.common.AccountsReceivableItemVO
ORDER_BY_AVGCOST - Static variable in class bb.common.ChangeStdCostWorkSheetItemVO
ORDER_BY_AVGCOST - Static variable in class bb.common.CycleCountListResult
ORDER_BY_AVGCOST - Static variable in class bb.common.InventoryAdjustmentVO
ORDER_BY_AVGCOST - Static variable in class bb.common.NonproductivePickingItemIssuedListResult
ORDER_BY_AVGCOST - Static variable in class bb.common.PartBasicInfoWithNewEngGroup
ORDER_BY_AVGCOST - Static variable in class bb.common.PartBasicInfoWithNewListPrice
ORDER_BY_AVGCOST - Static variable in class bb.common.PartWithExcessiveInventoryListResult
ORDER_BY_AVGCOST - Static variable in class bb.common.PartWithOnLoanQtyListResult
ORDER_BY_AVGCOST - Static variable in class bb.common.PartWithQAQtyListResult
ORDER_BY_AVGCOST - Static variable in class bb.common.PartWithQtyListResult
ORDER_BY_AVGCOST - Static variable in class bb.common.PartWithSipQtyListResult
ORDER_BY_AVGCOST - Static variable in class bb.common.PartWithSITQtyListResult
ORDER_BY_AVGCOST - Static variable in class bb.common.PartWithSTOQtyListResult
ORDER_BY_AVGCOST - Static variable in class bb.common.PartWithWipQtyListResult
ORDER_BY_AVGCOST - Static variable in class bb.common.PhysicalInventoryListResult
ORDER_BY_AVGCOST - Static variable in class bb.common.RollUpBomStdCostWorkSheetItemVO
ORDER_BY_AVGCOST - Static variable in class bb.common.SwapReceiverItemListResult
ORDER_BY_AVGCOST - Static variable in class bb.common.SwapShipperItemListResult
ORDER_BY_AVGCOST - Static variable in class bb.common.TransferOrderItemListResult
ORDER_BY_AVGCOST - Static variable in class bb.common.TransferReceiverItemListResult
ORDER_BY_AVGCOST - Static variable in class bb.common.TransferShipperItemListResult
ORDER_BY_AVGCOST - Static variable in class bb.common.WOItemPartDetailNotIssue
ORDER_BY_AVGCOST - Static variable in class bb.common.WorkOrderItemInWipListResult
ORDER_BY_AVGHRS - Static variable in class bb.common.WorkCenterRunTimeListResult
ORDER_BY_AVGSETUP - Static variable in class bb.common.WorkCenterRunTimeListResult
ORDER_BY_BALANCEDUE - Static variable in class bb.common.CustomerStatementListResult
ORDER_BY_BALANCEDUE - Static variable in class bb.common.VendorStatementListResult
ORDER_BY_BATCH - Static variable in class bb.common.GeneralLedgerByDateListResult
ORDER_BY_BATCH - Static variable in class bb.common.GLDebitCreditListResult
ORDER_BY_BB2COUNT - Static variable in class bb.common.LogPartDwfVO
ORDER_BY_BB2COUNT - Static variable in class bb.common.LogPartDwgVO
ORDER_BY_BILL - Static variable in class bb.common.PartBasicInfo
ORDER_BY_BILL - Static variable in class bb.common.PartOnHandWithMfgInfoResult
ORDER_BY_BILL - Static variable in class bb.common.PartWithManufacturerInfoResult
ORDER_BY_BILLITEMNUMBER - Static variable in class bb.common.BillLogVO
ORDER_BY_BILLNUMBER - Static variable in class bb.common.BillLogVO
ORDER_BY_BILLPK - Static variable in class bb.common.BillOnHandWithPartInfoResult
ORDER_BY_BILLPK - Static variable in class bb.common.BillWithPartInfoResult
ORDER_BY_BILLPK - Static variable in class bb.common.ToolListWithToolInfoResult
ORDER_BY_BILLTO - Static variable in class bb.common.AccountsReceivableInfoVO
ORDER_BY_BILLTOID - Static variable in class bb.common.ProformaInvoiceListResult
ORDER_BY_BILLTYPE - Static variable in class bb.common.BillLogVO
ORDER_BY_BIRTHDATE - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_BLOODPRESSURE - Static variable in class bb.common.CustomCheckUpEmployeeVO
ORDER_BY_BOILERPLATEID - Static variable in class bb.common.ARBoilerplateVO
ORDER_BY_BOILERPLATEID - Static variable in class bb.common.PurchaseOrderBoilerplateVO
ORDER_BY_BOILERPLATEID - Static variable in class bb.common.QuoteBoilerplateVO
ORDER_BY_BOILERPLATEID - Static variable in class bb.common.SalesOrderBoilerplateVO
ORDER_BY_BOILERPLATEID - Static variable in class bb.common.WorkOrderBoilerplateVO
ORDER_BY_BOMCOUNT - Static variable in class bb.common.RollUpBomStdCostWorkSheetVO
ORDER_BY_BULTRASONIC - Static variable in class bb.common.CustomCheckUpEmployeeVO
ORDER_BY_BUYDATE - Static variable in class bb.common.CustomAssetVO
ORDER_BY_BUYER - Static variable in class bb.common.AccountsPayableInfoVO
ORDER_BY_BUYER - Static variable in class bb.common.NcrReportListResult
ORDER_BY_BUYER - Static variable in class bb.common.POReceiverItemListResult
ORDER_BY_BUYER - Static variable in class bb.common.PrReceiverListResult
ORDER_BY_BUYER - Static variable in class bb.common.PurchaseOrderItemListResult
ORDER_BY_BUYER - Static variable in class bb.common.PurchaseOrderOpenDueListResult
ORDER_BY_BUYER - Static variable in class bb.common.RequestForQuoteCheckListResult
ORDER_BY_BUYER - Static variable in class bb.common.RequestForQuoteItemListResult
ORDER_BY_BUYER - Static variable in class bb.common.RequestForQuoteListResult
ORDER_BY_BUYER - Static variable in class bb.common.ReturnToVendorByDateListResult
ORDER_BY_BUYER - Static variable in class bb.common.ReturnToVendorCheckListResult
ORDER_BY_BUYER - Static variable in class bb.common.ReturnToVendorItemListResult
ORDER_BY_BUYER - Static variable in class bb.common.SwapReceiverListResult
ORDER_BY_BUYER - Static variable in class bb.common.SwapShipperListResult
ORDER_BY_BUYERCODE - Static variable in class bb.common.BuyerCodeVO
ORDER_BY_BUYERCODE - Static variable in class bb.common.InventoryListResult
ORDER_BY_BUYERCODE - Static variable in class bb.common.PartBasicInfo
ORDER_BY_BUYERCODE - Static variable in class bb.common.PartBasicInfoWithNewEngGroup
ORDER_BY_BUYERCODE - Static variable in class bb.common.PartBasicInfoWithNewListPrice
ORDER_BY_BUYERCODE - Static variable in class bb.common.PartOnHandWithMfgInfoResult
ORDER_BY_BUYERCODE - Static variable in class bb.common.PartOnHandWithPartBasicInfoResult
ORDER_BY_BUYERCODE - Static variable in class bb.common.PartWithInventoryInfoListResult
ORDER_BY_BUYERCODE - Static variable in class bb.common.PartWithoutLocateResult
ORDER_BY_BUYERCODE - Static variable in class bb.common.POReceiverItemListResult
ORDER_BY_BUYERGROUP - Static variable in class bb.common.SwapReceiverListResult
ORDER_BY_BUYERGROUP - Static variable in class bb.common.SwapShipperListResult
ORDER_BY_BUYERNAME - Static variable in class bb.common.BuyerCodeVO
ORDER_BY_BUYERNAME - Static variable in class bb.common.PurchaseOrderListResult
ORDER_BY_CANAPPROVEOWN - Static variable in class bb.common.NcrApprovalVO
ORDER_BY_CANAPPROVEOWN - Static variable in class bb.common.SwapOrderApprovalVO
ORDER_BY_CANAPPROVEOWN - Static variable in class bb.common.TransferOrderApprovalVO
ORDER_BY_CANAPPROVEOWNBOM - Static variable in class bb.common.BomApprovalVO
ORDER_BY_CANAPPROVEOWNPURCHASEORDER - Static variable in class bb.common.PurchaseOrderApprovalVO
ORDER_BY_CANAPPROVEOWNPURCHASEORDER - Static variable in class bb.common.WorkOrderApprovalVO
ORDER_BY_CANAPPROVEOWNRTV - Static variable in class bb.common.RTVApprovalVO
ORDER_BY_CANAPPROVEOWNWORKINSTRUCTION - Static variable in class bb.common.WorkInstructionApprovalVO
ORDER_BY_CANREVIEWOWNNONPROPICKING - Static variable in class bb.common.NonproductivePickingApprovalVO
ORDER_BY_CANREVIEWOWNNONPROPICKING - Static variable in class bb.common.NonproductivePickingApproveVO
ORDER_BY_CANREVIEWOWNONLOAN - Static variable in class bb.common.OnloanReviewVO
ORDER_BY_CANREVIEWOWNRMA - Static variable in class bb.common.RMAReviewVO
ORDER_BY_CANREVIEWOWNSALESORDER - Static variable in class bb.common.SalesOrderReviewVO
ORDER_BY_CARDID - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_CARNUMBER - Static variable in class bb.common.CorrectiveActionRequestVO
ORDER_BY_CARRIER - Static variable in class bb.common.SwapReceiverListResult
ORDER_BY_CARRIER - Static variable in class bb.common.SwapShipperListResult
ORDER_BY_CARRIER - Static variable in class bb.common.TransferOrderListResult
ORDER_BY_CARRIER - Static variable in class bb.common.TransferOrderVO
ORDER_BY_CARRIER - Static variable in class bb.common.TransferReceiverListResult
ORDER_BY_CARRIER - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_CARRIERACCOUNT - Static variable in class bb.common.SwapReceiverListResult
ORDER_BY_CARRIERACCOUNT - Static variable in class bb.common.SwapShipperListResult
ORDER_BY_CARRIERACCOUNT - Static variable in class bb.common.TransferOrderListResult
ORDER_BY_CARRIERACCOUNT - Static variable in class bb.common.TransferOrderVO
ORDER_BY_CARRIERACCOUNT - Static variable in class bb.common.TransferReceiverListResult
ORDER_BY_CARRIERACCOUNT - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_CATALOG - Static variable in class bb.common.SGPartCatalogResult
ORDER_BY_CATALOG - Static variable in class bb.common.SGSaleItemVO
ORDER_BY_CATEGORYID - Static variable in class bb.common.PartTraceableResult
ORDER_BY_CATEGORYNAME - Static variable in class bb.common.AccountsChartCategoryVO
ORDER_BY_CATEGORYSEQUENCE - Static variable in class bb.common.GeneralLedgerVO
ORDER_BY_CERTIFICATENAME - Static variable in class bb.common.CustomEmployeeTrainVO
ORDER_BY_CERTIFICATENUMBER - Static variable in class bb.common.PartCertificateListResult
ORDER_BY_CERTIFICATIONID - Static variable in class bb.common.CustomEmployeeTrainVO
ORDER_BY_CHANGEORDER - Static variable in class bb.common.CRTVListResult
ORDER_BY_CHANGEORDER - Static variable in class bb.common.DisassembleWorkOrderListResult
ORDER_BY_CHANGEORDER - Static variable in class bb.common.QuoteListResult
ORDER_BY_CHANGEORDER - Static variable in class bb.common.RMAListResult
ORDER_BY_CHANGEORDER - Static variable in class bb.common.RRMAListResult
ORDER_BY_CHECKACCOUNTNUMBER - Static variable in class bb.common.PayableMethodVO
ORDER_BY_CHECKEACHOTHER - Static variable in class bb.common.InspectionReportInfoVO
ORDER_BY_CHECKNUMBER - Static variable in class bb.common.AccountPayableCheckRunVO
ORDER_BY_CHECKNUMBER - Static variable in class bb.common.AccountPayableCheckVO
ORDER_BY_CHECKNUMBER - Static variable in class bb.common.ApCheckRunListResult
ORDER_BY_CHECKNUMBER - Static variable in class bb.common.GeneralLedgerListResult
ORDER_BY_CHECKNUMBER - Static variable in class bb.common.GLDebitCreditListResult
ORDER_BY_CHECKRUNNUMBER - Static variable in class bb.common.AccountPayableCheckRunVO
ORDER_BY_CHECKRUNNUMBER - Static variable in class bb.common.AccountPayableCheckVO
ORDER_BY_CHECKRUNNUMBER - Static variable in class bb.common.ApCheckRunListResult
ORDER_BY_CHECKTIME - Static variable in class bb.common.CustomCheckUpEmployeeVO
ORDER_BY_CITY - Static variable in class bb.common.CustomerVendorAddressInfoVO
ORDER_BY_CITY - Static variable in class bb.common.LockedCustomerAddressResult
ORDER_BY_CITY - Static variable in class bb.common.ManufacturerAddressInfoVO
ORDER_BY_CITY - Static variable in class bb.common.SGCustRequestForQuoteListResult
ORDER_BY_CITYCODE - Static variable in class bb.common.PosZipCodeTaxVO
ORDER_BY_CLEANWORKER - Static variable in class bb.common.InspectionReportInfoVO
ORDER_BY_CLINICALAB - Static variable in class bb.common.CustomCheckUpEmployeeVO
ORDER_BY_CLOSEDDATE - Static variable in class bb.common.CustomerServiceIncidentItemListResult
ORDER_BY_CLOSEDOUTDATE - Static variable in class bb.common.IcrListResult
ORDER_BY_CLOSEDOUTDATE - Static variable in class bb.common.InspectionConformanceReportVO
ORDER_BY_CLOSEDOUTDATE - Static variable in class bb.common.NcrReportListResult
ORDER_BY_CLOSEDOUTPRIVATENOTES - Static variable in class bb.common.NcrReportListResult
ORDER_BY_CLOSEOUTDATE - Static variable in class bb.common.IcrItemListResult
ORDER_BY_CLOSEOUTPRIVATENOTES - Static variable in class bb.common.EngineeringChangeRequestListResult
ORDER_BY_COCOMMENTS - Static variable in class bb.common.SwapReceiverListResult
ORDER_BY_COCOMMENTS - Static variable in class bb.common.SwapShipperListResult
ORDER_BY_COCOMMENTS - Static variable in class bb.common.TransferReceiverListResult
ORDER_BY_COCOMMENTS - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_CODE - Static variable in class bb.common.NonConformanceCodeVO
ORDER_BY_COLUMN_NUMBER - Static variable in class bb.common.ImportDataVO
ORDER_BY_COMMENT - Static variable in class bb.common.BizBoxUserEmployeeResult
ORDER_BY_COMMENT - Static variable in class bb.common.CustomCheckUpEmployeeVO
ORDER_BY_COMMENT - Static variable in class bb.common.OperationLogVO
ORDER_BY_COMMENT - Static variable in class bb.common.ToolCalibrateListResult
ORDER_BY_COMMENTS - Static variable in class bb.common.AccountingInfoDocumentVO
ORDER_BY_COMMENTS - Static variable in class bb.common.AllPartDocumentsVO
ORDER_BY_COMMENTS - Static variable in class bb.common.BomApprovalVO
ORDER_BY_COMMENTS - Static variable in class bb.common.BuyerCodeVO
ORDER_BY_COMMENTS - Static variable in class bb.common.ChangeStdCostWorkSheetVO
ORDER_BY_COMMENTS - Static variable in class bb.common.CompanyUnitVO
ORDER_BY_COMMENTS - Static variable in class bb.common.ContractPriceItemVO
ORDER_BY_COMMENTS - Static variable in class bb.common.CRTVListResult
ORDER_BY_COMMENTS - Static variable in class bb.common.CustomAssetVO
ORDER_BY_COMMENTS - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_COMMENTS - Static variable in class bb.common.CustomGoodsBreedVO
ORDER_BY_COMMENTS - Static variable in class bb.common.CustomJobCategoryVO
ORDER_BY_COMMENTS - Static variable in class bb.common.ECNReviewVO
ORDER_BY_COMMENTS - Static variable in class bb.common.ECRReviewVO
ORDER_BY_COMMENTS - Static variable in class bb.common.EmployeeRecordsVO
ORDER_BY_COMMENTS - Static variable in class bb.common.EngGroupUserVO
ORDER_BY_COMMENTS - Static variable in class bb.common.GeneralLedgerApprovalVO
ORDER_BY_COMMENTS - Static variable in class bb.common.IcrItemListResult
ORDER_BY_COMMENTS - Static variable in class bb.common.IcrListResult
ORDER_BY_COMMENTS - Static variable in class bb.common.InspectionConformanceReportVO
ORDER_BY_COMMENTS - Static variable in class bb.common.LabelTemplateVO
ORDER_BY_COMMENTS - Static variable in class bb.common.LogTaskVO
ORDER_BY_COMMENTS - Static variable in class bb.common.NcrApprovalVO
ORDER_BY_COMMENTS - Static variable in class bb.common.NonproductivePickingApprovalVO
ORDER_BY_COMMENTS - Static variable in class bb.common.PartClassVO
ORDER_BY_COMMENTS - Static variable in class bb.common.PartInQAVO
ORDER_BY_COMMENTS - Static variable in class bb.common.PrReceiverListResult
ORDER_BY_COMMENTS - Static variable in class bb.common.PurchaseOrderListResult
ORDER_BY_COMMENTS - Static variable in class bb.common.QuoteListResult
ORDER_BY_COMMENTS - Static variable in class bb.common.RRMAListResult
ORDER_BY_COMMENTS - Static variable in class bb.common.SwapOrderApprovalVO
ORDER_BY_COMMENTS - Static variable in class bb.common.TermVO
ORDER_BY_COMMENTS - Static variable in class bb.common.TransferOrderApprovalVO
ORDER_BY_COMMENTS - Static variable in class bb.common.TransferOrderListResult
ORDER_BY_COMMENTS - Static variable in class bb.common.TransferOrderVO
ORDER_BY_COMMENTS - Static variable in class bb.common.VendorContractPriceItemVO
ORDER_BY_COMMENTS - Static variable in class bb.common.WarehouseVO
ORDER_BY_COMMISSIONRATE - Static variable in class bb.common.ArCommissionListResult
ORDER_BY_COMMISSIONRATE - Static variable in class bb.common.ArSalesCodeTotalListResult
ORDER_BY_COMMISSIONRATE - Static variable in class bb.common.SalesCodeVO
ORDER_BY_COMMISSIONTOTAL - Static variable in class bb.common.ArSalesCodeTotalListResult
ORDER_BY_COMMITTED - Static variable in class bb.common.CycleCountListResult
ORDER_BY_COMMITTED - Static variable in class bb.common.InventoryAdjustmentVO
ORDER_BY_COMMITTED - Static variable in class bb.common.PhysicalInventoryListResult
ORDER_BY_COMMITTEDBY - Static variable in class bb.common.ChangeStdCostWorkSheetVO
ORDER_BY_COMMITTEDBY - Static variable in class bb.common.RollUpBomStdCostWorkSheetVO
ORDER_BY_COMMITTEDDATE - Static variable in class bb.common.ChangeStdCostWorkSheetVO
ORDER_BY_COMMITTEDDATE - Static variable in class bb.common.RollUpBomStdCostWorkSheetVO
ORDER_BY_COMMODITYCODE - Static variable in class bb.common.InventoryListResult
ORDER_BY_COMMODITYCODE - Static variable in class bb.common.PartBasicInfo
ORDER_BY_COMMODITYCODE - Static variable in class bb.common.PartBasicInfoWithNewEngGroup
ORDER_BY_COMMODITYCODE - Static variable in class bb.common.PartBasicInfoWithNewListPrice
ORDER_BY_COMMODITYCODE - Static variable in class bb.common.PartOnHandWithMfgInfoResult
ORDER_BY_COMMODITYCODE - Static variable in class bb.common.PartOnHandWithPartBasicInfoResult
ORDER_BY_COMMODITYCODE - Static variable in class bb.common.PartWithoutLocateResult
ORDER_BY_COMMODITYCODE - Static variable in class bb.common.SalesOrderItemListResult
ORDER_BY_COMPANYADDRESSBOOKNAME - Static variable in class bb.common.EmployeeCardVO
ORDER_BY_COMPANYNAME - Static variable in class bb.common.PartCertificateListResult
ORDER_BY_COMPANYNUITID - Static variable in class bb.common.POReceiverItemListResult
ORDER_BY_COMPANYNUITID - Static variable in class bb.common.PurchaseOrderItemListResult
ORDER_BY_COMPANYNUITID - Static variable in class bb.common.SalesOrderItemListResult
ORDER_BY_COMPANYNUITID - Static variable in class bb.common.ShipperItemListResult
ORDER_BY_COMPANYUNITID - Static variable in class bb.common.AccountBalanceListResult
ORDER_BY_COMPANYUNITID - Static variable in class bb.common.AccountBalanceResult
ORDER_BY_COMPANYUNITID - Static variable in class bb.common.AccountingInfoDocumentVO
ORDER_BY_companyUnitId - Static variable in class bb.common.AccountReceivableInfoWithPrepayResult
ORDER_BY_COMPANYUNITID - Static variable in class bb.common.AccountsPayableInfoVO
ORDER_BY_COMPANYUNITID - Static variable in class bb.common.AccountsReceivableInfoVO
ORDER_BY_COMPANYUNITID - Static variable in class bb.common.APItemListResult
ORDER_BY_COMPANYUNITID - Static variable in class bb.common.ApPrepayVO
ORDER_BY_COMPANYUNITID - Static variable in class bb.common.ArPrepayVO
ORDER_BY_COMPANYUNITID - Static variable in class bb.common.BizboxUserVO
ORDER_BY_COMPANYUNITID - Static variable in class bb.common.DisassembleWorkOrderItemListResult
ORDER_BY_COMPANYUNITID - Static variable in class bb.common.DWOIssueDetail
ORDER_BY_COMPANYUNITID - Static variable in class bb.common.InvoiceItemListResult
ORDER_BY_COMPANYUNITID - Static variable in class bb.common.NonproductivePickingItemResult
ORDER_BY_COMPANYUNITID - Static variable in class bb.common.NonproductivePickingTypeVO
ORDER_BY_COMPANYUNITID - Static variable in class bb.common.NonproductivePickingVO
ORDER_BY_COMPANYUNITID - Static variable in class bb.common.PayableMethodVO
ORDER_BY_COMPANYUNITID - Static variable in class bb.common.PurchaseWorkSheetVO
ORDER_BY_COMPANYUNITID - Static variable in class bb.common.ReturnToVendorByDateListResult
ORDER_BY_COMPANYUNITID - Static variable in class bb.common.RMAItemListResult
ORDER_BY_COMPANYUNITID - Static variable in class bb.common.SalesmanVO
ORDER_BY_COMPANYUNITID - Static variable in class bb.common.TempArApAgingVO
ORDER_BY_COMPANYUNITID - Static variable in class bb.common.WOReceiverDetail
ORDER_BY_COMPANYUNITID - Static variable in class bb.common.WorkOrderItemListResult
ORDER_BY_COMPANYUNITID - Static variable in class bb.common.WorkOrderItemPartDetailInWipVO
ORDER_BY_COMPANYUNITID - Static variable in class bb.common.WorkOrderWorkSheetVO
ORDER_BY_COMPLETEDDATE - Static variable in class bb.common.WorkOrderItemListResult
ORDER_BY_CONSIGNEDQTY - Static variable in class bb.common.HistoricalInventoryVO
ORDER_BY_CONTACT - Static variable in class bb.common.PrReceiverListResult
ORDER_BY_CONTACT - Static variable in class bb.common.SwapReceiverListResult
ORDER_BY_CONTACT - Static variable in class bb.common.SwapShipperListResult
ORDER_BY_CONTACT - Static variable in class bb.common.TransferOrderListResult
ORDER_BY_CONTACT - Static variable in class bb.common.TransferOrderVO
ORDER_BY_CONTACTDATE - Static variable in class bb.common.CustomerFeedbackVO
ORDER_BY_CONTACTNAME - Static variable in class bb.common.SGCustRequestForQuoteListResult
ORDER_BY_CONTRACTNAME - Static variable in class bb.common.ContractPriceCustomerVO
ORDER_BY_CONTRACTNAME - Static variable in class bb.common.ContractPriceItemVO
ORDER_BY_CONTRACTNAME - Static variable in class bb.common.VendorContractPriceItemVO
ORDER_BY_CONTRACTNAME - Static variable in class bb.common.VendorContractPriceVendorVO
ORDER_BY_CONTRACTNUMBER - Static variable in class bb.common.ContractPriceVO
ORDER_BY_CONTRACTNUMBER - Static variable in class bb.common.POSurveyReportVO
ORDER_BY_CONTRACTNUMBER - Static variable in class bb.common.VendorContractPriceVO
ORDER_BY_CONTROLNUMBER - Static variable in class bb.common.LogMiscDocumentVO
ORDER_BY_COST - Static variable in class bb.common.InventoryListResult
ORDER_BY_COST - Static variable in class bb.common.PartInQAVO
ORDER_BY_COST - Static variable in class bb.common.SalesOrder12MonthMarginResult
ORDER_BY_COST - Static variable in class bb.common.WorkOrderItemPartDetail
ORDER_BY_COST - Static variable in class bb.common.WorkOrderItemPartDetailInWipVO
ORDER_BY_COSTPERUNIT - Static variable in class bb.common.DisassembleWorkOrderItemListResult
ORDER_BY_COSTPERUNIT - Static variable in class bb.common.POReceiverItemListResult
ORDER_BY_COSTPERUNIT - Static variable in class bb.common.PurchaseOrderItemListResult
ORDER_BY_COSTPERUNIT - Static variable in class bb.common.RequestForQuoteItemListResult
ORDER_BY_COSTPERUNIT - Static variable in class bb.common.ReturnToVendorByDateListResult
ORDER_BY_costPerUnit - Static variable in class bb.common.RtvShipperItemListResult
ORDER_BY_COSTPERUNIT - Static variable in class bb.common.WorkOrderItemListResult
ORDER_BY_COUNTEDBY - Static variable in class bb.common.CycleCountListResult
ORDER_BY_COUNTEDBY - Static variable in class bb.common.InventoryAdjustmentListResult
ORDER_BY_COUNTEDBY - Static variable in class bb.common.InventoryAdjustmentVO
ORDER_BY_COUNTEDBY - Static variable in class bb.common.PhysicalInventoryListResult
ORDER_BY_COUNTEDDATE - Static variable in class bb.common.CycleCountListResult
ORDER_BY_COUNTEDDATE - Static variable in class bb.common.InventoryAdjustmentListResult
ORDER_BY_COUNTEDDATE - Static variable in class bb.common.InventoryAdjustmentVO
ORDER_BY_COUNTEDDATE - Static variable in class bb.common.PhysicalInventoryListResult
ORDER_BY_COUNTRY - Static variable in class bb.common.CustomerVendorAddressInfoVO
ORDER_BY_COUNTRY - Static variable in class bb.common.LockedCustomerAddressResult
ORDER_BY_COUNTRY - Static variable in class bb.common.ManufacturerAddressInfoVO
ORDER_BY_COUNTRY - Static variable in class bb.common.SalesMarginListResult
ORDER_BY_COUNTRY - Static variable in class bb.common.SalesOrderItemListResult
ORDER_BY_COUNTRY - Static variable in class bb.common.SGCustRequestForQuoteListResult
ORDER_BY_COUNTYCODE - Static variable in class bb.common.PosZipCodeTaxVO
ORDER_BY_CREATEDATE - Static variable in class bb.common.CustomerVendorAddressInfoVO
ORDER_BY_CREATEDATE - Static variable in class bb.common.PhysicalInventoryStatusVO
ORDER_BY_CREATEDBY - Static variable in class bb.common.ChangeStdCostWorkSheetVO
ORDER_BY_CREATEDBY - Static variable in class bb.common.RollUpBomStdCostWorkSheetVO
ORDER_BY_CREATEDDATE - Static variable in class bb.common.BillWithPartInfoResult
ORDER_BY_CREATEDDATE - Static variable in class bb.common.ChangeStdCostWorkSheetVO
ORDER_BY_CREATEDDATE - Static variable in class bb.common.RollUpBomStdCostWorkSheetVO
ORDER_BY_CREATOR - Static variable in class bb.common.PhysicalInventoryStatusVO
ORDER_BY_CREDIT - Static variable in class bb.common.GLDebitCreditListResult
ORDER_BY_CREDITACCOUNT - Static variable in class bb.common.InvoiceItemListResult
ORDER_BY_CREDITACCOUNTS - Static variable in class bb.common.GeneralLedgerCategoryVO
ORDER_BY_CREDITMEMONUMBER - Static variable in class bb.common.RMAReceiverListResult
ORDER_BY_CRFQNUMBER - Static variable in class bb.common.SGCustRequestForQuoteListResult
ORDER_BY_CRITICALLEVEL - Static variable in class bb.common.CustomerVendorAddressInfoVO
ORDER_BY_CRITICALLEVEL - Static variable in class bb.common.LockedCustomerAddressResult
ORDER_BY_CRTVDATE - Static variable in class bb.common.CRTVListResult
ORDER_BY_CRTVDATE - Static variable in class bb.common.RRMAListResult
ORDER_BY_CRTVNUMBER - Static variable in class bb.common.CRTVItemListResult
ORDER_BY_CRTVNUMBER - Static variable in class bb.common.CRTVListResult
ORDER_BY_CRTVNUMBER - Static variable in class bb.common.RRMAItemListResult
ORDER_BY_CRTVNUMBER - Static variable in class bb.common.RRMAListResult
ORDER_BY_CSINUMBER - Static variable in class bb.common.CustomerServiceIncidentItemListResult
ORDER_BY_CSINUMBER - Static variable in class bb.common.CustomerServiceIncidentListResult
ORDER_BY_CSINUMBER - Static variable in class bb.common.SGCustomerServiceRequestVO
ORDER_BY_CSRDATE - Static variable in class bb.common.SGCustomerServiceRequestVO
ORDER_BY_CSRNUMBER - Static variable in class bb.common.SGCustomerServiceRequestVO
ORDER_BY_CURRENCY - Static variable in class bb.common.AccountsPayableInfoVO
ORDER_BY_CURRENCY - Static variable in class bb.common.AccountsReceivableInfoVO
ORDER_BY_CURRENCY - Static variable in class bb.common.ApCheckRunListResult
ORDER_BY_CURRENCY - Static variable in class bb.common.ArCommissionListResult
ORDER_BY_CURRENCY - Static variable in class bb.common.ContractPriceVO
ORDER_BY_CURRENCY - Static variable in class bb.common.CurrencyVO
ORDER_BY_CURRENCY - Static variable in class bb.common.CustomerStatementTotalResult
ORDER_BY_CURRENCY - Static variable in class bb.common.DisassembleWorkOrderItemListResult
ORDER_BY_CURRENCY - Static variable in class bb.common.InvoiceItemListResult
ORDER_BY_CURRENCY - Static variable in class bb.common.NonproductivePickingApproveVO
ORDER_BY_CURRENCY - Static variable in class bb.common.OnloanReviewVO
ORDER_BY_CURRENCY - Static variable in class bb.common.PartIssuedListResult
ORDER_BY_CURRENCY - Static variable in class bb.common.PartReceivedListResult
ORDER_BY_CURRENCY - Static variable in class bb.common.POReceiverItemListResult
ORDER_BY_CURRENCY - Static variable in class bb.common.PurchaseOrderApprovalVO
ORDER_BY_CURRENCY - Static variable in class bb.common.PurchaseOrderItemListResult
ORDER_BY_CURRENCY - Static variable in class bb.common.RMAReviewVO
ORDER_BY_CURRENCY - Static variable in class bb.common.RTVApprovalVO
ORDER_BY_CURRENCY - Static variable in class bb.common.RtvShipperInfoVO
ORDER_BY_CURRENCY - Static variable in class bb.common.SalesMarginListResult
ORDER_BY_CURRENCY - Static variable in class bb.common.SalesOrderCheckListResult
ORDER_BY_CURRENCY - Static variable in class bb.common.SalesOrderListResult
ORDER_BY_CURRENCY - Static variable in class bb.common.SalesOrderReviewVO
ORDER_BY_CURRENCY - Static variable in class bb.common.SGCustRequestForQuoteListResult
ORDER_BY_CURRENCY - Static variable in class bb.common.TempArApAgingVO
ORDER_BY_CURRENCY - Static variable in class bb.common.TempReceiverWithoutAPInfo
ORDER_BY_CURRENCY - Static variable in class bb.common.TransferOrderListResult
ORDER_BY_CURRENCY - Static variable in class bb.common.TransferOrderVO
ORDER_BY_CURRENCY - Static variable in class bb.common.TransferReceiverListResult
ORDER_BY_CURRENCY - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_CURRENCY - Static variable in class bb.common.VendorContractPriceVO
ORDER_BY_CURRENCY - Static variable in class bb.common.WorkOrderApprovalVO
ORDER_BY_CURRENCY - Static variable in class bb.common.WorkOrderItemInWipListResult
ORDER_BY_CURRENCY - Static variable in class bb.common.WorkOrderItemListResult
ORDER_BY_CURRENT - Static variable in class bb.common.CustomerStatementTotalResult
ORDER_BY_CURRENTMONTHDEPRECIATE - Static variable in class bb.common.AssetDepreciateVO
ORDER_BY_CURRENTMONTHDEPRECIATE - Static variable in class bb.common.DepreciateMonthlyReport
ORDER_BY_CURRENTPOSITION - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_CURRENTPOSITIONLEVEL - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_CUSTID - Static variable in class bb.common.ARAuditListResult
ORDER_BY_CUSTID - Static variable in class bb.common.OnloanReceiverItemListResult
ORDER_BY_CUSTID - Static variable in class bb.common.RMAReceiverItemListResult
ORDER_BY_CUSTID - Static variable in class bb.common.SalesOrderShipDateListResult
ORDER_BY_CUSTID - Static variable in class bb.common.SGCustomerServiceRequestVO
ORDER_BY_CUSTID - Static variable in class bb.common.SGCustRequestForQuoteListResult
ORDER_BY_CUSTID - Static variable in class bb.common.SGSaleItemVO
ORDER_BY_CUSTOMERFLAG - Static variable in class bb.common.CustomerVendorAddressInfoVO
ORDER_BY_CUSTOMERFLAG - Static variable in class bb.common.LockedCustomerAddressResult
ORDER_BY_CUSTOMERHOLD - Static variable in class bb.common.CustomerVendorAddressInfoVO
ORDER_BY_CUSTOMERID - Static variable in class bb.common.AccountReceivableInfoWithPrepayResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.AccountsReceivableInfoVO
ORDER_BY_CUSTOMERID - Static variable in class bb.common.ARAllStatementsListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.ArCommissionListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.ARPaymentRunListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.ARPrepayAllStatementsListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.ArPrepayVO
ORDER_BY_CUSTOMERID - Static variable in class bb.common.ARTaxForZipcodeListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.CheckInvoiceItemListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.CRTVListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.CustomerFeedbackVO
ORDER_BY_CUSTOMERID - Static variable in class bb.common.CustomerServiceIncidentItemListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.CustomerServiceIncidentListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.CustomerStatementTotalResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.GeneralLedgerListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.GeneralLedgerVO
ORDER_BY_CUSTOMERID - Static variable in class bb.common.GLDebitCreditListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.InvoiceAgingItemListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.InvoiceItemListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.LnShipperItemListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.LnShipperListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.OnLoanItemListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.OnLoanListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.PackingBoxItemListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.ProformaInvoiceItemListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.ProformaInvoiceListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.QuoteItemListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.QuoteListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.RMAItemListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.RMAListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.RRMAListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.SalesMarginListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.SalesOrderCheckListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.SalesOrderItemCustomerTotalResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.SalesOrderItemListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.SalesOrderListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.SalesTaxListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.ShipListInfoVO
ORDER_BY_CUSTOMERID - Static variable in class bb.common.ShipperItemListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.ShipperListResult
ORDER_BY_CUSTOMERID - Static variable in class bb.common.TempArApAgingVO
ORDER_BY_CUSTOMERNAME - Static variable in class bb.common.ARAllStatementsListResult
ORDER_BY_CUSTOMERNAME - Static variable in class bb.common.ARPaymentRunListResult
ORDER_BY_CUSTOMERNAME - Static variable in class bb.common.ARPrepayAllStatementsListResult
ORDER_BY_CUSTOMERNAME - Static variable in class bb.common.ARTaxForZipcodeListResult
ORDER_BY_CUSTOMERNAME - Static variable in class bb.common.CustomerStatementTotalResult
ORDER_BY_CUSTOMERNAME - Static variable in class bb.common.LnShipperItemListResult
ORDER_BY_CUSTOMERNAME - Static variable in class bb.common.SalesMarginListResult
ORDER_BY_CUSTOMERNAME - Static variable in class bb.common.SalesOrderCheckListResult
ORDER_BY_CUSTOMERNAME - Static variable in class bb.common.SalesOrderListResult
ORDER_BY_CUSTOMERNAME - Static variable in class bb.common.ShipperItemListResult
ORDER_BY_CUSTOMERNAME - Static variable in class bb.common.TempArApAgingVO
ORDER_BY_CUSTOMERPO - Static variable in class bb.common.ArCommissionListResult
ORDER_BY_CUSTOMERPO - Static variable in class bb.common.CustomerStatementListResult
ORDER_BY_CUSTOMERPO - Static variable in class bb.common.InvoiceItemListResult
ORDER_BY_CUSTOMERPO - Static variable in class bb.common.OnLoanItemListResult
ORDER_BY_CUSTOMERPO - Static variable in class bb.common.OnLoanListResult
ORDER_BY_CUSTOMERPO - Static variable in class bb.common.ProformaInvoiceListResult
ORDER_BY_CUSTOMERPO - Static variable in class bb.common.SalesOrderItemListResult
ORDER_BY_CUSTOMERPO - Static variable in class bb.common.SalesOrderListResult
ORDER_BY_CUSTOMERPONUMBER - Static variable in class bb.common.AccountsReceivableInfoVO
ORDER_BY_CUSTOMERREFNUMBER - Static variable in class bb.common.QuoteListResult
ORDER_BY_CUSTOMERRFQNUMBER - Static variable in class bb.common.QuoteItemListResult
ORDER_BY_CUSTOMERSALES - Static variable in class bb.common.PaymentHistoryVO
ORDER_BY_CUSTOMERSERVICEINCIDENTNUMBER - Static variable in class bb.common.CustomerFeedbackVO
ORDER_BY_CUSTOMERTOCOUNTRY - Static variable in class bb.common.InvoiceItemListResult
ORDER_BY_CUSTOMERTOSTATE - Static variable in class bb.common.InvoiceItemListResult
ORDER_BY_CUSTPONUMBER - Static variable in class bb.common.SGSaleItemVO
ORDER_BY_DATE - Static variable in class bb.common.CustomerStatementListResult
ORDER_BY_DATE - Static variable in class bb.common.HistoricalInventoryVO
ORDER_BY_DATE - Static variable in class bb.common.LogInventoryListResult
ORDER_BY_DATE - Static variable in class bb.common.NcrNeedToScrapListResult
ORDER_BY_DATE - Static variable in class bb.common.VendorStatementListResult
ORDER_BY_DATE1 - Static variable in class bb.common.AccountPayableCheckRunVO
ORDER_BY_DATE1 - Static variable in class bb.common.ARPaymentRunVO
ORDER_BY_DATE1 - Static variable in class bb.common.ShipListInfoVO
ORDER_BY_DATE2 - Static variable in class bb.common.AccountPayableCheckRunVO
ORDER_BY_DATE2 - Static variable in class bb.common.ARPaymentRunVO
ORDER_BY_DATE2 - Static variable in class bb.common.ShipListInfoVO
ORDER_BY_DATECHECK - Static variable in class bb.common.IcrItemListResult
ORDER_BY_DATECHECKRUNPAID - Static variable in class bb.common.ApCheckRunListResult
ORDER_BY_DATEENTERED - Static variable in class bb.common.CorrectiveActionRequestVO
ORDER_BY_DATEENTERED - Static variable in class bb.common.PreventiveActionRequestVO
ORDER_BY_DATEFROM - Static variable in class bb.common.ExpenseListResult
ORDER_BY_DATEINVOICED - Static variable in class bb.common.AccountsReceivableInfoVO
ORDER_BY_DATEINVOICED - Static variable in class bb.common.ArCommissionListResult
ORDER_BY_DATEINVOICED - Static variable in class bb.common.CheckInvoiceItemListResult
ORDER_BY_DATEINVOICED - Static variable in class bb.common.CustomerStatementListResult
ORDER_BY_DATEINVOICED - Static variable in class bb.common.InvoiceAgingItemListResult
ORDER_BY_DATEINVOICED - Static variable in class bb.common.InvoiceItemListResult
ORDER_BY_DATEINVOICED - Static variable in class bb.common.SalesTaxListResult
ORDER_BY_DATEINVOICED - Static variable in class bb.common.SOShipperItemListResult
ORDER_BY_DATEISSUE - Static variable in class bb.common.NonproductivePickingItemIssuedListResult
ORDER_BY_DATEISSUE - Static variable in class bb.common.WorkOrderItemInWipListResult
ORDER_BY_DATEISSUED - Static variable in class bb.common.NonproductivePickingItemIssuedVO
ORDER_BY_DATEISSUED - Static variable in class bb.common.PartIssuedListResult
ORDER_BY_DATEISSUED - Static variable in class bb.common.PartIssuedVO
ORDER_BY_DATEISSUED - Static variable in class bb.common.PartReceivedListResult
ORDER_BY_DATEISSUED - Static variable in class bb.common.PartReceivedVO
ORDER_BY_DATEISSUED - Static variable in class bb.common.WorkOrderItemPartDetailInWipVO
ORDER_BY_DATEPAID - Static variable in class bb.common.AccountPayableCheckRunVO
ORDER_BY_DATEPAID - Static variable in class bb.common.APItemListResult
ORDER_BY_DATERECEIVED - Static variable in class bb.common.APItemListResult
ORDER_BY_DATERECEIVED - Static variable in class bb.common.OnloanReceiverListResult
ORDER_BY_DATERECEIVED - Static variable in class bb.common.PrReceiverListResult
ORDER_BY_DATERECEIVED - Static variable in class bb.common.RMAReceiverListResult
ORDER_BY_DATERECEIVED - Static variable in class bb.common.TempReceiverWithoutAPInfo
ORDER_BY_DATEREQUIRED - Static variable in class bb.common.PartIssuedListResult
ORDER_BY_DATEREQUIRED - Static variable in class bb.common.ReturnToVendorByDateListResult
ORDER_BY_DATEREQUIRED - Static variable in class bb.common.WorkOrderItemCanAssyResult
ORDER_BY_DATEREQUIRED - Static variable in class bb.common.WorkOrderItemReviewCostResult
ORDER_BY_DATESAVE - Static variable in class bb.common.TempReceiverWithoutAPInfo
ORDER_BY_DATESHIPED - Static variable in class bb.common.SalesTaxListResult
ORDER_BY_DATESHIPPED - Static variable in class bb.common.AccountsReceivableInfoVO
ORDER_BY_DATESHIPPED - Static variable in class bb.common.LnShipperItemListResult
ORDER_BY_DATESHIPPED - Static variable in class bb.common.LnShipperListResult
ORDER_BY_DATESHIPPED - Static variable in class bb.common.ProformaInvoiceListResult
ORDER_BY_DATESHIPPED - Static variable in class bb.common.RtvShipperInfoVO
ORDER_BY_dateShipped - Static variable in class bb.common.RtvShipperItemListResult
ORDER_BY_DATESHIPPED - Static variable in class bb.common.RtvShipperListResult
ORDER_BY_DATESHIPPED - Static variable in class bb.common.SGSaleItemVO
ORDER_BY_DATESHIPPED - Static variable in class bb.common.ShipperItemListResult
ORDER_BY_DATESHIPPED - Static variable in class bb.common.SOShipperItemListResult
ORDER_BY_DATETO - Static variable in class bb.common.ExpenseListResult
ORDER_BY_DAYS - Static variable in class bb.common.TermVO
ORDER_BY_DCNUMBER - Static variable in class bb.common.DesignControlListResult
ORDER_BY_DEBIT - Static variable in class bb.common.GLDebitCreditListResult
ORDER_BY_DEBITACCOUNT - Static variable in class bb.common.AccountsPayableInfoVO
ORDER_BY_DEBITACCOUNT - Static variable in class bb.common.APItemListResult
ORDER_BY_DEBITACCOUNT - Static variable in class bb.common.ReturnToVendorByDateListResult
ORDER_BY_DEBITACCOUNT - Static variable in class bb.common.RMAItemListResult
ORDER_BY_DEBITACCOUNTS - Static variable in class bb.common.GeneralLedgerCategoryVO
ORDER_BY_DEGREE - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_DELAYDAYS - Static variable in class bb.common.TransferOrderItemListResult
ORDER_BY_DELEVERYDATE - Static variable in class bb.common.PurchaseOrderItemListResult
ORDER_BY_DELEVERYDATE - Static variable in class bb.common.PurchaseOrderOpenDueListResult
ORDER_BY_DELIVERY - Static variable in class bb.common.EcnPOOrderResult
ORDER_BY_DELIVERY - Static variable in class bb.common.EcnWOOrderResult
ORDER_BY_DELIVERY - Static variable in class bb.common.PurchaseOrderCheckListResult
ORDER_BY_DELIVERY - Static variable in class bb.common.RequestForQuoteCheckListResult
ORDER_BY_DELIVERY - Static variable in class bb.common.RequestForQuoteItemListResult
ORDER_BY_DELIVERY - Static variable in class bb.common.RequestForQuoteListResult
ORDER_BY_DELIVERY - Static variable in class bb.common.ReturnToVendorItemListResult
ORDER_BY_DELIVERY - Static variable in class bb.common.WorkOrderItemToIssueResult
ORDER_BY_DELIVERYDATE - Static variable in class bb.common.OnLoanItemListResult
ORDER_BY_DELIVERYDATE - Static variable in class bb.common.RMAItemListResult
ORDER_BY_DELIVERYDATE - Static variable in class bb.common.SalesOrderItemListResult
ORDER_BY_DELIVERYDATE - Static variable in class bb.common.SalesOrderShipDateListResult
ORDER_BY_DELIVERYDATE - Static variable in class bb.common.TransferOrderItemListResult
ORDER_BY_DELIVERYDATE - Static variable in class bb.common.WOItemPartDetailNotIssue
ORDER_BY_DEPARTMENT - Static variable in class bb.common.BizBoxUserEmployeeResult
ORDER_BY_DEPARTMENT - Static variable in class bb.common.BuyerCodeVO
ORDER_BY_DEPARTMENT - Static variable in class bb.common.CustomAssetVO
ORDER_BY_DEPARTMENT - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_DEPARTMENT - Static variable in class bb.common.EmployeeCardVO
ORDER_BY_DEPARTMENT - Static variable in class bb.common.NoticeUserEmployeeListResult
ORDER_BY_DEPARTMENT - Static variable in class bb.common.SalesmanVO
ORDER_BY_DEPARTMENT - Static variable in class bb.common.WorkCenterVO
ORDER_BY_DEPARTMENTID - Static variable in class bb.common.AssetAddOrDisposalsReport
ORDER_BY_DEPARTMENTID - Static variable in class bb.common.AssetDepreciateDetailReport
ORDER_BY_DEPARTMENTID - Static variable in class bb.common.AssetDepreciateVO
ORDER_BY_DEPARTMENTID - Static variable in class bb.common.AssetVO
ORDER_BY_DEPARTMENTID - Static variable in class bb.common.BuyerCodeVO
ORDER_BY_DEPARTMENTID - Static variable in class bb.common.CorrectiveActionRequestVO
ORDER_BY_DEPARTMENTID - Static variable in class bb.common.DepreciateMonthlyReport
ORDER_BY_DEPARTMENTID - Static variable in class bb.common.EquipmentListResult
ORDER_BY_DEPARTMENTID - Static variable in class bb.common.NonproductivePickingVO
ORDER_BY_DEPARTMENTID - Static variable in class bb.common.PreventiveActionRequestVO
ORDER_BY_DEPARTMENTNAME - Static variable in class bb.common.PreventiveActionRequestVO
ORDER_BY_DEPARTNAME - Static variable in class bb.common.CorrectiveActionRequestVO
ORDER_BY_depreciatedAccm - Static variable in class bb.common.AssetDepreciateVO
ORDER_BY_DEPRECIATEDACCM - Static variable in class bb.common.AssetVO
ORDER_BY_DEPRECIATEDACCMMONTHS - Static variable in class bb.common.AssetVO
ORDER_BY_DEPRECIATEDDATE - Static variable in class bb.common.AssetVO
ORDER_BY_DEPRECIATEENDDATE - Static variable in class bb.common.AssetAddOrDisposalsReport
ORDER_BY_DEPRECIATEENDDATE - Static variable in class bb.common.AssetVO
ORDER_BY_DEPRECIATESTARTDATE - Static variable in class bb.common.AssetAddOrDisposalsReport
ORDER_BY_DEPRECIATESTARTDATE - Static variable in class bb.common.AssetVO
ORDER_BY_DEPRECIATESTATUS - Static variable in class bb.common.AssetAddOrDisposalsReport
ORDER_BY_DEPRECIATESTATUS - Static variable in class bb.common.AssetDepreciateVO
ORDER_BY_DEPRECIATESTATUS - Static variable in class bb.common.DepreciateMonthlyReport
ORDER_BY_DESCRIPTION - Static variable in class bb.common.AccountsChartCategoryVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.AccountsReceivableItemResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.AccountsReceivableItemVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.AllPartDocumentsVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.ARBoilerplateVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.AssetAddOrDisposalsReport
ORDER_BY_DESCRIPTION - Static variable in class bb.common.AssetDepreciateDetailReport
ORDER_BY_DESCRIPTION - Static variable in class bb.common.AssetDepreciateVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.AssetVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.BillWithPartInfoResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.BuyerCodeVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.CertificateDescriptionVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.ChangeStdCostWorkSheetItemVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.CustomDepartmentVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.DepreciateMonthlyReport
ORDER_BY_DESCRIPTION - Static variable in class bb.common.EmployeeRecordsVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.GeneralLedgerByDateListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.GeneralLedgerVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.GLAutoApproveVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.GLDebitCreditListResult
ORDER_BY_description - Static variable in class bb.common.HelpServerVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.HistoricalInventoryVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.IncotermVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.InspectionReportInspectMethodVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.InventoryAdjustmentListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.InventoryCycleResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.InventoryListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.InventoryMonthReport
ORDER_BY_DESCRIPTION - Static variable in class bb.common.InventoryNotUsedInMonthsforAppResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.InventoryNotUsedInMonthsResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.JobProcessSheetListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.LnShipperItemListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.LogInventoryListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.LogMiscDocumentVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.LogPartDocumentVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.LogPartDwfVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.LogPartDwgVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.LogTaskVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.LogTrackingVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.NoticeUserEmployeeListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.OnloanReceiverItemListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.OperatingInstructionsInspectStandardVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.OperatingInstructionsManualVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.OperatingInstructionsTypeVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.OperatingOutputFileTypeVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.PartBasicInfo
ORDER_BY_DESCRIPTION - Static variable in class bb.common.PartBasicInfoWithNewEngGroup
ORDER_BY_DESCRIPTION - Static variable in class bb.common.PartBasicInfoWithNewListPrice
ORDER_BY_DESCRIPTION - Static variable in class bb.common.PartClassInfoResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.PartInWipForIDListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.PartOnhandResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.PartOnHandWithMfgInfoResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.PartOnHandWithPartBasicInfoResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.PartTypeVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.PartUseTypeVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.PartWithExcessiveInventoryListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.PartWithOnLoanQtyListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.PartWithoutLocateResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.PartWithQAQtyListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.PartWithQtyListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.PartWithSipQtyListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.PartWithSITQtyListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.PartWithSTOQtyListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.PartWithWipQtyListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.PermissionListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.PhysicalInventoryStatusVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.POReceiverItemListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.ProformaInvoiceItemListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.PurchaseOrderBoilerplateVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.QuoteBoilerplateVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.RMAReceiverItemListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.RoleListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.RollUpBomStdCostWorkSheetItemVO
ORDER_BY_description - Static variable in class bb.common.RtvShipperItemListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.SalesmanVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.SalesOrder12MonthMarginResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.SalesOrderBoilerplateVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.SalesOrderItemGroupByPartListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.SGCustomerServiceRequestVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.SGPartCatalogResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.SGSaleItemVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.ShipListInfoVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.ShipperItemListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.SwapOrderItemListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.SwapReceiverItemListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.SwapShipperItemListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.ToolCalibrateListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.TransferOrderItemListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.TransferReceiverItemListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.TransferShipperItemListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.WOItemPartDetailNotIssue
ORDER_BY_DESCRIPTION - Static variable in class bb.common.WorkCenterVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.WorkOrderBoilerplateVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.WorkOrderItemCanAssyResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.WorkOrderItemLaborCostListResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.WorkOrderItemPartDetailInWipVO
ORDER_BY_DESCRIPTION - Static variable in class bb.common.WorkOrderItemReviewCostResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.WorkOrderItemToIssueResult
ORDER_BY_DESCRIPTION - Static variable in class bb.common.WorkOrderWorkInstructionListResult
ORDER_BY_DESIREDDATE - Static variable in class bb.common.TransferOrderItemListResult
ORDER_BY_DIFFCOUNT - Static variable in class bb.common.CycleCountListResult
ORDER_BY_DIFFCOUNT - Static variable in class bb.common.InventoryAdjustmentVO
ORDER_BY_DIFFCOUNT - Static variable in class bb.common.PhysicalInventoryListResult
ORDER_BY_DISASSEMBLEWORKORDERCOMMENTS - Static variable in class bb.common.DisassembleWorkOrderListResult
ORDER_BY_DISASSEMBLEWORKORDERITEMNUMBER - Static variable in class bb.common.DisassembleWorkOrderItemListResult
ORDER_BY_DISASSEMBLEWORKORDERITEMNUMBER - Static variable in class bb.common.DWOIssueDetail
ORDER_BY_DISASSEMBLEWORKORDERNUMBER - Static variable in class bb.common.DisassembleWorkOrderItemListResult
ORDER_BY_DISASSEMBLEWORKORDERNUMBER - Static variable in class bb.common.DWOIssueDetail
ORDER_BY_DISASSEMBLEWORKORDERNUMBER - Static variable in class bb.common.PartReceivedVO
ORDER_BY_DISASSEMBLEWORKORDERPRIVATENOTES - Static variable in class bb.common.DisassembleWorkOrderListResult
ORDER_BY_DISCOUNT - Static variable in class bb.common.ContractPriceItemVO
ORDER_BY_DISCOUNT - Static variable in class bb.common.POReceiverItemListResult
ORDER_BY_DISCOUNT - Static variable in class bb.common.PurchaseOrderItemListResult
ORDER_BY_DISCOUNT - Static variable in class bb.common.RequestForQuoteItemListResult
ORDER_BY_DISCOUNT - Static variable in class bb.common.ReturnToVendorByDateListResult
ORDER_BY_DISCOUNT - Static variable in class bb.common.VendorContractPriceItemVO
ORDER_BY_DISCOUNTTOTAL - Static variable in class bb.common.ArSalesCodeTotalListResult
ORDER_BY_DISPOSALBY - Static variable in class bb.common.SGCustomerServiceRequestVO
ORDER_BY_DISPOSITIONOFCHANGE - Static variable in class bb.common.EngineeringChangeRequestListResult
ORDER_BY_DOCFILENAME - Static variable in class bb.common.LogMiscDocumentVO
ORDER_BY_DOCLENGTH - Static variable in class bb.common.AccountingInfoDocumentVO
ORDER_BY_DOCLENGTH - Static variable in class bb.common.LogMiscDocumentVO
ORDER_BY_DOCNAME - Static variable in class bb.common.AccountingInfoDocumentVO
ORDER_BY_DOCNAME - Static variable in class bb.common.EmployeeRecordsVO
ORDER_BY_DOCNAME - Static variable in class bb.common.PartCertificateListResult
ORDER_BY_DOCTYPE - Static variable in class bb.common.LogMiscDocumentVO
ORDER_BY_DOCUMENTDATE - Static variable in class bb.common.AccountingInfoDocumentVO
ORDER_BY_DOCUMENTLENGTHBYTE - Static variable in class bb.common.LogPartDocumentVO
ORDER_BY_DOCUMENTTYPE - Static variable in class bb.common.AllPartDocumentsVO
ORDER_BY_DOCUMENTTYPE - Static variable in class bb.common.DocumentServerVO
ORDER_BY_DOCUMENTTYPE - Static variable in class bb.common.LogPartDocumentVO
ORDER_BY_DOCUMENTTYPE - Static variable in class bb.common.MiscDocumentSettingVO
ORDER_BY_DOCVERSION - Static variable in class bb.common.LogPartDocumentVO
ORDER_BY_DRAWING - Static variable in class bb.common.BillWithPartInfoResult
ORDER_BY_DRAWING - Static variable in class bb.common.PartBasicInfo
ORDER_BY_DRAWING - Static variable in class bb.common.PartBasicInfoWithNewEngGroup
ORDER_BY_DRAWING - Static variable in class bb.common.PartBasicInfoWithNewListPrice
ORDER_BY_DRAWING - Static variable in class bb.common.PartOnHandWithMfgInfoResult
ORDER_BY_DRAWING - Static variable in class bb.common.PartOnHandWithPartBasicInfoResult
ORDER_BY_DRAWING - Static variable in class bb.common.PartWithoutLocateResult
ORDER_BY_DRAWINGNUMBER - Static variable in class bb.common.InspectionReportInfoVO
ORDER_BY_DRAWINGNUMBER - Static variable in class bb.common.OperatingInstructionsVO
ORDER_BY_DUE - Static variable in class bb.common.AccountsPayableInfoVO
ORDER_BY_DUE1TO30TOTAL - Static variable in class bb.common.CustomerStatementTotalResult
ORDER_BY_DUE31TO60TOTAL - Static variable in class bb.common.CustomerStatementTotalResult
ORDER_BY_DUE61TO90TOTAL - Static variable in class bb.common.CustomerStatementTotalResult
ORDER_BY_DUE91TOTAL - Static variable in class bb.common.CustomerStatementTotalResult
ORDER_BY_DUEDATE - Static variable in class bb.common.CorrectiveActionRequestVO
ORDER_BY_DUEDATE - Static variable in class bb.common.CustomerServiceIncidentItemListResult
ORDER_BY_DUEDATE - Static variable in class bb.common.CustomerServiceIncidentListResult
ORDER_BY_DUEDATE - Static variable in class bb.common.DesignControlListResult
ORDER_BY_DUEDATE - Static variable in class bb.common.DisassembleWorkOrderItemListResult
ORDER_BY_DUEDATE - Static variable in class bb.common.EngineeringChangeListResult
ORDER_BY_DUEDATE - Static variable in class bb.common.EngineeringChangeRequestListResult
ORDER_BY_DUEDATE - Static variable in class bb.common.JobProcessSheetListResult
ORDER_BY_DUEDATE - Static variable in class bb.common.NcrReportListResult
ORDER_BY_DUEDATE - Static variable in class bb.common.NonConformanceReportVO
ORDER_BY_DUEDATE - Static variable in class bb.common.PreventiveActionRequestVO
ORDER_BY_DUEDATE - Static variable in class bb.common.PurchaseOrderOpenDueListResult
ORDER_BY_DUEDATE - Static variable in class bb.common.PurchaseWorkSheetVO
ORDER_BY_DUEDATE - Static variable in class bb.common.WoItemWorkInstructionListResult
ORDER_BY_DUEDATE - Static variable in class bb.common.WorkCenterRunTimeListResult
ORDER_BY_DUEDATE - Static variable in class bb.common.WorkInstructionRequestForChangeVO
ORDER_BY_DUEDATE - Static variable in class bb.common.WorkOrderItemListResult
ORDER_BY_DUEDATE - Static variable in class bb.common.WorkOrderWorkSheetVO
ORDER_BY_DWFEXTENSION - Static variable in class bb.common.LogPartDwfVO
ORDER_BY_DWFLENGTH - Static variable in class bb.common.LogPartDwfVO
ORDER_BY_DWG - Static variable in class bb.common.TransferReceiverItemListResult
ORDER_BY_DWG - Static variable in class bb.common.TransferShipperItemListResult
ORDER_BY_DWGEXTENSION - Static variable in class bb.common.LogPartDwgVO
ORDER_BY_DWGEXTENSION - Static variable in class bb.common.PartDwfWithPartInfoResult
ORDER_BY_DWGEXTENSION - Static variable in class bb.common.PartDwgWithPartInfoResult
ORDER_BY_DWGLENGTH - Static variable in class bb.common.LogPartDwfVO
ORDER_BY_DWGLENGTH - Static variable in class bb.common.LogPartDwgVO
ORDER_BY_DWGLENGTH - Static variable in class bb.common.PartDwfWithPartInfoResult
ORDER_BY_DWGLENGTH - Static variable in class bb.common.PartDwgWithPartInfoResult
ORDER_BY_DWODATE - Static variable in class bb.common.DisassembleWorkOrderListResult
ORDER_BY_DWONUMBER - Static variable in class bb.common.DisassembleWorkOrderListResult
ORDER_BY_EARNOSETEAR - Static variable in class bb.common.CustomCheckUpEmployeeVO
ORDER_BY_ECG - Static variable in class bb.common.CustomCheckUpEmployeeVO
ORDER_BY_ECNDESCRIPTION - Static variable in class bb.common.EngineeringChangeListResult
ORDER_BY_ECNNUMBER - Static variable in class bb.common.EngineeringChangeListResult
ORDER_BY_ECRDESCRIPTION - Static variable in class bb.common.EngineeringChangeRequestListResult
ORDER_BY_ECRENGINEER - Static variable in class bb.common.EngineeringChangeRequestListResult
ORDER_BY_ECRNUMBER - Static variable in class bb.common.EngineeringChangeRequestListResult
ORDER_BY_ECRPRIORITY - Static variable in class bb.common.EngineeringChangeRequestListResult
ORDER_BY_EDITDATE - Static variable in class bb.common.EngineeringSharingItemVO
ORDER_BY_EDUCATION - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_EFFECTIVEDATE - Static variable in class bb.common.WorkInstructionListResult
ORDER_BY_ELAPSEDTIMEBYHOUR - Static variable in class bb.common.OperatingInstructionsUserStatisticalResult
ORDER_BY_ELAPSEDTIMEBYHOUR - Static variable in class bb.common.OperatingInstructionsVO
ORDER_BY_EMAIL - Static variable in class bb.common.BizBoxUserEmployeeResult
ORDER_BY_EMAIL - Static variable in class bb.common.CustomerFeedbackVO
ORDER_BY_EMAIL - Static variable in class bb.common.EmployeeCardVO
ORDER_BY_EMAIL - Static variable in class bb.common.NoticeUserEmployeeListResult
ORDER_BY_EMAIL - Static variable in class bb.common.VendorGroupUserVO
ORDER_BY_EMPID - Static variable in class bb.common.CustomCheckUpEmployeeVO
ORDER_BY_EMPLOYEE - Static variable in class bb.common.LogInventoryListResult
ORDER_BY_EMPLOYEE - Static variable in class bb.common.WorkOrderItemTimeDetailVO
ORDER_BY_EMPLOYEEAGE - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_EMPLOYEEAGELEVEL - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_EMPLOYEEEMAIL - Static variable in class bb.common.PurchaseWorkSheetVO
ORDER_BY_EMPLOYEEEMAIL - Static variable in class bb.common.WorkOrderWorkSheetVO
ORDER_BY_EMPLOYEEID - Static variable in class bb.common.ArCommissionListResult
ORDER_BY_EMPLOYEEID - Static variable in class bb.common.ArSalesCodeTotalListResult
ORDER_BY_EMPLOYEEID - Static variable in class bb.common.BomApprovalVO
ORDER_BY_EMPLOYEEID - Static variable in class bb.common.CustomGoodsRecordVO
ORDER_BY_EMPLOYEEID - Static variable in class bb.common.ECNReviewVO
ORDER_BY_EMPLOYEEID - Static variable in class bb.common.ECRReviewVO
ORDER_BY_EMPLOYEEID - Static variable in class bb.common.EmployeePutGoodListResult
ORDER_BY_EMPLOYEEID - Static variable in class bb.common.EmployeeRecordsVO
ORDER_BY_EMPLOYEEID - Static variable in class bb.common.GeneralLedgerApprovalVO
ORDER_BY_EMPLOYEEID - Static variable in class bb.common.NcrApprovalVO
ORDER_BY_EMPLOYEEID - Static variable in class bb.common.NonproductivePickingApprovalVO
ORDER_BY_EMPLOYEEID - Static variable in class bb.common.NonproductivePickingApproveVO
ORDER_BY_EMPLOYEEID - Static variable in class bb.common.OnloanReviewVO
ORDER_BY_EMPLOYEEID - Static variable in class bb.common.OperationLogVO
ORDER_BY_EMPLOYEEID - Static variable in class bb.common.PurchaseOrderApprovalVO
ORDER_BY_EMPLOYEEID - Static variable in class bb.common.RMAReviewVO
ORDER_BY_EMPLOYEEID - Static variable in class bb.common.RTVApprovalVO
ORDER_BY_EMPLOYEEID - Static variable in class bb.common.SalesCodeVO
ORDER_BY_EMPLOYEEID - Static variable in class bb.common.SalesOrderReviewVO
ORDER_BY_EMPLOYEEID - Static variable in class bb.common.SwapOrderApprovalVO
ORDER_BY_EMPLOYEEID - Static variable in class bb.common.TransferOrderApprovalVO
ORDER_BY_EMPLOYEEID - Static variable in class bb.common.WorkInstructionApprovalVO
ORDER_BY_EMPLOYEEID - Static variable in class bb.common.WorkOrderApprovalVO
ORDER_BY_EMPLOYEEID - Static variable in class bb.common.WorkOrderTimeCardVO
ORDER_BY_EMPLOYEENAME - Static variable in class bb.common.EmployeePutGoodListResult
ORDER_BY_EMPLOYEENAME - Static variable in class bb.common.WorkOrderTimeCardVO
ORDER_BY_EMPLOYEEWORKAGE - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_EMPLOYEEWORKAGELEVEL - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_ENDAMOUNT - Static variable in class bb.common.InventoryMonthReport
ORDER_BY_ENDCOST - Static variable in class bb.common.InventoryMonthReport
ORDER_BY_ENDDATE - Static variable in class bb.common.FiscalYearSettingsVO
ORDER_BY_ENDDATE - Static variable in class bb.common.LogTaskVO
ORDER_BY_ENDDATE - Static variable in class bb.common.OperatingInstructionsUserStatisticalResult
ORDER_BY_ENDDATE - Static variable in class bb.common.OperatingInstructionsVO
ORDER_BY_ENDDATE - Static variable in class bb.common.RollUpBomStdCostWorkSheetVO
ORDER_BY_ENDQAAMOUNT - Static variable in class bb.common.InventoryMonthReport
ORDER_BY_ENDQAQTY - Static variable in class bb.common.InventoryMonthReport
ORDER_BY_ENDQTY - Static variable in class bb.common.InventoryMonthReport
ORDER_BY_ENDWIPAMOUNT - Static variable in class bb.common.InventoryMonthReport
ORDER_BY_ENDWIPQTY - Static variable in class bb.common.InventoryMonthReport
ORDER_BY_ENGACCEPTEMPLOYEE - Static variable in class bb.common.POSurveyReportVO
ORDER_BY_ENGINEERINGCHANGEDATE - Static variable in class bb.common.EngineeringChangeListResult
ORDER_BY_ENGINEERINGDESCRIPTION - Static variable in class bb.common.WorkInstructionListResult
ORDER_BY_ENTERBY - Static variable in class bb.common.NcrReportListResult
ORDER_BY_ENTERBY - Static variable in class bb.common.ReturnToVendorByDateListResult
ORDER_BY_ENTERED - Static variable in class bb.common.WorkOrderItemLaborCostListResult
ORDER_BY_EQUIPMENTID - Static variable in class bb.common.EquipmentListResult
ORDER_BY_ESTIMATENETSALRATE - Static variable in class bb.common.AssetVO
ORDER_BY_EXCESSIVEQTY - Static variable in class bb.common.PartWithExcessiveInventoryListResult
ORDER_BY_EXCESSIVETOTALAVGCOST - Static variable in class bb.common.PartWithExcessiveInventoryListResult
ORDER_BY_EXCESSIVETOTALSTDCOST - Static variable in class bb.common.PartWithExcessiveInventoryListResult
ORDER_BY_EXCHANGE - Static variable in class bb.common.CurrencyExchangeVO
ORDER_BY_EXCHANGE - Static variable in class bb.common.POReceiverItemListResult
ORDER_BY_EXCLUDE - Static variable in class bb.common.ARPaymentRunVO
ORDER_BY_EXPENSESTATEMENT - Static variable in class bb.common.ExpenseListResult
ORDER_BY_EXPIREDATE - Static variable in class bb.common.BizboxUserListResult
ORDER_BY_EXPIREDATE - Static variable in class bb.common.ContractPriceVO
ORDER_BY_EXPIREDATE - Static variable in class bb.common.CustomEmployeeTrainVO
ORDER_BY_EXPIREDATE - Static variable in class bb.common.VendorContractPriceVO
ORDER_BY_EXTENDEDCOST - Static variable in class bb.common.POReceiverItemListResult
ORDER_BY_EXTENDPRICE - Static variable in class bb.common.DisassembleWorkOrderItemListResult
ORDER_BY_EXTENDPRICE - Static variable in class bb.common.PurchaseOrderItemListResult
ORDER_BY_EXTENDPRICE - Static variable in class bb.common.WorkOrderItemListResult
ORDER_BY_EXTENSION - Static variable in class bb.common.AccountingInfoDocumentVO
ORDER_BY_EXTENSION - Static variable in class bb.common.EmployeeCardVO
ORDER_BY_EXTENSION - Static variable in class bb.common.LogMiscDocumentVO
ORDER_BY_EXTENSION - Static variable in class bb.common.PrintLogoVO
ORDER_BY_EXTENSION - Static variable in class bb.common.TermsConditionVO
ORDER_BY_FAX - Static variable in class bb.common.CustomerVendorAddressInfoVO
ORDER_BY_FAX - Static variable in class bb.common.EmployeeCardVO
ORDER_BY_FAX - Static variable in class bb.common.VendorGroupUserVO
ORDER_BY_FEEDBACKNUMBER - Static variable in class bb.common.CustomerFeedbackVO
ORDER_BY_FIRSTNAME - Static variable in class bb.common.EmployeeCardVO
ORDER_BY_FIRSTNAME - Static variable in class bb.common.SalesmanVO
ORDER_BY_FREIGHT - Static variable in class bb.common.SwapReceiverListResult
ORDER_BY_FREIGHT - Static variable in class bb.common.SwapShipperListResult
ORDER_BY_FREIGHT - Static variable in class bb.common.TransferOrderListResult
ORDER_BY_FREIGHT - Static variable in class bb.common.TransferOrderVO
ORDER_BY_FREIGHTRATECODE - Static variable in class bb.common.SwapShipperListResult
ORDER_BY_FREIGHTRATECODE - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_FREIGHTTOTAL - Static variable in class bb.common.ArCommissionListResult
ORDER_BY_FREIGHTTOTAL - Static variable in class bb.common.ArSalesCodeTotalListResult
ORDER_BY_FROMADDRESSID - Static variable in class bb.common.TransferOrderListResult
ORDER_BY_FROMADDRESSID - Static variable in class bb.common.TransferOrderVO
ORDER_BY_FROMADDRESSID - Static variable in class bb.common.TransferReceiverItemListResult
ORDER_BY_FROMADDRESSID - Static variable in class bb.common.TransferReceiverListResult
ORDER_BY_FROMADDRESSID - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_FROMADDRESSNAME - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_FROMLOCATION - Static variable in class bb.common.TransferOrderItemListResult
ORDER_BY_FTPPATH - Static variable in class bb.common.DocumentServerVO
ORDER_BY_FTPPATH - Static variable in class bb.common.MiscDocumentSettingVO
ORDER_BY_FULLNAME - Static variable in class bb.common.VendorGroupUserVO
ORDER_BY_FY - Static variable in class bb.common.FiscalYearSettingsVO
ORDER_BY_GAAR - Static variable in class bb.common.ARPaymentRunVO
ORDER_BY_GACHECKING - Static variable in class bb.common.ARPaymentRunVO
ORDER_BY_GENDER - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_GLACCOUNTNUMBER - Static variable in class bb.common.AssetVO
ORDER_BY_GLCAT - Static variable in class bb.common.GLAutoApproveVO
ORDER_BY_GLCATEGORY - Static variable in class bb.common.AssetDepreciateVO
ORDER_BY_GLCATEGORY - Static variable in class bb.common.GeneralLedgerListResult
ORDER_BY_GLCATEGORY - Static variable in class bb.common.GeneralLedgerVO
ORDER_BY_GLCATEGORY - Static variable in class bb.common.GLDebitCreditListResult
ORDER_BY_GLNUMBER - Static variable in class bb.common.GeneralLedgerByDateListResult
ORDER_BY_GLTYPE - Static variable in class bb.common.GeneralLedgerCategoryVO
ORDER_BY_GLTYPE - Static variable in class bb.common.GLAutoApproveVO
ORDER_BY_GOODQTY - Static variable in class bb.common.InspectionReportInfoVO
ORDER_BY_GOODSID - Static variable in class bb.common.CustomGoodsRecordVO
ORDER_BY_GOODSID - Static variable in class bb.common.EmployeePutGoodListResult
ORDER_BY_GOODSNAME - Static variable in class bb.common.EmployeePutGoodListResult
ORDER_BY_GRADUATEDATE - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_GRADUATESCHOOL - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_GRANDTOTAL - Static variable in class bb.common.AccountsReceivableInfoVO
ORDER_BY_GRANDTOTAL - Static variable in class bb.common.AccountsReceivableItemResult
ORDER_BY_GRANDTOTAL - Static variable in class bb.common.ArCommissionListResult
ORDER_BY_GRANDTOTAL - Static variable in class bb.common.ArSalesCodeTotalListResult
ORDER_BY_GRANDTOTAL - Static variable in class bb.common.VendorTotalAmountInPO
ORDER_BY_GRANTTOTAL - Static variable in class bb.common.POStatisticsResult
ORDER_BY_GRANTTOTAL - Static variable in class bb.common.ProformaInvoiceListResult
ORDER_BY_GRANTTOTAL - Static variable in class bb.common.TempReceiverWithoutAPInfo
ORDER_BY_GROSSMARGIN - Static variable in class bb.common.SalesOrder12MonthMarginResult
ORDER_BY_GROSSWEIGHT - Static variable in class bb.common.SwapShipperListResult
ORDER_BY_GROSSWEIGHT - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_HEIGHT - Static variable in class bb.common.LabelTemplateVO
ORDER_BY_helpServerIP - Static variable in class bb.common.HelpServerVO
ORDER_BY_helpServerPort - Static variable in class bb.common.HelpServerVO
ORDER_BY_HOLD - Static variable in class bb.common.PartBasicInfo
ORDER_BY_HOLD - Static variable in class bb.common.PartBasicInfoWithNewEngGroup
ORDER_BY_HOLD - Static variable in class bb.common.PartBasicInfoWithNewListPrice
ORDER_BY_HOLD - Static variable in class bb.common.PartOnHandWithMfgInfoResult
ORDER_BY_HOLD - Static variable in class bb.common.PartOnHandWithPartBasicInfoResult
ORDER_BY_HOLD - Static variable in class bb.common.PartWithoutLocateResult
ORDER_BY_HOMEPHONE - Static variable in class bb.common.BizBoxUserEmployeeResult
ORDER_BY_HOMEPHONE - Static variable in class bb.common.EmployeeCardVO
ORDER_BY_HOMEPHONE - Static variable in class bb.common.NoticeUserEmployeeListResult
ORDER_BY_HQA - Static variable in class bb.common.TransferReceiverItemListResult
ORDER_BY_ICRDATE - Static variable in class bb.common.IcrItemListResult
ORDER_BY_ICRDATE - Static variable in class bb.common.IcrListResult
ORDER_BY_ICRITEMNUMBER - Static variable in class bb.common.IcrItemListResult
ORDER_BY_ICRNUMBER - Static variable in class bb.common.IcrItemListResult
ORDER_BY_ICRNUMBER - Static variable in class bb.common.IcrListResult
ORDER_BY_ICRNUMBER - Static variable in class bb.common.InspectionConformanceReportVO
ORDER_BY_ID - Static variable in class bb.common.AssetTypeVO
ORDER_BY_ID - Static variable in class bb.common.CertificateDescriptionVO
ORDER_BY_ID - Static variable in class bb.common.CompanyUnitVO
ORDER_BY_ID - Static variable in class bb.common.CustomDepartmentVO
ORDER_BY_ID - Static variable in class bb.common.CustomerVendorAddressInfoVO
ORDER_BY_ID - Static variable in class bb.common.CustomGoodsBreedVO
ORDER_BY_ID - Static variable in class bb.common.CustomJobCategoryVO
ORDER_BY_ID - Static variable in class bb.common.DepartmentLocationForBackflushVO
ORDER_BY_ID - Static variable in class bb.common.EmployeeCardVO
ORDER_BY_ID - Static variable in class bb.common.EngGroupVO
ORDER_BY_ID - Static variable in class bb.common.GeneralLedgerCategoryVO
ORDER_BY_ID - Static variable in class bb.common.IncotermVO
ORDER_BY_ID - Static variable in class bb.common.LockedCustomerAddressResult
ORDER_BY_ID - Static variable in class bb.common.ManufacturerAddressInfoVO
ORDER_BY_ID - Static variable in class bb.common.NonproductivePickingItemResult
ORDER_BY_ID - Static variable in class bb.common.OperationLogVO
ORDER_BY_ID - Static variable in class bb.common.PartClassVO
ORDER_BY_ID - Static variable in class bb.common.PartTypeVO
ORDER_BY_ID - Static variable in class bb.common.UnitVO
ORDER_BY_ID - Static variable in class bb.common.VendorGroupUserVO
ORDER_BY_II - Static variable in class bb.common.ChangeStdCostWorkSheetVO
ORDER_BY_II - Static variable in class bb.common.CustomCheckUpEmployeeVO
ORDER_BY_II - Static variable in class bb.common.EmployeeRecordsVO
ORDER_BY_II - Static variable in class bb.common.GLAutoApproveVO
ORDER_BY_II - Static variable in class bb.common.HelpServerVO
ORDER_BY_II - Static variable in class bb.common.InspectionReportInspectMethodVO
ORDER_BY_II - Static variable in class bb.common.LabelTemplateVO
ORDER_BY_II - Static variable in class bb.common.OperatingInstructionsInspectStandardVO
ORDER_BY_II - Static variable in class bb.common.OperatingInstructionsManualVO
ORDER_BY_II - Static variable in class bb.common.OperatingInstructionsTypeVO
ORDER_BY_II - Static variable in class bb.common.OperatingOutputFileTypeVO
ORDER_BY_II - Static variable in class bb.common.RollUpBomStdCostWorkSheetVO
ORDER_BY_II - Static variable in class bb.common.TermVO
ORDER_BY_II - Static variable in class bb.common.ToolCalibrateListResult
ORDER_BY_II - Static variable in class bb.common.ToolCalibrationVO
ORDER_BY_II - Static variable in class bb.common.WorkOrderTimeCardVO
ORDER_BY_INAMOUNT - Static variable in class bb.common.InventoryMonthReport
ORDER_BY_INCLUDE - Static variable in class bb.common.ARPaymentRunVO
ORDER_BY_INCOST - Static variable in class bb.common.InventoryMonthReport
ORDER_BY_INCOST - Static variable in class bb.common.LogInventoryListResult
ORDER_BY_INCOTERM - Static variable in class bb.common.SalesOrderItemListResult
ORDER_BY_INCOTERM - Static variable in class bb.common.SwapReceiverListResult
ORDER_BY_INCOTERM - Static variable in class bb.common.SwapShipperListResult
ORDER_BY_INCOTERM - Static variable in class bb.common.TransferOrderListResult
ORDER_BY_INCOTERM - Static variable in class bb.common.TransferOrderVO
ORDER_BY_INCOTERM - Static variable in class bb.common.TransferReceiverListResult
ORDER_BY_INCOTERM - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_INCOTERMPLACEPORT - Static variable in class bb.common.SalesOrderItemListResult
ORDER_BY_INCOTERMPLACEPORT - Static variable in class bb.common.SwapReceiverListResult
ORDER_BY_INCOTERMPLACEPORT - Static variable in class bb.common.SwapShipperListResult
ORDER_BY_INCOTERMPLACEPORT - Static variable in class bb.common.TransferOrderListResult
ORDER_BY_INCOTERMPLACEPORT - Static variable in class bb.common.TransferOrderVO
ORDER_BY_INCOTERMPLACEPORT - Static variable in class bb.common.TransferReceiverListResult
ORDER_BY_INCOTERMPLACEPORT - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_INDEX - Static variable in class bb.common.AccountsChartCategoryVO
ORDER_BY_INITIALDEPRECIATECOST - Static variable in class bb.common.AssetAddOrDisposalsReport
ORDER_BY_initialDepreciateCost - Static variable in class bb.common.AssetDepreciateVO
ORDER_BY_INITIALDEPRECIATECOST - Static variable in class bb.common.AssetVO
ORDER_BY_INQA - Static variable in class bb.common.InventoryListResult
ORDER_BY_INQAQTY - Static variable in class bb.common.PartWithQAQtyListResult
ORDER_BY_INQAQTY - Static variable in class bb.common.PartWithSTOQtyListResult
ORDER_BY_INQTY - Static variable in class bb.common.InventoryMonthReport
ORDER_BY_INQTY - Static variable in class bb.common.LogInventoryListResult
ORDER_BY_INQTY - Static variable in class bb.common.LogTrackingVO
ORDER_BY_INQUALITYCHECKINGQTY - Static variable in class bb.common.HistoricalInventoryVO
ORDER_BY_INQUALITYCHECKINGQTY - Static variable in class bb.common.PhysicalInventoryListResult
ORDER_BY_INSIP - Static variable in class bb.common.BB2PartOnDemandListResult
ORDER_BY_INSIP - Static variable in class bb.common.InventoryListResult
ORDER_BY_INSIP - Static variable in class bb.common.PartOnhandResult
ORDER_BY_INSIP - Static variable in class bb.common.PartOnHandWithMfgInfoResult
ORDER_BY_INSIP - Static variable in class bb.common.SalesOrderItemGroupByPartListResult
ORDER_BY_INSIPINSO - Static variable in class bb.common.SalesOrderItemGroupByPartListResult
ORDER_BY_INSIT - Static variable in class bb.common.BB2PartOnDemandListResult
ORDER_BY_INSIT - Static variable in class bb.common.PartOnHandWithMfgInfoResult
ORDER_BY_INSPECTEDBY - Static variable in class bb.common.ToolCalibrateListResult
ORDER_BY_INSPECTEDBY - Static variable in class bb.common.ToolCalibrationVO
ORDER_BY_INSPECTIONDESCRIPTION - Static variable in class bb.common.InspectionItemVO
ORDER_BY_INSPECTIONPERIOD - Static variable in class bb.common.ToolCalibrateListResult
ORDER_BY_INSPECTIONPERIOD - Static variable in class bb.common.ToolCalibrationVO
ORDER_BY_INSPECTIONREPORTDATE - Static variable in class bb.common.InspectionReportInfoVO
ORDER_BY_INSPECTIONREPORTNUMBER - Static variable in class bb.common.InspectionReportInfoVO
ORDER_BY_INSPECTIONREPORTNUMBER - Static variable in class bb.common.OperatingInstructionsUserStatisticalResult
ORDER_BY_INSPECTIONREPORTNUMBER - Static variable in class bb.common.OperatingInstructionsVO
ORDER_BY_INSPECTIONREQUEST - Static variable in class bb.common.InspectionItemVO
ORDER_BY_INSPECTIONRESULT - Static variable in class bb.common.InspectionReportInfoVO
ORDER_BY_INSPECTIONTYPE - Static variable in class bb.common.PartInspectionResult
ORDER_BY_INSPECTOR - Static variable in class bb.common.IcrItemListResult
ORDER_BY_INSPECTOR - Static variable in class bb.common.InspectionReportInfoVO
ORDER_BY_INSPECTPROJECT - Static variable in class bb.common.PartInspectionVO
ORDER_BY_INSTO - Static variable in class bb.common.InventoryListResult
ORDER_BY_INTO - Static variable in class bb.common.HistoricalInventoryVO
ORDER_BY_INVOICEDATE - Static variable in class bb.common.CustomerFeedbackVO
ORDER_BY_INVOICEDTOTAL - Static variable in class bb.common.SalesOrder12MonthMarginResult
ORDER_BY_INVOICEITEMNUMBER - Static variable in class bb.common.SalesTaxListResult
ORDER_BY_INVOICENUMBER - Static variable in class bb.common.AccountReceivableInfoWithPrepayResult
ORDER_BY_INVOICENUMBER - Static variable in class bb.common.AccountsReceivableInfoVO
ORDER_BY_INVOICENUMBER - Static variable in class bb.common.ArCommissionListResult
ORDER_BY_INVOICENUMBER - Static variable in class bb.common.CheckInvoiceItemListResult
ORDER_BY_INVOICENUMBER - Static variable in class bb.common.CRTVListResult
ORDER_BY_INVOICENUMBER - Static variable in class bb.common.CustomerStatementListResult
ORDER_BY_INVOICENUMBER - Static variable in class bb.common.GeneralLedgerListResult
ORDER_BY_INVOICENUMBER - Static variable in class bb.common.GeneralLedgerVO
ORDER_BY_INVOICENUMBER - Static variable in class bb.common.GLDebitCreditListResult
ORDER_BY_INVOICENUMBER - Static variable in class bb.common.InvoiceAgingItemListResult
ORDER_BY_INVOICENUMBER - Static variable in class bb.common.InvoiceItemListResult
ORDER_BY_INVOICENUMBER - Static variable in class bb.common.RMAItemListResult
ORDER_BY_INVOICENUMBER - Static variable in class bb.common.RMAListResult
ORDER_BY_INVOICENUMBER - Static variable in class bb.common.RRMAListResult
ORDER_BY_INVOICENUMBER - Static variable in class bb.common.SalesTaxListResult
ORDER_BY_INVOICENUMBER - Static variable in class bb.common.SOShipperItemListResult
ORDER_BY_INWIP - Static variable in class bb.common.BB2PartOnDemandListResult
ORDER_BY_INWIP - Static variable in class bb.common.InventoryListResult
ORDER_BY_INWIP - Static variable in class bb.common.PartOnhandResult
ORDER_BY_INWIP - Static variable in class bb.common.PartOnHandWithMfgInfoResult
ORDER_BY_INWIP - Static variable in class bb.common.PartWithInventoryInfoListResult
ORDER_BY_INWIPQTY - Static variable in class bb.common.PartWithWipQtyListResult
ORDER_BY_IP - Static variable in class bb.common.BizboxUserVO
ORDER_BY_ISSUEAVGCOST - Static variable in class bb.common.WorkOrderItemInWipListResult
ORDER_BY_ISSUEDQUANTITY - Static variable in class bb.common.NonproductivePickingItemResult
ORDER_BY_ISSUEQUANTITY - Static variable in class bb.common.WOItemPartDetailNotIssue
ORDER_BY_ISSUEQUANTITY - Static variable in class bb.common.WorkOrderItemPartDetail
ORDER_BY_ISSUEQUANTITY - Static variable in class bb.common.WorkOrderOverIssueListResult
ORDER_BY_ITEMCOMMENTS - Static variable in class bb.common.SwapShipperItemListResult
ORDER_BY_ITEMCOMMENTS - Static variable in class bb.common.TransferOrderItemListResult
ORDER_BY_ITEMCOMMENTS - Static variable in class bb.common.TransferReceiverItemListResult
ORDER_BY_ITEMCOMMENTS - Static variable in class bb.common.TransferShipperItemListResult
ORDER_BY_ITEMCOMMENTS - Static variable in class bb.common.WorkOrderItemLaborCostListResult
ORDER_BY_ITEMCOUNT - Static variable in class bb.common.ChangeStdCostWorkSheetVO
ORDER_BY_ITEMDESCRIPTION - Static variable in class bb.common.RMAItemListResult
ORDER_BY_ITEMDESCRIPTION - Static variable in class bb.common.SalesOrderItemListResult
ORDER_BY_ITEMNUMBER - Static variable in class bb.common.POReceiverItemListResult
ORDER_BY_ITEMPRIVATENOTES - Static variable in class bb.common.SwapShipperItemListResult
ORDER_BY_ITEMPRIVATENOTES - Static variable in class bb.common.TransferOrderItemListResult
ORDER_BY_ITEMPRIVATENOTES - Static variable in class bb.common.TransferReceiverItemListResult
ORDER_BY_ITEMPRIVATENOTES - Static variable in class bb.common.TransferShipperItemListResult
ORDER_BY_JOBID - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_JOBID - Static variable in class bb.common.EmployeePutGoodListResult
ORDER_BY_JOBID - Static variable in class bb.common.SalesmanVO
ORDER_BY_JOBNAME - Static variable in class bb.common.EmployeePutGoodListResult
ORDER_BY_kg - Static variable in class bb.common.WeightUnitVO
ORDER_BY_LABELTYPE - Static variable in class bb.common.LabelTemplateVO
ORDER_BY_LANGUAGE - Static variable in class bb.common.AllPartDocumentsVO
ORDER_BY_language - Static variable in class bb.common.HelpServerVO
ORDER_BY_LANGUAGE - Static variable in class bb.common.LogPartDocumentVO
ORDER_BY_LANGUAGE - Static variable in class bb.common.SalesmanVO
ORDER_BY_LANGUAGE - Static variable in class bb.common.SGCustRequestForQuoteListResult
ORDER_BY_LANGUAGE - Static variable in class bb.common.TransferOrderListResult
ORDER_BY_LANGUAGE - Static variable in class bb.common.TransferOrderVO
ORDER_BY_LANGUAGE - Static variable in class bb.common.TransferReceiverListResult
ORDER_BY_LANGUAGE - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_LANIP - Static variable in class bb.common.BizboxUserVO
ORDER_BY_LANIP - Static variable in class bb.common.LogMiscDocumentVO
ORDER_BY_LANIP - Static variable in class bb.common.LogPartDocumentVO
ORDER_BY_LANIP - Static variable in class bb.common.LogPartDwfVO
ORDER_BY_LANIP - Static variable in class bb.common.LogPartDwgVO
ORDER_BY_LANIP - Static variable in class bb.common.OperationLogVO
ORDER_BY_LASTCHANGEDATE - Static variable in class bb.common.AccountingInfoDocumentVO
ORDER_BY_LASTCHANGEDATE - Static variable in class bb.common.AllPartDocumentsVO
ORDER_BY_LASTCHANGEDATE - Static variable in class bb.common.BillOnHandWithPartInfoResult
ORDER_BY_LASTCHANGEDATE - Static variable in class bb.common.BillWithPartInfoResult
ORDER_BY_LASTCHANGEDATE - Static variable in class bb.common.ContractPriceVO
ORDER_BY_LASTCHANGEDATE - Static variable in class bb.common.CorrectiveActionRequestVO
ORDER_BY_LASTCHANGEDATE - Static variable in class bb.common.CustomerVendorAddressInfoVO
ORDER_BY_LASTCHANGEDATE - Static variable in class bb.common.InspectionConformanceReportVO
ORDER_BY_LASTCHANGEDATE - Static variable in class bb.common.LogMiscDocumentVO
ORDER_BY_LASTCHANGEDATE - Static variable in class bb.common.LogPartDocumentVO
ORDER_BY_LASTCHANGEDATE - Static variable in class bb.common.LogPartDwfVO
ORDER_BY_LASTCHANGEDATE - Static variable in class bb.common.LogPartDwgVO
ORDER_BY_LASTCHANGEDATE - Static variable in class bb.common.LogTrackingVO
ORDER_BY_LASTCHANGEDATE - Static variable in class bb.common.NonConformanceCodeVO
ORDER_BY_LASTCHANGEDATE - Static variable in class bb.common.PartBasicInfo
ORDER_BY_LASTCHANGEDATE - Static variable in class bb.common.PreventiveActionRequestVO
ORDER_BY_LASTCHANGEDATE - Static variable in class bb.common.ToolListWithToolInfoResult
ORDER_BY_LASTCHANGEDATE - Static variable in class bb.common.TransferOrderListResult
ORDER_BY_LASTCHANGEDATE - Static variable in class bb.common.TransferOrderVO
ORDER_BY_LASTCHANGEDATE - Static variable in class bb.common.TransferReceiverListResult
ORDER_BY_LASTCHANGEDATE - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_LASTCHANGEDATE - Static variable in class bb.common.VendorContractPriceVO
ORDER_BY_LASTCHANGETIME - Static variable in class bb.common.BillLogVO
ORDER_BY_LASTCHANGETIME - Static variable in class bb.common.TransferReceiverListResult
ORDER_BY_LASTCHANGETIME - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_LASTCHANGEUSER - Static variable in class bb.common.AllPartDocumentsVO
ORDER_BY_LASTCHANGEUSER - Static variable in class bb.common.BillLogVO
ORDER_BY_LASTCHANGEUSER - Static variable in class bb.common.BillOnHandWithPartInfoResult
ORDER_BY_LASTCHANGEUSER - Static variable in class bb.common.BillWithPartInfoResult
ORDER_BY_LASTCHANGEUSER - Static variable in class bb.common.ContractPriceVO
ORDER_BY_LASTCHANGEUSER - Static variable in class bb.common.CorrectiveActionRequestVO
ORDER_BY_LASTCHANGEUSER - Static variable in class bb.common.DWOIssueDetail
ORDER_BY_LASTCHANGEUSER - Static variable in class bb.common.InspectionConformanceReportVO
ORDER_BY_LASTCHANGEUSER - Static variable in class bb.common.LogMiscDocumentVO
ORDER_BY_LASTCHANGEUSER - Static variable in class bb.common.LogPartDocumentVO
ORDER_BY_LASTCHANGEUSER - Static variable in class bb.common.LogPartDwfVO
ORDER_BY_LASTCHANGEUSER - Static variable in class bb.common.LogPartDwgVO
ORDER_BY_LASTCHANGEUSER - Static variable in class bb.common.LogTrackingVO
ORDER_BY_LASTCHANGEUSER - Static variable in class bb.common.NonConformanceCodeVO
ORDER_BY_LASTCHANGEUSER - Static variable in class bb.common.PreventiveActionRequestVO
ORDER_BY_LASTCHANGEUSER - Static variable in class bb.common.SalesmanVO
ORDER_BY_LASTCHANGEUSER - Static variable in class bb.common.ToolListWithToolInfoResult
ORDER_BY_LASTCHANGEUSER - Static variable in class bb.common.VendorContractPriceVO
ORDER_BY_LASTCHANGEUSER - Static variable in class bb.common.WOReceiverDetail
ORDER_BY_LASTCHANGEUSER - Static variable in class bb.common.WorkCenterVO
ORDER_BY_LASTCYCLECOUNT - Static variable in class bb.common.PartClassVO
ORDER_BY_LASTINDATE - Static variable in class bb.common.InventoryListResult
ORDER_BY_LASTINDATE - Static variable in class bb.common.InventoryNotUsedInMonthsforAppResult
ORDER_BY_LASTINDATE - Static variable in class bb.common.InventoryNotUsedInMonthsResult
ORDER_BY_LASTINSPECTION - Static variable in class bb.common.ToolCalibrateListResult
ORDER_BY_LASTINSPECTION - Static variable in class bb.common.ToolCalibrationVO
ORDER_BY_LASTLOGIN - Static variable in class bb.common.BizboxUserListResult
ORDER_BY_LASTMAINTENANCEDATE - Static variable in class bb.common.EquipmentListResult
ORDER_BY_LASTMONTHDEPRECIATE - Static variable in class bb.common.AssetDepreciateVO
ORDER_BY_LASTMONTHDEPRECIATE - Static variable in class bb.common.DepreciateMonthlyReport
ORDER_BY_LASTNAME - Static variable in class bb.common.EmployeeCardVO
ORDER_BY_LASTNAME - Static variable in class bb.common.SalesmanVO
ORDER_BY_LASTOUTDATE - Static variable in class bb.common.InventoryListResult
ORDER_BY_LASTOUTDATE - Static variable in class bb.common.InventoryNotUsedInMonthsforAppResult
ORDER_BY_LASTOUTDATE - Static variable in class bb.common.InventoryNotUsedInMonthsResult
ORDER_BY_LASTOUTDATE - Static variable in class bb.common.PartOnhandResult
ORDER_BY_LASTRECEIVEDATE - Static variable in class bb.common.PurchaseOrderItemListResult
ORDER_BY_LASTSHIPPEDDATE - Static variable in class bb.common.SalesOrderItemListResult
ORDER_BY_LASTUSER - Static variable in class bb.common.AccountingInfoDocumentVO
ORDER_BY_LASTUSER - Static variable in class bb.common.PartBasicInfo
ORDER_BY_LASTUSER - Static variable in class bb.common.ShipListInfoVO
ORDER_BY_LASTUSER - Static variable in class bb.common.TransferOrderListResult
ORDER_BY_LASTUSER - Static variable in class bb.common.TransferOrderVO
ORDER_BY_LASTUSER - Static variable in class bb.common.TransferReceiverListResult
ORDER_BY_LASTUSER - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_lbs - Static variable in class bb.common.WeightUnitVO
ORDER_BY_LENGTH - Static variable in class bb.common.PrintLogoVO
ORDER_BY_LENGTH - Static variable in class bb.common.TermsConditionVO
ORDER_BY_LEVEL - Static variable in class bb.common.RollUpBomStdCostWorkSheetItemVO
ORDER_BY_LEVEL - Static variable in class bb.common.SalesmanVO
ORDER_BY_LEVELDESCRIPTION - Static variable in class bb.common.PartSecurityLevelVO
ORDER_BY_LEVELID - Static variable in class bb.common.PartSecurityLevelVO
ORDER_BY_LISTPRICE - Static variable in class bb.common.ContractPriceItemVO
ORDER_BY_LISTPRICE - Static variable in class bb.common.InventoryListResult
ORDER_BY_LISTPRICE - Static variable in class bb.common.LnShipperItemListResult
ORDER_BY_LISTPRICE - Static variable in class bb.common.PartBasicInfoWithNewEngGroup
ORDER_BY_LISTPRICE - Static variable in class bb.common.PartBasicInfoWithNewListPrice
ORDER_BY_LISTPRICE - Static variable in class bb.common.PartWithQAQtyListResult
ORDER_BY_LISTPRICE - Static variable in class bb.common.PartWithQtyListResult
ORDER_BY_LISTPRICE - Static variable in class bb.common.PartWithSipQtyListResult
ORDER_BY_LISTPRICE - Static variable in class bb.common.PartWithSITQtyListResult
ORDER_BY_LISTPRICE - Static variable in class bb.common.PartWithSTOQtyListResult
ORDER_BY_LISTPRICE - Static variable in class bb.common.PartWithWipQtyListResult
ORDER_BY_LISTPRICE - Static variable in class bb.common.ShipperItemListResult
ORDER_BY_LISTPRICE - Static variable in class bb.common.VendorContractPriceItemVO
ORDER_BY_LNSHIPPERNUMBER - Static variable in class bb.common.LnShipperItemListResult
ORDER_BY_LNSHIPPERNUMBER - Static variable in class bb.common.LnShipperListResult
ORDER_BY_LNSHIPPERNUMBER - Static variable in class bb.common.OnloanReceiverItemListResult
ORDER_BY_LNSHIPPERNUMBER - Static variable in class bb.common.OnloanReceiverListResult
ORDER_BY_LOANDATE - Static variable in class bb.common.OnLoanItemListResult
ORDER_BY_LOANDATE - Static variable in class bb.common.OnLoanListResult
ORDER_BY_LOANITEMNUMBER - Static variable in class bb.common.OnLoanItemListResult
ORDER_BY_LOANNUMBER - Static variable in class bb.common.LnShipperItemListResult
ORDER_BY_LOANNUMBER - Static variable in class bb.common.LnShipperListResult
ORDER_BY_LOANNUMBER - Static variable in class bb.common.OnLoanItemListResult
ORDER_BY_LOANNUMBER - Static variable in class bb.common.OnLoanListResult
ORDER_BY_LOCALPATH - Static variable in class bb.common.DocumentServerVO
ORDER_BY_LOCALPATH - Static variable in class bb.common.MiscDocumentSettingVO
ORDER_BY_LOCATE - Static variable in class bb.common.InventoryNotUsedInMonthsResult
ORDER_BY_LOCATE - Static variable in class bb.common.NonproductivePickingItemIssuedVO
ORDER_BY_LOCATE - Static variable in class bb.common.PartIssuedListResult
ORDER_BY_LOCATE - Static variable in class bb.common.PartIssuedVO
ORDER_BY_LOCATE - Static variable in class bb.common.PartOnhandResult
ORDER_BY_LOCATE - Static variable in class bb.common.PartReceivedVO
ORDER_BY_LOCATE - Static variable in class bb.common.TransferOrderListResult
ORDER_BY_LOCATE - Static variable in class bb.common.TransferOrderVO
ORDER_BY_LOCATE - Static variable in class bb.common.TransferReceiverListResult
ORDER_BY_LOCATION - Static variable in class bb.common.AssetAddOrDisposalsReport
ORDER_BY_location - Static variable in class bb.common.AssetDepreciateVO
ORDER_BY_LOCATION - Static variable in class bb.common.CycleCountListResult
ORDER_BY_LOCATION - Static variable in class bb.common.DepartmentLocationForBackflushVO
ORDER_BY_LOCATION - Static variable in class bb.common.InventoryMonthReport
ORDER_BY_LOCATION - Static variable in class bb.common.LogInventoryListResult
ORDER_BY_LOCATION - Static variable in class bb.common.LogTrackingVO
ORDER_BY_LOCATION - Static variable in class bb.common.PartOnhandVO
ORDER_BY_LOCATION - Static variable in class bb.common.PhysicalInventoryListResult
ORDER_BY_LOCATION - Static variable in class bb.common.POReceiverItemListResult
ORDER_BY_LOCATION - Static variable in class bb.common.ShipperItemListResult
ORDER_BY_LOCATION - Static variable in class bb.common.ToolCalibrateListResult
ORDER_BY_LOCATION - Static variable in class bb.common.ToolCalibrationVO
ORDER_BY_LOCATION - Static variable in class bb.common.WOReceiverDetail
ORDER_BY_LOCATIONS - Static variable in class bb.common.POReceiverItemListResult
ORDER_BY_LOCK - Static variable in class bb.common.DocumentServerVO
ORDER_BY_LOCKED - Static variable in class bb.common.BizboxUserListResult
ORDER_BY_LOCKED - Static variable in class bb.common.PartClassVO
ORDER_BY_LOG - Static variable in class bb.common.RollUpBomStdCostWorkSheetVO
ORDER_BY_LOGONAME - Static variable in class bb.common.PrintLogoVO
ORDER_BY_MACADDRESS - Static variable in class bb.common.BizboxUserVO
ORDER_BY_MACADDRESS - Static variable in class bb.common.LogPartDocumentVO
ORDER_BY_MACADDRESS - Static variable in class bb.common.LogPartDwfVO
ORDER_BY_MACADDRESS - Static variable in class bb.common.LogPartDwgVO
ORDER_BY_MACADDRESS - Static variable in class bb.common.OperationLogVO
ORDER_BY_MAKEBUY - Static variable in class bb.common.ChangeStdCostWorkSheetItemVO
ORDER_BY_MAKEBUY - Static variable in class bb.common.PartBasicInfo
ORDER_BY_MAKEBUY - Static variable in class bb.common.PartCostVarianceListResult
ORDER_BY_MANUFACTURE - Static variable in class bb.common.CustomAssetVO
ORDER_BY_MANUFACTUREID - Static variable in class bb.common.CustomAssetVO
ORDER_BY_MANUFACTURERID - Static variable in class bb.common.EquipmentListResult
ORDER_BY_MANUFACTURERID - Static variable in class bb.common.PartOnHandWithMfgInfoResult
ORDER_BY_MANUFACTURERID - Static variable in class bb.common.PartWithManufacturerInfoResult
ORDER_BY_MANUFACTURERNAME - Static variable in class bb.common.PartOnHandWithMfgInfoResult
ORDER_BY_MANUFACTURERNAME - Static variable in class bb.common.PartWithManufacturerInfoResult
ORDER_BY_MANUFACTURERNAME - Static variable in class bb.common.ToolCalibrateListResult
ORDER_BY_MANUFACTURERNAME - Static variable in class bb.common.ToolCalibrationVO
ORDER_BY_MANUFACTURERPARTNUMBER - Static variable in class bb.common.PartOnHandWithMfgInfoResult
ORDER_BY_MANUFACTURERPARTNUMBER - Static variable in class bb.common.PartWithManufacturerInfoResult
ORDER_BY_MARGIN - Static variable in class bb.common.AccountsReceivableInfoVO
ORDER_BY_MAXQTY - Static variable in class bb.common.InventoryListResult
ORDER_BY_MAXQTY - Static variable in class bb.common.PartWithExcessiveInventoryListResult
ORDER_BY_MEASUREWORKER - Static variable in class bb.common.InspectionReportInfoVO
ORDER_BY_MFG - Static variable in class bb.common.SGSaleItemVO
ORDER_BY_MFG - Static variable in class bb.common.TransferReceiverItemListResult
ORDER_BY_MFG - Static variable in class bb.common.TransferShipperItemListResult
ORDER_BY_MFGDATE - Static variable in class bb.common.CustomAssetVO
ORDER_BY_MFGSTATUS - Static variable in class bb.common.DisassembleWorkOrderItemListResult
ORDER_BY_MFGSTATUS - Static variable in class bb.common.WorkOrderItemInWipListResult
ORDER_BY_MFGSTATUS - Static variable in class bb.common.WorkOrderItemListResult
ORDER_BY_MINORDER - Static variable in class bb.common.InventoryListResult
ORDER_BY_MINQTY - Static variable in class bb.common.InventoryListResult
ORDER_BY_MINQTY - Static variable in class bb.common.PartWithExcessiveInventoryListResult
ORDER_BY_MOBILE - Static variable in class bb.common.BizBoxUserEmployeeResult
ORDER_BY_MOBILE - Static variable in class bb.common.EmployeeCardVO
ORDER_BY_MOBILE - Static variable in class bb.common.NoticeUserEmployeeListResult
ORDER_BY_MOBILE - Static variable in class bb.common.VendorGroupUserVO
ORDER_BY_MODELNUMBER - Static variable in class bb.common.CustomAssetVO
ORDER_BY_MODELNUMBER - Static variable in class bb.common.InventoryListResult
ORDER_BY_MODELNUMBER - Static variable in class bb.common.InventoryNotUsedInMonthsforAppResult
ORDER_BY_MODELNUMBER - Static variable in class bb.common.PartBasicInfo
ORDER_BY_MODELNUMBER - Static variable in class bb.common.PartBasicInfoWithNewEngGroup
ORDER_BY_MODELNUMBER - Static variable in class bb.common.PartBasicInfoWithNewListPrice
ORDER_BY_MODELNUMBER - Static variable in class bb.common.PartOnhandVO
ORDER_BY_MODELNUMBER - Static variable in class bb.common.PartOnHandWithMfgInfoResult
ORDER_BY_MODELNUMBER - Static variable in class bb.common.PartOnHandWithPartBasicInfoResult
ORDER_BY_MODELNUMBER - Static variable in class bb.common.PartWithoutLocateResult
ORDER_BY_MODELNUMBER - Static variable in class bb.common.PhysicalInventoryListWithAppDataResult
ORDER_BY_MODELNUMBER - Static variable in class bb.common.WorkOrderItemIssuedTotalResult
ORDER_BY_month - Static variable in class bb.common.AssetDepreciateVO
ORDER_BY_monthDepreciationRate - Static variable in class bb.common.AssetDepreciateVO
ORDER_BY_MONTHDEPRECIATIONRATE - Static variable in class bb.common.AssetVO
ORDER_BY_MPN - Static variable in class bb.common.SGSaleItemVO
ORDER_BY_MPN - Static variable in class bb.common.TransferReceiverItemListResult
ORDER_BY_MPN - Static variable in class bb.common.TransferShipperItemListResult
ORDER_BY_NAME - Static variable in class bb.common.AccountPayableCheckVO
ORDER_BY_NAME - Static variable in class bb.common.AccountReceivableInfoWithPrepayResult
ORDER_BY_NAME - Static variable in class bb.common.AccountsPayableInfoVO
ORDER_BY_NAME - Static variable in class bb.common.AccountsReceivableInfoVO
ORDER_BY_NAME - Static variable in class bb.common.AssetTypeVO
ORDER_BY_NAME - Static variable in class bb.common.CompanyUnitVO
ORDER_BY_NAME - Static variable in class bb.common.CustomCheckUpEmployeeVO
ORDER_BY_NAME - Static variable in class bb.common.CustomDepartmentVO
ORDER_BY_NAME - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_NAME - Static variable in class bb.common.CustomerVendorAddressInfoVO
ORDER_BY_NAME - Static variable in class bb.common.CustomGoodsBreedVO
ORDER_BY_NAME - Static variable in class bb.common.CustomJobCategoryVO
ORDER_BY_NAME - Static variable in class bb.common.EngGroupVO
ORDER_BY_NAME - Static variable in class bb.common.GeneralLedgerCategoryVO
ORDER_BY_NAME - Static variable in class bb.common.GLDebitCreditListResult
ORDER_BY_NAME - Static variable in class bb.common.LabelTemplateVO
ORDER_BY_NAME - Static variable in class bb.common.LockedCustomerAddressResult
ORDER_BY_NAME - Static variable in class bb.common.LogTaskVO
ORDER_BY_NAME - Static variable in class bb.common.ManufacturerAddressInfoVO
ORDER_BY_NAME - Static variable in class bb.common.NonproductivePickingTypeVO
ORDER_BY_NAME - Static variable in class bb.common.SalesOrderItemCustomerTotalResult
ORDER_BY_NAME - Static variable in class bb.common.SGCustRequestForQuoteListResult
ORDER_BY_NAME - Static variable in class bb.common.SGPartCatalogResult
ORDER_BY_NAME - Static variable in class bb.common.VendorGroupUserVO
ORDER_BY_NAME - Static variable in class bb.common.VendorTotalAmountInPO
ORDER_BY_NAME - Static variable in class bb.common.WarehouseVO
ORDER_BY_NATIVEPLACE - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_NCR - Static variable in class bb.common.NcrNeedToScrapListResult
ORDER_BY_NCRDATE - Static variable in class bb.common.NcrReportListResult
ORDER_BY_NCRDATE - Static variable in class bb.common.NonConformanceReportVO
ORDER_BY_NCRNUMBER - Static variable in class bb.common.NcrReportListResult
ORDER_BY_NCRNUMBER - Static variable in class bb.common.NonConformanceReportVO
ORDER_BY_NCRNUMBER - Static variable in class bb.common.RMAItemListResult
ORDER_BY_NETSALVAGE - Static variable in class bb.common.AssetAddOrDisposalsReport
ORDER_BY_netSalvage - Static variable in class bb.common.AssetDepreciateVO
ORDER_BY_NETTOTAL - Static variable in class bb.common.ArSalesCodeTotalListResult
ORDER_BY_NEWAPPDAMAGED - Static variable in class bb.common.PhysicalInventoryListWithAppDataResult
ORDER_BY_NEWAPPNORMAL - Static variable in class bb.common.PhysicalInventoryListWithAppDataResult
ORDER_BY_NEWAPPOBSOLETE - Static variable in class bb.common.PhysicalInventoryListWithAppDataResult
ORDER_BY_NEWAPPOTHER - Static variable in class bb.common.PhysicalInventoryListWithAppDataResult
ORDER_BY_NEWAPPSLUGGISH - Static variable in class bb.common.PhysicalInventoryListWithAppDataResult
ORDER_BY_NEWAVGHRS - Static variable in class bb.common.WorkInstructionSeqAuditListResult
ORDER_BY_NEWCOST - Static variable in class bb.common.LogInventoryListResult
ORDER_BY_NEWINQA - Static variable in class bb.common.LogInventoryListResult
ORDER_BY_NEWINTO - Static variable in class bb.common.LogInventoryListResult
ORDER_BY_NEWONHAND - Static variable in class bb.common.CycleCountListResult
ORDER_BY_NEWONHAND - Static variable in class bb.common.InventoryAdjustmentVO
ORDER_BY_NEWONHAND - Static variable in class bb.common.LogInventoryListResult
ORDER_BY_NEWONHAND - Static variable in class bb.common.PhysicalInventoryListResult
ORDER_BY_NEWPARTNUMBER - Static variable in class bb.common.BillLogVO
ORDER_BY_NEWPARTQUANTITY - Static variable in class bb.common.BillLogVO
ORDER_BY_NEWPARTTYPE - Static variable in class bb.common.BillLogVO
ORDER_BY_NEWSIP - Static variable in class bb.common.LogInventoryListResult
ORDER_BY_NEWSIT - Static variable in class bb.common.LogInventoryListResult
ORDER_BY_NEWSPAREPART - Static variable in class bb.common.BillLogVO
ORDER_BY_NEWSTDCOST - Static variable in class bb.common.ChangeStdCostWorkSheetItemVO
ORDER_BY_NEWWIP - Static variable in class bb.common.LogInventoryListResult
ORDER_BY_NEXTCYCLECOUNT - Static variable in class bb.common.PartClassVO
ORDER_BY_NEXTINSPECTION - Static variable in class bb.common.ToolCalibrateListResult
ORDER_BY_NEXTINSPECTION - Static variable in class bb.common.ToolCalibrationVO
ORDER_BY_NEXTSCHEDULEDMAINTENANCEDATE - Static variable in class bb.common.EquipmentListResult
ORDER_BY_NONCONFORMANCECODE - Static variable in class bb.common.NCQRejectResult
ORDER_BY_NOTSHIPPEDQTY - Static variable in class bb.common.SalesOrderItemGroupByPartListResult
ORDER_BY_NUDESIGHRIGHT - Static variable in class bb.common.CustomCheckUpEmployeeVO
ORDER_BY_NUDESIGHTLEFT - Static variable in class bb.common.CustomCheckUpEmployeeVO
ORDER_BY_oldAvgCost - Static variable in class bb.common.PhysicalInventoryListResult
ORDER_BY_OLDCOST - Static variable in class bb.common.LogInventoryListResult
ORDER_BY_OLDINQA - Static variable in class bb.common.LogInventoryListResult
ORDER_BY_OLDINTO - Static variable in class bb.common.LogInventoryListResult
ORDER_BY_OLDONHAND - Static variable in class bb.common.LogInventoryListResult
ORDER_BY_oldOnloanQty - Static variable in class bb.common.PhysicalInventoryListResult
ORDER_BY_OLDSIP - Static variable in class bb.common.LogInventoryListResult
ORDER_BY_oldSip - Static variable in class bb.common.PhysicalInventoryListResult
ORDER_BY_OLDSIT - Static variable in class bb.common.LogInventoryListResult
ORDER_BY_oldStadCost - Static variable in class bb.common.PhysicalInventoryListResult
ORDER_BY_OLDWIP - Static variable in class bb.common.LogInventoryListResult
ORDER_BY_ONDEMAND - Static variable in class bb.common.BB2PartOnDemandListResult
ORDER_BY_ONDEMAND - Static variable in class bb.common.BillOnHandWithPartInfoResult
ORDER_BY_ONDEMAND - Static variable in class bb.common.PartOnHandWithMfgInfoResult
ORDER_BY_ONDEMAND - Static variable in class bb.common.PartWithExcessiveInventoryListResult
ORDER_BY_ONDEMAND - Static variable in class bb.common.PartWithInventoryInfoListResult
ORDER_BY_ONDEMAND - Static variable in class bb.common.SalesOrderItemGroupByPartListResult
ORDER_BY_ONDEMAND - Static variable in class bb.common.WOItemPartDetailNotIssue
ORDER_BY_ONDEMANDINSO - Static variable in class bb.common.SalesOrderItemGroupByPartListResult
ORDER_BY_ONDEMANDQTY - Static variable in class bb.common.HistoricalInventoryVO
ORDER_BY_ONDEMANDQTY - Static variable in class bb.common.PartOnHandWithPartBasicInfoResult
ORDER_BY_ONHAND - Static variable in class bb.common.BB2PartOnDemandListResult
ORDER_BY_ONHAND - Static variable in class bb.common.BillOnHandWithPartInfoResult
ORDER_BY_ONHAND - Static variable in class bb.common.ChangeStdCostWorkSheetItemVO
ORDER_BY_ONHAND - Static variable in class bb.common.HistoricalInventoryVO
ORDER_BY_ONHAND - Static variable in class bb.common.InventoryListResult
ORDER_BY_ONHAND - Static variable in class bb.common.InventoryNotUsedInMonthsforAppResult
ORDER_BY_ONHAND - Static variable in class bb.common.PartOnHandWithMfgInfoResult
ORDER_BY_ONHAND - Static variable in class bb.common.PartOnHandWithPartBasicInfoResult
ORDER_BY_ONHAND - Static variable in class bb.common.PartWithExcessiveInventoryListResult
ORDER_BY_ONHAND - Static variable in class bb.common.PartWithInventoryInfoListResult
ORDER_BY_ONHAND - Static variable in class bb.common.PartWithoutLocateResult
ORDER_BY_ONHAND - Static variable in class bb.common.PartWithQtyListResult
ORDER_BY_ONHAND - Static variable in class bb.common.PartWithSipQtyListResult
ORDER_BY_ONHAND - Static variable in class bb.common.PartWithSITQtyListResult
ORDER_BY_ONHAND - Static variable in class bb.common.RollUpBomStdCostWorkSheetItemVO
ORDER_BY_ONHAND - Static variable in class bb.common.SalesOrderItemGroupByPartListResult
ORDER_BY_ONHAND - Static variable in class bb.common.WOItemPartDetailNotIssue
ORDER_BY_ONHANDQTY - Static variable in class bb.common.AuditOnDemandResult
ORDER_BY_ONHANDQUANTITY - Static variable in class bb.common.PartOnhandVO
ORDER_BY_ONLOAN - Static variable in class bb.common.InventoryListResult
ORDER_BY_ONLOAN - Static variable in class bb.common.PartOnhandResult
ORDER_BY_ONLOANQTY - Static variable in class bb.common.HistoricalInventoryVO
ORDER_BY_ONLOANQTY - Static variable in class bb.common.PartWithOnLoanQtyListResult
ORDER_BY_ONORDER - Static variable in class bb.common.BB2PartOnDemandListResult
ORDER_BY_ONORDER - Static variable in class bb.common.BillOnHandWithPartInfoResult
ORDER_BY_ONORDER - Static variable in class bb.common.InventoryListResult
ORDER_BY_ONORDER - Static variable in class bb.common.PartOnHandWithMfgInfoResult
ORDER_BY_ONORDER - Static variable in class bb.common.PartWithExcessiveInventoryListResult
ORDER_BY_ONORDER - Static variable in class bb.common.PartWithInventoryInfoListResult
ORDER_BY_ONORDER - Static variable in class bb.common.SalesOrderItemGroupByPartListResult
ORDER_BY_ONORDER - Static variable in class bb.common.WOItemPartDetailNotIssue
ORDER_BY_ONORDERQTY - Static variable in class bb.common.HistoricalInventoryVO
ORDER_BY_ONORDERQTY - Static variable in class bb.common.PartOnHandWithPartBasicInfoResult
ORDER_BY_OPENDATE - Static variable in class bb.common.CustomerServiceIncidentItemListResult
ORDER_BY_OPENDATE - Static variable in class bb.common.CustomerServiceIncidentListResult
ORDER_BY_OPENDATE - Static variable in class bb.common.DesignControlListResult
ORDER_BY_OPERATINGENVIRONMENT - Static variable in class bb.common.InspectionReportInfoVO
ORDER_BY_OPERATINGENVIRONMENT - Static variable in class bb.common.OperatingInstructionsVO
ORDER_BY_OPERATINGINSTRUCTIONSDESCRIPTION - Static variable in class bb.common.OperatingInstructionsUserStatisticalResult
ORDER_BY_OPERATINGINSTRUCTIONSDESCRIPTION - Static variable in class bb.common.OperatingInstructionsVO
ORDER_BY_OPERATINGINSTRUCTIONSNOTES - Static variable in class bb.common.OperatingInstructionsVO
ORDER_BY_OPERATINGINSTRUCTIONSNUMBER - Static variable in class bb.common.InspectionReportInfoVO
ORDER_BY_OPERATINGINSTRUCTIONSNUMBER - Static variable in class bb.common.OperatingInstructionsUserStatisticalResult
ORDER_BY_OPERATINGINSTRUCTIONSNUMBER - Static variable in class bb.common.OperatingInstructionsVO
ORDER_BY_OPERATINGINSTRUCTIONSTYPE - Static variable in class bb.common.OperatingInstructionsVO
ORDER_BY_OPERATINGINSTRUCTIONSTYPEDESCRIPTION - Static variable in class bb.common.OperatingInstructionsUserStatisticalResult
ORDER_BY_OPERATINGINSTRUCTIONSTYPEID - Static variable in class bb.common.InspectionReportInfoVO
ORDER_BY_OPERATINGPROCESSNOTES - Static variable in class bb.common.OperatingInstructionsVO
ORDER_BY_OPERATINGPROCESSRECORD - Static variable in class bb.common.OperatingInstructionsVO
ORDER_BY_OPERATOR - Static variable in class bb.common.NonproductivePickingItemIssuedVO
ORDER_BY_OPTWHO - Static variable in class bb.common.EngineeringSharingItemVO
ORDER_BY_ORDERITEMNUMBER - Static variable in class bb.common.LogMiscDocumentVO
ORDER_BY_ORDERNUMBER - Static variable in class bb.common.LogMiscDocumentVO
ORDER_BY_ORDERNUMBER - Static variable in class bb.common.PartIssuedListResult
ORDER_BY_ORDERNUMBER - Static variable in class bb.common.PartIssuedVO
ORDER_BY_ORDERNUMBER - Static variable in class bb.common.PartReceivedListResult
ORDER_BY_ORDERNUMBER - Static variable in class bb.common.PartReceivedVO
ORDER_BY_ORDERQTY - Static variable in class bb.common.PurchaseOrderItemListResult
ORDER_BY_ORDERRELATEDDOC - Static variable in class bb.common.DisassembleWorkOrderItemListResult
ORDER_BY_ORDERRELATEDDOC - Static variable in class bb.common.WorkOrderItemListResult
ORDER_BY_ORDERTYPE - Static variable in class bb.common.NonproductivePickingItemIssuedListResult
ORDER_BY_ORDERTYPE - Static variable in class bb.common.NonproductivePickingItemResult
ORDER_BY_ORDERTYPE - Static variable in class bb.common.NonproductivePickingVO
ORDER_BY_ORDERTYPE - Static variable in class bb.common.TermsConditionVO
ORDER_BY_ORGANIZATION - Static variable in class bb.common.PartBasicInfo
ORDER_BY_ORGANIZATION - Static variable in class bb.common.PartBasicInfoWithNewEngGroup
ORDER_BY_ORGANIZATION - Static variable in class bb.common.PartBasicInfoWithNewListPrice
ORDER_BY_ORGANIZATION - Static variable in class bb.common.PartOnHandWithMfgInfoResult
ORDER_BY_ORGANIZATION - Static variable in class bb.common.PartOnHandWithPartBasicInfoResult
ORDER_BY_ORIGIALSHIPDATE - Static variable in class bb.common.POReceiverItemListResult
ORDER_BY_ORIGIN - Static variable in class bb.common.BillWithPartInfoResult
ORDER_BY_ORIGIN - Static variable in class bb.common.InspectionConformanceReportVO
ORDER_BY_ORIGIN - Static variable in class bb.common.NonConformanceCodeVO
ORDER_BY_ORIGIN - Static variable in class bb.common.PartBasicInfo
ORDER_BY_ORIGIN - Static variable in class bb.common.SwapReceiverListResult
ORDER_BY_ORIGIN - Static variable in class bb.common.TransferOrderListResult
ORDER_BY_ORIGIN - Static variable in class bb.common.TransferOrderVO
ORDER_BY_ORIGIN - Static variable in class bb.common.TransferReceiverListResult
ORDER_BY_ORIGIN - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_ORIGINAL - Static variable in class bb.common.SalesOrderShipDateListResult
ORDER_BY_ORIGINALCOST - Static variable in class bb.common.CustomAssetVO
ORDER_BY_ORIGINALDELIVERY - Static variable in class bb.common.SalesOrderItemListResult
ORDER_BY_ORIGINALINVOICENUMBER - Static variable in class bb.common.CustomerFeedbackVO
ORDER_BY_ORIGINALPOSITION - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_ORIGINALSALESORDERNUMBER - Static variable in class bb.common.CustomerFeedbackVO
ORDER_BY_ORIGINALWORKORDERNUMBER - Static variable in class bb.common.CustomerFeedbackVO
ORDER_BY_ORIGINATEDDATE - Static variable in class bb.common.WorkInstructionRequestForChangeVO
ORDER_BY_ORIGINATOR - Static variable in class bb.common.DisassembleWorkOrderItemListResult
ORDER_BY_ORIGINATOR - Static variable in class bb.common.EngineeringChangeListResult
ORDER_BY_ORIGINATOR - Static variable in class bb.common.EngineeringChangeRequestListResult
ORDER_BY_ORIGINATOR - Static variable in class bb.common.WorkOrderItemInWipListResult
ORDER_BY_ORIGINATOR - Static variable in class bb.common.WorkOrderItemListResult
ORDER_BY_OURPONUMBER - Static variable in class bb.common.APItemListResult
ORDER_BY_OURPONUMBER - Static variable in class bb.common.VendorStatementListResult
ORDER_BY_OURREFQUOTE - Static variable in class bb.common.QuoteListResult
ORDER_BY_OUTAMOUNT - Static variable in class bb.common.InventoryMonthReport
ORDER_BY_OUTCOST - Static variable in class bb.common.InventoryMonthReport
ORDER_BY_OUTCOST - Static variable in class bb.common.LogInventoryListResult
ORDER_BY_OUTQTY - Static variable in class bb.common.InventoryMonthReport
ORDER_BY_OUTQTY - Static variable in class bb.common.LogInventoryListResult
ORDER_BY_OUTQTY - Static variable in class bb.common.LogTrackingVO
ORDER_BY_OVERPERCENT - Static variable in class bb.common.WorkOrderItemReviewCostResult
ORDER_BY_OWNER - Static variable in class bb.common.PartClassVO
ORDER_BY_OWNERNAME - Static variable in class bb.common.ShipListInfoVO
ORDER_BY_OWNERNAME - Static variable in class bb.common.ShipListOwnerVO
ORDER_BY_PACKINGBOXITEMPK - Static variable in class bb.common.PackingBoxItemListResult
ORDER_BY_PAID - Static variable in class bb.common.AccountsReceivableInfoVO
ORDER_BY_PAIDDATE - Static variable in class bb.common.ArCommissionListResult
ORDER_BY_PAIDDATE - Static variable in class bb.common.InvoiceItemListResult
ORDER_BY_PARENTID - Static variable in class bb.common.EngGroupVO
ORDER_BY_PARNUMBER - Static variable in class bb.common.PreventiveActionRequestVO
ORDER_BY_PART - Static variable in class bb.common.BB2PartOnDemandListResult
ORDER_BY_PART - Static variable in class bb.common.HighUsagePartResult
ORDER_BY_PART - Static variable in class bb.common.InventoryCycleResult
ORDER_BY_PART - Static variable in class bb.common.InventoryListResult
ORDER_BY_PART - Static variable in class bb.common.InventoryNotUsedInMonthsResult
ORDER_BY_PART - Static variable in class bb.common.NcrNeedToScrapListResult
ORDER_BY_PART - Static variable in class bb.common.NcrReportListResult
ORDER_BY_PART - Static variable in class bb.common.PartClassInfoResult
ORDER_BY_PART - Static variable in class bb.common.PartInWipForIDListResult
ORDER_BY_PART - Static variable in class bb.common.PartOnhandResult
ORDER_BY_PART - Static variable in class bb.common.SalesOrder12MonthMarginResult
ORDER_BY_PART - Static variable in class bb.common.WOItemPartDetailNotIssue
ORDER_BY_PARTCLASS - Static variable in class bb.common.PartClassInfoResult
ORDER_BY_PARTDESC - Static variable in class bb.common.DisassembleWorkOrderItemListResult
ORDER_BY_PARTDESC - Static variable in class bb.common.NonproductivePickingItemIssuedListResult
ORDER_BY_PARTDESC - Static variable in class bb.common.RequestForQuoteItemListResult
ORDER_BY_PARTDESC - Static variable in class bb.common.WorkOrderItemInWipListResult
ORDER_BY_PARTDESC - Static variable in class bb.common.WorkOrderItemListResult
ORDER_BY_PARTDESC - Static variable in class bb.common.WorkOrderItemPartDetail
ORDER_BY_PARTDESCRIPTION - Static variable in class bb.common.DesignControlListResult
ORDER_BY_PARTDESCRIPTION - Static variable in class bb.common.EngineeringChangeListResult
ORDER_BY_PARTDESCRIPTION - Static variable in class bb.common.EngineeringChangeRequestListResult
ORDER_BY_PARTDESCRIPTION - Static variable in class bb.common.EngineeringSharingItemVO
ORDER_BY_PARTDESCRIPTION - Static variable in class bb.common.IcrItemListResult
ORDER_BY_PARTDESCRIPTION - Static variable in class bb.common.InventoryReportListResult
ORDER_BY_PARTDESCRIPTION - Static variable in class bb.common.PartCostVarianceListResult
ORDER_BY_PARTDESCRIPTION - Static variable in class bb.common.PartDwfWithPartInfoResult
ORDER_BY_PARTDESCRIPTION - Static variable in class bb.common.PartDwgWithPartInfoResult
ORDER_BY_PARTDESCRIPTION - Static variable in class bb.common.PartInspectionResult
ORDER_BY_PARTDESCRIPTION - Static variable in class bb.common.WorkOrderOverIssueListResult
ORDER_BY_PARTFROM - Static variable in class bb.common.AccountsReceivableItemResult
ORDER_BY_PARTFROM - Static variable in class bb.common.AccountsReceivableItemVO
ORDER_BY_PARTFROM - Static variable in class bb.common.CustomerServiceIncidentListResult
ORDER_BY_PARTFROM - Static variable in class bb.common.LogPartDwfVO
ORDER_BY_PARTFROM - Static variable in class bb.common.LogPartDwgVO
ORDER_BY_PARTFROM - Static variable in class bb.common.PackingBoxItemListResult
ORDER_BY_PARTFROM - Static variable in class bb.common.SwapOrderItemListResult
ORDER_BY_PARTFROM - Static variable in class bb.common.SwapReceiverItemListResult
ORDER_BY_PARTFROM - Static variable in class bb.common.SwapShipperItemListResult
ORDER_BY_PARTFROM - Static variable in class bb.common.TransferOrderItemListResult
ORDER_BY_PARTFROM - Static variable in class bb.common.TransferReceiverItemListResult
ORDER_BY_PARTFROM - Static variable in class bb.common.TransferShipperItemListResult
ORDER_BY_PARTFROM - Static variable in class bb.common.VendorPartVO
ORDER_BY_PARTINWIP - Static variable in class bb.common.PartInWipForIDListResult
ORDER_BY_PARTINWIPDESCRIPTION - Static variable in class bb.common.PartInWipForIDListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.AccountsReceivableItemResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.AccountsReceivableItemVO
ORDER_BY_PARTNUMBER - Static variable in class bb.common.APAgingItemListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.APItemListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.BillLogVO
ORDER_BY_PARTNUMBER - Static variable in class bb.common.CheckInvoiceItemListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.ContractPriceItemVO
ORDER_BY_PARTNUMBER - Static variable in class bb.common.CorrectiveActionRequestVO
ORDER_BY_PARTNUMBER - Static variable in class bb.common.CustomerServiceIncidentItemListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.CustomerServiceIncidentListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.CycleCountListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.DWOIssueDetail
ORDER_BY_PARTNUMBER - Static variable in class bb.common.HistoricalInventoryVO
ORDER_BY_PARTNUMBER - Static variable in class bb.common.IcrItemListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.InventoryAdjustmentListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.InventoryMonthReport
ORDER_BY_PARTNUMBER - Static variable in class bb.common.InventoryNotUsedInMonthsforAppResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.InventoryReportListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.InvoiceAgingItemListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.InvoiceItemListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.LnShipperItemListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.LogInventoryListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.LogMiscDocumentVO
ORDER_BY_PARTNUMBER - Static variable in class bb.common.LogPartDocumentVO
ORDER_BY_PARTNUMBER - Static variable in class bb.common.LogPartDwfVO
ORDER_BY_PARTNUMBER - Static variable in class bb.common.LogPartDwgVO
ORDER_BY_PARTNUMBER - Static variable in class bb.common.LogTrackingVO
ORDER_BY_PARTNUMBER - Static variable in class bb.common.NonConformanceReportVO
ORDER_BY_PARTNUMBER - Static variable in class bb.common.NonproductivePickingItemIssuedVO
ORDER_BY_PARTNUMBER - Static variable in class bb.common.NonproductivePickingItemResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.OnloanReceiverItemListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.PackingBoxItemListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.PartBasicInfo
ORDER_BY_PARTNUMBER - Static variable in class bb.common.PartCertificateListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.PartCostVarianceListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.PartDwfWithPartInfoResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.PartDwgWithPartInfoResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.PartInQAVO
ORDER_BY_PARTNUMBER - Static variable in class bb.common.PartInspectionResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.PartIssuedListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.PartIssuedVO
ORDER_BY_PARTNUMBER - Static variable in class bb.common.PartOnhandVO
ORDER_BY_PARTNUMBER - Static variable in class bb.common.PartReceivedListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.PartReceivedVO
ORDER_BY_PARTNUMBER - Static variable in class bb.common.PartUseTypeVO
ORDER_BY_PARTNUMBER - Static variable in class bb.common.PartWithInventoryInfoListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.PartWithManufacturerInfoResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.PhysicalInventoryListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.POReceiverItemListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.ProformaInvoiceItemListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.RMAReceiverItemListResult
ORDER_BY_partNumber - Static variable in class bb.common.RtvShipperItemListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.SalesOrderItemGroupByPartListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.SalesOrderShipDateListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.SalesTaxListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.SGCustomerServiceRequestVO
ORDER_BY_PARTNUMBER - Static variable in class bb.common.SGPartCatalogResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.SGQuoteCartListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.SGSaleItemVO
ORDER_BY_PARTNUMBER - Static variable in class bb.common.ShipperItemListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.SOShipperItemListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.SwapReceiverItemListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.SwapShipperItemListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.TransferOrderItemListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.TransferReceiverItemListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.TransferShipperItemListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.VendorPartVO
ORDER_BY_PARTNUMBER - Static variable in class bb.common.WOReceiverDetail
ORDER_BY_PARTNUMBER - Static variable in class bb.common.WorkInstructionListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.WorkInstructionRequestForChangeVO
ORDER_BY_PARTNUMBER - Static variable in class bb.common.WorkInstructionSequenceListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.WorkOrderItemCanAssyResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.WorkOrderItemInfoResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.WorkOrderItemIssuedTotalResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.WorkOrderItemLaborCostListResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.WorkOrderItemPartDetailInWipVO
ORDER_BY_PARTNUMBER - Static variable in class bb.common.WorkOrderItemReviewCostResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.WorkOrderItemTimeDetailVO
ORDER_BY_PARTNUMBER - Static variable in class bb.common.WorkOrderItemToIssueResult
ORDER_BY_PARTNUMBER - Static variable in class bb.common.WorkOrderTimeCardVO
ORDER_BY_PARTNUMBER - Static variable in class bb.common.WorkOrderWorkInstructionListResult
ORDER_BY_PARTORASSY - Static variable in class bb.common.SalesOrderItemListResult
ORDER_BY_PARTPK - Static variable in class bb.common.AuditOnDemandResult
ORDER_BY_PARTPK - Static variable in class bb.common.DesignControlListResult
ORDER_BY_PARTPK - Static variable in class bb.common.DisassembleWorkOrderItemListResult
ORDER_BY_PARTPK - Static variable in class bb.common.EngineeringChangeListResult
ORDER_BY_PARTPK - Static variable in class bb.common.EngineeringChangeRequestListResult
ORDER_BY_PARTPK - Static variable in class bb.common.JobProcessSheetListResult
ORDER_BY_PARTPK - Static variable in class bb.common.NonproductivePickingItemIssuedListResult
ORDER_BY_PARTPK - Static variable in class bb.common.OnLoanItemListResult
ORDER_BY_PARTPK - Static variable in class bb.common.PartBasicInfoWithNewEngGroup
ORDER_BY_PARTPK - Static variable in class bb.common.PartBasicInfoWithNewListPrice
ORDER_BY_PARTPK - Static variable in class bb.common.PartOnHandWithMfgInfoResult
ORDER_BY_PARTPK - Static variable in class bb.common.PartOnHandWithPartBasicInfoResult
ORDER_BY_PARTPK - Static variable in class bb.common.PartWithExcessiveInventoryListResult
ORDER_BY_PARTPK - Static variable in class bb.common.PartWithOnLoanQtyListResult
ORDER_BY_PARTPK - Static variable in class bb.common.PartWithoutLocateResult
ORDER_BY_PARTPK - Static variable in class bb.common.PartWithQAQtyListResult
ORDER_BY_PARTPK - Static variable in class bb.common.PartWithQtyListResult
ORDER_BY_PARTPK - Static variable in class bb.common.PartWithSipQtyListResult
ORDER_BY_PARTPK - Static variable in class bb.common.PartWithSITQtyListResult
ORDER_BY_PARTPK - Static variable in class bb.common.PartWithSTOQtyListResult
ORDER_BY_PARTPK - Static variable in class bb.common.PartWithWipQtyListResult
ORDER_BY_PARTPK - Static variable in class bb.common.PurchaseOrderItemListResult
ORDER_BY_PARTPK - Static variable in class bb.common.PurchaseOrderOpenDueListResult
ORDER_BY_PARTPK - Static variable in class bb.common.QuoteItemListResult
ORDER_BY_PARTPK - Static variable in class bb.common.RequestForQuoteItemListResult
ORDER_BY_PARTPK - Static variable in class bb.common.ReturnToVendorByDateListResult
ORDER_BY_PARTPK - Static variable in class bb.common.ReturnToVendorItemListResult
ORDER_BY_PARTPK - Static variable in class bb.common.RMAItemListResult
ORDER_BY_PARTPK - Static variable in class bb.common.SalesOrderItemListResult
ORDER_BY_PARTPK - Static variable in class bb.common.WorkOrderItemInWipListResult
ORDER_BY_PARTPK - Static variable in class bb.common.WorkOrderItemListResult
ORDER_BY_PARTPK - Static variable in class bb.common.WorkOrderItemPartDetail
ORDER_BY_PARTPK - Static variable in class bb.common.WorkOrderOverIssueListResult
ORDER_BY_PARTQUANTITY - Static variable in class bb.common.BillLogVO
ORDER_BY_PARTREVISION - Static variable in class bb.common.IcrItemListResult
ORDER_BY_PARTREVISION - Static variable in class bb.common.PartDwfWithPartInfoResult
ORDER_BY_PARTREVISION - Static variable in class bb.common.PartDwgWithPartInfoResult
ORDER_BY_PARTTYPE - Static variable in class bb.common.AccountsReceivableItemResult
ORDER_BY_PARTTYPE - Static variable in class bb.common.AccountsReceivableItemVO
ORDER_BY_PARTTYPE - Static variable in class bb.common.APItemListResult
ORDER_BY_PARTTYPE - Static variable in class bb.common.BillLogVO
ORDER_BY_PARTTYPE - Static variable in class bb.common.CustomerServiceIncidentListResult
ORDER_BY_PARTTYPE - Static variable in class bb.common.InventoryNotUsedInMonthsforAppResult
ORDER_BY_PARTTYPE - Static variable in class bb.common.LogMiscDocumentVO
ORDER_BY_PARTTYPE - Static variable in class bb.common.LogTrackingVO
ORDER_BY_PARTTYPE - Static variable in class bb.common.NonproductivePickingItemIssuedVO
ORDER_BY_PARTTYPE - Static variable in class bb.common.NonproductivePickingItemResult
ORDER_BY_PARTTYPE - Static variable in class bb.common.OnloanReceiverItemListResult
ORDER_BY_PARTTYPE - Static variable in class bb.common.PackingBoxItemListResult
ORDER_BY_PARTTYPE - Static variable in class bb.common.PartBasicInfo
ORDER_BY_PARTTYPE - Static variable in class bb.common.PartOnhandResult
ORDER_BY_PARTTYPE - Static variable in class bb.common.PartOnHandWithMfgInfoResult
ORDER_BY_PARTTYPE - Static variable in class bb.common.PartTypeVO
ORDER_BY_PARTTYPE - Static variable in class bb.common.PartUseTypeVO
ORDER_BY_PARTTYPE - Static variable in class bb.common.PartWithInventoryInfoListResult
ORDER_BY_PARTTYPE - Static variable in class bb.common.PartWithManufacturerInfoResult
ORDER_BY_PARTTYPE - Static variable in class bb.common.RMAReceiverItemListResult
ORDER_BY_PARTTYPE - Static variable in class bb.common.SalesTaxListResult
ORDER_BY_PARTTYPE - Static variable in class bb.common.SGQuoteCartListResult
ORDER_BY_PARTTYPE - Static variable in class bb.common.SwapOrderItemListResult
ORDER_BY_PARTTYPE - Static variable in class bb.common.SwapReceiverItemListResult
ORDER_BY_PARTTYPE - Static variable in class bb.common.SwapShipperItemListResult
ORDER_BY_PARTTYPE - Static variable in class bb.common.TransferOrderItemListResult
ORDER_BY_PARTTYPE - Static variable in class bb.common.TransferReceiverItemListResult
ORDER_BY_PARTTYPE - Static variable in class bb.common.TransferShipperItemListResult
ORDER_BY_PARTTYPE - Static variable in class bb.common.VendorPartVO
ORDER_BY_PARTTYPE - Static variable in class bb.common.WOItemPartDetailNotIssue
ORDER_BY_PARTTYPE - Static variable in class bb.common.WorkOrderItemInfoResult
ORDER_BY_PARTTYPE - Static variable in class bb.common.WorkOrderItemIssuedTotalResult
ORDER_BY_PARTTYPE - Static variable in class bb.common.WorkOrderItemLaborCostListResult
ORDER_BY_PARTTYPE - Static variable in class bb.common.WorkOrderItemTimeDetailVO
ORDER_BY_PARTUNIT - Static variable in class bb.common.PartBasicInfo
ORDER_BY_PARTUNIT - Static variable in class bb.common.PartBasicInfoWithNewEngGroup
ORDER_BY_PARTUNIT - Static variable in class bb.common.PartBasicInfoWithNewListPrice
ORDER_BY_PARTUNIT - Static variable in class bb.common.PartOnhandResult
ORDER_BY_PARTUNIT - Static variable in class bb.common.PartOnHandWithMfgInfoResult
ORDER_BY_PARTUNIT - Static variable in class bb.common.PartOnHandWithPartBasicInfoResult
ORDER_BY_PARTUNIT - Static variable in class bb.common.PartWithoutLocateResult
ORDER_BY_PAUSEDTIME - Static variable in class bb.common.OperatingInstructionsUserStatisticalResult
ORDER_BY_PAUSEDTIME - Static variable in class bb.common.OperatingInstructionsVO
ORDER_BY_PAUSEDTIMEBYHOUR - Static variable in class bb.common.OperatingInstructionsUserStatisticalResult
ORDER_BY_PAUSEDTIMEBYHOUR - Static variable in class bb.common.OperatingInstructionsVO
ORDER_BY_PAYABLEMETHODID - Static variable in class bb.common.PayableMethodVO
ORDER_BY_PAYABLEMETHODNAME - Static variable in class bb.common.PayableMethodVO
ORDER_BY_PAYDATE - Static variable in class bb.common.AccountsPayableInfoVO
ORDER_BY_PAYDATE - Static variable in class bb.common.AccountsReceivableInfoVO
ORDER_BY_PAYDATE - Static variable in class bb.common.APAgingItemListResult
ORDER_BY_PAYDATE - Static variable in class bb.common.ApCheckRunListResult
ORDER_BY_PAYDATE - Static variable in class bb.common.APItemListResult
ORDER_BY_PAYDATE - Static variable in class bb.common.ArCommissionListResult
ORDER_BY_PAYDATE - Static variable in class bb.common.ARPaymentRunListResult
ORDER_BY_PAYDATE - Static variable in class bb.common.InvoiceAgingItemListResult
ORDER_BY_PAYDATE - Static variable in class bb.common.InvoiceItemListResult
ORDER_BY_PAYDATE - Static variable in class bb.common.SalesTaxListResult
ORDER_BY_PAYDATE - Static variable in class bb.common.TempArApAgingVO
ORDER_BY_PAYMENTNUMBER - Static variable in class bb.common.ARPaymentRunListResult
ORDER_BY_PAYMENTNUMBER - Static variable in class bb.common.ARPaymentRunVO
ORDER_BY_PAYMENTRUNNUMBER - Static variable in class bb.common.ARPaymentRunListResult
ORDER_BY_PAYMENTRUNNUMBER - Static variable in class bb.common.ARPaymentRunVO
ORDER_BY_PCTMARGIN - Static variable in class bb.common.SalesOrder12MonthMarginResult
ORDER_BY_PERIOD - Static variable in class bb.common.PartClassVO
ORDER_BY_PERIODUNIT - Static variable in class bb.common.PartClassVO
ORDER_BY_PERMISSIONID - Static variable in class bb.common.PermissionListResult
ORDER_BY_PERMISSIONID - Static variable in class bb.common.PermissionVO
ORDER_BY_PERMISSIONID - Static variable in class bb.common.UserRolePermissionListResult
ORDER_BY_PERMISSIONNAME - Static variable in class bb.common.PermissionListResult
ORDER_BY_PERMISSIONNAME - Static variable in class bb.common.UserRolePermissionListResult
ORDER_BY_PFINVOICENUMBER - Static variable in class bb.common.ProformaInvoiceItemListResult
ORDER_BY_PFNUMBER - Static variable in class bb.common.ProformaInvoiceListResult
ORDER_BY_PHONE - Static variable in class bb.common.BizBoxUserEmployeeResult
ORDER_BY_PHONE - Static variable in class bb.common.CustomerVendorAddressInfoVO
ORDER_BY_PHONE - Static variable in class bb.common.EmployeeCardVO
ORDER_BY_PHONE - Static variable in class bb.common.NoticeUserEmployeeListResult
ORDER_BY_PICKER - Static variable in class bb.common.NonproductivePickingItemIssuedVO
ORDER_BY_PICKER - Static variable in class bb.common.PartIssuedVO
ORDER_BY_PICKINGITEMNUMBER - Static variable in class bb.common.NonproductivePickingItemIssuedVO
ORDER_BY_PICKINGNUMBER - Static variable in class bb.common.NonproductivePickingItemIssuedVO
ORDER_BY_PICKINGNUMBER - Static variable in class bb.common.NonproductivePickingItemResult
ORDER_BY_PICKINGNUMBER - Static variable in class bb.common.NonproductivePickingVO
ORDER_BY_PICKLISTORDERNUMBER - Static variable in class bb.common.InspectionReportInfoVO
ORDER_BY_PICKLISTORDERNUMBER - Static variable in class bb.common.OperatingInstructionsVO
ORDER_BY_PICTURE - Static variable in class bb.common.EmployeeCardVO
ORDER_BY_PK - Static variable in class bb.common.AllPartDocumentsVO
ORDER_BY_PK - Static variable in class bb.common.AssetDepreciateDetailReport
ORDER_BY_PK - Static variable in class bb.common.ChangeStdCostWorkSheetItemVO
ORDER_BY_PK - Static variable in class bb.common.ContractPriceCustomerVO
ORDER_BY_PK - Static variable in class bb.common.ContractPriceItemVO
ORDER_BY_PK - Static variable in class bb.common.CurrencyExchangeVO
ORDER_BY_PK - Static variable in class bb.common.CustomEmployeeTrainVO
ORDER_BY_PK - Static variable in class bb.common.CycleCountListResult
ORDER_BY_PK - Static variable in class bb.common.DepreciateMonthlyReport
ORDER_BY_PK - Static variable in class bb.common.EngGroupUserVO
ORDER_BY_PK - Static variable in class bb.common.EngineeringSharingItemVO
ORDER_BY_PK - Static variable in class bb.common.PhysicalInventoryListResult
ORDER_BY_PK - Static variable in class bb.common.PurchaseWorkSheetVO
ORDER_BY_PK - Static variable in class bb.common.RollUpBomStdCostWorkSheetItemVO
ORDER_BY_PK - Static variable in class bb.common.SalesOrderShipDateListResult
ORDER_BY_PK - Static variable in class bb.common.ToolCalibrateListResult
ORDER_BY_PK - Static variable in class bb.common.ToolCalibrationVO
ORDER_BY_PK - Static variable in class bb.common.VendorContractPriceItemVO
ORDER_BY_PK - Static variable in class bb.common.VendorContractPriceVendorVO
ORDER_BY_PK - Static variable in class bb.common.WorkCenterGroupItemVO
ORDER_BY_PK - Static variable in class bb.common.WorkOrderItemCanAssyResult
ORDER_BY_PK - Static variable in class bb.common.WorkOrderItemReviewCostResult
ORDER_BY_PK - Static variable in class bb.common.WorkOrderItemToIssueResult
ORDER_BY_PK - Static variable in class bb.common.WorkOrderWorkSheetVO
ORDER_BY_PK_ITEMNUMBER - Static variable in class bb.common.InspectionItemVO
ORDER_BY_PK_VENDORID - Static variable in class bb.common.VendorPartVO
ORDER_BY_PK_VENDORPARTFROM - Static variable in class bb.common.VendorPartVO
ORDER_BY_PK_VENDORPARTNUMBER - Static variable in class bb.common.VendorPartVO
ORDER_BY_PK_VENDORPARTTYPE - Static variable in class bb.common.VendorPartVO
ORDER_BY_PLACE - Static variable in class bb.common.CustomEmployeeTrainVO
ORDER_BY_PLACE - Static variable in class bb.common.IncotermVO
ORDER_BY_POACCEPTEMPLOYEE - Static variable in class bb.common.POSurveyReportVO
ORDER_BY_POBOILERPLATE - Static variable in class bb.common.PurchaseOrderBoilerplateVO
ORDER_BY_PODATE - Static variable in class bb.common.POStatisticsResult
ORDER_BY_PODATE - Static variable in class bb.common.PurchaseOrderCheckListResult
ORDER_BY_PODATE - Static variable in class bb.common.PurchaseOrderItemListResult
ORDER_BY_PODATE - Static variable in class bb.common.PurchaseOrderListResult
ORDER_BY_PODATE - Static variable in class bb.common.PurchaseOrderOpenDueListResult
ORDER_BY_POITEMPK - Static variable in class bb.common.EcnPOOrderResult
ORDER_BY_POITEMPK - Static variable in class bb.common.EcnWOOrderResult
ORDER_BY_POLITYVISAGE - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_POMESSAGENUMBER - Static variable in class bb.common.PoMessageListResult
ORDER_BY_PONUMBER - Static variable in class bb.common.AccountsPayableInfoVO
ORDER_BY_PONUMBER - Static variable in class bb.common.ApCheckRunListResult
ORDER_BY_PONUMBER - Static variable in class bb.common.ApPrepayVO
ORDER_BY_PONUMBER - Static variable in class bb.common.GeneralLedgerByDateListResult
ORDER_BY_PONUMBER - Static variable in class bb.common.NcrReportListResult
ORDER_BY_PONUMBER - Static variable in class bb.common.PoMessageListResult
ORDER_BY_PONUMBER - Static variable in class bb.common.POReceiverItemListResult
ORDER_BY_PONUMBER - Static variable in class bb.common.POStatisticsResult
ORDER_BY_PONUMBER - Static variable in class bb.common.PurchaseOrderCheckListResult
ORDER_BY_PONUMBER - Static variable in class bb.common.PurchaseOrderItemListResult
ORDER_BY_PONUMBER - Static variable in class bb.common.PurchaseOrderListResult
ORDER_BY_PONUMBER - Static variable in class bb.common.PurchaseOrderOpenDueListResult
ORDER_BY_PONUMBER - Static variable in class bb.common.ReturnToVendorCheckListResult
ORDER_BY_PONUMBER - Static variable in class bb.common.RtvShipperInfoVO
ORDER_BY_poNumber - Static variable in class bb.common.RtvShipperItemListResult
ORDER_BY_PONUMBER - Static variable in class bb.common.RtvShipperListResult
ORDER_BY_PONUMBER - Static variable in class bb.common.TempArApAgingVO
ORDER_BY_PORECEIVED - Static variable in class bb.common.POReceiverItemListResult
ORDER_BY_PORELATEDOC - Static variable in class bb.common.LogInventoryListResult
ORDER_BY_PORT - Static variable in class bb.common.OperationLogVO
ORDER_BY_PORTRAITORIENTATION - Static variable in class bb.common.LabelTemplateVO
ORDER_BY_POSHIPDATE - Static variable in class bb.common.POReceiverItemListResult
ORDER_BY_POSITION - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_POSITION - Static variable in class bb.common.EmployeeCardVO
ORDER_BY_POSTATUS - Static variable in class bb.common.PurchaseOrderListResult
ORDER_BY_POVENDER - Static variable in class bb.common.LogInventoryListResult
ORDER_BY_PRINCIPAL - Static variable in class bb.common.CustomAssetVO
ORDER_BY_PRINTEDBOARDNUMBER - Static variable in class bb.common.InspectionReportInfoVO
ORDER_BY_PRIORITY - Static variable in class bb.common.DisassembleWorkOrderItemListResult
ORDER_BY_PRIORITY - Static variable in class bb.common.SGCustomerServiceRequestVO
ORDER_BY_PRIORITY - Static variable in class bb.common.WorkOrderItemListResult
ORDER_BY_PRIVATENOTE - Static variable in class bb.common.QuoteListResult
ORDER_BY_PRIVATENOTES - Static variable in class bb.common.PrReceiverListResult
ORDER_BY_PRIVATENOTES - Static variable in class bb.common.TransferOrderListResult
ORDER_BY_PRIVATENOTES - Static variable in class bb.common.TransferOrderVO
ORDER_BY_PRNUMBER - Static variable in class bb.common.PrReceiverListResult
ORDER_BY_PROBLEMDESCRIPTION - Static variable in class bb.common.NcrReportListResult
ORDER_BY_PROBLEMDISPOSITION - Static variable in class bb.common.NcrReportListResult
ORDER_BY_PRODUCTCODE - Static variable in class bb.common.APItemListResult
ORDER_BY_PRODUCTCODE - Static variable in class bb.common.InventoryListResult
ORDER_BY_PRODUCTCODE - Static variable in class bb.common.InvoiceItemListResult
ORDER_BY_PRODUCTCODE - Static variable in class bb.common.PartBasicInfo
ORDER_BY_PRODUCTCODE - Static variable in class bb.common.PurchaseOrderItemListResult
ORDER_BY_PRODUCTCODE - Static variable in class bb.common.SalesOrderItemListResult
ORDER_BY_PROJECT - Static variable in class bb.common.DisassembleWorkOrderItemListResult
ORDER_BY_PROJECT - Static variable in class bb.common.DisassembleWorkOrderListResult
ORDER_BY_PROJECT - Static variable in class bb.common.NonproductivePickingItemIssuedListResult
ORDER_BY_PROJECT - Static variable in class bb.common.NonproductivePickingItemResult
ORDER_BY_PROJECT - Static variable in class bb.common.NonproductivePickingVO
ORDER_BY_PROJECT - Static variable in class bb.common.OnLoanListResult
ORDER_BY_PROJECT - Static variable in class bb.common.OnloanReceiverListResult
ORDER_BY_PROJECT - Static variable in class bb.common.OperatingInstructionsVO
ORDER_BY_project - Static variable in class bb.common.PartIssuedListResult
ORDER_BY_project - Static variable in class bb.common.PartReceivedListResult
ORDER_BY_PROJECT - Static variable in class bb.common.POStatisticsResult
ORDER_BY_PROJECT - Static variable in class bb.common.PurchaseOrderItemListResult
ORDER_BY_PROJECT - Static variable in class bb.common.PurchaseOrderListResult
ORDER_BY_PROJECT - Static variable in class bb.common.QuoteListResult
ORDER_BY_PROJECT - Static variable in class bb.common.RequestForQuoteCheckListResult
ORDER_BY_PROJECT - Static variable in class bb.common.RequestForQuoteListResult
ORDER_BY_PROJECT - Static variable in class bb.common.ReturnToVendorCheckListResult
ORDER_BY_PROJECT - Static variable in class bb.common.RMAListResult
ORDER_BY_PROJECT - Static variable in class bb.common.RMAReceiverListResult
ORDER_BY_PROJECT - Static variable in class bb.common.SalesOrderListResult
ORDER_BY_PROJECT - Static variable in class bb.common.ShipperItemListResult
ORDER_BY_PROJECT - Static variable in class bb.common.TotalAmountInPOByRefDoc
ORDER_BY_PROJECT - Static variable in class bb.common.WOReceiverDetail
ORDER_BY_PROJECT - Static variable in class bb.common.WorkOrderItemListResult
ORDER_BY_PROJECT - Static variable in class bb.common.WorkOrderListResult
ORDER_BY_PROJECTDESCRIPTION - Static variable in class bb.common.DesignControlListResult
ORDER_BY_PROJECTDESCRIPTION - Static variable in class bb.common.TotalAmountInPOByRefDoc
ORDER_BY_PROJECTENGINEER - Static variable in class bb.common.DesignControlListResult
ORDER_BY_PROJECTNAME - Static variable in class bb.common.CRTVListResult
ORDER_BY_PROJECTNAME - Static variable in class bb.common.POReceiverItemListResult
ORDER_BY_PROJECTNAME - Static variable in class bb.common.POSurveyReportVO
ORDER_BY_PROJECTNAME - Static variable in class bb.common.RRMAListResult
ORDER_BY_PROJECTNAME - Static variable in class bb.common.SalesOrderItemListResult
ORDER_BY_PROJECTNAME - Static variable in class bb.common.SwapReceiverListResult
ORDER_BY_PROJECTNAME - Static variable in class bb.common.SwapShipperListResult
ORDER_BY_PROOFREADER - Static variable in class bb.common.WorkInstructionListResult
ORDER_BY_PUBLICDOC - Static variable in class bb.common.LogPartDocumentVO
ORDER_BY_PURCHASEORDER - Static variable in class bb.common.IcrItemListResult
ORDER_BY_PURCHASEORDER - Static variable in class bb.common.IcrListResult
ORDER_BY_PURCHASEORDER - Static variable in class bb.common.InspectionConformanceReportVO
ORDER_BY_PURCHASEORDERNUMBER - Static variable in class bb.common.CustomerFeedbackVO
ORDER_BY_PURCHASEORDERNUMBER - Static variable in class bb.common.GeneralLedgerListResult
ORDER_BY_PURCHASEORDERNUMBER - Static variable in class bb.common.GeneralLedgerVO
ORDER_BY_PURCHASEORDERNUMBER - Static variable in class bb.common.GLDebitCreditListResult
ORDER_BY_PURCHASEORDERNUMBER - Static variable in class bb.common.PartCertificateListResult
ORDER_BY_PURCHASEORDERNUMBER - Static variable in class bb.common.POSurveyReportVO
ORDER_BY_PURCHASEORDERNUMBER - Static variable in class bb.common.ProformaInvoiceItemListResult
ORDER_BY_PURCHASEORDERNUMBER - Static variable in class bb.common.ReceiverInfoVO
ORDER_BY_PURCHASEORDERNUMBER - Static variable in class bb.common.TempReceiverWithoutAPInfo
ORDER_BY_PUTDATE - Static variable in class bb.common.EmployeePutGoodListResult
ORDER_BY_QAACCEPTEMPLOYEE - Static variable in class bb.common.POSurveyReportVO
ORDER_BY_QRQTY - Static variable in class bb.common.PartWithExcessiveInventoryListResult
ORDER_BY_QTBOILERPLATE - Static variable in class bb.common.QuoteBoilerplateVO
ORDER_BY_QTDATE - Static variable in class bb.common.QuoteItemListResult
ORDER_BY_QTDATE - Static variable in class bb.common.QuoteListResult
ORDER_BY_QTITEMNUMBER - Static variable in class bb.common.QuoteItemListResult
ORDER_BY_QTNUMBER - Static variable in class bb.common.QuoteItemListResult
ORDER_BY_QTNUMBER - Static variable in class bb.common.QuoteListResult
ORDER_BY_QTR1QTY - Static variable in class bb.common.HighUsagePartResult
ORDER_BY_QTR2QTY - Static variable in class bb.common.HighUsagePartResult
ORDER_BY_QTR3QTY - Static variable in class bb.common.HighUsagePartResult
ORDER_BY_QTR4QTY - Static variable in class bb.common.HighUsagePartResult
ORDER_BY_QTY - Static variable in class bb.common.DisassembleWorkOrderItemListResult
ORDER_BY_qty - Static variable in class bb.common.RtvShipperItemListResult
ORDER_BY_QTY - Static variable in class bb.common.SalesOrder12MonthMarginResult
ORDER_BY_QTY - Static variable in class bb.common.SGQuoteCartListResult
ORDER_BY_QTY - Static variable in class bb.common.WorkOrderItemListResult
ORDER_BY_QTY_SHIPPED - Static variable in class bb.common.DisassembleWorkOrderItemListResult
ORDER_BY_QTYCHECK - Static variable in class bb.common.IcrItemListResult
ORDER_BY_QTYINWIP - Static variable in class bb.common.WorkOrderItemPartDetailInWipVO
ORDER_BY_QTYISSUED - Static variable in class bb.common.NonproductivePickingItemIssuedVO
ORDER_BY_QTYK - Static variable in class bb.common.WoItemWorkInstructionListResult
ORDER_BY_QTYORDERED - Static variable in class bb.common.POReceiverItemListResult
ORDER_BY_QTYQUALIFIED - Static variable in class bb.common.IcrItemListResult
ORDER_BY_QTYRECEIVED - Static variable in class bb.common.POReceiverItemListResult
ORDER_BY_qtyShip - Static variable in class bb.common.RtvShipperItemListResult
ORDER_BY_QTYSHIPED - Static variable in class bb.common.SalesTaxListResult
ORDER_BY_QTYSHIPPED - Static variable in class bb.common.AccountsReceivableItemResult
ORDER_BY_QTYSHIPPED - Static variable in class bb.common.AccountsReceivableItemVO
ORDER_BY_QUALITYSTATUS - Static variable in class bb.common.CustomerVendorAddressInfoVO
ORDER_BY_QUALITYSTATUS - Static variable in class bb.common.LockedCustomerAddressResult
ORDER_BY_QUANTITY - Static variable in class bb.common.AssetAddOrDisposalsReport
ORDER_BY_QUANTITY - Static variable in class bb.common.AssetDepreciateDetailReport
ORDER_BY_QUANTITY - Static variable in class bb.common.AssetDepreciateVO
ORDER_BY_QUANTITY - Static variable in class bb.common.DepreciateMonthlyReport
ORDER_BY_QUANTITY - Static variable in class bb.common.InspectionReportInfoVO
ORDER_BY_QUANTITY - Static variable in class bb.common.LnShipperItemListResult
ORDER_BY_QUANTITY - Static variable in class bb.common.NonproductivePickingItemResult
ORDER_BY_QUANTITY - Static variable in class bb.common.OperatingInstructionsUserStatisticalResult
ORDER_BY_QUANTITY - Static variable in class bb.common.OperatingInstructionsVO
ORDER_BY_QUANTITY - Static variable in class bb.common.PackingBoxItemListResult
ORDER_BY_QUANTITY - Static variable in class bb.common.PartInQAVO
ORDER_BY_QUANTITY - Static variable in class bb.common.ShipperItemListResult
ORDER_BY_QUANTITY - Static variable in class bb.common.WOItemPartDetailNotIssue
ORDER_BY_QUANTITY - Static variable in class bb.common.WorkOrderItemInfoResult
ORDER_BY_QUANTITY - Static variable in class bb.common.WorkOrderItemPartDetail
ORDER_BY_QUANTITYASM - Static variable in class bb.common.WOItemPartDetailNotIssue
ORDER_BY_QUANTITYSHIP - Static variable in class bb.common.LnShipperItemListResult
ORDER_BY_QUANTITYSHIP - Static variable in class bb.common.ShipperItemListResult
ORDER_BY_QUANTITYSHIPPED - Static variable in class bb.common.SOShipperItemListResult
ORDER_BY_QUOTENUMBER - Static variable in class bb.common.SGCustRequestForQuoteListResult
ORDER_BY_RECEIVEDBY - Static variable in class bb.common.OnloanReceiverListResult
ORDER_BY_RECEIVEDBY - Static variable in class bb.common.PartInQAVO
ORDER_BY_RECEIVEDBY - Static variable in class bb.common.RMAReceiverListResult
ORDER_BY_RECEIVEDBY - Static variable in class bb.common.SwapReceiverListResult
ORDER_BY_RECEIVEDBY - Static variable in class bb.common.TempReceiverWithoutAPInfo
ORDER_BY_RECEIVEDBY - Static variable in class bb.common.TransferReceiverListResult
ORDER_BY_RECEIVEDDATE - Static variable in class bb.common.PartInQAVO
ORDER_BY_RECEIVEDDATE - Static variable in class bb.common.POReceiverItemListResult
ORDER_BY_RECEIVEDDATE - Static variable in class bb.common.SwapReceiverItemListResult
ORDER_BY_RECEIVEDDATE - Static variable in class bb.common.SwapReceiverListResult
ORDER_BY_RECEIVEDDATE - Static variable in class bb.common.TransferReceiverItemListResult
ORDER_BY_RECEIVEDDATE - Static variable in class bb.common.TransferReceiverListResult
ORDER_BY_RECEIVEDFROM - Static variable in class bb.common.PartInQAVO
ORDER_BY_RECEIVEDQTY - Static variable in class bb.common.PurchaseOrderItemListResult
ORDER_BY_RECEIVEDQTY - Static variable in class bb.common.SwapReceiverItemListResult
ORDER_BY_RECEIVEDQTY - Static variable in class bb.common.SwapShipperItemListResult
ORDER_BY_RECEIVEDQTY - Static variable in class bb.common.TransferOrderItemListResult
ORDER_BY_RECEIVEDQTY - Static variable in class bb.common.TransferReceiverItemListResult
ORDER_BY_RECEIVEDQTY - Static variable in class bb.common.TransferShipperItemListResult
ORDER_BY_RECEIVER - Static variable in class bb.common.MessageVO
ORDER_BY_RECEIVERBY - Static variable in class bb.common.OnloanReceiverItemListResult
ORDER_BY_RECEIVERBY - Static variable in class bb.common.RMAReceiverItemListResult
ORDER_BY_RECEIVERCOMMENTS - Static variable in class bb.common.TransferReceiverListResult
ORDER_BY_RECEIVERNUMBER - Static variable in class bb.common.AccountsPayableInfoVO
ORDER_BY_RECEIVERNUMBER - Static variable in class bb.common.OnloanReceiverItemListResult
ORDER_BY_RECEIVERNUMBER - Static variable in class bb.common.OnloanReceiverListResult
ORDER_BY_RECEIVERNUMBER - Static variable in class bb.common.PartCertificateListResult
ORDER_BY_RECEIVERNUMBER - Static variable in class bb.common.POReceiverItemListResult
ORDER_BY_RECEIVERNUMBER - Static variable in class bb.common.ReceiverInfoVO
ORDER_BY_RECEIVERNUMBER - Static variable in class bb.common.RMAReceiverItemListResult
ORDER_BY_RECEIVERNUMBER - Static variable in class bb.common.RMAReceiverListResult
ORDER_BY_RECEIVERNUMBER - Static variable in class bb.common.TempReceiverWithoutAPInfo
ORDER_BY_RECEIVERPRIVATENOTES - Static variable in class bb.common.TransferReceiverListResult
ORDER_BY_RECEIVESIGN - Static variable in class bb.common.CustomAssetVO
ORDER_BY_RECORDER - Static variable in class bb.common.CustomCheckUpEmployeeVO
ORDER_BY_RECORDER - Static variable in class bb.common.CustomEmployeeTrainVO
ORDER_BY_RECTIFYSIGHTLEFT - Static variable in class bb.common.CustomCheckUpEmployeeVO
ORDER_BY_RECTIFYSIGHTRIGHT - Static variable in class bb.common.CustomCheckUpEmployeeVO
ORDER_BY_REFDOC - Static variable in class bb.common.TotalAmountInPOByRefDoc
ORDER_BY_REFDOC1 - Static variable in class bb.common.JobProcessSheetListResult
ORDER_BY_REFDOC1 - Static variable in class bb.common.LogInventoryListResult
ORDER_BY_REFDOC1 - Static variable in class bb.common.LogTrackingVO
ORDER_BY_REFDOC1 - Static variable in class bb.common.TransferReceiverItemListResult
ORDER_BY_REFDOC1 - Static variable in class bb.common.TransferShipperItemListResult
ORDER_BY_REFDOC2 - Static variable in class bb.common.JobProcessSheetListResult
ORDER_BY_REFDOC2 - Static variable in class bb.common.LogInventoryListResult
ORDER_BY_REFDOC2 - Static variable in class bb.common.LogTrackingVO
ORDER_BY_REFDOC2 - Static variable in class bb.common.ReturnToVendorByDateListResult
ORDER_BY_REFDOC2 - Static variable in class bb.common.TransferReceiverItemListResult
ORDER_BY_REFDOC2 - Static variable in class bb.common.TransferShipperItemListResult
ORDER_BY_REFERENCENUMBER - Static variable in class bb.common.PartCertificateListResult
ORDER_BY_REFID - Static variable in class bb.common.BizboxUserListResult
ORDER_BY_REFID - Static variable in class bb.common.MessageVO
ORDER_BY_REFID - Static variable in class bb.common.UserRolePermissionListResult
ORDER_BY_REGINON - Static variable in class bb.common.SalesOrderItemListResult
ORDER_BY_REGION - Static variable in class bb.common.CustomerVendorAddressInfoVO
ORDER_BY_REJECTQTY - Static variable in class bb.common.InspectionReportInfoVO
ORDER_BY_REJECTREASON - Static variable in class bb.common.InspectionReportInfoVO
ORDER_BY_RELATEDDOC - Static variable in class bb.common.DisassembleWorkOrderItemListResult
ORDER_BY_RELATEDDOC - Static variable in class bb.common.PartIssuedListResult
ORDER_BY_RELATEDDOC - Static variable in class bb.common.PartReceivedListResult
ORDER_BY_RELATEDDOC - Static variable in class bb.common.POStatisticsResult
ORDER_BY_RELATEDDOC - Static variable in class bb.common.PrReceiverListResult
ORDER_BY_RELATEDDOC - Static variable in class bb.common.PurchaseOrderItemListResult
ORDER_BY_RELATEDDOC - Static variable in class bb.common.PurchaseOrderListResult
ORDER_BY_RELATEDDOC - Static variable in class bb.common.SalesOrderItemListResult
ORDER_BY_RELATEDDOC - Static variable in class bb.common.SwapReceiverListResult
ORDER_BY_RELATEDDOC - Static variable in class bb.common.SwapShipperListResult
ORDER_BY_RELATEDDOC - Static variable in class bb.common.TotalAmountInPOByRefDoc
ORDER_BY_RELATEDDOC - Static variable in class bb.common.WorkOrderItemInfoResult
ORDER_BY_RELATEDDOC - Static variable in class bb.common.WorkOrderItemInWipListResult
ORDER_BY_RELATEDDOC - Static variable in class bb.common.WorkOrderItemIssuedTotalResult
ORDER_BY_RELATEDDOC - Static variable in class bb.common.WorkOrderItemListResult
ORDER_BY_RELATEDDOC - Static variable in class bb.common.WorkOrderItemPartDetail
ORDER_BY_RELATEDDOCUMENT - Static variable in class bb.common.SalesOrderListResult
ORDER_BY_RELATEDDOCUMENT - Static variable in class bb.common.TransferOrderListResult
ORDER_BY_RELATEDDOCUMENT - Static variable in class bb.common.TransferOrderVO
ORDER_BY_RELATEDDOCUMENT - Static variable in class bb.common.TransferReceiverListResult
ORDER_BY_RELATEDDOCUMENT - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_RELATEDINSPECTORSIGN - Static variable in class bb.common.OperatingInstructionsVO
ORDER_BY_RELDOC - Static variable in class bb.common.GLDebitCreditListResult
ORDER_BY_REMARKS - Static variable in class bb.common.DocumentServerVO
ORDER_BY_REMARKS - Static variable in class bb.common.MiscDocumentSettingVO
ORDER_BY_REPORTEDBY - Static variable in class bb.common.CustomerFeedbackVO
ORDER_BY_REQUESTER - Static variable in class bb.common.PurchaseOrderItemListResult
ORDER_BY_REQUESTER - Static variable in class bb.common.PurchaseOrderListResult
ORDER_BY_REQUESTER - Static variable in class bb.common.TransferOrderListResult
ORDER_BY_REQUESTER - Static variable in class bb.common.TransferOrderVO
ORDER_BY_REQUESTINSPECTIONDATE - Static variable in class bb.common.OperatingInstructionsVO
ORDER_BY_REQUESTOR - Static variable in class bb.common.SGCustomerServiceRequestVO
ORDER_BY_REQUIREDATE - Static variable in class bb.common.SGCustomerServiceRequestVO
ORDER_BY_RESPONSIBILITY - Static variable in class bb.common.NcrNeedToScrapListResult
ORDER_BY_RESPONSIBILITY - Static variable in class bb.common.NcrReportListResult
ORDER_BY_RESPONSIBILITY - Static variable in class bb.common.OperatingInstructionsUserStatisticalResult
ORDER_BY_RESPONSIBILITY - Static variable in class bb.common.OperatingInstructionsVO
ORDER_BY_RESULT - Static variable in class bb.common.CustomEmployeeTrainVO
ORDER_BY_REVIEWDESCRIPTION - Static variable in class bb.common.WorkOrderItemReviewCostResult
ORDER_BY_REVIEWEDBY - Static variable in class bb.common.WorkOrderItemReviewCostResult
ORDER_BY_REVIEWEDDATE - Static variable in class bb.common.WorkOrderItemReviewCostResult
ORDER_BY_REVIEWLIMIT - Static variable in class bb.common.NonproductivePickingApproveVO
ORDER_BY_REVIEWLIMIT - Static variable in class bb.common.OnloanReviewVO
ORDER_BY_REVIEWLIMIT - Static variable in class bb.common.RMAReviewVO
ORDER_BY_REVIEWLIMIT - Static variable in class bb.common.SalesOrderReviewVO
ORDER_BY_REVISION - Static variable in class bb.common.LogPartDwfVO
ORDER_BY_REVISION - Static variable in class bb.common.LogPartDwgVO
ORDER_BY_REVISION - Static variable in class bb.common.PartDwfWithPartInfoResult
ORDER_BY_REVISION - Static variable in class bb.common.PartDwgWithPartInfoResult
ORDER_BY_REVISION - Static variable in class bb.common.PartOnHandWithMfgInfoResult
ORDER_BY_REVISION - Static variable in class bb.common.TransferReceiverItemListResult
ORDER_BY_REVISION - Static variable in class bb.common.TransferShipperItemListResult
ORDER_BY_REVISION - Static variable in class bb.common.WorkOrderItemTimeDetailVO
ORDER_BY_RFCNUMBER - Static variable in class bb.common.WorkInstructionRequestForChangeVO
ORDER_BY_RFQDATE - Static variable in class bb.common.RequestForQuoteCheckListResult
ORDER_BY_RFQDATE - Static variable in class bb.common.RequestForQuoteItemListResult
ORDER_BY_RFQDATE - Static variable in class bb.common.RequestForQuoteListResult
ORDER_BY_RFQITEMPK - Static variable in class bb.common.RequestForQuoteItemListResult
ORDER_BY_RFQMESSAGENUMBER - Static variable in class bb.common.RfqMessageListResult
ORDER_BY_RFQNUMBER - Static variable in class bb.common.RequestForQuoteCheckListResult
ORDER_BY_RFQNUMBER - Static variable in class bb.common.RequestForQuoteListResult
ORDER_BY_RFQNUMBER - Static variable in class bb.common.RfqMessageListResult
ORDER_BY_RIS - Static variable in class bb.common.CustomCheckUpEmployeeVO
ORDER_BY_RMADATE - Static variable in class bb.common.RMAItemListResult
ORDER_BY_RMADATE - Static variable in class bb.common.RMAListResult
ORDER_BY_RMANUMBER - Static variable in class bb.common.RMAItemListResult
ORDER_BY_RMANUMBER - Static variable in class bb.common.RMAListResult
ORDER_BY_RMANUMBER - Static variable in class bb.common.RMAReceiverItemListResult
ORDER_BY_RMANUMBER - Static variable in class bb.common.RMAReceiverListResult
ORDER_BY_ROLEID - Static variable in class bb.common.RoleListResult
ORDER_BY_ROLEID - Static variable in class bb.common.UserRolePermissionListResult
ORDER_BY_ROLENAME - Static variable in class bb.common.RoleListResult
ORDER_BY_ROLENAME - Static variable in class bb.common.UserRolePermissionListResult
ORDER_BY_ROLLUPCOST - Static variable in class bb.common.RollUpBomStdCostWorkSheetItemVO
ORDER_BY_ROLLUPCOUNT - Static variable in class bb.common.RollUpBomStdCostWorkSheetVO
ORDER_BY_RTVDATE - Static variable in class bb.common.ReturnToVendorByDateListResult
ORDER_BY_RTVDATE - Static variable in class bb.common.ReturnToVendorItemListResult
ORDER_BY_RTVITEMPK - Static variable in class bb.common.ReturnToVendorByDateListResult
ORDER_BY_RTVITEMPK - Static variable in class bb.common.ReturnToVendorItemListResult
ORDER_BY_RTVNUMBER - Static variable in class bb.common.NcrReportListResult
ORDER_BY_RTVNUMBER - Static variable in class bb.common.ReturnToVendorCheckListResult
ORDER_BY_RTVNUMBER - Static variable in class bb.common.ReturnToVendorListResult
ORDER_BY_RTVNUMBER - Static variable in class bb.common.RtvShipperInfoVO
ORDER_BY_rtvNumber - Static variable in class bb.common.RtvShipperItemListResult
ORDER_BY_RTVNUMBER - Static variable in class bb.common.RtvShipperListResult
ORDER_BY_rtvShipperItemNumber - Static variable in class bb.common.RtvShipperItemListResult
ORDER_BY_RTVSHIPPERNUMBER - Static variable in class bb.common.RtvShipperInfoVO
ORDER_BY_RTVSHIPPERNUMBER - Static variable in class bb.common.RtvShipperItemListResult
ORDER_BY_RTVSHIPPERNUMBER - Static variable in class bb.common.RtvShipperListResult
ORDER_BY_RV - Static variable in class bb.common.LogMiscDocumentVO
ORDER_BY_SALESCODEID - Static variable in class bb.common.ArCommissionListResult
ORDER_BY_SALESCODEID - Static variable in class bb.common.ArSalesCodeTotalListResult
ORDER_BY_SALESCODEID - Static variable in class bb.common.SalesCodeVO
ORDER_BY_SALESCODEID - Static variable in class bb.common.SalesOrderItemListResult
ORDER_BY_SALESCODENAME - Static variable in class bb.common.ArCommissionListResult
ORDER_BY_SALESCODENAME - Static variable in class bb.common.ArSalesCodeTotalListResult
ORDER_BY_SALESCODENAME - Static variable in class bb.common.SalesCodeVO
ORDER_BY_SALESMAN - Static variable in class bb.common.CRTVListResult
ORDER_BY_SALESMAN - Static variable in class bb.common.LnShipperListResult
ORDER_BY_SALESMAN - Static variable in class bb.common.QuoteListResult
ORDER_BY_SALESMAN - Static variable in class bb.common.RMAListResult
ORDER_BY_SALESMAN - Static variable in class bb.common.RRMAListResult
ORDER_BY_SALESMAN - Static variable in class bb.common.SalesOrderCheckListResult
ORDER_BY_SALESMAN - Static variable in class bb.common.SalesOrderItemListResult
ORDER_BY_SALESMAN - Static variable in class bb.common.SalesOrderListResult
ORDER_BY_SALESMAN - Static variable in class bb.common.ShipperListResult
ORDER_BY_SALESMANID - Static variable in class bb.common.SalesmanVO
ORDER_BY_SALESMANID - Static variable in class bb.common.SalesOrderCheckListResult
ORDER_BY_SALESNUMBER - Static variable in class bb.common.AccountReceivableInfoWithPrepayResult
ORDER_BY_SALESORDERNUMBER - Static variable in class bb.common.AccountsReceivableInfoVO
ORDER_BY_SALESORDERNUMBER - Static variable in class bb.common.ArCommissionListResult
ORDER_BY_SALESORDERNUMBER - Static variable in class bb.common.CRTVListResult
ORDER_BY_SALESORDERNUMBER - Static variable in class bb.common.CustomerServiceIncidentItemListResult
ORDER_BY_SALESORDERNUMBER - Static variable in class bb.common.GeneralLedgerListResult
ORDER_BY_SALESORDERNUMBER - Static variable in class bb.common.GeneralLedgerVO
ORDER_BY_SALESORDERNUMBER - Static variable in class bb.common.GLDebitCreditListResult
ORDER_BY_SALESORDERNUMBER - Static variable in class bb.common.InvoiceItemListResult
ORDER_BY_SALESORDERNUMBER - Static variable in class bb.common.PartCertificateListResult
ORDER_BY_SALESORDERNUMBER - Static variable in class bb.common.ProformaInvoiceItemListResult
ORDER_BY_SALESORDERNUMBER - Static variable in class bb.common.RMAItemListResult
ORDER_BY_SALESORDERNUMBER - Static variable in class bb.common.RMAListResult
ORDER_BY_SALESORDERNUMBER - Static variable in class bb.common.RRMAListResult
ORDER_BY_SALESORDERNUMBER - Static variable in class bb.common.SalesTaxListResult
ORDER_BY_SALESORDERNUMBER - Static variable in class bb.common.SGCustomerServiceRequestVO
ORDER_BY_SALESORDERNUMBER - Static variable in class bb.common.SGSaleItemVO
ORDER_BY_SALESORDERNUMBER - Static variable in class bb.common.ShipperItemListResult
ORDER_BY_SALESORDERNUMBER - Static variable in class bb.common.ShipperListResult
ORDER_BY_SALESORDERNUMBER - Static variable in class bb.common.SOShipperItemListResult
ORDER_BY_SEALWORKER - Static variable in class bb.common.InspectionReportInfoVO
ORDER_BY_SEARCHBUYER - Static variable in class bb.common.TempReceiverWithoutAPInfo
ORDER_BY_SEARCHCURRENCY - Static variable in class bb.common.TempReceiverWithoutAPInfo
ORDER_BY_SEARCHDATEFROM - Static variable in class bb.common.TempReceiverWithoutAPInfo
ORDER_BY_SEARCHDATETO - Static variable in class bb.common.TempReceiverWithoutAPInfo
ORDER_BY_SEARCHID - Static variable in class bb.common.TempReceiverWithoutAPInfo
ORDER_BY_SECURITYLEVEL - Static variable in class bb.common.EmployeeCardVO
ORDER_BY_SECURITYLEVEL - Static variable in class bb.common.PartBasicInfo
ORDER_BY_SECURITYLEVEL - Static variable in class bb.common.PartBasicInfoWithNewEngGroup
ORDER_BY_SECURITYLEVEL - Static variable in class bb.common.PartBasicInfoWithNewListPrice
ORDER_BY_SECURITYLEVEL - Static variable in class bb.common.PartOnHandWithMfgInfoResult
ORDER_BY_SECURITYLEVEL - Static variable in class bb.common.PartOnHandWithPartBasicInfoResult
ORDER_BY_SECURITYLEVEL - Static variable in class bb.common.SalesmanVO
ORDER_BY_SENDDATE - Static variable in class bb.common.MessageVO
ORDER_BY_SENDFROM - Static variable in class bb.common.MessageVO
ORDER_BY_SENDUSERNAME - Static variable in class bb.common.MessageVO
ORDER_BY_SEQNUMBER - Static variable in class bb.common.WorkCenterRunTimeListResult
ORDER_BY_SEQUENCESTATUS - Static variable in class bb.common.WorkInstructionSequenceListResult
ORDER_BY_SERIAL - Static variable in class bb.common.OperatingInstructionsVO
ORDER_BY_SERIAL - Static variable in class bb.common.SGCustomerServiceRequestVO
ORDER_BY_SERIALNO - Static variable in class bb.common.PartInQAVO
ORDER_BY_SERIALNUMBER - Static variable in class bb.common.CustomAssetVO
ORDER_BY_SERIALNUMBER - Static variable in class bb.common.InventoryNotUsedInMonthsforAppResult
ORDER_BY_SERIALNUMBER - Static variable in class bb.common.LnShipperItemListResult
ORDER_BY_SERIALNUMBER - Static variable in class bb.common.SGSaleItemVO
ORDER_BY_SERIALNUMBER - Static variable in class bb.common.ShipperItemListResult
ORDER_BY_SERIALNUMBER - Static variable in class bb.common.ToolCalibrateListResult
ORDER_BY_SERIALNUMBER - Static variable in class bb.common.WorkOrderItemTimeDetailVO
ORDER_BY_SERIALNUMBERTYPE - Static variable in class bb.common.OperatingInstructionsTypeVO
ORDER_BY_SERVER - Static variable in class bb.common.OperationLogVO
ORDER_BY_SERVERIP - Static variable in class bb.common.DocumentServerVO
ORDER_BY_SERVERIP - Static variable in class bb.common.MiscDocumentSettingVO
ORDER_BY_SERVERPORT - Static variable in class bb.common.DocumentServerVO
ORDER_BY_SERVERPORT - Static variable in class bb.common.MiscDocumentSettingVO
ORDER_BY_SERVICETYPE - Static variable in class bb.common.SGCustomerServiceRequestVO
ORDER_BY_SETID - Static variable in class bb.common.JobProcessSheetListResult
ORDER_BY_SHIPACCOUT - Static variable in class bb.common.TransferOrderListResult
ORDER_BY_SHIPACCOUT - Static variable in class bb.common.TransferOrderVO
ORDER_BY_SHIPACCOUT - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_SHIPINPROCESSQTY - Static variable in class bb.common.HistoricalInventoryVO
ORDER_BY_SHIPINPROCESSQTY - Static variable in class bb.common.PartWithSipQtyListResult
ORDER_BY_SHIPINPROCESSQTY - Static variable in class bb.common.PartWithSITQtyListResult
ORDER_BY_SHIPLIST - Static variable in class bb.common.ShipListInfoVO
ORDER_BY_SHIPPEDATE - Static variable in class bb.common.SwapShipperItemListResult
ORDER_BY_SHIPPEDBY - Static variable in class bb.common.RtvShipperListResult
ORDER_BY_SHIPPEDBY - Static variable in class bb.common.SwapShipperListResult
ORDER_BY_SHIPPEDBY - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_SHIPPEDDATE - Static variable in class bb.common.RtvShipperListResult
ORDER_BY_SHIPPEDDATE - Static variable in class bb.common.SwapShipperListResult
ORDER_BY_SHIPPEDDATE - Static variable in class bb.common.TransferShipperItemListResult
ORDER_BY_SHIPPEDDATE - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_SHIPPEDQTY - Static variable in class bb.common.SalesOrderItemGroupByPartListResult
ORDER_BY_SHIPPEDQTY - Static variable in class bb.common.SwapReceiverItemListResult
ORDER_BY_SHIPPEDQTY - Static variable in class bb.common.SwapShipperItemListResult
ORDER_BY_SHIPPEDQTY - Static variable in class bb.common.TransferOrderItemListResult
ORDER_BY_SHIPPEDQTY - Static variable in class bb.common.TransferReceiverItemListResult
ORDER_BY_SHIPPEDQTY - Static variable in class bb.common.TransferShipperItemListResult
ORDER_BY_SHIPPERCOMMENTS - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_SHIPPERDATE - Static variable in class bb.common.ShipperListResult
ORDER_BY_SHIPPERITEMPK - Static variable in class bb.common.SOShipperItemListResult
ORDER_BY_SHIPPERNUMBER - Static variable in class bb.common.AccountsReceivableInfoVO
ORDER_BY_SHIPPERNUMBER - Static variable in class bb.common.CustomerServiceIncidentItemListResult
ORDER_BY_SHIPPERNUMBER - Static variable in class bb.common.InvoiceItemListResult
ORDER_BY_SHIPPERNUMBER - Static variable in class bb.common.ShipperItemListResult
ORDER_BY_SHIPPERNUMBER - Static variable in class bb.common.ShipperListResult
ORDER_BY_SHIPPERPRIVATENOTES - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_SHIPPINGSTATUS - Static variable in class bb.common.PurchaseOrderOpenDueListResult
ORDER_BY_SHIPPINGWEIGHT - Static variable in class bb.common.InventoryMonthReport
ORDER_BY_SHIPPINGWEIGHT - Static variable in class bb.common.PartOnhandResult
ORDER_BY_SHIPPINGWEIGHTUNIT - Static variable in class bb.common.InventoryMonthReport
ORDER_BY_SHIPTO - Static variable in class bb.common.AccountsReceivableInfoVO
ORDER_BY_SHIPTO - Static variable in class bb.common.PurchaseOrderItemListResult
ORDER_BY_SHIPTOCOUNTRY - Static variable in class bb.common.InvoiceItemListResult
ORDER_BY_SHIPTOID - Static variable in class bb.common.CustomerFeedbackVO
ORDER_BY_SHIPTOID - Static variable in class bb.common.InvoiceItemListResult
ORDER_BY_SHIPTOID - Static variable in class bb.common.ProformaInvoiceListResult
ORDER_BY_SHIPTOID - Static variable in class bb.common.RtvShipperListResult
ORDER_BY_SHIPTOSTATE - Static variable in class bb.common.InvoiceItemListResult
ORDER_BY_SHIPVIA - Static variable in class bb.common.OnLoanItemListResult
ORDER_BY_SHIPVIA - Static variable in class bb.common.PurchaseOrderOpenDueListResult
ORDER_BY_SHIPVIA - Static variable in class bb.common.RtvShipperListResult
ORDER_BY_SHIPVIA - Static variable in class bb.common.SalesOrderItemListResult
ORDER_BY_SHIPVIA - Static variable in class bb.common.SwapReceiverListResult
ORDER_BY_SHIPVIA - Static variable in class bb.common.SwapShipperListResult
ORDER_BY_SHIPVIA - Static variable in class bb.common.TransferOrderListResult
ORDER_BY_SHIPVIA - Static variable in class bb.common.TransferOrderVO
ORDER_BY_SHIPVIA - Static variable in class bb.common.TransferReceiverItemListResult
ORDER_BY_SHIPVIA - Static variable in class bb.common.TransferReceiverListResult
ORDER_BY_SHIPVIA - Static variable in class bb.common.TransferShipperItemListResult
ORDER_BY_SHIPVIA - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_SHORTAGE - Static variable in class bb.common.InventoryListResult
ORDER_BY_SOBOILERPLATE - Static variable in class bb.common.SalesOrderBoilerplateVO
ORDER_BY_SODATE - Static variable in class bb.common.SalesOrderCheckListResult
ORDER_BY_SODATE - Static variable in class bb.common.SalesOrderItemListResult
ORDER_BY_SODATE - Static variable in class bb.common.SalesOrderListResult
ORDER_BY_SONUMBER - Static variable in class bb.common.ARPaymentRunListResult
ORDER_BY_SONUMBER - Static variable in class bb.common.ArPrepayVO
ORDER_BY_SONUMBER - Static variable in class bb.common.GeneralLedgerByDateListResult
ORDER_BY_SONUMBER - Static variable in class bb.common.NcrReportListResult
ORDER_BY_SONUMBER - Static variable in class bb.common.SalesOrderCheckListResult
ORDER_BY_SONUMBER - Static variable in class bb.common.SalesOrderItemListResult
ORDER_BY_SONUMBER - Static variable in class bb.common.SalesOrderListResult
ORDER_BY_SOQUANTITY - Static variable in class bb.common.SOShipperItemListResult
ORDER_BY_SOURCE - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_spaceHomePage - Static variable in class bb.common.HelpServerVO
ORDER_BY_SPAREPART - Static variable in class bb.common.BillLogVO
ORDER_BY_SPEAKER - Static variable in class bb.common.CustomEmployeeTrainVO
ORDER_BY_SPECIALTITLE - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_SPECIALTY - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_SPECIALWORK - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_SPECIFICATIONID - Static variable in class bb.common.PartTraceableResult
ORDER_BY_SRNUMBER - Static variable in class bb.common.POSurveyReportVO
ORDER_BY_STAFF - Static variable in class bb.common.OperatingInstructionsUserStatisticalResult
ORDER_BY_STAFF - Static variable in class bb.common.OperatingInstructionsVO
ORDER_BY_STAFFSIGN - Static variable in class bb.common.OperatingInstructionsVO
ORDER_BY_STANDARDCOST - Static variable in class bb.common.InventoryListResult
ORDER_BY_STANDARDCOST - Static variable in class bb.common.InventoryNotUsedInMonthsforAppResult
ORDER_BY_STANDARDCOST - Static variable in class bb.common.InventoryNotUsedInMonthsResult
ORDER_BY_STANDARDCOST - Static variable in class bb.common.PartCostVarianceListResult
ORDER_BY_STANDARDCOST - Static variable in class bb.common.PartOnHandWithMfgInfoResult
ORDER_BY_STANDARDCOST - Static variable in class bb.common.POReceiverItemListResult
ORDER_BY_STARTAMOUNT - Static variable in class bb.common.InventoryMonthReport
ORDER_BY_STARTCOST - Static variable in class bb.common.InventoryMonthReport
ORDER_BY_STARTDATE - Static variable in class bb.common.ContractPriceVO
ORDER_BY_STARTDATE - Static variable in class bb.common.CycleCountListResult
ORDER_BY_STARTDATE - Static variable in class bb.common.DisassembleWorkOrderItemListResult
ORDER_BY_STARTDATE - Static variable in class bb.common.EmployeeCardVO
ORDER_BY_STARTDATE - Static variable in class bb.common.FiscalYearSettingsVO
ORDER_BY_STARTDATE - Static variable in class bb.common.LogTaskVO
ORDER_BY_STARTDATE - Static variable in class bb.common.OperatingInstructionsUserStatisticalResult
ORDER_BY_STARTDATE - Static variable in class bb.common.OperatingInstructionsVO
ORDER_BY_STARTDATE - Static variable in class bb.common.PhysicalInventoryListResult
ORDER_BY_STARTDATE - Static variable in class bb.common.RollUpBomStdCostWorkSheetVO
ORDER_BY_STARTDATE - Static variable in class bb.common.SalesmanVO
ORDER_BY_STARTDATE - Static variable in class bb.common.VendorContractPriceVO
ORDER_BY_STARTDATE - Static variable in class bb.common.WOItemPartDetailNotIssue
ORDER_BY_STARTDATE - Static variable in class bb.common.WorkOrderItemCanAssyResult
ORDER_BY_STARTDATE - Static variable in class bb.common.WorkOrderItemListResult
ORDER_BY_STARTDATE - Static variable in class bb.common.WorkOrderItemReviewCostResult
ORDER_BY_STARTDATE - Static variable in class bb.common.WorkOrderItemToIssueResult
ORDER_BY_STARTQAAMOUNT - Static variable in class bb.common.InventoryMonthReport
ORDER_BY_STARTQAQTY - Static variable in class bb.common.InventoryMonthReport
ORDER_BY_STARTQTY - Static variable in class bb.common.InventoryMonthReport
ORDER_BY_STARTWIPAMOUNT - Static variable in class bb.common.InventoryMonthReport
ORDER_BY_STARTWIPQTY - Static variable in class bb.common.InventoryMonthReport
ORDER_BY_STATE - Static variable in class bb.common.CustomerVendorAddressInfoVO
ORDER_BY_STATE - Static variable in class bb.common.LockedCustomerAddressResult
ORDER_BY_STATE - Static variable in class bb.common.ManufacturerAddressInfoVO
ORDER_BY_STATE - Static variable in class bb.common.SalesMarginListResult
ORDER_BY_STATE - Static variable in class bb.common.SGCustRequestForQuoteListResult
ORDER_BY_STATURE - Static variable in class bb.common.CustomCheckUpEmployeeVO
ORDER_BY_STATUS - Static variable in class bb.common.AccountPayableCheckRunVO
ORDER_BY_STATUS - Static variable in class bb.common.AccountsPayableInfoVO
ORDER_BY_STATUS - Static variable in class bb.common.AccountsReceivableInfoVO
ORDER_BY_STATUS - Static variable in class bb.common.APAgingItemListResult
ORDER_BY_STATUS - Static variable in class bb.common.APItemListResult
ORDER_BY_STATUS - Static variable in class bb.common.ARPaymentRunVO
ORDER_BY_STATUS - Static variable in class bb.common.BillWithPartInfoResult
ORDER_BY_STATUS - Static variable in class bb.common.BizboxUserListResult
ORDER_BY_STATUS - Static variable in class bb.common.BizboxUserVO
ORDER_BY_STATUS - Static variable in class bb.common.ChangeStdCostWorkSheetVO
ORDER_BY_STATUS - Static variable in class bb.common.ContractPriceVO
ORDER_BY_STATUS - Static variable in class bb.common.CorrectiveActionRequestVO
ORDER_BY_STATUS - Static variable in class bb.common.CustomerFeedbackVO
ORDER_BY_STATUS - Static variable in class bb.common.DesignControlListResult
ORDER_BY_STATUS - Static variable in class bb.common.DisassembleWorkOrderItemListResult
ORDER_BY_STATUS - Static variable in class bb.common.DisassembleWorkOrderListResult
ORDER_BY_STATUS - Static variable in class bb.common.EmployeeCardVO
ORDER_BY_STATUS - Static variable in class bb.common.EngineeringChangeListResult
ORDER_BY_STATUS - Static variable in class bb.common.EngineeringChangeRequestListResult
ORDER_BY_STATUS - Static variable in class bb.common.ExpenseListResult
ORDER_BY_STATUS - Static variable in class bb.common.FiscalYearSettingsVO
ORDER_BY_STATUS - Static variable in class bb.common.IcrItemListResult
ORDER_BY_STATUS - Static variable in class bb.common.IcrListResult
ORDER_BY_STATUS - Static variable in class bb.common.InspectionConformanceReportVO
ORDER_BY_STATUS - Static variable in class bb.common.JobProcessSheetListResult
ORDER_BY_STATUS - Static variable in class bb.common.LnShipperItemListResult
ORDER_BY_STATUS - Static variable in class bb.common.LnShipperListResult
ORDER_BY_STATUS - Static variable in class bb.common.NcrNeedToScrapListResult
ORDER_BY_STATUS - Static variable in class bb.common.NcrReportListResult
ORDER_BY_STATUS - Static variable in class bb.common.OnLoanItemListResult
ORDER_BY_STATUS - Static variable in class bb.common.OnLoanListResult
ORDER_BY_STATUS - Static variable in class bb.common.OnloanReceiverItemListResult
ORDER_BY_STATUS - Static variable in class bb.common.OnloanReceiverListResult
ORDER_BY_STATUS - Static variable in class bb.common.OperatingInstructionsUserStatisticalResult
ORDER_BY_STATUS - Static variable in class bb.common.OperatingInstructionsVO
ORDER_BY_STATUS - Static variable in class bb.common.PackingBoxItemListResult
ORDER_BY_STATUS - Static variable in class bb.common.PhysicalInventoryStatusVO
ORDER_BY_STATUS - Static variable in class bb.common.PoMessageListResult
ORDER_BY_STATUS - Static variable in class bb.common.POReceiverItemListResult
ORDER_BY_STATUS - Static variable in class bb.common.PreventiveActionRequestVO
ORDER_BY_STATUS - Static variable in class bb.common.ProformaInvoiceItemListResult
ORDER_BY_STATUS - Static variable in class bb.common.ProformaInvoiceListResult
ORDER_BY_STATUS - Static variable in class bb.common.PrReceiverListResult
ORDER_BY_STATUS - Static variable in class bb.common.QuoteItemListResult
ORDER_BY_STATUS - Static variable in class bb.common.QuoteListResult
ORDER_BY_STATUS - Static variable in class bb.common.RequestForQuoteCheckListResult
ORDER_BY_STATUS - Static variable in class bb.common.RequestForQuoteListResult
ORDER_BY_STATUS - Static variable in class bb.common.ReturnToVendorByDateListResult
ORDER_BY_STATUS - Static variable in class bb.common.ReturnToVendorCheckListResult
ORDER_BY_STATUS - Static variable in class bb.common.ReturnToVendorItemListResult
ORDER_BY_STATUS - Static variable in class bb.common.RMAItemListResult
ORDER_BY_STATUS - Static variable in class bb.common.RMAListResult
ORDER_BY_STATUS - Static variable in class bb.common.RMAReceiverItemListResult
ORDER_BY_STATUS - Static variable in class bb.common.RMAReceiverListResult
ORDER_BY_STATUS - Static variable in class bb.common.RollUpBomStdCostWorkSheetVO
ORDER_BY_STATUS - Static variable in class bb.common.RtvShipperInfoVO
ORDER_BY_status - Static variable in class bb.common.RtvShipperItemListResult
ORDER_BY_STATUS - Static variable in class bb.common.RtvShipperListResult
ORDER_BY_STATUS - Static variable in class bb.common.SalesmanVO
ORDER_BY_STATUS - Static variable in class bb.common.SalesOrderCheckListResult
ORDER_BY_STATUS - Static variable in class bb.common.SalesOrderItemListResult
ORDER_BY_STATUS - Static variable in class bb.common.SalesOrderListResult
ORDER_BY_STATUS - Static variable in class bb.common.SalesOrderShipDateListResult
ORDER_BY_STATUS - Static variable in class bb.common.SGCustomerServiceRequestVO
ORDER_BY_STATUS - Static variable in class bb.common.ShipListInfoVO
ORDER_BY_STATUS - Static variable in class bb.common.ShipperItemListResult
ORDER_BY_STATUS - Static variable in class bb.common.ShipperListResult
ORDER_BY_STATUS - Static variable in class bb.common.SOShipperItemListResult
ORDER_BY_STATUS - Static variable in class bb.common.SwapReceiverItemListResult
ORDER_BY_STATUS - Static variable in class bb.common.SwapReceiverListResult
ORDER_BY_STATUS - Static variable in class bb.common.SwapShipperItemListResult
ORDER_BY_STATUS - Static variable in class bb.common.SwapShipperListResult
ORDER_BY_STATUS - Static variable in class bb.common.TempReceiverWithoutAPInfo
ORDER_BY_STATUS - Static variable in class bb.common.ToolCalibrateListResult
ORDER_BY_STATUS - Static variable in class bb.common.ToolCalibrationVO
ORDER_BY_STATUS - Static variable in class bb.common.TransferOrderItemListResult
ORDER_BY_STATUS - Static variable in class bb.common.TransferOrderListResult
ORDER_BY_STATUS - Static variable in class bb.common.TransferOrderVO
ORDER_BY_STATUS - Static variable in class bb.common.TransferReceiverItemListResult
ORDER_BY_STATUS - Static variable in class bb.common.TransferReceiverListResult
ORDER_BY_STATUS - Static variable in class bb.common.TransferShipperItemListResult
ORDER_BY_STATUS - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_STATUS - Static variable in class bb.common.VendorContractPriceVO
ORDER_BY_STATUS - Static variable in class bb.common.WorkInstructionListResult
ORDER_BY_STATUS - Static variable in class bb.common.WorkInstructionRequestForChangeVO
ORDER_BY_STATUS - Static variable in class bb.common.WorkOrderItemListResult
ORDER_BY_STATUS - Static variable in class bb.common.WorkOrderItemPartDetail
ORDER_BY_STATUS - Static variable in class bb.common.WorkOrderItemReviewCostResult
ORDER_BY_STATUS - Static variable in class bb.common.WorkOrderListResult
ORDER_BY_STDCOST - Static variable in class bb.common.AccountsReceivableItemResult
ORDER_BY_STDCOST - Static variable in class bb.common.AccountsReceivableItemVO
ORDER_BY_STDCOST - Static variable in class bb.common.ChangeStdCostWorkSheetItemVO
ORDER_BY_STDCOST - Static variable in class bb.common.NonproductivePickingItemIssuedListResult
ORDER_BY_STDCOST - Static variable in class bb.common.PartBasicInfoWithNewEngGroup
ORDER_BY_STDCOST - Static variable in class bb.common.PartBasicInfoWithNewListPrice
ORDER_BY_STDCOST - Static variable in class bb.common.PartWithExcessiveInventoryListResult
ORDER_BY_STDCOST - Static variable in class bb.common.PartWithOnLoanQtyListResult
ORDER_BY_STDCOST - Static variable in class bb.common.PartWithQAQtyListResult
ORDER_BY_STDCOST - Static variable in class bb.common.PartWithQtyListResult
ORDER_BY_STDCOST - Static variable in class bb.common.PartWithSipQtyListResult
ORDER_BY_STDCOST - Static variable in class bb.common.PartWithSITQtyListResult
ORDER_BY_STDCOST - Static variable in class bb.common.PartWithSTOQtyListResult
ORDER_BY_STDCOST - Static variable in class bb.common.PartWithWipQtyListResult
ORDER_BY_STDCOST - Static variable in class bb.common.RollUpBomStdCostWorkSheetItemVO
ORDER_BY_STDCOST - Static variable in class bb.common.SwapReceiverItemListResult
ORDER_BY_STDCOST - Static variable in class bb.common.SwapShipperItemListResult
ORDER_BY_STDCOST - Static variable in class bb.common.TransferOrderItemListResult
ORDER_BY_STDCOST - Static variable in class bb.common.TransferReceiverItemListResult
ORDER_BY_STDCOST - Static variable in class bb.common.TransferShipperItemListResult
ORDER_BY_STDCOST - Static variable in class bb.common.WOItemPartDetailNotIssue
ORDER_BY_STDCOST - Static variable in class bb.common.WorkOrderItemInWipListResult
ORDER_BY_STDCOST - Static variable in class bb.common.WorkOrderItemListResult
ORDER_BY_STDCOST - Static variable in class bb.common.WorkOrderItemPartDetailInWipVO
ORDER_BY_STOCKMONTH - Static variable in class bb.common.InventoryNotUsedInMonthsforAppResult
ORDER_BY_SUBDISCOUNTTOTAL - Static variable in class bb.common.ArCommissionListResult
ORDER_BY_SUBJECT - Static variable in class bb.common.MessageVO
ORDER_BY_SUBNETTOTAL - Static variable in class bb.common.ArCommissionListResult
ORDER_BY_SUBNETTOTAL - Static variable in class bb.common.SalesTaxListResult
ORDER_BY_SUBTOTAL - Static variable in class bb.common.AccountsReceivableItemResult
ORDER_BY_SUBTOTAL - Static variable in class bb.common.ArSalesCodeTotalListResult
ORDER_BY_SUBTOTAL - Static variable in class bb.common.RequestForQuoteItemListResult
ORDER_BY_SUBTOTAL - Static variable in class bb.common.TempReceiverWithoutAPInfo
ORDER_BY_SUBTOTAL - Static variable in class bb.common.VendorTotalAmountInPO
ORDER_BY_SUBUNITTOTAL - Static variable in class bb.common.ArCommissionListResult
ORDER_BY_SUMMARY - Static variable in class bb.common.TermsConditionVO
ORDER_BY_SWAPORDERNUMBER - Static variable in class bb.common.SwapReceiverItemListResult
ORDER_BY_SWAPORDERNUMBER - Static variable in class bb.common.SwapReceiverListResult
ORDER_BY_SWAPORDERNUMBER - Static variable in class bb.common.SwapShipperItemListResult
ORDER_BY_SWAPORDERNUMBER - Static variable in class bb.common.SwapShipperListResult
ORDER_BY_SWAPQTY - Static variable in class bb.common.SwapReceiverItemListResult
ORDER_BY_SWAPQTY - Static variable in class bb.common.SwapShipperItemListResult
ORDER_BY_SWAPRECEIVERITEMNUMBER - Static variable in class bb.common.SwapReceiverItemListResult
ORDER_BY_SWAPRECEIVERNUMBER - Static variable in class bb.common.SwapReceiverItemListResult
ORDER_BY_SWAPRECEIVERNUMBER - Static variable in class bb.common.SwapReceiverListResult
ORDER_BY_SWAPSHIPPERITEMNUMBER - Static variable in class bb.common.SwapShipperItemListResult
ORDER_BY_SWAPSHIPPERNUMBER - Static variable in class bb.common.SwapReceiverItemListResult
ORDER_BY_SWAPSHIPPERNUMBER - Static variable in class bb.common.SwapReceiverListResult
ORDER_BY_SWAPSHIPPERNUMBER - Static variable in class bb.common.SwapShipperItemListResult
ORDER_BY_SWAPSHIPPERNUMBER - Static variable in class bb.common.SwapShipperListResult
ORDER_BY_SWOITEMNUMBER - Static variable in class bb.common.SwapOrderItemListResult
ORDER_BY_SYSTEM - Static variable in class bb.common.OperationLogVO
ORDER_BY_SYSTEMONHAND - Static variable in class bb.common.CycleCountListResult
ORDER_BY_SYSTEMONHAND - Static variable in class bb.common.PhysicalInventoryListResult
ORDER_BY_SYSTEMUSERNAME - Static variable in class bb.common.BizBoxUserEmployeeResult
ORDER_BY_SYSTEMUSERNAME - Static variable in class bb.common.BizboxUserListResult
ORDER_BY_SYSTEMUSERNAME - Static variable in class bb.common.NoticeUserEmployeeListResult
ORDER_BY_TAGNUMBER - Static variable in class bb.common.PhysicalInventoryListResult
ORDER_BY_TARGET - Static variable in class bb.common.OperationLogVO
ORDER_BY_TAX - Static variable in class bb.common.PosZipCodeTaxVO
ORDER_BY_TAX - Static variable in class bb.common.SalesTaxListResult
ORDER_BY_TAXRATE - Static variable in class bb.common.POReceiverItemListResult
ORDER_BY_TAXRATE - Static variable in class bb.common.ReturnToVendorByDateListResult
ORDER_BY_TAXTOTAL - Static variable in class bb.common.ArCommissionListResult
ORDER_BY_TAXTOTAL - Static variable in class bb.common.ArSalesCodeTotalListResult
ORDER_BY_TECHNOLGYSTANDARD - Static variable in class bb.common.PartInspectionVO
ORDER_BY_TERMINATEDDATE - Static variable in class bb.common.EmployeeCardVO
ORDER_BY_TERMS - Static variable in class bb.common.CustomerStatementTotalResult
ORDER_BY_TERMS - Static variable in class bb.common.TransferOrderListResult
ORDER_BY_TERMS - Static variable in class bb.common.TransferOrderVO
ORDER_BY_TERMS - Static variable in class bb.common.TransferReceiverListResult
ORDER_BY_TERMS - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_TERMVALUE - Static variable in class bb.common.TermVO
ORDER_BY_TERRITORY - Static variable in class bb.common.SalesOrderItemListResult
ORDER_BY_TIMEOFF - Static variable in class bb.common.WorkOrderItemTimeDetailVO
ORDER_BY_TIMEON - Static variable in class bb.common.WorkOrderItemTimeDetailVO
ORDER_BY_TITLE - Static variable in class bb.common.CustomEmployeeTrainVO
ORDER_BY_TOADDRESSID - Static variable in class bb.common.TransferOrderListResult
ORDER_BY_TOADDRESSID - Static variable in class bb.common.TransferOrderVO
ORDER_BY_TOADDRESSID - Static variable in class bb.common.TransferReceiverItemListResult
ORDER_BY_TOADDRESSID - Static variable in class bb.common.TransferReceiverListResult
ORDER_BY_TOADDRESSID - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_TOADDRESSNAME - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_TOBEASM - Static variable in class bb.common.WorkOrderItemListResult
ORDER_BY_TOCOMPANYTIME - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_TOLOCATION - Static variable in class bb.common.TransferOrderItemListResult
ORDER_BY_TOPOSITIONTIME - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_TOTAL - Static variable in class bb.common.InventoryNotUsedInMonthsforAppResult
ORDER_BY_TOTALAVGCOST - Static variable in class bb.common.PartWithOnLoanQtyListResult
ORDER_BY_TOTALBALANCE - Static variable in class bb.common.CustomerStatementTotalResult
ORDER_BY_TOTALCOST - Static variable in class bb.common.SalesMarginListResult
ORDER_BY_TOTALCOST - Static variable in class bb.common.TransferOrderListResult
ORDER_BY_TOTALCOST - Static variable in class bb.common.TransferOrderVO
ORDER_BY_TOTALCOST - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_TOTALDISCOUNT - Static variable in class bb.common.VendorTotalAmountInPO
ORDER_BY_TOTALDUE - Static variable in class bb.common.CustomerStatementListResult
ORDER_BY_TOTALDUE - Static variable in class bb.common.VendorStatementListResult
ORDER_BY_TOTALFREIGHT - Static variable in class bb.common.POStatisticsResult
ORDER_BY_TOTALFREIGHT - Static variable in class bb.common.VendorTotalAmountInPO
ORDER_BY_TOTALMARGIN - Static variable in class bb.common.SalesMarginListResult
ORDER_BY_TOTALNET - Static variable in class bb.common.SalesMarginListResult
ORDER_BY_TOTALOPEN - Static variable in class bb.common.VendorTotalAmountInPO
ORDER_BY_TOTALPAGES - Static variable in class bb.common.PhysicalInventoryStatusVO
ORDER_BY_TOTALRECEIVED - Static variable in class bb.common.VendorTotalAmountInPO
ORDER_BY_TOTALSALES - Static variable in class bb.common.SalesMarginListResult
ORDER_BY_TOTALSTDCOST - Static variable in class bb.common.PartWithOnLoanQtyListResult
ORDER_BY_TOTALTAX - Static variable in class bb.common.POStatisticsResult
ORDER_BY_TOTALTAX - Static variable in class bb.common.VendorTotalAmountInPO
ORDER_BY_TOTALWIREFEE - Static variable in class bb.common.ARPaymentRunVO
ORDER_BY_TRACEABLELEVEL - Static variable in class bb.common.PartTraceableResult
ORDER_BY_TRACKING - Static variable in class bb.common.SwapReceiverListResult
ORDER_BY_TRACKING - Static variable in class bb.common.SwapShipperListResult
ORDER_BY_TRACKING - Static variable in class bb.common.TransferReceiverListResult
ORDER_BY_TRACKING - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_TRACKINGNUMBER - Static variable in class bb.common.LogTrackingVO
ORDER_BY_TRAINDATE - Static variable in class bb.common.CustomEmployeeTrainVO
ORDER_BY_TRANSACTIONDATE - Static variable in class bb.common.AccountPayableCheckRunVO
ORDER_BY_TRANSACTIONDATE - Static variable in class bb.common.AccountsCreditDebitListResult
ORDER_BY_TRANSACTIONDATE - Static variable in class bb.common.ARPaymentRunVO
ORDER_BY_TRANSACTIONDATE - Static variable in class bb.common.GeneralLedgerByDateListResult
ORDER_BY_TRANSACTIONDATE - Static variable in class bb.common.GeneralLedgerListResult
ORDER_BY_TRANSACTIONDATE - Static variable in class bb.common.GeneralLedgerVO
ORDER_BY_TRANSACTIONDATE - Static variable in class bb.common.GLDebitCreditListResult
ORDER_BY_TRANSACTIONNO - Static variable in class bb.common.AccountsCreditDebitListResult
ORDER_BY_TRANSACTIONNUMBER - Static variable in class bb.common.ApCheckRunListResult
ORDER_BY_TRANSACTIONNUMBER - Static variable in class bb.common.ARPaymentRunListResult
ORDER_BY_TRANSACTIONNUMBER - Static variable in class bb.common.ChangeStdCostWorkSheetVO
ORDER_BY_TRANSACTIONNUMBER - Static variable in class bb.common.GeneralLedgerListResult
ORDER_BY_TRANSACTIONNUMBER - Static variable in class bb.common.GeneralLedgerVO
ORDER_BY_TRANSACTIONNUMBER - Static variable in class bb.common.GLDebitCreditListResult
ORDER_BY_TRANSACTIONNUMBER - Static variable in class bb.common.NonproductivePickingItemIssuedVO
ORDER_BY_TRANSACTIONNUMBER - Static variable in class bb.common.PartIssuedListResult
ORDER_BY_TRANSACTIONNUMBER - Static variable in class bb.common.PartIssuedVO
ORDER_BY_TRANSACTIONNUMBER - Static variable in class bb.common.PartReceivedVO
ORDER_BY_TRANSACTIONNUMBER - Static variable in class bb.common.RollUpBomStdCostWorkSheetVO
ORDER_BY_TRANSACTIONNUMBER - Static variable in class bb.common.WorkOrderItemPartDetailInWipVO
ORDER_BY_TRANSACTIONTYPE - Static variable in class bb.common.AccountsCreditDebitListResult
ORDER_BY_TRANSACTIONTYPE - Static variable in class bb.common.GeneralLedgerListResult
ORDER_BY_TRANSACTIONTYPE - Static variable in class bb.common.GeneralLedgerVO
ORDER_BY_TRANSACTIONTYPE - Static variable in class bb.common.GLDebitCreditListResult
ORDER_BY_TRANSFERDATE - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_TRANSFERORDERDATE - Static variable in class bb.common.TransferOrderListResult
ORDER_BY_TRANSFERORDERDATE - Static variable in class bb.common.TransferOrderVO
ORDER_BY_TRANSFERORDERITEMNUMBER - Static variable in class bb.common.TransferOrderItemListResult
ORDER_BY_TRANSFERORDERNUMBER - Static variable in class bb.common.TransferOrderItemListResult
ORDER_BY_TRANSFERORDERNUMBER - Static variable in class bb.common.TransferOrderListResult
ORDER_BY_TRANSFERORDERNUMBER - Static variable in class bb.common.TransferOrderVO
ORDER_BY_TRANSFERORDERNUMBER - Static variable in class bb.common.TransferReceiverListResult
ORDER_BY_TRANSFERORDERNUMBER - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_TRANSFERQTY - Static variable in class bb.common.TransferOrderItemListResult
ORDER_BY_TRANSFERQTY - Static variable in class bb.common.TransferReceiverItemListResult
ORDER_BY_TRANSFERQTY - Static variable in class bb.common.TransferShipperItemListResult
ORDER_BY_TRANSFERRECEIVERITEMNUMBER - Static variable in class bb.common.TransferReceiverItemListResult
ORDER_BY_TRANSFERRECEIVERNUMBER - Static variable in class bb.common.TransferReceiverItemListResult
ORDER_BY_TRANSFERRECEIVERNUMBER - Static variable in class bb.common.TransferReceiverListResult
ORDER_BY_TRANSFERSHIPPERITEMNUMBER - Static variable in class bb.common.TransferShipperItemListResult
ORDER_BY_TRANSFERSHIPPERNUMBER - Static variable in class bb.common.TransferReceiverListResult
ORDER_BY_TRANSFERSHIPPERNUMBER - Static variable in class bb.common.TransferShipperItemListResult
ORDER_BY_TRANSFERSHIPPERNUMBER - Static variable in class bb.common.TransferShipperListResult
ORDER_BY_TRUENAME - Static variable in class bb.common.OperationLogVO
ORDER_BY_TYPE - Static variable in class bb.common.BizBoxUserEmployeeResult
ORDER_BY_TYPE - Static variable in class bb.common.BizboxUserListResult
ORDER_BY_TYPE - Static variable in class bb.common.CompanyUnitVO
ORDER_BY_TYPE - Static variable in class bb.common.EquipmentListResult
ORDER_BY_TYPE - Static variable in class bb.common.OperationLogVO
ORDER_BY_UNIT - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_UNIT - Static variable in class bb.common.CustomGoodsBreedVO
ORDER_BY_UNIT - Static variable in class bb.common.InventoryNotUsedInMonthsforAppResult
ORDER_BY_UNIT - Static variable in class bb.common.NonproductivePickingItemIssuedVO
ORDER_BY_UNIT - Static variable in class bb.common.NonproductivePickingItemResult
ORDER_BY_UNIT - Static variable in class bb.common.PartInspectionVO
ORDER_BY_UNIT - Static variable in class bb.common.PartWithInventoryInfoListResult
ORDER_BY_UNIT - Static variable in class bb.common.SGQuoteCartListResult
ORDER_BY_UNIT - Static variable in class bb.common.TransferReceiverItemListResult
ORDER_BY_UNIT - Static variable in class bb.common.TransferShipperItemListResult
ORDER_BY_UNIT - Static variable in class bb.common.WorkOrderItemPartDetail
ORDER_BY_UNITNAME - Static variable in class bb.common.UnitVO
ORDER_BY_USEAVGCOSTTOROLLUP - Static variable in class bb.common.RollUpBomStdCostWorkSheetVO
ORDER_BY_USEREMAIL - Static variable in class bb.common.SGCustRequestForQuoteListResult
ORDER_BY_USERNAME - Static variable in class bb.common.AccountingInfoDocumentVO
ORDER_BY_USERNAME - Static variable in class bb.common.BizBoxUserEmployeeResult
ORDER_BY_USERNAME - Static variable in class bb.common.BizboxUserListResult
ORDER_BY_USERNAME - Static variable in class bb.common.BizboxUserVO
ORDER_BY_USERNAME - Static variable in class bb.common.BomApprovalVO
ORDER_BY_USERNAME - Static variable in class bb.common.DocumentServerVO
ORDER_BY_USERNAME - Static variable in class bb.common.ECNReviewVO
ORDER_BY_USERNAME - Static variable in class bb.common.ECRReviewVO
ORDER_BY_USERNAME - Static variable in class bb.common.EmployeeCardVO
ORDER_BY_USERNAME - Static variable in class bb.common.EngGroupUserVO
ORDER_BY_USERNAME - Static variable in class bb.common.ExpenseListResult
ORDER_BY_USERNAME - Static variable in class bb.common.GeneralLedgerApprovalVO
ORDER_BY_USERNAME - Static variable in class bb.common.MiscDocumentSettingVO
ORDER_BY_USERNAME - Static variable in class bb.common.NcrApprovalVO
ORDER_BY_USERNAME - Static variable in class bb.common.NonproductivePickingApprovalVO
ORDER_BY_USERNAME - Static variable in class bb.common.NonproductivePickingApproveVO
ORDER_BY_USERNAME - Static variable in class bb.common.NoticeUserEmployeeListResult
ORDER_BY_USERNAME - Static variable in class bb.common.OnloanReviewVO
ORDER_BY_USERNAME - Static variable in class bb.common.OperationLogVO
ORDER_BY_USERNAME - Static variable in class bb.common.PurchaseOrderApprovalVO
ORDER_BY_USERNAME - Static variable in class bb.common.RMAReviewVO
ORDER_BY_USERNAME - Static variable in class bb.common.RTVApprovalVO
ORDER_BY_USERNAME - Static variable in class bb.common.SalesmanVO
ORDER_BY_USERNAME - Static variable in class bb.common.SalesOrderReviewVO
ORDER_BY_USERNAME - Static variable in class bb.common.SwapOrderApprovalVO
ORDER_BY_USERNAME - Static variable in class bb.common.TransferOrderApprovalVO
ORDER_BY_USERNAME - Static variable in class bb.common.UserRolePermissionListResult
ORDER_BY_USERNAME - Static variable in class bb.common.WorkOrderApprovalVO
ORDER_BY_USETYPE - Static variable in class bb.common.PartUseTypeVO
ORDER_BY_USINGDATE - Static variable in class bb.common.CustomAssetVO
ORDER_BY_USINGSTATUS - Static variable in class bb.common.AssetDepreciateVO
ORDER_BY_USINGSTATUS - Static variable in class bb.common.DepreciateMonthlyReport
ORDER_BY_VALIDDATE - Static variable in class bb.common.CustomerVendorAddressInfoVO
ORDER_BY_VALIDTHRU - Static variable in class bb.common.QuoteListResult
ORDER_BY_VARIANCE - Static variable in class bb.common.PartCostVarianceListResult
ORDER_BY_VARIANCEAMOUNT - Static variable in class bb.common.ChangeStdCostWorkSheetVO
ORDER_BY_VARIANCEAMOUNT - Static variable in class bb.common.RollUpBomStdCostWorkSheetVO
ORDER_BY_VARIANCECOUNT - Static variable in class bb.common.RollUpBomStdCostWorkSheetVO
ORDER_BY_VARIANCEPERCENT - Static variable in class bb.common.ChangeStdCostWorkSheetItemVO
ORDER_BY_VARIANCEPERCENT - Static variable in class bb.common.PartCostVarianceListResult
ORDER_BY_VENDORADDRESSINFO - Static variable in class bb.common.ReceiverInfoVO
ORDER_BY_VENDORCATEGORY - Static variable in class bb.common.CustomerVendorAddressInfoVO
ORDER_BY_VENDORCATEGORY - Static variable in class bb.common.LockedCustomerAddressResult
ORDER_BY_VENDORCATEGORY - Static variable in class bb.common.VendorCategoriesVO
ORDER_BY_VENDORFLAG - Static variable in class bb.common.CustomerVendorAddressInfoVO
ORDER_BY_VENDORFLAG - Static variable in class bb.common.LockedCustomerAddressResult
ORDER_BY_VENDORID - Static variable in class bb.common.AccountPayableCheckVO
ORDER_BY_VENDORID - Static variable in class bb.common.AccountsPayableInfoVO
ORDER_BY_VENDORID - Static variable in class bb.common.APAgingItemListResult
ORDER_BY_VENDORID - Static variable in class bb.common.APAuditListResult
ORDER_BY_VENDORID - Static variable in class bb.common.ApCheckRunListResult
ORDER_BY_VENDORID - Static variable in class bb.common.APItemListResult
ORDER_BY_VENDORID - Static variable in class bb.common.ApPrepayVO
ORDER_BY_VENDORID - Static variable in class bb.common.APTaxForZipcodeListResult
ORDER_BY_VENDORID - Static variable in class bb.common.DisassembleWorkOrderItemListResult
ORDER_BY_VENDORID - Static variable in class bb.common.DisassembleWorkOrderListResult
ORDER_BY_VENDORID - Static variable in class bb.common.DWOIssueDetail
ORDER_BY_VENDORID - Static variable in class bb.common.EcnPOOrderResult
ORDER_BY_VENDORID - Static variable in class bb.common.EcnWOOrderResult
ORDER_BY_VENDORID - Static variable in class bb.common.IcrItemListResult
ORDER_BY_VENDORID - Static variable in class bb.common.IcrListResult
ORDER_BY_VENDORID - Static variable in class bb.common.InspectionConformanceReportVO
ORDER_BY_VENDORID - Static variable in class bb.common.NcrReportListResult
ORDER_BY_VENDORID - Static variable in class bb.common.NonConformanceReportVO
ORDER_BY_VENDORID - Static variable in class bb.common.PartInWipForIDListResult
ORDER_BY_VENDORID - Static variable in class bb.common.PartIssuedListResult
ORDER_BY_VENDORID - Static variable in class bb.common.PartIssuedVO
ORDER_BY_VENDORID - Static variable in class bb.common.PartReceivedListResult
ORDER_BY_VENDORID - Static variable in class bb.common.PartReceivedVO
ORDER_BY_VENDORID - Static variable in class bb.common.PoMessageListResult
ORDER_BY_VENDORID - Static variable in class bb.common.POReceiverItemListResult
ORDER_BY_VENDORID - Static variable in class bb.common.POStatisticsResult
ORDER_BY_VENDORID - Static variable in class bb.common.POSurveyReportVO
ORDER_BY_VENDORID - Static variable in class bb.common.PrReceiverListResult
ORDER_BY_VENDORID - Static variable in class bb.common.PurchaseOrderCheckListResult
ORDER_BY_VENDORID - Static variable in class bb.common.PurchaseOrderItemListResult
ORDER_BY_VENDORID - Static variable in class bb.common.PurchaseOrderListResult
ORDER_BY_VENDORID - Static variable in class bb.common.PurchaseOrderOpenDueListResult
ORDER_BY_VENDORID - Static variable in class bb.common.ReceiverInfoVO
ORDER_BY_VENDORID - Static variable in class bb.common.RequestForQuoteCheckListResult
ORDER_BY_VENDORID - Static variable in class bb.common.RequestForQuoteItemListResult
ORDER_BY_VENDORID - Static variable in class bb.common.RequestForQuoteListResult
ORDER_BY_VENDORID - Static variable in class bb.common.ReturnToVendorByDateListResult
ORDER_BY_VENDORID - Static variable in class bb.common.ReturnToVendorCheckListResult
ORDER_BY_VENDORID - Static variable in class bb.common.ReturnToVendorItemListResult
ORDER_BY_VENDORID - Static variable in class bb.common.ReturnToVendorListResult
ORDER_BY_VENDORID - Static variable in class bb.common.RfqMessageListResult
ORDER_BY_VENDORID - Static variable in class bb.common.RtvShipperInfoVO
ORDER_BY_vendorId - Static variable in class bb.common.RtvShipperItemListResult
ORDER_BY_VENDORID - Static variable in class bb.common.RtvShipperListResult
ORDER_BY_VENDORID - Static variable in class bb.common.SwapReceiverListResult
ORDER_BY_VENDORID - Static variable in class bb.common.SwapShipperListResult
ORDER_BY_VENDORID - Static variable in class bb.common.TempReceiverWithoutAPInfo
ORDER_BY_VENDORID - Static variable in class bb.common.VendorTotalAmountInPO
ORDER_BY_VENDORID - Static variable in class bb.common.WOReceiverDetail
ORDER_BY_VENDORID - Static variable in class bb.common.WorkCenterRunTimeListResult
ORDER_BY_VENDORID - Static variable in class bb.common.WorkOrderCheckListResult
ORDER_BY_VENDORID - Static variable in class bb.common.WorkOrderItemLaborCostListResult
ORDER_BY_VENDORID - Static variable in class bb.common.WorkOrderItemListResult
ORDER_BY_VENDORID - Static variable in class bb.common.WorkOrderItemReviewCostResult
ORDER_BY_VENDORID - Static variable in class bb.common.WorkOrderItemTimeDetailVO
ORDER_BY_VENDORID - Static variable in class bb.common.WorkOrderItemToIssueResult
ORDER_BY_VENDORID - Static variable in class bb.common.WorkOrderListResult
ORDER_BY_VENDORID - Static variable in class bb.common.WorkOrderOverIssueListResult
ORDER_BY_VENDORID - Static variable in class bb.common.WorkOrderTimeCardVO
ORDER_BY_VENDORINVOICE - Static variable in class bb.common.AccountsPayableInfoVO
ORDER_BY_VENDORINVOICE - Static variable in class bb.common.APItemListResult
ORDER_BY_VENDORINVOICE - Static variable in class bb.common.GeneralLedgerByDateListResult
ORDER_BY_VENDORINVOICE - Static variable in class bb.common.GeneralLedgerListResult
ORDER_BY_VENDORINVOICE - Static variable in class bb.common.GLDebitCreditListResult
ORDER_BY_VENDORINVOICE - Static variable in class bb.common.TempArApAgingVO
ORDER_BY_VENDORINVOICE - Static variable in class bb.common.VendorStatementListResult
ORDER_BY_VENDORINVOICEDATE - Static variable in class bb.common.AccountsPayableInfoVO
ORDER_BY_VENDORINVOICEDATE - Static variable in class bb.common.APAgingItemListResult
ORDER_BY_VENDORINVOICEDATE - Static variable in class bb.common.APItemListResult
ORDER_BY_VENDORNAME - Static variable in class bb.common.ApCheckRunListResult
ORDER_BY_VENDORNAME - Static variable in class bb.common.APTaxForZipcodeListResult
ORDER_BY_VENDORNAME - Static variable in class bb.common.DisassembleWorkOrderListResult
ORDER_BY_VENDORNAME - Static variable in class bb.common.IcrItemListResult
ORDER_BY_VENDORNAME - Static variable in class bb.common.IcrListResult
ORDER_BY_VENDORNAME - Static variable in class bb.common.POStatisticsResult
ORDER_BY_VENDORNAME - Static variable in class bb.common.POSurveyReportVO
ORDER_BY_VENDORNAME - Static variable in class bb.common.PrReceiverListResult
ORDER_BY_VENDORNAME - Static variable in class bb.common.PurchaseOrderListResult
ORDER_BY_VENDORNAME - Static variable in class bb.common.RequestForQuoteItemListResult
ORDER_BY_VENDORNAME - Static variable in class bb.common.ReturnToVendorItemListResult
ORDER_BY_VENDORNAME - Static variable in class bb.common.SwapReceiverListResult
ORDER_BY_VENDORNAME - Static variable in class bb.common.SwapShipperListResult
ORDER_BY_VENDORNAME - Static variable in class bb.common.TempReceiverWithoutAPInfo
ORDER_BY_VENDORNAME - Static variable in class bb.common.WorkOrderListResult
ORDER_BY_VENDORPACKAGE - Static variable in class bb.common.AccountsPayableInfoVO
ORDER_BY_VENDORPACKAGE - Static variable in class bb.common.POReceiverItemListResult
ORDER_BY_VENDORPURCHASES - Static variable in class bb.common.PaymentHistoryVO
ORDER_BY_VENDORSALESORDER - Static variable in class bb.common.POStatisticsResult
ORDER_BY_VENDORSALESORDER - Static variable in class bb.common.POSurveyReportVO
ORDER_BY_VENDORSHIPDATE - Static variable in class bb.common.POReceiverItemListResult
ORDER_BY_VENDORSHIPDATE - Static variable in class bb.common.ReceiverInfoVO
ORDER_BY_VENDORSO - Static variable in class bb.common.PrReceiverListResult
ORDER_BY_VENDORTOTAL - Static variable in class bb.common.AccountsPayableInfoVO
ORDER_BY_WANIP - Static variable in class bb.common.LogPartDocumentVO
ORDER_BY_WANIP - Static variable in class bb.common.LogPartDwfVO
ORDER_BY_WANIP - Static variable in class bb.common.LogPartDwgVO
ORDER_BY_WANIP - Static variable in class bb.common.OperationLogVO
ORDER_BY_WAREACCEPTEMPLOYEE - Static variable in class bb.common.POSurveyReportVO
ORDER_BY_WAREHOUSEPREFIX - Static variable in class bb.common.WarehouseVO
ORDER_BY_WEIGHT - Static variable in class bb.common.PartBasicInfo
ORDER_BY_WEIGHT - Static variable in class bb.common.PartBasicInfoWithNewEngGroup
ORDER_BY_WEIGHT - Static variable in class bb.common.PartBasicInfoWithNewListPrice
ORDER_BY_WEIGHT - Static variable in class bb.common.PartOnHandWithMfgInfoResult
ORDER_BY_WEIGHT - Static variable in class bb.common.PartOnHandWithPartBasicInfoResult
ORDER_BY_WEIGHT - Static variable in class bb.common.PartWithoutLocateResult
ORDER_BY_WEIGHT - Static variable in class bb.common.SGQuoteCartListResult
ORDER_BY_WEIGHTUNIT - Static variable in class bb.common.SGQuoteCartListResult
ORDER_BY_weightUnitName - Static variable in class bb.common.WeightUnitVO
ORDER_BY_WIDESCRIPTION - Static variable in class bb.common.WorkInstructionListResult
ORDER_BY_WIDTH - Static variable in class bb.common.LabelTemplateVO
ORDER_BY_wikiSpaceName - Static variable in class bb.common.HelpServerVO
ORDER_BY_WIREFEEACCOUNT - Static variable in class bb.common.ARPaymentRunVO
ORDER_BY_WIREFEEAPNUMBER - Static variable in class bb.common.ARPaymentRunVO
ORDER_BY_WISEQPK - Static variable in class bb.common.WorkInstructionSeqAuditListResult
ORDER_BY_WISEQUENCE - Static variable in class bb.common.WorkInstructionRequestForChangeVO
ORDER_BY_WISEQUENCENUMBER - Static variable in class bb.common.WorkInstructionSequenceListResult
ORDER_BY_WOBOILERPLATE - Static variable in class bb.common.WorkOrderBoilerplateVO
ORDER_BY_WODATE - Static variable in class bb.common.WorkOrderCheckListResult
ORDER_BY_WOIQQUANTITY - Static variable in class bb.common.WOItemPartDetailNotIssue
ORDER_BY_WOISCOST - Static variable in class bb.common.WorkOrderItemPartDetailInWipVO
ORDER_BY_WOISSTDCOST - Static variable in class bb.common.WorkOrderItemPartDetailInWipVO
ORDER_BY_WOITEMITEMPK - Static variable in class bb.common.JobProcessSheetListResult
ORDER_BY_WOITEMPK - Static variable in class bb.common.WorkOrderItemPartDetail
ORDER_BY_WONUMBER - Static variable in class bb.common.NcrReportListResult
ORDER_BY_WONUMBER - Static variable in class bb.common.WorkOrderCheckListResult
ORDER_BY_WONUMBER - Static variable in class bb.common.WorkOrderListResult
ORDER_BY_WORKCENTER - Static variable in class bb.common.WorkCenterRunTimeListResult
ORDER_BY_WORKCENTER - Static variable in class bb.common.WorkInstructionSeqAuditListResult
ORDER_BY_WORKCENTER - Static variable in class bb.common.WorkInstructionSequenceListResult
ORDER_BY_WORKCENTER - Static variable in class bb.common.WorkOrderItemTimeDetailVO
ORDER_BY_WORKCENTER - Static variable in class bb.common.WorkOrderTimeCardVO
ORDER_BY_WORKCENTERID - Static variable in class bb.common.EquipmentListResult
ORDER_BY_WORKCENTERID - Static variable in class bb.common.WorkCenterGroupItemVO
ORDER_BY_WORKCENTERID - Static variable in class bb.common.WorkCenterVO
ORDER_BY_WORKCENTERID - Static variable in class bb.common.WorkInstructionRequestForChangeVO
ORDER_BY_WORKCENTERID - Static variable in class bb.common.WorkOrderItemLaborCostListResult
ORDER_BY_WORKINPROCESSQTY - Static variable in class bb.common.HistoricalInventoryVO
ORDER_BY_WORKINPROCESSQTY - Static variable in class bb.common.PhysicalInventoryListResult
ORDER_BY_WORKINSCTRUCTIONSEQUENCE - Static variable in class bb.common.WorkOrderTimeCardVO
ORDER_BY_WORKINSTRUCTIONREV - Static variable in class bb.common.WorkInstructionSequenceListResult
ORDER_BY_WORKORDER - Static variable in class bb.common.IcrItemListResult
ORDER_BY_WORKORDER - Static variable in class bb.common.IcrListResult
ORDER_BY_WORKORDER - Static variable in class bb.common.InspectionConformanceReportVO
ORDER_BY_WORKORDERANDITEMNUMBER - Static variable in class bb.common.OperatingInstructionsVO
ORDER_BY_WORKORDERITEMNUMBER - Static variable in class bb.common.WOItemPartDetailNotIssue
ORDER_BY_WORKORDERITEMNUMBER - Static variable in class bb.common.WoItemWorkInstructionListResult
ORDER_BY_WORKORDERITEMNUMBER - Static variable in class bb.common.WOReceiverDetail
ORDER_BY_WORKORDERITEMNUMBER - Static variable in class bb.common.WorkCenterRunTimeListResult
ORDER_BY_WORKORDERITEMNUMBER - Static variable in class bb.common.WorkOrderItemInfoResult
ORDER_BY_WORKORDERITEMNUMBER - Static variable in class bb.common.WorkOrderItemIssuedTotalResult
ORDER_BY_WORKORDERITEMNUMBER - Static variable in class bb.common.WorkOrderItemLaborCostListResult
ORDER_BY_WORKORDERITEMNUMBER - Static variable in class bb.common.WorkOrderItemListResult
ORDER_BY_WORKORDERITEMNUMBER - Static variable in class bb.common.WorkOrderTimeCardVO
ORDER_BY_WORKORDERITEMNUMBER - Static variable in class bb.common.WorkOrderWorkInstructionListResult
ORDER_BY_WORKORDERNUMBER - Static variable in class bb.common.CustomerServiceIncidentItemListResult
ORDER_BY_WORKORDERNUMBER - Static variable in class bb.common.NonproductivePickingItemIssuedListResult
ORDER_BY_WORKORDERNUMBER - Static variable in class bb.common.PartCertificateListResult
ORDER_BY_WORKORDERNUMBER - Static variable in class bb.common.PartInWipForIDListResult
ORDER_BY_WORKORDERNUMBER - Static variable in class bb.common.PartIssuedListResult
ORDER_BY_WORKORDERNUMBER - Static variable in class bb.common.PartIssuedVO
ORDER_BY_WORKORDERNUMBER - Static variable in class bb.common.PartReceivedListResult
ORDER_BY_WORKORDERNUMBER - Static variable in class bb.common.PartReceivedVO
ORDER_BY_WORKORDERNUMBER - Static variable in class bb.common.SGSaleItemVO
ORDER_BY_WORKORDERNUMBER - Static variable in class bb.common.WOItemPartDetailNotIssue
ORDER_BY_WORKORDERNUMBER - Static variable in class bb.common.WoItemWorkInstructionListResult
ORDER_BY_WORKORDERNUMBER - Static variable in class bb.common.WOReceiverDetail
ORDER_BY_WORKORDERNUMBER - Static variable in class bb.common.WorkCenterRunTimeListResult
ORDER_BY_WORKORDERNUMBER - Static variable in class bb.common.WorkOrderItemInfoResult
ORDER_BY_WORKORDERNUMBER - Static variable in class bb.common.WorkOrderItemInWipListResult
ORDER_BY_WORKORDERNUMBER - Static variable in class bb.common.WorkOrderItemIssuedTotalResult
ORDER_BY_WORKORDERNUMBER - Static variable in class bb.common.WorkOrderItemLaborCostListResult
ORDER_BY_WORKORDERNUMBER - Static variable in class bb.common.WorkOrderItemListResult
ORDER_BY_WORKORDERNUMBER - Static variable in class bb.common.WorkOrderItemPartDetailInWipVO
ORDER_BY_WORKORDERNUMBER - Static variable in class bb.common.WorkOrderItemTimeDetailVO
ORDER_BY_WORKORDERNUMBER - Static variable in class bb.common.WorkOrderOverIssueListResult
ORDER_BY_WORKORDERNUMBER - Static variable in class bb.common.WorkOrderTimeCardVO
ORDER_BY_WORKORDERNUMBER - Static variable in class bb.common.WorkOrderWorkInstructionListResult
ORDER_BY_WORKSHEETNUMBER - Static variable in class bb.common.PhysicalInventoryStatusVO
ORDER_BY_WORKTIME - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_WORKTYPE - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_WORKTYPEAFTER - Static variable in class bb.common.CustomEmployeeVO
ORDER_BY_YEARCODE - Static variable in class bb.common.AccountingInfoDocumentVO
ORDER_BY_YRQTY - Static variable in class bb.common.PartWithExcessiveInventoryListResult
ORDER_BY_YTRQTY - Static variable in class bb.common.HighUsagePartResult
ORDER_BY_ZIP - Static variable in class bb.common.CustomerVendorAddressInfoVO
ORDER_BY_ZIP - Static variable in class bb.common.LockedCustomerAddressResult
ORDER_BY_ZIP - Static variable in class bb.common.ManufacturerAddressInfoVO
ORDER_BY_ZIPCODE - Static variable in class bb.common.APTaxForZipcodeListResult
ORDER_BY_ZIPCODE - Static variable in class bb.common.ARTaxForZipcodeListResult
ORDER_BY_ZIPCODE - Static variable in class bb.common.PosZipCodeTaxVO
ORDER_BY_ZIPTO - Static variable in class bb.common.ZipCodeTaxVO
ORDER_CAN_NOT_LINK_TO_ITSELF - Static variable in class bb.common.BIZReason
ORDER_HAS_BEEN_CLOSED_ENTRY - Static variable in class bb.common.BIZReason
ORDER_IS_HOLD - Static variable in class bb.common.BIZReason
ORDER_NOT_IN_MY_PRINTLIST - Static variable in class bb.common.BIZReason
ORDER_WAS_CHANGED - Static variable in class bb.common.BIZReason
OrderApprovalItemsVO - Class in bb.common
OrderApprovalItemsVO() - Constructor for class bb.common.OrderApprovalItemsVO
OrderApprovalVO - Class in bb.common
OrderApproval generated by MyEclipse Persistence Tools
OrderApprovalVO() - Constructor for class bb.common.OrderApprovalVO
OrderBoilerplatePK - Class in bb.common
OrderBoilerplatePK(String, Byte) - Constructor for class bb.common.OrderBoilerplatePK
full constructor
OrderBoilerplatePK() - Constructor for class bb.common.OrderBoilerplatePK
default constructor
OrderBoilerplateVO - Class in bb.common
OrderBoilerplateVO() - Constructor for class bb.common.OrderBoilerplateVO
default constructor
OrderBy - Class in bb.common
OrderBy() - Constructor for class bb.common.OrderBy
OrderDemandForReceiverResult - Class in bb.common
OrderDemandForReceiverResult() - Constructor for class bb.common.OrderDemandForReceiverResult
OrderDocumentVO - Class in bb.common
OrderDocumentVO() - Constructor for class bb.common.OrderDocumentVO
OrderPK - Class in bb.common
OrderPK(String, String) - Constructor for class bb.common.OrderPK
OrderVendorItem - Class in bb.common
OrderVendorItem() - Constructor for class bb.common.OrderVendorItem
organizations - Static variable in class bb.common.Configure.Organization
ORIGINALARRIVALDATE - Static variable in class bb.common.Constant.DateType
ORIGINALSHIPDATE - Static variable in class bb.common.Constant.DateType
OTHER - Static variable in class bb.common.Constant.ChartOfAccountSubType
Other - Static variable in class bb.common.Constant.IssuedFrom
OTHER_PEOPLE_IS_RECEIVING_PLEASE_TRY_AGAIN - Static variable in class bb.common.BIZReason
OTHER_PEOPLE_IS_RUNNING_AUDIT_ONDEMAND_PLEASE_TRY_AGAIN_LATER - Static variable in class bb.common.BIZReason
OTHER_PEOPLE_IS_RUNNING_MRP_PLEASE_TRY_AGAIN_LATER - Static variable in class bb.common.BIZReason
Outer - Static variable in class bb.common.Constant.TransferType
OutputValueByMonthResult - Class in bb.common
OutputValueByMonthResult() - Constructor for class bb.common.OutputValueByMonthResult
OUTSIDE_COMPANY_EMPLOYID_MUST_BE_NULL - Static variable in class bb.common.BIZReason
OUTSIDE_DAMAGE_NOTICE - Static variable in class bb.common.Constant.ReceiveCondition
OUTSOURCING - Static variable in class bb.common.Constant.WorkCenterType
OVER_CARRY_PROFIT_AND_LOSS_APPROVED_BY_BY_CAN_NOT_BE_EMPTY - Static variable in class bb.common.BIZReason
OVER_CARRY_PROFIT_AND_LOSS_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY - Static variable in class bb.common.BIZReason
OVERCARRY - Static variable in class bb.common.Constant.GLApprovedType
overCarryingChangeStdCostWorkSheet(Long) - Method in interface bb.common.box.AccountingBox
overCarryingRollUpBomStdCostWorkSheet(Long) - Method in interface bb.common.box.AccountingBox
overCarryProfitAndLoss(String, String, Date, String) - Method in interface bb.common.box.AccountingBox
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M N O P Q R S T U V W X Y Z


OIPrincipalVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OIPrincipalVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.OIPrincipalVO
All Implemented Interfaces:
java.io.Serializable
public class OIPrincipalVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
OIPrincipalVO()
Method Summary
int | getId()
java.lang.String | getItemPrincipal()
java.lang.String | getQCPrincipal()
void | setId(int id)
void | setItemPrincipal(java.lang.String itemPrincipal)
void | setQCPrincipal(java.lang.String principal)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OIPrincipalVO

public OIPrincipalVO()
Method Detail

getId

public int getId()

setId

public void setId(int id)

getItemPrincipal

public java.lang.String getItemPrincipal()

setItemPrincipal

public void setItemPrincipal(java.lang.String itemPrincipal)

getQCPrincipal

public java.lang.String getQCPrincipal()

setQCPrincipal

public void setQCPrincipal(java.lang.String principal)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OnhandQualityResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OnhandQualityResult

java.lang.Object
    extended by  bb.common.OnhandQualityResult
All Implemented Interfaces:
java.io.Serializable
public class OnhandQualityResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
OnhandQualityResult()
OnhandQualityResult(java.lang.String project)
OnhandQualityResult(java.lang.String project, int line, java.math.BigDecimal total)
Method Summary
int | getLine()
java.util.HashMap<java.lang.String,java.math.BigDecimal> | getMap()
java.lang.String | getProject()
java.math.BigDecimal | getTotal()
void | setLine(int line)
void | setMap(java.util.HashMap<java.lang.String,java.math.BigDecimal> map)
void | setProject(java.lang.String project)
void | setTotal(java.math.BigDecimal total)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OnhandQualityResult

public OnhandQualityResult()

OnhandQualityResult

public OnhandQualityResult(java.lang.String project)

OnhandQualityResult

public OnhandQualityResult(java.lang.String project,
                           int line,
                           java.math.BigDecimal total)
Method Detail

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

getLine

public int getLine()

setLine

public void setLine(int line)

getTotal

public java.math.BigDecimal getTotal()

setTotal

public void setTotal(java.math.BigDecimal total)

getMap

public java.util.HashMap<java.lang.String,java.math.BigDecimal> getMap()

setMap

public void setMap(java.util.HashMap<java.lang.String,java.math.BigDecimal> map)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OnloanDocumentVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OnloanDocumentVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.OnloanDocumentVO
All Implemented Interfaces:
java.io.Serializable
public class OnloanDocumentVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
OnloanDocumentVO()
Method Summary
java.lang.String | getComments()
java.lang.String | getDocDescription()
java.lang.String | getDocFileName()
long | getDocLength()
java.util.Date | getDocumentDate()
java.lang.String | getExtension()
java.lang.Long | getIi()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getOnloanNumber()
void | setComments(java.lang.String comments)
void | setDocDescription(java.lang.String docDescription)
void | setDocFileName(java.lang.String docFileName)
void | setDocLength(long docLength)
void | setDocumentDate(java.util.Date documentDate)
void | setExtension(java.lang.String extension)
void | setIi(java.lang.Long ii)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setOnloanNumber(java.lang.String onloanNumber)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OnloanDocumentVO

public OnloanDocumentVO()
Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getDocDescription

public java.lang.String getDocDescription()

setDocDescription

public void setDocDescription(java.lang.String docDescription)

getDocumentDate

public java.util.Date getDocumentDate()

setDocumentDate

public void setDocumentDate(java.util.Date documentDate)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

getDocFileName

public java.lang.String getDocFileName()

setDocFileName

public void setDocFileName(java.lang.String docFileName)

getDocLength

public long getDocLength()

setDocLength

public void setDocLength(long docLength)

getOnloanNumber

public java.lang.String getOnloanNumber()

setOnloanNumber

public void setOnloanNumber(java.lang.String onloanNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OnLoanItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OnLoanItemListResult

java.lang.Object
    extended by  bb.common.OnLoanItemListResult
All Implemented Interfaces:
java.io.Serializable
public class OnLoanItemListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_CUSTOMERPO
static java.lang.String | ORDER_BY_DELIVERYDATE
static java.lang.String | ORDER_BY_LOANDATE
static java.lang.String | ORDER_BY_LOANITEMNUMBER
static java.lang.String | ORDER_BY_LOANNUMBER
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_SHIPVIA
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
OnLoanItemListResult()
Method Summary
java.lang.String | getCustomerId()
java.lang.String | getCustomerPo()
java.util.Date | getDeliveryDate()
java.math.BigDecimal | getDiscount()
java.lang.String | getItemDescription()
java.util.Date | getLoanDate()
java.lang.String | getLoanItemNumber()
java.lang.String | getLoanNumber()
java.math.BigDecimal | getLoanQty()
java.math.BigDecimal | getOnDemandQty()
java.math.BigDecimal | getOnhandQty()
java.math.BigDecimal | getOnorderQty()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.math.BigDecimal | getPricePerUnit()
java.math.BigDecimal | getReceivedQty()
java.math.BigDecimal | getShippedQty()
java.lang.String | getShipVia()
java.lang.String | getStatus()
void | setCustomerId(java.lang.String customerId)
void | setCustomerPo(java.lang.String customerPo)
void | setDeliveryDate(java.util.Date deliveryDate)
void | setDiscount(java.math.BigDecimal discount)
void | setItemDescription(java.lang.String itemDescription)
void | setLoanDate(java.util.Date loanDate)
void | setLoanItemNumber(java.lang.String loanItemNumber)
void | setLoanNumber(java.lang.String loanNumber)
void | setLoanQty(java.math.BigDecimal loanQty)
void | setOnDemandQty(java.math.BigDecimal onDemandQty)
void | setOnhandQty(java.math.BigDecimal onhandQty)
void | setOnorderQty(java.math.BigDecimal onorderQty)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setPricePerUnit(java.math.BigDecimal pricePerUnit)
void | setReceivedQty(java.math.BigDecimal receivedQty)
void | setShippedQty(java.math.BigDecimal shippedQty)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_LOANNUMBER

public static final java.lang.String ORDER_BY_LOANNUMBER
See Also:
Constant Field Values

ORDER_BY_LOANITEMNUMBER

public static final java.lang.String ORDER_BY_LOANITEMNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_LOANDATE

public static final java.lang.String ORDER_BY_LOANDATE
See Also:
Constant Field Values

ORDER_BY_DELIVERYDATE

public static final java.lang.String ORDER_BY_DELIVERYDATE
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_CUSTOMERPO

public static final java.lang.String ORDER_BY_CUSTOMERPO
See Also:
Constant Field Values

ORDER_BY_SHIPVIA

public static final java.lang.String ORDER_BY_SHIPVIA
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values
Constructor Detail

OnLoanItemListResult

public OnLoanItemListResult()
Method Detail

getOnDemandQty

public java.math.BigDecimal getOnDemandQty()

getOnorderQty

public java.math.BigDecimal getOnorderQty()

getOnhandQty

public java.math.BigDecimal getOnhandQty()

getStatus

public java.lang.String getStatus()

getShipVia

public java.lang.String getShipVia()

getCustomerPo

public java.lang.String getCustomerPo()

getCustomerId

public java.lang.String getCustomerId()

getDiscount

public java.math.BigDecimal getDiscount()

getPricePerUnit

public java.math.BigDecimal getPricePerUnit()

getShippedQty

public java.math.BigDecimal getShippedQty()

getDeliveryDate

public java.util.Date getDeliveryDate()

getItemDescription

public java.lang.String getItemDescription()

getPartPk

public PartPK getPartPk()

setOnDemandQty

public void setOnDemandQty(java.math.BigDecimal onDemandQty)

setOnorderQty

public void setOnorderQty(java.math.BigDecimal onorderQty)

setOnhandQty

public void setOnhandQty(java.math.BigDecimal onhandQty)

setStatus

public void setStatus(java.lang.String status)

setShipVia

public void setShipVia(java.lang.String shipVia)

setCustomerPo

public void setCustomerPo(java.lang.String customerPo)

setCustomerId

public void setCustomerId(java.lang.String customerId)

setDiscount

public void setDiscount(java.math.BigDecimal discount)

setPricePerUnit

public void setPricePerUnit(java.math.BigDecimal pricePerUnit)

setShippedQty

public void setShippedQty(java.math.BigDecimal shippedQty)

setDeliveryDate

public void setDeliveryDate(java.util.Date deliveryDate)

setItemDescription

public void setItemDescription(java.lang.String itemDescription)

setPartPk

public void setPartPk(PartPK partPk)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setLoanNumber

public void setLoanNumber(java.lang.String loanNumber)

setLoanItemNumber

public void setLoanItemNumber(java.lang.String loanItemNumber)

setReceivedQty

public void setReceivedQty(java.math.BigDecimal receivedQty)

setLoanQty

public void setLoanQty(java.math.BigDecimal loanQty)

setLoanDate

public void setLoanDate(java.util.Date loanDate)

getPartFrom

public java.lang.String getPartFrom()

getLoanNumber

public java.lang.String getLoanNumber()

getLoanItemNumber

public java.lang.String getLoanItemNumber()

getReceivedQty

public java.math.BigDecimal getReceivedQty()

getLoanQty

public java.math.BigDecimal getLoanQty()

getLoanDate

public java.util.Date getLoanDate()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OnLoanItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OnLoanItemPK

java.lang.Object
    extended by  bb.common.OnLoanItemPK
All Implemented Interfaces:
java.io.Serializable
public class OnLoanItemPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
OnLoanItemPK()
default constructor
OnLoanItemPK(java.lang.String loanNumber, java.lang.String loanItemNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getLoanItemNumber()
java.lang.String | getLoanNumber()
int | hashCode()
void | setLoanItemNumber(java.lang.String loanItemNumber)
void | setLoanNumber(java.lang.String loanNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

OnLoanItemPK

public OnLoanItemPK(java.lang.String loanNumber,
                    java.lang.String loanItemNumber)
full constructor

OnLoanItemPK

public OnLoanItemPK()
default constructor

Method Detail

getLoanNumber

public java.lang.String getLoanNumber()

setLoanNumber

public void setLoanNumber(java.lang.String loanNumber)

getLoanItemNumber

public java.lang.String getLoanItemNumber()

setLoanItemNumber

public void setLoanItemNumber(java.lang.String loanItemNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OnLoanItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OnLoanItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.OnLoanItemVO
All Implemented Interfaces:
java.io.Serializable
public class OnLoanItemVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
OnLoanItemVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getActual()
java.math.BigDecimal | getArDisc()
java.math.BigDecimal | getArNet()
java.math.BigDecimal | getArOpen()
java.math.BigDecimal | getArShip()
java.math.BigDecimal | getArSub()
java.math.BigDecimal | getArTax()
java.math.BigDecimal | getArTotal()
java.lang.String | getChangeOrder()
java.math.BigDecimal | getCost()
java.lang.String | getDcode()
int | getDelay()
java.util.Date | getDelivery()
java.lang.String | getDescription()
java.util.Date | getDesired()
java.math.BigDecimal | getDiscount()
java.lang.String | getDwg()
java.lang.String | getFob()
java.lang.String | getFreightWho()
java.math.BigDecimal | getHqa()
java.lang.String | getItemComments()
java.lang.String | getItemNotes()
java.math.BigDecimal | getLoanQuantity()
java.lang.String | getLocation()
java.lang.String | getMfg()
java.lang.String | getModelNumber()
java.lang.String | getMpn()
java.util.Date | getOriginal()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
OnLoanItemPK | getPk()
java.math.BigDecimal | getPricePerUnit()
java.lang.String | getPriority()
java.lang.String | getQr()
java.math.BigDecimal | getReceivedQuantity()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.lang.String | getRevision()
java.math.BigDecimal | getShippedQuantity()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.math.BigDecimal | getTaxRate()
java.lang.String | getUnit()
java.lang.Integer | getVersion()
int | hashCode()
void | setActual(java.util.Date actual)
void | setArDisc(java.math.BigDecimal arDisc)
void | setArNet(java.math.BigDecimal arNet)
void | setArOpen(java.math.BigDecimal arOpen)
void | setArShip(java.math.BigDecimal arShip)
void | setArSub(java.math.BigDecimal arSub)
void | setArTax(java.math.BigDecimal arTax)
void | setArTotal(java.math.BigDecimal arTotal)
void | setChangeOrder(java.lang.String changeOrder)
void | setCost(java.math.BigDecimal cost)
void | setDcode(java.lang.String dcode)
void | setDelay(int delay)
void | setDelivery(java.util.Date delivery)
void | setDescription(java.lang.String description)
void | setDesired(java.util.Date desired)
void | setDiscount(java.math.BigDecimal discount)
void | setDwg(java.lang.String dwg)
void | setFob(java.lang.String fob)
void | setFreightWho(java.lang.String freightWho)
void | setHqa(java.math.BigDecimal hqa)
void | setItemComments(java.lang.String itemComments)
void | setItemNotes(java.lang.String itemNotes)
void | setLoanQuantity(java.math.BigDecimal loanQuantity)
void | setLocation(java.lang.String location)
void | setMfg(java.lang.String mfg)
void | setModelNumber(java.lang.String modelNumber)
void | setMpn(java.lang.String mpn)
void | setOriginal(java.util.Date original)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(OnLoanItemPK pk)
void | setPricePerUnit(java.math.BigDecimal pricePerUnit)
void | setPriority(java.lang.String priority)
void | setQr(java.lang.String qr)
void | setReceivedQuantity(java.math.BigDecimal receivedQuantity)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setRevision(java.lang.String revision)
void | setShippedQuantity(java.math.BigDecimal shippedQuantity)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setUnit(java.lang.String unit)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

OnLoanItemVO

public OnLoanItemVO()
default constructor

Method Detail

getPk

public OnLoanItemPK getPk()

setPk

public void setPk(OnLoanItemPK pk)

getArSub

public java.math.BigDecimal getArSub()

setArSub

public void setArSub(java.math.BigDecimal arSub)

getArDisc

public java.math.BigDecimal getArDisc()

setArDisc

public void setArDisc(java.math.BigDecimal arDisc)

getArNet

public java.math.BigDecimal getArNet()

setArNet

public void setArNet(java.math.BigDecimal arNet)

getArShip

public java.math.BigDecimal getArShip()

setArShip

public void setArShip(java.math.BigDecimal arShip)

getArOpen

public java.math.BigDecimal getArOpen()

setArOpen

public void setArOpen(java.math.BigDecimal arOpen)

getArTax

public java.math.BigDecimal getArTax()

setArTax

public void setArTax(java.math.BigDecimal arTax)

getArTotal

public java.math.BigDecimal getArTotal()

setArTotal

public void setArTotal(java.math.BigDecimal arTotal)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getQr

public java.lang.String getQr()

setQr

public void setQr(java.lang.String qr)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getDelivery

public java.util.Date getDelivery()

setDelivery

public void setDelivery(java.util.Date delivery)

getDesired

public java.util.Date getDesired()

setDesired

public void setDesired(java.util.Date desired)

getDelay

public int getDelay()

setDelay

public void setDelay(int delay)

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getOriginal

public java.util.Date getOriginal()

setOriginal

public void setOriginal(java.util.Date original)

getActual

public java.util.Date getActual()

setActual

public void setActual(java.util.Date actual)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getFob

public java.lang.String getFob()

setFob

public void setFob(java.lang.String fob)

getFreightWho

public java.lang.String getFreightWho()

setFreightWho

public void setFreightWho(java.lang.String freightWho)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getDwg

public java.lang.String getDwg()

setDwg

public void setDwg(java.lang.String dwg)

getLoanQuantity

public java.math.BigDecimal getLoanQuantity()

setLoanQuantity

public void setLoanQuantity(java.math.BigDecimal loanQuantity)

getShippedQuantity

public java.math.BigDecimal getShippedQuantity()

setShippedQuantity

public void setShippedQuantity(java.math.BigDecimal shippedQuantity)

getReceivedQuantity

public java.math.BigDecimal getReceivedQuantity()

setReceivedQuantity

public void setReceivedQuantity(java.math.BigDecimal receivedQuantity)

getHqa

public java.math.BigDecimal getHqa()

setHqa

public void setHqa(java.math.BigDecimal hqa)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getDcode

public java.lang.String getDcode()

setDcode

public void setDcode(java.lang.String dcode)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getItemComments

public java.lang.String getItemComments()

setItemComments

public void setItemComments(java.lang.String itemComments)

getItemNotes

public java.lang.String getItemNotes()

getCost

public java.math.BigDecimal getCost()

getPricePerUnit

public java.math.BigDecimal getPricePerUnit()

getVersion

public java.lang.Integer getVersion()

setItemNotes

public void setItemNotes(java.lang.String itemNotes)

setCost

public void setCost(java.math.BigDecimal cost)

setPricePerUnit

public void setPricePerUnit(java.math.BigDecimal pricePerUnit)

setVersion

public void setVersion(java.lang.Integer version)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OnLoanListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OnLoanListResult

java.lang.Object
    extended by  bb.common.OnLoanListResult
All Implemented Interfaces:
java.io.Serializable
public class OnLoanListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_CUSTOMERPO
static java.lang.String | ORDER_BY_LOANDATE
static java.lang.String | ORDER_BY_LOANNUMBER
static java.lang.String | ORDER_BY_PROJECT
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
OnLoanListResult()
Method Summary
java.lang.String | getChangeOrder()
java.lang.String | getComments()
java.lang.String | getCustomerId()
java.lang.String | getCustomerPo()
java.util.Date | getLoanDate()
java.lang.String | getLoanNumber()
java.lang.String | getPrivateNote()
java.lang.String | getProject()
java.lang.String | getStatus()
void | setChangeOrder(java.lang.String changeOrder)
void | setComments(java.lang.String comments)
void | setCustomerId(java.lang.String customerId)
void | setCustomerPo(java.lang.String customerPo)
void | setLoanDate(java.util.Date loanDate)
void | setLoanNumber(java.lang.String loanNumber)
void | setPrivateNote(java.lang.String privateNote)
void | setProject(java.lang.String project)
void | setStatus(java.lang.String status)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_LOANNUMBER

public static final java.lang.String ORDER_BY_LOANNUMBER
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_CUSTOMERPO

public static final java.lang.String ORDER_BY_CUSTOMERPO
See Also:
Constant Field Values

ORDER_BY_PROJECT

public static final java.lang.String ORDER_BY_PROJECT
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_LOANDATE

public static final java.lang.String ORDER_BY_LOANDATE
See Also:
Constant Field Values
Constructor Detail

OnLoanListResult

public OnLoanListResult()
Method Detail

getStatus

public java.lang.String getStatus()

getComments

public java.lang.String getComments()

getPrivateNote

public java.lang.String getPrivateNote()

getProject

public java.lang.String getProject()

getCustomerPo

public java.lang.String getCustomerPo()

getCustomerId

public java.lang.String getCustomerId()

getChangeOrder

public java.lang.String getChangeOrder()

getLoanDate

public java.util.Date getLoanDate()

getLoanNumber

public java.lang.String getLoanNumber()

setStatus

public void setStatus(java.lang.String status)

setComments

public void setComments(java.lang.String comments)

setPrivateNote

public void setPrivateNote(java.lang.String privateNote)

setProject

public void setProject(java.lang.String project)

setCustomerPo

public void setCustomerPo(java.lang.String customerPo)

setCustomerId

public void setCustomerId(java.lang.String customerId)

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

setLoanDate

public void setLoanDate(java.util.Date loanDate)

setLoanNumber

public void setLoanNumber(java.lang.String loanNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OnloanReceiverItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OnloanReceiverItemListResult

java.lang.Object
    extended by  bb.common.OnloanReceiverItemListResult
All Implemented Interfaces:
java.io.Serializable
public class OnloanReceiverItemListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CUSTID
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_LNSHIPPERNUMBER
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_RECEIVERBY
static java.lang.String | ORDER_BY_RECEIVERNUMBER
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
OnloanReceiverItemListResult()
Method Summary
java.lang.String | getComments()
java.lang.String | getCustID()
java.util.Date | getDateReceived()
java.lang.String | getDescription()
java.lang.String | getLnNumber()
java.lang.String | getLnShipperNumber()
java.lang.String | getNotes()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getQuantityReceived()
java.lang.String | getReceivedBy()
java.lang.String | getReceiverItemNumber()
java.lang.String | getReceiverNumber()
java.lang.String | getStatus()
java.lang.String | getUnit()
void | setComments(java.lang.String comments)
void | setCustID(java.lang.String custID)
void | setDateReceived(java.util.Date dateReceived)
void | setDescription(java.lang.String description)
void | setLnNumber(java.lang.String lnNumber)
void | setLnShipperNumber(java.lang.String lnShipperNumber)
void | setNotes(java.lang.String notes)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setQuantity(java.math.BigDecimal quantity)
void | setQuantityReceived(java.math.BigDecimal quantityReceived)
void | setReceivedBy(java.lang.String receivedBy)
void | setReceiverItemNumber(java.lang.String receiverItemNumber)
void | setReceiverNumber(java.lang.String receiverNumber)
void | setStatus(java.lang.String status)
void | setUnit(java.lang.String unit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_RECEIVERNUMBER

public static final java.lang.String ORDER_BY_RECEIVERNUMBER
See Also:
Constant Field Values

ORDER_BY_LNSHIPPERNUMBER

public static final java.lang.String ORDER_BY_LNSHIPPERNUMBER
See Also:
Constant Field Values

ORDER_BY_RECEIVERBY

public static final java.lang.String ORDER_BY_RECEIVERBY
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_CUSTID

public static final java.lang.String ORDER_BY_CUSTID
See Also:
Constant Field Values
Constructor Detail

OnloanReceiverItemListResult

public OnloanReceiverItemListResult()
Method Detail

getCustID

public java.lang.String getCustID()

setCustID

public void setCustID(java.lang.String custID)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getNotes

public java.lang.String getNotes()

setNotes

public void setNotes(java.lang.String notes)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getReceivedBy

public java.lang.String getReceivedBy()

setReceivedBy

public void setReceivedBy(java.lang.String receivedBy)

getReceiverNumber

public java.lang.String getReceiverNumber()

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getDateReceived

public java.util.Date getDateReceived()

setDateReceived

public void setDateReceived(java.util.Date dateReceived)

getLnNumber

public java.lang.String getLnNumber()

setLnNumber

public void setLnNumber(java.lang.String lnNumber)

getLnShipperNumber

public java.lang.String getLnShipperNumber()

setLnShipperNumber

public void setLnShipperNumber(java.lang.String lnShipperNumber)

getQuantityReceived

public java.math.BigDecimal getQuantityReceived()

setQuantityReceived

public void setQuantityReceived(java.math.BigDecimal quantityReceived)

getReceiverItemNumber

public java.lang.String getReceiverItemNumber()

setReceiverItemNumber

public void setReceiverItemNumber(java.lang.String receiverItemNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OnloanReceiverItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OnloanReceiverItemPK

java.lang.Object
    extended by  bb.common.OnloanReceiverItemPK
All Implemented Interfaces:
java.io.Serializable
public class OnloanReceiverItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
OnloanReceiverItemPK()
OnloanReceiverItemPK(java.lang.String receiverNumber, java.lang.String receiverItemNumber)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getReceiverItemNumber()
java.lang.String | getReceiverNumber()
int | hashCode()
void | setReceiverItemNumber(java.lang.String receiverItemNumber)
void | setReceiverNumber(java.lang.String receiverNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

OnloanReceiverItemPK

public OnloanReceiverItemPK()

OnloanReceiverItemPK

public OnloanReceiverItemPK(java.lang.String receiverNumber,
                            java.lang.String receiverItemNumber)
Method Detail

setReceiverItemNumber

public void setReceiverItemNumber(java.lang.String receiverItemNumber)

getReceiverItemNumber

public java.lang.String getReceiverItemNumber()

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)

getReceiverNumber

public java.lang.String getReceiverNumber()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OnloanReceiverItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OnloanReceiverItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.OnloanReceiverItemVO
All Implemented Interfaces:
java.io.Serializable
public class OnloanReceiverItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
OnloanReceiverItemVO()
default constructor
OnloanReceiverItemVO(OnloanReceiverItemPK pk, java.lang.String lnShipperNumber, java.math.BigDecimal apSub, java.math.BigDecimal apReceived, java.math.BigDecimal apOpen, java.math.BigDecimal apDiscount, java.math.BigDecimal extendPrice, java.math.BigDecimal apTax, java.math.BigDecimal apTotal, java.lang.String referenceDoc1, java.lang.String referenceDoc2, java.lang.String qr, java.lang.String sentTo, java.lang.String receivedBy, java.lang.String condition, java.lang.String status, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String modelNumber, java.lang.String revision, java.lang.String location, java.math.BigDecimal quantity, java.math.BigDecimal quantityTraced, java.math.BigDecimal quantityReceived, java.math.BigDecimal costPerUnit, java.lang.String unit, java.math.BigDecimal discount, java.math.BigDecimal taxRate, java.lang.String description, java.lang.String mfg, java.lang.String mpn, java.lang.String serial)
minimal constructor
OnloanReceiverItemVO(OnloanReceiverItemPK pk, java.lang.String lnShipperNumber, java.math.BigDecimal apSub, java.math.BigDecimal apReceived, java.math.BigDecimal apOpen, java.math.BigDecimal apDiscount, java.math.BigDecimal extendPrice, java.math.BigDecimal apTax, java.math.BigDecimal apTotal, java.lang.String referenceDoc1, java.lang.String referenceDoc2, java.lang.String qr, java.lang.String sentTo, java.lang.String receivedBy, java.lang.String condition, java.lang.String status, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String modelNumber, java.lang.String revision, java.lang.String location, java.math.BigDecimal quantity, java.math.BigDecimal quantityTraced, java.math.BigDecimal quantityReceived, java.math.BigDecimal costPerUnit, java.lang.String unit, java.math.BigDecimal discount, java.math.BigDecimal taxRate, java.lang.String description, java.lang.String mfg, java.lang.String mpn, java.lang.String serial, java.lang.String receiverItemComments, java.lang.String receiverItemPrivateNotes)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getApDiscount()
java.math.BigDecimal | getApOpen()
java.math.BigDecimal | getApReceived()
java.math.BigDecimal | getApSub()
java.math.BigDecimal | getApTax()
java.math.BigDecimal | getApTotal()
java.lang.String | getCheckNumber()
java.lang.String | getComments()
java.lang.String | getCondition()
java.math.BigDecimal | getCostPerUnit()
java.util.Date | getDatePaid()
java.lang.String | getDescription()
java.math.BigDecimal | getDiscount()
java.math.BigDecimal | getDue()
java.math.BigDecimal | getExtendPrice()
java.lang.String | getLnShipperNumber()
java.lang.String | getLocation()
java.util.Map | getLocations()
java.lang.String | getMfg()
java.lang.String | getModelNumber()
java.lang.String | getMpn()
java.math.BigDecimal | getPaid()
PartVO | getPart()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
OnloanReceiverItemPK | getPk()
java.lang.String | getPrivateNotes()
java.lang.String | getQr()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getQuantityReceived()
java.math.BigDecimal | getQuantityTraced()
java.lang.String | getReceivedBy()
java.lang.String | getReferenceDoc1()
java.lang.String | getReferenceDoc2()
java.lang.String | getRevision()
java.lang.String | getSentTo()
java.lang.String | getSerial()
java.lang.String | getStatus()
java.math.BigDecimal | getTaxRate()
java.util.Map | getTrackings()
java.lang.String | getUnit()
int | hashCode()
void | setApDiscount(java.math.BigDecimal apDiscount)
void | setApOpen(java.math.BigDecimal apOpen)
void | setApReceived(java.math.BigDecimal apReceived)
void | setApSub(java.math.BigDecimal apSub)
void | setApTax(java.math.BigDecimal apTax)
void | setApTotal(java.math.BigDecimal apTotal)
void | setCheckNumber(java.lang.String checkNumber)
void | setComments(java.lang.String comments)
void | setCondition(java.lang.String condition)
void | setCostPerUnit(java.math.BigDecimal costPerUnit)
void | setDatePaid(java.util.Date datePaid)
void | setDescription(java.lang.String description)
void | setDiscount(java.math.BigDecimal discount)
void | setDue(java.math.BigDecimal due)
void | setExtendPrice(java.math.BigDecimal extendPrice)
void | setLnShipperNumber(java.lang.String lnShipperNumber)
void | setLocation(java.lang.String location)
void | setLocations(java.util.Map locations)
void | setMfg(java.lang.String mfg)
void | setModelNumber(java.lang.String modelNumber)
void | setMpn(java.lang.String mpn)
void | setPaid(java.math.BigDecimal paid)
void | setPart(PartVO part)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(OnloanReceiverItemPK pk)
void | setPrivateNotes(java.lang.String privateNotes)
void | setQr(java.lang.String qr)
void | setQuantity(java.math.BigDecimal quantity)
void | setQuantityReceived(java.math.BigDecimal quantityReceived)
void | setQuantityTraced(java.math.BigDecimal quantityTraced)
void | setReceivedBy(java.lang.String receivedBy)
void | setReferenceDoc1(java.lang.String referenceDoc1)
void | setReferenceDoc2(java.lang.String referenceDoc2)
void | setRevision(java.lang.String revision)
void | setSentTo(java.lang.String sentTo)
void | setSerial(java.lang.String serial)
void | setStatus(java.lang.String status)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setTrackings(java.util.Map trackings)
void | setUnit(java.lang.String unit)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

OnloanReceiverItemVO

public OnloanReceiverItemVO(OnloanReceiverItemPK pk,
                            java.lang.String lnShipperNumber,
                            java.math.BigDecimal apSub,
                            java.math.BigDecimal apReceived,
                            java.math.BigDecimal apOpen,
                            java.math.BigDecimal apDiscount,
                            java.math.BigDecimal extendPrice,
                            java.math.BigDecimal apTax,
                            java.math.BigDecimal apTotal,
                            java.lang.String referenceDoc1,
                            java.lang.String referenceDoc2,
                            java.lang.String qr,
                            java.lang.String sentTo,
                            java.lang.String receivedBy,
                            java.lang.String condition,
                            java.lang.String status,
                            java.lang.String partNumber,
                            java.lang.String partType,
                            java.lang.String partFrom,
                            java.lang.String modelNumber,
                            java.lang.String revision,
                            java.lang.String location,
                            java.math.BigDecimal quantity,
                            java.math.BigDecimal quantityTraced,
                            java.math.BigDecimal quantityReceived,
                            java.math.BigDecimal costPerUnit,
                            java.lang.String unit,
                            java.math.BigDecimal discount,
                            java.math.BigDecimal taxRate,
                            java.lang.String description,
                            java.lang.String mfg,
                            java.lang.String mpn,
                            java.lang.String serial,
                            java.lang.String receiverItemComments,
                            java.lang.String receiverItemPrivateNotes)
full constructor

OnloanReceiverItemVO

public OnloanReceiverItemVO()
default constructor

OnloanReceiverItemVO

public OnloanReceiverItemVO(OnloanReceiverItemPK pk,
                            java.lang.String lnShipperNumber,
                            java.math.BigDecimal apSub,
                            java.math.BigDecimal apReceived,
                            java.math.BigDecimal apOpen,
                            java.math.BigDecimal apDiscount,
                            java.math.BigDecimal extendPrice,
                            java.math.BigDecimal apTax,
                            java.math.BigDecimal apTotal,
                            java.lang.String referenceDoc1,
                            java.lang.String referenceDoc2,
                            java.lang.String qr,
                            java.lang.String sentTo,
                            java.lang.String receivedBy,
                            java.lang.String condition,
                            java.lang.String status,
                            java.lang.String partNumber,
                            java.lang.String partType,
                            java.lang.String partFrom,
                            java.lang.String modelNumber,
                            java.lang.String revision,
                            java.lang.String location,
                            java.math.BigDecimal quantity,
                            java.math.BigDecimal quantityTraced,
                            java.math.BigDecimal quantityReceived,
                            java.math.BigDecimal costPerUnit,
                            java.lang.String unit,
                            java.math.BigDecimal discount,
                            java.math.BigDecimal taxRate,
                            java.lang.String description,
                            java.lang.String mfg,
                            java.lang.String mpn,
                            java.lang.String serial)
minimal constructor

Method Detail

getApSub

public java.math.BigDecimal getApSub()

setApSub

public void setApSub(java.math.BigDecimal apSub)

getApReceived

public java.math.BigDecimal getApReceived()

setApReceived

public void setApReceived(java.math.BigDecimal apReceived)

getApOpen

public java.math.BigDecimal getApOpen()

setApOpen

public void setApOpen(java.math.BigDecimal apOpen)

getApDiscount

public java.math.BigDecimal getApDiscount()

setApDiscount

public void setApDiscount(java.math.BigDecimal apDiscount)

getExtendPrice

public java.math.BigDecimal getExtendPrice()

setExtendPrice

public void setExtendPrice(java.math.BigDecimal extendPrice)

getApTax

public java.math.BigDecimal getApTax()

setApTax

public void setApTax(java.math.BigDecimal apTax)

getApTotal

public java.math.BigDecimal getApTotal()

setApTotal

public void setApTotal(java.math.BigDecimal apTotal)

getReferenceDoc1

public java.lang.String getReferenceDoc1()

setReferenceDoc1

public void setReferenceDoc1(java.lang.String referenceDoc1)

getReferenceDoc2

public java.lang.String getReferenceDoc2()

setReferenceDoc2

public void setReferenceDoc2(java.lang.String referenceDoc2)

getQr

public java.lang.String getQr()

setQr

public void setQr(java.lang.String qr)

getSentTo

public java.lang.String getSentTo()

setSentTo

public void setSentTo(java.lang.String sentTo)

getReceivedBy

public java.lang.String getReceivedBy()

setReceivedBy

public void setReceivedBy(java.lang.String receivedBy)

getCondition

public java.lang.String getCondition()

setCondition

public void setCondition(java.lang.String condition)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getQuantityTraced

public java.math.BigDecimal getQuantityTraced()

setQuantityTraced

public void setQuantityTraced(java.math.BigDecimal quantityTraced)

getQuantityReceived

public java.math.BigDecimal getQuantityReceived()

setQuantityReceived

public void setQuantityReceived(java.math.BigDecimal quantityReceived)

getCostPerUnit

public java.math.BigDecimal getCostPerUnit()

setCostPerUnit

public void setCostPerUnit(java.math.BigDecimal costPerUnit)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getSerial

public java.lang.String getSerial()

setSerial

public void setSerial(java.lang.String serial)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getPrivateNotes

public java.lang.String getPrivateNotes()

setPrivateNotes

public void setPrivateNotes(java.lang.String privateNotes)

setPart

public void setPart(PartVO part)

setCheckNumber

public void setCheckNumber(java.lang.String checkNumber)

setDue

public void setDue(java.math.BigDecimal due)

setDatePaid

public void setDatePaid(java.util.Date datePaid)

setPaid

public void setPaid(java.math.BigDecimal paid)

getPart

public PartVO getPart()

getCheckNumber

public java.lang.String getCheckNumber()

getDue

public java.math.BigDecimal getDue()

getDatePaid

public java.util.Date getDatePaid()

getPaid

public java.math.BigDecimal getPaid()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getLnShipperNumber

public java.lang.String getLnShipperNumber()

setLnShipperNumber

public void setLnShipperNumber(java.lang.String lnShipperNumber)

getPk

public OnloanReceiverItemPK getPk()

setPk

public void setPk(OnloanReceiverItemPK pk)

getLocations

public java.util.Map getLocations()

setLocations

public void setLocations(java.util.Map locations)

getTrackings

public java.util.Map getTrackings()

setTrackings

public void setTrackings(java.util.Map trackings)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OnloanReceiverListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OnloanReceiverListResult

java.lang.Object
    extended by  bb.common.OnloanReceiverListResult
All Implemented Interfaces:
java.io.Serializable
public class OnloanReceiverListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DATERECEIVED
static java.lang.String | ORDER_BY_LNSHIPPERNUMBER
static java.lang.String | ORDER_BY_PROJECT
static java.lang.String | ORDER_BY_RECEIVEDBY
static java.lang.String | ORDER_BY_RECEIVERNUMBER
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
OnloanReceiverListResult()
Method Summary
java.lang.String | getComments()
java.lang.String | getCustID()
java.util.Date | getDateReceived()
java.lang.String | getLnShipperNumber()
java.lang.String | getNotes()
java.lang.String | getProject()
java.lang.String | getReceivedBy()
java.lang.String | getReceiverNumber()
java.lang.String | getStatus()
void | setComments(java.lang.String comments)
void | setCustID(java.lang.String custID)
void | setDateReceived(java.util.Date dateReceived)
void | setLnShipperNumber(java.lang.String lnShipperNumber)
void | setNotes(java.lang.String notes)
void | setProject(java.lang.String project)
void | setReceivedBy(java.lang.String receivedBy)
void | setReceiverNumber(java.lang.String receiverNumber)
void | setStatus(java.lang.String status)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_RECEIVERNUMBER

public static final java.lang.String ORDER_BY_RECEIVERNUMBER
See Also:
Constant Field Values

ORDER_BY_LNSHIPPERNUMBER

public static final java.lang.String ORDER_BY_LNSHIPPERNUMBER
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_RECEIVEDBY

public static final java.lang.String ORDER_BY_RECEIVEDBY
See Also:
Constant Field Values

ORDER_BY_DATERECEIVED

public static final java.lang.String ORDER_BY_DATERECEIVED
See Also:
Constant Field Values

ORDER_BY_PROJECT

public static final java.lang.String ORDER_BY_PROJECT
See Also:
Constant Field Values
Constructor Detail

OnloanReceiverListResult

public OnloanReceiverListResult()
Method Detail

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getCustID

public java.lang.String getCustID()

setCustID

public void setCustID(java.lang.String custID)

getDateReceived

public java.util.Date getDateReceived()

setDateReceived

public void setDateReceived(java.util.Date dateReceived)

getNotes

public java.lang.String getNotes()

setNotes

public void setNotes(java.lang.String notes)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

getReceivedBy

public java.lang.String getReceivedBy()

setReceivedBy

public void setReceivedBy(java.lang.String receivedBy)

getReceiverNumber

public java.lang.String getReceiverNumber()

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getLnShipperNumber

public java.lang.String getLnShipperNumber()

setLnShipperNumber

public void setLnShipperNumber(java.lang.String lnShipperNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OnloanReceiverVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OnloanReceiverVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.OnloanReceiverVO
All Implemented Interfaces:
java.io.Serializable
public class OnloanReceiverVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
OnloanReceiverVO()
default constructor
OnloanReceiverVO(java.lang.String receiverNumber, java.lang.String lnShipperNumber)
minimal constructor
OnloanReceiverVO(java.lang.String receiverNumber, java.lang.String lnShipperNumber, java.lang.String accountPayableNumber, java.lang.String custID, java.lang.String lastChangeUser, java.util.Date lastChangeDate, java.util.Date adate, java.lang.String origin, java.math.BigDecimal apSub, java.math.BigDecimal apReceived, java.math.BigDecimal apOpen, java.math.BigDecimal totalDiscount, java.math.BigDecimal subTotal, java.math.BigDecimal totalTax, java.math.BigDecimal totalFreight, java.math.BigDecimal grantTotal, java.math.BigDecimal apPaidReceived, java.math.BigDecimal apPaidGl, java.math.BigDecimal apGl1Recorded, java.math.BigDecimal apGl2Paid, java.lang.String changeOrder, java.lang.String status, java.lang.String collect, java.lang.String receivedBy, java.util.Date dateReceived, java.lang.String deliveredTo, java.lang.String freightBill, java.lang.String shippedVia, java.lang.String carrier, java.lang.String carrierAccount, java.lang.String tracking, java.lang.String incoterm, java.lang.String incotermPlacePort, java.lang.String currency, java.lang.String terms, java.lang.String requester, java.lang.String projectName, java.lang.String relatedDoc, java.lang.String debitAccount, java.lang.String bp, java.lang.String receiverComments, java.lang.String receiverPrivateNotes, java.math.BigDecimal due, java.lang.String cusInvoice, java.lang.String cusPackage, java.math.BigDecimal cusTotal, java.util.Date cusInvoiceDate, java.util.Date paydate, java.util.Date datePaid, java.lang.String checkNo, java.math.BigDecimal paid, java.lang.String itran, java.lang.String etran, int lastChangeTimes, CustomerVendorAddressInfoVO customerAddressInfo, java.util.Set receiverItem)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAccountPayableNumber()
java.util.Date | getAdate()
java.math.BigDecimal | getApGl1Recorded()
java.math.BigDecimal | getApGl2Paid()
java.lang.String | getApNetSet()
java.math.BigDecimal | getApOpen()
java.math.BigDecimal | getApPaidGl()
java.math.BigDecimal | getApPaidReceived()
java.math.BigDecimal | getApReceived()
java.math.BigDecimal | getApSub()
java.lang.String | getApTaxSet()
java.lang.String | getBatch()
java.lang.String | getBp()
java.lang.String | getBuyer()
java.lang.String | getCarrier()
java.lang.String | getCarrierAccount()
java.lang.String | getChangeOrder()
java.lang.String | getCheckNo()
java.lang.String | getCoComments()
java.lang.String | getCollect()
java.lang.String | getComments()
java.lang.String | getCompanyUnitId()
java.lang.String | getCurrency()
java.lang.String | getCusInvoice()
java.util.Date | getCusInvoiceDate()
java.lang.String | getCusPackage()
java.util.Date | getCusShipDate()
java.lang.String | getCustID()
CustomerVendorAddressInfoVO | getCustomerAddressInfo()
java.math.BigDecimal | getCusTotal()
java.util.Date | getDatePaid()
java.util.Date | getDateReceived()
java.lang.String | getDebitAccount()
java.lang.String | getDeliveredTo()
java.math.BigDecimal | getDue()
java.lang.String | getEtran()
java.math.BigDecimal | getExchange()
java.lang.String | getFreightBill()
java.math.BigDecimal | getGrantTotal()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getItran()
java.util.Date | getLastChangeDate()
int | getLastChangeTimes()
java.lang.String | getLastChangeUser()
java.lang.String | getLnShipperNumber()
java.lang.String | getOrigin()
java.math.BigDecimal | getPaid()
java.util.Date | getPaydate()
java.lang.String | getPrivateNotes()
java.lang.String | getProjectName()
java.lang.String | getReceivedBy()
java.util.Set | getReceiverItem()
java.lang.String | getReceiverNumber()
java.lang.String | getRelatedDoc()
java.lang.String | getRequester()
java.lang.String | getShippedVia()
java.lang.String | getStatus()
java.math.BigDecimal | getSubTotal()
java.lang.String | getTerms()
java.math.BigDecimal | getTotalDiscount()
java.math.BigDecimal | getTotalFreight()
java.math.BigDecimal | getTotalTax()
java.lang.String | getTracking()
int | hashCode()
void | setAccountPayableNumber(java.lang.String accountPayableNumber)
void | setAdate(java.util.Date adate)
void | setApGl1Recorded(java.math.BigDecimal apGl1Recorded)
void | setApGl2Paid(java.math.BigDecimal apGl2Paid)
void | setApNetSet(java.lang.String apNetSet)
void | setApOpen(java.math.BigDecimal apOpen)
void | setApPaidGl(java.math.BigDecimal apPaidGl)
void | setApPaidReceived(java.math.BigDecimal apPaidReceived)
void | setApReceived(java.math.BigDecimal apReceived)
void | setApSub(java.math.BigDecimal apSub)
void | setApTaxSet(java.lang.String apTaxSet)
void | setBatch(java.lang.String batch)
void | setBp(java.lang.String bp)
void | setBuyer(java.lang.String buyer)
void | setCarrier(java.lang.String carrier)
void | setCarrierAccount(java.lang.String carrierAccount)
void | setChangeOrder(java.lang.String changeOrder)
void | setCheckNo(java.lang.String checkNo)
void | setCoComments(java.lang.String coComments)
void | setCollect(java.lang.String collect)
void | setComments(java.lang.String comments)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCurrency(java.lang.String currency)
void | setCusInvoice(java.lang.String cusInvoice)
void | setCusInvoiceDate(java.util.Date cusInvoiceDate)
void | setCusPackage(java.lang.String cusPackage)
void | setCusShipDate(java.util.Date cusShipDate)
void | setCustID(java.lang.String custID)
void | setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | setCusTotal(java.math.BigDecimal cusTotal)
void | setDatePaid(java.util.Date datePaid)
void | setDateReceived(java.util.Date dateReceived)
void | setDebitAccount(java.lang.String debitAccount)
void | setDeliveredTo(java.lang.String deliveredTo)
void | setDue(java.math.BigDecimal due)
void | setEtran(java.lang.String etran)
void | setExchange(java.math.BigDecimal exchange)
void | setFreightBill(java.lang.String freightBill)
void | setGrantTotal(java.math.BigDecimal grantTotal)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setItran(java.lang.String itran)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTimes(int lastChangeTimes)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLnShipperNumber(java.lang.String lnShipperNumber)
void | setOrigin(java.lang.String origin)
void | setPaid(java.math.BigDecimal paid)
void | setPaydate(java.util.Date paydate)
void | setPrivateNotes(java.lang.String privateNotes)
void | setProjectName(java.lang.String projectName)
void | setReceivedBy(java.lang.String receivedBy)
void | setReceiverItem(java.util.Set receiverItem)
void | setReceiverNumber(java.lang.String receiverNumber)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setRequester(java.lang.String requester)
void | setShippedVia(java.lang.String shippedVia)
void | setStatus(java.lang.String status)
void | setSubTotal(java.math.BigDecimal subTotal)
void | setTerms(java.lang.String terms)
void | setTotalDiscount(java.math.BigDecimal totalDiscount)
void | setTotalFreight(java.math.BigDecimal totalFreight)
void | setTotalTax(java.math.BigDecimal totalTax)
void | setTracking(java.lang.String tracking)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

OnloanReceiverVO

public OnloanReceiverVO(java.lang.String receiverNumber,
                        java.lang.String lnShipperNumber,
                        java.lang.String accountPayableNumber,
                        java.lang.String custID,
                        java.lang.String lastChangeUser,
                        java.util.Date lastChangeDate,
                        java.util.Date adate,
                        java.lang.String origin,
                        java.math.BigDecimal apSub,
                        java.math.BigDecimal apReceived,
                        java.math.BigDecimal apOpen,
                        java.math.BigDecimal totalDiscount,
                        java.math.BigDecimal subTotal,
                        java.math.BigDecimal totalTax,
                        java.math.BigDecimal totalFreight,
                        java.math.BigDecimal grantTotal,
                        java.math.BigDecimal apPaidReceived,
                        java.math.BigDecimal apPaidGl,
                        java.math.BigDecimal apGl1Recorded,
                        java.math.BigDecimal apGl2Paid,
                        java.lang.String changeOrder,
                        java.lang.String status,
                        java.lang.String collect,
                        java.lang.String receivedBy,
                        java.util.Date dateReceived,
                        java.lang.String deliveredTo,
                        java.lang.String freightBill,
                        java.lang.String shippedVia,
                        java.lang.String carrier,
                        java.lang.String carrierAccount,
                        java.lang.String tracking,
                        java.lang.String incoterm,
                        java.lang.String incotermPlacePort,
                        java.lang.String currency,
                        java.lang.String terms,
                        java.lang.String requester,
                        java.lang.String projectName,
                        java.lang.String relatedDoc,
                        java.lang.String debitAccount,
                        java.lang.String bp,
                        java.lang.String receiverComments,
                        java.lang.String receiverPrivateNotes,
                        java.math.BigDecimal due,
                        java.lang.String cusInvoice,
                        java.lang.String cusPackage,
                        java.math.BigDecimal cusTotal,
                        java.util.Date cusInvoiceDate,
                        java.util.Date paydate,
                        java.util.Date datePaid,
                        java.lang.String checkNo,
                        java.math.BigDecimal paid,
                        java.lang.String itran,
                        java.lang.String etran,
                        int lastChangeTimes,
                        CustomerVendorAddressInfoVO customerAddressInfo,
                        java.util.Set receiverItem)
full constructor

OnloanReceiverVO

public OnloanReceiverVO()
default constructor

OnloanReceiverVO

public OnloanReceiverVO(java.lang.String receiverNumber,
                        java.lang.String lnShipperNumber)
minimal constructor

Method Detail

getReceiverNumber

public java.lang.String getReceiverNumber()

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)

getAccountPayableNumber

public java.lang.String getAccountPayableNumber()

setAccountPayableNumber

public void setAccountPayableNumber(java.lang.String accountPayableNumber)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getApSub

public java.math.BigDecimal getApSub()

setApSub

public void setApSub(java.math.BigDecimal apSub)

getApReceived

public java.math.BigDecimal getApReceived()

setApReceived

public void setApReceived(java.math.BigDecimal apReceived)

getApOpen

public java.math.BigDecimal getApOpen()

setApOpen

public void setApOpen(java.math.BigDecimal apOpen)

getTotalDiscount

public java.math.BigDecimal getTotalDiscount()

setTotalDiscount

public void setTotalDiscount(java.math.BigDecimal totalDiscount)

getSubTotal

public java.math.BigDecimal getSubTotal()

setSubTotal

public void setSubTotal(java.math.BigDecimal subTotal)

getTotalTax

public java.math.BigDecimal getTotalTax()

setTotalTax

public void setTotalTax(java.math.BigDecimal totalTax)

getTotalFreight

public java.math.BigDecimal getTotalFreight()

setTotalFreight

public void setTotalFreight(java.math.BigDecimal totalFreight)

getGrantTotal

public java.math.BigDecimal getGrantTotal()

setGrantTotal

public void setGrantTotal(java.math.BigDecimal grantTotal)

getApPaidReceived

public java.math.BigDecimal getApPaidReceived()

setApPaidReceived

public void setApPaidReceived(java.math.BigDecimal apPaidReceived)

getApPaidGl

public java.math.BigDecimal getApPaidGl()

setApPaidGl

public void setApPaidGl(java.math.BigDecimal apPaidGl)

getApGl1Recorded

public java.math.BigDecimal getApGl1Recorded()

setApGl1Recorded

public void setApGl1Recorded(java.math.BigDecimal apGl1Recorded)

getApGl2Paid

public java.math.BigDecimal getApGl2Paid()

setApGl2Paid

public void setApGl2Paid(java.math.BigDecimal apGl2Paid)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getCollect

public java.lang.String getCollect()

setCollect

public void setCollect(java.lang.String collect)

getReceivedBy

public java.lang.String getReceivedBy()

setReceivedBy

public void setReceivedBy(java.lang.String receivedBy)

getDateReceived

public java.util.Date getDateReceived()

setDateReceived

public void setDateReceived(java.util.Date dateReceived)

getDeliveredTo

public java.lang.String getDeliveredTo()

setDeliveredTo

public void setDeliveredTo(java.lang.String deliveredTo)

getFreightBill

public java.lang.String getFreightBill()

setFreightBill

public void setFreightBill(java.lang.String freightBill)

getShippedVia

public java.lang.String getShippedVia()

setShippedVia

public void setShippedVia(java.lang.String shippedVia)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAccount

public java.lang.String getCarrierAccount()

setCarrierAccount

public void setCarrierAccount(java.lang.String carrierAccount)

getTracking

public java.lang.String getTracking()

setTracking

public void setTracking(java.lang.String tracking)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getRequester

public java.lang.String getRequester()

setRequester

public void setRequester(java.lang.String requester)

getProjectName

public java.lang.String getProjectName()

setProjectName

public void setProjectName(java.lang.String projectName)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getDebitAccount

public java.lang.String getDebitAccount()

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

getBp

public java.lang.String getBp()

setBp

public void setBp(java.lang.String bp)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getPrivateNotes

public java.lang.String getPrivateNotes()

setPrivateNotes

public void setPrivateNotes(java.lang.String privateNotes)

getDue

public java.math.BigDecimal getDue()

setDue

public void setDue(java.math.BigDecimal due)

getPaydate

public java.util.Date getPaydate()

setPaydate

public void setPaydate(java.util.Date paydate)

getDatePaid

public java.util.Date getDatePaid()

setDatePaid

public void setDatePaid(java.util.Date datePaid)

getCheckNo

public java.lang.String getCheckNo()

setCheckNo

public void setCheckNo(java.lang.String checkNo)

getPaid

public java.math.BigDecimal getPaid()

setPaid

public void setPaid(java.math.BigDecimal paid)

getItran

public java.lang.String getItran()

setItran

public void setItran(java.lang.String itran)

getEtran

public java.lang.String getEtran()

setEtran

public void setEtran(java.lang.String etran)

getLastChangeTimes

public int getLastChangeTimes()

setLastChangeTimes

public void setLastChangeTimes(int lastChangeTimes)

getReceiverItem

public java.util.Set getReceiverItem()

getApNetSet

public java.lang.String getApNetSet()

getApTaxSet

public java.lang.String getApTaxSet()

getBatch

public java.lang.String getBatch()

getBuyer

public java.lang.String getBuyer()

getCoComments

public java.lang.String getCoComments()

setReceiverItem

public void setReceiverItem(java.util.Set receiverItem)

setApNetSet

public void setApNetSet(java.lang.String apNetSet)

setApTaxSet

public void setApTaxSet(java.lang.String apTaxSet)

setBatch

public void setBatch(java.lang.String batch)

setBuyer

public void setBuyer(java.lang.String buyer)

setCoComments

public void setCoComments(java.lang.String coComments)

getExchange

public java.math.BigDecimal getExchange()

setExchange

public void setExchange(java.math.BigDecimal exchange)

getCusInvoice

public java.lang.String getCusInvoice()

setCusInvoice

public void setCusInvoice(java.lang.String cusInvoice)

getCusInvoiceDate

public java.util.Date getCusInvoiceDate()

setCusInvoiceDate

public void setCusInvoiceDate(java.util.Date cusInvoiceDate)

getCusPackage

public java.lang.String getCusPackage()

setCusPackage

public void setCusPackage(java.lang.String cusPackage)

getCusShipDate

public java.util.Date getCusShipDate()

setCusShipDate

public void setCusShipDate(java.util.Date cusShipDate)

getCustID

public java.lang.String getCustID()

setCustID

public void setCustID(java.lang.String custID)

getCusTotal

public java.math.BigDecimal getCusTotal()

setCusTotal

public void setCusTotal(java.math.BigDecimal cusTotal)

getLnShipperNumber

public java.lang.String getLnShipperNumber()

setLnShipperNumber

public void setLnShipperNumber(java.lang.String lnShipperNumber)

getCustomerAddressInfo

public CustomerVendorAddressInfoVO getCustomerAddressInfo()

setCustomerAddressInfo

public void setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OnloanReviewVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OnloanReviewVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.OnloanReviewVO
All Implemented Interfaces:
java.io.Serializable
public class OnloanReviewVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CANREVIEWOWNONLOAN
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_EMPLOYEEID
static java.lang.String | ORDER_BY_REVIEWLIMIT
static java.lang.String | ORDER_BY_USERNAME
Constructor Summary
OnloanReviewVO()
default constructor
OnloanReviewVO(java.lang.String employeeId, java.lang.String userName, java.math.BigDecimal reviewLimit, java.lang.String currency, java.lang.String canReviewOwnOnloan)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCanReviewOwnOnloan()
java.lang.String | getCurrency()
java.lang.String | getEmployeeId()
java.math.BigDecimal | getReviewLimit()
java.lang.String | getUserName()
int | hashCode()
void | setCanReviewOwnOnloan(java.lang.String canReviewOwnOnloan)
void | setCurrency(java.lang.String currency)
void | setEmployeeId(java.lang.String employeeId)
void | setReviewLimit(java.math.BigDecimal reviewLimit)
void | setUserName(java.lang.String userName)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_EMPLOYEEID

public static final java.lang.String ORDER_BY_EMPLOYEEID
See Also:
Constant Field Values

ORDER_BY_USERNAME

public static final java.lang.String ORDER_BY_USERNAME
See Also:
Constant Field Values

ORDER_BY_REVIEWLIMIT

public static final java.lang.String ORDER_BY_REVIEWLIMIT
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values

ORDER_BY_CANREVIEWOWNONLOAN

public static final java.lang.String ORDER_BY_CANREVIEWOWNONLOAN
See Also:
Constant Field Values
Constructor Detail

OnloanReviewVO

public OnloanReviewVO(java.lang.String employeeId,
                      java.lang.String userName,
                      java.math.BigDecimal reviewLimit,
                      java.lang.String currency,
                      java.lang.String canReviewOwnOnloan)
full constructor

OnloanReviewVO

public OnloanReviewVO()
default constructor

Method Detail

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getReviewLimit

public java.math.BigDecimal getReviewLimit()

setReviewLimit

public void setReviewLimit(java.math.BigDecimal reviewLimit)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getCanReviewOwnOnloan

public java.lang.String getCanReviewOwnOnloan()

setCanReviewOwnOnloan

public void setCanReviewOwnOnloan(java.lang.String canReviewOwnOnloan)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OnloanShipperItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OnloanShipperItemPK

java.lang.Object
    extended by  bb.common.OnloanShipperItemPK
All Implemented Interfaces:
java.io.Serializable
public class OnloanShipperItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
OnloanShipperItemPK()
OnloanShipperItemPK(java.lang.String lnShipperNumber, java.lang.String lnShipperItemNumber)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getLnShipperItemNumber()
java.lang.String | getLnShipperNumber()
int | hashCode()
void | setLnShipperItemNumber(java.lang.String lnShipperItemNumber)
void | setLnShipperNumber(java.lang.String lnShipperNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

OnloanShipperItemPK

public OnloanShipperItemPK()

OnloanShipperItemPK

public OnloanShipperItemPK(java.lang.String lnShipperNumber,
                           java.lang.String lnShipperItemNumber)
Method Detail

getLnShipperItemNumber

public java.lang.String getLnShipperItemNumber()

setLnShipperItemNumber

public void setLnShipperItemNumber(java.lang.String lnShipperItemNumber)

getLnShipperNumber

public java.lang.String getLnShipperNumber()

setLnShipperNumber

public void setLnShipperNumber(java.lang.String lnShipperNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OnloanShipperItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OnloanShipperItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.OnloanShipperItemVO
All Implemented Interfaces:
java.io.Serializable
public class OnloanShipperItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
OnloanShipperItemVO()
default constructor
OnloanShipperItemVO(OnloanShipperItemPK pk, java.lang.String loanNumber, java.math.BigDecimal arSub, java.math.BigDecimal arShip, java.math.BigDecimal arOpen, java.math.BigDecimal arDiscount, java.math.BigDecimal arNet, java.math.BigDecimal arTax, java.math.BigDecimal arTotal, java.lang.String referenceDoc1, java.lang.String referenceDoc2, java.util.Date dateShipped, java.util.Date dateInvoiced, java.lang.String shipVia, java.lang.String shipToId, java.lang.String status, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String modelNumber, java.lang.String revision, java.lang.String location, java.math.BigDecimal loanQuantity, java.math.BigDecimal quantityShip, java.math.BigDecimal listPrice, java.math.BigDecimal averageCost, java.lang.String unit, java.math.BigDecimal discount, java.math.BigDecimal taxRate, java.lang.String description, java.lang.String mfg, java.lang.String mpn, java.lang.String serialNumber, java.lang.String shipperItemComments, java.lang.String shipperItemPrivateNotes)
full constructor
OnloanShipperItemVO(OnloanShipperItemPK pk, java.lang.String loanNumber, java.lang.String status, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom)
minimal constructor
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getArDiscount()
java.math.BigDecimal | getArNet()
java.math.BigDecimal | getArOpen()
java.math.BigDecimal | getArShip()
java.math.BigDecimal | getArSub()
java.math.BigDecimal | getArTax()
java.math.BigDecimal | getArTotal()
java.math.BigDecimal | getAverageCost()
java.lang.String | getCheckNumber()
java.util.Date | getDateInvoiced()
java.util.Date | getDatePaid()
java.util.Date | getDateShipped()
java.lang.String | getDescription()
java.math.BigDecimal | getDiscount()
java.math.BigDecimal | getDue()
java.math.BigDecimal | getListPrice()
java.lang.String | getLoanNumber()
java.math.BigDecimal | getLoanQuantity()
java.lang.String | getLocation()
java.util.Map | getLocations()
java.lang.String | getMfg()
java.lang.String | getModelNumber()
java.lang.String | getMpn()
java.math.BigDecimal | getPaid()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
OnloanShipperItemPK | getPk()
java.math.BigDecimal | getQuantityRec()
java.math.BigDecimal | getQuantityShip()
java.lang.String | getReferenceDoc1()
java.lang.String | getReferenceDoc2()
java.lang.String | getRevision()
java.lang.String | getSerialNumber()
java.lang.String | getShipperItemComments()
java.util.Set | getShipperItemManufacturer()
java.lang.String | getShipperItemPrivateNotes()
java.lang.String | getShipToId()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.math.BigDecimal | getTaxRate()
java.util.Map | getTrackings()
java.lang.String | getUnit()
int | hashCode()
void | setArDiscount(java.math.BigDecimal arDiscount)
void | setArNet(java.math.BigDecimal arNet)
void | setArOpen(java.math.BigDecimal arOpen)
void | setArShip(java.math.BigDecimal arShip)
void | setArSub(java.math.BigDecimal arSub)
void | setArTax(java.math.BigDecimal arTax)
void | setArTotal(java.math.BigDecimal arTotal)
void | setAverageCost(java.math.BigDecimal averageCost)
void | setCheckNumber(java.lang.String checkNumber)
void | setDateInvoiced(java.util.Date dateInvoiced)
void | setDatePaid(java.util.Date datePaid)
void | setDateShipped(java.util.Date dateShipped)
void | setDescription(java.lang.String description)
void | setDiscount(java.math.BigDecimal discount)
void | setDue(java.math.BigDecimal due)
void | setListPrice(java.math.BigDecimal listPrice)
void | setLoanNumber(java.lang.String loanNumber)
void | setLoanQuantity(java.math.BigDecimal loanQuantity)
void | setLocation(java.lang.String location)
void | setLocations(java.util.Map locations)
void | setMfg(java.lang.String mfg)
void | setModelNumber(java.lang.String modelNumber)
void | setMpn(java.lang.String mpn)
void | setPaid(java.math.BigDecimal paid)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(OnloanShipperItemPK pk)
void | setQuantityRec(java.math.BigDecimal quantityRec)
void | setQuantityShip(java.math.BigDecimal quantityShip)
void | setReferenceDoc1(java.lang.String referenceDoc1)
void | setReferenceDoc2(java.lang.String referenceDoc2)
void | setRevision(java.lang.String revision)
void | setSerialNumber(java.lang.String serialNumber)
void | setShipperItemComments(java.lang.String shipperItemComments)
void | setShipperItemManufacturer(java.util.Set shipperItemManufacturer)
void | setShipperItemPrivateNotes(java.lang.String shipperItemPrivateNotes)
void | setShipToId(java.lang.String shipToId)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setTrackings(java.util.Map trackings)
void | setUnit(java.lang.String unit)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

OnloanShipperItemVO

public OnloanShipperItemVO(OnloanShipperItemPK pk,
                           java.lang.String loanNumber,
                           java.math.BigDecimal arSub,
                           java.math.BigDecimal arShip,
                           java.math.BigDecimal arOpen,
                           java.math.BigDecimal arDiscount,
                           java.math.BigDecimal arNet,
                           java.math.BigDecimal arTax,
                           java.math.BigDecimal arTotal,
                           java.lang.String referenceDoc1,
                           java.lang.String referenceDoc2,
                           java.util.Date dateShipped,
                           java.util.Date dateInvoiced,
                           java.lang.String shipVia,
                           java.lang.String shipToId,
                           java.lang.String status,
                           java.lang.String partNumber,
                           java.lang.String partType,
                           java.lang.String partFrom,
                           java.lang.String modelNumber,
                           java.lang.String revision,
                           java.lang.String location,
                           java.math.BigDecimal loanQuantity,
                           java.math.BigDecimal quantityShip,
                           java.math.BigDecimal listPrice,
                           java.math.BigDecimal averageCost,
                           java.lang.String unit,
                           java.math.BigDecimal discount,
                           java.math.BigDecimal taxRate,
                           java.lang.String description,
                           java.lang.String mfg,
                           java.lang.String mpn,
                           java.lang.String serialNumber,
                           java.lang.String shipperItemComments,
                           java.lang.String shipperItemPrivateNotes)
full constructor

OnloanShipperItemVO

public OnloanShipperItemVO()
default constructor

OnloanShipperItemVO

public OnloanShipperItemVO(OnloanShipperItemPK pk,
                           java.lang.String loanNumber,
                           java.lang.String status,
                           java.lang.String partNumber,
                           java.lang.String partType,
                           java.lang.String partFrom)
minimal constructor

Method Detail

getArSub

public java.math.BigDecimal getArSub()

setArSub

public void setArSub(java.math.BigDecimal arSub)

getArShip

public java.math.BigDecimal getArShip()

setArShip

public void setArShip(java.math.BigDecimal arShip)

getArOpen

public java.math.BigDecimal getArOpen()

setArOpen

public void setArOpen(java.math.BigDecimal arOpen)

getArDiscount

public java.math.BigDecimal getArDiscount()

setArDiscount

public void setArDiscount(java.math.BigDecimal arDiscount)

getArNet

public java.math.BigDecimal getArNet()

setArNet

public void setArNet(java.math.BigDecimal arNet)

getArTax

public java.math.BigDecimal getArTax()

setArTax

public void setArTax(java.math.BigDecimal arTax)

getArTotal

public java.math.BigDecimal getArTotal()

setArTotal

public void setArTotal(java.math.BigDecimal arTotal)

getReferenceDoc1

public java.lang.String getReferenceDoc1()

setReferenceDoc1

public void setReferenceDoc1(java.lang.String referenceDoc1)

getReferenceDoc2

public java.lang.String getReferenceDoc2()

setReferenceDoc2

public void setReferenceDoc2(java.lang.String referenceDoc2)

getDateShipped

public java.util.Date getDateShipped()

setDateShipped

public void setDateShipped(java.util.Date dateShipped)

getDateInvoiced

public java.util.Date getDateInvoiced()

setDateInvoiced

public void setDateInvoiced(java.util.Date dateInvoiced)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getShipToId

public java.lang.String getShipToId()

setShipToId

public void setShipToId(java.lang.String shipToId)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getQuantityShip

public java.math.BigDecimal getQuantityShip()

setQuantityShip

public void setQuantityShip(java.math.BigDecimal quantityShip)

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

getAverageCost

public java.math.BigDecimal getAverageCost()

setAverageCost

public void setAverageCost(java.math.BigDecimal averageCost)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getSerialNumber

public java.lang.String getSerialNumber()

setSerialNumber

public void setSerialNumber(java.lang.String serialNumber)

getShipperItemComments

public java.lang.String getShipperItemComments()

setShipperItemComments

public void setShipperItemComments(java.lang.String shipperItemComments)

getShipperItemPrivateNotes

public java.lang.String getShipperItemPrivateNotes()

getCheckNumber

public java.lang.String getCheckNumber()

getDue

public java.math.BigDecimal getDue()

getDatePaid

public java.util.Date getDatePaid()

getPaid

public java.math.BigDecimal getPaid()

setShipperItemPrivateNotes

public void setShipperItemPrivateNotes(java.lang.String shipperItemPrivateNotes)

setCheckNumber

public void setCheckNumber(java.lang.String checkNumber)

setDue

public void setDue(java.math.BigDecimal due)

setDatePaid

public void setDatePaid(java.util.Date datePaid)

setPaid

public void setPaid(java.math.BigDecimal paid)

getShipperItemManufacturer

public java.util.Set getShipperItemManufacturer()

setShipperItemManufacturer

public void setShipperItemManufacturer(java.util.Set shipperItemManufacturer)

getLoanNumber

public java.lang.String getLoanNumber()

setLoanNumber

public void setLoanNumber(java.lang.String loanNumber)

setPk

public void setPk(OnloanShipperItemPK pk)

getPk

public OnloanShipperItemPK getPk()

getLoanQuantity

public java.math.BigDecimal getLoanQuantity()

setLoanQuantity

public void setLoanQuantity(java.math.BigDecimal loanQuantity)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getQuantityRec

public java.math.BigDecimal getQuantityRec()

setQuantityRec

public void setQuantityRec(java.math.BigDecimal quantityRec)

getLocations

public java.util.Map getLocations()

setLocations

public void setLocations(java.util.Map locations)

getTrackings

public java.util.Map getTrackings()

setTrackings

public void setTrackings(java.util.Map trackings)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OnloanShipperVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OnloanShipperVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.OnloanShipperVO
All Implemented Interfaces:
java.io.Serializable
public class OnloanShipperVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
OnloanShipperVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.math.BigDecimal | getArDiscount()
java.math.BigDecimal | getArFreight()
java.math.BigDecimal | getArGl1Recorded()
java.math.BigDecimal | getArGl2Paid()
java.lang.String | getArInvoiceNumber()
java.math.BigDecimal | getArNet()
java.lang.String | getArNetSet()
java.math.BigDecimal | getArOpen()
java.math.BigDecimal | getArPaidGl()
java.math.BigDecimal | getArPaidInvoice()
java.math.BigDecimal | getArShip()
java.math.BigDecimal | getArSub()
java.math.BigDecimal | getArTax()
java.lang.String | getArTaxSet()
java.math.BigDecimal | getArTotal()
java.lang.String | getBatch()
CustomerVendorAddressInfoVO | getBillToAddressInfo()
java.lang.String | getBillToId()
java.lang.String | getBp()
java.lang.String | getCarrier()
java.lang.String | getCarrierAccount()
java.lang.String | getChangeOrder()
java.lang.String | getCheckNumber()
java.lang.String | getCoComments()
java.lang.String | getCompanyUnitId()
java.lang.String | getCurrency()
CustomerVendorAddressInfoVO | getCustomerAddressInfo()
java.lang.String | getCustomerId()
java.lang.String | getCustomerPo()
java.util.Date | getDateInvoiced()
java.util.Date | getDatePaid()
java.util.Date | getDateShipped()
java.lang.String | getDebitAccount()
java.math.BigDecimal | getDue()
java.lang.String | getFreightBill()
java.lang.String | getFreightRateCode()
java.lang.String | getGrossWeight()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getInvoicedBy()
java.util.Date | getInvoicedDate()
java.lang.String | getLanguage()
java.util.Date | getLastChangedate()
int | getLastChangeTime()
java.lang.String | getLastChangeUser()
java.lang.String | getLnShipperNumber()
java.lang.String | getLoanNumber()
java.util.Set | getOnloanShipperItems()
java.lang.String | getOrigin()
java.lang.String | getOTran()
java.math.BigDecimal | getPaid()
java.util.Date | getPayDate()
java.lang.String | getRelatedDoc()
java.lang.String | getRemitId()
java.lang.String | getRTran()
java.lang.String | getSalesman()
java.lang.String | getShippedBy()
java.util.Date | getShippedDate()
java.lang.String | getShipperBp()
java.lang.String | getShipperComments()
java.lang.String | getShipperPrivateNotes()
CustomerVendorAddressInfoVO | getShipToAddressInfo()
java.lang.String | getShipToId()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.lang.String | getTerms()
java.lang.String | getTracking()
int | hashCode()
void | setAdate(java.util.Date adate)
void | setArDiscount(java.math.BigDecimal arDiscount)
void | setArFreight(java.math.BigDecimal arFreight)
void | setArGl1Recorded(java.math.BigDecimal arGl1Recorded)
void | setArGl2Paid(java.math.BigDecimal arGl2Paid)
void | setArInvoiceNumber(java.lang.String arInvoiceNumber)
void | setArNet(java.math.BigDecimal arNet)
void | setArNetSet(java.lang.String arNetSet)
void | setArOpen(java.math.BigDecimal arOpen)
void | setArPaidGl(java.math.BigDecimal arPaidGl)
void | setArPaidInvoice(java.math.BigDecimal arPaidInvoice)
void | setArShip(java.math.BigDecimal arShip)
void | setArSub(java.math.BigDecimal arSub)
void | setArTax(java.math.BigDecimal arTax)
void | setArTaxSet(java.lang.String arTaxSet)
void | setArTotal(java.math.BigDecimal arTotal)
void | setBatch(java.lang.String batch)
void | setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | setBillToId(java.lang.String billToId)
void | setBp(java.lang.String bp)
void | setCarrier(java.lang.String carrier)
void | setCarrierAccount(java.lang.String carrierAccount)
void | setChangeOrder(java.lang.String changeOrder)
void | setCheckNumber(java.lang.String checkNumber)
void | setCoComments(java.lang.String coComments)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCurrency(java.lang.String currency)
void | setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | setCustomerId(java.lang.String customerId)
void | setCustomerPo(java.lang.String customerPo)
void | setDateInvoiced(java.util.Date dateInvoiced)
void | setDatePaid(java.util.Date datePaid)
void | setDateShipped(java.util.Date dateShipped)
void | setDebitAccount(java.lang.String debitAccount)
void | setDue(java.math.BigDecimal due)
void | setFreightBill(java.lang.String freightBill)
void | setFreightRateCode(java.lang.String freightRateCode)
void | setGrossWeight(java.lang.String grossWeight)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setInvoicedBy(java.lang.String invoicedBy)
void | setInvoicedDate(java.util.Date invoicedDate)
void | setLanguage(java.lang.String language)
void | setLastChangedate(java.util.Date lastChangedate)
void | setLastChangeTime(int lastChangeTime)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLnShipperNumber(java.lang.String lnShipperNumber)
void | setLoanNumber(java.lang.String loanNumber)
void | setOnloanShipperItems(java.util.Set onloanShipperItems)
void | setOrigin(java.lang.String origin)
void | setOTran(java.lang.String oTran)
void | setPaid(java.math.BigDecimal paid)
void | setPayDate(java.util.Date payDate)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setRemitId(java.lang.String remitId)
void | setRTran(java.lang.String rTran)
void | setSalesman(java.lang.String salesman)
void | setShippedBy(java.lang.String shippedBy)
void | setShippedDate(java.util.Date shippedDate)
void | setShipperBp(java.lang.String shipperBp)
void | setShipperComments(java.lang.String shipperComments)
void | setShipperPrivateNotes(java.lang.String shipperPrivateNotes)
void | setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | setShipToId(java.lang.String shipToId)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setTerms(java.lang.String terms)
void | setTracking(java.lang.String tracking)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

OnloanShipperVO

public OnloanShipperVO()
Method Detail

getLnShipperNumber

public java.lang.String getLnShipperNumber()

setLnShipperNumber

public void setLnShipperNumber(java.lang.String lnShipperNumber)

getLoanNumber

public java.lang.String getLoanNumber()

setLoanNumber

public void setLoanNumber(java.lang.String loanNumber)

getArInvoiceNumber

public java.lang.String getArInvoiceNumber()

setArInvoiceNumber

public void setArInvoiceNumber(java.lang.String arInvoiceNumber)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getBillToId

public java.lang.String getBillToId()

setBillToId

public void setBillToId(java.lang.String billToId)

getCustomerPo

public java.lang.String getCustomerPo()

setCustomerPo

public void setCustomerPo(java.lang.String customerPo)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangedate

public java.util.Date getLastChangedate()

setLastChangedate

public void setLastChangedate(java.util.Date lastChangedate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getArSub

public java.math.BigDecimal getArSub()

setArSub

public void setArSub(java.math.BigDecimal arSub)

getArShip

public java.math.BigDecimal getArShip()

setArShip

public void setArShip(java.math.BigDecimal arShip)

getArOpen

public java.math.BigDecimal getArOpen()

setArOpen

public void setArOpen(java.math.BigDecimal arOpen)

getArDiscount

public java.math.BigDecimal getArDiscount()

setArDiscount

public void setArDiscount(java.math.BigDecimal arDiscount)

getArNet

public java.math.BigDecimal getArNet()

setArNet

public void setArNet(java.math.BigDecimal arNet)

getArTax

public java.math.BigDecimal getArTax()

setArTax

public void setArTax(java.math.BigDecimal arTax)

getArFreight

public java.math.BigDecimal getArFreight()

setArFreight

public void setArFreight(java.math.BigDecimal arFreight)

getArTotal

public java.math.BigDecimal getArTotal()

setArTotal

public void setArTotal(java.math.BigDecimal arTotal)

getArPaidInvoice

public java.math.BigDecimal getArPaidInvoice()

setArPaidInvoice

public void setArPaidInvoice(java.math.BigDecimal arPaidInvoice)

getArPaidGl

public java.math.BigDecimal getArPaidGl()

setArPaidGl

public void setArPaidGl(java.math.BigDecimal arPaidGl)

getArGl1Recorded

public java.math.BigDecimal getArGl1Recorded()

setArGl1Recorded

public void setArGl1Recorded(java.math.BigDecimal arGl1Recorded)

getArGl2Paid

public java.math.BigDecimal getArGl2Paid()

setArGl2Paid

public void setArGl2Paid(java.math.BigDecimal arGl2Paid)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getSalesman

public java.lang.String getSalesman()

setSalesman

public void setSalesman(java.lang.String salesman)

getShippedDate

public java.util.Date getShippedDate()

setShippedDate

public void setShippedDate(java.util.Date shippedDate)

getShippedBy

public java.lang.String getShippedBy()

setShippedBy

public void setShippedBy(java.lang.String shippedBy)

getInvoicedDate

public java.util.Date getInvoicedDate()

setInvoicedDate

public void setInvoicedDate(java.util.Date invoicedDate)

getInvoicedBy

public java.lang.String getInvoicedBy()

setInvoicedBy

public void setInvoicedBy(java.lang.String invoicedBy)

getShipToId

public java.lang.String getShipToId()

setShipToId

public void setShipToId(java.lang.String shipToId)

getRemitId

public java.lang.String getRemitId()

setRemitId

public void setRemitId(java.lang.String remitId)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAccount

public java.lang.String getCarrierAccount()

setCarrierAccount

public void setCarrierAccount(java.lang.String carrierAccount)

getFreightRateCode

public java.lang.String getFreightRateCode()

setFreightRateCode

public void setFreightRateCode(java.lang.String freightRateCode)

getGrossWeight

public java.lang.String getGrossWeight()

setGrossWeight

public void setGrossWeight(java.lang.String grossWeight)

getTracking

public java.lang.String getTracking()

setTracking

public void setTracking(java.lang.String tracking)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getDateShipped

public java.util.Date getDateShipped()

setDateShipped

public void setDateShipped(java.util.Date dateShipped)

getDateInvoiced

public java.util.Date getDateInvoiced()

setDateInvoiced

public void setDateInvoiced(java.util.Date dateInvoiced)

getFreightBill

public java.lang.String getFreightBill()

setFreightBill

public void setFreightBill(java.lang.String freightBill)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getDebitAccount

public java.lang.String getDebitAccount()

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

getBp

public java.lang.String getBp()

setBp

public void setBp(java.lang.String bp)

getShipperComments

public java.lang.String getShipperComments()

setShipperComments

public void setShipperComments(java.lang.String shipperComments)

getShipperPrivateNotes

public java.lang.String getShipperPrivateNotes()

setShipperPrivateNotes

public void setShipperPrivateNotes(java.lang.String shipperPrivateNotes)

getDue

public java.math.BigDecimal getDue()

setDue

public void setDue(java.math.BigDecimal due)

getPayDate

public java.util.Date getPayDate()

setPayDate

public void setPayDate(java.util.Date payDate)

getDatePaid

public java.util.Date getDatePaid()

setDatePaid

public void setDatePaid(java.util.Date datePaid)

getCheckNumber

public java.lang.String getCheckNumber()

setCheckNumber

public void setCheckNumber(java.lang.String checkNumber)

getPaid

public java.math.BigDecimal getPaid()

setPaid

public void setPaid(java.math.BigDecimal paid)

getOTran

public java.lang.String getOTran()

setOTran

public void setOTran(java.lang.String oTran)

getRTran

public java.lang.String getRTran()

setRTran

public void setRTran(java.lang.String rTran)

getLastChangeTime

public int getLastChangeTime()

setLastChangeTime

public void setLastChangeTime(int lastChangeTime)

getShipToAddressInfo

public CustomerVendorAddressInfoVO getShipToAddressInfo()

setShipToAddressInfo

public void setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)

getBillToAddressInfo

public CustomerVendorAddressInfoVO getBillToAddressInfo()

setBillToAddressInfo

public void setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)

getArTaxSet

public java.lang.String getArTaxSet()

getArNetSet

public java.lang.String getArNetSet()

getBatch

public java.lang.String getBatch()

getShipperBp

public java.lang.String getShipperBp()

getCoComments

public java.lang.String getCoComments()

setArTaxSet

public void setArTaxSet(java.lang.String arTaxSet)

setArNetSet

public void setArNetSet(java.lang.String arNetSet)

setBatch

public void setBatch(java.lang.String batch)

setShipperBp

public void setShipperBp(java.lang.String shipperBp)

setCoComments

public void setCoComments(java.lang.String coComments)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getOnloanShipperItems

public java.util.Set getOnloanShipperItems()

setOnloanShipperItems

public void setOnloanShipperItems(java.util.Set onloanShipperItems)

getCustomerAddressInfo

public CustomerVendorAddressInfoVO getCustomerAddressInfo()

setCustomerAddressInfo

public void setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OnLoanVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OnLoanVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.OnLoanVO
All Implemented Interfaces:
java.io.Serializable
public class OnLoanVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
OnLoanVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getActual()
java.util.Date | getAdate()
java.math.BigDecimal | getArDisc()
java.math.BigDecimal | getArFreight()
java.math.BigDecimal | getArGl1Recorded()
java.math.BigDecimal | getArGl2Paid()
java.math.BigDecimal | getArNet()
java.lang.String | getArNetSet()
java.math.BigDecimal | getArOpen()
java.math.BigDecimal | getArPaidGl()
java.math.BigDecimal | getArPaidInv()
java.math.BigDecimal | getArShip()
java.math.BigDecimal | getArSub()
java.math.BigDecimal | getArTax()
java.lang.String | getArTaxSet()
java.math.BigDecimal | getArTotal()
CustomerVendorAddressInfoVO | getBillToAddressInfo()
java.lang.String | getBilltoId()
java.lang.String | getBp()
java.lang.String | getCarrier()
java.lang.String | getCarrierAcct()
java.lang.String | getChangeOrder()
java.lang.String | getCompanyUnitId()
java.lang.String | getContact()
java.lang.String | getCurrency()
CustomerVendorAddressInfoVO | getCustomerAddressInfo()
java.lang.String | getCustomerEmail()
java.lang.String | getCustomerId()
java.lang.String | getCustomerPo()
java.lang.String | getDebitAccount()
byte | getDelay()
java.util.Date | getDelivery()
java.util.Date | getDesired()
java.lang.String | getFob()
java.lang.String | getFreightWho()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getLoanComments()
java.util.Date | getLoanDate()
java.lang.String | getLoanNotes()
java.lang.String | getLoanNumber()
java.lang.String | getLocate()
java.util.Set | getOnLoanDocuments()
java.util.Set | getOnLoanItems()
java.lang.String | getOrigin()
java.util.Date | getOriginal()
java.lang.String | getPriority()
java.lang.String | getProject()
java.lang.String | getQt()
java.lang.String | getReldoc()
java.lang.String | getRequestor()
java.util.Date | getReviewed()
java.lang.String | getReviewedBy()
java.lang.String | getSalesman()
short | getSalesmanId()
java.lang.String | getSgSo()
java.lang.String | getShipAcct()
CustomerVendorAddressInfoVO | getShipToAddressInfo()
java.lang.String | getShiptoId()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.lang.String | getTerms()
java.lang.Integer | getVersion()
int | hashCode()
void | setActual(java.util.Date actual)
void | setAdate(java.util.Date adate)
void | setArDisc(java.math.BigDecimal arDisc)
void | setArFreight(java.math.BigDecimal arFreight)
void | setArGl1Recorded(java.math.BigDecimal arGl1Recorded)
void | setArGl2Paid(java.math.BigDecimal arGl2Paid)
void | setArNet(java.math.BigDecimal arNet)
void | setArNetSet(java.lang.String arNetSet)
void | setArOpen(java.math.BigDecimal arOpen)
void | setArPaidGl(java.math.BigDecimal arPaidGl)
void | setArPaidInv(java.math.BigDecimal arPaidInv)
void | setArShip(java.math.BigDecimal arShip)
void | setArSub(java.math.BigDecimal arSub)
void | setArTax(java.math.BigDecimal arTax)
void | setArTaxSet(java.lang.String arTaxSet)
void | setArTotal(java.math.BigDecimal arTotal)
void | setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | setBilltoId(java.lang.String billtoId)
void | setBp(java.lang.String bp)
void | setCarrier(java.lang.String carrier)
void | setCarrierAcct(java.lang.String carrierAcct)
void | setChangeOrder(java.lang.String changeOrder)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setContact(java.lang.String contact)
void | setCurrency(java.lang.String currency)
void | setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | setCustomerEmail(java.lang.String customerEmail)
void | setCustomerId(java.lang.String customerId)
void | setCustomerPo(java.lang.String customerPo)
void | setDebitAccount(java.lang.String debitAccount)
void | setDelay(byte delay)
void | setDelivery(java.util.Date delivery)
void | setDesired(java.util.Date desired)
void | setFob(java.lang.String fob)
void | setFreightWho(java.lang.String freightWho)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLoanComments(java.lang.String loanComments)
void | setLoanDate(java.util.Date loanDate)
void | setLoanNotes(java.lang.String loanNotes)
void | setLoanNumber(java.lang.String loanNumber)
void | setLocate(java.lang.String locate)
void | setOnLoanDocuments(java.util.Set onLoanDocuments)
void | setOnLoanItems(java.util.Set onLoanItems)
void | setOrigin(java.lang.String origin)
void | setOriginal(java.util.Date original)
void | setPriority(java.lang.String priority)
void | setProject(java.lang.String project)
void | setQt(java.lang.String qt)
void | setReldoc(java.lang.String reldoc)
void | setRequestor(java.lang.String requestor)
void | setReviewed(java.util.Date reviewed)
void | setReviewedBy(java.lang.String reviewedBy)
void | setSalesman(java.lang.String salesman)
void | setSalesmanId(short salesmanId)
void | setSgSo(java.lang.String sgSo)
void | setShipAcct(java.lang.String shipAcct)
void | setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | setShiptoId(java.lang.String shiptoId)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setTerms(java.lang.String terms)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

OnLoanVO

public OnLoanVO()
default constructor

Method Detail

getLoanNumber

public java.lang.String getLoanNumber()

setLoanNumber

public void setLoanNumber(java.lang.String loanNumber)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getArNetSet

public java.lang.String getArNetSet()

setArNetSet

public void setArNetSet(java.lang.String arNetSet)

getArTaxSet

public java.lang.String getArTaxSet()

setArTaxSet

public void setArTaxSet(java.lang.String arTaxSet)

getArSub

public java.math.BigDecimal getArSub()

setArSub

public void setArSub(java.math.BigDecimal arSub)

getArDisc

public java.math.BigDecimal getArDisc()

setArDisc

public void setArDisc(java.math.BigDecimal arDisc)

getArNet

public java.math.BigDecimal getArNet()

setArNet

public void setArNet(java.math.BigDecimal arNet)

getArShip

public java.math.BigDecimal getArShip()

setArShip

public void setArShip(java.math.BigDecimal arShip)

getArOpen

public java.math.BigDecimal getArOpen()

setArOpen

public void setArOpen(java.math.BigDecimal arOpen)

getArTax

public java.math.BigDecimal getArTax()

setArTax

public void setArTax(java.math.BigDecimal arTax)

getArFreight

public java.math.BigDecimal getArFreight()

setArFreight

public void setArFreight(java.math.BigDecimal arFreight)

getArTotal

public java.math.BigDecimal getArTotal()

setArTotal

public void setArTotal(java.math.BigDecimal arTotal)

getArPaidInv

public java.math.BigDecimal getArPaidInv()

setArPaidInv

public void setArPaidInv(java.math.BigDecimal arPaidInv)

getArPaidGl

public java.math.BigDecimal getArPaidGl()

setArPaidGl

public void setArPaidGl(java.math.BigDecimal arPaidGl)

getArGl1Recorded

public java.math.BigDecimal getArGl1Recorded()

setArGl1Recorded

public void setArGl1Recorded(java.math.BigDecimal arGl1Recorded)

getArGl2Paid

public java.math.BigDecimal getArGl2Paid()

setArGl2Paid

public void setArGl2Paid(java.math.BigDecimal arGl2Paid)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getBilltoId

public java.lang.String getBilltoId()

setBilltoId

public void setBilltoId(java.lang.String billtoId)

getCustomerEmail

public java.lang.String getCustomerEmail()

setCustomerEmail

public void setCustomerEmail(java.lang.String customerEmail)

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getReviewed

public java.util.Date getReviewed()

setReviewed

public void setReviewed(java.util.Date reviewed)

getReviewedBy

public java.lang.String getReviewedBy()

setReviewedBy

public void setReviewedBy(java.lang.String reviewedBy)

getDelivery

public java.util.Date getDelivery()

setDelivery

public void setDelivery(java.util.Date delivery)

getDesired

public java.util.Date getDesired()

setDesired

public void setDesired(java.util.Date desired)

getDelay

public byte getDelay()

setDelay

public void setDelay(byte delay)

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getOriginal

public java.util.Date getOriginal()

setOriginal

public void setOriginal(java.util.Date original)

getActual

public java.util.Date getActual()

setActual

public void setActual(java.util.Date actual)

getShiptoId

public java.lang.String getShiptoId()

setShiptoId

public void setShiptoId(java.lang.String shiptoId)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAcct

public java.lang.String getCarrierAcct()

setCarrierAcct

public void setCarrierAcct(java.lang.String carrierAcct)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getShipAcct

public java.lang.String getShipAcct()

setShipAcct

public void setShipAcct(java.lang.String shipAcct)

getFreightWho

public java.lang.String getFreightWho()

setFreightWho

public void setFreightWho(java.lang.String freightWho)

getFob

public java.lang.String getFob()

setFob

public void setFob(java.lang.String fob)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getSalesman

public java.lang.String getSalesman()

setSalesman

public void setSalesman(java.lang.String salesman)

getSalesmanId

public short getSalesmanId()

setSalesmanId

public void setSalesmanId(short salesmanId)

getQt

public java.lang.String getQt()

setQt

public void setQt(java.lang.String qt)

getSgSo

public java.lang.String getSgSo()

setSgSo

public void setSgSo(java.lang.String sgSo)

getRequestor

public java.lang.String getRequestor()

setRequestor

public void setRequestor(java.lang.String requestor)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

getReldoc

public java.lang.String getReldoc()

setReldoc

public void setReldoc(java.lang.String reldoc)

getBp

public java.lang.String getBp()

setBp

public void setBp(java.lang.String bp)

getLoanComments

public java.lang.String getLoanComments()

setLoanComments

public void setLoanComments(java.lang.String loanComments)

getLoanNotes

public java.lang.String getLoanNotes()

setLoanNotes

public void setLoanNotes(java.lang.String loanNotes)

getVersion

public java.lang.Integer getVersion()

setVersion

public void setVersion(java.lang.Integer version)

getOnLoanItems

public java.util.Set getOnLoanItems()

getLoanDate

public java.util.Date getLoanDate()

getCustomerId

public java.lang.String getCustomerId()

getCustomerPo

public java.lang.String getCustomerPo()

getBillToAddressInfo

public CustomerVendorAddressInfoVO getBillToAddressInfo()

getCustomerAddressInfo

public CustomerVendorAddressInfoVO getCustomerAddressInfo()

getShipToAddressInfo

public CustomerVendorAddressInfoVO getShipToAddressInfo()

setOnLoanItems

public void setOnLoanItems(java.util.Set onLoanItems)

setLoanDate

public void setLoanDate(java.util.Date loanDate)

setCustomerId

public void setCustomerId(java.lang.String customerId)

setCustomerPo

public void setCustomerPo(java.lang.String customerPo)

setBillToAddressInfo

public void setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)

setCustomerAddressInfo

public void setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)

setShipToAddressInfo

public void setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getDebitAccount

public java.lang.String getDebitAccount()

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

getOnLoanDocuments

public java.util.Set getOnLoanDocuments()

setOnLoanDocuments

public void setOnLoanDocuments(java.util.Set onLoanDocuments)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OnTimeAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OnTimeAgent

java.lang.Object
    extended by  bb.common.OnTimeAgent
All Implemented Interfaces:
java.io.Serializable
public class OnTimeAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
OnTimeAgent()
Method Summary
int | getDay1()
int | getDay2()
int | getMonths()
boolean | isList12MonthAvg()
boolean | isListFiscalYear()
boolean | isListYearToDate()
void | setDay1(int day1)
void | setDay2(int day2)
void | setList12MonthAvg(boolean list12MonthAvg)
void | setListFiscalYear(boolean listFiscalYear)
void | setListYearToDate(boolean listYearToDate)
void | setMonths(int months)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OnTimeAgent

public OnTimeAgent()
Method Detail

getDay1

public int getDay1()

setDay1

public void setDay1(int day1)

getDay2

public int getDay2()

setDay2

public void setDay2(int day2)

isList12MonthAvg

public boolean isList12MonthAvg()

setList12MonthAvg

public void setList12MonthAvg(boolean list12MonthAvg)

isListFiscalYear

public boolean isListFiscalYear()

setListFiscalYear

public void setListFiscalYear(boolean listFiscalYear)

isListYearToDate

public boolean isListYearToDate()

setListYearToDate

public void setListYearToDate(boolean listYearToDate)

getMonths

public int getMonths()

setMonths

public void setMonths(int months)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OntimeDeliveryRateListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OntimeDeliveryRateListResult

java.lang.Object
    extended by  bb.common.OntimeDeliveryRateListResult
All Implemented Interfaces:
java.io.Serializable
public class OntimeDeliveryRateListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
OntimeDeliveryRateListResult()
Method Summary
java.lang.String | getId()
java.lang.String | getName()
java.math.BigDecimal | getOnTimeDelivedItemCount()
java.math.BigDecimal | getOnTimeDeliveryRate()
java.math.BigDecimal | getTotalItemCount()
void | setId(java.lang.String id)
void | setName(java.lang.String name)
void | setOnTimeDelivedItemCount(java.math.BigDecimal onTimeDelivedItemCount)
void | setOnTimeDeliveryRate(java.math.BigDecimal onTimeDeliveryRate)
void | setTotalItemCount(java.math.BigDecimal totalItemCount)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OntimeDeliveryRateListResult

public OntimeDeliveryRateListResult()
Method Detail

getOnTimeDelivedItemCount

public java.math.BigDecimal getOnTimeDelivedItemCount()

setOnTimeDelivedItemCount

public void setOnTimeDelivedItemCount(java.math.BigDecimal onTimeDelivedItemCount)

getOnTimeDeliveryRate

public java.math.BigDecimal getOnTimeDeliveryRate()

setOnTimeDeliveryRate

public void setOnTimeDeliveryRate(java.math.BigDecimal onTimeDeliveryRate)

getTotalItemCount

public java.math.BigDecimal getTotalItemCount()

setTotalItemCount

public void setTotalItemCount(java.math.BigDecimal totalItemCount)

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OntimeDeliveryRateResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OntimeDeliveryRateResult

java.lang.Object
    extended by  bb.common.OntimeDeliveryRateResult
All Implemented Interfaces:
java.io.Serializable
public class OntimeDeliveryRateResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
OntimeDeliveryRateResult()
Method Summary
CustomerVendorAddressInfoVO | getAddressInfo()
java.math.BigDecimal | getOnTimeDelivedItemCount()
java.math.BigDecimal | getOnTimeDeliveryRate()
java.math.BigDecimal | getTotalItemCount()
void | setAddressInfo(CustomerVendorAddressInfoVO addressInfo)
void | setOnTimeDelivedItemCount(java.math.BigDecimal onTimeDelivedItemCount)
void | setOnTimeDeliveryRate(java.math.BigDecimal onTimeDeliveryRate)
void | setTotalItemCount(java.math.BigDecimal totalItemCount)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OntimeDeliveryRateResult

public OntimeDeliveryRateResult()
Method Detail

getAddressInfo

public CustomerVendorAddressInfoVO getAddressInfo()

setAddressInfo

public void setAddressInfo(CustomerVendorAddressInfoVO addressInfo)

getOnTimeDelivedItemCount

public java.math.BigDecimal getOnTimeDelivedItemCount()

setOnTimeDelivedItemCount

public void setOnTimeDelivedItemCount(java.math.BigDecimal onTimeDelivedItemCount)

getOnTimeDeliveryRate

public java.math.BigDecimal getOnTimeDeliveryRate()

setOnTimeDeliveryRate

public void setOnTimeDeliveryRate(java.math.BigDecimal onTimeDeliveryRate)

getTotalItemCount

public java.math.BigDecimal getTotalItemCount()

setTotalItemCount

public void setTotalItemCount(java.math.BigDecimal totalItemCount)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OpCodeShortcutPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OpCodeShortcutPK

java.lang.Object
    extended by  bb.common.OpCodeShortcutPK
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<OpCodeShortcutPK>
public class OpCodeShortcutPK
extends java.lang.Object
implements java.io.Serializable, java.lang.Comparable<OpCodeShortcutPK>

See Also:
Serialized Form

Constructor Summary
OpCodeShortcutPK()
OpCodeShortcutPK(java.lang.String userName, java.lang.String operateCode)
Method Summary
int | compareTo(OpCodeShortcutPK other)
boolean | equals(java.lang.Object other)
java.lang.String | getOperateCode()
java.lang.String | getUserName()
int | hashCode()
void | setOperateCode(java.lang.String operateCode)
void | setUserName(java.lang.String userName)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

OpCodeShortcutPK

public OpCodeShortcutPK()

OpCodeShortcutPK

public OpCodeShortcutPK(java.lang.String userName,
                        java.lang.String operateCode)
Method Detail

setUserName

public void setUserName(java.lang.String userName)

getUserName

public java.lang.String getUserName()

setOperateCode

public void setOperateCode(java.lang.String operateCode)

getOperateCode

public java.lang.String getOperateCode()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

compareTo

public int compareTo(OpCodeShortcutPK other)
Specified by:
compareTo in interface java.lang.Comparable<OpCodeShortcutPK>
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OpCodeShortcutVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OpCodeShortcutVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.OpCodeShortcutVO
All Implemented Interfaces:
java.io.Serializable
public class OpCodeShortcutVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
OpCodeShortcutVO()
Method Summary
OpCodeShortcutPK | getOpCodeShortcutPK()
java.lang.String | getShortcut()
void | setOpCodeShortcutPK(OpCodeShortcutPK pk)
void | setShortcut(java.lang.String shortcut)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OpCodeShortcutVO

public OpCodeShortcutVO()
Method Detail

setOpCodeShortcutPK

public void setOpCodeShortcutPK(OpCodeShortcutPK pk)

getOpCodeShortcutPK

public OpCodeShortcutPK getOpCodeShortcutPK()

setShortcut

public void setShortcut(java.lang.String shortcut)

getShortcut

public java.lang.String getShortcut()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OperatingInstructionsInspectMethodItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OperatingInstructionsInspectMethodItemPK

java.lang.Object
    extended by  bb.common.OperatingInstructionsInspectMethodItemPK
All Implemented Interfaces:
java.io.Serializable
public class OperatingInstructionsInspectMethodItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
OperatingInstructionsInspectMethodItemPK()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Integer | getIi()
java.lang.String | getOperatingInstructionsNumber()
int | hashCode()
void | setIi(java.lang.Integer ii)
void | setOperatingInstructionsNumber(java.lang.String operatingInstructionsNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

OperatingInstructionsInspectMethodItemPK

public OperatingInstructionsInspectMethodItemPK()
Method Detail

getIi

public java.lang.Integer getIi()

setIi

public void setIi(java.lang.Integer ii)

getOperatingInstructionsNumber

public java.lang.String getOperatingInstructionsNumber()

setOperatingInstructionsNumber

public void setOperatingInstructionsNumber(java.lang.String operatingInstructionsNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OperatingInstructionsInspectMethodItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OperatingInstructionsInspectMethodItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.OperatingInstructionsInspectMethodItemVO
All Implemented Interfaces:
java.io.Serializable
public class OperatingInstructionsInspectMethodItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
OperatingInstructionsInspectMethodItemVO()
Method Summary
boolean | equals(java.lang.Object other)
InspectionReportInspectMethodVO | getOperatingInstructionsInspectMethod()
OperatingInstructionsInspectMethodItemPK | getPk()
int | hashCode()
void | setOperatingInstructionsInspectMethod(InspectionReportInspectMethodVO operatingInstructionsInspectMethod)
void | setPk(OperatingInstructionsInspectMethodItemPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

OperatingInstructionsInspectMethodItemVO

public OperatingInstructionsInspectMethodItemVO()
Method Detail

getPk

public OperatingInstructionsInspectMethodItemPK getPk()

setPk

public void setPk(OperatingInstructionsInspectMethodItemPK pk)

getOperatingInstructionsInspectMethod

public InspectionReportInspectMethodVO getOperatingInstructionsInspectMethod()

setOperatingInstructionsInspectMethod

public void setOperatingInstructionsInspectMethod(InspectionReportInspectMethodVO operatingInstructionsInspectMethod)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OperatingInstructionsInspectResultItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OperatingInstructionsInspectResultItemPK

java.lang.Object
    extended by  bb.common.OperatingInstructionsInspectResultItemPK
All Implemented Interfaces:
java.io.Serializable
public class OperatingInstructionsInspectResultItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
OperatingInstructionsInspectResultItemPK()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Integer | getIi()
java.lang.String | getOperatingInstructionsNumber()
int | hashCode()
void | setIi(java.lang.Integer ii)
void | setOperatingInstructionsNumber(java.lang.String operatingInstructionsNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

OperatingInstructionsInspectResultItemPK

public OperatingInstructionsInspectResultItemPK()
Method Detail

getIi

public java.lang.Integer getIi()

setIi

public void setIi(java.lang.Integer ii)

getOperatingInstructionsNumber

public java.lang.String getOperatingInstructionsNumber()

setOperatingInstructionsNumber

public void setOperatingInstructionsNumber(java.lang.String operatingInstructionsNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OperatingInstructionsInspectResultItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OperatingInstructionsInspectResultItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.OperatingInstructionsInspectResultItemVO
All Implemented Interfaces:
java.io.Serializable
public class OperatingInstructionsInspectResultItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
OperatingInstructionsInspectResultItemVO()
Method Summary
boolean | equals(java.lang.Object obj)
java.util.Date | getInspectionDate()
java.lang.String | getInspectionReportNumber()
java.lang.String | getInspectionResult()
java.lang.String | getInspectionResultSign()
OperatingInstructionsInspectResultItemPK | getPk()
int | hashCode()
void | setInspectionDate(java.util.Date inspectionDate)
void | setInspectionReportNumber(java.lang.String inspectionReportNumber)
void | setInspectionResult(java.lang.String inspectionResult)
void | setInspectionResultSign(java.lang.String inspectionResultSign)
void | setPk(OperatingInstructionsInspectResultItemPK pk)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OperatingInstructionsInspectResultItemVO

public OperatingInstructionsInspectResultItemVO()
Method Detail

getPk

public OperatingInstructionsInspectResultItemPK getPk()

setPk

public void setPk(OperatingInstructionsInspectResultItemPK pk)

getInspectionResultSign

public java.lang.String getInspectionResultSign()

setInspectionResultSign

public void setInspectionResultSign(java.lang.String inspectionResultSign)

getInspectionResult

public java.lang.String getInspectionResult()

setInspectionResult

public void setInspectionResult(java.lang.String inspectionResult)

getInspectionReportNumber

public java.lang.String getInspectionReportNumber()

setInspectionReportNumber

public void setInspectionReportNumber(java.lang.String inspectionReportNumber)

getInspectionDate

public java.util.Date getInspectionDate()

setInspectionDate

public void setInspectionDate(java.util.Date inspectionDate)

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OperatingInstructionsInspectStandardItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OperatingInstructionsInspectStandardItemPK

java.lang.Object
    extended by  bb.common.OperatingInstructionsInspectStandardItemPK
All Implemented Interfaces:
java.io.Serializable
public class OperatingInstructionsInspectStandardItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
OperatingInstructionsInspectStandardItemPK()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Integer | getIi()
java.lang.String | getOperatingInstructionsNumber()
int | hashCode()
void | setIi(java.lang.Integer ii)
void | setOperatingInstructionsNumber(java.lang.String operatingInstructionsNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

OperatingInstructionsInspectStandardItemPK

public OperatingInstructionsInspectStandardItemPK()
Method Detail

getIi

public java.lang.Integer getIi()

setIi

public void setIi(java.lang.Integer ii)

getOperatingInstructionsNumber

public java.lang.String getOperatingInstructionsNumber()

setOperatingInstructionsNumber

public void setOperatingInstructionsNumber(java.lang.String operatingInstructionsNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OperatingInstructionsInspectStandardItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OperatingInstructionsInspectStandardItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.OperatingInstructionsInspectStandardItemVO
All Implemented Interfaces:
java.io.Serializable
public class OperatingInstructionsInspectStandardItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
OperatingInstructionsInspectStandardItemVO()
Method Summary
boolean | equals(java.lang.Object other)
OperatingInstructionsInspectStandardVO | getOperatingInstructionsInspectStandard()
OperatingInstructionsInspectStandardItemPK | getPk()
int | hashCode()
void | setOperatingInstructionsInspectStandard(OperatingInstructionsInspectStandardVO operatingInstructionsInspectStandard)
void | setPk(OperatingInstructionsInspectStandardItemPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

OperatingInstructionsInspectStandardItemVO

public OperatingInstructionsInspectStandardItemVO()
Method Detail

getPk

public OperatingInstructionsInspectStandardItemPK getPk()

setPk

public void setPk(OperatingInstructionsInspectStandardItemPK pk)

getOperatingInstructionsInspectStandard

public OperatingInstructionsInspectStandardVO getOperatingInstructionsInspectStandard()

setOperatingInstructionsInspectStandard

public void setOperatingInstructionsInspectStandard(OperatingInstructionsInspectStandardVO operatingInstructionsInspectStandard)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OperatingInstructionsInspectStandardVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OperatingInstructionsInspectStandardVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.OperatingInstructionsInspectStandardVO
All Implemented Interfaces:
java.io.Serializable
public class OperatingInstructionsInspectStandardVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_II
Constructor Summary
OperatingInstructionsInspectStandardVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDescription()
java.lang.Integer | getIi()
int | hashCode()
void | setDescription(java.lang.String description)
void | setIi(java.lang.Integer ii)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_II

public static final java.lang.String ORDER_BY_II
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

OperatingInstructionsInspectStandardVO

public OperatingInstructionsInspectStandardVO()
Method Detail

getIi

public java.lang.Integer getIi()

setIi

public void setIi(java.lang.Integer ii)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OperatingInstructionsManualItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OperatingInstructionsManualItemPK

java.lang.Object
    extended by  bb.common.OperatingInstructionsManualItemPK
All Implemented Interfaces:
java.io.Serializable
public class OperatingInstructionsManualItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
OperatingInstructionsManualItemPK()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Integer | getIi()
java.lang.String | getOperatingInstructionsNumber()
int | hashCode()
void | setIi(java.lang.Integer ii)
void | setOperatingInstructionsNumber(java.lang.String operatingInstructionsNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

OperatingInstructionsManualItemPK

public OperatingInstructionsManualItemPK()
Method Detail

getIi

public java.lang.Integer getIi()

setIi

public void setIi(java.lang.Integer ii)

getOperatingInstructionsNumber

public java.lang.String getOperatingInstructionsNumber()

setOperatingInstructionsNumber

public void setOperatingInstructionsNumber(java.lang.String operatingInstructionsNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OperatingInstructionsManualItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OperatingInstructionsManualItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.OperatingInstructionsManualItemVO
All Implemented Interfaces:
java.io.Serializable
public class OperatingInstructionsManualItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
OperatingInstructionsManualItemVO()
Method Summary
boolean | equals(java.lang.Object other)
OperatingInstructionsManualVO | getOperatingInstructionsManual()
OperatingInstructionsManualItemPK | getPk()
int | hashCode()
void | setOperatingInstructionsManual(OperatingInstructionsManualVO operatingInstructionsManual)
void | setPk(OperatingInstructionsManualItemPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

OperatingInstructionsManualItemVO

public OperatingInstructionsManualItemVO()
Method Detail

getPk

public OperatingInstructionsManualItemPK getPk()

setPk

public void setPk(OperatingInstructionsManualItemPK pk)

getOperatingInstructionsManual

public OperatingInstructionsManualVO getOperatingInstructionsManual()

setOperatingInstructionsManual

public void setOperatingInstructionsManual(OperatingInstructionsManualVO operatingInstructionsManual)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OperatingInstructionsManualVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OperatingInstructionsManualVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.OperatingInstructionsManualVO
All Implemented Interfaces:
java.io.Serializable
public class OperatingInstructionsManualVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_II
Constructor Summary
OperatingInstructionsManualVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDescription()
java.lang.Integer | getIi()
int | hashCode()
void | setDescription(java.lang.String description)
void | setIi(java.lang.Integer ii)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_II

public static final java.lang.String ORDER_BY_II
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

OperatingInstructionsManualVO

public OperatingInstructionsManualVO()
Method Detail

getIi

public java.lang.Integer getIi()

setIi

public void setIi(java.lang.Integer ii)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OperatingInstructionsTypeVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OperatingInstructionsTypeVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.OperatingInstructionsTypeVO
All Implemented Interfaces:
java.io.Serializable
public class OperatingInstructionsTypeVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_II
static java.lang.String | ORDER_BY_SERIALNUMBERTYPE
Constructor Summary
OperatingInstructionsTypeVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDescription()
java.lang.Integer | getIi()
java.lang.String | getSerialNumberType()
int | hashCode()
void | setDescription(java.lang.String description)
void | setIi(java.lang.Integer ii)
void | setSerialNumberType(java.lang.String serialNumberType)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_II

public static final java.lang.String ORDER_BY_II
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_SERIALNUMBERTYPE

public static final java.lang.String ORDER_BY_SERIALNUMBERTYPE
See Also:
Constant Field Values
Constructor Detail

OperatingInstructionsTypeVO

public OperatingInstructionsTypeVO()
Method Detail

getIi

public java.lang.Integer getIi()

setIi

public void setIi(java.lang.Integer ii)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getSerialNumberType

public java.lang.String getSerialNumberType()

setSerialNumberType

public void setSerialNumberType(java.lang.String serialNumberType)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OperatingInstructionsUserStatisticalResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OperatingInstructionsUserStatisticalResult

java.lang.Object
    extended by  bb.common.OperatingInstructionsUserStatisticalResult
All Implemented Interfaces:
java.io.Serializable
public class OperatingInstructionsUserStatisticalResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ELAPSEDTIMEBYHOUR
static java.lang.String | ORDER_BY_ENDDATE
static java.lang.String | ORDER_BY_INSPECTIONREPORTNUMBER
static java.lang.String | ORDER_BY_OPERATINGINSTRUCTIONSDESCRIPTION
static java.lang.String | ORDER_BY_OPERATINGINSTRUCTIONSNUMBER
static java.lang.String | ORDER_BY_OPERATINGINSTRUCTIONSTYPEDESCRIPTION
static java.lang.String | ORDER_BY_PAUSEDTIME
static java.lang.String | ORDER_BY_PAUSEDTIMEBYHOUR
static java.lang.String | ORDER_BY_QUANTITY
static java.lang.String | ORDER_BY_RESPONSIBILITY
static java.lang.String | ORDER_BY_STAFF
static java.lang.String | ORDER_BY_STARTDATE
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
OperatingInstructionsUserStatisticalResult()
Method Summary
java.math.BigDecimal | getElapsedTimeByHour()
java.util.Date | getEndDate()
java.lang.String | getOperatingInstructionsDescription()
java.lang.String | getOperatingInstructionsNumber()
java.lang.String | getOperatingInstructionsTypeDescription()
java.util.Date | getPausedTime()
java.math.BigDecimal | getPausedTimeByHour()
java.math.BigDecimal | getQuantity()
java.lang.String | getResponsibility()
java.lang.String | getStaff()
java.util.Date | getStartDate()
java.lang.String | getStatus()
java.lang.String | getWorkOrderAndItemNumber()
void | setElapsedTimeByHour(java.math.BigDecimal elapsedTimeByHour)
void | setEndDate(java.util.Date endDate)
void | setOperatingInstructionsDescription(java.lang.String operatingInstructionsDescription)
void | setOperatingInstructionsNumber(java.lang.String operatingInstructionsNumber)
void | setOperatingInstructionsTypeDescription(java.lang.String operatingInstructionsTypeDescription)
void | setPausedTime(java.util.Date pausedTime)
void | setPausedTimeByHour(java.math.BigDecimal pausedTimeByHour)
void | setQuantity(java.math.BigDecimal quantity)
void | setResponsibility(java.lang.String responsibility)
void | setStaff(java.lang.String staff)
void | setStartDate(java.util.Date startDate)
void | setStatus(java.lang.String status)
void | setWorkOrderAndItemNumber(java.lang.String workOrderAndItemNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_OPERATINGINSTRUCTIONSNUMBER

public static final java.lang.String ORDER_BY_OPERATINGINSTRUCTIONSNUMBER
See Also:
Constant Field Values

ORDER_BY_RESPONSIBILITY

public static final java.lang.String ORDER_BY_RESPONSIBILITY
See Also:
Constant Field Values

ORDER_BY_OPERATINGINSTRUCTIONSTYPEDESCRIPTION

public static final java.lang.String ORDER_BY_OPERATINGINSTRUCTIONSTYPEDESCRIPTION
See Also:
Constant Field Values

ORDER_BY_OPERATINGINSTRUCTIONSDESCRIPTION

public static final java.lang.String ORDER_BY_OPERATINGINSTRUCTIONSDESCRIPTION
See Also:
Constant Field Values

ORDER_BY_QUANTITY

public static final java.lang.String ORDER_BY_QUANTITY
See Also:
Constant Field Values

ORDER_BY_STAFF

public static final java.lang.String ORDER_BY_STAFF
See Also:
Constant Field Values

ORDER_BY_STARTDATE

public static final java.lang.String ORDER_BY_STARTDATE
See Also:
Constant Field Values

ORDER_BY_ENDDATE

public static final java.lang.String ORDER_BY_ENDDATE
See Also:
Constant Field Values

ORDER_BY_PAUSEDTIME

public static final java.lang.String ORDER_BY_PAUSEDTIME
See Also:
Constant Field Values

ORDER_BY_ELAPSEDTIMEBYHOUR

public static final java.lang.String ORDER_BY_ELAPSEDTIMEBYHOUR
See Also:
Constant Field Values

ORDER_BY_PAUSEDTIMEBYHOUR

public static final java.lang.String ORDER_BY_PAUSEDTIMEBYHOUR
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_INSPECTIONREPORTNUMBER

public static final java.lang.String ORDER_BY_INSPECTIONREPORTNUMBER
See Also:
Constant Field Values
Constructor Detail

OperatingInstructionsUserStatisticalResult

public OperatingInstructionsUserStatisticalResult()
Method Detail

getElapsedTimeByHour

public java.math.BigDecimal getElapsedTimeByHour()

setElapsedTimeByHour

public void setElapsedTimeByHour(java.math.BigDecimal elapsedTimeByHour)

getEndDate

public java.util.Date getEndDate()

setEndDate

public void setEndDate(java.util.Date endDate)

getOperatingInstructionsDescription

public java.lang.String getOperatingInstructionsDescription()

setOperatingInstructionsDescription

public void setOperatingInstructionsDescription(java.lang.String operatingInstructionsDescription)

getOperatingInstructionsNumber

public java.lang.String getOperatingInstructionsNumber()

setOperatingInstructionsNumber

public void setOperatingInstructionsNumber(java.lang.String operatingInstructionsNumber)

getOperatingInstructionsTypeDescription

public java.lang.String getOperatingInstructionsTypeDescription()

setOperatingInstructionsTypeDescription

public void setOperatingInstructionsTypeDescription(java.lang.String operatingInstructionsTypeDescription)

getPausedTime

public java.util.Date getPausedTime()

setPausedTime

public void setPausedTime(java.util.Date pausedTime)

getPausedTimeByHour

public java.math.BigDecimal getPausedTimeByHour()

setPausedTimeByHour

public void setPausedTimeByHour(java.math.BigDecimal pausedTimeByHour)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getResponsibility

public java.lang.String getResponsibility()

setResponsibility

public void setResponsibility(java.lang.String responsibility)

getStaff

public java.lang.String getStaff()

setStaff

public void setStaff(java.lang.String staff)

getStartDate

public java.util.Date getStartDate()

setStartDate

public void setStartDate(java.util.Date startDate)

getWorkOrderAndItemNumber

public java.lang.String getWorkOrderAndItemNumber()

setWorkOrderAndItemNumber

public void setWorkOrderAndItemNumber(java.lang.String workOrderAndItemNumber)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OperatingInstructionsVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OperatingInstructionsVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.OperatingInstructionsVO
All Implemented Interfaces:
java.io.Serializable
public class OperatingInstructionsVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DRAWINGNUMBER
static java.lang.String | ORDER_BY_ELAPSEDTIMEBYHOUR
static java.lang.String | ORDER_BY_ENDDATE
static java.lang.String | ORDER_BY_INSPECTIONREPORTNUMBER
static java.lang.String | ORDER_BY_OPERATINGENVIRONMENT
static java.lang.String | ORDER_BY_OPERATINGINSTRUCTIONSDESCRIPTION
static java.lang.String | ORDER_BY_OPERATINGINSTRUCTIONSNOTES
static java.lang.String | ORDER_BY_OPERATINGINSTRUCTIONSNUMBER
static java.lang.String | ORDER_BY_OPERATINGINSTRUCTIONSTYPE
static java.lang.String | ORDER_BY_OPERATINGPROCESSNOTES
static java.lang.String | ORDER_BY_OPERATINGPROCESSRECORD
static java.lang.String | ORDER_BY_PAUSEDTIME
static java.lang.String | ORDER_BY_PAUSEDTIMEBYHOUR
static java.lang.String | ORDER_BY_PICKLISTORDERNUMBER
static java.lang.String | ORDER_BY_PROJECT
static java.lang.String | ORDER_BY_QUANTITY
static java.lang.String | ORDER_BY_RELATEDINSPECTORSIGN
static java.lang.String | ORDER_BY_REQUESTINSPECTIONDATE
static java.lang.String | ORDER_BY_RESPONSIBILITY
static java.lang.String | ORDER_BY_SERIAL
static java.lang.String | ORDER_BY_STAFF
static java.lang.String | ORDER_BY_STAFFSIGN
static java.lang.String | ORDER_BY_STARTDATE
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_WORKORDERANDITEMNUMBER
Constructor Summary
OperatingInstructionsVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.lang.String | getDrawingNumber()
java.math.BigDecimal | getElapsedTimeByHour()
java.util.Date | getEndDate()
java.lang.String | getInspectionContent()
java.lang.String | getInspectionOutputFileNumber()
java.lang.String | getInspectionReportNumber()
java.lang.String | getInspectionResult()
java.lang.String | getInspectionResultSign()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getOperatingInstructionsDescription()
java.util.Set<OperatingInstructionsInspectMethodItemVO> | getOperatingInstructionsInspectMethodItems()
java.util.Set<OperatingInstructionsInspectResultItemVO> | getOperatingInstructionsInspectResultItems()
java.util.Set<OperatingInstructionsInspectStandardItemVO> | getOperatingInstructionsInspectStandardItems()
java.util.Set<OperatingInstructionsManualItemVO> | getOperatingInstructionsManuals()
java.lang.String | getOperatingInstructionsNotes()
java.lang.String | getOperatingInstructionsNumber()
OperatingInstructionsTypeVO | getOperatingInstructionsType()
java.lang.Integer | getOperatingInstructionsTypeId()
java.util.Set<OperatingOutputFileItemVO> | getOperatingOutputFiles()
java.lang.String | getOperatingProcessNotes()
java.lang.String | getOperatingProcessRecord()
java.lang.String | getOrigin()
java.util.Date | getPausedTime()
java.math.BigDecimal | getPausedTimeByHour()
java.lang.String | getPickListOrderNumber()
java.lang.String | getProject()
java.math.BigDecimal | getQuantity()
java.lang.String | getRelatedInspectorSign()
java.util.Date | getRequestInspectionDate()
java.lang.String | getResolveResult()
java.lang.String | getResolveResultSign()
java.lang.String | getResponsibility()
java.lang.String | getSerial()
java.lang.String | getStaff()
java.lang.String | getStaffSign()
java.util.Date | getStartDate()
java.lang.String | getStatus()
java.lang.Integer | getVersion()
java.lang.String | getWorkOrderAndItemNumber()
int | hashCode()
boolean | isInspectionOutputFile()
boolean | isOperatingEnvironment()
void | setAdate(java.util.Date adate)
void | setDrawingNumber(java.lang.String drawingNumber)
void | setElapsedTimeByHour(java.math.BigDecimal elapsedTimeByHour)
void | setEndDate(java.util.Date endDate)
void | setInspectionContent(java.lang.String inspectionContent)
void | setInspectionOutputFile(boolean inspectionOutputFile)
void | setInspectionOutputFileNumber(java.lang.String inspectionOutputFileNumber)
void | setInspectionReportNumber(java.lang.String inspectionReportNumber)
void | setInspectionResult(java.lang.String inspectionResult)
void | setInspectionResultSign(java.lang.String inspectionResultSign)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setOperatingEnvironment(boolean operatingEnvironment)
void | setOperatingInstructionsDescription(java.lang.String operatingInstructionsDescription)
void | setOperatingInstructionsInspectMethodItems(java.util.Set<OperatingInstructionsInspectMethodItemVO> operatingInstructionsInspectMethodItems)
void | setOperatingInstructionsInspectResultItems(java.util.Set<OperatingInstructionsInspectResultItemVO> operatingInstructionsInspectResultItems)
void | setOperatingInstructionsInspectStandardItems(java.util.Set<OperatingInstructionsInspectStandardItemVO> operatingInstructionsInspectStandardItems)
void | setOperatingInstructionsManuals(java.util.Set<OperatingInstructionsManualItemVO> operatingInstructionsManuals)
void | setOperatingInstructionsNotes(java.lang.String operatingInstructionsNotes)
void | setOperatingInstructionsNumber(java.lang.String operatingInstructionsNumber)
void | setOperatingInstructionsType(OperatingInstructionsTypeVO operatingInstructionsType)
void | setOperatingInstructionsTypeId(java.lang.Integer operatingInstructionsTypeId)
void | setOperatingOutputFiles(java.util.Set<OperatingOutputFileItemVO> operatingOutputFiles)
void | setOperatingProcessNotes(java.lang.String operatingProcessNotes)
void | setOperatingProcessRecord(java.lang.String operatingProcessRecord)
void | setOrigin(java.lang.String origin)
void | setPausedTime(java.util.Date pausedTime)
void | setPausedTimeByHour(java.math.BigDecimal pausedTimeByHour)
void | setPickListOrderNumber(java.lang.String pickListOrderNumber)
void | setProject(java.lang.String project)
void | setQuantity(java.math.BigDecimal quantity)
void | setRelatedInspectorSign(java.lang.String relatedInspectorSign)
void | setRequestInspectionDate(java.util.Date requestInspectionDate)
void | setResolveResult(java.lang.String resolveResult)
void | setResolveResultSign(java.lang.String resolveResultSign)
void | setResponsibility(java.lang.String responsibility)
void | setSerial(java.lang.String serial)
void | setStaff(java.lang.String staff)
void | setStaffSign(java.lang.String staffSign)
void | setStartDate(java.util.Date startDate)
void | setStatus(java.lang.String status)
void | setVersion(java.lang.Integer version)
void | setWorkOrderAndItemNumber(java.lang.String workOrderAndItemNumber)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_OPERATINGINSTRUCTIONSNUMBER

public static final java.lang.String ORDER_BY_OPERATINGINSTRUCTIONSNUMBER
See Also:
Constant Field Values

ORDER_BY_WORKORDERANDITEMNUMBER

public static final java.lang.String ORDER_BY_WORKORDERANDITEMNUMBER
See Also:
Constant Field Values

ORDER_BY_PROJECT

public static final java.lang.String ORDER_BY_PROJECT
See Also:
Constant Field Values

ORDER_BY_SERIAL

public static final java.lang.String ORDER_BY_SERIAL
See Also:
Constant Field Values

ORDER_BY_RESPONSIBILITY

public static final java.lang.String ORDER_BY_RESPONSIBILITY
See Also:
Constant Field Values

ORDER_BY_OPERATINGINSTRUCTIONSTYPE

public static final java.lang.String ORDER_BY_OPERATINGINSTRUCTIONSTYPE
See Also:
Constant Field Values

ORDER_BY_OPERATINGINSTRUCTIONSDESCRIPTION

public static final java.lang.String ORDER_BY_OPERATINGINSTRUCTIONSDESCRIPTION
See Also:
Constant Field Values

ORDER_BY_QUANTITY

public static final java.lang.String ORDER_BY_QUANTITY
See Also:
Constant Field Values

ORDER_BY_PICKLISTORDERNUMBER

public static final java.lang.String ORDER_BY_PICKLISTORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_DRAWINGNUMBER

public static final java.lang.String ORDER_BY_DRAWINGNUMBER
See Also:
Constant Field Values

ORDER_BY_OPERATINGENVIRONMENT

public static final java.lang.String ORDER_BY_OPERATINGENVIRONMENT
See Also:
Constant Field Values

ORDER_BY_OPERATINGINSTRUCTIONSNOTES

public static final java.lang.String ORDER_BY_OPERATINGINSTRUCTIONSNOTES
See Also:
Constant Field Values

ORDER_BY_STAFF

public static final java.lang.String ORDER_BY_STAFF
See Also:
Constant Field Values

ORDER_BY_STARTDATE

public static final java.lang.String ORDER_BY_STARTDATE
See Also:
Constant Field Values

ORDER_BY_ENDDATE

public static final java.lang.String ORDER_BY_ENDDATE
See Also:
Constant Field Values

ORDER_BY_PAUSEDTIME

public static final java.lang.String ORDER_BY_PAUSEDTIME
See Also:
Constant Field Values

ORDER_BY_ELAPSEDTIMEBYHOUR

public static final java.lang.String ORDER_BY_ELAPSEDTIMEBYHOUR
See Also:
Constant Field Values

ORDER_BY_PAUSEDTIMEBYHOUR

public static final java.lang.String ORDER_BY_PAUSEDTIMEBYHOUR
See Also:
Constant Field Values

ORDER_BY_OPERATINGPROCESSRECORD

public static final java.lang.String ORDER_BY_OPERATINGPROCESSRECORD
See Also:
Constant Field Values

ORDER_BY_STAFFSIGN

public static final java.lang.String ORDER_BY_STAFFSIGN
See Also:
Constant Field Values

ORDER_BY_RELATEDINSPECTORSIGN

public static final java.lang.String ORDER_BY_RELATEDINSPECTORSIGN
See Also:
Constant Field Values

ORDER_BY_OPERATINGPROCESSNOTES

public static final java.lang.String ORDER_BY_OPERATINGPROCESSNOTES
See Also:
Constant Field Values

ORDER_BY_REQUESTINSPECTIONDATE

public static final java.lang.String ORDER_BY_REQUESTINSPECTIONDATE
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_INSPECTIONREPORTNUMBER

public static final java.lang.String ORDER_BY_INSPECTIONREPORTNUMBER
See Also:
Constant Field Values
Constructor Detail

OperatingInstructionsVO

public OperatingInstructionsVO()
Method Detail

getDrawingNumber

public java.lang.String getDrawingNumber()

setDrawingNumber

public void setDrawingNumber(java.lang.String drawingNumber)

getElapsedTimeByHour

public java.math.BigDecimal getElapsedTimeByHour()

setElapsedTimeByHour

public void setElapsedTimeByHour(java.math.BigDecimal elapsedTimeByHour)

getEndDate

public java.util.Date getEndDate()

setEndDate

public void setEndDate(java.util.Date endDate)

getInspectionContent

public java.lang.String getInspectionContent()

setInspectionContent

public void setInspectionContent(java.lang.String inspectionContent)

isInspectionOutputFile

public boolean isInspectionOutputFile()

setInspectionOutputFile

public void setInspectionOutputFile(boolean inspectionOutputFile)

getInspectionOutputFileNumber

public java.lang.String getInspectionOutputFileNumber()

setInspectionOutputFileNumber

public void setInspectionOutputFileNumber(java.lang.String inspectionOutputFileNumber)

setOperatingInstructionsInspectResultItems

public void setOperatingInstructionsInspectResultItems(java.util.Set<OperatingInstructionsInspectResultItemVO> operatingInstructionsInspectResultItems)

getOperatingInstructionsInspectResultItems

public java.util.Set<OperatingInstructionsInspectResultItemVO> getOperatingInstructionsInspectResultItems()

getInspectionReportNumber

public java.lang.String getInspectionReportNumber()

setInspectionReportNumber

public void setInspectionReportNumber(java.lang.String inspectionReportNumber)

getInspectionResult

public java.lang.String getInspectionResult()

setInspectionResult

public void setInspectionResult(java.lang.String inspectionResult)

getInspectionResultSign

public java.lang.String getInspectionResultSign()

setInspectionResultSign

public void setInspectionResultSign(java.lang.String inspectionResultSign)

isOperatingEnvironment

public boolean isOperatingEnvironment()

setOperatingEnvironment

public void setOperatingEnvironment(boolean operatingEnvironment)

getOperatingInstructionsDescription

public java.lang.String getOperatingInstructionsDescription()

setOperatingInstructionsDescription

public void setOperatingInstructionsDescription(java.lang.String operatingInstructionsDescription)

getOperatingInstructionsInspectStandardItems

public java.util.Set<OperatingInstructionsInspectStandardItemVO> getOperatingInstructionsInspectStandardItems()

setOperatingInstructionsInspectStandardItems

public void setOperatingInstructionsInspectStandardItems(java.util.Set<OperatingInstructionsInspectStandardItemVO> operatingInstructionsInspectStandardItems)

getOperatingInstructionsManuals

public java.util.Set<OperatingInstructionsManualItemVO> getOperatingInstructionsManuals()

setOperatingInstructionsManuals

public void setOperatingInstructionsManuals(java.util.Set<OperatingInstructionsManualItemVO> operatingInstructionsManuals)

getOperatingInstructionsNotes

public java.lang.String getOperatingInstructionsNotes()

setOperatingInstructionsNotes

public void setOperatingInstructionsNotes(java.lang.String operatingInstructionsNotes)

getOperatingInstructionsNumber

public java.lang.String getOperatingInstructionsNumber()

setOperatingInstructionsNumber

public void setOperatingInstructionsNumber(java.lang.String operatingInstructionsNumber)

getOperatingInstructionsType

public OperatingInstructionsTypeVO getOperatingInstructionsType()

setOperatingInstructionsType

public void setOperatingInstructionsType(OperatingInstructionsTypeVO operatingInstructionsType)

getOperatingInstructionsTypeId

public java.lang.Integer getOperatingInstructionsTypeId()

setOperatingInstructionsTypeId

public void setOperatingInstructionsTypeId(java.lang.Integer operatingInstructionsTypeId)

getOperatingOutputFiles

public java.util.Set<OperatingOutputFileItemVO> getOperatingOutputFiles()

setOperatingOutputFiles

public void setOperatingOutputFiles(java.util.Set<OperatingOutputFileItemVO> operatingOutputFiles)

getOperatingProcessNotes

public java.lang.String getOperatingProcessNotes()

setOperatingProcessNotes

public void setOperatingProcessNotes(java.lang.String operatingProcessNotes)

getOperatingProcessRecord

public java.lang.String getOperatingProcessRecord()

setOperatingProcessRecord

public void setOperatingProcessRecord(java.lang.String operatingProcessRecord)

getPickListOrderNumber

public java.lang.String getPickListOrderNumber()

setPickListOrderNumber

public void setPickListOrderNumber(java.lang.String pickListOrderNumber)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getRelatedInspectorSign

public java.lang.String getRelatedInspectorSign()

setRelatedInspectorSign

public void setRelatedInspectorSign(java.lang.String relatedInspectorSign)

getRequestInspectionDate

public java.util.Date getRequestInspectionDate()

setRequestInspectionDate

public void setRequestInspectionDate(java.util.Date requestInspectionDate)

getResolveResult

public java.lang.String getResolveResult()

setResolveResult

public void setResolveResult(java.lang.String resolveResult)

getResolveResultSign

public java.lang.String getResolveResultSign()

setResolveResultSign

public void setResolveResultSign(java.lang.String resolveResultSign)

getResponsibility

public java.lang.String getResponsibility()

setResponsibility

public void setResponsibility(java.lang.String responsibility)

getSerial

public java.lang.String getSerial()

setSerial

public void setSerial(java.lang.String serial)

getStaff

public java.lang.String getStaff()

setStaff

public void setStaff(java.lang.String staff)

getStaffSign

public java.lang.String getStaffSign()

setStaffSign

public void setStaffSign(java.lang.String staffSign)

getStartDate

public java.util.Date getStartDate()

setStartDate

public void setStartDate(java.util.Date startDate)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getWorkOrderAndItemNumber

public java.lang.String getWorkOrderAndItemNumber()

setWorkOrderAndItemNumber

public void setWorkOrderAndItemNumber(java.lang.String workOrderAndItemNumber)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getVersion

public java.lang.Integer getVersion()

setVersion

public void setVersion(java.lang.Integer version)

getPausedTimeByHour

public java.math.BigDecimal getPausedTimeByHour()

setPausedTimeByHour

public void setPausedTimeByHour(java.math.BigDecimal pausedTimeByHour)

getPausedTime

public java.util.Date getPausedTime()

setPausedTime

public void setPausedTime(java.util.Date pausedTime)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getOperatingInstructionsInspectMethodItems

public java.util.Set<OperatingInstructionsInspectMethodItemVO> getOperatingInstructionsInspectMethodItems()

setOperatingInstructionsInspectMethodItems

public void setOperatingInstructionsInspectMethodItems(java.util.Set<OperatingInstructionsInspectMethodItemVO> operatingInstructionsInspectMethodItems)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OperatingOutputFileItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OperatingOutputFileItemPK

java.lang.Object
    extended by  bb.common.OperatingOutputFileItemPK
All Implemented Interfaces:
java.io.Serializable
public class OperatingOutputFileItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
OperatingOutputFileItemPK()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Integer | getIi()
java.lang.String | getOperatingInstructionsNumber()
int | hashCode()
void | setIi(java.lang.Integer ii)
void | setOperatingInstructionsNumber(java.lang.String operatingInstructionsNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

OperatingOutputFileItemPK

public OperatingOutputFileItemPK()
Method Detail

getOperatingInstructionsNumber

public java.lang.String getOperatingInstructionsNumber()

setOperatingInstructionsNumber

public void setOperatingInstructionsNumber(java.lang.String operatingInstructionsNumber)

getIi

public java.lang.Integer getIi()

setIi

public void setIi(java.lang.Integer ii)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OperatingOutputFileItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OperatingOutputFileItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.OperatingOutputFileItemVO
All Implemented Interfaces:
java.io.Serializable
public class OperatingOutputFileItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
OperatingOutputFileItemVO()
Method Summary
boolean | equals(java.lang.Object other)
OperatingOutputFileTypeVO | getOperatingOutputFileType()
OperatingOutputFileItemPK | getPk()
java.lang.String | getRecordNumber()
int | hashCode()
void | setOperatingOutputFileType(OperatingOutputFileTypeVO operatingOutputFileType)
void | setPk(OperatingOutputFileItemPK pk)
void | setRecordNumber(java.lang.String recordNumber)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

OperatingOutputFileItemVO

public OperatingOutputFileItemVO()
Method Detail

getPk

public OperatingOutputFileItemPK getPk()

setPk

public void setPk(OperatingOutputFileItemPK pk)

getRecordNumber

public java.lang.String getRecordNumber()

setRecordNumber

public void setRecordNumber(java.lang.String recordNumber)

getOperatingOutputFileType

public OperatingOutputFileTypeVO getOperatingOutputFileType()

setOperatingOutputFileType

public void setOperatingOutputFileType(OperatingOutputFileTypeVO operatingOutputFileType)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OperatingOutputFileTypeVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OperatingOutputFileTypeVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.OperatingOutputFileTypeVO
All Implemented Interfaces:
java.io.Serializable
public class OperatingOutputFileTypeVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_II
Constructor Summary
OperatingOutputFileTypeVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDescription()
java.lang.Integer | getIi()
int | hashCode()
void | setDescription(java.lang.String description)
void | setIi(java.lang.Integer ii)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_II

public static final java.lang.String ORDER_BY_II
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

OperatingOutputFileTypeVO

public OperatingOutputFileTypeVO()
Method Detail

getIi

public java.lang.Integer getIi()

setIi

public void setIi(java.lang.Integer ii)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OperationLogVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OperationLogVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.OperationLogVO
All Implemented Interfaces:
java.io.Serializable
public class OperationLogVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACTION
static java.lang.String | ORDER_BY_ACTIONTIME
static java.lang.String | ORDER_BY_COMMENT
static java.lang.String | ORDER_BY_EMPLOYEEID
static java.lang.String | ORDER_BY_ID
static java.lang.String | ORDER_BY_LANIP
static java.lang.String | ORDER_BY_MACADDRESS
static java.lang.String | ORDER_BY_PORT
static java.lang.String | ORDER_BY_SERVER
static java.lang.String | ORDER_BY_SYSTEM
static java.lang.String | ORDER_BY_TARGET
static java.lang.String | ORDER_BY_TRUENAME
static java.lang.String | ORDER_BY_TYPE
static java.lang.String | ORDER_BY_USERNAME
static java.lang.String | ORDER_BY_WANIP
Constructor Summary
OperationLogVO()
OperationLogVO(java.lang.String userName, java.lang.String trueName, java.lang.String action, java.lang.String target)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAction()
java.util.Date | getActionTime()
java.lang.String | getComment()
java.lang.String | getEmployeeID()
java.lang.Long | getId()
java.lang.String | getLanIp()
java.lang.String | getMacAddress()
java.lang.String | getPort()
java.lang.String | getServer()
java.lang.String | getSystem()
java.lang.String | getTarget()
java.lang.String | getTrueName()
byte | getType()
java.lang.String | getUserName()
java.lang.String | getWanIp()
int | hashCode()
void | setAction(java.lang.String action)
void | setActionTime(java.util.Date actionTime)
void | setComment(java.lang.String comment)
void | setEmployeeID(java.lang.String employeeID)
void | setId(java.lang.Long id)
void | setLanIp(java.lang.String lanIp)
void | setMacAddress(java.lang.String macAddress)
void | setPort(java.lang.String port)
void | setServer(java.lang.String server)
void | setSystem(java.lang.String system)
void | setTarget(java.lang.String target)
void | setTrueName(java.lang.String trueName)
void | setType(byte type)
void | setUserName(java.lang.String userName)
void | setWanIp(java.lang.String wanIp)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_USERNAME

public static final java.lang.String ORDER_BY_USERNAME
See Also:
Constant Field Values

ORDER_BY_ACTION

public static final java.lang.String ORDER_BY_ACTION
See Also:
Constant Field Values

ORDER_BY_ACTIONTIME

public static final java.lang.String ORDER_BY_ACTIONTIME
See Also:
Constant Field Values

ORDER_BY_ID

public static final java.lang.String ORDER_BY_ID
See Also:
Constant Field Values

ORDER_BY_WANIP

public static final java.lang.String ORDER_BY_WANIP
See Also:
Constant Field Values

ORDER_BY_LANIP

public static final java.lang.String ORDER_BY_LANIP
See Also:
Constant Field Values

ORDER_BY_MACADDRESS

public static final java.lang.String ORDER_BY_MACADDRESS
See Also:
Constant Field Values

ORDER_BY_TRUENAME

public static final java.lang.String ORDER_BY_TRUENAME
See Also:
Constant Field Values

ORDER_BY_TYPE

public static final java.lang.String ORDER_BY_TYPE
See Also:
Constant Field Values

ORDER_BY_TARGET

public static final java.lang.String ORDER_BY_TARGET
See Also:
Constant Field Values

ORDER_BY_EMPLOYEEID

public static final java.lang.String ORDER_BY_EMPLOYEEID
See Also:
Constant Field Values

ORDER_BY_COMMENT

public static final java.lang.String ORDER_BY_COMMENT
See Also:
Constant Field Values

ORDER_BY_SERVER

public static final java.lang.String ORDER_BY_SERVER
See Also:
Constant Field Values

ORDER_BY_PORT

public static final java.lang.String ORDER_BY_PORT
See Also:
Constant Field Values

ORDER_BY_SYSTEM

public static final java.lang.String ORDER_BY_SYSTEM
See Also:
Constant Field Values
Constructor Detail

OperationLogVO

public OperationLogVO(java.lang.String userName,
                      java.lang.String trueName,
                      java.lang.String action,
                      java.lang.String target)

OperationLogVO

public OperationLogVO()
Method Detail

getEmployeeID

public java.lang.String getEmployeeID()

setEmployeeID

public void setEmployeeID(java.lang.String employeeID)

setId

public void setId(java.lang.Long id)

setUserName

public void setUserName(java.lang.String userName)

setTrueName

public void setTrueName(java.lang.String trueName)

setAction

public void setAction(java.lang.String action)

setTarget

public void setTarget(java.lang.String target)

getId

public java.lang.Long getId()

getUserName

public java.lang.String getUserName()

getType

public byte getType()

setType

public void setType(byte type)

getTrueName

public java.lang.String getTrueName()

getAction

public java.lang.String getAction()

getTarget

public java.lang.String getTarget()

getActionTime

public java.util.Date getActionTime()

setActionTime

public void setActionTime(java.util.Date actionTime)

getComment

public java.lang.String getComment()

setComment

public void setComment(java.lang.String comment)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getLanIp

public java.lang.String getLanIp()

setLanIp

public void setLanIp(java.lang.String lanIp)

getMacAddress

public java.lang.String getMacAddress()

setMacAddress

public void setMacAddress(java.lang.String macAddress)

getWanIp

public java.lang.String getWanIp()

setWanIp

public void setWanIp(java.lang.String wanIp)

getPort

public java.lang.String getPort()

setPort

public void setPort(java.lang.String port)

getServer

public java.lang.String getServer()

setServer

public void setServer(java.lang.String server)

getSystem

public java.lang.String getSystem()

setSystem

public void setSystem(java.lang.String system)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OrderApprovalItemsVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OrderApprovalItemsVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.OrderApprovalItemsVO
All Implemented Interfaces:
java.io.Serializable
public class OrderApprovalItemsVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
OrderApprovalItemsVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAction()
java.math.BigDecimal | getAvgCost()
int | getDelayDays()
java.lang.String | getDescription()
java.math.BigDecimal | getDiscount()
java.lang.String | getDwg()
java.util.Date | getEndDate()
java.math.BigDecimal | getExtendPrice()
java.lang.Long | getIi()
java.lang.String | getItemComments()
java.lang.String | getItemPrivateNotes()
java.lang.String | getMfg()
java.lang.String | getMpn()
OrderApprovalVO | getOrderApproval()
java.lang.Long | getOrderApprovalID()
java.util.Date | getOriginal()
java.math.BigDecimal | getOriginalAvgCost()
java.math.BigDecimal | getOriginalDiscount()
java.util.Date | getOriginalEndDate()
java.math.BigDecimal | getOriginalExtendPrice()
java.lang.String | getOriginalOrderItem()
java.lang.String | getOriginalPartDesc()
java.lang.String | getOriginalPartNumber()
java.lang.String | getOriginalPartType()
java.math.BigDecimal | getOriginalPoQty()
java.math.BigDecimal | getOriginalQty()
java.util.Date | getOriginalStartDate()
java.lang.String | getOriginalStatus()
java.math.BigDecimal | getOriginalStdCost()
java.math.BigDecimal | getOriginalTaxRate()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getPoQty()
java.lang.String | getPoUnit()
java.math.BigDecimal | getPoUnitRate()
java.math.BigDecimal | getQty()
java.lang.String | getReferenceDoc1()
java.lang.String | getReferenceDoc2()
java.lang.String | getRevision()
java.lang.String | getShipVia()
java.util.Date | getStartDate()
java.lang.String | getStatus()
java.math.BigDecimal | getStdCost()
java.math.BigDecimal | getTaxRate()
java.lang.String | getUnit()
int | hashCode()
boolean | isIcrRequiredWhenReceiverNa()
boolean | isOriginalIcrRequiredWhenReceiverNa()
void | setAction(java.lang.String action)
void | setAvgCost(java.math.BigDecimal avgCost)
void | setDelayDays(int delayDays)
void | setDescription(java.lang.String description)
void | setDiscount(java.math.BigDecimal discount)
void | setDwg(java.lang.String dwg)
void | setEndDate(java.util.Date endDate)
void | setExtendPrice(java.math.BigDecimal extendPrice)
void | setIcrRequiredWhenReceiverNa(boolean icrRequiredWhenReceiverNa)
void | setIi(java.lang.Long ii)
void | setItemComments(java.lang.String itemComments)
void | setItemPrivateNotes(java.lang.String itemPrivateNotes)
void | setMfg(java.lang.String mfg)
void | setMpn(java.lang.String mpn)
void | setOrderApproval(OrderApprovalVO orderApproval)
void | setOrderApprovalID(java.lang.Long orderApprovalID)
void | setOriginal(java.util.Date original)
void | setOriginalAvgCost(java.math.BigDecimal originalAvgCost)
void | setOriginalDiscount(java.math.BigDecimal originalDiscount)
void | setOriginalEndDate(java.util.Date originalEndDate)
void | setOriginalExtendPrice(java.math.BigDecimal originalExtendPrice)
void | setOriginalIcrRequiredWhenReceiverNa(boolean originalIcrRequiredWhenReceiverNa)
void | setOriginalOrderItem(java.lang.String originalOrderItem)
void | setOriginalPartDesc(java.lang.String originalPartDesc)
void | setOriginalPartNumber(java.lang.String originalPartNumber)
void | setOriginalPartType(java.lang.String originalPartType)
void | setOriginalPoQty(java.math.BigDecimal originalPoQty)
void | setOriginalQty(java.math.BigDecimal originalQty)
void | setOriginalStartDate(java.util.Date originalStartDate)
void | setOriginalStatus(java.lang.String originalStatus)
void | setOriginalStdCost(java.math.BigDecimal originalStdCost)
void | setOriginalTaxRate(java.math.BigDecimal originalTaxRate)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPoQty(java.math.BigDecimal poQty)
void | setPoUnit(java.lang.String poUnit)
void | setPoUnitRate(java.math.BigDecimal poUnitRate)
void | setQty(java.math.BigDecimal qty)
void | setReferenceDoc1(java.lang.String referenceDoc1)
void | setReferenceDoc2(java.lang.String referenceDoc2)
void | setRevision(java.lang.String revision)
void | setShipVia(java.lang.String shipVia)
void | setStartDate(java.util.Date startDate)
void | setStatus(java.lang.String status)
void | setStdCost(java.math.BigDecimal stdCost)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setUnit(java.lang.String unit)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

OrderApprovalItemsVO

public OrderApprovalItemsVO()
Method Detail

getAvgCost

public java.math.BigDecimal getAvgCost()

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getEndDate

public java.util.Date getEndDate()

setEndDate

public void setEndDate(java.util.Date endDate)

getDelayDays

public int getDelayDays()

setDelayDays

public void setDelayDays(int delayDays)

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getOrderApprovalID

public java.lang.Long getOrderApprovalID()

setOrderApprovalID

public void setOrderApprovalID(java.lang.Long orderApprovalID)

getOriginalAvgCost

public java.math.BigDecimal getOriginalAvgCost()

setOriginalAvgCost

public void setOriginalAvgCost(java.math.BigDecimal originalAvgCost)

getOriginalDiscount

public java.math.BigDecimal getOriginalDiscount()

setOriginalDiscount

public void setOriginalDiscount(java.math.BigDecimal originalDiscount)

getOriginalEndDate

public java.util.Date getOriginalEndDate()

setOriginalEndDate

public void setOriginalEndDate(java.util.Date originalEndDate)

getOriginalOrderItem

public java.lang.String getOriginalOrderItem()

setOriginalOrderItem

public void setOriginalOrderItem(java.lang.String originalOrderItem)

getOriginalPartDesc

public java.lang.String getOriginalPartDesc()

setOriginalPartDesc

public void setOriginalPartDesc(java.lang.String originalPartDesc)

getOriginalPartNumber

public java.lang.String getOriginalPartNumber()

setOriginalPartNumber

public void setOriginalPartNumber(java.lang.String originalPartNumber)

getOriginalPartType

public java.lang.String getOriginalPartType()

setOriginalPartType

public void setOriginalPartType(java.lang.String originalPartType)

getOriginalQty

public java.math.BigDecimal getOriginalQty()

setOriginalQty

public void setOriginalQty(java.math.BigDecimal originalQty)

getOriginalStartDate

public java.util.Date getOriginalStartDate()

setOriginalStartDate

public void setOriginalStartDate(java.util.Date originalStartDate)

getOriginalStdCost

public java.math.BigDecimal getOriginalStdCost()

setOriginalStdCost

public void setOriginalStdCost(java.math.BigDecimal originalStdCost)

getOriginalTaxRate

public java.math.BigDecimal getOriginalTaxRate()

setOriginalTaxRate

public void setOriginalTaxRate(java.math.BigDecimal originalTaxRate)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

getStartDate

public java.util.Date getStartDate()

setStartDate

public void setStartDate(java.util.Date startDate)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getAction

public java.lang.String getAction()

setAction

public void setAction(java.lang.String action)

getOrderApproval

public OrderApprovalVO getOrderApproval()

setOrderApproval

public void setOrderApproval(OrderApprovalVO orderApproval)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getOriginalPoQty

public java.math.BigDecimal getOriginalPoQty()

setOriginalPoQty

public void setOriginalPoQty(java.math.BigDecimal originalPoQty)

getPoQty

public java.math.BigDecimal getPoQty()

setPoQty

public void setPoQty(java.math.BigDecimal poQty)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getDwg

public java.lang.String getDwg()

setDwg

public void setDwg(java.lang.String dwg)

getItemComments

public java.lang.String getItemComments()

setItemComments

public void setItemComments(java.lang.String itemComments)

getItemPrivateNotes

public java.lang.String getItemPrivateNotes()

setItemPrivateNotes

public void setItemPrivateNotes(java.lang.String itemPrivateNotes)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getOriginal

public java.util.Date getOriginal()

setOriginal

public void setOriginal(java.util.Date original)

getPoUnit

public java.lang.String getPoUnit()

setPoUnit

public void setPoUnit(java.lang.String poUnit)

getPoUnitRate

public java.math.BigDecimal getPoUnitRate()

setPoUnitRate

public void setPoUnitRate(java.math.BigDecimal poUnitRate)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getOriginalExtendPrice

public java.math.BigDecimal getOriginalExtendPrice()

setOriginalExtendPrice

public void setOriginalExtendPrice(java.math.BigDecimal originalExtendPrice)

getExtendPrice

public java.math.BigDecimal getExtendPrice()

setExtendPrice

public void setExtendPrice(java.math.BigDecimal extendPrice)

getReferenceDoc1

public java.lang.String getReferenceDoc1()

setReferenceDoc1

public void setReferenceDoc1(java.lang.String referenceDoc1)

getReferenceDoc2

public java.lang.String getReferenceDoc2()

setReferenceDoc2

public void setReferenceDoc2(java.lang.String referenceDoc2)

getOriginalStatus

public java.lang.String getOriginalStatus()

setOriginalStatus

public void setOriginalStatus(java.lang.String originalStatus)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

isOriginalIcrRequiredWhenReceiverNa

public boolean isOriginalIcrRequiredWhenReceiverNa()

setOriginalIcrRequiredWhenReceiverNa

public void setOriginalIcrRequiredWhenReceiverNa(boolean originalIcrRequiredWhenReceiverNa)

isIcrRequiredWhenReceiverNa

public boolean isIcrRequiredWhenReceiverNa()

setIcrRequiredWhenReceiverNa

public void setIcrRequiredWhenReceiverNa(boolean icrRequiredWhenReceiverNa)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OrderApprovalVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OrderApprovalVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.OrderApprovalVO
All Implemented Interfaces:
java.io.Serializable
public class OrderApprovalVO
extends VO
implements java.io.Serializable

OrderApproval generated by MyEclipse Persistence Tools

See Also:
Serialized Form

Constructor Summary
OrderApprovalVO()
Method Summary
java.lang.String | getAction()
java.lang.String | getApplyBy()
java.util.Date | getApplyDate()
java.lang.String | getApprovedBy()
java.util.Date | getApprovedDate()
java.lang.String | getDescription()
java.lang.Long | getIi()
java.util.Set | getItems()
java.lang.String | getOrderNumber()
java.lang.String | getOrderType()
java.lang.String | getStatus()
void | setAction(java.lang.String action)
void | setApplyBy(java.lang.String applyBy)
void | setApplyDate(java.util.Date applyDate)
void | setApprovedBy(java.lang.String approvedBy)
void | setApprovedDate(java.util.Date approvedDate)
void | setDescription(java.lang.String description)
void | setIi(java.lang.Long ii)
void | setItems(java.util.Set items)
void | setOrderNumber(java.lang.String orderNumber)
void | setOrderType(java.lang.String orderType)
void | setStatus(java.lang.String status)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OrderApprovalVO

public OrderApprovalVO()
Method Detail

getAction

public java.lang.String getAction()

setAction

public void setAction(java.lang.String action)

getApplyBy

public java.lang.String getApplyBy()

setApplyBy

public void setApplyBy(java.lang.String applyBy)

getApplyDate

public java.util.Date getApplyDate()

setApplyDate

public void setApplyDate(java.util.Date applyDate)

getApprovedBy

public java.lang.String getApprovedBy()

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)

getApprovedDate

public java.util.Date getApprovedDate()

setApprovedDate

public void setApprovedDate(java.util.Date approvedDate)

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getItems

public java.util.Set getItems()

setItems

public void setItems(java.util.Set items)

getOrderNumber

public java.lang.String getOrderNumber()

setOrderNumber

public void setOrderNumber(java.lang.String orderNumber)

getOrderType

public java.lang.String getOrderType()

setOrderType

public void setOrderType(java.lang.String orderType)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OrderBoilerplatePK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OrderBoilerplatePK

java.lang.Object
    extended by  bb.common.OrderBoilerplatePK
All Implemented Interfaces:
java.io.Serializable
public class OrderBoilerplatePK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
OrderBoilerplatePK()
default constructor
OrderBoilerplatePK(java.lang.String orderNumber, java.lang.Byte ii)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Byte | getIi()
java.lang.String | getOrderNumber()
int | hashCode()
void | setIi(java.lang.Byte ii)
void | setOrderNumber(java.lang.String orderNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

OrderBoilerplatePK

public OrderBoilerplatePK(java.lang.String orderNumber,
                          java.lang.Byte ii)
full constructor

OrderBoilerplatePK

public OrderBoilerplatePK()
default constructor

Method Detail

getOrderNumber

public java.lang.String getOrderNumber()

setOrderNumber

public void setOrderNumber(java.lang.String orderNumber)

getIi

public java.lang.Byte getIi()

setIi

public void setIi(java.lang.Byte ii)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OrderBoilerplateVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OrderBoilerplateVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.OrderBoilerplateVO
All Implemented Interfaces:
java.io.Serializable
public class OrderBoilerplateVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
OrderBoilerplateVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getBpId()
java.lang.String | getBplate()
java.util.Date | getLastChangeDate()
OrderBoilerplatePK | getPk()
int | hashCode()
void | setBpId(java.lang.String bpId)
void | setBplate(java.lang.String bplate)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setPk(OrderBoilerplatePK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

OrderBoilerplateVO

public OrderBoilerplateVO()
default constructor

Method Detail

getPk

public OrderBoilerplatePK getPk()

setPk

public void setPk(OrderBoilerplatePK pk)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getBpId

public java.lang.String getBpId()

setBpId

public void setBpId(java.lang.String bpId)

getBplate

public java.lang.String getBplate()

setBplate

public void setBplate(java.lang.String bplate)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OrderBy

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OrderBy

java.lang.Object
    extended by  bb.common.OrderBy
All Implemented Interfaces:
java.io.Serializable
public class OrderBy
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ASC
static java.lang.String | DESC
Constructor Summary
OrderBy()
Method Summary
java.util.LinkedHashMap | getOrderBy()
void | setOrderBy(java.util.LinkedHashMap orderBy)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ASC

public static final java.lang.String ASC
See Also:
Constant Field Values

DESC

public static final java.lang.String DESC
See Also:
Constant Field Values
Constructor Detail

OrderBy

public OrderBy()
Method Detail

setOrderBy

public void setOrderBy(java.util.LinkedHashMap orderBy)

getOrderBy

public java.util.LinkedHashMap getOrderBy()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OrderDemandForReceiverResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OrderDemandForReceiverResult

java.lang.Object
    extended by  bb.common.OrderDemandForReceiverResult
All Implemented Interfaces:
java.io.Serializable
public class OrderDemandForReceiverResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
OrderDemandForReceiverResult()
Method Summary
BB2Part | getBB2Part()
java.math.BigDecimal | getDemand()
java.lang.String | getItemNumber()
java.lang.String | getOrderNumber()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
PartPK | getPartPk()
java.lang.String | getPartType()
java.lang.String | getUnit()
void | setDemand(java.math.BigDecimal demand)
void | setItemNumber(java.lang.String itemNumber)
void | setOrderNumber(java.lang.String orderNumber)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setUnit(java.lang.String unit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OrderDemandForReceiverResult

public OrderDemandForReceiverResult()
Method Detail

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

setOrderNumber

public void setOrderNumber(java.lang.String orderNumber)

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

setPartNumber

public void setPartNumber(java.lang.String partNumber)

setPartType

public void setPartType(java.lang.String partType)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setDemand

public void setDemand(java.math.BigDecimal demand)

getOrderNumber

public java.lang.String getOrderNumber()

getItemNumber

public java.lang.String getItemNumber()

getPartNumber

public java.lang.String getPartNumber()

getPartType

public java.lang.String getPartType()

getPartFrom

public java.lang.String getPartFrom()

getDemand

public java.math.BigDecimal getDemand()

getPartPk

public PartPK getPartPk()

getBB2Part

public BB2Part getBB2Part()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OrderDocumentVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OrderDocumentVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.OrderDocumentVO
All Implemented Interfaces:
java.io.Serializable
public class OrderDocumentVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
OrderDocumentVO()
Method Summary
java.lang.String | getComments()
java.lang.String | getDocDescription()
java.lang.String | getDocFileName()
long | getDocLength()
java.lang.String | getDocType()
java.util.Date | getDocumentDate()
java.lang.String | getExtension()
java.lang.Long | getIi()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getOrderNumber()
void | setComments(java.lang.String comments)
void | setDocDescription(java.lang.String docDescription)
void | setDocFileName(java.lang.String docFileName)
void | setDocLength(long docLength)
void | setDocType(java.lang.String docType)
void | setDocumentDate(java.util.Date documentDate)
void | setExtension(java.lang.String extension)
void | setIi(java.lang.Long ii)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setOrderNumber(java.lang.String orderNumber)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OrderDocumentVO

public OrderDocumentVO()
Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getOrderNumber

public java.lang.String getOrderNumber()

setOrderNumber

public void setOrderNumber(java.lang.String orderNumber)

getDocType

public java.lang.String getDocType()

setDocType

public void setDocType(java.lang.String docType)

getDocDescription

public java.lang.String getDocDescription()

setDocDescription

public void setDocDescription(java.lang.String docDescription)

getDocumentDate

public java.util.Date getDocumentDate()

setDocumentDate

public void setDocumentDate(java.util.Date documentDate)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

getDocFileName

public java.lang.String getDocFileName()

setDocFileName

public void setDocFileName(java.lang.String docFileName)

getDocLength

public long getDocLength()

setDocLength

public void setDocLength(long docLength)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OrderPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OrderPK

java.lang.Object
    extended by  bb.common.OrderPK
All Implemented Interfaces:
java.io.Serializable
public class OrderPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
OrderPK(java.lang.String orderNumber, java.lang.String itemNumber)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getItemNumber()
java.lang.String | getOrderNumber()
java.lang.String | getRefDocString()
int | hashCode()
void | setItemNumber(java.lang.String itemNumber)
void | setOrderNumber(java.lang.String orderNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

OrderPK

public OrderPK(java.lang.String orderNumber,
               java.lang.String itemNumber)
Method Detail

setOrderNumber

public void setOrderNumber(java.lang.String orderNumber)

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

getOrderNumber

public java.lang.String getOrderNumber()

getItemNumber

public java.lang.String getItemNumber()

getRefDocString

public java.lang.String getRefDocString()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OrderVendorItem

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OrderVendorItem

java.lang.Object
    extended by  bb.common.OrderVendorItem
All Implemented Interfaces:
java.io.Serializable
public class OrderVendorItem
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
OrderVendorItem()
Method Summary
java.util.Date | getArriveDate()
OrderPK | getPk()
java.math.BigDecimal | getShortQty()
java.lang.String | getVendorID()
void | setArriveDate(java.util.Date arriveDate)
void | setPk(OrderPK pk)
void | setShortQty(java.math.BigDecimal shortQty)
void | setVendorID(java.lang.String vendorID)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OrderVendorItem

public OrderVendorItem()
Method Detail

getVendorID

public java.lang.String getVendorID()

getPk

public OrderPK getPk()

getArriveDate

public java.util.Date getArriveDate()

getShortQty

public java.math.BigDecimal getShortQty()

setVendorID

public void setVendorID(java.lang.String vendorID)

setPk

public void setPk(OrderPK pk)

setArriveDate

public void setArriveDate(java.util.Date arriveDate)

setShortQty

public void setShortQty(java.math.BigDecimal shortQty)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OutputValueByMonthResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class OutputValueByMonthResult

java.lang.Object
    extended by  bb.common.OutputValueByMonthResult
All Implemented Interfaces:
java.io.Serializable
public class OutputValueByMonthResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
OutputValueByMonthResult()
Method Summary
java.util.Map<java.util.Date,java.math.BigDecimal> | getMonthOutputValues()
java.math.BigDecimal | getTotalOutputValue()
void | setMonthOutputValues(java.util.Map<java.util.Date,java.math.BigDecimal> monthOutputValues)
void | setTotalOutputValue(java.math.BigDecimal totalOutputValue)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OutputValueByMonthResult

public OutputValueByMonthResult()
Method Detail

getMonthOutputValues

public java.util.Map<java.util.Date,java.math.BigDecimal> getMonthOutputValues()

setMonthOutputValues

public void setMonthOutputValues(java.util.Map<java.util.Date,java.math.BigDecimal> monthOutputValues)

getTotalOutputValue

public java.math.BigDecimal getTotalOutputValue()

setTotalOutputValue

public void setTotalOutputValue(java.math.BigDecimal totalOutputValue)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Overview

PREV NEXT FRAMES NO FRAMES
Packages
bb.common
bb.common.box

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Overview List

All Classes

Packages
bb.common
bb.common.box


PackingBoxItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PackingBoxItemListResult

java.lang.Object
    extended by  bb.common.PackingBoxItemListResult
All Implemented Interfaces:
java.io.Serializable
public class PackingBoxItemListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_PACKINGBOXITEMPK
static java.lang.String | ORDER_BY_PARTFROM
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_QUANTITY
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
PackingBoxItemListResult()
Method Summary
java.lang.String | getCustomerId()
java.lang.String | getDescription()
PackingBoxItemPK | getPackingBoxItemPk()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getQuantity()
java.lang.String | getStatus()
void | setCustomerId(java.lang.String customerId)
void | setDescription(java.lang.String description)
void | setPackingBoxItemPk(PackingBoxItemPK packingBoxItemPk)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setQuantity(java.math.BigDecimal quantity)
void | setStatus(java.lang.String status)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PACKINGBOXITEMPK

public static final java.lang.String ORDER_BY_PACKINGBOXITEMPK
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_QUANTITY

public static final java.lang.String ORDER_BY_QUANTITY
See Also:
Constant Field Values

ORDER_BY_PARTFROM

public static final java.lang.String ORDER_BY_PARTFROM
See Also:
Constant Field Values
Constructor Detail

PackingBoxItemListResult

public PackingBoxItemListResult()
Method Detail

setPackingBoxItemPk

public void setPackingBoxItemPk(PackingBoxItemPK packingBoxItemPk)

setCustomerId

public void setCustomerId(java.lang.String customerId)

setStatus

public void setStatus(java.lang.String status)

setPartNumber

public void setPartNumber(java.lang.String partNumber)

setPartType

public void setPartType(java.lang.String partType)

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setDescription

public void setDescription(java.lang.String description)

getPackingBoxItemPk

public PackingBoxItemPK getPackingBoxItemPk()

getCustomerId

public java.lang.String getCustomerId()

getStatus

public java.lang.String getStatus()

getPartNumber

public java.lang.String getPartNumber()

getPartType

public java.lang.String getPartType()

getQuantity

public java.math.BigDecimal getQuantity()

getPartFrom

public java.lang.String getPartFrom()

getDescription

public java.lang.String getDescription()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PackingBoxItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PackingBoxItemPK

java.lang.Object
    extended by  bb.common.PackingBoxItemPK
All Implemented Interfaces:
java.io.Serializable
public class PackingBoxItemPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PackingBoxItemPK()
default constructor
PackingBoxItemPK(java.lang.String pfInvoiceNumber, java.lang.Integer packingBoxNumber, java.lang.String salesOrderNumber, java.lang.String salesOrderItemNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Integer | getPackingBoxNumber()
java.lang.String | getPfInvoiceNumber()
java.lang.String | getSalesOrderItemNumber()
java.lang.String | getSalesOrderNumber()
int | hashCode()
void | setPackingBoxNumber(java.lang.Integer packingBoxNumber)
void | setPfInvoiceNumber(java.lang.String pfInvoiceNumber)
void | setSalesOrderItemNumber(java.lang.String salesOrderItemNumber)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PackingBoxItemPK

public PackingBoxItemPK(java.lang.String pfInvoiceNumber,
                        java.lang.Integer packingBoxNumber,
                        java.lang.String salesOrderNumber,
                        java.lang.String salesOrderItemNumber)
full constructor

PackingBoxItemPK

public PackingBoxItemPK()
default constructor

Method Detail

getPfInvoiceNumber

public java.lang.String getPfInvoiceNumber()

setPfInvoiceNumber

public void setPfInvoiceNumber(java.lang.String pfInvoiceNumber)

getPackingBoxNumber

public java.lang.Integer getPackingBoxNumber()

setPackingBoxNumber

public void setPackingBoxNumber(java.lang.Integer packingBoxNumber)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getSalesOrderItemNumber

public java.lang.String getSalesOrderItemNumber()

setSalesOrderItemNumber

public void setSalesOrderItemNumber(java.lang.String salesOrderItemNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PackingBoxItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PackingBoxItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PackingBoxItemVO
All Implemented Interfaces:
java.io.Serializable
public class PackingBoxItemVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PackingBoxItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCustomerId()
java.lang.String | getDescription()
java.util.Map | getLocations()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
PackingBoxItemPK | getPk()
java.lang.String | getPurchaseOrderNumber()
java.math.BigDecimal | getQuantity()
java.lang.String | getShipTo()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.util.Map | getTrackings()
java.lang.String | getWeight()
int | hashCode()
void | setCustomerId(java.lang.String customerId)
void | setDescription(java.lang.String description)
void | setLocations(java.util.Map locations)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(PackingBoxItemPK pk)
void | setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)
void | setQuantity(java.math.BigDecimal quantity)
void | setShipTo(java.lang.String shipTo)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setTrackings(java.util.Map trackings)
void | setWeight(java.lang.String weight)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PackingBoxItemVO

public PackingBoxItemVO()
Method Detail

getPk

public PackingBoxItemPK getPk()

setPk

public void setPk(PackingBoxItemPK pk)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getPurchaseOrderNumber

public java.lang.String getPurchaseOrderNumber()

setPurchaseOrderNumber

public void setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)

getShipTo

public java.lang.String getShipTo()

setShipTo

public void setShipTo(java.lang.String shipTo)

getShipVia

public java.lang.String getShipVia()

getPartFrom

public java.lang.String getPartFrom()

setShipVia

public void setShipVia(java.lang.String shipVia)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getWeight

public java.lang.String getWeight()

setWeight

public void setWeight(java.lang.String weight)

getLocations

public java.util.Map getLocations()

setLocations

public void setLocations(java.util.Map locations)

getTrackings

public java.util.Map getTrackings()

setTrackings

public void setTrackings(java.util.Map trackings)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PackingBoxPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PackingBoxPK

java.lang.Object
    extended by  bb.common.PackingBoxPK
All Implemented Interfaces:
java.io.Serializable
public class PackingBoxPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PackingBoxPK()
default constructor
PackingBoxPK(java.lang.String pfInvoiceNumber, java.lang.Integer packingBoxNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Integer | getPackingBoxNumber()
java.lang.String | getPfInvoiceNumber()
int | hashCode()
void | setPackingBoxNumber(java.lang.Integer packingBoxNumber)
void | setPfInvoiceNumber(java.lang.String pfInvoiceNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PackingBoxPK

public PackingBoxPK(java.lang.String pfInvoiceNumber,
                    java.lang.Integer packingBoxNumber)
full constructor

PackingBoxPK

public PackingBoxPK()
default constructor

Method Detail

getPfInvoiceNumber

public java.lang.String getPfInvoiceNumber()

setPfInvoiceNumber

public void setPfInvoiceNumber(java.lang.String pfInvoiceNumber)

getPackingBoxNumber

public java.lang.Integer getPackingBoxNumber()

setPackingBoxNumber

public void setPackingBoxNumber(java.lang.Integer packingBoxNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PackingBoxSalesOrderItemAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PackingBoxSalesOrderItemAgent

java.lang.Object
    extended by  bb.common.PackingBoxSalesOrderItemAgent
All Implemented Interfaces:
java.io.Serializable
public class PackingBoxSalesOrderItemAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PackingBoxSalesOrderItemAgent()
Method Summary
void | clear()
boolean | equals(java.lang.Object other)
java.util.Iterator | getLocations()
java.util.Map | getLocationsMap()
PackingBoxPK | getPackingBoxPk()
java.math.BigDecimal | getQty()
java.math.BigDecimal | getQty(java.lang.String location)
SalesOrderItemPK | getSoItemPk()
java.util.HashMap<java.lang.String,java.math.BigDecimal> | getTrackings()
int | hashCode()
void | put(java.math.BigDecimal qty)
void | put(java.lang.String location, java.math.BigDecimal qty)
void | remove(java.lang.String location)
void | setPackingBoxPk(PackingBoxPK packingBoxPk)
void | setSoItemPk(SalesOrderItemPK soItemPk)
void | setTrackings(java.util.HashMap<java.lang.String,java.math.BigDecimal> trackings)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PackingBoxSalesOrderItemAgent

public PackingBoxSalesOrderItemAgent()
Method Detail

setSoItemPk

public void setSoItemPk(SalesOrderItemPK soItemPk)

setPackingBoxPk

public void setPackingBoxPk(PackingBoxPK packingBoxPk)

getSoItemPk

public SalesOrderItemPK getSoItemPk()

getPackingBoxPk

public PackingBoxPK getPackingBoxPk()

getQty

public java.math.BigDecimal getQty()

put

public void put(java.math.BigDecimal qty)

clear

public void clear()

put

public void put(java.lang.String location,
                java.math.BigDecimal qty)

remove

public void remove(java.lang.String location)

getQty

public java.math.BigDecimal getQty(java.lang.String location)

getLocations

public java.util.Iterator getLocations()

getLocationsMap

public java.util.Map getLocationsMap()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

setTrackings

public void setTrackings(java.util.HashMap<java.lang.String,java.math.BigDecimal> trackings)

getTrackings

public java.util.HashMap<java.lang.String,java.math.BigDecimal> getTrackings()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PackingBoxSalesOrderItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PackingBoxSalesOrderItemResult

java.lang.Object
    extended by  bb.common.PackingBoxSalesOrderItemResult
All Implemented Interfaces:
java.io.Serializable
public class PackingBoxSalesOrderItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PackingBoxSalesOrderItemResult()
Method Summary
void | clear()
java.lang.String | getDescription()
java.util.Iterator | getLocations()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getPtOnhand()
java.math.BigDecimal | getPtSipQty()
java.math.BigDecimal | getQty()
java.math.BigDecimal | getQty(java.lang.String location)
java.lang.String | getRevision()
java.lang.String | getSalesOrderItemNumber()
java.lang.String | getSalesOrderNumber()
java.lang.String | getShippingStatus()
java.math.BigDecimal | getShipQty()
java.math.BigDecimal | getShortQty()
java.math.BigDecimal | getSipQty()
java.lang.String | getStatus()
boolean | isChecked()
void | put(java.math.BigDecimal onhand)
void | put(java.lang.String location, java.math.BigDecimal onhand)
void | remove(java.lang.String location)
void | setChecked(boolean checked)
void | setDescription(java.lang.String description)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPtSipQty(java.math.BigDecimal ptSipQty)
void | setQty(java.math.BigDecimal qty)
void | setRevision(java.lang.String revision)
void | setSalesOrderItemNumber(java.lang.String salesOrderItemNumber)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setShippingStatus(java.lang.String shippingStatus)
void | setShipQty(java.math.BigDecimal shipQty)
void | setShortQty(java.math.BigDecimal shortQty)
void | setSipQty(java.math.BigDecimal sipQty)
void | setStatus(java.lang.String status)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PackingBoxSalesOrderItemResult

public PackingBoxSalesOrderItemResult()
Method Detail

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

setSalesOrderItemNumber

public void setSalesOrderItemNumber(java.lang.String salesOrderItemNumber)

setPartNumber

public void setPartNumber(java.lang.String partNumber)

setPartType

public void setPartType(java.lang.String partType)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setRevision

public void setRevision(java.lang.String revision)

setDescription

public void setDescription(java.lang.String description)

setStatus

public void setStatus(java.lang.String status)

setShippingStatus

public void setShippingStatus(java.lang.String shippingStatus)

setSipQty

public void setSipQty(java.math.BigDecimal sipQty)

setQty

public void setQty(java.math.BigDecimal qty)

setShipQty

public void setShipQty(java.math.BigDecimal shipQty)

setShortQty

public void setShortQty(java.math.BigDecimal shortQty)

setPtSipQty

public void setPtSipQty(java.math.BigDecimal ptSipQty)

setChecked

public void setChecked(boolean checked)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

getSalesOrderItemNumber

public java.lang.String getSalesOrderItemNumber()

getPartNumber

public java.lang.String getPartNumber()

getPartType

public java.lang.String getPartType()

getPartFrom

public java.lang.String getPartFrom()

getRevision

public java.lang.String getRevision()

getDescription

public java.lang.String getDescription()

getStatus

public java.lang.String getStatus()

getShippingStatus

public java.lang.String getShippingStatus()

getSipQty

public java.math.BigDecimal getSipQty()

getQty

public java.math.BigDecimal getQty()

getShipQty

public java.math.BigDecimal getShipQty()

getShortQty

public java.math.BigDecimal getShortQty()

getPtSipQty

public java.math.BigDecimal getPtSipQty()

isChecked

public boolean isChecked()

getPtOnhand

public java.math.BigDecimal getPtOnhand()

put

public void put(java.math.BigDecimal onhand)

clear

public void clear()

put

public void put(java.lang.String location,
                java.math.BigDecimal onhand)

remove

public void remove(java.lang.String location)

getQty

public java.math.BigDecimal getQty(java.lang.String location)

getLocations

public java.util.Iterator getLocations()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PackingBoxVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PackingBoxVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PackingBoxVO
All Implemented Interfaces:
java.io.Serializable
public class PackingBoxVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PackingBoxVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getBb2ShipTo()
java.lang.String | getBb2ShipToName()
java.lang.String | getBb2ShipVia()
java.lang.String | getCustomerId()
java.lang.String | getDimension()
java.math.BigDecimal | getGrossWeight()
java.math.BigDecimal | getNetWeight()
java.util.Set | getPackingBoxItems()
PackingBoxPK | getPk()
java.lang.String | getStatus()
java.lang.String | getWeightUnit()
int | hashCode()
void | setBb2ShipTo(java.lang.String bb2ShipTo)
void | setBb2ShipToName(java.lang.String bb2ShipToName)
void | setBb2ShipVia(java.lang.String bb2ShipVia)
void | setCustomerId(java.lang.String customerId)
void | setDimension(java.lang.String dimension)
void | setGrossWeight(java.math.BigDecimal grossWeight)
void | setNetWeight(java.math.BigDecimal netWeight)
void | setPackingBoxItems(java.util.Set packingBoxItems)
void | setPk(PackingBoxPK pk)
void | setStatus(java.lang.String status)
void | setWeightUnit(java.lang.String weightUnit)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PackingBoxVO

public PackingBoxVO()
default constructor

Method Detail

getPk

public PackingBoxPK getPk()

setPk

public void setPk(PackingBoxPK pk)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getDimension

public java.lang.String getDimension()

setDimension

public void setDimension(java.lang.String dimension)

getGrossWeight

public java.math.BigDecimal getGrossWeight()

setGrossWeight

public void setGrossWeight(java.math.BigDecimal grossWeight)

getNetWeight

public java.math.BigDecimal getNetWeight()

setNetWeight

public void setNetWeight(java.math.BigDecimal netWeight)

getWeightUnit

public java.lang.String getWeightUnit()

setWeightUnit

public void setWeightUnit(java.lang.String weightUnit)

getPackingBoxItems

public java.util.Set getPackingBoxItems()

setPackingBoxItems

public void setPackingBoxItems(java.util.Set packingBoxItems)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getBb2ShipTo

public java.lang.String getBb2ShipTo()

setBb2ShipTo

public void setBb2ShipTo(java.lang.String bb2ShipTo)

getBb2ShipVia

public java.lang.String getBb2ShipVia()

setBb2ShipVia

public void setBb2ShipVia(java.lang.String bb2ShipVia)

getBb2ShipToName

public java.lang.String getBb2ShipToName()

setBb2ShipToName

public void setBb2ShipToName(java.lang.String bb2ShipToName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartBasicInfo

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartBasicInfo

java.lang.Object
    extended by  bb.common.PartBasicInfo
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
BillItemSalesCostResult, BillItemUsageResult, BillItemWithPartInfoResult, BillSalesCostResult, BillWithPartInfoResult, PartBasicInfoWithNewEngGroup, PartBasicInfoWithNewListPrice, PartExportInfo, PartMaterialListResult, PartOnHandWithMfgInfoResult, PartOnHandWithPartBasicInfoResult, PartTraceableListResult, PartTraceableResult, PartWithOnhandDetailInfoResult, PartWithoutLocateResult, ToolBasicInfo
public class PartBasicInfo
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_BILL
static java.lang.String | ORDER_BY_BUYERCODE
static java.lang.String | ORDER_BY_COMMODITYCODE
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_DRAWING
static java.lang.String | ORDER_BY_HOLD
static java.lang.String | ORDER_BY_LASTCHANGEDATE
static java.lang.String | ORDER_BY_LASTUSER
static java.lang.String | ORDER_BY_MAKEBUY
static java.lang.String | ORDER_BY_MODELNUMBER
static java.lang.String | ORDER_BY_ORGANIZATION
static java.lang.String | ORDER_BY_ORIGIN
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_PARTUNIT
static java.lang.String | ORDER_BY_PRODUCTCODE
static java.lang.String | ORDER_BY_SECURITYLEVEL
static java.lang.String | ORDER_BY_WEIGHT
Constructor Summary
PartBasicInfo()
PartBasicInfo(PartPK pk)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getBill()
java.lang.String | getBuyerCode()
java.lang.String | getCommodityCode()
java.lang.String | getCountryOrigin()
java.lang.String | getDescription()
java.lang.String | getDetectionStandard()
java.lang.String | getDrawing()
java.lang.String | getEngGroup()
java.lang.String | getHavePicture()
java.lang.String | getHold()
java.util.Date | getLastChangeDate()
java.lang.String | getLastUser()
java.math.BigDecimal | getLeadTime()
java.lang.String | getMakeBuy()
java.lang.String | getMaterial()
java.lang.String | getModelNumber()
java.lang.String | getOrigin()
PartPK | getPartPk()
java.lang.String | getPartUnit()
java.lang.String | getProductCode()
java.lang.String | getRevision()
java.lang.String | getSaleable()
java.lang.String | getSalesDrawing()
java.lang.String | getSecurityLevel()
java.lang.String | getTraceable()
java.math.BigDecimal | getVolume()
java.lang.String | getVolumeUnit()
float | getWeight()
java.lang.String | getWeightUnit()
java.lang.String | getWi()
int | hashCode()
void | setBill(java.lang.String bill)
void | setBuyerCode(java.lang.String buyerCode)
void | setCommodityCode(java.lang.String commodityCode)
void | setCountryOrigin(java.lang.String countryOrigin)
void | setDescription(java.lang.String description)
void | setDetectionStandard(java.lang.String detectionStandard)
void | setDrawing(java.lang.String drawing)
void | setEngGroup(java.lang.String engGroup)
void | setHavePicture(java.lang.String havePicture)
void | setHold(java.lang.String hold)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastUser(java.lang.String lastUser)
void | setLeadTime(java.math.BigDecimal leadTime)
void | setMakeBuy(java.lang.String makeBuy)
void | setMaterial(java.lang.String material)
void | setModelNumber(java.lang.String modelNumber)
void | setOrigin(java.lang.String origin)
void | setPartPk(PartPK partPk)
void | setPartUnit(java.lang.String partUnit)
void | setProductCode(java.lang.String productCode)
void | setRevision(java.lang.String revision)
void | setSaleable(java.lang.String saleable)
void | setSalesDrawing(java.lang.String salesDrawing)
void | setSecurityLevel(java.lang.String securityLevel)
void | setTraceable(java.lang.String traceable)
void | setVolume(java.math.BigDecimal volume)
void | setVolumeUnit(java.lang.String volumeUnit)
void | setWeight(float weight)
void | setWeightUnit(java.lang.String weightUnit)
void | setWi(java.lang.String wi)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_WEIGHT

public static final java.lang.String ORDER_BY_WEIGHT
See Also:
Constant Field Values

ORDER_BY_BUYERCODE

public static final java.lang.String ORDER_BY_BUYERCODE
See Also:
Constant Field Values

ORDER_BY_HOLD

public static final java.lang.String ORDER_BY_HOLD
See Also:
Constant Field Values

ORDER_BY_DRAWING

public static final java.lang.String ORDER_BY_DRAWING
See Also:
Constant Field Values

ORDER_BY_MODELNUMBER

public static final java.lang.String ORDER_BY_MODELNUMBER
See Also:
Constant Field Values

ORDER_BY_COMMODITYCODE

public static final java.lang.String ORDER_BY_COMMODITYCODE
See Also:
Constant Field Values

ORDER_BY_PARTUNIT

public static final java.lang.String ORDER_BY_PARTUNIT
See Also:
Constant Field Values

ORDER_BY_ORGANIZATION

public static final java.lang.String ORDER_BY_ORGANIZATION
See Also:
Constant Field Values

ORDER_BY_SECURITYLEVEL

public static final java.lang.String ORDER_BY_SECURITYLEVEL
See Also:
Constant Field Values

ORDER_BY_MAKEBUY

public static final java.lang.String ORDER_BY_MAKEBUY
See Also:
Constant Field Values

ORDER_BY_BILL

public static final java.lang.String ORDER_BY_BILL
See Also:
Constant Field Values

ORDER_BY_LASTUSER

public static final java.lang.String ORDER_BY_LASTUSER
See Also:
Constant Field Values

ORDER_BY_ORIGIN

public static final java.lang.String ORDER_BY_ORIGIN
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEDATE

public static final java.lang.String ORDER_BY_LASTCHANGEDATE
See Also:
Constant Field Values

ORDER_BY_PRODUCTCODE

public static final java.lang.String ORDER_BY_PRODUCTCODE
See Also:
Constant Field Values
Constructor Detail

PartBasicInfo

public PartBasicInfo()

PartBasicInfo

public PartBasicInfo(PartPK pk)
Method Detail

getPartPk

public PartPK getPartPk()

setPartPk

public void setPartPk(PartPK partPk)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getHold

public java.lang.String getHold()

setHold

public void setHold(java.lang.String hold)

getDrawing

public java.lang.String getDrawing()

setDrawing

public void setDrawing(java.lang.String drawing)

getBill

public java.lang.String getBill()

setBill

public void setBill(java.lang.String bill)

getWi

public java.lang.String getWi()

setWi

public void setWi(java.lang.String wi)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getTraceable

public java.lang.String getTraceable()

getPartUnit

public java.lang.String getPartUnit()

getMakeBuy

public java.lang.String getMakeBuy()

getWeight

public float getWeight()

getWeightUnit

public java.lang.String getWeightUnit()

getBuyerCode

public java.lang.String getBuyerCode()

setTraceable

public void setTraceable(java.lang.String traceable)

setPartUnit

public void setPartUnit(java.lang.String partUnit)

setMakeBuy

public void setMakeBuy(java.lang.String makeBuy)

setWeight

public void setWeight(float weight)

setWeightUnit

public void setWeightUnit(java.lang.String weightUnit)

setBuyerCode

public void setBuyerCode(java.lang.String buyerCode)

getMaterial

public java.lang.String getMaterial()

setMaterial

public void setMaterial(java.lang.String material)

getCommodityCode

public java.lang.String getCommodityCode()

setCommodityCode

public void setCommodityCode(java.lang.String commodityCode)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getVolume

public java.math.BigDecimal getVolume()

setVolume

public void setVolume(java.math.BigDecimal volume)

getVolumeUnit

public java.lang.String getVolumeUnit()

setVolumeUnit

public void setVolumeUnit(java.lang.String volumeUnit)

getSalesDrawing

public java.lang.String getSalesDrawing()

setSalesDrawing

public void setSalesDrawing(java.lang.String salesDrawing)

getHavePicture

public java.lang.String getHavePicture()

setHavePicture

public void setHavePicture(java.lang.String havePicture)

getSaleable

public java.lang.String getSaleable()

setSaleable

public void setSaleable(java.lang.String saleable)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getProductCode

public java.lang.String getProductCode()

setProductCode

public void setProductCode(java.lang.String productCode)

getSecurityLevel

public java.lang.String getSecurityLevel()

setSecurityLevel

public void setSecurityLevel(java.lang.String securityLevel)

getEngGroup

public java.lang.String getEngGroup()

setEngGroup

public void setEngGroup(java.lang.String engGroup)

getLastUser

public java.lang.String getLastUser()

setLastUser

public void setLastUser(java.lang.String lastUser)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getDetectionStandard

public java.lang.String getDetectionStandard()

setDetectionStandard

public void setDetectionStandard(java.lang.String detectionStandard)

getCountryOrigin

public java.lang.String getCountryOrigin()

setCountryOrigin

public void setCountryOrigin(java.lang.String countryOrigin)

getLeadTime

public java.math.BigDecimal getLeadTime()

setLeadTime

public void setLeadTime(java.math.BigDecimal leadTime)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartBasicInfoWithNewEngGroup

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartBasicInfoWithNewEngGroup

java.lang.Object
    extended by  bb.common.PartBasicInfo
        extended by  bb.common.PartBasicInfoWithNewEngGroup
All Implemented Interfaces:
java.io.Serializable
public class PartBasicInfoWithNewEngGroup
extends PartBasicInfo
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AVGCOST
static java.lang.String | ORDER_BY_BUYERCODE
static java.lang.String | ORDER_BY_COMMODITYCODE
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_DRAWING
static java.lang.String | ORDER_BY_HOLD
static java.lang.String | ORDER_BY_LISTPRICE
static java.lang.String | ORDER_BY_MODELNUMBER
static java.lang.String | ORDER_BY_ORGANIZATION
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_PARTUNIT
static java.lang.String | ORDER_BY_SECURITYLEVEL
static java.lang.String | ORDER_BY_STDCOST
static java.lang.String | ORDER_BY_WEIGHT
Fields inherited from class bb.common.PartBasicInfo
ORDER_BY_BILL, ORDER_BY_LASTCHANGEDATE, ORDER_BY_LASTUSER, ORDER_BY_MAKEBUY, ORDER_BY_ORIGIN, ORDER_BY_PARTNUMBER, ORDER_BY_PARTTYPE, ORDER_BY_PRODUCTCODE
Constructor Summary
PartBasicInfoWithNewEngGroup()
Method Summary
java.lang.String | getNewEngGroup()
void | setNewEngGroup(java.lang.String newEngGroup)
Methods inherited from class bb.common.PartBasicInfo
equals, getBill, getBuyerCode, getCommodityCode, getCountryOrigin, getDescription, getDetectionStandard, getDrawing, getEngGroup, getHavePicture, getHold, getLastChangeDate, getLastUser, getLeadTime, getMakeBuy, getMaterial, getModelNumber, getOrigin, getPartPk, getPartUnit, getProductCode, getRevision, getSaleable, getSalesDrawing, getSecurityLevel, getTraceable, getVolume, getVolumeUnit, getWeight, getWeightUnit, getWi, hashCode, setBill, setBuyerCode, setCommodityCode, setCountryOrigin, setDescription, setDetectionStandard, setDrawing, setEngGroup, setHavePicture, setHold, setLastChangeDate, setLastUser, setLeadTime, setMakeBuy, setMaterial, setModelNumber, setOrigin, setPartPk, setPartUnit, setProductCode, setRevision, setSaleable, setSalesDrawing, setSecurityLevel, setTraceable, setVolume, setVolumeUnit, setWeight, setWeightUnit, setWi, toString
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_WEIGHT

public static final java.lang.String ORDER_BY_WEIGHT
See Also:
Constant Field Values

ORDER_BY_BUYERCODE

public static final java.lang.String ORDER_BY_BUYERCODE
See Also:
Constant Field Values

ORDER_BY_HOLD

public static final java.lang.String ORDER_BY_HOLD
See Also:
Constant Field Values

ORDER_BY_DRAWING

public static final java.lang.String ORDER_BY_DRAWING
See Also:
Constant Field Values

ORDER_BY_MODELNUMBER

public static final java.lang.String ORDER_BY_MODELNUMBER
See Also:
Constant Field Values

ORDER_BY_COMMODITYCODE

public static final java.lang.String ORDER_BY_COMMODITYCODE
See Also:
Constant Field Values

ORDER_BY_PARTUNIT

public static final java.lang.String ORDER_BY_PARTUNIT
See Also:
Constant Field Values

ORDER_BY_ORGANIZATION

public static final java.lang.String ORDER_BY_ORGANIZATION
See Also:
Constant Field Values

ORDER_BY_SECURITYLEVEL

public static final java.lang.String ORDER_BY_SECURITYLEVEL
See Also:
Constant Field Values

ORDER_BY_LISTPRICE

public static final java.lang.String ORDER_BY_LISTPRICE
See Also:
Constant Field Values

ORDER_BY_AVGCOST

public static final java.lang.String ORDER_BY_AVGCOST
See Also:
Constant Field Values

ORDER_BY_STDCOST

public static final java.lang.String ORDER_BY_STDCOST
See Also:
Constant Field Values
Constructor Detail

PartBasicInfoWithNewEngGroup

public PartBasicInfoWithNewEngGroup()
Method Detail

getNewEngGroup

public java.lang.String getNewEngGroup()

setNewEngGroup

public void setNewEngGroup(java.lang.String newEngGroup)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartBasicInfoWithNewListPrice

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartBasicInfoWithNewListPrice

java.lang.Object
    extended by  bb.common.PartBasicInfo
        extended by  bb.common.PartBasicInfoWithNewListPrice
All Implemented Interfaces:
java.io.Serializable
public class PartBasicInfoWithNewListPrice
extends PartBasicInfo
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AVGCOST
static java.lang.String | ORDER_BY_BUYERCODE
static java.lang.String | ORDER_BY_COMMODITYCODE
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_DRAWING
static java.lang.String | ORDER_BY_HOLD
static java.lang.String | ORDER_BY_LISTPRICE
static java.lang.String | ORDER_BY_MODELNUMBER
static java.lang.String | ORDER_BY_ORGANIZATION
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_PARTUNIT
static java.lang.String | ORDER_BY_SECURITYLEVEL
static java.lang.String | ORDER_BY_STDCOST
static java.lang.String | ORDER_BY_WEIGHT
Fields inherited from class bb.common.PartBasicInfo
ORDER_BY_BILL, ORDER_BY_LASTCHANGEDATE, ORDER_BY_LASTUSER, ORDER_BY_MAKEBUY, ORDER_BY_ORIGIN, ORDER_BY_PARTNUMBER, ORDER_BY_PARTTYPE, ORDER_BY_PRODUCTCODE
Constructor Summary
PartBasicInfoWithNewListPrice()
Method Summary
java.math.BigDecimal | getAvgCost()
java.math.BigDecimal | getListPrice()
java.math.BigDecimal | getNewListPrice()
java.math.BigDecimal | getStdCost()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setListPrice(java.math.BigDecimal listPrice)
void | setNewListPrice(java.math.BigDecimal newListPrice)
void | setStdCost(java.math.BigDecimal stdCost)
Methods inherited from class bb.common.PartBasicInfo
equals, getBill, getBuyerCode, getCommodityCode, getCountryOrigin, getDescription, getDetectionStandard, getDrawing, getEngGroup, getHavePicture, getHold, getLastChangeDate, getLastUser, getLeadTime, getMakeBuy, getMaterial, getModelNumber, getOrigin, getPartPk, getPartUnit, getProductCode, getRevision, getSaleable, getSalesDrawing, getSecurityLevel, getTraceable, getVolume, getVolumeUnit, getWeight, getWeightUnit, getWi, hashCode, setBill, setBuyerCode, setCommodityCode, setCountryOrigin, setDescription, setDetectionStandard, setDrawing, setEngGroup, setHavePicture, setHold, setLastChangeDate, setLastUser, setLeadTime, setMakeBuy, setMaterial, setModelNumber, setOrigin, setPartPk, setPartUnit, setProductCode, setRevision, setSaleable, setSalesDrawing, setSecurityLevel, setTraceable, setVolume, setVolumeUnit, setWeight, setWeightUnit, setWi, toString
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_WEIGHT

public static final java.lang.String ORDER_BY_WEIGHT
See Also:
Constant Field Values

ORDER_BY_BUYERCODE

public static final java.lang.String ORDER_BY_BUYERCODE
See Also:
Constant Field Values

ORDER_BY_HOLD

public static final java.lang.String ORDER_BY_HOLD
See Also:
Constant Field Values

ORDER_BY_DRAWING

public static final java.lang.String ORDER_BY_DRAWING
See Also:
Constant Field Values

ORDER_BY_MODELNUMBER

public static final java.lang.String ORDER_BY_MODELNUMBER
See Also:
Constant Field Values

ORDER_BY_COMMODITYCODE

public static final java.lang.String ORDER_BY_COMMODITYCODE
See Also:
Constant Field Values

ORDER_BY_PARTUNIT

public static final java.lang.String ORDER_BY_PARTUNIT
See Also:
Constant Field Values

ORDER_BY_ORGANIZATION

public static final java.lang.String ORDER_BY_ORGANIZATION
See Also:
Constant Field Values

ORDER_BY_SECURITYLEVEL

public static final java.lang.String ORDER_BY_SECURITYLEVEL
See Also:
Constant Field Values

ORDER_BY_LISTPRICE

public static final java.lang.String ORDER_BY_LISTPRICE
See Also:
Constant Field Values

ORDER_BY_AVGCOST

public static final java.lang.String ORDER_BY_AVGCOST
See Also:
Constant Field Values

ORDER_BY_STDCOST

public static final java.lang.String ORDER_BY_STDCOST
See Also:
Constant Field Values
Constructor Detail

PartBasicInfoWithNewListPrice

public PartBasicInfoWithNewListPrice()
Method Detail

getAvgCost

public java.math.BigDecimal getAvgCost()

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

getNewListPrice

public java.math.BigDecimal getNewListPrice()

setNewListPrice

public void setNewListPrice(java.math.BigDecimal newListPrice)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartCatagoryPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartCatagoryPK

java.lang.Object
    extended by  bb.common.PartCatagoryPK
All Implemented Interfaces:
java.io.Serializable
public class PartCatagoryPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartCatagoryPK()
PartCatagoryPK(java.lang.String bigCatagory, java.lang.String smallCatagory)
Method Summary
boolean | equals(java.lang.Object obj)
java.lang.String | getBigCatagory()
java.lang.String | getSmallCatagory()
int | hashCode()
void | setBigCatagory(java.lang.String bigCatagory)
void | setSmallCatagory(java.lang.String smallCatagory)
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PartCatagoryPK

public PartCatagoryPK()

PartCatagoryPK

public PartCatagoryPK(java.lang.String bigCatagory,
                      java.lang.String smallCatagory)
Method Detail

getBigCatagory

public java.lang.String getBigCatagory()

setBigCatagory

public void setBigCatagory(java.lang.String bigCatagory)

getSmallCatagory

public java.lang.String getSmallCatagory()

setSmallCatagory

public void setSmallCatagory(java.lang.String smallCatagory)

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartCatagoryVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartCatagoryVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartCatagoryVO
All Implemented Interfaces:
java.io.Serializable
public class PartCatagoryVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartCatagoryVO()
PartCatagoryVO(PartCatagoryPK pk, java.lang.String name)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getName()
PartCatagoryPK | getPk()
int | hashCode()
void | setName(java.lang.String name)
void | setPk(PartCatagoryPK pk)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PartCatagoryVO

public PartCatagoryVO()

PartCatagoryVO

public PartCatagoryVO(PartCatagoryPK pk,
                      java.lang.String name)
Method Detail

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getPk

public PartCatagoryPK getPk()

setPk

public void setPk(PartCatagoryPK pk)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartCatalogAuditResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartCatalogAuditResult

java.lang.Object
    extended by  bb.common.PartCatalogAuditResult
All Implemented Interfaces:
Alarmable, java.io.Serializable
public class PartCatalogAuditResult
extends java.lang.Object
implements java.io.Serializable, Alarmable

See Also:
Serialized Form

Constructor Summary
PartCatalogAuditResult()
Method Summary
boolean | equals(java.lang.Object other)
boolean | getAlarmValue()
java.lang.String | getCatalog()
java.lang.String | getCause()
java.lang.String | getDescription()
java.lang.String | getName()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getSaleable()
int | hashCode()
void | setAlarmValue(boolean alarmValue)
void | setCatalog(java.lang.String catalog)
void | setCause(java.lang.String cause)
void | setDescription(java.lang.String description)
void | setName(java.lang.String name)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setSaleable(java.lang.String saleable)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartCatalogAuditResult

public PartCatalogAuditResult()
Method Detail

getAlarmValue

public boolean getAlarmValue()
Specified by:
getAlarmValue in interface Alarmable

getCause

public java.lang.String getCause()
Specified by:
getCause in interface Alarmable

setAlarmValue

public void setAlarmValue(boolean alarmValue)
Specified by:
setAlarmValue in interface Alarmable

setCause

public void setCause(java.lang.String cause)
Specified by:
setCause in interface Alarmable

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getCatalog

public java.lang.String getCatalog()

setCatalog

public void setCatalog(java.lang.String catalog)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getSaleable

public java.lang.String getSaleable()

setSaleable

public void setSaleable(java.lang.String saleable)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartCatalogPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartCatalogPK

java.lang.Object
    extended by  bb.common.PartCatalogPK
All Implemented Interfaces:
java.io.Serializable
public class PartCatalogPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PartCatalogPK()
default constructor
PartCatalogPK(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
int | hashCode()
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartCatalogPK

public PartCatalogPK(java.lang.String partNumber,
                     java.lang.String partType,
                     java.lang.String partFrom)
full constructor

PartCatalogPK

public PartCatalogPK()
default constructor

Method Detail

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartCatalogVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartCatalogVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartCatalogVO
All Implemented Interfaces:
java.io.Serializable
public class PartCatalogVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PartCatalogVO()
default constructor
PartCatalogVO(PartCatalogPK pk, java.lang.String name, java.lang.String catalog, java.lang.String comments)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCatalog()
java.lang.String | getComments()
java.lang.String | getName()
PartCatalogPK | getPk()
int | hashCode()
void | setCatalog(java.lang.String catalog)
void | setComments(java.lang.String comments)
void | setName(java.lang.String name)
void | setPk(PartCatalogPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartCatalogVO

public PartCatalogVO(PartCatalogPK pk,
                     java.lang.String name,
                     java.lang.String catalog,
                     java.lang.String comments)
full constructor

PartCatalogVO

public PartCatalogVO()
default constructor

Method Detail

getPk

public PartCatalogPK getPk()

setPk

public void setPk(PartCatalogPK pk)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getCatalog

public java.lang.String getCatalog()

setCatalog

public void setCatalog(java.lang.String catalog)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartCertificateListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartCertificateListResult

java.lang.Object
    extended by  bb.common.PartCertificateListResult
All Implemented Interfaces:
java.io.Serializable
public class PartCertificateListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CERTIFICATENUMBER
static java.lang.String | ORDER_BY_COMPANYNAME
static java.lang.String | ORDER_BY_DOCNAME
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PURCHASEORDERNUMBER
static java.lang.String | ORDER_BY_RECEIVERNUMBER
static java.lang.String | ORDER_BY_REFERENCENUMBER
static java.lang.String | ORDER_BY_SALESORDERNUMBER
static java.lang.String | ORDER_BY_WORKORDERNUMBER
Constructor Summary
PartCertificateListResult()
Method Summary
java.lang.String | getCertificateDescription()
java.lang.String | getCertificateNumber()
java.lang.String | getCompanyName()
java.lang.Integer | getControlNumber()
long | getDocLength()
java.lang.String | getDocName()
java.lang.String | getExtension()
java.lang.String | getPartDescription()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getPurchaseOrderNumber()
java.lang.String | getReceiverNumber()
java.lang.String | getReferenceNumber()
java.lang.String | getSalesOrderNumber()
java.lang.String | getWorkOrderNumber()
void | setCertificateDescription(java.lang.String certificateDescription)
void | setCertificateNumber(java.lang.String certificateNumber)
void | setCompanyName(java.lang.String companyName)
void | setControlNumber(java.lang.Integer controlNumber)
void | setDocLength(long docLength)
void | setDocName(java.lang.String docName)
void | setExtension(java.lang.String extension)
void | setPartDescription(java.lang.String partDescription)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)
void | setReceiverNumber(java.lang.String receiverNumber)
void | setReferenceNumber(java.lang.String referenceNumber)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setWorkOrderNumber(java.lang.String workOrderNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_CERTIFICATENUMBER

public static final java.lang.String ORDER_BY_CERTIFICATENUMBER
See Also:
Constant Field Values

ORDER_BY_COMPANYNAME

public static final java.lang.String ORDER_BY_COMPANYNAME
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_WORKORDERNUMBER

public static final java.lang.String ORDER_BY_WORKORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_PURCHASEORDERNUMBER

public static final java.lang.String ORDER_BY_PURCHASEORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_RECEIVERNUMBER

public static final java.lang.String ORDER_BY_RECEIVERNUMBER
See Also:
Constant Field Values

ORDER_BY_SALESORDERNUMBER

public static final java.lang.String ORDER_BY_SALESORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_REFERENCENUMBER

public static final java.lang.String ORDER_BY_REFERENCENUMBER
See Also:
Constant Field Values

ORDER_BY_DOCNAME

public static final java.lang.String ORDER_BY_DOCNAME
See Also:
Constant Field Values
Constructor Detail

PartCertificateListResult

public PartCertificateListResult()
Method Detail

setControlNumber

public void setControlNumber(java.lang.Integer controlNumber)

setCertificateNumber

public void setCertificateNumber(java.lang.String certificateNumber)

setCompanyName

public void setCompanyName(java.lang.String companyName)

setCertificateDescription

public void setCertificateDescription(java.lang.String certificateDescription)

setPartNumber

public void setPartNumber(java.lang.String partNumber)

setPartType

public void setPartType(java.lang.String partType)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setPartDescription

public void setPartDescription(java.lang.String partDescription)

setWorkOrderNumber

public void setWorkOrderNumber(java.lang.String workOrderNumber)

setPurchaseOrderNumber

public void setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

setReferenceNumber

public void setReferenceNumber(java.lang.String referenceNumber)

getControlNumber

public java.lang.Integer getControlNumber()

getCertificateNumber

public java.lang.String getCertificateNumber()

getCompanyName

public java.lang.String getCompanyName()

getCertificateDescription

public java.lang.String getCertificateDescription()

getPartNumber

public java.lang.String getPartNumber()

getPartType

public java.lang.String getPartType()

getPartFrom

public java.lang.String getPartFrom()

getPartDescription

public java.lang.String getPartDescription()

getWorkOrderNumber

public java.lang.String getWorkOrderNumber()

getPurchaseOrderNumber

public java.lang.String getPurchaseOrderNumber()

getReceiverNumber

public java.lang.String getReceiverNumber()

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

getReferenceNumber

public java.lang.String getReferenceNumber()

getDocLength

public long getDocLength()

setDocLength

public void setDocLength(long docLength)

getDocName

public java.lang.String getDocName()

setDocName

public void setDocName(java.lang.String docName)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartCertificateVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartCertificateVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartCertificateVO
All Implemented Interfaces:
java.io.Serializable
public class PartCertificateVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartCertificateVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getCertificateDate()
java.lang.String | getCertificateDescription()
java.lang.String | getCertificateNumber()
java.lang.String | getComments()
java.lang.String | getCompanyName()
long | getDocLength()
java.lang.String | getDocName()
java.lang.String | getExtension()
java.lang.Integer | getIi()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getPurchaseOrderNumber()
java.lang.String | getReceiverNumber()
java.lang.String | getReferenceNumber()
java.lang.String | getRevision()
java.lang.String | getSalesOrderNumber()
java.lang.Integer | getVersion()
java.lang.String | getWorkerOrderNumber()
int | hashCode()
void | setCertificateDate(java.util.Date certificateDate)
void | setCertificateDescription(java.lang.String certificateDescription)
void | setCertificateNumber(java.lang.String certificateNumber)
void | setComments(java.lang.String comments)
void | setCompanyName(java.lang.String companyName)
void | setDocLength(long docLength)
void | setDocName(java.lang.String docName)
void | setExtension(java.lang.String extension)
void | setIi(java.lang.Integer ii)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)
void | setReceiverNumber(java.lang.String receiverNumber)
void | setReferenceNumber(java.lang.String referenceNumber)
void | setRevision(java.lang.String revision)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setVersion(java.lang.Integer version)
void | setWorkerOrderNumber(java.lang.String workerOrderNumber)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartCertificateVO

public PartCertificateVO()
default constructor

Method Detail

getIi

public java.lang.Integer getIi()

setIi

public void setIi(java.lang.Integer ii)

getCompanyName

public java.lang.String getCompanyName()

setCompanyName

public void setCompanyName(java.lang.String companyName)

getCertificateNumber

public java.lang.String getCertificateNumber()

setCertificateNumber

public void setCertificateNumber(java.lang.String certificateNumber)

getCertificateDescription

public java.lang.String getCertificateDescription()

setCertificateDescription

public void setCertificateDescription(java.lang.String certificateDescription)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getCertificateDate

public java.util.Date getCertificateDate()

setCertificateDate

public void setCertificateDate(java.util.Date certificateDate)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getWorkerOrderNumber

public java.lang.String getWorkerOrderNumber()

setWorkerOrderNumber

public void setWorkerOrderNumber(java.lang.String workerOrderNumber)

getPurchaseOrderNumber

public java.lang.String getPurchaseOrderNumber()

setPurchaseOrderNumber

public void setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)

getReceiverNumber

public java.lang.String getReceiverNumber()

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getReferenceNumber

public java.lang.String getReferenceNumber()

getDocLength

public long getDocLength()

setDocLength

public void setDocLength(long docLength)

getDocName

public java.lang.String getDocName()

setDocName

public void setDocName(java.lang.String docName)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

getVersion

public java.lang.Integer getVersion()

setReferenceNumber

public void setReferenceNumber(java.lang.String referenceNumber)

setVersion

public void setVersion(java.lang.Integer version)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartClassInfoResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartClassInfoResult

java.lang.Object
    extended by  bb.common.PartClassInfoResult
All Implemented Interfaces:
java.io.Serializable
public class PartClassInfoResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_PART
static java.lang.String | ORDER_BY_PARTCLASS
Constructor Summary
PartClassInfoResult()
Method Summary
java.lang.String | getDescription()
BB2Part | getPart()
java.lang.String | getPartClass()
void | setDescription(java.lang.String description)
void | setPart(BB2Part part)
void | setPartClass(java.lang.String partClass)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PART

public static final java.lang.String ORDER_BY_PART
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_PARTCLASS

public static final java.lang.String ORDER_BY_PARTCLASS
See Also:
Constant Field Values
Constructor Detail

PartClassInfoResult

public PartClassInfoResult()
Method Detail

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getPart

public BB2Part getPart()

setPart

public void setPart(BB2Part part)

getPartClass

public java.lang.String getPartClass()

setPartClass

public void setPartClass(java.lang.String partClass)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartClassVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartClassVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartClassVO
All Implemented Interfaces:
java.io.Serializable
public class PartClassVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_ID
static java.lang.String | ORDER_BY_LASTCYCLECOUNT
static java.lang.String | ORDER_BY_LOCKED
static java.lang.String | ORDER_BY_NEXTCYCLECOUNT
static java.lang.String | ORDER_BY_OWNER
static java.lang.String | ORDER_BY_PERIOD
static java.lang.String | ORDER_BY_PERIODUNIT
Constructor Summary
PartClassVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.lang.String | getId()
java.util.Date | getLastCycleCount()
java.util.Date | getNextCycleCount()
java.lang.String | getOwner()
int | getPeriod()
java.lang.String | getPeriodUnit()
int | hashCode()
boolean | isLocked()
void | setComments(java.lang.String comments)
void | setId(java.lang.String id)
void | setLastCycleCount(java.util.Date lastCycleCount)
void | setLocked(boolean locked)
void | setNextCycleCount(java.util.Date nextCycleCount)
void | setOwner(java.lang.String owner)
void | setPeriod(int period)
void | setPeriodUnit(java.lang.String periodUnit)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ID

public static final java.lang.String ORDER_BY_ID
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values

ORDER_BY_PERIOD

public static final java.lang.String ORDER_BY_PERIOD
See Also:
Constant Field Values

ORDER_BY_PERIODUNIT

public static final java.lang.String ORDER_BY_PERIODUNIT
See Also:
Constant Field Values

ORDER_BY_LASTCYCLECOUNT

public static final java.lang.String ORDER_BY_LASTCYCLECOUNT
See Also:
Constant Field Values

ORDER_BY_NEXTCYCLECOUNT

public static final java.lang.String ORDER_BY_NEXTCYCLECOUNT
See Also:
Constant Field Values

ORDER_BY_LOCKED

public static final java.lang.String ORDER_BY_LOCKED
See Also:
Constant Field Values

ORDER_BY_OWNER

public static final java.lang.String ORDER_BY_OWNER
See Also:
Constant Field Values
Constructor Detail

PartClassVO

public PartClassVO()
Method Detail

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getPeriod

public int getPeriod()

setPeriod

public void setPeriod(int period)

getPeriodUnit

public java.lang.String getPeriodUnit()

setPeriodUnit

public void setPeriodUnit(java.lang.String periodUnit)

getLastCycleCount

public java.util.Date getLastCycleCount()

setLastCycleCount

public void setLastCycleCount(java.util.Date lastCycleCount)

getNextCycleCount

public java.util.Date getNextCycleCount()

setNextCycleCount

public void setNextCycleCount(java.util.Date nextCycleCount)

isLocked

public boolean isLocked()

setLocked

public void setLocked(boolean locked)

getOwner

public java.lang.String getOwner()

setOwner

public void setOwner(java.lang.String owner)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartCostVarianceListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartCostVarianceListResult

java.lang.Object
    extended by  bb.common.PartCostVarianceListResult
All Implemented Interfaces:
java.io.Serializable
public class PartCostVarianceListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AVERAGECOST
static java.lang.String | ORDER_BY_MAKEBUY
static java.lang.String | ORDER_BY_PARTDESCRIPTION
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_STANDARDCOST
static java.lang.String | ORDER_BY_VARIANCE
static java.lang.String | ORDER_BY_VARIANCEPERCENT
Constructor Summary
PartCostVarianceListResult()
Method Summary
java.math.BigDecimal | getAverageCost()
java.lang.String | getLastPurchaseOrderNumberAndItemNumber()
java.lang.String | getLastPurchaseOrderVendorID()
java.lang.String | getLastPurchaseOrderVendorName()
java.math.BigDecimal | getLastPurchasePrice()
java.lang.String | getMakeBuy()
java.lang.String | getPartDescription()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getStandardCost()
java.math.BigDecimal | getVariance()
java.math.BigDecimal | getVariancePercent()
void | setAverageCost(java.math.BigDecimal averageCost)
void | setLastPurchaseOrderNumberAndItemNumber(java.lang.String lastPurchaseOrderNumberAndItemNumber)
void | setLastPurchaseOrderVendorID(java.lang.String lastPurchaseOrderVendorID)
void | setLastPurchaseOrderVendorName(java.lang.String lastPurchaseOrderVendorName)
void | setLastPurchasePrice(java.math.BigDecimal lastPurchasePrice)
void | setMakeBuy(java.lang.String makeBuy)
void | setPartDescription(java.lang.String partDescription)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setStandardCost(java.math.BigDecimal standardCost)
void | setVariance(java.math.BigDecimal variance)
void | setVariancePercent(java.math.BigDecimal variancePercent)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTDESCRIPTION

public static final java.lang.String ORDER_BY_PARTDESCRIPTION
See Also:
Constant Field Values

ORDER_BY_MAKEBUY

public static final java.lang.String ORDER_BY_MAKEBUY
See Also:
Constant Field Values

ORDER_BY_STANDARDCOST

public static final java.lang.String ORDER_BY_STANDARDCOST
See Also:
Constant Field Values

ORDER_BY_AVERAGECOST

public static final java.lang.String ORDER_BY_AVERAGECOST
See Also:
Constant Field Values

ORDER_BY_VARIANCE

public static final java.lang.String ORDER_BY_VARIANCE
See Also:
Constant Field Values

ORDER_BY_VARIANCEPERCENT

public static final java.lang.String ORDER_BY_VARIANCEPERCENT
See Also:
Constant Field Values
Constructor Detail

PartCostVarianceListResult

public PartCostVarianceListResult()
Method Detail

getAverageCost

public java.math.BigDecimal getAverageCost()

setAverageCost

public void setAverageCost(java.math.BigDecimal averageCost)

getLastPurchaseOrderNumberAndItemNumber

public java.lang.String getLastPurchaseOrderNumberAndItemNumber()

setLastPurchaseOrderNumberAndItemNumber

public void setLastPurchaseOrderNumberAndItemNumber(java.lang.String lastPurchaseOrderNumberAndItemNumber)

getLastPurchaseOrderVendorID

public java.lang.String getLastPurchaseOrderVendorID()

setLastPurchaseOrderVendorID

public void setLastPurchaseOrderVendorID(java.lang.String lastPurchaseOrderVendorID)

getLastPurchaseOrderVendorName

public java.lang.String getLastPurchaseOrderVendorName()

setLastPurchaseOrderVendorName

public void setLastPurchaseOrderVendorName(java.lang.String lastPurchaseOrderVendorName)

getLastPurchasePrice

public java.math.BigDecimal getLastPurchasePrice()

setLastPurchasePrice

public void setLastPurchasePrice(java.math.BigDecimal lastPurchasePrice)

getPartDescription

public java.lang.String getPartDescription()

setPartDescription

public void setPartDescription(java.lang.String partDescription)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getStandardCost

public java.math.BigDecimal getStandardCost()

setStandardCost

public void setStandardCost(java.math.BigDecimal standardCost)

getVariance

public java.math.BigDecimal getVariance()

setVariance

public void setVariance(java.math.BigDecimal variance)

getVariancePercent

public java.math.BigDecimal getVariancePercent()

setVariancePercent

public void setVariancePercent(java.math.BigDecimal variancePercent)

getMakeBuy

public java.lang.String getMakeBuy()

setMakeBuy

public void setMakeBuy(java.lang.String makeBuy)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartDescriptionPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartDescriptionPK

java.lang.Object
    extended by  bb.common.PartDescriptionPK
All Implemented Interfaces:
java.io.Serializable
public class PartDescriptionPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PartDescriptionPK()
default constructor
PartDescriptionPK(java.lang.String partNumber, java.lang.String partType, java.lang.String languageCode)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getLanguageCode()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
int | hashCode()
void | setLanguageCode(java.lang.String languageCode)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartDescriptionPK

public PartDescriptionPK(java.lang.String partNumber,
                         java.lang.String partType,
                         java.lang.String languageCode)
full constructor

PartDescriptionPK

public PartDescriptionPK()
default constructor

Method Detail

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getLanguageCode

public java.lang.String getLanguageCode()

setLanguageCode

public void setLanguageCode(java.lang.String languageCode)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartDescriptionVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartDescriptionVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartDescriptionVO
All Implemented Interfaces:
java.io.Serializable
public class PartDescriptionVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartDescriptionVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDescription()
PartDescriptionPK | getPk()
java.lang.String | getStatus()
java.lang.Integer | getVersion()
int | hashCode()
void | setDescription(java.lang.String description)
void | setPk(PartDescriptionPK pk)
void | setStatus(java.lang.String status)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartDescriptionVO

public PartDescriptionVO()
Method Detail

getPk

public PartDescriptionPK getPk()

setPk

public void setPk(PartDescriptionPK pk)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getDescription

public java.lang.String getDescription()

getVersion

public java.lang.Integer getVersion()

setDescription

public void setDescription(java.lang.String description)

setVersion

public void setVersion(java.lang.Integer version)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartDiscountPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartDiscountPK

java.lang.Object
    extended by  bb.common.PartDiscountPK
All Implemented Interfaces:
java.io.Serializable
public class PartDiscountPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartDiscountPK()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCustomerType()
java.lang.String | getDCode()
int | hashCode()
void | setCustomerType(java.lang.String customerType)
void | setDCode(java.lang.String code)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartDiscountPK

public PartDiscountPK()
Method Detail

getCustomerType

public java.lang.String getCustomerType()

setCustomerType

public void setCustomerType(java.lang.String customerType)

getDCode

public java.lang.String getDCode()

setDCode

public void setDCode(java.lang.String code)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartDiscountVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartDiscountVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartDiscountVO
All Implemented Interfaces:
java.io.Serializable
public class PartDiscountVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartDiscountVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.math.BigDecimal | getDiscountRate()
PartDiscountPK | getPk()
int | hashCode()
void | setComments(java.lang.String comments)
void | setDiscountRate(java.math.BigDecimal discountRate)
void | setPk(PartDiscountPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartDiscountVO

public PartDiscountVO()
Method Detail

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getDiscountRate

public java.math.BigDecimal getDiscountRate()

setDiscountRate

public void setDiscountRate(java.math.BigDecimal discountRate)

getPk

public PartDiscountPK getPk()

setPk

public void setPk(PartDiscountPK pk)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartDocumentPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartDocumentPK

java.lang.Object
    extended by  bb.common.PartDocumentPK
All Implemented Interfaces:
java.io.Serializable
public class PartDocumentPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PartDocumentPK()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDocumentType()
java.lang.String | getLanguage()
java.lang.String | getPartNumber()
int | hashCode()
void | setDocumentType(java.lang.String documentType)
void | setLanguage(java.lang.String language)
void | setPartNumber(java.lang.String partNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartDocumentPK

public PartDocumentPK()
default constructor

Method Detail

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getDocumentType

public java.lang.String getDocumentType()

setDocumentType

public void setDocumentType(java.lang.String documentType)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartDocumentVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartDocumentVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartDocumentVO
All Implemented Interfaces:
java.io.Serializable
public class PartDocumentVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PartDocumentVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.lang.String | getDescription()
java.lang.Long | getDocumentLengthByte()
java.lang.String | getDocVersion()
java.lang.String | getExtension()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
PartDocumentPK | getPk()
int | hashCode()
boolean | isPublicDoc()
void | setComments(java.lang.String comments)
void | setDescription(java.lang.String description)
void | setDocumentLengthByte(java.lang.Long documentLengthByte)
void | setDocVersion(java.lang.String docVersion)
void | setExtension(java.lang.String extension)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setPk(PartDocumentPK pk)
void | setPublicDoc(boolean publicDoc)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartDocumentVO

public PartDocumentVO()
default constructor

Method Detail

getPk

public PartDocumentPK getPk()

setPk

public void setPk(PartDocumentPK pk)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

isPublicDoc

public boolean isPublicDoc()

setPublicDoc

public void setPublicDoc(boolean publicDoc)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getDocumentLengthByte

public java.lang.Long getDocumentLengthByte()

setDocumentLengthByte

public void setDocumentLengthByte(java.lang.Long documentLengthByte)

getDocVersion

public java.lang.String getDocVersion()

setDocVersion

public void setDocVersion(java.lang.String docVersion)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartDueAddressListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartDueAddressListResult

java.lang.Object
    extended by  bb.common.PartDueAddressListResult
All Implemented Interfaces:
java.io.Serializable
public class PartDueAddressListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartDueAddressListResult()
Method Summary
java.lang.String | getAddressId()
java.lang.String | getAddressName()
int | getTotalItems()
void | setAddressId(java.lang.String addressId)
void | setAddressName(java.lang.String addressName)
void | setTotalItems(java.lang.Long totalItems)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PartDueAddressListResult

public PartDueAddressListResult()
Method Detail

getAddressName

public java.lang.String getAddressName()

setAddressId

public void setAddressId(java.lang.String addressId)

setAddressName

public void setAddressName(java.lang.String addressName)

setTotalItems

public void setTotalItems(java.lang.Long totalItems)

getAddressId

public java.lang.String getAddressId()

getTotalItems

public int getTotalItems()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartDwfAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartDwfAgent

java.lang.Object
    extended by  bb.common.PartDwfAgent
All Implemented Interfaces:
java.io.Serializable
public class PartDwfAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartDwfAgent()
Method Summary
boolean | equals(java.lang.Object other)
byte[] | getDrawing()
java.lang.String | getDrawingRevision()
java.lang.String | getExtension()
java.lang.String | getFileName()
java.util.ArrayList<java.lang.String> | getFileNames()
java.lang.String | getLanguage()
java.lang.String | getLanIp()
java.lang.String | getMacAdd()
java.lang.String | getOldFileName()
PartDwfPK | getPartDwfPk()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
byte[] | getPicture()
java.lang.String | getWanIp()
void | setDrawing(byte[] drawing)
void | setDrawingRevision(java.lang.String drawingRevision)
void | setExtension(java.lang.String extension)
void | setLanguage(java.lang.String language)
void | setLanIp(java.lang.String lanIp)
void | setMacAdd(java.lang.String macAdd)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPicture(byte[] picture)
void | setWanIp(java.lang.String wanIp)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PartDwfAgent

public PartDwfAgent()
Method Detail

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getLanIp

public java.lang.String getLanIp()

setLanIp

public void setLanIp(java.lang.String lanIp)

getMacAdd

public java.lang.String getMacAdd()

setMacAdd

public void setMacAdd(java.lang.String macAdd)

getWanIp

public java.lang.String getWanIp()

setWanIp

public void setWanIp(java.lang.String wanIp)

getFileName

public java.lang.String getFileName()

getFileNames

public java.util.ArrayList<java.lang.String> getFileNames()

getOldFileName

public java.lang.String getOldFileName()

getPartDwfPk

public PartDwfPK getPartDwfPk()

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getDrawingRevision

public java.lang.String getDrawingRevision()

setDrawingRevision

public void setDrawingRevision(java.lang.String drawingRevision)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getDrawing

public byte[] getDrawing()

setDrawing

public void setDrawing(byte[] drawing)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

getPicture

public byte[] getPicture()

setPicture

public void setPicture(byte[] picture)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartDwfPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartDwfPK

java.lang.Object
    extended by  bb.common.PartDwfPK
All Implemented Interfaces:
java.io.Serializable
public class PartDwfPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PartDwfPK()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getLanguage()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
int | hashCode()
void | setLanguage(java.lang.String language)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartDwfPK

public PartDwfPK()
default constructor

Method Detail

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartDwfVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartDwfVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartDwfVO
All Implemented Interfaces:
java.io.Serializable
public class PartDwfVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PartDwfVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDwgExtension()
long | getDwgLength()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
byte[] | getPicture()
PartDwfPK | getPk()
java.lang.String | getRevision()
int | hashCode()
void | setDwgExtension(java.lang.String dwgExtension)
void | setDwgLength(long dwgLength)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setPicture(byte[] picture)
void | setPk(PartDwfPK pk)
void | setRevision(java.lang.String revision)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartDwfVO

public PartDwfVO()
Method Detail

getPk

public PartDwfPK getPk()

setPk

public void setPk(PartDwfPK pk)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getDwgLength

public long getDwgLength()

setDwgLength

public void setDwgLength(long dwgLength)

getDwgExtension

public java.lang.String getDwgExtension()

setDwgExtension

public void setDwgExtension(java.lang.String dwgExtension)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getPicture

public byte[] getPicture()

setPicture

public void setPicture(byte[] picture)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartDwfWithPartInfoResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartDwfWithPartInfoResult

java.lang.Object
    extended by  bb.common.PartDwfWithPartInfoResult
All Implemented Interfaces:
java.io.Serializable
public class PartDwfWithPartInfoResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DWGEXTENSION
static java.lang.String | ORDER_BY_DWGLENGTH
static java.lang.String | ORDER_BY_PARTDESCRIPTION
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTREVISION
static java.lang.String | ORDER_BY_REVISION
Constructor Summary
PartDwfWithPartInfoResult()
Method Summary
java.lang.String | getDwfExtension()
long | getDwfLength()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getPartDescription()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartRevision()
java.lang.String | getPartType()
byte[] | getPicture()
java.lang.String | getRevision()
void | setDwfExtension(java.lang.String dwfExtension)
void | setDwfLength(long dwfLength)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setPartDescription(java.lang.String partDescription)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartRevision(java.lang.String partRevision)
void | setPartType(java.lang.String partType)
void | setPicture(byte[] picture)
void | setRevision(java.lang.String revision)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_REVISION

public static final java.lang.String ORDER_BY_REVISION
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTDESCRIPTION

public static final java.lang.String ORDER_BY_PARTDESCRIPTION
See Also:
Constant Field Values

ORDER_BY_PARTREVISION

public static final java.lang.String ORDER_BY_PARTREVISION
See Also:
Constant Field Values

ORDER_BY_DWGLENGTH

public static final java.lang.String ORDER_BY_DWGLENGTH
See Also:
Constant Field Values

ORDER_BY_DWGEXTENSION

public static final java.lang.String ORDER_BY_DWGEXTENSION
See Also:
Constant Field Values
Constructor Detail

PartDwfWithPartInfoResult

public PartDwfWithPartInfoResult()
Method Detail

getDwfExtension

public java.lang.String getDwfExtension()

setDwfExtension

public void setDwfExtension(java.lang.String dwfExtension)

getDwfLength

public long getDwfLength()

setDwfLength

public void setDwfLength(long dwfLength)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getPartDescription

public java.lang.String getPartDescription()

setPartDescription

public void setPartDescription(java.lang.String partDescription)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartRevision

public java.lang.String getPartRevision()

setPartRevision

public void setPartRevision(java.lang.String partRevision)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getPicture

public byte[] getPicture()

setPicture

public void setPicture(byte[] picture)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartDwgAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartDwgAgent

java.lang.Object
    extended by  bb.common.PartDwgAgent
All Implemented Interfaces:
java.io.Serializable
public class PartDwgAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartDwgAgent()
Method Summary
int | getDwgLength()
java.lang.String | getExtension()
java.lang.String | getFileName()
java.lang.String | getKey()
java.lang.String | getLanIp()
java.lang.String | getMacAdd()
PartDwgPK | getPartDwgPk()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
byte[] | getPicture()
java.lang.String | getRevision()
java.lang.String | getWanIp()
void | setDwgLength(int dwgLength)
void | setExtension(java.lang.String extension)
void | setKey(java.lang.String key)
void | setLanIp(java.lang.String lanIp)
void | setMacAdd(java.lang.String macAdd)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPicture(byte[] picture)
void | setRevision(java.lang.String revision)
void | setWanIp(java.lang.String wanIp)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PartDwgAgent

public PartDwgAgent()
Method Detail

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getLanIp

public java.lang.String getLanIp()

setLanIp

public void setLanIp(java.lang.String lanIp)

getMacAdd

public java.lang.String getMacAdd()

setMacAdd

public void setMacAdd(java.lang.String macAdd)

getWanIp

public java.lang.String getWanIp()

setWanIp

public void setWanIp(java.lang.String wanIp)

getFileName

public java.lang.String getFileName()

getPartDwgPk

public PartDwgPK getPartDwgPk()

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getPicture

public byte[] getPicture()

setPicture

public void setPicture(byte[] picture)

getDwgLength

public int getDwgLength()

setDwgLength

public void setDwgLength(int dwgLength)

getKey

public java.lang.String getKey()

setKey

public void setKey(java.lang.String key)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartDwgPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartDwgPK

java.lang.Object
    extended by  bb.common.PartDwgPK
All Implemented Interfaces:
java.io.Serializable
public class PartDwgPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PartDwgPK()
default constructor
PartDwgPK(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String revision, java.lang.String extension)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getExtension()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getRevision()
int | hashCode()
void | setExtension(java.lang.String extension)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setRevision(java.lang.String revision)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartDwgPK

public PartDwgPK(java.lang.String partNumber,
                 java.lang.String partType,
                 java.lang.String partFrom,
                 java.lang.String revision,
                 java.lang.String extension)
full constructor

PartDwgPK

public PartDwgPK()
default constructor

Method Detail

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartDwgVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartDwgVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartDwgVO
All Implemented Interfaces:
java.io.Serializable
public class PartDwgVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PartDwgVO()
default constructor
PartDwgVO(PartDwgPK pk, java.lang.String lastChangeUser, java.util.Date lastChangeDate, long dwgLength, java.lang.String dwgExtension)
full constructor
PartDwgVO(PartDwgPK pk, java.lang.String lastChangeUser, long dwgLength, java.lang.String dwgExtension)
minimal constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDwgExtension()
long | getDwgLength()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
byte[] | getPicture()
PartDwgPK | getPk()
int | hashCode()
void | setDwgExtension(java.lang.String dwgExtension)
void | setDwgLength(long dwgLength)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setPicture(byte[] picture)
void | setPk(PartDwgPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartDwgVO

public PartDwgVO(PartDwgPK pk,
                 java.lang.String lastChangeUser,
                 java.util.Date lastChangeDate,
                 long dwgLength,
                 java.lang.String dwgExtension)
full constructor

PartDwgVO

public PartDwgVO()
default constructor

PartDwgVO

public PartDwgVO(PartDwgPK pk,
                 java.lang.String lastChangeUser,
                 long dwgLength,
                 java.lang.String dwgExtension)
minimal constructor

Method Detail

getPk

public PartDwgPK getPk()

setPk

public void setPk(PartDwgPK pk)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getDwgLength

public long getDwgLength()

setDwgLength

public void setDwgLength(long dwgLength)

getDwgExtension

public java.lang.String getDwgExtension()

setDwgExtension

public void setDwgExtension(java.lang.String dwgExtension)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getPicture

public byte[] getPicture()

setPicture

public void setPicture(byte[] picture)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartDwgWithPartInfoResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartDwgWithPartInfoResult

java.lang.Object
    extended by  bb.common.PartDwgWithPartInfoResult
All Implemented Interfaces:
java.io.Serializable
public class PartDwgWithPartInfoResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DWGEXTENSION
static java.lang.String | ORDER_BY_DWGLENGTH
static java.lang.String | ORDER_BY_PARTDESCRIPTION
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTREVISION
static java.lang.String | ORDER_BY_REVISION
Constructor Summary
PartDwgWithPartInfoResult()
Method Summary
java.lang.String | getDwgExtension()
long | getDwgLength()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getPartDescription()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartRevision()
java.lang.String | getPartType()
byte[] | getPicture()
java.lang.String | getRevision()
void | setDwgExtension(java.lang.String dwgExtension)
void | setDwgLength(long dwgLength)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setPartDescription(java.lang.String partDescription)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartRevision(java.lang.String partRevision)
void | setPartType(java.lang.String partType)
void | setPicture(byte[] picture)
void | setRevision(java.lang.String revision)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_REVISION

public static final java.lang.String ORDER_BY_REVISION
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTDESCRIPTION

public static final java.lang.String ORDER_BY_PARTDESCRIPTION
See Also:
Constant Field Values

ORDER_BY_PARTREVISION

public static final java.lang.String ORDER_BY_PARTREVISION
See Also:
Constant Field Values

ORDER_BY_DWGLENGTH

public static final java.lang.String ORDER_BY_DWGLENGTH
See Also:
Constant Field Values

ORDER_BY_DWGEXTENSION

public static final java.lang.String ORDER_BY_DWGEXTENSION
See Also:
Constant Field Values
Constructor Detail

PartDwgWithPartInfoResult

public PartDwgWithPartInfoResult()
Method Detail

getDwgExtension

public java.lang.String getDwgExtension()

setDwgExtension

public void setDwgExtension(java.lang.String dwgExtension)

getDwgLength

public long getDwgLength()

setDwgLength

public void setDwgLength(long dwgLength)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getPartDescription

public java.lang.String getPartDescription()

setPartDescription

public void setPartDescription(java.lang.String partDescription)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartRevision

public java.lang.String getPartRevision()

setPartRevision

public void setPartRevision(java.lang.String partRevision)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPicture

public byte[] getPicture()

setPicture

public void setPicture(byte[] picture)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartExportInfo

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartExportInfo

java.lang.Object
    extended by  bb.common.PartBasicInfo
        extended by  bb.common.PartExportInfo
All Implemented Interfaces:
java.io.Serializable
public class PartExportInfo
extends PartBasicInfo
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
Fields inherited from class bb.common.PartBasicInfo
ORDER_BY_BILL, ORDER_BY_BUYERCODE, ORDER_BY_COMMODITYCODE, ORDER_BY_DESCRIPTION, ORDER_BY_DRAWING, ORDER_BY_HOLD, ORDER_BY_LASTCHANGEDATE, ORDER_BY_LASTUSER, ORDER_BY_MAKEBUY, ORDER_BY_MODELNUMBER, ORDER_BY_ORGANIZATION, ORDER_BY_ORIGIN, ORDER_BY_PARTNUMBER, ORDER_BY_PARTTYPE, ORDER_BY_PARTUNIT, ORDER_BY_PRODUCTCODE, ORDER_BY_SECURITYLEVEL, ORDER_BY_WEIGHT
Constructor Summary
PartExportInfo()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getCreatedDate()
java.lang.String | getOwner()
java.util.Date | getRevisionDate()
java.lang.String | getShippingWeight()
java.lang.String | getShippingWeightUnit()
int | hashCode()
void | setCreatedDate(java.util.Date createdDate)
void | setOwner(java.lang.String owner)
void | setRevisionDate(java.util.Date revisionDate)
void | setShippingWeight(java.lang.String shippingWeight)
void | setShippingWeightUnit(java.lang.String shippingWeightUnit)
java.lang.String | toString()
Methods inherited from class bb.common.PartBasicInfo
getBill, getBuyerCode, getCommodityCode, getCountryOrigin, getDescription, getDetectionStandard, getDrawing, getEngGroup, getHavePicture, getHold, getLastChangeDate, getLastUser, getLeadTime, getMakeBuy, getMaterial, getModelNumber, getOrigin, getPartPk, getPartUnit, getProductCode, getRevision, getSaleable, getSalesDrawing, getSecurityLevel, getTraceable, getVolume, getVolumeUnit, getWeight, getWeightUnit, getWi, setBill, setBuyerCode, setCommodityCode, setCountryOrigin, setDescription, setDetectionStandard, setDrawing, setEngGroup, setHavePicture, setHold, setLastChangeDate, setLastUser, setLeadTime, setMakeBuy, setMaterial, setModelNumber, setOrigin, setPartPk, setPartUnit, setProductCode, setRevision, setSaleable, setSalesDrawing, setSecurityLevel, setTraceable, setVolume, setVolumeUnit, setWeight, setWeightUnit, setWi
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartExportInfo

public PartExportInfo()
Method Detail

getCreatedDate

public java.util.Date getCreatedDate()

setCreatedDate

public void setCreatedDate(java.util.Date createdDate)

getOwner

public java.lang.String getOwner()

setOwner

public void setOwner(java.lang.String owner)

getRevisionDate

public java.util.Date getRevisionDate()

setRevisionDate

public void setRevisionDate(java.util.Date revisionDate)

getShippingWeight

public java.lang.String getShippingWeight()

setShippingWeight

public void setShippingWeight(java.lang.String shippingWeight)

getShippingWeightUnit

public java.lang.String getShippingWeightUnit()

setShippingWeightUnit

public void setShippingWeightUnit(java.lang.String shippingWeightUnit)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class PartBasicInfo

hashCode

public int hashCode()
Overrides:
hashCode in class PartBasicInfo

toString

public java.lang.String toString()
Overrides:
toString in class PartBasicInfo
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartInMrpListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartInMrpListResult

java.lang.Object
    extended by  bb.common.PartInMrpListResult
All Implemented Interfaces:
java.io.Serializable
public class PartInMrpListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartInMrpListResult()
Method Summary
java.lang.String | getDescription()
PartPK | getPartPk()
java.lang.String | getPartUnit()
java.util.ArrayList | getSoDetails()
java.math.BigDecimal | getTotalOndemand()
java.util.ArrayList | getWoDetails()
void | setDescription(java.lang.String description)
void | setPartPk(PartPK partPk)
void | setPartUnit(java.lang.String partUnit)
void | setSoDetails(java.util.ArrayList soDetails)
void | setTotalOndemand(java.math.BigDecimal totalOndemand)
void | setWoDetails(java.util.ArrayList woDetails)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PartInMrpListResult

public PartInMrpListResult()
Method Detail

getSoDetails

public java.util.ArrayList getSoDetails()

setSoDetails

public void setSoDetails(java.util.ArrayList soDetails)

getTotalOndemand

public java.math.BigDecimal getTotalOndemand()

setTotalOndemand

public void setTotalOndemand(java.math.BigDecimal totalOndemand)

getWoDetails

public java.util.ArrayList getWoDetails()

setWoDetails

public void setWoDetails(java.util.ArrayList woDetails)

getPartPk

public PartPK getPartPk()

setPartPk

public void setPartPk(PartPK partPk)

getPartUnit

public java.lang.String getPartUnit()

setPartUnit

public void setPartUnit(java.lang.String partUnit)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartInQAAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartInQAAgent

java.lang.Object
    extended by  bb.common.PartInQAAgent
All Implemented Interfaces:
java.io.Serializable
public class PartInQAAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartInQAAgent()
Method Summary
java.lang.String | getComments()
java.math.BigDecimal | getCost()
int | getIi()
java.lang.String | getNcrNumber()
BB2Part | getPart()
java.math.BigDecimal | getQty()
java.lang.String | getReceivedFrom()
java.lang.String | getRefDoc()
java.lang.String | getSerialNo()
void | setComments(java.lang.String comments)
void | setCost(java.math.BigDecimal cost)
void | setIi(int ii)
void | setNcrNumber(java.lang.String ncrNumber)
void | setPart(BB2Part part)
void | setQty(java.math.BigDecimal qty)
void | setReceivedFrom(java.lang.String receivedFrom)
void | setRefDoc(java.lang.String refDoc)
void | setSerialNo(java.lang.String serialNo)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PartInQAAgent

public PartInQAAgent()
Method Detail

getSerialNo

public java.lang.String getSerialNo()

setSerialNo

public void setSerialNo(java.lang.String serialNo)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getPart

public BB2Part getPart()

setPart

public void setPart(BB2Part part)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

getCost

public java.math.BigDecimal getCost()

setCost

public void setCost(java.math.BigDecimal cost)

getReceivedFrom

public java.lang.String getReceivedFrom()

setReceivedFrom

public void setReceivedFrom(java.lang.String receivedFrom)

getNcrNumber

public java.lang.String getNcrNumber()

setNcrNumber

public void setNcrNumber(java.lang.String ncrNumber)

getRefDoc

public java.lang.String getRefDoc()

setRefDoc

public void setRefDoc(java.lang.String refDoc)

setIi

public void setIi(int ii)

getIi

public int getIi()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartInQAResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartInQAResult

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartInQAResult
All Implemented Interfaces:
java.io.Serializable
public class PartInQAResult
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartInQAResult()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.math.BigDecimal | getCost()
java.lang.Integer | getIi()
java.lang.String | getNcrNumber()
java.lang.String | getPartDescription()
java.lang.String | getPartFrom()
java.util.List | getPartInqaItems()
java.lang.String | getPartNumber()
java.util.List | getPartOnhand()
java.lang.String | getPartType()
java.math.BigDecimal | getQuantity()
java.lang.String | getReceivedBy()
java.util.Date | getReceivedDate()
java.lang.String | getReceivedFrom()
int | hashCode()
void | setComments(java.lang.String comments)
void | setCost(java.math.BigDecimal cost)
void | setIi(java.lang.Integer ii)
void | setNcrNumber(java.lang.String ncrNumber)
void | setPartDescription(java.lang.String partDescription)
void | setPartFrom(java.lang.String partFrom)
void | setPartInqaItems(java.util.List partInqaItems)
void | setPartNumber(java.lang.String partNumber)
void | setPartOnhand(java.util.List partonhand)
void | setPartType(java.lang.String partType)
void | setQuantity(java.math.BigDecimal quantity)
void | setReceivedBy(java.lang.String receivedBy)
void | setReceivedDate(java.util.Date receivedDate)
void | setReceivedFrom(java.lang.String receivedFrom)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartInQAResult

public PartInQAResult()
Method Detail

getIi

public java.lang.Integer getIi()

setIi

public void setIi(java.lang.Integer ii)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getCost

public java.math.BigDecimal getCost()

setCost

public void setCost(java.math.BigDecimal cost)

getReceivedDate

public java.util.Date getReceivedDate()

setReceivedDate

public void setReceivedDate(java.util.Date receivedDate)

getReceivedBy

public java.lang.String getReceivedBy()

setReceivedBy

public void setReceivedBy(java.lang.String receivedBy)

getReceivedFrom

public java.lang.String getReceivedFrom()

setReceivedFrom

public void setReceivedFrom(java.lang.String receivedFrom)

getNcrNumber

public java.lang.String getNcrNumber()

setNcrNumber

public void setNcrNumber(java.lang.String ncrNumber)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getPartDescription

public java.lang.String getPartDescription()

setPartDescription

public void setPartDescription(java.lang.String partDescription)

getPartInqaItems

public java.util.List getPartInqaItems()

setPartInqaItems

public void setPartInqaItems(java.util.List partInqaItems)

getPartOnhand

public java.util.List getPartOnhand()

setPartOnhand

public void setPartOnhand(java.util.List partonhand)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartInQAVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartInQAVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartInQAVO
All Implemented Interfaces:
java.io.Serializable
public class PartInQAVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_COST
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_QUANTITY
static java.lang.String | ORDER_BY_RECEIVEDBY
static java.lang.String | ORDER_BY_RECEIVEDDATE
static java.lang.String | ORDER_BY_RECEIVEDFROM
static java.lang.String | ORDER_BY_SERIALNO
Constructor Summary
PartInQAVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.math.BigDecimal | getCost()
java.lang.Integer | getIi()
java.lang.String | getNcrNumber()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getQuantity()
java.lang.String | getReceivedBy()
java.util.Date | getReceivedDate()
java.lang.String | getReceivedFrom()
java.lang.String | getReceiverNumber()
java.lang.String | getRefDoc()
java.lang.String | getSerialNo()
int | hashCode()
void | setComments(java.lang.String comments)
void | setCost(java.math.BigDecimal cost)
void | setIi(java.lang.Integer ii)
void | setNcrNumber(java.lang.String ncrNumber)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setQuantity(java.math.BigDecimal quantity)
void | setReceivedBy(java.lang.String receivedBy)
void | setReceivedDate(java.util.Date receivedDate)
void | setReceivedFrom(java.lang.String receivedFrom)
void | setReceiverNumber(java.lang.String receiverNumber)
void | setRefDoc(java.lang.String refDoc)
void | setSerialNo(java.lang.String serialNo)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_QUANTITY

public static final java.lang.String ORDER_BY_QUANTITY
See Also:
Constant Field Values

ORDER_BY_COST

public static final java.lang.String ORDER_BY_COST
See Also:
Constant Field Values

ORDER_BY_RECEIVEDDATE

public static final java.lang.String ORDER_BY_RECEIVEDDATE
See Also:
Constant Field Values

ORDER_BY_RECEIVEDBY

public static final java.lang.String ORDER_BY_RECEIVEDBY
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values

ORDER_BY_RECEIVEDFROM

public static final java.lang.String ORDER_BY_RECEIVEDFROM
See Also:
Constant Field Values

ORDER_BY_SERIALNO

public static final java.lang.String ORDER_BY_SERIALNO
See Also:
Constant Field Values
Constructor Detail

PartInQAVO

public PartInQAVO()
Method Detail

getIi

public java.lang.Integer getIi()

setIi

public void setIi(java.lang.Integer ii)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getCost

public java.math.BigDecimal getCost()

setCost

public void setCost(java.math.BigDecimal cost)

getReceivedDate

public java.util.Date getReceivedDate()

setReceivedDate

public void setReceivedDate(java.util.Date receivedDate)

getReceivedBy

public java.lang.String getReceivedBy()

setReceivedBy

public void setReceivedBy(java.lang.String receivedBy)

getReceivedFrom

public java.lang.String getReceivedFrom()

setReceivedFrom

public void setReceivedFrom(java.lang.String receivedFrom)

getNcrNumber

public java.lang.String getNcrNumber()

setNcrNumber

public void setNcrNumber(java.lang.String ncrNumber)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getRefDoc

public java.lang.String getRefDoc()

setRefDoc

public void setRefDoc(java.lang.String refDoc)

getSerialNo

public java.lang.String getSerialNo()

setSerialNo

public void setSerialNo(java.lang.String serialNo)

getReceiverNumber

public java.lang.String getReceiverNumber()

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartInspectionPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartInspectionPK

java.lang.Object
    extended by  bb.common.PartInspectionPK
All Implemented Interfaces:
java.io.Serializable
public class PartInspectionPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartInspectionPK()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getItemNumber()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
int | hashCode()
void | setItemNumber(java.lang.String itemNumber)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartInspectionPK

public PartInspectionPK()
Method Detail

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getItemNumber

public java.lang.String getItemNumber()

setItemNumber

public void setItemNumber(java.lang.String itemNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartInspectionResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartInspectionResult

java.lang.Object
    extended by  bb.common.PartInspectionResult
All Implemented Interfaces:
java.io.Serializable
public class PartInspectionResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_INSPECTIONTYPE
static java.lang.String | ORDER_BY_PARTDESCRIPTION
static java.lang.String | ORDER_BY_PARTNUMBER
Constructor Summary
PartInspectionResult()
Method Summary
java.lang.String | getDescription()
java.util.Set | getInspections()
java.lang.String | getInspectionType()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
void | setDescription(java.lang.String description)
void | setInspections(java.util.Set inspections)
void | setInspectionType(java.lang.String inspectionType)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTDESCRIPTION

public static final java.lang.String ORDER_BY_PARTDESCRIPTION
See Also:
Constant Field Values

ORDER_BY_INSPECTIONTYPE

public static final java.lang.String ORDER_BY_INSPECTIONTYPE
See Also:
Constant Field Values
Constructor Detail

PartInspectionResult

public PartInspectionResult()
Method Detail

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getInspectionType

public java.lang.String getInspectionType()

setInspectionType

public void setInspectionType(java.lang.String inspectionType)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getInspections

public java.util.Set getInspections()

setInspections

public void setInspections(java.util.Set inspections)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartInspectionVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartInspectionVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartInspectionVO
All Implemented Interfaces:
java.io.Serializable
public class PartInspectionVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_INSPECTPROJECT
static java.lang.String | ORDER_BY_TECHNOLGYSTANDARD
static java.lang.String | ORDER_BY_UNIT
Constructor Summary
PartInspectionVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getInspectProject()
PartInspectionPK | getPk()
java.lang.String | getTechnolgyStandard()
java.lang.String | getUnit()
int | hashCode()
void | setInspectProject(java.lang.String inspectProject)
void | setPk(PartInspectionPK pk)
void | setTechnolgyStandard(java.lang.String technolgyStandard)
void | setUnit(java.lang.String unit)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_INSPECTPROJECT

public static final java.lang.String ORDER_BY_INSPECTPROJECT
See Also:
Constant Field Values

ORDER_BY_UNIT

public static final java.lang.String ORDER_BY_UNIT
See Also:
Constant Field Values

ORDER_BY_TECHNOLGYSTANDARD

public static final java.lang.String ORDER_BY_TECHNOLGYSTANDARD
See Also:
Constant Field Values
Constructor Detail

PartInspectionVO

public PartInspectionVO()
Method Detail

getInspectProject

public java.lang.String getInspectProject()

setInspectProject

public void setInspectProject(java.lang.String inspectProject)

getPk

public PartInspectionPK getPk()

setPk

public void setPk(PartInspectionPK pk)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getTechnolgyStandard

public java.lang.String getTechnolgyStandard()

setTechnolgyStandard

public void setTechnolgyStandard(java.lang.String technolgyStandard)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartInventoryVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartInventoryVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartInventoryVO
All Implemented Interfaces:
java.io.Serializable
public class PartInventoryVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartInventoryVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getActive()
java.math.BigDecimal | getAverageCost()
java.lang.String | getCCode()
java.math.BigDecimal | getConsignedQty()
int | getCycleCount()
java.lang.String | getDCode()
java.lang.String | getECode()
java.math.BigDecimal | getFirstInCost()
java.lang.String | getGa()
java.math.BigDecimal | getInQualityCheckingQty()
java.math.BigDecimal | getInSTO()
java.util.Date | getLastCount()
java.util.Date | getLastInDate()
java.util.Date | getLastOutDate()
java.math.BigDecimal | getLastPurchaseCost()
java.lang.String | getLastPurchaseOrderItemNumber()
java.lang.String | getLastPurchaseOrderNumber()
java.math.BigDecimal | getLeadTime()
java.math.BigDecimal | getListPrice()
java.math.BigDecimal | getMaxQty()
java.math.BigDecimal | getMinQty()
java.lang.String | getModelNumber()
java.lang.String | getOCode()
java.math.BigDecimal | getOnDemandQty()
java.math.BigDecimal | getOnhand()
java.math.BigDecimal | getOnloanQty()
java.math.BigDecimal | getOnOrderQty()
java.lang.String | getPartClass()
java.lang.String | getPCode()
PartPK | getPk()
java.math.BigDecimal | getPurchaseCost()
java.lang.String | getPurchaseOrderUnit()
java.math.BigDecimal | getQuarterUsage()
java.math.BigDecimal | getReceivedQty()
java.util.Date | getRecostedDate()
java.lang.String | getSalesOrderUnit()
java.math.BigDecimal | getShipInProcessQty()
java.math.BigDecimal | getShipInTransactionQty()
java.math.BigDecimal | getShippedQty()
java.math.BigDecimal | getStandardCost()
java.math.BigDecimal | getVarianceCost()
java.lang.Integer | getVersion()
java.math.BigDecimal | getWorkInProcessQty()
java.math.BigDecimal | getYearUsage()
int | hashCode()
void | setActive(java.lang.String active)
void | setAverageCost(java.math.BigDecimal averageCost)
void | setCCode(java.lang.String cCode)
void | setConsignedQty(java.math.BigDecimal consignedQty)
void | setCycleCount(int cycleCount)
void | setDCode(java.lang.String dCode)
void | setECode(java.lang.String eCode)
void | setFirstInCost(java.math.BigDecimal firstInCost)
void | setGa(java.lang.String ga)
void | setInQualityCheckingQty(java.math.BigDecimal inQualityCheckingQty)
void | setInSTO(java.math.BigDecimal inSTO)
void | setLastCount(java.util.Date lastCount)
void | setLastInDate(java.util.Date lastInDate)
void | setLastOutDate(java.util.Date lastOutDate)
void | setLastPurchaseCost(java.math.BigDecimal lastPurchaseCost)
void | setLastPurchaseOrderItemNumber(java.lang.String lastPurchaseOrderItemNumber)
void | setLastPurchaseOrderNumber(java.lang.String lastPurchaseOrderNumber)
void | setLeadTime(java.math.BigDecimal leadTime)
void | setListPrice(java.math.BigDecimal listPrice)
void | setMaxQty(java.math.BigDecimal maxQty)
void | setMinQty(java.math.BigDecimal minQty)
void | setModelNumber(java.lang.String modelNumber)
void | setOCode(java.lang.String oCode)
void | setOnDemandQty(java.math.BigDecimal onDemandQty)
void | setOnhand(java.math.BigDecimal onhand)
void | setOnloanQty(java.math.BigDecimal onloanQty)
void | setOnOrderQty(java.math.BigDecimal onOrderQty)
void | setPartClass(java.lang.String partClass)
void | setPCode(java.lang.String pCode)
void | setPk(PartPK pk)
void | setPurchaseCost(java.math.BigDecimal purchaseCost)
void | setPurchaseOrderUnit(java.lang.String purchaseOrderUnit)
void | setQuarterUsage(java.math.BigDecimal quarterUsage)
void | setReceivedQty(java.math.BigDecimal receivedQty)
void | setRecostedDate(java.util.Date recostedDate)
void | setSalesOrderUnit(java.lang.String salesOrderUnit)
void | setShipInProcessQty(java.math.BigDecimal shipInProcessQty)
void | setShipInTransactionQty(java.math.BigDecimal shipInTransactionQty)
void | setShippedQty(java.math.BigDecimal shippedQty)
void | setStandardCost(java.math.BigDecimal standardCost)
void | setVarianceCost(java.math.BigDecimal varianceCost)
void | setVersion(java.lang.Integer version)
void | setWorkInProcessQty(java.math.BigDecimal workInProcessQty)
void | setYearUsage(java.math.BigDecimal yearUsage)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartInventoryVO

public PartInventoryVO()
Method Detail

getPk

public PartPK getPk()

setPk

public void setPk(PartPK pk)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getActive

public java.lang.String getActive()

setActive

public void setActive(java.lang.String active)

getOnhand

public java.math.BigDecimal getOnhand()

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

getShippedQty

public java.math.BigDecimal getShippedQty()

setShippedQty

public void setShippedQty(java.math.BigDecimal shippedQty)

getReceivedQty

public java.math.BigDecimal getReceivedQty()

setReceivedQty

public void setReceivedQty(java.math.BigDecimal receivedQty)

getWorkInProcessQty

public java.math.BigDecimal getWorkInProcessQty()

setWorkInProcessQty

public void setWorkInProcessQty(java.math.BigDecimal workInProcessQty)

getOnloanQty

public java.math.BigDecimal getOnloanQty()

setOnloanQty

public void setOnloanQty(java.math.BigDecimal onloanQty)

getConsignedQty

public java.math.BigDecimal getConsignedQty()

setConsignedQty

public void setConsignedQty(java.math.BigDecimal consignedQty)

getInQualityCheckingQty

public java.math.BigDecimal getInQualityCheckingQty()

setInQualityCheckingQty

public void setInQualityCheckingQty(java.math.BigDecimal inQualityCheckingQty)

getOnDemandQty

public java.math.BigDecimal getOnDemandQty()

setOnDemandQty

public void setOnDemandQty(java.math.BigDecimal onDemandQty)

getOnOrderQty

public java.math.BigDecimal getOnOrderQty()

setOnOrderQty

public void setOnOrderQty(java.math.BigDecimal onOrderQty)

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

getAverageCost

public java.math.BigDecimal getAverageCost()

setAverageCost

public void setAverageCost(java.math.BigDecimal averageCost)

getStandardCost

public java.math.BigDecimal getStandardCost()

setStandardCost

public void setStandardCost(java.math.BigDecimal standardCost)

getPCode

public java.lang.String getPCode()

setPCode

public void setPCode(java.lang.String pCode)

getCCode

public java.lang.String getCCode()

setCCode

public void setCCode(java.lang.String cCode)

getOCode

public java.lang.String getOCode()

setOCode

public void setOCode(java.lang.String oCode)

getDCode

public java.lang.String getDCode()

setDCode

public void setDCode(java.lang.String dCode)

getECode

public java.lang.String getECode()

setECode

public void setECode(java.lang.String eCode)

getPurchaseOrderUnit

public java.lang.String getPurchaseOrderUnit()

setPurchaseOrderUnit

public void setPurchaseOrderUnit(java.lang.String purchaseOrderUnit)

getSalesOrderUnit

public java.lang.String getSalesOrderUnit()

setSalesOrderUnit

public void setSalesOrderUnit(java.lang.String salesOrderUnit)

getLeadTime

public java.math.BigDecimal getLeadTime()

setLeadTime

public void setLeadTime(java.math.BigDecimal leadTime)

getMinQty

public java.math.BigDecimal getMinQty()

setMinQty

public void setMinQty(java.math.BigDecimal minQty)

getMaxQty

public java.math.BigDecimal getMaxQty()

setMaxQty

public void setMaxQty(java.math.BigDecimal maxQty)

getYearUsage

public java.math.BigDecimal getYearUsage()

setYearUsage

public void setYearUsage(java.math.BigDecimal yearUsage)

getQuarterUsage

public java.math.BigDecimal getQuarterUsage()

setQuarterUsage

public void setQuarterUsage(java.math.BigDecimal quarterUsage)

getGa

public java.lang.String getGa()

setGa

public void setGa(java.lang.String ga)

getPurchaseCost

public java.math.BigDecimal getPurchaseCost()

getVersion

public java.lang.Integer getVersion()

getShipInProcessQty

public java.math.BigDecimal getShipInProcessQty()

getShipInTransactionQty

public java.math.BigDecimal getShipInTransactionQty()

getRecostedDate

public java.util.Date getRecostedDate()

setPurchaseCost

public void setPurchaseCost(java.math.BigDecimal purchaseCost)

setVersion

public void setVersion(java.lang.Integer version)

setShipInProcessQty

public void setShipInProcessQty(java.math.BigDecimal shipInProcessQty)

setShipInTransactionQty

public void setShipInTransactionQty(java.math.BigDecimal shipInTransactionQty)

setRecostedDate

public void setRecostedDate(java.util.Date recostedDate)

getLastInDate

public java.util.Date getLastInDate()

setLastInDate

public void setLastInDate(java.util.Date lastInDate)

getLastOutDate

public java.util.Date getLastOutDate()

setLastOutDate

public void setLastOutDate(java.util.Date lastOutDate)

getPartClass

public java.lang.String getPartClass()

setPartClass

public void setPartClass(java.lang.String partClass)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getFirstInCost

public java.math.BigDecimal getFirstInCost()

setFirstInCost

public void setFirstInCost(java.math.BigDecimal firstInCost)

getVarianceCost

public java.math.BigDecimal getVarianceCost()

setVarianceCost

public void setVarianceCost(java.math.BigDecimal varianceCost)

getLastPurchaseCost

public java.math.BigDecimal getLastPurchaseCost()

setLastPurchaseCost

public void setLastPurchaseCost(java.math.BigDecimal lastPurchaseCost)

getLastPurchaseOrderItemNumber

public java.lang.String getLastPurchaseOrderItemNumber()

setLastPurchaseOrderItemNumber

public void setLastPurchaseOrderItemNumber(java.lang.String lastPurchaseOrderItemNumber)

getLastPurchaseOrderNumber

public java.lang.String getLastPurchaseOrderNumber()

setLastPurchaseOrderNumber

public void setLastPurchaseOrderNumber(java.lang.String lastPurchaseOrderNumber)

getInSTO

public java.math.BigDecimal getInSTO()

setInSTO

public void setInSTO(java.math.BigDecimal inSTO)

getCycleCount

public int getCycleCount()

setCycleCount

public void setCycleCount(int cycleCount)

getLastCount

public java.util.Date getLastCount()

setLastCount

public void setLastCount(java.util.Date lastCount)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartInWipForIDListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartInWipForIDListResult

java.lang.Object
    extended by  bb.common.PartInWipForIDListResult
All Implemented Interfaces:
java.io.Serializable
public class PartInWipForIDListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_PART
static java.lang.String | ORDER_BY_PARTINWIP
static java.lang.String | ORDER_BY_PARTINWIPDESCRIPTION
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_WORKORDERNUMBER
Constructor Summary
PartInWipForIDListResult()
Method Summary
java.math.BigDecimal | getAvgCost()
java.lang.String | getDescription()
java.math.BigDecimal | getInWipQty()
java.math.BigDecimal | getIssuedQty()
BB2Part | getPart()
BB2Part | getPartInWip()
java.lang.String | getPartInWipDescription()
java.math.BigDecimal | getStdCost()
java.lang.String | getVendorId()
java.lang.String | getWorkorderItemNumber()
java.lang.String | getWorkOrderNumber()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setDescription(java.lang.String description)
void | setInWipQty(java.math.BigDecimal inWipQty)
void | setIssuedQty(java.math.BigDecimal issuedQty)
void | setPart(BB2Part part)
void | setPartInWip(BB2Part partInWip)
void | setPartInWipDescription(java.lang.String partInWipDescription)
void | setStdCost(java.math.BigDecimal stdCost)
void | setVendorId(java.lang.String vendorId)
void | setWorkorderItemNumber(java.lang.String workorderItemNumber)
void | setWorkOrderNumber(java.lang.String workOrderNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_WORKORDERNUMBER

public static final java.lang.String ORDER_BY_WORKORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_PARTINWIPDESCRIPTION

public static final java.lang.String ORDER_BY_PARTINWIPDESCRIPTION
See Also:
Constant Field Values

ORDER_BY_PARTINWIP

public static final java.lang.String ORDER_BY_PARTINWIP
See Also:
Constant Field Values

ORDER_BY_PART

public static final java.lang.String ORDER_BY_PART
See Also:
Constant Field Values
Constructor Detail

PartInWipForIDListResult

public PartInWipForIDListResult()
Method Detail

setWorkOrderNumber

public void setWorkOrderNumber(java.lang.String workOrderNumber)

setWorkorderItemNumber

public void setWorkorderItemNumber(java.lang.String workorderItemNumber)

setPart

public void setPart(BB2Part part)

setDescription

public void setDescription(java.lang.String description)

setIssuedQty

public void setIssuedQty(java.math.BigDecimal issuedQty)

setInWipQty

public void setInWipQty(java.math.BigDecimal inWipQty)

setVendorId

public void setVendorId(java.lang.String vendorId)

getWorkOrderNumber

public java.lang.String getWorkOrderNumber()

getWorkorderItemNumber

public java.lang.String getWorkorderItemNumber()

getPart

public BB2Part getPart()

getDescription

public java.lang.String getDescription()

getIssuedQty

public java.math.BigDecimal getIssuedQty()

getInWipQty

public java.math.BigDecimal getInWipQty()

getAvgCost

public java.math.BigDecimal getAvgCost()

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getVendorId

public java.lang.String getVendorId()

getPartInWip

public BB2Part getPartInWip()

setPartInWip

public void setPartInWip(BB2Part partInWip)

getPartInWipDescription

public java.lang.String getPartInWipDescription()

setPartInWipDescription

public void setPartInWipDescription(java.lang.String partInWipDescription)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartIssuedListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartIssuedListResult

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartIssuedVO
            extended by  bb.common.PartIssuedListResult
All Implemented Interfaces:
java.io.Serializable
public class PartIssuedListResult
extends PartIssuedVO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_DATEISSUED
static java.lang.String | ORDER_BY_DATEREQUIRED
static java.lang.String | ORDER_BY_LOCATE
static java.lang.String | ORDER_BY_ORDERNUMBER
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_project
static java.lang.String | ORDER_BY_RELATEDDOC
static java.lang.String | ORDER_BY_TRANSACTIONNUMBER
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_WORKORDERNUMBER
Fields inherited from class bb.common.PartIssuedVO
ORDER_BY_PICKER
Constructor Summary
PartIssuedListResult()
Method Summary
java.lang.String | getCurrency()
java.math.BigDecimal | getCurrentOnhand()
java.util.Date | getDateRequired()
java.lang.String | getProject()
java.lang.String | getRelatedDoc()
java.math.BigDecimal | getStdCostSubTotal()
java.math.BigDecimal | getStdCostSubTotal(int length)
java.math.BigDecimal | getTotalIssued()
void | setCurrency(java.lang.String currency)
void | setCurrentOnhand(java.math.BigDecimal currentOnhand)
void | setDateRequired(java.util.Date dateRequired)
void | setProject(java.lang.String project)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setTotalIssued(java.math.BigDecimal totalIssued)
Methods inherited from class bb.common.PartIssuedVO
equals, getCost, getDateIssued, getDescription, getIi, getItemNumber, getLocate, getLot, getNote, getOperator, getOrderNumber, getPartFrom, getPartNumber, getPartType, getPicker, getQtyIssued, getSerial, getStdCost, getTrackings, getTransactionNumber, getUnit, getVendorId, getWoisii, getWorkOrderItemNumber, getWorkOrderNumber, hashCode, setCost, setDateIssued, setDescription, setIi, setItemNumber, setLocate, setLot, setNote, setOperator, setOrderNumber, setPartFrom, setPartNumber, setPartType, setPicker, setQtyIssued, setSerial, setStdCost, setTrackings, setTransactionNumber, setUnit, setVendorId, setWoisii, setWorkOrderItemNumber, setWorkOrderNumber, toString
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ORDERNUMBER

public static final java.lang.String ORDER_BY_ORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_WORKORDERNUMBER

public static final java.lang.String ORDER_BY_WORKORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_DATEISSUED

public static final java.lang.String ORDER_BY_DATEISSUED
See Also:
Constant Field Values

ORDER_BY_RELATEDDOC

public static final java.lang.String ORDER_BY_RELATEDDOC
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values

ORDER_BY_DATEREQUIRED

public static final java.lang.String ORDER_BY_DATEREQUIRED
See Also:
Constant Field Values

ORDER_BY_LOCATE

public static final java.lang.String ORDER_BY_LOCATE
See Also:
Constant Field Values

ORDER_BY_TRANSACTIONNUMBER

public static final java.lang.String ORDER_BY_TRANSACTIONNUMBER
See Also:
Constant Field Values

ORDER_BY_project

public static final java.lang.String ORDER_BY_project
See Also:
Constant Field Values
Constructor Detail

PartIssuedListResult

public PartIssuedListResult()
Method Detail

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getDateRequired

public java.util.Date getDateRequired()

setDateRequired

public void setDateRequired(java.util.Date dateRequired)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getCurrentOnhand

public java.math.BigDecimal getCurrentOnhand()

setCurrentOnhand

public void setCurrentOnhand(java.math.BigDecimal currentOnhand)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

getTotalIssued

public java.math.BigDecimal getTotalIssued()

setTotalIssued

public void setTotalIssued(java.math.BigDecimal totalIssued)

getStdCostSubTotal

public java.math.BigDecimal getStdCostSubTotal(int length)
Overrides:
getStdCostSubTotal in class PartIssuedVO

getStdCostSubTotal

public java.math.BigDecimal getStdCostSubTotal()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartIssuedVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartIssuedVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartIssuedVO
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
PartIssuedListResult
public class PartIssuedVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DATEISSUED
static java.lang.String | ORDER_BY_LOCATE
static java.lang.String | ORDER_BY_ORDERNUMBER
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PICKER
static java.lang.String | ORDER_BY_TRANSACTIONNUMBER
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_WORKORDERNUMBER
Constructor Summary
PartIssuedVO()
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getCost()
java.util.Date | getDateIssued()
java.lang.String | getDescription()
java.lang.Integer | getIi()
java.lang.Short | getItemNumber()
java.lang.String | getLocate()
java.lang.String | getLot()
java.lang.String | getNote()
java.lang.String | getOperator()
java.lang.Integer | getOrderNumber()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getPicker()
java.math.BigDecimal | getQtyIssued()
java.lang.String | getSerial()
java.math.BigDecimal | getStdCost()
java.math.BigDecimal | getStdCostSubTotal(int length)
java.util.Map | getTrackings()
java.lang.String | getTransactionNumber()
java.lang.String | getUnit()
java.lang.String | getVendorId()
java.lang.Short | getWoisii()
java.lang.String | getWorkOrderItemNumber()
java.lang.String | getWorkOrderNumber()
int | hashCode()
void | setCost(java.math.BigDecimal cost)
void | setDateIssued(java.util.Date dateIssued)
void | setDescription(java.lang.String description)
void | setIi(java.lang.Integer ii)
void | setItemNumber(java.lang.Short itemNumber)
void | setLocate(java.lang.String locate)
void | setLot(java.lang.String lot)
void | setNote(java.lang.String note)
void | setOperator(java.lang.String operator)
void | setOrderNumber(java.lang.Integer orderNumber)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPicker(java.lang.String picker)
void | setQtyIssued(java.math.BigDecimal qtyIssued)
void | setSerial(java.lang.String serial)
void | setStdCost(java.math.BigDecimal stdCost)
void | setTrackings(java.util.Map trackings)
void | setTransactionNumber(java.lang.String transactionNumber)
void | setUnit(java.lang.String unit)
void | setVendorId(java.lang.String vendorId)
void | setWoisii(java.lang.Short woisii)
void | setWorkOrderItemNumber(java.lang.String workOrderItemNumber)
void | setWorkOrderNumber(java.lang.String workOrderNumber)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ORDERNUMBER

public static final java.lang.String ORDER_BY_ORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_WORKORDERNUMBER

public static final java.lang.String ORDER_BY_WORKORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_DATEISSUED

public static final java.lang.String ORDER_BY_DATEISSUED
See Also:
Constant Field Values

ORDER_BY_LOCATE

public static final java.lang.String ORDER_BY_LOCATE
See Also:
Constant Field Values

ORDER_BY_PICKER

public static final java.lang.String ORDER_BY_PICKER
See Also:
Constant Field Values

ORDER_BY_TRANSACTIONNUMBER

public static final java.lang.String ORDER_BY_TRANSACTIONNUMBER
See Also:
Constant Field Values
Constructor Detail

PartIssuedVO

public PartIssuedVO()
Method Detail

getIi

public java.lang.Integer getIi()

setIi

public void setIi(java.lang.Integer ii)

getWoisii

public java.lang.Short getWoisii()

setWoisii

public void setWoisii(java.lang.Short woisii)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getWorkOrderNumber

public java.lang.String getWorkOrderNumber()

setWorkOrderNumber

public void setWorkOrderNumber(java.lang.String workOrderNumber)

getWorkOrderItemNumber

public java.lang.String getWorkOrderItemNumber()

setWorkOrderItemNumber

public void setWorkOrderItemNumber(java.lang.String workOrderItemNumber)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getQtyIssued

public java.math.BigDecimal getQtyIssued()

setQtyIssued

public void setQtyIssued(java.math.BigDecimal qtyIssued)

getDateIssued

public java.util.Date getDateIssued()

setDateIssued

public void setDateIssued(java.util.Date dateIssued)

getCost

public java.math.BigDecimal getCost()

setCost

public void setCost(java.math.BigDecimal cost)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getSerial

public java.lang.String getSerial()

setSerial

public void setSerial(java.lang.String serial)

getLot

public java.lang.String getLot()

getOperator

public java.lang.String getOperator()

setLot

public void setLot(java.lang.String lot)

setOperator

public void setOperator(java.lang.String operator)

getItemNumber

public java.lang.Short getItemNumber()

setItemNumber

public void setItemNumber(java.lang.Short itemNumber)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getNote

public java.lang.String getNote()

setNote

public void setNote(java.lang.String note)

getOrderNumber

public java.lang.Integer getOrderNumber()

setOrderNumber

public void setOrderNumber(java.lang.Integer orderNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getPicker

public java.lang.String getPicker()

setPicker

public void setPicker(java.lang.String picker)

getTransactionNumber

public java.lang.String getTransactionNumber()

setTransactionNumber

public void setTransactionNumber(java.lang.String transactionNumber)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getStdCostSubTotal

public java.math.BigDecimal getStdCostSubTotal(int length)

getTrackings

public java.util.Map getTrackings()

setTrackings

public void setTrackings(java.util.Map trackings)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartIssueTotalResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartIssueTotalResult

java.lang.Object
    extended by  bb.common.PartIssueTotalResult
All Implemented Interfaces:
java.io.Serializable
public class PartIssueTotalResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartIssueTotalResult()
Method Summary
java.lang.Integer | getNumOfItems()
java.math.BigDecimal | getTotIssued()
java.math.BigDecimal | getTotIssuedAvgCost()
java.math.BigDecimal | getTotIssuedStdCost()
void | setNumOfItems(java.lang.Integer numOfItems)
void | setTotIssued(java.math.BigDecimal totIssued)
void | setTotIssuedAvgCost(java.math.BigDecimal totIssuedAvgCost)
void | setTotIssuedStdCost(java.math.BigDecimal totIssuedStdCost)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PartIssueTotalResult

public PartIssueTotalResult()
Method Detail

setNumOfItems

public void setNumOfItems(java.lang.Integer numOfItems)

setTotIssued

public void setTotIssued(java.math.BigDecimal totIssued)

setTotIssuedAvgCost

public void setTotIssuedAvgCost(java.math.BigDecimal totIssuedAvgCost)

getNumOfItems

public java.lang.Integer getNumOfItems()

getTotIssued

public java.math.BigDecimal getTotIssued()

getTotIssuedAvgCost

public java.math.BigDecimal getTotIssuedAvgCost()

getTotIssuedStdCost

public java.math.BigDecimal getTotIssuedStdCost()

setTotIssuedStdCost

public void setTotIssuedStdCost(java.math.BigDecimal totIssuedStdCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartManufacturerAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartManufacturerAgent

java.lang.Object
    extended by  bb.common.PartManufacturerAgent

public class PartManufacturerAgent
extends java.lang.Object

Constructor Summary
PartManufacturerAgent()
Method Summary
java.lang.String | getMfg()
java.lang.String | getMpn()
java.lang.String | getMpnRev()
void | setMfg(java.lang.String mfg)
void | setMpn(java.lang.String mpn)
void | setMpnRev(java.lang.String mpnRev)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PartManufacturerAgent

public PartManufacturerAgent()
Method Detail

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getMpnRev

public java.lang.String getMpnRev()

setMpnRev

public void setMpnRev(java.lang.String mpnRev)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartManufacturerPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartManufacturerPK

java.lang.Object
    extended by  bb.common.PartManufacturerPK
All Implemented Interfaces:
java.io.Serializable
public class PartManufacturerPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PartManufacturerPK()
default constructor
PartManufacturerPK(java.lang.String partNumber, java.lang.String partType, java.lang.Short manufacturerItem)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Short | getManufacturerItem()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
int | hashCode()
void | setManufacturerItem(java.lang.Short manufacturerItem)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartManufacturerPK

public PartManufacturerPK(java.lang.String partNumber,
                          java.lang.String partType,
                          java.lang.Short manufacturerItem)
full constructor

PartManufacturerPK

public PartManufacturerPK()
default constructor

Method Detail

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getManufacturerItem

public java.lang.Short getManufacturerItem()

setManufacturerItem

public void setManufacturerItem(java.lang.Short manufacturerItem)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartManufacturerVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartManufacturerVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartManufacturerVO
All Implemented Interfaces:
java.io.Serializable
public class PartManufacturerVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartManufacturerVO()
PartManufacturerVO(PartPK partPk)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getManufacturerId()
java.lang.String | getManufacturerName()
java.lang.String | getManufacturerPartNumber()
java.lang.String | getManufacturerPartRev()
PartManufacturerPK | getPk()
java.lang.String | getQualityCode()
java.lang.String | getRatingCode()
java.lang.String | getRemarks()
java.lang.String | getUnit()
java.lang.Integer | getVersion()
int | hashCode()
boolean | isPreferredPo()
boolean | isPreferredSo()
void | setManufacturerId(java.lang.String manufacturerId)
void | setManufacturerName(java.lang.String manufacturerName)
void | setManufacturerPartNumber(java.lang.String manufacturerPartNumber)
void | setManufacturerPartRev(java.lang.String manufacturerPartRev)
void | setPk(PartManufacturerPK pk)
void | setPreferredPo(boolean preferredPo)
void | setPreferredSo(boolean preferredSo)
void | setQualityCode(java.lang.String qualityCode)
void | setRatingCode(java.lang.String ratingCode)
void | setRemarks(java.lang.String remarks)
void | setUnit(java.lang.String unit)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartManufacturerVO

public PartManufacturerVO()

PartManufacturerVO

public PartManufacturerVO(PartPK partPk)
Method Detail

getPk

public PartManufacturerPK getPk()

setPk

public void setPk(PartManufacturerPK pk)

getManufacturerId

public java.lang.String getManufacturerId()

setManufacturerId

public void setManufacturerId(java.lang.String manufacturerId)

getQualityCode

public java.lang.String getQualityCode()

setQualityCode

public void setQualityCode(java.lang.String qualityCode)

getRatingCode

public java.lang.String getRatingCode()

setRatingCode

public void setRatingCode(java.lang.String ratingCode)

getManufacturerName

public java.lang.String getManufacturerName()

setManufacturerName

public void setManufacturerName(java.lang.String manufacturerName)

getManufacturerPartNumber

public java.lang.String getManufacturerPartNumber()

setManufacturerPartNumber

public void setManufacturerPartNumber(java.lang.String manufacturerPartNumber)

getRemarks

public java.lang.String getRemarks()

setRemarks

public void setRemarks(java.lang.String remarks)

getVersion

public java.lang.Integer getVersion()

getManufacturerPartRev

public java.lang.String getManufacturerPartRev()

setVersion

public void setVersion(java.lang.Integer version)

setManufacturerPartRev

public void setManufacturerPartRev(java.lang.String manufacturerPartRev)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

isPreferredPo

public boolean isPreferredPo()

setPreferredPo

public void setPreferredPo(boolean preferredPo)

isPreferredSo

public boolean isPreferredSo()

setPreferredSo

public void setPreferredSo(boolean preferredSo)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartMaterialBomListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartMaterialBomListResult

java.lang.Object
    extended by  bb.common.PartBasicInfo
        extended by  bb.common.PartMaterialListResult
            extended by  bb.common.PartMaterialBomListResult
All Implemented Interfaces:
java.io.Serializable
public class PartMaterialBomListResult
extends PartMaterialListResult
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
Fields inherited from class bb.common.PartBasicInfo
ORDER_BY_BILL, ORDER_BY_BUYERCODE, ORDER_BY_COMMODITYCODE, ORDER_BY_DESCRIPTION, ORDER_BY_DRAWING, ORDER_BY_HOLD, ORDER_BY_LASTCHANGEDATE, ORDER_BY_LASTUSER, ORDER_BY_MAKEBUY, ORDER_BY_MODELNUMBER, ORDER_BY_ORGANIZATION, ORDER_BY_ORIGIN, ORDER_BY_PARTNUMBER, ORDER_BY_PARTTYPE, ORDER_BY_PARTUNIT, ORDER_BY_PRODUCTCODE, ORDER_BY_SECURITYLEVEL, ORDER_BY_WEIGHT
Constructor Summary
PartMaterialBomListResult()
Method Summary
java.util.Set | getItems()
void | setItems(java.util.Set items)
Methods inherited from class bb.common.PartMaterialListResult
getInnerDiameter, getInnerDiameterUnit, getLength, getLengthUnit, getMaterial, getOuterDiameter, getOuterDiameterUnit, getQtrUsage, getType, getYrUsage, setInnerDiameter, setInnerDiameterUnit, setLength, setLengthUnit, setMaterial, setOuterDiameter, setOuterDiameterUnit, setQtrUsage, setType, setYrUsage
Methods inherited from class bb.common.PartBasicInfo
equals, getBill, getBuyerCode, getCommodityCode, getCountryOrigin, getDescription, getDetectionStandard, getDrawing, getEngGroup, getHavePicture, getHold, getLastChangeDate, getLastUser, getLeadTime, getMakeBuy, getModelNumber, getOrigin, getPartPk, getPartUnit, getProductCode, getRevision, getSaleable, getSalesDrawing, getSecurityLevel, getTraceable, getVolume, getVolumeUnit, getWeight, getWeightUnit, getWi, hashCode, setBill, setBuyerCode, setCommodityCode, setCountryOrigin, setDescription, setDetectionStandard, setDrawing, setEngGroup, setHavePicture, setHold, setLastChangeDate, setLastUser, setLeadTime, setMakeBuy, setModelNumber, setOrigin, setPartPk, setPartUnit, setProductCode, setRevision, setSaleable, setSalesDrawing, setSecurityLevel, setTraceable, setVolume, setVolumeUnit, setWeight, setWeightUnit, setWi, toString
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartMaterialBomListResult

public PartMaterialBomListResult()
Method Detail

setItems

public void setItems(java.util.Set items)

getItems

public java.util.Set getItems()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartMaterialListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartMaterialListResult

java.lang.Object
    extended by  bb.common.PartBasicInfo
        extended by  bb.common.PartMaterialListResult
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
PartMaterialBomListResult
public class PartMaterialListResult
extends PartBasicInfo
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
Fields inherited from class bb.common.PartBasicInfo
ORDER_BY_BILL, ORDER_BY_BUYERCODE, ORDER_BY_COMMODITYCODE, ORDER_BY_DESCRIPTION, ORDER_BY_DRAWING, ORDER_BY_HOLD, ORDER_BY_LASTCHANGEDATE, ORDER_BY_LASTUSER, ORDER_BY_MAKEBUY, ORDER_BY_MODELNUMBER, ORDER_BY_ORGANIZATION, ORDER_BY_ORIGIN, ORDER_BY_PARTNUMBER, ORDER_BY_PARTTYPE, ORDER_BY_PARTUNIT, ORDER_BY_PRODUCTCODE, ORDER_BY_SECURITYLEVEL, ORDER_BY_WEIGHT
Constructor Summary
PartMaterialListResult()
Method Summary
java.math.BigDecimal | getInnerDiameter()
java.lang.String | getInnerDiameterUnit()
java.math.BigDecimal | getLength()
java.lang.String | getLengthUnit()
java.lang.String | getMaterial()
java.math.BigDecimal | getOuterDiameter()
java.lang.String | getOuterDiameterUnit()
java.math.BigDecimal | getQtrUsage()
java.lang.String | getType()
java.math.BigDecimal | getYrUsage()
void | setInnerDiameter(java.math.BigDecimal innerDiameter)
void | setInnerDiameterUnit(java.lang.String innerDiameterUnit)
void | setLength(java.math.BigDecimal length)
void | setLengthUnit(java.lang.String lengthUnit)
void | setMaterial(java.lang.String material)
void | setOuterDiameter(java.math.BigDecimal outerDiameter)
void | setOuterDiameterUnit(java.lang.String outerDiameterUnit)
void | setQtrUsage(java.math.BigDecimal qtrUsage)
void | setType(java.lang.String type)
void | setYrUsage(java.math.BigDecimal yrUsage)
Methods inherited from class bb.common.PartBasicInfo
equals, getBill, getBuyerCode, getCommodityCode, getCountryOrigin, getDescription, getDetectionStandard, getDrawing, getEngGroup, getHavePicture, getHold, getLastChangeDate, getLastUser, getLeadTime, getMakeBuy, getModelNumber, getOrigin, getPartPk, getPartUnit, getProductCode, getRevision, getSaleable, getSalesDrawing, getSecurityLevel, getTraceable, getVolume, getVolumeUnit, getWeight, getWeightUnit, getWi, hashCode, setBill, setBuyerCode, setCommodityCode, setCountryOrigin, setDescription, setDetectionStandard, setDrawing, setEngGroup, setHavePicture, setHold, setLastChangeDate, setLastUser, setLeadTime, setMakeBuy, setModelNumber, setOrigin, setPartPk, setPartUnit, setProductCode, setRevision, setSaleable, setSalesDrawing, setSecurityLevel, setTraceable, setVolume, setVolumeUnit, setWeight, setWeightUnit, setWi, toString
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartMaterialListResult

public PartMaterialListResult()
Method Detail

getLengthUnit

public java.lang.String getLengthUnit()

getOuterDiameterUnit

public java.lang.String getOuterDiameterUnit()

getInnerDiameterUnit

public java.lang.String getInnerDiameterUnit()

getOuterDiameter

public java.math.BigDecimal getOuterDiameter()

getType

public java.lang.String getType()

setMaterial

public void setMaterial(java.lang.String material)
Overrides:
setMaterial in class PartBasicInfo

setLengthUnit

public void setLengthUnit(java.lang.String lengthUnit)

setOuterDiameterUnit

public void setOuterDiameterUnit(java.lang.String outerDiameterUnit)

setInnerDiameterUnit

public void setInnerDiameterUnit(java.lang.String innerDiameterUnit)

setOuterDiameter

public void setOuterDiameter(java.math.BigDecimal outerDiameter)

setType

public void setType(java.lang.String type)

setInnerDiameter

public void setInnerDiameter(java.math.BigDecimal innerDiameter)

setLength

public void setLength(java.math.BigDecimal length)

setYrUsage

public void setYrUsage(java.math.BigDecimal yrUsage)

setQtrUsage

public void setQtrUsage(java.math.BigDecimal qtrUsage)

getMaterial

public java.lang.String getMaterial()
Overrides:
getMaterial in class PartBasicInfo

getInnerDiameter

public java.math.BigDecimal getInnerDiameter()

getLength

public java.math.BigDecimal getLength()

getYrUsage

public java.math.BigDecimal getYrUsage()

getQtrUsage

public java.math.BigDecimal getQtrUsage()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartMaterialReportAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartMaterialReportAgent

java.lang.Object
    extended by  bb.common.PartMaterialReportAgent
All Implemented Interfaces:
java.io.Serializable
public class PartMaterialReportAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartMaterialReportAgent()
Method Summary
java.math.BigDecimal | getInnerDiameter()
java.lang.String | getInnerOperator()
java.lang.String | getInnerUnit()
java.math.BigDecimal | getLength()
java.lang.String | getLengthOperator()
java.lang.String | getLengthUnit()
java.lang.String | getMaterial()
java.math.BigDecimal | getOuterDiameter()
java.lang.String | getOuterUnit()
java.lang.String | getOutterOperator()
PartPK | getPartPk()
java.lang.String | getType()
java.math.BigDecimal | getWallDiameter()
java.lang.String | getWallOperator()
void | setInnerDiameter(java.math.BigDecimal innerDiameter)
void | setInnerOperator(java.lang.String innerOperator)
void | setInnerUnit(java.lang.String innerUnit)
void | setLength(java.math.BigDecimal length)
void | setLengthOperator(java.lang.String lengthOperator)
void | setLengthUnit(java.lang.String lengthUnit)
void | setMaterial(java.lang.String material)
void | setOuterDiameter(java.math.BigDecimal outerDiameter)
void | setOuterUnit(java.lang.String outerUnit)
void | setOutterOperator(java.lang.String outterOperator)
void | setPartPk(PartPK partPk)
void | setType(java.lang.String type)
void | setWallDiameter(java.math.BigDecimal wallDiameter)
void | setWallOperator(java.lang.String wallOperator)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PartMaterialReportAgent

public PartMaterialReportAgent()
Method Detail

getWallDiameter

public java.math.BigDecimal getWallDiameter()

getWallOperator

public java.lang.String getWallOperator()

getOutterOperator

public java.lang.String getOutterOperator()

getInnerDiameter

public java.math.BigDecimal getInnerDiameter()

getInnerOperator

public java.lang.String getInnerOperator()

getType

public java.lang.String getType()

setMaterial

public void setMaterial(java.lang.String material)

setWallDiameter

public void setWallDiameter(java.math.BigDecimal wallDiameter)

setWallOperator

public void setWallOperator(java.lang.String wallOperator)

setOutterOperator

public void setOutterOperator(java.lang.String outterOperator)

setInnerDiameter

public void setInnerDiameter(java.math.BigDecimal innerDiameter)

setInnerOperator

public void setInnerOperator(java.lang.String innerOperator)

setType

public void setType(java.lang.String type)

setLengthOperator

public void setLengthOperator(java.lang.String lengthOperator)

setLengthUnit

public void setLengthUnit(java.lang.String lengthUnit)

setLength

public void setLength(java.math.BigDecimal length)

setOuterUnit

public void setOuterUnit(java.lang.String outerUnit)

setInnerUnit

public void setInnerUnit(java.lang.String innerUnit)

getMaterial

public java.lang.String getMaterial()

getLengthOperator

public java.lang.String getLengthOperator()

getLengthUnit

public java.lang.String getLengthUnit()

getLength

public java.math.BigDecimal getLength()

getOuterUnit

public java.lang.String getOuterUnit()

getInnerUnit

public java.lang.String getInnerUnit()

getOuterDiameter

public java.math.BigDecimal getOuterDiameter()

setOuterDiameter

public void setOuterDiameter(java.math.BigDecimal outerDiameter)

getPartPk

public PartPK getPartPk()

setPartPk

public void setPartPk(PartPK partPk)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartMaterialVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartMaterialVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartMaterialVO
All Implemented Interfaces:
java.io.Serializable
public class PartMaterialVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PartMaterialVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getInnerDiameter()
java.lang.String | getInnerDiameterUnit()
java.math.BigDecimal | getLength()
java.lang.String | getLengthUnit()
java.lang.String | getMaterial()
java.math.BigDecimal | getOuterDiameter()
java.lang.String | getOuterDiameterUnit()
PartPK | getPk()
java.lang.String | getType()
int | hashCode()
void | setInnerDiameter(java.math.BigDecimal innerDiameter)
void | setInnerDiameterUnit(java.lang.String innerDiameterUnit)
void | setLength(java.math.BigDecimal length)
void | setLengthUnit(java.lang.String lengthUnit)
void | setMaterial(java.lang.String material)
void | setOuterDiameter(java.math.BigDecimal outerDiameter)
void | setOuterDiameterUnit(java.lang.String outerDiameterUnit)
void | setPk(PartPK pk)
void | setType(java.lang.String type)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartMaterialVO

public PartMaterialVO()
default constructor

Method Detail

getPk

public PartPK getPk()

setPk

public void setPk(PartPK pk)

getMaterial

public java.lang.String getMaterial()

setMaterial

public void setMaterial(java.lang.String material)

getType

public java.lang.String getType()

setType

public void setType(java.lang.String type)

getInnerDiameterUnit

public java.lang.String getInnerDiameterUnit()

setInnerDiameterUnit

public void setInnerDiameterUnit(java.lang.String innerDiameterUnit)

getInnerDiameter

public java.math.BigDecimal getInnerDiameter()

setInnerDiameter

public void setInnerDiameter(java.math.BigDecimal innerDiameter)

getOuterDiameterUnit

public java.lang.String getOuterDiameterUnit()

setOuterDiameterUnit

public void setOuterDiameterUnit(java.lang.String outerDiameterUnit)

getOuterDiameter

public java.math.BigDecimal getOuterDiameter()

setOuterDiameter

public void setOuterDiameter(java.math.BigDecimal outerDiameter)

getLengthUnit

public java.lang.String getLengthUnit()

setLengthUnit

public void setLengthUnit(java.lang.String lengthUnit)

getLength

public java.math.BigDecimal getLength()

setLength

public void setLength(java.math.BigDecimal length)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartMaterialWhereUsedItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartMaterialWhereUsedItemResult

java.lang.Object
    extended by  bb.common.PartMaterialWhereUsedItemResult
All Implemented Interfaces:
java.io.Serializable
public class PartMaterialWhereUsedItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartMaterialWhereUsedItemResult()
Method Summary
java.lang.String | getBill()
BillItemPK | getBillItemPk()
java.lang.String | getDescription()
java.math.BigDecimal | getInnerDiameter()
java.lang.String | getInnerDiameterUnit()
java.math.BigDecimal | getLength()
java.lang.String | getLengthUnit()
java.math.BigDecimal | getOnhand()
java.math.BigDecimal | getOuterDiameter()
java.lang.String | getOuterDiameterUnit()
java.math.BigDecimal | getQtrUsage()
java.math.BigDecimal | getQty()
java.math.BigDecimal | getYrUsage()
void | setBill(java.lang.String bill)
void | setBillItemPk(BillItemPK billItemPk)
void | setDescription(java.lang.String description)
void | setInnerDiameter(java.math.BigDecimal innerDiameter)
void | setInnerDiameterUnit(java.lang.String innerDiameterUnit)
void | setLength(java.math.BigDecimal length)
void | setLengthUnit(java.lang.String lengthUnit)
void | setOnhand(java.math.BigDecimal onhand)
void | setOuterDiameter(java.math.BigDecimal outerDiameter)
void | setOuterDiameterUnit(java.lang.String outerDiameterUnit)
void | setQtrUsage(java.math.BigDecimal qtrUsage)
void | setQty(java.math.BigDecimal qty)
void | setYrUsage(java.math.BigDecimal yrUsage)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PartMaterialWhereUsedItemResult

public PartMaterialWhereUsedItemResult()
Method Detail

setBillItemPk

public void setBillItemPk(BillItemPK billItemPk)

setQty

public void setQty(java.math.BigDecimal qty)

setDescription

public void setDescription(java.lang.String description)

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

setQtrUsage

public void setQtrUsage(java.math.BigDecimal qtrUsage)

setYrUsage

public void setYrUsage(java.math.BigDecimal yrUsage)

setBill

public void setBill(java.lang.String bill)

setOuterDiameterUnit

public void setOuterDiameterUnit(java.lang.String outerDiameterUnit)

setInnerDiameterUnit

public void setInnerDiameterUnit(java.lang.String innerDiameterUnit)

setLengthUnit

public void setLengthUnit(java.lang.String lengthUnit)

setOuterDiameter

public void setOuterDiameter(java.math.BigDecimal outerDiameter)

setInnerDiameter

public void setInnerDiameter(java.math.BigDecimal innerDiameter)

setLength

public void setLength(java.math.BigDecimal length)

getBillItemPk

public BillItemPK getBillItemPk()

getQty

public java.math.BigDecimal getQty()

getDescription

public java.lang.String getDescription()

getOnhand

public java.math.BigDecimal getOnhand()

getQtrUsage

public java.math.BigDecimal getQtrUsage()

getYrUsage

public java.math.BigDecimal getYrUsage()

getBill

public java.lang.String getBill()

getOuterDiameterUnit

public java.lang.String getOuterDiameterUnit()

getInnerDiameterUnit

public java.lang.String getInnerDiameterUnit()

getLengthUnit

public java.lang.String getLengthUnit()

getOuterDiameter

public java.math.BigDecimal getOuterDiameter()

getInnerDiameter

public java.math.BigDecimal getInnerDiameter()

getLength

public java.math.BigDecimal getLength()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartMaterialWhereUsedResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartMaterialWhereUsedResult

java.lang.Object
    extended by  bb.common.PartMaterialWhereUsedResult
All Implemented Interfaces:
java.io.Serializable
public class PartMaterialWhereUsedResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartMaterialWhereUsedResult()
Method Summary
java.lang.String | getDescription()
java.util.Set | getItems()
PartPK | getPartPk()
void | setDescription(java.lang.String description)
void | setItems(java.util.Set items)
void | setPartPk(PartPK partPk)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PartMaterialWhereUsedResult

public PartMaterialWhereUsedResult()
Method Detail

setPartPk

public void setPartPk(PartPK partPk)

setDescription

public void setDescription(java.lang.String description)

setItems

public void setItems(java.util.Set items)

getPartPk

public PartPK getPartPk()

getDescription

public java.lang.String getDescription()

getItems

public java.util.Set getItems()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartMRPVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartMRPVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartMRPVO
All Implemented Interfaces:
java.io.Serializable
public class PartMRPVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PartMRPVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDoNotIssueToWo()
java.lang.String | getDoNotKeepInInventory()
java.lang.String | getDoNotUseInMrp()
java.lang.String | getFloorStock()
java.lang.String | getMakeBuy()
PartPK | getPk()
int | hashCode()
void | setDoNotIssueToWo(java.lang.String doNotIssueToWo)
void | setDoNotKeepInInventory(java.lang.String doNotKeepInInventory)
void | setDoNotUseInMrp(java.lang.String doNotUseInMrp)
void | setFloorStock(java.lang.String floorStock)
void | setMakeBuy(java.lang.String makeBuy)
void | setPk(PartPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartMRPVO

public PartMRPVO()
Method Detail

getPk

public PartPK getPk()

setPk

public void setPk(PartPK pk)

getMakeBuy

public java.lang.String getMakeBuy()

setMakeBuy

public void setMakeBuy(java.lang.String makeBuy)

getFloorStock

public java.lang.String getFloorStock()

setFloorStock

public void setFloorStock(java.lang.String floorStock)

getDoNotUseInMrp

public java.lang.String getDoNotUseInMrp()

setDoNotUseInMrp

public void setDoNotUseInMrp(java.lang.String doNotUseInMrp)

getDoNotIssueToWo

public java.lang.String getDoNotIssueToWo()

setDoNotIssueToWo

public void setDoNotIssueToWo(java.lang.String doNotIssueToWo)

getDoNotKeepInInventory

public java.lang.String getDoNotKeepInInventory()

setDoNotKeepInInventory

public void setDoNotKeepInInventory(java.lang.String doNotKeepInInventory)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartNumberGenerateRuleVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartNumberGenerateRuleVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartNumberGenerateRuleVO
All Implemented Interfaces:
java.io.Serializable
public class PartNumberGenerateRuleVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartNumberGenerateRuleVO()
PartNumberGenerateRuleVO(java.lang.String startNumberForSeq)
Method Summary
java.lang.Long | getIi()
java.lang.String | getStartNumberForSeq()
void | setIi(java.lang.Long ii)
void | setStartNumberForSeq(java.lang.String startNumberForSeq)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PartNumberGenerateRuleVO

public PartNumberGenerateRuleVO()

PartNumberGenerateRuleVO

public PartNumberGenerateRuleVO(java.lang.String startNumberForSeq)
Method Detail

getStartNumberForSeq

public java.lang.String getStartNumberForSeq()

setStartNumberForSeq

public void setStartNumberForSeq(java.lang.String startNumberForSeq)

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartOnhandAndCostResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartOnhandAndCostResult

java.lang.Object
    extended by  bb.common.PartOnhandAndCostResult
All Implemented Interfaces:
java.io.Serializable
public class PartOnhandAndCostResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartOnhandAndCostResult()
Method Summary
java.math.BigDecimal | getAvgCost()
java.math.BigDecimal | getQty()
java.math.BigDecimal | getStdCost()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setQty(java.math.BigDecimal qty)
void | setStdCost(java.math.BigDecimal stdCost)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PartOnhandAndCostResult

public PartOnhandAndCostResult()
Method Detail

getAvgCost

public java.math.BigDecimal getAvgCost()

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartOnHandAuditAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartOnHandAuditAgent

java.lang.Object
    extended by  bb.common.PartOnHandAuditAgent
All Implemented Interfaces:
java.io.Serializable
public class PartOnHandAuditAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartOnHandAuditAgent()
Method Summary
java.lang.String | getPartNumber()
java.util.Date | getStartDate()
void | setPartNumber(java.lang.String partNumber)
void | setStartDate(java.util.Date startDate)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PartOnHandAuditAgent

public PartOnHandAuditAgent()
Method Detail

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getStartDate

public java.util.Date getStartDate()

setStartDate

public void setStartDate(java.util.Date startDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartOnHandAuditResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartOnHandAuditResult

java.lang.Object
    extended by  bb.common.PartOnHandAuditResult
All Implemented Interfaces:
Alarmable, java.io.Serializable
public class PartOnHandAuditResult
extends java.lang.Object
implements java.io.Serializable, Alarmable

See Also:
Serialized Form

Constructor Summary
PartOnHandAuditResult()
Method Summary
boolean | getAlarmValue()
java.math.BigDecimal | getAuditSip()
java.util.Date | getBreakPoint()
java.lang.String | getCause()
java.lang.String | getDescription()
java.math.BigDecimal | getOnhand()
java.math.BigDecimal | getOnhandTotal()
PartPK | getPk()
java.math.BigDecimal | getSip()
java.math.BigDecimal | getSoSip()
void | setAlarmValue(boolean alarmValue)
void | setAuditSip(java.math.BigDecimal auditSip)
void | setBreakPoint(java.util.Date breakPoint)
void | setCause(java.lang.String cause)
void | setDescription(java.lang.String description)
void | setOnhand(java.math.BigDecimal onhand)
void | setOnhandTotal(java.math.BigDecimal onhandTotal)
void | setPk(PartPK pk)
void | setSip(java.math.BigDecimal sip)
void | setSoSip(java.math.BigDecimal soSip)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PartOnHandAuditResult

public PartOnHandAuditResult()
Method Detail

getPk

public PartPK getPk()

setPk

public void setPk(PartPK pk)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getOnhand

public java.math.BigDecimal getOnhand()

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

getOnhandTotal

public java.math.BigDecimal getOnhandTotal()

setOnhandTotal

public void setOnhandTotal(java.math.BigDecimal onhandTotal)

getBreakPoint

public java.util.Date getBreakPoint()

setBreakPoint

public void setBreakPoint(java.util.Date breakPoint)

getSip

public java.math.BigDecimal getSip()

setSip

public void setSip(java.math.BigDecimal sip)

getAuditSip

public java.math.BigDecimal getAuditSip()

setAuditSip

public void setAuditSip(java.math.BigDecimal auditSip)

getSoSip

public java.math.BigDecimal getSoSip()

setSoSip

public void setSoSip(java.math.BigDecimal soSip)

getAlarmValue

public boolean getAlarmValue()
Specified by:
getAlarmValue in interface Alarmable

getCause

public java.lang.String getCause()
Specified by:
getCause in interface Alarmable

setAlarmValue

public void setAlarmValue(boolean alarmValue)
Specified by:
setAlarmValue in interface Alarmable

setCause

public void setCause(java.lang.String cause)
Specified by:
setCause in interface Alarmable
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartOnhandCostVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartOnhandCostVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartOnhandCostVO
All Implemented Interfaces:
java.io.Serializable
public class PartOnhandCostVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PartOnhandCostVO()
default constructor
Method Summary
java.math.BigDecimal | getCostPerUnit()
java.math.BigDecimal | getExchangeRate()
java.util.Date | getFifoDate()
java.math.BigDecimal | getFifoOnhand()
java.math.BigDecimal | getForeignCost()
java.lang.String | getForeignCurrency()
java.lang.Long | getIi()
java.util.Date | getLastOutDate()
java.lang.String | getLocalCurrency()
java.lang.String | getLocation()
java.lang.String | getLot()
java.math.BigDecimal | getOnhand()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.util.Date | getReceivedDate()
java.math.BigDecimal | getReceivedQty()
java.lang.String | getRefDoc()
java.lang.String | getRefDocReceiver()
java.lang.String | getSerialNumber()
java.lang.String | getUnit()
java.lang.String | getVendorId()
void | setCostPerUnit(java.math.BigDecimal costPerUnit)
void | setExchangeRate(java.math.BigDecimal exchangeRate)
void | setFifoDate(java.util.Date fifoDate)
void | setFifoOnhand(java.math.BigDecimal fifoOnhand)
void | setForeignCost(java.math.BigDecimal foreignCost)
void | setForeignCurrency(java.lang.String foreignCurrency)
void | setIi(java.lang.Long ii)
void | setLastOutDate(java.util.Date lastOutDate)
void | setLocalCurrency(java.lang.String localCurrency)
void | setLocation(java.lang.String location)
void | setLot(java.lang.String lot)
void | setOnhand(java.math.BigDecimal onhand)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setReceivedDate(java.util.Date receivedDate)
void | setReceivedQty(java.math.BigDecimal receivedQty)
void | setRefDoc(java.lang.String refDoc)
void | setRefDocReceiver(java.lang.String refDocReceiver)
void | setSerialNumber(java.lang.String serialNumber)
void | setUnit(java.lang.String unit)
void | setVendorId(java.lang.String vendorId)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PartOnhandCostVO

public PartOnhandCostVO()
default constructor

Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getLastOutDate

public java.util.Date getLastOutDate()

setLastOutDate

public void setLastOutDate(java.util.Date lastOutDate)

getReceivedDate

public java.util.Date getReceivedDate()

setReceivedDate

public void setReceivedDate(java.util.Date receivedDate)

getReceivedQty

public java.math.BigDecimal getReceivedQty()

setReceivedQty

public void setReceivedQty(java.math.BigDecimal receivedQty)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getOnhand

public java.math.BigDecimal getOnhand()

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

getCostPerUnit

public java.math.BigDecimal getCostPerUnit()

setCostPerUnit

public void setCostPerUnit(java.math.BigDecimal costPerUnit)

getLocalCurrency

public java.lang.String getLocalCurrency()

setLocalCurrency

public void setLocalCurrency(java.lang.String localCurrency)

getExchangeRate

public java.math.BigDecimal getExchangeRate()

setExchangeRate

public void setExchangeRate(java.math.BigDecimal exchangeRate)

getForeignCost

public java.math.BigDecimal getForeignCost()

setForeignCost

public void setForeignCost(java.math.BigDecimal foreignCost)

getForeignCurrency

public java.lang.String getForeignCurrency()

setForeignCurrency

public void setForeignCurrency(java.lang.String foreignCurrency)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getSerialNumber

public java.lang.String getSerialNumber()

setSerialNumber

public void setSerialNumber(java.lang.String serialNumber)

getLot

public java.lang.String getLot()

setLot

public void setLot(java.lang.String lot)

getRefDoc

public java.lang.String getRefDoc()

setRefDoc

public void setRefDoc(java.lang.String refDoc)

getRefDocReceiver

public java.lang.String getRefDocReceiver()

setRefDocReceiver

public void setRefDocReceiver(java.lang.String refDocReceiver)

getFifoOnhand

public java.math.BigDecimal getFifoOnhand()

setFifoOnhand

public void setFifoOnhand(java.math.BigDecimal fifoOnhand)

getFifoDate

public java.util.Date getFifoDate()

setFifoDate

public void setFifoDate(java.util.Date fifoDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartOnhandPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartOnhandPK

java.lang.Object
    extended by  bb.common.PartOnhandPK
All Implemented Interfaces:
java.io.Serializable
public class PartOnhandPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartOnhandPK()
PartOnhandPK(java.lang.String partNumber, java.lang.String partType, java.lang.String location)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getLocation()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
int | hashCode()
void | setLocation(java.lang.String location)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartOnhandPK

public PartOnhandPK()

PartOnhandPK

public PartOnhandPK(java.lang.String partNumber,
                    java.lang.String partType,
                    java.lang.String location)
Method Detail

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartNumber

public java.lang.String getPartNumber()

setPartType

public void setPartType(java.lang.String partType)

getPartType

public java.lang.String getPartType()

setLocation

public void setLocation(java.lang.String location)

getLocation

public java.lang.String getLocation()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartOnhandResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartOnhandResult

java.lang.Object
    extended by  bb.common.PartOnhandResult
All Implemented Interfaces:
java.io.Serializable
public class PartOnhandResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_INSIP
static java.lang.String | ORDER_BY_INWIP
static java.lang.String | ORDER_BY_LASTOUTDATE
static java.lang.String | ORDER_BY_LOCATE
static java.lang.String | ORDER_BY_ONLOAN
static java.lang.String | ORDER_BY_PART
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_PARTUNIT
static java.lang.String | ORDER_BY_SHIPPINGWEIGHT
Constructor Summary
PartOnhandResult()
Method Summary
java.math.BigDecimal | getAvgCost()
java.lang.String | getDescription()
java.math.BigDecimal | getInSIP()
java.math.BigDecimal | getInWIP()
java.util.Date | getLastOutDate()
java.util.Map<java.lang.String,PartOnhandAndCostResult> | getLocates()
java.math.BigDecimal | getOnhand(java.lang.String locate)
java.math.BigDecimal | getOnLoan()
java.util.Iterator | getOtherLocations()
BB2Part | getPart()
java.lang.String | getPartUnit()
java.lang.Float | getShippingWeight()
java.lang.String | getShippingWeightUnit()
java.math.BigDecimal | getStdCost()
java.math.BigDecimal | getTotalAvgCost()
java.math.BigDecimal | getTotalLocateQty()
java.math.BigDecimal | getTotalOnhand()
java.math.BigDecimal | getTotalStdCost()
boolean | isWarning()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setDescription(java.lang.String description)
void | setInSIP(java.math.BigDecimal inSIP)
void | setInWIP(java.math.BigDecimal inWIP)
void | setLastOutDate(java.util.Date lastOutDate)
void | setListOtherLocationsForSamePart(boolean listOtherLocationsForSamePart)
void | setLocates(java.util.Map<java.lang.String,PartOnhandAndCostResult> locates)
void | setOnLoan(java.math.BigDecimal onLoan)
void | setPart(BB2Part part)
void | setPartUnit(java.lang.String partUnit)
void | setShippingWeight(java.lang.Float shippingWeight)
void | setShippingWeightUnit(java.lang.String shippingWeightUnit)
void | setStdCost(java.math.BigDecimal stdCost)
void | setTotalAvgCost(java.math.BigDecimal totalAvgCost)
void | setTotalOnhand(java.math.BigDecimal totalOnhand)
void | setTotalStdCost(java.math.BigDecimal totalStdCost)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_PART

public static final java.lang.String ORDER_BY_PART
See Also:
Constant Field Values

ORDER_BY_LOCATE

public static final java.lang.String ORDER_BY_LOCATE
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_PARTUNIT

public static final java.lang.String ORDER_BY_PARTUNIT
See Also:
Constant Field Values

ORDER_BY_INSIP

public static final java.lang.String ORDER_BY_INSIP
See Also:
Constant Field Values

ORDER_BY_INWIP

public static final java.lang.String ORDER_BY_INWIP
See Also:
Constant Field Values

ORDER_BY_LASTOUTDATE

public static final java.lang.String ORDER_BY_LASTOUTDATE
See Also:
Constant Field Values

ORDER_BY_SHIPPINGWEIGHT

public static final java.lang.String ORDER_BY_SHIPPINGWEIGHT
See Also:
Constant Field Values

ORDER_BY_ONLOAN

public static final java.lang.String ORDER_BY_ONLOAN
See Also:
Constant Field Values
Constructor Detail

PartOnhandResult

public PartOnhandResult()
Method Detail

setListOtherLocationsForSamePart

public void setListOtherLocationsForSamePart(boolean listOtherLocationsForSamePart)

getTotalOnhand

public java.math.BigDecimal getTotalOnhand()

setTotalOnhand

public void setTotalOnhand(java.math.BigDecimal totalOnhand)

setPart

public void setPart(BB2Part part)

setDescription

public void setDescription(java.lang.String description)

setInSIP

public void setInSIP(java.math.BigDecimal inSIP)

getPart

public BB2Part getPart()

getDescription

public java.lang.String getDescription()

getInSIP

public java.math.BigDecimal getInSIP()

getOtherLocations

public java.util.Iterator getOtherLocations()

getTotalAvgCost

public java.math.BigDecimal getTotalAvgCost()

getOnhand

public java.math.BigDecimal getOnhand(java.lang.String locate)

setTotalAvgCost

public void setTotalAvgCost(java.math.BigDecimal totalAvgCost)

getTotalLocateQty

public java.math.BigDecimal getTotalLocateQty()

getTotalStdCost

public java.math.BigDecimal getTotalStdCost()

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

getAvgCost

public java.math.BigDecimal getAvgCost()

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

setTotalStdCost

public void setTotalStdCost(java.math.BigDecimal totalStdCost)

isWarning

public boolean isWarning()

getLocates

public java.util.Map<java.lang.String,PartOnhandAndCostResult> getLocates()

setLocates

public void setLocates(java.util.Map<java.lang.String,PartOnhandAndCostResult> locates)

getPartUnit

public java.lang.String getPartUnit()

setPartUnit

public void setPartUnit(java.lang.String partUnit)

getInWIP

public java.math.BigDecimal getInWIP()

setInWIP

public void setInWIP(java.math.BigDecimal inWIP)

getLastOutDate

public java.util.Date getLastOutDate()

setLastOutDate

public void setLastOutDate(java.util.Date lastOutDate)

getShippingWeight

public java.lang.Float getShippingWeight()

setShippingWeight

public void setShippingWeight(java.lang.Float shippingWeight)

getShippingWeightUnit

public java.lang.String getShippingWeightUnit()

setShippingWeightUnit

public void setShippingWeightUnit(java.lang.String shippingWeightUnit)

getOnLoan

public java.math.BigDecimal getOnLoan()

setOnLoan

public void setOnLoan(java.math.BigDecimal onLoan)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartOnhandVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartOnhandVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartOnhandVO
All Implemented Interfaces:
java.io.Serializable
public class PartOnhandVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_LOCATION
static java.lang.String | ORDER_BY_MODELNUMBER
static java.lang.String | ORDER_BY_ONHANDQUANTITY
static java.lang.String | ORDER_BY_PARTNUMBER
Constructor Summary
PartOnhandVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getActive()
java.math.BigDecimal | getAverageCost()
java.lang.String | getBb2description()
java.lang.String | getModelNumber()
java.math.BigDecimal | getOnHandQuantity()
PartOnhandPK | getPk()
java.lang.String | getWarehouse()
int | hashCode()
boolean | isFlushLocation()
void | setActive(java.lang.String active)
void | setAverageCost(java.math.BigDecimal averageCost)
void | setBb2description(java.lang.String bb2description)
void | setModelNumber(java.lang.String modelNumber)
void | setOnHandQuantity(java.math.BigDecimal onHandQuantity)
void | setPk(PartOnhandPK pk)
void | setWarehouse(java.lang.String warehouse)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ONHANDQUANTITY

public static final java.lang.String ORDER_BY_ONHANDQUANTITY
See Also:
Constant Field Values

ORDER_BY_MODELNUMBER

public static final java.lang.String ORDER_BY_MODELNUMBER
See Also:
Constant Field Values

ORDER_BY_LOCATION

public static final java.lang.String ORDER_BY_LOCATION
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values
Constructor Detail

PartOnhandVO

public PartOnhandVO()
Method Detail

getPk

public PartOnhandPK getPk()

setPk

public void setPk(PartOnhandPK pk)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getActive

public java.lang.String getActive()

setActive

public void setActive(java.lang.String active)

getOnHandQuantity

public java.math.BigDecimal getOnHandQuantity()

setOnHandQuantity

public void setOnHandQuantity(java.math.BigDecimal onHandQuantity)

getAverageCost

public java.math.BigDecimal getAverageCost()

setAverageCost

public void setAverageCost(java.math.BigDecimal averageCost)

getBb2description

public java.lang.String getBb2description()

setBb2description

public void setBb2description(java.lang.String bb2description)

getWarehouse

public java.lang.String getWarehouse()

setWarehouse

public void setWarehouse(java.lang.String warehouse)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

isFlushLocation

public boolean isFlushLocation()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartOnhandWithAverageCostResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartOnhandWithAverageCostResult

java.lang.Object
    extended by  bb.common.PartOnhandWithAverageCostResult
All Implemented Interfaces:
java.io.Serializable
public class PartOnhandWithAverageCostResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartOnhandWithAverageCostResult()
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getAverageCost()
PartOnhandVO | getPartOnhandVo()
int | hashCode()
void | setAverageCost(java.math.BigDecimal averageCost)
void | setPartOnhandVo(PartOnhandVO partOnhandVo)
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PartOnhandWithAverageCostResult

public PartOnhandWithAverageCostResult()
Method Detail

setAverageCost

public void setAverageCost(java.math.BigDecimal averageCost)

setPartOnhandVo

public void setPartOnhandVo(PartOnhandVO partOnhandVo)

getAverageCost

public java.math.BigDecimal getAverageCost()

getPartOnhandVo

public PartOnhandVO getPartOnhandVo()

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartOnHandWithMfgInfoResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartOnHandWithMfgInfoResult

java.lang.Object
    extended by  bb.common.PartBasicInfo
        extended by  bb.common.PartOnHandWithMfgInfoResult
All Implemented Interfaces:
java.io.Serializable
public class PartOnHandWithMfgInfoResult
extends PartBasicInfo
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AVERAGECOST
static java.lang.String | ORDER_BY_BILL
static java.lang.String | ORDER_BY_BUYERCODE
static java.lang.String | ORDER_BY_COMMODITYCODE
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_DRAWING
static java.lang.String | ORDER_BY_HOLD
static java.lang.String | ORDER_BY_INSIP
static java.lang.String | ORDER_BY_INSIT
static java.lang.String | ORDER_BY_INWIP
static java.lang.String | ORDER_BY_MANUFACTURERID
static java.lang.String | ORDER_BY_MANUFACTURERNAME
static java.lang.String | ORDER_BY_MANUFACTURERPARTNUMBER
static java.lang.String | ORDER_BY_MODELNUMBER
static java.lang.String | ORDER_BY_ONDEMAND
static java.lang.String | ORDER_BY_ONHAND
static java.lang.String | ORDER_BY_ONORDER
static java.lang.String | ORDER_BY_ORGANIZATION
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_PARTUNIT
static java.lang.String | ORDER_BY_REVISION
static java.lang.String | ORDER_BY_SECURITYLEVEL
static java.lang.String | ORDER_BY_STANDARDCOST
static java.lang.String | ORDER_BY_WEIGHT
Fields inherited from class bb.common.PartBasicInfo
ORDER_BY_LASTCHANGEDATE, ORDER_BY_LASTUSER, ORDER_BY_MAKEBUY, ORDER_BY_ORIGIN, ORDER_BY_PARTNUMBER, ORDER_BY_PRODUCTCODE
Constructor Summary
PartOnHandWithMfgInfoResult()
Method Summary
java.math.BigDecimal | getAverageCost()
java.math.BigDecimal | getInSip()
java.math.BigDecimal | getInSit()
java.math.BigDecimal | getInWip()
java.lang.String | getManufacturerId()
java.lang.String | getManufacturerName()
java.lang.String | getManufacturerPartNumber()
java.math.BigDecimal | getOndemand()
java.math.BigDecimal | getOnhand()
java.math.BigDecimal | getOnorder()
java.math.BigDecimal | getStandardCost()
void | setAverageCost(java.math.BigDecimal averageCost)
void | setInSip(java.math.BigDecimal inSip)
void | setInSit(java.math.BigDecimal inSit)
void | setInWip(java.math.BigDecimal inWip)
void | setManufacturerId(java.lang.String manufacturerId)
void | setManufacturerName(java.lang.String manufacturerName)
void | setManufacturerPartNumber(java.lang.String manufacturerPartNumber)
void | setOndemand(java.math.BigDecimal ondemand)
void | setOnhand(java.math.BigDecimal onhand)
void | setOnorder(java.math.BigDecimal onorder)
void | setStandardCost(java.math.BigDecimal standardCost)
Methods inherited from class bb.common.PartBasicInfo
equals, getBill, getBuyerCode, getCommodityCode, getCountryOrigin, getDescription, getDetectionStandard, getDrawing, getEngGroup, getHavePicture, getHold, getLastChangeDate, getLastUser, getLeadTime, getMakeBuy, getMaterial, getModelNumber, getOrigin, getPartPk, getPartUnit, getProductCode, getRevision, getSaleable, getSalesDrawing, getSecurityLevel, getTraceable, getVolume, getVolumeUnit, getWeight, getWeightUnit, getWi, hashCode, setBill, setBuyerCode, setCommodityCode, setCountryOrigin, setDescription, setDetectionStandard, setDrawing, setEngGroup, setHavePicture, setHold, setLastChangeDate, setLastUser, setLeadTime, setMakeBuy, setMaterial, setModelNumber, setOrigin, setPartPk, setPartUnit, setProductCode, setRevision, setSaleable, setSalesDrawing, setSecurityLevel, setTraceable, setVolume, setVolumeUnit, setWeight, setWeightUnit, setWi, toString
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ONHAND

public static final java.lang.String ORDER_BY_ONHAND
See Also:
Constant Field Values

ORDER_BY_ONORDER

public static final java.lang.String ORDER_BY_ONORDER
See Also:
Constant Field Values

ORDER_BY_ONDEMAND

public static final java.lang.String ORDER_BY_ONDEMAND
See Also:
Constant Field Values

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_WEIGHT

public static final java.lang.String ORDER_BY_WEIGHT
See Also:
Constant Field Values

ORDER_BY_BUYERCODE

public static final java.lang.String ORDER_BY_BUYERCODE
See Also:
Constant Field Values

ORDER_BY_HOLD

public static final java.lang.String ORDER_BY_HOLD
See Also:
Constant Field Values

ORDER_BY_DRAWING

public static final java.lang.String ORDER_BY_DRAWING
See Also:
Constant Field Values

ORDER_BY_MODELNUMBER

public static final java.lang.String ORDER_BY_MODELNUMBER
See Also:
Constant Field Values

ORDER_BY_COMMODITYCODE

public static final java.lang.String ORDER_BY_COMMODITYCODE
See Also:
Constant Field Values

ORDER_BY_PARTUNIT

public static final java.lang.String ORDER_BY_PARTUNIT
See Also:
Constant Field Values

ORDER_BY_SECURITYLEVEL

public static final java.lang.String ORDER_BY_SECURITYLEVEL
See Also:
Constant Field Values

ORDER_BY_ORGANIZATION

public static final java.lang.String ORDER_BY_ORGANIZATION
See Also:
Constant Field Values

ORDER_BY_REVISION

public static final java.lang.String ORDER_BY_REVISION
See Also:
Constant Field Values

ORDER_BY_BILL

public static final java.lang.String ORDER_BY_BILL
See Also:
Constant Field Values

ORDER_BY_INWIP

public static final java.lang.String ORDER_BY_INWIP
See Also:
Constant Field Values

ORDER_BY_INSIP

public static final java.lang.String ORDER_BY_INSIP
See Also:
Constant Field Values

ORDER_BY_INSIT

public static final java.lang.String ORDER_BY_INSIT
See Also:
Constant Field Values

ORDER_BY_AVERAGECOST

public static final java.lang.String ORDER_BY_AVERAGECOST
See Also:
Constant Field Values

ORDER_BY_STANDARDCOST

public static final java.lang.String ORDER_BY_STANDARDCOST
See Also:
Constant Field Values

ORDER_BY_MANUFACTURERID

public static final java.lang.String ORDER_BY_MANUFACTURERID
See Also:
Constant Field Values

ORDER_BY_MANUFACTURERNAME

public static final java.lang.String ORDER_BY_MANUFACTURERNAME
See Also:
Constant Field Values

ORDER_BY_MANUFACTURERPARTNUMBER

public static final java.lang.String ORDER_BY_MANUFACTURERPARTNUMBER
See Also:
Constant Field Values
Constructor Detail

PartOnHandWithMfgInfoResult

public PartOnHandWithMfgInfoResult()
Method Detail

getInSip

public java.math.BigDecimal getInSip()

setInSip

public void setInSip(java.math.BigDecimal inSip)

getInSit

public java.math.BigDecimal getInSit()

setInSit

public void setInSit(java.math.BigDecimal inSit)

getInWip

public java.math.BigDecimal getInWip()

setInWip

public void setInWip(java.math.BigDecimal inWip)

getManufacturerId

public java.lang.String getManufacturerId()

setManufacturerId

public void setManufacturerId(java.lang.String manufacturerId)

getManufacturerName

public java.lang.String getManufacturerName()

setManufacturerName

public void setManufacturerName(java.lang.String manufacturerName)

getManufacturerPartNumber

public java.lang.String getManufacturerPartNumber()

setManufacturerPartNumber

public void setManufacturerPartNumber(java.lang.String manufacturerPartNumber)

getOndemand

public java.math.BigDecimal getOndemand()

setOndemand

public void setOndemand(java.math.BigDecimal ondemand)

getOnhand

public java.math.BigDecimal getOnhand()

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

getOnorder

public java.math.BigDecimal getOnorder()

setOnorder

public void setOnorder(java.math.BigDecimal onorder)

getAverageCost

public java.math.BigDecimal getAverageCost()

setAverageCost

public void setAverageCost(java.math.BigDecimal averageCost)

getStandardCost

public java.math.BigDecimal getStandardCost()

setStandardCost

public void setStandardCost(java.math.BigDecimal standardCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartOnHandWithPartBasicInfoResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartOnHandWithPartBasicInfoResult

java.lang.Object
    extended by  bb.common.PartBasicInfo
        extended by  bb.common.PartOnHandWithPartBasicInfoResult
All Implemented Interfaces:
java.io.Serializable
public class PartOnHandWithPartBasicInfoResult
extends PartBasicInfo
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_BUYERCODE
static java.lang.String | ORDER_BY_COMMODITYCODE
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_DRAWING
static java.lang.String | ORDER_BY_HOLD
static java.lang.String | ORDER_BY_MODELNUMBER
static java.lang.String | ORDER_BY_ONDEMANDQTY
static java.lang.String | ORDER_BY_ONHAND
static java.lang.String | ORDER_BY_ONORDERQTY
static java.lang.String | ORDER_BY_ORGANIZATION
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_PARTUNIT
static java.lang.String | ORDER_BY_SECURITYLEVEL
static java.lang.String | ORDER_BY_WEIGHT
Fields inherited from class bb.common.PartBasicInfo
ORDER_BY_BILL, ORDER_BY_LASTCHANGEDATE, ORDER_BY_LASTUSER, ORDER_BY_MAKEBUY, ORDER_BY_ORIGIN, ORDER_BY_PARTNUMBER, ORDER_BY_PARTTYPE, ORDER_BY_PRODUCTCODE
Constructor Summary
PartOnHandWithPartBasicInfoResult()
Method Summary
java.math.BigDecimal | getListPrice()
java.math.BigDecimal | getOnDemandQty()
java.math.BigDecimal | getOnhand()
java.math.BigDecimal | getOnOrderQty()
java.math.BigDecimal | getPosOnhand()
java.math.BigDecimal | getShipInProcessQty()
java.math.BigDecimal | getShipInTransactionQty()
java.math.BigDecimal | getWorkInProcessQty()
void | setListPrice(java.math.BigDecimal listPrice)
void | setOnDemandQty(java.math.BigDecimal onDemandQty)
void | setOnhand(java.math.BigDecimal onhand)
void | setOnOrderQty(java.math.BigDecimal onOrderQty)
void | setPosOnhand(java.math.BigDecimal posOnhand)
void | setShipInProcessQty(java.math.BigDecimal shipInProcessQty)
void | setShipInTransactionQty(java.math.BigDecimal shipInTransactionQty)
void | setWorkInProcessQty(java.math.BigDecimal workInProcessQty)
Methods inherited from class bb.common.PartBasicInfo
equals, getBill, getBuyerCode, getCommodityCode, getCountryOrigin, getDescription, getDetectionStandard, getDrawing, getEngGroup, getHavePicture, getHold, getLastChangeDate, getLastUser, getLeadTime, getMakeBuy, getMaterial, getModelNumber, getOrigin, getPartPk, getPartUnit, getProductCode, getRevision, getSaleable, getSalesDrawing, getSecurityLevel, getTraceable, getVolume, getVolumeUnit, getWeight, getWeightUnit, getWi, hashCode, setBill, setBuyerCode, setCommodityCode, setCountryOrigin, setDescription, setDetectionStandard, setDrawing, setEngGroup, setHavePicture, setHold, setLastChangeDate, setLastUser, setLeadTime, setMakeBuy, setMaterial, setModelNumber, setOrigin, setPartPk, setPartUnit, setProductCode, setRevision, setSaleable, setSalesDrawing, setSecurityLevel, setTraceable, setVolume, setVolumeUnit, setWeight, setWeightUnit, setWi, toString
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_WEIGHT

public static final java.lang.String ORDER_BY_WEIGHT
See Also:
Constant Field Values

ORDER_BY_BUYERCODE

public static final java.lang.String ORDER_BY_BUYERCODE
See Also:
Constant Field Values

ORDER_BY_HOLD

public static final java.lang.String ORDER_BY_HOLD
See Also:
Constant Field Values

ORDER_BY_DRAWING

public static final java.lang.String ORDER_BY_DRAWING
See Also:
Constant Field Values

ORDER_BY_MODELNUMBER

public static final java.lang.String ORDER_BY_MODELNUMBER
See Also:
Constant Field Values

ORDER_BY_COMMODITYCODE

public static final java.lang.String ORDER_BY_COMMODITYCODE
See Also:
Constant Field Values

ORDER_BY_PARTUNIT

public static final java.lang.String ORDER_BY_PARTUNIT
See Also:
Constant Field Values

ORDER_BY_ORGANIZATION

public static final java.lang.String ORDER_BY_ORGANIZATION
See Also:
Constant Field Values

ORDER_BY_SECURITYLEVEL

public static final java.lang.String ORDER_BY_SECURITYLEVEL
See Also:
Constant Field Values

ORDER_BY_ONHAND

public static final java.lang.String ORDER_BY_ONHAND
See Also:
Constant Field Values

ORDER_BY_ONDEMANDQTY

public static final java.lang.String ORDER_BY_ONDEMANDQTY
See Also:
Constant Field Values

ORDER_BY_ONORDERQTY

public static final java.lang.String ORDER_BY_ONORDERQTY
See Also:
Constant Field Values
Constructor Detail

PartOnHandWithPartBasicInfoResult

public PartOnHandWithPartBasicInfoResult()
Method Detail

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

getOnDemandQty

public java.math.BigDecimal getOnDemandQty()

setOnDemandQty

public void setOnDemandQty(java.math.BigDecimal onDemandQty)

getOnhand

public java.math.BigDecimal getOnhand()

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

getOnOrderQty

public java.math.BigDecimal getOnOrderQty()

setOnOrderQty

public void setOnOrderQty(java.math.BigDecimal onOrderQty)

getShipInProcessQty

public java.math.BigDecimal getShipInProcessQty()

setShipInProcessQty

public void setShipInProcessQty(java.math.BigDecimal shipInProcessQty)

getShipInTransactionQty

public java.math.BigDecimal getShipInTransactionQty()

setShipInTransactionQty

public void setShipInTransactionQty(java.math.BigDecimal shipInTransactionQty)

getWorkInProcessQty

public java.math.BigDecimal getWorkInProcessQty()

setWorkInProcessQty

public void setWorkInProcessQty(java.math.BigDecimal workInProcessQty)

getPosOnhand

public java.math.BigDecimal getPosOnhand()

setPosOnhand

public void setPosOnhand(java.math.BigDecimal posOnhand)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartPictureVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartPictureVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartPictureVO
All Implemented Interfaces:
java.io.Serializable
public class PartPictureVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartPictureVO()
default constructor
PartPictureVO(java.lang.String extension)
minimal constructor
PartPictureVO(java.lang.String lastChangeUser, byte[] picture, java.lang.String extension, java.util.Date lastChangeDate)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getExtension()
java.lang.Short | getHeight()
java.lang.Long | getIi()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
byte[] | getPicture()
java.lang.Short | getWidth()
int | hashCode()
boolean | isMainPicture()
void | setExtension(java.lang.String extension)
void | setHeight(java.lang.Short height)
void | setIi(java.lang.Long ii)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setMainPicture(boolean mainPicture)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPicture(byte[] picture)
void | setWidth(java.lang.Short width)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartPictureVO

public PartPictureVO(java.lang.String lastChangeUser,
                     byte[] picture,
                     java.lang.String extension,
                     java.util.Date lastChangeDate)
full constructor

PartPictureVO

public PartPictureVO()
default constructor

PartPictureVO

public PartPictureVO(java.lang.String extension)
minimal constructor

Method Detail

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getWidth

public java.lang.Short getWidth()

setWidth

public void setWidth(java.lang.Short width)

getHeight

public java.lang.Short getHeight()

setHeight

public void setHeight(java.lang.Short height)

getPicture

public byte[] getPicture()

setPicture

public void setPicture(byte[] picture)

isMainPicture

public boolean isMainPicture()

setMainPicture

public void setMainPicture(boolean mainPicture)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartPK

java.lang.Object
    extended by  bb.common.PartPK
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<PartPK>
public class PartPK
extends java.lang.Object
implements java.io.Serializable, java.lang.Comparable<PartPK>

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PartPK()
default constructor
PartPK(java.lang.String partNumber, java.lang.String partType)
full constructor
Method Summary
int | compareTo(PartPK other)
boolean | equals(java.lang.Object other)
java.lang.String | getPartNumber()
java.lang.String | getPartType()
int | hashCode()
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartPK

public PartPK(java.lang.String partNumber,
              java.lang.String partType)
full constructor

PartPK

public PartPK()
default constructor

Method Detail

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()

compareTo

public int compareTo(PartPK other)
Specified by:
compareTo in interface java.lang.Comparable<PartPK>
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartReceivedListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartReceivedListResult

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartReceivedVO
            extended by  bb.common.PartReceivedListResult
All Implemented Interfaces:
java.io.Serializable
public class PartReceivedListResult
extends PartReceivedVO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_DATEISSUED
static java.lang.String | ORDER_BY_ORDERNUMBER
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_project
static java.lang.String | ORDER_BY_RELATEDDOC
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_WORKORDERNUMBER
Fields inherited from class bb.common.PartReceivedVO
ORDER_BY_DISASSEMBLEWORKORDERNUMBER, ORDER_BY_LOCATE, ORDER_BY_TRANSACTIONNUMBER
Constructor Summary
PartReceivedListResult()
Method Summary
java.lang.String | getCurrency()
java.math.BigDecimal | getCurrentOnhand()
java.util.Date | getDateRequired()
java.lang.String | getProject()
java.lang.String | getRelatedDoc()
java.math.BigDecimal | getTotalReceived()
void | setCurrency(java.lang.String currency)
void | setCurrentOnhand(java.math.BigDecimal currentOnhand)
void | setDateRequired(java.util.Date dateRequired)
void | setProject(java.lang.String project)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setTotalReceived(java.math.BigDecimal totalReceived)
Methods inherited from class bb.common.PartReceivedVO
equals, getCost, getDateReceived, getDescription, getDisassembleWorkOrderItemNumber, getDisassembleWorkOrderNumber, getIi, getItemNumber, getLocate, getLot, getNote, getOperator, getOrderNumber, getPartFrom, getPartNumber, getPartType, getQtyReceived, getReceiver, getSerial, getStdCost, getTrackings, getTransactionNumber, getUnit, getVendorId, hashCode, setCost, setDateReceived, setDescription, setDisassembleWorkOrderItemNumber, setDisassembleWorkOrderNumber, setIi, setItemNumber, setLocate, setLot, setNote, setOperator, setOrderNumber, setPartFrom, setPartNumber, setPartType, setQtyReceived, setReceiver, setSerial, setStdCost, setTrackings, setTransactionNumber, setUnit, setVendorId, toString
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ORDERNUMBER

public static final java.lang.String ORDER_BY_ORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_WORKORDERNUMBER

public static final java.lang.String ORDER_BY_WORKORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_DATEISSUED

public static final java.lang.String ORDER_BY_DATEISSUED
See Also:
Constant Field Values

ORDER_BY_RELATEDDOC

public static final java.lang.String ORDER_BY_RELATEDDOC
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values

ORDER_BY_project

public static final java.lang.String ORDER_BY_project
See Also:
Constant Field Values
Constructor Detail

PartReceivedListResult

public PartReceivedListResult()
Method Detail

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getDateRequired

public java.util.Date getDateRequired()

setDateRequired

public void setDateRequired(java.util.Date dateRequired)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

getCurrentOnhand

public java.math.BigDecimal getCurrentOnhand()

setCurrentOnhand

public void setCurrentOnhand(java.math.BigDecimal currentOnhand)

getTotalReceived

public java.math.BigDecimal getTotalReceived()

setTotalReceived

public void setTotalReceived(java.math.BigDecimal totalReceived)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartReceivedVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartReceivedVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartReceivedVO
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
PartReceivedListResult
public class PartReceivedVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DATEISSUED
static java.lang.String | ORDER_BY_DISASSEMBLEWORKORDERNUMBER
static java.lang.String | ORDER_BY_LOCATE
static java.lang.String | ORDER_BY_ORDERNUMBER
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_TRANSACTIONNUMBER
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_WORKORDERNUMBER
Constructor Summary
PartReceivedVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getCost()
java.util.Date | getDateReceived()
java.lang.String | getDescription()
java.lang.String | getDisassembleWorkOrderItemNumber()
java.lang.String | getDisassembleWorkOrderNumber()
java.lang.Integer | getIi()
java.lang.Short | getItemNumber()
java.lang.String | getLocate()
java.lang.String | getLot()
java.lang.String | getNote()
java.lang.String | getOperator()
java.lang.Integer | getOrderNumber()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getQtyReceived()
java.lang.String | getReceiver()
java.lang.String | getSerial()
java.math.BigDecimal | getStdCost()
java.util.Map | getTrackings()
java.lang.String | getTransactionNumber()
java.lang.String | getUnit()
java.lang.String | getVendorId()
int | hashCode()
void | setCost(java.math.BigDecimal cost)
void | setDateReceived(java.util.Date dateReceived)
void | setDescription(java.lang.String description)
void | setDisassembleWorkOrderItemNumber(java.lang.String disassembleWorkOrderItemNumber)
void | setDisassembleWorkOrderNumber(java.lang.String disassembleWorkOrderNumber)
void | setIi(java.lang.Integer ii)
void | setItemNumber(java.lang.Short itemNumber)
void | setLocate(java.lang.String locate)
void | setLot(java.lang.String lot)
void | setNote(java.lang.String note)
void | setOperator(java.lang.String operator)
void | setOrderNumber(java.lang.Integer orderNumber)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setQtyReceived(java.math.BigDecimal qtyReceived)
void | setReceiver(java.lang.String receiver)
void | setSerial(java.lang.String serial)
void | setStdCost(java.math.BigDecimal stdCost)
void | setTrackings(java.util.Map trackings)
void | setTransactionNumber(java.lang.String transactionNumber)
void | setUnit(java.lang.String unit)
void | setVendorId(java.lang.String vendorId)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ORDERNUMBER

public static final java.lang.String ORDER_BY_ORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_WORKORDERNUMBER

public static final java.lang.String ORDER_BY_WORKORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_DATEISSUED

public static final java.lang.String ORDER_BY_DATEISSUED
See Also:
Constant Field Values

ORDER_BY_LOCATE

public static final java.lang.String ORDER_BY_LOCATE
See Also:
Constant Field Values

ORDER_BY_TRANSACTIONNUMBER

public static final java.lang.String ORDER_BY_TRANSACTIONNUMBER
See Also:
Constant Field Values

ORDER_BY_DISASSEMBLEWORKORDERNUMBER

public static final java.lang.String ORDER_BY_DISASSEMBLEWORKORDERNUMBER
See Also:
Constant Field Values
Constructor Detail

PartReceivedVO

public PartReceivedVO()
default constructor

Method Detail

getIi

public java.lang.Integer getIi()

setIi

public void setIi(java.lang.Integer ii)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getDisassembleWorkOrderNumber

public java.lang.String getDisassembleWorkOrderNumber()

setDisassembleWorkOrderNumber

public void setDisassembleWorkOrderNumber(java.lang.String disassembleWorkOrderNumber)

getDisassembleWorkOrderItemNumber

public java.lang.String getDisassembleWorkOrderItemNumber()

setDisassembleWorkOrderItemNumber

public void setDisassembleWorkOrderItemNumber(java.lang.String disassembleWorkOrderItemNumber)

getQtyReceived

public java.math.BigDecimal getQtyReceived()

setQtyReceived

public void setQtyReceived(java.math.BigDecimal qtyReceived)

getDateReceived

public java.util.Date getDateReceived()

setDateReceived

public void setDateReceived(java.util.Date dateReceived)

getCost

public java.math.BigDecimal getCost()

setCost

public void setCost(java.math.BigDecimal cost)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getSerial

public java.lang.String getSerial()

setSerial

public void setSerial(java.lang.String serial)

getLot

public java.lang.String getLot()

getOperator

public java.lang.String getOperator()

setLot

public void setLot(java.lang.String lot)

setOperator

public void setOperator(java.lang.String operator)

getItemNumber

public java.lang.Short getItemNumber()

setItemNumber

public void setItemNumber(java.lang.Short itemNumber)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getNote

public java.lang.String getNote()

setNote

public void setNote(java.lang.String note)

getOrderNumber

public java.lang.Integer getOrderNumber()

setOrderNumber

public void setOrderNumber(java.lang.Integer orderNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getReceiver

public java.lang.String getReceiver()

setReceiver

public void setReceiver(java.lang.String receiver)

getTransactionNumber

public java.lang.String getTransactionNumber()

setTransactionNumber

public void setTransactionNumber(java.lang.String transactionNumber)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getTrackings

public java.util.Map getTrackings()

setTrackings

public void setTrackings(java.util.Map trackings)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartSecurityLevelVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartSecurityLevelVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartSecurityLevelVO
All Implemented Interfaces:
java.io.Serializable
public class PartSecurityLevelVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_LEVELDESCRIPTION
static java.lang.String | ORDER_BY_LEVELID
Constructor Summary
PartSecurityLevelVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getLevelDescription()
java.lang.String | getLevelId()
int | hashCode()
void | setLevelDescription(java.lang.String levelDescription)
void | setLevelId(java.lang.String levelId)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_LEVELID

public static final java.lang.String ORDER_BY_LEVELID
See Also:
Constant Field Values

ORDER_BY_LEVELDESCRIPTION

public static final java.lang.String ORDER_BY_LEVELDESCRIPTION
See Also:
Constant Field Values
Constructor Detail

PartSecurityLevelVO

public PartSecurityLevelVO()
Method Detail

getLevelId

public java.lang.String getLevelId()

setLevelId

public void setLevelId(java.lang.String levelId)

getLevelDescription

public java.lang.String getLevelDescription()

setLevelDescription

public void setLevelDescription(java.lang.String levelDescription)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartsToDeleteResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartsToDeleteResult

java.lang.Object
    extended by  bb.common.PartsToDeleteResult
All Implemented Interfaces:
java.io.Serializable
public class PartsToDeleteResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartsToDeleteResult()
Method Summary
java.util.List<BillWithPartInfoResult> | getBomToDeletedNotUsed()
java.util.List<PartBasicInfo> | getPartsToDeletedNotUsed()
java.util.List<PurchaseOrderItemListResult> | getPartsToDeleteInPO()
java.util.List<SalesOrderItemListResult> | getPartsToDeleteInSO()
java.util.List<WorkOrderItemListResult> | getPartsToDeleteInWO()
java.util.List<WorkOrderItemPartDetail> | getPartsToDeleteInWOItemDetail()
void | setBomToDeletedNotUsed(java.util.List<BillWithPartInfoResult> bomToDeletedNotUsed)
void | setPartsToDeletedNotUsed(java.util.List<PartBasicInfo> partsToDeletedNotUsed)
void | setPartsToDeleteInPO(java.util.List<PurchaseOrderItemListResult> partsToDeleteInPO)
void | setPartsToDeleteInSO(java.util.List<SalesOrderItemListResult> partsToDeleteInSO)
void | setPartsToDeleteInWO(java.util.List<WorkOrderItemListResult> partsToDeleteInWO)
void | setPartsToDeleteInWOItemDetail(java.util.List<WorkOrderItemPartDetail> partsToDeleteInWOItemDetail)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PartsToDeleteResult

public PartsToDeleteResult()
Method Detail

getPartsToDeleteInPO

public java.util.List<PurchaseOrderItemListResult> getPartsToDeleteInPO()

setPartsToDeleteInPO

public void setPartsToDeleteInPO(java.util.List<PurchaseOrderItemListResult> partsToDeleteInPO)

getPartsToDeleteInSO

public java.util.List<SalesOrderItemListResult> getPartsToDeleteInSO()

setPartsToDeleteInSO

public void setPartsToDeleteInSO(java.util.List<SalesOrderItemListResult> partsToDeleteInSO)

getPartsToDeleteInWO

public java.util.List<WorkOrderItemListResult> getPartsToDeleteInWO()

setPartsToDeleteInWO

public void setPartsToDeleteInWO(java.util.List<WorkOrderItemListResult> partsToDeleteInWO)

getPartsToDeleteInWOItemDetail

public java.util.List<WorkOrderItemPartDetail> getPartsToDeleteInWOItemDetail()

setPartsToDeleteInWOItemDetail

public void setPartsToDeleteInWOItemDetail(java.util.List<WorkOrderItemPartDetail> partsToDeleteInWOItemDetail)

getPartsToDeletedNotUsed

public java.util.List<PartBasicInfo> getPartsToDeletedNotUsed()

setPartsToDeletedNotUsed

public void setPartsToDeletedNotUsed(java.util.List<PartBasicInfo> partsToDeletedNotUsed)

getBomToDeletedNotUsed

public java.util.List<BillWithPartInfoResult> getBomToDeletedNotUsed()

setBomToDeletedNotUsed

public void setBomToDeletedNotUsed(java.util.List<BillWithPartInfoResult> bomToDeletedNotUsed)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartToAuditFlagResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartToAuditFlagResult

java.lang.Object
    extended by  bb.common.PartToAuditFlagResult
All Implemented Interfaces:
java.io.Serializable
public class PartToAuditFlagResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartToAuditFlagResult()
Method Summary
java.lang.String | getDescription()
java.lang.String | getFlagString()
java.lang.String | getPartFrom()
PartPK | getPk()
boolean | isNeedToSetFLAG()
void | setDescription(java.lang.String description)
void | setFlagString(java.lang.String flagString)
void | setNeedToSetFLAG(boolean needToSetFLAG)
void | setPartFrom(java.lang.String partFrom)
void | setPk(PartPK pk)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PartToAuditFlagResult

public PartToAuditFlagResult()
Method Detail

getFlagString

public java.lang.String getFlagString()

setFlagString

public void setFlagString(java.lang.String flagString)

isNeedToSetFLAG

public boolean isNeedToSetFLAG()

setNeedToSetFLAG

public void setNeedToSetFLAG(boolean needToSetFLAG)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getPk

public PartPK getPk()

setPk

public void setPk(PartPK pk)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartTraceableCategoryPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartTraceableCategoryPK

java.lang.Object
    extended by  bb.common.PartTraceableCategoryPK
All Implemented Interfaces:
java.io.Serializable
public class PartTraceableCategoryPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PartTraceableCategoryPK()
default constructor
PartTraceableCategoryPK(java.lang.String partNumber, java.lang.String partType, java.lang.Short traceableCategoryItem)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.Short | getTraceableCategoryItem()
int | hashCode()
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setTraceableCategoryItem(java.lang.Short traceableCategoryItem)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartTraceableCategoryPK

public PartTraceableCategoryPK(java.lang.String partNumber,
                               java.lang.String partType,
                               java.lang.Short traceableCategoryItem)
full constructor

PartTraceableCategoryPK

public PartTraceableCategoryPK()
default constructor

Method Detail

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getTraceableCategoryItem

public java.lang.Short getTraceableCategoryItem()

setTraceableCategoryItem

public void setTraceableCategoryItem(java.lang.Short traceableCategoryItem)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartTraceableCategoryVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartTraceableCategoryVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartTraceableCategoryVO
All Implemented Interfaces:
java.io.Serializable
public class PartTraceableCategoryVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartTraceableCategoryVO()
Method Summary
boolean | equals(java.lang.Object other)
TraceableCategoriesVO | getCategoryDescription()
java.lang.String | getCategoryId()
PartTraceableCategoryPK | getPk()
int | hashCode()
void | setCategoryDescription(TraceableCategoriesVO categoryDescriptionVO)
void | setCategoryId(java.lang.String categoryId)
void | setPk(PartTraceableCategoryPK pk)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartTraceableCategoryVO

public PartTraceableCategoryVO()
Method Detail

getPk

public PartTraceableCategoryPK getPk()

setPk

public void setPk(PartTraceableCategoryPK pk)

getCategoryId

public java.lang.String getCategoryId()

setCategoryId

public void setCategoryId(java.lang.String categoryId)

getCategoryDescription

public TraceableCategoriesVO getCategoryDescription()

setCategoryDescription

public void setCategoryDescription(TraceableCategoriesVO categoryDescriptionVO)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartTraceableInfoResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartTraceableInfoResult

java.lang.Object
    extended by  bb.common.PartTraceableInfoResult
All Implemented Interfaces:
java.io.Serializable
public class PartTraceableInfoResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartTraceableInfoResult()
Method Summary
java.util.Collection | getCategory()
PartBasicInfo | getPartBasicInfo()
java.util.Collection | getSpec()
java.lang.Byte | getTraceableLevel()
void | setCategory(java.util.Collection category)
void | setPartBasicInfo(PartBasicInfo partBasicInfo)
void | setSpec(java.util.Collection spec)
void | setTraceableLevel(java.lang.Byte traceableLevel)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PartTraceableInfoResult

public PartTraceableInfoResult()
Method Detail

getTraceableLevel

public java.lang.Byte getTraceableLevel()

setTraceableLevel

public void setTraceableLevel(java.lang.Byte traceableLevel)

setCategory

public void setCategory(java.util.Collection category)

getCategory

public java.util.Collection getCategory()

setSpec

public void setSpec(java.util.Collection spec)

setPartBasicInfo

public void setPartBasicInfo(PartBasicInfo partBasicInfo)

getSpec

public java.util.Collection getSpec()

getPartBasicInfo

public PartBasicInfo getPartBasicInfo()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartTraceableListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartTraceableListResult

java.lang.Object
    extended by  bb.common.PartBasicInfo
        extended by  bb.common.PartTraceableListResult
All Implemented Interfaces:
java.io.Serializable
public class PartTraceableListResult
extends PartBasicInfo
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
Fields inherited from class bb.common.PartBasicInfo
ORDER_BY_BILL, ORDER_BY_BUYERCODE, ORDER_BY_COMMODITYCODE, ORDER_BY_DESCRIPTION, ORDER_BY_DRAWING, ORDER_BY_HOLD, ORDER_BY_LASTCHANGEDATE, ORDER_BY_LASTUSER, ORDER_BY_MAKEBUY, ORDER_BY_MODELNUMBER, ORDER_BY_ORGANIZATION, ORDER_BY_ORIGIN, ORDER_BY_PARTNUMBER, ORDER_BY_PARTTYPE, ORDER_BY_PARTUNIT, ORDER_BY_PRODUCTCODE, ORDER_BY_SECURITYLEVEL, ORDER_BY_WEIGHT
Constructor Summary
PartTraceableListResult()
Method Summary
java.lang.String | getNewPart()
java.lang.Byte | getTraceableLevel()
void | setNewPart(java.lang.String newPart)
void | setTraceableLevel(java.lang.Byte traceableLevel)
Methods inherited from class bb.common.PartBasicInfo
equals, getBill, getBuyerCode, getCommodityCode, getCountryOrigin, getDescription, getDetectionStandard, getDrawing, getEngGroup, getHavePicture, getHold, getLastChangeDate, getLastUser, getLeadTime, getMakeBuy, getMaterial, getModelNumber, getOrigin, getPartPk, getPartUnit, getProductCode, getRevision, getSaleable, getSalesDrawing, getSecurityLevel, getTraceable, getVolume, getVolumeUnit, getWeight, getWeightUnit, getWi, hashCode, setBill, setBuyerCode, setCommodityCode, setCountryOrigin, setDescription, setDetectionStandard, setDrawing, setEngGroup, setHavePicture, setHold, setLastChangeDate, setLastUser, setLeadTime, setMakeBuy, setMaterial, setModelNumber, setOrigin, setPartPk, setPartUnit, setProductCode, setRevision, setSaleable, setSalesDrawing, setSecurityLevel, setTraceable, setVolume, setVolumeUnit, setWeight, setWeightUnit, setWi, toString
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartTraceableListResult

public PartTraceableListResult()
Method Detail

getTraceableLevel

public java.lang.Byte getTraceableLevel()

setTraceableLevel

public void setTraceableLevel(java.lang.Byte traceableLevel)

getNewPart

public java.lang.String getNewPart()

setNewPart

public void setNewPart(java.lang.String newPart)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartTraceableResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartTraceableResult

java.lang.Object
    extended by  bb.common.PartBasicInfo
        extended by  bb.common.PartTraceableResult
All Implemented Interfaces:
java.io.Serializable
public class PartTraceableResult
extends PartBasicInfo
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CATEGORYID
static java.lang.String | ORDER_BY_SPECIFICATIONID
static java.lang.String | ORDER_BY_TRACEABLELEVEL
Fields inherited from class bb.common.PartBasicInfo
ORDER_BY_BILL, ORDER_BY_BUYERCODE, ORDER_BY_COMMODITYCODE, ORDER_BY_DESCRIPTION, ORDER_BY_DRAWING, ORDER_BY_HOLD, ORDER_BY_LASTCHANGEDATE, ORDER_BY_LASTUSER, ORDER_BY_MAKEBUY, ORDER_BY_MODELNUMBER, ORDER_BY_ORGANIZATION, ORDER_BY_ORIGIN, ORDER_BY_PARTNUMBER, ORDER_BY_PARTTYPE, ORDER_BY_PARTUNIT, ORDER_BY_PRODUCTCODE, ORDER_BY_SECURITYLEVEL, ORDER_BY_WEIGHT
Constructor Summary
PartTraceableResult()
Method Summary
java.lang.String | getCategoryId()
java.lang.String | getCriticalityCategory()
java.lang.String | getQualitySpecification()
short | getSpecificationId()
java.lang.Byte | getTraceableLevel()
void | setCategoryId(java.lang.String categoryId)
void | setCriticalityCategory(java.lang.String criticalityCategory)
void | setQualitySpecification(java.lang.String qualitySpecification)
void | setSpecificationId(short specificationId)
void | setTraceableLevel(java.lang.Byte traceableLevel)
Methods inherited from class bb.common.PartBasicInfo
equals, getBill, getBuyerCode, getCommodityCode, getCountryOrigin, getDescription, getDetectionStandard, getDrawing, getEngGroup, getHavePicture, getHold, getLastChangeDate, getLastUser, getLeadTime, getMakeBuy, getMaterial, getModelNumber, getOrigin, getPartPk, getPartUnit, getProductCode, getRevision, getSaleable, getSalesDrawing, getSecurityLevel, getTraceable, getVolume, getVolumeUnit, getWeight, getWeightUnit, getWi, hashCode, setBill, setBuyerCode, setCommodityCode, setCountryOrigin, setDescription, setDetectionStandard, setDrawing, setEngGroup, setHavePicture, setHold, setLastChangeDate, setLastUser, setLeadTime, setMakeBuy, setMaterial, setModelNumber, setOrigin, setPartPk, setPartUnit, setProductCode, setRevision, setSaleable, setSalesDrawing, setSecurityLevel, setTraceable, setVolume, setVolumeUnit, setWeight, setWeightUnit, setWi, toString
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_TRACEABLELEVEL

public static final java.lang.String ORDER_BY_TRACEABLELEVEL
See Also:
Constant Field Values

ORDER_BY_CATEGORYID

public static final java.lang.String ORDER_BY_CATEGORYID
See Also:
Constant Field Values

ORDER_BY_SPECIFICATIONID

public static final java.lang.String ORDER_BY_SPECIFICATIONID
See Also:
Constant Field Values
Constructor Detail

PartTraceableResult

public PartTraceableResult()
Method Detail

getCategoryId

public java.lang.String getCategoryId()

setCategoryId

public void setCategoryId(java.lang.String categoryId)

getTraceableLevel

public java.lang.Byte getTraceableLevel()

setTraceableLevel

public void setTraceableLevel(java.lang.Byte traceableLevel)

getCriticalityCategory

public java.lang.String getCriticalityCategory()

setCriticalityCategory

public void setCriticalityCategory(java.lang.String criticalityCategory)

getQualitySpecification

public java.lang.String getQualitySpecification()

setQualitySpecification

public void setQualitySpecification(java.lang.String qualitySpecification)

getSpecificationId

public short getSpecificationId()

setSpecificationId

public void setSpecificationId(short specificationId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartTraceableSpecPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartTraceableSpecPK

java.lang.Object
    extended by  bb.common.PartTraceableSpecPK
All Implemented Interfaces:
java.io.Serializable
public class PartTraceableSpecPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PartTraceableSpecPK()
default constructor
PartTraceableSpecPK(java.lang.String partNumber, java.lang.String partType, java.lang.Short partTraceableSpecItem)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getPartNumber()
java.lang.Short | getPartTraceableSpecItem()
java.lang.String | getPartType()
int | hashCode()
void | setPartNumber(java.lang.String partNumber)
void | setPartTraceableSpecItem(java.lang.Short partTraceableSpecItem)
void | setPartType(java.lang.String partType)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartTraceableSpecPK

public PartTraceableSpecPK(java.lang.String partNumber,
                           java.lang.String partType,
                           java.lang.Short partTraceableSpecItem)
full constructor

PartTraceableSpecPK

public PartTraceableSpecPK()
default constructor

Method Detail

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartTraceableSpecItem

public java.lang.Short getPartTraceableSpecItem()

setPartTraceableSpecItem

public void setPartTraceableSpecItem(java.lang.Short partTraceableSpecItem)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartTraceableSpecVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartTraceableSpecVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartTraceableSpecVO
All Implemented Interfaces:
java.io.Serializable
public class PartTraceableSpecVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartTraceableSpecVO()
Method Summary
boolean | equals(java.lang.Object other)
PartTraceableSpecPK | getPk()
TraceableSpecsVO | getSpecification()
short | getSpecificationId()
int | hashCode()
void | setPk(PartTraceableSpecPK pk)
void | setSpecification(TraceableSpecsVO specificationVO)
void | setSpecificationId(short specificationId)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartTraceableSpecVO

public PartTraceableSpecVO()
Method Detail

getPk

public PartTraceableSpecPK getPk()

setPk

public void setPk(PartTraceableSpecPK pk)

getSpecificationId

public short getSpecificationId()

setSpecificationId

public void setSpecificationId(short specificationId)

getSpecification

public TraceableSpecsVO getSpecification()

setSpecification

public void setSpecification(TraceableSpecsVO specificationVO)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartTrackingPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartTrackingPK

java.lang.Object
    extended by  bb.common.PartTrackingPK
All Implemented Interfaces:
java.io.Serializable
public class PartTrackingPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartTrackingPK()
PartTrackingPK(java.lang.String partNumber, java.lang.String partType, java.lang.String trackingNumber)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getTrackingNumber()
int | hashCode()
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setTrackingNumber(java.lang.String trackingNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartTrackingPK

public PartTrackingPK()

PartTrackingPK

public PartTrackingPK(java.lang.String partNumber,
                      java.lang.String partType,
                      java.lang.String trackingNumber)
Method Detail

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartNumber

public java.lang.String getPartNumber()

setPartType

public void setPartType(java.lang.String partType)

getPartType

public java.lang.String getPartType()

setTrackingNumber

public void setTrackingNumber(java.lang.String trackingNumber)

getTrackingNumber

public java.lang.String getTrackingNumber()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartTrackingVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartTrackingVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartTrackingVO
All Implemented Interfaces:
java.io.Serializable
public class PartTrackingVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartTrackingVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getDueDate()
java.util.Date | getLastChangeDate()
java.math.BigDecimal | getNewQtyPicked()
PartTrackingPK | getPk()
java.math.BigDecimal | getQty()
int | hashCode()
void | setDueDate(java.util.Date dueDate)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setNewQtyPicked(java.math.BigDecimal newQtyPicked)
void | setPk(PartTrackingPK pk)
void | setQty(java.math.BigDecimal qty)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartTrackingVO

public PartTrackingVO()
Method Detail

getPk

public PartTrackingPK getPk()

setPk

public void setPk(PartTrackingPK pk)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

getNewQtyPicked

public java.math.BigDecimal getNewQtyPicked()

setNewQtyPicked

public void setNewQtyPicked(java.math.BigDecimal newQtyPicked)

getDueDate

public java.util.Date getDueDate()

setDueDate

public void setDueDate(java.util.Date dueDate)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartTypeVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartTypeVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartTypeVO
All Implemented Interfaces:
java.io.Serializable
public class PartTypeVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_ID
static java.lang.String | ORDER_BY_PARTTYPE
Constructor Summary
PartTypeVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDescription()
java.lang.Short | getId()
java.lang.String | getPartType()
int | hashCode()
boolean | isDocType()
void | setDescription(java.lang.String description)
void | setDocType(boolean docType)
void | setId(java.lang.Short id)
void | setPartType(java.lang.String partType)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ID

public static final java.lang.String ORDER_BY_ID
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

PartTypeVO

public PartTypeVO()
Method Detail

getId

public java.lang.Short getId()

setId

public void setId(java.lang.Short id)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

isDocType

public boolean isDocType()

setDocType

public void setDocType(boolean docType)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartUnitPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartUnitPK

java.lang.Object
    extended by  bb.common.PartUnitPK
All Implemented Interfaces:
java.io.Serializable
public class PartUnitPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartUnitPK()
PartUnitPK(PartPK partPk, java.lang.String unit)
PartUnitPK(java.lang.String partNumber, java.lang.String partType, java.lang.String unit)
Method Summary
boolean | equals(java.lang.Object obj)
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getUnit()
int | hashCode()
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setUnit(java.lang.String unit)
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PartUnitPK

public PartUnitPK()

PartUnitPK

public PartUnitPK(PartPK partPk,
                  java.lang.String unit)

PartUnitPK

public PartUnitPK(java.lang.String partNumber,
                  java.lang.String partType,
                  java.lang.String unit)
Method Detail

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartUnitVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartUnitVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartUnitVO
All Implemented Interfaces:
java.io.Serializable
public class PartUnitVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartUnitVO()
Method Summary
boolean | equals(java.lang.Object obj)
java.math.BigDecimal | getListPrice()
java.lang.String | getMultiplier()
PartUnitPK | getPk()
int | hashCode()
boolean | isDefaultPartUnit()
boolean | isPurchaseOrderUnit()
boolean | isSalesOrderUnit()
void | setDefaultPartUnit(boolean defaultPartUnit)
void | setListPrice(java.math.BigDecimal listPrice)
void | setMultiplier(java.lang.String multiplier)
void | setPk(PartUnitPK pk)
void | setPurchaseOrderUnit(boolean purchaseOrderUnit)
void | setSalesOrderUnit(boolean salesOrderUnit)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PartUnitVO

public PartUnitVO()
Method Detail

isDefaultPartUnit

public boolean isDefaultPartUnit()

setDefaultPartUnit

public void setDefaultPartUnit(boolean defaultPartUnit)

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

getMultiplier

public java.lang.String getMultiplier()

setMultiplier

public void setMultiplier(java.lang.String multiplier)

getPk

public PartUnitPK getPk()

setPk

public void setPk(PartUnitPK pk)

isPurchaseOrderUnit

public boolean isPurchaseOrderUnit()

setPurchaseOrderUnit

public void setPurchaseOrderUnit(boolean purchaseOrderUnit)

isSalesOrderUnit

public boolean isSalesOrderUnit()

setSalesOrderUnit

public void setSalesOrderUnit(boolean salesOrderUnit)

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


partUsedInfoResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class partUsedInfoResult

java.lang.Object
    extended by  bb.common.partUsedInfoResult
All Implemented Interfaces:
java.io.Serializable
public class partUsedInfoResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
partUsedInfoResult()
Method Summary
java.math.BigDecimal | getCost()
java.util.Date | getDateUsed()
java.lang.String | getPartNumber()
java.math.BigDecimal | getQty()
void | setCost(java.math.BigDecimal cost)
void | setDateUsed(java.util.Date dateUsed)
void | setPartNumber(java.lang.String partNumber)
void | setQty(java.math.BigDecimal qty)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

partUsedInfoResult

public partUsedInfoResult()
Method Detail

setPartNumber

public void setPartNumber(java.lang.String partNumber)

setQty

public void setQty(java.math.BigDecimal qty)

setCost

public void setCost(java.math.BigDecimal cost)

setDateUsed

public void setDateUsed(java.util.Date dateUsed)

getPartNumber

public java.lang.String getPartNumber()

getQty

public java.math.BigDecimal getQty()

getCost

public java.math.BigDecimal getCost()

getDateUsed

public java.util.Date getDateUsed()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartUseTypeVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartUseTypeVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartUseTypeVO
All Implemented Interfaces:
java.io.Serializable
public class PartUseTypeVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_USETYPE
Constructor Summary
PartUseTypeVO()
PartUseTypeVO(java.lang.String useType, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDescription()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getUseType()
int | hashCode()
void | setDescription(java.lang.String description)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setUseType(java.lang.String useType)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_USETYPE

public static final java.lang.String ORDER_BY_USETYPE
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

PartUseTypeVO

public PartUseTypeVO()

PartUseTypeVO

public PartUseTypeVO(java.lang.String useType,
                     java.lang.String partNumber,
                     java.lang.String partType,
                     java.lang.String partFrom)
Method Detail

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getUseType

public java.lang.String getUseType()

setUseType

public void setUseType(java.lang.String useType)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartVendorPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartVendorPK

java.lang.Object
    extended by  bb.common.PartVendorPK
All Implemented Interfaces:
java.io.Serializable
public class PartVendorPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PartVendorPK()
default constructor
PartVendorPK(java.lang.String partNumber, java.lang.String partType, java.lang.Byte vendorItem)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.Byte | getVendorItem()
int | hashCode()
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setVendorItem(java.lang.Byte vendorItem)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartVendorPK

public PartVendorPK(java.lang.String partNumber,
                    java.lang.String partType,
                    java.lang.Byte vendorItem)
full constructor

PartVendorPK

public PartVendorPK()
default constructor

Method Detail

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getVendorItem

public java.lang.Byte getVendorItem()

setVendorItem

public void setVendorItem(java.lang.Byte vendorItem)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartVendorVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartVendorVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartVendorVO
All Implemented Interfaces:
java.io.Serializable
public class PartVendorVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartVendorVO()
PartVendorVO(PartPK partPk)
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getEffectiveDate()
java.math.BigDecimal | getLastPurchaseCost()
java.lang.String | getLastPurchaseOrderItemNumber()
java.lang.String | getLastPurchaseOrderNumber()
java.util.Date | getOverdueDate()
PartVendorPK | getPk()
java.math.BigDecimal | getPoQty()
java.lang.String | getPoUnit()
java.lang.String | getQualityCode()
java.lang.String | getRatingCode()
java.lang.String | getRemarks()
java.lang.String | getRequestForQuote()
java.lang.String | getVendorCurrency()
java.lang.String | getVendorId()
java.math.BigDecimal | getVendorLeadTime()
java.lang.String | getVendorName()
java.math.BigDecimal | getVendorPrice()
java.lang.Integer | getVersion()
int | hashCode()
boolean | isPreferred()
void | setEffectiveDate(java.util.Date effectiveDate)
void | setLastPurchaseCost(java.math.BigDecimal lastPurchaseCost)
void | setLastPurchaseOrderItemNumber(java.lang.String lastPurchaseOrderItemNumber)
void | setLastPurchaseOrderNumber(java.lang.String lastPurchaseOrderNumber)
void | setOverdueDate(java.util.Date overdueDate)
void | setPk(PartVendorPK pk)
void | setPoQty(java.math.BigDecimal poQty)
void | setPoUnit(java.lang.String poUnit)
void | setPreferred(boolean preferred)
void | setQualityCode(java.lang.String qualityCode)
void | setRatingCode(java.lang.String ratingCode)
void | setRemarks(java.lang.String remarks)
void | setRequestForQuote(java.lang.String requestForQuote)
void | setVendorCurrency(java.lang.String vendorCurrency)
void | setVendorId(java.lang.String vendorId)
void | setVendorLeadTime(java.math.BigDecimal vendorLeadTime)
void | setVendorName(java.lang.String vendorName)
void | setVendorPrice(java.math.BigDecimal vendorPrice)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartVendorVO

public PartVendorVO()

PartVendorVO

public PartVendorVO(PartPK partPk)
Method Detail

getPk

public PartVendorPK getPk()

setPk

public void setPk(PartVendorPK pk)

getVersion

public java.lang.Integer getVersion()

setVersion

public void setVersion(java.lang.Integer version)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getQualityCode

public java.lang.String getQualityCode()

setQualityCode

public void setQualityCode(java.lang.String qualityCode)

getRatingCode

public java.lang.String getRatingCode()

setRatingCode

public void setRatingCode(java.lang.String ratingCode)

getVendorName

public java.lang.String getVendorName()

setVendorName

public void setVendorName(java.lang.String vendorName)

getVendorPrice

public java.math.BigDecimal getVendorPrice()

setVendorPrice

public void setVendorPrice(java.math.BigDecimal vendorPrice)

getVendorCurrency

public java.lang.String getVendorCurrency()

setVendorCurrency

public void setVendorCurrency(java.lang.String vendorCurrency)

getPoUnit

public java.lang.String getPoUnit()

setPoUnit

public void setPoUnit(java.lang.String poUnit)

getPoQty

public java.math.BigDecimal getPoQty()

setPoQty

public void setPoQty(java.math.BigDecimal poQty)

getVendorLeadTime

public java.math.BigDecimal getVendorLeadTime()

setVendorLeadTime

public void setVendorLeadTime(java.math.BigDecimal vendorLeadTime)

getEffectiveDate

public java.util.Date getEffectiveDate()

setEffectiveDate

public void setEffectiveDate(java.util.Date effectiveDate)

getRemarks

public java.lang.String getRemarks()

getRequestForQuote

public java.lang.String getRequestForQuote()

setRemarks

public void setRemarks(java.lang.String remarks)

setRequestForQuote

public void setRequestForQuote(java.lang.String requestForQuote)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getOverdueDate

public java.util.Date getOverdueDate()

setOverdueDate

public void setOverdueDate(java.util.Date overdueDate)

isPreferred

public boolean isPreferred()

setPreferred

public void setPreferred(boolean preferred)

getLastPurchaseCost

public java.math.BigDecimal getLastPurchaseCost()

setLastPurchaseCost

public void setLastPurchaseCost(java.math.BigDecimal lastPurchaseCost)

getLastPurchaseOrderItemNumber

public java.lang.String getLastPurchaseOrderItemNumber()

setLastPurchaseOrderItemNumber

public void setLastPurchaseOrderItemNumber(java.lang.String lastPurchaseOrderItemNumber)

getLastPurchaseOrderNumber

public java.lang.String getLastPurchaseOrderNumber()

setLastPurchaseOrderNumber

public void setLastPurchaseOrderNumber(java.lang.String lastPurchaseOrderNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartVO
All Implemented Interfaces:
java.io.Serializable
public class PartVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getBill()
java.lang.String | getBuyerCode()
java.lang.String | getCatalog()
java.lang.String | getComment()
java.lang.String | getCommodityCode()
java.lang.String | getCountryOrigin()
java.util.Date | getCreatedDate()
java.lang.String | getDescription()
java.lang.String | getDetectionStandard()
java.lang.String | getDrawing()
java.lang.String | getDrawingNumber()
java.lang.String | getDrawingRev()
java.lang.String | getEngGroup()
java.lang.String | getHavePicture()
java.lang.String | getHold()
java.lang.String | getInspectionType()
java.lang.String | getIrType()
java.lang.String | getIsActivePart()
java.util.Date | getLastChangeDate()
java.lang.String | getLastUser()
java.lang.String | getLevels()
java.lang.String | getMakeBuy()
java.util.Set | getManufacturers()
java.lang.String | getMaterial()
java.lang.String | getModelNumber()
java.util.Set | getMultiLanguage()
java.math.BigDecimal | getMultiQtyforApplying()
java.lang.String | getNewPart()
java.lang.String | getOrigin()
java.lang.String | getOwner()
PartInventoryVO | getPartInventory()
java.lang.String | getPartPoUnit()
java.math.BigDecimal | getPartPoUnitRate()
java.lang.String | getPartUnit()
PartPK | getPk()
java.lang.String | getProductCode()
java.lang.String | getRevision()
java.util.Date | getRevisionDate()
java.lang.String | getSaleable()
java.lang.String | getSalesDrawing()
java.lang.String | getSecurityLevel()
java.math.BigDecimal | getShippingDepth()
java.math.BigDecimal | getShippingLength()
float | getShippingWeight()
java.lang.String | getShippingWeightUnit()
java.math.BigDecimal | getShippingWidth()
java.lang.String | getTraceable()
java.lang.Byte | getTraceableLevel()
java.util.Set<PartUnitVO> | getUnits()
java.util.Set | getVendors()
java.lang.Integer | getVersion()
java.math.BigDecimal | getVolume()
java.lang.String | getVolumeUnit()
java.lang.String | getWi()
int | hashCode()
boolean | isDeleted()
boolean | isDiscountable()
boolean | isRecoil()
boolean | isTaxExempt()
boolean | isUseBackflush()
void | setBill(java.lang.String bill)
void | setBuyerCode(java.lang.String buyerCode)
void | setCatalog(java.lang.String catalog)
void | setComment(java.lang.String comment)
void | setCommodityCode(java.lang.String commodityCode)
void | setCountryOrigin(java.lang.String countryOrigin)
void | setCreatedDate(java.util.Date createdDate)
void | setDeleted(boolean deleted)
void | setDescription(java.lang.String description)
void | setDetectionStandard(java.lang.String detectionStandard)
void | setDiscountable(boolean discountable)
void | setDrawing(java.lang.String drawing)
void | setDrawingNumber(java.lang.String drawingNumber)
void | setDrawingRev(java.lang.String drawingRev)
void | setEngGroup(java.lang.String engGroup)
void | setHavePicture(java.lang.String havePicture)
void | setHold(java.lang.String hold)
void | setInspectionType(java.lang.String inspectionType)
void | setIrType(java.lang.String irType)
void | setIsActivePart(java.lang.String isActivePart)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastUser(java.lang.String lastUser)
void | setLevels(java.lang.String levels)
void | setMakeBuy(java.lang.String makeBuy)
void | setManufacturers(java.util.Set manufacturers)
void | setMaterial(java.lang.String material)
void | setModelNumber(java.lang.String modelNumber)
void | setMultiLanguage(java.util.Set multiLanguage)
void | setMultiQtyforApplying(java.math.BigDecimal multiQtyforApplying)
void | setNewPart(java.lang.String newPart)
void | setOrigin(java.lang.String origin)
void | setOwner(java.lang.String owner)
void | setPartInventory(PartInventoryVO partInventory)
void | setPartPoUnit(java.lang.String partPoUnit)
void | setPartPoUnitRate(java.math.BigDecimal partPoUnitRate)
void | setPartUnit(java.lang.String partUnit)
void | setPk(PartPK pk)
void | setProductCode(java.lang.String productCode)
void | setRecoil(boolean recoil)
void | setRevision(java.lang.String revision)
void | setRevisionDate(java.util.Date revisionDate)
void | setSaleable(java.lang.String saleable)
void | setSalesDrawing(java.lang.String salesDrawing)
void | setSecurityLevel(java.lang.String securityLevel)
void | setShippingDepth(java.math.BigDecimal shippingDepth)
void | setShippingLength(java.math.BigDecimal shippingLength)
void | setShippingWeight(float shippingWeight)
void | setShippingWeightUnit(java.lang.String shippingWeightUnit)
void | setShippingWidth(java.math.BigDecimal shippingWidth)
void | setTaxExempt(boolean taxExempt)
void | setTraceable(java.lang.String traceable)
void | setTraceableLevel(java.lang.Byte traceableLevel)
void | setUnits(java.util.Set<PartUnitVO> units)
void | setUseBackflush(boolean useBackflush)
void | setVendors(java.util.Set vendors)
void | setVersion(java.lang.Integer version)
void | setVolume(java.math.BigDecimal volume)
void | setVolumeUnit(java.lang.String volumeUnit)
void | setWi(java.lang.String wi)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartVO

public PartVO()
Method Detail

getPk

public PartPK getPk()

setPk

public void setPk(PartPK pk)

getLastUser

public java.lang.String getLastUser()

setLastUser

public void setLastUser(java.lang.String lastUser)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getCreatedDate

public java.util.Date getCreatedDate()

setCreatedDate

public void setCreatedDate(java.util.Date createdDate)

getOwner

public java.lang.String getOwner()

setOwner

public void setOwner(java.lang.String owner)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getBuyerCode

public java.lang.String getBuyerCode()

setBuyerCode

public void setBuyerCode(java.lang.String buyerCode)

getCommodityCode

public java.lang.String getCommodityCode()

setCommodityCode

public void setCommodityCode(java.lang.String commodityCode)

getMakeBuy

public java.lang.String getMakeBuy()

setMakeBuy

public void setMakeBuy(java.lang.String makeBuy)

getSaleable

public java.lang.String getSaleable()

setSaleable

public void setSaleable(java.lang.String saleable)

getTraceable

public java.lang.String getTraceable()

setTraceable

public void setTraceable(java.lang.String traceable)

getNewPart

public java.lang.String getNewPart()

setNewPart

public void setNewPart(java.lang.String newPart)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getRevisionDate

public java.util.Date getRevisionDate()

setRevisionDate

public void setRevisionDate(java.util.Date revisionDate)

getHold

public java.lang.String getHold()

setHold

public void setHold(java.lang.String hold)

getShippingWeight

public float getShippingWeight()

setShippingWeight

public void setShippingWeight(float shippingWeight)

getShippingWeightUnit

public java.lang.String getShippingWeightUnit()

setShippingWeightUnit

public void setShippingWeightUnit(java.lang.String shippingWeightUnit)

getPartUnit

public java.lang.String getPartUnit()

setPartUnit

public void setPartUnit(java.lang.String partUnit)

getComment

public java.lang.String getComment()

setComment

public void setComment(java.lang.String comment)

getDrawingNumber

public java.lang.String getDrawingNumber()

setDrawingNumber

public void setDrawingNumber(java.lang.String drawingNumber)

getDrawing

public java.lang.String getDrawing()

setDrawing

public void setDrawing(java.lang.String drawing)

getBill

public java.lang.String getBill()

setBill

public void setBill(java.lang.String bill)

getWi

public java.lang.String getWi()

setWi

public void setWi(java.lang.String wi)

getHavePicture

public java.lang.String getHavePicture()

setHavePicture

public void setHavePicture(java.lang.String havePicture)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getMultiLanguage

public java.util.Set getMultiLanguage()

setMultiLanguage

public void setMultiLanguage(java.util.Set multiLanguage)

getTraceableLevel

public java.lang.Byte getTraceableLevel()

setTraceableLevel

public void setTraceableLevel(java.lang.Byte traceableLevel)

getVendors

public java.util.Set getVendors()

setVendors

public void setVendors(java.util.Set vendors)

getManufacturers

public java.util.Set getManufacturers()

getVersion

public java.lang.Integer getVersion()

getMaterial

public java.lang.String getMaterial()

getLevels

public java.lang.String getLevels()

getIsActivePart

public java.lang.String getIsActivePart()

setManufacturers

public void setManufacturers(java.util.Set manufacturers)

setVersion

public void setVersion(java.lang.Integer version)

setMaterial

public void setMaterial(java.lang.String material)

setLevels

public void setLevels(java.lang.String levels)

setIsActivePart

public void setIsActivePart(java.lang.String isActivePart)

setPartInventory

public void setPartInventory(PartInventoryVO partInventory)

getPartInventory

public PartInventoryVO getPartInventory()

getVolume

public java.math.BigDecimal getVolume()

setVolume

public void setVolume(java.math.BigDecimal volume)

getVolumeUnit

public java.lang.String getVolumeUnit()

setVolumeUnit

public void setVolumeUnit(java.lang.String volumeUnit)

getShippingDepth

public java.math.BigDecimal getShippingDepth()

setShippingDepth

public void setShippingDepth(java.math.BigDecimal shippingDepth)

getShippingLength

public java.math.BigDecimal getShippingLength()

setShippingLength

public void setShippingLength(java.math.BigDecimal shippingLength)

getShippingWidth

public java.math.BigDecimal getShippingWidth()

setShippingWidth

public void setShippingWidth(java.math.BigDecimal shippingWidth)

getSalesDrawing

public java.lang.String getSalesDrawing()

setSalesDrawing

public void setSalesDrawing(java.lang.String salesDrawing)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getCatalog

public java.lang.String getCatalog()

setCatalog

public void setCatalog(java.lang.String catalog)

getProductCode

public java.lang.String getProductCode()

setProductCode

public void setProductCode(java.lang.String productCode)

isDeleted

public boolean isDeleted()

setDeleted

public void setDeleted(boolean deleted)

getDrawingRev

public java.lang.String getDrawingRev()

setDrawingRev

public void setDrawingRev(java.lang.String drawingRev)

getSecurityLevel

public java.lang.String getSecurityLevel()

setSecurityLevel

public void setSecurityLevel(java.lang.String securityLevel)

getEngGroup

public java.lang.String getEngGroup()

setEngGroup

public void setEngGroup(java.lang.String engGroup)

getPartPoUnit

public java.lang.String getPartPoUnit()

setPartPoUnit

public void setPartPoUnit(java.lang.String partPoUnit)

getPartPoUnitRate

public java.math.BigDecimal getPartPoUnitRate()

setPartPoUnitRate

public void setPartPoUnitRate(java.math.BigDecimal partPoUnitRate)

getDetectionStandard

public java.lang.String getDetectionStandard()

setDetectionStandard

public void setDetectionStandard(java.lang.String detectionStandard)

getCountryOrigin

public java.lang.String getCountryOrigin()

setCountryOrigin

public void setCountryOrigin(java.lang.String countryOrigin)

getInspectionType

public java.lang.String getInspectionType()

setInspectionType

public void setInspectionType(java.lang.String inspectionType)

getUnits

public java.util.Set<PartUnitVO> getUnits()

setUnits

public void setUnits(java.util.Set<PartUnitVO> units)

getIrType

public java.lang.String getIrType()

setIrType

public void setIrType(java.lang.String irType)

isRecoil

public boolean isRecoil()

setRecoil

public void setRecoil(boolean recoil)

isUseBackflush

public boolean isUseBackflush()

setUseBackflush

public void setUseBackflush(boolean useBackflush)

isDiscountable

public boolean isDiscountable()

setDiscountable

public void setDiscountable(boolean discountable)

isTaxExempt

public boolean isTaxExempt()

setTaxExempt

public void setTaxExempt(boolean taxExempt)

getMultiQtyforApplying

public java.math.BigDecimal getMultiQtyforApplying()

setMultiQtyforApplying

public void setMultiQtyforApplying(java.math.BigDecimal multiQtyforApplying)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartWhereUsedItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartWhereUsedItemResult

java.lang.Object
    extended by  bb.common.PartWhereUsedItemResult
All Implemented Interfaces:
java.io.Serializable
public class PartWhereUsedItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartWhereUsedItemResult()
Method Summary
java.lang.String | getBill()
java.lang.String | getDescription()
java.lang.String | getDrawing()
java.lang.String | getHold()
java.math.BigDecimal | getOnDemand()
java.math.BigDecimal | getOnhand()
java.math.BigDecimal | getOnOrder()
java.math.BigDecimal | getPartQuantity()
BillItemPK | getPk()
java.lang.String | getTraceable()
java.lang.Byte | getTraceableLevel()
java.lang.String | getWi()
void | setBill(java.lang.String bill)
void | setDescription(java.lang.String description)
void | setDrawing(java.lang.String drawing)
void | setHold(java.lang.String hold)
void | setOnDemand(java.math.BigDecimal onDemand)
void | setOnhand(java.math.BigDecimal onhand)
void | setOnOrder(java.math.BigDecimal onOrder)
void | setPartQuantity(java.math.BigDecimal partQuantity)
void | setPk(BillItemPK pk)
void | setTraceable(java.lang.String traceable)
void | setTraceableLevel(java.lang.Byte traceableLevel)
void | setWi(java.lang.String wi)
java.lang.String | toString()
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PartWhereUsedItemResult

public PartWhereUsedItemResult()
Method Detail

getPk

public BillItemPK getPk()

setPk

public void setPk(BillItemPK pk)

getPartQuantity

public java.math.BigDecimal getPartQuantity()

setPartQuantity

public void setPartQuantity(java.math.BigDecimal partQuantity)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getHold

public java.lang.String getHold()

setHold

public void setHold(java.lang.String hold)

getDrawing

public java.lang.String getDrawing()

setDrawing

public void setDrawing(java.lang.String drawing)

getBill

public java.lang.String getBill()

setBill

public void setBill(java.lang.String bill)

getWi

public java.lang.String getWi()

setWi

public void setWi(java.lang.String wi)

getTraceableLevel

public java.lang.Byte getTraceableLevel()

setTraceableLevel

public void setTraceableLevel(java.lang.Byte traceableLevel)

getTraceable

public java.lang.String getTraceable()

setTraceable

public void setTraceable(java.lang.String traceable)

getOnhand

public java.math.BigDecimal getOnhand()

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getOnOrder

public java.math.BigDecimal getOnOrder()

setOnOrder

public void setOnOrder(java.math.BigDecimal onOrder)

getOnDemand

public java.math.BigDecimal getOnDemand()

setOnDemand

public void setOnDemand(java.math.BigDecimal onDemand)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartWhereUsedResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartWhereUsedResult

java.lang.Object
    extended by  bb.common.PartWhereUsedResult
All Implemented Interfaces:
java.io.Serializable
public class PartWhereUsedResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartWhereUsedResult()
Method Summary
PartBasicInfo | getPartBasicInfo()
java.util.List | getPartWhereUsedItemResult()
void | setPartBasicInfo(PartBasicInfo partBasicInfo)
void | setPartWhereUsedItemResult(java.util.List partWhereUsedItemResult)
java.lang.String | toString()
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PartWhereUsedResult

public PartWhereUsedResult()
Method Detail

getPartBasicInfo

public PartBasicInfo getPartBasicInfo()

setPartBasicInfo

public void setPartBasicInfo(PartBasicInfo partBasicInfo)

getPartWhereUsedItemResult

public java.util.List getPartWhereUsedItemResult()

setPartWhereUsedItemResult

public void setPartWhereUsedItemResult(java.util.List partWhereUsedItemResult)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartWithExcessiveInventoryListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartWithExcessiveInventoryListResult

java.lang.Object
    extended by  bb.common.PartWithExcessiveInventoryListResult
All Implemented Interfaces:
java.io.Serializable
public class PartWithExcessiveInventoryListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AVGCOST
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_EXCESSIVEQTY
static java.lang.String | ORDER_BY_EXCESSIVETOTALAVGCOST
static java.lang.String | ORDER_BY_EXCESSIVETOTALSTDCOST
static java.lang.String | ORDER_BY_MAXQTY
static java.lang.String | ORDER_BY_MINQTY
static java.lang.String | ORDER_BY_ONDEMAND
static java.lang.String | ORDER_BY_ONHAND
static java.lang.String | ORDER_BY_ONORDER
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_QRQTY
static java.lang.String | ORDER_BY_STDCOST
static java.lang.String | ORDER_BY_YRQTY
Constructor Summary
PartWithExcessiveInventoryListResult()
Method Summary
java.math.BigDecimal | getAvgCost()
java.lang.String | getDescription()
java.math.BigDecimal | getExcessiveQty()
java.math.BigDecimal | getExcessiveTotalAvgCost()
java.math.BigDecimal | getExcessiveTotalStdCost()
java.math.BigDecimal | getMaxQty()
java.math.BigDecimal | getMinQty()
java.math.BigDecimal | getOnDemand()
java.math.BigDecimal | getOnHand()
java.math.BigDecimal | getOnOrder()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.math.BigDecimal | getQrQty()
java.math.BigDecimal | getStdCost()
java.math.BigDecimal | getYrQty()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setDescription(java.lang.String description)
void | setExcessiveQty(java.math.BigDecimal excessiveQty)
void | setExcessiveTotalAvgCost(java.math.BigDecimal excessiveTotalAvgCost)
void | setExcessiveTotalStdCost(java.math.BigDecimal excessiveTotalStdCost)
void | setMaxQty(java.math.BigDecimal maxQty)
void | setMinQty(java.math.BigDecimal minQty)
void | setOnDemand(java.math.BigDecimal onDemand)
void | setOnHand(java.math.BigDecimal onHand)
void | setOnOrder(java.math.BigDecimal onOrder)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setQrQty(java.math.BigDecimal qrQty)
void | setStdCost(java.math.BigDecimal stdCost)
void | setYrQty(java.math.BigDecimal yrQty)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_ONHAND

public static final java.lang.String ORDER_BY_ONHAND
See Also:
Constant Field Values

ORDER_BY_ONORDER

public static final java.lang.String ORDER_BY_ONORDER
See Also:
Constant Field Values

ORDER_BY_ONDEMAND

public static final java.lang.String ORDER_BY_ONDEMAND
See Also:
Constant Field Values

ORDER_BY_MINQTY

public static final java.lang.String ORDER_BY_MINQTY
See Also:
Constant Field Values

ORDER_BY_MAXQTY

public static final java.lang.String ORDER_BY_MAXQTY
See Also:
Constant Field Values

ORDER_BY_YRQTY

public static final java.lang.String ORDER_BY_YRQTY
See Also:
Constant Field Values

ORDER_BY_QRQTY

public static final java.lang.String ORDER_BY_QRQTY
See Also:
Constant Field Values

ORDER_BY_AVGCOST

public static final java.lang.String ORDER_BY_AVGCOST
See Also:
Constant Field Values

ORDER_BY_STDCOST

public static final java.lang.String ORDER_BY_STDCOST
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_EXCESSIVETOTALAVGCOST

public static final java.lang.String ORDER_BY_EXCESSIVETOTALAVGCOST
See Also:
Constant Field Values

ORDER_BY_EXCESSIVETOTALSTDCOST

public static final java.lang.String ORDER_BY_EXCESSIVETOTALSTDCOST
See Also:
Constant Field Values

ORDER_BY_EXCESSIVEQTY

public static final java.lang.String ORDER_BY_EXCESSIVEQTY
See Also:
Constant Field Values
Constructor Detail

PartWithExcessiveInventoryListResult

public PartWithExcessiveInventoryListResult()
Method Detail

getPartFrom

public java.lang.String getPartFrom()

getDescription

public java.lang.String getDescription()

getExcessiveQty

public java.math.BigDecimal getExcessiveQty()

getMinQty

public java.math.BigDecimal getMinQty()

getYrQty

public java.math.BigDecimal getYrQty()

getQrQty

public java.math.BigDecimal getQrQty()

getAvgCost

public java.math.BigDecimal getAvgCost()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setDescription

public void setDescription(java.lang.String description)

getOnDemand

public java.math.BigDecimal getOnDemand()

setOnDemand

public void setOnDemand(java.math.BigDecimal onDemand)

getOnHand

public java.math.BigDecimal getOnHand()

setOnHand

public void setOnHand(java.math.BigDecimal onHand)

getOnOrder

public java.math.BigDecimal getOnOrder()

setOnOrder

public void setOnOrder(java.math.BigDecimal onOrder)

setExcessiveQty

public void setExcessiveQty(java.math.BigDecimal excessiveQty)

setMinQty

public void setMinQty(java.math.BigDecimal minQty)

setYrQty

public void setYrQty(java.math.BigDecimal yrQty)

setQrQty

public void setQrQty(java.math.BigDecimal qrQty)

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

getExcessiveTotalAvgCost

public java.math.BigDecimal getExcessiveTotalAvgCost()

setExcessiveTotalAvgCost

public void setExcessiveTotalAvgCost(java.math.BigDecimal excessiveTotalAvgCost)

getExcessiveTotalStdCost

public java.math.BigDecimal getExcessiveTotalStdCost()

setExcessiveTotalStdCost

public void setExcessiveTotalStdCost(java.math.BigDecimal excessiveTotalStdCost)

getPartPk

public PartPK getPartPk()

setPartPk

public void setPartPk(PartPK partPk)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getMaxQty

public java.math.BigDecimal getMaxQty()

setMaxQty

public void setMaxQty(java.math.BigDecimal maxQty)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartWithInventoryInfoListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartWithInventoryInfoListResult

java.lang.Object
    extended by  bb.common.PartWithInventoryInfoListResult
All Implemented Interfaces:
java.io.Serializable
public class PartWithInventoryInfoListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_BUYERCODE
static java.lang.String | ORDER_BY_INWIP
static java.lang.String | ORDER_BY_ONDEMAND
static java.lang.String | ORDER_BY_ONHAND
static java.lang.String | ORDER_BY_ONORDER
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_UNIT
Constructor Summary
PartWithInventoryInfoListResult()
Method Summary
java.lang.String | getBill()
java.lang.String | getBuyerCode()
java.lang.String | getDescription()
java.lang.String | getDwg()
java.lang.String | getHold()
java.math.BigDecimal | getInwip()
java.math.BigDecimal | getOndemand()
java.math.BigDecimal | getOnhand()
java.math.BigDecimal | getOnorder()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getRev()
java.lang.String | getUnit()
java.lang.String | getWi()
void | setBill(java.lang.String bill)
void | setBuyerCode(java.lang.String buyerCode)
void | setDescription(java.lang.String description)
void | setDwg(java.lang.String dwg)
void | setHold(java.lang.String hold)
void | setInwip(java.math.BigDecimal inwip)
void | setOndemand(java.math.BigDecimal ondemand)
void | setOnhand(java.math.BigDecimal onhand)
void | setOnorder(java.math.BigDecimal onorder)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setRev(java.lang.String rev)
void | setUnit(java.lang.String unit)
void | setWi(java.lang.String wi)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_ONHAND

public static final java.lang.String ORDER_BY_ONHAND
See Also:
Constant Field Values

ORDER_BY_ONDEMAND

public static final java.lang.String ORDER_BY_ONDEMAND
See Also:
Constant Field Values

ORDER_BY_ONORDER

public static final java.lang.String ORDER_BY_ONORDER
See Also:
Constant Field Values

ORDER_BY_INWIP

public static final java.lang.String ORDER_BY_INWIP
See Also:
Constant Field Values

ORDER_BY_BUYERCODE

public static final java.lang.String ORDER_BY_BUYERCODE
See Also:
Constant Field Values

ORDER_BY_UNIT

public static final java.lang.String ORDER_BY_UNIT
See Also:
Constant Field Values
Constructor Detail

PartWithInventoryInfoListResult

public PartWithInventoryInfoListResult()
Method Detail

getInwip

public java.math.BigDecimal getInwip()

getOnorder

public java.math.BigDecimal getOnorder()

getOndemand

public java.math.BigDecimal getOndemand()

getOnhand

public java.math.BigDecimal getOnhand()

getDescription

public java.lang.String getDescription()

getUnit

public java.lang.String getUnit()

getWi

public java.lang.String getWi()

getBill

public java.lang.String getBill()

getDwg

public java.lang.String getDwg()

getHold

public java.lang.String getHold()

getRev

public java.lang.String getRev()

getPartFrom

public java.lang.String getPartFrom()

getPartType

public java.lang.String getPartType()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

setInwip

public void setInwip(java.math.BigDecimal inwip)

setOnorder

public void setOnorder(java.math.BigDecimal onorder)

setOndemand

public void setOndemand(java.math.BigDecimal ondemand)

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

setDescription

public void setDescription(java.lang.String description)

setUnit

public void setUnit(java.lang.String unit)

setWi

public void setWi(java.lang.String wi)

setBill

public void setBill(java.lang.String bill)

setDwg

public void setDwg(java.lang.String dwg)

setHold

public void setHold(java.lang.String hold)

setRev

public void setRev(java.lang.String rev)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setPartType

public void setPartType(java.lang.String partType)

setBuyerCode

public void setBuyerCode(java.lang.String buyerCode)

getPartNumber

public java.lang.String getPartNumber()

getBuyerCode

public java.lang.String getBuyerCode()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartWithManufacturerInfoResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartWithManufacturerInfoResult

java.lang.Object
    extended by  bb.common.PartWithManufacturerInfoResult
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
ToolWithManufacturerInfoResult
public class PartWithManufacturerInfoResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_BILL
static java.lang.String | ORDER_BY_MANUFACTURERID
static java.lang.String | ORDER_BY_MANUFACTURERNAME
static java.lang.String | ORDER_BY_MANUFACTURERPARTNUMBER
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTTYPE
Constructor Summary
PartWithManufacturerInfoResult()
Method Summary
java.lang.String | getBill()
java.lang.String | getDescription()
java.lang.String | getDrawing()
java.lang.String | getHold()
java.lang.String | getManufacturerId()
java.lang.Short | getManufacturerItem()
java.lang.String | getManufacturerName()
java.lang.String | getManufacturerPartNumber()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getTraceable()
void | setBill(java.lang.String bill)
void | setDescription(java.lang.String description)
void | setDrawing(java.lang.String drawing)
void | setHold(java.lang.String hold)
void | setManufacturerId(java.lang.String mfgId)
void | setManufacturerItem(java.lang.Short itemNumber)
void | setManufacturerName(java.lang.String mfgName)
void | setManufacturerPartNumber(java.lang.String mpn)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setTraceable(java.lang.String traceable)
java.lang.String | toString()
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_MANUFACTURERID

public static final java.lang.String ORDER_BY_MANUFACTURERID
See Also:
Constant Field Values

ORDER_BY_MANUFACTURERPARTNUMBER

public static final java.lang.String ORDER_BY_MANUFACTURERPARTNUMBER
See Also:
Constant Field Values

ORDER_BY_MANUFACTURERNAME

public static final java.lang.String ORDER_BY_MANUFACTURERNAME
See Also:
Constant Field Values

ORDER_BY_BILL

public static final java.lang.String ORDER_BY_BILL
See Also:
Constant Field Values
Constructor Detail

PartWithManufacturerInfoResult

public PartWithManufacturerInfoResult()
Method Detail

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getManufacturerItem

public java.lang.Short getManufacturerItem()

setManufacturerItem

public void setManufacturerItem(java.lang.Short itemNumber)

getTraceable

public java.lang.String getTraceable()

setTraceable

public void setTraceable(java.lang.String traceable)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getHold

public java.lang.String getHold()

setHold

public void setHold(java.lang.String hold)

getDrawing

public java.lang.String getDrawing()

setDrawing

public void setDrawing(java.lang.String drawing)

getBill

public java.lang.String getBill()

setBill

public void setBill(java.lang.String bill)

getManufacturerId

public java.lang.String getManufacturerId()

setManufacturerId

public void setManufacturerId(java.lang.String mfgId)

getManufacturerName

public java.lang.String getManufacturerName()

setManufacturerName

public void setManufacturerName(java.lang.String mfgName)

getManufacturerPartNumber

public java.lang.String getManufacturerPartNumber()

setManufacturerPartNumber

public void setManufacturerPartNumber(java.lang.String mpn)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartWithOnhandDetailInfoResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartWithOnhandDetailInfoResult

java.lang.Object
    extended by  bb.common.PartBasicInfo
        extended by  bb.common.PartWithOnhandDetailInfoResult
All Implemented Interfaces:
java.io.Serializable
public class PartWithOnhandDetailInfoResult
extends PartBasicInfo
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
Fields inherited from class bb.common.PartBasicInfo
ORDER_BY_BILL, ORDER_BY_BUYERCODE, ORDER_BY_COMMODITYCODE, ORDER_BY_DESCRIPTION, ORDER_BY_DRAWING, ORDER_BY_HOLD, ORDER_BY_LASTCHANGEDATE, ORDER_BY_LASTUSER, ORDER_BY_MAKEBUY, ORDER_BY_MODELNUMBER, ORDER_BY_ORGANIZATION, ORDER_BY_ORIGIN, ORDER_BY_PARTNUMBER, ORDER_BY_PARTTYPE, ORDER_BY_PARTUNIT, ORDER_BY_PRODUCTCODE, ORDER_BY_SECURITYLEVEL, ORDER_BY_WEIGHT
Constructor Summary
PartWithOnhandDetailInfoResult()
Method Summary
java.util.List | getDetails()
java.math.BigDecimal | getMaxQty()
java.math.BigDecimal | getMinQty()
java.math.BigDecimal | getQuarterUsage()
java.math.BigDecimal | getTotalOnhand()
java.lang.Byte | getTraceableLevel()
float | getWeight()
java.lang.String | getWeightUnit()
java.math.BigDecimal | getYearUsage()
void | setDetails(java.util.List details)
void | setMaxQty(java.math.BigDecimal maxQty)
void | setMinQty(java.math.BigDecimal minQty)
void | setQuarterUsage(java.math.BigDecimal quarterUsage)
void | setTotalOnhand(java.math.BigDecimal totalOnhand)
void | setTraceableLevel(java.lang.Byte traceableLevel)
void | setWeight(float weight)
void | setWeightUnit(java.lang.String weightUnit)
void | setYearUsage(java.math.BigDecimal yearUsage)
Methods inherited from class bb.common.PartBasicInfo
equals, getBill, getBuyerCode, getCommodityCode, getCountryOrigin, getDescription, getDetectionStandard, getDrawing, getEngGroup, getHavePicture, getHold, getLastChangeDate, getLastUser, getLeadTime, getMakeBuy, getMaterial, getModelNumber, getOrigin, getPartPk, getPartUnit, getProductCode, getRevision, getSaleable, getSalesDrawing, getSecurityLevel, getTraceable, getVolume, getVolumeUnit, getWi, hashCode, setBill, setBuyerCode, setCommodityCode, setCountryOrigin, setDescription, setDetectionStandard, setDrawing, setEngGroup, setHavePicture, setHold, setLastChangeDate, setLastUser, setLeadTime, setMakeBuy, setMaterial, setModelNumber, setOrigin, setPartPk, setPartUnit, setProductCode, setRevision, setSaleable, setSalesDrawing, setSecurityLevel, setTraceable, setVolume, setVolumeUnit, setWi, toString
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartWithOnhandDetailInfoResult

public PartWithOnhandDetailInfoResult()
Method Detail

getMinQty

public java.math.BigDecimal getMinQty()

setMinQty

public void setMinQty(java.math.BigDecimal minQty)

getMaxQty

public java.math.BigDecimal getMaxQty()

setMaxQty

public void setMaxQty(java.math.BigDecimal maxQty)

getTraceableLevel

public java.lang.Byte getTraceableLevel()

setTraceableLevel

public void setTraceableLevel(java.lang.Byte traceableLevel)

getYearUsage

public java.math.BigDecimal getYearUsage()

setYearUsage

public void setYearUsage(java.math.BigDecimal yearUsage)

getQuarterUsage

public java.math.BigDecimal getQuarterUsage()

setQuarterUsage

public void setQuarterUsage(java.math.BigDecimal quarterUsage)

getWeight

public float getWeight()
Overrides:
getWeight in class PartBasicInfo

setWeight

public void setWeight(float weight)
Overrides:
setWeight in class PartBasicInfo

getWeightUnit

public java.lang.String getWeightUnit()
Overrides:
getWeightUnit in class PartBasicInfo

setWeightUnit

public void setWeightUnit(java.lang.String weightUnit)
Overrides:
setWeightUnit in class PartBasicInfo

getTotalOnhand

public java.math.BigDecimal getTotalOnhand()

setTotalOnhand

public void setTotalOnhand(java.math.BigDecimal totalOnhand)

getDetails

public java.util.List getDetails()

setDetails

public void setDetails(java.util.List details)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartWithOnhandsVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartWithOnhandsVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PartWithOnhandsVO
All Implemented Interfaces:
java.io.Serializable
public class PartWithOnhandsVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PartWithOnhandsVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getBill()
java.lang.String | getBuyerCode()
java.lang.String | getCatalog()
java.lang.String | getComment()
java.lang.String | getCommodityCode()
java.util.Date | getCreatedDate()
java.lang.String | getDescription()
java.lang.String | getDrawing()
java.lang.String | getDrawingNumber()
java.lang.String | getDrawingRev()
java.lang.String | getEngGroup()
java.lang.String | getHavePicture()
java.lang.String | getHold()
java.lang.String | getIsActivePart()
java.util.Date | getLastChangeDate()
java.lang.String | getLastUser()
java.lang.String | getLevels()
java.lang.String | getMakeBuy()
java.lang.String | getMaterial()
java.lang.String | getModelNumber()
java.util.Set | getMultiLanguage()
java.lang.String | getNewPart()
java.util.Set<PartOnhandVO> | getOnHandLocations()
java.lang.String | getOrigin()
java.lang.String | getOwner()
PartInventoryVO | getPartInventory()
java.lang.String | getPartPoUnit()
java.math.BigDecimal | getPartPoUnitRate()
java.lang.String | getPartUnit()
PartPK | getPk()
java.lang.String | getProductCode()
java.lang.String | getRevision()
java.util.Date | getRevisionDate()
java.lang.String | getSaleable()
java.lang.String | getSalesDrawing()
java.lang.String | getSecurityLevel()
java.math.BigDecimal | getShippingDepth()
java.math.BigDecimal | getShippingLength()
float | getShippingWeight()
java.lang.String | getShippingWeightUnit()
java.math.BigDecimal | getShippingWidth()
java.lang.String | getTraceable()
java.lang.Byte | getTraceableLevel()
java.lang.Integer | getVersion()
java.math.BigDecimal | getVolume()
java.lang.String | getVolumeUnit()
java.lang.String | getWi()
int | hashCode()
boolean | isDeleted()
boolean | isRecoil()
boolean | isUseBackflush()
void | setBill(java.lang.String bill)
void | setBuyerCode(java.lang.String buyerCode)
void | setCatalog(java.lang.String catalog)
void | setComment(java.lang.String comment)
void | setCommodityCode(java.lang.String commodityCode)
void | setCreatedDate(java.util.Date createdDate)
void | setDeleted(boolean deleted)
void | setDescription(java.lang.String description)
void | setDrawing(java.lang.String drawing)
void | setDrawingNumber(java.lang.String drawingNumber)
void | setDrawingRev(java.lang.String drawingRev)
void | setEngGroup(java.lang.String engGroup)
void | setHavePicture(java.lang.String havePicture)
void | setHold(java.lang.String hold)
void | setIsActivePart(java.lang.String isActivePart)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastUser(java.lang.String lastUser)
void | setLevels(java.lang.String levels)
void | setMakeBuy(java.lang.String makeBuy)
void | setMaterial(java.lang.String material)
void | setModelNumber(java.lang.String modelNumber)
void | setMultiLanguage(java.util.Set multiLanguage)
void | setNewPart(java.lang.String newPart)
void | setOnHandLocations(java.util.Set<PartOnhandVO> onHandLocations)
void | setOrigin(java.lang.String origin)
void | setOwner(java.lang.String owner)
void | setPartInventory(PartInventoryVO partInventory)
void | setPartPoUnit(java.lang.String partPoUnit)
void | setPartPoUnitRate(java.math.BigDecimal partPoUnitRate)
void | setPartUnit(java.lang.String partUnit)
void | setPk(PartPK pk)
void | setProductCode(java.lang.String productCode)
void | setRecoil(boolean recoil)
void | setRevision(java.lang.String revision)
void | setRevisionDate(java.util.Date revisionDate)
void | setSaleable(java.lang.String saleable)
void | setSalesDrawing(java.lang.String salesDrawing)
void | setSecurityLevel(java.lang.String securityLevel)
void | setShippingDepth(java.math.BigDecimal shippingDepth)
void | setShippingLength(java.math.BigDecimal shippingLength)
void | setShippingWeight(float shippingWeight)
void | setShippingWeightUnit(java.lang.String shippingWeightUnit)
void | setShippingWidth(java.math.BigDecimal shippingWidth)
void | setTraceable(java.lang.String traceable)
void | setTraceableLevel(java.lang.Byte traceableLevel)
void | setUseBackflush(boolean useBackflush)
void | setVersion(java.lang.Integer version)
void | setVolume(java.math.BigDecimal volume)
void | setVolumeUnit(java.lang.String volumeUnit)
void | setWi(java.lang.String wi)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PartWithOnhandsVO

public PartWithOnhandsVO()
Method Detail

getPk

public PartPK getPk()

setPk

public void setPk(PartPK pk)

getLastUser

public java.lang.String getLastUser()

setLastUser

public void setLastUser(java.lang.String lastUser)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getCreatedDate

public java.util.Date getCreatedDate()

setCreatedDate

public void setCreatedDate(java.util.Date createdDate)

getOwner

public java.lang.String getOwner()

setOwner

public void setOwner(java.lang.String owner)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getBuyerCode

public java.lang.String getBuyerCode()

setBuyerCode

public void setBuyerCode(java.lang.String buyerCode)

getCommodityCode

public java.lang.String getCommodityCode()

setCommodityCode

public void setCommodityCode(java.lang.String commodityCode)

getMakeBuy

public java.lang.String getMakeBuy()

setMakeBuy

public void setMakeBuy(java.lang.String makeBuy)

getSaleable

public java.lang.String getSaleable()

setSaleable

public void setSaleable(java.lang.String saleable)

getTraceable

public java.lang.String getTraceable()

setTraceable

public void setTraceable(java.lang.String traceable)

getNewPart

public java.lang.String getNewPart()

setNewPart

public void setNewPart(java.lang.String newPart)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getRevisionDate

public java.util.Date getRevisionDate()

setRevisionDate

public void setRevisionDate(java.util.Date revisionDate)

getHold

public java.lang.String getHold()

setHold

public void setHold(java.lang.String hold)

getShippingWeight

public float getShippingWeight()

setShippingWeight

public void setShippingWeight(float shippingWeight)

getShippingWeightUnit

public java.lang.String getShippingWeightUnit()

setShippingWeightUnit

public void setShippingWeightUnit(java.lang.String shippingWeightUnit)

getPartUnit

public java.lang.String getPartUnit()

setPartUnit

public void setPartUnit(java.lang.String partUnit)

getComment

public java.lang.String getComment()

setComment

public void setComment(java.lang.String comment)

getDrawingNumber

public java.lang.String getDrawingNumber()

setDrawingNumber

public void setDrawingNumber(java.lang.String drawingNumber)

getDrawing

public java.lang.String getDrawing()

setDrawing

public void setDrawing(java.lang.String drawing)

getBill

public java.lang.String getBill()

setBill

public void setBill(java.lang.String bill)

getWi

public java.lang.String getWi()

setWi

public void setWi(java.lang.String wi)

getHavePicture

public java.lang.String getHavePicture()

setHavePicture

public void setHavePicture(java.lang.String havePicture)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getMultiLanguage

public java.util.Set getMultiLanguage()

setMultiLanguage

public void setMultiLanguage(java.util.Set multiLanguage)

getTraceableLevel

public java.lang.Byte getTraceableLevel()

setTraceableLevel

public void setTraceableLevel(java.lang.Byte traceableLevel)

getVersion

public java.lang.Integer getVersion()

getMaterial

public java.lang.String getMaterial()

getLevels

public java.lang.String getLevels()

getIsActivePart

public java.lang.String getIsActivePart()

setVersion

public void setVersion(java.lang.Integer version)

setMaterial

public void setMaterial(java.lang.String material)

setLevels

public void setLevels(java.lang.String levels)

setIsActivePart

public void setIsActivePart(java.lang.String isActivePart)

setPartInventory

public void setPartInventory(PartInventoryVO partInventory)

getPartInventory

public PartInventoryVO getPartInventory()

getVolume

public java.math.BigDecimal getVolume()

setVolume

public void setVolume(java.math.BigDecimal volume)

getVolumeUnit

public java.lang.String getVolumeUnit()

setVolumeUnit

public void setVolumeUnit(java.lang.String volumeUnit)

getShippingDepth

public java.math.BigDecimal getShippingDepth()

setShippingDepth

public void setShippingDepth(java.math.BigDecimal shippingDepth)

getShippingLength

public java.math.BigDecimal getShippingLength()

setShippingLength

public void setShippingLength(java.math.BigDecimal shippingLength)

getShippingWidth

public java.math.BigDecimal getShippingWidth()

setShippingWidth

public void setShippingWidth(java.math.BigDecimal shippingWidth)

getSalesDrawing

public java.lang.String getSalesDrawing()

setSalesDrawing

public void setSalesDrawing(java.lang.String salesDrawing)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getCatalog

public java.lang.String getCatalog()

setCatalog

public void setCatalog(java.lang.String catalog)

getProductCode

public java.lang.String getProductCode()

setProductCode

public void setProductCode(java.lang.String productCode)

isDeleted

public boolean isDeleted()

setDeleted

public void setDeleted(boolean deleted)

getDrawingRev

public java.lang.String getDrawingRev()

setDrawingRev

public void setDrawingRev(java.lang.String drawingRev)

getSecurityLevel

public java.lang.String getSecurityLevel()

setSecurityLevel

public void setSecurityLevel(java.lang.String securityLevel)

getEngGroup

public java.lang.String getEngGroup()

setEngGroup

public void setEngGroup(java.lang.String engGroup)

getPartPoUnit

public java.lang.String getPartPoUnit()

setPartPoUnit

public void setPartPoUnit(java.lang.String partPoUnit)

getPartPoUnitRate

public java.math.BigDecimal getPartPoUnitRate()

setPartPoUnitRate

public void setPartPoUnitRate(java.math.BigDecimal partPoUnitRate)

getOnHandLocations

public java.util.Set<PartOnhandVO> getOnHandLocations()

setOnHandLocations

public void setOnHandLocations(java.util.Set<PartOnhandVO> onHandLocations)

isRecoil

public boolean isRecoil()

setRecoil

public void setRecoil(boolean recoil)

isUseBackflush

public boolean isUseBackflush()

setUseBackflush

public void setUseBackflush(boolean useBackflush)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartWithOnLoanQtyListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartWithOnLoanQtyListResult

java.lang.Object
    extended by  bb.common.PartWithOnLoanQtyListResult
All Implemented Interfaces:
java.io.Serializable
public class PartWithOnLoanQtyListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AVGCOST
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_ONLOANQTY
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_STDCOST
static java.lang.String | ORDER_BY_TOTALAVGCOST
static java.lang.String | ORDER_BY_TOTALSTDCOST
Constructor Summary
PartWithOnLoanQtyListResult()
Method Summary
java.math.BigDecimal | getAvgCost()
java.lang.String | getDescription()
java.math.BigDecimal | getOnLoanQty()
PartPK | getPartPk()
java.math.BigDecimal | getStdCost()
java.math.BigDecimal | getTotalAvgCost()
java.math.BigDecimal | getTotalStdCost()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setDescription(java.lang.String description)
void | setOnLoanQty(java.math.BigDecimal onLoanQty)
void | setPartPk(PartPK partPk)
void | setStdCost(java.math.BigDecimal stdCost)
void | setTotalAvgCost(java.math.BigDecimal totalAvgCost)
void | setTotalStdCost(java.math.BigDecimal totalStdCost)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_ONLOANQTY

public static final java.lang.String ORDER_BY_ONLOANQTY
See Also:
Constant Field Values

ORDER_BY_AVGCOST

public static final java.lang.String ORDER_BY_AVGCOST
See Also:
Constant Field Values

ORDER_BY_STDCOST

public static final java.lang.String ORDER_BY_STDCOST
See Also:
Constant Field Values

ORDER_BY_TOTALAVGCOST

public static final java.lang.String ORDER_BY_TOTALAVGCOST
See Also:
Constant Field Values

ORDER_BY_TOTALSTDCOST

public static final java.lang.String ORDER_BY_TOTALSTDCOST
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

PartWithOnLoanQtyListResult

public PartWithOnLoanQtyListResult()
Method Detail

getAvgCost

public java.math.BigDecimal getAvgCost()

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getOnLoanQty

public java.math.BigDecimal getOnLoanQty()

setOnLoanQty

public void setOnLoanQty(java.math.BigDecimal onLoanQty)

getPartPk

public PartPK getPartPk()

setPartPk

public void setPartPk(PartPK partPk)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getTotalAvgCost

public java.math.BigDecimal getTotalAvgCost()

setTotalAvgCost

public void setTotalAvgCost(java.math.BigDecimal totalAvgCost)

getTotalStdCost

public java.math.BigDecimal getTotalStdCost()

setTotalStdCost

public void setTotalStdCost(java.math.BigDecimal totalStdCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartWithoutLocateResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartWithoutLocateResult

java.lang.Object
    extended by  bb.common.PartBasicInfo
        extended by  bb.common.PartWithoutLocateResult
All Implemented Interfaces:
java.io.Serializable
public class PartWithoutLocateResult
extends PartBasicInfo

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_BUYERCODE
static java.lang.String | ORDER_BY_COMMODITYCODE
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_DRAWING
static java.lang.String | ORDER_BY_HOLD
static java.lang.String | ORDER_BY_MODELNUMBER
static java.lang.String | ORDER_BY_ONHAND
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_PARTUNIT
static java.lang.String | ORDER_BY_WEIGHT
Fields inherited from class bb.common.PartBasicInfo
ORDER_BY_BILL, ORDER_BY_LASTCHANGEDATE, ORDER_BY_LASTUSER, ORDER_BY_MAKEBUY, ORDER_BY_ORGANIZATION, ORDER_BY_ORIGIN, ORDER_BY_PARTNUMBER, ORDER_BY_PARTTYPE, ORDER_BY_PRODUCTCODE, ORDER_BY_SECURITYLEVEL
Constructor Summary
PartWithoutLocateResult()
PartWithoutLocateResult(PartPK pk)
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getOnhand()
int | hashCode()
void | setOnhand(java.math.BigDecimal onhand)
java.lang.String | toString()
Methods inherited from class bb.common.PartBasicInfo
getBill, getBuyerCode, getCommodityCode, getCountryOrigin, getDescription, getDetectionStandard, getDrawing, getEngGroup, getHavePicture, getHold, getLastChangeDate, getLastUser, getLeadTime, getMakeBuy, getMaterial, getModelNumber, getOrigin, getPartPk, getPartUnit, getProductCode, getRevision, getSaleable, getSalesDrawing, getSecurityLevel, getTraceable, getVolume, getVolumeUnit, getWeight, getWeightUnit, getWi, setBill, setBuyerCode, setCommodityCode, setCountryOrigin, setDescription, setDetectionStandard, setDrawing, setEngGroup, setHavePicture, setHold, setLastChangeDate, setLastUser, setLeadTime, setMakeBuy, setMaterial, setModelNumber, setOrigin, setPartPk, setPartUnit, setProductCode, setRevision, setSaleable, setSalesDrawing, setSecurityLevel, setTraceable, setVolume, setVolumeUnit, setWeight, setWeightUnit, setWi
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ONHAND

public static final java.lang.String ORDER_BY_ONHAND
See Also:
Constant Field Values

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_WEIGHT

public static final java.lang.String ORDER_BY_WEIGHT
See Also:
Constant Field Values

ORDER_BY_BUYERCODE

public static final java.lang.String ORDER_BY_BUYERCODE
See Also:
Constant Field Values

ORDER_BY_HOLD

public static final java.lang.String ORDER_BY_HOLD
See Also:
Constant Field Values

ORDER_BY_DRAWING

public static final java.lang.String ORDER_BY_DRAWING
See Also:
Constant Field Values

ORDER_BY_MODELNUMBER

public static final java.lang.String ORDER_BY_MODELNUMBER
See Also:
Constant Field Values

ORDER_BY_COMMODITYCODE

public static final java.lang.String ORDER_BY_COMMODITYCODE
See Also:
Constant Field Values

ORDER_BY_PARTUNIT

public static final java.lang.String ORDER_BY_PARTUNIT
See Also:
Constant Field Values
Constructor Detail

PartWithoutLocateResult

public PartWithoutLocateResult()

PartWithoutLocateResult

public PartWithoutLocateResult(PartPK pk)
Method Detail

getOnhand

public java.math.BigDecimal getOnhand()

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class PartBasicInfo

hashCode

public int hashCode()
Overrides:
hashCode in class PartBasicInfo

toString

public java.lang.String toString()
Overrides:
toString in class PartBasicInfo
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartWithQAQtyListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartWithQAQtyListResult

java.lang.Object
    extended by  bb.common.PartWithQAQtyListResult
All Implemented Interfaces:
java.io.Serializable
public class PartWithQAQtyListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AVGCOST
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_INQAQTY
static java.lang.String | ORDER_BY_LISTPRICE
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_STDCOST
Constructor Summary
PartWithQAQtyListResult()
Method Summary
java.math.BigDecimal | getAvgCost()
java.lang.String | getDescription()
java.math.BigDecimal | getInQAQty()
java.math.BigDecimal | getListPrice()
java.math.BigDecimal | getOnHand()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.util.Set<RefdocVO> | getRefDocDetails()
java.math.BigDecimal | getStdCost()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setDescription(java.lang.String description)
void | setInQAQty(java.math.BigDecimal inQAQty)
void | setListPrice(java.math.BigDecimal listPrice)
void | setOnHand(java.math.BigDecimal onHand)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setRefDocDetails(java.util.Set<RefdocVO> refDocDetails)
void | setStdCost(java.math.BigDecimal stdCost)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_INQAQTY

public static final java.lang.String ORDER_BY_INQAQTY
See Also:
Constant Field Values

ORDER_BY_AVGCOST

public static final java.lang.String ORDER_BY_AVGCOST
See Also:
Constant Field Values

ORDER_BY_STDCOST

public static final java.lang.String ORDER_BY_STDCOST
See Also:
Constant Field Values

ORDER_BY_LISTPRICE

public static final java.lang.String ORDER_BY_LISTPRICE
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

PartWithQAQtyListResult

public PartWithQAQtyListResult()
Method Detail

setDescription

public void setDescription(java.lang.String description)

setInQAQty

public void setInQAQty(java.math.BigDecimal inQAQty)

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getDescription

public java.lang.String getDescription()

getInQAQty

public java.math.BigDecimal getInQAQty()

getAvgCost

public java.math.BigDecimal getAvgCost()

getPartFrom

public java.lang.String getPartFrom()

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

getOnHand

public java.math.BigDecimal getOnHand()

setOnHand

public void setOnHand(java.math.BigDecimal onHand)

getPartPk

public PartPK getPartPk()

setPartPk

public void setPartPk(PartPK partPk)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

setRefDocDetails

public void setRefDocDetails(java.util.Set<RefdocVO> refDocDetails)

getRefDocDetails

public java.util.Set<RefdocVO> getRefDocDetails()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartWithQtyListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartWithQtyListResult

java.lang.Object
    extended by  bb.common.PartWithQtyListResult
All Implemented Interfaces:
java.io.Serializable
public class PartWithQtyListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AVGCOST
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_LISTPRICE
static java.lang.String | ORDER_BY_ONHAND
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_STDCOST
Constructor Summary
PartWithQtyListResult()
Method Summary
java.math.BigDecimal | getAvgCost()
java.lang.String | getDescription()
java.math.BigDecimal | getListPrice()
java.math.BigDecimal | getOnHand()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.math.BigDecimal | getQty()
java.util.Set<RefdocVO> | getRefDocDetails()
java.math.BigDecimal | getStdCost()
java.math.BigDecimal | getTotalAvgCost()
java.math.BigDecimal | getTotalStdCost()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setDescription(java.lang.String description)
void | setListPrice(java.math.BigDecimal listPrice)
void | setOnHand(java.math.BigDecimal onHand)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setQty(java.math.BigDecimal qty)
void | setRefDocDetails(java.util.Set<RefdocVO> refDocDetails)
void | setStdCost(java.math.BigDecimal stdCost)
void | setTotalAvgCost(java.math.BigDecimal totalAvgCost)
void | setTotalStdCost(java.math.BigDecimal totalStdCost)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_ONHAND

public static final java.lang.String ORDER_BY_ONHAND
See Also:
Constant Field Values

ORDER_BY_AVGCOST

public static final java.lang.String ORDER_BY_AVGCOST
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_STDCOST

public static final java.lang.String ORDER_BY_STDCOST
See Also:
Constant Field Values

ORDER_BY_LISTPRICE

public static final java.lang.String ORDER_BY_LISTPRICE
See Also:
Constant Field Values
Constructor Detail

PartWithQtyListResult

public PartWithQtyListResult()
Method Detail

setDescription

public void setDescription(java.lang.String description)

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getDescription

public java.lang.String getDescription()

getAvgCost

public java.math.BigDecimal getAvgCost()

getPartFrom

public java.lang.String getPartFrom()

getOnHand

public java.math.BigDecimal getOnHand()

setOnHand

public void setOnHand(java.math.BigDecimal onHand)

getPartPk

public PartPK getPartPk()

setPartPk

public void setPartPk(PartPK partPk)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

getRefDocDetails

public java.util.Set<RefdocVO> getRefDocDetails()

setRefDocDetails

public void setRefDocDetails(java.util.Set<RefdocVO> refDocDetails)

getTotalAvgCost

public java.math.BigDecimal getTotalAvgCost()

setTotalAvgCost

public void setTotalAvgCost(java.math.BigDecimal totalAvgCost)

getTotalStdCost

public java.math.BigDecimal getTotalStdCost()

setTotalStdCost

public void setTotalStdCost(java.math.BigDecimal totalStdCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartWithSipQtyListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartWithSipQtyListResult

java.lang.Object
    extended by  bb.common.PartWithSipQtyListResult
All Implemented Interfaces:
java.io.Serializable
public class PartWithSipQtyListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AVGCOST
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_LISTPRICE
static java.lang.String | ORDER_BY_ONHAND
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_SHIPINPROCESSQTY
static java.lang.String | ORDER_BY_STDCOST
Constructor Summary
PartWithSipQtyListResult()
Method Summary
java.math.BigDecimal | getAvgCost()
java.lang.String | getDescription()
java.math.BigDecimal | getInSipQty()
java.math.BigDecimal | getListPrice()
java.math.BigDecimal | getOnHand()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.util.Set<RefdocVO> | getRefDocDetails()
java.math.BigDecimal | getStdCost()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setDescription(java.lang.String description)
void | setInSipQty(java.math.BigDecimal inSipQty)
void | setListPrice(java.math.BigDecimal listPrice)
void | setOnHand(java.math.BigDecimal onHand)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setRefDocDetails(java.util.Set<RefdocVO> refDocDetails)
void | setStdCost(java.math.BigDecimal stdCost)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_ONHAND

public static final java.lang.String ORDER_BY_ONHAND
See Also:
Constant Field Values

ORDER_BY_SHIPINPROCESSQTY

public static final java.lang.String ORDER_BY_SHIPINPROCESSQTY
See Also:
Constant Field Values

ORDER_BY_AVGCOST

public static final java.lang.String ORDER_BY_AVGCOST
See Also:
Constant Field Values

ORDER_BY_STDCOST

public static final java.lang.String ORDER_BY_STDCOST
See Also:
Constant Field Values

ORDER_BY_LISTPRICE

public static final java.lang.String ORDER_BY_LISTPRICE
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

PartWithSipQtyListResult

public PartWithSipQtyListResult()
Method Detail

setDescription

public void setDescription(java.lang.String description)

setInSipQty

public void setInSipQty(java.math.BigDecimal inSipQty)

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setRefDocDetails

public void setRefDocDetails(java.util.Set<RefdocVO> refDocDetails)

getDescription

public java.lang.String getDescription()

getInSipQty

public java.math.BigDecimal getInSipQty()

getAvgCost

public java.math.BigDecimal getAvgCost()

getPartFrom

public java.lang.String getPartFrom()

getRefDocDetails

public java.util.Set<RefdocVO> getRefDocDetails()

getOnHand

public java.math.BigDecimal getOnHand()

setOnHand

public void setOnHand(java.math.BigDecimal onHand)

getPartPk

public PartPK getPartPk()

setPartPk

public void setPartPk(PartPK partPk)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartWithSITQtyListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartWithSITQtyListResult

java.lang.Object
    extended by  bb.common.PartWithSITQtyListResult
All Implemented Interfaces:
java.io.Serializable
public class PartWithSITQtyListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AVGCOST
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_LISTPRICE
static java.lang.String | ORDER_BY_ONHAND
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_SHIPINPROCESSQTY
static java.lang.String | ORDER_BY_STDCOST
Constructor Summary
PartWithSITQtyListResult()
Method Summary
java.math.BigDecimal | getAvgCost()
java.lang.String | getDescription()
java.math.BigDecimal | getInSITQty()
java.math.BigDecimal | getListPrice()
java.math.BigDecimal | getOnHand()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.util.Set<RefdocVO> | getRefDocDetails()
java.math.BigDecimal | getStdCost()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setDescription(java.lang.String description)
void | setInSITQty(java.math.BigDecimal inSITQty)
void | setListPrice(java.math.BigDecimal listPrice)
void | setOnHand(java.math.BigDecimal onHand)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setRefDocDetails(java.util.Set<RefdocVO> refDocDetails)
void | setStdCost(java.math.BigDecimal stdCost)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_ONHAND

public static final java.lang.String ORDER_BY_ONHAND
See Also:
Constant Field Values

ORDER_BY_SHIPINPROCESSQTY

public static final java.lang.String ORDER_BY_SHIPINPROCESSQTY
See Also:
Constant Field Values

ORDER_BY_AVGCOST

public static final java.lang.String ORDER_BY_AVGCOST
See Also:
Constant Field Values

ORDER_BY_STDCOST

public static final java.lang.String ORDER_BY_STDCOST
See Also:
Constant Field Values

ORDER_BY_LISTPRICE

public static final java.lang.String ORDER_BY_LISTPRICE
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

PartWithSITQtyListResult

public PartWithSITQtyListResult()
Method Detail

setDescription

public void setDescription(java.lang.String description)

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setRefDocDetails

public void setRefDocDetails(java.util.Set<RefdocVO> refDocDetails)

getDescription

public java.lang.String getDescription()

getAvgCost

public java.math.BigDecimal getAvgCost()

getPartFrom

public java.lang.String getPartFrom()

getRefDocDetails

public java.util.Set<RefdocVO> getRefDocDetails()

getOnHand

public java.math.BigDecimal getOnHand()

setOnHand

public void setOnHand(java.math.BigDecimal onHand)

getPartPk

public PartPK getPartPk()

setPartPk

public void setPartPk(PartPK partPk)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

getInSITQty

public java.math.BigDecimal getInSITQty()

setInSITQty

public void setInSITQty(java.math.BigDecimal inSITQty)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartWithSTOQtyListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartWithSTOQtyListResult

java.lang.Object
    extended by  bb.common.PartWithSTOQtyListResult
All Implemented Interfaces:
java.io.Serializable
public class PartWithSTOQtyListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AVGCOST
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_INQAQTY
static java.lang.String | ORDER_BY_LISTPRICE
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_STDCOST
Constructor Summary
PartWithSTOQtyListResult()
Method Summary
java.math.BigDecimal | getAvgCost()
java.lang.String | getDescription()
java.math.BigDecimal | getInTOQty()
java.math.BigDecimal | getListPrice()
java.math.BigDecimal | getOnHand()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.util.Set<RefdocVO> | getRefDocDetails()
java.math.BigDecimal | getStdCost()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setDescription(java.lang.String description)
void | setInSTOQty(java.math.BigDecimal inTOQty)
void | setListPrice(java.math.BigDecimal listPrice)
void | setOnHand(java.math.BigDecimal onHand)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setRefDocDetails(java.util.Set<RefdocVO> refDocDetails)
void | setStdCost(java.math.BigDecimal stdCost)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_INQAQTY

public static final java.lang.String ORDER_BY_INQAQTY
See Also:
Constant Field Values

ORDER_BY_AVGCOST

public static final java.lang.String ORDER_BY_AVGCOST
See Also:
Constant Field Values

ORDER_BY_STDCOST

public static final java.lang.String ORDER_BY_STDCOST
See Also:
Constant Field Values

ORDER_BY_LISTPRICE

public static final java.lang.String ORDER_BY_LISTPRICE
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

PartWithSTOQtyListResult

public PartWithSTOQtyListResult()
Method Detail

getPartPk

public PartPK getPartPk()

setPartPk

public void setPartPk(PartPK partPk)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getOnHand

public java.math.BigDecimal getOnHand()

setOnHand

public void setOnHand(java.math.BigDecimal onHand)

getInTOQty

public java.math.BigDecimal getInTOQty()

setInSTOQty

public void setInSTOQty(java.math.BigDecimal inTOQty)

getAvgCost

public java.math.BigDecimal getAvgCost()

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getRefDocDetails

public java.util.Set<RefdocVO> getRefDocDetails()

setRefDocDetails

public void setRefDocDetails(java.util.Set<RefdocVO> refDocDetails)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PartWithWipQtyListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PartWithWipQtyListResult

java.lang.Object
    extended by  bb.common.PartWithWipQtyListResult
All Implemented Interfaces:
java.io.Serializable
public class PartWithWipQtyListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AVGCOST
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_INWIPQTY
static java.lang.String | ORDER_BY_LISTPRICE
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_STDCOST
Constructor Summary
PartWithWipQtyListResult()
Method Summary
java.math.BigDecimal | getAvgCost()
java.lang.String | getDescription()
java.math.BigDecimal | getInWipQty()
java.math.BigDecimal | getListPrice()
java.math.BigDecimal | getOnHand()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.util.Set<RefdocVO> | getRefDocDetails()
java.math.BigDecimal | getStdCost()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setDescription(java.lang.String description)
void | setInWipQty(java.math.BigDecimal inWipQty)
void | setListPrice(java.math.BigDecimal listPrice)
void | setOnHand(java.math.BigDecimal onHand)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setRefDocDetails(java.util.Set<RefdocVO> refDocDetails)
void | setStdCost(java.math.BigDecimal stdCost)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_INWIPQTY

public static final java.lang.String ORDER_BY_INWIPQTY
See Also:
Constant Field Values

ORDER_BY_AVGCOST

public static final java.lang.String ORDER_BY_AVGCOST
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_STDCOST

public static final java.lang.String ORDER_BY_STDCOST
See Also:
Constant Field Values

ORDER_BY_LISTPRICE

public static final java.lang.String ORDER_BY_LISTPRICE
See Also:
Constant Field Values
Constructor Detail

PartWithWipQtyListResult

public PartWithWipQtyListResult()
Method Detail

setDescription

public void setDescription(java.lang.String description)

setInWipQty

public void setInWipQty(java.math.BigDecimal inWipQty)

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setRefDocDetails

public void setRefDocDetails(java.util.Set<RefdocVO> refDocDetails)

getDescription

public java.lang.String getDescription()

getInWipQty

public java.math.BigDecimal getInWipQty()

getAvgCost

public java.math.BigDecimal getAvgCost()

getPartFrom

public java.lang.String getPartFrom()

getRefDocDetails

public java.util.Set<RefdocVO> getRefDocDetails()

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

getOnHand

public java.math.BigDecimal getOnHand()

setOnHand

public void setOnHand(java.math.BigDecimal onHand)

getPartPk

public PartPK getPartPk()

setPartPk

public void setPartPk(PartPK partPk)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PasswordPolicyAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PasswordPolicyAgent

java.lang.Object
    extended by  bb.common.PasswordPolicyAgent
All Implemented Interfaces:
java.io.Serializable
public class PasswordPolicyAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PasswordPolicyAgent()
Method Summary
java.lang.Boolean | getPasswordEncrypt()
java.lang.Integer | getPasswordLifetime()
java.lang.Integer | getPasswordMinLength()
boolean | isChangePasswordEncrypt()
boolean | isChangePasswordLifetime()
boolean | isChangePasswordMinLength()
void | setPasswordEncrypt(java.lang.Boolean passwordEncrypt)
void | setPasswordLifetime(java.lang.Integer passwordLifetime)
void | setPasswordMinLength(java.lang.Integer passwordMinLength)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PasswordPolicyAgent

public PasswordPolicyAgent()
Method Detail

getPasswordEncrypt

public java.lang.Boolean getPasswordEncrypt()

setPasswordEncrypt

public void setPasswordEncrypt(java.lang.Boolean passwordEncrypt)

getPasswordLifetime

public java.lang.Integer getPasswordLifetime()

setPasswordLifetime

public void setPasswordLifetime(java.lang.Integer passwordLifetime)

getPasswordMinLength

public java.lang.Integer getPasswordMinLength()

setPasswordMinLength

public void setPasswordMinLength(java.lang.Integer passwordMinLength)

isChangePasswordEncrypt

public boolean isChangePasswordEncrypt()

isChangePasswordLifetime

public boolean isChangePasswordLifetime()

isChangePasswordMinLength

public boolean isChangePasswordMinLength()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PayableCheckRunItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PayableCheckRunItemPK

java.lang.Object
    extended by  bb.common.PayableCheckRunItemPK
All Implemented Interfaces:
java.io.Serializable
public class PayableCheckRunItemPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PayableCheckRunItemPK()
default constructor
PayableCheckRunItemPK(java.lang.String checkRunNumber, java.lang.String apNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getApNumber()
java.lang.String | getCheckRunNumber()
int | hashCode()
void | setApNumber(java.lang.String apNumber)
void | setCheckRunNumber(java.lang.String checkRunNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PayableCheckRunItemPK

public PayableCheckRunItemPK(java.lang.String checkRunNumber,
                             java.lang.String apNumber)
full constructor

PayableCheckRunItemPK

public PayableCheckRunItemPK()
default constructor

Method Detail

getCheckRunNumber

public java.lang.String getCheckRunNumber()

setCheckRunNumber

public void setCheckRunNumber(java.lang.String checkRunNumber)

getApNumber

public java.lang.String getApNumber()

setApNumber

public void setApNumber(java.lang.String apNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PayableMethodVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PayableMethodVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PayableMethodVO
All Implemented Interfaces:
java.io.Serializable
public class PayableMethodVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CHECKACCOUNTNUMBER
static java.lang.String | ORDER_BY_COMPANYUNITID
static java.lang.String | ORDER_BY_PAYABLEMETHODID
static java.lang.String | ORDER_BY_PAYABLEMETHODNAME
Constructor Summary
PayableMethodVO()
Method Summary
boolean | equals(java.lang.Object obj)
java.lang.String | getCheckAccountNumber()
java.lang.String | getCompanyUnitId()
int | getPayableMethodID()
java.lang.String | getPayableMethodName()
int | hashCode()
void | setCheckAccountNumber(java.lang.String checkAccountNumber)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setPayableMethodID(int payableMethodID)
void | setPayableMethodName(java.lang.String payableMethodName)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PAYABLEMETHODID

public static final java.lang.String ORDER_BY_PAYABLEMETHODID
See Also:
Constant Field Values

ORDER_BY_PAYABLEMETHODNAME

public static final java.lang.String ORDER_BY_PAYABLEMETHODNAME
See Also:
Constant Field Values

ORDER_BY_CHECKACCOUNTNUMBER

public static final java.lang.String ORDER_BY_CHECKACCOUNTNUMBER
See Also:
Constant Field Values

ORDER_BY_COMPANYUNITID

public static final java.lang.String ORDER_BY_COMPANYUNITID
See Also:
Constant Field Values
Constructor Detail

PayableMethodVO

public PayableMethodVO()
Method Detail

getPayableMethodID

public int getPayableMethodID()

setPayableMethodID

public void setPayableMethodID(int payableMethodID)

getPayableMethodName

public java.lang.String getPayableMethodName()

setPayableMethodName

public void setPayableMethodName(java.lang.String payableMethodName)

getCheckAccountNumber

public java.lang.String getCheckAccountNumber()

setCheckAccountNumber

public void setCheckAccountNumber(java.lang.String checkAccountNumber)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PaymentAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PaymentAgent

java.lang.Object
    extended by  bb.common.PaymentAgent
All Implemented Interfaces:
java.io.Serializable
public class PaymentAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PaymentAgent()
Method Summary
java.lang.String | getAccountNumber()
java.lang.String | getAddressId()
java.lang.String | getArApNumber()
java.lang.String | getBatchRunNumber()
java.lang.String | getCheckNumber()
java.lang.String | getComments()
java.lang.String | getCompanyUnitId()
java.util.Date | getDatePaid()
java.math.BigDecimal | getExchangeRate()
java.lang.String | getGlSummary()
java.math.BigDecimal | getTotalPaid()
java.util.Map<java.lang.String,java.math.BigDecimal> | getTotalPaidMap()
boolean | isCloseAR()
void | setAccountNumber(java.lang.String accountNumber)
void | setAddressId(java.lang.String addressId)
void | setArApNumber(java.lang.String arApNumber)
void | setBatchRunNumber(java.lang.String batchRunNumber)
void | setCheckNumber(java.lang.String checkNumber)
void | setCloseAR(boolean closeAR)
void | setComments(java.lang.String comments)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setDatePaid(java.util.Date datePaid)
void | setExchangeRate(java.math.BigDecimal exchangeRate)
void | setGlSummary(java.lang.String glSummary)
void | setTotalPaid(java.math.BigDecimal totalPaid)
void | setTotalPaidMap(java.util.Map<java.lang.String,java.math.BigDecimal> totalPaidMap)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PaymentAgent

public PaymentAgent()
Method Detail

getComments

public java.lang.String getComments()

getTotalPaid

public java.math.BigDecimal getTotalPaid()

getCheckNumber

public java.lang.String getCheckNumber()

getAccountNumber

public java.lang.String getAccountNumber()

setDatePaid

public void setDatePaid(java.util.Date datePaid)

setComments

public void setComments(java.lang.String comments)

setTotalPaid

public void setTotalPaid(java.math.BigDecimal totalPaid)

setCheckNumber

public void setCheckNumber(java.lang.String checkNumber)

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

setAddressId

public void setAddressId(java.lang.String addressId)

setArApNumber

public void setArApNumber(java.lang.String arApNumber)

getDatePaid

public java.util.Date getDatePaid()

getAddressId

public java.lang.String getAddressId()

getArApNumber

public java.lang.String getArApNumber()

getBatchRunNumber

public java.lang.String getBatchRunNumber()

setBatchRunNumber

public void setBatchRunNumber(java.lang.String batchRunNumber)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getGlSummary

public java.lang.String getGlSummary()

setGlSummary

public void setGlSummary(java.lang.String glSummary)

getTotalPaidMap

public java.util.Map<java.lang.String,java.math.BigDecimal> getTotalPaidMap()

setTotalPaidMap

public void setTotalPaidMap(java.util.Map<java.lang.String,java.math.BigDecimal> totalPaidMap)

getExchangeRate

public java.math.BigDecimal getExchangeRate()

setExchangeRate

public void setExchangeRate(java.math.BigDecimal exchangeRate)

isCloseAR

public boolean isCloseAR()

setCloseAR

public void setCloseAR(boolean closeAR)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PaymentHistoryVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PaymentHistoryVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PaymentHistoryVO
All Implemented Interfaces:
java.io.Serializable
public class PaymentHistoryVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ADDRESSID
static java.lang.String | ORDER_BY_ADDRESSNAME
static java.lang.String | ORDER_BY_APDUEDAYS
static java.lang.String | ORDER_BY_ARDUEDAYS
static java.lang.String | ORDER_BY_CUSTOMERSALES
static java.lang.String | ORDER_BY_VENDORPURCHASES
Constructor Summary
PaymentHistoryVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAddressId()
java.lang.String | getAddressName()
java.lang.Float | getApDueDays()
java.math.BigDecimal | getApPaid()
java.lang.Float | getArDueDays()
java.math.BigDecimal | getArReceived()
java.math.BigDecimal | getCustomerSales()
java.util.Date | getLastChangeDate()
java.math.BigDecimal | getVendorPurchases()
int | hashCode()
void | setAddressId(java.lang.String addressId)
void | setAddressName(java.lang.String addressName)
void | setApDueDays(java.lang.Float apDueDays)
void | setApPaid(java.math.BigDecimal apPaid)
void | setArDueDays(java.lang.Float arDueDays)
void | setArReceived(java.math.BigDecimal arReceived)
void | setCustomerSales(java.math.BigDecimal customerSales)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setVendorPurchases(java.math.BigDecimal vendorPurchases)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ADDRESSID

public static final java.lang.String ORDER_BY_ADDRESSID
See Also:
Constant Field Values

ORDER_BY_ADDRESSNAME

public static final java.lang.String ORDER_BY_ADDRESSNAME
See Also:
Constant Field Values

ORDER_BY_VENDORPURCHASES

public static final java.lang.String ORDER_BY_VENDORPURCHASES
See Also:
Constant Field Values

ORDER_BY_ARDUEDAYS

public static final java.lang.String ORDER_BY_ARDUEDAYS
See Also:
Constant Field Values

ORDER_BY_APDUEDAYS

public static final java.lang.String ORDER_BY_APDUEDAYS
See Also:
Constant Field Values

ORDER_BY_CUSTOMERSALES

public static final java.lang.String ORDER_BY_CUSTOMERSALES
See Also:
Constant Field Values
Constructor Detail

PaymentHistoryVO

public PaymentHistoryVO()
Method Detail

getAddressId

public java.lang.String getAddressId()

setAddressId

public void setAddressId(java.lang.String addressId)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAddressName

public java.lang.String getAddressName()

setAddressName

public void setAddressName(java.lang.String addressName)

getCustomerSales

public java.math.BigDecimal getCustomerSales()

setCustomerSales

public void setCustomerSales(java.math.BigDecimal customerSales)

getArReceived

public java.math.BigDecimal getArReceived()

setArReceived

public void setArReceived(java.math.BigDecimal arReceived)

getVendorPurchases

public java.math.BigDecimal getVendorPurchases()

setVendorPurchases

public void setVendorPurchases(java.math.BigDecimal vendorPurchases)

getApPaid

public java.math.BigDecimal getApPaid()

getArDueDays

public java.lang.Float getArDueDays()

getApDueDays

public java.lang.Float getApDueDays()

setApPaid

public void setApPaid(java.math.BigDecimal apPaid)

setArDueDays

public void setArDueDays(java.lang.Float arDueDays)

setApDueDays

public void setApDueDays(java.lang.Float apDueDays)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PaymentInvoicesResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PaymentInvoicesResult

java.lang.Object
    extended by  bb.common.PaymentInvoicesResult
All Implemented Interfaces:
java.io.Serializable
public class PaymentInvoicesResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PaymentInvoicesResult()
Method Summary
java.util.Date | getAdate()
java.lang.String | getCheckNumber()
java.lang.String | getCheckRunNumber()
java.util.List<GeneralLedgerVO> | getPaymentInvoices()
java.math.BigDecimal | getReceived()
void | setAdate(java.util.Date adate)
void | setCheckNumber(java.lang.String checkNumber)
void | setCheckRunNumber(java.lang.String checkRunNumber)
void | setPaymentInvoices(java.util.List<GeneralLedgerVO> paymentInvoices)
void | setReceived(java.math.BigDecimal received)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PaymentInvoicesResult

public PaymentInvoicesResult()
Method Detail

getCheckRunNumber

public java.lang.String getCheckRunNumber()

setCheckRunNumber

public void setCheckRunNumber(java.lang.String checkRunNumber)

getCheckNumber

public java.lang.String getCheckNumber()

setCheckNumber

public void setCheckNumber(java.lang.String checkNumber)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getReceived

public java.math.BigDecimal getReceived()

setReceived

public void setReceived(java.math.BigDecimal received)

getPaymentInvoices

public java.util.List<GeneralLedgerVO> getPaymentInvoices()

setPaymentInvoices

public void setPaymentInvoices(java.util.List<GeneralLedgerVO> paymentInvoices)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PaymentRunItemTotalResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PaymentRunItemTotalResult

java.lang.Object
    extended by  bb.common.PaymentRunItemTotalResult
All Implemented Interfaces:
java.io.Serializable
public class PaymentRunItemTotalResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PaymentRunItemTotalResult()
Method Summary
java.math.BigDecimal | getArTotal()
java.math.BigDecimal | getTotalCheck()
java.math.BigDecimal | getTotalDue()
java.math.BigDecimal | getTotalPaid()
void | setArTotal(java.math.BigDecimal arTotal)
void | setTotalCheck(java.math.BigDecimal totalCheck)
void | setTotalDue(java.math.BigDecimal totalDue)
void | setTotalPaid(java.math.BigDecimal totalPaid)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PaymentRunItemTotalResult

public PaymentRunItemTotalResult()
Method Detail

getTotalDue

public java.math.BigDecimal getTotalDue()

getTotalPaid

public java.math.BigDecimal getTotalPaid()

getTotalCheck

public java.math.BigDecimal getTotalCheck()

setArTotal

public void setArTotal(java.math.BigDecimal arTotal)

setTotalDue

public void setTotalDue(java.math.BigDecimal totalDue)

setTotalPaid

public void setTotalPaid(java.math.BigDecimal totalPaid)

setTotalCheck

public void setTotalCheck(java.math.BigDecimal totalCheck)

getArTotal

public java.math.BigDecimal getArTotal()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PaymentVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PaymentVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PaymentVO
All Implemented Interfaces:
java.io.Serializable
public class PaymentVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PaymentVO()
Method Summary
java.lang.String | getCheckAccountNumber()
int | getPaymentID()
java.lang.String | getPaymentName()
void | setCheckAccountNumber(java.lang.String checkAccountNumber)
void | setPaymentID(int paymentID)
void | setPaymentName(java.lang.String paymentName)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PaymentVO

public PaymentVO()
Method Detail

getPaymentID

public int getPaymentID()

setPaymentID

public void setPaymentID(int paymentID)

getPaymentName

public java.lang.String getPaymentName()

setPaymentName

public void setPaymentName(java.lang.String paymentName)

getCheckAccountNumber

public java.lang.String getCheckAccountNumber()

setCheckAccountNumber

public void setCheckAccountNumber(java.lang.String checkAccountNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PermissionDescriptionPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PermissionDescriptionPK

java.lang.Object
    extended by  bb.common.PermissionDescriptionPK
All Implemented Interfaces:
java.io.Serializable
public class PermissionDescriptionPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PermissionDescriptionPK()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getLanguage()
java.lang.String | getPermissionId()
int | hashCode()
void | setLanguage(java.lang.String language)
void | setPermissionId(java.lang.String permissionId)
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PermissionDescriptionPK

public PermissionDescriptionPK()
default constructor

Method Detail

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getPermissionId

public java.lang.String getPermissionId()

setPermissionId

public void setPermissionId(java.lang.String permissionId)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PermissionDescriptionVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PermissionDescriptionVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PermissionDescriptionVO
All Implemented Interfaces:
java.io.Serializable
public class PermissionDescriptionVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PermissionDescriptionVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDescription()
java.lang.String | getPermissionName()
PermissionDescriptionPK | getPk()
int | hashCode()
void | setDescription(java.lang.String description)
void | setPermissionName(java.lang.String permissionName)
void | setPk(PermissionDescriptionPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PermissionDescriptionVO

public PermissionDescriptionVO()
Method Detail

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getPermissionName

public java.lang.String getPermissionName()

setPermissionName

public void setPermissionName(java.lang.String permissionName)

getPk

public PermissionDescriptionPK getPk()

setPk

public void setPk(PermissionDescriptionPK pk)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PermissionException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PermissionException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  bb.common.PermissionException
All Implemented Interfaces:
java.io.Serializable
public class PermissionException
extends java.lang.Exception

See Also:
Serialized Form

Field Summary
static java.lang.String INSUFFICIENT_PERMISSION
Constructor Summary
PermissionException()
PermissionException(java.lang.Exception e)
PermissionException(java.lang.String message)
Method Summary
java.lang.String | getReason()
void | setReason(java.lang.String reason)
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

INSUFFICIENT_PERMISSION

public static final java.lang.String INSUFFICIENT_PERMISSION
See Also:
Constant Field Values
Constructor Detail

PermissionException

public PermissionException()

PermissionException

public PermissionException(java.lang.Exception e)

PermissionException

public PermissionException(java.lang.String message)
Method Detail

setReason

public void setReason(java.lang.String reason)

getReason

public java.lang.String getReason()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PermissionListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PermissionListResult

java.lang.Object
    extended by  bb.common.PermissionListResult
All Implemented Interfaces:
java.io.Serializable
public class PermissionListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_PERMISSIONID
static java.lang.String | ORDER_BY_PERMISSIONNAME
java.lang.String | permissionId
Constructor Summary
PermissionListResult()
Method Summary
java.lang.String | getDescription()
java.lang.String | getPermissionId()
java.lang.String | getPermissionName()
void | setDescription(java.lang.String description)
void | setPermissionId(java.lang.String permissionId)
void | setPermissionName(java.lang.String permissionName)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PERMISSIONID

public static final java.lang.String ORDER_BY_PERMISSIONID
See Also:
Constant Field Values

ORDER_BY_PERMISSIONNAME

public static final java.lang.String ORDER_BY_PERMISSIONNAME
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

permissionId

public java.lang.String permissionId
Constructor Detail

PermissionListResult

public PermissionListResult()
Method Detail

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getPermissionName

public java.lang.String getPermissionName()

setPermissionName

public void setPermissionName(java.lang.String permissionName)

getPermissionId

public java.lang.String getPermissionId()

setPermissionId

public void setPermissionId(java.lang.String permissionId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PermissionMethodPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PermissionMethodPK

java.lang.Object
    extended by  bb.common.PermissionMethodPK
All Implemented Interfaces:
java.io.Serializable
public class PermissionMethodPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PermissionMethodPK()
default constructor
PermissionMethodPK(java.lang.String permissionId, java.lang.Long methodId)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Long | getMethodId()
java.lang.String | getPermissionId()
int | hashCode()
void | setMethodId(java.lang.Long methodId)
void | setPermissionId(java.lang.String permissionId)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PermissionMethodPK

public PermissionMethodPK(java.lang.String permissionId,
                          java.lang.Long methodId)
full constructor

PermissionMethodPK

public PermissionMethodPK()
default constructor

Method Detail

getPermissionId

public java.lang.String getPermissionId()

setPermissionId

public void setPermissionId(java.lang.String permissionId)

getMethodId

public java.lang.Long getMethodId()

setMethodId

public void setMethodId(java.lang.Long methodId)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PermissionMethodVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PermissionMethodVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PermissionMethodVO
All Implemented Interfaces:
java.io.Serializable
public class PermissionMethodVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PermissionMethodVO()
default constructor
PermissionMethodVO(PermissionMethodPK pk)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
EjbMethodVO | getEjbMethod()
PermissionMethodPK | getPk()
int | hashCode()
void | setEjbMethod(EjbMethodVO ejbMethod)
void | setPk(PermissionMethodPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PermissionMethodVO

public PermissionMethodVO(PermissionMethodPK pk)
full constructor

PermissionMethodVO

public PermissionMethodVO()
default constructor

Method Detail

getPk

public PermissionMethodPK getPk()

setPk

public void setPk(PermissionMethodPK pk)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getEjbMethod

public EjbMethodVO getEjbMethod()

setEjbMethod

public void setEjbMethod(EjbMethodVO ejbMethod)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PermissionVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PermissionVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PermissionVO
All Implemented Interfaces:
java.io.Serializable
public class PermissionVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String ORDER_BY_PERMISSIONID
Constructor Summary
PermissionVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Integer | getLevel()
java.util.Set | getMultiLanguage()
java.lang.String | getParentId()
java.lang.String | getPermissionId()
int | hashCode()
boolean | isPermission()
void | setLevel(java.lang.Integer level)
void | setMultiLanguage(java.util.Set multiLanguage)
void | setParentId(java.lang.String parentId)
void | setPermission(boolean permission)
void | setPermissionId(java.lang.String permissionId)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PERMISSIONID

public static final java.lang.String ORDER_BY_PERMISSIONID
See Also:
Constant Field Values
Constructor Detail

PermissionVO

public PermissionVO()
default constructor

Method Detail

getLevel

public java.lang.Integer getLevel()

setLevel

public void setLevel(java.lang.Integer level)

getParentId

public java.lang.String getParentId()

setParentId

public void setParentId(java.lang.String parentId)

isPermission

public boolean isPermission()

setPermission

public void setPermission(boolean permission)

getMultiLanguage

public java.util.Set getMultiLanguage()

setMultiLanguage

public void setMultiLanguage(java.util.Set multiLanguage)

getPermissionId

public java.lang.String getPermissionId()

setPermissionId

public void setPermissionId(java.lang.String permissionId)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PfReceiverItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PfReceiverItemPK

java.lang.Object
    extended by  bb.common.PfReceiverItemPK
All Implemented Interfaces:
java.io.Serializable
public class PfReceiverItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PfReceiverItemPK()
PfReceiverItemPK(java.lang.String pfReceiverNumber, java.lang.String purchaseOrderNumber, java.lang.String purchaseOrderItemNumber)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getPfReceiverNumber()
java.lang.String | getPurchaseOrderItemNumber()
java.lang.String | getPurchaseOrderNumber()
int | hashCode()
void | setPfReceiverNumber(java.lang.String pfReceiverNumber)
void | setPurchaseOrderItemNumber(java.lang.String purchaseOrderItemNumber)
void | setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PfReceiverItemPK

public PfReceiverItemPK()

PfReceiverItemPK

public PfReceiverItemPK(java.lang.String pfReceiverNumber,
                        java.lang.String purchaseOrderNumber,
                        java.lang.String purchaseOrderItemNumber)
Method Detail

getPfReceiverNumber

public java.lang.String getPfReceiverNumber()

setPfReceiverNumber

public void setPfReceiverNumber(java.lang.String pfReceiverNumber)

getPurchaseOrderItemNumber

public java.lang.String getPurchaseOrderItemNumber()

setPurchaseOrderItemNumber

public void setPurchaseOrderItemNumber(java.lang.String purchaseOrderItemNumber)

getPurchaseOrderNumber

public java.lang.String getPurchaseOrderNumber()

setPurchaseOrderNumber

public void setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PfReceiverItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PfReceiverItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PfReceiverItemVO
All Implemented Interfaces:
java.io.Serializable
public class PfReceiverItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PfReceiverItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getApDisc()
java.math.BigDecimal | getApNet()
java.lang.String | getApNumber()
java.math.BigDecimal | getApOpen()
java.math.BigDecimal | getApReceived()
java.math.BigDecimal | getApSub()
java.math.BigDecimal | getApTax()
java.math.BigDecimal | getApTotal()
java.math.BigDecimal | getAvgCost()
java.util.Date | getDateInvoiced()
java.util.Date | getDateShipped()
java.lang.String | getDescription()
java.math.BigDecimal | getDiscount()
java.lang.String | getItemComments()
java.lang.String | getItemPrivateNotes()
java.math.BigDecimal | getListPrice()
java.lang.String | getMfg()
java.lang.String | getModelNumber()
java.lang.String | getMpn()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getPfReceiverItemNumber()
PfReceiverItemPK | getPk()
java.math.BigDecimal | getQtyReceived()
java.math.BigDecimal | getQtyShipped()
java.math.BigDecimal | getQuantity()
java.lang.String | getReceiver()
java.lang.String | getRevision()
java.lang.String | getSalesOrderNumber()
java.lang.String | getSerial()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.math.BigDecimal | getTaxRate()
java.lang.String | getUnit()
java.lang.String | getVendorId()
java.lang.String | getVendorInvoiceNumber()
java.lang.String | getVendorShipperNumber()
int | hashCode()
void | setApDisc(java.math.BigDecimal apDisc)
void | setApNet(java.math.BigDecimal apNet)
void | setApNumber(java.lang.String apNumber)
void | setApOpen(java.math.BigDecimal apOpen)
void | setApReceived(java.math.BigDecimal apReceived)
void | setApSub(java.math.BigDecimal apSub)
void | setApTax(java.math.BigDecimal apTax)
void | setApTotal(java.math.BigDecimal apTotal)
void | setAvgCost(java.math.BigDecimal avgCost)
void | setDateInvoiced(java.util.Date dateInvoiced)
void | setDateShipped(java.util.Date dateShipped)
void | setDescription(java.lang.String description)
void | setDiscount(java.math.BigDecimal discount)
void | setItemComments(java.lang.String itemComments)
void | setItemPrivateNotes(java.lang.String itemPrivateNotes)
void | setListPrice(java.math.BigDecimal listPrice)
void | setMfg(java.lang.String mfg)
void | setModelNumber(java.lang.String modelNumber)
void | setMpn(java.lang.String mpn)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPfReceiverItemNumber(java.lang.String pfReceiverItemNumber)
void | setPk(PfReceiverItemPK pk)
void | setQtyReceived(java.math.BigDecimal qtyReceived)
void | setQtyShipped(java.math.BigDecimal qtyShipped)
void | setQuantity(java.math.BigDecimal quantity)
void | setReceiver(java.lang.String receiver)
void | setRevision(java.lang.String revision)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setSerial(java.lang.String serial)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setUnit(java.lang.String unit)
void | setVendorId(java.lang.String vendorId)
void | setVendorInvoiceNumber(java.lang.String vendorInvoiceNumber)
void | setVendorShipperNumber(java.lang.String vendorShipperNumber)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PfReceiverItemVO

public PfReceiverItemVO()
Method Detail

getPk

public PfReceiverItemPK getPk()

setPk

public void setPk(PfReceiverItemPK pk)

getApDisc

public java.math.BigDecimal getApDisc()

setApDisc

public void setApDisc(java.math.BigDecimal apDisc)

getApNet

public java.math.BigDecimal getApNet()

setApNet

public void setApNet(java.math.BigDecimal apNet)

getApOpen

public java.math.BigDecimal getApOpen()

setApOpen

public void setApOpen(java.math.BigDecimal apOpen)

getApReceived

public java.math.BigDecimal getApReceived()

setApReceived

public void setApReceived(java.math.BigDecimal apReceived)

getApSub

public java.math.BigDecimal getApSub()

setApSub

public void setApSub(java.math.BigDecimal apSub)

getApTax

public java.math.BigDecimal getApTax()

setApTax

public void setApTax(java.math.BigDecimal apTax)

getApTotal

public java.math.BigDecimal getApTotal()

setApTotal

public void setApTotal(java.math.BigDecimal apTotal)

getAvgCost

public java.math.BigDecimal getAvgCost()

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getItemComments

public java.lang.String getItemComments()

setItemComments

public void setItemComments(java.lang.String itemComments)

getItemPrivateNotes

public java.lang.String getItemPrivateNotes()

setItemPrivateNotes

public void setItemPrivateNotes(java.lang.String itemPrivateNotes)

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPfReceiverItemNumber

public java.lang.String getPfReceiverItemNumber()

setPfReceiverItemNumber

public void setPfReceiverItemNumber(java.lang.String pfReceiverItemNumber)

getQtyReceived

public java.math.BigDecimal getQtyReceived()

setQtyReceived

public void setQtyReceived(java.math.BigDecimal qtyReceived)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getSerial

public java.lang.String getSerial()

setSerial

public void setSerial(java.lang.String serial)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getDateInvoiced

public java.util.Date getDateInvoiced()

setDateInvoiced

public void setDateInvoiced(java.util.Date dateInvoiced)

getDateShipped

public java.util.Date getDateShipped()

setDateShipped

public void setDateShipped(java.util.Date dateShipped)

getQtyShipped

public java.math.BigDecimal getQtyShipped()

setQtyShipped

public void setQtyShipped(java.math.BigDecimal qtyShipped)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getVendorInvoiceNumber

public java.lang.String getVendorInvoiceNumber()

setVendorInvoiceNumber

public void setVendorInvoiceNumber(java.lang.String vendorInvoiceNumber)

getVendorShipperNumber

public java.lang.String getVendorShipperNumber()

setVendorShipperNumber

public void setVendorShipperNumber(java.lang.String vendorShipperNumber)

getApNumber

public java.lang.String getApNumber()

setApNumber

public void setApNumber(java.lang.String apNumber)

getReceiver

public java.lang.String getReceiver()

setReceiver

public void setReceiver(java.lang.String receiver)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PfReceiverItemWithNumberPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PfReceiverItemWithNumberPK

java.lang.Object
    extended by  bb.common.PfReceiverItemWithNumberPK
All Implemented Interfaces:
java.io.Serializable
public class PfReceiverItemWithNumberPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PfReceiverItemWithNumberPK()
PfReceiverItemWithNumberPK(PfReceiverItemPK pk, java.lang.String pfReceiverItemNumber)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getPfReceiverItemNumber()
PfReceiverItemPK | getPk()
int | hashCode()
void | setPfReceiverItemNumber(java.lang.String pfReceiverItemNumber)
void | setPk(PfReceiverItemPK pk)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PfReceiverItemWithNumberPK

public PfReceiverItemWithNumberPK()

PfReceiverItemWithNumberPK

public PfReceiverItemWithNumberPK(PfReceiverItemPK pk,
                                  java.lang.String pfReceiverItemNumber)
Method Detail

getPk

public PfReceiverItemPK getPk()

setPk

public void setPk(PfReceiverItemPK pk)

getPfReceiverItemNumber

public java.lang.String getPfReceiverItemNumber()

setPfReceiverItemNumber

public void setPfReceiverItemNumber(java.lang.String pfReceiverItemNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PfReceiverVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PfReceiverVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PfReceiverVO
All Implemented Interfaces:
java.io.Serializable
public class PfReceiverVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PfReceiverVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.math.BigDecimal | getApDisc()
java.math.BigDecimal | getApFreight()
java.math.BigDecimal | getApNet()
java.math.BigDecimal | getApOpen()
java.math.BigDecimal | getApReceived()
java.math.BigDecimal | getApSub()
java.math.BigDecimal | getApTax()
java.math.BigDecimal | getApTotal()
java.util.Date | getArrivalDate()
java.lang.String | getBillOfLading()
java.lang.String | getBp()
java.lang.String | getBuyer()
java.lang.String | getCarrier()
java.lang.String | getCarrierAccount()
java.lang.String | getChangeOrder()
java.lang.String | getComments()
java.lang.String | getContact()
java.lang.String | getContainerNumber()
java.lang.String | getContainerSealNumber()
java.lang.String | getCurrency()
java.util.Date | getDateReceived()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.util.Set | getItems()
java.util.Date | getLastChangeDate()
int | getLastChangeTimes()
java.lang.String | getLastChangeUser()
java.lang.String | getOrigin()
int | getPackingBoxNumbers()
java.lang.String | getPfReceiverNumber()
java.util.Date | getPrDate()
java.lang.String | getPrivateNotes()
java.lang.String | getProjectName()
java.util.Set | getPrPackingBoxes()
java.lang.String | getReceivedBy()
java.lang.String | getRelatedDoc()
java.lang.String | getRequester()
java.util.Date | getShipDate()
java.lang.String | getShippedVia()
java.lang.String | getShippingMark()
java.lang.String | getStatus()
java.lang.String | getTerms()
java.lang.String | getTracking()
CustomerVendorAddressInfoVO | getVendorAddressInfo()
java.lang.String | getVendorEmail()
java.lang.String | getVendorId()
java.lang.String | getVendorSO()
int | hashCode()
void | setAdate(java.util.Date adate)
void | setApDisc(java.math.BigDecimal apDisc)
void | setApFreight(java.math.BigDecimal apFreight)
void | setApNet(java.math.BigDecimal apNet)
void | setApOpen(java.math.BigDecimal apOpen)
void | setApReceived(java.math.BigDecimal apReceived)
void | setApSub(java.math.BigDecimal apSub)
void | setApTax(java.math.BigDecimal apTax)
void | setApTotal(java.math.BigDecimal apTotal)
void | setArrivalDate(java.util.Date arrivalDate)
void | setBillOfLading(java.lang.String billOfLading)
void | setBp(java.lang.String bp)
void | setBuyer(java.lang.String buyer)
void | setCarrier(java.lang.String carrier)
void | setCarrierAccount(java.lang.String carrierAccount)
void | setChangeOrder(java.lang.String changeOrder)
void | setComments(java.lang.String comments)
void | setContact(java.lang.String contact)
void | setContainerNumber(java.lang.String containerNumber)
void | setContainerSealNumber(java.lang.String containerSealNumber)
void | setCurrency(java.lang.String currency)
void | setDateReceived(java.util.Date dateReceived)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setItems(java.util.Set items)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTimes(int lastChangeTimes)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setOrigin(java.lang.String origin)
void | setPackingBoxNumbers(int packingBoxNumbers)
void | setPfReceiverNumber(java.lang.String pfReceiverNumber)
void | setPrDate(java.util.Date prDate)
void | setPrivateNotes(java.lang.String privateNotes)
void | setProjectName(java.lang.String projectName)
void | setPrPackingBoxes(java.util.Set prPackingBoxes)
void | setReceivedBy(java.lang.String receivedBy)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setRequester(java.lang.String requester)
void | setShipDate(java.util.Date shipDate)
void | setShippedVia(java.lang.String shippedVia)
void | setShippingMark(java.lang.String shippingMark)
void | setStatus(java.lang.String status)
void | setTerms(java.lang.String terms)
void | setTracking(java.lang.String tracking)
void | setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)
void | setVendorEmail(java.lang.String vendorEmail)
void | setVendorId(java.lang.String vendorId)
void | setVendorSO(java.lang.String vendorSO)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PfReceiverVO

public PfReceiverVO()
Method Detail

getPfReceiverNumber

public java.lang.String getPfReceiverNumber()

setPfReceiverNumber

public void setPfReceiverNumber(java.lang.String pfReceiverNumber)

getPrDate

public java.util.Date getPrDate()

setPrDate

public void setPrDate(java.util.Date prDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getApDisc

public java.math.BigDecimal getApDisc()

setApDisc

public void setApDisc(java.math.BigDecimal apDisc)

getApFreight

public java.math.BigDecimal getApFreight()

setApFreight

public void setApFreight(java.math.BigDecimal apFreight)

getApNet

public java.math.BigDecimal getApNet()

setApNet

public void setApNet(java.math.BigDecimal apNet)

getApOpen

public java.math.BigDecimal getApOpen()

setApOpen

public void setApOpen(java.math.BigDecimal apOpen)

getApReceived

public java.math.BigDecimal getApReceived()

setApReceived

public void setApReceived(java.math.BigDecimal apReceived)

getApSub

public java.math.BigDecimal getApSub()

setApSub

public void setApSub(java.math.BigDecimal apSub)

getApTax

public java.math.BigDecimal getApTax()

setApTax

public void setApTax(java.math.BigDecimal apTax)

getApTotal

public java.math.BigDecimal getApTotal()

setApTotal

public void setApTotal(java.math.BigDecimal apTotal)

getBp

public java.lang.String getBp()

setBp

public void setBp(java.lang.String bp)

getBuyer

public java.lang.String getBuyer()

setBuyer

public void setBuyer(java.lang.String buyer)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAccount

public java.lang.String getCarrierAccount()

setCarrierAccount

public void setCarrierAccount(java.lang.String carrierAccount)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getDateReceived

public java.util.Date getDateReceived()

setDateReceived

public void setDateReceived(java.util.Date dateReceived)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getItems

public java.util.Set getItems()

setItems

public void setItems(java.util.Set items)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeTimes

public int getLastChangeTimes()

setLastChangeTimes

public void setLastChangeTimes(int lastChangeTimes)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getPackingBoxNumbers

public int getPackingBoxNumbers()

setPackingBoxNumbers

public void setPackingBoxNumbers(int packingBoxNumbers)

getPrivateNotes

public java.lang.String getPrivateNotes()

setPrivateNotes

public void setPrivateNotes(java.lang.String privateNotes)

getProjectName

public java.lang.String getProjectName()

setProjectName

public void setProjectName(java.lang.String projectName)

getPrPackingBoxes

public java.util.Set getPrPackingBoxes()

setPrPackingBoxes

public void setPrPackingBoxes(java.util.Set prPackingBoxes)

getReceivedBy

public java.lang.String getReceivedBy()

setReceivedBy

public void setReceivedBy(java.lang.String receivedBy)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getRequester

public java.lang.String getRequester()

setRequester

public void setRequester(java.lang.String requester)

getShippedVia

public java.lang.String getShippedVia()

setShippedVia

public void setShippedVia(java.lang.String shippedVia)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getTracking

public java.lang.String getTracking()

setTracking

public void setTracking(java.lang.String tracking)

getVendorAddressInfo

public CustomerVendorAddressInfoVO getVendorAddressInfo()

setVendorAddressInfo

public void setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)

getVendorEmail

public java.lang.String getVendorEmail()

setVendorEmail

public void setVendorEmail(java.lang.String vendorEmail)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getVendorSO

public java.lang.String getVendorSO()

setVendorSO

public void setVendorSO(java.lang.String vendorSO)

getBillOfLading

public java.lang.String getBillOfLading()

setBillOfLading

public void setBillOfLading(java.lang.String billOfLading)

getContainerNumber

public java.lang.String getContainerNumber()

setContainerNumber

public void setContainerNumber(java.lang.String containerNumber)

getContainerSealNumber

public java.lang.String getContainerSealNumber()

setContainerSealNumber

public void setContainerSealNumber(java.lang.String containerSealNumber)

getShippingMark

public java.lang.String getShippingMark()

setShippingMark

public void setShippingMark(java.lang.String shippingMark)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getShipDate

public java.util.Date getShipDate()

setShipDate

public void setShipDate(java.util.Date shipDate)

getArrivalDate

public java.util.Date getArrivalDate()

setArrivalDate

public void setArrivalDate(java.util.Date arrivalDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PhysicalInventoryListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PhysicalInventoryListResult

java.lang.Object
    extended by  bb.common.PhysicalInventoryListResult
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
PhysicalInventoryListWithAppDataResult
public class PhysicalInventoryListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AVGCOST
static java.lang.String | ORDER_BY_COMMITTED
static java.lang.String | ORDER_BY_COUNTEDBY
static java.lang.String | ORDER_BY_COUNTEDDATE
static java.lang.String | ORDER_BY_DIFFCOUNT
static java.lang.String | ORDER_BY_INQUALITYCHECKINGQTY
static java.lang.String | ORDER_BY_LOCATION
static java.lang.String | ORDER_BY_NEWONHAND
static java.lang.String | ORDER_BY_oldAvgCost
static java.lang.String | ORDER_BY_oldOnloanQty
static java.lang.String | ORDER_BY_oldSip
static java.lang.String | ORDER_BY_oldStadCost
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PK
static java.lang.String | ORDER_BY_STARTDATE
static java.lang.String | ORDER_BY_SYSTEMONHAND
static java.lang.String | ORDER_BY_TAGNUMBER
static java.lang.String | ORDER_BY_WORKINPROCESSQTY
Constructor Summary
PhysicalInventoryListResult()
Method Summary
java.math.BigDecimal | getAvgCost()
java.lang.String | getCountedBy()
java.util.Date | getCountedDate()
java.lang.String | getDescription()
java.math.BigDecimal | getDiffcount()
java.math.BigDecimal | getInQualityCheckingQty()
java.lang.String | getLocation()
java.lang.String | getNewLocation()
java.math.BigDecimal | getNewOnhand()
java.math.BigDecimal | getOldAvgCost()
java.math.BigDecimal | getOldOnloanQty()
java.math.BigDecimal | getOldSip()
java.math.BigDecimal | getOldStadCost()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
PhysicalInventoryPK | getPk()
java.util.Date | getStartDate()
java.math.BigDecimal | getSystemOnhand()
java.lang.String | getTagNumber()
java.math.BigDecimal | getTotalNewOnhand()
java.lang.String | getUnit()
java.math.BigDecimal | getWorkInProcessQty()
boolean | isCommitted()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setCommitted(boolean committed)
void | setCountedBy(java.lang.String countedBy)
void | setCountedDate(java.util.Date countedDate)
void | setDescription(java.lang.String description)
void | setDiffcount(java.math.BigDecimal diffcount)
void | setInQualityCheckingQty(java.math.BigDecimal inQualityCheckingQty)
void | setLocation(java.lang.String location)
void | setNewLocation(java.lang.String newLocation)
void | setNewOnhand(java.math.BigDecimal newOnhand)
void | setOldAvgCost(java.math.BigDecimal oldAvgCost)
void | setOldOnloanQty(java.math.BigDecimal oldOnloanQty)
void | setOldSip(java.math.BigDecimal oldSip)
void | setOldStadCost(java.math.BigDecimal oldStadCost)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(PhysicalInventoryPK pk)
void | setStartDate(java.util.Date startDate)
void | setSystemOnhand(java.math.BigDecimal systemOnhand)
void | setTagNumber(java.lang.String tagNumber)
void | setTotalNewOnhand(java.math.BigDecimal totalNewOnhand)
void | setUnit(java.lang.String unit)
void | setWorkInProcessQty(java.math.BigDecimal workInProcessQty)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PK

public static final java.lang.String ORDER_BY_PK
See Also:
Constant Field Values

ORDER_BY_STARTDATE

public static final java.lang.String ORDER_BY_STARTDATE
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_TAGNUMBER

public static final java.lang.String ORDER_BY_TAGNUMBER
See Also:
Constant Field Values

ORDER_BY_LOCATION

public static final java.lang.String ORDER_BY_LOCATION
See Also:
Constant Field Values

ORDER_BY_SYSTEMONHAND

public static final java.lang.String ORDER_BY_SYSTEMONHAND
See Also:
Constant Field Values

ORDER_BY_NEWONHAND

public static final java.lang.String ORDER_BY_NEWONHAND
See Also:
Constant Field Values

ORDER_BY_DIFFCOUNT

public static final java.lang.String ORDER_BY_DIFFCOUNT
See Also:
Constant Field Values

ORDER_BY_COMMITTED

public static final java.lang.String ORDER_BY_COMMITTED
See Also:
Constant Field Values

ORDER_BY_AVGCOST

public static final java.lang.String ORDER_BY_AVGCOST
See Also:
Constant Field Values

ORDER_BY_COUNTEDBY

public static final java.lang.String ORDER_BY_COUNTEDBY
See Also:
Constant Field Values

ORDER_BY_COUNTEDDATE

public static final java.lang.String ORDER_BY_COUNTEDDATE
See Also:
Constant Field Values

ORDER_BY_WORKINPROCESSQTY

public static final java.lang.String ORDER_BY_WORKINPROCESSQTY
See Also:
Constant Field Values

ORDER_BY_INQUALITYCHECKINGQTY

public static final java.lang.String ORDER_BY_INQUALITYCHECKINGQTY
See Also:
Constant Field Values

ORDER_BY_oldSip

public static final java.lang.String ORDER_BY_oldSip
See Also:
Constant Field Values

ORDER_BY_oldOnloanQty

public static final java.lang.String ORDER_BY_oldOnloanQty
See Also:
Constant Field Values

ORDER_BY_oldAvgCost

public static final java.lang.String ORDER_BY_oldAvgCost
See Also:
Constant Field Values

ORDER_BY_oldStadCost

public static final java.lang.String ORDER_BY_oldStadCost
See Also:
Constant Field Values
Constructor Detail

PhysicalInventoryListResult

public PhysicalInventoryListResult()
Method Detail

setPk

public void setPk(PhysicalInventoryPK pk)

setStartDate

public void setStartDate(java.util.Date startDate)

setPartNumber

public void setPartNumber(java.lang.String partNumber)

setPartType

public void setPartType(java.lang.String partType)

setUnit

public void setUnit(java.lang.String unit)

setDescription

public void setDescription(java.lang.String description)

setLocation

public void setLocation(java.lang.String location)

setSystemOnhand

public void setSystemOnhand(java.math.BigDecimal systemOnhand)

setNewOnhand

public void setNewOnhand(java.math.BigDecimal newOnhand)

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

setCountedBy

public void setCountedBy(java.lang.String countedBy)

setCountedDate

public void setCountedDate(java.util.Date countedDate)

getPk

public PhysicalInventoryPK getPk()

getStartDate

public java.util.Date getStartDate()

getPartNumber

public java.lang.String getPartNumber()

getPartType

public java.lang.String getPartType()

getUnit

public java.lang.String getUnit()

getDescription

public java.lang.String getDescription()

getLocation

public java.lang.String getLocation()

getSystemOnhand

public java.math.BigDecimal getSystemOnhand()

getNewOnhand

public java.math.BigDecimal getNewOnhand()

getAvgCost

public java.math.BigDecimal getAvgCost()

getCountedBy

public java.lang.String getCountedBy()

getCountedDate

public java.util.Date getCountedDate()

isCommitted

public boolean isCommitted()

setCommitted

public void setCommitted(boolean committed)

getDiffcount

public java.math.BigDecimal getDiffcount()

setDiffcount

public void setDiffcount(java.math.BigDecimal diffcount)

getNewLocation

public java.lang.String getNewLocation()

setNewLocation

public void setNewLocation(java.lang.String newLocation)

getInQualityCheckingQty

public java.math.BigDecimal getInQualityCheckingQty()

setInQualityCheckingQty

public void setInQualityCheckingQty(java.math.BigDecimal inQualityCheckingQty)

getWorkInProcessQty

public java.math.BigDecimal getWorkInProcessQty()

setWorkInProcessQty

public void setWorkInProcessQty(java.math.BigDecimal workInProcessQty)

getTagNumber

public java.lang.String getTagNumber()

setTagNumber

public void setTagNumber(java.lang.String tagNumber)

getOldAvgCost

public java.math.BigDecimal getOldAvgCost()

setOldAvgCost

public void setOldAvgCost(java.math.BigDecimal oldAvgCost)

getOldOnloanQty

public java.math.BigDecimal getOldOnloanQty()

setOldOnloanQty

public void setOldOnloanQty(java.math.BigDecimal oldOnloanQty)

getOldSip

public java.math.BigDecimal getOldSip()

setOldSip

public void setOldSip(java.math.BigDecimal oldSip)

getOldStadCost

public java.math.BigDecimal getOldStadCost()

setOldStadCost

public void setOldStadCost(java.math.BigDecimal oldStadCost)

getTotalNewOnhand

public java.math.BigDecimal getTotalNewOnhand()

setTotalNewOnhand

public void setTotalNewOnhand(java.math.BigDecimal totalNewOnhand)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PhysicalInventoryListTotalResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PhysicalInventoryListTotalResult

java.lang.Object
    extended by  bb.common.PhysicalInventoryListTotalResult
All Implemented Interfaces:
java.io.Serializable
public class PhysicalInventoryListTotalResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PhysicalInventoryListTotalResult()
Method Summary
java.math.BigDecimal | getTotNewCost()
java.math.BigDecimal | getTotNewOnhand()
java.math.BigDecimal | getTotSystemCost()
java.math.BigDecimal | getTotSystemOnhand()
void | setTotNewCost(java.math.BigDecimal totNewCost)
void | setTotNewOnhand(java.math.BigDecimal totNewOnhand)
void | setTotSystemCost(java.math.BigDecimal totSystemCost)
void | setTotSystemOnhand(java.math.BigDecimal totSystemOnhand)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PhysicalInventoryListTotalResult

public PhysicalInventoryListTotalResult()
Method Detail

getTotSystemOnhand

public java.math.BigDecimal getTotSystemOnhand()

setTotSystemOnhand

public void setTotSystemOnhand(java.math.BigDecimal totSystemOnhand)

getTotNewOnhand

public java.math.BigDecimal getTotNewOnhand()

setTotNewOnhand

public void setTotNewOnhand(java.math.BigDecimal totNewOnhand)

getTotSystemCost

public java.math.BigDecimal getTotSystemCost()

setTotSystemCost

public void setTotSystemCost(java.math.BigDecimal totSystemCost)

getTotNewCost

public java.math.BigDecimal getTotNewCost()

setTotNewCost

public void setTotNewCost(java.math.BigDecimal totNewCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PhysicalInventoryListWithAppDataResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PhysicalInventoryListWithAppDataResult

java.lang.Object
    extended by  bb.common.PhysicalInventoryListResult
        extended by  bb.common.PhysicalInventoryListWithAppDataResult
All Implemented Interfaces:
java.io.Serializable
public class PhysicalInventoryListWithAppDataResult
extends PhysicalInventoryListResult
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_APPDAMAGED
static java.lang.String | ORDER_BY_APPNORMAL
static java.lang.String | ORDER_BY_APPOBSOLETE
static java.lang.String | ORDER_BY_APPOTHER
static java.lang.String | ORDER_BY_APPSLUGGISH
static java.lang.String | ORDER_BY_MODELNUMBER
static java.lang.String | ORDER_BY_NEWAPPDAMAGED
static java.lang.String | ORDER_BY_NEWAPPNORMAL
static java.lang.String | ORDER_BY_NEWAPPOBSOLETE
static java.lang.String | ORDER_BY_NEWAPPOTHER
static java.lang.String | ORDER_BY_NEWAPPSLUGGISH
Fields inherited from class bb.common.PhysicalInventoryListResult
ORDER_BY_AVGCOST, ORDER_BY_COMMITTED, ORDER_BY_COUNTEDBY, ORDER_BY_COUNTEDDATE, ORDER_BY_DIFFCOUNT, ORDER_BY_INQUALITYCHECKINGQTY, ORDER_BY_LOCATION, ORDER_BY_NEWONHAND, ORDER_BY_oldAvgCost, ORDER_BY_oldOnloanQty, ORDER_BY_oldSip, ORDER_BY_oldStadCost, ORDER_BY_PARTNUMBER, ORDER_BY_PK, ORDER_BY_STARTDATE, ORDER_BY_SYSTEMONHAND, ORDER_BY_TAGNUMBER, ORDER_BY_WORKINPROCESSQTY
Constructor Summary
PhysicalInventoryListWithAppDataResult()
Method Summary
java.util.HashMap | getCustomProperties()
java.lang.String | getModelNumber()
java.math.BigDecimal | getNewTotal()
java.math.BigDecimal | getOverageQty()
java.math.BigDecimal | getOverageTotal()
java.math.BigDecimal | getShortageQty()
java.math.BigDecimal | getShortageTotal()
java.math.BigDecimal | getSystemTotal()
void | setCustomProperties(java.util.HashMap customProperties)
void | setModelNumber(java.lang.String modelNumber)
void | setNewTotal(java.math.BigDecimal newTotal)
void | setOverageQty(java.math.BigDecimal overageQty)
void | setOverageTotal(java.math.BigDecimal overageTotal)
void | setShortageQty(java.math.BigDecimal shortageQty)
void | setShortageTotal(java.math.BigDecimal shortageTotal)
void | setSystemTotal(java.math.BigDecimal systemTotal)
Methods inherited from class bb.common.PhysicalInventoryListResult
getAvgCost, getCountedBy, getCountedDate, getDescription, getDiffcount, getInQualityCheckingQty, getLocation, getNewLocation, getNewOnhand, getOldAvgCost, getOldOnloanQty, getOldSip, getOldStadCost, getPartNumber, getPartType, getPk, getStartDate, getSystemOnhand, getTagNumber, getTotalNewOnhand, getUnit, getWorkInProcessQty, isCommitted, setAvgCost, setCommitted, setCountedBy, setCountedDate, setDescription, setDiffcount, setInQualityCheckingQty, setLocation, setNewLocation, setNewOnhand, setOldAvgCost, setOldOnloanQty, setOldSip, setOldStadCost, setPartNumber, setPartType, setPk, setStartDate, setSystemOnhand, setTagNumber, setTotalNewOnhand, setUnit, setWorkInProcessQty
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_APPNORMAL

public static final java.lang.String ORDER_BY_APPNORMAL
See Also:
Constant Field Values

ORDER_BY_APPOBSOLETE

public static final java.lang.String ORDER_BY_APPOBSOLETE
See Also:
Constant Field Values

ORDER_BY_APPDAMAGED

public static final java.lang.String ORDER_BY_APPDAMAGED
See Also:
Constant Field Values

ORDER_BY_APPSLUGGISH

public static final java.lang.String ORDER_BY_APPSLUGGISH
See Also:
Constant Field Values

ORDER_BY_APPOTHER

public static final java.lang.String ORDER_BY_APPOTHER
See Also:
Constant Field Values

ORDER_BY_MODELNUMBER

public static final java.lang.String ORDER_BY_MODELNUMBER
See Also:
Constant Field Values

ORDER_BY_NEWAPPNORMAL

public static final java.lang.String ORDER_BY_NEWAPPNORMAL
See Also:
Constant Field Values

ORDER_BY_NEWAPPOBSOLETE

public static final java.lang.String ORDER_BY_NEWAPPOBSOLETE
See Also:
Constant Field Values

ORDER_BY_NEWAPPDAMAGED

public static final java.lang.String ORDER_BY_NEWAPPDAMAGED
See Also:
Constant Field Values

ORDER_BY_NEWAPPSLUGGISH

public static final java.lang.String ORDER_BY_NEWAPPSLUGGISH
See Also:
Constant Field Values

ORDER_BY_NEWAPPOTHER

public static final java.lang.String ORDER_BY_NEWAPPOTHER
See Also:
Constant Field Values
Constructor Detail

PhysicalInventoryListWithAppDataResult

public PhysicalInventoryListWithAppDataResult()
Method Detail

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getSystemTotal

public java.math.BigDecimal getSystemTotal()

setSystemTotal

public void setSystemTotal(java.math.BigDecimal systemTotal)

getCustomProperties

public java.util.HashMap getCustomProperties()

setCustomProperties

public void setCustomProperties(java.util.HashMap customProperties)

getNewTotal

public java.math.BigDecimal getNewTotal()

setNewTotal

public void setNewTotal(java.math.BigDecimal newTotal)

getOverageQty

public java.math.BigDecimal getOverageQty()

setOverageQty

public void setOverageQty(java.math.BigDecimal overageQty)

getOverageTotal

public java.math.BigDecimal getOverageTotal()

setOverageTotal

public void setOverageTotal(java.math.BigDecimal overageTotal)

getShortageQty

public java.math.BigDecimal getShortageQty()

setShortageQty

public void setShortageQty(java.math.BigDecimal shortageQty)

getShortageTotal

public java.math.BigDecimal getShortageTotal()

setShortageTotal

public void setShortageTotal(java.math.BigDecimal shortageTotal)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PhysicalInventoryPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PhysicalInventoryPK

java.lang.Object
    extended by  bb.common.PhysicalInventoryPK
All Implemented Interfaces:
java.io.Serializable
public class PhysicalInventoryPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PhysicalInventoryPK()
default constructor
PhysicalInventoryPK(java.lang.Integer workSheetNumber, java.lang.Integer pageNumber, java.lang.Integer rowNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Integer | getPageNumber()
java.lang.Integer | getRowNumber()
java.lang.Integer | getWorkSheetNumber()
int | hashCode()
void | setPageNumber(java.lang.Integer pageNumber)
void | setRowNumber(java.lang.Integer rowNumber)
void | setWorkSheetNumber(java.lang.Integer workSheetNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PhysicalInventoryPK

public PhysicalInventoryPK(java.lang.Integer workSheetNumber,
                           java.lang.Integer pageNumber,
                           java.lang.Integer rowNumber)
full constructor

PhysicalInventoryPK

public PhysicalInventoryPK()
default constructor

Method Detail

getWorkSheetNumber

public java.lang.Integer getWorkSheetNumber()

setWorkSheetNumber

public void setWorkSheetNumber(java.lang.Integer workSheetNumber)

getPageNumber

public java.lang.Integer getPageNumber()

setPageNumber

public void setPageNumber(java.lang.Integer pageNumber)

getRowNumber

public java.lang.Integer getRowNumber()

setRowNumber

public void setRowNumber(java.lang.Integer rowNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PhysicalInventoryStatusVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PhysicalInventoryStatusVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PhysicalInventoryStatusVO
All Implemented Interfaces:
java.io.Serializable
public class PhysicalInventoryStatusVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CREATEDATE
static java.lang.String | ORDER_BY_CREATOR
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_TOTALPAGES
static java.lang.String | ORDER_BY_WORKSHEETNUMBER
Constructor Summary
PhysicalInventoryStatusVO()
Method Summary
java.util.Date | getCreateDate()
java.lang.String | getCreator()
java.lang.String | getDescription()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getStatus()
int | getTotalPages()
java.lang.Integer | getWorkSheetNumber()
boolean | isCycleCount()
void | setCreateDate(java.util.Date createDate)
void | setCreator(java.lang.String creator)
void | setCycleCount(boolean cycleCount)
void | setDescription(java.lang.String description)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setStatus(java.lang.String status)
void | setTotalPages(int totalPages)
void | setWorkSheetNumber(java.lang.Integer workSheetNumber)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_WORKSHEETNUMBER

public static final java.lang.String ORDER_BY_WORKSHEETNUMBER
See Also:
Constant Field Values

ORDER_BY_TOTALPAGES

public static final java.lang.String ORDER_BY_TOTALPAGES
See Also:
Constant Field Values

ORDER_BY_CREATEDATE

public static final java.lang.String ORDER_BY_CREATEDATE
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_CREATOR

public static final java.lang.String ORDER_BY_CREATOR
See Also:
Constant Field Values
Constructor Detail

PhysicalInventoryStatusVO

public PhysicalInventoryStatusVO()
Method Detail

getCreateDate

public java.util.Date getCreateDate()

setCreateDate

public void setCreateDate(java.util.Date createDate)

getCreator

public java.lang.String getCreator()

setCreator

public void setCreator(java.lang.String creator)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getTotalPages

public int getTotalPages()

setTotalPages

public void setTotalPages(int totalPages)

getWorkSheetNumber

public java.lang.Integer getWorkSheetNumber()

setWorkSheetNumber

public void setWorkSheetNumber(java.lang.Integer workSheetNumber)

isCycleCount

public boolean isCycleCount()

setCycleCount

public void setCycleCount(boolean cycleCount)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PhysicalInventoryVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PhysicalInventoryVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PhysicalInventoryVO
All Implemented Interfaces:
java.io.Serializable
public class PhysicalInventoryVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PhysicalInventoryVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getActive()
java.math.BigDecimal | getAverageCost()
java.lang.String | getCountedBy()
java.util.Date | getCountedDate()
java.math.BigDecimal | getDiffCount()
java.math.BigDecimal | getInQualityCheckingQty()
java.lang.String | getLocate()
java.lang.String | getMn()
java.lang.String | getNewLocation()
java.math.BigDecimal | getNewOnhand()
java.math.BigDecimal | getOnhand()
java.math.BigDecimal | getOnloanQty()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.util.Date | getPhysicalInventoryDate()
PhysicalInventoryPK | getPk()
java.math.BigDecimal | getShipInProcessQty()
java.math.BigDecimal | getStandardCost()
java.lang.String | getTagNumber()
java.math.BigDecimal | getTotalNewOnhand()
java.math.BigDecimal | getWorkInProcessQty()
int | hashCode()
boolean | isCommitted()
boolean | isMadeGL()
void | setActive(java.lang.String active)
void | setAverageCost(java.math.BigDecimal averageCost)
void | setCommitted(boolean committed)
void | setCountedBy(java.lang.String countedBy)
void | setCountedDate(java.util.Date countedDate)
void | setDiffCount(java.math.BigDecimal diffCount)
void | setInQualityCheckingQty(java.math.BigDecimal inQualityCheckingQty)
void | setLocate(java.lang.String locate)
void | setMadeGL(boolean madeGL)
void | setMn(java.lang.String mn)
void | setNewLocation(java.lang.String newLocation)
void | setNewOnhand(java.math.BigDecimal newOnhand)
void | setOnhand(java.math.BigDecimal onhand)
void | setOnloanQty(java.math.BigDecimal onloanQty)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPhysicalInventoryDate(java.util.Date physicalInventoryDate)
void | setPk(PhysicalInventoryPK pk)
void | setShipInProcessQty(java.math.BigDecimal shipInProcessQty)
void | setStandardCost(java.math.BigDecimal standardCost)
void | setTagNumber(java.lang.String tagNumber)
void | setTotalNewOnhand(java.math.BigDecimal totalNewOnhand)
void | setWorkInProcessQty(java.math.BigDecimal workInProcessQty)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PhysicalInventoryVO

public PhysicalInventoryVO()
Method Detail

getPk

public PhysicalInventoryPK getPk()

setPk

public void setPk(PhysicalInventoryPK pk)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPhysicalInventoryDate

public java.util.Date getPhysicalInventoryDate()

setPhysicalInventoryDate

public void setPhysicalInventoryDate(java.util.Date physicalInventoryDate)

getMn

public java.lang.String getMn()

setMn

public void setMn(java.lang.String mn)

getActive

public java.lang.String getActive()

setActive

public void setActive(java.lang.String active)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getOnhand

public java.math.BigDecimal getOnhand()

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

getNewOnhand

public java.math.BigDecimal getNewOnhand()

setNewOnhand

public void setNewOnhand(java.math.BigDecimal newOnhand)

getCountedBy

public java.lang.String getCountedBy()

setCountedBy

public void setCountedBy(java.lang.String countedBy)

getCountedDate

public java.util.Date getCountedDate()

setCountedDate

public void setCountedDate(java.util.Date countedDate)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

isCommitted

public boolean isCommitted()

setCommitted

public void setCommitted(boolean committed)

getDiffCount

public java.math.BigDecimal getDiffCount()

setDiffCount

public void setDiffCount(java.math.BigDecimal diffCount)

getNewLocation

public java.lang.String getNewLocation()

setNewLocation

public void setNewLocation(java.lang.String newLocation)

getInQualityCheckingQty

public java.math.BigDecimal getInQualityCheckingQty()

setInQualityCheckingQty

public void setInQualityCheckingQty(java.math.BigDecimal inQualityCheckingQty)

getWorkInProcessQty

public java.math.BigDecimal getWorkInProcessQty()

setWorkInProcessQty

public void setWorkInProcessQty(java.math.BigDecimal workInProcessQty)

getTagNumber

public java.lang.String getTagNumber()

setTagNumber

public void setTagNumber(java.lang.String tagNumber)

getOnloanQty

public java.math.BigDecimal getOnloanQty()

setOnloanQty

public void setOnloanQty(java.math.BigDecimal onloanQty)

getShipInProcessQty

public java.math.BigDecimal getShipInProcessQty()

setShipInProcessQty

public void setShipInProcessQty(java.math.BigDecimal shipInProcessQty)

getAverageCost

public java.math.BigDecimal getAverageCost()

setAverageCost

public void setAverageCost(java.math.BigDecimal averageCost)

getStandardCost

public java.math.BigDecimal getStandardCost()

setStandardCost

public void setStandardCost(java.math.BigDecimal standardCost)

getTotalNewOnhand

public java.math.BigDecimal getTotalNewOnhand()

setTotalNewOnhand

public void setTotalNewOnhand(java.math.BigDecimal totalNewOnhand)

isMadeGL

public boolean isMadeGL()

setMadeGL

public void setMadeGL(boolean madeGL)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


P-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M N O P Q R S T U V W X Y Z

P

P - Static variable in class bb.common.Constant.Prefix
PA - Static variable in class bb.common.Constant.Prefix
PA_ACCOUNT - Static variable in class bb.common.BizTarget
PA_VARIANCE_ACCOUNT - Static variable in class bb.common.BizTarget
PACKING_BOX - Static variable in class bb.common.BizTarget
PACKING_BOX_ALREADY_EXIST - Static variable in class bb.common.BIZReason
PACKING_BOX_BOX_INFO_NOT_COMPLETED - Static variable in class bb.common.BIZReason
PACKING_BOX_IS_NOT_EMPTY - Static variable in class bb.common.BIZReason
PACKING_BOX_ITEM - Static variable in class bb.common.BizTarget
PACKING_BOX_ITEM_ALREADY_EXIST - Static variable in class bb.common.BIZReason
PACKING_BOX_ITEM_NOT_EXIST - Static variable in class bb.common.BIZReason
PACKING_BOX_NOT_EXIST - Static variable in class bb.common.BIZReason
PackingBoxItemListResult - Class in bb.common
PackingBoxItemListResult() - Constructor for class bb.common.PackingBoxItemListResult
PackingBoxItemPK - Class in bb.common
PackingBoxItemPK(String, Integer, String, String) - Constructor for class bb.common.PackingBoxItemPK
full constructor
PackingBoxItemPK() - Constructor for class bb.common.PackingBoxItemPK
default constructor
PackingBoxItemVO - Class in bb.common
PackingBoxItemVO() - Constructor for class bb.common.PackingBoxItemVO
PackingBoxPK - Class in bb.common
PackingBoxPK(String, Integer) - Constructor for class bb.common.PackingBoxPK
full constructor
PackingBoxPK() - Constructor for class bb.common.PackingBoxPK
default constructor
PackingBoxSalesOrderItemAgent - Class in bb.common
PackingBoxSalesOrderItemAgent() - Constructor for class bb.common.PackingBoxSalesOrderItemAgent
PackingBoxSalesOrderItemResult - Class in bb.common
PackingBoxSalesOrderItemResult() - Constructor for class bb.common.PackingBoxSalesOrderItemResult
PackingBoxVO - Class in bb.common
PackingBoxVO() - Constructor for class bb.common.PackingBoxVO
default constructor
pageCount - Static variable in class bb.common.Constant
PAID - Static variable in class bb.common.Constant.CheckType
PAID_RECEIVED - Static variable in class bb.common.Constant.CheckType
PAID_TOTAL_IS_NOT_EAUAL - Static variable in class bb.common.BIZReason
PAIDDATE - Static variable in class bb.common.Constant.DateType
PAR_ALREADY_EXIST - Static variable in class bb.common.BIZReason
PAR_ITEM_ALREADY_EXIST - Static variable in class bb.common.BIZReason
PAR_ITEM_DOC - Static variable in class bb.common.Constant.MiscDocType
PAR_ITEM_NOT_EXIST - Static variable in class bb.common.BIZReason
PAR_NOT_EXIST - Static variable in class bb.common.BIZReason
parseNumber(String) - Static method in class bb.common.BB2Util
PART - Static variable in class bb.common.BizTarget
Part - Static variable in class bb.common.Constant.EngineeringSharingImportDataType
PART - Static variable in class bb.common.Constant.PrintTemplateType
PART_ADDRESS_ID - Static variable in class bb.common.LabelTemplateConstant
PART_ADDRESS_NAME - Static variable in class bb.common.LabelTemplateConstant
PART_ALREADY_BOM - Static variable in class bb.common.BIZReason
PART_ALREADY_EXIST - Static variable in class bb.common.BIZReason
PART_ALREADY_USED - Static variable in class bb.common.BIZReason
PART_CATALOG - Static variable in class bb.common.BizTarget
PART_CATALOG_ALREADY_EXIST - Static variable in class bb.common.BIZReason
PART_CATALOG_NOT_EXIST - Static variable in class bb.common.BIZReason
PART_CATEGORY_NOT_EXIST - Static variable in class bb.common.BIZReason
PART_CERTIFICATE - Static variable in class bb.common.BizTarget
PART_CERTIFICATE_ALREADY_EXIST - Static variable in class bb.common.BIZReason
PART_CERTIFICATE_NOT_EXIST - Static variable in class bb.common.BIZReason
PART_CLASS - Static variable in class bb.common.BizTarget
PART_CLASS_ALREADY_EXIST - Static variable in class bb.common.BIZReason
PART_CLASS_IS_USED - Static variable in class bb.common.BIZReason
PART_CLASS_NEED_BE_A_LETTER - Static variable in class bb.common.BIZReason
PART_CLASS_NOT_EXIST - Static variable in class bb.common.BIZReason
PART_DATE - Static variable in class bb.common.LabelTemplateConstant
PART_DESCRIPTION - Static variable in class bb.common.BizTarget
PART_DESCRIPTION - Static variable in class bb.common.LabelTemplateConstant
PART_DISCOUNT - Static variable in class bb.common.BizTarget
PART_DOC_ACTION - Static variable in class bb.common.DocumentAction.PartDocAction
PART_EXIST - Static variable in class bb.common.BIZReason
PART_FROM_NOT_EXIST - Static variable in class bb.common.BIZReason
PART_HAS_BEAN_RETURN - Static variable in class bb.common.BIZReason
PART_HAS_DRAWING - Static variable in class bb.common.BIZReason
PART_HAS_MANUFACTURER - Static variable in class bb.common.BIZReason
PART_HAS_MATERIAL - Static variable in class bb.common.BIZReason
PART_HAS_ONDEMAND - Static variable in class bb.common.BIZReason
PART_HAS_ONHAND - Static variable in class bb.common.BIZReason
PART_HAS_ONLOAN - Static variable in class bb.common.BIZReason
PART_HAS_ONORDER - Static variable in class bb.common.BIZReason
PART_HAS_PICTURE - Static variable in class bb.common.BIZReason
PART_HAS_QA - Static variable in class bb.common.BIZReason
PART_HAS_SIP - Static variable in class bb.common.BIZReason
PART_HAS_SIT - Static variable in class bb.common.BIZReason
PART_HAS_VENDOR - Static variable in class bb.common.BIZReason
PART_HAS_WIP - Static variable in class bb.common.BIZReason
PART_HAS_WORK_INSTRUCTION - Static variable in class bb.common.BIZReason
PART_IMPORT_FROM_OTHER_COMPANY_CANT_EDIT_REV - Static variable in class bb.common.BIZReason
PART_IN_QA - Static variable in class bb.common.BizTarget
PART_IN_QA_NOT_EXIST - Static variable in class bb.common.BIZReason
PART_IN_SIP - Static variable in class bb.common.BIZReason
PART_INSPECTION - Static variable in class bb.common.BizTarget
PART_INVENTORY - Static variable in class bb.common.BizTarget
PART_INVENTORY_NOT_ENOUGH - Static variable in class bb.common.BIZReason
PART_IS_BOM - Static variable in class bb.common.BIZReason
PART_IS_DELETED - Static variable in class bb.common.BIZReason
PART_IS_LOCKED - Static variable in class bb.common.BIZReason
PART_IS_NOT_BACKFLUSH_MATERIAL - Static variable in class bb.common.BIZReason
PART_ISSUE - Static variable in class bb.common.BizTarget
PART_LOCATION - Static variable in class bb.common.LabelTemplateConstant
PART_MANUFACTURER - Static variable in class bb.common.BizTarget
PART_MATERIAL - Static variable in class bb.common.BizTarget
PART_MATERIAL_ALREADY_EXIST - Static variable in class bb.common.BIZReason
PART_MATERIAL_NOT_EXIST - Static variable in class bb.common.BIZReason
PART_NO - Static variable in class bb.common.Constant.InventoryWorkSheetOrderBy
PART_NOT_BOM - Static variable in class bb.common.BIZReason
PART_NOT_EXIST - Static variable in class bb.common.BIZReason
PART_NOT_SALEABLE - Static variable in class bb.common.BIZReason
PART_NOT_SAME_BETWEEN_TWO_ORDERS - Static variable in class bb.common.BIZReason
PART_NUMBER_ALREADY_IN_USE - Static variable in class bb.common.BIZReason
PART_NUMBER_FOR_CATEGORY_IS_USED_UP - Static variable in class bb.common.BIZReason
PART_NUMBER_IS_USED_UP - Static variable in class bb.common.BIZReason
PART_NUMBER_MAX_LENGTH_CAN_NOT_SAMLLER_THAN - Static variable in class bb.common.BIZReason
PART_ONHAND - Static variable in class bb.common.BizTarget
PART_ONHAND_NOT_ENOUGH - Static variable in class bb.common.BIZReason
PART_ONHAND_NOT_EXIST - Static variable in class bb.common.BIZReason
PART_OPERATOR - Static variable in class bb.common.LabelTemplateConstant
PART_PART_NUMBER - Static variable in class bb.common.LabelTemplateConstant
PART_PICTURE - Static variable in class bb.common.BizTarget
PART_PICTURE - Static variable in class bb.common.Constant.MiscDocType
PART_PICTURE_EXIST - Static variable in class bb.common.BIZReason
PART_PICTURE_WITHOUT_LENGTH - Static variable in class bb.common.BIZReason
PART_QTY_RECEIVED_OR_SHIPPED - Static variable in class bb.common.LabelTemplateConstant
PART_RELATED_DOC - Static variable in class bb.common.LabelTemplateConstant
PART_SECURITY_LEVEL - Static variable in class bb.common.BizTarget
PART_SECURITY_LEVEL_EXIST - Static variable in class bb.common.BIZReason
PART_SECURITY_LEVEL_NOT_EXIST - Static variable in class bb.common.BIZReason
PART_SECURITY_LEVEL_USED_IN_PART - Static variable in class bb.common.BIZReason
PART_SHARE_COMPANY - Static variable in class bb.common.BizTarget
PART_SHARE_COMPANY_ID_DOES_NOT_EXIST - Static variable in class bb.common.BIZReason
PART_STILL_IS_HOLD - Static variable in class bb.common.BIZReason
PART_TPYE_IS_USING - Static variable in class bb.common.BIZReason
PART_TRACEABLE - Static variable in class bb.common.BizTarget
PART_TYPE - Static variable in class bb.common.BizTarget
PART_TYPE_ALREADY_EXIST - Static variable in class bb.common.BIZReason
PART_TYPE_NOT_EXIST - Static variable in class bb.common.BIZReason
PART_UNIT - Static variable in class bb.common.LabelTemplateConstant
PART_UOM - Static variable in class bb.common.BizTarget
PART_USE_TYPE_IS_EXIST - Static variable in class bb.common.BIZReason
PART_USE_TYPE_NOT_EXIST - Static variable in class bb.common.BIZReason
PART_USED_IN_API - Static variable in class bb.common.BIZReason
PART_USED_IN_ARI - Static variable in class bb.common.BIZReason
PART_USED_IN_BOM - Static variable in class bb.common.BIZReason
PART_USED_IN_ECN - Static variable in class bb.common.BIZReason
PART_USED_IN_ECR - Static variable in class bb.common.BIZReason
PART_USED_IN_EDC - Static variable in class bb.common.BIZReason
PART_USED_IN_LNI - Static variable in class bb.common.BIZReason
PART_USED_IN_POI - Static variable in class bb.common.BIZReason
PART_USED_IN_QTI - Static variable in class bb.common.BIZReason
PART_USED_IN_RFQI - Static variable in class bb.common.BIZReason
PART_USED_IN_RMAI - Static variable in class bb.common.BIZReason
PART_USED_IN_RTVI - Static variable in class bb.common.BIZReason
PART_USED_IN_SOI - Static variable in class bb.common.BIZReason
PART_USED_IN_SWSI - Static variable in class bb.common.BIZReason
PART_USED_IN_TOI - Static variable in class bb.common.BIZReason
PART_USED_IN_WOI - Static variable in class bb.common.BIZReason
PART_VENDOR - Static variable in class bb.common.BizTarget
PART_VENDOR_EXIST - Static variable in class bb.common.BIZReason
PART_VENDOR_NOT_EXIST - Static variable in class bb.common.BIZReason
PART_WITH_NCR - Static variable in class bb.common.BIZReason
PART_WITHOUT_INVENTORY - Static variable in class bb.common.BIZReason
PartBasicInfo - Class in bb.common
PartBasicInfo() - Constructor for class bb.common.PartBasicInfo
PartBasicInfo(PartPK) - Constructor for class bb.common.PartBasicInfo
PartBasicInfoWithNewEngGroup - Class in bb.common
PartBasicInfoWithNewEngGroup() - Constructor for class bb.common.PartBasicInfoWithNewEngGroup
PartBasicInfoWithNewListPrice - Class in bb.common
PartBasicInfoWithNewListPrice() - Constructor for class bb.common.PartBasicInfoWithNewListPrice
PartCatagoryPK - Class in bb.common
PartCatagoryPK() - Constructor for class bb.common.PartCatagoryPK
PartCatagoryPK(String, String) - Constructor for class bb.common.PartCatagoryPK
PartCatagoryVO - Class in bb.common
PartCatagoryVO() - Constructor for class bb.common.PartCatagoryVO
PartCatagoryVO(PartCatagoryPK, String) - Constructor for class bb.common.PartCatagoryVO
PARTCATALOG_NOT_EXIST - Static variable in class bb.common.BIZReason
PartCatalogAuditResult - Class in bb.common
PartCatalogAuditResult() - Constructor for class bb.common.PartCatalogAuditResult
PartCatalogPK - Class in bb.common
PartCatalogPK(String, String, String) - Constructor for class bb.common.PartCatalogPK
full constructor
PartCatalogPK() - Constructor for class bb.common.PartCatalogPK
default constructor
PartCatalogVO - Class in bb.common
PartCatalogVO(PartCatalogPK, String, String, String) - Constructor for class bb.common.PartCatalogVO
full constructor
PartCatalogVO() - Constructor for class bb.common.PartCatalogVO
default constructor
PartCertificateListResult - Class in bb.common
PartCertificateListResult() - Constructor for class bb.common.PartCertificateListResult
PartCertificateVO - Class in bb.common
PartCertificateVO() - Constructor for class bb.common.PartCertificateVO
default constructor
PartClassInfoResult - Class in bb.common
PartClassInfoResult() - Constructor for class bb.common.PartClassInfoResult
PartClassVO - Class in bb.common
PartClassVO() - Constructor for class bb.common.PartClassVO
PartCostVarianceListResult - Class in bb.common
PartCostVarianceListResult() - Constructor for class bb.common.PartCostVarianceListResult
PartDescription - Static variable in class bb.common.Constant.EngineeringSharingImportDataType
PartDescriptionPK - Class in bb.common
PartDescriptionPK(String, String, String) - Constructor for class bb.common.PartDescriptionPK
full constructor
PartDescriptionPK() - Constructor for class bb.common.PartDescriptionPK
default constructor
PartDescriptionVO - Class in bb.common
PartDescriptionVO() - Constructor for class bb.common.PartDescriptionVO
PartDiscountPK - Class in bb.common
PartDiscountPK() - Constructor for class bb.common.PartDiscountPK
PartDiscountVO - Class in bb.common
PartDiscountVO() - Constructor for class bb.common.PartDiscountVO
PartDocumentPK - Class in bb.common
PartDocumentPK() - Constructor for class bb.common.PartDocumentPK
default constructor
PartDocumentVO - Class in bb.common
PartDocumentVO() - Constructor for class bb.common.PartDocumentVO
default constructor
PartDueAddressListResult - Class in bb.common
PartDueAddressListResult() - Constructor for class bb.common.PartDueAddressListResult
PARTDWF_NOT_FOUND - Static variable in class bb.common.BIZReason
PartDwfAgent - Class in bb.common
PartDwfAgent() - Constructor for class bb.common.PartDwfAgent
PartDwfPK - Class in bb.common
PartDwfPK() - Constructor for class bb.common.PartDwfPK
default constructor
PartDwfVO - Class in bb.common
PartDwfVO() - Constructor for class bb.common.PartDwfVO
PartDwfWithPartInfoResult - Class in bb.common
PartDwfWithPartInfoResult() - Constructor for class bb.common.PartDwfWithPartInfoResult
PARTDWG_NOT_FOUND - Static variable in class bb.common.BIZReason
PartDwgAgent - Class in bb.common
PartDwgAgent() - Constructor for class bb.common.PartDwgAgent
PartDwgPK - Class in bb.common
PartDwgPK(String, String, String, String, String) - Constructor for class bb.common.PartDwgPK
full constructor
PartDwgPK() - Constructor for class bb.common.PartDwgPK
default constructor
PartDwgVO - Class in bb.common
PartDwgVO(PartDwgPK, String, Date, long, String) - Constructor for class bb.common.PartDwgVO
full constructor
PartDwgVO() - Constructor for class bb.common.PartDwgVO
default constructor
PartDwgVO(PartDwgPK, String, long, String) - Constructor for class bb.common.PartDwgVO
minimal constructor
PartDwgWithPartInfoResult - Class in bb.common
PartDwgWithPartInfoResult() - Constructor for class bb.common.PartDwgWithPartInfoResult
PartExportInfo - Class in bb.common
PartExportInfo() - Constructor for class bb.common.PartExportInfo
Partial - Static variable in class bb.common.Constant.Status
PartInMrpListResult - Class in bb.common
PartInMrpListResult() - Constructor for class bb.common.PartInMrpListResult
PartInQAAgent - Class in bb.common
PartInQAAgent() - Constructor for class bb.common.PartInQAAgent
PartInQAResult - Class in bb.common
PartInQAResult() - Constructor for class bb.common.PartInQAResult
PartInQAVO - Class in bb.common
PartInQAVO() - Constructor for class bb.common.PartInQAVO
PartInspectionPK - Class in bb.common
PartInspectionPK() - Constructor for class bb.common.PartInspectionPK
PartInspectionResult - Class in bb.common
PartInspectionResult() - Constructor for class bb.common.PartInspectionResult
PartInspectionVO - Class in bb.common
PartInspectionVO() - Constructor for class bb.common.PartInspectionVO
PartInventoryVO - Class in bb.common
PartInventoryVO() - Constructor for class bb.common.PartInventoryVO
PartInWipForIDListResult - Class in bb.common
PartInWipForIDListResult() - Constructor for class bb.common.PartInWipForIDListResult
PartIssuedListResult - Class in bb.common
PartIssuedListResult() - Constructor for class bb.common.PartIssuedListResult
PartIssuedVO - Class in bb.common
PartIssuedVO() - Constructor for class bb.common.PartIssuedVO
PartIssueTotalResult - Class in bb.common
PartIssueTotalResult() - Constructor for class bb.common.PartIssueTotalResult
PartManufacturerAgent - Class in bb.common
PartManufacturerAgent() - Constructor for class bb.common.PartManufacturerAgent
PartManufacturerPK - Class in bb.common
PartManufacturerPK(String, String, Short) - Constructor for class bb.common.PartManufacturerPK
full constructor
PartManufacturerPK() - Constructor for class bb.common.PartManufacturerPK
default constructor
PartManufacturerVO - Class in bb.common
PartManufacturerVO() - Constructor for class bb.common.PartManufacturerVO
PartManufacturerVO(PartPK) - Constructor for class bb.common.PartManufacturerVO
PartMaterialBomListResult - Class in bb.common
PartMaterialBomListResult() - Constructor for class bb.common.PartMaterialBomListResult
PartMaterialListResult - Class in bb.common
PartMaterialListResult() - Constructor for class bb.common.PartMaterialListResult
PartMaterialReportAgent - Class in bb.common
PartMaterialReportAgent() - Constructor for class bb.common.PartMaterialReportAgent
PartMaterialVO - Class in bb.common
PartMaterialVO() - Constructor for class bb.common.PartMaterialVO
default constructor
PartMaterialWhereUsedItemResult - Class in bb.common
PartMaterialWhereUsedItemResult() - Constructor for class bb.common.PartMaterialWhereUsedItemResult
PartMaterialWhereUsedResult - Class in bb.common
PartMaterialWhereUsedResult() - Constructor for class bb.common.PartMaterialWhereUsedResult
PartMRPVO - Class in bb.common
PartMRPVO() - Constructor for class bb.common.PartMRPVO
PartNumberFormat - Static variable in class bb.common.Constant
PartNumberGenerateRuleVO - Class in bb.common
PartNumberGenerateRuleVO() - Constructor for class bb.common.PartNumberGenerateRuleVO
PartNumberGenerateRuleVO(String) - Constructor for class bb.common.PartNumberGenerateRuleVO
PartOnhandAndCostResult - Class in bb.common
PartOnhandAndCostResult() - Constructor for class bb.common.PartOnhandAndCostResult
PartOnHandAuditAgent - Class in bb.common
PartOnHandAuditAgent() - Constructor for class bb.common.PartOnHandAuditAgent
PartOnHandAuditResult - Class in bb.common
PartOnHandAuditResult() - Constructor for class bb.common.PartOnHandAuditResult
PartOnhandCostVO - Class in bb.common
PartOnhandCostVO() - Constructor for class bb.common.PartOnhandCostVO
default constructor
PartOnhandPK - Class in bb.common
PartOnhandPK() - Constructor for class bb.common.PartOnhandPK
PartOnhandPK(String, String, String) - Constructor for class bb.common.PartOnhandPK
PartOnhandResult - Class in bb.common
PartOnhandResult() - Constructor for class bb.common.PartOnhandResult
PartOnhandVO - Class in bb.common
PartOnhandVO() - Constructor for class bb.common.PartOnhandVO
PartOnhandWithAverageCostResult - Class in bb.common
PartOnhandWithAverageCostResult() - Constructor for class bb.common.PartOnhandWithAverageCostResult
PartOnHandWithMfgInfoResult - Class in bb.common
PartOnHandWithMfgInfoResult() - Constructor for class bb.common.PartOnHandWithMfgInfoResult
PartOnHandWithPartBasicInfoResult - Class in bb.common
PartOnHandWithPartBasicInfoResult() - Constructor for class bb.common.PartOnHandWithPartBasicInfoResult
PartPictureVO - Class in bb.common
PartPictureVO(String, byte[], String, Date) - Constructor for class bb.common.PartPictureVO
full constructor
PartPictureVO() - Constructor for class bb.common.PartPictureVO
default constructor
PartPictureVO(String) - Constructor for class bb.common.PartPictureVO
minimal constructor
PartPK - Class in bb.common
PartPK(String, String) - Constructor for class bb.common.PartPK
full constructor
PartPK() - Constructor for class bb.common.PartPK
default constructor
PartReceivedListResult - Class in bb.common
PartReceivedListResult() - Constructor for class bb.common.PartReceivedListResult
PartReceivedVO - Class in bb.common
PartReceivedVO() - Constructor for class bb.common.PartReceivedVO
default constructor
PartSecurityLevelVO - Class in bb.common
PartSecurityLevelVO() - Constructor for class bb.common.PartSecurityLevelVO
PartsToDeleteResult - Class in bb.common
PartsToDeleteResult() - Constructor for class bb.common.PartsToDeleteResult
PARTTIME - Static variable in class bb.common.Constant.EmployeeStatus
PartToAuditFlagResult - Class in bb.common
PartToAuditFlagResult() - Constructor for class bb.common.PartToAuditFlagResult
PartTraceableCategoryPK - Class in bb.common
PartTraceableCategoryPK(String, String, Short) - Constructor for class bb.common.PartTraceableCategoryPK
full constructor
PartTraceableCategoryPK() - Constructor for class bb.common.PartTraceableCategoryPK
default constructor
PartTraceableCategoryVO - Class in bb.common
PartTraceableCategoryVO() - Constructor for class bb.common.PartTraceableCategoryVO
PartTraceableInfoResult - Class in bb.common
PartTraceableInfoResult() - Constructor for class bb.common.PartTraceableInfoResult
PartTraceableListResult - Class in bb.common
PartTraceableListResult() - Constructor for class bb.common.PartTraceableListResult
PartTraceableResult - Class in bb.common
PartTraceableResult() - Constructor for class bb.common.PartTraceableResult
PartTraceableSpecPK - Class in bb.common
PartTraceableSpecPK(String, String, Short) - Constructor for class bb.common.PartTraceableSpecPK
full constructor
PartTraceableSpecPK() - Constructor for class bb.common.PartTraceableSpecPK
default constructor
PartTraceableSpecVO - Class in bb.common
PartTraceableSpecVO() - Constructor for class bb.common.PartTraceableSpecVO
PartTrackingPK - Class in bb.common
PartTrackingPK() - Constructor for class bb.common.PartTrackingPK
PartTrackingPK(String, String, String) - Constructor for class bb.common.PartTrackingPK
PartTrackingVO - Class in bb.common
PartTrackingVO() - Constructor for class bb.common.PartTrackingVO
PartTypeVO - Class in bb.common
PartTypeVO() - Constructor for class bb.common.PartTypeVO
PartUnitPK - Class in bb.common
PartUnitPK() - Constructor for class bb.common.PartUnitPK
PartUnitPK(PartPK, String) - Constructor for class bb.common.PartUnitPK
PartUnitPK(String, String, String) - Constructor for class bb.common.PartUnitPK
PartUnitVO - Class in bb.common
PartUnitVO() - Constructor for class bb.common.PartUnitVO
partUsedInfoResult - Class in bb.common
partUsedInfoResult() - Constructor for class bb.common.partUsedInfoResult
PartUseTypeVO - Class in bb.common
PartUseTypeVO() - Constructor for class bb.common.PartUseTypeVO
PartUseTypeVO(String, String, String, String) - Constructor for class bb.common.PartUseTypeVO
PartVendorPK - Class in bb.common
PartVendorPK(String, String, Byte) - Constructor for class bb.common.PartVendorPK
full constructor
PartVendorPK() - Constructor for class bb.common.PartVendorPK
default constructor
PartVendorVO - Class in bb.common
PartVendorVO() - Constructor for class bb.common.PartVendorVO
PartVendorVO(PartPK) - Constructor for class bb.common.PartVendorVO
PartVO - Class in bb.common
PartVO() - Constructor for class bb.common.PartVO
PartWhereUsedItemResult - Class in bb.common
PartWhereUsedItemResult() - Constructor for class bb.common.PartWhereUsedItemResult
PartWhereUsedResult - Class in bb.common
PartWhereUsedResult() - Constructor for class bb.common.PartWhereUsedResult
PartWithExcessiveInventoryListResult - Class in bb.common
PartWithExcessiveInventoryListResult() - Constructor for class bb.common.PartWithExcessiveInventoryListResult
PartWithInventoryInfoListResult - Class in bb.common
PartWithInventoryInfoListResult() - Constructor for class bb.common.PartWithInventoryInfoListResult
PartWithManufacturerInfoResult - Class in bb.common
PartWithManufacturerInfoResult() - Constructor for class bb.common.PartWithManufacturerInfoResult
PartWithOnhandDetailInfoResult - Class in bb.common
PartWithOnhandDetailInfoResult() - Constructor for class bb.common.PartWithOnhandDetailInfoResult
PartWithOnhandsVO - Class in bb.common
PartWithOnhandsVO() - Constructor for class bb.common.PartWithOnhandsVO
PartWithOnLoanQtyListResult - Class in bb.common
PartWithOnLoanQtyListResult() - Constructor for class bb.common.PartWithOnLoanQtyListResult
PartWithoutLocateResult - Class in bb.common
PartWithoutLocateResult() - Constructor for class bb.common.PartWithoutLocateResult
PartWithoutLocateResult(PartPK) - Constructor for class bb.common.PartWithoutLocateResult
PartWithQAQtyListResult - Class in bb.common
PartWithQAQtyListResult() - Constructor for class bb.common.PartWithQAQtyListResult
PartWithQtyListResult - Class in bb.common
PartWithQtyListResult() - Constructor for class bb.common.PartWithQtyListResult
PartWithSipQtyListResult - Class in bb.common
PartWithSipQtyListResult() - Constructor for class bb.common.PartWithSipQtyListResult
PartWithSITQtyListResult - Class in bb.common
PartWithSITQtyListResult() - Constructor for class bb.common.PartWithSITQtyListResult
PartWithSTOQtyListResult - Class in bb.common
PartWithSTOQtyListResult() - Constructor for class bb.common.PartWithSTOQtyListResult
PartWithWipQtyListResult - Class in bb.common
PartWithWipQtyListResult() - Constructor for class bb.common.PartWithWipQtyListResult
PASSWORD_IS_TOO_SHORT - Static variable in class bb.common.BIZReason
PasswordPolicyAgent - Class in bb.common
PasswordPolicyAgent() - Constructor for class bb.common.PasswordPolicyAgent
PAUSE - Static variable in class bb.common.Constant.Status
pauseOperatingInstructions(OperatingInstructionsVO) - Method in interface bb.common.box.ManufacturingBox
PAY_DATE_SHOULD_BE_AFTER_GL_LOCKED_DATE - Static variable in class bb.common.BIZReason
PAYABLE_METHOD - Static variable in class bb.common.BizTarget
PayableCheckRunItemPK - Class in bb.common
PayableCheckRunItemPK(String, String) - Constructor for class bb.common.PayableCheckRunItemPK
full constructor
PayableCheckRunItemPK() - Constructor for class bb.common.PayableCheckRunItemPK
default constructor
PAYABLEGL - Static variable in class bb.common.Constant.GLType
PayableMethodVO - Class in bb.common
PayableMethodVO() - Constructor for class bb.common.PayableMethodVO
PAYMENT - Static variable in class bb.common.BizTarget
PAYMENT_RUN - Static variable in class bb.common.BizTarget
PAYMENT_RUN_ALREADY_COMMITTED - Static variable in class bb.common.BIZReason
PAYMENT_RUN_ALREADY_EXIST - Static variable in class bb.common.BIZReason
PAYMENT_RUN_NOT_EXIST - Static variable in class bb.common.BIZReason
PAYMENT_VARIANCE_OVER_THAN_GA_ZERO_CAN_NOT_CLOSE - Static variable in class bb.common.BIZReason
PaymentAgent - Class in bb.common
PaymentAgent() - Constructor for class bb.common.PaymentAgent
PaymentHistoryVO - Class in bb.common
PaymentHistoryVO() - Constructor for class bb.common.PaymentHistoryVO
PaymentInvoicesResult - Class in bb.common
PaymentInvoicesResult() - Constructor for class bb.common.PaymentInvoicesResult
PaymentRunItemTotalResult - Class in bb.common
PaymentRunItemTotalResult() - Constructor for class bb.common.PaymentRunItemTotalResult
PaymentVO - Class in bb.common
PaymentVO() - Constructor for class bb.common.PaymentVO
PDF - Static variable in class bb.common.Constant.FileExt
Pending - Static variable in class bb.common.Constant.Status
PERDAY - Static variable in class bb.common.Constant.PageCycleCount
PermanentClosed - Static variable in class bb.common.Constant.Status
PermissionDescriptionPK - Class in bb.common
PermissionDescriptionPK() - Constructor for class bb.common.PermissionDescriptionPK
default constructor
PermissionDescriptionVO - Class in bb.common
PermissionDescriptionVO() - Constructor for class bb.common.PermissionDescriptionVO
PermissionException - Exception in bb.common
PermissionException() - Constructor for exception bb.common.PermissionException
PermissionException(Exception) - Constructor for exception bb.common.PermissionException
PermissionException(String) - Constructor for exception bb.common.PermissionException
permissionId - Variable in class bb.common.PermissionListResult
PermissionListResult - Class in bb.common
PermissionListResult() - Constructor for class bb.common.PermissionListResult
PermissionMethodPK - Class in bb.common
PermissionMethodPK(String, Long) - Constructor for class bb.common.PermissionMethodPK
full constructor
PermissionMethodPK() - Constructor for class bb.common.PermissionMethodPK
default constructor
PermissionMethodVO - Class in bb.common
PermissionMethodVO(PermissionMethodPK) - Constructor for class bb.common.PermissionMethodVO
full constructor
PermissionMethodVO() - Constructor for class bb.common.PermissionMethodVO
default constructor
PermissionVO - Class in bb.common
PermissionVO() - Constructor for class bb.common.PermissionVO
default constructor
PERMONTH - Static variable in class bb.common.Constant.PageCycleCount
PERWEEK - Static variable in class bb.common.Constant.PageCycleCount
PERYEAR - Static variable in class bb.common.Constant.PageCycleCount
PF - Static variable in class bb.common.Constant.Prefix
PfReceiverItemPK - Class in bb.common
PfReceiverItemPK() - Constructor for class bb.common.PfReceiverItemPK
PfReceiverItemPK(String, String, String) - Constructor for class bb.common.PfReceiverItemPK
PfReceiverItemVO - Class in bb.common
PfReceiverItemVO() - Constructor for class bb.common.PfReceiverItemVO
PfReceiverItemWithNumberPK - Class in bb.common
PfReceiverItemWithNumberPK() - Constructor for class bb.common.PfReceiverItemWithNumberPK
PfReceiverItemWithNumberPK(PfReceiverItemPK, String) - Constructor for class bb.common.PfReceiverItemWithNumberPK
PfReceiverVO - Class in bb.common
PfReceiverVO() - Constructor for class bb.common.PfReceiverVO
PHYSICAL_WORK_SHEET - Static variable in class bb.common.BizTarget
PHYSICAL_WORK_SHEET_ALREADY_CLOSED - Static variable in class bb.common.BIZReason
PHYSICAL_WORK_SHEET_HAS_EXIST - Static variable in class bb.common.BIZReason
PHYSICAL_WORK_SHEET_NOT_EXIST - Static variable in class bb.common.BIZReason
PHYSICAL_WORK_SHEET_PAGE_NUMBER - Static variable in class bb.common.BizTarget
PHYSICAL_WORK_SHEET_PAGE_NUMBER_HAS_EXIST - Static variable in class bb.common.BIZReason
PHYSICAL_WORK_SHEET_PAGE_NUMBER_NOT_EXIST - Static variable in class bb.common.BIZReason
PhysicalInventoryListResult - Class in bb.common
PhysicalInventoryListResult() - Constructor for class bb.common.PhysicalInventoryListResult
PhysicalInventoryListTotalResult - Class in bb.common
PhysicalInventoryListTotalResult() - Constructor for class bb.common.PhysicalInventoryListTotalResult
PhysicalInventoryListWithAppDataResult - Class in bb.common
PhysicalInventoryListWithAppDataResult() - Constructor for class bb.common.PhysicalInventoryListWithAppDataResult
PhysicalInventoryPK - Class in bb.common
PhysicalInventoryPK(Integer, Integer, Integer) - Constructor for class bb.common.PhysicalInventoryPK
full constructor
PhysicalInventoryPK() - Constructor for class bb.common.PhysicalInventoryPK
default constructor
PhysicalInventoryStatusVO - Class in bb.common
PhysicalInventoryStatusVO() - Constructor for class bb.common.PhysicalInventoryStatusVO
PhysicalInventoryVO - Class in bb.common
PhysicalInventoryVO() - Constructor for class bb.common.PhysicalInventoryVO
PICKLIST - Static variable in class bb.common.Constant.PrintTemplateType
PickList_For_BOM - Static variable in class bb.common.Constant.PrintTemplateType
PickList_For_SO - Static variable in class bb.common.Constant.PrintTemplateType
PICTURE_NOT_FOUND - Static variable in class bb.common.BIZReason
PLA - Static variable in class bb.common.Constant.AmountType
PLANNING - Static variable in class bb.common.Configure.Module
PlanningBox - Interface in bb.common.box
PLB - Static variable in class bb.common.Constant.AmountType
PLEASE_CHANGE_CONDITION_THEN_SEARCH_AGAIN - Static variable in class bb.common.BIZReason
PLEASE_CHECK_WORK_INSTRUCTION_SEQUENCE - Static variable in class bb.common.BIZReason
PLEASE_CHECK_WORK_INSTRUCTION_SEQUENCE_OR_WORK_CENTER - Static variable in class bb.common.BIZReason
PLEASE_FILL_IN_UOM - Static variable in class bb.common.BIZReason
PLEASE_INPUT_A_OPEN_WORK_ORDER - Static variable in class bb.common.BIZReason
PLEASE_LOGIN_FIRST - Static variable in class bb.common.BIZReason
PO - Static variable in class bb.common.Constant.NoticeType
PO - Static variable in class bb.common.Constant.Prefix
PO - Static variable in class bb.common.Constant.PrintTemplateType
PO - Static variable in class bb.common.Constant.TermsConditonType
PO2POAgent - Class in bb.common
PO2POAgent() - Constructor for class bb.common.PO2POAgent
PO2SOExchange - Class in bb.common
PO2SOExchange() - Constructor for class bb.common.PO2SOExchange
PO2SOExchangeItem - Class in bb.common
PO2SOExchangeItem() - Constructor for class bb.common.PO2SOExchangeItem
PO2SOExchangeItemManufacturer - Class in bb.common
PO2SOExchangeItemManufacturer() - Constructor for class bb.common.PO2SOExchangeItemManufacturer
PO_ACTION - Static variable in class bb.common.Constant.NoticeAction
PO_DOC - Static variable in class bb.common.Constant.MiscDocType
PO_MAIL - Static variable in class bb.common.Constant.CustomerVendorMailType
PO_NNMBER - Static variable in class bb.common.BizTarget
POAndWOStatusResult - Class in bb.common
POAndWOStatusResult() - Constructor for class bb.common.POAndWOStatusResult
PODATE - Static variable in class bb.common.Constant.DateType
POForWISeqAgent - Class in bb.common
POForWISeqAgent(WorkOrderItemPK) - Constructor for class bb.common.POForWISeqAgent
PointOfSaleVO - Class in bb.common
PointOfSaleVO() - Constructor for class bb.common.PointOfSaleVO
POItemByRefDoc1ListResult - Class in bb.common
POItemByRefDoc1ListResult() - Constructor for class bb.common.POItemByRefDoc1ListResult
PoMessageItemPK - Class in bb.common
PoMessageItemPK() - Constructor for class bb.common.PoMessageItemPK
PoMessageItemPK(String, String) - Constructor for class bb.common.PoMessageItemPK
PoMessageItemVO - Class in bb.common
PoMessageItemVO() - Constructor for class bb.common.PoMessageItemVO
default constructor
PoMessageListResult - Class in bb.common
PoMessageListResult() - Constructor for class bb.common.PoMessageListResult
PoMessageVO - Class in bb.common
PoMessageVO() - Constructor for class bb.common.PoMessageVO
POPackage - Static variable in class bb.common.Constant.Package
PoReceiverByDateSummaryResult - Class in bb.common
PoReceiverByDateSummaryResult() - Constructor for class bb.common.PoReceiverByDateSummaryResult
POReceiverItemListResult - Class in bb.common
POReceiverItemListResult() - Constructor for class bb.common.POReceiverItemListResult
PORT_DEFAULT - Static variable in class bb.common.BizBoxServer
POS_ACCOUNTSRECEIVABLE - Static variable in class bb.common.LabelTemplateConstant
POS_AVGCOSTTOTAL - Static variable in class bb.common.LabelTemplateConstant
POS_CHANGE - Static variable in class bb.common.LabelTemplateConstant
POS_CHECKNUMBER - Static variable in class bb.common.LabelTemplateConstant
POS_CREDITCARDNUMBER - Static variable in class bb.common.LabelTemplateConstant
POS_CUSTOMERID - Static variable in class bb.common.LabelTemplateConstant
POS_DISCTOTAL - Static variable in class bb.common.LabelTemplateConstant
POS_DUTYFREENUMBER - Static variable in class bb.common.LabelTemplateConstant
POS_ELECSIGNATURE - Static variable in class bb.common.LabelTemplateConstant
POS_FREIGHT - Static variable in class bb.common.LabelTemplateConstant
POS_ITEM_AVGCOST - Static variable in class bb.common.LabelTemplateConstant
POS_ITEM_DESCRIPTION - Static variable in class bb.common.LabelTemplateConstant
POS_ITEM_DISCOUNT - Static variable in class bb.common.LabelTemplateConstant
POS_ITEM_DUTYFREE - Static variable in class bb.common.LabelTemplateConstant
POS_ITEM_NETTOTAL - Static variable in class bb.common.LabelTemplateConstant
POS_ITEM_NUMBER - Static variable in class bb.common.LabelTemplateConstant
POS_ITEM_PARTNUMBER - Static variable in class bb.common.LabelTemplateConstant
POS_ITEM_PARTTYPE - Static variable in class bb.common.LabelTemplateConstant
POS_ITEM_PRICE - Static variable in class bb.common.LabelTemplateConstant
POS_ITEM_PROFIT - Static variable in class bb.common.LabelTemplateConstant
POS_ITEM_PROFITBYSTDCOST - Static variable in class bb.common.LabelTemplateConstant
POS_ITEM_PROFITPERCENT - Static variable in class bb.common.LabelTemplateConstant
POS_ITEM_PROFITPERCENTBYSTDCOST - Static variable in class bb.common.LabelTemplateConstant
POS_ITEM_QUANTITY - Static variable in class bb.common.LabelTemplateConstant
POS_ITEM_REALTIMEONHAND - Static variable in class bb.common.LabelTemplateConstant
POS_ITEM_STDCOST - Static variable in class bb.common.LabelTemplateConstant
POS_ITEM_SUBTOTAL - Static variable in class bb.common.LabelTemplateConstant
POS_ITEM_TAXTOTAL - Static variable in class bb.common.LabelTemplateConstant
POS_NETTOTAL - Static variable in class bb.common.LabelTemplateConstant
POS_NOT_EXIST - Static variable in class bb.common.BIZReason
POS_PAYABLEMETHOD - Static variable in class bb.common.LabelTemplateConstant
POS_PROFITPERCENTTOTAL - Static variable in class bb.common.LabelTemplateConstant
POS_PROFITPERCENTTOTALBYSTDCOST - Static variable in class bb.common.LabelTemplateConstant
POS_PROFITTOTAL - Static variable in class bb.common.LabelTemplateConstant
POS_PROFITTOTALBYSTDCOST - Static variable in class bb.common.LabelTemplateConstant
POS_RAO_NUMBER - Static variable in class bb.common.LabelTemplateConstant
POS_REALRECEIVABLE - Static variable in class bb.common.LabelTemplateConstant
POS_SALESDATE - Static variable in class bb.common.LabelTemplateConstant
POS_SALESMAN - Static variable in class bb.common.LabelTemplateConstant
POS_SETTING - Static variable in class bb.common.BizTarget
POS_TAX - Static variable in class bb.common.LabelTemplateConstant
POS_TAXRATE - Static variable in class bb.common.LabelTemplateConstant
POS_TAXTOTAL - Static variable in class bb.common.LabelTemplateConstant
PosRefdocVO - Class in bb.common
PosRefdocVO(String, String, String, String, BigDecimal, String, Date, Integer, short) - Constructor for class bb.common.PosRefdocVO
full constructor
PosRefdocVO() - Constructor for class bb.common.PosRefdocVO
default constructor
POST_CHECK - Static variable in class bb.common.BizTarget
POStatisticsResult - Class in bb.common
POStatisticsResult() - Constructor for class bb.common.POStatisticsResult
postCheck(PostCheckAgent) - Method in interface bb.common.box.AccountingBox
PostCheckAgent - Class in bb.common
PostCheckAgent() - Constructor for class bb.common.PostCheckAgent
POSTED_GL_CAN_NOT_BE_CANCEL_APPROVE - Static variable in class bb.common.BIZReason
postGeneralLedger(String, String, List<String>) - Method in interface bb.common.box.AccountingBox
POSurveyReportAgent - Class in bb.common
POSurveyReportAgent() - Constructor for class bb.common.POSurveyReportAgent
POSurveyReportItemPK - Class in bb.common
POSurveyReportItemPK() - Constructor for class bb.common.POSurveyReportItemPK
POSurveyReportItemPK(String, String) - Constructor for class bb.common.POSurveyReportItemPK
POSurveyReportItemVO - Class in bb.common
POSurveyReportItemVO() - Constructor for class bb.common.POSurveyReportItemVO
POSurveyReportVO - Class in bb.common
POSurveyReportVO() - Constructor for class bb.common.POSurveyReportVO
PosZipCodeTaxPK - Class in bb.common
PosZipCodeTaxPK() - Constructor for class bb.common.PosZipCodeTaxPK
PosZipCodeTaxPK(String, String) - Constructor for class bb.common.PosZipCodeTaxPK
PosZipCodeTaxVO - Class in bb.common
PosZipCodeTaxVO() - Constructor for class bb.common.PosZipCodeTaxVO
PR - Static variable in class bb.common.Constant.Prefix
PR - Static variable in class bb.common.Constant.PrintTemplateType
PR_Packing_BOX - Static variable in class bb.common.Constant.PrintTemplateType
PrepayAgent - Class in bb.common
PrepayAgent() - Constructor for class bb.common.PrepayAgent
Prepayed - Static variable in class bb.common.Constant.Status
PrepaymentWireTransferAgent - Class in bb.common
PrepaymentWireTransferAgent() - Constructor for class bb.common.PrepaymentWireTransferAgent
PrepayPaymentAgent - Class in bb.common
PrepayPaymentAgent() - Constructor for class bb.common.PrepayPaymentAgent
PREVENTIVE_ACTION_REQUEST - Static variable in class bb.common.BizTarget
PREVENTIVE_ACTION_REQUEST_ITEM - Static variable in class bb.common.BizTarget
PreventiveActionRequestItemVO - Class in bb.common
PreventiveActionRequestItemVO() - Constructor for class bb.common.PreventiveActionRequestItemVO
default constructor
PreventiveActionRequestVO - Class in bb.common
PreventiveActionRequestVO() - Constructor for class bb.common.PreventiveActionRequestVO
default constructor
print(Object) - Static method in class bb.common.BB2Util
Debug tool print
PRINT_TEMPLATE - Static variable in class bb.common.BizTarget
PrintLogoVO - Class in bb.common
PrintLogoVO() - Constructor for class bb.common.PrintLogoVO
default constructor
PrintTemplateVO - Class in bb.common
PrintTemplateVO() - Constructor for class bb.common.PrintTemplateVO
PROFIT_LOSS - Static variable in class bb.common.Constant.CategoryReportType
PROFIT_LOSS - Static variable in class bb.common.Constant.MiscDocType
PROFIT_LOSS_PRE - Static variable in class bb.common.Constant.CategoryReportType
ProfitAndLossAccountsResult - Class in bb.common
ProfitAndLossAccountsResult() - Constructor for class bb.common.ProfitAndLossAccountsResult
ProfitLossStatementItemResult - Class in bb.common
ProfitLossStatementItemResult() - Constructor for class bb.common.ProfitLossStatementItemResult
ProfitLossStatementResult - Class in bb.common
ProfitLossStatementResult() - Constructor for class bb.common.ProfitLossStatementResult
PROFORMA_INVOICE - Static variable in class bb.common.BizTarget
PROFORMA_INVOICE_HAS_EXIST - Static variable in class bb.common.BIZReason
PROFORMA_INVOICE_ITEM_NOT_EXIST - Static variable in class bb.common.BIZReason
PROFORMA_INVOICE_NOT_EXIST - Static variable in class bb.common.BIZReason
PROFORMA_INVOICE_NOT_OPEN - Static variable in class bb.common.BIZReason
PROFORMA_RECEIVER - Static variable in class bb.common.BizTarget
PROFORMA_RECEIVER_HAS_EXIST - Static variable in class bb.common.BIZReason
PROFORMA_RECEIVER_NOT_EXIST - Static variable in class bb.common.BIZReason
ProformaInvoiceItemListResult - Class in bb.common
ProformaInvoiceItemListResult() - Constructor for class bb.common.ProformaInvoiceItemListResult
ProformaInvoiceItemManufacturerPK - Class in bb.common
ProformaInvoiceItemManufacturerPK() - Constructor for class bb.common.ProformaInvoiceItemManufacturerPK
ProformaInvoiceItemManufacturerPK(String, String, Short) - Constructor for class bb.common.ProformaInvoiceItemManufacturerPK
ProformaInvoiceItemManufacturerVO - Class in bb.common
ProformaInvoiceItemManufacturerVO() - Constructor for class bb.common.ProformaInvoiceItemManufacturerVO
ProformaInvoiceItemPK - Class in bb.common
ProformaInvoiceItemPK(String, String, String) - Constructor for class bb.common.ProformaInvoiceItemPK
full constructor
ProformaInvoiceItemPK() - Constructor for class bb.common.ProformaInvoiceItemPK
default constructor
ProformaInvoiceItemVO - Class in bb.common
ProformaInvoiceItemVO(ProformaInvoiceItemPK, String, String, String, String, String, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, String, String, Date, Date, String, String, String, String, String, String, String, String, String, BigDecimal, BigDecimal, BigDecimal, BigDecimal, String, BigDecimal, BigDecimal, String, String, String, String, String, String) - Constructor for class bb.common.ProformaInvoiceItemVO
full constructor
ProformaInvoiceItemVO() - Constructor for class bb.common.ProformaInvoiceItemVO
default constructor
ProformaInvoiceItemVO(ProformaInvoiceItemPK, String, String, String, String, String, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, String, String, Date, Date, String, String, String, String, String, String, String, String, String, BigDecimal, BigDecimal, BigDecimal, BigDecimal, String, BigDecimal, BigDecimal, String, String, String, String) - Constructor for class bb.common.ProformaInvoiceItemVO
minimal constructor
ProformaInvoiceListResult - Class in bb.common
ProformaInvoiceListResult() - Constructor for class bb.common.ProformaInvoiceListResult
ProformaInvoiceVO - Class in bb.common
ProformaInvoiceVO(String, int, String, String, String, String, String, String, Date, Date, String, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, String, String, String, Date, String, Date, String, String, String, String, Date, String, String, String, String, String, String, String, String, String, Date, Date, String, String, String, String, String, String, String, String, String, BigDecimal, Date, Date, String, BigDecimal, String, String, int, CustomerVendorAddressInfoVO, CustomerVendorAddressInfoVO, CustomerVendorAddressInfoVO, Set, Set) - Constructor for class bb.common.ProformaInvoiceVO
full constructor
ProformaInvoiceVO() - Constructor for class bb.common.ProformaInvoiceVO
default constructor
ProformaInvoiceVO(String, int, String, String, String, String, String, String, String, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, String, String, String, String, String, String, String, String, Date, String, String, String, String, String, String, String, String, String, Date, Date, String, String, String, String, String, String, String, BigDecimal, Date, Date, String, BigDecimal, String, String, Set, Set) - Constructor for class bb.common.ProformaInvoiceVO
minimal constructor
ProformaReceiverPackingBoxAgent - Class in bb.common
ProformaReceiverPackingBoxAgent() - Constructor for class bb.common.ProformaReceiverPackingBoxAgent
ProformaReceiverPackingBoxItemAgent - Class in bb.common
ProformaReceiverPackingBoxItemAgent() - Constructor for class bb.common.ProformaReceiverPackingBoxItemAgent
ProformaShipper - Static variable in class bb.common.Constant.PrintTemplateType
PROJECT_CLASS - Static variable in class bb.common.BizTarget
ProjectVO - Class in bb.common
ProjectVO() - Constructor for class bb.common.ProjectVO
PROPERTY - Static variable in class bb.common.Constant.DataFilterType
PrPackingBoxItemPK - Class in bb.common
PrPackingBoxItemPK(String, Integer, String, String) - Constructor for class bb.common.PrPackingBoxItemPK
full constructor
PrPackingBoxItemPK() - Constructor for class bb.common.PrPackingBoxItemPK
default constructor
PrPackingBoxItemVO - Class in bb.common
PrPackingBoxItemVO() - Constructor for class bb.common.PrPackingBoxItemVO
PrPackingBoxPK - Class in bb.common
PrPackingBoxPK(String, Integer) - Constructor for class bb.common.PrPackingBoxPK
full constructor
PrPackingBoxPK() - Constructor for class bb.common.PrPackingBoxPK
default constructor
PrPackingBoxVO - Class in bb.common
PrPackingBoxVO() - Constructor for class bb.common.PrPackingBoxVO
default constructor
PrReceiverListResult - Class in bb.common
PrReceiverListResult() - Constructor for class bb.common.PrReceiverListResult
PrReceiverWithQualityListResult - Class in bb.common
PrReceiverWithQualityListResult() - Constructor for class bb.common.PrReceiverWithQualityListResult
PULL_OUT_ON_DEMAND_ERROR - Static variable in class bb.common.BIZReason
pullFromWorkOrderPartDetail(HashSet<PullFromWorkOrderPartDetailAgent>, String) - Method in interface bb.common.box.WarehouseBox
PullFromWorkOrderPartDetailAgent - Class in bb.common
PullFromWorkOrderPartDetailAgent() - Constructor for class bb.common.PullFromWorkOrderPartDetailAgent
PURCHASE_ORDER - Static variable in class bb.common.BizTarget
PURCHASE_ORDER_ALREADY_RECEIVED - Static variable in class bb.common.BIZReason
PURCHASE_ORDER_APPROVAL - Static variable in class bb.common.BizTarget
PURCHASE_ORDER_APPROVAL_ALREADY_EXIST - Static variable in class bb.common.BIZReason
PURCHASE_ORDER_APPROVAL_NOT_EXIST - Static variable in class bb.common.BIZReason
PURCHASE_ORDER_HAS_EXIST - Static variable in class bb.common.BIZReason
PURCHASE_ORDER_ITEM - Static variable in class bb.common.BizTarget
PURCHASE_ORDER_ITEM_ALREADY_RECEIVED_OR_IN_SIT - Static variable in class bb.common.BIZReason
PURCHASE_ORDER_ITEM_HAS_REFERENCE - Static variable in class bb.common.BIZReason
PURCHASE_ORDER_ITEM_MANUFACTURER - Static variable in class bb.common.BizTarget
PURCHASE_ORDER_ITEM_NOT_CONTAINS_THIS_PART - Static variable in class bb.common.BIZReason
PURCHASE_ORDER_ITEM_NOT_EXIST - Static variable in class bb.common.BIZReason
PURCHASE_ORDER_ITEM_STATUS_NOT_OPEN - Static variable in class bb.common.BIZReason
PURCHASE_ORDER_MESSAGE - Static variable in class bb.common.BizTarget
PURCHASE_ORDER_MESSAGE_HAS_EXIST - Static variable in class bb.common.BIZReason
PURCHASE_ORDER_MESSAGE_NOT_EXIST - Static variable in class bb.common.BIZReason
PURCHASE_ORDER_NOT_APPROVED - Static variable in class bb.common.BIZReason
PURCHASE_ORDER_NOT_EXIST - Static variable in class bb.common.BIZReason
PURCHASE_ORDER_NOT_OPEN - Static variable in class bb.common.BIZReason
PURCHASE_WORK_SHEET - Static variable in class bb.common.BizTarget
PURCHASE_WORK_SHEET_HAS_EXIST - Static variable in class bb.common.BIZReason
PURCHASE_WORK_SHEET_ITEM - Static variable in class bb.common.BizTarget
PURCHASE_WORK_SHEET_ITEM_NOT_EXIST - Static variable in class bb.common.BIZReason
PURCHASE_WORK_SHEET_NOT_EXIST - Static variable in class bb.common.BIZReason
PurchaseOnTimeResult - Class in bb.common
PurchaseOnTimeResult() - Constructor for class bb.common.PurchaseOnTimeResult
PURCHASEORDER - Static variable in class bb.common.Constant.OrderType
PurchaseOrderApprovalVO - Class in bb.common
PurchaseOrderApprovalVO() - Constructor for class bb.common.PurchaseOrderApprovalVO
PurchaseOrderBoilerplateVO - Class in bb.common
PurchaseOrderBoilerplateVO(String, String, String) - Constructor for class bb.common.PurchaseOrderBoilerplateVO
full constructor
PurchaseOrderBoilerplateVO() - Constructor for class bb.common.PurchaseOrderBoilerplateVO
default constructor
PurchaseOrderBoilerplateVO(String, String) - Constructor for class bb.common.PurchaseOrderBoilerplateVO
minimal constructor
PurchaseOrderCheckListResult - Class in bb.common
PurchaseOrderCheckListResult() - Constructor for class bb.common.PurchaseOrderCheckListResult
PurchaseOrderContractResult - Class in bb.common
PurchaseOrderContractResult() - Constructor for class bb.common.PurchaseOrderContractResult
PurchaseOrderDocumentVO - Class in bb.common
PurchaseOrderDocumentVO() - Constructor for class bb.common.PurchaseOrderDocumentVO
PurchaseOrderItemListResult - Class in bb.common
PurchaseOrderItemListResult() - Constructor for class bb.common.PurchaseOrderItemListResult
PurchaseOrderItemManufacturerPK - Class in bb.common
PurchaseOrderItemManufacturerPK() - Constructor for class bb.common.PurchaseOrderItemManufacturerPK
PurchaseOrderItemManufacturerVO - Class in bb.common
PurchaseOrderItemManufacturerVO() - Constructor for class bb.common.PurchaseOrderItemManufacturerVO
PurchaseOrderItemPK - Class in bb.common
PurchaseOrderItemPK() - Constructor for class bb.common.PurchaseOrderItemPK
PurchaseOrderItemPK(String, String) - Constructor for class bb.common.PurchaseOrderItemPK
PurchaseOrderItemVO - Class in bb.common
PurchaseOrderItemVO() - Constructor for class bb.common.PurchaseOrderItemVO
PurchaseOrderListResult - Class in bb.common
PurchaseOrderListResult() - Constructor for class bb.common.PurchaseOrderListResult
PurchaseOrderOnOrderResult - Class in bb.common
PurchaseOrderOnOrderResult() - Constructor for class bb.common.PurchaseOrderOnOrderResult
PurchaseOrderOnTimeItemResult - Class in bb.common
PurchaseOrderOnTimeItemResult() - Constructor for class bb.common.PurchaseOrderOnTimeItemResult
PurchaseOrderOnTimeResult - Class in bb.common
PurchaseOrderOnTimeResult() - Constructor for class bb.common.PurchaseOrderOnTimeResult
PurchaseOrderOpenDueListResult - Class in bb.common
PurchaseOrderOpenDueListResult() - Constructor for class bb.common.PurchaseOrderOpenDueListResult
PurchaseOrderVO - Class in bb.common
PurchaseOrderVO() - Constructor for class bb.common.PurchaseOrderVO
PURCHASETAXRATE - Static variable in class bb.common.Constant.TaxType
PurchaseWorkSheetItemPK - Class in bb.common
PurchaseWorkSheetItemPK(String, String, Integer, Integer) - Constructor for class bb.common.PurchaseWorkSheetItemPK
full constructor
PurchaseWorkSheetItemPK() - Constructor for class bb.common.PurchaseWorkSheetItemPK
default constructor
PurchaseWorkSheetItemVO - Class in bb.common
PurchaseWorkSheetItemVO() - Constructor for class bb.common.PurchaseWorkSheetItemVO
PurchaseWorkSheetItemWithRelatedInfoResult - Class in bb.common
PurchaseWorkSheetItemWithRelatedInfoResult() - Constructor for class bb.common.PurchaseWorkSheetItemWithRelatedInfoResult
PurchaseWorkSheetPK - Class in bb.common
PurchaseWorkSheetPK(String, String, Integer) - Constructor for class bb.common.PurchaseWorkSheetPK
full constructor
PurchaseWorkSheetPK() - Constructor for class bb.common.PurchaseWorkSheetPK
default constructor
PurchaseWorkSheetVO - Class in bb.common
PurchaseWorkSheetVO() - Constructor for class bb.common.PurchaseWorkSheetVO
default constructor
PURCHASING - Static variable in class bb.common.Configure.Module
PurchasingBox - Interface in bb.common.box
PurchasingInfoCenterResult - Class in bb.common
PurchasingInfoCenterResult() - Constructor for class bb.common.PurchasingInfoCenterResult
put(String, QtyAndMoney) - Method in class bb.common.BB2QtyAndMoneyMap
put(BigDecimal) - Method in class bb.common.PackingBoxSalesOrderItemAgent
put(String, BigDecimal) - Method in class bb.common.PackingBoxSalesOrderItemAgent
put(BigDecimal) - Method in class bb.common.PackingBoxSalesOrderItemResult
put(String, BigDecimal) - Method in class bb.common.PackingBoxSalesOrderItemResult
putParttoInQA(HashSet<PuttoInQAAgent>, String) - Method in interface bb.common.box.WarehouseBox
putServerClientProperty(String, String) - Method in interface bb.common.box.CompanyBox
PuttoInQAAgent - Class in bb.common
PuttoInQAAgent() - Constructor for class bb.common.PuttoInQAAgent
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M N O P Q R S T U V W X Y Z


PlanningBox

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common.box
Interface PlanningBox

public interface PlanningBox

Method Summary
java.lang.String | addShipList(ShipListAgent agent)
ShipListVO | addShipList(ShipListVO vo)
void | addShipListItem(ShipListItemVO vo)
ShipListOwnerVO | addShipListOwner(ShipListOwnerVO vo)
ShipListOwnerVO | addShipListOwner(java.lang.String ownerName)
void | addShipListOwnerAttribute(ShipListOwnerAttributeVO vo)
java.util.Collection<ShipListOwnerAttributeVO> | constructShipListOwnerAttributes(java.lang.String ownerName, java.util.List customerIdSet, java.util.List vendorIdSet, java.util.List workCenterIdSet)
void | deleteShipList(ShipListVO vo)
void | deleteShipListItem(ShipListItemVO vo)
void | deleteShipListOwner(ShipListOwnerVO vo)
void | deleteShipListOwnerAttribute(ShipListOwnerAttributeVO vo)
java.util.Collection<ShipListOwnerVO> | findAllShipListOwners(int firstIndex, int maxLength)
java.util.Collection<ShipListInfoVO> | findAllShipLists(int firstIndex, int length)
java.util.Collection<SalesOrderListResult> | findSalesOrderListResultsforShipList(java.lang.String soNumberLike, java.lang.String[] customers, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)
ShipListInfoVO | findShipListByShipList(java.lang.String pk)
java.util.Collection<ShipListItemVO> | findShipListItems(java.lang.String shipList, int firstIndex, int maxLength)
java.util.Collection<ShipListOwnerVO> | findShipListOwnersByName(java.lang.String owner, int firstIndex, int maxLength)
java.util.Collection<ShipListInfoVO> | findShipLists(java.lang.String hql, int firstIndex, int maxLength)
java.util.Collection<ShipListInfoVO> | findShipListsById(java.lang.String id, int firstIndex, int length)
java.util.Collection<ShipListInfoVO> | findShipListsByOwner(java.lang.String owner, int firstIndex, int maxLength)
int | getAllShipListOwnersCount()
int | getAllShipListsCount()
int | getSalesOrderListResultsforShipListCount(java.lang.String soNumberLike, java.lang.String[] customers, java.util.Date from, java.util.Date to)
ShipListVO | getShipListByShipListNumber(java.lang.String shipListNumber)
ShipListItemRelatedDocResult | getShipListItemRelatedDocResult(SalesOrderItemPK pk)
int | getShipListItems(java.lang.String shipList)
ShipListOwnerVO | getShipListOwnerByName(java.lang.String pk)
int | getShipListOwnersCountByName(java.lang.String owner)
int | getShipListsCountById(java.lang.String id)
int | getShipListsCountByOwer(java.lang.String owner)
ShipListItemVOResult | initShipListItem(java.lang.String shipListNumber, SalesOrderItemPK itemPk)
java.util.Collection<ShipListItemVOResult> | initSOItemsToshiplist(java.lang.String shipList, java.lang.String ownerName, java.util.Date startDate, java.util.Date endDate, java.util.List salesOrderNumberSet, java.util.List customerIdSet, boolean custIsShipTOID, java.util.List vendorIdSet, java.util.List workCenterIdSet)
boolean | isShipListOwnerExistent(java.lang.String ownerName)
java.lang.String | updateShipList(ShipListVO vo)
void | updateShipListItem(ShipListItemVO vo)
ShipListOwnerVO | updateShipListOwner(ShipListOwnerVO vo)

Method Detail

addShipList

java.lang.String addShipList(ShipListAgent agent)
                             throws java.lang.Exception
Throws:
java.lang.Exception

addShipList

ShipListVO addShipList(ShipListVO vo)
                       throws java.lang.Exception
Throws:
java.lang.Exception

deleteShipList

void deleteShipList(ShipListVO vo)
                    throws java.lang.Exception
Throws:
java.lang.Exception

updateShipList

java.lang.String updateShipList(ShipListVO vo)
                                throws java.lang.Exception
Throws:
java.lang.Exception

initShipListItem

ShipListItemVOResult initShipListItem(java.lang.String shipListNumber,
                                      SalesOrderItemPK itemPk)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

getShipListByShipListNumber

ShipListVO getShipListByShipListNumber(java.lang.String shipListNumber)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

getShipListItemRelatedDocResult

ShipListItemRelatedDocResult getShipListItemRelatedDocResult(SalesOrderItemPK pk)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getAllShipListsCount

int getAllShipListsCount()
                         throws java.lang.Exception
Throws:
java.lang.Exception

findAllShipLists

java.util.Collection<ShipListInfoVO> findAllShipLists(int firstIndex,
                                                      int length)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

findShipListByShipList

ShipListInfoVO findShipListByShipList(java.lang.String pk)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findShipLists

java.util.Collection<ShipListInfoVO> findShipLists(java.lang.String hql,
                                                   int firstIndex,
                                                   int maxLength)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

findShipListsByOwner

java.util.Collection<ShipListInfoVO> findShipListsByOwner(java.lang.String owner,
                                                          int firstIndex,
                                                          int maxLength)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getShipListsCountByOwer

int getShipListsCountByOwer(java.lang.String owner)
                            throws java.lang.Exception
Throws:
java.lang.Exception

getShipListsCountById

int getShipListsCountById(java.lang.String id)
                          throws java.lang.Exception
Throws:
java.lang.Exception

findShipListsById

java.util.Collection<ShipListInfoVO> findShipListsById(java.lang.String id,
                                                       int firstIndex,
                                                       int length)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

addShipListItem

void addShipListItem(ShipListItemVO vo)
                     throws java.lang.Exception
Throws:
java.lang.Exception

deleteShipListItem

void deleteShipListItem(ShipListItemVO vo)
                        throws java.lang.Exception
Throws:
java.lang.Exception

updateShipListItem

void updateShipListItem(ShipListItemVO vo)
                        throws java.lang.Exception
Throws:
java.lang.Exception

addShipListOwner

ShipListOwnerVO addShipListOwner(java.lang.String ownerName)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

addShipListOwner

ShipListOwnerVO addShipListOwner(ShipListOwnerVO vo)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

updateShipListOwner

ShipListOwnerVO updateShipListOwner(ShipListOwnerVO vo)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

deleteShipListOwner

void deleteShipListOwner(ShipListOwnerVO vo)
                         throws java.lang.Exception
Throws:
java.lang.Exception

isShipListOwnerExistent

boolean isShipListOwnerExistent(java.lang.String ownerName)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findAllShipListOwners

java.util.Collection<ShipListOwnerVO> findAllShipListOwners(int firstIndex,
                                                            int maxLength)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getAllShipListOwnersCount

int getAllShipListOwnersCount()
                              throws java.lang.Exception
Throws:
java.lang.Exception

getShipListOwnersCountByName

int getShipListOwnersCountByName(java.lang.String owner)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findShipListOwnersByName

java.util.Collection<ShipListOwnerVO> findShipListOwnersByName(java.lang.String owner,
                                                               int firstIndex,
                                                               int maxLength)
                                                               throws java.lang.Exception
Throws:
java.lang.Exception

addShipListOwnerAttribute

void addShipListOwnerAttribute(ShipListOwnerAttributeVO vo)
                               throws java.lang.Exception
Throws:
java.lang.Exception

deleteShipListOwnerAttribute

void deleteShipListOwnerAttribute(ShipListOwnerAttributeVO vo)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

getShipListOwnerByName

ShipListOwnerVO getShipListOwnerByName(java.lang.String pk)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findShipListItems

java.util.Collection<ShipListItemVO> findShipListItems(java.lang.String shipList,
                                                       int firstIndex,
                                                       int maxLength)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getShipListItems

int getShipListItems(java.lang.String shipList)
                     throws java.lang.Exception
Throws:
java.lang.Exception

initSOItemsToshiplist

java.util.Collection<ShipListItemVOResult> initSOItemsToshiplist(java.lang.String shipList,
                                                                 java.lang.String ownerName,
                                                                 java.util.Date startDate,
                                                                 java.util.Date endDate,
                                                                 java.util.List salesOrderNumberSet,
                                                                 java.util.List customerIdSet,
                                                                 boolean custIsShipTOID,
                                                                 java.util.List vendorIdSet,
                                                                 java.util.List workCenterIdSet)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

constructShipListOwnerAttributes

java.util.Collection<ShipListOwnerAttributeVO> constructShipListOwnerAttributes(java.lang.String ownerName,
                                                                                java.util.List customerIdSet,
                                                                                java.util.List vendorIdSet,
                                                                                java.util.List workCenterIdSet)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findSalesOrderListResultsforShipList

java.util.Collection<SalesOrderListResult> findSalesOrderListResultsforShipList(java.lang.String soNumberLike,
                                                                                java.lang.String[] customers,
                                                                                java.util.Date from,
                                                                                java.util.Date to,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOrderListResultsforShipListCount

int getSalesOrderListResultsforShipListCount(java.lang.String soNumberLike,
                                             java.lang.String[] customers,
                                             java.util.Date from,
                                             java.util.Date to)
                                             throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PO2POAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PO2POAgent

java.lang.Object
    extended by  bb.common.PO2POAgent
All Implemented Interfaces:
java.io.Serializable
public class PO2POAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PO2POAgent()
Method Summary
java.util.Date | getArriveDate()
int | getDelayDays()
java.util.Date | getOriginalDate()
java.lang.String | getPoNumber()
java.util.Date | getShipDate()
java.lang.String | getVendorId()
void | setArriveDate(java.util.Date arriveDate)
void | setDelayDays(int delayDays)
void | setOriginalDate(java.util.Date originalDate)
void | setPoNumber(java.lang.String poNumber)
void | setShipDate(java.util.Date shipDate)
void | setVendorId(java.lang.String vendorId)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PO2POAgent

public PO2POAgent()
Method Detail

getDelayDays

public int getDelayDays()

setDelayDays

public void setDelayDays(int delayDays)

getShipDate

public java.util.Date getShipDate()

setShipDate

public void setShipDate(java.util.Date shipDate)

getArriveDate

public java.util.Date getArriveDate()

setArriveDate

public void setArriveDate(java.util.Date arriveDate)

getOriginalDate

public java.util.Date getOriginalDate()

setOriginalDate

public void setOriginalDate(java.util.Date originalDate)

getPoNumber

public java.lang.String getPoNumber()

setPoNumber

public void setPoNumber(java.lang.String poNumber)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PO2SOExchange

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PO2SOExchange

java.lang.Object
    extended by  bb.common.PO2SOExchange
All Implemented Interfaces:
java.io.Serializable
public class PO2SOExchange
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PO2SOExchange()
Method Summary
java.lang.String | getBilltoId()
java.lang.String | getBilltoName()
java.lang.String | getCarrier()
java.lang.String | getComments()
java.lang.String | getContact()
java.lang.String | getCurrency()
java.lang.String | getIncoterm()
java.util.Set | getItems()
java.util.Date | getPoDate()
java.lang.String | getPurchaerName()
java.lang.String | getPurchaseOrderNumber()
java.lang.String | getPurchaserId()
java.lang.String | getSellerId()
java.lang.String | getSellerName()
java.lang.String | getShiptoId()
java.lang.String | getShiptoName()
java.lang.String | getTerms()
void | setBilltoId(java.lang.String billtoId)
void | setBilltoName(java.lang.String billtoName)
void | setCarrier(java.lang.String carrier)
void | setComments(java.lang.String comments)
void | setContact(java.lang.String contact)
void | setCurrency(java.lang.String currency)
void | setIncoterm(java.lang.String incoterm)
void | setItems(java.util.Set items)
void | setPoDate(java.util.Date poDate)
void | setPurchaerName(java.lang.String purchaerName)
void | setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)
void | setPurchaserId(java.lang.String purchaserId)
void | setSellerId(java.lang.String sellerId)
void | setSellerName(java.lang.String sellerName)
void | setShiptoId(java.lang.String shiptoId)
void | setShiptoName(java.lang.String shiptoName)
void | setTerms(java.lang.String terms)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PO2SOExchange

public PO2SOExchange()
Method Detail

setItems

public void setItems(java.util.Set items)

setPurchaserId

public void setPurchaserId(java.lang.String purchaserId)

setSellerId

public void setSellerId(java.lang.String sellerId)

setPurchaerName

public void setPurchaerName(java.lang.String purchaerName)

setSellerName

public void setSellerName(java.lang.String sellerName)

setBilltoId

public void setBilltoId(java.lang.String billtoId)

setBilltoName

public void setBilltoName(java.lang.String billtoName)

setShiptoId

public void setShiptoId(java.lang.String shiptoId)

setShiptoName

public void setShiptoName(java.lang.String shiptoName)

setCurrency

public void setCurrency(java.lang.String currency)

setTerms

public void setTerms(java.lang.String terms)

setCarrier

public void setCarrier(java.lang.String carrier)

setIncoterm

public void setIncoterm(java.lang.String incoterm)

setContact

public void setContact(java.lang.String contact)

setComments

public void setComments(java.lang.String comments)

setPurchaseOrderNumber

public void setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)

setPoDate

public void setPoDate(java.util.Date poDate)

getItems

public java.util.Set getItems()

getPurchaserId

public java.lang.String getPurchaserId()

getSellerId

public java.lang.String getSellerId()

getPurchaerName

public java.lang.String getPurchaerName()

getSellerName

public java.lang.String getSellerName()

getBilltoId

public java.lang.String getBilltoId()

getBilltoName

public java.lang.String getBilltoName()

getShiptoId

public java.lang.String getShiptoId()

getShiptoName

public java.lang.String getShiptoName()

getCurrency

public java.lang.String getCurrency()

getTerms

public java.lang.String getTerms()

getCarrier

public java.lang.String getCarrier()

getIncoterm

public java.lang.String getIncoterm()

getContact

public java.lang.String getContact()

getComments

public java.lang.String getComments()

getPurchaseOrderNumber

public java.lang.String getPurchaseOrderNumber()

getPoDate

public java.util.Date getPoDate()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PO2SOExchangeItem

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PO2SOExchangeItem

java.lang.Object
    extended by  bb.common.PO2SOExchangeItem
All Implemented Interfaces:
java.io.Serializable
public class PO2SOExchangeItem
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PO2SOExchangeItem()
Method Summary
java.math.BigDecimal | getCostUnit()
int | getDelayDays()
java.math.BigDecimal | getDiscount()
java.lang.String | getItemComments()
java.util.Set | getItemManf()
java.lang.String | getItemNumber()
java.lang.String | getPartDescription()
java.lang.String | getPartFrom()
PartPK | getPartPK()
java.math.BigDecimal | getQtyOrdered()
java.util.Date | getShipDate()
java.lang.String | getShipVia()
java.math.BigDecimal | getTax()
void | setCostUnit(java.math.BigDecimal costUnit)
void | setDelayDays(int delayDays)
void | setDiscount(java.math.BigDecimal discount)
void | setItemComments(java.lang.String itemComments)
void | setItemManf(java.util.Set itemManf)
void | setItemNumber(java.lang.String itemNumber)
void | setPartDescription(java.lang.String partDescription)
void | setPartFrom(java.lang.String partFrom)
void | setPartPK(PartPK partPK)
void | setQtyOrdered(java.math.BigDecimal qtyOrdered)
void | setShipDate(java.util.Date shipDate)
void | setShipVia(java.lang.String shipVia)
void | setTax(java.math.BigDecimal tax)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PO2SOExchangeItem

public PO2SOExchangeItem()
Method Detail

getItemNumber

public java.lang.String getItemNumber()

getPartPK

public PartPK getPartPK()

getQtyOrdered

public java.math.BigDecimal getQtyOrdered()

getDiscount

public java.math.BigDecimal getDiscount()

getCostUnit

public java.math.BigDecimal getCostUnit()

getDelayDays

public int getDelayDays()

getShipDate

public java.util.Date getShipDate()

getShipVia

public java.lang.String getShipVia()

getPartDescription

public java.lang.String getPartDescription()

getItemComments

public java.lang.String getItemComments()

getTax

public java.math.BigDecimal getTax()

getPartFrom

public java.lang.String getPartFrom()

getItemManf

public java.util.Set getItemManf()

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

setPartPK

public void setPartPK(PartPK partPK)

setQtyOrdered

public void setQtyOrdered(java.math.BigDecimal qtyOrdered)

setDiscount

public void setDiscount(java.math.BigDecimal discount)

setCostUnit

public void setCostUnit(java.math.BigDecimal costUnit)

setDelayDays

public void setDelayDays(int delayDays)

setShipDate

public void setShipDate(java.util.Date shipDate)

setShipVia

public void setShipVia(java.lang.String shipVia)

setPartDescription

public void setPartDescription(java.lang.String partDescription)

setItemComments

public void setItemComments(java.lang.String itemComments)

setTax

public void setTax(java.math.BigDecimal tax)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setItemManf

public void setItemManf(java.util.Set itemManf)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PO2SOExchangeItemManufacturer

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PO2SOExchangeItemManufacturer

java.lang.Object
    extended by  bb.common.PO2SOExchangeItemManufacturer
All Implemented Interfaces:
java.io.Serializable
public class PO2SOExchangeItemManufacturer
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PO2SOExchangeItemManufacturer()
Method Summary
java.lang.String | getItemNumber()
java.lang.String | getManufacturerName()
java.lang.String | getManufacturerPN()
void | setItemNumber(java.lang.String itemNumber)
void | setManufacturerName(java.lang.String manufacturerName)
void | setManufacturerPN(java.lang.String manufacturerPN)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PO2SOExchangeItemManufacturer

public PO2SOExchangeItemManufacturer()
Method Detail

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

setManufacturerName

public void setManufacturerName(java.lang.String manufacturerName)

setManufacturerPN

public void setManufacturerPN(java.lang.String manufacturerPN)

getItemNumber

public java.lang.String getItemNumber()

getManufacturerName

public java.lang.String getManufacturerName()

getManufacturerPN

public java.lang.String getManufacturerPN()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POAndWOStatusResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class POAndWOStatusResult

java.lang.Object
    extended by  bb.common.POAndWOStatusResult
All Implemented Interfaces:
java.io.Serializable
public class POAndWOStatusResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
POAndWOStatusResult()
Method Summary
java.util.Date | getFromDate()
java.util.Collection | getPoStatus()
java.lang.String | getProject()
java.util.Date | getToDate()
java.util.Collection | getWoStatus()
void | setFromDate(java.util.Date fromDate)
void | setPoStatus(java.util.Collection poStatus)
void | setProject(java.lang.String project)
void | setToDate(java.util.Date toDate)
void | setWoStatus(java.util.Collection woStatus)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

POAndWOStatusResult

public POAndWOStatusResult()
Method Detail

getPoStatus

public java.util.Collection getPoStatus()

setPoStatus

public void setPoStatus(java.util.Collection poStatus)

getWoStatus

public java.util.Collection getWoStatus()

setWoStatus

public void setWoStatus(java.util.Collection woStatus)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

getFromDate

public java.util.Date getFromDate()

setFromDate

public void setFromDate(java.util.Date fromDate)

getToDate

public java.util.Date getToDate()

setToDate

public void setToDate(java.util.Date toDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POForWISeqAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class POForWISeqAgent

java.lang.Object
    extended by  bb.common.POForWISeqAgent
All Implemented Interfaces:
java.io.Serializable
public class POForWISeqAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
POForWISeqAgent(WorkOrderItemPK pk)
Method Summary
void | addItem(java.lang.String vendorID, WorkOrderWorkInstructionSequencePK item)
void | addItem(java.lang.String vendorID, WorkOrderWorkInstructionSequencePK item, java.util.Date requireDate, java.math.BigDecimal price)
void | clearItems()
WorkOrderItemPK | getPk()
java.math.BigDecimal | getPrice(WorkOrderWorkInstructionSequencePK pk)
java.util.Date | getRequireDate(WorkOrderWorkInstructionSequencePK pk)
java.util.Iterator<WorkOrderWorkInstructionSequencePK> | getSeqPKs()
java.util.Iterator<WorkOrderWorkInstructionSequencePK> | getSeqPKs(java.lang.String vendorID)
java.util.Iterator<java.lang.String> | getVendors()
boolean | isEmpty()
boolean | isEmpty(java.lang.String vendorID)
void | removeItem(WorkOrderWorkInstructionSequencePK item)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

POForWISeqAgent

public POForWISeqAgent(WorkOrderItemPK pk)
Method Detail

addItem

public void addItem(java.lang.String vendorID,
                    WorkOrderWorkInstructionSequencePK item)

addItem

public void addItem(java.lang.String vendorID,
                    WorkOrderWorkInstructionSequencePK item,
                    java.util.Date requireDate,
                    java.math.BigDecimal price)

getVendors

public java.util.Iterator<java.lang.String> getVendors()

getSeqPKs

public java.util.Iterator<WorkOrderWorkInstructionSequencePK> getSeqPKs(java.lang.String vendorID)

getSeqPKs

public java.util.Iterator<WorkOrderWorkInstructionSequencePK> getSeqPKs()

getRequireDate

public java.util.Date getRequireDate(WorkOrderWorkInstructionSequencePK pk)

getPrice

public java.math.BigDecimal getPrice(WorkOrderWorkInstructionSequencePK pk)

removeItem

public void removeItem(WorkOrderWorkInstructionSequencePK item)

clearItems

public void clearItems()

isEmpty

public boolean isEmpty()

isEmpty

public boolean isEmpty(java.lang.String vendorID)

getPk

public WorkOrderItemPK getPk()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PointOfSaleVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PointOfSaleVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PointOfSaleVO
All Implemented Interfaces:
java.io.Serializable
public class PointOfSaleVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PointOfSaleVO()
Method Summary
boolean | equals(java.lang.Object obj)
java.lang.String | getAutoApprovalBy()
java.lang.String | getCustomerID()
java.lang.String | getDefaultMFG()
java.lang.String | getId()
java.util.Date | getLastChangeDate()
java.lang.Integer | getLastChangeTimes()
java.lang.String | getLastChangeUser()
java.lang.String | getLocationForReturnMaterial()
byte[] | getLogo()
java.lang.String | getPayMethod()
java.lang.String | getPerDayDiffAccount()
int | getPrintAmount()
int | getReceiptTemplateID()
int | getReturnTemplateID()
java.lang.String | getRmaDebitAccount()
java.lang.String | getScannerPrefix()
java.lang.String | getScannerSuffix()
int | hashCode()
boolean | isDirectlyPrintAR()
boolean | isUseAutoApprovalGL()
boolean | isUseAutoCreateOrder()
boolean | isUsePOSReceive()
void | setAutoApprovalBy(java.lang.String autoApprovalBy)
void | setCustomerID(java.lang.String customerID)
void | setDefaultMFG(java.lang.String defaultMFG)
void | setDirectlyPrintAR(boolean directlyPrintAR)
void | setId(java.lang.String id)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTimes(java.lang.Integer lastChangeTimes)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLocationForReturnMaterial(java.lang.String locationForReturnMaterial)
void | setLogo(byte[] logo)
void | setPayMethod(java.lang.String payMethod)
void | setPerDayDiffAccount(java.lang.String perDayDiffAccount)
void | setPrintAmount(int printAmount)
void | setReceiptTemplateID(int receiptTemplateID)
void | setReturnTemplateID(int returnTemplateID)
void | setRmaDebitAccount(java.lang.String rmaDebitAccount)
void | setScannerPrefix(java.lang.String scannerPrefix)
void | setScannerSuffix(java.lang.String scannerSuffix)
void | setUseAutoApprovalGL(boolean useAutoApprovalGL)
void | setUseAutoCreateOrder(boolean useAutoCreateOrder)
void | setUsePOSReceive(boolean usePOSReceive)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PointOfSaleVO

public PointOfSaleVO()
Method Detail

isUseAutoCreateOrder

public boolean isUseAutoCreateOrder()

setUseAutoCreateOrder

public void setUseAutoCreateOrder(boolean useAutoCreateOrder)

isUseAutoApprovalGL

public boolean isUseAutoApprovalGL()

setUseAutoApprovalGL

public void setUseAutoApprovalGL(boolean useAutoApprovalGL)

getAutoApprovalBy

public java.lang.String getAutoApprovalBy()

setAutoApprovalBy

public void setAutoApprovalBy(java.lang.String autoApprovalBy)

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getPrintAmount

public int getPrintAmount()

setPrintAmount

public void setPrintAmount(int printAmount)

getPayMethod

public java.lang.String getPayMethod()

setPayMethod

public void setPayMethod(java.lang.String payMethod)

getPerDayDiffAccount

public java.lang.String getPerDayDiffAccount()

setPerDayDiffAccount

public void setPerDayDiffAccount(java.lang.String perDayDiffAccount)

getCustomerID

public java.lang.String getCustomerID()

setCustomerID

public void setCustomerID(java.lang.String customerID)

getLastChangeTimes

public java.lang.Integer getLastChangeTimes()

setLastChangeTimes

public void setLastChangeTimes(java.lang.Integer lastChangeTimes)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getLocationForReturnMaterial

public java.lang.String getLocationForReturnMaterial()

setLocationForReturnMaterial

public void setLocationForReturnMaterial(java.lang.String locationForReturnMaterial)

getRmaDebitAccount

public java.lang.String getRmaDebitAccount()

setRmaDebitAccount

public void setRmaDebitAccount(java.lang.String rmaDebitAccount)

getDefaultMFG

public java.lang.String getDefaultMFG()

setDefaultMFG

public void setDefaultMFG(java.lang.String defaultMFG)

isUsePOSReceive

public boolean isUsePOSReceive()

setUsePOSReceive

public void setUsePOSReceive(boolean usePOSReceive)

getLogo

public byte[] getLogo()

setLogo

public void setLogo(byte[] logo)

getScannerPrefix

public java.lang.String getScannerPrefix()

setScannerPrefix

public void setScannerPrefix(java.lang.String scannerPrefix)

getScannerSuffix

public java.lang.String getScannerSuffix()

setScannerSuffix

public void setScannerSuffix(java.lang.String scannerSuffix)

getReceiptTemplateID

public int getReceiptTemplateID()

setReceiptTemplateID

public void setReceiptTemplateID(int receiptTemplateID)

getReturnTemplateID

public int getReturnTemplateID()

setReturnTemplateID

public void setReturnTemplateID(int returnTemplateID)

isDirectlyPrintAR

public boolean isDirectlyPrintAR()

setDirectlyPrintAR

public void setDirectlyPrintAR(boolean directlyPrintAR)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POItemByRefDoc1ListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class POItemByRefDoc1ListResult

java.lang.Object
    extended by  bb.common.PurchaseOrderItemListResult
        extended by  bb.common.POItemByRefDoc1ListResult
All Implemented Interfaces:
java.io.Serializable
public class POItemByRefDoc1ListResult
extends PurchaseOrderItemListResult

See Also:
Serialized Form

Field Summary
Fields inherited from class bb.common.PurchaseOrderItemListResult
ORDER_BY_ACCOUNTNUMBER, ORDER_BY_APOPEN, ORDER_BY_APRECEIVED, ORDER_BY_ARRIVEDATE, ORDER_BY_BUYER, ORDER_BY_COMPANYNUITID, ORDER_BY_COSTPERUNIT, ORDER_BY_CURRENCY, ORDER_BY_DELEVERYDATE, ORDER_BY_DISCOUNT, ORDER_BY_EXTENDPRICE, ORDER_BY_LASTRECEIVEDATE, ORDER_BY_ORDERQTY, ORDER_BY_PARTPK, ORDER_BY_PODATE, ORDER_BY_PONUMBER, ORDER_BY_PRODUCTCODE, ORDER_BY_PROJECT, ORDER_BY_RECEIVEDQTY, ORDER_BY_RELATEDDOC, ORDER_BY_REQUESTER, ORDER_BY_SHIPTO, ORDER_BY_VENDORID
Constructor Summary
POItemByRefDoc1ListResult()
Method Summary
java.lang.String | getRefDoc1()
void | setRefDoc1(java.lang.String refDoc1)
Methods inherited from class bb.common.PurchaseOrderItemListResult
getAccountNumber, getApOpen, getApReceived, getArriveDate, getBuyer, getCompanyUnitId, getCostPerUnit, getCurrency, getDelayDays, getDeleveryDate, getDiscount, getExtendPrice, getItemDescription, getItemTotalTax, getLastReceiveDate, getOnDemandQty, getOnHandQty, getOnOrderQty, getOrderQty, getPartPk, getPoDate, getPoItemNumber, getPoItemStatus, getPoNumber, getProductCode, getProject, getReceivedQty, getRefDocOnes, getRefDocTwoes, getRelatedDoc, getRequester, getShipto, getSipQty, getSitQty, getUnit, getVendorId, getWipQty, setAccountNumber, setApOpen, setApReceived, setArriveDate, setBuyer, setCompanyUnitId, setCostPerUnit, setCurrency, setDelayDays, setDeleveryDate, setDiscount, setExtendPrice, setItemDescription, setItemTotalTax, setLastReceiveDate, setOnDemandQty, setOnHandQty, setOnOrderQty, setOrderQty, setPartPk, setPoDate, setPoItemNumber, setPoItemStatus, setPoNumber, setProductCode, setProject, setReceivedQty, setRefDocOnes, setRefDocTwoes, setRelatedDoc, setRequester, setShipto, setSipQty, setSitQty, setUnit, setVendorId, setWipQty
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

POItemByRefDoc1ListResult

public POItemByRefDoc1ListResult()
Method Detail

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PoMessageItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PoMessageItemPK

java.lang.Object
    extended by  bb.common.PoMessageItemPK
All Implemented Interfaces:
java.io.Serializable
public class PoMessageItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PoMessageItemPK()
PoMessageItemPK(java.lang.String poMessageNumber, java.lang.String itemNumber)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getItemNumber()
java.lang.String | getPoMessageNumber()
int | hashCode()
void | setItemNumber(java.lang.String itemNumber)
void | setPoMessageNumber(java.lang.String poMessageNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PoMessageItemPK

public PoMessageItemPK()

PoMessageItemPK

public PoMessageItemPK(java.lang.String poMessageNumber,
                       java.lang.String itemNumber)
Method Detail

getItemNumber

public java.lang.String getItemNumber()

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getPoMessageNumber

public java.lang.String getPoMessageNumber()

setPoMessageNumber

public void setPoMessageNumber(java.lang.String poMessageNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PoMessageItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PoMessageItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PoMessageItemVO
All Implemented Interfaces:
java.io.Serializable
public class PoMessageItemVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PoMessageItemVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getApNet()
java.math.BigDecimal | getApOpen()
java.math.BigDecimal | getApReceived()
java.math.BigDecimal | getApTotal()
java.lang.String | getComments()
java.math.BigDecimal | getCostPerUnit()
java.util.Date | getDateRequired()
int | getDelay()
java.math.BigDecimal | getDiscount()
java.math.BigDecimal | getItemSubTotal()
java.math.BigDecimal | getItemTotalDiscount()
java.math.BigDecimal | getItemTotalTax()
PoMessageItemPK | getPk()
PurchaseOrderItemVO | getPoItem()
java.lang.String | getPoNumber()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.math.BigDecimal | getTaxRate()
int | hashCode()
void | setApNet(java.math.BigDecimal apNet)
void | setApOpen(java.math.BigDecimal apOpen)
void | setApReceived(java.math.BigDecimal apReceived)
void | setApTotal(java.math.BigDecimal apTotal)
void | setComments(java.lang.String comments)
void | setCostPerUnit(java.math.BigDecimal costPerUnit)
void | setDateRequired(java.util.Date dateRequired)
void | setDelay(int delay)
void | setDiscount(java.math.BigDecimal discount)
void | setItemSubTotal(java.math.BigDecimal itemSubTotal)
void | setItemTotalDiscount(java.math.BigDecimal itemTotalDiscount)
void | setItemTotalTax(java.math.BigDecimal itemTotalTax)
void | setPk(PoMessageItemPK pk)
void | setPoItem(PurchaseOrderItemVO poItem)
void | setPoNumber(java.lang.String poNumber)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setTaxRate(java.math.BigDecimal taxRate)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PoMessageItemVO

public PoMessageItemVO()
default constructor

Method Detail

getPk

public PoMessageItemPK getPk()

setPk

public void setPk(PoMessageItemPK pk)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getCostPerUnit

public java.math.BigDecimal getCostPerUnit()

setCostPerUnit

public void setCostPerUnit(java.math.BigDecimal costPerUnit)

getDelay

public int getDelay()

setDelay

public void setDelay(int delay)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getPoItem

public PurchaseOrderItemVO getPoItem()

setPoItem

public void setPoItem(PurchaseOrderItemVO poItem)

getPoNumber

public java.lang.String getPoNumber()

setPoNumber

public void setPoNumber(java.lang.String poNumber)

getApNet

public java.math.BigDecimal getApNet()

setApNet

public void setApNet(java.math.BigDecimal apNet)

getApOpen

public java.math.BigDecimal getApOpen()

setApOpen

public void setApOpen(java.math.BigDecimal apOpen)

getApReceived

public java.math.BigDecimal getApReceived()

setApReceived

public void setApReceived(java.math.BigDecimal apReceived)

getApTotal

public java.math.BigDecimal getApTotal()

setApTotal

public void setApTotal(java.math.BigDecimal apTotal)

getItemSubTotal

public java.math.BigDecimal getItemSubTotal()

setItemSubTotal

public void setItemSubTotal(java.math.BigDecimal itemSubTotal)

getItemTotalDiscount

public java.math.BigDecimal getItemTotalDiscount()

setItemTotalDiscount

public void setItemTotalDiscount(java.math.BigDecimal itemTotalDiscount)

getItemTotalTax

public java.math.BigDecimal getItemTotalTax()

setItemTotalTax

public void setItemTotalTax(java.math.BigDecimal itemTotalTax)

getDateRequired

public java.util.Date getDateRequired()

setDateRequired

public void setDateRequired(java.util.Date dateRequired)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PoMessageListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PoMessageListResult

java.lang.Object
    extended by  bb.common.PoMessageListResult
All Implemented Interfaces:
java.io.Serializable
public class PoMessageListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_POMESSAGENUMBER
static java.lang.String | ORDER_BY_PONUMBER
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_VENDORID
Constructor Summary
PoMessageListResult()
Method Summary
java.lang.String | getComments()
java.util.Date | getPoMessageDate()
java.lang.String | getPoMessageNumber()
java.lang.String | getPoNumber()
java.lang.String | getStatus()
java.lang.String | getValidateCode()
java.lang.String | getVendorId()
void | setComments(java.lang.String comments)
void | setPoMessageDate(java.util.Date poMessageDate)
void | setPoMessageNumber(java.lang.String poMessageNumber)
void | setPoNumber(java.lang.String poNumber)
void | setStatus(java.lang.String status)
void | setValidateCode(java.lang.String validateCode)
void | setVendorId(java.lang.String vendorId)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_POMESSAGENUMBER

public static final java.lang.String ORDER_BY_POMESSAGENUMBER
See Also:
Constant Field Values

ORDER_BY_PONUMBER

public static final java.lang.String ORDER_BY_PONUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values
Constructor Detail

PoMessageListResult

public PoMessageListResult()
Method Detail

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getPoMessageDate

public java.util.Date getPoMessageDate()

setPoMessageDate

public void setPoMessageDate(java.util.Date poMessageDate)

getPoMessageNumber

public java.lang.String getPoMessageNumber()

setPoMessageNumber

public void setPoMessageNumber(java.lang.String poMessageNumber)

getPoNumber

public java.lang.String getPoNumber()

setPoNumber

public void setPoNumber(java.lang.String poNumber)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getValidateCode

public java.lang.String getValidateCode()

setValidateCode

public void setValidateCode(java.lang.String validateCode)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PoMessageVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PoMessageVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PoMessageVO
All Implemented Interfaces:
java.io.Serializable
public class PoMessageVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PoMessageVO()
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getApNet()
java.math.BigDecimal | getApOpen()
java.math.BigDecimal | getApReceived()
java.lang.String | getComments()
java.math.BigDecimal | getGrantTotal()
java.util.Set<PoMessageItemVO> | getItems()
java.util.Date | getPoMessageDate()
java.lang.String | getPoMessageNumber()
java.lang.String | getPoNumber()
java.lang.String | getStatus()
java.math.BigDecimal | getSubTotal()
java.math.BigDecimal | getTotalDiscount()
java.math.BigDecimal | getTotalFreight()
java.math.BigDecimal | getTotalTax()
java.lang.String | getValidateCode()
java.util.Date | getVendorApproved()
java.lang.String | getVendorApprovedBy()
java.lang.String | getVendorId()
int | hashCode()
void | setApNet(java.math.BigDecimal apNet)
void | setApOpen(java.math.BigDecimal apOpen)
void | setApReceived(java.math.BigDecimal apReceived)
void | setComments(java.lang.String comments)
void | setGrantTotal(java.math.BigDecimal grantTotal)
void | setItems(java.util.Set<PoMessageItemVO> items)
void | setPoMessageDate(java.util.Date poMessageDate)
void | setPoMessageNumber(java.lang.String poMessageNumber)
void | setPoNumber(java.lang.String poNumber)
void | setStatus(java.lang.String status)
void | setSubTotal(java.math.BigDecimal subTotal)
void | setTotalDiscount(java.math.BigDecimal totalDiscount)
void | setTotalFreight(java.math.BigDecimal totalFreight)
void | setTotalTax(java.math.BigDecimal totalTax)
void | setValidateCode(java.lang.String validateCode)
void | setVendorApproved(java.util.Date vendorApproved)
void | setVendorApprovedBy(java.lang.String vendorApprovedBy)
void | setVendorId(java.lang.String vendorId)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PoMessageVO

public PoMessageVO()
Method Detail

getPoMessageDate

public java.util.Date getPoMessageDate()

setPoMessageDate

public void setPoMessageDate(java.util.Date poMessageDate)

getPoMessageNumber

public java.lang.String getPoMessageNumber()

setPoMessageNumber

public void setPoMessageNumber(java.lang.String poMessageNumber)

getPoNumber

public java.lang.String getPoNumber()

setPoNumber

public void setPoNumber(java.lang.String poNumber)

getValidateCode

public java.lang.String getValidateCode()

setValidateCode

public void setValidateCode(java.lang.String validateCode)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getItems

public java.util.Set<PoMessageItemVO> getItems()

setItems

public void setItems(java.util.Set<PoMessageItemVO> items)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getApNet

public java.math.BigDecimal getApNet()

setApNet

public void setApNet(java.math.BigDecimal apNet)

getApOpen

public java.math.BigDecimal getApOpen()

setApOpen

public void setApOpen(java.math.BigDecimal apOpen)

getApReceived

public java.math.BigDecimal getApReceived()

setApReceived

public void setApReceived(java.math.BigDecimal apReceived)

getGrantTotal

public java.math.BigDecimal getGrantTotal()

setGrantTotal

public void setGrantTotal(java.math.BigDecimal grantTotal)

getSubTotal

public java.math.BigDecimal getSubTotal()

setSubTotal

public void setSubTotal(java.math.BigDecimal subTotal)

getTotalDiscount

public java.math.BigDecimal getTotalDiscount()

setTotalDiscount

public void setTotalDiscount(java.math.BigDecimal totalDiscount)

getTotalFreight

public java.math.BigDecimal getTotalFreight()

setTotalFreight

public void setTotalFreight(java.math.BigDecimal totalFreight)

getTotalTax

public java.math.BigDecimal getTotalTax()

setTotalTax

public void setTotalTax(java.math.BigDecimal totalTax)

getVendorApproved

public java.util.Date getVendorApproved()

setVendorApproved

public void setVendorApproved(java.util.Date vendorApproved)

getVendorApprovedBy

public java.lang.String getVendorApprovedBy()

setVendorApprovedBy

public void setVendorApprovedBy(java.lang.String vendorApprovedBy)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PoReceiverByDateSummaryResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PoReceiverByDateSummaryResult

java.lang.Object
    extended by  bb.common.PoReceiverByDateSummaryResult
All Implemented Interfaces:
java.io.Serializable
public class PoReceiverByDateSummaryResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PoReceiverByDateSummaryResult()
Method Summary
Money | getTotalAvgCost()
Money | getTotalStdCost()
void | setTotalAvgCost(Money totalAvgCost)
void | setTotalStdCost(Money totalStdCost)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PoReceiverByDateSummaryResult

public PoReceiverByDateSummaryResult()
Method Detail

setTotalStdCost

public void setTotalStdCost(Money totalStdCost)

setTotalAvgCost

public void setTotalAvgCost(Money totalAvgCost)

getTotalStdCost

public Money getTotalStdCost()

getTotalAvgCost

public Money getTotalAvgCost()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POReceiverItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class POReceiverItemListResult

java.lang.Object
    extended by  bb.common.POReceiverItemListResult
All Implemented Interfaces:
java.io.Serializable
public class POReceiverItemListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACCOUNTNUMBER
static java.lang.String | ORDER_BY_BUYER
static java.lang.String | ORDER_BY_BUYERCODE
static java.lang.String | ORDER_BY_COMPANYNUITID
static java.lang.String | ORDER_BY_COSTPERUNIT
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_DISCOUNT
static java.lang.String | ORDER_BY_EXCHANGE
static java.lang.String | ORDER_BY_EXTENDEDCOST
static java.lang.String | ORDER_BY_ITEMNUMBER
static java.lang.String | ORDER_BY_LOCATION
static java.lang.String | ORDER_BY_LOCATIONS
static java.lang.String | ORDER_BY_ORIGIALSHIPDATE
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PONUMBER
static java.lang.String | ORDER_BY_PORECEIVED
static java.lang.String | ORDER_BY_POSHIPDATE
static java.lang.String | ORDER_BY_PROJECTNAME
static java.lang.String | ORDER_BY_QTYORDERED
static java.lang.String | ORDER_BY_QTYRECEIVED
static java.lang.String | ORDER_BY_RECEIVEDDATE
static java.lang.String | ORDER_BY_RECEIVERNUMBER
static java.lang.String | ORDER_BY_STANDARDCOST
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_TAXRATE
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_VENDORPACKAGE
static java.lang.String | ORDER_BY_VENDORSHIPDATE
Constructor Summary
POReceiverItemListResult()
Method Summary
java.lang.String | getAccountNumber()
java.lang.String | getApItemNumber()
java.lang.String | getApItemStatus()
java.lang.String | getApNumber()
java.lang.String | getBuyer()
java.lang.String | getBuyerCode()
java.lang.String | getCompanyUnitId()
java.math.BigDecimal | getCostPerUnit()
java.lang.String | getCurrency()
java.lang.String | getDescription()
java.math.BigDecimal | getDiscount()
java.math.BigDecimal | getExchangeRate()
java.math.BigDecimal | getExtendedCost()
java.lang.String | getItemNumber()
java.lang.String | getLocation()
java.util.Map | getLocations()
java.util.Date | getOrigialShipDate()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getPoItemNumber()
java.lang.String | getPoNumber()
java.math.BigDecimal | getPoReceived()
java.util.Date | getPoShipDate()
java.lang.String | getProjectName()
java.math.BigDecimal | getQtyOrdered()
java.math.BigDecimal | getQtyReceived()
java.util.Date | getReceivedDate()
java.lang.String | getReceiverNumber()
java.math.BigDecimal | getStandardCost()
java.math.BigDecimal | getStandardExtendedCost()
java.lang.String | getStatus()
java.math.BigDecimal | getTaxRate()
java.lang.String | getVendorId()
java.lang.String | getVendorPackage()
java.util.Date | getVendorShipDate()
void | setAccountNumber(java.lang.String accountNumber)
void | setApItemNumber(java.lang.String apItemNumber)
void | setApItemStatus(java.lang.String apItemStatus)
void | setApNumber(java.lang.String apNumber)
void | setBuyer(java.lang.String buyer)
void | setBuyerCode(java.lang.String buyerCode)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCostPerUnit(java.math.BigDecimal costPerUnit)
void | setCurrency(java.lang.String currency)
void | setDescription(java.lang.String description)
void | setDiscount(java.math.BigDecimal discount)
void | setExchangeRate(java.math.BigDecimal exchangeRate)
void | setExtendedCost(java.math.BigDecimal extendedCost)
void | setItemNumber(java.lang.String itemNumber)
void | setLocation(java.lang.String location)
void | setLocations(java.util.Map locations)
void | setOrigialShipDate(java.util.Date origialShipDate)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPoItemNumber(java.lang.String poItemNumber)
void | setPoNumber(java.lang.String poNumber)
void | setPoReceived(java.math.BigDecimal poReceived)
void | setPoShipDate(java.util.Date poShipDate)
void | setProjectName(java.lang.String projectName)
void | setQtyOrdered(java.math.BigDecimal qtyOrdered)
void | setQtyReceived(java.math.BigDecimal qtyReceived)
void | setReceivedDate(java.util.Date receivedDate)
void | setReceiverNumber(java.lang.String receiverNumber)
void | setStandardCost(java.math.BigDecimal standardCost)
void | setStandardExtendedCost(java.math.BigDecimal standardExtendedCost)
void | setStatus(java.lang.String status)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setVendorId(java.lang.String vendorId)
void | setVendorPackage(java.lang.String vendorPackage)
void | setVendorShipDate(java.util.Date vendorShipDate)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_RECEIVERNUMBER

public static final java.lang.String ORDER_BY_RECEIVERNUMBER
See Also:
Constant Field Values

ORDER_BY_ITEMNUMBER

public static final java.lang.String ORDER_BY_ITEMNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_BUYER

public static final java.lang.String ORDER_BY_BUYER
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_RECEIVEDDATE

public static final java.lang.String ORDER_BY_RECEIVEDDATE
See Also:
Constant Field Values

ORDER_BY_PONUMBER

public static final java.lang.String ORDER_BY_PONUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_VENDORSHIPDATE

public static final java.lang.String ORDER_BY_VENDORSHIPDATE
See Also:
Constant Field Values

ORDER_BY_ORIGIALSHIPDATE

public static final java.lang.String ORDER_BY_ORIGIALSHIPDATE
See Also:
Constant Field Values

ORDER_BY_POSHIPDATE

public static final java.lang.String ORDER_BY_POSHIPDATE
See Also:
Constant Field Values

ORDER_BY_QTYORDERED

public static final java.lang.String ORDER_BY_QTYORDERED
See Also:
Constant Field Values

ORDER_BY_PORECEIVED

public static final java.lang.String ORDER_BY_PORECEIVED
See Also:
Constant Field Values

ORDER_BY_QTYRECEIVED

public static final java.lang.String ORDER_BY_QTYRECEIVED
See Also:
Constant Field Values

ORDER_BY_COSTPERUNIT

public static final java.lang.String ORDER_BY_COSTPERUNIT
See Also:
Constant Field Values

ORDER_BY_TAXRATE

public static final java.lang.String ORDER_BY_TAXRATE
See Also:
Constant Field Values

ORDER_BY_EXTENDEDCOST

public static final java.lang.String ORDER_BY_EXTENDEDCOST
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values

ORDER_BY_EXCHANGE

public static final java.lang.String ORDER_BY_EXCHANGE
See Also:
Constant Field Values

ORDER_BY_DISCOUNT

public static final java.lang.String ORDER_BY_DISCOUNT
See Also:
Constant Field Values

ORDER_BY_ACCOUNTNUMBER

public static final java.lang.String ORDER_BY_ACCOUNTNUMBER
See Also:
Constant Field Values

ORDER_BY_COMPANYNUITID

public static final java.lang.String ORDER_BY_COMPANYNUITID
See Also:
Constant Field Values

ORDER_BY_VENDORPACKAGE

public static final java.lang.String ORDER_BY_VENDORPACKAGE
See Also:
Constant Field Values

ORDER_BY_STANDARDCOST

public static final java.lang.String ORDER_BY_STANDARDCOST
See Also:
Constant Field Values

ORDER_BY_LOCATION

public static final java.lang.String ORDER_BY_LOCATION
See Also:
Constant Field Values

ORDER_BY_PROJECTNAME

public static final java.lang.String ORDER_BY_PROJECTNAME
See Also:
Constant Field Values

ORDER_BY_LOCATIONS

public static final java.lang.String ORDER_BY_LOCATIONS
See Also:
Constant Field Values

ORDER_BY_BUYERCODE

public static final java.lang.String ORDER_BY_BUYERCODE
See Also:
Constant Field Values
Constructor Detail

POReceiverItemListResult

public POReceiverItemListResult()
Method Detail

getPoReceived

public java.math.BigDecimal getPoReceived()

getQtyReceived

public java.math.BigDecimal getQtyReceived()

getQtyOrdered

public java.math.BigDecimal getQtyOrdered()

getPoNumber

public java.lang.String getPoNumber()

getReceivedDate

public java.util.Date getReceivedDate()

getPartFrom

public java.lang.String getPartFrom()

getPartType

public java.lang.String getPartType()

getPartNumber

public java.lang.String getPartNumber()

getStatus

public java.lang.String getStatus()

getItemNumber

public java.lang.String getItemNumber()

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)

setPoReceived

public void setPoReceived(java.math.BigDecimal poReceived)

setQtyReceived

public void setQtyReceived(java.math.BigDecimal qtyReceived)

setQtyOrdered

public void setQtyOrdered(java.math.BigDecimal qtyOrdered)

setPoNumber

public void setPoNumber(java.lang.String poNumber)

setReceivedDate

public void setReceivedDate(java.util.Date receivedDate)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setPartType

public void setPartType(java.lang.String partType)

setPartNumber

public void setPartNumber(java.lang.String partNumber)

setStatus

public void setStatus(java.lang.String status)

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

setVendorId

public void setVendorId(java.lang.String vendorId)

setLocation

public void setLocation(java.lang.String location)

setDescription

public void setDescription(java.lang.String description)

setBuyer

public void setBuyer(java.lang.String buyer)

setVendorShipDate

public void setVendorShipDate(java.util.Date vendorShipDate)

setPoShipDate

public void setPoShipDate(java.util.Date poShipDate)

setOrigialShipDate

public void setOrigialShipDate(java.util.Date origialShipDate)

setExtendedCost

public void setExtendedCost(java.math.BigDecimal extendedCost)

setCostPerUnit

public void setCostPerUnit(java.math.BigDecimal costPerUnit)

getReceiverNumber

public java.lang.String getReceiverNumber()

getVendorId

public java.lang.String getVendorId()

getLocation

public java.lang.String getLocation()

getDescription

public java.lang.String getDescription()

getBuyer

public java.lang.String getBuyer()

getVendorShipDate

public java.util.Date getVendorShipDate()

getPoShipDate

public java.util.Date getPoShipDate()

getOrigialShipDate

public java.util.Date getOrigialShipDate()

getExtendedCost

public java.math.BigDecimal getExtendedCost()

getCostPerUnit

public java.math.BigDecimal getCostPerUnit()

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getExchangeRate

public java.math.BigDecimal getExchangeRate()

setExchangeRate

public void setExchangeRate(java.math.BigDecimal exchangeRate)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getVendorPackage

public java.lang.String getVendorPackage()

setVendorPackage

public void setVendorPackage(java.lang.String vendorPackage)

getStandardCost

public java.math.BigDecimal getStandardCost()

setStandardCost

public void setStandardCost(java.math.BigDecimal standardCost)

getStandardExtendedCost

public java.math.BigDecimal getStandardExtendedCost()

setStandardExtendedCost

public void setStandardExtendedCost(java.math.BigDecimal standardExtendedCost)

getProjectName

public java.lang.String getProjectName()

setProjectName

public void setProjectName(java.lang.String projectName)

getLocations

public java.util.Map getLocations()

setLocations

public void setLocations(java.util.Map locations)

getBuyerCode

public java.lang.String getBuyerCode()

setBuyerCode

public void setBuyerCode(java.lang.String buyerCode)

getApItemNumber

public java.lang.String getApItemNumber()

setApItemNumber

public void setApItemNumber(java.lang.String apItemNumber)

getApItemStatus

public java.lang.String getApItemStatus()

setApItemStatus

public void setApItemStatus(java.lang.String apItemStatus)

getApNumber

public java.lang.String getApNumber()

setApNumber

public void setApNumber(java.lang.String apNumber)

getPoItemNumber

public java.lang.String getPoItemNumber()

setPoItemNumber

public void setPoItemNumber(java.lang.String poItemNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PosRefdocVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PosRefdocVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PosRefdocVO
All Implemented Interfaces:
java.io.Serializable
public class PosRefdocVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PosRefdocVO()
default constructor
PosRefdocVO(java.lang.String forderNumber, java.lang.String fitemNumber, java.lang.String torderNumber, java.lang.String titemNumber, java.math.BigDecimal qty, java.lang.String lastChangeUser, java.util.Date lastChangeDate, java.lang.Integer lastChangeTime, short linkRef)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getFitemNumber()
java.lang.String | getForderNumber()
java.lang.Long | getIi()
java.util.Date | getLastChangeDate()
java.lang.Integer | getLastChangeTime()
java.lang.String | getLastChangeUser()
short | getLinkOrRef()
java.math.BigDecimal | getQty()
java.lang.String | getTitemNumber()
java.lang.String | getTorderNumber()
int | hashCode()
void | setFitemNumber(java.lang.String fitemNumber)
void | setForderNumber(java.lang.String forderNumber)
void | setIi(java.lang.Long ii)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTime(java.lang.Integer lastChangeTime)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLinkOrRef(short linkOrRef)
void | setQty(java.math.BigDecimal qty)
void | setTitemNumber(java.lang.String titemNumber)
void | setTorderNumber(java.lang.String torderNumber)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PosRefdocVO

public PosRefdocVO(java.lang.String forderNumber,
                   java.lang.String fitemNumber,
                   java.lang.String torderNumber,
                   java.lang.String titemNumber,
                   java.math.BigDecimal qty,
                   java.lang.String lastChangeUser,
                   java.util.Date lastChangeDate,
                   java.lang.Integer lastChangeTime,
                   short linkRef)
full constructor

PosRefdocVO

public PosRefdocVO()
default constructor

Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getForderNumber

public java.lang.String getForderNumber()

setForderNumber

public void setForderNumber(java.lang.String forderNumber)

getFitemNumber

public java.lang.String getFitemNumber()

setFitemNumber

public void setFitemNumber(java.lang.String fitemNumber)

getTorderNumber

public java.lang.String getTorderNumber()

setTorderNumber

public void setTorderNumber(java.lang.String torderNumber)

getTitemNumber

public java.lang.String getTitemNumber()

setTitemNumber

public void setTitemNumber(java.lang.String titemNumber)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeTime

public java.lang.Integer getLastChangeTime()

setLastChangeTime

public void setLastChangeTime(java.lang.Integer lastChangeTime)

getLinkOrRef

public short getLinkOrRef()

setLinkOrRef

public void setLinkOrRef(short linkOrRef)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POStatisticsResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class POStatisticsResult

java.lang.Object
    extended by  bb.common.POStatisticsResult
All Implemented Interfaces:
java.io.Serializable
public class POStatisticsResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_GRANTTOTAL
static java.lang.String | ORDER_BY_PODATE
static java.lang.String | ORDER_BY_PONUMBER
static java.lang.String | ORDER_BY_PROJECT
static java.lang.String | ORDER_BY_RELATEDDOC
static java.lang.String | ORDER_BY_TOTALFREIGHT
static java.lang.String | ORDER_BY_TOTALTAX
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_VENDORNAME
static java.lang.String | ORDER_BY_VENDORSALESORDER
Constructor Summary
POStatisticsResult()
Method Summary
java.lang.String | getComments()
java.lang.String | getContact()
java.lang.String | getCurrency()
int | getDelayDays()
java.math.BigDecimal | getGrantTotal()
java.lang.Long | getItemCounts()
java.math.BigDecimal | getItemQty()
java.util.Date | getLatestReceiverDate()
java.util.Date | getLatestShipDate()
java.util.Date | getPoDate()
java.lang.String | getPoNumber()
java.lang.String | getProject()
java.lang.String | getRelatedDoc()
java.lang.String | getRequester()
java.lang.String | getStatus()
java.math.BigDecimal | getTotalFreight()
java.math.BigDecimal | getTotalTax()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
java.lang.String | getVendorSalesOrder()
void | setComments(java.lang.String comments)
void | setContact(java.lang.String contact)
void | setCurrency(java.lang.String currency)
void | setDelayDays(int delayDays)
void | setGrantTotal(java.math.BigDecimal grantTotal)
void | setItemCounts(java.lang.Long itemCounts)
void | setItemQty(java.math.BigDecimal itemQty)
void | setLatestReceiverDate(java.util.Date latestReceiverDate)
void | setLatestShipDate(java.util.Date latestShipDate)
void | setPoDate(java.util.Date poDate)
void | setPoNumber(java.lang.String poNumber)
void | setProject(java.lang.String project)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setRequester(java.lang.String requester)
void | setStatus(java.lang.String status)
void | setTotalFreight(java.math.BigDecimal totalFreight)
void | setTotalTax(java.math.BigDecimal totalTax)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
void | setVendorSalesOrder(java.lang.String vendorSalesOrder)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_VENDORSALESORDER

public static final java.lang.String ORDER_BY_VENDORSALESORDER
See Also:
Constant Field Values

ORDER_BY_PROJECT

public static final java.lang.String ORDER_BY_PROJECT
See Also:
Constant Field Values

ORDER_BY_PODATE

public static final java.lang.String ORDER_BY_PODATE
See Also:
Constant Field Values

ORDER_BY_RELATEDDOC

public static final java.lang.String ORDER_BY_RELATEDDOC
See Also:
Constant Field Values

ORDER_BY_GRANTTOTAL

public static final java.lang.String ORDER_BY_GRANTTOTAL
See Also:
Constant Field Values

ORDER_BY_VENDORNAME

public static final java.lang.String ORDER_BY_VENDORNAME
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_PONUMBER

public static final java.lang.String ORDER_BY_PONUMBER
See Also:
Constant Field Values

ORDER_BY_TOTALFREIGHT

public static final java.lang.String ORDER_BY_TOTALFREIGHT
See Also:
Constant Field Values

ORDER_BY_TOTALTAX

public static final java.lang.String ORDER_BY_TOTALTAX
See Also:
Constant Field Values
Constructor Detail

POStatisticsResult

public POStatisticsResult()
Method Detail

getTotalTax

public java.math.BigDecimal getTotalTax()

setTotalTax

public void setTotalTax(java.math.BigDecimal totalTax)

getPoNumber

public java.lang.String getPoNumber()

setPoNumber

public void setPoNumber(java.lang.String poNumber)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getDelayDays

public int getDelayDays()

setDelayDays

public void setDelayDays(int delayDays)

getGrantTotal

public java.math.BigDecimal getGrantTotal()

setGrantTotal

public void setGrantTotal(java.math.BigDecimal grantTotal)

getItemCounts

public java.lang.Long getItemCounts()

setItemCounts

public void setItemCounts(java.lang.Long itemCounts)

getItemQty

public java.math.BigDecimal getItemQty()

setItemQty

public void setItemQty(java.math.BigDecimal itemQty)

getLatestReceiverDate

public java.util.Date getLatestReceiverDate()

setLatestReceiverDate

public void setLatestReceiverDate(java.util.Date latestReceiverDate)

getLatestShipDate

public java.util.Date getLatestShipDate()

setLatestShipDate

public void setLatestShipDate(java.util.Date latestShipDate)

getPoDate

public java.util.Date getPoDate()

setPoDate

public void setPoDate(java.util.Date poDate)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getRequester

public java.lang.String getRequester()

setRequester

public void setRequester(java.lang.String requester)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getVendorName

public java.lang.String getVendorName()

setVendorName

public void setVendorName(java.lang.String vendorName)

getVendorSalesOrder

public java.lang.String getVendorSalesOrder()

setVendorSalesOrder

public void setVendorSalesOrder(java.lang.String vendorSalesOrder)

getTotalFreight

public java.math.BigDecimal getTotalFreight()

setTotalFreight

public void setTotalFreight(java.math.BigDecimal totalFreight)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PostCheckAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PostCheckAgent

java.lang.Object
    extended by  bb.common.PostCheckAgent
All Implemented Interfaces:
java.io.Serializable
public class PostCheckAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PostCheckAgent()
Method Summary
java.math.BigDecimal | getCheckAmount()
java.lang.String | getCheckNumber()
java.lang.String | getCompanyUnitOfCreditAcc()
java.lang.String | getCompanyUnitOfDebitAcc()
java.lang.String | getCreditAccount()
java.lang.String | getCustomerId()
java.lang.String | getDebitAccount()
java.lang.String | getGlSummary()
java.lang.String | getId()
java.lang.String | getInvoiceNumber()
java.util.Date | getMakeDate()
java.lang.String | getMemo()
java.lang.String | getSoNumber()
void | setCheckAmount(java.math.BigDecimal checkAmount)
void | setCheckNumber(java.lang.String checkNumber)
void | setCompanyUnitOfCreditAcc(java.lang.String companyUnitOfCreditAcc)
void | setCompanyUnitOfDebitAcc(java.lang.String companyUnitOfDebitAcc)
void | setCreditAccount(java.lang.String creditAccount)
void | setCustomerId(java.lang.String customerId)
void | setDebitAccount(java.lang.String debitAccount)
void | setGlSummary(java.lang.String glSummary)
void | setId(java.lang.String id)
void | setInvoiceNumber(java.lang.String invoiceNumber)
void | setMakeDate(java.util.Date makeDate)
void | setMemo(java.lang.String memo)
void | setSoNumber(java.lang.String soNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PostCheckAgent

public PostCheckAgent()
Method Detail

getMemo

public java.lang.String getMemo()

getDebitAccount

public java.lang.String getDebitAccount()

getMakeDate

public java.util.Date getMakeDate()

getCheckNumber

public java.lang.String getCheckNumber()

getCheckAmount

public java.math.BigDecimal getCheckAmount()

getId

public java.lang.String getId()

setMemo

public void setMemo(java.lang.String memo)

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

setMakeDate

public void setMakeDate(java.util.Date makeDate)

setCheckNumber

public void setCheckNumber(java.lang.String checkNumber)

setCheckAmount

public void setCheckAmount(java.math.BigDecimal checkAmount)

setId

public void setId(java.lang.String id)

setInvoiceNumber

public void setInvoiceNumber(java.lang.String invoiceNumber)

setCreditAccount

public void setCreditAccount(java.lang.String creditAccount)

setSoNumber

public void setSoNumber(java.lang.String soNumber)

setCustomerId

public void setCustomerId(java.lang.String customerId)

getInvoiceNumber

public java.lang.String getInvoiceNumber()

getCreditAccount

public java.lang.String getCreditAccount()

getSoNumber

public java.lang.String getSoNumber()

getCustomerId

public java.lang.String getCustomerId()

getCompanyUnitOfCreditAcc

public java.lang.String getCompanyUnitOfCreditAcc()

setCompanyUnitOfCreditAcc

public void setCompanyUnitOfCreditAcc(java.lang.String companyUnitOfCreditAcc)

getCompanyUnitOfDebitAcc

public java.lang.String getCompanyUnitOfDebitAcc()

setCompanyUnitOfDebitAcc

public void setCompanyUnitOfDebitAcc(java.lang.String companyUnitOfDebitAcc)

getGlSummary

public java.lang.String getGlSummary()

setGlSummary

public void setGlSummary(java.lang.String glSummary)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POSurveyReportAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class POSurveyReportAgent

java.lang.Object
    extended by  bb.common.POSurveyReportAgent
All Implemented Interfaces:
java.io.Serializable
public class POSurveyReportAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
POSurveyReportAgent()
Method Summary
java.lang.String | getContractNumber()
java.lang.String | getPoNumber()
java.util.Set<POSurveyReportItemVO> | getPoSurveyReportItem()
java.lang.String | getProjectName()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
java.lang.String | getVendorSalesOrder()
void | setContractNumber(java.lang.String contractNumber)
void | setPoNumber(java.lang.String poNumber)
void | setPoSurveyReportItem(java.util.Set<POSurveyReportItemVO> poSurveyReportItem)
void | setProjectName(java.lang.String projectName)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
void | setVendorSalesOrder(java.lang.String vendorSalesOrder)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

POSurveyReportAgent

public POSurveyReportAgent()
Method Detail

getContractNumber

public java.lang.String getContractNumber()

setContractNumber

public void setContractNumber(java.lang.String contractNumber)

getProjectName

public java.lang.String getProjectName()

setProjectName

public void setProjectName(java.lang.String projectName)

getVendorSalesOrder

public java.lang.String getVendorSalesOrder()

setVendorSalesOrder

public void setVendorSalesOrder(java.lang.String vendorSalesOrder)

getPoSurveyReportItem

public java.util.Set<POSurveyReportItemVO> getPoSurveyReportItem()

setPoSurveyReportItem

public void setPoSurveyReportItem(java.util.Set<POSurveyReportItemVO> poSurveyReportItem)

getPoNumber

public java.lang.String getPoNumber()

setPoNumber

public void setPoNumber(java.lang.String poNumber)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getVendorName

public java.lang.String getVendorName()

setVendorName

public void setVendorName(java.lang.String vendorName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POSurveyReportItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class POSurveyReportItemPK

java.lang.Object
    extended by  bb.common.POSurveyReportItemPK
All Implemented Interfaces:
java.io.Serializable
public class POSurveyReportItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
POSurveyReportItemPK()
POSurveyReportItemPK(java.lang.String srNumber, java.lang.String srItemNumber)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getSrItemNumber()
java.lang.String | getSrNumber()
int | hashCode()
void | setSrItemNumber(java.lang.String srItemNumber)
void | setSrNumber(java.lang.String srNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

POSurveyReportItemPK

public POSurveyReportItemPK()

POSurveyReportItemPK

public POSurveyReportItemPK(java.lang.String srNumber,
                            java.lang.String srItemNumber)
Method Detail

getSrItemNumber

public java.lang.String getSrItemNumber()

setSrItemNumber

public void setSrItemNumber(java.lang.String srItemNumber)

getSrNumber

public java.lang.String getSrNumber()

setSrNumber

public void setSrNumber(java.lang.String srNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POSurveyReportItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class POSurveyReportItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.POSurveyReportItemVO
All Implemented Interfaces:
java.io.Serializable
public class POSurveyReportItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
POSurveyReportItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDescription()
java.lang.String | getDwg()
java.lang.String | getPackCondition()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
POSurveyReportItemPK | getPk()
java.math.BigDecimal | getQuantityOrdered()
java.math.BigDecimal | getQuantityQualified()
java.math.BigDecimal | getQuantityReceived()
java.lang.String | getSpecification()
java.lang.String | getSrResult()
java.lang.String | getTestReport()
java.lang.String | getUnit()
int | hashCode()
void | setDescription(java.lang.String description)
void | setDwg(java.lang.String dwg)
void | setPackCondition(java.lang.String packCondition)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(POSurveyReportItemPK pk)
void | setQuantityOrdered(java.math.BigDecimal quantityOrdered)
void | setQuantityQualified(java.math.BigDecimal quantityQualified)
void | setQuantityReceived(java.math.BigDecimal quantityReceived)
void | setSpecification(java.lang.String specification)
void | setSrResult(java.lang.String srResult)
void | setTestReport(java.lang.String testReport)
void | setUnit(java.lang.String unit)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

POSurveyReportItemVO

public POSurveyReportItemVO()
Method Detail

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getDwg

public java.lang.String getDwg()

setDwg

public void setDwg(java.lang.String dwg)

getPackCondition

public java.lang.String getPackCondition()

setPackCondition

public void setPackCondition(java.lang.String packCondition)

getSpecification

public java.lang.String getSpecification()

setSpecification

public void setSpecification(java.lang.String specification)

getTestReport

public java.lang.String getTestReport()

setTestReport

public void setTestReport(java.lang.String testReport)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPk

public POSurveyReportItemPK getPk()

setPk

public void setPk(POSurveyReportItemPK pk)

getQuantityOrdered

public java.math.BigDecimal getQuantityOrdered()

setQuantityOrdered

public void setQuantityOrdered(java.math.BigDecimal quantityOrdered)

getQuantityQualified

public java.math.BigDecimal getQuantityQualified()

setQuantityQualified

public void setQuantityQualified(java.math.BigDecimal quantityQualified)

getQuantityReceived

public java.math.BigDecimal getQuantityReceived()

setQuantityReceived

public void setQuantityReceived(java.math.BigDecimal quantityReceived)

getSrResult

public java.lang.String getSrResult()

setSrResult

public void setSrResult(java.lang.String srResult)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


POSurveyReportVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class POSurveyReportVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.POSurveyReportVO
All Implemented Interfaces:
java.io.Serializable
public class POSurveyReportVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CONTRACTNUMBER
static java.lang.String | ORDER_BY_ENGACCEPTEMPLOYEE
static java.lang.String | ORDER_BY_POACCEPTEMPLOYEE
static java.lang.String | ORDER_BY_PROJECTNAME
static java.lang.String | ORDER_BY_PURCHASEORDERNUMBER
static java.lang.String | ORDER_BY_QAACCEPTEMPLOYEE
static java.lang.String | ORDER_BY_SRNUMBER
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_VENDORNAME
static java.lang.String | ORDER_BY_VENDORSALESORDER
static java.lang.String | ORDER_BY_WAREACCEPTEMPLOYEE
Constructor Summary
POSurveyReportVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.lang.String | getComments()
java.lang.String | getContractNumber()
java.lang.String | getEngAcceptEmployee()
java.util.Date | getLastChangeDate()
int | getLastChangeTimes()
java.lang.String | getLastChangeUser()
java.lang.String | getOrigin()
java.lang.String | getPoAcceptEmployee()
java.util.Set<POSurveyReportItemVO> | getPoSurveyReportItem()
java.lang.String | getProjectName()
java.lang.String | getPurchaseOrderNumber()
java.lang.String | getQaAcceptEmployee()
java.lang.String | getSrNumber()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
java.lang.String | getVendorSalesOrder()
java.lang.String | getWareAcceptEmployee()
int | hashCode()
void | setAdate(java.util.Date adate)
void | setComments(java.lang.String comments)
void | setContractNumber(java.lang.String contractNumber)
void | setEngAcceptEmployee(java.lang.String engAcceptEmployee)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTimes(int lastChangeTimes)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setOrigin(java.lang.String origin)
void | setPoAcceptEmployee(java.lang.String poAcceptEmployee)
void | setPoSurveyReportItem(java.util.Set<POSurveyReportItemVO> poSurveyReportItem)
void | setProjectName(java.lang.String projectName)
void | setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)
void | setQaAcceptEmployee(java.lang.String qaAcceptEmployee)
void | setSrNumber(java.lang.String srNumber)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
void | setVendorSalesOrder(java.lang.String vendorSalesOrder)
void | setWareAcceptEmployee(java.lang.String wareAcceptEmployee)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_SRNUMBER

public static final java.lang.String ORDER_BY_SRNUMBER
See Also:
Constant Field Values

ORDER_BY_PURCHASEORDERNUMBER

public static final java.lang.String ORDER_BY_PURCHASEORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_CONTRACTNUMBER

public static final java.lang.String ORDER_BY_CONTRACTNUMBER
See Also:
Constant Field Values

ORDER_BY_PROJECTNAME

public static final java.lang.String ORDER_BY_PROJECTNAME
See Also:
Constant Field Values

ORDER_BY_VENDORSALESORDER

public static final java.lang.String ORDER_BY_VENDORSALESORDER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_VENDORNAME

public static final java.lang.String ORDER_BY_VENDORNAME
See Also:
Constant Field Values

ORDER_BY_ENGACCEPTEMPLOYEE

public static final java.lang.String ORDER_BY_ENGACCEPTEMPLOYEE
See Also:
Constant Field Values

ORDER_BY_QAACCEPTEMPLOYEE

public static final java.lang.String ORDER_BY_QAACCEPTEMPLOYEE
See Also:
Constant Field Values

ORDER_BY_POACCEPTEMPLOYEE

public static final java.lang.String ORDER_BY_POACCEPTEMPLOYEE
See Also:
Constant Field Values

ORDER_BY_WAREACCEPTEMPLOYEE

public static final java.lang.String ORDER_BY_WAREACCEPTEMPLOYEE
See Also:
Constant Field Values
Constructor Detail

POSurveyReportVO

public POSurveyReportVO()
Method Detail

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getContractNumber

public java.lang.String getContractNumber()

setContractNumber

public void setContractNumber(java.lang.String contractNumber)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeTimes

public int getLastChangeTimes()

setLastChangeTimes

public void setLastChangeTimes(int lastChangeTimes)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getProjectName

public java.lang.String getProjectName()

setProjectName

public void setProjectName(java.lang.String projectName)

getSrNumber

public java.lang.String getSrNumber()

setSrNumber

public void setSrNumber(java.lang.String srNumber)

getVendorSalesOrder

public java.lang.String getVendorSalesOrder()

setVendorSalesOrder

public void setVendorSalesOrder(java.lang.String vendorSalesOrder)

getPoSurveyReportItem

public java.util.Set<POSurveyReportItemVO> getPoSurveyReportItem()

setPoSurveyReportItem

public void setPoSurveyReportItem(java.util.Set<POSurveyReportItemVO> poSurveyReportItem)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getPurchaseOrderNumber

public java.lang.String getPurchaseOrderNumber()

setPurchaseOrderNumber

public void setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getEngAcceptEmployee

public java.lang.String getEngAcceptEmployee()

setEngAcceptEmployee

public void setEngAcceptEmployee(java.lang.String engAcceptEmployee)

getPoAcceptEmployee

public java.lang.String getPoAcceptEmployee()

setPoAcceptEmployee

public void setPoAcceptEmployee(java.lang.String poAcceptEmployee)

getQaAcceptEmployee

public java.lang.String getQaAcceptEmployee()

setQaAcceptEmployee

public void setQaAcceptEmployee(java.lang.String qaAcceptEmployee)

getWareAcceptEmployee

public java.lang.String getWareAcceptEmployee()

setWareAcceptEmployee

public void setWareAcceptEmployee(java.lang.String wareAcceptEmployee)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getVendorName

public java.lang.String getVendorName()

setVendorName

public void setVendorName(java.lang.String vendorName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PosZipCodeTaxPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PosZipCodeTaxPK

java.lang.Object
    extended by  bb.common.PosZipCodeTaxPK
All Implemented Interfaces:
java.io.Serializable
public class PosZipCodeTaxPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PosZipCodeTaxPK()
PosZipCodeTaxPK(java.lang.String zipCodeStart, java.lang.String zipCodeEnd)
Method Summary
boolean | equals(java.lang.Object obj)
java.lang.String | getZipCodeEnd()
java.lang.String | getZipCodeStart()
int | hashCode()
void | setZipCodeEnd(java.lang.String zipCodeEnd)
void | setZipCodeStart(java.lang.String zipCodeStart)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PosZipCodeTaxPK

public PosZipCodeTaxPK()

PosZipCodeTaxPK

public PosZipCodeTaxPK(java.lang.String zipCodeStart,
                       java.lang.String zipCodeEnd)
Method Detail

getZipCodeStart

public java.lang.String getZipCodeStart()

setZipCodeStart

public void setZipCodeStart(java.lang.String zipCodeStart)

getZipCodeEnd

public java.lang.String getZipCodeEnd()

setZipCodeEnd

public void setZipCodeEnd(java.lang.String zipCodeEnd)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PosZipCodeTaxVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PosZipCodeTaxVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PosZipCodeTaxVO
All Implemented Interfaces:
java.io.Serializable
public class PosZipCodeTaxVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CITYCODE
static java.lang.String | ORDER_BY_COUNTYCODE
static java.lang.String | ORDER_BY_TAX
static java.lang.String | ORDER_BY_ZIPCODE
Constructor Summary
PosZipCodeTaxVO()
Method Summary
boolean | equals(java.lang.Object obj)
java.lang.String | getCityCode()
java.lang.String | getCityName()
java.math.BigDecimal | getCityTaxRate()
java.lang.String | getCountyCode()
java.lang.String | getCountyName()
java.math.BigDecimal | getCountyTaxRate()
java.lang.String | getDescription()
java.lang.String | getNotes()
PosZipCodeTaxPK | getPk()
java.lang.String | getStateName()
java.math.BigDecimal | getStateTaxRate()
java.math.BigDecimal | getTaxRate()
int | hashCode()
void | setCityCode(java.lang.String cityCode)
void | setCityName(java.lang.String cityName)
void | setCityTaxRate(java.math.BigDecimal cityTaxRate)
void | setCountyCode(java.lang.String countyCode)
void | setCountyName(java.lang.String countyName)
void | setCountyTaxRate(java.math.BigDecimal countyTaxRate)
void | setDescription(java.lang.String description)
void | setNotes(java.lang.String notes)
void | setPk(PosZipCodeTaxPK pk)
void | setStateName(java.lang.String stateName)
void | setStateTaxRate(java.math.BigDecimal stateTaxRate)
void | setTaxRate(java.math.BigDecimal taxRate)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ZIPCODE

public static final java.lang.String ORDER_BY_ZIPCODE
See Also:
Constant Field Values

ORDER_BY_TAX

public static final java.lang.String ORDER_BY_TAX
See Also:
Constant Field Values

ORDER_BY_CITYCODE

public static final java.lang.String ORDER_BY_CITYCODE
See Also:
Constant Field Values

ORDER_BY_COUNTYCODE

public static final java.lang.String ORDER_BY_COUNTYCODE
See Also:
Constant Field Values
Constructor Detail

PosZipCodeTaxVO

public PosZipCodeTaxVO()
Method Detail

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getNotes

public java.lang.String getNotes()

setNotes

public void setNotes(java.lang.String notes)

getStateName

public java.lang.String getStateName()

setStateName

public void setStateName(java.lang.String stateName)

getStateTaxRate

public java.math.BigDecimal getStateTaxRate()

setStateTaxRate

public void setStateTaxRate(java.math.BigDecimal stateTaxRate)

getCityName

public java.lang.String getCityName()

setCityName

public void setCityName(java.lang.String cityName)

getCityTaxRate

public java.math.BigDecimal getCityTaxRate()

setCityTaxRate

public void setCityTaxRate(java.math.BigDecimal cityTaxRate)

getCountyName

public java.lang.String getCountyName()

setCountyName

public void setCountyName(java.lang.String countyName)

getCountyTaxRate

public java.math.BigDecimal getCountyTaxRate()

setCountyTaxRate

public void setCountyTaxRate(java.math.BigDecimal countyTaxRate)

getPk

public PosZipCodeTaxPK getPk()

setPk

public void setPk(PosZipCodeTaxPK pk)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getCityCode

public java.lang.String getCityCode()

setCityCode

public void setCityCode(java.lang.String cityCode)

getCountyCode

public java.lang.String getCountyCode()

setCountyCode

public void setCountyCode(java.lang.String countyCode)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PrepayAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PrepayAgent

java.lang.Object
    extended by  bb.common.PrepayAgent
All Implemented Interfaces:
java.io.Serializable
public class PrepayAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PrepayAgent()
Method Summary
java.lang.String | getChangeOrder()
java.lang.String | getCurrency()
java.lang.String | getOrderNumber()
java.math.BigDecimal | getTotal()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
void | setChangeOrder(java.lang.String changeOrder)
void | setCurrency(java.lang.String currency)
void | setOrderNumber(java.lang.String orderNumber)
void | setTotal(java.math.BigDecimal total)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PrepayAgent

public PrepayAgent()
Method Detail

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getOrderNumber

public java.lang.String getOrderNumber()

setOrderNumber

public void setOrderNumber(java.lang.String orderNumber)

getTotal

public java.math.BigDecimal getTotal()

setTotal

public void setTotal(java.math.BigDecimal total)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getVendorName

public java.lang.String getVendorName()

setVendorName

public void setVendorName(java.lang.String vendorName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PrepaymentWireTransferAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PrepaymentWireTransferAgent

java.lang.Object
    extended by  bb.common.PrepaymentWireTransferAgent
All Implemented Interfaces:
java.io.Serializable
public class PrepaymentWireTransferAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PrepaymentWireTransferAgent()
Method Summary
ApPrepayItemPK[] | getAppiPk()
java.lang.String | getBankTransferFeeAccount()
java.lang.String | getCompanyUnitOfCreditAcc()
java.lang.String | getCompanyUnitOfDebitAcc()
java.lang.String | getCompanyUnitOfTransferFeeAcc()
java.lang.String | getCreditAccount()
java.lang.String | getDebitAccount()
java.lang.String[] | getExcludeVendorId()
java.util.Date | getFromDate()
java.lang.String[] | getIncludeVendorId()
java.util.Date | getToDate()
java.util.Date | getTransactionDate()
java.lang.String | getWireTransferNo()
void | setAppiPk(ApPrepayItemPK[] appiPk)
void | setBankTransferFeeAccount(java.lang.String bankTransferFeeAccount)
void | setCompanyUnitOfCreditAcc(java.lang.String companyUnitOfCreditAcc)
void | setCompanyUnitOfDebitAcc(java.lang.String companyUnitOfDebitAcc)
void | setCompanyUnitOfTransferFeeAcc(java.lang.String companyUnitOfTransferFeeAcc)
void | setCreditAccount(java.lang.String creditAccount)
void | setDebitAccount(java.lang.String debitAccount)
void | setExcludeVendorId(java.lang.String[] excludeVendorId)
void | setFromDate(java.util.Date fromDate)
void | setIncludeVendorId(java.lang.String[] includeVendorId)
void | setToDate(java.util.Date toDate)
void | setTransactionDate(java.util.Date transactionDate)
void | setWireTransferNo(java.lang.String wireTransferNo)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PrepaymentWireTransferAgent

public PrepaymentWireTransferAgent()
Method Detail

getAppiPk

public ApPrepayItemPK[] getAppiPk()

setAppiPk

public void setAppiPk(ApPrepayItemPK[] appiPk)

getBankTransferFeeAccount

public java.lang.String getBankTransferFeeAccount()

setBankTransferFeeAccount

public void setBankTransferFeeAccount(java.lang.String bankTransferFeeAccount)

getCompanyUnitOfCreditAcc

public java.lang.String getCompanyUnitOfCreditAcc()

setCompanyUnitOfCreditAcc

public void setCompanyUnitOfCreditAcc(java.lang.String companyUnitOfCreditAcc)

getCompanyUnitOfDebitAcc

public java.lang.String getCompanyUnitOfDebitAcc()

setCompanyUnitOfDebitAcc

public void setCompanyUnitOfDebitAcc(java.lang.String companyUnitOfDebitAcc)

getCompanyUnitOfTransferFeeAcc

public java.lang.String getCompanyUnitOfTransferFeeAcc()

setCompanyUnitOfTransferFeeAcc

public void setCompanyUnitOfTransferFeeAcc(java.lang.String companyUnitOfTransferFeeAcc)

getCreditAccount

public java.lang.String getCreditAccount()

setCreditAccount

public void setCreditAccount(java.lang.String creditAccount)

getDebitAccount

public java.lang.String getDebitAccount()

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

getExcludeVendorId

public java.lang.String[] getExcludeVendorId()

setExcludeVendorId

public void setExcludeVendorId(java.lang.String[] excludeVendorId)

getFromDate

public java.util.Date getFromDate()

setFromDate

public void setFromDate(java.util.Date fromDate)

getIncludeVendorId

public java.lang.String[] getIncludeVendorId()

setIncludeVendorId

public void setIncludeVendorId(java.lang.String[] includeVendorId)

getToDate

public java.util.Date getToDate()

setToDate

public void setToDate(java.util.Date toDate)

getTransactionDate

public java.util.Date getTransactionDate()

setTransactionDate

public void setTransactionDate(java.util.Date transactionDate)

getWireTransferNo

public java.lang.String getWireTransferNo()

setWireTransferNo

public void setWireTransferNo(java.lang.String wireTransferNo)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PrepayPaymentAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PrepayPaymentAgent

java.lang.Object
    extended by  bb.common.PrepayPaymentAgent
All Implemented Interfaces:
java.io.Serializable
public class PrepayPaymentAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PrepayPaymentAgent()
Method Summary
java.lang.String | getAccountNumber()
java.lang.String | getAddressId()
java.lang.String | getBatchRunNumber()
java.lang.String | getCheckNumber()
java.lang.String | getComments()
java.lang.String | getCompanyUnitId()
java.util.Date | getDatePaid()
java.math.BigDecimal | getExchange()
java.lang.String | getGlSummary()
java.lang.String | getPrapayItemNumber()
java.lang.String | getPrepayNumber()
java.math.BigDecimal | getTotalPaid()
void | setAccountNumber(java.lang.String accountNumber)
void | setAddressId(java.lang.String addressId)
void | setBatchRunNumber(java.lang.String batchRunNumber)
void | setCheckNumber(java.lang.String checkNumber)
void | setComments(java.lang.String comments)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setDatePaid(java.util.Date datePaid)
void | setExchange(java.math.BigDecimal exchange)
void | setGlSummary(java.lang.String glSummary)
void | setPrapayItemNumber(java.lang.String prapayItemNumber)
void | setPrepayNumber(java.lang.String prepayNumber)
void | setTotalPaid(java.math.BigDecimal totalPaid)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PrepayPaymentAgent

public PrepayPaymentAgent()
Method Detail

getComments

public java.lang.String getComments()

getTotalPaid

public java.math.BigDecimal getTotalPaid()

getCheckNumber

public java.lang.String getCheckNumber()

getAccountNumber

public java.lang.String getAccountNumber()

setDatePaid

public void setDatePaid(java.util.Date datePaid)

setComments

public void setComments(java.lang.String comments)

setTotalPaid

public void setTotalPaid(java.math.BigDecimal totalPaid)

setCheckNumber

public void setCheckNumber(java.lang.String checkNumber)

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

setAddressId

public void setAddressId(java.lang.String addressId)

getDatePaid

public java.util.Date getDatePaid()

getAddressId

public java.lang.String getAddressId()

getBatchRunNumber

public java.lang.String getBatchRunNumber()

setBatchRunNumber

public void setBatchRunNumber(java.lang.String batchRunNumber)

getPrapayItemNumber

public java.lang.String getPrapayItemNumber()

setPrapayItemNumber

public void setPrapayItemNumber(java.lang.String prapayItemNumber)

getPrepayNumber

public java.lang.String getPrepayNumber()

setPrepayNumber

public void setPrepayNumber(java.lang.String prepayNumber)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getGlSummary

public java.lang.String getGlSummary()

setGlSummary

public void setGlSummary(java.lang.String glSummary)

getExchange

public java.math.BigDecimal getExchange()

setExchange

public void setExchange(java.math.BigDecimal exchange)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PreventiveActionRequestItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PreventiveActionRequestItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PreventiveActionRequestItemVO
All Implemented Interfaces:
java.io.Serializable
public class PreventiveActionRequestItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PreventiveActionRequestItemVO()
default constructor
Method Summary
java.lang.String | getDescription()
long | getDocLength()
java.lang.String | getDocName()
java.lang.String | getExtension()
java.lang.Long | getParItemNumber()
java.lang.String | getParNumber()
java.lang.String | getStatus()
void | setDescription(java.lang.String description)
void | setDocLength(long docLength)
void | setDocName(java.lang.String docName)
void | setExtension(java.lang.String extension)
void | setParItemNumber(java.lang.Long parItemNumber)
void | setParNumber(java.lang.String parNumber)
void | setStatus(java.lang.String status)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PreventiveActionRequestItemVO

public PreventiveActionRequestItemVO()
default constructor

Method Detail

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getParItemNumber

public java.lang.Long getParItemNumber()

setParItemNumber

public void setParItemNumber(java.lang.Long parItemNumber)

getParNumber

public java.lang.String getParNumber()

setParNumber

public void setParNumber(java.lang.String parNumber)

getDocLength

public long getDocLength()

setDocLength

public void setDocLength(long docLength)

getDocName

public java.lang.String getDocName()

setDocName

public void setDocName(java.lang.String docName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PreventiveActionRequestVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PreventiveActionRequestVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PreventiveActionRequestVO
All Implemented Interfaces:
java.io.Serializable
public class PreventiveActionRequestVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DATEENTERED
static java.lang.String | ORDER_BY_DEPARTMENTID
static java.lang.String | ORDER_BY_DEPARTMENTNAME
static java.lang.String | ORDER_BY_DUEDATE
static java.lang.String | ORDER_BY_LASTCHANGEDATE
static java.lang.String | ORDER_BY_LASTCHANGEUSER
static java.lang.String | ORDER_BY_PARNUMBER
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
PreventiveActionRequestVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAcknowledgedBy()
java.util.Date | getAdate()
java.lang.String | getApprovedBy()
java.lang.String | getClosedOutApproval()
java.lang.String | getClosedOutComments()
java.util.Date | getClosedOutDate()
java.lang.String | getClosedOutPrivateNotes()
java.lang.String | getConditionDescription()
java.util.Date | getDateEntered()
java.lang.String | getDepartmentId()
java.lang.String | getDepartmentName()
java.lang.String | getDescription()
java.util.Date | getDueDate()
java.lang.String | getEnteredBy()
java.util.Date | getImplementionDue()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getModelNumber()
java.lang.String | getNotedBy()
java.lang.String | getOrigin()
java.lang.String | getParNumber()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.util.Set | getPreventiveActionRequestItems()
java.lang.String | getProposedAction()
java.util.Date | getProposedActionDate()
java.lang.String | getProposedBy()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.lang.String | getRevision()
java.lang.String | getStatus()
java.lang.String | getThirdParty()
java.lang.Integer | getVersion()
int | hashCode()
void | setAcknowledgedBy(java.lang.String acknowledgedBy)
void | setAdate(java.util.Date adate)
void | setApprovedBy(java.lang.String approvedBy)
void | setClosedOutApproval(java.lang.String closedOutApproval)
void | setClosedOutComments(java.lang.String closedOutComments)
void | setClosedOutDate(java.util.Date closedOutDate)
void | setClosedOutPrivateNotes(java.lang.String closedOutPrivateNotes)
void | setConditionDescription(java.lang.String conditionDescription)
void | setDateEntered(java.util.Date dateEntered)
void | setDepartmentId(java.lang.String departmentId)
void | setDepartmentName(java.lang.String departmentName)
void | setDescription(java.lang.String description)
void | setDueDate(java.util.Date dueDate)
void | setEnteredBy(java.lang.String enteredBy)
void | setImplementionDue(java.util.Date implementionDue)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setModelNumber(java.lang.String modelNumber)
void | setNotedBy(java.lang.String notedBy)
void | setOrigin(java.lang.String origin)
void | setParNumber(java.lang.String parNumber)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPreventiveActionRequestItems(java.util.Set preventiveActionRequestItems)
void | setProposedAction(java.lang.String proposedAction)
void | setProposedActionDate(java.util.Date proposedActionDate)
void | setProposedBy(java.lang.String proposedBy)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setRevision(java.lang.String revision)
void | setStatus(java.lang.String status)
void | setThirdParty(java.lang.String thirdParty)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PARNUMBER

public static final java.lang.String ORDER_BY_PARNUMBER
See Also:
Constant Field Values

ORDER_BY_DUEDATE

public static final java.lang.String ORDER_BY_DUEDATE
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEUSER

public static final java.lang.String ORDER_BY_LASTCHANGEUSER
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEDATE

public static final java.lang.String ORDER_BY_LASTCHANGEDATE
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_DEPARTMENTID

public static final java.lang.String ORDER_BY_DEPARTMENTID
See Also:
Constant Field Values

ORDER_BY_DEPARTMENTNAME

public static final java.lang.String ORDER_BY_DEPARTMENTNAME
See Also:
Constant Field Values

ORDER_BY_DATEENTERED

public static final java.lang.String ORDER_BY_DATEENTERED
See Also:
Constant Field Values
Constructor Detail

PreventiveActionRequestVO

public PreventiveActionRequestVO()
default constructor

Method Detail

getParNumber

public java.lang.String getParNumber()

setParNumber

public void setParNumber(java.lang.String parNumber)

getDueDate

public java.util.Date getDueDate()

setDueDate

public void setDueDate(java.util.Date dueDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getDateEntered

public java.util.Date getDateEntered()

setDateEntered

public void setDateEntered(java.util.Date dateEntered)

getEnteredBy

public java.lang.String getEnteredBy()

setEnteredBy

public void setEnteredBy(java.lang.String enteredBy)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getDepartmentId

public java.lang.String getDepartmentId()

setDepartmentId

public void setDepartmentId(java.lang.String departmentId)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getThirdParty

public java.lang.String getThirdParty()

setThirdParty

public void setThirdParty(java.lang.String thirdParty)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getConditionDescription

public java.lang.String getConditionDescription()

setConditionDescription

public void setConditionDescription(java.lang.String conditionDescription)

getNotedBy

public java.lang.String getNotedBy()

setNotedBy

public void setNotedBy(java.lang.String notedBy)

getAcknowledgedBy

public java.lang.String getAcknowledgedBy()

setAcknowledgedBy

public void setAcknowledgedBy(java.lang.String acknowledgedBy)

getProposedAction

public java.lang.String getProposedAction()

setProposedAction

public void setProposedAction(java.lang.String proposedAction)

getProposedBy

public java.lang.String getProposedBy()

setProposedBy

public void setProposedBy(java.lang.String proposedBy)

getApprovedBy

public java.lang.String getApprovedBy()

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)

getProposedActionDate

public java.util.Date getProposedActionDate()

setProposedActionDate

public void setProposedActionDate(java.util.Date proposedActionDate)

getImplementionDue

public java.util.Date getImplementionDue()

setImplementionDue

public void setImplementionDue(java.util.Date implementionDue)

getClosedOutApproval

public java.lang.String getClosedOutApproval()

setClosedOutApproval

public void setClosedOutApproval(java.lang.String closedOutApproval)

getClosedOutDate

public java.util.Date getClosedOutDate()

setClosedOutDate

public void setClosedOutDate(java.util.Date closedOutDate)

getClosedOutComments

public java.lang.String getClosedOutComments()

setClosedOutComments

public void setClosedOutComments(java.lang.String closedOutComments)

getClosedOutPrivateNotes

public java.lang.String getClosedOutPrivateNotes()

setClosedOutPrivateNotes

public void setClosedOutPrivateNotes(java.lang.String closedOutPrivateNotes)

getPreventiveActionRequestItems

public java.util.Set getPreventiveActionRequestItems()

getVersion

public java.lang.Integer getVersion()

getLastChangeUser

public java.lang.String getLastChangeUser()

getLastChangeDate

public java.util.Date getLastChangeDate()

getDepartmentName

public java.lang.String getDepartmentName()

getPartFrom

public java.lang.String getPartFrom()

setPreventiveActionRequestItems

public void setPreventiveActionRequestItems(java.util.Set preventiveActionRequestItems)

setVersion

public void setVersion(java.lang.Integer version)

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

setDepartmentName

public void setDepartmentName(java.lang.String departmentName)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PrintLogoVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PrintLogoVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PrintLogoVO
All Implemented Interfaces:
java.io.Serializable
public class PrintLogoVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_EXTENSION
static java.lang.String | ORDER_BY_LENGTH
static java.lang.String | ORDER_BY_LOGONAME
Constructor Summary
PrintLogoVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getExtension()
java.util.Date | getLastChangeDate()
java.lang.Integer | getLength()
byte[] | getLogo()
java.lang.String | getLogoName()
int | hashCode()
void | setExtension(java.lang.String extension)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLength(java.lang.Integer length)
void | setLogo(byte[] logo)
void | setLogoName(java.lang.String logoName)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_LOGONAME

public static final java.lang.String ORDER_BY_LOGONAME
See Also:
Constant Field Values

ORDER_BY_EXTENSION

public static final java.lang.String ORDER_BY_EXTENSION
See Also:
Constant Field Values

ORDER_BY_LENGTH

public static final java.lang.String ORDER_BY_LENGTH
See Also:
Constant Field Values
Constructor Detail

PrintLogoVO

public PrintLogoVO()
default constructor

Method Detail

getLogoName

public java.lang.String getLogoName()

setLogoName

public void setLogoName(java.lang.String logoName)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLogo

public byte[] getLogo()

setLogo

public void setLogo(byte[] logo)

getExtension

public java.lang.String getExtension()

getLength

public java.lang.Integer getLength()

setExtension

public void setExtension(java.lang.String extension)

setLength

public void setLength(java.lang.Integer length)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PrintTemplateVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PrintTemplateVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PrintTemplateVO
All Implemented Interfaces:
java.io.Serializable
public class PrintTemplateVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PrintTemplateVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.lang.String | getClazzName()
java.lang.String | getComments()
byte[] | getFile()
java.lang.String | getFileName()
int | getIi()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getOrigin()
java.lang.String | getTemplateName()
java.lang.Integer | getVersion()
int | hashCode()
void | setAdate(java.util.Date adate)
void | setClazzName(java.lang.String clazzName)
void | setComments(java.lang.String comments)
void | setFile(byte[] file)
void | setFileName(java.lang.String fileName)
void | setIi(int ii)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setOrigin(java.lang.String origin)
void | setTemplateName(java.lang.String templateName)
void | setVersion(java.lang.Integer version)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PrintTemplateVO

public PrintTemplateVO()
Method Detail

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getFile

public byte[] getFile()

setFile

public void setFile(byte[] file)

getVersion

public java.lang.Integer getVersion()

setVersion

public void setVersion(java.lang.Integer version)

getFileName

public java.lang.String getFileName()

setFileName

public void setFileName(java.lang.String fileName)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getClazzName

public java.lang.String getClazzName()

setClazzName

public void setClazzName(java.lang.String clazzName)

getIi

public int getIi()

setIi

public void setIi(int ii)

getTemplateName

public java.lang.String getTemplateName()

setTemplateName

public void setTemplateName(java.lang.String templateName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProfitAndLossAccountsResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ProfitAndLossAccountsResult

java.lang.Object
    extended by  bb.common.ProfitAndLossAccountsResult
All Implemented Interfaces:
java.io.Serializable
public class ProfitAndLossAccountsResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ProfitAndLossAccountsResult()
Method Summary
java.lang.String | getAccountNumber()
java.lang.String | getDescription()
java.lang.String | getPlAccountNumber()
java.lang.String | getPlDescription()
void | setAccountNumber(java.lang.String accountNumber)
void | setDescription(java.lang.String description)
void | setPlAccountNumber(java.lang.String plAccountNumber)
void | setPlDescription(java.lang.String plDescription)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ProfitAndLossAccountsResult

public ProfitAndLossAccountsResult()
Method Detail

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getPlAccountNumber

public java.lang.String getPlAccountNumber()

setPlAccountNumber

public void setPlAccountNumber(java.lang.String plAccountNumber)

getPlDescription

public java.lang.String getPlDescription()

setPlDescription

public void setPlDescription(java.lang.String plDescription)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProfitLossStatementItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ProfitLossStatementItemResult

java.lang.Object
    extended by  bb.common.ProfitLossStatementItemResult
All Implemented Interfaces:
java.io.Serializable
public class ProfitLossStatementItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ProfitLossStatementItemResult()
Method Summary
java.lang.String | getAccountNumber()
java.lang.String | getAccountType()
java.math.BigDecimal | getBudget()
java.lang.Double | getChangePercent()
java.math.BigDecimal | getChangePercentOfBudget()
java.math.BigDecimal | getCurrentPeriod()
java.lang.String | getDescription()
byte | getItems()
java.lang.String | getLevel()
java.math.BigDecimal | getPriorPeriod()
java.lang.Double | getSalesPercent()
java.lang.String | getType()
java.lang.String | getUpLevelAccountNumber()
void | setAccountNumber(java.lang.String accountNumber)
void | setAccountType(java.lang.String accountType)
void | setBudget(java.math.BigDecimal budget)
void | setChangePercent(java.lang.Double changePercent)
void | setChangePercentOfBudget(java.math.BigDecimal changePercentOfBudget)
void | setCurrentPeriod(java.math.BigDecimal currentPeriod)
void | setDescription(java.lang.String description)
void | setItems(byte items)
void | setLevel(java.lang.String level)
void | setPriorPeriod(java.math.BigDecimal priorPeriod)
void | setSalesPercent(java.lang.Double salesPercent)
void | setType(java.lang.String type)
void | setUpLevelAccountNumber(java.lang.String upLevelAccountNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ProfitLossStatementItemResult

public ProfitLossStatementItemResult()
Method Detail

getUpLevelAccountNumber

public java.lang.String getUpLevelAccountNumber()

getDescription

public java.lang.String getDescription()

getItems

public byte getItems()

getChangePercentOfBudget

public java.math.BigDecimal getChangePercentOfBudget()

getAccountType

public java.lang.String getAccountType()

getBudget

public java.math.BigDecimal getBudget()

getAccountNumber

public java.lang.String getAccountNumber()

getPriorPeriod

public java.math.BigDecimal getPriorPeriod()

getType

public java.lang.String getType()

getCurrentPeriod

public java.math.BigDecimal getCurrentPeriod()

setLevel

public void setLevel(java.lang.String level)

setUpLevelAccountNumber

public void setUpLevelAccountNumber(java.lang.String upLevelAccountNumber)

setDescription

public void setDescription(java.lang.String description)

setItems

public void setItems(byte items)

setChangePercentOfBudget

public void setChangePercentOfBudget(java.math.BigDecimal changePercentOfBudget)

setAccountType

public void setAccountType(java.lang.String accountType)

setBudget

public void setBudget(java.math.BigDecimal budget)

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

setPriorPeriod

public void setPriorPeriod(java.math.BigDecimal priorPeriod)

setType

public void setType(java.lang.String type)

setCurrentPeriod

public void setCurrentPeriod(java.math.BigDecimal currentPeriod)

setSalesPercent

public void setSalesPercent(java.lang.Double salesPercent)

setChangePercent

public void setChangePercent(java.lang.Double changePercent)

getLevel

public java.lang.String getLevel()

getSalesPercent

public java.lang.Double getSalesPercent()

getChangePercent

public java.lang.Double getChangePercent()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProfitLossStatementResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ProfitLossStatementResult

java.lang.Object
    extended by  bb.common.ProfitLossStatementResult
All Implemented Interfaces:
java.io.Serializable
public class ProfitLossStatementResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
 java.lang.String companyUnitId
Constructor Summary
ProfitLossStatementResult()
Method Summary
java.lang.String | getCompanyUnitId()
java.util.List | getCostOfSales()
java.util.Date | getCurrentPeriodFrom()
java.util.Date | getCurrentPeriodTo()
java.util.List | getGeneralAdmin()
java.math.BigDecimal | getGrossMargin()
ProfitLossStatementItemResult | getGrossProfit()
java.util.List | getIncomeFromOperating()
ProfitLossStatementItemResult | getNetProfit()
java.util.List | getOtherIncome()
java.util.Date | getPriorPeriodFrom()
java.util.Date | getPriorPeriodTo()
java.util.List | getResearchDevelopment()
java.math.BigDecimal | getReturnOnSales()
java.util.List | getSalesMarketing()
java.util.List | getSalesRevenue()
java.util.List | getTax()
ProfitLossStatementItemResult | getTotalCostOfSales()
ProfitLossStatementItemResult | getTotalGeneralAdmin()
ProfitLossStatementItemResult | getTotalIncomeFromOperating()
ProfitLossStatementItemResult | getTotalOperatingExpense()
ProfitLossStatementItemResult | getTotalOtherIncome()
ProfitLossStatementItemResult | getTotalResearchDevelopment()
ProfitLossStatementItemResult | getTotalSalesMarketing()
ProfitLossStatementItemResult | getTotalSalesRevenue()
ProfitLossStatementItemResult | getTotalTax()
ProfitLossStatementItemResult | getTotalWageLabor()
java.util.List | getWageLabor()
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCostOfSales(java.util.List costOfSales)
void | setCurrentPeriodFrom(java.util.Date currentPeriodFrom)
void | setCurrentPeriodTo(java.util.Date currentPeriodTo)
void | setGeneralAdmin(java.util.List generalAdmin)
void | setGrossMargin(java.math.BigDecimal grossMargin)
void | setGrossProfit(ProfitLossStatementItemResult grossProfit)
void | setIncomeFromOperating(java.util.List incomeFromOperating)
void | setNetProfit(ProfitLossStatementItemResult netProfit)
void | setOtherIncome(java.util.List otherIncome)
void | setPriorPeriodFrom(java.util.Date priorPeriodFrom)
void | setPriorPeriodTo(java.util.Date priorPeriodTo)
void | setResearchDevelopment(java.util.List researchDevelopment)
void | setReturnOnSales(java.math.BigDecimal returnOnSales)
void | setSalesMarketing(java.util.List salesMarketing)
void | setSalesRevenue(java.util.List salesRevenue)
void | setTax(java.util.List tax)
void | setTotalCostOfSales(ProfitLossStatementItemResult totalCostOfSales)
void | setTotalGeneralAdmin(ProfitLossStatementItemResult totalGeneralAdmin)
void | setTotalIncomeFromOperating(ProfitLossStatementItemResult totalIncomeFromOperating)
void | setTotalOperatingExpense(ProfitLossStatementItemResult totalOperatingExpense)
void | setTotalOtherIncome(ProfitLossStatementItemResult totalOtherIncome)
void | setTotalResearchDevelopment(ProfitLossStatementItemResult totalResearchDevelopment)
void | setTotalSalesMarketing(ProfitLossStatementItemResult totalSalesMarketing)
void | setTotalSalesRevenue(ProfitLossStatementItemResult totalSalesRevenue)
void | setTotalTax(ProfitLossStatementItemResult totalTax)
void | setTotalWageLabor(ProfitLossStatementItemResult totalWageLabor)
void | setWageLabor(java.util.List wageLabor)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

companyUnitId

public java.lang.String companyUnitId
Constructor Detail

ProfitLossStatementResult

public ProfitLossStatementResult()
Method Detail

getCostOfSales

public java.util.List getCostOfSales()

getSalesRevenue

public java.util.List getSalesRevenue()

getGrossMargin

public java.math.BigDecimal getGrossMargin()

getGrossProfit

public ProfitLossStatementItemResult getGrossProfit()

getNetProfit

public ProfitLossStatementItemResult getNetProfit()

getTax

public java.util.List getTax()

getTotalWageLabor

public ProfitLossStatementItemResult getTotalWageLabor()

getWageLabor

public java.util.List getWageLabor()

getTotalCostOfSales

public ProfitLossStatementItemResult getTotalCostOfSales()

getReturnOnSales

public java.math.BigDecimal getReturnOnSales()

getTotalResearchDevelopment

public ProfitLossStatementItemResult getTotalResearchDevelopment()

getSalesMarketing

public java.util.List getSalesMarketing()

getOtherIncome

public java.util.List getOtherIncome()

getTotalIncomeFromOperating

public ProfitLossStatementItemResult getTotalIncomeFromOperating()

getTotalOtherIncome

public ProfitLossStatementItemResult getTotalOtherIncome()

getTotalSalesRevenue

public ProfitLossStatementItemResult getTotalSalesRevenue()

getTotalTax

public ProfitLossStatementItemResult getTotalTax()

getIncomeFromOperating

public java.util.List getIncomeFromOperating()

getResearchDevelopment

public java.util.List getResearchDevelopment()

getTotalOperatingExpense

public ProfitLossStatementItemResult getTotalOperatingExpense()

setTotalSalesMarketing

public void setTotalSalesMarketing(ProfitLossStatementItemResult totalSalesMarketing)

setCostOfSales

public void setCostOfSales(java.util.List costOfSales)

setSalesRevenue

public void setSalesRevenue(java.util.List salesRevenue)

setGrossMargin

public void setGrossMargin(java.math.BigDecimal grossMargin)

setGrossProfit

public void setGrossProfit(ProfitLossStatementItemResult grossProfit)

setNetProfit

public void setNetProfit(ProfitLossStatementItemResult netProfit)

setTax

public void setTax(java.util.List tax)

setTotalWageLabor

public void setTotalWageLabor(ProfitLossStatementItemResult totalWageLabor)

setWageLabor

public void setWageLabor(java.util.List wageLabor)

setTotalCostOfSales

public void setTotalCostOfSales(ProfitLossStatementItemResult totalCostOfSales)

setReturnOnSales

public void setReturnOnSales(java.math.BigDecimal returnOnSales)

setTotalResearchDevelopment

public void setTotalResearchDevelopment(ProfitLossStatementItemResult totalResearchDevelopment)

setSalesMarketing

public void setSalesMarketing(java.util.List salesMarketing)

setOtherIncome

public void setOtherIncome(java.util.List otherIncome)

setTotalIncomeFromOperating

public void setTotalIncomeFromOperating(ProfitLossStatementItemResult totalIncomeFromOperating)

setTotalOtherIncome

public void setTotalOtherIncome(ProfitLossStatementItemResult totalOtherIncome)

setTotalSalesRevenue

public void setTotalSalesRevenue(ProfitLossStatementItemResult totalSalesRevenue)

setTotalTax

public void setTotalTax(ProfitLossStatementItemResult totalTax)

setIncomeFromOperating

public void setIncomeFromOperating(java.util.List incomeFromOperating)

setResearchDevelopment

public void setResearchDevelopment(java.util.List researchDevelopment)

setTotalOperatingExpense

public void setTotalOperatingExpense(ProfitLossStatementItemResult totalOperatingExpense)

setCurrentPeriodTo

public void setCurrentPeriodTo(java.util.Date currentPeriodTo)

setPriorPeriodTo

public void setPriorPeriodTo(java.util.Date priorPeriodTo)

setCurrentPeriodFrom

public void setCurrentPeriodFrom(java.util.Date currentPeriodFrom)

setPriorPeriodFrom

public void setPriorPeriodFrom(java.util.Date priorPeriodFrom)

setTotalGeneralAdmin

public void setTotalGeneralAdmin(ProfitLossStatementItemResult totalGeneralAdmin)

setGeneralAdmin

public void setGeneralAdmin(java.util.List generalAdmin)

getTotalSalesMarketing

public ProfitLossStatementItemResult getTotalSalesMarketing()

getCurrentPeriodTo

public java.util.Date getCurrentPeriodTo()

getPriorPeriodTo

public java.util.Date getPriorPeriodTo()

getCurrentPeriodFrom

public java.util.Date getCurrentPeriodFrom()

getPriorPeriodFrom

public java.util.Date getPriorPeriodFrom()

getTotalGeneralAdmin

public ProfitLossStatementItemResult getTotalGeneralAdmin()

getGeneralAdmin

public java.util.List getGeneralAdmin()

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProformaInvoiceItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ProformaInvoiceItemListResult

java.lang.Object
    extended by  bb.common.ProformaInvoiceItemListResult
All Implemented Interfaces:
java.io.Serializable
public class ProformaInvoiceItemListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PFINVOICENUMBER
static java.lang.String | ORDER_BY_PURCHASEORDERNUMBER
static java.lang.String | ORDER_BY_SALESORDERNUMBER
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
ProformaInvoiceItemListResult()
Method Summary
java.math.BigDecimal | getArSub()
java.lang.String | getCustomerId()
java.util.Date | getDateShipped()
java.lang.String | getDescription()
java.math.BigDecimal | getListPrice()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getPfInvoiceItemNumber()
java.lang.String | getPfInvoiceNumber()
java.lang.String | getPurchaseOrderNumber()
java.math.BigDecimal | getQtyShipped()
java.math.BigDecimal | getQuantity()
java.lang.String | getSalesOrderItem()
java.lang.String | getSalesOrderNumber()
java.lang.String | getStatus()
java.lang.String | getUnit()
void | setArSub(java.math.BigDecimal arSub)
void | setCustomerId(java.lang.String customerId)
void | setDateShipped(java.util.Date dateShipped)
void | setDescription(java.lang.String description)
void | setListPrice(java.math.BigDecimal listPrice)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPfInvoiceItemNumber(java.lang.String pfInvoiceItemNumber)
void | setPfInvoiceNumber(java.lang.String pfInvoiceNumber)
void | setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)
void | setQtyShipped(java.math.BigDecimal qtyShipped)
void | setQuantity(java.math.BigDecimal quantity)
void | setSalesOrderItem(java.lang.String salesOrderItem)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setStatus(java.lang.String status)
void | setUnit(java.lang.String unit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PFINVOICENUMBER

public static final java.lang.String ORDER_BY_PFINVOICENUMBER
See Also:
Constant Field Values

ORDER_BY_SALESORDERNUMBER

public static final java.lang.String ORDER_BY_SALESORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_PURCHASEORDERNUMBER

public static final java.lang.String ORDER_BY_PURCHASEORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values
Constructor Detail

ProformaInvoiceItemListResult

public ProformaInvoiceItemListResult()
Method Detail

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPfInvoiceItemNumber

public java.lang.String getPfInvoiceItemNumber()

setPfInvoiceItemNumber

public void setPfInvoiceItemNumber(java.lang.String pfInvoiceItemNumber)

getPurchaseOrderNumber

public java.lang.String getPurchaseOrderNumber()

setPurchaseOrderNumber

public void setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)

getQtyShipped

public java.math.BigDecimal getQtyShipped()

setQtyShipped

public void setQtyShipped(java.math.BigDecimal qtyShipped)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getPfInvoiceNumber

public java.lang.String getPfInvoiceNumber()

setPfInvoiceNumber

public void setPfInvoiceNumber(java.lang.String pfInvoiceNumber)

getSalesOrderItem

public java.lang.String getSalesOrderItem()

setSalesOrderItem

public void setSalesOrderItem(java.lang.String salesOrderItem)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getArSub

public java.math.BigDecimal getArSub()

setArSub

public void setArSub(java.math.BigDecimal arSub)

getDateShipped

public java.util.Date getDateShipped()

setDateShipped

public void setDateShipped(java.util.Date dateShipped)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProformaInvoiceItemManufacturerPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ProformaInvoiceItemManufacturerPK

java.lang.Object
    extended by  bb.common.ProformaInvoiceItemManufacturerPK
All Implemented Interfaces:
java.io.Serializable
public class ProformaInvoiceItemManufacturerPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ProformaInvoiceItemManufacturerPK()
ProformaInvoiceItemManufacturerPK(java.lang.String salesOrderNumber, java.lang.String salesOrderItemNumber, java.lang.Short ii)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Short | getIi()
java.lang.String | getPfInvoiceNumber()
java.lang.String | getSalesOrderItemNumber()
java.lang.String | getSalesOrderNumber()
int | hashCode()
void | setIi(java.lang.Short ii)
void | setPfInvoiceNumber(java.lang.String pfInvoiceNumber)
void | setSalesOrderItemNumber(java.lang.String salesOrderItemNumber)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ProformaInvoiceItemManufacturerPK

public ProformaInvoiceItemManufacturerPK()

ProformaInvoiceItemManufacturerPK

public ProformaInvoiceItemManufacturerPK(java.lang.String salesOrderNumber,
                                         java.lang.String salesOrderItemNumber,
                                         java.lang.Short ii)
Method Detail

getPfInvoiceNumber

public java.lang.String getPfInvoiceNumber()

setPfInvoiceNumber

public void setPfInvoiceNumber(java.lang.String pfInvoiceNumber)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getSalesOrderItemNumber

public java.lang.String getSalesOrderItemNumber()

setSalesOrderItemNumber

public void setSalesOrderItemNumber(java.lang.String salesOrderItemNumber)

getIi

public java.lang.Short getIi()

setIi

public void setIi(java.lang.Short ii)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProformaInvoiceItemManufacturerVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ProformaInvoiceItemManufacturerVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ProformaInvoiceItemManufacturerVO
All Implemented Interfaces:
java.io.Serializable
public class ProformaInvoiceItemManufacturerVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ProformaInvoiceItemManufacturerVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getManufacturerName()
java.lang.String | getManufacturerPartNumber()
ProformaInvoiceItemManufacturerPK | getPk()
int | hashCode()
void | setManufacturerName(java.lang.String manufacturerName)
void | setManufacturerPartNumber(java.lang.String manufacturerPartNumber)
void | setPk(ProformaInvoiceItemManufacturerPK pk)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ProformaInvoiceItemManufacturerVO

public ProformaInvoiceItemManufacturerVO()
Method Detail

getPk

public ProformaInvoiceItemManufacturerPK getPk()

setPk

public void setPk(ProformaInvoiceItemManufacturerPK pk)

getManufacturerName

public java.lang.String getManufacturerName()

setManufacturerName

public void setManufacturerName(java.lang.String manufacturerName)

getManufacturerPartNumber

public java.lang.String getManufacturerPartNumber()

setManufacturerPartNumber

public void setManufacturerPartNumber(java.lang.String manufacturerPartNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProformaInvoiceItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ProformaInvoiceItemPK

java.lang.Object
    extended by  bb.common.ProformaInvoiceItemPK
All Implemented Interfaces:
java.io.Serializable
public class ProformaInvoiceItemPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
ProformaInvoiceItemPK()
default constructor
ProformaInvoiceItemPK(java.lang.String pfInvoiceNumber, java.lang.String salesOrderNumber, java.lang.String salesOrderItem)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getPfInvoiceNumber()
java.lang.String | getSalesOrderItem()
java.lang.String | getSalesOrderNumber()
int | hashCode()
void | setPfInvoiceNumber(java.lang.String pfInvoiceNumber)
void | setSalesOrderItem(java.lang.String salesOrderItem)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ProformaInvoiceItemPK

public ProformaInvoiceItemPK(java.lang.String pfInvoiceNumber,
                             java.lang.String salesOrderNumber,
                             java.lang.String salesOrderItem)
full constructor

ProformaInvoiceItemPK

public ProformaInvoiceItemPK()
default constructor

Method Detail

getPfInvoiceNumber

public java.lang.String getPfInvoiceNumber()

setPfInvoiceNumber

public void setPfInvoiceNumber(java.lang.String pfInvoiceNumber)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getSalesOrderItem

public java.lang.String getSalesOrderItem()

setSalesOrderItem

public void setSalesOrderItem(java.lang.String salesOrderItem)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProformaInvoiceItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ProformaInvoiceItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ProformaInvoiceItemVO
All Implemented Interfaces:
java.io.Serializable
public class ProformaInvoiceItemVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
ProformaInvoiceItemVO()
default constructor
ProformaInvoiceItemVO(ProformaInvoiceItemPK pk, java.lang.String pfInvoiceItemNumber, java.lang.String customerId, java.lang.String purchaseOrderNumber, java.lang.String shipperNumber, java.lang.String ar, java.math.BigDecimal arSub, java.math.BigDecimal arShip, java.math.BigDecimal arOpen, java.math.BigDecimal arDisc, java.math.BigDecimal arNet, java.math.BigDecimal arTax, java.math.BigDecimal arTotal, java.lang.String refDoc1, java.lang.String refDoc2, java.util.Date dateShipped, java.util.Date dateInvoiced, java.lang.String shipVia, java.lang.String shipTo, java.lang.String status, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String modelNumber, java.lang.String revision, java.lang.String locate, java.math.BigDecimal quantity, java.math.BigDecimal qtyShipped, java.math.BigDecimal listPrice, java.math.BigDecimal avgCost, java.lang.String unit, java.math.BigDecimal discount, java.math.BigDecimal taxRate, java.lang.String description, java.lang.String mfg, java.lang.String mpn, java.lang.String serial)
minimal constructor
ProformaInvoiceItemVO(ProformaInvoiceItemPK pk, java.lang.String pfInvoiceItemNumber, java.lang.String customerId, java.lang.String purchaseOrderNumber, java.lang.String shipperNumber, java.lang.String ar, java.math.BigDecimal arSub, java.math.BigDecimal arShip, java.math.BigDecimal arOpen, java.math.BigDecimal arDisc, java.math.BigDecimal arNet, java.math.BigDecimal arTax, java.math.BigDecimal arTotal, java.lang.String refDoc1, java.lang.String refDoc2, java.util.Date dateShipped, java.util.Date dateInvoiced, java.lang.String shipVia, java.lang.String shipTo, java.lang.String status, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String modelNumber, java.lang.String revision, java.lang.String locate, java.math.BigDecimal quantity, java.math.BigDecimal qtyShipped, java.math.BigDecimal listPrice, java.math.BigDecimal avgCost, java.lang.String unit, java.math.BigDecimal discount, java.math.BigDecimal taxRate, java.lang.String description, java.lang.String mfg, java.lang.String mpn, java.lang.String serial, java.lang.String itemComments, java.lang.String itemPrivateNotes)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAr()
java.math.BigDecimal | getArDisc()
java.math.BigDecimal | getArNet()
java.math.BigDecimal | getArOpen()
java.math.BigDecimal | getArShip()
java.math.BigDecimal | getArSub()
java.math.BigDecimal | getArTax()
java.math.BigDecimal | getArTotal()
java.math.BigDecimal | getAvgCost()
java.lang.String | getCustomerId()
java.util.Date | getDateInvoiced()
java.util.Date | getDateShipped()
java.lang.String | getDescription()
java.math.BigDecimal | getDiscount()
java.lang.String | getItemComments()
java.lang.String | getItemPrivateNotes()
java.math.BigDecimal | getListPrice()
java.lang.String | getLocate()
java.lang.String | getMfg()
java.lang.String | getModelNumber()
java.lang.String | getMpn()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getPfInvoiceItemNumber()
ProformaInvoiceItemPK | getPk()
java.util.Set | getProformaInvoiceItemManufacturer()
java.lang.String | getPurchaseOrderNumber()
java.math.BigDecimal | getQtyShipped()
java.math.BigDecimal | getQuantity()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.lang.String | getRevision()
java.lang.String | getSerial()
java.lang.String | getShipperNumber()
java.lang.String | getShipTo()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.math.BigDecimal | getTaxRate()
java.lang.String | getUnit()
int | hashCode()
void | setAr(java.lang.String ar)
void | setArDisc(java.math.BigDecimal arDisc)
void | setArNet(java.math.BigDecimal arNet)
void | setArOpen(java.math.BigDecimal arOpen)
void | setArShip(java.math.BigDecimal arShip)
void | setArSub(java.math.BigDecimal arSub)
void | setArTax(java.math.BigDecimal arTax)
void | setArTotal(java.math.BigDecimal arTotal)
void | setAvgCost(java.math.BigDecimal avgCost)
void | setCustomerId(java.lang.String customerId)
void | setDateInvoiced(java.util.Date dateInvoiced)
void | setDateShipped(java.util.Date dateShipped)
void | setDescription(java.lang.String description)
void | setDiscount(java.math.BigDecimal discount)
void | setItemComments(java.lang.String itemComments)
void | setItemPrivateNotes(java.lang.String itemPrivateNotes)
void | setListPrice(java.math.BigDecimal listPrice)
void | setLocate(java.lang.String locate)
void | setMfg(java.lang.String mfg)
void | setModelNumber(java.lang.String modelNumber)
void | setMpn(java.lang.String mpn)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPfInvoiceItemNumber(java.lang.String pfInvoiceItemNumber)
void | setPk(ProformaInvoiceItemPK pk)
void | setProformaInvoiceItemManufacturer(java.util.Set proformaInvoiceItemManufacturer)
void | setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)
void | setQtyShipped(java.math.BigDecimal qtyShipped)
void | setQuantity(java.math.BigDecimal quantity)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setRevision(java.lang.String revision)
void | setSerial(java.lang.String serial)
void | setShipperNumber(java.lang.String shipperNumber)
void | setShipTo(java.lang.String shipTo)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setUnit(java.lang.String unit)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ProformaInvoiceItemVO

public ProformaInvoiceItemVO(ProformaInvoiceItemPK pk,
                             java.lang.String pfInvoiceItemNumber,
                             java.lang.String customerId,
                             java.lang.String purchaseOrderNumber,
                             java.lang.String shipperNumber,
                             java.lang.String ar,
                             java.math.BigDecimal arSub,
                             java.math.BigDecimal arShip,
                             java.math.BigDecimal arOpen,
                             java.math.BigDecimal arDisc,
                             java.math.BigDecimal arNet,
                             java.math.BigDecimal arTax,
                             java.math.BigDecimal arTotal,
                             java.lang.String refDoc1,
                             java.lang.String refDoc2,
                             java.util.Date dateShipped,
                             java.util.Date dateInvoiced,
                             java.lang.String shipVia,
                             java.lang.String shipTo,
                             java.lang.String status,
                             java.lang.String partNumber,
                             java.lang.String partType,
                             java.lang.String partFrom,
                             java.lang.String modelNumber,
                             java.lang.String revision,
                             java.lang.String locate,
                             java.math.BigDecimal quantity,
                             java.math.BigDecimal qtyShipped,
                             java.math.BigDecimal listPrice,
                             java.math.BigDecimal avgCost,
                             java.lang.String unit,
                             java.math.BigDecimal discount,
                             java.math.BigDecimal taxRate,
                             java.lang.String description,
                             java.lang.String mfg,
                             java.lang.String mpn,
                             java.lang.String serial,
                             java.lang.String itemComments,
                             java.lang.String itemPrivateNotes)
full constructor

ProformaInvoiceItemVO

public ProformaInvoiceItemVO()
default constructor

ProformaInvoiceItemVO

public ProformaInvoiceItemVO(ProformaInvoiceItemPK pk,
                             java.lang.String pfInvoiceItemNumber,
                             java.lang.String customerId,
                             java.lang.String purchaseOrderNumber,
                             java.lang.String shipperNumber,
                             java.lang.String ar,
                             java.math.BigDecimal arSub,
                             java.math.BigDecimal arShip,
                             java.math.BigDecimal arOpen,
                             java.math.BigDecimal arDisc,
                             java.math.BigDecimal arNet,
                             java.math.BigDecimal arTax,
                             java.math.BigDecimal arTotal,
                             java.lang.String refDoc1,
                             java.lang.String refDoc2,
                             java.util.Date dateShipped,
                             java.util.Date dateInvoiced,
                             java.lang.String shipVia,
                             java.lang.String shipTo,
                             java.lang.String status,
                             java.lang.String partNumber,
                             java.lang.String partType,
                             java.lang.String partFrom,
                             java.lang.String modelNumber,
                             java.lang.String revision,
                             java.lang.String locate,
                             java.math.BigDecimal quantity,
                             java.math.BigDecimal qtyShipped,
                             java.math.BigDecimal listPrice,
                             java.math.BigDecimal avgCost,
                             java.lang.String unit,
                             java.math.BigDecimal discount,
                             java.math.BigDecimal taxRate,
                             java.lang.String description,
                             java.lang.String mfg,
                             java.lang.String mpn,
                             java.lang.String serial)
minimal constructor

Method Detail

getPk

public ProformaInvoiceItemPK getPk()

setPk

public void setPk(ProformaInvoiceItemPK pk)

getPfInvoiceItemNumber

public java.lang.String getPfInvoiceItemNumber()

setPfInvoiceItemNumber

public void setPfInvoiceItemNumber(java.lang.String pfInvoiceItemNumber)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getPurchaseOrderNumber

public java.lang.String getPurchaseOrderNumber()

setPurchaseOrderNumber

public void setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)

getShipperNumber

public java.lang.String getShipperNumber()

setShipperNumber

public void setShipperNumber(java.lang.String shipperNumber)

getAr

public java.lang.String getAr()

setAr

public void setAr(java.lang.String ar)

getArSub

public java.math.BigDecimal getArSub()

setArSub

public void setArSub(java.math.BigDecimal arSub)

getArShip

public java.math.BigDecimal getArShip()

setArShip

public void setArShip(java.math.BigDecimal arShip)

getArOpen

public java.math.BigDecimal getArOpen()

setArOpen

public void setArOpen(java.math.BigDecimal arOpen)

getArDisc

public java.math.BigDecimal getArDisc()

setArDisc

public void setArDisc(java.math.BigDecimal arDisc)

getArNet

public java.math.BigDecimal getArNet()

setArNet

public void setArNet(java.math.BigDecimal arNet)

getArTax

public java.math.BigDecimal getArTax()

setArTax

public void setArTax(java.math.BigDecimal arTax)

getArTotal

public java.math.BigDecimal getArTotal()

setArTotal

public void setArTotal(java.math.BigDecimal arTotal)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getDateShipped

public java.util.Date getDateShipped()

setDateShipped

public void setDateShipped(java.util.Date dateShipped)

getDateInvoiced

public java.util.Date getDateInvoiced()

setDateInvoiced

public void setDateInvoiced(java.util.Date dateInvoiced)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getShipTo

public java.lang.String getShipTo()

setShipTo

public void setShipTo(java.lang.String shipTo)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getQtyShipped

public java.math.BigDecimal getQtyShipped()

setQtyShipped

public void setQtyShipped(java.math.BigDecimal qtyShipped)

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

getAvgCost

public java.math.BigDecimal getAvgCost()

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getSerial

public java.lang.String getSerial()

setSerial

public void setSerial(java.lang.String serial)

getItemComments

public java.lang.String getItemComments()

setItemComments

public void setItemComments(java.lang.String itemComments)

getItemPrivateNotes

public java.lang.String getItemPrivateNotes()

setItemPrivateNotes

public void setItemPrivateNotes(java.lang.String itemPrivateNotes)

getProformaInvoiceItemManufacturer

public java.util.Set getProformaInvoiceItemManufacturer()

setProformaInvoiceItemManufacturer

public void setProformaInvoiceItemManufacturer(java.util.Set proformaInvoiceItemManufacturer)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProformaInvoiceListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ProformaInvoiceListResult

java.lang.Object
    extended by  bb.common.ProformaInvoiceListResult
All Implemented Interfaces:
java.io.Serializable
public class ProformaInvoiceListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_BILLTOID
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_CUSTOMERPO
static java.lang.String | ORDER_BY_DATESHIPPED
static java.lang.String | ORDER_BY_GRANTTOTAL
static java.lang.String | ORDER_BY_PFNUMBER
static java.lang.String | ORDER_BY_SHIPTOID
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
ProformaInvoiceListResult()
Method Summary
java.lang.String | getBillToId()
java.lang.String | getComments()
java.lang.String | getCustomerId()
java.lang.String | getCustomerPo()
java.util.Date | getDateShipped()
java.math.BigDecimal | getGrantTotal()
java.lang.String | getPfnumber()
java.lang.String | getPrivateNotes()
java.lang.String | getShipToId()
java.lang.String | getStatus()
void | setBillToId(java.lang.String billToId)
void | setComments(java.lang.String comments)
void | setCustomerId(java.lang.String customerId)
void | setCustomerPo(java.lang.String customerPo)
void | setDateShipped(java.util.Date dateShipped)
void | setGrantTotal(java.math.BigDecimal grantTotal)
void | setPfnumber(java.lang.String pfnumber)
void | setPrivateNotes(java.lang.String privateNotes)
void | setShipToId(java.lang.String shipToId)
void | setStatus(java.lang.String status)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PFNUMBER

public static final java.lang.String ORDER_BY_PFNUMBER
See Also:
Constant Field Values

ORDER_BY_DATESHIPPED

public static final java.lang.String ORDER_BY_DATESHIPPED
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_BILLTOID

public static final java.lang.String ORDER_BY_BILLTOID
See Also:
Constant Field Values

ORDER_BY_SHIPTOID

public static final java.lang.String ORDER_BY_SHIPTOID
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_CUSTOMERPO

public static final java.lang.String ORDER_BY_CUSTOMERPO
See Also:
Constant Field Values

ORDER_BY_GRANTTOTAL

public static final java.lang.String ORDER_BY_GRANTTOTAL
See Also:
Constant Field Values
Constructor Detail

ProformaInvoiceListResult

public ProformaInvoiceListResult()
Method Detail

setPfnumber

public void setPfnumber(java.lang.String pfnumber)

setDateShipped

public void setDateShipped(java.util.Date dateShipped)

setCustomerId

public void setCustomerId(java.lang.String customerId)

setBillToId

public void setBillToId(java.lang.String billToId)

setShipToId

public void setShipToId(java.lang.String shipToId)

setStatus

public void setStatus(java.lang.String status)

setComments

public void setComments(java.lang.String comments)

setPrivateNotes

public void setPrivateNotes(java.lang.String privateNotes)

setCustomerPo

public void setCustomerPo(java.lang.String customerPo)

getPfnumber

public java.lang.String getPfnumber()

getDateShipped

public java.util.Date getDateShipped()

getCustomerId

public java.lang.String getCustomerId()

getBillToId

public java.lang.String getBillToId()

getShipToId

public java.lang.String getShipToId()

getStatus

public java.lang.String getStatus()

getComments

public java.lang.String getComments()

getPrivateNotes

public java.lang.String getPrivateNotes()

getCustomerPo

public java.lang.String getCustomerPo()

getGrantTotal

public java.math.BigDecimal getGrantTotal()

setGrantTotal

public void setGrantTotal(java.math.BigDecimal grantTotal)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProformaInvoiceVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ProformaInvoiceVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ProformaInvoiceVO
All Implemented Interfaces:
java.io.Serializable
public class ProformaInvoiceVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
ProformaInvoiceVO()
default constructor
ProformaInvoiceVO(java.lang.String pfInvoiceNumber, int packingBoxNumbers, java.lang.String customerId, java.lang.String customerPO, java.lang.String billTo, java.lang.String customerEmail, java.lang.String contact, java.lang.String lastChangeUser, java.util.Date lastChangeDate, java.util.Date adate, java.lang.String origin, java.math.BigDecimal arSub, java.math.BigDecimal arShip, java.math.BigDecimal arOpen, java.math.BigDecimal arDisc, java.math.BigDecimal arNet, java.math.BigDecimal arTax, java.math.BigDecimal arFreight, java.math.BigDecimal arTotal, java.math.BigDecimal arPaid, java.math.BigDecimal arPaidInv, java.math.BigDecimal arPaidGl, java.math.BigDecimal arGl1Recorded, java.math.BigDecimal arGl2Paid, java.lang.String changeOrder, java.lang.String status, java.lang.String salesman, java.util.Date shipped, java.lang.String shippedBy, java.util.Date invoicedDate, java.lang.String invoicedBy, java.lang.String shipTo, java.lang.String remitId, java.lang.String shipVia, java.util.Date estimatedArrival, java.lang.String carrier, java.lang.String carrierAccount, java.lang.String tracking, java.lang.String billOfLading, java.lang.String containerNumber, java.lang.String containerSealNumber, java.lang.String shippingMark, java.lang.String incoterm, java.lang.String incotermPlacePort, java.util.Date dateShipped, java.util.Date dateInvoiced, java.lang.String freightBill, java.lang.String currency, java.lang.String language, java.lang.String terms, java.lang.String reldoc, java.lang.String cacct1, java.lang.String bp, java.lang.String comments, java.lang.String notes, java.math.BigDecimal due, java.util.Date paydate, java.util.Date datePaid, java.lang.String checkNo, java.math.BigDecimal paid, java.lang.String otran, java.lang.String rtran, int lastChangeTimes, CustomerVendorAddressInfoVO customerAddressInfo, CustomerVendorAddressInfoVO shipToAddressInfo, CustomerVendorAddressInfoVO billToAddressInfo, java.util.Set proformaInvoiceItems, java.util.Set packingBoxes)
full constructor
ProformaInvoiceVO(java.lang.String pfInvoiceNumber, int packingBoxNumbers, java.lang.String customerId, java.lang.String customerPO, java.lang.String billTo, java.lang.String customerEmail, java.lang.String contact, java.lang.String lastChangeUser, java.lang.String origin, java.math.BigDecimal arSub, java.math.BigDecimal arShip, java.math.BigDecimal arOpen, java.math.BigDecimal arDisc, java.math.BigDecimal arNet, java.math.BigDecimal arTax, java.math.BigDecimal arFreight, java.math.BigDecimal arTotal, java.math.BigDecimal arPaid, java.math.BigDecimal arPaidInv, java.math.BigDecimal arPaidGl, java.math.BigDecimal arGl1Recorded, java.math.BigDecimal arGl2Paid, java.lang.String changeOrder, java.lang.String status, java.lang.String salesman, java.lang.String shippedBy, java.lang.String invoicedBy, java.lang.String shipTo, java.lang.String remitId, java.lang.String shipVia, java.util.Date estimatedArrival, java.lang.String carrier, java.lang.String carrierAccount, java.lang.String tracking, java.lang.String billOfLading, java.lang.String containerNumber, java.lang.String containerSealNumber, java.lang.String shippingMark, java.lang.String incoterm, java.lang.String incotermPlacePort, java.util.Date dateShipped, java.util.Date dateInvoiced, java.lang.String freightBill, java.lang.String currency, java.lang.String language, java.lang.String terms, java.lang.String reldoc, java.lang.String cacct1, java.lang.String bp, java.math.BigDecimal due, java.util.Date paydate, java.util.Date datePaid, java.lang.String checkNo, java.math.BigDecimal paid, java.lang.String otran, java.lang.String rtran, java.util.Set proformaInvoiceItems, java.util.Set packingBoxes)
minimal constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.math.BigDecimal | getArDisc()
java.math.BigDecimal | getArFreight()
java.math.BigDecimal | getArGl1Recorded()
java.math.BigDecimal | getArGl2Paid()
java.math.BigDecimal | getArNet()
java.math.BigDecimal | getArOpen()
java.math.BigDecimal | getArPaid()
java.math.BigDecimal | getArPaidGl()
java.math.BigDecimal | getArPaidInv()
java.math.BigDecimal | getArShip()
java.math.BigDecimal | getArSub()
java.math.BigDecimal | getArTax()
java.math.BigDecimal | getArTotal()
java.lang.String | getBillOfLading()
java.lang.String | getBillTo()
CustomerVendorAddressInfoVO | getBillToAddressInfo()
java.lang.String | getBp()
java.lang.String | getCacct1()
java.lang.String | getCarrier()
java.lang.String | getCarrierAccount()
java.lang.String | getChangeOrder()
java.lang.String | getCheckNo()
java.lang.String | getComments()
java.lang.String | getContact()
java.lang.String | getContainerNumber()
java.lang.String | getContainerSealNumber()
java.lang.String | getCurrency()
CustomerVendorAddressInfoVO | getCustomerAddressInfo()
java.lang.String | getCustomerEmail()
java.lang.String | getCustomerId()
java.lang.String | getCustomerPO()
java.util.Date | getDateInvoiced()
java.util.Date | getDatePaid()
java.util.Date | getDateShipped()
java.math.BigDecimal | getDue()
java.util.Date | getEstimatedArrival()
java.lang.String | getFreightBill()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getInvoicedBy()
java.util.Date | getInvoicedDate()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
int | getLastChangeTimes()
java.lang.String | getLastChangeUser()
java.lang.String | getNotes()
java.lang.String | getOrigin()
java.lang.String | getOtran()
java.util.Set | getPackingBoxes()
int | getPackingBoxNumbers()
java.math.BigDecimal | getPaid()
java.util.Date | getPaydate()
java.lang.String | getPfInvoiceNumber()
java.util.Set | getProformaInvoiceItems()
java.lang.String | getReldoc()
java.lang.String | getRemitId()
java.lang.String | getRtran()
java.lang.String | getSalesman()
CustomerVendorAddressInfoVO | getShipFromAddressInfo()
java.lang.String | getShipFromId()
java.util.Date | getShipped()
java.lang.String | getShippedBy()
java.lang.String | getShippingMark()
java.lang.String | getShipTo()
CustomerVendorAddressInfoVO | getShipToAddressInfo()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.lang.String | getTerms()
java.lang.String | getTracking()
int | hashCode()
void | setAdate(java.util.Date adate)
void | setArDisc(java.math.BigDecimal arDisc)
void | setArFreight(java.math.BigDecimal arFreight)
void | setArGl1Recorded(java.math.BigDecimal arGl1Recorded)
void | setArGl2Paid(java.math.BigDecimal arGl2Paid)
void | setArNet(java.math.BigDecimal arNet)
void | setArOpen(java.math.BigDecimal arOpen)
void | setArPaid(java.math.BigDecimal arPaid)
void | setArPaidGl(java.math.BigDecimal arPaidGl)
void | setArPaidInv(java.math.BigDecimal arPaidInv)
void | setArShip(java.math.BigDecimal arShip)
void | setArSub(java.math.BigDecimal arSub)
void | setArTax(java.math.BigDecimal arTax)
void | setArTotal(java.math.BigDecimal arTotal)
void | setBillOfLading(java.lang.String billOfLading)
void | setBillTo(java.lang.String billTo)
void | setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | setBp(java.lang.String bp)
void | setCacct1(java.lang.String cacct1)
void | setCarrier(java.lang.String carrier)
void | setCarrierAccount(java.lang.String carrierAccount)
void | setChangeOrder(java.lang.String changeOrder)
void | setCheckNo(java.lang.String checkNo)
void | setComments(java.lang.String comments)
void | setContact(java.lang.String contact)
void | setContainerNumber(java.lang.String containerNumber)
void | setContainerSealNumber(java.lang.String containerSealNumber)
void | setCurrency(java.lang.String currency)
void | setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | setCustomerEmail(java.lang.String customerEmail)
void | setCustomerId(java.lang.String customerId)
void | setCustomerPO(java.lang.String customerPO)
void | setDateInvoiced(java.util.Date dateInvoiced)
void | setDatePaid(java.util.Date datePaid)
void | setDateShipped(java.util.Date dateShipped)
void | setDue(java.math.BigDecimal due)
void | setEstimatedArrival(java.util.Date estimatedArrival)
void | setFreightBill(java.lang.String freightBill)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setInvoicedBy(java.lang.String invoicedBy)
void | setInvoicedDate(java.util.Date invoicedDate)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTimes(int lastChangeTimes)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setNotes(java.lang.String notes)
void | setOrigin(java.lang.String origin)
void | setOtran(java.lang.String otran)
void | setPackingBoxes(java.util.Set packingBoxes)
void | setPackingBoxNumbers(int packingBoxNumbers)
void | setPaid(java.math.BigDecimal paid)
void | setPaydate(java.util.Date paydate)
void | setPfInvoiceNumber(java.lang.String pfInvoiceNumber)
void | setProformaInvoiceItems(java.util.Set proformaInvoiceItems)
void | setReldoc(java.lang.String reldoc)
void | setRemitId(java.lang.String remitId)
void | setRtran(java.lang.String rtran)
void | setSalesman(java.lang.String salesman)
void | setShipFromAddressInfo(CustomerVendorAddressInfoVO shipFromAddressInfo)
void | setShipFromId(java.lang.String shipFromId)
void | setShipped(java.util.Date shipped)
void | setShippedBy(java.lang.String shippedBy)
void | setShippingMark(java.lang.String shippingMark)
void | setShipTo(java.lang.String shipTo)
void | setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setTerms(java.lang.String terms)
void | setTracking(java.lang.String tracking)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ProformaInvoiceVO

public ProformaInvoiceVO(java.lang.String pfInvoiceNumber,
                         int packingBoxNumbers,
                         java.lang.String customerId,
                         java.lang.String customerPO,
                         java.lang.String billTo,
                         java.lang.String customerEmail,
                         java.lang.String contact,
                         java.lang.String lastChangeUser,
                         java.util.Date lastChangeDate,
                         java.util.Date adate,
                         java.lang.String origin,
                         java.math.BigDecimal arSub,
                         java.math.BigDecimal arShip,
                         java.math.BigDecimal arOpen,
                         java.math.BigDecimal arDisc,
                         java.math.BigDecimal arNet,
                         java.math.BigDecimal arTax,
                         java.math.BigDecimal arFreight,
                         java.math.BigDecimal arTotal,
                         java.math.BigDecimal arPaid,
                         java.math.BigDecimal arPaidInv,
                         java.math.BigDecimal arPaidGl,
                         java.math.BigDecimal arGl1Recorded,
                         java.math.BigDecimal arGl2Paid,
                         java.lang.String changeOrder,
                         java.lang.String status,
                         java.lang.String salesman,
                         java.util.Date shipped,
                         java.lang.String shippedBy,
                         java.util.Date invoicedDate,
                         java.lang.String invoicedBy,
                         java.lang.String shipTo,
                         java.lang.String remitId,
                         java.lang.String shipVia,
                         java.util.Date estimatedArrival,
                         java.lang.String carrier,
                         java.lang.String carrierAccount,
                         java.lang.String tracking,
                         java.lang.String billOfLading,
                         java.lang.String containerNumber,
                         java.lang.String containerSealNumber,
                         java.lang.String shippingMark,
                         java.lang.String incoterm,
                         java.lang.String incotermPlacePort,
                         java.util.Date dateShipped,
                         java.util.Date dateInvoiced,
                         java.lang.String freightBill,
                         java.lang.String currency,
                         java.lang.String language,
                         java.lang.String terms,
                         java.lang.String reldoc,
                         java.lang.String cacct1,
                         java.lang.String bp,
                         java.lang.String comments,
                         java.lang.String notes,
                         java.math.BigDecimal due,
                         java.util.Date paydate,
                         java.util.Date datePaid,
                         java.lang.String checkNo,
                         java.math.BigDecimal paid,
                         java.lang.String otran,
                         java.lang.String rtran,
                         int lastChangeTimes,
                         CustomerVendorAddressInfoVO customerAddressInfo,
                         CustomerVendorAddressInfoVO shipToAddressInfo,
                         CustomerVendorAddressInfoVO billToAddressInfo,
                         java.util.Set proformaInvoiceItems,
                         java.util.Set packingBoxes)
full constructor

ProformaInvoiceVO

public ProformaInvoiceVO()
default constructor

ProformaInvoiceVO

public ProformaInvoiceVO(java.lang.String pfInvoiceNumber,
                         int packingBoxNumbers,
                         java.lang.String customerId,
                         java.lang.String customerPO,
                         java.lang.String billTo,
                         java.lang.String customerEmail,
                         java.lang.String contact,
                         java.lang.String lastChangeUser,
                         java.lang.String origin,
                         java.math.BigDecimal arSub,
                         java.math.BigDecimal arShip,
                         java.math.BigDecimal arOpen,
                         java.math.BigDecimal arDisc,
                         java.math.BigDecimal arNet,
                         java.math.BigDecimal arTax,
                         java.math.BigDecimal arFreight,
                         java.math.BigDecimal arTotal,
                         java.math.BigDecimal arPaid,
                         java.math.BigDecimal arPaidInv,
                         java.math.BigDecimal arPaidGl,
                         java.math.BigDecimal arGl1Recorded,
                         java.math.BigDecimal arGl2Paid,
                         java.lang.String changeOrder,
                         java.lang.String status,
                         java.lang.String salesman,
                         java.lang.String shippedBy,
                         java.lang.String invoicedBy,
                         java.lang.String shipTo,
                         java.lang.String remitId,
                         java.lang.String shipVia,
                         java.util.Date estimatedArrival,
                         java.lang.String carrier,
                         java.lang.String carrierAccount,
                         java.lang.String tracking,
                         java.lang.String billOfLading,
                         java.lang.String containerNumber,
                         java.lang.String containerSealNumber,
                         java.lang.String shippingMark,
                         java.lang.String incoterm,
                         java.lang.String incotermPlacePort,
                         java.util.Date dateShipped,
                         java.util.Date dateInvoiced,
                         java.lang.String freightBill,
                         java.lang.String currency,
                         java.lang.String language,
                         java.lang.String terms,
                         java.lang.String reldoc,
                         java.lang.String cacct1,
                         java.lang.String bp,
                         java.math.BigDecimal due,
                         java.util.Date paydate,
                         java.util.Date datePaid,
                         java.lang.String checkNo,
                         java.math.BigDecimal paid,
                         java.lang.String otran,
                         java.lang.String rtran,
                         java.util.Set proformaInvoiceItems,
                         java.util.Set packingBoxes)
minimal constructor

Method Detail

getPfInvoiceNumber

public java.lang.String getPfInvoiceNumber()

setPfInvoiceNumber

public void setPfInvoiceNumber(java.lang.String pfInvoiceNumber)

getPackingBoxNumbers

public int getPackingBoxNumbers()

setPackingBoxNumbers

public void setPackingBoxNumbers(int packingBoxNumbers)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getCustomerPO

public java.lang.String getCustomerPO()

setCustomerPO

public void setCustomerPO(java.lang.String customerPO)

getBillTo

public java.lang.String getBillTo()

setBillTo

public void setBillTo(java.lang.String billTo)

getCustomerEmail

public java.lang.String getCustomerEmail()

setCustomerEmail

public void setCustomerEmail(java.lang.String customerEmail)

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getArSub

public java.math.BigDecimal getArSub()

setArSub

public void setArSub(java.math.BigDecimal arSub)

getArShip

public java.math.BigDecimal getArShip()

setArShip

public void setArShip(java.math.BigDecimal arShip)

getArOpen

public java.math.BigDecimal getArOpen()

setArOpen

public void setArOpen(java.math.BigDecimal arOpen)

getArDisc

public java.math.BigDecimal getArDisc()

setArDisc

public void setArDisc(java.math.BigDecimal arDisc)

getArNet

public java.math.BigDecimal getArNet()

setArNet

public void setArNet(java.math.BigDecimal arNet)

getArTax

public java.math.BigDecimal getArTax()

setArTax

public void setArTax(java.math.BigDecimal arTax)

getArFreight

public java.math.BigDecimal getArFreight()

setArFreight

public void setArFreight(java.math.BigDecimal arFreight)

getArTotal

public java.math.BigDecimal getArTotal()

setArTotal

public void setArTotal(java.math.BigDecimal arTotal)

getArPaid

public java.math.BigDecimal getArPaid()

setArPaid

public void setArPaid(java.math.BigDecimal arPaid)

getArPaidInv

public java.math.BigDecimal getArPaidInv()

setArPaidInv

public void setArPaidInv(java.math.BigDecimal arPaidInv)

getArPaidGl

public java.math.BigDecimal getArPaidGl()

setArPaidGl

public void setArPaidGl(java.math.BigDecimal arPaidGl)

getArGl1Recorded

public java.math.BigDecimal getArGl1Recorded()

setArGl1Recorded

public void setArGl1Recorded(java.math.BigDecimal arGl1Recorded)

getArGl2Paid

public java.math.BigDecimal getArGl2Paid()

setArGl2Paid

public void setArGl2Paid(java.math.BigDecimal arGl2Paid)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getSalesman

public java.lang.String getSalesman()

setSalesman

public void setSalesman(java.lang.String salesman)

getShipped

public java.util.Date getShipped()

setShipped

public void setShipped(java.util.Date shipped)

getShippedBy

public java.lang.String getShippedBy()

setShippedBy

public void setShippedBy(java.lang.String shippedBy)

getInvoicedDate

public java.util.Date getInvoicedDate()

setInvoicedDate

public void setInvoicedDate(java.util.Date invoicedDate)

getInvoicedBy

public java.lang.String getInvoicedBy()

setInvoicedBy

public void setInvoicedBy(java.lang.String invoicedBy)

getShipTo

public java.lang.String getShipTo()

setShipTo

public void setShipTo(java.lang.String shipTo)

getRemitId

public java.lang.String getRemitId()

setRemitId

public void setRemitId(java.lang.String remitId)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getEstimatedArrival

public java.util.Date getEstimatedArrival()

setEstimatedArrival

public void setEstimatedArrival(java.util.Date estimatedArrival)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAccount

public java.lang.String getCarrierAccount()

setCarrierAccount

public void setCarrierAccount(java.lang.String carrierAccount)

getTracking

public java.lang.String getTracking()

setTracking

public void setTracking(java.lang.String tracking)

getBillOfLading

public java.lang.String getBillOfLading()

setBillOfLading

public void setBillOfLading(java.lang.String billOfLading)

getContainerNumber

public java.lang.String getContainerNumber()

setContainerNumber

public void setContainerNumber(java.lang.String containerNumber)

getContainerSealNumber

public java.lang.String getContainerSealNumber()

setContainerSealNumber

public void setContainerSealNumber(java.lang.String containerSealNumber)

getShippingMark

public java.lang.String getShippingMark()

setShippingMark

public void setShippingMark(java.lang.String shippingMark)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getDateShipped

public java.util.Date getDateShipped()

setDateShipped

public void setDateShipped(java.util.Date dateShipped)

getDateInvoiced

public java.util.Date getDateInvoiced()

setDateInvoiced

public void setDateInvoiced(java.util.Date dateInvoiced)

getFreightBill

public java.lang.String getFreightBill()

setFreightBill

public void setFreightBill(java.lang.String freightBill)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getReldoc

public java.lang.String getReldoc()

setReldoc

public void setReldoc(java.lang.String reldoc)

getCacct1

public java.lang.String getCacct1()

setCacct1

public void setCacct1(java.lang.String cacct1)

getBp

public java.lang.String getBp()

setBp

public void setBp(java.lang.String bp)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getNotes

public java.lang.String getNotes()

setNotes

public void setNotes(java.lang.String notes)

getDue

public java.math.BigDecimal getDue()

setDue

public void setDue(java.math.BigDecimal due)

getPaydate

public java.util.Date getPaydate()

setPaydate

public void setPaydate(java.util.Date paydate)

getDatePaid

public java.util.Date getDatePaid()

setDatePaid

public void setDatePaid(java.util.Date datePaid)

getCheckNo

public java.lang.String getCheckNo()

setCheckNo

public void setCheckNo(java.lang.String checkNo)

getPaid

public java.math.BigDecimal getPaid()

setPaid

public void setPaid(java.math.BigDecimal paid)

getOtran

public java.lang.String getOtran()

setOtran

public void setOtran(java.lang.String otran)

getRtran

public java.lang.String getRtran()

setRtran

public void setRtran(java.lang.String rtran)

getLastChangeTimes

public int getLastChangeTimes()

setLastChangeTimes

public void setLastChangeTimes(int lastChangeTimes)

getCustomerAddressInfo

public CustomerVendorAddressInfoVO getCustomerAddressInfo()

setCustomerAddressInfo

public void setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)

getShipToAddressInfo

public CustomerVendorAddressInfoVO getShipToAddressInfo()

setShipToAddressInfo

public void setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)

getBillToAddressInfo

public CustomerVendorAddressInfoVO getBillToAddressInfo()

setBillToAddressInfo

public void setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)

getProformaInvoiceItems

public java.util.Set getProformaInvoiceItems()

setProformaInvoiceItems

public void setProformaInvoiceItems(java.util.Set proformaInvoiceItems)

getPackingBoxes

public java.util.Set getPackingBoxes()

setPackingBoxes

public void setPackingBoxes(java.util.Set packingBoxes)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getShipFromAddressInfo

public CustomerVendorAddressInfoVO getShipFromAddressInfo()

setShipFromAddressInfo

public void setShipFromAddressInfo(CustomerVendorAddressInfoVO shipFromAddressInfo)

getShipFromId

public java.lang.String getShipFromId()

setShipFromId

public void setShipFromId(java.lang.String shipFromId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProformaReceiverPackingBoxAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ProformaReceiverPackingBoxAgent

java.lang.Object
    extended by  bb.common.ProformaReceiverPackingBoxAgent
All Implemented Interfaces:
java.io.Serializable
public class ProformaReceiverPackingBoxAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ProformaReceiverPackingBoxAgent()
Method Summary
java.util.LinkedHashMap<PackingBoxPK,java.util.ArrayList<ProformaReceiverPackingBoxItemAgent>> | getPbItems()
java.util.LinkedHashMap<PackingBoxPK,PrPackingBoxVO> | getPbs()
ProformaInvoiceVO | getPfVo()
java.lang.String | getVendorId()
void | setPbItems(java.util.LinkedHashMap<PackingBoxPK,java.util.ArrayList<ProformaReceiverPackingBoxItemAgent>> pbItems)
void | setPbs(java.util.LinkedHashMap<PackingBoxPK,PrPackingBoxVO> pbs)
void | setPfVo(ProformaInvoiceVO pfVo)
void | setVendorId(java.lang.String vendorId)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ProformaReceiverPackingBoxAgent

public ProformaReceiverPackingBoxAgent()
Method Detail

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getPbItems

public java.util.LinkedHashMap<PackingBoxPK,java.util.ArrayList<ProformaReceiverPackingBoxItemAgent>> getPbItems()

setPbItems

public void setPbItems(java.util.LinkedHashMap<PackingBoxPK,java.util.ArrayList<ProformaReceiverPackingBoxItemAgent>> pbItems)

getPfVo

public ProformaInvoiceVO getPfVo()

setPfVo

public void setPfVo(ProformaInvoiceVO pfVo)

getPbs

public java.util.LinkedHashMap<PackingBoxPK,PrPackingBoxVO> getPbs()

setPbs

public void setPbs(java.util.LinkedHashMap<PackingBoxPK,PrPackingBoxVO> pbs)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProformaReceiverPackingBoxItemAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ProformaReceiverPackingBoxItemAgent

java.lang.Object
    extended by  bb.common.ProformaReceiverPackingBoxItemAgent
All Implemented Interfaces:
java.io.Serializable
public class ProformaReceiverPackingBoxItemAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ProformaReceiverPackingBoxItemAgent()
Method Summary
PackingBoxItemVO | getPBItem()
java.util.LinkedHashSet<PurchaseOrderItemPK> | getPOItems()
PrPackingBoxItemVO | getPrPBItem()
boolean | isPartExist()
boolean | isVendPartExist()
void | setPartExist(boolean partExist)
void | setPBItem(PackingBoxItemVO item)
void | setPOItems(java.util.LinkedHashSet<PurchaseOrderItemPK> items)
void | setPrPBItem(PrPackingBoxItemVO prPBItem)
void | setVendPartExist(boolean vendPartExist)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ProformaReceiverPackingBoxItemAgent

public ProformaReceiverPackingBoxItemAgent()
Method Detail

isPartExist

public boolean isPartExist()

setPartExist

public void setPartExist(boolean partExist)

getPBItem

public PackingBoxItemVO getPBItem()

setPBItem

public void setPBItem(PackingBoxItemVO item)

getPOItems

public java.util.LinkedHashSet<PurchaseOrderItemPK> getPOItems()

setPOItems

public void setPOItems(java.util.LinkedHashSet<PurchaseOrderItemPK> items)

getPrPBItem

public PrPackingBoxItemVO getPrPBItem()

setPrPBItem

public void setPrPBItem(PrPackingBoxItemVO prPBItem)

isVendPartExist

public boolean isVendPartExist()

setVendPartExist

public void setVendPartExist(boolean vendPartExist)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProjectVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ProjectVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ProjectVO
All Implemented Interfaces:
java.io.Serializable
public class ProjectVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ProjectVO()
Method Summary
java.lang.String | getDescription()
java.lang.String | getId()
void | setDescription(java.lang.String description)
void | setId(java.lang.String id)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ProjectVO

public ProjectVO()
Method Detail

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PrPackingBoxItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PrPackingBoxItemPK

java.lang.Object
    extended by  bb.common.PrPackingBoxItemPK
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable
public class PrPackingBoxItemPK
extends java.lang.Object
implements java.io.Serializable, java.lang.Comparable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PrPackingBoxItemPK()
default constructor
PrPackingBoxItemPK(java.lang.String pfReceiverNumber, java.lang.Integer packingBoxNumber, java.lang.String purchaseOrderNumber, java.lang.String purchaseOrderItemNumber)
full constructor
Method Summary
int | compareTo(java.lang.Object o)
boolean | equals(java.lang.Object other)
java.lang.Integer | getPackingBoxNumber()
java.lang.String | getPfReceiverNumber()
java.lang.String | getPurchaseOrderItemNumber()
java.lang.String | getPurchaseOrderNumber()
int | hashCode()
void | setPackingBoxNumber(java.lang.Integer packingBoxNumber)
void | setPfReceiverNumber(java.lang.String pfReceiverNumber)
void | setPurchaseOrderItemNumber(java.lang.String purchaseOrderItemNumber)
void | setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PrPackingBoxItemPK

public PrPackingBoxItemPK(java.lang.String pfReceiverNumber,
                          java.lang.Integer packingBoxNumber,
                          java.lang.String purchaseOrderNumber,
                          java.lang.String purchaseOrderItemNumber)
full constructor

PrPackingBoxItemPK

public PrPackingBoxItemPK()
default constructor

Method Detail

getPfReceiverNumber

public java.lang.String getPfReceiverNumber()

setPfReceiverNumber

public void setPfReceiverNumber(java.lang.String pfReceiverNumber)

getPackingBoxNumber

public java.lang.Integer getPackingBoxNumber()

setPackingBoxNumber

public void setPackingBoxNumber(java.lang.Integer packingBoxNumber)

getPurchaseOrderNumber

public java.lang.String getPurchaseOrderNumber()

setPurchaseOrderNumber

public void setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)

getPurchaseOrderItemNumber

public java.lang.String getPurchaseOrderItemNumber()

setPurchaseOrderItemNumber

public void setPurchaseOrderItemNumber(java.lang.String purchaseOrderItemNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

compareTo

public int compareTo(java.lang.Object o)
Specified by:
compareTo in interface java.lang.Comparable
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PrPackingBoxItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PrPackingBoxItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PrPackingBoxItemVO
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable
public class PrPackingBoxItemVO
extends VO
implements java.io.Serializable, java.lang.Comparable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PrPackingBoxItemVO()
Method Summary
int | compareTo(java.lang.Object o)
boolean | equals(java.lang.Object other)
java.lang.String | getDescription()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
PrPackingBoxItemPK | getPk()
java.math.BigDecimal | getQuantity()
java.lang.String | getSalesOrderNumber()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.lang.String | getVendorId()
int | hashCode()
void | setDescription(java.lang.String description)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(PrPackingBoxItemPK pk)
void | setQuantity(java.math.BigDecimal quantity)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setVendorId(java.lang.String vendorId)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PrPackingBoxItemVO

public PrPackingBoxItemVO()
Method Detail

getPk

public PrPackingBoxItemPK getPk()

setPk

public void setPk(PrPackingBoxItemPK pk)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getShipVia

public java.lang.String getShipVia()

getPartFrom

public java.lang.String getPartFrom()

setShipVia

public void setShipVia(java.lang.String shipVia)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

compareTo

public int compareTo(java.lang.Object o)
Specified by:
compareTo in interface java.lang.Comparable
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PrPackingBoxPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PrPackingBoxPK

java.lang.Object
    extended by  bb.common.PrPackingBoxPK
All Implemented Interfaces:
java.io.Serializable
public class PrPackingBoxPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PrPackingBoxPK()
default constructor
PrPackingBoxPK(java.lang.String pfReceiverNumber, java.lang.Integer packingBoxNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Integer | getPackingBoxNumber()
java.lang.String | getPfReceiverNumber()
int | hashCode()
void | setPackingBoxNumber(java.lang.Integer packingBoxNumber)
void | setPfReceiverNumber(java.lang.String pfReceiverNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PrPackingBoxPK

public PrPackingBoxPK(java.lang.String pfReceiverNumber,
                      java.lang.Integer packingBoxNumber)
full constructor

PrPackingBoxPK

public PrPackingBoxPK()
default constructor

Method Detail

getPfReceiverNumber

public java.lang.String getPfReceiverNumber()

setPfReceiverNumber

public void setPfReceiverNumber(java.lang.String pfReceiverNumber)

getPackingBoxNumber

public java.lang.Integer getPackingBoxNumber()

setPackingBoxNumber

public void setPackingBoxNumber(java.lang.Integer packingBoxNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PrPackingBoxVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PrPackingBoxVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PrPackingBoxVO
All Implemented Interfaces:
java.io.Serializable
public class PrPackingBoxVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PrPackingBoxVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDimension()
java.math.BigDecimal | getGrossWeight()
java.math.BigDecimal | getNetWeight()
java.util.Set | getPackingBoxItems()
PrPackingBoxPK | getPk()
java.lang.String | getStatus()
java.lang.String | getVendorId()
java.lang.String | getWeightUnit()
int | hashCode()
void | setDimension(java.lang.String dimension)
void | setGrossWeight(java.math.BigDecimal grossWeight)
void | setNetWeight(java.math.BigDecimal netWeight)
void | setPackingBoxItems(java.util.Set packingBoxItems)
void | setPk(PrPackingBoxPK pk)
void | setStatus(java.lang.String status)
void | setVendorId(java.lang.String vendorId)
void | setWeightUnit(java.lang.String weightUnit)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PrPackingBoxVO

public PrPackingBoxVO()
default constructor

Method Detail

getPk

public PrPackingBoxPK getPk()

setPk

public void setPk(PrPackingBoxPK pk)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getDimension

public java.lang.String getDimension()

setDimension

public void setDimension(java.lang.String dimension)

getGrossWeight

public java.math.BigDecimal getGrossWeight()

setGrossWeight

public void setGrossWeight(java.math.BigDecimal grossWeight)

getNetWeight

public java.math.BigDecimal getNetWeight()

setNetWeight

public void setNetWeight(java.math.BigDecimal netWeight)

getWeightUnit

public java.lang.String getWeightUnit()

setWeightUnit

public void setWeightUnit(java.lang.String weightUnit)

getPackingBoxItems

public java.util.Set getPackingBoxItems()

setPackingBoxItems

public void setPackingBoxItems(java.util.Set packingBoxItems)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PrReceiverListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PrReceiverListResult

java.lang.Object
    extended by  bb.common.PrReceiverListResult
All Implemented Interfaces:
java.io.Serializable
public class PrReceiverListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_BUYER
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_CONTACT
static java.lang.String | ORDER_BY_DATERECEIVED
static java.lang.String | ORDER_BY_PRIVATENOTES
static java.lang.String | ORDER_BY_PRNUMBER
static java.lang.String | ORDER_BY_RELATEDDOC
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_VENDORNAME
static java.lang.String | ORDER_BY_VENDORSO
Constructor Summary
PrReceiverListResult()
Method Summary
java.lang.String | getBuyer()
java.lang.String | getComments()
java.lang.String | getContact()
java.util.Date | getDateReceived()
java.lang.String | getPrivateNotes()
java.lang.String | getPrNumber()
java.lang.String | getRelatedDoc()
java.lang.String | getStatus()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
java.lang.String | getVendorSO()
void | setBuyer(java.lang.String buyer)
void | setComments(java.lang.String comments)
void | setContact(java.lang.String contact)
void | setDateReceived(java.util.Date dateReceived)
void | setPrivateNotes(java.lang.String privateNotes)
void | setPrNumber(java.lang.String prNumber)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setStatus(java.lang.String status)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
void | setVendorSO(java.lang.String vendorSO)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PRNUMBER

public static final java.lang.String ORDER_BY_PRNUMBER
See Also:
Constant Field Values

ORDER_BY_DATERECEIVED

public static final java.lang.String ORDER_BY_DATERECEIVED
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_VENDORNAME

public static final java.lang.String ORDER_BY_VENDORNAME
See Also:
Constant Field Values

ORDER_BY_VENDORSO

public static final java.lang.String ORDER_BY_VENDORSO
See Also:
Constant Field Values

ORDER_BY_CONTACT

public static final java.lang.String ORDER_BY_CONTACT
See Also:
Constant Field Values

ORDER_BY_BUYER

public static final java.lang.String ORDER_BY_BUYER
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values

ORDER_BY_PRIVATENOTES

public static final java.lang.String ORDER_BY_PRIVATENOTES
See Also:
Constant Field Values

ORDER_BY_RELATEDDOC

public static final java.lang.String ORDER_BY_RELATEDDOC
See Also:
Constant Field Values
Constructor Detail

PrReceiverListResult

public PrReceiverListResult()
Method Detail

getBuyer

public java.lang.String getBuyer()

setBuyer

public void setBuyer(java.lang.String buyer)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getDateReceived

public java.util.Date getDateReceived()

setDateReceived

public void setDateReceived(java.util.Date dateReceived)

getPrivateNotes

public java.lang.String getPrivateNotes()

setPrivateNotes

public void setPrivateNotes(java.lang.String privateNotes)

getPrNumber

public java.lang.String getPrNumber()

setPrNumber

public void setPrNumber(java.lang.String prNumber)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getVendorName

public java.lang.String getVendorName()

setVendorName

public void setVendorName(java.lang.String vendorName)

getVendorSO

public java.lang.String getVendorSO()

setVendorSO

public void setVendorSO(java.lang.String vendorSO)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PrReceiverWithQualityListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PrReceiverWithQualityListResult

java.lang.Object
    extended by  bb.common.PrReceiverWithQualityListResult
All Implemented Interfaces:
java.io.Serializable
public class PrReceiverWithQualityListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PrReceiverWithQualityListResult()
Method Summary
java.lang.String | getComments()
java.lang.String | getDescription()
java.lang.String | getPart()
java.lang.String | getPoItemNumber()
java.lang.String | getPoNumber()
java.lang.String | getPrItemNumber()
java.lang.String | getPrNumber()
java.math.BigDecimal | getQtyOrdered()
java.math.BigDecimal | getQtyReceived()
java.math.BigDecimal | getQtySit()
java.lang.String | getVendorSO()
void | setComments(java.lang.String comments)
void | setDescription(java.lang.String description)
void | setPart(java.lang.String part)
void | setPoItemNumber(java.lang.String poItemNumber)
void | setPoNumber(java.lang.String poNumber)
void | setPrItemNumber(java.lang.String prItemNumber)
void | setPrNumber(java.lang.String prNumber)
void | setQtyOrdered(java.math.BigDecimal qtyOrdered)
void | setQtyReceived(java.math.BigDecimal qtyReceived)
void | setQtySit(java.math.BigDecimal qtySit)
void | setVendorSO(java.lang.String vendorSO)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PrReceiverWithQualityListResult

public PrReceiverWithQualityListResult()
Method Detail

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getPart

public java.lang.String getPart()

setPart

public void setPart(java.lang.String part)

getPoItemNumber

public java.lang.String getPoItemNumber()

setPoItemNumber

public void setPoItemNumber(java.lang.String poItemNumber)

getPoNumber

public java.lang.String getPoNumber()

setPoNumber

public void setPoNumber(java.lang.String poNumber)

getPrItemNumber

public java.lang.String getPrItemNumber()

setPrItemNumber

public void setPrItemNumber(java.lang.String prItemNumber)

getPrNumber

public java.lang.String getPrNumber()

setPrNumber

public void setPrNumber(java.lang.String prNumber)

getQtyOrdered

public java.math.BigDecimal getQtyOrdered()

setQtyOrdered

public void setQtyOrdered(java.math.BigDecimal qtyOrdered)

getQtyReceived

public java.math.BigDecimal getQtyReceived()

setQtyReceived

public void setQtyReceived(java.math.BigDecimal qtyReceived)

getQtySit

public java.math.BigDecimal getQtySit()

setQtySit

public void setQtySit(java.math.BigDecimal qtySit)

getVendorSO

public java.lang.String getVendorSO()

setVendorSO

public void setVendorSO(java.lang.String vendorSO)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PullFromWorkOrderPartDetailAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PullFromWorkOrderPartDetailAgent

java.lang.Object
    extended by  bb.common.PullFromWorkOrderPartDetailAgent
All Implemented Interfaces:
java.io.Serializable
public final class PullFromWorkOrderPartDetailAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PullFromWorkOrderPartDetailAgent()
Method Summary
java.math.BigDecimal | getCost()
BB2Part | getPart()
WorkOrderItemIssuePK | getPk()
java.math.BigDecimal | getQty()
void | setCost(java.math.BigDecimal cost)
void | setPart(BB2Part part)
void | setPk(WorkOrderItemIssuePK pk)
void | setQty(java.math.BigDecimal qty)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PullFromWorkOrderPartDetailAgent

public PullFromWorkOrderPartDetailAgent()
Method Detail

getPk

public WorkOrderItemIssuePK getPk()

setPk

public void setPk(WorkOrderItemIssuePK pk)

getPart

public BB2Part getPart()

setPart

public void setPart(BB2Part part)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

getCost

public java.math.BigDecimal getCost()

setCost

public void setCost(java.math.BigDecimal cost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PurchaseOnTimeResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PurchaseOnTimeResult

java.lang.Object
    extended by  bb.common.PurchaseOnTimeResult
All Implemented Interfaces:
java.io.Serializable
public class PurchaseOnTimeResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PurchaseOnTimeResult()
Method Summary
java.lang.String | getCurrency()
int | getDay1()
int | getDay2()
java.util.List<PurchaseOrderOnTimeItemResult> | getItems()
void | setCurrency(java.lang.String currency)
void | setDay1(int day1)
void | setDay2(int day2)
void | setItems(java.util.List<PurchaseOrderOnTimeItemResult> items)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PurchaseOnTimeResult

public PurchaseOnTimeResult()
Method Detail

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getDay1

public int getDay1()

setDay1

public void setDay1(int day1)

getDay2

public int getDay2()

setDay2

public void setDay2(int day2)

getItems

public java.util.List<PurchaseOrderOnTimeItemResult> getItems()

setItems

public void setItems(java.util.List<PurchaseOrderOnTimeItemResult> items)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PurchaseOrderApprovalVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PurchaseOrderApprovalVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PurchaseOrderApprovalVO
All Implemented Interfaces:
java.io.Serializable
public class PurchaseOrderApprovalVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_APPROVELIMIT
static java.lang.String | ORDER_BY_CANAPPROVEOWNPURCHASEORDER
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_EMPLOYEEID
static java.lang.String | ORDER_BY_USERNAME
Constructor Summary
PurchaseOrderApprovalVO()
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getApproveLimit()
java.lang.String | getCanApproveOwnPurchaseOrder()
java.lang.String | getComments()
java.lang.String | getCurrency()
java.lang.String | getEmployeeId()
java.lang.String | getUserName()
int | hashCode()
void | setApproveLimit(java.math.BigDecimal approveLimit)
void | setCanApproveOwnPurchaseOrder(java.lang.String canApproveOwnPurchaseOrder)
void | setComments(java.lang.String comments)
void | setCurrency(java.lang.String currency)
void | setEmployeeId(java.lang.String employeeId)
void | setUserName(java.lang.String userName)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_EMPLOYEEID

public static final java.lang.String ORDER_BY_EMPLOYEEID
See Also:
Constant Field Values

ORDER_BY_USERNAME

public static final java.lang.String ORDER_BY_USERNAME
See Also:
Constant Field Values

ORDER_BY_APPROVELIMIT

public static final java.lang.String ORDER_BY_APPROVELIMIT
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values

ORDER_BY_CANAPPROVEOWNPURCHASEORDER

public static final java.lang.String ORDER_BY_CANAPPROVEOWNPURCHASEORDER
See Also:
Constant Field Values
Constructor Detail

PurchaseOrderApprovalVO

public PurchaseOrderApprovalVO()
Method Detail

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getApproveLimit

public java.math.BigDecimal getApproveLimit()

setApproveLimit

public void setApproveLimit(java.math.BigDecimal approveLimit)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getCanApproveOwnPurchaseOrder

public java.lang.String getCanApproveOwnPurchaseOrder()

getComments

public java.lang.String getComments()

setCanApproveOwnPurchaseOrder

public void setCanApproveOwnPurchaseOrder(java.lang.String canApproveOwnPurchaseOrder)

setComments

public void setComments(java.lang.String comments)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PurchaseOrderBoilerplateVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PurchaseOrderBoilerplateVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PurchaseOrderBoilerplateVO
All Implemented Interfaces:
java.io.Serializable
public class PurchaseOrderBoilerplateVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_BOILERPLATEID
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_POBOILERPLATE
Constructor Summary
PurchaseOrderBoilerplateVO()
default constructor
PurchaseOrderBoilerplateVO(java.lang.String boilerplateId, java.lang.String description)
minimal constructor
PurchaseOrderBoilerplateVO(java.lang.String boilerplateId, java.lang.String description, java.lang.String poBoilerplate)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getBoilerplateId()
java.lang.String | getDescription()
java.lang.String | getPoBoilerplate()
int | hashCode()
void | setBoilerplateId(java.lang.String boilerplateId)
void | setDescription(java.lang.String description)
void | setPoBoilerplate(java.lang.String poBoilerplate)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_BOILERPLATEID

public static final java.lang.String ORDER_BY_BOILERPLATEID
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_POBOILERPLATE

public static final java.lang.String ORDER_BY_POBOILERPLATE
See Also:
Constant Field Values
Constructor Detail

PurchaseOrderBoilerplateVO

public PurchaseOrderBoilerplateVO(java.lang.String boilerplateId,
                                  java.lang.String description,
                                  java.lang.String poBoilerplate)
full constructor

PurchaseOrderBoilerplateVO

public PurchaseOrderBoilerplateVO()
default constructor

PurchaseOrderBoilerplateVO

public PurchaseOrderBoilerplateVO(java.lang.String boilerplateId,
                                  java.lang.String description)
minimal constructor

Method Detail

getBoilerplateId

public java.lang.String getBoilerplateId()

setBoilerplateId

public void setBoilerplateId(java.lang.String boilerplateId)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getPoBoilerplate

public java.lang.String getPoBoilerplate()

setPoBoilerplate

public void setPoBoilerplate(java.lang.String poBoilerplate)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PurchaseOrderCheckListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PurchaseOrderCheckListResult

java.lang.Object
    extended by  bb.common.PurchaseOrderCheckListResult
All Implemented Interfaces:
java.io.Serializable
public class PurchaseOrderCheckListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DELIVERY
static java.lang.String | ORDER_BY_PODATE
static java.lang.String | ORDER_BY_PONUMBER
static java.lang.String | ORDER_BY_VENDORID
Constructor Summary
PurchaseOrderCheckListResult()
Method Summary
java.math.BigDecimal | getApTotal()
java.lang.String | getBuyer()
java.lang.String | getComments()
java.lang.String | getCurrency()
java.util.Date | getDelivery()
java.util.Date | getPoDate()
java.lang.String | getPoNumber()
java.lang.String | getProject()
java.lang.String | getStatus()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
void | setApTotal(java.math.BigDecimal apTotal)
void | setBuyer(java.lang.String buyer)
void | setComments(java.lang.String comments)
void | setCurrency(java.lang.String currency)
void | setDelivery(java.util.Date delivery)
void | setPoDate(java.util.Date poDate)
void | setPoNumber(java.lang.String poNumber)
void | setProject(java.lang.String project)
void | setStatus(java.lang.String status)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PONUMBER

public static final java.lang.String ORDER_BY_PONUMBER
See Also:
Constant Field Values

ORDER_BY_PODATE

public static final java.lang.String ORDER_BY_PODATE
See Also:
Constant Field Values

ORDER_BY_DELIVERY

public static final java.lang.String ORDER_BY_DELIVERY
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values
Constructor Detail

PurchaseOrderCheckListResult

public PurchaseOrderCheckListResult()
Method Detail

getPoNumber

public java.lang.String getPoNumber()

getVendorId

public java.lang.String getVendorId()

getBuyer

public java.lang.String getBuyer()

getPoDate

public java.util.Date getPoDate()

getDelivery

public java.util.Date getDelivery()

getStatus

public java.lang.String getStatus()

getApTotal

public java.math.BigDecimal getApTotal()

getCurrency

public java.lang.String getCurrency()

getVendorName

public java.lang.String getVendorName()

getProject

public java.lang.String getProject()

getComments

public java.lang.String getComments()

setPoNumber

public void setPoNumber(java.lang.String poNumber)

setVendorId

public void setVendorId(java.lang.String vendorId)

setBuyer

public void setBuyer(java.lang.String buyer)

setPoDate

public void setPoDate(java.util.Date poDate)

setDelivery

public void setDelivery(java.util.Date delivery)

setStatus

public void setStatus(java.lang.String status)

setApTotal

public void setApTotal(java.math.BigDecimal apTotal)

setCurrency

public void setCurrency(java.lang.String currency)

setVendorName

public void setVendorName(java.lang.String vendorName)

setProject

public void setProject(java.lang.String project)

setComments

public void setComments(java.lang.String comments)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PurchaseOrderContractResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PurchaseOrderContractResult

java.lang.Object
    extended by  bb.common.PurchaseOrderContractResult
All Implemented Interfaces:
java.io.Serializable
public class PurchaseOrderContractResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PurchaseOrderContractResult()
Method Summary
java.util.Date | getArrivalDate()
java.lang.String | getArrivalStatus()
java.math.BigDecimal | getBudgetAmount()
java.lang.String | getBuyer()
java.lang.String | getComment()
java.lang.String | getContract()
java.math.BigDecimal | getContractAmount()
java.util.Date | getContractDate()
java.lang.String | getContractPeriod()
java.lang.String | getDelayDays()
java.lang.String | getDescription()
java.util.Date | getExpectDeliveryDate()
java.lang.String | getItemAndQuantity()
java.lang.String | getItemNumber()
java.util.HashMap | getMap()
java.math.BigDecimal | getNoPayAmount()
java.math.BigDecimal | getNoStorageAmount()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getPayAmount()
java.util.Date | getPayDate()
java.lang.String | getProjectNumber()
java.lang.String | getPurchaseContent()
java.lang.String | getPurchaseMethod()
java.lang.String | getPurchaseOrderNumber()
java.lang.String | getPurchaseRequestNumber()
java.lang.String | getRequester()
java.util.Date | getStorageDate()
java.util.Date | getSubmitDate()
java.lang.String | getType()
java.lang.String | getVendor()
java.lang.String | getVendorSO()
java.math.BigDecimal | getYearStorageAmount()
void | setArrivalDate(java.util.Date arrivalDate)
void | setArrivalStatus(java.lang.String arrivalStatus)
void | setBudgetAmount(java.math.BigDecimal budgetAmount)
void | setBuyer(java.lang.String buyer)
void | setComment(java.lang.String comment)
void | setContract(java.lang.String contract)
void | setContractAmount(java.math.BigDecimal contractAmount)
void | setContractDate(java.util.Date contractDate)
void | setContractPeriod(java.lang.String contractPeriod)
void | setDelayDays(java.lang.String delayDays)
void | setDescription(java.lang.String description)
void | setExpectDeliveryDate(java.util.Date expectDeliveryDate)
void | setItemAndQuantity(java.lang.String itemAndQuantity)
void | setItemNumber(java.lang.String itemNumber)
void | setMap(java.util.HashMap map)
void | setNoPayAmount(java.math.BigDecimal noPayAmount)
void | setNoStorageAmount(java.math.BigDecimal noStorageAmount)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPayAmount(java.math.BigDecimal payAmount)
void | setPayDate(java.util.Date payDate)
void | setProjectNumber(java.lang.String projectNumber)
void | setPurchaseContent(java.lang.String purchaseContent)
void | setPurchaseMethod(java.lang.String purchaseMethod)
void | setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)
void | setPurchaseRequestNumber(java.lang.String purchaseRequestNumber)
void | setRequester(java.lang.String requester)
void | setStorageDate(java.util.Date storageDate)
void | setSubmitDate(java.util.Date submitDate)
void | setType(java.lang.String type)
void | setVendor(java.lang.String vendor)
void | setVendorSO(java.lang.String vendorSO)
void | setYearStorageAmount(java.math.BigDecimal yearStorageAmount)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PurchaseOrderContractResult

public PurchaseOrderContractResult()
Method Detail

getMap

public java.util.HashMap getMap()

setMap

public void setMap(java.util.HashMap map)

getContract

public java.lang.String getContract()

setContract

public void setContract(java.lang.String contract)

getRequester

public java.lang.String getRequester()

setRequester

public void setRequester(java.lang.String requester)

getPurchaseRequestNumber

public java.lang.String getPurchaseRequestNumber()

setPurchaseRequestNumber

public void setPurchaseRequestNumber(java.lang.String purchaseRequestNumber)

getPurchaseOrderNumber

public java.lang.String getPurchaseOrderNumber()

setPurchaseOrderNumber

public void setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)

getProjectNumber

public java.lang.String getProjectNumber()

setProjectNumber

public void setProjectNumber(java.lang.String projectNumber)

getPurchaseContent

public java.lang.String getPurchaseContent()

setPurchaseContent

public void setPurchaseContent(java.lang.String purchaseContent)

getType

public java.lang.String getType()

setType

public void setType(java.lang.String type)

getItemAndQuantity

public java.lang.String getItemAndQuantity()

setItemAndQuantity

public void setItemAndQuantity(java.lang.String itemAndQuantity)

getBudgetAmount

public java.math.BigDecimal getBudgetAmount()

setBudgetAmount

public void setBudgetAmount(java.math.BigDecimal budgetAmount)

getContractAmount

public java.math.BigDecimal getContractAmount()

setContractAmount

public void setContractAmount(java.math.BigDecimal contractAmount)

getVendor

public java.lang.String getVendor()

setVendor

public void setVendor(java.lang.String vendor)

getPurchaseMethod

public java.lang.String getPurchaseMethod()

setPurchaseMethod

public void setPurchaseMethod(java.lang.String purchaseMethod)

getSubmitDate

public java.util.Date getSubmitDate()

setSubmitDate

public void setSubmitDate(java.util.Date submitDate)

getBuyer

public java.lang.String getBuyer()

setBuyer

public void setBuyer(java.lang.String buyer)

getContractPeriod

public java.lang.String getContractPeriod()

setContractPeriod

public void setContractPeriod(java.lang.String contractPeriod)

getContractDate

public java.util.Date getContractDate()

setContractDate

public void setContractDate(java.util.Date contractDate)

getExpectDeliveryDate

public java.util.Date getExpectDeliveryDate()

setExpectDeliveryDate

public void setExpectDeliveryDate(java.util.Date expectDeliveryDate)

getArrivalStatus

public java.lang.String getArrivalStatus()

setArrivalStatus

public void setArrivalStatus(java.lang.String arrivalStatus)

getArrivalDate

public java.util.Date getArrivalDate()

setArrivalDate

public void setArrivalDate(java.util.Date arrivalDate)

getStorageDate

public java.util.Date getStorageDate()

setStorageDate

public void setStorageDate(java.util.Date storageDate)

getYearStorageAmount

public java.math.BigDecimal getYearStorageAmount()

setYearStorageAmount

public void setYearStorageAmount(java.math.BigDecimal yearStorageAmount)

getNoStorageAmount

public java.math.BigDecimal getNoStorageAmount()

setNoStorageAmount

public void setNoStorageAmount(java.math.BigDecimal noStorageAmount)

getDelayDays

public java.lang.String getDelayDays()

setDelayDays

public void setDelayDays(java.lang.String delayDays)

getComment

public java.lang.String getComment()

setComment

public void setComment(java.lang.String comment)

getPayAmount

public java.math.BigDecimal getPayAmount()

setPayAmount

public void setPayAmount(java.math.BigDecimal payAmount)

getNoPayAmount

public java.math.BigDecimal getNoPayAmount()

setNoPayAmount

public void setNoPayAmount(java.math.BigDecimal noPayAmount)

getPayDate

public java.util.Date getPayDate()

setPayDate

public void setPayDate(java.util.Date payDate)

getItemNumber

public java.lang.String getItemNumber()

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getVendorSO

public java.lang.String getVendorSO()

setVendorSO

public void setVendorSO(java.lang.String vendorSO)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PurchaseOrderDocumentVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PurchaseOrderDocumentVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PurchaseOrderDocumentVO
All Implemented Interfaces:
java.io.Serializable
public class PurchaseOrderDocumentVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PurchaseOrderDocumentVO()
Method Summary
java.lang.String | getComments()
java.lang.String | getDocDescription()
java.lang.String | getDocFileName()
long | getDocLength()
java.util.Date | getDocumentDate()
java.lang.String | getExtension()
java.lang.Long | getIi()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getPoNumber()
void | setComments(java.lang.String comments)
void | setDocDescription(java.lang.String docDescription)
void | setDocFileName(java.lang.String docFileName)
void | setDocLength(long docLength)
void | setDocumentDate(java.util.Date documentDate)
void | setExtension(java.lang.String extension)
void | setIi(java.lang.Long ii)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setPoNumber(java.lang.String poNumber)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PurchaseOrderDocumentVO

public PurchaseOrderDocumentVO()
Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getPoNumber

public java.lang.String getPoNumber()

setPoNumber

public void setPoNumber(java.lang.String poNumber)

getDocDescription

public java.lang.String getDocDescription()

setDocDescription

public void setDocDescription(java.lang.String docDescription)

getDocumentDate

public java.util.Date getDocumentDate()

setDocumentDate

public void setDocumentDate(java.util.Date documentDate)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

getDocFileName

public java.lang.String getDocFileName()

setDocFileName

public void setDocFileName(java.lang.String docFileName)

getDocLength

public long getDocLength()

setDocLength

public void setDocLength(long docLength)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PurchaseOrderItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PurchaseOrderItemListResult

java.lang.Object
    extended by  bb.common.PurchaseOrderItemListResult
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
POItemByRefDoc1ListResult
public class PurchaseOrderItemListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACCOUNTNUMBER
static java.lang.String | ORDER_BY_APOPEN
static java.lang.String | ORDER_BY_APRECEIVED
static java.lang.String | ORDER_BY_ARRIVEDATE
static java.lang.String | ORDER_BY_BUYER
static java.lang.String | ORDER_BY_COMPANYNUITID
static java.lang.String | ORDER_BY_COSTPERUNIT
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_DELEVERYDATE
static java.lang.String | ORDER_BY_DISCOUNT
static java.lang.String | ORDER_BY_EXTENDPRICE
static java.lang.String | ORDER_BY_LASTRECEIVEDATE
static java.lang.String | ORDER_BY_ORDERQTY
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_PODATE
static java.lang.String | ORDER_BY_PONUMBER
static java.lang.String | ORDER_BY_PRODUCTCODE
static java.lang.String | ORDER_BY_PROJECT
static java.lang.String | ORDER_BY_RECEIVEDQTY
static java.lang.String | ORDER_BY_RELATEDDOC
static java.lang.String | ORDER_BY_REQUESTER
static java.lang.String | ORDER_BY_SHIPTO
static java.lang.String | ORDER_BY_VENDORID
Constructor Summary
PurchaseOrderItemListResult()
Method Summary
java.lang.String | getAccountNumber()
java.math.BigDecimal | getApOpen()
java.math.BigDecimal | getApReceived()
java.util.Date | getArriveDate()
java.lang.String | getBuyer()
java.lang.String | getCompanyUnitId()
java.math.BigDecimal | getCostPerUnit()
java.lang.String | getCurrency()
int | getDelayDays()
java.util.Date | getDeleveryDate()
java.math.BigDecimal | getDiscount()
java.math.BigDecimal | getExtendPrice()
java.lang.String | getItemDescription()
java.math.BigDecimal | getItemTotalTax()
java.util.Date | getLastReceiveDate()
java.math.BigDecimal | getOnDemandQty()
java.math.BigDecimal | getOnHandQty()
java.math.BigDecimal | getOnOrderQty()
java.math.BigDecimal | getOrderQty()
BB2Part | getPartPk()
java.util.Date | getPoDate()
java.lang.String | getPoItemNumber()
java.lang.String | getPoItemStatus()
java.lang.String | getPoNumber()
java.lang.String | getProductCode()
java.lang.String | getProject()
java.math.BigDecimal | getReceivedQty()
java.util.Set | getRefDocOnes()
java.util.Set | getRefDocTwoes()
java.lang.String | getRelatedDoc()
java.lang.String | getRequester()
java.lang.String | getShipto()
java.math.BigDecimal | getSipQty()
java.math.BigDecimal | getSitQty()
java.lang.String | getUnit()
java.lang.String | getVendorId()
java.math.BigDecimal | getWipQty()
void | setAccountNumber(java.lang.String accountNumber)
void | setApOpen(java.math.BigDecimal apOpen)
void | setApReceived(java.math.BigDecimal apReceived)
void | setArriveDate(java.util.Date arriveDate)
void | setBuyer(java.lang.String buyer)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCostPerUnit(java.math.BigDecimal costPerUnit)
void | setCurrency(java.lang.String currency)
void | setDelayDays(int delayDays)
void | setDeleveryDate(java.util.Date deleveryDate)
void | setDiscount(java.math.BigDecimal discount)
void | setExtendPrice(java.math.BigDecimal extendPrice)
void | setItemDescription(java.lang.String itemDescription)
void | setItemTotalTax(java.math.BigDecimal itemTotalTax)
void | setLastReceiveDate(java.util.Date lastReceiveDate)
void | setOnDemandQty(java.math.BigDecimal onDemandQty)
void | setOnHandQty(java.math.BigDecimal onHandQty)
void | setOnOrderQty(java.math.BigDecimal onOrderQty)
void | setOrderQty(java.math.BigDecimal orderQty)
void | setPartPk(BB2Part partPk)
void | setPoDate(java.util.Date poDate)
void | setPoItemNumber(java.lang.String poItemNumber)
void | setPoItemStatus(java.lang.String poItemStatus)
void | setPoNumber(java.lang.String poNumber)
void | setProductCode(java.lang.String productCode)
void | setProject(java.lang.String project)
void | setReceivedQty(java.math.BigDecimal receivedQty)
void | setRefDocOnes(java.util.Set refDocOnes)
void | setRefDocTwoes(java.util.Set refDocTwoes)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setRequester(java.lang.String requester)
void | setShipto(java.lang.String shipto)
void | setSipQty(java.math.BigDecimal sipQty)
void | setSitQty(java.math.BigDecimal sitQty)
void | setUnit(java.lang.String unit)
void | setVendorId(java.lang.String vendorId)
void | setWipQty(java.math.BigDecimal wipQty)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PONUMBER

public static final java.lang.String ORDER_BY_PONUMBER
See Also:
Constant Field Values

ORDER_BY_PODATE

public static final java.lang.String ORDER_BY_PODATE
See Also:
Constant Field Values

ORDER_BY_DELEVERYDATE

public static final java.lang.String ORDER_BY_DELEVERYDATE
See Also:
Constant Field Values

ORDER_BY_ARRIVEDATE

public static final java.lang.String ORDER_BY_ARRIVEDATE
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_BUYER

public static final java.lang.String ORDER_BY_BUYER
See Also:
Constant Field Values

ORDER_BY_PROJECT

public static final java.lang.String ORDER_BY_PROJECT
See Also:
Constant Field Values

ORDER_BY_REQUESTER

public static final java.lang.String ORDER_BY_REQUESTER
See Also:
Constant Field Values

ORDER_BY_SHIPTO

public static final java.lang.String ORDER_BY_SHIPTO
See Also:
Constant Field Values

ORDER_BY_ORDERQTY

public static final java.lang.String ORDER_BY_ORDERQTY
See Also:
Constant Field Values

ORDER_BY_RECEIVEDQTY

public static final java.lang.String ORDER_BY_RECEIVEDQTY
See Also:
Constant Field Values

ORDER_BY_COSTPERUNIT

public static final java.lang.String ORDER_BY_COSTPERUNIT
See Also:
Constant Field Values

ORDER_BY_DISCOUNT

public static final java.lang.String ORDER_BY_DISCOUNT
See Also:
Constant Field Values

ORDER_BY_EXTENDPRICE

public static final java.lang.String ORDER_BY_EXTENDPRICE
See Also:
Constant Field Values

ORDER_BY_APOPEN

public static final java.lang.String ORDER_BY_APOPEN
See Also:
Constant Field Values

ORDER_BY_APRECEIVED

public static final java.lang.String ORDER_BY_APRECEIVED
See Also:
Constant Field Values

ORDER_BY_RELATEDDOC

public static final java.lang.String ORDER_BY_RELATEDDOC
See Also:
Constant Field Values

ORDER_BY_LASTRECEIVEDATE

public static final java.lang.String ORDER_BY_LASTRECEIVEDATE
See Also:
Constant Field Values

ORDER_BY_ACCOUNTNUMBER

public static final java.lang.String ORDER_BY_ACCOUNTNUMBER
See Also:
Constant Field Values

ORDER_BY_COMPANYNUITID

public static final java.lang.String ORDER_BY_COMPANYNUITID
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values

ORDER_BY_PRODUCTCODE

public static final java.lang.String ORDER_BY_PRODUCTCODE
See Also:
Constant Field Values
Constructor Detail

PurchaseOrderItemListResult

public PurchaseOrderItemListResult()
Method Detail

getPoItemStatus

public java.lang.String getPoItemStatus()

getDeleveryDate

public java.util.Date getDeleveryDate()

getVendorId

public java.lang.String getVendorId()

getExtendPrice

public java.math.BigDecimal getExtendPrice()

getCostPerUnit

public java.math.BigDecimal getCostPerUnit()

getReceivedQty

public java.math.BigDecimal getReceivedQty()

getItemTotalTax

public java.math.BigDecimal getItemTotalTax()

getOrderQty

public java.math.BigDecimal getOrderQty()

getItemDescription

public java.lang.String getItemDescription()

getPartPk

public BB2Part getPartPk()

getPoItemNumber

public java.lang.String getPoItemNumber()

setPoNumber

public void setPoNumber(java.lang.String poNumber)

setItemTotalTax

public void setItemTotalTax(java.math.BigDecimal itemTotalTax)

setPoItemStatus

public void setPoItemStatus(java.lang.String poItemStatus)

setDeleveryDate

public void setDeleveryDate(java.util.Date deleveryDate)

setVendorId

public void setVendorId(java.lang.String vendorId)

setExtendPrice

public void setExtendPrice(java.math.BigDecimal extendPrice)

setCostPerUnit

public void setCostPerUnit(java.math.BigDecimal costPerUnit)

setReceivedQty

public void setReceivedQty(java.math.BigDecimal receivedQty)

setOrderQty

public void setOrderQty(java.math.BigDecimal orderQty)

setItemDescription

public void setItemDescription(java.lang.String itemDescription)

setPartPk

public void setPartPk(BB2Part partPk)

setPoItemNumber

public void setPoItemNumber(java.lang.String poItemNumber)

setDiscount

public void setDiscount(java.math.BigDecimal discount)

setPoDate

public void setPoDate(java.util.Date poDate)

setBuyer

public void setBuyer(java.lang.String buyer)

setUnit

public void setUnit(java.lang.String unit)

setProject

public void setProject(java.lang.String project)

setRequester

public void setRequester(java.lang.String requester)

setDelayDays

public void setDelayDays(int delayDays)

getPoNumber

public java.lang.String getPoNumber()

getDiscount

public java.math.BigDecimal getDiscount()

getPoDate

public java.util.Date getPoDate()

getBuyer

public java.lang.String getBuyer()

getUnit

public java.lang.String getUnit()

getProject

public java.lang.String getProject()

getRequester

public java.lang.String getRequester()

getDelayDays

public int getDelayDays()

getApOpen

public java.math.BigDecimal getApOpen()

setApOpen

public void setApOpen(java.math.BigDecimal apOpen)

getApReceived

public java.math.BigDecimal getApReceived()

setApReceived

public void setApReceived(java.math.BigDecimal apReceived)

getShipto

public java.lang.String getShipto()

setShipto

public void setShipto(java.lang.String shipto)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getArriveDate

public java.util.Date getArriveDate()

setArriveDate

public void setArriveDate(java.util.Date arriveDate)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getLastReceiveDate

public java.util.Date getLastReceiveDate()

setLastReceiveDate

public void setLastReceiveDate(java.util.Date lastReceiveDate)

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getProductCode

public java.lang.String getProductCode()

setProductCode

public void setProductCode(java.lang.String productCode)

getOnDemandQty

public java.math.BigDecimal getOnDemandQty()

setOnDemandQty

public void setOnDemandQty(java.math.BigDecimal onDemandQty)

getOnHandQty

public java.math.BigDecimal getOnHandQty()

setOnHandQty

public void setOnHandQty(java.math.BigDecimal onHandQty)

getOnOrderQty

public java.math.BigDecimal getOnOrderQty()

setOnOrderQty

public void setOnOrderQty(java.math.BigDecimal onOrderQty)

getSipQty

public java.math.BigDecimal getSipQty()

setSipQty

public void setSipQty(java.math.BigDecimal sipQty)

getSitQty

public java.math.BigDecimal getSitQty()

setSitQty

public void setSitQty(java.math.BigDecimal sitQty)

getWipQty

public java.math.BigDecimal getWipQty()

setWipQty

public void setWipQty(java.math.BigDecimal wipQty)

getRefDocOnes

public java.util.Set getRefDocOnes()

setRefDocOnes

public void setRefDocOnes(java.util.Set refDocOnes)

getRefDocTwoes

public java.util.Set getRefDocTwoes()

setRefDocTwoes

public void setRefDocTwoes(java.util.Set refDocTwoes)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PurchaseOrderItemManufacturerPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PurchaseOrderItemManufacturerPK

java.lang.Object
    extended by  bb.common.PurchaseOrderItemManufacturerPK
All Implemented Interfaces:
java.io.Serializable
public class PurchaseOrderItemManufacturerPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PurchaseOrderItemManufacturerPK()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Short | getItemNumber()
java.lang.String | getPurchaseOrderItemNumber()
java.lang.String | getPurchaseOrderNumber()
int | hashCode()
void | setItemNumber(java.lang.Short itemNumber)
void | setPurchaseOrderItemNumber(java.lang.String purchaseOrderItemNumber)
void | setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PurchaseOrderItemManufacturerPK

public PurchaseOrderItemManufacturerPK()
Method Detail

setPurchaseOrderNumber

public void setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)

getPurchaseOrderNumber

public java.lang.String getPurchaseOrderNumber()

setPurchaseOrderItemNumber

public void setPurchaseOrderItemNumber(java.lang.String purchaseOrderItemNumber)

getPurchaseOrderItemNumber

public java.lang.String getPurchaseOrderItemNumber()

setItemNumber

public void setItemNumber(java.lang.Short itemNumber)

getItemNumber

public java.lang.Short getItemNumber()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PurchaseOrderItemManufacturerVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PurchaseOrderItemManufacturerVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PurchaseOrderItemManufacturerVO
All Implemented Interfaces:
java.io.Serializable
public class PurchaseOrderItemManufacturerVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PurchaseOrderItemManufacturerVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getManufacturerName()
java.lang.String | getManufacturerPartNumber()
PurchaseOrderItemManufacturerPK | getPk()
int | hashCode()
void | setManufacturerName(java.lang.String manufacturerName)
void | setManufacturerPartNumber(java.lang.String manufacturerPartNumber)
void | setPk(PurchaseOrderItemManufacturerPK pk)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PurchaseOrderItemManufacturerVO

public PurchaseOrderItemManufacturerVO()
Method Detail

getPk

public PurchaseOrderItemManufacturerPK getPk()

setPk

public void setPk(PurchaseOrderItemManufacturerPK pk)

getManufacturerName

public java.lang.String getManufacturerName()

setManufacturerName

public void setManufacturerName(java.lang.String manufacturerName)

getManufacturerPartNumber

public java.lang.String getManufacturerPartNumber()

setManufacturerPartNumber

public void setManufacturerPartNumber(java.lang.String manufacturerPartNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PurchaseOrderItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PurchaseOrderItemPK

java.lang.Object
    extended by  bb.common.PurchaseOrderItemPK
All Implemented Interfaces:
java.io.Serializable
public class PurchaseOrderItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PurchaseOrderItemPK()
PurchaseOrderItemPK(java.lang.String purchaseOrderNumber, java.lang.String purchaseOrderItemNumber)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getPurchaseOrderItemNumber()
java.lang.String | getPurchaseOrderNumber()
int | hashCode()
void | setPurchaseOrderItemNumber(java.lang.String purchaseOrderItemNumber)
void | setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PurchaseOrderItemPK

public PurchaseOrderItemPK()

PurchaseOrderItemPK

public PurchaseOrderItemPK(java.lang.String purchaseOrderNumber,
                           java.lang.String purchaseOrderItemNumber)
Method Detail

setPurchaseOrderNumber

public void setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)

getPurchaseOrderNumber

public java.lang.String getPurchaseOrderNumber()

setPurchaseOrderItemNumber

public void setPurchaseOrderItemNumber(java.lang.String purchaseOrderItemNumber)

getPurchaseOrderItemNumber

public java.lang.String getPurchaseOrderItemNumber()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PurchaseOrderItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PurchaseOrderItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PurchaseOrderItemVO
All Implemented Interfaces:
java.io.Serializable
public class PurchaseOrderItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PurchaseOrderItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAcceptedBy()
java.util.Date | getAcceptedDate()
java.util.Date | getActual()
java.math.BigDecimal | getApNet()
java.math.BigDecimal | getApOpen()
java.math.BigDecimal | getApReceived()
java.math.BigDecimal | getApTotal()
java.util.Date | getArriveDate()
java.lang.String | getChangeMfg()
java.lang.String | getChangeOrder()
java.lang.String | getCommodityCode()
java.math.BigDecimal | getCostPerUnit()
java.math.BigDecimal | getCostPerUnitWithTax()
java.util.Date | getDateRequired()
int | getDelayDays()
java.lang.String | getDescription()
java.math.BigDecimal | getDiscount()
java.lang.String | getDwg()
java.math.BigDecimal | getHqa()
java.lang.String | getItemComments()
java.lang.String | getItemPrivateNotes()
java.math.BigDecimal | getItemSubTotal()
java.math.BigDecimal | getItemTotalDiscount()
java.math.BigDecimal | getItemTotalTax()
java.math.BigDecimal | getLeadTime()
java.lang.String | getLocate()
java.lang.String | getMfg()
java.lang.String | getModelNumber()
java.lang.String | getMpn()
java.util.Date | getOriginal()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
PurchaseOrderItemPK | getPk()
java.lang.String | getPoUnit()
java.math.BigDecimal | getPoUnitQty()
java.math.BigDecimal | getPoUnitRate()
java.lang.String | getPriority()
java.lang.String | getProductCode()
java.util.Set | getPurchaseOrderItemManufacturer()
java.lang.String | getQr()
java.math.BigDecimal | getQuantityOrdered()
java.math.BigDecimal | getQuantityReceived()
java.math.BigDecimal | getQuantityShipped()
java.util.Set | getRefDocOnes()
java.util.Set | getRefDocTwoes()
java.lang.String | getReferenceDoc1()
java.lang.String | getReferenceDoc2()
java.lang.String | getRevision()
java.lang.String | getShippingStatus()
java.lang.String | getShipVia()
java.math.BigDecimal | getSitQty()
java.lang.String | getStatus()
java.math.BigDecimal | getTaxRate()
java.lang.String | getTraceable()
java.lang.Byte | getTraceableLevel()
java.lang.String | getUnit()
int | hashCode()
boolean | isIcrRequiredWhenReceiverNa()
boolean | isUsePriceWithTax()
void | setAcceptedBy(java.lang.String acceptedBy)
void | setAcceptedDate(java.util.Date acceptedDate)
void | setActual(java.util.Date actual)
void | setApNet(java.math.BigDecimal apNet)
void | setApOpen(java.math.BigDecimal apOpen)
void | setApReceived(java.math.BigDecimal apReceived)
void | setApTotal(java.math.BigDecimal apTotal)
void | setArriveDate(java.util.Date arriveDate)
void | setChangeMfg(java.lang.String changeMfg)
void | setChangeOrder(java.lang.String changeOrder)
void | setCommodityCode(java.lang.String commodityCode)
void | setCostPerUnit(java.math.BigDecimal costPerUnit)
void | setCostPerUnitWithTax(java.math.BigDecimal costPerUnitWithTax)
void | setDateRequired(java.util.Date dateRequired)
void | setDelayDays(int delayDays)
void | setDescription(java.lang.String description)
void | setDiscount(java.math.BigDecimal discount)
void | setDwg(java.lang.String dwg)
void | setHqa(java.math.BigDecimal hqa)
void | setIcrRequiredWhenReceiverNa(boolean icrRequiredWhenReceiverNa)
void | setItemComments(java.lang.String itemComments)
void | setItemPrivateNotes(java.lang.String itemPrivateNotes)
void | setItemSubTotal(java.math.BigDecimal itemSubTotal)
void | setItemTotalDiscount(java.math.BigDecimal itemTotalDiscount)
void | setItemTotalTax(java.math.BigDecimal itemTotalTax)
void | setLeadTime(java.math.BigDecimal leadTime)
void | setLocate(java.lang.String locate)
void | setMfg(java.lang.String mfg)
void | setModelNumber(java.lang.String modelNumber)
void | setMpn(java.lang.String mpn)
void | setOriginal(java.util.Date original)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(PurchaseOrderItemPK pk)
void | setPoUnit(java.lang.String poUnit)
void | setPoUnitQty(java.math.BigDecimal poUnitQty)
void | setPoUnitRate(java.math.BigDecimal poUnitRate)
void | setPriority(java.lang.String priority)
void | setProductCode(java.lang.String productCode)
void | setPurchaseOrderItemManufacturer(java.util.Set purchaseOrderItemManufacturer)
void | setQr(java.lang.String qr)
void | setQuantityOrdered(java.math.BigDecimal quantityOrdered)
void | setQuantityReceived(java.math.BigDecimal quantityReceived)
void | setQuantityShipped(java.math.BigDecimal quantityShipped)
void | setRefDocOnes(java.util.Set refDocOnes)
void | setRefDocTwoes(java.util.Set refDocTwoes)
void | setReferenceDoc1(java.lang.String referenceDoc1)
void | setReferenceDoc2(java.lang.String referenceDoc2)
void | setRevision(java.lang.String revision)
void | setShippingStatus(java.lang.String shippingStatus)
void | setShipVia(java.lang.String shipVia)
void | setSitQty(java.math.BigDecimal sitQty)
void | setStatus(java.lang.String status)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setTraceable(java.lang.String traceable)
void | setTraceableLevel(java.lang.Byte traceableLevel)
void | setUnit(java.lang.String unit)
void | setUsePriceWithTax(boolean usePriceWithTax)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PurchaseOrderItemVO

public PurchaseOrderItemVO()
Method Detail

getPk

public PurchaseOrderItemPK getPk()

setPk

public void setPk(PurchaseOrderItemPK pk)

getItemSubTotal

public java.math.BigDecimal getItemSubTotal()

setItemSubTotal

public void setItemSubTotal(java.math.BigDecimal itemSubTotal)

getItemTotalDiscount

public java.math.BigDecimal getItemTotalDiscount()

setItemTotalDiscount

public void setItemTotalDiscount(java.math.BigDecimal itemTotalDiscount)

getApNet

public java.math.BigDecimal getApNet()

setApNet

public void setApNet(java.math.BigDecimal apNet)

getApReceived

public java.math.BigDecimal getApReceived()

setApReceived

public void setApReceived(java.math.BigDecimal apReceived)

getApOpen

public java.math.BigDecimal getApOpen()

setApOpen

public void setApOpen(java.math.BigDecimal apOpen)

getItemTotalTax

public java.math.BigDecimal getItemTotalTax()

setItemTotalTax

public void setItemTotalTax(java.math.BigDecimal itemTotalTax)

getApTotal

public java.math.BigDecimal getApTotal()

setApTotal

public void setApTotal(java.math.BigDecimal apTotal)

getReferenceDoc1

public java.lang.String getReferenceDoc1()

setReferenceDoc1

public void setReferenceDoc1(java.lang.String referenceDoc1)

getReferenceDoc2

public java.lang.String getReferenceDoc2()

setReferenceDoc2

public void setReferenceDoc2(java.lang.String referenceDoc2)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getQr

public java.lang.String getQr()

setQr

public void setQr(java.lang.String qr)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getAcceptedDate

public java.util.Date getAcceptedDate()

setAcceptedDate

public void setAcceptedDate(java.util.Date acceptedDate)

getAcceptedBy

public java.lang.String getAcceptedBy()

setAcceptedBy

public void setAcceptedBy(java.lang.String acceptedBy)

getDateRequired

public java.util.Date getDateRequired()

setDateRequired

public void setDateRequired(java.util.Date dateRequired)

getDelayDays

public int getDelayDays()

setDelayDays

public void setDelayDays(int delayDays)

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getOriginal

public java.util.Date getOriginal()

setOriginal

public void setOriginal(java.util.Date original)

getActual

public java.util.Date getActual()

setActual

public void setActual(java.util.Date actual)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getDwg

public java.lang.String getDwg()

setDwg

public void setDwg(java.lang.String dwg)

getQuantityOrdered

public java.math.BigDecimal getQuantityOrdered()

setQuantityOrdered

public void setQuantityOrdered(java.math.BigDecimal quantityOrdered)

getSitQty

public java.math.BigDecimal getSitQty()

setSitQty

public void setSitQty(java.math.BigDecimal sitQty)

getQuantityShipped

public java.math.BigDecimal getQuantityShipped()

setQuantityShipped

public void setQuantityShipped(java.math.BigDecimal quantityShipped)

getQuantityReceived

public java.math.BigDecimal getQuantityReceived()

setQuantityReceived

public void setQuantityReceived(java.math.BigDecimal quantityReceived)

getHqa

public java.math.BigDecimal getHqa()

setHqa

public void setHqa(java.math.BigDecimal hqa)

getCostPerUnit

public java.math.BigDecimal getCostPerUnit()

setCostPerUnit

public void setCostPerUnit(java.math.BigDecimal costPerUnit)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getChangeMfg

public java.lang.String getChangeMfg()

setChangeMfg

public void setChangeMfg(java.lang.String changeMfg)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getItemComments

public java.lang.String getItemComments()

setItemComments

public void setItemComments(java.lang.String itemComments)

getItemPrivateNotes

public java.lang.String getItemPrivateNotes()

setItemPrivateNotes

public void setItemPrivateNotes(java.lang.String itemPrivateNotes)

getPurchaseOrderItemManufacturer

public java.util.Set getPurchaseOrderItemManufacturer()

getRefDocOnes

public java.util.Set getRefDocOnes()

getShippingStatus

public java.lang.String getShippingStatus()

setPurchaseOrderItemManufacturer

public void setPurchaseOrderItemManufacturer(java.util.Set purchaseOrderItemManufacturer)

setRefDocOnes

public void setRefDocOnes(java.util.Set refDocOnes)

getRefDocTwoes

public java.util.Set getRefDocTwoes()

setRefDocTwoes

public void setRefDocTwoes(java.util.Set refDocTwoes)

setShippingStatus

public void setShippingStatus(java.lang.String shippingStatus)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getArriveDate

public java.util.Date getArriveDate()

setArriveDate

public void setArriveDate(java.util.Date arriveDate)

getTraceable

public java.lang.String getTraceable()

setTraceable

public void setTraceable(java.lang.String traceable)

getTraceableLevel

public java.lang.Byte getTraceableLevel()

setTraceableLevel

public void setTraceableLevel(java.lang.Byte traceableLevel)

getPoUnit

public java.lang.String getPoUnit()

setPoUnit

public void setPoUnit(java.lang.String poUnit)

getPoUnitQty

public java.math.BigDecimal getPoUnitQty()

setPoUnitQty

public void setPoUnitQty(java.math.BigDecimal poUnitQty)

getPoUnitRate

public java.math.BigDecimal getPoUnitRate()

setPoUnitRate

public void setPoUnitRate(java.math.BigDecimal poUnitRate)

getCostPerUnitWithTax

public java.math.BigDecimal getCostPerUnitWithTax()

setCostPerUnitWithTax

public void setCostPerUnitWithTax(java.math.BigDecimal costPerUnitWithTax)

getProductCode

public java.lang.String getProductCode()

setProductCode

public void setProductCode(java.lang.String productCode)

isUsePriceWithTax

public boolean isUsePriceWithTax()

setUsePriceWithTax

public void setUsePriceWithTax(boolean usePriceWithTax)

getCommodityCode

public java.lang.String getCommodityCode()

setCommodityCode

public void setCommodityCode(java.lang.String commodityCode)

getLeadTime

public java.math.BigDecimal getLeadTime()

setLeadTime

public void setLeadTime(java.math.BigDecimal leadTime)

isIcrRequiredWhenReceiverNa

public boolean isIcrRequiredWhenReceiverNa()

setIcrRequiredWhenReceiverNa

public void setIcrRequiredWhenReceiverNa(boolean icrRequiredWhenReceiverNa)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PurchaseOrderListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PurchaseOrderListResult

java.lang.Object
    extended by  bb.common.PurchaseOrderListResult
All Implemented Interfaces:
java.io.Serializable
public class PurchaseOrderListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACKNOWLEDGEDATE
static java.lang.String | ORDER_BY_BUYERNAME
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_PODATE
static java.lang.String | ORDER_BY_PONUMBER
static java.lang.String | ORDER_BY_POSTATUS
static java.lang.String | ORDER_BY_PROJECT
static java.lang.String | ORDER_BY_RELATEDDOC
static java.lang.String | ORDER_BY_REQUESTER
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_VENDORNAME
Constructor Summary
PurchaseOrderListResult()
Method Summary
java.util.Date | getAcknowledgeDate()
java.math.BigDecimal | getApPrepay()
java.math.BigDecimal | getApPrepayGl()
java.lang.String | getBuyerName()
java.lang.String | getChangeOrder()
java.lang.String | getComments()
java.util.Date | getPoDate()
java.lang.String | getPoNumber()
java.lang.String | getPoStatus()
java.lang.String | getPrivateNotes()
java.lang.String | getProject()
java.lang.String | getRelatedDoc()
java.lang.String | getRequester()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
java.lang.String | getVendorSO()
void | setAcknowledgeDate(java.util.Date acknowledgeDate)
void | setApPrepay(java.math.BigDecimal apPrepay)
void | setApPrepayGl(java.math.BigDecimal apPrepayGl)
void | setBuyerName(java.lang.String buyerName)
void | setChangeOrder(java.lang.String changeOrder)
void | setComments(java.lang.String comments)
void | setPoDate(java.util.Date poDate)
void | setPoNumber(java.lang.String poNumber)
void | setPoStatus(java.lang.String poStatus)
void | setPrivateNotes(java.lang.String privateNotes)
void | setProject(java.lang.String project)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setRequester(java.lang.String requester)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
void | setVendorSO(java.lang.String vendorSO)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PONUMBER

public static final java.lang.String ORDER_BY_PONUMBER
See Also:
Constant Field Values

ORDER_BY_PODATE

public static final java.lang.String ORDER_BY_PODATE
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_BUYERNAME

public static final java.lang.String ORDER_BY_BUYERNAME
See Also:
Constant Field Values

ORDER_BY_POSTATUS

public static final java.lang.String ORDER_BY_POSTATUS
See Also:
Constant Field Values

ORDER_BY_VENDORNAME

public static final java.lang.String ORDER_BY_VENDORNAME
See Also:
Constant Field Values

ORDER_BY_REQUESTER

public static final java.lang.String ORDER_BY_REQUESTER
See Also:
Constant Field Values

ORDER_BY_PROJECT

public static final java.lang.String ORDER_BY_PROJECT
See Also:
Constant Field Values

ORDER_BY_RELATEDDOC

public static final java.lang.String ORDER_BY_RELATEDDOC
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values

ORDER_BY_ACKNOWLEDGEDATE

public static final java.lang.String ORDER_BY_ACKNOWLEDGEDATE
See Also:
Constant Field Values
Constructor Detail

PurchaseOrderListResult

public PurchaseOrderListResult()
Method Detail

getVendorSO

public java.lang.String getVendorSO()

setVendorSO

public void setVendorSO(java.lang.String vendorSO)

getPoStatus

public java.lang.String getPoStatus()

getComments

public java.lang.String getComments()

getProject

public java.lang.String getProject()

getBuyerName

public java.lang.String getBuyerName()

getVendorName

public java.lang.String getVendorName()

getVendorId

public java.lang.String getVendorId()

getPoDate

public java.util.Date getPoDate()

setPoNumber

public void setPoNumber(java.lang.String poNumber)

setPoStatus

public void setPoStatus(java.lang.String poStatus)

setComments

public void setComments(java.lang.String comments)

setProject

public void setProject(java.lang.String project)

setBuyerName

public void setBuyerName(java.lang.String buyerName)

setVendorName

public void setVendorName(java.lang.String vendorName)

setVendorId

public void setVendorId(java.lang.String vendorId)

setPoDate

public void setPoDate(java.util.Date poDate)

setRequester

public void setRequester(java.lang.String requester)

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getPoNumber

public java.lang.String getPoNumber()

getRequester

public java.lang.String getRequester()

getChangeOrder

public java.lang.String getChangeOrder()

getPrivateNotes

public java.lang.String getPrivateNotes()

setPrivateNotes

public void setPrivateNotes(java.lang.String privateNotes)

getAcknowledgeDate

public java.util.Date getAcknowledgeDate()

setAcknowledgeDate

public void setAcknowledgeDate(java.util.Date acknowledgeDate)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getApPrepay

public java.math.BigDecimal getApPrepay()

setApPrepay

public void setApPrepay(java.math.BigDecimal apPrepay)

getApPrepayGl

public java.math.BigDecimal getApPrepayGl()

setApPrepayGl

public void setApPrepayGl(java.math.BigDecimal apPrepayGl)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PurchaseOrderOnOrderResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PurchaseOrderOnOrderResult

java.lang.Object
    extended by  bb.common.PurchaseOrderOnOrderResult
All Implemented Interfaces:
java.io.Serializable
public class PurchaseOrderOnOrderResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PurchaseOrderOnOrderResult()
Method Summary
java.util.Date | getArriveDate()
int | getDelayDays()
java.util.Date | getDeliveryDate()
java.lang.String | getDescription()
java.lang.String | getNotes()
java.lang.String | getPartFrom()
PartPK | getPartPk()
PurchaseOrderItemPK | getPurchaseOrderItemPk()
java.math.BigDecimal | getQuantityOnOrder()
java.math.BigDecimal | getQuantityOrdered()
java.math.BigDecimal | getQuantityReceived()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.lang.String | getShipToId()
java.math.BigDecimal | getSitQty()
java.lang.String | getVendorId()
void | setArriveDate(java.util.Date arriveDate)
void | setDelayDays(int delayDays)
void | setDeliveryDate(java.util.Date deliveryDate)
void | setDescription(java.lang.String description)
void | setNotes(java.lang.String notes)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setPurchaseOrderItemPk(PurchaseOrderItemPK purchaseOrderPk)
void | setQuantityOnOrder(java.math.BigDecimal quantityOnOrder)
void | setQuantityOrdered(java.math.BigDecimal quantityOrdered)
void | setQuantityReceived(java.math.BigDecimal quantityReceived)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setShipToId(java.lang.String shipToId)
void | setSitQty(java.math.BigDecimal sitQty)
void | setVendorId(java.lang.String vendorId)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PurchaseOrderOnOrderResult

public PurchaseOrderOnOrderResult()
Method Detail

getPartPk

public PartPK getPartPk()

setPartPk

public void setPartPk(PartPK partPk)

getPurchaseOrderItemPk

public PurchaseOrderItemPK getPurchaseOrderItemPk()

setPurchaseOrderItemPk

public void setPurchaseOrderItemPk(PurchaseOrderItemPK purchaseOrderPk)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getQuantityOrdered

public java.math.BigDecimal getQuantityOrdered()

setQuantityOrdered

public void setQuantityOrdered(java.math.BigDecimal quantityOrdered)

getQuantityReceived

public java.math.BigDecimal getQuantityReceived()

setQuantityReceived

public void setQuantityReceived(java.math.BigDecimal quantityReceived)

getQuantityOnOrder

public java.math.BigDecimal getQuantityOnOrder()

setQuantityOnOrder

public void setQuantityOnOrder(java.math.BigDecimal quantityOnOrder)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getDeliveryDate

public java.util.Date getDeliveryDate()

setDeliveryDate

public void setDeliveryDate(java.util.Date deliveryDate)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getDelayDays

public int getDelayDays()

setDelayDays

public void setDelayDays(int delayDays)

getSitQty

public java.math.BigDecimal getSitQty()

setSitQty

public void setSitQty(java.math.BigDecimal sitQty)

getNotes

public java.lang.String getNotes()

setNotes

public void setNotes(java.lang.String notes)

getShipToId

public java.lang.String getShipToId()

setShipToId

public void setShipToId(java.lang.String shipToId)

getArriveDate

public java.util.Date getArriveDate()

setArriveDate

public void setArriveDate(java.util.Date arriveDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PurchaseOrderOnTimeItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PurchaseOrderOnTimeItemResult

java.lang.Object
    extended by  bb.common.PurchaseOrderOnTimeItemResult
All Implemented Interfaces:
java.io.Serializable
public class PurchaseOrderOnTimeItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | FISCAL_YEAR
static java.lang.String | MONTH_12_AVG
static java.lang.String | YEAR_TO_DATE
Constructor Summary
PurchaseOrderOnTimeItemResult()
Method Summary
java.math.BigDecimal | getDays()
java.lang.String | getMonth()
java.math.BigDecimal | getNotRecItemsOnTimeQty()
java.math.BigDecimal | getNotRecTotalOnTime()
int | getPurItemCount()
java.math.BigDecimal | getPurTotal()
int | getRecItemsOnTimeCount()
java.math.BigDecimal | getRecTotalOnTime()
void | setDays(java.math.BigDecimal days)
void | setMonth(java.lang.String month)
void | setNotRecItemsOnTimeQty(java.math.BigDecimal notRecItemsOnTimeQty)
void | setNotRecTotalOnTime(java.math.BigDecimal notRecTotalOnTime)
void | setPurItemCount(int purItemCount)
void | setPurTotal(java.math.BigDecimal purTotal)
void | setRecItemsOnTimeCount(int recItemsOnTimeCount)
void | setRecTotalOnTime(java.math.BigDecimal recTotalOnTime)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

FISCAL_YEAR

public static final java.lang.String FISCAL_YEAR
See Also:
Constant Field Values

YEAR_TO_DATE

public static final java.lang.String YEAR_TO_DATE
See Also:
Constant Field Values

MONTH_12_AVG

public static final java.lang.String MONTH_12_AVG
See Also:
Constant Field Values
Constructor Detail

PurchaseOrderOnTimeItemResult

public PurchaseOrderOnTimeItemResult()
Method Detail

getDays

public java.math.BigDecimal getDays()

setDays

public void setDays(java.math.BigDecimal days)

getMonth

public java.lang.String getMonth()

setMonth

public void setMonth(java.lang.String month)

getNotRecItemsOnTimeQty

public java.math.BigDecimal getNotRecItemsOnTimeQty()

setNotRecItemsOnTimeQty

public void setNotRecItemsOnTimeQty(java.math.BigDecimal notRecItemsOnTimeQty)

getNotRecTotalOnTime

public java.math.BigDecimal getNotRecTotalOnTime()

setNotRecTotalOnTime

public void setNotRecTotalOnTime(java.math.BigDecimal notRecTotalOnTime)

getPurItemCount

public int getPurItemCount()

setPurItemCount

public void setPurItemCount(int purItemCount)

getPurTotal

public java.math.BigDecimal getPurTotal()

setPurTotal

public void setPurTotal(java.math.BigDecimal purTotal)

getRecItemsOnTimeCount

public int getRecItemsOnTimeCount()

setRecItemsOnTimeCount

public void setRecItemsOnTimeCount(int recItemsOnTimeCount)

getRecTotalOnTime

public java.math.BigDecimal getRecTotalOnTime()

setRecTotalOnTime

public void setRecTotalOnTime(java.math.BigDecimal recTotalOnTime)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PurchaseOrderOnTimeResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PurchaseOrderOnTimeResult

java.lang.Object
    extended by  bb.common.PurchaseOrderOnTimeResult
All Implemented Interfaces:
java.io.Serializable
public class PurchaseOrderOnTimeResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PurchaseOrderOnTimeResult()
Method Summary
java.lang.String | getCurrency()
java.lang.Integer | getDuePOItemOf12MonthAvg()
java.lang.Integer | getDuePOItemOfFiscalYear()
java.lang.Integer | getDuePOItemOfLastMonth()
java.lang.Integer | getDuePOItemOfThisMonth()
java.lang.Integer | getDuePOItemOfYtd()
java.math.BigDecimal | getDuePOTotalof12MonthAvg()
java.math.BigDecimal | getDuePOTotalofFiscalYear()
java.math.BigDecimal | getDuePOTotalofLastMonth()
java.math.BigDecimal | getDuePOTotalofThisMonth()
java.math.BigDecimal | getDuePOTotalofYtd()
java.lang.Integer | getOntimeReceiverItemsof12MonthAvg()
java.lang.Integer | getOntimeReceiverItemsofFiscalYear()
java.lang.Integer | getOntimeReceiverItemsofLastMonth()
java.lang.Integer | getOntimeReceiverItemsofThisMonth()
java.lang.Integer | getOntimeReceiverItemsofYtd()
java.math.BigDecimal | getOntimeReceiverTotalOf12MonthAvg()
java.math.BigDecimal | getOntimeReceiverTotalOfFiscalYear()
java.math.BigDecimal | getOntimeReceiverTotalOfLastMonth()
java.math.BigDecimal | getOntimeReceiverTotalOfThisMonth()
java.math.BigDecimal | getOntimeReceiverTotalOfYtd()
void | setCurrency(java.lang.String currency)
void | setDuePOItemOf12MonthAvg(java.lang.Integer duePOItemOf12MonthAvg)
void | setDuePOItemOfFiscalYear(java.lang.Integer duePOItemOfFiscalYear)
void | setDuePOItemOfLastMonth(java.lang.Integer duePOItemOfLastMonth)
void | setDuePOItemOfThisMonth(java.lang.Integer duePOItemOfThisMonth)
void | setDuePOItemOfYtd(java.lang.Integer duePOItemOfYtd)
void | setDuePOTotalof12MonthAvg(java.math.BigDecimal duePOTotalof12MonthAvg)
void | setDuePOTotalofFiscalYear(java.math.BigDecimal duePOTotalofFiscalYear)
void | setDuePOTotalofLastMonth(java.math.BigDecimal duePOTotalofLastMonth)
void | setDuePOTotalofThisMonth(java.math.BigDecimal duePOTotalofThisMonth)
void | setDuePOTotalofYtd(java.math.BigDecimal duePOTotalofYtd)
void | setOntimeReceiverItemsof12MonthAvg(java.lang.Integer ontimeReceiverItemsof12MonthAvg)
void | setOntimeReceiverItemsofFiscalYear(java.lang.Integer ontimeReceiverItemsofFiscalYear)
void | setOntimeReceiverItemsofLastMonth(java.lang.Integer ontimeReceiverItemsofLastMonth)
void | setOntimeReceiverItemsofThisMonth(java.lang.Integer ontimeReceiverItemsofThisMonth)
void | setOntimeReceiverItemsofYtd(java.lang.Integer ontimeReceiverItemsofYtd)
void | setOntimeReceiverTotalOf12MonthAvg(java.math.BigDecimal ontimeReceiverTotalOf12MonthAvg)
void | setOntimeReceiverTotalOfFiscalYear(java.math.BigDecimal ontimeReceiverTotalOfFiscalYear)
void | setOntimeReceiverTotalOfLastMonth(java.math.BigDecimal ontimeReceiverTotalOfLastMonth)
void | setOntimeReceiverTotalOfThisMonth(java.math.BigDecimal ontimeReceiverTotalOfThisMonth)
void | setOntimeReceiverTotalOfYtd(java.math.BigDecimal ontimeReceiverTotalOfYtd)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PurchaseOrderOnTimeResult

public PurchaseOrderOnTimeResult()
Method Detail

setCurrency

public void setCurrency(java.lang.String currency)

setDuePOTotalofThisMonth

public void setDuePOTotalofThisMonth(java.math.BigDecimal duePOTotalofThisMonth)

setOntimeReceiverItemsofThisMonth

public void setOntimeReceiverItemsofThisMonth(java.lang.Integer ontimeReceiverItemsofThisMonth)

setDuePOTotalofLastMonth

public void setDuePOTotalofLastMonth(java.math.BigDecimal duePOTotalofLastMonth)

setDuePOTotalofFiscalYear

public void setDuePOTotalofFiscalYear(java.math.BigDecimal duePOTotalofFiscalYear)

setDuePOTotalofYtd

public void setDuePOTotalofYtd(java.math.BigDecimal duePOTotalofYtd)

setDuePOTotalof12MonthAvg

public void setDuePOTotalof12MonthAvg(java.math.BigDecimal duePOTotalof12MonthAvg)

setOntimeReceiverItemsofLastMonth

public void setOntimeReceiverItemsofLastMonth(java.lang.Integer ontimeReceiverItemsofLastMonth)

setOntimeReceiverItemsofFiscalYear

public void setOntimeReceiverItemsofFiscalYear(java.lang.Integer ontimeReceiverItemsofFiscalYear)

setOntimeReceiverItemsofYtd

public void setOntimeReceiverItemsofYtd(java.lang.Integer ontimeReceiverItemsofYtd)

setOntimeReceiverItemsof12MonthAvg

public void setOntimeReceiverItemsof12MonthAvg(java.lang.Integer ontimeReceiverItemsof12MonthAvg)

setDuePOItemOfThisMonth

public void setDuePOItemOfThisMonth(java.lang.Integer duePOItemOfThisMonth)

setDuePOItemOfLastMonth

public void setDuePOItemOfLastMonth(java.lang.Integer duePOItemOfLastMonth)

setDuePOItemOfFiscalYear

public void setDuePOItemOfFiscalYear(java.lang.Integer duePOItemOfFiscalYear)

setDuePOItemOfYtd

public void setDuePOItemOfYtd(java.lang.Integer duePOItemOfYtd)

setDuePOItemOf12MonthAvg

public void setDuePOItemOf12MonthAvg(java.lang.Integer duePOItemOf12MonthAvg)

setOntimeReceiverTotalOfThisMonth

public void setOntimeReceiverTotalOfThisMonth(java.math.BigDecimal ontimeReceiverTotalOfThisMonth)

setOntimeReceiverTotalOfLastMonth

public void setOntimeReceiverTotalOfLastMonth(java.math.BigDecimal ontimeReceiverTotalOfLastMonth)

setOntimeReceiverTotalOfFiscalYear

public void setOntimeReceiverTotalOfFiscalYear(java.math.BigDecimal ontimeReceiverTotalOfFiscalYear)

setOntimeReceiverTotalOfYtd

public void setOntimeReceiverTotalOfYtd(java.math.BigDecimal ontimeReceiverTotalOfYtd)

setOntimeReceiverTotalOf12MonthAvg

public void setOntimeReceiverTotalOf12MonthAvg(java.math.BigDecimal ontimeReceiverTotalOf12MonthAvg)

getCurrency

public java.lang.String getCurrency()

getDuePOTotalofThisMonth

public java.math.BigDecimal getDuePOTotalofThisMonth()

getOntimeReceiverItemsofThisMonth

public java.lang.Integer getOntimeReceiverItemsofThisMonth()

getDuePOTotalofLastMonth

public java.math.BigDecimal getDuePOTotalofLastMonth()

getDuePOTotalofFiscalYear

public java.math.BigDecimal getDuePOTotalofFiscalYear()

getDuePOTotalofYtd

public java.math.BigDecimal getDuePOTotalofYtd()

getDuePOTotalof12MonthAvg

public java.math.BigDecimal getDuePOTotalof12MonthAvg()

getOntimeReceiverItemsofLastMonth

public java.lang.Integer getOntimeReceiverItemsofLastMonth()

getOntimeReceiverItemsofFiscalYear

public java.lang.Integer getOntimeReceiverItemsofFiscalYear()

getOntimeReceiverItemsofYtd

public java.lang.Integer getOntimeReceiverItemsofYtd()

getOntimeReceiverItemsof12MonthAvg

public java.lang.Integer getOntimeReceiverItemsof12MonthAvg()

getDuePOItemOfThisMonth

public java.lang.Integer getDuePOItemOfThisMonth()

getDuePOItemOfLastMonth

public java.lang.Integer getDuePOItemOfLastMonth()

getDuePOItemOfFiscalYear

public java.lang.Integer getDuePOItemOfFiscalYear()

getDuePOItemOfYtd

public java.lang.Integer getDuePOItemOfYtd()

getDuePOItemOf12MonthAvg

public java.lang.Integer getDuePOItemOf12MonthAvg()

getOntimeReceiverTotalOfThisMonth

public java.math.BigDecimal getOntimeReceiverTotalOfThisMonth()

getOntimeReceiverTotalOfLastMonth

public java.math.BigDecimal getOntimeReceiverTotalOfLastMonth()

getOntimeReceiverTotalOfFiscalYear

public java.math.BigDecimal getOntimeReceiverTotalOfFiscalYear()

getOntimeReceiverTotalOfYtd

public java.math.BigDecimal getOntimeReceiverTotalOfYtd()

getOntimeReceiverTotalOf12MonthAvg

public java.math.BigDecimal getOntimeReceiverTotalOf12MonthAvg()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PurchaseOrderOpenDueListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PurchaseOrderOpenDueListResult

java.lang.Object
    extended by  bb.common.PurchaseOrderOpenDueListResult
All Implemented Interfaces:
java.io.Serializable
public class PurchaseOrderOpenDueListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_BUYER
static java.lang.String | ORDER_BY_DELEVERYDATE
static java.lang.String | ORDER_BY_DUEDATE
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_PODATE
static java.lang.String | ORDER_BY_PONUMBER
static java.lang.String | ORDER_BY_SHIPPINGSTATUS
static java.lang.String | ORDER_BY_SHIPVIA
static java.lang.String | ORDER_BY_VENDORID
Constructor Summary
PurchaseOrderOpenDueListResult()
Method Summary
java.lang.String | getBuyer()
int | getDelayDays()
java.util.Date | getDeleveryDate()
java.util.Date | getDueDate()
java.math.BigDecimal | getOnDemandQty()
java.math.BigDecimal | getOnhandQty()
java.math.BigDecimal | getOnOrderQty()
BB2Part | getPartPk()
java.util.Date | getPoDate()
java.lang.String | getPoItemDescription()
java.lang.String | getPoItemNumber()
java.lang.String | getPoNumber()
java.math.BigDecimal | getPoQty()
java.math.BigDecimal | getQuantityReceived()
java.lang.String | getShippingStatus()
java.lang.String | getShipVia()
java.lang.String | getVendorId()
java.math.BigDecimal | getYearUsage()
void | setBuyer(java.lang.String buyer)
void | setDelayDays(int delayDays)
void | setDeleveryDate(java.util.Date deleveryDate)
void | setDueDate(java.util.Date dueDate)
void | setOnDemandQty(java.math.BigDecimal onDemandQty)
void | setOnhandQty(java.math.BigDecimal onhandQty)
void | setOnOrderQty(java.math.BigDecimal onOrderQty)
void | setPartPk(BB2Part partPk)
void | setPoDate(java.util.Date poDate)
void | setPoItemDescription(java.lang.String poItemDescription)
void | setPoItemNumber(java.lang.String poItemNumber)
void | setPoNumber(java.lang.String poNumber)
void | setPoQty(java.math.BigDecimal poQty)
void | setQuantityReceived(java.math.BigDecimal quantityReceived)
void | setShippingStatus(java.lang.String shippingStatus)
void | setShipVia(java.lang.String shipVia)
void | setVendorId(java.lang.String vendorId)
void | setYearUsage(java.math.BigDecimal yearUsage)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PONUMBER

public static final java.lang.String ORDER_BY_PONUMBER
See Also:
Constant Field Values

ORDER_BY_PODATE

public static final java.lang.String ORDER_BY_PODATE
See Also:
Constant Field Values

ORDER_BY_DUEDATE

public static final java.lang.String ORDER_BY_DUEDATE
See Also:
Constant Field Values

ORDER_BY_DELEVERYDATE

public static final java.lang.String ORDER_BY_DELEVERYDATE
See Also:
Constant Field Values

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_SHIPPINGSTATUS

public static final java.lang.String ORDER_BY_SHIPPINGSTATUS
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_BUYER

public static final java.lang.String ORDER_BY_BUYER
See Also:
Constant Field Values

ORDER_BY_SHIPVIA

public static final java.lang.String ORDER_BY_SHIPVIA
See Also:
Constant Field Values
Constructor Detail

PurchaseOrderOpenDueListResult

public PurchaseOrderOpenDueListResult()
Method Detail

getBuyer

public java.lang.String getBuyer()

setBuyer

public void setBuyer(java.lang.String buyer)

getVendorId

public java.lang.String getVendorId()

getQuantityReceived

public java.math.BigDecimal getQuantityReceived()

getPoQty

public java.math.BigDecimal getPoQty()

getPoItemDescription

public java.lang.String getPoItemDescription()

getDueDate

public java.util.Date getDueDate()

getPoDate

public java.util.Date getPoDate()

getPartPk

public BB2Part getPartPk()

getPoItemNumber

public java.lang.String getPoItemNumber()

setPoNumber

public void setPoNumber(java.lang.String poNumber)

setVendorId

public void setVendorId(java.lang.String vendorId)

setQuantityReceived

public void setQuantityReceived(java.math.BigDecimal quantityReceived)

setPoQty

public void setPoQty(java.math.BigDecimal poQty)

setPoItemDescription

public void setPoItemDescription(java.lang.String poItemDescription)

setDueDate

public void setDueDate(java.util.Date dueDate)

setPoDate

public void setPoDate(java.util.Date poDate)

setPartPk

public void setPartPk(BB2Part partPk)

setPoItemNumber

public void setPoItemNumber(java.lang.String poItemNumber)

setOnOrderQty

public void setOnOrderQty(java.math.BigDecimal onOrderQty)

setOnhandQty

public void setOnhandQty(java.math.BigDecimal onhandQty)

setOnDemandQty

public void setOnDemandQty(java.math.BigDecimal onDemandQty)

setShippingStatus

public void setShippingStatus(java.lang.String shippingStatus)

setShipVia

public void setShipVia(java.lang.String shipVia)

getPoNumber

public java.lang.String getPoNumber()

getOnOrderQty

public java.math.BigDecimal getOnOrderQty()

getOnhandQty

public java.math.BigDecimal getOnhandQty()

getOnDemandQty

public java.math.BigDecimal getOnDemandQty()

getShippingStatus

public java.lang.String getShippingStatus()

getShipVia

public java.lang.String getShipVia()

getDeleveryDate

public java.util.Date getDeleveryDate()

setDeleveryDate

public void setDeleveryDate(java.util.Date deleveryDate)

getDelayDays

public int getDelayDays()

setDelayDays

public void setDelayDays(int delayDays)

getYearUsage

public java.math.BigDecimal getYearUsage()

setYearUsage

public void setYearUsage(java.math.BigDecimal yearUsage)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PurchaseOrderVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PurchaseOrderVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PurchaseOrderVO
All Implemented Interfaces:
java.io.Serializable
public class PurchaseOrderVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PurchaseOrderVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAcknowledgeDate()
java.util.Date | getActual()
java.util.Date | getAdate()
java.math.BigDecimal | getApGl1Recorded()
java.math.BigDecimal | getApGl2Paid()
java.math.BigDecimal | getApNet()
java.lang.String | getApNetSet()
java.math.BigDecimal | getApOpen()
java.math.BigDecimal | getApPaidGl()
java.math.BigDecimal | getApPaidReceived()
java.lang.String | getAppNumber()
java.math.BigDecimal | getApPrepay()
java.math.BigDecimal | getApPrepayApply()
java.math.BigDecimal | getApPrepayDue()
java.math.BigDecimal | getApPrepayGl()
java.lang.String | getApprovedBy()
java.util.Date | getApprovedDate()
java.math.BigDecimal | getApReceived()
java.lang.String | getApTaxSet()
CustomerVendorAddressInfoVO | getBillToAddressInfo()
java.lang.String | getBillToId()
java.util.Set | getBoilerplates()
java.lang.String | getBp()
java.math.BigDecimal | getBudgetAmount()
java.lang.String | getBuyer()
java.lang.String | getBuyerGroup()
java.lang.String | getCarrier()
java.lang.String | getCarrierAccount()
java.lang.String | getChangeOrder()
java.lang.String | getCoComments()
java.lang.String | getCompanyUnitId()
java.lang.String | getContact()
java.util.Date | getContractDate()
java.lang.String | getCurrency()
java.util.Date | getDateRequired()
java.lang.String | getDebitAccount()
byte | getDelayDays()
java.math.BigDecimal | getExchange()
java.math.BigDecimal | getGrantTotal()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
int | getLastChangeTimes()
java.lang.String | getLastChangeUser()
java.lang.String | getLocate()
java.lang.String | getOrigin()
java.util.Date | getOriginal()
java.lang.String | getPoBoilerplate()
java.util.Date | getPoDate()
java.lang.String | getPoRequestionNumber()
java.lang.String | getPoType()
java.lang.String | getPriority()
java.lang.String | getProjectName()
java.lang.String | getPurchaseMethod()
java.lang.String | getPurchaseOrderComments()
java.util.Set | getPurchaseOrderDocuments()
java.util.Set<PurchaseOrderItemVO> | getPurchaseOrderItem()
java.lang.String | getPurchaseOrderNumber()
java.lang.String | getPurchaseOrderPrivateNotes()
java.lang.String | getRelatedDoc()
java.lang.String | getRequester()
java.lang.String | getSalesOrderNumber()
java.lang.String | getShippingStatus()
CustomerVendorAddressInfoVO | getShipToAddressInfo()
java.lang.String | getShipToId()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.util.Date | getSubmitDate()
java.math.BigDecimal | getSubTotal()
java.lang.String | getTerms()
java.math.BigDecimal | getTotalDiscount()
java.math.BigDecimal | getTotalFreight()
java.math.BigDecimal | getTotalTax()
java.lang.String | getVendorAcknowledge()
CustomerVendorAddressInfoVO | getVendorAddressInfo()
java.lang.String | getVendorId()
java.lang.String | getVendorSalesOrder()
int | hashCode()
boolean | isHold()
void | setAcknowledgeDate(java.util.Date acknowledgeDate)
void | setActual(java.util.Date actual)
void | setAdate(java.util.Date adate)
void | setApGl1Recorded(java.math.BigDecimal apGl1Recorded)
void | setApGl2Paid(java.math.BigDecimal apGl2Paid)
void | setApNet(java.math.BigDecimal apNet)
void | setApNetSet(java.lang.String apNetSet)
void | setApOpen(java.math.BigDecimal apOpen)
void | setApPaidGl(java.math.BigDecimal apPaidGl)
void | setApPaidReceived(java.math.BigDecimal apPaidReceived)
void | setAppNumber(java.lang.String appNumber)
void | setApPrepay(java.math.BigDecimal apPrepay)
void | setApPrepayApply(java.math.BigDecimal apPrepayApply)
void | setApPrepayDue(java.math.BigDecimal apPrepayDue)
void | setApPrepayGl(java.math.BigDecimal apPrepayGl)
void | setApprovedBy(java.lang.String approvedBy)
void | setApprovedDate(java.util.Date approvedDate)
void | setApReceived(java.math.BigDecimal apReceived)
void | setApTaxSet(java.lang.String apTaxSet)
void | setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | setBillToId(java.lang.String billToId)
void | setBoilerplates(java.util.Set boilerplates)
void | setBp(java.lang.String bp)
void | setBudgetAmount(java.math.BigDecimal budgetAmount)
void | setBuyer(java.lang.String buyer)
void | setBuyerGroup(java.lang.String buyerGroup)
void | setCarrier(java.lang.String carrier)
void | setCarrierAccount(java.lang.String carrierAccount)
void | setChangeOrder(java.lang.String changeOrder)
void | setCoComments(java.lang.String coComments)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setContact(java.lang.String contact)
void | setContractDate(java.util.Date contractDate)
void | setCurrency(java.lang.String currency)
void | setDateRequired(java.util.Date dateRequired)
void | setDebitAccount(java.lang.String debitAccount)
void | setDelayDays(byte delayDays)
void | setExchange(java.math.BigDecimal exchange)
void | setGrantTotal(java.math.BigDecimal grantTotal)
void | setHold(boolean hold)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTimes(int lastChangeTimes)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLocate(java.lang.String locate)
void | setOrigin(java.lang.String origin)
void | setOriginal(java.util.Date original)
void | setPoBoilerplate(java.lang.String poBoilerplate)
void | setPoDate(java.util.Date poDate)
void | setPoRequestionNumber(java.lang.String poRequestionNumber)
void | setPoType(java.lang.String poType)
void | setPriority(java.lang.String priority)
void | setProjectName(java.lang.String projectName)
void | setPurchaseMethod(java.lang.String purchaseMethod)
void | setPurchaseOrderComments(java.lang.String purchaseOrderComments)
void | setPurchaseOrderDocuments(java.util.Set purchaseOrderDocuments)
void | setPurchaseOrderItem(java.util.Set<PurchaseOrderItemVO> purchaseOrderItem)
void | setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)
void | setPurchaseOrderPrivateNotes(java.lang.String purchaseOrderPrivateNotes)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setRequester(java.lang.String requester)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setShippingStatus(java.lang.String shippingStatus)
void | setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | setShipToId(java.lang.String shipToId)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setSubmitDate(java.util.Date submitDate)
void | setSubTotal(java.math.BigDecimal subTotal)
void | setTerms(java.lang.String terms)
void | setTotalDiscount(java.math.BigDecimal totalDiscount)
void | setTotalFreight(java.math.BigDecimal totalFreight)
void | setTotalTax(java.math.BigDecimal totalTax)
void | setVendorAcknowledge(java.lang.String vendorAcknowledge)
void | setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)
void | setVendorId(java.lang.String vendorId)
void | setVendorSalesOrder(java.lang.String vendorSalesOrder)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PurchaseOrderVO

public PurchaseOrderVO()
Method Detail

getPurchaseOrderNumber

public java.lang.String getPurchaseOrderNumber()

setPurchaseOrderNumber

public void setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getApNetSet

public java.lang.String getApNetSet()

setApNetSet

public void setApNetSet(java.lang.String apNetSet)

getApTaxSet

public java.lang.String getApTaxSet()

setApTaxSet

public void setApTaxSet(java.lang.String apTaxSet)

getSubTotal

public java.math.BigDecimal getSubTotal()

setSubTotal

public void setSubTotal(java.math.BigDecimal subTotal)

getTotalDiscount

public java.math.BigDecimal getTotalDiscount()

setTotalDiscount

public void setTotalDiscount(java.math.BigDecimal totalDiscount)

getApNet

public java.math.BigDecimal getApNet()

setApNet

public void setApNet(java.math.BigDecimal apNet)

getApReceived

public java.math.BigDecimal getApReceived()

setApReceived

public void setApReceived(java.math.BigDecimal apReceived)

getApOpen

public java.math.BigDecimal getApOpen()

setApOpen

public void setApOpen(java.math.BigDecimal apOpen)

getTotalTax

public java.math.BigDecimal getTotalTax()

setTotalTax

public void setTotalTax(java.math.BigDecimal totalTax)

getTotalFreight

public java.math.BigDecimal getTotalFreight()

setTotalFreight

public void setTotalFreight(java.math.BigDecimal totalFreight)

getGrantTotal

public java.math.BigDecimal getGrantTotal()

setGrantTotal

public void setGrantTotal(java.math.BigDecimal grantTotal)

getApPaidReceived

public java.math.BigDecimal getApPaidReceived()

setApPaidReceived

public void setApPaidReceived(java.math.BigDecimal apPaidReceived)

getApPaidGl

public java.math.BigDecimal getApPaidGl()

setApPaidGl

public void setApPaidGl(java.math.BigDecimal apPaidGl)

getApGl1Recorded

public java.math.BigDecimal getApGl1Recorded()

setApGl1Recorded

public void setApGl1Recorded(java.math.BigDecimal apGl1Recorded)

getApGl2Paid

public java.math.BigDecimal getApGl2Paid()

setApGl2Paid

public void setApGl2Paid(java.math.BigDecimal apGl2Paid)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getBillToId

public java.lang.String getBillToId()

setBillToId

public void setBillToId(java.lang.String billToId)

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getApprovedDate

public java.util.Date getApprovedDate()

setApprovedDate

public void setApprovedDate(java.util.Date approvedDate)

getApprovedBy

public java.lang.String getApprovedBy()

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)

getDateRequired

public java.util.Date getDateRequired()

setDateRequired

public void setDateRequired(java.util.Date dateRequired)

getDelayDays

public byte getDelayDays()

setDelayDays

public void setDelayDays(byte delayDays)

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getOriginal

public java.util.Date getOriginal()

setOriginal

public void setOriginal(java.util.Date original)

getActual

public java.util.Date getActual()

setActual

public void setActual(java.util.Date actual)

getShipToId

public java.lang.String getShipToId()

setShipToId

public void setShipToId(java.lang.String shipToId)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAccount

public java.lang.String getCarrierAccount()

setCarrierAccount

public void setCarrierAccount(java.lang.String carrierAccount)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getPoDate

public java.util.Date getPoDate()

setPoDate

public void setPoDate(java.util.Date poDate)

getBuyer

public java.lang.String getBuyer()

setBuyer

public void setBuyer(java.lang.String buyer)

getBuyerGroup

public java.lang.String getBuyerGroup()

setBuyerGroup

public void setBuyerGroup(java.lang.String buyerGroup)

getRequester

public java.lang.String getRequester()

setRequester

public void setRequester(java.lang.String requester)

getProjectName

public java.lang.String getProjectName()

setProjectName

public void setProjectName(java.lang.String projectName)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getDebitAccount

public java.lang.String getDebitAccount()

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

getBp

public java.lang.String getBp()

setBp

public void setBp(java.lang.String bp)

getPurchaseOrderComments

public java.lang.String getPurchaseOrderComments()

setPurchaseOrderComments

public void setPurchaseOrderComments(java.lang.String purchaseOrderComments)

getPurchaseOrderPrivateNotes

public java.lang.String getPurchaseOrderPrivateNotes()

setPurchaseOrderPrivateNotes

public void setPurchaseOrderPrivateNotes(java.lang.String purchaseOrderPrivateNotes)

getLastChangeTimes

public int getLastChangeTimes()

setLastChangeTimes

public void setLastChangeTimes(int lastChangeTimes)

getVendorAddressInfo

public CustomerVendorAddressInfoVO getVendorAddressInfo()

setVendorAddressInfo

public void setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)

getShipToAddressInfo

public CustomerVendorAddressInfoVO getShipToAddressInfo()

setShipToAddressInfo

public void setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)

getBillToAddressInfo

public CustomerVendorAddressInfoVO getBillToAddressInfo()

setBillToAddressInfo

public void setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)

getPurchaseOrderItem

public java.util.Set<PurchaseOrderItemVO> getPurchaseOrderItem()

getShippingStatus

public java.lang.String getShippingStatus()

getPoBoilerplate

public java.lang.String getPoBoilerplate()

getAcknowledgeDate

public java.util.Date getAcknowledgeDate()

getBoilerplates

public java.util.Set getBoilerplates()

getCoComments

public java.lang.String getCoComments()

setPurchaseOrderItem

public void setPurchaseOrderItem(java.util.Set<PurchaseOrderItemVO> purchaseOrderItem)

setShippingStatus

public void setShippingStatus(java.lang.String shippingStatus)

setPoBoilerplate

public void setPoBoilerplate(java.lang.String poBoilerplate)

setAcknowledgeDate

public void setAcknowledgeDate(java.util.Date acknowledgeDate)

setBoilerplates

public void setBoilerplates(java.util.Set boilerplates)

setCoComments

public void setCoComments(java.lang.String coComments)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getExchange

public java.math.BigDecimal getExchange()

setExchange

public void setExchange(java.math.BigDecimal exchange)

getVendorSalesOrder

public java.lang.String getVendorSalesOrder()

setVendorSalesOrder

public void setVendorSalesOrder(java.lang.String vendorSalesOrder)

getPurchaseOrderDocuments

public java.util.Set getPurchaseOrderDocuments()

setPurchaseOrderDocuments

public void setPurchaseOrderDocuments(java.util.Set purchaseOrderDocuments)

getVendorAcknowledge

public java.lang.String getVendorAcknowledge()

setVendorAcknowledge

public void setVendorAcknowledge(java.lang.String vendorAcknowledge)

getApPrepay

public java.math.BigDecimal getApPrepay()

setApPrepay

public void setApPrepay(java.math.BigDecimal apPrepay)

getApPrepayGl

public java.math.BigDecimal getApPrepayGl()

setApPrepayGl

public void setApPrepayGl(java.math.BigDecimal apPrepayGl)

getAppNumber

public java.lang.String getAppNumber()

setAppNumber

public void setAppNumber(java.lang.String appNumber)

getApPrepayDue

public java.math.BigDecimal getApPrepayDue()

setApPrepayDue

public void setApPrepayDue(java.math.BigDecimal apPrepayDue)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getApPrepayApply

public java.math.BigDecimal getApPrepayApply()

setApPrepayApply

public void setApPrepayApply(java.math.BigDecimal apPrepayApply)

getContractDate

public java.util.Date getContractDate()

setContractDate

public void setContractDate(java.util.Date contractDate)

isHold

public boolean isHold()

setHold

public void setHold(boolean hold)

getPoRequestionNumber

public java.lang.String getPoRequestionNumber()

setPoRequestionNumber

public void setPoRequestionNumber(java.lang.String poRequestionNumber)

getBudgetAmount

public java.math.BigDecimal getBudgetAmount()

setBudgetAmount

public void setBudgetAmount(java.math.BigDecimal budgetAmount)

getPurchaseMethod

public java.lang.String getPurchaseMethod()

setPurchaseMethod

public void setPurchaseMethod(java.lang.String purchaseMethod)

getSubmitDate

public java.util.Date getSubmitDate()

setSubmitDate

public void setSubmitDate(java.util.Date submitDate)

getPoType

public java.lang.String getPoType()

setPoType

public void setPoType(java.lang.String poType)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PurchaseWorkSheetItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PurchaseWorkSheetItemPK

java.lang.Object
    extended by  bb.common.PurchaseWorkSheetItemPK
All Implemented Interfaces:
java.io.Serializable
public class PurchaseWorkSheetItemPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PurchaseWorkSheetItemPK()
default constructor
PurchaseWorkSheetItemPK(java.lang.String employeeId, java.lang.String cartType, java.lang.Integer workSheetNumber, java.lang.Integer itemNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCartType()
java.lang.String | getEmployeeId()
java.lang.Integer | getItemNumber()
java.lang.Integer | getWorkSheetNumber()
int | hashCode()
void | setCartType(java.lang.String cartType)
void | setEmployeeId(java.lang.String employeeId)
void | setItemNumber(java.lang.Integer itemNumber)
void | setWorkSheetNumber(java.lang.Integer workSheetNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PurchaseWorkSheetItemPK

public PurchaseWorkSheetItemPK(java.lang.String employeeId,
                               java.lang.String cartType,
                               java.lang.Integer workSheetNumber,
                               java.lang.Integer itemNumber)
full constructor

PurchaseWorkSheetItemPK

public PurchaseWorkSheetItemPK()
default constructor

Method Detail

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getCartType

public java.lang.String getCartType()

setCartType

public void setCartType(java.lang.String cartType)

getWorkSheetNumber

public java.lang.Integer getWorkSheetNumber()

setWorkSheetNumber

public void setWorkSheetNumber(java.lang.Integer workSheetNumber)

getItemNumber

public java.lang.Integer getItemNumber()

setItemNumber

public void setItemNumber(java.lang.Integer itemNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PurchaseWorkSheetItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PurchaseWorkSheetItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PurchaseWorkSheetItemVO
All Implemented Interfaces:
java.io.Serializable
public class PurchaseWorkSheetItemVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PurchaseWorkSheetItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.util.Date | getDelivery()
java.lang.String | getItemNotes()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getMakePo()
java.lang.String | getMakeRfq()
short | getMfgId()
java.lang.String | getMfgIds()
java.math.BigDecimal | getMonthQty()
java.lang.Integer | getMonths()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
PurchaseWorkSheetItemPK | getPk()
java.util.Map | getPurchaseRefdoc()
java.math.BigDecimal | getQuantity()
java.util.Map | getRefdoc()
java.lang.String | getRfqIds()
java.lang.String | getRfqIdWritein()
java.lang.Byte | getVendId()
java.lang.String | getVendIdWritein()
int | hashCode()
void | setComments(java.lang.String comments)
void | setDelivery(java.util.Date delivery)
void | setItemNotes(java.lang.String itemNotes)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setMakePo(java.lang.String makePo)
void | setMakeRfq(java.lang.String makeRfq)
void | setMfgId(short mfgId)
void | setMfgIds(java.lang.String mfgIds)
void | setMonthQty(java.math.BigDecimal monthQty)
void | setMonths(java.lang.Integer months)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(PurchaseWorkSheetItemPK pk)
void | setPurchaseRefdoc(java.util.Map purchaseRefdoc)
void | setQuantity(java.math.BigDecimal quantity)
void | setRefdoc(java.util.Map refdoc)
void | setRfqIds(java.lang.String rfqIds)
void | setRfqIdWritein(java.lang.String rfqIdWritein)
void | setVendId(java.lang.Byte vendId)
void | setVendIdWritein(java.lang.String vendIdWritein)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PurchaseWorkSheetItemVO

public PurchaseWorkSheetItemVO()
Method Detail

getPk

public PurchaseWorkSheetItemPK getPk()

setPk

public void setPk(PurchaseWorkSheetItemPK pk)

getMakePo

public java.lang.String getMakePo()

setMakePo

public void setMakePo(java.lang.String makePo)

getMakeRfq

public java.lang.String getMakeRfq()

setMakeRfq

public void setMakeRfq(java.lang.String makeRfq)

getRfqIds

public java.lang.String getRfqIds()

setRfqIds

public void setRfqIds(java.lang.String rfqIds)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getItemNotes

public java.lang.String getItemNotes()

setItemNotes

public void setItemNotes(java.lang.String itemNotes)

getVendId

public java.lang.Byte getVendId()

setVendId

public void setVendId(java.lang.Byte vendId)

getMfgId

public short getMfgId()

setMfgId

public void setMfgId(short mfgId)

getMfgIds

public java.lang.String getMfgIds()

setMfgIds

public void setMfgIds(java.lang.String mfgIds)

getVendIdWritein

public java.lang.String getVendIdWritein()

setVendIdWritein

public void setVendIdWritein(java.lang.String vendIdWritein)

getRfqIdWritein

public java.lang.String getRfqIdWritein()

getDelivery

public java.util.Date getDelivery()

getMonthQty

public java.math.BigDecimal getMonthQty()

getMonths

public java.lang.Integer getMonths()

setRfqIdWritein

public void setRfqIdWritein(java.lang.String rfqIdWritein)

setDelivery

public void setDelivery(java.util.Date delivery)

setMonthQty

public void setMonthQty(java.math.BigDecimal monthQty)

setMonths

public void setMonths(java.lang.Integer months)

getRefdoc

public java.util.Map getRefdoc()

setRefdoc

public void setRefdoc(java.util.Map refdoc)

getPurchaseRefdoc

public java.util.Map getPurchaseRefdoc()

setPurchaseRefdoc

public void setPurchaseRefdoc(java.util.Map purchaseRefdoc)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PurchaseWorkSheetItemWithRelatedInfoResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PurchaseWorkSheetItemWithRelatedInfoResult

java.lang.Object
    extended by  bb.common.PurchaseWorkSheetItemWithRelatedInfoResult
All Implemented Interfaces:
java.io.Serializable
public class PurchaseWorkSheetItemWithRelatedInfoResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PurchaseWorkSheetItemWithRelatedInfoResult()
Method Summary
PartBasicInfo | getPartBasicInfo()
PartInventoryVO | getPartInventoryVO()
java.util.List | getPartManufacturers()
java.util.List | getPartVendors()
ToolBasicInfo | getToolBasicInfo()
ToolInventoryVO | getToolInventoryVO()
PurchaseWorkSheetItemVO | getWorkSheetItem()
void | setPartBasicInfo(PartBasicInfo partBasicInfo)
void | setPartInventoryVO(PartInventoryVO partInventoryVO)
void | setPartManufacturers(java.util.List partManufacturers)
void | setPartVendors(java.util.List partVendors)
void | setToolBasicInfo(ToolBasicInfo toolBasicInfo)
void | setToolInventoryVO(ToolInventoryVO toolInventoryVO)
void | setWorkSheetItem(PurchaseWorkSheetItemVO workSheetItem)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PurchaseWorkSheetItemWithRelatedInfoResult

public PurchaseWorkSheetItemWithRelatedInfoResult()
Method Detail

getPartBasicInfo

public PartBasicInfo getPartBasicInfo()

setPartBasicInfo

public void setPartBasicInfo(PartBasicInfo partBasicInfo)

getPartInventoryVO

public PartInventoryVO getPartInventoryVO()

setPartInventoryVO

public void setPartInventoryVO(PartInventoryVO partInventoryVO)

getPartVendors

public java.util.List getPartVendors()

setPartVendors

public void setPartVendors(java.util.List partVendors)

getPartManufacturers

public java.util.List getPartManufacturers()

getToolBasicInfo

public ToolBasicInfo getToolBasicInfo()

getToolInventoryVO

public ToolInventoryVO getToolInventoryVO()

getWorkSheetItem

public PurchaseWorkSheetItemVO getWorkSheetItem()

setPartManufacturers

public void setPartManufacturers(java.util.List partManufacturers)

setToolBasicInfo

public void setToolBasicInfo(ToolBasicInfo toolBasicInfo)

setToolInventoryVO

public void setToolInventoryVO(ToolInventoryVO toolInventoryVO)

setWorkSheetItem

public void setWorkSheetItem(PurchaseWorkSheetItemVO workSheetItem)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PurchaseWorkSheetPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PurchaseWorkSheetPK

java.lang.Object
    extended by  bb.common.PurchaseWorkSheetPK
All Implemented Interfaces:
java.io.Serializable
public class PurchaseWorkSheetPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
PurchaseWorkSheetPK()
default constructor
PurchaseWorkSheetPK(java.lang.String employeeId, java.lang.String cartType, java.lang.Integer workSheetNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCartType()
java.lang.String | getEmployeeId()
java.lang.Integer | getWorkSheetNumber()
int | hashCode()
void | setCartType(java.lang.String cartType)
void | setEmployeeId(java.lang.String employeeId)
void | setWorkSheetNumber(java.lang.Integer workSheetNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PurchaseWorkSheetPK

public PurchaseWorkSheetPK(java.lang.String employeeId,
                           java.lang.String cartType,
                           java.lang.Integer workSheetNumber)
full constructor

PurchaseWorkSheetPK

public PurchaseWorkSheetPK()
default constructor

Method Detail

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getCartType

public java.lang.String getCartType()

setCartType

public void setCartType(java.lang.String cartType)

getWorkSheetNumber

public java.lang.Integer getWorkSheetNumber()

setWorkSheetNumber

public void setWorkSheetNumber(java.lang.Integer workSheetNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PurchaseWorkSheetVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PurchaseWorkSheetVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.PurchaseWorkSheetVO
All Implemented Interfaces:
java.io.Serializable
public class PurchaseWorkSheetVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_COMPANYUNITID
static java.lang.String | ORDER_BY_DUEDATE
static java.lang.String | ORDER_BY_EMPLOYEEEMAIL
static java.lang.String | ORDER_BY_PK
Constructor Summary
PurchaseWorkSheetVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCompanyUnitId()
java.lang.String | getDebitAccount()
java.lang.String | getDescription()
java.util.Date | getDueDate()
java.lang.String | getEmployeeEmail()
java.lang.String | getOrderBy()
PurchaseWorkSheetPK | getPk()
java.lang.String | getPublicToUser()
java.util.Set | getPurchaseWorkSheetItem()
int | hashCode()
boolean | isPublicToEvery()
boolean | isPublicWorkSheet()
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setDebitAccount(java.lang.String debitAccount)
void | setDescription(java.lang.String description)
void | setDueDate(java.util.Date dueDate)
void | setEmployeeEmail(java.lang.String employeeEmail)
void | setOrderBy(java.lang.String orderBy)
void | setPk(PurchaseWorkSheetPK pk)
void | setPublicToEvery(boolean publicToEvery)
void | setPublicToUser(java.lang.String publicToUser)
void | setPublicWorkSheet(boolean publicWorkSheet)
void | setPurchaseWorkSheetItem(java.util.Set purchaseWorkSheetItem)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PK

public static final java.lang.String ORDER_BY_PK
See Also:
Constant Field Values

ORDER_BY_EMPLOYEEEMAIL

public static final java.lang.String ORDER_BY_EMPLOYEEEMAIL
See Also:
Constant Field Values

ORDER_BY_DUEDATE

public static final java.lang.String ORDER_BY_DUEDATE
See Also:
Constant Field Values

ORDER_BY_COMPANYUNITID

public static final java.lang.String ORDER_BY_COMPANYUNITID
See Also:
Constant Field Values
Constructor Detail

PurchaseWorkSheetVO

public PurchaseWorkSheetVO()
default constructor

Method Detail

getPk

public PurchaseWorkSheetPK getPk()

setPk

public void setPk(PurchaseWorkSheetPK pk)

getEmployeeEmail

public java.lang.String getEmployeeEmail()

setEmployeeEmail

public void setEmployeeEmail(java.lang.String employeeEmail)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getDueDate

public java.util.Date getDueDate()

setDueDate

public void setDueDate(java.util.Date dueDate)

getPurchaseWorkSheetItem

public java.util.Set getPurchaseWorkSheetItem()

setPurchaseWorkSheetItem

public void setPurchaseWorkSheetItem(java.util.Set purchaseWorkSheetItem)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getDebitAccount

public java.lang.String getDebitAccount()

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

isPublicToEvery

public boolean isPublicToEvery()

setPublicToEvery

public void setPublicToEvery(boolean publicToEvery)

getPublicToUser

public java.lang.String getPublicToUser()

setPublicToUser

public void setPublicToUser(java.lang.String publicToUser)

isPublicWorkSheet

public boolean isPublicWorkSheet()

setPublicWorkSheet

public void setPublicWorkSheet(boolean publicWorkSheet)

getOrderBy

public java.lang.String getOrderBy()

setOrderBy

public void setOrderBy(java.lang.String orderBy)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PurchasingBox

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common.box
Interface PurchasingBox

public interface PurchasingBox

Method Summary
PoMessageVO | acceptPoMessage(java.lang.String poMessageNumber, java.lang.String comments, java.util.Hashtable itemComments)
RfqMessageVO | acceptRfqMessage(java.lang.String rfqMessageNumber, java.lang.String comments, java.util.Hashtable itemComments, boolean updatePartVendor)
MyPrintListVO | addMyPrintList(java.lang.String soNumber)
java.lang.String | addPfReceiver(ProformaReceiverPackingBoxAgent agent)
java.lang.String | addPfReceiver(java.lang.String vendorId)
PoMessageVO | addPoMessage(java.lang.String poNumber)
PurchaseWorkSheetVO | addPOWSFromQuote(java.lang.String qtNumber)
PurchaseWorkSheetVO | addPOWSFromSO(java.lang.String soNumber)
PurchaseOrderVO | addPurchaseOrder(java.lang.String vendorId)
PurchaseOrderApprovalVO | addPurchaseOrderApproval(java.lang.String employeeId)
PurchaseOrderBoilerplateVO | addPurchaseOrderBP(PurchaseOrderBoilerplateVO vo)
java.lang.String | addPurchaseOrderByMPNPart(java.lang.String vendorId)
java.lang.String | addPurchaseOrderFromRequestForQuote(java.lang.String rfqNumber, java.lang.String vendorId)
java.util.Collection<java.lang.String> | addPurchaseOrderFromWISeq(POForWISeqAgent agent)
java.lang.String | addPurchaseOrderFromWISeq(java.lang.String vendorID, WorkOrderWorkInstructionSequencePK seqPk)
PurchaseOrderItemVO | addPurchaseOrderItem(PurchaseOrderItemVO purItemVO)
PurchaseWorkSheetVO | addPurchaseWorkSheet()
PurchaseWorkSheetVO | addPurchaseWorkSheet(java.util.ArrayList list)
PurchaseWorkSheetVO | addPurchaseWorkSheet(PurchaseWorkSheetVO pwsVO)
PurchaseWorkSheetItemVO | addPurchaseWorkSheetItem(PurchaseWorkSheetItemVO pwsItemVO)
RefdocVO | addRefdocTwo(PurchaseOrderItemPK poItemPk, java.lang.String orderNumber, java.lang.String itemNumber, java.math.BigDecimal refdocQty)
RequestForQuoteVO | addRequestForQuote(java.lang.String vendorId)
RequestForQuoteVO | addRequestForQuote(java.lang.String vendorId, java.lang.String oldRFQNumber, boolean includeItems)
java.lang.String | addReturnToVendor(AddRTVAgent agent)
RequestForQuoteVO | addRfqFromQuote(java.lang.String vendorId, java.lang.String quoteNumber)
RequestForQuoteVO | addRfqFromSO(java.lang.String vendorId, java.lang.String soNumber, boolean isCopyMpn)
RfqMessageVO | addRfqMessage(java.lang.String rfqNumber)
java.lang.String | addRTVApproval(java.lang.String employeeID)
java.lang.String | addSwapOrder(java.lang.String vendId)
SwapOrderApprovalVO | addSwapOrderApproval(java.lang.String employeeId)
java.lang.String | addVendorContractPrice(VendorContractPriceVO vo)
VendorContractPriceItemVO | addVendorContractPriceItem(VendorContractPriceItemVO vo)
java.util.Collection<VendorContractPriceItemVO> | addVendorContractPriceItems(java.util.ArrayList list)
VendorContractPriceVendorVO | addVendorContractPriceVendor(VendorContractPriceVendorVO vo)
SwapOrderVO | approvalSwapOrder(SwapOrderVO toVO)
void | approvePoMessageByVendor(java.lang.String poMessageNumber, java.lang.String vendorUserName)
PurchaseOrderVO | approvePurchaseOrder(PurchaseOrderVO purVO)
PurchaseOrderVO | approvePurchaseOrder(java.lang.String purchaseOrderNumber)
RequestForQuoteVO | approveRequestForQuote(RequestForQuoteVO rfqVo)
RequestForQuoteVO | approveRequestForQuote(java.lang.String rfqNumber)
java.lang.String | approveReturnToVendor(ReturnToVendorVO rtvVO)
java.lang.String | approveReturnToVendor(java.lang.String rtvNumber)
java.util.Collection<AuditOnDemandResult> | auditing(java.util.ArrayList list)
java.lang.String | cancelPurchaseOrder(java.lang.String poNumber)
java.lang.String | cancelRfq(java.lang.String rfqNumber)
java.lang.String | cancelRTV(java.lang.String rtvNumber)
java.lang.String | cancelSwap(java.lang.String swapNumber)
boolean | checkOrderItemExist(OrderPK pk)
void | clearAllReferenceDocOnesToPurchaseOrderItem(PurchaseOrderItemPK pk)
void | clearAllReferenceDocTwoesToPurchaseOrderItem(PurchaseOrderItemPK pk)
boolean | clearMyPurchaseOrderPrintList(java.lang.String purchaseOrderNumberLike)
void | clearPurchaseOrderItemReferenceDocOne(java.lang.String referenceDoc)
void | clearPurchaseOrderItemReferenceDocTwo(java.lang.String referenceDoc)
java.lang.String | copyPurchaseOrderFromPurchaseOrder(PO2POAgent agent)
PurchaseOrderVO | copyPurchaseOrderFromSalesOrder(SO2POAgent agent)
PO2SOExchange | createPO2SOExchange(java.lang.String poNumber)
void | deleteMyPrintList(java.util.ArrayList poNumberList)
void | deletePfReceiver(java.lang.String pfReceiverNumber)
java.util.Collection<PurchaseOrderDocumentVO> | deletePODoc(MiscDocAgent agent)
void | deletePurchaseOrder(PurchaseOrderVO purVO)
void | deletePurchaseOrderApproval(java.lang.String employeeId)
void | deletePurchaseOrderBP(java.lang.String bpID)
void | deletePurchaseOrderItem(PurchaseOrderItemVO purItemVO)
void | deletePurchaseOrderItems(java.lang.String purchaseNumber)
void | deletePurchaseWorkSheet(PurchaseWorkSheetVO pwsVO)
void | deletePurchaseWorkSheetItem(PurchaseWorkSheetItemVO pwsItemVO)
void | deleteRefdocTwo(BB2RefdocPK pk)
void | deleteRequestForQuote(RequestForQuoteVO rfqVO)
void | deleteReturnToVendor(ReturnToVendorVO rtvVO)
void | deleteRTVApproval(java.lang.String employeeID)
void | deleteSwapOrder(SwapOrderVO vo)
void | deleteSwapOrderApproval(java.lang.String employeeId)
void | deleteVendorContractPrice(VendorContractPriceVO cpVO)
void | deleteVendorContractPriceItem(VendorContractPriceItemVO cpiVO)
void | deleteVendorContractPriceVendor(VendorContractPriceVendorVO cpcVO)
BB2File | downloadPODoc(MiscDocAgent agent)
java.lang.Object | execute(java.lang.String excuterName, java.lang.Object[] values, java.lang.Class[] types)
java.lang.Object | executeDaoMethod(java.lang.String daoName, java.lang.String methodName, java.lang.Object[] values, java.lang.Class[] types)
java.util.Collection<java.util.Map> | findAllMPNParts()
java.util.Collection<PartTraceableInfoResult> | findAllPartTraceableByPN(java.lang.String poNumber)
java.util.Collection<PrReceiverListResult> | findAllPfReceivers(int firstIndex, int maxLength)
java.util.Collection<PoMessageListResult> | findAllPoMessages()
java.util.Collection<PurchaseOrderApprovalVO> | findAllPurchaseOrderApprovals(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderBoilerplateVO> | findAllPurchaseOrderBP(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | findAllPurchaseOrderByAddressId(java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderCheckListResult> | findAllPurchaseOrderCheckListResults(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | findAllPurchaseOrderItems(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | findAllPurchaseOrderItemsByAddressId(java.lang.String startWith, java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | findAllPurchaseOrders(int firstIndex, int maxLength)
java.util.Collection<POStatisticsResult> | findAllPurchaseOrderStatistics(java.lang.String project, java.lang.String relatedDoc, java.lang.String vendorName, java.lang.String requester, java.lang.String contact, int firstIndex, int maxLength)
java.util.Collection<PurchaseWorkSheetVO> | findAllPurchaseWorkSheet(int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteCheckListResult> | findAllRfqCheckListResults(int firstIndex, int maxLength)
java.util.Collection<RfqMessageListResult> | findAllRfqMessages()
java.util.Collection<RTVApprovalVO> | findAllRTVApprovals(int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorCheckListResult> | findAllRtvCheckListResults(int firstIndex, int maxLength)
java.util.Collection<SwapOrderApprovalVO> | findAllSwapOrderApproval(int firstIndex, int maxLength)
java.util.Collection<VendorContractPriceVO> | findAllVendorContracts(int firstIndex, int maxLength)
java.util.Collection<BB2PartOnDemandListResult> | findBB2PartOnDemandListResultForPart(boolean compessSuff, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | findCancelledPurchaseOrderItems(int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteItemListResult> | findCancelledRequestForQuoteItemListResults(int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorByDateListResult> | findCancelledReturnToVendorItemsListResults(int firstIndex, int maxLength)
java.util.Collection<SwapOrderItemListResult> | findCancelledSwapOrder(int firstIndex, int maxLength)
java.util.Collection<VendorContractPriceVendorVO> | findContractVendorsByContractNumber(java.lang.String contractNumber, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderOpenDueListResult> | findDuePurchaseOrderItemByBuyerCode(java.lang.String buyerCode, int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteItemListResult> | findDueRequestForQuoteItemListResults(int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorItemListResult> | findDueReturnToVendorItemListResults(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | findMyPoPrintList()
java.util.Collection<PurchaseWorkSheetVO> | findMyPurchaseWorkSheet(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | findOpenPurchaseOrder(java.lang.String startWith, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | findOpenPurchaseOrderByAddressId(java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderOpenDueListResult> | findOpenPurchaseOrderByBuyer(java.lang.String buyer, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | findOpenPurchaseOrderByProjectLike(java.lang.String projectLike, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | findOpenPurchaseOrderByRequesterLike(java.lang.String requesterLike, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | findOpenPurchaseOrderForReceiver(java.lang.String startWith, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderOpenDueListResult> | findOpenPurchaseOrderItemByBuyerCode(java.lang.String buyerCode, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderOpenDueListResult> | findOpenPurchaseOrderItemByShipVia(java.lang.String vendorId, java.lang.String shipVia, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderOpenDueListResult> | findOpenPurchaseOrderItems(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | findOpenPurchaseOrderItemsByAddressId(java.lang.String startWith, java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | findOpenPurchaseOrderItemsByPartPk(PartPK pk, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | findOpenPurchaseOrderNotAcknowledged(int firstIndex, int maxLength)
java.util.Collection<Money> | findOpenPurchaseOrderTotal()
java.util.Collection<PurchaseOrderListResult> | findOpenPurchaseOrdertRelatedDoc(java.lang.String startWith, java.lang.String refDoc, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | findOpenPurchaseOrderwithPrepay(java.lang.String startWith, int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteItemListResult> | findOpenRequestForQuoteItemListResults(int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorItemListResult> | findOpenReturnToVendorItemListResults(int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorListResult> | findOpenReturnToVendorListResultsByRtvNumber(java.lang.String rtvNumber, int firstIndex, int maxLength)
java.util.Collection<SwapOrderListResult> | findOpenSwapOrder(java.lang.String swoNumber, int firstIndex, int maxLength)
java.util.Collection<PartWithInventoryInfoListResult> | findPartByBuyerCode(java.lang.String buyerCode, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<PartInMrpListResult> | findPartInMrpListResult(java.util.List<PartPK> partPks)
java.util.Collection<PurchaseOrderOpenDueListResult> | findPastDuePurchaseOrderByBuyer(java.lang.String buyer, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderOpenDueListResult> | findPastDuePurchaseOrderItemByShipVia(java.lang.String vendorId, java.lang.String shipVia, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderOpenDueListResult> | findPastDuePurchaseOrderItems(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | findPastDuePurchaseOrderItemsByAddressId(java.lang.String startWith, java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<Money> | findPastDuePurchaseOrderTotal()
java.util.Collection<PrReceiverListResult> | findPfReceiversByPfNumber(java.lang.String pfReceiverNumberLike, int firstIndex, int maxLength)
java.util.Collection<PrReceiverListResult> | findPfReceiversByVendorId(java.lang.String vendorId, int firstIndex, int maxLength)
java.util.Collection<PrReceiverListResult> | findPfReceiversOpenByVendorId(java.lang.String vendorId, int firstIndex, int maxLength)
java.util.Collection<PartDueAddressListResult> | findPoDueVendors()
java.util.Collection<PoMessageListResult> | findPoMessagesByStatusAndID(java.lang.String[] status, java.lang.String vendorIdLike, int firstIndex, int maxLength)
java.util.Collection<TotalByDateResult> | findPoTotalByDateResults(java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String status, java.lang.String partNumberLike, java.lang.String partType, java.lang.String shipto, java.lang.String vendorId, java.lang.String project, java.lang.String requester, java.lang.String buyer, java.lang.String currency, java.lang.String relatedDoc, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isHold, java.lang.String productCode)
java.util.Collection<PurchaseOrderContractResult> | findPurchaseContract(java.util.Date fromDate, java.util.Date toDate, java.lang.String currency, java.lang.String type)
java.util.Collection<java.util.Map> | findPurchaseOrderApPrepays(java.lang.String[] poNumbers)
java.util.Collection<PurchaseOrderBoilerplateVO> | findPurchaseOrderBPBybpID(java.lang.String bpId, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | findPurchaseOrderByPoNumber(java.lang.String poNumber, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | findPurchaseOrderByRange(java.lang.String poStart, java.lang.String poEnd, java.lang.String vendorIdLike, java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderCheckListResult> | findPurchaseOrderCheckListResults(java.lang.String startWith, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | findPurchaseOrderItemByDate(java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String status, java.lang.String partNumberLike, java.lang.String partType, java.lang.String shipto, java.lang.String vendorId, java.lang.String project, java.lang.String requester, java.lang.String buyer, java.lang.String currency, java.lang.String relatedDoc, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isHold, java.lang.String productCode, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | findPurchaseOrderItemsByPartNumberLike(java.lang.String partNumberReg, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | findPurchaseOrderItemsByPartPk(PartPK pk, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemVO> | findPurchaseOrderItemsByPoNumber(java.lang.String poNumber)
java.util.Collection<PurchaseOrderItemListResult> | findPurchaseOrderItemsByProject(java.lang.String startWith, java.lang.String status, java.lang.String dateType, java.util.Date startDate, java.util.Date toDate, java.lang.String project, int firstIndex, int maxLength)
java.util.Collection<POItemByRefDoc1ListResult> | findPurchaseOrderItemsByRefDoc1(java.lang.String startWith, java.lang.String status, java.lang.String dateType, java.util.Date startDate, java.util.Date toDate, java.lang.String refDoc, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | findPurchaseOrderItemsByRelatedDoc(java.lang.String startWith, java.lang.String status, java.lang.String dateType, java.util.Date startDate, java.util.Date toDate, java.lang.String relatedDoc, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | findPurchaseOrdersByRefdoc(java.lang.String poNumber, java.lang.String status, java.lang.String refdoc, java.util.Date dateFrom, java.util.Date dateTo, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | findPurchaseOrdersForReceiving(java.lang.String refDoc, java.lang.String vendorNameLike, java.lang.String partNumberLike, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<PurchaseWorkSheetVO> | findPurchaseWorkSheetByEmployeeEmailLike(java.lang.String employeeEmailLike, int firstIndex, int maxLength)
java.util.Collection<PurchaseWorkSheetVO> | findPurchaseWorkSheetByEmployeeId(java.lang.String employeeId, boolean isMfrPurchaseWorkSheet, int firstIndex, int maxLength)
java.util.Collection<PurchaseWorkSheetItemWithRelatedInfoResult> | findPurchaseWorkSheetItemsByWorkSheetPk(PurchaseWorkSheetPK workSheetPk)
java.util.Collection<RequestForQuoteItemListResult> | findRequestForQuoteItemListResults(java.lang.String partNumberLike, java.lang.String partType, java.lang.String status, boolean isDue, int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteItemListResult> | findRequestForQuoteItemListResults(java.lang.String partNumberLike, java.lang.String partType, java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteItemListResult> | findRequestForQuoteItemListResultsByPartNumberAndDateLike(java.lang.String searchText, java.lang.String partType, java.lang.String dateType, java.util.Date dateBigin, java.util.Date dateEnd, java.lang.String vendorId, boolean vendorIdLike, int firstIndex, int length)
java.util.Collection<RequestForQuoteItemListResult> | findRequestForQuoteItemListResultsByPartNumberAndDateLike(java.lang.String searchText, java.lang.String partType, java.lang.String dateType, java.util.Date dateBigin, java.util.Date dateEnd, java.lang.String vendorId, java.lang.String buyer, int firstIndex, int length)
java.util.Collection<RequestForQuoteItemListResult> | findRequestForQuoteItemListResultsByPartNumberLike(java.lang.String partNumberLike, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteListResult> | findRequestForQuoteListResults(java.lang.String rfqNumber, java.lang.String status, java.lang.String vendId, int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteListResult> | findRequestForQuoteListResultsByRfqNumber(java.lang.String rfqNumber, int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteListResult> | findRequestForQuoteListResultsByVendorId(java.lang.String vendorId, int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorItemListResult> | findReturnToVendorItemListResults(java.lang.String partNumberLike, java.lang.String partType, java.lang.String status, boolean isDue, int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorItemListResult> | findReturnToVendorItemListResults(java.lang.String partNumberLike, java.lang.String partType, java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorItemListResult> | findReturnToVendorItemListResultsByPartNumberLike(java.lang.String partNumberLike, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorByDateListResult> | findReturnToVendorItemsListResults(java.lang.String partnumber, java.lang.String parttype, java.lang.String status, java.lang.String shipto, java.lang.String vendorId, java.lang.String po, java.lang.String ncrNumber, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isRtvDate, java.util.Date startDate, java.util.Date toDate, java.lang.String project, java.lang.String requester, java.lang.String buyer, java.lang.String enterBy, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorByDateListResult> | findReturnToVendorItemsListResults(java.lang.String partnumber, java.lang.String parttype, java.lang.String status, java.lang.String shipto, java.lang.String vendorId, java.lang.String po, java.lang.String ncrNumber, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isRtvDate, java.util.Date startDate, java.util.Date toDate, java.lang.String project, java.lang.String requester, java.lang.String buyer, java.lang.String enterBy, java.lang.String refDoc, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorListResult> | findReturnToVendorListResults(java.lang.String rtvNumber, java.lang.String status, java.lang.String vendId, int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorListResult> | findReturnToVendorListResultsByRtvNumber(java.lang.String rtvNumber, int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorListResult> | findReturnToVendorListResultsByVendorId(java.lang.String vendorId, int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteCheckListResult> | findRfqCheckListResults(java.lang.String startWith, int firstIndex, int maxLength)
java.util.Collection<RfqMessageListResult> | findRfqMessagesByStatusAndID(java.lang.String[] status, java.lang.String vendorIdLike, int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorCheckListResult> | findRtvCheckListResults(java.lang.String startWith, int firstIndex, int maxLength)
java.util.Collection<SwapOrderItemListResult> | findSwapOrderByDate(java.lang.String swoNumber, PartPK partPk, java.lang.String dateType, java.util.Date startDate, java.util.Date toDate, java.lang.String vendorId, java.lang.String buyer, java.lang.String projectName, java.lang.String relatedDoc, java.lang.String status, java.lang.String partFrom, int firstIndex, int maxLength)
java.util.Collection<SwapOrderListResult> | findSwapOrders(java.lang.String swoNumber, java.lang.String vendorId, java.lang.String buyer, java.lang.String projectName, java.lang.String relatedDoc, java.lang.String[] status, java.util.Date startDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<TotalAmountInPOByRefDoc> | findTotalPOByProject(java.lang.String startWith, java.lang.String project, java.util.Date fromDate, java.util.Date toDate, java.lang.String dateType, java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<TotalAmountInPOByRefDoc> | findTotalPOByRelatedDoc(java.lang.String startWith, java.lang.String refDoc, java.util.Date fromDate, java.util.Date toDate, java.lang.String dateType, java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<TotalAmountInPOByRefDoc> | findTotalPOItemByRefDoc1(java.lang.String startWith, java.lang.String refDoc, java.util.Date fromDate, java.util.Date toDate, java.lang.String dateType, java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<VendorContractPriceItemVO> | findVendorContractItemsByContractNumber(java.lang.String contractNumber, int firstIndex, int maxLength)
java.util.Collection<VendorContractPriceVendorVO> | findVendorContractsByAddressId(java.lang.String addressIdRegex, int firstIndex, int maxLength)
java.util.Collection<VendorContractPriceVO> | findVendorContractsByContractNumber(java.lang.String contractNumber, int firstIndex, int maxLength)
java.util.Collection<OntimeDeliveryRateListResult> | findVendorOnTimeDeliveryRateByVendorId(java.lang.String vendorId, java.util.Date from, java.util.Date to, java.lang.String dateType, int delayDays, int beforeDays, boolean includeInSit, int firstIndex, int maxLength)
java.util.Collection<VendorTotalAmountInPO> | findVendorPurchaseOrderByDate(java.lang.String vendorId, java.util.Date fromDate, java.util.Date toDate, java.lang.String dateType, java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | findVendorPurchaseOrderItems(java.lang.String vendorId, java.util.Date from, java.util.Date to, java.lang.String dateType, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | findVendorPurchaseOrderItemsByDate(java.lang.String vendorId, java.util.Date from, java.util.Date to, java.lang.String dateType, java.lang.String status, int firstIndex, int maxLength)
java.lang.String | finishProformaReceiver(java.lang.String pfReceiverNumber, FinishProformaReceiverAgent agent)
java.lang.String | finishProformaReceiver(java.lang.String pfReceiverNumber, PfReceiverItemVO itemVO, java.util.HashSet<PrPackingBoxItemVO> boxItemVOs, java.lang.String receiverNumber)
int | getAllPfReceiversCount()
int | getAllPoMessageCount()
int | getAllPurchaseOrderApprovalsCount()
int | getAllPurchaseOrderBPCount()
int | getAllPurchaseOrderCheckListResultsCount()
int | getAllPurchaseOrderCountByAddressId(java.lang.String addressId)
int | getAllPurchaseOrderItemsCount()
int | getAllPurchaseOrderItemsCountByAddressId(java.lang.String startWith, java.lang.String addressId)
int | getAllPurchaseOrdersCount()
int | getAllPurchaseOrderStatisticsCount(java.lang.String project, java.lang.String relatedDoc, java.lang.String vendorName, java.lang.String requester, java.lang.String contact)
java.util.Collection<TotalByDateResult> | getAllPurchaseOrderStatisticsTotal(java.lang.String project, java.lang.String relatedDoc, java.lang.String vendorName, java.lang.String requester, java.lang.String contact)
int | getAllPurchaseWorkSheetCount()
int | getAllRfqCheckListResultsCount()
int | getAllRfqMessageCount()
int | getAllRTVApprovalsCount()
int | getAllRtvCheckListResultsCount()
int | getAllSwapOrderApprovalCount()
int | getAllVendorContractsCount()
AuditLogVO | getAuditLog()
java.util.Collection<AuditOnDemandResult> | getAuditResults()
int | getBB2PartOnDemandListResultForPart(boolean compessSuff)
int | getCancelledPurchaseOrderItemsCount()
int | getCancelledRequestForQuoteItemListResultsCount()
int | getCancelledReturnToVendorItemsListResultsCount()
int | getCancelledSwapOrderCount()
int | getContractVendorsCountByContractNumber(java.lang.String contractNumber)
int | getDuePurchaseOrderItemCountByBuyerCode(java.lang.String buyerCode)
int | getDueRequestForQuoteItemListResultsCount()
int | getDueReturnToVendorItemListResultsCount()
java.math.BigDecimal | getInitDefaultCostPerUnit(BB2Part part, java.lang.String poNumber)
java.util.Map<java.util.Date,OntimeDeliveryRateResult> | getLast12MonthOntimeDeliveryRate(java.lang.String vendorId, java.lang.String dateType, int overDueDays, int advanceDays)
MrpItemOrderDemandRecordsResult | getMrpItemOrderDemandRecordsResult(PartPK part, MrpReportAgent agent)
MrpItemResult | getMrpItemResult(PartPK pk, boolean minQty, boolean includeTolerance)
MrpItemResult | getMrpItemResult(PartPK part, MrpReportAgent tmp)
BB2PartMrpResult | getMrpResult(BB2Part part)
int | getMyPurchaseWorkSheetByCount()
IncomeByMonthChartResult | getNext12MonthPoShipAmount()
int | getOpenPurchaseOrderCount(java.lang.String startWith)
int | getOpenPurchaseOrderCountByAddressId(java.lang.String addressId)
int | getOpenPurchaseOrderCountByBuyer(java.lang.String buyer)
int | getOpenPurchaseOrderCountsByProjectLike(java.lang.String projectLike)
int | getOpenPurchaseOrderCountsByRequesterLike(java.lang.String requesterLike)
int | getOpenPurchaseOrderForReceiverCount(java.lang.String startWith)
int | getOpenPurchaseOrderItemByShipVia(java.lang.String vendorId, java.lang.String shipVia)
java.util.Collection<TotalByDateResult> | getOpenPurchaseOrderItemByShipViaTotal(java.lang.String vendorId, java.lang.String shipVia)
int | getOpenPurchaseOrderItemCount()
int | getOpenPurchaseOrderItemCountByBuyerCode(java.lang.String buyerCode)
int | getOpenPurchaseOrderItemCountByPartPk(PartPK pk)
int | getOpenPurchaseOrderItemsCountByAddressId(java.lang.String startWith, java.lang.String addressId)
int | getOpenPurchaseOrderNotAcknowledged()
int | getOpenPurchaseOrdertRelatedDocCount(java.lang.String startWith, java.lang.String refDoc)
int | getOpenPurchaseOrderwithPrepayCount(java.lang.String startWith)
int | getOpenRequestForQuoteItemListResultsCount()
int | getOpenReturnToVendorItemListResultsCount()
int | getOpenReturnToVendorListResultsCountByRtvNumber(java.lang.String rtvNumber)
int | getOpenSwapOrderCount(java.lang.String swoNumber)
int | getPartByBuyerCodeCount(java.lang.String buyerCode, java.lang.String languageCode)
java.util.Collection<PartPK> | getPartPKList(MrpReportAgent agent)
int | getPastDuePurchaseOrderCountByBuyer(java.lang.String buyer)
int | getPastDuePurchaseOrderItemByShipVia(java.lang.String vendorId, java.lang.String shipVia)
java.util.Collection<TotalByDateResult> | getPastDuePurchaseOrderItemByShipViaTotal(java.lang.String vendorId, java.lang.String shipVia)
int | getPastDuePurchaseOrderItemCount()
int | getPastDuePurchaseOrderItemsCountByAddressId(java.lang.String startWith, java.lang.String addressId)
PfReceiverVO | getPfReceiver(java.lang.String pfReceiverNumber)
int | getPfReceiversCountByPfNumber(java.lang.String pfReceiverNumberLike)
int | getPfReceiversCountByVendorId(java.lang.String vendorId)
int | getPfReceiversOpenCountByVendorId(java.lang.String vendorId)
java.util.Collection<PurchaseOrderItemVO> | getPOItemsforRtv(java.lang.String purchaseNumber)
PoMessageVO | getPoMessage(java.lang.String poMessageNumber)
PoMessageVO | getPoMessageByPoNumber(java.lang.String poNumber)
int | getPoMessageCountByStatusAndID(java.lang.String[] status, java.lang.String vendorIdLike)
java.lang.String | getPoMessageStatus(java.lang.String poNumber)
PrPackingBoxVO | getPrPackingBox(PrPackingBoxPK pk)
java.math.BigDecimal | getPurchaseOrderApPrepayApply(java.lang.String poNumber)
java.math.BigDecimal | getPurchaseOrderApPrepayPaid(java.lang.String poNumber)
PurchaseOrderApprovalVO | getPurchaseOrderApprovalByEmployeeId(java.lang.String employeeId)
PurchaseOrderApprovalVO | getPurchaseOrderApprovalByUserNumber(java.lang.String userName)
PurchaseOrderBoilerplateVO | getPurchaseOrderBPByPk(java.lang.String purchaseOrderBoilerplateId)
int | getPurchaseOrderBPCountBybpID(java.lang.String bpId)
PurchaseOrderVO | getPurchaseOrderByPoNumber(java.lang.String poNumber)
int | getPurchaseOrderCheckListResultsCount(java.lang.String startWith)
int | getPurchaseOrderCountByPoNumber(java.lang.String poNumber)
int | getPurchaseOrderCountByRange(java.lang.String poStart, java.lang.String poEnd, java.lang.String vendorIdLike, java.lang.String status)
PurchaseOrderDocumentVO | getPurchaseOrderDocumentByID(java.lang.Long controlNumber)
PurchaseOrderItemVO | getPurchaseOrderItemByPk(PurchaseOrderItemPK pk)
int | getPurchaseOrderItemCountByDate(java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String status, java.lang.String partNumberLike, java.lang.String partType, java.lang.String shipto, java.lang.String vendorId, java.lang.String project, java.lang.String requester, java.lang.String buyer, java.lang.String currency, java.lang.String relatedDoc, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isHold, java.lang.String productCode)
int | getPurchaseOrderItemCountByPartNumberLike(java.lang.String partNumberReg, java.lang.String partType)
int | getPurchaseOrderItemCountByPartPk(PartPK pk)
int | getPurchaseOrderItemCountByPoNumber(java.lang.String poNumber)
int | getPurchaseOrderItemCountByProject(java.lang.String startWith, java.lang.String status, java.lang.String dateType, java.util.Date startDate, java.util.Date toDate, java.lang.String project)
int | getPurchaseOrderItemCountByRefDoc1(java.lang.String startWith, java.lang.String status, java.lang.String dateType, java.util.Date startDate, java.util.Date toDate, java.lang.String refDoc)
int | getPurchaseOrderItemCountByRelatedDoc(java.lang.String startWith, java.lang.String status, java.lang.String dateType, java.util.Date startDate, java.util.Date toDate, java.lang.String relatedDoc)
java.util.Collection<PartDwfAgent> | getPurchaseOrderItemDwf(java.lang.String purchaseOrderNumber)
int | getPurchaseOrdersCountByByRefdoc(java.lang.String poNumber, java.lang.String status, java.lang.String refdoc, java.util.Date dateFrom, java.util.Date dateTo)
int | getPurchaseOrdersForReceivingCount(java.lang.String refDoc, java.lang.String vendorNameLike, java.lang.String partNumberLike, java.lang.String partType)
java.lang.String | getPurchaseOrderStatus(java.lang.String poNumber)
java.util.Collection<TotalByDateResult> | getPurchaseOrderTotalResultByRelatedDoc(java.lang.String startWith, java.lang.String status, java.lang.String dateType, java.util.Date startDate, java.util.Date toDate, java.lang.String relatedDoc)
int | getPurchaseWorkSheetByCountByEmployeeId(java.lang.String employeeId)
PurchaseWorkSheetVO | getPurchaseWorkSheetByPk(PurchaseWorkSheetPK pk)
int | getPurchaseWorkSheetCountByEmployeeEmailLike(java.lang.String employeeEmailLike)
RequestForQuoteVO | getRequestForQuoteByRfqNumber(java.lang.String rfqNumber)
int | getRequestForQuoteItemListResultsCount(java.lang.String partNumberLike, java.lang.String partType, java.lang.String status)
int | getRequestForQuoteItemListResultsCount(java.lang.String partNumberLike, java.lang.String partType, java.lang.String status, boolean isDue)
int | getRequestForQuoteItemListResultsCountByPartNumberAndDateLike(java.lang.String searchText, java.lang.String partType, java.lang.String dateType, java.util.Date dateBigin, java.util.Date dateEnd, java.lang.String vendorId, boolean vendorIdLike)
int | getRequestForQuoteItemListResultsCountByPartNumberAndDateLike(java.lang.String searchText, java.lang.String getPartType, java.lang.String getDateType, java.util.Date getDateBigin, java.util.Date getDateEnd, java.lang.String getVendorId, java.lang.String buyer)
int | getRequestForQuoteItemListResultsCountByPartNumberLike(java.lang.String partNumberLike, java.lang.String partType)
int | getRequestForQuoteListResultsCount(java.lang.String rfqNumber, java.lang.String status, java.lang.String vendId)
int | getRequestForQuoteListResultsCountByRfqNumber(java.lang.String rfqNumber)
int | getRequestForQuoteListResultsCountByVendorId(java.lang.String vendorId)
java.lang.String | getRequestForQuoteStatus(java.lang.String requestForQuoteNumber)
ReturnToVendorVO | getReturnToVendorByRtvNumber(java.lang.String rtvNumber)
int | getReturnToVendorItemListResultsCount(java.lang.String partNumberLike, java.lang.String partType, java.lang.String status)
int | getReturnToVendorItemListResultsCount(java.lang.String partNumberLike, java.lang.String partType, java.lang.String status, boolean isDue)
int | getReturnToVendorItemListResultsCountByPartNumberLike(java.lang.String partNumberLike, java.lang.String partType)
int | getReturnToVendorItemsListResultsCount(java.lang.String partnumber, java.lang.String parttype, java.lang.String status, java.lang.String shipto, java.lang.String vendorId, java.lang.String po, java.lang.String ncrNumber, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isRtvDate, java.util.Date startDate, java.util.Date toDate, java.lang.String project, java.lang.String requester, java.lang.String buyer, java.lang.String enterBy, java.lang.String currency)
int | getReturnToVendorItemsListResultsCount(java.lang.String partnumber, java.lang.String parttype, java.lang.String status, java.lang.String shipto, java.lang.String vendorId, java.lang.String po, java.lang.String ncrNumber, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isRtvDate, java.util.Date startDate, java.util.Date toDate, java.lang.String project, java.lang.String requester, java.lang.String buyer, java.lang.String enterBy, java.lang.String refDoc, java.lang.String currency)
int | getReturnToVendorListResultsCount(java.lang.String rtvNumber, java.lang.String status, java.lang.String vendId)
int | getReturnToVendorListResultsCountByRtvNumber(java.lang.String rtvNumber)
int | getReturnToVendorListResultsCountByVendorId(java.lang.String vendorId)
java.lang.String | getReturnToVendorStatus(java.lang.String returnToVendorNumber)
int | getRfqCheckListResultsCount(java.lang.String startWith)
RfqMessageVO | getRfqMessage(java.lang.String rfqMessageNumber)
RfqMessageVO | getRfqMessageByRfqNumber(java.lang.String rfqNumber)
int | getRfqMessageCountByStatusAndID(java.lang.String[] status, java.lang.String vendorIdLike)
java.lang.String | getRfqMessageStatus(java.lang.String rfqNumber)
java.util.Collection<PartDwfAgent> | getRfqOrderItemDwf(java.lang.String rfqNumber)
RTVApprovalVO | getRTVApproval(java.lang.String employeeID)
int | getRtvCheckListResultsCount(java.lang.String startWith)
java.util.Collection<RtvShipperItemListResult> | getRtvShipperByPoNumber(java.lang.String poNumber)
SwapOrderApprovalVO | getSwapOrderApprovalByEmployeeId(java.lang.String employeeId)
int | getSwapOrderCountByDate(java.lang.String swoNumber, PartPK partPk, java.lang.String dateType, java.util.Date startDate, java.util.Date toDate, java.lang.String vendorId, java.lang.String buyer, java.lang.String projectName, java.lang.String relatedDoc, java.lang.String status, java.lang.String partFrom)
int | getSwapOrdersCount(java.lang.String swoNumber, java.lang.String vendorId, java.lang.String buyer, java.lang.String projectName, java.lang.String relatedDoc, java.lang.String[] status, java.util.Date startDate, java.util.Date toDate)
SwapOrderVO | getSwapOrderVOBySwapNumber(java.lang.String swapNumber)
int | getTotalPOByProjectCount(java.lang.String startWith, java.lang.String project, java.util.Date fromDate, java.util.Date toDate, java.lang.String dateType, java.lang.String status)
int | getTotalPOByRelatedDocCount(java.lang.String startWith, java.lang.String refDoc, java.util.Date fromDate, java.util.Date toDate, java.lang.String dateType, java.lang.String status)
int | getTotalPOItemByRefDoc1Count(java.lang.String startWith, java.lang.String refDoc, java.util.Date fromDate, java.util.Date toDate, java.lang.String dateType, java.lang.String status)
int | getVendorContractItemsCountByContractNumber(java.lang.String contractNumber)
VendorContractPriceVO | getVendorContractPriceById(java.lang.String cpNumber)
VendorContractPriceItemVO | getVendorContractPriceItem(VendorContractPriceItemPK pk)
VendorContractPriceVendorVO | getVendorContractPriceVendor(VendorContractPriceVendorPK pk)
int | getVendorContractsByAddressIdCount(java.lang.String addressIdRegex)
int | getVendorContractsCountByContractNumber(java.lang.String contractNumber)
OntimeDeliveryRateResult | getVendorOnTimeDeliveryRate(java.lang.String vendorId, java.util.Date from, java.util.Date to, java.lang.String dateType, int delayDays, int beforeDays, boolean includeInSit)
int | getVendorOnTimeDeliveryRateCountByVendorId(java.lang.String vendorId, java.util.Date from, java.util.Date to, java.lang.String dateType, int delayDays, int beforeDays, boolean includeInSit)
int | getVendorPurchaseOrderByDateCount(java.lang.String vendorId, java.util.Date fromDate, java.util.Date toDate, java.lang.String dateType, java.lang.String status)
int | getVendorPurchaseOrderItemCount(java.lang.String vendorId, java.util.Date from, java.util.Date to, java.lang.String dateType)
int | getVendorPurchaseOrderItemCountByDate(java.lang.String vendorId, java.util.Date from, java.util.Date to, java.lang.String dateType, java.lang.String status)
void | importTempMpn(java.util.Collection<java.util.Map> datas)
ProformaReceiverPackingBoxAgent | initProformaReceiverPackingBoxs(ProformaInvoiceVO pfVo, java.lang.String vendorId)
PurchaseOrderItemVO | initPurchaseOrderItemForPart(java.lang.String purchaseOrderNumber, java.lang.String itemNumber, PartPK partPk, java.math.BigDecimal qty)
PurchaseWorkSheetItemWithRelatedInfoResult | initPurchaseWorkSheetItemForPart(PurchaseWorkSheetPK pk, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
RequestForQuoteItemVO | initRequestForQuoteItemForPart(java.lang.String requestForQuoteNumber, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty, java.lang.String languageCode)
RequestForQuoteItemVO | initRequestForQuoteItemForTool(java.lang.String requestForQuoteNumber, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty, java.lang.String languageCode)
ReturnToVendorItemVO | initReturnToVendorItemForPart(java.lang.String rtvNumber, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
ReturnToVendorItemVO | initReturnToVendorItemForTool(java.lang.String rtvNumber, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
SwapOrderItemVO | initSwapOrderItem(SwapOrderVO toVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool)
boolean | isPfReceiverExistent(java.lang.String pfReceiverNumber)
boolean | isPoMessageExistent(java.lang.String poNumber)
boolean | isPurchaseOrderApprovalExistent(java.lang.String approvalUserName)
boolean | isPurchaseOrderBoilerplateExist(java.lang.String purchaseOrderBoilerplateId)
boolean | isPurchaseOrderExistent(java.lang.String purchaseOrderNumber)
boolean | isPurchaseOrderInMyPrintList(java.lang.String purchaseOrderNumber)
boolean | isPurchaseOrderItemExistent(PurchaseOrderItemPK pk)
boolean | isPurchaseWorkSheetExistent(PurchaseWorkSheetPK pk)
boolean | isRequestForQuoteExistent(java.lang.String requestForQuoteNumber)
boolean | isRequestForQuoteOPEN(java.lang.String requestForQuoteNumber)
boolean | isReturnToVendorExistent(java.lang.String returnToVendorNumber)
boolean | isRfqMessageExistent(java.lang.String rfqMessageNumber)
boolean | isRFQMessageItemExist(RequestForQuoteItemPK pk)
boolean | isVendorContractPriceExistent(java.lang.String contractNumber)
boolean | isVendorContractPriceItemExistent(VendorContractPriceItemPK pk)
boolean | isVendorContractPriceVendorExistent(VendorContractPriceVendorPK pk)
java.util.Collection<PurchaseOrderListResult> | makePurchaseOrders(PurchaseWorkSheetVO pwsVO)
java.util.Collection<RequestForQuoteListResult> | makeRequestForQuotes(PurchaseWorkSheetVO pwsVO)
PoMessageVO | refusePoMessage(java.lang.String poMessageNumber, java.lang.String comments, java.util.Hashtable itemComments, boolean updatePo)
RfqMessageVO | refuseRfqMessage(java.lang.String rfqMessageNumber, java.lang.String comments, java.util.Hashtable itemComments, boolean resend, boolean updateRfq)
void | saveMPNPart(java.util.ArrayList<java.util.Map> datas)
PoMessageVO | savePoMessage(java.lang.String poMessageNumber, java.lang.String comments, java.util.Hashtable itemComments)
RfqMessageVO | saveRfqMessage(java.lang.String rfqMessageNumber, java.lang.String comments, java.util.Hashtable itemComments)
void | setPurchaseOrderItemReferenceDocOne(PurchaseOrderItemPK pk, java.lang.String referenceDoc)
void | setPurchaseOrderItemReferenceDocTwo(PurchaseOrderItemPK pk, java.lang.String referenceDoc)
void | updatePfReceiver(PfReceiverVO vo)
PoMessageVO | updatePoMessageByVendor(PoMessageVO vo)
java.lang.String | updatePurchaseOrder(PurchaseOrderVO purVO)
PurchaseOrderApprovalVO | updatePurchaseOrderApproval(PurchaseOrderApprovalVO purApprovalVO)
PurchaseOrderBoilerplateVO | updatePurchaseOrderBP(PurchaseOrderBoilerplateVO vo)
void | updatePurchaseOrderItem(PurchaseOrderItemVO purItemVO)
PurchaseWorkSheetVO | updatePurchaseWorkSheet(PurchaseWorkSheetVO pwsVO)
void | updatePurchaseWorkSheetItem(PurchaseWorkSheetItemVO pwsItemVO)
RefdocVO | updateRefdocTwo(RefdocVO vo)
java.lang.String | updateRequestForQuote(RequestForQuoteVO rfqVO)
java.lang.String | updateReturnToVendor(ReturnToVendorVO rtvVO)
RfqMessageVO | updateRfqMessage(RfqMessageVO vo)
java.lang.String | updateRTVApproval(RTVApprovalVO vo)
SwapOrderVO | updateSwapOrder(SwapOrderVO vo)
void | updateSwapOrderApproval(SwapOrderApprovalVO vo)
java.lang.String | updateVendorContractPrice(VendorContractPriceVO vo)
VendorContractPriceItemVO | updateVendorContractPriceItem(VendorContractPriceItemVO vo)
VendorContractPriceVendorVO | updateVendorContractPriceVendor(VendorContractPriceVendorVO vo)
java.util.Collection<PurchaseOrderDocumentVO> | uploadOrUpdatePODoc(MiscDocAgent agent)
boolean | validatePoMessage(java.lang.String poMessageNumber, java.lang.String valicateCode)
boolean | validateRfqMessage(java.lang.String rfqMessageNumber, java.lang.String valicateCode)

Method Detail

addPurchaseOrder

PurchaseOrderVO addPurchaseOrder(java.lang.String vendorId)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

addPurchaseOrderFromRequestForQuote

java.lang.String addPurchaseOrderFromRequestForQuote(java.lang.String rfqNumber,
                                                     java.lang.String vendorId)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

copyPurchaseOrderFromSalesOrder

PurchaseOrderVO copyPurchaseOrderFromSalesOrder(SO2POAgent agent)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

copyPurchaseOrderFromPurchaseOrder

java.lang.String copyPurchaseOrderFromPurchaseOrder(PO2POAgent agent)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

addPurchaseOrderFromWISeq

java.lang.String addPurchaseOrderFromWISeq(java.lang.String vendorID,
                                           WorkOrderWorkInstructionSequencePK seqPk)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

addPurchaseOrderFromWISeq

java.util.Collection<java.lang.String> addPurchaseOrderFromWISeq(POForWISeqAgent agent)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

updatePurchaseOrder

java.lang.String updatePurchaseOrder(PurchaseOrderVO purVO)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

approvePurchaseOrder

PurchaseOrderVO approvePurchaseOrder(PurchaseOrderVO purVO)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

approvePurchaseOrder

PurchaseOrderVO approvePurchaseOrder(java.lang.String purchaseOrderNumber)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

deletePurchaseOrder

void deletePurchaseOrder(PurchaseOrderVO purVO)
                         throws java.lang.Exception
Throws:
java.lang.Exception

isPurchaseOrderExistent

boolean isPurchaseOrderExistent(java.lang.String purchaseOrderNumber)
                                throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderStatus

java.lang.String getPurchaseOrderStatus(java.lang.String poNumber)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

cancelPurchaseOrder

java.lang.String cancelPurchaseOrder(java.lang.String poNumber)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findAllPurchaseOrders

java.util.Collection<PurchaseOrderListResult> findAllPurchaseOrders(int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getAllPurchaseOrdersCount

int getAllPurchaseOrdersCount()
                              throws java.lang.Exception
Throws:
java.lang.Exception

findOpenPurchaseOrder

java.util.Collection<PurchaseOrderListResult> findOpenPurchaseOrder(java.lang.String startWith,
                                                                    int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getOpenPurchaseOrderCount

int getOpenPurchaseOrderCount(java.lang.String startWith)
                              throws java.lang.Exception
Throws:
java.lang.Exception

findPurchaseOrdersForReceiving

java.util.Collection<PurchaseOrderListResult> findPurchaseOrdersForReceiving(java.lang.String refDoc,
                                                                             java.lang.String vendorNameLike,
                                                                             java.lang.String partNumberLike,
                                                                             java.lang.String partType,
                                                                             int firstIndex,
                                                                             int maxLength)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrdersForReceivingCount

int getPurchaseOrdersForReceivingCount(java.lang.String refDoc,
                                       java.lang.String vendorNameLike,
                                       java.lang.String partNumberLike,
                                       java.lang.String partType)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findOpenPurchaseOrderForReceiver

java.util.Collection<PurchaseOrderListResult> findOpenPurchaseOrderForReceiver(java.lang.String startWith,
                                                                               int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getOpenPurchaseOrderForReceiverCount

int getOpenPurchaseOrderForReceiverCount(java.lang.String startWith)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

findOpenPurchaseOrderwithPrepay

java.util.Collection<PurchaseOrderListResult> findOpenPurchaseOrderwithPrepay(java.lang.String startWith,
                                                                              int firstIndex,
                                                                              int maxLength)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getOpenPurchaseOrderwithPrepayCount

int getOpenPurchaseOrderwithPrepayCount(java.lang.String startWith)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findOpenPurchaseOrdertRelatedDoc

java.util.Collection<PurchaseOrderListResult> findOpenPurchaseOrdertRelatedDoc(java.lang.String startWith,
                                                                               java.lang.String refDoc,
                                                                               int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getOpenPurchaseOrdertRelatedDocCount

int getOpenPurchaseOrdertRelatedDocCount(java.lang.String startWith,
                                         java.lang.String refDoc)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderByPoNumber

PurchaseOrderVO getPurchaseOrderByPoNumber(java.lang.String poNumber)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderApPrepayPaid

java.math.BigDecimal getPurchaseOrderApPrepayPaid(java.lang.String poNumber)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderApPrepayApply

java.math.BigDecimal getPurchaseOrderApPrepayApply(java.lang.String poNumber)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

findPurchaseOrderApPrepays

java.util.Collection<java.util.Map> findPurchaseOrderApPrepays(java.lang.String[] poNumbers)
                                                               throws java.lang.Exception
Throws:
java.lang.Exception

findAllPurchaseOrderItems

java.util.Collection<PurchaseOrderItemListResult> findAllPurchaseOrderItems(int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getAllPurchaseOrderItemsCount

int getAllPurchaseOrderItemsCount()
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findAllPurchaseOrderCheckListResults

java.util.Collection<PurchaseOrderCheckListResult> findAllPurchaseOrderCheckListResults(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllPurchaseOrderCheckListResultsCount

int getAllPurchaseOrderCheckListResultsCount()
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findPurchaseOrderCheckListResults

java.util.Collection<PurchaseOrderCheckListResult> findPurchaseOrderCheckListResults(java.lang.String startWith,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderCheckListResultsCount

int getPurchaseOrderCheckListResultsCount(java.lang.String startWith)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

findPurchaseOrderItemsByPartPk

java.util.Collection<PurchaseOrderItemListResult> findPurchaseOrderItemsByPartPk(PartPK pk,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderItemCountByPartPk

int getPurchaseOrderItemCountByPartPk(PartPK pk)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findOpenPurchaseOrderItemsByPartPk

java.util.Collection<PurchaseOrderItemListResult> findOpenPurchaseOrderItemsByPartPk(PartPK pk,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOpenPurchaseOrderItemCountByPartPk

int getOpenPurchaseOrderItemCountByPartPk(PartPK pk)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

initPurchaseOrderItemForPart

PurchaseOrderItemVO initPurchaseOrderItemForPart(java.lang.String purchaseOrderNumber,
                                                 java.lang.String itemNumber,
                                                 PartPK partPk,
                                                 java.math.BigDecimal qty)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getRtvShipperByPoNumber

java.util.Collection<RtvShipperItemListResult> getRtvShipperByPoNumber(java.lang.String poNumber)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

findPurchaseOrderItemsByPartNumberLike

java.util.Collection<PurchaseOrderItemListResult> findPurchaseOrderItemsByPartNumberLike(java.lang.String partNumberReg,
                                                                                java.lang.String partType,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderItemCountByPartNumberLike

int getPurchaseOrderItemCountByPartNumberLike(java.lang.String partNumberReg,
                                              java.lang.String partType)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

findPurchaseOrderByPoNumber

java.util.Collection<PurchaseOrderListResult> findPurchaseOrderByPoNumber(java.lang.String poNumber,
                                                                          int firstIndex,
                                                                          int maxLength)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderCountByPoNumber

int getPurchaseOrderCountByPoNumber(java.lang.String poNumber)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findOpenPurchaseOrderByProjectLike

java.util.Collection<PurchaseOrderListResult> findOpenPurchaseOrderByProjectLike(java.lang.String projectLike,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOpenPurchaseOrderCountsByProjectLike

int getOpenPurchaseOrderCountsByProjectLike(java.lang.String projectLike)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

findOpenPurchaseOrderByRequesterLike

java.util.Collection<PurchaseOrderListResult> findOpenPurchaseOrderByRequesterLike(java.lang.String requesterLike,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOpenPurchaseOrderCountsByRequesterLike

int getOpenPurchaseOrderCountsByRequesterLike(java.lang.String requesterLike)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

findOpenPurchaseOrderNotAcknowledged

java.util.Collection<PurchaseOrderListResult> findOpenPurchaseOrderNotAcknowledged(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOpenPurchaseOrderNotAcknowledged

int getOpenPurchaseOrderNotAcknowledged()
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findPurchaseOrderByRange

java.util.Collection<PurchaseOrderListResult> findPurchaseOrderByRange(java.lang.String poStart,
                                                                       java.lang.String poEnd,
                                                                       java.lang.String vendorIdLike,
                                                                       java.lang.String status,
                                                                       int firstIndex,
                                                                       int maxLength)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderCountByRange

int getPurchaseOrderCountByRange(java.lang.String poStart,
                                 java.lang.String poEnd,
                                 java.lang.String vendorIdLike,
                                 java.lang.String status)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderItemCountByDate

int getPurchaseOrderItemCountByDate(java.lang.String dateType,
                                    java.util.Date fromDate,
                                    java.util.Date toDate,
                                    java.lang.String status,
                                    java.lang.String partNumberLike,
                                    java.lang.String partType,
                                    java.lang.String shipto,
                                    java.lang.String vendorId,
                                    java.lang.String project,
                                    java.lang.String requester,
                                    java.lang.String buyer,
                                    java.lang.String currency,
                                    java.lang.String relatedDoc,
                                    java.lang.String accountNumber,
                                    java.lang.String companyUnitId,
                                    boolean isHold,
                                    java.lang.String productCode)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findPoTotalByDateResults

java.util.Collection<TotalByDateResult> findPoTotalByDateResults(java.lang.String dateType,
                                                                 java.util.Date fromDate,
                                                                 java.util.Date toDate,
                                                                 java.lang.String status,
                                                                 java.lang.String partNumberLike,
                                                                 java.lang.String partType,
                                                                 java.lang.String shipto,
                                                                 java.lang.String vendorId,
                                                                 java.lang.String project,
                                                                 java.lang.String requester,
                                                                 java.lang.String buyer,
                                                                 java.lang.String currency,
                                                                 java.lang.String relatedDoc,
                                                                 java.lang.String accountNumber,
                                                                 java.lang.String companyUnitId,
                                                                 boolean isHold,
                                                                 java.lang.String productCode)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findPurchaseOrderItemByDate

java.util.Collection<PurchaseOrderItemListResult> findPurchaseOrderItemByDate(java.lang.String dateType,
                                                                              java.util.Date fromDate,
                                                                              java.util.Date toDate,
                                                                              java.lang.String status,
                                                                              java.lang.String partNumberLike,
                                                                              java.lang.String partType,
                                                                              java.lang.String shipto,
                                                                              java.lang.String vendorId,
                                                                              java.lang.String project,
                                                                              java.lang.String requester,
                                                                              java.lang.String buyer,
                                                                              java.lang.String currency,
                                                                              java.lang.String relatedDoc,
                                                                              java.lang.String accountNumber,
                                                                              java.lang.String companyUnitId,
                                                                              boolean isHold,
                                                                              java.lang.String productCode,
                                                                              int firstIndex,
                                                                              int maxLength)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

findAllPurchaseOrderStatistics

java.util.Collection<POStatisticsResult> findAllPurchaseOrderStatistics(java.lang.String project,
                                                                        java.lang.String relatedDoc,
                                                                        java.lang.String vendorName,
                                                                        java.lang.String requester,
                                                                        java.lang.String contact,
                                                                        int firstIndex,
                                                                        int maxLength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getAllPurchaseOrderStatisticsCount

int getAllPurchaseOrderStatisticsCount(java.lang.String project,
                                       java.lang.String relatedDoc,
                                       java.lang.String vendorName,
                                       java.lang.String requester,
                                       java.lang.String contact)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

getAllPurchaseOrderStatisticsTotal

java.util.Collection<TotalByDateResult> getAllPurchaseOrderStatisticsTotal(java.lang.String project,
                                                                           java.lang.String relatedDoc,
                                                                           java.lang.String vendorName,
                                                                           java.lang.String requester,
                                                                           java.lang.String contact)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

findOpenPurchaseOrderItems

java.util.Collection<PurchaseOrderOpenDueListResult> findOpenPurchaseOrderItems(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOpenPurchaseOrderItemCount

int getOpenPurchaseOrderItemCount()
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findPurchaseOrderItemsByPoNumber

java.util.Collection<PurchaseOrderItemVO> findPurchaseOrderItemsByPoNumber(java.lang.String poNumber)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderItemCountByPoNumber

int getPurchaseOrderItemCountByPoNumber(java.lang.String poNumber)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findOpenPurchaseOrderByBuyer

java.util.Collection<PurchaseOrderOpenDueListResult> findOpenPurchaseOrderByBuyer(java.lang.String buyer,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOpenPurchaseOrderCountByBuyer

int getOpenPurchaseOrderCountByBuyer(java.lang.String buyer)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findPastDuePurchaseOrderByBuyer

java.util.Collection<PurchaseOrderOpenDueListResult> findPastDuePurchaseOrderByBuyer(java.lang.String buyer,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPastDuePurchaseOrderCountByBuyer

int getPastDuePurchaseOrderCountByBuyer(java.lang.String buyer)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findOpenPurchaseOrderItemByBuyerCode

java.util.Collection<PurchaseOrderOpenDueListResult> findOpenPurchaseOrderItemByBuyerCode(java.lang.String buyerCode,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOpenPurchaseOrderItemCountByBuyerCode

int getOpenPurchaseOrderItemCountByBuyerCode(java.lang.String buyerCode)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findDuePurchaseOrderItemByBuyerCode

java.util.Collection<PurchaseOrderOpenDueListResult> findDuePurchaseOrderItemByBuyerCode(java.lang.String buyerCode,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getDuePurchaseOrderItemCountByBuyerCode

int getDuePurchaseOrderItemCountByBuyerCode(java.lang.String buyerCode)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

findPartByBuyerCode

java.util.Collection<PartWithInventoryInfoListResult> findPartByBuyerCode(java.lang.String buyerCode,
                                                                          java.lang.String languageCode,
                                                                          int firstIndex,
                                                                          int maxLength)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getPartByBuyerCodeCount

int getPartByBuyerCodeCount(java.lang.String buyerCode,
                            java.lang.String languageCode)
                            throws java.lang.Exception
Throws:
java.lang.Exception

isPurchaseOrderItemExistent

boolean isPurchaseOrderItemExistent(PurchaseOrderItemPK pk)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

addPurchaseOrderItem

PurchaseOrderItemVO addPurchaseOrderItem(PurchaseOrderItemVO purItemVO)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderItemByPk

PurchaseOrderItemVO getPurchaseOrderItemByPk(PurchaseOrderItemPK pk)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

updatePurchaseOrderItem

void updatePurchaseOrderItem(PurchaseOrderItemVO purItemVO)
                             throws java.lang.Exception
Throws:
java.lang.Exception

deletePurchaseOrderItem

void deletePurchaseOrderItem(PurchaseOrderItemVO purItemVO)
                             throws java.lang.Exception
Throws:
java.lang.Exception

deletePurchaseOrderItems

void deletePurchaseOrderItems(java.lang.String purchaseNumber)
                              throws java.lang.Exception
Throws:
java.lang.Exception

getPOItemsforRtv

java.util.Collection<PurchaseOrderItemVO> getPOItemsforRtv(java.lang.String purchaseNumber)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

setPurchaseOrderItemReferenceDocOne

void setPurchaseOrderItemReferenceDocOne(PurchaseOrderItemPK pk,
                                         java.lang.String referenceDoc)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

setPurchaseOrderItemReferenceDocTwo

void setPurchaseOrderItemReferenceDocTwo(PurchaseOrderItemPK pk,
                                         java.lang.String referenceDoc)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

clearPurchaseOrderItemReferenceDocOne

void clearPurchaseOrderItemReferenceDocOne(java.lang.String referenceDoc)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

clearPurchaseOrderItemReferenceDocTwo

void clearPurchaseOrderItemReferenceDocTwo(java.lang.String referenceDoc)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

clearAllReferenceDocOnesToPurchaseOrderItem

void clearAllReferenceDocOnesToPurchaseOrderItem(PurchaseOrderItemPK pk)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

clearAllReferenceDocTwoesToPurchaseOrderItem

void clearAllReferenceDocTwoesToPurchaseOrderItem(PurchaseOrderItemPK pk)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

findPastDuePurchaseOrderItems

java.util.Collection<PurchaseOrderOpenDueListResult> findPastDuePurchaseOrderItems(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPastDuePurchaseOrderItemCount

int getPastDuePurchaseOrderItemCount()
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findPastDuePurchaseOrderTotal

java.util.Collection<Money> findPastDuePurchaseOrderTotal()
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

findOpenPurchaseOrderTotal

java.util.Collection<Money> findOpenPurchaseOrderTotal()
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getOpenPurchaseOrderItemByShipViaTotal

java.util.Collection<TotalByDateResult> getOpenPurchaseOrderItemByShipViaTotal(java.lang.String vendorId,
                                                                               java.lang.String shipVia)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getOpenPurchaseOrderItemByShipVia

int getOpenPurchaseOrderItemByShipVia(java.lang.String vendorId,
                                      java.lang.String shipVia)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findOpenPurchaseOrderItemByShipVia

java.util.Collection<PurchaseOrderOpenDueListResult> findOpenPurchaseOrderItemByShipVia(java.lang.String vendorId,
                                                                                java.lang.String shipVia,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPastDuePurchaseOrderItemByShipViaTotal

java.util.Collection<TotalByDateResult> getPastDuePurchaseOrderItemByShipViaTotal(java.lang.String vendorId,
                                                                                java.lang.String shipVia)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPastDuePurchaseOrderItemByShipVia

int getPastDuePurchaseOrderItemByShipVia(java.lang.String vendorId,
                                         java.lang.String shipVia)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

findPastDuePurchaseOrderItemByShipVia

java.util.Collection<PurchaseOrderOpenDueListResult> findPastDuePurchaseOrderItemByShipVia(java.lang.String vendorId,
                                                                                java.lang.String shipVia,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findPoDueVendors

java.util.Collection<PartDueAddressListResult> findPoDueVendors()
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findAllPurchaseOrderByAddressId

java.util.Collection<PurchaseOrderListResult> findAllPurchaseOrderByAddressId(java.lang.String addressId,
                                                                              int firstIndex,
                                                                              int maxLength)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getAllPurchaseOrderCountByAddressId

int getAllPurchaseOrderCountByAddressId(java.lang.String addressId)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findOpenPurchaseOrderByAddressId

java.util.Collection<PurchaseOrderListResult> findOpenPurchaseOrderByAddressId(java.lang.String addressId,
                                                                               int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getOpenPurchaseOrderCountByAddressId

int getOpenPurchaseOrderCountByAddressId(java.lang.String addressId)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

findAllPurchaseOrderItemsByAddressId

java.util.Collection<PurchaseOrderItemListResult> findAllPurchaseOrderItemsByAddressId(java.lang.String startWith,
                                                                                java.lang.String addressId,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllPurchaseOrderItemsCountByAddressId

int getAllPurchaseOrderItemsCountByAddressId(java.lang.String startWith,
                                             java.lang.String addressId)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findOpenPurchaseOrderItemsByAddressId

java.util.Collection<PurchaseOrderItemListResult> findOpenPurchaseOrderItemsByAddressId(java.lang.String startWith,
                                                                                java.lang.String addressId,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOpenPurchaseOrderItemsCountByAddressId

int getOpenPurchaseOrderItemsCountByAddressId(java.lang.String startWith,
                                              java.lang.String addressId)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

findPastDuePurchaseOrderItemsByAddressId

java.util.Collection<PurchaseOrderItemListResult> findPastDuePurchaseOrderItemsByAddressId(java.lang.String startWith,
                                                                                java.lang.String addressId,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPastDuePurchaseOrderItemsCountByAddressId

int getPastDuePurchaseOrderItemsCountByAddressId(java.lang.String startWith,
                                                 java.lang.String addressId)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findTotalPOByRelatedDoc

java.util.Collection<TotalAmountInPOByRefDoc> findTotalPOByRelatedDoc(java.lang.String startWith,
                                                                      java.lang.String refDoc,
                                                                      java.util.Date fromDate,
                                                                      java.util.Date toDate,
                                                                      java.lang.String dateType,
                                                                      java.lang.String status,
                                                                      int firstIndex,
                                                                      int maxLength)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getTotalPOByRelatedDocCount

int getTotalPOByRelatedDocCount(java.lang.String startWith,
                                java.lang.String refDoc,
                                java.util.Date fromDate,
                                java.util.Date toDate,
                                java.lang.String dateType,
                                java.lang.String status)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findTotalPOByProject

java.util.Collection<TotalAmountInPOByRefDoc> findTotalPOByProject(java.lang.String startWith,
                                                                   java.lang.String project,
                                                                   java.util.Date fromDate,
                                                                   java.util.Date toDate,
                                                                   java.lang.String dateType,
                                                                   java.lang.String status,
                                                                   int firstIndex,
                                                                   int maxLength)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getTotalPOByProjectCount

int getTotalPOByProjectCount(java.lang.String startWith,
                             java.lang.String project,
                             java.util.Date fromDate,
                             java.util.Date toDate,
                             java.lang.String dateType,
                             java.lang.String status)
                             throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderTotalResultByRelatedDoc

java.util.Collection<TotalByDateResult> getPurchaseOrderTotalResultByRelatedDoc(java.lang.String startWith,
                                                                                java.lang.String status,
                                                                                java.lang.String dateType,
                                                                                java.util.Date startDate,
                                                                                java.util.Date toDate,
                                                                                java.lang.String relatedDoc)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findPurchaseOrderItemsByRelatedDoc

java.util.Collection<PurchaseOrderItemListResult> findPurchaseOrderItemsByRelatedDoc(java.lang.String startWith,
                                                                                java.lang.String status,
                                                                                java.lang.String dateType,
                                                                                java.util.Date startDate,
                                                                                java.util.Date toDate,
                                                                                java.lang.String relatedDoc,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderItemCountByRelatedDoc

int getPurchaseOrderItemCountByRelatedDoc(java.lang.String startWith,
                                          java.lang.String status,
                                          java.lang.String dateType,
                                          java.util.Date startDate,
                                          java.util.Date toDate,
                                          java.lang.String relatedDoc)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

findTotalPOItemByRefDoc1

java.util.Collection<TotalAmountInPOByRefDoc> findTotalPOItemByRefDoc1(java.lang.String startWith,
                                                                       java.lang.String refDoc,
                                                                       java.util.Date fromDate,
                                                                       java.util.Date toDate,
                                                                       java.lang.String dateType,
                                                                       java.lang.String status,
                                                                       int firstIndex,
                                                                       int maxLength)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getTotalPOItemByRefDoc1Count

int getTotalPOItemByRefDoc1Count(java.lang.String startWith,
                                 java.lang.String refDoc,
                                 java.util.Date fromDate,
                                 java.util.Date toDate,
                                 java.lang.String dateType,
                                 java.lang.String status)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findPurchaseOrderItemsByRefDoc1

java.util.Collection<POItemByRefDoc1ListResult> findPurchaseOrderItemsByRefDoc1(java.lang.String startWith,
                                                                                java.lang.String status,
                                                                                java.lang.String dateType,
                                                                                java.util.Date startDate,
                                                                                java.util.Date toDate,
                                                                                java.lang.String refDoc,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderItemCountByRefDoc1

int getPurchaseOrderItemCountByRefDoc1(java.lang.String startWith,
                                       java.lang.String status,
                                       java.lang.String dateType,
                                       java.util.Date startDate,
                                       java.util.Date toDate,
                                       java.lang.String refDoc)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

addPurchaseOrderApproval

PurchaseOrderApprovalVO addPurchaseOrderApproval(java.lang.String employeeId)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

updatePurchaseOrderApproval

PurchaseOrderApprovalVO updatePurchaseOrderApproval(PurchaseOrderApprovalVO purApprovalVO)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

deletePurchaseOrderApproval

void deletePurchaseOrderApproval(java.lang.String employeeId)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderApprovalByUserNumber

PurchaseOrderApprovalVO getPurchaseOrderApprovalByUserNumber(java.lang.String userName)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderApprovalByEmployeeId

PurchaseOrderApprovalVO getPurchaseOrderApprovalByEmployeeId(java.lang.String employeeId)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

isPurchaseOrderApprovalExistent

boolean isPurchaseOrderApprovalExistent(java.lang.String approvalUserName)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findAllPurchaseOrderApprovals

java.util.Collection<PurchaseOrderApprovalVO> findAllPurchaseOrderApprovals(int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getAllPurchaseOrderApprovalsCount

int getAllPurchaseOrderApprovalsCount()
                                      throws java.lang.Exception
Throws:
java.lang.Exception

addRequestForQuote

RequestForQuoteVO addRequestForQuote(java.lang.String vendorId)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

addRequestForQuote

RequestForQuoteVO addRequestForQuote(java.lang.String vendorId,
                                     java.lang.String oldRFQNumber,
                                     boolean includeItems)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

addRfqFromQuote

RequestForQuoteVO addRfqFromQuote(java.lang.String vendorId,
                                  java.lang.String quoteNumber)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

addRfqFromSO

RequestForQuoteVO addRfqFromSO(java.lang.String vendorId,
                               java.lang.String soNumber,
                               boolean isCopyMpn)
                               throws java.lang.Exception
Throws:
java.lang.Exception

addPOWSFromSO

PurchaseWorkSheetVO addPOWSFromSO(java.lang.String soNumber)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

addPOWSFromQuote

PurchaseWorkSheetVO addPOWSFromQuote(java.lang.String qtNumber)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

updateRequestForQuote

java.lang.String updateRequestForQuote(RequestForQuoteVO rfqVO)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

approveRequestForQuote

RequestForQuoteVO approveRequestForQuote(RequestForQuoteVO rfqVo)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

approveRequestForQuote

RequestForQuoteVO approveRequestForQuote(java.lang.String rfqNumber)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

deleteRequestForQuote

void deleteRequestForQuote(RequestForQuoteVO rfqVO)
                           throws java.lang.Exception
Throws:
java.lang.Exception

isRFQMessageItemExist

boolean isRFQMessageItemExist(RequestForQuoteItemPK pk)
                              throws java.lang.Exception
Throws:
java.lang.Exception

isRequestForQuoteExistent

boolean isRequestForQuoteExistent(java.lang.String requestForQuoteNumber)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

getRequestForQuoteStatus

java.lang.String getRequestForQuoteStatus(java.lang.String requestForQuoteNumber)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

isRequestForQuoteOPEN

boolean isRequestForQuoteOPEN(java.lang.String requestForQuoteNumber)
                              throws java.lang.Exception
Throws:
java.lang.Exception

findRequestForQuoteItemListResults

java.util.Collection<RequestForQuoteItemListResult> findRequestForQuoteItemListResults(java.lang.String partNumberLike,
                                                                                java.lang.String partType,
                                                                                java.lang.String status,
                                                                                boolean isDue,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getRequestForQuoteItemListResultsCount

int getRequestForQuoteItemListResultsCount(java.lang.String partNumberLike,
                                           java.lang.String partType,
                                           java.lang.String status,
                                           boolean isDue)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

findRequestForQuoteItemListResults

java.util.Collection<RequestForQuoteItemListResult> findRequestForQuoteItemListResults(java.lang.String partNumberLike,
                                                                                java.lang.String partType,
                                                                                java.lang.String status,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getRequestForQuoteItemListResultsCount

int getRequestForQuoteItemListResultsCount(java.lang.String partNumberLike,
                                           java.lang.String partType,
                                           java.lang.String status)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

findRequestForQuoteItemListResultsByPartNumberLike

java.util.Collection<RequestForQuoteItemListResult> findRequestForQuoteItemListResultsByPartNumberLike(java.lang.String partNumberLike,
                                                                                java.lang.String partType,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getRequestForQuoteItemListResultsCountByPartNumberLike

int getRequestForQuoteItemListResultsCountByPartNumberLike(java.lang.String partNumberLike,
                                                           java.lang.String partType)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

findOpenRequestForQuoteItemListResults

java.util.Collection<RequestForQuoteItemListResult> findOpenRequestForQuoteItemListResults(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOpenRequestForQuoteItemListResultsCount

int getOpenRequestForQuoteItemListResultsCount()
                                               throws java.lang.Exception
Throws:
java.lang.Exception

findCancelledRequestForQuoteItemListResults

java.util.Collection<RequestForQuoteItemListResult> findCancelledRequestForQuoteItemListResults(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getCancelledRequestForQuoteItemListResultsCount

int getCancelledRequestForQuoteItemListResultsCount()
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

findDueRequestForQuoteItemListResults

java.util.Collection<RequestForQuoteItemListResult> findDueRequestForQuoteItemListResults(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getDueRequestForQuoteItemListResultsCount

int getDueRequestForQuoteItemListResultsCount()
                                              throws java.lang.Exception
Throws:
java.lang.Exception

initRequestForQuoteItemForPart

RequestForQuoteItemVO initRequestForQuoteItemForPart(java.lang.String requestForQuoteNumber,
                                                     java.lang.String itemNum,
                                                     PartPK partPk,
                                                     java.math.BigDecimal qty,
                                                     java.lang.String languageCode)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

initRequestForQuoteItemForTool

RequestForQuoteItemVO initRequestForQuoteItemForTool(java.lang.String requestForQuoteNumber,
                                                     java.lang.String itemNum,
                                                     PartPK partPk,
                                                     java.math.BigDecimal qty,
                                                     java.lang.String languageCode)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getRequestForQuoteByRfqNumber

RequestForQuoteVO getRequestForQuoteByRfqNumber(java.lang.String rfqNumber)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

findRequestForQuoteListResults

java.util.Collection<RequestForQuoteListResult> findRequestForQuoteListResults(java.lang.String rfqNumber,
                                                                               java.lang.String status,
                                                                               java.lang.String vendId,
                                                                               int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getRequestForQuoteListResultsCount

int getRequestForQuoteListResultsCount(java.lang.String rfqNumber,
                                       java.lang.String status,
                                       java.lang.String vendId)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findRequestForQuoteListResultsByRfqNumber

java.util.Collection<RequestForQuoteListResult> findRequestForQuoteListResultsByRfqNumber(java.lang.String rfqNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getRequestForQuoteListResultsCountByRfqNumber

int getRequestForQuoteListResultsCountByRfqNumber(java.lang.String rfqNumber)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

findRequestForQuoteListResultsByVendorId

java.util.Collection<RequestForQuoteListResult> findRequestForQuoteListResultsByVendorId(java.lang.String vendorId,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getRequestForQuoteListResultsCountByVendorId

int getRequestForQuoteListResultsCountByVendorId(java.lang.String vendorId)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findReturnToVendorItemListResults

java.util.Collection<ReturnToVendorItemListResult> findReturnToVendorItemListResults(java.lang.String partNumberLike,
                                                                                java.lang.String partType,
                                                                                java.lang.String status,
                                                                                boolean isDue,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getReturnToVendorItemListResultsCount

int getReturnToVendorItemListResultsCount(java.lang.String partNumberLike,
                                          java.lang.String partType,
                                          java.lang.String status,
                                          boolean isDue)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

findReturnToVendorItemsListResults

java.util.Collection<ReturnToVendorByDateListResult> findReturnToVendorItemsListResults(java.lang.String partnumber,
                                                                                java.lang.String parttype,
                                                                                java.lang.String status,
                                                                                java.lang.String shipto,
                                                                                java.lang.String vendorId,
                                                                                java.lang.String po,
                                                                                java.lang.String ncrNumber,
                                                                                java.lang.String accountNumber,
                                                                                java.lang.String companyUnitId,
                                                                                boolean isRtvDate,
                                                                                java.util.Date startDate,
                                                                                java.util.Date toDate,
                                                                                java.lang.String project,
                                                                                java.lang.String requester,
                                                                                java.lang.String buyer,
                                                                                java.lang.String enterBy,
                                                                                java.lang.String currency,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getReturnToVendorItemsListResultsCount

int getReturnToVendorItemsListResultsCount(java.lang.String partnumber,
                                           java.lang.String parttype,
                                           java.lang.String status,
                                           java.lang.String shipto,
                                           java.lang.String vendorId,
                                           java.lang.String po,
                                           java.lang.String ncrNumber,
                                           java.lang.String accountNumber,
                                           java.lang.String companyUnitId,
                                           boolean isRtvDate,
                                           java.util.Date startDate,
                                           java.util.Date toDate,
                                           java.lang.String project,
                                           java.lang.String requester,
                                           java.lang.String buyer,
                                           java.lang.String enterBy,
                                           java.lang.String currency)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

findCancelledReturnToVendorItemsListResults

java.util.Collection<ReturnToVendorByDateListResult> findCancelledReturnToVendorItemsListResults(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getCancelledReturnToVendorItemsListResultsCount

int getCancelledReturnToVendorItemsListResultsCount()
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

findReturnToVendorItemsListResults

java.util.Collection<ReturnToVendorByDateListResult> findReturnToVendorItemsListResults(java.lang.String partnumber,
                                                                                java.lang.String parttype,
                                                                                java.lang.String status,
                                                                                java.lang.String shipto,
                                                                                java.lang.String vendorId,
                                                                                java.lang.String po,
                                                                                java.lang.String ncrNumber,
                                                                                java.lang.String accountNumber,
                                                                                java.lang.String companyUnitId,
                                                                                boolean isRtvDate,
                                                                                java.util.Date startDate,
                                                                                java.util.Date toDate,
                                                                                java.lang.String project,
                                                                                java.lang.String requester,
                                                                                java.lang.String buyer,
                                                                                java.lang.String enterBy,
                                                                                java.lang.String refDoc,
                                                                                java.lang.String currency,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getReturnToVendorItemsListResultsCount

int getReturnToVendorItemsListResultsCount(java.lang.String partnumber,
                                           java.lang.String parttype,
                                           java.lang.String status,
                                           java.lang.String shipto,
                                           java.lang.String vendorId,
                                           java.lang.String po,
                                           java.lang.String ncrNumber,
                                           java.lang.String accountNumber,
                                           java.lang.String companyUnitId,
                                           boolean isRtvDate,
                                           java.util.Date startDate,
                                           java.util.Date toDate,
                                           java.lang.String project,
                                           java.lang.String requester,
                                           java.lang.String buyer,
                                           java.lang.String enterBy,
                                           java.lang.String refDoc,
                                           java.lang.String currency)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

findReturnToVendorItemListResults

java.util.Collection<ReturnToVendorItemListResult> findReturnToVendorItemListResults(java.lang.String partNumberLike,
                                                                                java.lang.String partType,
                                                                                java.lang.String status,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getReturnToVendorItemListResultsCount

int getReturnToVendorItemListResultsCount(java.lang.String partNumberLike,
                                          java.lang.String partType,
                                          java.lang.String status)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

findReturnToVendorItemListResultsByPartNumberLike

java.util.Collection<ReturnToVendorItemListResult> findReturnToVendorItemListResultsByPartNumberLike(java.lang.String partNumberLike,
                                                                                java.lang.String partType,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getReturnToVendorItemListResultsCountByPartNumberLike

int getReturnToVendorItemListResultsCountByPartNumberLike(java.lang.String partNumberLike,
                                                          java.lang.String partType)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

findOpenReturnToVendorItemListResults

java.util.Collection<ReturnToVendorItemListResult> findOpenReturnToVendorItemListResults(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOpenReturnToVendorItemListResultsCount

int getOpenReturnToVendorItemListResultsCount()
                                              throws java.lang.Exception
Throws:
java.lang.Exception

findDueReturnToVendorItemListResults

java.util.Collection<ReturnToVendorItemListResult> findDueReturnToVendorItemListResults(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getDueReturnToVendorItemListResultsCount

int getDueReturnToVendorItemListResultsCount()
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findAllRfqCheckListResults

java.util.Collection<RequestForQuoteCheckListResult> findAllRfqCheckListResults(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllRfqCheckListResultsCount

int getAllRfqCheckListResultsCount()
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findRfqCheckListResults

java.util.Collection<RequestForQuoteCheckListResult> findRfqCheckListResults(java.lang.String startWith,
                                                                             int firstIndex,
                                                                             int maxLength)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getRfqCheckListResultsCount

int getRfqCheckListResultsCount(java.lang.String startWith)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findReturnToVendorListResults

java.util.Collection<ReturnToVendorListResult> findReturnToVendorListResults(java.lang.String rtvNumber,
                                                                             java.lang.String status,
                                                                             java.lang.String vendId,
                                                                             int firstIndex,
                                                                             int maxLength)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getReturnToVendorListResultsCount

int getReturnToVendorListResultsCount(java.lang.String rtvNumber,
                                      java.lang.String status,
                                      java.lang.String vendId)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findReturnToVendorListResultsByRtvNumber

java.util.Collection<ReturnToVendorListResult> findReturnToVendorListResultsByRtvNumber(java.lang.String rtvNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getReturnToVendorListResultsCountByRtvNumber

int getReturnToVendorListResultsCountByRtvNumber(java.lang.String rtvNumber)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findReturnToVendorListResultsByVendorId

java.util.Collection<ReturnToVendorListResult> findReturnToVendorListResultsByVendorId(java.lang.String vendorId,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getReturnToVendorListResultsCountByVendorId

int getReturnToVendorListResultsCountByVendorId(java.lang.String vendorId)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

findOpenReturnToVendorListResultsByRtvNumber

java.util.Collection<ReturnToVendorListResult> findOpenReturnToVendorListResultsByRtvNumber(java.lang.String rtvNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOpenReturnToVendorListResultsCountByRtvNumber

int getOpenReturnToVendorListResultsCountByRtvNumber(java.lang.String rtvNumber)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

findAllRtvCheckListResults

java.util.Collection<ReturnToVendorCheckListResult> findAllRtvCheckListResults(int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getAllRtvCheckListResultsCount

int getAllRtvCheckListResultsCount()
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findRtvCheckListResults

java.util.Collection<ReturnToVendorCheckListResult> findRtvCheckListResults(java.lang.String startWith,
                                                                            int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getRtvCheckListResultsCount

int getRtvCheckListResultsCount(java.lang.String startWith)
                                throws java.lang.Exception
Throws:
java.lang.Exception

addReturnToVendor

java.lang.String addReturnToVendor(AddRTVAgent agent)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

updateReturnToVendor

java.lang.String updateReturnToVendor(ReturnToVendorVO rtvVO)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

approveReturnToVendor

java.lang.String approveReturnToVendor(ReturnToVendorVO rtvVO)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

approveReturnToVendor

java.lang.String approveReturnToVendor(java.lang.String rtvNumber)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

deleteReturnToVendor

void deleteReturnToVendor(ReturnToVendorVO rtvVO)
                          throws java.lang.Exception
Throws:
java.lang.Exception

isReturnToVendorExistent

boolean isReturnToVendorExistent(java.lang.String returnToVendorNumber)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

getReturnToVendorStatus

java.lang.String getReturnToVendorStatus(java.lang.String returnToVendorNumber)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

getReturnToVendorByRtvNumber

ReturnToVendorVO getReturnToVendorByRtvNumber(java.lang.String rtvNumber)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

initReturnToVendorItemForPart

ReturnToVendorItemVO initReturnToVendorItemForPart(java.lang.String rtvNumber,
                                                   java.lang.String itemNum,
                                                   PartPK partPk,
                                                   java.math.BigDecimal qty)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

initReturnToVendorItemForTool

ReturnToVendorItemVO initReturnToVendorItemForTool(java.lang.String rtvNumber,
                                                   java.lang.String itemNum,
                                                   PartPK partPk,
                                                   java.math.BigDecimal qty)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

uploadOrUpdatePODoc

java.util.Collection<PurchaseOrderDocumentVO> uploadOrUpdatePODoc(MiscDocAgent agent)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

downloadPODoc

BB2File downloadPODoc(MiscDocAgent agent)
                      throws java.lang.Exception
Throws:
java.lang.Exception

deletePODoc

java.util.Collection<PurchaseOrderDocumentVO> deletePODoc(MiscDocAgent agent)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderDocumentByID

PurchaseOrderDocumentVO getPurchaseOrderDocumentByID(java.lang.Long controlNumber)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getMrpResult

BB2PartMrpResult getMrpResult(BB2Part part)
                              throws java.lang.Exception
Throws:
java.lang.Exception

getPartPKList

java.util.Collection<PartPK> getPartPKList(MrpReportAgent agent)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

findPartInMrpListResult

java.util.Collection<PartInMrpListResult> findPartInMrpListResult(java.util.List<PartPK> partPks)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getMrpItemResult

MrpItemResult getMrpItemResult(PartPK pk,
                               boolean minQty,
                               boolean includeTolerance)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getMrpItemResult

MrpItemResult getMrpItemResult(PartPK part,
                               MrpReportAgent tmp)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getMrpItemOrderDemandRecordsResult

MrpItemOrderDemandRecordsResult getMrpItemOrderDemandRecordsResult(PartPK part,
                                                                   MrpReportAgent agent)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getAuditLog

AuditLogVO getAuditLog()
                       throws java.lang.Exception
Throws:
java.lang.Exception

addPurchaseWorkSheet

PurchaseWorkSheetVO addPurchaseWorkSheet()
                                         throws java.lang.Exception
Throws:
java.lang.Exception

addPurchaseWorkSheet

PurchaseWorkSheetVO addPurchaseWorkSheet(PurchaseWorkSheetVO pwsVO)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

addPurchaseWorkSheet

PurchaseWorkSheetVO addPurchaseWorkSheet(java.util.ArrayList list)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

updatePurchaseWorkSheet

PurchaseWorkSheetVO updatePurchaseWorkSheet(PurchaseWorkSheetVO pwsVO)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

deletePurchaseWorkSheet

void deletePurchaseWorkSheet(PurchaseWorkSheetVO pwsVO)
                             throws java.lang.Exception
Throws:
java.lang.Exception

isPurchaseWorkSheetExistent

boolean isPurchaseWorkSheetExistent(PurchaseWorkSheetPK pk)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseWorkSheetByPk

PurchaseWorkSheetVO getPurchaseWorkSheetByPk(PurchaseWorkSheetPK pk)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

makePurchaseOrders

java.util.Collection<PurchaseOrderListResult> makePurchaseOrders(PurchaseWorkSheetVO pwsVO)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

makeRequestForQuotes

java.util.Collection<RequestForQuoteListResult> makeRequestForQuotes(PurchaseWorkSheetVO pwsVO)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

findAllPurchaseWorkSheet

java.util.Collection<PurchaseWorkSheetVO> findAllPurchaseWorkSheet(int firstIndex,
                                                                   int maxLength)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getAllPurchaseWorkSheetCount

int getAllPurchaseWorkSheetCount()
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findMyPurchaseWorkSheet

java.util.Collection<PurchaseWorkSheetVO> findMyPurchaseWorkSheet(int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getMyPurchaseWorkSheetByCount

int getMyPurchaseWorkSheetByCount()
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findPurchaseWorkSheetByEmployeeId

java.util.Collection<PurchaseWorkSheetVO> findPurchaseWorkSheetByEmployeeId(java.lang.String employeeId,
                                                                            boolean isMfrPurchaseWorkSheet,
                                                                            int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseWorkSheetByCountByEmployeeId

int getPurchaseWorkSheetByCountByEmployeeId(java.lang.String employeeId)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

findPurchaseWorkSheetByEmployeeEmailLike

java.util.Collection<PurchaseWorkSheetVO> findPurchaseWorkSheetByEmployeeEmailLike(java.lang.String employeeEmailLike,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseWorkSheetCountByEmployeeEmailLike

int getPurchaseWorkSheetCountByEmployeeEmailLike(java.lang.String employeeEmailLike)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

addPurchaseWorkSheetItem

PurchaseWorkSheetItemVO addPurchaseWorkSheetItem(PurchaseWorkSheetItemVO pwsItemVO)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

updatePurchaseWorkSheetItem

void updatePurchaseWorkSheetItem(PurchaseWorkSheetItemVO pwsItemVO)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

deletePurchaseWorkSheetItem

void deletePurchaseWorkSheetItem(PurchaseWorkSheetItemVO pwsItemVO)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findPurchaseWorkSheetItemsByWorkSheetPk

java.util.Collection<PurchaseWorkSheetItemWithRelatedInfoResult> findPurchaseWorkSheetItemsByWorkSheetPk(PurchaseWorkSheetPK workSheetPk)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

initPurchaseWorkSheetItemForPart

PurchaseWorkSheetItemWithRelatedInfoResult initPurchaseWorkSheetItemForPart(PurchaseWorkSheetPK pk,
                                                                            java.lang.String itemNum,
                                                                            PartPK partPk,
                                                                            java.math.BigDecimal qty)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getAuditResults

java.util.Collection<AuditOnDemandResult> getAuditResults()
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

auditing

java.util.Collection<AuditOnDemandResult> auditing(java.util.ArrayList list)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

addPurchaseOrderBP

PurchaseOrderBoilerplateVO addPurchaseOrderBP(PurchaseOrderBoilerplateVO vo)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

deletePurchaseOrderBP

void deletePurchaseOrderBP(java.lang.String bpID)
                           throws java.lang.Exception
Throws:
java.lang.Exception

updatePurchaseOrderBP

PurchaseOrderBoilerplateVO updatePurchaseOrderBP(PurchaseOrderBoilerplateVO vo)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getAllPurchaseOrderBPCount

int getAllPurchaseOrderBPCount()
                               throws java.lang.Exception
Throws:
java.lang.Exception

findAllPurchaseOrderBP

java.util.Collection<PurchaseOrderBoilerplateVO> findAllPurchaseOrderBP(int firstIndex,
                                                                        int maxLength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderBPCountBybpID

int getPurchaseOrderBPCountBybpID(java.lang.String bpId)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findPurchaseOrderBPBybpID

java.util.Collection<PurchaseOrderBoilerplateVO> findPurchaseOrderBPBybpID(java.lang.String bpId,
                                                                           int firstIndex,
                                                                           int maxLength)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderBPByPk

PurchaseOrderBoilerplateVO getPurchaseOrderBPByPk(java.lang.String purchaseOrderBoilerplateId)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

isPurchaseOrderBoilerplateExist

boolean isPurchaseOrderBoilerplateExist(java.lang.String purchaseOrderBoilerplateId)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

addRefdocTwo

RefdocVO addRefdocTwo(PurchaseOrderItemPK poItemPk,
                      java.lang.String orderNumber,
                      java.lang.String itemNumber,
                      java.math.BigDecimal refdocQty)
                      throws java.lang.Exception
Throws:
java.lang.Exception

updateRefdocTwo

RefdocVO updateRefdocTwo(RefdocVO vo)
                         throws java.lang.Exception
Throws:
java.lang.Exception

deleteRefdocTwo

void deleteRefdocTwo(BB2RefdocPK pk)
                     throws java.lang.Exception
Throws:
java.lang.Exception

isPurchaseOrderInMyPrintList

boolean isPurchaseOrderInMyPrintList(java.lang.String purchaseOrderNumber)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

deleteMyPrintList

void deleteMyPrintList(java.util.ArrayList poNumberList)
                       throws java.lang.Exception
Throws:
java.lang.Exception

addMyPrintList

MyPrintListVO addMyPrintList(java.lang.String soNumber)
                             throws java.lang.Exception
Throws:
java.lang.Exception

clearMyPurchaseOrderPrintList

boolean clearMyPurchaseOrderPrintList(java.lang.String purchaseOrderNumberLike)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findMyPoPrintList

java.util.Collection<PurchaseOrderListResult> findMyPoPrintList()
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findAllPartTraceableByPN

java.util.Collection<PartTraceableInfoResult> findAllPartTraceableByPN(java.lang.String poNumber)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderItemDwf

java.util.Collection<PartDwfAgent> getPurchaseOrderItemDwf(java.lang.String purchaseOrderNumber)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getRfqOrderItemDwf

java.util.Collection<PartDwfAgent> getRfqOrderItemDwf(java.lang.String rfqNumber)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

findBB2PartOnDemandListResultForPart

java.util.Collection<BB2PartOnDemandListResult> findBB2PartOnDemandListResultForPart(boolean compessSuff,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getBB2PartOnDemandListResultForPart

int getBB2PartOnDemandListResultForPart(boolean compessSuff)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

addRfqMessage

RfqMessageVO addRfqMessage(java.lang.String rfqNumber)
                           throws java.lang.Exception
Throws:
java.lang.Exception

isRfqMessageExistent

boolean isRfqMessageExistent(java.lang.String rfqMessageNumber)
                             throws java.lang.Exception
Throws:
java.lang.Exception

validateRfqMessage

boolean validateRfqMessage(java.lang.String rfqMessageNumber,
                           java.lang.String valicateCode)
                           throws java.lang.Exception
Throws:
java.lang.Exception

getRfqMessage

RfqMessageVO getRfqMessage(java.lang.String rfqMessageNumber)
                           throws java.lang.Exception
Throws:
java.lang.Exception

getRfqMessageByRfqNumber

RfqMessageVO getRfqMessageByRfqNumber(java.lang.String rfqNumber)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

updateRfqMessage

RfqMessageVO updateRfqMessage(RfqMessageVO vo)
                              throws java.lang.Exception
Throws:
java.lang.Exception

getRfqMessageStatus

java.lang.String getRfqMessageStatus(java.lang.String rfqNumber)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findAllRfqMessages

java.util.Collection<RfqMessageListResult> findAllRfqMessages()
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getAllRfqMessageCount

int getAllRfqMessageCount()
                          throws java.lang.Exception
Throws:
java.lang.Exception

findRfqMessagesByStatusAndID

java.util.Collection<RfqMessageListResult> findRfqMessagesByStatusAndID(java.lang.String[] status,
                                                                        java.lang.String vendorIdLike,
                                                                        int firstIndex,
                                                                        int maxLength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getRfqMessageCountByStatusAndID

int getRfqMessageCountByStatusAndID(java.lang.String[] status,
                                    java.lang.String vendorIdLike)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

acceptRfqMessage

RfqMessageVO acceptRfqMessage(java.lang.String rfqMessageNumber,
                              java.lang.String comments,
                              java.util.Hashtable itemComments,
                              boolean updatePartVendor)
                              throws java.lang.Exception
Throws:
java.lang.Exception

refuseRfqMessage

RfqMessageVO refuseRfqMessage(java.lang.String rfqMessageNumber,
                              java.lang.String comments,
                              java.util.Hashtable itemComments,
                              boolean resend,
                              boolean updateRfq)
                              throws java.lang.Exception
Throws:
java.lang.Exception

saveRfqMessage

RfqMessageVO saveRfqMessage(java.lang.String rfqMessageNumber,
                            java.lang.String comments,
                            java.util.Hashtable itemComments)
                            throws java.lang.Exception
Throws:
java.lang.Exception

addPoMessage

PoMessageVO addPoMessage(java.lang.String poNumber)
                         throws java.lang.Exception
Throws:
java.lang.Exception

isPoMessageExistent

boolean isPoMessageExistent(java.lang.String poNumber)
                            throws java.lang.Exception
Throws:
java.lang.Exception

validatePoMessage

boolean validatePoMessage(java.lang.String poMessageNumber,
                          java.lang.String valicateCode)
                          throws java.lang.Exception
Throws:
java.lang.Exception

getPoMessage

PoMessageVO getPoMessage(java.lang.String poMessageNumber)
                         throws java.lang.Exception
Throws:
java.lang.Exception

getPoMessageByPoNumber

PoMessageVO getPoMessageByPoNumber(java.lang.String poNumber)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

updatePoMessageByVendor

PoMessageVO updatePoMessageByVendor(PoMessageVO vo)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

approvePoMessageByVendor

void approvePoMessageByVendor(java.lang.String poMessageNumber,
                              java.lang.String vendorUserName)
                              throws java.lang.Exception
Throws:
java.lang.Exception

getPoMessageStatus

java.lang.String getPoMessageStatus(java.lang.String poNumber)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findAllPoMessages

java.util.Collection<PoMessageListResult> findAllPoMessages()
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getAllPoMessageCount

int getAllPoMessageCount()
                         throws java.lang.Exception
Throws:
java.lang.Exception

findPoMessagesByStatusAndID

java.util.Collection<PoMessageListResult> findPoMessagesByStatusAndID(java.lang.String[] status,
                                                                      java.lang.String vendorIdLike,
                                                                      int firstIndex,
                                                                      int maxLength)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getPoMessageCountByStatusAndID

int getPoMessageCountByStatusAndID(java.lang.String[] status,
                                   java.lang.String vendorIdLike)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

acceptPoMessage

PoMessageVO acceptPoMessage(java.lang.String poMessageNumber,
                            java.lang.String comments,
                            java.util.Hashtable itemComments)
                            throws java.lang.Exception
Throws:
java.lang.Exception

refusePoMessage

PoMessageVO refusePoMessage(java.lang.String poMessageNumber,
                            java.lang.String comments,
                            java.util.Hashtable itemComments,
                            boolean updatePo)
                            throws java.lang.Exception
Throws:
java.lang.Exception

savePoMessage

PoMessageVO savePoMessage(java.lang.String poMessageNumber,
                          java.lang.String comments,
                          java.util.Hashtable itemComments)
                          throws java.lang.Exception
Throws:
java.lang.Exception

createPO2SOExchange

PO2SOExchange createPO2SOExchange(java.lang.String poNumber)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

addPfReceiver

java.lang.String addPfReceiver(java.lang.String vendorId)
                               throws java.lang.Exception
Throws:
java.lang.Exception

addPfReceiver

java.lang.String addPfReceiver(ProformaReceiverPackingBoxAgent agent)
                               throws java.lang.Exception
Throws:
java.lang.Exception

initProformaReceiverPackingBoxs

ProformaReceiverPackingBoxAgent initProformaReceiverPackingBoxs(ProformaInvoiceVO pfVo,
                                                                java.lang.String vendorId)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

isPfReceiverExistent

boolean isPfReceiverExistent(java.lang.String pfReceiverNumber)
                             throws java.lang.Exception
Throws:
java.lang.Exception

getPfReceiver

PfReceiverVO getPfReceiver(java.lang.String pfReceiverNumber)
                           throws java.lang.Exception
Throws:
java.lang.Exception

updatePfReceiver

void updatePfReceiver(PfReceiverVO vo)
                      throws java.lang.Exception
Throws:
java.lang.Exception

deletePfReceiver

void deletePfReceiver(java.lang.String pfReceiverNumber)
                      throws java.lang.Exception
Throws:
java.lang.Exception

finishProformaReceiver

java.lang.String finishProformaReceiver(java.lang.String pfReceiverNumber,
                                        FinishProformaReceiverAgent agent)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

finishProformaReceiver

java.lang.String finishProformaReceiver(java.lang.String pfReceiverNumber,
                                        PfReceiverItemVO itemVO,
                                        java.util.HashSet<PrPackingBoxItemVO> boxItemVOs,
                                        java.lang.String receiverNumber)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

getAllPfReceiversCount

int getAllPfReceiversCount()
                           throws java.lang.Exception
Throws:
java.lang.Exception

findAllPfReceivers

java.util.Collection<PrReceiverListResult> findAllPfReceivers(int firstIndex,
                                                              int maxLength)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getPfReceiversCountByPfNumber

int getPfReceiversCountByPfNumber(java.lang.String pfReceiverNumberLike)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findPfReceiversByPfNumber

java.util.Collection<PrReceiverListResult> findPfReceiversByPfNumber(java.lang.String pfReceiverNumberLike,
                                                                     int firstIndex,
                                                                     int maxLength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getPfReceiversCountByVendorId

int getPfReceiversCountByVendorId(java.lang.String vendorId)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findPfReceiversByVendorId

java.util.Collection<PrReceiverListResult> findPfReceiversByVendorId(java.lang.String vendorId,
                                                                     int firstIndex,
                                                                     int maxLength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getPfReceiversOpenCountByVendorId

int getPfReceiversOpenCountByVendorId(java.lang.String vendorId)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findPfReceiversOpenByVendorId

java.util.Collection<PrReceiverListResult> findPfReceiversOpenByVendorId(java.lang.String vendorId,
                                                                         int firstIndex,
                                                                         int maxLength)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getPrPackingBox

PrPackingBoxVO getPrPackingBox(PrPackingBoxPK pk)
                               throws java.lang.Exception
Throws:
java.lang.Exception

executeDaoMethod

java.lang.Object executeDaoMethod(java.lang.String daoName,
                                  java.lang.String methodName,
                                  java.lang.Object[] values,
                                  java.lang.Class[] types)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

execute

java.lang.Object execute(java.lang.String excuterName,
                         java.lang.Object[] values,
                         java.lang.Class[] types)
                         throws java.lang.Exception
Throws:
java.lang.Exception

addRTVApproval

java.lang.String addRTVApproval(java.lang.String employeeID)
                                throws java.lang.Exception
Throws:
java.lang.Exception

updateRTVApproval

java.lang.String updateRTVApproval(RTVApprovalVO vo)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

deleteRTVApproval

void deleteRTVApproval(java.lang.String employeeID)
                       throws java.lang.Exception
Throws:
java.lang.Exception

getRTVApproval

RTVApprovalVO getRTVApproval(java.lang.String employeeID)
                             throws java.lang.Exception
Throws:
java.lang.Exception

findAllRTVApprovals

java.util.Collection<RTVApprovalVO> findAllRTVApprovals(int firstIndex,
                                                        int maxLength)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getAllRTVApprovalsCount

int getAllRTVApprovalsCount()
                            throws java.lang.Exception
Throws:
java.lang.Exception

addVendorContractPrice

java.lang.String addVendorContractPrice(VendorContractPriceVO vo)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

updateVendorContractPrice

java.lang.String updateVendorContractPrice(VendorContractPriceVO vo)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

deleteVendorContractPrice

void deleteVendorContractPrice(VendorContractPriceVO cpVO)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getVendorContractPriceById

VendorContractPriceVO getVendorContractPriceById(java.lang.String cpNumber)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

isVendorContractPriceExistent

boolean isVendorContractPriceExistent(java.lang.String contractNumber)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findAllVendorContracts

java.util.Collection<VendorContractPriceVO> findAllVendorContracts(int firstIndex,
                                                                   int maxLength)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getAllVendorContractsCount

int getAllVendorContractsCount()
                               throws java.lang.Exception
Throws:
java.lang.Exception

findVendorContractsByContractNumber

java.util.Collection<VendorContractPriceVO> findVendorContractsByContractNumber(java.lang.String contractNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getVendorContractsCountByContractNumber

int getVendorContractsCountByContractNumber(java.lang.String contractNumber)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

addVendorContractPriceVendor

VendorContractPriceVendorVO addVendorContractPriceVendor(VendorContractPriceVendorVO vo)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

updateVendorContractPriceVendor

VendorContractPriceVendorVO updateVendorContractPriceVendor(VendorContractPriceVendorVO vo)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

deleteVendorContractPriceVendor

void deleteVendorContractPriceVendor(VendorContractPriceVendorVO cpcVO)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

getVendorContractPriceVendor

VendorContractPriceVendorVO getVendorContractPriceVendor(VendorContractPriceVendorPK pk)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

isVendorContractPriceVendorExistent

boolean isVendorContractPriceVendorExistent(VendorContractPriceVendorPK pk)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

findContractVendorsByContractNumber

java.util.Collection<VendorContractPriceVendorVO> findContractVendorsByContractNumber(java.lang.String contractNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getContractVendorsCountByContractNumber

int getContractVendorsCountByContractNumber(java.lang.String contractNumber)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

addVendorContractPriceItem

VendorContractPriceItemVO addVendorContractPriceItem(VendorContractPriceItemVO vo)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

addVendorContractPriceItems

java.util.Collection<VendorContractPriceItemVO> addVendorContractPriceItems(java.util.ArrayList list)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

updateVendorContractPriceItem

VendorContractPriceItemVO updateVendorContractPriceItem(VendorContractPriceItemVO vo)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

deleteVendorContractPriceItem

void deleteVendorContractPriceItem(VendorContractPriceItemVO cpiVO)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

getVendorContractPriceItem

VendorContractPriceItemVO getVendorContractPriceItem(VendorContractPriceItemPK pk)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

isVendorContractPriceItemExistent

boolean isVendorContractPriceItemExistent(VendorContractPriceItemPK pk)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

findVendorContractItemsByContractNumber

java.util.Collection<VendorContractPriceItemVO> findVendorContractItemsByContractNumber(java.lang.String contractNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getVendorContractItemsCountByContractNumber

int getVendorContractItemsCountByContractNumber(java.lang.String contractNumber)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

findVendorContractsByAddressId

java.util.Collection<VendorContractPriceVendorVO> findVendorContractsByAddressId(java.lang.String addressIdRegex,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getVendorContractsByAddressIdCount

int getVendorContractsByAddressIdCount(java.lang.String addressIdRegex)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

checkOrderItemExist

boolean checkOrderItemExist(OrderPK pk)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findVendorOnTimeDeliveryRateByVendorId

java.util.Collection<OntimeDeliveryRateListResult> findVendorOnTimeDeliveryRateByVendorId(java.lang.String vendorId,
                                                                                java.util.Date from,
                                                                                java.util.Date to,
                                                                                java.lang.String dateType,
                                                                                int delayDays,
                                                                                int beforeDays,
                                                                                boolean includeInSit,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getVendorOnTimeDeliveryRateCountByVendorId

int getVendorOnTimeDeliveryRateCountByVendorId(java.lang.String vendorId,
                                               java.util.Date from,
                                               java.util.Date to,
                                               java.lang.String dateType,
                                               int delayDays,
                                               int beforeDays,
                                               boolean includeInSit)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

getVendorOnTimeDeliveryRate

OntimeDeliveryRateResult getVendorOnTimeDeliveryRate(java.lang.String vendorId,
                                                     java.util.Date from,
                                                     java.util.Date to,
                                                     java.lang.String dateType,
                                                     int delayDays,
                                                     int beforeDays,
                                                     boolean includeInSit)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getLast12MonthOntimeDeliveryRate

java.util.Map<java.util.Date,OntimeDeliveryRateResult> getLast12MonthOntimeDeliveryRate(java.lang.String vendorId,
                                                                                java.lang.String dateType,
                                                                                int overDueDays,
                                                                                int advanceDays)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findVendorPurchaseOrderItems

java.util.Collection<PurchaseOrderItemListResult> findVendorPurchaseOrderItems(java.lang.String vendorId,
                                                                               java.util.Date from,
                                                                               java.util.Date to,
                                                                               java.lang.String dateType,
                                                                               int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getVendorPurchaseOrderItemCount

int getVendorPurchaseOrderItemCount(java.lang.String vendorId,
                                    java.util.Date from,
                                    java.util.Date to,
                                    java.lang.String dateType)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findVendorPurchaseOrderItemsByDate

java.util.Collection<PurchaseOrderItemListResult> findVendorPurchaseOrderItemsByDate(java.lang.String vendorId,
                                                                                java.util.Date from,
                                                                                java.util.Date to,
                                                                                java.lang.String dateType,
                                                                                java.lang.String status,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getVendorPurchaseOrderItemCountByDate

int getVendorPurchaseOrderItemCountByDate(java.lang.String vendorId,
                                          java.util.Date from,
                                          java.util.Date to,
                                          java.lang.String dateType,
                                          java.lang.String status)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

getNext12MonthPoShipAmount

IncomeByMonthChartResult getNext12MonthPoShipAmount()
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getVendorPurchaseOrderByDateCount

int getVendorPurchaseOrderByDateCount(java.lang.String vendorId,
                                      java.util.Date fromDate,
                                      java.util.Date toDate,
                                      java.lang.String dateType,
                                      java.lang.String status)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findVendorPurchaseOrderByDate

java.util.Collection<VendorTotalAmountInPO> findVendorPurchaseOrderByDate(java.lang.String vendorId,
                                                                          java.util.Date fromDate,
                                                                          java.util.Date toDate,
                                                                          java.lang.String dateType,
                                                                          java.lang.String status,
                                                                          int firstIndex,
                                                                          int maxLength)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

findCancelledPurchaseOrderItems

java.util.Collection<PurchaseOrderItemListResult> findCancelledPurchaseOrderItems(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getCancelledPurchaseOrderItemsCount

int getCancelledPurchaseOrderItemsCount()
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findPurchaseContract

java.util.Collection<PurchaseOrderContractResult> findPurchaseContract(java.util.Date fromDate,
                                                                       java.util.Date toDate,
                                                                       java.lang.String currency,
                                                                       java.lang.String type)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderItemCountByProject

int getPurchaseOrderItemCountByProject(java.lang.String startWith,
                                       java.lang.String status,
                                       java.lang.String dateType,
                                       java.util.Date startDate,
                                       java.util.Date toDate,
                                       java.lang.String project)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findPurchaseOrderItemsByProject

java.util.Collection<PurchaseOrderItemListResult> findPurchaseOrderItemsByProject(java.lang.String startWith,
                                                                                java.lang.String status,
                                                                                java.lang.String dateType,
                                                                                java.util.Date startDate,
                                                                                java.util.Date toDate,
                                                                                java.lang.String project,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getRequestForQuoteItemListResultsCountByPartNumberAndDateLike

int getRequestForQuoteItemListResultsCountByPartNumberAndDateLike(java.lang.String searchText,
                                                                  java.lang.String getPartType,
                                                                  java.lang.String getDateType,
                                                                  java.util.Date getDateBigin,
                                                                  java.util.Date getDateEnd,
                                                                  java.lang.String getVendorId,
                                                                  java.lang.String buyer)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

findRequestForQuoteItemListResultsByPartNumberAndDateLike

java.util.Collection<RequestForQuoteItemListResult> findRequestForQuoteItemListResultsByPartNumberAndDateLike(java.lang.String searchText,
                                                                                java.lang.String partType,
                                                                                java.lang.String dateType,
                                                                                java.util.Date dateBigin,
                                                                                java.util.Date dateEnd,
                                                                                java.lang.String vendorId,
                                                                                java.lang.String buyer,
                                                                                int firstIndex,
                                                                                int length)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

addSwapOrder

java.lang.String addSwapOrder(java.lang.String vendId)
                              throws java.lang.Exception
Throws:
java.lang.Exception

updateSwapOrder

SwapOrderVO updateSwapOrder(SwapOrderVO vo)
                            throws java.lang.Exception
Throws:
java.lang.Exception

deleteSwapOrder

void deleteSwapOrder(SwapOrderVO vo)
                     throws java.lang.Exception
Throws:
java.lang.Exception

getSwapOrderVOBySwapNumber

SwapOrderVO getSwapOrderVOBySwapNumber(java.lang.String swapNumber)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findOpenSwapOrder

java.util.Collection<SwapOrderListResult> findOpenSwapOrder(java.lang.String swoNumber,
                                                            int firstIndex,
                                                            int maxLength)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getOpenSwapOrderCount

int getOpenSwapOrderCount(java.lang.String swoNumber)
                          throws java.lang.Exception
Throws:
java.lang.Exception

findSwapOrderByDate

java.util.Collection<SwapOrderItemListResult> findSwapOrderByDate(java.lang.String swoNumber,
                                                                  PartPK partPk,
                                                                  java.lang.String dateType,
                                                                  java.util.Date startDate,
                                                                  java.util.Date toDate,
                                                                  java.lang.String vendorId,
                                                                  java.lang.String buyer,
                                                                  java.lang.String projectName,
                                                                  java.lang.String relatedDoc,
                                                                  java.lang.String status,
                                                                  java.lang.String partFrom,
                                                                  int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getSwapOrderCountByDate

int getSwapOrderCountByDate(java.lang.String swoNumber,
                            PartPK partPk,
                            java.lang.String dateType,
                            java.util.Date startDate,
                            java.util.Date toDate,
                            java.lang.String vendorId,
                            java.lang.String buyer,
                            java.lang.String projectName,
                            java.lang.String relatedDoc,
                            java.lang.String status,
                            java.lang.String partFrom)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findCancelledSwapOrder

java.util.Collection<SwapOrderItemListResult> findCancelledSwapOrder(int firstIndex,
                                                                     int maxLength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getCancelledSwapOrderCount

int getCancelledSwapOrderCount()
                               throws java.lang.Exception
Throws:
java.lang.Exception

initSwapOrderItem

SwapOrderItemVO initSwapOrderItem(SwapOrderVO toVo,
                                  PartPK partPk,
                                  java.math.BigDecimal quantity,
                                  boolean isTool)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

approvalSwapOrder

SwapOrderVO approvalSwapOrder(SwapOrderVO toVO)
                              throws java.lang.Exception
Throws:
java.lang.Exception

findSwapOrders

java.util.Collection<SwapOrderListResult> findSwapOrders(java.lang.String swoNumber,
                                                         java.lang.String vendorId,
                                                         java.lang.String buyer,
                                                         java.lang.String projectName,
                                                         java.lang.String relatedDoc,
                                                         java.lang.String[] status,
                                                         java.util.Date startDate,
                                                         java.util.Date toDate,
                                                         int firstIndex,
                                                         int maxLength)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getSwapOrdersCount

int getSwapOrdersCount(java.lang.String swoNumber,
                       java.lang.String vendorId,
                       java.lang.String buyer,
                       java.lang.String projectName,
                       java.lang.String relatedDoc,
                       java.lang.String[] status,
                       java.util.Date startDate,
                       java.util.Date toDate)
                       throws java.lang.Exception
Throws:
java.lang.Exception

addSwapOrderApproval

SwapOrderApprovalVO addSwapOrderApproval(java.lang.String employeeId)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

updateSwapOrderApproval

void updateSwapOrderApproval(SwapOrderApprovalVO vo)
                             throws java.lang.Exception
Throws:
java.lang.Exception

deleteSwapOrderApproval

void deleteSwapOrderApproval(java.lang.String employeeId)
                             throws java.lang.Exception
Throws:
java.lang.Exception

getSwapOrderApprovalByEmployeeId

SwapOrderApprovalVO getSwapOrderApprovalByEmployeeId(java.lang.String employeeId)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

findAllSwapOrderApproval

java.util.Collection<SwapOrderApprovalVO> findAllSwapOrderApproval(int firstIndex,
                                                                   int maxLength)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getAllSwapOrderApprovalCount

int getAllSwapOrderApprovalCount()
                                 throws java.lang.Exception
Throws:
java.lang.Exception

importTempMpn

void importTempMpn(java.util.Collection<java.util.Map> datas)
                   throws java.lang.Exception
Throws:
java.lang.Exception

findAllMPNParts

java.util.Collection<java.util.Map> findAllMPNParts()
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

saveMPNPart

void saveMPNPart(java.util.ArrayList<java.util.Map> datas)
                 throws java.lang.Exception
Throws:
java.lang.Exception

addPurchaseOrderByMPNPart

java.lang.String addPurchaseOrderByMPNPart(java.lang.String vendorId)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

findRequestForQuoteItemListResultsByPartNumberAndDateLike

java.util.Collection<RequestForQuoteItemListResult> findRequestForQuoteItemListResultsByPartNumberAndDateLike(java.lang.String searchText,
                                                                                java.lang.String partType,
                                                                                java.lang.String dateType,
                                                                                java.util.Date dateBigin,
                                                                                java.util.Date dateEnd,
                                                                                java.lang.String vendorId,
                                                                                boolean vendorIdLike,
                                                                                int firstIndex,
                                                                                int length)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getRequestForQuoteItemListResultsCountByPartNumberAndDateLike

int getRequestForQuoteItemListResultsCountByPartNumberAndDateLike(java.lang.String searchText,
                                                                  java.lang.String partType,
                                                                  java.lang.String dateType,
                                                                  java.util.Date dateBigin,
                                                                  java.util.Date dateEnd,
                                                                  java.lang.String vendorId,
                                                                  boolean vendorIdLike)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getInitDefaultCostPerUnit

java.math.BigDecimal getInitDefaultCostPerUnit(BB2Part part,
                                               java.lang.String poNumber)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

cancelRfq

java.lang.String cancelRfq(java.lang.String rfqNumber)
                           throws java.lang.Exception
Throws:
java.lang.Exception

cancelSwap

java.lang.String cancelSwap(java.lang.String swapNumber)
                            throws java.lang.Exception
Throws:
java.lang.Exception

cancelRTV

java.lang.String cancelRTV(java.lang.String rtvNumber)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findPurchaseOrdersByRefdoc

java.util.Collection<PurchaseOrderItemListResult> findPurchaseOrdersByRefdoc(java.lang.String poNumber,
                                                                             java.lang.String status,
                                                                             java.lang.String refdoc,
                                                                             java.util.Date dateFrom,
                                                                             java.util.Date dateTo,
                                                                             int firstIndex,
                                                                             int maxLength)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrdersCountByByRefdoc

int getPurchaseOrdersCountByByRefdoc(java.lang.String poNumber,
                                     java.lang.String status,
                                     java.lang.String refdoc,
                                     java.util.Date dateFrom,
                                     java.util.Date dateTo)
                                     throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PurchasingInfoCenterResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PurchasingInfoCenterResult

java.lang.Object
    extended by  bb.common.PurchasingInfoCenterResult
All Implemented Interfaces:
java.io.Serializable
public class PurchasingInfoCenterResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PurchasingInfoCenterResult()
Method Summary
java.math.BigDecimal | getAvgFyPoAddedCount()
java.math.BigDecimal | getAvgFyPoiAddedCount()
java.math.BigDecimal | getAvgFyPurchaserAccount()
java.math.BigDecimal | getAvgFyReceiverAccount()
java.math.BigDecimal | getAvgFyReceiverCount()
java.math.BigDecimal | getAvgFyReceiverItemCount()
java.lang.Integer | getCurrentMonthPoAddedCount()
java.lang.Integer | getCurrentMonthPoiAddedCount()
java.math.BigDecimal | getCurrentMonthPurchaseAccount()
java.math.BigDecimal | getCurrentMonthReceiverAccount()
java.lang.Integer | getCurrentMonthReceiverCount()
java.lang.Integer | getCurrentMonthReceiverItemCount()
java.math.BigDecimal | getDueOriginalPromisePurchaseAccount()
java.math.BigDecimal | getDuePurchaseAccount()
java.lang.Integer | getDuePurchaseCount()
java.lang.Integer | getFyPoAddedCount()
java.lang.Integer | getFyPoiAddedCount()
java.math.BigDecimal | getFyPurchaserAccount()
java.math.BigDecimal | getFyReceiverAccount()
java.lang.Integer | getFyReceiverCount()
java.lang.Integer | getFyReceiverItemCount()
java.lang.Integer | getLastMonthPoAddedCount()
java.lang.Integer | getLastMonthPoiAddedCount()
java.math.BigDecimal | getLastMonthPurchaseAccount()
java.math.BigDecimal | getLastMonthReceiverAccount()
java.lang.Integer | getLastMonthReceiverCount()
java.lang.Integer | getLastMonthReceiverItemCount()
java.math.BigDecimal | getOpenPurchaseAccount()
java.lang.Integer | getPurchaseWithPartOnHoldCount()
void | setAvgFyPoAddedCount(java.math.BigDecimal avgFyPoAddedCount)
void | setAvgFyPoiAddedCount(java.math.BigDecimal avgFyPoiAddedCount)
void | setAvgFyPurchaserAccount(java.math.BigDecimal avgFyPurchaserAccount)
void | setAvgFyReceiverAccount(java.math.BigDecimal avgFyReceiverAccount)
void | setAvgFyReceiverCount(java.math.BigDecimal avgFyReceiverCount)
void | setAvgFyReceiverItemCount(java.math.BigDecimal avgFyReceiverItemCount)
void | setCurrentMonthPoAddedCount(java.lang.Integer currentMonthPoAddedCount)
void | setCurrentMonthPoiAddedCount(java.lang.Integer currentMonthPoiAddedCount)
void | setCurrentMonthPurchaseAccount(java.math.BigDecimal currentMonthPurchaseAccount)
void | setCurrentMonthReceiverAccount(java.math.BigDecimal currentMonthReceiverAccount)
void | setCurrentMonthReceiverCount(java.lang.Integer currentMonthReceiverCount)
void | setCurrentMonthReceiverItemCount(java.lang.Integer currentMonthReceiverItemCount)
void | setDueOriginalPromisePurchaseAccount(java.math.BigDecimal dueOriginalPromisePurchaseAccount)
void | setDuePurchaseAccount(java.math.BigDecimal duePurchaseAccount)
void | setDuePurchaseCount(java.lang.Integer duePurchaseCount)
void | setFyPoAddedCount(java.lang.Integer fyPoAddedCount)
void | setFyPoiAddedCount(java.lang.Integer fyPoiAddedCount)
void | setFyPurchaserAccount(java.math.BigDecimal fyPurchaserAccount)
void | setFyReceiverAccount(java.math.BigDecimal fyReceiverAccount)
void | setFyReceiverCount(java.lang.Integer fyReceiverCount)
void | setFyReceiverItemCount(java.lang.Integer fyReceiverItemCount)
void | setLastMonthPoAddedCount(java.lang.Integer lastMonthPoAddedCount)
void | setLastMonthPoiAddedCount(java.lang.Integer lastMonthPoiAddedCount)
void | setLastMonthPurchaseAccount(java.math.BigDecimal lastMonthPurchaseAccount)
void | setLastMonthReceiverAccount(java.math.BigDecimal lastMonthReceiverAccount)
void | setLastMonthReceiverCount(java.lang.Integer lastMonthReceiverCount)
void | setLastMonthReceiverItemCount(java.lang.Integer lastMonthReceiverItemCount)
void | setOpenPurchaseAccount(java.math.BigDecimal openPurchaseAccount)
void | setPurchaseWithPartOnHoldCount(java.lang.Integer purchaseWithPartOnHoldCount)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PurchasingInfoCenterResult

public PurchasingInfoCenterResult()
Method Detail

setCurrentMonthPurchaseAccount

public void setCurrentMonthPurchaseAccount(java.math.BigDecimal currentMonthPurchaseAccount)

setCurrentMonthPoAddedCount

public void setCurrentMonthPoAddedCount(java.lang.Integer currentMonthPoAddedCount)

setCurrentMonthPoiAddedCount

public void setCurrentMonthPoiAddedCount(java.lang.Integer currentMonthPoiAddedCount)

setLastMonthPurchaseAccount

public void setLastMonthPurchaseAccount(java.math.BigDecimal lastMonthPurchaseAccount)

setFyPurchaserAccount

public void setFyPurchaserAccount(java.math.BigDecimal fyPurchaserAccount)

setAvgFyPurchaserAccount

public void setAvgFyPurchaserAccount(java.math.BigDecimal avgFyPurchaserAccount)

setLastMonthPoAddedCount

public void setLastMonthPoAddedCount(java.lang.Integer lastMonthPoAddedCount)

setLastMonthPoiAddedCount

public void setLastMonthPoiAddedCount(java.lang.Integer lastMonthPoiAddedCount)

setFyPoAddedCount

public void setFyPoAddedCount(java.lang.Integer fyPoAddedCount)

setFyPoiAddedCount

public void setFyPoiAddedCount(java.lang.Integer fyPoiAddedCount)

setAvgFyPoAddedCount

public void setAvgFyPoAddedCount(java.math.BigDecimal avgFyPoAddedCount)

setAvgFyPoiAddedCount

public void setAvgFyPoiAddedCount(java.math.BigDecimal avgFyPoiAddedCount)

setCurrentMonthReceiverCount

public void setCurrentMonthReceiverCount(java.lang.Integer currentMonthReceiverCount)

setCurrentMonthReceiverItemCount

public void setCurrentMonthReceiverItemCount(java.lang.Integer currentMonthReceiverItemCount)

setLastMonthReceiverCount

public void setLastMonthReceiverCount(java.lang.Integer lastMonthReceiverCount)

setLastMonthReceiverItemCount

public void setLastMonthReceiverItemCount(java.lang.Integer lastMonthReceiverItemCount)

setFyReceiverCount

public void setFyReceiverCount(java.lang.Integer fyReceiverCount)

setFyReceiverItemCount

public void setFyReceiverItemCount(java.lang.Integer fyReceiverItemCount)

setAvgFyReceiverCount

public void setAvgFyReceiverCount(java.math.BigDecimal avgFyReceiverCount)

setAvgFyReceiverItemCount

public void setAvgFyReceiverItemCount(java.math.BigDecimal avgFyReceiverItemCount)

setCurrentMonthReceiverAccount

public void setCurrentMonthReceiverAccount(java.math.BigDecimal currentMonthReceiverAccount)

setLastMonthReceiverAccount

public void setLastMonthReceiverAccount(java.math.BigDecimal lastMonthReceiverAccount)

setFyReceiverAccount

public void setFyReceiverAccount(java.math.BigDecimal fyReceiverAccount)

setAvgFyReceiverAccount

public void setAvgFyReceiverAccount(java.math.BigDecimal avgFyReceiverAccount)

setOpenPurchaseAccount

public void setOpenPurchaseAccount(java.math.BigDecimal openPurchaseAccount)

setDuePurchaseAccount

public void setDuePurchaseAccount(java.math.BigDecimal duePurchaseAccount)

setDuePurchaseCount

public void setDuePurchaseCount(java.lang.Integer duePurchaseCount)

setPurchaseWithPartOnHoldCount

public void setPurchaseWithPartOnHoldCount(java.lang.Integer purchaseWithPartOnHoldCount)

getCurrentMonthPurchaseAccount

public java.math.BigDecimal getCurrentMonthPurchaseAccount()

getCurrentMonthPoAddedCount

public java.lang.Integer getCurrentMonthPoAddedCount()

getCurrentMonthPoiAddedCount

public java.lang.Integer getCurrentMonthPoiAddedCount()

getLastMonthPurchaseAccount

public java.math.BigDecimal getLastMonthPurchaseAccount()

getFyPurchaserAccount

public java.math.BigDecimal getFyPurchaserAccount()

getAvgFyPurchaserAccount

public java.math.BigDecimal getAvgFyPurchaserAccount()

getLastMonthPoAddedCount

public java.lang.Integer getLastMonthPoAddedCount()

getLastMonthPoiAddedCount

public java.lang.Integer getLastMonthPoiAddedCount()

getFyPoAddedCount

public java.lang.Integer getFyPoAddedCount()

getFyPoiAddedCount

public java.lang.Integer getFyPoiAddedCount()

getAvgFyPoAddedCount

public java.math.BigDecimal getAvgFyPoAddedCount()

getAvgFyPoiAddedCount

public java.math.BigDecimal getAvgFyPoiAddedCount()

getCurrentMonthReceiverCount

public java.lang.Integer getCurrentMonthReceiverCount()

getCurrentMonthReceiverItemCount

public java.lang.Integer getCurrentMonthReceiverItemCount()

getLastMonthReceiverCount

public java.lang.Integer getLastMonthReceiverCount()

getLastMonthReceiverItemCount

public java.lang.Integer getLastMonthReceiverItemCount()

getFyReceiverCount

public java.lang.Integer getFyReceiverCount()

getFyReceiverItemCount

public java.lang.Integer getFyReceiverItemCount()

getAvgFyReceiverCount

public java.math.BigDecimal getAvgFyReceiverCount()

getAvgFyReceiverItemCount

public java.math.BigDecimal getAvgFyReceiverItemCount()

getCurrentMonthReceiverAccount

public java.math.BigDecimal getCurrentMonthReceiverAccount()

getLastMonthReceiverAccount

public java.math.BigDecimal getLastMonthReceiverAccount()

getFyReceiverAccount

public java.math.BigDecimal getFyReceiverAccount()

getAvgFyReceiverAccount

public java.math.BigDecimal getAvgFyReceiverAccount()

getOpenPurchaseAccount

public java.math.BigDecimal getOpenPurchaseAccount()

getDuePurchaseAccount

public java.math.BigDecimal getDuePurchaseAccount()

getDuePurchaseCount

public java.lang.Integer getDuePurchaseCount()

getPurchaseWithPartOnHoldCount

public java.lang.Integer getPurchaseWithPartOnHoldCount()

getDueOriginalPromisePurchaseAccount

public java.math.BigDecimal getDueOriginalPromisePurchaseAccount()

setDueOriginalPromisePurchaseAccount

public void setDueOriginalPromisePurchaseAccount(java.math.BigDecimal dueOriginalPromisePurchaseAccount)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PuttoInQAAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class PuttoInQAAgent

java.lang.Object
    extended by  bb.common.PuttoInQAAgent
All Implemented Interfaces:
java.io.Serializable
public final class PuttoInQAAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
PuttoInQAAgent()
Method Summary
java.math.BigDecimal | getCost()
java.lang.String | getLocate()
BB2Part | getPart()
java.math.BigDecimal | getQty()
java.util.Set<ReceiverItemTrackingLogAgent> | getTrackingLog()
void | setCost(java.math.BigDecimal cost)
void | setLocate(java.lang.String locate)
void | setPart(BB2Part part)
void | setQty(java.math.BigDecimal qty)
void | setTrackingLog(java.util.Set<ReceiverItemTrackingLogAgent> trackingLog)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PuttoInQAAgent

public PuttoInQAAgent()
Method Detail

getPart

public BB2Part getPart()

setPart

public void setPart(BB2Part part)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

getCost

public java.math.BigDecimal getCost()

setCost

public void setCost(java.math.BigDecimal cost)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getTrackingLog

public java.util.Set<ReceiverItemTrackingLogAgent> getTrackingLog()

setTrackingLog

public void setTrackingLog(java.util.Set<ReceiverItemTrackingLogAgent> trackingLog)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Q-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M N O P Q R S T U V W X Y Z

Q

Q_CODE_ONLY - Static variable in class bb.common.Constant.VendorQualityStatus
QN - Static variable in class bb.common.Constant.ChartOfAccountType
QR - Static variable in class bb.common.Constant.ChartOfAccountType
QT_DOC - Static variable in class bb.common.BizTarget
QT_DOC - Static variable in class bb.common.Constant.MiscDocType
QT_DOC_NOT_FIND - Static variable in class bb.common.BIZReason
QtrUsage - Static variable in class bb.common.MrpReportAgent
QTY_RECEIVED_CAN_NOT_MORE_THAN_QTY_PURCHASED - Static variable in class bb.common.BIZReason
QTY_RECEIVED_CAN_NOT_MORE_THAN_QTY_QUALIFIED - Static variable in class bb.common.BIZReason
QTY_SHOULD_BE_BIGGER_THAN_ISSUED_QTY - Static variable in class bb.common.BIZReason
QTY_SHOULD_HAS_SAME_POSITIVE_NEGATIVE_WITH_ISSUED_QTY - Static variable in class bb.common.BIZReason
QtyAndMoney - Class in bb.common
QtyAndMoney() - Constructor for class bb.common.QtyAndMoney
QtyDetailResult - Class in bb.common
QtyDetailResult() - Constructor for class bb.common.QtyDetailResult
QUALITY - Static variable in class bb.common.Configure.Module
Quality - Static variable in class bb.common.Constant.IssuedFrom
Quality - Static variable in class bb.common.Constant.ReceivedTo
QualityBox - Interface in bb.common.box
QualityGroupPK - Class in bb.common
QualityGroupPK(String, String) - Constructor for class bb.common.QualityGroupPK
full constructor
QualityGroupPK() - Constructor for class bb.common.QualityGroupPK
default constructor
QualityGroupVO - Class in bb.common
QualityGroupVO(QualityGroupPK) - Constructor for class bb.common.QualityGroupVO
full constructor
QualityGroupVO() - Constructor for class bb.common.QualityGroupVO
default constructor
QualityInfoCenterResult - Class in bb.common
QualityInfoCenterResult() - Constructor for class bb.common.QualityInfoCenterResult
QUANTIRY_CAN_NOT_BE_ZERO - Static variable in class bb.common.BIZReason
QUANTITY_CAN_NOT_LESS_THAN_ZERO - Static variable in class bb.common.BIZReason
QUARTER - Static variable in class bb.common.Constant.CycleCountPeriodUnit
QUARTER - Static variable in class bb.common.Constant.PeriodUnit
queryBySql(String) - Method in interface bb.common.box.CompanyBox
QUOTE - Static variable in class bb.common.BizTarget
QUOTE - Static variable in class bb.common.Constant.OrderType
QUOTE - Static variable in class bb.common.Constant.PrintTemplateType
QUOTE - Static variable in class bb.common.Constant.TermsConditonType
Quote2QuoteAgent - Class in bb.common
Quote2QuoteAgent() - Constructor for class bb.common.Quote2QuoteAgent
QUOTE_ALREADY_REVIEWED - Static variable in class bb.common.BIZReason
QUOTE_ITEM - Static variable in class bb.common.BizTarget
QUOTE_ITEM_MFG - Static variable in class bb.common.BizTarget
QUOTE_ITEM_PK_WRONG - Static variable in class bb.common.BIZReason
QUOTE_NOT_EXIST - Static variable in class bb.common.BIZReason
QUOTE_WITHOUT_ITEMS - Static variable in class bb.common.BIZReason
QuoteBoilerplateVO - Class in bb.common
QuoteBoilerplateVO(String, String, String) - Constructor for class bb.common.QuoteBoilerplateVO
full constructor
QuoteBoilerplateVO() - Constructor for class bb.common.QuoteBoilerplateVO
default constructor
QuoteBoilerplateVO(String, String) - Constructor for class bb.common.QuoteBoilerplateVO
minimal constructor
QuoteDocumentVO - Class in bb.common
QuoteDocumentVO() - Constructor for class bb.common.QuoteDocumentVO
quoteForCRFQ(String) - Method in interface bb.common.box.SalesBox
QuoteItemListResult - Class in bb.common
QuoteItemListResult() - Constructor for class bb.common.QuoteItemListResult
QuoteItemManufacturerPK - Class in bb.common
QuoteItemManufacturerPK(String, String, short) - Constructor for class bb.common.QuoteItemManufacturerPK
full constructor
QuoteItemManufacturerPK() - Constructor for class bb.common.QuoteItemManufacturerPK
default constructor
QuoteItemManufacturerVO - Class in bb.common
QuoteItemManufacturerVO(QuoteItemManufacturerPK, String, String) - Constructor for class bb.common.QuoteItemManufacturerVO
QuoteItemManufacturerVO() - Constructor for class bb.common.QuoteItemManufacturerVO
QuoteItemPK - Class in bb.common
QuoteItemPK(String, String) - Constructor for class bb.common.QuoteItemPK
full constructor
QuoteItemPK() - Constructor for class bb.common.QuoteItemPK
default constructor
QuoteItemVO - Class in bb.common
QuoteItemVO() - Constructor for class bb.common.QuoteItemVO
QuoteListResult - Class in bb.common
QuoteListResult() - Constructor for class bb.common.QuoteListResult
QuoteVO - Class in bb.common
QuoteVO() - Constructor for class bb.common.QuoteVO
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M N O P Q R S T U V W X Y Z


QtyAndMoney

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class QtyAndMoney

java.lang.Object
    extended by  bb.common.QtyAndMoney
All Implemented Interfaces:
java.io.Serializable
public class QtyAndMoney
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
QtyAndMoney()
Method Summary
Money | getMoney()
java.math.BigDecimal | getQty()
void | setMoney(Money money)
void | setQty(java.math.BigDecimal qty)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

QtyAndMoney

public QtyAndMoney()
Method Detail

getMoney

public Money getMoney()

setMoney

public void setMoney(Money money)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QtyDetailResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class QtyDetailResult

java.lang.Object
    extended by  bb.common.QtyDetailResult
All Implemented Interfaces:
java.io.Serializable
public class QtyDetailResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
QtyDetailResult()
Method Summary
java.math.BigDecimal | getQty()
java.lang.String | getStr()
void | setQty(java.math.BigDecimal qty)
void | setStr(java.lang.String str)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

QtyDetailResult

public QtyDetailResult()
Method Detail

setQty

public void setQty(java.math.BigDecimal qty)

setStr

public void setStr(java.lang.String str)

getQty

public java.math.BigDecimal getQty()

getStr

public java.lang.String getStr()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QualityBox

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common.box
Interface QualityBox

public interface QualityBox

Method Summary
AddressQualityDocumentsVO | addAddressQualityDocuments(AddressQualityDocumentsVO vo)
CorrectiveActionRequestVO | addCar(CorrectiveActionRequestVO vo)
CertificateDescriptionVO | addCertificateDescription(CertificateDescriptionVO vo)
java.lang.String | addICR(InspectionConformanceReportVO vo)
InspectionTypeVO | addInspectionType(InspectionTypeVO inspectionType)
void | addMultiplePartTracking(java.util.Collection<PartTrackingVO> partTrackings)
NonConformanceCodeVO | addNCC(NonConformanceCodeVO vo)
java.lang.String | addNCR(NonConformanceReportVO vo)
java.lang.String | addNCR(NonConformanceReportVO vo, java.util.HashSet<java.lang.Integer> sets)
NcrApprovalVO | addNcrApproval(java.lang.String employeeId, java.lang.String approvableType)
void | addNCRPicture(NCRPictureVO vo)
PreventiveActionRequestVO | addPAR(PreventiveActionRequestVO vo)
PartInspectionVO | addPartInspection(PartInspectionVO vo)
java.lang.String | addPOSurveyReportWithPO(POSurveyReportAgent agent)
QualityGroupVO | addQualityGroup(QualityGroupVO vo)
SerialNumberPK | addSerialNumber(PartCertificateVO partCertificateVo)
SerialNumberPK | addSerialNumber(PartCertificateVO partCertificateVo, java.lang.String originalCertificateNumber)
NonConformanceReportVO | approvalNcrForEng(NonConformanceReportVO ncrVo)
NonConformanceReportVO | approvalNcrForMfg(NonConformanceReportVO ncrVo)
NonConformanceReportVO | approvalNcrForQa(NonConformanceReportVO ncrVo)
void | batchCloseNcrs(java.util.List<java.lang.String> ncrNumbers)
void | clearNCRReferenceDocOne(java.lang.String referenceDoc)
void | clearNCRReferenceDocTwo(java.lang.String referenceDoc)
void | deleteAddressQualityDocuments(java.lang.Long ii)
java.util.Collection<AddressQualityDocumentsVO> | deleteAddressQualityDocuments(MiscDocAgent agent)
void | deleteCar(CorrectiveActionRequestVO vo)
void | deleteCertificateDescription(CertificateDescriptionVO vo)
void | deleteInspectionType(InspectionTypeVO inspectionType)
void | deleteNCC(NonConformanceCodeVO vo)
void | deleteNCR(NonConformanceReportVO vo)
void | deleteNcrApproval(NcrApprovalPK pk)
void | deleteNCRPicture(java.lang.Long ii)
java.util.Collection<NCRPictureVO> | deleteNCRPicture(MiscDocAgent agent)
void | deletePAR(java.lang.String parNumber)
java.util.Collection<PreventiveActionRequestItemVO> | deletePARDoc(MiscDocAgent agent)
void | deletePartCertificate(MiscDocAgent agent)
void | deletePartInspection(PartInspectionPK pk)
void | deletePOSurveyReport(java.lang.String srNumber)
void | deleteQualityGroup(QualityGroupVO vo)
void | deleteSerialNumber(java.lang.String serialNumber)
byte[] | downloadAddressQualityDocuments(MiscDocAgent agent)
BB2File | downLoadNCRPicture(MiscDocAgent agent)
BB2File | downloadPARDoc(MiscDocAgent agent)
BB2File | downloadPartCertificateFile(MiscDocAgent agent)
java.util.Collection<AddressQualityDocumentsVO> | findAddressQualityDocumentsByCategory(java.lang.String category, java.lang.String id)
java.util.Collection<AddressQualityDocumentsVO> | findAddressQualityDocumentsInfo(java.lang.String addressId, boolean useLikeMatch, int firstIndex, int maxLength)
java.util.Collection<NcrReportListResult> | findAllCanClosedNcrs(java.lang.String pnLike, java.lang.String partType, java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, boolean isListNotZero, boolean isListEquals, int firstIndex, int maxLength)
java.util.Collection<CorrectiveActionRequestVO> | findAllCars(int firstIndex, int maxLength)
java.util.Collection<CertificateDescriptionVO> | findAllCertificateDescs()
java.util.Collection<NonConformanceCodeVO> | findAllNCCs(int firstIndex, int maxLength)
java.util.Collection<NonConformanceReportVO> | findAllNCRs(int firstIndex, int maxLength)
java.util.Collection<PreventiveActionRequestVO> | findAllPars(int firstIndex, int maxLength)
java.util.Collection<PartCertificateListResult> | findAllPartCertificates(int firstIndex, int maxLength)
java.util.Collection<PartInQAVO> | findAllPartInQAsToMakeNCR(java.lang.String partNumber, int firstIndex, int maxLength)
java.util.Collection<QualityGroupVO> | findAllQualityGroups(int firstIndex, int maxLength)
java.util.Collection<SerialNumberVO> | findAllSerialNumbers(int firstIndex, int maxLength)
CorrectiveActionRequestVO | findCarByPk(java.lang.String carNumber)
java.util.Collection<CorrectiveActionRequestVO> | findCars(java.lang.String carNumber, java.lang.String pn, java.lang.String pa, java.lang.String id, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<CorrectiveActionRequestVO> | findCarsByCarNumber(java.lang.String carNumber, int firstIndex, int maxLength)
java.util.Collection<CorrectiveActionRequestVO> | findCarsByPastDue(int firstIndex, int maxLength)
java.util.Collection<CorrectiveActionRequestVO> | findCarsByPn(java.lang.String pn, java.lang.String pa, int firstIndex, int maxLength)
java.util.Collection<CorrectiveActionRequestVO> | findCarsByStatus(java.lang.String status, int firstIndex, int maxLength)
CertificateDescriptionVO | findCertificateDescByPk(int pk)
java.util.Collection<CertificateDescriptionVO> | findCertificateDescs(int firstIndex, int maxLength)
NonConformanceReportVO | findCustomerVendorIDByOrderNumber(java.lang.String orderNumber)
java.util.Collection<NonConformanceReportVO> | findDueNCRs(int firstIndex, int maxLength)
java.util.Collection<PreventiveActionRequestVO> | findDuePARs(int firstIndex, int maxLength)
InspectionConformanceReportVO | findIcrById(java.lang.String icrNumber)
InspectionConformanceReportItemVO | findIcrItemByPk(InspectionConformanceReportItemPK pk)
java.util.Collection<IcrItemListResult> | findIcrItemsByDate(java.lang.String icrNumber, java.lang.String vendorId, java.lang.String pn, java.lang.String inspector, java.lang.String wo, java.lang.String po, java.util.Date from, java.util.Date to, java.lang.String status, java.lang.String dateType, int firstIndex, int maxLength)
java.util.Collection<IcrListResult> | findIcrsById(java.lang.String icrNumber, int firstIndex, int maxLength)
java.util.Collection<IcrListResult> | findIcrsByVendorId(java.lang.String vendorId, int firstIndex, int maxLength)
java.util.Collection<InspectionTypeVO> | findInspectionType(java.lang.String type, int firstIndex, int maxLength)
java.util.Collection<LogTrackingVO> | findLogTrackings(java.lang.String partNumber, java.lang.String partType, java.lang.String trackingNumber, java.lang.String refDoc1, java.lang.String refDoc2, java.lang.String operator, java.lang.String location, java.util.Date fromDate, java.util.Date toDate, int operationType, int firstIndex, int maxLength)
NonConformanceCodeVO | findNccById(java.lang.String code)
java.util.Collection<NCQRejectResult> | findNCQsByNCCode(java.lang.String[] nCCodes, java.util.Date dateFrom, java.util.Date dateTo, int firstIndex, int maxLength)
java.util.Collection<NCQRejectResult> | findNCQsByNCCode(java.lang.String nCCode, java.util.Date dateFrom, java.util.Date dateTo, int firstIndex, int maxLength)
java.util.Collection<NcrApprovalVO> | findNcrApprovals(java.lang.String approvableType, int firstIndex, int maxLength)
NonConformanceReportVO | findNcrById(java.lang.String ncrNumber)
java.util.Collection<NcrReportListResult> | findNCRListByNCCode(java.lang.String nCCode, java.util.Date dateFrom, java.util.Date dateTo, int firstIndex, int maxLength)
java.util.Collection<NcrReportListResult> | findNCRsByDate(java.lang.String pnLike, java.lang.String partType, java.lang.String id, java.lang.String ncCode, java.lang.String purchaseOrderNumber, java.lang.String workOrderNumber, java.lang.String salesOrderNumber, java.lang.String rtvNumber, java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String status, java.lang.String enterBy, java.lang.String responsibility, java.lang.String problemDescription, java.lang.String problemDisposition, java.lang.String closedOutPrivateNotes, java.lang.String buyer, java.lang.String approvalType, java.lang.String approvedType, java.lang.String approval, int firstIndex, int maxLength)
java.util.Collection<NonConformanceReportVO> | findNCRsByNcrNumber(java.lang.String ncrNumberRegexp, int firstIndex, int maxLength)
java.util.Collection<NonConformanceReportVO> | findNCRsByPart(PartPK pk, int firstIndex, int maxLength)
java.util.Collection<NcrNeedToScrapListResult> | findNCRsToCreateScrapGlByDate(java.lang.String pnLike, java.lang.String partType, java.util.Date fromDate, java.util.Date toDate, java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<IcrListResult> | findOpenIcrs(java.lang.String icrNumber, int firstIndex, int maxLength)
java.util.Collection<NonConformanceReportVO> | findOpenNCRs(int firstIndex, int maxLength)
java.util.Collection<NonConformanceReportVO> | findOpenNCRsByPartPK(PartPK pk, int firstIndex, int maxLength)
java.util.Collection<PreventiveActionRequestVO> | findOpenPARs(int firstIndex, int maxLength)
PreventiveActionRequestVO | findPARByPk(java.lang.String pk)
java.util.Collection<PreventiveActionRequestItemVO> | findPARItemsByPAR(java.lang.String parNumber)
java.util.Collection<PreventiveActionRequestVO> | findPARsByDate(java.lang.String pn, java.lang.String pa, java.lang.String customerId, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<PreventiveActionRequestVO> | findPARsByParNumber(java.lang.String parNumber, int firstIndex, int maxLength)
java.util.Collection<PreventiveActionRequestVO> | findPARsByPn(java.lang.String pn, java.lang.String pa, int firstIndex, int maxLength)
java.util.Collection<PartCertificateVO> | findPartCertificateByCertificateNumber(java.lang.String partCertificateNumber, java.lang.String comments, java.lang.String partCertificateDesc, int firstIndex, int maxLength)
PartCertificateVO | findPartCertificateByPk(int pk)
java.util.Collection<PartCertificateListResult> | findPartCertificatesByCertificateDesc(java.lang.String cn, int firstIndex, int maxLength)
java.util.Collection<PartCertificateListResult> | findPartCertificatesByCn(java.lang.String cn, int firstIndex, int maxLength)
java.util.Collection<PartCertificateListResult> | findPartCertificatesByPn(java.lang.String partNumberRegex, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<PartCertificateListResult> | findPartCertificatesByPo(java.lang.String po, int firstIndex, int maxLength)
java.util.Collection<PartCertificateListResult> | findPartCertificatesByRef(java.lang.String ref, int firstIndex, int maxLength)
java.util.Collection<PartCertificateListResult> | findPartCertificatesByRn(java.lang.String rn, int firstIndex, int maxLength)
java.util.Collection<PartCertificateListResult> | findPartCertificatesByWo(java.lang.String wo, int firstIndex, int maxLength)
java.util.Collection<PartInspectionVO> | findPartInspectionByPartPk(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, int firstIndex, int maxLength)
java.util.Collection<java.util.Map> | findPartOnhandWithoutTracking(java.lang.String partNumber, java.lang.String partType, boolean onlyPartwithouttrackingQty, int firstIndex, int maxLength)
java.util.Collection<PartTrackingVO> | findPartTracking(PartPK pk)
PartTrackingVO | findPartTrackingByPk(PartTrackingPK pk)
java.util.Collection<PartInspectionResult> | findPartWithInspection(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, int firstIndex, int maxLength)
java.util.Collection<PartInspectionResult> | findPartWithInspectionType(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String inspectionType, int firstIndex, int maxLength)
java.util.Collection<POSurveyReportVO> | findPOSurveyReport(java.lang.String srNumber, java.lang.String purchaseOrderNumber, java.lang.String vendorId, int firstIndex, int maxLength)
QualityGroupVO | findQualityGroupByPk(QualityGroupPK pk)
SerialNumberVO | findSerialNumberByPk(SerialNumberPK pk)
java.util.Collection<PartCertificateVO> | findSerialNumberByPn(java.lang.String partNumberRegex, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<PartCertificateListResult> | findSerialNumbersBySerialNumber(java.lang.String serialNumberLike, java.lang.String partNumber, java.lang.String partType, java.lang.String workerOrderNumber, java.lang.String purchaseOrderNumber, java.lang.String salesOrderNumber, java.lang.String referenceNumber, int firstIndex, int maxLength)
int | getAccressQualityDocumentsCount(java.lang.String addressId, boolean useLikeMatch)
AddressQualityDocumentsVO | getAddressQualityDocument(java.lang.Long ii)
AddressQualityDocumentsVO | getAddressQualityDocumentInfo(java.lang.Long ii)
int | getAllCanClosedNcrsCount(java.lang.String pnLike, java.lang.String partType, java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, boolean isListNotZero, boolean isListEquals)
int | getAllCarsCount()
int | getAllCertificateDescsCount()
java.util.Collection<java.lang.String> | getAllInspectionType()
int | getAllNCCsCount()
int | getAllNCRsCount()
int | getAllPARsCount()
int | getAllPartCertificatesCount()
int | getAllPartInQAsToMakeNCRCount(java.lang.String partNumber)
int | getAllQualityGroupsCount()
int | getAllSerialNumberCount()
java.lang.String | getBB2PartDescription(BB2Part part, java.lang.String language)
int | getCarsCount(java.lang.String carNumber, java.lang.String pn, java.lang.String pa, java.lang.String id, java.util.Date fromDate, java.util.Date toDate)
int | getCarsCountByCarNumber(java.lang.String carNumber)
int | getCarsCountByPastDue()
int | getCarsCountByPn(java.lang.String pn, java.lang.String pa)
int | getCarsCountByStatus(java.lang.String status)
int | getDueNCRsCount()
int | getDuePARsCount()
InspectionConformanceReportItemInfo | getIcrItemInfoByPk(InspectionConformanceReportItemPK pk)
int | getIcrItemsCountByDate(java.lang.String icrNumber, java.lang.String vendorId, java.lang.String inspector, java.lang.String wo, java.lang.String pn, java.lang.String po, java.util.Date from, java.util.Date to, java.lang.String status, java.lang.String dateType)
int | getIcrsCountById(java.lang.String icrNumber)
int | getIcrsCountByVendorId(java.lang.String vendorId)
InspectionTypeVO | getInspectionType(java.lang.String type)
int | getInspectionTypeCount(java.lang.String type)
int | getLogTrackingsCount(java.lang.String partNumber, java.lang.String partType, java.lang.String trackingNumber, java.lang.String refDoc1, java.lang.String refDoc2, java.lang.String operator, java.lang.String location, java.util.Date fromDate, java.util.Date toDate, int operationType)
int | getNCQsByNCCodeCount(java.lang.String nCCode, java.util.Date dateFrom, java.util.Date dateTo)
NcrApprovalVO | getNcrApprovalByEmployeeId(NcrApprovalPK pk)
int | getNcrApprovalsCount(java.lang.String approvableType)
int | getNCRListByNCCodeCount(java.lang.String nCCode, java.util.Date dateFrom, java.util.Date dateTo)
NCRPictureVO | getNCRPicture(java.lang.Long ii)
java.util.Collection<NCRPictureListResult> | getNCRPictureListResults(java.lang.String ncrNumber)
int | getNCRsCountByDate(java.lang.String pnLike, java.lang.String partType, java.lang.String id, java.lang.String ncCode, java.lang.String purchaseOrderNumber, java.lang.String workOrderNumber, java.lang.String salesOrderNumber, java.lang.String rtvNumber, java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String status, java.lang.String enterBy, java.lang.String responsibility, java.lang.String problemDescription, java.lang.String problemDisposition, java.lang.String closedOutPrivateNotes, java.lang.String buyer, java.lang.String approvalType, java.lang.String approvedType, java.lang.String approval)
int | getNCRsCountByNcrNumber(java.lang.String ncrNumberRegexp)
int | getNCRSCountByPart(PartPK pk)
int | getNCRsToCreateScrapGlByDateCount(java.lang.String pnLike, java.lang.String partType, java.util.Date fromDate, java.util.Date toDate, java.lang.String status)
int | getOpenIcrsCount(java.lang.String icrNumber)
int | getOpenNCRsCount()
int | getOpenNCRsCountByPartPK(PartPK pk)
int | getOpenPARsCount()
int | getOpenPARsCountByDate(java.lang.String pn, java.lang.String pa, java.lang.String customerId, java.util.Date fromDate, java.util.Date toDate)
int | getPARItemsByPAR(java.lang.String parNumber)
int | getPARsCountByParNumber(java.lang.String parNumber)
int | getPARsCountByPn(java.lang.String pn, java.lang.String pa)
PartCertificateVO | getPartCertificateByCertificateNumber(java.lang.String cnNumber)
int | getPartCertificateByCertificateNumberCount(java.lang.String partCertificateNumber, java.lang.String comments, java.lang.String partCertificateDesc)
int | getPartCertificatesCountByCertificateDesc(java.lang.String cn)
int | getPartCertificatesCountByCn(java.lang.String cn)
int | getPartCertificatesCountByPn(java.lang.String partNumberRegex, java.lang.String partType)
int | getPartCertificatesCountByPo(java.lang.String po)
int | getPartCertificatesCountByRef(java.lang.String ref)
int | getPartCertificatesCountByRn(java.lang.String rn)
int | getPartCertificatesCountByWo(java.lang.String wo)
PartInspectionVO | getPartInspection(PartInspectionPK pk)
PartInspectionResult | getPartInspection(PartInspectionResult result)
int | getPartInspectionCountByPartPK(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom)
int | getPartOnhandWithoutTrackingCount(java.lang.String partNumber, java.lang.String partType, boolean onlyPartwithouttrackingQty)
int | getPartWithInspectionCount(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom)
int | getPartWithInspectionTypeCount(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String inspectionType)
POSurveyReportVO | getPOSurveyReport(java.lang.String srNumber)
int | getPOSurveyReportCount(java.lang.String srNumber, java.lang.String purchaseOrderNumber, java.lang.String vendorId)
PurchaseOrderVO | getPurchaseOrderByPoNumberForIR(java.lang.String poNumber)
SerialNumberResult | getSerialNumberResult(SerialNumberPK pk)
int | getSerialNumbersCountByPn(java.lang.String partNumberRegex, java.lang.String partType)
int | getSerialNumbersCountBySerialNumber(java.lang.String serialNumberLike, java.lang.String partNumber, java.lang.String partType, java.lang.String workerOrderNumber, java.lang.String purchaseOrderNumber, java.lang.String salesOrderNumber, java.lang.String referenceNumber)
java.util.Collection<GeneralLedgerVO> | getTransactionByNCRNumber(java.lang.String ncrNumber)
WorkOrderVO | getWorkOrderByWoForIR(java.lang.String id)
boolean | isCertificateNumberExist(java.lang.String certificateNumber)
boolean | isIcrExist(java.lang.String icrNumber)
boolean | isIcrFinishedInspection(java.lang.String poNumber, java.lang.String woNumber)
boolean | isNCRExist(java.lang.String ncrNumber)
boolean | isPartInspectionExist(PartInspectionPK pk)
boolean | isPOSurveyReportExist(java.lang.String srNumber)
boolean | isQualityGroupExist(java.lang.String userName, java.lang.String addId)
boolean | isSerialNumberExist(java.lang.String serialNumber)
java.lang.String | makeNcrScrapGl(NcrScrapAgent agent)
void | setNCRReferenceDocOne(java.lang.String ncrNumber, java.lang.String referenceDoc)
void | setNCRReferenceDocTwo(java.lang.String ncrNumber, java.lang.String referenceDoc)
AddressQualityDocumentsVO | updateAddressQualityDocuments(AddressQualityDocumentsVO vo)
AddressQualityDocumentsVO | updateAddressQualityDocumentsInfo(AddressQualityDocumentsVO vo)
CorrectiveActionRequestVO | updateCar(CorrectiveActionRequestVO vo)
CertificateDescriptionVO | updateCertificateDescription(CertificateDescriptionVO vo)
void | updateICR(InspectionConformanceReportVO vo)
void | updateICRItem(InspectionConformanceReportItemVO vo)
InspectionTypeVO | updateInspectionType(InspectionTypeVO vo)
NonConformanceCodeVO | updateNCC(NonConformanceCodeVO vo)
NonConformanceReportVO | updateNCR(NonConformanceReportVO vo, java.util.HashSet<PuttoInQAAgent> putToInQAAgentSet, java.util.HashSet<PullFromWorkOrderPartDetailAgent> pullFromWorkOrderPartDetailAgentSet, java.util.HashSet<RebackInQAAgent> reBackInQAAgentSet)
void | updateNcrApproval(NcrApprovalVO vo)
void | updateNCRPicture(NCRPictureVO vo)
PreventiveActionRequestVO | updatePAR(PreventiveActionRequestVO vo)
void | updatePartInspection(PartInspectionResult result)
void | updatePartWithInspectionType(java.util.HashSet<BB2Part> set, java.lang.String inspectionType)
POSurveyReportVO | updatePOSurveyReport(POSurveyReportVO vo)
QualityGroupVO | updateQualityGroup(QualityGroupVO vo)
SerialNumberVO | updateSerialNumber(SerialNumberVO vo)
java.util.Collection<AddressQualityDocumentsVO> | uploadOrUpdateAddressQualityDocuments(MiscDocAgent agent)
java.util.Collection<NCRPictureVO> | uploadOrUpdateNCRPicture(MiscDocAgent agent)
java.util.Collection<PreventiveActionRequestItemVO> | uploadOrUpdatePARDoc(MiscDocAgent agent)
PartCertificateVO | uploadPartCertificate(MiscDocAgent agent)

Method Detail

addCar

CorrectiveActionRequestVO addCar(CorrectiveActionRequestVO vo)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

deleteCar

void deleteCar(CorrectiveActionRequestVO vo)
               throws java.lang.Exception
Throws:
java.lang.Exception

updateCar

CorrectiveActionRequestVO updateCar(CorrectiveActionRequestVO vo)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findAllCars

java.util.Collection<CorrectiveActionRequestVO> findAllCars(int firstIndex,
                                                            int maxLength)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getAllCarsCount

int getAllCarsCount()
                    throws java.lang.Exception
Throws:
java.lang.Exception

findCarByPk

CorrectiveActionRequestVO findCarByPk(java.lang.String carNumber)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findCarsByPn

java.util.Collection<CorrectiveActionRequestVO> findCarsByPn(java.lang.String pn,
                                                             java.lang.String pa,
                                                             int firstIndex,
                                                             int maxLength)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getCarsCountByPn

int getCarsCountByPn(java.lang.String pn,
                     java.lang.String pa)
                     throws java.lang.Exception
Throws:
java.lang.Exception

findCarsByPastDue

java.util.Collection<CorrectiveActionRequestVO> findCarsByPastDue(int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getCarsCountByPastDue

int getCarsCountByPastDue()
                          throws java.lang.Exception
Throws:
java.lang.Exception

findCarsByStatus

java.util.Collection<CorrectiveActionRequestVO> findCarsByStatus(java.lang.String status,
                                                                 int firstIndex,
                                                                 int maxLength)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getCarsCountByStatus

int getCarsCountByStatus(java.lang.String status)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findCars

java.util.Collection<CorrectiveActionRequestVO> findCars(java.lang.String carNumber,
                                                         java.lang.String pn,
                                                         java.lang.String pa,
                                                         java.lang.String id,
                                                         java.util.Date fromDate,
                                                         java.util.Date toDate,
                                                         int firstIndex,
                                                         int maxLength)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getCarsCount

int getCarsCount(java.lang.String carNumber,
                 java.lang.String pn,
                 java.lang.String pa,
                 java.lang.String id,
                 java.util.Date fromDate,
                 java.util.Date toDate)
                 throws java.lang.Exception
Throws:
java.lang.Exception

findCarsByCarNumber

java.util.Collection<CorrectiveActionRequestVO> findCarsByCarNumber(java.lang.String carNumber,
                                                                    int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getCarsCountByCarNumber

int getCarsCountByCarNumber(java.lang.String carNumber)
                            throws java.lang.Exception
Throws:
java.lang.Exception

addPAR

PreventiveActionRequestVO addPAR(PreventiveActionRequestVO vo)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

deletePAR

void deletePAR(java.lang.String parNumber)
               throws java.lang.Exception
Throws:
java.lang.Exception

updatePAR

PreventiveActionRequestVO updatePAR(PreventiveActionRequestVO vo)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

uploadOrUpdatePARDoc

java.util.Collection<PreventiveActionRequestItemVO> uploadOrUpdatePARDoc(MiscDocAgent agent)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

downloadPARDoc

BB2File downloadPARDoc(MiscDocAgent agent)
                       throws java.lang.Exception
Throws:
java.lang.Exception

deletePARDoc

java.util.Collection<PreventiveActionRequestItemVO> deletePARDoc(MiscDocAgent agent)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findAllPars

java.util.Collection<PreventiveActionRequestVO> findAllPars(int firstIndex,
                                                            int maxLength)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getAllPARsCount

int getAllPARsCount()
                    throws java.lang.Exception
Throws:
java.lang.Exception

findPARByPk

PreventiveActionRequestVO findPARByPk(java.lang.String pk)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findPARsByParNumber

java.util.Collection<PreventiveActionRequestVO> findPARsByParNumber(java.lang.String parNumber,
                                                                    int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getPARsCountByParNumber

int getPARsCountByParNumber(java.lang.String parNumber)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findOpenPARs

java.util.Collection<PreventiveActionRequestVO> findOpenPARs(int firstIndex,
                                                             int maxLength)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getOpenPARsCount

int getOpenPARsCount()
                     throws java.lang.Exception
Throws:
java.lang.Exception

findPARsByPn

java.util.Collection<PreventiveActionRequestVO> findPARsByPn(java.lang.String pn,
                                                             java.lang.String pa,
                                                             int firstIndex,
                                                             int maxLength)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getPARsCountByPn

int getPARsCountByPn(java.lang.String pn,
                     java.lang.String pa)
                     throws java.lang.Exception
Throws:
java.lang.Exception

findPARsByDate

java.util.Collection<PreventiveActionRequestVO> findPARsByDate(java.lang.String pn,
                                                               java.lang.String pa,
                                                               java.lang.String customerId,
                                                               java.util.Date fromDate,
                                                               java.util.Date toDate,
                                                               int firstIndex,
                                                               int maxLength)
                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getOpenPARsCountByDate

int getOpenPARsCountByDate(java.lang.String pn,
                           java.lang.String pa,
                           java.lang.String customerId,
                           java.util.Date fromDate,
                           java.util.Date toDate)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findPARItemsByPAR

java.util.Collection<PreventiveActionRequestItemVO> findPARItemsByPAR(java.lang.String parNumber)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getPARItemsByPAR

int getPARItemsByPAR(java.lang.String parNumber)
                     throws java.lang.Exception
Throws:
java.lang.Exception

findDuePARs

java.util.Collection<PreventiveActionRequestVO> findDuePARs(int firstIndex,
                                                            int maxLength)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getDuePARsCount

int getDuePARsCount()
                    throws java.lang.Exception
Throws:
java.lang.Exception

addCertificateDescription

CertificateDescriptionVO addCertificateDescription(CertificateDescriptionVO vo)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

updateCertificateDescription

CertificateDescriptionVO updateCertificateDescription(CertificateDescriptionVO vo)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

deleteCertificateDescription

void deleteCertificateDescription(CertificateDescriptionVO vo)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

getAllCertificateDescsCount

int getAllCertificateDescsCount()
                                throws java.lang.Exception
Throws:
java.lang.Exception

findCertificateDescByPk

CertificateDescriptionVO findCertificateDescByPk(int pk)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findCertificateDescs

java.util.Collection<CertificateDescriptionVO> findCertificateDescs(int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

findAllCertificateDescs

java.util.Collection<CertificateDescriptionVO> findAllCertificateDescs()
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

isCertificateNumberExist

boolean isCertificateNumberExist(java.lang.String certificateNumber)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findAllPartCertificates

java.util.Collection<PartCertificateListResult> findAllPartCertificates(int firstIndex,
                                                                        int maxLength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getAllPartCertificatesCount

int getAllPartCertificatesCount()
                                throws java.lang.Exception
Throws:
java.lang.Exception

getPartCertificateByCertificateNumber

PartCertificateVO getPartCertificateByCertificateNumber(java.lang.String cnNumber)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

findPartCertificateByPk

PartCertificateVO findPartCertificateByPk(int pk)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

findPartCertificatesByCn

java.util.Collection<PartCertificateListResult> findPartCertificatesByCn(java.lang.String cn,
                                                                         int firstIndex,
                                                                         int maxLength)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getPartCertificatesCountByCn

int getPartCertificatesCountByCn(java.lang.String cn)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findPartCertificatesByCertificateDesc

java.util.Collection<PartCertificateListResult> findPartCertificatesByCertificateDesc(java.lang.String cn,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPartCertificatesCountByCertificateDesc

int getPartCertificatesCountByCertificateDesc(java.lang.String cn)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

findPartCertificatesByRn

java.util.Collection<PartCertificateListResult> findPartCertificatesByRn(java.lang.String rn,
                                                                         int firstIndex,
                                                                         int maxLength)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getPartCertificatesCountByRn

int getPartCertificatesCountByRn(java.lang.String rn)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findPartCertificatesByPn

java.util.Collection<PartCertificateListResult> findPartCertificatesByPn(java.lang.String partNumberRegex,
                                                                         java.lang.String partType,
                                                                         int firstIndex,
                                                                         int maxLength)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getPartCertificatesCountByPn

int getPartCertificatesCountByPn(java.lang.String partNumberRegex,
                                 java.lang.String partType)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findPartCertificatesByWo

java.util.Collection<PartCertificateListResult> findPartCertificatesByWo(java.lang.String wo,
                                                                         int firstIndex,
                                                                         int maxLength)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getPartCertificatesCountByWo

int getPartCertificatesCountByWo(java.lang.String wo)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findPartCertificatesByPo

java.util.Collection<PartCertificateListResult> findPartCertificatesByPo(java.lang.String po,
                                                                         int firstIndex,
                                                                         int maxLength)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getPartCertificatesCountByPo

int getPartCertificatesCountByPo(java.lang.String po)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findPartCertificatesByRef

java.util.Collection<PartCertificateListResult> findPartCertificatesByRef(java.lang.String ref,
                                                                          int firstIndex,
                                                                          int maxLength)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getPartCertificatesCountByRef

int getPartCertificatesCountByRef(java.lang.String ref)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

deletePartCertificate

void deletePartCertificate(MiscDocAgent agent)
                           throws java.lang.Exception
Throws:
java.lang.Exception

uploadPartCertificate

PartCertificateVO uploadPartCertificate(MiscDocAgent agent)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

downloadPartCertificateFile

BB2File downloadPartCertificateFile(MiscDocAgent agent)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

addNCC

NonConformanceCodeVO addNCC(NonConformanceCodeVO vo)
                            throws java.lang.Exception
Throws:
java.lang.Exception

updateNCC

NonConformanceCodeVO updateNCC(NonConformanceCodeVO vo)
                               throws java.lang.Exception
Throws:
java.lang.Exception

deleteNCC

void deleteNCC(NonConformanceCodeVO vo)
               throws java.lang.Exception
Throws:
java.lang.Exception

findAllNCCs

java.util.Collection<NonConformanceCodeVO> findAllNCCs(int firstIndex,
                                                       int maxLength)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getAllNCCsCount

int getAllNCCsCount()
                    throws java.lang.Exception
Throws:
java.lang.Exception

findNccById

NonConformanceCodeVO findNccById(java.lang.String code)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findNCQsByNCCode

java.util.Collection<NCQRejectResult> findNCQsByNCCode(java.lang.String nCCode,
                                                       java.util.Date dateFrom,
                                                       java.util.Date dateTo,
                                                       int firstIndex,
                                                       int maxLength)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

findNCQsByNCCode

java.util.Collection<NCQRejectResult> findNCQsByNCCode(java.lang.String[] nCCodes,
                                                       java.util.Date dateFrom,
                                                       java.util.Date dateTo,
                                                       int firstIndex,
                                                       int maxLength)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getNCQsByNCCodeCount

int getNCQsByNCCodeCount(java.lang.String nCCode,
                         java.util.Date dateFrom,
                         java.util.Date dateTo)
                         throws java.lang.Exception
Throws:
java.lang.Exception

addNCR

java.lang.String addNCR(NonConformanceReportVO vo)
                        throws java.lang.Exception
Throws:
java.lang.Exception

addNCR

java.lang.String addNCR(NonConformanceReportVO vo,
                        java.util.HashSet<java.lang.Integer> sets)
                        throws java.lang.Exception
Throws:
java.lang.Exception

updateNCR

NonConformanceReportVO updateNCR(NonConformanceReportVO vo,
                                 java.util.HashSet<PuttoInQAAgent> putToInQAAgentSet,
                                 java.util.HashSet<PullFromWorkOrderPartDetailAgent> pullFromWorkOrderPartDetailAgentSet,
                                 java.util.HashSet<RebackInQAAgent> reBackInQAAgentSet)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

deleteNCR

void deleteNCR(NonConformanceReportVO vo)
               throws java.lang.Exception
Throws:
java.lang.Exception

setNCRReferenceDocOne

void setNCRReferenceDocOne(java.lang.String ncrNumber,
                           java.lang.String referenceDoc)
                           throws java.lang.Exception
Throws:
java.lang.Exception

setNCRReferenceDocTwo

void setNCRReferenceDocTwo(java.lang.String ncrNumber,
                           java.lang.String referenceDoc)
                           throws java.lang.Exception
Throws:
java.lang.Exception

clearNCRReferenceDocOne

void clearNCRReferenceDocOne(java.lang.String referenceDoc)
                             throws java.lang.Exception
Throws:
java.lang.Exception

clearNCRReferenceDocTwo

void clearNCRReferenceDocTwo(java.lang.String referenceDoc)
                             throws java.lang.Exception
Throws:
java.lang.Exception

isNCRExist

boolean isNCRExist(java.lang.String ncrNumber)
                   throws java.lang.Exception
Throws:
java.lang.Exception

findAllNCRs

java.util.Collection<NonConformanceReportVO> findAllNCRs(int firstIndex,
                                                         int maxLength)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getAllNCRsCount

int getAllNCRsCount()
                    throws java.lang.Exception
Throws:
java.lang.Exception

findNcrById

NonConformanceReportVO findNcrById(java.lang.String ncrNumber)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findDueNCRs

java.util.Collection<NonConformanceReportVO> findDueNCRs(int firstIndex,
                                                         int maxLength)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getDueNCRsCount

int getDueNCRsCount()
                    throws java.lang.Exception
Throws:
java.lang.Exception

findOpenNCRs

java.util.Collection<NonConformanceReportVO> findOpenNCRs(int firstIndex,
                                                          int maxLength)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getOpenNCRsCount

int getOpenNCRsCount()
                     throws java.lang.Exception
Throws:
java.lang.Exception

findNCRsToCreateScrapGlByDate

java.util.Collection<NcrNeedToScrapListResult> findNCRsToCreateScrapGlByDate(java.lang.String pnLike,
                                                                             java.lang.String partType,
                                                                             java.util.Date fromDate,
                                                                             java.util.Date toDate,
                                                                             java.lang.String status,
                                                                             int firstIndex,
                                                                             int maxLength)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getNCRsToCreateScrapGlByDateCount

int getNCRsToCreateScrapGlByDateCount(java.lang.String pnLike,
                                      java.lang.String partType,
                                      java.util.Date fromDate,
                                      java.util.Date toDate,
                                      java.lang.String status)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findNCRsByPart

java.util.Collection<NonConformanceReportVO> findNCRsByPart(PartPK pk,
                                                            int firstIndex,
                                                            int maxLength)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getNCRSCountByPart

int getNCRSCountByPart(PartPK pk)
                       throws java.lang.Exception
Throws:
java.lang.Exception

findOpenNCRsByPartPK

java.util.Collection<NonConformanceReportVO> findOpenNCRsByPartPK(PartPK pk,
                                                                  int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getOpenNCRsCountByPartPK

int getOpenNCRsCountByPartPK(PartPK pk)
                             throws java.lang.Exception
Throws:
java.lang.Exception

findNCRsByNcrNumber

java.util.Collection<NonConformanceReportVO> findNCRsByNcrNumber(java.lang.String ncrNumberRegexp,
                                                                 int firstIndex,
                                                                 int maxLength)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getNCRsCountByNcrNumber

int getNCRsCountByNcrNumber(java.lang.String ncrNumberRegexp)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findNCRsByDate

java.util.Collection<NcrReportListResult> findNCRsByDate(java.lang.String pnLike,
                                                         java.lang.String partType,
                                                         java.lang.String id,
                                                         java.lang.String ncCode,
                                                         java.lang.String purchaseOrderNumber,
                                                         java.lang.String workOrderNumber,
                                                         java.lang.String salesOrderNumber,
                                                         java.lang.String rtvNumber,
                                                         java.lang.String dateType,
                                                         java.util.Date fromDate,
                                                         java.util.Date toDate,
                                                         java.lang.String status,
                                                         java.lang.String enterBy,
                                                         java.lang.String responsibility,
                                                         java.lang.String problemDescription,
                                                         java.lang.String problemDisposition,
                                                         java.lang.String closedOutPrivateNotes,
                                                         java.lang.String buyer,
                                                         java.lang.String approvalType,
                                                         java.lang.String approvedType,
                                                         java.lang.String approval,
                                                         int firstIndex,
                                                         int maxLength)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getNCRsCountByDate

int getNCRsCountByDate(java.lang.String pnLike,
                       java.lang.String partType,
                       java.lang.String id,
                       java.lang.String ncCode,
                       java.lang.String purchaseOrderNumber,
                       java.lang.String workOrderNumber,
                       java.lang.String salesOrderNumber,
                       java.lang.String rtvNumber,
                       java.lang.String dateType,
                       java.util.Date fromDate,
                       java.util.Date toDate,
                       java.lang.String status,
                       java.lang.String enterBy,
                       java.lang.String responsibility,
                       java.lang.String problemDescription,
                       java.lang.String problemDisposition,
                       java.lang.String closedOutPrivateNotes,
                       java.lang.String buyer,
                       java.lang.String approvalType,
                       java.lang.String approvedType,
                       java.lang.String approval)
                       throws java.lang.Exception
Throws:
java.lang.Exception

findAllCanClosedNcrs

java.util.Collection<NcrReportListResult> findAllCanClosedNcrs(java.lang.String pnLike,
                                                               java.lang.String partType,
                                                               java.lang.String dateType,
                                                               java.util.Date fromDate,
                                                               java.util.Date toDate,
                                                               boolean isListNotZero,
                                                               boolean isListEquals,
                                                               int firstIndex,
                                                               int maxLength)
                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getAllCanClosedNcrsCount

int getAllCanClosedNcrsCount(java.lang.String pnLike,
                             java.lang.String partType,
                             java.lang.String dateType,
                             java.util.Date fromDate,
                             java.util.Date toDate,
                             boolean isListNotZero,
                             boolean isListEquals)
                             throws java.lang.Exception
Throws:
java.lang.Exception

batchCloseNcrs

void batchCloseNcrs(java.util.List<java.lang.String> ncrNumbers)
                    throws java.lang.Exception
Throws:
java.lang.Exception

makeNcrScrapGl

java.lang.String makeNcrScrapGl(NcrScrapAgent agent)
                                throws java.lang.Exception
Throws:
java.lang.Exception

getTransactionByNCRNumber

java.util.Collection<GeneralLedgerVO> getTransactionByNCRNumber(java.lang.String ncrNumber)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

uploadOrUpdateNCRPicture

java.util.Collection<NCRPictureVO> uploadOrUpdateNCRPicture(MiscDocAgent agent)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

deleteNCRPicture

java.util.Collection<NCRPictureVO> deleteNCRPicture(MiscDocAgent agent)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

downLoadNCRPicture

BB2File downLoadNCRPicture(MiscDocAgent agent)
                           throws java.lang.Exception
Throws:
java.lang.Exception

addNCRPicture

void addNCRPicture(NCRPictureVO vo)
                   throws java.lang.Exception
Throws:
java.lang.Exception

updateNCRPicture

void updateNCRPicture(NCRPictureVO vo)
                      throws java.lang.Exception
Throws:
java.lang.Exception

deleteNCRPicture

void deleteNCRPicture(java.lang.Long ii)
                      throws java.lang.Exception
Throws:
java.lang.Exception

getNCRPicture

NCRPictureVO getNCRPicture(java.lang.Long ii)
                           throws java.lang.Exception
Throws:
java.lang.Exception

getNCRPictureListResults

java.util.Collection<NCRPictureListResult> getNCRPictureListResults(java.lang.String ncrNumber)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

addSerialNumber

SerialNumberPK addSerialNumber(PartCertificateVO partCertificateVo)
                               throws java.lang.Exception
Throws:
java.lang.Exception

addSerialNumber

SerialNumberPK addSerialNumber(PartCertificateVO partCertificateVo,
                               java.lang.String originalCertificateNumber)
                               throws java.lang.Exception
Throws:
java.lang.Exception

deleteSerialNumber

void deleteSerialNumber(java.lang.String serialNumber)
                        throws java.lang.Exception
Throws:
java.lang.Exception

updateSerialNumber

SerialNumberVO updateSerialNumber(SerialNumberVO vo)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

isSerialNumberExist

boolean isSerialNumberExist(java.lang.String serialNumber)
                            throws java.lang.Exception
Throws:
java.lang.Exception

getAllSerialNumberCount

int getAllSerialNumberCount()
                            throws java.lang.Exception
Throws:
java.lang.Exception

findSerialNumberByPk

SerialNumberVO findSerialNumberByPk(SerialNumberPK pk)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findAllSerialNumbers

java.util.Collection<SerialNumberVO> findAllSerialNumbers(int firstIndex,
                                                          int maxLength)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

findSerialNumbersBySerialNumber

java.util.Collection<PartCertificateListResult> findSerialNumbersBySerialNumber(java.lang.String serialNumberLike,
                                                                                java.lang.String partNumber,
                                                                                java.lang.String partType,
                                                                                java.lang.String workerOrderNumber,
                                                                                java.lang.String purchaseOrderNumber,
                                                                                java.lang.String salesOrderNumber,
                                                                                java.lang.String referenceNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getSerialNumbersCountBySerialNumber

int getSerialNumbersCountBySerialNumber(java.lang.String serialNumberLike,
                                        java.lang.String partNumber,
                                        java.lang.String partType,
                                        java.lang.String workerOrderNumber,
                                        java.lang.String purchaseOrderNumber,
                                        java.lang.String salesOrderNumber,
                                        java.lang.String referenceNumber)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

getSerialNumberResult

SerialNumberResult getSerialNumberResult(SerialNumberPK pk)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

getBB2PartDescription

java.lang.String getBB2PartDescription(BB2Part part,
                                       java.lang.String language)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findSerialNumberByPn

java.util.Collection<PartCertificateVO> findSerialNumberByPn(java.lang.String partNumberRegex,
                                                             java.lang.String partType,
                                                             int firstIndex,
                                                             int maxLength)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getSerialNumbersCountByPn

int getSerialNumbersCountByPn(java.lang.String partNumberRegex,
                              java.lang.String partType)
                              throws java.lang.Exception
Throws:
java.lang.Exception

uploadOrUpdateAddressQualityDocuments

java.util.Collection<AddressQualityDocumentsVO> uploadOrUpdateAddressQualityDocuments(MiscDocAgent agent)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

deleteAddressQualityDocuments

java.util.Collection<AddressQualityDocumentsVO> deleteAddressQualityDocuments(MiscDocAgent agent)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

downloadAddressQualityDocuments

byte[] downloadAddressQualityDocuments(MiscDocAgent agent)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

addAddressQualityDocuments

AddressQualityDocumentsVO addAddressQualityDocuments(AddressQualityDocumentsVO vo)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getAddressQualityDocumentInfo

AddressQualityDocumentsVO getAddressQualityDocumentInfo(java.lang.Long ii)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

updateAddressQualityDocuments

AddressQualityDocumentsVO updateAddressQualityDocuments(AddressQualityDocumentsVO vo)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

updateAddressQualityDocumentsInfo

AddressQualityDocumentsVO updateAddressQualityDocumentsInfo(AddressQualityDocumentsVO vo)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

findAddressQualityDocumentsInfo

java.util.Collection<AddressQualityDocumentsVO> findAddressQualityDocumentsInfo(java.lang.String addressId,
                                                                                boolean useLikeMatch,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAccressQualityDocumentsCount

int getAccressQualityDocumentsCount(java.lang.String addressId,
                                    boolean useLikeMatch)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

deleteAddressQualityDocuments

void deleteAddressQualityDocuments(java.lang.Long ii)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

getAddressQualityDocument

AddressQualityDocumentsVO getAddressQualityDocument(java.lang.Long ii)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

addQualityGroup

QualityGroupVO addQualityGroup(QualityGroupVO vo)
                               throws java.lang.Exception
Throws:
java.lang.Exception

deleteQualityGroup

void deleteQualityGroup(QualityGroupVO vo)
                        throws java.lang.Exception
Throws:
java.lang.Exception

updateQualityGroup

QualityGroupVO updateQualityGroup(QualityGroupVO vo)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findQualityGroupByPk

QualityGroupVO findQualityGroupByPk(QualityGroupPK pk)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

getAllQualityGroupsCount

int getAllQualityGroupsCount()
                             throws java.lang.Exception
Throws:
java.lang.Exception

findAllQualityGroups

java.util.Collection<QualityGroupVO> findAllQualityGroups(int firstIndex,
                                                          int maxLength)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

isQualityGroupExist

boolean isQualityGroupExist(java.lang.String userName,
                            java.lang.String addId)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findAllPartInQAsToMakeNCR

java.util.Collection<PartInQAVO> findAllPartInQAsToMakeNCR(java.lang.String partNumber,
                                                           int firstIndex,
                                                           int maxLength)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getAllPartInQAsToMakeNCRCount

int getAllPartInQAsToMakeNCRCount(java.lang.String partNumber)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findNCRListByNCCode

java.util.Collection<NcrReportListResult> findNCRListByNCCode(java.lang.String nCCode,
                                                              java.util.Date dateFrom,
                                                              java.util.Date dateTo,
                                                              int firstIndex,
                                                              int maxLength)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getNCRListByNCCodeCount

int getNCRListByNCCodeCount(java.lang.String nCCode,
                            java.util.Date dateFrom,
                            java.util.Date dateTo)
                            throws java.lang.Exception
Throws:
java.lang.Exception

addICR

java.lang.String addICR(InspectionConformanceReportVO vo)
                        throws java.lang.Exception
Throws:
java.lang.Exception

updateICR

void updateICR(InspectionConformanceReportVO vo)
               throws java.lang.Exception
Throws:
java.lang.Exception

updateICRItem

void updateICRItem(InspectionConformanceReportItemVO vo)
                   throws java.lang.Exception
Throws:
java.lang.Exception

isIcrExist

boolean isIcrExist(java.lang.String icrNumber)
                   throws java.lang.Exception
Throws:
java.lang.Exception

isIcrFinishedInspection

boolean isIcrFinishedInspection(java.lang.String poNumber,
                                java.lang.String woNumber)
                                throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderByPoNumberForIR

PurchaseOrderVO getPurchaseOrderByPoNumberForIR(java.lang.String poNumber)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderByWoForIR

WorkOrderVO getWorkOrderByWoForIR(java.lang.String id)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findIcrById

InspectionConformanceReportVO findIcrById(java.lang.String icrNumber)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

findIcrItemByPk

InspectionConformanceReportItemVO findIcrItemByPk(InspectionConformanceReportItemPK pk)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getIcrItemInfoByPk

InspectionConformanceReportItemInfo getIcrItemInfoByPk(InspectionConformanceReportItemPK pk)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

findIcrsById

java.util.Collection<IcrListResult> findIcrsById(java.lang.String icrNumber,
                                                 int firstIndex,
                                                 int maxLength)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getIcrsCountById

int getIcrsCountById(java.lang.String icrNumber)
                     throws java.lang.Exception
Throws:
java.lang.Exception

findIcrsByVendorId

java.util.Collection<IcrListResult> findIcrsByVendorId(java.lang.String vendorId,
                                                       int firstIndex,
                                                       int maxLength)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getIcrsCountByVendorId

int getIcrsCountByVendorId(java.lang.String vendorId)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findIcrItemsByDate

java.util.Collection<IcrItemListResult> findIcrItemsByDate(java.lang.String icrNumber,
                                                           java.lang.String vendorId,
                                                           java.lang.String pn,
                                                           java.lang.String inspector,
                                                           java.lang.String wo,
                                                           java.lang.String po,
                                                           java.util.Date from,
                                                           java.util.Date to,
                                                           java.lang.String status,
                                                           java.lang.String dateType,
                                                           int firstIndex,
                                                           int maxLength)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getIcrItemsCountByDate

int getIcrItemsCountByDate(java.lang.String icrNumber,
                           java.lang.String vendorId,
                           java.lang.String inspector,
                           java.lang.String wo,
                           java.lang.String pn,
                           java.lang.String po,
                           java.util.Date from,
                           java.util.Date to,
                           java.lang.String status,
                           java.lang.String dateType)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findOpenIcrs

java.util.Collection<IcrListResult> findOpenIcrs(java.lang.String icrNumber,
                                                 int firstIndex,
                                                 int maxLength)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getOpenIcrsCount

int getOpenIcrsCount(java.lang.String icrNumber)
                     throws java.lang.Exception
Throws:
java.lang.Exception

addPartInspection

PartInspectionVO addPartInspection(PartInspectionVO vo)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

updatePartInspection

void updatePartInspection(PartInspectionResult result)
                          throws java.lang.Exception
Throws:
java.lang.Exception

deletePartInspection

void deletePartInspection(PartInspectionPK pk)
                          throws java.lang.Exception
Throws:
java.lang.Exception

getPartInspection

PartInspectionVO getPartInspection(PartInspectionPK pk)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

isPartInspectionExist

boolean isPartInspectionExist(PartInspectionPK pk)
                              throws java.lang.Exception
Throws:
java.lang.Exception

getPartInspectionCountByPartPK

int getPartInspectionCountByPartPK(java.lang.String partNumber,
                                   java.lang.String partType,
                                   java.lang.String partFrom)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findPartInspectionByPartPk

java.util.Collection<PartInspectionVO> findPartInspectionByPartPk(java.lang.String partNumber,
                                                                  java.lang.String partType,
                                                                  java.lang.String partFrom,
                                                                  int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

addPOSurveyReportWithPO

java.lang.String addPOSurveyReportWithPO(POSurveyReportAgent agent)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

updatePOSurveyReport

POSurveyReportVO updatePOSurveyReport(POSurveyReportVO vo)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

deletePOSurveyReport

void deletePOSurveyReport(java.lang.String srNumber)
                          throws java.lang.Exception
Throws:
java.lang.Exception

getPOSurveyReport

POSurveyReportVO getPOSurveyReport(java.lang.String srNumber)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

isPOSurveyReportExist

boolean isPOSurveyReportExist(java.lang.String srNumber)
                              throws java.lang.Exception
Throws:
java.lang.Exception

getPOSurveyReportCount

int getPOSurveyReportCount(java.lang.String srNumber,
                           java.lang.String purchaseOrderNumber,
                           java.lang.String vendorId)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findPOSurveyReport

java.util.Collection<POSurveyReportVO> findPOSurveyReport(java.lang.String srNumber,
                                                          java.lang.String purchaseOrderNumber,
                                                          java.lang.String vendorId,
                                                          int firstIndex,
                                                          int maxLength)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

findLogTrackings

java.util.Collection<LogTrackingVO> findLogTrackings(java.lang.String partNumber,
                                                     java.lang.String partType,
                                                     java.lang.String trackingNumber,
                                                     java.lang.String refDoc1,
                                                     java.lang.String refDoc2,
                                                     java.lang.String operator,
                                                     java.lang.String location,
                                                     java.util.Date fromDate,
                                                     java.util.Date toDate,
                                                     int operationType,
                                                     int firstIndex,
                                                     int maxLength)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getLogTrackingsCount

int getLogTrackingsCount(java.lang.String partNumber,
                         java.lang.String partType,
                         java.lang.String trackingNumber,
                         java.lang.String refDoc1,
                         java.lang.String refDoc2,
                         java.lang.String operator,
                         java.lang.String location,
                         java.util.Date fromDate,
                         java.util.Date toDate,
                         int operationType)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findPartTracking

java.util.Collection<PartTrackingVO> findPartTracking(PartPK pk)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

findPartTrackingByPk

PartTrackingVO findPartTrackingByPk(PartTrackingPK pk)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findPartOnhandWithoutTracking

java.util.Collection<java.util.Map> findPartOnhandWithoutTracking(java.lang.String partNumber,
                                                                  java.lang.String partType,
                                                                  boolean onlyPartwithouttrackingQty,
                                                                  int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getPartOnhandWithoutTrackingCount

int getPartOnhandWithoutTrackingCount(java.lang.String partNumber,
                                      java.lang.String partType,
                                      boolean onlyPartwithouttrackingQty)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

addMultiplePartTracking

void addMultiplePartTracking(java.util.Collection<PartTrackingVO> partTrackings)
                             throws java.lang.Exception
Throws:
java.lang.Exception

findCustomerVendorIDByOrderNumber

NonConformanceReportVO findCustomerVendorIDByOrderNumber(java.lang.String orderNumber)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

findAddressQualityDocumentsByCategory

java.util.Collection<AddressQualityDocumentsVO> findAddressQualityDocumentsByCategory(java.lang.String category,
                                                                                java.lang.String id)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findPartCertificateByCertificateNumber

java.util.Collection<PartCertificateVO> findPartCertificateByCertificateNumber(java.lang.String partCertificateNumber,
                                                                               java.lang.String comments,
                                                                               java.lang.String partCertificateDesc,
                                                                               int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getPartCertificateByCertificateNumberCount

int getPartCertificateByCertificateNumberCount(java.lang.String partCertificateNumber,
                                               java.lang.String comments,
                                               java.lang.String partCertificateDesc)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

addInspectionType

InspectionTypeVO addInspectionType(InspectionTypeVO inspectionType)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

deleteInspectionType

void deleteInspectionType(InspectionTypeVO inspectionType)
                          throws java.lang.Exception
Throws:
java.lang.Exception

updateInspectionType

InspectionTypeVO updateInspectionType(InspectionTypeVO vo)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

getInspectionType

InspectionTypeVO getInspectionType(java.lang.String type)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findInspectionType

java.util.Collection<InspectionTypeVO> findInspectionType(java.lang.String type,
                                                          int firstIndex,
                                                          int maxLength)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getInspectionTypeCount

int getInspectionTypeCount(java.lang.String type)
                           throws java.lang.Exception
Throws:
java.lang.Exception

getAllInspectionType

java.util.Collection<java.lang.String> getAllInspectionType()
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

updatePartWithInspectionType

void updatePartWithInspectionType(java.util.HashSet<BB2Part> set,
                                  java.lang.String inspectionType)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findPartWithInspectionType

java.util.Collection<PartInspectionResult> findPartWithInspectionType(java.lang.String partNumber,
                                                                      java.lang.String partType,
                                                                      java.lang.String partFrom,
                                                                      java.lang.String inspectionType,
                                                                      int firstIndex,
                                                                      int maxLength)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getPartWithInspectionTypeCount

int getPartWithInspectionTypeCount(java.lang.String partNumber,
                                   java.lang.String partType,
                                   java.lang.String partFrom,
                                   java.lang.String inspectionType)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findPartWithInspection

java.util.Collection<PartInspectionResult> findPartWithInspection(java.lang.String partNumber,
                                                                  java.lang.String partType,
                                                                  java.lang.String partFrom,
                                                                  int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getPartWithInspectionCount

int getPartWithInspectionCount(java.lang.String partNumber,
                               java.lang.String partType,
                               java.lang.String partFrom)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getPartInspection

PartInspectionResult getPartInspection(PartInspectionResult result)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

approvalNcrForQa

NonConformanceReportVO approvalNcrForQa(NonConformanceReportVO ncrVo)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

approvalNcrForEng

NonConformanceReportVO approvalNcrForEng(NonConformanceReportVO ncrVo)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

approvalNcrForMfg

NonConformanceReportVO approvalNcrForMfg(NonConformanceReportVO ncrVo)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

addNcrApproval

NcrApprovalVO addNcrApproval(java.lang.String employeeId,
                             java.lang.String approvableType)
                             throws java.lang.Exception
Throws:
java.lang.Exception

updateNcrApproval

void updateNcrApproval(NcrApprovalVO vo)
                       throws java.lang.Exception
Throws:
java.lang.Exception

deleteNcrApproval

void deleteNcrApproval(NcrApprovalPK pk)
                       throws java.lang.Exception
Throws:
java.lang.Exception

getNcrApprovalByEmployeeId

NcrApprovalVO getNcrApprovalByEmployeeId(NcrApprovalPK pk)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

findNcrApprovals

java.util.Collection<NcrApprovalVO> findNcrApprovals(java.lang.String approvableType,
                                                     int firstIndex,
                                                     int maxLength)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getNcrApprovalsCount

int getNcrApprovalsCount(java.lang.String approvableType)
                         throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QualityGroupPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class QualityGroupPK

java.lang.Object
    extended by  bb.common.QualityGroupPK
All Implemented Interfaces:
java.io.Serializable
public class QualityGroupPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
QualityGroupPK()
default constructor
QualityGroupPK(java.lang.String addId, java.lang.String userName)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAddId()
java.lang.String | getUserName()
int | hashCode()
void | setAddId(java.lang.String addId)
void | setUserName(java.lang.String userName)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

QualityGroupPK

public QualityGroupPK(java.lang.String addId,
                      java.lang.String userName)
full constructor

QualityGroupPK

public QualityGroupPK()
default constructor

Method Detail

getAddId

public java.lang.String getAddId()

setAddId

public void setAddId(java.lang.String addId)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QualityGroupVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class QualityGroupVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.QualityGroupVO
All Implemented Interfaces:
java.io.Serializable
public class QualityGroupVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
QualityGroupVO()
default constructor
QualityGroupVO(QualityGroupPK pk)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getCreateTime()
java.lang.String | getEmail()
java.lang.String | getPassword()
QualityGroupPK | getPk()
int | hashCode()
void | setCreateTime(java.util.Date createTime)
void | setEmail(java.lang.String email)
void | setPassword(java.lang.String password)
void | setPk(QualityGroupPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

QualityGroupVO

public QualityGroupVO(QualityGroupPK pk)
full constructor

QualityGroupVO

public QualityGroupVO()
default constructor

Method Detail

getCreateTime

public java.util.Date getCreateTime()

setCreateTime

public void setCreateTime(java.util.Date createTime)

getEmail

public java.lang.String getEmail()

setEmail

public void setEmail(java.lang.String email)

getPassword

public java.lang.String getPassword()

setPassword

public void setPassword(java.lang.String password)

getPk

public QualityGroupPK getPk()

setPk

public void setPk(QualityGroupPK pk)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QualityInfoCenterResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class QualityInfoCenterResult

java.lang.Object
    extended by  bb.common.QualityInfoCenterResult
All Implemented Interfaces:
java.io.Serializable
public class QualityInfoCenterResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
QualityInfoCenterResult()
Method Summary
java.math.BigDecimal | getCurrentMonthRejectQty()
java.math.BigDecimal | getLastMonthRejectQty()
java.lang.Integer | getOpenNcrCount()
java.lang.Integer | getPastDueNcrCount()
java.math.BigDecimal | getTotalInQaByCost()
void | setCurrentMonthRejectQty(java.math.BigDecimal currentMonthRejectQty)
void | setLastMonthRejectQty(java.math.BigDecimal lastMonthRejectQty)
void | setOpenNcrCount(java.lang.Integer openNcrCount)
void | setPastDueNcrCount(java.lang.Integer pastDueNcrCount)
void | setTotalInQaByCost(java.math.BigDecimal totalInQaByCost)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

QualityInfoCenterResult

public QualityInfoCenterResult()
Method Detail

setPastDueNcrCount

public void setPastDueNcrCount(java.lang.Integer pastDueNcrCount)

setOpenNcrCount

public void setOpenNcrCount(java.lang.Integer openNcrCount)

getPastDueNcrCount

public java.lang.Integer getPastDueNcrCount()

getOpenNcrCount

public java.lang.Integer getOpenNcrCount()

getTotalInQaByCost

public java.math.BigDecimal getTotalInQaByCost()

setTotalInQaByCost

public void setTotalInQaByCost(java.math.BigDecimal totalInQaByCost)

getCurrentMonthRejectQty

public java.math.BigDecimal getCurrentMonthRejectQty()

setCurrentMonthRejectQty

public void setCurrentMonthRejectQty(java.math.BigDecimal currentMonthRejectQty)

getLastMonthRejectQty

public java.math.BigDecimal getLastMonthRejectQty()

setLastMonthRejectQty

public void setLastMonthRejectQty(java.math.BigDecimal lastMonthRejectQty)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Quote2QuoteAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Quote2QuoteAgent

java.lang.Object
    extended by  bb.common.Quote2QuoteAgent
All Implemented Interfaces:
java.io.Serializable
public class Quote2QuoteAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
Quote2QuoteAgent()
Method Summary
java.lang.String | getBillToId()
java.lang.String | getCustomerId()
java.lang.String | getQuoteNumber()
java.lang.String | getShipToId()
void | setBillToId(java.lang.String billToId)
void | setCustomerId(java.lang.String customerId)
void | setQuoteNumber(java.lang.String quoteNumber)
void | setShipToId(java.lang.String shipToId)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Quote2QuoteAgent

public Quote2QuoteAgent()
Method Detail

getBillToId

public java.lang.String getBillToId()

setBillToId

public void setBillToId(java.lang.String billToId)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getShipToId

public java.lang.String getShipToId()

setShipToId

public void setShipToId(java.lang.String shipToId)

getQuoteNumber

public java.lang.String getQuoteNumber()

setQuoteNumber

public void setQuoteNumber(java.lang.String quoteNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QuoteBoilerplateVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class QuoteBoilerplateVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.QuoteBoilerplateVO
All Implemented Interfaces:
java.io.Serializable
public class QuoteBoilerplateVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_BOILERPLATEID
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_QTBOILERPLATE
Constructor Summary
QuoteBoilerplateVO()
default constructor
QuoteBoilerplateVO(java.lang.String boilerplateId, java.lang.String description)
minimal constructor
QuoteBoilerplateVO(java.lang.String boilerplateId, java.lang.String description, java.lang.String qtBoilerplate)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getBoilerplateId()
java.lang.String | getDescription()
java.lang.String | getQtBoilerplate()
int | hashCode()
void | setBoilerplateId(java.lang.String boilerplateId)
void | setDescription(java.lang.String description)
void | setQtBoilerplate(java.lang.String qtBoilerplate)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_BOILERPLATEID

public static final java.lang.String ORDER_BY_BOILERPLATEID
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_QTBOILERPLATE

public static final java.lang.String ORDER_BY_QTBOILERPLATE
See Also:
Constant Field Values
Constructor Detail

QuoteBoilerplateVO

public QuoteBoilerplateVO(java.lang.String boilerplateId,
                          java.lang.String description,
                          java.lang.String qtBoilerplate)
full constructor

QuoteBoilerplateVO

public QuoteBoilerplateVO()
default constructor

QuoteBoilerplateVO

public QuoteBoilerplateVO(java.lang.String boilerplateId,
                          java.lang.String description)
minimal constructor

Method Detail

getBoilerplateId

public java.lang.String getBoilerplateId()

setBoilerplateId

public void setBoilerplateId(java.lang.String boilerplateId)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getQtBoilerplate

public java.lang.String getQtBoilerplate()

setQtBoilerplate

public void setQtBoilerplate(java.lang.String qtBoilerplate)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QuoteDocumentVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class QuoteDocumentVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.QuoteDocumentVO
All Implemented Interfaces:
java.io.Serializable
public class QuoteDocumentVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
QuoteDocumentVO()
Method Summary
java.lang.String | getComments()
long | getDocLength()
java.lang.String | getDocName()
java.util.Date | getDocumentDate()
java.lang.String | getDocumentDescription()
java.lang.String | getDt()
java.lang.String | getExtension()
java.lang.Long | getIi()
java.util.Date | getLastChangeDate()
java.lang.String | getLastUser()
java.lang.String | getQuoteNumber()
void | setComments(java.lang.String comments)
void | setDocLength(long docLength)
void | setDocName(java.lang.String docName)
void | setDocumentDate(java.util.Date documentDate)
void | setDocumentDescription(java.lang.String documentDescription)
void | setDt(java.lang.String dt)
void | setExtension(java.lang.String extension)
void | setIi(java.lang.Long ii)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastUser(java.lang.String lastUser)
void | setQuoteNumber(java.lang.String quoteNumber)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

QuoteDocumentVO

public QuoteDocumentVO()
Method Detail

getDocLength

public long getDocLength()

setDocLength

public void setDocLength(long docLength)

getDocName

public java.lang.String getDocName()

setDocName

public void setDocName(java.lang.String docName)

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getQuoteNumber

public java.lang.String getQuoteNumber()

setQuoteNumber

public void setQuoteNumber(java.lang.String quoteNumber)

getDocumentDescription

public java.lang.String getDocumentDescription()

setDocumentDescription

public void setDocumentDescription(java.lang.String documentDescription)

getDt

public java.lang.String getDt()

setDt

public void setDt(java.lang.String dt)

getDocumentDate

public java.util.Date getDocumentDate()

setDocumentDate

public void setDocumentDate(java.util.Date documentDate)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getLastUser

public java.lang.String getLastUser()

setLastUser

public void setLastUser(java.lang.String lastUser)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QuoteItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class QuoteItemListResult

java.lang.Object
    extended by  bb.common.QuoteItemListResult
All Implemented Interfaces:
java.io.Serializable
public class QuoteItemListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_CUSTOMERRFQNUMBER
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_QTDATE
static java.lang.String | ORDER_BY_QTITEMNUMBER
static java.lang.String | ORDER_BY_QTNUMBER
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
QuoteItemListResult()
Method Summary
java.lang.String | getCurrency()
java.lang.String | getCustomerId()
java.lang.String | getCustomerRefNumber()
java.lang.String | getCustomerRfqNumber()
java.lang.String | getDelivery()
java.math.BigDecimal | getDiscount()
java.math.BigDecimal | getExtendsPrice()
java.lang.String | getItemDescription()
java.math.BigDecimal | getOnDemandQty()
java.math.BigDecimal | getOnhandQty()
java.math.BigDecimal | getOnorderQty()
java.math.BigDecimal | getOrderedQty()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.math.BigDecimal | getPricePerUnit()
java.util.Date | getQtDate()
java.lang.String | getQtItemNumber()
java.lang.String | getQtNumber()
java.lang.String | getShipVia()
java.math.BigDecimal | getSipQty()
java.lang.String | getStatus()
java.lang.String | getUnit()
java.math.BigDecimal | getWipQty()
void | setCurrency(java.lang.String currency)
void | setCustomerId(java.lang.String customerId)
void | setCustomerRefNumber(java.lang.String customerRefNumber)
void | setCustomerRfqNumber(java.lang.String customerRfqNumber)
void | setDelivery(java.lang.String delivery)
void | setDiscount(java.math.BigDecimal discount)
void | setExtendsPrice(java.math.BigDecimal extendsPrice)
void | setItemDescription(java.lang.String itemDescription)
void | setOnDemandQty(java.math.BigDecimal onDemandQty)
void | setOnhandQty(java.math.BigDecimal onhandQty)
void | setOnorderQty(java.math.BigDecimal onorderQty)
void | setOrderedQty(java.math.BigDecimal orderedQty)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setPricePerUnit(java.math.BigDecimal pricePerUnit)
void | setQtDate(java.util.Date qtDate)
void | setQtItemNumber(java.lang.String qtItemNumber)
void | setQtNumber(java.lang.String qtNumber)
void | setShipVia(java.lang.String shipVia)
void | setSipQty(java.math.BigDecimal sipQty)
void | setStatus(java.lang.String status)
void | setUnit(java.lang.String unit)
void | setWipQty(java.math.BigDecimal wipQty)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_QTNUMBER

public static final java.lang.String ORDER_BY_QTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_QTITEMNUMBER

public static final java.lang.String ORDER_BY_QTITEMNUMBER
See Also:
Constant Field Values

ORDER_BY_QTDATE

public static final java.lang.String ORDER_BY_QTDATE
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_CUSTOMERRFQNUMBER

public static final java.lang.String ORDER_BY_CUSTOMERRFQNUMBER
See Also:
Constant Field Values
Constructor Detail

QuoteItemListResult

public QuoteItemListResult()
Method Detail

getSipQty

public java.math.BigDecimal getSipQty()

setSipQty

public void setSipQty(java.math.BigDecimal sipQty)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getWipQty

public java.math.BigDecimal getWipQty()

setWipQty

public void setWipQty(java.math.BigDecimal wipQty)

getOnDemandQty

public java.math.BigDecimal getOnDemandQty()

getOnorderQty

public java.math.BigDecimal getOnorderQty()

getOnhandQty

public java.math.BigDecimal getOnhandQty()

getStatus

public java.lang.String getStatus()

getShipVia

public java.lang.String getShipVia()

getCustomerId

public java.lang.String getCustomerId()

getDiscount

public java.math.BigDecimal getDiscount()

getPricePerUnit

public java.math.BigDecimal getPricePerUnit()

getOrderedQty

public java.math.BigDecimal getOrderedQty()

getItemDescription

public java.lang.String getItemDescription()

getPartPk

public PartPK getPartPk()

getQtItemNumber

public java.lang.String getQtItemNumber()

setQtNumber

public void setQtNumber(java.lang.String qtNumber)

setOnDemandQty

public void setOnDemandQty(java.math.BigDecimal onDemandQty)

setOnorderQty

public void setOnorderQty(java.math.BigDecimal onorderQty)

setOnhandQty

public void setOnhandQty(java.math.BigDecimal onhandQty)

setStatus

public void setStatus(java.lang.String status)

setShipVia

public void setShipVia(java.lang.String shipVia)

setCustomerId

public void setCustomerId(java.lang.String customerId)

setDiscount

public void setDiscount(java.math.BigDecimal discount)

setPricePerUnit

public void setPricePerUnit(java.math.BigDecimal pricePerUnit)

setOrderedQty

public void setOrderedQty(java.math.BigDecimal orderedQty)

setItemDescription

public void setItemDescription(java.lang.String itemDescription)

setPartPk

public void setPartPk(PartPK partPk)

setQtItemNumber

public void setQtItemNumber(java.lang.String qtItemNumber)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setQtDate

public void setQtDate(java.util.Date qtDate)

setDelivery

public void setDelivery(java.lang.String delivery)

setCustomerRefNumber

public void setCustomerRefNumber(java.lang.String customerRefNumber)

setExtendsPrice

public void setExtendsPrice(java.math.BigDecimal extendsPrice)

getQtNumber

public java.lang.String getQtNumber()

getPartFrom

public java.lang.String getPartFrom()

getQtDate

public java.util.Date getQtDate()

getDelivery

public java.lang.String getDelivery()

getCustomerRefNumber

public java.lang.String getCustomerRefNumber()

getExtendsPrice

public java.math.BigDecimal getExtendsPrice()

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getCustomerRfqNumber

public java.lang.String getCustomerRfqNumber()

setCustomerRfqNumber

public void setCustomerRfqNumber(java.lang.String customerRfqNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QuoteItemManufacturerPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class QuoteItemManufacturerPK

java.lang.Object
    extended by  bb.common.QuoteItemManufacturerPK
All Implemented Interfaces:
java.io.Serializable
public class QuoteItemManufacturerPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
QuoteItemManufacturerPK()
default constructor
QuoteItemManufacturerPK(java.lang.String quoteNumber, java.lang.String quoteItemNumber, short ii)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Short | getIi()
java.lang.String | getQuoteItemNumber()
java.lang.String | getQuoteNumber()
int | hashCode()
void | setIi(java.lang.Short ii)
void | setQuoteItemNumber(java.lang.String quoteItemNumber)
void | setQuoteNumber(java.lang.String quoteNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

QuoteItemManufacturerPK

public QuoteItemManufacturerPK(java.lang.String quoteNumber,
                               java.lang.String quoteItemNumber,
                               short ii)
full constructor

QuoteItemManufacturerPK

public QuoteItemManufacturerPK()
default constructor

Method Detail

getQuoteNumber

public java.lang.String getQuoteNumber()

setQuoteNumber

public void setQuoteNumber(java.lang.String quoteNumber)

getQuoteItemNumber

public java.lang.String getQuoteItemNumber()

setQuoteItemNumber

public void setQuoteItemNumber(java.lang.String quoteItemNumber)

getIi

public java.lang.Short getIi()

setIi

public void setIi(java.lang.Short ii)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QuoteItemManufacturerVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class QuoteItemManufacturerVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.QuoteItemManufacturerVO
All Implemented Interfaces:
java.io.Serializable
public class QuoteItemManufacturerVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
QuoteItemManufacturerVO()
QuoteItemManufacturerVO(QuoteItemManufacturerPK pk, java.lang.String manufacturerName, java.lang.String manufacturerPartNumber)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getManufacturerName()
java.lang.String | getManufacturerPartNumber()
QuoteItemManufacturerPK | getPk()
int | hashCode()
void | setManufacturerName(java.lang.String manufacturerName)
void | setManufacturerPartNumber(java.lang.String manufacturerPartNumber)
void | setPk(QuoteItemManufacturerPK pk)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

QuoteItemManufacturerVO

public QuoteItemManufacturerVO(QuoteItemManufacturerPK pk,
                               java.lang.String manufacturerName,
                               java.lang.String manufacturerPartNumber)

QuoteItemManufacturerVO

public QuoteItemManufacturerVO()
Method Detail

getPk

public QuoteItemManufacturerPK getPk()

setPk

public void setPk(QuoteItemManufacturerPK pk)

getManufacturerName

public java.lang.String getManufacturerName()

setManufacturerName

public void setManufacturerName(java.lang.String manufacturerName)

getManufacturerPartNumber

public java.lang.String getManufacturerPartNumber()

setManufacturerPartNumber

public void setManufacturerPartNumber(java.lang.String manufacturerPartNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QuoteItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class QuoteItemPK

java.lang.Object
    extended by  bb.common.QuoteItemPK
All Implemented Interfaces:
java.io.Serializable
public class QuoteItemPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
QuoteItemPK()
default constructor
QuoteItemPK(java.lang.String quoteNumber, java.lang.String quoteItemNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getQuoteItemNumber()
java.lang.String | getQuoteNumber()
int | hashCode()
void | setQuoteItemNumber(java.lang.String quoteItemNumber)
void | setQuoteNumber(java.lang.String quoteNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

QuoteItemPK

public QuoteItemPK(java.lang.String quoteNumber,
                   java.lang.String quoteItemNumber)
full constructor

QuoteItemPK

public QuoteItemPK()
default constructor

Method Detail

getQuoteNumber

public java.lang.String getQuoteNumber()

setQuoteNumber

public void setQuoteNumber(java.lang.String quoteNumber)

getQuoteItemNumber

public java.lang.String getQuoteItemNumber()

setQuoteItemNumber

public void setQuoteItemNumber(java.lang.String quoteItemNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QuoteItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class QuoteItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.QuoteItemVO
All Implemented Interfaces:
java.io.Serializable
public class QuoteItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
QuoteItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getAccountReceivableDiscount()
java.math.BigDecimal | getAccountReceivableSub()
java.math.BigDecimal | getAccountReceivableTax()
java.math.BigDecimal | getAccountReceivableTotal()
java.lang.String | getChangeOrder()
java.math.BigDecimal | getCost()
int | getDelayDays()
java.lang.String | getDelivery()
java.lang.String | getDescription()
java.util.Date | getDesiredDate()
java.math.BigDecimal | getDiscount()
java.lang.String | getDwg()
java.math.BigDecimal | getExtendPrice()
java.math.BigDecimal | getHqa()
java.lang.String | getLocate()
java.math.BigDecimal | getMargin()
java.math.BigDecimal | getMarginByStdCost()
java.math.BigDecimal | getMarginPercent()
java.math.BigDecimal | getMarginPercentByStdCost()
java.lang.String | getMfg()
java.lang.String | getModelNumber()
java.lang.String | getMpn()
java.lang.String | getOriginal()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
QuoteItemPK | getPk()
java.math.BigDecimal | getPricePerUnit()
java.lang.String | getPriority()
java.lang.String | getQr()
java.math.BigDecimal | getQuantityShipped()
java.lang.String | getQuoteItemComments()
java.util.Set | getQuoteItemManufacturer()
java.lang.String | getQuoteItemPrivateNotes()
java.math.BigDecimal | getQuoteQuantity()
java.util.Set | getRefDocOnes()
java.util.Set | getRefDocTwoes()
java.lang.String | getReferenceDoc1()
java.lang.String | getReferenceDoc2()
java.lang.String | getRevision()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.math.BigDecimal | getStdCost()
java.math.BigDecimal | getTaxRate()
java.lang.String | getUnit()
int | hashCode()
void | setAccountReceivableDiscount(java.math.BigDecimal accountReceivableDiscount)
void | setAccountReceivableSub(java.math.BigDecimal accountReceivableSub)
void | setAccountReceivableTax(java.math.BigDecimal accountReceivableTax)
void | setAccountReceivableTotal(java.math.BigDecimal accountReceivableTotal)
void | setChangeOrder(java.lang.String changeOrder)
void | setCost(java.math.BigDecimal cost)
void | setDelayDays(int delayDays)
void | setDelivery(java.lang.String delivery)
void | setDescription(java.lang.String description)
void | setDesiredDate(java.util.Date desiredDate)
void | setDiscount(java.math.BigDecimal discount)
void | setDwg(java.lang.String dwg)
void | setExtendPrice(java.math.BigDecimal extendPrice)
void | setHqa(java.math.BigDecimal hqa)
void | setLocate(java.lang.String locate)
void | setMargin(java.math.BigDecimal margin)
void | setMarginByStdCost(java.math.BigDecimal marginByStdCost)
void | setMarginPercent(java.math.BigDecimal marginPercent)
void | setMarginPercentByStdCost(java.math.BigDecimal marginPercentByStdCost)
void | setMfg(java.lang.String mfg)
void | setModelNumber(java.lang.String modelNumber)
void | setMpn(java.lang.String mpn)
void | setOriginal(java.lang.String original)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(QuoteItemPK pk)
void | setPricePerUnit(java.math.BigDecimal pricePerUnit)
void | setPriority(java.lang.String priority)
void | setQr(java.lang.String qr)
void | setQuantityShipped(java.math.BigDecimal quantityShipped)
void | setQuoteItemComments(java.lang.String quoteItemComments)
void | setQuoteItemManufacturer(java.util.Set quoteItemManufacturer)
void | setQuoteItemPrivateNotes(java.lang.String quoteItemPrivateNotes)
void | setQuoteQuantity(java.math.BigDecimal quoteQuantity)
void | setRefDocOnes(java.util.Set refDocOnes)
void | setRefDocTwoes(java.util.Set refDocTwoes)
void | setReferenceDoc1(java.lang.String referenceDoc1)
void | setReferenceDoc2(java.lang.String referenceDoc2)
void | setRevision(java.lang.String revision)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setStdCost(java.math.BigDecimal stdCost)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setUnit(java.lang.String unit)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

QuoteItemVO

public QuoteItemVO()
Method Detail

getPk

public QuoteItemPK getPk()

setPk

public void setPk(QuoteItemPK pk)

getAccountReceivableSub

public java.math.BigDecimal getAccountReceivableSub()

setAccountReceivableSub

public void setAccountReceivableSub(java.math.BigDecimal accountReceivableSub)

getAccountReceivableDiscount

public java.math.BigDecimal getAccountReceivableDiscount()

setAccountReceivableDiscount

public void setAccountReceivableDiscount(java.math.BigDecimal accountReceivableDiscount)

getExtendPrice

public java.math.BigDecimal getExtendPrice()

setExtendPrice

public void setExtendPrice(java.math.BigDecimal extendPrice)

getAccountReceivableTax

public java.math.BigDecimal getAccountReceivableTax()

setAccountReceivableTax

public void setAccountReceivableTax(java.math.BigDecimal accountReceivableTax)

getAccountReceivableTotal

public java.math.BigDecimal getAccountReceivableTotal()

setAccountReceivableTotal

public void setAccountReceivableTotal(java.math.BigDecimal accountReceivableTotal)

getReferenceDoc1

public java.lang.String getReferenceDoc1()

setReferenceDoc1

public void setReferenceDoc1(java.lang.String referenceDoc1)

getReferenceDoc2

public java.lang.String getReferenceDoc2()

setReferenceDoc2

public void setReferenceDoc2(java.lang.String referenceDoc2)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getQr

public java.lang.String getQr()

setQr

public void setQr(java.lang.String qr)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getDelivery

public java.lang.String getDelivery()

setDelivery

public void setDelivery(java.lang.String delivery)

getDesiredDate

public java.util.Date getDesiredDate()

setDesiredDate

public void setDesiredDate(java.util.Date desiredDate)

getDelayDays

public int getDelayDays()

setDelayDays

public void setDelayDays(int delayDays)

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getOriginal

public java.lang.String getOriginal()

setOriginal

public void setOriginal(java.lang.String original)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getDwg

public java.lang.String getDwg()

setDwg

public void setDwg(java.lang.String dwg)

getQuoteQuantity

public java.math.BigDecimal getQuoteQuantity()

setQuoteQuantity

public void setQuoteQuantity(java.math.BigDecimal quoteQuantity)

getQuantityShipped

public java.math.BigDecimal getQuantityShipped()

setQuantityShipped

public void setQuantityShipped(java.math.BigDecimal quantityShipped)

getHqa

public java.math.BigDecimal getHqa()

setHqa

public void setHqa(java.math.BigDecimal hqa)

getCost

public java.math.BigDecimal getCost()

setCost

public void setCost(java.math.BigDecimal cost)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getPricePerUnit

public java.math.BigDecimal getPricePerUnit()

setPricePerUnit

public void setPricePerUnit(java.math.BigDecimal pricePerUnit)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getQuoteItemComments

public java.lang.String getQuoteItemComments()

setQuoteItemComments

public void setQuoteItemComments(java.lang.String quoteItemComments)

getQuoteItemPrivateNotes

public java.lang.String getQuoteItemPrivateNotes()

setQuoteItemPrivateNotes

public void setQuoteItemPrivateNotes(java.lang.String quoteItemPrivateNotes)

getQuoteItemManufacturer

public java.util.Set getQuoteItemManufacturer()

setQuoteItemManufacturer

public void setQuoteItemManufacturer(java.util.Set quoteItemManufacturer)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getMargin

public java.math.BigDecimal getMargin()

setMargin

public void setMargin(java.math.BigDecimal margin)

getMarginPercent

public java.math.BigDecimal getMarginPercent()

setMarginPercent

public void setMarginPercent(java.math.BigDecimal marginPercent)

getMarginByStdCost

public java.math.BigDecimal getMarginByStdCost()

setMarginByStdCost

public void setMarginByStdCost(java.math.BigDecimal marginByStdCost)

getMarginPercentByStdCost

public java.math.BigDecimal getMarginPercentByStdCost()

setMarginPercentByStdCost

public void setMarginPercentByStdCost(java.math.BigDecimal marginPercentByStdCost)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getRefDocOnes

public java.util.Set getRefDocOnes()

setRefDocOnes

public void setRefDocOnes(java.util.Set refDocOnes)

getRefDocTwoes

public java.util.Set getRefDocTwoes()

setRefDocTwoes

public void setRefDocTwoes(java.util.Set refDocTwoes)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QuoteListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class QuoteListResult

java.lang.Object
    extended by  bb.common.QuoteListResult
All Implemented Interfaces:
java.io.Serializable
public class QuoteListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CHANGEORDER
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_CUSTOMERREFNUMBER
static java.lang.String | ORDER_BY_OURREFQUOTE
static java.lang.String | ORDER_BY_PRIVATENOTE
static java.lang.String | ORDER_BY_PROJECT
static java.lang.String | ORDER_BY_QTDATE
static java.lang.String | ORDER_BY_QTNUMBER
static java.lang.String | ORDER_BY_SALESMAN
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_VALIDTHRU
Constructor Summary
QuoteListResult()
Method Summary
java.lang.String | getChangeOrder()
java.lang.String | getComments()
java.lang.String | getCustomerId()
java.lang.String | getCustomerRefNumber()
java.lang.String | getOurRefQuote()
java.lang.String | getPrivateNote()
java.lang.String | getProject()
java.util.Date | getQtDate()
java.lang.String | getQtNumber()
java.lang.String | getSalesman()
java.lang.String | getStatus()
java.util.Date | getValidThru()
void | setChangeOrder(java.lang.String changeOrder)
void | setComments(java.lang.String comments)
void | setCustomerId(java.lang.String customerId)
void | setCustomerRefNumber(java.lang.String customerRefNumber)
void | setOurRefQuote(java.lang.String ourRefQuote)
void | setPrivateNote(java.lang.String privateNote)
void | setProject(java.lang.String project)
void | setQtDate(java.util.Date qtDate)
void | setQtNumber(java.lang.String qtNumber)
void | setSalesman(java.lang.String salesman)
void | setStatus(java.lang.String status)
void | setValidThru(java.util.Date validThru)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_QTNUMBER

public static final java.lang.String ORDER_BY_QTNUMBER
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_CHANGEORDER

public static final java.lang.String ORDER_BY_CHANGEORDER
See Also:
Constant Field Values

ORDER_BY_CUSTOMERREFNUMBER

public static final java.lang.String ORDER_BY_CUSTOMERREFNUMBER
See Also:
Constant Field Values

ORDER_BY_PROJECT

public static final java.lang.String ORDER_BY_PROJECT
See Also:
Constant Field Values

ORDER_BY_PRIVATENOTE

public static final java.lang.String ORDER_BY_PRIVATENOTE
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_VALIDTHRU

public static final java.lang.String ORDER_BY_VALIDTHRU
See Also:
Constant Field Values

ORDER_BY_SALESMAN

public static final java.lang.String ORDER_BY_SALESMAN
See Also:
Constant Field Values

ORDER_BY_OURREFQUOTE

public static final java.lang.String ORDER_BY_OURREFQUOTE
See Also:
Constant Field Values

ORDER_BY_QTDATE

public static final java.lang.String ORDER_BY_QTDATE
See Also:
Constant Field Values
Constructor Detail

QuoteListResult

public QuoteListResult()
Method Detail

getStatus

public java.lang.String getStatus()

getComments

public java.lang.String getComments()

getPrivateNote

public java.lang.String getPrivateNote()

getProject

public java.lang.String getProject()

getCustomerId

public java.lang.String getCustomerId()

getChangeOrder

public java.lang.String getChangeOrder()

getQtDate

public java.util.Date getQtDate()

getQtNumber

public java.lang.String getQtNumber()

setStatus

public void setStatus(java.lang.String status)

setComments

public void setComments(java.lang.String comments)

setPrivateNote

public void setPrivateNote(java.lang.String privateNote)

setProject

public void setProject(java.lang.String project)

setCustomerId

public void setCustomerId(java.lang.String customerId)

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

setQtDate

public void setQtDate(java.util.Date qtDate)

setQtNumber

public void setQtNumber(java.lang.String qtNumber)

setCustomerRefNumber

public void setCustomerRefNumber(java.lang.String customerRefNumber)

setValidThru

public void setValidThru(java.util.Date validThru)

setSalesman

public void setSalesman(java.lang.String salesman)

setOurRefQuote

public void setOurRefQuote(java.lang.String ourRefQuote)

getCustomerRefNumber

public java.lang.String getCustomerRefNumber()

getValidThru

public java.util.Date getValidThru()

getSalesman

public java.lang.String getSalesman()

getOurRefQuote

public java.lang.String getOurRefQuote()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QuoteVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class QuoteVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.QuoteVO
All Implemented Interfaces:
java.io.Serializable
public class QuoteVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
QuoteVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getADate()
java.lang.String | getArNetSet()
java.math.BigDecimal | getArSub()
java.lang.String | getArTaxSet()
CustomerVendorAddressInfoVO | getBillToAddressInfo()
java.lang.String | getBillToId()
java.util.Set | getBoilerplates()
java.lang.String | getBp()
java.lang.String | getCarrier()
java.lang.String | getCarrierAccount()
java.lang.String | getChangeOrder()
java.lang.String | getCoComments()
java.lang.String | getCompanyUnitId()
java.lang.String | getContact()
java.lang.String | getCreditAccount()
java.lang.String | getCurrency()
CustomerVendorAddressInfoVO | getCustomerAddressInfo()
java.lang.String | getCustomerId()
java.lang.String | getCustomerRefNumber()
byte | getDelay()
java.lang.String | getDelivery()
java.lang.String | getDesired()
java.math.BigDecimal | getExchange()
java.math.BigDecimal | getGrantTotal()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
java.lang.String | getLastUser()
java.lang.String | getLocate()
java.math.BigDecimal | getMargin()
java.math.BigDecimal | getMarginByStdCost()
java.math.BigDecimal | getMarginPercent()
java.math.BigDecimal | getMarginPercentByStdCost()
java.lang.String | getOrigin()
java.lang.String | getOriginal()
java.lang.String | getPriority()
java.lang.String | getProjectName()
java.lang.String | getQuoteComments()
java.util.Date | getQuoteDate()
java.util.Set | getQuoteDocuments()
java.util.Set | getQuoteItems()
java.lang.String | getQuoteNumber()
java.lang.String | getQuotePrivateNotes()
java.lang.String | getRelatedDocument()
java.lang.String | getRequester()
java.util.Date | getReviewed()
java.lang.String | getReviewedBy()
java.lang.String | getSalesGroutQuoteNumber()
java.lang.String | getSalesman()
short | getSalesmanId()
CustomerVendorAddressInfoVO | getShipToAddressInfo()
java.lang.String | getShipToId()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.math.BigDecimal | getSubTotal()
java.lang.String | getTerms()
java.math.BigDecimal | getTotalCost()
java.math.BigDecimal | getTotalDiscount()
java.math.BigDecimal | getTotalFreight()
java.math.BigDecimal | getTotalStdCost()
java.math.BigDecimal | getTotalTax()
java.util.Date | getValidThru()
java.lang.Integer | getVersion()
int | hashCode()
void | setADate(java.util.Date adate)
void | setArNetSet(java.lang.String arNetSet)
void | setArSub(java.math.BigDecimal arSub)
void | setArTaxSet(java.lang.String arTaxSet)
void | setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | setBillToId(java.lang.String billToId)
void | setBoilerplates(java.util.Set boilerplates)
void | setBp(java.lang.String bp)
void | setCarrier(java.lang.String carrier)
void | setCarrierAccount(java.lang.String carrierAccount)
void | setChangeOrder(java.lang.String changeOrder)
void | setCoComments(java.lang.String coComments)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setContact(java.lang.String contact)
void | setCreditAccount(java.lang.String creditAccount)
void | setCurrency(java.lang.String currency)
void | setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | setCustomerId(java.lang.String customerId)
void | setCustomerRefNumber(java.lang.String customerRefNumber)
void | setDelay(byte delay)
void | setDelivery(java.lang.String delivery)
void | setDesired(java.lang.String desired)
void | setExchange(java.math.BigDecimal exchange)
void | setGrantTotal(java.math.BigDecimal grantTotal)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastUser(java.lang.String lastUser)
void | setLocate(java.lang.String locate)
void | setMargin(java.math.BigDecimal margin)
void | setMarginByStdCost(java.math.BigDecimal marginByStdCost)
void | setMarginPercent(java.math.BigDecimal marginPercent)
void | setMarginPercentByStdCost(java.math.BigDecimal marginPercentByStdCost)
void | setOrigin(java.lang.String origin)
void | setOriginal(java.lang.String original)
void | setPriority(java.lang.String priority)
void | setProjectName(java.lang.String projectName)
void | setQuoteComments(java.lang.String quoteComments)
void | setQuoteDate(java.util.Date quoteDate)
void | setQuoteDocuments(java.util.Set quoteDocument)
void | setQuoteItems(java.util.Set quoteItem)
void | setQuoteNumber(java.lang.String quoteNumber)
void | setQuotePrivateNotes(java.lang.String quotePrivateNotes)
void | setRelatedDocument(java.lang.String relatedDocument)
void | setRequester(java.lang.String requestor)
void | setReviewed(java.util.Date reviewed)
void | setReviewedBy(java.lang.String reviewedBy)
void | setSalesGroutQuoteNumber(java.lang.String salesGroutQuoteNumber)
void | setSalesman(java.lang.String salesman)
void | setSalesmanId(short salesmanId)
void | setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | setShipToId(java.lang.String shipToId)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setSubTotal(java.math.BigDecimal subTotal)
void | setTerms(java.lang.String terms)
void | setTotalCost(java.math.BigDecimal totalCost)
void | setTotalDiscount(java.math.BigDecimal totalDiscount)
void | setTotalFreight(java.math.BigDecimal totalFreight)
void | setTotalStdCost(java.math.BigDecimal totalStdCost)
void | setTotalTax(java.math.BigDecimal totalTax)
void | setValidThru(java.util.Date validThru)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

QuoteVO

public QuoteVO()
Method Detail

getQuoteNumber

public java.lang.String getQuoteNumber()

setQuoteNumber

public void setQuoteNumber(java.lang.String quoteNumber)

getValidThru

public java.util.Date getValidThru()

setValidThru

public void setValidThru(java.util.Date validThru)

getLastUser

public java.lang.String getLastUser()

setLastUser

public void setLastUser(java.lang.String lastUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getADate

public java.util.Date getADate()

setADate

public void setADate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getArNetSet

public java.lang.String getArNetSet()

setArNetSet

public void setArNetSet(java.lang.String arNetSet)

getArTaxSet

public java.lang.String getArTaxSet()

setArTaxSet

public void setArTaxSet(java.lang.String arTaxSet)

getArSub

public java.math.BigDecimal getArSub()

setArSub

public void setArSub(java.math.BigDecimal arSub)

getTotalDiscount

public java.math.BigDecimal getTotalDiscount()

setTotalDiscount

public void setTotalDiscount(java.math.BigDecimal totalDiscount)

getSubTotal

public java.math.BigDecimal getSubTotal()

setSubTotal

public void setSubTotal(java.math.BigDecimal subTotal)

getTotalTax

public java.math.BigDecimal getTotalTax()

setTotalTax

public void setTotalTax(java.math.BigDecimal totalTax)

getTotalFreight

public java.math.BigDecimal getTotalFreight()

setTotalFreight

public void setTotalFreight(java.math.BigDecimal totalFreight)

getGrantTotal

public java.math.BigDecimal getGrantTotal()

setGrantTotal

public void setGrantTotal(java.math.BigDecimal grantTotal)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getBillToId

public java.lang.String getBillToId()

setBillToId

public void setBillToId(java.lang.String billToId)

getCustomerRefNumber

public java.lang.String getCustomerRefNumber()

setCustomerRefNumber

public void setCustomerRefNumber(java.lang.String customerRefNumber)

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getReviewed

public java.util.Date getReviewed()

setReviewed

public void setReviewed(java.util.Date reviewed)

getReviewedBy

public java.lang.String getReviewedBy()

setReviewedBy

public void setReviewedBy(java.lang.String reviewedBy)

getDelivery

public java.lang.String getDelivery()

setDelivery

public void setDelivery(java.lang.String delivery)

getDesired

public java.lang.String getDesired()

setDesired

public void setDesired(java.lang.String desired)

getDelay

public byte getDelay()

setDelay

public void setDelay(byte delay)

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getOriginal

public java.lang.String getOriginal()

setOriginal

public void setOriginal(java.lang.String original)

getShipToId

public java.lang.String getShipToId()

setShipToId

public void setShipToId(java.lang.String shipToId)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAccount

public java.lang.String getCarrierAccount()

setCarrierAccount

public void setCarrierAccount(java.lang.String carrierAccount)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getQuoteDate

public java.util.Date getQuoteDate()

setQuoteDate

public void setQuoteDate(java.util.Date quoteDate)

getSalesman

public java.lang.String getSalesman()

setSalesman

public void setSalesman(java.lang.String salesman)

getSalesmanId

public short getSalesmanId()

setSalesmanId

public void setSalesmanId(short salesmanId)

getSalesGroutQuoteNumber

public java.lang.String getSalesGroutQuoteNumber()

setSalesGroutQuoteNumber

public void setSalesGroutQuoteNumber(java.lang.String salesGroutQuoteNumber)

getRequester

public java.lang.String getRequester()

setRequester

public void setRequester(java.lang.String requestor)

getProjectName

public java.lang.String getProjectName()

setProjectName

public void setProjectName(java.lang.String projectName)

getRelatedDocument

public java.lang.String getRelatedDocument()

setRelatedDocument

public void setRelatedDocument(java.lang.String relatedDocument)

getCreditAccount

public java.lang.String getCreditAccount()

setCreditAccount

public void setCreditAccount(java.lang.String creditAccount)

getBp

public java.lang.String getBp()

setBp

public void setBp(java.lang.String bp)

getQuoteComments

public java.lang.String getQuoteComments()

setQuoteComments

public void setQuoteComments(java.lang.String quoteComments)

getQuotePrivateNotes

public java.lang.String getQuotePrivateNotes()

setQuotePrivateNotes

public void setQuotePrivateNotes(java.lang.String quotePrivateNotes)

getCustomerAddressInfo

public CustomerVendorAddressInfoVO getCustomerAddressInfo()

setCustomerAddressInfo

public void setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)

getShipToAddressInfo

public CustomerVendorAddressInfoVO getShipToAddressInfo()

setShipToAddressInfo

public void setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)

getBillToAddressInfo

public CustomerVendorAddressInfoVO getBillToAddressInfo()

setBillToAddressInfo

public void setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)

getQuoteItems

public java.util.Set getQuoteItems()

setQuoteItems

public void setQuoteItems(java.util.Set quoteItem)

getQuoteDocuments

public java.util.Set getQuoteDocuments()

getVersion

public java.lang.Integer getVersion()

getBoilerplates

public java.util.Set getBoilerplates()

getCoComments

public java.lang.String getCoComments()

setQuoteDocuments

public void setQuoteDocuments(java.util.Set quoteDocument)

setVersion

public void setVersion(java.lang.Integer version)

setBoilerplates

public void setBoilerplates(java.util.Set boilerplates)

setCoComments

public void setCoComments(java.lang.String coComments)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getMargin

public java.math.BigDecimal getMargin()

setMargin

public void setMargin(java.math.BigDecimal margin)

getMarginPercent

public java.math.BigDecimal getMarginPercent()

setMarginPercent

public void setMarginPercent(java.math.BigDecimal marginPercent)

getExchange

public java.math.BigDecimal getExchange()

setExchange

public void setExchange(java.math.BigDecimal exchange)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getMarginByStdCost

public java.math.BigDecimal getMarginByStdCost()

setMarginByStdCost

public void setMarginByStdCost(java.math.BigDecimal marginByStdCost)

getMarginPercentByStdCost

public java.math.BigDecimal getMarginPercentByStdCost()

setMarginPercentByStdCost

public void setMarginPercentByStdCost(java.math.BigDecimal marginPercentByStdCost)

getTotalCost

public java.math.BigDecimal getTotalCost()

setTotalCost

public void setTotalCost(java.math.BigDecimal totalCost)

getTotalStdCost

public java.math.BigDecimal getTotalStdCost()

setTotalStdCost

public void setTotalStdCost(java.math.BigDecimal totalStdCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Reason

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Reason

java.lang.Object
    extended by  bb.common.Reason
All Implemented Interfaces:
java.io.Serializable
public final class Reason
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
Reason(java.lang.String reason)
Method Summary
boolean | equals(java.lang.Object other)
static Reason | getInstance(java.lang.String reason)
java.lang.String | getReason()
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Reason

public Reason(java.lang.String reason)
Method Detail

getReason

public java.lang.String getReason()

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getInstance

public static Reason getInstance(java.lang.String reason)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RebackInQAAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RebackInQAAgent

java.lang.Object
    extended by  bb.common.RebackInQAAgent
All Implemented Interfaces:
java.io.Serializable
public final class RebackInQAAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
RebackInQAAgent()
Method Summary
java.math.BigDecimal | getCost()
java.lang.Integer | getIi()
java.lang.String | getLocate()
java.lang.String | getNcrNumber()
BB2Part | getPart()
java.math.BigDecimal | getQuantity()
java.util.Set<ReceiverItemTrackingLogAgent> | getTrackingLog()
void | setCost(java.math.BigDecimal cost)
void | setIi(java.lang.Integer ii)
void | setLocate(java.lang.String locate)
void | setNcrNumber(java.lang.String ncrNumber)
void | setPart(BB2Part part)
void | setQuantity(java.math.BigDecimal quantity)
void | setTrackingLog(java.util.Set<ReceiverItemTrackingLogAgent> trackingLog)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RebackInQAAgent

public RebackInQAAgent()
Method Detail

getIi

public java.lang.Integer getIi()

setIi

public void setIi(java.lang.Integer ii)

getPart

public BB2Part getPart()

setPart

public void setPart(BB2Part part)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getCost

public java.math.BigDecimal getCost()

setCost

public void setCost(java.math.BigDecimal cost)

getNcrNumber

public java.lang.String getNcrNumber()

setNcrNumber

public void setNcrNumber(java.lang.String ncrNumber)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getTrackingLog

public java.util.Set<ReceiverItemTrackingLogAgent> getTrackingLog()

setTrackingLog

public void setTrackingLog(java.util.Set<ReceiverItemTrackingLogAgent> trackingLog)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReceivedToOrderItem

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ReceivedToOrderItem

java.lang.Object
    extended by  bb.common.ReceivedToOrderItem
All Implemented Interfaces:
java.io.Serializable
public class ReceivedToOrderItem
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ReceivedToOrderItem()
Method Summary
java.lang.Boolean | getIsGroup()
java.lang.Short | getItemNumber()
java.math.BigDecimal | getQtyShipped()
java.lang.String | getReceivedTo()
java.lang.String | getShipperNumber()
java.math.BigDecimal | getShortQuantity()
java.lang.String | getToItemNumber()
java.lang.String | getToOrderNumber()
void | setIsGroup(java.lang.Boolean isGroup)
void | setItemNumber(java.lang.Short itemNumber)
void | setQtyShipped(java.math.BigDecimal qtyShipped)
void | setReceivedTo(java.lang.String receivedTo)
void | setShipperNumber(java.lang.String shipperNumber)
void | setShortQuantity(java.math.BigDecimal shortQuantity)
void | setToItemNumber(java.lang.String toItemNumber)
void | setToOrderNumber(java.lang.String toOrderNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ReceivedToOrderItem

public ReceivedToOrderItem()
Method Detail

setToOrderNumber

public void setToOrderNumber(java.lang.String toOrderNumber)

setToItemNumber

public void setToItemNumber(java.lang.String toItemNumber)

setShortQuantity

public void setShortQuantity(java.math.BigDecimal shortQuantity)

setReceivedTo

public void setReceivedTo(java.lang.String receivedTo)

setIsGroup

public void setIsGroup(java.lang.Boolean isGroup)

setItemNumber

public void setItemNumber(java.lang.Short itemNumber)

setShipperNumber

public void setShipperNumber(java.lang.String shipperNumber)

setQtyShipped

public void setQtyShipped(java.math.BigDecimal qtyShipped)

getToOrderNumber

public java.lang.String getToOrderNumber()

getToItemNumber

public java.lang.String getToItemNumber()

getShortQuantity

public java.math.BigDecimal getShortQuantity()

getReceivedTo

public java.lang.String getReceivedTo()

getIsGroup

public java.lang.Boolean getIsGroup()

getItemNumber

public java.lang.Short getItemNumber()

getShipperNumber

public java.lang.String getShipperNumber()

getQtyShipped

public java.math.BigDecimal getQtyShipped()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReceiverAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ReceiverAgent

java.lang.Object
    extended by  bb.common.ReceiverAgent
All Implemented Interfaces:
java.io.Serializable
public class ReceiverAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ReceiverAgent()
Method Summary
java.math.BigDecimal | getFreight()
java.lang.String | getGlSummary()
Reason | getIllegalSettingReason()
java.util.Set<ReceiverItemAgent> | getItems()
java.lang.String | getOrderNumber()
java.util.Date | getReceivedDate()
java.lang.String | getTrackingNumber()
java.lang.String | getVendorInvoice()
java.util.Date | getVendorInvoiceDate()
java.util.Date | getVendorShipDate()
java.lang.String | getVendorShipperNumber()
java.lang.String | getWareHouse()
void | refresh()
void | setFreight(java.math.BigDecimal freight)
void | setGlSummary(java.lang.String glSummary)
void | setItems(java.util.Set<ReceiverItemAgent> items)
void | setOrderNumber(java.lang.String orderNumber)
void | setReceivedDate(java.util.Date receivedDate)
void | setTrackingNumber(java.lang.String trackingNumber)
void | setVendorInvoice(java.lang.String vendorInvoice)
void | setVendorInvoiceDate(java.util.Date vendorInvoiceDate)
void | setVendorShipDate(java.util.Date vendorShipDate)
void | setVendorShipperNumber(java.lang.String vendorShipperNumber)
void | setWareHouse(java.lang.String wareHouse)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ReceiverAgent

public ReceiverAgent()
Method Detail

getOrderNumber

public java.lang.String getOrderNumber()

getWareHouse

public java.lang.String getWareHouse()

getReceivedDate

public java.util.Date getReceivedDate()

getItems

public java.util.Set<ReceiverItemAgent> getItems()

getVendorInvoice

public java.lang.String getVendorInvoice()

getVendorInvoiceDate

public java.util.Date getVendorInvoiceDate()

getFreight

public java.math.BigDecimal getFreight()

getVendorShipDate

public java.util.Date getVendorShipDate()

setOrderNumber

public void setOrderNumber(java.lang.String orderNumber)

setWareHouse

public void setWareHouse(java.lang.String wareHouse)

setReceivedDate

public void setReceivedDate(java.util.Date receivedDate)

setItems

public void setItems(java.util.Set<ReceiverItemAgent> items)

setVendorInvoice

public void setVendorInvoice(java.lang.String vendorInvoice)

setVendorInvoiceDate

public void setVendorInvoiceDate(java.util.Date vendorInvoiceDate)

setFreight

public void setFreight(java.math.BigDecimal freight)

setVendorShipDate

public void setVendorShipDate(java.util.Date vendorShipDate)

refresh

public void refresh()

getIllegalSettingReason

public Reason getIllegalSettingReason()

getVendorShipperNumber

public java.lang.String getVendorShipperNumber()

setVendorShipperNumber

public void setVendorShipperNumber(java.lang.String vendorShipperNumber)

getGlSummary

public java.lang.String getGlSummary()

setGlSummary

public void setGlSummary(java.lang.String glSummary)

getTrackingNumber

public java.lang.String getTrackingNumber()

setTrackingNumber

public void setTrackingNumber(java.lang.String trackingNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReceiverInfoVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ReceiverInfoVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ReceiverInfoVO
All Implemented Interfaces:
java.io.Serializable
public class ReceiverInfoVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_PURCHASEORDERNUMBER
static java.lang.String | ORDER_BY_RECEIVERNUMBER
static java.lang.String | ORDER_BY_VENDORADDRESSINFO
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_VENDORSHIPDATE
Constructor Summary
ReceiverInfoVO()
default constructor
ReceiverInfoVO(java.lang.String receiverNumber, java.lang.String purchaseOrderNumber)
minimal constructor
ReceiverInfoVO(java.lang.String receiverNumber, java.lang.String purchaseOrderNumber, java.lang.String accountPayableNumber, java.lang.String vendorId, java.lang.String lastChangeUser, java.util.Date lastChangeDate, java.util.Date adate, java.lang.String origin, java.math.BigDecimal apSub, java.math.BigDecimal apReceived, java.math.BigDecimal apOpen, java.math.BigDecimal totalDiscount, java.math.BigDecimal subTotal, java.math.BigDecimal totalTax, java.math.BigDecimal totalFreight, java.math.BigDecimal grantTotal, java.math.BigDecimal apPaidReceived, java.math.BigDecimal apPaidGl, java.math.BigDecimal apGl1Recorded, java.math.BigDecimal apGl2Paid, java.lang.String changeOrder, java.lang.String status, java.lang.String collect, java.lang.String receivedBy, java.util.Date dateReceived, java.lang.String deliveredTo, java.lang.String freightBill, java.lang.String shippedVia, java.lang.String carrier, java.lang.String carrierAccount, java.lang.String tracking, java.lang.String incoterm, java.lang.String incotermPlacePort, java.lang.String currency, java.lang.String terms, java.lang.String requester, java.lang.String projectName, java.lang.String relatedDoc, java.lang.String debitAccount, java.lang.String bp, java.lang.String receiverComments, java.lang.String receiverPrivateNotes, java.math.BigDecimal due, java.lang.String vendorInvoice, java.lang.String vendorPackage, java.math.BigDecimal vendorTotal, java.util.Date vendorInvoiceDate, java.util.Date paydate, java.util.Date datePaid, java.lang.String checkNo, java.math.BigDecimal paid, java.lang.String itran, java.lang.String etran, int lastChangeTimes, CustomerVendorAddressInfoVO vendorAddressInfoVO)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAccountPayableNumber()
java.util.Date | getAdate()
java.math.BigDecimal | getApGl1Recorded()
java.math.BigDecimal | getApGl2Paid()
java.math.BigDecimal | getApOpen()
java.math.BigDecimal | getApPaidGl()
java.math.BigDecimal | getApPaidReceived()
java.math.BigDecimal | getApReceived()
java.math.BigDecimal | getApSub()
java.lang.String | getBatch()
java.lang.String | getBp()
java.lang.String | getBuyer()
java.lang.String | getCarrier()
java.lang.String | getCarrierAccount()
java.lang.String | getChangeOrder()
java.lang.String | getCheckNo()
java.lang.String | getCollect()
java.lang.String | getCurrency()
java.util.Date | getDatePaid()
java.util.Date | getDateReceived()
java.lang.String | getDebitAccount()
java.lang.String | getDeliveredTo()
java.math.BigDecimal | getDue()
java.lang.String | getEtran()
java.lang.String | getFreightBill()
java.math.BigDecimal | getGrantTotal()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getItran()
java.util.Date | getLastChangeDate()
int | getLastChangeTimes()
java.lang.String | getLastChangeUser()
java.lang.String | getOrigin()
java.math.BigDecimal | getPaid()
java.util.Date | getPaydate()
java.lang.String | getProjectName()
java.lang.String | getPurchaseOrderNumber()
java.lang.String | getReceivedBy()
java.lang.String | getReceiverComments()
java.lang.String | getReceiverNumber()
java.lang.String | getReceiverPrivateNotes()
java.lang.String | getRelatedDoc()
java.lang.String | getRequester()
java.lang.String | getShippedVia()
java.lang.String | getStatus()
java.math.BigDecimal | getSubTotal()
java.lang.String | getTerms()
java.math.BigDecimal | getTotalDiscount()
java.math.BigDecimal | getTotalFreight()
java.math.BigDecimal | getTotalTax()
java.lang.String | getTracking()
CustomerVendorAddressInfoVO | getVendorAddressInfoVO()
java.lang.String | getVendorId()
java.lang.String | getVendorInvoice()
java.util.Date | getVendorInvoiceDate()
java.lang.String | getVendorPackage()
java.util.Date | getVendorShipDate()
java.math.BigDecimal | getVendorTotal()
int | hashCode()
void | setAccountPayableNumber(java.lang.String accountPayableNumber)
void | setAdate(java.util.Date adate)
void | setApGl1Recorded(java.math.BigDecimal apGl1Recorded)
void | setApGl2Paid(java.math.BigDecimal apGl2Paid)
void | setApOpen(java.math.BigDecimal apOpen)
void | setApPaidGl(java.math.BigDecimal apPaidGl)
void | setApPaidReceived(java.math.BigDecimal apPaidReceived)
void | setApReceived(java.math.BigDecimal apReceived)
void | setApSub(java.math.BigDecimal apSub)
void | setBatch(java.lang.String batch)
void | setBp(java.lang.String bp)
void | setBuyer(java.lang.String buyer)
void | setCarrier(java.lang.String carrier)
void | setCarrierAccount(java.lang.String carrierAccount)
void | setChangeOrder(java.lang.String changeOrder)
void | setCheckNo(java.lang.String checkNo)
void | setCollect(java.lang.String collect)
void | setCurrency(java.lang.String currency)
void | setDatePaid(java.util.Date datePaid)
void | setDateReceived(java.util.Date dateReceived)
void | setDebitAccount(java.lang.String debitAccount)
void | setDeliveredTo(java.lang.String deliveredTo)
void | setDue(java.math.BigDecimal due)
void | setEtran(java.lang.String etran)
void | setFreightBill(java.lang.String freightBill)
void | setGrantTotal(java.math.BigDecimal grantTotal)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setItran(java.lang.String itran)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTimes(int lastChangeTimes)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setOrigin(java.lang.String origin)
void | setPaid(java.math.BigDecimal paid)
void | setPaydate(java.util.Date paydate)
void | setProjectName(java.lang.String projectName)
void | setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)
void | setReceivedBy(java.lang.String receivedBy)
void | setReceiverComments(java.lang.String receiverComments)
void | setReceiverNumber(java.lang.String receiverNumber)
void | setReceiverPrivateNotes(java.lang.String receiverPrivateNotes)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setRequester(java.lang.String requester)
void | setShippedVia(java.lang.String shippedVia)
void | setStatus(java.lang.String status)
void | setSubTotal(java.math.BigDecimal subTotal)
void | setTerms(java.lang.String terms)
void | setTotalDiscount(java.math.BigDecimal totalDiscount)
void | setTotalFreight(java.math.BigDecimal totalFreight)
void | setTotalTax(java.math.BigDecimal totalTax)
void | setTracking(java.lang.String tracking)
void | setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfoVO)
void | setVendorId(java.lang.String vendorId)
void | setVendorInvoice(java.lang.String vendorInvoice)
void | setVendorInvoiceDate(java.util.Date vendorInvoiceDate)
void | setVendorPackage(java.lang.String vendorPackage)
void | setVendorShipDate(java.util.Date vendorShipDate)
void | setVendorTotal(java.math.BigDecimal vendorTotal)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_RECEIVERNUMBER

public static final java.lang.String ORDER_BY_RECEIVERNUMBER
See Also:
Constant Field Values

ORDER_BY_PURCHASEORDERNUMBER

public static final java.lang.String ORDER_BY_PURCHASEORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_VENDORADDRESSINFO

public static final java.lang.String ORDER_BY_VENDORADDRESSINFO
See Also:
Constant Field Values

ORDER_BY_VENDORSHIPDATE

public static final java.lang.String ORDER_BY_VENDORSHIPDATE
See Also:
Constant Field Values
Constructor Detail

ReceiverInfoVO

public ReceiverInfoVO(java.lang.String receiverNumber,
                      java.lang.String purchaseOrderNumber,
                      java.lang.String accountPayableNumber,
                      java.lang.String vendorId,
                      java.lang.String lastChangeUser,
                      java.util.Date lastChangeDate,
                      java.util.Date adate,
                      java.lang.String origin,
                      java.math.BigDecimal apSub,
                      java.math.BigDecimal apReceived,
                      java.math.BigDecimal apOpen,
                      java.math.BigDecimal totalDiscount,
                      java.math.BigDecimal subTotal,
                      java.math.BigDecimal totalTax,
                      java.math.BigDecimal totalFreight,
                      java.math.BigDecimal grantTotal,
                      java.math.BigDecimal apPaidReceived,
                      java.math.BigDecimal apPaidGl,
                      java.math.BigDecimal apGl1Recorded,
                      java.math.BigDecimal apGl2Paid,
                      java.lang.String changeOrder,
                      java.lang.String status,
                      java.lang.String collect,
                      java.lang.String receivedBy,
                      java.util.Date dateReceived,
                      java.lang.String deliveredTo,
                      java.lang.String freightBill,
                      java.lang.String shippedVia,
                      java.lang.String carrier,
                      java.lang.String carrierAccount,
                      java.lang.String tracking,
                      java.lang.String incoterm,
                      java.lang.String incotermPlacePort,
                      java.lang.String currency,
                      java.lang.String terms,
                      java.lang.String requester,
                      java.lang.String projectName,
                      java.lang.String relatedDoc,
                      java.lang.String debitAccount,
                      java.lang.String bp,
                      java.lang.String receiverComments,
                      java.lang.String receiverPrivateNotes,
                      java.math.BigDecimal due,
                      java.lang.String vendorInvoice,
                      java.lang.String vendorPackage,
                      java.math.BigDecimal vendorTotal,
                      java.util.Date vendorInvoiceDate,
                      java.util.Date paydate,
                      java.util.Date datePaid,
                      java.lang.String checkNo,
                      java.math.BigDecimal paid,
                      java.lang.String itran,
                      java.lang.String etran,
                      int lastChangeTimes,
                      CustomerVendorAddressInfoVO vendorAddressInfoVO)
full constructor

ReceiverInfoVO

public ReceiverInfoVO()
default constructor

ReceiverInfoVO

public ReceiverInfoVO(java.lang.String receiverNumber,
                      java.lang.String purchaseOrderNumber)
minimal constructor

Method Detail

getReceiverNumber

public java.lang.String getReceiverNumber()

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)

getPurchaseOrderNumber

public java.lang.String getPurchaseOrderNumber()

setPurchaseOrderNumber

public void setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)

getAccountPayableNumber

public java.lang.String getAccountPayableNumber()

setAccountPayableNumber

public void setAccountPayableNumber(java.lang.String accountPayableNumber)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getApSub

public java.math.BigDecimal getApSub()

setApSub

public void setApSub(java.math.BigDecimal apSub)

getApReceived

public java.math.BigDecimal getApReceived()

setApReceived

public void setApReceived(java.math.BigDecimal apReceived)

getApOpen

public java.math.BigDecimal getApOpen()

setApOpen

public void setApOpen(java.math.BigDecimal apOpen)

getTotalDiscount

public java.math.BigDecimal getTotalDiscount()

setTotalDiscount

public void setTotalDiscount(java.math.BigDecimal totalDiscount)

getSubTotal

public java.math.BigDecimal getSubTotal()

setSubTotal

public void setSubTotal(java.math.BigDecimal subTotal)

getTotalTax

public java.math.BigDecimal getTotalTax()

setTotalTax

public void setTotalTax(java.math.BigDecimal totalTax)

getTotalFreight

public java.math.BigDecimal getTotalFreight()

setTotalFreight

public void setTotalFreight(java.math.BigDecimal totalFreight)

getGrantTotal

public java.math.BigDecimal getGrantTotal()

setGrantTotal

public void setGrantTotal(java.math.BigDecimal grantTotal)

getApPaidReceived

public java.math.BigDecimal getApPaidReceived()

setApPaidReceived

public void setApPaidReceived(java.math.BigDecimal apPaidReceived)

getApPaidGl

public java.math.BigDecimal getApPaidGl()

setApPaidGl

public void setApPaidGl(java.math.BigDecimal apPaidGl)

getApGl1Recorded

public java.math.BigDecimal getApGl1Recorded()

setApGl1Recorded

public void setApGl1Recorded(java.math.BigDecimal apGl1Recorded)

getApGl2Paid

public java.math.BigDecimal getApGl2Paid()

setApGl2Paid

public void setApGl2Paid(java.math.BigDecimal apGl2Paid)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getCollect

public java.lang.String getCollect()

setCollect

public void setCollect(java.lang.String collect)

getReceivedBy

public java.lang.String getReceivedBy()

setReceivedBy

public void setReceivedBy(java.lang.String receivedBy)

getDateReceived

public java.util.Date getDateReceived()

setDateReceived

public void setDateReceived(java.util.Date dateReceived)

getDeliveredTo

public java.lang.String getDeliveredTo()

setDeliveredTo

public void setDeliveredTo(java.lang.String deliveredTo)

getFreightBill

public java.lang.String getFreightBill()

setFreightBill

public void setFreightBill(java.lang.String freightBill)

getShippedVia

public java.lang.String getShippedVia()

setShippedVia

public void setShippedVia(java.lang.String shippedVia)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAccount

public java.lang.String getCarrierAccount()

setCarrierAccount

public void setCarrierAccount(java.lang.String carrierAccount)

getTracking

public java.lang.String getTracking()

setTracking

public void setTracking(java.lang.String tracking)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getRequester

public java.lang.String getRequester()

setRequester

public void setRequester(java.lang.String requester)

getProjectName

public java.lang.String getProjectName()

setProjectName

public void setProjectName(java.lang.String projectName)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getDebitAccount

public java.lang.String getDebitAccount()

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

getBp

public java.lang.String getBp()

setBp

public void setBp(java.lang.String bp)

getReceiverComments

public java.lang.String getReceiverComments()

setReceiverComments

public void setReceiverComments(java.lang.String receiverComments)

getReceiverPrivateNotes

public java.lang.String getReceiverPrivateNotes()

setReceiverPrivateNotes

public void setReceiverPrivateNotes(java.lang.String receiverPrivateNotes)

getDue

public java.math.BigDecimal getDue()

setDue

public void setDue(java.math.BigDecimal due)

getVendorInvoice

public java.lang.String getVendorInvoice()

setVendorInvoice

public void setVendorInvoice(java.lang.String vendorInvoice)

getVendorPackage

public java.lang.String getVendorPackage()

setVendorPackage

public void setVendorPackage(java.lang.String vendorPackage)

getVendorTotal

public java.math.BigDecimal getVendorTotal()

setVendorTotal

public void setVendorTotal(java.math.BigDecimal vendorTotal)

getVendorInvoiceDate

public java.util.Date getVendorInvoiceDate()

setVendorInvoiceDate

public void setVendorInvoiceDate(java.util.Date vendorInvoiceDate)

getPaydate

public java.util.Date getPaydate()

setPaydate

public void setPaydate(java.util.Date paydate)

getDatePaid

public java.util.Date getDatePaid()

setDatePaid

public void setDatePaid(java.util.Date datePaid)

getCheckNo

public java.lang.String getCheckNo()

setCheckNo

public void setCheckNo(java.lang.String checkNo)

getPaid

public java.math.BigDecimal getPaid()

setPaid

public void setPaid(java.math.BigDecimal paid)

getItran

public java.lang.String getItran()

setItran

public void setItran(java.lang.String itran)

getEtran

public java.lang.String getEtran()

setEtran

public void setEtran(java.lang.String etran)

getLastChangeTimes

public int getLastChangeTimes()

setLastChangeTimes

public void setLastChangeTimes(int lastChangeTimes)

setBatch

public void setBatch(java.lang.String batch)

setBuyer

public void setBuyer(java.lang.String buyer)

setVendorShipDate

public void setVendorShipDate(java.util.Date vendorShipDate)

getVendorAddressInfoVO

public CustomerVendorAddressInfoVO getVendorAddressInfoVO()

getBatch

public java.lang.String getBatch()

getBuyer

public java.lang.String getBuyer()

getVendorShipDate

public java.util.Date getVendorShipDate()

setVendorAddressInfo

public void setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfoVO)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReceiverItemAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ReceiverItemAgent

java.lang.Object
    extended by  bb.common.ReceiverItemAgent
All Implemented Interfaces:
java.io.Serializable
public class ReceiverItemAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ReceiverItemAgent()
Method Summary
void | adjustNaRecTobyPartNumber(java.lang.String partNumber)
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.lang.String | getCondition()
java.math.BigDecimal | getCost()
java.lang.String | getDescription()
java.math.BigDecimal | getFreight()
java.lang.String | getIrNumber()
java.lang.Short | getItemNumber()
java.util.Map | getLocatoins()
java.lang.String | getLot()
java.lang.String | getMfgPartNumber()
java.lang.String | getNaRecTo()
java.lang.String | getOneLocations()
java.lang.String | getOrderItemNumber()
java.lang.String | getOrderNumber()
BB2Part | getPart()
java.util.Set<ReceiverItemDetailAgent> | getReceivedToDetails()
java.lang.String | getReceiverNumber()
java.lang.String | getSerial()
java.math.BigDecimal | getTotalReceivedQty()
java.util.Map | getTrackingLog()
int | hashCode()
void | refresh()
void | setComments(java.lang.String comments)
void | setCondition(java.lang.String condition)
void | setCost(java.math.BigDecimal cost)
void | setDescription(java.lang.String description)
void | setFreight(java.math.BigDecimal freight)
void | setIrNumber(java.lang.String irNumber)
void | setItemNumber(java.lang.Short itemNumber)
void | setLot(java.lang.String lot)
void | setMfgPartNumber(java.lang.String mfgPartNumber)
void | setNaRecTo(java.lang.String naRecTo)
void | setOrderItemNumber(java.lang.String orderItemNumber)
void | setOrderNumber(java.lang.String orderNumber)
void | setPart(BB2Part part)
void | setReceivedToDetails(java.util.Set<ReceiverItemDetailAgent> receivedToDetails)
void | setReceiverNumber(java.lang.String receiverNumber)
void | setSerial(java.lang.String serial)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ReceiverItemAgent

public ReceiverItemAgent()
Method Detail

getReceiverNumber

public java.lang.String getReceiverNumber()

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)

setOrderItemNumber

public void setOrderItemNumber(java.lang.String orderItemNumber)

setFreight

public void setFreight(java.math.BigDecimal freight)

setCondition

public void setCondition(java.lang.String condition)

setComments

public void setComments(java.lang.String comments)

setSerial

public void setSerial(java.lang.String serial)

setLot

public void setLot(java.lang.String lot)

setReceivedToDetails

public void setReceivedToDetails(java.util.Set<ReceiverItemDetailAgent> receivedToDetails)

setCost

public void setCost(java.math.BigDecimal cost)

getOrderItemNumber

public java.lang.String getOrderItemNumber()

getFreight

public java.math.BigDecimal getFreight()

getCondition

public java.lang.String getCondition()

getComments

public java.lang.String getComments()

getSerial

public java.lang.String getSerial()

getLot

public java.lang.String getLot()

getReceivedToDetails

public java.util.Set<ReceiverItemDetailAgent> getReceivedToDetails()

getTotalReceivedQty

public java.math.BigDecimal getTotalReceivedQty()

getCost

public java.math.BigDecimal getCost()

getNaRecTo

public java.lang.String getNaRecTo()

setNaRecTo

public void setNaRecTo(java.lang.String naRecTo)

getItemNumber

public java.lang.Short getItemNumber()

setItemNumber

public void setItemNumber(java.lang.Short itemNumber)

getOrderNumber

public java.lang.String getOrderNumber()

setOrderNumber

public void setOrderNumber(java.lang.String orderNumber)

getPart

public BB2Part getPart()

setPart

public void setPart(BB2Part part)

refresh

public void refresh()

getOneLocations

public java.lang.String getOneLocations()

getLocatoins

public java.util.Map getLocatoins()

getTrackingLog

public java.util.Map getTrackingLog()

adjustNaRecTobyPartNumber

public void adjustNaRecTobyPartNumber(java.lang.String partNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getIrNumber

public java.lang.String getIrNumber()

setIrNumber

public void setIrNumber(java.lang.String irNumber)

getMfgPartNumber

public java.lang.String getMfgPartNumber()

setMfgPartNumber

public void setMfgPartNumber(java.lang.String mfgPartNumber)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReceiverItemDetailAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ReceiverItemDetailAgent

java.lang.Object
    extended by  bb.common.ReceiverItemDetailAgent
All Implemented Interfaces:
java.io.Serializable
public class ReceiverItemDetailAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ReceiverItemDetailAgent()
Method Summary
java.math.BigDecimal | getCost()
java.lang.Boolean | getIsGroup()
java.lang.Short | getItemNumber()
java.lang.String | getLocation()
java.math.BigDecimal | getReceivedQty()
java.lang.String | getReceivedTo()
java.lang.String | getShipperNumber()
java.lang.String | getToItemNumber()
java.lang.String | getToOrderNumber()
java.util.Set<ReceiverItemTrackingLogAgent> | getTrackingLog()
java.util.HashMap<java.lang.String,java.math.BigDecimal> | getTrackings()
void | setCost(java.math.BigDecimal cost)
void | setIsGroup(java.lang.Boolean isGroup)
void | setItemNumber(java.lang.Short itemNumber)
void | setLocation(java.lang.String location)
void | setReceivedQty(java.math.BigDecimal receivedQty)
void | setReceivedTo(java.lang.String receivedTo)
void | setShipperNumber(java.lang.String shipperNumber)
void | setToItemNumber(java.lang.String toItemNumber)
void | setToOrderNumber(java.lang.String toOrderNumber)
void | setTrackingLog(java.util.Set<ReceiverItemTrackingLogAgent> trackingLog)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ReceiverItemDetailAgent

public ReceiverItemDetailAgent()
Method Detail

setReceivedTo

public void setReceivedTo(java.lang.String receivedTo)

setReceivedQty

public void setReceivedQty(java.math.BigDecimal receivedQty)

setLocation

public void setLocation(java.lang.String location)

setToOrderNumber

public void setToOrderNumber(java.lang.String toOrderNumber)

setToItemNumber

public void setToItemNumber(java.lang.String toItemNumber)

setShipperNumber

public void setShipperNumber(java.lang.String shipperNumber)

setCost

public void setCost(java.math.BigDecimal cost)

setIsGroup

public void setIsGroup(java.lang.Boolean isGroup)

setItemNumber

public void setItemNumber(java.lang.Short itemNumber)

getReceivedTo

public java.lang.String getReceivedTo()

getReceivedQty

public java.math.BigDecimal getReceivedQty()

getLocation

public java.lang.String getLocation()

getToOrderNumber

public java.lang.String getToOrderNumber()

getToItemNumber

public java.lang.String getToItemNumber()

getShipperNumber

public java.lang.String getShipperNumber()

getCost

public java.math.BigDecimal getCost()

getIsGroup

public java.lang.Boolean getIsGroup()

getItemNumber

public java.lang.Short getItemNumber()

getTrackingLog

public java.util.Set<ReceiverItemTrackingLogAgent> getTrackingLog()

setTrackingLog

public void setTrackingLog(java.util.Set<ReceiverItemTrackingLogAgent> trackingLog)

getTrackings

public java.util.HashMap<java.lang.String,java.math.BigDecimal> getTrackings()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReceiverItemManufacturerPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ReceiverItemManufacturerPK

java.lang.Object
    extended by  bb.common.ReceiverItemManufacturerPK
All Implemented Interfaces:
java.io.Serializable
public class ReceiverItemManufacturerPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ReceiverItemManufacturerPK()
ReceiverItemManufacturerPK(java.lang.String receiverNumber, java.lang.String purchaseOrderItemNumber, java.lang.Short ii)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Short | getIi()
java.lang.String | getPurchaseOrderItemNumber()
java.lang.String | getReceiverNumber()
int | hashCode()
void | setIi(java.lang.Short ii)
void | setPurchaseOrderItemNumber(java.lang.String purchaseOrderItemNumber)
void | setReceiverNumber(java.lang.String receiverNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ReceiverItemManufacturerPK

public ReceiverItemManufacturerPK()

ReceiverItemManufacturerPK

public ReceiverItemManufacturerPK(java.lang.String receiverNumber,
                                  java.lang.String purchaseOrderItemNumber,
                                  java.lang.Short ii)
Method Detail

getReceiverNumber

public java.lang.String getReceiverNumber()

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)

getPurchaseOrderItemNumber

public java.lang.String getPurchaseOrderItemNumber()

setPurchaseOrderItemNumber

public void setPurchaseOrderItemNumber(java.lang.String purchaseOrderItemNumber)

getIi

public java.lang.Short getIi()

setIi

public void setIi(java.lang.Short ii)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReceiverItemManufacturerVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ReceiverItemManufacturerVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ReceiverItemManufacturerVO
All Implemented Interfaces:
java.io.Serializable
public class ReceiverItemManufacturerVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ReceiverItemManufacturerVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getManufacturerName()
java.lang.String | getManufacturerPartNumber()
ReceiverItemManufacturerPK | getPk()
int | hashCode()
void | setManufacturerName(java.lang.String manufacturerName)
void | setManufacturerPartNumber(java.lang.String manufacturerPartNumber)
void | setPk(ReceiverItemManufacturerPK pk)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ReceiverItemManufacturerVO

public ReceiverItemManufacturerVO()
Method Detail

getPk

public ReceiverItemManufacturerPK getPk()

setPk

public void setPk(ReceiverItemManufacturerPK pk)

getManufacturerName

public java.lang.String getManufacturerName()

setManufacturerName

public void setManufacturerName(java.lang.String manufacturerName)

getManufacturerPartNumber

public java.lang.String getManufacturerPartNumber()

setManufacturerPartNumber

public void setManufacturerPartNumber(java.lang.String manufacturerPartNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReceiverItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ReceiverItemPK

java.lang.Object
    extended by  bb.common.ReceiverItemPK
All Implemented Interfaces:
java.io.Serializable
public class ReceiverItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ReceiverItemPK()
ReceiverItemPK(java.lang.String receiverNumber, java.lang.String receiverItemNumber)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getReceiverItemNumber()
java.lang.String | getReceiverNumber()
int | hashCode()
void | setReceiverItemNumber(java.lang.String receiverItemNumber)
void | setReceiverNumber(java.lang.String receiverNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ReceiverItemPK

public ReceiverItemPK()

ReceiverItemPK

public ReceiverItemPK(java.lang.String receiverNumber,
                      java.lang.String receiverItemNumber)
Method Detail

setReceiverItemNumber

public void setReceiverItemNumber(java.lang.String receiverItemNumber)

getReceiverItemNumber

public java.lang.String getReceiverItemNumber()

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)

getReceiverNumber

public java.lang.String getReceiverNumber()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReceiverItemTrackingLogAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ReceiverItemTrackingLogAgent

java.lang.Object
    extended by  bb.common.ReceiverItemTrackingLogAgent
All Implemented Interfaces:
java.io.Serializable
public class ReceiverItemTrackingLogAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ReceiverItemTrackingLogAgent()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getDueDate()
java.math.BigDecimal | getQty()
java.lang.String | getTrackingNumber()
int | hashCode()
void | setDueDate(java.util.Date dueDate)
void | setQty(java.math.BigDecimal qty)
void | setTrackingNumber(java.lang.String trackingNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ReceiverItemTrackingLogAgent

public ReceiverItemTrackingLogAgent()
Method Detail

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

getTrackingNumber

public java.lang.String getTrackingNumber()

setTrackingNumber

public void setTrackingNumber(java.lang.String trackingNumber)

getDueDate

public java.util.Date getDueDate()

setDueDate

public void setDueDate(java.util.Date dueDate)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReceiverItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ReceiverItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ReceiverItemVO
All Implemented Interfaces:
java.io.Serializable
public class ReceiverItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ReceiverItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAccountPayableNumber()
java.math.BigDecimal | getApDiscount()
java.math.BigDecimal | getApOpen()
java.math.BigDecimal | getApReceived()
java.math.BigDecimal | getApSub()
java.math.BigDecimal | getApTax()
java.math.BigDecimal | getApTotal()
java.math.BigDecimal | getBb2PoRecQty()
java.lang.String | getCheckNumber()
java.lang.String | getComments()
java.lang.String | getCondition()
java.math.BigDecimal | getCostPerUnit()
java.util.Date | getDatePaid()
java.lang.String | getDescription()
java.math.BigDecimal | getDiscount()
java.math.BigDecimal | getDue()
java.math.BigDecimal | getExtendPrice()
java.math.BigDecimal | getItemGrandTotal()
java.lang.String | getLocation()
java.util.Map | getLocations()
java.lang.String | getMfg()
java.lang.String | getModelNumber()
java.lang.String | getMpn()
java.math.BigDecimal | getPaid()
PartVO | getPart()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
ReceiverItemPK | getPk()
java.lang.String | getPoItemNumber()
java.lang.String | getPrivateNotes()
java.lang.String | getProductCode()
java.lang.String | getPurchaseOrderNumber()
java.lang.String | getQr()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getQuantityReceived()
java.math.BigDecimal | getQuantityTraced()
java.lang.String | getReceivedBy()
java.util.Set | getReceiverItemManufacturer()
java.util.Set | getRefDocOnes()
java.util.Set | getRefDocTwoes()
java.lang.String | getReferenceDoc1()
java.lang.String | getReferenceDoc2()
java.lang.String | getRevision()
java.lang.String | getSentTo()
java.lang.String | getSerial()
java.lang.String | getStatus()
java.math.BigDecimal | getStdCost()
java.math.BigDecimal | getTaxRate()
java.util.Map | getTrackings()
java.lang.String | getUnit()
int | hashCode()
void | setAccountPayableNumber(java.lang.String accountPayableNumber)
void | setApDiscount(java.math.BigDecimal apDiscount)
void | setApOpen(java.math.BigDecimal apOpen)
void | setApReceived(java.math.BigDecimal apReceived)
void | setApSub(java.math.BigDecimal apSub)
void | setApTax(java.math.BigDecimal apTax)
void | setApTotal(java.math.BigDecimal apTotal)
void | setBb2PoRecQty(java.math.BigDecimal bb2PoRecQty)
void | setCheckNumber(java.lang.String checkNumber)
void | setComments(java.lang.String comments)
void | setCondition(java.lang.String condition)
void | setCostPerUnit(java.math.BigDecimal costPerUnit)
void | setDatePaid(java.util.Date datePaid)
void | setDescription(java.lang.String description)
void | setDiscount(java.math.BigDecimal discount)
void | setDue(java.math.BigDecimal due)
void | setExtendPrice(java.math.BigDecimal extendPrice)
void | setItemGrandTotal(java.math.BigDecimal itemGrandTotal)
void | setLocation(java.lang.String location)
void | setLocations(java.util.Map locations)
void | setMfg(java.lang.String mfg)
void | setModelNumber(java.lang.String modelNumber)
void | setMpn(java.lang.String mpn)
void | setPaid(java.math.BigDecimal paid)
void | setPart(PartVO part)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(ReceiverItemPK pk)
void | setPoItemNumber(java.lang.String poItemNumber)
void | setPrivateNotes(java.lang.String privateNotes)
void | setProductCode(java.lang.String productCode)
void | setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)
void | setQr(java.lang.String qr)
void | setQuantity(java.math.BigDecimal quantity)
void | setQuantityReceived(java.math.BigDecimal quantityReceived)
void | setQuantityTraced(java.math.BigDecimal quantityTraced)
void | setReceivedBy(java.lang.String receivedBy)
void | setReceiverItemManufacturer(java.util.Set receiverItemManufacturer)
void | setRefDocOnes(java.util.Set refDocOnes)
void | setRefDocTwoes(java.util.Set refDocTwoes)
void | setReferenceDoc1(java.lang.String referenceDoc1)
void | setReferenceDoc2(java.lang.String referenceDoc2)
void | setRevision(java.lang.String revision)
void | setSentTo(java.lang.String sentTo)
void | setSerial(java.lang.String serial)
void | setStatus(java.lang.String status)
void | setStdCost(java.math.BigDecimal stdCost)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setTrackings(java.util.Map trackings)
void | setUnit(java.lang.String unit)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ReceiverItemVO

public ReceiverItemVO()
Method Detail

getPk

public ReceiverItemPK getPk()

setPk

public void setPk(ReceiverItemPK pk)

getPurchaseOrderNumber

public java.lang.String getPurchaseOrderNumber()

setPurchaseOrderNumber

public void setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)

getApSub

public java.math.BigDecimal getApSub()

setApSub

public void setApSub(java.math.BigDecimal apSub)

getApReceived

public java.math.BigDecimal getApReceived()

setApReceived

public void setApReceived(java.math.BigDecimal apReceived)

getApOpen

public java.math.BigDecimal getApOpen()

setApOpen

public void setApOpen(java.math.BigDecimal apOpen)

getApDiscount

public java.math.BigDecimal getApDiscount()

setApDiscount

public void setApDiscount(java.math.BigDecimal apDiscount)

getExtendPrice

public java.math.BigDecimal getExtendPrice()

setExtendPrice

public void setExtendPrice(java.math.BigDecimal extendPrice)

getApTax

public java.math.BigDecimal getApTax()

setApTax

public void setApTax(java.math.BigDecimal apTax)

getApTotal

public java.math.BigDecimal getApTotal()

setApTotal

public void setApTotal(java.math.BigDecimal apTotal)

getReferenceDoc1

public java.lang.String getReferenceDoc1()

setReferenceDoc1

public void setReferenceDoc1(java.lang.String referenceDoc1)

getReferenceDoc2

public java.lang.String getReferenceDoc2()

setReferenceDoc2

public void setReferenceDoc2(java.lang.String referenceDoc2)

getQr

public java.lang.String getQr()

setQr

public void setQr(java.lang.String qr)

getSentTo

public java.lang.String getSentTo()

setSentTo

public void setSentTo(java.lang.String sentTo)

getReceivedBy

public java.lang.String getReceivedBy()

setReceivedBy

public void setReceivedBy(java.lang.String receivedBy)

getCondition

public java.lang.String getCondition()

setCondition

public void setCondition(java.lang.String condition)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getQuantityTraced

public java.math.BigDecimal getQuantityTraced()

setQuantityTraced

public void setQuantityTraced(java.math.BigDecimal quantityTraced)

getQuantityReceived

public java.math.BigDecimal getQuantityReceived()

setQuantityReceived

public void setQuantityReceived(java.math.BigDecimal quantityReceived)

getCostPerUnit

public java.math.BigDecimal getCostPerUnit()

setCostPerUnit

public void setCostPerUnit(java.math.BigDecimal costPerUnit)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getSerial

public java.lang.String getSerial()

setSerial

public void setSerial(java.lang.String serial)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getPrivateNotes

public java.lang.String getPrivateNotes()

setPrivateNotes

public void setPrivateNotes(java.lang.String privateNotes)

setPart

public void setPart(PartVO part)

setCheckNumber

public void setCheckNumber(java.lang.String checkNumber)

setDue

public void setDue(java.math.BigDecimal due)

setDatePaid

public void setDatePaid(java.util.Date datePaid)

setPaid

public void setPaid(java.math.BigDecimal paid)

setRefDocOnes

public void setRefDocOnes(java.util.Set refDocOnes)

setBb2PoRecQty

public void setBb2PoRecQty(java.math.BigDecimal bb2PoRecQty)

getPart

public PartVO getPart()

getCheckNumber

public java.lang.String getCheckNumber()

getDue

public java.math.BigDecimal getDue()

getDatePaid

public java.util.Date getDatePaid()

getPaid

public java.math.BigDecimal getPaid()

getRefDocTwoes

public java.util.Set getRefDocTwoes()

setRefDocTwoes

public void setRefDocTwoes(java.util.Set refDocTwoes)

getRefDocOnes

public java.util.Set getRefDocOnes()

getBb2PoRecQty

public java.math.BigDecimal getBb2PoRecQty()

getReceiverItemManufacturer

public java.util.Set getReceiverItemManufacturer()

setReceiverItemManufacturer

public void setReceiverItemManufacturer(java.util.Set receiverItemManufacturer)

getPoItemNumber

public java.lang.String getPoItemNumber()

setPoItemNumber

public void setPoItemNumber(java.lang.String poItemNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getItemGrandTotal

public java.math.BigDecimal getItemGrandTotal()

setItemGrandTotal

public void setItemGrandTotal(java.math.BigDecimal itemGrandTotal)

getAccountPayableNumber

public java.lang.String getAccountPayableNumber()

setAccountPayableNumber

public void setAccountPayableNumber(java.lang.String accountPayableNumber)

getProductCode

public java.lang.String getProductCode()

setProductCode

public void setProductCode(java.lang.String productCode)

getLocations

public java.util.Map getLocations()

setLocations

public void setLocations(java.util.Map locations)

getTrackings

public java.util.Map getTrackings()

setTrackings

public void setTrackings(java.util.Map trackings)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReceiverShipAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ReceiverShipAgent

java.lang.Object
    extended by  bb.common.ReceiverShipAgent
All Implemented Interfaces:
java.io.Serializable
public class ReceiverShipAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ReceiverShipAgent()
Method Summary
java.math.BigDecimal | getFreight()
java.lang.String | getLocation(java.lang.String itemNumber)
java.util.Map<java.lang.String,java.lang.String> | getLocations()
java.lang.String | getOrderNumber()
java.lang.Boolean | getReceiveAll()
java.lang.Boolean | getReceiveAllSo()
java.lang.Boolean | getReceiveAllWo()
java.util.Date | getReceivedDate()
java.lang.String | getSerial(java.lang.String itemNumber)
java.util.Map<java.lang.String,java.lang.String> | getSerials()
java.lang.String | getShipperNumber(java.lang.String itemNumber)
java.util.Map<java.lang.String,java.lang.String> | getShipperNumbers()
java.lang.String | getVendorInvoice()
java.util.Date | getVendorInvoiceDate()
java.lang.String | getVendorShipperNumber()
java.lang.String | getWareHouse()
void | setFreight(java.math.BigDecimal freight)
void | setLocations(java.util.Map<java.lang.String,java.lang.String> locations)
void | setLoction(java.lang.String itemNumber, java.lang.String location)
void | setOrderNumber(java.lang.String orderNumber)
void | setReceiveAll(java.lang.Boolean receiveAll)
void | setReceiveAllSo(java.lang.Boolean receiveAllSo)
void | setReceiveAllWo(java.lang.Boolean receiveAllWo)
void | setReceivedDate(java.util.Date receivedDate)
void | setSerial(java.lang.String itemNumber, java.lang.String serial)
void | setSerials(java.util.Map<java.lang.String,java.lang.String> serials)
void | setShipperNumber(java.lang.String itemNumber, java.lang.String shipperNumber)
void | setShipperNumbers(java.util.Map<java.lang.String,java.lang.String> shipperNumbers)
void | setVendorInvoice(java.lang.String vendorInvoice)
void | setVendorInvoiceDate(java.util.Date vendorInvoiceDate)
void | setVendorShipperNumber(java.lang.String vendorShipperNumber)
void | setWareHouse(java.lang.String wareHouse)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ReceiverShipAgent

public ReceiverShipAgent()
Method Detail

getOrderNumber

public java.lang.String getOrderNumber()

getWareHouse

public java.lang.String getWareHouse()

getReceivedDate

public java.util.Date getReceivedDate()

getVendorInvoice

public java.lang.String getVendorInvoice()

getVendorInvoiceDate

public java.util.Date getVendorInvoiceDate()

getFreight

public java.math.BigDecimal getFreight()

getReceiveAll

public java.lang.Boolean getReceiveAll()

getReceiveAllSo

public java.lang.Boolean getReceiveAllSo()

getReceiveAllWo

public java.lang.Boolean getReceiveAllWo()

getLocations

public java.util.Map<java.lang.String,java.lang.String> getLocations()

getSerials

public java.util.Map<java.lang.String,java.lang.String> getSerials()

getShipperNumbers

public java.util.Map<java.lang.String,java.lang.String> getShipperNumbers()

setOrderNumber

public void setOrderNumber(java.lang.String orderNumber)

setWareHouse

public void setWareHouse(java.lang.String wareHouse)

setReceivedDate

public void setReceivedDate(java.util.Date receivedDate)

setVendorInvoice

public void setVendorInvoice(java.lang.String vendorInvoice)

setVendorInvoiceDate

public void setVendorInvoiceDate(java.util.Date vendorInvoiceDate)

setFreight

public void setFreight(java.math.BigDecimal freight)

setReceiveAll

public void setReceiveAll(java.lang.Boolean receiveAll)

setReceiveAllSo

public void setReceiveAllSo(java.lang.Boolean receiveAllSo)

setReceiveAllWo

public void setReceiveAllWo(java.lang.Boolean receiveAllWo)

setLocations

public void setLocations(java.util.Map<java.lang.String,java.lang.String> locations)

setSerials

public void setSerials(java.util.Map<java.lang.String,java.lang.String> serials)

setShipperNumbers

public void setShipperNumbers(java.util.Map<java.lang.String,java.lang.String> shipperNumbers)

getLocation

public java.lang.String getLocation(java.lang.String itemNumber)

setLoction

public void setLoction(java.lang.String itemNumber,
                       java.lang.String location)

getSerial

public java.lang.String getSerial(java.lang.String itemNumber)

setSerial

public void setSerial(java.lang.String itemNumber,
                      java.lang.String serial)

getShipperNumber

public java.lang.String getShipperNumber(java.lang.String itemNumber)

setShipperNumber

public void setShipperNumber(java.lang.String itemNumber,
                             java.lang.String shipperNumber)

getVendorShipperNumber

public java.lang.String getVendorShipperNumber()

setVendorShipperNumber

public void setVendorShipperNumber(java.lang.String vendorShipperNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReceiverVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ReceiverVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ReceiverVO
All Implemented Interfaces:
java.io.Serializable
public class ReceiverVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ReceiverVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAccountPayableNumber()
java.util.Date | getAdate()
java.math.BigDecimal | getApGl1Recorded()
java.math.BigDecimal | getApGl2Paid()
java.lang.String | getApNetSet()
java.math.BigDecimal | getApOpen()
java.math.BigDecimal | getApPaidGl()
java.math.BigDecimal | getApPaidReceived()
java.math.BigDecimal | getApReceived()
java.math.BigDecimal | getApSub()
java.lang.String | getApTaxSet()
java.lang.String | getBatch()
java.lang.String | getBp()
java.lang.String | getBuyer()
java.lang.String | getCarrier()
java.lang.String | getCarrierAccount()
java.lang.String | getChangeOrder()
java.lang.String | getCheckNo()
java.lang.String | getCoComments()
java.lang.String | getCollect()
java.lang.String | getComments()
java.lang.String | getCompanyUnitId()
java.lang.String | getCurrency()
java.util.Date | getDatePaid()
java.util.Date | getDateReceived()
java.lang.String | getDebitAccount()
java.lang.String | getDeliveredTo()
java.math.BigDecimal | getDue()
java.lang.String | getEtran()
java.math.BigDecimal | getExchange()
java.lang.String | getFreightBill()
java.math.BigDecimal | getGrantTotal()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getItran()
java.util.Date | getLastChangeDate()
int | getLastChangeTimes()
java.lang.String | getLastChangeUser()
java.lang.String | getOrigin()
java.math.BigDecimal | getPaid()
java.util.Date | getPaydate()
java.lang.String | getPrivateNotes()
java.lang.String | getProjectName()
java.lang.String | getPurchaseOrderNumber()
java.lang.String | getReceivedBy()
java.util.Set | getReceiverItem()
java.lang.String | getReceiverNumber()
java.lang.String | getRelatedDoc()
java.lang.String | getRequester()
java.lang.String | getShippedVia()
java.lang.String | getStatus()
java.math.BigDecimal | getSubTotal()
java.lang.String | getTerms()
java.math.BigDecimal | getTotalDiscount()
java.math.BigDecimal | getTotalFreight()
java.math.BigDecimal | getTotalTax()
java.lang.String | getTracking()
CustomerVendorAddressInfoVO | getVendorAddressInfo()
java.lang.String | getVendorId()
java.lang.String | getVendorInvoice()
java.util.Date | getVendorInvoiceDate()
java.lang.String | getVendorPackage()
java.util.Date | getVendorShipDate()
java.math.BigDecimal | getVendorTotal()
int | hashCode()
void | setAccountPayableNumber(java.lang.String accountPayableNumber)
void | setAdate(java.util.Date adate)
void | setApGl1Recorded(java.math.BigDecimal apGl1Recorded)
void | setApGl2Paid(java.math.BigDecimal apGl2Paid)
void | setApNetSet(java.lang.String apNetSet)
void | setApOpen(java.math.BigDecimal apOpen)
void | setApPaidGl(java.math.BigDecimal apPaidGl)
void | setApPaidReceived(java.math.BigDecimal apPaidReceived)
void | setApReceived(java.math.BigDecimal apReceived)
void | setApSub(java.math.BigDecimal apSub)
void | setApTaxSet(java.lang.String apTaxSet)
void | setBatch(java.lang.String batch)
void | setBp(java.lang.String bp)
void | setBuyer(java.lang.String buyer)
void | setCarrier(java.lang.String carrier)
void | setCarrierAccount(java.lang.String carrierAccount)
void | setChangeOrder(java.lang.String changeOrder)
void | setCheckNo(java.lang.String checkNo)
void | setCoComments(java.lang.String coComments)
void | setCollect(java.lang.String collect)
void | setComments(java.lang.String comments)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCurrency(java.lang.String currency)
void | setDatePaid(java.util.Date datePaid)
void | setDateReceived(java.util.Date dateReceived)
void | setDebitAccount(java.lang.String debitAccount)
void | setDeliveredTo(java.lang.String deliveredTo)
void | setDue(java.math.BigDecimal due)
void | setEtran(java.lang.String etran)
void | setExchange(java.math.BigDecimal exchange)
void | setFreightBill(java.lang.String freightBill)
void | setGrantTotal(java.math.BigDecimal grantTotal)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setItran(java.lang.String itran)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTimes(int lastChangeTimes)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setOrigin(java.lang.String origin)
void | setPaid(java.math.BigDecimal paid)
void | setPaydate(java.util.Date paydate)
void | setPrivateNotes(java.lang.String privateNotes)
void | setProjectName(java.lang.String projectName)
void | setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)
void | setReceivedBy(java.lang.String receivedBy)
void | setReceiverItem(java.util.Set receiverItem)
void | setReceiverNumber(java.lang.String receiverNumber)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setRequester(java.lang.String requester)
void | setShippedVia(java.lang.String shippedVia)
void | setStatus(java.lang.String status)
void | setSubTotal(java.math.BigDecimal subTotal)
void | setTerms(java.lang.String terms)
void | setTotalDiscount(java.math.BigDecimal totalDiscount)
void | setTotalFreight(java.math.BigDecimal totalFreight)
void | setTotalTax(java.math.BigDecimal totalTax)
void | setTracking(java.lang.String tracking)
void | setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)
void | setVendorId(java.lang.String vendorId)
void | setVendorInvoice(java.lang.String vendorInvoice)
void | setVendorInvoiceDate(java.util.Date vendorInvoiceDate)
void | setVendorPackage(java.lang.String vendorPackage)
void | setVendorShipDate(java.util.Date vendorShipDate)
void | setVendorTotal(java.math.BigDecimal vendorTotal)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ReceiverVO

public ReceiverVO()
Method Detail

getReceiverNumber

public java.lang.String getReceiverNumber()

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)

getPurchaseOrderNumber

public java.lang.String getPurchaseOrderNumber()

setPurchaseOrderNumber

public void setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)

getAccountPayableNumber

public java.lang.String getAccountPayableNumber()

setAccountPayableNumber

public void setAccountPayableNumber(java.lang.String accountPayableNumber)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getApSub

public java.math.BigDecimal getApSub()

setApSub

public void setApSub(java.math.BigDecimal apSub)

getApReceived

public java.math.BigDecimal getApReceived()

setApReceived

public void setApReceived(java.math.BigDecimal apReceived)

getApOpen

public java.math.BigDecimal getApOpen()

setApOpen

public void setApOpen(java.math.BigDecimal apOpen)

getTotalDiscount

public java.math.BigDecimal getTotalDiscount()

setTotalDiscount

public void setTotalDiscount(java.math.BigDecimal totalDiscount)

getSubTotal

public java.math.BigDecimal getSubTotal()

setSubTotal

public void setSubTotal(java.math.BigDecimal subTotal)

getTotalTax

public java.math.BigDecimal getTotalTax()

setTotalTax

public void setTotalTax(java.math.BigDecimal totalTax)

getTotalFreight

public java.math.BigDecimal getTotalFreight()

setTotalFreight

public void setTotalFreight(java.math.BigDecimal totalFreight)

getGrantTotal

public java.math.BigDecimal getGrantTotal()

setGrantTotal

public void setGrantTotal(java.math.BigDecimal grantTotal)

getApPaidReceived

public java.math.BigDecimal getApPaidReceived()

setApPaidReceived

public void setApPaidReceived(java.math.BigDecimal apPaidReceived)

getApPaidGl

public java.math.BigDecimal getApPaidGl()

setApPaidGl

public void setApPaidGl(java.math.BigDecimal apPaidGl)

getApGl1Recorded

public java.math.BigDecimal getApGl1Recorded()

setApGl1Recorded

public void setApGl1Recorded(java.math.BigDecimal apGl1Recorded)

getApGl2Paid

public java.math.BigDecimal getApGl2Paid()

setApGl2Paid

public void setApGl2Paid(java.math.BigDecimal apGl2Paid)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getCollect

public java.lang.String getCollect()

setCollect

public void setCollect(java.lang.String collect)

getReceivedBy

public java.lang.String getReceivedBy()

setReceivedBy

public void setReceivedBy(java.lang.String receivedBy)

getDateReceived

public java.util.Date getDateReceived()

setDateReceived

public void setDateReceived(java.util.Date dateReceived)

getDeliveredTo

public java.lang.String getDeliveredTo()

setDeliveredTo

public void setDeliveredTo(java.lang.String deliveredTo)

getFreightBill

public java.lang.String getFreightBill()

setFreightBill

public void setFreightBill(java.lang.String freightBill)

getShippedVia

public java.lang.String getShippedVia()

setShippedVia

public void setShippedVia(java.lang.String shippedVia)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAccount

public java.lang.String getCarrierAccount()

setCarrierAccount

public void setCarrierAccount(java.lang.String carrierAccount)

getTracking

public java.lang.String getTracking()

setTracking

public void setTracking(java.lang.String tracking)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getRequester

public java.lang.String getRequester()

setRequester

public void setRequester(java.lang.String requester)

getProjectName

public java.lang.String getProjectName()

setProjectName

public void setProjectName(java.lang.String projectName)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getDebitAccount

public java.lang.String getDebitAccount()

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

getBp

public java.lang.String getBp()

setBp

public void setBp(java.lang.String bp)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getPrivateNotes

public java.lang.String getPrivateNotes()

setPrivateNotes

public void setPrivateNotes(java.lang.String privateNotes)

getDue

public java.math.BigDecimal getDue()

setDue

public void setDue(java.math.BigDecimal due)

getVendorInvoice

public java.lang.String getVendorInvoice()

setVendorInvoice

public void setVendorInvoice(java.lang.String vendorInvoice)

getVendorPackage

public java.lang.String getVendorPackage()

setVendorPackage

public void setVendorPackage(java.lang.String vendorPackage)

getVendorTotal

public java.math.BigDecimal getVendorTotal()

setVendorTotal

public void setVendorTotal(java.math.BigDecimal vendorTotal)

getVendorInvoiceDate

public java.util.Date getVendorInvoiceDate()

setVendorInvoiceDate

public void setVendorInvoiceDate(java.util.Date vendorInvoiceDate)

getPaydate

public java.util.Date getPaydate()

setPaydate

public void setPaydate(java.util.Date paydate)

getDatePaid

public java.util.Date getDatePaid()

setDatePaid

public void setDatePaid(java.util.Date datePaid)

getCheckNo

public java.lang.String getCheckNo()

setCheckNo

public void setCheckNo(java.lang.String checkNo)

getPaid

public java.math.BigDecimal getPaid()

setPaid

public void setPaid(java.math.BigDecimal paid)

getItran

public java.lang.String getItran()

setItran

public void setItran(java.lang.String itran)

getEtran

public java.lang.String getEtran()

setEtran

public void setEtran(java.lang.String etran)

getLastChangeTimes

public int getLastChangeTimes()

setLastChangeTimes

public void setLastChangeTimes(int lastChangeTimes)

getVendorAddressInfo

public CustomerVendorAddressInfoVO getVendorAddressInfo()

setVendorAddressInfo

public void setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)

getReceiverItem

public java.util.Set getReceiverItem()

getApNetSet

public java.lang.String getApNetSet()

getApTaxSet

public java.lang.String getApTaxSet()

getBatch

public java.lang.String getBatch()

getBuyer

public java.lang.String getBuyer()

getCoComments

public java.lang.String getCoComments()

getVendorShipDate

public java.util.Date getVendorShipDate()

setReceiverItem

public void setReceiverItem(java.util.Set receiverItem)

setApNetSet

public void setApNetSet(java.lang.String apNetSet)

setApTaxSet

public void setApTaxSet(java.lang.String apTaxSet)

setBatch

public void setBatch(java.lang.String batch)

setBuyer

public void setBuyer(java.lang.String buyer)

setCoComments

public void setCoComments(java.lang.String coComments)

setVendorShipDate

public void setVendorShipDate(java.util.Date vendorShipDate)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getExchange

public java.math.BigDecimal getExchange()

setExchange

public void setExchange(java.math.BigDecimal exchange)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReceivingItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ReceivingItemResult

java.lang.Object
    extended by  bb.common.ReceivingItemResult
All Implemented Interfaces:
java.io.Serializable
public class ReceivingItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ReceivingItemResult()
Method Summary
java.lang.String | getComments()
java.math.BigDecimal | getCostPerUnit()
java.lang.String | getDescription()
java.lang.String | getDrawing()
java.lang.String | getIrNumber()
java.math.BigDecimal | getIrTotalRefQty()
java.lang.Short | getItemNumber()
java.math.BigDecimal | getMaxReceived()
java.lang.String | getMfg()
java.math.BigDecimal | getMinReceived()
java.lang.String | getMpn()
java.lang.String | getOrderItemNumber()
java.lang.String | getOrderNumber()
java.lang.String | getPartFrom()
java.util.Set | getPartLocations()
java.util.Set<PartManufacturerVO> | getPartManufacturers()
PartPK | getPartPk()
java.util.Set<PartTrackingVO> | getPartTracking()
java.util.Date | getPoItemShipDate()
java.lang.String | getPoUnit()
java.math.BigDecimal | getPoUnitQty()
java.lang.String | getPrivateNotes()
java.lang.String | getQCode()
java.math.BigDecimal | getQtyCheck()
java.math.BigDecimal | getQtyQualified()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getQuantityReceived()
java.lang.String | getRCode()
java.util.Set | getReceivedToOrderItems()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.lang.String | getRevision()
java.lang.String | getStatus()
java.math.BigDecimal | getTotalOnDemand()
java.math.BigDecimal | getTotalOnhand()
java.lang.String | getUnit()
boolean | isIcrRequiredWhenReceiverNa()
boolean | isItemReceivable()
boolean | isItemReceivableAll()
boolean | isTraceable()
void | setComments(java.lang.String comments)
void | setCostPerUnit(java.math.BigDecimal costPerUnit)
void | setDescription(java.lang.String description)
void | setDrawing(java.lang.String drawing)
void | setIcrRequiredWhenReceiverNa(boolean icrRequiredWhenReceiverNa)
void | setIrNumber(java.lang.String irNumber)
void | setIrTotalRefQty(java.math.BigDecimal irTotalRefQty)
void | setItemNumber(java.lang.Short itemNumber)
void | setItemReceivable(boolean itemReceivable)
void | setItemReceivableAll(boolean itemReceivableAll)
void | setMaxReceived(java.math.BigDecimal maxReceived)
void | setMfg(java.lang.String mfg)
void | setMinReceived(java.math.BigDecimal minReceived)
void | setMpn(java.lang.String mpn)
void | setOrderItemNumber(java.lang.String orderItemNumber)
void | setOrderNumber(java.lang.String orderNumber)
void | setPartFrom(java.lang.String partFrom)
void | setPartLocations(java.util.Set partLocations)
void | setPartManufacturers(java.util.Set<PartManufacturerVO> partManufacturers)
void | setPartPk(PartPK partPk)
void | setPartTracking(java.util.Set<PartTrackingVO> partTracking)
void | setPoItemShipDate(java.util.Date poItemShipDate)
void | setPoUnit(java.lang.String poUnit)
void | setPoUnitQty(java.math.BigDecimal poUnitQty)
void | setPrivateNotes(java.lang.String privateNotes)
void | setQCode(java.lang.String qCode)
void | setQtyCheck(java.math.BigDecimal qtyCheck)
void | setQtyQualified(java.math.BigDecimal qtyQualified)
void | setQuantity(java.math.BigDecimal quantity)
void | setQuantityReceived(java.math.BigDecimal quantityReceived)
void | setRCode(java.lang.String rCode)
void | setReceivedToOrderItems(java.util.Set receivedToOrderItems)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setRevision(java.lang.String revision)
void | setStatus(java.lang.String status)
void | setTotalOnDemand(java.math.BigDecimal totalOnDemand)
void | setTotalOnhand(java.math.BigDecimal totalOnhand)
void | setTraceable(boolean traceable)
void | setUnit(java.lang.String unit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ReceivingItemResult

public ReceivingItemResult()
Method Detail

setOrderNumber

public void setOrderNumber(java.lang.String orderNumber)

setOrderItemNumber

public void setOrderItemNumber(java.lang.String orderItemNumber)

setPartPk

public void setPartPk(PartPK partPk)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setRevision

public void setRevision(java.lang.String revision)

setDrawing

public void setDrawing(java.lang.String drawing)

setDescription

public void setDescription(java.lang.String description)

setComments

public void setComments(java.lang.String comments)

setPrivateNotes

public void setPrivateNotes(java.lang.String privateNotes)

setMfg

public void setMfg(java.lang.String mfg)

setMpn

public void setMpn(java.lang.String mpn)

setQCode

public void setQCode(java.lang.String qCode)

setRCode

public void setRCode(java.lang.String rCode)

setStatus

public void setStatus(java.lang.String status)

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

setQuantityReceived

public void setQuantityReceived(java.math.BigDecimal quantityReceived)

setPartLocations

public void setPartLocations(java.util.Set partLocations)

setTotalOnhand

public void setTotalOnhand(java.math.BigDecimal totalOnhand)

setUnit

public void setUnit(java.lang.String unit)

setReceivedToOrderItems

public void setReceivedToOrderItems(java.util.Set receivedToOrderItems)

setPoItemShipDate

public void setPoItemShipDate(java.util.Date poItemShipDate)

getOrderNumber

public java.lang.String getOrderNumber()

getOrderItemNumber

public java.lang.String getOrderItemNumber()

getPartPk

public PartPK getPartPk()

getPartFrom

public java.lang.String getPartFrom()

getRevision

public java.lang.String getRevision()

getDrawing

public java.lang.String getDrawing()

getDescription

public java.lang.String getDescription()

getComments

public java.lang.String getComments()

getPrivateNotes

public java.lang.String getPrivateNotes()

getMfg

public java.lang.String getMfg()

getMpn

public java.lang.String getMpn()

getQCode

public java.lang.String getQCode()

getRCode

public java.lang.String getRCode()

getStatus

public java.lang.String getStatus()

getQuantity

public java.math.BigDecimal getQuantity()

getQuantityReceived

public java.math.BigDecimal getQuantityReceived()

getPartLocations

public java.util.Set getPartLocations()

getTotalOnhand

public java.math.BigDecimal getTotalOnhand()

getUnit

public java.lang.String getUnit()

getReceivedToOrderItems

public java.util.Set getReceivedToOrderItems()

getPoItemShipDate

public java.util.Date getPoItemShipDate()

isItemReceivable

public boolean isItemReceivable()

setItemReceivable

public void setItemReceivable(boolean itemReceivable)

isItemReceivableAll

public boolean isItemReceivableAll()

setItemReceivableAll

public void setItemReceivableAll(boolean itemReceivableAll)

getMaxReceived

public java.math.BigDecimal getMaxReceived()

setMaxReceived

public void setMaxReceived(java.math.BigDecimal maxReceived)

getMinReceived

public java.math.BigDecimal getMinReceived()

setMinReceived

public void setMinReceived(java.math.BigDecimal minReceived)

getTotalOnDemand

public java.math.BigDecimal getTotalOnDemand()

setTotalOnDemand

public void setTotalOnDemand(java.math.BigDecimal totalOnDemand)

getPoUnit

public java.lang.String getPoUnit()

setPoUnit

public void setPoUnit(java.lang.String poUnit)

getPoUnitQty

public java.math.BigDecimal getPoUnitQty()

setPoUnitQty

public void setPoUnitQty(java.math.BigDecimal poUnitQty)

getQtyCheck

public java.math.BigDecimal getQtyCheck()

setQtyCheck

public void setQtyCheck(java.math.BigDecimal qtyCheck)

getQtyQualified

public java.math.BigDecimal getQtyQualified()

setQtyQualified

public void setQtyQualified(java.math.BigDecimal qtyQualified)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getIrNumber

public java.lang.String getIrNumber()

setIrNumber

public void setIrNumber(java.lang.String irNumber)

getCostPerUnit

public java.math.BigDecimal getCostPerUnit()

setCostPerUnit

public void setCostPerUnit(java.math.BigDecimal costPerUnit)

getIrTotalRefQty

public java.math.BigDecimal getIrTotalRefQty()

setIrTotalRefQty

public void setIrTotalRefQty(java.math.BigDecimal irTotalRefQty)

getPartTracking

public java.util.Set<PartTrackingVO> getPartTracking()

setPartTracking

public void setPartTracking(java.util.Set<PartTrackingVO> partTracking)

isTraceable

public boolean isTraceable()

setTraceable

public void setTraceable(boolean traceable)

getPartManufacturers

public java.util.Set<PartManufacturerVO> getPartManufacturers()

setPartManufacturers

public void setPartManufacturers(java.util.Set<PartManufacturerVO> partManufacturers)

getItemNumber

public java.lang.Short getItemNumber()

setItemNumber

public void setItemNumber(java.lang.Short itemNumber)

isIcrRequiredWhenReceiverNa

public boolean isIcrRequiredWhenReceiverNa()

setIcrRequiredWhenReceiverNa

public void setIcrRequiredWhenReceiverNa(boolean icrRequiredWhenReceiverNa)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReceivingResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ReceivingResult

java.lang.Object
    extended by  bb.common.ReceivingResult
All Implemented Interfaces:
java.io.Serializable
public class ReceivingResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ReceivingResult()
Method Summary
java.lang.String | getChangeOrder()
java.lang.String | getCompanyUnitId()
java.lang.String | getDebitAccount()
java.math.BigDecimal | getFreight()
java.lang.String | getOrderNumber()
java.lang.String | getProject()
java.lang.String | getReceiver()
java.util.Set | getReceivingItems()
java.lang.String | getRelatedDoc()
java.lang.String | getUserName()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
boolean | isHold()
void | setChangeOrder(java.lang.String changeOrder)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setDebitAccount(java.lang.String debitAccount)
void | setFreight(java.math.BigDecimal freight)
void | setHold(boolean hold)
void | setOrderNumber(java.lang.String orderNumber)
void | setProject(java.lang.String project)
void | setReceiver(java.lang.String receiver)
void | setReceivingItems(java.util.Set receivingItems)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setUserName(java.lang.String userName)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ReceivingResult

public ReceivingResult()
Method Detail

setOrderNumber

public void setOrderNumber(java.lang.String orderNumber)

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

setVendorId

public void setVendorId(java.lang.String vendorId)

setVendorName

public void setVendorName(java.lang.String vendorName)

setReceivingItems

public void setReceivingItems(java.util.Set receivingItems)

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

getOrderNumber

public java.lang.String getOrderNumber()

getChangeOrder

public java.lang.String getChangeOrder()

getVendorId

public java.lang.String getVendorId()

getVendorName

public java.lang.String getVendorName()

getReceivingItems

public java.util.Set getReceivingItems()

getDebitAccount

public java.lang.String getDebitAccount()

getFreight

public java.math.BigDecimal getFreight()

setFreight

public void setFreight(java.math.BigDecimal freight)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

isHold

public boolean isHold()

setHold

public void setHold(boolean hold)

getReceiver

public java.lang.String getReceiver()

setReceiver

public void setReceiver(java.lang.String receiver)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RecursiveBillPath

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RecursiveBillPath

java.lang.Object
    extended by  bb.common.RecursiveBillPath
All Implemented Interfaces:
java.io.Serializable
public class RecursiveBillPath
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
RecursiveBillPath()
RecursiveBillPath(PartPK pk)
Method Summary
void | addPath(java.util.ArrayList<PartBasicInfo> path)
void | addPath(java.util.HashSet<java.util.ArrayList<PartBasicInfo>> paths)
void | clear()
java.util.Iterator<java.util.ArrayList<PartBasicInfo>> | getPaths()
PartPK | getPk()
boolean | isNesedBOM()
void | setPk(PartPK pk)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RecursiveBillPath

public RecursiveBillPath()

RecursiveBillPath

public RecursiveBillPath(PartPK pk)
Method Detail

getPk

public PartPK getPk()

setPk

public void setPk(PartPK pk)

getPaths

public java.util.Iterator<java.util.ArrayList<PartBasicInfo>> getPaths()

addPath

public void addPath(java.util.ArrayList<PartBasicInfo> path)

addPath

public void addPath(java.util.HashSet<java.util.ArrayList<PartBasicInfo>> paths)

clear

public void clear()

isNesedBOM

public boolean isNesedBOM()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RefdocElement

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RefdocElement

java.lang.Object
    extended by  bb.common.RefdocElement
All Implemented Interfaces:
java.io.Serializable
public class RefdocElement
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
RefdocElement()
Method Summary
java.lang.String | getItemNumber()
java.lang.String | getOrderNumber()
java.math.BigDecimal | getQty()
java.lang.String | getRefDocString()
void | setItemNumber(java.lang.String itemNumber)
void | setOrderNumber(java.lang.String orderNumber)
void | setQty(java.math.BigDecimal qty)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RefdocElement

public RefdocElement()
Method Detail

getOrderNumber

public java.lang.String getOrderNumber()

setOrderNumber

public void setOrderNumber(java.lang.String orderNumber)

getItemNumber

public java.lang.String getItemNumber()

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

getRefDocString

public java.lang.String getRefDocString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RefdocVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RefdocVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.RefdocVO
All Implemented Interfaces:
java.io.Serializable
public class RefdocVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
RefdocVO()
default constructor
RefdocVO(java.lang.String forderNumber, java.lang.String fitemNumber, java.lang.String torderNumber, java.lang.String titemNumber, java.math.BigDecimal qty, java.lang.String lastChangeUser, java.util.Date lastChangeDate, java.lang.Integer lastChangeTime, short linkRef)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getFitemNumber()
java.lang.String | getForderNumber()
java.lang.Long | getIi()
java.util.Date | getLastChangeDate()
java.lang.Integer | getLastChangeTime()
java.lang.String | getLastChangeUser()
short | getLinkOrRef()
java.math.BigDecimal | getQty()
java.lang.String | getTitemNumber()
java.lang.String | getTorderNumber()
int | hashCode()
void | setFitemNumber(java.lang.String fitemNumber)
void | setForderNumber(java.lang.String forderNumber)
void | setIi(java.lang.Long ii)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTime(java.lang.Integer lastChangeTime)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLinkOrRef(short linkOrRef)
void | setQty(java.math.BigDecimal qty)
void | setTitemNumber(java.lang.String titemNumber)
void | setTorderNumber(java.lang.String torderNumber)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

RefdocVO

public RefdocVO(java.lang.String forderNumber,
                java.lang.String fitemNumber,
                java.lang.String torderNumber,
                java.lang.String titemNumber,
                java.math.BigDecimal qty,
                java.lang.String lastChangeUser,
                java.util.Date lastChangeDate,
                java.lang.Integer lastChangeTime,
                short linkRef)
full constructor

RefdocVO

public RefdocVO()
default constructor

Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getForderNumber

public java.lang.String getForderNumber()

setForderNumber

public void setForderNumber(java.lang.String forderNumber)

getFitemNumber

public java.lang.String getFitemNumber()

setFitemNumber

public void setFitemNumber(java.lang.String fitemNumber)

getTorderNumber

public java.lang.String getTorderNumber()

setTorderNumber

public void setTorderNumber(java.lang.String torderNumber)

getTitemNumber

public java.lang.String getTitemNumber()

setTitemNumber

public void setTitemNumber(java.lang.String titemNumber)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeTime

public java.lang.Integer getLastChangeTime()

setLastChangeTime

public void setLastChangeTime(java.lang.Integer lastChangeTime)

getLinkOrRef

public short getLinkOrRef()

setLinkOrRef

public void setLinkOrRef(short linkOrRef)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RequestForQuoteCheckListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RequestForQuoteCheckListResult

java.lang.Object
    extended by  bb.common.RequestForQuoteCheckListResult
All Implemented Interfaces:
java.io.Serializable
public class RequestForQuoteCheckListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_BUYER
static java.lang.String | ORDER_BY_DELIVERY
static java.lang.String | ORDER_BY_PROJECT
static java.lang.String | ORDER_BY_RFQDATE
static java.lang.String | ORDER_BY_RFQNUMBER
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_VENDORID
Constructor Summary
RequestForQuoteCheckListResult()
Method Summary
java.math.BigDecimal | getApTotal()
java.lang.String | getBuyer()
java.lang.String | getComments()
java.lang.String | getCurrency()
java.util.Date | getDelivery()
java.lang.String | getProject()
java.util.Date | getRfqDate()
java.lang.String | getRfqNumber()
java.lang.String | getStatus()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
void | setApTotal(java.math.BigDecimal apTotal)
void | setBuyer(java.lang.String buyer)
void | setComments(java.lang.String comments)
void | setCurrency(java.lang.String currency)
void | setDelivery(java.util.Date delivery)
void | setProject(java.lang.String project)
void | setRfqDate(java.util.Date rfqDate)
void | setRfqNumber(java.lang.String rfqNumber)
void | setStatus(java.lang.String status)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_RFQNUMBER

public static final java.lang.String ORDER_BY_RFQNUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_BUYER

public static final java.lang.String ORDER_BY_BUYER
See Also:
Constant Field Values

ORDER_BY_RFQDATE

public static final java.lang.String ORDER_BY_RFQDATE
See Also:
Constant Field Values

ORDER_BY_DELIVERY

public static final java.lang.String ORDER_BY_DELIVERY
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_PROJECT

public static final java.lang.String ORDER_BY_PROJECT
See Also:
Constant Field Values
Constructor Detail

RequestForQuoteCheckListResult

public RequestForQuoteCheckListResult()
Method Detail

getRfqNumber

public java.lang.String getRfqNumber()

getVendorId

public java.lang.String getVendorId()

getBuyer

public java.lang.String getBuyer()

getRfqDate

public java.util.Date getRfqDate()

getDelivery

public java.util.Date getDelivery()

getStatus

public java.lang.String getStatus()

getApTotal

public java.math.BigDecimal getApTotal()

getCurrency

public java.lang.String getCurrency()

getVendorName

public java.lang.String getVendorName()

getProject

public java.lang.String getProject()

getComments

public java.lang.String getComments()

setRfqNumber

public void setRfqNumber(java.lang.String rfqNumber)

setVendorId

public void setVendorId(java.lang.String vendorId)

setBuyer

public void setBuyer(java.lang.String buyer)

setRfqDate

public void setRfqDate(java.util.Date rfqDate)

setDelivery

public void setDelivery(java.util.Date delivery)

setStatus

public void setStatus(java.lang.String status)

setApTotal

public void setApTotal(java.math.BigDecimal apTotal)

setCurrency

public void setCurrency(java.lang.String currency)

setVendorName

public void setVendorName(java.lang.String vendorName)

setProject

public void setProject(java.lang.String project)

setComments

public void setComments(java.lang.String comments)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RequestForQuoteItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RequestForQuoteItemListResult

java.lang.Object
    extended by  bb.common.RequestForQuoteItemListResult
All Implemented Interfaces:
java.io.Serializable
public class RequestForQuoteItemListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_BUYER
static java.lang.String | ORDER_BY_COSTPERUNIT
static java.lang.String | ORDER_BY_DELIVERY
static java.lang.String | ORDER_BY_DISCOUNT
static java.lang.String | ORDER_BY_PARTDESC
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_RFQDATE
static java.lang.String | ORDER_BY_RFQITEMPK
static java.lang.String | ORDER_BY_SUBTOTAL
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_VENDORNAME
Constructor Summary
RequestForQuoteItemListResult()
Method Summary
java.lang.String | getBuyer()
java.lang.String | getComments()
java.math.BigDecimal | getCostPerUnit()
java.util.Date | getDelivery()
java.math.BigDecimal | getDiscount()
java.lang.String | getPartDesc()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.math.BigDecimal | getQty()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.util.Date | getRfqDate()
RequestForQuoteItemPK | getRfqItemPk()
java.lang.String | getStatus()
java.math.BigDecimal | getSubTotal()
java.lang.String | getUnit()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
void | setBuyer(java.lang.String buyer)
void | setComments(java.lang.String comments)
void | setCostPerUnit(java.math.BigDecimal costPerUnit)
void | setDelivery(java.util.Date delivery)
void | setDiscount(java.math.BigDecimal discount)
void | setPartDesc(java.lang.String partDesc)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setQty(java.math.BigDecimal qty)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setRfqDate(java.util.Date rfqDate)
void | setRfqItemPk(RequestForQuoteItemPK rfqItemPk)
void | setStatus(java.lang.String status)
void | setSubTotal(java.math.BigDecimal subTotal)
void | setUnit(java.lang.String unit)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_RFQITEMPK

public static final java.lang.String ORDER_BY_RFQITEMPK
See Also:
Constant Field Values

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_PARTDESC

public static final java.lang.String ORDER_BY_PARTDESC
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_VENDORNAME

public static final java.lang.String ORDER_BY_VENDORNAME
See Also:
Constant Field Values

ORDER_BY_DELIVERY

public static final java.lang.String ORDER_BY_DELIVERY
See Also:
Constant Field Values

ORDER_BY_RFQDATE

public static final java.lang.String ORDER_BY_RFQDATE
See Also:
Constant Field Values

ORDER_BY_BUYER

public static final java.lang.String ORDER_BY_BUYER
See Also:
Constant Field Values

ORDER_BY_COSTPERUNIT

public static final java.lang.String ORDER_BY_COSTPERUNIT
See Also:
Constant Field Values

ORDER_BY_SUBTOTAL

public static final java.lang.String ORDER_BY_SUBTOTAL
See Also:
Constant Field Values

ORDER_BY_DISCOUNT

public static final java.lang.String ORDER_BY_DISCOUNT
See Also:
Constant Field Values
Constructor Detail

RequestForQuoteItemListResult

public RequestForQuoteItemListResult()
Method Detail

getSubTotal

public java.math.BigDecimal getSubTotal()

setSubTotal

public void setSubTotal(java.math.BigDecimal subTotal)

getPartPk

public PartPK getPartPk()

getPartDesc

public java.lang.String getPartDesc()

getQty

public java.math.BigDecimal getQty()

getUnit

public java.lang.String getUnit()

getRfqItemPk

public RequestForQuoteItemPK getRfqItemPk()

getVendorId

public java.lang.String getVendorId()

getVendorName

public java.lang.String getVendorName()

getDelivery

public java.util.Date getDelivery()

getComments

public java.lang.String getComments()

getStatus

public java.lang.String getStatus()

getBuyer

public java.lang.String getBuyer()

getRfqDate

public java.util.Date getRfqDate()

getPartFrom

public java.lang.String getPartFrom()

getRefDoc1

public java.lang.String getRefDoc1()

getRefDoc2

public java.lang.String getRefDoc2()

setPartPk

public void setPartPk(PartPK partPk)

setPartDesc

public void setPartDesc(java.lang.String partDesc)

setQty

public void setQty(java.math.BigDecimal qty)

setUnit

public void setUnit(java.lang.String unit)

setRfqItemPk

public void setRfqItemPk(RequestForQuoteItemPK rfqItemPk)

setVendorId

public void setVendorId(java.lang.String vendorId)

setVendorName

public void setVendorName(java.lang.String vendorName)

setDelivery

public void setDelivery(java.util.Date delivery)

setComments

public void setComments(java.lang.String comments)

setStatus

public void setStatus(java.lang.String status)

setBuyer

public void setBuyer(java.lang.String buyer)

setRfqDate

public void setRfqDate(java.util.Date rfqDate)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getCostPerUnit

public java.math.BigDecimal getCostPerUnit()

setCostPerUnit

public void setCostPerUnit(java.math.BigDecimal costPerUnit)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RequestForQuoteItemManufacturerPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RequestForQuoteItemManufacturerPK

java.lang.Object
    extended by  bb.common.RequestForQuoteItemManufacturerPK
All Implemented Interfaces:
java.io.Serializable
public class RequestForQuoteItemManufacturerPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
RequestForQuoteItemManufacturerPK()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Short | getIi()
java.lang.String | getRequestForQuoteItemNumber()
java.lang.String | getRequestForQuoteNumber()
int | hashCode()
void | setIi(java.lang.Short ii)
void | setRequestForQuoteItemNumber(java.lang.String requestForQuoteItemNumber)
void | setRequestForQuoteNumber(java.lang.String requestForQuoteNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

RequestForQuoteItemManufacturerPK

public RequestForQuoteItemManufacturerPK()
Method Detail

setRequestForQuoteNumber

public void setRequestForQuoteNumber(java.lang.String requestForQuoteNumber)

getRequestForQuoteNumber

public java.lang.String getRequestForQuoteNumber()

setRequestForQuoteItemNumber

public void setRequestForQuoteItemNumber(java.lang.String requestForQuoteItemNumber)

getRequestForQuoteItemNumber

public java.lang.String getRequestForQuoteItemNumber()

setIi

public void setIi(java.lang.Short ii)

getIi

public java.lang.Short getIi()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RequestForQuoteItemManufacturerVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RequestForQuoteItemManufacturerVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.RequestForQuoteItemManufacturerVO
All Implemented Interfaces:
java.io.Serializable
public class RequestForQuoteItemManufacturerVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
RequestForQuoteItemManufacturerVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getManufacturerName()
java.lang.String | getManufacturerPartNumber()
RequestForQuoteItemManufacturerPK | getPk()
int | hashCode()
void | setManufacturerName(java.lang.String manufacturerName)
void | setManufacturerPartNumber(java.lang.String manufacturerPartNumber)
void | setPk(RequestForQuoteItemManufacturerPK pk)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

RequestForQuoteItemManufacturerVO

public RequestForQuoteItemManufacturerVO()
Method Detail

getPk

public RequestForQuoteItemManufacturerPK getPk()

setPk

public void setPk(RequestForQuoteItemManufacturerPK pk)

getManufacturerName

public java.lang.String getManufacturerName()

setManufacturerName

public void setManufacturerName(java.lang.String manufacturerName)

getManufacturerPartNumber

public java.lang.String getManufacturerPartNumber()

setManufacturerPartNumber

public void setManufacturerPartNumber(java.lang.String manufacturerPartNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RequestForQuoteItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RequestForQuoteItemPK

java.lang.Object
    extended by  bb.common.RequestForQuoteItemPK
All Implemented Interfaces:
java.io.Serializable
public class RequestForQuoteItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
RequestForQuoteItemPK()
RequestForQuoteItemPK(java.lang.String requestForQuoteNumber, java.lang.String requestForQuoteItemNumber)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getRequestForQuoteItemNumber()
java.lang.String | getRequestForQuoteNumber()
int | hashCode()
void | setRequestForQuoteItemNumber(java.lang.String requestForQuoteItemNumber)
void | setRequestForQuoteNumber(java.lang.String requestForQuoteNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

RequestForQuoteItemPK

public RequestForQuoteItemPK()

RequestForQuoteItemPK

public RequestForQuoteItemPK(java.lang.String requestForQuoteNumber,
                             java.lang.String requestForQuoteItemNumber)
Method Detail

setRequestForQuoteNumber

public void setRequestForQuoteNumber(java.lang.String requestForQuoteNumber)

getRequestForQuoteNumber

public java.lang.String getRequestForQuoteNumber()

setRequestForQuoteItemNumber

public void setRequestForQuoteItemNumber(java.lang.String requestForQuoteItemNumber)

getRequestForQuoteItemNumber

public java.lang.String getRequestForQuoteItemNumber()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RequestForQuoteItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RequestForQuoteItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.RequestForQuoteItemVO
All Implemented Interfaces:
java.io.Serializable
public class RequestForQuoteItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
RequestForQuoteItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getActual()
java.math.BigDecimal | getApDiscount()
java.math.BigDecimal | getApOpen()
java.math.BigDecimal | getApReceived()
java.math.BigDecimal | getApSub()
java.math.BigDecimal | getApTax()
java.math.BigDecimal | getApTotal()
java.lang.String | getCompany()
java.math.BigDecimal | getCostPerUnit()
java.util.Date | getDateRequired()
int | getDelay()
java.lang.String | getDescription()
java.math.BigDecimal | getDiscount()
java.lang.String | getDwg()
java.math.BigDecimal | getExtentPrice()
java.math.BigDecimal | getFreight()
java.math.BigDecimal | getHqa()
int | getLeadTime()
java.lang.String | getLocation()
java.lang.String | getMfg()
java.lang.String | getModelNumber()
java.lang.String | getMpn()
java.util.Date | getOriginal()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
RequestForQuoteItemPK | getPk()
java.lang.String | getPriority()
java.lang.String | getQr()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getReceivedQuantity()
java.lang.String | getReferenceDoc1()
java.lang.String | getReferenceDoc2()
java.util.Set | getRequestForQuoteItemManufacturer()
java.lang.String | getRevision()
java.lang.String | getRfqItemComments()
java.lang.String | getRfqItemPrivateNotes()
java.math.BigDecimal | getShipQuantity()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.math.BigDecimal | getTaxRate()
java.lang.String | getUnit()
int | hashCode()
void | setActual(java.util.Date actual)
void | setApDiscount(java.math.BigDecimal apDiscount)
void | setApOpen(java.math.BigDecimal apOpen)
void | setApReceived(java.math.BigDecimal apReceived)
void | setApSub(java.math.BigDecimal apSub)
void | setApTax(java.math.BigDecimal apTax)
void | setApTotal(java.math.BigDecimal apTotal)
void | setCompany(java.lang.String company)
void | setCostPerUnit(java.math.BigDecimal costPerUnit)
void | setDateRequired(java.util.Date dateRequired)
void | setDelay(int delay)
void | setDescription(java.lang.String description)
void | setDiscount(java.math.BigDecimal discount)
void | setDwg(java.lang.String dwg)
void | setExtentPrice(java.math.BigDecimal extentPrice)
void | setFreight(java.math.BigDecimal freight)
void | setHqa(java.math.BigDecimal hqa)
void | setLeadTime(int leadTime)
void | setLocation(java.lang.String location)
void | setMfg(java.lang.String mfg)
void | setModelNumber(java.lang.String modelNumber)
void | setMpn(java.lang.String mpn)
void | setOriginal(java.util.Date original)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(RequestForQuoteItemPK pk)
void | setPriority(java.lang.String priority)
void | setQr(java.lang.String qr)
void | setQuantity(java.math.BigDecimal quantity)
void | setReceivedQuantity(java.math.BigDecimal receivedQuantity)
void | setReferenceDoc1(java.lang.String referenceDoc1)
void | setReferenceDoc2(java.lang.String referenceDoc2)
void | setRequestForQuoteItemManufacturer(java.util.Set requestForQuoteItemManufacturer)
void | setRevision(java.lang.String revision)
void | setRfqItemComments(java.lang.String rfqItemComments)
void | setRfqItemPrivateNotes(java.lang.String rfqItemPrivateNotes)
void | setShipQuantity(java.math.BigDecimal shipQuantity)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setUnit(java.lang.String unit)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

RequestForQuoteItemVO

public RequestForQuoteItemVO()
Method Detail

getPk

public RequestForQuoteItemPK getPk()

setPk

public void setPk(RequestForQuoteItemPK pk)

getApSub

public java.math.BigDecimal getApSub()

setApSub

public void setApSub(java.math.BigDecimal apSub)

getApDiscount

public java.math.BigDecimal getApDiscount()

setApDiscount

public void setApDiscount(java.math.BigDecimal apDiscount)

getExtentPrice

public java.math.BigDecimal getExtentPrice()

setExtentPrice

public void setExtentPrice(java.math.BigDecimal extentPrice)

getApReceived

public java.math.BigDecimal getApReceived()

setApReceived

public void setApReceived(java.math.BigDecimal apReceived)

getApOpen

public java.math.BigDecimal getApOpen()

setApOpen

public void setApOpen(java.math.BigDecimal apOpen)

getApTax

public java.math.BigDecimal getApTax()

setApTax

public void setApTax(java.math.BigDecimal apTax)

getApTotal

public java.math.BigDecimal getApTotal()

setApTotal

public void setApTotal(java.math.BigDecimal apTotal)

getReferenceDoc1

public java.lang.String getReferenceDoc1()

setReferenceDoc1

public void setReferenceDoc1(java.lang.String referenceDoc1)

getReferenceDoc2

public java.lang.String getReferenceDoc2()

setReferenceDoc2

public void setReferenceDoc2(java.lang.String referenceDoc2)

getCompany

public java.lang.String getCompany()

setCompany

public void setCompany(java.lang.String company)

getQr

public java.lang.String getQr()

setQr

public void setQr(java.lang.String qr)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getLeadTime

public int getLeadTime()

setLeadTime

public void setLeadTime(int leadTime)

getDateRequired

public java.util.Date getDateRequired()

setDateRequired

public void setDateRequired(java.util.Date dateRequired)

getDelay

public int getDelay()

setDelay

public void setDelay(int delay)

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getOriginal

public java.util.Date getOriginal()

setOriginal

public void setOriginal(java.util.Date original)

getActual

public java.util.Date getActual()

setActual

public void setActual(java.util.Date actual)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getFreight

public java.math.BigDecimal getFreight()

setFreight

public void setFreight(java.math.BigDecimal freight)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getDwg

public java.lang.String getDwg()

setDwg

public void setDwg(java.lang.String dwg)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getShipQuantity

public java.math.BigDecimal getShipQuantity()

setShipQuantity

public void setShipQuantity(java.math.BigDecimal shipQuantity)

getReceivedQuantity

public java.math.BigDecimal getReceivedQuantity()

setReceivedQuantity

public void setReceivedQuantity(java.math.BigDecimal receivedQuantity)

getHqa

public java.math.BigDecimal getHqa()

setHqa

public void setHqa(java.math.BigDecimal hqa)

getCostPerUnit

public java.math.BigDecimal getCostPerUnit()

setCostPerUnit

public void setCostPerUnit(java.math.BigDecimal costPerUnit)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getRfqItemComments

public java.lang.String getRfqItemComments()

setRfqItemComments

public void setRfqItemComments(java.lang.String rfqItemComments)

getRfqItemPrivateNotes

public java.lang.String getRfqItemPrivateNotes()

setRfqItemPrivateNotes

public void setRfqItemPrivateNotes(java.lang.String rfqItemPrivateNotes)

getRequestForQuoteItemManufacturer

public java.util.Set getRequestForQuoteItemManufacturer()

setRequestForQuoteItemManufacturer

public void setRequestForQuoteItemManufacturer(java.util.Set requestForQuoteItemManufacturer)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RequestForQuoteListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RequestForQuoteListResult

java.lang.Object
    extended by  bb.common.RequestForQuoteListResult
All Implemented Interfaces:
java.io.Serializable
public class RequestForQuoteListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_BUYER
static java.lang.String | ORDER_BY_DELIVERY
static java.lang.String | ORDER_BY_PROJECT
static java.lang.String | ORDER_BY_RFQDATE
static java.lang.String | ORDER_BY_RFQNUMBER
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_VENDORID
Constructor Summary
RequestForQuoteListResult()
Method Summary
java.lang.String | getBuyer()
java.lang.String | getChangeOrder()
java.lang.String | getComments()
java.util.Date | getDelivery()
java.lang.String | getProject()
java.util.Date | getRespondDate()
java.util.Date | getRfqDate()
java.lang.String | getRfqNumber()
java.lang.String | getStatus()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
void | setBuyer(java.lang.String buyer)
void | setChangeOrder(java.lang.String changeOrder)
void | setComments(java.lang.String comments)
void | setDelivery(java.util.Date delivery)
void | setProject(java.lang.String project)
void | setRespondDate(java.util.Date respondDate)
void | setRfqDate(java.util.Date rfqDate)
void | setRfqNumber(java.lang.String rfqNumber)
void | setStatus(java.lang.String status)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_RFQNUMBER

public static final java.lang.String ORDER_BY_RFQNUMBER
See Also:
Constant Field Values

ORDER_BY_RFQDATE

public static final java.lang.String ORDER_BY_RFQDATE
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_DELIVERY

public static final java.lang.String ORDER_BY_DELIVERY
See Also:
Constant Field Values

ORDER_BY_BUYER

public static final java.lang.String ORDER_BY_BUYER
See Also:
Constant Field Values

ORDER_BY_PROJECT

public static final java.lang.String ORDER_BY_PROJECT
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values
Constructor Detail

RequestForQuoteListResult

public RequestForQuoteListResult()
Method Detail

setRfqNumber

public void setRfqNumber(java.lang.String rfqNumber)

setRfqDate

public void setRfqDate(java.util.Date rfqDate)

setVendorId

public void setVendorId(java.lang.String vendorId)

setVendorName

public void setVendorName(java.lang.String vendorName)

setDelivery

public void setDelivery(java.util.Date delivery)

setRespondDate

public void setRespondDate(java.util.Date respondDate)

setBuyer

public void setBuyer(java.lang.String buyer)

setProject

public void setProject(java.lang.String project)

setComments

public void setComments(java.lang.String comments)

setStatus

public void setStatus(java.lang.String status)

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getRfqNumber

public java.lang.String getRfqNumber()

getRfqDate

public java.util.Date getRfqDate()

getVendorId

public java.lang.String getVendorId()

getVendorName

public java.lang.String getVendorName()

getDelivery

public java.util.Date getDelivery()

getRespondDate

public java.util.Date getRespondDate()

getBuyer

public java.lang.String getBuyer()

getProject

public java.lang.String getProject()

getComments

public java.lang.String getComments()

getStatus

public java.lang.String getStatus()

getChangeOrder

public java.lang.String getChangeOrder()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RequestForQuoteVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RequestForQuoteVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.RequestForQuoteVO
All Implemented Interfaces:
java.io.Serializable
public class RequestForQuoteVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
RequestForQuoteVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getActual()
java.util.Date | getAdate()
java.math.BigDecimal | getApDiscount()
java.math.BigDecimal | getApNet()
java.math.BigDecimal | getApOpen()
java.lang.String | getApprovedBy()
java.util.Date | getApprovedDate()
java.math.BigDecimal | getApReceived()
CustomerVendorAddressInfoVO | getBillToAddressInfo()
java.lang.String | getBillToId()
java.lang.String | getBp()
java.lang.String | getBuyer()
java.lang.String | getCarrier()
java.lang.String | getCarrierAcct()
java.lang.String | getChangeOrder()
java.lang.String | getCoComments()
java.lang.String | getCompanyUnitId()
java.lang.String | getContact()
java.lang.String | getCurrency()
java.lang.String | getDebitAccount()
byte | getDelay()
java.util.Date | getDelivery()
java.math.BigDecimal | getGrantTotal()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
int | getLastChangeTimes()
java.lang.String | getLastChangeUser()
java.lang.String | getLocation()
java.util.Date | getOriginal()
java.util.Date | getPleaseRespondBy()
java.lang.String | getPriority()
java.lang.String | getProjectName()
java.lang.String | getRelatedDoc()
java.lang.String | getRequester()
java.util.Set | getRequestForQuoteItem()
java.lang.String | getRequestForQuoteNumber()
java.lang.String | getRfqComments()
java.util.Date | getRfqDate()
java.lang.String | getRfqPrivateNotes()
java.lang.String | getSalesOrderNumber()
java.lang.String | getShipAccount()
CustomerVendorAddressInfoVO | getShipToAddressInfo()
java.lang.String | getShipToId()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.math.BigDecimal | getSubTotal()
java.lang.String | getTaxRate()
java.lang.String | getTerms()
java.math.BigDecimal | getTotalFreight()
java.math.BigDecimal | getTotalTax()
CustomerVendorAddressInfoVO | getVendorAddressInfo()
java.lang.String | getVendorId()
int | hashCode()
void | setActual(java.util.Date actual)
void | setAdate(java.util.Date adate)
void | setApDiscount(java.math.BigDecimal apDiscount)
void | setApNet(java.math.BigDecimal apNet)
void | setApOpen(java.math.BigDecimal apOpen)
void | setApprovedBy(java.lang.String approvedBy)
void | setApprovedDate(java.util.Date approvedDate)
void | setApReceived(java.math.BigDecimal apReceived)
void | setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | setBillToId(java.lang.String billToId)
void | setBp(java.lang.String bp)
void | setBuyer(java.lang.String buyer)
void | setCarrier(java.lang.String carrier)
void | setCarrierAcct(java.lang.String carrierAcct)
void | setChangeOrder(java.lang.String changeOrder)
void | setCoComments(java.lang.String coComments)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setContact(java.lang.String contact)
void | setCurrency(java.lang.String currency)
void | setDebitAccount(java.lang.String debitAccount)
void | setDelay(byte delay)
void | setDelivery(java.util.Date delivery)
void | setGrantTotal(java.math.BigDecimal grantTotal)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTimes(int lastChangeTimes)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLocation(java.lang.String location)
void | setOriginal(java.util.Date original)
void | setPleaseRespondBy(java.util.Date pleaseRespondBy)
void | setPriority(java.lang.String priority)
void | setProjectName(java.lang.String projectName)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setRequester(java.lang.String requester)
void | setRequestForQuoteItem(java.util.Set requestForQuoteItem)
void | setRequestForQuoteNumber(java.lang.String requestForQuoteNumber)
void | setRfqComments(java.lang.String rfqComments)
void | setRfqDate(java.util.Date rfqDate)
void | setRfqPrivateNotes(java.lang.String rfqPrivateNotes)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setShipAccount(java.lang.String shipAccount)
void | setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | setShipToId(java.lang.String shipToId)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setSubTotal(java.math.BigDecimal subTotal)
void | setTaxRate(java.lang.String taxRate)
void | setTerms(java.lang.String terms)
void | setTotalFreight(java.math.BigDecimal totalFreight)
void | setTotalTax(java.math.BigDecimal totalTax)
void | setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)
void | setVendorId(java.lang.String vendorId)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

RequestForQuoteVO

public RequestForQuoteVO()
Method Detail

getRequestForQuoteNumber

public java.lang.String getRequestForQuoteNumber()

setRequestForQuoteNumber

public void setRequestForQuoteNumber(java.lang.String requestForQuoteNumber)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getSubTotal

public java.math.BigDecimal getSubTotal()

setSubTotal

public void setSubTotal(java.math.BigDecimal subTotal)

getApDiscount

public java.math.BigDecimal getApDiscount()

setApDiscount

public void setApDiscount(java.math.BigDecimal apDiscount)

getApNet

public java.math.BigDecimal getApNet()

setApNet

public void setApNet(java.math.BigDecimal apNet)

getApReceived

public java.math.BigDecimal getApReceived()

setApReceived

public void setApReceived(java.math.BigDecimal apReceived)

getApOpen

public java.math.BigDecimal getApOpen()

setApOpen

public void setApOpen(java.math.BigDecimal apOpen)

getTotalTax

public java.math.BigDecimal getTotalTax()

setTotalTax

public void setTotalTax(java.math.BigDecimal totalTax)

getTotalFreight

public java.math.BigDecimal getTotalFreight()

setTotalFreight

public void setTotalFreight(java.math.BigDecimal totalFreight)

getGrantTotal

public java.math.BigDecimal getGrantTotal()

setGrantTotal

public void setGrantTotal(java.math.BigDecimal grantTotal)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getPleaseRespondBy

public java.util.Date getPleaseRespondBy()

setPleaseRespondBy

public void setPleaseRespondBy(java.util.Date pleaseRespondBy)

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getDelivery

public java.util.Date getDelivery()

setDelivery

public void setDelivery(java.util.Date delivery)

getDelay

public byte getDelay()

setDelay

public void setDelay(byte delay)

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getOriginal

public java.util.Date getOriginal()

setOriginal

public void setOriginal(java.util.Date original)

getActual

public java.util.Date getActual()

setActual

public void setActual(java.util.Date actual)

getShipToId

public java.lang.String getShipToId()

setShipToId

public void setShipToId(java.lang.String shipToId)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAcct

public java.lang.String getCarrierAcct()

setCarrierAcct

public void setCarrierAcct(java.lang.String carrierAcct)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getShipAccount

public java.lang.String getShipAccount()

setShipAccount

public void setShipAccount(java.lang.String shipAccount)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getRfqDate

public java.util.Date getRfqDate()

setRfqDate

public void setRfqDate(java.util.Date rfqDate)

getBuyer

public java.lang.String getBuyer()

setBuyer

public void setBuyer(java.lang.String buyer)

getRequester

public java.lang.String getRequester()

setRequester

public void setRequester(java.lang.String requester)

getProjectName

public java.lang.String getProjectName()

setProjectName

public void setProjectName(java.lang.String projectName)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getDebitAccount

public java.lang.String getDebitAccount()

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

getTaxRate

public java.lang.String getTaxRate()

setTaxRate

public void setTaxRate(java.lang.String taxRate)

getRfqComments

public java.lang.String getRfqComments()

setRfqComments

public void setRfqComments(java.lang.String rfqComments)

getBp

public java.lang.String getBp()

setBp

public void setBp(java.lang.String bp)

getRfqPrivateNotes

public java.lang.String getRfqPrivateNotes()

setRfqPrivateNotes

public void setRfqPrivateNotes(java.lang.String rfqPrivateNotes)

getApprovedDate

public java.util.Date getApprovedDate()

setApprovedDate

public void setApprovedDate(java.util.Date approvedDate)

getApprovedBy

public java.lang.String getApprovedBy()

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)

getBillToId

public java.lang.String getBillToId()

setBillToId

public void setBillToId(java.lang.String billToId)

getLastChangeTimes

public int getLastChangeTimes()

setLastChangeTimes

public void setLastChangeTimes(int lastChangeTimes)

getVendorAddressInfo

public CustomerVendorAddressInfoVO getVendorAddressInfo()

setVendorAddressInfo

public void setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)

getShipToAddressInfo

public CustomerVendorAddressInfoVO getShipToAddressInfo()

setShipToAddressInfo

public void setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)

getBillToAddressInfo

public CustomerVendorAddressInfoVO getBillToAddressInfo()

setBillToAddressInfo

public void setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)

getRequestForQuoteItem

public java.util.Set getRequestForQuoteItem()

getCoComments

public java.lang.String getCoComments()

setRequestForQuoteItem

public void setRequestForQuoteItem(java.util.Set requestForQuoteItem)

setCoComments

public void setCoComments(java.lang.String coComments)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RequestForRMAItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RequestForRMAItemPK

java.lang.Object
    extended by  bb.common.RequestForRMAItemPK
All Implemented Interfaces:
java.io.Serializable
public class RequestForRMAItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
RequestForRMAItemPK()
RequestForRMAItemPK(java.lang.String rrmaNumber, java.lang.String rrmaItemNumber)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getRrmaItemNumber()
java.lang.String | getRrmaNumber()
int | hashCode()
void | setRrmaItemNumber(java.lang.String rrmaItemNumber)
void | setRrmaNumber(java.lang.String rrmaNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

RequestForRMAItemPK

public RequestForRMAItemPK(java.lang.String rrmaNumber,
                           java.lang.String rrmaItemNumber)

RequestForRMAItemPK

public RequestForRMAItemPK()
Method Detail

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getRrmaNumber

public java.lang.String getRrmaNumber()

setRrmaNumber

public void setRrmaNumber(java.lang.String rrmaNumber)

getRrmaItemNumber

public java.lang.String getRrmaItemNumber()

setRrmaItemNumber

public void setRrmaItemNumber(java.lang.String rrmaItemNumber)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RequestForRMAItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RequestForRMAItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.RequestForRMAItemVO
All Implemented Interfaces:
java.io.Serializable
public class RequestForRMAItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
RequestForRMAItemVO()
default constructor
RequestForRMAItemVO(RequestForRMAItemPK pk, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom)
minimal constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAccepted()
java.lang.String | getAcceptedBy()
java.util.Date | getActual()
java.math.BigDecimal | getApDiscount()
java.math.BigDecimal | getApOpen()
java.math.BigDecimal | getApReceivd()
java.math.BigDecimal | getApSub()
java.math.BigDecimal | getApTax()
java.math.BigDecimal | getApTotal()
java.lang.String | getChangeMfg()
java.lang.String | getChangeOrder()
java.math.BigDecimal | getCostPerUnit()
java.math.BigDecimal | getCurrentCost()
java.math.BigDecimal | getCurrentStdCost()
int | getDelay()
java.util.Date | getDelivery()
java.lang.String | getDescription()
java.math.BigDecimal | getDiscount()
java.lang.String | getDwg()
java.math.BigDecimal | getExtendPrice()
java.lang.String | getLocate()
java.lang.String | getMfg()
java.lang.String | getModelNumber()
java.lang.String | getMpn()
java.util.Date | getOriginal()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
RequestForRMAItemPK | getPk()
java.lang.String | getPriority()
java.lang.String | getQr()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getReceivedQuantity()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.util.Set | getReturnMaterialAuthorizationItemManufacturer()
java.lang.String | getRevision()
java.lang.String | getRrmaItemComments()
java.lang.String | getRrmaItemPrivateNotes()
java.math.BigDecimal | getSalesCost()
java.math.BigDecimal | getSalesPrice()
java.math.BigDecimal | getSalesQty()
java.math.BigDecimal | getSalesStdCost()
java.lang.String | getSalesUnit()
java.math.BigDecimal | getShip()
java.lang.String | getShipvia()
java.lang.String | getStatus()
java.math.BigDecimal | getTaxRate()
java.lang.String | getUnit()
int | hashCode()
void | setAccepted(java.util.Date accepted)
void | setAcceptedBy(java.lang.String acceptedBy)
void | setActual(java.util.Date actual)
void | setApDiscount(java.math.BigDecimal apDiscount)
void | setApOpen(java.math.BigDecimal apOpen)
void | setApReceivd(java.math.BigDecimal apReceivd)
void | setApSub(java.math.BigDecimal apSub)
void | setApTax(java.math.BigDecimal apTax)
void | setApTotal(java.math.BigDecimal apTotal)
void | setChangeMfg(java.lang.String changeMfg)
void | setChangeOrder(java.lang.String changeOrder)
void | setCostPerUnit(java.math.BigDecimal costPerUnit)
void | setCurrentCost(java.math.BigDecimal currentCost)
void | setCurrentStdCost(java.math.BigDecimal currentStdCost)
void | setDelay(int delay)
void | setDelivery(java.util.Date delivery)
void | setDescription(java.lang.String description)
void | setDiscount(java.math.BigDecimal discount)
void | setDwg(java.lang.String dwg)
void | setExtendPrice(java.math.BigDecimal extendPrice)
void | setLocate(java.lang.String locate)
void | setMfg(java.lang.String mfg)
void | setModelNumber(java.lang.String modelNumber)
void | setMpn(java.lang.String mpn)
void | setOriginal(java.util.Date original)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(RequestForRMAItemPK pk)
void | setPriority(java.lang.String priority)
void | setQr(java.lang.String qr)
void | setQuantity(java.math.BigDecimal quantity)
void | setReceivedQuantity(java.math.BigDecimal receivedQuantity)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setReturnMaterialAuthorizationItemManufacturer(java.util.Set returnMaterialAuthorizationItemManufacturer)
void | setRevision(java.lang.String revision)
void | setRrmaItemComments(java.lang.String rrmaItemComments)
void | setRrmaItemPrivateNotes(java.lang.String rrmaItemPrivateNotes)
void | setSalesCost(java.math.BigDecimal salesCost)
void | setSalesPrice(java.math.BigDecimal salesPrice)
void | setSalesQty(java.math.BigDecimal salesQty)
void | setSalesStdCost(java.math.BigDecimal salesStdCost)
void | setSalesUnit(java.lang.String salesUnit)
void | setShip(java.math.BigDecimal ship)
void | setShipvia(java.lang.String shipvia)
void | setStatus(java.lang.String status)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setUnit(java.lang.String unit)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

RequestForRMAItemVO

public RequestForRMAItemVO()
default constructor

RequestForRMAItemVO

public RequestForRMAItemVO(RequestForRMAItemPK pk,
                           java.lang.String partNumber,
                           java.lang.String partType,
                           java.lang.String partFrom)
minimal constructor

Method Detail

getPk

public RequestForRMAItemPK getPk()

setPk

public void setPk(RequestForRMAItemPK pk)

getApSub

public java.math.BigDecimal getApSub()

setApSub

public void setApSub(java.math.BigDecimal apSub)

getApDiscount

public java.math.BigDecimal getApDiscount()

setApDiscount

public void setApDiscount(java.math.BigDecimal apDiscount)

getExtendPrice

public java.math.BigDecimal getExtendPrice()

setExtendPrice

public void setExtendPrice(java.math.BigDecimal extendPrice)

getApReceivd

public java.math.BigDecimal getApReceivd()

setApReceivd

public void setApReceivd(java.math.BigDecimal apReceivd)

getApOpen

public java.math.BigDecimal getApOpen()

setApOpen

public void setApOpen(java.math.BigDecimal apOpen)

getApTax

public java.math.BigDecimal getApTax()

setApTax

public void setApTax(java.math.BigDecimal apTax)

getApTotal

public java.math.BigDecimal getApTotal()

setApTotal

public void setApTotal(java.math.BigDecimal apTotal)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getQr

public java.lang.String getQr()

setQr

public void setQr(java.lang.String qr)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getAccepted

public java.util.Date getAccepted()

setAccepted

public void setAccepted(java.util.Date accepted)

getAcceptedBy

public java.lang.String getAcceptedBy()

setAcceptedBy

public void setAcceptedBy(java.lang.String acceptedBy)

getDelivery

public java.util.Date getDelivery()

setDelivery

public void setDelivery(java.util.Date delivery)

getDelay

public int getDelay()

setDelay

public void setDelay(int delay)

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getOriginal

public java.util.Date getOriginal()

setOriginal

public void setOriginal(java.util.Date original)

getActual

public java.util.Date getActual()

setActual

public void setActual(java.util.Date actual)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getShipvia

public java.lang.String getShipvia()

setShipvia

public void setShipvia(java.lang.String shipvia)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getDwg

public java.lang.String getDwg()

setDwg

public void setDwg(java.lang.String dwg)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getShip

public java.math.BigDecimal getShip()

setShip

public void setShip(java.math.BigDecimal ship)

getReceivedQuantity

public java.math.BigDecimal getReceivedQuantity()

setReceivedQuantity

public void setReceivedQuantity(java.math.BigDecimal receivedQuantity)

getCostPerUnit

public java.math.BigDecimal getCostPerUnit()

setCostPerUnit

public void setCostPerUnit(java.math.BigDecimal costPerUnit)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getChangeMfg

public java.lang.String getChangeMfg()

setChangeMfg

public void setChangeMfg(java.lang.String changeMfg)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getRrmaItemComments

public java.lang.String getRrmaItemComments()

setRrmaItemComments

public void setRrmaItemComments(java.lang.String rrmaItemComments)

getRrmaItemPrivateNotes

public java.lang.String getRrmaItemPrivateNotes()

setRrmaItemPrivateNotes

public void setRrmaItemPrivateNotes(java.lang.String rrmaItemPrivateNotes)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getSalesCost

public java.math.BigDecimal getSalesCost()

setSalesCost

public void setSalesCost(java.math.BigDecimal salesCost)

getCurrentCost

public java.math.BigDecimal getCurrentCost()

setCurrentCost

public void setCurrentCost(java.math.BigDecimal currentCost)

getCurrentStdCost

public java.math.BigDecimal getCurrentStdCost()

setCurrentStdCost

public void setCurrentStdCost(java.math.BigDecimal currentStdCost)

getSalesStdCost

public java.math.BigDecimal getSalesStdCost()

setSalesStdCost

public void setSalesStdCost(java.math.BigDecimal salesStdCost)

getReturnMaterialAuthorizationItemManufacturer

public java.util.Set getReturnMaterialAuthorizationItemManufacturer()

setReturnMaterialAuthorizationItemManufacturer

public void setReturnMaterialAuthorizationItemManufacturer(java.util.Set returnMaterialAuthorizationItemManufacturer)

getSalesPrice

public java.math.BigDecimal getSalesPrice()

setSalesPrice

public void setSalesPrice(java.math.BigDecimal salesPrice)

getSalesQty

public java.math.BigDecimal getSalesQty()

setSalesQty

public void setSalesQty(java.math.BigDecimal salesQty)

getSalesUnit

public java.lang.String getSalesUnit()

setSalesUnit

public void setSalesUnit(java.lang.String salesUnit)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RequestForRMAVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RequestForRMAVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.RequestForRMAVO
All Implemented Interfaces:
java.io.Serializable
public class RequestForRMAVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
RequestForRMAVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getActual()
java.util.Date | getAdate()
java.math.BigDecimal | getApGl1Recorded()
java.math.BigDecimal | getApGl2Paid()
java.lang.String | getApNetSet()
java.math.BigDecimal | getApOpen()
java.math.BigDecimal | getApPaidGl()
java.math.BigDecimal | getApPaidReceived()
java.lang.String | getApprovedBy()
java.util.Date | getApprovedTime()
java.math.BigDecimal | getApReceived()
java.math.BigDecimal | getApSub()
java.lang.String | getApTaxSet()
CustomerVendorAddressInfoVO | getBillToAddressInfo()
java.lang.String | getBillToId()
java.lang.String | getBp()
java.lang.String | getCarrier()
java.lang.String | getCarrierAcct()
java.lang.String | getChangeOrder()
java.lang.String | getCoComments()
java.lang.String | getComments()
java.lang.String | getCompanyUnitId()
java.lang.String | getContact()
java.lang.String | getCurrency()
CustomerVendorAddressInfoVO | getCustomerAddressInfo()
java.lang.String | getCustomerId()
java.lang.String | getDebitAccount()
byte | getDelay()
java.util.Date | getDelivery()
java.math.BigDecimal | getExchange()
java.math.BigDecimal | getGrantTotal()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getInvoiceNumber()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getLocate()
java.lang.String | getOrigin()
java.util.Date | getOriginal()
java.lang.String | getPriority()
java.lang.String | getPrivateNotes()
java.lang.String | getProjectName()
java.lang.String | getRelatedDoc()
java.lang.String | getRequester()
java.lang.String | getRmaNumber()
java.util.Date | getRrmaDate()
java.util.Set<RequestForRMAItemVO> | getRrmaItem()
java.lang.String | getRrmaNumber()
java.lang.String | getSalesCodeId()
java.lang.String | getSalesman()
java.lang.String | getSalesOrderNumber()
CustomerVendorAddressInfoVO | getShipToAddressInfo()
java.lang.String | getShipToId()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.math.BigDecimal | getSubTotal()
java.lang.String | getTerms()
java.math.BigDecimal | getTotalDiscount()
java.math.BigDecimal | getTotalFreight()
java.math.BigDecimal | getTotalTax()
java.lang.Integer | getVersion()
int | hashCode()
void | setActual(java.util.Date actual)
void | setAdate(java.util.Date adate)
void | setApGl1Recorded(java.math.BigDecimal apGl1Recorded)
void | setApGl2Paid(java.math.BigDecimal apGl2Paid)
void | setApNetSet(java.lang.String apNetSet)
void | setApOpen(java.math.BigDecimal apOpen)
void | setApPaidGl(java.math.BigDecimal apPaidGl)
void | setApPaidReceived(java.math.BigDecimal apPaidReceived)
void | setApprovedBy(java.lang.String approvedBy)
void | setApprovedTime(java.util.Date approvedTime)
void | setApReceived(java.math.BigDecimal apReceived)
void | setApSub(java.math.BigDecimal apSub)
void | setApTaxSet(java.lang.String apTaxSet)
void | setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | setBillToId(java.lang.String billToId)
void | setBp(java.lang.String bp)
void | setCarrier(java.lang.String carrier)
void | setCarrierAcct(java.lang.String carrierAcct)
void | setChangeOrder(java.lang.String changeOrder)
void | setCoComments(java.lang.String coComments)
void | setComments(java.lang.String comments)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setContact(java.lang.String contact)
void | setCurrency(java.lang.String currency)
void | setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | setCustomerId(java.lang.String customerId)
void | setDebitAccount(java.lang.String debitAccount)
void | setDelay(byte delay)
void | setDelivery(java.util.Date delivery)
void | setExchange(java.math.BigDecimal exchange)
void | setGrantTotal(java.math.BigDecimal grantTotal)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setInvoiceNumber(java.lang.String invoiceNumber)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLocate(java.lang.String locate)
void | setOrigin(java.lang.String origin)
void | setOriginal(java.util.Date original)
void | setPriority(java.lang.String priority)
void | setPrivateNotes(java.lang.String privateNotes)
void | setProjectName(java.lang.String projectName)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setRequester(java.lang.String requester)
void | setRmaNumber(java.lang.String rmaNumber)
void | setRrmaDate(java.util.Date rrmaDate)
void | setRrmaItem(java.util.Set<RequestForRMAItemVO> rrmaItem)
void | setRrmaNumber(java.lang.String rrmaNumber)
void | setSalesCodeId(java.lang.String salesCodeId)
void | setSalesman(java.lang.String salesman)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | setShipToId(java.lang.String shipToId)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setSubTotal(java.math.BigDecimal subTotal)
void | setTerms(java.lang.String terms)
void | setTotalDiscount(java.math.BigDecimal totalDiscount)
void | setTotalFreight(java.math.BigDecimal totalFreight)
void | setTotalTax(java.math.BigDecimal totalTax)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

RequestForRMAVO

public RequestForRMAVO()
Method Detail

getRrmaNumber

public java.lang.String getRrmaNumber()

setRrmaNumber

public void setRrmaNumber(java.lang.String rrmaNumber)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getApNetSet

public java.lang.String getApNetSet()

setApNetSet

public void setApNetSet(java.lang.String apNetSet)

getApTaxSet

public java.lang.String getApTaxSet()

setApTaxSet

public void setApTaxSet(java.lang.String apTaxSet)

getSubTotal

public java.math.BigDecimal getSubTotal()

setSubTotal

public void setSubTotal(java.math.BigDecimal subTotal)

getTotalDiscount

public java.math.BigDecimal getTotalDiscount()

setTotalDiscount

public void setTotalDiscount(java.math.BigDecimal totalDiscount)

getApReceived

public java.math.BigDecimal getApReceived()

setApReceived

public void setApReceived(java.math.BigDecimal apReceived)

getApOpen

public java.math.BigDecimal getApOpen()

setApOpen

public void setApOpen(java.math.BigDecimal apOpen)

getTotalTax

public java.math.BigDecimal getTotalTax()

setTotalTax

public void setTotalTax(java.math.BigDecimal totalTax)

getTotalFreight

public java.math.BigDecimal getTotalFreight()

setTotalFreight

public void setTotalFreight(java.math.BigDecimal totalFreight)

getGrantTotal

public java.math.BigDecimal getGrantTotal()

setGrantTotal

public void setGrantTotal(java.math.BigDecimal grantTotal)

getApPaidReceived

public java.math.BigDecimal getApPaidReceived()

setApPaidReceived

public void setApPaidReceived(java.math.BigDecimal apPaidReceived)

getApPaidGl

public java.math.BigDecimal getApPaidGl()

setApPaidGl

public void setApPaidGl(java.math.BigDecimal apPaidGl)

getApGl1Recorded

public java.math.BigDecimal getApGl1Recorded()

setApGl1Recorded

public void setApGl1Recorded(java.math.BigDecimal apGl1Recorded)

getApGl2Paid

public java.math.BigDecimal getApGl2Paid()

setApGl2Paid

public void setApGl2Paid(java.math.BigDecimal apGl2Paid)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getBillToId

public java.lang.String getBillToId()

setBillToId

public void setBillToId(java.lang.String billToId)

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getApprovedTime

public java.util.Date getApprovedTime()

setApprovedTime

public void setApprovedTime(java.util.Date approvedTime)

getApprovedBy

public java.lang.String getApprovedBy()

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)

getDelivery

public java.util.Date getDelivery()

setDelivery

public void setDelivery(java.util.Date delivery)

getDelay

public byte getDelay()

setDelay

public void setDelay(byte delay)

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getOriginal

public java.util.Date getOriginal()

setOriginal

public void setOriginal(java.util.Date original)

getActual

public java.util.Date getActual()

setActual

public void setActual(java.util.Date actual)

getShipToId

public java.lang.String getShipToId()

setShipToId

public void setShipToId(java.lang.String shipToId)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAcct

public java.lang.String getCarrierAcct()

setCarrierAcct

public void setCarrierAcct(java.lang.String carrierAcct)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getRrmaDate

public java.util.Date getRrmaDate()

setRrmaDate

public void setRrmaDate(java.util.Date rrmaDate)

getSalesman

public java.lang.String getSalesman()

setSalesman

public void setSalesman(java.lang.String salesman)

getProjectName

public java.lang.String getProjectName()

setProjectName

public void setProjectName(java.lang.String projectName)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getDebitAccount

public java.lang.String getDebitAccount()

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

getBp

public java.lang.String getBp()

setBp

public void setBp(java.lang.String bp)

getCustomerAddressInfo

public CustomerVendorAddressInfoVO getCustomerAddressInfo()

setCustomerAddressInfo

public void setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)

getBillToAddressInfo

public CustomerVendorAddressInfoVO getBillToAddressInfo()

setBillToAddressInfo

public void setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)

getShipToAddressInfo

public CustomerVendorAddressInfoVO getShipToAddressInfo()

setShipToAddressInfo

public void setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)

getVersion

public java.lang.Integer getVersion()

getRequester

public java.lang.String getRequester()

getApSub

public java.math.BigDecimal getApSub()

setVersion

public void setVersion(java.lang.Integer version)

setRequester

public void setRequester(java.lang.String requester)

setApSub

public void setApSub(java.math.BigDecimal apSub)

getCoComments

public java.lang.String getCoComments()

setCoComments

public void setCoComments(java.lang.String coComments)

getExchange

public java.math.BigDecimal getExchange()

setExchange

public void setExchange(java.math.BigDecimal exchange)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getSalesCodeId

public java.lang.String getSalesCodeId()

setSalesCodeId

public void setSalesCodeId(java.lang.String salesCodeId)

getRrmaItem

public java.util.Set<RequestForRMAItemVO> getRrmaItem()

setRrmaItem

public void setRrmaItem(java.util.Set<RequestForRMAItemVO> rrmaItem)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getPrivateNotes

public java.lang.String getPrivateNotes()

setPrivateNotes

public void setPrivateNotes(java.lang.String privateNotes)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getInvoiceNumber

public java.lang.String getInvoiceNumber()

setInvoiceNumber

public void setInvoiceNumber(java.lang.String invoiceNumber)

getRmaNumber

public java.lang.String getRmaNumber()

setRmaNumber

public void setRmaNumber(java.lang.String rmaNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReturnMaterialAuthorizationDocumentVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ReturnMaterialAuthorizationDocumentVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ReturnMaterialAuthorizationDocumentVO
All Implemented Interfaces:
java.io.Serializable
public class ReturnMaterialAuthorizationDocumentVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ReturnMaterialAuthorizationDocumentVO()
default constructor
Method Summary
java.lang.String | getComments()
long | getDocLength()
java.lang.String | getDocName()
java.util.Date | getDocumentDate()
java.lang.String | getDocumentDescription()
java.lang.String | getExtension()
java.lang.Long | getIi()
java.util.Date | getLastChangeDate()
java.lang.String | getLastUser()
java.lang.String | getRmaNumber()
void | setComments(java.lang.String comments)
void | setDocLength(long docLength)
void | setDocName(java.lang.String docName)
void | setDocumentDate(java.util.Date documentDate)
void | setDocumentDescription(java.lang.String documentDescription)
void | setExtension(java.lang.String extension)
void | setIi(java.lang.Long ii)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastUser(java.lang.String lastUser)
void | setRmaNumber(java.lang.String rmaNumber)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ReturnMaterialAuthorizationDocumentVO

public ReturnMaterialAuthorizationDocumentVO()
default constructor

Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getRmaNumber

public java.lang.String getRmaNumber()

setRmaNumber

public void setRmaNumber(java.lang.String rmaNumber)

getDocumentDescription

public java.lang.String getDocumentDescription()

setDocumentDescription

public void setDocumentDescription(java.lang.String documentDescription)

getDocumentDate

public java.util.Date getDocumentDate()

setDocumentDate

public void setDocumentDate(java.util.Date documentDate)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getLastUser

public java.lang.String getLastUser()

setLastUser

public void setLastUser(java.lang.String lastUser)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getDocLength

public long getDocLength()

setDocLength

public void setDocLength(long docLength)

getDocName

public java.lang.String getDocName()

setDocName

public void setDocName(java.lang.String docName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReturnMaterialAuthorizationItemManufacturerPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ReturnMaterialAuthorizationItemManufacturerPK

java.lang.Object
    extended by  bb.common.ReturnMaterialAuthorizationItemManufacturerPK
All Implemented Interfaces:
java.io.Serializable
public class ReturnMaterialAuthorizationItemManufacturerPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ReturnMaterialAuthorizationItemManufacturerPK()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Short | getItemNumber()
java.lang.String | getRmaItemNumber()
java.lang.String | getRmaNumber()
int | hashCode()
void | setItemNumber(java.lang.Short itemNumber)
void | setRmaItemNumber(java.lang.String rmaItemNumber)
void | setRmaNumber(java.lang.String rmaNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ReturnMaterialAuthorizationItemManufacturerPK

public ReturnMaterialAuthorizationItemManufacturerPK()
Method Detail

getRmaItemNumber

public java.lang.String getRmaItemNumber()

setRmaItemNumber

public void setRmaItemNumber(java.lang.String rmaItemNumber)

getRmaNumber

public java.lang.String getRmaNumber()

setRmaNumber

public void setRmaNumber(java.lang.String rmaNumber)

setItemNumber

public void setItemNumber(java.lang.Short itemNumber)

getItemNumber

public java.lang.Short getItemNumber()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReturnMaterialAuthorizationItemManufacturerVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ReturnMaterialAuthorizationItemManufacturerVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ReturnMaterialAuthorizationItemManufacturerVO
All Implemented Interfaces:
java.io.Serializable
public class ReturnMaterialAuthorizationItemManufacturerVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ReturnMaterialAuthorizationItemManufacturerVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getManufacturerName()
java.lang.String | getManufacturerPartNumber()
ReturnMaterialAuthorizationItemManufacturerPK | getPk()
int | hashCode()
void | setManufacturerName(java.lang.String manufacturerName)
void | setManufacturerPartNumber(java.lang.String manufacturerPartNumber)
void | setPk(ReturnMaterialAuthorizationItemManufacturerPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ReturnMaterialAuthorizationItemManufacturerVO

public ReturnMaterialAuthorizationItemManufacturerVO()
default constructor

Method Detail

getPk

public ReturnMaterialAuthorizationItemManufacturerPK getPk()

setPk

public void setPk(ReturnMaterialAuthorizationItemManufacturerPK pk)

getManufacturerName

public java.lang.String getManufacturerName()

setManufacturerName

public void setManufacturerName(java.lang.String manufacturerName)

getManufacturerPartNumber

public java.lang.String getManufacturerPartNumber()

setManufacturerPartNumber

public void setManufacturerPartNumber(java.lang.String manufacturerPartNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReturnMaterialAuthorizationItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ReturnMaterialAuthorizationItemPK

java.lang.Object
    extended by  bb.common.ReturnMaterialAuthorizationItemPK
All Implemented Interfaces:
java.io.Serializable
public class ReturnMaterialAuthorizationItemPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
ReturnMaterialAuthorizationItemPK()
default constructor
ReturnMaterialAuthorizationItemPK(java.lang.String rmaNumber, java.lang.String rmaItemNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getRmaItemNumber()
java.lang.String | getRmaNumber()
int | hashCode()
void | setRmaItemNumber(java.lang.String rmaItemNumber)
void | setRmaNumber(java.lang.String rmaNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ReturnMaterialAuthorizationItemPK

public ReturnMaterialAuthorizationItemPK(java.lang.String rmaNumber,
                                         java.lang.String rmaItemNumber)
full constructor

ReturnMaterialAuthorizationItemPK

public ReturnMaterialAuthorizationItemPK()
default constructor

Method Detail

getRmaNumber

public java.lang.String getRmaNumber()

setRmaNumber

public void setRmaNumber(java.lang.String rmaNumber)

getRmaItemNumber

public java.lang.String getRmaItemNumber()

setRmaItemNumber

public void setRmaItemNumber(java.lang.String rmaItemNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReturnMaterialAuthorizationItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ReturnMaterialAuthorizationItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ReturnMaterialAuthorizationItemVO
All Implemented Interfaces:
java.io.Serializable
public class ReturnMaterialAuthorizationItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ReturnMaterialAuthorizationItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAccepted()
java.lang.String | getAcceptedBy()
java.util.Date | getActual()
java.math.BigDecimal | getApDiscount()
java.math.BigDecimal | getApOpen()
java.math.BigDecimal | getApReceivd()
java.math.BigDecimal | getApSub()
java.math.BigDecimal | getApTax()
java.math.BigDecimal | getApTotal()
java.lang.String | getChangeMfg()
java.lang.String | getChangeOrder()
java.math.BigDecimal | getCostPerUnit()
java.math.BigDecimal | getCurrentCost()
java.math.BigDecimal | getCurrentStdCost()
int | getDelay()
java.util.Date | getDelivery()
java.lang.String | getDescription()
java.math.BigDecimal | getDiscount()
java.lang.String | getDwg()
java.math.BigDecimal | getExtendPrice()
java.math.BigDecimal | getHqa()
java.lang.String | getLocate()
java.lang.String | getMfg()
java.lang.String | getModelNumber()
java.lang.String | getMpn()
java.lang.String | getNcrNumber()
java.util.Date | getOriginal()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
ReturnMaterialAuthorizationItemPK | getPk()
java.lang.String | getPriority()
java.lang.String | getQr()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getReceivedQuantity()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.util.Set | getReturnMaterialAuthorizationItemManufacturer()
java.lang.String | getRevision()
java.lang.String | getRmaItemComments()
java.lang.String | getRmaItemPrivateNotes()
java.math.BigDecimal | getSalesCost()
java.math.BigDecimal | getSalesPrice()
java.math.BigDecimal | getSalesQty()
java.math.BigDecimal | getSalesStdCost()
java.lang.String | getSalesUnit()
java.math.BigDecimal | getShip()
java.lang.String | getShipvia()
java.lang.String | getStatus()
java.math.BigDecimal | getTaxRate()
java.lang.String | getUnit()
java.lang.Integer | getVersion()
int | hashCode()
void | setAccepted(java.util.Date accepted)
void | setAcceptedBy(java.lang.String acceptedBy)
void | setActual(java.util.Date actual)
void | setApDiscount(java.math.BigDecimal apDiscount)
void | setApOpen(java.math.BigDecimal apOpen)
void | setApReceivd(java.math.BigDecimal apReceivd)
void | setApSub(java.math.BigDecimal apSub)
void | setApTax(java.math.BigDecimal apTax)
void | setApTotal(java.math.BigDecimal apTotal)
void | setChangeMfg(java.lang.String changeMfg)
void | setChangeOrder(java.lang.String changeOrder)
void | setCostPerUnit(java.math.BigDecimal costPerUnit)
void | setCurrentCost(java.math.BigDecimal currentCost)
void | setCurrentStdCost(java.math.BigDecimal currentStdCost)
void | setDelay(int delay)
void | setDelivery(java.util.Date delivery)
void | setDescription(java.lang.String description)
void | setDiscount(java.math.BigDecimal discount)
void | setDwg(java.lang.String dwg)
void | setExtendPrice(java.math.BigDecimal extendPrice)
void | setHqa(java.math.BigDecimal hqa)
void | setLocate(java.lang.String locate)
void | setMfg(java.lang.String mfg)
void | setModelNumber(java.lang.String modelNumber)
void | setMpn(java.lang.String mpn)
void | setNcrNumber(java.lang.String ncrNumber)
void | setOriginal(java.util.Date original)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(ReturnMaterialAuthorizationItemPK pk)
void | setPriority(java.lang.String priority)
void | setQr(java.lang.String qr)
void | setQuantity(java.math.BigDecimal quantity)
void | setReceivedQuantity(java.math.BigDecimal receivedQuantity)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setReturnMaterialAuthorizationItemManufacturer(java.util.Set returnMaterialAuthorizationItemManufacturer)
void | setRevision(java.lang.String revision)
void | setRmaItemComments(java.lang.String rmaItemComments)
void | setRmaItemPrivateNotes(java.lang.String rmaItemPrivateNotes)
void | setSalesCost(java.math.BigDecimal salesCost)
void | setSalesPrice(java.math.BigDecimal salesPrice)
void | setSalesQty(java.math.BigDecimal salesQty)
void | setSalesStdCost(java.math.BigDecimal salesStdCost)
void | setSalesUnit(java.lang.String salesUnit)
void | setShip(java.math.BigDecimal ship)
void | setShipvia(java.lang.String shipvia)
void | setStatus(java.lang.String status)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setUnit(java.lang.String unit)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ReturnMaterialAuthorizationItemVO

public ReturnMaterialAuthorizationItemVO()
Method Detail

getPk

public ReturnMaterialAuthorizationItemPK getPk()

setPk

public void setPk(ReturnMaterialAuthorizationItemPK pk)

getApSub

public java.math.BigDecimal getApSub()

setApSub

public void setApSub(java.math.BigDecimal apSub)

getApDiscount

public java.math.BigDecimal getApDiscount()

setApDiscount

public void setApDiscount(java.math.BigDecimal apDiscount)

getExtendPrice

public java.math.BigDecimal getExtendPrice()

setExtendPrice

public void setExtendPrice(java.math.BigDecimal extendPrice)

getApReceivd

public java.math.BigDecimal getApReceivd()

setApReceivd

public void setApReceivd(java.math.BigDecimal apReceivd)

getApOpen

public java.math.BigDecimal getApOpen()

setApOpen

public void setApOpen(java.math.BigDecimal apOpen)

getApTax

public java.math.BigDecimal getApTax()

setApTax

public void setApTax(java.math.BigDecimal apTax)

getApTotal

public java.math.BigDecimal getApTotal()

setApTotal

public void setApTotal(java.math.BigDecimal apTotal)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getQr

public java.lang.String getQr()

setQr

public void setQr(java.lang.String qr)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getAccepted

public java.util.Date getAccepted()

setAccepted

public void setAccepted(java.util.Date accepted)

getAcceptedBy

public java.lang.String getAcceptedBy()

setAcceptedBy

public void setAcceptedBy(java.lang.String acceptedBy)

getDelivery

public java.util.Date getDelivery()

setDelivery

public void setDelivery(java.util.Date delivery)

getDelay

public int getDelay()

setDelay

public void setDelay(int delay)

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getOriginal

public java.util.Date getOriginal()

setOriginal

public void setOriginal(java.util.Date original)

getActual

public java.util.Date getActual()

setActual

public void setActual(java.util.Date actual)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getShipvia

public java.lang.String getShipvia()

setShipvia

public void setShipvia(java.lang.String shipvia)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getDwg

public java.lang.String getDwg()

setDwg

public void setDwg(java.lang.String dwg)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getShip

public java.math.BigDecimal getShip()

setShip

public void setShip(java.math.BigDecimal ship)

getReceivedQuantity

public java.math.BigDecimal getReceivedQuantity()

setReceivedQuantity

public void setReceivedQuantity(java.math.BigDecimal receivedQuantity)

getHqa

public java.math.BigDecimal getHqa()

setHqa

public void setHqa(java.math.BigDecimal hqa)

getCostPerUnit

public java.math.BigDecimal getCostPerUnit()

setCostPerUnit

public void setCostPerUnit(java.math.BigDecimal costPerUnit)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getChangeMfg

public java.lang.String getChangeMfg()

setChangeMfg

public void setChangeMfg(java.lang.String changeMfg)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getRmaItemComments

public java.lang.String getRmaItemComments()

setRmaItemComments

public void setRmaItemComments(java.lang.String rmaItemComments)

getRmaItemPrivateNotes

public java.lang.String getRmaItemPrivateNotes()

getVersion

public java.lang.Integer getVersion()

setRmaItemPrivateNotes

public void setRmaItemPrivateNotes(java.lang.String rmaItemPrivateNotes)

setVersion

public void setVersion(java.lang.Integer version)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getSalesCost

public java.math.BigDecimal getSalesCost()

setSalesCost

public void setSalesCost(java.math.BigDecimal salesCost)

getCurrentCost

public java.math.BigDecimal getCurrentCost()

setCurrentCost

public void setCurrentCost(java.math.BigDecimal currentCost)

getNcrNumber

public java.lang.String getNcrNumber()

setNcrNumber

public void setNcrNumber(java.lang.String ncrNumber)

getCurrentStdCost

public java.math.BigDecimal getCurrentStdCost()

setCurrentStdCost

public void setCurrentStdCost(java.math.BigDecimal currentStdCost)

getSalesStdCost

public java.math.BigDecimal getSalesStdCost()

setSalesStdCost

public void setSalesStdCost(java.math.BigDecimal salesStdCost)

getReturnMaterialAuthorizationItemManufacturer

public java.util.Set getReturnMaterialAuthorizationItemManufacturer()

setReturnMaterialAuthorizationItemManufacturer

public void setReturnMaterialAuthorizationItemManufacturer(java.util.Set returnMaterialAuthorizationItemManufacturer)

getSalesPrice

public java.math.BigDecimal getSalesPrice()

setSalesPrice

public void setSalesPrice(java.math.BigDecimal salesPrice)

getSalesQty

public java.math.BigDecimal getSalesQty()

setSalesQty

public void setSalesQty(java.math.BigDecimal salesQty)

getSalesUnit

public java.lang.String getSalesUnit()

setSalesUnit

public void setSalesUnit(java.lang.String salesUnit)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReturnMaterialAuthorizationVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ReturnMaterialAuthorizationVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ReturnMaterialAuthorizationVO
All Implemented Interfaces:
java.io.Serializable
public class ReturnMaterialAuthorizationVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ReturnMaterialAuthorizationVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getActual()
java.util.Date | getAdate()
java.math.BigDecimal | getApGl1Recorded()
java.math.BigDecimal | getApGl2Paid()
java.lang.String | getApNetSet()
java.math.BigDecimal | getApOpen()
java.math.BigDecimal | getApPaidGl()
java.math.BigDecimal | getApPaidReceived()
java.lang.String | getApprovedBy()
java.util.Date | getApprovedTime()
java.math.BigDecimal | getApReceived()
java.math.BigDecimal | getApSub()
java.lang.String | getApTaxSet()
java.util.List<RMAReceiverItemVO> | getBb2RmaReceiverItems()
CustomerVendorAddressInfoVO | getBillToAddressInfo()
java.lang.String | getBillToId()
java.lang.String | getBp()
java.lang.String | getCarrier()
java.lang.String | getCarrierAcct()
java.lang.String | getChangeOrder()
java.lang.String | getCoComments()
java.lang.String | getCompanyUnitId()
java.lang.String | getContact()
java.lang.String | getCrtvNumber()
java.lang.String | getCurrency()
CustomerVendorAddressInfoVO | getCustomerAddressInfo()
java.lang.String | getCustomerId()
java.lang.String | getDebitAccount()
byte | getDelay()
java.util.Date | getDelivery()
java.math.BigDecimal | getExchange()
java.math.BigDecimal | getGrantTotal()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getInvoiceNumber()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getLocate()
java.lang.String | getOrigin()
java.util.Date | getOriginal()
java.lang.String | getPriority()
java.lang.String | getProjectName()
java.lang.String | getReceiptNumber()
java.lang.String | getRelatedDoc()
java.lang.String | getRequester()
java.lang.String | getRmaComments()
java.util.Date | getRmaDate()
java.util.Set | getRmaDocment()
java.util.Set | getRmaItem()
java.lang.String | getRmaNumber()
java.lang.String | getRmaPrivateNotes()
java.lang.String | getSalesCodeId()
java.lang.String | getSalesman()
java.lang.String | getSalesOrderNumber()
CustomerVendorAddressInfoVO | getShipToAddressInfo()
java.lang.String | getShipToId()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.math.BigDecimal | getSubTotal()
java.lang.String | getTerms()
java.math.BigDecimal | getTotalDiscount()
java.math.BigDecimal | getTotalFreight()
java.math.BigDecimal | getTotalTax()
java.lang.Integer | getVersion()
int | hashCode()
boolean | isByPos()
void | setActual(java.util.Date actual)
void | setAdate(java.util.Date adate)
void | setApGl1Recorded(java.math.BigDecimal apGl1Recorded)
void | setApGl2Paid(java.math.BigDecimal apGl2Paid)
void | setApNetSet(java.lang.String apNetSet)
void | setApOpen(java.math.BigDecimal apOpen)
void | setApPaidGl(java.math.BigDecimal apPaidGl)
void | setApPaidReceived(java.math.BigDecimal apPaidReceived)
void | setApprovedBy(java.lang.String approvedBy)
void | setApprovedTime(java.util.Date approvedTime)
void | setApReceived(java.math.BigDecimal apReceived)
void | setApSub(java.math.BigDecimal apSub)
void | setApTaxSet(java.lang.String apTaxSet)
void | setBb2RmaReceiverItems(java.util.List<RMAReceiverItemVO> bb2RmaReceiverItems)
void | setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | setBillToId(java.lang.String billToId)
void | setBp(java.lang.String bp)
void | setByPos(boolean byPos)
void | setCarrier(java.lang.String carrier)
void | setCarrierAcct(java.lang.String carrierAcct)
void | setChangeOrder(java.lang.String changeOrder)
void | setCoComments(java.lang.String coComments)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setContact(java.lang.String contact)
void | setCrtvNumber(java.lang.String crtvNumber)
void | setCurrency(java.lang.String currency)
void | setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | setCustomerId(java.lang.String customerId)
void | setDebitAccount(java.lang.String debitAccount)
void | setDelay(byte delay)
void | setDelivery(java.util.Date delivery)
void | setExchange(java.math.BigDecimal exchange)
void | setGrantTotal(java.math.BigDecimal grantTotal)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setInvoiceNumber(java.lang.String invoiceNumber)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLocate(java.lang.String locate)
void | setOrigin(java.lang.String origin)
void | setOriginal(java.util.Date original)
void | setPriority(java.lang.String priority)
void | setProjectName(java.lang.String projectName)
void | setReceiptNumber(java.lang.String receiptNumber)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setRequester(java.lang.String requester)
void | setRmaComments(java.lang.String rmaComments)
void | setRmaDate(java.util.Date rmaDate)
void | setRmaDocment(java.util.Set rmaDocment)
void | setRmaItem(java.util.Set rmaItem)
void | setRmaNumber(java.lang.String rmaNumber)
void | setRmaPrivateNotes(java.lang.String rmaPrivateNotes)
void | setSalesCodeId(java.lang.String salesCodeId)
void | setSalesman(java.lang.String salesman)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | setShipToId(java.lang.String shipToId)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setSubTotal(java.math.BigDecimal subTotal)
void | setTerms(java.lang.String terms)
void | setTotalDiscount(java.math.BigDecimal totalDiscount)
void | setTotalFreight(java.math.BigDecimal totalFreight)
void | setTotalTax(java.math.BigDecimal totalTax)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ReturnMaterialAuthorizationVO

public ReturnMaterialAuthorizationVO()
Method Detail

getRmaNumber

public java.lang.String getRmaNumber()

setRmaNumber

public void setRmaNumber(java.lang.String rmaNumber)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getApNetSet

public java.lang.String getApNetSet()

setApNetSet

public void setApNetSet(java.lang.String apNetSet)

getApTaxSet

public java.lang.String getApTaxSet()

setApTaxSet

public void setApTaxSet(java.lang.String apTaxSet)

getSubTotal

public java.math.BigDecimal getSubTotal()

setSubTotal

public void setSubTotal(java.math.BigDecimal subTotal)

getTotalDiscount

public java.math.BigDecimal getTotalDiscount()

setTotalDiscount

public void setTotalDiscount(java.math.BigDecimal totalDiscount)

getApReceived

public java.math.BigDecimal getApReceived()

setApReceived

public void setApReceived(java.math.BigDecimal apReceived)

getApOpen

public java.math.BigDecimal getApOpen()

setApOpen

public void setApOpen(java.math.BigDecimal apOpen)

getTotalTax

public java.math.BigDecimal getTotalTax()

setTotalTax

public void setTotalTax(java.math.BigDecimal totalTax)

getTotalFreight

public java.math.BigDecimal getTotalFreight()

setTotalFreight

public void setTotalFreight(java.math.BigDecimal totalFreight)

getGrantTotal

public java.math.BigDecimal getGrantTotal()

setGrantTotal

public void setGrantTotal(java.math.BigDecimal grantTotal)

getApPaidReceived

public java.math.BigDecimal getApPaidReceived()

setApPaidReceived

public void setApPaidReceived(java.math.BigDecimal apPaidReceived)

getApPaidGl

public java.math.BigDecimal getApPaidGl()

setApPaidGl

public void setApPaidGl(java.math.BigDecimal apPaidGl)

getApGl1Recorded

public java.math.BigDecimal getApGl1Recorded()

setApGl1Recorded

public void setApGl1Recorded(java.math.BigDecimal apGl1Recorded)

getApGl2Paid

public java.math.BigDecimal getApGl2Paid()

setApGl2Paid

public void setApGl2Paid(java.math.BigDecimal apGl2Paid)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getBillToId

public java.lang.String getBillToId()

setBillToId

public void setBillToId(java.lang.String billToId)

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getInvoiceNumber

public java.lang.String getInvoiceNumber()

setInvoiceNumber

public void setInvoiceNumber(java.lang.String invoiceNumber)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getApprovedTime

public java.util.Date getApprovedTime()

setApprovedTime

public void setApprovedTime(java.util.Date approvedTime)

getApprovedBy

public java.lang.String getApprovedBy()

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)

getDelivery

public java.util.Date getDelivery()

setDelivery

public void setDelivery(java.util.Date delivery)

getDelay

public byte getDelay()

setDelay

public void setDelay(byte delay)

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getOriginal

public java.util.Date getOriginal()

setOriginal

public void setOriginal(java.util.Date original)

getActual

public java.util.Date getActual()

setActual

public void setActual(java.util.Date actual)

getShipToId

public java.lang.String getShipToId()

setShipToId

public void setShipToId(java.lang.String shipToId)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAcct

public java.lang.String getCarrierAcct()

setCarrierAcct

public void setCarrierAcct(java.lang.String carrierAcct)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getRmaDate

public java.util.Date getRmaDate()

setRmaDate

public void setRmaDate(java.util.Date rmaDate)

getSalesman

public java.lang.String getSalesman()

setSalesman

public void setSalesman(java.lang.String salesman)

getProjectName

public java.lang.String getProjectName()

setProjectName

public void setProjectName(java.lang.String projectName)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getDebitAccount

public java.lang.String getDebitAccount()

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

getBp

public java.lang.String getBp()

setBp

public void setBp(java.lang.String bp)

getRmaComments

public java.lang.String getRmaComments()

setRmaComments

public void setRmaComments(java.lang.String rmaComments)

getRmaPrivateNotes

public java.lang.String getRmaPrivateNotes()

setRmaPrivateNotes

public void setRmaPrivateNotes(java.lang.String rmaPrivateNotes)

getCustomerAddressInfo

public CustomerVendorAddressInfoVO getCustomerAddressInfo()

setCustomerAddressInfo

public void setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)

getBillToAddressInfo

public CustomerVendorAddressInfoVO getBillToAddressInfo()

setBillToAddressInfo

public void setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)

getShipToAddressInfo

public CustomerVendorAddressInfoVO getShipToAddressInfo()

setShipToAddressInfo

public void setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)

getRmaItem

public java.util.Set getRmaItem()

getVersion

public java.lang.Integer getVersion()

getRequester

public java.lang.String getRequester()

getApSub

public java.math.BigDecimal getApSub()

setRmaItem

public void setRmaItem(java.util.Set rmaItem)

setVersion

public void setVersion(java.lang.Integer version)

setRequester

public void setRequester(java.lang.String requester)

setApSub

public void setApSub(java.math.BigDecimal apSub)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getBb2RmaReceiverItems

public java.util.List<RMAReceiverItemVO> getBb2RmaReceiverItems()

setBb2RmaReceiverItems

public void setBb2RmaReceiverItems(java.util.List<RMAReceiverItemVO> bb2RmaReceiverItems)

getCoComments

public java.lang.String getCoComments()

setCoComments

public void setCoComments(java.lang.String coComments)

getExchange

public java.math.BigDecimal getExchange()

setExchange

public void setExchange(java.math.BigDecimal exchange)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getSalesCodeId

public java.lang.String getSalesCodeId()

setSalesCodeId

public void setSalesCodeId(java.lang.String salesCodeId)

isByPos

public boolean isByPos()

setByPos

public void setByPos(boolean byPos)

getRmaDocment

public java.util.Set getRmaDocment()

setRmaDocment

public void setRmaDocment(java.util.Set rmaDocment)

getReceiptNumber

public java.lang.String getReceiptNumber()

setReceiptNumber

public void setReceiptNumber(java.lang.String receiptNumber)

getCrtvNumber

public java.lang.String getCrtvNumber()

setCrtvNumber

public void setCrtvNumber(java.lang.String crtvNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReturnToVendorByDateListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ReturnToVendorByDateListResult

java.lang.Object
    extended by  bb.common.ReturnToVendorByDateListResult
All Implemented Interfaces:
java.io.Serializable
public class ReturnToVendorByDateListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_APNET
static java.lang.String | ORDER_BY_BUYER
static java.lang.String | ORDER_BY_COMPANYUNITID
static java.lang.String | ORDER_BY_COSTPERUNIT
static java.lang.String | ORDER_BY_DATEREQUIRED
static java.lang.String | ORDER_BY_DEBITACCOUNT
static java.lang.String | ORDER_BY_DISCOUNT
static java.lang.String | ORDER_BY_ENTERBY
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_REFDOC2
static java.lang.String | ORDER_BY_RTVDATE
static java.lang.String | ORDER_BY_RTVITEMPK
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_TAXRATE
static java.lang.String | ORDER_BY_VENDORID
Constructor Summary
ReturnToVendorByDateListResult()
Method Summary
java.math.BigDecimal | getApNet()
java.lang.String | getBillToId()
java.lang.String | getBuyer()
java.lang.String | getCompanyUnitId()
java.math.BigDecimal | getCostPerUnit()
java.lang.String | getCurrency()
java.util.Date | getDateRequired()
java.lang.String | getDebitAccount()
java.lang.String | getDescription()
java.math.BigDecimal | getDiscount()
java.lang.String | getEnterBy()
java.lang.String | getNcr()
BB2Part | getPartPk()
java.lang.String | getPo()
java.lang.String | getProject()
java.math.BigDecimal | getQuantity()
java.lang.String | getRefDoc2()
java.lang.String | getRequestor()
java.lang.String | getRtvComments()
java.util.Date | getRtvDate()
java.lang.String | getRtvistatus()
ReturnToVendorItemPK | getRtvItemPk()
java.math.BigDecimal | getShip()
java.lang.String | getShipTo()
java.math.BigDecimal | getTaxRate()
java.lang.String | getUnit()
java.lang.String | getVendorId()
void | setApNet(java.math.BigDecimal apNet)
void | setBillToId(java.lang.String billToId)
void | setBuyer(java.lang.String buyer)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCostPerUnit(java.math.BigDecimal costPerUnit)
void | setCurrency(java.lang.String currency)
void | setDateRequired(java.util.Date dateRequired)
void | setDebitAccount(java.lang.String debitAccount)
void | setDescription(java.lang.String description)
void | setDiscount(java.math.BigDecimal discount)
void | setEnterBy(java.lang.String enterBy)
void | setNcr(java.lang.String ncr)
void | setPartPk(BB2Part partPk)
void | setPo(java.lang.String po)
void | setProject(java.lang.String project)
void | setQuantity(java.math.BigDecimal quantity)
void | setRefDoc2(java.lang.String refDoc2)
void | setRequestor(java.lang.String requestor)
void | setRtvComments(java.lang.String rtvComments)
void | setRtvDate(java.util.Date rtvDate)
void | setRtvistatus(java.lang.String rtvistatus)
void | setRtvItemPk(ReturnToVendorItemPK rtvItemPk)
void | setShip(java.math.BigDecimal ship)
void | setShipTo(java.lang.String shipTo)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setUnit(java.lang.String unit)
void | setVendorId(java.lang.String vendorId)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_RTVITEMPK

public static final java.lang.String ORDER_BY_RTVITEMPK
See Also:
Constant Field Values

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_BUYER

public static final java.lang.String ORDER_BY_BUYER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_DATEREQUIRED

public static final java.lang.String ORDER_BY_DATEREQUIRED
See Also:
Constant Field Values

ORDER_BY_COSTPERUNIT

public static final java.lang.String ORDER_BY_COSTPERUNIT
See Also:
Constant Field Values

ORDER_BY_APNET

public static final java.lang.String ORDER_BY_APNET
See Also:
Constant Field Values

ORDER_BY_DISCOUNT

public static final java.lang.String ORDER_BY_DISCOUNT
See Also:
Constant Field Values

ORDER_BY_RTVDATE

public static final java.lang.String ORDER_BY_RTVDATE
See Also:
Constant Field Values

ORDER_BY_ENTERBY

public static final java.lang.String ORDER_BY_ENTERBY
See Also:
Constant Field Values

ORDER_BY_DEBITACCOUNT

public static final java.lang.String ORDER_BY_DEBITACCOUNT
See Also:
Constant Field Values

ORDER_BY_COMPANYUNITID

public static final java.lang.String ORDER_BY_COMPANYUNITID
See Also:
Constant Field Values

ORDER_BY_TAXRATE

public static final java.lang.String ORDER_BY_TAXRATE
See Also:
Constant Field Values

ORDER_BY_REFDOC2

public static final java.lang.String ORDER_BY_REFDOC2
See Also:
Constant Field Values
Constructor Detail

ReturnToVendorByDateListResult

public ReturnToVendorByDateListResult()
Method Detail

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getBillToId

public java.lang.String getBillToId()

setBillToId

public void setBillToId(java.lang.String billToId)

getBuyer

public java.lang.String getBuyer()

setBuyer

public void setBuyer(java.lang.String buyer)

getCostPerUnit

public java.math.BigDecimal getCostPerUnit()

setCostPerUnit

public void setCostPerUnit(java.math.BigDecimal costPerUnit)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getDateRequired

public java.util.Date getDateRequired()

setDateRequired

public void setDateRequired(java.util.Date dateRequired)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getPartPk

public BB2Part getPartPk()

setPartPk

public void setPartPk(BB2Part partPk)

getPo

public java.lang.String getPo()

setPo

public void setPo(java.lang.String po)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getRequestor

public java.lang.String getRequestor()

setRequestor

public void setRequestor(java.lang.String requestor)

getRtvComments

public java.lang.String getRtvComments()

setRtvComments

public void setRtvComments(java.lang.String rtvComments)

getRtvDate

public java.util.Date getRtvDate()

setRtvDate

public void setRtvDate(java.util.Date rtvDate)

getApNet

public java.math.BigDecimal getApNet()

setApNet

public void setApNet(java.math.BigDecimal apNet)

getRtvistatus

public java.lang.String getRtvistatus()

setRtvistatus

public void setRtvistatus(java.lang.String rtvistatus)

getRtvItemPk

public ReturnToVendorItemPK getRtvItemPk()

setRtvItemPk

public void setRtvItemPk(ReturnToVendorItemPK rtvItemPk)

getShip

public java.math.BigDecimal getShip()

setShip

public void setShip(java.math.BigDecimal ship)

getShipTo

public java.lang.String getShipTo()

setShipTo

public void setShipTo(java.lang.String shipTo)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getEnterBy

public java.lang.String getEnterBy()

setEnterBy

public void setEnterBy(java.lang.String enterBy)

getNcr

public java.lang.String getNcr()

setNcr

public void setNcr(java.lang.String ncr)

getDebitAccount

public java.lang.String getDebitAccount()

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReturnToVendorCheckListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ReturnToVendorCheckListResult

java.lang.Object
    extended by  bb.common.ReturnToVendorCheckListResult
All Implemented Interfaces:
java.io.Serializable
public class ReturnToVendorCheckListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_BUYER
static java.lang.String | ORDER_BY_PONUMBER
static java.lang.String | ORDER_BY_PROJECT
static java.lang.String | ORDER_BY_RTVNUMBER
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_VENDORID
Constructor Summary
ReturnToVendorCheckListResult()
Method Summary
java.math.BigDecimal | getApTotal()
java.lang.String | getBuyer()
java.lang.String | getComments()
java.lang.String | getCurrency()
java.util.Date | getDelivery()
java.lang.String | getPoNumber()
java.lang.String | getProject()
java.util.Date | getRtvDate()
java.lang.String | getRtvNumber()
java.lang.String | getStatus()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
void | setApTotal(java.math.BigDecimal apTotal)
void | setBuyer(java.lang.String buyer)
void | setComments(java.lang.String comments)
void | setCurrency(java.lang.String currency)
void | setDelivery(java.util.Date delivery)
void | setPoNumber(java.lang.String poNumber)
void | setProject(java.lang.String project)
void | setRtvDate(java.util.Date rtvDate)
void | setRtvNumber(java.lang.String rtvNumber)
void | setStatus(java.lang.String status)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_RTVNUMBER

public static final java.lang.String ORDER_BY_RTVNUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_BUYER

public static final java.lang.String ORDER_BY_BUYER
See Also:
Constant Field Values

ORDER_BY_PROJECT

public static final java.lang.String ORDER_BY_PROJECT
See Also:
Constant Field Values

ORDER_BY_PONUMBER

public static final java.lang.String ORDER_BY_PONUMBER
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values
Constructor Detail

ReturnToVendorCheckListResult

public ReturnToVendorCheckListResult()
Method Detail

getRtvNumber

public java.lang.String getRtvNumber()

getVendorId

public java.lang.String getVendorId()

getBuyer

public java.lang.String getBuyer()

getRtvDate

public java.util.Date getRtvDate()

getDelivery

public java.util.Date getDelivery()

getStatus

public java.lang.String getStatus()

getApTotal

public java.math.BigDecimal getApTotal()

getCurrency

public java.lang.String getCurrency()

getVendorName

public java.lang.String getVendorName()

getProject

public java.lang.String getProject()

getComments

public java.lang.String getComments()

getPoNumber

public java.lang.String getPoNumber()

setRtvNumber

public void setRtvNumber(java.lang.String rtvNumber)

setVendorId

public void setVendorId(java.lang.String vendorId)

setBuyer

public void setBuyer(java.lang.String buyer)

setRtvDate

public void setRtvDate(java.util.Date rtvDate)

setDelivery

public void setDelivery(java.util.Date delivery)

setStatus

public void setStatus(java.lang.String status)

setApTotal

public void setApTotal(java.math.BigDecimal apTotal)

setCurrency

public void setCurrency(java.lang.String currency)

setVendorName

public void setVendorName(java.lang.String vendorName)

setProject

public void setProject(java.lang.String project)

setComments

public void setComments(java.lang.String comments)

setPoNumber

public void setPoNumber(java.lang.String poNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReturnToVendorItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ReturnToVendorItemListResult

java.lang.Object
    extended by  bb.common.ReturnToVendorItemListResult
All Implemented Interfaces:
java.io.Serializable
public class ReturnToVendorItemListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_BUYER
static java.lang.String | ORDER_BY_DELIVERY
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_RTVDATE
static java.lang.String | ORDER_BY_RTVITEMPK
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_VENDORNAME
Constructor Summary
ReturnToVendorItemListResult()
Method Summary
java.lang.String | getBuyer()
java.lang.String | getComments()
java.math.BigDecimal | getCost()
java.util.Date | getDelivery()
java.math.BigDecimal | getDiscount()
java.math.BigDecimal | getExtPrice()
java.lang.String | getPartDesc()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.lang.String | getPoItemNumber()
java.math.BigDecimal | getQty()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.util.Date | getRtvDate()
ReturnToVendorItemPK | getRtvItemPk()
java.math.BigDecimal | getShipped()
java.lang.String | getStatus()
java.lang.String | getUnit()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
void | setBuyer(java.lang.String buyer)
void | setComments(java.lang.String comments)
void | setCost(java.math.BigDecimal cost)
void | setDelivery(java.util.Date delivery)
void | setDiscount(java.math.BigDecimal discount)
void | setExtPrice(java.math.BigDecimal extPrice)
void | setPartDesc(java.lang.String partDesc)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setPoItemNumber(java.lang.String poItemNumber)
void | setQty(java.math.BigDecimal qty)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setRtvDate(java.util.Date rtvDate)
void | setRtvItemPk(ReturnToVendorItemPK rtvItemPk)
void | setShipped(java.math.BigDecimal shipped)
void | setStatus(java.lang.String status)
void | setUnit(java.lang.String unit)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_RTVITEMPK

public static final java.lang.String ORDER_BY_RTVITEMPK
See Also:
Constant Field Values

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_BUYER

public static final java.lang.String ORDER_BY_BUYER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_RTVDATE

public static final java.lang.String ORDER_BY_RTVDATE
See Also:
Constant Field Values

ORDER_BY_DELIVERY

public static final java.lang.String ORDER_BY_DELIVERY
See Also:
Constant Field Values

ORDER_BY_VENDORNAME

public static final java.lang.String ORDER_BY_VENDORNAME
See Also:
Constant Field Values
Constructor Detail

ReturnToVendorItemListResult

public ReturnToVendorItemListResult()
Method Detail

getRtvItemPk

public ReturnToVendorItemPK getRtvItemPk()

getPartPk

public PartPK getPartPk()

getPartDesc

public java.lang.String getPartDesc()

getQty

public java.math.BigDecimal getQty()

getShipped

public java.math.BigDecimal getShipped()

getCost

public java.math.BigDecimal getCost()

getDiscount

public java.math.BigDecimal getDiscount()

getExtPrice

public java.math.BigDecimal getExtPrice()

getVendorId

public java.lang.String getVendorId()

getVendorName

public java.lang.String getVendorName()

getDelivery

public java.util.Date getDelivery()

getStatus

public java.lang.String getStatus()

getPoItemNumber

public java.lang.String getPoItemNumber()

getPartFrom

public java.lang.String getPartFrom()

getComments

public java.lang.String getComments()

getBuyer

public java.lang.String getBuyer()

getUnit

public java.lang.String getUnit()

getRtvDate

public java.util.Date getRtvDate()

getRefDoc1

public java.lang.String getRefDoc1()

getRefDoc2

public java.lang.String getRefDoc2()

setRtvItemPk

public void setRtvItemPk(ReturnToVendorItemPK rtvItemPk)

setPartPk

public void setPartPk(PartPK partPk)

setPartDesc

public void setPartDesc(java.lang.String partDesc)

setQty

public void setQty(java.math.BigDecimal qty)

setShipped

public void setShipped(java.math.BigDecimal shipped)

setCost

public void setCost(java.math.BigDecimal cost)

setDiscount

public void setDiscount(java.math.BigDecimal discount)

setExtPrice

public void setExtPrice(java.math.BigDecimal extPrice)

setVendorId

public void setVendorId(java.lang.String vendorId)

setVendorName

public void setVendorName(java.lang.String vendorName)

setDelivery

public void setDelivery(java.util.Date delivery)

setStatus

public void setStatus(java.lang.String status)

setPoItemNumber

public void setPoItemNumber(java.lang.String poItemNumber)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setComments

public void setComments(java.lang.String comments)

setBuyer

public void setBuyer(java.lang.String buyer)

setUnit

public void setUnit(java.lang.String unit)

setRtvDate

public void setRtvDate(java.util.Date rtvDate)

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReturnToVendorItemManufacturerPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ReturnToVendorItemManufacturerPK

java.lang.Object
    extended by  bb.common.ReturnToVendorItemManufacturerPK
All Implemented Interfaces:
java.io.Serializable
public class ReturnToVendorItemManufacturerPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ReturnToVendorItemManufacturerPK()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Short | getItemNumber()
java.lang.String | getReturnToVendorItemNumber()
java.lang.String | getReturnToVendorNumber()
int | hashCode()
void | setItemNumber(java.lang.Short itemNumber)
void | setReturnToVendorItemNumber(java.lang.String returnToVendorItemNumber)
void | setReturnToVendorNumber(java.lang.String returnToVendorNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ReturnToVendorItemManufacturerPK

public ReturnToVendorItemManufacturerPK()
Method Detail

getReturnToVendorItemNumber

public java.lang.String getReturnToVendorItemNumber()

setReturnToVendorItemNumber

public void setReturnToVendorItemNumber(java.lang.String returnToVendorItemNumber)

getReturnToVendorNumber

public java.lang.String getReturnToVendorNumber()

setReturnToVendorNumber

public void setReturnToVendorNumber(java.lang.String returnToVendorNumber)

setItemNumber

public void setItemNumber(java.lang.Short itemNumber)

getItemNumber

public java.lang.Short getItemNumber()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReturnToVendorItemManufacturerVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ReturnToVendorItemManufacturerVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ReturnToVendorItemManufacturerVO
All Implemented Interfaces:
java.io.Serializable
public class ReturnToVendorItemManufacturerVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ReturnToVendorItemManufacturerVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getManufacturerName()
java.lang.String | getManufacturerPartNumber()
ReturnToVendorItemManufacturerPK | getPk()
int | hashCode()
void | setManufacturerName(java.lang.String manufacturerName)
void | setManufacturerPartNumber(java.lang.String manufacturerPartNumber)
void | setPk(ReturnToVendorItemManufacturerPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ReturnToVendorItemManufacturerVO

public ReturnToVendorItemManufacturerVO()
default constructor

Method Detail

getPk

public ReturnToVendorItemManufacturerPK getPk()

setPk

public void setPk(ReturnToVendorItemManufacturerPK pk)

getManufacturerName

public java.lang.String getManufacturerName()

setManufacturerName

public void setManufacturerName(java.lang.String manufacturerName)

getManufacturerPartNumber

public java.lang.String getManufacturerPartNumber()

setManufacturerPartNumber

public void setManufacturerPartNumber(java.lang.String manufacturerPartNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReturnToVendorItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ReturnToVendorItemPK

java.lang.Object
    extended by  bb.common.ReturnToVendorItemPK
All Implemented Interfaces:
java.io.Serializable
public class ReturnToVendorItemPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
ReturnToVendorItemPK()
default constructor
ReturnToVendorItemPK(java.lang.String returnToVendorNumber, java.lang.String returnToVendorItemNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getReturnToVendorItemNumber()
java.lang.String | getReturnToVendorNumber()
int | hashCode()
void | setReturnToVendorItemNumber(java.lang.String returnToVendorItemNumber)
void | setReturnToVendorNumber(java.lang.String returnToVendorNumber)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ReturnToVendorItemPK

public ReturnToVendorItemPK(java.lang.String returnToVendorNumber,
                            java.lang.String returnToVendorItemNumber)
full constructor

ReturnToVendorItemPK

public ReturnToVendorItemPK()
default constructor

Method Detail

getReturnToVendorNumber

public java.lang.String getReturnToVendorNumber()

setReturnToVendorNumber

public void setReturnToVendorNumber(java.lang.String returnToVendorNumber)

getReturnToVendorItemNumber

public java.lang.String getReturnToVendorItemNumber()

setReturnToVendorItemNumber

public void setReturnToVendorItemNumber(java.lang.String returnToVendorItemNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReturnToVendorItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ReturnToVendorItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ReturnToVendorItemVO
All Implemented Interfaces:
java.io.Serializable
public class ReturnToVendorItemVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
ReturnToVendorItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAccepted()
java.lang.String | getAcceptedBy()
java.util.Date | getActual()
java.math.BigDecimal | getApDisc()
java.math.BigDecimal | getApNet()
java.math.BigDecimal | getApOpen()
java.math.BigDecimal | getApRcvd()
java.math.BigDecimal | getApSub()
java.math.BigDecimal | getApTax()
java.math.BigDecimal | getApTotal()
java.lang.String | getChangeMfg()
java.lang.String | getChangeOrder()
java.math.BigDecimal | getCostPerUnit()
int | getDelay()
java.util.Date | getDelivery()
java.lang.String | getDescription()
java.math.BigDecimal | getDiscount()
java.lang.String | getDwg()
java.math.BigDecimal | getHqa()
java.lang.String | getItemComments()
java.math.BigDecimal | getItemGrandTotal()
java.lang.String | getItemPrivateNotes()
java.lang.String | getLocate()
java.lang.String | getMfg()
java.lang.String | getModelNumber()
java.lang.String | getMpn()
java.lang.String | getNcrNumber()
java.util.Date | getOriginal()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getPi()
ReturnToVendorItemPK | getPk()
java.lang.String | getPoUnit()
java.math.BigDecimal | getPoUnitQty()
java.lang.String | getPriority()
java.lang.String | getQr()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getReceivedQty()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.util.Set | getReturnToVendorItemManufacturer()
java.lang.String | getRevision()
java.math.BigDecimal | getShip()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.math.BigDecimal | getTaxRate()
java.lang.String | getUnit()
int | hashCode()
void | setAccepted(java.util.Date accepted)
void | setAcceptedBy(java.lang.String acceptedBy)
void | setActual(java.util.Date actual)
void | setApDisc(java.math.BigDecimal apDisc)
void | setApNet(java.math.BigDecimal apNet)
void | setApOpen(java.math.BigDecimal apOpen)
void | setApRcvd(java.math.BigDecimal apRcvd)
void | setApSub(java.math.BigDecimal apSub)
void | setApTax(java.math.BigDecimal apTax)
void | setApTotal(java.math.BigDecimal apTotal)
void | setChangeMfg(java.lang.String changeMfg)
void | setChangeOrder(java.lang.String changeOrder)
void | setCostPerUnit(java.math.BigDecimal costPerUnit)
void | setDelay(int delay)
void | setDelivery(java.util.Date delivery)
void | setDescription(java.lang.String description)
void | setDiscount(java.math.BigDecimal discount)
void | setDwg(java.lang.String dwg)
void | setHqa(java.math.BigDecimal hqa)
void | setItemComments(java.lang.String itemComments)
void | setItemGrandTotal(java.math.BigDecimal itemGrandTotal)
void | setItemPrivateNotes(java.lang.String itemPrivateNotes)
void | setLocate(java.lang.String locate)
void | setMfg(java.lang.String mfg)
void | setModelNumber(java.lang.String modelNumber)
void | setMpn(java.lang.String mpn)
void | setNcrNumber(java.lang.String ncrNumber)
void | setOriginal(java.util.Date original)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPi(java.lang.String pi)
void | setPk(ReturnToVendorItemPK pk)
void | setPoUnit(java.lang.String poUnit)
void | setPoUnitQty(java.math.BigDecimal poUnitQty)
void | setPriority(java.lang.String priority)
void | setQr(java.lang.String qr)
void | setQuantity(java.math.BigDecimal quantity)
void | setReceivedQty(java.math.BigDecimal receivedQty)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setReturnToVendorItemManufacturer(java.util.Set returnToVendorItemManufacturer)
void | setRevision(java.lang.String revision)
void | setShip(java.math.BigDecimal ship)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setUnit(java.lang.String unit)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ReturnToVendorItemVO

public ReturnToVendorItemVO()
Method Detail

getPk

public ReturnToVendorItemPK getPk()

setPk

public void setPk(ReturnToVendorItemPK pk)

getPi

public java.lang.String getPi()

setPi

public void setPi(java.lang.String pi)

getApSub

public java.math.BigDecimal getApSub()

setApSub

public void setApSub(java.math.BigDecimal apSub)

getApDisc

public java.math.BigDecimal getApDisc()

setApDisc

public void setApDisc(java.math.BigDecimal apDisc)

getApNet

public java.math.BigDecimal getApNet()

setApNet

public void setApNet(java.math.BigDecimal apNet)

getApRcvd

public java.math.BigDecimal getApRcvd()

setApRcvd

public void setApRcvd(java.math.BigDecimal apRcvd)

getApOpen

public java.math.BigDecimal getApOpen()

setApOpen

public void setApOpen(java.math.BigDecimal apOpen)

getApTax

public java.math.BigDecimal getApTax()

setApTax

public void setApTax(java.math.BigDecimal apTax)

getApTotal

public java.math.BigDecimal getApTotal()

setApTotal

public void setApTotal(java.math.BigDecimal apTotal)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getQr

public java.lang.String getQr()

setQr

public void setQr(java.lang.String qr)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getAccepted

public java.util.Date getAccepted()

setAccepted

public void setAccepted(java.util.Date accepted)

getAcceptedBy

public java.lang.String getAcceptedBy()

setAcceptedBy

public void setAcceptedBy(java.lang.String acceptedBy)

getDelivery

public java.util.Date getDelivery()

setDelivery

public void setDelivery(java.util.Date delivery)

getDelay

public int getDelay()

setDelay

public void setDelay(int delay)

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getOriginal

public java.util.Date getOriginal()

setOriginal

public void setOriginal(java.util.Date original)

getActual

public java.util.Date getActual()

setActual

public void setActual(java.util.Date actual)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getDwg

public java.lang.String getDwg()

setDwg

public void setDwg(java.lang.String dwg)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getShip

public java.math.BigDecimal getShip()

setShip

public void setShip(java.math.BigDecimal ship)

getReceivedQty

public java.math.BigDecimal getReceivedQty()

setReceivedQty

public void setReceivedQty(java.math.BigDecimal receivedQty)

getHqa

public java.math.BigDecimal getHqa()

setHqa

public void setHqa(java.math.BigDecimal hqa)

getCostPerUnit

public java.math.BigDecimal getCostPerUnit()

setCostPerUnit

public void setCostPerUnit(java.math.BigDecimal costPerUnit)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getChangeMfg

public java.lang.String getChangeMfg()

setChangeMfg

public void setChangeMfg(java.lang.String changeMfg)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getItemComments

public java.lang.String getItemComments()

setItemComments

public void setItemComments(java.lang.String itemComments)

getItemPrivateNotes

public java.lang.String getItemPrivateNotes()

setItemPrivateNotes

public void setItemPrivateNotes(java.lang.String itemPrivateNotes)

getNcrNumber

public java.lang.String getNcrNumber()

setNcrNumber

public void setNcrNumber(java.lang.String ncrNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getPoUnit

public java.lang.String getPoUnit()

setPoUnit

public void setPoUnit(java.lang.String poUnit)

getPoUnitQty

public java.math.BigDecimal getPoUnitQty()

setPoUnitQty

public void setPoUnitQty(java.math.BigDecimal poUnitQty)

getReturnToVendorItemManufacturer

public java.util.Set getReturnToVendorItemManufacturer()

setReturnToVendorItemManufacturer

public void setReturnToVendorItemManufacturer(java.util.Set returnToVendorItemManufacturer)

getItemGrandTotal

public java.math.BigDecimal getItemGrandTotal()

setItemGrandTotal

public void setItemGrandTotal(java.math.BigDecimal itemGrandTotal)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReturnToVendorListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ReturnToVendorListResult

java.lang.Object
    extended by  bb.common.ReturnToVendorListResult
All Implemented Interfaces:
java.io.Serializable
public class ReturnToVendorListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_RTVNUMBER
static java.lang.String | ORDER_BY_VENDORID
Constructor Summary
ReturnToVendorListResult()
Method Summary
java.lang.String | getBuyer()
java.lang.String | getComments()
java.util.Date | getDelivery()
java.lang.String | getPoNumber()
java.lang.String | getProject()
java.util.Date | getRtvDate()
java.lang.String | getRtvNumber()
java.lang.String | getStatus()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
void | setBuyer(java.lang.String buyer)
void | setComments(java.lang.String comments)
void | setDelivery(java.util.Date delivery)
void | setPoNumber(java.lang.String poNumber)
void | setProject(java.lang.String project)
void | setRtvDate(java.util.Date rtvDate)
void | setRtvNumber(java.lang.String rtvNumber)
void | setStatus(java.lang.String status)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_RTVNUMBER

public static final java.lang.String ORDER_BY_RTVNUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values
Constructor Detail

ReturnToVendorListResult

public ReturnToVendorListResult()
Method Detail

setRtvNumber

public void setRtvNumber(java.lang.String rtvNumber)

setRtvDate

public void setRtvDate(java.util.Date rtvDate)

setVendorId

public void setVendorId(java.lang.String vendorId)

setVendorName

public void setVendorName(java.lang.String vendorName)

setDelivery

public void setDelivery(java.util.Date delivery)

setBuyer

public void setBuyer(java.lang.String buyer)

setProject

public void setProject(java.lang.String project)

setComments

public void setComments(java.lang.String comments)

setStatus

public void setStatus(java.lang.String status)

setPoNumber

public void setPoNumber(java.lang.String poNumber)

getRtvNumber

public java.lang.String getRtvNumber()

getRtvDate

public java.util.Date getRtvDate()

getVendorId

public java.lang.String getVendorId()

getVendorName

public java.lang.String getVendorName()

getDelivery

public java.util.Date getDelivery()

getBuyer

public java.lang.String getBuyer()

getProject

public java.lang.String getProject()

getComments

public java.lang.String getComments()

getStatus

public java.lang.String getStatus()

getPoNumber

public java.lang.String getPoNumber()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReturnToVendorVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ReturnToVendorVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ReturnToVendorVO
All Implemented Interfaces:
java.io.Serializable
public class ReturnToVendorVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
ReturnToVendorVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getActual()
java.util.Date | getAdate()
java.math.BigDecimal | getApDisc()
java.math.BigDecimal | getApGl1Recorded()
java.math.BigDecimal | getApGl2Paid()
java.math.BigDecimal | getApNet()
java.lang.String | getApNetSet()
java.math.BigDecimal | getApOpen()
java.math.BigDecimal | getApPaidGl()
java.math.BigDecimal | getApPaidRcv()
java.lang.String | getApprovedBy()
java.util.Date | getApprovedDate()
java.math.BigDecimal | getApRcvd()
java.lang.String | getApTaxSet()
java.util.List<RtvShipperItemListResult> | getBb2ShipperItems()
CustomerVendorAddressInfoVO | getBillToAddressInfo()
java.lang.String | getBillToId()
java.lang.String | getBp()
java.lang.String | getBuyer()
java.lang.String | getBuyor()
java.lang.String | getBuyorGroup()
java.lang.String | getCarrier()
java.lang.String | getCarrierAccount()
java.lang.String | getChangeOrder()
java.lang.String | getCoComments()
java.lang.String | getCompanyUnitId()
java.lang.String | getContact()
java.lang.String | getCurrency()
java.util.Date | getDateEntered()
java.util.Date | getDateRequired()
java.lang.String | getDebitAccount()
byte | getDelayDays()
java.lang.String | getEnterBy()
java.math.BigDecimal | getGrantTotal()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
java.lang.Integer | getLastChangeTimes()
java.lang.String | getLastChangeUser()
java.lang.String | getLocate()
java.lang.String | getOrigin()
java.util.Date | getOriginal()
java.lang.String | getPo()
java.lang.String | getPriority()
java.lang.String | getProject()
java.lang.String | getReldoc()
java.lang.String | getRequestor()
java.lang.String | getReturnToVendorNumber()
java.lang.String | getRtvComments()
java.util.Set | getRtvItems()
java.lang.String | getRtvPrivateNotes()
java.lang.String | getShipAccount()
java.lang.String | getShipTo()
CustomerVendorAddressInfoVO | getShipToAddressInfo()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.math.BigDecimal | getSubTotal()
java.lang.String | getTerms()
java.math.BigDecimal | getTotalFreight()
java.math.BigDecimal | getTotalTax()
CustomerVendorAddressInfoVO | getVendorAddressInfo()
java.lang.String | getVendorId()
int | hashCode()
void | setActual(java.util.Date actual)
void | setAdate(java.util.Date adate)
void | setApDisc(java.math.BigDecimal apDisc)
void | setApGl1Recorded(java.math.BigDecimal apGl1Recorded)
void | setApGl2Paid(java.math.BigDecimal apGl2Paid)
void | setApNet(java.math.BigDecimal apNet)
void | setApNetSet(java.lang.String apNetSet)
void | setApOpen(java.math.BigDecimal apOpen)
void | setApPaidGl(java.math.BigDecimal apPaidGl)
void | setApPaidRcv(java.math.BigDecimal apPaidRcv)
void | setApprovedBy(java.lang.String approvedBy)
void | setApprovedDate(java.util.Date approvedDate)
void | setApRcvd(java.math.BigDecimal apRcvd)
void | setApTaxSet(java.lang.String apTaxSet)
void | setBb2ShipperItems(java.util.List<RtvShipperItemListResult> bb2ShipperItems)
void | setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | setBillToId(java.lang.String billToId)
void | setBp(java.lang.String bp)
void | setBuyer(java.lang.String buyer)
void | setBuyor(java.lang.String buyor)
void | setBuyorGroup(java.lang.String buyorGroup)
void | setCarrier(java.lang.String carrier)
void | setCarrierAccount(java.lang.String carrierAccount)
void | setChangeOrder(java.lang.String changeOrder)
void | setCoComments(java.lang.String coComments)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setContact(java.lang.String contact)
void | setCurrency(java.lang.String currency)
void | setDateEntered(java.util.Date dateEntered)
void | setDateRequired(java.util.Date dateRequired)
void | setDebitAccount(java.lang.String debitAccount)
void | setDelayDays(byte delayDays)
void | setEnterBy(java.lang.String enterBy)
void | setGrantTotal(java.math.BigDecimal grantTotal)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTimes(java.lang.Integer lastChangeTimes)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLocate(java.lang.String locate)
void | setOrigin(java.lang.String origin)
void | setOriginal(java.util.Date original)
void | setPo(java.lang.String po)
void | setPriority(java.lang.String priority)
void | setProject(java.lang.String project)
void | setReldoc(java.lang.String reldoc)
void | setRequestor(java.lang.String requestor)
void | setReturnToVendorNumber(java.lang.String returnToVendorNumber)
void | setRtvComments(java.lang.String rtvComments)
void | setRtvItems(java.util.Set rtvItems)
void | setRtvPrivateNotes(java.lang.String rtvPrivateNotes)
void | setShipAccount(java.lang.String shipAccount)
void | setShipTo(java.lang.String shipTo)
void | setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setSubTotal(java.math.BigDecimal subTotal)
void | setTerms(java.lang.String terms)
void | setTotalFreight(java.math.BigDecimal totalFreight)
void | setTotalTax(java.math.BigDecimal totalTax)
void | setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)
void | setVendorId(java.lang.String vendorId)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ReturnToVendorVO

public ReturnToVendorVO()
default constructor

Method Detail

getReturnToVendorNumber

public java.lang.String getReturnToVendorNumber()

setReturnToVendorNumber

public void setReturnToVendorNumber(java.lang.String returnToVendorNumber)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getApNetSet

public java.lang.String getApNetSet()

setApNetSet

public void setApNetSet(java.lang.String apNetSet)

getApTaxSet

public java.lang.String getApTaxSet()

setApTaxSet

public void setApTaxSet(java.lang.String apTaxSet)

getSubTotal

public java.math.BigDecimal getSubTotal()

setSubTotal

public void setSubTotal(java.math.BigDecimal subTotal)

getApDisc

public java.math.BigDecimal getApDisc()

setApDisc

public void setApDisc(java.math.BigDecimal apDisc)

getApNet

public java.math.BigDecimal getApNet()

setApNet

public void setApNet(java.math.BigDecimal apNet)

getApRcvd

public java.math.BigDecimal getApRcvd()

setApRcvd

public void setApRcvd(java.math.BigDecimal apRcvd)

getApOpen

public java.math.BigDecimal getApOpen()

setApOpen

public void setApOpen(java.math.BigDecimal apOpen)

getTotalTax

public java.math.BigDecimal getTotalTax()

setTotalTax

public void setTotalTax(java.math.BigDecimal totalTax)

getTotalFreight

public java.math.BigDecimal getTotalFreight()

setTotalFreight

public void setTotalFreight(java.math.BigDecimal totalFreight)

getGrantTotal

public java.math.BigDecimal getGrantTotal()

setGrantTotal

public void setGrantTotal(java.math.BigDecimal grantTotal)

getApPaidRcv

public java.math.BigDecimal getApPaidRcv()

setApPaidRcv

public void setApPaidRcv(java.math.BigDecimal apPaidRcv)

getApPaidGl

public java.math.BigDecimal getApPaidGl()

setApPaidGl

public void setApPaidGl(java.math.BigDecimal apPaidGl)

getApGl1Recorded

public java.math.BigDecimal getApGl1Recorded()

setApGl1Recorded

public void setApGl1Recorded(java.math.BigDecimal apGl1Recorded)

getApGl2Paid

public java.math.BigDecimal getApGl2Paid()

setApGl2Paid

public void setApGl2Paid(java.math.BigDecimal apGl2Paid)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getBillToId

public java.lang.String getBillToId()

setBillToId

public void setBillToId(java.lang.String billToId)

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getPo

public java.lang.String getPo()

setPo

public void setPo(java.lang.String po)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getApprovedDate

public java.util.Date getApprovedDate()

setApprovedDate

public void setApprovedDate(java.util.Date approvedDate)

getApprovedBy

public java.lang.String getApprovedBy()

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)

getDateRequired

public java.util.Date getDateRequired()

setDateRequired

public void setDateRequired(java.util.Date dateRequired)

getDelayDays

public byte getDelayDays()

setDelayDays

public void setDelayDays(byte delayDays)

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getOriginal

public java.util.Date getOriginal()

setOriginal

public void setOriginal(java.util.Date original)

getActual

public java.util.Date getActual()

setActual

public void setActual(java.util.Date actual)

getShipTo

public java.lang.String getShipTo()

setShipTo

public void setShipTo(java.lang.String shipTo)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAccount

public java.lang.String getCarrierAccount()

setCarrierAccount

public void setCarrierAccount(java.lang.String carrierAccount)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getShipAccount

public java.lang.String getShipAccount()

setShipAccount

public void setShipAccount(java.lang.String shipAccount)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getDateEntered

public java.util.Date getDateEntered()

setDateEntered

public void setDateEntered(java.util.Date dateEntered)

getBuyor

public java.lang.String getBuyor()

setBuyor

public void setBuyor(java.lang.String buyor)

getBuyorGroup

public java.lang.String getBuyorGroup()

setBuyorGroup

public void setBuyorGroup(java.lang.String buyorGroup)

getRequestor

public java.lang.String getRequestor()

setRequestor

public void setRequestor(java.lang.String requestor)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

getReldoc

public java.lang.String getReldoc()

setReldoc

public void setReldoc(java.lang.String reldoc)

getDebitAccount

public java.lang.String getDebitAccount()

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

getBp

public java.lang.String getBp()

setBp

public void setBp(java.lang.String bp)

getRtvComments

public java.lang.String getRtvComments()

setRtvComments

public void setRtvComments(java.lang.String rtvComments)

getRtvPrivateNotes

public java.lang.String getRtvPrivateNotes()

setRtvPrivateNotes

public void setRtvPrivateNotes(java.lang.String rtvPrivateNotes)

getBuyer

public java.lang.String getBuyer()

setBuyer

public void setBuyer(java.lang.String buyer)

getLastChangeTimes

public java.lang.Integer getLastChangeTimes()

setLastChangeTimes

public void setLastChangeTimes(java.lang.Integer lastChangeTimes)

setShipToAddressInfo

public void setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)

setBillToAddressInfo

public void setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)

getRtvItems

public java.util.Set getRtvItems()

getBillToAddressInfo

public CustomerVendorAddressInfoVO getBillToAddressInfo()

getShipToAddressInfo

public CustomerVendorAddressInfoVO getShipToAddressInfo()

getVendorAddressInfo

public CustomerVendorAddressInfoVO getVendorAddressInfo()

setRtvItems

public void setRtvItems(java.util.Set rtvItems)

setVendorAddressInfo

public void setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getBb2ShipperItems

public java.util.List<RtvShipperItemListResult> getBb2ShipperItems()

setBb2ShipperItems

public void setBb2ShipperItems(java.util.List<RtvShipperItemListResult> bb2ShipperItems)

getCoComments

public java.lang.String getCoComments()

setCoComments

public void setCoComments(java.lang.String coComments)

getEnterBy

public java.lang.String getEnterBy()

setEnterBy

public void setEnterBy(java.lang.String enterBy)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RfqMessageItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RfqMessageItemPK

java.lang.Object
    extended by  bb.common.RfqMessageItemPK
All Implemented Interfaces:
java.io.Serializable
public class RfqMessageItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
RfqMessageItemPK()
RfqMessageItemPK(java.lang.String rfqMessageNumber, java.lang.String itemNumber)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getItemNumber()
java.lang.String | getRfqMessageNumber()
int | hashCode()
void | setItemNumber(java.lang.String itemNumber)
void | setRfqMessageNumber(java.lang.String rfqMessageNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

RfqMessageItemPK

public RfqMessageItemPK()

RfqMessageItemPK

public RfqMessageItemPK(java.lang.String rfqMessageNumber,
                        java.lang.String itemNumber)
Method Detail

getItemNumber

public java.lang.String getItemNumber()

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

getRfqMessageNumber

public java.lang.String getRfqMessageNumber()

setRfqMessageNumber

public void setRfqMessageNumber(java.lang.String rfqMessageNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RfqMessageItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RfqMessageItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.RfqMessageItemVO
All Implemented Interfaces:
java.io.Serializable
public class RfqMessageItemVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
RfqMessageItemVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.math.BigDecimal | getCostPerUnit()
int | getDelay()
java.math.BigDecimal | getDiscount()
java.math.BigDecimal | getFreight()
int | getLeadTime()
RfqMessageItemPK | getPk()
RequestForQuoteItemVO | getRfqItem()
java.lang.String | getRfqNumber()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.math.BigDecimal | getTaxRate()
int | hashCode()
void | setComments(java.lang.String comments)
void | setCostPerUnit(java.math.BigDecimal costPerUnit)
void | setDelay(int delay)
void | setDiscount(java.math.BigDecimal discount)
void | setFreight(java.math.BigDecimal freight)
void | setLeadTime(int leadTime)
void | setPk(RfqMessageItemPK pk)
void | setRfqItem(RequestForQuoteItemVO rfqItem)
void | setRfqNumber(java.lang.String rfqNumber)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setTaxRate(java.math.BigDecimal taxRate)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

RfqMessageItemVO

public RfqMessageItemVO()
default constructor

Method Detail

getPk

public RfqMessageItemPK getPk()

setPk

public void setPk(RfqMessageItemPK pk)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getCostPerUnit

public java.math.BigDecimal getCostPerUnit()

setCostPerUnit

public void setCostPerUnit(java.math.BigDecimal costPerUnit)

getDelay

public int getDelay()

setDelay

public void setDelay(int delay)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getFreight

public java.math.BigDecimal getFreight()

setFreight

public void setFreight(java.math.BigDecimal freight)

getLeadTime

public int getLeadTime()

setLeadTime

public void setLeadTime(int leadTime)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getRfqItem

public RequestForQuoteItemVO getRfqItem()

setRfqItem

public void setRfqItem(RequestForQuoteItemVO rfqItem)

getRfqNumber

public java.lang.String getRfqNumber()

setRfqNumber

public void setRfqNumber(java.lang.String rfqNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RfqMessageListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RfqMessageListResult

java.lang.Object
    extended by  bb.common.RfqMessageListResult
All Implemented Interfaces:
java.io.Serializable
public class RfqMessageListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_RFQMESSAGENUMBER
static java.lang.String | ORDER_BY_RFQNUMBER
static java.lang.String | ORDER_BY_VENDORID
Constructor Summary
RfqMessageListResult()
Method Summary
java.lang.String | getComments()
java.util.Date | getRfqMessageDate()
java.lang.String | getRfqMessageNumber()
java.lang.String | getRfqNumber()
java.lang.String | getStatus()
java.lang.String | getValidateCode()
java.lang.String | getVendorId()
void | setComments(java.lang.String comments)
void | setRfqMessageDate(java.util.Date rfqMessageDate)
void | setRfqMessageNumber(java.lang.String rfqMessageNumber)
void | setRfqNumber(java.lang.String rfqNumber)
void | setStatus(java.lang.String status)
void | setValidateCode(java.lang.String validateCode)
void | setVendorId(java.lang.String vendorId)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_RFQMESSAGENUMBER

public static final java.lang.String ORDER_BY_RFQMESSAGENUMBER
See Also:
Constant Field Values

ORDER_BY_RFQNUMBER

public static final java.lang.String ORDER_BY_RFQNUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values
Constructor Detail

RfqMessageListResult

public RfqMessageListResult()
Method Detail

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getRfqMessageDate

public java.util.Date getRfqMessageDate()

setRfqMessageDate

public void setRfqMessageDate(java.util.Date rfqMessageDate)

getRfqMessageNumber

public java.lang.String getRfqMessageNumber()

setRfqMessageNumber

public void setRfqMessageNumber(java.lang.String rfqMessageNumber)

getRfqNumber

public java.lang.String getRfqNumber()

setRfqNumber

public void setRfqNumber(java.lang.String rfqNumber)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getValidateCode

public java.lang.String getValidateCode()

setValidateCode

public void setValidateCode(java.lang.String validateCode)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RfqMessageVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RfqMessageVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.RfqMessageVO
All Implemented Interfaces:
java.io.Serializable
public class RfqMessageVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
RfqMessageVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.util.Set | getItems()
java.util.Date | getRfqMessageDate()
java.lang.String | getRfqMessageNumber()
java.lang.String | getRfqNumber()
java.lang.String | getStatus()
java.lang.String | getValidateCode()
java.lang.String | getVendorId()
int | hashCode()
void | setComments(java.lang.String comments)
void | setItems(java.util.Set items)
void | setRfqMessageDate(java.util.Date rfqMessageDate)
void | setRfqMessageNumber(java.lang.String rfqMessageNumber)
void | setRfqNumber(java.lang.String rfqNumber)
void | setStatus(java.lang.String status)
void | setValidateCode(java.lang.String validateCode)
void | setVendorId(java.lang.String vendorId)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

RfqMessageVO

public RfqMessageVO()
Method Detail

getRfqMessageNumber

public java.lang.String getRfqMessageNumber()

setRfqMessageNumber

public void setRfqMessageNumber(java.lang.String rfqMessageNumber)

getRfqMessageDate

public java.util.Date getRfqMessageDate()

setRfqMessageDate

public void setRfqMessageDate(java.util.Date rfqMessageDate)

getRfqNumber

public java.lang.String getRfqNumber()

setRfqNumber

public void setRfqNumber(java.lang.String rfqNumber)

getValidateCode

public java.lang.String getValidateCode()

setValidateCode

public void setValidateCode(java.lang.String validateCode)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getItems

public java.util.Set getItems()

setItems

public void setItems(java.util.Set items)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


R-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M N O P Q R S T U V W X Y Z

R

R - Static variable in class bb.common.Constant.Prefix
R - Static variable in class bb.common.Constant.TransactionType
read(String) - Method in class bb.common.MessageVO
readByBytes(byte[]) - Static method in class bb.common.BB2Util
readMessage(Long) - Method in interface bb.common.box.CompanyBox
Reason - Class in bb.common
Reason(String) - Constructor for class bb.common.Reason
RebackInQAAgent - Class in bb.common
RebackInQAAgent() - Constructor for class bb.common.RebackInQAAgent
rebackInQAtoWareHouse(HashSet<RebackInQAAgent>) - Method in interface bb.common.box.WarehouseBox
RECEIPT_ORDER - Static variable in class bb.common.Constant.PosOrderType
RECEIVE_ITEM_DOSE_NOT_EXIST_IN_WO_PART_DETAIL - Static variable in class bb.common.BIZReason
RECEIVE_QTY_IS_NOT_SAME_WITH_WO_PART_DETAIL_QTY - Static variable in class bb.common.BIZReason
RECEIVE_QTY_IS_OVER_THAN_RMA_ITEM_ORDERED - Static variable in class bb.common.BIZReason
RECEIVE_TO_WRONG_WAREHOUSE - Static variable in class bb.common.BIZReason
RECEIVED - Static variable in class bb.common.Constant.CheckType
Received - Static variable in class bb.common.Constant.Status
RECEIVED_TOTAL_IS_NOT_EAUAL - Static variable in class bb.common.BIZReason
RECEIVEDDATE - Static variable in class bb.common.Constant.DateType
ReceivedToOrderItem - Class in bb.common
ReceivedToOrderItem() - Constructor for class bb.common.ReceivedToOrderItem
RECEIVEGL - Static variable in class bb.common.Constant.GLType
receivePaymentFromPaymentRunExecuter(String) - Method in interface bb.common.box.AccountingBox
RECEIVER - Static variable in class bb.common.BizTarget
RECEIVER - Static variable in class bb.common.Constant.OrderType
RECEIVER - Static variable in class bb.common.Constant.PrintTemplateType
RECEIVER_HAS_BEEN_CLOSED - Static variable in class bb.common.BIZReason
RECEIVER_HAS_EXIST - Static variable in class bb.common.BIZReason
RECEIVER_IS_NOT_FOR_THIS_PO - Static variable in class bb.common.BIZReason
RECEIVER_ITEM - Static variable in class bb.common.BizTarget
RECEIVER_ITEM_AGENT - Static variable in class bb.common.BizTarget
RECEIVER_ITEM_HAS_BEEN_CLOSED - Static variable in class bb.common.BIZReason
RECEIVER_ITEM_HAS_BEEN_CREATED_AP - Static variable in class bb.common.BIZReason
RECEIVER_ITEM_HAS_EXIST - Static variable in class bb.common.BIZReason
RECEIVER_ITEM_NOT_EXIST - Static variable in class bb.common.BIZReason
RECEIVER_NOT_EXIST - Static variable in class bb.common.BIZReason
RECEIVER_QTY_CAN_NOT_BE_CHANGED - Static variable in class bb.common.BIZReason
RECEIVER_REF_DOC_NUMBER_CAN_NOT_BE_CHANGED - Static variable in class bb.common.BIZReason
RECEIVER_WORK_ORDER - Static variable in class bb.common.BizTarget
ReceiverAgent - Class in bb.common
ReceiverAgent() - Constructor for class bb.common.ReceiverAgent
ReceiverInfoVO - Class in bb.common
ReceiverInfoVO(String, String, String, String, String, Date, Date, String, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, String, String, String, String, Date, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, BigDecimal, String, String, BigDecimal, Date, Date, Date, String, BigDecimal, String, String, int, CustomerVendorAddressInfoVO) - Constructor for class bb.common.ReceiverInfoVO
full constructor
ReceiverInfoVO() - Constructor for class bb.common.ReceiverInfoVO
default constructor
ReceiverInfoVO(String, String) - Constructor for class bb.common.ReceiverInfoVO
minimal constructor
ReceiverItemAgent - Class in bb.common
ReceiverItemAgent() - Constructor for class bb.common.ReceiverItemAgent
ReceiverItemDetailAgent - Class in bb.common
ReceiverItemDetailAgent() - Constructor for class bb.common.ReceiverItemDetailAgent
ReceiverItemManufacturerPK - Class in bb.common
ReceiverItemManufacturerPK() - Constructor for class bb.common.ReceiverItemManufacturerPK
ReceiverItemManufacturerPK(String, String, Short) - Constructor for class bb.common.ReceiverItemManufacturerPK
ReceiverItemManufacturerVO - Class in bb.common
ReceiverItemManufacturerVO() - Constructor for class bb.common.ReceiverItemManufacturerVO
ReceiverItemPK - Class in bb.common
ReceiverItemPK() - Constructor for class bb.common.ReceiverItemPK
ReceiverItemPK(String, String) - Constructor for class bb.common.ReceiverItemPK
ReceiverItemTrackingLogAgent - Class in bb.common
ReceiverItemTrackingLogAgent() - Constructor for class bb.common.ReceiverItemTrackingLogAgent
ReceiverItemVO - Class in bb.common
ReceiverItemVO() - Constructor for class bb.common.ReceiverItemVO
ReceiverShipAgent - Class in bb.common
ReceiverShipAgent() - Constructor for class bb.common.ReceiverShipAgent
ReceiverVO - Class in bb.common
ReceiverVO() - Constructor for class bb.common.ReceiverVO
RECEIVING_DWO - Static variable in class bb.common.Constant.TrackingNumberType
RECEIVING_NCR - Static variable in class bb.common.Constant.TrackingNumberType
RECEIVING_ONLOAN - Static variable in class bb.common.Constant.TrackingNumberType
RECEIVING_PO - Static variable in class bb.common.Constant.TrackingNumberType
RECEIVING_RMA - Static variable in class bb.common.Constant.TrackingNumberType
RECEIVING_SWAP_ORDER - Static variable in class bb.common.Constant.TrackingNumberType
RECEIVING_TRANSFER_ORDER - Static variable in class bb.common.Constant.TrackingNumberType
RECEIVING_WO - Static variable in class bb.common.Constant.TrackingNumberType
ReceivingItemResult - Class in bb.common
ReceivingItemResult() - Constructor for class bb.common.ReceivingItemResult
ReceivingResult - Class in bb.common
ReceivingResult() - Constructor for class bb.common.ReceivingResult
RECIEVE - Static variable in class bb.common.Constant.NoticeAction
RecoilLocationSpecial - Static variable in class bb.common.Constant
RECORD - Static variable in class bb.common.Constant.DataFilterType
RECURSIVE_BILL - Static variable in class bb.common.Constant
RECURSIVE_BOM_NOT_ALLOWED - Static variable in class bb.common.BIZReason
RecursiveBillPath - Class in bb.common
RecursiveBillPath() - Constructor for class bb.common.RecursiveBillPath
RecursiveBillPath(PartPK) - Constructor for class bb.common.RecursiveBillPath
REF_DOC_CLOSED - Static variable in class bb.common.BIZReason
REF_DOC_HAS_EXIST - Static variable in class bb.common.BIZReason
REF_DOC_LINK_TO_NOT_EXIST_ORDER - Static variable in class bb.common.BIZReason
REF_DOC_NOT_EXIST - Static variable in class bb.common.BIZReason
REF_DOC_TOTAL_QTY_MORE_THAN_QTY_OF_FROM_ORDER - Static variable in class bb.common.BIZReason
REF_DOC_TOTAL_QTY_MORE_THAN_QTY_OF_TO_ORDER - Static variable in class bb.common.BIZReason
REFDOC - Static variable in class bb.common.Constant.NaRecTo
RefdocElement - Class in bb.common
RefdocElement() - Constructor for class bb.common.RefdocElement
RefdocVO - Class in bb.common
RefdocVO(String, String, String, String, BigDecimal, String, Date, Integer, short) - Constructor for class bb.common.RefdocVO
full constructor
RefdocVO() - Constructor for class bb.common.RefdocVO
default constructor
REFERENCE_DOC - Static variable in class bb.common.BizTarget
refresh(int) - Method in class bb.common.IssueItemAgent
refresh() - Method in class bb.common.ReceiverAgent
refresh() - Method in class bb.common.ReceiverItemAgent
refresh() - Method in class bb.common.ShipperAgent
refresh() - Method in class bb.common.ShipperItemAgent
refreshChangeStdCostWorkSheetItemStdCostAndOnhand(Long) - Method in interface bb.common.box.AccountingBox
refreshProformaInvoice(ProformaInvoiceVO) - Method in interface bb.common.box.WarehouseBox
Refused - Static variable in class bb.common.Constant.Status
refusePoMessage(String, String, Hashtable, boolean) - Method in interface bb.common.box.PurchasingBox
refuseRfqMessage(String, String, Hashtable, boolean, boolean) - Method in interface bb.common.box.PurchasingBox
region - Variable in class bb.common.SalesOrderItemListResult
Reject - Static variable in class bb.common.Constant.Status
REJECT_ORDER - Static variable in class bb.common.Constant.PosOrderType
reloadServer() - Method in interface bb.common.box.CompanyBox
remove(String) - Method in class bb.common.PackingBoxSalesOrderItemAgent
remove(String) - Method in class bb.common.PackingBoxSalesOrderItemResult
removeAppProperty(String) - Method in interface bb.common.box.CompanyBox
removeItem(WorkOrderWorkInstructionSequencePK) - Method in class bb.common.POForWISeqAgent
removeItem(String) - Method in class bb.common.WCLoadAgent
removeLastComma(String) - Static method in class bb.common.BB2Util
removeList(List<Object>) - Method in class bb.common.ListCache
removeMessage(Long) - Method in interface bb.common.box.CompanyBox
removeOldMessages(Date) - Method in interface bb.common.box.CompanyBox
removeProformaInvoiceItem(ProformaInvoiceItemPK) - Method in interface bb.common.box.WarehouseBox
removeRoleFromUser(String, String) - Method in interface bb.common.box.SecurityBox
removeSalesOrderItemToPackingBox(PackingBoxItemPK) - Method in interface bb.common.box.WarehouseBox
replaceBuyerCode(String, String) - Method in interface bb.common.box.CompanyBox
REPLACEMENT_PART_ITEMS_ERROR - Static variable in class bb.common.BIZReason
replacePartForBOM(ArrayList<BillPK>, PartPK, PartPK) - Method in interface bb.common.box.EngineeringBox
replaceString(String, String) - Static method in class bb.common.BB2Util
REQUEST_FOR_CHANGE - Static variable in class bb.common.BizTarget
REQUEST_FOR_QUOTE - Static variable in class bb.common.BizTarget
REQUEST_FOR_QUOTE_ITEM - Static variable in class bb.common.BizTarget
REQUEST_FOR_QUOTE_ITEM_MANUFACTURER - Static variable in class bb.common.BizTarget
REQUEST_FOR_QUOTE_ITEM_NOT_EXIST - Static variable in class bb.common.BIZReason
REQUEST_FOR_QUOTE_NOT_EXIST - Static variable in class bb.common.BIZReason
REQUESTDATE - Static variable in class bb.common.Constant.DateType
RequestForQuoteCheckListResult - Class in bb.common
RequestForQuoteCheckListResult() - Constructor for class bb.common.RequestForQuoteCheckListResult
RequestForQuoteItemListResult - Class in bb.common
RequestForQuoteItemListResult() - Constructor for class bb.common.RequestForQuoteItemListResult
RequestForQuoteItemManufacturerPK - Class in bb.common
RequestForQuoteItemManufacturerPK() - Constructor for class bb.common.RequestForQuoteItemManufacturerPK
RequestForQuoteItemManufacturerVO - Class in bb.common
RequestForQuoteItemManufacturerVO() - Constructor for class bb.common.RequestForQuoteItemManufacturerVO
RequestForQuoteItemPK - Class in bb.common
RequestForQuoteItemPK() - Constructor for class bb.common.RequestForQuoteItemPK
RequestForQuoteItemPK(String, String) - Constructor for class bb.common.RequestForQuoteItemPK
RequestForQuoteItemVO - Class in bb.common
RequestForQuoteItemVO() - Constructor for class bb.common.RequestForQuoteItemVO
RequestForQuoteListResult - Class in bb.common
RequestForQuoteListResult() - Constructor for class bb.common.RequestForQuoteListResult
RequestForQuoteVO - Class in bb.common
RequestForQuoteVO() - Constructor for class bb.common.RequestForQuoteVO
RequestForRMAItemPK - Class in bb.common
RequestForRMAItemPK(String, String) - Constructor for class bb.common.RequestForRMAItemPK
RequestForRMAItemPK() - Constructor for class bb.common.RequestForRMAItemPK
RequestForRMAItemVO - Class in bb.common
RequestForRMAItemVO() - Constructor for class bb.common.RequestForRMAItemVO
default constructor
RequestForRMAItemVO(RequestForRMAItemPK, String, String, String) - Constructor for class bb.common.RequestForRMAItemVO
minimal constructor
RequestForRMAVO - Class in bb.common
RequestForRMAVO() - Constructor for class bb.common.RequestForRMAVO
REQUESTINSPECTION - Static variable in class bb.common.Constant.Status
requestInspectionForOperatingInstructions(OperatingInstructionsVO) - Method in interface bb.common.box.ManufacturingBox
resetBB2PartAvgCost(BB2Part) - Method in interface bb.common.box.EngineeringBox
resetMainPartPicture(Long) - Method in interface bb.common.box.EngineeringBox
resetSgClientProgramPassword(String) - Method in interface bb.common.box.AddressBox
resetUserCompanyUnitId(String) - Method in interface bb.common.box.SecurityBox
resetVendorGroupPassword(String) - Method in interface bb.common.box.AddressBox
restrictValue(BigDecimal, BigDecimal, BigDecimal) - Static method in class bb.common.BB2Util
restrictValue(BigDecimal) - Static method in class bb.common.BB2Util
restrictValue(BigDecimal, int) - Static method in class bb.common.BB2Util
RETURN_ADDRESS_ID_TO_ID_IS_NOT_EXIST - Static variable in class bb.common.BIZReason
RETURN_MATERIAL_AUTHORIZATION_ITEM_MANUFACTURER - Static variable in class bb.common.BizTarget
RETURN_TO_VENDOR - Static variable in class bb.common.BizTarget
RETURN_TO_VENDOR_ITEM - Static variable in class bb.common.BizTarget
RETURN_TO_VENDOR_ITEM_MANUFACTURER - Static variable in class bb.common.BizTarget
RETURN_TO_VENDOR_ITEM_NOT_EXIST - Static variable in class bb.common.BIZReason
RETURN_TO_VENDOR_NOT_EXIST - Static variable in class bb.common.BIZReason
ReturnMaterialAuthorizationDocumentVO - Class in bb.common
ReturnMaterialAuthorizationDocumentVO() - Constructor for class bb.common.ReturnMaterialAuthorizationDocumentVO
default constructor
ReturnMaterialAuthorizationItemManufacturerPK - Class in bb.common
ReturnMaterialAuthorizationItemManufacturerPK() - Constructor for class bb.common.ReturnMaterialAuthorizationItemManufacturerPK
ReturnMaterialAuthorizationItemManufacturerVO - Class in bb.common
ReturnMaterialAuthorizationItemManufacturerVO() - Constructor for class bb.common.ReturnMaterialAuthorizationItemManufacturerVO
default constructor
ReturnMaterialAuthorizationItemPK - Class in bb.common
ReturnMaterialAuthorizationItemPK(String, String) - Constructor for class bb.common.ReturnMaterialAuthorizationItemPK
full constructor
ReturnMaterialAuthorizationItemPK() - Constructor for class bb.common.ReturnMaterialAuthorizationItemPK
default constructor
ReturnMaterialAuthorizationItemVO - Class in bb.common
ReturnMaterialAuthorizationItemVO() - Constructor for class bb.common.ReturnMaterialAuthorizationItemVO
ReturnMaterialAuthorizationVO - Class in bb.common
ReturnMaterialAuthorizationVO() - Constructor for class bb.common.ReturnMaterialAuthorizationVO
ReturnToVendorByDateListResult - Class in bb.common
ReturnToVendorByDateListResult() - Constructor for class bb.common.ReturnToVendorByDateListResult
ReturnToVendorCheckListResult - Class in bb.common
ReturnToVendorCheckListResult() - Constructor for class bb.common.ReturnToVendorCheckListResult
ReturnToVendorItemListResult - Class in bb.common
ReturnToVendorItemListResult() - Constructor for class bb.common.ReturnToVendorItemListResult
ReturnToVendorItemManufacturerPK - Class in bb.common
ReturnToVendorItemManufacturerPK() - Constructor for class bb.common.ReturnToVendorItemManufacturerPK
ReturnToVendorItemManufacturerVO - Class in bb.common
ReturnToVendorItemManufacturerVO() - Constructor for class bb.common.ReturnToVendorItemManufacturerVO
default constructor
ReturnToVendorItemPK - Class in bb.common
ReturnToVendorItemPK(String, String) - Constructor for class bb.common.ReturnToVendorItemPK
full constructor
ReturnToVendorItemPK() - Constructor for class bb.common.ReturnToVendorItemPK
default constructor
ReturnToVendorItemVO - Class in bb.common
ReturnToVendorItemVO() - Constructor for class bb.common.ReturnToVendorItemVO
ReturnToVendorListResult - Class in bb.common
ReturnToVendorListResult() - Constructor for class bb.common.ReturnToVendorListResult
ReturnToVendorVO - Class in bb.common
ReturnToVendorVO() - Constructor for class bb.common.ReturnToVendorVO
default constructor
reverseRelatedInspectorSign(String, String) - Method in interface bb.common.box.ManufacturingBox
reverseResultSign(String) - Method in interface bb.common.box.ManufacturingBox
reverseStaffSign(String, String) - Method in interface bb.common.box.ManufacturingBox
REVIEW - Static variable in class bb.common.Constant.NoticeAction
REVIEW_SO - Static variable in class bb.common.Constant.SystemUserGroup
Reviewed - Static variable in class bb.common.Constant.Status
reviewEngineeringSharingImportLog(EngineeringSharingImportLogVO) - Method in interface bb.common.box.EngineeringBox
reviewOnLoan(OnLoanVO) - Method in interface bb.common.box.WarehouseBox
reviewQuote(String) - Method in interface bb.common.box.SalesBox
reviewRma(ReturnMaterialAuthorizationVO) - Method in interface bb.common.box.SalesBox
reviewRrma(RequestForRMAVO) - Method in interface bb.common.box.SalesBox
reviewSalesOrder(SalesOrderVO) - Method in interface bb.common.box.SalesBox
reviewWorkOrderItemCost(WorkOrderItemPK, String) - Method in interface bb.common.box.WorkOrderBox
RFQ - Static variable in class bb.common.Constant.PrintTemplateType
RFQ_MESSAGE - Static variable in class bb.common.BizTarget
RFQ_MESSAGE_HAS_EXIST - Static variable in class bb.common.BIZReason
RFQ_MESSAGE_ITEM - Static variable in class bb.common.BizTarget
RFQ_MESSAGE_NOT_EXIST - Static variable in class bb.common.BIZReason
RFQDATE - Static variable in class bb.common.Constant.DateType
RfqMessageItemPK - Class in bb.common
RfqMessageItemPK() - Constructor for class bb.common.RfqMessageItemPK
RfqMessageItemPK(String, String) - Constructor for class bb.common.RfqMessageItemPK
RfqMessageItemVO - Class in bb.common
RfqMessageItemVO() - Constructor for class bb.common.RfqMessageItemVO
default constructor
RfqMessageListResult - Class in bb.common
RfqMessageListResult() - Constructor for class bb.common.RfqMessageListResult
RfqMessageVO - Class in bb.common
RfqMessageVO() - Constructor for class bb.common.RfqMessageVO
rightTrim(String, String) - Static method in class bb.common.BB2Util
RMA - Static variable in class bb.common.BizTarget
RMA - Static variable in class bb.common.Constant.Prefix
RMA_ALREADY_REVIEWED - Static variable in class bb.common.BIZReason
RMA_DEBIT_ACCOUNT_IS_NOT_CONFIGURED - Static variable in class bb.common.BIZReason
RMA_DOC - Static variable in class bb.common.BizTarget
RMA_DOC - Static variable in class bb.common.Constant.MiscDocType
RMA_DOC_NOT_FIND - Static variable in class bb.common.BIZReason
RMA_HAS_EXIST - Static variable in class bb.common.BIZReason
RMA_ITEM - Static variable in class bb.common.BizTarget
RMA_ITEM_HAS_EXIST - Static variable in class bb.common.BIZReason
RMA_ITEM_NOT_EXIST - Static variable in class bb.common.BIZReason
RMA_NOT_EXIST - Static variable in class bb.common.BIZReason
RMA_NOT_REVIEWED - Static variable in class bb.common.BIZReason
RMA_ORDER_ITEM_ALREADY_RECEIVED - Static variable in class bb.common.BIZReason
RMA_PK_WRONG - Static variable in class bb.common.BIZReason
RMA_RECEIVER - Static variable in class bb.common.BizTarget
RMA_RECEIVER_HAS_HAVED_CREDITMEMO - Static variable in class bb.common.BIZReason
RMA_RECEIVER_ITEM - Static variable in class bb.common.BizTarget
RMA_RECEIVER_NOT_EXIST - Static variable in class bb.common.BIZReason
RMA_REVIEW - Static variable in class bb.common.BizTarget
RMA_REVIEW_ALREADY_EXIST - Static variable in class bb.common.BIZReason
RMA_REVIEW_NOT_EXIST - Static variable in class bb.common.BIZReason
RMAItemListResult - Class in bb.common
RMAItemListResult() - Constructor for class bb.common.RMAItemListResult
RMAListResult - Class in bb.common
RMAListResult() - Constructor for class bb.common.RMAListResult
RMAR - Static variable in class bb.common.Constant.Prefix
RMARECEIVER - Static variable in class bb.common.Constant.PrintTemplateType
RMAReceiverItemListResult - Class in bb.common
RMAReceiverItemListResult() - Constructor for class bb.common.RMAReceiverItemListResult
RMAReceiverItemPK - Class in bb.common
RMAReceiverItemPK(String, String) - Constructor for class bb.common.RMAReceiverItemPK
full constructor
RMAReceiverItemPK() - Constructor for class bb.common.RMAReceiverItemPK
default constructor
RMAReceiverItemVO - Class in bb.common
RMAReceiverItemVO() - Constructor for class bb.common.RMAReceiverItemVO
RMAReceiverListResult - Class in bb.common
RMAReceiverListResult() - Constructor for class bb.common.RMAReceiverListResult
RMAReceiverResult - Class in bb.common
RMAReceiverResult() - Constructor for class bb.common.RMAReceiverResult
RMAReceiverVO - Class in bb.common
RMAReceiverVO() - Constructor for class bb.common.RMAReceiverVO
RMAReviewVO - Class in bb.common
RMAReviewVO() - Constructor for class bb.common.RMAReviewVO
RN - Static variable in class bb.common.Constant.ChartOfAccountType
RO - Static variable in class bb.common.Constant.ChartOfAccountType
RoleDescriptionPK - Class in bb.common
RoleDescriptionPK() - Constructor for class bb.common.RoleDescriptionPK
default constructor
RoleDescriptionVO - Class in bb.common
RoleDescriptionVO() - Constructor for class bb.common.RoleDescriptionVO
RoleId - Variable in class bb.common.RoleListResult
RoleListResult - Class in bb.common
RoleListResult() - Constructor for class bb.common.RoleListResult
RolePermissionPK - Class in bb.common
RolePermissionPK(String, String) - Constructor for class bb.common.RolePermissionPK
full constructor
RolePermissionPK() - Constructor for class bb.common.RolePermissionPK
default constructor
RolePermissionVO - Class in bb.common
RolePermissionVO(RolePermissionPK) - Constructor for class bb.common.RolePermissionVO
full constructor
RolePermissionVO() - Constructor for class bb.common.RolePermissionVO
default constructor
RoleVO - Class in bb.common
RoleVO() - Constructor for class bb.common.RoleVO
default constructor
RoleVO(String, Set) - Constructor for class bb.common.RoleVO
minimal constructor
ROLL_UP_BOM_STD_COST_WORKSHEET - Static variable in class bb.common.BizTarget
ROLL_UP_BOM_STD_COST_WORKSHEET_NOT_EXIST - Static variable in class bb.common.BIZReason
RollUpBomStdCostWorkSheetItemPK - Class in bb.common
RollUpBomStdCostWorkSheetItemPK() - Constructor for class bb.common.RollUpBomStdCostWorkSheetItemPK
RollUpBomStdCostWorkSheetItemPK(Long, String, String) - Constructor for class bb.common.RollUpBomStdCostWorkSheetItemPK
RollUpBomStdCostWorkSheetItemVO - Class in bb.common
RollUpBomStdCostWorkSheetItemVO() - Constructor for class bb.common.RollUpBomStdCostWorkSheetItemVO
RollUpBomStdCostWorkSheetVO - Class in bb.common
RollUpBomStdCostWorkSheetVO() - Constructor for class bb.common.RollUpBomStdCostWorkSheetVO
rollUpCashFlowBudget(String, String, String) - Method in interface bb.common.box.AccountingBox
rollUpFiscalYearBudget(String, String) - Method in interface bb.common.box.AccountingBox
rollupPartStandardCost(PartPK) - Method in interface bb.common.box.EngineeringBox
RollUPPartStandardCostResult - Class in bb.common
RollUPPartStandardCostResult() - Constructor for class bb.common.RollUPPartStandardCostResult
RRMA - Static variable in class bb.common.BizTarget
RRMA - Static variable in class bb.common.Constant.Prefix
RRMA_ALREADY_REVIEWED - Static variable in class bb.common.BIZReason
RRMA_CUSTOMERID_NOT_MATCH - Static variable in class bb.common.BIZReason
RRMA_ITEM - Static variable in class bb.common.BizTarget
RRMA_NOT_EXIST - Static variable in class bb.common.BIZReason
RRMA_NOT_OPEN - Static variable in class bb.common.BIZReason
RRMA_PK_WRONG - Static variable in class bb.common.BIZReason
RRMAItemListResult - Class in bb.common
RRMAItemListResult() - Constructor for class bb.common.RRMAItemListResult
RRMAListResult - Class in bb.common
RRMAListResult() - Constructor for class bb.common.RRMAListResult
RT - Static variable in class bb.common.Constant.Prefix
RT - Static variable in class bb.common.Constant.PrintTemplateType
RTV - Static variable in class bb.common.Constant.Prefix
RTV_APPROVAL - Static variable in class bb.common.BizTarget
RTV_APPROVAL_ALREADY_EXIST - Static variable in class bb.common.BIZReason
RTV_APPROVAL_NOT_EXIST - Static variable in class bb.common.BIZReason
RTV_ITEM_ALREADY_SHIPPER - Static variable in class bb.common.BIZReason
RTV_ORDER_ITEM_ALREADY_SHIPPED - Static variable in class bb.common.BIZReason
RTV_SHIPPER - Static variable in class bb.common.BizTarget
RTV_SHIPPER_NOT_EXIST - Static variable in class bb.common.BIZReason
RTVApprovalVO - Class in bb.common
RTVApprovalVO() - Constructor for class bb.common.RTVApprovalVO
RTVSH - Static variable in class bb.common.Constant.Prefix
RTVSHIPPER - Static variable in class bb.common.Constant.PrintTemplateType
RtvShipperInfoVO - Class in bb.common
RtvShipperInfoVO() - Constructor for class bb.common.RtvShipperInfoVO
default constructor
RtvShipperItemListResult - Class in bb.common
RtvShipperItemListResult() - Constructor for class bb.common.RtvShipperItemListResult
RtvShipperItemPK - Class in bb.common
RtvShipperItemPK(String, String) - Constructor for class bb.common.RtvShipperItemPK
full constructor
RtvShipperItemPK() - Constructor for class bb.common.RtvShipperItemPK
default constructor
RtvShipperItemVO - Class in bb.common
RtvShipperItemVO() - Constructor for class bb.common.RtvShipperItemVO
default constructor
RtvShipperListResult - Class in bb.common
RtvShipperListResult() - Constructor for class bb.common.RtvShipperListResult
RtvShipperVO - Class in bb.common
RtvShipperVO() - Constructor for class bb.common.RtvShipperVO
Run - Static variable in class bb.common.Constant.Status
RUNNING - Static variable in class bb.common.Constant.Status
RUNNING_ACCOUNT_ORDER - Static variable in class bb.common.BizTarget
RunningAccountOrderItemPK - Class in bb.common
RunningAccountOrderItemPK() - Constructor for class bb.common.RunningAccountOrderItemPK
RunningAccountOrderItemPK(String, String) - Constructor for class bb.common.RunningAccountOrderItemPK
RunningAccountOrderItemResult - Class in bb.common
RunningAccountOrderItemResult() - Constructor for class bb.common.RunningAccountOrderItemResult
RunningAccountOrderItemVO - Class in bb.common
RunningAccountOrderItemVO() - Constructor for class bb.common.RunningAccountOrderItemVO
RunningAccountOrderVO - Class in bb.common
RunningAccountOrderVO() - Constructor for class bb.common.RunningAccountOrderVO
RunTaxPaymentResult - Class in bb.common
RunTaxPaymentResult() - Constructor for class bb.common.RunTaxPaymentResult
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M N O P Q R S T U V W X Y Z


RMAItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RMAItemListResult

java.lang.Object
    extended by  bb.common.RMAItemListResult
All Implemented Interfaces:
java.io.Serializable
public class RMAItemListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_COMPANYUNITID
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_DEBITACCOUNT
static java.lang.String | ORDER_BY_DELIVERYDATE
static java.lang.String | ORDER_BY_INVOICENUMBER
static java.lang.String | ORDER_BY_ITEMDESCRIPTION
static java.lang.String | ORDER_BY_NCRNUMBER
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_RMADATE
static java.lang.String | ORDER_BY_RMANUMBER
static java.lang.String | ORDER_BY_SALESORDERNUMBER
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
RMAItemListResult()
Method Summary
java.lang.String | getCompanyUnitId()
java.math.BigDecimal | getCostPerUnit()
java.lang.String | getCustomerId()
java.lang.String | getDebitAccount()
java.util.Date | getDeliveryDate()
java.math.BigDecimal | getDiscount()
java.lang.String | getInvoiceNumber()
java.lang.String | getItemDescription()
java.lang.String | getNcrNumber()
java.math.BigDecimal | getOnDemandQty()
java.math.BigDecimal | getOnhandQty()
java.math.BigDecimal | getOnorderQty()
java.math.BigDecimal | getOrderedQty()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.math.BigDecimal | getReceivedQty()
java.util.Date | getRmaDate()
java.lang.String | getRmaItemNumber()
java.lang.String | getRmaNumber()
java.lang.String | getSalesman()
java.lang.String | getSalesOrderNumber()
java.lang.String | getStatus()
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCostPerUnit(java.math.BigDecimal costPerUnit)
void | setCustomerId(java.lang.String customerId)
void | setDebitAccount(java.lang.String debitAccount)
void | setDeliveryDate(java.util.Date deliveryDate)
void | setDiscount(java.math.BigDecimal discount)
void | setInvoiceNumber(java.lang.String invoiceNumber)
void | setItemDescription(java.lang.String itemDescription)
void | setNcrNumber(java.lang.String ncrNumber)
void | setOnDemandQty(java.math.BigDecimal onDemandQty)
void | setOnhandQty(java.math.BigDecimal onhandQty)
void | setOnorderQty(java.math.BigDecimal onorderQty)
void | setOrderedQty(java.math.BigDecimal orderedQty)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setReceivedQty(java.math.BigDecimal receivedQty)
void | setRmaDate(java.util.Date rmaDate)
void | setRmaItemNumber(java.lang.String rmaItemNumber)
void | setRmaNumber(java.lang.String rmaNumber)
void | setSalesman(java.lang.String salesman)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setStatus(java.lang.String status)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_RMANUMBER

public static final java.lang.String ORDER_BY_RMANUMBER
See Also:
Constant Field Values

ORDER_BY_RMADATE

public static final java.lang.String ORDER_BY_RMADATE
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_INVOICENUMBER

public static final java.lang.String ORDER_BY_INVOICENUMBER
See Also:
Constant Field Values

ORDER_BY_SALESORDERNUMBER

public static final java.lang.String ORDER_BY_SALESORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_NCRNUMBER

public static final java.lang.String ORDER_BY_NCRNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_ITEMDESCRIPTION

public static final java.lang.String ORDER_BY_ITEMDESCRIPTION
See Also:
Constant Field Values

ORDER_BY_DELIVERYDATE

public static final java.lang.String ORDER_BY_DELIVERYDATE
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_DEBITACCOUNT

public static final java.lang.String ORDER_BY_DEBITACCOUNT
See Also:
Constant Field Values

ORDER_BY_COMPANYUNITID

public static final java.lang.String ORDER_BY_COMPANYUNITID
See Also:
Constant Field Values
Constructor Detail

RMAItemListResult

public RMAItemListResult()
Method Detail

getOnDemandQty

public java.math.BigDecimal getOnDemandQty()

getOnorderQty

public java.math.BigDecimal getOnorderQty()

getOnhandQty

public java.math.BigDecimal getOnhandQty()

getStatus

public java.lang.String getStatus()

getCustomerId

public java.lang.String getCustomerId()

getDiscount

public java.math.BigDecimal getDiscount()

getOrderedQty

public java.math.BigDecimal getOrderedQty()

getDeliveryDate

public java.util.Date getDeliveryDate()

getRmaDate

public java.util.Date getRmaDate()

getItemDescription

public java.lang.String getItemDescription()

getPartPk

public PartPK getPartPk()

getRmaItemNumber

public java.lang.String getRmaItemNumber()

setRmaNumber

public void setRmaNumber(java.lang.String rmaNumber)

setOnDemandQty

public void setOnDemandQty(java.math.BigDecimal onDemandQty)

setOnorderQty

public void setOnorderQty(java.math.BigDecimal onorderQty)

setOnhandQty

public void setOnhandQty(java.math.BigDecimal onhandQty)

setStatus

public void setStatus(java.lang.String status)

setCustomerId

public void setCustomerId(java.lang.String customerId)

setDiscount

public void setDiscount(java.math.BigDecimal discount)

setOrderedQty

public void setOrderedQty(java.math.BigDecimal orderedQty)

setDeliveryDate

public void setDeliveryDate(java.util.Date deliveryDate)

setRmaDate

public void setRmaDate(java.util.Date rmaDate)

setItemDescription

public void setItemDescription(java.lang.String itemDescription)

setPartPk

public void setPartPk(PartPK partPk)

setRmaItemNumber

public void setRmaItemNumber(java.lang.String rmaItemNumber)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setInvoiceNumber

public void setInvoiceNumber(java.lang.String invoiceNumber)

setReceivedQty

public void setReceivedQty(java.math.BigDecimal receivedQty)

setCostPerUnit

public void setCostPerUnit(java.math.BigDecimal costPerUnit)

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getRmaNumber

public java.lang.String getRmaNumber()

getPartFrom

public java.lang.String getPartFrom()

getInvoiceNumber

public java.lang.String getInvoiceNumber()

getReceivedQty

public java.math.BigDecimal getReceivedQty()

getCostPerUnit

public java.math.BigDecimal getCostPerUnit()

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

getNcrNumber

public java.lang.String getNcrNumber()

setNcrNumber

public void setNcrNumber(java.lang.String ncrNumber)

getSalesman

public java.lang.String getSalesman()

setSalesman

public void setSalesman(java.lang.String salesman)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getDebitAccount

public java.lang.String getDebitAccount()

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RMAListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RMAListResult

java.lang.Object
    extended by  bb.common.RMAListResult
All Implemented Interfaces:
java.io.Serializable
public class RMAListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CHANGEORDER
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_INVOICENUMBER
static java.lang.String | ORDER_BY_PROJECT
static java.lang.String | ORDER_BY_RMADATE
static java.lang.String | ORDER_BY_RMANUMBER
static java.lang.String | ORDER_BY_SALESMAN
static java.lang.String | ORDER_BY_SALESORDERNUMBER
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
RMAListResult()
Method Summary
java.lang.String | getChangeOrder()
java.lang.String | getComments()
java.lang.String | getCustomerId()
java.lang.String | getInvoiceNumber()
java.lang.String | getPrivateNote()
java.lang.String | getProject()
java.lang.String | getRequester()
java.util.Date | getRmaDate()
java.lang.String | getRmaNumber()
java.lang.String | getSalesman()
java.lang.String | getSalesOrderNumber()
java.lang.String | getStatus()
void | setChangeOrder(java.lang.String changeOrder)
void | setComments(java.lang.String comments)
void | setCustomerId(java.lang.String customerId)
void | setInvoiceNumber(java.lang.String invoiceNumber)
void | setPrivateNote(java.lang.String privateNote)
void | setProject(java.lang.String project)
void | setRequester(java.lang.String requester)
void | setRmaDate(java.util.Date rmaDate)
void | setRmaNumber(java.lang.String rmaNumber)
void | setSalesman(java.lang.String salesman)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setStatus(java.lang.String status)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_RMANUMBER

public static final java.lang.String ORDER_BY_RMANUMBER
See Also:
Constant Field Values

ORDER_BY_RMADATE

public static final java.lang.String ORDER_BY_RMADATE
See Also:
Constant Field Values

ORDER_BY_CHANGEORDER

public static final java.lang.String ORDER_BY_CHANGEORDER
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_INVOICENUMBER

public static final java.lang.String ORDER_BY_INVOICENUMBER
See Also:
Constant Field Values

ORDER_BY_PROJECT

public static final java.lang.String ORDER_BY_PROJECT
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_SALESORDERNUMBER

public static final java.lang.String ORDER_BY_SALESORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_SALESMAN

public static final java.lang.String ORDER_BY_SALESMAN
See Also:
Constant Field Values
Constructor Detail

RMAListResult

public RMAListResult()
Method Detail

getStatus

public java.lang.String getStatus()

getComments

public java.lang.String getComments()

getPrivateNote

public java.lang.String getPrivateNote()

getProject

public java.lang.String getProject()

getCustomerId

public java.lang.String getCustomerId()

getChangeOrder

public java.lang.String getChangeOrder()

getRmaDate

public java.util.Date getRmaDate()

setRmaNumber

public void setRmaNumber(java.lang.String rmaNumber)

setStatus

public void setStatus(java.lang.String status)

setComments

public void setComments(java.lang.String comments)

setPrivateNote

public void setPrivateNote(java.lang.String privateNote)

setProject

public void setProject(java.lang.String project)

setCustomerId

public void setCustomerId(java.lang.String customerId)

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

setRmaDate

public void setRmaDate(java.util.Date rmaDate)

setRequester

public void setRequester(java.lang.String requester)

setInvoiceNumber

public void setInvoiceNumber(java.lang.String invoiceNumber)

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

setSalesman

public void setSalesman(java.lang.String salesman)

getRmaNumber

public java.lang.String getRmaNumber()

getRequester

public java.lang.String getRequester()

getInvoiceNumber

public java.lang.String getInvoiceNumber()

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

getSalesman

public java.lang.String getSalesman()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RMAReceiverItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RMAReceiverItemListResult

java.lang.Object
    extended by  bb.common.RMAReceiverItemListResult
All Implemented Interfaces:
java.io.Serializable
public class RMAReceiverItemListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CUSTID
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_RECEIVERBY
static java.lang.String | ORDER_BY_RECEIVERNUMBER
static java.lang.String | ORDER_BY_RMANUMBER
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
RMAReceiverItemListResult()
Method Summary
java.lang.String | getCm()
java.lang.String | getComments()
java.lang.String | getCustID()
java.util.Date | getDateReceived()
java.lang.String | getDescription()
java.lang.String | getItemNumber()
java.lang.String | getNotes()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getQuantityRcv()
java.lang.String | getReceivedBy()
java.lang.String | getReceiverNumber()
java.lang.String | getRmaNumber()
java.math.BigDecimal | getSalesCost()
java.lang.String | getSoNumber()
java.lang.String | getStatus()
java.lang.String | getUnit()
void | setCm(java.lang.String cm)
void | setComments(java.lang.String comments)
void | setCustID(java.lang.String custID)
void | setDateReceived(java.util.Date dateReceived)
void | setDescription(java.lang.String description)
void | setItemNumber(java.lang.String itemNumber)
void | setNotes(java.lang.String notes)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setQuantity(java.math.BigDecimal quantity)
void | setQuantityRcv(java.math.BigDecimal quantityRcv)
void | setReceivedBy(java.lang.String receivedBy)
void | setReceiverNumber(java.lang.String receiverNumber)
void | setRmaNumber(java.lang.String rmaNumber)
void | setSalesCost(java.math.BigDecimal salesCost)
void | setSoNumber(java.lang.String soNumber)
void | setStatus(java.lang.String status)
void | setUnit(java.lang.String unit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_RECEIVERNUMBER

public static final java.lang.String ORDER_BY_RECEIVERNUMBER
See Also:
Constant Field Values

ORDER_BY_RMANUMBER

public static final java.lang.String ORDER_BY_RMANUMBER
See Also:
Constant Field Values

ORDER_BY_RECEIVERBY

public static final java.lang.String ORDER_BY_RECEIVERBY
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_CUSTID

public static final java.lang.String ORDER_BY_CUSTID
See Also:
Constant Field Values
Constructor Detail

RMAReceiverItemListResult

public RMAReceiverItemListResult()
Method Detail

getSoNumber

public java.lang.String getSoNumber()

setSoNumber

public void setSoNumber(java.lang.String soNumber)

getCustID

public java.lang.String getCustID()

setCustID

public void setCustID(java.lang.String custID)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getItemNumber

public java.lang.String getItemNumber()

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

getNotes

public java.lang.String getNotes()

setNotes

public void setNotes(java.lang.String notes)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getQuantityRcv

public java.math.BigDecimal getQuantityRcv()

setQuantityRcv

public void setQuantityRcv(java.math.BigDecimal quantityRcv)

getReceivedBy

public java.lang.String getReceivedBy()

setReceivedBy

public void setReceivedBy(java.lang.String receivedBy)

getReceiverNumber

public java.lang.String getReceiverNumber()

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)

getRmaNumber

public java.lang.String getRmaNumber()

setRmaNumber

public void setRmaNumber(java.lang.String rmaNumber)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getCm

public java.lang.String getCm()

setCm

public void setCm(java.lang.String cm)

getDateReceived

public java.util.Date getDateReceived()

setDateReceived

public void setDateReceived(java.util.Date dateReceived)

getSalesCost

public java.math.BigDecimal getSalesCost()

setSalesCost

public void setSalesCost(java.math.BigDecimal salesCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RMAReceiverItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RMAReceiverItemPK

java.lang.Object
    extended by  bb.common.RMAReceiverItemPK
All Implemented Interfaces:
java.io.Serializable
public class RMAReceiverItemPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
RMAReceiverItemPK()
default constructor
RMAReceiverItemPK(java.lang.String receiverNumber, java.lang.String itemNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getItemNumber()
java.lang.String | getReceiverNumber()
int | hashCode()
void | setItemNumber(java.lang.String itemNumber)
void | setReceiverNumber(java.lang.String receiverNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

RMAReceiverItemPK

public RMAReceiverItemPK(java.lang.String receiverNumber,
                         java.lang.String itemNumber)
full constructor

RMAReceiverItemPK

public RMAReceiverItemPK()
default constructor

Method Detail

getItemNumber

public java.lang.String getItemNumber()

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

getReceiverNumber

public java.lang.String getReceiverNumber()

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RMAReceiverItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RMAReceiverItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.RMAReceiverItemVO
All Implemented Interfaces:
java.io.Serializable
public class RMAReceiverItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
RMAReceiverItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCheckNo()
java.math.BigDecimal | getCmDisc()
java.math.BigDecimal | getCmNet()
java.math.BigDecimal | getCmOpen()
java.math.BigDecimal | getCmRcvd()
java.math.BigDecimal | getCmSub()
java.math.BigDecimal | getCmTax()
java.math.BigDecimal | getCmTotal()
java.lang.String | getComments()
java.lang.String | getCondition()
java.math.BigDecimal | getCurrentCost()
java.math.BigDecimal | getCurrentStdCost()
java.util.Date | getDatePaid()
java.lang.String | getDescription()
java.math.BigDecimal | getDiscount()
java.math.BigDecimal | getDue()
java.math.BigDecimal | getHqa()
java.lang.String | getLocate()
java.util.Map | getLocations()
java.lang.String | getMfg()
java.lang.String | getModel()
java.lang.String | getMpn()
java.lang.String | getNotes()
java.math.BigDecimal | getPaid()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
RMAReceiverItemPK | getPk()
java.math.BigDecimal | getPrice()
java.lang.String | getQr()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getQuantityRcv()
java.math.BigDecimal | getQuantityTraced()
java.lang.String | getReceivedBy()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.lang.String | getRevision()
java.lang.String | getRmaNumber()
java.math.BigDecimal | getSalesCost()
java.math.BigDecimal | getSalesStdCost()
java.lang.String | getSentTo()
java.lang.String | getSerial()
java.lang.String | getStatus()
java.math.BigDecimal | getTaxr()
java.util.Map | getTrackings()
java.lang.String | getUnit()
int | hashCode()
void | setCheckNo(java.lang.String checkNo)
void | setCmDisc(java.math.BigDecimal cmDisc)
void | setCmNet(java.math.BigDecimal cmNet)
void | setCmOpen(java.math.BigDecimal cmOpen)
void | setCmRcvd(java.math.BigDecimal cmRcvd)
void | setCmSub(java.math.BigDecimal cmSub)
void | setCmTax(java.math.BigDecimal cmTax)
void | setCmTotal(java.math.BigDecimal cmTotal)
void | setComments(java.lang.String comments)
void | setCondition(java.lang.String condition)
void | setCurrentCost(java.math.BigDecimal currentCost)
void | setCurrentStdCost(java.math.BigDecimal currentStdCost)
void | setDatePaid(java.util.Date datePaid)
void | setDescription(java.lang.String description)
void | setDiscount(java.math.BigDecimal discount)
void | setDue(java.math.BigDecimal due)
void | setHqa(java.math.BigDecimal hqa)
void | setLocate(java.lang.String locate)
void | setLocations(java.util.Map locations)
void | setMfg(java.lang.String mfg)
void | setModel(java.lang.String model)
void | setMpn(java.lang.String mpn)
void | setNotes(java.lang.String notes)
void | setPaid(java.math.BigDecimal paid)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(RMAReceiverItemPK pk)
void | setPrice(java.math.BigDecimal price)
void | setQr(java.lang.String qr)
void | setQuantity(java.math.BigDecimal quantity)
void | setQuantityRcv(java.math.BigDecimal quantityRcv)
void | setQuantityTraced(java.math.BigDecimal quantityTraced)
void | setReceivedBy(java.lang.String receivedBy)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setRevision(java.lang.String revision)
void | setRmaNumber(java.lang.String rmaNumber)
void | setSalesCost(java.math.BigDecimal salesCost)
void | setSalesStdCost(java.math.BigDecimal salesStdCost)
void | setSentTo(java.lang.String sentTo)
void | setSerial(java.lang.String serial)
void | setStatus(java.lang.String status)
void | setTaxr(java.math.BigDecimal taxr)
void | setTrackings(java.util.Map trackings)
void | setUnit(java.lang.String unit)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

RMAReceiverItemVO

public RMAReceiverItemVO()
Method Detail

getPk

public RMAReceiverItemPK getPk()

setPk

public void setPk(RMAReceiverItemPK pk)

getRmaNumber

public java.lang.String getRmaNumber()

setRmaNumber

public void setRmaNumber(java.lang.String rmaNumber)

getCmSub

public java.math.BigDecimal getCmSub()

setCmSub

public void setCmSub(java.math.BigDecimal cmSub)

getCmRcvd

public java.math.BigDecimal getCmRcvd()

setCmRcvd

public void setCmRcvd(java.math.BigDecimal cmRcvd)

getCmOpen

public java.math.BigDecimal getCmOpen()

setCmOpen

public void setCmOpen(java.math.BigDecimal cmOpen)

getCmDisc

public java.math.BigDecimal getCmDisc()

setCmDisc

public void setCmDisc(java.math.BigDecimal cmDisc)

getCmNet

public java.math.BigDecimal getCmNet()

setCmNet

public void setCmNet(java.math.BigDecimal cmNet)

getCmTax

public java.math.BigDecimal getCmTax()

setCmTax

public void setCmTax(java.math.BigDecimal cmTax)

getCmTotal

public java.math.BigDecimal getCmTotal()

setCmTotal

public void setCmTotal(java.math.BigDecimal cmTotal)

getDue

public java.math.BigDecimal getDue()

setDue

public void setDue(java.math.BigDecimal due)

getPaid

public java.math.BigDecimal getPaid()

setPaid

public void setPaid(java.math.BigDecimal paid)

getDatePaid

public java.util.Date getDatePaid()

setDatePaid

public void setDatePaid(java.util.Date datePaid)

getCheckNo

public java.lang.String getCheckNo()

setCheckNo

public void setCheckNo(java.lang.String checkNo)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getQr

public java.lang.String getQr()

setQr

public void setQr(java.lang.String qr)

getSentTo

public java.lang.String getSentTo()

setSentTo

public void setSentTo(java.lang.String sentTo)

getReceivedBy

public java.lang.String getReceivedBy()

setReceivedBy

public void setReceivedBy(java.lang.String receivedBy)

getCondition

public java.lang.String getCondition()

setCondition

public void setCondition(java.lang.String condition)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getModel

public java.lang.String getModel()

setModel

public void setModel(java.lang.String model)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getQuantityTraced

public java.math.BigDecimal getQuantityTraced()

setQuantityTraced

public void setQuantityTraced(java.math.BigDecimal quantityTraced)

getQuantityRcv

public java.math.BigDecimal getQuantityRcv()

setQuantityRcv

public void setQuantityRcv(java.math.BigDecimal quantityRcv)

getPrice

public java.math.BigDecimal getPrice()

setPrice

public void setPrice(java.math.BigDecimal price)

getSalesCost

public java.math.BigDecimal getSalesCost()

setSalesCost

public void setSalesCost(java.math.BigDecimal salesCost)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getTaxr

public java.math.BigDecimal getTaxr()

setTaxr

public void setTaxr(java.math.BigDecimal taxr)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getSerial

public java.lang.String getSerial()

setSerial

public void setSerial(java.lang.String serial)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getNotes

public java.lang.String getNotes()

setNotes

public void setNotes(java.lang.String notes)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getCurrentCost

public java.math.BigDecimal getCurrentCost()

setCurrentCost

public void setCurrentCost(java.math.BigDecimal currentCost)

getCurrentStdCost

public java.math.BigDecimal getCurrentStdCost()

setCurrentStdCost

public void setCurrentStdCost(java.math.BigDecimal currentStdCost)

getSalesStdCost

public java.math.BigDecimal getSalesStdCost()

setSalesStdCost

public void setSalesStdCost(java.math.BigDecimal salesStdCost)

getLocations

public java.util.Map getLocations()

setLocations

public void setLocations(java.util.Map locations)

getTrackings

public java.util.Map getTrackings()

setTrackings

public void setTrackings(java.util.Map trackings)

getHqa

public java.math.BigDecimal getHqa()

setHqa

public void setHqa(java.math.BigDecimal hqa)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RMAReceiverListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RMAReceiverListResult

java.lang.Object
    extended by  bb.common.RMAReceiverListResult
All Implemented Interfaces:
java.io.Serializable
public class RMAReceiverListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CREDITMEMONUMBER
static java.lang.String | ORDER_BY_DATERECEIVED
static java.lang.String | ORDER_BY_PROJECT
static java.lang.String | ORDER_BY_RECEIVEDBY
static java.lang.String | ORDER_BY_RECEIVERNUMBER
static java.lang.String | ORDER_BY_RMANUMBER
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
RMAReceiverListResult()
Method Summary
java.lang.String | getComments()
java.lang.String | getCreditMemoNumber()
java.lang.String | getCustID()
java.util.Date | getDateReceived()
java.lang.String | getNotes()
java.lang.String | getProject()
java.lang.String | getReceivedBy()
java.lang.String | getReceiverNumber()
java.lang.String | getRmaNumber()
java.lang.String | getStatus()
void | setComments(java.lang.String comments)
void | setCreditMemoNumber(java.lang.String creditMemoNumber)
void | setCustID(java.lang.String custID)
void | setDateReceived(java.util.Date dateReceived)
void | setNotes(java.lang.String notes)
void | setProject(java.lang.String project)
void | setReceivedBy(java.lang.String receivedBy)
void | setReceiverNumber(java.lang.String receiverNumber)
void | setRmaNumber(java.lang.String rmaNumber)
void | setStatus(java.lang.String status)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_RECEIVERNUMBER

public static final java.lang.String ORDER_BY_RECEIVERNUMBER
See Also:
Constant Field Values

ORDER_BY_RMANUMBER

public static final java.lang.String ORDER_BY_RMANUMBER
See Also:
Constant Field Values

ORDER_BY_CREDITMEMONUMBER

public static final java.lang.String ORDER_BY_CREDITMEMONUMBER
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_RECEIVEDBY

public static final java.lang.String ORDER_BY_RECEIVEDBY
See Also:
Constant Field Values

ORDER_BY_DATERECEIVED

public static final java.lang.String ORDER_BY_DATERECEIVED
See Also:
Constant Field Values

ORDER_BY_PROJECT

public static final java.lang.String ORDER_BY_PROJECT
See Also:
Constant Field Values
Constructor Detail

RMAReceiverListResult

public RMAReceiverListResult()
Method Detail

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getCreditMemoNumber

public java.lang.String getCreditMemoNumber()

setCreditMemoNumber

public void setCreditMemoNumber(java.lang.String creditMemoNumber)

getCustID

public java.lang.String getCustID()

setCustID

public void setCustID(java.lang.String custID)

getDateReceived

public java.util.Date getDateReceived()

setDateReceived

public void setDateReceived(java.util.Date dateReceived)

getNotes

public java.lang.String getNotes()

setNotes

public void setNotes(java.lang.String notes)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

getReceivedBy

public java.lang.String getReceivedBy()

setReceivedBy

public void setReceivedBy(java.lang.String receivedBy)

getReceiverNumber

public java.lang.String getReceiverNumber()

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)

getRmaNumber

public java.lang.String getRmaNumber()

setRmaNumber

public void setRmaNumber(java.lang.String rmaNumber)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RMAReceiverResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RMAReceiverResult

java.lang.Object
    extended by  bb.common.RMAReceiverResult
All Implemented Interfaces:
java.io.Serializable
public class RMAReceiverResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
RMAReceiverResult()
Method Summary
java.lang.String | getBillToId()
java.lang.String | getCustomerId()
java.util.Date | getDelivery()
java.lang.String | getDescription()
java.util.Map<java.lang.String,java.math.BigDecimal> | getLocations()
ReturnMaterialAuthorizationItemPK | getPk()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getReceivedQuantity()
java.lang.String | getShipToId()
void | setBillToId(java.lang.String billToId)
void | setCustomerId(java.lang.String customerId)
void | setDelivery(java.util.Date delivery)
void | setDescription(java.lang.String description)
void | setLocations(java.util.Map<java.lang.String,java.math.BigDecimal> locations)
void | setPk(ReturnMaterialAuthorizationItemPK pk)
void | setQuantity(java.math.BigDecimal quantity)
void | setReceivedQuantity(java.math.BigDecimal receivedQuantity)
void | setShipToId(java.lang.String shipToId)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RMAReceiverResult

public RMAReceiverResult()
Method Detail

getPk

public ReturnMaterialAuthorizationItemPK getPk()

setPk

public void setPk(ReturnMaterialAuthorizationItemPK pk)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getReceivedQuantity

public java.math.BigDecimal getReceivedQuantity()

setReceivedQuantity

public void setReceivedQuantity(java.math.BigDecimal receivedQuantity)

getDelivery

public java.util.Date getDelivery()

setDelivery

public void setDelivery(java.util.Date delivery)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getBillToId

public java.lang.String getBillToId()

setBillToId

public void setBillToId(java.lang.String billToId)

getShipToId

public java.lang.String getShipToId()

setShipToId

public void setShipToId(java.lang.String shipToId)

getLocations

public java.util.Map<java.lang.String,java.math.BigDecimal> getLocations()

setLocations

public void setLocations(java.util.Map<java.lang.String,java.math.BigDecimal> locations)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RMAReceiverVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RMAReceiverVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.RMAReceiverVO
All Implemented Interfaces:
java.io.Serializable
public class RMAReceiverVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
RMAReceiverVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.lang.String | getBatch()
java.lang.String | getBillToId()
CustomerVendorAddressInfoVO | getBillToInfo()
java.lang.String | getBp()
java.lang.String | getBuyor()
java.lang.String | getCarrier()
java.lang.String | getCarrierAcct()
java.lang.String | getChangeOrder()
java.lang.String | getCheckNo()
java.math.BigDecimal | getCmDisc()
java.math.BigDecimal | getCmFreight()
java.math.BigDecimal | getCmGl1Recorded()
java.math.BigDecimal | getCmGl2Paid()
java.math.BigDecimal | getCmNet()
java.lang.String | getCmNetSet()
java.math.BigDecimal | getCmOpen()
java.math.BigDecimal | getCmPaidGl()
java.math.BigDecimal | getCmPaidRcv()
java.math.BigDecimal | getCmRcvd()
java.math.BigDecimal | getCmSub()
java.math.BigDecimal | getCmTax()
java.lang.String | getCmTaxSet()
java.math.BigDecimal | getCmTotal()
java.lang.String | getCoComments()
java.lang.String | getCollect()
java.lang.String | getComments()
java.lang.String | getCompanyUnitId()
java.lang.String | getCreditMemoNumber()
java.lang.String | getCurrency()
java.lang.String | getCustID()
CustomerVendorAddressInfoVO | getCustomerAddressInfo()
java.lang.String | getCustomerDm()
java.util.Date | getCustomerDmDate()
java.math.BigDecimal | getCustomerDmTotal()
java.lang.String | getCustomerShipper()
java.util.Date | getCustomerShipperDate()
java.util.Date | getDatePaid()
java.util.Date | getDateReceived()
java.lang.String | getDebitAccount()
java.lang.String | getDeliveredTo()
java.math.BigDecimal | getDue()
java.lang.String | getEtran()
java.math.BigDecimal | getExchange()
java.lang.String | getFreightBill()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.util.Set | getItems()
java.lang.String | getItran()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getNotes()
java.lang.String | getOrigin()
java.math.BigDecimal | getPaid()
java.util.Date | getPaydate()
java.lang.String | getProject()
java.lang.String | getReceivedBy()
java.lang.String | getReceiverNumber()
java.lang.String | getReldoc()
java.lang.String | getRequestor()
java.lang.String | getRmaNumber()
java.lang.String | getShippedVia()
java.lang.String | getShipToId()
CustomerVendorAddressInfoVO | getShipToInfo()
java.lang.String | getStatus()
java.lang.String | getTerms()
java.lang.String | getTracking()
java.lang.Integer | getVersion()
int | hashCode()
void | setAdate(java.util.Date adate)
void | setBatch(java.lang.String batch)
void | setBillToId(java.lang.String billToId)
void | setBillToInfo(CustomerVendorAddressInfoVO billToInfo)
void | setBp(java.lang.String bp)
void | setBuyor(java.lang.String buyor)
void | setCarrier(java.lang.String carrier)
void | setCarrierAcct(java.lang.String carrierAcct)
void | setChangeOrder(java.lang.String changeOrder)
void | setCheckNo(java.lang.String checkNo)
void | setCmDisc(java.math.BigDecimal cmDisc)
void | setCmFreight(java.math.BigDecimal cmFreight)
void | setCmGl1Recorded(java.math.BigDecimal cmGl1Recorded)
void | setCmGl2Paid(java.math.BigDecimal cmGl2Paid)
void | setCmNet(java.math.BigDecimal cmNet)
void | setCmNetSet(java.lang.String cmNetSet)
void | setCmOpen(java.math.BigDecimal cmOpen)
void | setCmPaidGl(java.math.BigDecimal cmPaidGl)
void | setCmPaidRcv(java.math.BigDecimal cmPaidRcv)
void | setCmRcvd(java.math.BigDecimal cmRcvd)
void | setCmSub(java.math.BigDecimal cmSub)
void | setCmTax(java.math.BigDecimal cmTax)
void | setCmTaxSet(java.lang.String cmTaxSet)
void | setCmTotal(java.math.BigDecimal cmTotal)
void | setCoComments(java.lang.String coComments)
void | setCollect(java.lang.String collect)
void | setComments(java.lang.String comments)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCreditMemoNumber(java.lang.String creditMemoNumber)
void | setCurrency(java.lang.String currency)
void | setCustID(java.lang.String custID)
void | setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | setCustomerDm(java.lang.String customerDm)
void | setCustomerDmDate(java.util.Date customerDmDate)
void | setCustomerDmTotal(java.math.BigDecimal customerDmTotal)
void | setCustomerShipper(java.lang.String customerShipper)
void | setCustomerShipperDate(java.util.Date customerShipperDate)
void | setDatePaid(java.util.Date datePaid)
void | setDateReceived(java.util.Date dateReceived)
void | setDebitAccount(java.lang.String debitAccount)
void | setDeliveredTo(java.lang.String deliveredTo)
void | setDue(java.math.BigDecimal due)
void | setEtran(java.lang.String etran)
void | setExchange(java.math.BigDecimal exchange)
void | setFreightBill(java.lang.String freightBill)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setItems(java.util.Set items)
void | setItran(java.lang.String itran)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setNotes(java.lang.String notes)
void | setOrigin(java.lang.String origin)
void | setPaid(java.math.BigDecimal paid)
void | setPaydate(java.util.Date paydate)
void | setProject(java.lang.String project)
void | setReceivedBy(java.lang.String receivedBy)
void | setReceiverNumber(java.lang.String receiverNumber)
void | setReldoc(java.lang.String reldoc)
void | setRequestor(java.lang.String requestor)
void | setRmaNumber(java.lang.String rmaNumber)
void | setShippedVia(java.lang.String shippedVia)
void | setShipToId(java.lang.String shipToId)
void | setShipToInfo(CustomerVendorAddressInfoVO shipToInfo)
void | setStatus(java.lang.String status)
void | setTerms(java.lang.String terms)
void | setTracking(java.lang.String tracking)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

RMAReceiverVO

public RMAReceiverVO()
Method Detail

getCustomerAddressInfo

public CustomerVendorAddressInfoVO getCustomerAddressInfo()

setCustomerAddressInfo

public void setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)

getReceiverNumber

public java.lang.String getReceiverNumber()

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)

getRmaNumber

public java.lang.String getRmaNumber()

setRmaNumber

public void setRmaNumber(java.lang.String rmaNumber)

getCreditMemoNumber

public java.lang.String getCreditMemoNumber()

setCreditMemoNumber

public void setCreditMemoNumber(java.lang.String creditMemoNumber)

getCustID

public java.lang.String getCustID()

setCustID

public void setCustID(java.lang.String custID)

getBatch

public java.lang.String getBatch()

setBatch

public void setBatch(java.lang.String batch)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getCmNetSet

public java.lang.String getCmNetSet()

setCmNetSet

public void setCmNetSet(java.lang.String cmNetSet)

getCmTaxSet

public java.lang.String getCmTaxSet()

setCmTaxSet

public void setCmTaxSet(java.lang.String cmTaxSet)

getCmSub

public java.math.BigDecimal getCmSub()

setCmSub

public void setCmSub(java.math.BigDecimal cmSub)

getCmRcvd

public java.math.BigDecimal getCmRcvd()

setCmRcvd

public void setCmRcvd(java.math.BigDecimal cmRcvd)

getCmOpen

public java.math.BigDecimal getCmOpen()

setCmOpen

public void setCmOpen(java.math.BigDecimal cmOpen)

getCmDisc

public java.math.BigDecimal getCmDisc()

setCmDisc

public void setCmDisc(java.math.BigDecimal cmDisc)

getCmNet

public java.math.BigDecimal getCmNet()

setCmNet

public void setCmNet(java.math.BigDecimal cmNet)

getCmTax

public java.math.BigDecimal getCmTax()

setCmTax

public void setCmTax(java.math.BigDecimal cmTax)

getCmFreight

public java.math.BigDecimal getCmFreight()

setCmFreight

public void setCmFreight(java.math.BigDecimal cmFreight)

getCmTotal

public java.math.BigDecimal getCmTotal()

setCmTotal

public void setCmTotal(java.math.BigDecimal cmTotal)

getCmPaidRcv

public java.math.BigDecimal getCmPaidRcv()

setCmPaidRcv

public void setCmPaidRcv(java.math.BigDecimal cmPaidRcv)

getCmPaidGl

public java.math.BigDecimal getCmPaidGl()

setCmPaidGl

public void setCmPaidGl(java.math.BigDecimal cmPaidGl)

getCmGl1Recorded

public java.math.BigDecimal getCmGl1Recorded()

setCmGl1Recorded

public void setCmGl1Recorded(java.math.BigDecimal cmGl1Recorded)

getCmGl2Paid

public java.math.BigDecimal getCmGl2Paid()

setCmGl2Paid

public void setCmGl2Paid(java.math.BigDecimal cmGl2Paid)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getCoComments

public java.lang.String getCoComments()

setCoComments

public void setCoComments(java.lang.String coComments)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getCollect

public java.lang.String getCollect()

setCollect

public void setCollect(java.lang.String collect)

getReceivedBy

public java.lang.String getReceivedBy()

setReceivedBy

public void setReceivedBy(java.lang.String receivedBy)

getDateReceived

public java.util.Date getDateReceived()

setDateReceived

public void setDateReceived(java.util.Date dateReceived)

getDeliveredTo

public java.lang.String getDeliveredTo()

setDeliveredTo

public void setDeliveredTo(java.lang.String deliveredTo)

getFreightBill

public java.lang.String getFreightBill()

setFreightBill

public void setFreightBill(java.lang.String freightBill)

getShippedVia

public java.lang.String getShippedVia()

setShippedVia

public void setShippedVia(java.lang.String shippedVia)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAcct

public java.lang.String getCarrierAcct()

setCarrierAcct

public void setCarrierAcct(java.lang.String carrierAcct)

getTracking

public java.lang.String getTracking()

setTracking

public void setTracking(java.lang.String tracking)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getRequestor

public java.lang.String getRequestor()

setRequestor

public void setRequestor(java.lang.String requestor)

getBuyor

public java.lang.String getBuyor()

setBuyor

public void setBuyor(java.lang.String buyor)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

getReldoc

public java.lang.String getReldoc()

setReldoc

public void setReldoc(java.lang.String reldoc)

getDebitAccount

public java.lang.String getDebitAccount()

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

getBp

public java.lang.String getBp()

setBp

public void setBp(java.lang.String bp)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getNotes

public java.lang.String getNotes()

setNotes

public void setNotes(java.lang.String notes)

getDue

public java.math.BigDecimal getDue()

setDue

public void setDue(java.math.BigDecimal due)

getPaydate

public java.util.Date getPaydate()

setPaydate

public void setPaydate(java.util.Date paydate)

getDatePaid

public java.util.Date getDatePaid()

setDatePaid

public void setDatePaid(java.util.Date datePaid)

getCheckNo

public java.lang.String getCheckNo()

setCheckNo

public void setCheckNo(java.lang.String checkNo)

getPaid

public java.math.BigDecimal getPaid()

setPaid

public void setPaid(java.math.BigDecimal paid)

getItran

public java.lang.String getItran()

setItran

public void setItran(java.lang.String itran)

getEtran

public java.lang.String getEtran()

setEtran

public void setEtran(java.lang.String etran)

getVersion

public java.lang.Integer getVersion()

setVersion

public void setVersion(java.lang.Integer version)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getItems

public java.util.Set getItems()

setItems

public void setItems(java.util.Set items)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getBillToId

public java.lang.String getBillToId()

setBillToId

public void setBillToId(java.lang.String billToId)

getBillToInfo

public CustomerVendorAddressInfoVO getBillToInfo()

setBillToInfo

public void setBillToInfo(CustomerVendorAddressInfoVO billToInfo)

getShipToId

public java.lang.String getShipToId()

setShipToId

public void setShipToId(java.lang.String shipToId)

getShipToInfo

public CustomerVendorAddressInfoVO getShipToInfo()

setShipToInfo

public void setShipToInfo(CustomerVendorAddressInfoVO shipToInfo)

getCustomerDm

public java.lang.String getCustomerDm()

setCustomerDm

public void setCustomerDm(java.lang.String customerDm)

getCustomerDmDate

public java.util.Date getCustomerDmDate()

setCustomerDmDate

public void setCustomerDmDate(java.util.Date customerDmDate)

getCustomerDmTotal

public java.math.BigDecimal getCustomerDmTotal()

setCustomerDmTotal

public void setCustomerDmTotal(java.math.BigDecimal customerDmTotal)

getCustomerShipper

public java.lang.String getCustomerShipper()

setCustomerShipper

public void setCustomerShipper(java.lang.String customerShipper)

getCustomerShipperDate

public java.util.Date getCustomerShipperDate()

setCustomerShipperDate

public void setCustomerShipperDate(java.util.Date customerShipperDate)

getExchange

public java.math.BigDecimal getExchange()

setExchange

public void setExchange(java.math.BigDecimal exchange)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RMAReviewVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RMAReviewVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.RMAReviewVO
All Implemented Interfaces:
java.io.Serializable
public class RMAReviewVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CANREVIEWOWNRMA
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_EMPLOYEEID
static java.lang.String | ORDER_BY_REVIEWLIMIT
static java.lang.String | ORDER_BY_USERNAME
Constructor Summary
RMAReviewVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCanReviewOwnRMA()
java.lang.String | getComments()
java.lang.String | getCurrency()
java.lang.String | getEmployeeID()
java.math.BigDecimal | getReviewLimit()
java.lang.String | getUserName()
int | hashCode()
void | setCanReviewOwnRMA(java.lang.String canReviewOwnRMA)
void | setComments(java.lang.String comments)
void | setCurrency(java.lang.String currency)
void | setEmployeeID(java.lang.String employeeID)
void | setReviewLimit(java.math.BigDecimal reviewLimit)
void | setUserName(java.lang.String userName)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_EMPLOYEEID

public static final java.lang.String ORDER_BY_EMPLOYEEID
See Also:
Constant Field Values

ORDER_BY_USERNAME

public static final java.lang.String ORDER_BY_USERNAME
See Also:
Constant Field Values

ORDER_BY_REVIEWLIMIT

public static final java.lang.String ORDER_BY_REVIEWLIMIT
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values

ORDER_BY_CANREVIEWOWNRMA

public static final java.lang.String ORDER_BY_CANREVIEWOWNRMA
See Also:
Constant Field Values
Constructor Detail

RMAReviewVO

public RMAReviewVO()
Method Detail

getEmployeeID

public java.lang.String getEmployeeID()

setEmployeeID

public void setEmployeeID(java.lang.String employeeID)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getReviewLimit

public java.math.BigDecimal getReviewLimit()

setReviewLimit

public void setReviewLimit(java.math.BigDecimal reviewLimit)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getCanReviewOwnRMA

public java.lang.String getCanReviewOwnRMA()

setCanReviewOwnRMA

public void setCanReviewOwnRMA(java.lang.String canReviewOwnRMA)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RoleDescriptionPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RoleDescriptionPK

java.lang.Object
    extended by  bb.common.RoleDescriptionPK
All Implemented Interfaces:
java.io.Serializable
public class RoleDescriptionPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
RoleDescriptionPK()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getLanguage()
java.lang.String | getRoleId()
int | hashCode()
void | setLanguage(java.lang.String language)
void | setRoleId(java.lang.String roleId)
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RoleDescriptionPK

public RoleDescriptionPK()
default constructor

Method Detail

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getRoleId

public java.lang.String getRoleId()

setRoleId

public void setRoleId(java.lang.String roleId)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RoleDescriptionVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RoleDescriptionVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.RoleDescriptionVO
All Implemented Interfaces:
java.io.Serializable
public class RoleDescriptionVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
RoleDescriptionVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDescription()
RoleDescriptionPK | getPk()
java.lang.String | getRoleName()
int | hashCode()
void | setDescription(java.lang.String description)
void | setPk(RoleDescriptionPK pk)
void | setRoleName(java.lang.String roleName)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

RoleDescriptionVO

public RoleDescriptionVO()
Method Detail

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getPk

public RoleDescriptionPK getPk()

setPk

public void setPk(RoleDescriptionPK pk)

getRoleName

public java.lang.String getRoleName()

setRoleName

public void setRoleName(java.lang.String roleName)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RoleListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RoleListResult

java.lang.Object
    extended by  bb.common.RoleListResult
All Implemented Interfaces:
java.io.Serializable
public class RoleListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_ROLEID
static java.lang.String | ORDER_BY_ROLENAME
java.lang.String | RoleId
Constructor Summary
RoleListResult()
Method Summary
boolean | equals(java.lang.Object obj)
java.lang.String | getDescription()
java.lang.String | getRoleId()
java.lang.String | getRoleName()
boolean | isSystem()
void | setDescription(java.lang.String description)
void | setRoleId(java.lang.String roleId)
void | setRoleName(java.lang.String roleName)
void | setSystem(boolean system)
Methods inherited from class java.lang.Object
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_ROLEID

public static final java.lang.String ORDER_BY_ROLEID
See Also:
Constant Field Values

ORDER_BY_ROLENAME

public static final java.lang.String ORDER_BY_ROLENAME
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

RoleId

public java.lang.String RoleId
Constructor Detail

RoleListResult

public RoleListResult()
Method Detail

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getRoleId

public java.lang.String getRoleId()

setRoleId

public void setRoleId(java.lang.String roleId)

getRoleName

public java.lang.String getRoleName()

setRoleName

public void setRoleName(java.lang.String roleName)

isSystem

public boolean isSystem()

setSystem

public void setSystem(boolean system)

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RolePermissionPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RolePermissionPK

java.lang.Object
    extended by  bb.common.RolePermissionPK
All Implemented Interfaces:
java.io.Serializable
public class RolePermissionPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
RolePermissionPK()
default constructor
RolePermissionPK(java.lang.String roleId, java.lang.String permissionId)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getPermissionId()
java.lang.String | getRoleId()
int | hashCode()
void | setPermissionId(java.lang.String permissionId)
void | setRoleId(java.lang.String roleId)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

RolePermissionPK

public RolePermissionPK(java.lang.String roleId,
                        java.lang.String permissionId)
full constructor

RolePermissionPK

public RolePermissionPK()
default constructor

Method Detail

getRoleId

public java.lang.String getRoleId()

setRoleId

public void setRoleId(java.lang.String roleId)

getPermissionId

public java.lang.String getPermissionId()

setPermissionId

public void setPermissionId(java.lang.String permissionId)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RolePermissionVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RolePermissionVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.RolePermissionVO
All Implemented Interfaces:
java.io.Serializable
public class RolePermissionVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
RolePermissionVO()
default constructor
RolePermissionVO(RolePermissionPK pk)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
RolePermissionPK | getPk()
int | hashCode()
void | setPk(RolePermissionPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

RolePermissionVO

public RolePermissionVO(RolePermissionPK pk)
full constructor

RolePermissionVO

public RolePermissionVO()
default constructor

Method Detail

getPk

public RolePermissionPK getPk()

setPk

public void setPk(RolePermissionPK pk)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RoleVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RoleVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.RoleVO
All Implemented Interfaces:
java.io.Serializable
public class RoleVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
RoleVO()
default constructor
RoleVO(java.lang.String roleId, java.util.Set rolePermissions)
minimal constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Set | getMultiLanguage()
java.lang.String | getRoleId()
java.util.Set | getRolePermissions()
int | hashCode()
boolean | isSystem()
void | setMultiLanguage(java.util.Set multiLanguage)
void | setRoleId(java.lang.String roleId)
void | setRolePermissions(java.util.Set rolePermissions)
void | setSystem(boolean system)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

RoleVO

public RoleVO()
default constructor

RoleVO

public RoleVO(java.lang.String roleId,
              java.util.Set rolePermissions)
minimal constructor

Method Detail

getRoleId

public java.lang.String getRoleId()

setRoleId

public void setRoleId(java.lang.String roleId)

getRolePermissions

public java.util.Set getRolePermissions()

setRolePermissions

public void setRolePermissions(java.util.Set rolePermissions)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getMultiLanguage

public java.util.Set getMultiLanguage()

setMultiLanguage

public void setMultiLanguage(java.util.Set multiLanguage)

isSystem

public boolean isSystem()

setSystem

public void setSystem(boolean system)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RollUpBomStdCostWorkSheetItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RollUpBomStdCostWorkSheetItemPK

java.lang.Object
    extended by  bb.common.RollUpBomStdCostWorkSheetItemPK
All Implemented Interfaces:
java.io.Serializable
public class RollUpBomStdCostWorkSheetItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
RollUpBomStdCostWorkSheetItemPK()
RollUpBomStdCostWorkSheetItemPK(java.lang.Long ii, java.lang.String billNumber, java.lang.String billType)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getBillNumber()
java.lang.String | getBillType()
java.lang.Long | getIi()
int | hashCode()
void | setBillNumber(java.lang.String billNumber)
void | setBillType(java.lang.String billType)
void | setIi(java.lang.Long ii)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

RollUpBomStdCostWorkSheetItemPK

public RollUpBomStdCostWorkSheetItemPK()

RollUpBomStdCostWorkSheetItemPK

public RollUpBomStdCostWorkSheetItemPK(java.lang.Long ii,
                                       java.lang.String billNumber,
                                       java.lang.String billType)
Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getBillNumber

public java.lang.String getBillNumber()

setBillNumber

public void setBillNumber(java.lang.String billNumber)

getBillType

public java.lang.String getBillType()

setBillType

public void setBillType(java.lang.String billType)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RollUpBomStdCostWorkSheetItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RollUpBomStdCostWorkSheetItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.RollUpBomStdCostWorkSheetItemVO
All Implemented Interfaces:
java.io.Serializable
public class RollUpBomStdCostWorkSheetItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AVGCOST
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_LEVEL
static java.lang.String | ORDER_BY_ONHAND
static java.lang.String | ORDER_BY_PK
static java.lang.String | ORDER_BY_ROLLUPCOST
static java.lang.String | ORDER_BY_STDCOST
Constructor Summary
RollUpBomStdCostWorkSheetItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getAvgCost()
java.lang.String | getDescription()
java.lang.Integer | getLevel()
java.math.BigDecimal | getOnHand()
RollUpBomStdCostWorkSheetItemPK | getPk()
java.math.BigDecimal | getRollUpCost()
java.math.BigDecimal | getStdCost()
int | hashCode()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setDescription(java.lang.String description)
void | setLevel(java.lang.Integer level)
void | setOnHand(java.math.BigDecimal onHand)
void | setPk(RollUpBomStdCostWorkSheetItemPK pk)
void | setRollUpCost(java.math.BigDecimal rollUpCost)
void | setStdCost(java.math.BigDecimal stdCost)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PK

public static final java.lang.String ORDER_BY_PK
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_STDCOST

public static final java.lang.String ORDER_BY_STDCOST
See Also:
Constant Field Values

ORDER_BY_AVGCOST

public static final java.lang.String ORDER_BY_AVGCOST
See Also:
Constant Field Values

ORDER_BY_ROLLUPCOST

public static final java.lang.String ORDER_BY_ROLLUPCOST
See Also:
Constant Field Values

ORDER_BY_ONHAND

public static final java.lang.String ORDER_BY_ONHAND
See Also:
Constant Field Values

ORDER_BY_LEVEL

public static final java.lang.String ORDER_BY_LEVEL
See Also:
Constant Field Values
Constructor Detail

RollUpBomStdCostWorkSheetItemVO

public RollUpBomStdCostWorkSheetItemVO()
Method Detail

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getPk

public RollUpBomStdCostWorkSheetItemPK getPk()

setPk

public void setPk(RollUpBomStdCostWorkSheetItemPK pk)

getRollUpCost

public java.math.BigDecimal getRollUpCost()

setRollUpCost

public void setRollUpCost(java.math.BigDecimal rollUpCost)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getAvgCost

public java.math.BigDecimal getAvgCost()

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

getLevel

public java.lang.Integer getLevel()

setLevel

public void setLevel(java.lang.Integer level)

getOnHand

public java.math.BigDecimal getOnHand()

setOnHand

public void setOnHand(java.math.BigDecimal onHand)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RollUpBomStdCostWorkSheetVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RollUpBomStdCostWorkSheetVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.RollUpBomStdCostWorkSheetVO
All Implemented Interfaces:
java.io.Serializable
public class RollUpBomStdCostWorkSheetVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_BOMCOUNT
static java.lang.String | ORDER_BY_COMMITTEDBY
static java.lang.String | ORDER_BY_COMMITTEDDATE
static java.lang.String | ORDER_BY_CREATEDBY
static java.lang.String | ORDER_BY_CREATEDDATE
static java.lang.String | ORDER_BY_ENDDATE
static java.lang.String | ORDER_BY_II
static java.lang.String | ORDER_BY_LOG
static java.lang.String | ORDER_BY_ROLLUPCOUNT
static java.lang.String | ORDER_BY_STARTDATE
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_TRANSACTIONNUMBER
static java.lang.String | ORDER_BY_USEAVGCOSTTOROLLUP
static java.lang.String | ORDER_BY_VARIANCEAMOUNT
static java.lang.String | ORDER_BY_VARIANCECOUNT
Constructor Summary
RollUpBomStdCostWorkSheetVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Integer | getBomCount()
java.lang.String | getCommittedBy()
java.util.Date | getCommittedDate()
java.lang.String | getCreatedBy()
java.util.Date | getCreatedDate()
java.util.Date | getEndDate()
java.lang.Long | getIi()
java.lang.String | getLog()
java.lang.Integer | getRollUpCount()
java.util.Date | getStartDate()
java.lang.String | getStatus()
java.lang.String | getTransactionNumber()
java.math.BigDecimal | getVarianceAmount()
java.lang.Integer | getVarianceCount()
int | hashCode()
boolean | isUseAvgCostToRollUp()
void | setBomCount(java.lang.Integer bomCount)
void | setCommittedBy(java.lang.String committedBy)
void | setCommittedDate(java.util.Date committedDate)
void | setCreatedBy(java.lang.String createdBy)
void | setCreatedDate(java.util.Date createdDate)
void | setEndDate(java.util.Date endDate)
void | setIi(java.lang.Long ii)
void | setLog(java.lang.String log)
void | setRollUpCount(java.lang.Integer rollUpCount)
void | setStartDate(java.util.Date startDate)
void | setStatus(java.lang.String status)
void | setTransactionNumber(java.lang.String transactionNumber)
void | setUseAvgCostToRollUp(boolean useAvgCostToRollUp)
void | setVarianceAmount(java.math.BigDecimal varianceAmount)
void | setVarianceCount(java.lang.Integer varianceCount)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_II

public static final java.lang.String ORDER_BY_II
See Also:
Constant Field Values

ORDER_BY_CREATEDBY

public static final java.lang.String ORDER_BY_CREATEDBY
See Also:
Constant Field Values

ORDER_BY_CREATEDDATE

public static final java.lang.String ORDER_BY_CREATEDDATE
See Also:
Constant Field Values

ORDER_BY_STARTDATE

public static final java.lang.String ORDER_BY_STARTDATE
See Also:
Constant Field Values

ORDER_BY_ENDDATE

public static final java.lang.String ORDER_BY_ENDDATE
See Also:
Constant Field Values

ORDER_BY_BOMCOUNT

public static final java.lang.String ORDER_BY_BOMCOUNT
See Also:
Constant Field Values

ORDER_BY_ROLLUPCOUNT

public static final java.lang.String ORDER_BY_ROLLUPCOUNT
See Also:
Constant Field Values

ORDER_BY_VARIANCECOUNT

public static final java.lang.String ORDER_BY_VARIANCECOUNT
See Also:
Constant Field Values

ORDER_BY_VARIANCEAMOUNT

public static final java.lang.String ORDER_BY_VARIANCEAMOUNT
See Also:
Constant Field Values

ORDER_BY_COMMITTEDDATE

public static final java.lang.String ORDER_BY_COMMITTEDDATE
See Also:
Constant Field Values

ORDER_BY_COMMITTEDBY

public static final java.lang.String ORDER_BY_COMMITTEDBY
See Also:
Constant Field Values

ORDER_BY_TRANSACTIONNUMBER

public static final java.lang.String ORDER_BY_TRANSACTIONNUMBER
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_LOG

public static final java.lang.String ORDER_BY_LOG
See Also:
Constant Field Values

ORDER_BY_USEAVGCOSTTOROLLUP

public static final java.lang.String ORDER_BY_USEAVGCOSTTOROLLUP
See Also:
Constant Field Values
Constructor Detail

RollUpBomStdCostWorkSheetVO

public RollUpBomStdCostWorkSheetVO()
Method Detail

getBomCount

public java.lang.Integer getBomCount()

setBomCount

public void setBomCount(java.lang.Integer bomCount)

getCommittedBy

public java.lang.String getCommittedBy()

setCommittedBy

public void setCommittedBy(java.lang.String committedBy)

getCommittedDate

public java.util.Date getCommittedDate()

setCommittedDate

public void setCommittedDate(java.util.Date committedDate)

getEndDate

public java.util.Date getEndDate()

setEndDate

public void setEndDate(java.util.Date endDate)

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getRollUpCount

public java.lang.Integer getRollUpCount()

setRollUpCount

public void setRollUpCount(java.lang.Integer rollUpCount)

getStartDate

public java.util.Date getStartDate()

setStartDate

public void setStartDate(java.util.Date startDate)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getVarianceCount

public java.lang.Integer getVarianceCount()

setVarianceCount

public void setVarianceCount(java.lang.Integer varianceCount)

getLog

public java.lang.String getLog()

setLog

public void setLog(java.lang.String log)

getCreatedBy

public java.lang.String getCreatedBy()

setCreatedBy

public void setCreatedBy(java.lang.String createdBy)

getCreatedDate

public java.util.Date getCreatedDate()

setCreatedDate

public void setCreatedDate(java.util.Date createdDate)

getVarianceAmount

public java.math.BigDecimal getVarianceAmount()

setVarianceAmount

public void setVarianceAmount(java.math.BigDecimal varianceAmount)

getTransactionNumber

public java.lang.String getTransactionNumber()

setTransactionNumber

public void setTransactionNumber(java.lang.String transactionNumber)

isUseAvgCostToRollUp

public boolean isUseAvgCostToRollUp()

setUseAvgCostToRollUp

public void setUseAvgCostToRollUp(boolean useAvgCostToRollUp)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RollUPPartStandardCostResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RollUPPartStandardCostResult

java.lang.Object
    extended by  bb.common.RollUPPartStandardCostResult
All Implemented Interfaces:
java.io.Serializable
public class RollUPPartStandardCostResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
RollUPPartStandardCostResult()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getBill()
java.lang.String | getDescription()
java.lang.String | getPcode()
PartPK | getPk()
java.math.BigDecimal | getRollupStdCost()
java.math.BigDecimal | getStandardCost()
int | hashCode()
void | setBill(java.lang.String bill)
void | setDescription(java.lang.String description)
void | setPcode(java.lang.String pcode)
void | setPk(PartPK pk)
void | setRollupStdCost(java.math.BigDecimal rollupStdCost)
void | setStandardCost(java.math.BigDecimal standardCost)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

RollUPPartStandardCostResult

public RollUPPartStandardCostResult()
Method Detail

getBill

public java.lang.String getBill()

setBill

public void setBill(java.lang.String bill)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getPk

public PartPK getPk()

setPk

public void setPk(PartPK pk)

getRollupStdCost

public java.math.BigDecimal getRollupStdCost()

setRollupStdCost

public void setRollupStdCost(java.math.BigDecimal rollupStdCost)

getStandardCost

public java.math.BigDecimal getStandardCost()

setStandardCost

public void setStandardCost(java.math.BigDecimal standardCost)

getPcode

public java.lang.String getPcode()

setPcode

public void setPcode(java.lang.String pcode)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RRMAItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RRMAItemListResult

java.lang.Object
    extended by  bb.common.RRMAItemListResult
All Implemented Interfaces:
java.io.Serializable
public class RRMAItemListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String ORDER_BY_CRTVNUMBER
Constructor Summary
RRMAItemListResult()
Method Summary
java.lang.String | getCompanyUnitId()
java.math.BigDecimal | getCostPerUnit()
java.lang.String | getCustomerId()
java.lang.String | getDebitAccount()
java.util.Date | getDeliveryDate()
java.math.BigDecimal | getDiscount()
java.lang.String | getInvoiceNumber()
java.lang.String | getItemDescription()
java.math.BigDecimal | getOnDemandQty()
java.math.BigDecimal | getOnhandQty()
java.math.BigDecimal | getOnorderQty()
java.math.BigDecimal | getOrderedQty()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.util.Date | getRrmaDate()
java.lang.String | getRrmaItemNumber()
java.lang.String | getRrmaNumber()
java.lang.String | getSalesman()
java.lang.String | getSalesOrderNumber()
java.lang.String | getStatus()
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCostPerUnit(java.math.BigDecimal costPerUnit)
void | setCustomerId(java.lang.String customerId)
void | setDebitAccount(java.lang.String debitAccount)
void | setDeliveryDate(java.util.Date deliveryDate)
void | setDiscount(java.math.BigDecimal discount)
void | setInvoiceNumber(java.lang.String invoiceNumber)
void | setItemDescription(java.lang.String itemDescription)
void | setOnDemandQty(java.math.BigDecimal onDemandQty)
void | setOnhandQty(java.math.BigDecimal onhandQty)
void | setOnorderQty(java.math.BigDecimal onorderQty)
void | setOrderedQty(java.math.BigDecimal orderedQty)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setRrmaDate(java.util.Date rrmaDate)
void | setRrmaItemNumber(java.lang.String rrmaItemNumber)
void | setRrmaNumber(java.lang.String rrmaNumber)
void | setSalesman(java.lang.String salesman)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setStatus(java.lang.String status)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_CRTVNUMBER

public static final java.lang.String ORDER_BY_CRTVNUMBER
See Also:
Constant Field Values
Constructor Detail

RRMAItemListResult

public RRMAItemListResult()
Method Detail

getRrmaNumber

public java.lang.String getRrmaNumber()

setRrmaNumber

public void setRrmaNumber(java.lang.String rrmaNumber)

getRrmaItemNumber

public java.lang.String getRrmaItemNumber()

setRrmaItemNumber

public void setRrmaItemNumber(java.lang.String rrmaItemNumber)

getPartPk

public PartPK getPartPk()

setPartPk

public void setPartPk(PartPK partPk)

getItemDescription

public java.lang.String getItemDescription()

setItemDescription

public void setItemDescription(java.lang.String itemDescription)

getRrmaDate

public java.util.Date getRrmaDate()

setRrmaDate

public void setRrmaDate(java.util.Date rrmaDate)

getDeliveryDate

public java.util.Date getDeliveryDate()

setDeliveryDate

public void setDeliveryDate(java.util.Date deliveryDate)

getOrderedQty

public java.math.BigDecimal getOrderedQty()

setOrderedQty

public void setOrderedQty(java.math.BigDecimal orderedQty)

getCostPerUnit

public java.math.BigDecimal getCostPerUnit()

setCostPerUnit

public void setCostPerUnit(java.math.BigDecimal costPerUnit)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getInvoiceNumber

public java.lang.String getInvoiceNumber()

setInvoiceNumber

public void setInvoiceNumber(java.lang.String invoiceNumber)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getSalesman

public java.lang.String getSalesman()

setSalesman

public void setSalesman(java.lang.String salesman)

getOnhandQty

public java.math.BigDecimal getOnhandQty()

setOnhandQty

public void setOnhandQty(java.math.BigDecimal onhandQty)

getOnorderQty

public java.math.BigDecimal getOnorderQty()

setOnorderQty

public void setOnorderQty(java.math.BigDecimal onorderQty)

getOnDemandQty

public java.math.BigDecimal getOnDemandQty()

setOnDemandQty

public void setOnDemandQty(java.math.BigDecimal onDemandQty)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getDebitAccount

public java.lang.String getDebitAccount()

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RRMAListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RRMAListResult

java.lang.Object
    extended by  bb.common.RRMAListResult
All Implemented Interfaces:
java.io.Serializable
public class RRMAListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CHANGEORDER
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_CRTVDATE
static java.lang.String | ORDER_BY_CRTVNUMBER
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_INVOICENUMBER
static java.lang.String | ORDER_BY_PROJECTNAME
static java.lang.String | ORDER_BY_SALESMAN
static java.lang.String | ORDER_BY_SALESORDERNUMBER
Constructor Summary
RRMAListResult()
Method Summary
java.lang.String | getChangeOrder()
java.lang.String | getComments()
java.lang.String | getCustomerId()
java.lang.String | getInvoiceNumber()
java.lang.String | getPrivateNote()
java.lang.String | getProject()
java.lang.String | getRequester()
java.util.Date | getRrmaDate()
java.lang.String | getRrmaNumber()
java.lang.String | getSalesman()
java.lang.String | getSalesOrderNumber()
java.lang.String | getStatus()
void | setChangeOrder(java.lang.String changeOrder)
void | setComments(java.lang.String comments)
void | setCustomerId(java.lang.String customerId)
void | setInvoiceNumber(java.lang.String invoiceNumber)
void | setPrivateNote(java.lang.String privateNote)
void | setProject(java.lang.String project)
void | setRequester(java.lang.String requester)
void | setRrmaDate(java.util.Date rrmaDate)
void | setRrmaNumber(java.lang.String rrmamNuber)
void | setSalesman(java.lang.String salesman)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setStatus(java.lang.String status)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_CRTVNUMBER

public static final java.lang.String ORDER_BY_CRTVNUMBER
See Also:
Constant Field Values

ORDER_BY_CHANGEORDER

public static final java.lang.String ORDER_BY_CHANGEORDER
See Also:
Constant Field Values

ORDER_BY_CRTVDATE

public static final java.lang.String ORDER_BY_CRTVDATE
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_INVOICENUMBER

public static final java.lang.String ORDER_BY_INVOICENUMBER
See Also:
Constant Field Values

ORDER_BY_SALESORDERNUMBER

public static final java.lang.String ORDER_BY_SALESORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_PROJECTNAME

public static final java.lang.String ORDER_BY_PROJECTNAME
See Also:
Constant Field Values

ORDER_BY_SALESMAN

public static final java.lang.String ORDER_BY_SALESMAN
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values
Constructor Detail

RRMAListResult

public RRMAListResult()
Method Detail

getRrmaNumber

public java.lang.String getRrmaNumber()

setRrmaNumber

public void setRrmaNumber(java.lang.String rrmamNuber)

getRrmaDate

public java.util.Date getRrmaDate()

setRrmaDate

public void setRrmaDate(java.util.Date rrmaDate)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getInvoiceNumber

public java.lang.String getInvoiceNumber()

setInvoiceNumber

public void setInvoiceNumber(java.lang.String invoiceNumber)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

getPrivateNote

public java.lang.String getPrivateNote()

setPrivateNote

public void setPrivateNote(java.lang.String privateNote)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getRequester

public java.lang.String getRequester()

setRequester

public void setRequester(java.lang.String requester)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getSalesman

public java.lang.String getSalesman()

setSalesman

public void setSalesman(java.lang.String salesman)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RTVApprovalVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RTVApprovalVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.RTVApprovalVO
All Implemented Interfaces:
java.io.Serializable
public class RTVApprovalVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_APPROVALLIMIT
static java.lang.String | ORDER_BY_CANAPPROVEOWNRTV
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_EMPLOYEEID
static java.lang.String | ORDER_BY_USERNAME
Constructor Summary
RTVApprovalVO()
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getApprovalLimit()
java.lang.String | getCanApproveOwnRTV()
java.lang.String | getComments()
java.lang.String | getCurrency()
java.lang.String | getEmployeeID()
java.lang.String | getUserName()
int | hashCode()
void | setApprovalLimit(java.math.BigDecimal approvalLimit)
void | setCanApproveOwnRTV(java.lang.String canApproveOwnRTV)
void | setComments(java.lang.String comments)
void | setCurrency(java.lang.String currency)
void | setEmployeeID(java.lang.String employeeID)
void | setUserName(java.lang.String userName)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_EMPLOYEEID

public static final java.lang.String ORDER_BY_EMPLOYEEID
See Also:
Constant Field Values

ORDER_BY_USERNAME

public static final java.lang.String ORDER_BY_USERNAME
See Also:
Constant Field Values

ORDER_BY_APPROVALLIMIT

public static final java.lang.String ORDER_BY_APPROVALLIMIT
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values

ORDER_BY_CANAPPROVEOWNRTV

public static final java.lang.String ORDER_BY_CANAPPROVEOWNRTV
See Also:
Constant Field Values
Constructor Detail

RTVApprovalVO

public RTVApprovalVO()
Method Detail

getEmployeeID

public java.lang.String getEmployeeID()

setEmployeeID

public void setEmployeeID(java.lang.String employeeID)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getApprovalLimit

public java.math.BigDecimal getApprovalLimit()

setApprovalLimit

public void setApprovalLimit(java.math.BigDecimal approvalLimit)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getCanApproveOwnRTV

public java.lang.String getCanApproveOwnRTV()

setCanApproveOwnRTV

public void setCanApproveOwnRTV(java.lang.String canApproveOwnRTV)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RtvShipperInfoVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RtvShipperInfoVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.RtvShipperInfoVO
All Implemented Interfaces:
java.io.Serializable
public class RtvShipperInfoVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_DATESHIPPED
static java.lang.String | ORDER_BY_PONUMBER
static java.lang.String | ORDER_BY_RTVNUMBER
static java.lang.String | ORDER_BY_RTVSHIPPERNUMBER
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_VENDORID
Constructor Summary
RtvShipperInfoVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.math.BigDecimal | getApDiscount()
java.math.BigDecimal | getApFreight()
java.math.BigDecimal | getApGl1Recorded()
java.math.BigDecimal | getApGl2Paid()
java.math.BigDecimal | getApNet()
java.lang.String | getApNetSet()
java.lang.String | getApNumber()
java.math.BigDecimal | getApOpen()
java.math.BigDecimal | getApPaidGl()
java.math.BigDecimal | getApPaidInv()
java.math.BigDecimal | getApShip()
java.math.BigDecimal | getApSub()
java.math.BigDecimal | getApTax()
java.lang.String | getApTaxSet()
java.math.BigDecimal | getApTotal()
java.lang.String | getBatch()
CustomerVendorAddressInfoVO | getBillToAddressInfo()
java.lang.String | getBilltoId()
java.lang.String | getBp()
java.lang.String | getCarrier()
java.lang.String | getCarrierAccount()
java.lang.String | getChangeOrder()
java.lang.String | getCheckNumber()
java.lang.String | getCoComments()
java.lang.String | getComments()
java.lang.String | getCurrency()
java.util.Date | getDateInvoiced()
java.util.Date | getDatePaid()
java.util.Date | getDateShipped()
java.lang.String | getDebitAccount()
java.math.BigDecimal | getDue()
java.lang.String | getFreightBill()
java.lang.String | getFreightRateCode()
java.lang.String | getGrossWeight()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getInvoicedBy()
java.util.Date | getInvoicedDate()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getNotes()
java.lang.String | getOrigin()
java.lang.String | getOtran()
java.math.BigDecimal | getPaid()
java.util.Date | getPaydate()
java.lang.String | getPoNumber()
java.lang.String | getReldoc()
java.lang.String | getRemitId()
java.lang.String | getRtran()
java.lang.String | getRtvNumber()
java.lang.String | getRtvShipperNumber()
java.lang.String | getSalesman()
java.lang.String | getShBplate()
java.lang.String | getShippedBy()
java.util.Date | getShippedDate()
CustomerVendorAddressInfoVO | getShipToAddressInfo()
java.lang.String | getShipToId()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.lang.String | getTerms()
java.lang.String | getTracking()
java.lang.String | getVendorId()
int | getVersion()
int | hashCode()
boolean | isVendorPicked()
void | setAdate(java.util.Date adate)
void | setApDiscount(java.math.BigDecimal apDiscount)
void | setApFreight(java.math.BigDecimal apFreight)
void | setApGl1Recorded(java.math.BigDecimal apGl1Recorded)
void | setApGl2Paid(java.math.BigDecimal apGl2Paid)
void | setApNet(java.math.BigDecimal apNet)
void | setApNetSet(java.lang.String apNetSet)
void | setApNumber(java.lang.String apNumber)
void | setApOpen(java.math.BigDecimal apOpen)
void | setApPaidGl(java.math.BigDecimal apPaidGl)
void | setApPaidInv(java.math.BigDecimal apPaidInv)
void | setApShip(java.math.BigDecimal apShip)
void | setApSub(java.math.BigDecimal apSub)
void | setApTax(java.math.BigDecimal apTax)
void | setApTaxSet(java.lang.String apTaxSet)
void | setApTotal(java.math.BigDecimal apTotal)
void | setBatch(java.lang.String batch)
void | setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | setBilltoId(java.lang.String billtoId)
void | setBp(java.lang.String bp)
void | setCarrier(java.lang.String carrier)
void | setCarrierAccount(java.lang.String carrierAccount)
void | setChangeOrder(java.lang.String changeOrder)
void | setCheckNumber(java.lang.String checkNumber)
void | setCoComments(java.lang.String coComments)
void | setComments(java.lang.String comments)
void | setCurrency(java.lang.String currency)
void | setDateInvoiced(java.util.Date dateInvoiced)
void | setDatePaid(java.util.Date datePaid)
void | setDateShipped(java.util.Date dateShipped)
void | setDebitAccount(java.lang.String debitAccount)
void | setDue(java.math.BigDecimal due)
void | setFreightBill(java.lang.String freightBill)
void | setFreightRateCode(java.lang.String freightRateCode)
void | setGrossWeight(java.lang.String grossWeight)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setInvoicedBy(java.lang.String invoicedBy)
void | setInvoicedDate(java.util.Date invoicedDate)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setNotes(java.lang.String notes)
void | setOrigin(java.lang.String origin)
void | setOtran(java.lang.String otran)
void | setPaid(java.math.BigDecimal paid)
void | setPaydate(java.util.Date paydate)
void | setPoNumber(java.lang.String poNumber)
void | setReldoc(java.lang.String reldoc)
void | setRemitId(java.lang.String remitId)
void | setRtran(java.lang.String rtran)
void | setRtvNumber(java.lang.String rtvNumber)
void | setRtvShipperNumber(java.lang.String rtvShipperNumber)
void | setSalesman(java.lang.String salesman)
void | setShBplate(java.lang.String shBplate)
void | setShippedBy(java.lang.String shippedBy)
void | setShippedDate(java.util.Date shippedDate)
void | setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | setShipToId(java.lang.String shipToId)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setTerms(java.lang.String terms)
void | setTracking(java.lang.String tracking)
void | setVendorId(java.lang.String vendorId)
void | setVendorPicked(boolean vendorPicked)
void | setVersion(int version)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_RTVSHIPPERNUMBER

public static final java.lang.String ORDER_BY_RTVSHIPPERNUMBER
See Also:
Constant Field Values

ORDER_BY_RTVNUMBER

public static final java.lang.String ORDER_BY_RTVNUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_PONUMBER

public static final java.lang.String ORDER_BY_PONUMBER
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_DATESHIPPED

public static final java.lang.String ORDER_BY_DATESHIPPED
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values
Constructor Detail

RtvShipperInfoVO

public RtvShipperInfoVO()
default constructor

Method Detail

getRtvShipperNumber

public java.lang.String getRtvShipperNumber()

setRtvShipperNumber

public void setRtvShipperNumber(java.lang.String rtvShipperNumber)

getRtvNumber

public java.lang.String getRtvNumber()

setRtvNumber

public void setRtvNumber(java.lang.String rtvNumber)

getApNumber

public java.lang.String getApNumber()

setApNumber

public void setApNumber(java.lang.String apNumber)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getBatch

public java.lang.String getBatch()

setBatch

public void setBatch(java.lang.String batch)

getBilltoId

public java.lang.String getBilltoId()

setBilltoId

public void setBilltoId(java.lang.String billtoId)

getPoNumber

public java.lang.String getPoNumber()

setPoNumber

public void setPoNumber(java.lang.String poNumber)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getApNetSet

public java.lang.String getApNetSet()

setApNetSet

public void setApNetSet(java.lang.String apNetSet)

getApTaxSet

public java.lang.String getApTaxSet()

setApTaxSet

public void setApTaxSet(java.lang.String apTaxSet)

getApSub

public java.math.BigDecimal getApSub()

setApSub

public void setApSub(java.math.BigDecimal apSub)

getApShip

public java.math.BigDecimal getApShip()

setApShip

public void setApShip(java.math.BigDecimal apShip)

getApOpen

public java.math.BigDecimal getApOpen()

setApOpen

public void setApOpen(java.math.BigDecimal apOpen)

getApDiscount

public java.math.BigDecimal getApDiscount()

setApDiscount

public void setApDiscount(java.math.BigDecimal apDiscount)

getApNet

public java.math.BigDecimal getApNet()

setApNet

public void setApNet(java.math.BigDecimal apNet)

getApTax

public java.math.BigDecimal getApTax()

setApTax

public void setApTax(java.math.BigDecimal apTax)

getApFreight

public java.math.BigDecimal getApFreight()

setApFreight

public void setApFreight(java.math.BigDecimal apFreight)

getApTotal

public java.math.BigDecimal getApTotal()

setApTotal

public void setApTotal(java.math.BigDecimal apTotal)

getApPaidInv

public java.math.BigDecimal getApPaidInv()

setApPaidInv

public void setApPaidInv(java.math.BigDecimal apPaidInv)

getApPaidGl

public java.math.BigDecimal getApPaidGl()

setApPaidGl

public void setApPaidGl(java.math.BigDecimal apPaidGl)

getApGl1Recorded

public java.math.BigDecimal getApGl1Recorded()

setApGl1Recorded

public void setApGl1Recorded(java.math.BigDecimal apGl1Recorded)

getApGl2Paid

public java.math.BigDecimal getApGl2Paid()

setApGl2Paid

public void setApGl2Paid(java.math.BigDecimal apGl2Paid)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getCoComments

public java.lang.String getCoComments()

setCoComments

public void setCoComments(java.lang.String coComments)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getSalesman

public java.lang.String getSalesman()

setSalesman

public void setSalesman(java.lang.String salesman)

getShippedDate

public java.util.Date getShippedDate()

setShippedDate

public void setShippedDate(java.util.Date shippedDate)

getShippedBy

public java.lang.String getShippedBy()

setShippedBy

public void setShippedBy(java.lang.String shippedBy)

getInvoicedDate

public java.util.Date getInvoicedDate()

setInvoicedDate

public void setInvoicedDate(java.util.Date invoicedDate)

getInvoicedBy

public java.lang.String getInvoicedBy()

setInvoicedBy

public void setInvoicedBy(java.lang.String invoicedBy)

getShipToId

public java.lang.String getShipToId()

setShipToId

public void setShipToId(java.lang.String shipToId)

getRemitId

public java.lang.String getRemitId()

setRemitId

public void setRemitId(java.lang.String remitId)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAccount

public java.lang.String getCarrierAccount()

setCarrierAccount

public void setCarrierAccount(java.lang.String carrierAccount)

getFreightRateCode

public java.lang.String getFreightRateCode()

setFreightRateCode

public void setFreightRateCode(java.lang.String freightRateCode)

getGrossWeight

public java.lang.String getGrossWeight()

setGrossWeight

public void setGrossWeight(java.lang.String grossWeight)

getTracking

public java.lang.String getTracking()

setTracking

public void setTracking(java.lang.String tracking)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getDateShipped

public java.util.Date getDateShipped()

setDateShipped

public void setDateShipped(java.util.Date dateShipped)

getDateInvoiced

public java.util.Date getDateInvoiced()

setDateInvoiced

public void setDateInvoiced(java.util.Date dateInvoiced)

getFreightBill

public java.lang.String getFreightBill()

setFreightBill

public void setFreightBill(java.lang.String freightBill)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getReldoc

public java.lang.String getReldoc()

setReldoc

public void setReldoc(java.lang.String reldoc)

getDebitAccount

public java.lang.String getDebitAccount()

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

getBp

public java.lang.String getBp()

setBp

public void setBp(java.lang.String bp)

getShBplate

public java.lang.String getShBplate()

setShBplate

public void setShBplate(java.lang.String shBplate)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getNotes

public java.lang.String getNotes()

setNotes

public void setNotes(java.lang.String notes)

getDue

public java.math.BigDecimal getDue()

setDue

public void setDue(java.math.BigDecimal due)

getPaydate

public java.util.Date getPaydate()

setPaydate

public void setPaydate(java.util.Date paydate)

getDatePaid

public java.util.Date getDatePaid()

setDatePaid

public void setDatePaid(java.util.Date datePaid)

getCheckNumber

public java.lang.String getCheckNumber()

setCheckNumber

public void setCheckNumber(java.lang.String checkNumber)

getPaid

public java.math.BigDecimal getPaid()

setPaid

public void setPaid(java.math.BigDecimal paid)

getOtran

public java.lang.String getOtran()

setOtran

public void setOtran(java.lang.String otran)

getRtran

public java.lang.String getRtran()

setRtran

public void setRtran(java.lang.String rtran)

getVersion

public int getVersion()

setVersion

public void setVersion(int version)

getShipToAddressInfo

public CustomerVendorAddressInfoVO getShipToAddressInfo()

setShipToAddressInfo

public void setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)

getBillToAddressInfo

public CustomerVendorAddressInfoVO getBillToAddressInfo()

setBillToAddressInfo

public void setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

isVendorPicked

public boolean isVendorPicked()

setVendorPicked

public void setVendorPicked(boolean vendorPicked)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RtvShipperItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RtvShipperItemListResult

java.lang.Object
    extended by  bb.common.RtvShipperItemListResult
All Implemented Interfaces:
java.io.Serializable
public class RtvShipperItemListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_apNumber
static java.lang.String | ORDER_BY_costPerUnit
static java.lang.String | ORDER_BY_dateShipped
static java.lang.String | ORDER_BY_description
static java.lang.String | ORDER_BY_partNumber
static java.lang.String | ORDER_BY_poNumber
static java.lang.String | ORDER_BY_qty
static java.lang.String | ORDER_BY_qtyShip
static java.lang.String | ORDER_BY_rtvNumber
static java.lang.String | ORDER_BY_rtvShipperItemNumber
static java.lang.String | ORDER_BY_RTVSHIPPERNUMBER
static java.lang.String | ORDER_BY_status
static java.lang.String | ORDER_BY_vendorId
Constructor Summary
RtvShipperItemListResult()
Method Summary
java.lang.String | getApNumber()
java.lang.String | getComments()
java.math.BigDecimal | getCostPerUnit()
java.util.Date | getDateShipped()
java.lang.String | getDescription()
java.lang.String | getNotes()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getPoNumber()
java.math.BigDecimal | getQty()
java.math.BigDecimal | getQtyShip()
java.lang.String | getRtvNumber()
java.lang.String | getRtvShipperItemNumber()
java.lang.String | getRtvShipperNumber()
java.lang.String | getShipvia()
java.lang.String | getStatus()
java.lang.String | getVendorId()
void | setApNumber(java.lang.String apNumber)
void | setComments(java.lang.String comments)
void | setCostPerUnit(java.math.BigDecimal costPerUnit)
void | setDateShipped(java.util.Date dateShipped)
void | setDescription(java.lang.String description)
void | setNotes(java.lang.String notes)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPoNumber(java.lang.String poNumber)
void | setQty(java.math.BigDecimal qty)
void | setQtyShip(java.math.BigDecimal qtyShip)
void | setRtvNumber(java.lang.String rtvNumber)
void | setRtvShipperItemNumber(java.lang.String rtvShipperItemNumber)
void | setRtvShipperNumber(java.lang.String rtvShipperNumber)
void | setShipvia(java.lang.String shipvia)
void | setStatus(java.lang.String status)
void | setVendorId(java.lang.String vendorId)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_RTVSHIPPERNUMBER

public static final java.lang.String ORDER_BY_RTVSHIPPERNUMBER
See Also:
Constant Field Values

ORDER_BY_rtvShipperItemNumber

public static final java.lang.String ORDER_BY_rtvShipperItemNumber
See Also:
Constant Field Values

ORDER_BY_rtvNumber

public static final java.lang.String ORDER_BY_rtvNumber
See Also:
Constant Field Values

ORDER_BY_dateShipped

public static final java.lang.String ORDER_BY_dateShipped
See Also:
Constant Field Values

ORDER_BY_status

public static final java.lang.String ORDER_BY_status
See Also:
Constant Field Values

ORDER_BY_partNumber

public static final java.lang.String ORDER_BY_partNumber
See Also:
Constant Field Values

ORDER_BY_qty

public static final java.lang.String ORDER_BY_qty
See Also:
Constant Field Values

ORDER_BY_qtyShip

public static final java.lang.String ORDER_BY_qtyShip
See Also:
Constant Field Values

ORDER_BY_costPerUnit

public static final java.lang.String ORDER_BY_costPerUnit
See Also:
Constant Field Values

ORDER_BY_poNumber

public static final java.lang.String ORDER_BY_poNumber
See Also:
Constant Field Values

ORDER_BY_description

public static final java.lang.String ORDER_BY_description
See Also:
Constant Field Values

ORDER_BY_vendorId

public static final java.lang.String ORDER_BY_vendorId
See Also:
Constant Field Values

ORDER_BY_apNumber

public static final java.lang.String ORDER_BY_apNumber
See Also:
Constant Field Values
Constructor Detail

RtvShipperItemListResult

public RtvShipperItemListResult()
Method Detail

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getDateShipped

public java.util.Date getDateShipped()

setDateShipped

public void setDateShipped(java.util.Date dateShipped)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getNotes

public java.lang.String getNotes()

setNotes

public void setNotes(java.lang.String notes)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

getQtyShip

public java.math.BigDecimal getQtyShip()

setQtyShip

public void setQtyShip(java.math.BigDecimal qtyShip)

getRtvNumber

public java.lang.String getRtvNumber()

setRtvNumber

public void setRtvNumber(java.lang.String rtvNumber)

getRtvShipperItemNumber

public java.lang.String getRtvShipperItemNumber()

setRtvShipperItemNumber

public void setRtvShipperItemNumber(java.lang.String rtvShipperItemNumber)

getRtvShipperNumber

public java.lang.String getRtvShipperNumber()

setRtvShipperNumber

public void setRtvShipperNumber(java.lang.String rtvShipperNumber)

getShipvia

public java.lang.String getShipvia()

setShipvia

public void setShipvia(java.lang.String shipvia)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getPoNumber

public java.lang.String getPoNumber()

setPoNumber

public void setPoNumber(java.lang.String poNumber)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getApNumber

public java.lang.String getApNumber()

setApNumber

public void setApNumber(java.lang.String apNumber)

getCostPerUnit

public java.math.BigDecimal getCostPerUnit()

setCostPerUnit

public void setCostPerUnit(java.math.BigDecimal costPerUnit)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RtvShipperItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RtvShipperItemPK

java.lang.Object
    extended by  bb.common.RtvShipperItemPK
All Implemented Interfaces:
java.io.Serializable
public class RtvShipperItemPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
RtvShipperItemPK()
default constructor
RtvShipperItemPK(java.lang.String rtvShipperNumber, java.lang.String rtvShipperItemNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getRtvShipperItemNumber()
java.lang.String | getRtvShipperNumber()
int | hashCode()
void | setRtvShipperItemNumber(java.lang.String rtvShipperItemNumber)
void | setRtvShipperNumber(java.lang.String rtvShipperNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

RtvShipperItemPK

public RtvShipperItemPK(java.lang.String rtvShipperNumber,
                        java.lang.String rtvShipperItemNumber)
full constructor

RtvShipperItemPK

public RtvShipperItemPK()
default constructor

Method Detail

getRtvShipperNumber

public java.lang.String getRtvShipperNumber()

setRtvShipperNumber

public void setRtvShipperNumber(java.lang.String rtvShipperNumber)

getRtvShipperItemNumber

public java.lang.String getRtvShipperItemNumber()

setRtvShipperItemNumber

public void setRtvShipperItemNumber(java.lang.String rtvShipperItemNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RtvShipperItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RtvShipperItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.RtvShipperItemVO
All Implemented Interfaces:
java.io.Serializable
public class RtvShipperItemVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
RtvShipperItemVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getApDisc()
java.math.BigDecimal | getApNet()
java.math.BigDecimal | getApOpen()
java.math.BigDecimal | getApShip()
java.math.BigDecimal | getApSub()
java.math.BigDecimal | getApTax()
java.math.BigDecimal | getApTotal()
java.math.BigDecimal | getAvgCost()
java.lang.String | getCheckNo()
java.lang.String | getComments()
java.util.Date | getDateInvoiced()
java.util.Date | getDatePaid()
java.util.Date | getDateShipped()
java.lang.String | getDescription()
java.math.BigDecimal | getDiscount()
java.math.BigDecimal | getDue()
java.math.BigDecimal | getItemGrandTotal()
java.math.BigDecimal | getListPrice()
java.lang.String | getLocate()
java.util.Map | getLocations()
java.lang.String | getMfg()
java.lang.String | getMoldNumber()
java.lang.String | getMpn()
java.lang.String | getNotes()
java.math.BigDecimal | getPaid()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
RtvShipperItemPK | getPk()
java.math.BigDecimal | getQty()
java.math.BigDecimal | getQtyShip()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.util.Set | getRefDocOnes()
java.util.Set | getRefDocTwoes()
java.lang.String | getRevision()
java.lang.String | getRtvNumber()
java.lang.String | getSerial()
java.lang.String | getShipto()
java.lang.String | getShipvia()
java.lang.String | getStatus()
java.math.BigDecimal | getStdCost()
java.math.BigDecimal | getTaxRate()
java.util.Map | getTrackings()
java.lang.String | getUnit()
int | hashCode()
void | setApDisc(java.math.BigDecimal apDisc)
void | setApNet(java.math.BigDecimal apNet)
void | setApOpen(java.math.BigDecimal apOpen)
void | setApShip(java.math.BigDecimal apShip)
void | setApSub(java.math.BigDecimal apSub)
void | setApTax(java.math.BigDecimal apTax)
void | setApTotal(java.math.BigDecimal apTotal)
void | setAvgCost(java.math.BigDecimal avgCost)
void | setCheckNo(java.lang.String checkNo)
void | setComments(java.lang.String comments)
void | setDateInvoiced(java.util.Date dateInvoiced)
void | setDatePaid(java.util.Date datePaid)
void | setDateShipped(java.util.Date dateShipped)
void | setDescription(java.lang.String description)
void | setDiscount(java.math.BigDecimal discount)
void | setDue(java.math.BigDecimal due)
void | setItemGrandTotal(java.math.BigDecimal itemGrandTotal)
void | setListPrice(java.math.BigDecimal listPrice)
void | setLocate(java.lang.String locate)
void | setLocations(java.util.Map locations)
void | setMfg(java.lang.String mfg)
void | setMoldNumber(java.lang.String moldNumber)
void | setMpn(java.lang.String mpn)
void | setNotes(java.lang.String notes)
void | setPaid(java.math.BigDecimal paid)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(RtvShipperItemPK pk)
void | setQty(java.math.BigDecimal qty)
void | setQtyShip(java.math.BigDecimal qtyShip)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setRefDocOnes(java.util.Set refDocOnes)
void | setRefDocTwoes(java.util.Set refDocTwoes)
void | setRevision(java.lang.String revision)
void | setRtvNumber(java.lang.String rtvNumber)
void | setSerial(java.lang.String serial)
void | setShipto(java.lang.String shipto)
void | setShipvia(java.lang.String shipvia)
void | setStatus(java.lang.String status)
void | setStdCost(java.math.BigDecimal stdCost)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setTrackings(java.util.Map trackings)
void | setUnit(java.lang.String unit)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

RtvShipperItemVO

public RtvShipperItemVO()
default constructor

Method Detail

getLocations

public java.util.Map getLocations()

setLocations

public void setLocations(java.util.Map locations)

getTrackings

public java.util.Map getTrackings()

setTrackings

public void setTrackings(java.util.Map trackings)

getPk

public RtvShipperItemPK getPk()

setPk

public void setPk(RtvShipperItemPK pk)

getRtvNumber

public java.lang.String getRtvNumber()

setRtvNumber

public void setRtvNumber(java.lang.String rtvNumber)

getApSub

public java.math.BigDecimal getApSub()

setApSub

public void setApSub(java.math.BigDecimal apSub)

getApShip

public java.math.BigDecimal getApShip()

setApShip

public void setApShip(java.math.BigDecimal apShip)

getApOpen

public java.math.BigDecimal getApOpen()

setApOpen

public void setApOpen(java.math.BigDecimal apOpen)

getApDisc

public java.math.BigDecimal getApDisc()

setApDisc

public void setApDisc(java.math.BigDecimal apDisc)

getApNet

public java.math.BigDecimal getApNet()

setApNet

public void setApNet(java.math.BigDecimal apNet)

getApTax

public java.math.BigDecimal getApTax()

setApTax

public void setApTax(java.math.BigDecimal apTax)

getApTotal

public java.math.BigDecimal getApTotal()

setApTotal

public void setApTotal(java.math.BigDecimal apTotal)

getDue

public java.math.BigDecimal getDue()

setDue

public void setDue(java.math.BigDecimal due)

getPaid

public java.math.BigDecimal getPaid()

setPaid

public void setPaid(java.math.BigDecimal paid)

getDatePaid

public java.util.Date getDatePaid()

setDatePaid

public void setDatePaid(java.util.Date datePaid)

getCheckNo

public java.lang.String getCheckNo()

setCheckNo

public void setCheckNo(java.lang.String checkNo)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getDateShipped

public java.util.Date getDateShipped()

setDateShipped

public void setDateShipped(java.util.Date dateShipped)

getDateInvoiced

public java.util.Date getDateInvoiced()

setDateInvoiced

public void setDateInvoiced(java.util.Date dateInvoiced)

getShipvia

public java.lang.String getShipvia()

setShipvia

public void setShipvia(java.lang.String shipvia)

getShipto

public java.lang.String getShipto()

setShipto

public void setShipto(java.lang.String shipto)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getMoldNumber

public java.lang.String getMoldNumber()

setMoldNumber

public void setMoldNumber(java.lang.String moldNumber)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

getQtyShip

public java.math.BigDecimal getQtyShip()

setQtyShip

public void setQtyShip(java.math.BigDecimal qtyShip)

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

getAvgCost

public java.math.BigDecimal getAvgCost()

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getSerial

public java.lang.String getSerial()

setSerial

public void setSerial(java.lang.String serial)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getNotes

public java.lang.String getNotes()

setNotes

public void setNotes(java.lang.String notes)

getItemGrandTotal

public java.math.BigDecimal getItemGrandTotal()

setItemGrandTotal

public void setItemGrandTotal(java.math.BigDecimal itemGrandTotal)

getRefDocTwoes

public java.util.Set getRefDocTwoes()

setRefDocTwoes

public void setRefDocTwoes(java.util.Set refDocTwoes)

getRefDocOnes

public java.util.Set getRefDocOnes()

setRefDocOnes

public void setRefDocOnes(java.util.Set refDocOnes)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RtvShipperListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RtvShipperListResult

java.lang.Object
    extended by  bb.common.RtvShipperListResult
All Implemented Interfaces:
java.io.Serializable
public class RtvShipperListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_APNUMBER
static java.lang.String | ORDER_BY_DATESHIPPED
static java.lang.String | ORDER_BY_PONUMBER
static java.lang.String | ORDER_BY_RTVNUMBER
static java.lang.String | ORDER_BY_RTVSHIPPERNUMBER
static java.lang.String | ORDER_BY_SHIPPEDBY
static java.lang.String | ORDER_BY_SHIPPEDDATE
static java.lang.String | ORDER_BY_SHIPTOID
static java.lang.String | ORDER_BY_SHIPVIA
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_VENDORID
Constructor Summary
RtvShipperListResult()
Method Summary
java.lang.String | getApNumber()
java.lang.String | getComments()
java.util.Date | getDateShipped()
java.lang.String | getNotes()
java.lang.String | getPoNumber()
java.lang.String | getRtvNumber()
java.lang.String | getRtvShipperNumber()
java.lang.String | getShippedBy()
java.util.Date | getShippedDate()
java.lang.String | getShipToId()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.lang.String | getVendorId()
void | setApNumber(java.lang.String apNumber)
void | setComments(java.lang.String comments)
void | setDateShipped(java.util.Date dateShipped)
void | setNotes(java.lang.String notes)
void | setPoNumber(java.lang.String poNumber)
void | setRtvNumber(java.lang.String rtvNumber)
void | setRtvShipperNumber(java.lang.String rtvShipperNumber)
void | setShippedBy(java.lang.String shippedBy)
void | setShippedDate(java.util.Date shippedDate)
void | setShipToId(java.lang.String shipToId)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setVendorId(java.lang.String vendorId)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_RTVSHIPPERNUMBER

public static final java.lang.String ORDER_BY_RTVSHIPPERNUMBER
See Also:
Constant Field Values

ORDER_BY_RTVNUMBER

public static final java.lang.String ORDER_BY_RTVNUMBER
See Also:
Constant Field Values

ORDER_BY_APNUMBER

public static final java.lang.String ORDER_BY_APNUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_PONUMBER

public static final java.lang.String ORDER_BY_PONUMBER
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_SHIPPEDBY

public static final java.lang.String ORDER_BY_SHIPPEDBY
See Also:
Constant Field Values

ORDER_BY_SHIPPEDDATE

public static final java.lang.String ORDER_BY_SHIPPEDDATE
See Also:
Constant Field Values

ORDER_BY_DATESHIPPED

public static final java.lang.String ORDER_BY_DATESHIPPED
See Also:
Constant Field Values

ORDER_BY_SHIPTOID

public static final java.lang.String ORDER_BY_SHIPTOID
See Also:
Constant Field Values

ORDER_BY_SHIPVIA

public static final java.lang.String ORDER_BY_SHIPVIA
See Also:
Constant Field Values
Constructor Detail

RtvShipperListResult

public RtvShipperListResult()
Method Detail

getApNumber

public java.lang.String getApNumber()

setApNumber

public void setApNumber(java.lang.String apNumber)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getDateShipped

public java.util.Date getDateShipped()

setDateShipped

public void setDateShipped(java.util.Date dateShipped)

getNotes

public java.lang.String getNotes()

setNotes

public void setNotes(java.lang.String notes)

getPoNumber

public java.lang.String getPoNumber()

setPoNumber

public void setPoNumber(java.lang.String poNumber)

getRtvNumber

public java.lang.String getRtvNumber()

setRtvNumber

public void setRtvNumber(java.lang.String rtvNumber)

getRtvShipperNumber

public java.lang.String getRtvShipperNumber()

setRtvShipperNumber

public void setRtvShipperNumber(java.lang.String rtvShipperNumber)

getShippedBy

public java.lang.String getShippedBy()

setShippedBy

public void setShippedBy(java.lang.String shippedBy)

getShippedDate

public java.util.Date getShippedDate()

setShippedDate

public void setShippedDate(java.util.Date shippedDate)

getShipToId

public java.lang.String getShipToId()

setShipToId

public void setShipToId(java.lang.String shipToId)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RtvShipperVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RtvShipperVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.RtvShipperVO
All Implemented Interfaces:
java.io.Serializable
public class RtvShipperVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
RtvShipperVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.math.BigDecimal | getApDiscount()
java.math.BigDecimal | getApFreight()
java.math.BigDecimal | getApGl1Recorded()
java.math.BigDecimal | getApGl2Paid()
java.math.BigDecimal | getApNet()
java.lang.String | getApNetSet()
java.lang.String | getApNumber()
java.math.BigDecimal | getApOpen()
java.math.BigDecimal | getApPaidGl()
java.math.BigDecimal | getApPaidInv()
java.math.BigDecimal | getApShip()
java.math.BigDecimal | getApSub()
java.math.BigDecimal | getApTax()
java.lang.String | getApTaxSet()
java.math.BigDecimal | getApTotal()
java.lang.String | getBatch()
CustomerVendorAddressInfoVO | getBillToAddressInfo()
java.lang.String | getBilltoId()
java.lang.String | getBp()
java.lang.String | getCarrier()
java.lang.String | getCarrierAccount()
java.lang.String | getChangeOrder()
java.lang.String | getCheckNumber()
java.lang.String | getCoComments()
java.lang.String | getComments()
java.lang.String | getCompanyUnitId()
java.lang.String | getCurrency()
java.util.Date | getDateInvoiced()
java.util.Date | getDatePaid()
java.util.Date | getDateShipped()
java.lang.String | getDebitAccount()
java.math.BigDecimal | getDue()
java.lang.String | getFreightBill()
java.lang.String | getFreightRateCode()
java.lang.String | getGrossWeight()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getInvoicedBy()
java.util.Date | getInvoicedDate()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getNotes()
java.lang.String | getOrigin()
java.lang.String | getOtran()
java.math.BigDecimal | getPaid()
java.util.Date | getPaydate()
java.lang.String | getPoNumber()
java.lang.String | getReldoc()
java.lang.String | getRemitId()
java.lang.String | getRtran()
java.lang.String | getRtvNumber()
java.util.Set | getRtvShipperItems()
java.lang.String | getRtvShipperNumber()
java.lang.String | getSalesman()
java.lang.String | getShBplate()
java.lang.String | getShippedBy()
java.util.Date | getShippedDate()
CustomerVendorAddressInfoVO | getShipToAddressInfo()
java.lang.String | getShipToId()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.lang.String | getTerms()
java.lang.String | getTracking()
CustomerVendorAddressInfoVO | getVendorAddressInfo()
java.lang.String | getVendorId()
int | getVersion()
int | hashCode()
boolean | isVendorPicked()
void | setAdate(java.util.Date adate)
void | setApDiscount(java.math.BigDecimal apDiscount)
void | setApFreight(java.math.BigDecimal apFreight)
void | setApGl1Recorded(java.math.BigDecimal apGl1Recorded)
void | setApGl2Paid(java.math.BigDecimal apGl2Paid)
void | setApNet(java.math.BigDecimal apNet)
void | setApNetSet(java.lang.String apNetSet)
void | setApNumber(java.lang.String apNumber)
void | setApOpen(java.math.BigDecimal apOpen)
void | setApPaidGl(java.math.BigDecimal apPaidGl)
void | setApPaidInv(java.math.BigDecimal apPaidInv)
void | setApShip(java.math.BigDecimal apShip)
void | setApSub(java.math.BigDecimal apSub)
void | setApTax(java.math.BigDecimal apTax)
void | setApTaxSet(java.lang.String apTaxSet)
void | setApTotal(java.math.BigDecimal apTotal)
void | setBatch(java.lang.String batch)
void | setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | setBilltoId(java.lang.String billtoId)
void | setBp(java.lang.String bp)
void | setCarrier(java.lang.String carrier)
void | setCarrierAccount(java.lang.String carrierAccount)
void | setChangeOrder(java.lang.String changeOrder)
void | setCheckNumber(java.lang.String checkNumber)
void | setCoComments(java.lang.String coComments)
void | setComments(java.lang.String comments)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCurrency(java.lang.String currency)
void | setDateInvoiced(java.util.Date dateInvoiced)
void | setDatePaid(java.util.Date datePaid)
void | setDateShipped(java.util.Date dateShipped)
void | setDebitAccount(java.lang.String debitAccount)
void | setDue(java.math.BigDecimal due)
void | setFreightBill(java.lang.String freightBill)
void | setFreightRateCode(java.lang.String freightRateCode)
void | setGrossWeight(java.lang.String grossWeight)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setInvoicedBy(java.lang.String invoicedBy)
void | setInvoicedDate(java.util.Date invoicedDate)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setNotes(java.lang.String notes)
void | setOrigin(java.lang.String origin)
void | setOtran(java.lang.String otran)
void | setPaid(java.math.BigDecimal paid)
void | setPaydate(java.util.Date paydate)
void | setPoNumber(java.lang.String poNumber)
void | setReldoc(java.lang.String reldoc)
void | setRemitId(java.lang.String remitId)
void | setRtran(java.lang.String rtran)
void | setRtvNumber(java.lang.String rtvNumber)
void | setRtvShipperItems(java.util.Set rtvShipperItems)
void | setRtvShipperNumber(java.lang.String rtvShipperNumber)
void | setSalesman(java.lang.String salesman)
void | setShBplate(java.lang.String shBplate)
void | setShippedBy(java.lang.String shippedBy)
void | setShippedDate(java.util.Date shippedDate)
void | setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | setShipToId(java.lang.String shipToId)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setTerms(java.lang.String terms)
void | setTracking(java.lang.String tracking)
void | setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)
void | setVendorId(java.lang.String vendorId)
void | setVendorPicked(boolean vendorPicked)
void | setVersion(int version)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

RtvShipperVO

public RtvShipperVO()
Method Detail

getRtvShipperNumber

public java.lang.String getRtvShipperNumber()

setRtvShipperNumber

public void setRtvShipperNumber(java.lang.String rtvShipperNumber)

getRtvNumber

public java.lang.String getRtvNumber()

setRtvNumber

public void setRtvNumber(java.lang.String rtvNumber)

getApNumber

public java.lang.String getApNumber()

setApNumber

public void setApNumber(java.lang.String apNumber)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getBatch

public java.lang.String getBatch()

setBatch

public void setBatch(java.lang.String batch)

getBilltoId

public java.lang.String getBilltoId()

setBilltoId

public void setBilltoId(java.lang.String billtoId)

getPoNumber

public java.lang.String getPoNumber()

setPoNumber

public void setPoNumber(java.lang.String poNumber)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getApNetSet

public java.lang.String getApNetSet()

setApNetSet

public void setApNetSet(java.lang.String apNetSet)

getApTaxSet

public java.lang.String getApTaxSet()

setApTaxSet

public void setApTaxSet(java.lang.String apTaxSet)

getApSub

public java.math.BigDecimal getApSub()

setApSub

public void setApSub(java.math.BigDecimal apSub)

getApShip

public java.math.BigDecimal getApShip()

setApShip

public void setApShip(java.math.BigDecimal apShip)

getApOpen

public java.math.BigDecimal getApOpen()

setApOpen

public void setApOpen(java.math.BigDecimal apOpen)

getApDiscount

public java.math.BigDecimal getApDiscount()

setApDiscount

public void setApDiscount(java.math.BigDecimal apDiscount)

getApNet

public java.math.BigDecimal getApNet()

setApNet

public void setApNet(java.math.BigDecimal apNet)

getApTax

public java.math.BigDecimal getApTax()

setApTax

public void setApTax(java.math.BigDecimal apTax)

getApFreight

public java.math.BigDecimal getApFreight()

setApFreight

public void setApFreight(java.math.BigDecimal apFreight)

getApTotal

public java.math.BigDecimal getApTotal()

setApTotal

public void setApTotal(java.math.BigDecimal apTotal)

getApPaidInv

public java.math.BigDecimal getApPaidInv()

setApPaidInv

public void setApPaidInv(java.math.BigDecimal apPaidInv)

getApPaidGl

public java.math.BigDecimal getApPaidGl()

setApPaidGl

public void setApPaidGl(java.math.BigDecimal apPaidGl)

getApGl1Recorded

public java.math.BigDecimal getApGl1Recorded()

setApGl1Recorded

public void setApGl1Recorded(java.math.BigDecimal apGl1Recorded)

getApGl2Paid

public java.math.BigDecimal getApGl2Paid()

setApGl2Paid

public void setApGl2Paid(java.math.BigDecimal apGl2Paid)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getCoComments

public java.lang.String getCoComments()

setCoComments

public void setCoComments(java.lang.String coComments)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getSalesman

public java.lang.String getSalesman()

setSalesman

public void setSalesman(java.lang.String salesman)

getShippedDate

public java.util.Date getShippedDate()

setShippedDate

public void setShippedDate(java.util.Date shippedDate)

getShippedBy

public java.lang.String getShippedBy()

setShippedBy

public void setShippedBy(java.lang.String shippedBy)

getInvoicedDate

public java.util.Date getInvoicedDate()

setInvoicedDate

public void setInvoicedDate(java.util.Date invoicedDate)

getInvoicedBy

public java.lang.String getInvoicedBy()

setInvoicedBy

public void setInvoicedBy(java.lang.String invoicedBy)

getShipToId

public java.lang.String getShipToId()

setShipToId

public void setShipToId(java.lang.String shipToId)

getRemitId

public java.lang.String getRemitId()

setRemitId

public void setRemitId(java.lang.String remitId)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAccount

public java.lang.String getCarrierAccount()

setCarrierAccount

public void setCarrierAccount(java.lang.String carrierAccount)

getFreightRateCode

public java.lang.String getFreightRateCode()

setFreightRateCode

public void setFreightRateCode(java.lang.String freightRateCode)

getGrossWeight

public java.lang.String getGrossWeight()

setGrossWeight

public void setGrossWeight(java.lang.String grossWeight)

getTracking

public java.lang.String getTracking()

setTracking

public void setTracking(java.lang.String tracking)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getDateShipped

public java.util.Date getDateShipped()

setDateShipped

public void setDateShipped(java.util.Date dateShipped)

getDateInvoiced

public java.util.Date getDateInvoiced()

setDateInvoiced

public void setDateInvoiced(java.util.Date dateInvoiced)

getFreightBill

public java.lang.String getFreightBill()

setFreightBill

public void setFreightBill(java.lang.String freightBill)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getReldoc

public java.lang.String getReldoc()

setReldoc

public void setReldoc(java.lang.String reldoc)

getDebitAccount

public java.lang.String getDebitAccount()

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

getBp

public java.lang.String getBp()

setBp

public void setBp(java.lang.String bp)

getShBplate

public java.lang.String getShBplate()

setShBplate

public void setShBplate(java.lang.String shBplate)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getNotes

public java.lang.String getNotes()

setNotes

public void setNotes(java.lang.String notes)

getDue

public java.math.BigDecimal getDue()

setDue

public void setDue(java.math.BigDecimal due)

getPaydate

public java.util.Date getPaydate()

setPaydate

public void setPaydate(java.util.Date paydate)

getDatePaid

public java.util.Date getDatePaid()

setDatePaid

public void setDatePaid(java.util.Date datePaid)

getCheckNumber

public java.lang.String getCheckNumber()

setCheckNumber

public void setCheckNumber(java.lang.String checkNumber)

getPaid

public java.math.BigDecimal getPaid()

setPaid

public void setPaid(java.math.BigDecimal paid)

getOtran

public java.lang.String getOtran()

setOtran

public void setOtran(java.lang.String otran)

getRtran

public java.lang.String getRtran()

setRtran

public void setRtran(java.lang.String rtran)

getVersion

public int getVersion()

setVersion

public void setVersion(int version)

getVendorAddressInfo

public CustomerVendorAddressInfoVO getVendorAddressInfo()

setVendorAddressInfo

public void setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)

getShipToAddressInfo

public CustomerVendorAddressInfoVO getShipToAddressInfo()

setShipToAddressInfo

public void setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)

getBillToAddressInfo

public CustomerVendorAddressInfoVO getBillToAddressInfo()

setBillToAddressInfo

public void setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)

getRtvShipperItems

public java.util.Set getRtvShipperItems()

setRtvShipperItems

public void setRtvShipperItems(java.util.Set rtvShipperItems)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

isVendorPicked

public boolean isVendorPicked()

setVendorPicked

public void setVendorPicked(boolean vendorPicked)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RunningAccountOrderItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RunningAccountOrderItemPK

java.lang.Object
    extended by  bb.common.RunningAccountOrderItemPK
All Implemented Interfaces:
java.io.Serializable
public class RunningAccountOrderItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
RunningAccountOrderItemPK()
RunningAccountOrderItemPK(java.lang.String runningAccountOrderNumber, java.lang.String runningAccountOrderItemNumber)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getRunningAccountOrderItemNumber()
java.lang.String | getRunningAccountOrderNumber()
int | hashCode()
void | setRunningAccountOrderItemNumber(java.lang.String runningAccountOrderItemNumber)
void | setRunningAccountOrderNumber(java.lang.String runningAccountOrderNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

RunningAccountOrderItemPK

public RunningAccountOrderItemPK()

RunningAccountOrderItemPK

public RunningAccountOrderItemPK(java.lang.String runningAccountOrderNumber,
                                 java.lang.String runningAccountOrderItemNumber)
Method Detail

getRunningAccountOrderNumber

public java.lang.String getRunningAccountOrderNumber()

setRunningAccountOrderNumber

public void setRunningAccountOrderNumber(java.lang.String runningAccountOrderNumber)

getRunningAccountOrderItemNumber

public java.lang.String getRunningAccountOrderItemNumber()

setRunningAccountOrderItemNumber

public void setRunningAccountOrderItemNumber(java.lang.String runningAccountOrderItemNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RunningAccountOrderItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RunningAccountOrderItemResult

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.RunningAccountOrderItemVO
            extended by  bb.common.RunningAccountOrderItemResult
All Implemented Interfaces:
java.io.Serializable
public class RunningAccountOrderItemResult
extends RunningAccountOrderItemVO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
RunningAccountOrderItemResult()
Method Summary
java.lang.String | getBillTo()
java.lang.String | getCheckNumber()
java.lang.String | getComments()
java.lang.String | getContact()
java.lang.String | getCustomerId()
java.math.BigDecimal | getFreight()
java.lang.String | getNotes()
java.lang.String | getPayableMethod()
java.lang.String | getPoNumber()
java.lang.String | getRaoiNumber()
java.lang.String | getRaoNumber()
java.util.Date | getSalesDate()
java.lang.String | getSalesman()
java.lang.String | getSalesOrder()
java.lang.String | getShipTo()
java.math.BigDecimal | getTaxRate()
boolean | isCheckReturn()
void | setBillTo(java.lang.String billTo)
void | setCheckNumber(java.lang.String checkNumber)
void | setCheckReturn(boolean checkReturn)
void | setComments(java.lang.String comments)
void | setContact(java.lang.String contact)
void | setCustomerId(java.lang.String customerId)
void | setFreight(java.math.BigDecimal freight)
void | setNotes(java.lang.String notes)
void | setPayableMethod(java.lang.String payableMethod)
void | setPoNumber(java.lang.String poNumber)
void | setRaoiNumber(java.lang.String raoiNumber)
void | setRaoNumber(java.lang.String raoNumber)
void | setSalesDate(java.util.Date salesDate)
void | setSalesman(java.lang.String salesman)
void | setSalesOrder(java.lang.String salesOrder)
void | setShipTo(java.lang.String shipTo)
void | setTaxRate(java.math.BigDecimal taxRate)
Methods inherited from class bb.common.RunningAccountOrderItemVO
equals, getAvgCost, getBoughtQty, getCommodityCode, getDesc, getDiscount, getLastSOPrice, getMfgPartNumber, getModelNumber, getNetTotal, getPartNumber, getPartOnhand, getPartType, getPk, getPoPrice, getPoPriceProfit, getPoPriceProfitPercent, getPrice, getProductCode, getProfit, getProfitByStdCost, getProfitPercent, getProfitPercentByStdCost, getQuantity, getRealTimeOnhand, getRefDoc, getSalesPrice, getStdCost, getSubTotal, getTax, getTaxTotal, getTempOnhand, getUnit, getUnitPrice, getUnitQty, getUnits, hashCode, isDiscountable, isDutyFree, isPartTaxExempt, setAvgCost, setBoughtQty, setCommodityCode, setDesc, setDiscount, setDiscountable, setDutyFree, setLastSOPrice, setMfgPartNumber, setModelNumber, setNetTotal, setPartNumber, setPartOnhand, setPartTaxExempt, setPartType, setPk, setPoPrice, setPoPriceProfit, setPoPriceProfitPercent, setPrice, setProductCode, setProfit, setProfitByStdCost, setProfitPercent, setProfitPercentByStdCost, setQuantity, setRealTimeOnhand, setRefDoc, setSalesPrice, setStdCost, setSubTotal, setTax, setTaxTotal, setTempOnhand, setUnit, setUnitPrice, setUnitQty, setUnits, toString
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

RunningAccountOrderItemResult

public RunningAccountOrderItemResult()
Method Detail

getRaoNumber

public java.lang.String getRaoNumber()

setRaoNumber

public void setRaoNumber(java.lang.String raoNumber)

getRaoiNumber

public java.lang.String getRaoiNumber()

setRaoiNumber

public void setRaoiNumber(java.lang.String raoiNumber)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getPayableMethod

public java.lang.String getPayableMethod()

setPayableMethod

public void setPayableMethod(java.lang.String payableMethod)

getSalesDate

public java.util.Date getSalesDate()

setSalesDate

public void setSalesDate(java.util.Date salesDate)

getSalesman

public java.lang.String getSalesman()

setSalesman

public void setSalesman(java.lang.String salesman)

isCheckReturn

public boolean isCheckReturn()

setCheckReturn

public void setCheckReturn(boolean checkReturn)

getSalesOrder

public java.lang.String getSalesOrder()

setSalesOrder

public void setSalesOrder(java.lang.String salesOrder)

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getFreight

public java.math.BigDecimal getFreight()
Overrides:
getFreight in class RunningAccountOrderItemVO

setFreight

public void setFreight(java.math.BigDecimal freight)
Overrides:
setFreight in class RunningAccountOrderItemVO

getShipTo

public java.lang.String getShipTo()

setShipTo

public void setShipTo(java.lang.String shipTo)

getBillTo

public java.lang.String getBillTo()

setBillTo

public void setBillTo(java.lang.String billTo)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getNotes

public java.lang.String getNotes()

setNotes

public void setNotes(java.lang.String notes)

getPoNumber

public java.lang.String getPoNumber()

setPoNumber

public void setPoNumber(java.lang.String poNumber)

getCheckNumber

public java.lang.String getCheckNumber()

setCheckNumber

public void setCheckNumber(java.lang.String checkNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RunningAccountOrderItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RunningAccountOrderItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.RunningAccountOrderItemVO
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
RunningAccountOrderItemResult
public class RunningAccountOrderItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
RunningAccountOrderItemVO()
Method Summary
boolean | equals(java.lang.Object obj)
java.math.BigDecimal | getAvgCost()
java.math.BigDecimal | getBoughtQty()
java.lang.String | getCommodityCode()
java.lang.String | getDesc()
java.math.BigDecimal | getDiscount()
java.math.BigDecimal | getFreight()
java.lang.String | getLastSOPrice()
java.lang.String | getMfgPartNumber()
java.lang.String | getModelNumber()
java.math.BigDecimal | getNetTotal()
java.lang.String | getPartNumber()
java.math.BigDecimal | getPartOnhand()
java.lang.String | getPartType()
RunningAccountOrderItemPK | getPk()
java.math.BigDecimal | getPoPrice()
java.math.BigDecimal | getPoPriceProfit()
java.math.BigDecimal | getPoPriceProfitPercent()
java.math.BigDecimal | getPrice()
java.lang.String | getProductCode()
java.math.BigDecimal | getProfit()
java.math.BigDecimal | getProfitByStdCost()
java.math.BigDecimal | getProfitPercent()
java.math.BigDecimal | getProfitPercentByStdCost()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getRealTimeOnhand()
java.util.Set | getRefDoc()
java.math.BigDecimal | getSalesPrice()
java.math.BigDecimal | getStdCost()
java.math.BigDecimal | getSubTotal()
java.math.BigDecimal | getTax()
java.math.BigDecimal | getTaxTotal()
java.math.BigDecimal | getTempOnhand()
java.lang.String | getUnit()
java.math.BigDecimal | getUnitPrice()
java.math.BigDecimal | getUnitQty()
java.util.Set<PartUnitVO> | getUnits()
int | hashCode()
boolean | isDiscountable()
boolean | isDutyFree()
boolean | isPartTaxExempt()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setBoughtQty(java.math.BigDecimal boughtQty)
void | setCommodityCode(java.lang.String commodityCode)
void | setDesc(java.lang.String desc)
void | setDiscount(java.math.BigDecimal discount)
void | setDiscountable(boolean discountable)
void | setDutyFree(boolean dutyFree)
void | setFreight(java.math.BigDecimal freight)
void | setLastSOPrice(java.lang.String lastSOPrice)
void | setMfgPartNumber(java.lang.String mfgPartNumber)
void | setModelNumber(java.lang.String modelNumber)
void | setNetTotal(java.math.BigDecimal netTotal)
void | setPartNumber(java.lang.String partNumber)
void | setPartOnhand(java.math.BigDecimal partOnhand)
void | setPartTaxExempt(boolean partTaxExempt)
void | setPartType(java.lang.String partType)
void | setPk(RunningAccountOrderItemPK pk)
void | setPoPrice(java.math.BigDecimal poPrice)
void | setPoPriceProfit(java.math.BigDecimal poPriceProfit)
void | setPoPriceProfitPercent(java.math.BigDecimal poPriceProfitPercent)
void | setPrice(java.math.BigDecimal price)
void | setProductCode(java.lang.String productCode)
void | setProfit(java.math.BigDecimal profit)
void | setProfitByStdCost(java.math.BigDecimal profitByStdCost)
void | setProfitPercent(java.math.BigDecimal profitPercent)
void | setProfitPercentByStdCost(java.math.BigDecimal profitPercentByStdCost)
void | setQuantity(java.math.BigDecimal quantity)
void | setRealTimeOnhand(java.math.BigDecimal realTimeOnhand)
void | setRefDoc(java.util.Set refDoc)
void | setSalesPrice(java.math.BigDecimal salesPrice)
void | setStdCost(java.math.BigDecimal stdCost)
void | setSubTotal(java.math.BigDecimal subTotal)
void | setTax(java.math.BigDecimal tax)
void | setTaxTotal(java.math.BigDecimal taxTotal)
void | setTempOnhand(java.math.BigDecimal tempOnhand)
void | setUnit(java.lang.String unit)
void | setUnitPrice(java.math.BigDecimal unitPrice)
void | setUnitQty(java.math.BigDecimal unitQty)
void | setUnits(java.util.Set<PartUnitVO> units)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

RunningAccountOrderItemVO

public RunningAccountOrderItemVO()
Method Detail

getPk

public RunningAccountOrderItemPK getPk()

setPk

public void setPk(RunningAccountOrderItemPK pk)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getDesc

public java.lang.String getDesc()

setDesc

public void setDesc(java.lang.String desc)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getPrice

public java.math.BigDecimal getPrice()

setPrice

public void setPrice(java.math.BigDecimal price)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getRealTimeOnhand

public java.math.BigDecimal getRealTimeOnhand()

setRealTimeOnhand

public void setRealTimeOnhand(java.math.BigDecimal realTimeOnhand)

getSubTotal

public java.math.BigDecimal getSubTotal()

setSubTotal

public void setSubTotal(java.math.BigDecimal subTotal)

getNetTotal

public java.math.BigDecimal getNetTotal()

setNetTotal

public void setNetTotal(java.math.BigDecimal netTotal)

getTaxTotal

public java.math.BigDecimal getTaxTotal()

setTaxTotal

public void setTaxTotal(java.math.BigDecimal taxTotal)

getAvgCost

public java.math.BigDecimal getAvgCost()

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

getProfit

public java.math.BigDecimal getProfit()

setProfit

public void setProfit(java.math.BigDecimal profit)

getProfitPercent

public java.math.BigDecimal getProfitPercent()

setProfitPercent

public void setProfitPercent(java.math.BigDecimal profitPercent)

isDutyFree

public boolean isDutyFree()

setDutyFree

public void setDutyFree(boolean dutyFree)

getProfitByStdCost

public java.math.BigDecimal getProfitByStdCost()

setProfitByStdCost

public void setProfitByStdCost(java.math.BigDecimal profitByStdCost)

getProfitPercentByStdCost

public java.math.BigDecimal getProfitPercentByStdCost()

setProfitPercentByStdCost

public void setProfitPercentByStdCost(java.math.BigDecimal profitPercentByStdCost)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getTempOnhand

public java.math.BigDecimal getTempOnhand()

setTempOnhand

public void setTempOnhand(java.math.BigDecimal tempOnhand)

getRefDoc

public java.util.Set getRefDoc()

setRefDoc

public void setRefDoc(java.util.Set refDoc)

getFreight

public java.math.BigDecimal getFreight()

setFreight

public void setFreight(java.math.BigDecimal freight)

getMfgPartNumber

public java.lang.String getMfgPartNumber()

setMfgPartNumber

public void setMfgPartNumber(java.lang.String mfgPartNumber)

getBoughtQty

public java.math.BigDecimal getBoughtQty()

setBoughtQty

public void setBoughtQty(java.math.BigDecimal boughtQty)

getPartOnhand

public java.math.BigDecimal getPartOnhand()

setPartOnhand

public void setPartOnhand(java.math.BigDecimal partOnhand)

getPoPrice

public java.math.BigDecimal getPoPrice()

setPoPrice

public void setPoPrice(java.math.BigDecimal poPrice)

getPoPriceProfit

public java.math.BigDecimal getPoPriceProfit()

setPoPriceProfit

public void setPoPriceProfit(java.math.BigDecimal poPriceProfit)

getPoPriceProfitPercent

public java.math.BigDecimal getPoPriceProfitPercent()

setPoPriceProfitPercent

public void setPoPriceProfitPercent(java.math.BigDecimal poPriceProfitPercent)

getSalesPrice

public java.math.BigDecimal getSalesPrice()

setSalesPrice

public void setSalesPrice(java.math.BigDecimal salesPrice)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getUnits

public java.util.Set<PartUnitVO> getUnits()

setUnits

public void setUnits(java.util.Set<PartUnitVO> units)

getUnitQty

public java.math.BigDecimal getUnitQty()

setUnitQty

public void setUnitQty(java.math.BigDecimal unitQty)

getUnitPrice

public java.math.BigDecimal getUnitPrice()

setUnitPrice

public void setUnitPrice(java.math.BigDecimal unitPrice)

getTax

public java.math.BigDecimal getTax()

setTax

public void setTax(java.math.BigDecimal tax)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getCommodityCode

public java.lang.String getCommodityCode()

setCommodityCode

public void setCommodityCode(java.lang.String commodityCode)

getProductCode

public java.lang.String getProductCode()

setProductCode

public void setProductCode(java.lang.String productCode)

isDiscountable

public boolean isDiscountable()

setDiscountable

public void setDiscountable(boolean discountable)

getLastSOPrice

public java.lang.String getLastSOPrice()

setLastSOPrice

public void setLastSOPrice(java.lang.String lastSOPrice)

isPartTaxExempt

public boolean isPartTaxExempt()

setPartTaxExempt

public void setPartTaxExempt(boolean partTaxExempt)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RunningAccountOrderVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RunningAccountOrderVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.RunningAccountOrderVO
All Implemented Interfaces:
java.io.Serializable
public class RunningAccountOrderVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
RunningAccountOrderVO()
Method Summary
boolean | equals(java.lang.Object obj)
java.math.BigDecimal | getAccountsReceivable()
java.math.BigDecimal | getAvgCostTotal()
java.lang.String | getBillTo()
java.math.BigDecimal | getChangeNote()
java.lang.String | getCheckNumber()
java.lang.String | getComments()
java.lang.String | getComputerId()
java.lang.String | getContact()
java.lang.String | getCreditCardNumber()
java.lang.String | getCurrency()
CustomerVendorAddressInfoVO | getCustomerAddressInfo()
java.lang.String | getCustomerId()
java.math.BigDecimal | getDiscTotal()
java.lang.String | getDutyFreeNumber()
byte[] | getElecSignature()
java.math.BigDecimal | getExchange()
java.math.BigDecimal | getFreight()
java.lang.String | getInvoiceNumber()
java.lang.String | getIpAddr()
java.math.BigDecimal | getNetTotal()
java.lang.String | getNotes()
java.lang.String | getOriginalNumber()
java.lang.String | getPayableMethod()
java.lang.String | getPoNumber()
java.lang.String | getPrintReturnNumber()
java.math.BigDecimal | getProfitPercentTotal()
java.math.BigDecimal | getProfitPercentTotalByStdCost()
java.math.BigDecimal | getProfitTotal()
java.math.BigDecimal | getProfitTotalByStdCost()
java.math.BigDecimal | getRealReceivable()
java.util.Set | getRunningAccountOrderItems()
java.lang.String | getRunningAccountOrderNumber()
java.util.Date | getSalesDate()
java.lang.String | getSalesman()
java.lang.String | getSalesOrder()
java.lang.String | getShipTo()
java.math.BigDecimal | getSubTotal()
java.math.BigDecimal | getTax()
java.math.BigDecimal | getTaxRate()
java.math.BigDecimal | getTaxTotal()
java.lang.String | getTaxType()
java.util.Date | getValidDate()
int | hashCode()
boolean | isCheckReturn()
void | setAccountsReceivable(java.math.BigDecimal accountsReceivable)
void | setAvgCostTotal(java.math.BigDecimal avgCostTotal)
void | setBillTo(java.lang.String billTo)
void | setChangeNote(java.math.BigDecimal changeNote)
void | setCheckNumber(java.lang.String checkNumber)
void | setCheckReturn(boolean checkReturn)
void | setComments(java.lang.String comments)
void | setComputerId(java.lang.String computerId)
void | setContact(java.lang.String contact)
void | setCreditCardNumber(java.lang.String creditCardNumber)
void | setCurrency(java.lang.String currency)
void | setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | setCustomerId(java.lang.String customerId)
void | setDiscTotal(java.math.BigDecimal discTotal)
void | setDutyFreeNumber(java.lang.String dutyFreeNumber)
void | setElecSignature(byte[] elecSignature)
void | setExchange(java.math.BigDecimal exchange)
void | setFreight(java.math.BigDecimal freight)
void | setInvoiceNumber(java.lang.String invoiceNumber)
void | setIpAddr(java.lang.String ipAddr)
void | setNetTotal(java.math.BigDecimal netTotal)
void | setNotes(java.lang.String notes)
void | setOriginalNumber(java.lang.String originalNumber)
void | setPayableMethod(java.lang.String payableMethod)
void | setPoNumber(java.lang.String poNumber)
void | setPrintReturnNumber(java.lang.String printReturnNumber)
void | setProfitPercentTotal(java.math.BigDecimal profitPercentTotal)
void | setProfitPercentTotalByStdCost(java.math.BigDecimal profitPercentTotalByStdCost)
void | setProfitTotal(java.math.BigDecimal profitTotal)
void | setProfitTotalByStdCost(java.math.BigDecimal profitTotalByStdCost)
void | setRealReceivable(java.math.BigDecimal realReceivable)
void | setRunningAccountOrderItems(java.util.Set runningAccountOrderItems)
void | setRunningAccountOrderNumber(java.lang.String runningAccountOrderNumber)
void | setSalesDate(java.util.Date salesDate)
void | setSalesman(java.lang.String salesman)
void | setSalesOrder(java.lang.String salesOrder)
void | setShipTo(java.lang.String shipTo)
void | setSubTotal(java.math.BigDecimal subTotal)
void | setTax(java.math.BigDecimal tax)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setTaxTotal(java.math.BigDecimal taxTotal)
void | setTaxType(java.lang.String taxType)
void | setValidDate(java.util.Date validDate)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

RunningAccountOrderVO

public RunningAccountOrderVO()
Method Detail

getRunningAccountOrderNumber

public java.lang.String getRunningAccountOrderNumber()

setRunningAccountOrderNumber

public void setRunningAccountOrderNumber(java.lang.String runningAccountOrderNumber)

getSalesman

public java.lang.String getSalesman()

setSalesman

public void setSalesman(java.lang.String salesman)

getSalesDate

public java.util.Date getSalesDate()

setSalesDate

public void setSalesDate(java.util.Date salesDate)

getNetTotal

public java.math.BigDecimal getNetTotal()

setNetTotal

public void setNetTotal(java.math.BigDecimal netTotal)

getAvgCostTotal

public java.math.BigDecimal getAvgCostTotal()

setAvgCostTotal

public void setAvgCostTotal(java.math.BigDecimal avgCostTotal)

getProfitTotal

public java.math.BigDecimal getProfitTotal()

setProfitTotal

public void setProfitTotal(java.math.BigDecimal profitTotal)

getProfitPercentTotal

public java.math.BigDecimal getProfitPercentTotal()

setProfitPercentTotal

public void setProfitPercentTotal(java.math.BigDecimal profitPercentTotal)

getTaxTotal

public java.math.BigDecimal getTaxTotal()

setTaxTotal

public void setTaxTotal(java.math.BigDecimal taxTotal)

getAccountsReceivable

public java.math.BigDecimal getAccountsReceivable()

setAccountsReceivable

public void setAccountsReceivable(java.math.BigDecimal accountsReceivable)

getRealReceivable

public java.math.BigDecimal getRealReceivable()

setRealReceivable

public void setRealReceivable(java.math.BigDecimal realReceivable)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getElecSignature

public byte[] getElecSignature()

setElecSignature

public void setElecSignature(byte[] elecSignature)

getPayableMethod

public java.lang.String getPayableMethod()

setPayableMethod

public void setPayableMethod(java.lang.String payableMethod)

getCheckNumber

public java.lang.String getCheckNumber()

setCheckNumber

public void setCheckNumber(java.lang.String checkNumber)

getCreditCardNumber

public java.lang.String getCreditCardNumber()

setCreditCardNumber

public void setCreditCardNumber(java.lang.String creditCardNumber)

getDutyFreeNumber

public java.lang.String getDutyFreeNumber()

setDutyFreeNumber

public void setDutyFreeNumber(java.lang.String dutyFreeNumber)

isCheckReturn

public boolean isCheckReturn()

setCheckReturn

public void setCheckReturn(boolean checkReturn)

getOriginalNumber

public java.lang.String getOriginalNumber()

setOriginalNumber

public void setOriginalNumber(java.lang.String originalNumber)

getCustomerAddressInfo

public CustomerVendorAddressInfoVO getCustomerAddressInfo()

setCustomerAddressInfo

public void setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)

getRunningAccountOrderItems

public java.util.Set getRunningAccountOrderItems()

setRunningAccountOrderItems

public void setRunningAccountOrderItems(java.util.Set runningAccountOrderItems)

getSalesOrder

public java.lang.String getSalesOrder()

setSalesOrder

public void setSalesOrder(java.lang.String salesOrder)

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getProfitTotalByStdCost

public java.math.BigDecimal getProfitTotalByStdCost()

setProfitTotalByStdCost

public void setProfitTotalByStdCost(java.math.BigDecimal profitTotalByStdCost)

getProfitPercentTotalByStdCost

public java.math.BigDecimal getProfitPercentTotalByStdCost()

setProfitPercentTotalByStdCost

public void setProfitPercentTotalByStdCost(java.math.BigDecimal profitPercentTotalByStdCost)

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getFreight

public java.math.BigDecimal getFreight()

setFreight

public void setFreight(java.math.BigDecimal freight)

getComputerId

public java.lang.String getComputerId()

setComputerId

public void setComputerId(java.lang.String computerId)

getInvoiceNumber

public java.lang.String getInvoiceNumber()

setInvoiceNumber

public void setInvoiceNumber(java.lang.String invoiceNumber)

getSubTotal

public java.math.BigDecimal getSubTotal()

setSubTotal

public void setSubTotal(java.math.BigDecimal subTotal)

getDiscTotal

public java.math.BigDecimal getDiscTotal()

setDiscTotal

public void setDiscTotal(java.math.BigDecimal discTotal)

getBillTo

public java.lang.String getBillTo()

setBillTo

public void setBillTo(java.lang.String billTo)

getShipTo

public java.lang.String getShipTo()

setShipTo

public void setShipTo(java.lang.String shipTo)

getTax

public java.math.BigDecimal getTax()

setTax

public void setTax(java.math.BigDecimal tax)

getChangeNote

public java.math.BigDecimal getChangeNote()

setChangeNote

public void setChangeNote(java.math.BigDecimal changeNote)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getExchange

public java.math.BigDecimal getExchange()

setExchange

public void setExchange(java.math.BigDecimal exchange)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getNotes

public java.lang.String getNotes()

setNotes

public void setNotes(java.lang.String notes)

getPoNumber

public java.lang.String getPoNumber()

setPoNumber

public void setPoNumber(java.lang.String poNumber)

getIpAddr

public java.lang.String getIpAddr()

setIpAddr

public void setIpAddr(java.lang.String ipAddr)

getPrintReturnNumber

public java.lang.String getPrintReturnNumber()

setPrintReturnNumber

public void setPrintReturnNumber(java.lang.String printReturnNumber)

getTaxType

public java.lang.String getTaxType()

setTaxType

public void setTaxType(java.lang.String taxType)

getValidDate

public java.util.Date getValidDate()

setValidDate

public void setValidDate(java.util.Date validDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RunTaxPaymentResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class RunTaxPaymentResult

java.lang.Object
    extended by  bb.common.RunTaxPaymentResult
All Implemented Interfaces:
java.io.Serializable
public class RunTaxPaymentResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
RunTaxPaymentResult()
Method Summary
java.lang.String | getCustomerId()
java.lang.String | getRunningAccountOrderNumber()
java.lang.String | getSalesman()
java.lang.String | getTaxTotal()
void | setCustomerId(java.lang.String customerId)
void | setRunningAccountOrderNumber(java.lang.String runningAccountOrderNumber)
void | setSalesman(java.lang.String salesman)
void | setTaxTotal(java.lang.String taxTotal)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RunTaxPaymentResult

public RunTaxPaymentResult()
Method Detail

getRunningAccountOrderNumber

public java.lang.String getRunningAccountOrderNumber()

setRunningAccountOrderNumber

public void setRunningAccountOrderNumber(java.lang.String runningAccountOrderNumber)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getSalesman

public java.lang.String getSalesman()

setSalesman

public void setSalesman(java.lang.String salesman)

getTaxTotal

public java.lang.String getTaxTotal()

setTaxTotal

public void setTaxTotal(java.lang.String taxTotal)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesBomItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesBomItemResult

java.lang.Object
    extended by  bb.common.SalesBomItemResult
All Implemented Interfaces:
java.io.Serializable
public class SalesBomItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SalesBomItemResult()
Method Summary
java.lang.String | getBill()
BillItemPK | getBillItemPk()
java.lang.String | getBillPartFrom()
java.lang.String | getDescription()
java.lang.String | getDrawing()
java.lang.String | getHold()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.math.BigDecimal | getQuantity()
java.lang.String | getRemovedItem()
java.lang.String | getRevision()
java.lang.String | getSaleable()
java.lang.String | getSparePart()
java.lang.String | getUnit()
void | setBill(java.lang.String bill)
void | setBillItemPk(BillItemPK billItemPk)
void | setBillPartFrom(java.lang.String billPartFrom)
void | setDescription(java.lang.String description)
void | setDrawing(java.lang.String drawing)
void | setHold(java.lang.String hold)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setQuantity(java.math.BigDecimal quantity)
void | setRemovedItem(java.lang.String removedItem)
void | setRevision(java.lang.String revision)
void | setSaleable(java.lang.String saleable)
void | setSparePart(java.lang.String sparePart)
void | setUnit(java.lang.String unit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SalesBomItemResult

public SalesBomItemResult()
Method Detail

getSparePart

public java.lang.String getSparePart()

setSparePart

public void setSparePart(java.lang.String sparePart)

setBillItemPk

public void setBillItemPk(BillItemPK billItemPk)

setBillPartFrom

public void setBillPartFrom(java.lang.String billPartFrom)

setSaleable

public void setSaleable(java.lang.String saleable)

setRemovedItem

public void setRemovedItem(java.lang.String removedItem)

setPartPk

public void setPartPk(PartPK partPk)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

setRevision

public void setRevision(java.lang.String revision)

setUnit

public void setUnit(java.lang.String unit)

setDescription

public void setDescription(java.lang.String description)

setHold

public void setHold(java.lang.String hold)

setDrawing

public void setDrawing(java.lang.String drawing)

setBill

public void setBill(java.lang.String bill)

getBillItemPk

public BillItemPK getBillItemPk()

getBillPartFrom

public java.lang.String getBillPartFrom()

getSaleable

public java.lang.String getSaleable()

getRemovedItem

public java.lang.String getRemovedItem()

getPartPk

public PartPK getPartPk()

getPartFrom

public java.lang.String getPartFrom()

getQuantity

public java.math.BigDecimal getQuantity()

getRevision

public java.lang.String getRevision()

getUnit

public java.lang.String getUnit()

getDescription

public java.lang.String getDescription()

getHold

public java.lang.String getHold()

getDrawing

public java.lang.String getDrawing()

getBill

public java.lang.String getBill()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesBomResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesBomResult

java.lang.Object
    extended by  bb.common.SalesBomResult
All Implemented Interfaces:
java.io.Serializable
public class SalesBomResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SalesBomResult()
Method Summary
java.lang.String | getBillPartFrom()
BillPK | getBillPk()
java.lang.String | getDescription()
java.lang.String | getDrawing()
java.lang.String | getHold()
java.util.Set | getItems()
java.lang.String | getRevision()
java.lang.String | getSaleable()
java.lang.String | getUnit()
void | setBillPartFrom(java.lang.String billPartFrom)
void | setBillPk(BillPK billPk)
void | setDescription(java.lang.String description)
void | setDrawing(java.lang.String drawing)
void | setHold(java.lang.String hold)
void | setItems(java.util.Set items)
void | setRevision(java.lang.String revision)
void | setSaleable(java.lang.String saleable)
void | setUnit(java.lang.String unit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SalesBomResult

public SalesBomResult()
Method Detail

getBillPk

public BillPK getBillPk()

getBillPartFrom

public java.lang.String getBillPartFrom()

getSaleable

public java.lang.String getSaleable()

getRevision

public java.lang.String getRevision()

getUnit

public java.lang.String getUnit()

getDescription

public java.lang.String getDescription()

getHold

public java.lang.String getHold()

getDrawing

public java.lang.String getDrawing()

getItems

public java.util.Set getItems()

setBillPk

public void setBillPk(BillPK billPk)

setBillPartFrom

public void setBillPartFrom(java.lang.String billPartFrom)

setSaleable

public void setSaleable(java.lang.String saleable)

setRevision

public void setRevision(java.lang.String revision)

setUnit

public void setUnit(java.lang.String unit)

setDescription

public void setDescription(java.lang.String description)

setHold

public void setHold(java.lang.String hold)

setDrawing

public void setDrawing(java.lang.String drawing)

setItems

public void setItems(java.util.Set items)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesBox

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common.box
Interface SalesBox

public interface SalesBox

Method Summary
java.lang.String | addCatalog(CatalogVO vo)
java.lang.String | addContractPrice(ContractPriceVO vo)
ContractPriceCustomerVO | addContractPriceCustomer(ContractPriceCustomerVO vo)
ContractPriceItemVO | addContractPriceItem(ContractPriceItemVO vo)
java.util.Collection<ContractPriceItemVO> | addContractPriceItems(java.util.ArrayList list)
IncotermVO | addIncoterm(IncotermVO vo)
MyPrintListVO | addMyPrintList(java.lang.String soNumber)
void | addPartCatalog(java.lang.String catalogID, java.util.HashSet<PartCatalogPK> items)
PartDiscountVO | addPartDiscount(PartDiscountVO vo)
void | addProject(ProjectVO vo)
QuoteVO | addQuote(QuoteVO vo)
QuoteBoilerplateVO | addQuoteBP(QuoteBoilerplateVO vo)
RefdocVO | addRefdocOne(SalesOrderItemPK soItemPk, java.lang.String forderNumber, java.lang.String fItemNumber, java.math.BigDecimal refdocQty)
java.lang.String | addRma(java.lang.String invoiceNumber, boolean includeItems)
java.lang.String | addRmaByCustomerId(java.lang.String customerId)
java.lang.String | addRmaBySalesOrder(java.lang.String soNumber, boolean includeItems)
java.lang.String | addRMAReview(java.lang.String employeeID)
SalesCodeVO | addSalesCodeByAddressId(java.lang.String salesCodeId, java.lang.String addressId)
SalesCodeVO | addSalesCodeByEmployeeId(java.lang.String salesCodeId, java.lang.String employeeId)
java.util.List | addSalesCodeCustomerByAddressIds(java.util.List addressIds, java.lang.String salesCodeId)
SalesmanVO | addSalesman(SalesmanVO vo)
SalesmanVO | addSalesman(java.lang.String lastName)
SalesOrderVO | addSalesOrder(SalesOrderVO vo)
SalesOrderBoilerplateVO | addSalesOrderBP(SalesOrderBoilerplateVO vo)
SalesOrderReviewVO | addSalesOrderControl(java.lang.String employeeId)
void | addSGCustomerCatalog(java.lang.String cusID, java.util.ArrayList<PartCatalogPK> pks, boolean checkCatalog)
void | addSGCustomerCatalog(java.lang.String cusID, PartCatalogPK pk)
SGSaleItemVO | addSGSaleItem(SGSaleItemAgent agent)
void | batchUpdateContractItemDiscount(java.lang.String contractNumber, java.math.BigDecimal discount)
java.lang.String | cancelQuote(java.lang.String quoteNumber)
java.lang.String | cancelRMA(java.lang.String rmaNumber)
java.lang.String | cancelSalesOrder(java.lang.String soNumber)
boolean | clearMySalesOrderPrintList(java.lang.String salesOrderNumberLike)
void | clearSalesOrderItemReferenceDocOne(java.lang.String referenceDoc)
void | clearSalesOrderItemReferenceDocTwo(java.lang.String referenceDoc)
void | closePastedQuotes(java.lang.String[] qtNumbers)
PurchaseOrderVO | copyPurchaseOrderFromSalesOrder(SO2POAgent agent)
java.lang.String | copyQuoteToQuote(Quote2QuoteAgent agent)
java.lang.String | copyQuoteToSalesOrder(java.lang.String qtNumber, boolean needClosed)
java.lang.String | copySalesOrderFromSalesOrder(SO2SOAgent agent)
WorkOrderVO | copyWorkOrderFromSalesOrder(SO2WOAgent agent)
SalesOrderVO | createSalesOrderByExchange(PO2SOExchange exchange)
void | deleteCatalog(java.lang.String catalogID)
void | deleteContractPrice(ContractPriceVO cpVO)
void | deleteContractPriceCustomer(ContractPriceCustomerVO cpcVO)
void | deleteContractPriceItem(ContractPriceItemVO cpiVO)
java.util.Collection<ReturnMaterialAuthorizationDocumentVO> | deleteFTPRMADoc(MiscDocAgent agent)
java.util.Collection<SalesOrderDocumentVO> | deleteFTPSODoc(MiscDocAgent agent)
void | deleteIncoterm(IncotermVO vo)
void | deleteMyPrintList(java.util.ArrayList soNumberList)
void | deletePartCatalog(java.util.ArrayList<PartCatalogPK> pks)
void | deletePartCatalog(PartCatalogPK pk)
void | deletePartDiscount(PartDiscountVO vo)
void | deleteProject(java.lang.String id)
void | deleteQuoteBP(java.lang.String bpID)
java.util.Collection<QuoteDocumentVO> | deleteQuoteDocument(MiscDocAgent agent)
void | deleteRefdocOne(BB2RefdocPK pk)
void | deleteRMAReview(java.lang.String employeeID)
void | deleteSalesCode(java.lang.String salesCodeId)
void | deleteSalesman(SalesmanVO vo)
void | deleteSalesOrderBP(java.lang.String bpID)
void | deleteSalesOrderControl(java.lang.String employeeId)
void | deleteSGCustomerCatalog(java.util.ArrayList<SGCustomerCatalogPK> pks)
void | deleteSGCustomerCatalog(SGCustomerCatalogPK pk)
void | deleteSGSaleItem(int ii)
byte[] | downloadFTPRMADoc(MiscDocAgent agent)
byte[] | downloadFTPSODoc(MiscDocAgent agent)
byte[] | downloadQuoteDocument(MiscDocAgent agent)
java.util.Collection<ContractPriceVO> | findAllContracts(int firstIndex, int maxLength)
java.util.Collection<RMAItemListResult> | findAllDueRma(int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | findAllDueSoItems(int firstIndex, int maxLength)
java.util.Collection<IncotermVO> | findAllIncoterms(int firstIndex, int maxLength)
java.util.Collection<QuoteListResult> | findAllOpenQuote(int firstIndex, int maxLength)
java.util.Collection<RMAItemListResult> | findAllOpenRma(int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | findAllOpenSoItems(boolean orderByDeliveryDateAsc, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | findAllOpenSoItemsByAddressId(java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | findAllOpenSoItemsByAddressIdandShipVia(java.lang.String addressId, java.lang.String shipVia, int firstIndex, int maxLength)
java.util.Collection<PartDiscountVO> | findAllPartDiscount(int firstIndex, int maxLength)
java.util.Collection<PartTraceableInfoResult> | findAllPartTraceableBySN(java.lang.String soNumber)
java.util.Collection<SalesOrderItemListResult> | findAllPastDueSoItemsByAddressId(java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<QuoteListResult> | findAllPastedQuotes(int firstIndex, int maxLength)
java.util.Collection<QuoteBoilerplateVO> | findAllQuoteBP(int firstIndex, int maxLength)
java.util.Collection<QuoteListResult> | findAllQuotes(int firstIndex, int maxLength)
java.util.Collection<RMAReviewVO> | findAllRMAReviews(int firstIndex, int maxLength)
java.util.Collection<RMAListResult> | findAllRmas(int firstIndex, int maxLength)
java.util.Collection<SalesCodeVO> | findAllSalesCode(int firstIndex, int maxLength)
java.util.Collection<BB2DoubleString> | findAllSalesCodeName(int firstIndex, int maxLength)
java.util.Collection<SalesmanVO> | findAllSalesmen(int firstIndex, int maxLength)
java.util.Collection<SalesOrderBoilerplateVO> | findAllSalesOrderBP(int firstIndex, int maxLength)
java.util.Collection<SalesOrderReviewVO> | findAllSalesOrderControl(int firstIndex, int maxLength)
java.util.Collection<SalesOrderListResult> | findAllSalesOrders(int firstIndex, int maxLength)
java.util.Collection<SalesOrderListResult> | findAllSalesOrdersByAddressId(java.lang.String customerIdExp, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | findAllSoItemsByAddressId(java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | findAllSOItemsCanShip(java.lang.String partFrom, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | findAvailablePartsForCGCustomer(java.lang.String customerID, java.lang.String partFrom, java.lang.String partTo, java.lang.String commodityCode, java.lang.String descLike, java.lang.String productCode, boolean ignoreCatalog, int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | findAvailablePartsToSalesCatalog(java.lang.String pnRegex, java.lang.String pn2Regex, java.lang.String commodityCodeLike, java.lang.String descLike, java.lang.String productCode, int firstIndex, int maxLength)
java.util.Collection<QuoteItemListResult> | findCancelledQuoteItem(int firstIndex, int maxLength)
java.util.Collection<RMAItemListResult> | findCancelledRmaItems(int firstIndex, int maxLength)
java.util.Collection<CatalogVO> | findCatalogs(java.lang.String catalogID, java.lang.String description, int firstIndex, int maxLength)
java.util.Collection<SalesOrderCheckListResult> | findCheckList(int firstIndex, int maxLength)
java.util.Collection<ContractPriceCustomerVO> | findContractCustomersByContractNumber(java.lang.String contractNumber, int firstIndex, int maxLength)
java.util.Collection<CPItemFromQuoteResult> | findContractItemFromQuoteItem(java.lang.String contractNumber, java.lang.String quoteNumber)
java.util.Collection<ContractPriceItemVO> | findContractItemsByContractNumber(java.lang.String contractNumber, int firstIndex, int maxLength)
java.util.Collection<ContractPriceCustomerVO> | findContractsByAddressId(java.lang.String addressIdRegex, int firstIndex, int maxLength)
java.util.Collection<ContractPriceVO> | findContractsByContractNumber(java.lang.String contractNumber, int firstIndex, int maxLength)
java.util.Collection<OntimeDeliveryRateListResult> | findCustomerOnTimeDeliveryRateByCustomerId(java.lang.String customerId, java.util.Date from, java.util.Date to, java.lang.String dateType, int delayDays, int beforeDays, java.lang.String salesman, java.lang.String partNumber, java.lang.String partType, java.lang.String incoterm, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemCustomerTotalResult> | findDueSalesOrderItemCustomerTotalResultsByCustomerId(java.lang.String customerIdLike, int firstIndex, int maxLength)
java.util.Collection<SalesOrderListResult> | findDueSalesOrdersByAddressId(java.lang.String customerIdExp, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | findDueShortageSalesOrderItems(java.lang.String partNumberLike, java.lang.String partType, java.lang.String salesOrderNumber, java.lang.String customerID, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | findDueSoItemsByDateType(java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<MonthSoOrArByCustomerResult> | findMonthSOByCustomer(java.util.Date fromMonth, java.util.Date toMonth, java.lang.String salesOrderStatus, java.lang.String customerId, int firstIndex, int maxLength)
java.util.Collection<SalesOrderListResult> | findMySoPrintList()
java.util.Collection<SGCustRequestForQuoteListResult> | findNeedQuoteSGCustRequestForQuoteListResults(java.lang.String crfqNumber, int firstIndex, int maxLength)
java.util.Collection<SalesOrderListResult> | findOpenNotReviewedSalesOrders(java.lang.String soNumberLike, int firstIndex, int maxLength)
java.util.Collection<QuoteListResult> | findOpenQuoteByAddressId(java.lang.String id, int firstIndex, int maxLength)
java.util.Collection<QuoteItemListResult> | findOpenQuoteItemByAddressId(java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<QuoteItemListResult> | findOpenQuoteItemByPartPk(PartPK partPk, int firstIndex, int maxLength)
java.util.Collection<RMAListResult> | findOpenRMAs(java.lang.String rmaNumberExp, int firstIndex, int maxLength)
java.util.Collection<RMAItemListResult> | findOpenRMAsByPartPk(PartPK pk, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | findOpenSaleOrderItemByPartPk(PartPK partPk, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemCustomerTotalResult> | findOpenSalesOrderItemCustomerTotalResultsByCustomerId(java.lang.String customerIdLike, int firstIndex, int maxLength)
java.util.Collection<SalesOrderListResult> | findOpenSalesOrdersByAddressId(java.lang.String customerIdExp, int firstIndex, int maxLength)
java.util.Collection<SalesOrderListResult> | findOpenSalesOrdersForShippingBySoNumber(java.lang.String soIdExp, int firstIndex, int maxLength)
java.util.Collection<SalesOrderListResult> | findOpenSalesOrderWithPrepay(java.lang.String startWith, int firstIndex, int maxLength)
java.util.Collection<SGCustomerServiceRequestVO> | findOpenSGCustomerServiceRequests(int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | findOpenShipViaSalesOrderItems(java.lang.String partNumberLike, java.lang.String partType, java.lang.String salesOrderNumber, java.lang.String customerID, java.lang.String shipVia, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | findOpenShortageSalesOrderItems(java.lang.String partNumberLike, java.lang.String partType, java.lang.String salesOrderNumber, java.lang.String customerID, int firstIndex, int maxLength)
java.util.Collection<SGCustomerServiceRequestVO> | findPendingSGCustomerServiceRequests(int firstIndex, int maxLength)
java.util.Collection<ProjectVO> | findProjectById(java.lang.String id, int firstIndex, int maxLength)
java.util.Collection<QuoteBoilerplateVO> | findQuoteBPByBPId(java.lang.String bpId, int firstIndex, int maxLength)
java.util.Collection<QuoteListResult> | findQuoteByAddressId(java.lang.String id, int firstIndex, int maxLength)
java.util.Collection<QuoteListResult> | findQuoteByQuoteNumberLike(java.lang.String qtNumberLike, int firstIndex, int maxLength)
int | findQuoteDocumentInfo(java.lang.String quoteNumber)
java.util.Collection<QuoteDocumentVO> | findQuoteDocumentInfo(java.lang.String quoteNumber, int firstIndex, int maxLength)
java.util.Collection<SGCustRequestForQuoteListResult> | findQuoteedSGCustRequestForQuoteListResults(java.lang.String userEmail, java.lang.String contactName, java.lang.String custID, int firstIndex, int maxLength)
java.util.Collection<QuoteItemListResult> | findQuoteItemByAddressId(java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<QuoteItemListResult> | findQuoteItemByDate(PartPK partPk, java.lang.String quoteNumber, java.lang.String customerRFQNumber, java.lang.String customerId, java.lang.String includeCustomerIds, java.lang.String excludeCustomerIds, java.lang.String salesMan, java.util.Date fromDate, java.util.Date toDate, java.lang.String status, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<QuoteItemListResult> | findQuoteItemByPartLike(java.lang.String partNumber, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<QuoteItemListResult> | findQuoteItemByPartPk(PartPK pk, int firstIndex, int maxLength)
java.util.Collection<TotalByDateResult> | findQuoteTotalByDateResults(PartPK partPk, java.lang.String quoteNumber, java.lang.String customerRFQNumber, java.lang.String customerId, java.lang.String includeCustomerIds, java.lang.String excludeCustomerIds, java.lang.String salesMan, java.util.Date fromDate, java.util.Date toDate, java.lang.String status, java.lang.String currency)
ReturnMaterialAuthorizationVO | findRmaById(java.lang.String rmaNumber)
java.util.Collection<RMAListResult> | findRmaCheckList(int firstIndex, int maxLength)
java.util.Collection<RMAItemListResult> | findRmaItemByCustomerIdLike(java.lang.String customerIdLike, int firstIndex, int maxLength)
java.util.Collection<RMAItemListResult> | findRmaItemByPartPk(PartPK partPk, int firstIndex, int maxLength)
java.util.Collection<RMAItemListResult> | findRmaItemsByDate(PartPK partPk, java.lang.String rmaNumber, java.lang.String rmaItemNumber, java.lang.String customerId, java.lang.String salesMan, java.lang.String ncrNumber, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isRequireDate, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<RMAListResult> | findRMAsByIvoiceNumber(java.lang.String invoiceNumber, int firstIndex, int maxLength)
java.util.Collection<RMAItemListResult> | findRMAsByPartPk(PartPK pk, int firstIndex, int maxLength)
java.util.Collection<RMAListResult> | findRMAsByRmaNumber(java.lang.String rmaNumberExp, int firstIndex, int maxLength)
java.util.Collection<RMAListResult> | findRMAsBySoNumber(java.lang.String salesOrderNumberExp, int firstIndex, int maxLength)
java.util.Collection<RRMAItemListResult> | findRRMAItemListResult(PartPK partPk, java.lang.String rrmaNumber, java.lang.String rrmaItemNumber, java.lang.String customerId, java.lang.String salesMan, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isRequireDate, java.util.Date fromDate, java.util.Date toDate, boolean incluedInventory, int firstIndex, int maxLength)
java.util.Collection<RRMAListResult> | findRRMAListResult(java.lang.String rrmaNumberLike, java.lang.String status, java.lang.String project, java.lang.String requester, java.lang.String soNumber, java.lang.String invNumber, java.lang.String customerID, int firstIndex, int maxLength)
java.util.Collection<SalesCodeVO> | findSalesCodeById(java.lang.String salesCodeId, java.lang.String salesCodeName, java.lang.String addressId, java.lang.String employeeId, java.math.BigDecimal commissionRate, int firstIndex, int maxLength)
java.util.Map<java.lang.Integer,java.lang.String> | findSalesman(java.lang.String idRegex, java.lang.String lastNameLike, int firstIndex, int maxLength)
java.util.Collection<SalesmanVO> | findSalesmanById(java.lang.String idRegex, int firstIndex, int maxLength)
java.util.Collection<SalesmanVO> | findSalesmanByLastName(java.lang.String lastNameLike, int firstIndex, int maxLength)
java.util.Collection<java.util.Map> | findSalesOrderArPrepays(java.lang.String[] soNumbers)
java.util.Collection<SalesOrderBoilerplateVO> | findSalesOrderBPByBPId(java.lang.String boilerplateId, int firstIndex, int maxLength)
java.util.Collection<SalesOrderReviewVO> | findSalesOrderControlByUserTrueNameLike(java.lang.String userTrueNameLike, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | findSalesOrderItemByPartPk(PartPK pk, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemGroupByPartListResult> | findSalesOrderItemGroupByPart(java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemGroupByPartListResult> | findSalesOrderItemGroupByPart(java.lang.String partNumber, java.lang.String partType, java.lang.String status, java.lang.String dateTpey, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | findSalesOrderItemsByCustomerId(java.lang.String customerId, java.util.Date from, java.util.Date to, java.lang.String dateType, java.lang.String salesman, java.lang.String partNumber, java.lang.String partType, java.lang.String incoterm, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | findSalesOrderItemsByDate(java.lang.String partNumberLike, java.lang.String partType, java.lang.String customerId, java.lang.String includeCustomerIds, java.lang.String excludeCustomerIds, java.lang.String salesMan, java.lang.String status, java.lang.String productCode, java.lang.String commodityCode, java.lang.String projectName, java.lang.String dateColumn, java.util.Date fromDate, java.util.Date toDate, java.lang.String currency, java.lang.String salesCodeId, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isHold, java.lang.String state, java.lang.String incotermPort, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | findSalesOrderItemsByDates(java.lang.String partNumberLike, java.lang.String partType, java.lang.String customerId, java.lang.String includeCustomerIds, java.lang.String excludeCustomerIds, java.lang.String salesMan, java.lang.String status, java.lang.String productCode, java.lang.String projectName, java.lang.String relatedDoc, java.lang.String dateColumn, java.util.Date fromDate, java.util.Date toDate, java.lang.String currency, java.lang.String salesCodeID, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isHold, java.lang.String state, java.lang.String incoterm, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | findSalesOrderItemsByDates(java.lang.String partNumberLike, java.lang.String partType, java.lang.String customerId, java.lang.String includeCustomerIds, java.lang.String excludeCustomerIds, java.lang.String salesMan, java.lang.String status, java.lang.String productCode, java.lang.String projectName, java.lang.String relatedDoc, java.lang.String dateColumn, java.util.Date fromDate, java.util.Date toDate, java.lang.String currency, java.lang.String salesCodeID, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String state, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | findSalesOrderItemsBySalesman(java.lang.String salesmanLike, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | findSalesOrderItemsCost(java.lang.String status, int firstIndex, int maxLenggh)
java.util.Collection<SalesOrderVO> | findSalesOrderItemsWithoutInvoice(java.lang.String customerId, java.lang.String currency, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)
java.util.Collection<SalesOrderListResult> | findSalesOrdersByPoNumber(java.lang.String poNumberExp, int firstIndex, int maxLength)
java.util.Collection<SalesOrderListResult> | findSalesOrdersBySalesman(java.lang.String salesmanExp, int firstIndex, int maxLength)
java.util.Collection<SalesOrderListResult> | findSalesOrdersBySoNumber(java.lang.String soNumberExp, int firstIndex, int maxLength)
java.util.Collection<SGCustomerServiceRequestVO> | findSGCustomerServiceRequestsByDate(java.lang.String csrNumber, java.lang.String custID, java.lang.String pnLike, java.lang.String soLike, java.lang.String serial, java.lang.String status, java.lang.String csiNum, java.util.Date fDate, java.util.Date tDate, int firstIndex, int maxLength)
java.util.Collection<SGPartCatalogResult> | findSGPartCatalogResults(java.lang.String catalog, java.lang.String pnLike, int firstIndex, int maxLength)
java.util.Collection<SGPartCatalogResult> | findSGPartCatalogResultsforCustomerID(java.lang.String customerID, java.lang.String catalog, int firstIndex, int maxLength)
java.util.List | findSGPartCatalogResultsforCustomerIDAndMultiCondition(java.lang.String customerID, java.lang.String catalogID, int firstIndex, int maxLength)
java.util.Collection<SGPartCatalogResult> | findSGPartCatalogResultsforCustomerIDByPart(java.lang.String catalogID, java.lang.String partNum, int firstIndex, int maxLength)
java.util.Collection<SGSaleItemVO> | findSGSaleItems(java.lang.String custID, java.lang.String soNumber, java.lang.String poNumber, java.lang.String pnNumber, java.lang.String paType, java.lang.String serial, int firstIndex, int maxLength)
java.util.Collection<TotalByDateResult> | findSoTotalByDateResults(java.lang.String partNumberLike, java.lang.String partType, java.lang.String customerIdLike, java.lang.String includeCustomerIds, java.lang.String excludeCustomerIds, java.lang.String salesMan, java.lang.String status, java.lang.String productCode, java.lang.String commodityCode, java.lang.String projectName, java.lang.String dateColumn, java.util.Date fromDate, java.util.Date toDate, java.lang.String currency, java.lang.String salesCodeId, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isHold, java.lang.String state, java.lang.String incotermPort)
java.util.Collection<BB2DoubleString> | getAllCatalogsId()
int | getAllContractsCount()
int | getAllDueRmaCount()
Money | getAllDueSalesOrdersTotalMoneyValue()
Money | getAllDueSalesOrdersTotalMoneyValue(java.lang.String customerId)
int | getAllDueSoItemsCount()
int | getAllIncotermsCount()
int | getAllOpenQuotesCount()
int | getAllOpenRmaCount()
Money | getAllOpenSalesOrdersTotalMoneyValue()
Money | getAllOpenSalesOrdersTotalMoneyValue(java.lang.String customerId)
int | getAllOpenSoItemsCount()
int | getAllOpenSoItemsCountByAddressId(java.lang.String addressId)
int | getAllOpenSoItemsCountByAddressIdandShipVia(java.lang.String addressId, java.lang.String shipVia)
int | getAllPartdiscount()
int | getAllPastDueSoItemsCountByAddressId(java.lang.String addressId)
int | getAllPastedQuotesCount()
int | getAllQuoteBPCount()
int | getAllQuoteCount()
int | getAllRMAReviewsCount()
int | getAllRmasCount()
int | getAllSalesCodeCount()
int | getAllSalesCodeNameCount()
int | getAllSalesmanCount()
int | getAllSalesOrderBPCount()
int | getAllSalesOrderControlCount()
int | getAllSalesOrderCount()
int | getAllSalesOrdersCountByAddressId(java.lang.String customerIdExp)
int | getAllSOItemsCanShipCount(java.lang.String partFrom, java.util.Date fromDate, java.util.Date toDate)
int | getAllSoItemsCountByAddressId(java.lang.String addressId)
int | getAvailablePartsForCGCustomerCount(java.lang.String customerID, java.lang.String partFrom, java.lang.String partTo, java.lang.String commodityCodeLike, java.lang.String descLike, java.lang.String productCode, boolean ignoreCatalog)
int | getAvailablePartsToSalesCatalogCount(java.lang.String pnRegex, java.lang.String pn2Regex, java.lang.String commodityCodeLike, java.lang.String descLike, java.lang.String productCode)
int | getCancelledQuoteItemCount()
int | getCancelledRmaItemsCount()
CatalogVO | getCatalog(java.lang.String catalogID)
int | getCatalogsCount(java.lang.String catalogID, java.lang.String description)
int | getCheckListCount()
java.lang.String | getCompanyUnitIDBySalesman(java.lang.String salesmanId)
int | getContractCustomersCountByContractNumber(java.lang.String contractNumber)
int | getContractItemsCountByContractNumber(java.lang.String contractNumber)
ContractPriceVO | getContractPriceById(java.lang.String cpNumber)
ContractPriceCustomerVO | getContractPriceCustomer(ContractPriceCustomerPK pk)
ContractPriceItemVO | getContractPriceItem(ContractPriceItemPK pk)
int | getContractsByAddressIdCount(java.lang.String addressIdRegex)
int | getContractsCountByContractNumber(java.lang.String contractNumber)
OntimeDeliveryRateResult | getCustomerOnTimeDeliveryRate(java.lang.String customerId, java.util.Date from, java.util.Date to, java.lang.String dateType, int delayDays, int beforeDays, java.lang.String salesman, java.lang.String partNumber, java.lang.String partType, java.lang.String incoterm)
int | getCustomerOnTimeDeliveryRateCountByCustomerId(java.lang.String customerId, java.util.Date from, java.util.Date to, java.lang.String dateType, int delayDays, int beforeDays, java.lang.String salesman, java.lang.String partNumber, java.lang.String partType, java.lang.String incoterm)
int | getDueSalesOrderItemCustomerTotalResultsByCustomerId(java.lang.String customerIdLike)
int | getDueSalesOrdersCountByAddressId(java.lang.String customerIdExp)
Money | getDueSalesOrdersTotalMoneyValueByDate(java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate)
int | getDueShortageSalesOrderItemsCount(java.lang.String partNumberLike, java.lang.String partType, java.lang.String salesOrderNumber, java.lang.String customerID)
int | getDueSoItemsCountByDateType(java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate)
IncotermVO | getIncotermById(java.lang.String id)
java.math.BigDecimal[] | getInitDefaultPricePerUnit(BB2Part part, java.lang.String soNumber)
java.util.Map<java.util.Date,OntimeDeliveryRateResult> | getLast12MonthOntimeDeliveryRate(java.lang.String customerId, java.lang.String dateType, int overDueDays, int advanceDays, java.lang.String salesman, java.lang.String partNumber, java.lang.String partType, java.lang.String incoterm)
int | getMonthSOByCustomerCount(java.util.Date fromMonth, java.util.Date toMonth, java.lang.String salesOrderStatus, java.lang.String customerId)
java.util.Map<java.lang.String,java.math.BigDecimal> | getMonthSOByCustomerSum(java.util.Date fromMonth, java.util.Date toMonth, java.lang.String salesOrderStatus, java.lang.String customerId)
int | getNeedQuoteSGCustRequestForQuoteListResultsCount(java.lang.String crfqNumber)
java.lang.String | getNewQuoteItemNumber(java.lang.String qo)
java.lang.String | getNewSalesOrderItemNumber(java.lang.String qo)
IncomeByMonthChartResult | getNext12MonthSoShipAmount()
int | getOpenNotReviewedSalesOrdersCount(java.lang.String soNumberLike)
int | getOpenQuoteItemCountByAddressId(java.lang.String addressId)
int | getOpenQuoteItemCountByPartPk(PartPK partPk)
int | getOpenQuotesCountByAddressId(java.lang.String id)
int | getOpenRMAsCount(java.lang.String rmaNumberExp)
int | getOpenRMAsCountByPartPk(PartPK pk)
int | getOpenSaleOrderItemByPartPkCount(PartPK partPk)
int | getOpenSalesOrderItemCustomerTotalResultsByCustomerId(java.lang.String customerIdLike)
int | getOpenSalesOrdersCountByAddressId(java.lang.String customerIdExp)
int | getOpenSalesOrdersForShippingCountBySoNumber(java.lang.String soIdExp)
int | getOpenSalesOrderWithPrepayCount(java.lang.String startWith)
int | getOpenSGCustomerServiceRequestsCount()
int | getOpenShipViaSalesOrderItemsCount(java.lang.String partNumberLike, java.lang.String partType, java.lang.String salesOrderNumber, java.lang.String customerID, java.lang.String shipVia)
int | getOpenShortageSalesOrderItemsCount(java.lang.String partNumberLike, java.lang.String partType, java.lang.String salesOrderNumber, java.lang.String customerID)
java.util.Collection<PartCatalogAuditResult> | getPartCatalogAuditResults(java.lang.String pnLike)
java.util.Collection<PartCatalogVO> | getPartCatalogs(java.lang.String catalogID)
PartDiscountVO | getPartDiscountVOByPk(PartDiscountPK pk)
int | getPendingSGCustomerServiceRequestsCount()
ProjectVO | getProjectByID(java.lang.String id)
int | getProjectByIdCount(java.lang.String id)
QuoteBoilerplateVO | getQuoteBPByPk(java.lang.String quoteBoilerplateId)
int | getQuoteBPCountByBPId(java.lang.String bpId)
QuoteVO | getQuoteById(java.lang.String qtNumber)
int | getQuoteByQuoteNumberLike(java.lang.String qtNumberLike)
QuoteDocumentVO | getQuoteDocumentByID(java.lang.Long controlNumber)
int | getQuoteedSGCustRequestForQuoteListResultsCount(java.lang.String userEmail, java.lang.String contactName, java.lang.String custID)
int | getQuoteItemCountByAddressId(java.lang.String addressId)
int | getQuoteItemCountByDate(PartPK partPk, java.lang.String quoteNumber, java.lang.String customerRFQNumber, java.lang.String customerId, java.lang.String includeCustomerIds, java.lang.String excludeCustomerIds, java.lang.String salesMan, java.util.Date fromDate, java.util.Date toDate, java.lang.String status, java.lang.String currency)
int | getQuoteItemCountByPartLike(java.lang.String partNumber, java.lang.String partType)
int | getQuoteItemCountByPartPK(PartPK pk)
QuoteItemVO | getQuoteItemVo(QuoteItemPK pk)
int | getQuotesCountByAddressId(java.lang.String id)
int | getRmaCheckListCount()
int | getRmaItemByPartPkCount(PartPK partPk)
int | getRmaItemCountByCustomerIdLike(java.lang.String customerIdLike)
int | getRmaItemsCountByDate(PartPK partPk, java.lang.String rmaNumber, java.lang.String rmaItemNumber, java.lang.String customerId, java.lang.String salesMan, java.lang.String ncrNumber, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isRequireDate, java.util.Date fromDate, java.util.Date toDate)
java.util.Collection<RMAReceiverItemListResult> | getRmaReceiverBySoNumber(java.lang.String soNumber)
RMAReviewVO | getRMAReview(java.lang.String employeeID)
int | getRMAsCountByInvoiceNumber(java.lang.String invoiceNumber)
int | getRMAsCountByPartPk(PartPK pk)
int | getRMAsCountByRmaNumber(java.lang.String rmaNumberExp)
int | getRMAsCountBySoNumber(java.lang.String salesOrderNumberExp)
RequestForRMAVO | getRRMAById(java.lang.String rrmaNumber)
RequestForRMAItemVO | getRRMAItemByPk(RequestForRMAItemPK pk)
int | getRRMAItemListResultCount(PartPK partPk, java.lang.String rrmaNumber, java.lang.String rrmaItemNumber, java.lang.String customerId, java.lang.String salesMan, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isRequireDate, java.util.Date fromDate, java.util.Date toDate)
int | getRRMAListResultCount(java.lang.String rrmaNumberLike, java.lang.String status, java.lang.String project, java.lang.String requester, java.lang.String soNumber, java.lang.String invNumber, java.lang.String customerID)
SalesOrderDocumentVO | getSaleOrderDocumentByID(java.lang.Long controlNumber)
SalesBomResult | getSalesBomResult(BillPK billPk, java.lang.String partFrom)
java.util.Collection<SalesCodeVO> | getSalesCodeByAddressId(java.lang.String addressId)
SalesCodeVO | getSalesCodeByPk(java.lang.String salesCodeId)
int | getSalesCodeCountById(java.lang.String salesCodeId, java.lang.String salesCodeName, java.lang.String addressId, java.lang.String employeeId, java.math.BigDecimal commissionRate)
java.util.List | getSalesCodeCustomerByAddressIds(java.util.List addressIds)
SalesmanVO | getSalesmanByPk(int id)
int | getSalesmanCount(java.lang.String idRegex, java.lang.String lastNameLike)
int | getSalesmanCountById(java.lang.String idRegex)
int | getSalesmanCountByLastName(java.lang.String lastNameLike)
java.math.BigDecimal | getSalesOrderArPrepayApply(java.lang.String soNumber)
java.math.BigDecimal | getSalesOrderArPrepayPaid(java.lang.String soNumber)
SalesOrderBoilerplateVO | getSalesOrderBPByPk(java.lang.String salesOrderBoilerplateId)
int | getSalesOrderBPCountByBPId(java.lang.String boilerplateId)
SalesOrderVO | getSalesOrderById(java.lang.String soNumber)
SalesOrderVO | getSalesOrderByIdForPrintSOLabel(java.lang.String soNumber)
SalesOrderReviewVO | getSalesOrderControlByEmoloyeeTrueName(java.lang.String emoloyeeTrueName)
SalesOrderReviewVO | getSalesOrderControlByEmployeeId(java.lang.String employeeId)
int | getSalesOrderControlCountByUserTrueNameLike(java.lang.String userTrueNameLike)
int | getSalesOrderItemByPartPkCount(PartPK pk)
SalesOrderItemVO | getSalesOrderItemByPk(SalesOrderItemPK pk)
SalesOrderItemCostResult | getSalesOrderItemCostResult(java.lang.String status)
int | getSalesOrderItemGroupByPartCount(java.util.Date fromDate, java.util.Date toDate)
int | getSalesOrderItemGroupByPartCount(java.lang.String partNumber, java.lang.String partType, java.lang.String status, java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate)
int | getSalesOrderItemsByCustomerIdCount(java.lang.String customerId, java.util.Date from, java.util.Date to, java.lang.String dateType, java.lang.String salesman, java.lang.String partNumber, java.lang.String partType, java.lang.String incoterm)
int | getSalesOrderItemsCost(java.lang.String status)
int | getSalesOrderItemsCountByDate(java.lang.String partNumberLike, java.lang.String partType, java.lang.String customerId, java.lang.String includeCustomerIds, java.lang.String excludeCustomerIds, java.lang.String salesMan, java.lang.String status, java.lang.String productCode, java.lang.String commodityCode, java.lang.String projectName, java.lang.String dateColumn, java.util.Date fromDate, java.util.Date toDate, java.lang.String currency, java.lang.String salesCodeId, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isHold, java.lang.String state, java.lang.String incotermPort)
int | getSalesOrderItemsCountByDates(java.lang.String partNumberLike, java.lang.String partType, java.lang.String customerId, java.lang.String includeCustomerIds, java.lang.String excludeCustomerIds, java.lang.String salesMan, java.lang.String status, java.lang.String productCode, java.lang.String projectName, java.lang.String relatedDoc, java.lang.String dateColumn, java.util.Date fromDate, java.util.Date toDate, java.lang.String currency, java.lang.String salesCodeId, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isHold, java.lang.String state)
int | getSalesOrderItemsCountByDates(java.lang.String partNumberLike, java.lang.String partType, java.lang.String customerId, java.lang.String includeCustomerIds, java.lang.String excludeCustomerIds, java.lang.String salesMan, java.lang.String status, java.lang.String productCode, java.lang.String projectName, java.lang.String relatedDoc, java.lang.String dateColumn, java.util.Date fromDate, java.util.Date toDate, java.lang.String currency, java.lang.String salesCodeId, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String state)
int | getSalesOrderItemsCountBySalesman(java.lang.String salesmanLike)
int | getSalesOrdersByPoNumberCount(java.lang.String poNumberExp)
int | getSalesOrdersBySoNumberCount(java.lang.String soNumberExp)
int | getSalesOrdersCountBySalesman(java.lang.String salesmanExp)
SalesOrderVO | getSalesOrderWithOrderApplyByWo(java.lang.Long orderApplyID)
SalesPartListResult | getSalesPartListResult(BillPK billPk, java.lang.String partFrom)
SGCustomerCatalogVO | getSGCustomerCatalog(SGCustomerCatalogPK pk)
java.util.Collection<SGPartCatalogResult> | getSGCustomerCatalogByPN(java.lang.String customerID, java.lang.String pnLike)
SGCustomerServiceRequestVO | getSGCustomerServiceRequest(java.lang.String csrNumber)
int | getSGCustomerServiceRequestsCountByDate(java.lang.String csrNumber, java.lang.String custID, java.lang.String pnLike, java.lang.String soLike, java.lang.String serial, java.lang.String status, java.lang.String csiNum, java.util.Date fDate, java.util.Date tDate)
SGCustRequestForQuoteResult | getSGCustRequestForQuoteResult(java.lang.String crfqNumber)
java.lang.String | getSGPartCatalogConditionDescForCustomerID(java.lang.String customerID)
int | getSGPartCatalogCountByCustomerID(java.lang.String customerID)
int | getSGPartCatalogCountByCustomerIDAndMultiCondition(java.lang.String customerID, java.lang.String catalogID)
java.util.Collection<SGPartCatalogResult> | getSGPartCatalogResults(java.lang.String catalogID)
int | getSGPartCatalogResultsCount(java.lang.String catalog, java.lang.String pnLike)
java.util.Collection<SGPartCatalogResult> | getSGPartCatalogResultsforCustomerID(java.lang.String customerID, int firstIndex, int maxLength)
java.util.Collection<SGPartCatalogResult> | getSGPartCatalogResultsforCustomerID(java.lang.String customerID, java.lang.String catalogID)
int | getSGPartCatalogResultsforCustomerIDByPartCount(java.lang.String catalogID, java.lang.String partNum)
int | getSGPartCatalogResultsforCustomerIDCount(java.lang.String customerID, java.lang.String catalog)
java.util.Collection<SGPartCatalogResult> | getSGPartCatalogResultsNotforCustomerID(java.lang.String customerID, java.lang.String catalogID)
SGSaleItemVO | getSGSaleItem(int ii)
int | getSGSaleItemsCount(java.lang.String custID, java.lang.String soNumber, java.lang.String poNumber, java.lang.String pnNumber, java.lang.String paType, java.lang.String serial)
int[] | getSoCountPerMonth(int year)
java.util.Collection<SOShipperItemListResult> | getSOShipperItemListResultsOfSalesOrder(java.lang.String soNumber)
java.util.Collection<PartBasicInfo> | getSpareSaleableParts(java.lang.String pnLike, java.lang.String description)
java.util.Collection<BB2PartInSipOfSoItemResult> | getTotalSOInSipDetail(BB2Part part)
java.lang.String | getUserEmail(java.lang.String crfqNumber)
java.util.HashMap<BB2Part,BB2WeightInfoResult> | getWeightInfo(java.util.HashSet<BB2Part> pks)
QuoteItemVO | initQuoteItem(QuoteVO soVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool)
ReturnMaterialAuthorizationItemVO | initRmaItem(ReturnMaterialAuthorizationVO rmaVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool)
ReturnMaterialAuthorizationItemVO | initRmaItem(ReturnMaterialAuthorizationVO rmaVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool, boolean isPOS)
SalesOrderItemVO | initSalesOrderItem(SalesOrderVO soVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool)
SalesOrderItemVO | initSalesOrderItem(SalesOrderVO soVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool, boolean isPOS)
boolean | isContractPriceCustomerExistent(ContractPriceCustomerPK pk)
boolean | isContractPriceExistent(java.lang.String contractNumber)
boolean | isContractPriceItemExistent(ContractPriceItemPK pk)
boolean | isQuoteBoilerplateExist(java.lang.String quoteBoilerplateId)
boolean | isQuoteExist(java.lang.String quoteNumber)
boolean | isRrmaExist(java.lang.String rrmaNumber)
boolean | isRrmaItemExist(RequestForRMAItemPK pk)
boolean | isSalesOrderAndSoItemOpen(SalesOrderItemPK pk)
boolean | isSalesOrderBoilerplateExist(java.lang.String salesOrderBoilerplateId)
boolean | isSalesOrderControlRecorded(java.lang.String employeeId)
boolean | isSalesOrderExist(java.lang.String soNumber)
boolean | isSalesOrderInMyPrintList(java.lang.String salesOrderNumber)
boolean | isSalesOrderItemExist(SalesOrderItemPK pk)
ReturnMaterialAuthorizationVO | makeRMAFromRRMANumber(java.lang.String rrmaNumber)
QuoteVO | quoteForCRFQ(java.lang.String crfqNumber)
QuoteVO | reviewQuote(java.lang.String qtNumber)
ReturnMaterialAuthorizationVO | reviewRma(ReturnMaterialAuthorizationVO rmaVo)
RequestForRMAVO | reviewRrma(RequestForRMAVO rrma)
SalesOrderVO | reviewSalesOrder(SalesOrderVO soVo)
void | setSalesOrderItemReferenceDocOne(SalesOrderItemPK pk, java.lang.String referenceDoc)
void | setSalesOrderItemReferenceDocTwo(SalesOrderItemPK pk, java.lang.String referenceDoc)
java.lang.String | updateCatalog(CatalogVO vo)
java.lang.String | updateContractPrice(ContractPriceVO vo)
ContractPriceCustomerVO | updateContractPriceCustomer(ContractPriceCustomerVO vo)
ContractPriceItemVO | updateContractPriceItem(ContractPriceItemVO vo)
IncotermVO | updateIncoterm(IncotermVO vo)
void | updatePartCatalog(java.util.ArrayList<PartCatalogVO> volist)
void | updatePartCatalog(PartCatalogVO vo)
void | updatePartDiscount(PartDiscountVO vo)
void | updateProject(ProjectVO vo)
QuoteVO | updateQuote(QuoteVO vo)
QuoteBoilerplateVO | updateQuoteBP(QuoteBoilerplateVO vo)
RefdocVO | updateRefdocOne(RefdocVO vo)
java.lang.String | updateRma(ReturnMaterialAuthorizationVO vo)
java.lang.String | updateRMAReview(RMAReviewVO vo)
SalesCodeVO | updateSalesCode(SalesCodeVO vo)
SalesmanVO | updateSalesman(SalesmanVO vo)
java.lang.String | updateSalesOrder(SalesOrderVO vo)
SalesOrderBoilerplateVO | updateSalesOrderBP(SalesOrderBoilerplateVO vo)
SalesOrderReviewVO | updateSalesOrderControl(SalesOrderReviewVO vo)
void | updateSGCustomerCatalog(java.util.ArrayList<SGCustomerCatalogVO> vos)
void | updateSGCustomerCatalog(SGCustomerCatalogVO vo)
java.lang.String | updateSGCustomerServiceRequest(SGCustomerServiceRequestVO vo)
SGSaleItemVO | updateSGSaleItem(SGSaleItemVO vo)
java.util.Collection<ReturnMaterialAuthorizationDocumentVO> | uploadOrUpdateFTPRMADoc(MiscDocAgent agent)
java.util.Collection<SalesOrderDocumentVO> | uploadOrUpdateFTPSODoc(MiscDocAgent agent)
java.util.Collection<QuoteDocumentVO> | uploadOrUpdateQuoteDocument(MiscDocAgent agent)

Method Detail

findAllQuotes

java.util.Collection<QuoteListResult> findAllQuotes(int firstIndex,
                                                    int maxLength)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getAllQuoteCount

int getAllQuoteCount()
                     throws java.lang.Exception
Throws:
java.lang.Exception

getQuoteById

QuoteVO getQuoteById(java.lang.String qtNumber)
                     throws java.lang.Exception
Throws:
java.lang.Exception

findAllOpenQuote

java.util.Collection<QuoteListResult> findAllOpenQuote(int firstIndex,
                                                       int maxLength)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getAllOpenQuotesCount

int getAllOpenQuotesCount()
                          throws java.lang.Exception
Throws:
java.lang.Exception

findQuoteByQuoteNumberLike

java.util.Collection<QuoteListResult> findQuoteByQuoteNumberLike(java.lang.String qtNumberLike,
                                                                 int firstIndex,
                                                                 int maxLength)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getQuoteByQuoteNumberLike

int getQuoteByQuoteNumberLike(java.lang.String qtNumberLike)
                              throws java.lang.Exception
Throws:
java.lang.Exception

findQuoteByAddressId

java.util.Collection<QuoteListResult> findQuoteByAddressId(java.lang.String id,
                                                           int firstIndex,
                                                           int maxLength)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

findOpenQuoteByAddressId

java.util.Collection<QuoteListResult> findOpenQuoteByAddressId(java.lang.String id,
                                                               int firstIndex,
                                                               int maxLength)
                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getQuotesCountByAddressId

int getQuotesCountByAddressId(java.lang.String id)
                              throws java.lang.Exception
Throws:
java.lang.Exception

getOpenQuotesCountByAddressId

int getOpenQuotesCountByAddressId(java.lang.String id)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findAllPastedQuotes

java.util.Collection<QuoteListResult> findAllPastedQuotes(int firstIndex,
                                                          int maxLength)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getAllPastedQuotesCount

int getAllPastedQuotesCount()
                            throws java.lang.Exception
Throws:
java.lang.Exception

addQuote

QuoteVO addQuote(QuoteVO vo)
                 throws java.lang.Exception
Throws:
java.lang.Exception

updateQuote

QuoteVO updateQuote(QuoteVO vo)
                    throws java.lang.Exception
Throws:
java.lang.Exception

quoteForCRFQ

QuoteVO quoteForCRFQ(java.lang.String crfqNumber)
                     throws java.lang.Exception
Throws:
java.lang.Exception

initQuoteItem

QuoteItemVO initQuoteItem(QuoteVO soVo,
                          PartPK partPk,
                          java.math.BigDecimal quantity,
                          boolean isTool)
                          throws java.lang.Exception
Throws:
java.lang.Exception

reviewQuote

QuoteVO reviewQuote(java.lang.String qtNumber)
                    throws java.lang.Exception
Throws:
java.lang.Exception

closePastedQuotes

void closePastedQuotes(java.lang.String[] qtNumbers)
                       throws java.lang.Exception
Throws:
java.lang.Exception

copyQuoteToQuote

java.lang.String copyQuoteToQuote(Quote2QuoteAgent agent)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findQuoteItemByAddressId

java.util.Collection<QuoteItemListResult> findQuoteItemByAddressId(java.lang.String addressId,
                                                                   int firstIndex,
                                                                   int maxLength)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getQuoteItemCountByAddressId

int getQuoteItemCountByAddressId(java.lang.String addressId)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findOpenQuoteItemByAddressId

java.util.Collection<QuoteItemListResult> findOpenQuoteItemByAddressId(java.lang.String addressId,
                                                                       int firstIndex,
                                                                       int maxLength)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getOpenQuoteItemCountByAddressId

int getOpenQuoteItemCountByAddressId(java.lang.String addressId)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findQuoteItemByPartPk

java.util.Collection<QuoteItemListResult> findQuoteItemByPartPk(PartPK pk,
                                                                int firstIndex,
                                                                int maxLength)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getQuoteItemCountByPartPK

int getQuoteItemCountByPartPK(PartPK pk)
                              throws java.lang.Exception
Throws:
java.lang.Exception

findOpenQuoteItemByPartPk

java.util.Collection<QuoteItemListResult> findOpenQuoteItemByPartPk(PartPK partPk,
                                                                    int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getOpenQuoteItemCountByPartPk

int getOpenQuoteItemCountByPartPk(PartPK partPk)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findQuoteItemByPartLike

java.util.Collection<QuoteItemListResult> findQuoteItemByPartLike(java.lang.String partNumber,
                                                                  java.lang.String partType,
                                                                  int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getQuoteItemCountByPartLike

int getQuoteItemCountByPartLike(java.lang.String partNumber,
                                java.lang.String partType)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findQuoteItemByDate

java.util.Collection<QuoteItemListResult> findQuoteItemByDate(PartPK partPk,
                                                              java.lang.String quoteNumber,
                                                              java.lang.String customerRFQNumber,
                                                              java.lang.String customerId,
                                                              java.lang.String includeCustomerIds,
                                                              java.lang.String excludeCustomerIds,
                                                              java.lang.String salesMan,
                                                              java.util.Date fromDate,
                                                              java.util.Date toDate,
                                                              java.lang.String status,
                                                              java.lang.String currency,
                                                              int firstIndex,
                                                              int maxLength)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

findQuoteTotalByDateResults

java.util.Collection<TotalByDateResult> findQuoteTotalByDateResults(PartPK partPk,
                                                                    java.lang.String quoteNumber,
                                                                    java.lang.String customerRFQNumber,
                                                                    java.lang.String customerId,
                                                                    java.lang.String includeCustomerIds,
                                                                    java.lang.String excludeCustomerIds,
                                                                    java.lang.String salesMan,
                                                                    java.util.Date fromDate,
                                                                    java.util.Date toDate,
                                                                    java.lang.String status,
                                                                    java.lang.String currency)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getQuoteItemCountByDate

int getQuoteItemCountByDate(PartPK partPk,
                            java.lang.String quoteNumber,
                            java.lang.String customerRFQNumber,
                            java.lang.String customerId,
                            java.lang.String includeCustomerIds,
                            java.lang.String excludeCustomerIds,
                            java.lang.String salesMan,
                            java.util.Date fromDate,
                            java.util.Date toDate,
                            java.lang.String status,
                            java.lang.String currency)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findCancelledQuoteItem

java.util.Collection<QuoteItemListResult> findCancelledQuoteItem(int firstIndex,
                                                                 int maxLength)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getCancelledQuoteItemCount

int getCancelledQuoteItemCount()
                               throws java.lang.Exception
Throws:
java.lang.Exception

getQuoteDocumentByID

QuoteDocumentVO getQuoteDocumentByID(java.lang.Long controlNumber)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

downloadQuoteDocument

byte[] downloadQuoteDocument(MiscDocAgent agent)
                             throws java.lang.Exception
Throws:
java.lang.Exception

deleteQuoteDocument

java.util.Collection<QuoteDocumentVO> deleteQuoteDocument(MiscDocAgent agent)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

uploadOrUpdateQuoteDocument

java.util.Collection<QuoteDocumentVO> uploadOrUpdateQuoteDocument(MiscDocAgent agent)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

findQuoteDocumentInfo

java.util.Collection<QuoteDocumentVO> findQuoteDocumentInfo(java.lang.String quoteNumber,
                                                            int firstIndex,
                                                            int maxLength)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

findQuoteDocumentInfo

int findQuoteDocumentInfo(java.lang.String quoteNumber)
                          throws java.lang.Exception
Throws:
java.lang.Exception

findNeedQuoteSGCustRequestForQuoteListResults

java.util.Collection<SGCustRequestForQuoteListResult> findNeedQuoteSGCustRequestForQuoteListResults(java.lang.String crfqNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getNeedQuoteSGCustRequestForQuoteListResultsCount

int getNeedQuoteSGCustRequestForQuoteListResultsCount(java.lang.String crfqNumber)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

findQuoteedSGCustRequestForQuoteListResults

java.util.Collection<SGCustRequestForQuoteListResult> findQuoteedSGCustRequestForQuoteListResults(java.lang.String userEmail,
                                                                                java.lang.String contactName,
                                                                                java.lang.String custID,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getQuoteedSGCustRequestForQuoteListResultsCount

int getQuoteedSGCustRequestForQuoteListResultsCount(java.lang.String userEmail,
                                                    java.lang.String contactName,
                                                    java.lang.String custID)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getSGCustRequestForQuoteResult

SGCustRequestForQuoteResult getSGCustRequestForQuoteResult(java.lang.String crfqNumber)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getUserEmail

java.lang.String getUserEmail(java.lang.String crfqNumber)
                              throws java.lang.Exception
Throws:
java.lang.Exception

addSalesOrder

SalesOrderVO addSalesOrder(SalesOrderVO vo)
                           throws java.lang.Exception
Throws:
java.lang.Exception

copyQuoteToSalesOrder

java.lang.String copyQuoteToSalesOrder(java.lang.String qtNumber,
                                       boolean needClosed)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

copySalesOrderFromSalesOrder

java.lang.String copySalesOrderFromSalesOrder(SO2SOAgent agent)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

createSalesOrderByExchange

SalesOrderVO createSalesOrderByExchange(PO2SOExchange exchange)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

updateSalesOrder

java.lang.String updateSalesOrder(SalesOrderVO vo)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

cancelSalesOrder

java.lang.String cancelSalesOrder(java.lang.String soNumber)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

isSalesOrderExist

boolean isSalesOrderExist(java.lang.String soNumber)
                          throws java.lang.Exception
Throws:
java.lang.Exception

isQuoteExist

boolean isQuoteExist(java.lang.String quoteNumber)
                     throws java.lang.Exception
Throws:
java.lang.Exception

initSalesOrderItem

SalesOrderItemVO initSalesOrderItem(SalesOrderVO soVo,
                                    PartPK partPk,
                                    java.math.BigDecimal quantity,
                                    boolean isTool)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

initSalesOrderItem

SalesOrderItemVO initSalesOrderItem(SalesOrderVO soVo,
                                    PartPK partPk,
                                    java.math.BigDecimal quantity,
                                    boolean isTool,
                                    boolean isPOS)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

reviewSalesOrder

SalesOrderVO reviewSalesOrder(SalesOrderVO soVo)
                              throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOrderById

SalesOrderVO getSalesOrderById(java.lang.String soNumber)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOrderByIdForPrintSOLabel

SalesOrderVO getSalesOrderByIdForPrintSOLabel(java.lang.String soNumber)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOrderWithOrderApplyByWo

SalesOrderVO getSalesOrderWithOrderApplyByWo(java.lang.Long orderApplyID)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOrderArPrepayPaid

java.math.BigDecimal getSalesOrderArPrepayPaid(java.lang.String soNumber)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOrderArPrepayApply

java.math.BigDecimal getSalesOrderArPrepayApply(java.lang.String soNumber)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

findSalesOrderArPrepays

java.util.Collection<java.util.Map> findSalesOrderArPrepays(java.lang.String[] soNumbers)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

findAllSalesOrders

java.util.Collection<SalesOrderListResult> findAllSalesOrders(int firstIndex,
                                                              int maxLength)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

findCheckList

java.util.Collection<SalesOrderCheckListResult> findCheckList(int firstIndex,
                                                              int maxLength)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getAllSalesOrderCount

int getAllSalesOrderCount()
                          throws java.lang.Exception
Throws:
java.lang.Exception

getSoCountPerMonth

int[] getSoCountPerMonth(int year)
                         throws java.lang.Exception
Throws:
java.lang.Exception

getCheckListCount

int getCheckListCount()
                      throws java.lang.Exception
Throws:
java.lang.Exception

setSalesOrderItemReferenceDocOne

void setSalesOrderItemReferenceDocOne(SalesOrderItemPK pk,
                                      java.lang.String referenceDoc)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

setSalesOrderItemReferenceDocTwo

void setSalesOrderItemReferenceDocTwo(SalesOrderItemPK pk,
                                      java.lang.String referenceDoc)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

clearSalesOrderItemReferenceDocOne

void clearSalesOrderItemReferenceDocOne(java.lang.String referenceDoc)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

clearSalesOrderItemReferenceDocTwo

void clearSalesOrderItemReferenceDocTwo(java.lang.String referenceDoc)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

isSalesOrderItemExist

boolean isSalesOrderItemExist(SalesOrderItemPK pk)
                              throws java.lang.Exception
Throws:
java.lang.Exception

isSalesOrderAndSoItemOpen

boolean isSalesOrderAndSoItemOpen(SalesOrderItemPK pk)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findSalesOrderItemByPartPk

java.util.Collection<SalesOrderItemListResult> findSalesOrderItemByPartPk(PartPK pk,
                                                                          int firstIndex,
                                                                          int maxLength)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOrderItemByPk

SalesOrderItemVO getSalesOrderItemByPk(SalesOrderItemPK pk)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOrderItemByPartPkCount

int getSalesOrderItemByPartPkCount(PartPK pk)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findOpenSaleOrderItemByPartPk

java.util.Collection<SalesOrderItemListResult> findOpenSaleOrderItemByPartPk(PartPK partPk,
                                                                             int firstIndex,
                                                                             int maxLength)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getOpenSaleOrderItemByPartPkCount

int getOpenSaleOrderItemByPartPkCount(PartPK partPk)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findSalesOrderItemsBySalesman

java.util.Collection<SalesOrderItemListResult> findSalesOrderItemsBySalesman(java.lang.String salesmanLike,
                                                                             int firstIndex,
                                                                             int maxLength)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOrderItemsCountBySalesman

int getSalesOrderItemsCountBySalesman(java.lang.String salesmanLike)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findOpenNotReviewedSalesOrders

java.util.Collection<SalesOrderListResult> findOpenNotReviewedSalesOrders(java.lang.String soNumberLike,
                                                                          int firstIndex,
                                                                          int maxLength)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getOpenNotReviewedSalesOrdersCount

int getOpenNotReviewedSalesOrdersCount(java.lang.String soNumberLike)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findSalesOrdersBySoNumber

java.util.Collection<SalesOrderListResult> findSalesOrdersBySoNumber(java.lang.String soNumberExp,
                                                                     int firstIndex,
                                                                     int maxLength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOrdersBySoNumberCount

int getSalesOrdersBySoNumberCount(java.lang.String soNumberExp)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findOpenSalesOrdersForShippingBySoNumber

java.util.Collection<SalesOrderListResult> findOpenSalesOrdersForShippingBySoNumber(java.lang.String soIdExp,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOpenSalesOrdersForShippingCountBySoNumber

int getOpenSalesOrdersForShippingCountBySoNumber(java.lang.String soIdExp)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findSalesOrdersByPoNumber

java.util.Collection<SalesOrderListResult> findSalesOrdersByPoNumber(java.lang.String poNumberExp,
                                                                     int firstIndex,
                                                                     int maxLength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOrdersByPoNumberCount

int getSalesOrdersByPoNumberCount(java.lang.String poNumberExp)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findSalesOrdersBySalesman

java.util.Collection<SalesOrderListResult> findSalesOrdersBySalesman(java.lang.String salesmanExp,
                                                                     int firstIndex,
                                                                     int maxLength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOrdersCountBySalesman

int getSalesOrdersCountBySalesman(java.lang.String salesmanExp)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findOpenSalesOrderWithPrepay

java.util.Collection<SalesOrderListResult> findOpenSalesOrderWithPrepay(java.lang.String startWith,
                                                                        int firstIndex,
                                                                        int maxLength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getOpenSalesOrderWithPrepayCount

int getOpenSalesOrderWithPrepayCount(java.lang.String startWith)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findSoTotalByDateResults

java.util.Collection<TotalByDateResult> findSoTotalByDateResults(java.lang.String partNumberLike,
                                                                 java.lang.String partType,
                                                                 java.lang.String customerIdLike,
                                                                 java.lang.String includeCustomerIds,
                                                                 java.lang.String excludeCustomerIds,
                                                                 java.lang.String salesMan,
                                                                 java.lang.String status,
                                                                 java.lang.String productCode,
                                                                 java.lang.String commodityCode,
                                                                 java.lang.String projectName,
                                                                 java.lang.String dateColumn,
                                                                 java.util.Date fromDate,
                                                                 java.util.Date toDate,
                                                                 java.lang.String currency,
                                                                 java.lang.String salesCodeId,
                                                                 java.lang.String accountNumber,
                                                                 java.lang.String companyUnitId,
                                                                 boolean isHold,
                                                                 java.lang.String state,
                                                                 java.lang.String incotermPort)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findSalesOrderItemsByDate

java.util.Collection<SalesOrderItemListResult> findSalesOrderItemsByDate(java.lang.String partNumberLike,
                                                                         java.lang.String partType,
                                                                         java.lang.String customerId,
                                                                         java.lang.String includeCustomerIds,
                                                                         java.lang.String excludeCustomerIds,
                                                                         java.lang.String salesMan,
                                                                         java.lang.String status,
                                                                         java.lang.String productCode,
                                                                         java.lang.String commodityCode,
                                                                         java.lang.String projectName,
                                                                         java.lang.String dateColumn,
                                                                         java.util.Date fromDate,
                                                                         java.util.Date toDate,
                                                                         java.lang.String currency,
                                                                         java.lang.String salesCodeId,
                                                                         java.lang.String accountNumber,
                                                                         java.lang.String companyUnitId,
                                                                         boolean isHold,
                                                                         java.lang.String state,
                                                                         java.lang.String incotermPort,
                                                                         int firstIndex,
                                                                         int maxLength)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOrderItemsCountByDate

int getSalesOrderItemsCountByDate(java.lang.String partNumberLike,
                                  java.lang.String partType,
                                  java.lang.String customerId,
                                  java.lang.String includeCustomerIds,
                                  java.lang.String excludeCustomerIds,
                                  java.lang.String salesMan,
                                  java.lang.String status,
                                  java.lang.String productCode,
                                  java.lang.String commodityCode,
                                  java.lang.String projectName,
                                  java.lang.String dateColumn,
                                  java.util.Date fromDate,
                                  java.util.Date toDate,
                                  java.lang.String currency,
                                  java.lang.String salesCodeId,
                                  java.lang.String accountNumber,
                                  java.lang.String companyUnitId,
                                  boolean isHold,
                                  java.lang.String state,
                                  java.lang.String incotermPort)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findAllSoItemsByAddressId

java.util.Collection<SalesOrderItemListResult> findAllSoItemsByAddressId(java.lang.String addressId,
                                                                         int firstIndex,
                                                                         int maxLength)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getAllSoItemsCountByAddressId

int getAllSoItemsCountByAddressId(java.lang.String addressId)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findAllOpenSoItemsByAddressId

java.util.Collection<SalesOrderItemListResult> findAllOpenSoItemsByAddressId(java.lang.String addressId,
                                                                             int firstIndex,
                                                                             int maxLength)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getAllOpenSoItemsCountByAddressId

int getAllOpenSoItemsCountByAddressId(java.lang.String addressId)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findAllOpenSoItemsByAddressIdandShipVia

java.util.Collection<SalesOrderItemListResult> findAllOpenSoItemsByAddressIdandShipVia(java.lang.String addressId,
                                                                                java.lang.String shipVia,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllOpenSoItemsCountByAddressIdandShipVia

int getAllOpenSoItemsCountByAddressIdandShipVia(java.lang.String addressId,
                                                java.lang.String shipVia)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

findAllPastDueSoItemsByAddressId

java.util.Collection<SalesOrderItemListResult> findAllPastDueSoItemsByAddressId(java.lang.String addressId,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllPastDueSoItemsCountByAddressId

int getAllPastDueSoItemsCountByAddressId(java.lang.String addressId)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

findAllSalesOrdersByAddressId

java.util.Collection<SalesOrderListResult> findAllSalesOrdersByAddressId(java.lang.String customerIdExp,
                                                                         int firstIndex,
                                                                         int maxLength)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getAllSalesOrdersCountByAddressId

int getAllSalesOrdersCountByAddressId(java.lang.String customerIdExp)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findOpenSalesOrdersByAddressId

java.util.Collection<SalesOrderListResult> findOpenSalesOrdersByAddressId(java.lang.String customerIdExp,
                                                                          int firstIndex,
                                                                          int maxLength)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getOpenSalesOrdersCountByAddressId

int getOpenSalesOrdersCountByAddressId(java.lang.String customerIdExp)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findDueSalesOrdersByAddressId

java.util.Collection<SalesOrderListResult> findDueSalesOrdersByAddressId(java.lang.String customerIdExp,
                                                                         int firstIndex,
                                                                         int maxLength)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getDueSalesOrdersCountByAddressId

int getDueSalesOrdersCountByAddressId(java.lang.String customerIdExp)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findAllOpenSoItems

java.util.Collection<SalesOrderItemListResult> findAllOpenSoItems(boolean orderByDeliveryDateAsc,
                                                                  int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getAllOpenSoItemsCount

int getAllOpenSoItemsCount()
                           throws java.lang.Exception
Throws:
java.lang.Exception

findAllSOItemsCanShip

java.util.Collection<SalesOrderItemListResult> findAllSOItemsCanShip(java.lang.String partFrom,
                                                                     java.util.Date fromDate,
                                                                     java.util.Date toDate,
                                                                     int firstIndex,
                                                                     int maxLength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getAllSOItemsCanShipCount

int getAllSOItemsCanShipCount(java.lang.String partFrom,
                              java.util.Date fromDate,
                              java.util.Date toDate)
                              throws java.lang.Exception
Throws:
java.lang.Exception

getTotalSOInSipDetail

java.util.Collection<BB2PartInSipOfSoItemResult> getTotalSOInSipDetail(BB2Part part)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getAllOpenSalesOrdersTotalMoneyValue

Money getAllOpenSalesOrdersTotalMoneyValue(java.lang.String customerId)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

getAllDueSalesOrdersTotalMoneyValue

Money getAllDueSalesOrdersTotalMoneyValue(java.lang.String customerId)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

getAllOpenSalesOrdersTotalMoneyValue

Money getAllOpenSalesOrdersTotalMoneyValue()
                                           throws java.lang.Exception
Throws:
java.lang.Exception

findAllDueSoItems

java.util.Collection<SalesOrderItemListResult> findAllDueSoItems(int firstIndex,
                                                                 int maxLength)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getAllDueSoItemsCount

int getAllDueSoItemsCount()
                          throws java.lang.Exception
Throws:
java.lang.Exception

findOpenShortageSalesOrderItems

java.util.Collection<SalesOrderItemListResult> findOpenShortageSalesOrderItems(java.lang.String partNumberLike,
                                                                               java.lang.String partType,
                                                                               java.lang.String salesOrderNumber,
                                                                               java.lang.String customerID,
                                                                               int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getOpenShortageSalesOrderItemsCount

int getOpenShortageSalesOrderItemsCount(java.lang.String partNumberLike,
                                        java.lang.String partType,
                                        java.lang.String salesOrderNumber,
                                        java.lang.String customerID)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findDueShortageSalesOrderItems

java.util.Collection<SalesOrderItemListResult> findDueShortageSalesOrderItems(java.lang.String partNumberLike,
                                                                              java.lang.String partType,
                                                                              java.lang.String salesOrderNumber,
                                                                              java.lang.String customerID,
                                                                              int firstIndex,
                                                                              int maxLength)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getDueShortageSalesOrderItemsCount

int getDueShortageSalesOrderItemsCount(java.lang.String partNumberLike,
                                       java.lang.String partType,
                                       java.lang.String salesOrderNumber,
                                       java.lang.String customerID)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findOpenShipViaSalesOrderItems

java.util.Collection<SalesOrderItemListResult> findOpenShipViaSalesOrderItems(java.lang.String partNumberLike,
                                                                              java.lang.String partType,
                                                                              java.lang.String salesOrderNumber,
                                                                              java.lang.String customerID,
                                                                              java.lang.String shipVia,
                                                                              int firstIndex,
                                                                              int maxLength)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getOpenShipViaSalesOrderItemsCount

int getOpenShipViaSalesOrderItemsCount(java.lang.String partNumberLike,
                                       java.lang.String partType,
                                       java.lang.String salesOrderNumber,
                                       java.lang.String customerID,
                                       java.lang.String shipVia)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

getAllDueSalesOrdersTotalMoneyValue

Money getAllDueSalesOrdersTotalMoneyValue()
                                          throws java.lang.Exception
Throws:
java.lang.Exception

findOpenSalesOrderItemCustomerTotalResultsByCustomerId

java.util.Collection<SalesOrderItemCustomerTotalResult> findOpenSalesOrderItemCustomerTotalResultsByCustomerId(java.lang.String customerIdLike,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOpenSalesOrderItemCustomerTotalResultsByCustomerId

int getOpenSalesOrderItemCustomerTotalResultsByCustomerId(java.lang.String customerIdLike)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

findDueSalesOrderItemCustomerTotalResultsByCustomerId

java.util.Collection<SalesOrderItemCustomerTotalResult> findDueSalesOrderItemCustomerTotalResultsByCustomerId(java.lang.String customerIdLike,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getDueSalesOrderItemCustomerTotalResultsByCustomerId

int getDueSalesOrderItemCustomerTotalResultsByCustomerId(java.lang.String customerIdLike)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

addContractPrice

java.lang.String addContractPrice(ContractPriceVO vo)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

updateContractPrice

java.lang.String updateContractPrice(ContractPriceVO vo)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

deleteContractPrice

void deleteContractPrice(ContractPriceVO cpVO)
                         throws java.lang.Exception
Throws:
java.lang.Exception

getContractPriceById

ContractPriceVO getContractPriceById(java.lang.String cpNumber)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

isContractPriceExistent

boolean isContractPriceExistent(java.lang.String contractNumber)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findAllContracts

java.util.Collection<ContractPriceVO> findAllContracts(int firstIndex,
                                                       int maxLength)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getAllContractsCount

int getAllContractsCount()
                         throws java.lang.Exception
Throws:
java.lang.Exception

findContractsByContractNumber

java.util.Collection<ContractPriceVO> findContractsByContractNumber(java.lang.String contractNumber,
                                                                    int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getContractsCountByContractNumber

int getContractsCountByContractNumber(java.lang.String contractNumber)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

addContractPriceCustomer

ContractPriceCustomerVO addContractPriceCustomer(ContractPriceCustomerVO vo)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

updateContractPriceCustomer

ContractPriceCustomerVO updateContractPriceCustomer(ContractPriceCustomerVO vo)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

deleteContractPriceCustomer

void deleteContractPriceCustomer(ContractPriceCustomerVO cpcVO)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

getContractPriceCustomer

ContractPriceCustomerVO getContractPriceCustomer(ContractPriceCustomerPK pk)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

isContractPriceCustomerExistent

boolean isContractPriceCustomerExistent(ContractPriceCustomerPK pk)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findContractCustomersByContractNumber

java.util.Collection<ContractPriceCustomerVO> findContractCustomersByContractNumber(java.lang.String contractNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getContractCustomersCountByContractNumber

int getContractCustomersCountByContractNumber(java.lang.String contractNumber)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

addContractPriceItem

ContractPriceItemVO addContractPriceItem(ContractPriceItemVO vo)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

addContractPriceItems

java.util.Collection<ContractPriceItemVO> addContractPriceItems(java.util.ArrayList list)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

updateContractPriceItem

ContractPriceItemVO updateContractPriceItem(ContractPriceItemVO vo)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

deleteContractPriceItem

void deleteContractPriceItem(ContractPriceItemVO cpiVO)
                             throws java.lang.Exception
Throws:
java.lang.Exception

getContractPriceItem

ContractPriceItemVO getContractPriceItem(ContractPriceItemPK pk)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

isContractPriceItemExistent

boolean isContractPriceItemExistent(ContractPriceItemPK pk)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findContractItemsByContractNumber

java.util.Collection<ContractPriceItemVO> findContractItemsByContractNumber(java.lang.String contractNumber,
                                                                            int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getContractItemsCountByContractNumber

int getContractItemsCountByContractNumber(java.lang.String contractNumber)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

findContractsByAddressId

java.util.Collection<ContractPriceCustomerVO> findContractsByAddressId(java.lang.String addressIdRegex,
                                                                       int firstIndex,
                                                                       int maxLength)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getContractsByAddressIdCount

int getContractsByAddressIdCount(java.lang.String addressIdRegex)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findContractItemFromQuoteItem

java.util.Collection<CPItemFromQuoteResult> findContractItemFromQuoteItem(java.lang.String contractNumber,
                                                                          java.lang.String quoteNumber)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

batchUpdateContractItemDiscount

void batchUpdateContractItemDiscount(java.lang.String contractNumber,
                                     java.math.BigDecimal discount)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findAllIncoterms

java.util.Collection<IncotermVO> findAllIncoterms(int firstIndex,
                                                  int maxLength)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

deleteIncoterm

void deleteIncoterm(IncotermVO vo)
                    throws java.lang.Exception
Throws:
java.lang.Exception

getAllIncotermsCount

int getAllIncotermsCount()
                         throws java.lang.Exception
Throws:
java.lang.Exception

updateIncoterm

IncotermVO updateIncoterm(IncotermVO vo)
                          throws java.lang.Exception
Throws:
java.lang.Exception

addIncoterm

IncotermVO addIncoterm(IncotermVO vo)
                       throws java.lang.Exception
Throws:
java.lang.Exception

getIncotermById

IncotermVO getIncotermById(java.lang.String id)
                           throws java.lang.Exception
Throws:
java.lang.Exception

addRma

java.lang.String addRma(java.lang.String invoiceNumber,
                        boolean includeItems)
                        throws java.lang.Exception
Throws:
java.lang.Exception

addRmaBySalesOrder

java.lang.String addRmaBySalesOrder(java.lang.String soNumber,
                                    boolean includeItems)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

addRmaByCustomerId

java.lang.String addRmaByCustomerId(java.lang.String customerId)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

updateRma

java.lang.String updateRma(ReturnMaterialAuthorizationVO vo)
                           throws java.lang.Exception
Throws:
java.lang.Exception

initRmaItem

ReturnMaterialAuthorizationItemVO initRmaItem(ReturnMaterialAuthorizationVO rmaVo,
                                              PartPK partPk,
                                              java.math.BigDecimal quantity,
                                              boolean isTool)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

initRmaItem

ReturnMaterialAuthorizationItemVO initRmaItem(ReturnMaterialAuthorizationVO rmaVo,
                                              PartPK partPk,
                                              java.math.BigDecimal quantity,
                                              boolean isTool,
                                              boolean isPOS)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

reviewRma

ReturnMaterialAuthorizationVO reviewRma(ReturnMaterialAuthorizationVO rmaVo)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findAllRmas

java.util.Collection<RMAListResult> findAllRmas(int firstIndex,
                                                int maxLength)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllRmasCount

int getAllRmasCount()
                    throws java.lang.Exception
Throws:
java.lang.Exception

findRmaCheckList

java.util.Collection<RMAListResult> findRmaCheckList(int firstIndex,
                                                     int maxLength)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getRmaCheckListCount

int getRmaCheckListCount()
                         throws java.lang.Exception
Throws:
java.lang.Exception

findRMAsByRmaNumber

java.util.Collection<RMAListResult> findRMAsByRmaNumber(java.lang.String rmaNumberExp,
                                                        int firstIndex,
                                                        int maxLength)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getRMAsCountByRmaNumber

int getRMAsCountByRmaNumber(java.lang.String rmaNumberExp)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findRMAsBySoNumber

java.util.Collection<RMAListResult> findRMAsBySoNumber(java.lang.String salesOrderNumberExp,
                                                       int firstIndex,
                                                       int maxLength)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getRMAsCountBySoNumber

int getRMAsCountBySoNumber(java.lang.String salesOrderNumberExp)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findRMAsByIvoiceNumber

java.util.Collection<RMAListResult> findRMAsByIvoiceNumber(java.lang.String invoiceNumber,
                                                           int firstIndex,
                                                           int maxLength)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getRMAsCountByInvoiceNumber

int getRMAsCountByInvoiceNumber(java.lang.String invoiceNumber)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findRmaItemByPartPk

java.util.Collection<RMAItemListResult> findRmaItemByPartPk(PartPK partPk,
                                                            int firstIndex,
                                                            int maxLength)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getRmaItemByPartPkCount

int getRmaItemByPartPkCount(PartPK partPk)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findRmaItemsByDate

java.util.Collection<RMAItemListResult> findRmaItemsByDate(PartPK partPk,
                                                           java.lang.String rmaNumber,
                                                           java.lang.String rmaItemNumber,
                                                           java.lang.String customerId,
                                                           java.lang.String salesMan,
                                                           java.lang.String ncrNumber,
                                                           java.lang.String status,
                                                           java.lang.String accountNumber,
                                                           java.lang.String companyUnitId,
                                                           boolean isRequireDate,
                                                           java.util.Date fromDate,
                                                           java.util.Date toDate,
                                                           int firstIndex,
                                                           int maxLength)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getRmaItemsCountByDate

int getRmaItemsCountByDate(PartPK partPk,
                           java.lang.String rmaNumber,
                           java.lang.String rmaItemNumber,
                           java.lang.String customerId,
                           java.lang.String salesMan,
                           java.lang.String ncrNumber,
                           java.lang.String status,
                           java.lang.String accountNumber,
                           java.lang.String companyUnitId,
                           boolean isRequireDate,
                           java.util.Date fromDate,
                           java.util.Date toDate)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findCancelledRmaItems

java.util.Collection<RMAItemListResult> findCancelledRmaItems(int firstIndex,
                                                              int maxLength)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getCancelledRmaItemsCount

int getCancelledRmaItemsCount()
                              throws java.lang.Exception
Throws:
java.lang.Exception

findAllOpenRma

java.util.Collection<RMAItemListResult> findAllOpenRma(int firstIndex,
                                                       int maxLength)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getAllOpenRmaCount

int getAllOpenRmaCount()
                       throws java.lang.Exception
Throws:
java.lang.Exception

findOpenRMAs

java.util.Collection<RMAListResult> findOpenRMAs(java.lang.String rmaNumberExp,
                                                 int firstIndex,
                                                 int maxLength)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getOpenRMAsCount

int getOpenRMAsCount(java.lang.String rmaNumberExp)
                     throws java.lang.Exception
Throws:
java.lang.Exception

findAllDueRma

java.util.Collection<RMAItemListResult> findAllDueRma(int firstIndex,
                                                      int maxLength)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getAllDueRmaCount

int getAllDueRmaCount()
                      throws java.lang.Exception
Throws:
java.lang.Exception

findRmaById

ReturnMaterialAuthorizationVO findRmaById(java.lang.String rmaNumber)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

findRmaItemByCustomerIdLike

java.util.Collection<RMAItemListResult> findRmaItemByCustomerIdLike(java.lang.String customerIdLike,
                                                                    int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getRmaItemCountByCustomerIdLike

int getRmaItemCountByCustomerIdLike(java.lang.String customerIdLike)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

getRmaReceiverBySoNumber

java.util.Collection<RMAReceiverItemListResult> getRmaReceiverBySoNumber(java.lang.String soNumber)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

addSalesman

SalesmanVO addSalesman(java.lang.String lastName)
                       throws java.lang.Exception
Throws:
java.lang.Exception

addSalesman

SalesmanVO addSalesman(SalesmanVO vo)
                       throws java.lang.Exception
Throws:
java.lang.Exception

updateSalesman

SalesmanVO updateSalesman(SalesmanVO vo)
                          throws java.lang.Exception
Throws:
java.lang.Exception

deleteSalesman

void deleteSalesman(SalesmanVO vo)
                    throws java.lang.Exception
Throws:
java.lang.Exception

findAllSalesmen

java.util.Collection<SalesmanVO> findAllSalesmen(int firstIndex,
                                                 int maxLength)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getAllSalesmanCount

int getAllSalesmanCount()
                        throws java.lang.Exception
Throws:
java.lang.Exception

getSalesmanByPk

SalesmanVO getSalesmanByPk(int id)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findSalesmanById

java.util.Collection<SalesmanVO> findSalesmanById(java.lang.String idRegex,
                                                  int firstIndex,
                                                  int maxLength)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getSalesmanCountById

int getSalesmanCountById(java.lang.String idRegex)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findSalesmanByLastName

java.util.Collection<SalesmanVO> findSalesmanByLastName(java.lang.String lastNameLike,
                                                        int firstIndex,
                                                        int maxLength)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getSalesmanCountByLastName

int getSalesmanCountByLastName(java.lang.String lastNameLike)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findSalesman

java.util.Map<java.lang.Integer,java.lang.String> findSalesman(java.lang.String idRegex,
                                                               java.lang.String lastNameLike,
                                                               int firstIndex,
                                                               int maxLength)
                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getSalesmanCount

int getSalesmanCount(java.lang.String idRegex,
                     java.lang.String lastNameLike)
                     throws java.lang.Exception
Throws:
java.lang.Exception

getCompanyUnitIDBySalesman

java.lang.String getCompanyUnitIDBySalesman(java.lang.String salesmanId)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

addSalesCodeByAddressId

SalesCodeVO addSalesCodeByAddressId(java.lang.String salesCodeId,
                                    java.lang.String addressId)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

addSalesCodeByEmployeeId

SalesCodeVO addSalesCodeByEmployeeId(java.lang.String salesCodeId,
                                     java.lang.String employeeId)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

updateSalesCode

SalesCodeVO updateSalesCode(SalesCodeVO vo)
                            throws java.lang.Exception
Throws:
java.lang.Exception

addSalesCodeCustomerByAddressIds

java.util.List addSalesCodeCustomerByAddressIds(java.util.List addressIds,
                                                java.lang.String salesCodeId)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

getSalesCodeCustomerByAddressIds

java.util.List getSalesCodeCustomerByAddressIds(java.util.List addressIds)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

deleteSalesCode

void deleteSalesCode(java.lang.String salesCodeId)
                     throws java.lang.Exception
Throws:
java.lang.Exception

findAllSalesCodeName

java.util.Collection<BB2DoubleString> findAllSalesCodeName(int firstIndex,
                                                           int maxLength)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getAllSalesCodeNameCount

int getAllSalesCodeNameCount()
                             throws java.lang.Exception
Throws:
java.lang.Exception

findAllSalesCode

java.util.Collection<SalesCodeVO> findAllSalesCode(int firstIndex,
                                                   int maxLength)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getAllSalesCodeCount

int getAllSalesCodeCount()
                         throws java.lang.Exception
Throws:
java.lang.Exception

findMonthSOByCustomer

java.util.Collection<MonthSoOrArByCustomerResult> findMonthSOByCustomer(java.util.Date fromMonth,
                                                                        java.util.Date toMonth,
                                                                        java.lang.String salesOrderStatus,
                                                                        java.lang.String customerId,
                                                                        int firstIndex,
                                                                        int maxLength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getMonthSOByCustomerCount

int getMonthSOByCustomerCount(java.util.Date fromMonth,
                              java.util.Date toMonth,
                              java.lang.String salesOrderStatus,
                              java.lang.String customerId)
                              throws java.lang.Exception
Throws:
java.lang.Exception

getMonthSOByCustomerSum

java.util.Map<java.lang.String,java.math.BigDecimal> getMonthSOByCustomerSum(java.util.Date fromMonth,
                                                                             java.util.Date toMonth,
                                                                             java.lang.String salesOrderStatus,
                                                                             java.lang.String customerId)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getSalesCodeByAddressId

java.util.Collection<SalesCodeVO> getSalesCodeByAddressId(java.lang.String addressId)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getSalesCodeByPk

SalesCodeVO getSalesCodeByPk(java.lang.String salesCodeId)
                             throws java.lang.Exception
Throws:
java.lang.Exception

findSalesCodeById

java.util.Collection<SalesCodeVO> findSalesCodeById(java.lang.String salesCodeId,
                                                    java.lang.String salesCodeName,
                                                    java.lang.String addressId,
                                                    java.lang.String employeeId,
                                                    java.math.BigDecimal commissionRate,
                                                    int firstIndex,
                                                    int maxLength)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getSalesCodeCountById

int getSalesCodeCountById(java.lang.String salesCodeId,
                          java.lang.String salesCodeName,
                          java.lang.String addressId,
                          java.lang.String employeeId,
                          java.math.BigDecimal commissionRate)
                          throws java.lang.Exception
Throws:
java.lang.Exception

uploadOrUpdateFTPSODoc

java.util.Collection<SalesOrderDocumentVO> uploadOrUpdateFTPSODoc(MiscDocAgent agent)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

downloadFTPSODoc

byte[] downloadFTPSODoc(MiscDocAgent agent)
                        throws java.lang.Exception
Throws:
java.lang.Exception

getSaleOrderDocumentByID

SalesOrderDocumentVO getSaleOrderDocumentByID(java.lang.Long controlNumber)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

deleteFTPSODoc

java.util.Collection<SalesOrderDocumentVO> deleteFTPSODoc(MiscDocAgent agent)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

addSalesOrderControl

SalesOrderReviewVO addSalesOrderControl(java.lang.String employeeId)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

updateSalesOrderControl

SalesOrderReviewVO updateSalesOrderControl(SalesOrderReviewVO vo)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

deleteSalesOrderControl

void deleteSalesOrderControl(java.lang.String employeeId)
                             throws java.lang.Exception
Throws:
java.lang.Exception

findAllSalesOrderControl

java.util.Collection<SalesOrderReviewVO> findAllSalesOrderControl(int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getAllSalesOrderControlCount

int getAllSalesOrderControlCount()
                                 throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOrderControlByEmployeeId

SalesOrderReviewVO getSalesOrderControlByEmployeeId(java.lang.String employeeId)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOrderControlByEmoloyeeTrueName

SalesOrderReviewVO getSalesOrderControlByEmoloyeeTrueName(java.lang.String emoloyeeTrueName)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

findSalesOrderControlByUserTrueNameLike

java.util.Collection<SalesOrderReviewVO> findSalesOrderControlByUserTrueNameLike(java.lang.String userTrueNameLike,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOrderControlCountByUserTrueNameLike

int getSalesOrderControlCountByUserTrueNameLike(java.lang.String userTrueNameLike)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

isSalesOrderControlRecorded

boolean isSalesOrderControlRecorded(java.lang.String employeeId)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

getSalesBomResult

SalesBomResult getSalesBomResult(BillPK billPk,
                                 java.lang.String partFrom)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

getSalesPartListResult

SalesPartListResult getSalesPartListResult(BillPK billPk,
                                           java.lang.String partFrom)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

getSOShipperItemListResultsOfSalesOrder

java.util.Collection<SOShipperItemListResult> getSOShipperItemListResultsOfSalesOrder(java.lang.String soNumber)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

addSalesOrderBP

SalesOrderBoilerplateVO addSalesOrderBP(SalesOrderBoilerplateVO vo)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

updateSalesOrderBP

SalesOrderBoilerplateVO updateSalesOrderBP(SalesOrderBoilerplateVO vo)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

deleteSalesOrderBP

void deleteSalesOrderBP(java.lang.String bpID)
                        throws java.lang.Exception
Throws:
java.lang.Exception

getAllSalesOrderBPCount

int getAllSalesOrderBPCount()
                            throws java.lang.Exception
Throws:
java.lang.Exception

findAllSalesOrderBP

java.util.Collection<SalesOrderBoilerplateVO> findAllSalesOrderBP(int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOrderBPCountByBPId

int getSalesOrderBPCountByBPId(java.lang.String boilerplateId)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findSalesOrderBPByBPId

java.util.Collection<SalesOrderBoilerplateVO> findSalesOrderBPByBPId(java.lang.String boilerplateId,
                                                                     int firstIndex,
                                                                     int maxLength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOrderBPByPk

SalesOrderBoilerplateVO getSalesOrderBPByPk(java.lang.String salesOrderBoilerplateId)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

isSalesOrderBoilerplateExist

boolean isSalesOrderBoilerplateExist(java.lang.String salesOrderBoilerplateId)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

addQuoteBP

QuoteBoilerplateVO addQuoteBP(QuoteBoilerplateVO vo)
                              throws java.lang.Exception
Throws:
java.lang.Exception

updateQuoteBP

QuoteBoilerplateVO updateQuoteBP(QuoteBoilerplateVO vo)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

deleteQuoteBP

void deleteQuoteBP(java.lang.String bpID)
                   throws java.lang.Exception
Throws:
java.lang.Exception

getAllQuoteBPCount

int getAllQuoteBPCount()
                       throws java.lang.Exception
Throws:
java.lang.Exception

findAllQuoteBP

java.util.Collection<QuoteBoilerplateVO> findAllQuoteBP(int firstIndex,
                                                        int maxLength)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getQuoteBPCountByBPId

int getQuoteBPCountByBPId(java.lang.String bpId)
                          throws java.lang.Exception
Throws:
java.lang.Exception

findQuoteBPByBPId

java.util.Collection<QuoteBoilerplateVO> findQuoteBPByBPId(java.lang.String bpId,
                                                           int firstIndex,
                                                           int maxLength)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getQuoteBPByPk

QuoteBoilerplateVO getQuoteBPByPk(java.lang.String quoteBoilerplateId)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

isQuoteBoilerplateExist

boolean isQuoteBoilerplateExist(java.lang.String quoteBoilerplateId)
                                throws java.lang.Exception
Throws:
java.lang.Exception

copyWorkOrderFromSalesOrder

WorkOrderVO copyWorkOrderFromSalesOrder(SO2WOAgent agent)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

copyPurchaseOrderFromSalesOrder

PurchaseOrderVO copyPurchaseOrderFromSalesOrder(SO2POAgent agent)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

addRefdocOne

RefdocVO addRefdocOne(SalesOrderItemPK soItemPk,
                      java.lang.String forderNumber,
                      java.lang.String fItemNumber,
                      java.math.BigDecimal refdocQty)
                      throws java.lang.Exception
Throws:
java.lang.Exception

updateRefdocOne

RefdocVO updateRefdocOne(RefdocVO vo)
                         throws java.lang.Exception
Throws:
java.lang.Exception

deleteRefdocOne

void deleteRefdocOne(BB2RefdocPK pk)
                     throws java.lang.Exception
Throws:
java.lang.Exception

findSalesOrderItemsCost

java.util.Collection<SalesOrderItemListResult> findSalesOrderItemsCost(java.lang.String status,
                                                                       int firstIndex,
                                                                       int maxLenggh)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOrderItemsCost

int getSalesOrderItemsCost(java.lang.String status)
                           throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOrderItemCostResult

SalesOrderItemCostResult getSalesOrderItemCostResult(java.lang.String status)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

isSalesOrderInMyPrintList

boolean isSalesOrderInMyPrintList(java.lang.String salesOrderNumber)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

deleteMyPrintList

void deleteMyPrintList(java.util.ArrayList soNumberList)
                       throws java.lang.Exception
Throws:
java.lang.Exception

addMyPrintList

MyPrintListVO addMyPrintList(java.lang.String soNumber)
                             throws java.lang.Exception
Throws:
java.lang.Exception

clearMySalesOrderPrintList

boolean clearMySalesOrderPrintList(java.lang.String salesOrderNumberLike)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findMySoPrintList

java.util.Collection<SalesOrderListResult> findMySoPrintList()
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

findAllPartTraceableBySN

java.util.Collection<PartTraceableInfoResult> findAllPartTraceableBySN(java.lang.String soNumber)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getPartDiscountVOByPk

PartDiscountVO getPartDiscountVOByPk(PartDiscountPK pk)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findAllPartDiscount

java.util.Collection<PartDiscountVO> findAllPartDiscount(int firstIndex,
                                                         int maxLength)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getAllPartdiscount

int getAllPartdiscount()
                       throws java.lang.Exception
Throws:
java.lang.Exception

addPartDiscount

PartDiscountVO addPartDiscount(PartDiscountVO vo)
                               throws java.lang.Exception
Throws:
java.lang.Exception

deletePartDiscount

void deletePartDiscount(PartDiscountVO vo)
                        throws java.lang.Exception
Throws:
java.lang.Exception

updatePartDiscount

void updatePartDiscount(PartDiscountVO vo)
                        throws java.lang.Exception
Throws:
java.lang.Exception

addRMAReview

java.lang.String addRMAReview(java.lang.String employeeID)
                              throws java.lang.Exception
Throws:
java.lang.Exception

updateRMAReview

java.lang.String updateRMAReview(RMAReviewVO vo)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

deleteRMAReview

void deleteRMAReview(java.lang.String employeeID)
                     throws java.lang.Exception
Throws:
java.lang.Exception

getRMAReview

RMAReviewVO getRMAReview(java.lang.String employeeID)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findAllRMAReviews

java.util.Collection<RMAReviewVO> findAllRMAReviews(int firstIndex,
                                                    int maxLength)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getAllRMAReviewsCount

int getAllRMAReviewsCount()
                          throws java.lang.Exception
Throws:
java.lang.Exception

getWeightInfo

java.util.HashMap<BB2Part,BB2WeightInfoResult> getWeightInfo(java.util.HashSet<BB2Part> pks)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

addCatalog

java.lang.String addCatalog(CatalogVO vo)
                            throws java.lang.Exception
Throws:
java.lang.Exception

updateCatalog

java.lang.String updateCatalog(CatalogVO vo)
                               throws java.lang.Exception
Throws:
java.lang.Exception

deleteCatalog

void deleteCatalog(java.lang.String catalogID)
                   throws java.lang.Exception
Throws:
java.lang.Exception

getCatalog

CatalogVO getCatalog(java.lang.String catalogID)
                     throws java.lang.Exception
Throws:
java.lang.Exception

getAllCatalogsId

java.util.Collection<BB2DoubleString> getAllCatalogsId()
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

findCatalogs

java.util.Collection<CatalogVO> findCatalogs(java.lang.String catalogID,
                                             java.lang.String description,
                                             int firstIndex,
                                             int maxLength)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

getCatalogsCount

int getCatalogsCount(java.lang.String catalogID,
                     java.lang.String description)
                     throws java.lang.Exception
Throws:
java.lang.Exception

getPartCatalogAuditResults

java.util.Collection<PartCatalogAuditResult> getPartCatalogAuditResults(java.lang.String pnLike)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

addPartCatalog

void addPartCatalog(java.lang.String catalogID,
                    java.util.HashSet<PartCatalogPK> items)
                    throws java.lang.Exception
Throws:
java.lang.Exception

updatePartCatalog

void updatePartCatalog(PartCatalogVO vo)
                       throws java.lang.Exception
Throws:
java.lang.Exception

updatePartCatalog

void updatePartCatalog(java.util.ArrayList<PartCatalogVO> volist)
                       throws java.lang.Exception
Throws:
java.lang.Exception

deletePartCatalog

void deletePartCatalog(PartCatalogPK pk)
                       throws java.lang.Exception
Throws:
java.lang.Exception

deletePartCatalog

void deletePartCatalog(java.util.ArrayList<PartCatalogPK> pks)
                       throws java.lang.Exception
Throws:
java.lang.Exception

getPartCatalogs

java.util.Collection<PartCatalogVO> getPartCatalogs(java.lang.String catalogID)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

addSGCustomerCatalog

void addSGCustomerCatalog(java.lang.String cusID,
                          PartCatalogPK pk)
                          throws java.lang.Exception
Throws:
java.lang.Exception

addSGCustomerCatalog

void addSGCustomerCatalog(java.lang.String cusID,
                          java.util.ArrayList<PartCatalogPK> pks,
                          boolean checkCatalog)
                          throws java.lang.Exception
Throws:
java.lang.Exception

updateSGCustomerCatalog

void updateSGCustomerCatalog(SGCustomerCatalogVO vo)
                             throws java.lang.Exception
Throws:
java.lang.Exception

updateSGCustomerCatalog

void updateSGCustomerCatalog(java.util.ArrayList<SGCustomerCatalogVO> vos)
                             throws java.lang.Exception
Throws:
java.lang.Exception

deleteSGCustomerCatalog

void deleteSGCustomerCatalog(java.util.ArrayList<SGCustomerCatalogPK> pks)
                             throws java.lang.Exception
Throws:
java.lang.Exception

deleteSGCustomerCatalog

void deleteSGCustomerCatalog(SGCustomerCatalogPK pk)
                             throws java.lang.Exception
Throws:
java.lang.Exception

getSGCustomerCatalog

SGCustomerCatalogVO getSGCustomerCatalog(SGCustomerCatalogPK pk)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

getSGCustomerCatalogByPN

java.util.Collection<SGPartCatalogResult> getSGCustomerCatalogByPN(java.lang.String customerID,
                                                                   java.lang.String pnLike)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

findSGPartCatalogResults

java.util.Collection<SGPartCatalogResult> findSGPartCatalogResults(java.lang.String catalog,
                                                                   java.lang.String pnLike,
                                                                   int firstIndex,
                                                                   int maxLength)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getSGPartCatalogResultsCount

int getSGPartCatalogResultsCount(java.lang.String catalog,
                                 java.lang.String pnLike)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findAvailablePartsToSalesCatalog

java.util.Collection<PartBasicInfo> findAvailablePartsToSalesCatalog(java.lang.String pnRegex,
                                                                     java.lang.String pn2Regex,
                                                                     java.lang.String commodityCodeLike,
                                                                     java.lang.String descLike,
                                                                     java.lang.String productCode,
                                                                     int firstIndex,
                                                                     int maxLength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getAvailablePartsToSalesCatalogCount

int getAvailablePartsToSalesCatalogCount(java.lang.String pnRegex,
                                         java.lang.String pn2Regex,
                                         java.lang.String commodityCodeLike,
                                         java.lang.String descLike,
                                         java.lang.String productCode)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

findAvailablePartsForCGCustomer

java.util.Collection<PartBasicInfo> findAvailablePartsForCGCustomer(java.lang.String customerID,
                                                                    java.lang.String partFrom,
                                                                    java.lang.String partTo,
                                                                    java.lang.String commodityCode,
                                                                    java.lang.String descLike,
                                                                    java.lang.String productCode,
                                                                    boolean ignoreCatalog,
                                                                    int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getAvailablePartsForCGCustomerCount

int getAvailablePartsForCGCustomerCount(java.lang.String customerID,
                                        java.lang.String partFrom,
                                        java.lang.String partTo,
                                        java.lang.String commodityCodeLike,
                                        java.lang.String descLike,
                                        java.lang.String productCode,
                                        boolean ignoreCatalog)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

getSGPartCatalogCountByCustomerID

int getSGPartCatalogCountByCustomerID(java.lang.String customerID)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findSGPartCatalogResultsforCustomerID

java.util.Collection<SGPartCatalogResult> findSGPartCatalogResultsforCustomerID(java.lang.String customerID,
                                                                                java.lang.String catalog,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getSGPartCatalogResultsforCustomerIDCount

int getSGPartCatalogResultsforCustomerIDCount(java.lang.String customerID,
                                              java.lang.String catalog)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

findSGPartCatalogResultsforCustomerIDByPart

java.util.Collection<SGPartCatalogResult> findSGPartCatalogResultsforCustomerIDByPart(java.lang.String catalogID,
                                                                                java.lang.String partNum,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getSGPartCatalogResultsforCustomerIDByPartCount

int getSGPartCatalogResultsforCustomerIDByPartCount(java.lang.String catalogID,
                                                    java.lang.String partNum)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getSGPartCatalogResults

java.util.Collection<SGPartCatalogResult> getSGPartCatalogResults(java.lang.String catalogID)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getSGPartCatalogResultsforCustomerID

java.util.Collection<SGPartCatalogResult> getSGPartCatalogResultsforCustomerID(java.lang.String customerID,
                                                                               java.lang.String catalogID)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getSGPartCatalogResultsforCustomerID

java.util.Collection<SGPartCatalogResult> getSGPartCatalogResultsforCustomerID(java.lang.String customerID,
                                                                               int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getSGPartCatalogResultsNotforCustomerID

java.util.Collection<SGPartCatalogResult> getSGPartCatalogResultsNotforCustomerID(java.lang.String customerID,
                                                                                java.lang.String catalogID)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

addSGSaleItem

SGSaleItemVO addSGSaleItem(SGSaleItemAgent agent)
                           throws java.lang.Exception
Throws:
java.lang.Exception

updateSGSaleItem

SGSaleItemVO updateSGSaleItem(SGSaleItemVO vo)
                              throws java.lang.Exception
Throws:
java.lang.Exception

deleteSGSaleItem

void deleteSGSaleItem(int ii)
                      throws java.lang.Exception
Throws:
java.lang.Exception

getSGSaleItem

SGSaleItemVO getSGSaleItem(int ii)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findSGSaleItems

java.util.Collection<SGSaleItemVO> findSGSaleItems(java.lang.String custID,
                                                   java.lang.String soNumber,
                                                   java.lang.String poNumber,
                                                   java.lang.String pnNumber,
                                                   java.lang.String paType,
                                                   java.lang.String serial,
                                                   int firstIndex,
                                                   int maxLength)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getSGSaleItemsCount

int getSGSaleItemsCount(java.lang.String custID,
                        java.lang.String soNumber,
                        java.lang.String poNumber,
                        java.lang.String pnNumber,
                        java.lang.String paType,
                        java.lang.String serial)
                        throws java.lang.Exception
Throws:
java.lang.Exception

getSpareSaleableParts

java.util.Collection<PartBasicInfo> getSpareSaleableParts(java.lang.String pnLike,
                                                          java.lang.String description)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getSGCustomerServiceRequest

SGCustomerServiceRequestVO getSGCustomerServiceRequest(java.lang.String csrNumber)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

updateSGCustomerServiceRequest

java.lang.String updateSGCustomerServiceRequest(SGCustomerServiceRequestVO vo)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

findSGCustomerServiceRequestsByDate

java.util.Collection<SGCustomerServiceRequestVO> findSGCustomerServiceRequestsByDate(java.lang.String csrNumber,
                                                                                java.lang.String custID,
                                                                                java.lang.String pnLike,
                                                                                java.lang.String soLike,
                                                                                java.lang.String serial,
                                                                                java.lang.String status,
                                                                                java.lang.String csiNum,
                                                                                java.util.Date fDate,
                                                                                java.util.Date tDate,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getSGCustomerServiceRequestsCountByDate

int getSGCustomerServiceRequestsCountByDate(java.lang.String csrNumber,
                                            java.lang.String custID,
                                            java.lang.String pnLike,
                                            java.lang.String soLike,
                                            java.lang.String serial,
                                            java.lang.String status,
                                            java.lang.String csiNum,
                                            java.util.Date fDate,
                                            java.util.Date tDate)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

findOpenSGCustomerServiceRequests

java.util.Collection<SGCustomerServiceRequestVO> findOpenSGCustomerServiceRequests(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOpenSGCustomerServiceRequestsCount

int getOpenSGCustomerServiceRequestsCount()
                                          throws java.lang.Exception
Throws:
java.lang.Exception

findPendingSGCustomerServiceRequests

java.util.Collection<SGCustomerServiceRequestVO> findPendingSGCustomerServiceRequests(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPendingSGCustomerServiceRequestsCount

int getPendingSGCustomerServiceRequestsCount()
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findSalesOrderItemGroupByPart

java.util.Collection<SalesOrderItemGroupByPartListResult> findSalesOrderItemGroupByPart(java.util.Date fromDate,
                                                                                java.util.Date toDate,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findSalesOrderItemGroupByPart

java.util.Collection<SalesOrderItemGroupByPartListResult> findSalesOrderItemGroupByPart(java.lang.String partNumber,
                                                                                java.lang.String partType,
                                                                                java.lang.String status,
                                                                                java.lang.String dateTpey,
                                                                                java.util.Date fromDate,
                                                                                java.util.Date toDate,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOrderItemGroupByPartCount

int getSalesOrderItemGroupByPartCount(java.lang.String partNumber,
                                      java.lang.String partType,
                                      java.lang.String status,
                                      java.lang.String dateType,
                                      java.util.Date fromDate,
                                      java.util.Date toDate)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOrderItemGroupByPartCount

int getSalesOrderItemGroupByPartCount(java.util.Date fromDate,
                                      java.util.Date toDate)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

getCustomerOnTimeDeliveryRateCountByCustomerId

int getCustomerOnTimeDeliveryRateCountByCustomerId(java.lang.String customerId,
                                                   java.util.Date from,
                                                   java.util.Date to,
                                                   java.lang.String dateType,
                                                   int delayDays,
                                                   int beforeDays,
                                                   java.lang.String salesman,
                                                   java.lang.String partNumber,
                                                   java.lang.String partType,
                                                   java.lang.String incoterm)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

findCustomerOnTimeDeliveryRateByCustomerId

java.util.Collection<OntimeDeliveryRateListResult> findCustomerOnTimeDeliveryRateByCustomerId(java.lang.String customerId,
                                                                                java.util.Date from,
                                                                                java.util.Date to,
                                                                                java.lang.String dateType,
                                                                                int delayDays,
                                                                                int beforeDays,
                                                                                java.lang.String salesman,
                                                                                java.lang.String partNumber,
                                                                                java.lang.String partType,
                                                                                java.lang.String incoterm,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getCustomerOnTimeDeliveryRate

OntimeDeliveryRateResult getCustomerOnTimeDeliveryRate(java.lang.String customerId,
                                                       java.util.Date from,
                                                       java.util.Date to,
                                                       java.lang.String dateType,
                                                       int delayDays,
                                                       int beforeDays,
                                                       java.lang.String salesman,
                                                       java.lang.String partNumber,
                                                       java.lang.String partType,
                                                       java.lang.String incoterm)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getLast12MonthOntimeDeliveryRate

java.util.Map<java.util.Date,OntimeDeliveryRateResult> getLast12MonthOntimeDeliveryRate(java.lang.String customerId,
                                                                                java.lang.String dateType,
                                                                                int overDueDays,
                                                                                int advanceDays,
                                                                                java.lang.String salesman,
                                                                                java.lang.String partNumber,
                                                                                java.lang.String partType,
                                                                                java.lang.String incoterm)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findSalesOrderItemsByCustomerId

java.util.Collection<SalesOrderItemListResult> findSalesOrderItemsByCustomerId(java.lang.String customerId,
                                                                               java.util.Date from,
                                                                               java.util.Date to,
                                                                               java.lang.String dateType,
                                                                               java.lang.String salesman,
                                                                               java.lang.String partNumber,
                                                                               java.lang.String partType,
                                                                               java.lang.String incoterm,
                                                                               int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOrderItemsByCustomerIdCount

int getSalesOrderItemsByCustomerIdCount(java.lang.String customerId,
                                        java.util.Date from,
                                        java.util.Date to,
                                        java.lang.String dateType,
                                        java.lang.String salesman,
                                        java.lang.String partNumber,
                                        java.lang.String partType,
                                        java.lang.String incoterm)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

getNext12MonthSoShipAmount

IncomeByMonthChartResult getNext12MonthSoShipAmount()
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

addProject

void addProject(ProjectVO vo)
                throws java.lang.Exception
Throws:
java.lang.Exception

updateProject

void updateProject(ProjectVO vo)
                   throws java.lang.Exception
Throws:
java.lang.Exception

getProjectByID

ProjectVO getProjectByID(java.lang.String id)
                         throws java.lang.Exception
Throws:
java.lang.Exception

deleteProject

void deleteProject(java.lang.String id)
                   throws java.lang.Exception
Throws:
java.lang.Exception

findProjectById

java.util.Collection<ProjectVO> findProjectById(java.lang.String id,
                                                int firstIndex,
                                                int maxLength)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

getProjectByIdCount

int getProjectByIdCount(java.lang.String id)
                        throws java.lang.Exception
Throws:
java.lang.Exception

findSalesOrderItemsByDates

java.util.Collection<SalesOrderItemListResult> findSalesOrderItemsByDates(java.lang.String partNumberLike,
                                                                          java.lang.String partType,
                                                                          java.lang.String customerId,
                                                                          java.lang.String includeCustomerIds,
                                                                          java.lang.String excludeCustomerIds,
                                                                          java.lang.String salesMan,
                                                                          java.lang.String status,
                                                                          java.lang.String productCode,
                                                                          java.lang.String projectName,
                                                                          java.lang.String relatedDoc,
                                                                          java.lang.String dateColumn,
                                                                          java.util.Date fromDate,
                                                                          java.util.Date toDate,
                                                                          java.lang.String currency,
                                                                          java.lang.String salesCodeID,
                                                                          java.lang.String accountNumber,
                                                                          java.lang.String companyUnitId,
                                                                          boolean isHold,
                                                                          java.lang.String state,
                                                                          java.lang.String incoterm,
                                                                          int firstIndex,
                                                                          int maxLength)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

findSalesOrderItemsByDates

java.util.Collection<SalesOrderItemListResult> findSalesOrderItemsByDates(java.lang.String partNumberLike,
                                                                          java.lang.String partType,
                                                                          java.lang.String customerId,
                                                                          java.lang.String includeCustomerIds,
                                                                          java.lang.String excludeCustomerIds,
                                                                          java.lang.String salesMan,
                                                                          java.lang.String status,
                                                                          java.lang.String productCode,
                                                                          java.lang.String projectName,
                                                                          java.lang.String relatedDoc,
                                                                          java.lang.String dateColumn,
                                                                          java.util.Date fromDate,
                                                                          java.util.Date toDate,
                                                                          java.lang.String currency,
                                                                          java.lang.String salesCodeID,
                                                                          java.lang.String accountNumber,
                                                                          java.lang.String companyUnitId,
                                                                          java.lang.String state,
                                                                          int firstIndex,
                                                                          int maxLength)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOrderItemsCountByDates

int getSalesOrderItemsCountByDates(java.lang.String partNumberLike,
                                   java.lang.String partType,
                                   java.lang.String customerId,
                                   java.lang.String includeCustomerIds,
                                   java.lang.String excludeCustomerIds,
                                   java.lang.String salesMan,
                                   java.lang.String status,
                                   java.lang.String productCode,
                                   java.lang.String projectName,
                                   java.lang.String relatedDoc,
                                   java.lang.String dateColumn,
                                   java.util.Date fromDate,
                                   java.util.Date toDate,
                                   java.lang.String currency,
                                   java.lang.String salesCodeId,
                                   java.lang.String accountNumber,
                                   java.lang.String companyUnitId,
                                   boolean isHold,
                                   java.lang.String state)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOrderItemsCountByDates

int getSalesOrderItemsCountByDates(java.lang.String partNumberLike,
                                   java.lang.String partType,
                                   java.lang.String customerId,
                                   java.lang.String includeCustomerIds,
                                   java.lang.String excludeCustomerIds,
                                   java.lang.String salesMan,
                                   java.lang.String status,
                                   java.lang.String productCode,
                                   java.lang.String projectName,
                                   java.lang.String relatedDoc,
                                   java.lang.String dateColumn,
                                   java.util.Date fromDate,
                                   java.util.Date toDate,
                                   java.lang.String currency,
                                   java.lang.String salesCodeId,
                                   java.lang.String accountNumber,
                                   java.lang.String companyUnitId,
                                   java.lang.String state)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findOpenRMAsByPartPk

java.util.Collection<RMAItemListResult> findOpenRMAsByPartPk(PartPK pk,
                                                             int firstIndex,
                                                             int maxLength)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

findRMAsByPartPk

java.util.Collection<RMAItemListResult> findRMAsByPartPk(PartPK pk,
                                                         int firstIndex,
                                                         int maxLength)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getOpenRMAsCountByPartPk

int getOpenRMAsCountByPartPk(PartPK pk)
                             throws java.lang.Exception
Throws:
java.lang.Exception

getRMAsCountByPartPk

int getRMAsCountByPartPk(PartPK pk)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findSalesOrderItemsWithoutInvoice

java.util.Collection<SalesOrderVO> findSalesOrderItemsWithoutInvoice(java.lang.String customerId,
                                                                     java.lang.String currency,
                                                                     java.util.Date from,
                                                                     java.util.Date to,
                                                                     int firstIndex,
                                                                     int maxLength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

deleteFTPRMADoc

java.util.Collection<ReturnMaterialAuthorizationDocumentVO> deleteFTPRMADoc(MiscDocAgent agent)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

uploadOrUpdateFTPRMADoc

java.util.Collection<ReturnMaterialAuthorizationDocumentVO> uploadOrUpdateFTPRMADoc(MiscDocAgent agent)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

downloadFTPRMADoc

byte[] downloadFTPRMADoc(MiscDocAgent agent)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findDueSoItemsByDateType

java.util.Collection<SalesOrderItemListResult> findDueSoItemsByDateType(java.lang.String dateType,
                                                                        java.util.Date fromDate,
                                                                        java.util.Date toDate,
                                                                        int firstIndex,
                                                                        int maxLength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getDueSoItemsCountByDateType

int getDueSoItemsCountByDateType(java.lang.String dateType,
                                 java.util.Date fromDate,
                                 java.util.Date toDate)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

getDueSalesOrdersTotalMoneyValueByDate

Money getDueSalesOrdersTotalMoneyValueByDate(java.lang.String dateType,
                                             java.util.Date fromDate,
                                             java.util.Date toDate)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

getQuoteItemVo

QuoteItemVO getQuoteItemVo(QuoteItemPK pk)
                           throws java.lang.Exception
Throws:
java.lang.Exception

getNewQuoteItemNumber

java.lang.String getNewQuoteItemNumber(java.lang.String qo)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

getNewSalesOrderItemNumber

java.lang.String getNewSalesOrderItemNumber(java.lang.String qo)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

getSGPartCatalogCountByCustomerIDAndMultiCondition

int getSGPartCatalogCountByCustomerIDAndMultiCondition(java.lang.String customerID,
                                                       java.lang.String catalogID)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

findSGPartCatalogResultsforCustomerIDAndMultiCondition

java.util.List findSGPartCatalogResultsforCustomerIDAndMultiCondition(java.lang.String customerID,
                                                                      java.lang.String catalogID,
                                                                      int firstIndex,
                                                                      int maxLength)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getSGPartCatalogConditionDescForCustomerID

java.lang.String getSGPartCatalogConditionDescForCustomerID(java.lang.String customerID)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

isRrmaExist

boolean isRrmaExist(java.lang.String rrmaNumber)
                    throws java.lang.Exception
Throws:
java.lang.Exception

isRrmaItemExist

boolean isRrmaItemExist(RequestForRMAItemPK pk)
                        throws java.lang.Exception
Throws:
java.lang.Exception

getRRMAById

RequestForRMAVO getRRMAById(java.lang.String rrmaNumber)
                            throws java.lang.Exception
Throws:
java.lang.Exception

getRRMAItemByPk

RequestForRMAItemVO getRRMAItemByPk(RequestForRMAItemPK pk)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

getRRMAListResultCount

int getRRMAListResultCount(java.lang.String rrmaNumberLike,
                           java.lang.String status,
                           java.lang.String project,
                           java.lang.String requester,
                           java.lang.String soNumber,
                           java.lang.String invNumber,
                           java.lang.String customerID)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findRRMAListResult

java.util.Collection<RRMAListResult> findRRMAListResult(java.lang.String rrmaNumberLike,
                                                        java.lang.String status,
                                                        java.lang.String project,
                                                        java.lang.String requester,
                                                        java.lang.String soNumber,
                                                        java.lang.String invNumber,
                                                        java.lang.String customerID,
                                                        int firstIndex,
                                                        int maxLength)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getRRMAItemListResultCount

int getRRMAItemListResultCount(PartPK partPk,
                               java.lang.String rrmaNumber,
                               java.lang.String rrmaItemNumber,
                               java.lang.String customerId,
                               java.lang.String salesMan,
                               java.lang.String status,
                               java.lang.String accountNumber,
                               java.lang.String companyUnitId,
                               boolean isRequireDate,
                               java.util.Date fromDate,
                               java.util.Date toDate)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findRRMAItemListResult

java.util.Collection<RRMAItemListResult> findRRMAItemListResult(PartPK partPk,
                                                                java.lang.String rrmaNumber,
                                                                java.lang.String rrmaItemNumber,
                                                                java.lang.String customerId,
                                                                java.lang.String salesMan,
                                                                java.lang.String status,
                                                                java.lang.String accountNumber,
                                                                java.lang.String companyUnitId,
                                                                boolean isRequireDate,
                                                                java.util.Date fromDate,
                                                                java.util.Date toDate,
                                                                boolean incluedInventory,
                                                                int firstIndex,
                                                                int maxLength)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

reviewRrma

RequestForRMAVO reviewRrma(RequestForRMAVO rrma)
                           throws java.lang.Exception
Throws:
java.lang.Exception

makeRMAFromRRMANumber

ReturnMaterialAuthorizationVO makeRMAFromRRMANumber(java.lang.String rrmaNumber)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getInitDefaultPricePerUnit

java.math.BigDecimal[] getInitDefaultPricePerUnit(BB2Part part,
                                                  java.lang.String soNumber)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

cancelQuote

java.lang.String cancelQuote(java.lang.String quoteNumber)
                             throws java.lang.Exception
Throws:
java.lang.Exception

cancelRMA

java.lang.String cancelRMA(java.lang.String rmaNumber)
                           throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesCodeVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesCodeVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SalesCodeVO
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
ArSalesCodeTotalListResult
public class SalesCodeVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ADDRESSID
static java.lang.String | ORDER_BY_ADDRESSNAME
static java.lang.String | ORDER_BY_COMMISSIONRATE
static java.lang.String | ORDER_BY_EMPLOYEEID
static java.lang.String | ORDER_BY_SALESCODEID
static java.lang.String | ORDER_BY_SALESCODENAME
Constructor Summary
SalesCodeVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAddressId()
java.lang.String | getAddressName()
java.lang.String | getComments()
java.math.BigDecimal | getCommissionRate()
java.lang.String | getEmployeeId()
java.util.Date | getLastChangeDate()
java.lang.Integer | getLastChangeTimes()
java.lang.String | getLastChangeUser()
java.lang.String | getSalesCodeId()
java.util.Set | getSalesCodeIds()
java.lang.String | getSalesCodeName()
int | hashCode()
boolean | isContainTax()
void | setAddressId(java.lang.String addressId)
void | setAddressName(java.lang.String addressName)
void | setComments(java.lang.String comments)
void | setCommissionRate(java.math.BigDecimal commissionRate)
void | setContainTax(boolean containTax)
void | setEmployeeId(java.lang.String employeeId)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTimes(java.lang.Integer lastChangeTimes)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setSalesCodeId(java.lang.String salesCodeId)
void | setSalesCodeIds(java.util.Set salesCodeIds)
void | setSalesCodeName(java.lang.String salesCodeName)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_SALESCODEID

public static final java.lang.String ORDER_BY_SALESCODEID
See Also:
Constant Field Values

ORDER_BY_SALESCODENAME

public static final java.lang.String ORDER_BY_SALESCODENAME
See Also:
Constant Field Values

ORDER_BY_ADDRESSID

public static final java.lang.String ORDER_BY_ADDRESSID
See Also:
Constant Field Values

ORDER_BY_ADDRESSNAME

public static final java.lang.String ORDER_BY_ADDRESSNAME
See Also:
Constant Field Values

ORDER_BY_EMPLOYEEID

public static final java.lang.String ORDER_BY_EMPLOYEEID
See Also:
Constant Field Values

ORDER_BY_COMMISSIONRATE

public static final java.lang.String ORDER_BY_COMMISSIONRATE
See Also:
Constant Field Values
Constructor Detail

SalesCodeVO

public SalesCodeVO()
Method Detail

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getLastChangeTimes

public java.lang.Integer getLastChangeTimes()

setLastChangeTimes

public void setLastChangeTimes(java.lang.Integer lastChangeTimes)

getAddressId

public java.lang.String getAddressId()

setAddressId

public void setAddressId(java.lang.String addressId)

getSalesCodeId

public java.lang.String getSalesCodeId()

setSalesCodeId

public void setSalesCodeId(java.lang.String salesCodeId)

getAddressName

public java.lang.String getAddressName()

setAddressName

public void setAddressName(java.lang.String addressName)

getSalesCodeName

public java.lang.String getSalesCodeName()

setSalesCodeName

public void setSalesCodeName(java.lang.String salesCodeName)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

isContainTax

public boolean isContainTax()

setContainTax

public void setContainTax(boolean containTax)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getCommissionRate

public java.math.BigDecimal getCommissionRate()

setCommissionRate

public void setCommissionRate(java.math.BigDecimal commissionRate)

getSalesCodeIds

public java.util.Set getSalesCodeIds()

setSalesCodeIds

public void setSalesCodeIds(java.util.Set salesCodeIds)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesInfoCenter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesInfoCenter

java.lang.Object
    extended by  bb.common.SalesInfoCenter
All Implemented Interfaces:
java.io.Serializable
public class SalesInfoCenter
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Nested Class Summary
static class | SalesInfoCenter.DueSoCount
static class | SalesInfoCenter.DueSoSum
static class | SalesInfoCenter.GrossMargin
static class | SalesInfoCenter.InvoicedSum
static class | SalesInfoCenter.OpenSoSum
static class | SalesInfoCenter.SoCount
static class | SalesInfoCenter.SoCountWithPartsOnhold
static class | SalesInfoCenter.SoItemCount
static class | SalesInfoCenter.SoTotalSum
Constructor Summary
SalesInfoCenter()
Method Summary
SalesInfoCenter.DueSoCount | getDueSoCount()
SalesInfoCenter.DueSoSum | getDueSoSum()
SalesInfoCenter.GrossMargin | getGrossMargin()
SalesInfoCenter.InvoicedSum | getInvoicedSum()
SalesInfoCenter.OpenSoSum | getOpenSoSum()
SalesInfoCenter.SoCount | getSoCount()
SalesInfoCenter.SoCountWithPartsOnhold | getSoCountWithPartsOnhold()
SalesInfoCenter.SoItemCount | getSoItemCount()
SalesInfoCenter.SoTotalSum | getSoTotalSum()
void | setDueSoCount(SalesInfoCenter.DueSoCount dueSoCount)
void | setDueSoSum(SalesInfoCenter.DueSoSum dueSoSum)
void | setGrossMargin(SalesInfoCenter.GrossMargin grossMargin)
void | setInvoicedSum(SalesInfoCenter.InvoicedSum invoicedSum)
void | setOpenSoSum(SalesInfoCenter.OpenSoSum openSoSum)
void | setSoCount(SalesInfoCenter.SoCount soCount)
void | setSoCountWithPartsOnhold(SalesInfoCenter.SoCountWithPartsOnhold soCountWithPartsOnhold)
void | setSoItemCount(SalesInfoCenter.SoItemCount soItemCount)
void | setSoTotalSum(SalesInfoCenter.SoTotalSum soTotalSum)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SalesInfoCenter

public SalesInfoCenter()
Method Detail

setSoTotalSum

public void setSoTotalSum(SalesInfoCenter.SoTotalSum soTotalSum)

getSoTotalSum

public SalesInfoCenter.SoTotalSum getSoTotalSum()

setSoCount

public void setSoCount(SalesInfoCenter.SoCount soCount)

getSoCount

public SalesInfoCenter.SoCount getSoCount()

setSoItemCount

public void setSoItemCount(SalesInfoCenter.SoItemCount soItemCount)

getSoItemCount

public SalesInfoCenter.SoItemCount getSoItemCount()

setOpenSoSum

public void setOpenSoSum(SalesInfoCenter.OpenSoSum openSoSum)

getOpenSoSum

public SalesInfoCenter.OpenSoSum getOpenSoSum()

setDueSoCount

public void setDueSoCount(SalesInfoCenter.DueSoCount dueSoCount)

getDueSoCount

public SalesInfoCenter.DueSoCount getDueSoCount()

setDueSoSum

public void setDueSoSum(SalesInfoCenter.DueSoSum dueSoSum)

getDueSoSum

public SalesInfoCenter.DueSoSum getDueSoSum()

setSoCountWithPartsOnhold

public void setSoCountWithPartsOnhold(SalesInfoCenter.SoCountWithPartsOnhold soCountWithPartsOnhold)

getSoCountWithPartsOnhold

public SalesInfoCenter.SoCountWithPartsOnhold getSoCountWithPartsOnhold()

setGrossMargin

public void setGrossMargin(SalesInfoCenter.GrossMargin grossMargin)

getGrossMargin

public SalesInfoCenter.GrossMargin getGrossMargin()

setInvoicedSum

public void setInvoicedSum(SalesInfoCenter.InvoicedSum invoicedSum)

getInvoicedSum

public SalesInfoCenter.InvoicedSum getInvoicedSum()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesInfoCenter.DueSoCount

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesInfoCenter.DueSoCount

java.lang.Object
    extended by  bb.common.SalesInfoCenter.DueSoCount
Enclosing class:
SalesInfoCenter
public static class SalesInfoCenter.DueSoCount
extends java.lang.Object

Constructor Summary
SalesInfoCenter.DueSoCount()
Method Summary
double | getAveragePerMonth()
double | getFiscalYear()
double | getLastMonth()
double | getThisMonth()
void | setAveragePerMonth(double averagePerMonth)
void | setFiscalYear(int fiscalYear)
void | setLastMonth(int lastMonth)
void | setThisMonth(int thisMonth)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SalesInfoCenter.DueSoCount

public SalesInfoCenter.DueSoCount()
Method Detail

setThisMonth

public void setThisMonth(int thisMonth)

getThisMonth

public double getThisMonth()

setLastMonth

public void setLastMonth(int lastMonth)

getLastMonth

public double getLastMonth()

getFiscalYear

public double getFiscalYear()

setFiscalYear

public void setFiscalYear(int fiscalYear)

setAveragePerMonth

public void setAveragePerMonth(double averagePerMonth)

getAveragePerMonth

public double getAveragePerMonth()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesInfoCenter.DueSoSum

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesInfoCenter.DueSoSum

java.lang.Object
    extended by  bb.common.SalesInfoCenter.DueSoSum
Enclosing class:
SalesInfoCenter
public static class SalesInfoCenter.DueSoSum
extends java.lang.Object

Constructor Summary
SalesInfoCenter.DueSoSum()
Method Summary
double | getAveragePerMonth()
double | getFiscalYear()
double | getLastMonth()
double | getThisMonth()
void | setAveragePerMonth(double averagePerMonth)
void | setFiscalYear(double fiscalYear)
void | setLastMonth(double lastMonth)
void | setThisMonth(double thisMonth)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SalesInfoCenter.DueSoSum

public SalesInfoCenter.DueSoSum()
Method Detail

setThisMonth

public void setThisMonth(double thisMonth)

getThisMonth

public double getThisMonth()

setLastMonth

public void setLastMonth(double lastMonth)

getLastMonth

public double getLastMonth()

getFiscalYear

public double getFiscalYear()

setFiscalYear

public void setFiscalYear(double fiscalYear)

setAveragePerMonth

public void setAveragePerMonth(double averagePerMonth)

getAveragePerMonth

public double getAveragePerMonth()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesInfoCenter.GrossMargin

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesInfoCenter.GrossMargin

java.lang.Object
    extended by  bb.common.SalesInfoCenter.GrossMargin
Enclosing class:
SalesInfoCenter
public static class SalesInfoCenter.GrossMargin
extends java.lang.Object

Constructor Summary
SalesInfoCenter.GrossMargin()
Method Summary
float | getAveragePerMonth()
float | getFiscalYear()
float | getLastMonth()
float | getThisMonth()
void | setAveragePerMonth(float averagePerMonth)
void | setFiscalYear(float fiscalYear)
void | setLastMonth(float lastMonth)
void | setThisMonth(float thisMonth)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SalesInfoCenter.GrossMargin

public SalesInfoCenter.GrossMargin()
Method Detail

setThisMonth

public void setThisMonth(float thisMonth)

getThisMonth

public float getThisMonth()

setLastMonth

public void setLastMonth(float lastMonth)

getLastMonth

public float getLastMonth()

getFiscalYear

public float getFiscalYear()

setFiscalYear

public void setFiscalYear(float fiscalYear)

setAveragePerMonth

public void setAveragePerMonth(float averagePerMonth)

getAveragePerMonth

public float getAveragePerMonth()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesInfoCenter.InvoicedSum

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesInfoCenter.InvoicedSum

java.lang.Object
    extended by  bb.common.SalesInfoCenter.InvoicedSum
Enclosing class:
SalesInfoCenter
public static class SalesInfoCenter.InvoicedSum
extends java.lang.Object

Constructor Summary
SalesInfoCenter.InvoicedSum()
Method Summary
double | getAveragePerMonth()
double | getFiscalYear()
double | getLastMonth()
double | getThisMonth()
void | setAveragePerMonth(double averagePerMonth)
void | setFiscalYear(double fiscalYear)
void | setLastMonth(double lastMonth)
void | setThisMonth(double thisMonth)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SalesInfoCenter.InvoicedSum

public SalesInfoCenter.InvoicedSum()
Method Detail

setThisMonth

public void setThisMonth(double thisMonth)

getThisMonth

public double getThisMonth()

setLastMonth

public void setLastMonth(double lastMonth)

getLastMonth

public double getLastMonth()

getFiscalYear

public double getFiscalYear()

setFiscalYear

public void setFiscalYear(double fiscalYear)

setAveragePerMonth

public void setAveragePerMonth(double averagePerMonth)

getAveragePerMonth

public double getAveragePerMonth()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesInfoCenter.OpenSoSum

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesInfoCenter.OpenSoSum

java.lang.Object
    extended by  bb.common.SalesInfoCenter.OpenSoSum
Enclosing class:
SalesInfoCenter
public static class SalesInfoCenter.OpenSoSum
extends java.lang.Object

Constructor Summary
SalesInfoCenter.OpenSoSum()
Method Summary
double | getAveragePerMonth()
double | getFiscalYear()
double | getLastMonth()
double | getThisMonth()
void | setAveragePerMonth(double averagePerMonth)
void | setFiscalYear(double fiscalYear)
void | setLastMonth(double lastMonth)
void | setThisMonth(double thisMonth)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SalesInfoCenter.OpenSoSum

public SalesInfoCenter.OpenSoSum()
Method Detail

setThisMonth

public void setThisMonth(double thisMonth)

getThisMonth

public double getThisMonth()

setLastMonth

public void setLastMonth(double lastMonth)

getLastMonth

public double getLastMonth()

getFiscalYear

public double getFiscalYear()

setFiscalYear

public void setFiscalYear(double fiscalYear)

setAveragePerMonth

public void setAveragePerMonth(double averagePerMonth)

getAveragePerMonth

public double getAveragePerMonth()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesInfoCenter.SoCount

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesInfoCenter.SoCount

java.lang.Object
    extended by  bb.common.SalesInfoCenter.SoCount
All Implemented Interfaces:
java.io.Serializable
Enclosing class:
SalesInfoCenter
public static class SalesInfoCenter.SoCount
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SalesInfoCenter.SoCount()
Method Summary
double | getAveragePerMonth()
double | getFiscalYear()
double | getLastMonth()
double | getThisMonth()
void | setAveragePerMonth(double averagePerMonth)
void | setFiscalYear(int fiscalYear)
void | setLastMonth(int lastMonth)
void | setThisMonth(int thisMonth)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SalesInfoCenter.SoCount

public SalesInfoCenter.SoCount()
Method Detail

setThisMonth

public void setThisMonth(int thisMonth)

getThisMonth

public double getThisMonth()

setLastMonth

public void setLastMonth(int lastMonth)

getLastMonth

public double getLastMonth()

getFiscalYear

public double getFiscalYear()

setFiscalYear

public void setFiscalYear(int fiscalYear)

setAveragePerMonth

public void setAveragePerMonth(double averagePerMonth)

getAveragePerMonth

public double getAveragePerMonth()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesInfoCenter.SoCountWithPartsOnhold

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesInfoCenter.SoCountWithPartsOnhold

java.lang.Object
    extended by  bb.common.SalesInfoCenter.SoCountWithPartsOnhold
Enclosing class:
SalesInfoCenter
public static class SalesInfoCenter.SoCountWithPartsOnhold
extends java.lang.Object

Constructor Summary
SalesInfoCenter.SoCountWithPartsOnhold()
Method Summary
double | getAveragePerMonth()
double | getFiscalYear()
double | getLastMonth()
double | getThisMonth()
void | setAveragePerMonth(double averagePerMonth)
void | setFiscalYear(int fiscalYear)
void | setLastMonth(int lastMonth)
void | setThisMonth(int thisMonth)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SalesInfoCenter.SoCountWithPartsOnhold

public SalesInfoCenter.SoCountWithPartsOnhold()
Method Detail

setThisMonth

public void setThisMonth(int thisMonth)

getThisMonth

public double getThisMonth()

setLastMonth

public void setLastMonth(int lastMonth)

getLastMonth

public double getLastMonth()

getFiscalYear

public double getFiscalYear()

setFiscalYear

public void setFiscalYear(int fiscalYear)

setAveragePerMonth

public void setAveragePerMonth(double averagePerMonth)

getAveragePerMonth

public double getAveragePerMonth()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesInfoCenter.SoItemCount

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesInfoCenter.SoItemCount

java.lang.Object
    extended by  bb.common.SalesInfoCenter.SoItemCount
All Implemented Interfaces:
java.io.Serializable
Enclosing class:
SalesInfoCenter
public static class SalesInfoCenter.SoItemCount
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SalesInfoCenter.SoItemCount()
Method Summary
double | getAveragePerMonth()
double | getFiscalYear()
double | getLastMonth()
double | getThisMonth()
void | setAveragePerMonth(double averagePerMonth)
void | setFiscalYear(int fiscalYear)
void | setLastMonth(int lastMonth)
void | setThisMonth(int thisMonth)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SalesInfoCenter.SoItemCount

public SalesInfoCenter.SoItemCount()
Method Detail

setThisMonth

public void setThisMonth(int thisMonth)

getThisMonth

public double getThisMonth()

setLastMonth

public void setLastMonth(int lastMonth)

getLastMonth

public double getLastMonth()

getFiscalYear

public double getFiscalYear()

setFiscalYear

public void setFiscalYear(int fiscalYear)

setAveragePerMonth

public void setAveragePerMonth(double averagePerMonth)

getAveragePerMonth

public double getAveragePerMonth()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesInfoCenter.SoTotalSum

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesInfoCenter.SoTotalSum

java.lang.Object
    extended by  bb.common.SalesInfoCenter.SoTotalSum
All Implemented Interfaces:
java.io.Serializable
Enclosing class:
SalesInfoCenter
public static class SalesInfoCenter.SoTotalSum
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SalesInfoCenter.SoTotalSum()
Method Summary
double | getAveragePerMonth()
double | getFiscalYear()
double | getLastMonth()
double | getThisMonth()
void | setAveragePerMonth(double averagePerMonth)
void | setFiscalYear(double fiscalYear)
void | setLastMonth(double lastMonth)
void | setThisMonth(double thisMonth)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SalesInfoCenter.SoTotalSum

public SalesInfoCenter.SoTotalSum()
Method Detail

setThisMonth

public void setThisMonth(double thisMonth)

getThisMonth

public double getThisMonth()

setLastMonth

public void setLastMonth(double lastMonth)

getLastMonth

public double getLastMonth()

getFiscalYear

public double getFiscalYear()

setFiscalYear

public void setFiscalYear(double fiscalYear)

setAveragePerMonth

public void setAveragePerMonth(double averagePerMonth)

getAveragePerMonth

public double getAveragePerMonth()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesInfoCenterResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesInfoCenterResult

java.lang.Object
    extended by  bb.common.SalesInfoCenterResult
All Implemented Interfaces:
java.io.Serializable
public class SalesInfoCenterResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SalesInfoCenterResult()
Method Summary
java.lang.String | getCurrency()
java.math.BigDecimal | getCurrentMonthInvoicedAccount()
java.math.BigDecimal | getCurrentMonthInvoiceGrossMargin()
java.lang.Integer | getCurrentMonthSalesItemCount()
java.math.BigDecimal | getCurrentMonthSalesOrderAccount()
java.lang.Integer | getCurrentMonthSalesOrderCount()
java.math.BigDecimal | getDueOriginalPromiseSalesAccount()
java.math.BigDecimal | getEachMonthInvoiceAvgAccount()
java.math.BigDecimal | getEachMonthInvoiceAvgGrossMargin()
java.lang.Integer | getEachMonthSalesItemAvgCount()
java.math.BigDecimal | getEachMonthSalesOrderAvgAccount()
java.lang.Integer | getEachMonthSalesOrderAvgCount()
java.math.BigDecimal | getFiscalYearInvoiceAccount()
java.math.BigDecimal | getFiscalYearInvoiceGrossMargin()
java.lang.Integer | getFiscalYearSalesItemCount()
java.math.BigDecimal | getFiscalYearSalesOrderAccount()
java.lang.Integer | getFiscalYearSalesOrderCount()
java.math.BigDecimal | getLastFiscalYearInvoiceAccount()
java.math.BigDecimal | getLastFiscalYearSalesAccount()
java.math.BigDecimal | getLastMonthInvoiceAccount()
java.math.BigDecimal | getLastMonthInvoiceGrossMargin()
java.lang.Integer | getLastMonthSalesItemCount()
java.math.BigDecimal | getLastMonthSalesOrderAccount()
java.lang.Integer | getLastMonthSalesOrderCount()
java.math.BigDecimal | getLastTwevMonthsTotalSalesGrossMargin()
java.math.BigDecimal | getOpenSalesAccount()
java.math.BigDecimal | getPastDueSalesAccount()
java.lang.Integer | getPastDueSalesCount()
java.lang.Integer | getSalesCountWithPartOnHold()
void | setCurrency(java.lang.String currency)
void | setCurrentMonthInvoicedAccount(java.math.BigDecimal currentMonthInvoicedAccount)
void | setCurrentMonthInvoiceGrossMargin(java.math.BigDecimal currentMonthInvoiceGrossMargin)
void | setCurrentMonthSalesItemCount(java.lang.Integer currentMonthSalesItemCount)
void | setCurrentMonthSalesOrderAccount(java.math.BigDecimal currentMonthSalesOrderAccount)
void | setCurrentMonthSalesOrderCount(java.lang.Integer currentMonthSalesOrderCount)
void | setDueOriginalPromiseSalesAccount(java.math.BigDecimal dueOriginalPromiseSalesAccount)
void | setEachMonthInvoiceAvgAccount(java.math.BigDecimal eachMonthInvoiceAvgAccount)
void | setEachMonthInvoiceAvgGrossMargin(java.math.BigDecimal eachMonthInvoiceAvgGrossMargin)
void | setEachMonthSalesItemAvgCount(java.lang.Integer eachMonthSalesItemAvgCount)
void | setEachMonthSalesOrderAvgAccount(java.math.BigDecimal eachMonthSalesOrderAvgAccount)
void | setEachMonthSalesOrderAvgCount(java.lang.Integer eachMonthSalesOrderAvgCount)
void | setFiscalYearInvoiceAccount(java.math.BigDecimal fiscalYearInvoiceAccount)
void | setFiscalYearInvoiceGrossMargin(java.math.BigDecimal fiscalYearInvoiceGrossMargin)
void | setFiscalYearSalesItemCount(java.lang.Integer fiscalYearSalesItemCount)
void | setFiscalYearSalesOrderAccount(java.math.BigDecimal fiscalYearSalesOrderAccount)
void | setFiscalYearSalesOrderCount(java.lang.Integer fiscalYearSalesOrderCount)
void | setLastFiscalYearInvoiceAccount(java.math.BigDecimal lastFiscalYearInvoiceAccount)
void | setLastFiscalYearSalesAccount(java.math.BigDecimal lastFiscalYearSalesAccount)
void | setLastMonthInvoiceAccount(java.math.BigDecimal lastMonthInvoiceAccount)
void | setLastMonthInvoiceGrossMargin(java.math.BigDecimal lastMonthInvoiceGrossMargin)
void | setLastMonthSalesItemCount(java.lang.Integer lastMonthSalesItemCount)
void | setLastMonthSalesOrderAccount(java.math.BigDecimal lastMonthSalesOrderAccount)
void | setLastMonthSalesOrderCount(java.lang.Integer lastMonthSalesOrderCount)
void | setLastTwevMonthsTotalSalesGrossMargin(java.math.BigDecimal lastTwevMonthsTotalSalesGrossMargin)
void | setOpenSalesAccount(java.math.BigDecimal openSalesAccount)
void | setPastDueSalesAccount(java.math.BigDecimal pastDueSalesAccount)
void | setPastDueSalesCount(java.lang.Integer pastDueSalesCount)
void | setSalesCountWithPartOnHold(java.lang.Integer salesCountWithPartOnHold)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SalesInfoCenterResult

public SalesInfoCenterResult()
Method Detail

setCurrency

public void setCurrency(java.lang.String currency)

setLastMonthSalesOrderAccount

public void setLastMonthSalesOrderAccount(java.math.BigDecimal lastMonthSalesOrderAccount)

setFiscalYearSalesOrderAccount

public void setFiscalYearSalesOrderAccount(java.math.BigDecimal fiscalYearSalesOrderAccount)

setEachMonthSalesOrderAvgAccount

public void setEachMonthSalesOrderAvgAccount(java.math.BigDecimal eachMonthSalesOrderAvgAccount)

setCurrentMonthSalesOrderCount

public void setCurrentMonthSalesOrderCount(java.lang.Integer currentMonthSalesOrderCount)

setLastMonthSalesOrderCount

public void setLastMonthSalesOrderCount(java.lang.Integer lastMonthSalesOrderCount)

setFiscalYearSalesOrderCount

public void setFiscalYearSalesOrderCount(java.lang.Integer fiscalYearSalesOrderCount)

setEachMonthSalesOrderAvgCount

public void setEachMonthSalesOrderAvgCount(java.lang.Integer eachMonthSalesOrderAvgCount)

setCurrentMonthSalesItemCount

public void setCurrentMonthSalesItemCount(java.lang.Integer currentMonthSalesItemCount)

setLastMonthSalesItemCount

public void setLastMonthSalesItemCount(java.lang.Integer lastMonthSalesItemCount)

setFiscalYearSalesItemCount

public void setFiscalYearSalesItemCount(java.lang.Integer fiscalYearSalesItemCount)

setEachMonthSalesItemAvgCount

public void setEachMonthSalesItemAvgCount(java.lang.Integer eachMonthSalesItemAvgCount)

setOpenSalesAccount

public void setOpenSalesAccount(java.math.BigDecimal openSalesAccount)

setPastDueSalesAccount

public void setPastDueSalesAccount(java.math.BigDecimal pastDueSalesAccount)

setPastDueSalesCount

public void setPastDueSalesCount(java.lang.Integer pastDueSalesCount)

setSalesCountWithPartOnHold

public void setSalesCountWithPartOnHold(java.lang.Integer salesCountWithPartOnHold)

setCurrentMonthInvoicedAccount

public void setCurrentMonthInvoicedAccount(java.math.BigDecimal currentMonthInvoicedAccount)

setLastMonthInvoiceAccount

public void setLastMonthInvoiceAccount(java.math.BigDecimal lastMonthInvoiceAccount)

setFiscalYearInvoiceAccount

public void setFiscalYearInvoiceAccount(java.math.BigDecimal fiscalYearInvoiceAccount)

setEachMonthInvoiceAvgAccount

public void setEachMonthInvoiceAvgAccount(java.math.BigDecimal eachMonthInvoiceAvgAccount)

setCurrentMonthInvoiceGrossMargin

public void setCurrentMonthInvoiceGrossMargin(java.math.BigDecimal currentMonthInvoiceGrossMargin)

setLastMonthInvoiceGrossMargin

public void setLastMonthInvoiceGrossMargin(java.math.BigDecimal lastMonthInvoiceGrossMargin)

setFiscalYearInvoiceGrossMargin

public void setFiscalYearInvoiceGrossMargin(java.math.BigDecimal fiscalYearInvoiceGrossMargin)

setEachMonthInvoiceAvgGrossMargin

public void setEachMonthInvoiceAvgGrossMargin(java.math.BigDecimal eachMonthInvoiceAvgGrossMargin)

setLastFiscalYearInvoiceAccount

public void setLastFiscalYearInvoiceAccount(java.math.BigDecimal lastFiscalYearInvoiceAccount)

setLastFiscalYearSalesAccount

public void setLastFiscalYearSalesAccount(java.math.BigDecimal lastFiscalYearSalesAccount)

getCurrency

public java.lang.String getCurrency()

getLastMonthSalesOrderAccount

public java.math.BigDecimal getLastMonthSalesOrderAccount()

getFiscalYearSalesOrderAccount

public java.math.BigDecimal getFiscalYearSalesOrderAccount()

getEachMonthSalesOrderAvgAccount

public java.math.BigDecimal getEachMonthSalesOrderAvgAccount()

getCurrentMonthSalesOrderCount

public java.lang.Integer getCurrentMonthSalesOrderCount()

getLastMonthSalesOrderCount

public java.lang.Integer getLastMonthSalesOrderCount()

getFiscalYearSalesOrderCount

public java.lang.Integer getFiscalYearSalesOrderCount()

getEachMonthSalesOrderAvgCount

public java.lang.Integer getEachMonthSalesOrderAvgCount()

getCurrentMonthSalesItemCount

public java.lang.Integer getCurrentMonthSalesItemCount()

getLastMonthSalesItemCount

public java.lang.Integer getLastMonthSalesItemCount()

getFiscalYearSalesItemCount

public java.lang.Integer getFiscalYearSalesItemCount()

getEachMonthSalesItemAvgCount

public java.lang.Integer getEachMonthSalesItemAvgCount()

getOpenSalesAccount

public java.math.BigDecimal getOpenSalesAccount()

getPastDueSalesAccount

public java.math.BigDecimal getPastDueSalesAccount()

getPastDueSalesCount

public java.lang.Integer getPastDueSalesCount()

getSalesCountWithPartOnHold

public java.lang.Integer getSalesCountWithPartOnHold()

getCurrentMonthInvoicedAccount

public java.math.BigDecimal getCurrentMonthInvoicedAccount()

getLastMonthInvoiceAccount

public java.math.BigDecimal getLastMonthInvoiceAccount()

getFiscalYearInvoiceAccount

public java.math.BigDecimal getFiscalYearInvoiceAccount()

getEachMonthInvoiceAvgAccount

public java.math.BigDecimal getEachMonthInvoiceAvgAccount()

getCurrentMonthInvoiceGrossMargin

public java.math.BigDecimal getCurrentMonthInvoiceGrossMargin()

getLastMonthInvoiceGrossMargin

public java.math.BigDecimal getLastMonthInvoiceGrossMargin()

getFiscalYearInvoiceGrossMargin

public java.math.BigDecimal getFiscalYearInvoiceGrossMargin()

getEachMonthInvoiceAvgGrossMargin

public java.math.BigDecimal getEachMonthInvoiceAvgGrossMargin()

getLastFiscalYearInvoiceAccount

public java.math.BigDecimal getLastFiscalYearInvoiceAccount()

getLastFiscalYearSalesAccount

public java.math.BigDecimal getLastFiscalYearSalesAccount()

getCurrentMonthSalesOrderAccount

public java.math.BigDecimal getCurrentMonthSalesOrderAccount()

setCurrentMonthSalesOrderAccount

public void setCurrentMonthSalesOrderAccount(java.math.BigDecimal currentMonthSalesOrderAccount)

getDueOriginalPromiseSalesAccount

public java.math.BigDecimal getDueOriginalPromiseSalesAccount()

setDueOriginalPromiseSalesAccount

public void setDueOriginalPromiseSalesAccount(java.math.BigDecimal dueOriginalPromiseSalesAccount)

getLastTwevMonthsTotalSalesGrossMargin

public java.math.BigDecimal getLastTwevMonthsTotalSalesGrossMargin()

setLastTwevMonthsTotalSalesGrossMargin

public void setLastTwevMonthsTotalSalesGrossMargin(java.math.BigDecimal lastTwevMonthsTotalSalesGrossMargin)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesmanVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesmanVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SalesmanVO
All Implemented Interfaces:
java.io.Serializable
public class SalesmanVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_COMPANYUNITID
static java.lang.String | ORDER_BY_DEPARTMENT
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_FIRSTNAME
static java.lang.String | ORDER_BY_JOBID
static java.lang.String | ORDER_BY_LANGUAGE
static java.lang.String | ORDER_BY_LASTCHANGEUSER
static java.lang.String | ORDER_BY_LASTNAME
static java.lang.String | ORDER_BY_LEVEL
static java.lang.String | ORDER_BY_SALESMANID
static java.lang.String | ORDER_BY_SECURITYLEVEL
static java.lang.String | ORDER_BY_STARTDATE
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_USERNAME
Constructor Summary
SalesmanVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.lang.String | getAddress1()
java.lang.String | getAddress2()
java.lang.String | getCity()
java.lang.String | getComments()
java.math.BigDecimal | getCommission()
java.lang.String | getCompany()
java.lang.String | getCompanyUnitId()
java.lang.String | getCountry()
java.lang.String | getDepartment()
java.lang.String | getDescription()
java.lang.String | getEmail()
java.lang.String | getEmergencyContact()
java.lang.String | getExtension()
java.lang.String | getFirstName()
java.lang.String | getHomeAddress()
java.lang.String | getHomePhone()
java.lang.String | getJobId()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
int | getLastChangeTimes()
java.lang.String | getLastChangeUser()
java.lang.String | getLastName()
java.lang.String | getLevel()
java.lang.String | getPassword()
java.lang.String | getPhone()
java.lang.String | getPhoneExtension()
byte[] | getPicture()
int | getSalesmanId()
java.lang.String | getSecurityLevel()
java.util.Date | getStartDate()
java.lang.String | getState()
java.lang.String | getStatus()
java.lang.String | getUserName()
java.lang.String | getWifeName()
java.lang.String | getWorkAddress()
java.lang.String | getZip()
int | hashCode()
void | setAdate(java.util.Date adate)
void | setAddress1(java.lang.String address1)
void | setAddress2(java.lang.String address2)
void | setCity(java.lang.String city)
void | setComments(java.lang.String comments)
void | setCommission(java.math.BigDecimal commission)
void | setCompany(java.lang.String company)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCountry(java.lang.String country)
void | setDepartment(java.lang.String department)
void | setDescription(java.lang.String description)
void | setEmail(java.lang.String email)
void | setEmergencyContact(java.lang.String emergencyContact)
void | setExtension(java.lang.String extension)
void | setFirstName(java.lang.String firstName)
void | setHomeAddress(java.lang.String homeAddress)
void | setHomePhone(java.lang.String homePhone)
void | setJobId(java.lang.String jobId)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTimes(int lastChangeTimes)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLastName(java.lang.String lastName)
void | setLevel(java.lang.String level)
void | setPassword(java.lang.String password)
void | setPhone(java.lang.String phone)
void | setPhoneExtension(java.lang.String phoneExtension)
void | setPicture(byte[] picture)
void | setSalesmanId(int salesmanId)
void | setSecurityLevel(java.lang.String securityLevel)
void | setStartDate(java.util.Date startDate)
void | setState(java.lang.String state)
void | setStatus(java.lang.String status)
void | setUserName(java.lang.String userName)
void | setWifeName(java.lang.String wifeName)
void | setWorkAddress(java.lang.String workAddress)
void | setZip(java.lang.String zip)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_SALESMANID

public static final java.lang.String ORDER_BY_SALESMANID
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEUSER

public static final java.lang.String ORDER_BY_LASTCHANGEUSER
See Also:
Constant Field Values

ORDER_BY_LEVEL

public static final java.lang.String ORDER_BY_LEVEL
See Also:
Constant Field Values

ORDER_BY_USERNAME

public static final java.lang.String ORDER_BY_USERNAME
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_LANGUAGE

public static final java.lang.String ORDER_BY_LANGUAGE
See Also:
Constant Field Values

ORDER_BY_LASTNAME

public static final java.lang.String ORDER_BY_LASTNAME
See Also:
Constant Field Values

ORDER_BY_FIRSTNAME

public static final java.lang.String ORDER_BY_FIRSTNAME
See Also:
Constant Field Values

ORDER_BY_DEPARTMENT

public static final java.lang.String ORDER_BY_DEPARTMENT
See Also:
Constant Field Values

ORDER_BY_STARTDATE

public static final java.lang.String ORDER_BY_STARTDATE
See Also:
Constant Field Values

ORDER_BY_JOBID

public static final java.lang.String ORDER_BY_JOBID
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_SECURITYLEVEL

public static final java.lang.String ORDER_BY_SECURITYLEVEL
See Also:
Constant Field Values

ORDER_BY_COMPANYUNITID

public static final java.lang.String ORDER_BY_COMPANYUNITID
See Also:
Constant Field Values
Constructor Detail

SalesmanVO

public SalesmanVO()
Method Detail

getSalesmanId

public int getSalesmanId()

setSalesmanId

public void setSalesmanId(int salesmanId)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeTimes

public int getLastChangeTimes()

setLastChangeTimes

public void setLastChangeTimes(int lastChangeTimes)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getCompany

public java.lang.String getCompany()

setCompany

public void setCompany(java.lang.String company)

getLevel

public java.lang.String getLevel()

setLevel

public void setLevel(java.lang.String level)

getPassword

public java.lang.String getPassword()

setPassword

public void setPassword(java.lang.String password)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getLastName

public java.lang.String getLastName()

setLastName

public void setLastName(java.lang.String lastName)

getFirstName

public java.lang.String getFirstName()

setFirstName

public void setFirstName(java.lang.String firstName)

getWorkAddress

public java.lang.String getWorkAddress()

setWorkAddress

public void setWorkAddress(java.lang.String workAddress)

getHomeAddress

public java.lang.String getHomeAddress()

setHomeAddress

public void setHomeAddress(java.lang.String homeAddress)

getDepartment

public java.lang.String getDepartment()

setDepartment

public void setDepartment(java.lang.String department)

getStartDate

public java.util.Date getStartDate()

setStartDate

public void setStartDate(java.util.Date startDate)

getPhone

public java.lang.String getPhone()

setPhone

public void setPhone(java.lang.String phone)

getPhoneExtension

public java.lang.String getPhoneExtension()

setPhoneExtension

public void setPhoneExtension(java.lang.String phoneExtension)

getEmail

public java.lang.String getEmail()

setEmail

public void setEmail(java.lang.String email)

getPicture

public byte[] getPicture()

setPicture

public void setPicture(byte[] picture)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

getJobId

public java.lang.String getJobId()

setJobId

public void setJobId(java.lang.String jobId)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getSecurityLevel

public java.lang.String getSecurityLevel()

setSecurityLevel

public void setSecurityLevel(java.lang.String securityLevel)

getCommission

public java.math.BigDecimal getCommission()

setCommission

public void setCommission(java.math.BigDecimal commission)

getAddress1

public java.lang.String getAddress1()

setAddress1

public void setAddress1(java.lang.String address1)

getAddress2

public java.lang.String getAddress2()

setAddress2

public void setAddress2(java.lang.String address2)

getCity

public java.lang.String getCity()

setCity

public void setCity(java.lang.String city)

getState

public java.lang.String getState()

setState

public void setState(java.lang.String state)

getZip

public java.lang.String getZip()

setZip

public void setZip(java.lang.String zip)

getCountry

public java.lang.String getCountry()

setCountry

public void setCountry(java.lang.String country)

getHomePhone

public java.lang.String getHomePhone()

setHomePhone

public void setHomePhone(java.lang.String homePhone)

getEmergencyContact

public java.lang.String getEmergencyContact()

setEmergencyContact

public void setEmergencyContact(java.lang.String emergencyContact)

getWifeName

public java.lang.String getWifeName()

setWifeName

public void setWifeName(java.lang.String wifeName)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesMarginListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesMarginListResult

java.lang.Object
    extended by  bb.common.SalesMarginListResult
All Implemented Interfaces:
java.io.Serializable
public class SalesMarginListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_COUNTRY
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_CUSTOMERNAME
static java.lang.String | ORDER_BY_STATE
static java.lang.String | ORDER_BY_TOTALCOST
static java.lang.String | ORDER_BY_TOTALMARGIN
static java.lang.String | ORDER_BY_TOTALNET
static java.lang.String | ORDER_BY_TOTALSALES
Constructor Summary
SalesMarginListResult()
Method Summary
java.lang.String | getCountry()
java.lang.String | getCurrency()
java.lang.String | getCustomerId()
java.lang.String | getCustomerName()
java.math.BigDecimal | getExchange()
java.lang.String | getState()
java.math.BigDecimal | getTotalCost()
java.math.BigDecimal | getTotalMargin()
java.math.BigDecimal | getTotalNet()
java.math.BigDecimal | getTotalSales()
void | setCountry(java.lang.String country)
void | setCurrency(java.lang.String currency)
void | setCustomerId(java.lang.String customerId)
void | setCustomerName(java.lang.String customerName)
void | setExchange(java.math.BigDecimal exchange)
void | setState(java.lang.String state)
void | setTotalCost(java.math.BigDecimal totalCost)
void | setTotalMargin(java.math.BigDecimal totalMargin)
void | setTotalNet(java.math.BigDecimal totalNet)
void | setTotalSales(java.math.BigDecimal totalSales)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_CUSTOMERNAME

public static final java.lang.String ORDER_BY_CUSTOMERNAME
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values

ORDER_BY_TOTALNET

public static final java.lang.String ORDER_BY_TOTALNET
See Also:
Constant Field Values

ORDER_BY_TOTALSALES

public static final java.lang.String ORDER_BY_TOTALSALES
See Also:
Constant Field Values

ORDER_BY_TOTALCOST

public static final java.lang.String ORDER_BY_TOTALCOST
See Also:
Constant Field Values

ORDER_BY_TOTALMARGIN

public static final java.lang.String ORDER_BY_TOTALMARGIN
See Also:
Constant Field Values

ORDER_BY_COUNTRY

public static final java.lang.String ORDER_BY_COUNTRY
See Also:
Constant Field Values

ORDER_BY_STATE

public static final java.lang.String ORDER_BY_STATE
See Also:
Constant Field Values
Constructor Detail

SalesMarginListResult

public SalesMarginListResult()
Method Detail

setCountry

public void setCountry(java.lang.String country)

getCountry

public java.lang.String getCountry()

setCustomerId

public void setCustomerId(java.lang.String customerId)

setCustomerName

public void setCustomerName(java.lang.String customerName)

setCurrency

public void setCurrency(java.lang.String currency)

setExchange

public void setExchange(java.math.BigDecimal exchange)

setTotalNet

public void setTotalNet(java.math.BigDecimal totalNet)

setTotalCost

public void setTotalCost(java.math.BigDecimal totalCost)

setTotalMargin

public void setTotalMargin(java.math.BigDecimal totalMargin)

setTotalSales

public void setTotalSales(java.math.BigDecimal totalSales)

getCustomerId

public java.lang.String getCustomerId()

getCustomerName

public java.lang.String getCustomerName()

getCurrency

public java.lang.String getCurrency()

getExchange

public java.math.BigDecimal getExchange()

getTotalNet

public java.math.BigDecimal getTotalNet()

getTotalCost

public java.math.BigDecimal getTotalCost()

getTotalMargin

public java.math.BigDecimal getTotalMargin()

getTotalSales

public java.math.BigDecimal getTotalSales()

getState

public java.lang.String getState()

setState

public void setState(java.lang.String state)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesOnTimeResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesOnTimeResult

java.lang.Object
    extended by  bb.common.SalesOnTimeResult
All Implemented Interfaces:
java.io.Serializable
public class SalesOnTimeResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SalesOnTimeResult()
Method Summary
java.lang.String | getCurrency()
int | getDay1()
int | getDay2()
java.util.List<SalesOrderOnTimeItemResult> | getItems()
void | setCurrency(java.lang.String currency)
void | setDay1(int day1)
void | setDay2(int day2)
void | setItems(java.util.List<SalesOrderOnTimeItemResult> items)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SalesOnTimeResult

public SalesOnTimeResult()
Method Detail

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getItems

public java.util.List<SalesOrderOnTimeItemResult> getItems()

setItems

public void setItems(java.util.List<SalesOrderOnTimeItemResult> items)

getDay1

public int getDay1()

setDay1

public void setDay1(int day1)

getDay2

public int getDay2()

setDay2

public void setDay2(int day2)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesOrder12MonthMarginResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesOrder12MonthMarginResult

java.lang.Object
    extended by  bb.common.SalesOrder12MonthMarginResult
All Implemented Interfaces:
java.io.Serializable
public class SalesOrder12MonthMarginResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_COST
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_GROSSMARGIN
static java.lang.String | ORDER_BY_INVOICEDTOTAL
static java.lang.String | ORDER_BY_PART
static java.lang.String | ORDER_BY_PCTMARGIN
static java.lang.String | ORDER_BY_QTY
Constructor Summary
SalesOrder12MonthMarginResult()
Method Summary
java.math.BigDecimal | getCost()
java.lang.String | getCurrency()
java.lang.String | getDescription()
java.math.BigDecimal | getGrossMargin()
java.math.BigDecimal | getInvoicedTotal()
BB2Part | getPart()
java.math.BigDecimal | getPctMargin()
java.math.BigDecimal | getQty()
void | setCost(java.math.BigDecimal cost)
void | setCurrency(java.lang.String currency)
void | setDescription(java.lang.String description)
void | setGrossMargin(java.math.BigDecimal grossMargin)
void | setInvoicedTotal(java.math.BigDecimal invoicedTotal)
void | setPart(BB2Part part)
void | setPctMargin(java.math.BigDecimal pctMargin)
void | setQty(java.math.BigDecimal qty)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PART

public static final java.lang.String ORDER_BY_PART
See Also:
Constant Field Values

ORDER_BY_QTY

public static final java.lang.String ORDER_BY_QTY
See Also:
Constant Field Values

ORDER_BY_INVOICEDTOTAL

public static final java.lang.String ORDER_BY_INVOICEDTOTAL
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_GROSSMARGIN

public static final java.lang.String ORDER_BY_GROSSMARGIN
See Also:
Constant Field Values

ORDER_BY_PCTMARGIN

public static final java.lang.String ORDER_BY_PCTMARGIN
See Also:
Constant Field Values

ORDER_BY_COST

public static final java.lang.String ORDER_BY_COST
See Also:
Constant Field Values
Constructor Detail

SalesOrder12MonthMarginResult

public SalesOrder12MonthMarginResult()
Method Detail

setPart

public void setPart(BB2Part part)

setQty

public void setQty(java.math.BigDecimal qty)

setInvoicedTotal

public void setInvoicedTotal(java.math.BigDecimal invoicedTotal)

setGrossMargin

public void setGrossMargin(java.math.BigDecimal grossMargin)

setPctMargin

public void setPctMargin(java.math.BigDecimal pctMargin)

setDescription

public void setDescription(java.lang.String description)

getPart

public BB2Part getPart()

getQty

public java.math.BigDecimal getQty()

getInvoicedTotal

public java.math.BigDecimal getInvoicedTotal()

getGrossMargin

public java.math.BigDecimal getGrossMargin()

getPctMargin

public java.math.BigDecimal getPctMargin()

getDescription

public java.lang.String getDescription()

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getCost

public java.math.BigDecimal getCost()

setCost

public void setCost(java.math.BigDecimal cost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesOrderBoilerplateVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesOrderBoilerplateVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SalesOrderBoilerplateVO
All Implemented Interfaces:
java.io.Serializable
public class SalesOrderBoilerplateVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_BOILERPLATEID
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_SOBOILERPLATE
Constructor Summary
SalesOrderBoilerplateVO()
default constructor
SalesOrderBoilerplateVO(java.lang.String boilerplateId, java.lang.String description)
minimal constructor
SalesOrderBoilerplateVO(java.lang.String boilerplateId, java.lang.String description, java.lang.String soBoilerplate)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getBoilerplateId()
java.lang.String | getDescription()
java.lang.String | getSoBoilerplate()
int | hashCode()
void | setBoilerplateId(java.lang.String boilerplateId)
void | setDescription(java.lang.String description)
void | setSoBoilerplate(java.lang.String soBoilerplate)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_BOILERPLATEID

public static final java.lang.String ORDER_BY_BOILERPLATEID
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_SOBOILERPLATE

public static final java.lang.String ORDER_BY_SOBOILERPLATE
See Also:
Constant Field Values
Constructor Detail

SalesOrderBoilerplateVO

public SalesOrderBoilerplateVO(java.lang.String boilerplateId,
                               java.lang.String description,
                               java.lang.String soBoilerplate)
full constructor

SalesOrderBoilerplateVO

public SalesOrderBoilerplateVO()
default constructor

SalesOrderBoilerplateVO

public SalesOrderBoilerplateVO(java.lang.String boilerplateId,
                               java.lang.String description)
minimal constructor

Method Detail

getBoilerplateId

public java.lang.String getBoilerplateId()

setBoilerplateId

public void setBoilerplateId(java.lang.String boilerplateId)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getSoBoilerplate

public java.lang.String getSoBoilerplate()

setSoBoilerplate

public void setSoBoilerplate(java.lang.String soBoilerplate)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesOrderCheckListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesOrderCheckListResult

java.lang.Object
    extended by  bb.common.SalesOrderCheckListResult
All Implemented Interfaces:
java.io.Serializable
public class SalesOrderCheckListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_CUSTOMERNAME
static java.lang.String | ORDER_BY_SALESMAN
static java.lang.String | ORDER_BY_SALESMANID
static java.lang.String | ORDER_BY_SODATE
static java.lang.String | ORDER_BY_SONUMBER
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
SalesOrderCheckListResult()
Method Summary
java.math.BigDecimal | getArTotal()
java.lang.String | getCurrency()
java.lang.String | getCustomerId()
java.lang.String | getCustomerName()
java.lang.String | getSalesMan()
short | getSalesManId()
java.util.Date | getSoDate()
java.lang.String | getSoNumber()
java.lang.String | getStatus()
void | setArTotal(java.math.BigDecimal arTotal)
void | setCurrency(java.lang.String currency)
void | setCustomerId(java.lang.String customerId)
void | setCustomerName(java.lang.String customerName)
void | setSalesMan(java.lang.String salesMan)
void | setSalesManId(short salesManId)
void | setSoDate(java.util.Date soDate)
void | setSoNumber(java.lang.String soNumber)
void | setStatus(java.lang.String status)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_SONUMBER

public static final java.lang.String ORDER_BY_SONUMBER
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_SALESMAN

public static final java.lang.String ORDER_BY_SALESMAN
See Also:
Constant Field Values

ORDER_BY_SODATE

public static final java.lang.String ORDER_BY_SODATE
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values

ORDER_BY_CUSTOMERNAME

public static final java.lang.String ORDER_BY_CUSTOMERNAME
See Also:
Constant Field Values

ORDER_BY_SALESMANID

public static final java.lang.String ORDER_BY_SALESMANID
See Also:
Constant Field Values
Constructor Detail

SalesOrderCheckListResult

public SalesOrderCheckListResult()
Method Detail

getCustomerId

public java.lang.String getCustomerId()

getSoDate

public java.util.Date getSoDate()

getStatus

public java.lang.String getStatus()

getSoNumber

public java.lang.String getSoNumber()

getCurrency

public java.lang.String getCurrency()

getCustomerName

public java.lang.String getCustomerName()

getSalesMan

public java.lang.String getSalesMan()

setArTotal

public void setArTotal(java.math.BigDecimal arTotal)

setCustomerId

public void setCustomerId(java.lang.String customerId)

setSoDate

public void setSoDate(java.util.Date soDate)

setStatus

public void setStatus(java.lang.String status)

setSoNumber

public void setSoNumber(java.lang.String soNumber)

setCurrency

public void setCurrency(java.lang.String currency)

setCustomerName

public void setCustomerName(java.lang.String customerName)

setSalesMan

public void setSalesMan(java.lang.String salesMan)

setSalesManId

public void setSalesManId(short salesManId)

getArTotal

public java.math.BigDecimal getArTotal()

getSalesManId

public short getSalesManId()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesOrderDocumentVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesOrderDocumentVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SalesOrderDocumentVO
All Implemented Interfaces:
java.io.Serializable
public class SalesOrderDocumentVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
SalesOrderDocumentVO()
Method Summary
java.lang.String | getComments()
java.lang.String | getDocDescription()
java.lang.String | getDocFileName()
long | getDocLength()
java.util.Date | getDocumentDate()
java.lang.String | getExtension()
java.lang.Long | getIi()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getSoNumber()
void | setComments(java.lang.String comments)
void | setDocDescription(java.lang.String docDescription)
void | setDocFileName(java.lang.String docFileName)
void | setDocLength(long docLength)
void | setDocumentDate(java.util.Date documentDate)
void | setExtension(java.lang.String extension)
void | setIi(java.lang.Long ii)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setSoNumber(java.lang.String soNumber)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SalesOrderDocumentVO

public SalesOrderDocumentVO()
Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getSoNumber

public java.lang.String getSoNumber()

setSoNumber

public void setSoNumber(java.lang.String soNumber)

getDocDescription

public java.lang.String getDocDescription()

setDocDescription

public void setDocDescription(java.lang.String docDescription)

getDocumentDate

public java.util.Date getDocumentDate()

setDocumentDate

public void setDocumentDate(java.util.Date documentDate)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

getDocFileName

public java.lang.String getDocFileName()

setDocFileName

public void setDocFileName(java.lang.String docFileName)

getDocLength

public long getDocLength()

setDocLength

public void setDocLength(long docLength)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesOrderItemCostResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesOrderItemCostResult

java.lang.Object
    extended by  bb.common.SalesOrderItemCostResult
All Implemented Interfaces:
java.io.Serializable
public class SalesOrderItemCostResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SalesOrderItemCostResult()
Method Summary
java.math.BigDecimal | getAverageCost()
java.math.BigDecimal | getAvgCost()
java.lang.String | getCurrency()
java.math.BigDecimal | getHighestCost()
java.math.BigDecimal | getListPrice()
java.math.BigDecimal | getLowestCost()
int | getNumOfMissingItems()
java.math.BigDecimal | getStdCost()
java.math.BigDecimal | getTotalMoney()
void | setAverageCost(java.math.BigDecimal averageCost)
void | setAvgCost(java.math.BigDecimal avgCost)
void | setCurrency(java.lang.String currency)
void | setHighestCost(java.math.BigDecimal highestCost)
void | setListPrice(java.math.BigDecimal listPrice)
void | setLowestCost(java.math.BigDecimal lowestCost)
void | setNumOfMissingItems(int numOfMissingItems)
void | setStdCost(java.math.BigDecimal stdCost)
void | setTotalMoney(java.math.BigDecimal totalMoney)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SalesOrderItemCostResult

public SalesOrderItemCostResult()
Method Detail

setTotalMoney

public void setTotalMoney(java.math.BigDecimal totalMoney)

setCurrency

public void setCurrency(java.lang.String currency)

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

setNumOfMissingItems

public void setNumOfMissingItems(int numOfMissingItems)

setLowestCost

public void setLowestCost(java.math.BigDecimal lowestCost)

setAverageCost

public void setAverageCost(java.math.BigDecimal averageCost)

setHighestCost

public void setHighestCost(java.math.BigDecimal highestCost)

getTotalMoney

public java.math.BigDecimal getTotalMoney()

getCurrency

public java.lang.String getCurrency()

getListPrice

public java.math.BigDecimal getListPrice()

getStdCost

public java.math.BigDecimal getStdCost()

getAvgCost

public java.math.BigDecimal getAvgCost()

getNumOfMissingItems

public int getNumOfMissingItems()

getLowestCost

public java.math.BigDecimal getLowestCost()

getAverageCost

public java.math.BigDecimal getAverageCost()

getHighestCost

public java.math.BigDecimal getHighestCost()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesOrderItemCustomerTotalResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesOrderItemCustomerTotalResult

java.lang.Object
    extended by  bb.common.SalesOrderItemCustomerTotalResult
All Implemented Interfaces:
java.io.Serializable
public class SalesOrderItemCustomerTotalResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_NAME
Constructor Summary
SalesOrderItemCustomerTotalResult()
Method Summary
java.lang.String | getCurrency()
java.lang.String | getCustomerId()
java.lang.String | getName()
int | getNumOfItems()
java.math.BigDecimal | getTotal()
void | setCurrency(java.lang.String currency)
void | setCustomerId(java.lang.String customerId)
void | setName(java.lang.String name)
void | setNumOfItems(int numOfItems)
void | setTotal(java.math.BigDecimal total)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_NAME

public static final java.lang.String ORDER_BY_NAME
See Also:
Constant Field Values
Constructor Detail

SalesOrderItemCustomerTotalResult

public SalesOrderItemCustomerTotalResult()
Method Detail

setCustomerId

public void setCustomerId(java.lang.String customerId)

setName

public void setName(java.lang.String name)

setCurrency

public void setCurrency(java.lang.String currency)

setTotal

public void setTotal(java.math.BigDecimal total)

setNumOfItems

public void setNumOfItems(int numOfItems)

getCustomerId

public java.lang.String getCustomerId()

getName

public java.lang.String getName()

getCurrency

public java.lang.String getCurrency()

getTotal

public java.math.BigDecimal getTotal()

getNumOfItems

public int getNumOfItems()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesOrderItemGroupByPartListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesOrderItemGroupByPartListResult

java.lang.Object
    extended by  bb.common.SalesOrderItemGroupByPartListResult
All Implemented Interfaces:
java.io.Serializable
public class SalesOrderItemGroupByPartListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_INSIP
static java.lang.String | ORDER_BY_INSIPINSO
static java.lang.String | ORDER_BY_NOTSHIPPEDQTY
static java.lang.String | ORDER_BY_ONDEMAND
static java.lang.String | ORDER_BY_ONDEMANDINSO
static java.lang.String | ORDER_BY_ONHAND
static java.lang.String | ORDER_BY_ONORDER
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_SHIPPEDQTY
Constructor Summary
SalesOrderItemGroupByPartListResult()
Method Summary
java.lang.String | getCommodityCode()
java.lang.String | getDescription()
java.math.BigDecimal | getInSIP()
java.math.BigDecimal | getInSIPInSO()
java.math.BigDecimal | getNotShippedQty()
java.math.BigDecimal | getOnDemand()
java.math.BigDecimal | getOnDemandInSO()
java.math.BigDecimal | getOnhand()
java.math.BigDecimal | getOnOrder()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getQuantityOrdered()
java.math.BigDecimal | getQuantityShipped()
java.math.BigDecimal | getShippedQty()
void | setCommodityCode(java.lang.String commodityCode)
void | setDescription(java.lang.String description)
void | setInSIP(java.math.BigDecimal inSIP)
void | setInSIPInSO(java.math.BigDecimal inSIPInSO)
void | setNotShippedQty(java.math.BigDecimal notShippedQty)
void | setOnDemand(java.math.BigDecimal onDemand)
void | setOnDemandInSO(java.math.BigDecimal onDemandInSO)
void | setOnhand(java.math.BigDecimal onhand)
void | setOnOrder(java.math.BigDecimal onOrder)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setQuantityOrdered(java.math.BigDecimal quantityOrdered)
void | setQuantityShipped(java.math.BigDecimal quantityShipped)
void | setShippedQty(java.math.BigDecimal shippedQty)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_ONHAND

public static final java.lang.String ORDER_BY_ONHAND
See Also:
Constant Field Values

ORDER_BY_ONORDER

public static final java.lang.String ORDER_BY_ONORDER
See Also:
Constant Field Values

ORDER_BY_ONDEMAND

public static final java.lang.String ORDER_BY_ONDEMAND
See Also:
Constant Field Values

ORDER_BY_ONDEMANDINSO

public static final java.lang.String ORDER_BY_ONDEMANDINSO
See Also:
Constant Field Values

ORDER_BY_INSIP

public static final java.lang.String ORDER_BY_INSIP
See Also:
Constant Field Values

ORDER_BY_INSIPINSO

public static final java.lang.String ORDER_BY_INSIPINSO
See Also:
Constant Field Values

ORDER_BY_NOTSHIPPEDQTY

public static final java.lang.String ORDER_BY_NOTSHIPPEDQTY
See Also:
Constant Field Values

ORDER_BY_SHIPPEDQTY

public static final java.lang.String ORDER_BY_SHIPPEDQTY
See Also:
Constant Field Values
Constructor Detail

SalesOrderItemGroupByPartListResult

public SalesOrderItemGroupByPartListResult()
Method Detail

getOnOrder

public java.math.BigDecimal getOnOrder()

setOnOrder

public void setOnOrder(java.math.BigDecimal onOrder)

getOnDemand

public java.math.BigDecimal getOnDemand()

setOnDemand

public void setOnDemand(java.math.BigDecimal onDemand)

getOnDemandInSO

public java.math.BigDecimal getOnDemandInSO()

setOnDemandInSO

public void setOnDemandInSO(java.math.BigDecimal onDemandInSO)

getInSIP

public java.math.BigDecimal getInSIP()

setInSIP

public void setInSIP(java.math.BigDecimal inSIP)

getInSIPInSO

public java.math.BigDecimal getInSIPInSO()

setInSIPInSO

public void setInSIPInSO(java.math.BigDecimal inSIPInSO)

getNotShippedQty

public java.math.BigDecimal getNotShippedQty()

setNotShippedQty

public void setNotShippedQty(java.math.BigDecimal notShippedQty)

getShippedQty

public java.math.BigDecimal getShippedQty()

setShippedQty

public void setShippedQty(java.math.BigDecimal shippedQty)

getCommodityCode

public java.lang.String getCommodityCode()

setCommodityCode

public void setCommodityCode(java.lang.String commodityCode)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getOnhand

public java.math.BigDecimal getOnhand()

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getQuantityOrdered

public java.math.BigDecimal getQuantityOrdered()

setQuantityOrdered

public void setQuantityOrdered(java.math.BigDecimal quantityOrdered)

getQuantityShipped

public java.math.BigDecimal getQuantityShipped()

setQuantityShipped

public void setQuantityShipped(java.math.BigDecimal quantityShipped)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesOrderItemInfoVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesOrderItemInfoVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SalesOrderItemInfoVO
All Implemented Interfaces:
java.io.Serializable
public class SalesOrderItemInfoVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SalesOrderItemInfoVO()
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getAccountReceivableDiscount()
java.math.BigDecimal | getAccountReceivableOpen()
java.math.BigDecimal | getAccountReceivableShip()
java.math.BigDecimal | getAccountReceivableSub()
java.math.BigDecimal | getAccountReceivableTax()
java.util.Date | getActual()
java.math.BigDecimal | getArTotal()
java.lang.String | getChangeOrder()
java.math.BigDecimal | getCost()
int | getDelayDays()
java.util.Date | getDeliveryDate()
java.util.Date | getDesiredDate()
java.math.BigDecimal | getDiscount()
java.lang.String | getDiscountCode()
java.lang.String | getDwg()
java.math.BigDecimal | getExtendPrice()
java.math.BigDecimal | getHqa()
java.lang.String | getLocate()
java.lang.String | getMfg()
java.lang.String | getModelNumber()
java.lang.String | getMpn()
java.util.Date | getOriginal()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
SalesOrderItemPK | getPk()
java.math.BigDecimal | getPricePerUnit()
java.lang.String | getPriority()
java.lang.String | getQr()
java.math.BigDecimal | getQuantityOrdered()
java.math.BigDecimal | getQuantityShipped()
java.lang.String | getReferenceDoc1()
java.lang.String | getReferenceDoc2()
java.lang.String | getRevision()
java.lang.String | getSalesItemDescription()
java.lang.String | getSalesOrderItemComments()
java.lang.String | getSalesOrderItemPrivateNotes()
java.lang.String | getShippingStatus()
java.lang.String | getShipVia()
java.math.BigDecimal | getSipQty()
java.lang.String | getStatus()
java.math.BigDecimal | getTaxRate()
java.lang.String | getUnit()
java.lang.Integer | getVersion()
int | hashCode()
void | setAccountReceivableDiscount(java.math.BigDecimal accountReceivableDiscount)
void | setAccountReceivableOpen(java.math.BigDecimal accountReceivableOpen)
void | setAccountReceivableShip(java.math.BigDecimal accountReceivableShip)
void | setAccountReceivableSub(java.math.BigDecimal accountReceivableSub)
void | setAccountReceivableTax(java.math.BigDecimal accountReceivableTax)
void | setActual(java.util.Date actual)
void | setArTotal(java.math.BigDecimal arTotal)
void | setChangeOrder(java.lang.String changeOrder)
void | setCost(java.math.BigDecimal cost)
void | setDelayDays(int delayDays)
void | setDeliveryDate(java.util.Date deliveryDate)
void | setDesiredDate(java.util.Date desiredDate)
void | setDiscount(java.math.BigDecimal discount)
void | setDiscountCode(java.lang.String discountCode)
void | setDwg(java.lang.String dwg)
void | setExtendPrice(java.math.BigDecimal extendPrice)
void | setHqa(java.math.BigDecimal hqa)
void | setLocate(java.lang.String locate)
void | setMfg(java.lang.String mfg)
void | setModelNumber(java.lang.String modelNumber)
void | setMpn(java.lang.String mpn)
void | setOriginal(java.util.Date original)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(SalesOrderItemPK pk)
void | setPricePerUnit(java.math.BigDecimal pricePerUnit)
void | setPriority(java.lang.String priority)
void | setQr(java.lang.String qr)
void | setQuantityOrdered(java.math.BigDecimal quantityOrdered)
void | setQuantityShipped(java.math.BigDecimal quantityShipped)
void | setReferenceDoc1(java.lang.String referenceDoc1)
void | setReferenceDoc2(java.lang.String referenceDoc2)
void | setRevision(java.lang.String revision)
void | setSalesItemDescription(java.lang.String salesItemDescription)
void | setSalesOrderItemComments(java.lang.String salesOrderItemComments)
void | setSalesOrderItemPrivateNotes(java.lang.String salesOrderItemPrivateNotes)
void | setShippingStatus(java.lang.String shippingStatus)
void | setShipVia(java.lang.String shipVia)
void | setSipQty(java.math.BigDecimal sipQty)
void | setStatus(java.lang.String status)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setUnit(java.lang.String unit)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SalesOrderItemInfoVO

public SalesOrderItemInfoVO()
Method Detail

getPk

public SalesOrderItemPK getPk()

setPk

public void setPk(SalesOrderItemPK pk)

getAccountReceivableSub

public java.math.BigDecimal getAccountReceivableSub()

setAccountReceivableSub

public void setAccountReceivableSub(java.math.BigDecimal accountReceivableSub)

getAccountReceivableDiscount

public java.math.BigDecimal getAccountReceivableDiscount()

setAccountReceivableDiscount

public void setAccountReceivableDiscount(java.math.BigDecimal accountReceivableDiscount)

getExtendPrice

public java.math.BigDecimal getExtendPrice()

setExtendPrice

public void setExtendPrice(java.math.BigDecimal extendPrice)

getAccountReceivableShip

public java.math.BigDecimal getAccountReceivableShip()

setAccountReceivableShip

public void setAccountReceivableShip(java.math.BigDecimal accountReceivableShip)

getAccountReceivableOpen

public java.math.BigDecimal getAccountReceivableOpen()

setAccountReceivableOpen

public void setAccountReceivableOpen(java.math.BigDecimal accountReceivableOpen)

getAccountReceivableTax

public java.math.BigDecimal getAccountReceivableTax()

setAccountReceivableTax

public void setAccountReceivableTax(java.math.BigDecimal accountReceivableTax)

getArTotal

public java.math.BigDecimal getArTotal()

setArTotal

public void setArTotal(java.math.BigDecimal arTotal)

getReferenceDoc1

public java.lang.String getReferenceDoc1()

setReferenceDoc1

public void setReferenceDoc1(java.lang.String referenceDoc1)

getReferenceDoc2

public java.lang.String getReferenceDoc2()

setReferenceDoc2

public void setReferenceDoc2(java.lang.String referenceDoc2)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getQr

public java.lang.String getQr()

setQr

public void setQr(java.lang.String qr)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getDeliveryDate

public java.util.Date getDeliveryDate()

setDeliveryDate

public void setDeliveryDate(java.util.Date deliveryDate)

getDesiredDate

public java.util.Date getDesiredDate()

setDesiredDate

public void setDesiredDate(java.util.Date desiredDate)

getDelayDays

public int getDelayDays()

setDelayDays

public void setDelayDays(int delayDays)

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getOriginal

public java.util.Date getOriginal()

setOriginal

public void setOriginal(java.util.Date original)

getActual

public java.util.Date getActual()

setActual

public void setActual(java.util.Date actual)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getDwg

public java.lang.String getDwg()

setDwg

public void setDwg(java.lang.String dwg)

getQuantityOrdered

public java.math.BigDecimal getQuantityOrdered()

setQuantityOrdered

public void setQuantityOrdered(java.math.BigDecimal quantityOrdered)

getQuantityShipped

public java.math.BigDecimal getQuantityShipped()

setQuantityShipped

public void setQuantityShipped(java.math.BigDecimal quantityShipped)

getHqa

public java.math.BigDecimal getHqa()

setHqa

public void setHqa(java.math.BigDecimal hqa)

getCost

public java.math.BigDecimal getCost()

setCost

public void setCost(java.math.BigDecimal cost)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getPricePerUnit

public java.math.BigDecimal getPricePerUnit()

setPricePerUnit

public void setPricePerUnit(java.math.BigDecimal pricePerUnit)

getDiscountCode

public java.lang.String getDiscountCode()

setDiscountCode

public void setDiscountCode(java.lang.String discountCode)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getSalesItemDescription

public java.lang.String getSalesItemDescription()

setSalesItemDescription

public void setSalesItemDescription(java.lang.String salesItemDescription)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getSalesOrderItemComments

public java.lang.String getSalesOrderItemComments()

setSalesOrderItemComments

public void setSalesOrderItemComments(java.lang.String salesOrderItemComments)

getSalesOrderItemPrivateNotes

public java.lang.String getSalesOrderItemPrivateNotes()

setSalesOrderItemPrivateNotes

public void setSalesOrderItemPrivateNotes(java.lang.String salesOrderItemPrivateNotes)

getVersion

public java.lang.Integer getVersion()

getShippingStatus

public java.lang.String getShippingStatus()

getSipQty

public java.math.BigDecimal getSipQty()

setVersion

public void setVersion(java.lang.Integer version)

setShippingStatus

public void setShippingStatus(java.lang.String shippingStatus)

setSipQty

public void setSipQty(java.math.BigDecimal sipQty)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesOrderItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesOrderItemListResult

java.lang.Object
    extended by  bb.common.SalesOrderItemListResult
All Implemented Interfaces:
java.io.Serializable
public class SalesOrderItemListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
java.lang.String | invoiceStatus
java.lang.String | lastInvoiceNumber
static java.lang.String | ORDER_BY_ACCOUNTNUMBER
static java.lang.String | ORDER_BY_ARRIVEDATE
static java.lang.String | ORDER_BY_COMMODITYCODE
static java.lang.String | ORDER_BY_COMPANYNUITID
static java.lang.String | ORDER_BY_COUNTRY
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_CUSTOMERPO
static java.lang.String | ORDER_BY_DELIVERYDATE
static java.lang.String | ORDER_BY_INCOTERM
static java.lang.String | ORDER_BY_INCOTERMPLACEPORT
static java.lang.String | ORDER_BY_ITEMDESCRIPTION
static java.lang.String | ORDER_BY_LASTSHIPPEDDATE
static java.lang.String | ORDER_BY_ORIGINALDELIVERY
static java.lang.String | ORDER_BY_PARTORASSY
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_PRODUCTCODE
static java.lang.String | ORDER_BY_PROJECTNAME
static java.lang.String | ORDER_BY_REGINON
static java.lang.String | ORDER_BY_RELATEDDOC
static java.lang.String | ORDER_BY_SALESCODEID
static java.lang.String | ORDER_BY_SALESMAN
static java.lang.String | ORDER_BY_SHIPVIA
static java.lang.String | ORDER_BY_SODATE
static java.lang.String | ORDER_BY_SONUMBER
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_TERRITORY
java.lang.String | region
Constructor Summary
SalesOrderItemListResult()
Method Summary
java.lang.String | getAccountNumber()
java.math.BigDecimal | getAccountReceivableOpen()
java.math.BigDecimal | getAccountReceivableShip()
java.util.Date | getArriveDate()
java.lang.String | getComment()
java.lang.String | getCommodityCode()
java.lang.String | getCompanyUnitId()
java.lang.String | getCountry()
java.lang.String | getCurrency()
java.lang.String | getCustomerId()
java.lang.String | getCustomerPo()
int | getDelayDays()
java.util.Date | getDeliveryDate()
java.math.BigDecimal | getDiscount()
java.math.BigDecimal | getExtendPrice()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getInvoiceStatus()
java.lang.String | getItemDescription()
java.lang.String | getLastInvoiceNumber()
java.util.Date | getLastShippedDate()
java.lang.String | getMfg()
java.lang.String | getMpn()
java.math.BigDecimal | getOnDemandQty()
java.math.BigDecimal | getOnHandQty()
java.math.BigDecimal | getOnOrderQty()
java.math.BigDecimal | getOrderedQty()
java.util.Date | getOriginalDelivery()
java.lang.String | getPartFrom()
java.lang.String | getPartOrAssy()
PartPK | getPartPk()
java.math.BigDecimal | getPricePerUnit()
java.lang.String | getProductCode()
java.lang.String | getProjectName()
java.util.Set | getRefDocOnes()
java.util.Set | getRefDocTwoes()
java.lang.String | getRegion()
java.lang.String | getRelatedDoc()
java.lang.String | getSalesCodeId()
java.lang.String | getSalesman()
java.math.BigDecimal | getShippedQty()
java.lang.String | getShipVia()
java.math.BigDecimal | getShortAgeQty()
java.math.BigDecimal | getSipQty()
java.math.BigDecimal | getSitQty()
java.util.Date | getSoDate()
java.lang.String | getSoItemNumber()
java.lang.String | getSoNumber()
java.math.BigDecimal | getSoSipQty()
java.lang.String | getState()
java.lang.String | getStatus()
java.math.BigDecimal | getSubTotal()
java.lang.String | getTerritory()
java.lang.String | getUnit()
java.math.BigDecimal | getWipQty()
void | setAccountNumber(java.lang.String accountNumber)
void | setAccountReceivableOpen(java.math.BigDecimal accountReceivableOpen)
void | setAccountReceivableShip(java.math.BigDecimal accountReceivableShip)
void | setArriveDate(java.util.Date arriveDate)
void | setComment(java.lang.String comment)
void | setCommodityCode(java.lang.String commodityCode)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCountry(java.lang.String country)
void | setCurrency(java.lang.String currency)
void | setCustomerId(java.lang.String customerId)
void | setCustomerPo(java.lang.String customerPo)
void | setDelayDays(int delayDays)
void | setDeliveryDate(java.util.Date deliveryDate)
void | setDiscount(java.math.BigDecimal discount)
void | setExtendPrice(java.math.BigDecimal extendPrice)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setInvoiceStatus(java.lang.String invoiceStatus)
void | setItemDescription(java.lang.String itemDescription)
void | setLastInvoiceNumber(java.lang.String lastInvoiceNumber)
void | setLastShippedDate(java.util.Date lastShippedDate)
void | setMfg(java.lang.String mfg)
void | setMpn(java.lang.String mpn)
void | setOnDemandQty(java.math.BigDecimal onDemandQty)
void | setOnHandQty(java.math.BigDecimal onHandQty)
void | setOnOrderQty(java.math.BigDecimal onOrderQty)
void | setOrderedQty(java.math.BigDecimal orderedQty)
void | setOriginalDelivery(java.util.Date originalDelivery)
void | setPartFrom(java.lang.String partFrom)
void | setPartOrAssy(java.lang.String partOrAssy)
void | setPartPk(PartPK partPk)
void | setPricePerUnit(java.math.BigDecimal pricePerUnit)
void | setProductCode(java.lang.String productCode)
void | setProjectName(java.lang.String projectName)
void | setRefDocOnes(java.util.Set refDocOnes)
void | setRefDocTwoes(java.util.Set refDocTwoes)
void | setRegion(java.lang.String region)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setSalesCodeId(java.lang.String salesCodeId)
void | setSalesman(java.lang.String salesman)
void | setShippedQty(java.math.BigDecimal shippedQty)
void | setShipVia(java.lang.String shipVia)
void | setShortAgeQty(java.math.BigDecimal shortAgeQty)
void | setSipQty(java.math.BigDecimal sipQty)
void | setSitQty(java.math.BigDecimal sitQty)
void | setSoDate(java.util.Date soDate)
void | setSoItemNumber(java.lang.String soItemNumber)
void | setSoNumber(java.lang.String soNumber)
void | setSoSipQty(java.math.BigDecimal soSipQty)
void | setState(java.lang.String state)
void | setStatus(java.lang.String status)
void | setTerritory(java.lang.String territory)
void | setUnit(java.lang.String unit)
void | setWipQty(java.math.BigDecimal wipQty)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_SONUMBER

public static final java.lang.String ORDER_BY_SONUMBER
See Also:
Constant Field Values

ORDER_BY_SODATE

public static final java.lang.String ORDER_BY_SODATE
See Also:
Constant Field Values

ORDER_BY_DELIVERYDATE

public static final java.lang.String ORDER_BY_DELIVERYDATE
See Also:
Constant Field Values

ORDER_BY_ARRIVEDATE

public static final java.lang.String ORDER_BY_ARRIVEDATE
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_ITEMDESCRIPTION

public static final java.lang.String ORDER_BY_ITEMDESCRIPTION
See Also:
Constant Field Values

ORDER_BY_ORIGINALDELIVERY

public static final java.lang.String ORDER_BY_ORIGINALDELIVERY
See Also:
Constant Field Values

ORDER_BY_SHIPVIA

public static final java.lang.String ORDER_BY_SHIPVIA
See Also:
Constant Field Values

ORDER_BY_SALESMAN

public static final java.lang.String ORDER_BY_SALESMAN
See Also:
Constant Field Values

ORDER_BY_CUSTOMERPO

public static final java.lang.String ORDER_BY_CUSTOMERPO
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_PARTORASSY

public static final java.lang.String ORDER_BY_PARTORASSY
See Also:
Constant Field Values

ORDER_BY_PRODUCTCODE

public static final java.lang.String ORDER_BY_PRODUCTCODE
See Also:
Constant Field Values

ORDER_BY_LASTSHIPPEDDATE

public static final java.lang.String ORDER_BY_LASTSHIPPEDDATE
See Also:
Constant Field Values

ORDER_BY_PROJECTNAME

public static final java.lang.String ORDER_BY_PROJECTNAME
See Also:
Constant Field Values

ORDER_BY_SALESCODEID

public static final java.lang.String ORDER_BY_SALESCODEID
See Also:
Constant Field Values

ORDER_BY_ACCOUNTNUMBER

public static final java.lang.String ORDER_BY_ACCOUNTNUMBER
See Also:
Constant Field Values

ORDER_BY_COMPANYNUITID

public static final java.lang.String ORDER_BY_COMPANYNUITID
See Also:
Constant Field Values

ORDER_BY_REGINON

public static final java.lang.String ORDER_BY_REGINON
See Also:
Constant Field Values

ORDER_BY_TERRITORY

public static final java.lang.String ORDER_BY_TERRITORY
See Also:
Constant Field Values

ORDER_BY_COUNTRY

public static final java.lang.String ORDER_BY_COUNTRY
See Also:
Constant Field Values

ORDER_BY_RELATEDDOC

public static final java.lang.String ORDER_BY_RELATEDDOC
See Also:
Constant Field Values

ORDER_BY_COMMODITYCODE

public static final java.lang.String ORDER_BY_COMMODITYCODE
See Also:
Constant Field Values

ORDER_BY_INCOTERMPLACEPORT

public static final java.lang.String ORDER_BY_INCOTERMPLACEPORT
See Also:
Constant Field Values

ORDER_BY_INCOTERM

public static final java.lang.String ORDER_BY_INCOTERM
See Also:
Constant Field Values

region

public java.lang.String region

lastInvoiceNumber

public java.lang.String lastInvoiceNumber

invoiceStatus

public java.lang.String invoiceStatus
Constructor Detail

SalesOrderItemListResult

public SalesOrderItemListResult()
Method Detail

getRefDocOnes

public java.util.Set getRefDocOnes()

setRefDocOnes

public void setRefDocOnes(java.util.Set refDocOnes)

getRefDocTwoes

public java.util.Set getRefDocTwoes()

setRefDocTwoes

public void setRefDocTwoes(java.util.Set refDocTwoes)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getLastShippedDate

public java.util.Date getLastShippedDate()

setLastShippedDate

public void setLastShippedDate(java.util.Date lastShippedDate)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getPartOrAssy

public java.lang.String getPartOrAssy()

setPartOrAssy

public void setPartOrAssy(java.lang.String partOrAssy)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getAccountReceivableOpen

public java.math.BigDecimal getAccountReceivableOpen()

setAccountReceivableOpen

public void setAccountReceivableOpen(java.math.BigDecimal accountReceivableOpen)

getAccountReceivableShip

public java.math.BigDecimal getAccountReceivableShip()

setAccountReceivableShip

public void setAccountReceivableShip(java.math.BigDecimal accountReceivableShip)

getExtendPrice

public java.math.BigDecimal getExtendPrice()

setExtendPrice

public void setExtendPrice(java.math.BigDecimal extendPrice)

getOnDemandQty

public java.math.BigDecimal getOnDemandQty()

getStatus

public java.lang.String getStatus()

getShipVia

public java.lang.String getShipVia()

getCustomerPo

public java.lang.String getCustomerPo()

getCustomerId

public java.lang.String getCustomerId()

getDiscount

public java.math.BigDecimal getDiscount()

getPricePerUnit

public java.math.BigDecimal getPricePerUnit()

getShippedQty

public java.math.BigDecimal getShippedQty()

getOrderedQty

public java.math.BigDecimal getOrderedQty()

getDeliveryDate

public java.util.Date getDeliveryDate()

getSoDate

public java.util.Date getSoDate()

getItemDescription

public java.lang.String getItemDescription()

getPartPk

public PartPK getPartPk()

getSoItemNumber

public java.lang.String getSoItemNumber()

setSoNumber

public void setSoNumber(java.lang.String soNumber)

setOnDemandQty

public void setOnDemandQty(java.math.BigDecimal onDemandQty)

setStatus

public void setStatus(java.lang.String status)

setShipVia

public void setShipVia(java.lang.String shipVia)

setCustomerPo

public void setCustomerPo(java.lang.String customerPo)

setCustomerId

public void setCustomerId(java.lang.String customerId)

setDiscount

public void setDiscount(java.math.BigDecimal discount)

setPricePerUnit

public void setPricePerUnit(java.math.BigDecimal pricePerUnit)

setShippedQty

public void setShippedQty(java.math.BigDecimal shippedQty)

setOrderedQty

public void setOrderedQty(java.math.BigDecimal orderedQty)

setDeliveryDate

public void setDeliveryDate(java.util.Date deliveryDate)

setSoDate

public void setSoDate(java.util.Date soDate)

setItemDescription

public void setItemDescription(java.lang.String itemDescription)

setPartPk

public void setPartPk(PartPK partPk)

setSoItemNumber

public void setSoItemNumber(java.lang.String soItemNumber)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setSalesman

public void setSalesman(java.lang.String salesman)

setUnit

public void setUnit(java.lang.String unit)

setSipQty

public void setSipQty(java.math.BigDecimal sipQty)

setOriginalDelivery

public void setOriginalDelivery(java.util.Date originalDelivery)

setWipQty

public void setWipQty(java.math.BigDecimal wipQty)

setDelayDays

public void setDelayDays(int delayDays)

setShortAgeQty

public void setShortAgeQty(java.math.BigDecimal shortAgeQty)

getSoNumber

public java.lang.String getSoNumber()

getPartFrom

public java.lang.String getPartFrom()

getSalesman

public java.lang.String getSalesman()

getUnit

public java.lang.String getUnit()

getSipQty

public java.math.BigDecimal getSipQty()

getOriginalDelivery

public java.util.Date getOriginalDelivery()

getWipQty

public java.math.BigDecimal getWipQty()

getDelayDays

public int getDelayDays()

getShortAgeQty

public java.math.BigDecimal getShortAgeQty()

getSitQty

public java.math.BigDecimal getSitQty()

setSitQty

public void setSitQty(java.math.BigDecimal sitQty)

getSoSipQty

public java.math.BigDecimal getSoSipQty()

setSoSipQty

public void setSoSipQty(java.math.BigDecimal soSipQty)

getArriveDate

public java.util.Date getArriveDate()

setArriveDate

public void setArriveDate(java.util.Date arriveDate)

getProductCode

public java.lang.String getProductCode()

setProductCode

public void setProductCode(java.lang.String productCode)

getProjectName

public java.lang.String getProjectName()

setProjectName

public void setProjectName(java.lang.String projectName)

getSalesCodeId

public java.lang.String getSalesCodeId()

setSalesCodeId

public void setSalesCodeId(java.lang.String salesCodeId)

getOnHandQty

public java.math.BigDecimal getOnHandQty()

setOnHandQty

public void setOnHandQty(java.math.BigDecimal onHandQty)

getOnOrderQty

public java.math.BigDecimal getOnOrderQty()

setOnOrderQty

public void setOnOrderQty(java.math.BigDecimal onOrderQty)

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getInvoiceStatus

public java.lang.String getInvoiceStatus()

setInvoiceStatus

public void setInvoiceStatus(java.lang.String invoiceStatus)

getLastInvoiceNumber

public java.lang.String getLastInvoiceNumber()

setLastInvoiceNumber

public void setLastInvoiceNumber(java.lang.String lastInvoiceNumber)

getRegion

public java.lang.String getRegion()

setRegion

public void setRegion(java.lang.String region)

getState

public java.lang.String getState()

setState

public void setState(java.lang.String state)

getTerritory

public java.lang.String getTerritory()

setTerritory

public void setTerritory(java.lang.String territory)

getCountry

public java.lang.String getCountry()

setCountry

public void setCountry(java.lang.String country)

getComment

public java.lang.String getComment()

setComment

public void setComment(java.lang.String comment)

getCommodityCode

public java.lang.String getCommodityCode()

setCommodityCode

public void setCommodityCode(java.lang.String commodityCode)

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncoterm

public java.lang.String getIncoterm()

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getSubTotal

public java.math.BigDecimal getSubTotal()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesOrderItemManufacturerPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesOrderItemManufacturerPK

java.lang.Object
    extended by  bb.common.SalesOrderItemManufacturerPK
All Implemented Interfaces:
java.io.Serializable
public class SalesOrderItemManufacturerPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
SalesOrderItemManufacturerPK()
default constructor
SalesOrderItemManufacturerPK(java.lang.String salesOrderNumber, java.lang.String salesOrderItemNumber, java.lang.Short ii)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Short | getIi()
java.lang.String | getSalesOrderItemNumber()
java.lang.String | getSalesOrderNumber()
int | hashCode()
void | setIi(java.lang.Short ii)
void | setSalesOrderItemNumber(java.lang.String salesOrderItemNumber)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SalesOrderItemManufacturerPK

public SalesOrderItemManufacturerPK(java.lang.String salesOrderNumber,
                                    java.lang.String salesOrderItemNumber,
                                    java.lang.Short ii)
full constructor

SalesOrderItemManufacturerPK

public SalesOrderItemManufacturerPK()
default constructor

Method Detail

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getSalesOrderItemNumber

public java.lang.String getSalesOrderItemNumber()

setSalesOrderItemNumber

public void setSalesOrderItemNumber(java.lang.String salesOrderItemNumber)

getIi

public java.lang.Short getIi()

setIi

public void setIi(java.lang.Short ii)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesOrderItemManufacturerVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesOrderItemManufacturerVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SalesOrderItemManufacturerVO
All Implemented Interfaces:
java.io.Serializable
public class SalesOrderItemManufacturerVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SalesOrderItemManufacturerVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getManufacturerName()
java.lang.String | getManufacturerPartNumber()
SalesOrderItemManufacturerPK | getPk()
int | hashCode()
void | setManufacturerName(java.lang.String manufacturerName)
void | setManufacturerPartNumber(java.lang.String manufacturerPartNumber)
void | setPk(SalesOrderItemManufacturerPK pk)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SalesOrderItemManufacturerVO

public SalesOrderItemManufacturerVO()
Method Detail

getPk

public SalesOrderItemManufacturerPK getPk()

setPk

public void setPk(SalesOrderItemManufacturerPK pk)

getManufacturerName

public java.lang.String getManufacturerName()

setManufacturerName

public void setManufacturerName(java.lang.String manufacturerName)

getManufacturerPartNumber

public java.lang.String getManufacturerPartNumber()

setManufacturerPartNumber

public void setManufacturerPartNumber(java.lang.String manufacturerPartNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesOrderItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesOrderItemPK

java.lang.Object
    extended by  bb.common.SalesOrderItemPK
All Implemented Interfaces:
java.io.Serializable
public class SalesOrderItemPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
SalesOrderItemPK()
default constructor
SalesOrderItemPK(java.lang.String salesOrderNumber, java.lang.String salesOrderItemNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getSalesOrderItemNumber()
java.lang.String | getSalesOrderNumber()
int | hashCode()
void | setSalesOrderItemNumber(java.lang.String salesOrderItemNumber)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SalesOrderItemPK

public SalesOrderItemPK(java.lang.String salesOrderNumber,
                        java.lang.String salesOrderItemNumber)
full constructor

SalesOrderItemPK

public SalesOrderItemPK()
default constructor

Method Detail

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getSalesOrderItemNumber

public java.lang.String getSalesOrderItemNumber()

setSalesOrderItemNumber

public void setSalesOrderItemNumber(java.lang.String salesOrderItemNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesOrderItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesOrderItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SalesOrderItemVO
All Implemented Interfaces:
java.io.Serializable
public class SalesOrderItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SalesOrderItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getAccountReceivableDiscount()
java.math.BigDecimal | getAccountReceivableOpen()
java.math.BigDecimal | getAccountReceivableShip()
java.math.BigDecimal | getAccountReceivableSub()
java.math.BigDecimal | getAccountReceivableTax()
java.util.Date | getActual()
java.lang.String | getArInvoiceNumber()
java.util.Date | getArriveDate()
java.math.BigDecimal | getArTotal()
java.lang.String | getBill()
java.lang.String | getChangeOrder()
java.lang.String | getCommodityCode()
java.math.BigDecimal | getCost()
java.math.BigDecimal | getCostPerUnitWithTax()
int | getDelayDays()
java.util.Date | getDeliveryDate()
java.util.Date | getDesiredDate()
java.math.BigDecimal | getDiscount()
java.lang.String | getDiscountCode()
java.lang.String | getDwg()
java.math.BigDecimal | getExtendPrice()
java.math.BigDecimal | getHqa()
java.lang.String | getLocate()
java.math.BigDecimal | getMargin()
java.math.BigDecimal | getMarginByStdCost()
java.math.BigDecimal | getMarginPercent()
java.math.BigDecimal | getMarginPercentByStdCost()
java.lang.String | getMfg()
java.lang.String | getModelNumber()
java.lang.String | getMpn()
java.util.Date | getOriginal()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
SalesOrderItemPK | getPk()
java.math.BigDecimal | getPricePerUnit()
java.lang.String | getPriority()
java.lang.String | getProductCode()
java.lang.String | getQr()
java.math.BigDecimal | getQuantityOrdered()
java.math.BigDecimal | getQuantityShipped()
java.util.Set | getRefDocOnes()
java.util.Set | getRefDocTwoes()
java.lang.String | getReferenceDoc1()
java.lang.String | getReferenceDoc2()
java.lang.String | getRevision()
java.lang.String | getSalesItemDescription()
java.lang.String | getSalesOrderItemComments()
java.util.Set | getSalesOrderItemManufacturer()
java.lang.String | getSalesOrderItemPrivateNotes()
java.math.BigDecimal | getSalesPrice()
java.math.BigDecimal | getSalesQty()
java.lang.String | getSalesUnit()
java.lang.String | getShippingStatus()
java.lang.String | getShipVia()
java.math.BigDecimal | getSipQty()
java.lang.String | getStatus()
java.math.BigDecimal | getStdCost()
java.math.BigDecimal | getTaxRate()
java.lang.String | getTraceable()
java.lang.Byte | getTraceableLevel()
java.lang.String | getUnit()
java.lang.Integer | getVersion()
int | hashCode()
boolean | isUsePriceWithTax()
void | setAccountReceivableDiscount(java.math.BigDecimal accountReceivableDiscount)
void | setAccountReceivableOpen(java.math.BigDecimal accountReceivableOpen)
void | setAccountReceivableShip(java.math.BigDecimal accountReceivableShip)
void | setAccountReceivableSub(java.math.BigDecimal accountReceivableSub)
void | setAccountReceivableTax(java.math.BigDecimal accountReceivableTax)
void | setActual(java.util.Date actual)
void | setArInvoiceNumber(java.lang.String arInvoiceNumber)
void | setArriveDate(java.util.Date arriveDate)
void | setArTotal(java.math.BigDecimal arTotal)
void | setBill(java.lang.String bill)
void | setChangeOrder(java.lang.String changeOrder)
void | setCommodityCode(java.lang.String commodityCode)
void | setCost(java.math.BigDecimal cost)
void | setCostPerUnitWithTax(java.math.BigDecimal costPerUnitWithTax)
void | setDelayDays(int delayDays)
void | setDeliveryDate(java.util.Date deliveryDate)
void | setDesiredDate(java.util.Date desiredDate)
void | setDiscount(java.math.BigDecimal discount)
void | setDiscountCode(java.lang.String discountCode)
void | setDwg(java.lang.String dwg)
void | setExtendPrice(java.math.BigDecimal extendPrice)
void | setHqa(java.math.BigDecimal hqa)
void | setLocate(java.lang.String locate)
void | setMargin(java.math.BigDecimal margin)
void | setMarginByStdCost(java.math.BigDecimal marginByStdCost)
void | setMarginPercent(java.math.BigDecimal marginPercent)
void | setMarginPercentByStdCost(java.math.BigDecimal marginPercentByStdCost)
void | setMfg(java.lang.String mfg)
void | setModelNumber(java.lang.String modelNumber)
void | setMpn(java.lang.String mpn)
void | setOriginal(java.util.Date original)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(SalesOrderItemPK pk)
void | setPricePerUnit(java.math.BigDecimal pricePerUnit)
void | setPriority(java.lang.String priority)
void | setProductCode(java.lang.String productCode)
void | setQr(java.lang.String qr)
void | setQuantityOrdered(java.math.BigDecimal quantityOrdered)
void | setQuantityShipped(java.math.BigDecimal quantityShipped)
void | setRefDocOnes(java.util.Set refDocOnes)
void | setRefDocTwoes(java.util.Set refDocTwoes)
void | setReferenceDoc1(java.lang.String referenceDoc1)
void | setReferenceDoc2(java.lang.String referenceDoc2)
void | setRevision(java.lang.String revision)
void | setSalesItemDescription(java.lang.String salesItemDescription)
void | setSalesOrderItemComments(java.lang.String salesOrderItemComments)
void | setSalesOrderItemManufacturer(java.util.Set salesOrderItemManufacturer)
void | setSalesOrderItemPrivateNotes(java.lang.String salesOrderItemPrivateNotes)
void | setSalesPrice(java.math.BigDecimal salesPrice)
void | setSalesQty(java.math.BigDecimal salesQty)
void | setSalesUnit(java.lang.String salesUnit)
void | setShippingStatus(java.lang.String shippingStatus)
void | setShipVia(java.lang.String shipVia)
void | setSipQty(java.math.BigDecimal sipQty)
void | setStatus(java.lang.String status)
void | setStdCost(java.math.BigDecimal stdCost)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setTraceable(java.lang.String traceable)
void | setTraceableLevel(java.lang.Byte traceableLevel)
void | setUnit(java.lang.String unit)
void | setUsePriceWithTax(boolean usePriceWithTax)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SalesOrderItemVO

public SalesOrderItemVO()
Method Detail

getPk

public SalesOrderItemPK getPk()

setPk

public void setPk(SalesOrderItemPK pk)

getAccountReceivableSub

public java.math.BigDecimal getAccountReceivableSub()

setAccountReceivableSub

public void setAccountReceivableSub(java.math.BigDecimal accountReceivableSub)

getAccountReceivableDiscount

public java.math.BigDecimal getAccountReceivableDiscount()

setAccountReceivableDiscount

public void setAccountReceivableDiscount(java.math.BigDecimal accountReceivableDiscount)

getExtendPrice

public java.math.BigDecimal getExtendPrice()

setExtendPrice

public void setExtendPrice(java.math.BigDecimal extendPrice)

getAccountReceivableShip

public java.math.BigDecimal getAccountReceivableShip()

setAccountReceivableShip

public void setAccountReceivableShip(java.math.BigDecimal accountReceivableShip)

getAccountReceivableOpen

public java.math.BigDecimal getAccountReceivableOpen()

setAccountReceivableOpen

public void setAccountReceivableOpen(java.math.BigDecimal accountReceivableOpen)

getAccountReceivableTax

public java.math.BigDecimal getAccountReceivableTax()

setAccountReceivableTax

public void setAccountReceivableTax(java.math.BigDecimal accountReceivableTax)

getArTotal

public java.math.BigDecimal getArTotal()

setArTotal

public void setArTotal(java.math.BigDecimal arTotal)

getReferenceDoc1

public java.lang.String getReferenceDoc1()

setReferenceDoc1

public void setReferenceDoc1(java.lang.String referenceDoc1)

getReferenceDoc2

public java.lang.String getReferenceDoc2()

setReferenceDoc2

public void setReferenceDoc2(java.lang.String referenceDoc2)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getQr

public java.lang.String getQr()

setQr

public void setQr(java.lang.String qr)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getDeliveryDate

public java.util.Date getDeliveryDate()

setDeliveryDate

public void setDeliveryDate(java.util.Date deliveryDate)

getDesiredDate

public java.util.Date getDesiredDate()

setDesiredDate

public void setDesiredDate(java.util.Date desiredDate)

getDelayDays

public int getDelayDays()

setDelayDays

public void setDelayDays(int delayDays)

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getOriginal

public java.util.Date getOriginal()

setOriginal

public void setOriginal(java.util.Date original)

getActual

public java.util.Date getActual()

setActual

public void setActual(java.util.Date actual)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getDwg

public java.lang.String getDwg()

setDwg

public void setDwg(java.lang.String dwg)

getQuantityOrdered

public java.math.BigDecimal getQuantityOrdered()

setQuantityOrdered

public void setQuantityOrdered(java.math.BigDecimal quantityOrdered)

getQuantityShipped

public java.math.BigDecimal getQuantityShipped()

setQuantityShipped

public void setQuantityShipped(java.math.BigDecimal quantityShipped)

getHqa

public java.math.BigDecimal getHqa()

setHqa

public void setHqa(java.math.BigDecimal hqa)

getCost

public java.math.BigDecimal getCost()

setCost

public void setCost(java.math.BigDecimal cost)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getPricePerUnit

public java.math.BigDecimal getPricePerUnit()

setPricePerUnit

public void setPricePerUnit(java.math.BigDecimal pricePerUnit)

getDiscountCode

public java.lang.String getDiscountCode()

setDiscountCode

public void setDiscountCode(java.lang.String discountCode)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getSalesItemDescription

public java.lang.String getSalesItemDescription()

setSalesItemDescription

public void setSalesItemDescription(java.lang.String salesItemDescription)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getSalesOrderItemComments

public java.lang.String getSalesOrderItemComments()

setSalesOrderItemComments

public void setSalesOrderItemComments(java.lang.String salesOrderItemComments)

getSalesOrderItemPrivateNotes

public java.lang.String getSalesOrderItemPrivateNotes()

setSalesOrderItemPrivateNotes

public void setSalesOrderItemPrivateNotes(java.lang.String salesOrderItemPrivateNotes)

getSalesOrderItemManufacturer

public java.util.Set getSalesOrderItemManufacturer()

getVersion

public java.lang.Integer getVersion()

getShippingStatus

public java.lang.String getShippingStatus()

getRefDocOnes

public java.util.Set getRefDocOnes()

getSipQty

public java.math.BigDecimal getSipQty()

setSalesOrderItemManufacturer

public void setSalesOrderItemManufacturer(java.util.Set salesOrderItemManufacturer)

setVersion

public void setVersion(java.lang.Integer version)

setShippingStatus

public void setShippingStatus(java.lang.String shippingStatus)

getRefDocTwoes

public java.util.Set getRefDocTwoes()

setRefDocTwoes

public void setRefDocTwoes(java.util.Set refDocTwoes)

setRefDocOnes

public void setRefDocOnes(java.util.Set refDocOnes)

setSipQty

public void setSipQty(java.math.BigDecimal sipQty)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getMargin

public java.math.BigDecimal getMargin()

setMargin

public void setMargin(java.math.BigDecimal margin)

getMarginPercent

public java.math.BigDecimal getMarginPercent()

setMarginPercent

public void setMarginPercent(java.math.BigDecimal marginPercent)

getBill

public java.lang.String getBill()

setBill

public void setBill(java.lang.String bill)

getArriveDate

public java.util.Date getArriveDate()

setArriveDate

public void setArriveDate(java.util.Date arriveDate)

getTraceable

public java.lang.String getTraceable()

setTraceable

public void setTraceable(java.lang.String traceable)

getTraceableLevel

public java.lang.Byte getTraceableLevel()

setTraceableLevel

public void setTraceableLevel(java.lang.Byte traceableLevel)

getProductCode

public java.lang.String getProductCode()

setProductCode

public void setProductCode(java.lang.String productCode)

getMarginByStdCost

public java.math.BigDecimal getMarginByStdCost()

setMarginByStdCost

public void setMarginByStdCost(java.math.BigDecimal marginByStdCost)

getMarginPercentByStdCost

public java.math.BigDecimal getMarginPercentByStdCost()

setMarginPercentByStdCost

public void setMarginPercentByStdCost(java.math.BigDecimal marginPercentByStdCost)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getCommodityCode

public java.lang.String getCommodityCode()

setCommodityCode

public void setCommodityCode(java.lang.String commodityCode)

getArInvoiceNumber

public java.lang.String getArInvoiceNumber()

setArInvoiceNumber

public void setArInvoiceNumber(java.lang.String arInvoiceNumber)

getCostPerUnitWithTax

public java.math.BigDecimal getCostPerUnitWithTax()

setCostPerUnitWithTax

public void setCostPerUnitWithTax(java.math.BigDecimal costPerUnitWithTax)

isUsePriceWithTax

public boolean isUsePriceWithTax()

setUsePriceWithTax

public void setUsePriceWithTax(boolean usePriceWithTax)

getSalesPrice

public java.math.BigDecimal getSalesPrice()

setSalesPrice

public void setSalesPrice(java.math.BigDecimal salesPrice)

getSalesQty

public java.math.BigDecimal getSalesQty()

setSalesQty

public void setSalesQty(java.math.BigDecimal salesQty)

getSalesUnit

public java.lang.String getSalesUnit()

setSalesUnit

public void setSalesUnit(java.lang.String salesUnit)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesOrderListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesOrderListResult

java.lang.Object
    extended by  bb.common.SalesOrderListResult
All Implemented Interfaces:
java.io.Serializable
public class SalesOrderListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_CUSTOMERNAME
static java.lang.String | ORDER_BY_CUSTOMERPO
static java.lang.String | ORDER_BY_PROJECT
static java.lang.String | ORDER_BY_RELATEDDOCUMENT
static java.lang.String | ORDER_BY_SALESMAN
static java.lang.String | ORDER_BY_SODATE
static java.lang.String | ORDER_BY_SONUMBER
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
SalesOrderListResult()
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getArPrepay()
java.math.BigDecimal | getArPrepayGl()
java.lang.String | getChangeOrder()
java.lang.String | getComments()
java.lang.String | getCurrency()
java.lang.String | getCustomerId()
java.lang.String | getCustomerName()
java.lang.String | getCustomerPo()
java.math.BigDecimal | getGrantTotal()
java.lang.String | getPrivateNote()
java.lang.String | getProject()
java.lang.String | getRelatedDocument()
java.lang.String | getSalesman()
java.util.Date | getSoDate()
java.lang.String | getSoNumber()
java.lang.String | getStatus()
int | hashCode()
void | setArPrepay(java.math.BigDecimal arPrepay)
void | setArPrepayGl(java.math.BigDecimal arPrepayGl)
void | setChangeOrder(java.lang.String changeOrder)
void | setComments(java.lang.String comments)
void | setCurrency(java.lang.String currency)
void | setCustomerId(java.lang.String customerId)
void | setCustomerName(java.lang.String customerName)
void | setCustomerPo(java.lang.String customerPo)
void | setGrantTotal(java.math.BigDecimal grantTotal)
void | setPrivateNote(java.lang.String privateNote)
void | setProject(java.lang.String project)
void | setRelatedDocument(java.lang.String relatedDocument)
void | setSalesman(java.lang.String salesman)
void | setSoDate(java.util.Date soDate)
void | setSoNumber(java.lang.String soNumber)
void | setStatus(java.lang.String status)
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_SONUMBER

public static final java.lang.String ORDER_BY_SONUMBER
See Also:
Constant Field Values

ORDER_BY_SODATE

public static final java.lang.String ORDER_BY_SODATE
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_CUSTOMERPO

public static final java.lang.String ORDER_BY_CUSTOMERPO
See Also:
Constant Field Values

ORDER_BY_PROJECT

public static final java.lang.String ORDER_BY_PROJECT
See Also:
Constant Field Values

ORDER_BY_SALESMAN

public static final java.lang.String ORDER_BY_SALESMAN
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values

ORDER_BY_CUSTOMERNAME

public static final java.lang.String ORDER_BY_CUSTOMERNAME
See Also:
Constant Field Values

ORDER_BY_RELATEDDOCUMENT

public static final java.lang.String ORDER_BY_RELATEDDOCUMENT
See Also:
Constant Field Values
Constructor Detail

SalesOrderListResult

public SalesOrderListResult()
Method Detail

getStatus

public java.lang.String getStatus()

getComments

public java.lang.String getComments()

getPrivateNote

public java.lang.String getPrivateNote()

getProject

public java.lang.String getProject()

getCustomerPo

public java.lang.String getCustomerPo()

getCustomerId

public java.lang.String getCustomerId()

getChangeOrder

public java.lang.String getChangeOrder()

getSoDate

public java.util.Date getSoDate()

setSoNumber

public void setSoNumber(java.lang.String soNumber)

setStatus

public void setStatus(java.lang.String status)

setComments

public void setComments(java.lang.String comments)

setPrivateNote

public void setPrivateNote(java.lang.String privateNote)

setProject

public void setProject(java.lang.String project)

setCustomerPo

public void setCustomerPo(java.lang.String customerPo)

setCustomerId

public void setCustomerId(java.lang.String customerId)

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

setSoDate

public void setSoDate(java.util.Date soDate)

setSalesman

public void setSalesman(java.lang.String salesman)

getSoNumber

public java.lang.String getSoNumber()

getSalesman

public java.lang.String getSalesman()

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getCustomerName

public java.lang.String getCustomerName()

setCustomerName

public void setCustomerName(java.lang.String customerName)

getGrantTotal

public java.math.BigDecimal getGrantTotal()

setGrantTotal

public void setGrantTotal(java.math.BigDecimal grantTotal)

getRelatedDocument

public java.lang.String getRelatedDocument()

setRelatedDocument

public void setRelatedDocument(java.lang.String relatedDocument)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getArPrepay

public java.math.BigDecimal getArPrepay()

setArPrepay

public void setArPrepay(java.math.BigDecimal arPrepay)

getArPrepayGl

public java.math.BigDecimal getArPrepayGl()

setArPrepayGl

public void setArPrepayGl(java.math.BigDecimal arPrepayGl)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesOrderOnDemandResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesOrderOnDemandResult

java.lang.Object
    extended by  bb.common.SalesOrderOnDemandResult
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
SalesOrderOrphanedResult
public class SalesOrderOnDemandResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SalesOrderOnDemandResult()
Method Summary
java.util.Date | getArriveDate()
java.lang.String | getCustomerId()
java.lang.String | getCustomerPo()
int | getDelayDays()
java.util.Date | getDeliveryDate()
java.lang.String | getDescription()
java.util.Map | getLocations()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.math.BigDecimal | getQuantituInSip()
java.math.BigDecimal | getQuantityOnDemand()
java.math.BigDecimal | getQuantityOrdered()
java.math.BigDecimal | getQuantityShipped()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
SalesOrderItemPK | getSalesOrderItemPk()
java.lang.String | getShipVia()
void | setArriveDate(java.util.Date arriveDate)
void | setCustomerId(java.lang.String customerId)
void | setCustomerPo(java.lang.String customerPo)
void | setDelayDays(int delayDays)
void | setDeliveryDate(java.util.Date deliveryDate)
void | setDescription(java.lang.String description)
void | setLocations(java.util.Map locations)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setQuantituInSip(java.math.BigDecimal quantituInSip)
void | setQuantityOnDemand(java.math.BigDecimal quantityOnDemand)
void | setQuantityOrdered(java.math.BigDecimal quantityOrdered)
void | setQuantityShipped(java.math.BigDecimal quantityShipped)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setSalesOrderItemPk(SalesOrderItemPK salesOrderItemPk)
void | setShipVia(java.lang.String shipVia)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SalesOrderOnDemandResult

public SalesOrderOnDemandResult()
Method Detail

getLocations

public java.util.Map getLocations()

setLocations

public void setLocations(java.util.Map locations)

getCustomerPo

public java.lang.String getCustomerPo()

setCustomerPo

public void setCustomerPo(java.lang.String customerPo)

getPartPk

public PartPK getPartPk()

setPartPk

public void setPartPk(PartPK partPk)

getSalesOrderItemPk

public SalesOrderItemPK getSalesOrderItemPk()

setSalesOrderItemPk

public void setSalesOrderItemPk(SalesOrderItemPK salesOrderItemPk)

getQuantityOrdered

public java.math.BigDecimal getQuantityOrdered()

setQuantityOrdered

public void setQuantityOrdered(java.math.BigDecimal quantityOrdered)

getQuantityShipped

public java.math.BigDecimal getQuantityShipped()

setQuantityShipped

public void setQuantityShipped(java.math.BigDecimal quantityShipped)

getQuantityOnDemand

public java.math.BigDecimal getQuantityOnDemand()

setQuantityOnDemand

public void setQuantityOnDemand(java.math.BigDecimal quantityOnDemand)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getDeliveryDate

public java.util.Date getDeliveryDate()

setDeliveryDate

public void setDeliveryDate(java.util.Date deliveryDate)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getDelayDays

public int getDelayDays()

setDelayDays

public void setDelayDays(int delayDays)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getArriveDate

public java.util.Date getArriveDate()

setArriveDate

public void setArriveDate(java.util.Date arriveDate)

getQuantituInSip

public java.math.BigDecimal getQuantituInSip()

setQuantituInSip

public void setQuantituInSip(java.math.BigDecimal quantituInSip)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesOrderOnTimeItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesOrderOnTimeItemResult

java.lang.Object
    extended by  bb.common.SalesOrderOnTimeItemResult
All Implemented Interfaces:
java.io.Serializable
public class SalesOrderOnTimeItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | FISCAL_YEAR
static java.lang.String | MONTH_12_AVG
static java.lang.String | YEAR_TO_DATE
Constructor Summary
SalesOrderOnTimeItemResult()
Method Summary
java.math.BigDecimal | getDays()
java.lang.String | getMonth()
java.math.BigDecimal | getNotShippedOnTimeQty()
java.math.BigDecimal | getNotShippedOnTimeTotal()
int | getSalesItemCount()
java.math.BigDecimal | getSalesMarginPct()
java.math.BigDecimal | getSalesTotal()
int | getShippedItemCount()
java.math.BigDecimal | getShippedMarginPct()
java.math.BigDecimal | getShippedTotalOnTime()
void | setDays(java.math.BigDecimal days)
void | setMonth(java.lang.String month)
void | setNotShippedOnTimeQty(java.math.BigDecimal notShippedOnTimeQty)
void | setNotShippedOnTimeTotal(java.math.BigDecimal notShippedOnTimeTotal)
void | setSalesItemCount(int salesItemCount)
void | setSalesMarginPct(java.math.BigDecimal salesMarginPct)
void | setSalesTotal(java.math.BigDecimal salesTotal)
void | setShippedItemCount(int shippedItemCount)
void | setShippedMarginPct(java.math.BigDecimal shippedMarginPct)
void | setShippedTotalOnTime(java.math.BigDecimal shippedTotalOnTime)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

FISCAL_YEAR

public static final java.lang.String FISCAL_YEAR
See Also:
Constant Field Values

YEAR_TO_DATE

public static final java.lang.String YEAR_TO_DATE
See Also:
Constant Field Values

MONTH_12_AVG

public static final java.lang.String MONTH_12_AVG
See Also:
Constant Field Values
Constructor Detail

SalesOrderOnTimeItemResult

public SalesOrderOnTimeItemResult()
Method Detail

getDays

public java.math.BigDecimal getDays()

setDays

public void setDays(java.math.BigDecimal days)

getMonth

public java.lang.String getMonth()

setMonth

public void setMonth(java.lang.String month)

getSalesItemCount

public int getSalesItemCount()

setSalesItemCount

public void setSalesItemCount(int salesItemCount)

getSalesMarginPct

public java.math.BigDecimal getSalesMarginPct()

setSalesMarginPct

public void setSalesMarginPct(java.math.BigDecimal salesMarginPct)

getSalesTotal

public java.math.BigDecimal getSalesTotal()

setSalesTotal

public void setSalesTotal(java.math.BigDecimal salesTotal)

getShippedItemCount

public int getShippedItemCount()

setShippedItemCount

public void setShippedItemCount(int shippedItemCount)

getShippedMarginPct

public java.math.BigDecimal getShippedMarginPct()

setShippedMarginPct

public void setShippedMarginPct(java.math.BigDecimal shippedMarginPct)

getShippedTotalOnTime

public java.math.BigDecimal getShippedTotalOnTime()

setShippedTotalOnTime

public void setShippedTotalOnTime(java.math.BigDecimal shippedTotalOnTime)

getNotShippedOnTimeTotal

public java.math.BigDecimal getNotShippedOnTimeTotal()

setNotShippedOnTimeTotal

public void setNotShippedOnTimeTotal(java.math.BigDecimal notShippedOnTimeTotal)

getNotShippedOnTimeQty

public java.math.BigDecimal getNotShippedOnTimeQty()

setNotShippedOnTimeQty

public void setNotShippedOnTimeQty(java.math.BigDecimal notShippedOnTimeQty)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesOrderOnTimeResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesOrderOnTimeResult

java.lang.Object
    extended by  bb.common.SalesOrderOnTimeResult
All Implemented Interfaces:
java.io.Serializable
public class SalesOrderOnTimeResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SalesOrderOnTimeResult()
Method Summary
java.lang.String | getCurrency()
java.math.BigDecimal | getGrossMarginPct12MonthAvg()
java.math.BigDecimal | getGrossMarginPctFysical()
java.math.BigDecimal | getGrossMarginPctLastMonth()
java.math.BigDecimal | getGrossMarginPctThisMonth()
java.math.BigDecimal | getGrossMarginPctYtd()
java.math.BigDecimal | getGrossMarginShippedOnTime12MonthAvg()
java.math.BigDecimal | getGrossMarginShippedOnTimeFysical()
java.math.BigDecimal | getGrossMarginShippedOnTimeLastMonth()
java.math.BigDecimal | getGrossMarginShippedOnTimeThisMonth()
java.math.BigDecimal | getGrossMarginShippedOnTimeYtd()
java.math.BigDecimal | getSoDueItems12MonthAvg()
java.math.BigDecimal | getSoDueItemsFysical()
java.math.BigDecimal | getSoDueItemsLastMonth()
java.math.BigDecimal | getSoDueItemsThisMonth()
java.math.BigDecimal | getSoDueItemsYtd()
java.math.BigDecimal | getSoDueTotal12MonthAvg()
java.math.BigDecimal | getSoDueTotalFysical()
java.math.BigDecimal | getSoDueTotalLastMonth()
java.math.BigDecimal | getSoDueTotalThisMonth()
java.math.BigDecimal | getSoDueTotalYtd()
java.math.BigDecimal | getSoShippedItemOntime12MonthAvg()
java.math.BigDecimal | getSoShippedItemOntimeFysical()
java.math.BigDecimal | getSoShippedItemOntimeLastMonth()
java.math.BigDecimal | getSoShippedItemOntimeThisMonth()
java.math.BigDecimal | getSoShippedItemOntimeYtd()
java.math.BigDecimal | getSoShippedTotalOntime12MonthAvg()
java.math.BigDecimal | getSoShippedTotalOntimeFysical()
java.math.BigDecimal | getSoShippedTotalOntimeLastMonth()
java.math.BigDecimal | getSoShippedTotalOntimeThisMonth()
java.math.BigDecimal | getSoShippedTotalOntimeYtd()
void | setCurrency(java.lang.String currency)
void | setGrossMarginPct12MonthAvg(java.math.BigDecimal grossMarginPct12MonthAvg)
void | setGrossMarginPctFysical(java.math.BigDecimal grossMarginPctFysical)
void | setGrossMarginPctLastMonth(java.math.BigDecimal grossMarginPctLastMonth)
void | setGrossMarginPctThisMonth(java.math.BigDecimal grossMarginPctThisMonth)
void | setGrossMarginPctYtd(java.math.BigDecimal grossMarginPctYtd)
void | setGrossMarginShippedOnTime12MonthAvg(java.math.BigDecimal grossMarginShippedOnTime12MonthAvg)
void | setGrossMarginShippedOnTimeFysical(java.math.BigDecimal grossMarginShippedOnTimeFysical)
void | setGrossMarginShippedOnTimeLastMonth(java.math.BigDecimal grossMarginShippedOnTimeLastMonth)
void | setGrossMarginShippedOnTimeThisMonth(java.math.BigDecimal grossMarginShippedOnTimeThisMonth)
void | setGrossMarginShippedOnTimeYtd(java.math.BigDecimal grossMarginShippedOnTimeYtd)
void | setSoDueItems12MonthAvg(java.math.BigDecimal soDueItems12MonthAvg)
void | setSoDueItemsFysical(java.math.BigDecimal soDueItemsFysical)
void | setSoDueItemsLastMonth(java.math.BigDecimal soDueItemsLastMonth)
void | setSoDueItemsThisMonth(java.math.BigDecimal soDueItemsThisMonth)
void | setSoDueItemsYtd(java.math.BigDecimal soDueItemsYtd)
void | setSoDueTotal12MonthAvg(java.math.BigDecimal soDueTotal12MonthAvg)
void | setSoDueTotalFysical(java.math.BigDecimal soDueTotalFysical)
void | setSoDueTotalLastMonth(java.math.BigDecimal soDueTotalLastMonth)
void | setSoDueTotalThisMonth(java.math.BigDecimal soDueTotalThisMonth)
void | setSoDueTotalYtd(java.math.BigDecimal soDueTotalYtd)
void | setSoShippedItemOntime12MonthAvg(java.math.BigDecimal soShippedItemOntime12MonthAvg)
void | setSoShippedItemOntimeFysical(java.math.BigDecimal soShippedItemOntimeFysical)
void | setSoShippedItemOntimeLastMonth(java.math.BigDecimal soShippedItemOntimeLastMonth)
void | setSoShippedItemOntimeThisMonth(java.math.BigDecimal soShippedItemOntimeThisMonth)
void | setSoShippedItemOntimeYtd(java.math.BigDecimal soShippedItemOntimeYtd)
void | setSoShippedTotalOntime12MonthAvg(java.math.BigDecimal soShippedTotalOntime12MonthAvg)
void | setSoShippedTotalOntimeFysical(java.math.BigDecimal soShippedTotalOntimeFysical)
void | setSoShippedTotalOntimeLastMonth(java.math.BigDecimal soShippedTotalOntimeLastMonth)
void | setSoShippedTotalOntimeThisMonth(java.math.BigDecimal soShippedTotalOntimeThisMonth)
void | setSoShippedTotalOntimeYtd(java.math.BigDecimal soShippedTotalOntimeYtd)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SalesOrderOnTimeResult

public SalesOrderOnTimeResult()
Method Detail

setCurrency

public void setCurrency(java.lang.String currency)

setSoDueTotalThisMonth

public void setSoDueTotalThisMonth(java.math.BigDecimal soDueTotalThisMonth)

setSoDueItemsThisMonth

public void setSoDueItemsThisMonth(java.math.BigDecimal soDueItemsThisMonth)

setGrossMarginPctThisMonth

public void setGrossMarginPctThisMonth(java.math.BigDecimal grossMarginPctThisMonth)

setSoShippedTotalOntimeThisMonth

public void setSoShippedTotalOntimeThisMonth(java.math.BigDecimal soShippedTotalOntimeThisMonth)

setSoShippedItemOntimeThisMonth

public void setSoShippedItemOntimeThisMonth(java.math.BigDecimal soShippedItemOntimeThisMonth)

setGrossMarginShippedOnTimeThisMonth

public void setGrossMarginShippedOnTimeThisMonth(java.math.BigDecimal grossMarginShippedOnTimeThisMonth)

setGrossMarginPct12MonthAvg

public void setGrossMarginPct12MonthAvg(java.math.BigDecimal grossMarginPct12MonthAvg)

setGrossMarginPctFysical

public void setGrossMarginPctFysical(java.math.BigDecimal grossMarginPctFysical)

setGrossMarginPctLastMonth

public void setGrossMarginPctLastMonth(java.math.BigDecimal grossMarginPctLastMonth)

setGrossMarginPctYtd

public void setGrossMarginPctYtd(java.math.BigDecimal grossMarginPctYtd)

setGrossMarginShippedOnTime12MonthAvg

public void setGrossMarginShippedOnTime12MonthAvg(java.math.BigDecimal grossMarginShippedOnTime12MonthAvg)

setGrossMarginShippedOnTimeFysical

public void setGrossMarginShippedOnTimeFysical(java.math.BigDecimal grossMarginShippedOnTimeFysical)

setGrossMarginShippedOnTimeLastMonth

public void setGrossMarginShippedOnTimeLastMonth(java.math.BigDecimal grossMarginShippedOnTimeLastMonth)

setGrossMarginShippedOnTimeYtd

public void setGrossMarginShippedOnTimeYtd(java.math.BigDecimal grossMarginShippedOnTimeYtd)

setSoDueItems12MonthAvg

public void setSoDueItems12MonthAvg(java.math.BigDecimal soDueItems12MonthAvg)

setSoDueItemsFysical

public void setSoDueItemsFysical(java.math.BigDecimal soDueItemsFysical)

setSoDueItemsLastMonth

public void setSoDueItemsLastMonth(java.math.BigDecimal soDueItemsLastMonth)

setSoDueItemsYtd

public void setSoDueItemsYtd(java.math.BigDecimal soDueItemsYtd)

setSoDueTotal12MonthAvg

public void setSoDueTotal12MonthAvg(java.math.BigDecimal soDueTotal12MonthAvg)

setSoDueTotalFysical

public void setSoDueTotalFysical(java.math.BigDecimal soDueTotalFysical)

setSoDueTotalLastMonth

public void setSoDueTotalLastMonth(java.math.BigDecimal soDueTotalLastMonth)

setSoDueTotalYtd

public void setSoDueTotalYtd(java.math.BigDecimal soDueTotalYtd)

setSoShippedItemOntime12MonthAvg

public void setSoShippedItemOntime12MonthAvg(java.math.BigDecimal soShippedItemOntime12MonthAvg)

setSoShippedItemOntimeFysical

public void setSoShippedItemOntimeFysical(java.math.BigDecimal soShippedItemOntimeFysical)

setSoShippedItemOntimeLastMonth

public void setSoShippedItemOntimeLastMonth(java.math.BigDecimal soShippedItemOntimeLastMonth)

setSoShippedItemOntimeYtd

public void setSoShippedItemOntimeYtd(java.math.BigDecimal soShippedItemOntimeYtd)

setSoShippedTotalOntime12MonthAvg

public void setSoShippedTotalOntime12MonthAvg(java.math.BigDecimal soShippedTotalOntime12MonthAvg)

setSoShippedTotalOntimeFysical

public void setSoShippedTotalOntimeFysical(java.math.BigDecimal soShippedTotalOntimeFysical)

setSoShippedTotalOntimeLastMonth

public void setSoShippedTotalOntimeLastMonth(java.math.BigDecimal soShippedTotalOntimeLastMonth)

setSoShippedTotalOntimeYtd

public void setSoShippedTotalOntimeYtd(java.math.BigDecimal soShippedTotalOntimeYtd)

getCurrency

public java.lang.String getCurrency()

getSoDueTotalThisMonth

public java.math.BigDecimal getSoDueTotalThisMonth()

getSoDueItemsThisMonth

public java.math.BigDecimal getSoDueItemsThisMonth()

getGrossMarginPctThisMonth

public java.math.BigDecimal getGrossMarginPctThisMonth()

getSoShippedTotalOntimeThisMonth

public java.math.BigDecimal getSoShippedTotalOntimeThisMonth()

getSoShippedItemOntimeThisMonth

public java.math.BigDecimal getSoShippedItemOntimeThisMonth()

getGrossMarginShippedOnTimeThisMonth

public java.math.BigDecimal getGrossMarginShippedOnTimeThisMonth()

getGrossMarginPct12MonthAvg

public java.math.BigDecimal getGrossMarginPct12MonthAvg()

getGrossMarginPctFysical

public java.math.BigDecimal getGrossMarginPctFysical()

getGrossMarginPctLastMonth

public java.math.BigDecimal getGrossMarginPctLastMonth()

getGrossMarginPctYtd

public java.math.BigDecimal getGrossMarginPctYtd()

getGrossMarginShippedOnTime12MonthAvg

public java.math.BigDecimal getGrossMarginShippedOnTime12MonthAvg()

getGrossMarginShippedOnTimeFysical

public java.math.BigDecimal getGrossMarginShippedOnTimeFysical()

getGrossMarginShippedOnTimeLastMonth

public java.math.BigDecimal getGrossMarginShippedOnTimeLastMonth()

getGrossMarginShippedOnTimeYtd

public java.math.BigDecimal getGrossMarginShippedOnTimeYtd()

getSoDueItems12MonthAvg

public java.math.BigDecimal getSoDueItems12MonthAvg()

getSoDueItemsFysical

public java.math.BigDecimal getSoDueItemsFysical()

getSoDueItemsLastMonth

public java.math.BigDecimal getSoDueItemsLastMonth()

getSoDueItemsYtd

public java.math.BigDecimal getSoDueItemsYtd()

getSoDueTotal12MonthAvg

public java.math.BigDecimal getSoDueTotal12MonthAvg()

getSoDueTotalFysical

public java.math.BigDecimal getSoDueTotalFysical()

getSoDueTotalLastMonth

public java.math.BigDecimal getSoDueTotalLastMonth()

getSoDueTotalYtd

public java.math.BigDecimal getSoDueTotalYtd()

getSoShippedItemOntime12MonthAvg

public java.math.BigDecimal getSoShippedItemOntime12MonthAvg()

getSoShippedItemOntimeFysical

public java.math.BigDecimal getSoShippedItemOntimeFysical()

getSoShippedItemOntimeLastMonth

public java.math.BigDecimal getSoShippedItemOntimeLastMonth()

getSoShippedItemOntimeYtd

public java.math.BigDecimal getSoShippedItemOntimeYtd()

getSoShippedTotalOntime12MonthAvg

public java.math.BigDecimal getSoShippedTotalOntime12MonthAvg()

getSoShippedTotalOntimeFysical

public java.math.BigDecimal getSoShippedTotalOntimeFysical()

getSoShippedTotalOntimeLastMonth

public java.math.BigDecimal getSoShippedTotalOntimeLastMonth()

getSoShippedTotalOntimeYtd

public java.math.BigDecimal getSoShippedTotalOntimeYtd()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesOrderOrphanedResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesOrderOrphanedResult

java.lang.Object
    extended by  bb.common.SalesOrderOnDemandResult
        extended by  bb.common.SalesOrderOrphanedResult
All Implemented Interfaces:
java.io.Serializable
public class SalesOrderOrphanedResult
extends SalesOrderOnDemandResult
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SalesOrderOrphanedResult()
Method Summary
java.math.BigDecimal | getQuantityNotShipped()
void | setQuantityNotShipped(java.math.BigDecimal quantityNotShipped)
Methods inherited from class bb.common.SalesOrderOnDemandResult
getArriveDate, getCustomerId, getCustomerPo, getDelayDays, getDeliveryDate, getDescription, getLocations, getPartFrom, getPartPk, getQuantituInSip, getQuantityOnDemand, getQuantityOrdered, getQuantityShipped, getRefDoc1, getRefDoc2, getSalesOrderItemPk, getShipVia, setArriveDate, setCustomerId, setCustomerPo, setDelayDays, setDeliveryDate, setDescription, setLocations, setPartFrom, setPartPk, setQuantituInSip, setQuantityOnDemand, setQuantityOrdered, setQuantityShipped, setRefDoc1, setRefDoc2, setSalesOrderItemPk, setShipVia
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SalesOrderOrphanedResult

public SalesOrderOrphanedResult()
Method Detail

getQuantityNotShipped

public java.math.BigDecimal getQuantityNotShipped()

setQuantityNotShipped

public void setQuantityNotShipped(java.math.BigDecimal quantityNotShipped)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesOrderReviewVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesOrderReviewVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SalesOrderReviewVO
All Implemented Interfaces:
java.io.Serializable
public class SalesOrderReviewVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CANREVIEWOWNSALESORDER
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_EMPLOYEEID
static java.lang.String | ORDER_BY_REVIEWLIMIT
static java.lang.String | ORDER_BY_USERNAME
Constructor Summary
SalesOrderReviewVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCanReviewOwnSalesOrder()
java.lang.String | getCurrency()
java.lang.String | getEmployeeId()
java.math.BigDecimal | getReviewLimit()
java.lang.String | getUserName()
int | hashCode()
void | setCanReviewOwnSalesOrder(java.lang.String canReviewOwnSalesOrder)
void | setCurrency(java.lang.String currency)
void | setEmployeeId(java.lang.String employeeId)
void | setReviewLimit(java.math.BigDecimal reviewLimit)
void | setUserName(java.lang.String userName)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_EMPLOYEEID

public static final java.lang.String ORDER_BY_EMPLOYEEID
See Also:
Constant Field Values

ORDER_BY_USERNAME

public static final java.lang.String ORDER_BY_USERNAME
See Also:
Constant Field Values

ORDER_BY_REVIEWLIMIT

public static final java.lang.String ORDER_BY_REVIEWLIMIT
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values

ORDER_BY_CANREVIEWOWNSALESORDER

public static final java.lang.String ORDER_BY_CANREVIEWOWNSALESORDER
See Also:
Constant Field Values
Constructor Detail

SalesOrderReviewVO

public SalesOrderReviewVO()
Method Detail

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getReviewLimit

public java.math.BigDecimal getReviewLimit()

setReviewLimit

public void setReviewLimit(java.math.BigDecimal reviewLimit)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getCanReviewOwnSalesOrder

public java.lang.String getCanReviewOwnSalesOrder()

setCanReviewOwnSalesOrder

public void setCanReviewOwnSalesOrder(java.lang.String canReviewOwnSalesOrder)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesOrderShipDateListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesOrderShipDateListResult

java.lang.Object
    extended by  bb.common.SalesOrderShipDateListResult
All Implemented Interfaces:
java.io.Serializable
public class SalesOrderShipDateListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CUSTID
static java.lang.String | ORDER_BY_DELIVERYDATE
static java.lang.String | ORDER_BY_ORIGINAL
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PK
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
SalesOrderShipDateListResult()
Method Summary
java.lang.String | getCustID()
java.util.Date | getDeliveryDate()
java.util.Date | getOriginal()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
SalesOrderItemPK | getPk()
java.math.BigDecimal | getQuantityOrdered()
java.math.BigDecimal | getQuantityShipped()
java.lang.String | getRevision()
java.lang.String | getSalesItemDescription()
java.util.Date | getShippedDate()
java.lang.String | getShipperNumber()
java.lang.String | getStatus()
java.lang.String | getUnit()
void | setCustID(java.lang.String custID)
void | setDeliveryDate(java.util.Date deliveryDate)
void | setOriginal(java.util.Date original)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(SalesOrderItemPK pk)
void | setQuantityOrdered(java.math.BigDecimal quantityOrdered)
void | setQuantityShipped(java.math.BigDecimal quantityShipped)
void | setRevision(java.lang.String revision)
void | setSalesItemDescription(java.lang.String salesItemDescription)
void | setShippedDate(java.util.Date shippedDate)
void | setShipperNumber(java.lang.String shipperNumber)
void | setStatus(java.lang.String status)
void | setUnit(java.lang.String unit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PK

public static final java.lang.String ORDER_BY_PK
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_CUSTID

public static final java.lang.String ORDER_BY_CUSTID
See Also:
Constant Field Values

ORDER_BY_DELIVERYDATE

public static final java.lang.String ORDER_BY_DELIVERYDATE
See Also:
Constant Field Values

ORDER_BY_ORIGINAL

public static final java.lang.String ORDER_BY_ORIGINAL
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values
Constructor Detail

SalesOrderShipDateListResult

public SalesOrderShipDateListResult()
Method Detail

getShipperNumber

public java.lang.String getShipperNumber()

setShipperNumber

public void setShipperNumber(java.lang.String shipperNumber)

getDeliveryDate

public java.util.Date getDeliveryDate()

setDeliveryDate

public void setDeliveryDate(java.util.Date deliveryDate)

getOriginal

public java.util.Date getOriginal()

setOriginal

public void setOriginal(java.util.Date original)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPk

public SalesOrderItemPK getPk()

setPk

public void setPk(SalesOrderItemPK pk)

getQuantityOrdered

public java.math.BigDecimal getQuantityOrdered()

setQuantityOrdered

public void setQuantityOrdered(java.math.BigDecimal quantityOrdered)

getQuantityShipped

public java.math.BigDecimal getQuantityShipped()

setQuantityShipped

public void setQuantityShipped(java.math.BigDecimal quantityShipped)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getSalesItemDescription

public java.lang.String getSalesItemDescription()

setSalesItemDescription

public void setSalesItemDescription(java.lang.String salesItemDescription)

getShippedDate

public java.util.Date getShippedDate()

setShippedDate

public void setShippedDate(java.util.Date shippedDate)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getCustID

public java.lang.String getCustID()

setCustID

public void setCustID(java.lang.String custID)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesOrderVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesOrderVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SalesOrderVO
All Implemented Interfaces:
java.io.Serializable
public class SalesOrderVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SalesOrderVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getActual()
java.util.Date | getAdate()
java.math.BigDecimal | getArGl1Recorded()
java.math.BigDecimal | getArGl2Paid()
java.lang.String | getArNetSet()
java.math.BigDecimal | getArOpen()
java.math.BigDecimal | getArPaidGl()
java.lang.String | getArpNumber()
java.math.BigDecimal | getArPrepay()
java.math.BigDecimal | getArPrepayApply()
java.math.BigDecimal | getArPrepayDue()
java.math.BigDecimal | getArPrepayGl()
java.math.BigDecimal | getArShip()
java.math.BigDecimal | getArSub()
java.lang.String | getArTaxSet()
CustomerVendorAddressInfoVO | getBillToAddressInfo()
java.lang.String | getBillToId()
java.util.Set | getBoilerplates()
java.lang.String | getBp()
java.lang.String | getCarrier()
java.lang.String | getCarrierAccount()
java.lang.String | getChangeOrder()
java.lang.String | getCoComments()
java.lang.String | getCompanyUnitId()
java.lang.String | getContact()
java.lang.String | getCreditAccount()
java.lang.String | getCurrency()
CustomerVendorAddressInfoVO | getCustomerAddressInfo()
java.lang.String | getCustomerEmail()
java.lang.String | getCustomerId()
java.lang.String | getCustomerPo()
byte | getDelay()
java.util.Date | getDelivery()
java.util.Date | getDesired()
java.math.BigDecimal | getExchange()
java.math.BigDecimal | getGrantTotal()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
java.lang.String | getLastUser()
java.lang.String | getLocate()
java.math.BigDecimal | getMargin()
java.math.BigDecimal | getMarginByStdCost()
java.math.BigDecimal | getMarginPercent()
java.math.BigDecimal | getMarginPercentByStdCost()
java.lang.String | getOpinion()
java.lang.String | getOrigin()
java.util.Date | getOriginal()
java.lang.String | getPriority()
java.lang.String | getProjectName()
java.lang.String | getQuoteNumber()
java.lang.String | getReceiptNumber()
java.lang.String | getReferenceSalesOrder()
java.lang.String | getRelatedDocument()
java.lang.String | getRequester()
java.lang.String | getReviewedBy()
java.util.Date | getReviewedDate()
java.lang.String | getSalesCodeId()
java.lang.String | getSalesman()
short | getSalesmanId()
java.lang.String | getSalesOrderBoilerplate()
java.lang.String | getSalesOrderComments()
java.util.Date | getSalesOrderDate()
java.util.Set | getSalesOrderDocuments()
java.util.Set<SalesOrderItemVO> | getSalesOrderItems()
java.lang.String | getSalesOrderNumber()
java.lang.String | getSalesOrderPrivateNotes()
java.lang.String | getShipAccout()
java.lang.String | getShippingStatus()
CustomerVendorAddressInfoVO | getShipToAddressInfo()
java.lang.String | getShipToId()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.math.BigDecimal | getSubTotal()
java.lang.String | getTerms()
java.math.BigDecimal | getTotalCost()
java.math.BigDecimal | getTotalDiscount()
java.math.BigDecimal | getTotalFreight()
java.math.BigDecimal | getTotalPaidInvoice()
java.math.BigDecimal | getTotalStdCost()
java.math.BigDecimal | getTotalTax()
java.lang.Integer | getVersion()
int | hashCode()
boolean | isByPos()
boolean | isHold()
void | setActual(java.util.Date actual)
void | setAdate(java.util.Date adate)
void | setArGl1Recorded(java.math.BigDecimal arGl1Recorded)
void | setArGl2Paid(java.math.BigDecimal arGl2Paid)
void | setArNetSet(java.lang.String arNetSet)
void | setArOpen(java.math.BigDecimal arOpen)
void | setArPaidGl(java.math.BigDecimal arPaidGl)
void | setArpNumber(java.lang.String arpNumber)
void | setArPrepay(java.math.BigDecimal arPrepay)
void | setArPrepayApply(java.math.BigDecimal arPrepayApply)
void | setArPrepayDue(java.math.BigDecimal arPrepayDue)
void | setArPrepayGl(java.math.BigDecimal arPrepayGl)
void | setArShip(java.math.BigDecimal arShip)
void | setArSub(java.math.BigDecimal arSub)
void | setArTaxSet(java.lang.String arTaxSet)
void | setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | setBillToId(java.lang.String billToId)
void | setBoilerplates(java.util.Set boilerplates)
void | setBp(java.lang.String bp)
void | setByPos(boolean byPos)
void | setCarrier(java.lang.String carrier)
void | setCarrierAccount(java.lang.String carrierAccount)
void | setChangeOrder(java.lang.String changeOrder)
void | setCoComments(java.lang.String coComments)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setContact(java.lang.String contact)
void | setCreditAccount(java.lang.String creditAccount)
void | setCurrency(java.lang.String currency)
void | setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | setCustomerEmail(java.lang.String customerEmail)
void | setCustomerId(java.lang.String customerId)
void | setCustomerPo(java.lang.String customerPo)
void | setDelay(byte delay)
void | setDelivery(java.util.Date delivery)
void | setDesired(java.util.Date desired)
void | setExchange(java.math.BigDecimal exchange)
void | setGrantTotal(java.math.BigDecimal grantTotal)
void | setHold(boolean hold)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastUser(java.lang.String lastUser)
void | setLocate(java.lang.String locate)
void | setMargin(java.math.BigDecimal margin)
void | setMarginByStdCost(java.math.BigDecimal marginByStdCost)
void | setMarginPercent(java.math.BigDecimal marginPercent)
void | setMarginPercentByStdCost(java.math.BigDecimal marginPercentByStdCost)
void | setOpinion(java.lang.String opinion)
void | setOrigin(java.lang.String origin)
void | setOriginal(java.util.Date original)
void | setPriority(java.lang.String priority)
void | setProjectName(java.lang.String projectName)
void | setQuoteNumber(java.lang.String quoteNumber)
void | setReceiptNumber(java.lang.String receiptNumber)
void | setReferenceSalesOrder(java.lang.String referenceSalesOrder)
void | setRelatedDocument(java.lang.String relatedDocument)
void | setRequester(java.lang.String requester)
void | setReviewedBy(java.lang.String reviewedBy)
void | setReviewedDate(java.util.Date reviewedDate)
void | setSalesCodeId(java.lang.String salesCodeId)
void | setSalesman(java.lang.String salesman)
void | setSalesmanId(short salesmanId)
void | setSalesOrderBoilerplate(java.lang.String salesOrderBoilerplate)
void | setSalesOrderComments(java.lang.String salesOrderComments)
void | setSalesOrderDate(java.util.Date salesOrderDate)
void | setSalesOrderDocuments(java.util.Set salesOrderDocuments)
void | setSalesOrderItems(java.util.Set<SalesOrderItemVO> salesOrderItem)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setSalesOrderPrivateNotes(java.lang.String salesOrderPrivateNotes)
void | setShipAccout(java.lang.String shipAccout)
void | setShippingStatus(java.lang.String shippingStatus)
void | setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | setShipToId(java.lang.String shipToId)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setSubTotal(java.math.BigDecimal subTotal)
void | setTerms(java.lang.String terms)
void | setTotalCost(java.math.BigDecimal totalCost)
void | setTotalDiscount(java.math.BigDecimal totalDiscount)
void | setTotalFreight(java.math.BigDecimal totalFreight)
void | setTotalPaidInvoice(java.math.BigDecimal totalPaidInvoice)
void | setTotalStdCost(java.math.BigDecimal totalStdCost)
void | setTotalTax(java.math.BigDecimal totalTax)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SalesOrderVO

public SalesOrderVO()
default constructor

Method Detail

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getLastUser

public java.lang.String getLastUser()

setLastUser

public void setLastUser(java.lang.String lastUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getArNetSet

public java.lang.String getArNetSet()

setArNetSet

public void setArNetSet(java.lang.String arNetSet)

getArTaxSet

public java.lang.String getArTaxSet()

setArTaxSet

public void setArTaxSet(java.lang.String arTaxSet)

getArSub

public java.math.BigDecimal getArSub()

setArSub

public void setArSub(java.math.BigDecimal arSub)

getTotalDiscount

public java.math.BigDecimal getTotalDiscount()

setTotalDiscount

public void setTotalDiscount(java.math.BigDecimal totalDiscount)

getSubTotal

public java.math.BigDecimal getSubTotal()

setSubTotal

public void setSubTotal(java.math.BigDecimal subTotal)

getArShip

public java.math.BigDecimal getArShip()

setArShip

public void setArShip(java.math.BigDecimal arShip)

getArOpen

public java.math.BigDecimal getArOpen()

setArOpen

public void setArOpen(java.math.BigDecimal arOpen)

getTotalTax

public java.math.BigDecimal getTotalTax()

setTotalTax

public void setTotalTax(java.math.BigDecimal totalTax)

getTotalFreight

public java.math.BigDecimal getTotalFreight()

setTotalFreight

public void setTotalFreight(java.math.BigDecimal totalFreight)

getGrantTotal

public java.math.BigDecimal getGrantTotal()

setGrantTotal

public void setGrantTotal(java.math.BigDecimal grantTotal)

getTotalPaidInvoice

public java.math.BigDecimal getTotalPaidInvoice()

setTotalPaidInvoice

public void setTotalPaidInvoice(java.math.BigDecimal totalPaidInvoice)

getArPaidGl

public java.math.BigDecimal getArPaidGl()

setArPaidGl

public void setArPaidGl(java.math.BigDecimal arPaidGl)

getArGl1Recorded

public java.math.BigDecimal getArGl1Recorded()

setArGl1Recorded

public void setArGl1Recorded(java.math.BigDecimal arGl1Recorded)

getArGl2Paid

public java.math.BigDecimal getArGl2Paid()

setArGl2Paid

public void setArGl2Paid(java.math.BigDecimal arGl2Paid)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getBillToId

public java.lang.String getBillToId()

setBillToId

public void setBillToId(java.lang.String billToId)

getCustomerPo

public java.lang.String getCustomerPo()

setCustomerPo

public void setCustomerPo(java.lang.String customerPo)

getCustomerEmail

public java.lang.String getCustomerEmail()

setCustomerEmail

public void setCustomerEmail(java.lang.String customerEmail)

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getReviewedDate

public java.util.Date getReviewedDate()

setReviewedDate

public void setReviewedDate(java.util.Date reviewedDate)

getReviewedBy

public java.lang.String getReviewedBy()

setReviewedBy

public void setReviewedBy(java.lang.String reviewedBy)

getDelivery

public java.util.Date getDelivery()

setDelivery

public void setDelivery(java.util.Date delivery)

getDesired

public java.util.Date getDesired()

setDesired

public void setDesired(java.util.Date desired)

getDelay

public byte getDelay()

setDelay

public void setDelay(byte delay)

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getOriginal

public java.util.Date getOriginal()

setOriginal

public void setOriginal(java.util.Date original)

getActual

public java.util.Date getActual()

setActual

public void setActual(java.util.Date actual)

getShipToId

public java.lang.String getShipToId()

setShipToId

public void setShipToId(java.lang.String shipToId)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAccount

public java.lang.String getCarrierAccount()

setCarrierAccount

public void setCarrierAccount(java.lang.String carrierAccount)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getShipAccout

public java.lang.String getShipAccout()

setShipAccout

public void setShipAccout(java.lang.String shipAccout)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getSalesOrderDate

public java.util.Date getSalesOrderDate()

setSalesOrderDate

public void setSalesOrderDate(java.util.Date salesOrderDate)

getSalesman

public java.lang.String getSalesman()

setSalesman

public void setSalesman(java.lang.String salesman)

getSalesmanId

public short getSalesmanId()

setSalesmanId

public void setSalesmanId(short salesmanId)

getQuoteNumber

public java.lang.String getQuoteNumber()

setQuoteNumber

public void setQuoteNumber(java.lang.String quoteNumber)

getReferenceSalesOrder

public java.lang.String getReferenceSalesOrder()

setReferenceSalesOrder

public void setReferenceSalesOrder(java.lang.String referenceSalesOrder)

getRequester

public java.lang.String getRequester()

setRequester

public void setRequester(java.lang.String requester)

getProjectName

public java.lang.String getProjectName()

setProjectName

public void setProjectName(java.lang.String projectName)

getRelatedDocument

public java.lang.String getRelatedDocument()

setRelatedDocument

public void setRelatedDocument(java.lang.String relatedDocument)

getCreditAccount

public java.lang.String getCreditAccount()

setCreditAccount

public void setCreditAccount(java.lang.String creditAccount)

getBp

public java.lang.String getBp()

setBp

public void setBp(java.lang.String bp)

getSalesOrderComments

public java.lang.String getSalesOrderComments()

setSalesOrderComments

public void setSalesOrderComments(java.lang.String salesOrderComments)

getSalesOrderPrivateNotes

public java.lang.String getSalesOrderPrivateNotes()

setSalesOrderPrivateNotes

public void setSalesOrderPrivateNotes(java.lang.String salesOrderPrivateNotes)

getCustomerAddressInfo

public CustomerVendorAddressInfoVO getCustomerAddressInfo()

setCustomerAddressInfo

public void setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)

getShipToAddressInfo

public CustomerVendorAddressInfoVO getShipToAddressInfo()

setShipToAddressInfo

public void setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)

getBillToAddressInfo

public CustomerVendorAddressInfoVO getBillToAddressInfo()

setBillToAddressInfo

public void setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)

getSalesOrderItems

public java.util.Set<SalesOrderItemVO> getSalesOrderItems()

getVersion

public java.lang.Integer getVersion()

getSalesOrderBoilerplate

public java.lang.String getSalesOrderBoilerplate()

getShippingStatus

public java.lang.String getShippingStatus()

getBoilerplates

public java.util.Set getBoilerplates()

getCoComments

public java.lang.String getCoComments()

setSalesOrderItems

public void setSalesOrderItems(java.util.Set<SalesOrderItemVO> salesOrderItem)

setVersion

public void setVersion(java.lang.Integer version)

setSalesOrderBoilerplate

public void setSalesOrderBoilerplate(java.lang.String salesOrderBoilerplate)

setShippingStatus

public void setShippingStatus(java.lang.String shippingStatus)

setBoilerplates

public void setBoilerplates(java.util.Set boilerplates)

setCoComments

public void setCoComments(java.lang.String coComments)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getMargin

public java.math.BigDecimal getMargin()

setMargin

public void setMargin(java.math.BigDecimal margin)

getMarginPercent

public java.math.BigDecimal getMarginPercent()

setMarginPercent

public void setMarginPercent(java.math.BigDecimal marginPercent)

getExchange

public java.math.BigDecimal getExchange()

setExchange

public void setExchange(java.math.BigDecimal exchange)

getTotalCost

public java.math.BigDecimal getTotalCost()

setTotalCost

public void setTotalCost(java.math.BigDecimal totalCost)

getSalesOrderDocuments

public java.util.Set getSalesOrderDocuments()

setSalesOrderDocuments

public void setSalesOrderDocuments(java.util.Set salesOrderDocuments)

getArpNumber

public java.lang.String getArpNumber()

setArpNumber

public void setArpNumber(java.lang.String arpNumber)

getArPrepay

public java.math.BigDecimal getArPrepay()

setArPrepay

public void setArPrepay(java.math.BigDecimal arPrepay)

getArPrepayGl

public java.math.BigDecimal getArPrepayGl()

setArPrepayGl

public void setArPrepayGl(java.math.BigDecimal arPrepayGl)

getSalesCodeId

public java.lang.String getSalesCodeId()

setSalesCodeId

public void setSalesCodeId(java.lang.String salesCodeId)

getArPrepayDue

public java.math.BigDecimal getArPrepayDue()

setArPrepayDue

public void setArPrepayDue(java.math.BigDecimal arPrepayDue)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getMarginByStdCost

public java.math.BigDecimal getMarginByStdCost()

setMarginByStdCost

public void setMarginByStdCost(java.math.BigDecimal marginByStdCost)

getMarginPercentByStdCost

public java.math.BigDecimal getMarginPercentByStdCost()

setMarginPercentByStdCost

public void setMarginPercentByStdCost(java.math.BigDecimal marginPercentByStdCost)

getTotalStdCost

public java.math.BigDecimal getTotalStdCost()

setTotalStdCost

public void setTotalStdCost(java.math.BigDecimal totalStdCost)

getArPrepayApply

public java.math.BigDecimal getArPrepayApply()

setArPrepayApply

public void setArPrepayApply(java.math.BigDecimal arPrepayApply)

isHold

public boolean isHold()

setHold

public void setHold(boolean hold)

getOpinion

public java.lang.String getOpinion()

setOpinion

public void setOpinion(java.lang.String opinion)

isByPos

public boolean isByPos()

setByPos

public void setByPos(boolean byPos)

getReceiptNumber

public java.lang.String getReceiptNumber()

setReceiptNumber

public void setReceiptNumber(java.lang.String receiptNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesPartListItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesPartListItemResult

java.lang.Object
    extended by  bb.common.SalesPartListItemResult
All Implemented Interfaces:
java.io.Serializable
public class SalesPartListItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SalesPartListItemResult()
Method Summary
BillItemPK | getBillItemPk()
java.lang.String | getBillPartFrom()
java.lang.String | getDescription()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.math.BigDecimal | getQuantity()
java.lang.String | getRevision()
java.lang.String | getUnit()
void | setBillItemPk(BillItemPK billItemPk)
void | setBillPartFrom(java.lang.String billPartFrom)
void | setDescription(java.lang.String description)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setQuantity(java.math.BigDecimal quantity)
void | setRevision(java.lang.String revision)
void | setUnit(java.lang.String unit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SalesPartListItemResult

public SalesPartListItemResult()
Method Detail

getBillItemPk

public BillItemPK getBillItemPk()

getQuantity

public java.math.BigDecimal getQuantity()

getPartPk

public PartPK getPartPk()

getPartFrom

public java.lang.String getPartFrom()

getBillPartFrom

public java.lang.String getBillPartFrom()

getRevision

public java.lang.String getRevision()

getUnit

public java.lang.String getUnit()

getDescription

public java.lang.String getDescription()

setBillItemPk

public void setBillItemPk(BillItemPK billItemPk)

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

setPartPk

public void setPartPk(PartPK partPk)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setBillPartFrom

public void setBillPartFrom(java.lang.String billPartFrom)

setRevision

public void setRevision(java.lang.String revision)

setUnit

public void setUnit(java.lang.String unit)

setDescription

public void setDescription(java.lang.String description)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesPartListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesPartListResult

java.lang.Object
    extended by  bb.common.SalesPartListResult
All Implemented Interfaces:
java.io.Serializable
public class SalesPartListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SalesPartListResult()
Method Summary
java.lang.String | getBillPartFrom()
BillPK | getBillPk()
java.lang.String | getDescription()
java.util.Set | getItems()
java.lang.String | getRevision()
java.lang.String | getUnit()
void | setBillPartFrom(java.lang.String billPartFrom)
void | setBillPk(BillPK billPk)
void | setDescription(java.lang.String description)
void | setItems(java.util.Set items)
void | setRevision(java.lang.String revision)
void | setUnit(java.lang.String unit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SalesPartListResult

public SalesPartListResult()
Method Detail

setBillPk

public void setBillPk(BillPK billPk)

setBillPartFrom

public void setBillPartFrom(java.lang.String billPartFrom)

setRevision

public void setRevision(java.lang.String revision)

setUnit

public void setUnit(java.lang.String unit)

setDescription

public void setDescription(java.lang.String description)

setItems

public void setItems(java.util.Set items)

getBillPk

public BillPK getBillPk()

getBillPartFrom

public java.lang.String getBillPartFrom()

getRevision

public java.lang.String getRevision()

getUnit

public java.lang.String getUnit()

getDescription

public java.lang.String getDescription()

getItems

public java.util.Set getItems()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SalesTaxListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SalesTaxListResult

java.lang.Object
    extended by  bb.common.SalesTaxListResult
All Implemented Interfaces:
java.io.Serializable
public class SalesTaxListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AMOUNTPAID
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_DATEINVOICED
static java.lang.String | ORDER_BY_DATESHIPED
static java.lang.String | ORDER_BY_INVOICEITEMNUMBER
static java.lang.String | ORDER_BY_INVOICENUMBER
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_PAYDATE
static java.lang.String | ORDER_BY_QTYSHIPED
static java.lang.String | ORDER_BY_SALESORDERNUMBER
static java.lang.String | ORDER_BY_SUBNETTOTAL
static java.lang.String | ORDER_BY_TAX
Constructor Summary
SalesTaxListResult()
Method Summary
java.math.BigDecimal | getAmountPaid()
java.lang.String | getCustomerId()
java.util.Date | getDateInvoiced()
java.util.Date | getDateShiped()
java.lang.String | getDescription()
java.math.BigDecimal | getDiscountTotal()
java.math.BigDecimal | getGrandTotal()
java.lang.String | getInvoiceItemNumber()
java.lang.String | getInvoiceNumber()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.util.Date | getPayDate()
java.math.BigDecimal | getQtyShiped()
java.lang.String | getSalesOrderNumber()
java.math.BigDecimal | getSubNetTotal()
java.math.BigDecimal | getSubTotal()
java.math.BigDecimal | getTax()
void | setAmountPaid(java.math.BigDecimal amountPaid)
void | setCustomerId(java.lang.String customerId)
void | setDateInvoiced(java.util.Date dateInvoiced)
void | setDateShiped(java.util.Date dateShiped)
void | setDescription(java.lang.String description)
void | setDiscountTotal(java.math.BigDecimal discountTotal)
void | setGrandTotal(java.math.BigDecimal grandTotal)
void | setInvoiceItemNumber(java.lang.String invoiceItemNumber)
void | setInvoiceNumber(java.lang.String invoiceNumber)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPayDate(java.util.Date payDate)
void | setQtyShiped(java.math.BigDecimal qtyShiped)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setSubNetTotal(java.math.BigDecimal subNetTotal)
void | setSubTotal(java.math.BigDecimal subTotal)
void | setTax(java.math.BigDecimal tax)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_INVOICENUMBER

public static final java.lang.String ORDER_BY_INVOICENUMBER
See Also:
Constant Field Values

ORDER_BY_SALESORDERNUMBER

public static final java.lang.String ORDER_BY_SALESORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_INVOICEITEMNUMBER

public static final java.lang.String ORDER_BY_INVOICEITEMNUMBER
See Also:
Constant Field Values

ORDER_BY_DATESHIPED

public static final java.lang.String ORDER_BY_DATESHIPED
See Also:
Constant Field Values

ORDER_BY_DATEINVOICED

public static final java.lang.String ORDER_BY_DATEINVOICED
See Also:
Constant Field Values

ORDER_BY_PAYDATE

public static final java.lang.String ORDER_BY_PAYDATE
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_QTYSHIPED

public static final java.lang.String ORDER_BY_QTYSHIPED
See Also:
Constant Field Values

ORDER_BY_TAX

public static final java.lang.String ORDER_BY_TAX
See Also:
Constant Field Values

ORDER_BY_AMOUNTPAID

public static final java.lang.String ORDER_BY_AMOUNTPAID
See Also:
Constant Field Values

ORDER_BY_SUBNETTOTAL

public static final java.lang.String ORDER_BY_SUBNETTOTAL
See Also:
Constant Field Values
Constructor Detail

SalesTaxListResult

public SalesTaxListResult()
Method Detail

getAmountPaid

public java.math.BigDecimal getAmountPaid()

getGrandTotal

public java.math.BigDecimal getGrandTotal()

getTax

public java.math.BigDecimal getTax()

getDiscountTotal

public java.math.BigDecimal getDiscountTotal()

getSubTotal

public java.math.BigDecimal getSubTotal()

getQtyShiped

public java.math.BigDecimal getQtyShiped()

getCustomerId

public java.lang.String getCustomerId()

getDescription

public java.lang.String getDescription()

getPartFrom

public java.lang.String getPartFrom()

getPartType

public java.lang.String getPartType()

getPartNumber

public java.lang.String getPartNumber()

getDateShiped

public java.util.Date getDateShiped()

getInvoiceItemNumber

public java.lang.String getInvoiceItemNumber()

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setInvoiceNumber

public void setInvoiceNumber(java.lang.String invoiceNumber)

setAmountPaid

public void setAmountPaid(java.math.BigDecimal amountPaid)

setGrandTotal

public void setGrandTotal(java.math.BigDecimal grandTotal)

setTax

public void setTax(java.math.BigDecimal tax)

setDiscountTotal

public void setDiscountTotal(java.math.BigDecimal discountTotal)

setSubTotal

public void setSubTotal(java.math.BigDecimal subTotal)

setQtyShiped

public void setQtyShiped(java.math.BigDecimal qtyShiped)

setCustomerId

public void setCustomerId(java.lang.String customerId)

setDescription

public void setDescription(java.lang.String description)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setPartType

public void setPartType(java.lang.String partType)

setPartNumber

public void setPartNumber(java.lang.String partNumber)

setDateShiped

public void setDateShiped(java.util.Date dateShiped)

setInvoiceItemNumber

public void setInvoiceItemNumber(java.lang.String invoiceItemNumber)

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getInvoiceNumber

public java.lang.String getInvoiceNumber()

getSubNetTotal

public java.math.BigDecimal getSubNetTotal()

setSubNetTotal

public void setSubNetTotal(java.math.BigDecimal subNetTotal)

getDateInvoiced

public java.util.Date getDateInvoiced()

setDateInvoiced

public void setDateInvoiced(java.util.Date dateInvoiced)

getPayDate

public java.util.Date getPayDate()

setPayDate

public void setPayDate(java.util.Date payDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ScrapAssetAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ScrapAssetAgent

java.lang.Object
    extended by  bb.common.ScrapAssetAgent
All Implemented Interfaces:
java.io.Serializable
public class ScrapAssetAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ScrapAssetAgent()
Method Summary
java.lang.String | getAssetAccount()
java.lang.String | getAssetLiquidationAccount()
java.lang.String | getDepricateAccount()
java.lang.String | getDescription()
void | setAssetAccount(java.lang.String assetAccount)
void | setAssetLiquidationAccount(java.lang.String assetLiquidationAccount)
void | setDepricateAccount(java.lang.String depricateAccount)
void | setDescription(java.lang.String description)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ScrapAssetAgent

public ScrapAssetAgent()
Method Detail

getAssetAccount

public java.lang.String getAssetAccount()

setAssetAccount

public void setAssetAccount(java.lang.String assetAccount)

getAssetLiquidationAccount

public java.lang.String getAssetLiquidationAccount()

setAssetLiquidationAccount

public void setAssetLiquidationAccount(java.lang.String assetLiquidationAccount)

getDepricateAccount

public java.lang.String getDepricateAccount()

setDepricateAccount

public void setDepricateAccount(java.lang.String depricateAccount)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ScrapReportVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ScrapReportVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ScrapReportVO
All Implemented Interfaces:
java.io.Serializable
public class ScrapReportVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
ScrapReportVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getApprovalBy()
java.util.Date | getApprovalDate()
java.math.BigDecimal | getCost()
java.lang.String | getCreditAccount()
java.lang.String | getDebitAccount()
java.lang.String | getDescription()
java.lang.String | getEnterBy()
java.util.Date | getLastChangeDate()
java.lang.Integer | getLastChangeTimes()
java.lang.String | getLastChangeUser()
java.lang.String | getNcrNumber()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getPoNumber()
java.lang.String | getProblemDescription()
java.math.BigDecimal | getScrapQty()
java.util.Date | getSrDate()
java.lang.String | getSrNumber()
java.lang.String | getStatus()
java.math.BigDecimal | getTotalCost()
java.lang.String | getTransactionNumber()
java.lang.String | getWoNumber()
int | hashCode()
void | setApprovalBy(java.lang.String approvalBy)
void | setApprovalDate(java.util.Date approvalDate)
void | setCost(java.math.BigDecimal cost)
void | setCreditAccount(java.lang.String creditAccount)
void | setDebitAccount(java.lang.String debitAccount)
void | setDescription(java.lang.String description)
void | setEnterBy(java.lang.String enterBy)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTimes(java.lang.Integer lastChangeTimes)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setNcrNumber(java.lang.String ncrNumber)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPoNumber(java.lang.String poNumber)
void | setProblemDescription(java.lang.String problemDescription)
void | setScrapQty(java.math.BigDecimal scrapQty)
void | setSrDate(java.util.Date srDate)
void | setSrNumber(java.lang.String srNumber)
void | setStatus(java.lang.String status)
void | setTotalCost(java.math.BigDecimal totalCost)
void | setTransactionNumber(java.lang.String transactionNumber)
void | setWoNumber(java.lang.String woNumber)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ScrapReportVO

public ScrapReportVO()
Method Detail

getSrNumber

public java.lang.String getSrNumber()

setSrNumber

public void setSrNumber(java.lang.String srNumber)

getNcrNumber

public java.lang.String getNcrNumber()

setNcrNumber

public void setNcrNumber(java.lang.String ncrNumber)

getEnterBy

public java.lang.String getEnterBy()

setEnterBy

public void setEnterBy(java.lang.String enterBy)

getSrDate

public java.util.Date getSrDate()

setSrDate

public void setSrDate(java.util.Date srDate)

getApprovalBy

public java.lang.String getApprovalBy()

setApprovalBy

public void setApprovalBy(java.lang.String approvalBy)

getApprovalDate

public java.util.Date getApprovalDate()

setApprovalDate

public void setApprovalDate(java.util.Date approvalDate)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeTimes

public java.lang.Integer getLastChangeTimes()

setLastChangeTimes

public void setLastChangeTimes(java.lang.Integer lastChangeTimes)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getScrapQty

public java.math.BigDecimal getScrapQty()

setScrapQty

public void setScrapQty(java.math.BigDecimal scrapQty)

getCost

public java.math.BigDecimal getCost()

setCost

public void setCost(java.math.BigDecimal cost)

getTotalCost

public java.math.BigDecimal getTotalCost()

setTotalCost

public void setTotalCost(java.math.BigDecimal totalCost)

getPoNumber

public java.lang.String getPoNumber()

setPoNumber

public void setPoNumber(java.lang.String poNumber)

getWoNumber

public java.lang.String getWoNumber()

setWoNumber

public void setWoNumber(java.lang.String woNumber)

getProblemDescription

public java.lang.String getProblemDescription()

setProblemDescription

public void setProblemDescription(java.lang.String problemDescription)

getTransactionNumber

public java.lang.String getTransactionNumber()

setTransactionNumber

public void setTransactionNumber(java.lang.String transactionNumber)

getDebitAccount

public java.lang.String getDebitAccount()

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

getCreditAccount

public java.lang.String getCreditAccount()

setCreditAccount

public void setCreditAccount(java.lang.String creditAccount)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SecurityBox

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common.box
Interface SecurityBox

public interface SecurityBox

Method Summary
void | addEjbMethod(EjbMethodVO ejbMethodVo)
void | addPermission(PermissionVO permissionVo)
void | addPermissionMethod(PermissionMethodVO permissionMethodVo)
void | addRole(RoleVO vo)
void | addRoleToUser(java.lang.String roleId, java.lang.String userName)
BizboxUserVO | addUser(BizboxUserVO vo)
void | batchUpdateExpiredDate(java.util.Date newdate)
RoleVO | copyRoleToRole(java.lang.String oldRoleId, java.lang.String roleId)
java.lang.String | copyUserToUser(User2UserAgent agent)
void | deleteEjbMethod(EjbMethodVO ejbMethodVo)
void | deletePermission(PermissionVO permissionVo)
void | deletePermissionMethod(PermissionMethodVO permissionMethodVo)
void | deleteRole(java.lang.String roleId)
void | deleteUser(java.lang.String userName)
java.util.Collection<EjbMethodVO> | findAllMethod(int firstIndex, int maxLength)
java.util.Collection<BizboxUserListResult> | findAllOnlineUsers(int firstIndex, int maxLength)
java.util.Collection<PermissionVO> | findAllPermission(boolean leaf, int firstIndex, int maxLength)
java.util.Collection<PermissionMethodVO> | findAllPermissionMethod(int firstIndex, int maxLength)
java.util.Collection<PermissionMethodVO> | findAllPermissionMethodsByUserName(java.lang.String username)
java.util.Collection<PermissionListResult> | findAllPermissionWithLanguage(boolean leaf, java.lang.String language, int firstIndex, int maxLength)
java.util.Collection<RoleListResult> | findAllRoles(java.lang.String language, int firstIndex, int maxLength)
java.util.Collection<RoleListResult> | findAllRolesByRoleId(java.lang.String roleId, java.lang.String language, int firstIndex, int maxLength)
java.util.Collection<BizboxUserListResult> | findAllUsers(int firstIndex, int maxLength)
java.util.Collection<BizBoxUserEmployeeResult> | findAllUsersEmployeeInfo(java.lang.String userName, java.lang.String systemUserName, boolean withoutLocked, int firstIndex, int maxLength)
java.util.Collection<BizBoxUserEmployeeResult> | findAllUsersEmployeeInfo(java.lang.String userName, java.lang.String systemUserName, int firstIndex, int maxLength)
java.util.Collection<PermissionMethodVO> | findEjbMethodsByPermissionId(java.lang.String permissionId, int firstIndex, int maxLength)
java.util.Collection<EjbMethodVO> | findMethodsByEjbName(java.lang.String ejbName, int firstIndex, int maxLength)
java.util.Collection<BizboxUserListResult> | findOnlineUsersByUserName(java.lang.String userName, int firstIndex, int maxLength)
java.util.Collection<PermissionListResult> | findPermissionsById(java.lang.String permissionId, java.lang.String language, int firstIndex, int maxLength)
java.util.Collection<PermissionVO> | findPermissionsByRole(java.lang.String roleId, int firstIndex, int maxLength)
java.util.Collection<java.lang.String> | findPermissionsBySelf()
java.util.Collection<PermissionVO> | findPermissionsBySelf(int firstIndex, int maxLength)
java.util.Collection<java.lang.String> | findPermissionsByUser(java.lang.String userName)
java.util.Collection<PermissionVO> | findPermissionsByUser(java.lang.String userName, int firstIndex, int maxLength)
java.util.Collection<RoleListResult> | findRolesByPermission(java.lang.String permissionId, java.lang.String language, int firstIndex, int maxLength)
java.util.Collection<RoleListResult> | findRolesBySelf(java.lang.String language, int firstIndex, int maxLength)
java.util.Collection<RoleListResult> | findRolesByUser(java.lang.String userName, java.lang.String language, int firstIndex, int maxLength)
java.lang.String | findTrueName(java.lang.String userName)
java.util.Collection<UserRolePermissionListResult> | findUserRoleByPermission(java.lang.String permissionId, java.lang.String language, int firstIndex, int maxLength)
java.util.Collection<BizboxUserListResult> | findUsers(java.lang.String userName, int status, java.util.Date lastLoginFrom, java.util.Date lastLoginTo, int type, int locked, int firstIndex, int maxLength)
java.util.Collection<BizboxUserListResult> | findUsersByEmployeeId(java.lang.String employeeId, int firstIndex, int maxLength)
java.util.Collection<BizboxUserListResult> | findUsersByPermission(java.lang.String permissionId, int firstIndex, int maxLength)
java.util.Collection<BizboxUserListResult> | findUsersByRole(java.lang.String roleId, int firstIndex, int maxLength)
java.util.Collection<BizboxUserListResult> | findUsersByUserName(java.lang.String userName, int firstIndex, int maxLength)
int | getAllMethodsCount()
int | getAllOnlineUsersCount()
int | getAllPermissionCount(boolean leaf)
int | getAllPermissionMethodCount()
int | getAllRolesByRoleIdCount(java.lang.String roleId, java.lang.String language)
int | getAllRolesCount(java.lang.String language)
int | getAllUsersCount()
int | getAllUsersEmployeeInfoCount(java.lang.String userName, java.lang.String systemUserName)
int | getAllUsersEmployeeInfoCount(java.lang.String userName, java.lang.String systemUserName, boolean withoutLocked)
int | getEjbMethodsByPermissionIdCount(java.lang.String permissionId)
int | getMethodsCountByEjbName(java.lang.String ejbName)
int | getOnlineUsersCountByUserName(java.lang.String userName)
PermissionVO | getPermissionByPK(java.lang.String permissionId)
PermissionMethodVO | getPermissionMethodByPk(PermissionMethodPK pk)
int | getPermissionsByIdCount(java.lang.String permissionId)
int | getPermissionsCountByRole(java.lang.String roleId)
int | getPermissionsCountBySelf()
int | getPermissionsCountByUser(java.lang.String userName)
RoleVO | getRoleByPk(java.lang.String roleId)
int | getRolesCountByPermission(java.lang.String permissionId, java.lang.String language)
int | getRolesCountBySelf(java.lang.String language)
int | getRolesCountByUser(java.lang.String userName, java.lang.String language)
BizboxUserVO | getUserByPk(java.lang.String userName)
BizboxUserVO | getUserBySelf()
int | getUserRoleCountByPermission(java.lang.String permissionId)
int | getUsersByEmployeeIdCount(java.lang.String employeeId)
int | getUsersCount(java.lang.String userName, int status, java.util.Date lastLoginFrom, java.util.Date lastLoginTo, int type, int locked)
int | getUsersCountByPermission(java.lang.String permissionId)
int | getUsersCountByRole(java.lang.String roleId)
int | getUsersCountByUserName(java.lang.String userName)
java.lang.String | getUsersMultiCompanyUnit(java.lang.String userName)
boolean | isBizBoxUserExistByUserName(java.lang.String userName)
boolean | isEmployeeIdUsedByOther(java.lang.String employeeId)
boolean | isLocked(java.lang.String userName, java.lang.String system)
boolean | isLogin(java.lang.String userName, java.lang.String system)
boolean | isMyPasswordExpired()
boolean | isRole(java.lang.String roleId)
boolean | isRoleExist(java.lang.String roleId)
boolean | isSystemRole(java.lang.String roleId)
boolean | isUserRoleExist(java.lang.String userName, java.lang.String roleId)
void | lockUser(java.lang.String userName)
void | lockUserByEmployeeId(java.lang.String employeeId)
void | logoutUser(java.lang.String userName, java.lang.String system)
void | removeRoleFromUser(java.lang.String roleId, java.lang.String userName)
void | resetUserCompanyUnitId(java.lang.String companyUnitId)
void | unlockUser(java.lang.String userName)
void | updateEjbMethod(EjbMethodVO ejbMethodVo)
void | updateMyPassword(java.lang.String password)
void | updatePermission(PermissionVO permissionVo)
void | updatePermissionMethod(PermissionMethodVO permissionMethodVo)
void | updateRole(RoleVO vo)
void | updateUser(BizboxUserVO vo, java.lang.String[] roleIDs)
void | updateUserPassword(java.lang.String password, java.lang.String userName)
void | updateUserRefId(java.lang.String userName, java.lang.String refId)

Method Detail

addUser

BizboxUserVO addUser(BizboxUserVO vo)
                     throws java.lang.Exception
Throws:
java.lang.Exception

deleteUser

void deleteUser(java.lang.String userName)
                throws java.lang.Exception
Throws:
java.lang.Exception

updateUser

void updateUser(BizboxUserVO vo,
                java.lang.String[] roleIDs)
                throws java.lang.Exception
Throws:
java.lang.Exception

updateUserRefId

void updateUserRefId(java.lang.String userName,
                     java.lang.String refId)
                     throws java.lang.Exception
Throws:
java.lang.Exception

isLogin

boolean isLogin(java.lang.String userName,
                java.lang.String system)
                throws java.lang.Exception
Throws:
java.lang.Exception

isLocked

boolean isLocked(java.lang.String userName,
                 java.lang.String system)
                 throws java.lang.Exception
Throws:
java.lang.Exception

logoutUser

void logoutUser(java.lang.String userName,
                java.lang.String system)
                throws java.lang.Exception
Throws:
java.lang.Exception

lockUser

void lockUser(java.lang.String userName)
              throws java.lang.Exception
Throws:
java.lang.Exception

unlockUser

void unlockUser(java.lang.String userName)
                throws java.lang.Exception
Throws:
java.lang.Exception

copyUserToUser

java.lang.String copyUserToUser(User2UserAgent agent)
                                throws java.lang.Exception
Throws:
java.lang.Exception

isMyPasswordExpired

boolean isMyPasswordExpired()
                            throws java.lang.Exception
Throws:
java.lang.Exception

getAllUsersCount

int getAllUsersCount()
                     throws java.lang.Exception
Throws:
java.lang.Exception

findAllUsers

java.util.Collection<BizboxUserListResult> findAllUsers(int firstIndex,
                                                        int maxLength)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getUserByPk

BizboxUserVO getUserByPk(java.lang.String userName)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findTrueName

java.lang.String findTrueName(java.lang.String userName)
                              throws java.lang.Exception
Throws:
java.lang.Exception

updateMyPassword

void updateMyPassword(java.lang.String password)
                      throws java.lang.Exception
Throws:
java.lang.Exception

updateUserPassword

void updateUserPassword(java.lang.String password,
                        java.lang.String userName)
                        throws java.lang.Exception
Throws:
java.lang.Exception

getUsersMultiCompanyUnit

java.lang.String getUsersMultiCompanyUnit(java.lang.String userName)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

findUsers

java.util.Collection<BizboxUserListResult> findUsers(java.lang.String userName,
                                                     int status,
                                                     java.util.Date lastLoginFrom,
                                                     java.util.Date lastLoginTo,
                                                     int type,
                                                     int locked,
                                                     int firstIndex,
                                                     int maxLength)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getUsersCount

int getUsersCount(java.lang.String userName,
                  int status,
                  java.util.Date lastLoginFrom,
                  java.util.Date lastLoginTo,
                  int type,
                  int locked)
                  throws java.lang.Exception
Throws:
java.lang.Exception

getUsersByEmployeeIdCount

int getUsersByEmployeeIdCount(java.lang.String employeeId)
                              throws java.lang.Exception
Throws:
java.lang.Exception

findUsersByEmployeeId

java.util.Collection<BizboxUserListResult> findUsersByEmployeeId(java.lang.String employeeId,
                                                                 int firstIndex,
                                                                 int maxLength)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

resetUserCompanyUnitId

void resetUserCompanyUnitId(java.lang.String companyUnitId)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findUsersByUserName

java.util.Collection<BizboxUserListResult> findUsersByUserName(java.lang.String userName,
                                                               int firstIndex,
                                                               int maxLength)
                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getUsersCountByUserName

int getUsersCountByUserName(java.lang.String userName)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findOnlineUsersByUserName

java.util.Collection<BizboxUserListResult> findOnlineUsersByUserName(java.lang.String userName,
                                                                     int firstIndex,
                                                                     int maxLength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getOnlineUsersCountByUserName

int getOnlineUsersCountByUserName(java.lang.String userName)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

getUserBySelf

BizboxUserVO getUserBySelf()
                           throws java.lang.Exception
Throws:
java.lang.Exception

findAllOnlineUsers

java.util.Collection<BizboxUserListResult> findAllOnlineUsers(int firstIndex,
                                                              int maxLength)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getAllOnlineUsersCount

int getAllOnlineUsersCount()
                           throws java.lang.Exception
Throws:
java.lang.Exception

isBizBoxUserExistByUserName

boolean isBizBoxUserExistByUserName(java.lang.String userName)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findAllUsersEmployeeInfo

java.util.Collection<BizBoxUserEmployeeResult> findAllUsersEmployeeInfo(java.lang.String userName,
                                                                        java.lang.String systemUserName,
                                                                        int firstIndex,
                                                                        int maxLength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getAllUsersEmployeeInfoCount

int getAllUsersEmployeeInfoCount(java.lang.String userName,
                                 java.lang.String systemUserName)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findAllUsersEmployeeInfo

java.util.Collection<BizBoxUserEmployeeResult> findAllUsersEmployeeInfo(java.lang.String userName,
                                                                        java.lang.String systemUserName,
                                                                        boolean withoutLocked,
                                                                        int firstIndex,
                                                                        int maxLength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getAllUsersEmployeeInfoCount

int getAllUsersEmployeeInfoCount(java.lang.String userName,
                                 java.lang.String systemUserName,
                                 boolean withoutLocked)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

batchUpdateExpiredDate

void batchUpdateExpiredDate(java.util.Date newdate)
                            throws java.lang.Exception
Throws:
java.lang.Exception

getPermissionsCountByRole

int getPermissionsCountByRole(java.lang.String roleId)
                              throws java.lang.Exception
Throws:
java.lang.Exception

findPermissionsByRole

java.util.Collection<PermissionVO> findPermissionsByRole(java.lang.String roleId,
                                                         int firstIndex,
                                                         int maxLength)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getPermissionsCountByUser

int getPermissionsCountByUser(java.lang.String userName)
                              throws java.lang.Exception
Throws:
java.lang.Exception

getPermissionsCountBySelf

int getPermissionsCountBySelf()
                              throws java.lang.Exception
Throws:
java.lang.Exception

findPermissionsByUser

java.util.Collection<PermissionVO> findPermissionsByUser(java.lang.String userName,
                                                         int firstIndex,
                                                         int maxLength)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

findPermissionsBySelf

java.util.Collection<PermissionVO> findPermissionsBySelf(int firstIndex,
                                                         int maxLength)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

findPermissionsByUser

java.util.Collection<java.lang.String> findPermissionsByUser(java.lang.String userName)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

findPermissionsBySelf

java.util.Collection<java.lang.String> findPermissionsBySelf()
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

isSystemRole

boolean isSystemRole(java.lang.String roleId)
                     throws java.lang.Exception
Throws:
java.lang.Exception

isRoleExist

boolean isRoleExist(java.lang.String roleId)
                    throws java.lang.Exception
Throws:
java.lang.Exception

copyRoleToRole

RoleVO copyRoleToRole(java.lang.String oldRoleId,
                      java.lang.String roleId)
                      throws java.lang.Exception
Throws:
java.lang.Exception

addRole

void addRole(RoleVO vo)
             throws java.lang.Exception
Throws:
java.lang.Exception

deleteRole

void deleteRole(java.lang.String roleId)
                throws java.lang.Exception
Throws:
java.lang.Exception

updateRole

void updateRole(RoleVO vo)
                throws java.lang.Exception
Throws:
java.lang.Exception

getRoleByPk

RoleVO getRoleByPk(java.lang.String roleId)
                   throws java.lang.Exception
Throws:
java.lang.Exception

getAllRolesByRoleIdCount

int getAllRolesByRoleIdCount(java.lang.String roleId,
                             java.lang.String language)
                             throws java.lang.Exception
Throws:
java.lang.Exception

findAllRolesByRoleId

java.util.Collection<RoleListResult> findAllRolesByRoleId(java.lang.String roleId,
                                                          java.lang.String language,
                                                          int firstIndex,
                                                          int maxLength)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getAllRolesCount

int getAllRolesCount(java.lang.String language)
                     throws java.lang.Exception
Throws:
java.lang.Exception

findAllRoles

java.util.Collection<RoleListResult> findAllRoles(java.lang.String language,
                                                  int firstIndex,
                                                  int maxLength)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getRolesCountByUser

int getRolesCountByUser(java.lang.String userName,
                        java.lang.String language)
                        throws java.lang.Exception
Throws:
java.lang.Exception

getRolesCountBySelf

int getRolesCountBySelf(java.lang.String language)
                        throws java.lang.Exception
Throws:
java.lang.Exception

findRolesByUser

java.util.Collection<RoleListResult> findRolesByUser(java.lang.String userName,
                                                     java.lang.String language,
                                                     int firstIndex,
                                                     int maxLength)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

findRolesBySelf

java.util.Collection<RoleListResult> findRolesBySelf(java.lang.String language,
                                                     int firstIndex,
                                                     int maxLength)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

addRoleToUser

void addRoleToUser(java.lang.String roleId,
                   java.lang.String userName)
                   throws java.lang.Exception
Throws:
java.lang.Exception

removeRoleFromUser

void removeRoleFromUser(java.lang.String roleId,
                        java.lang.String userName)
                        throws java.lang.Exception
Throws:
java.lang.Exception

isUserRoleExist

boolean isUserRoleExist(java.lang.String userName,
                        java.lang.String roleId)
                        throws java.lang.Exception
Throws:
java.lang.Exception

findUsersByRole

java.util.Collection<BizboxUserListResult> findUsersByRole(java.lang.String roleId,
                                                           int firstIndex,
                                                           int maxLength)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getUsersCountByRole

int getUsersCountByRole(java.lang.String roleId)
                        throws java.lang.Exception
Throws:
java.lang.Exception

findUsersByPermission

java.util.Collection<BizboxUserListResult> findUsersByPermission(java.lang.String permissionId,
                                                                 int firstIndex,
                                                                 int maxLength)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getUsersCountByPermission

int getUsersCountByPermission(java.lang.String permissionId)
                              throws java.lang.Exception
Throws:
java.lang.Exception

findRolesByPermission

java.util.Collection<RoleListResult> findRolesByPermission(java.lang.String permissionId,
                                                           java.lang.String language,
                                                           int firstIndex,
                                                           int maxLength)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getRolesCountByPermission

int getRolesCountByPermission(java.lang.String permissionId,
                              java.lang.String language)
                              throws java.lang.Exception
Throws:
java.lang.Exception

addPermission

void addPermission(PermissionVO permissionVo)
                   throws java.lang.Exception
Throws:
java.lang.Exception

deletePermission

void deletePermission(PermissionVO permissionVo)
                      throws java.lang.Exception
Throws:
java.lang.Exception

updatePermission

void updatePermission(PermissionVO permissionVo)
                      throws java.lang.Exception
Throws:
java.lang.Exception

findAllPermission

java.util.Collection<PermissionVO> findAllPermission(boolean leaf,
                                                     int firstIndex,
                                                     int maxLength)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

findAllPermissionWithLanguage

java.util.Collection<PermissionListResult> findAllPermissionWithLanguage(boolean leaf,
                                                                         java.lang.String language,
                                                                         int firstIndex,
                                                                         int maxLength)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getAllPermissionCount

int getAllPermissionCount(boolean leaf)
                          throws java.lang.Exception
Throws:
java.lang.Exception

getPermissionByPK

PermissionVO getPermissionByPK(java.lang.String permissionId)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findPermissionsById

java.util.Collection<PermissionListResult> findPermissionsById(java.lang.String permissionId,
                                                               java.lang.String language,
                                                               int firstIndex,
                                                               int maxLength)
                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getPermissionsByIdCount

int getPermissionsByIdCount(java.lang.String permissionId)
                            throws java.lang.Exception
Throws:
java.lang.Exception

addPermissionMethod

void addPermissionMethod(PermissionMethodVO permissionMethodVo)
                         throws java.lang.Exception
Throws:
java.lang.Exception

deletePermissionMethod

void deletePermissionMethod(PermissionMethodVO permissionMethodVo)
                            throws java.lang.Exception
Throws:
java.lang.Exception

updatePermissionMethod

void updatePermissionMethod(PermissionMethodVO permissionMethodVo)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findAllPermissionMethod

java.util.Collection<PermissionMethodVO> findAllPermissionMethod(int firstIndex,
                                                                 int maxLength)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getAllPermissionMethodCount

int getAllPermissionMethodCount()
                                throws java.lang.Exception
Throws:
java.lang.Exception

getPermissionMethodByPk

PermissionMethodVO getPermissionMethodByPk(PermissionMethodPK pk)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

findEjbMethodsByPermissionId

java.util.Collection<PermissionMethodVO> findEjbMethodsByPermissionId(java.lang.String permissionId,
                                                                      int firstIndex,
                                                                      int maxLength)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getEjbMethodsByPermissionIdCount

int getEjbMethodsByPermissionIdCount(java.lang.String permissionId)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

addEjbMethod

void addEjbMethod(EjbMethodVO ejbMethodVo)
                  throws java.lang.Exception
Throws:
java.lang.Exception

deleteEjbMethod

void deleteEjbMethod(EjbMethodVO ejbMethodVo)
                     throws java.lang.Exception
Throws:
java.lang.Exception

updateEjbMethod

void updateEjbMethod(EjbMethodVO ejbMethodVo)
                     throws java.lang.Exception
Throws:
java.lang.Exception

findAllMethod

java.util.Collection<EjbMethodVO> findAllMethod(int firstIndex,
                                                int maxLength)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllMethodsCount

int getAllMethodsCount()
                       throws java.lang.Exception
Throws:
java.lang.Exception

findMethodsByEjbName

java.util.Collection<EjbMethodVO> findMethodsByEjbName(java.lang.String ejbName,
                                                       int firstIndex,
                                                       int maxLength)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getMethodsCountByEjbName

int getMethodsCountByEjbName(java.lang.String ejbName)
                             throws java.lang.Exception
Throws:
java.lang.Exception

findAllPermissionMethodsByUserName

java.util.Collection<PermissionMethodVO> findAllPermissionMethodsByUserName(java.lang.String username)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

lockUserByEmployeeId

void lockUserByEmployeeId(java.lang.String employeeId)
                          throws java.lang.Exception
Throws:
java.lang.Exception

findUserRoleByPermission

java.util.Collection<UserRolePermissionListResult> findUserRoleByPermission(java.lang.String permissionId,
                                                                            java.lang.String language,
                                                                            int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getUserRoleCountByPermission

int getUserRoleCountByPermission(java.lang.String permissionId)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

isEmployeeIdUsedByOther

boolean isEmployeeIdUsedByOther(java.lang.String employeeId)
                                throws java.lang.Exception
Throws:
java.lang.Exception

isRole

boolean isRole(java.lang.String roleId)
               throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Serialized Form

Overview

Package

Class

Use

Tree

Deprecated

Index

Help

PREV NEXT

FRAMES NO FRAMES

Serialized Form

Package bb.common

Class bb.common.AccountAgingTotalResult extends java.lang.Object implements Serializable

Serialized Fields

currency
java.lang.String currency
totalDue
java.math.BigDecimal totalDue
current
java.math.BigDecimal current
d01_30
java.math.BigDecimal d01_30
d31_60
java.math.BigDecimal d31_60
d61_90
java.math.BigDecimal d61_90
d90_plus
java.math.BigDecimal d90_plus
Class bb.common.AccountAuditAgent extends java.lang.Object implements Serializable

Serialized Fields

orderNumLike
java.lang.String orderNumLike
addressIDLike
java.lang.String addressIDLike
currency
java.lang.String currency
startDate
java.util.Date startDate
Class bb.common.AccountBalanceAgent extends java.lang.Object implements Serializable

Serialized Fields

monthYear
java.lang.String monthYear
debitAccountBalance
java.util.Map<K,V> debitAccountBalance
creditAccountBalance
java.util.Map<K,V> creditAccountBalance
orgDebitAccountBalance
java.util.Map<K,V> orgDebitAccountBalance
orgCreditAccountBalance
java.util.Map<K,V> orgCreditAccountBalance
glSummary
java.lang.String glSummary
Class bb.common.AccountBalanceListResult extends java.lang.Object implements Serializable

Serialized Fields

addressId
java.lang.String addressId
addressName
java.lang.String addressName
accountNumber
java.lang.String accountNumber
companyUnitId
java.lang.String companyUnitId
accountDescription
java.lang.String accountDescription
debit
java.math.BigDecimal debit
credit
java.math.BigDecimal credit
balance
java.math.BigDecimal balance
Class bb.common.AccountBalanceResult extends java.lang.Object implements Serializable

Serialized Fields

accountNumber
java.lang.String accountNumber
upLevelAccount
java.lang.String upLevelAccount
items
byte items
level
java.lang.String level
accountType
java.lang.String accountType
deductable
java.lang.String deductable
debitOrCredit
java.lang.String debitOrCredit
description
java.lang.String description
debitBeginPeriodBalance
java.math.BigDecimal debitBeginPeriodBalance
creditBeginPeriodBalance
java.math.BigDecimal creditBeginPeriodBalance
debitAmount
java.math.BigDecimal debitAmount
creditAmount
java.math.BigDecimal creditAmount
debitEndPeriodBalance
java.math.BigDecimal debitEndPeriodBalance
creditEndPeriodBalance
java.math.BigDecimal creditEndPeriodBalance
balance
java.math.BigDecimal balance
beginPeriodBalance
java.math.BigDecimal beginPeriodBalance
Class bb.common.AccountCreditDebitPK extends java.lang.Object implements Serializable

Serialized Fields

itemNumber
java.lang.Integer itemNumber
identifier field

transactionNumber
java.lang.String transactionNumber
identifier field

Class bb.common.AccountCreditVO extends VO implements Serializable

Serialized Fields

pk
AccountCreditDebitPK pk
identifier field

transactionDate
java.util.Date transactionDate
persistent field

transactionType
java.lang.String transactionType
persistent field

addressId
java.lang.String addressId
persistent field

accountNumber
java.lang.String accountNumber
persistent field

credit
java.math.BigDecimal credit
nullable persistent field

currency
java.lang.String currency
originalCredit
java.math.BigDecimal originalCredit
persistent field

description
java.lang.String description
exchange
java.math.BigDecimal exchange
nullable persistent field

companyUnitId
java.lang.String companyUnitId
persistent field

accountsChart
AccountsChartVO accountsChart
alarmValue
boolean alarmValue
cause
java.lang.String cause
Class bb.common.AccountDebitVO extends VO implements Serializable

Serialized Fields

pk
AccountCreditDebitPK pk
identifier field

transactionDate
java.util.Date transactionDate
persistent field

transactionType
java.lang.String transactionType
persistent field

addressId
java.lang.String addressId
persistent field

accountNumber
java.lang.String accountNumber
persistent field

debit
java.math.BigDecimal debit
nullable persistent field

currency
java.lang.String currency
persistent field

exchange
java.math.BigDecimal exchange
nullable persistent field

originalDebit
java.math.BigDecimal originalDebit
persistent field

description
java.lang.String description
full constructor

companyUnitId
java.lang.String companyUnitId
persistent field

accountsChart
AccountsChartVO accountsChart
alarmValue
boolean alarmValue
cause
java.lang.String cause
Class bb.common.AccountInfoCenterItemResult extends java.lang.Object implements Serializable

Serialized Fields

count
java.lang.Long count
currency
java.lang.String currency
total
java.math.BigDecimal total
Class bb.common.AccountInfoCenterResult extends java.lang.Object implements Serializable

Serialized Fields

arOpenItems
java.util.Set<E> arOpenItems
arDueItems
java.util.Set<E> arDueItems
apOpenItems
java.util.Set<E> apOpenItems
apDueItems
java.util.Set<E> apDueItems
Class bb.common.AccountingBalanceSheetResult extends java.lang.Object implements Serializable

Serialized Fields

cash
java.math.BigDecimal cash
tradeAccount
java.math.BigDecimal tradeAccount
inventory
java.math.BigDecimal inventory
otherCurrentAssets
java.math.BigDecimal otherCurrentAssets
totalCurrentAssets
java.math.BigDecimal totalCurrentAssets
totalAssets
java.math.BigDecimal totalAssets
longTermAssets
java.math.BigDecimal longTermAssets
propertyEquipments
java.math.BigDecimal propertyEquipments
accountsPayable
java.math.BigDecimal accountsPayable
totalCurrentLiabilities
java.math.BigDecimal totalCurrentLiabilities
totalLiabilities
java.math.BigDecimal totalLiabilities
retainedEarnings
java.math.BigDecimal retainedEarnings
totalShareholdersEquity
java.math.BigDecimal totalShareholdersEquity
totalLiabilityesEquity
java.math.BigDecimal totalLiabilityesEquity
shareholders
java.util.Set<E> shareholders
Class bb.common.AccountingConfigurationVO extends VO implements Serializable

Serialized Fields

id
java.lang.String id
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
useJournalAccount
boolean useJournalAccount
useApprovalGl
boolean useApprovalGl
useAutoApprovalGl
boolean useAutoApprovalGl
usePostGl
boolean usePostGl
useCarryOverPL
boolean useCarryOverPL
useTaxReport
boolean useTaxReport
useCloseEntry
boolean useCloseEntry
arOrcmApprovedBy
java.lang.String arOrcmApprovedBy
apOrdmApprovedBy
java.lang.String apOrdmApprovedBy
recWoApprovedBy
java.lang.String recWoApprovedBy
stdCostApprovedBy
java.lang.String stdCostApprovedBy
assetApprovedBy
java.lang.String assetApprovedBy
ncrScrapApprovedBy
java.lang.String ncrScrapApprovedBy
localSettings
java.lang.String localSettings
glStyle
java.lang.String glStyle
Class bb.common.AccountingInfoDocumentVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
yearCode
java.lang.String yearCode
userName
java.lang.String userName
companyUnitId
java.lang.String companyUnitId
documentDate
java.util.Date documentDate
comments
java.lang.String comments
lastUser
java.lang.String lastUser
extension
java.lang.String extension
lastChangeDate
java.util.Date lastChangeDate
docLength
long docLength
docName
java.lang.String docName
accountingReportType
java.lang.String accountingReportType
reSend
boolean reSend
currentPeriodFrom
java.util.Date currentPeriodFrom
currentPeriodTo
java.util.Date currentPeriodTo
priorPeriodFrom
java.util.Date priorPeriodFrom
priorPeriodTo
java.util.Date priorPeriodTo
document
byte[] document
Class bb.common.AccountingSettingsVO extends VO implements Serializable

Serialized Fields

id
java.lang.String id
identifier field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

inventoryValuation
java.lang.String inventoryValuation
directMaterialPriceVarianceAccount
java.lang.String directMaterialPriceVarianceAccount
directMaterialUsageVarianceAccount
java.lang.String directMaterialUsageVarianceAccount
currentRetainedEarning
java.lang.String currentRetainedEarning
woDebitAccount
java.lang.String woDebitAccount
persistent field

poDebitAccount
java.lang.String poDebitAccount
persistent field

mpoDebitAccount
java.lang.String mpoDebitAccount
poVAT
java.lang.String poVAT
purchaseOrderPrepay
java.lang.String purchaseOrderPrepay
apDiscountAccount
java.lang.String apDiscountAccount
apDiscountMethod
java.lang.String apDiscountMethod
soCreditAccount
java.lang.String soCreditAccount
persistent field

soVAT
java.lang.String soVAT
salesOrderPrepay
java.lang.String salesOrderPrepay
arDiscountAccount
java.lang.String arDiscountAccount
arDiscountMethod
java.lang.String arDiscountMethod
gaInboundFreight
java.lang.String gaInboundFreight
persistent field

gaOutboundFreight
java.lang.String gaOutboundFreight
persistent field

gaCogs
java.lang.String gaCogs
persistent field

gaWoic
java.lang.String gaWoic
persistent field

gaWip
java.lang.String gaWip
gaEmployeeLabor
java.lang.String gaEmployeeLabor
gaScrap
java.lang.String gaScrap
persistent field

gaCogsContra
java.lang.String gaCogsContra
nullable persistent field

gaBusinessIncome
java.lang.String gaBusinessIncome
persistent field

gaAp
java.lang.String gaAp
persistent field

gaPurchaseDiscount
java.lang.String gaPurchaseDiscount
apBatch
java.lang.String apBatch
persistent field

gaAr
java.lang.String gaAr
persistent field

gaChecking
java.lang.String gaChecking
persistent field

gaCheckNo
java.lang.String gaCheckNo
persistent field

arWireFeeAccount
java.lang.String arWireFeeAccount
assetDeprCreditAccount
java.lang.String assetDeprCreditAccount
gaExchangeGainsAndLoss
java.lang.String gaExchangeGainsAndLoss
gaZero
java.math.BigDecimal gaZero
persistent field

glNdaysOk
int glNdaysOk
persistent field

checkPrintAdjust
byte checkPrintAdjust
version
java.lang.Integer version
nullable persistent field

useZipCode
boolean useZipCode
laborCost
boolean laborCost
machineCost
boolean machineCost
startWipDate
java.util.Date startWipDate
currentYearMonth
java.lang.String currentYearMonth
gaProfitForCurrentYear
java.lang.String gaProfitForCurrentYear
valuationStorageAccount
java.lang.String valuationStorageAccount
materialValuationStorageVarianceAccount
java.lang.String materialValuationStorageVarianceAccount
unbilledAccount
java.lang.String unbilledAccount
unbilledIncomeAccount
java.lang.String unbilledIncomeAccount
vendorPaymentVarianceAccount
java.lang.String vendorPaymentVarianceAccount
gaDep
java.lang.String gaDep
checkPrintAdjustX
byte checkPrintAdjustX
checkPrintAdjustY
byte checkPrintAdjustY
financingExpensesAccount
java.lang.String financingExpensesAccount
Class bb.common.AccountingTotalMoneyResult extends java.lang.Object implements Serializable

Serialized Fields

unitTotal
java.math.BigDecimal unitTotal
shipTotal
java.math.BigDecimal shipTotal
openTotal
java.math.BigDecimal openTotal
discountTotal
java.math.BigDecimal discountTotal
totalNet
java.math.BigDecimal totalNet
totalTax
java.math.BigDecimal totalTax
freightTotal
java.math.BigDecimal freightTotal
grandTotal
java.math.BigDecimal grandTotal
totalPaid
java.math.BigDecimal totalPaid
currency
java.lang.String currency
amountDue
java.math.BigDecimal amountDue
subNetTotal
java.math.BigDecimal subNetTotal
avgMargin
java.math.BigDecimal avgMargin
stdMargin
java.math.BigDecimal stdMargin
avgMarginPercent
java.math.BigDecimal avgMarginPercent
stdMarginPercent
java.math.BigDecimal stdMarginPercent
Class bb.common.AccountingTransactionTypeVO extends VO implements Serializable

Serialized Fields

transactionType
java.lang.String transactionType
description
java.lang.String description
Class bb.common.AccountMonthPK extends java.lang.Object implements Serializable

Serialized Fields

accountNumber
java.lang.String accountNumber
identifier field

companyUnitId
java.lang.String companyUnitId
identifier field

month
java.lang.String month
identifier field

Class bb.common.AccountPayableCheckRunItemVO extends VO implements Serializable

Serialized Fields

pk
PayableCheckRunItemPK pk
identifier field

status
java.lang.String status
persistent field

apStatus
java.lang.String apStatus
lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

checkNumber
java.lang.String checkNumber
persistent field

memo
java.lang.String memo
persistent field

poNumber
java.lang.String poNumber
persistent field

receiverNumber
java.lang.String receiverNumber
persistent field

vendorId
java.lang.String vendorId
persistent field

toBePaid
java.math.BigDecimal toBePaid
persistent field

currency
java.lang.String currency
persistent field

exchange
java.math.BigDecimal exchange
persistent field

language
java.lang.String language
persistent field

vendorInvoice
java.lang.String vendorInvoice
persistent field

vendorTotal
java.math.BigDecimal vendorTotal
persistent field

vendorInvoiceDate
java.util.Date vendorInvoiceDate
persistent field

payDate
java.util.Date payDate
persistent field

due
java.math.BigDecimal due
persistent field

apTotal
java.math.BigDecimal apTotal
paid
java.math.BigDecimal paid
transactionNo
java.lang.String transactionNo
customerAddressInfo
CustomerVendorAddressInfoVO customerAddressInfo
version
int version
nullable persistent field

checkTotal
java.math.BigDecimal checkTotal
Class bb.common.AccountPayableCheckRunVO extends VO implements Serializable

Serialized Fields

checkRunNumber
java.lang.String checkRunNumber
identifier field

status
java.lang.String status
persistent field

checkNumber
java.lang.String checkNumber
persistent field

datePaid
java.util.Date datePaid
transactionDate
java.util.Date transactionDate
persistent field

gaAp
java.lang.String gaAp
persistent field

gaChecking
java.lang.String gaChecking
persistent field

include
java.lang.String include
persistent field

exclude
java.lang.String exclude
persistent field

date1
java.util.Date date1
persistent field

date2
java.util.Date date2
persistent field

checked
java.lang.String checked
persistent field

madeBy
java.lang.String madeBy
companyUnitOfGaAp
java.lang.String companyUnitOfGaAp
persistent field

companyUnitOfGaChecking
java.lang.String companyUnitOfGaChecking
persistent field

checkRunItems
java.util.Set<E> checkRunItems
persistent field

Class bb.common.AccountPayableCheckVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
identifier field

companyUnitId
java.lang.String companyUnitId
persistent field

accountNumber
java.lang.String accountNumber
identifier field

checkNumber
java.lang.String checkNumber
identifier field

status
java.lang.String status
persistent field

checkNumberInt
int checkNumberInt
persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

origin
java.lang.String origin
persistent field

checkRunNumber
java.lang.String checkRunNumber
persistent field

vendorId
java.lang.String vendorId
persistent field

remitId
java.lang.String remitId
persistent field

tn1
java.lang.String tn1
persistent field

tn2
java.lang.String tn2
persistent field

numberOfAPs
java.lang.Long numberOfAPs
persistent field

datePaid
java.util.Date datePaid
persistent field

memo
java.lang.String memo
persistent field

paid
java.math.BigDecimal paid
persistent field

paidExactly
java.lang.String paidExactly
persistent field

currency
java.lang.String currency
persistent field

exchange
java.math.BigDecimal exchange
persistent field

language
java.lang.String language
persistent field

name
java.lang.String name
persistent field

address1
java.lang.String address1
persistent field

address2
java.lang.String address2
persistent field

city
java.lang.String city
persistent field

state
java.lang.String state
persistent field

zip
java.lang.String zip
persistent field

country
java.lang.String country
persistent field

comment
java.lang.String comment
nullable persistent field

version
int version
nullable persistent field

vendorInvoice
java.lang.String vendorInvoice
Class bb.common.AccountPayableInfoWithPrepayResult extends java.lang.Object implements Serializable

Serialized Fields

vendorId
java.lang.String vendorId
vendorName
java.lang.String vendorName
apNumber
java.lang.String apNumber
vendorInvoice
java.lang.String vendorInvoice
companyUnitId
java.lang.String companyUnitId
vendorTotal
java.math.BigDecimal vendorTotal
apNet
java.math.BigDecimal apNet
due
java.math.BigDecimal due
payDate
java.util.Date payDate
poNumber
java.lang.String poNumber
appNumber
java.lang.String appNumber
apPrepay
java.math.BigDecimal apPrepay
apPrepayGl
java.math.BigDecimal apPrepayGl
apPrepayDue
java.math.BigDecimal apPrepayDue
apPrepayApply
java.math.BigDecimal apPrepayApply
receiverNumber
java.lang.String receiverNumber
buyer
java.lang.String buyer
status
java.lang.String status
Class bb.common.AccountReceivableInfoWithPrepayResult extends java.lang.Object implements Serializable

Serialized Fields

customerId
java.lang.String customerId
customerName
java.lang.String customerName
invoiceNumber
java.lang.String invoiceNumber
salesOrderNumber
java.lang.String salesOrderNumber
companyUnitId
java.lang.String companyUnitId
grandTotal
java.math.BigDecimal grandTotal
amountDue
java.math.BigDecimal amountDue
payDate
java.util.Date payDate
arpNumber
java.lang.String arpNumber
arPrepay
java.math.BigDecimal arPrepay
arPrepayGl
java.math.BigDecimal arPrepayGl
arPrepayDue
java.math.BigDecimal arPrepayDue
arPrepayApply
java.math.BigDecimal arPrepayApply
Class bb.common.AccountReceivablePaymentVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
identifier field

paymentNumber
java.lang.String paymentNumber
customerId
java.lang.String customerId
gaChecking
java.lang.String gaChecking
persistent field

companyUnitOfGaChecking
java.lang.String companyUnitOfGaChecking
status
java.lang.String status
persistent field

paymentNoInt
int paymentNoInt
persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

origin
java.lang.String origin
persistent field

paymentRunNumber
java.lang.String paymentRunNumber
persistent field

remitId
java.lang.String remitId
persistent field

tn1
java.lang.String tn1
persistent field

tn2
java.lang.String tn2
persistent field

nnAr
byte nnAr
persistent field

datePaid
java.util.Date datePaid
persistent field

memo
java.lang.String memo
persistent field

paid
java.math.BigDecimal paid
persistent field

paidExactly
java.lang.String paidExactly
persistent field

currency
java.lang.String currency
persistent field

exchange
java.math.BigDecimal exchange
persistent field

language
java.lang.String language
persistent field

name
java.lang.String name
persistent field

addr1
java.lang.String addr1
persistent field

addr2
java.lang.String addr2
persistent field

city
java.lang.String city
persistent field

state
java.lang.String state
persistent field

zip
java.lang.String zip
persistent field

country
java.lang.String country
persistent field

pp
java.lang.String pp
nullable persistent field

version
int version
nullable persistent field

Class bb.common.AccountsChartAdvanceCategoryVO extends VO implements Serializable

Serialized Fields

type
java.lang.String type
monthYear
java.lang.String monthYear
data
byte[] data
Class bb.common.AccountsChartCategoryListResult extends AccountsChartCategoryVO implements Serializable

Serialized Fields

balance
java.math.BigDecimal balance
yearBalance
java.math.BigDecimal yearBalance
Class bb.common.AccountsChartCategoryVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
identifier field

categoryName
java.lang.String categoryName
persistent field

parentCategory
java.lang.Long parentCategory
persistent field

index
java.lang.Integer index
persistent field

predefined
boolean predefined
persistent field

visibleInReport
boolean visibleInReport
persistent field

categoryType
java.lang.String categoryType
persistent field

reportType
java.lang.String reportType
persistent field

formula
java.lang.String formula
persistent field

yearBalanceFormula
java.lang.String yearBalanceFormula
persistent field

Class bb.common.AccountsChartMappingPK extends java.lang.Object implements Serializable

Serialized Fields

serverAccountNumber
java.lang.String serverAccountNumber
subAccountNumber
java.lang.String subAccountNumber
subcompanyId
java.lang.String subcompanyId
Class bb.common.AccountsChartMappingVO extends VO implements Serializable

Serialized Fields

pk
AccountsChartMappingPK pk
origin
java.lang.String origin
createdDate
java.util.Date createdDate
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
comments
java.lang.String comments
Class bb.common.AccountsChartResult extends java.lang.Object implements Serializable

Serialized Fields

accountsChartVO
AccountsChartVO accountsChartVO
budgetAccountsChart
java.util.Map<K,V> budgetAccountsChart
actualAccountsChart
java.util.Map<K,V> actualAccountsChart
Class bb.common.AccountsChartVO extends VO implements Serializable

Serialized Fields

accountNumber
java.lang.String accountNumber
identifier field

items
byte items
persistent field

level
java.lang.String level
upLevelAccount
java.lang.String upLevelAccount
lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

adate
java.util.Date adate
nullable persistent field

origin
java.lang.String origin
persistent field

accountType
java.lang.String accountType
persistent field

deductable
java.lang.String deductable
persistent field

debitOrCredit
java.lang.String debitOrCredit
persistent field

type
java.lang.String type
description
java.lang.String description
persistent field

lastChangeTimes
int lastChangeTimes
nullable persistent field

categoryId
java.lang.Long categoryId
active
boolean active
accountSubType
java.lang.String accountSubType
foreignCurrencyAcc
boolean foreignCurrencyAcc
auditForeignCurrency
boolean auditForeignCurrency
multiLanuageDescription
java.util.Set<E> multiLanuageDescription
Class bb.common.AccountsCreditDebitListResult extends java.lang.Object implements Serializable

Serialized Fields

transactionNo
java.lang.String transactionNo
transactionDate
java.util.Date transactionDate
transactionType
java.lang.String transactionType
accountNumber
java.lang.String accountNumber
creditDebit
java.math.BigDecimal creditDebit
description
java.lang.String description
alarmValue
boolean alarmValue
cause
java.lang.String cause
Class bb.common.AccountsPayableInfoVO extends VO implements Serializable

Serialized Fields

apNumber
java.lang.String apNumber
identifier field

poNumber
java.lang.String poNumber
persistent field

receiverNumber
java.lang.String receiverNumber
persistent field

vendorId
java.lang.String vendorId
persistent field

apDate
java.util.Date apDate
batch
java.lang.String batch
persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

adate
java.util.Date adate
nullable persistent field

origin
java.lang.String origin
persistent field

apNetSet
java.lang.String apNetSet
persistent field

apTaxSet
java.lang.String apTaxSet
persistent field

apSub
java.math.BigDecimal apSub
persistent field

apRecieved
java.math.BigDecimal apRecieved
persistent field

apOpen
java.math.BigDecimal apOpen
persistent field

apDiscount
java.math.BigDecimal apDiscount
persistent field

apNet
java.math.BigDecimal apNet
persistent field

apTax
java.math.BigDecimal apTax
persistent field

apFreight
java.math.BigDecimal apFreight
persistent field

apTotal
java.math.BigDecimal apTotal
persistent field

apPaidRcv
java.math.BigDecimal apPaidRcv
persistent field

apPaidGl
java.math.BigDecimal apPaidGl
persistent field

apGl1Recorded
java.math.BigDecimal apGl1Recorded
persistent field

apGl2Paid
java.math.BigDecimal apGl2Paid
persistent field

changeOrder
java.lang.String changeOrder
persistent field

status
java.lang.String status
persistent field

collect
java.lang.String collect
persistent field

freightWho
java.lang.String freightWho
persistent field

receivedBy
java.lang.String receivedBy
persistent field

dateReceived
java.util.Date dateReceived
nullable persistent field

deliveredTo
java.lang.String deliveredTo
persistent field

freightBill
java.lang.String freightBill
persistent field

shippedVia
java.lang.String shippedVia
persistent field

carrier
java.lang.String carrier
persistent field

carrierAccount
java.lang.String carrierAccount
persistent field

tracking
java.lang.String tracking
persistent field

incoterm
java.lang.String incoterm
persistent field

incotermPlacePort
java.lang.String incotermPlacePort
persistent field

currency
java.lang.String currency
persistent field

exchange
java.math.BigDecimal exchange
persistent field

terms
java.lang.String terms
persistent field

termsDiscountPercent
java.lang.String termsDiscountPercent
termsDiscountDay
java.lang.String termsDiscountDay
buyer
java.lang.String buyer
requestor
java.lang.String requestor
persistent field

project
java.lang.String project
persistent field

reldoc
java.lang.String reldoc
persistent field

debitAccount
java.lang.String debitAccount
persistent field

bp
java.lang.String bp
persistent field

comments
java.lang.String comments
nullable persistent field

notes
java.lang.String notes
nullable persistent field

termsDiscount
java.math.BigDecimal termsDiscount
due
java.math.BigDecimal due
persistent field

vendorInvoice
java.lang.String vendorInvoice
persistent field

vendorPackage
java.lang.String vendorPackage
persistent field

vendorTotal
java.math.BigDecimal vendorTotal
persistent field

vendorInvoiceDate
java.util.Date vendorInvoiceDate
nullable persistent field

payDate
java.util.Date payDate
nullable persistent field

datePaid
java.util.Date datePaid
nullable persistent field

checkNumber
java.lang.String checkNumber
persistent field

paid
java.math.BigDecimal paid
persistent field

itran
java.lang.String itran
persistent field

etran
java.lang.String etran
persistent field

companyUnitId
java.lang.String companyUnitId
persistent field

version
java.lang.Integer version
nullable persistent field

customerAddressInfo
CustomerVendorAddressInfoVO customerAddressInfo
nullable persistent field

employee
EmployeeCardVO employee
Class bb.common.AccountsPayableItemManufacturerPK extends java.lang.Object implements Serializable

Serialized Fields

apNumber
java.lang.String apNumber
purchaseOrderItemNumber
java.lang.String purchaseOrderItemNumber
itemNumber
java.lang.Short itemNumber
Class bb.common.AccountsPayableItemManufacturerVO extends VO implements Serializable

Serialized Fields

pk
AccountsPayableItemManufacturerPK pk
manufacturerName
java.lang.String manufacturerName
manufacturerPartNumber
java.lang.String manufacturerPartNumber
Class bb.common.AccountsPayableItemPK extends java.lang.Object implements Serializable

Serialized Fields

apNumber
java.lang.String apNumber
identifier field

apItemNumber
java.lang.String apItemNumber
identifier field

Class bb.common.AccountsPayableItemVO extends VO implements Serializable

Serialized Fields

pk
AccountsPayableItemPK pk
identifier field

poNumber
java.lang.String poNumber
persistent field

apSub
java.math.BigDecimal apSub
persistent field

apReceived
java.math.BigDecimal apReceived
persistent field

apOpen
java.math.BigDecimal apOpen
persistent field

apDiscount
java.math.BigDecimal apDiscount
persistent field

apNet
java.math.BigDecimal apNet
persistent field

apTax
java.math.BigDecimal apTax
persistent field

apTotal
java.math.BigDecimal apTotal
persistent field

due
java.math.BigDecimal due
persistent field

paid
java.math.BigDecimal paid
persistent field

datePaid
java.util.Date datePaid
nullable persistent field

checkNumber
java.lang.String checkNumber
persistent field

refDoc1
java.lang.String refDoc1
persistent field

refDoc2
java.lang.String refDoc2
persistent field

qr
java.lang.String qr
persistent field

sentTo
java.lang.String sentTo
persistent field

receivedBy
java.lang.String receivedBy
persistent field

condition
java.lang.String condition
persistent field

status
java.lang.String status
persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
persistent field

moldeNumber
java.lang.String moldeNumber
persistent field

revision
java.lang.String revision
persistent field

location
java.lang.String location
persistent field

quantity
java.math.BigDecimal quantity
persistent field

qtyTraced
java.math.BigDecimal qtyTraced
persistent field

qtyReceived
java.math.BigDecimal qtyReceived
persistent field

cost
java.math.BigDecimal cost
persistent field

stdCost
java.math.BigDecimal stdCost
unit
java.lang.String unit
persistent field

discount
java.math.BigDecimal discount
persistent field

taxRate
java.math.BigDecimal taxRate
persistent field

description
java.lang.String description
persistent field

mfg
java.lang.String mfg
persistent field

mpn
java.lang.String mpn
persistent field

serial
java.lang.String serial
persistent field

comments
java.lang.String comments
nullable persistent field

notes
java.lang.String notes
nullable persistent field

refDocTwoes
java.util.Set<E> refDocTwoes
nullable persistent field

refDocOnes
java.util.Set<E> refDocOnes
accountsPayableItemManufacturer
java.util.Set<E> accountsPayableItemManufacturer
poRecQty
java.math.BigDecimal poRecQty
receiverNumber
java.lang.String receiverNumber
receiverItemNumber
java.lang.String receiverItemNumber
accountNumber
java.lang.String accountNumber
productCode
java.lang.String productCode
Class bb.common.AccountsPayableVO extends VO implements Serializable

Serialized Fields

apNumber
java.lang.String apNumber
identifier field

poNumber
java.lang.String poNumber
persistent field

receiverNumber
java.lang.String receiverNumber
persistent field

vendorId
java.lang.String vendorId
persistent field

apDate
java.util.Date apDate
batch
java.lang.String batch
persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

adate
java.util.Date adate
nullable persistent field

origin
java.lang.String origin
persistent field

apNetSet
java.lang.String apNetSet
persistent field

apTaxSet
java.lang.String apTaxSet
persistent field

apSub
java.math.BigDecimal apSub
persistent field

apRecieved
java.math.BigDecimal apRecieved
persistent field

apOpen
java.math.BigDecimal apOpen
persistent field

apDiscount
java.math.BigDecimal apDiscount
persistent field

apNet
java.math.BigDecimal apNet
persistent field

apTax
java.math.BigDecimal apTax
persistent field

apFreight
java.math.BigDecimal apFreight
persistent field

apTotal
java.math.BigDecimal apTotal
persistent field

apPaidRcv
java.math.BigDecimal apPaidRcv
persistent field

apPaidGl
java.math.BigDecimal apPaidGl
persistent field

apGl1Recorded
java.math.BigDecimal apGl1Recorded
persistent field

apGl2Paid
java.math.BigDecimal apGl2Paid
persistent field

changeOrder
java.lang.String changeOrder
persistent field

status
java.lang.String status
persistent field

collect
java.lang.String collect
persistent field

freightWho
java.lang.String freightWho
persistent field

receivedBy
java.lang.String receivedBy
persistent field

dateReceived
java.util.Date dateReceived
nullable persistent field

deliveredTo
java.lang.String deliveredTo
persistent field

freightBill
java.lang.String freightBill
persistent field

shippedVia
java.lang.String shippedVia
persistent field

carrier
java.lang.String carrier
persistent field

carrierAccount
java.lang.String carrierAccount
persistent field

tracking
java.lang.String tracking
persistent field

incoterm
java.lang.String incoterm
persistent field

incotermPlacePort
java.lang.String incotermPlacePort
persistent field

currency
java.lang.String currency
persistent field

exchange
java.math.BigDecimal exchange
persistent field

terms
java.lang.String terms
persistent field

termsDiscountPercent
java.lang.String termsDiscountPercent
termsDiscountDay
java.lang.String termsDiscountDay
buyer
java.lang.String buyer
requestor
java.lang.String requestor
persistent field

project
java.lang.String project
persistent field

reldoc
java.lang.String reldoc
persistent field

debitAccount
java.lang.String debitAccount
persistent field

bp
java.lang.String bp
persistent field

comments
java.lang.String comments
nullable persistent field

notes
java.lang.String notes
nullable persistent field

termsDiscount
java.math.BigDecimal termsDiscount
due
java.math.BigDecimal due
persistent field

vendorInvoice
java.lang.String vendorInvoice
persistent field

vendorPackage
java.lang.String vendorPackage
persistent field

vendorTotal
java.math.BigDecimal vendorTotal
persistent field

vendorInvoiceDate
java.util.Date vendorInvoiceDate
nullable persistent field

payDate
java.util.Date payDate
nullable persistent field

datePaid
java.util.Date datePaid
nullable persistent field

checkNumber
java.lang.String checkNumber
persistent field

paid
java.math.BigDecimal paid
persistent field

itran
java.lang.String itran
persistent field

etran
java.lang.String etran
persistent field

companyUnitId
java.lang.String companyUnitId
persistent field

version
java.lang.Integer version
nullable persistent field

customerAddressInfo
CustomerVendorAddressInfoVO customerAddressInfo
nullable persistent field

accountsPayableItems
java.util.Set<E> accountsPayableItems
persistent field

employee
EmployeeCardVO employee
coComments
java.lang.String coComments
poGrandTotal
java.math.BigDecimal poGrandTotal
reCalcSubTotal
boolean reCalcSubTotal
reCalcTax
boolean reCalcTax
apGLDate
java.util.Date apGLDate
paymentVariance
java.math.BigDecimal paymentVariance
Class bb.common.AccountsReceivableInfoVO extends VO implements Serializable

Serialized Fields

invoiceNumber
java.lang.String invoiceNumber
identifier field

salesOrderNumber
java.lang.String salesOrderNumber
persistent field

shipperNumber
java.lang.String shipperNumber
persistent field

pfInvoiceNumber
java.lang.String pfInvoiceNumber
customerId
java.lang.String customerId
persistent field

batchNumber
java.lang.String batchNumber
billTo
java.lang.String billTo
persistent field

customerPoNumber
java.lang.String customerPoNumber
persistent field

customerEmail
java.lang.String customerEmail
persistent field

contact
java.lang.String contact
persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

adate
java.util.Date adate
nullable persistent field

origin
java.lang.String origin
persistent field

arNetSet
java.lang.String arNetSet
persistent field

arTaxSet
java.lang.String arTaxSet
persistent field

subUnitTotal
java.math.BigDecimal subUnitTotal
persistent field

arShip
java.math.BigDecimal arShip
persistent field

arOpen
java.math.BigDecimal arOpen
persistent field

subDiscountTotal
java.math.BigDecimal subDiscountTotal
persistent field

subNetTotal
java.math.BigDecimal subNetTotal
persistent field

taxTotal
java.math.BigDecimal taxTotal
persistent field

freightTotal
java.math.BigDecimal freightTotal
persistent field

grandTotal
java.math.BigDecimal grandTotal
persistent field

margin
java.math.BigDecimal margin
marginPercent
java.math.BigDecimal marginPercent
totalCost
java.math.BigDecimal totalCost
marginByStdCost
java.math.BigDecimal marginByStdCost
marginPercentByStdCost
java.math.BigDecimal marginPercentByStdCost
totalStdCost
java.math.BigDecimal totalStdCost
arPaidInvoice
java.math.BigDecimal arPaidInvoice
persistent field

arPaidGl
java.math.BigDecimal arPaidGl
persistent field

arGl1Recorded
java.math.BigDecimal arGl1Recorded
persistent field

arGl2Paid
java.math.BigDecimal arGl2Paid
persistent field

changeOrder
java.lang.String changeOrder
persistent field

status
java.lang.String status
persistent field

salesman
java.lang.String salesman
persistent field

requestor
java.lang.String requestor
shipped
java.util.Date shipped
nullable persistent field

shippedBy
java.lang.String shippedBy
persistent field

invoicedDate
java.util.Date invoicedDate
nullable persistent field

invoicedBy
java.lang.String invoicedBy
persistent field

shipTo
java.lang.String shipTo
persistent field

remitId
java.lang.String remitId
persistent field

fob
java.lang.String fob
shipVia
java.lang.String shipVia
persistent field

carrier
java.lang.String carrier
persistent field

carrierAcct
java.lang.String carrierAcct
persistent field

tracking
java.lang.String tracking
persistent field

incoterm
java.lang.String incoterm
persistent field

incotermPlacePort
java.lang.String incotermPlacePort
persistent field

freightWho
java.lang.String freightWho
dateShipped
java.util.Date dateShipped
persistent field

dateInvoiced
java.util.Date dateInvoiced
persistent field

freightBill
java.lang.String freightBill
persistent field

currency
java.lang.String currency
persistent field

exchange
java.math.BigDecimal exchange
language
java.lang.String language
persistent field

terms
java.lang.String terms
persistent field

reldoc
java.lang.String reldoc
persistent field

creditAccount
java.lang.String creditAccount
persistent field

bp
java.lang.String bp
persistent field

invoiceBoilerplate
java.lang.String invoiceBoilerplate
invoiceComments
java.lang.String invoiceComments
nullable persistent field

invoiceNotes
java.lang.String invoiceNotes
nullable persistent field

amountDue
java.math.BigDecimal amountDue
persistent field

paydate
java.util.Date paydate
persistent field

datePaid
java.util.Date datePaid
persistent field

checkNo
java.lang.String checkNo
persistent field

paid
java.math.BigDecimal paid
persistent field

otran
java.lang.String otran
persistent field

rtran
java.lang.String rtran
persistent field

salesCodeId
java.lang.String salesCodeId
persistent field

companyUnitId
java.lang.String companyUnitId
persistent field

version
java.lang.Integer version
nullable persistent field

customerAddressInfo
CustomerVendorAddressInfoVO customerAddressInfo
nullable persistent field

Class bb.common.AccountsReceivableItemManufacturerPK extends java.lang.Object implements Serializable

Serialized Fields

invoiceNumber
java.lang.String invoiceNumber
identifier field

salesOrderItemNumber
java.lang.String salesOrderItemNumber
identifier field

ii
java.lang.Short ii
identifier field

Class bb.common.AccountsReceivableItemManufacturerVO extends VO implements Serializable

Serialized Fields

pk
AccountsReceivableItemManufacturerPK pk
manufacturerName
java.lang.String manufacturerName
manufacturerPartNumber
java.lang.String manufacturerPartNumber
Class bb.common.AccountsReceivableItemPK extends java.lang.Object implements Serializable

Serialized Fields

invoiceNumber
java.lang.String invoiceNumber
identifier field

invoiceItemNumber
java.lang.String invoiceItemNumber
identifier field

Class bb.common.AccountsReceivableItemResult extends AccountsReceivableItemVO implements Serializable

Serialized Fields

grandTotal
java.math.BigDecimal grandTotal
subTotal
java.math.BigDecimal subTotal
Class bb.common.AccountsReceivableItemVO extends VO implements Serializable

Serialized Fields

pk
AccountsReceivableItemPK pk
identifier field

salesOrderNumber
java.lang.String salesOrderNumber
persistent field

salesOrderItemNumber
java.lang.String salesOrderItemNumber
persistent field

shipperNumber
java.lang.String shipperNumber
persistent field

shipperItemNumber
java.lang.String shipperItemNumber
persistent field

accountNumber
java.lang.String accountNumber
persistent field

arSub
java.math.BigDecimal arSub
persistent field

arShip
java.math.BigDecimal arShip
persistent field

arOpen
java.math.BigDecimal arOpen
persistent field

arDisc
java.math.BigDecimal arDisc
persistent field

arNet
java.math.BigDecimal arNet
persistent field

arTax
java.math.BigDecimal arTax
persistent field

arTotal
java.math.BigDecimal arTotal
persistent field

margin
java.math.BigDecimal margin
marginPercent
java.math.BigDecimal marginPercent
marginByStdCost
java.math.BigDecimal marginByStdCost
marginPercentByStdCost
java.math.BigDecimal marginPercentByStdCost
due
java.math.BigDecimal due
paid
java.math.BigDecimal paid
datePaid
java.util.Date datePaid
checkNumber
java.lang.String checkNumber
refDoc1
java.lang.String refDoc1
persistent field

refDoc2
java.lang.String refDoc2
persistent field

dateShipped
java.util.Date dateShipped
persistent field

dateInvoiced
java.util.Date dateInvoiced
persistent field

shipVia
java.lang.String shipVia
persistent field

shipTo
java.lang.String shipTo
persistent field

status
java.lang.String status
persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
persistent field

modelNumber
java.lang.String modelNumber
persistent field

revision
java.lang.String revision
persistent field

locate
java.lang.String locate
persistent field

qtyOrdered
java.math.BigDecimal qtyOrdered
persistent field

qtyShipped
java.math.BigDecimal qtyShipped
persistent field

listPrice
java.math.BigDecimal listPrice
persistent field

avgCost
java.math.BigDecimal avgCost
persistent field

stdCost
java.math.BigDecimal stdCost
unit
java.lang.String unit
persistent field

discount
java.math.BigDecimal discount
persistent field

taxRate
java.math.BigDecimal taxRate
persistent field

description
java.lang.String description
persistent field

mfg
java.lang.String mfg
persistent field

mpn
java.lang.String mpn
persistent field

serial
java.lang.String serial
persistent field

invoiceComments
java.lang.String invoiceComments
nullable persistent field

invoicePrivateNotes
java.lang.String invoicePrivateNotes
nullable persistent field

refDocTwoes
java.util.Set<E> refDocTwoes
refDocOnes
java.util.Set<E> refDocOnes
accountsReceivableItemManufacturer
java.util.Set<E> accountsReceivableItemManufacturer
productCode
java.lang.String productCode
countryOrigin
java.lang.String countryOrigin
Class bb.common.AccountsReceivableVO extends VO implements Serializable

Serialized Fields

invoiceNumber
java.lang.String invoiceNumber
identifier field

salesOrderNumber
java.lang.String salesOrderNumber
persistent field

shipperNumber
java.lang.String shipperNumber
persistent field

pfInvoiceNumber
java.lang.String pfInvoiceNumber
customerId
java.lang.String customerId
persistent field

batchNumber
java.lang.String batchNumber
billTo
java.lang.String billTo
persistent field

customerPoNumber
java.lang.String customerPoNumber
persistent field

customerEmail
java.lang.String customerEmail
persistent field

contact
java.lang.String contact
persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

adate
java.util.Date adate
nullable persistent field

origin
java.lang.String origin
persistent field

arNetSet
java.lang.String arNetSet
persistent field

arTaxSet
java.lang.String arTaxSet
persistent field

subUnitTotal
java.math.BigDecimal subUnitTotal
persistent field

arShip
java.math.BigDecimal arShip
persistent field

arOpen
java.math.BigDecimal arOpen
persistent field

subDiscountTotal
java.math.BigDecimal subDiscountTotal
persistent field

subNetTotal
java.math.BigDecimal subNetTotal
persistent field

taxTotal
java.math.BigDecimal taxTotal
persistent field

freightTotal
java.math.BigDecimal freightTotal
persistent field

grandTotal
java.math.BigDecimal grandTotal
persistent field

margin
java.math.BigDecimal margin
marginPercent
java.math.BigDecimal marginPercent
totalCost
java.math.BigDecimal totalCost
marginByStdCost
java.math.BigDecimal marginByStdCost
marginPercentByStdCost
java.math.BigDecimal marginPercentByStdCost
totalStdCost
java.math.BigDecimal totalStdCost
arPaidInvoice
java.math.BigDecimal arPaidInvoice
persistent field

arPaidGl
java.math.BigDecimal arPaidGl
persistent field

arGl1Recorded
java.math.BigDecimal arGl1Recorded
persistent field

arGl2Paid
java.math.BigDecimal arGl2Paid
persistent field

changeOrder
java.lang.String changeOrder
persistent field

status
java.lang.String status
persistent field

salesman
java.lang.String salesman
persistent field

requestor
java.lang.String requestor
shipped
java.util.Date shipped
nullable persistent field

shippedBy
java.lang.String shippedBy
persistent field

invoicedDate
java.util.Date invoicedDate
nullable persistent field

invoicedBy
java.lang.String invoicedBy
persistent field

shipTo
java.lang.String shipTo
persistent field

remitId
java.lang.String remitId
persistent field

fob
java.lang.String fob
shipVia
java.lang.String shipVia
persistent field

carrier
java.lang.String carrier
persistent field

carrierAcct
java.lang.String carrierAcct
persistent field

tracking
java.lang.String tracking
persistent field

incoterm
java.lang.String incoterm
persistent field

incotermPlacePort
java.lang.String incotermPlacePort
persistent field

freightWho
java.lang.String freightWho
dateShipped
java.util.Date dateShipped
persistent field

dateInvoiced
java.util.Date dateInvoiced
persistent field

freightBill
java.lang.String freightBill
persistent field

currency
java.lang.String currency
persistent field

exchange
java.math.BigDecimal exchange
language
java.lang.String language
persistent field

terms
java.lang.String terms
persistent field

reldoc
java.lang.String reldoc
persistent field

creditAccount
java.lang.String creditAccount
persistent field

bp
java.lang.String bp
persistent field

invoiceBoilerplate
java.lang.String invoiceBoilerplate
invoiceComments
java.lang.String invoiceComments
nullable persistent field

invoiceNotes
java.lang.String invoiceNotes
nullable persistent field

amountDue
java.math.BigDecimal amountDue
persistent field

paydate
java.util.Date paydate
persistent field

datePaid
java.util.Date datePaid
persistent field

checkNo
java.lang.String checkNo
persistent field

paid
java.math.BigDecimal paid
persistent field

otran
java.lang.String otran
persistent field

rtran
java.lang.String rtran
persistent field

salesCodeId
java.lang.String salesCodeId
companyUnitId
java.lang.String companyUnitId
persistent field

version
java.lang.Integer version
nullable persistent field

customerAddressInfo
CustomerVendorAddressInfoVO customerAddressInfo
nullable persistent field

shipToAddressInfo
CustomerVendorAddressInfoVO shipToAddressInfo
nullable persistent field

billToAddressInfo
CustomerVendorAddressInfoVO billToAddressInfo
nullable persistent field

accountsReceivableItems
java.util.Set<E> accountsReceivableItems
persistent field

coComments
java.lang.String coComments
bb2FeedBackNumber
java.lang.String bb2FeedBackNumber
boilerplates
java.util.Set<E> boilerplates
billAndHold
java.lang.String billAndHold
signature
byte[] signature
paymentVariance
java.math.BigDecimal paymentVariance
paymentVarianceGL
java.lang.String paymentVarianceGL
Class bb.common.AddPayableWithoutReceiverAgent extends java.lang.Object implements Serializable

Serialized Fields

batchNumber
java.lang.String batchNumber
vendorId
java.lang.String vendorId
vendorInvoice
java.lang.String vendorInvoice
invoiceDate
java.util.Date invoiceDate
transactionDate
java.util.Date transactionDate
vendorAmount
java.math.BigDecimal vendorAmount
description
java.lang.String description
companyUnitId
java.lang.String companyUnitId
debitAccount
java.lang.String debitAccount
taxRate
java.math.BigDecimal taxRate
glSummary
java.lang.String glSummary
APGLDate
java.util.Date APGLDate
Class bb.common.AddPhysicalInventoryAgent extends java.lang.Object implements Serializable

Serialized Fields

workSheetNumber
java.lang.Integer workSheetNumber
pageNumber
java.lang.Integer pageNumber
partPk
PartPK partPk
location
java.lang.String location
newOnhand
java.math.BigDecimal newOnhand
tagNumber
java.lang.String tagNumber
Class bb.common.AddProformaReceiverAgent extends java.lang.Object implements Serializable

Serialized Fields

vendorId
java.lang.String vendorId
prDate
java.util.Date prDate
items
java.util.LinkedHashSet<E> items
Class bb.common.AddProformaReceiverItemAgent extends java.lang.Object implements Serializable

Serialized Fields

pk
PurchaseOrderItemPK pk
qty
java.math.BigDecimal qty
shipDate
java.util.Date shipDate
packingBoxNumber
java.lang.Integer packingBoxNumber
invoiceNumber
java.lang.String invoiceNumber
Class bb.common.AddressAccountInfo extends java.lang.Object implements Serializable

Serialized Fields

id
java.lang.String id
name
java.lang.String name
currency
java.lang.String currency
accountNumber
java.lang.String accountNumber
description
java.lang.String description
debitOrCredit
java.lang.String debitOrCredit
exchange
java.math.BigDecimal exchange
apStartBalance
java.math.BigDecimal apStartBalance
appStartBalance
java.math.BigDecimal appStartBalance
arStartBalance
java.math.BigDecimal arStartBalance
arpStartBalance
java.math.BigDecimal arpStartBalance
apEndBalance
java.math.BigDecimal apEndBalance
appEndBalance
java.math.BigDecimal appEndBalance
arEndBalance
java.math.BigDecimal arEndBalance
arpEndBalance
java.math.BigDecimal arpEndBalance
apAmount
java.math.BigDecimal apAmount
appAmount
java.math.BigDecimal appAmount
arAmount
java.math.BigDecimal arAmount
arpAmount
java.math.BigDecimal arpAmount
apOriginalAmount
java.math.BigDecimal apOriginalAmount
appOriginalAmount
java.math.BigDecimal appOriginalAmount
arOriginalAmount
java.math.BigDecimal arOriginalAmount
arpOriginalAmount
java.math.BigDecimal arpOriginalAmount
Class bb.common.AddressQualityDocumentsVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
identifier field

addressId
java.lang.String addressId
persistent field

docType
java.lang.String docType
persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

uploadDate
java.util.Date uploadDate
nullable persistent field

documentDescription
java.lang.String documentDescription
nullable persistent field

documentLength
java.lang.Long documentLength
nullable persistent field

documentExtension
java.lang.String documentExtension
persistent field

docName
java.lang.String docName
expireDate
java.util.Date expireDate
category
java.lang.String category
Class bb.common.AddRTVAgent extends java.lang.Object implements Serializable

Serialized Fields

value
java.lang.String value
byVendor
boolean byVendor
poItemPk
java.util.List<E> poItemPk
Class bb.common.AllBudgetResult extends java.lang.Object implements Serializable

Serialized Fields

budgetForRevenueListResult
java.util.List<E> budgetForRevenueListResult
budgetForExpenseListResult
java.util.List<E> budgetForExpenseListResult
Class bb.common.AllPartDocumentsPK extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
identifier field

documentType
java.lang.String documentType
identifier field

language
java.lang.String language
identifier field

docVersion
java.lang.String docVersion
identifier field

Class bb.common.AllPartDocumentsVO extends VO implements Serializable

Serialized Fields

pk
AllPartDocumentsPK pk
identifier field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

publicDoc
boolean publicDoc
persistent field

description
java.lang.String description
persistent field

comments
java.lang.String comments
nullable persistent field

documentLengthByte
java.lang.Long documentLengthByte
extension
java.lang.String extension
Class bb.common.AllStatementsListResult extends java.lang.Object implements Serializable

Serialized Fields

customerId
java.lang.String customerId
customerName
java.lang.String customerName
email
java.lang.String email
arTotalDue
java.math.BigDecimal arTotalDue
arAmountPaid
java.math.BigDecimal arAmountPaid
arBalenceDue
java.math.BigDecimal arBalenceDue
arCurrency
java.lang.String arCurrency
prepayTotalDue
java.math.BigDecimal prepayTotalDue
prepayAmountPaid
java.math.BigDecimal prepayAmountPaid
prepayBalenceDue
java.math.BigDecimal prepayBalenceDue
prepayApply
java.math.BigDecimal prepayApply
prepayCurrency
java.lang.String prepayCurrency
customerParentId
java.lang.String customerParentId
contacts
java.util.Set<E> contacts
emails
java.util.Set<E> emails
billTo
java.lang.String billTo
Class bb.common.AmountsStatementResult extends java.lang.Object implements Serializable

Serialized Fields

accountNumber
java.lang.String accountNumber
accountType
java.lang.String accountType
debitOrCredit
java.lang.String debitOrCredit
description
java.lang.String description
totalAmount
java.math.BigDecimal totalAmount
Class bb.common.APAgingItemListResult extends APItemListResult implements Serializable

Serialized Fields

vendorInvoiceDate
java.util.Date vendorInvoiceDate
Class bb.common.APAuditListResult extends java.lang.Object implements Serializable

Serialized Fields

apNumber
java.lang.String apNumber
vendorID
java.lang.String vendorID
status
java.lang.String status
currency
java.lang.String currency
apNet
java.math.BigDecimal apNet
calcNet
java.math.BigDecimal calcNet
apTotal
java.math.BigDecimal apTotal
apFreight
java.math.BigDecimal apFreight
apTax
java.math.BigDecimal apTax
apPaid
java.math.BigDecimal apPaid
apDue
java.math.BigDecimal apDue
totalI
java.math.BigDecimal totalI
totalE
java.math.BigDecimal totalE
vendorTotal
java.math.BigDecimal vendorTotal
exchange
java.math.BigDecimal exchange
transactionIDate
java.util.Date transactionIDate
transactionEDate
java.util.Date transactionEDate
paybyVendorInvoiceTotal
boolean paybyVendorInvoiceTotal
alarm
boolean alarm
cause
java.lang.String cause
Class bb.common.ApCheckRunItemAgent extends java.lang.Object implements Serializable

Serialized Fields

includeVendorId
java.lang.String[] includeVendorId
excludeVendorId
java.lang.String[] excludeVendorId
fromDate
java.util.Date fromDate
toDate
java.util.Date toDate
apNumber
java.lang.String[] apNumber
currency
java.lang.String currency
Class bb.common.ApCheckRunListResult extends java.lang.Object implements Serializable

Serialized Fields

checkRunNumber
java.lang.String checkRunNumber
checkNumber
java.lang.String checkNumber
amount
java.math.BigDecimal amount
currency
java.lang.String currency
transactionNumber
java.lang.String transactionNumber
payDate
java.util.Date payDate
vendorId
java.lang.String vendorId
vendorName
java.lang.String vendorName
apNumber
java.lang.String apNumber
poNumber
java.lang.String poNumber
dateCheckPaid
java.util.Date dateCheckPaid
dateCheckRunPaid
java.util.Date dateCheckRunPaid
Class bb.common.APItemListResult extends java.lang.Object implements Serializable

Serialized Fields

dateReceived
java.util.Date dateReceived
vendorInvoiceDate
java.util.Date vendorInvoiceDate
payDate
java.util.Date payDate
apNumber
java.lang.String apNumber
apItemNumber
java.lang.String apItemNumber
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
description
java.lang.String description
qtyOrdered
java.math.BigDecimal qtyOrdered
qtyReceived
java.math.BigDecimal qtyReceived
cost
java.math.BigDecimal cost
taxRate
java.math.BigDecimal taxRate
discount
java.math.BigDecimal discount
extPrice
java.math.BigDecimal extPrice
vendorId
java.lang.String vendorId
ourPoNumber
java.lang.String ourPoNumber
debitAccount
java.lang.String debitAccount
status
java.lang.String status
due
java.math.BigDecimal due
vendorInvoice
java.lang.String vendorInvoice
terms
java.lang.String terms
companyUnitId
java.lang.String companyUnitId
datePaid
java.util.Date datePaid
productCode
java.lang.String productCode
receiverNumber
java.lang.String receiverNumber
Class bb.common.AppColumnVO extends VO implements Serializable

Serialized Fields

name
java.lang.String name
type
java.lang.String type
displayName
java.lang.String displayName
poClass
java.lang.String poClass
tableName
java.lang.String tableName
editable
boolean editable
formula
java.lang.String formula
Class bb.common.AppException extends BB2ServerException implements Serializable

Class bb.common.APPrepayInfoResult extends java.lang.Object implements Serializable

Serialized Fields

vendorId
java.lang.String vendorId
vendorName
java.lang.String vendorName
pk
ApPrepayItemPK pk
poNumber
java.lang.String poNumber
appiPrepay
java.math.BigDecimal appiPrepay
appiPrepayDue
java.math.BigDecimal appiPrepayDue
appiPrepayGl
java.math.BigDecimal appiPrepayGl
companyUnitId
java.lang.String companyUnitId
payDate
java.util.Date payDate
Class bb.common.ApPrepayItemPK extends java.lang.Object implements Serializable

Serialized Fields

apPrepayNumber
java.lang.String apPrepayNumber
apPrepayItemNumber
java.lang.String apPrepayItemNumber
Class bb.common.ApPrepayItemVO extends VO implements Serializable

Serialized Fields

pk
ApPrepayItemPK pk
poNumber
java.lang.String poNumber
appiPrepay
java.math.BigDecimal appiPrepay
appiPrepayDue
java.math.BigDecimal appiPrepayDue
appiPrepayGl
java.math.BigDecimal appiPrepayGl
dateRequired
java.util.Date dateRequired
status
java.lang.String status
comments
java.lang.String comments
Class bb.common.ApPrepaymentCheckRunItemAgent extends java.lang.Object implements Serializable

Serialized Fields

includeVendorId
java.lang.String[] includeVendorId
excludeVendorId
java.lang.String[] excludeVendorId
fromDate
java.util.Date fromDate
toDate
java.util.Date toDate
appiPk
ApPrepayItemPK[] appiPk
Class bb.common.ApPrepayVO extends VO implements Serializable

Serialized Fields

apPrepayNumber
java.lang.String apPrepayNumber
purchaseOrderNumber
java.lang.String purchaseOrderNumber
vendorSO
java.lang.String vendorSO
poTotal
java.math.BigDecimal poTotal
vendorId
java.lang.String vendorId
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
apPrepay
java.math.BigDecimal apPrepay
apPrepayDue
java.math.BigDecimal apPrepayDue
apPrepayGl
java.math.BigDecimal apPrepayGl
apPrepayApply
java.math.BigDecimal apPrepayApply
status
java.lang.String status
appDate
java.util.Date appDate
currency
java.lang.String currency
exchange
java.math.BigDecimal exchange
requester
java.lang.String requester
vendorInvoice
java.lang.String vendorInvoice
check
java.lang.String check
vendorInvoiceTotal
java.math.BigDecimal vendorInvoiceTotal
companyUnitId
java.lang.String companyUnitId
vendorAddressInfo
CustomerVendorAddressInfoVO vendorAddressInfo
apPrepayItem
java.util.Set<E> apPrepayItem
Class bb.common.ApprovedGLResult extends java.lang.Object implements Serializable

Serialized Fields

totalGL
int totalGL
approveSuccessGL
int approveSuccessGL
errorGL
int errorGL
approveSuccessGLList
java.util.List<E> approveSuccessGLList
approvedGLList
java.util.List<E> approvedGLList
errorGLList
java.util.List<E> errorGLList
approvedErrorList
java.util.List<E> approvedErrorList
overdueList
java.util.List<E> overdueList
Class bb.common.APTaxForZipcodeListResult extends java.lang.Object implements Serializable

Serialized Fields

vendorId
java.lang.String vendorId
vendorName
java.lang.String vendorName
zipcode
java.lang.String zipcode
currency
java.lang.String currency
acount
int acount
totaltax
java.math.BigDecimal totaltax
Class bb.common.ARAllStatementsListResult extends java.lang.Object implements Serializable

Serialized Fields

customerId
java.lang.String customerId
customerName
java.lang.String customerName
email
java.lang.String email
totalDue
java.math.BigDecimal totalDue
amountPaid
java.math.BigDecimal amountPaid
balenceDue
java.math.BigDecimal balenceDue
currency
java.lang.String currency
Class bb.common.ARAuditListResult extends java.lang.Object implements Serializable

Serialized Fields

arNumber
java.lang.String arNumber
custID
java.lang.String custID
status
java.lang.String status
currency
java.lang.String currency
arNet
java.math.BigDecimal arNet
calcNet
java.math.BigDecimal calcNet
arTotal
java.math.BigDecimal arTotal
arFreight
java.math.BigDecimal arFreight
arTax
java.math.BigDecimal arTax
arPaid
java.math.BigDecimal arPaid
arDue
java.math.BigDecimal arDue
totalO
java.math.BigDecimal totalO
totalR
java.math.BigDecimal totalR
exchange
java.math.BigDecimal exchange
transactionODate
java.util.Date transactionODate
transactionRDate
java.util.Date transactionRDate
alarm
boolean alarm
cause
java.lang.String cause
Class bb.common.ARBoilerplateVO extends VO implements Serializable

Serialized Fields

boilerplateId
java.lang.String boilerplateId
identifier field

description
java.lang.String description
persistent field

arBoilerplate
java.lang.String arBoilerplate
nullable persistent field

Class bb.common.ArCommissionListResult extends java.lang.Object implements Serializable

Serialized Fields

invoiceNumber
java.lang.String invoiceNumber
status
java.lang.String status
salesOrderNumber
java.lang.String salesOrderNumber
paidDate
java.util.Date paidDate
dateInvoiced
java.util.Date dateInvoiced
payDate
java.util.Date payDate
salesCodeId
java.lang.String salesCodeId
salesCodeName
java.lang.String salesCodeName
addressId
java.lang.String addressId
addressName
java.lang.String addressName
employeeId
java.lang.String employeeId
currency
java.lang.String currency
subUnitTotal
java.math.BigDecimal subUnitTotal
subDiscountTotal
java.math.BigDecimal subDiscountTotal
subNetTotal
java.math.BigDecimal subNetTotal
taxTotal
java.math.BigDecimal taxTotal
freightTotal
java.math.BigDecimal freightTotal
grandTotal
java.math.BigDecimal grandTotal
commissionRate
java.math.BigDecimal commissionRate
totalCommission
java.math.BigDecimal totalCommission
customerId
java.lang.String customerId
customerPO
java.lang.String customerPO
Class bb.common.ArCommissionTotalResult extends java.lang.Object implements Serializable

Serialized Fields

subTotal
java.math.BigDecimal subTotal
discountTotal
java.math.BigDecimal discountTotal
netTotal
java.math.BigDecimal netTotal
taxTotal
java.math.BigDecimal taxTotal
freightTotal
java.math.BigDecimal freightTotal
grandTotal
java.math.BigDecimal grandTotal
currency
java.lang.String currency
commissionTotal
java.math.BigDecimal commissionTotal
Class bb.common.ArPaymentRunItemAgent extends java.lang.Object implements Serializable

Serialized Fields

includeVendorId
java.lang.String[] includeVendorId
excludeVendorId
java.lang.String[] excludeVendorId
fromDate
java.util.Date fromDate
toDate
java.util.Date toDate
arNumber
java.lang.String[] arNumber
Class bb.common.ARPaymentRunItemPK extends java.lang.Object implements Serializable

Serialized Fields

paymentRunNumber
java.lang.String paymentRunNumber
identifier field

arNumber
java.lang.String arNumber
identifier field

Class bb.common.ARPaymentRunItemVO extends VO implements Serializable

Serialized Fields

pk
ARPaymentRunItemPK pk
identifier field

status
java.lang.String status
persistent field

arStatus
java.lang.String arStatus
lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

paymentNumber
java.lang.String paymentNumber
persistent field

memo
java.lang.String memo
persistent field

soNumber
java.lang.String soNumber
persistent field

sn
java.lang.String sn
persistent field

customerId
java.lang.String customerId
persistent field

paid
java.math.BigDecimal paid
persistent field

currency
java.lang.String currency
persistent field

exchange
java.math.BigDecimal exchange
persistent field

language
java.lang.String language
persistent field

poNumber
java.lang.String poNumber
persistent field

arTotal
java.math.BigDecimal arTotal
persistent field

paidToDate
java.math.BigDecimal paidToDate
dateInvoiced
java.util.Date dateInvoiced
persistent field

payDate
java.util.Date payDate
persistent field

due
java.math.BigDecimal due
persistent field

transactionNo
java.lang.String transactionNo
customerAddressInfo
CustomerVendorAddressInfoVO customerAddressInfo
version
int version
nullable persistent field

Class bb.common.ARPaymentRunListResult extends java.lang.Object implements Serializable

Serialized Fields

paymentRunNumber
java.lang.String paymentRunNumber
paymentNumber
java.lang.String paymentNumber
amount
java.math.BigDecimal amount
currency
java.lang.String currency
transactionNumber
java.lang.String transactionNumber
payDate
java.util.Date payDate
customerId
java.lang.String customerId
customerName
java.lang.String customerName
arNumber
java.lang.String arNumber
soNumber
java.lang.String soNumber
Class bb.common.ARPaymentRunVO extends VO implements Serializable

Serialized Fields

paymentRunNumber
java.lang.String paymentRunNumber
identifier field

status
java.lang.String status
persistent field

paymentNumber
java.lang.String paymentNumber
persistent field

datePaid
java.util.Date datePaid
transactionDate
java.util.Date transactionDate
persistent field

gaAr
java.lang.String gaAr
persistent field

gaChecking
java.lang.String gaChecking
persistent field

wireFeeAccount
java.lang.String wireFeeAccount
totalWireFee
java.math.BigDecimal totalWireFee
wireFeeApNumber
java.lang.String wireFeeApNumber
include
java.lang.String include
persistent field

exclude
java.lang.String exclude
persistent field

date1
java.util.Date date1
persistent field

date2
java.util.Date date2
persistent field

checked
java.lang.String checked
persistent field

madeBy
java.lang.String madeBy
companyUnitOfGaAr
java.lang.String companyUnitOfGaAr
companyUnitOfGaChecking
java.lang.String companyUnitOfGaChecking
companyUnitOfWireFeeAcc
java.lang.String companyUnitOfWireFeeAcc
paymentRunItems
java.util.Set<E> paymentRunItems
Class bb.common.ARPrepayAllStatementsListResult extends java.lang.Object implements Serializable

Serialized Fields

customerId
java.lang.String customerId
customerName
java.lang.String customerName
email
java.lang.String email
totalDue
java.math.BigDecimal totalDue
amountPaid
java.math.BigDecimal amountPaid
balanceDue
java.math.BigDecimal balanceDue
currency
java.lang.String currency
totalApply
java.math.BigDecimal totalApply
Class bb.common.ARPrepayInfoResult extends java.lang.Object implements Serializable

Serialized Fields

customerId
java.lang.String customerId
customerName
java.lang.String customerName
pk
ArPrepayItemPK pk
salesOrderNumber
java.lang.String salesOrderNumber
arpiPrepay
java.math.BigDecimal arpiPrepay
arpiPrepayDue
java.math.BigDecimal arpiPrepayDue
arpiPrepayGl
java.math.BigDecimal arpiPrepayGl
companyUnitId
java.lang.String companyUnitId
payDate
java.util.Date payDate
Class bb.common.ArPrepayItemPK extends java.lang.Object implements Serializable

Serialized Fields

arPrepayNumber
java.lang.String arPrepayNumber
arPrepayItemNumber
java.lang.String arPrepayItemNumber
Class bb.common.ArPrepayItemVO extends VO implements Serializable

Serialized Fields

pk
ArPrepayItemPK pk
soNumber
java.lang.String soNumber
arpiPrepay
java.math.BigDecimal arpiPrepay
arpiPrepayDue
java.math.BigDecimal arpiPrepayDue
arpiPrepayGl
java.math.BigDecimal arpiPrepayGl
dateRequired
java.util.Date dateRequired
status
java.lang.String status
comments
java.lang.String comments
Class bb.common.ArPrepaymentRunItemAgent extends java.lang.Object implements Serializable

Serialized Fields

includeVendorId
java.lang.String[] includeVendorId
excludeVendorId
java.lang.String[] excludeVendorId
fromDate
java.util.Date fromDate
toDate
java.util.Date toDate
arpiNumber
ArPrepayItemPK[] arpiNumber
Class bb.common.ARPrepaymentWireTransferAgent extends java.lang.Object implements Serializable

Serialized Fields

includeVendorId
java.lang.String[] includeVendorId
excludeVendorId
java.lang.String[] excludeVendorId
fromDate
java.util.Date fromDate
toDate
java.util.Date toDate
arpiPk
ArPrepayItemPK[] arpiPk
wireTransferNo
java.lang.String wireTransferNo
transactionDate
java.util.Date transactionDate
debitAccount
java.lang.String debitAccount
creditAccount
java.lang.String creditAccount
bankTransferFeeAccount
java.lang.String bankTransferFeeAccount
companyUnitOfDebitAcc
java.lang.String companyUnitOfDebitAcc
companyUnitOfCreditAcc
java.lang.String companyUnitOfCreditAcc
companyUnitOfTransferFeeAcc
java.lang.String companyUnitOfTransferFeeAcc
Class bb.common.ArPrepayVO extends VO implements Serializable

Serialized Fields

arPrepayNumber
java.lang.String arPrepayNumber
salesOrderNumber
java.lang.String salesOrderNumber
customerPO
java.lang.String customerPO
soTotal
java.math.BigDecimal soTotal
customerId
java.lang.String customerId
billToId
java.lang.String billToId
shipToId
java.lang.String shipToId
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
arPrepay
java.math.BigDecimal arPrepay
arPrepayDue
java.math.BigDecimal arPrepayDue
arPrepayGl
java.math.BigDecimal arPrepayGl
arPrepayApply
java.math.BigDecimal arPrepayApply
status
java.lang.String status
arpDate
java.util.Date arpDate
currency
java.lang.String currency
exchange
java.math.BigDecimal exchange
requester
java.lang.String requester
check
java.lang.String check
companyUnitId
java.lang.String companyUnitId
customerAddressInfo
CustomerVendorAddressInfoVO customerAddressInfo
billToAddressInfo
CustomerVendorAddressInfoVO billToAddressInfo
shipToAddressInfo
CustomerVendorAddressInfoVO shipToAddressInfo
arPrepayItem
java.util.Set<E> arPrepayItem
Class bb.common.ArSalesCodeTotalListResult extends SalesCodeVO implements Serializable

Serialized Fields

subTotal
java.math.BigDecimal subTotal
discountTotal
java.math.BigDecimal discountTotal
netTotal
java.math.BigDecimal netTotal
taxTotal
java.math.BigDecimal taxTotal
freightTotal
java.math.BigDecimal freightTotal
grandTotal
java.math.BigDecimal grandTotal
commissionTotal
java.math.BigDecimal commissionTotal
Class bb.common.ARTaxForZipcodeListResult extends java.lang.Object implements Serializable

Serialized Fields

customerId
java.lang.String customerId
customerName
java.lang.String customerName
zipcode
java.lang.String zipcode
currency
java.lang.String currency
acount
int acount
totaltax
java.math.BigDecimal totaltax
Class bb.common.AssetAddOrDisposalsReport extends java.lang.Object implements Serializable

Serialized Fields

assetNumber
java.lang.String assetNumber
identifier field

assetType
java.lang.String assetType
persistent field

description
java.lang.String description
persistent field

departmentID
java.lang.String departmentID
persistent field

location
java.lang.String location
persistent field

depreciateStatus
java.lang.String depreciateStatus
persistent field

acquisitionDate
java.util.Date acquisitionDate
persistent field

acquisitionCost
java.math.BigDecimal acquisitionCost
persistent field

initialDepreciateCost
java.math.BigDecimal initialDepreciateCost
persistent field

accmDepreciateCost
java.math.BigDecimal accmDepreciateCost
persistent field

depreciateStartDate
java.util.Date depreciateStartDate
persistent field

depreciateEndDate
java.util.Date depreciateEndDate
persistent field

netSalvage
java.math.BigDecimal netSalvage
quantity
java.math.BigDecimal quantity
persistent field

netBookValue
java.math.BigDecimal netBookValue
Class bb.common.AssetAmortizationExpenseAccountPK extends java.lang.Object implements Serializable

Serialized Fields

assetNumber
java.lang.String assetNumber
item
java.lang.String item
Class bb.common.AssetAmortizationExpenseAccountVO extends VO implements Serializable

Serialized Fields

pk
AssetAmortizationExpenseAccountPK pk
account
java.lang.String account
companyUnit
java.lang.String companyUnit
percent
java.math.BigDecimal percent
Class bb.common.AssetDepreciateDetailReport extends VO implements Serializable

Serialized Fields

assetNumber
java.lang.String assetNumber
identifier field

assetType
java.lang.String assetType
persistent field

description
java.lang.String description
persistent field

departmentID
java.lang.String departmentID
persistent field

usingLife
int usingLife
persistent field

quantity
java.math.BigDecimal quantity
persistent field

acquisitionCost
java.math.BigDecimal acquisitionCost
persistent field

initialDepreciateCost
java.math.BigDecimal initialDepreciateCost
persistent field

netSalvage
java.math.BigDecimal netSalvage
monthDepreciationRate
java.math.BigDecimal monthDepreciationRate
persistent field

lastYearDepreciationAccm
java.math.BigDecimal lastYearDepreciationAccm
persistent field

currentYearDepreciationAccm
java.math.BigDecimal currentYearDepreciationAccm
persistent field

currentYearDepreciateTotal
java.math.BigDecimal currentYearDepreciateTotal
undepreciatedBalance
java.math.BigDecimal undepreciatedBalance
estimateDepreciate
java.math.BigDecimal estimateDepreciate
depreciatedAccm
java.math.BigDecimal depreciatedAccm
datePaid
java.util.Date datePaid
depreciateStartDate
java.util.Date depreciateStartDate
depreciateEndDate
java.util.Date depreciateEndDate
status
java.lang.String status
depreciate
java.util.Map<K,V> depreciate
persistent field

Class bb.common.AssetDepreciatePK extends java.lang.Object implements Serializable

Serialized Fields

assetNumber
java.lang.String assetNumber
identifier field

month
java.lang.String month
identifier field

Class bb.common.AssetDepreciateVO extends VO implements Serializable

Serialized Fields

pk
AssetDepreciatePK pk
identifier field

assetType
java.lang.String assetType
persistent field

description
java.lang.String description
persistent field

usingStatus
java.lang.String usingStatus
persistent field

depreciateStatus
java.lang.String depreciateStatus
persistent field

departmentID
java.lang.String departmentID
persistent field

location
java.lang.String location
persistent field

transactionNumber
java.lang.String transactionNumber
persistent field

glCategory
java.lang.String glCategory
persistent field

categorySequence
java.lang.Integer categorySequence
persistent field

amortizationExpenseAccount
java.lang.String amortizationExpenseAccount
persistent field

accumulatedDeprAccount
java.lang.String accumulatedDeprAccount
persistent field

companyUnitOfAmorExpenseAcc
java.lang.String companyUnitOfAmorExpenseAcc
persistent field

coUnitOfAccumulatedDeprAcc
java.lang.String coUnitOfAccumulatedDeprAcc
persistent field

acquisitionCost
java.math.BigDecimal acquisitionCost
persistent field

initialDepreciateCost
java.math.BigDecimal initialDepreciateCost
lastChangeTimes
int lastChangeTimes
nullable persistent field

monthDepreciationRate
java.math.BigDecimal monthDepreciationRate
currentMonthDepreciate
java.math.BigDecimal currentMonthDepreciate
undepreciatedBalance
java.math.BigDecimal undepreciatedBalance
netSalvage
java.math.BigDecimal netSalvage
depreciatedAccm
java.math.BigDecimal depreciatedAccm
lastYeardepreciatedAccm
java.math.BigDecimal lastYeardepreciatedAccm
depreciateDate
java.util.Date depreciateDate
usingLife
int usingLife
estimateNetSalRate
java.math.BigDecimal estimateNetSalRate
unDepreciatedAccm
java.math.BigDecimal unDepreciatedAccm
amortizationExpenseAccounts
java.util.Set<E> amortizationExpenseAccounts
Class bb.common.AssetReportSumResult extends VO implements Serializable

Serialized Fields

acquisitionCost
java.math.BigDecimal acquisitionCost
initialDepreciateCost
java.math.BigDecimal initialDepreciateCost
currentMonthDepreciate
java.math.BigDecimal currentMonthDepreciate
netSalvage
java.math.BigDecimal netSalvage
depreciatedAccm
java.math.BigDecimal depreciatedAccm
qty
java.math.BigDecimal qty
Class bb.common.AssetTypeVO extends VO implements Serializable

Serialized Fields

id
java.lang.String id
name
java.lang.String name
persistent field

lastChangeTimes
java.lang.Integer lastChangeTimes
nullable persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

Class bb.common.AssetUsagePK extends java.lang.Object implements Serializable

Serialized Fields

ii
java.lang.Short ii
assetNumber
java.lang.String assetNumber
Class bb.common.AssetUsageVO extends VO implements Serializable

Serialized Fields

pk
AssetUsagePK pk
user
java.lang.String user
receiveDate
java.util.Date receiveDate
returnDate
java.util.Date returnDate
receiveSign
java.lang.String receiveSign
returnSign
java.lang.String returnSign
receiveDepartment
java.lang.String receiveDepartment
returnDepartment
java.lang.String returnDepartment
receiveComment
java.lang.String receiveComment
returnComment
java.lang.String returnComment
Class bb.common.AssetVO extends VO implements Serializable

Serialized Fields

assetNumber
java.lang.String assetNumber
identifier field

glAccountNumber
java.lang.String glAccountNumber
persistent field

assetType
java.lang.String assetType
persistent field

assetType2
java.lang.String assetType2
persistent field

description
java.lang.String description
persistent field

depreciationType
java.lang.String depreciationType
persistent field

serialNumber
java.lang.String serialNumber
persistent field

location
java.lang.String location
persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

adate
java.util.Date adate
nullable persistent field

origin
java.lang.String origin
persistent field

acquisitionDate
java.util.Date acquisitionDate
persistent field

acquisitionCost
java.math.BigDecimal acquisitionCost
persistent field

foreignCurrency
java.lang.String foreignCurrency
persistent field

foreignCurrencyCost
java.math.BigDecimal foreignCurrencyCost
persistent field

depreciatedCost
java.math.BigDecimal depreciatedCost
persistent field

depreciateStartDate
java.util.Date depreciateStartDate
persistent field

depreciateEndDate
java.util.Date depreciateEndDate
persistent field

refDoc1
java.lang.String refDoc1
persistent field

refDoc2
java.lang.String refDoc2
persistent field

lastChangeTimes
int lastChangeTimes
nullable persistent field

usingStatus
java.lang.String usingStatus
nullable persistent field

depreciateStatus
java.lang.String depreciateStatus
nullable persistent field

departmentID
java.lang.String departmentID
nullable persistent field

purchaseOrderNumber
java.lang.String purchaseOrderNumber
nullable persistent field

amortizationExpenseAccount
java.lang.String amortizationExpenseAccount
nullable persistent field

accumulatedDeprAccount
java.lang.String accumulatedDeprAccount
persistent field

coUnitOfAccumulatedDeprAcc
java.lang.String coUnitOfAccumulatedDeprAcc
persistent field

companyUnitOfAmorExpenseAcc
java.lang.String companyUnitOfAmorExpenseAcc
persistent field

companyUnitOfGlAcc
java.lang.String companyUnitOfGlAcc
persistent field

estimateNetSalRate
java.math.BigDecimal estimateNetSalRate
nullable persistent field

netSalvage
java.math.BigDecimal netSalvage
nullable persistent field

usingLife
int usingLife
nullable persistent field

monthDepreciationRate
java.math.BigDecimal monthDepreciationRate
nullable persistent field

annualDepreciationRate
java.math.BigDecimal annualDepreciationRate
nullable persistent field

quantity
java.math.BigDecimal quantity
nullable persistent field

initialDepreciateCost
java.math.BigDecimal initialDepreciateCost
nullable persistent field

receiveDate
java.util.Date receiveDate
persistent field

datePaid
java.util.Date datePaid
persistent field

mfgID
java.lang.String mfgID
persistent field

modelNO
java.lang.String modelNO
persistent field

project
java.lang.String project
nullable persistent field

assetStatus
java.lang.String assetStatus
persistent field

mfgCode
java.lang.String mfgCode
persistent field

assignTo
java.lang.String assignTo
nullable persistent field

comments
java.lang.String comments
persistent field

depreciatedAccm
java.math.BigDecimal depreciatedAccm
nullable persistent field

amortizationExpenseAccounts
java.util.Set<E> amortizationExpenseAccounts
monthDepreciation
java.math.BigDecimal monthDepreciation
status
java.lang.String status
depreciations
java.util.Set<E> depreciations
default constructor

depreciatedAccmMonths
int depreciatedAccmMonths
Class bb.common.AuditLogVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
auditBy
java.lang.String auditBy
auditTime
java.util.Date auditTime
Class bb.common.AuditOnDemandResult extends java.lang.Object implements Serializable

Serialized Fields

partPk
PartPK partPk
description
java.lang.String description
systemWip
java.math.BigDecimal systemWip
auditWip
java.math.BigDecimal auditWip
systemOndemand
java.math.BigDecimal systemOndemand
auditOndemand
java.math.BigDecimal auditOndemand
systemOnorder
java.math.BigDecimal systemOnorder
auditOnorder
java.math.BigDecimal auditOnorder
systemYrUsage
java.math.BigDecimal systemYrUsage
auditYrUsage
java.math.BigDecimal auditYrUsage
systemQtrUsage
java.math.BigDecimal systemQtrUsage
auditQtrUsage
java.math.BigDecimal auditQtrUsage
onhandQty
java.math.BigDecimal onhandQty
auditOnhandQty
java.math.BigDecimal auditOnhandQty
Class bb.common.AuditPartInQAResult extends VO implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
persistent field

quantity
java.math.BigDecimal quantity
persistent field

totalQty
java.math.BigDecimal totalQty
persistent field

inQAQty
java.math.BigDecimal inQAQty
persistent field

ncrNumber
java.lang.String ncrNumber
ncrStatus
java.lang.String ncrStatus
Class bb.common.BalanceSheetSideBySideItemResult extends java.lang.Object implements Serializable

Serialized Fields

accountNumber
java.lang.String accountNumber
accountType
java.lang.String accountType
level
java.lang.String level
items
byte items
upLevelAccountNumber
java.lang.String upLevelAccountNumber
creditOrDebit
java.lang.String creditOrDebit
accountDescription
java.lang.String accountDescription
balance
java.math.BigDecimal balance
percentage
java.lang.Double percentage
Class bb.common.BalanceSheetSideBySideResult extends java.lang.Object implements Serializable

Serialized Fields

monthYear
java.lang.String monthYear
currentAssets
java.util.List<E> currentAssets
totalCurrentAssets
BalanceSheetSideBySideItemResult totalCurrentAssets
fixedAssets
java.util.List<E> fixedAssets
totalFixedAssets
BalanceSheetSideBySideItemResult totalFixedAssets
otherAssets
java.util.List<E> otherAssets
totalOtherAssets
BalanceSheetSideBySideItemResult totalOtherAssets
totalAssets
BalanceSheetSideBySideItemResult totalAssets
currentLiability
java.util.List<E> currentLiability
totalCurrentLiability
BalanceSheetSideBySideItemResult totalCurrentLiability
otherLiability
java.util.List<E> otherLiability
totalOtherLiability
BalanceSheetSideBySideItemResult totalOtherLiability
totalLiability
BalanceSheetSideBySideItemResult totalLiability
ownersEquity
java.util.List<E> ownersEquity
totalOwnersEquity
BalanceSheetSideBySideItemResult totalOwnersEquity
totalReturainedEarnings
BalanceSheetSideBySideItemResult totalReturainedEarnings
totalLiabilityEquity
BalanceSheetSideBySideItemResult totalLiabilityEquity
Class bb.common.BankReconciliationReportVO extends VO implements Serializable

Serialized Fields

pk
AccountMonthPK pk
status
java.lang.String status
Class bb.common.BB2AttachFile extends java.lang.Object implements Serializable

Serialized Fields

file
byte[] file
filename
java.lang.String filename
Class bb.common.BB2BigDecimalAndString extends java.lang.Object implements Serializable

Serialized Fields

id
java.math.BigDecimal id
desc
java.lang.String desc
Class bb.common.BB2BugNotice extends java.lang.Object implements Serializable

Serialized Fields

content
java.lang.String content
subject
java.lang.String subject
sendFrom
java.lang.String sendFrom
sendTo
java.lang.String sendTo
attach
java.util.ArrayList<E> attach
Class bb.common.BB2Document extends java.lang.Object implements Serializable

Serialized Fields

pn
java.lang.String pn
version
java.lang.String version
language
java.lang.String language
documentType
java.lang.String documentType
from
java.lang.String from
comments
java.lang.String comments
bytes
byte[] bytes
Class bb.common.BB2DocumentException extends BB2ServerException implements Serializable

Serialized Fields

target
java.lang.String target
Class bb.common.BB2DoubleCost extends java.lang.Object implements Serializable

Serialized Fields

avgAmount
java.math.BigDecimal avgAmount
stdAmount
java.math.BigDecimal stdAmount
Class bb.common.BB2DoubleString extends java.lang.Object implements Serializable

Serialized Fields

identifier
java.lang.String identifier
description
java.lang.String description
Class bb.common.BB2Event extends java.lang.Object implements Serializable

Serialized Fields

source
java.lang.String source
action
java.lang.String action
message
java.lang.String message
popup
boolean popup
Class bb.common.BB2File extends java.lang.Object implements Serializable

Serialized Fields

context
byte[] context
ext
java.lang.String ext
filename
java.lang.String filename
Class bb.common.BB2FiscalYearDate extends java.lang.Object implements Serializable

Serialized Fields

startDate
java.util.Date startDate
endDate
java.util.Date endDate
monthCount
int monthCount
Class bb.common.BB2Login extends java.lang.Object implements Serializable

Serialized Fields

userName
java.lang.String userName
password
java.lang.String password
system
java.lang.String system
language
java.lang.String language
clientIP
java.lang.String clientIP
clientWanIp
java.lang.String clientWanIp
clientMAC
java.lang.String clientMAC
loginType
java.lang.String loginType
Class bb.common.BB2MessagingException extends BB2ServerException implements Serializable

Class bb.common.BB2Notice extends java.lang.Object implements Serializable

Serialized Fields

sendFrom
java.lang.String sendFrom
sentTo
java.lang.String[] sentTo
copyTo
java.lang.String[] copyTo
noticeText
java.lang.String noticeText
hostName
java.lang.String hostName
orderNumber
java.lang.String orderNumber
messageNumber
java.lang.String messageNumber
validateCode
java.lang.String validateCode
subject
java.lang.String subject
needReply
boolean needReply
attach
java.util.ArrayList<E> attach
Class bb.common.BB2Part extends java.lang.Object implements Serializable

Serialized Fields

partPk
PartPK partPk
partFrom
java.lang.String partFrom
Class bb.common.BB2PartBasicInfo extends java.lang.Object implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

part
BB2Part part
description
java.lang.String description
Class bb.common.BB2PartByDateResult extends java.lang.Object implements Serializable

Serialized Fields

part
BB2Part part
newOnhand
java.math.BigDecimal newOnhand
newTotalCost
java.math.BigDecimal newTotalCost
totalIssuedQty
java.math.BigDecimal totalIssuedQty
totalReceiveQty
java.math.BigDecimal totalReceiveQty
oldOnhand
java.math.BigDecimal oldOnhand
oldTotalCost
java.math.BigDecimal oldTotalCost
totalIssuedCost
java.math.BigDecimal totalIssuedCost
totalReceivedCost
java.math.BigDecimal totalReceivedCost
currency
java.lang.String currency
unit
java.lang.String unit
Class bb.common.BB2PartInfo extends BB2PartBasicInfo implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

dwg
java.lang.String dwg
bom
java.lang.String bom
hold
java.lang.String hold
rev
java.lang.String rev
onhand
java.math.BigDecimal onhand
onorder
java.math.BigDecimal onorder
ondemand
java.math.BigDecimal ondemand
inWip
java.math.BigDecimal inWip
inSip
java.math.BigDecimal inSip
inSit
java.math.BigDecimal inSit
minQty
java.math.BigDecimal minQty
maxQty
java.math.BigDecimal maxQty
yrUsage
java.math.BigDecimal yrUsage
qtrUsage
java.math.BigDecimal qtrUsage
leadtime
java.math.BigDecimal leadtime
Class bb.common.BB2PartInSipItemResult extends java.lang.Object implements Serializable

Serialized Fields

packBoxItemPk
PackingBoxItemPK packBoxItemPk
qtyInSip
java.math.BigDecimal qtyInSip
deliveryDate
java.util.Date deliveryDate
customerId
java.lang.String customerId
Class bb.common.BB2PartInSipOfSoItemResult extends java.lang.Object implements Serializable

Serialized Fields

pk
SalesOrderItemPK pk
qtyOrdered
java.math.BigDecimal qtyOrdered
qtyInSip
java.math.BigDecimal qtyInSip
qtyShipped
java.math.BigDecimal qtyShipped
deliveryDate
java.util.Date deliveryDate
customerId
java.lang.String customerId
Class bb.common.BB2PartInSitItemResult extends java.lang.Object implements Serializable

Serialized Fields

packBoxItemPk
PrPackingBoxItemPK packBoxItemPk
qtyInSit
java.math.BigDecimal qtyInSit
deliveryDate
java.util.Date deliveryDate
vendorId
java.lang.String vendorId
arrivalDate
java.util.Date arrivalDate
shipToId
java.lang.String shipToId
Class bb.common.BB2PartInSTOItemResult extends java.lang.Object implements Serializable

Serialized Fields

pk
TransferShipperItemPK pk
qty
java.math.BigDecimal qty
status
java.lang.String status
toAddressId
java.lang.String toAddressId
shipDate
java.util.Date shipDate
Class bb.common.BB2PartInventoryResult extends java.lang.Object implements Serializable

Serialized Fields

part
BB2Part part
onhand
java.math.BigDecimal onhand
onOrderQty
java.math.BigDecimal onOrderQty
onDemandQty
java.math.BigDecimal onDemandQty
workInProcessQty
java.math.BigDecimal workInProcessQty
shipInProcessQty
java.math.BigDecimal shipInProcessQty
shipInTransactionQty
java.math.BigDecimal shipInTransactionQty
avgcost
java.math.BigDecimal avgcost
Class bb.common.BB2PartMrpResult extends BB2PartInfo implements Serializable

Serialized Fields

purchaseOrderOnOrderResult
java.util.ArrayList<E> purchaseOrderOnOrderResult
workOrderOnOrderResult
java.util.ArrayList<E> workOrderOnOrderResult
workOrderOnDemandResult
java.util.ArrayList<E> workOrderOnDemandResult
salesOrderOnDemandResult
java.util.ArrayList<E> salesOrderOnDemandResult
salesOrderOrphanedResult
java.util.ArrayList<E> salesOrderOrphanedResult
Class bb.common.BB2PartOnDemandListResult extends java.lang.Object implements Serializable

Serialized Fields

part
BB2Part part
description
java.lang.String description
onhand
java.math.BigDecimal onhand
onorder
java.math.BigDecimal onorder
ondemand
java.math.BigDecimal ondemand
insip
java.math.BigDecimal insip
insit
java.math.BigDecimal insit
inwip
java.math.BigDecimal inwip
Class bb.common.BB2PartOnhandPK extends java.lang.Object implements Serializable

Serialized Fields

partFrom
java.lang.String partFrom
pk
PartOnhandPK pk
Class bb.common.BB2PartOnLoanItemResult extends java.lang.Object implements Serializable

Serialized Fields

pk
OnloanShipperItemPK pk
qty
java.math.BigDecimal qty
status
java.lang.String status
customerId
java.lang.String customerId
shipDate
java.util.Date shipDate
Class bb.common.BB2PartTotalInQADetailResult extends BB2PartBasicInfo implements Serializable

Serialized Fields

totalInQA
java.math.BigDecimal totalInQA
details
java.util.List<E> details
Class bb.common.BB2PartTotalInSipDetailResult extends BB2PartBasicInfo implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

totalInSip
java.math.BigDecimal totalInSip
details
java.util.ArrayList<E> details
Class bb.common.BB2PartTotalInSitDetailResult extends BB2PartBasicInfo implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

totalInSit
java.math.BigDecimal totalInSit
details
java.util.ArrayList<E> details
Class bb.common.BB2PartTotalInSTODetailResult extends BB2PartBasicInfo implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

totalInSTO
java.math.BigDecimal totalInSTO
details
java.util.ArrayList<E> details
Class bb.common.BB2PartTotalInWipDetailResult extends BB2PartBasicInfo implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

totalInWip
java.math.BigDecimal totalInWip
details
java.util.ArrayList<E> details
dwoDetails
java.util.ArrayList<E> dwoDetails
Class bb.common.BB2PartTotalOndemandDetailResult extends BB2PartBasicInfo implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

totalOndemand
java.math.BigDecimal totalOndemand
soDetails
java.util.ArrayList<E> soDetails
woDetails
java.util.ArrayList<E> woDetails
dwoDetails
java.util.ArrayList<E> dwoDetails
npDetails
java.util.ArrayList<E> npDetails
rmaDetails
java.util.ArrayList<E> rmaDetails
Class bb.common.BB2PartTotalOnhandDetailResult extends BB2PartBasicInfo implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

totalOnhand
java.math.BigDecimal totalOnhand
details
java.util.ArrayList<E> details
minQty
java.math.BigDecimal minQty
maxQty
java.math.BigDecimal maxQty
qtrUsage
java.math.BigDecimal qtrUsage
yrUsage
java.math.BigDecimal yrUsage
weight
java.math.BigDecimal weight
weightUnit
java.lang.String weightUnit
unit
java.lang.String unit
Class bb.common.BB2PartTotalOnloanDetailResult extends BB2PartBasicInfo implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

totalOnloan
java.math.BigDecimal totalOnloan
details
java.util.ArrayList<E> details
Class bb.common.BB2PartTotalOnorderDetailResult extends BB2PartBasicInfo implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

totalOnorder
java.math.BigDecimal totalOnorder
poDetails
java.util.ArrayList<E> poDetails
woDetails
java.util.ArrayList<E> woDetails
swsDetails
java.util.ArrayList<E> swsDetails
dwoDetails
java.util.ArrayList<E> dwoDetails
Class bb.common.BB2Picture extends BB2File implements Serializable

Serialized Fields

id
java.lang.Long id
mainPicture
boolean mainPicture
width
java.lang.Short width
height
java.lang.Short height
Class bb.common.BB2QtyAndMoneyMap extends java.lang.Object implements Serializable

Serialized Fields

map
java.util.HashMap<K,V> map
Class bb.common.BB2RefdocPK extends java.lang.Object implements Serializable

Serialized Fields

forderNumber
java.lang.String forderNumber
fitemNumber
java.lang.String fitemNumber
torderNumber
java.lang.String torderNumber
titemNumber
java.lang.String titemNumber
Class bb.common.BB2ServerException extends java.lang.Exception implements Serializable

Serialized Fields

reason
Reason reason
parameter
java.lang.Object parameter
Class bb.common.BB2Task extends java.lang.Object implements Serializable

Serialized Fields

name
java.lang.String name
taskClass
java.lang.String taskClass
description
java.lang.String description
params
java.lang.String params
Class bb.common.BB2tripleString extends java.lang.Object implements Serializable

Serialized Fields

accountNumber
java.lang.String accountNumber
identifier field

currency
java.lang.String currency
identifier field

addressId
java.lang.String addressId
identifier field

Class bb.common.BB2WeightInfoResult extends java.lang.Object implements Serializable

Serialized Fields

part
BB2Part part
weight
java.math.BigDecimal weight
weightUnit
java.lang.String weightUnit
volume
java.math.BigDecimal volume
volumeUnit
java.lang.String volumeUnit
Class bb.common.BillDetailCostResult extends java.lang.Object implements Serializable

Serialized Fields

billInfo
BillDetailCostWithPartInfoResult billInfo
billItems
java.util.Set<E> billItems
listCost
java.math.BigDecimal listCost
averageCost
java.math.BigDecimal averageCost
standardCost
java.math.BigDecimal standardCost
missingItems
java.lang.Integer missingItems
vendorLowestCost
java.math.BigDecimal vendorLowestCost
vendorAverageCost
java.math.BigDecimal vendorAverageCost
vendorHighestCost
java.math.BigDecimal vendorHighestCost
Class bb.common.BillDetailCostWithPartInfoResult extends BillWithPartInfoResult implements Serializable

Serialized Fields

listPrice
java.math.BigDecimal listPrice
averageCost
java.math.BigDecimal averageCost
standardCost
java.math.BigDecimal standardCost
Class bb.common.BillItemDetailCostWithPartInfoResult extends BillItemWithPartInfoResult implements Serializable

Serialized Fields

listPrice
java.math.BigDecimal listPrice
averageCost
java.math.BigDecimal averageCost
standardCost
java.math.BigDecimal standardCost
Class bb.common.BillItemOnHandUsageResult extends BillItemUsageResult implements Serializable

Serialized Fields

onhand
java.math.BigDecimal onhand
onorder
java.math.BigDecimal onorder
ondemand
java.math.BigDecimal ondemand
inWip
java.math.BigDecimal inWip
inSip
java.math.BigDecimal inSip
inSit
java.math.BigDecimal inSit
onhandLocation
java.util.Collection<E> onhandLocation
Class bb.common.BillItemOnHandWithPartInfoResult extends BillItemWithPartInfoResult implements Serializable

Serialized Fields

onhand
java.math.BigDecimal onhand
onorder
java.math.BigDecimal onorder
ondemand
java.math.BigDecimal ondemand
inWip
java.math.BigDecimal inWip
inSip
java.math.BigDecimal inSip
inSit
java.math.BigDecimal inSit
onhandLocation
java.util.Collection<E> onhandLocation
Class bb.common.BillItemPK extends java.lang.Object implements Serializable

Serialized Fields

billNumber
java.lang.String billNumber
identifier field

billType
java.lang.String billType
identifier field

billItemNumber
java.lang.String billItemNumber
identifier field

Class bb.common.BillItemReplacementVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
billNumber
java.lang.String billNumber
billType
java.lang.String billType
asmSequenceNo
java.lang.String asmSequenceNo
replacePartNumber
java.lang.String replacePartNumber
replacePartType
java.lang.String replacePartType
ratio
java.math.BigDecimal ratio
scrapRate
java.math.BigDecimal scrapRate
replaceDesc
java.lang.String replaceDesc
itemComments
java.lang.String itemComments
onHand
java.math.BigDecimal onHand
Class bb.common.BillItemSalesCostResult extends PartBasicInfo implements Serializable

Serialized Fields

salesable
java.lang.String salesable
billItemPk
BillItemPK billItemPk
qty
java.math.BigDecimal qty
sparePart
java.lang.String sparePart
listPrice
java.math.BigDecimal listPrice
averageCost
java.math.BigDecimal averageCost
standardCost
java.math.BigDecimal standardCost
partManufacturer
java.util.List<E> partManufacturer
totalListPrice
java.math.BigDecimal totalListPrice
totalStdCost
java.math.BigDecimal totalStdCost
totalAvgCost
java.math.BigDecimal totalAvgCost
Class bb.common.BillItemSalesResult extends java.lang.Object implements Serializable

Serialized Fields

billItemPk
BillItemPK billItemPk
qty
java.math.BigDecimal qty
partNumber
java.lang.String partNumber
partType
java.lang.String partType
rev
java.lang.String rev
unit
java.lang.String unit
description
java.lang.String description
sparePart
java.lang.String sparePart
Class bb.common.BillItemSalesXResult extends java.lang.Object implements Serializable

Serialized Fields

salesable
java.lang.String salesable
billItemPk
BillItemPK billItemPk
qty
java.math.BigDecimal qty
partNumber
java.lang.String partNumber
partType
java.lang.String partType
rev
java.lang.String rev
hold
java.lang.String hold
dwg
java.lang.String dwg
unit
java.lang.String unit
bill
java.lang.String bill
description
java.lang.String description
sparePart
java.lang.String sparePart
listPrice
java.math.BigDecimal listPrice
averageCost
java.math.BigDecimal averageCost
standardCost
java.math.BigDecimal standardCost
makeBuy
java.lang.String makeBuy
Class bb.common.BillItemUsagePathResult extends java.lang.Object implements Serializable

Serialized Fields

pk
PartPK pk
itemNumber
java.lang.String itemNumber
descripiton
java.lang.String descripiton
itemQty
java.math.BigDecimal itemQty
usageQty
java.math.BigDecimal usageQty
sparePart
java.lang.String sparePart
itemComments
java.lang.String itemComments
Class bb.common.BillItemUsageResult extends PartBasicInfo implements Serializable

Serialized Fields

fixedQty
java.math.BigDecimal fixedQty
spareQty
java.math.BigDecimal spareQty
totalQty
java.math.BigDecimal totalQty
listPrice
java.math.BigDecimal listPrice
averageCost
java.math.BigDecimal averageCost
standardCost
java.math.BigDecimal standardCost
items
java.util.ArrayList<E> items
Class bb.common.BillItemVO extends VO implements Serializable

Serialized Fields

pk
BillItemPK pk
asmSequenceNo
java.lang.String asmSequenceNo
kitNumber
java.lang.Integer kitNumber
bc
java.lang.String bc
partQuantity
java.math.BigDecimal partQuantity
partNumber
java.lang.String partNumber
partType
java.lang.String partType
sparePart
java.lang.String sparePart
comments
java.lang.String comments
roundToIntForSetup
boolean roundToIntForSetup
scrapRate
java.math.BigDecimal scrapRate
billItemReplacements
java.util.Set<E> billItemReplacements
Class bb.common.BillItemWithPartInfoResult extends PartBasicInfo implements Serializable

Serialized Fields

billItemPk
BillItemPK billItemPk
traceableLevel
java.lang.Byte traceableLevel
partQuantity
java.math.BigDecimal partQuantity
asmSequenceNo
java.lang.String asmSequenceNo
kitNumber
java.lang.Integer kitNumber
sparePart
java.lang.String sparePart
listPrice
java.math.BigDecimal listPrice
comments
java.lang.String comments
scrapRate
java.math.BigDecimal scrapRate
scrapQty
java.math.BigDecimal scrapQty
backflushMaterial
boolean backflushMaterial
partManufacturer
java.util.List<E> partManufacturer
billItemReplacements
java.util.Set<E> billItemReplacements
ecnList
java.util.List<E> ecnList
multiQtyforApplying
java.math.BigDecimal multiQtyforApplying
Class bb.common.BillLogVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
billNumber
java.lang.String billNumber
billType
java.lang.String billType
billItemNumber
java.lang.String billItemNumber
lastChangeTime
java.util.Date lastChangeTime
lastChangeUser
java.lang.String lastChangeUser
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partQuantity
java.math.BigDecimal partQuantity
sparePart
java.lang.String sparePart
newPartNumber
java.lang.String newPartNumber
newPartType
java.lang.String newPartType
newPartQuantity
java.math.BigDecimal newPartQuantity
newSparePart
java.lang.String newSparePart
Class bb.common.BillOnHandWithPartInfoResult extends BillWithPartInfoResult implements Serializable

Serialized Fields

onhand
java.math.BigDecimal onhand
onorder
java.math.BigDecimal onorder
ondemand
java.math.BigDecimal ondemand
inWip
java.math.BigDecimal inWip
inSip
java.math.BigDecimal inSip
inSit
java.math.BigDecimal inSit
locationOnhand
java.math.BigDecimal locationOnhand
Class bb.common.BillPK extends java.lang.Object implements Serializable

Serialized Fields

billNumber
java.lang.String billNumber
billType
java.lang.String billType
Class bb.common.BillSalesCostResult extends PartBasicInfo implements Serializable

Serialized Fields

billPk
BillPK billPk
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
listPrice
java.math.BigDecimal listPrice
averageCost
java.math.BigDecimal averageCost
standardCost
java.math.BigDecimal standardCost
saleable
java.lang.String saleable
Class bb.common.BillSalesOfCostResult extends java.lang.Object implements Serializable

Serialized Fields

missingItems
java.lang.Integer missingItems
totallistCost
java.math.BigDecimal totallistCost
totalaverageCost
java.math.BigDecimal totalaverageCost
totalstandardCost
java.math.BigDecimal totalstandardCost
vendorLowestCost
java.math.BigDecimal vendorLowestCost
vendorAverageCost
java.math.BigDecimal vendorAverageCost
vendorHighestCost
java.math.BigDecimal vendorHighestCost
Class bb.common.BillSalesResult extends java.lang.Object implements Serializable

Serialized Fields

partPk
PartPK partPk
rev
java.lang.String rev
unit
java.lang.String unit
description
java.lang.String description
items
java.util.Set<E> items
Class bb.common.BillSalesXResult extends java.lang.Object implements Serializable

Serialized Fields

partPk
PartPK partPk
salesable
java.lang.String salesable
hold
java.lang.String hold
dwg
java.lang.String dwg
rev
java.lang.String rev
unit
java.lang.String unit
description
java.lang.String description
items
java.util.Set<E> items
listPrice
java.math.BigDecimal listPrice
averageCost
java.math.BigDecimal averageCost
standardCost
java.math.BigDecimal standardCost
missingItems
java.lang.Integer missingItems
totallistCost
java.math.BigDecimal totallistCost
totalaverageCost
java.math.BigDecimal totalaverageCost
totalstandardCost
java.math.BigDecimal totalstandardCost
vendorLowestCost
java.math.BigDecimal vendorLowestCost
vendorAverageCost
java.math.BigDecimal vendorAverageCost
vendorHighestCost
java.math.BigDecimal vendorHighestCost
Class bb.common.BillVO extends VO implements Serializable

Serialized Fields

pk
BillPK pk
lastChangeUser
java.lang.String lastChangeUser
origin
java.lang.String origin
lastChangeDate
java.util.Date lastChangeDate
billItem
java.util.Set<E> billItem
version
java.lang.Integer version
rbFlag
java.lang.String rbFlag
mfgBillSetupInfo
java.lang.String mfgBillSetupInfo
createdDate
java.util.Date createdDate
status
java.lang.String status
approvedBy
java.lang.String approvedBy
approvedDate
java.util.Date approvedDate
Class bb.common.BillWhereUsedItemResult extends java.lang.Object implements Serializable

Serialized Fields

billItemPk
BillItemPK billItemPk
onhand
java.math.BigDecimal onhand
description
java.lang.String description
bill
java.lang.String bill
qty
java.math.BigDecimal qty
Class bb.common.BillWhereUsedResult extends java.lang.Object implements Serializable

Serialized Fields

partPk
PartPK partPk
description
java.lang.String description
makeBuy
java.lang.String makeBuy
totalQty
java.math.BigDecimal totalQty
onhand
java.math.BigDecimal onhand
onorder
java.math.BigDecimal onorder
ondemand
java.math.BigDecimal ondemand
items
java.util.Set<E> items
Class bb.common.BillWithPartInfoResult extends PartBasicInfo implements Serializable

Serialized Fields

traceableLevel
java.lang.Byte traceableLevel
billPk
BillPK billPk
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
createdDate
java.util.Date createdDate
status
java.lang.String status
approvedBy
java.lang.String approvedBy
approvedDate
java.util.Date approvedDate
partManufacturer
java.util.List<E> partManufacturer
ecnList
java.util.List<E> ecnList
Class bb.common.BizboxBugChangesInfoVO extends VO implements Serializable

Serialized Fields

id
java.lang.Integer id
identifier field

bugId
java.lang.Integer bugId
persistent field

action
java.lang.String action
persistent field

fixedBy
java.lang.String fixedBy
persistent field

fixedDate
java.util.Date fixedDate
nullable persistent field

description
java.lang.String description
nullable persistent field

length
java.lang.Integer length
nullable persistent field

extension
java.lang.String extension
persistent field

status
java.lang.String status
persistent field

Class bb.common.BizboxBugChangesVO extends VO implements Serializable

Serialized Fields

id
java.lang.Integer id
identifier field

bugId
java.lang.Integer bugId
persistent field

action
java.lang.String action
persistent field

fixedBy
java.lang.String fixedBy
persistent field

fixedDate
java.util.Date fixedDate
nullable persistent field

description
java.lang.String description
nullable persistent field

attachment
byte[] attachment
nullable persistent field

extension
java.lang.String extension
persistent field

status
java.lang.String status
persistent field

Class bb.common.BizboxBugInfoVO extends VO implements Serializable

Serialized Fields

id
java.lang.Integer id
identifier field

bugTitle
java.lang.String bugTitle
persistent field

moduleName
java.lang.String moduleName
persistent field

osType
java.lang.String osType
persistent field

jreVersion
java.lang.String jreVersion
persistent field

screenSize
java.lang.String screenSize
persistent field

reportBy
java.lang.String reportBy
persistent field

reportDate
java.util.Date reportDate
nullable persistent field

priority
java.lang.String priority
persistent field

severity
java.lang.String severity
persistent field

bugDescription
java.lang.String bugDescription
persistent field

length
java.lang.Integer length
nullable persistent field

extension
java.lang.String extension
persistent field

status
java.lang.String status
persistent field

changes
java.util.Set<E> changes
Class bb.common.BizboxBugVO extends VO implements Serializable

Serialized Fields

id
java.lang.Integer id
identifier field

bugTitle
java.lang.String bugTitle
persistent field

moduleName
java.lang.String moduleName
persistent field

osType
java.lang.String osType
persistent field

jreVersion
java.lang.String jreVersion
persistent field

screenSize
java.lang.String screenSize
persistent field

reportBy
java.lang.String reportBy
persistent field

reportDate
java.util.Date reportDate
nullable persistent field

priority
java.lang.String priority
persistent field

severity
java.lang.String severity
persistent field

bugDescription
java.lang.String bugDescription
persistent field

attachment
byte[] attachment
nullable persistent field

extension
java.lang.String extension
persistent field

status
java.lang.String status
persistent field

Class bb.common.BizBoxServer extends java.lang.Object implements Serializable

Serialized Fields

server
java.lang.String server
port
java.lang.String port
system
java.lang.String system
username
java.lang.String username
password
java.lang.String password
languageCode
java.lang.String languageCode
Class bb.common.BizBoxUserEmployeeResult extends java.lang.Object implements Serializable

Serialized Fields

userName
java.lang.String userName
systemUserName
java.lang.String systemUserName
type
int type
refId
java.lang.String refId
locked
boolean locked
department
java.lang.String department
phone
java.lang.String phone
email
java.lang.String email
mobile
java.lang.String mobile
homePhone
java.lang.String homePhone
comment
java.lang.String comment
firstName
java.lang.String firstName
middleName
java.lang.String middleName
lastName
java.lang.String lastName
fullName
java.lang.String fullName
Class bb.common.BizboxUserListResult extends VO implements Serializable

Serialized Fields

userName
java.lang.String userName
systemUserName
java.lang.String systemUserName
ip
java.lang.String ip
status
int status
lastLogin
java.util.Date lastLogin
lastLogout
java.util.Date lastLogout
createTime
java.util.Date createTime
type
int type
refId
java.lang.String refId
locked
boolean locked
expireDate
java.util.Date expireDate
canUpdateAnything
short canUpdateAnything
comment
java.lang.String comment
department
java.lang.String department
Class bb.common.BizboxUserVO extends VO implements Serializable

Serialized Fields

userName
java.lang.String userName
identifier field

password
java.lang.String password
persistent field

ip
java.lang.String ip
nullable persistent field

lanIp
java.lang.String lanIp
macAddress
java.lang.String macAddress
status
int status
persistent field

lastLogin
java.util.Date lastLogin
nullable persistent field

lastLogout
java.util.Date lastLogout
nullable persistent field

createTime
java.util.Date createTime
nullable persistent field

type
int type
persistent field

refId
java.lang.String refId
persistent field

companyUnitId
java.lang.String companyUnitId
multiCompanyUnit
java.lang.String multiCompanyUnit
persistent field

locked
boolean locked
persistent field

expireDate
java.util.Date expireDate
nullable persistent field

canUpdateAnything
short canUpdateAnything
comment
java.lang.String comment
nullable persistent field

lastChangePassword
java.util.Date lastChangePassword
Class bb.common.BizException extends BB2ServerException implements Serializable

Serialized Fields

target
java.lang.String target
parameter
java.lang.Object parameter
Class bb.common.BomApprovalVO extends VO implements Serializable

Serialized Fields

employeeId
java.lang.String employeeId
userName
java.lang.String userName
canApproveOwnBom
boolean canApproveOwnBom
comments
java.lang.String comments
Class bb.common.BOMCanAssyAgent extends java.lang.Object implements Serializable

Serialized Fields

partNums
java.util.List<E> partNums
listSO
boolean listSO
listWO
boolean listWO
billNumber
java.lang.String billNumber
listBOM
boolean listBOM
rootBOM
boolean rootBOM
usedDate
java.util.Date usedDate
Class bb.common.BOMCanAssyListResult extends java.lang.Object implements Serializable

Serialized Fields

pk
PartPK pk
description
java.lang.String description
onhand
java.math.BigDecimal onhand
ondemand
java.math.BigDecimal ondemand
onOrder
java.math.BigDecimal onOrder
qty
java.math.BigDecimal qty
Class bb.common.BomItemWithOEMResult extends java.lang.Object implements Serializable

Serialized Fields

billItemPk
BillItemPK billItemPk
qty
java.math.BigDecimal qty
partPk
PartPK partPk
mfgID
java.lang.String mfgID
mpn
java.lang.String mpn
rev
java.lang.String rev
dwg
java.lang.String dwg
bom
java.lang.String bom
wi
java.lang.String wi
unit
java.lang.String unit
traceable
java.lang.String traceable
description
java.lang.String description
listPrice
java.math.BigDecimal listPrice
Class bb.common.BomPickListItemResult extends java.lang.Object implements Serializable

Serialized Fields

billItemPk
BillItemPK billItemPk
partPk
PartPK partPk
partFrom
java.lang.String partFrom
revision
java.lang.String revision
dwg
java.lang.String dwg
bom
java.lang.String bom
description
java.lang.String description
partUnit
java.lang.String partUnit
location
java.lang.String location
onhand
java.math.BigDecimal onhand
qtyRequested
java.math.BigDecimal qtyRequested
qtyPicked
java.math.BigDecimal qtyPicked
Class bb.common.BomPickListResult extends java.lang.Object implements Serializable

Serialized Fields

billPk
BillPK billPk
partFrom
java.lang.String partFrom
description
java.lang.String description
quantity
java.math.BigDecimal quantity
items
java.util.Set<E> items
Class bb.common.BOMTreeRollUPMap extends java.lang.Object implements Serializable

Serialized Fields

s
java.util.HashMap<K,V> s
t
java.util.HashMap<K,V> t
Class bb.common.BomWithOEMResult extends java.lang.Object implements Serializable

Serialized Fields

billPk
BillPK billPk
mfgID
java.lang.String mfgID
mpn
java.lang.String mpn
rev
java.lang.String rev
dwg
java.lang.String dwg
unit
java.lang.String unit
description
java.lang.String description
listPrice
java.math.BigDecimal listPrice
items
java.util.Set<E> items
Class bb.common.BudgetListResult extends java.lang.Object implements Serializable

Serialized Fields

accountNumber
java.lang.String accountNumber
accountType
java.lang.String accountType
level
java.lang.String level
upLevelAccount
java.lang.String upLevelAccount
items
byte items
description
java.lang.String description
checkedItem
java.lang.String checkedItem
budget
java.util.Map<K,V> budget
actual
java.util.Map<K,V> actual
varianceAMT
java.util.Map<K,V> varianceAMT
variancePercentage
java.util.Map<K,V> variancePercentage
budgetYTD
java.util.Map<K,V> budgetYTD
actualYTD
java.util.Map<K,V> actualYTD
varianceAMTYTD
java.util.Map<K,V> varianceAMTYTD
variancePercentageYTD
java.util.Map<K,V> variancePercentageYTD
actualTotleMap
java.util.HashMap<K,V> actualTotleMap
total
java.math.BigDecimal total
budgetTotal
java.math.BigDecimal budgetTotal
actualTotal
java.math.BigDecimal actualTotal
varianceAMTTotal
java.math.BigDecimal varianceAMTTotal
variancePercentageTotal
java.math.BigDecimal variancePercentageTotal
checked
boolean checked
active
boolean active
Class bb.common.BuyerCodeVO extends VO implements Serializable

Serialized Fields

id
java.lang.Integer id
buyerCode
java.lang.String buyerCode
actionType
java.lang.String actionType
description
java.lang.String description
buyerName
java.lang.String buyerName
department
java.lang.String department
departmentId
java.lang.String departmentId
comments
java.lang.String comments
Class bb.common.CarrierPK extends java.lang.Object implements Serializable

Serialized Fields

addressId
java.lang.String addressId
identifier field

seq
java.lang.String seq
identifier field

Class bb.common.CarrierVO extends VO implements Serializable

Serialized Fields

pk
CarrierPK pk
identifier field

carrier
java.lang.String carrier
persistent field

carrierAccount
java.lang.String carrierAccount
persistent field

remarks
java.lang.String remarks
persistent field

Class bb.common.CashFlowByMonthReportResult extends java.lang.Object implements Serializable

Serialized Fields

ar
java.util.Map<K,V> ar
openSo
java.util.Map<K,V> openSo
arPrepay
java.util.Map<K,V> arPrepay
ap
java.util.Map<K,V> ap
openPo
java.util.Map<K,V> openPo
apPrepay
java.util.Map<K,V> apPrepay
arPastDue
java.math.BigDecimal arPastDue
soPastDue
java.math.BigDecimal soPastDue
apPastDue
java.math.BigDecimal apPastDue
poPastDue
java.math.BigDecimal poPastDue
arPrepayPastDue
java.math.BigDecimal arPrepayPastDue
apPrepayPastDue
java.math.BigDecimal apPrepayPastDue
Class bb.common.CashFlowMonthTotalResult extends java.lang.Object implements Serializable

Serialized Fields

month
java.lang.String month
startMonthBudget
java.math.BigDecimal startMonthBudget
endMonthBudget
java.math.BigDecimal endMonthBudget
eTotalBudget
java.math.BigDecimal eTotalBudget
rTotalBudget
java.math.BigDecimal rTotalBudget
Class bb.common.CashierVO extends VO implements Serializable

Serialized Fields

cashier
java.lang.String cashier
password
java.lang.String password
lastName
java.lang.String lastName
middleName
java.lang.String middleName
firstName
java.lang.String firstName
Class bb.common.CatalogVO extends VO implements Serializable

Serialized Fields

catalogID
java.lang.String catalogID
description
java.lang.String description
Class bb.common.CertificateDescriptionVO extends VO implements Serializable

Serialized Fields

id
java.lang.Integer id
identifier field

description
java.lang.String description
persistent field

Class bb.common.ChangeStdCostWorkSheetItemPK extends java.lang.Object implements Serializable

Serialized Fields

ii
java.lang.Long ii
partNumber
java.lang.String partNumber
partType
java.lang.String partType
Class bb.common.ChangeStdCostWorkSheetItemVO extends VO implements Serializable

Serialized Fields

pk
ChangeStdCostWorkSheetItemPK pk
description
java.lang.String description
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
newStdCost
java.math.BigDecimal newStdCost
variancePercent
java.math.BigDecimal variancePercent
onHand
java.math.BigDecimal onHand
makeBuy
java.lang.String makeBuy
Class bb.common.ChangeStdCostWorkSheetVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
createdBy
java.lang.String createdBy
createdDate
java.util.Date createdDate
itemCount
java.lang.Integer itemCount
varianceAmount
java.math.BigDecimal varianceAmount
committedDate
java.util.Date committedDate
committedBy
java.lang.String committedBy
transactionNumber
java.lang.String transactionNumber
status
java.lang.String status
comments
java.lang.String comments
Class bb.common.CheckInvoiceItemListResult extends InvoiceItemListResult implements Serializable

Serialized Fields

signature
byte[] signature
raoNumber
java.lang.String raoNumber
Class bb.common.CheckRunItemTotalResult extends java.lang.Object implements Serializable

Serialized Fields

vendorTotal
java.math.BigDecimal vendorTotal
apTotal
java.math.BigDecimal apTotal
totalPaid
java.math.BigDecimal totalPaid
totalDue
java.math.BigDecimal totalDue
totalToBePaid
java.math.BigDecimal totalToBePaid
Class bb.common.ClientListItem extends java.lang.Object implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

identifier
java.lang.String identifier
str
java.lang.String str
Class bb.common.ClosingStatementItemResult extends java.lang.Object implements Serializable

Serialized Fields

accountNumber
java.lang.String accountNumber
accountType
java.lang.String accountType
level
java.lang.String level
items
byte items
upLevelAccountNumber
java.lang.String upLevelAccountNumber
creditOrDebit
java.lang.String creditOrDebit
addOrSubtract
java.lang.String addOrSubtract
accountDescription
java.lang.String accountDescription
credit
java.math.BigDecimal credit
debit
java.math.BigDecimal debit
balance
java.math.BigDecimal balance
monthToDate
java.math.BigDecimal monthToDate
yearToDate
java.math.BigDecimal yearToDate
Class bb.common.ClosingStatementResult extends java.lang.Object implements Serializable

Serialized Fields

monthYear
java.lang.String monthYear
previousMonthYear
java.lang.String previousMonthYear
companyUnitId
java.lang.String companyUnitId
grossRevenue
ClosingStatementTotalResult grossRevenue
costOfGoodsSold
ClosingStatementTotalResult costOfGoodsSold
grossNetProfit
ClosingStatementTotalResult grossNetProfit
costOfLabor
ClosingStatementTotalResult costOfLabor
operatingExpenses
ClosingStatementTotalResult operatingExpenses
netProfitBeforeWriteOffs
ClosingStatementTotalResult netProfitBeforeWriteOffs
writeOffExpenses
ClosingStatementTotalResult writeOffExpenses
netProfitBeforeOtherIncome
ClosingStatementTotalResult netProfitBeforeOtherIncome
otherIncome
ClosingStatementTotalResult otherIncome
otherExpenses
ClosingStatementTotalResult otherExpenses
netProfiteBeforeIncomeTax
ClosingStatementTotalResult netProfiteBeforeIncomeTax
incomeTax
ClosingStatementTotalResult incomeTax
netProfit
ClosingStatementTotalResult netProfit
currentAssets
java.util.List<E> currentAssets
totalCurrentAssets
java.math.BigDecimal totalCurrentAssets
otherAssets
java.util.List<E> otherAssets
totalOtherAssets
java.math.BigDecimal totalOtherAssets
fixedAssets
java.util.List<E> fixedAssets
totalFixedAssets
java.math.BigDecimal totalFixedAssets
lessDepreciation
java.util.List<E> lessDepreciation
totalDepreciation
java.math.BigDecimal totalDepreciation
totalAssets
java.math.BigDecimal totalAssets
currentLiabilities
java.util.List<E> currentLiabilities
totalCurrentLiabilities
java.math.BigDecimal totalCurrentLiabilities
longTermLiabilities
java.util.List<E> longTermLiabilities
totalLongTermLiabilities
java.math.BigDecimal totalLongTermLiabilities
otherLiabilities
java.util.List<E> otherLiabilities
totalOtherLiabilities
java.math.BigDecimal totalOtherLiabilities
equity
java.util.List<E> equity
retainedEqrning
java.math.BigDecimal retainedEqrning
totalEquity
java.math.BigDecimal totalEquity
totalLiabilityesEquity
java.math.BigDecimal totalLiabilityesEquity
revenueItems
java.util.List<E> revenueItems
revenueTotal
ClosingStatementTotalResult revenueTotal
costOfGoodsSoldItems
java.util.List<E> costOfGoodsSoldItems
costOfLaborItems
java.util.List<E> costOfLaborItems
operatingExpenseItems
java.util.List<E> operatingExpenseItems
writeOffExpenseItems
java.util.List<E> writeOffExpenseItems
otherExpenseItemsItems
java.util.List<E> otherExpenseItemsItems
incomeTaxItems
java.util.List<E> incomeTaxItems
retainedEarningTotal
ClosingStatementTotalResult retainedEarningTotal
generalLedgerBalance
java.util.List<E> generalLedgerBalance
totalGeneralLedgerBalance
java.util.TreeMap<K,V> totalGeneralLedgerBalance
Class bb.common.ClosingStatementTotalResult extends java.lang.Object implements Serializable

Serialized Fields

monthToDate
java.math.BigDecimal monthToDate
yearToDate
java.math.BigDecimal yearToDate
previousMonthTotal
java.math.BigDecimal previousMonthTotal
changePercent
java.math.BigDecimal changePercent
Class bb.common.CommonPrintTemplateVO extends VO implements Serializable

Serialized Fields

id
int id
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
adate
java.util.Date adate
origin
java.lang.String origin
version
java.lang.Integer version
templateName
java.lang.String templateName
width
int width
template
byte[] template
Class bb.common.CompanyUnitAccountPK extends java.lang.Object implements Serializable

Serialized Fields

companyUnitId
java.lang.String companyUnitId
identifier field

accountNumber
java.lang.String accountNumber
identifier field

Class bb.common.CompanyUnitAccountVO extends VO implements Serializable

Serialized Fields

pk
CompanyUnitAccountPK pk
identifier field

lastChangeDate
java.util.Date lastChangeDate
lastChangeUser
java.lang.String lastChangeUser
persistent field

Class bb.common.CompanyUnitVO extends VO implements Serializable

Serialized Fields

id
java.lang.String id
name
java.lang.String name
persistent field

lastChangeTimes
java.lang.Integer lastChangeTimes
nullable persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

type
java.lang.String type
comments
java.lang.String comments
level
java.lang.String level
upLevelUnitId
java.lang.String upLevelUnitId
Class bb.common.CompanyVO extends VO implements Serializable

Serialized Fields

id
java.lang.String id
identifier field

lastChangeUser
java.lang.String lastChangeUser
nullable persistent field

lastChangeTimes
java.lang.Integer lastChangeTimes
nullable persistent field

currency
java.lang.String currency
nullable persistent field

language
java.lang.String language
persistent field

systemLanguage
java.lang.String systemLanguage
persistent field

logo
byte[] logo
nullable persistent field

companyHome
byte[] companyHome
license
byte[] license
customTree
byte[] customTree
companyName
java.lang.String companyName
nullable persistent field

daysOverdue
java.lang.Byte daysOverdue
nullable persistent field

daysCurrent
java.lang.Short daysCurrent
nullable persistent field

engineeringChangePrefix
java.lang.String engineeringChangePrefix
persistent field

engineeringChangeDigits
byte engineeringChangeDigits
persistent field

engineeringChangeRequestPrefix
java.lang.String engineeringChangeRequestPrefix
persistent field

engineeringChangeRequestDigits
byte engineeringChangeRequestDigits
persistent field

employeeIdPrefix
java.lang.String employeeIdPrefix
employeeIdDigits
byte employeeIdDigits
autoEmployeeId
boolean autoEmployeeId
separateCV
boolean separateCV
tempWorkerPrefix
java.lang.String tempWorkerPrefix
tempWorkerDigits
byte tempWorkerDigits
autoTempWorderId
boolean autoTempWorderId
woPrefix
java.lang.String woPrefix
woDigits
byte woDigits
poPrefix
java.lang.String poPrefix
poDigits
byte poDigits
soPrefix
java.lang.String soPrefix
soDigits
byte soDigits
receiverPrefix
java.lang.String receiverPrefix
receiverDigits
byte receiverDigits
lnReceiverPrefix
java.lang.String lnReceiverPrefix
lnReceiverDigits
byte lnReceiverDigits
rmaReceiverPrefix
java.lang.String rmaReceiverPrefix
rmaReceiverDigits
byte rmaReceiverDigits
shipperPrefix
java.lang.String shipperPrefix
shipperDigits
byte shipperDigits
lnShipperPrefix
java.lang.String lnShipperPrefix
lnShipperDigits
byte lnShipperDigits
rtvShipperPrefix
java.lang.String rtvShipperPrefix
rtvShipperDigits
byte rtvShipperDigits
apPrefix
java.lang.String apPrefix
apDigits
byte apDigits
arPrefix
java.lang.String arPrefix
arDigits
byte arDigits
rfqPrefix
java.lang.String rfqPrefix
rfqDigits
byte rfqDigits
rtvPrefix
java.lang.String rtvPrefix
rtvDigits
byte rtvDigits
qtPrefix
java.lang.String qtPrefix
qtDigits
byte qtDigits
rmaPrefix
java.lang.String rmaPrefix
rmaDigits
byte rmaDigits
cmPrefix
java.lang.String cmPrefix
cmDigits
byte cmDigits
dmPrefix
java.lang.String dmPrefix
dmDigits
byte dmDigits
edcPrefix
java.lang.String edcPrefix
edcDigits
byte edcDigits
glPrefix
java.lang.String glPrefix
glDigits
byte glDigits
apPrepayPrefix
java.lang.String apPrepayPrefix
apPrepayDigits
byte apPrepayDigits
arPrepayPrefix
java.lang.String arPrepayPrefix
arPrepayDigits
byte arPrepayDigits
partNumberMinLength
byte partNumberMinLength
partNumberMaxLength
byte partNumberMaxLength
home
java.lang.String home
persistent field

sg
java.lang.String sg
persistent field

poweredBy
java.lang.String poweredBy
persistent field

lastInventory
java.util.Date lastInventory
persistent field

timeZone
java.lang.String timeZone
persistent field

billToId
java.lang.String billToId
persistent field

shipToId
java.lang.String shipToId
persistent field

returnAddressId
java.lang.String returnAddressId
companyId
java.lang.String companyId
pa
java.lang.String pa
persistent field

changeRule
int changeRule
customerRFQReceiverEmail
java.lang.String customerRFQReceiverEmail
csrReceiverEmail
java.lang.String csrReceiverEmail
reportBugEmail
java.lang.String reportBugEmail
lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

upcaseDescription
java.lang.String upcaseDescription
upcaseWorkInstructionSeq
java.lang.String upcaseWorkInstructionSeq
vgPrincipalUserId
java.lang.String vgPrincipalUserId
vgPrincipalUserName
java.lang.String vgPrincipalUserName
vgAddress
java.lang.String vgAddress
dataVersion
java.lang.String dataVersion
saleableForNewPart
boolean saleableForNewPart
Default Value

engineeringNewPartForNewPart
boolean engineeringNewPartForNewPart
shippingWeightUnit
java.lang.String shippingWeightUnit
makeBuyForNewPart
java.lang.String makeBuyForNewPart
setupInventoryForNewPart
boolean setupInventoryForNewPart
showOrgAndLevelForPart
boolean showOrgAndLevelForPart
addressIdDefaultQaStatus
java.lang.String addressIdDefaultQaStatus
passwordEncrypt
boolean passwordEncrypt
passwordLifetime
int passwordLifetime
passwordMinLength
int passwordMinLength
workTimePeriod
java.lang.String workTimePeriod
useWorkOrderCostControl
boolean useWorkOrderCostControl
workOrderCostControlBy
java.lang.String workOrderCostControlBy
workOrderCostStart
java.math.BigDecimal workOrderCostStart
workOrderOverPercent
java.math.BigDecimal workOrderOverPercent
wiSeqLength
int wiSeqLength
enableTracking
boolean enableTracking
useOrderChangeApproval
boolean useOrderChangeApproval
useBomApproval
boolean useBomApproval
receiveNeedIr
boolean receiveNeedIr
includePoTax
boolean includePoTax
defaultVendorTax
java.math.BigDecimal defaultVendorTax
needPassforIssuingWO
boolean needPassforIssuingWO
useBranchWarehouse
boolean useBranchWarehouse
initBranchWarehouse
boolean initBranchWarehouse
separateCostBetweenWarehouse
boolean separateCostBetweenWarehouse
useIncludeTaxCostforPO
boolean useIncludeTaxCostforPO
useEngGroupUser
boolean useEngGroupUser
partNumberGenerateType
java.lang.String partNumberGenerateType
partNumberSeqLength
int partNumberSeqLength
partBigCatagoryLength
int partBigCatagoryLength
partSmallCatagoryLength
int partSmallCatagoryLength
partSplitChar
java.lang.String partSplitChar
warningWhenTwoPartInOneLocation
boolean warningWhenTwoPartInOneLocation
deleteZeroLocation
boolean deleteZeroLocation
approveSubWO
boolean approveSubWO
refNAPO
boolean refNAPO
printBarCodeForOrder
boolean printBarCodeForOrder
makeGLWhenReceivingWO
boolean makeGLWhenReceivingWO
defaultWOVendorID
java.lang.String defaultWOVendorID
showTimeZone
boolean showTimeZone
initStep
java.lang.String initStep
allowEmptyGL
boolean allowEmptyGL
valuationStorage
boolean valuationStorage
exchangeRate
java.lang.String exchangeRate
decimalLength
int decimalLength
nonEnglishAllowed
boolean nonEnglishAllowed
partUnit
java.lang.String partUnit
toolUnit
java.lang.String toolUnit
paOffsetType
java.lang.String paOffsetType
remitAddressId
java.lang.String remitAddressId
swoPrefix
java.lang.String swoPrefix
swoDigits
byte swoDigits
swsPrefix
java.lang.String swsPrefix
swsDigits
byte swsDigits
swrPrefix
java.lang.String swrPrefix
swrDigits
byte swrDigits
unbilled
boolean unbilled
receivingPOZeroCost
boolean receivingPOZeroCost
mpnUsedOneTime
boolean mpnUsedOneTime
showNumberTailZero
boolean showNumberTailZero
needPickerforIssuingWO
boolean needPickerforIssuingWO
recoil
boolean recoil
allowNegativeCreditOrDebit
boolean allowNegativeCreditOrDebit
warehouseLocationSplitChar
java.lang.String warehouseLocationSplitChar
useOperationScrap
boolean useOperationScrap
oneGLForBatchPayment
boolean oneGLForBatchPayment
useEcStartWithYear
boolean useEcStartWithYear
usePriceWithTaxDefault
boolean usePriceWithTaxDefault
noticeReceiveGap
int noticeReceiveGap
ncCodeOnlyOneLetterOrTwoNumber
boolean ncCodeOnlyOneLetterOrTwoNumber
useUppercaseSystemUserName
boolean useUppercaseSystemUserName
useMultiQtyforApplying
boolean useMultiQtyforApplying
usePriceWithTaxAsListPriceInVCP
boolean usePriceWithTaxAsListPriceInVCP
Class bb.common.ContractPriceCustomerPK extends java.lang.Object implements Serializable

Serialized Fields

contractNumber
java.lang.String contractNumber
identifier field

id
java.lang.String id
identifier field

Class bb.common.ContractPriceCustomerVO extends VO implements Serializable

Serialized Fields

pk
ContractPriceCustomerPK pk
contractName
java.lang.String contractName
customerInfo
CustomerVendorAddressInfoVO customerInfo
Class bb.common.ContractPriceItemPK extends java.lang.Object implements Serializable

Serialized Fields

contractNumber
java.lang.String contractNumber
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
Class bb.common.ContractPriceItemVO extends VO implements Serializable

Serialized Fields

pk
ContractPriceItemPK pk
contractName
java.lang.String contractName
listPrice
java.math.BigDecimal listPrice
discount
java.math.BigDecimal discount
comments
java.lang.String comments
bb2ListPrice
java.math.BigDecimal bb2ListPrice
bb2AvgCost
java.math.BigDecimal bb2AvgCost
bb2StdCost
java.math.BigDecimal bb2StdCost
description
java.lang.String description
mfgPartNumber
java.lang.String mfgPartNumber
Class bb.common.ContractPriceVO extends VO implements Serializable

Serialized Fields

contractNumber
java.lang.String contractNumber
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
lastChangeTimes
int lastChangeTimes
origin
java.lang.String origin
status
java.lang.String status
contractName
java.lang.String contractName
description
java.lang.String description
currency
java.lang.String currency
startDate
java.util.Date startDate
expireDate
java.util.Date expireDate
createDate
java.util.Date createDate
Class bb.common.CorrectiveActionRequestVO extends VO implements Serializable

Serialized Fields

carNumber
java.lang.String carNumber
identifier field

dueDate
java.util.Date dueDate
persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

adate
java.util.Date adate
nullable persistent field

origin
java.lang.String origin
persistent field

dateEntered
java.util.Date dateEntered
persistent field

enteredBy
java.lang.String enteredBy
persistent field

status
java.lang.String status
persistent field

departmentId
java.lang.String departmentId
persistent field

departName
java.lang.String departName
persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

modelNumber
java.lang.String modelNumber
persistent field

revision
java.lang.String revision
persistent field

description
java.lang.String description
nullable persistent field

thirdParty
java.lang.String thirdParty
persistent field

refDoc1
java.lang.String refDoc1
persistent field

refDoc2
java.lang.String refDoc2
persistent field

conditionDescription
java.lang.String conditionDescription
nullable persistent field

conditionNotedBy
java.lang.String conditionNotedBy
persistent field

conditionAcknowledgedBy
java.lang.String conditionAcknowledgedBy
persistent field

proposedAction
java.lang.String proposedAction
nullable persistent field

proposedBy
java.lang.String proposedBy
persistent field

proposedActionDate
java.util.Date proposedActionDate
persistent field

approvedBy
java.lang.String approvedBy
persistent field

implementionDue
java.util.Date implementionDue
persistent field

closedOutBy
java.lang.String closedOutBy
persistent field

closedOutDate
java.util.Date closedOutDate
persistent field

closedOutComments
java.lang.String closedOutComments
nullable persistent field

closedOutPrivateNotes
java.lang.String closedOutPrivateNotes
nullable persistent field

version
java.lang.Integer version
nullable persistent field

partFrom
java.lang.String partFrom
responsibility
java.lang.String responsibility
Class bb.common.CPItemFromQuoteResult extends java.lang.Object implements Serializable

Serialized Fields

quoteItemNumber
java.lang.String quoteItemNumber
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
description
java.lang.String description
customerID
java.lang.String customerID
validThru
java.util.Date validThru
contractNumber
java.lang.String contractNumber
quoteCurrency
java.lang.String quoteCurrency
cpiCurrency
java.lang.String cpiCurrency
mfgPartNumbers
java.util.Collection<E> mfgPartNumbers
highlight
boolean highlight
exchange
java.math.BigDecimal exchange
quoteListPrice
java.math.BigDecimal quoteListPrice
quoteDiscount
java.math.BigDecimal quoteDiscount
cpiListPrice
java.math.BigDecimal cpiListPrice
cpiDiscount
java.math.BigDecimal cpiDiscount
Class bb.common.CRTVItemListResult extends java.lang.Object implements Serializable

Serialized Fields

crtvNumber
java.lang.String crtvNumber
crtvItemNumber
java.lang.String crtvItemNumber
partPk
PartPK partPk
itemDescription
java.lang.String itemDescription
crtvDate
java.util.Date crtvDate
deliveryDate
java.util.Date deliveryDate
orderedQty
java.math.BigDecimal orderedQty
costPerUnit
java.math.BigDecimal costPerUnit
discount
java.math.BigDecimal discount
customerId
java.lang.String customerId
invoiceNumber
java.lang.String invoiceNumber
salesOrderNumber
java.lang.String salesOrderNumber
status
java.lang.String status
salesman
java.lang.String salesman
onhandQty
java.math.BigDecimal onhandQty
onorderQty
java.math.BigDecimal onorderQty
onDemandQty
java.math.BigDecimal onDemandQty
partFrom
java.lang.String partFrom
debitAccount
java.lang.String debitAccount
companyUnitId
java.lang.String companyUnitId
Class bb.common.CRTVListResult extends java.lang.Object implements Serializable

Serialized Fields

crtvNumber
java.lang.String crtvNumber
crtvDate
java.util.Date crtvDate
changeOrder
java.lang.String changeOrder
customerId
java.lang.String customerId
invoiceNumber
java.lang.String invoiceNumber
project
java.lang.String project
privateNote
java.lang.String privateNote
comments
java.lang.String comments
status
java.lang.String status
requester
java.lang.String requester
salesOrderNumber
java.lang.String salesOrderNumber
salesman
java.lang.String salesman
Class bb.common.CSRAgent extends java.lang.Object implements Serializable

Serialized Fields

priority
java.lang.String priority
seriveType
java.lang.String seriveType
custID
java.lang.String custID
requestor
java.lang.String requestor
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
salesOrderNumber
java.lang.String salesOrderNumber
salesOrderItemNumber
java.lang.String salesOrderItemNumber
serial
java.lang.String serial
equipCondition
java.lang.String equipCondition
reqDescription
java.lang.String reqDescription
requireDate
java.util.Date requireDate
location
java.lang.String location
contact
java.lang.String contact
phone
java.lang.String phone
email
java.lang.String email
Class bb.common.CurrencyAgent extends VO implements Serializable

Serialized Fields

fiscalYearSettingsVO
FiscalYearSettingsVO fiscalYearSettingsVO
vo
CurrencyVO vo
Class bb.common.CurrencyExchangePK extends java.lang.Object implements Serializable

Serialized Fields

monthYear
java.lang.String monthYear
identifier field

currency
java.lang.String currency
identifier field

Class bb.common.CurrencyExchangeVO extends VO implements Serializable

Serialized Fields

pk
CurrencyExchangePK pk
exchange
java.math.BigDecimal exchange
auditExchange
java.math.BigDecimal auditExchange
orgAuditExchange
java.math.BigDecimal orgAuditExchange
startMonth
java.util.Date startMonth
endMonth
java.util.Date endMonth
Class bb.common.CurrencyVO extends VO implements Serializable

Serialized Fields

currency
java.lang.String currency
exchange
java.math.BigDecimal exchange
symbol
java.lang.String symbol
exchangeRate
java.util.Set<E> exchangeRate
Class bb.common.CurrentBalanceResult extends java.lang.Object implements Serializable

Serialized Fields

accountVo
AccountsChartVO accountVo
debitStartingBalance
java.math.BigDecimal debitStartingBalance
creditStartingBalance
java.math.BigDecimal creditStartingBalance
debitMonthTotal
java.math.BigDecimal debitMonthTotal
creditMonthTotal
java.math.BigDecimal creditMonthTotal
debitEndingBalance
java.math.BigDecimal debitEndingBalance
creditEndingBalance
java.math.BigDecimal creditEndingBalance
totalItems
int totalItems
Class bb.common.CustomAssetRecordPK extends java.lang.Object implements Serializable

Serialized Fields

ii
java.lang.Short ii
assetNumber
java.lang.String assetNumber
Class bb.common.CustomAssetRecordVO extends VO implements Serializable

Serialized Fields

pk
CustomAssetRecordPK pk
user
java.lang.String user
receiveDate
java.util.Date receiveDate
returnDate
java.util.Date returnDate
receiveSign
java.lang.String receiveSign
returnSign
java.lang.String returnSign
receiveDepartment
java.lang.String receiveDepartment
returnDepartment
java.lang.String returnDepartment
receiveComment
java.lang.String receiveComment
returnComment
java.lang.String returnComment
customReceiveDepartment
CustomDepartmentVO customReceiveDepartment
customReturnDepartment
CustomDepartmentVO customReturnDepartment
Class bb.common.CustomAssetVO extends VO implements Serializable

Serialized Fields

assetNumber
java.lang.String assetNumber
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
assetName
java.lang.String assetName
originalCost
java.math.BigDecimal originalCost
serialNumber
java.lang.String serialNumber
project
java.lang.String project
manufacture
java.lang.String manufacture
assetOrder
java.lang.String assetOrder
manufactureId
java.lang.String manufactureId
modelNumber
java.lang.String modelNumber
assetDate
java.util.Date assetDate
mfgDate
java.util.Date mfgDate
usingUnit
java.lang.String usingUnit
tnDate
java.util.Date tnDate
buyDate
java.util.Date buyDate
usingDate
java.util.Date usingDate
principal
java.lang.String principal
department
java.lang.String department
assetStatus
java.lang.String assetStatus
certificateStatus
java.lang.String certificateStatus
comments
java.lang.String comments
receiveSign
java.lang.String receiveSign
assetRecords
java.util.Set<E> assetRecords
Class bb.common.CustomCheckUpEmployeeVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
empId
java.lang.String empId
name
java.lang.String name
checkTime
java.util.Date checkTime
age
int age
stature
int stature
bloodPressure
java.lang.String bloodPressure
nudeSightLeft
java.math.BigDecimal nudeSightLeft
rectifySightLeft
java.math.BigDecimal rectifySightLeft
nudeSighRight
java.math.BigDecimal nudeSighRight
rectifySightRight
java.math.BigDecimal rectifySightRight
earNoseTear
java.lang.String earNoseTear
ecg
java.lang.String ecg
bUltrasonic
java.lang.String bUltrasonic
ris
java.lang.String ris
clinicaLab
java.lang.String clinicaLab
comment
java.lang.String comment
recorder
java.lang.String recorder
Class bb.common.CustomDepartmentVO extends VO implements Serializable

Serialized Fields

id
java.lang.String id
name
java.lang.String name
description
java.lang.String description
Class bb.common.CustomEmployeeTrainPK extends java.lang.Object implements Serializable

Serialized Fields

ii
java.lang.Short ii
id
java.lang.String id
Class bb.common.CustomEmployeeTrainVO extends VO implements Serializable

Serialized Fields

pk
CustomEmployeeTrainPK pk
title
java.lang.String title
trainDate
java.util.Date trainDate
place
java.lang.String place
speaker
java.lang.String speaker
result
java.lang.String result
certificateName
java.lang.String certificateName
certificationId
java.lang.String certificationId
expireDate
java.util.Date expireDate
recorder
java.lang.String recorder
Class bb.common.CustomEmployeeVO extends VO implements Serializable

Serialized Fields

id
java.lang.String id
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
unit
java.lang.String unit
department
java.lang.String department
name
java.lang.String name
gender
java.lang.String gender
cardId
java.lang.String cardId
birthDate
java.util.Date birthDate
nativePlace
java.lang.String nativePlace
polityVisage
java.lang.String polityVisage
education
java.lang.String education
degree
java.lang.String degree
specialty
java.lang.String specialty
graduateSchool
java.lang.String graduateSchool
graduateDate
java.util.Date graduateDate
enterSchool
java.util.Date enterSchool
englishAbility
java.lang.String englishAbility
specialTitle
java.lang.String specialTitle
specialWork
java.lang.String specialWork
workType
java.lang.String workType
workTypeAfter
java.lang.String workTypeAfter
jobId
java.lang.String jobId
workTime
java.util.Date workTime
toCompanyTime
java.util.Date toCompanyTime
toPositionTime
java.util.Date toPositionTime
originalPosition
java.lang.String originalPosition
position
java.lang.String position
currentPosition
java.lang.String currentPosition
positionLevel
java.lang.String positionLevel
currentPositionLevel
java.lang.String currentPositionLevel
source
java.lang.String source
transferDate
java.util.Date transferDate
comments
java.lang.String comments
workComments
java.lang.String workComments
trainComments
java.lang.String trainComments
customDepartment
CustomDepartmentVO customDepartment
employeeAge
int employeeAge
employeeAgeLevel
int employeeAgeLevel
employeeWorkAge
int employeeWorkAge
employeeWorkAgeLevel
int employeeWorkAgeLevel
employeeTrain
java.util.Set<E> employeeTrain
employeeWorkExperience
java.util.Set<E> employeeWorkExperience
Class bb.common.CustomEmployeeWorkExperienceVO extends VO implements Serializable

Serialized Fields

pk
CustomEmployeeTrainPK pk
fromDate
java.util.Date fromDate
jobTitle
java.lang.String jobTitle
companyName
java.lang.String companyName
authenticator
java.lang.String authenticator
Class bb.common.CustomerCLimitResult extends java.lang.Object implements Serializable

Serialized Fields

cHold
boolean cHold
cclimit
boolean cclimit
Class bb.common.CustomerFeedbackVO extends VO implements Serializable

Serialized Fields

feedbackNumber
java.lang.String feedbackNumber
identifier field

customerServiceIncidentNumber
java.lang.String customerServiceIncidentNumber
persistent field

customerId
java.lang.String customerId
persistent field

shipToId
java.lang.String shipToId
persistent field

email
java.lang.String email
persistent field

originalInvoiceNumber
java.lang.String originalInvoiceNumber
persistent field

originalSalesOrderNumber
java.lang.String originalSalesOrderNumber
persistent field

originalWorkOrderNumber
java.lang.String originalWorkOrderNumber
persistent field

purchaseOrderNumber
java.lang.String purchaseOrderNumber
persistent field

reportedBy
java.lang.String reportedBy
persistent field

invoiceDate
java.util.Date invoiceDate
persistent field

contactDate
java.util.Date contactDate
persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

status
java.lang.String status
persistent field

comments
java.lang.String comments
nullable persistent field

version
java.lang.Integer version
nullable persistent field

feedbackItems
java.util.Set<E> feedbackItems
customerAddressInfo
CustomerVendorAddressInfoVO customerAddressInfo
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
partDescription
java.lang.String partDescription
Class bb.common.CustomerPrepayStatementListResult extends java.lang.Object implements Serializable

Serialized Fields

pk
ArPrepayItemPK pk
dateRequired
java.util.Date dateRequired
salesOrder
java.lang.String salesOrder
customerPO
java.lang.String customerPO
totalDue
java.math.BigDecimal totalDue
amountPaid
java.math.BigDecimal amountPaid
balanceDue
java.math.BigDecimal balanceDue
Class bb.common.CustomerReturnToVendorItemPK extends java.lang.Object implements Serializable

Serialized Fields

crtvNumber
java.lang.String crtvNumber
crtvItemNumber
java.lang.String crtvItemNumber
Class bb.common.CustomerReturnToVendorItemVO extends VO implements Serializable

Serialized Fields

pk
CustomerReturnToVendorItemPK pk
identifier field

apSub
java.math.BigDecimal apSub
persistent field

apDiscount
java.math.BigDecimal apDiscount
persistent field

extendPrice
java.math.BigDecimal extendPrice
persistent field

apReceivd
java.math.BigDecimal apReceivd
persistent field

apOpen
java.math.BigDecimal apOpen
persistent field

apTax
java.math.BigDecimal apTax
persistent field

apTotal
java.math.BigDecimal apTotal
persistent field

refDoc1
java.lang.String refDoc1
persistent field

refDoc2
java.lang.String refDoc2
persistent field

changeOrder
java.lang.String changeOrder
persistent field

qr
java.lang.String qr
persistent field

status
java.lang.String status
persistent field

accepted
java.util.Date accepted
nullable persistent field

acceptedBy
java.lang.String acceptedBy
persistent field

delivery
java.util.Date delivery
persistent field

delay
int delay
persistent field

priority
java.lang.String priority
persistent field

original
java.util.Date original
persistent field

actual
java.util.Date actual
persistent field

locate
java.lang.String locate
persistent field

shipvia
java.lang.String shipvia
persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
persistent field

modelNumber
java.lang.String modelNumber
persistent field

revision
java.lang.String revision
persistent field

dwg
java.lang.String dwg
persistent field

quantity
java.math.BigDecimal quantity
persistent field

ship
java.math.BigDecimal ship
persistent field

receivedQuantity
java.math.BigDecimal receivedQuantity
persistent field

costPerUnit
java.math.BigDecimal costPerUnit
persistent field

unit
java.lang.String unit
persistent field

discount
java.math.BigDecimal discount
persistent field

taxRate
java.math.BigDecimal taxRate
persistent field

salesCost
java.math.BigDecimal salesCost
persistent field

currentCost
java.math.BigDecimal currentCost
persistent field

salesStdCost
java.math.BigDecimal salesStdCost
currentStdCost
java.math.BigDecimal currentStdCost
description
java.lang.String description
persistent field

changeMfg
java.lang.String changeMfg
persistent field

mfg
java.lang.String mfg
persistent field

mpn
java.lang.String mpn
persistent field

crtvItemComments
java.lang.String crtvItemComments
nullable persistent field

crtvItemPrivateNotes
java.lang.String crtvItemPrivateNotes
nullable persistent field

returnMaterialAuthorizationItemManufacturer
java.util.Set<E> returnMaterialAuthorizationItemManufacturer
salesUnit
java.lang.String salesUnit
salesQty
java.math.BigDecimal salesQty
salesPrice
java.math.BigDecimal salesPrice
Class bb.common.CustomerReturnToVendorVO extends VO implements Serializable

Serialized Fields

crtvNumber
java.lang.String crtvNumber
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
adate
java.util.Date adate
origin
java.lang.String origin
apNetSet
java.lang.String apNetSet
apTaxSet
java.lang.String apTaxSet
subTotal
java.math.BigDecimal subTotal
totalDiscount
java.math.BigDecimal totalDiscount
apSub
java.math.BigDecimal apSub
apReceived
java.math.BigDecimal apReceived
apOpen
java.math.BigDecimal apOpen
totalTax
java.math.BigDecimal totalTax
totalFreight
java.math.BigDecimal totalFreight
grantTotal
java.math.BigDecimal grantTotal
apPaidReceived
java.math.BigDecimal apPaidReceived
apPaidGl
java.math.BigDecimal apPaidGl
apGl1Recorded
java.math.BigDecimal apGl1Recorded
apGl2Paid
java.math.BigDecimal apGl2Paid
changeOrder
java.lang.String changeOrder
coComments
java.lang.String coComments
customerId
java.lang.String customerId
billToId
java.lang.String billToId
contact
java.lang.String contact
salesOrderNumber
java.lang.String salesOrderNumber
status
java.lang.String status
approvedTime
java.util.Date approvedTime
approvedBy
java.lang.String approvedBy
delivery
java.util.Date delivery
delay
byte delay
priority
java.lang.String priority
original
java.util.Date original
actual
java.util.Date actual
shipToId
java.lang.String shipToId
shipVia
java.lang.String shipVia
carrier
java.lang.String carrier
carrierAcct
java.lang.String carrierAcct
incoterm
java.lang.String incoterm
incotermPlacePort
java.lang.String incotermPlacePort
locate
java.lang.String locate
language
java.lang.String language
currency
java.lang.String currency
exchange
java.math.BigDecimal exchange
terms
java.lang.String terms
crtvDate
java.util.Date crtvDate
salesman
java.lang.String salesman
salesCodeId
java.lang.String salesCodeId
requester
java.lang.String requester
projectName
java.lang.String projectName
relatedDoc
java.lang.String relatedDoc
debitAccount
java.lang.String debitAccount
bp
java.lang.String bp
comments
java.lang.String comments
privateNotes
java.lang.String privateNotes
companyUnitId
java.lang.String companyUnitId
version
java.lang.Integer version
customerAddressInfo
CustomerVendorAddressInfoVO customerAddressInfo
billToAddressInfo
CustomerVendorAddressInfoVO billToAddressInfo
shipToAddressInfo
CustomerVendorAddressInfoVO shipToAddressInfo
crtvItem
java.util.Set<E> crtvItem
invoiceNumber
java.lang.String invoiceNumber
rmaNumber
java.lang.String rmaNumber
Class bb.common.CustomerServiceIncidentItemListResult extends java.lang.Object implements Serializable

Serialized Fields

csiNumber
java.lang.String csiNumber
description
java.lang.String description
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
partDescription
java.lang.String partDescription
openDate
java.util.Date openDate
dueDate
java.util.Date dueDate
closedDate
java.util.Date closedDate
priority
java.lang.String priority
status
java.lang.String status
customerId
java.lang.String customerId
originalInvoice
java.lang.String originalInvoice
originalShipperNumber
java.lang.String originalShipperNumber
originalWorkOrderNumber
java.lang.String originalWorkOrderNumber
originalSalesOrderNumber
java.lang.String originalSalesOrderNumber
reportBy
java.lang.String reportBy
Class bb.common.CustomerServiceIncidentItemVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
identifier field

incidentNumber
java.lang.String incidentNumber
persistent field

emailSent
java.util.Date emailSent
nullable persistent field

emailFrom
java.lang.String emailFrom
persistent field

emailTo
java.lang.String emailTo
persistent field

description
java.lang.String description
persistent field

extension
java.lang.String extension
persistent field

question
java.lang.String question
persistent field

analysis
java.lang.String analysis
persistent field

results
java.lang.String results
persistent field

status
java.lang.String status
persistent. field

docName
java.lang.String docName
persistent field

docLength
long docLength
persistent field

Class bb.common.CustomerServiceIncidentListResult extends java.lang.Object implements Serializable

Serialized Fields

csiNumber
java.lang.String csiNumber
description
java.lang.String description
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
partDescription
java.lang.String partDescription
openDate
java.util.Date openDate
dueDate
java.util.Date dueDate
priority
java.lang.String priority
status
java.lang.String status
customerId
java.lang.String customerId
Class bb.common.CustomerServiceIncidentVO extends VO implements Serializable

Serialized Fields

incidentNumber
java.lang.String incidentNumber
identifier field

customerId
java.lang.String customerId
persistent field

refDoc1
java.lang.String refDoc1
persistent field

refDoc2
java.lang.String refDoc2
persistent field

location
java.lang.String location
persistent field

reportBy
java.lang.String reportBy
persistent field

incidentType
java.lang.String incidentType
persistent field

openDate
java.util.Date openDate
persistent field

dueDate
java.util.Date dueDate
persistent field

closedDate
java.util.Date closedDate
persistent field

product
java.lang.String product
persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
persistent field

revision
java.lang.String revision
persistent field

originalInvoice
java.lang.String originalInvoice
persistent field

originalShipperNumber
java.lang.String originalShipperNumber
persistent field

originalWorkOrderNumber
java.lang.String originalWorkOrderNumber
persistent field

originalSalesOrderNumber
java.lang.String originalSalesOrderNumber
persistent field

serialNumber
java.lang.String serialNumber
persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

customerEmail
java.lang.String customerEmail
persistent field

csEmail
java.lang.String csEmail
persistent field

status
java.lang.String status
persistent field

priority
java.lang.String priority
persistent field

description
java.lang.String description
persistent field

detailDescription
java.lang.String detailDescription
nullable persistent field

stepsToReproduce
java.lang.String stepsToReproduce
nullable persistent field

version
java.lang.Integer version
nullable persistent field

customerAddressInfo
CustomerVendorAddressInfoVO customerAddressInfo
nullable persistent field

incidentItems
java.util.Set<E> incidentItems
persistent field

Class bb.common.CustomerStatementListResult extends java.lang.Object implements Serializable

Serialized Fields

invoiceNumber
java.lang.String invoiceNumber
dateInvoiced
java.util.Date dateInvoiced
date
java.util.Date date
customerPo
java.lang.String customerPo
totalDue
java.math.BigDecimal totalDue
amountPaid
java.math.BigDecimal amountPaid
balanceDue
java.math.BigDecimal balanceDue
salesOrder
java.lang.String salesOrder
Class bb.common.CustomerStatementResult extends java.lang.Object implements Serializable

Serialized Fields

customerId
java.lang.String customerId
customerName
java.lang.String customerName
balanceForward
java.math.BigDecimal balanceForward
transactionAmount
java.math.BigDecimal transactionAmount
serviceCharge
java.math.BigDecimal serviceCharge
paymentAmount
java.math.BigDecimal paymentAmount
balanceDue
java.math.BigDecimal balanceDue
paymentInvoices
java.util.List<E> paymentInvoices
transactionInvoices
java.util.List<E> transactionInvoices
arAging
java.util.Collection<E> arAging
addrInfo
CustomerVendorAddressInfoVO addrInfo
currency
java.lang.String currency
Class bb.common.CustomerStatementTotalResult extends java.lang.Object implements Serializable

Serialized Fields

customerId
java.lang.String customerId
customerName
java.lang.String customerName
currency
java.lang.String currency
totalBalance
java.math.BigDecimal totalBalance
current
java.math.BigDecimal current
due1To30Total
java.math.BigDecimal due1To30Total
due31To60Total
java.math.BigDecimal due31To60Total
due61To90Total
java.math.BigDecimal due61To90Total
due91Total
java.math.BigDecimal due91Total
terms
java.lang.String terms
avgDaysToPay
int avgDaysToPay
asOf
java.util.Date asOf
billTo
java.lang.String billTo
customerHold
boolean customerHold
customerCreditLimit
java.math.BigDecimal customerCreditLimit
Class bb.common.CustomerVendorAddressInfoVO extends VO implements Serializable

Serialized Fields

id
java.lang.String id
remitId
java.lang.String remitId
lastUser
java.lang.String lastUser
persistent field

origin
java.lang.String origin
lastChangeTimes
int lastChangeTimes
persistent field

name
java.lang.String name
persistent field

address
java.lang.String address
persistent field

address2
java.lang.String address2
persistent field

city
java.lang.String city
persistent field

state
java.lang.String state
persistent field

zip
java.lang.String zip
persistent field

country
java.lang.String country
persistent field

language
java.lang.String language
persistent field

weightUnit
java.lang.String weightUnit
persistent field

currency
java.lang.String currency
persistent field

countryCode
java.lang.String countryCode
persistent field

phone
java.lang.String phone
persistent field

fax
java.lang.String fax
persistent field

phone2
java.lang.String phone2
persistent field

email
java.lang.String email
persistent field

taxId
java.lang.String taxId
persistent field

comments
java.lang.String comments
persistent field

customerShippingDays
byte customerShippingDays
persistent field

customerFlag
java.lang.String customerFlag
persistent field

vendorFlag
java.lang.String vendorFlag
persistent field

vendorShippingDays
byte vendorShippingDays
vendorCategory
java.lang.String vendorCategory
criticalLevel
java.lang.String criticalLevel
qualityStatus
java.lang.String qualityStatus
region
java.lang.String region
salesCodeId
java.lang.String salesCodeId
lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

createDate
java.util.Date createDate
deleted
boolean deleted
type
java.lang.String type
customerHold
boolean customerHold
dutyFree
boolean dutyFree
validDate
java.util.Date validDate
salesTaxNumber
java.lang.String salesTaxNumber
shipTo
java.lang.String shipTo
billTo
java.lang.String billTo
printInvoice
boolean printInvoice
parent
java.lang.String parent
taxType
java.lang.String taxType
vendorDepositBank
java.lang.String vendorDepositBank
departmentDepositBank
java.lang.String departmentDepositBank
vendorId
java.lang.String vendorId
departmentAccount
java.lang.String departmentAccount
taxPayerIDCode
java.lang.String taxPayerIDCode
useBackflush
boolean useBackflush
defaultAccount
java.lang.String defaultAccount
byInvoice
boolean byInvoice
Class bb.common.CustomerVendorAddressTotalInfo extends java.lang.Object implements Serializable

Serialized Fields

currency
java.lang.String currency
aRCurrentBalance
java.math.BigDecimal aRCurrentBalance
aRPaseDueBalance
java.math.BigDecimal aRPaseDueBalance
aRSalesOrder12Months
java.math.BigDecimal aRSalesOrder12Months
aRPaymentDue
java.math.BigDecimal aRPaymentDue
aRPaymentDueDays
int aRPaymentDueDays
aPCurrentBalance
java.math.BigDecimal aPCurrentBalance
aPPaseDueBalance
java.math.BigDecimal aPPaseDueBalance
aPPurchaseOrder12Months
java.math.BigDecimal aPPurchaseOrder12Months
aPPaymentDue
java.math.BigDecimal aPPaymentDue
aPPaymentDueDays
int aPPaymentDueDays
Class bb.common.CustomerVendorAddressVO extends VO implements Serializable

Serialized Fields

id
java.lang.String id
identifier field

remitId
java.lang.String remitId
persistent field

lastUser
java.lang.String lastUser
persistent field

version
java.lang.Integer version
persistent field

createDate
java.util.Date createDate
nullable persistent field

origin
java.lang.String origin
persistent field

name
java.lang.String name
persistent field

address
java.lang.String address
persistent field

address2
java.lang.String address2
persistent field

city
java.lang.String city
persistent field

state
java.lang.String state
persistent field

zip
java.lang.String zip
persistent field

country
java.lang.String country
persistent field

language
java.lang.String language
persistent field

weightUnit
java.lang.String weightUnit
persistent field

currency
java.lang.String currency
persistent field

countryCode
java.lang.String countryCode
persistent field

phone
java.lang.String phone
persistent field

fax
java.lang.String fax
persistent field

phone2
java.lang.String phone2
persistent field

email
java.lang.String email
persistent field

webSite
java.lang.String webSite
persistent field

taxId
java.lang.String taxId
persistent field

comments
java.lang.String comments
persistent field

salesman
java.lang.String salesman
persistent field

territory
java.lang.String territory
persistent field

region
java.lang.String region
persistent field

customerShippingDays
byte customerShippingDays
persistent field

customerFlag
java.lang.String customerFlag
persistent field

specialCustomerCode
java.lang.String specialCustomerCode
customerAccount
java.lang.String customerAccount
persistent field

customerShipVia
java.lang.String customerShipVia
persistent field

customerCarrier
java.lang.String customerCarrier
persistent field

customerCarrierAccount
java.lang.String customerCarrierAccount
persistent field

customerIncoterm
java.lang.String customerIncoterm
persistent field

customerIncotermPlacePort
java.lang.String customerIncotermPlacePort
persistent field

customerTerms
java.lang.String customerTerms
persistent field

customerDiscount
java.math.BigDecimal customerDiscount
persistent field

customerTaxCode
java.lang.String customerTaxCode
persistent field

customerTaxRate
java.math.BigDecimal customerTaxRate
persistent field

CustomerCreditLimit
java.math.BigDecimal CustomerCreditLimit
persistent field

customerComments
java.lang.String customerComments
persistent field

vendorFlag
java.lang.String vendorFlag
persistent field

vendorShippingDays
byte vendorShippingDays
specialVendorCode
java.lang.String specialVendorCode
vendorCategory
java.lang.String vendorCategory
criticalLevel
java.lang.String criticalLevel
qualityStatus
java.lang.String qualityStatus
vendorId
java.lang.String vendorId
persistent field

vendorShipVia
java.lang.String vendorShipVia
persistent field

vendorCarrier
java.lang.String vendorCarrier
persistent field

vendorCarrierAccount
java.lang.String vendorCarrierAccount
persistent field

vendorIncoterm
java.lang.String vendorIncoterm
persistent field

vendorIncotermPlacePort
java.lang.String vendorIncotermPlacePort
persistent field

vendorTerms
java.lang.String vendorTerms
persistent field

vendorDiscount
java.math.BigDecimal vendorDiscount
persistent field

vendorTaxRate
java.math.BigDecimal vendorTaxRate
persistent field

vendorCreditLimit
java.math.BigDecimal vendorCreditLimit
persistent field

vendorComments
java.lang.String vendorComments
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

useCTaxRate
boolean useCTaxRate
nullable persistent field

useVTaxRate
boolean useVTaxRate
nullable persistent field

customerHold
boolean customerHold
deleted
boolean deleted
password
java.lang.String password
contacts
java.util.Set<E> contacts
persistent field

multiDescription
java.util.Set<E> multiDescription
persistent field

addressQualityDocuments
java.util.Set<E> addressQualityDocuments
type
java.lang.String type
vendorDepositBank
java.lang.String vendorDepositBank
customerDepositBank
java.lang.String customerDepositBank
dutyFree
boolean dutyFree
validDate
java.util.Date validDate
salesTaxNumber
java.lang.String salesTaxNumber
shipTo
java.lang.String shipTo
billTo
java.lang.String billTo
printInvoice
boolean printInvoice
parent
java.lang.String parent
taxType
java.lang.String taxType
departmentDepositBank
java.lang.String departmentDepositBank
departmentAccount
java.lang.String departmentAccount
taxPayerIDCode
java.lang.String taxPayerIDCode
useBackflush
boolean useBackflush
defaultAccount
java.lang.String defaultAccount
byInvoice
boolean byInvoice
Class bb.common.CustomerVendorContactPK extends java.lang.Object implements Serializable

Serialized Fields

id
java.lang.String id
identifier field

item
java.lang.Short item
identifier field

Class bb.common.CustomerVendorContactVO extends VO implements Serializable

Serialized Fields

pk
CustomerVendorContactPK pk
name
java.lang.String name
phone
java.lang.String phone
mobile
java.lang.String mobile
fax
java.lang.String fax
email
java.lang.String email
comments
java.lang.String comments
title
java.lang.String title
soMail
boolean soMail
poMail
boolean poMail
accountingMail
boolean accountingMail
rfqMail
boolean rfqMail
qtMail
boolean qtMail
type
java.lang.String type
Class bb.common.CustomerVendorDescriptionPK extends java.lang.Object implements Serializable

Serialized Fields

id
java.lang.String id
identifier field

language
java.lang.String language
identifier field

Class bb.common.CustomerVendorDescriptionVO extends VO implements Serializable

Serialized Fields

pk
CustomerVendorDescriptionPK pk
status
java.lang.String status
name
java.lang.String name
addressOne
java.lang.String addressOne
addressTwo
java.lang.String addressTwo
city
java.lang.String city
state
java.lang.String state
zip
java.lang.String zip
country
java.lang.String country
Class bb.common.CustomerVendorTypeVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Integer ii
customerType
java.lang.String customerType
vendorType
java.lang.String vendorType
comments
java.lang.String comments
Class bb.common.CustomGoodsBreedVO extends VO implements Serializable

Serialized Fields

id
java.lang.String id
name
java.lang.String name
active
boolean active
unit
java.lang.String unit
comments
java.lang.String comments
Class bb.common.CustomGoodsRecordVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
employeeId
java.lang.String employeeId
goodsId
java.lang.String goodsId
putDate
java.util.Date putDate
Class bb.common.CustomJobCategoryGoodsPK extends java.lang.Object implements Serializable

Serialized Fields

jobId
java.lang.String jobId
goodsId
java.lang.String goodsId
Class bb.common.CustomJobCategoryGoodsVO extends VO implements Serializable

Serialized Fields

pk
CustomJobCategoryGoodsPK pk
frequency
int frequency
Class bb.common.CustomJobCategoryVO extends VO implements Serializable

Serialized Fields

id
java.lang.String id
name
java.lang.String name
comments
java.lang.String comments
customJobCategoryGoods
java.util.Set<E> customJobCategoryGoods
Class bb.common.CustomSearchVO extends VO implements Serializable

Serialized Fields

id
java.lang.String id
name
java.lang.String name
module
java.lang.String module
xml
java.lang.String xml
Class bb.common.CustomTranslationVO extends VO implements Serializable

Serialized Fields

id
java.lang.String id
originalTranslation
java.lang.String originalTranslation
customTranslation
java.lang.String customTranslation
Class bb.common.CV2CVAgent extends java.lang.Object implements Serializable

Serialized Fields

oldId
java.lang.String oldId
id
java.lang.String id
name
java.lang.String name
type
java.lang.String type
Class bb.common.CycleCountAgent extends java.lang.Object implements Serializable

Serialized Fields

pk
CycleCountPK pk
physicalCount
java.math.BigDecimal physicalCount
location
java.lang.String location
Class bb.common.CycleCountListResult extends java.lang.Object implements Serializable

Serialized Fields

pk
CycleCountPK pk
partClass
java.lang.String partClass
startDate
java.util.Date startDate
partNumber
java.lang.String partNumber
partType
java.lang.String partType
unit
java.lang.String unit
description
java.lang.String description
location
java.lang.String location
newLocation
java.lang.String newLocation
systemOnhand
java.math.BigDecimal systemOnhand
newOnhand
java.math.BigDecimal newOnhand
diffcount
java.math.BigDecimal diffcount
committed
boolean committed
avgCost
java.math.BigDecimal avgCost
countedBy
java.lang.String countedBy
countedDate
java.util.Date countedDate
Class bb.common.CycleCountListTotalResult extends java.lang.Object implements Serializable

Serialized Fields

totSystemOnhand
java.math.BigDecimal totSystemOnhand
totNewOnhand
java.math.BigDecimal totNewOnhand
totSystemCost
java.math.BigDecimal totSystemCost
totNewCost
java.math.BigDecimal totNewCost
Class bb.common.CycleCountPK extends java.lang.Object implements Serializable

Serialized Fields

workSheetNumber
java.lang.Integer workSheetNumber
identifier field

pageNumber
java.lang.Integer pageNumber
identifier field

rowNumber
java.lang.Integer rowNumber
identifier field

Class bb.common.CycleCountStatusVO extends VO implements Serializable

Serialized Fields

workSheetNumber
java.lang.Integer workSheetNumber
partClass
java.lang.String partClass
totalPages
int totalPages
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
createDate
java.util.Date createDate
creator
java.lang.String creator
description
java.lang.String description
status
java.lang.String status
Class bb.common.CycleCountVO extends VO implements Serializable

Serialized Fields

pk
CycleCountPK pk
identifier field

partClass
java.lang.String partClass
partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

physicalInventoryDate
java.util.Date physicalInventoryDate
nullable persistent field

mn
java.lang.String mn
persistent field

active
java.lang.String active
persistent field

locate
java.lang.String locate
persistent field

newLocation
java.lang.String newLocation
onhand
java.math.BigDecimal onhand
persistent field

newOnhand
java.math.BigDecimal newOnhand
persistent field

diffCount
java.math.BigDecimal diffCount
committed
boolean committed
countedBy
java.lang.String countedBy
nullable persistent field

countedDate
java.util.Date countedDate
nullable persistent field

ii
java.lang.Long ii
Class bb.common.DataFilterVO extends VO implements Serializable

Serialized Fields

id
java.lang.String id
tableName
java.lang.String tableName
poClass
java.lang.String poClass
filterType
java.lang.String filterType
filterCondition
java.lang.String filterCondition
filterSQL
java.lang.String filterSQL
filterPO
java.lang.String filterPO
warning
java.lang.String warning
inUse
boolean inUse
validate
java.lang.String validate
Class bb.common.DBAccessException extends BB2ServerException implements Serializable

Class bb.common.DebitsCreditsResult extends java.lang.Object implements Serializable

Serialized Fields

orderNumber
java.lang.String orderNumber
currency
java.lang.String currency
debits
java.util.List<E> debits
credits
java.util.List<E> credits
Class bb.common.DepartmentLocationForBackflushVO extends VO implements Serializable

Serialized Fields

id
java.lang.String id
location
java.lang.String location
Class bb.common.DepositSummaryResult extends java.lang.Object implements Serializable

Serialized Fields

glNumber
java.lang.String glNumber
checkNumber
java.lang.String checkNumber
pmtMethod
java.lang.String pmtMethod
customerId
java.lang.String customerId
customerName
java.lang.String customerName
memo
java.lang.String memo
amount
java.math.BigDecimal amount
companyUnitId
java.lang.String companyUnitId
accountNumber
java.lang.String accountNumber
accountDescription
java.lang.String accountDescription
description
java.lang.String description
actualAmount
java.math.BigDecimal actualAmount
Class bb.common.DepreciateMonthlyReport extends java.lang.Object implements Serializable

Serialized Fields

assetType
java.lang.String assetType
persistent field

usingStatus
java.lang.String usingStatus
persistent field

depreciateStatus
java.lang.String depreciateStatus
persistent field

departmentID
java.lang.String departmentID
persistent field

currency
java.lang.String currency
persistent field

totLastMDepreciate
java.math.BigDecimal totLastMDepreciate
persistent field

totCurrentMDepreciate
java.math.BigDecimal totCurrentMDepreciate
totVarDepreciate
java.math.BigDecimal totVarDepreciate
totVarCost
java.math.BigDecimal totVarCost
Class bb.common.DesignControlDocumentVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
identifier field

designControlNumber
java.lang.String designControlNumber
persistent field

sequence
java.lang.String sequence
persistent field

description
java.lang.String description
nullable persistent field

dt
java.lang.String dt
nullable persistent field

documentDate
java.util.Date documentDate
nullable persistent field

comments
java.lang.String comments
nullable persistent field

lastChangeUser
java.lang.String lastChangeUser
nullable persistent field

extension
java.lang.String extension
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

docLength
long docLength
docName
java.lang.String docName
Class bb.common.DesignControlInfoVO extends VO implements Serializable

Serialized Fields

designControlNumber
java.lang.String designControlNumber
identifier field

status
java.lang.String status
persistent field

date
java.util.Date date
nullable persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

dd
java.lang.String dd
persistent field

openDate
java.util.Date openDate
nullable persistent field

dueDate
java.util.Date dueDate
nullable persistent field

closeDate
java.util.Date closeDate
nullable persistent field

projectClass
java.lang.String projectClass
nullable persistent field

projectEngineer
java.lang.String projectEngineer
persistent field

projectTeam
java.lang.String projectTeam
nullable persistent field

department
java.lang.String department
nullable persistent field

ec
java.lang.String ec
nullable persistent field

workOrderNumber
java.lang.String workOrderNumber
nullable persistent field

salesOrderNumber
java.lang.String salesOrderNumber
nullable persistent field

projectDescription
java.lang.String projectDescription
nullable persistent field

designInputDescription
java.lang.String designInputDescription
nullable persistent field

designOutputDescription
java.lang.String designOutputDescription
nullable persistent field

designReviewDescription
java.lang.String designReviewDescription
nullable persistent field

designValidationDescription
java.lang.String designValidationDescription
nullable persistent field

designVerificationDescription
java.lang.String designVerificationDescription
nullable persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

origin
java.lang.String origin
persistent field

lastChangeTimes
int lastChangeTimes
nullable persistent field

Class bb.common.DesignControlListResult extends java.lang.Object implements Serializable

Serialized Fields

partPk
PartPK partPk
dcNumber
java.lang.String dcNumber
projectDescription
java.lang.String projectDescription
partDescription
java.lang.String partDescription
openDate
java.util.Date openDate
dueDate
java.util.Date dueDate
projectEngineer
java.lang.String projectEngineer
status
java.lang.String status
Class bb.common.DesignControlVO extends VO implements Serializable

Serialized Fields

designControlNumber
java.lang.String designControlNumber
identifier field

status
java.lang.String status
persistent field

date
java.util.Date date
nullable persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

dd
java.lang.String dd
persistent field

openDate
java.util.Date openDate
nullable persistent field

dueDate
java.util.Date dueDate
nullable persistent field

closeDate
java.util.Date closeDate
nullable persistent field

projectClass
java.lang.String projectClass
nullable persistent field

projectEngineer
java.lang.String projectEngineer
persistent field

projectTeam
java.lang.String projectTeam
nullable persistent field

department
java.lang.String department
nullable persistent field

ec
java.lang.String ec
nullable persistent field

workOrderNumber
java.lang.String workOrderNumber
nullable persistent field

salesOrderNumber
java.lang.String salesOrderNumber
nullable persistent field

projectDescription
java.lang.String projectDescription
nullable persistent field

designInputDescription
java.lang.String designInputDescription
nullable persistent field

designOutputDescription
java.lang.String designOutputDescription
nullable persistent field

designReviewDescription
java.lang.String designReviewDescription
nullable persistent field

designValidationDescription
java.lang.String designValidationDescription
nullable persistent field

designVerificationDescription
java.lang.String designVerificationDescription
nullable persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

origin
java.lang.String origin
persistent field

version
java.lang.Integer version
nullable persistent field

edcDocuments
java.util.Set<E> edcDocuments
persistent field

Class bb.common.DisassembleWorkOrderApprovalVO extends VO implements Serializable

Serialized Fields

employeeId
java.lang.String employeeId
identifier field

userName
java.lang.String userName
persistent field

approvalLimit
java.math.BigDecimal approvalLimit
persistent field

currency
java.lang.String currency
persistent field

canApproveOwnWorkOrder
java.lang.String canApproveOwnWorkOrder
persistent field

Class bb.common.DisassembleWorkOrderDocumentVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
identifier field

dwoNumber
java.lang.String dwoNumber
persistent field

docDescription
java.lang.String docDescription
persistent field

documentDate
java.util.Date documentDate
nullable persistent field

comments
java.lang.String comments
nullable persistent field

lastChangeUser
java.lang.String lastChangeUser
nullable persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

extension
java.lang.String extension
persistent field

docFileName
java.lang.String docFileName
persistent field

docLength
long docLength
persistent field

Class bb.common.DisassembleWorkOrderIssueVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
disassembleWorkOrderNumber
java.lang.String disassembleWorkOrderNumber
disassembleWorkOrderItemNumber
java.lang.String disassembleWorkOrderItemNumber
orderNumber
java.lang.Long orderNumber
vendorID
java.lang.String vendorID
operator
java.lang.String operator
picker
java.lang.String picker
lastChangeUser
java.lang.String lastChangeUser
LastChangeDate
java.util.Date LastChangeDate
refDoc2
java.lang.String refDoc2
dateMade
java.util.Date dateMade
qtyShip
java.math.BigDecimal qtyShip
condition
java.lang.String condition
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
modelNumber
java.lang.String modelNumber
revision
java.lang.String revision
description
java.lang.String description
cost
java.math.BigDecimal cost
stdCost
java.math.BigDecimal stdCost
unit
java.lang.String unit
serial
java.lang.String serial
lot
java.lang.String lot
transactionNumber
java.lang.String transactionNumber
dwoisCost
java.math.BigDecimal dwoisCost
persistent field

dwoisStdCost
java.math.BigDecimal dwoisStdCost
companyUnitId
java.lang.String companyUnitId
persistent field

locations
java.util.Map<K,V> locations
trackings
java.util.Map<K,V> trackings
Class bb.common.DisassembleWorkOrderIssuingItemResult extends java.lang.Object implements Serializable

Serialized Fields

orderNumber
java.lang.String orderNumber
itemNumber
java.lang.String itemNumber
partPk
PartPK partPk
partFrom
java.lang.String partFrom
revision
java.lang.String revision
drawing
java.lang.String drawing
description
java.lang.String description
traceable
boolean traceable
comments
java.lang.String comments
privateNotes
java.lang.String privateNotes
refDoc1
java.lang.String refDoc1
refDoc2
java.lang.String refDoc2
mfg
java.lang.String mfg
mpn
java.lang.String mpn
qCode
java.lang.String qCode
rCode
java.lang.String rCode
status
java.lang.String status
quantity
java.math.BigDecimal quantity
quantityIssued
java.math.BigDecimal quantityIssued
minIssued
java.math.BigDecimal minIssued
maxIssued
java.math.BigDecimal maxIssued
unit
java.lang.String unit
totalOnhand
java.math.BigDecimal totalOnhand
totalOnDemand
java.math.BigDecimal totalOnDemand
partLocations
java.util.Set<E> partLocations
partTracking
java.util.Set<E> partTracking
issuedToOrderItems
java.util.Set<E> issuedToOrderItems
poUnit
java.lang.String poUnit
poUnitQty
java.math.BigDecimal poUnitQty
shipDate
java.util.Date shipDate
qtyCheck
java.math.BigDecimal qtyCheck
costPerUnit
java.math.BigDecimal costPerUnit
avgCost
java.math.BigDecimal avgCost
irTotalRefQty
java.math.BigDecimal irTotalRefQty
partManufacturers
java.util.Set<E> partManufacturers
Class bb.common.DisassembleWorkOrderIssuingResult extends java.lang.Object implements Serializable

Serialized Fields

orderNumber
java.lang.String orderNumber
changeOrder
java.lang.String changeOrder
issueDate
java.util.Date issueDate
vendorId
java.lang.String vendorId
vendorName
java.lang.String vendorName
companyUnitId
java.lang.String companyUnitId
debitAccount
java.lang.String debitAccount
relatedDoc
java.lang.String relatedDoc
userName
java.lang.String userName
project
java.lang.String project
freight
java.math.BigDecimal freight
hold
boolean hold
receiver
java.lang.String receiver
status
java.lang.String status
disassembleIssuingItems
java.util.Set<E> disassembleIssuingItems
Class bb.common.DisassembleWorkOrderItemListResult extends java.lang.Object implements Serializable

Serialized Fields

dwoItemPk
DisassembleWorkOrderItemPK dwoItemPk
partPk
PartPK partPk
partFrom
java.lang.String partFrom
relatedDoc
java.lang.String relatedDoc
partDesc
java.lang.String partDesc
qty
java.math.BigDecimal qty
quantityShipped
java.math.BigDecimal quantityShipped
nonIssueQty
java.math.BigDecimal nonIssueQty
vendorId
java.lang.String vendorId
vendorName
java.lang.String vendorName
startDate
java.util.Date startDate
dueDate
java.util.Date dueDate
completedDate
java.util.Date completedDate
status
java.lang.String status
unit
java.lang.String unit
originator
java.lang.String originator
comments
java.lang.String comments
notes
java.lang.String notes
refDoc1
java.util.Set<E> refDoc1
refDoc2
java.util.Set<E> refDoc2
mfgStatus
java.lang.String mfgStatus
project
java.lang.String project
priority
java.lang.String priority
woComments
java.lang.String woComments
setId
java.lang.String setId
costPerUnit
java.math.BigDecimal costPerUnit
extendPrice
java.math.BigDecimal extendPrice
currency
java.lang.String currency
accountNumber
java.lang.String accountNumber
companyUnitId
java.lang.String companyUnitId
totalNonIssueCost
java.math.BigDecimal totalNonIssueCost
totalIssuedCost
java.math.BigDecimal totalIssuedCost
partAvgCost
java.math.BigDecimal partAvgCost
inWIPQty
java.math.BigDecimal inWIPQty
wowiPartAvgCost
java.math.BigDecimal wowiPartAvgCost
orderRelatedDoc
java.lang.String orderRelatedDoc
refDocOnes
java.util.Set<E> refDocOnes
refDocTwoes
java.util.Set<E> refDocTwoes
totalReceivedCost
java.math.BigDecimal totalReceivedCost
Class bb.common.DisassembleWorkOrderItemPartDetailItemResult extends java.lang.Object implements Serializable

Serialized Fields

receiveVo
DisassembleWorkOrderItemReceiverVO receiveVo
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
onhand
java.math.BigDecimal onhand
onorder
java.math.BigDecimal onorder
ondemand
java.math.BigDecimal ondemand
refDoc1Set
java.util.Set<E> refDoc1Set
Class bb.common.DisassembleWorkOrderItemPartDetailResult extends java.lang.Object implements Serializable

Serialized Fields

disassembleWorkOrderItemPk
DisassembleWorkOrderItemPK disassembleWorkOrderItemPk
partPk
PartPK partPk
partFrom
java.lang.String partFrom
description
java.lang.String description
quantity
java.math.BigDecimal quantity
bomCost
java.math.BigDecimal bomCost
startDate
java.util.Date startDate
receiveDate
java.util.Date receiveDate
wiSetId
java.lang.String wiSetId
status
java.lang.String status
costAlarm
boolean costAlarm
reviewedBy
java.lang.String reviewedBy
reviewedDate
java.util.Date reviewedDate
reviewedDesc
java.lang.String reviewedDesc
varianceCost
java.math.BigDecimal varianceCost
sumCost
java.math.BigDecimal sumCost
totControlCost
java.math.BigDecimal totControlCost
diffCost
java.math.BigDecimal diffCost
refDocTwoes
java.util.Set<E> refDocTwoes
items
java.util.Set<E> items
receivedCost
java.math.BigDecimal receivedCost
shortageCost
java.math.BigDecimal shortageCost
bomStdCost
java.math.BigDecimal bomStdCost
receivedStdCost
java.math.BigDecimal receivedStdCost
shortageStdCost
java.math.BigDecimal shortageStdCost
Class bb.common.DisassembleWorkOrderItemPK extends java.lang.Object implements Serializable

Serialized Fields

disassembleWorkOrderNumber
java.lang.String disassembleWorkOrderNumber
disassembleWorkOrderItemNumber
java.lang.String disassembleWorkOrderItemNumber
Class bb.common.DisassembleWorkOrderItemReceiverPK extends java.lang.Object implements Serializable

Serialized Fields

disassembleWorkOrderNumber
java.lang.String disassembleWorkOrderNumber
disassembleWorkOrderItemNumber
java.lang.String disassembleWorkOrderItemNumber
itemNumber
java.lang.Short itemNumber
Class bb.common.DisassembleWorkOrderItemReceiverVO extends VO implements Serializable

Serialized Fields

pk
DisassembleWorkOrderItemReceiverPK pk
referenceDoc1
java.lang.String referenceDoc1
bomLastChangeTimes
int bomLastChangeTimes
bomColor
java.lang.String bomColor
bomLevel
byte bomLevel
bomNumber
java.lang.String bomNumber
bnIi
byte bnIi
bomItemQty
java.math.BigDecimal bomItemQty
bomItemNumber
java.lang.String bomItemNumber
bc
java.lang.String bc
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
modelNumber
java.lang.String modelNumber
revision
java.lang.String revision
description
java.lang.String description
quantity
java.math.BigDecimal quantity
receivedQuantity
java.math.BigDecimal receivedQuantity
dateReceived
java.util.Date dateReceived
lastDate
java.util.Date lastDate
cost
java.math.BigDecimal cost
unit
java.lang.String unit
serial
java.lang.String serial
lot
java.lang.String lot
comments
java.lang.String comments
dwoicCost
java.math.BigDecimal dwoicCost
employeeLaborCost
java.math.BigDecimal employeeLaborCost
irNumber
java.lang.String irNumber
locations
java.util.Map<K,V> locations
trackings
java.util.Map<K,V> trackings
Class bb.common.DisassembleWorkOrderItemVO extends VO implements Serializable

Serialized Fields

pk
DisassembleWorkOrderItemPK pk
identifier field

relatedDoc
java.lang.String relatedDoc
setId
java.lang.String setId
nullable persistent field

dwoSub
java.math.BigDecimal dwoSub
persistent field

dwoDisc
java.math.BigDecimal dwoDisc
persistent field

extendPrice
java.math.BigDecimal extendPrice
persistent field

dwoMade
java.math.BigDecimal dwoMade
persistent field

dwoOpen
java.math.BigDecimal dwoOpen
persistent field

dwoTax
java.math.BigDecimal dwoTax
persistent field

dwoTotal
java.math.BigDecimal dwoTotal
persistent field

referenceDoc1
java.lang.String referenceDoc1
persistent field

referenceDoc2
java.lang.String referenceDoc2
persistent field

changeOrder
java.lang.String changeOrder
persistent field

qr
java.lang.String qr
persistent field

status
java.lang.String status
persistent field

mfgStatus
java.lang.String mfgStatus
persistent field

startDate
java.util.Date startDate
persistent field

dateRequired
java.util.Date dateRequired
persistent field

desired
java.util.Date desired
persistent field

delayDays
int delayDays
persistent field

priority
java.lang.String priority
persistent field

original
java.util.Date original
persistent field

actual
java.util.Date actual
persistent field

location
java.lang.String location
persistent field

shipVia
java.lang.String shipVia
persistent field

freight
java.math.BigDecimal freight
persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
persistent field

partUnit
java.lang.String partUnit
modelNumber
java.lang.String modelNumber
persistent field

revision
java.lang.String revision
persistent field

dwg
java.lang.String dwg
persistent field

wiFlag
java.lang.String wiFlag
persistent field

quantity
java.math.BigDecimal quantity
persistent field

quantityShip
java.math.BigDecimal quantityShip
persistent field

hqa
java.math.BigDecimal hqa
persistent field

costPerUnit
java.math.BigDecimal costPerUnit
persistent field

stdCostPerUnit
java.math.BigDecimal stdCostPerUnit
unit
java.lang.String unit
persistent field

list
java.math.BigDecimal list
persistent field

discount
java.math.BigDecimal discount
persistent field

taxRate
java.math.BigDecimal taxRate
persistent field

description
java.lang.String description
persistent field

disassembleWorkOrderItemComments
java.lang.String disassembleWorkOrderItemComments
nullable persistent field

disassembleWorkOrderItemPrivateNotes
java.lang.String disassembleWorkOrderItemPrivateNotes
nullable persistent field

costAlarm
boolean costAlarm
persistent field

reviewedDate
java.util.Date reviewedDate
reviewedBy
java.lang.String reviewedBy
persistent field

reviewDescription
java.lang.String reviewDescription
originalCost
java.math.BigDecimal originalCost
overPercent
java.math.BigDecimal overPercent
refDocOnes
java.util.Set<E> refDocOnes
refDocTwoes
java.util.Set<E> refDocTwoes
createdGL
boolean createdGL
hold
java.lang.String hold
Class bb.common.DisassembleWorkOrderListResult extends java.lang.Object implements Serializable

Serialized Fields

dwoNumber
java.lang.String dwoNumber
dwoDate
java.util.Date dwoDate
vendorId
java.lang.String vendorId
vendorName
java.lang.String vendorName
priority
java.lang.String priority
project
java.lang.String project
subTotal
java.math.BigDecimal subTotal
grantTotal
java.math.BigDecimal grantTotal
status
java.lang.String status
originator
java.lang.String originator
changeOrder
java.lang.String changeOrder
disassembleWorkOrderComments
java.lang.String disassembleWorkOrderComments
disassembleWorkOrderPrivateNotes
java.lang.String disassembleWorkOrderPrivateNotes
Class bb.common.DisassembleWorkOrderReceivingResult extends java.lang.Object implements Serializable

Serialized Fields

orderNumber
java.lang.String orderNumber
itemNumber
java.lang.String itemNumber
orderDate
java.util.Date orderDate
vendorId
java.lang.String vendorId
billId
java.lang.String billId
shipId
java.lang.String shipId
changeOrder
java.lang.String changeOrder
project
java.lang.String project
shipvia
java.lang.String shipvia
orderStatus
java.lang.String orderStatus
approvedDate
java.util.Date approvedDate
approvedBy
java.lang.String approvedBy
partPk
PartPK partPk
partFrom
java.lang.String partFrom
revision
java.lang.String revision
drawing
java.lang.String drawing
description
java.lang.String description
quantity
java.math.BigDecimal quantity
quantityShipped
java.math.BigDecimal quantityShipped
unit
java.lang.String unit
requireDate
java.util.Date requireDate
itemStatus
java.lang.String itemStatus
refDoc1
java.lang.String refDoc1
refDoc2
java.lang.String refDoc2
disassembleWorkOrderReceivingItems
java.util.Set<E> disassembleWorkOrderReceivingItems
isHold
boolean isHold
Class bb.common.DisassembleWorkOrderVO extends VO implements Serializable

Serialized Fields

disassembleWorkOrderNumber
java.lang.String disassembleWorkOrderNumber
identifier field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

adate
java.util.Date adate
nullable persistent field

origin
java.lang.String origin
persistent field

dwoSub
java.math.BigDecimal dwoSub
persistent field

dwoDisc
java.math.BigDecimal dwoDisc
persistent field

subTotal
java.math.BigDecimal subTotal
persistent field

dwoMade
java.math.BigDecimal dwoMade
persistent field

dwoOpen
java.math.BigDecimal dwoOpen
persistent field

totalTax
java.math.BigDecimal totalTax
persistent field

totalFreight
java.math.BigDecimal totalFreight
persistent field

grantTotal
java.math.BigDecimal grantTotal
persistent field

changeOrder
java.lang.String changeOrder
persistent field

vendorId
java.lang.String vendorId
persistent field

billToId
java.lang.String billToId
persistent field

po
java.lang.String po
persistent field

contact
java.lang.String contact
persistent field

status
java.lang.String status
persistent field

approved
java.util.Date approved
nullable persistent field

approvedBy
java.lang.String approvedBy
persistent field

originator
java.lang.String originator
persistent field

delivery
java.util.Date delivery
persistent field

desired
java.util.Date desired
persistent field

delay
int delay
persistent field

priority
java.lang.String priority
persistent field

original
java.util.Date original
persistent field

actual
java.lang.String actual
persistent field

shipToId
java.lang.String shipToId
persistent field

shipVia
java.lang.String shipVia
persistent field

shippingAccount
java.lang.String shippingAccount
persistent field

location
java.lang.String location
persistent field

language
java.lang.String language
persistent field

currency
java.lang.String currency
persistent field

terms
java.lang.String terms
persistent field

entered
java.util.Date entered
persistent field

salesman
java.lang.String salesman
persistent field

requestor
java.lang.String requestor
persistent field

project
java.lang.String project
persistent field

relatedDoc
java.lang.String relatedDoc
persistent field

debitAccount
java.lang.String debitAccount
persistent field

bp
java.lang.String bp
persistent field

disassembleWorkOrderComments
java.lang.String disassembleWorkOrderComments
nullable persistent field

disassembleWorkOrderPrivateNotes
java.lang.String disassembleWorkOrderPrivateNotes
nullable persistent field

companyUnitId
java.lang.String companyUnitId
persistent field

useWip
boolean useWip
persistent field

lastChangeTimes
int lastChangeTimes
nullable persistent field

vendorAddressInfo
CustomerVendorAddressInfoVO vendorAddressInfo
nullable persistent field

shipToAddressInfo
CustomerVendorAddressInfoVO shipToAddressInfo
nullable persistent field

billToAddressInfo
CustomerVendorAddressInfoVO billToAddressInfo
nullable persistent field

disassembleWorkOrderItem
java.util.Set<E> disassembleWorkOrderItem
persistent field

boilerplates
java.util.Set<E> boilerplates
coComments
java.lang.String coComments
hold
boolean hold
Class bb.common.DocumentInfoAgent extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
partRevision
java.lang.String partRevision
language
java.lang.String language
documentType
java.lang.String documentType
isPublic
boolean isPublic
extention
java.lang.String extention
wanIp
java.lang.String wanIp
lanIp
java.lang.String lanIp
macAdd
java.lang.String macAdd
comments
java.lang.String comments
Class bb.common.DocumentLogVO extends VO implements Serializable

Serialized Fields

id
java.lang.Long id
identifier field

userName
java.lang.String userName
persistent field

action
java.lang.Integer action
persistent field

dir
java.lang.String dir
persistent field

fileName
java.lang.String fileName
persistent field

timestamp
java.sql.Timestamp timestamp
persistent field

Class bb.common.DocumentServerVO extends VO implements Serializable

Serialized Fields

documentType
java.lang.String documentType
identifier field

serverIp
java.lang.String serverIp
persistent field

serverPort
java.lang.String serverPort
persistent field

userName
java.lang.String userName
persistent field

userPassword
java.lang.String userPassword
persistent field

ftpPath
java.lang.String ftpPath
persistent field

localPath
java.lang.String localPath
persistent field

lock
java.lang.String lock
persistent field

remarks
java.lang.String remarks
persistent field

saveToFtp
boolean saveToFtp
persistent field

Class bb.common.DuePATotalByVendorResult extends java.lang.Object implements Serializable

Serialized Fields

unitTotal
java.math.BigDecimal unitTotal
shipTotal
java.math.BigDecimal shipTotal
openTotal
java.math.BigDecimal openTotal
discountTotal
java.math.BigDecimal discountTotal
totalNet
java.math.BigDecimal totalNet
totalTax
java.math.BigDecimal totalTax
freightTotal
java.math.BigDecimal freightTotal
grandTotal
java.math.BigDecimal grandTotal
totalPaid
java.math.BigDecimal totalPaid
currency
java.lang.String currency
amountDue
java.math.BigDecimal amountDue
subNetTotal
java.math.BigDecimal subNetTotal
avgMargin
java.math.BigDecimal avgMargin
stdMargin
java.math.BigDecimal stdMargin
avgMarginPercent
java.math.BigDecimal avgMarginPercent
stdMarginPercent
java.math.BigDecimal stdMarginPercent
Class bb.common.DwfUploadSettingsVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Integer ii
identifier field

drawingType
java.lang.String drawingType
persistent field

saveToFtp
boolean saveToFtp
persistent field

serverIp
java.lang.String serverIp
persistent field

serverPort
java.lang.String serverPort
persistent field

userName
java.lang.String userName
persistent field

userPassword
java.lang.String userPassword
persistent field

ftpPath
java.lang.String ftpPath
persistent field

localPath
java.lang.String localPath
persistent field

remarks
java.lang.String remarks
persistent field

Class bb.common.DwgUploadSettingsVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Integer ii
identifier field

drawingType
java.lang.String drawingType
persistent field

saveToFtp
boolean saveToFtp
persistent field

serverIp
java.lang.String serverIp
persistent field

serverPort
java.lang.String serverPort
persistent field

userName
java.lang.String userName
persistent field

userPassword
java.lang.String userPassword
persistent field

ftpPath
java.lang.String ftpPath
persistent field

localPath
java.lang.String localPath
persistent field

remarks
java.lang.String remarks
persistent field

Class bb.common.DWOIssueDetail extends java.lang.Object implements Serializable

Serialized Fields

quantity
java.math.BigDecimal quantity
quantityShippedTotal
java.math.BigDecimal quantityShippedTotal
qtyShipped
java.math.BigDecimal qtyShipped
dateMade
java.util.Date dateMade
dateRequired
java.util.Date dateRequired
costPerUnit
java.math.BigDecimal costPerUnit
disassembleWorkOrderNumber
java.lang.String disassembleWorkOrderNumber
disassembleWorkOrderItemNumber
java.lang.String disassembleWorkOrderItemNumber
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
vendorId
java.lang.String vendorId
standardCost
java.math.BigDecimal standardCost
description
java.lang.String description
companyUnitId
java.lang.String companyUnitId
accountNumber
java.lang.String accountNumber
location
java.util.LinkedHashMap<K,V> location
lastChangeUser
java.lang.String lastChangeUser
Class bb.common.DynamicSearchFilter extends java.lang.Object implements Serializable

Serialized Fields

methodName
java.lang.String methodName
filter
java.lang.String filter
orderBy
java.lang.String orderBy
Class bb.common.EcnCheckOrderResult extends java.lang.Object implements Serializable

Serialized Fields

woOrderItems
java.util.Set<E> woOrderItems
poOrderItems
java.util.Set<E> poOrderItems
part
BB2Part part
Class bb.common.EcnPOOrderResult extends java.lang.Object implements Serializable

Serialized Fields

poItemPk
PurchaseOrderItemPK poItemPk
delivery
java.util.Date delivery
description
java.lang.String description
qty
java.math.BigDecimal qty
recQty
java.math.BigDecimal recQty
onhand
java.math.BigDecimal onhand
onorder
java.math.BigDecimal onorder
ondemand
java.math.BigDecimal ondemand
vendorId
java.lang.String vendorId
Class bb.common.ECNReviewVO extends VO implements Serializable

Serialized Fields

employeeId
java.lang.String employeeId
identifier field

userName
java.lang.String userName
persistent field

comments
java.lang.String comments
Class bb.common.EcnWOOrderResult extends java.lang.Object implements Serializable

Serialized Fields

woItemPk
WorkOrderItemPK woItemPk
delivery
java.util.Date delivery
description
java.lang.String description
vendorId
java.lang.String vendorId
qty
java.math.BigDecimal qty
asm
java.math.BigDecimal asm
onorder
java.math.BigDecimal onorder
onhand
java.math.BigDecimal onhand
ondemand
java.math.BigDecimal ondemand
Class bb.common.ECRReviewVO extends VO implements Serializable

Serialized Fields

employeeId
java.lang.String employeeId
identifier field

userName
java.lang.String userName
persistent field

comments
java.lang.String comments
Class bb.common.EjbMethodVO extends VO implements Serializable

Serialized Fields

methodId
java.lang.Long methodId
identifier field

ejbName
java.lang.String ejbName
persistent field

methodName
java.lang.String methodName
persistent field

comments
java.lang.String comments
nullable persistent field

Class bb.common.EmployeeCardVO extends VO implements Serializable

Serialized Fields

id
java.lang.String id
tempWorker
boolean tempWorker
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
terminatedDate
java.util.Date terminatedDate
version
java.lang.Integer version
aDate
java.util.Date aDate
userName
java.lang.String userName
lastName
java.lang.String lastName
firstName
java.lang.String firstName
workAddress
java.lang.String workAddress
department
java.lang.String department
startDate
java.util.Date startDate
phone
java.lang.String phone
extension
java.lang.String extension
email
java.lang.String email
picture
byte[] picture
extent
java.lang.String extent
jobId
java.lang.String jobId
status
java.lang.String status
securityLevel
java.lang.String securityLevel
companyAddressBookName
java.lang.String companyAddressBookName
middleName
java.lang.String middleName
manager
java.lang.String manager
position
java.lang.String position
mobile
java.lang.String mobile
fax
java.lang.String fax
homePhone
java.lang.String homePhone
idCard
java.lang.String idCard
showHomePhone
java.lang.String showHomePhone
showMobile
java.lang.String showMobile
showFax
java.lang.String showFax
birthPlace
java.lang.String birthPlace
education
java.lang.String education
source
java.lang.String source
comments
java.lang.String comments
listInAddressBook
java.lang.String listInAddressBook
birthDate
java.util.Date birthDate
transferDate
java.util.Date transferDate
contractExpires
java.util.Date contractExpires
gender
boolean gender
Class bb.common.EmployeeEducationPK extends java.lang.Object implements Serializable

Serialized Fields

ii
java.lang.Short ii
employeeId
java.lang.String employeeId
Class bb.common.EmployeeEducationResult extends EmployeeEducationVO implements Serializable

Serialized Fields

userName
java.lang.String userName
lastName
java.lang.String lastName
firstName
java.lang.String firstName
Class bb.common.EmployeeEducationVO extends VO implements Serializable

Serialized Fields

pk
EmployeeEducationPK pk
college
java.lang.String college
fromDate
java.util.Date fromDate
toDate
java.util.Date toDate
degree
java.lang.String degree
major
java.lang.String major
city
java.lang.String city
description
java.lang.String description
Class bb.common.EmployeeHomeVO extends VO implements Serializable

Serialized Fields

id
java.lang.String id
homeAddress
java.lang.String homeAddress
addressOne
java.lang.String addressOne
addressTwo
java.lang.String addressTwo
city
java.lang.String city
state
java.lang.String state
zip
java.lang.String zip
country
java.lang.String country
spouseName
java.lang.String spouseName
homePhone
java.lang.String homePhone
emergencyContact
java.lang.String emergencyContact
comment
java.lang.String comment
Class bb.common.EmployeeJobDescriptionVO extends VO implements Serializable

Serialized Fields

id
java.lang.String id
identifier field

description
java.lang.String description
persistent field

longDescription
java.sql.Blob longDescription
nullable persistent field

Class bb.common.EmployeeLaborAgent extends java.lang.Object implements Serializable

Serialized Fields

workOrderNumber
java.lang.String workOrderNumber
workOrderItemNumber
java.lang.String workOrderItemNumber
employeeId
java.lang.String employeeId
comments
java.lang.String comments
hours
java.math.BigDecimal hours
cost
java.math.BigDecimal cost
Class bb.common.EmployeePutGoodListResult extends java.lang.Object implements Serializable

Serialized Fields

employeeId
java.lang.String employeeId
employeeName
java.lang.String employeeName
jobId
java.lang.String jobId
jobName
java.lang.String jobName
goodsId
java.lang.String goodsId
goodsName
java.lang.String goodsName
putDate
java.util.Date putDate
Class bb.common.EmployeeRecordsVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
employeeId
java.lang.String employeeId
description
java.lang.String description
comments
java.lang.String comments
extension
java.lang.String extension
docName
java.lang.String docName
docLength
long docLength
date
java.util.Date date
recordType
java.lang.String recordType
Class bb.common.EmployeeTimeCardResult extends java.lang.Object implements Serializable

Serialized Fields

employeeId
java.lang.String employeeId
employeeName
java.lang.String employeeName
timeCards
java.util.List<E> timeCards
Class bb.common.EmployeeTrainingVO extends VO implements Serializable

Serialized Fields

pk
EmployeeWorkExperiencePK pk
title
java.lang.String title
trainDate
java.util.Date trainDate
expireDate
java.util.Date expireDate
place
java.lang.String place
speaker
java.lang.String speaker
recorder
java.lang.String recorder
certiNumber
java.lang.String certiNumber
certiName
java.lang.String certiName
result
java.lang.String result
Class bb.common.EmployeeWorkExperiencePK extends java.lang.Object implements Serializable

Serialized Fields

ii
java.lang.Short ii
employeeId
java.lang.String employeeId
Class bb.common.EmployeeWorkExperienceVO extends VO implements Serializable

Serialized Fields

pk
EmployeeWorkExperiencePK pk
companyName
java.lang.String companyName
fromDate
java.util.Date fromDate
toDate
java.util.Date toDate
jobTitle
java.lang.String jobTitle
location
java.lang.String location
description
java.lang.String description
authenticator
java.lang.String authenticator
Class bb.common.EngGroupUserPK extends java.lang.Object implements Serializable

Serialized Fields

engGroupId
java.lang.String engGroupId
empId
java.lang.String empId
Class bb.common.EngGroupUserVO extends VO implements Serializable

Serialized Fields

pk
EngGroupUserPK pk
userName
java.lang.String userName
comments
java.lang.String comments
Class bb.common.EngGroupVO extends VO implements Serializable

Serialized Fields

id
java.lang.String id
parentId
java.lang.String parentId
name
java.lang.String name
Class bb.common.EngineeringChangeDocumentVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
identifier field

engineeringChangeNumber
java.lang.String engineeringChangeNumber
persistent field

docDescription
java.lang.String docDescription
persistent field

documentDate
java.util.Date documentDate
nullable persistent field

comments
java.lang.String comments
nullable persistent field

lastChangeUser
java.lang.String lastChangeUser
nullable persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

extension
java.lang.String extension
persistent field

docFileName
java.lang.String docFileName
persistent field

docLength
long docLength
persistent field

Class bb.common.EngineeringChangeListResult extends java.lang.Object implements Serializable

Serialized Fields

partPk
PartPK partPk
partDescription
java.lang.String partDescription
ecnNumber
java.lang.String ecnNumber
ecnDescription
java.lang.String ecnDescription
newRevision
java.lang.String newRevision
oldRevision
java.lang.String oldRevision
status
java.lang.String status
originator
java.lang.String originator
dueDate
java.util.Date dueDate
partFrom
java.lang.String partFrom
importEcnNumber
java.lang.String importEcnNumber
importCompanyId
java.lang.String importCompanyId
engineeringChangeDate
java.util.Date engineeringChangeDate
Class bb.common.EngineeringChangeRequestDocumentVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
identifier field

engineeringChangeRequestNumber
java.lang.String engineeringChangeRequestNumber
persistent field

docDescription
java.lang.String docDescription
persistent field

documentDate
java.util.Date documentDate
nullable persistent field

comments
java.lang.String comments
nullable persistent field

lastChangeUser
java.lang.String lastChangeUser
nullable persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

extension
java.lang.String extension
persistent field

docFileName
java.lang.String docFileName
persistent field

docLength
long docLength
persistent field

Class bb.common.EngineeringChangeRequestListResult extends java.lang.Object implements Serializable

Serialized Fields

partPk
PartPK partPk
partDescription
java.lang.String partDescription
ecrNumber
java.lang.String ecrNumber
ecrDescription
java.lang.String ecrDescription
status
java.lang.String status
dueDate
java.util.Date dueDate
partFrom
java.lang.String partFrom
ecrEngineer
java.lang.String ecrEngineer
originator
java.lang.String originator
closedOutPrivateNotes
java.lang.String closedOutPrivateNotes
ecrPriority
java.lang.String ecrPriority
dispositionOfChange
java.lang.String dispositionOfChange
Class bb.common.EngineeringChangeRequestVO extends VO implements Serializable

Serialized Fields

engineeringChangeRequestNumber
java.lang.String engineeringChangeRequestNumber
dueDate
java.util.Date dueDate
lastUser
java.lang.String lastUser
lastChangeDate
java.util.Date lastChangeDate
version
java.lang.Integer version
status
java.lang.String status
ecrDate
java.util.Date ecrDate
originator
java.lang.String originator
description
java.lang.String description
approved
java.lang.String approved
partNumber
java.lang.String partNumber
partType
java.lang.String partType
revision
java.lang.String revision
changedByEngineer
java.lang.String changedByEngineer
engineeringChangeNoticeNumber
java.lang.String engineeringChangeNoticeNumber
closedOutDate
java.util.Date closedOutDate
closedOutPrivateNotes
java.lang.String closedOutPrivateNotes
dispositionOfChange
java.lang.String dispositionOfChange
partFrom
java.lang.String partFrom
approvedDate
java.util.Date approvedDate
ecrPriority
java.lang.String ecrPriority
engineeringChangeRequestDocuments
java.util.Set<E> engineeringChangeRequestDocuments
Class bb.common.EngineeringChangeVO extends VO implements Serializable

Serialized Fields

engineeringChangeNumber
java.lang.String engineeringChangeNumber
identifier field

refDoc1
java.lang.String refDoc1
persistent field

refDoc2
java.lang.String refDoc2
persistent field

dueDate
java.util.Date dueDate
persistent field

lastUser
java.lang.String lastUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

version
java.lang.Integer version
persistent field

origin
java.lang.String origin
persistent field

status
java.lang.String status
persistent field

engineeringChangeDate
java.util.Date engineeringChangeDate
persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

modelNumber
java.lang.String modelNumber
persistent field

oldRev
java.lang.String oldRev
persistent field

newRev
java.lang.String newRev
persistent field

effectiveDate
java.util.Date effectiveDate
persistent field

haveDrawingRevised
java.lang.String haveDrawingRevised
persistent field

drawingRevisedDate
java.util.Date drawingRevisedDate
persistent field

originator
java.lang.String originator
persistent field

description
java.lang.String description
persistent field

inventoryAction
java.lang.String inventoryAction
persistent field

inventoryUseAsIs
java.lang.String inventoryUseAsIs
persistent field

inventoryModify
java.lang.String inventoryModify
persistent field

inventoryScrap
java.lang.String inventoryScrap
persistent field

onorderAction
java.lang.String onorderAction
persistent field

onorderUseAsIs
java.lang.String onorderUseAsIs
persistent field

onorderModify
java.lang.String onorderModify
persistent field

onorderScrap
java.lang.String onorderScrap
persistent field

approved
java.lang.String approved
persistent field

partFrom
java.lang.String partFrom
hold
boolean hold
importEc
java.lang.String importEc
importComment
java.lang.String importComment
importCompany
java.lang.String importCompany
approvedDate
java.util.Date approvedDate
engineeringChangeDocuments
java.util.Set<E> engineeringChangeDocuments
Class bb.common.EngineeringInfoCenterResult extends java.lang.Object implements Serializable

Serialized Fields

pastDueEcnCount
java.lang.Integer pastDueEcnCount
openEcnCount
java.lang.Integer openEcnCount
partOnholdCount
java.lang.Integer partOnholdCount
dwfCount
java.lang.Integer dwfCount
dwfAddedCurrentMonthCount
java.lang.Integer dwfAddedCurrentMonthCount
dwfAddedLastMonthCount
java.lang.Integer dwfAddedLastMonthCount
openEcrCount
java.lang.Integer openEcrCount
openEdcCount
java.lang.Integer openEdcCount
notApproveEcnCount
java.lang.Integer notApproveEcnCount
cancelledEcnCount
java.lang.Integer cancelledEcnCount
obsoleteEcnCount
java.lang.Integer obsoleteEcnCount
Class bb.common.EngineeringSharingImportLogVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
partNumber
java.lang.String partNumber
partType
java.lang.String partType
importType
java.lang.String importType
importDataType
java.lang.String importDataType
importKey
java.lang.String importKey
content
java.lang.String content
importDate
java.util.Date importDate
reviewed
java.util.Date reviewed
reviewedBy
java.lang.String reviewedBy
status
java.lang.String status
ecnNumber
java.lang.String ecnNumber
Class bb.common.EngineeringSharingItemPK extends java.lang.Object implements Serializable

Serialized Fields

companyId
java.lang.String companyId
identifier field

partNumber
java.lang.String partNumber
identifier field

partType
java.lang.String partType
identifier field

Class bb.common.EngineeringSharingItemVO extends VO implements Serializable

Serialized Fields

pk
EngineeringSharingItemPK pk
optWho
java.lang.String optWho
editDate
java.util.Date editDate
partDescription
java.lang.String partDescription
Class bb.common.EngineeringSharingVO extends VO implements Serializable

Serialized Fields

companyId
java.lang.String companyId
identifier field

companyName
java.lang.String companyName
persistent field

lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
validFrom
java.util.Date validFrom
nullable persistent field

validTo
java.util.Date validTo
nullable persistent field

contact
java.lang.String contact
engineeringSharingRule
java.lang.String engineeringSharingRule
comments
java.lang.String comments
Class bb.common.EquipmentListResult extends java.lang.Object implements Serializable

Serialized Fields

equipmentId
java.lang.String equipmentId
ref
java.lang.String ref
departmentId
java.lang.String departmentId
description
java.lang.String description
model
java.lang.String model
manufacturerId
java.lang.String manufacturerId
maintenanceBy
java.lang.String maintenanceBy
assetNum
java.lang.String assetNum
lastMaintenanceDate
java.util.Date lastMaintenanceDate
nextScheduledMaintenanceDate
java.util.Date nextScheduledMaintenanceDate
equipmentNotes
java.lang.String equipmentNotes
currentRunHours
java.math.BigDecimal currentRunHours
runHoursLimit
java.lang.Integer runHoursLimit
status
java.lang.String status
type
java.lang.String type
workCenterId
java.lang.String workCenterId
warning
boolean warning
Class bb.common.EquipmentVO extends VO implements Serializable

Serialized Fields

equipmentId
java.lang.String equipmentId
identifier field

ref
java.lang.String ref
persistent field

rate
java.math.BigDecimal rate
nullable persistent field

hrs
java.lang.Integer hrs
nullable persistent field

departmentId
java.lang.String departmentId
nullable persistent field

description
java.lang.String description
nullable persistent field

manufacturerId
java.lang.String manufacturerId
nullable persistent field

model
java.lang.String model
nullable persistent field

totalPower
java.math.BigDecimal totalPower
persistent field

powerUnit
java.lang.String powerUnit
persistent field

maintenanceBy
java.lang.String maintenanceBy
persistent field

assetNum
java.lang.String assetNum
persistent field

serial
java.lang.String serial
nullable persistent field

installedDate
java.util.Date installedDate
nullable persistent field

originalCost
java.math.BigDecimal originalCost
persistent field

costCurrency
java.lang.String costCurrency
persistent field

currentRunHours
java.math.BigDecimal currentRunHours
nullable persistent field

runHoursLimit
java.lang.Integer runHoursLimit
maintencePeriod
java.lang.Integer maintencePeriod
nullable persistent field

periodUnit
java.lang.String periodUnit
persistent field

lastMaintenanceDate
java.util.Date lastMaintenanceDate
nullable persistent field

nextScheduledMaintenanceDate
java.util.Date nextScheduledMaintenanceDate
nullable persistent field

equipmentNotes
java.lang.String equipmentNotes
nullable persistent field

status
java.lang.String status
persistent field

type
java.lang.String type
workCenterId
java.lang.String workCenterId
maintenanceItems
java.util.Set<E> maintenanceItems
Class bb.common.ExchangeAuditItemResult extends java.lang.Object implements Serializable

Serialized Fields

accountNumber
java.lang.String accountNumber
accountType
java.lang.String accountType
level
java.lang.String level
items
byte items
upLevelAccountNumber
java.lang.String upLevelAccountNumber
creditOrDebit
java.lang.String creditOrDebit
addOrSubtract
java.lang.String addOrSubtract
accountDescription
java.lang.String accountDescription
currency
java.lang.String currency
exchange
java.math.BigDecimal exchange
credit
java.math.BigDecimal credit
debit
java.math.BigDecimal debit
balance
java.math.BigDecimal balance
bookBalance
java.math.BigDecimal bookBalance
variance
java.math.BigDecimal variance
address
java.lang.String address
orgCredit
java.math.BigDecimal orgCredit
orgDebit
java.math.BigDecimal orgDebit
orgBalance
java.math.BigDecimal orgBalance
Class bb.common.ExchangeAuditResult extends java.lang.Object implements Serializable

Serialized Fields

transactionNumber
java.lang.String transactionNumber
monthYear
java.lang.String monthYear
companyUnitId
java.lang.String companyUnitId
map
java.util.Map<K,V> map
list
java.util.List<E> list
glSummary
java.lang.String glSummary
Class bb.common.ExpenseAccountVO extends VO implements Serializable

Serialized Fields

type
java.lang.String type
identifier field

accountNumber
java.lang.String accountNumber
persistent field

companyUnitId
java.lang.String companyUnitId
persistent field

description
java.lang.String description
persistent field

Class bb.common.ExpenseItemPK extends java.lang.Object implements Serializable

Serialized Fields

expenseStatement
java.lang.String expenseStatement
identifier field

ii
java.lang.Integer ii
identifier field

Class bb.common.ExpenseItemVO extends VO implements Serializable

Serialized Fields

pk
ExpenseItemPK pk
identifier field

dateFrom
java.util.Date dateFrom
persistent field

dateTo
java.util.Date dateTo
persistent field

type
java.lang.String type
persistent field

amount
java.math.BigDecimal amount
persistent field

currency
java.lang.String currency
persistent field

description
java.lang.String description
persistent field

ga
java.lang.String ga
persistent field

comment
java.lang.String comment
persistent field

Class bb.common.ExpenseListResult extends java.lang.Object implements Serializable

Serialized Fields

expenseStatement
java.lang.String expenseStatement
dateFrom
java.util.Date dateFrom
dateTo
java.util.Date dateTo
userName
java.lang.String userName
status
java.lang.String status
Class bb.common.ExpenseVO extends VO implements Serializable

Serialized Fields

expenseStatement
java.lang.String expenseStatement
identifier field

apNumber
java.lang.String apNumber
persistent field

status
java.lang.String status
persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

userName
java.lang.String userName
persistent field

department
java.lang.String department
persistent field

employeeId
java.lang.String employeeId
persistent field

position
java.lang.String position
persistent field

manager
java.lang.String manager
persistent field

approveDate
java.util.Date approveDate
nullable persistent field

approvedBy
java.lang.String approvedBy
persistent field

date1
java.util.Date date1
persistent field

date2
java.util.Date date2
persistent field

total
java.math.BigDecimal total
persistent field

advances
java.math.BigDecimal advances
persistent field

reimbursement
java.math.BigDecimal reimbursement
persistent field

paymentNeeded
java.math.BigDecimal paymentNeeded
persistent field

cashCheckReceived
java.lang.String cashCheckReceived
persistent field

checkPaid
java.lang.String checkPaid
persistent field

datePaid
java.util.Date datePaid
nullable persistent field

version
int version
nullable persistent field

expensesItems
java.util.Set<E> expensesItems
persistent field

Class bb.common.FeedbackAnswerPK extends java.lang.Object implements Serializable

Serialized Fields

questionId
java.lang.String questionId
identifier field

answerItem
java.lang.String answerItem
identifier field

Class bb.common.FeedbackAnswerVO extends VO implements Serializable

Serialized Fields

pk
FeedbackAnswerPK pk
identifier field

answerEn
java.lang.String answerEn
persistent field

answerCn
java.lang.String answerCn
persistent field

feedbackQuestion
FeedbackQuestionVO feedbackQuestion
nullable persistent field

Class bb.common.FeedBackItemPK extends java.lang.Object implements Serializable

Serialized Fields

feedBackNumber
java.lang.String feedBackNumber
identifier field

questionId
java.lang.String questionId
identifier field

Class bb.common.FeedbackItemVO extends VO implements Serializable

Serialized Fields

pk
FeedBackItemPK pk
identifier field

answerItem
java.lang.String answerItem
persistent field

Class bb.common.FeedbackQuestionVO extends VO implements Serializable

Serialized Fields

questionId
java.lang.String questionId
identifier field

questionEn
java.lang.String questionEn
persistent field

questionCn
java.lang.String questionCn
persistent field

answers
java.util.Set<E> answers
persistent field

Class bb.common.FinishProformaReceiverAgent extends java.lang.Object implements Serializable

Serialized Fields

receiveAllSo
boolean receiveAllSo
receiveAllWo
boolean receiveAllWo
Class bb.common.FiscalYearSettingsVO extends VO implements Serializable

Serialized Fields

fy
java.lang.String fy
identifier field

startDate
java.util.Date startDate
persistent field

endDate
java.util.Date endDate
persistent field

status
java.lang.String status
nullable persistent field

useAccountPeriod
boolean useAccountPeriod
acctPeriod
java.util.Set<E> acctPeriod
Class bb.common.GeneralLedgerApprovalVO extends VO implements Serializable

Serialized Fields

employeeId
java.lang.String employeeId
userName
java.lang.String userName
approveLimit
java.math.BigDecimal approveLimit
comments
java.lang.String comments
Class bb.common.GeneralLedgerByDateListResult extends java.lang.Object implements Serializable

Serialized Fields

glNumber
java.lang.String glNumber
accountNumber
java.lang.String accountNumber
accountDesctiption
java.lang.String accountDesctiption
accountType
java.lang.String accountType
transactionDate
java.util.Date transactionDate
debit
java.math.BigDecimal debit
credit
java.math.BigDecimal credit
addressId
java.lang.String addressId
addressName
java.lang.String addressName
poNumber
java.lang.String poNumber
apNumber
java.lang.String apNumber
vendorInvoice
java.lang.String vendorInvoice
batch
java.lang.String batch
soNumber
java.lang.String soNumber
arNumber
java.lang.String arNumber
checkNumber
java.lang.String checkNumber
paid
java.math.BigDecimal paid
received
java.math.BigDecimal received
cashier
java.lang.String cashier
description
java.lang.String description
companyUnitId
java.lang.String companyUnitId
glCategory
java.lang.String glCategory
summary
java.lang.String summary
categorySequence
java.lang.Integer categorySequence
balance
java.math.BigDecimal balance
clear
boolean clear
Class bb.common.GeneralLedgerCategoryVO extends VO implements Serializable

Serialized Fields

id
java.lang.String id
name
java.lang.String name
glType
java.lang.String glType
debitAccounts
java.lang.String debitAccounts
creditAccounts
java.lang.String creditAccounts
Class bb.common.GeneralLedgerEntry extends java.lang.Object implements Serializable

Serialized Fields

description
java.lang.String description
accountNumber
java.lang.String accountNumber
accountNumberDescription
java.lang.String accountNumberDescription
firstLevelAccountNumber
java.lang.String firstLevelAccountNumber
firstLevelAccountNumberDescription
java.lang.String firstLevelAccountNumberDescription
debit
java.math.BigDecimal debit
credit
java.math.BigDecimal credit
originalCredit
java.math.BigDecimal originalCredit
originalDebit
java.math.BigDecimal originalDebit
exchange
java.math.BigDecimal exchange
Class bb.common.GeneralLedgerListResult extends java.lang.Object implements Serializable

Serialized Fields

transactionNumber
java.lang.String transactionNumber
transactionDate
java.util.Date transactionDate
transactionType
java.lang.String transactionType
customerId
java.lang.String customerId
name
java.lang.String name
batch
java.lang.String batch
currency
java.lang.String currency
exchange
java.math.BigDecimal exchange
checkNumber
java.lang.String checkNumber
memo
java.lang.String memo
checkPrinted
java.lang.String checkPrinted
bankReconsiled
java.lang.String bankReconsiled
lastChangeUser
java.lang.String lastChangeUser
lastChangeTimes
java.lang.Integer lastChangeTimes
adate
java.util.Date adate
reldoc
java.lang.String reldoc
purchaseOrderNumber
java.lang.String purchaseOrderNumber
receiverNumber
java.lang.String receiverNumber
accountsPayableNumber
java.lang.String accountsPayableNumber
vendorInvoice
java.lang.String vendorInvoice
paid
java.math.BigDecimal paid
salesOrderNumber
java.lang.String salesOrderNumber
shipperNumber
java.lang.String shipperNumber
invoiceNumber
java.lang.String invoiceNumber
customerPo
java.lang.String customerPo
discount
java.math.BigDecimal discount
salesTax
java.math.BigDecimal salesTax
received
java.math.BigDecimal received
description
java.lang.String description
freight
java.math.BigDecimal freight
salesman
java.lang.String salesman
commission
java.math.BigDecimal commission
comments
java.lang.String comments
notes
java.lang.String notes
lastChangeDate
java.util.Date lastChangeDate
transactionTypeDescription
java.lang.String transactionTypeDescription
glCategory
java.lang.String glCategory
categorySequence
java.lang.Integer categorySequence
Class bb.common.GeneralLedgerPrintResult extends java.lang.Object implements Serializable

Serialized Fields

glCategory
java.lang.String glCategory
categoryName
java.lang.String categoryName
categorySequence
java.lang.Integer categorySequence
attachmentNum
java.lang.Integer attachmentNum
transactionDate
java.util.Date transactionDate
origin
java.lang.String origin
approvedBy
java.lang.String approvedBy
postedBy
java.lang.String postedBy
totalAmount
java.math.BigDecimal totalAmount
entryList
java.util.List<E> entryList
Class bb.common.GeneralLedgerResult extends java.lang.Object implements Serializable

Serialized Fields

transactionNumber
java.lang.String transactionNumber
transactionDate
java.util.Date transactionDate
transactionType
java.lang.String transactionType
batch
java.lang.String batch
check
java.lang.String check
checkPrinted
java.lang.String checkPrinted
bankReconciled
java.lang.String bankReconciled
ourPO
java.lang.String ourPO
receiverNumber
java.lang.String receiverNumber
vendorInvoice
java.lang.String vendorInvoice
salesOrderNumber
java.lang.String salesOrderNumber
shipperNumber
java.lang.String shipperNumber
invoiceNumber
java.lang.String invoiceNumber
customerPO
java.lang.String customerPO
discount
java.math.BigDecimal discount
salesTax
java.math.BigDecimal salesTax
commission
java.math.BigDecimal commission
id
java.lang.String id
name
java.lang.String name
Class bb.common.GeneralLedgerSettingsVO extends VO implements Serializable

Serialized Fields

id
java.lang.String id
identifier field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

validTransactionDate
java.util.Date validTransactionDate
persistent field

lockedTransactionDate
java.util.Date lockedTransactionDate
persistent field

status
java.lang.String status
persistent field

initSom
java.util.Date initSom
persistent field

cm0
java.lang.String cm0
persistent field

cm1
java.lang.String cm1
persistent field

cm2
java.lang.String cm2
persistent field

fy
java.lang.String fy
persistent field

fy1
int fy1
persistent field

fy2
int fy2
persistent field

fm0
java.lang.String fm0
persistent field

fm1
java.lang.String fm1
persistent field

fm2
java.lang.String fm2
persistent field

version
int version
nullable persistent field

Class bb.common.GeneralLedgerVO extends VO implements Serializable

Serialized Fields

transactionNumber
java.lang.String transactionNumber
identifier field

glCategory
java.lang.String glCategory
categorySequence
java.lang.Integer categorySequence
attachmentNum
java.lang.Integer attachmentNum
transactionDate
java.util.Date transactionDate
persistent field

transactionType
java.lang.String transactionType
persistent field

customerId
java.lang.String customerId
persistent field

name
java.lang.String name
batch
java.lang.String batch
nullable persistent field

currency
java.lang.String currency
nullable persistent field

exchange
java.math.BigDecimal exchange
checkNumber
java.lang.String checkNumber
nullable persistent field

checkRunNumber
java.lang.String checkRunNumber
memo
java.lang.String memo
checkPrinted
java.lang.String checkPrinted
nullable persistent field

bankReconsiled
java.lang.String bankReconsiled
nullable persistent field

lastChangeUser
java.lang.String lastChangeUser
nullable persistent field

lastChangeTimes
java.lang.Integer lastChangeTimes
nullable persistent field

adate
java.util.Date adate
nullable persistent field

origin
java.lang.String origin
approvedDate
java.util.Date approvedDate
approvedBy
java.lang.String approvedBy
approvalStatus
java.lang.String approvalStatus
posted
boolean posted
postedBy
java.lang.String postedBy
reldoc
java.lang.String reldoc
nullable persistent field

purchaseOrderNumber
java.lang.String purchaseOrderNumber
persistent field

receiverNumber
java.lang.String receiverNumber
persistent field

accountsPayableNumber
java.lang.String accountsPayableNumber
persistent field

vendorInvoice
java.lang.String vendorInvoice
persistent field

paid
java.math.BigDecimal paid
nullable persistent field

salesOrderNumber
java.lang.String salesOrderNumber
persistent field

shipperNumber
java.lang.String shipperNumber
persistent field

invoiceNumber
java.lang.String invoiceNumber
persistent field

customerPo
java.lang.String customerPo
persistent field

discount
java.math.BigDecimal discount
nullable persistent field

salesTax
java.math.BigDecimal salesTax
nullable persistent field

received
java.math.BigDecimal received
nullable persistent field

description
java.lang.String description
nullable persistent field

freight
java.math.BigDecimal freight
nullable persistent field

salesman
java.lang.String salesman
nullable persistent field

commission
java.math.BigDecimal commission
nullable persistent field

comments
java.lang.String comments
nullable persistent field

notes
java.lang.String notes
nullable persistent field

appNumber
java.lang.String appNumber
arpNumber
java.lang.String arpNumber
appItemNumber
java.lang.String appItemNumber
arpItemNumber
java.lang.String arpItemNumber
overCarryPL
boolean overCarryPL
lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

clear
boolean clear
deposit
boolean deposit
reconciledDate
java.util.Date reconciledDate
transactionTypeDescription
AccountingTransactionTypeVO transactionTypeDescription
nullable persistent field

accountCredit
java.util.Set<E> accountCredit
accountDebit
java.util.Set<E> accountDebit
apPrepayApplys
java.util.Map<K,V> apPrepayApplys
arPrepayApplys
java.util.Map<K,V> arPrepayApplys
Class bb.common.GLApprovalListResult extends java.lang.Object implements Serializable

Serialized Fields

transactionDate
java.util.Date transactionDate
glNumber
java.lang.String glNumber
glCategory
java.lang.String glCategory
categorySequence
java.lang.Integer categorySequence
description
java.lang.String description
totalDebit
java.math.BigDecimal totalDebit
totalCredit
java.math.BigDecimal totalCredit
origin
java.lang.String origin
approvalStatus
java.lang.String approvalStatus
approvedBy
java.lang.String approvedBy
Class bb.common.GLAutoApproveVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
glType
java.lang.String glType
approvedBy
java.lang.String approvedBy
autoApprove
boolean autoApprove
glCat
java.lang.String glCat
description
java.lang.String description
Class bb.common.GlBalanceInfoResult extends java.lang.Object implements Serializable

Serialized Fields

periodDebitAmount
java.math.BigDecimal periodDebitAmount
periodCreditAmount
java.math.BigDecimal periodCreditAmount
periodDC
java.lang.String periodDC
periodBalance
java.math.BigDecimal periodBalance
yearDebitAmount
java.math.BigDecimal yearDebitAmount
yearCreditAmount
java.math.BigDecimal yearCreditAmount
yearDC
java.lang.String yearDC
yearBalance
java.math.BigDecimal yearBalance
Class bb.common.GLByDateTotalResult extends java.lang.Object implements Serializable

Serialized Fields

startingBalanceCredit
java.math.BigDecimal startingBalanceCredit
startingBalanceDebit
java.math.BigDecimal startingBalanceDebit
totalDebit
java.math.BigDecimal totalDebit
totalCredit
java.math.BigDecimal totalCredit
endingBalanceCredit
java.math.BigDecimal endingBalanceCredit
endingBalanceDebit
java.math.BigDecimal endingBalanceDebit
Class bb.common.GlCashFlowBudgetVO extends VO implements Serializable

Serialized Fields

pk
AccountMonthPK pk
identifier field

accountType
java.lang.String accountType
persistent field

cf
java.lang.String cf
persistent field

budget
java.math.BigDecimal budget
persistent field

checked
boolean checked
Class bb.common.GLCatAndSequence extends java.lang.Object implements Serializable

Serialized Fields

glCategory
java.lang.String glCategory
categorySequence
java.lang.Integer categorySequence
glNumber
java.lang.String glNumber
Class bb.common.GLCheckRegisterResult extends java.lang.Object implements Serializable

Serialized Fields

accountNumber
java.lang.String accountNumber
accountDescription
java.lang.String accountDescription
companyUnit
java.lang.String companyUnit
fMonthYear
java.lang.String fMonthYear
tMonthYear
java.lang.String tMonthYear
id
java.lang.String id
checkType
java.lang.String checkType
results
java.util.Collection<E> results
Class bb.common.GLDebitCreditListResult extends GeneralLedgerListResult implements Serializable

Serialized Fields

accountNumber
java.lang.String accountNumber
debit
java.math.BigDecimal debit
credit
java.math.BigDecimal credit
Class bb.common.GlFiscalYearBudgetVO extends VO implements Serializable

Serialized Fields

pk
AccountMonthPK pk
identifier field

accountType
java.lang.String accountType
persistent field

budget
java.math.BigDecimal budget
persistent field

Class bb.common.GLInfoByPeriodResult extends java.lang.Object implements Serializable

Serialized Fields

beginBalance
java.math.BigDecimal beginBalance
debitOrCredit
java.lang.String debitOrCredit
showOriginal
boolean showOriginal
periodBalance
java.util.Map<K,V> periodBalance
dailyList
java.util.Map<K,V> dailyList
Class bb.common.GLItemVO extends VO implements Serializable

Serialized Fields

pk
AccountCreditDebitPK pk
transactionDate
java.util.Date transactionDate
transactionType
java.lang.String transactionType
addressId
java.lang.String addressId
accountNumber
java.lang.String accountNumber
credit
java.math.BigDecimal credit
currency
java.lang.String currency
originalCredit
java.math.BigDecimal originalCredit
description
java.lang.String description
exchange
java.math.BigDecimal exchange
companyUnitId
java.lang.String companyUnitId
accountsChart
AccountsChartVO accountsChart
alarmValue
boolean alarmValue
cause
java.lang.String cause
debit
java.math.BigDecimal debit
originalDebit
java.math.BigDecimal originalDebit
Class bb.common.GlMonthBudgetVO extends VO implements Serializable

Serialized Fields

monthYear
java.lang.String monthYear
identifier field

startMonth
java.util.Date startMonth
persistent field

endMonth
java.util.Date endMonth
persistent field

status
java.lang.String status
nullable persistent field

c7
java.lang.String c7
persistent field

Class bb.common.GlMonthVO extends VO implements Serializable

Serialized Fields

monthYear
java.lang.String monthYear
identifier field

startMonth
java.util.Date startMonth
persistent field

endMonth
java.util.Date endMonth
persistent field

status
java.lang.String status
nullable persistent field

c7
java.lang.String c7
persistent field

fy
java.lang.String fy
Class bb.common.GroupUserPK extends java.lang.Object implements Serializable

Serialized Fields

userName
java.lang.String userName
userGroup
java.lang.String userGroup
Class bb.common.GroupUserVO extends VO implements Serializable

Serialized Fields

pk
GroupUserPK pk
firstName
java.lang.String firstName
middleName
java.lang.String middleName
lastName
java.lang.String lastName
description
java.lang.String description
employeeId
java.lang.String employeeId
Class bb.common.HelpServerVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
helpServerIP
java.lang.String helpServerIP
helpServerPort
java.lang.String helpServerPort
wikiSpaceName
java.lang.String wikiSpaceName
spaceHomePage
java.lang.String spaceHomePage
language
java.lang.String language
actived
boolean actived
description
java.lang.String description
Class bb.common.HighUsagePartResult extends java.lang.Object implements Serializable

Serialized Fields

part
BB2Part part
description
java.lang.String description
ytrQty
java.math.BigDecimal ytrQty
qtr1Qty
java.math.BigDecimal qtr1Qty
qtr2Qty
java.math.BigDecimal qtr2Qty
qtr3Qty
java.math.BigDecimal qtr3Qty
qtr4Qty
java.math.BigDecimal qtr4Qty
vendors
java.util.List<E> vendors
Class bb.common.HistoricalInventoryTotalResult extends java.lang.Object implements Serializable

Serialized Fields

date
java.util.Date date
totalByAvgCost
java.math.BigDecimal totalByAvgCost
totalByStdCost
java.math.BigDecimal totalByStdCost
Class bb.common.HistoricalInventoryVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
date
java.util.Date date
partNumber
java.lang.String partNumber
partType
java.lang.String partType
description
java.lang.String description
onhand
java.math.BigDecimal onhand
workInProcessQty
java.math.BigDecimal workInProcessQty
shipInProcessQty
java.math.BigDecimal shipInProcessQty
shipInTransactionQty
java.math.BigDecimal shipInTransactionQty
inTOQty
java.math.BigDecimal inTOQty
onloanQty
java.math.BigDecimal onloanQty
consignedQty
java.math.BigDecimal consignedQty
inQualityCheckingQty
java.math.BigDecimal inQualityCheckingQty
onDemandQty
java.math.BigDecimal onDemandQty
onOrderQty
java.math.BigDecimal onOrderQty
listPrice
java.math.BigDecimal listPrice
averageCost
java.math.BigDecimal averageCost
standardCost
java.math.BigDecimal standardCost
lastOutDate
java.util.Date lastOutDate
lastInDate
java.util.Date lastInDate
Class bb.common.I18nEvent extends BB2Event implements Serializable

Serialized Fields

actionI18nKey
java.lang.String actionI18nKey
messageI18nKey
java.lang.String messageI18nKey
actionI18nParams
java.lang.String[] actionI18nParams
messageI18nParams
java.lang.String[] messageI18nParams
Class bb.common.IcrItemListResult extends VO implements Serializable

Serialized Fields

icrNumber
java.lang.String icrNumber
icrItemNumber
java.lang.String icrItemNumber
icrDate
java.util.Date icrDate
purchaseOrder
java.lang.String purchaseOrder
workOrder
java.lang.String workOrder
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
vendorId
java.lang.String vendorId
vendorName
java.lang.String vendorName
partRevision
java.lang.String partRevision
partDescription
java.lang.String partDescription
qtyCheck
java.math.BigDecimal qtyCheck
qtyQualified
java.math.BigDecimal qtyQualified
status
java.lang.String status
inspector
java.lang.String inspector
dateCheck
java.util.Date dateCheck
comments
java.lang.String comments
closedOutDate
java.util.Date closedOutDate
Class bb.common.IcrListResult extends java.lang.Object implements Serializable

Serialized Fields

icrNumber
java.lang.String icrNumber
icrDate
java.util.Date icrDate
purchaseOrder
java.lang.String purchaseOrder
workOrder
java.lang.String workOrder
vendorId
java.lang.String vendorId
vendorName
java.lang.String vendorName
status
java.lang.String status
closedOutDate
java.util.Date closedOutDate
comments
java.lang.String comments
Class bb.common.ImportContractPriceData extends VO implements Serializable

Serialized Fields

contractPrice
java.lang.String contractPrice
items
java.util.HashSet<E> items
customers
java.util.HashSet<E> customers
Class bb.common.ImportDataVO extends VO implements Serializable

Serialized Fields

ii
int ii
data
java.lang.Object data
errorMsg
java.lang.String errorMsg
Class bb.common.IncomeByMonthChartResult extends java.lang.Object implements Serializable

Serialized Fields

infoByMonthMap
java.util.Map<K,V> infoByMonthMap
totalAmount
java.math.BigDecimal totalAmount
pastDueAmount
java.math.BigDecimal pastDueAmount
Class bb.common.IncotermVO extends VO implements Serializable

Serialized Fields

id
java.lang.String id
description
java.lang.String description
place
java.lang.String place
Class bb.common.InfoByFiscalChartResult extends java.lang.Object implements Serializable

Serialized Fields

infoByMonthMap
java.util.Map<K,V> infoByMonthMap
infoTotalMap
java.util.Map<K,V> infoTotalMap
Class bb.common.InfoByMonthChartResult extends java.lang.Object implements Serializable

Serialized Fields

infoByMonthMap
java.util.Map<K,V> infoByMonthMap
infoTotalMap
java.util.Map<K,V> infoTotalMap
Class bb.common.InfoByMonthResult extends java.lang.Object implements Serializable

Serialized Fields

totalMoney
java.math.BigDecimal totalMoney
itemTotalCount
java.lang.Integer itemTotalCount
totalCount
java.lang.Integer totalCount
Class bb.common.InSipAudittListResult extends java.lang.Object implements Serializable

Serialized Fields

pk
PartPK pk
partFrom
java.lang.String partFrom
partDescription
java.lang.String partDescription
totSoSIPQty
java.math.BigDecimal totSoSIPQty
totPFSIPQty
java.math.BigDecimal totPFSIPQty
totInSIPQty
java.math.BigDecimal totInSIPQty
onhand
java.math.BigDecimal onhand
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
Class bb.common.InspectionConformanceReportItemCheckPK extends java.lang.Object implements Serializable

Serialized Fields

icrNumber
java.lang.String icrNumber
icrItemNumber
java.lang.String icrItemNumber
itemNumber
java.lang.String itemNumber
Class bb.common.InspectionConformanceReportItemCheckVO extends VO implements Serializable

Serialized Fields

pk
InspectionConformanceReportItemCheckPK pk
inspectProject
java.lang.String inspectProject
unit
java.lang.String unit
technolgyStandard
java.lang.String technolgyStandard
actualResult
java.lang.String actualResult
regulared
boolean regulared
Class bb.common.InspectionConformanceReportItemInfo extends java.lang.Object implements Serializable

Serialized Fields

item
InspectionConformanceReportItemVO item
purchaseOrder
java.lang.String purchaseOrder
workOrder
java.lang.String workOrder
lastChangeUser
java.lang.String lastChangeUser
vendorId
java.lang.String vendorId
vendorName
java.lang.String vendorName
Class bb.common.InspectionConformanceReportItemPK extends java.lang.Object implements Serializable

Serialized Fields

icrNumber
java.lang.String icrNumber
icrItemNumber
java.lang.String icrItemNumber
Class bb.common.InspectionConformanceReportItemVO extends VO implements Serializable

Serialized Fields

pk
InspectionConformanceReportItemPK pk
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
partRevision
java.lang.String partRevision
partDescription
java.lang.String partDescription
qtyCheck
java.math.BigDecimal qtyCheck
qtyQualified
java.math.BigDecimal qtyQualified
qtyReject
java.math.BigDecimal qtyReject
status
java.lang.String status
inspector
java.lang.String inspector
dateCheck
java.util.Date dateCheck
comments
java.lang.String comments
icrItemChecks
java.util.Set<E> icrItemChecks
refDocOnes
java.util.Set<E> refDocOnes
refDocTwoes
java.util.Set<E> refDocTwoes
Class bb.common.InspectionConformanceReportVO extends VO implements Serializable

Serialized Fields

icrNumber
java.lang.String icrNumber
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
version
java.lang.Integer version
icrDate
java.util.Date icrDate
adate
java.util.Date adate
origin
java.lang.String origin
purchaseOrder
java.lang.String purchaseOrder
workOrder
java.lang.String workOrder
transferShipperNumber
java.lang.String transferShipperNumber
vendorId
java.lang.String vendorId
status
java.lang.String status
closedOutDate
java.util.Date closedOutDate
comments
java.lang.String comments
processInspection
boolean processInspection
icrItems
java.util.Set<E> icrItems
vendorAddressInfo
CustomerVendorAddressInfoVO vendorAddressInfo
icrDocuments
java.util.Set<E> icrDocuments
Class bb.common.InspectionItemPK extends java.lang.Object implements Serializable

Serialized Fields

operatingInstructionsTypeId
java.lang.Integer operatingInstructionsTypeId
itemNumber
java.lang.String itemNumber
Class bb.common.InspectionItemVO extends VO implements Serializable

Serialized Fields

pk
InspectionItemPK pk
inspectionDescription
java.lang.String inspectionDescription
inspectionRequest
java.lang.String inspectionRequest
Class bb.common.InspectionReportInfoVO extends VO implements Serializable

Serialized Fields

inspectionReportNumber
java.lang.String inspectionReportNumber
printedBoardNumber
java.lang.String printedBoardNumber
drawingNumber
java.lang.String drawingNumber
operatingEnvironment
boolean operatingEnvironment
pickListOrderNumber
java.lang.String pickListOrderNumber
quantity
java.math.BigDecimal quantity
sealWorker
java.lang.String sealWorker
measureWorker
java.lang.String measureWorker
cleanWorker
java.lang.String cleanWorker
checkEachOther
boolean checkEachOther
goodQty
java.math.BigDecimal goodQty
rejectQty
java.math.BigDecimal rejectQty
rejectReason
java.lang.String rejectReason
inspectionResult
java.lang.String inspectionResult
inspector
java.lang.String inspector
inspectionReportDate
java.util.Date inspectionReportDate
operatingInstructionsNumber
java.lang.String operatingInstructionsNumber
operatingInstructionsTypeId
java.lang.Integer operatingInstructionsTypeId
operatingInstructionsType
OperatingInstructionsTypeVO operatingInstructionsType
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
adate
java.util.Date adate
origin
java.lang.String origin
version
java.lang.Integer version
Class bb.common.InspectionReportInspectMethodItemPK extends java.lang.Object implements Serializable

Serialized Fields

inspectionReportNumber
java.lang.String inspectionReportNumber
ii
java.lang.Integer ii
Class bb.common.InspectionReportInspectMethodItemVO extends VO implements Serializable

Serialized Fields

pk
InspectionReportInspectMethodItemPK pk
inspectionReportInspectMethod
InspectionReportInspectMethodVO inspectionReportInspectMethod
Class bb.common.InspectionReportInspectMethodVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Integer ii
description
java.lang.String description
Class bb.common.InspectionReportInspectStandardItemPK extends java.lang.Object implements Serializable

Serialized Fields

inspectionReportNumber
java.lang.String inspectionReportNumber
ii
java.lang.Integer ii
Class bb.common.InspectionReportInspectStandardItemVO extends VO implements Serializable

Serialized Fields

pk
InspectionReportInspectStandardItemPK pk
inspectionReportInspectStandard
OperatingInstructionsInspectStandardVO inspectionReportInspectStandard
Class bb.common.InspectionReportItemPK extends java.lang.Object implements Serializable

Serialized Fields

inspectionReportNumber
java.lang.String inspectionReportNumber
itemNumber
java.lang.String itemNumber
Class bb.common.InspectionReportItemQtyPK extends java.lang.Object implements Serializable

Serialized Fields

inspectionReportNumber
java.lang.String inspectionReportNumber
itemNumber
java.lang.String itemNumber
ii
java.lang.Byte ii
Class bb.common.InspectionReportItemQtyVO extends VO implements Serializable

Serialized Fields

pk
InspectionReportItemQtyPK pk
Class bb.common.InspectionReportItemVO extends VO implements Serializable

Serialized Fields

pk
InspectionReportItemPK pk
items
java.util.Set<E> items
Class bb.common.InspectionReportVO extends VO implements Serializable

Serialized Fields

inspectionReportNumber
java.lang.String inspectionReportNumber
printedBoardNumber
java.lang.String printedBoardNumber
drawingNumber
java.lang.String drawingNumber
operatingEnvironment
boolean operatingEnvironment
pickListOrderNumber
java.lang.String pickListOrderNumber
quantity
java.math.BigDecimal quantity
sealWorker
java.lang.String sealWorker
measureWorker
java.lang.String measureWorker
cleanWorker
java.lang.String cleanWorker
checkEachOther
boolean checkEachOther
inspectionReportInspectStandardItems
java.util.Set<E> inspectionReportInspectStandardItems
inspectionReportInspectMethodItems
java.util.Set<E> inspectionReportInspectMethodItems
inspectionReportItems
java.util.Set<E> inspectionReportItems
goodQty
java.math.BigDecimal goodQty
rejectQty
java.math.BigDecimal rejectQty
rejectReason
java.lang.String rejectReason
inspectionResult
java.lang.String inspectionResult
inspector
java.lang.String inspector
inspectionReportDate
java.util.Date inspectionReportDate
operatingInstructionsNumber
java.lang.String operatingInstructionsNumber
operatingInstructionsTypeId
java.lang.Integer operatingInstructionsTypeId
operatingInstructionsType
OperatingInstructionsTypeVO operatingInstructionsType
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
adate
java.util.Date adate
origin
java.lang.String origin
version
java.lang.Integer version
Class bb.common.InspectionTypeItemPK extends java.lang.Object implements Serializable

Serialized Fields

inspectionType
java.lang.String inspectionType
itemNumber
java.lang.String itemNumber
Class bb.common.InspectionTypeItemVO extends VO implements Serializable

Serialized Fields

pk
InspectionTypeItemPK pk
inspectProject
java.lang.String inspectProject
unit
java.lang.String unit
technolgyStandard
java.lang.String technolgyStandard
Class bb.common.InspectionTypeVO extends VO implements Serializable

Serialized Fields

inspectionType
java.lang.String inspectionType
note
java.lang.String note
inspectionTypeItems
java.util.Set<E> inspectionTypeItems
Class bb.common.InventoryAdjustmentDetailResult extends java.lang.Object implements Serializable

Serialized Fields

lastAdjustment
InventoryAdjustmentVO lastAdjustment
totalOnhand
java.math.BigDecimal totalOnhand
averageCostResultList
java.util.List<E> averageCostResultList
partInventoryInfo
PartInventoryVO partInventoryInfo
toolInventoryInfo
ToolInventoryVO toolInventoryInfo
partInfo
PartBasicInfo partInfo
toolInfo
ToolBasicInfo toolInfo
partFrom
java.lang.String partFrom
Class bb.common.InventoryAdjustmentListResult extends InventoryAdjustmentVO implements Serializable

Serialized Fields

description
java.lang.String description
Class bb.common.InventoryAdjustmentVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
identifier field

partNumber
java.lang.String partNumber
partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

countedDate
java.util.Date countedDate
persistent field

countedBy
java.lang.String countedBy
persistent field

oldOnhandQty
java.math.BigDecimal oldOnhandQty
persistent field

newOnhandQty
java.math.BigDecimal newOnhandQty
persistent field

oldCost
java.math.BigDecimal oldCost
persistent field

newCost
java.math.BigDecimal newCost
persistent field

comments
java.lang.String comments
nullable persistent field

version
java.lang.Integer version
nullable persistent field

Class bb.common.InventoryAmountByMonth extends java.lang.Object implements Serializable

Serialized Fields

avgCost
java.util.Map<K,V> avgCost
stdCost
java.util.Map<K,V> stdCost
Class bb.common.InventoryAuditReportResult extends InventoryReportListResult implements Serializable

Serialized Fields

totalAdjustQty
java.math.BigDecimal totalAdjustQty
totalAdjustMoney
java.math.BigDecimal totalAdjustMoney
totalCountOnhandQty
java.math.BigDecimal totalCountOnhandQty
totalVarOnhandQty
java.math.BigDecimal totalVarOnhandQty
Class bb.common.InventoryCycleItemResult extends java.lang.Object implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

onhand
java.math.BigDecimal onhand
location
java.lang.String location
count
java.lang.Integer count
Class bb.common.InventoryCycleResult extends java.lang.Object implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

part
BB2Part part
description
java.lang.String description
partUnit
java.lang.String partUnit
totOnhand
java.math.BigDecimal totOnhand
items
java.util.Set<E> items
Class bb.common.InventoryListResult extends java.lang.Object implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

part
BB2Part part
description
java.lang.String description
onhand
java.math.BigDecimal onhand
inQa
java.math.BigDecimal inQa
inWip
java.math.BigDecimal inWip
inSip
java.math.BigDecimal inSip
totalInventory
java.math.BigDecimal totalInventory
onOrder
java.math.BigDecimal onOrder
onDemand
java.math.BigDecimal onDemand
cost
java.math.BigDecimal cost
standardCost
java.math.BigDecimal standardCost
listPrice
java.math.BigDecimal listPrice
minQty
java.math.BigDecimal minQty
maxQty
java.math.BigDecimal maxQty
location
java.lang.String location
commodityCode
java.lang.String commodityCode
modelNumber
java.lang.String modelNumber
productCode
java.lang.String productCode
buyercode
java.lang.String buyercode
lastInDate
java.util.Date lastInDate
lastOutDate
java.util.Date lastOutDate
onLoan
java.math.BigDecimal onLoan
inSTO
java.math.BigDecimal inSTO
shortage
java.math.BigDecimal shortage
minOrder
java.math.BigDecimal minOrder
sold
java.math.BigDecimal sold
profitMarginByAvgCost
java.math.BigDecimal profitMarginByAvgCost
Class bb.common.InventoryMonthReport extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
partType
java.lang.String partType
startQty
java.math.BigDecimal startQty
startCost
java.math.BigDecimal startCost
startAmount
java.math.BigDecimal startAmount
inQty
java.math.BigDecimal inQty
inCost
java.math.BigDecimal inCost
inAmount
java.math.BigDecimal inAmount
outQty
java.math.BigDecimal outQty
outCost
java.math.BigDecimal outCost
outAmount
java.math.BigDecimal outAmount
endQty
java.math.BigDecimal endQty
endCost
java.math.BigDecimal endCost
endAmount
java.math.BigDecimal endAmount
description
java.lang.String description
startQaQty
java.math.BigDecimal startQaQty
startWipQty
java.math.BigDecimal startWipQty
startQaAmount
java.math.BigDecimal startQaAmount
startWipAmount
java.math.BigDecimal startWipAmount
endQaQty
java.math.BigDecimal endQaQty
endWipQty
java.math.BigDecimal endWipQty
endQaAmount
java.math.BigDecimal endQaAmount
endWipAmount
java.math.BigDecimal endWipAmount
location
java.lang.String location
stdCost
java.math.BigDecimal stdCost
shippingWeight
java.math.BigDecimal shippingWeight
shippingWeightUnit
java.lang.String shippingWeightUnit
overageQty
java.math.BigDecimal overageQty
overageAmount
java.math.BigDecimal overageAmount
shortageQty
java.math.BigDecimal shortageQty
shortageAmount
java.math.BigDecimal shortageAmount
Class bb.common.InventoryNotUsedInMonthsforAppResult extends InventoryNotUsedInMonthsResult implements Serializable

Serialized Fields

modelNumber
java.lang.String modelNumber
unit
java.lang.String unit
stockMonth
java.lang.Integer stockMonth
partNumber
java.lang.String partNumber
partType
java.lang.String partType
serialNumber
int serialNumber
Class bb.common.InventoryNotUsedInMonthsResult extends java.lang.Object implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

part
BB2Part part
rev
java.lang.String rev
dwg
java.lang.String dwg
bill
java.lang.String bill
description
java.lang.String description
locate
java.lang.String locate
onhand
java.math.BigDecimal onhand
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
extAvgCost
java.math.BigDecimal extAvgCost
extStdCost
java.math.BigDecimal extStdCost
lastUsedDate
java.util.Date lastUsedDate
lastInDate
java.util.Date lastInDate
lastOutDate
java.util.Date lastOutDate
Class bb.common.InventoryNotUsedTotal extends java.lang.Object implements Serializable

Serialized Fields

totalAvgCost
java.math.BigDecimal totalAvgCost
totalStdCost
java.math.BigDecimal totalStdCost
Class bb.common.InventoryPartInOutDetailListResult extends VO implements Serializable

Serialized Fields

ser
int ser
partType
java.lang.String partType
orderNumber
java.lang.String orderNumber
partNumber
java.lang.String partNumber
partFrom
java.lang.String partFrom
model
java.lang.String model
unit
java.lang.String unit
costPerUnit
java.math.BigDecimal costPerUnit
periodNumber
java.math.BigDecimal periodNumber
periodTotalCost
java.math.BigDecimal periodTotalCost
inQty
java.math.BigDecimal inQty
inTotalCost
java.math.BigDecimal inTotalCost
outQty
java.math.BigDecimal outQty
outTotalCost
java.math.BigDecimal outTotalCost
totalQty
java.math.BigDecimal totalQty
totalCost
java.math.BigDecimal totalCost
comments
java.lang.String comments
desc
java.lang.String desc
overageQty
java.math.BigDecimal overageQty
overageAmount
java.math.BigDecimal overageAmount
shortageQty
java.math.BigDecimal shortageQty
shortageAmount
java.math.BigDecimal shortageAmount
Class bb.common.InventoryReportListResult extends java.lang.Object implements Serializable

Serialized Fields

dateFrom
java.util.Date dateFrom
dateTo
java.util.Date dateTo
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partDescription
java.lang.String partDescription
newSipQty
java.math.BigDecimal newSipQty
newSitQty
java.math.BigDecimal newSitQty
newLnQty
java.math.BigDecimal newLnQty
newQaQty
java.math.BigDecimal newQaQty
oldSipQty
java.math.BigDecimal oldSipQty
oldSitQty
java.math.BigDecimal oldSitQty
oldLnQty
java.math.BigDecimal oldLnQty
oldQaQty
java.math.BigDecimal oldQaQty
totalOldOnhand
java.math.BigDecimal totalOldOnhand
totalNewOnhand
java.math.BigDecimal totalNewOnhand
totalOldCost
java.math.BigDecimal totalOldCost
totalNewCost
java.math.BigDecimal totalNewCost
totalIssued
java.math.BigDecimal totalIssued
totalIssuedMoney
java.math.BigDecimal totalIssuedMoney
totalReceived
java.math.BigDecimal totalReceived
totalRecMoney
java.math.BigDecimal totalRecMoney
Class bb.common.InventoryTotalCostResult extends java.lang.Object implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

totalOnhandAvgCost
java.math.BigDecimal totalOnhandAvgCost
totalOnhandStdCost
java.math.BigDecimal totalOnhandStdCost
totalOnhandListPrice
java.math.BigDecimal totalOnhandListPrice
totalInQaAvgCost
java.math.BigDecimal totalInQaAvgCost
totalInQaStdCost
java.math.BigDecimal totalInQaStdCost
totalInQaListPrice
java.math.BigDecimal totalInQaListPrice
totalInWipAvgCost
java.math.BigDecimal totalInWipAvgCost
totalInWipStdCost
java.math.BigDecimal totalInWipStdCost
totalInWipListPrice
java.math.BigDecimal totalInWipListPrice
totalInSipStdCost
java.math.BigDecimal totalInSipStdCost
totalInSipAvgCost
java.math.BigDecimal totalInSipAvgCost
totalInSipListPrice
java.math.BigDecimal totalInSipListPrice
totalInventoryAvgCost
java.math.BigDecimal totalInventoryAvgCost
totalInventoryStdCost
java.math.BigDecimal totalInventoryStdCost
totalInventoryListPrice
java.math.BigDecimal totalInventoryListPrice
totalOnLoanAvgCost
java.math.BigDecimal totalOnLoanAvgCost
totalOnLoanStdCost
java.math.BigDecimal totalOnLoanStdCost
totalOnLoanListPrice
java.math.BigDecimal totalOnLoanListPrice
totalInSTOAvgCost
java.math.BigDecimal totalInSTOAvgCost
totalInSTOStdCost
java.math.BigDecimal totalInSTOStdCost
totalInSTOListPrice
java.math.BigDecimal totalInSTOListPrice
date
java.util.Date date
Class bb.common.InventoryTotalResult extends java.lang.Object implements Serializable

Serialized Fields

totalInWareHouseByAvgCost
java.math.BigDecimal totalInWareHouseByAvgCost
totalInWipByAvgCost
java.math.BigDecimal totalInWipByAvgCost
totalInQaByAvgCost
java.math.BigDecimal totalInQaByAvgCost
totalOnloanByAvgCost
java.math.BigDecimal totalOnloanByAvgCost
totalOnconsignmentByAvgCost
java.math.BigDecimal totalOnconsignmentByAvgCost
totalInShippingNotArByAvgCost
java.math.BigDecimal totalInShippingNotArByAvgCost
onorderByAvgCost
java.math.BigDecimal onorderByAvgCost
ondemandByAvgCost
java.math.BigDecimal ondemandByAvgCost
minQtyByAvgCost
java.math.BigDecimal minQtyByAvgCost
maxQtyByAvgCost
java.math.BigDecimal maxQtyByAvgCost
totalInWareHouseByStdCost
java.math.BigDecimal totalInWareHouseByStdCost
totalInWipByStdCost
java.math.BigDecimal totalInWipByStdCost
totalInQaByStdCost
java.math.BigDecimal totalInQaByStdCost
totalOnloanByStdCost
java.math.BigDecimal totalOnloanByStdCost
totalOnconsignmentByStdCost
java.math.BigDecimal totalOnconsignmentByStdCost
totalInShippingNotArByStdCost
java.math.BigDecimal totalInShippingNotArByStdCost
onorderByStdCost
java.math.BigDecimal onorderByStdCost
ondemandByStdCost
java.math.BigDecimal ondemandByStdCost
minQtyByStdCost
java.math.BigDecimal minQtyByStdCost
maxQtyByStdCost
java.math.BigDecimal maxQtyByStdCost
Class bb.common.InvoiceAgingItemListResult extends InvoiceItemListResult implements Serializable

Class bb.common.InvoiceItemListResult extends java.lang.Object implements Serializable

Serialized Fields

invoiceNumber
java.lang.String invoiceNumber
invoiceItemNumber
java.lang.String invoiceItemNumber
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
description
java.lang.String description
customerId
java.lang.String customerId
customerPo
java.lang.String customerPo
creditAccount
java.lang.String creditAccount
status
java.lang.String status
salesOrderNumber
java.lang.String salesOrderNumber
shipperNumber
java.lang.String shipperNumber
shipToState
java.lang.String shipToState
shipToCountry
java.lang.String shipToCountry
shipToId
java.lang.String shipToId
companyUnitId
java.lang.String companyUnitId
qtyOrdered
java.math.BigDecimal qtyOrdered
qtyShipped
java.math.BigDecimal qtyShipped
unitPrice
java.math.BigDecimal unitPrice
taxRate
java.math.BigDecimal taxRate
dicount
java.math.BigDecimal dicount
extPrice
java.math.BigDecimal extPrice
due
java.math.BigDecimal due
margin
java.math.BigDecimal margin
marginPercent
java.math.BigDecimal marginPercent
paidDate
java.util.Date paidDate
dateInvoiced
java.util.Date dateInvoiced
payDate
java.util.Date payDate
currency
java.lang.String currency
productCode
java.lang.String productCode
customerTostate
java.lang.String customerTostate
customerToCountry
java.lang.String customerToCountry
Class bb.common.InvokeException extends BB2ServerException implements Serializable

Class bb.common.IpAddressVO extends VO implements Serializable

Serialized Fields

id
java.lang.Long id
identifier field

ip1
java.lang.Long ip1
nullable persistent field

ip2
java.lang.Long ip2
nullable persistent field

country
java.lang.String country
nullable persistent field

city
java.lang.String city
nullable persistent field

Class bb.common.IssuedFromOrderItem extends java.lang.Object implements Serializable

Serialized Fields

orderNumber
java.lang.String orderNumber
itemNumber
java.lang.String itemNumber
issuedFrom
java.lang.String issuedFrom
issuedLocate
java.lang.String issuedLocate
availQty
java.math.BigDecimal availQty
cost
java.math.BigDecimal cost
partInQAII
int partInQAII
Class bb.common.IssueItemAgent extends java.lang.Object implements Serializable

Serialized Fields

workOrderItemPk
WorkOrderItemPK workOrderItemPk
IssueItemAgent: describe how to issue parts to WorkOrderItem or DisassembleWorkOrder.

itemNumber
java.lang.Short itemNumber
isGroup
java.lang.Boolean isGroup
partPk
PartPK partPk
partFrom
java.lang.String partFrom
serial
java.lang.String serial
lot
java.lang.String lot
picker
java.lang.String picker
totalIssuedQty
java.math.BigDecimal totalIssuedQty
avgCost
java.math.BigDecimal avgCost
issueItemDetails
java.util.Set<E> issueItemDetails
orderPk
OrderPK orderPk
Class bb.common.IssueItemDetailAgent extends java.lang.Object implements Serializable

Serialized Fields

issuedFrom
java.lang.String issuedFrom
IssueItemDetailAgent: describe the details how to issue the material

locate
java.lang.String locate
issuedQty
java.math.BigDecimal issuedQty
cost
java.math.BigDecimal cost
orderNumber
java.lang.String orderNumber
trackingLog
java.util.Set<E> trackingLog
Class bb.common.IssuingItemResult extends java.lang.Object implements Serializable

Serialized Fields

workOrderItemPK
WorkOrderItemPK workOrderItemPK
IssuingItemResult: a Object wrapping the requirement information of a type of materials

itemNumber
java.lang.Short itemNumber
isGroup
java.lang.Boolean isGroup
partPk
PartPK partPk
partFrom
java.lang.String partFrom
revision
java.lang.String revision
description
java.lang.String description
traceable
boolean traceable
quantity
java.math.BigDecimal quantity
quantityIssued
java.math.BigDecimal quantityIssued
serial
java.lang.String serial
lot
java.lang.String lot
cost
java.math.BigDecimal cost
avgCost
java.math.BigDecimal avgCost
partLocations
java.util.Set<E> partLocations
othersLocations
java.util.Set<E> othersLocations
totalOnhand
java.math.BigDecimal totalOnhand
ondemand
java.math.BigDecimal ondemand
minIssued
java.math.BigDecimal minIssued
maxIssued
java.math.BigDecimal maxIssued
scrapQty
java.math.BigDecimal scrapQty
partTracking
java.util.Set<E> partTracking
Class bb.common.IssuingResult extends java.lang.Object implements Serializable

Serialized Fields

orderNumber
java.lang.String orderNumber
IssuingResult: used to wrap the WorkOrder and WorkOrderItem gerneral Information which is displayed the UI of Issuing part to WorkOrderItem

itemNumber
java.lang.String itemNumber
orderDate
java.util.Date orderDate
vendorId
java.lang.String vendorId
billId
java.lang.String billId
shipId
java.lang.String shipId
changeOrder
java.lang.String changeOrder
project
java.lang.String project
shipvia
java.lang.String shipvia
orderStatus
java.lang.String orderStatus
approvedDate
java.util.Date approvedDate
approvedBy
java.lang.String approvedBy
partPk
PartPK partPk
partFrom
java.lang.String partFrom
revision
java.lang.String revision
drawing
java.lang.String drawing
description
java.lang.String description
quantity
java.math.BigDecimal quantity
quantityAsm
java.math.BigDecimal quantityAsm
unit
java.lang.String unit
requireDate
java.util.Date requireDate
itemStatus
java.lang.String itemStatus
refDoc1
java.lang.String refDoc1
refDoc2
java.lang.String refDoc2
issuingItems
java.util.Set<E> issuingItems
costControlAgent
WOItemCostControlAgent costControlAgent
Class bb.common.JobProcessSheetItemResult extends java.lang.Object implements Serializable

Serialized Fields

seqNumber
java.lang.String seqNumber
workCenter
java.lang.String workCenter
wcDescription
java.lang.String wcDescription
goodQty
java.math.BigDecimal goodQty
rejectQty
java.math.BigDecimal rejectQty
requiredDate
java.util.Date requiredDate
inspectedDate
java.util.Date inspectedDate
inspectedBy
java.lang.String inspectedBy
Class bb.common.JobProcessSheetListResult extends java.lang.Object implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

woItemItemPk
WorkOrderItemPK woItemItemPk
partPk
PartPK partPk
partFrom
java.lang.String partFrom
description
java.lang.String description
quantity
java.math.BigDecimal quantity
quantityAsm
java.math.BigDecimal quantityAsm
dueDate
java.util.Date dueDate
refDoc1
java.lang.String refDoc1
refDoc2
java.lang.String refDoc2
status
java.lang.String status
vendorId
java.lang.String vendorId
setId
java.lang.String setId
Class bb.common.JobProcessSheetResult extends java.lang.Object implements Serializable

Serialized Fields

woNumber
java.lang.String woNumber
woItemNumber
java.lang.String woItemNumber
partFrom
java.lang.String partFrom
description
java.lang.String description
partPK
PartPK partPK
qty
java.math.BigDecimal qty
dueDate
java.util.Date dueDate
seqs
java.util.Set<E> seqs
setId
java.lang.String setId
vendorId
java.lang.String vendorId
woComments
java.lang.String woComments
itemComments
java.lang.String itemComments
Class bb.common.JounalEntryListResult extends java.lang.Object implements Serializable

Serialized Fields

transactionNumber
java.lang.String transactionNumber
categoryId
java.lang.String categoryId
categorySequence
java.lang.Integer categorySequence
transactionDate
java.util.Date transactionDate
description
java.lang.String description
debitAccount
java.lang.String debitAccount
creditAccount
java.lang.String creditAccount
relevantAccount
java.lang.String relevantAccount
debitAmount
java.math.BigDecimal debitAmount
creditAmount
java.math.BigDecimal creditAmount
exchange
java.math.BigDecimal exchange
originalDebitAmount
java.math.BigDecimal originalDebitAmount
originalCreditAmount
java.math.BigDecimal originalCreditAmount
debitOrCredit
java.lang.String debitOrCredit
balance
java.math.BigDecimal balance
originalBalance
java.math.BigDecimal originalBalance
summary
java.lang.String summary
relevantAccountDescription
java.lang.String relevantAccountDescription
currency
java.lang.String currency
posted
boolean posted
Class bb.common.LabelTemplateConstant extends java.lang.Object implements Serializable

Class bb.common.LabelTemplateItemPK extends java.lang.Object implements Serializable

Serialized Fields

ii
java.lang.Integer ii
itemNumber
java.lang.String itemNumber
Class bb.common.LabelTemplateItemVO extends VO implements Serializable

Serialized Fields

pk
LabelTemplateItemPK pk
itemType
java.lang.String itemType
name
java.lang.String name
labelVisible
boolean labelVisible
labelPosition
int labelPosition
x
int x
y
int y
width
int width
height
int height
font
java.lang.String font
fontSize
int fontSize
italic
boolean italic
strikeThrough
boolean strikeThrough
underline
boolean underline
Class bb.common.LabelTemplateVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Integer ii
labelType
java.lang.String labelType
active
boolean active
name
java.lang.String name
comments
java.lang.String comments
width
int width
height
int height
items
java.util.Set<E> items
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
adate
java.util.Date adate
origin
java.lang.String origin
version
java.lang.Integer version
portraitOrientation
boolean portraitOrientation
Class bb.common.ListCache extends java.lang.Object implements Serializable

Serialized Fields

s
boolean s
h
java.util.HashSet<E> h
hm
java.util.HashMap<K,V> hm
Class bb.common.LnShipperItemListResult extends java.lang.Object implements Serializable

Serialized Fields

lnShipperNumber
java.lang.String lnShipperNumber
lnShipperItemNumber
java.lang.String lnShipperItemNumber
loanNumber
java.lang.String loanNumber
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
description
java.lang.String description
serialNumber
java.lang.String serialNumber
quantity
java.math.BigDecimal quantity
quantityShip
java.math.BigDecimal quantityShip
customerId
java.lang.String customerId
customerName
java.lang.String customerName
dateShipped
java.util.Date dateShipped
listPrice
java.math.BigDecimal listPrice
status
java.lang.String status
Class bb.common.LnShipperListResult extends java.lang.Object implements Serializable

Serialized Fields

lnShipperNumber
java.lang.String lnShipperNumber
dateShipped
java.util.Date dateShipped
customerId
java.lang.String customerId
loanNumber
java.lang.String loanNumber
salesman
java.lang.String salesman
comments
java.lang.String comments
status
java.lang.String status
customerName
java.lang.String customerName
changeOrder
java.lang.String changeOrder
Class bb.common.LocationResult extends java.lang.Object implements Serializable

Serialized Fields

location
java.lang.String location
locationCount
java.lang.Integer locationCount
Class bb.common.LockedCustomerAddressResult extends java.lang.Object implements Serializable

Serialized Fields

id
java.lang.String id
customerFlag
java.lang.String customerFlag
vendorFlag
java.lang.String vendorFlag
vendorCategory
java.lang.String vendorCategory
criticalLevel
java.lang.String criticalLevel
qualityStatus
java.lang.String qualityStatus
name
java.lang.String name
city
java.lang.String city
state
java.lang.String state
zip
java.lang.String zip
country
java.lang.String country
comments
java.lang.String comments
alarmValue
boolean alarmValue
cause
java.lang.String cause
Class bb.common.LoginException extends BB2ServerException implements Serializable

Class bb.common.LogInventoryListResult extends java.lang.Object implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
employee
java.lang.String employee
date
java.util.Date date
inQty
java.math.BigDecimal inQty
inCost
java.math.BigDecimal inCost
outQty
java.math.BigDecimal outQty
outCost
java.math.BigDecimal outCost
newOnhand
java.math.BigDecimal newOnhand
oldOnhand
java.math.BigDecimal oldOnhand
newInQA
java.math.BigDecimal newInQA
oldInQA
java.math.BigDecimal oldInQA
newSip
java.math.BigDecimal newSip
oldSip
java.math.BigDecimal oldSip
newSit
java.math.BigDecimal newSit
oldSit
java.math.BigDecimal oldSit
newWip
java.math.BigDecimal newWip
oldWip
java.math.BigDecimal oldWip
newInTO
java.math.BigDecimal newInTO
oldInTO
java.math.BigDecimal oldInTO
newCost
java.math.BigDecimal newCost
oldCost
java.math.BigDecimal oldCost
refDoc1
java.lang.String refDoc1
refDoc2
java.lang.String refDoc2
description
java.lang.String description
location
java.lang.String location
poRelateDoc
java.lang.String poRelateDoc
poVender
java.lang.String poVender
Class bb.common.LogInventoryVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
identifier field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

inQty
java.math.BigDecimal inQty
persistent field

inCost
java.math.BigDecimal inCost
nullable persistent field

outQty
java.math.BigDecimal outQty
nullable persistent field

outCost
java.math.BigDecimal outCost
newOnhand
java.math.BigDecimal newOnhand
persistent field

oldOnhand
java.math.BigDecimal oldOnhand
persistent field

newInQA
java.math.BigDecimal newInQA
persistent field

oldInQA
java.math.BigDecimal oldInQA
persistent field

newSip
java.math.BigDecimal newSip
persistent field

oldSip
java.math.BigDecimal oldSip
persistent field

newSit
java.math.BigDecimal newSit
persistent field

oldSit
java.math.BigDecimal oldSit
persistent field

newWip
java.math.BigDecimal newWip
oldWip
java.math.BigDecimal oldWip
newCost
java.math.BigDecimal newCost
persistent field

oldCost
java.math.BigDecimal oldCost
persistent field

refDoc1
java.lang.String refDoc1
persistent field

refDoc2
java.lang.String refDoc2
persistent field

serial
java.lang.String serial
persistent field

location
java.lang.String location
stdCost
java.math.BigDecimal stdCost
Class bb.common.LogMethodPK extends java.lang.Object implements Serializable

Serialized Fields

ejbName
java.lang.String ejbName
methodName
java.lang.String methodName
Class bb.common.LogMethodVO extends VO implements Serializable

Serialized Fields

pk
LogMethodPK pk
needLog
boolean needLog
Class bb.common.LogMiscDocumentVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
docType
java.lang.String docType
orderNumber
java.lang.String orderNumber
orderItemNumber
java.lang.String orderItemNumber
controlNumber
long controlNumber
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
rv
java.lang.String rv
action
java.lang.String action
lastChangeUser
java.lang.String lastChangeUser
lastchangeDate
java.util.Date lastchangeDate
wanIp
java.lang.String wanIp
lanIp
java.lang.String lanIp
macAddress
java.lang.String macAddress
description
java.lang.String description
docFileName
java.lang.String docFileName
extension
java.lang.String extension
docLength
long docLength
yearCode
java.lang.String yearCode
companyUnitId
java.lang.String companyUnitId
Class bb.common.LogPartDocumentVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
identifier field

partNumber
java.lang.String partNumber
persistent field

documentType
java.lang.String documentType
nullable persistent field

language
java.lang.String language
persistent field

docVersion
java.lang.String docVersion
persistent field

action
java.lang.String action
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

wanIp
java.lang.String wanIp
persistent field

lanIp
java.lang.String lanIp
persistent field

macAddress
java.lang.String macAddress
persistent field

publicDoc
boolean publicDoc
persistent field

description
java.lang.String description
persistent field

documentLengthByte
java.lang.Long documentLengthByte
nullable persistent field

extension
java.lang.String extension
Class bb.common.LogPartDwfVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
identifier field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

revision
java.lang.String revision
persistent field

language
java.lang.String language
partFrom
java.lang.String partFrom
identifier field

action
java.lang.String action
persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

wanIp
java.lang.String wanIp
persistent field

lanIp
java.lang.String lanIp
persistent field

macAddress
java.lang.String macAddress
persistent field

description
java.lang.String description
persistent field

dwfExtension
java.lang.String dwfExtension
persistent field

dwfLength
long dwfLength
persistent field

bb2count
java.lang.Integer bb2count
Class bb.common.LogPartDwgVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
identifier field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

revision
java.lang.String revision
persistent field

partFrom
java.lang.String partFrom
identifier field

action
java.lang.String action
persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

wanIp
java.lang.String wanIp
persistent field

lanIp
java.lang.String lanIp
persistent field

macAddress
java.lang.String macAddress
persistent field

description
java.lang.String description
persistent field

dwgExtension
java.lang.String dwgExtension
persistent field

dwgLength
long dwgLength
persistent field

bb2count
java.lang.Integer bb2count
Class bb.common.LogTaskVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
identifier field

taskId
java.lang.Long taskId
name
java.lang.String name
persistent field

description
java.lang.String description
persistent field

startDate
java.util.Date startDate
nullable persistent field

endDate
java.util.Date endDate
nullable persistent field

comments
java.lang.String comments
persistent field

success
boolean success
Class bb.common.LogTrackingVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
partNumber
java.lang.String partNumber
partType
java.lang.String partType
description
java.lang.String description
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
inQty
java.math.BigDecimal inQty
outQty
java.math.BigDecimal outQty
trackingNumber
java.lang.String trackingNumber
refDoc1
java.lang.String refDoc1
refDoc2
java.lang.String refDoc2
location
java.lang.String location
operationType
int operationType
addressId
java.lang.String addressId
addressName
java.lang.String addressName
Class bb.common.MaintenanceItemPK extends java.lang.Object implements Serializable

Serialized Fields

equimentId
java.lang.String equimentId
identifier field

ii
java.lang.Integer ii
identifier field

Class bb.common.MaintenanceItemVO extends VO implements Serializable

Serialized Fields

pk
MaintenanceItemPK pk
identifier field

maintenanceDate
java.util.Date maintenanceDate
nullable persistent field

type
java.lang.String type
persistent field

maintemanceBy
java.lang.String maintemanceBy
persistent field

maintemanceNotes
java.lang.String maintemanceNotes
nullable persistent field

Class bb.common.MakeAccountPayableAgent extends java.lang.Object implements Serializable

Serialized Fields

vendorInvoiceNumber
java.lang.String vendorInvoiceNumber
vendorInvoiceDate
java.util.Date vendorInvoiceDate
vendorInvoiceTotal
java.math.BigDecimal vendorInvoiceTotal
vendorShipper
java.lang.String vendorShipper
batchNumber
java.lang.String batchNumber
currency
java.lang.String currency
debitAccount
java.lang.String debitAccount
companyUnitOfDebitAcc
java.lang.String companyUnitOfDebitAcc
terms
java.lang.String terms
subTotal
java.math.BigDecimal subTotal
tax
java.math.BigDecimal tax
freight
java.math.BigDecimal freight
receiverComments
java.lang.String receiverComments
receiverNotes
java.lang.String receiverNotes
bp
java.lang.String bp
reCalSubTotal
java.lang.Boolean reCalSubTotal
reCalTax
java.lang.Boolean reCalTax
receiverNumber
java.lang.String receiverNumber
payThisTotal
java.math.BigDecimal payThisTotal
lastChangeTimes
int lastChangeTimes
vendorId
java.lang.String vendorId
prepayApply
boolean prepayApply
glSummary
java.lang.String glSummary
apGLDate
java.util.Date apGLDate
receiverItemPKs
java.util.ArrayList<E> receiverItemPKs
prepayApplyPoNumbers
java.util.ArrayList<E> prepayApplyPoNumbers
Class bb.common.MakeBillAndHoldInvoiceAgent extends java.lang.Object implements Serializable

Serialized Fields

dateInvoiced
java.util.Date dateInvoiced
currency
java.lang.String currency
companyUnitId
java.lang.String companyUnitId
debitAccount
java.lang.String debitAccount
terms
java.lang.String terms
subTotal
java.math.BigDecimal subTotal
freight
java.math.BigDecimal freight
tax
java.math.BigDecimal tax
shipperNumber
java.lang.String shipperNumber
lastChangeTimes
int lastChangeTimes
reCalSubTotal
java.lang.Boolean reCalSubTotal
reCalTax
java.lang.Boolean reCalTax
shipVia
java.lang.String shipVia
prepayApply
boolean prepayApply
glSummary
java.lang.String glSummary
customId
java.lang.String customId
billToId
java.lang.String billToId
shipToId
java.lang.String shipToId
salesItemPks
java.util.ArrayList<E> salesItemPks
Class bb.common.MakeCheckAgent extends java.lang.Object implements Serializable

Serialized Fields

accountNumber
java.lang.String accountNumber
checkNumber
java.lang.String checkNumber
makeDate
java.util.Date makeDate
debitAccount
java.lang.String debitAccount
totalToPaid
java.math.BigDecimal totalToPaid
memo
java.lang.String memo
apNumber
java.lang.String apNumber
poNumber
java.lang.String poNumber
vendorId
java.lang.String vendorId
name
java.lang.String name
appItem
java.lang.String appItem
companyUnitOfAcc
java.lang.String companyUnitOfAcc
companyUnitOfDebitAcc
java.lang.String companyUnitOfDebitAcc
glSummary
java.lang.String glSummary
Class bb.common.MakeCreditMemoAgent extends java.lang.Object implements Serializable

Serialized Fields

dateInvoice
java.util.Date dateInvoice
batchNumber
java.lang.String batchNumber
currency
java.lang.String currency
companyUnitId
java.lang.String companyUnitId
creditAccount
java.lang.String creditAccount
terms
java.lang.String terms
rmaReceiverNumber
java.lang.String rmaReceiverNumber
lastChangeTimes
int lastChangeTimes
creditMemoComments
java.lang.String creditMemoComments
creditMemoNotes
java.lang.String creditMemoNotes
bp
java.lang.String bp
arNet
java.math.BigDecimal arNet
arTax
java.math.BigDecimal arTax
arFreight
java.math.BigDecimal arFreight
customerInvoiceNumber
java.lang.String customerInvoiceNumber
customerInvoiceTotal
java.math.BigDecimal customerInvoiceTotal
customerInvoiceDate
java.util.Date customerInvoiceDate
glSummary
java.lang.String glSummary
Class bb.common.MakeDebitMemoAgent extends java.lang.Object implements Serializable

Serialized Fields

vendorInvoiceNumber
java.lang.String vendorInvoiceNumber
vendorInvoiceDate
java.util.Date vendorInvoiceDate
vendorInvoiceTotal
java.math.BigDecimal vendorInvoiceTotal
batchNumber
java.lang.String batchNumber
currency
java.lang.String currency
companyUnitId
java.lang.String companyUnitId
debitAccount
java.lang.String debitAccount
terms
java.lang.String terms
debitMemoComments
java.lang.String debitMemoComments
debitMemoNotes
java.lang.String debitMemoNotes
reCalSubTotal
java.lang.Boolean reCalSubTotal
reCalTax
java.lang.Boolean reCalTax
rtvShipperNumber
java.lang.String rtvShipperNumber
glSummary
java.lang.String glSummary
payThisTotal
java.math.BigDecimal payThisTotal
Class bb.common.MakeInvoiceAgent extends java.lang.Object implements Serializable

Serialized Fields

dateInvoiced
java.util.Date dateInvoiced
currency
java.lang.String currency
companyUnitId
java.lang.String companyUnitId
debitAccount
java.lang.String debitAccount
terms
java.lang.String terms
subTotal
java.math.BigDecimal subTotal
freight
java.math.BigDecimal freight
tax
java.math.BigDecimal tax
shipperNumber
java.lang.String shipperNumber
lastChangeTimes
int lastChangeTimes
reCalSubTotal
java.lang.Boolean reCalSubTotal
reCalTax
java.lang.Boolean reCalTax
shipVia
java.lang.String shipVia
prepayApply
boolean prepayApply
glSummary
java.lang.String glSummary
customId
java.lang.String customId
billToId
java.lang.String billToId
shipToId
java.lang.String shipToId
carrierAccount
java.lang.String carrierAccount
freightRateCode
java.lang.String freightRateCode
tracking
java.lang.String tracking
shipperItemPks
java.util.ArrayList<E> shipperItemPks
salesItemPks
java.util.ArrayList<E> salesItemPks
prepayApplySoNumbers
java.util.ArrayList<E> prepayApplySoNumbers
Class bb.common.MakePrepaymentCheckAgent extends java.lang.Object implements Serializable

Serialized Fields

accountNumber
java.lang.String accountNumber
checkNumber
java.lang.String checkNumber
makeDate
java.util.Date makeDate
totalToPaid
java.math.BigDecimal totalToPaid
memo
java.lang.String memo
appNumber
java.lang.String appNumber
itemNumber
java.lang.String itemNumber
companyUnitOfAcc
java.lang.String companyUnitOfAcc
glSummary
java.lang.String glSummary
exchange
java.math.BigDecimal exchange
Class bb.common.ManufacturerAddressInfoVO extends VO implements Serializable

Serialized Fields

id
java.lang.String id
lastChangeUser
java.lang.String lastChangeUser
lastChangeTimes
int lastChangeTimes
aDate
java.util.Date aDate
origin
java.lang.String origin
name
java.lang.String name
addressOne
java.lang.String addressOne
addressTwo
java.lang.String addressTwo
city
java.lang.String city
state
java.lang.String state
zip
java.lang.String zip
country
java.lang.String country
countryCode
java.lang.String countryCode
phone
java.lang.String phone
fax
java.lang.String fax
phone2
java.lang.String phone2
email
java.lang.String email
webSite
java.lang.String webSite
comments
java.lang.String comments
lastChangeDate
java.util.Date lastChangeDate
deleted
boolean deleted
Class bb.common.ManufacturerAddressVO extends VO implements Serializable

Serialized Fields

id
java.lang.String id
lastChangeUser
java.lang.String lastChangeUser
version
java.lang.Integer version
aDate
java.util.Date aDate
origin
java.lang.String origin
name
java.lang.String name
addressOne
java.lang.String addressOne
addressTwo
java.lang.String addressTwo
city
java.lang.String city
state
java.lang.String state
zip
java.lang.String zip
country
java.lang.String country
countryCode
java.lang.String countryCode
phone
java.lang.String phone
fax
java.lang.String fax
phone2
java.lang.String phone2
email
java.lang.String email
webSite
java.lang.String webSite
comments
java.lang.String comments
lastChangeDate
java.util.Date lastChangeDate
deleted
boolean deleted
contacts
java.util.Set<E> contacts
multiDescription
java.util.Set<E> multiDescription
Class bb.common.ManufacturerContactPK extends java.lang.Object implements Serializable

Serialized Fields

id
java.lang.String id
item
java.lang.Short item
Class bb.common.ManufacturerContactVO extends VO implements Serializable

Serialized Fields

pk
ManufacturerContactPK pk
name
java.lang.String name
phone
java.lang.String phone
mobile
java.lang.String mobile
fax
java.lang.String fax
email
java.lang.String email
comments
java.lang.String comments
title
java.lang.String title
Class bb.common.ManufacturerDescriptionPK extends java.lang.Object implements Serializable

Serialized Fields

id
java.lang.String id
identifier field

language
java.lang.String language
identifier field

Class bb.common.ManufacturerDescriptionVO extends VO implements Serializable

Serialized Fields

pk
ManufacturerDescriptionPK pk
status
java.lang.String status
name
java.lang.String name
addressOne
java.lang.String addressOne
addressTwo
java.lang.String addressTwo
city
java.lang.String city
state
java.lang.String state
zip
java.lang.String zip
country
java.lang.String country
Class bb.common.MasterWorkOrderTreeItemResult extends BillItemOnHandWithPartInfoResult implements Serializable

Serialized Fields

setupQty
java.math.BigDecimal setupQty
orderQty
java.math.BigDecimal orderQty
issuedQty
java.math.BigDecimal issuedQty
alreadySetup
boolean alreadySetup
orphan
boolean orphan
Class bb.common.MessageAgent extends java.lang.Object implements Serializable

Serialized Fields

subject
java.lang.String subject
context
java.lang.String context
receivers
java.lang.String receivers
refId
java.lang.Long refId
Class bb.common.MessageVO extends VO implements Serializable

Serialized Fields

id
java.lang.Long id
identifier field

receiver
java.lang.String receiver
persistent field

sendFrom
java.lang.String sendFrom
nullable persistent field

sendUsername
java.lang.String sendUsername
nullable persistent field

sendDate
java.util.Date sendDate
persistent field

context
java.lang.String context
nullable persistent field

refId
java.lang.Long refId
nullable persistent field

subject
java.lang.String subject
status
java.lang.String status
removed
boolean removed
receiverUserName
java.lang.String receiverUserName
allReceiver
java.lang.String allReceiver
level
java.lang.String level
Class bb.common.MfrMpnListResult extends java.lang.Object implements Serializable

Serialized Fields

mfrName
java.lang.String mfrName
mpn
java.lang.String mpn
Class bb.common.MiscDocAgent extends java.lang.Object implements Serializable

Serialized Fields

controlNumber
java.lang.Long controlNumber
orderNumber
java.lang.String orderNumber
orderItemNumber
java.lang.String orderItemNumber
docLength
long docLength
extension
java.lang.String extension
documentDate
java.util.Date documentDate
docDescription
java.lang.String docDescription
comments
java.lang.String comments
wanIp
java.lang.String wanIp
lanIp
java.lang.String lanIp
macAdd
java.lang.String macAdd
document
byte[] document
docName
java.lang.String docName
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
language
java.lang.String language
revision
java.lang.String revision
docType
java.lang.String docType
sequence
java.lang.String sequence
status
java.lang.String status
companyUnitId
java.lang.String companyUnitId
yearCode
java.lang.String yearCode
currentPeriodFrom
java.util.Date currentPeriodFrom
currentPeriodTo
java.util.Date currentPeriodTo
priorPeriodFrom
java.util.Date priorPeriodFrom
priorPeriodTo
java.util.Date priorPeriodTo
poNumber
java.lang.String poNumber
soNumber
java.lang.String soNumber
woNumber
java.lang.String woNumber
recNumber
java.lang.String recNumber
refNumber
java.lang.String refNumber
width
java.lang.Short width
height
java.lang.Short height
isMainPicture
boolean isMainPicture
picture
byte[] picture
setId
java.lang.String setId
recordType
java.lang.String recordType
expireDate
java.util.Date expireDate
category
java.lang.String category
Class bb.common.MiscDocumentSettingVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Integer ii
documentType
java.lang.String documentType
saveToFtp
boolean saveToFtp
serverIp
java.lang.String serverIp
serverPort
java.lang.String serverPort
userName
java.lang.String userName
userPassword
java.lang.String userPassword
ftpPath
java.lang.String ftpPath
localPath
java.lang.String localPath
locked
boolean locked
remarks
java.lang.String remarks
Class bb.common.Money extends java.lang.Object implements Serializable

Serialized Fields

currency
java.lang.String currency
value
java.math.BigDecimal value
Class bb.common.MoneyInDrawResult extends java.lang.Object implements Serializable

Serialized Fields

computerId
java.lang.String computerId
cashTotal
java.math.BigDecimal cashTotal
checkTotal
java.math.BigDecimal checkTotal
ccTotal
java.math.BigDecimal ccTotal
invoiceTotal
java.math.BigDecimal invoiceTotal
total
java.math.BigDecimal total
Class bb.common.MonthBalanceResult extends java.lang.Object implements Serializable

Serialized Fields

accountsChartVO
AccountsChartVO accountsChartVO
debitBalance
java.math.BigDecimal debitBalance
creditBalance
java.math.BigDecimal creditBalance
orgDebitBalance
java.math.BigDecimal orgDebitBalance
orgCreditBalance
java.math.BigDecimal orgCreditBalance
Class bb.common.MonthSoOrArByCustomerResult extends java.lang.Object implements Serializable

Serialized Fields

customerId
java.lang.String customerId
customerName
java.lang.String customerName
monthAmountMap
java.util.Map<K,V> monthAmountMap
Class bb.common.MrpByMonthResult extends java.lang.Object implements Serializable

Serialized Fields

ii
int ii
monthName
java.lang.String monthName
shortQty
java.math.BigDecimal shortQty
usageQty
java.math.BigDecimal usageQty
availQty
java.math.BigDecimal availQty
orderQty
java.math.BigDecimal orderQty
orderUsageQty
java.math.BigDecimal orderUsageQty
Date
java.util.Date Date
Class bb.common.MrpItemOrderDemandRecordsResult extends java.lang.Object implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

part
PartPK part
poOnOrderList
java.util.ArrayList<E> poOnOrderList
woOnOrderList
java.util.ArrayList<E> woOnOrderList
soOnDemandList
java.util.ArrayList<E> soOnDemandList
stockOnDemandList
java.util.ArrayList<E> stockOnDemandList
orphanedSoOnDemandList
java.util.ArrayList<E> orphanedSoOnDemandList
orphanedWoOnDemandList
java.util.ArrayList<E> orphanedWoOnDemandList
Class bb.common.MrpItemResult extends java.lang.Object implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

mustOrder
java.math.BigDecimal mustOrder
monthsInfo
java.util.LinkedList<E> monthsInfo
shortItemPk
OrderPK shortItemPk
lateItemPk
OrderPK lateItemPk
part
PartPK part
partBasicInfo
PartBasicInfo partBasicInfo
partInventory
PartInventoryVO partInventory
mustOrderBefore
java.math.BigDecimal mustOrderBefore
notReviewedOnOrderQty
java.math.BigDecimal notReviewedOnOrderQty
notReviewedOnDemandQty
java.math.BigDecimal notReviewedOnDemandQty
beforeDate
java.util.Date beforeDate
poOnOrderList
java.util.ArrayList<E> poOnOrderList
woOnOrderList
java.util.ArrayList<E> woOnOrderList
swsOnOrderList
java.util.ArrayList<E> swsOnOrderList
dwoOnOrderList
java.util.ArrayList<E> dwoOnOrderList
soOnDemandList
java.util.ArrayList<E> soOnDemandList
dwoOnDemandList
java.util.ArrayList<E> dwoOnDemandList
stockOnDemandList
java.util.ArrayList<E> stockOnDemandList
poNotApprovedOnOrderList
java.util.ArrayList<E> poNotApprovedOnOrderList
woNotApprovedOnOrderList
java.util.ArrayList<E> woNotApprovedOnOrderList
soNotReviewedOnDemandList
java.util.ArrayList<E> soNotReviewedOnDemandList
orphanedSoOnDemandList
java.util.ArrayList<E> orphanedSoOnDemandList
orphanedWoOnDemandList
java.util.ArrayList<E> orphanedWoOnDemandList
nonproPickingOnDemandList
java.util.ArrayList<E> nonproPickingOnDemandList
onDemandQty
java.math.BigDecimal onDemandQty
Class bb.common.MrpReportAgent extends java.lang.Object implements Serializable

Serialized Fields

buyerCode
java.lang.String buyerCode
salesOrderNumber
java.lang.String salesOrderNumber
workOrderNumber
java.lang.String workOrderNumber
includeAssembly
boolean includeAssembly
partNumberFrom
java.lang.String partNumberFrom
partNumberTo
java.lang.String partNumberTo
partType
java.lang.String partType
makeBuy
java.lang.String makeBuy
commodityCode
java.lang.String commodityCode
customerId
java.lang.String customerId
minQty
boolean minQty
leadTime
boolean leadTime
showOnDemand
boolean showOnDemand
showOnOrder
boolean showOnOrder
listAllDemand
boolean listAllDemand
listPastDue
boolean listPastDue
suppressPartOnorderEqualOrLargeOndemand
boolean suppressPartOnorderEqualOrLargeOndemand
computeOrpSOWO
boolean computeOrpSOWO
listUsage
java.lang.String listUsage
listAllPart
boolean listAllPart
billPk
BillPK billPk
level
int level
showNotReviewOrder
boolean showNotReviewOrder
woProject
java.lang.String woProject
partNumbers
java.lang.String[] partNumbers
tDate
java.util.Date tDate
listZeroNeedBefore
boolean listZeroNeedBefore
showZeroMustOrder
boolean showZeroMustOrder
considerInSTO
boolean considerInSTO
includeToleranceQty
boolean includeToleranceQty
leadTimeFrom
java.math.BigDecimal leadTimeFrom
leadTimeTo
java.math.BigDecimal leadTimeTo
Class bb.common.MultiLanguageAccountsChartPK extends java.lang.Object implements Serializable

Serialized Fields

accountNumber
java.lang.String accountNumber
language
java.lang.String language
Class bb.common.MultiLanguageAccountsChartVO extends VO implements Serializable

Serialized Fields

pk
MultiLanguageAccountsChartPK pk
description
java.lang.String description
Class bb.common.MyPrintListPK extends java.lang.Object implements Serializable

Serialized Fields

userName
java.lang.String userName
identifier field

orderNumber
java.lang.String orderNumber
identifier field

Class bb.common.MyPrintListVO extends VO implements Serializable

Serialized Fields

pk
MyPrintListPK pk
identifier field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

Class bb.common.NCQRejectResult extends java.lang.Object implements Serializable

Serialized Fields

rejectQuantity
java.math.BigDecimal rejectQuantity
persistent field

rejectPercent
java.math.BigDecimal rejectPercent
persistent field

nonConformanceCode
java.lang.String nonConformanceCode
persistent field

Class bb.common.NcrApprovalPK extends java.lang.Object implements Serializable

Serialized Fields

employeeId
java.lang.String employeeId
approvableType
java.lang.String approvableType
Class bb.common.NcrApprovalVO extends VO implements Serializable

Serialized Fields

pk
NcrApprovalPK pk
userName
java.lang.String userName
canApproveOwn
boolean canApproveOwn
comments
java.lang.String comments
Class bb.common.NcrNeedToScrapListResult extends java.lang.Object implements Serializable

Serialized Fields

ncrNumber
java.lang.String ncrNumber
dueDate
java.util.Date dueDate
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
adate
java.util.Date adate
ncrDate
java.util.Date ncrDate
responsibility
java.lang.String responsibility
status
java.lang.String status
partNumber
java.lang.String partNumber
partType
java.lang.String partType
inspectedQty
java.math.BigDecimal inspectedQty
purchaseOrderNumber
java.lang.String purchaseOrderNumber
receiverNumber
java.lang.String receiverNumber
workOrderNumber
java.lang.String workOrderNumber
salesOrderNumber
java.lang.String salesOrderNumber
rtvNumber
java.lang.String rtvNumber
rmaNumber
java.lang.String rmaNumber
partsPulledFromStock
java.math.BigDecimal partsPulledFromStock
partPutBackToStock
java.math.BigDecimal partPutBackToStock
qtyRework
java.math.BigDecimal qtyRework
qtyWaiver
java.math.BigDecimal qtyWaiver
qtyRegrade
java.math.BigDecimal qtyRegrade
qtyReject
java.math.BigDecimal qtyReject
qtyScrap
java.math.BigDecimal qtyScrap
qtyScraped
java.math.BigDecimal qtyScraped
qtyNeedtoScrap
java.math.BigDecimal qtyNeedtoScrap
partFrom
java.lang.String partFrom
Class bb.common.NCRPictureListResult extends java.lang.Object implements Serializable

Serialized Fields

ii
java.lang.Long ii
ncrNumber
java.lang.String ncrNumber
extension
java.lang.String extension
comments
java.lang.String comments
Class bb.common.NCRPictureVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
identifier field

ncrNumber
java.lang.String ncrNumber
persistent field

extension
java.lang.String extension
nullable persistent field

comments
java.lang.String comments
nullable persistent field

pictureLength
long pictureLength
pictureName
java.lang.String pictureName
uploadTime
java.util.Date uploadTime
Class bb.common.NcrReportListResult extends java.lang.Object implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

ncrNumber
java.lang.String ncrNumber
vendorId
java.lang.String vendorId
woNumber
java.lang.String woNumber
soNumber
java.lang.String soNumber
poNumber
java.lang.String poNumber
ncode
java.lang.String ncode
part
BB2Part part
qtyInspected
java.math.BigDecimal qtyInspected
qtyScraped
java.math.BigDecimal qtyScraped
qtyRejected
java.math.BigDecimal qtyRejected
partsPulledFromStock
java.math.BigDecimal partsPulledFromStock
partPutBackToStock
java.math.BigDecimal partPutBackToStock
ncrDate
java.util.Date ncrDate
enterBy
java.lang.String enterBy
status
java.lang.String status
responsibility
java.lang.String responsibility
dueDate
java.util.Date dueDate
closedOutDate
java.util.Date closedOutDate
partDescription
java.lang.String partDescription
rtvNumber
java.lang.String rtvNumber
problemDescription
java.lang.String problemDescription
problemDisposition
java.lang.String problemDisposition
closedOutPrivateNotes
java.lang.String closedOutPrivateNotes
buyer
java.lang.String buyer
approvedOpinionQa
java.lang.String approvedOpinionQa
approvedOpinionEng
java.lang.String approvedOpinionEng
approvedOpinionMfg
java.lang.String approvedOpinionMfg
Class bb.common.NcrScrapAgent extends java.lang.Object implements Serializable

Serialized Fields

qty
java.math.BigDecimal qty
ncrNumber
java.lang.String ncrNumber
debit
java.lang.String debit
credit
java.lang.String credit
debitText
java.lang.String debitText
creditText
java.lang.String creditText
glSummary
java.lang.String glSummary
Class bb.common.NonConformanceCodeDescriptionPK extends java.lang.Object implements Serializable

Serialized Fields

code
java.lang.String code
language
java.lang.String language
Class bb.common.NonConformanceCodeDescriptionVO extends VO implements Serializable

Serialized Fields

pk
NonConformanceCodeDescriptionPK pk
identifier field

description
java.lang.String description
persistent field

Class bb.common.NonConformanceCodeVO extends VO implements Serializable

Serialized Fields

code
java.lang.String code
identifier field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

adate
java.util.Date adate
nullable persistent field

origin
java.lang.String origin
persistent field

localDescription
java.lang.String localDescription
persistent field

descriptions
java.util.Set<E> descriptions
version
java.lang.Integer version
nullable persistent field

Class bb.common.NonConformanceQuantityPK extends java.lang.Object implements Serializable

Serialized Fields

ncrNumber
java.lang.String ncrNumber
identifier field

ii
java.lang.Integer ii
identifier field

Class bb.common.NonConformanceQuantityVO extends VO implements Serializable

Serialized Fields

pk
NonConformanceQuantityPK pk
identifier field

rejectQuantity
java.math.BigDecimal rejectQuantity
persistent field

nonConformanceCode
java.lang.String nonConformanceCode
persistent field

nonConformanceCodeNameVO
NonConformanceCodeVO nonConformanceCodeNameVO
nullable persistent field

nonConformanceReportVO
NonConformanceReportVO nonConformanceReportVO
nullable persistent field

Class bb.common.NonConformanceReportResult extends java.lang.Object implements Serializable

Serialized Fields

partsPulledFromStock
java.math.BigDecimal partsPulledFromStock
partPutBackToStock
java.math.BigDecimal partPutBackToStock
averageCost
java.math.BigDecimal averageCost
Class bb.common.NonConformanceReportVO extends VO implements Serializable

Serialized Fields

ncrNumber
java.lang.String ncrNumber
identifier field

dueDate
java.util.Date dueDate
persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

adate
java.util.Date adate
nullable persistent field

origin
java.lang.String origin
persistent field

ncrDate
java.util.Date ncrDate
persistent field

enteredBy
java.lang.String enteredBy
persistent field

responsibility
java.lang.String responsibility
status
java.lang.String status
persistent field

vendorId
java.lang.String vendorId
persistent field

inspectedQty
java.math.BigDecimal inspectedQty
persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

modelNumber
java.lang.String modelNumber
persistent field

drawing
java.lang.String drawing
partRevision
java.lang.String partRevision
persistent field

partDescription
java.lang.String partDescription
persistent field

partSerialNumber
java.lang.String partSerialNumber
persistent field

purchaseOrderNumber
java.lang.String purchaseOrderNumber
persistent field

qr
java.lang.String qr
persistent field

receiverNumber
java.lang.String receiverNumber
persistent field

workOrderNumber
java.lang.String workOrderNumber
persistent field

salesOrderNumber
java.lang.String salesOrderNumber
persistent field

rtvNumber
java.lang.String rtvNumber
rmaNumber
java.lang.String rmaNumber
refDoc1
java.lang.String refDoc1
persistent field

refDoc2
java.lang.String refDoc2
persistent field

refAcct
java.lang.String refAcct
persistent field

problemDescription
java.lang.String problemDescription
persistent field

xrework
java.lang.String xrework
persistent field

xwaiver
java.lang.String xwaiver
persistent field

xregrade
java.lang.String xregrade
persistent field

xreject
java.lang.String xreject
persistent field

xscrap
java.lang.String xscrap
persistent field

dispositionDate
java.util.Date dispositionDate
persistent field

problemDisposition
java.lang.String problemDisposition
nullable persistent field

dispositionApprovedQa
java.lang.String dispositionApprovedQa
persistent field

dispositionApprovedEng
java.lang.String dispositionApprovedEng
persistent field

dispositionApprovedMfg
java.lang.String dispositionApprovedMfg
persistent field

partsPulledFromStock
java.math.BigDecimal partsPulledFromStock
persistent field

partsPulledFromStockDate
java.util.Date partsPulledFromStockDate
persistent field

partPutBackToStock
java.math.BigDecimal partPutBackToStock
persistent field

partPutBackToStockDate
java.util.Date partPutBackToStockDate
persistent field

qc
java.lang.String qc
persistent field

closedOutApproval
java.lang.String closedOutApproval
persistent field

closedOutDate
java.util.Date closedOutDate
persistent field

closedOutPrivateNotes
java.lang.String closedOutPrivateNotes
persistent field

qtyRework
java.math.BigDecimal qtyRework
persistent field

qtyWaiver
java.math.BigDecimal qtyWaiver
persistent field

qtyRegrade
java.math.BigDecimal qtyRegrade
persistent field

qtyReject
java.math.BigDecimal qtyReject
persistent field

qtyScrap
java.math.BigDecimal qtyScrap
persistent field

version
java.lang.Integer version
nullable persistent field

dateApprovedQa
java.util.Date dateApprovedQa
persistent field

dateApprovedEng
java.util.Date dateApprovedEng
persistent field

dateApprovedMfg
java.util.Date dateApprovedMfg
persistent field

nonConformanceQuantity
java.util.Set<E> nonConformanceQuantity
persistent field

ncrPictures
java.util.Set<E> ncrPictures
partFrom
java.lang.String partFrom
buyer
java.lang.String buyer
approvedOpinionQa
java.lang.String approvedOpinionQa
approvedOpinionEng
java.lang.String approvedOpinionEng
approvedOpinionMfg
java.lang.String approvedOpinionMfg
Class bb.common.NonproductivePickingApprovalVO extends VO implements Serializable

Serialized Fields

employeeId
java.lang.String employeeId
userName
java.lang.String userName
comments
java.lang.String comments
canReviewOwnNonproPicking
boolean canReviewOwnNonproPicking
Class bb.common.NonproductivePickingApproveVO extends VO implements Serializable

Serialized Fields

employeeId
java.lang.String employeeId
userName
java.lang.String userName
reviewLimit
java.math.BigDecimal reviewLimit
currency
java.lang.String currency
canReviewOwnNonproPicking
java.lang.String canReviewOwnNonproPicking
Class bb.common.NonproductivePickingItemIssuedListResult extends java.lang.Object implements Serializable

Serialized Fields

ii
java.lang.Integer ii
orderNumber
java.lang.Integer orderNumber
itemNumber
java.lang.Short itemNumber
pickingNumber
java.lang.String pickingNumber
pickingItemNumber
java.lang.String pickingItemNumber
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
partDesc
java.lang.String partDesc
qty
java.math.BigDecimal qty
issuedQty
java.math.BigDecimal issuedQty
originator
java.lang.String originator
mfgStatus
java.lang.String mfgStatus
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
issueAvgCost
java.math.BigDecimal issueAvgCost
dateIssue
java.util.Date dateIssue
avgTotalAmount
java.math.BigDecimal avgTotalAmount
stdTotalAmount
java.math.BigDecimal stdTotalAmount
orderType
java.lang.String orderType
accountNumber
java.lang.String accountNumber
companyUnitId
java.lang.String companyUnitId
itemComments
java.lang.String itemComments
operator
java.lang.String operator
picker
java.lang.String picker
unit
java.lang.String unit
locate
java.lang.String locate
note
java.lang.String note
transactionNumber
java.lang.String transactionNumber
departmentId
java.lang.String departmentId
locations
java.util.Map<K,V> locations
trackings
java.util.Map<K,V> trackings
project
java.lang.String project
Class bb.common.NonproductivePickingItemIssuedVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Integer ii
orderNumber
java.lang.Integer orderNumber
itemNumber
java.lang.Short itemNumber
pickingNumber
java.lang.String pickingNumber
pickingItemNumber
java.lang.String pickingItemNumber
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
description
java.lang.String description
qtyIssued
java.math.BigDecimal qtyIssued
dateIssued
java.util.Date dateIssued
operator
java.lang.String operator
picker
java.lang.String picker
unit
java.lang.String unit
note
java.lang.String note
transactionNumber
java.lang.String transactionNumber
cost
java.math.BigDecimal cost
stdCost
java.math.BigDecimal stdCost
departmentId
java.lang.String departmentId
locations
java.util.Map<K,V> locations
trackings
java.util.Map<K,V> trackings
Class bb.common.NonproductivePickingItemPK extends java.lang.Object implements Serializable

Serialized Fields

pickingNumber
java.lang.String pickingNumber
pickingItemNumber
java.lang.String pickingItemNumber
Class bb.common.NonproductivePickingItemResult extends java.lang.Object implements Serializable

Serialized Fields

pickingNumber
java.lang.String pickingNumber
pickingItemNumber
java.lang.String pickingItemNumber
approvedDate
java.util.Date approvedDate
approvedBy
java.lang.String approvedBy
orderType
java.lang.String orderType
accountNumber
java.lang.String accountNumber
companyUnitId
java.lang.String companyUnitId
id
java.lang.String id
status
java.lang.String status
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
quantity
java.math.BigDecimal quantity
issuedQuantity
java.math.BigDecimal issuedQuantity
description
java.lang.String description
unit
java.lang.String unit
comments
java.lang.String comments
notes
java.lang.String notes
project
java.lang.String project
Class bb.common.NonproductivePickingItemVO extends VO implements Serializable

Serialized Fields

pk
NonproductivePickingItemPK pk
status
java.lang.String status
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
quantity
java.math.BigDecimal quantity
issuedQuantity
java.math.BigDecimal issuedQuantity
description
java.lang.String description
unit
java.lang.String unit
comments
java.lang.String comments
notes
java.lang.String notes
transactionNumber
java.lang.String transactionNumber
deliveryDate
java.util.Date deliveryDate
desiredDate
java.util.Date desiredDate
delayDays
int delayDays
arriveDate
java.util.Date arriveDate
original
java.util.Date original
actual
java.util.Date actual
cost
java.math.BigDecimal cost
stdCost
java.math.BigDecimal stdCost
revision
java.lang.String revision
dwg
java.lang.String dwg
avgTotal
java.math.BigDecimal avgTotal
stdTotal
java.math.BigDecimal stdTotal
Class bb.common.NonproductivePickingOnDemandResult extends java.lang.Object implements Serializable

Serialized Fields

partPk
PartPK partPk
partFrom
java.lang.String partFrom
pk
NonproductivePickingItemPK pk
description
java.lang.String description
quantity
java.math.BigDecimal quantity
quantityIssued
java.math.BigDecimal quantityIssued
quantityOnDemand
java.math.BigDecimal quantityOnDemand
id
java.lang.String id
adate
java.util.Date adate
shipVia
java.lang.String shipVia
deliveryDate
java.util.Date deliveryDate
arriveDate
java.util.Date arriveDate
delayDays
int delayDays
locations
java.util.Map<K,V> locations
Class bb.common.NonproductivePickingTypeVO extends VO implements Serializable

Serialized Fields

ii
int ii
name
java.lang.String name
accountNumber
java.lang.String accountNumber
companyUnitId
java.lang.String companyUnitId
Class bb.common.NonproductivePickingVO extends VO implements Serializable

Serialized Fields

pickingNumber
java.lang.String pickingNumber
version
java.lang.Integer version
lastUser
java.lang.String lastUser
lastChangeDate
java.util.Date lastChangeDate
adate
java.util.Date adate
origin
java.lang.String origin
status
java.lang.String status
approvedDate
java.util.Date approvedDate
approvedBy
java.lang.String approvedBy
departmentId
java.lang.String departmentId
orderType
java.lang.String orderType
accountNumber
java.lang.String accountNumber
companyUnitId
java.lang.String companyUnitId
comments
java.lang.String comments
notes
java.lang.String notes
project
java.lang.String project
addressInfo
CustomerVendorAddressInfoVO addressInfo
avgTotal
java.math.BigDecimal avgTotal
stdTotal
java.math.BigDecimal stdTotal
pickingItems
java.util.Set<E> pickingItems
Class bb.common.NoticeUserEmployeeListResult extends java.lang.Object implements Serializable

Serialized Fields

userName
java.lang.String userName
systemUserName
java.lang.String systemUserName
employeeId
java.lang.String employeeId
department
java.lang.String department
phone
java.lang.String phone
email
java.lang.String email
mobile
java.lang.String mobile
homePhone
java.lang.String homePhone
description
java.lang.String description
firstName
java.lang.String firstName
middleName
java.lang.String middleName
lastName
java.lang.String lastName
fullName
java.lang.String fullName
Class bb.common.OIPrincipalVO extends VO implements Serializable

Serialized Fields

id
int id
itemPrincipal
java.lang.String itemPrincipal
QCPrincipal
java.lang.String QCPrincipal
Class bb.common.OnhandQualityResult extends java.lang.Object implements Serializable

Serialized Fields

project
java.lang.String project
line
int line
total
java.math.BigDecimal total
map
java.util.HashMap<K,V> map
Class bb.common.OnloanDocumentVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
onloanNumber
java.lang.String onloanNumber
docDescription
java.lang.String docDescription
documentDate
java.util.Date documentDate
comments
java.lang.String comments
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
extension
java.lang.String extension
docFileName
java.lang.String docFileName
docLength
long docLength
Class bb.common.OnLoanItemListResult extends java.lang.Object implements Serializable

Serialized Fields

loanNumber
java.lang.String loanNumber
loanItemNumber
java.lang.String loanItemNumber
partPk
PartPK partPk
itemDescription
java.lang.String itemDescription
loanDate
java.util.Date loanDate
deliveryDate
java.util.Date deliveryDate
loanQty
java.math.BigDecimal loanQty
shippedQty
java.math.BigDecimal shippedQty
pricePerUnit
java.math.BigDecimal pricePerUnit
discount
java.math.BigDecimal discount
customerId
java.lang.String customerId
customerPo
java.lang.String customerPo
shipVia
java.lang.String shipVia
status
java.lang.String status
onhandQty
java.math.BigDecimal onhandQty
onorderQty
java.math.BigDecimal onorderQty
onDemandQty
java.math.BigDecimal onDemandQty
partFrom
java.lang.String partFrom
receivedQty
java.math.BigDecimal receivedQty
Class bb.common.OnLoanItemPK extends java.lang.Object implements Serializable

Serialized Fields

loanNumber
java.lang.String loanNumber
identifier field

loanItemNumber
java.lang.String loanItemNumber
identifier field

Class bb.common.OnLoanItemVO extends VO implements Serializable

Serialized Fields

pk
OnLoanItemPK pk
identifier field

arSub
java.math.BigDecimal arSub
persistent field

arDisc
java.math.BigDecimal arDisc
persistent field

arNet
java.math.BigDecimal arNet
persistent field

arShip
java.math.BigDecimal arShip
persistent field

arOpen
java.math.BigDecimal arOpen
persistent field

arTax
java.math.BigDecimal arTax
persistent field

arTotal
java.math.BigDecimal arTotal
persistent field

refDoc1
java.lang.String refDoc1
persistent field

refDoc2
java.lang.String refDoc2
persistent field

changeOrder
java.lang.String changeOrder
persistent field

qr
java.lang.String qr
persistent field

status
java.lang.String status
persistent field

delivery
java.util.Date delivery
persistent field

desired
java.util.Date desired
persistent field

delay
int delay
persistent field

priority
java.lang.String priority
persistent field

original
java.util.Date original
persistent field

actual
java.util.Date actual
persistent field

location
java.lang.String location
persistent field

shipVia
java.lang.String shipVia
persistent field

fob
java.lang.String fob
persistent field

freightWho
java.lang.String freightWho
persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
persistent field

modelNumber
java.lang.String modelNumber
persistent field

revision
java.lang.String revision
persistent field

dwg
java.lang.String dwg
persistent field

loanQuantity
java.math.BigDecimal loanQuantity
persistent field

shippedQuantity
java.math.BigDecimal shippedQuantity
persistent field

receivedQuantity
java.math.BigDecimal receivedQuantity
persistent field

hqa
java.math.BigDecimal hqa
persistent field

cost
java.math.BigDecimal cost
persistent field

unit
java.lang.String unit
persistent field

pricePerUnit
java.math.BigDecimal pricePerUnit
persistent field

dcode
java.lang.String dcode
persistent field

discount
java.math.BigDecimal discount
persistent field

taxRate
java.math.BigDecimal taxRate
persistent field

description
java.lang.String description
persistent field

mfg
java.lang.String mfg
persistent field

mpn
java.lang.String mpn
persistent field

itemComments
java.lang.String itemComments
nullable persistent field

itemNotes
java.lang.String itemNotes
nullable persistent field

version
java.lang.Integer version
Class bb.common.OnLoanListResult extends java.lang.Object implements Serializable

Serialized Fields

loanNumber
java.lang.String loanNumber
loanDate
java.util.Date loanDate
changeOrder
java.lang.String changeOrder
customerId
java.lang.String customerId
customerPo
java.lang.String customerPo
project
java.lang.String project
privateNote
java.lang.String privateNote
comments
java.lang.String comments
status
java.lang.String status
Class bb.common.OnloanReceiverItemListResult extends java.lang.Object implements Serializable

Serialized Fields

receiverItemNumber
java.lang.String receiverItemNumber
receiverNumber
java.lang.String receiverNumber
lnShipperNumber
java.lang.String lnShipperNumber
receivedBy
java.lang.String receivedBy
status
java.lang.String status
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
quantity
java.math.BigDecimal quantity
quantityReceived
java.math.BigDecimal quantityReceived
unit
java.lang.String unit
description
java.lang.String description
dateReceived
java.util.Date dateReceived
comments
java.lang.String comments
notes
java.lang.String notes
custID
java.lang.String custID
lnNumber
java.lang.String lnNumber
Class bb.common.OnloanReceiverItemPK extends java.lang.Object implements Serializable

Serialized Fields

receiverItemNumber
java.lang.String receiverItemNumber
receiverNumber
java.lang.String receiverNumber
Class bb.common.OnloanReceiverItemVO extends VO implements Serializable

Serialized Fields

pk
OnloanReceiverItemPK pk
lnShipperNumber
java.lang.String lnShipperNumber
checkNumber
java.lang.String checkNumber
referenceDoc1
java.lang.String referenceDoc1
referenceDoc2
java.lang.String referenceDoc2
qr
java.lang.String qr
sentTo
java.lang.String sentTo
receivedBy
java.lang.String receivedBy
condition
java.lang.String condition
status
java.lang.String status
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
modelNumber
java.lang.String modelNumber
revision
java.lang.String revision
location
java.lang.String location
unit
java.lang.String unit
description
java.lang.String description
mfg
java.lang.String mfg
mpn
java.lang.String mpn
serial
java.lang.String serial
comments
java.lang.String comments
privateNotes
java.lang.String privateNotes
datePaid
java.util.Date datePaid
apSub
java.math.BigDecimal apSub
apReceived
java.math.BigDecimal apReceived
apOpen
java.math.BigDecimal apOpen
apDiscount
java.math.BigDecimal apDiscount
extendPrice
java.math.BigDecimal extendPrice
apTax
java.math.BigDecimal apTax
apTotal
java.math.BigDecimal apTotal
due
java.math.BigDecimal due
paid
java.math.BigDecimal paid
quantity
java.math.BigDecimal quantity
quantityTraced
java.math.BigDecimal quantityTraced
quantityReceived
java.math.BigDecimal quantityReceived
costPerUnit
java.math.BigDecimal costPerUnit
discount
java.math.BigDecimal discount
taxRate
java.math.BigDecimal taxRate
part
PartVO part
locations
java.util.Map<K,V> locations
trackings
java.util.Map<K,V> trackings
Class bb.common.OnloanReceiverListResult extends java.lang.Object implements Serializable

Serialized Fields

receiverNumber
java.lang.String receiverNumber
lnShipperNumber
java.lang.String lnShipperNumber
custID
java.lang.String custID
status
java.lang.String status
receivedBy
java.lang.String receivedBy
dateReceived
java.util.Date dateReceived
project
java.lang.String project
comments
java.lang.String comments
notes
java.lang.String notes
Class bb.common.OnloanReceiverVO extends VO implements Serializable

Serialized Fields

receiverNumber
java.lang.String receiverNumber
lnShipperNumber
java.lang.String lnShipperNumber
accountPayableNumber
java.lang.String accountPayableNumber
custID
java.lang.String custID
batch
java.lang.String batch
lastChangeUser
java.lang.String lastChangeUser
origin
java.lang.String origin
apNetSet
java.lang.String apNetSet
apTaxSet
java.lang.String apTaxSet
changeOrder
java.lang.String changeOrder
status
java.lang.String status
collect
java.lang.String collect
receivedBy
java.lang.String receivedBy
deliveredTo
java.lang.String deliveredTo
freightBill
java.lang.String freightBill
shippedVia
java.lang.String shippedVia
carrier
java.lang.String carrier
carrierAccount
java.lang.String carrierAccount
tracking
java.lang.String tracking
incoterm
java.lang.String incoterm
incotermPlacePort
java.lang.String incotermPlacePort
currency
java.lang.String currency
terms
java.lang.String terms
requester
java.lang.String requester
buyer
java.lang.String buyer
projectName
java.lang.String projectName
relatedDoc
java.lang.String relatedDoc
debitAccount
java.lang.String debitAccount
companyUnitId
java.lang.String companyUnitId
bp
java.lang.String bp
comments
java.lang.String comments
privateNotes
java.lang.String privateNotes
cusInvoice
java.lang.String cusInvoice
cusPackage
java.lang.String cusPackage
checkNo
java.lang.String checkNo
itran
java.lang.String itran
etran
java.lang.String etran
coComments
java.lang.String coComments
lastChangeDate
java.util.Date lastChangeDate
adate
java.util.Date adate
cusInvoiceDate
java.util.Date cusInvoiceDate
cusShipDate
java.util.Date cusShipDate
paydate
java.util.Date paydate
datePaid
java.util.Date datePaid
dateReceived
java.util.Date dateReceived
paid
java.math.BigDecimal paid
cusTotal
java.math.BigDecimal cusTotal
due
java.math.BigDecimal due
exchange
java.math.BigDecimal exchange
apSub
java.math.BigDecimal apSub
apReceived
java.math.BigDecimal apReceived
apOpen
java.math.BigDecimal apOpen
totalDiscount
java.math.BigDecimal totalDiscount
subTotal
java.math.BigDecimal subTotal
totalTax
java.math.BigDecimal totalTax
totalFreight
java.math.BigDecimal totalFreight
grantTotal
java.math.BigDecimal grantTotal
apPaidReceived
java.math.BigDecimal apPaidReceived
apPaidGl
java.math.BigDecimal apPaidGl
apGl1Recorded
java.math.BigDecimal apGl1Recorded
apGl2Paid
java.math.BigDecimal apGl2Paid
lastChangeTimes
int lastChangeTimes
customerAddressInfo
CustomerVendorAddressInfoVO customerAddressInfo
receiverItem
java.util.Set<E> receiverItem
Class bb.common.OnloanReviewVO extends VO implements Serializable

Serialized Fields

employeeId
java.lang.String employeeId
identifier field

userName
java.lang.String userName
persistent field

reviewLimit
java.math.BigDecimal reviewLimit
persistent field

currency
java.lang.String currency
persistent field

canReviewOwnOnloan
java.lang.String canReviewOwnOnloan
persistent field

Class bb.common.OnloanShipperItemPK extends java.lang.Object implements Serializable

Serialized Fields

lnShipperNumber
java.lang.String lnShipperNumber
lnShipperItemNumber
java.lang.String lnShipperItemNumber
Class bb.common.OnloanShipperItemVO extends VO implements Serializable

Serialized Fields

pk
OnloanShipperItemPK pk
identifier field

loanNumber
java.lang.String loanNumber
persistent field

checkNumber
java.lang.String checkNumber
persistent field

referenceDoc1
java.lang.String referenceDoc1
persistent field

referenceDoc2
java.lang.String referenceDoc2
persistent field

shipVia
java.lang.String shipVia
persistent field

shipToId
java.lang.String shipToId
persistent field

status
java.lang.String status
persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
persistent field

modelNumber
java.lang.String modelNumber
persistent field

revision
java.lang.String revision
persistent field

location
java.lang.String location
persistent field

unit
java.lang.String unit
persistent field

discount
java.math.BigDecimal discount
persistent field

taxRate
java.math.BigDecimal taxRate
persistent field

description
java.lang.String description
persistent field

mfg
java.lang.String mfg
persistent field

mpn
java.lang.String mpn
persistent field

serialNumber
java.lang.String serialNumber
persistent field

shipperItemComments
java.lang.String shipperItemComments
nullable persistent field

shipperItemPrivateNotes
java.lang.String shipperItemPrivateNotes
nullable persistent field

datePaid
java.util.Date datePaid
persistent field

dateShipped
java.util.Date dateShipped
persistent field

dateInvoiced
java.util.Date dateInvoiced
persistent field

arSub
java.math.BigDecimal arSub
persistent field

arShip
java.math.BigDecimal arShip
persistent field

arOpen
java.math.BigDecimal arOpen
persistent field

arDiscount
java.math.BigDecimal arDiscount
persistent field

arNet
java.math.BigDecimal arNet
persistent field

arTax
java.math.BigDecimal arTax
persistent field

arTotal
java.math.BigDecimal arTotal
persistent field

due
java.math.BigDecimal due
persistent field

paid
java.math.BigDecimal paid
persistent field

loanQuantity
java.math.BigDecimal loanQuantity
persistent field

quantityShip
java.math.BigDecimal quantityShip
persistent field

quantityRec
java.math.BigDecimal quantityRec
persistent field

listPrice
java.math.BigDecimal listPrice
persistent field

averageCost
java.math.BigDecimal averageCost
persistent field

shipperItemManufacturer
java.util.Set<E> shipperItemManufacturer
persistent field

locations
java.util.Map<K,V> locations
trackings
java.util.Map<K,V> trackings
Class bb.common.OnloanShipperVO extends VO implements Serializable

Serialized Fields

lnShipperNumber
java.lang.String lnShipperNumber
loanNumber
java.lang.String loanNumber
persistent field

arInvoiceNumber
java.lang.String arInvoiceNumber
persistent field

customerId
java.lang.String customerId
persistent field

batch
java.lang.String batch
persistent field

billToId
java.lang.String billToId
persistent field

customerPo
java.lang.String customerPo
persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

origin
java.lang.String origin
persistent field

arNetSet
java.lang.String arNetSet
persistent field

arTaxSet
java.lang.String arTaxSet
persistent field

changeOrder
java.lang.String changeOrder
persistent field

status
java.lang.String status
persistent field

salesman
java.lang.String salesman
persistent field

shippedBy
java.lang.String shippedBy
persistent field

invoicedBy
java.lang.String invoicedBy
persistent field

shipToId
java.lang.String shipToId
persistent field

remitId
java.lang.String remitId
persistent field

shipVia
java.lang.String shipVia
persistent field

carrier
java.lang.String carrier
persistent field

carrierAccount
java.lang.String carrierAccount
persistent field

freightRateCode
java.lang.String freightRateCode
persistent field

grossWeight
java.lang.String grossWeight
persistent field

tracking
java.lang.String tracking
persistent field

incoterm
java.lang.String incoterm
persistent field

incotermPlacePort
java.lang.String incotermPlacePort
persistent field

freightBill
java.lang.String freightBill
persistent field

currency
java.lang.String currency
persistent field

language
java.lang.String language
persistent field

terms
java.lang.String terms
persistent field

relatedDoc
java.lang.String relatedDoc
persistent field

debitAccount
java.lang.String debitAccount
persistent field

companyUnitId
java.lang.String companyUnitId
persistent field

bp
java.lang.String bp
persistent field

shipperBp
java.lang.String shipperBp
persistent field

shipperComments
java.lang.String shipperComments
nullable persistent field

shipperPrivateNotes
java.lang.String shipperPrivateNotes
nullable persistent field

checkNumber
java.lang.String checkNumber
persistent field

oTran
java.lang.String oTran
persistent field

rTran
java.lang.String rTran
persistent field

coComments
java.lang.String coComments
persistent field

payDate
java.util.Date payDate
datePaid
java.util.Date datePaid
persistent field

shippedDate
java.util.Date shippedDate
nullable persistent field

invoicedDate
java.util.Date invoicedDate
nullable persistent field

dateShipped
java.util.Date dateShipped
persistent field

dateInvoiced
java.util.Date dateInvoiced
lastChangedate
java.util.Date lastChangedate
adate
java.util.Date adate
arSub
java.math.BigDecimal arSub
persistent field

arShip
java.math.BigDecimal arShip
persistent field

arOpen
java.math.BigDecimal arOpen
persistent field

arDiscount
java.math.BigDecimal arDiscount
persistent field

arNet
java.math.BigDecimal arNet
persistent field

arTax
java.math.BigDecimal arTax
persistent field

arFreight
java.math.BigDecimal arFreight
persistent field

arTotal
java.math.BigDecimal arTotal
persistent field

arPaidInvoice
java.math.BigDecimal arPaidInvoice
persistent field

arPaidGl
java.math.BigDecimal arPaidGl
persistent field

arGl1Recorded
java.math.BigDecimal arGl1Recorded
persistent field

arGl2Paid
java.math.BigDecimal arGl2Paid
persistent field

due
java.math.BigDecimal due
persistent field

paid
java.math.BigDecimal paid
persistent field

lastChangeTime
int lastChangeTime
nullable persistent field

customerAddressInfo
CustomerVendorAddressInfoVO customerAddressInfo
shipToAddressInfo
CustomerVendorAddressInfoVO shipToAddressInfo
billToAddressInfo
CustomerVendorAddressInfoVO billToAddressInfo
onloanShipperItems
java.util.Set<E> onloanShipperItems
Class bb.common.OnLoanVO extends VO implements Serializable

Serialized Fields

loanNumber
java.lang.String loanNumber
identifier field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

adate
java.util.Date adate
nullable persistent field

origin
java.lang.String origin
persistent field

arNetSet
java.lang.String arNetSet
persistent field

arTaxSet
java.lang.String arTaxSet
persistent field

arSub
java.math.BigDecimal arSub
persistent field

arDisc
java.math.BigDecimal arDisc
persistent field

arNet
java.math.BigDecimal arNet
persistent field

arShip
java.math.BigDecimal arShip
persistent field

arOpen
java.math.BigDecimal arOpen
persistent field

arTax
java.math.BigDecimal arTax
persistent field

arFreight
java.math.BigDecimal arFreight
persistent field

arTotal
java.math.BigDecimal arTotal
persistent field

arPaidInv
java.math.BigDecimal arPaidInv
persistent field

arPaidGl
java.math.BigDecimal arPaidGl
persistent field

arGl1Recorded
java.math.BigDecimal arGl1Recorded
persistent field

arGl2Paid
java.math.BigDecimal arGl2Paid
persistent field

changeOrder
java.lang.String changeOrder
persistent field

customerId
java.lang.String customerId
persistent field

billtoId
java.lang.String billtoId
persistent field

customerPo
java.lang.String customerPo
persistent field

customerEmail
java.lang.String customerEmail
persistent field

contact
java.lang.String contact
persistent field

status
java.lang.String status
persistent field

reviewed
java.util.Date reviewed
nullable persistent field

reviewedBy
java.lang.String reviewedBy
persistent field

delivery
java.util.Date delivery
persistent field

desired
java.util.Date desired
persistent field

delay
byte delay
persistent field

priority
java.lang.String priority
persistent field

original
java.util.Date original
persistent field

actual
java.util.Date actual
persistent field

shiptoId
java.lang.String shiptoId
persistent field

shipVia
java.lang.String shipVia
persistent field

carrier
java.lang.String carrier
persistent field

carrierAcct
java.lang.String carrierAcct
persistent field

incoterm
java.lang.String incoterm
persistent field

incotermPlacePort
java.lang.String incotermPlacePort
persistent field

shipAcct
java.lang.String shipAcct
persistent field

freightWho
java.lang.String freightWho
persistent field

fob
java.lang.String fob
persistent field

locate
java.lang.String locate
persistent field

language
java.lang.String language
persistent field

currency
java.lang.String currency
persistent field

terms
java.lang.String terms
persistent field

loanDate
java.util.Date loanDate
persistent field

salesman
java.lang.String salesman
persistent field

salesmanId
short salesmanId
persistent field

qt
java.lang.String qt
persistent field

sgSo
java.lang.String sgSo
persistent field

requestor
java.lang.String requestor
persistent field

project
java.lang.String project
persistent field

reldoc
java.lang.String reldoc
persistent field

debitAccount
java.lang.String debitAccount
persistent field

bp
java.lang.String bp
persistent field

loanComments
java.lang.String loanComments
nullable persistent field

loanNotes
java.lang.String loanNotes
nullable persistent field

companyUnitId
java.lang.String companyUnitId
persistent field

version
java.lang.Integer version
persistent field

onLoanItems
java.util.Set<E> onLoanItems
persistent field

customerAddressInfo
CustomerVendorAddressInfoVO customerAddressInfo
nullable persistent field

shipToAddressInfo
CustomerVendorAddressInfoVO shipToAddressInfo
nullable persistent field

billToAddressInfo
CustomerVendorAddressInfoVO billToAddressInfo
nullable persistent field

onLoanDocuments
java.util.Set<E> onLoanDocuments
Class bb.common.OnTimeAgent extends java.lang.Object implements Serializable

Serialized Fields

listFiscalYear
boolean listFiscalYear
listYearToDate
boolean listYearToDate
list12MonthAvg
boolean list12MonthAvg
months
int months
day1
int day1
day2
int day2
Class bb.common.OntimeDeliveryRateListResult extends java.lang.Object implements Serializable

Serialized Fields

id
java.lang.String id
name
java.lang.String name
totalItemCount
java.math.BigDecimal totalItemCount
onTimeDelivedItemCount
java.math.BigDecimal onTimeDelivedItemCount
onTimeDeliveryRate
java.math.BigDecimal onTimeDeliveryRate
Class bb.common.OntimeDeliveryRateResult extends java.lang.Object implements Serializable

Serialized Fields

addressInfo
CustomerVendorAddressInfoVO addressInfo
totalItemCount
java.math.BigDecimal totalItemCount
onTimeDelivedItemCount
java.math.BigDecimal onTimeDelivedItemCount
onTimeDeliveryRate
java.math.BigDecimal onTimeDeliveryRate
Class bb.common.OpCodeShortcutPK extends java.lang.Object implements Serializable

Serialized Fields

userName
java.lang.String userName
operateCode
java.lang.String operateCode
Class bb.common.OpCodeShortcutVO extends VO implements Serializable

Serialized Fields

pk
OpCodeShortcutPK pk
shortcut
java.lang.String shortcut
Class bb.common.OperatingInstructionsInspectMethodItemPK extends java.lang.Object implements Serializable

Serialized Fields

operatingInstructionsNumber
java.lang.String operatingInstructionsNumber
ii
java.lang.Integer ii
Class bb.common.OperatingInstructionsInspectMethodItemVO extends VO implements Serializable

Serialized Fields

pk
OperatingInstructionsInspectMethodItemPK pk
operatingInstructionsInspectMethod
InspectionReportInspectMethodVO operatingInstructionsInspectMethod
Class bb.common.OperatingInstructionsInspectResultItemPK extends java.lang.Object implements Serializable

Serialized Fields

operatingInstructionsNumber
java.lang.String operatingInstructionsNumber
ii
java.lang.Integer ii
Class bb.common.OperatingInstructionsInspectResultItemVO extends VO implements Serializable

Serialized Fields

pk
OperatingInstructionsInspectResultItemPK pk
inspectionResultSign
java.lang.String inspectionResultSign
inspectionResult
java.lang.String inspectionResult
inspectionReportNumber
java.lang.String inspectionReportNumber
inspectionDate
java.util.Date inspectionDate
Class bb.common.OperatingInstructionsInspectStandardItemPK extends java.lang.Object implements Serializable

Serialized Fields

operatingInstructionsNumber
java.lang.String operatingInstructionsNumber
ii
java.lang.Integer ii
Class bb.common.OperatingInstructionsInspectStandardItemVO extends VO implements Serializable

Serialized Fields

pk
OperatingInstructionsInspectStandardItemPK pk
operatingInstructionsInspectStandard
OperatingInstructionsInspectStandardVO operatingInstructionsInspectStandard
Class bb.common.OperatingInstructionsInspectStandardVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Integer ii
description
java.lang.String description
Class bb.common.OperatingInstructionsManualItemPK extends java.lang.Object implements Serializable

Serialized Fields

operatingInstructionsNumber
java.lang.String operatingInstructionsNumber
ii
java.lang.Integer ii
Class bb.common.OperatingInstructionsManualItemVO extends VO implements Serializable

Serialized Fields

pk
OperatingInstructionsManualItemPK pk
operatingInstructionsManual
OperatingInstructionsManualVO operatingInstructionsManual
Class bb.common.OperatingInstructionsManualVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Integer ii
description
java.lang.String description
Class bb.common.OperatingInstructionsTypeVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Integer ii
description
java.lang.String description
serialNumberType
java.lang.String serialNumberType
Class bb.common.OperatingInstructionsUserStatisticalResult extends java.lang.Object implements Serializable

Serialized Fields

operatingInstructionsNumber
java.lang.String operatingInstructionsNumber
workOrderAndItemNumber
java.lang.String workOrderAndItemNumber
responsibility
java.lang.String responsibility
operatingInstructionsTypeDescription
java.lang.String operatingInstructionsTypeDescription
operatingInstructionsDescription
java.lang.String operatingInstructionsDescription
quantity
java.math.BigDecimal quantity
staff
java.lang.String staff
startDate
java.util.Date startDate
endDate
java.util.Date endDate
pausedTime
java.util.Date pausedTime
elapsedTimeByHour
java.math.BigDecimal elapsedTimeByHour
pausedTimeByHour
java.math.BigDecimal pausedTimeByHour
status
java.lang.String status
Class bb.common.OperatingInstructionsVO extends VO implements Serializable

Serialized Fields

operatingInstructionsNumber
java.lang.String operatingInstructionsNumber
workOrderAndItemNumber
java.lang.String workOrderAndItemNumber
project
java.lang.String project
serial
java.lang.String serial
responsibility
java.lang.String responsibility
operatingInstructionsTypeId
java.lang.Integer operatingInstructionsTypeId
operatingInstructionsType
OperatingInstructionsTypeVO operatingInstructionsType
operatingInstructionsDescription
java.lang.String operatingInstructionsDescription
quantity
java.math.BigDecimal quantity
pickListOrderNumber
java.lang.String pickListOrderNumber
operatingInstructionsManuals
java.util.Set<E> operatingInstructionsManuals
drawingNumber
java.lang.String drawingNumber
operatingEnvironment
boolean operatingEnvironment
operatingInstructionsNotes
java.lang.String operatingInstructionsNotes
staff
java.lang.String staff
startDate
java.util.Date startDate
endDate
java.util.Date endDate
pausedTime
java.util.Date pausedTime
elapsedTimeByHour
java.math.BigDecimal elapsedTimeByHour
pausedTimeByHour
java.math.BigDecimal pausedTimeByHour
operatingProcessRecord
java.lang.String operatingProcessRecord
operatingOutputFiles
java.util.Set<E> operatingOutputFiles
staffSign
java.lang.String staffSign
relatedInspectorSign
java.lang.String relatedInspectorSign
operatingProcessNotes
java.lang.String operatingProcessNotes
requestInspectionDate
java.util.Date requestInspectionDate
inspectionContent
java.lang.String inspectionContent
operatingInstructionsInspectStandardItems
java.util.Set<E> operatingInstructionsInspectStandardItems
inspectionResult
java.lang.String inspectionResult
inspectionResultSign
java.lang.String inspectionResultSign
resolveResult
java.lang.String resolveResult
resolveResultSign
java.lang.String resolveResultSign
inspectionOutputFile
boolean inspectionOutputFile
inspectionOutputFileNumber
java.lang.String inspectionOutputFileNumber
operatingInstructionsInspectResultItems
java.util.Set<E> operatingInstructionsInspectResultItems
operatingInstructionsInspectMethodItems
java.util.Set<E> operatingInstructionsInspectMethodItems
status
java.lang.String status
inspectionReportNumber
java.lang.String inspectionReportNumber
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
adate
java.util.Date adate
origin
java.lang.String origin
version
java.lang.Integer version
Class bb.common.OperatingOutputFileItemPK extends java.lang.Object implements Serializable

Serialized Fields

operatingInstructionsNumber
java.lang.String operatingInstructionsNumber
ii
java.lang.Integer ii
Class bb.common.OperatingOutputFileItemVO extends VO implements Serializable

Serialized Fields

pk
OperatingOutputFileItemPK pk
recordNumber
java.lang.String recordNumber
operatingOutputFileType
OperatingOutputFileTypeVO operatingOutputFileType
Class bb.common.OperatingOutputFileTypeVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Integer ii
description
java.lang.String description
Class bb.common.OperationLogVO extends VO implements Serializable

Serialized Fields

id
java.lang.Long id
identifier field

server
java.lang.String server
identifier field

port
java.lang.String port
identifier field

system
java.lang.String system
identifier field

userName
java.lang.String userName
nullable persistent field

type
byte type
persistent field

trueName
java.lang.String trueName
nullable persistent field

action
java.lang.String action
nullable persistent field

target
java.lang.String target
nullable persistent field

actionTime
java.util.Date actionTime
nullable persistent field

wanIp
java.lang.String wanIp
lanIp
java.lang.String lanIp
macAddress
java.lang.String macAddress
comment
java.lang.String comment
nullable persistent field

employeeID
java.lang.String employeeID
Class bb.common.OrderApprovalItemsVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
action
java.lang.String action
orderApprovalID
java.lang.Long orderApprovalID
orderApproval
OrderApprovalVO orderApproval
originalOrderItem
java.lang.String originalOrderItem
originalPartNumber
java.lang.String originalPartNumber
originalPartType
java.lang.String originalPartType
originalPartDesc
java.lang.String originalPartDesc
originalQty
java.math.BigDecimal originalQty
originalPoQty
java.math.BigDecimal originalPoQty
originalAvgCost
java.math.BigDecimal originalAvgCost
originalStdCost
java.math.BigDecimal originalStdCost
originalDiscount
java.math.BigDecimal originalDiscount
originalTaxRate
java.math.BigDecimal originalTaxRate
originalStartDate
java.util.Date originalStartDate
originalEndDate
java.util.Date originalEndDate
originalStatus
java.lang.String originalStatus
partNumber
java.lang.String partNumber
partType
java.lang.String partType
qty
java.math.BigDecimal qty
poQty
java.math.BigDecimal poQty
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
discount
java.math.BigDecimal discount
taxRate
java.math.BigDecimal taxRate
startDate
java.util.Date startDate
endDate
java.util.Date endDate
delayDays
int delayDays
revision
java.lang.String revision
dwg
java.lang.String dwg
unit
java.lang.String unit
poUnit
java.lang.String poUnit
poUnitRate
java.math.BigDecimal poUnitRate
shipVia
java.lang.String shipVia
description
java.lang.String description
itemComments
java.lang.String itemComments
itemPrivateNotes
java.lang.String itemPrivateNotes
mfg
java.lang.String mfg
mpn
java.lang.String mpn
original
java.util.Date original
originalExtendPrice
java.math.BigDecimal originalExtendPrice
extendPrice
java.math.BigDecimal extendPrice
referenceDoc1
java.lang.String referenceDoc1
referenceDoc2
java.lang.String referenceDoc2
status
java.lang.String status
originalIcrRequiredWhenReceiverNa
boolean originalIcrRequiredWhenReceiverNa
icrRequiredWhenReceiverNa
boolean icrRequiredWhenReceiverNa
Class bb.common.OrderApprovalVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
action
java.lang.String action
orderType
java.lang.String orderType
orderNumber
java.lang.String orderNumber
applyDate
java.util.Date applyDate
applyBy
java.lang.String applyBy
approvedDate
java.util.Date approvedDate
approvedBy
java.lang.String approvedBy
status
java.lang.String status
description
java.lang.String description
items
java.util.Set<E> items
Class bb.common.OrderBoilerplatePK extends java.lang.Object implements Serializable

Serialized Fields

orderNumber
java.lang.String orderNumber
identifier field

ii
java.lang.Byte ii
identifier field

Class bb.common.OrderBoilerplateVO extends VO implements Serializable

Serialized Fields

pk
OrderBoilerplatePK pk
identifier field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

bpId
java.lang.String bpId
persistent field

bplate
java.lang.String bplate
persistent field

Class bb.common.OrderBy extends java.lang.Object implements Serializable

Serialized Fields

orderBy
java.util.LinkedHashMap<K,V> orderBy
Class bb.common.OrderDemandForReceiverResult extends java.lang.Object implements Serializable

Serialized Fields

orderNumber
java.lang.String orderNumber
itemNumber
java.lang.String itemNumber
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
demand
java.math.BigDecimal demand
unit
java.lang.String unit
Class bb.common.OrderDocumentVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
orderNumber
java.lang.String orderNumber
docType
java.lang.String docType
docDescription
java.lang.String docDescription
documentDate
java.util.Date documentDate
comments
java.lang.String comments
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
extension
java.lang.String extension
docFileName
java.lang.String docFileName
docLength
long docLength
Class bb.common.OrderPK extends java.lang.Object implements Serializable

Serialized Fields

orderNumber
java.lang.String orderNumber
itemNumber
java.lang.String itemNumber
Class bb.common.OrderVendorItem extends java.lang.Object implements Serializable

Serialized Fields

vendorID
java.lang.String vendorID
pk
OrderPK pk
arriveDate
java.util.Date arriveDate
shortQty
java.math.BigDecimal shortQty
Class bb.common.OutputValueByMonthResult extends java.lang.Object implements Serializable

Serialized Fields

monthOutputValues
java.util.Map<K,V> monthOutputValues
totalOutputValue
java.math.BigDecimal totalOutputValue
Class bb.common.PackingBoxItemListResult extends java.lang.Object implements Serializable

Serialized Fields

packingBoxItemPk
PackingBoxItemPK packingBoxItemPk
customerId
java.lang.String customerId
status
java.lang.String status
partNumber
java.lang.String partNumber
partType
java.lang.String partType
quantity
java.math.BigDecimal quantity
partFrom
java.lang.String partFrom
description
java.lang.String description
Class bb.common.PackingBoxItemPK extends java.lang.Object implements Serializable

Serialized Fields

pfInvoiceNumber
java.lang.String pfInvoiceNumber
identifier field

packingBoxNumber
java.lang.Integer packingBoxNumber
identifier field

salesOrderNumber
java.lang.String salesOrderNumber
identifier field

salesOrderItemNumber
java.lang.String salesOrderItemNumber
identifier field

Class bb.common.PackingBoxItemVO extends VO implements Serializable

Serialized Fields

pk
PackingBoxItemPK pk
identifier field

status
java.lang.String status
persistent field

quantity
java.math.BigDecimal quantity
persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
description
java.lang.String description
persistent field

customerId
java.lang.String customerId
persistent field

purchaseOrderNumber
java.lang.String purchaseOrderNumber
persistent field

shipTo
java.lang.String shipTo
persistent field

shipVia
java.lang.String shipVia
persistent field

weight
java.lang.String weight
locations
java.util.Map<K,V> locations
trackings
java.util.Map<K,V> trackings
Class bb.common.PackingBoxPK extends java.lang.Object implements Serializable

Serialized Fields

pfInvoiceNumber
java.lang.String pfInvoiceNumber
identifier field

packingBoxNumber
java.lang.Integer packingBoxNumber
identifier field

Class bb.common.PackingBoxSalesOrderItemAgent extends java.lang.Object implements Serializable

Serialized Fields

soItemPk
SalesOrderItemPK soItemPk
packingBoxPk
PackingBoxPK packingBoxPk
d
java.util.HashMap<K,V> d
trackings
java.util.HashMap<K,V> trackings
Class bb.common.PackingBoxSalesOrderItemResult extends java.lang.Object implements Serializable

Serialized Fields

salesOrderNumber
java.lang.String salesOrderNumber
salesOrderItemNumber
java.lang.String salesOrderItemNumber
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
revision
java.lang.String revision
description
java.lang.String description
status
java.lang.String status
shippingStatus
java.lang.String shippingStatus
sipQty
java.math.BigDecimal sipQty
qty
java.math.BigDecimal qty
shipQty
java.math.BigDecimal shipQty
shortQty
java.math.BigDecimal shortQty
ptSipQty
java.math.BigDecimal ptSipQty
checked
boolean checked
d
java.util.HashMap<K,V> d
Class bb.common.PackingBoxVO extends VO implements Serializable

Serialized Fields

pk
PackingBoxPK pk
identifier field

customerId
java.lang.String customerId
persistent field

status
java.lang.String status
persistent field

dimension
java.lang.String dimension
persistent field

grossWeight
java.math.BigDecimal grossWeight
persistent field

netWeight
java.math.BigDecimal netWeight
persistent field

weightUnit
java.lang.String weightUnit
persistent field

bb2ShipVia
java.lang.String bb2ShipVia
persistent field

bb2ShipTo
java.lang.String bb2ShipTo
persistent field

bb2ShipToName
java.lang.String bb2ShipToName
packingBoxItems
java.util.Set<E> packingBoxItems
persistent field

Class bb.common.PartBasicInfo extends java.lang.Object implements Serializable

Serialized Fields

partPk
PartPK partPk
revision
java.lang.String revision
hold
java.lang.String hold
drawing
java.lang.String drawing
bill
java.lang.String bill
traceable
java.lang.String traceable
lastUser
java.lang.String lastUser
lastChangeDate
java.util.Date lastChangeDate
origin
java.lang.String origin
description
java.lang.String description
wi
java.lang.String wi
partUnit
java.lang.String partUnit
makeBuy
java.lang.String makeBuy
weight
float weight
weightUnit
java.lang.String weightUnit
volume
java.math.BigDecimal volume
volumeUnit
java.lang.String volumeUnit
buyerCode
java.lang.String buyerCode
material
java.lang.String material
modelNumber
java.lang.String modelNumber
commodityCode
java.lang.String commodityCode
productCode
java.lang.String productCode
salesDrawing
java.lang.String salesDrawing
havePicture
java.lang.String havePicture
saleable
java.lang.String saleable
engGroup
java.lang.String engGroup
securityLevel
java.lang.String securityLevel
detectionStandard
java.lang.String detectionStandard
countryOrigin
java.lang.String countryOrigin
leadTime
java.math.BigDecimal leadTime
Class bb.common.PartBasicInfoWithNewEngGroup extends PartBasicInfo implements Serializable

Serialized Fields

newEngGroup
java.lang.String newEngGroup
Class bb.common.PartBasicInfoWithNewListPrice extends PartBasicInfo implements Serializable

Serialized Fields

listPrice
java.math.BigDecimal listPrice
newListPrice
java.math.BigDecimal newListPrice
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
Class bb.common.PartCatagoryPK extends java.lang.Object implements Serializable

Serialized Fields

bigCatagory
java.lang.String bigCatagory
smallCatagory
java.lang.String smallCatagory
Class bb.common.PartCatagoryVO extends VO implements Serializable

Serialized Fields

pk
PartCatagoryPK pk
name
java.lang.String name
Class bb.common.PartCatalogAuditResult extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
name
java.lang.String name
catalog
java.lang.String catalog
description
java.lang.String description
saleable
java.lang.String saleable
cause
java.lang.String cause
alarmValue
boolean alarmValue
Class bb.common.PartCatalogPK extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
identifier field

partType
java.lang.String partType
identifier field

partFrom
java.lang.String partFrom
identifier field

Class bb.common.PartCatalogVO extends VO implements Serializable

Serialized Fields

pk
PartCatalogPK pk
identifier field

name
java.lang.String name
persistent field

catalog
java.lang.String catalog
persistent field

comments
java.lang.String comments
persistent field

Class bb.common.PartCertificateListResult extends java.lang.Object implements Serializable

Serialized Fields

controlNumber
java.lang.Integer controlNumber
certificateNumber
java.lang.String certificateNumber
companyName
java.lang.String companyName
certificateDescription
java.lang.String certificateDescription
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
partDescription
java.lang.String partDescription
workOrderNumber
java.lang.String workOrderNumber
purchaseOrderNumber
java.lang.String purchaseOrderNumber
receiverNumber
java.lang.String receiverNumber
salesOrderNumber
java.lang.String salesOrderNumber
referenceNumber
java.lang.String referenceNumber
extension
java.lang.String extension
docLength
long docLength
docName
java.lang.String docName
Class bb.common.PartCertificateVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Integer ii
identifier field

companyName
java.lang.String companyName
persistent field

certificateNumber
java.lang.String certificateNumber
persistent field

certificateDescription
java.lang.String certificateDescription
persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
persistent field

revision
java.lang.String revision
persistent field

certificateDate
java.util.Date certificateDate
persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

workerOrderNumber
java.lang.String workerOrderNumber
persistent field

purchaseOrderNumber
java.lang.String purchaseOrderNumber
persistent field

receiverNumber
java.lang.String receiverNumber
persistent field

salesOrderNumber
java.lang.String salesOrderNumber
persistent field

comments
java.lang.String comments
persistent field

referenceNumber
java.lang.String referenceNumber
persistent field

extension
java.lang.String extension
docLength
long docLength
docName
java.lang.String docName
version
java.lang.Integer version
nullable persistent field

Class bb.common.PartClassInfoResult extends java.lang.Object implements Serializable

Serialized Fields

part
BB2Part part
description
java.lang.String description
partClass
java.lang.String partClass
Class bb.common.PartClassVO extends VO implements Serializable

Serialized Fields

id
java.lang.String id
identifier field

comments
java.lang.String comments
persistent field

period
int period
periodUnit
java.lang.String periodUnit
persistent field

lastCycleCount
java.util.Date lastCycleCount
nextCycleCount
java.util.Date nextCycleCount
locked
boolean locked
owner
java.lang.String owner
Class bb.common.PartCostVarianceListResult extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
partType
java.lang.String partType
makeBuy
java.lang.String makeBuy
partDescription
java.lang.String partDescription
standardCost
java.math.BigDecimal standardCost
averageCost
java.math.BigDecimal averageCost
variance
java.math.BigDecimal variance
variancePercent
java.math.BigDecimal variancePercent
lastPurchaseOrderNumberAndItemNumber
java.lang.String lastPurchaseOrderNumberAndItemNumber
lastPurchasePrice
java.math.BigDecimal lastPurchasePrice
lastPurchaseOrderVendorID
java.lang.String lastPurchaseOrderVendorID
lastPurchaseOrderVendorName
java.lang.String lastPurchaseOrderVendorName
Class bb.common.PartDescriptionPK extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
identifier field

partType
java.lang.String partType
identifier field

languageCode
java.lang.String languageCode
identifier field

Class bb.common.PartDescriptionVO extends VO implements Serializable

Serialized Fields

pk
PartDescriptionPK pk
version
java.lang.Integer version
status
java.lang.String status
description
java.lang.String description
Class bb.common.PartDiscountPK extends java.lang.Object implements Serializable

Serialized Fields

dCode
java.lang.String dCode
customerType
java.lang.String customerType
Class bb.common.PartDiscountVO extends VO implements Serializable

Serialized Fields

pk
PartDiscountPK pk
discountRate
java.math.BigDecimal discountRate
comments
java.lang.String comments
Class bb.common.PartDocumentPK extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
identifier field

documentType
java.lang.String documentType
identifier field

language
java.lang.String language
identifier field

Class bb.common.PartDocumentVO extends VO implements Serializable

Serialized Fields

pk
PartDocumentPK pk
identifier field

docVersion
java.lang.String docVersion
lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

publicDoc
boolean publicDoc
persistent field

description
java.lang.String description
persistent field

comments
java.lang.String comments
nullable persistent field

documentLengthByte
java.lang.Long documentLengthByte
extension
java.lang.String extension
Class bb.common.PartDueAddressListResult extends java.lang.Object implements Serializable

Serialized Fields

addressId
java.lang.String addressId
addressName
java.lang.String addressName
totalItems
java.lang.Long totalItems
Class bb.common.PartDwfAgent extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
language
java.lang.String language
wanIp
java.lang.String wanIp
lanIp
java.lang.String lanIp
macAdd
java.lang.String macAdd
drawingRevision
java.lang.String drawingRevision
drawing
byte[] drawing
extension
java.lang.String extension
picture
byte[] picture
Class bb.common.PartDwfPK extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
identifier field

partType
java.lang.String partType
identifier field

partFrom
java.lang.String partFrom
identifier field

language
java.lang.String language
identifier field

Class bb.common.PartDwfVO extends VO implements Serializable

Serialized Fields

pk
PartDwfPK pk
identifier field

revision
java.lang.String revision
lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

dwgLength
long dwgLength
persistent field

dwgExtension
java.lang.String dwgExtension
persistent field

picture
byte[] picture
Class bb.common.PartDwfWithPartInfoResult extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
revision
java.lang.String revision
language
java.lang.String language
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
dwfLength
long dwfLength
dwfExtension
java.lang.String dwfExtension
partDescription
java.lang.String partDescription
partRevision
java.lang.String partRevision
picture
byte[] picture
Class bb.common.PartDwgAgent extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
revision
java.lang.String revision
wanIp
java.lang.String wanIp
lanIp
java.lang.String lanIp
macAdd
java.lang.String macAdd
dwgLength
int dwgLength
key
java.lang.String key
picture
byte[] picture
extension
java.lang.String extension
Class bb.common.PartDwgPK extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
identifier field

partType
java.lang.String partType
identifier field

partFrom
java.lang.String partFrom
identifier field

revision
java.lang.String revision
identifier field

extension
java.lang.String extension
Class bb.common.PartDwgVO extends VO implements Serializable

Serialized Fields

pk
PartDwgPK pk
identifier field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

dwgLength
long dwgLength
persistent field

dwgExtension
java.lang.String dwgExtension
persistent field

picture
byte[] picture
Class bb.common.PartDwgWithPartInfoResult extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
revision
java.lang.String revision
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
dwgLength
long dwgLength
dwgExtension
java.lang.String dwgExtension
partDescription
java.lang.String partDescription
partRevision
java.lang.String partRevision
picture
byte[] picture
Class bb.common.PartExportInfo extends PartBasicInfo implements Serializable

Serialized Fields

owner
java.lang.String owner
shippingWeight
java.lang.String shippingWeight
shippingWeightUnit
java.lang.String shippingWeightUnit
revisionDate
java.util.Date revisionDate
createdDate
java.util.Date createdDate
Class bb.common.PartInMrpListResult extends java.lang.Object implements Serializable

Serialized Fields

partPk
PartPK partPk
partUnit
java.lang.String partUnit
description
java.lang.String description
totalOndemand
java.math.BigDecimal totalOndemand
soDetails
java.util.ArrayList<E> soDetails
woDetails
java.util.ArrayList<E> woDetails
Class bb.common.PartInQAAgent extends java.lang.Object implements Serializable

Serialized Fields

part
BB2Part part
qty
java.math.BigDecimal qty
cost
java.math.BigDecimal cost
receivedFrom
java.lang.String receivedFrom
ncrNumber
java.lang.String ncrNumber
comments
java.lang.String comments
serialNo
java.lang.String serialNo
refDoc
java.lang.String refDoc
ii
int ii
Class bb.common.PartInQAResult extends VO implements Serializable

Serialized Fields

ii
java.lang.Integer ii
identifier field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
persistent field

quantity
java.math.BigDecimal quantity
persistent field

cost
java.math.BigDecimal cost
persistent field

receivedDate
java.util.Date receivedDate
persistent field

receivedBy
java.lang.String receivedBy
persistent field

receivedFrom
java.lang.String receivedFrom
persistent field

ncrNumber
java.lang.String ncrNumber
partDescription
java.lang.String partDescription
partonhand
java.util.List<E> partonhand
persistent field

partInqaItems
java.util.List<E> partInqaItems
comments
java.lang.String comments
Class bb.common.PartInQAVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Integer ii
identifier field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
persistent field

quantity
java.math.BigDecimal quantity
persistent field

cost
java.math.BigDecimal cost
persistent field

receivedDate
java.util.Date receivedDate
persistent field

receivedBy
java.lang.String receivedBy
persistent field

refDoc
java.lang.String refDoc
receivedFrom
java.lang.String receivedFrom
persistent field

receiverNumber
java.lang.String receiverNumber
ncrNumber
java.lang.String ncrNumber
comments
java.lang.String comments
persistent field

serialNo
java.lang.String serialNo
Class bb.common.PartInspectionPK extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
itemNumber
java.lang.String itemNumber
Class bb.common.PartInspectionResult extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
inspectionType
java.lang.String inspectionType
description
java.lang.String description
inspections
java.util.Set<E> inspections
Class bb.common.PartInspectionVO extends VO implements Serializable

Serialized Fields

pk
PartInspectionPK pk
inspectProject
java.lang.String inspectProject
unit
java.lang.String unit
technolgyStandard
java.lang.String technolgyStandard
Class bb.common.PartInventoryVO extends VO implements Serializable

Serialized Fields

pk
PartPK pk
version
java.lang.Integer version
modelNumber
java.lang.String modelNumber
active
java.lang.String active
onhand
java.math.BigDecimal onhand
shippedQty
java.math.BigDecimal shippedQty
receivedQty
java.math.BigDecimal receivedQty
workInProcessQty
java.math.BigDecimal workInProcessQty
onloanQty
java.math.BigDecimal onloanQty
consignedQty
java.math.BigDecimal consignedQty
inQualityCheckingQty
java.math.BigDecimal inQualityCheckingQty
onDemandQty
java.math.BigDecimal onDemandQty
onOrderQty
java.math.BigDecimal onOrderQty
listPrice
java.math.BigDecimal listPrice
averageCost
java.math.BigDecimal averageCost
standardCost
java.math.BigDecimal standardCost
firstInCost
java.math.BigDecimal firstInCost
pCode
java.lang.String pCode
cCode
java.lang.String cCode
oCode
java.lang.String oCode
dCode
java.lang.String dCode
eCode
java.lang.String eCode
purchaseOrderUnit
java.lang.String purchaseOrderUnit
salesOrderUnit
java.lang.String salesOrderUnit
leadTime
java.math.BigDecimal leadTime
minQty
java.math.BigDecimal minQty
maxQty
java.math.BigDecimal maxQty
yearUsage
java.math.BigDecimal yearUsage
quarterUsage
java.math.BigDecimal quarterUsage
ga
java.lang.String ga
purchaseCost
java.math.BigDecimal purchaseCost
lastPurchaseCost
java.math.BigDecimal lastPurchaseCost
lastPurchaseOrderNumber
java.lang.String lastPurchaseOrderNumber
lastPurchaseOrderItemNumber
java.lang.String lastPurchaseOrderItemNumber
shipInProcessQty
java.math.BigDecimal shipInProcessQty
shipInTransactionQty
java.math.BigDecimal shipInTransactionQty
recostedDate
java.util.Date recostedDate
lastOutDate
java.util.Date lastOutDate
lastInDate
java.util.Date lastInDate
partClass
java.lang.String partClass
varianceCost
java.math.BigDecimal varianceCost
inSTO
java.math.BigDecimal inSTO
cycleCount
int cycleCount
lastCount
java.util.Date lastCount
Class bb.common.PartInWipForIDListResult extends java.lang.Object implements Serializable

Serialized Fields

workOrderNumber
java.lang.String workOrderNumber
workorderItemNumber
java.lang.String workorderItemNumber
partInWip
BB2Part partInWip
part
BB2Part part
description
java.lang.String description
partInWipDescription
java.lang.String partInWipDescription
issuedQty
java.math.BigDecimal issuedQty
inWipQty
java.math.BigDecimal inWipQty
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
vendorId
java.lang.String vendorId
Class bb.common.PartIssuedListResult extends PartIssuedVO implements Serializable

Serialized Fields

relatedDoc
java.lang.String relatedDoc
currency
java.lang.String currency
dateRequired
java.util.Date dateRequired
project
java.lang.String project
currentOnhand
java.math.BigDecimal currentOnhand
totalIssued
java.math.BigDecimal totalIssued
Class bb.common.PartIssuedVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Integer ii
identifier field

orderNumber
java.lang.Integer orderNumber
itemNumber
java.lang.Short itemNumber
woisii
java.lang.Short woisii
vendorId
java.lang.String vendorId
persistent field

workOrderNumber
java.lang.String workOrderNumber
persistent field

workOrderItemNumber
java.lang.String workOrderItemNumber
persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
persistent field

description
java.lang.String description
persistent field

qtyIssued
java.math.BigDecimal qtyIssued
persistent field

dateIssued
java.util.Date dateIssued
persistent field

operator
java.lang.String operator
cost
java.math.BigDecimal cost
persistent field

stdCost
java.math.BigDecimal stdCost
unit
java.lang.String unit
persistent field

serial
java.lang.String serial
persistent field

lot
java.lang.String lot
persistent field

locate
java.lang.String locate
note
java.lang.String note
picker
java.lang.String picker
transactionNumber
java.lang.String transactionNumber
persistent field

trackings
java.util.Map<K,V> trackings
Class bb.common.PartIssueTotalResult extends java.lang.Object implements Serializable

Serialized Fields

numOfItems
java.lang.Integer numOfItems
totIssued
java.math.BigDecimal totIssued
totIssuedAvgCost
java.math.BigDecimal totIssuedAvgCost
totIssuedStdCost
java.math.BigDecimal totIssuedStdCost
Class bb.common.PartManufacturerPK extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
identifier field

partType
java.lang.String partType
identifier field

manufacturerItem
java.lang.Short manufacturerItem
identifier field

Class bb.common.PartManufacturerVO extends VO implements Serializable

Serialized Fields

pk
PartManufacturerPK pk
manufacturerId
java.lang.String manufacturerId
qualityCode
java.lang.String qualityCode
ratingCode
java.lang.String ratingCode
preferredSo
boolean preferredSo
preferredPo
boolean preferredPo
manufacturerName
java.lang.String manufacturerName
manufacturerPartNumber
java.lang.String manufacturerPartNumber
manufacturerPartRev
java.lang.String manufacturerPartRev
remarks
java.lang.String remarks
version
java.lang.Integer version
unit
java.lang.String unit
Class bb.common.PartMaterialBomListResult extends PartMaterialListResult implements Serializable

Serialized Fields

items
java.util.Set<E> items
Class bb.common.PartMaterialListResult extends PartBasicInfo implements Serializable

Serialized Fields

material
java.lang.String material
type
java.lang.String type
outerDiameter
java.math.BigDecimal outerDiameter
innerDiameter
java.math.BigDecimal innerDiameter
innerDiameterUnit
java.lang.String innerDiameterUnit
outerDiameterUnit
java.lang.String outerDiameterUnit
length
java.math.BigDecimal length
lengthUnit
java.lang.String lengthUnit
yrUsage
java.math.BigDecimal yrUsage
qtrUsage
java.math.BigDecimal qtrUsage
Class bb.common.PartMaterialReportAgent extends java.lang.Object implements Serializable

Serialized Fields

partPk
PartPK partPk
material
java.lang.String material
type
java.lang.String type
innerOperator
java.lang.String innerOperator
innerDiameter
java.math.BigDecimal innerDiameter
outterOperator
java.lang.String outterOperator
outerDiameter
java.math.BigDecimal outerDiameter
wallOperator
java.lang.String wallOperator
wallDiameter
java.math.BigDecimal wallDiameter
innerUnit
java.lang.String innerUnit
outerUnit
java.lang.String outerUnit
length
java.math.BigDecimal length
lengthUnit
java.lang.String lengthUnit
lengthOperator
java.lang.String lengthOperator
Class bb.common.PartMaterialVO extends VO implements Serializable

Serialized Fields

pk
PartPK pk
identifier field

material
java.lang.String material
persistent field

type
java.lang.String type
persistent field

innerDiameterUnit
java.lang.String innerDiameterUnit
persistent field

innerDiameter
java.math.BigDecimal innerDiameter
persistent field

outerDiameterUnit
java.lang.String outerDiameterUnit
persistent field

outerDiameter
java.math.BigDecimal outerDiameter
persistent field

lengthUnit
java.lang.String lengthUnit
persistent field

length
java.math.BigDecimal length
persistent field

Class bb.common.PartMaterialWhereUsedItemResult extends java.lang.Object implements Serializable

Serialized Fields

billItemPk
BillItemPK billItemPk
qty
java.math.BigDecimal qty
description
java.lang.String description
onhand
java.math.BigDecimal onhand
qtrUsage
java.math.BigDecimal qtrUsage
yrUsage
java.math.BigDecimal yrUsage
bill
java.lang.String bill
outerDiameterUnit
java.lang.String outerDiameterUnit
innerDiameterUnit
java.lang.String innerDiameterUnit
lengthUnit
java.lang.String lengthUnit
outerDiameter
java.math.BigDecimal outerDiameter
innerDiameter
java.math.BigDecimal innerDiameter
length
java.math.BigDecimal length
Class bb.common.PartMaterialWhereUsedResult extends java.lang.Object implements Serializable

Serialized Fields

partPk
PartPK partPk
description
java.lang.String description
items
java.util.Set<E> items
Class bb.common.PartMRPVO extends VO implements Serializable

Serialized Fields

pk
PartPK pk
identifier field

makeBuy
java.lang.String makeBuy
persistent field

floorStock
java.lang.String floorStock
persistent field

doNotUseInMrp
java.lang.String doNotUseInMrp
persistent field

doNotIssueToWo
java.lang.String doNotIssueToWo
persistent field

doNotKeepInInventory
java.lang.String doNotKeepInInventory
persistent field

Class bb.common.PartNumberGenerateRuleVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
startNumberForSeq
java.lang.String startNumberForSeq
Class bb.common.PartOnhandAndCostResult extends java.lang.Object implements Serializable

Serialized Fields

qty
java.math.BigDecimal qty
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
Class bb.common.PartOnHandAuditAgent extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
startDate
java.util.Date startDate
Class bb.common.PartOnHandAuditResult extends java.lang.Object implements Serializable

Serialized Fields

pk
PartPK pk
description
java.lang.String description
onhand
java.math.BigDecimal onhand
onhandTotal
java.math.BigDecimal onhandTotal
breakPoint
java.util.Date breakPoint
sip
java.math.BigDecimal sip
auditSip
java.math.BigDecimal auditSip
soSip
java.math.BigDecimal soSip
Class bb.common.PartOnhandCostVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
identifier field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
persistent field

vendorId
java.lang.String vendorId
persistent field

lastOutDate
java.util.Date lastOutDate
nullable persistent field

receivedDate
java.util.Date receivedDate
nullable persistent field

receivedQty
java.math.BigDecimal receivedQty
persistent field

location
java.lang.String location
persistent field

onhand
java.math.BigDecimal onhand
persistent field

fifoOnhand
java.math.BigDecimal fifoOnhand
fifoDate
java.util.Date fifoDate
costPerUnit
java.math.BigDecimal costPerUnit
persistent field

localCurrency
java.lang.String localCurrency
persistent field

exchangeRate
java.math.BigDecimal exchangeRate
persistent field

foreignCost
java.math.BigDecimal foreignCost
persistent field

foreignCurrency
java.lang.String foreignCurrency
persistent field

unit
java.lang.String unit
persistent field

serialNumber
java.lang.String serialNumber
persistent field

lot
java.lang.String lot
persistent field

refDoc
java.lang.String refDoc
persistent field

refDocReceiver
java.lang.String refDocReceiver
persistent field

Class bb.common.PartOnhandPK extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
partType
java.lang.String partType
location
java.lang.String location
Class bb.common.PartOnhandResult extends java.lang.Object implements Serializable

Serialized Fields

part
BB2Part part
description
java.lang.String description
partUnit
java.lang.String partUnit
shippingWeight
java.lang.Float shippingWeight
shippingWeightUnit
java.lang.String shippingWeightUnit
inSIP
java.math.BigDecimal inSIP
inWIP
java.math.BigDecimal inWIP
lastOutDate
java.util.Date lastOutDate
totalOnhand
java.math.BigDecimal totalOnhand
totalAvgCost
java.math.BigDecimal totalAvgCost
totalStdCost
java.math.BigDecimal totalStdCost
locates
java.util.Map<K,V> locates
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
listOtherLocationsForSamePart
boolean listOtherLocationsForSamePart
onLoan
java.math.BigDecimal onLoan
Class bb.common.PartOnhandVO extends VO implements Serializable

Serialized Fields

pk
PartOnhandPK pk
identifier field

modelNumber
java.lang.String modelNumber
persistent field

active
java.lang.String active
persistent field

onHandQuantity
java.math.BigDecimal onHandQuantity
persistent field

averageCost
java.math.BigDecimal averageCost
bb2description
java.lang.String bb2description
warehouse
java.lang.String warehouse
Class bb.common.PartOnhandWithAverageCostResult extends java.lang.Object implements Serializable

Serialized Fields

averageCost
java.math.BigDecimal averageCost
partOnhandVo
PartOnhandVO partOnhandVo
Class bb.common.PartOnHandWithMfgInfoResult extends PartBasicInfo implements Serializable

Serialized Fields

onhand
java.math.BigDecimal onhand
onorder
java.math.BigDecimal onorder
ondemand
java.math.BigDecimal ondemand
averageCost
java.math.BigDecimal averageCost
standardCost
java.math.BigDecimal standardCost
inWip
java.math.BigDecimal inWip
inSip
java.math.BigDecimal inSip
inSit
java.math.BigDecimal inSit
manufacturerId
java.lang.String manufacturerId
manufacturerName
java.lang.String manufacturerName
manufacturerPartNumber
java.lang.String manufacturerPartNumber
Class bb.common.PartOnHandWithPartBasicInfoResult extends PartBasicInfo implements Serializable

Serialized Fields

listPrice
java.math.BigDecimal listPrice
onhand
java.math.BigDecimal onhand
onDemandQty
java.math.BigDecimal onDemandQty
onOrderQty
java.math.BigDecimal onOrderQty
shipInProcessQty
java.math.BigDecimal shipInProcessQty
workInProcessQty
java.math.BigDecimal workInProcessQty
shipInTransactionQty
java.math.BigDecimal shipInTransactionQty
posOnhand
java.math.BigDecimal posOnhand
Class bb.common.PartPictureVO extends VO implements Serializable

Serialized Fields

lastChangeUser
java.lang.String lastChangeUser
nullable persistent field

picture
byte[] picture
nullable persistent field

extension
java.lang.String extension
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

ii
java.lang.Long ii
partNumber
java.lang.String partNumber
identifier field

partType
java.lang.String partType
identifier field

width
java.lang.Short width
identifier field

height
java.lang.Short height
identifier field

mainPicture
boolean mainPicture
Class bb.common.PartPK extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
identifier field

partType
java.lang.String partType
identifier field

Class bb.common.PartReceivedListResult extends PartReceivedVO implements Serializable

Serialized Fields

relatedDoc
java.lang.String relatedDoc
currency
java.lang.String currency
dateRequired
java.util.Date dateRequired
project
java.lang.String project
currentOnhand
java.math.BigDecimal currentOnhand
totalReceived
java.math.BigDecimal totalReceived
Class bb.common.PartReceivedVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Integer ii
identifier field

orderNumber
java.lang.Integer orderNumber
itemNumber
java.lang.Short itemNumber
vendorId
java.lang.String vendorId
persistent field

disassembleWorkOrderNumber
java.lang.String disassembleWorkOrderNumber
persistent field

disassembleWorkOrderItemNumber
java.lang.String disassembleWorkOrderItemNumber
persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
persistent field

description
java.lang.String description
persistent field

qtyReceived
java.math.BigDecimal qtyReceived
persistent field

dateReceived
java.util.Date dateReceived
persistent field

operator
java.lang.String operator
cost
java.math.BigDecimal cost
persistent field

stdCost
java.math.BigDecimal stdCost
unit
java.lang.String unit
persistent field

serial
java.lang.String serial
persistent field

lot
java.lang.String lot
persistent field

locate
java.lang.String locate
note
java.lang.String note
receiver
java.lang.String receiver
transactionNumber
java.lang.String transactionNumber
persistent field

trackings
java.util.Map<K,V> trackings
Class bb.common.PartSecurityLevelVO extends VO implements Serializable

Serialized Fields

levelId
java.lang.String levelId
levelDescription
java.lang.String levelDescription
Class bb.common.PartsToDeleteResult extends java.lang.Object implements Serializable

Serialized Fields

partsToDeleteInSO
java.util.List<E> partsToDeleteInSO
partsToDeleteInPO
java.util.List<E> partsToDeleteInPO
partsToDeleteInWO
java.util.List<E> partsToDeleteInWO
partsToDeleteInWOItemDetail
java.util.List<E> partsToDeleteInWOItemDetail
partsToDeletedNotUsed
java.util.List<E> partsToDeletedNotUsed
bomToDeletedNotUsed
java.util.List<E> bomToDeletedNotUsed
Class bb.common.PartToAuditFlagResult extends java.lang.Object implements Serializable

Serialized Fields

pk
PartPK pk
partFrom
java.lang.String partFrom
description
java.lang.String description
flagString
java.lang.String flagString
needToSetFLAG
boolean needToSetFLAG
Class bb.common.PartTraceableCategoryPK extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
identifier field

partType
java.lang.String partType
identifier field

traceableCategoryItem
java.lang.Short traceableCategoryItem
identifier field

Class bb.common.PartTraceableCategoryVO extends VO implements Serializable

Serialized Fields

pk
PartTraceableCategoryPK pk
categoryId
java.lang.String categoryId
categoryDescriptionVO
TraceableCategoriesVO categoryDescriptionVO
Class bb.common.PartTraceableInfoResult extends java.lang.Object implements Serializable

Serialized Fields

traceableLevel
java.lang.Byte traceableLevel
category
java.util.Collection<E> category
spec
java.util.Collection<E> spec
partBasicInfo
PartBasicInfo partBasicInfo
Class bb.common.PartTraceableListResult extends PartBasicInfo implements Serializable

Serialized Fields

traceableLevel
java.lang.Byte traceableLevel
newPart
java.lang.String newPart
Class bb.common.PartTraceableResult extends PartBasicInfo implements Serializable

Serialized Fields

traceableLevel
java.lang.Byte traceableLevel
categoryId
java.lang.String categoryId
specificationId
short specificationId
criticalityCategory
java.lang.String criticalityCategory
qualitySpecification
java.lang.String qualitySpecification
Class bb.common.PartTraceableSpecPK extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
identifier field

partType
java.lang.String partType
identifier field

partTraceableSpecItem
java.lang.Short partTraceableSpecItem
identifier field

Class bb.common.PartTraceableSpecVO extends VO implements Serializable

Serialized Fields

pk
PartTraceableSpecPK pk
specificationId
short specificationId
specificationVO
TraceableSpecsVO specificationVO
Class bb.common.PartTrackingPK extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
partType
java.lang.String partType
trackingNumber
java.lang.String trackingNumber
Class bb.common.PartTrackingVO extends VO implements Serializable

Serialized Fields

pk
PartTrackingPK pk
qty
java.math.BigDecimal qty
newQtyPicked
java.math.BigDecimal newQtyPicked
lastChangeDate
java.util.Date lastChangeDate
dueDate
java.util.Date dueDate
Class bb.common.PartTypeVO extends VO implements Serializable

Serialized Fields

id
java.lang.Short id
identifier field

partType
java.lang.String partType
persistent field

docType
boolean docType
description
java.lang.String description
persistent field

Class bb.common.PartUnitPK extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
partType
java.lang.String partType
unit
java.lang.String unit
Class bb.common.PartUnitVO extends VO implements Serializable

Serialized Fields

pk
PartUnitPK pk
listPrice
java.math.BigDecimal listPrice
multiplier
java.lang.String multiplier
salesOrderUnit
boolean salesOrderUnit
purchaseOrderUnit
boolean purchaseOrderUnit
defaultPartUnit
boolean defaultPartUnit
Class bb.common.partUsedInfoResult extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
qty
java.math.BigDecimal qty
cost
java.math.BigDecimal cost
dateUsed
java.util.Date dateUsed
Class bb.common.PartUseTypeVO extends VO implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
useType
java.lang.String useType
description
java.lang.String description
Class bb.common.PartVendorPK extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
identifier field

partType
java.lang.String partType
identifier field

vendorItem
java.lang.Byte vendorItem
identifier field

Class bb.common.PartVendorVO extends VO implements Serializable

Serialized Fields

pk
PartVendorPK pk
version
java.lang.Integer version
vendorId
java.lang.String vendorId
qualityCode
java.lang.String qualityCode
ratingCode
java.lang.String ratingCode
preferred
boolean preferred
vendorName
java.lang.String vendorName
vendorPrice
java.math.BigDecimal vendorPrice
vendorCurrency
java.lang.String vendorCurrency
poUnit
java.lang.String poUnit
poQty
java.math.BigDecimal poQty
vendorLeadTime
java.math.BigDecimal vendorLeadTime
effectiveDate
java.util.Date effectiveDate
overdueDate
java.util.Date overdueDate
remarks
java.lang.String remarks
requestForQuote
java.lang.String requestForQuote
lastPurchaseCost
java.math.BigDecimal lastPurchaseCost
lastPurchaseOrderNumber
java.lang.String lastPurchaseOrderNumber
lastPurchaseOrderItemNumber
java.lang.String lastPurchaseOrderItemNumber
Class bb.common.PartVO extends VO implements Serializable

Serialized Fields

pk
PartPK pk
lastUser
java.lang.String lastUser
version
java.lang.Integer version
origin
java.lang.String origin
createdDate
java.util.Date createdDate
owner
java.lang.String owner
modelNumber
java.lang.String modelNumber
buyerCode
java.lang.String buyerCode
commodityCode
java.lang.String commodityCode
productCode
java.lang.String productCode
makeBuy
java.lang.String makeBuy
saleable
java.lang.String saleable
traceable
java.lang.String traceable
traceableLevel
java.lang.Byte traceableLevel
newPart
java.lang.String newPart
description
java.lang.String description
revision
java.lang.String revision
revisionDate
java.util.Date revisionDate
hold
java.lang.String hold
shippingWeight
float shippingWeight
shippingWeightUnit
java.lang.String shippingWeightUnit
shippingLength
java.math.BigDecimal shippingLength
shippingWidth
java.math.BigDecimal shippingWidth
shippingDepth
java.math.BigDecimal shippingDepth
volume
java.math.BigDecimal volume
volumeUnit
java.lang.String volumeUnit
partUnit
java.lang.String partUnit
comment
java.lang.String comment
drawingNumber
java.lang.String drawingNumber
drawing
java.lang.String drawing
bill
java.lang.String bill
wi
java.lang.String wi
havePicture
java.lang.String havePicture
lastChangeDate
java.util.Date lastChangeDate
inspectionType
java.lang.String inspectionType
multiLanguage
java.util.Set<E> multiLanguage
vendors
java.util.Set<E> vendors
manufacturers
java.util.Set<E> manufacturers
partInventory
PartInventoryVO partInventory
levels
java.lang.String levels
material
java.lang.String material
isActivePart
java.lang.String isActivePart
salesDrawing
java.lang.String salesDrawing
catalog
java.lang.String catalog
deleted
boolean deleted
drawingRev
java.lang.String drawingRev
engGroup
java.lang.String engGroup
securityLevel
java.lang.String securityLevel
partPoUnit
java.lang.String partPoUnit
partPoUnitRate
java.math.BigDecimal partPoUnitRate
detectionStandard
java.lang.String detectionStandard
countryOrigin
java.lang.String countryOrigin
recoil
boolean recoil
useBackflush
boolean useBackflush
discountable
boolean discountable
taxExempt
boolean taxExempt
units
java.util.Set<E> units
irType
java.lang.String irType
multiQtyforApplying
java.math.BigDecimal multiQtyforApplying
Class bb.common.PartWhereUsedItemResult extends java.lang.Object implements Serializable

Serialized Fields

pk
BillItemPK pk
partQuantity
java.math.BigDecimal partQuantity
description
java.lang.String description
bill
java.lang.String bill
wi
java.lang.String wi
hold
java.lang.String hold
drawing
java.lang.String drawing
traceable
java.lang.String traceable
traceableLevel
java.lang.Byte traceableLevel
onhand
java.math.BigDecimal onhand
onOrder
java.math.BigDecimal onOrder
onDemand
java.math.BigDecimal onDemand
Class bb.common.PartWhereUsedResult extends java.lang.Object implements Serializable

Serialized Fields

partBasicInfo
PartBasicInfo partBasicInfo
partWhereUsedItemResult
java.util.List<E> partWhereUsedItemResult
Class bb.common.PartWithExcessiveInventoryListResult extends java.lang.Object implements Serializable

Serialized Fields

partPk
PartPK partPk
partFrom
java.lang.String partFrom
description
java.lang.String description
onHand
java.math.BigDecimal onHand
onOrder
java.math.BigDecimal onOrder
onDemand
java.math.BigDecimal onDemand
excessiveQty
java.math.BigDecimal excessiveQty
minQty
java.math.BigDecimal minQty
maxQty
java.math.BigDecimal maxQty
yrQty
java.math.BigDecimal yrQty
qrQty
java.math.BigDecimal qrQty
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
excessiveTotalAvgCost
java.math.BigDecimal excessiveTotalAvgCost
excessiveTotalStdCost
java.math.BigDecimal excessiveTotalStdCost
Class bb.common.PartWithInventoryInfoListResult extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
rev
java.lang.String rev
hold
java.lang.String hold
dwg
java.lang.String dwg
bill
java.lang.String bill
wi
java.lang.String wi
unit
java.lang.String unit
description
java.lang.String description
onhand
java.math.BigDecimal onhand
ondemand
java.math.BigDecimal ondemand
onorder
java.math.BigDecimal onorder
inwip
java.math.BigDecimal inwip
buyerCode
java.lang.String buyerCode
Class bb.common.PartWithManufacturerInfoResult extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
partType
java.lang.String partType
manufacturerItem
java.lang.Short manufacturerItem
hold
java.lang.String hold
drawing
java.lang.String drawing
bill
java.lang.String bill
traceable
java.lang.String traceable
description
java.lang.String description
manufacturerId
java.lang.String manufacturerId
manufacturerName
java.lang.String manufacturerName
manufacturerPartNumber
java.lang.String manufacturerPartNumber
Class bb.common.PartWithOnhandDetailInfoResult extends PartBasicInfo implements Serializable

Serialized Fields

traceableLevel
java.lang.Byte traceableLevel
minQty
java.math.BigDecimal minQty
maxQty
java.math.BigDecimal maxQty
yearUsage
java.math.BigDecimal yearUsage
quarterUsage
java.math.BigDecimal quarterUsage
weight
float weight
weightUnit
java.lang.String weightUnit
totalOnhand
java.math.BigDecimal totalOnhand
details
java.util.List<E> details
Class bb.common.PartWithOnhandsVO extends VO implements Serializable

Serialized Fields

pk
PartPK pk
lastUser
java.lang.String lastUser
version
java.lang.Integer version
origin
java.lang.String origin
createdDate
java.util.Date createdDate
owner
java.lang.String owner
modelNumber
java.lang.String modelNumber
buyerCode
java.lang.String buyerCode
commodityCode
java.lang.String commodityCode
productCode
java.lang.String productCode
makeBuy
java.lang.String makeBuy
saleable
java.lang.String saleable
traceable
java.lang.String traceable
traceableLevel
java.lang.Byte traceableLevel
newPart
java.lang.String newPart
description
java.lang.String description
revision
java.lang.String revision
revisionDate
java.util.Date revisionDate
hold
java.lang.String hold
shippingWeight
float shippingWeight
shippingWeightUnit
java.lang.String shippingWeightUnit
shippingLength
java.math.BigDecimal shippingLength
shippingWidth
java.math.BigDecimal shippingWidth
shippingDepth
java.math.BigDecimal shippingDepth
volume
java.math.BigDecimal volume
volumeUnit
java.lang.String volumeUnit
partUnit
java.lang.String partUnit
comment
java.lang.String comment
drawingNumber
java.lang.String drawingNumber
drawing
java.lang.String drawing
bill
java.lang.String bill
wi
java.lang.String wi
havePicture
java.lang.String havePicture
lastChangeDate
java.util.Date lastChangeDate
multiLanguage
java.util.Set<E> multiLanguage
onHandLocations
java.util.Set<E> onHandLocations
partInventory
PartInventoryVO partInventory
levels
java.lang.String levels
material
java.lang.String material
isActivePart
java.lang.String isActivePart
salesDrawing
java.lang.String salesDrawing
catalog
java.lang.String catalog
deleted
boolean deleted
drawingRev
java.lang.String drawingRev
engGroup
java.lang.String engGroup
securityLevel
java.lang.String securityLevel
partPoUnit
java.lang.String partPoUnit
partPoUnitRate
java.math.BigDecimal partPoUnitRate
recoil
boolean recoil
useBackflush
boolean useBackflush
Class bb.common.PartWithOnLoanQtyListResult extends java.lang.Object implements Serializable

Serialized Fields

partPk
PartPK partPk
description
java.lang.String description
onLoanQty
java.math.BigDecimal onLoanQty
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
totalAvgCost
java.math.BigDecimal totalAvgCost
totalStdCost
java.math.BigDecimal totalStdCost
Class bb.common.PartWithoutLocateResult extends PartBasicInfo implements Serializable

Serialized Fields

onhand
java.math.BigDecimal onhand
Class bb.common.PartWithQAQtyListResult extends java.lang.Object implements Serializable

Serialized Fields

partPk
PartPK partPk
description
java.lang.String description
onHand
java.math.BigDecimal onHand
inQAQty
java.math.BigDecimal inQAQty
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
listPrice
java.math.BigDecimal listPrice
partFrom
java.lang.String partFrom
refDocDetails
java.util.Set<E> refDocDetails
Class bb.common.PartWithQtyListResult extends java.lang.Object implements Serializable

Serialized Fields

partPk
PartPK partPk
description
java.lang.String description
onHand
java.math.BigDecimal onHand
qty
java.math.BigDecimal qty
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
listPrice
java.math.BigDecimal listPrice
totalAvgCost
java.math.BigDecimal totalAvgCost
totalStdCost
java.math.BigDecimal totalStdCost
partFrom
java.lang.String partFrom
refDocDetails
java.util.Set<E> refDocDetails
Class bb.common.PartWithSipQtyListResult extends java.lang.Object implements Serializable

Serialized Fields

partPk
PartPK partPk
description
java.lang.String description
onHand
java.math.BigDecimal onHand
inSipQty
java.math.BigDecimal inSipQty
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
listPrice
java.math.BigDecimal listPrice
partFrom
java.lang.String partFrom
refDocDetails
java.util.Set<E> refDocDetails
Class bb.common.PartWithSITQtyListResult extends java.lang.Object implements Serializable

Serialized Fields

partPk
PartPK partPk
description
java.lang.String description
onHand
java.math.BigDecimal onHand
inSITQty
java.math.BigDecimal inSITQty
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
listPrice
java.math.BigDecimal listPrice
partFrom
java.lang.String partFrom
refDocDetails
java.util.Set<E> refDocDetails
Class bb.common.PartWithSTOQtyListResult extends java.lang.Object implements Serializable

Serialized Fields

partPk
PartPK partPk
description
java.lang.String description
onHand
java.math.BigDecimal onHand
inSTOQty
java.math.BigDecimal inSTOQty
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
listPrice
java.math.BigDecimal listPrice
partFrom
java.lang.String partFrom
refDocDetails
java.util.Set<E> refDocDetails
Class bb.common.PartWithWipQtyListResult extends java.lang.Object implements Serializable

Serialized Fields

partPk
PartPK partPk
description
java.lang.String description
onHand
java.math.BigDecimal onHand
inWipQty
java.math.BigDecimal inWipQty
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
listPrice
java.math.BigDecimal listPrice
partFrom
java.lang.String partFrom
refDocDetails
java.util.Set<E> refDocDetails
Class bb.common.PasswordPolicyAgent extends java.lang.Object implements Serializable

Serialized Fields

passwordEncrypt
java.lang.Boolean passwordEncrypt
passwordLifetime
java.lang.Integer passwordLifetime
passwordMinLength
java.lang.Integer passwordMinLength
changePasswordEncrypt
boolean changePasswordEncrypt
changePasswordLifetime
boolean changePasswordLifetime
changePasswordMinLength
boolean changePasswordMinLength
Class bb.common.PayableCheckRunItemPK extends java.lang.Object implements Serializable

Serialized Fields

checkRunNumber
java.lang.String checkRunNumber
identifier field

apNumber
java.lang.String apNumber
identifier field

Class bb.common.PayableMethodVO extends VO implements Serializable

Serialized Fields

payableMethodID
int payableMethodID
payableMethodName
java.lang.String payableMethodName
checkAccountNumber
java.lang.String checkAccountNumber
companyUnitId
java.lang.String companyUnitId
Class bb.common.PaymentAgent extends java.lang.Object implements Serializable

Serialized Fields

datePaid
java.util.Date datePaid
companyUnitId
java.lang.String companyUnitId
accountNumber
java.lang.String accountNumber
checkNumber
java.lang.String checkNumber
totalPaid
java.math.BigDecimal totalPaid
comments
java.lang.String comments
arApNumber
java.lang.String arApNumber
addressId
java.lang.String addressId
batchRunNumber
java.lang.String batchRunNumber
glSummary
java.lang.String glSummary
exchangeRate
java.math.BigDecimal exchangeRate
totalPaidMap
java.util.Map<K,V> totalPaidMap
closeAR
boolean closeAR
Class bb.common.PaymentHistoryVO extends VO implements Serializable

Serialized Fields

addressId
java.lang.String addressId
identifier field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

addressName
java.lang.String addressName
persistent field

customerSales
java.math.BigDecimal customerSales
nullable persistent field

arReceived
java.math.BigDecimal arReceived
nullable persistent field

arDueDays
java.lang.Float arDueDays
nullable persistent field

vendorPurchases
java.math.BigDecimal vendorPurchases
nullable persistent field

apPaid
java.math.BigDecimal apPaid
nullable persistent field

apDueDays
java.lang.Float apDueDays
nullable persistent field

Class bb.common.PaymentInvoicesResult extends java.lang.Object implements Serializable

Serialized Fields

checkRunNumber
java.lang.String checkRunNumber
checkNumber
java.lang.String checkNumber
adate
java.util.Date adate
received
java.math.BigDecimal received
paymentInvoices
java.util.List<E> paymentInvoices
Class bb.common.PaymentRunItemTotalResult extends java.lang.Object implements Serializable

Serialized Fields

arTotal
java.math.BigDecimal arTotal
totalPaid
java.math.BigDecimal totalPaid
totalDue
java.math.BigDecimal totalDue
totalCheck
java.math.BigDecimal totalCheck
Class bb.common.PaymentVO extends VO implements Serializable

Serialized Fields

paymentID
int paymentID
paymentName
java.lang.String paymentName
checkAccountNumber
java.lang.String checkAccountNumber
Class bb.common.PermissionDescriptionPK extends java.lang.Object implements Serializable

Serialized Fields

permissionId
java.lang.String permissionId
identifier field

language
java.lang.String language
identifier field

Class bb.common.PermissionDescriptionVO extends VO implements Serializable

Serialized Fields

pk
PermissionDescriptionPK pk
permissionName
java.lang.String permissionName
description
java.lang.String description
Class bb.common.PermissionException extends java.lang.Exception implements Serializable

Serialized Fields

reason
java.lang.String reason
Class bb.common.PermissionListResult extends java.lang.Object implements Serializable

Serialized Fields

permissionId
java.lang.String permissionId
permissionName
java.lang.String permissionName
description
java.lang.String description
Class bb.common.PermissionMethodPK extends java.lang.Object implements Serializable

Serialized Fields

permissionId
java.lang.String permissionId
identifier field

methodId
java.lang.Long methodId
identifier field

Class bb.common.PermissionMethodVO extends VO implements Serializable

Serialized Fields

pk
PermissionMethodPK pk
identifier field

ejbMethod
EjbMethodVO ejbMethod
Class bb.common.PermissionVO extends VO implements Serializable

Serialized Fields

permissionId
java.lang.String permissionId
level
java.lang.Integer level
parentId
java.lang.String parentId
permission
boolean permission
multiLanguage
java.util.Set<E> multiLanguage
Class bb.common.PfReceiverItemPK extends java.lang.Object implements Serializable

Serialized Fields

pfReceiverNumber
java.lang.String pfReceiverNumber
purchaseOrderNumber
java.lang.String purchaseOrderNumber
purchaseOrderItemNumber
java.lang.String purchaseOrderItemNumber
Class bb.common.PfReceiverItemVO extends VO implements Serializable

Serialized Fields

pk
PfReceiverItemPK pk
pfReceiverItemNumber
java.lang.String pfReceiverItemNumber
vendorId
java.lang.String vendorId
salesOrderNumber
java.lang.String salesOrderNumber
vendorShipperNumber
java.lang.String vendorShipperNumber
vendorInvoiceNumber
java.lang.String vendorInvoiceNumber
receiver
java.lang.String receiver
apNumber
java.lang.String apNumber
apSub
java.math.BigDecimal apSub
apReceived
java.math.BigDecimal apReceived
apOpen
java.math.BigDecimal apOpen
apDisc
java.math.BigDecimal apDisc
apNet
java.math.BigDecimal apNet
apTax
java.math.BigDecimal apTax
apTotal
java.math.BigDecimal apTotal
dateShipped
java.util.Date dateShipped
dateInvoiced
java.util.Date dateInvoiced
shipVia
java.lang.String shipVia
status
java.lang.String status
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
modelNumber
java.lang.String modelNumber
revision
java.lang.String revision
quantity
java.math.BigDecimal quantity
qtyShipped
java.math.BigDecimal qtyShipped
qtyReceived
java.math.BigDecimal qtyReceived
listPrice
java.math.BigDecimal listPrice
avgCost
java.math.BigDecimal avgCost
unit
java.lang.String unit
discount
java.math.BigDecimal discount
taxRate
java.math.BigDecimal taxRate
description
java.lang.String description
mfg
java.lang.String mfg
mpn
java.lang.String mpn
serial
java.lang.String serial
itemComments
java.lang.String itemComments
itemPrivateNotes
java.lang.String itemPrivateNotes
Class bb.common.PfReceiverItemWithNumberPK extends java.lang.Object implements Serializable

Serialized Fields

pk
PfReceiverItemPK pk
pfReceiverItemNumber
java.lang.String pfReceiverItemNumber
Class bb.common.PfReceiverVO extends VO implements Serializable

Serialized Fields

pfReceiverNumber
java.lang.String pfReceiverNumber
prDate
java.util.Date prDate
packingBoxNumbers
int packingBoxNumbers
vendorId
java.lang.String vendorId
vendorSO
java.lang.String vendorSO
vendorEmail
java.lang.String vendorEmail
contact
java.lang.String contact
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
adate
java.util.Date adate
origin
java.lang.String origin
apSub
java.math.BigDecimal apSub
apReceived
java.math.BigDecimal apReceived
apOpen
java.math.BigDecimal apOpen
apDisc
java.math.BigDecimal apDisc
apNet
java.math.BigDecimal apNet
apTax
java.math.BigDecimal apTax
apFreight
java.math.BigDecimal apFreight
apTotal
java.math.BigDecimal apTotal
changeOrder
java.lang.String changeOrder
status
java.lang.String status
receivedBy
java.lang.String receivedBy
dateReceived
java.util.Date dateReceived
shippedVia
java.lang.String shippedVia
carrier
java.lang.String carrier
carrierAccount
java.lang.String carrierAccount
tracking
java.lang.String tracking
billOfLading
java.lang.String billOfLading
containerNumber
java.lang.String containerNumber
containerSealNumber
java.lang.String containerSealNumber
shippingMark
java.lang.String shippingMark
incoterm
java.lang.String incoterm
incotermPlacePort
java.lang.String incotermPlacePort
currency
java.lang.String currency
terms
java.lang.String terms
requester
java.lang.String requester
buyer
java.lang.String buyer
projectName
java.lang.String projectName
relatedDoc
java.lang.String relatedDoc
bp
java.lang.String bp
comments
java.lang.String comments
privateNotes
java.lang.String privateNotes
lastChangeTimes
int lastChangeTimes
vendorAddressInfo
CustomerVendorAddressInfoVO vendorAddressInfo
items
java.util.Set<E> items
prPackingBoxes
java.util.Set<E> prPackingBoxes
shipDate
java.util.Date shipDate
arrivalDate
java.util.Date arrivalDate
Class bb.common.PhysicalInventoryListResult extends java.lang.Object implements Serializable

Serialized Fields

pk
PhysicalInventoryPK pk
startDate
java.util.Date startDate
partNumber
java.lang.String partNumber
partType
java.lang.String partType
unit
java.lang.String unit
description
java.lang.String description
tagNumber
java.lang.String tagNumber
location
java.lang.String location
newLocation
java.lang.String newLocation
systemOnhand
java.math.BigDecimal systemOnhand
newOnhand
java.math.BigDecimal newOnhand
diffcount
java.math.BigDecimal diffcount
workInProcessQty
java.math.BigDecimal workInProcessQty
inQualityCheckingQty
java.math.BigDecimal inQualityCheckingQty
committed
boolean committed
avgCost
java.math.BigDecimal avgCost
countedBy
java.lang.String countedBy
countedDate
java.util.Date countedDate
oldSip
java.math.BigDecimal oldSip
oldOnloanQty
java.math.BigDecimal oldOnloanQty
oldAvgCost
java.math.BigDecimal oldAvgCost
oldStadCost
java.math.BigDecimal oldStadCost
totalNewOnhand
java.math.BigDecimal totalNewOnhand
Class bb.common.PhysicalInventoryListTotalResult extends java.lang.Object implements Serializable

Serialized Fields

totSystemOnhand
java.math.BigDecimal totSystemOnhand
totNewOnhand
java.math.BigDecimal totNewOnhand
totSystemCost
java.math.BigDecimal totSystemCost
totNewCost
java.math.BigDecimal totNewCost
Class bb.common.PhysicalInventoryListWithAppDataResult extends PhysicalInventoryListResult implements Serializable

Serialized Fields

modelNumber
java.lang.String modelNumber
systemTotal
java.math.BigDecimal systemTotal
customProperties
java.util.HashMap<K,V> customProperties
newTotal
java.math.BigDecimal newTotal
overageQty
java.math.BigDecimal overageQty
overageTotal
java.math.BigDecimal overageTotal
shortageQty
java.math.BigDecimal shortageQty
shortageTotal
java.math.BigDecimal shortageTotal
Class bb.common.PhysicalInventoryPK extends java.lang.Object implements Serializable

Serialized Fields

workSheetNumber
java.lang.Integer workSheetNumber
identifier field

pageNumber
java.lang.Integer pageNumber
identifier field

rowNumber
java.lang.Integer rowNumber
identifier field

Class bb.common.PhysicalInventoryStatusVO extends VO implements Serializable

Serialized Fields

workSheetNumber
java.lang.Integer workSheetNumber
totalPages
int totalPages
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
createDate
java.util.Date createDate
creator
java.lang.String creator
description
java.lang.String description
status
java.lang.String status
cycleCount
boolean cycleCount
Class bb.common.PhysicalInventoryVO extends VO implements Serializable

Serialized Fields

pk
PhysicalInventoryPK pk
identifier field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

physicalInventoryDate
java.util.Date physicalInventoryDate
nullable persistent field

mn
java.lang.String mn
persistent field

active
java.lang.String active
persistent field

tagNumber
java.lang.String tagNumber
locate
java.lang.String locate
persistent field

newLocation
java.lang.String newLocation
onhand
java.math.BigDecimal onhand
persistent field

newOnhand
java.math.BigDecimal newOnhand
persistent field

workInProcessQty
java.math.BigDecimal workInProcessQty
inQualityCheckingQty
java.math.BigDecimal inQualityCheckingQty
diffCount
java.math.BigDecimal diffCount
committed
boolean committed
countedBy
java.lang.String countedBy
persistent field

countedDate
java.util.Date countedDate
nullable persistent field

ii
java.lang.Long ii
shipInProcessQty
java.math.BigDecimal shipInProcessQty
onloanQty
java.math.BigDecimal onloanQty
averageCost
java.math.BigDecimal averageCost
standardCost
java.math.BigDecimal standardCost
totalNewOnhand
java.math.BigDecimal totalNewOnhand
madeGL
boolean madeGL
Class bb.common.PO2POAgent extends java.lang.Object implements Serializable

Serialized Fields

poNumber
java.lang.String poNumber
vendorId
java.lang.String vendorId
arriveDate
java.util.Date arriveDate
originalDate
java.util.Date originalDate
shipDate
java.util.Date shipDate
delayDays
int delayDays
Class bb.common.PO2SOExchange extends java.lang.Object implements Serializable

Serialized Fields

items
java.util.Set<E> items
purchaserId
java.lang.String purchaserId
sellerId
java.lang.String sellerId
purchaerName
java.lang.String purchaerName
sellerName
java.lang.String sellerName
billtoId
java.lang.String billtoId
billtoName
java.lang.String billtoName
shiptoId
java.lang.String shiptoId
shiptoName
java.lang.String shiptoName
currency
java.lang.String currency
terms
java.lang.String terms
carrier
java.lang.String carrier
incoterm
java.lang.String incoterm
contact
java.lang.String contact
comments
java.lang.String comments
purchaseOrderNumber
java.lang.String purchaseOrderNumber
poDate
java.util.Date poDate
Class bb.common.PO2SOExchangeItem extends java.lang.Object implements Serializable

Serialized Fields

itemNumber
java.lang.String itemNumber
partPK
PartPK partPK
qtyOrdered
java.math.BigDecimal qtyOrdered
discount
java.math.BigDecimal discount
costUnit
java.math.BigDecimal costUnit
delayDays
int delayDays
shipDate
java.util.Date shipDate
shipVia
java.lang.String shipVia
partDescription
java.lang.String partDescription
itemComments
java.lang.String itemComments
tax
java.math.BigDecimal tax
partFrom
java.lang.String partFrom
itemManf
java.util.Set<E> itemManf
Class bb.common.PO2SOExchangeItemManufacturer extends java.lang.Object implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

itemNumber
java.lang.String itemNumber
manufacturerName
java.lang.String manufacturerName
manufacturerPN
java.lang.String manufacturerPN
Class bb.common.POAndWOStatusResult extends java.lang.Object implements Serializable

Serialized Fields

poStatus
java.util.Collection<E> poStatus
woStatus
java.util.Collection<E> woStatus
fromDate
java.util.Date fromDate
toDate
java.util.Date toDate
project
java.lang.String project
Class bb.common.POForWISeqAgent extends java.lang.Object implements Serializable

Serialized Fields

pk
WorkOrderItemPK pk
items
java.util.HashMap<K,V> items
V
java.util.HashMap<K,V> V
D
java.util.HashMap<K,V> D
P
java.util.HashMap<K,V> P
Class bb.common.PointOfSaleVO extends VO implements Serializable

Serialized Fields

id
java.lang.String id
printAmount
int printAmount
payMethod
java.lang.String payMethod
perDayDiffAccount
java.lang.String perDayDiffAccount
customerID
java.lang.String customerID
lastChangeTimes
java.lang.Integer lastChangeTimes
lastChangeDate
java.util.Date lastChangeDate
lastChangeUser
java.lang.String lastChangeUser
locationForReturnMaterial
java.lang.String locationForReturnMaterial
rmaDebitAccount
java.lang.String rmaDebitAccount
useAutoCreateOrder
boolean useAutoCreateOrder
useAutoApprovalGL
boolean useAutoApprovalGL
autoApprovalBy
java.lang.String autoApprovalBy
defaultMFG
java.lang.String defaultMFG
usePOSReceive
boolean usePOSReceive
logo
byte[] logo
scannerPrefix
java.lang.String scannerPrefix
scannerSuffix
java.lang.String scannerSuffix
receiptTemplateID
int receiptTemplateID
returnTemplateID
int returnTemplateID
directlyPrintAR
boolean directlyPrintAR
Class bb.common.POItemByRefDoc1ListResult extends PurchaseOrderItemListResult implements Serializable

Serialized Fields

refDoc1
java.lang.String refDoc1
Class bb.common.PoMessageItemPK extends java.lang.Object implements Serializable

Serialized Fields

poMessageNumber
java.lang.String poMessageNumber
itemNumber
java.lang.String itemNumber
Class bb.common.PoMessageItemVO extends VO implements Serializable

Serialized Fields

pk
PoMessageItemPK pk
identifier field

poNumber
java.lang.String poNumber
status
java.lang.String status
persistent field

dateRequired
java.util.Date dateRequired
persistent field

delay
int delay
persistent field

shipVia
java.lang.String shipVia
persistent field

costPerUnit
java.math.BigDecimal costPerUnit
persistent field

discount
java.math.BigDecimal discount
persistent field

taxRate
java.math.BigDecimal taxRate
persistent field

itemSubTotal
java.math.BigDecimal itemSubTotal
persistent field

itemTotalDiscount
java.math.BigDecimal itemTotalDiscount
persistent field

apNet
java.math.BigDecimal apNet
persistent field

apReceived
java.math.BigDecimal apReceived
persistent field

apOpen
java.math.BigDecimal apOpen
persistent field

itemTotalTax
java.math.BigDecimal itemTotalTax
persistent field

apTotal
java.math.BigDecimal apTotal
persistent field

comments
java.lang.String comments
persistent field

poItem
PurchaseOrderItemVO poItem
Class bb.common.PoMessageListResult extends java.lang.Object implements Serializable

Serialized Fields

poMessageNumber
java.lang.String poMessageNumber
poNumber
java.lang.String poNumber
vendorId
java.lang.String vendorId
validateCode
java.lang.String validateCode
poMessageDate
java.util.Date poMessageDate
comments
java.lang.String comments
status
java.lang.String status
Class bb.common.PoMessageVO extends VO implements Serializable

Serialized Fields

poMessageNumber
java.lang.String poMessageNumber
poNumber
java.lang.String poNumber
vendorId
java.lang.String vendorId
validateCode
java.lang.String validateCode
poMessageDate
java.util.Date poMessageDate
subTotal
java.math.BigDecimal subTotal
totalDiscount
java.math.BigDecimal totalDiscount
apNet
java.math.BigDecimal apNet
apReceived
java.math.BigDecimal apReceived
apOpen
java.math.BigDecimal apOpen
totalTax
java.math.BigDecimal totalTax
totalFreight
java.math.BigDecimal totalFreight
grantTotal
java.math.BigDecimal grantTotal
comments
java.lang.String comments
status
java.lang.String status
vendorApprovedBy
java.lang.String vendorApprovedBy
vendorApproved
java.util.Date vendorApproved
items
java.util.Set<E> items
Class bb.common.PoReceiverByDateSummaryResult extends java.lang.Object implements Serializable

Serialized Fields

totalStdCost
Money totalStdCost
totalAvgCost
Money totalAvgCost
Class bb.common.POReceiverItemListResult extends java.lang.Object implements Serializable

Serialized Fields

receiverNumber
java.lang.String receiverNumber
itemNumber
java.lang.String itemNumber
status
java.lang.String status
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
poNumber
java.lang.String poNumber
poItemNumber
java.lang.String poItemNumber
vendorId
java.lang.String vendorId
location
java.lang.String location
description
java.lang.String description
buyer
java.lang.String buyer
currency
java.lang.String currency
accountNumber
java.lang.String accountNumber
companyUnitId
java.lang.String companyUnitId
vendorPackage
java.lang.String vendorPackage
projectName
java.lang.String projectName
vendorShipDate
java.util.Date vendorShipDate
poShipDate
java.util.Date poShipDate
origialShipDate
java.util.Date origialShipDate
receivedDate
java.util.Date receivedDate
qtyOrdered
java.math.BigDecimal qtyOrdered
qtyReceived
java.math.BigDecimal qtyReceived
poReceived
java.math.BigDecimal poReceived
extendedCost
java.math.BigDecimal extendedCost
costPerUnit
java.math.BigDecimal costPerUnit
taxRate
java.math.BigDecimal taxRate
discount
java.math.BigDecimal discount
exchangeRate
java.math.BigDecimal exchangeRate
standardCost
java.math.BigDecimal standardCost
standardExtendedCost
java.math.BigDecimal standardExtendedCost
locations
java.util.Map<K,V> locations
buyerCode
java.lang.String buyerCode
apNumber
java.lang.String apNumber
apItemNumber
java.lang.String apItemNumber
apItemStatus
java.lang.String apItemStatus
Class bb.common.PosRefdocVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
identifier field

forderNumber
java.lang.String forderNumber
persistent field

fitemNumber
java.lang.String fitemNumber
persistent field

torderNumber
java.lang.String torderNumber
persistent field

titemNumber
java.lang.String titemNumber
persistent field

qty
java.math.BigDecimal qty
persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
persistent field

lastChangeTime
java.lang.Integer lastChangeTime
persistent field

linkOrRef
short linkOrRef
persistent field

Class bb.common.POStatisticsResult extends java.lang.Object implements Serializable

Serialized Fields

comments
java.lang.String comments
itemCounts
java.lang.Long itemCounts
itemQty
java.math.BigDecimal itemQty
requester
java.lang.String requester
vendorSalesOrder
java.lang.String vendorSalesOrder
project
java.lang.String project
poDate
java.util.Date poDate
relatedDoc
java.lang.String relatedDoc
currency
java.lang.String currency
grantTotal
java.math.BigDecimal grantTotal
latestShipDate
java.util.Date latestShipDate
vendorId
java.lang.String vendorId
vendorName
java.lang.String vendorName
status
java.lang.String status
latestReceiverDate
java.util.Date latestReceiverDate
delayDays
int delayDays
contact
java.lang.String contact
poNumber
java.lang.String poNumber
totalFreight
java.math.BigDecimal totalFreight
totalTax
java.math.BigDecimal totalTax
Class bb.common.PostCheckAgent extends java.lang.Object implements Serializable

Serialized Fields

creditAccount
java.lang.String creditAccount
checkNumber
java.lang.String checkNumber
makeDate
java.util.Date makeDate
debitAccount
java.lang.String debitAccount
companyUnitOfCreditAcc
java.lang.String companyUnitOfCreditAcc
companyUnitOfDebitAcc
java.lang.String companyUnitOfDebitAcc
checkAmount
java.math.BigDecimal checkAmount
memo
java.lang.String memo
soNumber
java.lang.String soNumber
invoiceNumber
java.lang.String invoiceNumber
customerId
java.lang.String customerId
id
java.lang.String id
glSummary
java.lang.String glSummary
Class bb.common.POSurveyReportAgent extends java.lang.Object implements Serializable

Serialized Fields

poNumber
java.lang.String poNumber
contractNumber
java.lang.String contractNumber
projectName
java.lang.String projectName
vendorSalesOrder
java.lang.String vendorSalesOrder
vendorId
java.lang.String vendorId
vendorName
java.lang.String vendorName
poSurveyReportItem
java.util.Set<E> poSurveyReportItem
persistent field

Class bb.common.POSurveyReportItemPK extends java.lang.Object implements Serializable

Serialized Fields

srNumber
java.lang.String srNumber
srItemNumber
java.lang.String srItemNumber
Class bb.common.POSurveyReportItemVO extends VO implements Serializable

Serialized Fields

pk
POSurveyReportItemPK pk
identifier field

partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
quantityOrdered
java.math.BigDecimal quantityOrdered
quantityQualified
java.math.BigDecimal quantityQualified
quantityReceived
java.math.BigDecimal quantityReceived
unit
java.lang.String unit
description
java.lang.String description
dwg
java.lang.String dwg
packCondition
java.lang.String packCondition
specification
java.lang.String specification
testReport
java.lang.String testReport
srResult
java.lang.String srResult
Class bb.common.POSurveyReportVO extends VO implements Serializable

Serialized Fields

srNumber
java.lang.String srNumber
purchaseOrderNumber
java.lang.String purchaseOrderNumber
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
adate
java.util.Date adate
origin
java.lang.String origin
contractNumber
java.lang.String contractNumber
projectName
java.lang.String projectName
lastChangeTimes
int lastChangeTimes
vendorSalesOrder
java.lang.String vendorSalesOrder
vendorId
java.lang.String vendorId
vendorName
java.lang.String vendorName
comments
java.lang.String comments
engAcceptEmployee
java.lang.String engAcceptEmployee
qaAcceptEmployee
java.lang.String qaAcceptEmployee
poAcceptEmployee
java.lang.String poAcceptEmployee
wareAcceptEmployee
java.lang.String wareAcceptEmployee
poSurveyReportItem
java.util.Set<E> poSurveyReportItem
persistent field

Class bb.common.PosZipCodeTaxPK extends java.lang.Object implements Serializable

Serialized Fields

zipCodeStart
java.lang.String zipCodeStart
zipCodeEnd
java.lang.String zipCodeEnd
Class bb.common.PosZipCodeTaxVO extends VO implements Serializable

Serialized Fields

pk
PosZipCodeTaxPK pk
description
java.lang.String description
taxRate
java.math.BigDecimal taxRate
notes
java.lang.String notes
stateName
java.lang.String stateName
stateTaxRate
java.math.BigDecimal stateTaxRate
cityName
java.lang.String cityName
cityTaxRate
java.math.BigDecimal cityTaxRate
countyName
java.lang.String countyName
countyTaxRate
java.math.BigDecimal countyTaxRate
cityCode
java.lang.String cityCode
countyCode
java.lang.String countyCode
Class bb.common.PrepayAgent extends java.lang.Object implements Serializable

Serialized Fields

orderNumber
java.lang.String orderNumber
changeOrder
java.lang.String changeOrder
vendorId
java.lang.String vendorId
vendorName
java.lang.String vendorName
currency
java.lang.String currency
total
java.math.BigDecimal total
Class bb.common.PrepaymentWireTransferAgent extends java.lang.Object implements Serializable

Serialized Fields

includeVendorId
java.lang.String[] includeVendorId
excludeVendorId
java.lang.String[] excludeVendorId
fromDate
java.util.Date fromDate
toDate
java.util.Date toDate
appiPk
ApPrepayItemPK[] appiPk
wireTransferNo
java.lang.String wireTransferNo
transactionDate
java.util.Date transactionDate
debitAccount
java.lang.String debitAccount
creditAccount
java.lang.String creditAccount
bankTransferFeeAccount
java.lang.String bankTransferFeeAccount
companyUnitOfDebitAcc
java.lang.String companyUnitOfDebitAcc
companyUnitOfCreditAcc
java.lang.String companyUnitOfCreditAcc
companyUnitOfTransferFeeAcc
java.lang.String companyUnitOfTransferFeeAcc
Class bb.common.PrepayPaymentAgent extends java.lang.Object implements Serializable

Serialized Fields

datePaid
java.util.Date datePaid
companyUnitId
java.lang.String companyUnitId
accountNumber
java.lang.String accountNumber
checkNumber
java.lang.String checkNumber
totalPaid
java.math.BigDecimal totalPaid
comments
java.lang.String comments
prepayNumber
java.lang.String prepayNumber
prapayItemNumber
java.lang.String prapayItemNumber
addressId
java.lang.String addressId
batchRunNumber
java.lang.String batchRunNumber
glSummary
java.lang.String glSummary
exchange
java.math.BigDecimal exchange
Class bb.common.PreventiveActionRequestItemVO extends VO implements Serializable

Serialized Fields

parItemNumber
java.lang.Long parItemNumber
identifier field

parNumber
java.lang.String parNumber
identifier field

description
java.lang.String description
persistent field

extension
java.lang.String extension
persistent field

status
java.lang.String status
persistent field

docName
java.lang.String docName
persistent field

docLength
long docLength
persistent field

Class bb.common.PreventiveActionRequestVO extends VO implements Serializable

Serialized Fields

parNumber
java.lang.String parNumber
identifier field

dueDate
java.util.Date dueDate
persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

adate
java.util.Date adate
nullable persistent field

origin
java.lang.String origin
persistent field

dateEntered
java.util.Date dateEntered
persistent field

enteredBy
java.lang.String enteredBy
persistent field

status
java.lang.String status
persistent field

departmentId
java.lang.String departmentId
persistent field

departmentName
java.lang.String departmentName
persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

modelNumber
java.lang.String modelNumber
persistent field

revision
java.lang.String revision
persistent field

description
java.lang.String description
persistent field

thirdParty
java.lang.String thirdParty
persistent field

refDoc1
java.lang.String refDoc1
persistent field

refDoc2
java.lang.String refDoc2
persistent field

conditionDescription
java.lang.String conditionDescription
nullable persistent field

notedBy
java.lang.String notedBy
persistent field

acknowledgedBy
java.lang.String acknowledgedBy
persistent field

proposedAction
java.lang.String proposedAction
nullable persistent field

proposedBy
java.lang.String proposedBy
persistent field

approvedBy
java.lang.String approvedBy
persistent field

proposedActionDate
java.util.Date proposedActionDate
persistent field

implementionDue
java.util.Date implementionDue
persistent field

closedOutApproval
java.lang.String closedOutApproval
persistent field

closedOutDate
java.util.Date closedOutDate
persistent field

closedOutComments
java.lang.String closedOutComments
nullable persistent field

closedOutPrivateNotes
java.lang.String closedOutPrivateNotes
persistent field

version
java.lang.Integer version
nullable persistent field

preventiveActionRequestItems
java.util.Set<E> preventiveActionRequestItems
persistent field

partFrom
java.lang.String partFrom
Class bb.common.PrintLogoVO extends VO implements Serializable

Serialized Fields

logoName
java.lang.String logoName
identifier field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

logo
byte[] logo
nullable persistent field

extension
java.lang.String extension
nullable persistent field

length
java.lang.Integer length
Class bb.common.PrintTemplateVO extends VO implements Serializable

Serialized Fields

ii
int ii
comments
java.lang.String comments
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
adate
java.util.Date adate
origin
java.lang.String origin
file
byte[] file
version
java.lang.Integer version
fileName
java.lang.String fileName
clazzName
java.lang.String clazzName
templateName
java.lang.String templateName
Class bb.common.ProfitAndLossAccountsResult extends java.lang.Object implements Serializable

Serialized Fields

accountNumber
java.lang.String accountNumber
description
java.lang.String description
plAccountNumber
java.lang.String plAccountNumber
plDescription
java.lang.String plDescription
Class bb.common.ProfitLossStatementItemResult extends java.lang.Object implements Serializable

Serialized Fields

accountNumber
java.lang.String accountNumber
items
byte items
level
java.lang.String level
upLevelAccountNumber
java.lang.String upLevelAccountNumber
accountType
java.lang.String accountType
type
java.lang.String type
description
java.lang.String description
priorPeriod
java.math.BigDecimal priorPeriod
budget
java.math.BigDecimal budget
currentPeriod
java.math.BigDecimal currentPeriod
salesPercent
java.lang.Double salesPercent
changePercent
java.lang.Double changePercent
changePercentOfBudget
java.math.BigDecimal changePercentOfBudget
Class bb.common.ProfitLossStatementResult extends java.lang.Object implements Serializable

Serialized Fields

currentPeriodFrom
java.util.Date currentPeriodFrom
currentPeriodTo
java.util.Date currentPeriodTo
priorPeriodFrom
java.util.Date priorPeriodFrom
priorPeriodTo
java.util.Date priorPeriodTo
companyUnitId
java.lang.String companyUnitId
grossMargin
java.math.BigDecimal grossMargin
returnOnSales
java.math.BigDecimal returnOnSales
salesRevenue
java.util.List<E> salesRevenue
totalSalesRevenue
ProfitLossStatementItemResult totalSalesRevenue
costOfSales
java.util.List<E> costOfSales
totalCostOfSales
ProfitLossStatementItemResult totalCostOfSales
grossProfit
ProfitLossStatementItemResult grossProfit
salesMarketing
java.util.List<E> salesMarketing
totalSalesMarketing
ProfitLossStatementItemResult totalSalesMarketing
researchDevelopment
java.util.List<E> researchDevelopment
totalResearchDevelopment
ProfitLossStatementItemResult totalResearchDevelopment
wageLabor
java.util.List<E> wageLabor
totalWageLabor
ProfitLossStatementItemResult totalWageLabor
generalAdmin
java.util.List<E> generalAdmin
totalGeneralAdmin
ProfitLossStatementItemResult totalGeneralAdmin
totalOperatingExpense
ProfitLossStatementItemResult totalOperatingExpense
incomeFromOperating
java.util.List<E> incomeFromOperating
totalIncomeFromOperating
ProfitLossStatementItemResult totalIncomeFromOperating
otherIncome
java.util.List<E> otherIncome
totalOtherIncome
ProfitLossStatementItemResult totalOtherIncome
tax
java.util.List<E> tax
totalTax
ProfitLossStatementItemResult totalTax
netProfit
ProfitLossStatementItemResult netProfit
Class bb.common.ProformaInvoiceItemListResult extends java.lang.Object implements Serializable

Serialized Fields

pfInvoiceNumber
java.lang.String pfInvoiceNumber
salesOrderNumber
java.lang.String salesOrderNumber
salesOrderItem
java.lang.String salesOrderItem
pfInvoiceItemNumber
java.lang.String pfInvoiceItemNumber
customerId
java.lang.String customerId
purchaseOrderNumber
java.lang.String purchaseOrderNumber
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
quantity
java.math.BigDecimal quantity
qtyShipped
java.math.BigDecimal qtyShipped
listPrice
java.math.BigDecimal listPrice
arSub
java.math.BigDecimal arSub
unit
java.lang.String unit
description
java.lang.String description
status
java.lang.String status
dateShipped
java.util.Date dateShipped
Class bb.common.ProformaInvoiceItemManufacturerPK extends java.lang.Object implements Serializable

Serialized Fields

pfInvoiceNumber
java.lang.String pfInvoiceNumber
salesOrderNumber
java.lang.String salesOrderNumber
salesOrderItemNumber
java.lang.String salesOrderItemNumber
ii
java.lang.Short ii
Class bb.common.ProformaInvoiceItemManufacturerVO extends VO implements Serializable

Serialized Fields

pk
ProformaInvoiceItemManufacturerPK pk
manufacturerName
java.lang.String manufacturerName
manufacturerPartNumber
java.lang.String manufacturerPartNumber
Class bb.common.ProformaInvoiceItemPK extends java.lang.Object implements Serializable

Serialized Fields

pfInvoiceNumber
java.lang.String pfInvoiceNumber
identifier field

salesOrderNumber
java.lang.String salesOrderNumber
identifier field

salesOrderItem
java.lang.String salesOrderItem
identifier field

Class bb.common.ProformaInvoiceItemVO extends VO implements Serializable

Serialized Fields

pk
ProformaInvoiceItemPK pk
identifier field

pfInvoiceItemNumber
java.lang.String pfInvoiceItemNumber
persistent field

customerId
java.lang.String customerId
persistent field

purchaseOrderNumber
java.lang.String purchaseOrderNumber
persistent field

shipperNumber
java.lang.String shipperNumber
persistent field

ar
java.lang.String ar
persistent field

arSub
java.math.BigDecimal arSub
persistent field

arShip
java.math.BigDecimal arShip
persistent field

arOpen
java.math.BigDecimal arOpen
persistent field

arDisc
java.math.BigDecimal arDisc
persistent field

arNet
java.math.BigDecimal arNet
persistent field

arTax
java.math.BigDecimal arTax
persistent field

arTotal
java.math.BigDecimal arTotal
persistent field

refDoc1
java.lang.String refDoc1
persistent field

refDoc2
java.lang.String refDoc2
persistent field

dateShipped
java.util.Date dateShipped
persistent field

dateInvoiced
java.util.Date dateInvoiced
persistent field

shipVia
java.lang.String shipVia
persistent field

shipTo
java.lang.String shipTo
persistent field

status
java.lang.String status
persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
persistent field

modelNumber
java.lang.String modelNumber
persistent field

revision
java.lang.String revision
persistent field

locate
java.lang.String locate
persistent field

quantity
java.math.BigDecimal quantity
persistent field

qtyShipped
java.math.BigDecimal qtyShipped
persistent field

listPrice
java.math.BigDecimal listPrice
persistent field

avgCost
java.math.BigDecimal avgCost
persistent field

unit
java.lang.String unit
persistent field

discount
java.math.BigDecimal discount
persistent field

taxRate
java.math.BigDecimal taxRate
persistent field

description
java.lang.String description
persistent field

mfg
java.lang.String mfg
persistent field

mpn
java.lang.String mpn
persistent field

serial
java.lang.String serial
persistent field

itemComments
java.lang.String itemComments
nullable persistent field

itemPrivateNotes
java.lang.String itemPrivateNotes
nullable persistent field

proformaInvoiceItemManufacturer
java.util.Set<E> proformaInvoiceItemManufacturer
Class bb.common.ProformaInvoiceListResult extends java.lang.Object implements Serializable

Serialized Fields

pfnumber
java.lang.String pfnumber
dateShipped
java.util.Date dateShipped
customerId
java.lang.String customerId
billToId
java.lang.String billToId
shipToId
java.lang.String shipToId
status
java.lang.String status
comments
java.lang.String comments
privateNotes
java.lang.String privateNotes
customerPo
java.lang.String customerPo
grantTotal
java.math.BigDecimal grantTotal
Class bb.common.ProformaInvoiceVO extends VO implements Serializable

Serialized Fields

pfInvoiceNumber
java.lang.String pfInvoiceNumber
identifier field

packingBoxNumbers
int packingBoxNumbers
persistent field

customerId
java.lang.String customerId
persistent field

shipFromId
java.lang.String shipFromId
customerPO
java.lang.String customerPO
persistent field

billTo
java.lang.String billTo
persistent field

customerEmail
java.lang.String customerEmail
persistent field

contact
java.lang.String contact
persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

adate
java.util.Date adate
nullable persistent field

origin
java.lang.String origin
persistent field

arSub
java.math.BigDecimal arSub
persistent field

arShip
java.math.BigDecimal arShip
persistent field

arOpen
java.math.BigDecimal arOpen
persistent field

arDisc
java.math.BigDecimal arDisc
persistent field

arNet
java.math.BigDecimal arNet
persistent field

arTax
java.math.BigDecimal arTax
persistent field

arFreight
java.math.BigDecimal arFreight
persistent field

arTotal
java.math.BigDecimal arTotal
persistent field

arPaid
java.math.BigDecimal arPaid
persistent field

arPaidInv
java.math.BigDecimal arPaidInv
persistent field

arPaidGl
java.math.BigDecimal arPaidGl
persistent field

arGl1Recorded
java.math.BigDecimal arGl1Recorded
persistent field

arGl2Paid
java.math.BigDecimal arGl2Paid
persistent field

changeOrder
java.lang.String changeOrder
persistent field

status
java.lang.String status
persistent field

salesman
java.lang.String salesman
persistent field

shipped
java.util.Date shipped
nullable persistent field

shippedBy
java.lang.String shippedBy
persistent field

invoicedDate
java.util.Date invoicedDate
nullable persistent field

invoicedBy
java.lang.String invoicedBy
persistent field

shipTo
java.lang.String shipTo
persistent field

remitId
java.lang.String remitId
persistent field

shipVia
java.lang.String shipVia
persistent field

estimatedArrival
java.util.Date estimatedArrival
persistent field

carrier
java.lang.String carrier
persistent field

carrierAccount
java.lang.String carrierAccount
persistent field

tracking
java.lang.String tracking
persistent field

billOfLading
java.lang.String billOfLading
persistent field

containerNumber
java.lang.String containerNumber
persistent field

containerSealNumber
java.lang.String containerSealNumber
persistent field

shippingMark
java.lang.String shippingMark
persistent field

incoterm
java.lang.String incoterm
persistent field

incotermPlacePort
java.lang.String incotermPlacePort
persistent field

dateShipped
java.util.Date dateShipped
persistent field

dateInvoiced
java.util.Date dateInvoiced
persistent field

freightBill
java.lang.String freightBill
persistent field

currency
java.lang.String currency
persistent field

language
java.lang.String language
persistent field

terms
java.lang.String terms
persistent field

reldoc
java.lang.String reldoc
persistent field

cacct1
java.lang.String cacct1
persistent field

bp
java.lang.String bp
persistent field

comments
java.lang.String comments
nullable persistent field

notes
java.lang.String notes
nullable persistent field

due
java.math.BigDecimal due
persistent field

paydate
java.util.Date paydate
persistent field

datePaid
java.util.Date datePaid
persistent field

checkNo
java.lang.String checkNo
persistent field

paid
java.math.BigDecimal paid
persistent field

otran
java.lang.String otran
persistent field

rtran
java.lang.String rtran
persistent field

lastChangeTimes
int lastChangeTimes
nullable persistent field

customerAddressInfo
CustomerVendorAddressInfoVO customerAddressInfo
nullable persistent field

shipFromAddressInfo
CustomerVendorAddressInfoVO shipFromAddressInfo
nullable persistent field

shipToAddressInfo
CustomerVendorAddressInfoVO shipToAddressInfo
nullable persistent field

billToAddressInfo
CustomerVendorAddressInfoVO billToAddressInfo
nullable persistent field

proformaInvoiceItems
java.util.Set<E> proformaInvoiceItems
persistent field

packingBoxes
java.util.Set<E> packingBoxes
persistent field

Class bb.common.ProformaReceiverPackingBoxAgent extends java.lang.Object implements Serializable

Serialized Fields

vendorId
java.lang.String vendorId
pfVo
ProformaInvoiceVO pfVo
pbs
java.util.LinkedHashMap<K,V> pbs
pbItems
java.util.LinkedHashMap<K,V> pbItems
Class bb.common.ProformaReceiverPackingBoxItemAgent extends java.lang.Object implements Serializable

Serialized Fields

prPBItem
PrPackingBoxItemVO prPBItem
pBItem
PackingBoxItemVO pBItem
pOItems
java.util.LinkedHashSet<E> pOItems
vendPartExist
boolean vendPartExist
partExist
boolean partExist
Class bb.common.ProjectVO extends VO implements Serializable

Serialized Fields

id
java.lang.String id
description
java.lang.String description
Class bb.common.PrPackingBoxItemPK extends java.lang.Object implements Serializable

Serialized Fields

pfReceiverNumber
java.lang.String pfReceiverNumber
identifier field

packingBoxNumber
java.lang.Integer packingBoxNumber
identifier field

purchaseOrderNumber
java.lang.String purchaseOrderNumber
identifier field

purchaseOrderItemNumber
java.lang.String purchaseOrderItemNumber
identifier field

Class bb.common.PrPackingBoxItemVO extends VO implements Serializable

Serialized Fields

pk
PrPackingBoxItemPK pk
identifier field

status
java.lang.String status
persistent field

quantity
java.math.BigDecimal quantity
persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
description
java.lang.String description
persistent field

vendorId
java.lang.String vendorId
persistent field

salesOrderNumber
java.lang.String salesOrderNumber
persistent field

shipVia
java.lang.String shipVia
persistent field

Class bb.common.PrPackingBoxPK extends java.lang.Object implements Serializable

Serialized Fields

pfReceiverNumber
java.lang.String pfReceiverNumber
identifier field

packingBoxNumber
java.lang.Integer packingBoxNumber
identifier field

Class bb.common.PrPackingBoxVO extends VO implements Serializable

Serialized Fields

pk
PrPackingBoxPK pk
identifier field

vendorId
java.lang.String vendorId
persistent field

status
java.lang.String status
persistent field

dimension
java.lang.String dimension
persistent field

grossWeight
java.math.BigDecimal grossWeight
persistent field

netWeight
java.math.BigDecimal netWeight
persistent field

weightUnit
java.lang.String weightUnit
persistent field

packingBoxItems
java.util.Set<E> packingBoxItems
persistent field

Class bb.common.PrReceiverListResult extends java.lang.Object implements Serializable

Serialized Fields

prNumber
java.lang.String prNumber
dateReceived
java.util.Date dateReceived
vendorId
java.lang.String vendorId
vendorName
java.lang.String vendorName
vendorSO
java.lang.String vendorSO
contact
java.lang.String contact
buyer
java.lang.String buyer
status
java.lang.String status
comments
java.lang.String comments
privateNotes
java.lang.String privateNotes
relatedDoc
java.lang.String relatedDoc
Class bb.common.PrReceiverWithQualityListResult extends java.lang.Object implements Serializable

Serialized Fields

prNumber
java.lang.String prNumber
prItemNumber
java.lang.String prItemNumber
poNumber
java.lang.String poNumber
poItemNumber
java.lang.String poItemNumber
vendorSO
java.lang.String vendorSO
part
java.lang.String part
description
java.lang.String description
comments
java.lang.String comments
qtyOrdered
java.math.BigDecimal qtyOrdered
qtySit
java.math.BigDecimal qtySit
qtyReceived
java.math.BigDecimal qtyReceived
Class bb.common.PullFromWorkOrderPartDetailAgent extends java.lang.Object implements Serializable

Serialized Fields

pk
WorkOrderItemIssuePK pk
part
BB2Part part
qty
java.math.BigDecimal qty
cost
java.math.BigDecimal cost
Class bb.common.PurchaseOnTimeResult extends java.lang.Object implements Serializable

Serialized Fields

currency
java.lang.String currency
day1
int day1
day2
int day2
items
java.util.List<E> items
Class bb.common.PurchaseOrderApprovalVO extends VO implements Serializable

Serialized Fields

employeeId
java.lang.String employeeId
identifier field

userName
java.lang.String userName
persistent field

approveLimit
java.math.BigDecimal approveLimit
persistent field

currency
java.lang.String currency
persistent field

canApproveOwnPurchaseOrder
java.lang.String canApproveOwnPurchaseOrder
persistent field

comments
java.lang.String comments
Class bb.common.PurchaseOrderBoilerplateVO extends VO implements Serializable

Serialized Fields

boilerplateId
java.lang.String boilerplateId
identifier field

description
java.lang.String description
persistent field

poBoilerplate
java.lang.String poBoilerplate
nullable persistent field

Class bb.common.PurchaseOrderCheckListResult extends java.lang.Object implements Serializable

Serialized Fields

poNumber
java.lang.String poNumber
vendorId
java.lang.String vendorId
buyer
java.lang.String buyer
poDate
java.util.Date poDate
delivery
java.util.Date delivery
status
java.lang.String status
apTotal
java.math.BigDecimal apTotal
currency
java.lang.String currency
vendorName
java.lang.String vendorName
project
java.lang.String project
comments
java.lang.String comments
Class bb.common.PurchaseOrderContractResult extends java.lang.Object implements Serializable

Serialized Fields

contract
java.lang.String contract
requester
java.lang.String requester
purchaseRequestNumber
java.lang.String purchaseRequestNumber
purchaseOrderNumber
java.lang.String purchaseOrderNumber
vendorSO
java.lang.String vendorSO
projectNumber
java.lang.String projectNumber
purchaseContent
java.lang.String purchaseContent
itemNumber
java.lang.String itemNumber
partNumber
java.lang.String partNumber
partType
java.lang.String partType
description
java.lang.String description
type
java.lang.String type
itemAndQuantity
java.lang.String itemAndQuantity
budgetAmount
java.math.BigDecimal budgetAmount
contractAmount
java.math.BigDecimal contractAmount
vendor
java.lang.String vendor
purchaseMethod
java.lang.String purchaseMethod
submitDate
java.util.Date submitDate
buyer
java.lang.String buyer
contractPeriod
java.lang.String contractPeriod
contractDate
java.util.Date contractDate
expectDeliveryDate
java.util.Date expectDeliveryDate
arrivalStatus
java.lang.String arrivalStatus
arrivalDate
java.util.Date arrivalDate
storageDate
java.util.Date storageDate
yearStorageAmount
java.math.BigDecimal yearStorageAmount
noStorageAmount
java.math.BigDecimal noStorageAmount
delayDays
java.lang.String delayDays
comment
java.lang.String comment
payAmount
java.math.BigDecimal payAmount
noPayAmount
java.math.BigDecimal noPayAmount
payDate
java.util.Date payDate
map
java.util.HashMap<K,V> map
Class bb.common.PurchaseOrderDocumentVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
poNumber
java.lang.String poNumber
docDescription
java.lang.String docDescription
documentDate
java.util.Date documentDate
comments
java.lang.String comments
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
extension
java.lang.String extension
docFileName
java.lang.String docFileName
docLength
long docLength
Class bb.common.PurchaseOrderItemListResult extends java.lang.Object implements Serializable

Serialized Fields

poNumber
java.lang.String poNumber
poItemNumber
java.lang.String poItemNumber
partPk
BB2Part partPk
itemDescription
java.lang.String itemDescription
orderQty
java.math.BigDecimal orderQty
receivedQty
java.math.BigDecimal receivedQty
costPerUnit
java.math.BigDecimal costPerUnit
itemTotalTax
java.math.BigDecimal itemTotalTax
discount
java.math.BigDecimal discount
extendPrice
java.math.BigDecimal extendPrice
vendorId
java.lang.String vendorId
deleveryDate
java.util.Date deleveryDate
arriveDate
java.util.Date arriveDate
delayDays
int delayDays
poItemStatus
java.lang.String poItemStatus
poDate
java.util.Date poDate
unit
java.lang.String unit
buyer
java.lang.String buyer
project
java.lang.String project
requester
java.lang.String requester
apOpen
java.math.BigDecimal apOpen
apReceived
java.math.BigDecimal apReceived
shipto
java.lang.String shipto
currency
java.lang.String currency
relatedDoc
java.lang.String relatedDoc
lastReceiveDate
java.util.Date lastReceiveDate
accountNumber
java.lang.String accountNumber
companyUnitId
java.lang.String companyUnitId
productCode
java.lang.String productCode
onHandQty
java.math.BigDecimal onHandQty
onOrderQty
java.math.BigDecimal onOrderQty
onDemandQty
java.math.BigDecimal onDemandQty
sipQty
java.math.BigDecimal sipQty
sitQty
java.math.BigDecimal sitQty
wipQty
java.math.BigDecimal wipQty
refDocOnes
java.util.Set<E> refDocOnes
refDocTwoes
java.util.Set<E> refDocTwoes
Class bb.common.PurchaseOrderItemManufacturerPK extends java.lang.Object implements Serializable

Serialized Fields

purchaseOrderNumber
java.lang.String purchaseOrderNumber
purchaseOrderItemNumber
java.lang.String purchaseOrderItemNumber
itemNumber
java.lang.Short itemNumber
Class bb.common.PurchaseOrderItemManufacturerVO extends VO implements Serializable

Serialized Fields

pk
PurchaseOrderItemManufacturerPK pk
manufacturerName
java.lang.String manufacturerName
manufacturerPartNumber
java.lang.String manufacturerPartNumber
Class bb.common.PurchaseOrderItemPK extends java.lang.Object implements Serializable

Serialized Fields

purchaseOrderNumber
java.lang.String purchaseOrderNumber
purchaseOrderItemNumber
java.lang.String purchaseOrderItemNumber
Class bb.common.PurchaseOrderItemVO extends VO implements Serializable

Serialized Fields

pk
PurchaseOrderItemPK pk
itemSubTotal
java.math.BigDecimal itemSubTotal
itemTotalDiscount
java.math.BigDecimal itemTotalDiscount
apNet
java.math.BigDecimal apNet
apReceived
java.math.BigDecimal apReceived
apOpen
java.math.BigDecimal apOpen
itemTotalTax
java.math.BigDecimal itemTotalTax
apTotal
java.math.BigDecimal apTotal
referenceDoc1
java.lang.String referenceDoc1
referenceDoc2
java.lang.String referenceDoc2
changeOrder
java.lang.String changeOrder
qr
java.lang.String qr
status
java.lang.String status
shippingStatus
java.lang.String shippingStatus
acceptedDate
java.util.Date acceptedDate
acceptedBy
java.lang.String acceptedBy
dateRequired
java.util.Date dateRequired
delayDays
int delayDays
arriveDate
java.util.Date arriveDate
priority
java.lang.String priority
original
java.util.Date original
actual
java.util.Date actual
locate
java.lang.String locate
shipVia
java.lang.String shipVia
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
modelNumber
java.lang.String modelNumber
revision
java.lang.String revision
dwg
java.lang.String dwg
traceable
java.lang.String traceable
traceableLevel
java.lang.Byte traceableLevel
quantityOrdered
java.math.BigDecimal quantityOrdered
sitQty
java.math.BigDecimal sitQty
quantityShipped
java.math.BigDecimal quantityShipped
quantityReceived
java.math.BigDecimal quantityReceived
hqa
java.math.BigDecimal hqa
costPerUnit
java.math.BigDecimal costPerUnit
costPerUnitWithTax
java.math.BigDecimal costPerUnitWithTax
unit
java.lang.String unit
poUnit
java.lang.String poUnit
poUnitRate
java.math.BigDecimal poUnitRate
poUnitQty
java.math.BigDecimal poUnitQty
discount
java.math.BigDecimal discount
taxRate
java.math.BigDecimal taxRate
description
java.lang.String description
changeMfg
java.lang.String changeMfg
mfg
java.lang.String mfg
mpn
java.lang.String mpn
itemComments
java.lang.String itemComments
itemPrivateNotes
java.lang.String itemPrivateNotes
usePriceWithTax
boolean usePriceWithTax
purchaseOrderItemManufacturer
java.util.Set<E> purchaseOrderItemManufacturer
refDocOnes
java.util.Set<E> refDocOnes
refDocTwoes
java.util.Set<E> refDocTwoes
productCode
java.lang.String productCode
commodityCode
java.lang.String commodityCode
leadTime
java.math.BigDecimal leadTime
icrRequiredWhenReceiverNa
boolean icrRequiredWhenReceiverNa
Class bb.common.PurchaseOrderListResult extends java.lang.Object implements Serializable

Serialized Fields

poNumber
java.lang.String poNumber
poDate
java.util.Date poDate
vendorId
java.lang.String vendorId
changeOrder
java.lang.String changeOrder
vendorName
java.lang.String vendorName
buyerName
java.lang.String buyerName
project
java.lang.String project
comments
java.lang.String comments
poStatus
java.lang.String poStatus
requester
java.lang.String requester
vendorSO
java.lang.String vendorSO
privateNotes
java.lang.String privateNotes
acknowledgeDate
java.util.Date acknowledgeDate
relatedDoc
java.lang.String relatedDoc
apPrepay
java.math.BigDecimal apPrepay
apPrepayGl
java.math.BigDecimal apPrepayGl
Class bb.common.PurchaseOrderOnOrderResult extends java.lang.Object implements Serializable

Serialized Fields

partPk
PartPK partPk
purchaseOrderItemPk
PurchaseOrderItemPK purchaseOrderItemPk
description
java.lang.String description
refDoc1
java.lang.String refDoc1
refDoc2
java.lang.String refDoc2
quantityOrdered
java.math.BigDecimal quantityOrdered
quantityReceived
java.math.BigDecimal quantityReceived
quantityOnOrder
java.math.BigDecimal quantityOnOrder
sitQty
java.math.BigDecimal sitQty
vendorId
java.lang.String vendorId
shipToId
java.lang.String shipToId
deliveryDate
java.util.Date deliveryDate
arriveDate
java.util.Date arriveDate
delayDays
int delayDays
partFrom
java.lang.String partFrom
notes
java.lang.String notes
Class bb.common.PurchaseOrderOnTimeItemResult extends java.lang.Object implements Serializable

Serialized Fields

month
java.lang.String month
purTotal
java.math.BigDecimal purTotal
purItemCount
int purItemCount
recTotalOnTime
java.math.BigDecimal recTotalOnTime
recItemsOnTimeCount
int recItemsOnTimeCount
notRecTotalOnTime
java.math.BigDecimal notRecTotalOnTime
notRecItemsOnTimeQty
java.math.BigDecimal notRecItemsOnTimeQty
days
java.math.BigDecimal days
Class bb.common.PurchaseOrderOnTimeResult extends java.lang.Object implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

currency
java.lang.String currency
duePOTotalofThisMonth
java.math.BigDecimal duePOTotalofThisMonth
ontimeReceiverItemsofThisMonth
java.lang.Integer ontimeReceiverItemsofThisMonth
duePOTotalofLastMonth
java.math.BigDecimal duePOTotalofLastMonth
duePOTotalofFiscalYear
java.math.BigDecimal duePOTotalofFiscalYear
duePOTotalofYtd
java.math.BigDecimal duePOTotalofYtd
duePOTotalof12MonthAvg
java.math.BigDecimal duePOTotalof12MonthAvg
ontimeReceiverItemsofLastMonth
java.lang.Integer ontimeReceiverItemsofLastMonth
ontimeReceiverItemsofFiscalYear
java.lang.Integer ontimeReceiverItemsofFiscalYear
ontimeReceiverItemsofYtd
java.lang.Integer ontimeReceiverItemsofYtd
ontimeReceiverItemsof12MonthAvg
java.lang.Integer ontimeReceiverItemsof12MonthAvg
duePOItemOfThisMonth
java.lang.Integer duePOItemOfThisMonth
duePOItemOfLastMonth
java.lang.Integer duePOItemOfLastMonth
duePOItemOfFiscalYear
java.lang.Integer duePOItemOfFiscalYear
duePOItemOfYtd
java.lang.Integer duePOItemOfYtd
duePOItemOf12MonthAvg
java.lang.Integer duePOItemOf12MonthAvg
ontimeReceiverTotalOfThisMonth
java.math.BigDecimal ontimeReceiverTotalOfThisMonth
ontimeReceiverTotalOfLastMonth
java.math.BigDecimal ontimeReceiverTotalOfLastMonth
ontimeReceiverTotalOfFiscalYear
java.math.BigDecimal ontimeReceiverTotalOfFiscalYear
ontimeReceiverTotalOfYtd
java.math.BigDecimal ontimeReceiverTotalOfYtd
ontimeReceiverTotalOf12MonthAvg
java.math.BigDecimal ontimeReceiverTotalOf12MonthAvg
Class bb.common.PurchaseOrderOpenDueListResult extends java.lang.Object implements Serializable

Serialized Fields

poNumber
java.lang.String poNumber
poItemNumber
java.lang.String poItemNumber
vendorId
java.lang.String vendorId
shippingStatus
java.lang.String shippingStatus
shipVia
java.lang.String shipVia
buyer
java.lang.String buyer
poItemDescription
java.lang.String poItemDescription
poDate
java.util.Date poDate
dueDate
java.util.Date dueDate
deleveryDate
java.util.Date deleveryDate
delayDays
int delayDays
poQty
java.math.BigDecimal poQty
quantityReceived
java.math.BigDecimal quantityReceived
onhandQty
java.math.BigDecimal onhandQty
onOrderQty
java.math.BigDecimal onOrderQty
onDemandQty
java.math.BigDecimal onDemandQty
yearUsage
java.math.BigDecimal yearUsage
partPk
BB2Part partPk
Class bb.common.PurchaseOrderVO extends VO implements Serializable

Serialized Fields

purchaseOrderNumber
java.lang.String purchaseOrderNumber
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
adate
java.util.Date adate
origin
java.lang.String origin
apNetSet
java.lang.String apNetSet
apTaxSet
java.lang.String apTaxSet
subTotal
java.math.BigDecimal subTotal
totalDiscount
java.math.BigDecimal totalDiscount
apNet
java.math.BigDecimal apNet
apReceived
java.math.BigDecimal apReceived
apOpen
java.math.BigDecimal apOpen
totalTax
java.math.BigDecimal totalTax
totalFreight
java.math.BigDecimal totalFreight
grantTotal
java.math.BigDecimal grantTotal
apPaidReceived
java.math.BigDecimal apPaidReceived
apPaidGl
java.math.BigDecimal apPaidGl
apGl1Recorded
java.math.BigDecimal apGl1Recorded
apGl2Paid
java.math.BigDecimal apGl2Paid
appNumber
java.lang.String appNumber
apPrepay
java.math.BigDecimal apPrepay
apPrepayDue
java.math.BigDecimal apPrepayDue
apPrepayGl
java.math.BigDecimal apPrepayGl
apPrepayApply
java.math.BigDecimal apPrepayApply
changeOrder
java.lang.String changeOrder
vendorId
java.lang.String vendorId
billToId
java.lang.String billToId
contact
java.lang.String contact
salesOrderNumber
java.lang.String salesOrderNumber
status
java.lang.String status
shippingStatus
java.lang.String shippingStatus
approvedDate
java.util.Date approvedDate
approvedBy
java.lang.String approvedBy
acknowledgeDate
java.util.Date acknowledgeDate
dateRequired
java.util.Date dateRequired
delayDays
byte delayDays
priority
java.lang.String priority
original
java.util.Date original
actual
java.util.Date actual
shipToId
java.lang.String shipToId
shipVia
java.lang.String shipVia
carrier
java.lang.String carrier
carrierAccount
java.lang.String carrierAccount
incoterm
java.lang.String incoterm
incotermPlacePort
java.lang.String incotermPlacePort
locate
java.lang.String locate
language
java.lang.String language
currency
java.lang.String currency
exchange
java.math.BigDecimal exchange
terms
java.lang.String terms
poDate
java.util.Date poDate
contractDate
java.util.Date contractDate
buyer
java.lang.String buyer
buyerGroup
java.lang.String buyerGroup
requester
java.lang.String requester
projectName
java.lang.String projectName
relatedDoc
java.lang.String relatedDoc
debitAccount
java.lang.String debitAccount
bp
java.lang.String bp
poBoilerplate
java.lang.String poBoilerplate
purchaseOrderComments
java.lang.String purchaseOrderComments
purchaseOrderPrivateNotes
java.lang.String purchaseOrderPrivateNotes
coComments
java.lang.String coComments
vendorSalesOrder
java.lang.String vendorSalesOrder
vendorAcknowledge
java.lang.String vendorAcknowledge
companyUnitId
java.lang.String companyUnitId
lastChangeTimes
int lastChangeTimes
hold
boolean hold
poRequestionNumber
java.lang.String poRequestionNumber
budgetAmount
java.math.BigDecimal budgetAmount
purchaseMethod
java.lang.String purchaseMethod
poType
java.lang.String poType
submitDate
java.util.Date submitDate
vendorAddressInfo
CustomerVendorAddressInfoVO vendorAddressInfo
shipToAddressInfo
CustomerVendorAddressInfoVO shipToAddressInfo
billToAddressInfo
CustomerVendorAddressInfoVO billToAddressInfo
purchaseOrderItem
java.util.Set<E> purchaseOrderItem
boilerplates
java.util.Set<E> boilerplates
purchaseOrderDocuments
java.util.Set<E> purchaseOrderDocuments
Class bb.common.PurchaseWorkSheetItemPK extends java.lang.Object implements Serializable

Serialized Fields

employeeId
java.lang.String employeeId
identifier field

cartType
java.lang.String cartType
workSheetNumber
java.lang.Integer workSheetNumber
itemNumber
java.lang.Integer itemNumber
Class bb.common.PurchaseWorkSheetItemVO extends VO implements Serializable

Serialized Fields

pk
PurchaseWorkSheetItemPK pk
identifier field

makePo
java.lang.String makePo
persistent field

makeRfq
java.lang.String makeRfq
persistent field

rfqIds
java.lang.String rfqIds
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

lastChangeUser
java.lang.String lastChangeUser
nullable persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

quantity
java.math.BigDecimal quantity
nullable persistent field

comments
java.lang.String comments
nullable persistent field

itemNotes
java.lang.String itemNotes
nullable persistent field

vendId
java.lang.Byte vendId
nullable persistent field

mfgId
short mfgId
persistent field

mfgIds
java.lang.String mfgIds
persistent field

vendIdWritein
java.lang.String vendIdWritein
persistent field

rfqIdWritein
java.lang.String rfqIdWritein
persistent field

delivery
java.util.Date delivery
monthQty
java.math.BigDecimal monthQty
months
java.lang.Integer months
refdoc
java.util.Map<K,V> refdoc
purchaseRefdoc
java.util.Map<K,V> purchaseRefdoc
Class bb.common.PurchaseWorkSheetItemWithRelatedInfoResult extends java.lang.Object implements Serializable

Serialized Fields

partBasicInfo
PartBasicInfo partBasicInfo
partInventoryVO
PartInventoryVO partInventoryVO
partVendors
java.util.List<E> partVendors
partManufacturers
java.util.List<E> partManufacturers
toolBasicInfo
ToolBasicInfo toolBasicInfo
toolInventoryVO
ToolInventoryVO toolInventoryVO
workSheetItem
PurchaseWorkSheetItemVO workSheetItem
Class bb.common.PurchaseWorkSheetPK extends java.lang.Object implements Serializable

Serialized Fields

employeeId
java.lang.String employeeId
identifier field

cartType
java.lang.String cartType
workSheetNumber
java.lang.Integer workSheetNumber
Class bb.common.PurchaseWorkSheetVO extends VO implements Serializable

Serialized Fields

pk
PurchaseWorkSheetPK pk
identifier field

employeeEmail
java.lang.String employeeEmail
persistent field

description
java.lang.String description
persistent field

dueDate
java.util.Date dueDate
nullable persistent field

companyUnitId
java.lang.String companyUnitId
persistent field

debitAccount
java.lang.String debitAccount
persistent field

purchaseWorkSheetItem
java.util.Set<E> purchaseWorkSheetItem
persistent field

publicWorkSheet
boolean publicWorkSheet
publicToEvery
boolean publicToEvery
publicToUser
java.lang.String publicToUser
orderBy
java.lang.String orderBy
Class bb.common.PurchasingInfoCenterResult extends java.lang.Object implements Serializable

Serialized Fields

currentMonthPurchaseAccount
java.math.BigDecimal currentMonthPurchaseAccount
currentMonthPoAddedCount
java.lang.Integer currentMonthPoAddedCount
currentMonthPoiAddedCount
java.lang.Integer currentMonthPoiAddedCount
lastMonthPurchaseAccount
java.math.BigDecimal lastMonthPurchaseAccount
fyPurchaserAccount
java.math.BigDecimal fyPurchaserAccount
avgFyPurchaserAccount
java.math.BigDecimal avgFyPurchaserAccount
lastMonthPoAddedCount
java.lang.Integer lastMonthPoAddedCount
lastMonthPoiAddedCount
java.lang.Integer lastMonthPoiAddedCount
fyPoAddedCount
java.lang.Integer fyPoAddedCount
fyPoiAddedCount
java.lang.Integer fyPoiAddedCount
avgFyPoAddedCount
java.math.BigDecimal avgFyPoAddedCount
avgFyPoiAddedCount
java.math.BigDecimal avgFyPoiAddedCount
currentMonthReceiverCount
java.lang.Integer currentMonthReceiverCount
currentMonthReceiverItemCount
java.lang.Integer currentMonthReceiverItemCount
lastMonthReceiverCount
java.lang.Integer lastMonthReceiverCount
lastMonthReceiverItemCount
java.lang.Integer lastMonthReceiverItemCount
fyReceiverCount
java.lang.Integer fyReceiverCount
fyReceiverItemCount
java.lang.Integer fyReceiverItemCount
avgFyReceiverCount
java.math.BigDecimal avgFyReceiverCount
avgFyReceiverItemCount
java.math.BigDecimal avgFyReceiverItemCount
currentMonthReceiverAccount
java.math.BigDecimal currentMonthReceiverAccount
lastMonthReceiverAccount
java.math.BigDecimal lastMonthReceiverAccount
fyReceiverAccount
java.math.BigDecimal fyReceiverAccount
avgFyReceiverAccount
java.math.BigDecimal avgFyReceiverAccount
openPurchaseAccount
java.math.BigDecimal openPurchaseAccount
duePurchaseAccount
java.math.BigDecimal duePurchaseAccount
duePurchaseCount
java.lang.Integer duePurchaseCount
dueOriginalPromisePurchaseAccount
java.math.BigDecimal dueOriginalPromisePurchaseAccount
purchaseWithPartOnHoldCount
java.lang.Integer purchaseWithPartOnHoldCount
Class bb.common.PuttoInQAAgent extends java.lang.Object implements Serializable

Serialized Fields

part
BB2Part part
qty
java.math.BigDecimal qty
cost
java.math.BigDecimal cost
locate
java.lang.String locate
trackingLog
java.util.Set<E> trackingLog
Class bb.common.QtyAndMoney extends java.lang.Object implements Serializable

Serialized Fields

qty
java.math.BigDecimal qty
money
Money money
Class bb.common.QtyDetailResult extends java.lang.Object implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

qty
java.math.BigDecimal qty
str
java.lang.String str
Class bb.common.QualityGroupPK extends java.lang.Object implements Serializable

Serialized Fields

addId
java.lang.String addId
identifier field

userName
java.lang.String userName
identifier field

Class bb.common.QualityGroupVO extends VO implements Serializable

Serialized Fields

pk
QualityGroupPK pk
identifier field

password
java.lang.String password
persistent field

email
java.lang.String email
nullable persistent field

createTime
java.util.Date createTime
nullable persistent field

Class bb.common.QualityInfoCenterResult extends java.lang.Object implements Serializable

Serialized Fields

pastDueNcrCount
java.lang.Integer pastDueNcrCount
openNcrCount
java.lang.Integer openNcrCount
totalInQaByCost
java.math.BigDecimal totalInQaByCost
currentMonthRejectQty
java.math.BigDecimal currentMonthRejectQty
lastMonthRejectQty
java.math.BigDecimal lastMonthRejectQty
Class bb.common.Quote2QuoteAgent extends java.lang.Object implements Serializable

Serialized Fields

quoteNumber
java.lang.String quoteNumber
customerId
java.lang.String customerId
billToId
java.lang.String billToId
shipToId
java.lang.String shipToId
Class bb.common.QuoteBoilerplateVO extends VO implements Serializable

Serialized Fields

boilerplateId
java.lang.String boilerplateId
identifier field

description
java.lang.String description
persistent field

qtBoilerplate
java.lang.String qtBoilerplate
nullable persistent field

Class bb.common.QuoteDocumentVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
quoteNumber
java.lang.String quoteNumber
documentDescription
java.lang.String documentDescription
dt
java.lang.String dt
documentDate
java.util.Date documentDate
comments
java.lang.String comments
lastUser
java.lang.String lastUser
extension
java.lang.String extension
lastChangeDate
java.util.Date lastChangeDate
docLength
long docLength
docName
java.lang.String docName
Class bb.common.QuoteItemListResult extends java.lang.Object implements Serializable

Serialized Fields

qtNumber
java.lang.String qtNumber
qtItemNumber
java.lang.String qtItemNumber
partPk
PartPK partPk
itemDescription
java.lang.String itemDescription
qtDate
java.util.Date qtDate
delivery
java.lang.String delivery
orderedQty
java.math.BigDecimal orderedQty
pricePerUnit
java.math.BigDecimal pricePerUnit
discount
java.math.BigDecimal discount
customerId
java.lang.String customerId
customerRefNumber
java.lang.String customerRefNumber
shipVia
java.lang.String shipVia
status
java.lang.String status
onhandQty
java.math.BigDecimal onhandQty
onorderQty
java.math.BigDecimal onorderQty
onDemandQty
java.math.BigDecimal onDemandQty
partFrom
java.lang.String partFrom
extendsPrice
java.math.BigDecimal extendsPrice
unit
java.lang.String unit
sipQty
java.math.BigDecimal sipQty
wipQty
java.math.BigDecimal wipQty
currency
java.lang.String currency
customerRfqNumber
java.lang.String customerRfqNumber
Class bb.common.QuoteItemManufacturerPK extends java.lang.Object implements Serializable

Serialized Fields

quoteNumber
java.lang.String quoteNumber
identifier field

quoteItemNumber
java.lang.String quoteItemNumber
identifier field

ii
java.lang.Short ii
identifier field

Class bb.common.QuoteItemManufacturerVO extends VO implements Serializable

Serialized Fields

pk
QuoteItemManufacturerPK pk
manufacturerName
java.lang.String manufacturerName
manufacturerPartNumber
java.lang.String manufacturerPartNumber
Class bb.common.QuoteItemPK extends java.lang.Object implements Serializable

Serialized Fields

quoteNumber
java.lang.String quoteNumber
identifier field

quoteItemNumber
java.lang.String quoteItemNumber
identifier field

Class bb.common.QuoteItemVO extends VO implements Serializable

Serialized Fields

pk
QuoteItemPK pk
accountReceivableSub
java.math.BigDecimal accountReceivableSub
accountReceivableDiscount
java.math.BigDecimal accountReceivableDiscount
extendPrice
java.math.BigDecimal extendPrice
accountReceivableTax
java.math.BigDecimal accountReceivableTax
accountReceivableTotal
java.math.BigDecimal accountReceivableTotal
referenceDoc1
java.lang.String referenceDoc1
referenceDoc2
java.lang.String referenceDoc2
changeOrder
java.lang.String changeOrder
qr
java.lang.String qr
status
java.lang.String status
delivery
java.lang.String delivery
desiredDate
java.util.Date desiredDate
delayDays
int delayDays
priority
java.lang.String priority
original
java.lang.String original
locate
java.lang.String locate
shipVia
java.lang.String shipVia
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
modelNumber
java.lang.String modelNumber
revision
java.lang.String revision
dwg
java.lang.String dwg
quoteQuantity
java.math.BigDecimal quoteQuantity
quantityShipped
java.math.BigDecimal quantityShipped
hqa
java.math.BigDecimal hqa
cost
java.math.BigDecimal cost
stdCost
java.math.BigDecimal stdCost
unit
java.lang.String unit
pricePerUnit
java.math.BigDecimal pricePerUnit
discount
java.math.BigDecimal discount
taxRate
java.math.BigDecimal taxRate
margin
java.math.BigDecimal margin
marginPercent
java.math.BigDecimal marginPercent
marginByStdCost
java.math.BigDecimal marginByStdCost
marginPercentByStdCost
java.math.BigDecimal marginPercentByStdCost
description
java.lang.String description
mfg
java.lang.String mfg
mpn
java.lang.String mpn
quoteItemComments
java.lang.String quoteItemComments
quoteItemPrivateNotes
java.lang.String quoteItemPrivateNotes
quoteItemManufacturer
java.util.Set<E> quoteItemManufacturer
refDocOnes
java.util.Set<E> refDocOnes
refDocTwoes
java.util.Set<E> refDocTwoes
Class bb.common.QuoteListResult extends java.lang.Object implements Serializable

Serialized Fields

qtNumber
java.lang.String qtNumber
qtDate
java.util.Date qtDate
changeOrder
java.lang.String changeOrder
customerId
java.lang.String customerId
customerRefNumber
java.lang.String customerRefNumber
project
java.lang.String project
privateNote
java.lang.String privateNote
comments
java.lang.String comments
status
java.lang.String status
validThru
java.util.Date validThru
salesman
java.lang.String salesman
ourRefQuote
java.lang.String ourRefQuote
Class bb.common.QuoteVO extends VO implements Serializable

Serialized Fields

quoteNumber
java.lang.String quoteNumber
validThru
java.util.Date validThru
lastUser
java.lang.String lastUser
lastChangeDate
java.util.Date lastChangeDate
aDate
java.util.Date aDate
origin
java.lang.String origin
arNetSet
java.lang.String arNetSet
arTaxSet
java.lang.String arTaxSet
arSub
java.math.BigDecimal arSub
totalDiscount
java.math.BigDecimal totalDiscount
subTotal
java.math.BigDecimal subTotal
totalTax
java.math.BigDecimal totalTax
totalFreight
java.math.BigDecimal totalFreight
grantTotal
java.math.BigDecimal grantTotal
margin
java.math.BigDecimal margin
marginPercent
java.math.BigDecimal marginPercent
totalCost
java.math.BigDecimal totalCost
marginByStdCost
java.math.BigDecimal marginByStdCost
marginPercentByStdCost
java.math.BigDecimal marginPercentByStdCost
totalStdCost
java.math.BigDecimal totalStdCost
changeOrder
java.lang.String changeOrder
customerId
java.lang.String customerId
billToId
java.lang.String billToId
customerRefNumber
java.lang.String customerRefNumber
contact
java.lang.String contact
status
java.lang.String status
reviewed
java.util.Date reviewed
reviewedBy
java.lang.String reviewedBy
delivery
java.lang.String delivery
desired
java.lang.String desired
delay
byte delay
priority
java.lang.String priority
original
java.lang.String original
shipToId
java.lang.String shipToId
shipVia
java.lang.String shipVia
carrier
java.lang.String carrier
carrierAccount
java.lang.String carrierAccount
incoterm
java.lang.String incoterm
incotermPlacePort
java.lang.String incotermPlacePort
locate
java.lang.String locate
language
java.lang.String language
currency
java.lang.String currency
exchange
java.math.BigDecimal exchange
terms
java.lang.String terms
quoteDate
java.util.Date quoteDate
salesman
java.lang.String salesman
salesmanId
short salesmanId
salesGroutQuoteNumber
java.lang.String salesGroutQuoteNumber
requester
java.lang.String requester
projectName
java.lang.String projectName
relatedDocument
java.lang.String relatedDocument
creditAccount
java.lang.String creditAccount
bp
java.lang.String bp
quoteComments
java.lang.String quoteComments
quotePrivateNotes
java.lang.String quotePrivateNotes
version
java.lang.Integer version
customerAddressInfo
CustomerVendorAddressInfoVO customerAddressInfo
shipToAddressInfo
CustomerVendorAddressInfoVO shipToAddressInfo
billToAddressInfo
CustomerVendorAddressInfoVO billToAddressInfo
quoteItems
java.util.Set<E> quoteItems
quoteDocuments
java.util.Set<E> quoteDocuments
boilerplates
java.util.Set<E> boilerplates
coComments
java.lang.String coComments
companyUnitId
java.lang.String companyUnitId
persistent field

Class bb.common.Reason extends java.lang.Object implements Serializable

Serialized Fields

reason
java.lang.String reason
Class bb.common.RebackInQAAgent extends java.lang.Object implements Serializable

Serialized Fields

ii
java.lang.Integer ii
part
BB2Part part
quantity
java.math.BigDecimal quantity
cost
java.math.BigDecimal cost
ncrNumber
java.lang.String ncrNumber
locate
java.lang.String locate
trackingLog
java.util.Set<E> trackingLog
Class bb.common.ReceivedToOrderItem extends java.lang.Object implements Serializable

Serialized Fields

toOrderNumber
java.lang.String toOrderNumber
ReceivedToOrderItem: used to show which order is allowed directly to be shipped from the current receiving.

toItemNumber
java.lang.String toItemNumber
shortQuantity
java.math.BigDecimal shortQuantity
receivedTo
java.lang.String receivedTo
isGroup
java.lang.Boolean isGroup
itemNumber
java.lang.Short itemNumber
shipperNumber
java.lang.String shipperNumber
qtyShipped
java.math.BigDecimal qtyShipped
Class bb.common.ReceiverAgent extends java.lang.Object implements Serializable

Serialized Fields

orderNumber
java.lang.String orderNumber
wareHouse
java.lang.String wareHouse
receivedDate
java.util.Date receivedDate
items
java.util.Set<E> items
vendorInvoice
java.lang.String vendorInvoice
vendorShipperNumber
java.lang.String vendorShipperNumber
vendorInvoiceDate
java.util.Date vendorInvoiceDate
freight
java.math.BigDecimal freight
vendorShipDate
java.util.Date vendorShipDate
glSummary
java.lang.String glSummary
trackingNumber
java.lang.String trackingNumber
Class bb.common.ReceiverInfoVO extends VO implements Serializable

Serialized Fields

receiverNumber
java.lang.String receiverNumber
identifier field

purchaseOrderNumber
java.lang.String purchaseOrderNumber
persistent field

accountPayableNumber
java.lang.String accountPayableNumber
persistent field

vendorId
java.lang.String vendorId
persistent field

batch
java.lang.String batch
lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

adate
java.util.Date adate
nullable persistent field

origin
java.lang.String origin
persistent field

apSub
java.math.BigDecimal apSub
persistent field

apReceived
java.math.BigDecimal apReceived
persistent field

apOpen
java.math.BigDecimal apOpen
persistent field

totalDiscount
java.math.BigDecimal totalDiscount
persistent field

subTotal
java.math.BigDecimal subTotal
persistent field

totalTax
java.math.BigDecimal totalTax
persistent field

totalFreight
java.math.BigDecimal totalFreight
persistent field

grantTotal
java.math.BigDecimal grantTotal
persistent field

apPaidReceived
java.math.BigDecimal apPaidReceived
persistent field

apPaidGl
java.math.BigDecimal apPaidGl
persistent field

apGl1Recorded
java.math.BigDecimal apGl1Recorded
persistent field

apGl2Paid
java.math.BigDecimal apGl2Paid
persistent field

changeOrder
java.lang.String changeOrder
persistent field

status
java.lang.String status
persistent field

collect
java.lang.String collect
persistent field

receivedBy
java.lang.String receivedBy
persistent field

dateReceived
java.util.Date dateReceived
persistent field

deliveredTo
java.lang.String deliveredTo
persistent field

freightBill
java.lang.String freightBill
persistent field

shippedVia
java.lang.String shippedVia
persistent field

carrier
java.lang.String carrier
persistent field

carrierAccount
java.lang.String carrierAccount
persistent field

tracking
java.lang.String tracking
persistent field

incoterm
java.lang.String incoterm
persistent field

incotermPlacePort
java.lang.String incotermPlacePort
persistent field

currency
java.lang.String currency
persistent field

terms
java.lang.String terms
persistent field

requester
java.lang.String requester
persistent field

buyer
java.lang.String buyer
projectName
java.lang.String projectName
persistent field

relatedDoc
java.lang.String relatedDoc
persistent field

debitAccount
java.lang.String debitAccount
persistent field

bp
java.lang.String bp
persistent field

receiverComments
java.lang.String receiverComments
nullable persistent field

receiverPrivateNotes
java.lang.String receiverPrivateNotes
nullable persistent field

due
java.math.BigDecimal due
persistent field

vendorInvoice
java.lang.String vendorInvoice
persistent field

vendorPackage
java.lang.String vendorPackage
persistent field

vendorTotal
java.math.BigDecimal vendorTotal
persistent field

vendorInvoiceDate
java.util.Date vendorInvoiceDate
persistent field

vendorShipDate
java.util.Date vendorShipDate
paydate
java.util.Date paydate
persistent field

datePaid
java.util.Date datePaid
persistent field

checkNo
java.lang.String checkNo
persistent field

paid
java.math.BigDecimal paid
persistent field

itran
java.lang.String itran
persistent field

etran
java.lang.String etran
persistent field

lastChangeTimes
int lastChangeTimes
nullable persistent field

vendorAddressInfoVO
CustomerVendorAddressInfoVO vendorAddressInfoVO
nullable persistent field

Class bb.common.ReceiverItemAgent extends java.lang.Object implements Serializable

Serialized Fields

orderItemNumber
java.lang.String orderItemNumber
freight
java.math.BigDecimal freight
condition
java.lang.String condition
comments
java.lang.String comments
serial
java.lang.String serial
lot
java.lang.String lot
totalReceivedQty
java.math.BigDecimal totalReceivedQty
cost
java.math.BigDecimal cost
receivedToDetails
java.util.Set<E> receivedToDetails
naRecTo
java.lang.String naRecTo
receiverNumber
java.lang.String receiverNumber
mfgPartNumber
java.lang.String mfgPartNumber
irNumber
java.lang.String irNumber
orderNumber
java.lang.String orderNumber
itemNumber
java.lang.Short itemNumber
part
BB2Part part
description
java.lang.String description
Class bb.common.ReceiverItemDetailAgent extends java.lang.Object implements Serializable

Serialized Fields

receivedTo
java.lang.String receivedTo
ReceiverItemDetailAgent: describes the details how to receive this material

receivedQty
java.math.BigDecimal receivedQty
location
java.lang.String location
toOrderNumber
java.lang.String toOrderNumber
toItemNumber
java.lang.String toItemNumber
shipperNumber
java.lang.String shipperNumber
cost
java.math.BigDecimal cost
isGroup
java.lang.Boolean isGroup
itemNumber
java.lang.Short itemNumber
trackingLog
java.util.Set<E> trackingLog
Class bb.common.ReceiverItemManufacturerPK extends java.lang.Object implements Serializable

Serialized Fields

receiverNumber
java.lang.String receiverNumber
purchaseOrderItemNumber
java.lang.String purchaseOrderItemNumber
ii
java.lang.Short ii
Class bb.common.ReceiverItemManufacturerVO extends VO implements Serializable

Serialized Fields

pk
ReceiverItemManufacturerPK pk
manufacturerName
java.lang.String manufacturerName
manufacturerPartNumber
java.lang.String manufacturerPartNumber
Class bb.common.ReceiverItemPK extends java.lang.Object implements Serializable

Serialized Fields

receiverItemNumber
java.lang.String receiverItemNumber
receiverNumber
java.lang.String receiverNumber
Class bb.common.ReceiverItemTrackingLogAgent extends java.lang.Object implements Serializable

Serialized Fields

trackingNumber
java.lang.String trackingNumber
qty
java.math.BigDecimal qty
dueDate
java.util.Date dueDate
Class bb.common.ReceiverItemVO extends VO implements Serializable

Serialized Fields

pk
ReceiverItemPK pk
purchaseOrderNumber
java.lang.String purchaseOrderNumber
poItemNumber
java.lang.String poItemNumber
apSub
java.math.BigDecimal apSub
apReceived
java.math.BigDecimal apReceived
apOpen
java.math.BigDecimal apOpen
apDiscount
java.math.BigDecimal apDiscount
extendPrice
java.math.BigDecimal extendPrice
apTax
java.math.BigDecimal apTax
apTotal
java.math.BigDecimal apTotal
due
java.math.BigDecimal due
paid
java.math.BigDecimal paid
datePaid
java.util.Date datePaid
checkNumber
java.lang.String checkNumber
referenceDoc1
java.lang.String referenceDoc1
referenceDoc2
java.lang.String referenceDoc2
qr
java.lang.String qr
sentTo
java.lang.String sentTo
receivedBy
java.lang.String receivedBy
condition
java.lang.String condition
status
java.lang.String status
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
modelNumber
java.lang.String modelNumber
revision
java.lang.String revision
location
java.lang.String location
quantity
java.math.BigDecimal quantity
quantityTraced
java.math.BigDecimal quantityTraced
quantityReceived
java.math.BigDecimal quantityReceived
costPerUnit
java.math.BigDecimal costPerUnit
unit
java.lang.String unit
discount
java.math.BigDecimal discount
taxRate
java.math.BigDecimal taxRate
description
java.lang.String description
mfg
java.lang.String mfg
mpn
java.lang.String mpn
serial
java.lang.String serial
comments
java.lang.String comments
privateNotes
java.lang.String privateNotes
stdCost
java.math.BigDecimal stdCost
itemGrandTotal
java.math.BigDecimal itemGrandTotal
part
PartVO part
refDocTwoes
java.util.Set<E> refDocTwoes
refDocOnes
java.util.Set<E> refDocOnes
bb2PoRecQty
java.math.BigDecimal bb2PoRecQty
receiverItemManufacturer
java.util.Set<E> receiverItemManufacturer
accountPayableNumber
java.lang.String accountPayableNumber
productCode
java.lang.String productCode
locations
java.util.Map<K,V> locations
trackings
java.util.Map<K,V> trackings
Class bb.common.ReceiverShipAgent extends java.lang.Object implements Serializable

Serialized Fields

orderNumber
java.lang.String orderNumber
wareHouse
java.lang.String wareHouse
receivedDate
java.util.Date receivedDate
vendorInvoice
java.lang.String vendorInvoice
vendorShipperNumber
java.lang.String vendorShipperNumber
vendorInvoiceDate
java.util.Date vendorInvoiceDate
freight
java.math.BigDecimal freight
receiveAll
java.lang.Boolean receiveAll
receiveAllSo
java.lang.Boolean receiveAllSo
receiveAllWo
java.lang.Boolean receiveAllWo
locations
java.util.Map<K,V> locations
serials
java.util.Map<K,V> serials
shipperNumbers
java.util.Map<K,V> shipperNumbers
Class bb.common.ReceiverVO extends VO implements Serializable

Serialized Fields

receiverNumber
java.lang.String receiverNumber
purchaseOrderNumber
java.lang.String purchaseOrderNumber
accountPayableNumber
java.lang.String accountPayableNumber
vendorId
java.lang.String vendorId
batch
java.lang.String batch
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
adate
java.util.Date adate
origin
java.lang.String origin
apNetSet
java.lang.String apNetSet
apTaxSet
java.lang.String apTaxSet
apSub
java.math.BigDecimal apSub
apReceived
java.math.BigDecimal apReceived
apOpen
java.math.BigDecimal apOpen
totalDiscount
java.math.BigDecimal totalDiscount
subTotal
java.math.BigDecimal subTotal
totalTax
java.math.BigDecimal totalTax
totalFreight
java.math.BigDecimal totalFreight
grantTotal
java.math.BigDecimal grantTotal
apPaidReceived
java.math.BigDecimal apPaidReceived
apPaidGl
java.math.BigDecimal apPaidGl
apGl1Recorded
java.math.BigDecimal apGl1Recorded
apGl2Paid
java.math.BigDecimal apGl2Paid
changeOrder
java.lang.String changeOrder
status
java.lang.String status
collect
java.lang.String collect
receivedBy
java.lang.String receivedBy
dateReceived
java.util.Date dateReceived
deliveredTo
java.lang.String deliveredTo
freightBill
java.lang.String freightBill
shippedVia
java.lang.String shippedVia
carrier
java.lang.String carrier
carrierAccount
java.lang.String carrierAccount
tracking
java.lang.String tracking
incoterm
java.lang.String incoterm
incotermPlacePort
java.lang.String incotermPlacePort
currency
java.lang.String currency
exchange
java.math.BigDecimal exchange
terms
java.lang.String terms
requester
java.lang.String requester
buyer
java.lang.String buyer
projectName
java.lang.String projectName
relatedDoc
java.lang.String relatedDoc
debitAccount
java.lang.String debitAccount
bp
java.lang.String bp
comments
java.lang.String comments
privateNotes
java.lang.String privateNotes
due
java.math.BigDecimal due
vendorInvoice
java.lang.String vendorInvoice
vendorPackage
java.lang.String vendorPackage
vendorTotal
java.math.BigDecimal vendorTotal
vendorInvoiceDate
java.util.Date vendorInvoiceDate
vendorShipDate
java.util.Date vendorShipDate
paydate
java.util.Date paydate
datePaid
java.util.Date datePaid
checkNo
java.lang.String checkNo
paid
java.math.BigDecimal paid
itran
java.lang.String itran
etran
java.lang.String etran
companyUnitId
java.lang.String companyUnitId
lastChangeTimes
int lastChangeTimes
vendorAddressInfo
CustomerVendorAddressInfoVO vendorAddressInfo
receiverItem
java.util.Set<E> receiverItem
coComments
java.lang.String coComments
Class bb.common.ReceivingItemResult extends java.lang.Object implements Serializable

Serialized Fields

orderNumber
java.lang.String orderNumber
orderItemNumber
java.lang.String orderItemNumber
partPk
PartPK partPk
partFrom
java.lang.String partFrom
revision
java.lang.String revision
drawing
java.lang.String drawing
description
java.lang.String description
traceable
boolean traceable
comments
java.lang.String comments
privateNotes
java.lang.String privateNotes
refDoc1
java.lang.String refDoc1
refDoc2
java.lang.String refDoc2
mfg
java.lang.String mfg
mpn
java.lang.String mpn
qCode
java.lang.String qCode
rCode
java.lang.String rCode
status
java.lang.String status
quantity
java.math.BigDecimal quantity
quantityReceived
java.math.BigDecimal quantityReceived
minReceived
java.math.BigDecimal minReceived
maxReceived
java.math.BigDecimal maxReceived
unit
java.lang.String unit
itemReceivableAll
boolean itemReceivableAll
itemReceivable
boolean itemReceivable
totalOnhand
java.math.BigDecimal totalOnhand
totalOnDemand
java.math.BigDecimal totalOnDemand
partLocations
java.util.Set<E> partLocations
partTracking
java.util.Set<E> partTracking
receivedToOrderItems
java.util.Set<E> receivedToOrderItems
poUnit
java.lang.String poUnit
poUnitQty
java.math.BigDecimal poUnitQty
poItemShipDate
java.util.Date poItemShipDate
irNumber
java.lang.String irNumber
qtyCheck
java.math.BigDecimal qtyCheck
qtyQualified
java.math.BigDecimal qtyQualified
costPerUnit
java.math.BigDecimal costPerUnit
irTotalRefQty
java.math.BigDecimal irTotalRefQty
icrRequiredWhenReceiverNa
boolean icrRequiredWhenReceiverNa
itemNumber
java.lang.Short itemNumber
partManufacturers
java.util.Set<E> partManufacturers
Class bb.common.ReceivingResult extends java.lang.Object implements Serializable

Serialized Fields

orderNumber
java.lang.String orderNumber
changeOrder
java.lang.String changeOrder
vendorId
java.lang.String vendorId
vendorName
java.lang.String vendorName
companyUnitId
java.lang.String companyUnitId
debitAccount
java.lang.String debitAccount
relatedDoc
java.lang.String relatedDoc
userName
java.lang.String userName
project
java.lang.String project
freight
java.math.BigDecimal freight
hold
boolean hold
receiver
java.lang.String receiver
receivingItems
java.util.Set<E> receivingItems
Class bb.common.RecursiveBillPath extends java.lang.Object implements Serializable

Serialized Fields

pk
PartPK pk
paths
java.util.HashSet<E> paths
Class bb.common.RefdocElement extends java.lang.Object implements Serializable

Serialized Fields

orderNumber
java.lang.String orderNumber
itemNumber
java.lang.String itemNumber
qty
java.math.BigDecimal qty
Class bb.common.RefdocVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
identifier field

forderNumber
java.lang.String forderNumber
persistent field

fitemNumber
java.lang.String fitemNumber
persistent field

torderNumber
java.lang.String torderNumber
persistent field

titemNumber
java.lang.String titemNumber
persistent field

qty
java.math.BigDecimal qty
persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
persistent field

lastChangeTime
java.lang.Integer lastChangeTime
persistent field

linkOrRef
short linkOrRef
persistent field

Class bb.common.RequestForQuoteCheckListResult extends java.lang.Object implements Serializable

Serialized Fields

rfqNumber
java.lang.String rfqNumber
vendorId
java.lang.String vendorId
buyer
java.lang.String buyer
rfqDate
java.util.Date rfqDate
delivery
java.util.Date delivery
status
java.lang.String status
apTotal
java.math.BigDecimal apTotal
currency
java.lang.String currency
vendorName
java.lang.String vendorName
project
java.lang.String project
comments
java.lang.String comments
Class bb.common.RequestForQuoteItemListResult extends java.lang.Object implements Serializable

Serialized Fields

rfqItemPk
RequestForQuoteItemPK rfqItemPk
partPk
PartPK partPk
partDesc
java.lang.String partDesc
qty
java.math.BigDecimal qty
unit
java.lang.String unit
vendorId
java.lang.String vendorId
vendorName
java.lang.String vendorName
delivery
java.util.Date delivery
comments
java.lang.String comments
status
java.lang.String status
buyer
java.lang.String buyer
rfqDate
java.util.Date rfqDate
partFrom
java.lang.String partFrom
refDoc1
java.lang.String refDoc1
refDoc2
java.lang.String refDoc2
costPerUnit
java.math.BigDecimal costPerUnit
subTotal
java.math.BigDecimal subTotal
discount
java.math.BigDecimal discount
Class bb.common.RequestForQuoteItemManufacturerPK extends java.lang.Object implements Serializable

Serialized Fields

requestForQuoteNumber
java.lang.String requestForQuoteNumber
requestForQuoteItemNumber
java.lang.String requestForQuoteItemNumber
ii
java.lang.Short ii
Class bb.common.RequestForQuoteItemManufacturerVO extends VO implements Serializable

Serialized Fields

pk
RequestForQuoteItemManufacturerPK pk
manufacturerName
java.lang.String manufacturerName
manufacturerPartNumber
java.lang.String manufacturerPartNumber
Class bb.common.RequestForQuoteItemPK extends java.lang.Object implements Serializable

Serialized Fields

requestForQuoteNumber
java.lang.String requestForQuoteNumber
requestForQuoteItemNumber
java.lang.String requestForQuoteItemNumber
Class bb.common.RequestForQuoteItemVO extends VO implements Serializable

Serialized Fields

pk
RequestForQuoteItemPK pk
apSub
java.math.BigDecimal apSub
apDiscount
java.math.BigDecimal apDiscount
extentPrice
java.math.BigDecimal extentPrice
apReceived
java.math.BigDecimal apReceived
apOpen
java.math.BigDecimal apOpen
apTax
java.math.BigDecimal apTax
apTotal
java.math.BigDecimal apTotal
referenceDoc1
java.lang.String referenceDoc1
referenceDoc2
java.lang.String referenceDoc2
company
java.lang.String company
qr
java.lang.String qr
status
java.lang.String status
leadTime
int leadTime
dateRequired
java.util.Date dateRequired
delay
int delay
priority
java.lang.String priority
original
java.util.Date original
actual
java.util.Date actual
location
java.lang.String location
shipVia
java.lang.String shipVia
freight
java.math.BigDecimal freight
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
modelNumber
java.lang.String modelNumber
revision
java.lang.String revision
dwg
java.lang.String dwg
quantity
java.math.BigDecimal quantity
shipQuantity
java.math.BigDecimal shipQuantity
receivedQuantity
java.math.BigDecimal receivedQuantity
hqa
java.math.BigDecimal hqa
costPerUnit
java.math.BigDecimal costPerUnit
unit
java.lang.String unit
discount
java.math.BigDecimal discount
taxRate
java.math.BigDecimal taxRate
description
java.lang.String description
mfg
java.lang.String mfg
mpn
java.lang.String mpn
rfqItemComments
java.lang.String rfqItemComments
rfqItemPrivateNotes
java.lang.String rfqItemPrivateNotes
requestForQuoteItemManufacturer
java.util.Set<E> requestForQuoteItemManufacturer
Class bb.common.RequestForQuoteListResult extends java.lang.Object implements Serializable

Serialized Fields

rfqNumber
java.lang.String rfqNumber
rfqDate
java.util.Date rfqDate
vendorId
java.lang.String vendorId
vendorName
java.lang.String vendorName
delivery
java.util.Date delivery
respondDate
java.util.Date respondDate
buyer
java.lang.String buyer
project
java.lang.String project
comments
java.lang.String comments
status
java.lang.String status
changeOrder
java.lang.String changeOrder
Class bb.common.RequestForQuoteVO extends VO implements Serializable

Serialized Fields

requestForQuoteNumber
java.lang.String requestForQuoteNumber
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
adate
java.util.Date adate
subTotal
java.math.BigDecimal subTotal
apDiscount
java.math.BigDecimal apDiscount
apNet
java.math.BigDecimal apNet
apReceived
java.math.BigDecimal apReceived
apOpen
java.math.BigDecimal apOpen
totalTax
java.math.BigDecimal totalTax
totalFreight
java.math.BigDecimal totalFreight
grantTotal
java.math.BigDecimal grantTotal
changeOrder
java.lang.String changeOrder
vendorId
java.lang.String vendorId
pleaseRespondBy
java.util.Date pleaseRespondBy
contact
java.lang.String contact
salesOrderNumber
java.lang.String salesOrderNumber
status
java.lang.String status
delivery
java.util.Date delivery
delay
byte delay
priority
java.lang.String priority
original
java.util.Date original
actual
java.util.Date actual
shipToId
java.lang.String shipToId
shipVia
java.lang.String shipVia
carrier
java.lang.String carrier
carrierAcct
java.lang.String carrierAcct
incoterm
java.lang.String incoterm
incotermPlacePort
java.lang.String incotermPlacePort
shipAccount
java.lang.String shipAccount
location
java.lang.String location
language
java.lang.String language
currency
java.lang.String currency
terms
java.lang.String terms
rfqDate
java.util.Date rfqDate
buyer
java.lang.String buyer
requester
java.lang.String requester
projectName
java.lang.String projectName
relatedDoc
java.lang.String relatedDoc
debitAccount
java.lang.String debitAccount
taxRate
java.lang.String taxRate
rfqComments
java.lang.String rfqComments
bp
java.lang.String bp
rfqPrivateNotes
java.lang.String rfqPrivateNotes
approvedDate
java.util.Date approvedDate
approvedBy
java.lang.String approvedBy
billToId
java.lang.String billToId
companyUnitId
java.lang.String companyUnitId
lastChangeTimes
int lastChangeTimes
vendorAddressInfo
CustomerVendorAddressInfoVO vendorAddressInfo
shipToAddressInfo
CustomerVendorAddressInfoVO shipToAddressInfo
billToAddressInfo
CustomerVendorAddressInfoVO billToAddressInfo
requestForQuoteItem
java.util.Set<E> requestForQuoteItem
coComments
java.lang.String coComments
Class bb.common.RequestForRMAItemPK extends java.lang.Object implements Serializable

Serialized Fields

rrmaNumber
java.lang.String rrmaNumber
rrmaItemNumber
java.lang.String rrmaItemNumber
Class bb.common.RequestForRMAItemVO extends VO implements Serializable

Serialized Fields

pk
RequestForRMAItemPK pk
identifier field

apSub
java.math.BigDecimal apSub
persistent field

apDiscount
java.math.BigDecimal apDiscount
persistent field

extendPrice
java.math.BigDecimal extendPrice
persistent field

apReceivd
java.math.BigDecimal apReceivd
persistent field

apOpen
java.math.BigDecimal apOpen
persistent field

apTax
java.math.BigDecimal apTax
persistent field

apTotal
java.math.BigDecimal apTotal
persistent field

refDoc1
java.lang.String refDoc1
persistent field

refDoc2
java.lang.String refDoc2
persistent field

changeOrder
java.lang.String changeOrder
persistent field

qr
java.lang.String qr
persistent field

status
java.lang.String status
persistent field

accepted
java.util.Date accepted
nullable persistent field

acceptedBy
java.lang.String acceptedBy
persistent field

delivery
java.util.Date delivery
persistent field

delay
int delay
persistent field

priority
java.lang.String priority
persistent field

original
java.util.Date original
persistent field

actual
java.util.Date actual
persistent field

locate
java.lang.String locate
persistent field

shipvia
java.lang.String shipvia
persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
persistent field

modelNumber
java.lang.String modelNumber
persistent field

revision
java.lang.String revision
persistent field

dwg
java.lang.String dwg
persistent field

quantity
java.math.BigDecimal quantity
persistent field

ship
java.math.BigDecimal ship
persistent field

receivedQuantity
java.math.BigDecimal receivedQuantity
persistent field

costPerUnit
java.math.BigDecimal costPerUnit
persistent field

unit
java.lang.String unit
persistent field

discount
java.math.BigDecimal discount
persistent field

taxRate
java.math.BigDecimal taxRate
persistent field

salesCost
java.math.BigDecimal salesCost
persistent field

currentCost
java.math.BigDecimal currentCost
persistent field

salesStdCost
java.math.BigDecimal salesStdCost
currentStdCost
java.math.BigDecimal currentStdCost
description
java.lang.String description
persistent field

changeMfg
java.lang.String changeMfg
persistent field

mfg
java.lang.String mfg
persistent field

mpn
java.lang.String mpn
persistent field

rrmaItemComments
java.lang.String rrmaItemComments
nullable persistent field

rrmaItemPrivateNotes
java.lang.String rrmaItemPrivateNotes
nullable persistent field

returnMaterialAuthorizationItemManufacturer
java.util.Set<E> returnMaterialAuthorizationItemManufacturer
salesUnit
java.lang.String salesUnit
salesQty
java.math.BigDecimal salesQty
salesPrice
java.math.BigDecimal salesPrice
Class bb.common.RequestForRMAVO extends VO implements Serializable

Serialized Fields

rrmaNumber
java.lang.String rrmaNumber
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
adate
java.util.Date adate
origin
java.lang.String origin
apNetSet
java.lang.String apNetSet
apTaxSet
java.lang.String apTaxSet
subTotal
java.math.BigDecimal subTotal
totalDiscount
java.math.BigDecimal totalDiscount
apSub
java.math.BigDecimal apSub
apReceived
java.math.BigDecimal apReceived
apOpen
java.math.BigDecimal apOpen
totalTax
java.math.BigDecimal totalTax
totalFreight
java.math.BigDecimal totalFreight
grantTotal
java.math.BigDecimal grantTotal
apPaidReceived
java.math.BigDecimal apPaidReceived
apPaidGl
java.math.BigDecimal apPaidGl
apGl1Recorded
java.math.BigDecimal apGl1Recorded
apGl2Paid
java.math.BigDecimal apGl2Paid
changeOrder
java.lang.String changeOrder
coComments
java.lang.String coComments
customerId
java.lang.String customerId
billToId
java.lang.String billToId
contact
java.lang.String contact
salesOrderNumber
java.lang.String salesOrderNumber
status
java.lang.String status
approvedTime
java.util.Date approvedTime
approvedBy
java.lang.String approvedBy
delivery
java.util.Date delivery
delay
byte delay
priority
java.lang.String priority
original
java.util.Date original
actual
java.util.Date actual
shipToId
java.lang.String shipToId
shipVia
java.lang.String shipVia
carrier
java.lang.String carrier
carrierAcct
java.lang.String carrierAcct
incoterm
java.lang.String incoterm
incotermPlacePort
java.lang.String incotermPlacePort
locate
java.lang.String locate
language
java.lang.String language
currency
java.lang.String currency
exchange
java.math.BigDecimal exchange
terms
java.lang.String terms
rrmaDate
java.util.Date rrmaDate
salesman
java.lang.String salesman
salesCodeId
java.lang.String salesCodeId
requester
java.lang.String requester
projectName
java.lang.String projectName
relatedDoc
java.lang.String relatedDoc
debitAccount
java.lang.String debitAccount
bp
java.lang.String bp
comments
java.lang.String comments
privateNotes
java.lang.String privateNotes
companyUnitId
java.lang.String companyUnitId
version
java.lang.Integer version
customerAddressInfo
CustomerVendorAddressInfoVO customerAddressInfo
billToAddressInfo
CustomerVendorAddressInfoVO billToAddressInfo
shipToAddressInfo
CustomerVendorAddressInfoVO shipToAddressInfo
rrmaItem
java.util.Set<E> rrmaItem
invoiceNumber
java.lang.String invoiceNumber
rmaNumber
java.lang.String rmaNumber
Class bb.common.ReturnMaterialAuthorizationDocumentVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
rmaNumber
java.lang.String rmaNumber
documentDescription
java.lang.String documentDescription
documentDate
java.util.Date documentDate
comments
java.lang.String comments
lastUser
java.lang.String lastUser
extension
java.lang.String extension
lastChangeDate
java.util.Date lastChangeDate
docLength
long docLength
docName
java.lang.String docName
Class bb.common.ReturnMaterialAuthorizationItemManufacturerPK extends java.lang.Object implements Serializable

Serialized Fields

rmaNumber
java.lang.String rmaNumber
rmaItemNumber
java.lang.String rmaItemNumber
itemNumber
java.lang.Short itemNumber
Class bb.common.ReturnMaterialAuthorizationItemManufacturerVO extends VO implements Serializable

Serialized Fields

pk
ReturnMaterialAuthorizationItemManufacturerPK pk
identifier field

manufacturerName
java.lang.String manufacturerName
persistent field

manufacturerPartNumber
java.lang.String manufacturerPartNumber
persistent field

Class bb.common.ReturnMaterialAuthorizationItemPK extends java.lang.Object implements Serializable

Serialized Fields

rmaNumber
java.lang.String rmaNumber
identifier field

rmaItemNumber
java.lang.String rmaItemNumber
identifier field

Class bb.common.ReturnMaterialAuthorizationItemVO extends VO implements Serializable

Serialized Fields

pk
ReturnMaterialAuthorizationItemPK pk
apSub
java.math.BigDecimal apSub
apDiscount
java.math.BigDecimal apDiscount
extendPrice
java.math.BigDecimal extendPrice
apReceivd
java.math.BigDecimal apReceivd
apOpen
java.math.BigDecimal apOpen
apTax
java.math.BigDecimal apTax
apTotal
java.math.BigDecimal apTotal
refDoc1
java.lang.String refDoc1
refDoc2
java.lang.String refDoc2
ncrNumber
java.lang.String ncrNumber
changeOrder
java.lang.String changeOrder
qr
java.lang.String qr
status
java.lang.String status
accepted
java.util.Date accepted
acceptedBy
java.lang.String acceptedBy
delivery
java.util.Date delivery
delay
int delay
priority
java.lang.String priority
original
java.util.Date original
actual
java.util.Date actual
locate
java.lang.String locate
shipvia
java.lang.String shipvia
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
modelNumber
java.lang.String modelNumber
revision
java.lang.String revision
dwg
java.lang.String dwg
quantity
java.math.BigDecimal quantity
ship
java.math.BigDecimal ship
receivedQuantity
java.math.BigDecimal receivedQuantity
hqa
java.math.BigDecimal hqa
costPerUnit
java.math.BigDecimal costPerUnit
unit
java.lang.String unit
discount
java.math.BigDecimal discount
taxRate
java.math.BigDecimal taxRate
salesCost
java.math.BigDecimal salesCost
currentCost
java.math.BigDecimal currentCost
salesStdCost
java.math.BigDecimal salesStdCost
currentStdCost
java.math.BigDecimal currentStdCost
description
java.lang.String description
changeMfg
java.lang.String changeMfg
mfg
java.lang.String mfg
mpn
java.lang.String mpn
rmaItemComments
java.lang.String rmaItemComments
rmaItemPrivateNotes
java.lang.String rmaItemPrivateNotes
version
java.lang.Integer version
returnMaterialAuthorizationItemManufacturer
java.util.Set<E> returnMaterialAuthorizationItemManufacturer
salesUnit
java.lang.String salesUnit
salesQty
java.math.BigDecimal salesQty
salesPrice
java.math.BigDecimal salesPrice
Class bb.common.ReturnMaterialAuthorizationVO extends VO implements Serializable

Serialized Fields

rmaNumber
java.lang.String rmaNumber
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
adate
java.util.Date adate
origin
java.lang.String origin
apNetSet
java.lang.String apNetSet
apTaxSet
java.lang.String apTaxSet
subTotal
java.math.BigDecimal subTotal
totalDiscount
java.math.BigDecimal totalDiscount
apSub
java.math.BigDecimal apSub
apReceived
java.math.BigDecimal apReceived
apOpen
java.math.BigDecimal apOpen
totalTax
java.math.BigDecimal totalTax
totalFreight
java.math.BigDecimal totalFreight
grantTotal
java.math.BigDecimal grantTotal
apPaidReceived
java.math.BigDecimal apPaidReceived
apPaidGl
java.math.BigDecimal apPaidGl
apGl1Recorded
java.math.BigDecimal apGl1Recorded
apGl2Paid
java.math.BigDecimal apGl2Paid
changeOrder
java.lang.String changeOrder
coComments
java.lang.String coComments
customerId
java.lang.String customerId
billToId
java.lang.String billToId
contact
java.lang.String contact
salesOrderNumber
java.lang.String salesOrderNumber
invoiceNumber
java.lang.String invoiceNumber
status
java.lang.String status
approvedTime
java.util.Date approvedTime
approvedBy
java.lang.String approvedBy
delivery
java.util.Date delivery
delay
byte delay
priority
java.lang.String priority
original
java.util.Date original
actual
java.util.Date actual
shipToId
java.lang.String shipToId
shipVia
java.lang.String shipVia
carrier
java.lang.String carrier
carrierAcct
java.lang.String carrierAcct
incoterm
java.lang.String incoterm
incotermPlacePort
java.lang.String incotermPlacePort
locate
java.lang.String locate
language
java.lang.String language
currency
java.lang.String currency
exchange
java.math.BigDecimal exchange
terms
java.lang.String terms
rmaDate
java.util.Date rmaDate
salesman
java.lang.String salesman
salesCodeId
java.lang.String salesCodeId
requester
java.lang.String requester
projectName
java.lang.String projectName
relatedDoc
java.lang.String relatedDoc
debitAccount
java.lang.String debitAccount
bp
java.lang.String bp
rmaComments
java.lang.String rmaComments
rmaPrivateNotes
java.lang.String rmaPrivateNotes
companyUnitId
java.lang.String companyUnitId
version
java.lang.Integer version
customerAddressInfo
CustomerVendorAddressInfoVO customerAddressInfo
billToAddressInfo
CustomerVendorAddressInfoVO billToAddressInfo
shipToAddressInfo
CustomerVendorAddressInfoVO shipToAddressInfo
rmaItem
java.util.Set<E> rmaItem
rmaDocment
java.util.Set<E> rmaDocment
bb2RmaReceiverItems
java.util.List<E> bb2RmaReceiverItems
byPos
boolean byPos
receiptNumber
java.lang.String receiptNumber
crtvNumber
java.lang.String crtvNumber
Class bb.common.ReturnToVendorByDateListResult extends java.lang.Object implements Serializable

Serialized Fields

rtvItemPk
ReturnToVendorItemPK rtvItemPk
partPk
BB2Part partPk
VendorId
java.lang.String VendorId
rtvDate
java.util.Date rtvDate
dateRequired
java.util.Date dateRequired
buyer
java.lang.String buyer
project
java.lang.String project
rtvComments
java.lang.String rtvComments
po
java.lang.String po
ncr
java.lang.String ncr
enterBy
java.lang.String enterBy
taxRate
java.math.BigDecimal taxRate
requestor
java.lang.String requestor
billToId
java.lang.String billToId
shipTo
java.lang.String shipTo
currency
java.lang.String currency
description
java.lang.String description
quantity
java.math.BigDecimal quantity
ship
java.math.BigDecimal ship
unit
java.lang.String unit
costPerUnit
java.math.BigDecimal costPerUnit
discount
java.math.BigDecimal discount
apNet
java.math.BigDecimal apNet
rtvistatus
java.lang.String rtvistatus
debitAccount
java.lang.String debitAccount
companyUnitId
java.lang.String companyUnitId
refDoc2
java.lang.String refDoc2
Class bb.common.ReturnToVendorCheckListResult extends java.lang.Object implements Serializable

Serialized Fields

rtvNumber
java.lang.String rtvNumber
vendorId
java.lang.String vendorId
buyer
java.lang.String buyer
rtvDate
java.util.Date rtvDate
delivery
java.util.Date delivery
status
java.lang.String status
apTotal
java.math.BigDecimal apTotal
currency
java.lang.String currency
vendorName
java.lang.String vendorName
project
java.lang.String project
comments
java.lang.String comments
poNumber
java.lang.String poNumber
Class bb.common.ReturnToVendorItemListResult extends java.lang.Object implements Serializable

Serialized Fields

rtvItemPk
ReturnToVendorItemPK rtvItemPk
partPk
PartPK partPk
partDesc
java.lang.String partDesc
qty
java.math.BigDecimal qty
shipped
java.math.BigDecimal shipped
cost
java.math.BigDecimal cost
discount
java.math.BigDecimal discount
extPrice
java.math.BigDecimal extPrice
vendorId
java.lang.String vendorId
vendorName
java.lang.String vendorName
delivery
java.util.Date delivery
status
java.lang.String status
poItemNumber
java.lang.String poItemNumber
partFrom
java.lang.String partFrom
comments
java.lang.String comments
buyer
java.lang.String buyer
unit
java.lang.String unit
rtvDate
java.util.Date rtvDate
refDoc1
java.lang.String refDoc1
refDoc2
java.lang.String refDoc2
Class bb.common.ReturnToVendorItemManufacturerPK extends java.lang.Object implements Serializable

Serialized Fields

returnToVendorNumber
java.lang.String returnToVendorNumber
returnToVendorItemNumber
java.lang.String returnToVendorItemNumber
itemNumber
java.lang.Short itemNumber
Class bb.common.ReturnToVendorItemManufacturerVO extends VO implements Serializable

Serialized Fields

pk
ReturnToVendorItemManufacturerPK pk
identifier field

manufacturerName
java.lang.String manufacturerName
persistent field

manufacturerPartNumber
java.lang.String manufacturerPartNumber
persistent field

Class bb.common.ReturnToVendorItemPK extends java.lang.Object implements Serializable

Serialized Fields

returnToVendorNumber
java.lang.String returnToVendorNumber
identifier field

returnToVendorItemNumber
java.lang.String returnToVendorItemNumber
identifier field

Class bb.common.ReturnToVendorItemVO extends VO implements Serializable

Serialized Fields

pk
ReturnToVendorItemPK pk
identifier field

pi
java.lang.String pi
persistent field

apSub
java.math.BigDecimal apSub
persistent field

apDisc
java.math.BigDecimal apDisc
persistent field

apNet
java.math.BigDecimal apNet
persistent field

apRcvd
java.math.BigDecimal apRcvd
persistent field

apOpen
java.math.BigDecimal apOpen
persistent field

apTax
java.math.BigDecimal apTax
persistent field

apTotal
java.math.BigDecimal apTotal
persistent field

refDoc1
java.lang.String refDoc1
persistent field

refDoc2
java.lang.String refDoc2
persistent field

ncrNumber
java.lang.String ncrNumber
changeOrder
java.lang.String changeOrder
persistent field

qr
java.lang.String qr
persistent field

status
java.lang.String status
persistent field

accepted
java.util.Date accepted
nullable persistent field

acceptedBy
java.lang.String acceptedBy
persistent field

delivery
java.util.Date delivery
persistent field

delay
int delay
persistent field

priority
java.lang.String priority
persistent field

original
java.util.Date original
persistent field

actual
java.util.Date actual
persistent field

locate
java.lang.String locate
persistent field

shipVia
java.lang.String shipVia
persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
persistent field

modelNumber
java.lang.String modelNumber
persistent field

revision
java.lang.String revision
persistent field

dwg
java.lang.String dwg
persistent field

quantity
java.math.BigDecimal quantity
persistent field

ship
java.math.BigDecimal ship
persistent field

receivedQty
java.math.BigDecimal receivedQty
persistent field

hqa
java.math.BigDecimal hqa
persistent field

costPerUnit
java.math.BigDecimal costPerUnit
persistent field

unit
java.lang.String unit
persistent field

discount
java.math.BigDecimal discount
persistent field

taxRate
java.math.BigDecimal taxRate
persistent field

description
java.lang.String description
persistent field

changeMfg
java.lang.String changeMfg
persistent field

mfg
java.lang.String mfg
persistent field

mpn
java.lang.String mpn
persistent field

itemComments
java.lang.String itemComments
nullable persistent field

itemPrivateNotes
java.lang.String itemPrivateNotes
nullable persistent field

itemGrandTotal
java.math.BigDecimal itemGrandTotal
poUnit
java.lang.String poUnit
poUnitQty
java.math.BigDecimal poUnitQty
returnToVendorItemManufacturer
java.util.Set<E> returnToVendorItemManufacturer
Class bb.common.ReturnToVendorListResult extends java.lang.Object implements Serializable

Serialized Fields

rtvNumber
java.lang.String rtvNumber
rtvDate
java.util.Date rtvDate
vendorId
java.lang.String vendorId
vendorName
java.lang.String vendorName
delivery
java.util.Date delivery
buyer
java.lang.String buyer
project
java.lang.String project
comments
java.lang.String comments
status
java.lang.String status
poNumber
java.lang.String poNumber
Class bb.common.ReturnToVendorVO extends VO implements Serializable

Serialized Fields

returnToVendorNumber
java.lang.String returnToVendorNumber
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
adate
java.util.Date adate
origin
java.lang.String origin
apNetSet
java.lang.String apNetSet
apTaxSet
java.lang.String apTaxSet
subTotal
java.math.BigDecimal subTotal
apDisc
java.math.BigDecimal apDisc
apNet
java.math.BigDecimal apNet
apRcvd
java.math.BigDecimal apRcvd
apOpen
java.math.BigDecimal apOpen
totalTax
java.math.BigDecimal totalTax
totalFreight
java.math.BigDecimal totalFreight
grantTotal
java.math.BigDecimal grantTotal
apPaidRcv
java.math.BigDecimal apPaidRcv
apPaidGl
java.math.BigDecimal apPaidGl
apGl1Recorded
java.math.BigDecimal apGl1Recorded
apGl2Paid
java.math.BigDecimal apGl2Paid
changeOrder
java.lang.String changeOrder
coComments
java.lang.String coComments
vendorId
java.lang.String vendorId
billToId
java.lang.String billToId
contact
java.lang.String contact
po
java.lang.String po
status
java.lang.String status
approvedDate
java.util.Date approvedDate
approvedBy
java.lang.String approvedBy
dateRequired
java.util.Date dateRequired
delayDays
byte delayDays
priority
java.lang.String priority
original
java.util.Date original
actual
java.util.Date actual
shipTo
java.lang.String shipTo
shipVia
java.lang.String shipVia
carrier
java.lang.String carrier
carrierAccount
java.lang.String carrierAccount
incoterm
java.lang.String incoterm
incotermPlacePort
java.lang.String incotermPlacePort
shipAccount
java.lang.String shipAccount
locate
java.lang.String locate
language
java.lang.String language
currency
java.lang.String currency
terms
java.lang.String terms
dateEntered
java.util.Date dateEntered
enterBy
java.lang.String enterBy
buyor
java.lang.String buyor
buyorGroup
java.lang.String buyorGroup
requestor
java.lang.String requestor
project
java.lang.String project
reldoc
java.lang.String reldoc
debitAccount
java.lang.String debitAccount
bp
java.lang.String bp
rtvComments
java.lang.String rtvComments
rtvPrivateNotes
java.lang.String rtvPrivateNotes
nullable persistent field

buyer
java.lang.String buyer
companyUnitId
java.lang.String companyUnitId
persistent field

lastChangeTimes
java.lang.Integer lastChangeTimes
nullable persistent field

rtvItems
java.util.Set<E> rtvItems
billToAddressInfo
CustomerVendorAddressInfoVO billToAddressInfo
shipToAddressInfo
CustomerVendorAddressInfoVO shipToAddressInfo
vendorAddressInfo
CustomerVendorAddressInfoVO vendorAddressInfo
bb2ShipperItems
java.util.List<E> bb2ShipperItems
Class bb.common.RfqMessageItemPK extends java.lang.Object implements Serializable

Serialized Fields

rfqMessageNumber
java.lang.String rfqMessageNumber
itemNumber
java.lang.String itemNumber
Class bb.common.RfqMessageItemVO extends VO implements Serializable

Serialized Fields

pk
RfqMessageItemPK pk
identifier field

rfqNumber
java.lang.String rfqNumber
status
java.lang.String status
persistent field

leadTime
int leadTime
persistent field

delay
int delay
persistent field

shipVia
java.lang.String shipVia
persistent field

freight
java.math.BigDecimal freight
persistent field

costPerUnit
java.math.BigDecimal costPerUnit
persistent field

discount
java.math.BigDecimal discount
persistent field

taxRate
java.math.BigDecimal taxRate
persistent field

comments
java.lang.String comments
persistent field

rfqItem
RequestForQuoteItemVO rfqItem
Class bb.common.RfqMessageListResult extends java.lang.Object implements Serializable

Serialized Fields

rfqMessageNumber
java.lang.String rfqMessageNumber
rfqNumber
java.lang.String rfqNumber
vendorId
java.lang.String vendorId
validateCode
java.lang.String validateCode
rfqMessageDate
java.util.Date rfqMessageDate
comments
java.lang.String comments
status
java.lang.String status
Class bb.common.RfqMessageVO extends VO implements Serializable

Serialized Fields

rfqMessageNumber
java.lang.String rfqMessageNumber
rfqNumber
java.lang.String rfqNumber
vendorId
java.lang.String vendorId
validateCode
java.lang.String validateCode
rfqMessageDate
java.util.Date rfqMessageDate
comments
java.lang.String comments
status
java.lang.String status
items
java.util.Set<E> items
Class bb.common.RMAItemListResult extends java.lang.Object implements Serializable

Serialized Fields

rmaNumber
java.lang.String rmaNumber
rmaItemNumber
java.lang.String rmaItemNumber
partPk
PartPK partPk
itemDescription
java.lang.String itemDescription
rmaDate
java.util.Date rmaDate
deliveryDate
java.util.Date deliveryDate
orderedQty
java.math.BigDecimal orderedQty
receivedQty
java.math.BigDecimal receivedQty
costPerUnit
java.math.BigDecimal costPerUnit
discount
java.math.BigDecimal discount
customerId
java.lang.String customerId
invoiceNumber
java.lang.String invoiceNumber
salesOrderNumber
java.lang.String salesOrderNumber
ncrNumber
java.lang.String ncrNumber
status
java.lang.String status
salesman
java.lang.String salesman
onhandQty
java.math.BigDecimal onhandQty
onorderQty
java.math.BigDecimal onorderQty
onDemandQty
java.math.BigDecimal onDemandQty
partFrom
java.lang.String partFrom
debitAccount
java.lang.String debitAccount
companyUnitId
java.lang.String companyUnitId
Class bb.common.RMAListResult extends java.lang.Object implements Serializable

Serialized Fields

rmaNumber
java.lang.String rmaNumber
rmaDate
java.util.Date rmaDate
changeOrder
java.lang.String changeOrder
customerId
java.lang.String customerId
invoiceNumber
java.lang.String invoiceNumber
project
java.lang.String project
privateNote
java.lang.String privateNote
comments
java.lang.String comments
status
java.lang.String status
requester
java.lang.String requester
salesOrderNumber
java.lang.String salesOrderNumber
salesman
java.lang.String salesman
Class bb.common.RMAReceiverItemListResult extends java.lang.Object implements Serializable

Serialized Fields

itemNumber
java.lang.String itemNumber
receiverNumber
java.lang.String receiverNumber
rmaNumber
java.lang.String rmaNumber
receivedBy
java.lang.String receivedBy
status
java.lang.String status
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
quantity
java.math.BigDecimal quantity
quantityRcv
java.math.BigDecimal quantityRcv
salesCost
java.math.BigDecimal salesCost
cm
java.lang.String cm
unit
java.lang.String unit
description
java.lang.String description
dateReceived
java.util.Date dateReceived
comments
java.lang.String comments
notes
java.lang.String notes
custID
java.lang.String custID
soNumber
java.lang.String soNumber
Class bb.common.RMAReceiverItemPK extends java.lang.Object implements Serializable

Serialized Fields

itemNumber
java.lang.String itemNumber
identifier field

receiverNumber
java.lang.String receiverNumber
identifier field

Class bb.common.RMAReceiverItemVO extends VO implements Serializable

Serialized Fields

pk
RMAReceiverItemPK pk
identifier field

rmaNumber
java.lang.String rmaNumber
persistent field

cmSub
java.math.BigDecimal cmSub
persistent field

cmRcvd
java.math.BigDecimal cmRcvd
persistent field

cmOpen
java.math.BigDecimal cmOpen
persistent field

cmDisc
java.math.BigDecimal cmDisc
persistent field

cmNet
java.math.BigDecimal cmNet
persistent field

cmTax
java.math.BigDecimal cmTax
persistent field

cmTotal
java.math.BigDecimal cmTotal
persistent field

due
java.math.BigDecimal due
persistent field

paid
java.math.BigDecimal paid
persistent field

datePaid
java.util.Date datePaid
nullable persistent field

checkNo
java.lang.String checkNo
persistent field

refDoc1
java.lang.String refDoc1
persistent field

refDoc2
java.lang.String refDoc2
persistent field

qr
java.lang.String qr
persistent field

sentTo
java.lang.String sentTo
persistent field

receivedBy
java.lang.String receivedBy
persistent field

condition
java.lang.String condition
persistent field

status
java.lang.String status
persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
persistent field

model
java.lang.String model
persistent field

revision
java.lang.String revision
persistent field

locate
java.lang.String locate
persistent field

quantity
java.math.BigDecimal quantity
persistent field

quantityTraced
java.math.BigDecimal quantityTraced
persistent field

quantityRcv
java.math.BigDecimal quantityRcv
persistent field

price
java.math.BigDecimal price
persistent field

unit
java.lang.String unit
persistent field

discount
java.math.BigDecimal discount
persistent field

taxr
java.math.BigDecimal taxr
persistent field

salesCost
java.math.BigDecimal salesCost
persistent field

currentCost
java.math.BigDecimal currentCost
persistent field

salesStdCost
java.math.BigDecimal salesStdCost
currentStdCost
java.math.BigDecimal currentStdCost
description
java.lang.String description
persistent field

mfg
java.lang.String mfg
persistent field

mpn
java.lang.String mpn
persistent field

serial
java.lang.String serial
persistent field

comments
java.lang.String comments
nullable persistent field

notes
java.lang.String notes
nullable persistent field

hqa
java.math.BigDecimal hqa
locations
java.util.Map<K,V> locations
trackings
java.util.Map<K,V> trackings
Class bb.common.RMAReceiverListResult extends java.lang.Object implements Serializable

Serialized Fields

receiverNumber
java.lang.String receiverNumber
rmaNumber
java.lang.String rmaNumber
creditMemoNumber
java.lang.String creditMemoNumber
custID
java.lang.String custID
status
java.lang.String status
receivedBy
java.lang.String receivedBy
dateReceived
java.util.Date dateReceived
project
java.lang.String project
comments
java.lang.String comments
notes
java.lang.String notes
Class bb.common.RMAReceiverResult extends java.lang.Object implements Serializable

Serialized Fields

pk
ReturnMaterialAuthorizationItemPK pk
quantity
java.math.BigDecimal quantity
receivedQuantity
java.math.BigDecimal receivedQuantity
delivery
java.util.Date delivery
description
java.lang.String description
customerId
java.lang.String customerId
billToId
java.lang.String billToId
shipToId
java.lang.String shipToId
locations
java.util.Map<K,V> locations
Class bb.common.RMAReceiverVO extends VO implements Serializable

Serialized Fields

receiverNumber
java.lang.String receiverNumber
identifier field

rmaNumber
java.lang.String rmaNumber
persistent field

creditMemoNumber
java.lang.String creditMemoNumber
persistent field

custID
java.lang.String custID
persistent field

billToId
java.lang.String billToId
shipToId
java.lang.String shipToId
batch
java.lang.String batch
persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
persistent field

adate
java.util.Date adate
persistent field

origin
java.lang.String origin
persistent field

cmNetSet
java.lang.String cmNetSet
persistent field

cmTaxSet
java.lang.String cmTaxSet
persistent field

cmSub
java.math.BigDecimal cmSub
persistent field

cmRcvd
java.math.BigDecimal cmRcvd
persistent field

cmOpen
java.math.BigDecimal cmOpen
persistent field

cmDisc
java.math.BigDecimal cmDisc
persistent field

cmNet
java.math.BigDecimal cmNet
persistent field

cmTax
java.math.BigDecimal cmTax
persistent field

cmFreight
java.math.BigDecimal cmFreight
persistent field

cmTotal
java.math.BigDecimal cmTotal
persistent field

cmPaidRcv
java.math.BigDecimal cmPaidRcv
persistent field

cmPaidGl
java.math.BigDecimal cmPaidGl
persistent field

cmGl1Recorded
java.math.BigDecimal cmGl1Recorded
persistent field

cmGl2Paid
java.math.BigDecimal cmGl2Paid
persistent field

changeOrder
java.lang.String changeOrder
persistent field

coComments
java.lang.String coComments
nullable persistent field

status
java.lang.String status
persistent field

collect
java.lang.String collect
persistent field

receivedBy
java.lang.String receivedBy
persistent field

dateReceived
java.util.Date dateReceived
persistent field

deliveredTo
java.lang.String deliveredTo
persistent field

freightBill
java.lang.String freightBill
persistent field

shippedVia
java.lang.String shippedVia
persistent field

carrier
java.lang.String carrier
persistent field

carrierAcct
java.lang.String carrierAcct
persistent field

tracking
java.lang.String tracking
persistent field

incoterm
java.lang.String incoterm
persistent field

incotermPlacePort
java.lang.String incotermPlacePort
persistent field

currency
java.lang.String currency
persistent field

exchange
java.math.BigDecimal exchange
terms
java.lang.String terms
persistent field

requestor
java.lang.String requestor
persistent field

buyor
java.lang.String buyor
persistent field

project
java.lang.String project
persistent field

reldoc
java.lang.String reldoc
persistent field

debitAccount
java.lang.String debitAccount
persistent field

bp
java.lang.String bp
persistent field

comments
java.lang.String comments
nullable persistent field

notes
java.lang.String notes
nullable persistent field

due
java.math.BigDecimal due
persistent field

customerDm
java.lang.String customerDm
customerShipper
java.lang.String customerShipper
customerDmTotal
java.math.BigDecimal customerDmTotal
customerShipperDate
java.util.Date customerShipperDate
customerDmDate
java.util.Date customerDmDate
paydate
java.util.Date paydate
nullable persistent field

datePaid
java.util.Date datePaid
nullable persistent field

checkNo
java.lang.String checkNo
persistent field

paid
java.math.BigDecimal paid
persistent field

itran
java.lang.String itran
persistent field

etran
java.lang.String etran
persistent field

companyUnitId
java.lang.String companyUnitId
persistent field

version
java.lang.Integer version
nullable persistent field

language
java.lang.String language
persistent field

items
java.util.Set<E> items
persistent field

customerAddressInfo
CustomerVendorAddressInfoVO customerAddressInfo
billToInfo
CustomerVendorAddressInfoVO billToInfo
shipToInfo
CustomerVendorAddressInfoVO shipToInfo
Class bb.common.RMAReviewVO extends VO implements Serializable

Serialized Fields

employeeID
java.lang.String employeeID
identifier field

userName
java.lang.String userName
persistent field

reviewLimit
java.math.BigDecimal reviewLimit
persistent field

currency
java.lang.String currency
persistent field

canReviewOwnRMA
java.lang.String canReviewOwnRMA
persistent field

comments
java.lang.String comments
nullable persistent field

Class bb.common.RoleDescriptionPK extends java.lang.Object implements Serializable

Serialized Fields

roleId
java.lang.String roleId
identifier field

language
java.lang.String language
identifier field

Class bb.common.RoleDescriptionVO extends VO implements Serializable

Serialized Fields

pk
RoleDescriptionPK pk
roleName
java.lang.String roleName
description
java.lang.String description
Class bb.common.RoleListResult extends java.lang.Object implements Serializable

Serialized Fields

RoleId
java.lang.String RoleId
system
boolean system
roleName
java.lang.String roleName
description
java.lang.String description
Class bb.common.RolePermissionPK extends java.lang.Object implements Serializable

Serialized Fields

roleId
java.lang.String roleId
identifier field

permissionId
java.lang.String permissionId
identifier field

Class bb.common.RolePermissionVO extends VO implements Serializable

Serialized Fields

pk
RolePermissionPK pk
identifier field

Class bb.common.RoleVO extends VO implements Serializable

Serialized Fields

roleId
java.lang.String roleId
identifier field

system
boolean system
multiLanguage
java.util.Set<E> multiLanguage
rolePermissions
java.util.Set<E> rolePermissions
persistent field

Class bb.common.RollUpBomStdCostWorkSheetItemPK extends java.lang.Object implements Serializable

Serialized Fields

ii
java.lang.Long ii
billNumber
java.lang.String billNumber
billType
java.lang.String billType
Class bb.common.RollUpBomStdCostWorkSheetItemVO extends VO implements Serializable

Serialized Fields

pk
RollUpBomStdCostWorkSheetItemPK pk
description
java.lang.String description
stdCost
java.math.BigDecimal stdCost
avgCost
java.math.BigDecimal avgCost
rollUpCost
java.math.BigDecimal rollUpCost
onHand
java.math.BigDecimal onHand
level
java.lang.Integer level
Class bb.common.RollUpBomStdCostWorkSheetVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
createdBy
java.lang.String createdBy
createdDate
java.util.Date createdDate
startDate
java.util.Date startDate
endDate
java.util.Date endDate
bomCount
java.lang.Integer bomCount
rollUpCount
java.lang.Integer rollUpCount
varianceCount
java.lang.Integer varianceCount
varianceAmount
java.math.BigDecimal varianceAmount
committedDate
java.util.Date committedDate
committedBy
java.lang.String committedBy
transactionNumber
java.lang.String transactionNumber
status
java.lang.String status
log
java.lang.String log
useAvgCostToRollUp
boolean useAvgCostToRollUp
Class bb.common.RollUPPartStandardCostResult extends java.lang.Object implements Serializable

Serialized Fields

pk
PartPK pk
description
java.lang.String description
bill
java.lang.String bill
pcode
java.lang.String pcode
standardCost
java.math.BigDecimal standardCost
rollupStdCost
java.math.BigDecimal rollupStdCost
Class bb.common.RRMAItemListResult extends java.lang.Object implements Serializable

Serialized Fields

rrmaNumber
java.lang.String rrmaNumber
rrmaItemNumber
java.lang.String rrmaItemNumber
partPk
PartPK partPk
itemDescription
java.lang.String itemDescription
rrmaDate
java.util.Date rrmaDate
deliveryDate
java.util.Date deliveryDate
orderedQty
java.math.BigDecimal orderedQty
costPerUnit
java.math.BigDecimal costPerUnit
discount
java.math.BigDecimal discount
customerId
java.lang.String customerId
invoiceNumber
java.lang.String invoiceNumber
salesOrderNumber
java.lang.String salesOrderNumber
status
java.lang.String status
salesman
java.lang.String salesman
onhandQty
java.math.BigDecimal onhandQty
onorderQty
java.math.BigDecimal onorderQty
onDemandQty
java.math.BigDecimal onDemandQty
partFrom
java.lang.String partFrom
debitAccount
java.lang.String debitAccount
companyUnitId
java.lang.String companyUnitId
Class bb.common.RRMAListResult extends java.lang.Object implements Serializable

Serialized Fields

rrmaNumber
java.lang.String rrmaNumber
rrmaDate
java.util.Date rrmaDate
changeOrder
java.lang.String changeOrder
customerId
java.lang.String customerId
invoiceNumber
java.lang.String invoiceNumber
project
java.lang.String project
privateNote
java.lang.String privateNote
comments
java.lang.String comments
status
java.lang.String status
requester
java.lang.String requester
salesOrderNumber
java.lang.String salesOrderNumber
salesman
java.lang.String salesman
Class bb.common.RTVApprovalVO extends VO implements Serializable

Serialized Fields

employeeID
java.lang.String employeeID
identifier field

userName
java.lang.String userName
persistent field

approvalLimit
java.math.BigDecimal approvalLimit
persistent field

currency
java.lang.String currency
persistent field

canApproveOwnRTV
java.lang.String canApproveOwnRTV
persistent field

comments
java.lang.String comments
nullable persistent field

Class bb.common.RtvShipperInfoVO extends VO implements Serializable

Serialized Fields

rtvShipperNumber
java.lang.String rtvShipperNumber
identifier field

rtvNumber
java.lang.String rtvNumber
persistent field

apNumber
java.lang.String apNumber
persistent field

vendorId
java.lang.String vendorId
persistent field

batch
java.lang.String batch
persistent field

billtoId
java.lang.String billtoId
persistent field

poNumber
java.lang.String poNumber
persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

adate
java.util.Date adate
nullable persistent field

origin
java.lang.String origin
persistent field

apNetSet
java.lang.String apNetSet
persistent field

apTaxSet
java.lang.String apTaxSet
persistent field

apSub
java.math.BigDecimal apSub
persistent field

apShip
java.math.BigDecimal apShip
persistent field

apOpen
java.math.BigDecimal apOpen
persistent field

apDiscount
java.math.BigDecimal apDiscount
persistent field

apNet
java.math.BigDecimal apNet
persistent field

apTax
java.math.BigDecimal apTax
persistent field

apFreight
java.math.BigDecimal apFreight
persistent field

apTotal
java.math.BigDecimal apTotal
persistent field

apPaidInv
java.math.BigDecimal apPaidInv
persistent field

apPaidGl
java.math.BigDecimal apPaidGl
persistent field

apGl1Recorded
java.math.BigDecimal apGl1Recorded
persistent field

apGl2Paid
java.math.BigDecimal apGl2Paid
persistent field

changeOrder
java.lang.String changeOrder
persistent field

coComments
java.lang.String coComments
nullable persistent field

status
java.lang.String status
persistent field

salesman
java.lang.String salesman
persistent field

shippedDate
java.util.Date shippedDate
nullable persistent field

shippedBy
java.lang.String shippedBy
persistent field

invoicedDate
java.util.Date invoicedDate
nullable persistent field

invoicedBy
java.lang.String invoicedBy
persistent field

shipToId
java.lang.String shipToId
persistent field

remitId
java.lang.String remitId
persistent field

shipVia
java.lang.String shipVia
persistent field

carrier
java.lang.String carrier
persistent field

carrierAccount
java.lang.String carrierAccount
persistent field

freightRateCode
java.lang.String freightRateCode
persistent field

grossWeight
java.lang.String grossWeight
persistent field

tracking
java.lang.String tracking
persistent field

incoterm
java.lang.String incoterm
persistent field

incotermPlacePort
java.lang.String incotermPlacePort
persistent field

dateShipped
java.util.Date dateShipped
nullable persistent field

dateInvoiced
java.util.Date dateInvoiced
nullable persistent field

freightBill
java.lang.String freightBill
persistent field

currency
java.lang.String currency
persistent field

language
java.lang.String language
persistent field

terms
java.lang.String terms
persistent field

reldoc
java.lang.String reldoc
persistent field

debitAccount
java.lang.String debitAccount
persistent field

bp
java.lang.String bp
persistent field

shBplate
java.lang.String shBplate
nullable persistent field

comments
java.lang.String comments
nullable persistent field

notes
java.lang.String notes
nullable persistent field

due
java.math.BigDecimal due
persistent field

paydate
java.util.Date paydate
nullable persistent field

datePaid
java.util.Date datePaid
nullable persistent field

checkNumber
java.lang.String checkNumber
persistent field

paid
java.math.BigDecimal paid
persistent field

otran
java.lang.String otran
persistent field

rtran
java.lang.String rtran
persistent field

version
int version
nullable persistent field

vendorPicked
boolean vendorPicked
shipToAddressInfo
CustomerVendorAddressInfoVO shipToAddressInfo
nullable persistent field

billToAddressInfo
CustomerVendorAddressInfoVO billToAddressInfo
nullable persistent field

Class bb.common.RtvShipperItemListResult extends java.lang.Object implements Serializable

Serialized Fields

rtvShipperNumber
java.lang.String rtvShipperNumber
rtvShipperItemNumber
java.lang.String rtvShipperItemNumber
rtvNumber
java.lang.String rtvNumber
dateShipped
java.util.Date dateShipped
shipvia
java.lang.String shipvia
status
java.lang.String status
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
qty
java.math.BigDecimal qty
qtyShip
java.math.BigDecimal qtyShip
costPerUnit
java.math.BigDecimal costPerUnit
poNumber
java.lang.String poNumber
description
java.lang.String description
comments
java.lang.String comments
notes
java.lang.String notes
vendorId
java.lang.String vendorId
apNumber
java.lang.String apNumber
Class bb.common.RtvShipperItemPK extends java.lang.Object implements Serializable

Serialized Fields

rtvShipperNumber
java.lang.String rtvShipperNumber
identifier field

rtvShipperItemNumber
java.lang.String rtvShipperItemNumber
identifier field

Class bb.common.RtvShipperItemVO extends VO implements Serializable

Serialized Fields

pk
RtvShipperItemPK pk
identifier field

rtvNumber
java.lang.String rtvNumber
persistent field

apSub
java.math.BigDecimal apSub
persistent field

apShip
java.math.BigDecimal apShip
persistent field

apOpen
java.math.BigDecimal apOpen
persistent field

apDisc
java.math.BigDecimal apDisc
persistent field

apNet
java.math.BigDecimal apNet
persistent field

apTax
java.math.BigDecimal apTax
persistent field

apTotal
java.math.BigDecimal apTotal
persistent field

due
java.math.BigDecimal due
persistent field

paid
java.math.BigDecimal paid
persistent field

datePaid
java.util.Date datePaid
nullable persistent field

checkNo
java.lang.String checkNo
persistent field

refDoc1
java.lang.String refDoc1
persistent field

refDoc2
java.lang.String refDoc2
persistent field

dateShipped
java.util.Date dateShipped
nullable persistent field

dateInvoiced
java.util.Date dateInvoiced
nullable persistent field

shipvia
java.lang.String shipvia
persistent field

shipto
java.lang.String shipto
persistent field

status
java.lang.String status
persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
persistent field

moldNumber
java.lang.String moldNumber
persistent field

revision
java.lang.String revision
persistent field

locate
java.lang.String locate
persistent field

qty
java.math.BigDecimal qty
persistent field

qtyShip
java.math.BigDecimal qtyShip
persistent field

listPrice
java.math.BigDecimal listPrice
persistent field

avgCost
java.math.BigDecimal avgCost
persistent field

stdCost
java.math.BigDecimal stdCost
unit
java.lang.String unit
persistent field

discount
java.math.BigDecimal discount
persistent field

taxRate
java.math.BigDecimal taxRate
persistent field

description
java.lang.String description
persistent field

mfg
java.lang.String mfg
persistent field

mpn
java.lang.String mpn
persistent field

serial
java.lang.String serial
persistent field

comments
java.lang.String comments
nullable persistent field

notes
java.lang.String notes
nullable persistent field

itemGrandTotal
java.math.BigDecimal itemGrandTotal
item grand total*

refDocTwoes
java.util.Set<E> refDocTwoes
nullable persistent field

refDocOnes
java.util.Set<E> refDocOnes
persistent field

locations
java.util.Map<K,V> locations
trackings
java.util.Map<K,V> trackings
Class bb.common.RtvShipperListResult extends java.lang.Object implements Serializable

Serialized Fields

rtvShipperNumber
java.lang.String rtvShipperNumber
rtvNumber
java.lang.String rtvNumber
apNumber
java.lang.String apNumber
vendorId
java.lang.String vendorId
poNumber
java.lang.String poNumber
status
java.lang.String status
shippedDate
java.util.Date shippedDate
shippedBy
java.lang.String shippedBy
shipToId
java.lang.String shipToId
shipVia
java.lang.String shipVia
dateShipped
java.util.Date dateShipped
comments
java.lang.String comments
notes
java.lang.String notes
Class bb.common.RtvShipperVO extends VO implements Serializable

Serialized Fields

rtvShipperNumber
java.lang.String rtvShipperNumber
identifier field

rtvNumber
java.lang.String rtvNumber
persistent field

apNumber
java.lang.String apNumber
persistent field

vendorId
java.lang.String vendorId
persistent field

batch
java.lang.String batch
persistent field

billtoId
java.lang.String billtoId
persistent field

poNumber
java.lang.String poNumber
persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

adate
java.util.Date adate
nullable persistent field

origin
java.lang.String origin
persistent field

apNetSet
java.lang.String apNetSet
persistent field

apTaxSet
java.lang.String apTaxSet
persistent field

apSub
java.math.BigDecimal apSub
persistent field

apShip
java.math.BigDecimal apShip
persistent field

apOpen
java.math.BigDecimal apOpen
persistent field

apDiscount
java.math.BigDecimal apDiscount
persistent field

apNet
java.math.BigDecimal apNet
persistent field

apTax
java.math.BigDecimal apTax
persistent field

apFreight
java.math.BigDecimal apFreight
persistent field

apTotal
java.math.BigDecimal apTotal
persistent field

apPaidInv
java.math.BigDecimal apPaidInv
persistent field

apPaidGl
java.math.BigDecimal apPaidGl
persistent field

apGl1Recorded
java.math.BigDecimal apGl1Recorded
persistent field

apGl2Paid
java.math.BigDecimal apGl2Paid
persistent field

changeOrder
java.lang.String changeOrder
persistent field

coComments
java.lang.String coComments
nullable persistent field

status
java.lang.String status
persistent field

salesman
java.lang.String salesman
persistent field

shippedDate
java.util.Date shippedDate
nullable persistent field

shippedBy
java.lang.String shippedBy
persistent field

invoicedDate
java.util.Date invoicedDate
nullable persistent field

invoicedBy
java.lang.String invoicedBy
persistent field

shipToId
java.lang.String shipToId
persistent field

remitId
java.lang.String remitId
persistent field

shipVia
java.lang.String shipVia
persistent field

carrier
java.lang.String carrier
persistent field

carrierAccount
java.lang.String carrierAccount
persistent field

freightRateCode
java.lang.String freightRateCode
persistent field

grossWeight
java.lang.String grossWeight
persistent field

tracking
java.lang.String tracking
persistent field

incoterm
java.lang.String incoterm
persistent field

incotermPlacePort
java.lang.String incotermPlacePort
persistent field

dateShipped
java.util.Date dateShipped
nullable persistent field

dateInvoiced
java.util.Date dateInvoiced
nullable persistent field

freightBill
java.lang.String freightBill
persistent field

currency
java.lang.String currency
persistent field

language
java.lang.String language
persistent field

terms
java.lang.String terms
persistent field

reldoc
java.lang.String reldoc
persistent field

debitAccount
java.lang.String debitAccount
persistent field

bp
java.lang.String bp
persistent field

shBplate
java.lang.String shBplate
nullable persistent field

comments
java.lang.String comments
nullable persistent field

notes
java.lang.String notes
nullable persistent field

due
java.math.BigDecimal due
persistent field

paydate
java.util.Date paydate
nullable persistent field

datePaid
java.util.Date datePaid
nullable persistent field

checkNumber
java.lang.String checkNumber
persistent field

paid
java.math.BigDecimal paid
persistent field

otran
java.lang.String otran
persistent field

rtran
java.lang.String rtran
persistent field

companyUnitId
java.lang.String companyUnitId
persistent field

version
int version
nullable persistent field

vendorPicked
boolean vendorPicked
vendorAddressInfo
CustomerVendorAddressInfoVO vendorAddressInfo
shipToAddressInfo
CustomerVendorAddressInfoVO shipToAddressInfo
nullable persistent field

billToAddressInfo
CustomerVendorAddressInfoVO billToAddressInfo
nullable persistent field

rtvShipperItems
java.util.Set<E> rtvShipperItems
persistent field

Class bb.common.RunningAccountOrderItemPK extends java.lang.Object implements Serializable

Serialized Fields

runningAccountOrderNumber
java.lang.String runningAccountOrderNumber
runningAccountOrderItemNumber
java.lang.String runningAccountOrderItemNumber
Class bb.common.RunningAccountOrderItemResult extends RunningAccountOrderItemVO implements Serializable

Serialized Fields

raoNumber
java.lang.String raoNumber
raoiNumber
java.lang.String raoiNumber
customerId
java.lang.String customerId
taxRate
java.math.BigDecimal taxRate
payableMethod
java.lang.String payableMethod
salesDate
java.util.Date salesDate
salesman
java.lang.String salesman
checkReturn
boolean checkReturn
salesOrder
java.lang.String salesOrder
contact
java.lang.String contact
freight
java.math.BigDecimal freight
shipTo
java.lang.String shipTo
billTo
java.lang.String billTo
comments
java.lang.String comments
notes
java.lang.String notes
poNumber
java.lang.String poNumber
checkNumber
java.lang.String checkNumber
Class bb.common.RunningAccountOrderItemVO extends VO implements Serializable

Serialized Fields

pk
RunningAccountOrderItemPK pk
partNumber
java.lang.String partNumber
partType
java.lang.String partType
desc
java.lang.String desc
quantity
java.math.BigDecimal quantity
price
java.math.BigDecimal price
discount
java.math.BigDecimal discount
realTimeOnhand
java.math.BigDecimal realTimeOnhand
tempOnhand
java.math.BigDecimal tempOnhand
subTotal
java.math.BigDecimal subTotal
netTotal
java.math.BigDecimal netTotal
taxTotal
java.math.BigDecimal taxTotal
freight
java.math.BigDecimal freight
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
profit
java.math.BigDecimal profit
profitPercent
java.math.BigDecimal profitPercent
profitByStdCost
java.math.BigDecimal profitByStdCost
profitPercentByStdCost
java.math.BigDecimal profitPercentByStdCost
boughtQty
java.math.BigDecimal boughtQty
partOnhand
java.math.BigDecimal partOnhand
dutyFree
boolean dutyFree
mfgPartNumber
java.lang.String mfgPartNumber
poPrice
java.math.BigDecimal poPrice
poPriceProfit
java.math.BigDecimal poPriceProfit
poPriceProfitPercent
java.math.BigDecimal poPriceProfitPercent
salesPrice
java.math.BigDecimal salesPrice
refDoc
java.util.Set<E> refDoc
unit
java.lang.String unit
unitQty
java.math.BigDecimal unitQty
unitPrice
java.math.BigDecimal unitPrice
units
java.util.Set<E> units
tax
java.math.BigDecimal tax
modelNumber
java.lang.String modelNumber
commodityCode
java.lang.String commodityCode
productCode
java.lang.String productCode
discountable
boolean discountable
partTaxExempt
boolean partTaxExempt
lastSOPrice
java.lang.String lastSOPrice
Class bb.common.RunningAccountOrderVO extends VO implements Serializable

Serialized Fields

runningAccountOrderNumber
java.lang.String runningAccountOrderNumber
salesman
java.lang.String salesman
salesDate
java.util.Date salesDate
netTotal
java.math.BigDecimal netTotal
subTotal
java.math.BigDecimal subTotal
discTotal
java.math.BigDecimal discTotal
taxTotal
java.math.BigDecimal taxTotal
avgCostTotal
java.math.BigDecimal avgCostTotal
profitTotal
java.math.BigDecimal profitTotal
profitPercentTotal
java.math.BigDecimal profitPercentTotal
profitTotalByStdCost
java.math.BigDecimal profitTotalByStdCost
profitPercentTotalByStdCost
java.math.BigDecimal profitPercentTotalByStdCost
accountsReceivable
java.math.BigDecimal accountsReceivable
realReceivable
java.math.BigDecimal realReceivable
customerId
java.lang.String customerId
elecSignature
byte[] elecSignature
payableMethod
java.lang.String payableMethod
checkNumber
java.lang.String checkNumber
creditCardNumber
java.lang.String creditCardNumber
dutyFreeNumber
java.lang.String dutyFreeNumber
checkReturn
boolean checkReturn
originalNumber
java.lang.String originalNumber
customerAddressInfo
CustomerVendorAddressInfoVO customerAddressInfo
runningAccountOrderItems
java.util.Set<E> runningAccountOrderItems
salesOrder
java.lang.String salesOrder
taxRate
java.math.BigDecimal taxRate
freight
java.math.BigDecimal freight
contact
java.lang.String contact
computerId
java.lang.String computerId
invoiceNumber
java.lang.String invoiceNumber
billTo
java.lang.String billTo
shipTo
java.lang.String shipTo
tax
java.math.BigDecimal tax
changeNote
java.math.BigDecimal changeNote
currency
java.lang.String currency
exchange
java.math.BigDecimal exchange
comments
java.lang.String comments
notes
java.lang.String notes
poNumber
java.lang.String poNumber
ipAddr
java.lang.String ipAddr
printReturnNumber
java.lang.String printReturnNumber
taxType
java.lang.String taxType
validDate
java.util.Date validDate
Class bb.common.RunTaxPaymentResult extends java.lang.Object implements Serializable

Serialized Fields

runningAccountOrderNumber
java.lang.String runningAccountOrderNumber
customerId
java.lang.String customerId
salesman
java.lang.String salesman
taxTotal
java.lang.String taxTotal
Class bb.common.SalesBomItemResult extends java.lang.Object implements Serializable

Serialized Fields

billItemPk
BillItemPK billItemPk
billPartFrom
java.lang.String billPartFrom
saleable
java.lang.String saleable
removedItem
java.lang.String removedItem
partPk
PartPK partPk
partFrom
java.lang.String partFrom
quantity
java.math.BigDecimal quantity
revision
java.lang.String revision
unit
java.lang.String unit
description
java.lang.String description
hold
java.lang.String hold
drawing
java.lang.String drawing
bill
java.lang.String bill
sparePart
java.lang.String sparePart
Class bb.common.SalesBomResult extends java.lang.Object implements Serializable

Serialized Fields

billPk
BillPK billPk
billPartFrom
java.lang.String billPartFrom
saleable
java.lang.String saleable
revision
java.lang.String revision
unit
java.lang.String unit
description
java.lang.String description
hold
java.lang.String hold
drawing
java.lang.String drawing
items
java.util.Set<E> items
Class bb.common.SalesCodeVO extends VO implements Serializable

Serialized Fields

salesCodeId
java.lang.String salesCodeId
salesCodeName
java.lang.String salesCodeName
lastChangeTimes
java.lang.Integer lastChangeTimes
addressId
java.lang.String addressId
addressName
java.lang.String addressName
lastChangeUser
java.lang.String lastChangeUser
employeeId
java.lang.String employeeId
commissionRate
java.math.BigDecimal commissionRate
lastChangeDate
java.util.Date lastChangeDate
comments
java.lang.String comments
containTax
boolean containTax
salesCodeIds
java.util.Set<E> salesCodeIds
Class bb.common.SalesInfoCenter extends java.lang.Object implements Serializable

Serialized Fields

soTotalSum
SalesInfoCenter.SoTotalSum soTotalSum
soCount
SalesInfoCenter.SoCount soCount
soItemCount
SalesInfoCenter.SoItemCount soItemCount
openSoSum
SalesInfoCenter.OpenSoSum openSoSum
dueSoSum
SalesInfoCenter.DueSoSum dueSoSum
dueSoCount
SalesInfoCenter.DueSoCount dueSoCount
soCountWithPartsOnhold
SalesInfoCenter.SoCountWithPartsOnhold soCountWithPartsOnhold
invoicedSum
SalesInfoCenter.InvoicedSum invoicedSum
grossMargin
SalesInfoCenter.GrossMargin grossMargin
Class bb.common.SalesInfoCenter.SoCount extends java.lang.Object implements Serializable

Serialized Fields

thisMonth
int thisMonth
lastMonth
int lastMonth
fiscalYear
int fiscalYear
averagePerMonth
double averagePerMonth
Class bb.common.SalesInfoCenter.SoItemCount extends java.lang.Object implements Serializable

Serialized Fields

thisMonth
int thisMonth
lastMonth
int lastMonth
fiscalYear
int fiscalYear
averagePerMonth
double averagePerMonth
Class bb.common.SalesInfoCenter.SoTotalSum extends java.lang.Object implements Serializable

Serialized Fields

thisMonth
double thisMonth
lastMonth
double lastMonth
fiscalYear
double fiscalYear
averagePerMonth
double averagePerMonth
Class bb.common.SalesInfoCenterResult extends java.lang.Object implements Serializable

Serialized Fields

currency
java.lang.String currency
currentMonthSalesOrderAccount
java.math.BigDecimal currentMonthSalesOrderAccount
lastMonthSalesOrderAccount
java.math.BigDecimal lastMonthSalesOrderAccount
fiscalYearSalesOrderAccount
java.math.BigDecimal fiscalYearSalesOrderAccount
eachMonthSalesOrderAvgAccount
java.math.BigDecimal eachMonthSalesOrderAvgAccount
currentMonthSalesOrderCount
java.lang.Integer currentMonthSalesOrderCount
lastMonthSalesOrderCount
java.lang.Integer lastMonthSalesOrderCount
fiscalYearSalesOrderCount
java.lang.Integer fiscalYearSalesOrderCount
eachMonthSalesOrderAvgCount
java.lang.Integer eachMonthSalesOrderAvgCount
currentMonthSalesItemCount
java.lang.Integer currentMonthSalesItemCount
lastMonthSalesItemCount
java.lang.Integer lastMonthSalesItemCount
fiscalYearSalesItemCount
java.lang.Integer fiscalYearSalesItemCount
eachMonthSalesItemAvgCount
java.lang.Integer eachMonthSalesItemAvgCount
openSalesAccount
java.math.BigDecimal openSalesAccount
pastDueSalesAccount
java.math.BigDecimal pastDueSalesAccount
pastDueSalesCount
java.lang.Integer pastDueSalesCount
salesCountWithPartOnHold
java.lang.Integer salesCountWithPartOnHold
currentMonthInvoicedAccount
java.math.BigDecimal currentMonthInvoicedAccount
lastMonthInvoiceAccount
java.math.BigDecimal lastMonthInvoiceAccount
fiscalYearInvoiceAccount
java.math.BigDecimal fiscalYearInvoiceAccount
eachMonthInvoiceAvgAccount
java.math.BigDecimal eachMonthInvoiceAvgAccount
currentMonthInvoiceGrossMargin
java.math.BigDecimal currentMonthInvoiceGrossMargin
lastMonthInvoiceGrossMargin
java.math.BigDecimal lastMonthInvoiceGrossMargin
fiscalYearInvoiceGrossMargin
java.math.BigDecimal fiscalYearInvoiceGrossMargin
eachMonthInvoiceAvgGrossMargin
java.math.BigDecimal eachMonthInvoiceAvgGrossMargin
lastFiscalYearInvoiceAccount
java.math.BigDecimal lastFiscalYearInvoiceAccount
lastFiscalYearSalesAccount
java.math.BigDecimal lastFiscalYearSalesAccount
dueOriginalPromiseSalesAccount
java.math.BigDecimal dueOriginalPromiseSalesAccount
lastTwevMonthsTotalSalesGrossMargin
java.math.BigDecimal lastTwevMonthsTotalSalesGrossMargin
Class bb.common.SalesmanVO extends VO implements Serializable

Serialized Fields

salesmanId
int salesmanId
identifier field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeTimes
java.lang.Integer lastChangeTimes
nullable persistent field

adate
java.util.Date adate
nullable persistent field

company
java.lang.String company
persistent field

level
java.lang.String level
persistent field

password
java.lang.String password
persistent field

userName
java.lang.String userName
persistent field

description
java.lang.String description
nullable persistent field

language
java.lang.String language
nullable persistent field

lastName
java.lang.String lastName
persistent field

firstName
java.lang.String firstName
persistent field

workAddress
java.lang.String workAddress
persistent field

homeAddress
java.lang.String homeAddress
persistent field

department
java.lang.String department
persistent field

startDate
java.util.Date startDate
nullable persistent field

phone
java.lang.String phone
nullable persistent field

phoneExtension
java.lang.String phoneExtension
nullable persistent field

email
java.lang.String email
nullable persistent field

picture
byte[] picture
nullable persistent field

extension
java.lang.String extension
nullable persistent field

jobId
java.lang.String jobId
persistent field

status
java.lang.String status
persistent field

securityLevel
java.lang.String securityLevel
persistent field

commission
java.math.BigDecimal commission
persistent field

address1
java.lang.String address1
persistent field

address2
java.lang.String address2
persistent field

city
java.lang.String city
persistent field

state
java.lang.String state
persistent field

zip
java.lang.String zip
persistent field

country
java.lang.String country
persistent field

homePhone
java.lang.String homePhone
persistent field

emergencyContact
java.lang.String emergencyContact
persistent field

wifeName
java.lang.String wifeName
persistent field

companyUnitId
java.lang.String companyUnitId
persistent field

comments
java.lang.String comments
lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

Class bb.common.SalesMarginListResult extends java.lang.Object implements Serializable

Serialized Fields

customerId
java.lang.String customerId
customerName
java.lang.String customerName
currency
java.lang.String currency
exchange
java.math.BigDecimal exchange
totalNet
java.math.BigDecimal totalNet
totalSales
java.math.BigDecimal totalSales
totalCost
java.math.BigDecimal totalCost
totalMargin
java.math.BigDecimal totalMargin
country
java.lang.String country
state
java.lang.String state
Class bb.common.SalesOnTimeResult extends java.lang.Object implements Serializable

Serialized Fields

currency
java.lang.String currency
day1
int day1
day2
int day2
items
java.util.List<E> items
Class bb.common.SalesOrder12MonthMarginResult extends java.lang.Object implements Serializable

Serialized Fields

part
BB2Part part
qty
java.math.BigDecimal qty
invoicedTotal
java.math.BigDecimal invoicedTotal
grossMargin
java.math.BigDecimal grossMargin
cost
java.math.BigDecimal cost
pctMargin
java.math.BigDecimal pctMargin
description
java.lang.String description
currency
java.lang.String currency
Class bb.common.SalesOrderBoilerplateVO extends VO implements Serializable

Serialized Fields

boilerplateId
java.lang.String boilerplateId
identifier field

description
java.lang.String description
persistent field

soBoilerplate
java.lang.String soBoilerplate
nullable persistent field

Class bb.common.SalesOrderCheckListResult extends java.lang.Object implements Serializable

Serialized Fields

soNumber
java.lang.String soNumber
customerId
java.lang.String customerId
salesMan
java.lang.String salesMan
soDate
java.util.Date soDate
status
java.lang.String status
arTotal
java.math.BigDecimal arTotal
currency
java.lang.String currency
customerName
java.lang.String customerName
salesManId
short salesManId
Class bb.common.SalesOrderDocumentVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
soNumber
java.lang.String soNumber
docDescription
java.lang.String docDescription
documentDate
java.util.Date documentDate
comments
java.lang.String comments
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
extension
java.lang.String extension
docFileName
java.lang.String docFileName
docLength
long docLength
Class bb.common.SalesOrderItemCostResult extends java.lang.Object implements Serializable

Serialized Fields

totalMoney
java.math.BigDecimal totalMoney
currency
java.lang.String currency
listPrice
java.math.BigDecimal listPrice
stdCost
java.math.BigDecimal stdCost
avgCost
java.math.BigDecimal avgCost
numOfMissingItems
int numOfMissingItems
lowestCost
java.math.BigDecimal lowestCost
averageCost
java.math.BigDecimal averageCost
highestCost
java.math.BigDecimal highestCost
Class bb.common.SalesOrderItemCustomerTotalResult extends java.lang.Object implements Serializable

Serialized Fields

customerId
java.lang.String customerId
name
java.lang.String name
currency
java.lang.String currency
total
java.math.BigDecimal total
numOfItems
int numOfItems
Class bb.common.SalesOrderItemGroupByPartListResult extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
description
java.lang.String description
commodityCode
java.lang.String commodityCode
quantityOrdered
java.math.BigDecimal quantityOrdered
onhand
java.math.BigDecimal onhand
onOrder
java.math.BigDecimal onOrder
quantityShipped
java.math.BigDecimal quantityShipped
onDemand
java.math.BigDecimal onDemand
onDemandInSO
java.math.BigDecimal onDemandInSO
inSIP
java.math.BigDecimal inSIP
inSIPInSO
java.math.BigDecimal inSIPInSO
notShippedQty
java.math.BigDecimal notShippedQty
shippedQty
java.math.BigDecimal shippedQty
Class bb.common.SalesOrderItemInfoVO extends VO implements Serializable

Serialized Fields

pk
SalesOrderItemPK pk
accountReceivableSub
java.math.BigDecimal accountReceivableSub
accountReceivableDiscount
java.math.BigDecimal accountReceivableDiscount
extendPrice
java.math.BigDecimal extendPrice
accountReceivableShip
java.math.BigDecimal accountReceivableShip
accountReceivableOpen
java.math.BigDecimal accountReceivableOpen
accountReceivableTax
java.math.BigDecimal accountReceivableTax
arTotal
java.math.BigDecimal arTotal
referenceDoc1
java.lang.String referenceDoc1
referenceDoc2
java.lang.String referenceDoc2
changeOrder
java.lang.String changeOrder
qr
java.lang.String qr
status
java.lang.String status
shippingStatus
java.lang.String shippingStatus
deliveryDate
java.util.Date deliveryDate
desiredDate
java.util.Date desiredDate
delayDays
int delayDays
priority
java.lang.String priority
original
java.util.Date original
actual
java.util.Date actual
locate
java.lang.String locate
shipVia
java.lang.String shipVia
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
modelNumber
java.lang.String modelNumber
revision
java.lang.String revision
dwg
java.lang.String dwg
quantityOrdered
java.math.BigDecimal quantityOrdered
sipQty
java.math.BigDecimal sipQty
quantityShipped
java.math.BigDecimal quantityShipped
hqa
java.math.BigDecimal hqa
cost
java.math.BigDecimal cost
unit
java.lang.String unit
pricePerUnit
java.math.BigDecimal pricePerUnit
discountCode
java.lang.String discountCode
discount
java.math.BigDecimal discount
taxRate
java.math.BigDecimal taxRate
salesItemDescription
java.lang.String salesItemDescription
mfg
java.lang.String mfg
mpn
java.lang.String mpn
salesOrderItemComments
java.lang.String salesOrderItemComments
salesOrderItemPrivateNotes
java.lang.String salesOrderItemPrivateNotes
version
java.lang.Integer version
Class bb.common.SalesOrderItemListResult extends java.lang.Object implements Serializable

Serialized Fields

soNumber
java.lang.String soNumber
soItemNumber
java.lang.String soItemNumber
partPk
PartPK partPk
productCode
java.lang.String productCode
projectName
java.lang.String projectName
itemDescription
java.lang.String itemDescription
soDate
java.util.Date soDate
deliveryDate
java.util.Date deliveryDate
arriveDate
java.util.Date arriveDate
delayDays
int delayDays
orderedQty
java.math.BigDecimal orderedQty
shippedQty
java.math.BigDecimal shippedQty
soSipQty
java.math.BigDecimal soSipQty
pricePerUnit
java.math.BigDecimal pricePerUnit
discount
java.math.BigDecimal discount
customerId
java.lang.String customerId
customerPo
java.lang.String customerPo
salesman
java.lang.String salesman
salesCodeId
java.lang.String salesCodeId
shipVia
java.lang.String shipVia
status
java.lang.String status
onHandQty
java.math.BigDecimal onHandQty
onOrderQty
java.math.BigDecimal onOrderQty
onDemandQty
java.math.BigDecimal onDemandQty
partFrom
java.lang.String partFrom
unit
java.lang.String unit
sipQty
java.math.BigDecimal sipQty
sitQty
java.math.BigDecimal sitQty
originalDelivery
java.util.Date originalDelivery
wipQty
java.math.BigDecimal wipQty
shortAgeQty
java.math.BigDecimal shortAgeQty
extendPrice
java.math.BigDecimal extendPrice
accountReceivableShip
java.math.BigDecimal accountReceivableShip
accountReceivableOpen
java.math.BigDecimal accountReceivableOpen
currency
java.lang.String currency
partOrAssy
java.lang.String partOrAssy
mpn
java.lang.String mpn
mfg
java.lang.String mfg
lastShippedDate
java.util.Date lastShippedDate
accountNumber
java.lang.String accountNumber
region
java.lang.String region
lastInvoiceNumber
java.lang.String lastInvoiceNumber
invoiceStatus
java.lang.String invoiceStatus
companyUnitId
java.lang.String companyUnitId
state
java.lang.String state
territory
java.lang.String territory
country
java.lang.String country
relatedDoc
java.lang.String relatedDoc
comment
java.lang.String comment
commodityCode
java.lang.String commodityCode
incotermPlacePort
java.lang.String incotermPlacePort
incoterm
java.lang.String incoterm
refDocOnes
java.util.Set<E> refDocOnes
refDocTwoes
java.util.Set<E> refDocTwoes
Class bb.common.SalesOrderItemManufacturerPK extends java.lang.Object implements Serializable

Serialized Fields

salesOrderNumber
java.lang.String salesOrderNumber
identifier field

salesOrderItemNumber
java.lang.String salesOrderItemNumber
identifier field

ii
java.lang.Short ii
identifier field

Class bb.common.SalesOrderItemManufacturerVO extends VO implements Serializable

Serialized Fields

pk
SalesOrderItemManufacturerPK pk
manufacturerName
java.lang.String manufacturerName
manufacturerPartNumber
java.lang.String manufacturerPartNumber
Class bb.common.SalesOrderItemPK extends java.lang.Object implements Serializable

Serialized Fields

salesOrderNumber
java.lang.String salesOrderNumber
identifier field

salesOrderItemNumber
java.lang.String salesOrderItemNumber
identifier field

Class bb.common.SalesOrderItemVO extends VO implements Serializable

Serialized Fields

pk
SalesOrderItemPK pk
accountReceivableSub
java.math.BigDecimal accountReceivableSub
accountReceivableDiscount
java.math.BigDecimal accountReceivableDiscount
extendPrice
java.math.BigDecimal extendPrice
accountReceivableShip
java.math.BigDecimal accountReceivableShip
accountReceivableOpen
java.math.BigDecimal accountReceivableOpen
accountReceivableTax
java.math.BigDecimal accountReceivableTax
arTotal
java.math.BigDecimal arTotal
margin
java.math.BigDecimal margin
marginPercent
java.math.BigDecimal marginPercent
marginByStdCost
java.math.BigDecimal marginByStdCost
marginPercentByStdCost
java.math.BigDecimal marginPercentByStdCost
referenceDoc1
java.lang.String referenceDoc1
referenceDoc2
java.lang.String referenceDoc2
changeOrder
java.lang.String changeOrder
qr
java.lang.String qr
status
java.lang.String status
shippingStatus
java.lang.String shippingStatus
deliveryDate
java.util.Date deliveryDate
desiredDate
java.util.Date desiredDate
delayDays
int delayDays
arriveDate
java.util.Date arriveDate
priority
java.lang.String priority
original
java.util.Date original
actual
java.util.Date actual
locate
java.lang.String locate
shipVia
java.lang.String shipVia
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
modelNumber
java.lang.String modelNumber
revision
java.lang.String revision
dwg
java.lang.String dwg
bill
java.lang.String bill
quantityOrdered
java.math.BigDecimal quantityOrdered
sipQty
java.math.BigDecimal sipQty
quantityShipped
java.math.BigDecimal quantityShipped
hqa
java.math.BigDecimal hqa
cost
java.math.BigDecimal cost
stdCost
java.math.BigDecimal stdCost
unit
java.lang.String unit
pricePerUnit
java.math.BigDecimal pricePerUnit
discountCode
java.lang.String discountCode
discount
java.math.BigDecimal discount
taxRate
java.math.BigDecimal taxRate
salesItemDescription
java.lang.String salesItemDescription
mfg
java.lang.String mfg
mpn
java.lang.String mpn
salesOrderItemComments
java.lang.String salesOrderItemComments
salesOrderItemPrivateNotes
java.lang.String salesOrderItemPrivateNotes
salesOrderItemManufacturer
java.util.Set<E> salesOrderItemManufacturer
version
java.lang.Integer version
refDocOnes
java.util.Set<E> refDocOnes
refDocTwoes
java.util.Set<E> refDocTwoes
traceable
java.lang.String traceable
traceableLevel
java.lang.Byte traceableLevel
productCode
java.lang.String productCode
commodityCode
java.lang.String commodityCode
arInvoiceNumber
java.lang.String arInvoiceNumber
costPerUnitWithTax
java.math.BigDecimal costPerUnitWithTax
usePriceWithTax
boolean usePriceWithTax
salesUnit
java.lang.String salesUnit
salesQty
java.math.BigDecimal salesQty
salesPrice
java.math.BigDecimal salesPrice
Class bb.common.SalesOrderListResult extends java.lang.Object implements Serializable

Serialized Fields

soNumber
java.lang.String soNumber
soDate
java.util.Date soDate
changeOrder
java.lang.String changeOrder
customerId
java.lang.String customerId
customerPo
java.lang.String customerPo
project
java.lang.String project
privateNote
java.lang.String privateNote
comments
java.lang.String comments
salesman
java.lang.String salesman
status
java.lang.String status
grantTotal
java.math.BigDecimal grantTotal
currency
java.lang.String currency
customerName
java.lang.String customerName
relatedDocument
java.lang.String relatedDocument
arPrepay
java.math.BigDecimal arPrepay
arPrepayGl
java.math.BigDecimal arPrepayGl
Class bb.common.SalesOrderOnDemandResult extends java.lang.Object implements Serializable

Serialized Fields

partPk
PartPK partPk
partFrom
java.lang.String partFrom
salesOrderItemPk
SalesOrderItemPK salesOrderItemPk
description
java.lang.String description
quantityOrdered
java.math.BigDecimal quantityOrdered
quantityShipped
java.math.BigDecimal quantityShipped
quantityOnDemand
java.math.BigDecimal quantityOnDemand
quantituInSip
java.math.BigDecimal quantituInSip
refDoc1
java.lang.String refDoc1
refDoc2
java.lang.String refDoc2
customerId
java.lang.String customerId
shipVia
java.lang.String shipVia
deliveryDate
java.util.Date deliveryDate
arriveDate
java.util.Date arriveDate
delayDays
int delayDays
customerPo
java.lang.String customerPo
locations
java.util.Map<K,V> locations
Class bb.common.SalesOrderOnTimeItemResult extends java.lang.Object implements Serializable

Serialized Fields

month
java.lang.String month
salesTotal
java.math.BigDecimal salesTotal
salesItemCount
int salesItemCount
salesMarginPct
java.math.BigDecimal salesMarginPct
shippedTotalOnTime
java.math.BigDecimal shippedTotalOnTime
shippedItemCount
int shippedItemCount
shippedMarginPct
java.math.BigDecimal shippedMarginPct
notShippedOnTimeQty
java.math.BigDecimal notShippedOnTimeQty
notShippedOnTimeTotal
java.math.BigDecimal notShippedOnTimeTotal
days
java.math.BigDecimal days
Class bb.common.SalesOrderOnTimeResult extends java.lang.Object implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

currency
java.lang.String currency
soDueTotalThisMonth
java.math.BigDecimal soDueTotalThisMonth
soDueItemsThisMonth
java.math.BigDecimal soDueItemsThisMonth
grossMarginPctThisMonth
java.math.BigDecimal grossMarginPctThisMonth
soShippedTotalOntimeThisMonth
java.math.BigDecimal soShippedTotalOntimeThisMonth
soShippedItemOntimeThisMonth
java.math.BigDecimal soShippedItemOntimeThisMonth
grossMarginShippedOnTimeThisMonth
java.math.BigDecimal grossMarginShippedOnTimeThisMonth
soDueTotalLastMonth
java.math.BigDecimal soDueTotalLastMonth
soDueItemsLastMonth
java.math.BigDecimal soDueItemsLastMonth
grossMarginPctLastMonth
java.math.BigDecimal grossMarginPctLastMonth
soShippedTotalOntimeLastMonth
java.math.BigDecimal soShippedTotalOntimeLastMonth
soShippedItemOntimeLastMonth
java.math.BigDecimal soShippedItemOntimeLastMonth
grossMarginShippedOnTimeLastMonth
java.math.BigDecimal grossMarginShippedOnTimeLastMonth
soDueTotalFysical
java.math.BigDecimal soDueTotalFysical
soDueItemsFysical
java.math.BigDecimal soDueItemsFysical
grossMarginPctFysical
java.math.BigDecimal grossMarginPctFysical
soShippedTotalOntimeFysical
java.math.BigDecimal soShippedTotalOntimeFysical
soShippedItemOntimeFysical
java.math.BigDecimal soShippedItemOntimeFysical
grossMarginShippedOnTimeFysical
java.math.BigDecimal grossMarginShippedOnTimeFysical
soDueTotalYtd
java.math.BigDecimal soDueTotalYtd
soDueItemsYtd
java.math.BigDecimal soDueItemsYtd
grossMarginPctYtd
java.math.BigDecimal grossMarginPctYtd
soShippedTotalOntimeYtd
java.math.BigDecimal soShippedTotalOntimeYtd
soShippedItemOntimeYtd
java.math.BigDecimal soShippedItemOntimeYtd
grossMarginShippedOnTimeYtd
java.math.BigDecimal grossMarginShippedOnTimeYtd
soDueTotal12MonthAvg
java.math.BigDecimal soDueTotal12MonthAvg
soDueItems12MonthAvg
java.math.BigDecimal soDueItems12MonthAvg
grossMarginPct12MonthAvg
java.math.BigDecimal grossMarginPct12MonthAvg
soShippedTotalOntime12MonthAvg
java.math.BigDecimal soShippedTotalOntime12MonthAvg
soShippedItemOntime12MonthAvg
java.math.BigDecimal soShippedItemOntime12MonthAvg
grossMarginShippedOnTime12MonthAvg
java.math.BigDecimal grossMarginShippedOnTime12MonthAvg
Class bb.common.SalesOrderOrphanedResult extends SalesOrderOnDemandResult implements Serializable

Serialized Fields

quantityNotShipped
java.math.BigDecimal quantityNotShipped
Class bb.common.SalesOrderReviewVO extends VO implements Serializable

Serialized Fields

employeeId
java.lang.String employeeId
identifier field

userName
java.lang.String userName
persistent field

reviewLimit
java.math.BigDecimal reviewLimit
persistent field

currency
java.lang.String currency
persistent field

canReviewOwnSalesOrder
java.lang.String canReviewOwnSalesOrder
persistent field

Class bb.common.SalesOrderShipDateListResult extends java.lang.Object implements Serializable

Serialized Fields

pk
SalesOrderItemPK pk
status
java.lang.String status
custID
java.lang.String custID
deliveryDate
java.util.Date deliveryDate
original
java.util.Date original
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
revision
java.lang.String revision
quantityOrdered
java.math.BigDecimal quantityOrdered
quantityShipped
java.math.BigDecimal quantityShipped
unit
java.lang.String unit
salesItemDescription
java.lang.String salesItemDescription
shippedDate
java.util.Date shippedDate
shipperNumber
java.lang.String shipperNumber
Class bb.common.SalesOrderVO extends VO implements Serializable

Serialized Fields

salesOrderNumber
java.lang.String salesOrderNumber
identifier field

lastUser
java.lang.String lastUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

adate
java.util.Date adate
nullable persistent field

origin
java.lang.String origin
persistent field

arNetSet
java.lang.String arNetSet
persistent field

arTaxSet
java.lang.String arTaxSet
persistent field

arSub
java.math.BigDecimal arSub
persistent field

totalDiscount
java.math.BigDecimal totalDiscount
persistent field

subTotal
java.math.BigDecimal subTotal
persistent field

arShip
java.math.BigDecimal arShip
persistent field

arOpen
java.math.BigDecimal arOpen
persistent field

totalTax
java.math.BigDecimal totalTax
persistent field

totalFreight
java.math.BigDecimal totalFreight
persistent field

grantTotal
java.math.BigDecimal grantTotal
persistent field

margin
java.math.BigDecimal margin
marginPercent
java.math.BigDecimal marginPercent
totalCost
java.math.BigDecimal totalCost
marginByStdCost
java.math.BigDecimal marginByStdCost
marginPercentByStdCost
java.math.BigDecimal marginPercentByStdCost
totalStdCost
java.math.BigDecimal totalStdCost
totalPaidInvoice
java.math.BigDecimal totalPaidInvoice
persistent field

arPaidGl
java.math.BigDecimal arPaidGl
persistent field

arGl1Recorded
java.math.BigDecimal arGl1Recorded
persistent field

arGl2Paid
java.math.BigDecimal arGl2Paid
persistent field

arpNumber
java.lang.String arpNumber
arPrepay
java.math.BigDecimal arPrepay
arPrepayDue
java.math.BigDecimal arPrepayDue
arPrepayGl
java.math.BigDecimal arPrepayGl
arPrepayApply
java.math.BigDecimal arPrepayApply
changeOrder
java.lang.String changeOrder
persistent field

customerId
java.lang.String customerId
persistent field

billToId
java.lang.String billToId
persistent field

customerPo
java.lang.String customerPo
persistent field

customerEmail
java.lang.String customerEmail
persistent field

contact
java.lang.String contact
persistent field

status
java.lang.String status
persistent field

shippingStatus
java.lang.String shippingStatus
reviewedDate
java.util.Date reviewedDate
reviewedBy
java.lang.String reviewedBy
persistent field

delivery
java.util.Date delivery
persistent field

desired
java.util.Date desired
persistent field

delay
byte delay
persistent field

priority
java.lang.String priority
persistent field

original
java.util.Date original
persistent field

actual
java.util.Date actual
persistent field

shipToId
java.lang.String shipToId
persistent field

shipVia
java.lang.String shipVia
persistent field

carrier
java.lang.String carrier
persistent field

carrierAccount
java.lang.String carrierAccount
persistent field

incoterm
java.lang.String incoterm
persistent field

incotermPlacePort
java.lang.String incotermPlacePort
persistent field

shipAccout
java.lang.String shipAccout
persistent field

locate
java.lang.String locate
persistent field

language
java.lang.String language
persistent field

currency
java.lang.String currency
persistent field

exchange
java.math.BigDecimal exchange
terms
java.lang.String terms
persistent field

salesOrderDate
java.util.Date salesOrderDate
persistent field

salesman
java.lang.String salesman
persistent field

salesmanId
short salesmanId
persistent field

salesCodeId
java.lang.String salesCodeId
quoteNumber
java.lang.String quoteNumber
persistent field

referenceSalesOrder
java.lang.String referenceSalesOrder
persistent field

requester
java.lang.String requester
persistent field

projectName
java.lang.String projectName
persistent field

relatedDocument
java.lang.String relatedDocument
persistent field

creditAccount
java.lang.String creditAccount
persistent field

bp
java.lang.String bp
persistent field

salesOrderBoilerplate
java.lang.String salesOrderBoilerplate
salesOrderComments
java.lang.String salesOrderComments
nullable persistent field

salesOrderPrivateNotes
java.lang.String salesOrderPrivateNotes
nullable persistent field

version
java.lang.Integer version
nullable persistent field

hold
boolean hold
opinion
java.lang.String opinion
customerAddressInfo
CustomerVendorAddressInfoVO customerAddressInfo
nullable persistent field

shipToAddressInfo
CustomerVendorAddressInfoVO shipToAddressInfo
nullable persistent field

billToAddressInfo
CustomerVendorAddressInfoVO billToAddressInfo
nullable persistent field

salesOrderItems
java.util.Set<E> salesOrderItems
persistent field

boilerplates
java.util.Set<E> boilerplates
salesOrderDocuments
java.util.Set<E> salesOrderDocuments
coComments
java.lang.String coComments
companyUnitId
java.lang.String companyUnitId
persistent field

byPos
boolean byPos
receiptNumber
java.lang.String receiptNumber
Class bb.common.SalesPartListItemResult extends java.lang.Object implements Serializable

Serialized Fields

billItemPk
BillItemPK billItemPk
billPartFrom
java.lang.String billPartFrom
quantity
java.math.BigDecimal quantity
partPk
PartPK partPk
partFrom
java.lang.String partFrom
revision
java.lang.String revision
unit
java.lang.String unit
description
java.lang.String description
Class bb.common.SalesPartListResult extends java.lang.Object implements Serializable

Serialized Fields

billPk
BillPK billPk
billPartFrom
java.lang.String billPartFrom
revision
java.lang.String revision
unit
java.lang.String unit
description
java.lang.String description
items
java.util.Set<E> items
Class bb.common.SalesTaxListResult extends java.lang.Object implements Serializable

Serialized Fields

invoiceNumber
java.lang.String invoiceNumber
salesOrderNumber
java.lang.String salesOrderNumber
invoiceItemNumber
java.lang.String invoiceItemNumber
dateShiped
java.util.Date dateShiped
dateInvoiced
java.util.Date dateInvoiced
payDate
java.util.Date payDate
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
description
java.lang.String description
customerId
java.lang.String customerId
qtyShiped
java.math.BigDecimal qtyShiped
subTotal
java.math.BigDecimal subTotal
discountTotal
java.math.BigDecimal discountTotal
tax
java.math.BigDecimal tax
grandTotal
java.math.BigDecimal grandTotal
amountPaid
java.math.BigDecimal amountPaid
subNetTotal
java.math.BigDecimal subNetTotal
Class bb.common.ScrapAssetAgent extends java.lang.Object implements Serializable

Serialized Fields

assetAccount
java.lang.String assetAccount
assetLiquidationAccount
java.lang.String assetLiquidationAccount
depricateAccount
java.lang.String depricateAccount
description
java.lang.String description
Class bb.common.ScrapReportVO extends VO implements Serializable

Serialized Fields

srNumber
java.lang.String srNumber
identifier field

ncrNumber
java.lang.String ncrNumber
persistent field

enterBy
java.lang.String enterBy
persistent field

srDate
java.util.Date srDate
nullable persistent field

approvalBy
java.lang.String approvalBy
nullable persistent field

approvalDate
java.util.Date approvalDate
nullable persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

lastChangeTimes
java.lang.Integer lastChangeTimes
nullable persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
persistent field

description
java.lang.String description
persistent field

scrapQty
java.math.BigDecimal scrapQty
persistent field

cost
java.math.BigDecimal cost
persistent field

totalCost
java.math.BigDecimal totalCost
persistent field

poNumber
java.lang.String poNumber
persistent field

woNumber
java.lang.String woNumber
persistent field

problemDescription
java.lang.String problemDescription
nullable persistent field

transactionNumber
java.lang.String transactionNumber
persistent field

debitAccount
java.lang.String debitAccount
persistent field

creditAccount
java.lang.String creditAccount
persistent field

status
java.lang.String status
persistent field

Class bb.common.SerialNumberItemPK extends java.lang.Object implements Serializable

Serialized Fields

commanyName
java.lang.String commanyName
identifier field

serialNumber
java.lang.String serialNumber
identifier field

serialNumberItemNumber
java.lang.String serialNumberItemNumber
identifier field

Class bb.common.SerialNumberItemResult extends java.lang.Object implements Serializable

Serialized Fields

itemNumber
java.lang.String itemNumber
serialNumber
java.lang.String serialNumber
companyName
java.lang.String companyName
control
java.lang.Integer control
description
java.lang.String description
part
BB2Part part
partDescription
java.lang.String partDescription
length
java.lang.Long length
Class bb.common.SerialNumberItemVO extends VO implements Serializable

Serialized Fields

pk
SerialNumberItemPK pk
certificateNumber
java.lang.String certificateNumber
Class bb.common.SerialNumberPK extends java.lang.Object implements Serializable

Serialized Fields

commanyName
java.lang.String commanyName
identifier field

serialNumber
java.lang.String serialNumber
identifier field

Class bb.common.SerialNumberResult extends java.lang.Object implements Serializable

Serialized Fields

serialNubmer
java.lang.String serialNubmer
companyName
java.lang.String companyName
description
java.lang.String description
partDescription
java.lang.String partDescription
control
java.lang.Integer control
part
BB2Part part
certificateDate
java.util.Date certificateDate
woNumber
java.lang.String woNumber
poNumber
java.lang.String poNumber
soNumber
java.lang.String soNumber
receNumber
java.lang.String receNumber
refNumber
java.lang.String refNumber
revision
java.lang.String revision
comments
java.lang.String comments
items
java.util.ArrayList<E> items
length
java.lang.Long length
Class bb.common.SerialNumberVO extends VO implements Serializable

Serialized Fields

pk
SerialNumberPK pk
identifier field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

version
java.lang.Integer version
nullable persistent field

serialNumberItems
java.util.Set<E> serialNumberItems
persistent field

Class bb.common.ServerAction extends java.lang.Object implements Serializable

Serialized Fields

id
java.lang.Object id
moduleName
java.lang.String moduleName
method
java.lang.String method
params
java.lang.Object[] params
paramTypes
java.lang.Class<T>[] paramTypes
orderBy
OrderBy orderBy
dynamicSearchFilter
DynamicSearchFilter dynamicSearchFilter
Class bb.common.ServerClientPropertyPK extends java.lang.Object implements Serializable

Serialized Fields

id
java.lang.String id
owner
java.lang.String owner
Class bb.common.ServerClientPropertyVO extends VO implements Serializable

Serialized Fields

pk
ServerClientPropertyPK pk
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
value
java.lang.String value
createDate
java.util.Date createDate
Class bb.common.ServerException extends java.lang.Exception implements Serializable

Serialized Fields

reason
java.lang.String reason
Class bb.common.SGBillItemPK extends java.lang.Object implements Serializable

Serialized Fields

billNumber
java.lang.String billNumber
identifier field

billType
java.lang.String billType
identifier field

itemNumber
java.lang.String itemNumber
identifier field

Class bb.common.SGBillItemVO extends VO implements Serializable

Serialized Fields

pk
SGBillItemPK pk
identifier field

bc
java.lang.String bc
persistent field

itemQty
java.math.BigDecimal itemQty
persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

Class bb.common.SGBOMItemResult extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
revision
java.lang.String revision
descripiton
java.lang.String descripiton
dwg
java.lang.String dwg
hasPicture
java.lang.String hasPicture
unit
java.lang.String unit
bill
java.lang.String bill
billItemNumber
java.lang.String billItemNumber
weight
float weight
weightUnit
java.lang.String weightUnit
volume
java.math.BigDecimal volume
volumeUnit
java.lang.String volumeUnit
onhand
java.math.BigDecimal onhand
qty
java.math.BigDecimal qty
Class bb.common.SGBOMResult extends java.lang.Object implements Serializable

Serialized Fields

bom
SGBOMItemResult bom
items
java.util.List<E> items
Class bb.common.SGCartCheckOutResult extends java.lang.Object implements Serializable

Serialized Fields

userEmail
java.lang.String userEmail
contactName
java.lang.String contactName
name
java.lang.String name
addr1
java.lang.String addr1
addr2
java.lang.String addr2
city
java.lang.String city
state
java.lang.String state
zip
java.lang.String zip
country
java.lang.String country
phone
java.lang.String phone
fax
java.lang.String fax
items
java.util.List<E> items
Class bb.common.SGCartLogin extends java.lang.Object implements Serializable

Serialized Fields

userEmail
java.lang.String userEmail
password
java.lang.String password
Class bb.common.SGClientAccountPK extends java.lang.Object implements Serializable

Serialized Fields

client
java.lang.String client
identifier field

user
java.lang.String user
identifier field

Class bb.common.SGClientAccountVO extends VO implements Serializable

Serialized Fields

pk
SGClientAccountPK pk
identifier field

password
java.lang.String password
persistent field

userName
java.lang.String userName
persistent field

userCompany
java.lang.String userCompany
nullable persistent field

level
java.lang.String level
persistent field

Class bb.common.SGClientLogin extends java.lang.Object implements Serializable

Serialized Fields

client
java.lang.String client
loginName
java.lang.String loginName
password
java.lang.String password
Class bb.common.SgClientProgramUserVO extends VO implements Serializable

Serialized Fields

userName
java.lang.String userName
identifier field

fullName
java.lang.String fullName
phone
java.lang.String phone
mobile
java.lang.String mobile
persistent field

fax
java.lang.String fax
persistent field

userEmail
java.lang.String userEmail
persistent field

custID
java.lang.String custID
password
java.lang.String password
persistent field

language
java.lang.String language
type
java.lang.String type
receiver
java.lang.String receiver
customerAddressInfo
CustomerVendorAddressInfoVO customerAddressInfo
Class bb.common.SGCompanyPK extends java.lang.Object implements Serializable

Serialized Fields

division
java.lang.String division
identifier field

client
java.lang.String client
identifier field

Class bb.common.SGCompanyVO extends VO implements Serializable

Serialized Fields

pk
SGCompanyPK pk
identifier field

lastUserName
java.lang.String lastUserName
nullable persistent field

lastChangeDate
java.util.Date lastChangeDate
persistent field

lastChangeTime
java.lang.Integer lastChangeTime
nullable persistent field

host
java.lang.String host
persistent field

home
java.lang.String home
persistent field

currency
java.lang.String currency
nullable persistent field

logo
java.lang.String logo
nullable persistent field

name
java.lang.String name
nullable persistent field

custRfqMailto
java.lang.String custRfqMailto
nullable persistent field

custSaleMailto
java.lang.String custSaleMailto
nullable persistent field

custQuotePriceMailto
java.lang.String custQuotePriceMailto
nullable persistent field

custQuoteMailto
java.lang.String custQuoteMailto
nullable persistent field

unixHome
java.lang.String unixHome
persistent field

gotoCatalog
java.lang.String gotoCatalog
persistent field

gotoManual
java.lang.String gotoManual
persistent field

gotoOverview
java.lang.String gotoOverview
persistent field

gotoPic
java.lang.String gotoPic
persistent field

gotoTechSheet
java.lang.String gotoTechSheet
persistent field

gotoTroubleshooting
java.lang.String gotoTroubleshooting
persistent field

poweredBy
java.lang.String poweredBy
persistent field

internalSalesMailto
java.lang.String internalSalesMailto
persistent field

testingMailto
java.lang.String testingMailto
persistent field

timezero
java.lang.String timezero
persistent field

Class bb.common.SGCustomerCatalogPK extends java.lang.Object implements Serializable

Serialized Fields

customer
java.lang.String customer
identifier field

partNumber
java.lang.String partNumber
identifier field

partType
java.lang.String partType
identifier field

partFrom
java.lang.String partFrom
identifier field

Class bb.common.SGCustomerCatalogVO extends VO implements Serializable

Serialized Fields

pk
SGCustomerCatalogPK pk
identifier field

comments
java.lang.String comments
persistent field

conditionDes
java.lang.String conditionDes
Class bb.common.SGCustomerServiceRequestVO extends VO implements Serializable

Serialized Fields

csrNumber
java.lang.String csrNumber
identifier field

serviceType
java.lang.String serviceType
persistent field

priority
java.lang.String priority
persistent field

custID
java.lang.String custID
persistent field

status
java.lang.String status
persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
persistent field

csrDate
java.util.Date csrDate
nullable persistent field

requestor
java.lang.String requestor
persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
nullable persistent field

revsion
java.lang.String revsion
persistent field

description
java.lang.String description
persistent field

salesOrderNumber
java.lang.String salesOrderNumber
persistent field

salesOrderItemNumber
java.lang.String salesOrderItemNumber
persistent field

serial
java.lang.String serial
persistent field

equipCondition
java.lang.String equipCondition
persistent field

reqDescription
java.lang.String reqDescription
nullable persistent field

requireDate
java.util.Date requireDate
nullable persistent field

location
java.lang.String location
persistent field

contact
java.lang.String contact
persistent field

phone
java.lang.String phone
persistent field

email
java.lang.String email
persistent field

disposalDescription
java.lang.String disposalDescription
nullable persistent field

disposalBy
java.lang.String disposalBy
persistent field

approved
java.util.Date approved
nullable persistent field

approvedBy
java.lang.String approvedBy
persistent field

csiNumber
java.lang.String csiNumber
persistent field

Class bb.common.SGCustRequestForQuoteItemPK extends java.lang.Object implements Serializable

Serialized Fields

crfqNumber
java.lang.String crfqNumber
identifier field

crfqItemNumber
java.lang.String crfqItemNumber
identifier field

Class bb.common.SGCustRequestForQuoteItemResult extends java.lang.Object implements Serializable

Serialized Fields

pk
SGCustRequestForQuoteItemPK pk
partNumber
java.lang.String partNumber
partType
java.lang.String partType
unit
java.lang.String unit
description
java.lang.String description
weightUnit
java.lang.String weightUnit
weight
java.math.BigDecimal weight
qty
java.math.BigDecimal qty
Class bb.common.SGCustRequestForQuoteItemVO extends VO implements Serializable

Serialized Fields

pk
SGCustRequestForQuoteItemPK pk
identifier field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

rev
java.lang.String rev
partFrom
java.lang.String partFrom
persistent field

qty
java.math.BigDecimal qty
nullable persistent field

description
java.lang.String description
itemComments
java.lang.String itemComments
requireDate
java.util.Date requireDate
Class bb.common.SGCustRequestForQuoteListResult extends java.lang.Object implements Serializable

Serialized Fields

crfqNumber
java.lang.String crfqNumber
userEmail
java.lang.String userEmail
contactName
java.lang.String contactName
custID
java.lang.String custID
name
java.lang.String name
addr1
java.lang.String addr1
addr2
java.lang.String addr2
city
java.lang.String city
state
java.lang.String state
zip
java.lang.String zip
country
java.lang.String country
language
java.lang.String language
currency
java.lang.String currency
phone
java.lang.String phone
fax
java.lang.String fax
comments
java.lang.String comments
quoteNumber
java.lang.String quoteNumber
crfqDate
java.util.Date crfqDate
Class bb.common.SGCustRequestForQuoteResult extends java.lang.Object implements Serializable

Serialized Fields

crfqNumber
java.lang.String crfqNumber
quoteNumber
java.lang.String quoteNumber
userEmail
java.lang.String userEmail
contactName
java.lang.String contactName
custID
java.lang.String custID
name
java.lang.String name
addr1
java.lang.String addr1
addr2
java.lang.String addr2
city
java.lang.String city
state
java.lang.String state
zip
java.lang.String zip
country
java.lang.String country
language
java.lang.String language
currency
java.lang.String currency
phone
java.lang.String phone
fax
java.lang.String fax
comments
java.lang.String comments
items
java.util.Set<E> items
Class bb.common.SGCustRequestForQuoteVO extends VO implements Serializable

Serialized Fields

crfqNumber
java.lang.String crfqNumber
identifier field

crfqDate
java.util.Date crfqDate
custID
java.lang.String custID
persistent field

contactName
java.lang.String contactName
persistent field

phone
java.lang.String phone
persistent field

mobile
java.lang.String mobile
persistent field

fax
java.lang.String fax
persistent field

userEmail
java.lang.String userEmail
persistent field

lastUserName
java.lang.String lastUserName
nullable persistent field

lastChangeDate
java.util.Date lastChangeDate
persistent field

division
java.lang.String division
persistent field

quoteNumber
java.lang.String quoteNumber
persistent field

client
java.lang.String client
persistent field

currency
java.lang.String currency
nullable persistent field

comments
java.lang.String comments
nullable persistent field

status
java.lang.String status
items
java.util.Set<E> items
persistent field

Class bb.common.SGDocPartPK extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
identifier field

language
java.lang.String language
identifier field

Class bb.common.SGDocPartVO extends VO implements Serializable

Serialized Fields

pk
SGDocPartPK pk
identifier field

lastUserName
java.lang.String lastUserName
nullable persistent field

lastChangeDate
java.util.Date lastChangeDate
persistent field

catTest
java.lang.String catTest
persistent field

catTestRv
java.lang.String catTestRv
persistent field

techSheet
java.lang.String techSheet
persistent field

techRev
java.lang.String techRev
persistent field

overview
java.lang.String overview
persistent field

overviewRev
java.lang.String overviewRev
persistent field

troubleshooting
java.lang.String troubleshooting
persistent field

troubleRev
java.lang.String troubleRev
persistent field

generalDocument
java.lang.String generalDocument
persistent field

generalDocumentRev
java.lang.String generalDocumentRev
persistent field

companyHomes
java.lang.String companyHomes
persistent field

companyHomesRev
java.lang.String companyHomesRev
persistent field

manual
java.lang.String manual
persistent field

manualRev
java.lang.String manualRev
persistent field

catalog
java.lang.String catalog
persistent field

catalogRev
java.lang.String catalogRev
persistent field

Class bb.common.SGDwgPicturePK extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
identifier field

language
java.lang.String language
identifier field

Class bb.common.SGDwgPictureVO extends VO implements Serializable

Serialized Fields

pk
SGDwgPicturePK pk
identifier field

lastUserName
java.lang.String lastUserName
persistent field

lastChangeDate
java.util.Date lastChangeDate
persistent field

picture
java.sql.Blob picture
nullable persistent field

extension
java.lang.String extension
persistent field

revision
java.lang.String revision
persistent field

Class bb.common.SGLogLoginVO extends VO implements Serializable

Serialized Fields

identifier
int identifier
identifier field

lastChangeDate
java.util.Date lastChangeDate
persistent field

lastChangeTime
java.util.Date lastChangeTime
persistent field

sessionId
java.lang.String sessionId
persistent field

division
java.lang.String division
persistent field

client
java.lang.String client
persistent field

userCompany
java.lang.String userCompany
persistent field

user
java.lang.String user
persistent field

userName
java.lang.String userName
persistent field

userIp
java.lang.String userIp
persistent field

userLanguage
java.lang.String userLanguage
persistent field

level
java.lang.String level
nullable persistent field

Class bb.common.SGPartCartAgent extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
partType
java.lang.String partType
qty
java.math.BigDecimal qty
Class bb.common.SGPartCatalogResult extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
partType
java.lang.String partType
name
java.lang.String name
catalog
java.lang.String catalog
commodityCode
java.lang.String commodityCode
revision
java.lang.String revision
revisionDate
java.util.Date revisionDate
drawing
java.lang.String drawing
havePicture
java.lang.String havePicture
bill
java.lang.String bill
weight
float weight
weightUnit
java.lang.String weightUnit
unit
java.lang.String unit
description
java.lang.String description
comments
java.lang.String comments
custID
java.lang.String custID
productCode
java.lang.String productCode
conditionDes
java.lang.String conditionDes
Class bb.common.SGPartDocFlagResult extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
language
java.lang.String language
techSheet
boolean techSheet
overview
boolean overview
troubleshooting
boolean troubleshooting
manual
boolean manual
Class bb.common.SGPartListItemResult extends java.lang.Object implements Serializable

Serialized Fields

billNumber
java.lang.String billNumber
billType
java.lang.String billType
itemNumber
java.lang.String itemNumber
partNumber
java.lang.String partNumber
partType
java.lang.String partType
unit
java.lang.String unit
description
java.lang.String description
qty
java.math.BigDecimal qty
picture
boolean picture
Class bb.common.SGPartListResult extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
partType
java.lang.String partType
unit
java.lang.String unit
description
java.lang.String description
qty
java.math.BigDecimal qty
picture
boolean picture
drawing
boolean drawing
docFlags
java.util.Set<E> docFlags
items
java.util.Set<E> items
Class bb.common.SGPicturePK extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
identifier field

width
java.lang.Short width
identifier field

height
java.lang.Short height
identifier field

Class bb.common.SGPictureVO extends VO implements Serializable

Serialized Fields

pk
SGPicturePK pk
identifier field

lastUserName
java.lang.String lastUserName
nullable persistent field

lastChangeDate
java.util.Date lastChangeDate
persistent field

picture
java.sql.Blob picture
nullable persistent field

extension
java.lang.String extension
persistent field

Class bb.common.SGQuoteAddressResult extends java.lang.Object implements Serializable

Serialized Fields

userEmail
java.lang.String userEmail
contactName
java.lang.String contactName
name
java.lang.String name
addr1
java.lang.String addr1
addr2
java.lang.String addr2
city
java.lang.String city
state
java.lang.String state
zip
java.lang.String zip
country
java.lang.String country
phone
java.lang.String phone
fax
java.lang.String fax
Class bb.common.SGQuoteAddressVO extends VO implements Serializable

Serialized Fields

userEmail
java.lang.String userEmail
identifier field

password
java.lang.String password
persistent field

level
java.lang.String level
persistent field

client
java.lang.String client
persistent field

division
java.lang.String division
persistent field

contactName
java.lang.String contactName
nullable persistent field

name
java.lang.String name
nullable persistent field

addr1
java.lang.String addr1
nullable persistent field

addr2
java.lang.String addr2
nullable persistent field

city
java.lang.String city
nullable persistent field

state
java.lang.String state
nullable persistent field

zip
java.lang.String zip
nullable persistent field

country
java.lang.String country
nullable persistent field

language
java.lang.String language
nullable persistent field

currency
java.lang.String currency
nullable persistent field

countryCode
java.lang.String countryCode
nullable persistent field

phone
java.lang.String phone
nullable persistent field

fax
java.lang.String fax
nullable persistent field

Class bb.common.SGQuoteCartListResult extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
partType
java.lang.String partType
unit
java.lang.String unit
description
java.lang.String description
weightUnit
java.lang.String weightUnit
weight
java.lang.Float weight
qty
java.math.BigDecimal qty
Class bb.common.SGQuoteCartVO extends VO implements Serializable

Serialized Fields

identifer
int identifer
identifier field

userEmail
java.lang.String userEmail
persistent field

weightUnit
java.lang.String weightUnit
persistent field

lastChangeDate
java.util.Date lastChangeDate
persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

qty
java.math.BigDecimal qty
nullable persistent field

Class bb.common.SGQuoteLoginVO extends VO implements Serializable

Serialized Fields

identifier
int identifier
identifier field

userEmail
java.lang.String userEmail
persistent field

lastChangeDate
java.util.Date lastChangeDate
persistent field

sessionId
java.lang.String sessionId
persistent field

division
java.lang.String division
persistent field

client
java.lang.String client
persistent field

userIp
java.lang.String userIp
persistent field

level
java.lang.String level
nullable persistent field

referer
java.lang.String referer
nullable persistent field

Class bb.common.SGSaleItemAgent extends java.lang.Object implements Serializable

Serialized Fields

salesOrderNumber
java.lang.String salesOrderNumber
salesOrderItemNumber
java.lang.String salesOrderItemNumber
quantity
java.math.BigDecimal quantity
serialNumber
java.lang.String serialNumber
Class bb.common.SGSaleItemVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
custID
java.lang.String custID
persistent field

salesOrderNumber
java.lang.String salesOrderNumber
persistent field

salesOrderItemNumber
java.lang.String salesOrderItemNumber
persistent field

workOrderNumber
java.lang.String workOrderNumber
persistent field

workOrderItemNumber
java.lang.String workOrderItemNumber
persistent field

custPONumber
java.lang.String custPONumber
persistent field

dateShipped
java.util.Date dateShipped
persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
persistent field

catalog
java.lang.String catalog
persistent field

modelNumber
java.lang.String modelNumber
persistent field

revision
java.lang.String revision
persistent field

quantity
java.math.BigDecimal quantity
persistent field

unit
java.lang.String unit
persistent field

description
java.lang.String description
persistent field

mfg
java.lang.String mfg
persistent field

mpn
java.lang.String mpn
persistent field

serialNumber
java.lang.String serialNumber
persistent field

comments
java.lang.String comments
persistent field

bb2HavePic
java.lang.String bb2HavePic
bb2HaveSalesDwg
java.lang.String bb2HaveSalesDwg
Class bb.common.SGWeightUnitVO extends VO implements Serializable

Serialized Fields

weightUnit
java.lang.String weightUnit
identifier field

kg
double kg
persistent field

lbs
double lbs
persistent field

Class bb.common.ShareHoldersEquityResult extends java.lang.Object implements Serializable

Serialized Fields

accountNumber
java.lang.String accountNumber
debitOrCredit
java.lang.String debitOrCredit
accountDescription
java.lang.String accountDescription
amount
java.math.BigDecimal amount
Class bb.common.ShipListAgent extends java.lang.Object implements Serializable

Serialized Fields

ownerName
java.lang.String ownerName
newShipListDescription
java.lang.String newShipListDescription
byShipTOID
boolean byShipTOID
startDate
java.util.Date startDate
endDate
java.util.Date endDate
salesOrderSet
java.util.Set<E> salesOrderSet
customerSet
java.util.Set<E> customerSet
vendorSet
java.util.Set<E> vendorSet
workCenterSet
java.util.Set<E> workCenterSet
Class bb.common.ShipListInfoVO extends VO implements Serializable

Serialized Fields

shipList
java.lang.String shipList
ownerName
java.lang.String ownerName
persistent field

lastUser
java.lang.String lastUser
nullable persistent field

lastCahgeDate
java.util.Date lastCahgeDate
nullable persistent field

lastChangeTimes
int lastChangeTimes
persistent field

date1
java.util.Date date1
persistent field

date2
java.util.Date date2
persistent field

description
java.lang.String description
persistent field

comments
java.lang.String comments
persistent field

status
java.lang.String status
persistent field

customerId
java.lang.String customerId
persistent field

Class bb.common.ShipListItemPK extends java.lang.Object implements Serializable

Serialized Fields

shipListNumber
java.lang.String shipListNumber
identifier field

salesOrderNumber
java.lang.String salesOrderNumber
identifier field

salesOrderItemNumber
java.lang.String salesOrderItemNumber
identifier field

Class bb.common.ShipListItemRelatedDocResult extends java.lang.Object implements Serializable

Serialized Fields

pk
SalesOrderItemPK pk
part
BB2Part part
description
java.lang.String description
qty
java.math.BigDecimal qty
deliveryDate
java.util.Date deliveryDate
onhand
java.math.BigDecimal onhand
items
java.util.ArrayList<E> items
Class bb.common.ShipListItemVO extends VO implements Serializable

Serialized Fields

pk
ShipListItemPK pk
identifier field

status
java.lang.String status
persistent field

comments
java.lang.String comments
persistent field

Class bb.common.ShipListItemVOResult extends ShipListItemVO implements Serializable

Serialized Fields

pk
ShipListItemPK pk
identifier field

salesOrderNumber
java.lang.String salesOrderNumber
salesOrderItemNumber
java.lang.String salesOrderItemNumber
custId
java.lang.String custId
shipTo
java.lang.String shipTo
dateRequited
java.util.Date dateRequited
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
description
java.lang.String description
requiredQty
java.math.BigDecimal requiredQty
shipVia
java.lang.String shipVia
soComments
java.lang.String soComments
totalOndemand
java.math.BigDecimal totalOndemand
totalOnhand
java.math.BigDecimal totalOnhand
partLocations
java.util.Set<E> partLocations
VendorItems
java.util.Set<E> VendorItems
customerPo
java.lang.String customerPo
shippingWeight
java.lang.String shippingWeight
Class bb.common.ShipListOwnerAttributePK extends java.lang.Object implements Serializable

Serialized Fields

ownerName
java.lang.String ownerName
identifier field

ii
java.lang.Byte ii
identifier field

Class bb.common.ShipListOwnerAttributeVO extends VO implements Serializable

Serialized Fields

pk
ShipListOwnerAttributePK pk
vendorId
java.lang.String vendorId
persistent field

workCenterId
java.lang.String workCenterId
persistent field

customerId
java.lang.String customerId
persistent field

shipListOwner
ShipListOwnerVO shipListOwner
nullable persistent field

Class bb.common.ShipListOwnerVO extends VO implements Serializable

Serialized Fields

ownerName
java.lang.String ownerName
identifier field

lastChangeUser
java.lang.String lastChangeUser
nullable persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

version
java.lang.Integer version
nullable persistent field

description
java.lang.String description
nullable persistent field

shipListOwnerAttributes
java.util.Set<E> shipListOwnerAttributes
persistent field

Class bb.common.ShipListVO extends VO implements Serializable

Serialized Fields

shipList
java.lang.String shipList
identifier field

ownerName
java.lang.String ownerName
persistent field

lastUser
java.lang.String lastUser
nullable persistent field

lastCahgeDate
java.util.Date lastCahgeDate
nullable persistent field

version
java.lang.Integer version
persistent field

date1
java.util.Date date1
persistent field

date2
java.util.Date date2
persistent field

description
java.lang.String description
persistent field

comments
java.lang.String comments
persistent field

status
java.lang.String status
persistent field

customerId
java.lang.String customerId
persistent field

shipListItems
java.util.Set<E> shipListItems
persistent field

Class bb.common.ShipperAgent extends java.lang.Object implements Serializable

Serialized Fields

orderNumber
java.lang.String orderNumber
tracking
java.lang.String tracking
freightRateCode
java.lang.String freightRateCode
grossWeight
java.lang.String grossWeight
arFreight
java.math.BigDecimal arFreight
carrier
java.lang.String carrier
items
java.util.Set<E> items
shipVia
java.lang.String shipVia
totPackingBoxNumber
int totPackingBoxNumber
Class bb.common.ShipperInfoVO extends VO implements Serializable

Serialized Fields

shipperNumber
java.lang.String shipperNumber
salesOrderNumber
java.lang.String salesOrderNumber
arInvoiceNumber
java.lang.String arInvoiceNumber
customerId
java.lang.String customerId
billToId
java.lang.String billToId
customerPo
java.lang.String customerPo
lastChangeUser
java.lang.String lastChangeUser
lastChangedate
java.util.Date lastChangedate
adate
java.util.Date adate
origin
java.lang.String origin
arSub
java.math.BigDecimal arSub
arShip
java.math.BigDecimal arShip
arOpen
java.math.BigDecimal arOpen
arDiscount
java.math.BigDecimal arDiscount
arNet
java.math.BigDecimal arNet
arTax
java.math.BigDecimal arTax
arFreight
java.math.BigDecimal arFreight
arTotal
java.math.BigDecimal arTotal
arPaidInvoice
java.math.BigDecimal arPaidInvoice
arPaidGl
java.math.BigDecimal arPaidGl
arGl1Recorded
java.math.BigDecimal arGl1Recorded
arGl2Paid
java.math.BigDecimal arGl2Paid
changeOrder
java.lang.String changeOrder
status
java.lang.String status
salesman
java.lang.String salesman
shippedDate
java.util.Date shippedDate
shippedBy
java.lang.String shippedBy
invoicedDate
java.util.Date invoicedDate
invoicedBy
java.lang.String invoicedBy
shipToId
java.lang.String shipToId
remitId
java.lang.String remitId
shipVia
java.lang.String shipVia
carrier
java.lang.String carrier
carrierAccount
java.lang.String carrierAccount
freightRateCode
java.lang.String freightRateCode
grossWeight
java.lang.String grossWeight
tracking
java.lang.String tracking
incoterm
java.lang.String incoterm
incotermPlacePort
java.lang.String incotermPlacePort
dateShipped
java.util.Date dateShipped
dateInvoiced
java.util.Date dateInvoiced
freightBill
java.lang.String freightBill
currency
java.lang.String currency
language
java.lang.String language
terms
java.lang.String terms
relatedDoc
java.lang.String relatedDoc
DebitAccount
java.lang.String DebitAccount
bp
java.lang.String bp
shipperComments
java.lang.String shipperComments
shipperPrivateNotes
java.lang.String shipperPrivateNotes
due
java.math.BigDecimal due
payDate
java.util.Date payDate
datePaid
java.util.Date datePaid
checkNumber
java.lang.String checkNumber
paid
java.math.BigDecimal paid
oTran
java.lang.String oTran
rTran
java.lang.String rTran
shipToAddressInfo
CustomerVendorAddressInfoVO shipToAddressInfo
billToAddressInfo
CustomerVendorAddressInfoVO billToAddressInfo
Class bb.common.ShipperItemAgent extends java.lang.Object implements Serializable

Serialized Fields

itemNumber
java.lang.String itemNumber
comment
java.lang.String comment
totalShippedQty
java.math.BigDecimal totalShippedQty
avgCost
java.math.BigDecimal avgCost
shipperItemDetails
java.util.Set<E> shipperItemDetails
serial
java.lang.String serial
shipperNumber
java.lang.String shipperNumber
Class bb.common.ShipperItemDetailAgent extends java.lang.Object implements Serializable

Serialized Fields

issuedFrom
java.lang.String issuedFrom
ShipperItemDetailAgent: describe the details how to ship the material

locate
java.lang.String locate
shippedQty
java.math.BigDecimal shippedQty
cost
java.math.BigDecimal cost
boxNumber
int boxNumber
ofBoxNumber
int ofBoxNumber
ncrNumber
java.lang.String ncrNumber
partInQAII
int partInQAII
trackingLog
java.util.Set<E> trackingLog
Class bb.common.ShipperItemListResult extends java.lang.Object implements Serializable

Serialized Fields

shipperNumber
java.lang.String shipperNumber
shipperItemNumber
java.lang.String shipperItemNumber
arInvoiceNumber
java.lang.String arInvoiceNumber
salesOrderNumber
java.lang.String salesOrderNumber
salesOrderItemNumber
java.lang.String salesOrderItemNumber
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
description
java.lang.String description
serialNumber
java.lang.String serialNumber
quantity
java.math.BigDecimal quantity
quantityShip
java.math.BigDecimal quantityShip
totalQtyShip
java.math.BigDecimal totalQtyShip
customerId
java.lang.String customerId
customerName
java.lang.String customerName
dateShipped
java.util.Date dateShipped
listPrice
java.math.BigDecimal listPrice
status
java.lang.String status
accountNumber
java.lang.String accountNumber
companyUnitId
java.lang.String companyUnitId
taxRate
java.math.BigDecimal taxRate
discRate
java.math.BigDecimal discRate
extPrice
java.math.BigDecimal extPrice
currency
java.lang.String currency
location
java.lang.String location
averageCost
java.math.BigDecimal averageCost
project
java.lang.String project
deliveryDate
java.util.Date deliveryDate
locations
java.util.Map<K,V> locations
Class bb.common.ShipperItemManufacturerPK extends java.lang.Object implements Serializable

Serialized Fields

shipperNumber
java.lang.String shipperNumber
salesOrderItemNumber
java.lang.String salesOrderItemNumber
ii
java.lang.Short ii
Class bb.common.ShipperItemManufacturerVO extends VO implements Serializable

Serialized Fields

pk
ShipperItemManufacturerPK pk
manufacturerName
java.lang.String manufacturerName
manufacturerPartNumber
java.lang.String manufacturerPartNumber
Class bb.common.ShipperItemPK extends java.lang.Object implements Serializable

Serialized Fields

shipperNumber
java.lang.String shipperNumber
shipperItemNumber
java.lang.String shipperItemNumber
Class bb.common.ShipperItemVO extends VO implements Serializable

Serialized Fields

pk
ShipperItemPK pk
salesOrder
java.lang.String salesOrder
arSub
java.math.BigDecimal arSub
arShip
java.math.BigDecimal arShip
arOpen
java.math.BigDecimal arOpen
arDiscount
java.math.BigDecimal arDiscount
arNet
java.math.BigDecimal arNet
arTax
java.math.BigDecimal arTax
arTotal
java.math.BigDecimal arTotal
due
java.math.BigDecimal due
paid
java.math.BigDecimal paid
datePaid
java.util.Date datePaid
checkNumber
java.lang.String checkNumber
referenceDoc1
java.lang.String referenceDoc1
referenceDoc2
java.lang.String referenceDoc2
dateShipped
java.util.Date dateShipped
dateInvoiced
java.util.Date dateInvoiced
shipVia
java.lang.String shipVia
shipToId
java.lang.String shipToId
status
java.lang.String status
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
modelNumber
java.lang.String modelNumber
revision
java.lang.String revision
location
java.lang.String location
soQuantity
java.math.BigDecimal soQuantity
bb2SoShippedQty
java.math.BigDecimal bb2SoShippedQty
bb2BackOrderQty
java.math.BigDecimal bb2BackOrderQty
quantityShip
java.math.BigDecimal quantityShip
listPrice
java.math.BigDecimal listPrice
averageCost
java.math.BigDecimal averageCost
stdCost
java.math.BigDecimal stdCost
unit
java.lang.String unit
discount
java.math.BigDecimal discount
taxRate
java.math.BigDecimal taxRate
description
java.lang.String description
mfg
java.lang.String mfg
mpn
java.lang.String mpn
invoiceNumber
java.lang.String invoiceNumber
serialNumber
java.lang.String serialNumber
shipperItemComments
java.lang.String shipperItemComments
shipperItemPrivateNotes
java.lang.String shipperItemPrivateNotes
refDocTwoes
java.util.Set<E> refDocTwoes
refDocOnes
java.util.Set<E> refDocOnes
shipperItemManufacturer
java.util.Set<E> shipperItemManufacturer
glNumber
java.lang.String glNumber
offsetUnbilledGLNumber
java.lang.String offsetUnbilledGLNumber
unbilledExchange
java.math.BigDecimal unbilledExchange
productCode
java.lang.String productCode
locations
java.util.Map<K,V> locations
trackings
java.util.Map<K,V> trackings
Class bb.common.ShipperListResult extends java.lang.Object implements Serializable

Serialized Fields

shipperNumber
java.lang.String shipperNumber
shipperDate
java.util.Date shipperDate
customerId
java.lang.String customerId
salesOrderNumber
java.lang.String salesOrderNumber
salesman
java.lang.String salesman
comments
java.lang.String comments
status
java.lang.String status
customerName
java.lang.String customerName
changeOrder
java.lang.String changeOrder
Class bb.common.ShipperVO extends VO implements Serializable

Serialized Fields

shipperNumber
java.lang.String shipperNumber
salesOrderNumber
java.lang.String salesOrderNumber
arInvoiceNumber
java.lang.String arInvoiceNumber
pfInvoiceNumber
java.lang.String pfInvoiceNumber
customerId
java.lang.String customerId
batch
java.lang.String batch
billToId
java.lang.String billToId
customerPo
java.lang.String customerPo
lastChangeUser
java.lang.String lastChangeUser
lastChangedate
java.util.Date lastChangedate
adate
java.util.Date adate
origin
java.lang.String origin
arNetSet
java.lang.String arNetSet
arTaxSet
java.lang.String arTaxSet
arSub
java.math.BigDecimal arSub
arShip
java.math.BigDecimal arShip
arOpen
java.math.BigDecimal arOpen
arDiscount
java.math.BigDecimal arDiscount
arNet
java.math.BigDecimal arNet
arTax
java.math.BigDecimal arTax
arFreight
java.math.BigDecimal arFreight
arTotal
java.math.BigDecimal arTotal
arPaidInvoice
java.math.BigDecimal arPaidInvoice
arPaidGl
java.math.BigDecimal arPaidGl
arGl1Recorded
java.math.BigDecimal arGl1Recorded
arGl2Paid
java.math.BigDecimal arGl2Paid
changeOrder
java.lang.String changeOrder
status
java.lang.String status
salesman
java.lang.String salesman
shippedDate
java.util.Date shippedDate
shippedBy
java.lang.String shippedBy
invoicedDate
java.util.Date invoicedDate
invoicedBy
java.lang.String invoicedBy
shipToId
java.lang.String shipToId
remitId
java.lang.String remitId
shipVia
java.lang.String shipVia
carrier
java.lang.String carrier
carrierAccount
java.lang.String carrierAccount
freightRateCode
java.lang.String freightRateCode
grossWeight
java.lang.String grossWeight
tracking
java.lang.String tracking
incoterm
java.lang.String incoterm
incotermPlacePort
java.lang.String incotermPlacePort
dateShipped
java.util.Date dateShipped
dateInvoiced
java.util.Date dateInvoiced
freightBill
java.lang.String freightBill
currency
java.lang.String currency
language
java.lang.String language
terms
java.lang.String terms
relatedDoc
java.lang.String relatedDoc
DebitAccount
java.lang.String DebitAccount
bp
java.lang.String bp
shipperBp
java.lang.String shipperBp
shipperComments
java.lang.String shipperComments
shipperPrivateNotes
java.lang.String shipperPrivateNotes
due
java.math.BigDecimal due
payDate
java.util.Date payDate
datePaid
java.util.Date datePaid
checkNumber
java.lang.String checkNumber
paid
java.math.BigDecimal paid
oTran
java.lang.String oTran
rTran
java.lang.String rTran
companyUnitId
java.lang.String companyUnitId
lastChangeTime
int lastChangeTime
project
java.lang.String project
customerAddressInfo
CustomerVendorAddressInfoVO customerAddressInfo
shipToAddressInfo
CustomerVendorAddressInfoVO shipToAddressInfo
billToAddressInfo
CustomerVendorAddressInfoVO billToAddressInfo
shipperItems
java.util.Set<E> shipperItems
coComments
java.lang.String coComments
Class bb.common.ShippingItemResult extends java.lang.Object implements Serializable

Serialized Fields

orderNumber
java.lang.String orderNumber
itemNumber
java.lang.String itemNumber
partPk
PartPK partPk
partFrom
java.lang.String partFrom
revision
java.lang.String revision
drawing
java.lang.String drawing
description
java.lang.String description
traceable
boolean traceable
quantity
java.math.BigDecimal quantity
quantityShip
java.math.BigDecimal quantityShip
unit
java.lang.String unit
mfg
java.lang.String mfg
mpn
java.lang.String mpn
comments
java.lang.String comments
privateNotes
java.lang.String privateNotes
refDoc1
java.lang.String refDoc1
refDoc2
java.lang.String refDoc2
ncrNumber
java.lang.String ncrNumber
onhand
java.math.BigDecimal onhand
status
java.lang.String status
shipDate
java.util.Date shipDate
partOnhandLocations
java.util.Set<E> partOnhandLocations
othersLocations
java.util.Set<E> othersLocations
partTracking
java.util.Set<E> partTracking
quantitySip
java.math.BigDecimal quantitySip
avgCost
java.math.BigDecimal avgCost
demand
java.math.BigDecimal demand
poUnit
java.lang.String poUnit
poUnitQty
java.math.BigDecimal poUnitQty
Class bb.common.ShippingResult extends java.lang.Object implements Serializable

Serialized Fields

orderNumber
java.lang.String orderNumber
changOrder
java.lang.String changOrder
customerId
java.lang.String customerId
customerName
java.lang.String customerName
incoterm
java.lang.String incoterm
placePort
java.lang.String placePort
freight
java.math.BigDecimal freight
arPrepayGl
java.math.BigDecimal arPrepayGl
arPrepay
java.math.BigDecimal arPrepay
hold
boolean hold
shippingItems
java.util.Set<E> shippingItems
Class bb.common.ShoppingCartItem extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
rev
java.lang.String rev
quantity
java.math.BigDecimal quantity
dateRequired
java.util.Date dateRequired
description
java.lang.String description
Class bb.common.SmtpServerVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Short ii
identifier field

host
java.lang.String host
persistent field

port
int port
persistent field

displayName
java.lang.String displayName
persistent field

requireAuth
boolean requireAuth
persistent field

userName
java.lang.String userName
persistent field

password
java.lang.String password
persistent field

comments
java.lang.String comments
sendFrom
java.lang.String sendFrom
Class bb.common.SO2POAgent extends java.lang.Object implements Serializable

Serialized Fields

soNumber
java.lang.String soNumber
vendorId
java.lang.String vendorId
includeMPNs
boolean includeMPNs
shipVia
java.lang.String shipVia
Class bb.common.SO2SOAgent extends java.lang.Object implements Serializable

Serialized Fields

soNumber
java.lang.String soNumber
customerId
java.lang.String customerId
billToId
java.lang.String billToId
shipToId
java.lang.String shipToId
customerPo
java.lang.String customerPo
contact
java.lang.String contact
shipDate
java.util.Date shipDate
arriveDate
java.util.Date arriveDate
originalDate
java.util.Date originalDate
delayDays
int delayDays
Class bb.common.SO2WOAgent extends java.lang.Object implements Serializable

Serialized Fields

soNumber
java.lang.String soNumber
vendorId
java.lang.String vendorId
isCopyMpn
boolean isCopyMpn
Class bb.common.SoPickListResult extends java.lang.Object implements Serializable

Serialized Fields

salesOrderNumber
java.lang.String salesOrderNumber
status
java.lang.String status
items
java.util.Set<E> items
Class bb.common.SOShipperItemListResult extends java.lang.Object implements Serializable

Serialized Fields

shipperItemPk
ShipperItemPK shipperItemPk
salesOrderNumber
java.lang.String salesOrderNumber
soQuantity
java.math.BigDecimal soQuantity
quantityShipped
java.math.BigDecimal quantityShipped
dateShipped
java.util.Date dateShipped
invoiceNumber
java.lang.String invoiceNumber
dateInvoiced
java.util.Date dateInvoiced
status
java.lang.String status
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partDescription
java.lang.String partDescription
Class bb.common.StaffWorkingInformationResult extends java.lang.Object implements Serializable

Serialized Fields

staff
java.lang.String staff
working
boolean working
workingInfo
java.lang.String workingInfo
Class bb.common.StockTransactionAdjustmentResult extends java.lang.Object implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

comments
java.lang.String comments
countedBy
java.lang.String countedBy
counted
java.util.Date counted
newOnhand
java.math.BigDecimal newOnhand
oldOnhand
java.math.BigDecimal oldOnhand
adjustedQty
java.math.BigDecimal adjustedQty
part
BB2Part part
Class bb.common.StockTransactionPartInfoResult extends java.lang.Object implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

part
BB2Part part
rev
java.lang.String rev
hold
java.lang.String hold
dwg
java.lang.String dwg
bill
java.lang.String bill
description
java.lang.String description
onhand
java.math.BigDecimal onhand
onorder
java.math.BigDecimal onorder
ondemand
java.math.BigDecimal ondemand
inWip
java.math.BigDecimal inWip
lendTime
java.math.BigDecimal lendTime
yUsage
java.math.BigDecimal yUsage
qtrUsage
java.math.BigDecimal qtrUsage
maxQty
java.math.BigDecimal maxQty
minQty
java.math.BigDecimal minQty
Class bb.common.StockTransactionPOReceiverResult extends java.lang.Object implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

receiverNumber
java.lang.String receiverNumber
itemNumber
java.lang.String itemNumber
part
BB2Part part
poNumber
java.lang.String poNumber
vendorId
java.lang.String vendorId
receivedBy
java.lang.String receivedBy
receivedDate
java.util.Date receivedDate
recQty
java.math.BigDecimal recQty
Class bb.common.StockTransactionSOShipperResult extends java.lang.Object implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

shipperNumber
java.lang.String shipperNumber
itemNumber
java.lang.String itemNumber
soNumber
java.lang.String soNumber
customerId
java.lang.String customerId
shippedBy
java.lang.String shippedBy
shippedQty
java.math.BigDecimal shippedQty
shippedDate
java.util.Date shippedDate
part
BB2Part part
Class bb.common.StockTransactionWOReceiverResult extends java.lang.Object implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

woNumber
java.lang.String woNumber
itemNumber
java.lang.String itemNumber
vendorId
java.lang.String vendorId
recQty
java.math.BigDecimal recQty
receivedDate
java.util.Date receivedDate
part
BB2Part part
Class bb.common.StockTransactionWOShipperResult extends java.lang.Object implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

woNumber
java.lang.String woNumber
itemNumber
java.lang.String itemNumber
customerId
java.lang.String customerId
issuedQty
java.math.BigDecimal issuedQty
issuedDate
java.util.Date issuedDate
part
BB2Part part
Class bb.common.SubcompanyLoginAgent extends java.lang.Object implements Serializable

Serialized Fields

server
java.lang.String server
system
java.lang.String system
userName
java.lang.String userName
port
java.lang.String port
password
java.lang.String password
languageCode
java.lang.String languageCode
Class bb.common.SubcompanyVO extends VO implements Serializable

Serialized Fields

addressID
java.lang.String addressID
companyName
java.lang.String companyName
ipAddress
java.lang.String ipAddress
system
java.lang.String system
port
java.lang.String port
serverLocation
java.lang.String serverLocation
accessUserName
java.lang.String accessUserName
accessPassword
java.lang.String accessPassword
createDate
java.util.Date createDate
lastChangeDate
java.util.Date lastChangeDate
lastSyncDate
java.util.Date lastSyncDate
lastChangeBy
java.lang.String lastChangeBy
ownershipPercent
float ownershipPercent
description
java.lang.String description
contactPerson
java.lang.String contactPerson
group
java.lang.String group
Class bb.common.SwapOrderApprovalVO extends VO implements Serializable

Serialized Fields

employeeId
java.lang.String employeeId
userName
java.lang.String userName
canApproveOwn
boolean canApproveOwn
comments
java.lang.String comments
Class bb.common.SwapOrderItemListResult extends java.lang.Object implements Serializable

Serialized Fields

swoNumber
java.lang.String swoNumber
swoItemNumber
java.lang.String swoItemNumber
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
description
java.lang.String description
itemComments
java.lang.String itemComments
swapQty
java.math.BigDecimal swapQty
shippedQty
java.math.BigDecimal shippedQty
receivedQty
java.math.BigDecimal receivedQty
itemStatus
java.lang.String itemStatus
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
deliveryDate
java.util.Date deliveryDate
desiredDate
java.util.Date desiredDate
delayDays
int delayDays
arriveDate
java.util.Date arriveDate
vendorId
java.lang.String vendorId
swapDate
java.util.Date swapDate
buyer
java.lang.String buyer
buyerGroup
java.lang.String buyerGroup
projectName
java.lang.String projectName
relatedDoc
java.lang.String relatedDoc
Class bb.common.SwapOrderItemPK extends java.lang.Object implements Serializable

Serialized Fields

swapOrder
java.lang.String swapOrder
swapOrderItem
java.lang.String swapOrderItem
Class bb.common.SwapOrderItemVO extends VO implements Serializable

Serialized Fields

pk
SwapOrderItemPK pk
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
description
java.lang.String description
swapQty
java.math.BigDecimal swapQty
shippedQty
java.math.BigDecimal shippedQty
receivedQty
java.math.BigDecimal receivedQty
status
java.lang.String status
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
deliveryDate
java.util.Date deliveryDate
desiredDate
java.util.Date desiredDate
delayDays
int delayDays
arriveDate
java.util.Date arriveDate
itemComments
java.lang.String itemComments
itemPrivateNotes
java.lang.String itemPrivateNotes
revision
java.lang.String revision
dwg
java.lang.String dwg
mfg
java.lang.String mfg
mpn
java.lang.String mpn
unit
java.lang.String unit
refDoc1
java.lang.String refDoc1
refDoc2
java.lang.String refDoc2
refDocTwoes
java.util.Set<E> refDocTwoes
Class bb.common.SwapOrderListResult extends SwapOrderVO implements Serializable

Serialized Fields

vendorName
java.lang.String vendorName
swapOrderNumber
java.lang.String swapOrderNumber
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
adate
java.util.Date adate
origin
java.lang.String origin
vendorId
java.lang.String vendorId
contact
java.lang.String contact
status
java.lang.String status
approvedDate
java.util.Date approvedDate
approvedBy
java.lang.String approvedBy
language
java.lang.String language
swapDate
java.util.Date swapDate
buyer
java.lang.String buyer
buyerGroup
java.lang.String buyerGroup
projectName
java.lang.String projectName
relatedDoc
java.lang.String relatedDoc
comments
java.lang.String comments
notes
java.lang.String notes
freight
java.math.BigDecimal freight
carrier
java.lang.String carrier
carrierAccount
java.lang.String carrierAccount
incoterm
java.lang.String incoterm
incotermPlacePort
java.lang.String incotermPlacePort
shipVia
java.lang.String shipVia
Class bb.common.SwapOrderVO extends VO implements Serializable

Serialized Fields

swapOrderNumber
java.lang.String swapOrderNumber
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
adate
java.util.Date adate
origin
java.lang.String origin
vendorId
java.lang.String vendorId
contact
java.lang.String contact
status
java.lang.String status
approvedDate
java.util.Date approvedDate
approvedBy
java.lang.String approvedBy
language
java.lang.String language
swapDate
java.util.Date swapDate
buyer
java.lang.String buyer
buyerGroup
java.lang.String buyerGroup
projectName
java.lang.String projectName
relatedDoc
java.lang.String relatedDoc
comments
java.lang.String comments
notes
java.lang.String notes
freight
java.math.BigDecimal freight
carrier
java.lang.String carrier
carrierAccount
java.lang.String carrierAccount
incoterm
java.lang.String incoterm
incotermPlacePort
java.lang.String incotermPlacePort
shipVia
java.lang.String shipVia
vendorAddressInfo
CustomerVendorAddressInfoVO vendorAddressInfo
swapOrderItems
java.util.Set<E> swapOrderItems
Class bb.common.SwapReceiverItemListResult extends java.lang.Object implements Serializable

Serialized Fields

swapReceiverNumber
java.lang.String swapReceiverNumber
swapShipperNumber
java.lang.String swapShipperNumber
swapOrderNumber
java.lang.String swapOrderNumber
swapReceiverItemNumber
java.lang.String swapReceiverItemNumber
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
description
java.lang.String description
swapQty
java.math.BigDecimal swapQty
shippedQty
java.math.BigDecimal shippedQty
receivedQty
java.math.BigDecimal receivedQty
status
java.lang.String status
location
java.lang.String location
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
receivedDate
java.util.Date receivedDate
itemComments
java.lang.String itemComments
itemPrivateNotes
java.lang.String itemPrivateNotes
Class bb.common.SwapReceiverItemPK extends java.lang.Object implements Serializable

Serialized Fields

swapReceiverNumber
java.lang.String swapReceiverNumber
swapReceiverItemNumber
java.lang.String swapReceiverItemNumber
Class bb.common.SwapReceiverItemVO extends VO implements Serializable

Serialized Fields

pk
SwapReceiverItemPK pk
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
description
java.lang.String description
swapQty
java.math.BigDecimal swapQty
shippedQty
java.math.BigDecimal shippedQty
receivedQty
java.math.BigDecimal receivedQty
status
java.lang.String status
location
java.lang.String location
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
receivedDate
java.util.Date receivedDate
itemComments
java.lang.String itemComments
itemPrivateNotes
java.lang.String itemPrivateNotes
revision
java.lang.String revision
dwg
java.lang.String dwg
mfg
java.lang.String mfg
mpn
java.lang.String mpn
unit
java.lang.String unit
refDoc1
java.lang.String refDoc1
refDoc2
java.lang.String refDoc2
refDocTwoes
java.util.Set<E> refDocTwoes
locations
java.util.Map<K,V> locations
trackings
java.util.Map<K,V> trackings
Class bb.common.SwapReceiverListResult extends java.lang.Object implements Serializable

Serialized Fields

vendorName
java.lang.String vendorName
swapReceiverNumber
java.lang.String swapReceiverNumber
swapShipperNumber
java.lang.String swapShipperNumber
swapOrderNumber
java.lang.String swapOrderNumber
version
int version
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
adate
java.util.Date adate
origin
java.lang.String origin
vendorId
java.lang.String vendorId
contact
java.lang.String contact
status
java.lang.String status
receivedDate
java.util.Date receivedDate
receivedBy
java.lang.String receivedBy
language
java.lang.String language
buyer
java.lang.String buyer
buyerGroup
java.lang.String buyerGroup
projectName
java.lang.String projectName
relatedDoc
java.lang.String relatedDoc
comments
java.lang.String comments
notes
java.lang.String notes
freight
java.math.BigDecimal freight
carrier
java.lang.String carrier
carrierAccount
java.lang.String carrierAccount
incoterm
java.lang.String incoterm
incotermPlacePort
java.lang.String incotermPlacePort
shipVia
java.lang.String shipVia
coComments
java.lang.String coComments
tracking
java.lang.String tracking
Class bb.common.SwapReceiverVO extends VO implements Serializable

Serialized Fields

swapReceiverNumber
java.lang.String swapReceiverNumber
swapShipperNumber
java.lang.String swapShipperNumber
swapOrderNumber
java.lang.String swapOrderNumber
version
int version
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
adate
java.util.Date adate
origin
java.lang.String origin
vendorId
java.lang.String vendorId
contact
java.lang.String contact
status
java.lang.String status
receivedDate
java.util.Date receivedDate
receivedBy
java.lang.String receivedBy
language
java.lang.String language
buyer
java.lang.String buyer
buyerGroup
java.lang.String buyerGroup
projectName
java.lang.String projectName
relatedDoc
java.lang.String relatedDoc
comments
java.lang.String comments
notes
java.lang.String notes
freight
java.math.BigDecimal freight
carrier
java.lang.String carrier
carrierAccount
java.lang.String carrierAccount
incoterm
java.lang.String incoterm
incotermPlacePort
java.lang.String incotermPlacePort
shipVia
java.lang.String shipVia
coComments
java.lang.String coComments
tracking
java.lang.String tracking
vendorAddressInfo
CustomerVendorAddressInfoVO vendorAddressInfo
swapReceiverItems
java.util.Set<E> swapReceiverItems
Class bb.common.SwapShipperItemListResult extends java.lang.Object implements Serializable

Serialized Fields

swapShipperNumber
java.lang.String swapShipperNumber
swapOrderNumber
java.lang.String swapOrderNumber
swapShipperItemNumber
java.lang.String swapShipperItemNumber
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
description
java.lang.String description
swapQty
java.math.BigDecimal swapQty
shippedQty
java.math.BigDecimal shippedQty
receivedQty
java.math.BigDecimal receivedQty
status
java.lang.String status
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
shippedDate
java.util.Date shippedDate
itemComments
java.lang.String itemComments
itemPrivateNotes
java.lang.String itemPrivateNotes
Class bb.common.SwapShipperItemPK extends java.lang.Object implements Serializable

Serialized Fields

swapShipperNumber
java.lang.String swapShipperNumber
swapShipperItemNumber
java.lang.String swapShipperItemNumber
Class bb.common.SwapShipperItemVO extends VO implements Serializable

Serialized Fields

pk
SwapShipperItemPK pk
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
description
java.lang.String description
swapQty
java.math.BigDecimal swapQty
shippedQty
java.math.BigDecimal shippedQty
receivedQty
java.math.BigDecimal receivedQty
status
java.lang.String status
location
java.lang.String location
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
shippedDate
java.util.Date shippedDate
itemComments
java.lang.String itemComments
itemPrivateNotes
java.lang.String itemPrivateNotes
revision
java.lang.String revision
dwg
java.lang.String dwg
mfg
java.lang.String mfg
mpn
java.lang.String mpn
unit
java.lang.String unit
refDoc1
java.lang.String refDoc1
refDoc2
java.lang.String refDoc2
refDocTwoes
java.util.Set<E> refDocTwoes
locations
java.util.Map<K,V> locations
trackings
java.util.Map<K,V> trackings
Class bb.common.SwapShipperListResult extends java.lang.Object implements Serializable

Serialized Fields

vendorName
java.lang.String vendorName
swapShipperNumber
java.lang.String swapShipperNumber
swapOrderNumber
java.lang.String swapOrderNumber
version
int version
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
adate
java.util.Date adate
origin
java.lang.String origin
vendorId
java.lang.String vendorId
contact
java.lang.String contact
status
java.lang.String status
shippedDate
java.util.Date shippedDate
shippedBy
java.lang.String shippedBy
language
java.lang.String language
buyer
java.lang.String buyer
buyerGroup
java.lang.String buyerGroup
projectName
java.lang.String projectName
relatedDoc
java.lang.String relatedDoc
comments
java.lang.String comments
notes
java.lang.String notes
freight
java.math.BigDecimal freight
carrier
java.lang.String carrier
carrierAccount
java.lang.String carrierAccount
incoterm
java.lang.String incoterm
incotermPlacePort
java.lang.String incotermPlacePort
shipVia
java.lang.String shipVia
coComments
java.lang.String coComments
tracking
java.lang.String tracking
freightRateCode
java.lang.String freightRateCode
grossWeight
java.lang.String grossWeight
Class bb.common.SwapShipperOnOrderResult extends java.lang.Object implements Serializable

Serialized Fields

partPk
PartPK partPk
swapShipperItemPk
SwapShipperItemPK swapShipperItemPk
description
java.lang.String description
swapQty
java.math.BigDecimal swapQty
receivedQty
java.math.BigDecimal receivedQty
shippedQty
java.math.BigDecimal shippedQty
quantityOnOrder
java.math.BigDecimal quantityOnOrder
vendorId
java.lang.String vendorId
shippedDate
java.util.Date shippedDate
partFrom
java.lang.String partFrom
Class bb.common.SwapShipperVO extends VO implements Serializable

Serialized Fields

swapShipperNumber
java.lang.String swapShipperNumber
swapOrderNumber
java.lang.String swapOrderNumber
version
int version
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
adate
java.util.Date adate
origin
java.lang.String origin
vendorId
java.lang.String vendorId
contact
java.lang.String contact
status
java.lang.String status
shippedDate
java.util.Date shippedDate
shippedBy
java.lang.String shippedBy
language
java.lang.String language
buyer
java.lang.String buyer
buyerGroup
java.lang.String buyerGroup
projectName
java.lang.String projectName
relatedDoc
java.lang.String relatedDoc
comments
java.lang.String comments
notes
java.lang.String notes
freight
java.math.BigDecimal freight
carrier
java.lang.String carrier
carrierAccount
java.lang.String carrierAccount
incoterm
java.lang.String incoterm
incotermPlacePort
java.lang.String incotermPlacePort
shipVia
java.lang.String shipVia
coComments
java.lang.String coComments
tracking
java.lang.String tracking
freightRateCode
java.lang.String freightRateCode
grossWeight
java.lang.String grossWeight
vendorAddressInfo
CustomerVendorAddressInfoVO vendorAddressInfo
swapShipperItems
java.util.Set<E> swapShipperItems
Class bb.common.TakeCycleCountAgent extends java.lang.Object implements Serializable

Serialized Fields

workSheetNumber
int workSheetNumber
partClass
java.lang.String partClass
orderBy
java.lang.String orderBy
description
java.lang.String description
zerolocation
boolean zerolocation
Class bb.common.TaskFileResult extends java.lang.Object implements Serializable

Serialized Fields

ii
java.lang.Long ii
fileName
java.lang.String fileName
extension
java.lang.String extension
path
java.lang.String path
size
long size
fileDate
java.util.Date fileDate
Class bb.common.TaskVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
identifier field

name
java.lang.String name
description
java.lang.String description
comments
java.lang.String comments
persistent field

tmin
java.lang.String tmin
persistent field

thrs
java.lang.String thrs
persistent field

tdate
java.lang.String tdate
persistent field

tmonth
java.lang.String tmonth
persistent field

tday
java.lang.String tday
persistent field

params
java.lang.String params
emailto
java.lang.String emailto
failEmailto
java.lang.String failEmailto
failRepeat
int failRepeat
repeatDelay
int repeatDelay
needLog
boolean needLog
startDate
java.util.Date startDate
endDate
java.util.Date endDate
sendNotice
boolean sendNotice
noticeReceivers
java.lang.String noticeReceivers
failNoticeReceivers
java.lang.String failNoticeReceivers
Class bb.common.TaxAccountVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Integer ii
salesTaxRate
java.math.BigDecimal salesTaxRate
purchaseTaxRate
java.math.BigDecimal purchaseTaxRate
accountNumber
java.lang.String accountNumber
Class bb.common.TempArApAgingVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
user
java.lang.String user
mothedParm
java.lang.String mothedParm
lastChangeDate
java.util.Date lastChangeDate
arApNumber
java.lang.String arApNumber
poNumber
java.lang.String poNumber
arApDate
java.util.Date arApDate
payDate
java.util.Date payDate
customerId
java.lang.String customerId
customerName
java.lang.String customerName
currency
java.lang.String currency
exchange
java.math.BigDecimal exchange
arApTotal
java.math.BigDecimal arApTotal
paid
java.math.BigDecimal paid
due
java.math.BigDecimal due
status
java.lang.String status
companyUnitId
java.lang.String companyUnitId
vendorInvoice
java.lang.String vendorInvoice
Class bb.common.TempReceiverWithoutAPInfo extends VO implements Serializable

Serialized Fields

dateSave
java.util.Date dateSave
searchDateFrom
java.util.Date searchDateFrom
searchDateTo
java.util.Date searchDateTo
searchId
java.lang.String searchId
searchBuyer
java.lang.String searchBuyer
searchCurrency
java.lang.String searchCurrency
receiverNumber
java.lang.String receiverNumber
purchaseOrderNumber
java.lang.String purchaseOrderNumber
vendorId
java.lang.String vendorId
vendorName
java.lang.String vendorName
subTotal
java.math.BigDecimal subTotal
grantTotal
java.math.BigDecimal grantTotal
currency
java.lang.String currency
dateReceived
java.util.Date dateReceived
receivedBy
java.lang.String receivedBy
status
java.lang.String status
Class bb.common.TermAgent extends java.lang.Object implements Serializable

Serialized Fields

term
java.lang.Integer term
days
java.lang.Integer days
termValue
java.lang.String termValue
discount
java.math.BigDecimal discount
termAlias
java.lang.String termAlias
comments
java.lang.String comments
Class bb.common.TermsConditionVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Integer ii
identifier field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

orderType
java.lang.String orderType
persistent field

document
byte[] document
nullable persistent field

extension
java.lang.String extension
persistent field

length
java.lang.Integer length
summary
java.lang.String summary
Class bb.common.TermVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Integer ii
identifier field

term
java.lang.Integer term
persistent field

days
java.lang.Integer days
nullable persistent field

discount
java.math.BigDecimal discount
persistent field

termValue
java.lang.String termValue
persistent field

termAlias
java.lang.String termAlias
persistent field

comments
java.lang.String comments
nullable persistent field

Class bb.common.ToolBasicInfo extends PartBasicInfo implements Serializable

Serialized Fields

calibration
java.lang.String calibration
Class bb.common.ToolCalibrateListResult extends ToolCalibrationVO implements Serializable

Serialized Fields

toolDescription
java.lang.String toolDescription
Class bb.common.ToolCalibrationVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
identifier field

partNumber
java.lang.String partNumber
identifier field

partType
java.lang.String partType
identifier field

location
java.lang.String location
persistent field

assignedTo
java.lang.String assignedTo
persistent field

serialNumber
java.lang.String serialNumber
persistent field

gageSet
java.lang.String gageSet
persistent field

manufacturerName
java.lang.String manufacturerName
persistent field

modelNumber
java.lang.String modelNumber
persistent field

status
java.lang.String status
persistent field

previousInspection
java.util.Date previousInspection
persistent field

lastInspection
java.util.Date lastInspection
persistent field

nextInspection
java.util.Date nextInspection
persistent field

inspectionPeriod
java.lang.String inspectionPeriod
persistent field

inspectionPeriodUnit
java.lang.String inspectionPeriodUnit
persistent field

certificationNumber
java.lang.String certificationNumber
persistent field

comment
java.lang.String comment
nullable persistent field

inspectedBy
java.lang.String inspectedBy
Class bb.common.ToolDescriptionVO extends VO implements Serializable

Serialized Fields

pk
PartDescriptionPK pk
status
java.lang.String status
persistent field

description
java.lang.String description
persistent field

version
java.lang.Integer version
Class bb.common.ToolInventoryVO extends VO implements Serializable

Serialized Fields

pk
PartPK pk
identifier field

modelNumber
java.lang.String modelNumber
persistent field

active
java.lang.String active
persistent field

onhand
java.math.BigDecimal onhand
persistent field

shippedQty
java.math.BigDecimal shippedQty
persistent field

receivedQty
java.math.BigDecimal receivedQty
persistent field

workInProcessQty
java.math.BigDecimal workInProcessQty
persistent field

onloanQty
java.math.BigDecimal onloanQty
persistent field

consignedQty
java.math.BigDecimal consignedQty
persistent field

inQualityCheckingQty
java.math.BigDecimal inQualityCheckingQty
persistent field

onDemandQty
java.math.BigDecimal onDemandQty
persistent field

onOrderQty
java.math.BigDecimal onOrderQty
persistent field

listPrice
java.math.BigDecimal listPrice
persistent field

averageCost
java.math.BigDecimal averageCost
persistent field

standardCost
java.math.BigDecimal standardCost
persistent field

firstInCost
java.math.BigDecimal firstInCost
PCode
java.lang.String PCode
persistent field

CCode
java.lang.String CCode
persistent field

OCode
java.lang.String OCode
persistent field

DCode
java.lang.String DCode
persistent field

ECode
java.lang.String ECode
persistent field

purchaseOrderUnit
java.lang.String purchaseOrderUnit
persistent field

salesOrderUnit
java.lang.String salesOrderUnit
persistent field

leadTime
java.math.BigDecimal leadTime
persistent field

minQty
java.math.BigDecimal minQty
persistent field

maxQty
java.math.BigDecimal maxQty
persistent field

yearUsage
java.math.BigDecimal yearUsage
persistent field

quarterUsage
java.math.BigDecimal quarterUsage
persistent field

ga
java.lang.String ga
persistent field

purchaseCost
java.math.BigDecimal purchaseCost
persistent field

lastPurchaseCost
java.math.BigDecimal lastPurchaseCost
lastPurchaseOrderNumber
java.lang.String lastPurchaseOrderNumber
lastPurchaseOrderItemNumber
java.lang.String lastPurchaseOrderItemNumber
version
java.lang.Integer version
shipInProcessQty
java.math.BigDecimal shipInProcessQty
shipInTransactionQty
java.math.BigDecimal shipInTransactionQty
inSTO
java.math.BigDecimal inSTO
Class bb.common.ToolListDetailCostResult extends java.lang.Object implements Serializable

Serialized Fields

toolListInfo
ToolListDetailCostWithToolInfoResult toolListInfo
ToolListItems
java.util.Set<E> ToolListItems
listCost
java.math.BigDecimal listCost
averageCost
java.math.BigDecimal averageCost
standardCost
java.math.BigDecimal standardCost
missingItems
java.lang.Integer missingItems
vendorLowestCost
java.math.BigDecimal vendorLowestCost
vendorAverageCost
java.math.BigDecimal vendorAverageCost
vendorHighestCost
java.math.BigDecimal vendorHighestCost
Class bb.common.ToolListDetailCostWithToolInfoResult extends ToolListWithToolInfoResult implements Serializable

Serialized Fields

listPrice
java.math.BigDecimal listPrice
averageCost
java.math.BigDecimal averageCost
standardCost
java.math.BigDecimal standardCost
Class bb.common.ToolListInfoVO extends VO implements Serializable

Serialized Fields

pk
BillPK pk
identifier field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
toolVO
ToolVO toolVO
Class bb.common.ToolListItemDetailCostWithToolInfoResult extends ToolListItemWithToolInfoResult implements Serializable

Serialized Fields

listPrice
java.math.BigDecimal listPrice
averageCost
java.math.BigDecimal averageCost
standardCost
java.math.BigDecimal standardCost
Class bb.common.ToolListItemVO extends VO implements Serializable

Serialized Fields

pk
BillItemPK pk
identifier field

bc
java.lang.String bc
persistent field

partQuantity
java.math.BigDecimal partQuantity
persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

toolListInfo
ToolListVO toolListInfo
nullable persistent field

Class bb.common.ToolListItemWithToolInfoResult extends ToolBasicInfo implements Serializable

Serialized Fields

billItemPk
BillItemPK billItemPk
partQuantity
java.math.BigDecimal partQuantity
Class bb.common.ToolListVO extends VO implements Serializable

Serialized Fields

pk
BillPK pk
identifier field

lastChangeUser
java.lang.String lastChangeUser
persistent field

version
java.lang.Integer version
persistent field

origin
java.lang.String origin
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

items
java.util.Set<E> items
persistent field

Class bb.common.ToolListWithToolInfoResult extends ToolBasicInfo implements Serializable

Serialized Fields

billPk
BillPK billPk
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
Class bb.common.ToolManufacturerVO extends VO implements Serializable

Serialized Fields

pk
PartManufacturerPK pk
identifier field

manufacturerId
java.lang.String manufacturerId
persistent field

qualityCode
java.lang.String qualityCode
persistent field

ratingCode
java.lang.String ratingCode
persistent field

preferredSo
boolean preferredSo
preferredPo
boolean preferredPo
manufacturerName
java.lang.String manufacturerName
persistent field

manufacturerPartNumber
java.lang.String manufacturerPartNumber
persistent field

manufacturerPartRev
java.lang.String manufacturerPartRev
remarks
java.lang.String remarks
persistent field

version
java.lang.Integer version
Class bb.common.ToolOnhandVO extends VO implements Serializable

Serialized Fields

pk
PartOnhandPK pk
identifier field

modelNumber
java.lang.String modelNumber
persistent field

active
java.lang.String active
persistent field

onHandQuantity
java.math.BigDecimal onHandQuantity
persistent field

averageCost
java.math.BigDecimal averageCost
warehouse
java.lang.String warehouse
Class bb.common.ToolOnhandWithAverageCostResult extends java.lang.Object implements Serializable

Serialized Fields

averageCost
java.math.BigDecimal averageCost
toolOnhandVo
ToolOnhandVO toolOnhandVo
Class bb.common.ToolVendorVO extends VO implements Serializable

Serialized Fields

pk
PartVendorPK pk
identifier field

vendorId
java.lang.String vendorId
persistent field

qualityCode
java.lang.String qualityCode
persistent field

ratingCode
java.lang.String ratingCode
persistent field

preferred
boolean preferred
vendorName
java.lang.String vendorName
vendorPrice
java.math.BigDecimal vendorPrice
persistent field

vendorCurrency
java.lang.String vendorCurrency
persistent field

poUnit
java.lang.String poUnit
persistent field

poQty
java.math.BigDecimal poQty
persistent field

vendorLeadTime
short vendorLeadTime
persistent field

effectiveDate
java.util.Date effectiveDate
persistent field

overdueDate
java.util.Date overdueDate
remarks
java.lang.String remarks
persistent field

requestForQuote
java.lang.String requestForQuote
version
java.lang.Integer version
lastPurchaseCost
java.math.BigDecimal lastPurchaseCost
lastPurchaseOrderNumber
java.lang.String lastPurchaseOrderNumber
lastPurchaseOrderItemNumber
java.lang.String lastPurchaseOrderItemNumber
Class bb.common.ToolVO extends VO implements Serializable

Serialized Fields

pk
PartPK pk
identifier field

lastUser
java.lang.String lastUser
persistent field

origin
java.lang.String origin
persistent field

createdDate
java.util.Date createdDate
nullable persistent field

owner
java.lang.String owner
persistent field

modelNumber
java.lang.String modelNumber
persistent field

commodityCode
java.lang.String commodityCode
persistent field

buyerCode
java.lang.String buyerCode
persistent field

makeBuy
java.lang.String makeBuy
persistent field

saleable
java.lang.String saleable
persistent field

calibration
java.lang.String calibration
persistent field

description
java.lang.String description
persistent field

revision
java.lang.String revision
persistent field

revisionDate
java.util.Date revisionDate
persistent field

hold
java.lang.String hold
persistent field

shippingWeight
float shippingWeight
persistent field

shippingWeightUnit
java.lang.String shippingWeightUnit
persistent field

shippingLength
java.math.BigDecimal shippingLength
shippingWidth
java.math.BigDecimal shippingWidth
shippingDepth
java.math.BigDecimal shippingDepth
volume
java.math.BigDecimal volume
volumeUnit
java.lang.String volumeUnit
partUnit
java.lang.String partUnit
persistent field

comment
java.lang.String comment
persistent field

drawing
java.lang.String drawing
persistent field

bill
java.lang.String bill
persistent field

wi
java.lang.String wi
persistent field

lastChangeDate
java.util.Date lastChangeDate
persistent field

version
java.lang.Integer version
nullable persistent field

multiLanguage
java.util.Set<E> multiLanguage
persistent field

vendors
java.util.Set<E> vendors
persistent field

manufacturers
java.util.Set<E> manufacturers
persistent field

Inspections
java.util.Set<E> Inspections
partInventory
ToolInventoryVO partInventory
inactive
boolean inactive
inspectionType
java.lang.String inspectionType
irType
java.lang.String irType
Class bb.common.ToolWhereUsedItemResult extends java.lang.Object implements Serializable

Serialized Fields

pk
BillItemPK pk
partQuantity
java.math.BigDecimal partQuantity
description
java.lang.String description
bill
java.lang.String bill
wi
java.lang.String wi
hold
java.lang.String hold
drawing
java.lang.String drawing
onhand
java.math.BigDecimal onhand
Class bb.common.ToolWhereUsedResult extends java.lang.Object implements Serializable

Serialized Fields

toolBasicInfo
ToolBasicInfo toolBasicInfo
toolWhereUsedItemResult
java.util.List<E> toolWhereUsedItemResult
Class bb.common.ToolWithManufacturerInfoResult extends PartWithManufacturerInfoResult implements Serializable

Serialized Fields

calibration
java.lang.String calibration
Class bb.common.ToolWithOnhandsVO extends VO implements Serializable

Serialized Fields

pk
PartPK pk
identifier field

lastUser
java.lang.String lastUser
persistent field

origin
java.lang.String origin
persistent field

createdDate
java.util.Date createdDate
nullable persistent field

owner
java.lang.String owner
persistent field

modelNumber
java.lang.String modelNumber
persistent field

commodityCode
java.lang.String commodityCode
persistent field

buyerCode
java.lang.String buyerCode
persistent field

makeBuy
java.lang.String makeBuy
persistent field

saleable
java.lang.String saleable
persistent field

calibration
java.lang.String calibration
persistent field

description
java.lang.String description
persistent field

revision
java.lang.String revision
persistent field

revisionDate
java.util.Date revisionDate
persistent field

hold
java.lang.String hold
persistent field

shippingWeight
float shippingWeight
persistent field

shippingWeightUnit
java.lang.String shippingWeightUnit
persistent field

shippingLength
java.math.BigDecimal shippingLength
shippingWidth
java.math.BigDecimal shippingWidth
shippingDepth
java.math.BigDecimal shippingDepth
volume
java.math.BigDecimal volume
volumeUnit
java.lang.String volumeUnit
partUnit
java.lang.String partUnit
persistent field

comment
java.lang.String comment
persistent field

drawing
java.lang.String drawing
persistent field

bill
java.lang.String bill
persistent field

wi
java.lang.String wi
persistent field

lastChangeDate
java.util.Date lastChangeDate
persistent field

version
java.lang.Integer version
nullable persistent field

multiLanguage
java.util.Set<E> multiLanguage
persistent field

onHandLocations
java.util.Set<E> onHandLocations
persistent field

partInventory
ToolInventoryVO partInventory
Class bb.common.TotalAmountInPOByRefDoc extends VendorTotalAmountInPO implements Serializable

Serialized Fields

refdoc
java.lang.String refdoc
relatedDoc
java.lang.String relatedDoc
project
java.lang.String project
projectDescription
java.lang.String projectDescription
totalDue
java.math.BigDecimal totalDue
Class bb.common.TotalByDateResult extends java.lang.Object implements Serializable

Serialized Fields

subTotal
java.math.BigDecimal subTotal
totalRecOrShip
java.math.BigDecimal totalRecOrShip
totalOpen
java.math.BigDecimal totalOpen
totalTax
java.math.BigDecimal totalTax
totalDiscount
java.math.BigDecimal totalDiscount
grandTotal
java.math.BigDecimal grandTotal
totalFreight
java.math.BigDecimal totalFreight
currency
java.lang.String currency
totalStandardCost
java.math.BigDecimal totalStandardCost
Class bb.common.TraceableCategoriesVO extends VO implements Serializable

Serialized Fields

categoryId
java.lang.String categoryId
criticalityCategory
java.lang.String criticalityCategory
Class bb.common.TraceableSpecsVO extends VO implements Serializable

Serialized Fields

qualityId
java.lang.Short qualityId
qualitySpecification
java.lang.String qualitySpecification
memo
java.lang.String memo
Class bb.common.TransferOrderApprovalVO extends VO implements Serializable

Serialized Fields

employeeId
java.lang.String employeeId
userName
java.lang.String userName
canApproveOwn
boolean canApproveOwn
comments
java.lang.String comments
Class bb.common.TransferOrderItemListResult extends java.lang.Object implements Serializable

Serialized Fields

transferOrderNumber
java.lang.String transferOrderNumber
transferOrderItemNumber
java.lang.String transferOrderItemNumber
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
description
java.lang.String description
transferQty
java.math.BigDecimal transferQty
shippedQty
java.math.BigDecimal shippedQty
receivedQty
java.math.BigDecimal receivedQty
status
java.lang.String status
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
deliveryDate
java.util.Date deliveryDate
desiredDate
java.util.Date desiredDate
delayDays
int delayDays
arriveDate
java.util.Date arriveDate
itemComments
java.lang.String itemComments
itemPrivateNotes
java.lang.String itemPrivateNotes
fromLocation
java.lang.String fromLocation
toLocation
java.lang.String toLocation
Class bb.common.TransferOrderItemPK extends java.lang.Object implements Serializable

Serialized Fields

transferOrderNumber
java.lang.String transferOrderNumber
transferOrderItemNumber
java.lang.String transferOrderItemNumber
Class bb.common.TransferOrderItemVO extends VO implements Serializable

Serialized Fields

pk
TransferOrderItemPK pk
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
description
java.lang.String description
transferQty
java.math.BigDecimal transferQty
shippedQty
java.math.BigDecimal shippedQty
receivedQty
java.math.BigDecimal receivedQty
status
java.lang.String status
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
deliveryDate
java.util.Date deliveryDate
desiredDate
java.util.Date desiredDate
delayDays
int delayDays
arriveDate
java.util.Date arriveDate
itemComments
java.lang.String itemComments
itemPrivateNotes
java.lang.String itemPrivateNotes
fromLocation
java.lang.String fromLocation
toLocation
java.lang.String toLocation
revision
java.lang.String revision
dwg
java.lang.String dwg
mfg
java.lang.String mfg
mpn
java.lang.String mpn
unit
java.lang.String unit
refDoc1
java.lang.String refDoc1
refDoc2
java.lang.String refDoc2
qtyShip
java.math.BigDecimal qtyShip
refDocTwoes
java.util.Set<E> refDocTwoes
Class bb.common.TransferOrderListResult extends java.lang.Object implements Serializable

Serialized Fields

transferOrderNumber
java.lang.String transferOrderNumber
adate
java.util.Date adate
origin
java.lang.String origin
lastUser
java.lang.String lastUser
lastChangeDate
java.util.Date lastChangeDate
totalCost
java.math.BigDecimal totalCost
status
java.lang.String status
approvedBy
java.lang.String approvedBy
approveDate
java.util.Date approveDate
carrier
java.lang.String carrier
carrierAccount
java.lang.String carrierAccount
incoterm
java.lang.String incoterm
incotermPlacePort
java.lang.String incotermPlacePort
shipAccout
java.lang.String shipAccout
locate
java.lang.String locate
language
java.lang.String language
currency
java.lang.String currency
shipVia
java.lang.String shipVia
contact
java.lang.String contact
freight
java.math.BigDecimal freight
comments
java.lang.String comments
privateNotes
java.lang.String privateNotes
fromAddressId
java.lang.String fromAddressId
toAddressId
java.lang.String toAddressId
transferOrderDate
java.util.Date transferOrderDate
terms
java.lang.String terms
requester
java.lang.String requester
relatedDocument
java.lang.String relatedDocument
Class bb.common.TransferOrderVO extends VO implements Serializable

Serialized Fields

transferOrderNumber
java.lang.String transferOrderNumber
adate
java.util.Date adate
origin
java.lang.String origin
lastUser
java.lang.String lastUser
lastChangeDate
java.util.Date lastChangeDate
totalCost
java.math.BigDecimal totalCost
status
java.lang.String status
approvedBy
java.lang.String approvedBy
approveDate
java.util.Date approveDate
carrier
java.lang.String carrier
carrierAccount
java.lang.String carrierAccount
incoterm
java.lang.String incoterm
incotermPlacePort
java.lang.String incotermPlacePort
shipAccout
java.lang.String shipAccout
locate
java.lang.String locate
language
java.lang.String language
currency
java.lang.String currency
shipVia
java.lang.String shipVia
contact
java.lang.String contact
freight
java.math.BigDecimal freight
comments
java.lang.String comments
privateNotes
java.lang.String privateNotes
fromAddressId
java.lang.String fromAddressId
toAddressId
java.lang.String toAddressId
transferOrderDate
java.util.Date transferOrderDate
terms
java.lang.String terms
requester
java.lang.String requester
relatedDocument
java.lang.String relatedDocument
fromAddressInfo
CustomerVendorAddressInfoVO fromAddressInfo
toAddressInfo
CustomerVendorAddressInfoVO toAddressInfo
transferOrderItems
java.util.Set<E> transferOrderItems
version
int version
transferType
java.lang.String transferType
Class bb.common.TransferReceiverItemListResult extends java.lang.Object implements Serializable

Serialized Fields

transferReceiverNumber
java.lang.String transferReceiverNumber
transferReceiverItemNumber
java.lang.String transferReceiverItemNumber
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
description
java.lang.String description
transferQty
java.math.BigDecimal transferQty
shippedQty
java.math.BigDecimal shippedQty
receivedQty
java.math.BigDecimal receivedQty
status
java.lang.String status
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
itemComments
java.lang.String itemComments
itemPrivateNotes
java.lang.String itemPrivateNotes
revision
java.lang.String revision
dwg
java.lang.String dwg
mfg
java.lang.String mfg
mpn
java.lang.String mpn
unit
java.lang.String unit
refDoc1
java.lang.String refDoc1
refDoc2
java.lang.String refDoc2
receivedDate
java.util.Date receivedDate
shipVia
java.lang.String shipVia
hqa
java.math.BigDecimal hqa
fromAddressId
java.lang.String fromAddressId
toAddressId
java.lang.String toAddressId
Class bb.common.TransferReceiverItemPK extends java.lang.Object implements Serializable

Serialized Fields

transferReceiverNumber
java.lang.String transferReceiverNumber
transferReceiverItemNumber
java.lang.String transferReceiverItemNumber
Class bb.common.TransferReceiverItemVO extends VO implements Serializable

Serialized Fields

pk
TransferReceiverItemPK pk
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
description
java.lang.String description
transferQty
java.math.BigDecimal transferQty
shippedQty
java.math.BigDecimal shippedQty
receivedQty
java.math.BigDecimal receivedQty
status
java.lang.String status
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
itemComments
java.lang.String itemComments
itemPrivateNotes
java.lang.String itemPrivateNotes
location
java.lang.String location
revision
java.lang.String revision
dwg
java.lang.String dwg
mfg
java.lang.String mfg
mpn
java.lang.String mpn
unit
java.lang.String unit
refDoc1
java.lang.String refDoc1
refDoc2
java.lang.String refDoc2
receivedDate
java.util.Date receivedDate
shipVia
java.lang.String shipVia
hqa
java.math.BigDecimal hqa
locations
java.util.Map<K,V> locations
trackings
java.util.Map<K,V> trackings
Class bb.common.TransferReceiverListResult extends java.lang.Object implements Serializable

Serialized Fields

transferReceiverNumber
java.lang.String transferReceiverNumber
transferShipperNumber
java.lang.String transferShipperNumber
transferOrderNumber
java.lang.String transferOrderNumber
adate
java.util.Date adate
origin
java.lang.String origin
lastUser
java.lang.String lastUser
lastChangeDate
java.util.Date lastChangeDate
status
java.lang.String status
carrier
java.lang.String carrier
carrierAccount
java.lang.String carrierAccount
incoterm
java.lang.String incoterm
incotermPlacePort
java.lang.String incotermPlacePort
locate
java.lang.String locate
language
java.lang.String language
currency
java.lang.String currency
shipVia
java.lang.String shipVia
fromAddressId
java.lang.String fromAddressId
toAddressId
java.lang.String toAddressId
receivedDate
java.util.Date receivedDate
arFreight
java.math.BigDecimal arFreight
coComments
java.lang.String coComments
tracking
java.lang.String tracking
terms
java.lang.String terms
lastChangeTime
int lastChangeTime
relatedDocument
java.lang.String relatedDocument
receiverComments
java.lang.String receiverComments
receiverPrivateNotes
java.lang.String receiverPrivateNotes
receivedBy
java.lang.String receivedBy
Class bb.common.TransferReceiverVO extends VO implements Serializable

Serialized Fields

transferReceiverNumber
java.lang.String transferReceiverNumber
transferShipperNumber
java.lang.String transferShipperNumber
transferOrderNumber
java.lang.String transferOrderNumber
adate
java.util.Date adate
origin
java.lang.String origin
lastUser
java.lang.String lastUser
lastChangeDate
java.util.Date lastChangeDate
totalCost
java.math.BigDecimal totalCost
status
java.lang.String status
carrier
java.lang.String carrier
carrierAccount
java.lang.String carrierAccount
incoterm
java.lang.String incoterm
incotermPlacePort
java.lang.String incotermPlacePort
locate
java.lang.String locate
language
java.lang.String language
currency
java.lang.String currency
shipVia
java.lang.String shipVia
fromAddressId
java.lang.String fromAddressId
toAddressId
java.lang.String toAddressId
fromAddressInfo
CustomerVendorAddressInfoVO fromAddressInfo
toAddressInfo
CustomerVendorAddressInfoVO toAddressInfo
receivedDate
java.util.Date receivedDate
transferReceiverItems
java.util.Set<E> transferReceiverItems
arFreight
java.math.BigDecimal arFreight
coComments
java.lang.String coComments
tracking
java.lang.String tracking
terms
java.lang.String terms
lastChangeTime
int lastChangeTime
relatedDocument
java.lang.String relatedDocument
receiverComments
java.lang.String receiverComments
receiverPrivateNotes
java.lang.String receiverPrivateNotes
receivedBy
java.lang.String receivedBy
Class bb.common.TransferShipperItemListResult extends java.lang.Object implements Serializable

Serialized Fields

transferShipperNumber
java.lang.String transferShipperNumber
transferShipperItemNumber
java.lang.String transferShipperItemNumber
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
description
java.lang.String description
transferQty
java.math.BigDecimal transferQty
shippedQty
java.math.BigDecimal shippedQty
receivedQty
java.math.BigDecimal receivedQty
status
java.lang.String status
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
itemComments
java.lang.String itemComments
itemPrivateNotes
java.lang.String itemPrivateNotes
revision
java.lang.String revision
dwg
java.lang.String dwg
mfg
java.lang.String mfg
mpn
java.lang.String mpn
unit
java.lang.String unit
refDoc1
java.lang.String refDoc1
refDoc2
java.lang.String refDoc2
shippedDate
java.util.Date shippedDate
shipVia
java.lang.String shipVia
Class bb.common.TransferShipperItemPK extends java.lang.Object implements Serializable

Serialized Fields

transferShipperNumber
java.lang.String transferShipperNumber
transferShipperItemNumber
java.lang.String transferShipperItemNumber
Class bb.common.TransferShipperItemVO extends VO implements Serializable

Serialized Fields

pk
TransferShipperItemPK pk
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
description
java.lang.String description
transferQty
java.math.BigDecimal transferQty
shippedQty
java.math.BigDecimal shippedQty
receivedQty
java.math.BigDecimal receivedQty
status
java.lang.String status
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
itemComments
java.lang.String itemComments
itemPrivateNotes
java.lang.String itemPrivateNotes
location
java.lang.String location
revision
java.lang.String revision
mfg
java.lang.String mfg
mpn
java.lang.String mpn
unit
java.lang.String unit
refDoc1
java.lang.String refDoc1
refDoc2
java.lang.String refDoc2
shippedDate
java.util.Date shippedDate
shipVia
java.lang.String shipVia
refDocTwoes
java.util.Set<E> refDocTwoes
locations
java.util.Map<K,V> locations
trackings
java.util.Map<K,V> trackings
Class bb.common.TransferShipperListResult extends java.lang.Object implements Serializable

Serialized Fields

transferShipperNumber
java.lang.String transferShipperNumber
transferOrderNumber
java.lang.String transferOrderNumber
adate
java.util.Date adate
origin
java.lang.String origin
lastUser
java.lang.String lastUser
lastChangeDate
java.util.Date lastChangeDate
totalCost
java.math.BigDecimal totalCost
status
java.lang.String status
carrier
java.lang.String carrier
carrierAccount
java.lang.String carrierAccount
incoterm
java.lang.String incoterm
incotermPlacePort
java.lang.String incotermPlacePort
shipAccout
java.lang.String shipAccout
language
java.lang.String language
currency
java.lang.String currency
shipVia
java.lang.String shipVia
arFreight
java.math.BigDecimal arFreight
coComments
java.lang.String coComments
fromAddressId
java.lang.String fromAddressId
toAddressId
java.lang.String toAddressId
fromAddressName
java.lang.String fromAddressName
toAddressName
java.lang.String toAddressName
shippedDate
java.util.Date shippedDate
shippedBy
java.lang.String shippedBy
tracking
java.lang.String tracking
freightRateCode
java.lang.String freightRateCode
grossWeight
java.lang.String grossWeight
terms
java.lang.String terms
lastChangeTime
int lastChangeTime
relatedDocument
java.lang.String relatedDocument
shipperComments
java.lang.String shipperComments
shipperPrivateNotes
java.lang.String shipperPrivateNotes
Class bb.common.TransferShipperVO extends VO implements Serializable

Serialized Fields

transferShipperNumber
java.lang.String transferShipperNumber
transferOrderNumber
java.lang.String transferOrderNumber
adate
java.util.Date adate
origin
java.lang.String origin
lastUser
java.lang.String lastUser
lastChangeDate
java.util.Date lastChangeDate
totalCost
java.math.BigDecimal totalCost
status
java.lang.String status
carrier
java.lang.String carrier
carrierAccount
java.lang.String carrierAccount
incoterm
java.lang.String incoterm
incotermPlacePort
java.lang.String incotermPlacePort
shipAccout
java.lang.String shipAccout
language
java.lang.String language
currency
java.lang.String currency
shipVia
java.lang.String shipVia
contact
java.lang.String contact
arFreight
java.math.BigDecimal arFreight
coComments
java.lang.String coComments
fromAddressId
java.lang.String fromAddressId
toAddressId
java.lang.String toAddressId
fromAddressInfo
CustomerVendorAddressInfoVO fromAddressInfo
toAddressInfo
CustomerVendorAddressInfoVO toAddressInfo
shippedDate
java.util.Date shippedDate
shippedBy
java.lang.String shippedBy
transferShipperItems
java.util.Set<E> transferShipperItems
tracking
java.lang.String tracking
freightRateCode
java.lang.String freightRateCode
grossWeight
java.lang.String grossWeight
terms
java.lang.String terms
lastChangeTime
int lastChangeTime
relatedDocument
java.lang.String relatedDocument
shipperComments
java.lang.String shipperComments
shipperPrivateNotes
java.lang.String shipperPrivateNotes
glNumber
java.lang.String glNumber
Class bb.common.TwelveMonthCashFlowReportResult extends java.lang.Object implements Serializable

Serialized Fields

columns
java.util.LinkedHashSet<E> columns
cashPosition
java.util.TreeMap<K,V> cashPosition
ar
java.util.TreeMap<K,V> ar
openSo
java.util.TreeMap<K,V> openSo
rAccounts
java.util.TreeMap<K,V> rAccounts
totalReceipts
java.util.TreeMap<K,V> totalReceipts
totalCashAvailiable
java.util.TreeMap<K,V> totalCashAvailiable
ap
java.util.TreeMap<K,V> ap
openPos
java.util.TreeMap<K,V> openPos
eAccounts
java.util.TreeMap<K,V> eAccounts
totalPayOut
java.util.TreeMap<K,V> totalPayOut
cashEndPosition
java.util.TreeMap<K,V> cashEndPosition
Class bb.common.UnitVO extends VO implements Serializable

Serialized Fields

id
long id
unitName
java.lang.String unitName
Class bb.common.UpdatePhysicalInventoryAgent extends java.lang.Object implements Serializable

Serialized Fields

pk
PhysicalInventoryPK pk
physicalCount
java.math.BigDecimal physicalCount
partPk
PartPK partPk
location
java.lang.String location
tagNumber
java.lang.String tagNumber
customProperties
java.util.HashMap<K,V> customProperties
Class bb.common.User2UserAgent extends java.lang.Object implements Serializable

Serialized Fields

originalUserName
java.lang.String originalUserName
userName
java.lang.String userName
password
java.lang.String password
type
int type
refId
java.lang.String refId
comments
java.lang.String comments
Class bb.common.UserGroupVO extends VO implements Serializable

Serialized Fields

id
java.lang.String id
owner
java.lang.String owner
description
java.lang.String description
global
boolean global
Class bb.common.UserRolePermissionListResult extends VO implements Serializable

Serialized Fields

userName
java.lang.String userName
permissionId
java.lang.String permissionId
permissionName
java.lang.String permissionName
roleId
java.lang.String roleId
roleName
java.lang.String roleName
refId
java.lang.String refId
systemName
java.lang.String systemName
Class bb.common.UserRolePK extends java.lang.Object implements Serializable

Serialized Fields

userName
java.lang.String userName
identifier field

roleId
java.lang.String roleId
identifier field

Class bb.common.UserRoleVO extends VO implements Serializable

Serialized Fields

pk
UserRolePK pk
pk

Class bb.common.VendorCategoriesVO extends VO implements Serializable

Serialized Fields

vendorCategory
java.lang.String vendorCategory
description
java.lang.String description
Class bb.common.VendorContractPriceItemPK extends java.lang.Object implements Serializable

Serialized Fields

contractNumber
java.lang.String contractNumber
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
Class bb.common.VendorContractPriceItemVO extends VO implements Serializable

Serialized Fields

pk
VendorContractPriceItemPK pk
identifier field

contractName
java.lang.String contractName
persistent field

listPrice
java.math.BigDecimal listPrice
persistent field

discount
java.math.BigDecimal discount
persistent field

comments
java.lang.String comments
persistent field

bb2ListPrice
java.math.BigDecimal bb2ListPrice
bb2AvgCost
java.math.BigDecimal bb2AvgCost
bb2StdCost
java.math.BigDecimal bb2StdCost
description
java.lang.String description
Class bb.common.VendorContractPriceVendorPK extends java.lang.Object implements Serializable

Serialized Fields

contractNumber
java.lang.String contractNumber
identifier field

id
java.lang.String id
identifier field

Class bb.common.VendorContractPriceVendorVO extends VO implements Serializable

Serialized Fields

pk
VendorContractPriceVendorPK pk
identifier field

contractName
java.lang.String contractName
persistent field

vendorInfo
CustomerVendorAddressInfoVO vendorInfo
nullable persistent field

Class bb.common.VendorContractPriceVO extends VO implements Serializable

Serialized Fields

contractNumber
java.lang.String contractNumber
identifier field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

lastChangeTimes
int lastChangeTimes
persistent field

origin
java.lang.String origin
persistent field

status
java.lang.String status
persistent field

contractName
java.lang.String contractName
persistent field

description
java.lang.String description
persistent field

currency
java.lang.String currency
persistent field

startDate
java.util.Date startDate
persistent field

expireDate
java.util.Date expireDate
persistent field

Class bb.common.VendorCriticalLevelVO extends VO implements Serializable

Serialized Fields

criticalLevel
java.lang.String criticalLevel
description
java.lang.String description
Class bb.common.VendorGroupUserVO extends VO implements Serializable

Serialized Fields

vendorId
java.lang.String vendorId
identifier field

password
java.lang.String password
persistent field

userName
java.lang.String userName
fullName
java.lang.String fullName
phone
java.lang.String phone
mobile
java.lang.String mobile
fax
java.lang.String fax
userEmail
java.lang.String userEmail
language
java.lang.String language
customerAddressInfo
CustomerVendorAddressInfoVO customerAddressInfo
Class bb.common.VendorPartPK extends java.lang.Object implements Serializable

Serialized Fields

vendorPartNumber
java.lang.String vendorPartNumber
identifier field

vendorPartType
java.lang.String vendorPartType
identifier field

vendorPartFrom
java.lang.String vendorPartFrom
identifier field

vendorId
java.lang.String vendorId
identifier field

Class bb.common.VendorPartVO extends VO implements Serializable

Serialized Fields

pk
VendorPartPK pk
identifier field

partNumber
java.lang.String partNumber
identifier field

partType
java.lang.String partType
identifier field

partFrom
java.lang.String partFrom
identifier field

Class bb.common.VendorPrepayStatementListResult extends java.lang.Object implements Serializable

Serialized Fields

pk
ApPrepayItemPK pk
dateRequired
java.util.Date dateRequired
ourPoNumber
java.lang.String ourPoNumber
totalDue
java.math.BigDecimal totalDue
amountPaid
java.math.BigDecimal amountPaid
balanceDue
java.math.BigDecimal balanceDue
Class bb.common.VendorQtyPricePK extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
identifier field

partType
java.lang.String partType
identifier field

partFrom
java.lang.String partFrom
identifier field

vendorId
java.lang.String vendorId
identifier field

jj
java.lang.Byte jj
identifier field

Class bb.common.VendorQtyPriceVO extends VO implements Serializable

Serialized Fields

pk
VendorQtyPricePK pk
identifier field

fromQty
java.math.BigDecimal fromQty
nullable persistent field

toQty
java.math.BigDecimal toQty
nullable persistent field

price
java.math.BigDecimal price
nullable persistent field

currency
java.lang.String currency
nullable persistent field

discount
java.math.BigDecimal discount
nullable persistent field

Class bb.common.VendorStatementListResult extends java.lang.Object implements Serializable

Serialized Fields

apNumber
java.lang.String apNumber
date
java.util.Date date
ourPoNumber
java.lang.String ourPoNumber
totalDue
java.math.BigDecimal totalDue
amountPaid
java.math.BigDecimal amountPaid
balanceDue
java.math.BigDecimal balanceDue
vendorInvoice
java.lang.String vendorInvoice
Class bb.common.VendorTotalAmountInPO extends java.lang.Object implements Serializable

Serialized Fields

vendorId
java.lang.String vendorId
name
java.lang.String name
subTotal
java.math.BigDecimal subTotal
totalDiscount
java.math.BigDecimal totalDiscount
totalTax
java.math.BigDecimal totalTax
totalFreight
java.math.BigDecimal totalFreight
grandTotal
java.math.BigDecimal grandTotal
totalReceived
java.math.BigDecimal totalReceived
totalOpen
java.math.BigDecimal totalOpen
Class bb.common.VO extends java.lang.Object implements Serializable

Serialized Fields

customProperties
java.util.Map<K,V> customProperties
clientProperties
java.util.Map<K,V> clientProperties
Class bb.common.WareHousePartPrefixKeeperVO extends VO implements Serializable

Serialized Fields

warehouseName
java.lang.String warehouseName
district
java.lang.String district
partPrefix
java.lang.String partPrefix
keeper
java.lang.String keeper
description
java.lang.String description
Class bb.common.WarehouseTransferPK extends java.lang.Object implements Serializable

Serialized Fields

warehousePrefix
java.lang.String warehousePrefix
warehousePrefixTransferTo
java.lang.String warehousePrefixTransferTo
Class bb.common.WarehouseTransferVO extends VO implements Serializable

Serialized Fields

pk
WarehouseTransferPK pk
Class bb.common.WarehouseVO extends VO implements Serializable

Serialized Fields

warehousePrefix
java.lang.String warehousePrefix
name
java.lang.String name
comments
java.lang.String comments
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
adate
java.util.Date adate
origin
java.lang.String origin
lastChangeTimes
int lastChangeTimes
items
java.util.Set<E> items
Class bb.common.WareHousingInfoCenterResult extends java.lang.Object implements Serializable

Serialized Fields

currentMonthShipperCount
java.lang.Integer currentMonthShipperCount
currentMonthShipperItemCount
java.lang.Integer currentMonthShipperItemCount
currentMonthReceiverCount
java.lang.Integer currentMonthReceiverCount
currentMonthReceiverItemCount
java.lang.Integer currentMonthReceiverItemCount
dueSOCount
java.lang.Integer dueSOCount
soWithPartOnHoldCount
java.lang.Integer soWithPartOnHoldCount
fyShippperCount
java.lang.Integer fyShippperCount
fyReceiverCount
java.lang.Integer fyReceiverCount
ytdShipperCount
java.lang.Integer ytdShipperCount
ytdReceiverCount
java.lang.Integer ytdReceiverCount
inSipCount
java.lang.Integer inSipCount
inSipTotal
Money inSipTotal
inSitCount
java.lang.Integer inSitCount
inSitTotal
Money inSitTotal
Class bb.common.WC2WCAgent extends java.lang.Object implements Serializable

Serialized Fields

workCenterId
java.lang.String workCenterId
description
java.lang.String description
oldWorkCenterId
java.lang.String oldWorkCenterId
Class bb.common.WCLoadAgent extends java.lang.Object implements Serializable

Serialized Fields

items
java.util.HashMap<K,V> items
fDate
java.util.Date fDate
tDate
java.util.Date tDate
Class bb.common.WCLoadByDateResult extends java.lang.Object implements Serializable

Serialized Fields

pk
WorkOrderWorkInstructionSequencePK pk
part
BB2Part part
startDate
java.util.Date startDate
endDate
java.util.Date endDate
estSetup
java.math.BigDecimal estSetup
timePeriod
java.util.Set<E> timePeriod
workCenterId
java.lang.String workCenterId
description
java.lang.String description
Class bb.common.WCLoadDetailResult extends java.lang.Object implements Serializable

Serialized Fields

woNumber
java.lang.String woNumber
itemNumber
java.lang.String itemNumber
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
description
java.lang.String description
startDate
java.util.Date startDate
delivery
java.util.Date delivery
notAsmQty
java.math.BigDecimal notAsmQty
qtyToAsm
java.math.BigDecimal qtyToAsm
issuedRate
java.math.BigDecimal issuedRate
workCenter
java.lang.String workCenter
seqWC
java.lang.String seqWC
seqNumber
java.lang.String seqNumber
setup
java.math.BigDecimal setup
hours
java.math.BigDecimal hours
total
java.math.BigDecimal total
totalNotCompletedSeqBefore
java.math.BigDecimal totalNotCompletedSeqBefore
notCompletedSeqBefore
int notCompletedSeqBefore
notCompletedSeqWithPOBefore
int notCompletedSeqWithPOBefore
finishDateOfSeqWithPOBefore
java.util.Date finishDateOfSeqWithPOBefore
running
boolean running
seqStartDate
java.util.Date seqStartDate
seqEndDate
java.util.Date seqEndDate
seqActualFinishedDate
java.util.Date seqActualFinishedDate
seqActualBeginDate
java.util.Date seqActualBeginDate
finishPercent
java.math.BigDecimal finishPercent
finished
boolean finished
Class bb.common.WCLoadOnDateResult extends java.lang.Object implements Serializable

Serialized Fields

workTime
java.lang.String workTime
timePeriod
java.util.Set<E> timePeriod
set
java.util.Set<E> set
Class bb.common.WeightUnitVO extends VO implements Serializable

Serialized Fields

weightUnitName
java.lang.String weightUnitName
identifier field

kg
double kg
persistent field

lbs
double lbs
persistent field

Class bb.common.WireTransferAgent extends java.lang.Object implements Serializable

Serialized Fields

includeVendorId
java.lang.String[] includeVendorId
excludeVendorId
java.lang.String[] excludeVendorId
fromDate
java.util.Date fromDate
toDate
java.util.Date toDate
arApNumber
java.lang.String[] arApNumber
wireTransferNo
java.lang.String wireTransferNo
transactionDate
java.util.Date transactionDate
debitAccount
java.lang.String debitAccount
creditAccount
java.lang.String creditAccount
bankTransferFeeAccount
java.lang.String bankTransferFeeAccount
companyUnitOfTransferFeeAcc
java.lang.String companyUnitOfTransferFeeAcc
currency
java.lang.String currency
Class bb.common.WO2WOAgent extends java.lang.Object implements Serializable

Serialized Fields

woNumber
java.lang.String woNumber
vendorId
java.lang.String vendorId
startDate
java.util.Date startDate
dateRequired
java.util.Date dateRequired
Class bb.common.WOIssuedByMonthChartResult extends java.lang.Object implements Serializable

Serialized Fields

totalIssued
java.math.BigDecimal totalIssued
totalRec
java.math.BigDecimal totalRec
totalIssuedCost
java.math.BigDecimal totalIssuedCost
totalRecCost
java.math.BigDecimal totalRecCost
issuedByMonthList
java.util.ArrayList<E> issuedByMonthList
Class bb.common.WOIssuedByMonthResult extends java.lang.Object implements Serializable

Serialized Fields

date
java.util.Date date
issueQuantity
java.math.BigDecimal issueQuantity
recQuantity
java.math.BigDecimal recQuantity
issueCost
java.math.BigDecimal issueCost
recCost
java.math.BigDecimal recCost
Class bb.common.WOItemCostControlAgent extends java.lang.Object implements Serializable

Serialized Fields

pk
WorkOrderItemPK pk
part
BB2Part part
qty
java.math.BigDecimal qty
costAlarm
boolean costAlarm
reviewedBy
java.lang.String reviewedBy
reviewedDate
java.util.Date reviewedDate
reviewedDesc
java.lang.String reviewedDesc
varianceCost
java.math.BigDecimal varianceCost
sumCost
java.math.BigDecimal sumCost
totControlCost
java.math.BigDecimal totControlCost
diffCost
java.math.BigDecimal diffCost
Class bb.common.WOItemPartDetailNotIssue extends java.lang.Object implements Serializable

Serialized Fields

workOrderNumber
java.lang.String workOrderNumber
workOrderItemNumber
java.lang.String workOrderItemNumber
woiQquantity
java.math.BigDecimal woiQquantity
quantityAsm
java.math.BigDecimal quantityAsm
part
BB2Part part
asmPart
BB2Part asmPart
quantity
java.math.BigDecimal quantity
issueQuantity
java.math.BigDecimal issueQuantity
onhand
java.math.BigDecimal onhand
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
startDate
java.util.Date startDate
deliveryDate
java.util.Date deliveryDate
description
java.lang.String description
onorder
java.math.BigDecimal onorder
ondemand
java.math.BigDecimal ondemand
pmList
java.util.List<E> pmList
woItems
java.util.List<E> woItems
Class bb.common.WoItemPickListItemResult extends java.lang.Object implements Serializable

Serialized Fields

woItemIssuePk
WorkOrderItemIssuePK woItemIssuePk
partPk
PartPK partPk
partFrom
java.lang.String partFrom
description
java.lang.String description
partUnit
java.lang.String partUnit
location
java.lang.String location
revision
java.lang.String revision
quantity
java.math.BigDecimal quantity
qtyIssued
java.math.BigDecimal qtyIssued
qtyRequired
java.math.BigDecimal qtyRequired
qtyPicked
java.math.BigDecimal qtyPicked
onhand
java.math.BigDecimal onhand
lastDate
java.util.Date lastDate
warehousePrefix
java.lang.String warehousePrefix
partOnhands
java.util.List<E> partOnhands
comments
java.lang.String comments
Class bb.common.WoItemPickListResult extends java.lang.Object implements Serializable

Serialized Fields

woItemPk
WorkOrderItemPK woItemPk
partPk
PartPK partPk
partFrom
java.lang.String partFrom
revision
java.lang.String revision
changeOrder
java.lang.String changeOrder
description
java.lang.String description
partUnit
java.lang.String partUnit
woStatus
java.lang.String woStatus
woItemStatus
java.lang.String woItemStatus
quantity
java.math.BigDecimal quantity
woDate
java.util.Date woDate
workOrderItemComments
java.lang.String workOrderItemComments
workOrderItemPrivateNotes
java.lang.String workOrderItemPrivateNotes
project
java.lang.String project
vendorId
java.lang.String vendorId
vendorName
java.lang.String vendorName
topOrder
java.lang.String topOrder
dateRequired
java.util.Date dateRequired
startDate
java.util.Date startDate
refDocTwoes
java.util.Set<E> refDocTwoes
items
java.util.Set<E> items
qtyAsm
java.math.BigDecimal qtyAsm
locationPrefix
java.lang.String locationPrefix
Class bb.common.WoItemWorkInstructionListResult extends java.lang.Object implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

workOrderNumber
java.lang.String workOrderNumber
workOrderItemNumber
java.lang.String workOrderItemNumber
part
BB2Part part
description
java.lang.String description
qty
java.math.BigDecimal qty
dueDate
java.util.Date dueDate
Class bb.common.WOReceiverDetail extends java.lang.Object implements Serializable

Serialized Fields

quantity
java.math.BigDecimal quantity
quantityAsm
java.math.BigDecimal quantityAsm
dateRequired
java.util.Date dateRequired
costPerUnit
java.math.BigDecimal costPerUnit
workOrderNumber
java.lang.String workOrderNumber
workOrderItemNumber
java.lang.String workOrderItemNumber
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
qtyAssy
java.math.BigDecimal qtyAssy
dateMade
java.util.Date dateMade
vendorId
java.lang.String vendorId
standardCost
java.math.BigDecimal standardCost
description
java.lang.String description
companyUnitId
java.lang.String companyUnitId
accountNumber
java.lang.String accountNumber
location
java.lang.String location
lastChangeUser
java.lang.String lastChangeUser
project
java.lang.String project
weightUnit
java.lang.String weightUnit
weight
float weight
totalWeight
java.math.BigDecimal totalWeight
comments
java.lang.String comments
Class bb.common.WorkCalendarVO extends VO implements Serializable

Serialized Fields

workDate
java.lang.Long workDate
day
java.lang.String day
comment
java.lang.String comment
timePeriod
java.util.Set<E> timePeriod
date
java.util.Date date
Class bb.common.WorkCenterAgent extends java.lang.Object implements Serializable

Serialized Fields

wcID
java.lang.String wcID
group
boolean group
minDate
java.util.Date minDate
maxDate
java.util.Date maxDate
agents
java.util.HashSet<E> agents
workOrder
java.lang.String workOrder
Class bb.common.WorkCenterGroupItemPK extends java.lang.Object implements Serializable

Serialized Fields

workCenterGroupId
java.lang.String workCenterGroupId
workCenterGroupItemNumber
java.lang.String workCenterGroupItemNumber
Class bb.common.WorkCenterGroupItemVO extends VO implements Serializable

Serialized Fields

pk
WorkCenterGroupItemPK pk
identifier field

workCenterId
java.lang.String workCenterId
persistent field

workCenter
WorkCenterVO workCenter
nullable persistent field

Class bb.common.WorkCenterLoadAgent extends java.lang.Object implements Serializable

Serialized Fields

workCenterLike
java.lang.String workCenterLike
departmentLike
java.lang.String departmentLike
fromDate
java.util.Date fromDate
toDate
java.util.Date toDate
fullload
boolean fullload
Class bb.common.WorkCenterLoadListResult extends java.lang.Object implements Serializable

Serialized Fields

workCenter
java.lang.String workCenter
description
java.lang.String description
department
java.lang.String department
maxLoad
java.math.BigDecimal maxLoad
setupHrs
java.math.BigDecimal setupHrs
loadHrs
java.math.BigDecimal loadHrs
totalHrs
java.math.BigDecimal totalHrs
loadDetailList
java.util.List<E> loadDetailList
group
boolean group
Class bb.common.WorkCenterOnDateAgent extends WorkCenterAgent implements Serializable

Serialized Fields

date
java.util.Date date
endDate
java.util.Date endDate
Class bb.common.WorkCenterRunTimeAgent extends java.lang.Object implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

workCenter
java.lang.String workCenter
fromDate
java.util.Date fromDate
toDate
java.util.Date toDate
Class bb.common.WorkCenterRunTimeListResult extends java.lang.Object implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

workOrderNumber
java.lang.String workOrderNumber
workOrderItemNumber
java.lang.String workOrderItemNumber
part
BB2Part part
description
java.lang.String description
notCompletedQty
java.math.BigDecimal notCompletedQty
dueDate
java.util.Date dueDate
seqNumber
java.lang.String seqNumber
workCenter
java.lang.String workCenter
vendorId
java.lang.String vendorId
avgSetup
java.math.BigDecimal avgSetup
avgHrs
java.math.BigDecimal avgHrs
sumSetup
java.math.BigDecimal sumSetup
sumHrs
java.math.BigDecimal sumHrs
sumTime
java.math.BigDecimal sumTime
Class bb.common.WorkCenterRunTimeTotalResult extends java.lang.Object implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

workCenter
java.lang.String workCenter
fromDate
java.util.Date fromDate
toDate
java.util.Date toDate
sumSetupTime
java.math.BigDecimal sumSetupTime
sumRunTime
java.math.BigDecimal sumRunTime
sumTime
java.math.BigDecimal sumTime
Class bb.common.WorkCenterVendorPK extends java.lang.Object implements Serializable

Serialized Fields

workCenterId
java.lang.String workCenterId
vendorId
java.lang.String vendorId
Class bb.common.WorkCenterVendorVO extends VO implements Serializable

Serialized Fields

pk
WorkCenterVendorPK pk
vendorName
java.lang.String vendorName
defaultVendor
java.lang.String defaultVendor
Class bb.common.WorkCenterVO extends VO implements Serializable

Serialized Fields

workCenterId
java.lang.String workCenterId
identifier field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

origin
java.lang.String origin
persistent field

workCenterGroupId
java.lang.String workCenterGroupId
persistent field

workCenterGroupFlag
java.lang.String workCenterGroupFlag
daysPerWeek
java.math.BigDecimal daysPerWeek
persistent field

department
java.lang.String department
persistent field

description
java.lang.String description
persistent field

costCenter
java.lang.String costCenter
workCenterType
java.lang.String workCenterType
machineQty
java.math.BigDecimal machineQty
machineHoursPerDay
java.math.BigDecimal machineHoursPerDay
machinePerformance
java.math.BigDecimal machinePerformance
machinePay
java.math.BigDecimal machinePay
workerQty
java.math.BigDecimal workerQty
workerHoursPerDay
java.math.BigDecimal workerHoursPerDay
workerPerformance
java.math.BigDecimal workerPerformance
workerPay
java.math.BigDecimal workerPay
parentWorkCenter
WorkCenterVO parentWorkCenter
workCenterItems
java.util.Set<E> workCenterItems
workCenterVendors
java.util.Set<E> workCenterVendors
equipmentID
java.lang.String equipmentID
equipment
EquipmentVO equipment
Class bb.common.WorkFlowVO extends VO implements Serializable

Serialized Fields

createBy
java.lang.String createBy
workFlowName
java.lang.String workFlowName
workFlowData
byte[] workFlowData
lastBy
java.lang.String lastBy
lastChangeDate
java.util.Date lastChangeDate
description
java.lang.String description
Class bb.common.WorkInstructionApprovalVO extends VO implements Serializable

Serialized Fields

employeeId
java.lang.String employeeId
name
java.lang.String name
canApproveOwnWorkInstruction
boolean canApproveOwnWorkInstruction
comments
java.lang.String comments
Class bb.common.WorkInstructionDocumentVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
identifier field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
persistent field

setId
java.lang.String setId
persistent field

docDescription
java.lang.String docDescription
persistent field

documentDate
java.util.Date documentDate
nullable persistent field

comments
java.lang.String comments
nullable persistent field

lastChangeUser
java.lang.String lastChangeUser
nullable persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

extension
java.lang.String extension
persistent field

docFileName
java.lang.String docFileName
persistent field

docLength
long docLength
persistent field

Class bb.common.WorkInstructionListResult extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
setId
java.lang.String setId
workInstructionRev
java.lang.String workInstructionRev
engineeringDescription
java.lang.String engineeringDescription
partRev
java.lang.String partRev
author
java.lang.String author
proofreader
java.lang.String proofreader
status
java.lang.String status
defaultWi
java.lang.String defaultWi
wiNumber
java.lang.String wiNumber
approvedBy
java.lang.String approvedBy
approved
java.util.Date approved
effectiveDate
java.util.Date effectiveDate
wiDescription
java.lang.String wiDescription
Class bb.common.WorkInstructionPictureVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
identifier field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
persistent field

setId
java.lang.String setId
persistent field

sequenceNumber
java.lang.String sequenceNumber
persistent field

itemNumber
java.lang.String itemNumber
lastChangeUser
java.lang.String lastChangeUser
nullable persistent field

picture
byte[] picture
nullable persistent field

width
short width
persistent field

height
short height
persistent field

extension
java.lang.String extension
persistent field

ldate
java.util.Date ldate
nullable persistent field

Class bb.common.WorkInstructionPK extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
identifier field

partType
java.lang.String partType
identifier field

partFrom
java.lang.String partFrom
identifier field

setId
java.lang.String setId
identifier field

Class bb.common.WorkInstructionRequestForChangeVO extends VO implements Serializable

Serialized Fields

rfcNumber
java.lang.String rfcNumber
identifier field

partNumber
java.lang.String partNumber
persistent field

workCenterId
java.lang.String workCenterId
partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
persistent field

setId
java.lang.String setId
persistent field

wiSequence
java.lang.String wiSequence
persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

adate
java.util.Date adate
nullable persistent field

origin
java.lang.String origin
persistent field

departmentId
java.lang.String departmentId
persistent field

originatedDate
java.util.Date originatedDate
persistent field

originator
java.lang.String originator
persistent field

wiDescription
java.lang.String wiDescription
persistent field

descriptionOfChange
java.lang.String descriptionOfChange
nullable persistent field

dueDate
java.util.Date dueDate
persistent field

status
java.lang.String status
persistent field

approvedDate
java.util.Date approvedDate
nullable persistent field

approvedBy
java.lang.String approvedBy
persistent field

wasWiRevised
java.lang.String wasWiRevised
persistent field

wiRevisedDate
java.util.Date wiRevisedDate
persistent field

effectiveDate
java.util.Date effectiveDate
persistent field

lastChangeTimes
int lastChangeTimes
nullable persistent field

Class bb.common.WorkInstructionSeqAuditListResult extends java.lang.Object implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

wiSeqPk
WorkInstructionSequencePK wiSeqPk
partDesc
java.lang.String partDesc
workCenter
java.lang.String workCenter
wcDesc
java.lang.String wcDesc
oldAvgHrs
java.math.BigDecimal oldAvgHrs
newAvgHrs
java.math.BigDecimal newAvgHrs
Class bb.common.WorkInstructionSequenceListResult extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
setId
java.lang.String setId
workCenter
java.lang.String workCenter
wiSequenceNumber
java.lang.String wiSequenceNumber
partDescription
java.lang.String partDescription
author
java.lang.String author
sequenceStatus
java.lang.String sequenceStatus
workInstructionRev
java.lang.String workInstructionRev
wiNumber
java.lang.String wiNumber
Class bb.common.WorkInstructionSequencePK extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
identifier field

partType
java.lang.String partType
identifier field

partFrom
java.lang.String partFrom
identifier field

setId
java.lang.String setId
identifier field

sequenceNumber
java.lang.String sequenceNumber
identifier field

Class bb.common.WorkInstructionSequenceVO extends VO implements Serializable

Serialized Fields

pk
WorkInstructionSequencePK pk
identifier field

sequenceRev
java.lang.String sequenceRev
persistent field

specialProcess
java.lang.String specialProcess
persistent field

toolNumber
java.lang.String toolNumber
persistent field

workCenter
java.lang.String workCenter
persistent field

description
java.lang.String description
persistent field

language2
java.lang.String language2
nullable persistent field

description2
java.lang.String description2
nullable persistent field

language3
java.lang.String language3
nullable persistent field

description3
java.lang.String description3
nullable persistent field

estSetup
java.math.BigDecimal estSetup
persistent field

estSetupH
int estSetupH
persistent field

estSetupM
int estSetupM
persistent field

estSetupS
int estSetupS
persistent field

avgSetup
java.math.BigDecimal avgSetup
persistent field

avgSetupH
int avgSetupH
persistent field

avgSetupM
int avgSetupM
persistent field

avgSetupS
int avgSetupS
persistent field

stdSetup
java.math.BigDecimal stdSetup
persistent field

stdSetupH
int stdSetupH
persistent field

stdSetupM
int stdSetupM
persistent field

stdSetupS
int stdSetupS
persistent field

estHours
java.math.BigDecimal estHours
persistent field

estHoursH
int estHoursH
persistent field

estHoursM
int estHoursM
persistent field

estHoursS
int estHoursS
persistent field

avgHours
java.math.BigDecimal avgHours
persistent field

avgHoursH
int avgHoursH
persistent field

avgHoursM
int avgHoursM
persistent field

avgHoursS
int avgHoursS
persistent field

stdHours
java.math.BigDecimal stdHours
persistent field

stdHoursH
int stdHoursH
persistent field

stdHoursM
int stdHoursM
persistent field

stdHoursS
int stdHoursS
persistent field

ref
java.lang.String ref
persistent field

status
java.lang.String status
persistent field

outSourcing
java.lang.String outSourcing
workInstructionPictures
java.util.Set<E> workInstructionPictures
persistent field

Class bb.common.WorkInstructionSummaryItemResult extends java.lang.Object implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

seqNumber
java.lang.String seqNumber
seqRev
java.lang.String seqRev
workCenter
java.lang.String workCenter
wcDescription
java.lang.String wcDescription
shortDescription
java.lang.String shortDescription
estSetupHrs
java.math.BigDecimal estSetupHrs
avgSetupHrs
java.math.BigDecimal avgSetupHrs
estRunHrs
java.math.BigDecimal estRunHrs
avgRunHrs
java.math.BigDecimal avgRunHrs
status
java.lang.String status
Class bb.common.WorkInstructionSummaryResult extends java.lang.Object implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

setId
java.lang.String setId
part
BB2Part part
rev
java.lang.String rev
description
java.lang.String description
items
java.util.List<E> items
Class bb.common.WorkInstructionVO extends VO implements Serializable

Serialized Fields

pk
WorkInstructionPK pk
identifier field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

adate
java.util.Date adate
nullable persistent field

workInstructionRev
java.lang.String workInstructionRev
persistent field

defaultWi
java.lang.String defaultWi
persistent field

author
java.lang.String author
persistent field

approvedBy
java.lang.String approvedBy
persistent field

approved
java.util.Date approved
nullable persistent field

effectiveDate
java.util.Date effectiveDate
persistent field

proofreader
java.lang.String proofreader
status
java.lang.String status
persistent field

description
java.lang.String description
version
java.lang.Integer version
nullable persistent field

sequences
java.util.Set<E> sequences
persistent field

comment
java.lang.String comment
Class bb.common.WorkOrderApprovalVO extends VO implements Serializable

Serialized Fields

employeeId
java.lang.String employeeId
identifier field

userName
java.lang.String userName
persistent field

approvalLimit
java.math.BigDecimal approvalLimit
persistent field

currency
java.lang.String currency
persistent field

canApproveOwnWorkOrder
java.lang.String canApproveOwnWorkOrder
persistent field

Class bb.common.WorkOrderBoilerplateVO extends VO implements Serializable

Serialized Fields

boilerplateId
java.lang.String boilerplateId
identifier field

description
java.lang.String description
persistent field

woBoilerplate
java.lang.String woBoilerplate
nullable persistent field

Class bb.common.WorkOrderCheckListResult extends java.lang.Object implements Serializable

Serialized Fields

woNumber
java.lang.String woNumber
vendorId
java.lang.String vendorId
originator
java.lang.String originator
woDate
java.util.Date woDate
dueDate
java.util.Date dueDate
status
java.lang.String status
apTotal
java.math.BigDecimal apTotal
currency
java.lang.String currency
vendorName
java.lang.String vendorName
project
java.lang.String project
comments
java.lang.String comments
priority
java.lang.String priority
Class bb.common.WorkOrderDocumentVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
woNumber
java.lang.String woNumber
docDescription
java.lang.String docDescription
documentDate
java.util.Date documentDate
comments
java.lang.String comments
lastChangeUser
java.lang.String lastChangeUser
lastChangeDate
java.util.Date lastChangeDate
extension
java.lang.String extension
docFileName
java.lang.String docFileName
docLength
long docLength
Class bb.common.WorkOrderInfoCenterResult extends java.lang.Object implements Serializable

Serialized Fields

openWOAccount
java.math.BigDecimal openWOAccount
pastDueWOAccount
java.math.BigDecimal pastDueWOAccount
openWOCount
java.lang.Integer openWOCount
pastDueWOCount
java.lang.Integer pastDueWOCount
withPartHoldWOCount
java.lang.Integer withPartHoldWOCount
Class bb.common.WorkOrderInWipResult extends java.lang.Object implements Serializable

Serialized Fields

partPk
PartPK partPk
workOrderItemPk
WorkOrderItemPK workOrderItemPk
woiQty
java.math.BigDecimal woiQty
woiQtyAsm
java.math.BigDecimal woiQtyAsm
quantityDemanded
java.math.BigDecimal quantityDemanded
quantityIssued
java.math.BigDecimal quantityIssued
quantityInWip
java.math.BigDecimal quantityInWip
id
java.lang.String id
deliveryDate
java.util.Date deliveryDate
partFrom
java.lang.String partFrom
delayDays
int delayDays
Class bb.common.WorkOrderIssuedOrderListResult extends java.lang.Object implements Serializable

Serialized Fields

orderNumber
java.lang.String orderNumber
workOrderNumber
java.lang.String workOrderNumber
workOrderItemNumber
java.lang.String workOrderItemNumber
dateIssued
java.util.Date dateIssued
operator
java.lang.String operator
totalIssuedCost
java.math.BigDecimal totalIssuedCost
Class bb.common.WorkOrderIssueStatisticsResult extends java.lang.Object implements Serializable

Serialized Fields

partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
description
java.lang.String description
project
java.lang.String project
totalIssue
java.math.BigDecimal totalIssue
materialShare
java.math.BigDecimal materialShare
subTotal
java.math.BigDecimal subTotal
map
java.util.HashMap<K,V> map
Class bb.common.WorkOrderItemAgent extends java.lang.Object implements Serializable

Serialized Fields

partPk
PartPK partPk
partFrom
java.lang.String partFrom
qty
java.math.BigDecimal qty
Class bb.common.WorkOrderItemCanAssyAgent extends java.lang.Object implements Serializable

Serialized Fields

woNumber
java.lang.String woNumber
partNumber
java.lang.String partNumber
vendorID
java.lang.String vendorID
toDate
java.util.Date toDate
byOnHand
boolean byOnHand
Class bb.common.WorkOrderItemCanAssyResult extends java.lang.Object implements Serializable

Serialized Fields

pk
WorkOrderItemPK pk
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
description
java.lang.String description
startDate
java.util.Date startDate
dateRequired
java.util.Date dateRequired
rev
java.lang.String rev
mfgStatus
java.lang.String mfgStatus
qty
java.math.BigDecimal qty
asm
java.math.BigDecimal asm
avialQty
java.math.BigDecimal avialQty
maxAssyQty
java.math.BigDecimal maxAssyQty
Class bb.common.WorkOrderItemInfoResult extends java.lang.Object implements Serializable

Serialized Fields

workOrderNumber
java.lang.String workOrderNumber
workOrderItemNumber
java.lang.String workOrderItemNumber
masterWorkOrder
boolean masterWorkOrder
relatedDoc
java.lang.String relatedDoc
partNumber
java.lang.String partNumber
partType
java.lang.String partType
quantity
java.math.BigDecimal quantity
quantityAsm
java.math.BigDecimal quantityAsm
description
java.lang.String description
Class bb.common.WorkOrderItemInWipListResult extends java.lang.Object implements Serializable

Serialized Fields

workOrderNumber
java.lang.String workOrderNumber
workOrderItemNumber
java.lang.String workOrderItemNumber
itemNumber
java.lang.Short itemNumber
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
relatedDoc
java.lang.String relatedDoc
partDesc
java.lang.String partDesc
qty
java.math.BigDecimal qty
issuedQty
java.math.BigDecimal issuedQty
originator
java.lang.String originator
mfgStatus
java.lang.String mfgStatus
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
issueAvgCost
java.math.BigDecimal issueAvgCost
dateIssue
java.util.Date dateIssue
currency
java.lang.String currency
avgTotalAmount
java.math.BigDecimal avgTotalAmount
stdTotalAmount
java.math.BigDecimal stdTotalAmount
Class bb.common.WorkOrderItemIssuedTotalResult extends java.lang.Object implements Serializable

Serialized Fields

sequence
int sequence
relatedDoc
java.lang.String relatedDoc
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
description
java.lang.String description
modelNumber
java.lang.String modelNumber
workOrderNumber
java.lang.String workOrderNumber
workOrderItemNumber
java.lang.String workOrderItemNumber
unit
java.lang.String unit
cost
java.math.BigDecimal cost
quantity
java.math.BigDecimal quantity
issueQuantity
java.math.BigDecimal issueQuantity
issuedTotal
java.math.BigDecimal issuedTotal
workOrderItemComments
java.lang.String workOrderItemComments
Class bb.common.WorkOrderItemIssuePK extends java.lang.Object implements Serializable

Serialized Fields

workOrderNumber
java.lang.String workOrderNumber
workOrderItemNumber
java.lang.String workOrderItemNumber
itemNumber
java.lang.Short itemNumber
Class bb.common.WorkOrderItemIssueVO extends VO implements Serializable

Serialized Fields

pk
WorkOrderItemIssuePK pk
referenceDoc1
java.lang.String referenceDoc1
bomLastChangeTimes
int bomLastChangeTimes
bomColor
java.lang.String bomColor
bomLevel
byte bomLevel
bomNumber
java.lang.String bomNumber
bnIi
byte bnIi
bomItemQty
java.math.BigDecimal bomItemQty
bomItemNumber
java.lang.String bomItemNumber
bc
java.lang.String bc
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
modelNumber
java.lang.String modelNumber
revision
java.lang.String revision
description
java.lang.String description
quantity
java.math.BigDecimal quantity
issueQuantity
java.math.BigDecimal issueQuantity
dateIssued
java.util.Date dateIssued
lastDate
java.util.Date lastDate
cost
java.math.BigDecimal cost
unit
java.lang.String unit
serial
java.lang.String serial
lot
java.lang.String lot
comments
java.lang.String comments
replacedItem
java.lang.String replacedItem
inWip
java.math.BigDecimal inWip
partAvgCost
java.math.BigDecimal partAvgCost
scrapQty
java.math.BigDecimal scrapQty
bomScrapQty
java.math.BigDecimal bomScrapQty
mfg
java.lang.String mfg
mpn
java.lang.String mpn
Class bb.common.WorkOrderItemLaborCostListResult extends java.lang.Object implements Serializable

Serialized Fields

workOrderNumber
java.lang.String workOrderNumber
workOrderItemNumber
java.lang.String workOrderItemNumber
vendorId
java.lang.String vendorId
entered
java.util.Date entered
workCenterId
java.lang.String workCenterId
partFrom
java.lang.String partFrom
partNumber
java.lang.String partNumber
partType
java.lang.String partType
itemComments
java.lang.String itemComments
description
java.lang.String description
workerCost
java.math.BigDecimal workerCost
machineCost
java.math.BigDecimal machineCost
totalMfgTime
java.math.BigDecimal totalMfgTime
Class bb.common.WorkOrderItemListResult extends java.lang.Object implements Serializable

Serialized Fields

woItemPk
WorkOrderItemPK woItemPk
partPk
PartPK partPk
partFrom
java.lang.String partFrom
relatedDoc
java.lang.String relatedDoc
partDesc
java.lang.String partDesc
qty
java.math.BigDecimal qty
asm
java.math.BigDecimal asm
nonIssueQty
java.math.BigDecimal nonIssueQty
vendorId
java.lang.String vendorId
vendorName
java.lang.String vendorName
startDate
java.util.Date startDate
dueDate
java.util.Date dueDate
completedDate
java.util.Date completedDate
status
java.lang.String status
unit
java.lang.String unit
originator
java.lang.String originator
comments
java.lang.String comments
notes
java.lang.String notes
refDoc1
java.util.Set<E> refDoc1
refDoc2
java.util.Set<E> refDoc2
mfgStatus
java.lang.String mfgStatus
project
java.lang.String project
priority
java.lang.String priority
woComments
java.lang.String woComments
setId
java.lang.String setId
costPerUnit
java.math.BigDecimal costPerUnit
extendPrice
java.math.BigDecimal extendPrice
currency
java.lang.String currency
accountNumber
java.lang.String accountNumber
companyUnitId
java.lang.String companyUnitId
totalNonIssueCost
java.math.BigDecimal totalNonIssueCost
totalIssuedCost
java.math.BigDecimal totalIssuedCost
partAvgCost
java.math.BigDecimal partAvgCost
inWIPQty
java.math.BigDecimal inWIPQty
wowiPartAvgCost
java.math.BigDecimal wowiPartAvgCost
orderRelatedDoc
java.lang.String orderRelatedDoc
wowiCurrentInstrucationSeq
java.lang.String wowiCurrentInstrucationSeq
wowiCurrentInstrucationSeqWC
java.lang.String wowiCurrentInstrucationSeqWC
wowiCurrentInstrucationSeqWCDesc
java.lang.String wowiCurrentInstrucationSeqWCDesc
toBeAsm
java.math.BigDecimal toBeAsm
canAsm
java.math.BigDecimal canAsm
refDocOnes
java.util.Set<E> refDocOnes
refDocTwoes
java.util.Set<E> refDocTwoes
standardCost
java.math.BigDecimal standardCost
weightUnit
java.lang.String weightUnit
weight
float weight
totalWeight
java.math.BigDecimal totalWeight
totalAsmWeight
java.math.BigDecimal totalAsmWeight
totalToBeAsmWeight
java.math.BigDecimal totalToBeAsmWeight
totalAsmStandardCost
java.math.BigDecimal totalAsmStandardCost
totalToBeAsmStandardCost
java.math.BigDecimal totalToBeAsmStandardCost
Class bb.common.WorkOrderItemPartDetail extends java.lang.Object implements Serializable

Serialized Fields

woItemPk
WorkOrderItemPK woItemPk
partPk
PartPK partPk
partFrom
java.lang.String partFrom
relatedDoc
java.lang.String relatedDoc
partDesc
java.lang.String partDesc
quantity
java.math.BigDecimal quantity
issueQuantity
java.math.BigDecimal issueQuantity
dateIssued
java.util.Date dateIssued
lastDate
java.util.Date lastDate
cost
java.math.BigDecimal cost
unit
java.lang.String unit
status
java.lang.String status
bomNumber
java.lang.String bomNumber
bomItemNumber
java.lang.String bomItemNumber
mfgStatus
java.lang.String mfgStatus
original
java.util.Date original
actual
java.util.Date actual
Class bb.common.WorkOrderItemPartDetailInWipVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
identifier field

workOrderNumber
java.lang.String workOrderNumber
identifier field

workOrderItemNumber
java.lang.String workOrderItemNumber
identifier field

itemNumber
java.lang.Short itemNumber
identifier field

lastChangeUser
java.lang.String lastChangeUser
persistent field

LastChangeDate
java.util.Date LastChangeDate
nullable persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
persistent field

description
java.lang.String description
persistent field

qtyInWip
java.math.BigDecimal qtyInWip
persistent field

cost
java.math.BigDecimal cost
persistent field

stdCost
java.math.BigDecimal stdCost
persistent field

dateIssued
java.util.Date dateIssued
persistent field

woisCost
java.math.BigDecimal woisCost
persistent field

woisStdCost
java.math.BigDecimal woisStdCost
persistent field

companyUnitId
java.lang.String companyUnitId
persistent field

transactionNumber
java.lang.String transactionNumber
persistent field

Class bb.common.WorkOrderItemPartDetailItemResult extends java.lang.Object implements Serializable

Serialized Fields

issueVo
WorkOrderItemIssueVO issueVo
avgCost
java.math.BigDecimal avgCost
stdCost
java.math.BigDecimal stdCost
onhand
java.math.BigDecimal onhand
onorder
java.math.BigDecimal onorder
ondemand
java.math.BigDecimal ondemand
refDoc1Set
java.util.Set<E> refDoc1Set
Class bb.common.WorkOrderItemPartDetailResult extends java.lang.Object implements Serializable

Serialized Fields

woItemPk
WorkOrderItemPK woItemPk
partPk
PartPK partPk
partFrom
java.lang.String partFrom
description
java.lang.String description
quantity
java.math.BigDecimal quantity
bomCost
java.math.BigDecimal bomCost
startDate
java.util.Date startDate
deliveryDate
java.util.Date deliveryDate
wiSetId
java.lang.String wiSetId
status
java.lang.String status
costAlarm
boolean costAlarm
reviewedBy
java.lang.String reviewedBy
reviewedDate
java.util.Date reviewedDate
reviewedDesc
java.lang.String reviewedDesc
varianceCost
java.math.BigDecimal varianceCost
sumCost
java.math.BigDecimal sumCost
totControlCost
java.math.BigDecimal totControlCost
diffCost
java.math.BigDecimal diffCost
refDocTwoes
java.util.Set<E> refDocTwoes
items
java.util.Set<E> items
issuedCost
java.math.BigDecimal issuedCost
shortageCost
java.math.BigDecimal shortageCost
bomStdCost
java.math.BigDecimal bomStdCost
issuedStdCost
java.math.BigDecimal issuedStdCost
shortageStdCost
java.math.BigDecimal shortageStdCost
Class bb.common.WorkOrderItemPK extends java.lang.Object implements Serializable

Serialized Fields

workOrderNumber
java.lang.String workOrderNumber
workOrderItemNumber
java.lang.String workOrderItemNumber
Class bb.common.WorkOrderItemReviewCostResult extends java.lang.Object implements Serializable

Serialized Fields

pk
WorkOrderItemPK pk
vendorId
java.lang.String vendorId
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
quantity
java.math.BigDecimal quantity
quantityAsm
java.math.BigDecimal quantityAsm
description
java.lang.String description
startDate
java.util.Date startDate
dateRequired
java.util.Date dateRequired
reviewedDate
java.util.Date reviewedDate
reviewedBy
java.lang.String reviewedBy
reviewDescription
java.lang.String reviewDescription
originalCost
java.math.BigDecimal originalCost
status
java.lang.String status
varianceCost
java.math.BigDecimal varianceCost
sumCost
java.math.BigDecimal sumCost
totControlCost
java.math.BigDecimal totControlCost
diffCost
java.math.BigDecimal diffCost
overPercent
java.math.BigDecimal overPercent
Class bb.common.WorkOrderItemSeqWCLoadResult extends java.lang.Object implements Serializable

Serialized Fields

pk
WorkOrderItemPK pk
seqNumber
java.lang.String seqNumber
workCenter
java.lang.String workCenter
startDate
java.util.Date startDate
endDate
java.util.Date endDate
actualStartDate
java.util.Date actualStartDate
actualEndDate
java.util.Date actualEndDate
hours
java.math.BigDecimal hours
finish
boolean finish
focusWC
boolean focusWC
outSourcing
java.lang.String outSourcing
completePercent
double completePercent
workCenterItem
int workCenterItem
Class bb.common.WorkOrderItemSetupItemAgent extends java.lang.Object implements Serializable

Serialized Fields

partPk
PartPK partPk
partFrom
java.lang.String partFrom
asmSequenceNo
java.lang.String asmSequenceNo
qty
java.math.BigDecimal qty
replaceItem
java.lang.String replaceItem
parent
BillPK parent
scrapQty
java.math.BigDecimal scrapQty
scrapRate
java.math.BigDecimal scrapRate
replacedItem
java.lang.String replacedItem
cost
java.math.BigDecimal cost
multiQtyforApplying
java.math.BigDecimal multiQtyforApplying
Class bb.common.WorkOrderItemTimeDetailResult extends java.lang.Object implements Serializable

Serialized Fields

woItemPk
WorkOrderItemPK woItemPk
partPk
PartPK partPk
partFrom
java.lang.String partFrom
description
java.lang.String description
quantity
java.math.BigDecimal quantity
totalCost
java.math.BigDecimal totalCost
totalLabor
java.math.BigDecimal totalLabor
total
java.math.BigDecimal total
startDate
java.util.Date startDate
deliveryDate
java.util.Date deliveryDate
wiSetId
java.lang.String wiSetId
status
java.lang.String status
items
java.util.List<E> items
Class bb.common.WorkOrderItemTimeDetailVO extends VO implements Serializable

Serialized Fields

workOrderNumber
java.lang.String workOrderNumber
workOrderItemNumber
java.lang.String workOrderItemNumber
workInstructionSequence
java.lang.String workInstructionSequence
ii
java.lang.Long ii
lastChangeUser
java.lang.String lastChangeUser
workCenter
java.lang.String workCenter
wcActivity
java.lang.String wcActivity
qty
java.math.BigDecimal qty
reject
java.math.BigDecimal reject
employee
java.lang.String employee
timeOn
java.util.Date timeOn
timeOff
java.util.Date timeOff
estHours
java.math.BigDecimal estHours
hours
java.math.BigDecimal hours
cost
java.math.BigDecimal cost
unit
java.lang.String unit
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
modelNumber
java.lang.String modelNumber
revision
java.lang.String revision
description
java.lang.String description
pqty
java.math.BigDecimal pqty
serialNumber
java.lang.String serialNumber
lot
java.lang.String lot
comments
java.lang.String comments
employeeLaborCost
boolean employeeLaborCost
lastChangeDate
java.util.Date lastChangeDate
employeeId
java.lang.String employeeId
vendorId
java.lang.String vendorId
Class bb.common.WorkOrderItemToIssueResult extends java.lang.Object implements Serializable

Serialized Fields

pk
WorkOrderItemPK pk
vendorID
java.lang.String vendorID
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
description
java.lang.String description
qty
java.math.BigDecimal qty
asm
java.math.BigDecimal asm
startDate
java.util.Date startDate
delivery
java.util.Date delivery
Class bb.common.WorkOrderItemVO extends VO implements Serializable

Serialized Fields

pk
WorkOrderItemPK pk
identifier field

masterWorkOrder
boolean masterWorkOrder
relatedDoc
java.lang.String relatedDoc
setId
java.lang.String setId
nullable persistent field

woSub
java.math.BigDecimal woSub
persistent field

woDisc
java.math.BigDecimal woDisc
persistent field

extendPrice
java.math.BigDecimal extendPrice
persistent field

woMade
java.math.BigDecimal woMade
persistent field

woOpen
java.math.BigDecimal woOpen
persistent field

woTax
java.math.BigDecimal woTax
persistent field

woTotal
java.math.BigDecimal woTotal
persistent field

referenceDoc1
java.lang.String referenceDoc1
persistent field

referenceDoc2
java.lang.String referenceDoc2
persistent field

changeOrder
java.lang.String changeOrder
persistent field

qr
java.lang.String qr
persistent field

status
java.lang.String status
persistent field

mfgStatus
java.lang.String mfgStatus
persistent field

startDate
java.util.Date startDate
persistent field

dateRequired
java.util.Date dateRequired
persistent field

desired
java.util.Date desired
persistent field

delayDays
int delayDays
persistent field

priority
java.lang.String priority
persistent field

original
java.util.Date original
persistent field

actual
java.util.Date actual
persistent field

location
java.lang.String location
persistent field

shipVia
java.lang.String shipVia
persistent field

freight
java.math.BigDecimal freight
persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
persistent field

partUnit
java.lang.String partUnit
persistent field

modelNumber
java.lang.String modelNumber
persistent field

revision
java.lang.String revision
persistent field

dwg
java.lang.String dwg
persistent field

wiFlag
java.lang.String wiFlag
persistent field

quantity
java.math.BigDecimal quantity
persistent field

quantityAsm
java.math.BigDecimal quantityAsm
persistent field

hqa
java.math.BigDecimal hqa
persistent field

costPerUnit
java.math.BigDecimal costPerUnit
persistent field

stdCostPerUnit
java.math.BigDecimal stdCostPerUnit
unit
java.lang.String unit
persistent field

list
java.math.BigDecimal list
persistent field

discount
java.math.BigDecimal discount
persistent field

taxRate
java.math.BigDecimal taxRate
persistent field

description
java.lang.String description
persistent field

mfg
java.lang.String mfg
persistent field

mpn
java.lang.String mpn
persistent field

mpnRev
java.lang.String mpnRev
workOrderItemComments
java.lang.String workOrderItemComments
nullable persistent field

workOrderItemPrivateNotes
java.lang.String workOrderItemPrivateNotes
nullable persistent field

costAlarm
boolean costAlarm
persistent field

reviewedDate
java.util.Date reviewedDate
reviewedBy
java.lang.String reviewedBy
persistent field

reviewDescription
java.lang.String reviewDescription
hold
java.lang.String hold
originalCost
java.math.BigDecimal originalCost
overPercent
java.math.BigDecimal overPercent
refDocOnes
java.util.Set<E> refDocOnes
refDocTwoes
java.util.Set<E> refDocTwoes
wowiCurrentInstrucationSeq
java.lang.String wowiCurrentInstrucationSeq
wowiCurrentInstrucationSeqWC
java.lang.String wowiCurrentInstrucationSeqWC
wowiCurrentInstrucationSeqWCDesc
java.lang.String wowiCurrentInstrucationSeqWCDesc
leadTime
java.math.BigDecimal leadTime
icrRequiredWhenReceiverNa
boolean icrRequiredWhenReceiverNa
Class bb.common.WorkOrderItemWCLoadResult extends java.lang.Object implements Serializable

Serialized Fields

pk
WorkOrderItemPK pk
part
BB2Part part
qty
java.math.BigDecimal qty
startDate
java.util.Date startDate
delivery
java.util.Date delivery
finishable
boolean finishable
description
java.lang.String description
items
java.util.List<E> items
Class bb.common.WorkOrderListResult extends java.lang.Object implements Serializable

Serialized Fields

woNumber
java.lang.String woNumber
woDate
java.util.Date woDate
delivery
java.util.Date delivery
vendorId
java.lang.String vendorId
vendorName
java.lang.String vendorName
priority
java.lang.String priority
project
java.lang.String project
comments
java.lang.String comments
status
java.lang.String status
originator
java.lang.String originator
changeOrder
java.lang.String changeOrder
Class bb.common.WorkOrderNotSetupResult extends WorkOrderOnDemandResult implements Serializable

Class bb.common.WorkOrderOnDemandResult extends java.lang.Object implements Serializable

Serialized Fields

partPk
PartPK partPk
partFrom
java.lang.String partFrom
workOrderItemPk
WorkOrderItemPK workOrderItemPk
description
java.lang.String description
workOrderItemQuantity
java.math.BigDecimal workOrderItemQuantity
quantityAsm
java.math.BigDecimal quantityAsm
quantityNotAsm
java.math.BigDecimal quantityNotAsm
refDoc1
java.lang.String refDoc1
refDoc2
java.lang.String refDoc2
quantityDemanded
java.math.BigDecimal quantityDemanded
quantityIssued
java.math.BigDecimal quantityIssued
quantityOnDemand
java.math.BigDecimal quantityOnDemand
id
java.lang.String id
startDate
java.util.Date startDate
deliveryDate
java.util.Date deliveryDate
arriveDate
java.util.Date arriveDate
delayDays
int delayDays
locations
java.util.Map<K,V> locations
Class bb.common.WorkOrderOnOrderResult extends java.lang.Object implements Serializable

Serialized Fields

partPk
PartPK partPk
workOrderItemPk
WorkOrderItemPK workOrderItemPk
description
java.lang.String description
refDoc1
java.lang.String refDoc1
refDoc2
java.lang.String refDoc2
quantityOrdered
java.math.BigDecimal quantityOrdered
quantityAsm
java.math.BigDecimal quantityAsm
quantityOnOrder
java.math.BigDecimal quantityOnOrder
id
java.lang.String id
shipToId
java.lang.String shipToId
deliveryDate
java.util.Date deliveryDate
arriveDate
java.util.Date arriveDate
partFrom
java.lang.String partFrom
delayDays
int delayDays
Class bb.common.WorkOrderOnTimeItemResult extends java.lang.Object implements Serializable

Serialized Fields

month
java.lang.String month
woTotal
java.math.BigDecimal woTotal
woItemCount
int woItemCount
recTotalOnTime
java.math.BigDecimal recTotalOnTime
recItemsOnTimeCount
int recItemsOnTimeCount
notRecTotalOnTime
java.math.BigDecimal notRecTotalOnTime
notRecItemsOnTimeQty
java.math.BigDecimal notRecItemsOnTimeQty
days
java.math.BigDecimal days
Class bb.common.WorkOrderOnTimeResult extends java.lang.Object implements Serializable

Serialized Fields

currency
java.lang.String currency
day1
int day1
day2
int day2
items
java.util.List<E> items
Class bb.common.WorkOrderOverIssueListResult extends java.lang.Object implements Serializable

Serialized Fields

workOrderNumber
java.lang.String workOrderNumber
workOrderItemNumber
java.lang.String workOrderItemNumber
vendorId
java.lang.String vendorId
partPk
PartPK partPk
partFrom
java.lang.String partFrom
partDescription
java.lang.String partDescription
bomQty
java.math.BigDecimal bomQty
setupQty
java.math.BigDecimal setupQty
issueQuantity
java.math.BigDecimal issueQuantity
startDate
java.util.Date startDate
dateRequired
java.util.Date dateRequired
ncr
java.util.Set<E> ncr
Class bb.common.WorkOrderQueryInfo extends java.lang.Object implements Serializable

Serialized Fields

startDate
java.sql.Date startDate
dueDate
java.sql.Date dueDate
wo
java.lang.String wo
wi
java.lang.String wi
partNumber
java.lang.String partNumber
description
java.lang.String description
quantity
java.math.BigDecimal quantity
quantityAsm
java.math.BigDecimal quantityAsm
status
java.lang.String status
relatedDoc
java.lang.String relatedDoc
customerId
java.lang.String customerId
Class bb.common.WorkOrderReceiverVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
identifier field

workOrderNumber
java.lang.String workOrderNumber
identifier field

workOrderItemNumber
java.lang.String workOrderItemNumber
identifier field

lastChangeUser
java.lang.String lastChangeUser
persistent field

LastChangeDate
java.util.Date LastChangeDate
nullable persistent field

refDoc2
java.lang.String refDoc2
persistent field

dateMade
java.util.Date dateMade
persistent field

qtyAssy
java.math.BigDecimal qtyAssy
persistent field

condition
java.lang.String condition
persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
persistent field

modelNumber
java.lang.String modelNumber
persistent field

revision
java.lang.String revision
persistent field

description
java.lang.String description
persistent field

cost
java.math.BigDecimal cost
persistent field

stdCost
java.math.BigDecimal stdCost
unit
java.lang.String unit
persistent field

serial
java.lang.String serial
persistent field

lot
java.lang.String lot
persistent field

transactionNumber
java.lang.String transactionNumber
persistent field

woicCost
java.math.BigDecimal woicCost
persistent field

employeeLaborCost
java.math.BigDecimal employeeLaborCost
woisCost
java.math.BigDecimal woisCost
persistent field

woisStdCost
java.math.BigDecimal woisStdCost
companyUnitId
java.lang.String companyUnitId
persistent field

irNumber
java.lang.String irNumber
location
java.lang.String location
trackings
java.util.Map<K,V> trackings
Class bb.common.WorkOrderTimeCardVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Long ii
employeeId
java.lang.String employeeId
employeeName
java.lang.String employeeName
workOrderNumber
java.lang.String workOrderNumber
workOrderItemNumber
java.lang.String workOrderItemNumber
workCenter
java.lang.String workCenter
workInsctructionSequence
java.lang.String workInsctructionSequence
status
java.lang.String status
partNumber
java.lang.String partNumber
partType
java.lang.String partType
partFrom
java.lang.String partFrom
revision
java.lang.String revision
specialProcess
java.lang.String specialProcess
quantity
java.math.BigDecimal quantity
rejectQty
java.math.BigDecimal rejectQty
woicItem
short woicItem
woisItem
short woisItem
timeOn
java.util.Date timeOn
timeOff
java.util.Date timeOff
finished
boolean finished
vendorId
java.lang.String vendorId
Class bb.common.WorkOrderVO extends VO implements Serializable

Serialized Fields

workOrderNumber
java.lang.String workOrderNumber
identifier field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

adate
java.util.Date adate
nullable persistent field

origin
java.lang.String origin
persistent field

woSub
java.math.BigDecimal woSub
persistent field

woDisc
java.math.BigDecimal woDisc
persistent field

subTotal
java.math.BigDecimal subTotal
persistent field

woMade
java.math.BigDecimal woMade
persistent field

woOpen
java.math.BigDecimal woOpen
persistent field

totalTax
java.math.BigDecimal totalTax
persistent field

totalFreight
java.math.BigDecimal totalFreight
persistent field

grantTotal
java.math.BigDecimal grantTotal
persistent field

changeOrder
java.lang.String changeOrder
persistent field

vendorId
java.lang.String vendorId
persistent field

billToId
java.lang.String billToId
persistent field

po
java.lang.String po
persistent field

contact
java.lang.String contact
persistent field

status
java.lang.String status
persistent field

approved
java.util.Date approved
nullable persistent field

approvedBy
java.lang.String approvedBy
persistent field

originator
java.lang.String originator
persistent field

delivery
java.util.Date delivery
persistent field

desired
java.util.Date desired
persistent field

delay
int delay
persistent field

priority
java.lang.String priority
persistent field

original
java.util.Date original
persistent field

actual
java.lang.String actual
persistent field

shipToId
java.lang.String shipToId
persistent field

shipVia
java.lang.String shipVia
persistent field

shippingAccount
java.lang.String shippingAccount
persistent field

location
java.lang.String location
persistent field

language
java.lang.String language
persistent field

currency
java.lang.String currency
persistent field

terms
java.lang.String terms
persistent field

entered
java.util.Date entered
persistent field

salesman
java.lang.String salesman
persistent field

requestor
java.lang.String requestor
persistent field

project
java.lang.String project
persistent field

relatedDoc
java.lang.String relatedDoc
persistent field

debitAccount
java.lang.String debitAccount
persistent field

bp
java.lang.String bp
persistent field

workOrderComments
java.lang.String workOrderComments
nullable persistent field

workOrderPrivateNotes
java.lang.String workOrderPrivateNotes
nullable persistent field

companyUnitId
java.lang.String companyUnitId
persistent field

useWip
boolean useWip
persistent field

lastChangeTimes
int lastChangeTimes
nullable persistent field

vendorAddressInfo
CustomerVendorAddressInfoVO vendorAddressInfo
nullable persistent field

shipToAddressInfo
CustomerVendorAddressInfoVO shipToAddressInfo
nullable persistent field

billToAddressInfo
CustomerVendorAddressInfoVO billToAddressInfo
nullable persistent field

workOrderItem
java.util.Set<E> workOrderItem
persistent field

boilerplates
java.util.Set<E> boilerplates
coComments
java.lang.String coComments
hold
boolean hold
Class bb.common.WorkOrderWorkInstructionListResult extends java.lang.Object implements Serializable

Serialized Fields

workOrderNumber
java.lang.String workOrderNumber
workOrderItemNumber
java.lang.String workOrderItemNumber
partNumber
java.lang.String partNumber
partType
java.lang.String partType
description
java.lang.String description
status
java.lang.String status
requiredDate
java.util.Date requiredDate
shipDate
java.util.Date shipDate
actualShipDate
java.util.Date actualShipDate
refDoc
java.util.Set<E> refDoc
sequences
java.util.Set<E> sequences
Class bb.common.WorkOrderWorkInstructionPK extends java.lang.Object implements Serializable

Serialized Fields

workOrderNumber
java.lang.String workOrderNumber
identifier field

workOrderItemNumber
java.lang.String workOrderItemNumber
identifier field

Class bb.common.WorkOrderWorkInstructionSequenceDateAgent extends java.lang.Object implements Serializable

Serialized Fields

pk
WorkOrderWorkInstructionSequencePK pk
identifier field

startDate
java.util.Date startDate
identifier field

hours
java.math.BigDecimal hours
identifier field

endDate
java.util.Date endDate
actualStartDate
java.util.Date actualStartDate
actualEndDate
java.util.Date actualEndDate
completePercent
double completePercent
workCenterItem
int workCenterItem
Class bb.common.WorkOrderWorkInstructionSequencePK extends java.lang.Object implements Serializable

Serialized Fields

workOrderNumber
java.lang.String workOrderNumber
identifier field

workOrderItemNumber
java.lang.String workOrderItemNumber
identifier field

workInstructionSequence
java.lang.String workInstructionSequence
identifier field

Class bb.common.WorkOrderWorkInstructionSequenceVO extends VO implements Serializable

Serialized Fields

pk
WorkOrderWorkInstructionSequencePK pk
identifier field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
persistent field

setId
java.lang.String setId
persistent field

startDate
java.util.Date startDate
endDate
java.util.Date endDate
sequanceRev
java.lang.String sequanceRev
persistent field

specialProcess
java.lang.String specialProcess
persistent field

toolNumber
java.lang.String toolNumber
persistent field

workCenterId
java.lang.String workCenterId
persistent field

description
java.lang.String description
persistent field

language2
java.lang.String language2
nullable persistent field

description2
java.lang.String description2
nullable persistent field

language3
java.lang.String language3
nullable persistent field

description3
java.lang.String description3
nullable persistent field

estSetup
java.math.BigDecimal estSetup
persistent field

estSetupH
int estSetupH
persistent field

estSetupM
int estSetupM
persistent field

estSetupS
int estSetupS
persistent field

avgSetup
java.math.BigDecimal avgSetup
persistent field

avgSetupH
int avgSetupH
persistent field

avgSetupM
int avgSetupM
persistent field

avgSetupS
int avgSetupS
persistent field

stdSetup
java.math.BigDecimal stdSetup
persistent field

stdSetupH
int stdSetupH
persistent field

stdSetupM
int stdSetupM
persistent field

estHrs
java.math.BigDecimal estHrs
persistent field

estHrsH
int estHrsH
persistent field

estHrsM
int estHrsM
persistent field

estHrsS
int estHrsS
avgHrs
java.math.BigDecimal avgHrs
persistent field

avgHrsH
int avgHrsH
persistent field

avgHrsM
int avgHrsM
persistent field

avgHrsS
int avgHrsS
persistent field

stdHrs
java.math.BigDecimal stdHrs
persistent field

stdHrsH
int stdHrsH
persistent field

stdHrsM
int stdHrsM
persistent field

stdHrsS
int stdHrsS
persistent field

ref
java.lang.String ref
persistent field

status
java.lang.String status
persistent field

finished
boolean finished
finishedDate
java.util.Date finishedDate
beginDate
java.util.Date beginDate
finishPercent
java.math.BigDecimal finishPercent
outSourcing
java.lang.String outSourcing
calcLoad
java.lang.String calcLoad
workCenterItem
int workCenterItem
Class bb.common.WorkOrderWorkInstructionVO extends VO implements Serializable

Serialized Fields

pk
WorkOrderWorkInstructionPK pk
identifier field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

partFrom
java.lang.String partFrom
persistent field

setId
java.lang.String setId
persistent field

lastChangeUser
java.lang.String lastChangeUser
persistent field

lastChangeDate
java.util.Date lastChangeDate
nullable persistent field

version
java.lang.Integer version
persistent field

adate
java.util.Date adate
nullable persistent field

workInstructionRev
java.lang.String workInstructionRev
persistent field

defaultWi
java.lang.String defaultWi
persistent field

author
java.lang.String author
persistent field

approvedBy
java.lang.String approvedBy
persistent field

approved
java.util.Date approved
nullable persistent field

effectiveDate
java.util.Date effectiveDate
persistent field

proofreader
java.lang.String proofreader
status
java.lang.String status
persistent field

description
java.lang.String description
sequences
java.util.Set<E> sequences
persistent field

qty
java.math.BigDecimal qty
woStartDate
java.util.Date woStartDate
woRequireDate
java.util.Date woRequireDate
comment
java.lang.String comment
Class bb.common.WorkOrderWorkItemDateAgent extends java.lang.Object implements Serializable

Serialized Fields

pk
WorkOrderItemPK pk
identifier field

dateRequired
java.util.Date dateRequired
identifier field

startDate
java.util.Date startDate
Class bb.common.WorkOrderWorkSheetItemPK extends java.lang.Object implements Serializable

Serialized Fields

employeeId
java.lang.String employeeId
identifier field

cartType
java.lang.String cartType
identifier field

workSheetNumber
java.lang.Integer workSheetNumber
identifier field

itemNumber
java.lang.Integer itemNumber
identifier field

Class bb.common.WorkOrderWorkSheetItemVO extends VO implements Serializable

Serialized Fields

pk
WorkOrderWorkSheetItemPK pk
identifier field

lastChangeDate
java.util.Date lastChangeDate
persistent field

lastChangeUser
java.lang.String lastChangeUser
nullable persistent field

makeWo
java.lang.String makeWo
nullable persistent field

makeRfq
java.lang.String makeRfq
persistent field

rfqIds
java.lang.String rfqIds
persistent field

partNumber
java.lang.String partNumber
persistent field

partType
java.lang.String partType
persistent field

delivery
java.util.Date delivery
persistent field

quantity
java.math.BigDecimal quantity
nullable persistent field

monthQty
java.math.BigDecimal monthQty
persistent field

months
int months
persistent field

comments
java.lang.String comments
nullable persistent field

privateNotes
java.lang.String privateNotes
nullable persistent field

vendId
java.lang.Byte vendId
nullable persistent field

mfgId
short mfgId
persistent field

mfgIds
java.lang.String mfgIds
persistent field

vendIdWritein
java.lang.String vendIdWritein
persistent field

rfqIdWritein
java.lang.String rfqIdWritein
persistent field

Class bb.common.WorkOrderWorkSheetItemWithRelatedInfoResult extends java.lang.Object implements Serializable

Serialized Fields

partBasicInfo
PartBasicInfo partBasicInfo
partInventoryVO
PartInventoryVO partInventoryVO
partVendors
java.util.List<E> partVendors
partManufacturers
java.util.List<E> partManufacturers
toolBasicInfo
ToolBasicInfo toolBasicInfo
toolInventoryVO
ToolInventoryVO toolInventoryVO
workSheetItem
WorkOrderWorkSheetItemVO workSheetItem
Class bb.common.WorkOrderWorkSheetPK extends java.lang.Object implements Serializable

Serialized Fields

employeeId
java.lang.String employeeId
identifier field

cartType
java.lang.String cartType
identifier field

workSheetNumber
java.lang.Integer workSheetNumber
identifier field

Class bb.common.WorkOrderWorkSheetVO extends VO implements Serializable

Serialized Fields

pk
WorkOrderWorkSheetPK pk
identifier field

employeeEmail
java.lang.String employeeEmail
persistent field

description
java.lang.String description
persistent field

dueDate
java.util.Date dueDate
nullable persistent field

companyUnitId
java.lang.String companyUnitId
persistent field

debitAccount
java.lang.String debitAccount
persistent field

workOrderWorkSheetItem
java.util.Set<E> workOrderWorkSheetItem
persistent field

publicWorkSheet
boolean publicWorkSheet
publicToEvery
boolean publicToEvery
publicToUser
java.lang.String publicToUser
Class bb.common.WorkPeriodVO extends VO implements Serializable

Serialized Fields

ii
long ii
workDate
java.lang.Long workDate
dateFrom
java.util.Date dateFrom
dateTo
java.util.Date dateTo
Class bb.common.WorkSheetPartAgent extends java.lang.Object implements Serializable

Serialization Methods

readObject
private void readObject(java.io.ObjectInputStream ois)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
Throws:
java.io.IOException
java.lang.ClassNotFoundException

writeObject
private void writeObject(java.io.ObjectOutputStream oos)
                  throws java.io.IOException
Throws:
java.io.IOException

Serialized Fields

partPk
PartPK partPk
qty
java.math.BigDecimal qty
qtyMonths
java.math.BigDecimal qtyMonths
months
java.lang.Integer months
delivery
java.util.Date delivery
Class bb.common.ZipCodeTaxVO extends VO implements Serializable

Serialized Fields

ii
java.lang.Integer ii
taxType
java.lang.String taxType
zipTo
java.lang.String zipTo
taxRate
java.math.BigDecimal taxRate
Class bb.common.ZipcodeTotalsResult extends java.lang.Object implements Serializable

Serialized Fields

zipCode
java.lang.String zipCode
zipCodeFrom
java.lang.String zipCodeFrom
zipCodeTo
java.lang.String zipCodeTo
description
java.lang.String description
totalTax
java.math.BigDecimal totalTax
taxRate
java.math.BigDecimal taxRate
grandTotal
java.math.BigDecimal grandTotal
customerID
java.lang.String customerID
customerName
java.lang.String customerName
shipToID
java.lang.String shipToID
shipToName
java.lang.String shipToName
address1
java.lang.String address1
address2
java.lang.String address2
taxType
java.lang.String taxType
cityName
java.lang.String cityName
parentName
java.lang.String parentName
taxExempt
boolean taxExempt
validDate
java.util.Date validDate
taxNumber
java.lang.String taxNumber
runningAccountNumber
java.lang.String runningAccountNumber
cityOrCountyCode
java.lang.String cityOrCountyCode
totalSales
java.math.BigDecimal totalSales
totalExemptions
java.math.BigDecimal totalExemptions
netTaxableSales
java.math.BigDecimal netTaxableSales
orderNumber
java.lang.String orderNumber
item
java.lang.String item
date
java.util.Date date
Class bb.common.ZipCodeVO extends VO implements Serializable

Serialized Fields

zipId
java.lang.String zipId
zipName
java.lang.String zipName
Class bb.common.ZippedByteArray extends java.lang.Object implements Serializable

Serialized Fields

data
byte[] data
Overview

Package

Class

Use

Tree

Deprecated

Index

Help

PREV NEXT

FRAMES NO FRAMES


SerialNumberItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SerialNumberItemPK

java.lang.Object
    extended by  bb.common.SerialNumberItemPK
All Implemented Interfaces:
java.io.Serializable
public class SerialNumberItemPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
SerialNumberItemPK()
default constructor
SerialNumberItemPK(java.lang.String commanyName, java.lang.String serialNumber, java.lang.String serialNumberItemNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCommanyName()
java.lang.String | getSerialNumber()
java.lang.String | getSerialNumberItemNumber()
int | hashCode()
void | setCommanyName(java.lang.String commanyName)
void | setSerialNumber(java.lang.String serialNumber)
void | setSerialNumberItemNumber(java.lang.String serialNumberItemNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SerialNumberItemPK

public SerialNumberItemPK(java.lang.String commanyName,
                          java.lang.String serialNumber,
                          java.lang.String serialNumberItemNumber)
full constructor

SerialNumberItemPK

public SerialNumberItemPK()
default constructor

Method Detail

getCommanyName

public java.lang.String getCommanyName()

setCommanyName

public void setCommanyName(java.lang.String commanyName)

getSerialNumber

public java.lang.String getSerialNumber()

setSerialNumber

public void setSerialNumber(java.lang.String serialNumber)

getSerialNumberItemNumber

public java.lang.String getSerialNumberItemNumber()

setSerialNumberItemNumber

public void setSerialNumberItemNumber(java.lang.String serialNumberItemNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SerialNumberItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SerialNumberItemResult

java.lang.Object
    extended by  bb.common.SerialNumberItemResult
All Implemented Interfaces:
java.io.Serializable
public class SerialNumberItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SerialNumberItemResult()
Method Summary
java.lang.String | getCompanyName()
java.lang.Integer | getControl()
java.lang.String | getDescription()
java.lang.String | getItemNumber()
java.lang.Long | getLength()
BB2Part | getPart()
java.lang.String | getPartDescription()
java.lang.String | getSerialNumber()
void | setCompanyName(java.lang.String companyName)
void | setControl(java.lang.Integer control)
void | setDescription(java.lang.String description)
void | setItemNumber(java.lang.String itemNumber)
void | setLength(java.lang.Long length)
void | setPart(BB2Part part)
void | setPartDescription(java.lang.String partDescription)
void | setSerialNumber(java.lang.String serialNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SerialNumberItemResult

public SerialNumberItemResult()
Method Detail

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

setSerialNumber

public void setSerialNumber(java.lang.String serialNumber)

setCompanyName

public void setCompanyName(java.lang.String companyName)

setControl

public void setControl(java.lang.Integer control)

setDescription

public void setDescription(java.lang.String description)

setPart

public void setPart(BB2Part part)

setPartDescription

public void setPartDescription(java.lang.String partDescription)

setLength

public void setLength(java.lang.Long length)

getItemNumber

public java.lang.String getItemNumber()

getSerialNumber

public java.lang.String getSerialNumber()

getCompanyName

public java.lang.String getCompanyName()

getControl

public java.lang.Integer getControl()

getDescription

public java.lang.String getDescription()

getPart

public BB2Part getPart()

getPartDescription

public java.lang.String getPartDescription()

getLength

public java.lang.Long getLength()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SerialNumberItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SerialNumberItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SerialNumberItemVO
All Implemented Interfaces:
java.io.Serializable
public class SerialNumberItemVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
SerialNumberItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCertificateNumber()
SerialNumberItemPK | getPk()
int | hashCode()
void | setCertificateNumber(java.lang.String certificateNumber)
void | setPk(SerialNumberItemPK pk)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SerialNumberItemVO

public SerialNumberItemVO()
Method Detail

getPk

public SerialNumberItemPK getPk()

setPk

public void setPk(SerialNumberItemPK pk)

getCertificateNumber

public java.lang.String getCertificateNumber()

setCertificateNumber

public void setCertificateNumber(java.lang.String certificateNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SerialNumberPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SerialNumberPK

java.lang.Object
    extended by  bb.common.SerialNumberPK
All Implemented Interfaces:
java.io.Serializable
public class SerialNumberPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
SerialNumberPK()
default constructor
SerialNumberPK(java.lang.String commanyName, java.lang.String serialNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCommanyName()
java.lang.String | getSerialNumber()
int | hashCode()
void | setCommanyName(java.lang.String commanyName)
void | setSerialNumber(java.lang.String serialNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SerialNumberPK

public SerialNumberPK(java.lang.String commanyName,
                      java.lang.String serialNumber)
full constructor

SerialNumberPK

public SerialNumberPK()
default constructor

Method Detail

getCommanyName

public java.lang.String getCommanyName()

setCommanyName

public void setCommanyName(java.lang.String commanyName)

getSerialNumber

public java.lang.String getSerialNumber()

setSerialNumber

public void setSerialNumber(java.lang.String serialNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SerialNumberResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SerialNumberResult

java.lang.Object
    extended by  bb.common.SerialNumberResult
All Implemented Interfaces:
java.io.Serializable
public class SerialNumberResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SerialNumberResult()
Method Summary
java.util.Date | getCertificateDate()
java.lang.String | getComments()
java.lang.String | getCompanyName()
java.lang.Integer | getControl()
java.lang.String | getDescription()
java.util.ArrayList | getItems()
java.lang.Long | getLength()
BB2Part | getPart()
java.lang.String | getPartDescription()
java.lang.String | getPoNumber()
java.lang.String | getReceNumber()
java.lang.String | getRefNumber()
java.lang.String | getRevision()
java.lang.String | getSerialNubmer()
java.lang.String | getSoNumber()
java.lang.String | getWoNumber()
void | setCertificateDate(java.util.Date certificateDate)
void | setComments(java.lang.String comments)
void | setCompanyName(java.lang.String companyName)
void | setControl(java.lang.Integer control)
void | setDescription(java.lang.String description)
void | setItems(java.util.ArrayList items)
void | setLength(java.lang.Long length)
void | setPart(BB2Part part)
void | setPartDescription(java.lang.String partDescription)
void | setPoNumber(java.lang.String poNumber)
void | setReceNumber(java.lang.String receNumber)
void | setRefNumber(java.lang.String refNumber)
void | setRevision(java.lang.String revision)
void | setSerialNubmer(java.lang.String serialNubmer)
void | setSoNumber(java.lang.String soNumber)
void | setWoNumber(java.lang.String woNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SerialNumberResult

public SerialNumberResult()
Method Detail

setSerialNubmer

public void setSerialNubmer(java.lang.String serialNubmer)

setCompanyName

public void setCompanyName(java.lang.String companyName)

setDescription

public void setDescription(java.lang.String description)

setPartDescription

public void setPartDescription(java.lang.String partDescription)

setControl

public void setControl(java.lang.Integer control)

setPart

public void setPart(BB2Part part)

setItems

public void setItems(java.util.ArrayList items)

setLength

public void setLength(java.lang.Long length)

getSerialNubmer

public java.lang.String getSerialNubmer()

getCompanyName

public java.lang.String getCompanyName()

getDescription

public java.lang.String getDescription()

getPartDescription

public java.lang.String getPartDescription()

getControl

public java.lang.Integer getControl()

getPart

public BB2Part getPart()

getItems

public java.util.ArrayList getItems()

getLength

public java.lang.Long getLength()

getCertificateDate

public java.util.Date getCertificateDate()

setCertificateDate

public void setCertificateDate(java.util.Date certificateDate)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getPoNumber

public java.lang.String getPoNumber()

setPoNumber

public void setPoNumber(java.lang.String poNumber)

getReceNumber

public java.lang.String getReceNumber()

setReceNumber

public void setReceNumber(java.lang.String receNumber)

getRefNumber

public java.lang.String getRefNumber()

setRefNumber

public void setRefNumber(java.lang.String refNumber)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getSoNumber

public java.lang.String getSoNumber()

setSoNumber

public void setSoNumber(java.lang.String soNumber)

getWoNumber

public java.lang.String getWoNumber()

setWoNumber

public void setWoNumber(java.lang.String woNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SerialNumberVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SerialNumberVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SerialNumberVO
All Implemented Interfaces:
java.io.Serializable
public class SerialNumberVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
SerialNumberVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
SerialNumberPK | getPk()
java.util.Set | getSerialNumberItems()
java.lang.Integer | getVersion()
int | hashCode()
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setPk(SerialNumberPK pk)
void | setSerialNumberItems(java.util.Set serialNumberItems)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SerialNumberVO

public SerialNumberVO()
default constructor

Method Detail

getPk

public SerialNumberPK getPk()

setPk

public void setPk(SerialNumberPK pk)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getSerialNumberItems

public java.util.Set getSerialNumberItems()

getVersion

public java.lang.Integer getVersion()

setSerialNumberItems

public void setSerialNumberItems(java.util.Set serialNumberItems)

setVersion

public void setVersion(java.lang.Integer version)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ServerAction

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ServerAction

java.lang.Object
    extended by  bb.common.ServerAction
All Implemented Interfaces:
java.io.Serializable
public class ServerAction
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ServerAction(java.lang.String moduleName, java.lang.String method)
ServerAction(java.lang.String moduleName, java.lang.String method, java.lang.Object[] params, java.lang.Class[] paramTypes)
Method Summary
DynamicSearchFilter | getDynamicSearchFilter()
java.lang.Object | getId()
java.lang.String | getMethod()
java.lang.String | getModuleName()
OrderBy | getOrderBy()
java.lang.Object[] | getParams()
java.lang.Class[] | getParamTypes()
void | setDynamicSearchFilter(DynamicSearchFilter dynamicSearchFilter)
void | setId(java.lang.Object id)
void | setOrderBy(OrderBy orderBy)
java.lang.String | toString()
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ServerAction

public ServerAction(java.lang.String moduleName,
                    java.lang.String method,
                    java.lang.Object[] params,
                    java.lang.Class[] paramTypes)

ServerAction

public ServerAction(java.lang.String moduleName,
                    java.lang.String method)
Method Detail

getId

public java.lang.Object getId()

setId

public void setId(java.lang.Object id)

setOrderBy

public void setOrderBy(OrderBy orderBy)

getModuleName

public java.lang.String getModuleName()

getMethod

public java.lang.String getMethod()

getParams

public java.lang.Object[] getParams()

getParamTypes

public java.lang.Class[] getParamTypes()

getOrderBy

public OrderBy getOrderBy()

getDynamicSearchFilter

public DynamicSearchFilter getDynamicSearchFilter()

setDynamicSearchFilter

public void setDynamicSearchFilter(DynamicSearchFilter dynamicSearchFilter)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ServerClientPropertyPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ServerClientPropertyPK

java.lang.Object
    extended by  bb.common.ServerClientPropertyPK
All Implemented Interfaces:
java.io.Serializable
public class ServerClientPropertyPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ServerClientPropertyPK()
Method Summary
boolean | equals(java.lang.Object obj)
java.lang.String | getId()
java.lang.String | getOwner()
int | hashCode()
void | setId(java.lang.String id)
void | setOwner(java.lang.String owner)
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ServerClientPropertyPK

public ServerClientPropertyPK()
Method Detail

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getOwner

public java.lang.String getOwner()

setOwner

public void setOwner(java.lang.String owner)

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ServerClientPropertyVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ServerClientPropertyVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ServerClientPropertyVO
All Implemented Interfaces:
java.io.Serializable
public class ServerClientPropertyVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ServerClientPropertyVO()
Method Summary
java.util.Date | getCreateDate()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
ServerClientPropertyPK | getPk()
java.lang.String | getValue()
void | setCreateDate(java.util.Date createDate)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setPk(ServerClientPropertyPK pk)
void | setValue(java.lang.String value)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ServerClientPropertyVO

public ServerClientPropertyVO()
Method Detail

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getPk

public ServerClientPropertyPK getPk()

setPk

public void setPk(ServerClientPropertyPK pk)

getValue

public java.lang.String getValue()

setValue

public void setValue(java.lang.String value)

getCreateDate

public java.util.Date getCreateDate()

setCreateDate

public void setCreateDate(java.util.Date createDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ServerException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ServerException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  bb.common.ServerException
All Implemented Interfaces:
java.io.Serializable
public class ServerException
extends java.lang.Exception

See Also:
Serialized Form

Field Summary
static java.lang.String UNKNOWN_EXCEPTION
Constructor Summary
ServerException()
ServerException(java.lang.Exception e)
ServerException(java.lang.Exception e, java.lang.String reason)
ServerException(java.lang.String reason)
Method Summary
java.lang.String | getReason()
void | setReason(java.lang.String reason)
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

UNKNOWN_EXCEPTION

public static final java.lang.String UNKNOWN_EXCEPTION
See Also:
Constant Field Values
Constructor Detail

ServerException

public ServerException()

ServerException

public ServerException(java.lang.Exception e)

ServerException

public ServerException(java.lang.Exception e,
                       java.lang.String reason)

ServerException

public ServerException(java.lang.String reason)
Method Detail

setReason

public void setReason(java.lang.String reason)

getReason

public java.lang.String getReason()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGBillItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGBillItemPK

java.lang.Object
    extended by  bb.common.SGBillItemPK
All Implemented Interfaces:
java.io.Serializable
public class SGBillItemPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
SGBillItemPK()
default constructor
SGBillItemPK(java.lang.String billNumber, java.lang.String billType, java.lang.String itemNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getBillNumber()
java.lang.String | getBillType()
java.lang.String | getItemNumber()
int | hashCode()
void | setBillNumber(java.lang.String billNumber)
void | setBillType(java.lang.String billType)
void | setItemNumber(java.lang.String itemNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SGBillItemPK

public SGBillItemPK(java.lang.String billNumber,
                    java.lang.String billType,
                    java.lang.String itemNumber)
full constructor

SGBillItemPK

public SGBillItemPK()
default constructor

Method Detail

getBillNumber

public java.lang.String getBillNumber()

setBillNumber

public void setBillNumber(java.lang.String billNumber)

getBillType

public java.lang.String getBillType()

setBillType

public void setBillType(java.lang.String billType)

getItemNumber

public java.lang.String getItemNumber()

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGBillItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGBillItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SGBillItemVO
All Implemented Interfaces:
java.io.Serializable
public class SGBillItemVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
SGBillItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getBc()
java.math.BigDecimal | getItemQty()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
SGBillItemPK | getPk()
int | hashCode()
void | setBc(java.lang.String bc)
void | setItemQty(java.math.BigDecimal itemQty)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(SGBillItemPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SGBillItemVO

public SGBillItemVO()
Method Detail

getPk

public SGBillItemPK getPk()

setPk

public void setPk(SGBillItemPK pk)

getBc

public java.lang.String getBc()

setBc

public void setBc(java.lang.String bc)

getItemQty

public java.math.BigDecimal getItemQty()

setItemQty

public void setItemQty(java.math.BigDecimal itemQty)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGBOMItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGBOMItemResult

java.lang.Object
    extended by  bb.common.SGBOMItemResult
All Implemented Interfaces:
java.io.Serializable
public class SGBOMItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SGBOMItemResult()
Method Summary
java.lang.String | getBill()
java.lang.String | getBillItemNumber()
java.lang.String | getDescripiton()
java.lang.String | getDwg()
java.lang.String | getHasPicture()
java.math.BigDecimal | getOnhand()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getQty()
java.lang.String | getRevision()
java.lang.String | getUnit()
java.math.BigDecimal | getVolume()
java.lang.String | getVolumeUnit()
float | getWeight()
java.lang.String | getWeightUnit()
void | setBill(java.lang.String bill)
void | setBillItemNumber(java.lang.String billItemNumber)
void | setDescripiton(java.lang.String descripiton)
void | setDwg(java.lang.String dwg)
void | setHasPicture(java.lang.String hasPicture)
void | setOnhand(java.math.BigDecimal onhand)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setQty(java.math.BigDecimal qty)
void | setRevision(java.lang.String revision)
void | setUnit(java.lang.String unit)
void | setVolume(java.math.BigDecimal volume)
void | setVolumeUnit(java.lang.String volumeUnit)
void | setWeight(float weight)
void | setWeightUnit(java.lang.String weightUnit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SGBOMItemResult

public SGBOMItemResult()
Method Detail

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getDescripiton

public java.lang.String getDescripiton()

setDescripiton

public void setDescripiton(java.lang.String descripiton)

getDwg

public java.lang.String getDwg()

setDwg

public void setDwg(java.lang.String dwg)

getHasPicture

public java.lang.String getHasPicture()

setHasPicture

public void setHasPicture(java.lang.String hasPicture)

getBill

public java.lang.String getBill()

setBill

public void setBill(java.lang.String bill)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

getWeight

public float getWeight()

setWeight

public void setWeight(float weight)

getWeightUnit

public java.lang.String getWeightUnit()

setWeightUnit

public void setWeightUnit(java.lang.String weightUnit)

getVolume

public java.math.BigDecimal getVolume()

setVolume

public void setVolume(java.math.BigDecimal volume)

getVolumeUnit

public java.lang.String getVolumeUnit()

setVolumeUnit

public void setVolumeUnit(java.lang.String volumeUnit)

getOnhand

public java.math.BigDecimal getOnhand()

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

getBillItemNumber

public java.lang.String getBillItemNumber()

setBillItemNumber

public void setBillItemNumber(java.lang.String billItemNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGBOMResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGBOMResult

java.lang.Object
    extended by  bb.common.SGBOMResult
All Implemented Interfaces:
java.io.Serializable
public class SGBOMResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SGBOMResult()
Method Summary
SGBOMItemResult | getBom()
java.util.List<SGBOMItemResult> | getItems()
void | setBom(SGBOMItemResult bom)
void | setItems(java.util.List<SGBOMItemResult> items)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SGBOMResult

public SGBOMResult()
Method Detail

getBom

public SGBOMItemResult getBom()

setBom

public void setBom(SGBOMItemResult bom)

getItems

public java.util.List<SGBOMItemResult> getItems()

setItems

public void setItems(java.util.List<SGBOMItemResult> items)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGCartCheckOutResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGCartCheckOutResult

java.lang.Object
    extended by  bb.common.SGCartCheckOutResult
All Implemented Interfaces:
java.io.Serializable
public class SGCartCheckOutResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SGCartCheckOutResult()
Method Summary
java.lang.String | getAddr1()
java.lang.String | getAddr2()
java.lang.String | getCity()
java.lang.String | getContactName()
java.lang.String | getCountry()
java.lang.String | getFax()
java.util.List<SGQuoteCartListResult> | getItems()
java.lang.String | getName()
java.lang.String | getPhone()
java.lang.String | getState()
java.lang.String | getUserEmail()
java.lang.String | getZip()
void | setAddr1(java.lang.String addr1)
void | setAddr2(java.lang.String addr2)
void | setCity(java.lang.String city)
void | setContactName(java.lang.String contactName)
void | setCountry(java.lang.String country)
void | setFax(java.lang.String fax)
void | setItems(java.util.List<SGQuoteCartListResult> items)
void | setName(java.lang.String name)
void | setPhone(java.lang.String phone)
void | setState(java.lang.String state)
void | setUserEmail(java.lang.String userEmail)
void | setZip(java.lang.String zip)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SGCartCheckOutResult

public SGCartCheckOutResult()
Method Detail

getAddr1

public java.lang.String getAddr1()

setAddr1

public void setAddr1(java.lang.String addr1)

getAddr2

public java.lang.String getAddr2()

setAddr2

public void setAddr2(java.lang.String addr2)

getCity

public java.lang.String getCity()

setCity

public void setCity(java.lang.String city)

getContactName

public java.lang.String getContactName()

setContactName

public void setContactName(java.lang.String contactName)

getCountry

public java.lang.String getCountry()

setCountry

public void setCountry(java.lang.String country)

getFax

public java.lang.String getFax()

setFax

public void setFax(java.lang.String fax)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getPhone

public java.lang.String getPhone()

setPhone

public void setPhone(java.lang.String phone)

getState

public java.lang.String getState()

setState

public void setState(java.lang.String state)

getUserEmail

public java.lang.String getUserEmail()

setUserEmail

public void setUserEmail(java.lang.String userEmail)

getZip

public java.lang.String getZip()

setZip

public void setZip(java.lang.String zip)

getItems

public java.util.List<SGQuoteCartListResult> getItems()

setItems

public void setItems(java.util.List<SGQuoteCartListResult> items)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGCartLogin

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGCartLogin

java.lang.Object
    extended by  bb.common.SGCartLogin
All Implemented Interfaces:
java.io.Serializable
public class SGCartLogin
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SGCartLogin()
Method Summary
java.lang.String | getPassword()
java.lang.String | getUserEmail()
void | setPassword(java.lang.String password)
void | setUserEmail(java.lang.String userEmail)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SGCartLogin

public SGCartLogin()
Method Detail

getPassword

public java.lang.String getPassword()

setPassword

public void setPassword(java.lang.String password)

getUserEmail

public java.lang.String getUserEmail()

setUserEmail

public void setUserEmail(java.lang.String userEmail)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGClientAccountPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGClientAccountPK

java.lang.Object
    extended by  bb.common.SGClientAccountPK
All Implemented Interfaces:
java.io.Serializable
public class SGClientAccountPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
SGClientAccountPK()
default constructor
SGClientAccountPK(java.lang.String client, java.lang.String user)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getClient()
java.lang.String | getUser()
int | hashCode()
void | setClient(java.lang.String client)
void | setUser(java.lang.String user)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SGClientAccountPK

public SGClientAccountPK(java.lang.String client,
                         java.lang.String user)
full constructor

SGClientAccountPK

public SGClientAccountPK()
default constructor

Method Detail

getClient

public java.lang.String getClient()

setClient

public void setClient(java.lang.String client)

getUser

public java.lang.String getUser()

setUser

public void setUser(java.lang.String user)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGClientAccountVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGClientAccountVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SGClientAccountVO
All Implemented Interfaces:
java.io.Serializable
public class SGClientAccountVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
SGClientAccountVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getLevel()
java.lang.String | getPassword()
SGClientAccountPK | getPk()
java.lang.String | getUserCompany()
java.lang.String | getUserName()
int | hashCode()
void | setLevel(java.lang.String level)
void | setPassword(java.lang.String password)
void | setPk(SGClientAccountPK pk)
void | setUserCompany(java.lang.String userCompany)
void | setUserName(java.lang.String userName)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SGClientAccountVO

public SGClientAccountVO()
Method Detail

getPk

public SGClientAccountPK getPk()

setPk

public void setPk(SGClientAccountPK pk)

getPassword

public java.lang.String getPassword()

setPassword

public void setPassword(java.lang.String password)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getUserCompany

public java.lang.String getUserCompany()

setUserCompany

public void setUserCompany(java.lang.String userCompany)

getLevel

public java.lang.String getLevel()

setLevel

public void setLevel(java.lang.String level)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGClientLogin

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGClientLogin

java.lang.Object
    extended by  bb.common.SGClientLogin
All Implemented Interfaces:
java.io.Serializable
public class SGClientLogin
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SGClientLogin()
Method Summary
java.lang.String | getClient()
java.lang.String | getLoginName()
java.lang.String | getPassword()
void | setClient(java.lang.String client)
void | setLoginName(java.lang.String loginName)
void | setPassword(java.lang.String password)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SGClientLogin

public SGClientLogin()
Method Detail

getClient

public java.lang.String getClient()

setClient

public void setClient(java.lang.String client)

getLoginName

public java.lang.String getLoginName()

setLoginName

public void setLoginName(java.lang.String loginName)

getPassword

public java.lang.String getPassword()

setPassword

public void setPassword(java.lang.String password)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SgClientProgramUserVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SgClientProgramUserVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SgClientProgramUserVO
All Implemented Interfaces:
java.io.Serializable
public class SgClientProgramUserVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
SgClientProgramUserVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCustID()
CustomerVendorAddressInfoVO | getCustomerAddressInfo()
java.lang.String | getFax()
java.lang.String | getFullName()
java.lang.String | getLanguage()
java.lang.String | getMobile()
java.lang.String | getPassword()
java.lang.String | getPhone()
java.lang.String | getReceiver()
java.lang.String | getType()
java.lang.String | getUserEmail()
java.lang.String | getUserName()
int | hashCode()
void | setCustID(java.lang.String custID)
void | setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | setFax(java.lang.String fax)
void | setFullName(java.lang.String fullName)
void | setLanguage(java.lang.String language)
void | setMobile(java.lang.String mobile)
void | setPassword(java.lang.String password)
void | setPhone(java.lang.String phone)
void | setReceiver(java.lang.String receiver)
void | setType(java.lang.String type)
void | setUserEmail(java.lang.String userEmail)
void | setUserName(java.lang.String userName)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SgClientProgramUserVO

public SgClientProgramUserVO()
Method Detail

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getPassword

public java.lang.String getPassword()

setPassword

public void setPassword(java.lang.String password)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getFullName

public java.lang.String getFullName()

setFullName

public void setFullName(java.lang.String fullName)

getPhone

public java.lang.String getPhone()

setPhone

public void setPhone(java.lang.String phone)

getMobile

public java.lang.String getMobile()

setMobile

public void setMobile(java.lang.String mobile)

getFax

public java.lang.String getFax()

setFax

public void setFax(java.lang.String fax)

getUserEmail

public java.lang.String getUserEmail()

setUserEmail

public void setUserEmail(java.lang.String userEmail)

getCustID

public java.lang.String getCustID()

setCustID

public void setCustID(java.lang.String custID)

getCustomerAddressInfo

public CustomerVendorAddressInfoVO getCustomerAddressInfo()

setCustomerAddressInfo

public void setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)

getType

public java.lang.String getType()

setType

public void setType(java.lang.String type)

getReceiver

public java.lang.String getReceiver()

setReceiver

public void setReceiver(java.lang.String receiver)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGCompanyPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGCompanyPK

java.lang.Object
    extended by  bb.common.SGCompanyPK
All Implemented Interfaces:
java.io.Serializable
public class SGCompanyPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
SGCompanyPK()
default constructor
SGCompanyPK(java.lang.String division, java.lang.String client)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getClient()
java.lang.String | getDivision()
int | hashCode()
void | setClient(java.lang.String client)
void | setDivision(java.lang.String division)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SGCompanyPK

public SGCompanyPK(java.lang.String division,
                   java.lang.String client)
full constructor

SGCompanyPK

public SGCompanyPK()
default constructor

Method Detail

getDivision

public java.lang.String getDivision()

setDivision

public void setDivision(java.lang.String division)

getClient

public java.lang.String getClient()

setClient

public void setClient(java.lang.String client)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGCompanyVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGCompanyVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SGCompanyVO
All Implemented Interfaces:
java.io.Serializable
public class SGCompanyVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
SGCompanyVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCurrency()
java.lang.String | getCustQuoteMailto()
java.lang.String | getCustQuotePriceMailto()
java.lang.String | getCustRfqMailto()
java.lang.String | getCustSaleMailto()
java.lang.String | getGotoCatalog()
java.lang.String | getGotoManual()
java.lang.String | getGotoOverview()
java.lang.String | getGotoPic()
java.lang.String | getGotoTechSheet()
java.lang.String | getGotoTroubleshooting()
java.lang.String | getHome()
java.lang.String | getHost()
java.lang.String | getInternalSalesMailto()
java.util.Date | getLastChangeDate()
java.lang.Integer | getLastChangeTime()
java.lang.String | getLastUserName()
java.lang.String | getLogo()
java.lang.String | getName()
SGCompanyPK | getPk()
java.lang.String | getPoweredBy()
java.lang.String | getTestingMailto()
java.lang.String | getTimezero()
java.lang.String | getUnixHome()
int | hashCode()
void | setCurrency(java.lang.String currency)
void | setCustQuoteMailto(java.lang.String custQuoteMailto)
void | setCustQuotePriceMailto(java.lang.String custQuotePriceMailto)
void | setCustRfqMailto(java.lang.String custRfqMailto)
void | setCustSaleMailto(java.lang.String custSaleMailto)
void | setGotoCatalog(java.lang.String gotoCatalog)
void | setGotoManual(java.lang.String gotoManual)
void | setGotoOverview(java.lang.String gotoOverview)
void | setGotoPic(java.lang.String gotoPic)
void | setGotoTechSheet(java.lang.String gotoTechSheet)
void | setGotoTroubleshooting(java.lang.String gotoTroubleshooting)
void | setHome(java.lang.String home)
void | setHost(java.lang.String host)
void | setInternalSalesMailto(java.lang.String internalSalesMailto)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTime(java.lang.Integer lastChangeTime)
void | setLastUserName(java.lang.String lastUserName)
void | setLogo(java.lang.String logo)
void | setName(java.lang.String name)
void | setPk(SGCompanyPK pk)
void | setPoweredBy(java.lang.String poweredBy)
void | setTestingMailto(java.lang.String testingMailto)
void | setTimezero(java.lang.String timezero)
void | setUnixHome(java.lang.String unixHome)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SGCompanyVO

public SGCompanyVO()
Method Detail

getPk

public SGCompanyPK getPk()

setPk

public void setPk(SGCompanyPK pk)

getLastUserName

public java.lang.String getLastUserName()

setLastUserName

public void setLastUserName(java.lang.String lastUserName)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeTime

public java.lang.Integer getLastChangeTime()

setLastChangeTime

public void setLastChangeTime(java.lang.Integer lastChangeTime)

getHost

public java.lang.String getHost()

setHost

public void setHost(java.lang.String host)

getHome

public java.lang.String getHome()

setHome

public void setHome(java.lang.String home)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getLogo

public java.lang.String getLogo()

setLogo

public void setLogo(java.lang.String logo)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getCustRfqMailto

public java.lang.String getCustRfqMailto()

setCustRfqMailto

public void setCustRfqMailto(java.lang.String custRfqMailto)

getCustSaleMailto

public java.lang.String getCustSaleMailto()

setCustSaleMailto

public void setCustSaleMailto(java.lang.String custSaleMailto)

getCustQuotePriceMailto

public java.lang.String getCustQuotePriceMailto()

setCustQuotePriceMailto

public void setCustQuotePriceMailto(java.lang.String custQuotePriceMailto)

getCustQuoteMailto

public java.lang.String getCustQuoteMailto()

setCustQuoteMailto

public void setCustQuoteMailto(java.lang.String custQuoteMailto)

getUnixHome

public java.lang.String getUnixHome()

setUnixHome

public void setUnixHome(java.lang.String unixHome)

getGotoCatalog

public java.lang.String getGotoCatalog()

setGotoCatalog

public void setGotoCatalog(java.lang.String gotoCatalog)

getGotoManual

public java.lang.String getGotoManual()

setGotoManual

public void setGotoManual(java.lang.String gotoManual)

getGotoOverview

public java.lang.String getGotoOverview()

setGotoOverview

public void setGotoOverview(java.lang.String gotoOverview)

getGotoPic

public java.lang.String getGotoPic()

setGotoPic

public void setGotoPic(java.lang.String gotoPic)

getGotoTechSheet

public java.lang.String getGotoTechSheet()

setGotoTechSheet

public void setGotoTechSheet(java.lang.String gotoTechSheet)

getGotoTroubleshooting

public java.lang.String getGotoTroubleshooting()

setGotoTroubleshooting

public void setGotoTroubleshooting(java.lang.String gotoTroubleshooting)

getPoweredBy

public java.lang.String getPoweredBy()

setPoweredBy

public void setPoweredBy(java.lang.String poweredBy)

getInternalSalesMailto

public java.lang.String getInternalSalesMailto()

setInternalSalesMailto

public void setInternalSalesMailto(java.lang.String internalSalesMailto)

getTestingMailto

public java.lang.String getTestingMailto()

setTestingMailto

public void setTestingMailto(java.lang.String testingMailto)

getTimezero

public java.lang.String getTimezero()

setTimezero

public void setTimezero(java.lang.String timezero)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGCustomerCatalogPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGCustomerCatalogPK

java.lang.Object
    extended by  bb.common.SGCustomerCatalogPK
All Implemented Interfaces:
java.io.Serializable
public class SGCustomerCatalogPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SGCustomerCatalogPK()
default constructor
SGCustomerCatalogPK(java.lang.String customer, java.lang.String partNumber, java.lang.String partType)
SGCustomerCatalogPK(java.lang.String customer, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCustomer()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
int | hashCode()
void | setCustomer(java.lang.String customer)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SGCustomerCatalogPK

public SGCustomerCatalogPK(java.lang.String customer,
                           java.lang.String partNumber,
                           java.lang.String partType,
                           java.lang.String partFrom)
full constructor

SGCustomerCatalogPK

public SGCustomerCatalogPK(java.lang.String customer,
                           java.lang.String partNumber,
                           java.lang.String partType)

SGCustomerCatalogPK

public SGCustomerCatalogPK()
default constructor

Method Detail

getCustomer

public java.lang.String getCustomer()

setCustomer

public void setCustomer(java.lang.String customer)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGCustomerCatalogVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGCustomerCatalogVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SGCustomerCatalogVO
All Implemented Interfaces:
java.io.Serializable
public class SGCustomerCatalogVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SGCustomerCatalogVO()
default constructor
SGCustomerCatalogVO(SGCustomerCatalogPK pk, java.lang.String comments)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.lang.String | getConditionDes()
SGCustomerCatalogPK | getPk()
int | hashCode()
void | setComments(java.lang.String comments)
void | setConditionDes(java.lang.String conditionDes)
void | setPk(SGCustomerCatalogPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SGCustomerCatalogVO

public SGCustomerCatalogVO(SGCustomerCatalogPK pk,
                           java.lang.String comments)
full constructor

SGCustomerCatalogVO

public SGCustomerCatalogVO()
default constructor

Method Detail

getPk

public SGCustomerCatalogPK getPk()

setPk

public void setPk(SGCustomerCatalogPK pk)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getConditionDes

public java.lang.String getConditionDes()

setConditionDes

public void setConditionDes(java.lang.String conditionDes)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGCustomerServiceRequestVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGCustomerServiceRequestVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SGCustomerServiceRequestVO
All Implemented Interfaces:
java.io.Serializable
public class SGCustomerServiceRequestVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_APPROVEDBY
static java.lang.String | ORDER_BY_CSINUMBER
static java.lang.String | ORDER_BY_CSRDATE
static java.lang.String | ORDER_BY_CSRNUMBER
static java.lang.String | ORDER_BY_CUSTID
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_DISPOSALBY
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PRIORITY
static java.lang.String | ORDER_BY_REQUESTOR
static java.lang.String | ORDER_BY_REQUIREDATE
static java.lang.String | ORDER_BY_SALESORDERNUMBER
static java.lang.String | ORDER_BY_SERIAL
static java.lang.String | ORDER_BY_SERVICETYPE
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
SGCustomerServiceRequestVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getApproved()
java.lang.String | getApprovedBy()
java.lang.String | getContact()
java.lang.String | getCsiNumber()
java.util.Date | getCsrDate()
java.lang.String | getCsrNumber()
java.lang.String | getCustID()
java.lang.String | getDescription()
java.lang.String | getDisposalBy()
java.lang.String | getDisposalDescription()
java.lang.String | getEmail()
java.lang.String | getEquipCondition()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getLocation()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getPhone()
java.lang.String | getPriority()
java.lang.String | getReqDescription()
java.lang.String | getRequestor()
java.util.Date | getRequireDate()
java.lang.String | getRevsion()
java.lang.String | getSalesOrderItemNumber()
java.lang.String | getSalesOrderNumber()
java.lang.String | getSerial()
java.lang.String | getServiceType()
java.lang.String | getStatus()
int | hashCode()
void | setApproved(java.util.Date approved)
void | setApprovedBy(java.lang.String approvedBy)
void | setContact(java.lang.String contact)
void | setCsiNumber(java.lang.String csiNumber)
void | setCsrDate(java.util.Date csrDate)
void | setCsrNumber(java.lang.String csrNumber)
void | setCustID(java.lang.String custID)
void | setDescription(java.lang.String description)
void | setDisposalBy(java.lang.String disposalBy)
void | setDisposalDescription(java.lang.String disposalDescription)
void | setEmail(java.lang.String email)
void | setEquipCondition(java.lang.String equipCondition)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLocation(java.lang.String location)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPhone(java.lang.String phone)
void | setPriority(java.lang.String priority)
void | setReqDescription(java.lang.String reqDescription)
void | setRequestor(java.lang.String requestor)
void | setRequireDate(java.util.Date requireDate)
void | setRevsion(java.lang.String revsion)
void | setSalesOrderItemNumber(java.lang.String salesOrderItemNumber)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setSerial(java.lang.String serial)
void | setServiceType(java.lang.String serviceType)
void | setStatus(java.lang.String status)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_CSRNUMBER

public static final java.lang.String ORDER_BY_CSRNUMBER
See Also:
Constant Field Values

ORDER_BY_SERVICETYPE

public static final java.lang.String ORDER_BY_SERVICETYPE
See Also:
Constant Field Values

ORDER_BY_PRIORITY

public static final java.lang.String ORDER_BY_PRIORITY
See Also:
Constant Field Values

ORDER_BY_CSRDATE

public static final java.lang.String ORDER_BY_CSRDATE
See Also:
Constant Field Values

ORDER_BY_CUSTID

public static final java.lang.String ORDER_BY_CUSTID
See Also:
Constant Field Values

ORDER_BY_REQUESTOR

public static final java.lang.String ORDER_BY_REQUESTOR
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_SALESORDERNUMBER

public static final java.lang.String ORDER_BY_SALESORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_SERIAL

public static final java.lang.String ORDER_BY_SERIAL
See Also:
Constant Field Values

ORDER_BY_REQUIREDATE

public static final java.lang.String ORDER_BY_REQUIREDATE
See Also:
Constant Field Values

ORDER_BY_DISPOSALBY

public static final java.lang.String ORDER_BY_DISPOSALBY
See Also:
Constant Field Values

ORDER_BY_APPROVEDBY

public static final java.lang.String ORDER_BY_APPROVEDBY
See Also:
Constant Field Values

ORDER_BY_CSINUMBER

public static final java.lang.String ORDER_BY_CSINUMBER
See Also:
Constant Field Values
Constructor Detail

SGCustomerServiceRequestVO

public SGCustomerServiceRequestVO()
Method Detail

getCsrNumber

public java.lang.String getCsrNumber()

setCsrNumber

public void setCsrNumber(java.lang.String csrNumber)

getServiceType

public java.lang.String getServiceType()

setServiceType

public void setServiceType(java.lang.String serviceType)

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getCustID

public java.lang.String getCustID()

setCustID

public void setCustID(java.lang.String custID)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getCsrDate

public java.util.Date getCsrDate()

setCsrDate

public void setCsrDate(java.util.Date csrDate)

getRequestor

public java.lang.String getRequestor()

setRequestor

public void setRequestor(java.lang.String requestor)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getRevsion

public java.lang.String getRevsion()

setRevsion

public void setRevsion(java.lang.String revsion)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getSalesOrderItemNumber

public java.lang.String getSalesOrderItemNumber()

setSalesOrderItemNumber

public void setSalesOrderItemNumber(java.lang.String salesOrderItemNumber)

getSerial

public java.lang.String getSerial()

setSerial

public void setSerial(java.lang.String serial)

getEquipCondition

public java.lang.String getEquipCondition()

setEquipCondition

public void setEquipCondition(java.lang.String equipCondition)

getReqDescription

public java.lang.String getReqDescription()

setReqDescription

public void setReqDescription(java.lang.String reqDescription)

getRequireDate

public java.util.Date getRequireDate()

setRequireDate

public void setRequireDate(java.util.Date requireDate)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getPhone

public java.lang.String getPhone()

setPhone

public void setPhone(java.lang.String phone)

getEmail

public java.lang.String getEmail()

setEmail

public void setEmail(java.lang.String email)

getDisposalDescription

public java.lang.String getDisposalDescription()

setDisposalDescription

public void setDisposalDescription(java.lang.String disposalDescription)

getDisposalBy

public java.lang.String getDisposalBy()

setDisposalBy

public void setDisposalBy(java.lang.String disposalBy)

getApproved

public java.util.Date getApproved()

setApproved

public void setApproved(java.util.Date approved)

getApprovedBy

public java.lang.String getApprovedBy()

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)

getCsiNumber

public java.lang.String getCsiNumber()

setCsiNumber

public void setCsiNumber(java.lang.String csiNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGCustRequestForQuoteItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGCustRequestForQuoteItemPK

java.lang.Object
    extended by  bb.common.SGCustRequestForQuoteItemPK
All Implemented Interfaces:
java.io.Serializable
public class SGCustRequestForQuoteItemPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
SGCustRequestForQuoteItemPK()
default constructor
SGCustRequestForQuoteItemPK(java.lang.String crfqNumber, java.lang.String crfqItemNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCrfqItemNumber()
java.lang.String | getCrfqNumber()
int | hashCode()
void | setCrfqItemNumber(java.lang.String crfqItemNumber)
void | setCrfqNumber(java.lang.String crfqNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SGCustRequestForQuoteItemPK

public SGCustRequestForQuoteItemPK(java.lang.String crfqNumber,
                                   java.lang.String crfqItemNumber)
full constructor

SGCustRequestForQuoteItemPK

public SGCustRequestForQuoteItemPK()
default constructor

Method Detail

getCrfqNumber

public java.lang.String getCrfqNumber()

setCrfqNumber

public void setCrfqNumber(java.lang.String crfqNumber)

getCrfqItemNumber

public java.lang.String getCrfqItemNumber()

setCrfqItemNumber

public void setCrfqItemNumber(java.lang.String crfqItemNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGCustRequestForQuoteItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGCustRequestForQuoteItemResult

java.lang.Object
    extended by  bb.common.SGCustRequestForQuoteItemResult
All Implemented Interfaces:
java.io.Serializable
public class SGCustRequestForQuoteItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SGCustRequestForQuoteItemResult()
Method Summary
java.lang.String | getDescription()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
SGCustRequestForQuoteItemPK | getPk()
java.math.BigDecimal | getQty()
java.lang.String | getUnit()
java.math.BigDecimal | getWeight()
java.lang.String | getWeightUnit()
void | setDescription(java.lang.String description)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(SGCustRequestForQuoteItemPK pk)
void | setQty(java.math.BigDecimal qty)
void | setUnit(java.lang.String unit)
void | setWeight(java.math.BigDecimal weight)
void | setWeightUnit(java.lang.String weightUnit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SGCustRequestForQuoteItemResult

public SGCustRequestForQuoteItemResult()
Method Detail

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPk

public SGCustRequestForQuoteItemPK getPk()

setPk

public void setPk(SGCustRequestForQuoteItemPK pk)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getWeight

public java.math.BigDecimal getWeight()

setWeight

public void setWeight(java.math.BigDecimal weight)

getWeightUnit

public java.lang.String getWeightUnit()

setWeightUnit

public void setWeightUnit(java.lang.String weightUnit)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGCustRequestForQuoteItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGCustRequestForQuoteItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SGCustRequestForQuoteItemVO
All Implemented Interfaces:
java.io.Serializable
public class SGCustRequestForQuoteItemVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
SGCustRequestForQuoteItemVO()
default constructor
SGCustRequestForQuoteItemVO(SGCustRequestForQuoteItemPK pk, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom)
minimal constructor
SGCustRequestForQuoteItemVO(SGCustRequestForQuoteItemPK pk, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.math.BigDecimal qty)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDescription()
java.lang.String | getItemComments()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
SGCustRequestForQuoteItemPK | getPk()
java.math.BigDecimal | getQty()
java.util.Date | getRequireDate()
java.lang.String | getRev()
int | hashCode()
void | setDescription(java.lang.String description)
void | setItemComments(java.lang.String itemComments)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(SGCustRequestForQuoteItemPK pk)
void | setQty(java.math.BigDecimal qty)
void | setRequireDate(java.util.Date requireDate)
void | setRev(java.lang.String rev)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SGCustRequestForQuoteItemVO

public SGCustRequestForQuoteItemVO(SGCustRequestForQuoteItemPK pk,
                                   java.lang.String partNumber,
                                   java.lang.String partType,
                                   java.lang.String partFrom,
                                   java.math.BigDecimal qty)
full constructor

SGCustRequestForQuoteItemVO

public SGCustRequestForQuoteItemVO()
default constructor

SGCustRequestForQuoteItemVO

public SGCustRequestForQuoteItemVO(SGCustRequestForQuoteItemPK pk,
                                   java.lang.String partNumber,
                                   java.lang.String partType,
                                   java.lang.String partFrom)
minimal constructor

Method Detail

getPk

public SGCustRequestForQuoteItemPK getPk()

setPk

public void setPk(SGCustRequestForQuoteItemPK pk)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getItemComments

public java.lang.String getItemComments()

setItemComments

public void setItemComments(java.lang.String itemComments)

getRev

public java.lang.String getRev()

setRev

public void setRev(java.lang.String rev)

getRequireDate

public java.util.Date getRequireDate()

setRequireDate

public void setRequireDate(java.util.Date requireDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGCustRequestForQuoteListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGCustRequestForQuoteListResult

java.lang.Object
    extended by  bb.common.SGCustRequestForQuoteListResult
All Implemented Interfaces:
java.io.Serializable
public class SGCustRequestForQuoteListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ADDR1
static java.lang.String | ORDER_BY_CITY
static java.lang.String | ORDER_BY_CONTACTNAME
static java.lang.String | ORDER_BY_COUNTRY
static java.lang.String | ORDER_BY_CRFQNUMBER
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_CUSTID
static java.lang.String | ORDER_BY_LANGUAGE
static java.lang.String | ORDER_BY_NAME
static java.lang.String | ORDER_BY_QUOTENUMBER
static java.lang.String | ORDER_BY_STATE
static java.lang.String | ORDER_BY_USEREMAIL
Constructor Summary
SGCustRequestForQuoteListResult()
Method Summary
java.lang.String | getAddr1()
java.lang.String | getAddr2()
java.lang.String | getCity()
java.lang.String | getComments()
java.lang.String | getContactName()
java.lang.String | getCountry()
java.util.Date | getCrfqDate()
java.lang.String | getCrfqNumber()
java.lang.String | getCurrency()
java.lang.String | getCustID()
java.lang.String | getFax()
java.lang.String | getLanguage()
java.lang.String | getName()
java.lang.String | getPhone()
java.lang.String | getQuoteNumber()
java.lang.String | getState()
java.lang.String | getUserEmail()
java.lang.String | getZip()
void | setAddr1(java.lang.String addr1)
void | setAddr2(java.lang.String addr2)
void | setCity(java.lang.String city)
void | setComments(java.lang.String comments)
void | setContactName(java.lang.String contactName)
void | setCountry(java.lang.String country)
void | setCrfqDate(java.util.Date crfqDate)
void | setCrfqNumber(java.lang.String crfqNumber)
void | setCurrency(java.lang.String currency)
void | setCustID(java.lang.String custID)
void | setFax(java.lang.String fax)
void | setLanguage(java.lang.String language)
void | setName(java.lang.String name)
void | setPhone(java.lang.String phone)
void | setQuoteNumber(java.lang.String quoteNumber)
void | setState(java.lang.String state)
void | setUserEmail(java.lang.String userEmail)
void | setZip(java.lang.String zip)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_CRFQNUMBER

public static final java.lang.String ORDER_BY_CRFQNUMBER
See Also:
Constant Field Values

ORDER_BY_QUOTENUMBER

public static final java.lang.String ORDER_BY_QUOTENUMBER
See Also:
Constant Field Values

ORDER_BY_USEREMAIL

public static final java.lang.String ORDER_BY_USEREMAIL
See Also:
Constant Field Values

ORDER_BY_CONTACTNAME

public static final java.lang.String ORDER_BY_CONTACTNAME
See Also:
Constant Field Values

ORDER_BY_CUSTID

public static final java.lang.String ORDER_BY_CUSTID
See Also:
Constant Field Values

ORDER_BY_NAME

public static final java.lang.String ORDER_BY_NAME
See Also:
Constant Field Values

ORDER_BY_ADDR1

public static final java.lang.String ORDER_BY_ADDR1
See Also:
Constant Field Values

ORDER_BY_CITY

public static final java.lang.String ORDER_BY_CITY
See Also:
Constant Field Values

ORDER_BY_STATE

public static final java.lang.String ORDER_BY_STATE
See Also:
Constant Field Values

ORDER_BY_COUNTRY

public static final java.lang.String ORDER_BY_COUNTRY
See Also:
Constant Field Values

ORDER_BY_LANGUAGE

public static final java.lang.String ORDER_BY_LANGUAGE
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values
Constructor Detail

SGCustRequestForQuoteListResult

public SGCustRequestForQuoteListResult()
Method Detail

getAddr1

public java.lang.String getAddr1()

setAddr1

public void setAddr1(java.lang.String addr1)

getAddr2

public java.lang.String getAddr2()

setAddr2

public void setAddr2(java.lang.String addr2)

getCity

public java.lang.String getCity()

setCity

public void setCity(java.lang.String city)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getContactName

public java.lang.String getContactName()

setContactName

public void setContactName(java.lang.String contactName)

getCountry

public java.lang.String getCountry()

setCountry

public void setCountry(java.lang.String country)

getCrfqNumber

public java.lang.String getCrfqNumber()

setCrfqNumber

public void setCrfqNumber(java.lang.String crfqNumber)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getFax

public java.lang.String getFax()

setFax

public void setFax(java.lang.String fax)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getPhone

public java.lang.String getPhone()

setPhone

public void setPhone(java.lang.String phone)

getState

public java.lang.String getState()

setState

public void setState(java.lang.String state)

getUserEmail

public java.lang.String getUserEmail()

setUserEmail

public void setUserEmail(java.lang.String userEmail)

getZip

public java.lang.String getZip()

setZip

public void setZip(java.lang.String zip)

getQuoteNumber

public java.lang.String getQuoteNumber()

setQuoteNumber

public void setQuoteNumber(java.lang.String quoteNumber)

getCustID

public java.lang.String getCustID()

setCustID

public void setCustID(java.lang.String custID)

getCrfqDate

public java.util.Date getCrfqDate()

setCrfqDate

public void setCrfqDate(java.util.Date crfqDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGCustRequestForQuoteResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGCustRequestForQuoteResult

java.lang.Object
    extended by  bb.common.SGCustRequestForQuoteResult
All Implemented Interfaces:
java.io.Serializable
public class SGCustRequestForQuoteResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SGCustRequestForQuoteResult()
Method Summary
java.lang.String | getAddr1()
java.lang.String | getAddr2()
java.lang.String | getCity()
java.lang.String | getComments()
java.lang.String | getContactName()
java.lang.String | getCountry()
java.lang.String | getCrfqNumber()
java.lang.String | getCurrency()
java.lang.String | getCustID()
java.lang.String | getFax()
java.util.Set<SGCustRequestForQuoteItemResult> | getItems()
java.lang.String | getLanguage()
java.lang.String | getName()
java.lang.String | getPhone()
java.lang.String | getQuoteNumber()
java.lang.String | getState()
java.lang.String | getUserEmail()
java.lang.String | getZip()
void | setAddr1(java.lang.String addr1)
void | setAddr2(java.lang.String addr2)
void | setCity(java.lang.String city)
void | setComments(java.lang.String comments)
void | setContactName(java.lang.String contactName)
void | setCountry(java.lang.String country)
void | setCrfqNumber(java.lang.String crfqNumber)
void | setCurrency(java.lang.String currency)
void | setCustID(java.lang.String custID)
void | setFax(java.lang.String fax)
void | setItems(java.util.Set<SGCustRequestForQuoteItemResult> items)
void | setLanguage(java.lang.String language)
void | setName(java.lang.String name)
void | setPhone(java.lang.String phone)
void | setQuoteNumber(java.lang.String quoteNumber)
void | setState(java.lang.String state)
void | setUserEmail(java.lang.String userEmail)
void | setZip(java.lang.String zip)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SGCustRequestForQuoteResult

public SGCustRequestForQuoteResult()
Method Detail

getAddr1

public java.lang.String getAddr1()

setAddr1

public void setAddr1(java.lang.String addr1)

getAddr2

public java.lang.String getAddr2()

setAddr2

public void setAddr2(java.lang.String addr2)

getCity

public java.lang.String getCity()

setCity

public void setCity(java.lang.String city)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getContactName

public java.lang.String getContactName()

setContactName

public void setContactName(java.lang.String contactName)

getCountry

public java.lang.String getCountry()

setCountry

public void setCountry(java.lang.String country)

getCrfqNumber

public java.lang.String getCrfqNumber()

setCrfqNumber

public void setCrfqNumber(java.lang.String crfqNumber)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getFax

public java.lang.String getFax()

setFax

public void setFax(java.lang.String fax)

getItems

public java.util.Set<SGCustRequestForQuoteItemResult> getItems()

setItems

public void setItems(java.util.Set<SGCustRequestForQuoteItemResult> items)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getPhone

public java.lang.String getPhone()

setPhone

public void setPhone(java.lang.String phone)

getState

public java.lang.String getState()

setState

public void setState(java.lang.String state)

getUserEmail

public java.lang.String getUserEmail()

setUserEmail

public void setUserEmail(java.lang.String userEmail)

getZip

public java.lang.String getZip()

setZip

public void setZip(java.lang.String zip)

getQuoteNumber

public java.lang.String getQuoteNumber()

setQuoteNumber

public void setQuoteNumber(java.lang.String quoteNumber)

getCustID

public java.lang.String getCustID()

setCustID

public void setCustID(java.lang.String custID)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGCustRequestForQuoteVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGCustRequestForQuoteVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SGCustRequestForQuoteVO
All Implemented Interfaces:
java.io.Serializable
public class SGCustRequestForQuoteVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
SGCustRequestForQuoteVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getClient()
java.lang.String | getComments()
java.lang.String | getContactName()
java.util.Date | getCrfqDate()
java.lang.String | getCrfqNumber()
java.lang.String | getCurrency()
java.lang.String | getCustID()
java.lang.String | getDivision()
java.lang.String | getFax()
java.util.Set | getItems()
java.util.Date | getLastChangeDate()
java.lang.String | getLastUserName()
java.lang.String | getMobile()
java.lang.String | getPhone()
java.lang.String | getQuoteNumber()
java.lang.String | getStatus()
java.lang.String | getUserEmail()
int | hashCode()
void | setClient(java.lang.String client)
void | setComments(java.lang.String comments)
void | setContactName(java.lang.String contactName)
void | setCrfqDate(java.util.Date crfqDate)
void | setCrfqNumber(java.lang.String crfqNumber)
void | setCurrency(java.lang.String currency)
void | setCustID(java.lang.String custID)
void | setDivision(java.lang.String division)
void | setFax(java.lang.String fax)
void | setItems(java.util.Set items)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastUserName(java.lang.String lastUserName)
void | setMobile(java.lang.String mobile)
void | setPhone(java.lang.String phone)
void | setQuoteNumber(java.lang.String quoteNumber)
void | setStatus(java.lang.String status)
void | setUserEmail(java.lang.String userEmail)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SGCustRequestForQuoteVO

public SGCustRequestForQuoteVO()
default constructor

Method Detail

getCrfqNumber

public java.lang.String getCrfqNumber()

setCrfqNumber

public void setCrfqNumber(java.lang.String crfqNumber)

getCustID

public java.lang.String getCustID()

setCustID

public void setCustID(java.lang.String custID)

getContactName

public java.lang.String getContactName()

setContactName

public void setContactName(java.lang.String contactName)

getPhone

public java.lang.String getPhone()

setPhone

public void setPhone(java.lang.String phone)

getMobile

public java.lang.String getMobile()

setMobile

public void setMobile(java.lang.String mobile)

getFax

public java.lang.String getFax()

setFax

public void setFax(java.lang.String fax)

getUserEmail

public java.lang.String getUserEmail()

setUserEmail

public void setUserEmail(java.lang.String userEmail)

getLastUserName

public java.lang.String getLastUserName()

setLastUserName

public void setLastUserName(java.lang.String lastUserName)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getDivision

public java.lang.String getDivision()

setDivision

public void setDivision(java.lang.String division)

getQuoteNumber

public java.lang.String getQuoteNumber()

setQuoteNumber

public void setQuoteNumber(java.lang.String quoteNumber)

getClient

public java.lang.String getClient()

setClient

public void setClient(java.lang.String client)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getItems

public java.util.Set getItems()

setItems

public void setItems(java.util.Set items)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getCrfqDate

public java.util.Date getCrfqDate()

setCrfqDate

public void setCrfqDate(java.util.Date crfqDate)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGDocPartPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGDocPartPK

java.lang.Object
    extended by  bb.common.SGDocPartPK
All Implemented Interfaces:
java.io.Serializable
public class SGDocPartPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
SGDocPartPK()
default constructor
SGDocPartPK(java.lang.String partNumber, java.lang.String language)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getLanguage()
java.lang.String | getPartNumber()
int | hashCode()
void | setLanguage(java.lang.String language)
void | setPartNumber(java.lang.String partNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SGDocPartPK

public SGDocPartPK(java.lang.String partNumber,
                   java.lang.String language)
full constructor

SGDocPartPK

public SGDocPartPK()
default constructor

Method Detail

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGDocPartVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGDocPartVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SGDocPartVO
All Implemented Interfaces:
java.io.Serializable
public class SGDocPartVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
SGDocPartVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCatalog()
java.lang.String | getCatalogRev()
java.lang.String | getCatTest()
java.lang.String | getCatTestRv()
java.lang.String | getCompanyHomes()
java.lang.String | getCompanyHomesRev()
java.lang.String | getGeneralDocument()
java.lang.String | getGeneralDocumentRev()
java.util.Date | getLastChangeDate()
java.lang.String | getLastUserName()
java.lang.String | getManual()
java.lang.String | getManualRev()
java.lang.String | getOverview()
java.lang.String | getOverviewRev()
SGDocPartPK | getPk()
java.lang.String | getTechRev()
java.lang.String | getTechSheet()
java.lang.String | getTroubleRev()
java.lang.String | getTroubleshooting()
int | hashCode()
void | setCatalog(java.lang.String catalog)
void | setCatalogRev(java.lang.String catalogRev)
void | setCatTest(java.lang.String catTest)
void | setCatTestRv(java.lang.String catTestRv)
void | setCompanyHomes(java.lang.String companyHomes)
void | setCompanyHomesRev(java.lang.String companyHomesRev)
void | setGeneralDocument(java.lang.String generalDocument)
void | setGeneralDocumentRev(java.lang.String generalDocumentRev)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastUserName(java.lang.String lastUserName)
void | setManual(java.lang.String manual)
void | setManualRev(java.lang.String manualRev)
void | setOverview(java.lang.String overview)
void | setOverviewRev(java.lang.String overviewRev)
void | setPk(SGDocPartPK pk)
void | setTechRev(java.lang.String techRev)
void | setTechSheet(java.lang.String techSheet)
void | setTroubleRev(java.lang.String troubleRev)
void | setTroubleshooting(java.lang.String troubleshooting)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SGDocPartVO

public SGDocPartVO()
Method Detail

getPk

public SGDocPartPK getPk()

setPk

public void setPk(SGDocPartPK pk)

getLastUserName

public java.lang.String getLastUserName()

setLastUserName

public void setLastUserName(java.lang.String lastUserName)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getCatTest

public java.lang.String getCatTest()

setCatTest

public void setCatTest(java.lang.String catTest)

getCatTestRv

public java.lang.String getCatTestRv()

setCatTestRv

public void setCatTestRv(java.lang.String catTestRv)

getTechSheet

public java.lang.String getTechSheet()

setTechSheet

public void setTechSheet(java.lang.String techSheet)

getTechRev

public java.lang.String getTechRev()

setTechRev

public void setTechRev(java.lang.String techRev)

getOverview

public java.lang.String getOverview()

setOverview

public void setOverview(java.lang.String overview)

getOverviewRev

public java.lang.String getOverviewRev()

setOverviewRev

public void setOverviewRev(java.lang.String overviewRev)

getTroubleshooting

public java.lang.String getTroubleshooting()

setTroubleshooting

public void setTroubleshooting(java.lang.String troubleshooting)

getTroubleRev

public java.lang.String getTroubleRev()

setTroubleRev

public void setTroubleRev(java.lang.String troubleRev)

getGeneralDocument

public java.lang.String getGeneralDocument()

setGeneralDocument

public void setGeneralDocument(java.lang.String generalDocument)

getGeneralDocumentRev

public java.lang.String getGeneralDocumentRev()

setGeneralDocumentRev

public void setGeneralDocumentRev(java.lang.String generalDocumentRev)

getCompanyHomes

public java.lang.String getCompanyHomes()

setCompanyHomes

public void setCompanyHomes(java.lang.String companyHomes)

getCompanyHomesRev

public java.lang.String getCompanyHomesRev()

setCompanyHomesRev

public void setCompanyHomesRev(java.lang.String companyHomesRev)

getManual

public java.lang.String getManual()

setManual

public void setManual(java.lang.String manual)

getManualRev

public java.lang.String getManualRev()

setManualRev

public void setManualRev(java.lang.String manualRev)

getCatalog

public java.lang.String getCatalog()

setCatalog

public void setCatalog(java.lang.String catalog)

getCatalogRev

public java.lang.String getCatalogRev()

setCatalogRev

public void setCatalogRev(java.lang.String catalogRev)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGDwgPicturePK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGDwgPicturePK

java.lang.Object
    extended by  bb.common.SGDwgPicturePK
All Implemented Interfaces:
java.io.Serializable
public class SGDwgPicturePK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
SGDwgPicturePK()
default constructor
SGDwgPicturePK(java.lang.String partNumber, java.lang.String language)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getLanguage()
java.lang.String | getPartNumber()
int | hashCode()
void | setLanguage(java.lang.String language)
void | setPartNumber(java.lang.String partNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SGDwgPicturePK

public SGDwgPicturePK(java.lang.String partNumber,
                      java.lang.String language)
full constructor

SGDwgPicturePK

public SGDwgPicturePK()
default constructor

Method Detail

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGDwgPictureVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGDwgPictureVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SGDwgPictureVO
All Implemented Interfaces:
java.io.Serializable
public class SGDwgPictureVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
SGDwgPictureVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getExtension()
java.util.Date | getLastChangeDate()
java.lang.String | getLastUserName()
java.sql.Blob | getPicture()
SGDwgPicturePK | getPk()
java.lang.String | getRevision()
int | hashCode()
void | setExtension(java.lang.String extension)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastUserName(java.lang.String lastUserName)
void | setPicture(java.sql.Blob picture)
void | setPk(SGDwgPicturePK pk)
void | setRevision(java.lang.String revision)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SGDwgPictureVO

public SGDwgPictureVO()
Method Detail

getPk

public SGDwgPicturePK getPk()

setPk

public void setPk(SGDwgPicturePK pk)

getLastUserName

public java.lang.String getLastUserName()

setLastUserName

public void setLastUserName(java.lang.String lastUserName)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getPicture

public java.sql.Blob getPicture()

setPicture

public void setPicture(java.sql.Blob picture)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGLogLoginVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGLogLoginVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SGLogLoginVO
All Implemented Interfaces:
java.io.Serializable
public class SGLogLoginVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
SGLogLoginVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getClient()
java.lang.String | getDivision()
int | getIdentifier()
java.util.Date | getLastChangeDate()
java.util.Date | getLastChangeTime()
java.lang.String | getLevel()
java.lang.String | getSessionId()
java.lang.String | getUser()
java.lang.String | getUserCompany()
java.lang.String | getUserIp()
java.lang.String | getUserLanguage()
java.lang.String | getUserName()
int | hashCode()
void | setClient(java.lang.String client)
void | setDivision(java.lang.String division)
void | setIdentifier(int identifier)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTime(java.util.Date lastChangeTime)
void | setLevel(java.lang.String level)
void | setSessionId(java.lang.String sessionId)
void | setUser(java.lang.String user)
void | setUserCompany(java.lang.String userCompany)
void | setUserIp(java.lang.String userIp)
void | setUserLanguage(java.lang.String userLanguage)
void | setUserName(java.lang.String userName)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SGLogLoginVO

public SGLogLoginVO()
Method Detail

getIdentifier

public int getIdentifier()

setIdentifier

public void setIdentifier(int identifier)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeTime

public java.util.Date getLastChangeTime()

setLastChangeTime

public void setLastChangeTime(java.util.Date lastChangeTime)

getSessionId

public java.lang.String getSessionId()

setSessionId

public void setSessionId(java.lang.String sessionId)

getDivision

public java.lang.String getDivision()

setDivision

public void setDivision(java.lang.String division)

getClient

public java.lang.String getClient()

setClient

public void setClient(java.lang.String client)

getUserCompany

public java.lang.String getUserCompany()

setUserCompany

public void setUserCompany(java.lang.String userCompany)

getUser

public java.lang.String getUser()

setUser

public void setUser(java.lang.String user)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getUserIp

public java.lang.String getUserIp()

setUserIp

public void setUserIp(java.lang.String userIp)

getUserLanguage

public java.lang.String getUserLanguage()

setUserLanguage

public void setUserLanguage(java.lang.String userLanguage)

getLevel

public java.lang.String getLevel()

setLevel

public void setLevel(java.lang.String level)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGPartCartAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGPartCartAgent

java.lang.Object
    extended by  bb.common.SGPartCartAgent
All Implemented Interfaces:
java.io.Serializable
public class SGPartCartAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SGPartCartAgent()
Method Summary
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getQty()
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setQty(java.math.BigDecimal qty)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SGPartCartAgent

public SGPartCartAgent()
Method Detail

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGPartCatalogResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGPartCatalogResult

java.lang.Object
    extended by  bb.common.SGPartCatalogResult
All Implemented Interfaces:
java.io.Serializable
public class SGPartCatalogResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CATALOG
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_NAME
static java.lang.String | ORDER_BY_PARTNUMBER
Constructor Summary
SGPartCatalogResult()
Method Summary
java.lang.String | getBill()
java.lang.String | getCatalog()
java.lang.String | getComments()
java.lang.String | getCommodityCode()
java.lang.String | getConditionDes()
java.lang.String | getCustID()
java.lang.String | getDescription()
java.lang.String | getDrawing()
java.lang.String | getHavePicture()
java.lang.String | getName()
BB2Part | getPart()
PartCatalogPK | getPartCatalogPK()
PartCatalogVO | getPartCatalogVO()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getProductCode()
java.lang.String | getRevision()
java.util.Date | getRevisionDate()
SGCustomerCatalogPK | getSGCustomerCatalogPK()
SGCustomerCatalogVO | getSGCustomerCatalogVO()
java.lang.String | getUnit()
float | getWeight()
java.lang.String | getWeightUnit()
void | setBill(java.lang.String bill)
void | setCatalog(java.lang.String catalog)
void | setComments(java.lang.String comments)
void | setCommodityCode(java.lang.String commodityCode)
void | setConditionDes(java.lang.String conditionDes)
void | setCustID(java.lang.String custID)
void | setDescription(java.lang.String description)
void | setDrawing(java.lang.String drawing)
void | setHavePicture(java.lang.String havePicture)
void | setName(java.lang.String name)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setProductCode(java.lang.String productCode)
void | setRevision(java.lang.String revision)
void | setRevisionDate(java.util.Date revisionDate)
void | setUnit(java.lang.String unit)
void | setWeight(float weight)
void | setWeightUnit(java.lang.String weightUnit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_NAME

public static final java.lang.String ORDER_BY_NAME
See Also:
Constant Field Values

ORDER_BY_CATALOG

public static final java.lang.String ORDER_BY_CATALOG
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

SGPartCatalogResult

public SGPartCatalogResult()
Method Detail

getProductCode

public java.lang.String getProductCode()

setProductCode

public void setProductCode(java.lang.String productCode)

getCustID

public java.lang.String getCustID()

setCustID

public void setCustID(java.lang.String custID)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getCatalog

public java.lang.String getCatalog()

setCatalog

public void setCatalog(java.lang.String catalog)

getCommodityCode

public java.lang.String getCommodityCode()

setCommodityCode

public void setCommodityCode(java.lang.String commodityCode)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getRevisionDate

public java.util.Date getRevisionDate()

setRevisionDate

public void setRevisionDate(java.util.Date revisionDate)

getDrawing

public java.lang.String getDrawing()

setDrawing

public void setDrawing(java.lang.String drawing)

getBill

public java.lang.String getBill()

setBill

public void setBill(java.lang.String bill)

getWeight

public float getWeight()

setWeight

public void setWeight(float weight)

getWeightUnit

public java.lang.String getWeightUnit()

setWeightUnit

public void setWeightUnit(java.lang.String weightUnit)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getHavePicture

public java.lang.String getHavePicture()

setHavePicture

public void setHavePicture(java.lang.String havePicture)

getPartCatalogVO

public PartCatalogVO getPartCatalogVO()

getPartCatalogPK

public PartCatalogPK getPartCatalogPK()

getSGCustomerCatalogVO

public SGCustomerCatalogVO getSGCustomerCatalogVO()

getPart

public BB2Part getPart()

getSGCustomerCatalogPK

public SGCustomerCatalogPK getSGCustomerCatalogPK()

getConditionDes

public java.lang.String getConditionDes()

setConditionDes

public void setConditionDes(java.lang.String conditionDes)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGPartDocFlagResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGPartDocFlagResult

java.lang.Object
    extended by  bb.common.SGPartDocFlagResult
All Implemented Interfaces:
java.io.Serializable
public class SGPartDocFlagResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SGPartDocFlagResult()
Method Summary
java.lang.String | getLanguage()
java.lang.String | getPartNumber()
boolean | isManual()
boolean | isOverview()
boolean | isTechSheet()
boolean | isTroubleshooting()
void | setLanguage(java.lang.String language)
void | setManual(boolean manual)
void | setOverview(boolean overview)
void | setPartNumber(java.lang.String partNumber)
void | setTechSheet(boolean techSheet)
void | setTroubleshooting(boolean troubleshooting)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SGPartDocFlagResult

public SGPartDocFlagResult()
Method Detail

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

isManual

public boolean isManual()

setManual

public void setManual(boolean manual)

isOverview

public boolean isOverview()

setOverview

public void setOverview(boolean overview)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

isTechSheet

public boolean isTechSheet()

setTechSheet

public void setTechSheet(boolean techSheet)

isTroubleshooting

public boolean isTroubleshooting()

setTroubleshooting

public void setTroubleshooting(boolean troubleshooting)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGPartListItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGPartListItemResult

java.lang.Object
    extended by  bb.common.SGPartListItemResult
All Implemented Interfaces:
java.io.Serializable
public class SGPartListItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SGPartListItemResult()
Method Summary
java.lang.String | getBillNumber()
java.lang.String | getBillType()
java.lang.String | getDescription()
java.lang.String | getItemNumber()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getQty()
java.lang.String | getUnit()
boolean | isPicture()
void | setBillNumber(java.lang.String billNumber)
void | setBillType(java.lang.String billType)
void | setDescription(java.lang.String description)
void | setItemNumber(java.lang.String itemNumber)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPicture(boolean picture)
void | setQty(java.math.BigDecimal qty)
void | setUnit(java.lang.String unit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SGPartListItemResult

public SGPartListItemResult()
Method Detail

getBillNumber

public java.lang.String getBillNumber()

setBillNumber

public void setBillNumber(java.lang.String billNumber)

getBillType

public java.lang.String getBillType()

setBillType

public void setBillType(java.lang.String billType)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getItemNumber

public java.lang.String getItemNumber()

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

isPicture

public boolean isPicture()

setPicture

public void setPicture(boolean picture)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGPartListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGPartListResult

java.lang.Object
    extended by  bb.common.SGPartListResult
All Implemented Interfaces:
java.io.Serializable
public class SGPartListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SGPartListResult()
Method Summary
java.lang.String | getDescription()
java.util.Set<SGPartDocFlagResult> | getDocFlags()
java.util.Set<SGPartListItemResult> | getItems()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getQty()
java.lang.String | getUnit()
boolean | isDrawing()
boolean | isPicture()
void | setDescription(java.lang.String description)
void | setDocFlags(java.util.Set<SGPartDocFlagResult> docFlags)
void | setDrawing(boolean drawing)
void | setItems(java.util.Set<SGPartListItemResult> items)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPicture(boolean picture)
void | setQty(java.math.BigDecimal qty)
void | setUnit(java.lang.String unit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SGPartListResult

public SGPartListResult()
Method Detail

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

isDrawing

public boolean isDrawing()

setDrawing

public void setDrawing(boolean drawing)

getItems

public java.util.Set<SGPartListItemResult> getItems()

setItems

public void setItems(java.util.Set<SGPartListItemResult> items)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

isPicture

public boolean isPicture()

setPicture

public void setPicture(boolean picture)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getDocFlags

public java.util.Set<SGPartDocFlagResult> getDocFlags()

setDocFlags

public void setDocFlags(java.util.Set<SGPartDocFlagResult> docFlags)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGPicturePK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGPicturePK

java.lang.Object
    extended by  bb.common.SGPicturePK
All Implemented Interfaces:
java.io.Serializable
public class SGPicturePK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
SGPicturePK()
default constructor
SGPicturePK(java.lang.String partNumber, java.lang.Short width, java.lang.Short height)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Short | getHeight()
java.lang.String | getPartNumber()
java.lang.Short | getWidth()
int | hashCode()
void | setHeight(java.lang.Short height)
void | setPartNumber(java.lang.String partNumber)
void | setWidth(java.lang.Short width)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SGPicturePK

public SGPicturePK(java.lang.String partNumber,
                   java.lang.Short width,
                   java.lang.Short height)
full constructor

SGPicturePK

public SGPicturePK()
default constructor

Method Detail

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getWidth

public java.lang.Short getWidth()

setWidth

public void setWidth(java.lang.Short width)

getHeight

public java.lang.Short getHeight()

setHeight

public void setHeight(java.lang.Short height)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGPictureVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGPictureVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SGPictureVO
All Implemented Interfaces:
java.io.Serializable
public class SGPictureVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
SGPictureVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getExtension()
java.util.Date | getLastChangeDate()
java.lang.String | getLastUserName()
java.sql.Blob | getPicture()
SGPicturePK | getPk()
int | hashCode()
void | setExtension(java.lang.String extension)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastUserName(java.lang.String lastUserName)
void | setPicture(java.sql.Blob picture)
void | setPk(SGPicturePK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SGPictureVO

public SGPictureVO()
Method Detail

getPk

public SGPicturePK getPk()

setPk

public void setPk(SGPicturePK pk)

getLastUserName

public java.lang.String getLastUserName()

setLastUserName

public void setLastUserName(java.lang.String lastUserName)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getPicture

public java.sql.Blob getPicture()

setPicture

public void setPicture(java.sql.Blob picture)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGQuoteAddressResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGQuoteAddressResult

java.lang.Object
    extended by  bb.common.SGQuoteAddressResult
All Implemented Interfaces:
java.io.Serializable
public class SGQuoteAddressResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SGQuoteAddressResult()
Method Summary
java.lang.String | getAddr1()
java.lang.String | getAddr2()
java.lang.String | getCity()
java.lang.String | getContactName()
java.lang.String | getCountry()
java.lang.String | getFax()
java.lang.String | getName()
java.lang.String | getPhone()
java.lang.String | getState()
java.lang.String | getUserEmail()
java.lang.String | getZip()
void | setAddr1(java.lang.String addr1)
void | setAddr2(java.lang.String addr2)
void | setCity(java.lang.String city)
void | setContactName(java.lang.String contactName)
void | setCountry(java.lang.String country)
void | setFax(java.lang.String fax)
void | setName(java.lang.String name)
void | setPhone(java.lang.String phone)
void | setState(java.lang.String state)
void | setUserEmail(java.lang.String userEmail)
void | setZip(java.lang.String zip)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SGQuoteAddressResult

public SGQuoteAddressResult()
Method Detail

getAddr1

public java.lang.String getAddr1()

setAddr1

public void setAddr1(java.lang.String addr1)

getAddr2

public java.lang.String getAddr2()

setAddr2

public void setAddr2(java.lang.String addr2)

getCity

public java.lang.String getCity()

setCity

public void setCity(java.lang.String city)

getContactName

public java.lang.String getContactName()

setContactName

public void setContactName(java.lang.String contactName)

getCountry

public java.lang.String getCountry()

setCountry

public void setCountry(java.lang.String country)

getFax

public java.lang.String getFax()

setFax

public void setFax(java.lang.String fax)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getPhone

public java.lang.String getPhone()

setPhone

public void setPhone(java.lang.String phone)

getState

public java.lang.String getState()

setState

public void setState(java.lang.String state)

getUserEmail

public java.lang.String getUserEmail()

setUserEmail

public void setUserEmail(java.lang.String userEmail)

getZip

public java.lang.String getZip()

setZip

public void setZip(java.lang.String zip)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGQuoteAddressVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGQuoteAddressVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SGQuoteAddressVO
All Implemented Interfaces:
java.io.Serializable
public class SGQuoteAddressVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
SGQuoteAddressVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAddr1()
java.lang.String | getAddr2()
java.lang.String | getCity()
java.lang.String | getClient()
java.lang.String | getContactName()
java.lang.String | getCountry()
java.lang.String | getCountryCode()
java.lang.String | getCurrency()
java.lang.String | getDivision()
java.lang.String | getFax()
java.lang.String | getLanguage()
java.lang.String | getLevel()
java.lang.String | getName()
java.lang.String | getPassword()
java.lang.String | getPhone()
java.lang.String | getState()
java.lang.String | getUserEmail()
java.lang.String | getZip()
int | hashCode()
void | setAddr1(java.lang.String addr1)
void | setAddr2(java.lang.String addr2)
void | setCity(java.lang.String city)
void | setClient(java.lang.String client)
void | setContactName(java.lang.String contactName)
void | setCountry(java.lang.String country)
void | setCountryCode(java.lang.String countryCode)
void | setCurrency(java.lang.String currency)
void | setDivision(java.lang.String division)
void | setFax(java.lang.String fax)
void | setLanguage(java.lang.String language)
void | setLevel(java.lang.String level)
void | setName(java.lang.String name)
void | setPassword(java.lang.String password)
void | setPhone(java.lang.String phone)
void | setState(java.lang.String state)
void | setUserEmail(java.lang.String userEmail)
void | setZip(java.lang.String zip)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SGQuoteAddressVO

public SGQuoteAddressVO()
Method Detail

getUserEmail

public java.lang.String getUserEmail()

setUserEmail

public void setUserEmail(java.lang.String userEmail)

getPassword

public java.lang.String getPassword()

setPassword

public void setPassword(java.lang.String password)

getLevel

public java.lang.String getLevel()

setLevel

public void setLevel(java.lang.String level)

getClient

public java.lang.String getClient()

setClient

public void setClient(java.lang.String client)

getDivision

public java.lang.String getDivision()

setDivision

public void setDivision(java.lang.String division)

getContactName

public java.lang.String getContactName()

setContactName

public void setContactName(java.lang.String contactName)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getAddr1

public java.lang.String getAddr1()

setAddr1

public void setAddr1(java.lang.String addr1)

getAddr2

public java.lang.String getAddr2()

setAddr2

public void setAddr2(java.lang.String addr2)

getCity

public java.lang.String getCity()

setCity

public void setCity(java.lang.String city)

getState

public java.lang.String getState()

setState

public void setState(java.lang.String state)

getZip

public java.lang.String getZip()

setZip

public void setZip(java.lang.String zip)

getCountry

public java.lang.String getCountry()

setCountry

public void setCountry(java.lang.String country)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getCountryCode

public java.lang.String getCountryCode()

setCountryCode

public void setCountryCode(java.lang.String countryCode)

getPhone

public java.lang.String getPhone()

setPhone

public void setPhone(java.lang.String phone)

getFax

public java.lang.String getFax()

setFax

public void setFax(java.lang.String fax)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGQuoteCartListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGQuoteCartListResult

java.lang.Object
    extended by  bb.common.SGQuoteCartListResult
All Implemented Interfaces:
java.io.Serializable
public class SGQuoteCartListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_QTY
static java.lang.String | ORDER_BY_UNIT
static java.lang.String | ORDER_BY_WEIGHT
static java.lang.String | ORDER_BY_WEIGHTUNIT
Constructor Summary
SGQuoteCartListResult()
Method Summary
java.lang.String | getDescription()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getQty()
java.lang.String | getUnit()
java.lang.Float | getWeight()
java.lang.String | getWeightUnit()
void | setDescription(java.lang.String description)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setQty(java.math.BigDecimal qty)
void | setUnit(java.lang.String unit)
void | setWeight(java.lang.Float weight)
void | setWeightUnit(java.lang.String weightUnit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_UNIT

public static final java.lang.String ORDER_BY_UNIT
See Also:
Constant Field Values

ORDER_BY_WEIGHTUNIT

public static final java.lang.String ORDER_BY_WEIGHTUNIT
See Also:
Constant Field Values

ORDER_BY_WEIGHT

public static final java.lang.String ORDER_BY_WEIGHT
See Also:
Constant Field Values

ORDER_BY_QTY

public static final java.lang.String ORDER_BY_QTY
See Also:
Constant Field Values
Constructor Detail

SGQuoteCartListResult

public SGQuoteCartListResult()
Method Detail

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getWeight

public java.lang.Float getWeight()

setWeight

public void setWeight(java.lang.Float weight)

getWeightUnit

public java.lang.String getWeightUnit()

setWeightUnit

public void setWeightUnit(java.lang.String weightUnit)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGQuoteCartVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGQuoteCartVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SGQuoteCartVO
All Implemented Interfaces:
java.io.Serializable
public class SGQuoteCartVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
SGQuoteCartVO()
Method Summary
boolean | equals(java.lang.Object other)
int | getIdentifer()
java.util.Date | getLastChangeDate()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getQty()
java.lang.String | getUserEmail()
java.lang.String | getWeightUnit()
int | hashCode()
void | setIdentifer(int identifer)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setQty(java.math.BigDecimal qty)
void | setUserEmail(java.lang.String userEmail)
void | setWeightUnit(java.lang.String weightUnit)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SGQuoteCartVO

public SGQuoteCartVO()
Method Detail

getIdentifer

public int getIdentifer()

setIdentifer

public void setIdentifer(int identifer)

getUserEmail

public java.lang.String getUserEmail()

setUserEmail

public void setUserEmail(java.lang.String userEmail)

getWeightUnit

public java.lang.String getWeightUnit()

setWeightUnit

public void setWeightUnit(java.lang.String weightUnit)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGQuoteLoginVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGQuoteLoginVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SGQuoteLoginVO
All Implemented Interfaces:
java.io.Serializable
public class SGQuoteLoginVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
SGQuoteLoginVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getClient()
java.lang.String | getDivision()
int | getIdentifier()
java.util.Date | getLastChangeDate()
java.lang.String | getLevel()
java.lang.String | getReferer()
java.lang.String | getSessionId()
java.lang.String | getUserEmail()
java.lang.String | getUserIp()
int | hashCode()
void | setClient(java.lang.String client)
void | setDivision(java.lang.String division)
void | setIdentifier(int identifier)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLevel(java.lang.String level)
void | setReferer(java.lang.String referer)
void | setSessionId(java.lang.String sessionId)
void | setUserEmail(java.lang.String userEmail)
void | setUserIp(java.lang.String userIp)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SGQuoteLoginVO

public SGQuoteLoginVO()
Method Detail

getIdentifier

public int getIdentifier()

setIdentifier

public void setIdentifier(int identifier)

getUserEmail

public java.lang.String getUserEmail()

setUserEmail

public void setUserEmail(java.lang.String userEmail)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getSessionId

public java.lang.String getSessionId()

setSessionId

public void setSessionId(java.lang.String sessionId)

getDivision

public java.lang.String getDivision()

setDivision

public void setDivision(java.lang.String division)

getClient

public java.lang.String getClient()

setClient

public void setClient(java.lang.String client)

getUserIp

public java.lang.String getUserIp()

setUserIp

public void setUserIp(java.lang.String userIp)

getLevel

public java.lang.String getLevel()

setLevel

public void setLevel(java.lang.String level)

getReferer

public java.lang.String getReferer()

setReferer

public void setReferer(java.lang.String referer)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGSaleItemAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGSaleItemAgent

java.lang.Object
    extended by  bb.common.SGSaleItemAgent
All Implemented Interfaces:
java.io.Serializable
public class SGSaleItemAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SGSaleItemAgent()
Method Summary
java.math.BigDecimal | getQuantity()
java.lang.String | getSalesOrderItemNumber()
java.lang.String | getSalesOrderNumber()
java.lang.String | getSerialNumber()
void | setQuantity(java.math.BigDecimal quantity)
void | setSalesOrderItemNumber(java.lang.String salesOrderItemNumber)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setSerialNumber(java.lang.String serialNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SGSaleItemAgent

public SGSaleItemAgent()
Method Detail

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getSalesOrderItemNumber

public java.lang.String getSalesOrderItemNumber()

setSalesOrderItemNumber

public void setSalesOrderItemNumber(java.lang.String salesOrderItemNumber)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getSerialNumber

public java.lang.String getSerialNumber()

setSerialNumber

public void setSerialNumber(java.lang.String serialNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGSaleItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGSaleItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SGSaleItemVO
All Implemented Interfaces:
java.io.Serializable
public class SGSaleItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CATALOG
static java.lang.String | ORDER_BY_CUSTID
static java.lang.String | ORDER_BY_CUSTPONUMBER
static java.lang.String | ORDER_BY_DATESHIPPED
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_MFG
static java.lang.String | ORDER_BY_MPN
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_SALESORDERNUMBER
static java.lang.String | ORDER_BY_SERIALNUMBER
static java.lang.String | ORDER_BY_WORKORDERNUMBER
Constructor Summary
SGSaleItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getBb2HavePic()
java.lang.String | getBb2HaveSalesDwg()
java.lang.String | getCatalog()
java.lang.String | getComments()
java.lang.String | getCustID()
java.lang.String | getCustPONumber()
java.util.Date | getDateShipped()
java.lang.String | getDescription()
java.lang.Long | getIi()
java.lang.String | getMfg()
java.lang.String | getModelNumber()
java.lang.String | getMpn()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getQuantity()
java.lang.String | getRevision()
java.lang.String | getSalesOrderItemNumber()
java.lang.String | getSalesOrderNumber()
java.lang.String | getSerialNumber()
java.lang.String | getUnit()
java.lang.String | getWorkOrderItemNumber()
java.lang.String | getWorkOrderNumber()
int | hashCode()
void | setBb2HavePic(java.lang.String bb2HavePic)
void | setBb2HaveSalesDwg(java.lang.String bb2HaveSalesDwg)
void | setCatalog(java.lang.String catalog)
void | setComments(java.lang.String comments)
void | setCustID(java.lang.String custID)
void | setCustPONumber(java.lang.String custPONumber)
void | setDateShipped(java.util.Date dateShipped)
void | setDescription(java.lang.String description)
void | setIi(java.lang.Long ii)
void | setMfg(java.lang.String mfg)
void | setModelNumber(java.lang.String modelNumber)
void | setMpn(java.lang.String mpn)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setQuantity(java.math.BigDecimal quantity)
void | setRevision(java.lang.String revision)
void | setSalesOrderItemNumber(java.lang.String salesOrderItemNumber)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setSerialNumber(java.lang.String serialNumber)
void | setUnit(java.lang.String unit)
void | setWorkOrderItemNumber(java.lang.String workOrderItemNumber)
void | setWorkOrderNumber(java.lang.String workOrderNumber)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_CUSTID

public static final java.lang.String ORDER_BY_CUSTID
See Also:
Constant Field Values

ORDER_BY_CATALOG

public static final java.lang.String ORDER_BY_CATALOG
See Also:
Constant Field Values

ORDER_BY_SALESORDERNUMBER

public static final java.lang.String ORDER_BY_SALESORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_WORKORDERNUMBER

public static final java.lang.String ORDER_BY_WORKORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_CUSTPONUMBER

public static final java.lang.String ORDER_BY_CUSTPONUMBER
See Also:
Constant Field Values

ORDER_BY_DATESHIPPED

public static final java.lang.String ORDER_BY_DATESHIPPED
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_MPN

public static final java.lang.String ORDER_BY_MPN
See Also:
Constant Field Values

ORDER_BY_MFG

public static final java.lang.String ORDER_BY_MFG
See Also:
Constant Field Values

ORDER_BY_SERIALNUMBER

public static final java.lang.String ORDER_BY_SERIALNUMBER
See Also:
Constant Field Values
Constructor Detail

SGSaleItemVO

public SGSaleItemVO()
Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getCustID

public java.lang.String getCustID()

setCustID

public void setCustID(java.lang.String custID)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getSalesOrderItemNumber

public java.lang.String getSalesOrderItemNumber()

setSalesOrderItemNumber

public void setSalesOrderItemNumber(java.lang.String salesOrderItemNumber)

getWorkOrderNumber

public java.lang.String getWorkOrderNumber()

setWorkOrderNumber

public void setWorkOrderNumber(java.lang.String workOrderNumber)

getWorkOrderItemNumber

public java.lang.String getWorkOrderItemNumber()

setWorkOrderItemNumber

public void setWorkOrderItemNumber(java.lang.String workOrderItemNumber)

getCustPONumber

public java.lang.String getCustPONumber()

setCustPONumber

public void setCustPONumber(java.lang.String custPONumber)

getDateShipped

public java.util.Date getDateShipped()

setDateShipped

public void setDateShipped(java.util.Date dateShipped)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getCatalog

public java.lang.String getCatalog()

setCatalog

public void setCatalog(java.lang.String catalog)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getSerialNumber

public java.lang.String getSerialNumber()

setSerialNumber

public void setSerialNumber(java.lang.String serialNumber)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getBb2HavePic

public java.lang.String getBb2HavePic()

setBb2HavePic

public void setBb2HavePic(java.lang.String bb2HavePic)

getBb2HaveSalesDwg

public java.lang.String getBb2HaveSalesDwg()

setBb2HaveSalesDwg

public void setBb2HaveSalesDwg(java.lang.String bb2HaveSalesDwg)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SGWeightUnitVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SGWeightUnitVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SGWeightUnitVO
All Implemented Interfaces:
java.io.Serializable
public class SGWeightUnitVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
SGWeightUnitVO()
Method Summary
boolean | equals(java.lang.Object other)
double | getKg()
double | getLbs()
java.lang.String | getWeightUnit()
int | hashCode()
void | setKg(double kg)
void | setLbs(double lbs)
void | setWeightUnit(java.lang.String weightUnit)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SGWeightUnitVO

public SGWeightUnitVO()
Method Detail

getWeightUnit

public java.lang.String getWeightUnit()

setWeightUnit

public void setWeightUnit(java.lang.String weightUnit)

getKg

public double getKg()

setKg

public void setKg(double kg)

getLbs

public double getLbs()

setLbs

public void setLbs(double lbs)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShareHoldersEquityResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ShareHoldersEquityResult

java.lang.Object
    extended by  bb.common.ShareHoldersEquityResult
All Implemented Interfaces:
java.io.Serializable
public class ShareHoldersEquityResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ShareHoldersEquityResult()
Method Summary
java.lang.String | getAccountDescription()
java.lang.String | getAccountNumber()
java.math.BigDecimal | getAmount()
java.lang.String | getDebitOrCredit()
void | setAccountDescription(java.lang.String accountDescription)
void | setAccountNumber(java.lang.String accountNumber)
void | setAmount(java.math.BigDecimal amount)
void | setDebitOrCredit(java.lang.String debitOrCredit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ShareHoldersEquityResult

public ShareHoldersEquityResult()
Method Detail

getAccountNumber

public java.lang.String getAccountNumber()

getDebitOrCredit

public java.lang.String getDebitOrCredit()

getAccountDescription

public java.lang.String getAccountDescription()

setAmount

public void setAmount(java.math.BigDecimal amount)

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

setDebitOrCredit

public void setDebitOrCredit(java.lang.String debitOrCredit)

setAccountDescription

public void setAccountDescription(java.lang.String accountDescription)

getAmount

public java.math.BigDecimal getAmount()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShipListAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ShipListAgent

java.lang.Object
    extended by  bb.common.ShipListAgent
All Implemented Interfaces:
java.io.Serializable
public class ShipListAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ShipListAgent()
Method Summary
java.util.Set | getCustomerSet()
java.util.Date | getEndDate()
java.lang.String | getNewShipListDescription()
java.lang.String | getOwnerName()
java.util.Set | getSalesOrderSet()
java.util.Date | getStartDate()
java.util.Set | getVendorSet()
java.util.Set | getWorkCenterSet()
boolean | isByShipTOID()
void | setByShipTOID(boolean byShipTOID)
void | setCustomerSet(java.util.Set customerSet)
void | setEndDate(java.util.Date endDate)
void | setNewShipListDescription(java.lang.String newShipListDescription)
void | setOwnerName(java.lang.String ownerName)
void | setSalesOrderSet(java.util.Set salesOrderSet)
void | setStartDate(java.util.Date startDate)
void | setVendorSet(java.util.Set vendorSet)
void | setWorkCenterSet(java.util.Set workCenterSet)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ShipListAgent

public ShipListAgent()
Method Detail

setOwnerName

public void setOwnerName(java.lang.String ownerName)

setNewShipListDescription

public void setNewShipListDescription(java.lang.String newShipListDescription)

setStartDate

public void setStartDate(java.util.Date startDate)

setEndDate

public void setEndDate(java.util.Date endDate)

setSalesOrderSet

public void setSalesOrderSet(java.util.Set salesOrderSet)

setCustomerSet

public void setCustomerSet(java.util.Set customerSet)

setVendorSet

public void setVendorSet(java.util.Set vendorSet)

setWorkCenterSet

public void setWorkCenterSet(java.util.Set workCenterSet)

getOwnerName

public java.lang.String getOwnerName()

getNewShipListDescription

public java.lang.String getNewShipListDescription()

getStartDate

public java.util.Date getStartDate()

getEndDate

public java.util.Date getEndDate()

getSalesOrderSet

public java.util.Set getSalesOrderSet()

getCustomerSet

public java.util.Set getCustomerSet()

getVendorSet

public java.util.Set getVendorSet()

getWorkCenterSet

public java.util.Set getWorkCenterSet()

isByShipTOID

public boolean isByShipTOID()

setByShipTOID

public void setByShipTOID(boolean byShipTOID)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShipListInfoVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ShipListInfoVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ShipListInfoVO
All Implemented Interfaces:
java.io.Serializable
public class ShipListInfoVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_DATE1
static java.lang.String | ORDER_BY_DATE2
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_LASTUSER
static java.lang.String | ORDER_BY_OWNERNAME
static java.lang.String | ORDER_BY_SHIPLIST
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
ShipListInfoVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.lang.String | getCustomerId()
java.util.Date | getDate1()
java.util.Date | getDate2()
java.lang.String | getDescription()
java.util.Date | getLastCahgeDate()
int | getLastChangeTimes()
java.lang.String | getLastUser()
java.lang.String | getOwnerName()
java.lang.String | getShipList()
java.lang.String | getStatus()
int | hashCode()
void | setComments(java.lang.String comments)
void | setCustomerId(java.lang.String customerId)
void | setDate1(java.util.Date date1)
void | setDate2(java.util.Date date2)
void | setDescription(java.lang.String description)
void | setLastCahgeDate(java.util.Date lastCahgeDate)
void | setLastChangeTimes(int lastChangeTimes)
void | setLastUser(java.lang.String lastUser)
void | setOwnerName(java.lang.String ownerName)
void | setShipList(java.lang.String shipList)
void | setStatus(java.lang.String status)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_SHIPLIST

public static final java.lang.String ORDER_BY_SHIPLIST
See Also:
Constant Field Values

ORDER_BY_OWNERNAME

public static final java.lang.String ORDER_BY_OWNERNAME
See Also:
Constant Field Values

ORDER_BY_LASTUSER

public static final java.lang.String ORDER_BY_LASTUSER
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_DATE1

public static final java.lang.String ORDER_BY_DATE1
See Also:
Constant Field Values

ORDER_BY_DATE2

public static final java.lang.String ORDER_BY_DATE2
See Also:
Constant Field Values
Constructor Detail

ShipListInfoVO

public ShipListInfoVO()
default constructor

Method Detail

getShipList

public java.lang.String getShipList()

setShipList

public void setShipList(java.lang.String shipList)

getOwnerName

public java.lang.String getOwnerName()

setOwnerName

public void setOwnerName(java.lang.String ownerName)

getLastUser

public java.lang.String getLastUser()

setLastUser

public void setLastUser(java.lang.String lastUser)

getLastCahgeDate

public java.util.Date getLastCahgeDate()

setLastCahgeDate

public void setLastCahgeDate(java.util.Date lastCahgeDate)

getLastChangeTimes

public int getLastChangeTimes()

setLastChangeTimes

public void setLastChangeTimes(int lastChangeTimes)

getDate1

public java.util.Date getDate1()

setDate1

public void setDate1(java.util.Date date1)

getDate2

public java.util.Date getDate2()

setDate2

public void setDate2(java.util.Date date2)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShipListItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ShipListItemPK

java.lang.Object
    extended by  bb.common.ShipListItemPK
All Implemented Interfaces:
java.io.Serializable
public class ShipListItemPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
ShipListItemPK()
default constructor
ShipListItemPK(java.lang.String shipListNumber, java.lang.String salesOrderNumber, java.lang.String salesOrderItemNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getSalesOrderItemNumber()
java.lang.String | getSalesOrderNumber()
java.lang.String | getShipListNumber()
int | hashCode()
void | setSalesOrderItemNumber(java.lang.String salesOrderItemNumber)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setShipListNumber(java.lang.String shipListNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ShipListItemPK

public ShipListItemPK(java.lang.String shipListNumber,
                      java.lang.String salesOrderNumber,
                      java.lang.String salesOrderItemNumber)
full constructor

ShipListItemPK

public ShipListItemPK()
default constructor

Method Detail

getShipListNumber

public java.lang.String getShipListNumber()

setShipListNumber

public void setShipListNumber(java.lang.String shipListNumber)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getSalesOrderItemNumber

public java.lang.String getSalesOrderItemNumber()

setSalesOrderItemNumber

public void setSalesOrderItemNumber(java.lang.String salesOrderItemNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShipListItemRelatedDocResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ShipListItemRelatedDocResult

java.lang.Object
    extended by  bb.common.ShipListItemRelatedDocResult
All Implemented Interfaces:
java.io.Serializable
public class ShipListItemRelatedDocResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ShipListItemRelatedDocResult()
Method Summary
java.util.Date | getDeliveryDate()
java.lang.String | getDescription()
java.util.ArrayList<OrderVendorItem> | getItems()
java.math.BigDecimal | getOnhand()
BB2Part | getPart()
SalesOrderItemPK | getPk()
java.math.BigDecimal | getQty()
void | setDeliveryDate(java.util.Date deliveryDate)
void | setDescription(java.lang.String description)
void | setItems(java.util.ArrayList<OrderVendorItem> items)
void | setOnhand(java.math.BigDecimal onhand)
void | setPart(BB2Part part)
void | setPk(SalesOrderItemPK pk)
void | setQty(java.math.BigDecimal qty)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ShipListItemRelatedDocResult

public ShipListItemRelatedDocResult()
Method Detail

getPk

public SalesOrderItemPK getPk()

getPart

public BB2Part getPart()

getDescription

public java.lang.String getDescription()

getQty

public java.math.BigDecimal getQty()

getDeliveryDate

public java.util.Date getDeliveryDate()

getOnhand

public java.math.BigDecimal getOnhand()

getItems

public java.util.ArrayList<OrderVendorItem> getItems()

setPk

public void setPk(SalesOrderItemPK pk)

setPart

public void setPart(BB2Part part)

setDescription

public void setDescription(java.lang.String description)

setQty

public void setQty(java.math.BigDecimal qty)

setDeliveryDate

public void setDeliveryDate(java.util.Date deliveryDate)

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

setItems

public void setItems(java.util.ArrayList<OrderVendorItem> items)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShipListItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ShipListItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ShipListItemVO
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
ShipListItemVOResult
public class ShipListItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ShipListItemVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
ShipListItemPK | getPk()
java.lang.String | getStatus()
int | hashCode()
void | setComments(java.lang.String comments)
void | setPk(ShipListItemPK pk)
void | setStatus(java.lang.String status)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ShipListItemVO

public ShipListItemVO()
default constructor

Method Detail

getPk

public ShipListItemPK getPk()

setPk

public void setPk(ShipListItemPK pk)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShipListItemVOResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ShipListItemVOResult

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ShipListItemVO
            extended by  bb.common.ShipListItemVOResult
All Implemented Interfaces:
java.io.Serializable
public class ShipListItemVOResult
extends ShipListItemVO

See Also:
Serialized Form

Constructor Summary
ShipListItemVOResult()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCustId()
java.lang.String | getCustomerPo()
java.util.Date | getDateRequited()
java.lang.String | getDescription()
java.lang.String | getPartFrom()
java.util.Set | getPartLocations()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
ShipListItemPK | getPk()
java.math.BigDecimal | getRequiredQty()
java.lang.String | getSalesOrderItemNumber()
java.lang.String | getSalesOrderNumber()
ShipListItemVO | getShipListItemVO()
java.lang.String | getShippingWeight()
java.lang.String | getShipTo()
java.lang.String | getShipVia()
java.lang.String | getSoComments()
java.math.BigDecimal | getTotalOndemand()
java.math.BigDecimal | getTotalOnhand()
java.util.Set | getVendorItems()
void | setCustId(java.lang.String custId)
void | setCustomerPo(java.lang.String customerPo)
void | setDateRequited(java.util.Date dateRequited)
void | setDescription(java.lang.String description)
void | setPartFrom(java.lang.String partFrom)
void | setPartLocations(java.util.Set partLocations)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(ShipListItemPK pk)
void | setRequiredQty(java.math.BigDecimal requiredQty)
void | setSalesOrderItemNumber(java.lang.String salesOrderItemNumber)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setShippingWeight(java.lang.String shippingWeight)
void | setShipTo(java.lang.String shipTo)
void | setShipVia(java.lang.String shipVia)
void | setSoComments(java.lang.String soComments)
void | setTotalOndemand(java.math.BigDecimal totalOndemand)
void | setTotalOnhand(java.math.BigDecimal totalOnhand)
void | setVendorItems(java.util.Set vendorItems)
Methods inherited from class bb.common.ShipListItemVO
getComments, getStatus, hashCode, setComments, setStatus, toString, uniqueStr
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ShipListItemVOResult

public ShipListItemVOResult()
Method Detail

getCustId

public java.lang.String getCustId()

getShipTo

public java.lang.String getShipTo()

getDateRequited

public java.util.Date getDateRequited()

getPartNumber

public java.lang.String getPartNumber()

getPartType

public java.lang.String getPartType()

getPartFrom

public java.lang.String getPartFrom()

getDescription

public java.lang.String getDescription()

getRequiredQty

public java.math.BigDecimal getRequiredQty()

getShipVia

public java.lang.String getShipVia()

setCustId

public void setCustId(java.lang.String custId)

setShipTo

public void setShipTo(java.lang.String shipTo)

setDateRequited

public void setDateRequited(java.util.Date dateRequited)

setPartNumber

public void setPartNumber(java.lang.String partNumber)

setPartType

public void setPartType(java.lang.String partType)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setDescription

public void setDescription(java.lang.String description)

setRequiredQty

public void setRequiredQty(java.math.BigDecimal requiredQty)

setShipVia

public void setShipVia(java.lang.String shipVia)

getShipListItemVO

public ShipListItemVO getShipListItemVO()

getSalesOrderItemNumber

public java.lang.String getSalesOrderItemNumber()

setSalesOrderItemNumber

public void setSalesOrderItemNumber(java.lang.String salesOrderItemNumber)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getPartLocations

public java.util.Set getPartLocations()

setPartLocations

public void setPartLocations(java.util.Set partLocations)

getTotalOndemand

public java.math.BigDecimal getTotalOndemand()

setTotalOndemand

public void setTotalOndemand(java.math.BigDecimal totalOndemand)

getTotalOnhand

public java.math.BigDecimal getTotalOnhand()

setTotalOnhand

public void setTotalOnhand(java.math.BigDecimal totalOnhand)

getVendorItems

public java.util.Set getVendorItems()

setVendorItems

public void setVendorItems(java.util.Set vendorItems)

getPk

public ShipListItemPK getPk()
Overrides:
getPk in class ShipListItemVO

setPk

public void setPk(ShipListItemPK pk)
Overrides:
setPk in class ShipListItemVO

getSoComments

public java.lang.String getSoComments()

setSoComments

public void setSoComments(java.lang.String soComments)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class ShipListItemVO

getCustomerPo

public java.lang.String getCustomerPo()

setCustomerPo

public void setCustomerPo(java.lang.String customerPo)

getShippingWeight

public java.lang.String getShippingWeight()

setShippingWeight

public void setShippingWeight(java.lang.String shippingWeight)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShipListOwnerAttributePK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ShipListOwnerAttributePK

java.lang.Object
    extended by  bb.common.ShipListOwnerAttributePK
All Implemented Interfaces:
java.io.Serializable
public class ShipListOwnerAttributePK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
ShipListOwnerAttributePK()
default constructor
ShipListOwnerAttributePK(java.lang.String ownerName)
ShipListOwnerAttributePK(java.lang.String ownerName, java.lang.Byte ii)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Byte | getIi()
java.lang.String | getOwnerName()
int | hashCode()
void | setIi(java.lang.Byte ii)
void | setOwnerName(java.lang.String ownerName)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ShipListOwnerAttributePK

public ShipListOwnerAttributePK(java.lang.String ownerName,
                                java.lang.Byte ii)
full constructor

ShipListOwnerAttributePK

public ShipListOwnerAttributePK()
default constructor

ShipListOwnerAttributePK

public ShipListOwnerAttributePK(java.lang.String ownerName)
Method Detail

getOwnerName

public java.lang.String getOwnerName()

setOwnerName

public void setOwnerName(java.lang.String ownerName)

getIi

public java.lang.Byte getIi()

setIi

public void setIi(java.lang.Byte ii)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShipListOwnerAttributeVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ShipListOwnerAttributeVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ShipListOwnerAttributeVO
All Implemented Interfaces:
java.io.Serializable
public class ShipListOwnerAttributeVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ShipListOwnerAttributeVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCustomerId()
ShipListOwnerAttributePK | getPk()
ShipListOwnerVO | getShipListOwner()
java.lang.String | getVendorId()
java.lang.String | getWorkCenterId()
int | hashCode()
void | setCustomerId(java.lang.String customerId)
void | setPk(ShipListOwnerAttributePK pk)
void | setShipListOwner(ShipListOwnerVO shipListOwner)
void | setVendorId(java.lang.String vendorId)
void | setWorkCenterId(java.lang.String workCenterId)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ShipListOwnerAttributeVO

public ShipListOwnerAttributeVO()
default constructor

Method Detail

getPk

public ShipListOwnerAttributePK getPk()

setPk

public void setPk(ShipListOwnerAttributePK pk)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getWorkCenterId

public java.lang.String getWorkCenterId()

setWorkCenterId

public void setWorkCenterId(java.lang.String workCenterId)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getShipListOwner

public ShipListOwnerVO getShipListOwner()

setShipListOwner

public void setShipListOwner(ShipListOwnerVO shipListOwner)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShipListOwnerVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ShipListOwnerVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ShipListOwnerVO
All Implemented Interfaces:
java.io.Serializable
public class ShipListOwnerVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String ORDER_BY_OWNERNAME
Constructor Summary
ShipListOwnerVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDescription()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getOwnerName()
java.util.Set | getShipListOwnerAttributes()
java.lang.Integer | getVersion()
int | hashCode()
void | setDescription(java.lang.String description)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setOwnerName(java.lang.String ownerName)
void | setShipListOwnerAttributes(java.util.Set shipListOwnerAttributes)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_OWNERNAME

public static final java.lang.String ORDER_BY_OWNERNAME
See Also:
Constant Field Values
Constructor Detail

ShipListOwnerVO

public ShipListOwnerVO()
default constructor

Method Detail

getOwnerName

public java.lang.String getOwnerName()

setOwnerName

public void setOwnerName(java.lang.String ownerName)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getVersion

public java.lang.Integer getVersion()

setVersion

public void setVersion(java.lang.Integer version)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getShipListOwnerAttributes

public java.util.Set getShipListOwnerAttributes()

setShipListOwnerAttributes

public void setShipListOwnerAttributes(java.util.Set shipListOwnerAttributes)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShipListVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ShipListVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ShipListVO
All Implemented Interfaces:
java.io.Serializable
public class ShipListVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ShipListVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.lang.String | getCustomerId()
java.util.Date | getDate1()
java.util.Date | getDate2()
java.lang.String | getDescription()
java.util.Date | getLastCahgeDate()
java.lang.String | getLastUser()
java.lang.String | getOwnerName()
java.lang.String | getShipList()
java.util.Set | getShipListItems()
java.lang.String | getStatus()
java.lang.Integer | getVersion()
int | hashCode()
void | setComments(java.lang.String comments)
void | setCustomerId(java.lang.String customerId)
void | setDate1(java.util.Date date1)
void | setDate2(java.util.Date date2)
void | setDescription(java.lang.String description)
void | setLastCahgeDate(java.util.Date lastCahgeDate)
void | setLastUser(java.lang.String lastUser)
void | setOwnerName(java.lang.String ownerName)
void | setShipList(java.lang.String shipList)
void | setShipListItems(java.util.Set shipListItems)
void | setStatus(java.lang.String status)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ShipListVO

public ShipListVO()
default constructor

Method Detail

getShipList

public java.lang.String getShipList()

setShipList

public void setShipList(java.lang.String shipList)

getOwnerName

public java.lang.String getOwnerName()

setOwnerName

public void setOwnerName(java.lang.String ownerName)

getLastUser

public java.lang.String getLastUser()

setLastUser

public void setLastUser(java.lang.String lastUser)

getLastCahgeDate

public java.util.Date getLastCahgeDate()

setLastCahgeDate

public void setLastCahgeDate(java.util.Date lastCahgeDate)

getVersion

public java.lang.Integer getVersion()

setVersion

public void setVersion(java.lang.Integer version)

getDate1

public java.util.Date getDate1()

setDate1

public void setDate1(java.util.Date date1)

getDate2

public java.util.Date getDate2()

setDate2

public void setDate2(java.util.Date date2)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getShipListItems

public java.util.Set getShipListItems()

setShipListItems

public void setShipListItems(java.util.Set shipListItems)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShipperAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ShipperAgent

java.lang.Object
    extended by  bb.common.ShipperAgent
All Implemented Interfaces:
java.io.Serializable
public class ShipperAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ShipperAgent()
Method Summary
java.math.BigDecimal | getArFreight()
java.lang.String | getCarrier()
java.lang.String | getFreightRateCode()
java.lang.String | getGrossWeight()
java.util.Set | getItems()
java.lang.String | getOrderNumber()
java.lang.String | getShipVia()
int | getTotPackingBoxNumber()
java.lang.String | getTracking()
void | refresh()
void | setArFreight(java.math.BigDecimal arFreight)
void | setCarrier(java.lang.String carrier)
void | setFreightRateCode(java.lang.String freightRateCode)
void | setGrossWeight(java.lang.String grossWeight)
void | setItems(java.util.Set items)
void | setOrderNumber(java.lang.String orderNumber)
void | setShipVia(java.lang.String shipVia)
void | setTracking(java.lang.String tracking)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ShipperAgent

public ShipperAgent()
Method Detail

getOrderNumber

public java.lang.String getOrderNumber()

getTracking

public java.lang.String getTracking()

getFreightRateCode

public java.lang.String getFreightRateCode()

getGrossWeight

public java.lang.String getGrossWeight()

getArFreight

public java.math.BigDecimal getArFreight()

getItems

public java.util.Set getItems()

getCarrier

public java.lang.String getCarrier()

getShipVia

public java.lang.String getShipVia()

getTotPackingBoxNumber

public int getTotPackingBoxNumber()

setOrderNumber

public void setOrderNumber(java.lang.String orderNumber)

setTracking

public void setTracking(java.lang.String tracking)

setFreightRateCode

public void setFreightRateCode(java.lang.String freightRateCode)

setGrossWeight

public void setGrossWeight(java.lang.String grossWeight)

setArFreight

public void setArFreight(java.math.BigDecimal arFreight)

setItems

public void setItems(java.util.Set items)

setCarrier

public void setCarrier(java.lang.String carrier)

setShipVia

public void setShipVia(java.lang.String shipVia)

refresh

public void refresh()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShipperInfoVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ShipperInfoVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ShipperInfoVO
All Implemented Interfaces:
java.io.Serializable
public class ShipperInfoVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ShipperInfoVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.math.BigDecimal | getArDiscount()
java.math.BigDecimal | getArFreight()
java.math.BigDecimal | getArGl1Recorded()
java.math.BigDecimal | getArGl2Paid()
java.lang.String | getArInvoiceNumber()
java.math.BigDecimal | getArNet()
java.math.BigDecimal | getArOpen()
java.math.BigDecimal | getArPaidGl()
java.math.BigDecimal | getArPaidInvoice()
java.math.BigDecimal | getArShip()
java.math.BigDecimal | getArSub()
java.math.BigDecimal | getArTax()
java.math.BigDecimal | getArTotal()
CustomerVendorAddressInfoVO | getBillToAddressInfo()
java.lang.String | getBillToId()
java.lang.String | getBp()
java.lang.String | getCarrier()
java.lang.String | getCarrierAccount()
java.lang.String | getChangeOrder()
java.lang.String | getCheckNumber()
java.lang.String | getCurrency()
java.lang.String | getCustomerId()
java.lang.String | getCustomerPo()
java.util.Date | getDateInvoiced()
java.util.Date | getDatePaid()
java.util.Date | getDateShipped()
java.lang.String | getDebitAccount()
java.math.BigDecimal | getDue()
java.lang.String | getFreightBill()
java.lang.String | getFreightRateCode()
java.lang.String | getGrossWeight()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getInvoicedBy()
java.util.Date | getInvoicedDate()
java.lang.String | getLanguage()
java.util.Date | getLastChangedate()
java.lang.String | getLastChangeUser()
java.lang.String | getOrigin()
java.lang.String | getOTran()
java.math.BigDecimal | getPaid()
java.util.Date | getPayDate()
java.lang.String | getRelatedDoc()
java.lang.String | getRemitId()
java.lang.String | getRTran()
java.lang.String | getSalesman()
java.lang.String | getSalesOrderNumber()
java.lang.String | getShippedBy()
java.util.Date | getShippedDate()
java.lang.String | getShipperComments()
java.lang.String | getShipperNumber()
java.lang.String | getShipperPrivateNotes()
CustomerVendorAddressInfoVO | getShipToAddressInfo()
java.lang.String | getShipToId()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.lang.String | getTerms()
java.lang.String | getTracking()
int | hashCode()
void | setAdate(java.util.Date adate)
void | setArDiscount(java.math.BigDecimal arDiscount)
void | setArFreight(java.math.BigDecimal arFreight)
void | setArGl1Recorded(java.math.BigDecimal arGl1Recorded)
void | setArGl2Paid(java.math.BigDecimal arGl2Paid)
void | setArInvoiceNumber(java.lang.String arInvoiceNumber)
void | setArNet(java.math.BigDecimal arNet)
void | setArOpen(java.math.BigDecimal arOpen)
void | setArPaidGl(java.math.BigDecimal arPaidGl)
void | setArPaidInvoice(java.math.BigDecimal arPaidInvoice)
void | setArShip(java.math.BigDecimal arShip)
void | setArSub(java.math.BigDecimal arSub)
void | setArTax(java.math.BigDecimal arTax)
void | setArTotal(java.math.BigDecimal arTotal)
void | setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | setBillToId(java.lang.String billToId)
void | setBp(java.lang.String bp)
void | setCarrier(java.lang.String carrier)
void | setCarrierAccount(java.lang.String carrierAccount)
void | setChangeOrder(java.lang.String changeOrder)
void | setCheckNumber(java.lang.String checkNumber)
void | setCurrency(java.lang.String currency)
void | setCustomerId(java.lang.String customerId)
void | setCustomerPo(java.lang.String customerPo)
void | setDateInvoiced(java.util.Date dateInvoiced)
void | setDatePaid(java.util.Date datePaid)
void | setDateShipped(java.util.Date dateShipped)
void | setDebitAccount(java.lang.String DebitAccount)
void | setDue(java.math.BigDecimal due)
void | setFreightBill(java.lang.String freightBill)
void | setFreightRateCode(java.lang.String freightRateCode)
void | setGrossWeight(java.lang.String grossWeight)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setInvoicedBy(java.lang.String invoicedBy)
void | setInvoicedDate(java.util.Date invoicedDate)
void | setLanguage(java.lang.String language)
void | setLastChangedate(java.util.Date lastChangedate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setOrigin(java.lang.String origin)
void | setOTran(java.lang.String oTran)
void | setPaid(java.math.BigDecimal paid)
void | setPayDate(java.util.Date payDate)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setRemitId(java.lang.String remitId)
void | setRTran(java.lang.String rTran)
void | setSalesman(java.lang.String salesman)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setShippedBy(java.lang.String shippedBy)
void | setShippedDate(java.util.Date shippedDate)
void | setShipperComments(java.lang.String shipperComments)
void | setShipperNumber(java.lang.String shipperNumber)
void | setShipperPrivateNotes(java.lang.String shipperPrivateNotes)
void | setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | setShipToId(java.lang.String shipToId)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setTerms(java.lang.String terms)
void | setTracking(java.lang.String tracking)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ShipperInfoVO

public ShipperInfoVO()
Method Detail

getShipperNumber

public java.lang.String getShipperNumber()

setShipperNumber

public void setShipperNumber(java.lang.String shipperNumber)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getArInvoiceNumber

public java.lang.String getArInvoiceNumber()

setArInvoiceNumber

public void setArInvoiceNumber(java.lang.String arInvoiceNumber)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getBillToId

public java.lang.String getBillToId()

setBillToId

public void setBillToId(java.lang.String billToId)

getCustomerPo

public java.lang.String getCustomerPo()

setCustomerPo

public void setCustomerPo(java.lang.String customerPo)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangedate

public java.util.Date getLastChangedate()

setLastChangedate

public void setLastChangedate(java.util.Date lastChangedate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getArSub

public java.math.BigDecimal getArSub()

setArSub

public void setArSub(java.math.BigDecimal arSub)

getArShip

public java.math.BigDecimal getArShip()

setArShip

public void setArShip(java.math.BigDecimal arShip)

getArOpen

public java.math.BigDecimal getArOpen()

setArOpen

public void setArOpen(java.math.BigDecimal arOpen)

getArDiscount

public java.math.BigDecimal getArDiscount()

setArDiscount

public void setArDiscount(java.math.BigDecimal arDiscount)

getArNet

public java.math.BigDecimal getArNet()

setArNet

public void setArNet(java.math.BigDecimal arNet)

getArTax

public java.math.BigDecimal getArTax()

setArTax

public void setArTax(java.math.BigDecimal arTax)

getArFreight

public java.math.BigDecimal getArFreight()

setArFreight

public void setArFreight(java.math.BigDecimal arFreight)

getArTotal

public java.math.BigDecimal getArTotal()

setArTotal

public void setArTotal(java.math.BigDecimal arTotal)

getArPaidInvoice

public java.math.BigDecimal getArPaidInvoice()

setArPaidInvoice

public void setArPaidInvoice(java.math.BigDecimal arPaidInvoice)

getArPaidGl

public java.math.BigDecimal getArPaidGl()

setArPaidGl

public void setArPaidGl(java.math.BigDecimal arPaidGl)

getArGl1Recorded

public java.math.BigDecimal getArGl1Recorded()

setArGl1Recorded

public void setArGl1Recorded(java.math.BigDecimal arGl1Recorded)

getArGl2Paid

public java.math.BigDecimal getArGl2Paid()

setArGl2Paid

public void setArGl2Paid(java.math.BigDecimal arGl2Paid)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getSalesman

public java.lang.String getSalesman()

setSalesman

public void setSalesman(java.lang.String salesman)

getShippedDate

public java.util.Date getShippedDate()

setShippedDate

public void setShippedDate(java.util.Date shippedDate)

getShippedBy

public java.lang.String getShippedBy()

setShippedBy

public void setShippedBy(java.lang.String shippedBy)

getInvoicedDate

public java.util.Date getInvoicedDate()

setInvoicedDate

public void setInvoicedDate(java.util.Date invoicedDate)

getInvoicedBy

public java.lang.String getInvoicedBy()

setInvoicedBy

public void setInvoicedBy(java.lang.String invoicedBy)

getShipToId

public java.lang.String getShipToId()

setShipToId

public void setShipToId(java.lang.String shipToId)

getRemitId

public java.lang.String getRemitId()

setRemitId

public void setRemitId(java.lang.String remitId)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAccount

public java.lang.String getCarrierAccount()

setCarrierAccount

public void setCarrierAccount(java.lang.String carrierAccount)

getFreightRateCode

public java.lang.String getFreightRateCode()

setFreightRateCode

public void setFreightRateCode(java.lang.String freightRateCode)

getGrossWeight

public java.lang.String getGrossWeight()

setGrossWeight

public void setGrossWeight(java.lang.String grossWeight)

getTracking

public java.lang.String getTracking()

setTracking

public void setTracking(java.lang.String tracking)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getDateShipped

public java.util.Date getDateShipped()

setDateShipped

public void setDateShipped(java.util.Date dateShipped)

getDateInvoiced

public java.util.Date getDateInvoiced()

setDateInvoiced

public void setDateInvoiced(java.util.Date dateInvoiced)

getFreightBill

public java.lang.String getFreightBill()

setFreightBill

public void setFreightBill(java.lang.String freightBill)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getDebitAccount

public java.lang.String getDebitAccount()

setDebitAccount

public void setDebitAccount(java.lang.String DebitAccount)

getBp

public java.lang.String getBp()

setBp

public void setBp(java.lang.String bp)

getShipperComments

public java.lang.String getShipperComments()

setShipperComments

public void setShipperComments(java.lang.String shipperComments)

getShipperPrivateNotes

public java.lang.String getShipperPrivateNotes()

setShipperPrivateNotes

public void setShipperPrivateNotes(java.lang.String shipperPrivateNotes)

getDue

public java.math.BigDecimal getDue()

setDue

public void setDue(java.math.BigDecimal due)

getPayDate

public java.util.Date getPayDate()

setPayDate

public void setPayDate(java.util.Date payDate)

getDatePaid

public java.util.Date getDatePaid()

setDatePaid

public void setDatePaid(java.util.Date datePaid)

getCheckNumber

public java.lang.String getCheckNumber()

setCheckNumber

public void setCheckNumber(java.lang.String checkNumber)

getPaid

public java.math.BigDecimal getPaid()

setPaid

public void setPaid(java.math.BigDecimal paid)

getOTran

public java.lang.String getOTran()

setOTran

public void setOTran(java.lang.String oTran)

getRTran

public java.lang.String getRTran()

getBillToAddressInfo

public CustomerVendorAddressInfoVO getBillToAddressInfo()

getShipToAddressInfo

public CustomerVendorAddressInfoVO getShipToAddressInfo()

setRTran

public void setRTran(java.lang.String rTran)

setBillToAddressInfo

public void setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)

setShipToAddressInfo

public void setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShipperItemAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ShipperItemAgent

java.lang.Object
    extended by  bb.common.ShipperItemAgent
All Implemented Interfaces:
java.io.Serializable
public class ShipperItemAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ShipperItemAgent()
Method Summary
java.math.BigDecimal | getAvgCost()
java.lang.String | getComment()
java.lang.String | getItemNumber()
java.util.Map | getLocatoins()
int | getMaxPackagingBoxNum()
java.lang.String | getOneLocations()
java.lang.String | getSerial()
java.util.Set<ShipperItemDetailAgent> | getShipperItemDetails()
java.lang.String | getShipperNumber()
java.math.BigDecimal | getTotalShippedQty()
java.util.Map | getTrackingLog()
void | refresh()
void | setComment(java.lang.String comment)
void | setItemNumber(java.lang.String itemNumber)
void | setSerial(java.lang.String serial)
void | setShipperItemDetails(java.util.Set<ShipperItemDetailAgent> shipperItemDetails)
void | setShipperNumber(java.lang.String shipperNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ShipperItemAgent

public ShipperItemAgent()
Method Detail

getItemNumber

public java.lang.String getItemNumber()

getComment

public java.lang.String getComment()

getTotalShippedQty

public java.math.BigDecimal getTotalShippedQty()

getShipperItemDetails

public java.util.Set<ShipperItemDetailAgent> getShipperItemDetails()

getAvgCost

public java.math.BigDecimal getAvgCost()

getSerial

public java.lang.String getSerial()

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

setComment

public void setComment(java.lang.String comment)

setShipperItemDetails

public void setShipperItemDetails(java.util.Set<ShipperItemDetailAgent> shipperItemDetails)

setSerial

public void setSerial(java.lang.String serial)

refresh

public void refresh()

getMaxPackagingBoxNum

public int getMaxPackagingBoxNum()

getShipperNumber

public java.lang.String getShipperNumber()

setShipperNumber

public void setShipperNumber(java.lang.String shipperNumber)

getOneLocations

public java.lang.String getOneLocations()

getLocatoins

public java.util.Map getLocatoins()

getTrackingLog

public java.util.Map getTrackingLog()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShipperItemDetailAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ShipperItemDetailAgent

java.lang.Object
    extended by  bb.common.ShipperItemDetailAgent
All Implemented Interfaces:
java.io.Serializable
public class ShipperItemDetailAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ShipperItemDetailAgent()
Method Summary
int | getBoxNumber()
java.math.BigDecimal | getCost()
java.lang.String | getIssuedFrom()
java.lang.String | getLocate()
java.lang.String | getNcrNumber()
int | getOfBoxNumber()
int | getPartInQAII()
java.math.BigDecimal | getShippedQty()
java.util.Set<ReceiverItemTrackingLogAgent> | getTrackingLog()
java.util.HashMap<java.lang.String,java.math.BigDecimal> | getTrackings()
void | setBoxNumber(int boxNumber)
void | setCost(java.math.BigDecimal cost)
void | setIssuedFrom(java.lang.String issuedFrom)
void | setLocate(java.lang.String locate)
void | setNcrNumber(java.lang.String ncrNumber)
void | setOfBoxNumber(int ofBoxNumber)
void | setPartInQAII(int partInQAII)
void | setShippedQty(java.math.BigDecimal shippedQty)
void | setTrackingLog(java.util.Set<ReceiverItemTrackingLogAgent> trackingLog)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ShipperItemDetailAgent

public ShipperItemDetailAgent()
Method Detail

setLocate

public void setLocate(java.lang.String locate)

setShippedQty

public void setShippedQty(java.math.BigDecimal shippedQty)

setCost

public void setCost(java.math.BigDecimal cost)

setBoxNumber

public void setBoxNumber(int boxNumber)

setOfBoxNumber

public void setOfBoxNumber(int ofBoxNumber)

getLocate

public java.lang.String getLocate()

getShippedQty

public java.math.BigDecimal getShippedQty()

getCost

public java.math.BigDecimal getCost()

getBoxNumber

public int getBoxNumber()

getOfBoxNumber

public int getOfBoxNumber()

getIssuedFrom

public java.lang.String getIssuedFrom()

setIssuedFrom

public void setIssuedFrom(java.lang.String issuedFrom)

getTrackingLog

public java.util.Set<ReceiverItemTrackingLogAgent> getTrackingLog()

setTrackingLog

public void setTrackingLog(java.util.Set<ReceiverItemTrackingLogAgent> trackingLog)

getNcrNumber

public java.lang.String getNcrNumber()

setNcrNumber

public void setNcrNumber(java.lang.String ncrNumber)

getPartInQAII

public int getPartInQAII()

setPartInQAII

public void setPartInQAII(int partInQAII)

getTrackings

public java.util.HashMap<java.lang.String,java.math.BigDecimal> getTrackings()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShipperItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ShipperItemListResult

java.lang.Object
    extended by  bb.common.ShipperItemListResult
All Implemented Interfaces:
java.io.Serializable
public class ShipperItemListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ARINVOICENUMBER
static java.lang.String | ORDER_BY_AVERAGECOST
static java.lang.String | ORDER_BY_COMPANYNUITID
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_CUSTOMERNAME
static java.lang.String | ORDER_BY_DATESHIPPED
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_LISTPRICE
static java.lang.String | ORDER_BY_LOCATION
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PROJECT
static java.lang.String | ORDER_BY_QUANTITY
static java.lang.String | ORDER_BY_QUANTITYSHIP
static java.lang.String | ORDER_BY_SALESORDERNUMBER
static java.lang.String | ORDER_BY_SERIALNUMBER
static java.lang.String | ORDER_BY_SHIPPERNUMBER
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
ShipperItemListResult()
Method Summary
java.lang.String | getAccountNumber()
java.lang.String | getArInvoiceNumber()
java.math.BigDecimal | getAverageCost()
java.lang.String | getCompanyUnitId()
java.lang.String | getCurrency()
java.lang.String | getCustomerId()
java.lang.String | getCustomerName()
java.util.Date | getDateShipped()
java.util.Date | getDeliveryDate()
java.lang.String | getDescription()
java.math.BigDecimal | getDiscRate()
java.math.BigDecimal | getExtPrice()
java.math.BigDecimal | getListPrice()
java.lang.String | getLocation()
java.util.Map | getLocations()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getProject()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getQuantityShip()
java.lang.String | getSalesOrderItemNumber()
java.lang.String | getSalesOrderNumber()
java.lang.String | getSerialNumber()
java.lang.String | getShipperItemNumber()
java.lang.String | getShipperNumber()
java.lang.String | getStatus()
java.math.BigDecimal | getTaxRate()
java.math.BigDecimal | getTotalQtyShip()
void | setAccountNumber(java.lang.String accountNumber)
void | setArInvoiceNumber(java.lang.String arInvoiceNumber)
void | setAverageCost(java.math.BigDecimal averageCost)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCurrency(java.lang.String currency)
void | setCustomerId(java.lang.String customerId)
void | setCustomerName(java.lang.String customerName)
void | setDateShipped(java.util.Date dateShipped)
void | setDeliveryDate(java.util.Date deliveryDate)
void | setDescription(java.lang.String description)
void | setDiscRate(java.math.BigDecimal rate)
void | setExtPrice(java.math.BigDecimal extPrice)
void | setListPrice(java.math.BigDecimal listPrice)
void | setLocation(java.lang.String location)
void | setLocations(java.util.Map locations)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setProject(java.lang.String project)
void | setQuantity(java.math.BigDecimal quantity)
void | setQuantityShip(java.math.BigDecimal quantityShip)
void | setSalesOrderItemNumber(java.lang.String salesOrderItemNumber)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setSerialNumber(java.lang.String serialNumber)
void | setShipperItemNumber(java.lang.String shipperItemNumber)
void | setShipperNumber(java.lang.String shipperNumber)
void | setStatus(java.lang.String status)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setTotalQtyShip(java.math.BigDecimal totalQtyShip)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_SHIPPERNUMBER

public static final java.lang.String ORDER_BY_SHIPPERNUMBER
See Also:
Constant Field Values

ORDER_BY_ARINVOICENUMBER

public static final java.lang.String ORDER_BY_ARINVOICENUMBER
See Also:
Constant Field Values

ORDER_BY_SALESORDERNUMBER

public static final java.lang.String ORDER_BY_SALESORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_SERIALNUMBER

public static final java.lang.String ORDER_BY_SERIALNUMBER
See Also:
Constant Field Values

ORDER_BY_QUANTITY

public static final java.lang.String ORDER_BY_QUANTITY
See Also:
Constant Field Values

ORDER_BY_QUANTITYSHIP

public static final java.lang.String ORDER_BY_QUANTITYSHIP
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_DATESHIPPED

public static final java.lang.String ORDER_BY_DATESHIPPED
See Also:
Constant Field Values

ORDER_BY_LISTPRICE

public static final java.lang.String ORDER_BY_LISTPRICE
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_CUSTOMERNAME

public static final java.lang.String ORDER_BY_CUSTOMERNAME
See Also:
Constant Field Values

ORDER_BY_COMPANYNUITID

public static final java.lang.String ORDER_BY_COMPANYNUITID
See Also:
Constant Field Values

ORDER_BY_LOCATION

public static final java.lang.String ORDER_BY_LOCATION
See Also:
Constant Field Values

ORDER_BY_AVERAGECOST

public static final java.lang.String ORDER_BY_AVERAGECOST
See Also:
Constant Field Values

ORDER_BY_PROJECT

public static final java.lang.String ORDER_BY_PROJECT
See Also:
Constant Field Values
Constructor Detail

ShipperItemListResult

public ShipperItemListResult()
Method Detail

getShipperNumber

public java.lang.String getShipperNumber()

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

getSalesOrderItemNumber

public java.lang.String getSalesOrderItemNumber()

getPartNumber

public java.lang.String getPartNumber()

getPartType

public java.lang.String getPartType()

getPartFrom

public java.lang.String getPartFrom()

getDescription

public java.lang.String getDescription()

getQuantity

public java.math.BigDecimal getQuantity()

getQuantityShip

public java.math.BigDecimal getQuantityShip()

getCustomerId

public java.lang.String getCustomerId()

getDateShipped

public java.util.Date getDateShipped()

getListPrice

public java.math.BigDecimal getListPrice()

getStatus

public java.lang.String getStatus()

setShipperNumber

public void setShipperNumber(java.lang.String shipperNumber)

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

setSalesOrderItemNumber

public void setSalesOrderItemNumber(java.lang.String salesOrderItemNumber)

setPartNumber

public void setPartNumber(java.lang.String partNumber)

setPartType

public void setPartType(java.lang.String partType)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setDescription

public void setDescription(java.lang.String description)

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

setQuantityShip

public void setQuantityShip(java.math.BigDecimal quantityShip)

setCustomerId

public void setCustomerId(java.lang.String customerId)

setDateShipped

public void setDateShipped(java.util.Date dateShipped)

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

setStatus

public void setStatus(java.lang.String status)

getCustomerName

public java.lang.String getCustomerName()

setCustomerName

public void setCustomerName(java.lang.String customerName)

getArInvoiceNumber

public java.lang.String getArInvoiceNumber()

setArInvoiceNumber

public void setArInvoiceNumber(java.lang.String arInvoiceNumber)

getSerialNumber

public java.lang.String getSerialNumber()

setSerialNumber

public void setSerialNumber(java.lang.String serialNumber)

getTotalQtyShip

public java.math.BigDecimal getTotalQtyShip()

setTotalQtyShip

public void setTotalQtyShip(java.math.BigDecimal totalQtyShip)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getDiscRate

public java.math.BigDecimal getDiscRate()

setDiscRate

public void setDiscRate(java.math.BigDecimal rate)

getExtPrice

public java.math.BigDecimal getExtPrice()

setExtPrice

public void setExtPrice(java.math.BigDecimal extPrice)

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getAverageCost

public java.math.BigDecimal getAverageCost()

setAverageCost

public void setAverageCost(java.math.BigDecimal averageCost)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

getDeliveryDate

public java.util.Date getDeliveryDate()

setDeliveryDate

public void setDeliveryDate(java.util.Date deliveryDate)

getShipperItemNumber

public java.lang.String getShipperItemNumber()

setShipperItemNumber

public void setShipperItemNumber(java.lang.String shipperItemNumber)

getLocations

public java.util.Map getLocations()

setLocations

public void setLocations(java.util.Map locations)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShipperItemManufacturerPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ShipperItemManufacturerPK

java.lang.Object
    extended by  bb.common.ShipperItemManufacturerPK
All Implemented Interfaces:
java.io.Serializable
public class ShipperItemManufacturerPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ShipperItemManufacturerPK()
ShipperItemManufacturerPK(java.lang.String shipperNumber, java.lang.String salesOrderItemNumber, java.lang.Short ii)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Short | getIi()
java.lang.String | getSalesOrderItemNumber()
java.lang.String | getShipperNumber()
int | hashCode()
void | setIi(java.lang.Short ii)
void | setSalesOrderItemNumber(java.lang.String salesOrderItemNumber)
void | setShipperNumber(java.lang.String shipperNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ShipperItemManufacturerPK

public ShipperItemManufacturerPK()

ShipperItemManufacturerPK

public ShipperItemManufacturerPK(java.lang.String shipperNumber,
                                 java.lang.String salesOrderItemNumber,
                                 java.lang.Short ii)
Method Detail

getShipperNumber

public java.lang.String getShipperNumber()

setShipperNumber

public void setShipperNumber(java.lang.String shipperNumber)

getSalesOrderItemNumber

public java.lang.String getSalesOrderItemNumber()

setSalesOrderItemNumber

public void setSalesOrderItemNumber(java.lang.String salesOrderItemNumber)

getIi

public java.lang.Short getIi()

setIi

public void setIi(java.lang.Short ii)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShipperItemManufacturerVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ShipperItemManufacturerVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ShipperItemManufacturerVO
All Implemented Interfaces:
java.io.Serializable
public class ShipperItemManufacturerVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ShipperItemManufacturerVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getManufacturerName()
java.lang.String | getManufacturerPartNumber()
ShipperItemManufacturerPK | getPk()
int | hashCode()
void | setManufacturerName(java.lang.String manufacturerName)
void | setManufacturerPartNumber(java.lang.String manufacturerPartNumber)
void | setPk(ShipperItemManufacturerPK pk)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ShipperItemManufacturerVO

public ShipperItemManufacturerVO()
Method Detail

getPk

public ShipperItemManufacturerPK getPk()

setPk

public void setPk(ShipperItemManufacturerPK pk)

getManufacturerName

public java.lang.String getManufacturerName()

setManufacturerName

public void setManufacturerName(java.lang.String manufacturerName)

getManufacturerPartNumber

public java.lang.String getManufacturerPartNumber()

setManufacturerPartNumber

public void setManufacturerPartNumber(java.lang.String manufacturerPartNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShipperItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ShipperItemPK

java.lang.Object
    extended by  bb.common.ShipperItemPK
All Implemented Interfaces:
java.io.Serializable
public class ShipperItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ShipperItemPK()
ShipperItemPK(java.lang.String shipperNumber, java.lang.String shipperItemNumber)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getShipperItemNumber()
java.lang.String | getShipperNumber()
int | hashCode()
void | setShipperItemNumber(java.lang.String shipperItemNumber)
void | setShipperNumber(java.lang.String shipperNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ShipperItemPK

public ShipperItemPK()

ShipperItemPK

public ShipperItemPK(java.lang.String shipperNumber,
                     java.lang.String shipperItemNumber)
Method Detail

setShipperNumber

public void setShipperNumber(java.lang.String shipperNumber)

getShipperNumber

public java.lang.String getShipperNumber()

setShipperItemNumber

public void setShipperItemNumber(java.lang.String shipperItemNumber)

getShipperItemNumber

public java.lang.String getShipperItemNumber()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShipperItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ShipperItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ShipperItemVO
All Implemented Interfaces:
java.io.Serializable
public class ShipperItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ShipperItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getArDiscount()
java.math.BigDecimal | getArNet()
java.math.BigDecimal | getArOpen()
java.math.BigDecimal | getArShip()
java.math.BigDecimal | getArSub()
java.math.BigDecimal | getArTax()
java.math.BigDecimal | getArTotal()
java.math.BigDecimal | getAverageCost()
java.math.BigDecimal | getBb2BackOrderQty()
java.math.BigDecimal | getBb2SoShippedQty()
java.lang.String | getCheckNumber()
java.util.Date | getDateInvoiced()
java.util.Date | getDatePaid()
java.util.Date | getDateShipped()
java.lang.String | getDescription()
java.math.BigDecimal | getDiscount()
java.math.BigDecimal | getDue()
java.lang.String | getGlNumber()
java.lang.String | getInvoiceNumber()
java.math.BigDecimal | getListPrice()
java.lang.String | getLocation()
java.util.Map | getLocations()
java.lang.String | getMfg()
java.lang.String | getModelNumber()
java.lang.String | getMpn()
java.lang.String | getOffsetUnbilledGLNumber()
java.math.BigDecimal | getPaid()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
ShipperItemPK | getPk()
java.lang.String | getProductCode()
java.math.BigDecimal | getQuantityShip()
java.util.Set | getRefDocOnes()
java.util.Set | getRefDocTwoes()
java.lang.String | getReferenceDoc1()
java.lang.String | getReferenceDoc2()
java.lang.String | getRevision()
java.lang.String | getSalesOrder()
java.lang.String | getSerialNumber()
java.lang.String | getShipperItemComments()
java.util.Set | getShipperItemManufacturer()
java.lang.String | getShipperItemPrivateNotes()
java.lang.String | getShipToId()
java.lang.String | getShipVia()
java.math.BigDecimal | getSoQuantity()
java.lang.String | getStatus()
java.math.BigDecimal | getStdCost()
java.math.BigDecimal | getTaxRate()
java.util.Map | getTrackings()
java.math.BigDecimal | getUnbilledExchange()
java.lang.String | getUnit()
int | hashCode()
void | setArDiscount(java.math.BigDecimal arDiscount)
void | setArNet(java.math.BigDecimal arNet)
void | setArOpen(java.math.BigDecimal arOpen)
void | setArShip(java.math.BigDecimal arShip)
void | setArSub(java.math.BigDecimal arSub)
void | setArTax(java.math.BigDecimal arTax)
void | setArTotal(java.math.BigDecimal arTotal)
void | setAverageCost(java.math.BigDecimal averageCost)
void | setBb2BackOrderQty(java.math.BigDecimal bb2BackOrderQty)
void | setBb2SoShippedQty(java.math.BigDecimal bb2SoShippedQty)
void | setCheckNumber(java.lang.String checkNumber)
void | setDateInvoiced(java.util.Date dateInvoiced)
void | setDatePaid(java.util.Date datePaid)
void | setDateShipped(java.util.Date dateShipped)
void | setDescription(java.lang.String description)
void | setDiscount(java.math.BigDecimal discount)
void | setDue(java.math.BigDecimal due)
void | setGlNumber(java.lang.String glNumber)
void | setInvoiceNumber(java.lang.String invoiceNumber)
void | setListPrice(java.math.BigDecimal listPrice)
void | setLocation(java.lang.String location)
void | setLocations(java.util.Map locations)
void | setMfg(java.lang.String mfg)
void | setModelNumber(java.lang.String modelNumber)
void | setMpn(java.lang.String mpn)
void | setOffsetUnbilledGLNumber(java.lang.String offsetUnbilledGLNumber)
void | setPaid(java.math.BigDecimal paid)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(ShipperItemPK pk)
void | setProductCode(java.lang.String productCode)
void | setQuantityShip(java.math.BigDecimal quantityShip)
void | setRefDocOnes(java.util.Set refDocOnes)
void | setRefDocTwoes(java.util.Set refDocTwoes)
void | setReferenceDoc1(java.lang.String referenceDoc1)
void | setReferenceDoc2(java.lang.String referenceDoc2)
void | setRevision(java.lang.String revision)
void | setSalesOrder(java.lang.String salesOrder)
void | setSerialNumber(java.lang.String serialNumber)
void | setShipperItemComments(java.lang.String shipperItemComments)
void | setShipperItemManufacturer(java.util.Set shipperItemManufacturer)
void | setShipperItemPrivateNotes(java.lang.String shipperItemPrivateNotes)
void | setShipToId(java.lang.String shipToId)
void | setShipVia(java.lang.String shipVia)
void | setSoQuantity(java.math.BigDecimal soQuantity)
void | setStatus(java.lang.String status)
void | setStdCost(java.math.BigDecimal stdCost)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setTrackings(java.util.Map trackings)
void | setUnbilledExchange(java.math.BigDecimal unbilledExchange)
void | setUnit(java.lang.String unit)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ShipperItemVO

public ShipperItemVO()
Method Detail

getPk

public ShipperItemPK getPk()

setPk

public void setPk(ShipperItemPK pk)

getSalesOrder

public java.lang.String getSalesOrder()

setSalesOrder

public void setSalesOrder(java.lang.String salesOrder)

getArSub

public java.math.BigDecimal getArSub()

setArSub

public void setArSub(java.math.BigDecimal arSub)

getArShip

public java.math.BigDecimal getArShip()

setArShip

public void setArShip(java.math.BigDecimal arShip)

getArOpen

public java.math.BigDecimal getArOpen()

setArOpen

public void setArOpen(java.math.BigDecimal arOpen)

getArDiscount

public java.math.BigDecimal getArDiscount()

setArDiscount

public void setArDiscount(java.math.BigDecimal arDiscount)

getArNet

public java.math.BigDecimal getArNet()

setArNet

public void setArNet(java.math.BigDecimal arNet)

getArTax

public java.math.BigDecimal getArTax()

setArTax

public void setArTax(java.math.BigDecimal arTax)

getArTotal

public java.math.BigDecimal getArTotal()

setArTotal

public void setArTotal(java.math.BigDecimal arTotal)

getReferenceDoc1

public java.lang.String getReferenceDoc1()

setReferenceDoc1

public void setReferenceDoc1(java.lang.String referenceDoc1)

getReferenceDoc2

public java.lang.String getReferenceDoc2()

setReferenceDoc2

public void setReferenceDoc2(java.lang.String referenceDoc2)

getDateShipped

public java.util.Date getDateShipped()

setDateShipped

public void setDateShipped(java.util.Date dateShipped)

getDateInvoiced

public java.util.Date getDateInvoiced()

setDateInvoiced

public void setDateInvoiced(java.util.Date dateInvoiced)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getShipToId

public java.lang.String getShipToId()

setShipToId

public void setShipToId(java.lang.String shipToId)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getSoQuantity

public java.math.BigDecimal getSoQuantity()

setSoQuantity

public void setSoQuantity(java.math.BigDecimal soQuantity)

getQuantityShip

public java.math.BigDecimal getQuantityShip()

setQuantityShip

public void setQuantityShip(java.math.BigDecimal quantityShip)

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

getAverageCost

public java.math.BigDecimal getAverageCost()

setAverageCost

public void setAverageCost(java.math.BigDecimal averageCost)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getSerialNumber

public java.lang.String getSerialNumber()

setSerialNumber

public void setSerialNumber(java.lang.String serialNumber)

getShipperItemComments

public java.lang.String getShipperItemComments()

setShipperItemComments

public void setShipperItemComments(java.lang.String shipperItemComments)

getShipperItemPrivateNotes

public java.lang.String getShipperItemPrivateNotes()

getCheckNumber

public java.lang.String getCheckNumber()

getDue

public java.math.BigDecimal getDue()

getDatePaid

public java.util.Date getDatePaid()

getPaid

public java.math.BigDecimal getPaid()

getRefDocOnes

public java.util.Set getRefDocOnes()

setShipperItemPrivateNotes

public void setShipperItemPrivateNotes(java.lang.String shipperItemPrivateNotes)

setCheckNumber

public void setCheckNumber(java.lang.String checkNumber)

setDue

public void setDue(java.math.BigDecimal due)

setDatePaid

public void setDatePaid(java.util.Date datePaid)

setPaid

public void setPaid(java.math.BigDecimal paid)

getRefDocTwoes

public java.util.Set getRefDocTwoes()

setRefDocTwoes

public void setRefDocTwoes(java.util.Set refDocTwoes)

setRefDocOnes

public void setRefDocOnes(java.util.Set refDocOnes)

getShipperItemManufacturer

public java.util.Set getShipperItemManufacturer()

setShipperItemManufacturer

public void setShipperItemManufacturer(java.util.Set shipperItemManufacturer)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getBb2SoShippedQty

public java.math.BigDecimal getBb2SoShippedQty()

setBb2SoShippedQty

public void setBb2SoShippedQty(java.math.BigDecimal bb2SoShippedQty)

getBb2BackOrderQty

public java.math.BigDecimal getBb2BackOrderQty()

setBb2BackOrderQty

public void setBb2BackOrderQty(java.math.BigDecimal bb2BackOrderQty)

getInvoiceNumber

public java.lang.String getInvoiceNumber()

setInvoiceNumber

public void setInvoiceNumber(java.lang.String invoiceNumber)

getProductCode

public java.lang.String getProductCode()

setProductCode

public void setProductCode(java.lang.String productCode)

getGlNumber

public java.lang.String getGlNumber()

setGlNumber

public void setGlNumber(java.lang.String glNumber)

getOffsetUnbilledGLNumber

public java.lang.String getOffsetUnbilledGLNumber()

setOffsetUnbilledGLNumber

public void setOffsetUnbilledGLNumber(java.lang.String offsetUnbilledGLNumber)

getUnbilledExchange

public java.math.BigDecimal getUnbilledExchange()

setUnbilledExchange

public void setUnbilledExchange(java.math.BigDecimal unbilledExchange)

getLocations

public java.util.Map getLocations()

setLocations

public void setLocations(java.util.Map locations)

getTrackings

public java.util.Map getTrackings()

setTrackings

public void setTrackings(java.util.Map trackings)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShipperListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ShipperListResult

java.lang.Object
    extended by  bb.common.ShipperListResult
All Implemented Interfaces:
java.io.Serializable
public class ShipperListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_SALESMAN
static java.lang.String | ORDER_BY_SALESORDERNUMBER
static java.lang.String | ORDER_BY_SHIPPERDATE
static java.lang.String | ORDER_BY_SHIPPERNUMBER
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
ShipperListResult()
Method Summary
java.lang.String | getChangeOrder()
java.lang.String | getComments()
java.lang.String | getCustomerId()
java.lang.String | getCustomerName()
java.lang.String | getSalesman()
java.lang.String | getSalesOrderNumber()
java.util.Date | getShipperDate()
java.lang.String | getShipperNumber()
java.lang.String | getStatus()
void | setChangeOrder(java.lang.String changeOrder)
void | setComments(java.lang.String comments)
void | setCustomerId(java.lang.String customerId)
void | setCustomerName(java.lang.String customerName)
void | setSalesman(java.lang.String salesman)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setShipperDate(java.util.Date shipperDate)
void | setShipperNumber(java.lang.String shipperNumber)
void | setStatus(java.lang.String status)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_SHIPPERNUMBER

public static final java.lang.String ORDER_BY_SHIPPERNUMBER
See Also:
Constant Field Values

ORDER_BY_SHIPPERDATE

public static final java.lang.String ORDER_BY_SHIPPERDATE
See Also:
Constant Field Values

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_SALESORDERNUMBER

public static final java.lang.String ORDER_BY_SALESORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_SALESMAN

public static final java.lang.String ORDER_BY_SALESMAN
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values
Constructor Detail

ShipperListResult

public ShipperListResult()
Method Detail

getShipperNumber

public java.lang.String getShipperNumber()

getShipperDate

public java.util.Date getShipperDate()

getCustomerId

public java.lang.String getCustomerId()

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

getSalesman

public java.lang.String getSalesman()

getComments

public java.lang.String getComments()

getStatus

public java.lang.String getStatus()

getCustomerName

public java.lang.String getCustomerName()

getChangeOrder

public java.lang.String getChangeOrder()

setShipperNumber

public void setShipperNumber(java.lang.String shipperNumber)

setShipperDate

public void setShipperDate(java.util.Date shipperDate)

setCustomerId

public void setCustomerId(java.lang.String customerId)

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

setSalesman

public void setSalesman(java.lang.String salesman)

setComments

public void setComments(java.lang.String comments)

setStatus

public void setStatus(java.lang.String status)

setCustomerName

public void setCustomerName(java.lang.String customerName)

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShipperVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ShipperVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ShipperVO
All Implemented Interfaces:
java.io.Serializable
public class ShipperVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ShipperVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.math.BigDecimal | getArDiscount()
java.math.BigDecimal | getArFreight()
java.math.BigDecimal | getArGl1Recorded()
java.math.BigDecimal | getArGl2Paid()
java.lang.String | getArInvoiceNumber()
java.math.BigDecimal | getArNet()
java.lang.String | getArNetSet()
java.math.BigDecimal | getArOpen()
java.math.BigDecimal | getArPaidGl()
java.math.BigDecimal | getArPaidInvoice()
java.math.BigDecimal | getArShip()
java.math.BigDecimal | getArSub()
java.math.BigDecimal | getArTax()
java.lang.String | getArTaxSet()
java.math.BigDecimal | getArTotal()
java.lang.String | getBatch()
CustomerVendorAddressInfoVO | getBillToAddressInfo()
java.lang.String | getBillToId()
java.lang.String | getBp()
java.lang.String | getCarrier()
java.lang.String | getCarrierAccount()
java.lang.String | getChangeOrder()
java.lang.String | getCheckNumber()
java.lang.String | getCoComments()
java.lang.String | getCompanyUnitId()
java.lang.String | getCurrency()
CustomerVendorAddressInfoVO | getCustomerAddressInfo()
java.lang.String | getCustomerId()
java.lang.String | getCustomerPo()
java.util.Date | getDateInvoiced()
java.util.Date | getDatePaid()
java.util.Date | getDateShipped()
java.lang.String | getDebitAccount()
java.math.BigDecimal | getDue()
java.lang.String | getFreightBill()
java.lang.String | getFreightRateCode()
java.lang.String | getGrossWeight()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getInvoicedBy()
java.util.Date | getInvoicedDate()
java.lang.String | getLanguage()
java.util.Date | getLastChangedate()
int | getLastChangeTime()
java.lang.String | getLastChangeUser()
java.lang.String | getOrigin()
java.lang.String | getOTran()
java.math.BigDecimal | getPaid()
java.util.Date | getPayDate()
java.lang.String | getPfInvoiceNumber()
java.lang.String | getProject()
java.lang.String | getRelatedDoc()
java.lang.String | getRemitId()
java.lang.String | getRTran()
java.lang.String | getSalesman()
java.lang.String | getSalesOrderNumber()
java.lang.String | getShippedBy()
java.util.Date | getShippedDate()
java.lang.String | getShipperBp()
java.lang.String | getShipperComments()
java.util.Set | getShipperItems()
java.lang.String | getShipperNumber()
java.lang.String | getShipperPrivateNotes()
CustomerVendorAddressInfoVO | getShipToAddressInfo()
java.lang.String | getShipToId()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.lang.String | getTerms()
java.lang.String | getTracking()
int | hashCode()
void | setAdate(java.util.Date adate)
void | setArDiscount(java.math.BigDecimal arDiscount)
void | setArFreight(java.math.BigDecimal arFreight)
void | setArGl1Recorded(java.math.BigDecimal arGl1Recorded)
void | setArGl2Paid(java.math.BigDecimal arGl2Paid)
void | setArInvoiceNumber(java.lang.String arInvoiceNumber)
void | setArNet(java.math.BigDecimal arNet)
void | setArNetSet(java.lang.String arNetSet)
void | setArOpen(java.math.BigDecimal arOpen)
void | setArPaidGl(java.math.BigDecimal arPaidGl)
void | setArPaidInvoice(java.math.BigDecimal arPaidInvoice)
void | setArShip(java.math.BigDecimal arShip)
void | setArSub(java.math.BigDecimal arSub)
void | setArTax(java.math.BigDecimal arTax)
void | setArTaxSet(java.lang.String arTaxSet)
void | setArTotal(java.math.BigDecimal arTotal)
void | setBatch(java.lang.String batch)
void | setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | setBillToId(java.lang.String billToId)
void | setBp(java.lang.String bp)
void | setCarrier(java.lang.String carrier)
void | setCarrierAccount(java.lang.String carrierAccount)
void | setChangeOrder(java.lang.String changeOrder)
void | setCheckNumber(java.lang.String checkNumber)
void | setCoComments(java.lang.String coComments)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCurrency(java.lang.String currency)
void | setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | setCustomerId(java.lang.String customerId)
void | setCustomerPo(java.lang.String customerPo)
void | setDateInvoiced(java.util.Date dateInvoiced)
void | setDatePaid(java.util.Date datePaid)
void | setDateShipped(java.util.Date dateShipped)
void | setDebitAccount(java.lang.String DebitAccount)
void | setDue(java.math.BigDecimal due)
void | setFreightBill(java.lang.String freightBill)
void | setFreightRateCode(java.lang.String freightRateCode)
void | setGrossWeight(java.lang.String grossWeight)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setInvoicedBy(java.lang.String invoicedBy)
void | setInvoicedDate(java.util.Date invoicedDate)
void | setLanguage(java.lang.String language)
void | setLastChangedate(java.util.Date lastChangedate)
void | setLastChangeTime(int lastChangeTime)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setOrigin(java.lang.String origin)
void | setOTran(java.lang.String oTran)
void | setPaid(java.math.BigDecimal paid)
void | setPayDate(java.util.Date payDate)
void | setPfInvoiceNumber(java.lang.String pfInvoiceNumber)
void | setProject(java.lang.String project)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setRemitId(java.lang.String remitId)
void | setRTran(java.lang.String rTran)
void | setSalesman(java.lang.String salesman)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setShippedBy(java.lang.String shippedBy)
void | setShippedDate(java.util.Date shippedDate)
void | setShipperBp(java.lang.String shipperBp)
void | setShipperComments(java.lang.String shipperComments)
void | setShipperItems(java.util.Set shipperItem)
void | setShipperNumber(java.lang.String shipperNumber)
void | setShipperPrivateNotes(java.lang.String shipperPrivateNotes)
void | setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | setShipToId(java.lang.String shipToId)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setTerms(java.lang.String terms)
void | setTracking(java.lang.String tracking)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ShipperVO

public ShipperVO()
Method Detail

getShipperNumber

public java.lang.String getShipperNumber()

setShipperNumber

public void setShipperNumber(java.lang.String shipperNumber)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getArInvoiceNumber

public java.lang.String getArInvoiceNumber()

setArInvoiceNumber

public void setArInvoiceNumber(java.lang.String arInvoiceNumber)

getPfInvoiceNumber

public java.lang.String getPfInvoiceNumber()

setPfInvoiceNumber

public void setPfInvoiceNumber(java.lang.String pfInvoiceNumber)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getBillToId

public java.lang.String getBillToId()

setBillToId

public void setBillToId(java.lang.String billToId)

getCustomerPo

public java.lang.String getCustomerPo()

setCustomerPo

public void setCustomerPo(java.lang.String customerPo)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangedate

public java.util.Date getLastChangedate()

setLastChangedate

public void setLastChangedate(java.util.Date lastChangedate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getArSub

public java.math.BigDecimal getArSub()

setArSub

public void setArSub(java.math.BigDecimal arSub)

getArShip

public java.math.BigDecimal getArShip()

setArShip

public void setArShip(java.math.BigDecimal arShip)

getArOpen

public java.math.BigDecimal getArOpen()

setArOpen

public void setArOpen(java.math.BigDecimal arOpen)

getArDiscount

public java.math.BigDecimal getArDiscount()

setArDiscount

public void setArDiscount(java.math.BigDecimal arDiscount)

getArNet

public java.math.BigDecimal getArNet()

setArNet

public void setArNet(java.math.BigDecimal arNet)

getArTax

public java.math.BigDecimal getArTax()

setArTax

public void setArTax(java.math.BigDecimal arTax)

getArFreight

public java.math.BigDecimal getArFreight()

setArFreight

public void setArFreight(java.math.BigDecimal arFreight)

getArTotal

public java.math.BigDecimal getArTotal()

setArTotal

public void setArTotal(java.math.BigDecimal arTotal)

getArPaidInvoice

public java.math.BigDecimal getArPaidInvoice()

setArPaidInvoice

public void setArPaidInvoice(java.math.BigDecimal arPaidInvoice)

getArPaidGl

public java.math.BigDecimal getArPaidGl()

setArPaidGl

public void setArPaidGl(java.math.BigDecimal arPaidGl)

getArGl1Recorded

public java.math.BigDecimal getArGl1Recorded()

setArGl1Recorded

public void setArGl1Recorded(java.math.BigDecimal arGl1Recorded)

getArGl2Paid

public java.math.BigDecimal getArGl2Paid()

setArGl2Paid

public void setArGl2Paid(java.math.BigDecimal arGl2Paid)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getSalesman

public java.lang.String getSalesman()

setSalesman

public void setSalesman(java.lang.String salesman)

getShippedDate

public java.util.Date getShippedDate()

setShippedDate

public void setShippedDate(java.util.Date shippedDate)

getShippedBy

public java.lang.String getShippedBy()

setShippedBy

public void setShippedBy(java.lang.String shippedBy)

getInvoicedDate

public java.util.Date getInvoicedDate()

setInvoicedDate

public void setInvoicedDate(java.util.Date invoicedDate)

getInvoicedBy

public java.lang.String getInvoicedBy()

setInvoicedBy

public void setInvoicedBy(java.lang.String invoicedBy)

getShipToId

public java.lang.String getShipToId()

setShipToId

public void setShipToId(java.lang.String shipToId)

getRemitId

public java.lang.String getRemitId()

setRemitId

public void setRemitId(java.lang.String remitId)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAccount

public java.lang.String getCarrierAccount()

setCarrierAccount

public void setCarrierAccount(java.lang.String carrierAccount)

getFreightRateCode

public java.lang.String getFreightRateCode()

setFreightRateCode

public void setFreightRateCode(java.lang.String freightRateCode)

getGrossWeight

public java.lang.String getGrossWeight()

setGrossWeight

public void setGrossWeight(java.lang.String grossWeight)

getTracking

public java.lang.String getTracking()

setTracking

public void setTracking(java.lang.String tracking)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getDateShipped

public java.util.Date getDateShipped()

setDateShipped

public void setDateShipped(java.util.Date dateShipped)

getDateInvoiced

public java.util.Date getDateInvoiced()

setDateInvoiced

public void setDateInvoiced(java.util.Date dateInvoiced)

getFreightBill

public java.lang.String getFreightBill()

setFreightBill

public void setFreightBill(java.lang.String freightBill)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getDebitAccount

public java.lang.String getDebitAccount()

setDebitAccount

public void setDebitAccount(java.lang.String DebitAccount)

getBp

public java.lang.String getBp()

setBp

public void setBp(java.lang.String bp)

getShipperComments

public java.lang.String getShipperComments()

setShipperComments

public void setShipperComments(java.lang.String shipperComments)

getShipperPrivateNotes

public java.lang.String getShipperPrivateNotes()

setShipperPrivateNotes

public void setShipperPrivateNotes(java.lang.String shipperPrivateNotes)

getDue

public java.math.BigDecimal getDue()

setDue

public void setDue(java.math.BigDecimal due)

getPayDate

public java.util.Date getPayDate()

setPayDate

public void setPayDate(java.util.Date payDate)

getDatePaid

public java.util.Date getDatePaid()

setDatePaid

public void setDatePaid(java.util.Date datePaid)

getCheckNumber

public java.lang.String getCheckNumber()

setCheckNumber

public void setCheckNumber(java.lang.String checkNumber)

getPaid

public java.math.BigDecimal getPaid()

setPaid

public void setPaid(java.math.BigDecimal paid)

getOTran

public java.lang.String getOTran()

setOTran

public void setOTran(java.lang.String oTran)

getRTran

public java.lang.String getRTran()

setRTran

public void setRTran(java.lang.String rTran)

getLastChangeTime

public int getLastChangeTime()

setLastChangeTime

public void setLastChangeTime(int lastChangeTime)

getShipToAddressInfo

public CustomerVendorAddressInfoVO getShipToAddressInfo()

setShipToAddressInfo

public void setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)

getBillToAddressInfo

public CustomerVendorAddressInfoVO getBillToAddressInfo()

setBillToAddressInfo

public void setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)

getShipperItems

public java.util.Set getShipperItems()

getArTaxSet

public java.lang.String getArTaxSet()

getArNetSet

public java.lang.String getArNetSet()

getBatch

public java.lang.String getBatch()

getShipperBp

public java.lang.String getShipperBp()

getCoComments

public java.lang.String getCoComments()

setShipperItems

public void setShipperItems(java.util.Set shipperItem)

setArTaxSet

public void setArTaxSet(java.lang.String arTaxSet)

setArNetSet

public void setArNetSet(java.lang.String arNetSet)

setBatch

public void setBatch(java.lang.String batch)

setShipperBp

public void setShipperBp(java.lang.String shipperBp)

setCoComments

public void setCoComments(java.lang.String coComments)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getCustomerAddressInfo

public CustomerVendorAddressInfoVO getCustomerAddressInfo()

setCustomerAddressInfo

public void setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShippingItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ShippingItemResult

java.lang.Object
    extended by  bb.common.ShippingItemResult
All Implemented Interfaces:
java.io.Serializable
public class ShippingItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ShippingItemResult()
Method Summary
java.math.BigDecimal | getAvgCost()
java.lang.String | getComments()
java.math.BigDecimal | getDemand()
java.lang.String | getDescription()
java.lang.String | getDrawing()
java.lang.String | getItemNumber()
java.lang.String | getMfg()
java.lang.String | getMpn()
java.lang.String | getNcrNumber()
java.math.BigDecimal | getOnhand()
java.lang.String | getOrderNumber()
java.util.Set | getOthersLocations()
java.lang.String | getPartFrom()
java.util.Set | getPartOnhandLocations()
PartPK | getPartPk()
java.util.Set<PartTrackingVO> | getPartTracking()
java.lang.String | getPoUnit()
java.math.BigDecimal | getPoUnitQty()
java.lang.String | getPrivateNotes()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getQuantityShip()
java.math.BigDecimal | getQuantitySip()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.lang.String | getRevision()
java.util.Date | getShipDate()
java.lang.String | getStatus()
java.lang.String | getUnit()
boolean | isTraceable()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setComments(java.lang.String comments)
void | setDemand(java.math.BigDecimal demand)
void | setDescription(java.lang.String description)
void | setDrawing(java.lang.String drawing)
void | setItemNumber(java.lang.String itemNumber)
void | setMfg(java.lang.String mfg)
void | setMpn(java.lang.String mpn)
void | setNcrNumber(java.lang.String ncrNumber)
void | setOnhand(java.math.BigDecimal onhand)
void | setOrderNumber(java.lang.String orderNumber)
void | setOthersLocations(java.util.Set othersLocations)
void | setPartFrom(java.lang.String partFrom)
void | setPartOnhandLocations(java.util.Set partOnhandLocations)
void | setPartPk(PartPK partPk)
void | setPartTracking(java.util.Set<PartTrackingVO> partTracking)
void | setPoUnit(java.lang.String poUnit)
void | setPoUnitQty(java.math.BigDecimal poUnitQty)
void | setPrivateNotes(java.lang.String privateNotes)
void | setQuantity(java.math.BigDecimal quantity)
void | setQuantityShip(java.math.BigDecimal quantityShip)
void | setQuantitySip(java.math.BigDecimal quantitySip)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setRevision(java.lang.String revision)
void | setShipDate(java.util.Date shipDate)
void | setStatus(java.lang.String status)
void | setTraceable(boolean traceable)
void | setUnit(java.lang.String unit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ShippingItemResult

public ShippingItemResult()
Method Detail

getOrderNumber

public java.lang.String getOrderNumber()

getItemNumber

public java.lang.String getItemNumber()

getPartFrom

public java.lang.String getPartFrom()

getRevision

public java.lang.String getRevision()

getDrawing

public java.lang.String getDrawing()

getDescription

public java.lang.String getDescription()

getQuantity

public java.math.BigDecimal getQuantity()

getQuantityShip

public java.math.BigDecimal getQuantityShip()

getUnit

public java.lang.String getUnit()

getMfg

public java.lang.String getMfg()

getMpn

public java.lang.String getMpn()

getComments

public java.lang.String getComments()

getPrivateNotes

public java.lang.String getPrivateNotes()

getRefDoc1

public java.lang.String getRefDoc1()

getRefDoc2

public java.lang.String getRefDoc2()

getOnhand

public java.math.BigDecimal getOnhand()

getPartOnhandLocations

public java.util.Set getPartOnhandLocations()

getPartPk

public PartPK getPartPk()

getStatus

public java.lang.String getStatus()

getQuantitySip

public java.math.BigDecimal getQuantitySip()

getAvgCost

public java.math.BigDecimal getAvgCost()

getDemand

public java.math.BigDecimal getDemand()

setOrderNumber

public void setOrderNumber(java.lang.String orderNumber)

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setRevision

public void setRevision(java.lang.String revision)

setDrawing

public void setDrawing(java.lang.String drawing)

setDescription

public void setDescription(java.lang.String description)

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

setQuantityShip

public void setQuantityShip(java.math.BigDecimal quantityShip)

setUnit

public void setUnit(java.lang.String unit)

setMfg

public void setMfg(java.lang.String mfg)

setMpn

public void setMpn(java.lang.String mpn)

setComments

public void setComments(java.lang.String comments)

setPrivateNotes

public void setPrivateNotes(java.lang.String privateNotes)

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

setPartOnhandLocations

public void setPartOnhandLocations(java.util.Set partOnhandLocations)

setPartPk

public void setPartPk(PartPK partPk)

setStatus

public void setStatus(java.lang.String status)

setQuantitySip

public void setQuantitySip(java.math.BigDecimal quantitySip)

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

setDemand

public void setDemand(java.math.BigDecimal demand)

getOthersLocations

public java.util.Set getOthersLocations()

setOthersLocations

public void setOthersLocations(java.util.Set othersLocations)

getShipDate

public java.util.Date getShipDate()

setShipDate

public void setShipDate(java.util.Date shipDate)

getNcrNumber

public java.lang.String getNcrNumber()

setNcrNumber

public void setNcrNumber(java.lang.String ncrNumber)

getPoUnit

public java.lang.String getPoUnit()

setPoUnit

public void setPoUnit(java.lang.String poUnit)

getPoUnitQty

public java.math.BigDecimal getPoUnitQty()

setPoUnitQty

public void setPoUnitQty(java.math.BigDecimal poUnitQty)

getPartTracking

public java.util.Set<PartTrackingVO> getPartTracking()

setPartTracking

public void setPartTracking(java.util.Set<PartTrackingVO> partTracking)

isTraceable

public boolean isTraceable()

setTraceable

public void setTraceable(boolean traceable)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShippingResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ShippingResult

java.lang.Object
    extended by  bb.common.ShippingResult
All Implemented Interfaces:
java.io.Serializable
public class ShippingResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ShippingResult()
Method Summary
java.math.BigDecimal | getArPrepay()
java.math.BigDecimal | getArPrepayGl()
java.lang.String | getChangOrder()
java.lang.String | getCustomerId()
java.lang.String | getCustomerName()
java.math.BigDecimal | getFreight()
java.lang.String | getIncoterm()
java.lang.String | getOrderNumber()
java.lang.String | getPlacePort()
java.util.Set | getShippingItems()
boolean | isHold()
void | setArPrepay(java.math.BigDecimal arPrepay)
void | setArPrepayGl(java.math.BigDecimal arPrepayGl)
void | setChangOrder(java.lang.String changOrder)
void | setCustomerId(java.lang.String customerId)
void | setCustomerName(java.lang.String customerName)
void | setFreight(java.math.BigDecimal freight)
void | setHold(boolean hold)
void | setIncoterm(java.lang.String incoterm)
void | setOrderNumber(java.lang.String orderNumber)
void | setPlacePort(java.lang.String placePort)
void | setShippingItems(java.util.Set shippingItems)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ShippingResult

public ShippingResult()
Method Detail

getOrderNumber

public java.lang.String getOrderNumber()

getChangOrder

public java.lang.String getChangOrder()

getCustomerId

public java.lang.String getCustomerId()

getCustomerName

public java.lang.String getCustomerName()

getIncoterm

public java.lang.String getIncoterm()

getPlacePort

public java.lang.String getPlacePort()

getShippingItems

public java.util.Set getShippingItems()

setOrderNumber

public void setOrderNumber(java.lang.String orderNumber)

setChangOrder

public void setChangOrder(java.lang.String changOrder)

setCustomerId

public void setCustomerId(java.lang.String customerId)

setCustomerName

public void setCustomerName(java.lang.String customerName)

setIncoterm

public void setIncoterm(java.lang.String incoterm)

setPlacePort

public void setPlacePort(java.lang.String placePort)

setShippingItems

public void setShippingItems(java.util.Set shippingItems)

getFreight

public java.math.BigDecimal getFreight()

setFreight

public void setFreight(java.math.BigDecimal freight)

getArPrepay

public java.math.BigDecimal getArPrepay()

setArPrepay

public void setArPrepay(java.math.BigDecimal arPrepay)

getArPrepayGl

public java.math.BigDecimal getArPrepayGl()

setArPrepayGl

public void setArPrepayGl(java.math.BigDecimal arPrepayGl)

isHold

public boolean isHold()

setHold

public void setHold(boolean hold)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShoppingCartItem

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ShoppingCartItem

java.lang.Object
    extended by  bb.common.ShoppingCartItem
All Implemented Interfaces:
java.io.Serializable
public class ShoppingCartItem
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ShoppingCartItem()
ShoppingCartItem(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.math.BigDecimal quantity, java.lang.String description)
Method Summary
java.util.Date | getDateRequired()
java.lang.String | getDescription()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getQuantity()
java.lang.String | getRev()
void | setDateRequired(java.util.Date dateRequired)
void | setDescription(java.lang.String description)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setQuantity(java.math.BigDecimal quantity)
void | setRev(java.lang.String rev)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ShoppingCartItem

public ShoppingCartItem()

ShoppingCartItem

public ShoppingCartItem(java.lang.String partNumber,
                        java.lang.String partType,
                        java.lang.String partFrom,
                        java.math.BigDecimal quantity,
                        java.lang.String description)
Method Detail

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartNumber

public java.lang.String getPartNumber()

getPartType

public java.lang.String getPartType()

getQuantity

public java.math.BigDecimal getQuantity()

getDescription

public java.lang.String getDescription()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

setPartType

public void setPartType(java.lang.String partType)

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

setDescription

public void setDescription(java.lang.String description)

getRev

public java.lang.String getRev()

setRev

public void setRev(java.lang.String rev)

getDateRequired

public java.util.Date getDateRequired()

setDateRequired

public void setDateRequired(java.util.Date dateRequired)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


S-Index

Overview

Package

Class

Use

Tree

Deprecated

Index

Help

PREV LETTER NEXT LETTER

FRAMES NO FRAMES

A B C D E F G H I J L M N O P Q R S T U V W X Y Z

S

S - Static variable in class bb.common.Constant.Prefix

SALES - Static variable in class bb.common.Configure.Module

SALES_CODE - Static variable in class bb.common.BizTarget

SALES_CODE_ALREADY_EXIST - Static variable in class bb.common.BIZReason

SALES_CODE_NOT_EXIST - Static variable in class bb.common.BIZReason

SALES_ITEM_HAS_BEEN_CLOSED - Static variable in class bb.common.BIZReason

SALES_ITEM_HAS_BEEN_CREATED_INVOICE - Static variable in class bb.common.BIZReason

SALES_ORDER - Static variable in class bb.common.BizTarget

SALES_ORDER_ALREADY_CLOSED - Static variable in class bb.common.BIZReason

SALES_ORDER_ALREADY_REVIEWED - Static variable in class bb.common.BIZReason

SALES_ORDER_ALREADY_SHIPPED - Static variable in class bb.common.BIZReason

SALES_ORDER_CURRENCY - Static variable in class bb.common.BizTarget

SALES_ORDER_HAS_BEEN_CLOSED - Static variable in class bb.common.BIZReason

SALES_ORDER_HAS_BEEN_HOLD - Static variable in class bb.common.BIZReason

SALES_ORDER_IS_BILL_AND_HOLD - Static variable in class bb.common.BIZReason

SALES_ORDER_IS_NOT_REVIEWED - Static variable in class bb.common.BIZReason

SALES_ORDER_ITEM - Static variable in class bb.common.BizTarget

SALES_ORDER_ITEM_ALREADY_COMPLETED - Static variable in class bb.common.BIZReason

SALES_ORDER_ITEM_ALREADY_SHIPPED_OR_IN_SIP - Static variable in class bb.common.BIZReason

SALES_ORDER_ITEM_HAS_EXIST - Static variable in class bb.common.BIZReason

SALES_ORDER_ITEM_MFG - Static variable in class bb.common.BizTarget

SALES_ORDER_ITEM_MFG_PK_WRONG - Static variable in class bb.common.BIZReason

SALES_ORDER_ITEM_NOT_EXIST - Static variable in class bb.common.BIZReason

SALES_ORDER_ITEM_NOT_EXIST_FOR_THIS_SHIPPER_ITEM - Static variable in class bb.common.BIZReason

SALES_ORDER_ITEM_NOT_OPEN - Static variable in class bb.common.BIZReason

SALES_ORDER_ITEM_PK_WRONG - Static variable in class bb.common.BIZReason

SALES_ORDER_ITEM_WITHOUT_SUCH_QTY_TO_SHIPPED - Static variable in class bb.common.BIZReason

SALES_ORDER_NOT_EXIST - Static variable in class bb.common.BIZReason

SALES_ORDER_NOT_OPEN - Static variable in class bb.common.BIZReason

SALES_ORDER_REVIEW - Static variable in class bb.common.BizTarget

SALES_ORDER_REVIEW_ALREADY_EXIST - Static variable in class bb.common.BIZReason

SALES_ORDER_REVIEW_NOT_EXIST - Static variable in class bb.common.BIZReason

SALES_ORDER_SHIPPER_NOT_EXIST - Static variable in class bb.common.BIZReason

SalesBomItemResult - Class in bb.common

SalesBomItemResult() - Constructor for class bb.common.SalesBomItemResult

SalesBomResult - Class in bb.common

SalesBomResult() - Constructor for class bb.common.SalesBomResult

SalesBox - Interface in bb.common.box

SalesCodeVO - Class in bb.common

SalesCodeVO() - Constructor for class bb.common.SalesCodeVO

SalesInfoCenter - Class in bb.common

SalesInfoCenter() - Constructor for class bb.common.SalesInfoCenter

SalesInfoCenter.DueSoCount - Class in bb.common

SalesInfoCenter.DueSoCount() - Constructor for class bb.common.SalesInfoCenter.DueSoCount

SalesInfoCenter.DueSoSum - Class in bb.common

SalesInfoCenter.DueSoSum() - Constructor for class bb.common.SalesInfoCenter.DueSoSum

SalesInfoCenter.GrossMargin - Class in bb.common

SalesInfoCenter.GrossMargin() - Constructor for class bb.common.SalesInfoCenter.GrossMargin

SalesInfoCenter.InvoicedSum - Class in bb.common

SalesInfoCenter.InvoicedSum() - Constructor for class bb.common.SalesInfoCenter.InvoicedSum

SalesInfoCenter.OpenSoSum - Class in bb.common

SalesInfoCenter.OpenSoSum() - Constructor for class bb.common.SalesInfoCenter.OpenSoSum

SalesInfoCenter.SoCount - Class in bb.common

SalesInfoCenter.SoCount() - Constructor for class bb.common.SalesInfoCenter.SoCount

SalesInfoCenter.SoCountWithPartsOnhold - Class in bb.common

SalesInfoCenter.SoCountWithPartsOnhold() - Constructor for class bb.common.SalesInfoCenter.SoCountWithPartsOnhold

SalesInfoCenter.SoItemCount - Class in bb.common

SalesInfoCenter.SoItemCount() - Constructor for class bb.common.SalesInfoCenter.SoItemCount

SalesInfoCenter.SoTotalSum - Class in bb.common

SalesInfoCenter.SoTotalSum() - Constructor for class bb.common.SalesInfoCenter.SoTotalSum

SalesInfoCenterResult - Class in bb.common

SalesInfoCenterResult() - Constructor for class bb.common.SalesInfoCenterResult

SALESMAN - Static variable in class bb.common.BizTarget

SALESMAN_NOT_EXIST - Static variable in class bb.common.BIZReason

SalesmanVO - Class in bb.common

SalesmanVO() - Constructor for class bb.common.SalesmanVO

SalesMarginListResult - Class in bb.common

SalesMarginListResult() - Constructor for class bb.common.SalesMarginListResult

SalesOnTimeResult - Class in bb.common

SalesOnTimeResult() - Constructor for class bb.common.SalesOnTimeResult

SALESORDER - Static variable in class bb.common.Constant.OrderType

SalesOrder - Static variable in class bb.common.Constant.ReceivedTo

SalesOrder12MonthMarginResult - Class in bb.common

SalesOrder12MonthMarginResult() - Constructor for class bb.common.SalesOrder12MonthMarginResult

SalesOrderBoilerplateVO - Class in bb.common

SalesOrderBoilerplateVO(String, String, String) - Constructor for class bb.common.SalesOrderBoilerplateVO
full constructor
SalesOrderBoilerplateVO() - Constructor for class bb.common.SalesOrderBoilerplateVO
default constructor
SalesOrderBoilerplateVO(String, String) - Constructor for class bb.common.SalesOrderBoilerplateVO
minimal constructor
SalesOrderCheckListResult - Class in bb.common

SalesOrderCheckListResult() - Constructor for class bb.common.SalesOrderCheckListResult

SalesOrderDocumentVO - Class in bb.common

SalesOrderDocumentVO() - Constructor for class bb.common.SalesOrderDocumentVO

SalesOrderItemCostResult - Class in bb.common

SalesOrderItemCostResult() - Constructor for class bb.common.SalesOrderItemCostResult

SalesOrderItemCustomerTotalResult - Class in bb.common

SalesOrderItemCustomerTotalResult() - Constructor for class bb.common.SalesOrderItemCustomerTotalResult

SalesOrderItemGroupByPartListResult - Class in bb.common

SalesOrderItemGroupByPartListResult() - Constructor for class bb.common.SalesOrderItemGroupByPartListResult

SalesOrderItemInfoVO - Class in bb.common

SalesOrderItemInfoVO() - Constructor for class bb.common.SalesOrderItemInfoVO

SalesOrderItemListResult - Class in bb.common

SalesOrderItemListResult() - Constructor for class bb.common.SalesOrderItemListResult

SalesOrderItemManufacturerPK - Class in bb.common

SalesOrderItemManufacturerPK(String, String, Short) - Constructor for class bb.common.SalesOrderItemManufacturerPK
full constructor
SalesOrderItemManufacturerPK() - Constructor for class bb.common.SalesOrderItemManufacturerPK
default constructor
SalesOrderItemManufacturerVO - Class in bb.common

SalesOrderItemManufacturerVO() - Constructor for class bb.common.SalesOrderItemManufacturerVO

SalesOrderItemPK - Class in bb.common

SalesOrderItemPK(String, String) - Constructor for class bb.common.SalesOrderItemPK
full constructor
SalesOrderItemPK() - Constructor for class bb.common.SalesOrderItemPK
default constructor
SalesOrderItemVO - Class in bb.common

SalesOrderItemVO() - Constructor for class bb.common.SalesOrderItemVO

SalesOrderListResult - Class in bb.common

SalesOrderListResult() - Constructor for class bb.common.SalesOrderListResult

salesOrderNumber - Variable in class bb.common.SoPickListResult

SalesOrderOnDemandResult - Class in bb.common

SalesOrderOnDemandResult() - Constructor for class bb.common.SalesOrderOnDemandResult

SalesOrderOnTimeItemResult - Class in bb.common

SalesOrderOnTimeItemResult() - Constructor for class bb.common.SalesOrderOnTimeItemResult

SalesOrderOnTimeResult - Class in bb.common

SalesOrderOnTimeResult() - Constructor for class bb.common.SalesOrderOnTimeResult

SalesOrderOrphanedResult - Class in bb.common

SalesOrderOrphanedResult() - Constructor for class bb.common.SalesOrderOrphanedResult

SalesOrderReviewVO - Class in bb.common

SalesOrderReviewVO() - Constructor for class bb.common.SalesOrderReviewVO

SalesOrderShipDateListResult - Class in bb.common

SalesOrderShipDateListResult() - Constructor for class bb.common.SalesOrderShipDateListResult

SalesOrderVO - Class in bb.common

SalesOrderVO() - Constructor for class bb.common.SalesOrderVO
default constructor
SalesPartListItemResult - Class in bb.common

SalesPartListItemResult() - Constructor for class bb.common.SalesPartListItemResult

SalesPartListResult - Class in bb.common

SalesPartListResult() - Constructor for class bb.common.SalesPartListResult

SalesTaxListResult - Class in bb.common

SalesTaxListResult() - Constructor for class bb.common.SalesTaxListResult

SALESTAXRATE - Static variable in class bb.common.Constant.TaxType

SAVE_TO_DB_ERROR - Static variable in class bb.common.BIZReason

saveMPNPart(ArrayList<Map>) - Method in interface bb.common.box.PurchasingBox

savePoMessage(String, String, Hashtable) - Method in interface bb.common.box.PurchasingBox

saveReceiverWithOutAP(String, String, String, Date, Date) - Method in interface bb.common.box.AccountingBox

saveRfqMessage(String, String, Hashtable) - Method in interface bb.common.box.PurchasingBox

saveWoItemSeqStartDate(ArrayList<WorkOrderWorkInstructionSequenceDateAgent>) - Method in interface bb.common.box.WorkOrderBox

saveWorkOrderItemDate(ArrayList<WorkOrderWorkItemDateAgent>) - Method in interface bb.common.box.WorkOrderBox

scrapAsset(AssetVO, ScrapAssetAgent) - Method in interface bb.common.box.AccountingBox

ScrapAssetAgent - Class in bb.common

ScrapAssetAgent() - Constructor for class bb.common.ScrapAssetAgent

SCRAPPED - Static variable in class bb.common.Constant.EquipmentStatus

SCRAPPED - Static variable in class bb.common.Constant.Status

ScrapReportVO - Class in bb.common

ScrapReportVO() - Constructor for class bb.common.ScrapReportVO

SECOND - Static variable in class bb.common.Constant.ECRPriority

SECURITY - Static variable in class bb.common.Configure.Module

SECURITY_ACCESS_TO_METHOD - Static variable in class bb.common.BIZReason

SecurityBox - Interface in bb.common.box

SEND_MAIL_ERROR - Static variable in class bb.common.BIZReason

sendARStatement(BB2Notice) - Method in interface bb.common.box.CompanyBox

sendBugNotice(BB2BugNotice) - Method in interface bb.common.box.CompanyBox

sendNotice(BB2Notice) - Method in interface bb.common.box.CompanyBox

sendPoNotice(BB2Notice) - Method in interface bb.common.box.CompanyBox

sendQuoteNotice(BB2Notice) - Method in interface bb.common.box.CompanyBox

sendRfqNotice(BB2Notice) - Method in interface bb.common.box.CompanyBox

SENT_TO_QC - Static variable in class bb.common.Constant.ReceiveCondition

SEQNO - Static variable in class bb.common.Constant.PartNumberGenerateType

SERIAL_NUMBER - Static variable in class bb.common.BizTarget

SERIAL_NUMBER - Static variable in class bb.common.Constant

SERIAL_NUMBER_ALREADY_EXIST - Static variable in class bb.common.BIZReason

SERIAL_NUMBER_NOT_EXIST - Static variable in class bb.common.BIZReason

SerialNumberItemPK - Class in bb.common

SerialNumberItemPK(String, String, String) - Constructor for class bb.common.SerialNumberItemPK
full constructor
SerialNumberItemPK() - Constructor for class bb.common.SerialNumberItemPK
default constructor
SerialNumberItemResult - Class in bb.common

SerialNumberItemResult() - Constructor for class bb.common.SerialNumberItemResult

SerialNumberItemVO - Class in bb.common

SerialNumberItemVO() - Constructor for class bb.common.SerialNumberItemVO

SerialNumberPK - Class in bb.common

SerialNumberPK(String, String) - Constructor for class bb.common.SerialNumberPK
full constructor
SerialNumberPK() - Constructor for class bb.common.SerialNumberPK
default constructor
SerialNumberResult - Class in bb.common

SerialNumberResult() - Constructor for class bb.common.SerialNumberResult

SerialNumberVO - Class in bb.common

SerialNumberVO() - Constructor for class bb.common.SerialNumberVO
default constructor
SERVER_TIME_ERROR - Static variable in class bb.common.BIZReason

ServerAction - Class in bb.common

ServerAction(String, String, Object[], Class[]) - Constructor for class bb.common.ServerAction

ServerAction(String, String) - Constructor for class bb.common.ServerAction

serverAndOrg - Static variable in class bb.common.Configure.Organization

ServerClientPropertyPK - Class in bb.common

ServerClientPropertyPK() - Constructor for class bb.common.ServerClientPropertyPK

ServerClientPropertyVO - Class in bb.common

ServerClientPropertyVO() - Constructor for class bb.common.ServerClientPropertyVO

ServerException - Exception in bb.common

ServerException() - Constructor for exception bb.common.ServerException

ServerException(Exception) - Constructor for exception bb.common.ServerException

ServerException(Exception, String) - Constructor for exception bb.common.ServerException

ServerException(String) - Constructor for exception bb.common.ServerException

servers - Static variable in class bb.common.Configure.Organization

setAccepted(Date) - Method in class bb.common.CustomerReturnToVendorItemVO

setAccepted(Date) - Method in class bb.common.RequestForRMAItemVO

setAccepted(Date) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setAccepted(Date) - Method in class bb.common.ReturnToVendorItemVO

setAcceptedBy(String) - Method in class bb.common.CustomerReturnToVendorItemVO

setAcceptedBy(String) - Method in class bb.common.PurchaseOrderItemVO

setAcceptedBy(String) - Method in class bb.common.RequestForRMAItemVO

setAcceptedBy(String) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setAcceptedBy(String) - Method in class bb.common.ReturnToVendorItemVO

setAcceptedDate(Date) - Method in class bb.common.PurchaseOrderItemVO

setAccessPassword(String) - Method in class bb.common.SubcompanyVO

setAccessUserName(String) - Method in class bb.common.SubcompanyVO

setAccmDepreciateCost(BigDecimal) - Method in class bb.common.AssetAddOrDisposalsReport

setAccount(String) - Method in class bb.common.AssetAmortizationExpenseAccountVO

setAccountCredit(Set) - Method in class bb.common.GeneralLedgerVO

setAccountDebit(Set) - Method in class bb.common.GeneralLedgerVO

setAccountDescription(String) - Method in class bb.common.AccountBalanceListResult

setAccountDescription(String) - Method in class bb.common.BalanceSheetSideBySideItemResult

setAccountDescription(String) - Method in class bb.common.ClosingStatementItemResult

setAccountDescription(String) - Method in class bb.common.DepositSummaryResult

setAccountDescription(String) - Method in class bb.common.ExchangeAuditItemResult

setAccountDescription(String) - Method in class bb.common.GLCheckRegisterResult

setAccountDescription(String) - Method in class bb.common.ShareHoldersEquityResult

setAccountDesctiption(String) - Method in class bb.common.GeneralLedgerByDateListResult

setAccountingMail(boolean) - Method in class bb.common.CustomerVendorContactVO

setAccountingReportType(String) - Method in class bb.common.AccountingInfoDocumentVO

setAccountNumber(String) - Method in class bb.common.AccountBalanceListResult

setAccountNumber(String) - Method in class bb.common.AccountBalanceResult

setAccountNumber(String) - Method in class bb.common.AccountCreditVO

setAccountNumber(String) - Method in class bb.common.AccountDebitVO

setAccountNumber(String) - Method in class bb.common.AccountMonthPK

setAccountNumber(String) - Method in class bb.common.AccountPayableCheckVO

setAccountNumber(String) - Method in class bb.common.AccountsChartVO

setAccountNumber(String) - Method in class bb.common.AccountsCreditDebitListResult

setAccountNumber(String) - Method in class bb.common.AccountsPayableItemVO

setAccountNumber(String) - Method in class bb.common.AccountsReceivableItemVO

setAccountNumber(String) - Method in class bb.common.AddressAccountInfo

setAccountNumber(String) - Method in class bb.common.AmountsStatementResult

setAccountNumber(String) - Method in class bb.common.BalanceSheetSideBySideItemResult

setAccountNumber(String) - Method in class bb.common.BB2tripleString

setAccountNumber(String) - Method in class bb.common.BudgetListResult

setAccountNumber(String) - Method in class bb.common.ClosingStatementItemResult

setAccountNumber(String) - Method in class bb.common.CompanyUnitAccountPK

setAccountNumber(String) - Method in class bb.common.DepositSummaryResult

setAccountNumber(String) - Method in class bb.common.DisassembleWorkOrderItemListResult

setAccountNumber(String) - Method in class bb.common.DWOIssueDetail

setAccountNumber(String) - Method in class bb.common.ExchangeAuditItemResult

setAccountNumber(String) - Method in class bb.common.ExpenseAccountVO

setAccountNumber(String) - Method in class bb.common.GeneralLedgerByDateListResult

setAccountNumber(String) - Method in class bb.common.GeneralLedgerEntry

setAccountNumber(String) - Method in class bb.common.GLCheckRegisterResult

setAccountNumber(String) - Method in class bb.common.GLDebitCreditListResult

setAccountNumber(String) - Method in class bb.common.GLItemVO

setAccountNumber(String) - Method in class bb.common.MakeCheckAgent

setAccountNumber(String) - Method in class bb.common.MakePrepaymentCheckAgent

setAccountNumber(String) - Method in class bb.common.MultiLanguageAccountsChartPK

setAccountNumber(String) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setAccountNumber(String) - Method in class bb.common.NonproductivePickingItemResult

setAccountNumber(String) - Method in class bb.common.NonproductivePickingTypeVO

setAccountNumber(String) - Method in class bb.common.NonproductivePickingVO

setAccountNumber(String) - Method in class bb.common.PaymentAgent

setAccountNumber(String) - Method in class bb.common.POReceiverItemListResult

setAccountNumber(String) - Method in class bb.common.PrepayPaymentAgent

setAccountNumber(String) - Method in class bb.common.ProfitAndLossAccountsResult

setAccountNumber(String) - Method in class bb.common.ProfitLossStatementItemResult

setAccountNumber(String) - Method in class bb.common.PurchaseOrderItemListResult

setAccountNumber(String) - Method in class bb.common.SalesOrderItemListResult

setAccountNumber(String) - Method in class bb.common.ShareHoldersEquityResult

setAccountNumber(String) - Method in class bb.common.ShipperItemListResult

setAccountNumber(String) - Method in class bb.common.TaxAccountVO

setAccountNumber(String) - Method in class bb.common.WOReceiverDetail

setAccountNumber(String) - Method in class bb.common.WorkOrderItemListResult

setAccountNumberDescription(String) - Method in class bb.common.GeneralLedgerEntry

setAccountPayableNumber(String) - Method in class bb.common.OnloanReceiverVO

setAccountPayableNumber(String) - Method in class bb.common.ReceiverInfoVO

setAccountPayableNumber(String) - Method in class bb.common.ReceiverItemVO

setAccountPayableNumber(String) - Method in class bb.common.ReceiverVO

setAccountReceivableDiscount(BigDecimal) - Method in class bb.common.QuoteItemVO

setAccountReceivableDiscount(BigDecimal) - Method in class bb.common.SalesOrderItemInfoVO

setAccountReceivableDiscount(BigDecimal) - Method in class bb.common.SalesOrderItemVO

setAccountReceivableOpen(BigDecimal) - Method in class bb.common.SalesOrderItemInfoVO

setAccountReceivableOpen(BigDecimal) - Method in class bb.common.SalesOrderItemListResult

setAccountReceivableOpen(BigDecimal) - Method in class bb.common.SalesOrderItemVO

setAccountReceivableShip(BigDecimal) - Method in class bb.common.SalesOrderItemInfoVO

setAccountReceivableShip(BigDecimal) - Method in class bb.common.SalesOrderItemListResult

setAccountReceivableShip(BigDecimal) - Method in class bb.common.SalesOrderItemVO

setAccountReceivableSub(BigDecimal) - Method in class bb.common.QuoteItemVO

setAccountReceivableSub(BigDecimal) - Method in class bb.common.SalesOrderItemInfoVO

setAccountReceivableSub(BigDecimal) - Method in class bb.common.SalesOrderItemVO

setAccountReceivableTax(BigDecimal) - Method in class bb.common.QuoteItemVO

setAccountReceivableTax(BigDecimal) - Method in class bb.common.SalesOrderItemInfoVO

setAccountReceivableTax(BigDecimal) - Method in class bb.common.SalesOrderItemVO

setAccountReceivableTotal(BigDecimal) - Method in class bb.common.QuoteItemVO

setAccountsChart(AccountsChartVO) - Method in class bb.common.AccountCreditVO

setAccountsChart(AccountsChartVO) - Method in class bb.common.AccountDebitVO

setAccountsChart(AccountsChartVO) - Method in class bb.common.GLItemVO

setAccountsChartVO(AccountsChartVO) - Method in class bb.common.AccountsChartResult

setAccountsChartVO(AccountsChartVO) - Method in class bb.common.MonthBalanceResult

setAccountsPayable(BigDecimal) - Method in class bb.common.AccountingBalanceSheetResult

setAccountsPayableItemManufacturer(Set) - Method in class bb.common.AccountsPayableItemVO

setAccountsPayableItems(Set<AccountsPayableItemVO>) - Method in class bb.common.AccountsPayableVO

setAccountsPayableNumber(String) - Method in class bb.common.GeneralLedgerListResult

setAccountsPayableNumber(String) - Method in class bb.common.GeneralLedgerVO

setAccountsReceivable(BigDecimal) - Method in class bb.common.RunningAccountOrderVO

setAccountsReceivableItemManufacturer(Set) - Method in class bb.common.AccountsReceivableItemVO

setAccountsReceivableItems(Set) - Method in class bb.common.AccountsReceivableVO

setAccountSubType(String) - Method in class bb.common.AccountsChartVO

setAccountType(String) - Method in class bb.common.AccountBalanceResult

setAccountType(String) - Method in class bb.common.AccountsChartVO

setAccountType(String) - Method in class bb.common.AmountsStatementResult

setAccountType(String) - Method in class bb.common.BalanceSheetSideBySideItemResult

setAccountType(String) - Method in class bb.common.BudgetListResult

setAccountType(String) - Method in class bb.common.ClosingStatementItemResult

setAccountType(String) - Method in class bb.common.ExchangeAuditItemResult

setAccountType(String) - Method in class bb.common.GeneralLedgerByDateListResult

setAccountType(String) - Method in class bb.common.GlCashFlowBudgetVO

setAccountType(String) - Method in class bb.common.GlFiscalYearBudgetVO

setAccountType(String) - Method in class bb.common.ProfitLossStatementItemResult

setAccountVo(AccountsChartVO) - Method in class bb.common.CurrentBalanceResult

setAcctPeriod(Set) - Method in class bb.common.FiscalYearSettingsVO

setAccumulatedDeprAccount(String) - Method in class bb.common.AssetDepreciateVO

setAccumulatedDeprAccount(String) - Method in class bb.common.AssetVO

setAcknowledgeDate(Date) - Method in class bb.common.PurchaseOrderListResult

setAcknowledgeDate(Date) - Method in class bb.common.PurchaseOrderVO

setAcknowledgedBy(String) - Method in class bb.common.PreventiveActionRequestVO

setAcount(int) - Method in class bb.common.APTaxForZipcodeListResult

setAcount(int) - Method in class bb.common.ARTaxForZipcodeListResult

setAcquisitionCost(BigDecimal) - Method in class bb.common.AssetAddOrDisposalsReport

setAcquisitionCost(BigDecimal) - Method in class bb.common.AssetDepreciateDetailReport

setAcquisitionCost(BigDecimal) - Method in class bb.common.AssetDepreciateVO

setAcquisitionCost(BigDecimal) - Method in class bb.common.AssetReportSumResult

setAcquisitionCost(BigDecimal) - Method in class bb.common.AssetVO

setAcquisitionDate(Date) - Method in class bb.common.AssetAddOrDisposalsReport

setAcquisitionDate(Date) - Method in class bb.common.AssetVO

setAction(String) - Method in class bb.common.BizboxBugChangesInfoVO

setAction(String) - Method in class bb.common.BizboxBugChangesVO

setAction(Integer) - Method in class bb.common.DocumentLogVO

setAction(String) - Method in class bb.common.LogMiscDocumentVO

setAction(String) - Method in class bb.common.LogPartDocumentVO

setAction(String) - Method in class bb.common.LogPartDwfVO

setAction(String) - Method in class bb.common.LogPartDwgVO

setAction(String) - Method in class bb.common.OperationLogVO

setAction(String) - Method in class bb.common.OrderApprovalItemsVO

setAction(String) - Method in class bb.common.OrderApprovalVO

setActionI18nKey(String) - Method in class bb.common.I18nEvent

setActionI18nParams(String[]) - Method in class bb.common.I18nEvent

setActionTime(Date) - Method in class bb.common.OperationLogVO

setActionType(String) - Method in class bb.common.BuyerCodeVO

setActive(boolean) - Method in class bb.common.AccountsChartVO

setActive(boolean) - Method in class bb.common.BudgetListResult

setActive(boolean) - Method in class bb.common.CustomGoodsBreedVO

setActive(String) - Method in class bb.common.CycleCountVO

setActive(boolean) - Method in class bb.common.LabelTemplateVO

setActive(String) - Method in class bb.common.PartInventoryVO

setActive(String) - Method in class bb.common.PartOnhandVO

setActive(String) - Method in class bb.common.PhysicalInventoryVO

setActive(String) - Method in class bb.common.ToolInventoryVO

setActive(String) - Method in class bb.common.ToolOnhandVO

setActived(boolean) - Method in class bb.common.HelpServerVO

setActual(Map) - Method in class bb.common.BudgetListResult

setActual(Date) - Method in class bb.common.CustomerReturnToVendorItemVO

setActual(Date) - Method in class bb.common.CustomerReturnToVendorVO

setActual(Date) - Method in class bb.common.DisassembleWorkOrderItemVO

setActual(String) - Method in class bb.common.DisassembleWorkOrderVO

setActual(Date) - Method in class bb.common.NonproductivePickingItemVO

setActual(Date) - Method in class bb.common.OnLoanItemVO

setActual(Date) - Method in class bb.common.OnLoanVO

setActual(Date) - Method in class bb.common.PurchaseOrderItemVO

setActual(Date) - Method in class bb.common.PurchaseOrderVO

setActual(Date) - Method in class bb.common.RequestForQuoteItemVO

setActual(Date) - Method in class bb.common.RequestForQuoteVO

setActual(Date) - Method in class bb.common.RequestForRMAItemVO

setActual(Date) - Method in class bb.common.RequestForRMAVO

setActual(Date) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setActual(Date) - Method in class bb.common.ReturnMaterialAuthorizationVO

setActual(Date) - Method in class bb.common.ReturnToVendorItemVO

setActual(Date) - Method in class bb.common.ReturnToVendorVO

setActual(Date) - Method in class bb.common.SalesOrderItemInfoVO

setActual(Date) - Method in class bb.common.SalesOrderItemVO

setActual(Date) - Method in class bb.common.SalesOrderVO

setActual(Date) - Method in class bb.common.WorkOrderItemPartDetail

setActual(Date) - Method in class bb.common.WorkOrderItemVO

setActual(String) - Method in class bb.common.WorkOrderVO

setActualAccountsChart(Map<Date, BigDecimal>) - Method in class bb.common.AccountsChartResult

setActualAmount(BigDecimal) - Method in class bb.common.DepositSummaryResult

setActualEndDate(Date) - Method in class bb.common.WorkOrderItemSeqWCLoadResult

setActualEndDate(Date) - Method in class bb.common.WorkOrderWorkInstructionSequenceDateAgent

setActualResult(String) - Method in class bb.common.InspectionConformanceReportItemCheckVO

setActualShipDate(Date) - Method in class bb.common.WorkOrderWorkInstructionListResult

setActualStartDate(Date) - Method in class bb.common.WorkOrderItemSeqWCLoadResult

setActualStartDate(Date) - Method in class bb.common.WorkOrderWorkInstructionSequenceDateAgent

setActualTotal(BigDecimal) - Method in class bb.common.BudgetListResult

setActualTotleMap(HashMap<String, Map>) - Method in class bb.common.BudgetListResult

setActualYTD(Map) - Method in class bb.common.BudgetListResult

setAdate(Date) - Method in class bb.common.AccountsChartVO

setAdate(Date) - Method in class bb.common.AccountsPayableInfoVO

setAdate(Date) - Method in class bb.common.AccountsPayableVO

setAdate(Date) - Method in class bb.common.AccountsReceivableInfoVO

setAdate(Date) - Method in class bb.common.AccountsReceivableVO

setAdate(Date) - Method in class bb.common.AssetVO

setAdate(Date) - Method in class bb.common.CommonPrintTemplateVO

setAdate(Date) - Method in class bb.common.CorrectiveActionRequestVO

setAdate(Date) - Method in class bb.common.CustomerReturnToVendorVO

setAdate(Date) - Method in class bb.common.DisassembleWorkOrderVO

setADate(Date) - Method in class bb.common.EmployeeCardVO

setAdate(Date) - Method in class bb.common.GeneralLedgerListResult

setAdate(Date) - Method in class bb.common.GeneralLedgerVO

setAdate(Date) - Method in class bb.common.InspectionConformanceReportVO

setAdate(Date) - Method in class bb.common.InspectionReportInfoVO

setAdate(Date) - Method in class bb.common.InspectionReportVO

setAdate(Date) - Method in class bb.common.LabelTemplateVO

setADate(Date) - Method in class bb.common.ManufacturerAddressInfoVO

setADate(Date) - Method in class bb.common.ManufacturerAddressVO

setAdate(Date) - Method in class bb.common.NcrNeedToScrapListResult

setAdate(Date) - Method in class bb.common.NonConformanceCodeVO

setAdate(Date) - Method in class bb.common.NonConformanceReportVO

setAdate(Date) - Method in class bb.common.NonproductivePickingOnDemandResult

setAdate(Date) - Method in class bb.common.NonproductivePickingVO

setAdate(Date) - Method in class bb.common.OnloanReceiverVO

setAdate(Date) - Method in class bb.common.OnloanShipperVO

setAdate(Date) - Method in class bb.common.OnLoanVO

setAdate(Date) - Method in class bb.common.OperatingInstructionsVO

setAdate(Date) - Method in class bb.common.PaymentInvoicesResult

setAdate(Date) - Method in class bb.common.PfReceiverVO

setAdate(Date) - Method in class bb.common.POSurveyReportVO

setAdate(Date) - Method in class bb.common.PreventiveActionRequestVO

setAdate(Date) - Method in class bb.common.PrintTemplateVO

setAdate(Date) - Method in class bb.common.ProformaInvoiceVO

setAdate(Date) - Method in class bb.common.PurchaseOrderVO

setADate(Date) - Method in class bb.common.QuoteVO

setAdate(Date) - Method in class bb.common.ReceiverInfoVO

setAdate(Date) - Method in class bb.common.ReceiverVO

setAdate(Date) - Method in class bb.common.RequestForQuoteVO

setAdate(Date) - Method in class bb.common.RequestForRMAVO

setAdate(Date) - Method in class bb.common.ReturnMaterialAuthorizationVO

setAdate(Date) - Method in class bb.common.ReturnToVendorVO

setAdate(Date) - Method in class bb.common.RMAReceiverVO

setAdate(Date) - Method in class bb.common.RtvShipperInfoVO

setAdate(Date) - Method in class bb.common.RtvShipperVO

setAdate(Date) - Method in class bb.common.SalesmanVO

setAdate(Date) - Method in class bb.common.SalesOrderVO

setAdate(Date) - Method in class bb.common.ShipperInfoVO

setAdate(Date) - Method in class bb.common.ShipperVO

setAdate(Date) - Method in class bb.common.SwapOrderListResult

setAdate(Date) - Method in class bb.common.SwapOrderVO

setAdate(Date) - Method in class bb.common.SwapReceiverListResult

setAdate(Date) - Method in class bb.common.SwapReceiverVO

setAdate(Date) - Method in class bb.common.SwapShipperListResult

setAdate(Date) - Method in class bb.common.SwapShipperVO

setAdate(Date) - Method in class bb.common.TransferOrderListResult

setAdate(Date) - Method in class bb.common.TransferOrderVO

setAdate(Date) - Method in class bb.common.TransferReceiverListResult

setAdate(Date) - Method in class bb.common.TransferReceiverVO

setAdate(Date) - Method in class bb.common.TransferShipperListResult

setAdate(Date) - Method in class bb.common.TransferShipperVO

setAdate(Date) - Method in class bb.common.WarehouseVO

setAdate(Date) - Method in class bb.common.WorkInstructionRequestForChangeVO

setAdate(Date) - Method in class bb.common.WorkInstructionVO

setAdate(Date) - Method in class bb.common.WorkOrderVO

setAdate(Date) - Method in class bb.common.WorkOrderWorkInstructionVO

setAddId(String) - Method in class bb.common.QualityGroupPK

setAddOrSubtract(String) - Method in class bb.common.ClosingStatementItemResult

setAddOrSubtract(String) - Method in class bb.common.ExchangeAuditItemResult

setAddr1(String) - Method in class bb.common.AccountReceivablePaymentVO

setAddr1(String) - Method in class bb.common.SGCartCheckOutResult

setAddr1(String) - Method in class bb.common.SGCustRequestForQuoteListResult

setAddr1(String) - Method in class bb.common.SGCustRequestForQuoteResult

setAddr1(String) - Method in class bb.common.SGQuoteAddressResult

setAddr1(String) - Method in class bb.common.SGQuoteAddressVO

setAddr2(String) - Method in class bb.common.AccountReceivablePaymentVO

setAddr2(String) - Method in class bb.common.SGCartCheckOutResult

setAddr2(String) - Method in class bb.common.SGCustRequestForQuoteListResult

setAddr2(String) - Method in class bb.common.SGCustRequestForQuoteResult

setAddr2(String) - Method in class bb.common.SGQuoteAddressResult

setAddr2(String) - Method in class bb.common.SGQuoteAddressVO

setAddress(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setAddress(String) - Method in class bb.common.CustomerVendorAddressVO

setAddress(String) - Method in class bb.common.ExchangeAuditItemResult

setAddress1(String) - Method in class bb.common.AccountPayableCheckVO

setAddress1(String) - Method in class bb.common.SalesmanVO

setAddress1(String) - Method in class bb.common.ZipcodeTotalsResult

setAddress2(String) - Method in class bb.common.AccountPayableCheckVO

setAddress2(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setAddress2(String) - Method in class bb.common.CustomerVendorAddressVO

setAddress2(String) - Method in class bb.common.SalesmanVO

setAddress2(String) - Method in class bb.common.ZipcodeTotalsResult

setAddressId(String) - Method in class bb.common.AccountBalanceListResult

setAddressId(String) - Method in class bb.common.AccountCreditVO

setAddressId(String) - Method in class bb.common.AccountDebitVO

setAddressId(String) - Method in class bb.common.AddressQualityDocumentsVO

setAddressId(String) - Method in class bb.common.ArCommissionListResult

setAddressId(String) - Method in class bb.common.BB2tripleString

setAddressId(String) - Method in class bb.common.CarrierPK

setAddressId(String) - Method in class bb.common.GeneralLedgerByDateListResult

setAddressId(String) - Method in class bb.common.GLItemVO

setAddressId(String) - Method in class bb.common.LogTrackingVO

setAddressId(String) - Method in class bb.common.PartDueAddressListResult

setAddressId(String) - Method in class bb.common.PaymentAgent

setAddressId(String) - Method in class bb.common.PaymentHistoryVO

setAddressId(String) - Method in class bb.common.PrepayPaymentAgent

setAddressId(String) - Method in class bb.common.SalesCodeVO

setAddressID(String) - Method in class bb.common.SubcompanyVO

setAddressIdDefaultQaStatus(String) - Method in class bb.common.CompanyVO

setAddressIDLike(String) - Method in class bb.common.AccountAuditAgent

setAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.NonproductivePickingVO

setAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.OntimeDeliveryRateResult

setAddressName(String) - Method in class bb.common.AccountBalanceListResult

setAddressName(String) - Method in class bb.common.ArCommissionListResult

setAddressName(String) - Method in class bb.common.GeneralLedgerByDateListResult

setAddressName(String) - Method in class bb.common.LogTrackingVO

setAddressName(String) - Method in class bb.common.PartDueAddressListResult

setAddressName(String) - Method in class bb.common.PaymentHistoryVO

setAddressName(String) - Method in class bb.common.SalesCodeVO

setAddressOne(String) - Method in class bb.common.CustomerVendorDescriptionVO

setAddressOne(String) - Method in class bb.common.EmployeeHomeVO

setAddressOne(String) - Method in class bb.common.ManufacturerAddressInfoVO

setAddressOne(String) - Method in class bb.common.ManufacturerAddressVO

setAddressOne(String) - Method in class bb.common.ManufacturerDescriptionVO

setAddressQualityDocuments(Set) - Method in class bb.common.CustomerVendorAddressVO

setAddressTwo(String) - Method in class bb.common.CustomerVendorDescriptionVO

setAddressTwo(String) - Method in class bb.common.EmployeeHomeVO

setAddressTwo(String) - Method in class bb.common.ManufacturerAddressInfoVO

setAddressTwo(String) - Method in class bb.common.ManufacturerAddressVO

setAddressTwo(String) - Method in class bb.common.ManufacturerDescriptionVO

setAddrInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.CustomerStatementResult

setAdjustedQty(BigDecimal) - Method in class bb.common.StockTransactionAdjustmentResult

setAdvances(BigDecimal) - Method in class bb.common.ExpenseVO

setAge(Integer) - Method in class bb.common.CustomCheckUpEmployeeVO

setAge(int) - Method in class bb.common.CustomCheckUpEmployeeVO

setAlarmValue(boolean) - Method in class bb.common.AccountCreditVO

setAlarmValue(boolean) - Method in class bb.common.AccountDebitVO

setAlarmValue(boolean) - Method in class bb.common.AccountsCreditDebitListResult

setAlarmValue(boolean) - Method in interface bb.common.Alarmable

setAlarmValue(boolean) - Method in class bb.common.APAuditListResult

setAlarmValue(boolean) - Method in class bb.common.ARAuditListResult

setAlarmValue(boolean) - Method in class bb.common.GLItemVO

setAlarmValue(boolean) - Method in class bb.common.LockedCustomerAddressResult

setAlarmValue(boolean) - Method in class bb.common.PartCatalogAuditResult

setAlarmValue(boolean) - Method in class bb.common.PartOnHandAuditResult

setAllowEmptyGL(boolean) - Method in class bb.common.CompanyVO

setAllowNegativeCreditOrDebit(boolean) - Method in class bb.common.CompanyVO

setAllReceiver(String) - Method in class bb.common.MessageVO

setAlreadySetup(boolean) - Method in class bb.common.MasterWorkOrderTreeItemResult

setAmortizationExpenseAccount(String) - Method in class bb.common.AssetDepreciateVO

setAmortizationExpenseAccount(String) - Method in class bb.common.AssetVO

setAmortizationExpenseAccounts(Set<AssetAmortizationExpenseAccountVO>) - Method in class bb.common.AssetDepreciateVO

setAmortizationExpenseAccounts(Set<AssetAmortizationExpenseAccountVO>) - Method in class bb.common.AssetVO

setAmount(BigDecimal) - Method in class bb.common.ApCheckRunListResult

setAmount(BigDecimal) - Method in class bb.common.ARPaymentRunListResult

setAmount(BigDecimal) - Method in class bb.common.DepositSummaryResult

setAmount(BigDecimal) - Method in class bb.common.ExpenseItemVO

setAmount(BigDecimal) - Method in class bb.common.ShareHoldersEquityResult

setAmountDue(BigDecimal) - Method in class bb.common.AccountingTotalMoneyResult

setAmountDue(BigDecimal) - Method in class bb.common.AccountReceivableInfoWithPrepayResult

setAmountDue(BigDecimal) - Method in class bb.common.AccountsReceivableInfoVO

setAmountDue(BigDecimal) - Method in class bb.common.AccountsReceivableVO

setAmountDue(BigDecimal) - Method in class bb.common.DuePATotalByVendorResult

setAmountPaid(BigDecimal) - Method in class bb.common.ARAllStatementsListResult

setAmountPaid(BigDecimal) - Method in class bb.common.ARPrepayAllStatementsListResult

setAmountPaid(BigDecimal) - Method in class bb.common.CustomerPrepayStatementListResult

setAmountPaid(BigDecimal) - Method in class bb.common.CustomerStatementListResult

setAmountPaid(BigDecimal) - Method in class bb.common.SalesTaxListResult

setAmountPaid(BigDecimal) - Method in class bb.common.VendorPrepayStatementListResult

setAmountPaid(BigDecimal) - Method in class bb.common.VendorStatementListResult

setAnalysis(String) - Method in class bb.common.CustomerServiceIncidentItemVO

setAnnualDepreciationRate(BigDecimal) - Method in class bb.common.AssetVO

setAnswerCn(String) - Method in class bb.common.FeedbackAnswerVO

setAnswerEn(String) - Method in class bb.common.FeedbackAnswerVO

setAnswerItem(String) - Method in class bb.common.FeedbackAnswerPK

setAnswerItem(String) - Method in class bb.common.FeedbackItemVO

setAnswers(Set) - Method in class bb.common.FeedbackQuestionVO

setAp(Map<String, BigDecimal>) - Method in class bb.common.CashFlowByMonthReportResult

setAp(TreeMap) - Method in class bb.common.TwelveMonthCashFlowReportResult

setApAmount(BigDecimal) - Method in class bb.common.AddressAccountInfo

setApBatch(String) - Method in class bb.common.AccountingSettingsVO

setAPCurrentBalance(BigDecimal) - Method in class bb.common.CustomerVendorAddressTotalInfo

setApDate(Date) - Method in class bb.common.AccountsPayableInfoVO

setApDate(Date) - Method in class bb.common.AccountsPayableVO

setApDigits(byte) - Method in class bb.common.CompanyVO

setApDisc(BigDecimal) - Method in class bb.common.PfReceiverItemVO

setApDisc(BigDecimal) - Method in class bb.common.PfReceiverVO

setApDisc(BigDecimal) - Method in class bb.common.ReturnToVendorItemVO

setApDisc(BigDecimal) - Method in class bb.common.ReturnToVendorVO

setApDisc(BigDecimal) - Method in class bb.common.RtvShipperItemVO

setApDiscount(BigDecimal) - Method in class bb.common.AccountsPayableInfoVO

setApDiscount(BigDecimal) - Method in class bb.common.AccountsPayableItemVO

setApDiscount(BigDecimal) - Method in class bb.common.AccountsPayableVO

setApDiscount(BigDecimal) - Method in class bb.common.CustomerReturnToVendorItemVO

setApDiscount(BigDecimal) - Method in class bb.common.OnloanReceiverItemVO

setApDiscount(BigDecimal) - Method in class bb.common.ReceiverItemVO

setApDiscount(BigDecimal) - Method in class bb.common.RequestForQuoteItemVO

setApDiscount(BigDecimal) - Method in class bb.common.RequestForQuoteVO

setApDiscount(BigDecimal) - Method in class bb.common.RequestForRMAItemVO

setApDiscount(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setApDiscount(BigDecimal) - Method in class bb.common.RtvShipperInfoVO

setApDiscount(BigDecimal) - Method in class bb.common.RtvShipperVO

setApDiscountAccount(String) - Method in class bb.common.AccountingSettingsVO

setApDiscountMethod(String) - Method in class bb.common.AccountingSettingsVO

setApDue(BigDecimal) - Method in class bb.common.APAuditListResult

setApDueDays(Float) - Method in class bb.common.PaymentHistoryVO

setApDueItems(Set) - Method in class bb.common.AccountInfoCenterResult

setApEndBalance(BigDecimal) - Method in class bb.common.AddressAccountInfo

setApFreight(BigDecimal) - Method in class bb.common.AccountsPayableInfoVO

setApFreight(BigDecimal) - Method in class bb.common.AccountsPayableVO

setApFreight(BigDecimal) - Method in class bb.common.APAuditListResult

setApFreight(BigDecimal) - Method in class bb.common.PfReceiverVO

setApFreight(BigDecimal) - Method in class bb.common.RtvShipperInfoVO

setApFreight(BigDecimal) - Method in class bb.common.RtvShipperVO

setApGl1Recorded(BigDecimal) - Method in class bb.common.AccountsPayableInfoVO

setApGl1Recorded(BigDecimal) - Method in class bb.common.AccountsPayableVO

setApGl1Recorded(BigDecimal) - Method in class bb.common.CustomerReturnToVendorVO

setApGl1Recorded(BigDecimal) - Method in class bb.common.OnloanReceiverVO

setApGl1Recorded(BigDecimal) - Method in class bb.common.PurchaseOrderVO

setApGl1Recorded(BigDecimal) - Method in class bb.common.ReceiverInfoVO

setApGl1Recorded(BigDecimal) - Method in class bb.common.ReceiverVO

setApGl1Recorded(BigDecimal) - Method in class bb.common.RequestForRMAVO

setApGl1Recorded(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationVO

setApGl1Recorded(BigDecimal) - Method in class bb.common.ReturnToVendorVO

setApGl1Recorded(BigDecimal) - Method in class bb.common.RtvShipperInfoVO

setApGl1Recorded(BigDecimal) - Method in class bb.common.RtvShipperVO

setApGl2Paid(BigDecimal) - Method in class bb.common.AccountsPayableInfoVO

setApGl2Paid(BigDecimal) - Method in class bb.common.AccountsPayableVO

setApGl2Paid(BigDecimal) - Method in class bb.common.CustomerReturnToVendorVO

setApGl2Paid(BigDecimal) - Method in class bb.common.OnloanReceiverVO

setApGl2Paid(BigDecimal) - Method in class bb.common.PurchaseOrderVO

setApGl2Paid(BigDecimal) - Method in class bb.common.ReceiverInfoVO

setApGl2Paid(BigDecimal) - Method in class bb.common.ReceiverVO

setApGl2Paid(BigDecimal) - Method in class bb.common.RequestForRMAVO

setApGl2Paid(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationVO

setApGl2Paid(BigDecimal) - Method in class bb.common.ReturnToVendorVO

setApGl2Paid(BigDecimal) - Method in class bb.common.RtvShipperInfoVO

setApGl2Paid(BigDecimal) - Method in class bb.common.RtvShipperVO

setApGLDate(Date) - Method in class bb.common.AccountsPayableVO

setAPGLDate(Date) - Method in class bb.common.AddPayableWithoutReceiverAgent

setApGLDate(Date) - Method in class bb.common.MakeAccountPayableAgent

setApItemNumber(String) - Method in class bb.common.AccountsPayableItemPK

setApItemNumber(String) - Method in class bb.common.APItemListResult

setApItemNumber(String) - Method in class bb.common.POReceiverItemListResult

setApItemStatus(String) - Method in class bb.common.POReceiverItemListResult

setApNet(BigDecimal) - Method in class bb.common.AccountPayableInfoWithPrepayResult

setApNet(BigDecimal) - Method in class bb.common.AccountsPayableInfoVO

setApNet(BigDecimal) - Method in class bb.common.AccountsPayableItemVO

setApNet(BigDecimal) - Method in class bb.common.AccountsPayableVO

setApNet(BigDecimal) - Method in class bb.common.APAuditListResult

setApNet(BigDecimal) - Method in class bb.common.PfReceiverItemVO

setApNet(BigDecimal) - Method in class bb.common.PfReceiverVO

setApNet(BigDecimal) - Method in class bb.common.PoMessageItemVO

setApNet(BigDecimal) - Method in class bb.common.PoMessageVO

setApNet(BigDecimal) - Method in class bb.common.PurchaseOrderItemVO

setApNet(BigDecimal) - Method in class bb.common.PurchaseOrderVO

setApNet(BigDecimal) - Method in class bb.common.RequestForQuoteVO

setApNet(BigDecimal) - Method in class bb.common.ReturnToVendorByDateListResult

setApNet(BigDecimal) - Method in class bb.common.ReturnToVendorItemVO

setApNet(BigDecimal) - Method in class bb.common.ReturnToVendorVO

setApNet(BigDecimal) - Method in class bb.common.RtvShipperInfoVO

setApNet(BigDecimal) - Method in class bb.common.RtvShipperItemVO

setApNet(BigDecimal) - Method in class bb.common.RtvShipperVO

setApNetSet(String) - Method in class bb.common.AccountsPayableInfoVO

setApNetSet(String) - Method in class bb.common.AccountsPayableVO

setApNetSet(String) - Method in class bb.common.CustomerReturnToVendorVO

setApNetSet(String) - Method in class bb.common.OnloanReceiverVO

setApNetSet(String) - Method in class bb.common.PurchaseOrderVO

setApNetSet(String) - Method in class bb.common.ReceiverVO

setApNetSet(String) - Method in class bb.common.RequestForRMAVO

setApNetSet(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setApNetSet(String) - Method in class bb.common.ReturnToVendorVO

setApNetSet(String) - Method in class bb.common.RtvShipperInfoVO

setApNetSet(String) - Method in class bb.common.RtvShipperVO

setApNumber(String) - Method in class bb.common.AccountPayableInfoWithPrepayResult

setApNumber(String) - Method in class bb.common.AccountsPayableInfoVO

setApNumber(String) - Method in class bb.common.AccountsPayableItemManufacturerPK

setApNumber(String) - Method in class bb.common.AccountsPayableItemPK

setApNumber(String) - Method in class bb.common.AccountsPayableVO

setApNumber(String) - Method in class bb.common.APAuditListResult

setApNumber(String[]) - Method in class bb.common.ApCheckRunItemAgent

setApNumber(String) - Method in class bb.common.ApCheckRunListResult

setApNumber(String) - Method in class bb.common.APItemListResult

setApNumber(String) - Method in class bb.common.ExpenseVO

setApNumber(String) - Method in class bb.common.GeneralLedgerByDateListResult

setApNumber(String) - Method in class bb.common.MakeCheckAgent

setApNumber(String) - Method in class bb.common.PayableCheckRunItemPK

setApNumber(String) - Method in class bb.common.PfReceiverItemVO

setApNumber(String) - Method in class bb.common.POReceiverItemListResult

setApNumber(String) - Method in class bb.common.RtvShipperInfoVO

setApNumber(String) - Method in class bb.common.RtvShipperItemListResult

setApNumber(String) - Method in class bb.common.RtvShipperListResult

setApNumber(String) - Method in class bb.common.RtvShipperVO

setApNumber(String) - Method in class bb.common.VendorStatementListResult

setApOpen(BigDecimal) - Method in class bb.common.AccountsPayableInfoVO

setApOpen(BigDecimal) - Method in class bb.common.AccountsPayableItemVO

setApOpen(BigDecimal) - Method in class bb.common.AccountsPayableVO

setApOpen(BigDecimal) - Method in class bb.common.CustomerReturnToVendorItemVO

setApOpen(BigDecimal) - Method in class bb.common.CustomerReturnToVendorVO

setApOpen(BigDecimal) - Method in class bb.common.OnloanReceiverItemVO

setApOpen(BigDecimal) - Method in class bb.common.OnloanReceiverVO

setApOpen(BigDecimal) - Method in class bb.common.PfReceiverItemVO

setApOpen(BigDecimal) - Method in class bb.common.PfReceiverVO

setApOpen(BigDecimal) - Method in class bb.common.PoMessageItemVO

setApOpen(BigDecimal) - Method in class bb.common.PoMessageVO

setApOpen(BigDecimal) - Method in class bb.common.PurchaseOrderItemListResult

setApOpen(BigDecimal) - Method in class bb.common.PurchaseOrderItemVO

setApOpen(BigDecimal) - Method in class bb.common.PurchaseOrderVO

setApOpen(BigDecimal) - Method in class bb.common.ReceiverInfoVO

setApOpen(BigDecimal) - Method in class bb.common.ReceiverItemVO

setApOpen(BigDecimal) - Method in class bb.common.ReceiverVO

setApOpen(BigDecimal) - Method in class bb.common.RequestForQuoteItemVO

setApOpen(BigDecimal) - Method in class bb.common.RequestForQuoteVO

setApOpen(BigDecimal) - Method in class bb.common.RequestForRMAItemVO

setApOpen(BigDecimal) - Method in class bb.common.RequestForRMAVO

setApOpen(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setApOpen(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationVO

setApOpen(BigDecimal) - Method in class bb.common.ReturnToVendorItemVO

setApOpen(BigDecimal) - Method in class bb.common.ReturnToVendorVO

setApOpen(BigDecimal) - Method in class bb.common.RtvShipperInfoVO

setApOpen(BigDecimal) - Method in class bb.common.RtvShipperItemVO

setApOpen(BigDecimal) - Method in class bb.common.RtvShipperVO

setApOpenItems(Set) - Method in class bb.common.AccountInfoCenterResult

setApOrdmApprovedBy(String) - Method in class bb.common.AccountingConfigurationVO

setApOriginalAmount(BigDecimal) - Method in class bb.common.AddressAccountInfo

setApPaid(BigDecimal) - Method in class bb.common.APAuditListResult

setApPaid(BigDecimal) - Method in class bb.common.PaymentHistoryVO

setApPaidGl(BigDecimal) - Method in class bb.common.AccountsPayableInfoVO

setApPaidGl(BigDecimal) - Method in class bb.common.AccountsPayableVO

setApPaidGl(BigDecimal) - Method in class bb.common.CustomerReturnToVendorVO

setApPaidGl(BigDecimal) - Method in class bb.common.OnloanReceiverVO

setApPaidGl(BigDecimal) - Method in class bb.common.PurchaseOrderVO

setApPaidGl(BigDecimal) - Method in class bb.common.ReceiverInfoVO

setApPaidGl(BigDecimal) - Method in class bb.common.ReceiverVO

setApPaidGl(BigDecimal) - Method in class bb.common.RequestForRMAVO

setApPaidGl(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationVO

setApPaidGl(BigDecimal) - Method in class bb.common.ReturnToVendorVO

setApPaidGl(BigDecimal) - Method in class bb.common.RtvShipperInfoVO

setApPaidGl(BigDecimal) - Method in class bb.common.RtvShipperVO

setApPaidInv(BigDecimal) - Method in class bb.common.RtvShipperInfoVO

setApPaidInv(BigDecimal) - Method in class bb.common.RtvShipperVO

setApPaidRcv(BigDecimal) - Method in class bb.common.AccountsPayableInfoVO

setApPaidRcv(BigDecimal) - Method in class bb.common.AccountsPayableVO

setApPaidRcv(BigDecimal) - Method in class bb.common.ReturnToVendorVO

setApPaidReceived(BigDecimal) - Method in class bb.common.CustomerReturnToVendorVO

setApPaidReceived(BigDecimal) - Method in class bb.common.OnloanReceiverVO

setApPaidReceived(BigDecimal) - Method in class bb.common.PurchaseOrderVO

setApPaidReceived(BigDecimal) - Method in class bb.common.ReceiverInfoVO

setApPaidReceived(BigDecimal) - Method in class bb.common.ReceiverVO

setApPaidReceived(BigDecimal) - Method in class bb.common.RequestForRMAVO

setApPaidReceived(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationVO

setAppAmount(BigDecimal) - Method in class bb.common.AddressAccountInfo

setAPPaseDueBalance(BigDecimal) - Method in class bb.common.CustomerVendorAddressTotalInfo

setApPastDue(BigDecimal) - Method in class bb.common.CashFlowByMonthReportResult

setAPPaymentDue(BigDecimal) - Method in class bb.common.CustomerVendorAddressTotalInfo

setAPPaymentDueDays(int) - Method in class bb.common.CustomerVendorAddressTotalInfo

setAppDate(Date) - Method in class bb.common.ApPrepayVO

setAppEndBalance(BigDecimal) - Method in class bb.common.AddressAccountInfo

setAppiPk(ApPrepayItemPK[]) - Method in class bb.common.ApPrepaymentCheckRunItemAgent

setAppiPk(ApPrepayItemPK[]) - Method in class bb.common.PrepaymentWireTransferAgent

setAppiPrepay(BigDecimal) - Method in class bb.common.APPrepayInfoResult

setAppiPrepay(BigDecimal) - Method in class bb.common.ApPrepayItemVO

setAppiPrepayDue(BigDecimal) - Method in class bb.common.APPrepayInfoResult

setAppiPrepayDue(BigDecimal) - Method in class bb.common.ApPrepayItemVO

setAppiPrepayGl(BigDecimal) - Method in class bb.common.APPrepayInfoResult

setAppiPrepayGl(BigDecimal) - Method in class bb.common.ApPrepayItemVO

setAppItem(String) - Method in class bb.common.MakeCheckAgent

setAppItemNumber(String) - Method in class bb.common.GeneralLedgerVO

setApplyBy(String) - Method in class bb.common.OrderApprovalVO

setApplyDate(Date) - Method in class bb.common.OrderApprovalVO

setAppNumber(String) - Method in class bb.common.AccountPayableInfoWithPrepayResult

setAppNumber(String) - Method in class bb.common.GeneralLedgerVO

setAppNumber(String) - Method in class bb.common.MakePrepaymentCheckAgent

setAppNumber(String) - Method in class bb.common.PurchaseOrderVO

setAppOriginalAmount(BigDecimal) - Method in class bb.common.AddressAccountInfo

setAppProperty(String, String) - Method in interface bb.common.box.CompanyBox

setApPrefix(String) - Method in class bb.common.CompanyVO

setApPrepay(BigDecimal) - Method in class bb.common.AccountPayableInfoWithPrepayResult

setApPrepay(BigDecimal) - Method in class bb.common.ApPrepayVO

setApPrepay(Map<String, BigDecimal>) - Method in class bb.common.CashFlowByMonthReportResult

setApPrepay(BigDecimal) - Method in class bb.common.PurchaseOrderListResult

setApPrepay(BigDecimal) - Method in class bb.common.PurchaseOrderVO

setApPrepayApply(BigDecimal) - Method in class bb.common.AccountPayableInfoWithPrepayResult

setApPrepayApply(BigDecimal) - Method in class bb.common.ApPrepayVO

setApPrepayApply(BigDecimal) - Method in class bb.common.PurchaseOrderVO

setApPrepayApplys(Map) - Method in class bb.common.GeneralLedgerVO

setApPrepayDigits(byte) - Method in class bb.common.CompanyVO

setApPrepayDue(BigDecimal) - Method in class bb.common.AccountPayableInfoWithPrepayResult

setApPrepayDue(BigDecimal) - Method in class bb.common.ApPrepayVO

setApPrepayDue(BigDecimal) - Method in class bb.common.PurchaseOrderVO

setApPrepayGl(BigDecimal) - Method in class bb.common.AccountPayableInfoWithPrepayResult

setApPrepayGl(BigDecimal) - Method in class bb.common.ApPrepayVO

setApPrepayGl(BigDecimal) - Method in class bb.common.PurchaseOrderListResult

setApPrepayGl(BigDecimal) - Method in class bb.common.PurchaseOrderVO

setApPrepayItem(Set<ApPrepayItemVO>) - Method in class bb.common.ApPrepayVO

setApPrepayItemNumber(String) - Method in class bb.common.ApPrepayItemPK

setApPrepayNumber(String) - Method in class bb.common.ApPrepayItemPK

setApPrepayNumber(String) - Method in class bb.common.ApPrepayVO

setApPrepayPastDue(BigDecimal) - Method in class bb.common.CashFlowByMonthReportResult

setApPrepayPrefix(String) - Method in class bb.common.CompanyVO

setApprovableType(String) - Method in class bb.common.NcrApprovalPK

setApprovalBy(String) - Method in class bb.common.ScrapReportVO

setApprovalDate(Date) - Method in class bb.common.ScrapReportVO

setApprovalLimit(BigDecimal) - Method in class bb.common.DisassembleWorkOrderApprovalVO

setApprovalLimit(BigDecimal) - Method in class bb.common.RTVApprovalVO

setApprovalLimit(BigDecimal) - Method in class bb.common.WorkOrderApprovalVO

setApprovalStatus(String) - Method in class bb.common.GeneralLedgerVO

setApprovalStatus(String) - Method in class bb.common.GLApprovalListResult

setApproved(Date) - Method in class bb.common.DisassembleWorkOrderVO

setApproved(String) - Method in class bb.common.EngineeringChangeRequestVO

setApproved(String) - Method in class bb.common.EngineeringChangeVO

setApproved(Date) - Method in class bb.common.SGCustomerServiceRequestVO

setApproved(Date) - Method in class bb.common.WorkInstructionListResult

setApproved(Date) - Method in class bb.common.WorkInstructionVO

setApproved(Date) - Method in class bb.common.WorkOrderVO

setApproved(Date) - Method in class bb.common.WorkOrderWorkInstructionVO

setApproveDate(Date) - Method in class bb.common.ExpenseVO

setApproveDate(Date) - Method in class bb.common.TransferOrderListResult

setApproveDate(Date) - Method in class bb.common.TransferOrderVO

setApprovedBy(String) - Method in class bb.common.BillVO

setApprovedBy(String) - Method in class bb.common.BillWithPartInfoResult

setApprovedBy(String) - Method in class bb.common.CorrectiveActionRequestVO

setApprovedBy(String) - Method in class bb.common.CustomerReturnToVendorVO

setApprovedBy(String) - Method in class bb.common.DisassembleWorkOrderReceivingResult

setApprovedBy(String) - Method in class bb.common.DisassembleWorkOrderVO

setApprovedBy(String) - Method in class bb.common.ExpenseVO

setApprovedBy(String) - Method in class bb.common.GeneralLedgerPrintResult

setApprovedBy(String) - Method in class bb.common.GeneralLedgerVO

setApprovedBy(String) - Method in class bb.common.GLApprovalListResult

setApprovedBy(String) - Method in class bb.common.GLAutoApproveVO

setApprovedBy(String) - Method in class bb.common.IssuingResult

setApprovedBy(String) - Method in class bb.common.NonproductivePickingItemResult

setApprovedBy(String) - Method in class bb.common.NonproductivePickingVO

setApprovedBy(String) - Method in class bb.common.OrderApprovalVO

setApprovedBy(String) - Method in class bb.common.PreventiveActionRequestVO

setApprovedBy(String) - Method in class bb.common.PurchaseOrderVO

setApprovedBy(String) - Method in class bb.common.RequestForQuoteVO

setApprovedBy(String) - Method in class bb.common.RequestForRMAVO

setApprovedBy(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setApprovedBy(String) - Method in class bb.common.ReturnToVendorVO

setApprovedBy(String) - Method in class bb.common.SGCustomerServiceRequestVO

setApprovedBy(String) - Method in class bb.common.SwapOrderListResult

setApprovedBy(String) - Method in class bb.common.SwapOrderVO

setApprovedBy(String) - Method in class bb.common.TransferOrderListResult

setApprovedBy(String) - Method in class bb.common.TransferOrderVO

setApprovedBy(String) - Method in class bb.common.WorkInstructionListResult

setApprovedBy(String) - Method in class bb.common.WorkInstructionRequestForChangeVO

setApprovedBy(String) - Method in class bb.common.WorkInstructionVO

setApprovedBy(String) - Method in class bb.common.WorkOrderVO

setApprovedBy(String) - Method in class bb.common.WorkOrderWorkInstructionVO

setApprovedDate(Date) - Method in class bb.common.BillVO

setApprovedDate(Date) - Method in class bb.common.BillWithPartInfoResult

setApprovedDate(Date) - Method in class bb.common.DisassembleWorkOrderReceivingResult

setApprovedDate(Date) - Method in class bb.common.EngineeringChangeRequestVO

setApprovedDate(Date) - Method in class bb.common.EngineeringChangeVO

setApprovedDate(Date) - Method in class bb.common.GeneralLedgerVO

setApprovedDate(Date) - Method in class bb.common.IssuingResult

setApprovedDate(Date) - Method in class bb.common.NonproductivePickingItemResult

setApprovedDate(Date) - Method in class bb.common.NonproductivePickingVO

setApprovedDate(Date) - Method in class bb.common.OrderApprovalVO

setApprovedDate(Date) - Method in class bb.common.PurchaseOrderVO

setApprovedDate(Date) - Method in class bb.common.RequestForQuoteVO

setApprovedDate(Date) - Method in class bb.common.ReturnToVendorVO

setApprovedDate(Date) - Method in class bb.common.SwapOrderListResult

setApprovedDate(Date) - Method in class bb.common.SwapOrderVO

setApprovedDate(Date) - Method in class bb.common.WorkInstructionRequestForChangeVO

setApprovedErrorList(List<String>) - Method in class bb.common.ApprovedGLResult

setApprovedGLList(List<String>) - Method in class bb.common.ApprovedGLResult

setApprovedOpinionEng(String) - Method in class bb.common.NcrReportListResult

setApprovedOpinionEng(String) - Method in class bb.common.NonConformanceReportVO

setApprovedOpinionMfg(String) - Method in class bb.common.NcrReportListResult

setApprovedOpinionMfg(String) - Method in class bb.common.NonConformanceReportVO

setApprovedOpinionQa(String) - Method in class bb.common.NcrReportListResult

setApprovedOpinionQa(String) - Method in class bb.common.NonConformanceReportVO

setApprovedTime(Date) - Method in class bb.common.CustomerReturnToVendorVO

setApprovedTime(Date) - Method in class bb.common.RequestForRMAVO

setApprovedTime(Date) - Method in class bb.common.ReturnMaterialAuthorizationVO

setApproveLimit(BigDecimal) - Method in class bb.common.GeneralLedgerApprovalVO

setApproveLimit(BigDecimal) - Method in class bb.common.PurchaseOrderApprovalVO

setApproveSubWO(boolean) - Method in class bb.common.CompanyVO

setApproveSuccessGL(int) - Method in class bb.common.ApprovedGLResult

setApproveSuccessGLList(List<String>) - Method in class bb.common.ApprovedGLResult

setAppStartBalance(BigDecimal) - Method in class bb.common.AddressAccountInfo

setAPPurchaseOrder12Months(BigDecimal) - Method in class bb.common.CustomerVendorAddressTotalInfo

setApRcvd(BigDecimal) - Method in class bb.common.ReturnToVendorItemVO

setApRcvd(BigDecimal) - Method in class bb.common.ReturnToVendorVO

setApReceivd(BigDecimal) - Method in class bb.common.CustomerReturnToVendorItemVO

setApReceivd(BigDecimal) - Method in class bb.common.RequestForRMAItemVO

setApReceivd(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setApReceived(BigDecimal) - Method in class bb.common.AccountsPayableItemVO

setApReceived(BigDecimal) - Method in class bb.common.CustomerReturnToVendorVO

setApReceived(BigDecimal) - Method in class bb.common.OnloanReceiverItemVO

setApReceived(BigDecimal) - Method in class bb.common.OnloanReceiverVO

setApReceived(BigDecimal) - Method in class bb.common.PfReceiverItemVO

setApReceived(BigDecimal) - Method in class bb.common.PfReceiverVO

setApReceived(BigDecimal) - Method in class bb.common.PoMessageItemVO

setApReceived(BigDecimal) - Method in class bb.common.PoMessageVO

setApReceived(BigDecimal) - Method in class bb.common.PurchaseOrderItemListResult

setApReceived(BigDecimal) - Method in class bb.common.PurchaseOrderItemVO

setApReceived(BigDecimal) - Method in class bb.common.PurchaseOrderVO

setApReceived(BigDecimal) - Method in class bb.common.ReceiverInfoVO

setApReceived(BigDecimal) - Method in class bb.common.ReceiverItemVO

setApReceived(BigDecimal) - Method in class bb.common.ReceiverVO

setApReceived(BigDecimal) - Method in class bb.common.RequestForQuoteItemVO

setApReceived(BigDecimal) - Method in class bb.common.RequestForQuoteVO

setApReceived(BigDecimal) - Method in class bb.common.RequestForRMAVO

setApReceived(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationVO

setApRecieved(BigDecimal) - Method in class bb.common.AccountsPayableInfoVO

setApRecieved(BigDecimal) - Method in class bb.common.AccountsPayableVO

setApShip(BigDecimal) - Method in class bb.common.RtvShipperInfoVO

setApShip(BigDecimal) - Method in class bb.common.RtvShipperItemVO

setApShip(BigDecimal) - Method in class bb.common.RtvShipperVO

setApStartBalance(BigDecimal) - Method in class bb.common.AddressAccountInfo

setApStatus(String) - Method in class bb.common.AccountPayableCheckRunItemVO

setApSub(BigDecimal) - Method in class bb.common.AccountsPayableInfoVO

setApSub(BigDecimal) - Method in class bb.common.AccountsPayableItemVO

setApSub(BigDecimal) - Method in class bb.common.AccountsPayableVO

setApSub(BigDecimal) - Method in class bb.common.CustomerReturnToVendorItemVO

setApSub(BigDecimal) - Method in class bb.common.CustomerReturnToVendorVO

setApSub(BigDecimal) - Method in class bb.common.OnloanReceiverItemVO

setApSub(BigDecimal) - Method in class bb.common.OnloanReceiverVO

setApSub(BigDecimal) - Method in class bb.common.PfReceiverItemVO

setApSub(BigDecimal) - Method in class bb.common.PfReceiverVO

setApSub(BigDecimal) - Method in class bb.common.ReceiverInfoVO

setApSub(BigDecimal) - Method in class bb.common.ReceiverItemVO

setApSub(BigDecimal) - Method in class bb.common.ReceiverVO

setApSub(BigDecimal) - Method in class bb.common.RequestForQuoteItemVO

setApSub(BigDecimal) - Method in class bb.common.RequestForRMAItemVO

setApSub(BigDecimal) - Method in class bb.common.RequestForRMAVO

setApSub(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setApSub(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationVO

setApSub(BigDecimal) - Method in class bb.common.ReturnToVendorItemVO

setApSub(BigDecimal) - Method in class bb.common.RtvShipperInfoVO

setApSub(BigDecimal) - Method in class bb.common.RtvShipperItemVO

setApSub(BigDecimal) - Method in class bb.common.RtvShipperVO

setApTax(BigDecimal) - Method in class bb.common.AccountsPayableInfoVO

setApTax(BigDecimal) - Method in class bb.common.AccountsPayableItemVO

setApTax(BigDecimal) - Method in class bb.common.AccountsPayableVO

setApTax(BigDecimal) - Method in class bb.common.APAuditListResult

setApTax(BigDecimal) - Method in class bb.common.CustomerReturnToVendorItemVO

setApTax(BigDecimal) - Method in class bb.common.OnloanReceiverItemVO

setApTax(BigDecimal) - Method in class bb.common.PfReceiverItemVO

setApTax(BigDecimal) - Method in class bb.common.PfReceiverVO

setApTax(BigDecimal) - Method in class bb.common.ReceiverItemVO

setApTax(BigDecimal) - Method in class bb.common.RequestForQuoteItemVO

setApTax(BigDecimal) - Method in class bb.common.RequestForRMAItemVO

setApTax(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setApTax(BigDecimal) - Method in class bb.common.ReturnToVendorItemVO

setApTax(BigDecimal) - Method in class bb.common.RtvShipperInfoVO

setApTax(BigDecimal) - Method in class bb.common.RtvShipperItemVO

setApTax(BigDecimal) - Method in class bb.common.RtvShipperVO

setApTaxSet(String) - Method in class bb.common.AccountsPayableInfoVO

setApTaxSet(String) - Method in class bb.common.AccountsPayableVO

setApTaxSet(String) - Method in class bb.common.CustomerReturnToVendorVO

setApTaxSet(String) - Method in class bb.common.OnloanReceiverVO

setApTaxSet(String) - Method in class bb.common.PurchaseOrderVO

setApTaxSet(String) - Method in class bb.common.ReceiverVO

setApTaxSet(String) - Method in class bb.common.RequestForRMAVO

setApTaxSet(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setApTaxSet(String) - Method in class bb.common.ReturnToVendorVO

setApTaxSet(String) - Method in class bb.common.RtvShipperInfoVO

setApTaxSet(String) - Method in class bb.common.RtvShipperVO

setApTotal(BigDecimal) - Method in class bb.common.AccountPayableCheckRunItemVO

setApTotal(BigDecimal) - Method in class bb.common.AccountsPayableInfoVO

setApTotal(BigDecimal) - Method in class bb.common.AccountsPayableItemVO

setApTotal(BigDecimal) - Method in class bb.common.AccountsPayableVO

setApTotal(BigDecimal) - Method in class bb.common.APAuditListResult

setApTotal(BigDecimal) - Method in class bb.common.CheckRunItemTotalResult

setApTotal(BigDecimal) - Method in class bb.common.CustomerReturnToVendorItemVO

setApTotal(BigDecimal) - Method in class bb.common.OnloanReceiverItemVO

setApTotal(BigDecimal) - Method in class bb.common.PfReceiverItemVO

setApTotal(BigDecimal) - Method in class bb.common.PfReceiverVO

setApTotal(BigDecimal) - Method in class bb.common.PoMessageItemVO

setApTotal(BigDecimal) - Method in class bb.common.PurchaseOrderCheckListResult

setApTotal(BigDecimal) - Method in class bb.common.PurchaseOrderItemVO

setApTotal(BigDecimal) - Method in class bb.common.ReceiverItemVO

setApTotal(BigDecimal) - Method in class bb.common.RequestForQuoteCheckListResult

setApTotal(BigDecimal) - Method in class bb.common.RequestForQuoteItemVO

setApTotal(BigDecimal) - Method in class bb.common.RequestForRMAItemVO

setApTotal(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setApTotal(BigDecimal) - Method in class bb.common.ReturnToVendorCheckListResult

setApTotal(BigDecimal) - Method in class bb.common.ReturnToVendorItemVO

setApTotal(BigDecimal) - Method in class bb.common.RtvShipperInfoVO

setApTotal(BigDecimal) - Method in class bb.common.RtvShipperItemVO

setApTotal(BigDecimal) - Method in class bb.common.RtvShipperVO

setApTotal(BigDecimal) - Method in class bb.common.WorkOrderCheckListResult

setAr(Map<String, BigDecimal>) - Method in class bb.common.CashFlowByMonthReportResult

setAr(String) - Method in class bb.common.ProformaInvoiceItemVO

setAr(TreeMap) - Method in class bb.common.TwelveMonthCashFlowReportResult

setArAging(Collection<CustomerStatementTotalResult>) - Method in class bb.common.CustomerStatementResult

setArAmount(BigDecimal) - Method in class bb.common.AddressAccountInfo

setArAmountPaid(BigDecimal) - Method in class bb.common.AllStatementsListResult

setArApDate(Date) - Method in class bb.common.TempArApAgingVO

setArApNumber(String) - Method in class bb.common.PaymentAgent

setArApNumber(String) - Method in class bb.common.TempArApAgingVO

setArApNumber(String[]) - Method in class bb.common.WireTransferAgent

setArApTotal(BigDecimal) - Method in class bb.common.TempArApAgingVO

setArBalenceDue(BigDecimal) - Method in class bb.common.AllStatementsListResult

setArBoilerplate(String) - Method in class bb.common.ARBoilerplateVO

setArCurrency(String) - Method in class bb.common.AllStatementsListResult

setARCurrentBalance(BigDecimal) - Method in class bb.common.CustomerVendorAddressTotalInfo

setArDigits(byte) - Method in class bb.common.CompanyVO

setArDisc(BigDecimal) - Method in class bb.common.AccountsReceivableItemVO

setArDisc(BigDecimal) - Method in class bb.common.OnLoanItemVO

setArDisc(BigDecimal) - Method in class bb.common.OnLoanVO

setArDisc(BigDecimal) - Method in class bb.common.ProformaInvoiceItemVO

setArDisc(BigDecimal) - Method in class bb.common.ProformaInvoiceVO

setArDiscount(BigDecimal) - Method in class bb.common.OnloanShipperItemVO

setArDiscount(BigDecimal) - Method in class bb.common.OnloanShipperVO

setArDiscount(BigDecimal) - Method in class bb.common.ShipperInfoVO

setArDiscount(BigDecimal) - Method in class bb.common.ShipperItemVO

setArDiscount(BigDecimal) - Method in class bb.common.ShipperVO

setArDiscountAccount(String) - Method in class bb.common.AccountingSettingsVO

setArDiscountMethod(String) - Method in class bb.common.AccountingSettingsVO

setArDue(BigDecimal) - Method in class bb.common.ARAuditListResult

setArDueDays(Float) - Method in class bb.common.PaymentHistoryVO

setArDueItems(Set) - Method in class bb.common.AccountInfoCenterResult

setArEndBalance(BigDecimal) - Method in class bb.common.AddressAccountInfo

setArFreight(BigDecimal) - Method in class bb.common.ARAuditListResult

setArFreight(BigDecimal) - Method in class bb.common.MakeCreditMemoAgent

setArFreight(BigDecimal) - Method in class bb.common.OnloanShipperVO

setArFreight(BigDecimal) - Method in class bb.common.OnLoanVO

setArFreight(BigDecimal) - Method in class bb.common.ProformaInvoiceVO

setArFreight(BigDecimal) - Method in class bb.common.ShipperAgent

setArFreight(BigDecimal) - Method in class bb.common.ShipperInfoVO

setArFreight(BigDecimal) - Method in class bb.common.ShipperVO

setArFreight(BigDecimal) - Method in class bb.common.TransferReceiverListResult

setArFreight(BigDecimal) - Method in class bb.common.TransferReceiverVO

setArFreight(BigDecimal) - Method in class bb.common.TransferShipperListResult

setArFreight(BigDecimal) - Method in class bb.common.TransferShipperVO

setArGl1Recorded(BigDecimal) - Method in class bb.common.AccountsReceivableInfoVO

setArGl1Recorded(BigDecimal) - Method in class bb.common.AccountsReceivableVO

setArGl1Recorded(BigDecimal) - Method in class bb.common.OnloanShipperVO

setArGl1Recorded(BigDecimal) - Method in class bb.common.OnLoanVO

setArGl1Recorded(BigDecimal) - Method in class bb.common.ProformaInvoiceVO

setArGl1Recorded(BigDecimal) - Method in class bb.common.SalesOrderVO

setArGl1Recorded(BigDecimal) - Method in class bb.common.ShipperInfoVO

setArGl1Recorded(BigDecimal) - Method in class bb.common.ShipperVO

setArGl2Paid(BigDecimal) - Method in class bb.common.AccountsReceivableInfoVO

setArGl2Paid(BigDecimal) - Method in class bb.common.AccountsReceivableVO

setArGl2Paid(BigDecimal) - Method in class bb.common.OnloanShipperVO

setArGl2Paid(BigDecimal) - Method in class bb.common.OnLoanVO

setArGl2Paid(BigDecimal) - Method in class bb.common.ProformaInvoiceVO

setArGl2Paid(BigDecimal) - Method in class bb.common.SalesOrderVO

setArGl2Paid(BigDecimal) - Method in class bb.common.ShipperInfoVO

setArGl2Paid(BigDecimal) - Method in class bb.common.ShipperVO

setArInvoiceNumber(String) - Method in class bb.common.OnloanShipperVO

setArInvoiceNumber(String) - Method in class bb.common.SalesOrderItemVO

setArInvoiceNumber(String) - Method in class bb.common.ShipperInfoVO

setArInvoiceNumber(String) - Method in class bb.common.ShipperItemListResult

setArInvoiceNumber(String) - Method in class bb.common.ShipperVO

setArNet(BigDecimal) - Method in class bb.common.AccountsReceivableItemVO

setArNet(BigDecimal) - Method in class bb.common.ARAuditListResult

setArNet(BigDecimal) - Method in class bb.common.MakeCreditMemoAgent

setArNet(BigDecimal) - Method in class bb.common.OnLoanItemVO

setArNet(BigDecimal) - Method in class bb.common.OnloanShipperItemVO

setArNet(BigDecimal) - Method in class bb.common.OnloanShipperVO

setArNet(BigDecimal) - Method in class bb.common.OnLoanVO

setArNet(BigDecimal) - Method in class bb.common.ProformaInvoiceItemVO

setArNet(BigDecimal) - Method in class bb.common.ProformaInvoiceVO

setArNet(BigDecimal) - Method in class bb.common.ShipperInfoVO

setArNet(BigDecimal) - Method in class bb.common.ShipperItemVO

setArNet(BigDecimal) - Method in class bb.common.ShipperVO

setArNetSet(String) - Method in class bb.common.AccountsReceivableInfoVO

setArNetSet(String) - Method in class bb.common.AccountsReceivableVO

setArNetSet(String) - Method in class bb.common.OnloanShipperVO

setArNetSet(String) - Method in class bb.common.OnLoanVO

setArNetSet(String) - Method in class bb.common.QuoteVO

setArNetSet(String) - Method in class bb.common.SalesOrderVO

setArNetSet(String) - Method in class bb.common.ShipperVO

setArNumber(String) - Method in class bb.common.ARAuditListResult

setArNumber(String[]) - Method in class bb.common.ArPaymentRunItemAgent

setArNumber(String) - Method in class bb.common.ARPaymentRunItemPK

setArNumber(String) - Method in class bb.common.ARPaymentRunListResult

setArNumber(String) - Method in class bb.common.GeneralLedgerByDateListResult

setArOpen(BigDecimal) - Method in class bb.common.AccountsReceivableInfoVO

setArOpen(BigDecimal) - Method in class bb.common.AccountsReceivableItemVO

setArOpen(BigDecimal) - Method in class bb.common.AccountsReceivableVO

setArOpen(BigDecimal) - Method in class bb.common.OnLoanItemVO

setArOpen(BigDecimal) - Method in class bb.common.OnloanShipperItemVO

setArOpen(BigDecimal) - Method in class bb.common.OnloanShipperVO

setArOpen(BigDecimal) - Method in class bb.common.OnLoanVO

setArOpen(BigDecimal) - Method in class bb.common.ProformaInvoiceItemVO

setArOpen(BigDecimal) - Method in class bb.common.ProformaInvoiceVO

setArOpen(BigDecimal) - Method in class bb.common.SalesOrderVO

setArOpen(BigDecimal) - Method in class bb.common.ShipperInfoVO

setArOpen(BigDecimal) - Method in class bb.common.ShipperItemVO

setArOpen(BigDecimal) - Method in class bb.common.ShipperVO

setArOpenItems(Set) - Method in class bb.common.AccountInfoCenterResult

setArOrcmApprovedBy(String) - Method in class bb.common.AccountingConfigurationVO

setArOriginalAmount(BigDecimal) - Method in class bb.common.AddressAccountInfo

setArPaid(BigDecimal) - Method in class bb.common.ARAuditListResult

setArPaid(BigDecimal) - Method in class bb.common.ProformaInvoiceVO

setArPaidGl(BigDecimal) - Method in class bb.common.AccountsReceivableInfoVO

setArPaidGl(BigDecimal) - Method in class bb.common.AccountsReceivableVO

setArPaidGl(BigDecimal) - Method in class bb.common.OnloanShipperVO

setArPaidGl(BigDecimal) - Method in class bb.common.OnLoanVO

setArPaidGl(BigDecimal) - Method in class bb.common.ProformaInvoiceVO

setArPaidGl(BigDecimal) - Method in class bb.common.SalesOrderVO

setArPaidGl(BigDecimal) - Method in class bb.common.ShipperInfoVO

setArPaidGl(BigDecimal) - Method in class bb.common.ShipperVO

setArPaidInv(BigDecimal) - Method in class bb.common.OnLoanVO

setArPaidInv(BigDecimal) - Method in class bb.common.ProformaInvoiceVO

setArPaidInvoice(BigDecimal) - Method in class bb.common.AccountsReceivableInfoVO

setArPaidInvoice(BigDecimal) - Method in class bb.common.AccountsReceivableVO

setArPaidInvoice(BigDecimal) - Method in class bb.common.OnloanShipperVO

setArPaidInvoice(BigDecimal) - Method in class bb.common.ShipperInfoVO

setArPaidInvoice(BigDecimal) - Method in class bb.common.ShipperVO

setArpAmount(BigDecimal) - Method in class bb.common.AddressAccountInfo

setARPaseDueBalance(BigDecimal) - Method in class bb.common.CustomerVendorAddressTotalInfo

setArPastDue(BigDecimal) - Method in class bb.common.CashFlowByMonthReportResult

setARPaymentDue(BigDecimal) - Method in class bb.common.CustomerVendorAddressTotalInfo

setARPaymentDueDays(int) - Method in class bb.common.CustomerVendorAddressTotalInfo

setArpDate(Date) - Method in class bb.common.ArPrepayVO

setArpEndBalance(BigDecimal) - Method in class bb.common.AddressAccountInfo

setArpiNumber(ArPrepayItemPK[]) - Method in class bb.common.ArPrepaymentRunItemAgent

setArpiPk(ArPrepayItemPK[]) - Method in class bb.common.ARPrepaymentWireTransferAgent

setArpiPrepay(BigDecimal) - Method in class bb.common.ARPrepayInfoResult

setArpiPrepay(BigDecimal) - Method in class bb.common.ArPrepayItemVO

setArpiPrepayDue(BigDecimal) - Method in class bb.common.ARPrepayInfoResult

setArpiPrepayDue(BigDecimal) - Method in class bb.common.ArPrepayItemVO

setArpiPrepayGl(BigDecimal) - Method in class bb.common.ARPrepayInfoResult

setArpiPrepayGl(BigDecimal) - Method in class bb.common.ArPrepayItemVO

setArpItemNumber(String) - Method in class bb.common.GeneralLedgerVO

setArpNumber(String) - Method in class bb.common.AccountReceivableInfoWithPrepayResult

setArpNumber(String) - Method in class bb.common.GeneralLedgerVO

setArpNumber(String) - Method in class bb.common.SalesOrderVO

setArpOriginalAmount(BigDecimal) - Method in class bb.common.AddressAccountInfo

setArPrefix(String) - Method in class bb.common.CompanyVO

setArPrepay(BigDecimal) - Method in class bb.common.AccountReceivableInfoWithPrepayResult

setArPrepay(BigDecimal) - Method in class bb.common.ArPrepayVO

setArPrepay(Map<String, BigDecimal>) - Method in class bb.common.CashFlowByMonthReportResult

setArPrepay(BigDecimal) - Method in class bb.common.SalesOrderListResult

setArPrepay(BigDecimal) - Method in class bb.common.SalesOrderVO

setArPrepay(BigDecimal) - Method in class bb.common.ShippingResult

setArPrepayApply(BigDecimal) - Method in class bb.common.AccountReceivableInfoWithPrepayResult

setArPrepayApply(BigDecimal) - Method in class bb.common.ArPrepayVO

setArPrepayApply(BigDecimal) - Method in class bb.common.SalesOrderVO

setArPrepayApplys(Map) - Method in class bb.common.GeneralLedgerVO

setArPrepayDigits(byte) - Method in class bb.common.CompanyVO

setArPrepayDue(BigDecimal) - Method in class bb.common.AccountReceivableInfoWithPrepayResult

setArPrepayDue(BigDecimal) - Method in class bb.common.ArPrepayVO

setArPrepayDue(BigDecimal) - Method in class bb.common.SalesOrderVO

setArPrepayGl(BigDecimal) - Method in class bb.common.AccountReceivableInfoWithPrepayResult

setArPrepayGl(BigDecimal) - Method in class bb.common.ArPrepayVO

setArPrepayGl(BigDecimal) - Method in class bb.common.SalesOrderListResult

setArPrepayGl(BigDecimal) - Method in class bb.common.SalesOrderVO

setArPrepayGl(BigDecimal) - Method in class bb.common.ShippingResult

setArPrepayItem(Set<ArPrepayItemVO>) - Method in class bb.common.ArPrepayVO

setArPrepayItemNumber(String) - Method in class bb.common.ArPrepayItemPK

setArPrepayNumber(String) - Method in class bb.common.ArPrepayItemPK

setArPrepayNumber(String) - Method in class bb.common.ArPrepayVO

setArPrepayPastDue(BigDecimal) - Method in class bb.common.CashFlowByMonthReportResult

setArPrepayPrefix(String) - Method in class bb.common.CompanyVO

setArpStartBalance(BigDecimal) - Method in class bb.common.AddressAccountInfo

setArReceived(BigDecimal) - Method in class bb.common.PaymentHistoryVO

setArrivalDate(Date) - Method in class bb.common.BB2PartInSitItemResult

setArrivalDate(Date) - Method in class bb.common.PfReceiverVO

setArrivalDate(Date) - Method in class bb.common.PurchaseOrderContractResult

setArrivalStatus(String) - Method in class bb.common.PurchaseOrderContractResult

setArriveDate(Date) - Method in class bb.common.NonproductivePickingItemVO

setArriveDate(Date) - Method in class bb.common.NonproductivePickingOnDemandResult

setArriveDate(Date) - Method in class bb.common.OrderVendorItem

setArriveDate(Date) - Method in class bb.common.PO2POAgent

setArriveDate(Date) - Method in class bb.common.PurchaseOrderItemListResult

setArriveDate(Date) - Method in class bb.common.PurchaseOrderItemVO

setArriveDate(Date) - Method in class bb.common.PurchaseOrderOnOrderResult

setArriveDate(Date) - Method in class bb.common.SalesOrderItemListResult

setArriveDate(Date) - Method in class bb.common.SalesOrderItemVO

setArriveDate(Date) - Method in class bb.common.SalesOrderOnDemandResult

setArriveDate(Date) - Method in class bb.common.SO2SOAgent

setArriveDate(Date) - Method in class bb.common.SwapOrderItemListResult

setArriveDate(Date) - Method in class bb.common.SwapOrderItemVO

setArriveDate(Date) - Method in class bb.common.TransferOrderItemListResult

setArriveDate(Date) - Method in class bb.common.TransferOrderItemVO

setArriveDate(Date) - Method in class bb.common.WorkOrderOnDemandResult

setArriveDate(Date) - Method in class bb.common.WorkOrderOnOrderResult

setARSalesOrder12Months(BigDecimal) - Method in class bb.common.CustomerVendorAddressTotalInfo

setArShip(BigDecimal) - Method in class bb.common.AccountsReceivableInfoVO

setArShip(BigDecimal) - Method in class bb.common.AccountsReceivableItemVO

setArShip(BigDecimal) - Method in class bb.common.AccountsReceivableVO

setArShip(BigDecimal) - Method in class bb.common.OnLoanItemVO

setArShip(BigDecimal) - Method in class bb.common.OnloanShipperItemVO

setArShip(BigDecimal) - Method in class bb.common.OnloanShipperVO

setArShip(BigDecimal) - Method in class bb.common.OnLoanVO

setArShip(BigDecimal) - Method in class bb.common.ProformaInvoiceItemVO

setArShip(BigDecimal) - Method in class bb.common.ProformaInvoiceVO

setArShip(BigDecimal) - Method in class bb.common.SalesOrderVO

setArShip(BigDecimal) - Method in class bb.common.ShipperInfoVO

setArShip(BigDecimal) - Method in class bb.common.ShipperItemVO

setArShip(BigDecimal) - Method in class bb.common.ShipperVO

setArStartBalance(BigDecimal) - Method in class bb.common.AddressAccountInfo

setArStatus(String) - Method in class bb.common.ARPaymentRunItemVO

setArSub(BigDecimal) - Method in class bb.common.AccountsReceivableItemVO

setArSub(BigDecimal) - Method in class bb.common.OnLoanItemVO

setArSub(BigDecimal) - Method in class bb.common.OnloanShipperItemVO

setArSub(BigDecimal) - Method in class bb.common.OnloanShipperVO

setArSub(BigDecimal) - Method in class bb.common.OnLoanVO

setArSub(BigDecimal) - Method in class bb.common.ProformaInvoiceItemListResult

setArSub(BigDecimal) - Method in class bb.common.ProformaInvoiceItemVO

setArSub(BigDecimal) - Method in class bb.common.ProformaInvoiceVO

setArSub(BigDecimal) - Method in class bb.common.QuoteVO

setArSub(BigDecimal) - Method in class bb.common.SalesOrderVO

setArSub(BigDecimal) - Method in class bb.common.ShipperInfoVO

setArSub(BigDecimal) - Method in class bb.common.ShipperItemVO

setArSub(BigDecimal) - Method in class bb.common.ShipperVO

setArTax(BigDecimal) - Method in class bb.common.AccountsReceivableItemVO

setArTax(BigDecimal) - Method in class bb.common.ARAuditListResult

setArTax(BigDecimal) - Method in class bb.common.MakeCreditMemoAgent

setArTax(BigDecimal) - Method in class bb.common.OnLoanItemVO

setArTax(BigDecimal) - Method in class bb.common.OnloanShipperItemVO

setArTax(BigDecimal) - Method in class bb.common.OnloanShipperVO

setArTax(BigDecimal) - Method in class bb.common.OnLoanVO

setArTax(BigDecimal) - Method in class bb.common.ProformaInvoiceItemVO

setArTax(BigDecimal) - Method in class bb.common.ProformaInvoiceVO

setArTax(BigDecimal) - Method in class bb.common.ShipperInfoVO

setArTax(BigDecimal) - Method in class bb.common.ShipperItemVO

setArTax(BigDecimal) - Method in class bb.common.ShipperVO

setArTaxSet(String) - Method in class bb.common.AccountsReceivableInfoVO

setArTaxSet(String) - Method in class bb.common.AccountsReceivableVO

setArTaxSet(String) - Method in class bb.common.OnloanShipperVO

setArTaxSet(String) - Method in class bb.common.OnLoanVO

setArTaxSet(String) - Method in class bb.common.QuoteVO

setArTaxSet(String) - Method in class bb.common.SalesOrderVO

setArTaxSet(String) - Method in class bb.common.ShipperVO

setArTotal(BigDecimal) - Method in class bb.common.AccountsReceivableItemVO

setArTotal(BigDecimal) - Method in class bb.common.ARAuditListResult

setArTotal(BigDecimal) - Method in class bb.common.ARPaymentRunItemVO

setArTotal(BigDecimal) - Method in class bb.common.OnLoanItemVO

setArTotal(BigDecimal) - Method in class bb.common.OnloanShipperItemVO

setArTotal(BigDecimal) - Method in class bb.common.OnloanShipperVO

setArTotal(BigDecimal) - Method in class bb.common.OnLoanVO

setArTotal(BigDecimal) - Method in class bb.common.PaymentRunItemTotalResult

setArTotal(BigDecimal) - Method in class bb.common.ProformaInvoiceItemVO

setArTotal(BigDecimal) - Method in class bb.common.ProformaInvoiceVO

setArTotal(BigDecimal) - Method in class bb.common.SalesOrderCheckListResult

setArTotal(BigDecimal) - Method in class bb.common.SalesOrderItemInfoVO

setArTotal(BigDecimal) - Method in class bb.common.SalesOrderItemVO

setArTotal(BigDecimal) - Method in class bb.common.ShipperInfoVO

setArTotal(BigDecimal) - Method in class bb.common.ShipperItemVO

setArTotal(BigDecimal) - Method in class bb.common.ShipperVO

setArTotalDue(BigDecimal) - Method in class bb.common.AllStatementsListResult

setArWireFeeAccount(String) - Method in class bb.common.AccountingSettingsVO

setAsm(BigDecimal) - Method in class bb.common.EcnWOOrderResult

setAsm(BigDecimal) - Method in class bb.common.WorkOrderItemCanAssyResult

setAsm(BigDecimal) - Method in class bb.common.WorkOrderItemListResult

setAsm(BigDecimal) - Method in class bb.common.WorkOrderItemToIssueResult

setAsmPart(BB2Part) - Method in class bb.common.WOItemPartDetailNotIssue

setAsmSequenceNo(String) - Method in class bb.common.BillItemReplacementVO

setAsmSequenceNo(String) - Method in class bb.common.BillItemVO

setAsmSequenceNo(String) - Method in class bb.common.BillItemWithPartInfoResult

setAsmSequenceNo(String) - Method in class bb.common.WorkOrderItemSetupItemAgent

setAsOf(Date) - Method in class bb.common.CustomerStatementTotalResult

setAssetAccount(String) - Method in class bb.common.ScrapAssetAgent

setAssetApprovedBy(String) - Method in class bb.common.AccountingConfigurationVO

setAssetDate(Date) - Method in class bb.common.CustomAssetVO

setAssetDeprCreditAccount(String) - Method in class bb.common.AccountingSettingsVO

setAssetLiquidationAccount(String) - Method in class bb.common.ScrapAssetAgent

setAssetName(String) - Method in class bb.common.CustomAssetVO

setAssetNum(String) - Method in class bb.common.EquipmentListResult

setAssetNum(String) - Method in class bb.common.EquipmentVO

setAssetNumber(String) - Method in class bb.common.AssetAddOrDisposalsReport

setAssetNumber(String) - Method in class bb.common.AssetAmortizationExpenseAccountPK

setAssetNumber(String) - Method in class bb.common.AssetDepreciateDetailReport

setAssetNumber(String) - Method in class bb.common.AssetDepreciatePK

setAssetNumber(String) - Method in class bb.common.AssetUsagePK

setAssetNumber(String) - Method in class bb.common.AssetVO

setAssetNumber(String) - Method in class bb.common.CustomAssetRecordPK

setAssetNumber(String) - Method in class bb.common.CustomAssetVO

setAssetOrder(String) - Method in class bb.common.CustomAssetVO

setAssetRecords(Set) - Method in class bb.common.CustomAssetVO

setAssetStatus(String) - Method in class bb.common.AssetVO

setAssetStatus(String) - Method in class bb.common.CustomAssetVO

setAssetType(String) - Method in class bb.common.AssetAddOrDisposalsReport

setAssetType(String) - Method in class bb.common.AssetDepreciateDetailReport

setAssetType(String) - Method in class bb.common.AssetDepreciateVO

setAssetType(String) - Method in class bb.common.AssetVO

setAssetType(String) - Method in class bb.common.DepreciateMonthlyReport

setAssetType2(String) - Method in class bb.common.AssetVO

setAssignedTo(String) - Method in class bb.common.ToolCalibrationVO

setAssignTo(String) - Method in class bb.common.AssetVO

setAttach(ArrayList<BB2AttachFile>) - Method in class bb.common.BB2BugNotice

setAttach(ArrayList<BB2AttachFile>) - Method in class bb.common.BB2Notice

setAttachment(byte[]) - Method in class bb.common.BizboxBugChangesVO

setAttachment(byte[]) - Method in class bb.common.BizboxBugVO

setAttachmentNum(Integer) - Method in class bb.common.GeneralLedgerPrintResult

setAttachmentNum(Integer) - Method in class bb.common.GeneralLedgerVO

setAuditBy(String) - Method in class bb.common.AuditLogVO

setAuditExchange(BigDecimal) - Method in class bb.common.CurrencyExchangeVO

setAuditForeignCurrency(boolean) - Method in class bb.common.AccountsChartVO

setAuditOndemand(BigDecimal) - Method in class bb.common.AuditOnDemandResult

setAuditOnhandQty(BigDecimal) - Method in class bb.common.AuditOnDemandResult

setAuditOnorder(BigDecimal) - Method in class bb.common.AuditOnDemandResult

setAuditQtrUsage(BigDecimal) - Method in class bb.common.AuditOnDemandResult

setAuditSip(BigDecimal) - Method in class bb.common.PartOnHandAuditResult

setAuditTime(Date) - Method in class bb.common.AuditLogVO

setAuditWip(BigDecimal) - Method in class bb.common.AuditOnDemandResult

setAuditYrUsage(BigDecimal) - Method in class bb.common.AuditOnDemandResult

setAuthenticator(String) - Method in class bb.common.CustomEmployeeWorkExperienceVO

setAuthenticator(String) - Method in class bb.common.EmployeeWorkExperienceVO

setAuthor(String) - Method in class bb.common.WorkInstructionListResult

setAuthor(String) - Method in class bb.common.WorkInstructionSequenceListResult

setAuthor(String) - Method in class bb.common.WorkInstructionVO

setAuthor(String) - Method in class bb.common.WorkOrderWorkInstructionVO

setAutoApprovalBy(String) - Method in class bb.common.PointOfSaleVO

setAutoApprove(boolean) - Method in class bb.common.GLAutoApproveVO

setAutoEmployeeId(boolean) - Method in class bb.common.CompanyVO

setAutoTempWorderId(boolean) - Method in class bb.common.CompanyVO

setAvailQty(BigDecimal) - Method in class bb.common.IssuedFromOrderItem

setAvailQty(BigDecimal) - Method in class bb.common.MrpByMonthResult

setAverageCost(BigDecimal) - Method in class bb.common.BillDetailCostResult

setAverageCost(BigDecimal) - Method in class bb.common.BillDetailCostWithPartInfoResult

setAverageCost(BigDecimal) - Method in class bb.common.BillItemDetailCostWithPartInfoResult

setAverageCost(BigDecimal) - Method in class bb.common.BillItemSalesCostResult

setAverageCost(BigDecimal) - Method in class bb.common.BillItemSalesXResult

setAverageCost(BigDecimal) - Method in class bb.common.BillItemUsageResult

setAverageCost(BigDecimal) - Method in class bb.common.BillSalesCostResult

setAverageCost(BigDecimal) - Method in class bb.common.BillSalesXResult

setAverageCost(BigDecimal) - Method in class bb.common.HistoricalInventoryVO

setAverageCost(BigDecimal) - Method in class bb.common.NonConformanceReportResult

setAverageCost(BigDecimal) - Method in class bb.common.OnloanShipperItemVO

setAverageCost(BigDecimal) - Method in class bb.common.PartCostVarianceListResult

setAverageCost(BigDecimal) - Method in class bb.common.PartInventoryVO

setAverageCost(BigDecimal) - Method in class bb.common.PartOnhandVO

setAverageCost(BigDecimal) - Method in class bb.common.PartOnhandWithAverageCostResult

setAverageCost(BigDecimal) - Method in class bb.common.PartOnHandWithMfgInfoResult

setAverageCost(BigDecimal) - Method in class bb.common.PhysicalInventoryVO

setAverageCost(BigDecimal) - Method in class bb.common.SalesOrderItemCostResult

setAverageCost(BigDecimal) - Method in class bb.common.ShipperItemListResult

setAverageCost(BigDecimal) - Method in class bb.common.ShipperItemVO

setAverageCost(BigDecimal) - Method in class bb.common.ToolInventoryVO

setAverageCost(BigDecimal) - Method in class bb.common.ToolListDetailCostResult

setAverageCost(BigDecimal) - Method in class bb.common.ToolListDetailCostWithToolInfoResult

setAverageCost(BigDecimal) - Method in class bb.common.ToolListItemDetailCostWithToolInfoResult

setAverageCost(BigDecimal) - Method in class bb.common.ToolOnhandVO

setAverageCost(BigDecimal) - Method in class bb.common.ToolOnhandWithAverageCostResult

setAverageCostResultList(List) - Method in class bb.common.InventoryAdjustmentDetailResult

setAveragePerMonth(double) - Method in class bb.common.SalesInfoCenter.DueSoCount

setAveragePerMonth(double) - Method in class bb.common.SalesInfoCenter.DueSoSum

setAveragePerMonth(float) - Method in class bb.common.SalesInfoCenter.GrossMargin

setAveragePerMonth(double) - Method in class bb.common.SalesInfoCenter.InvoicedSum

setAveragePerMonth(double) - Method in class bb.common.SalesInfoCenter.OpenSoSum

setAveragePerMonth(double) - Method in class bb.common.SalesInfoCenter.SoCount

setAveragePerMonth(double) - Method in class bb.common.SalesInfoCenter.SoCountWithPartsOnhold

setAveragePerMonth(double) - Method in class bb.common.SalesInfoCenter.SoItemCount

setAveragePerMonth(double) - Method in class bb.common.SalesInfoCenter.SoTotalSum

setAvgAmount(BigDecimal) - Method in class bb.common.BB2DoubleCost

setAvgCost(BigDecimal) - Method in class bb.common.AccountsReceivableItemVO

setAvgcost(BigDecimal) - Method in class bb.common.BB2PartInventoryResult

setAvgCost(BigDecimal) - Method in class bb.common.ChangeStdCostWorkSheetItemVO

setAvgCost(BigDecimal) - Method in class bb.common.CycleCountListResult

setAvgCost(BigDecimal) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setAvgCost(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemPartDetailItemResult

setAvgCost(BigDecimal) - Method in class bb.common.InSipAudittListResult

setAvgCost(Map<String, BigDecimal>) - Method in class bb.common.InventoryAmountByMonth

setAvgCost(BigDecimal) - Method in class bb.common.InventoryNotUsedInMonthsResult

setAvgCost(BigDecimal) - Method in class bb.common.IssuingItemResult

setAvgCost(BigDecimal) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setAvgCost(BigDecimal) - Method in class bb.common.OrderApprovalItemsVO

setAvgCost(BigDecimal) - Method in class bb.common.PartBasicInfoWithNewListPrice

setAvgCost(BigDecimal) - Method in class bb.common.PartInWipForIDListResult

setAvgCost(BigDecimal) - Method in class bb.common.PartOnhandAndCostResult

setAvgCost(BigDecimal) - Method in class bb.common.PartOnhandResult

setAvgCost(BigDecimal) - Method in class bb.common.PartWithExcessiveInventoryListResult

setAvgCost(BigDecimal) - Method in class bb.common.PartWithOnLoanQtyListResult

setAvgCost(BigDecimal) - Method in class bb.common.PartWithQAQtyListResult

setAvgCost(BigDecimal) - Method in class bb.common.PartWithQtyListResult

setAvgCost(BigDecimal) - Method in class bb.common.PartWithSipQtyListResult

setAvgCost(BigDecimal) - Method in class bb.common.PartWithSITQtyListResult

setAvgCost(BigDecimal) - Method in class bb.common.PartWithSTOQtyListResult

setAvgCost(BigDecimal) - Method in class bb.common.PartWithWipQtyListResult

setAvgCost(BigDecimal) - Method in class bb.common.PfReceiverItemVO

setAvgCost(BigDecimal) - Method in class bb.common.PhysicalInventoryListResult

setAvgCost(BigDecimal) - Method in class bb.common.ProformaInvoiceItemVO

setAvgCost(BigDecimal) - Method in class bb.common.RollUpBomStdCostWorkSheetItemVO

setAvgCost(BigDecimal) - Method in class bb.common.RtvShipperItemVO

setAvgCost(BigDecimal) - Method in class bb.common.RunningAccountOrderItemVO

setAvgCost(BigDecimal) - Method in class bb.common.SalesOrderItemCostResult

setAvgCost(BigDecimal) - Method in class bb.common.ShippingItemResult

setAvgCost(BigDecimal) - Method in class bb.common.SwapOrderItemListResult

setAvgCost(BigDecimal) - Method in class bb.common.SwapOrderItemVO

setAvgCost(BigDecimal) - Method in class bb.common.SwapReceiverItemListResult

setAvgCost(BigDecimal) - Method in class bb.common.SwapReceiverItemVO

setAvgCost(BigDecimal) - Method in class bb.common.SwapShipperItemListResult

setAvgCost(BigDecimal) - Method in class bb.common.SwapShipperItemVO

setAvgCost(BigDecimal) - Method in class bb.common.TransferOrderItemListResult

setAvgCost(BigDecimal) - Method in class bb.common.TransferOrderItemVO

setAvgCost(BigDecimal) - Method in class bb.common.TransferReceiverItemListResult

setAvgCost(BigDecimal) - Method in class bb.common.TransferReceiverItemVO

setAvgCost(BigDecimal) - Method in class bb.common.TransferShipperItemListResult

setAvgCost(BigDecimal) - Method in class bb.common.TransferShipperItemVO

setAvgCost(BigDecimal) - Method in class bb.common.WOItemPartDetailNotIssue

setAvgCost(BigDecimal) - Method in class bb.common.WorkOrderItemInWipListResult

setAvgCost(BigDecimal) - Method in class bb.common.WorkOrderItemPartDetailItemResult

setAvgCostTotal(BigDecimal) - Method in class bb.common.RunningAccountOrderVO

setAvgDaysToPay(int) - Method in class bb.common.CustomerStatementTotalResult

setAvgFyPoAddedCount(BigDecimal) - Method in class bb.common.PurchasingInfoCenterResult

setAvgFyPoiAddedCount(BigDecimal) - Method in class bb.common.PurchasingInfoCenterResult

setAvgFyPurchaserAccount(BigDecimal) - Method in class bb.common.PurchasingInfoCenterResult

setAvgFyReceiverAccount(BigDecimal) - Method in class bb.common.PurchasingInfoCenterResult

setAvgFyReceiverCount(BigDecimal) - Method in class bb.common.PurchasingInfoCenterResult

setAvgFyReceiverItemCount(BigDecimal) - Method in class bb.common.PurchasingInfoCenterResult

setAvgHours(BigDecimal) - Method in class bb.common.WorkInstructionSequenceVO

setAvgHoursH(int) - Method in class bb.common.WorkInstructionSequenceVO

setAvgHoursM(int) - Method in class bb.common.WorkInstructionSequenceVO

setAvgHoursS(int) - Method in class bb.common.WorkInstructionSequenceVO

setAvgHrs(BigDecimal) - Method in class bb.common.WorkCenterRunTimeListResult

setAvgHrs(BigDecimal) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setAvgHrsH(int) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setAvgHrsM(int) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setAvgHrsS(int) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setAvgMargin(BigDecimal) - Method in class bb.common.AccountingTotalMoneyResult

setAvgMargin(BigDecimal) - Method in class bb.common.DuePATotalByVendorResult

setAvgMarginPercent(BigDecimal) - Method in class bb.common.AccountingTotalMoneyResult

setAvgMarginPercent(BigDecimal) - Method in class bb.common.DuePATotalByVendorResult

setAvgRunHrs(BigDecimal) - Method in class bb.common.WorkInstructionSummaryItemResult

setAvgSetup(BigDecimal) - Method in class bb.common.WorkCenterRunTimeListResult

setAvgSetup(BigDecimal) - Method in class bb.common.WorkInstructionSequenceVO

setAvgSetup(BigDecimal) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setAvgSetupH(int) - Method in class bb.common.WorkInstructionSequenceVO

setAvgSetupH(int) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setAvgSetupHrs(BigDecimal) - Method in class bb.common.WorkInstructionSummaryItemResult

setAvgSetupM(int) - Method in class bb.common.WorkInstructionSequenceVO

setAvgSetupM(int) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setAvgSetupS(int) - Method in class bb.common.WorkInstructionSequenceVO

setAvgSetupS(int) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setAvgTotal(BigDecimal) - Method in class bb.common.NonproductivePickingItemVO

setAvgTotal(BigDecimal) - Method in class bb.common.NonproductivePickingVO

setAvgTotalAmount(BigDecimal) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setAvgTotalAmount(BigDecimal) - Method in class bb.common.WorkOrderItemInWipListResult

setAvialQty(BigDecimal) - Method in class bb.common.WorkOrderItemCanAssyResult

setBackflushMaterial(boolean) - Method in class bb.common.BillItemWithPartInfoResult

setBalance(BigDecimal) - Method in class bb.common.AccountBalanceListResult

setBalance(BigDecimal) - Method in class bb.common.AccountBalanceResult

setBalance(BigDecimal) - Method in class bb.common.AccountsChartCategoryListResult

setBalance(BigDecimal) - Method in class bb.common.BalanceSheetSideBySideItemResult

setBalance(BigDecimal) - Method in class bb.common.ClosingStatementItemResult

setBalance(BigDecimal) - Method in class bb.common.ExchangeAuditItemResult

setBalance(BigDecimal) - Method in class bb.common.GeneralLedgerByDateListResult

setBalance(BigDecimal) - Method in class bb.common.JounalEntryListResult

setBalanceDue(BigDecimal) - Method in class bb.common.ARPrepayAllStatementsListResult

setBalanceDue(BigDecimal) - Method in class bb.common.CustomerPrepayStatementListResult

setBalanceDue(BigDecimal) - Method in class bb.common.CustomerStatementListResult

setBalanceDue(BigDecimal) - Method in class bb.common.CustomerStatementResult

setBalanceDue(BigDecimal) - Method in class bb.common.VendorPrepayStatementListResult

setBalanceDue(BigDecimal) - Method in class bb.common.VendorStatementListResult

setBalanceForward(BigDecimal) - Method in class bb.common.CustomerStatementResult

setBalenceDue(BigDecimal) - Method in class bb.common.ARAllStatementsListResult

setBankReconciled(String) - Method in class bb.common.GeneralLedgerResult

setBankReconsiled(String) - Method in class bb.common.GeneralLedgerListResult

setBankReconsiled(String) - Method in class bb.common.GeneralLedgerVO

setBankTransferFeeAccount(String) - Method in class bb.common.ARPrepaymentWireTransferAgent

setBankTransferFeeAccount(String) - Method in class bb.common.PrepaymentWireTransferAgent

setBankTransferFeeAccount(String) - Method in class bb.common.WireTransferAgent

setBatch(String) - Method in class bb.common.AccountsPayableInfoVO

setBatch(String) - Method in class bb.common.AccountsPayableVO

setBatch(String) - Method in class bb.common.GeneralLedgerByDateListResult

setBatch(String) - Method in class bb.common.GeneralLedgerListResult

setBatch(String) - Method in class bb.common.GeneralLedgerResult

setBatch(String) - Method in class bb.common.GeneralLedgerVO

setBatch(String) - Method in class bb.common.OnloanReceiverVO

setBatch(String) - Method in class bb.common.OnloanShipperVO

setBatch(String) - Method in class bb.common.ReceiverInfoVO

setBatch(String) - Method in class bb.common.ReceiverVO

setBatch(String) - Method in class bb.common.RMAReceiverVO

setBatch(String) - Method in class bb.common.RtvShipperInfoVO

setBatch(String) - Method in class bb.common.RtvShipperVO

setBatch(String) - Method in class bb.common.ShipperVO

setBatchNumber(String) - Method in class bb.common.AccountsReceivableInfoVO

setBatchNumber(String) - Method in class bb.common.AccountsReceivableVO

setBatchNumber(String) - Method in class bb.common.AddPayableWithoutReceiverAgent

setBatchNumber(String) - Method in class bb.common.MakeAccountPayableAgent

setBatchNumber(String) - Method in class bb.common.MakeCreditMemoAgent

setBatchNumber(String) - Method in class bb.common.MakeDebitMemoAgent

setBatchRunNumber(String) - Method in class bb.common.PaymentAgent

setBatchRunNumber(String) - Method in class bb.common.PrepayPaymentAgent

setBb2AvgCost(BigDecimal) - Method in class bb.common.ContractPriceItemVO

setBb2AvgCost(BigDecimal) - Method in class bb.common.VendorContractPriceItemVO

setBb2BackOrderQty(BigDecimal) - Method in class bb.common.ShipperItemVO

setBb2description(String) - Method in class bb.common.PartOnhandVO

setBb2FeedBackNumber(String) - Method in class bb.common.AccountsReceivableVO

setBb2HavePic(String) - Method in class bb.common.SGSaleItemVO

setBb2HaveSalesDwg(String) - Method in class bb.common.SGSaleItemVO

setBb2ListPrice(BigDecimal) - Method in class bb.common.ContractPriceItemVO

setBb2ListPrice(BigDecimal) - Method in class bb.common.VendorContractPriceItemVO

setBb2PoRecQty(BigDecimal) - Method in class bb.common.ReceiverItemVO

setBb2RmaReceiverItems(List<RMAReceiverItemVO>) - Method in class bb.common.ReturnMaterialAuthorizationVO

setBb2ShipperItems(List<RtvShipperItemListResult>) - Method in class bb.common.ReturnToVendorVO

setBb2ShipTo(String) - Method in class bb.common.PackingBoxVO

setBb2ShipToName(String) - Method in class bb.common.PackingBoxVO

setBb2ShipVia(String) - Method in class bb.common.PackingBoxVO

setBb2SoShippedQty(BigDecimal) - Method in class bb.common.ShipperItemVO

setBb2StdCost(BigDecimal) - Method in class bb.common.ContractPriceItemVO

setBb2StdCost(BigDecimal) - Method in class bb.common.VendorContractPriceItemVO

setBc(String) - Method in class bb.common.BillItemVO

setBc(String) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

setBc(String) - Method in class bb.common.SGBillItemVO

setBc(String) - Method in class bb.common.ToolListItemVO

setBc(String) - Method in class bb.common.WorkOrderItemIssueVO

setBeanValue(Object, String, Object) - Static method in class bb.common.BB2Util

setBeforeDate(Date) - Method in class bb.common.MrpItemResult

setBeginBalance(BigDecimal) - Method in class bb.common.GLInfoByPeriodResult

setBeginDate(Date) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setBeginPeriodBalance(BigDecimal) - Method in class bb.common.AccountBalanceResult

setBigCatagory(String) - Method in class bb.common.PartCatagoryPK

setBill(String) - Method in class bb.common.BillItemSalesCostResult

setBill(String) - Method in class bb.common.BillItemSalesXResult

setBill(String) - Method in class bb.common.BillWhereUsedItemResult

setBill(String) - Method in class bb.common.InventoryNotUsedInMonthsResult

setBill(String) - Method in class bb.common.PartBasicInfo

setBill(String) - Method in class bb.common.PartMaterialWhereUsedItemResult

setBill(String) - Method in class bb.common.PartVO

setBill(String) - Method in class bb.common.PartWhereUsedItemResult

setBill(String) - Method in class bb.common.PartWithInventoryInfoListResult

setBill(String) - Method in class bb.common.PartWithManufacturerInfoResult

setBill(String) - Method in class bb.common.PartWithOnhandsVO

setBill(String) - Method in class bb.common.RollUPPartStandardCostResult

setBill(String) - Method in class bb.common.SalesBomItemResult

setBill(String) - Method in class bb.common.SalesOrderItemVO

setBill(String) - Method in class bb.common.SGBOMItemResult

setBill(String) - Method in class bb.common.SGPartCatalogResult

setBill(String) - Method in class bb.common.StockTransactionPartInfoResult

setBill(String) - Method in class bb.common.ToolVO

setBill(String) - Method in class bb.common.ToolWhereUsedItemResult

setBill(String) - Method in class bb.common.ToolWithOnhandsVO

setBillAndHold(String) - Method in class bb.common.AccountsReceivableVO

setBillId(String) - Method in class bb.common.DisassembleWorkOrderReceivingResult

setBillId(String) - Method in class bb.common.IssuingResult

setBillInfo(BillDetailCostWithPartInfoResult) - Method in class bb.common.BillDetailCostResult

setBillItem(Set) - Method in class bb.common.BillVO

setBillItemNumber(String) - Method in class bb.common.BillItemPK

setBillItemNumber(String) - Method in class bb.common.BillLogVO

setBillItemNumber(String) - Method in class bb.common.SGBOMItemResult

setBillItemPk(BillItemPK) - Method in class bb.common.BillItemSalesCostResult

setBillItemPk(BillItemPK) - Method in class bb.common.BillItemSalesResult

setBillItemPk(BillItemPK) - Method in class bb.common.BillItemSalesXResult

setBillItemPk(BillItemPK) - Method in class bb.common.BillItemWithPartInfoResult

setBillItemPk(BillItemPK) - Method in class bb.common.BillWhereUsedItemResult

setBillItemPk(BillItemPK) - Method in class bb.common.BomItemWithOEMResult

setBillItemPk(BillItemPK) - Method in class bb.common.BomPickListItemResult

setBillItemPk(BillItemPK) - Method in class bb.common.PartMaterialWhereUsedItemResult

setBillItemPk(BillItemPK) - Method in class bb.common.SalesBomItemResult

setBillItemPk(BillItemPK) - Method in class bb.common.SalesPartListItemResult

setBillItemPk(BillItemPK) - Method in class bb.common.ToolListItemWithToolInfoResult

setBillItemReplacements(Set<BillItemReplacementVO>) - Method in class bb.common.BillItemVO

setBillItemReplacements(Set<BillItemReplacementVO>) - Method in class bb.common.BillItemWithPartInfoResult

setBillItems(Set) - Method in class bb.common.BillDetailCostResult

setBillNumber(String) - Method in class bb.common.BillItemPK

setBillNumber(String) - Method in class bb.common.BillItemReplacementVO

setBillNumber(String) - Method in class bb.common.BillLogVO

setBillNumber(String) - Method in class bb.common.BillPK

setBillNumber(String) - Method in class bb.common.BOMCanAssyAgent

setBillNumber(String) - Method in class bb.common.RollUpBomStdCostWorkSheetItemPK

setBillNumber(String) - Method in class bb.common.SGBillItemPK

setBillNumber(String) - Method in class bb.common.SGPartListItemResult

setBillOfLading(String) - Method in class bb.common.PfReceiverVO

setBillOfLading(String) - Method in class bb.common.ProformaInvoiceVO

setBillPartFrom(String) - Method in class bb.common.SalesBomItemResult

setBillPartFrom(String) - Method in class bb.common.SalesBomResult

setBillPartFrom(String) - Method in class bb.common.SalesPartListItemResult

setBillPartFrom(String) - Method in class bb.common.SalesPartListResult

setBillPk(BillPK) - Method in class bb.common.BillSalesCostResult

setBillPk(BillPK) - Method in class bb.common.BillWithPartInfoResult

setBillPk(BillPK) - Method in class bb.common.BomPickListResult

setBillPk(BillPK) - Method in class bb.common.BomWithOEMResult

setBillPk(BillPK) - Method in class bb.common.MrpReportAgent

setBillPk(BillPK) - Method in class bb.common.SalesBomResult

setBillPk(BillPK) - Method in class bb.common.SalesPartListResult

setBillPk(BillPK) - Method in class bb.common.ToolListWithToolInfoResult

setBillTo(String) - Method in class bb.common.AccountsReceivableInfoVO

setBillTo(String) - Method in class bb.common.AccountsReceivableVO

setBillTo(String) - Method in class bb.common.AllStatementsListResult

setBillTo(String) - Method in class bb.common.CustomerStatementTotalResult

setBillTo(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setBillTo(String) - Method in class bb.common.CustomerVendorAddressVO

setBillTo(String) - Method in class bb.common.ProformaInvoiceVO

setBillTo(String) - Method in class bb.common.RunningAccountOrderItemResult

setBillTo(String) - Method in class bb.common.RunningAccountOrderVO

setBillToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.AccountsReceivableVO

setBillToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.ArPrepayVO

setBillToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.CustomerReturnToVendorVO

setBillToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.DisassembleWorkOrderVO

setBillToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.OnloanShipperVO

setBillToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.OnLoanVO

setBillToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.ProformaInvoiceVO

setBillToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.PurchaseOrderVO

setBillToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.QuoteVO

setBillToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.RequestForQuoteVO

setBillToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.RequestForRMAVO

setBillToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.ReturnMaterialAuthorizationVO

setBillToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.ReturnToVendorVO

setBillToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.RtvShipperInfoVO

setBillToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.RtvShipperVO

setBillToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.SalesOrderVO

setBillToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.ShipperInfoVO

setBillToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.ShipperVO

setBillToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.WorkOrderVO

setBillToId(String) - Method in class bb.common.ArPrepayVO

setBillToId(String) - Method in class bb.common.CompanyVO

setBillToId(String) - Method in class bb.common.CustomerReturnToVendorVO

setBillToId(String) - Method in class bb.common.DisassembleWorkOrderVO

setBillToId(String) - Method in class bb.common.MakeBillAndHoldInvoiceAgent

setBillToId(String) - Method in class bb.common.MakeInvoiceAgent

setBillToId(String) - Method in class bb.common.OnloanShipperVO

setBilltoId(String) - Method in class bb.common.OnLoanVO

setBilltoId(String) - Method in class bb.common.PO2SOExchange

setBillToId(String) - Method in class bb.common.ProformaInvoiceListResult

setBillToId(String) - Method in class bb.common.PurchaseOrderVO

setBillToId(String) - Method in class bb.common.Quote2QuoteAgent

setBillToId(String) - Method in class bb.common.QuoteVO

setBillToId(String) - Method in class bb.common.RequestForQuoteVO

setBillToId(String) - Method in class bb.common.RequestForRMAVO

setBillToId(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setBillToId(String) - Method in class bb.common.ReturnToVendorByDateListResult

setBillToId(String) - Method in class bb.common.ReturnToVendorVO

setBillToId(String) - Method in class bb.common.RMAReceiverResult

setBillToId(String) - Method in class bb.common.RMAReceiverVO

setBilltoId(String) - Method in class bb.common.RtvShipperInfoVO

setBilltoId(String) - Method in class bb.common.RtvShipperVO

setBillToId(String) - Method in class bb.common.SalesOrderVO

setBillToId(String) - Method in class bb.common.ShipperInfoVO

setBillToId(String) - Method in class bb.common.ShipperVO

setBillToId(String) - Method in class bb.common.SO2SOAgent

setBillToId(String) - Method in class bb.common.WorkOrderVO

setBillToInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.RMAReceiverVO

setBilltoName(String) - Method in class bb.common.PO2SOExchange

setBillType(String) - Method in class bb.common.BillItemPK

setBillType(String) - Method in class bb.common.BillItemReplacementVO

setBillType(String) - Method in class bb.common.BillLogVO

setBillType(String) - Method in class bb.common.BillPK

setBillType(String) - Method in class bb.common.RollUpBomStdCostWorkSheetItemPK

setBillType(String) - Method in class bb.common.SGBillItemPK

setBillType(String) - Method in class bb.common.SGPartListItemResult

setBirthDate(Date) - Method in class bb.common.CustomEmployeeVO

setBirthDate(Date) - Method in class bb.common.EmployeeCardVO

setBirthPlace(String) - Method in class bb.common.EmployeeCardVO

setBloodPressure(String) - Method in class bb.common.CustomCheckUpEmployeeVO

setBnIi(byte) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

setBnIi(byte) - Method in class bb.common.WorkOrderItemIssueVO

setBoilerplateId(String) - Method in class bb.common.ARBoilerplateVO

setBoilerplateId(String) - Method in class bb.common.PurchaseOrderBoilerplateVO

setBoilerplateId(String) - Method in class bb.common.QuoteBoilerplateVO

setBoilerplateId(String) - Method in class bb.common.SalesOrderBoilerplateVO

setBoilerplateId(String) - Method in class bb.common.WorkOrderBoilerplateVO

setBoilerplates(Set) - Method in class bb.common.AccountsReceivableVO

setBoilerplates(Set) - Method in class bb.common.DisassembleWorkOrderVO

setBoilerplates(Set) - Method in class bb.common.PurchaseOrderVO

setBoilerplates(Set) - Method in class bb.common.QuoteVO

setBoilerplates(Set) - Method in class bb.common.SalesOrderVO

setBoilerplates(Set) - Method in class bb.common.WorkOrderVO

setBom(String) - Method in class bb.common.BB2PartInfo

setBom(String) - Method in class bb.common.BomItemWithOEMResult

setBom(String) - Method in class bb.common.BomPickListItemResult

setBom(SGBOMItemResult) - Method in class bb.common.SGBOMResult

setBomColor(String) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

setBomColor(String) - Method in class bb.common.WorkOrderItemIssueVO

setBomCost(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

setBomCost(BigDecimal) - Method in class bb.common.WorkOrderItemPartDetailResult

setBomCount(Integer) - Method in class bb.common.RollUpBomStdCostWorkSheetVO

setBomItemNumber(String) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

setBomItemNumber(String) - Method in class bb.common.WorkOrderItemIssueVO

setBomItemNumber(String) - Method in class bb.common.WorkOrderItemPartDetail

setBomItemQty(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

setBomItemQty(BigDecimal) - Method in class bb.common.WorkOrderItemIssueVO

setBomLastChangeTimes(int) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

setBomLastChangeTimes(int) - Method in class bb.common.WorkOrderItemIssueVO

setBomLevel(byte) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

setBomLevel(byte) - Method in class bb.common.WorkOrderItemIssueVO

setBomNumber(String) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

setBomNumber(String) - Method in class bb.common.WorkOrderItemIssueVO

setBomNumber(String) - Method in class bb.common.WorkOrderItemPartDetail

setBomQty(BigDecimal) - Method in class bb.common.WorkOrderOverIssueListResult

setBomScrapQty(BigDecimal) - Method in class bb.common.WorkOrderItemIssueVO

setBomStdCost(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

setBomStdCost(BigDecimal) - Method in class bb.common.WorkOrderItemPartDetailResult

setBomToDeletedNotUsed(List<BillWithPartInfoResult>) - Method in class bb.common.PartsToDeleteResult

setBookBalance(BigDecimal) - Method in class bb.common.ExchangeAuditItemResult

setBoughtQty(BigDecimal) - Method in class bb.common.RunningAccountOrderItemVO

setBoxNumber(int) - Method in class bb.common.ShipperItemDetailAgent

setBp(String) - Method in class bb.common.AccountsPayableInfoVO

setBp(String) - Method in class bb.common.AccountsPayableVO

setBp(String) - Method in class bb.common.AccountsReceivableInfoVO

setBp(String) - Method in class bb.common.AccountsReceivableVO

setBp(String) - Method in class bb.common.CustomerReturnToVendorVO

setBp(String) - Method in class bb.common.DisassembleWorkOrderVO

setBp(String) - Method in class bb.common.MakeAccountPayableAgent

setBp(String) - Method in class bb.common.MakeCreditMemoAgent

setBp(String) - Method in class bb.common.OnloanReceiverVO

setBp(String) - Method in class bb.common.OnloanShipperVO

setBp(String) - Method in class bb.common.OnLoanVO

setBp(String) - Method in class bb.common.PfReceiverVO

setBp(String) - Method in class bb.common.ProformaInvoiceVO

setBp(String) - Method in class bb.common.PurchaseOrderVO

setBp(String) - Method in class bb.common.QuoteVO

setBp(String) - Method in class bb.common.ReceiverInfoVO

setBp(String) - Method in class bb.common.ReceiverVO

setBp(String) - Method in class bb.common.RequestForQuoteVO

setBp(String) - Method in class bb.common.RequestForRMAVO

setBp(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setBp(String) - Method in class bb.common.ReturnToVendorVO

setBp(String) - Method in class bb.common.RMAReceiverVO

setBp(String) - Method in class bb.common.RtvShipperInfoVO

setBp(String) - Method in class bb.common.RtvShipperVO

setBp(String) - Method in class bb.common.SalesOrderVO

setBp(String) - Method in class bb.common.ShipperInfoVO

setBp(String) - Method in class bb.common.ShipperVO

setBp(String) - Method in class bb.common.WorkOrderVO

setBpId(String) - Method in class bb.common.OrderBoilerplateVO

setBplate(String) - Method in class bb.common.OrderBoilerplateVO

setBreakPoint(Date) - Method in class bb.common.PartOnHandAuditResult

setBudget(Map) - Method in class bb.common.BudgetListResult

setBudget(BigDecimal) - Method in class bb.common.GlCashFlowBudgetVO

setBudget(BigDecimal) - Method in class bb.common.GlFiscalYearBudgetVO

setBudget(BigDecimal) - Method in class bb.common.ProfitLossStatementItemResult

setBudgetAccountsChart(Map<Date, BigDecimal>) - Method in class bb.common.AccountsChartResult

setBudgetAmount(BigDecimal) - Method in class bb.common.PurchaseOrderContractResult

setBudgetAmount(BigDecimal) - Method in class bb.common.PurchaseOrderVO

setBudgetForExpenseListResult(List<BudgetListResult>) - Method in class bb.common.AllBudgetResult

setBudgetForRevenueListResult(List<BudgetListResult>) - Method in class bb.common.AllBudgetResult

setBudgetTotal(BigDecimal) - Method in class bb.common.BudgetListResult

setBudgetYTD(Map) - Method in class bb.common.BudgetListResult

setBugDescription(String) - Method in class bb.common.BizboxBugInfoVO

setBugDescription(String) - Method in class bb.common.BizboxBugVO

setBugId(Integer) - Method in class bb.common.BizboxBugChangesInfoVO

setBugId(Integer) - Method in class bb.common.BizboxBugChangesVO

setBugTitle(String) - Method in class bb.common.BizboxBugInfoVO

setBugTitle(String) - Method in class bb.common.BizboxBugVO

setbUltrasonic(String) - Method in class bb.common.CustomCheckUpEmployeeVO

setBUltrasonic(String) - Method in class bb.common.CustomCheckUpEmployeeVO

setBuyDate(Date) - Method in class bb.common.CustomAssetVO

setBuyer(String) - Method in class bb.common.AccountPayableInfoWithPrepayResult

setBuyer(String) - Method in class bb.common.AccountsPayableInfoVO

setBuyer(String) - Method in class bb.common.AccountsPayableVO

setBuyer(String) - Method in class bb.common.NcrReportListResult

setBuyer(String) - Method in class bb.common.NonConformanceReportVO

setBuyer(String) - Method in class bb.common.OnloanReceiverVO

setBuyer(String) - Method in class bb.common.PfReceiverVO

setBuyer(String) - Method in class bb.common.POReceiverItemListResult

setBuyer(String) - Method in class bb.common.PrReceiverListResult

setBuyer(String) - Method in class bb.common.PurchaseOrderCheckListResult

setBuyer(String) - Method in class bb.common.PurchaseOrderContractResult

setBuyer(String) - Method in class bb.common.PurchaseOrderItemListResult

setBuyer(String) - Method in class bb.common.PurchaseOrderOpenDueListResult

setBuyer(String) - Method in class bb.common.PurchaseOrderVO

setBuyer(String) - Method in class bb.common.ReceiverInfoVO

setBuyer(String) - Method in class bb.common.ReceiverVO

setBuyer(String) - Method in class bb.common.RequestForQuoteCheckListResult

setBuyer(String) - Method in class bb.common.RequestForQuoteItemListResult

setBuyer(String) - Method in class bb.common.RequestForQuoteListResult

setBuyer(String) - Method in class bb.common.RequestForQuoteVO

setBuyer(String) - Method in class bb.common.ReturnToVendorByDateListResult

setBuyer(String) - Method in class bb.common.ReturnToVendorCheckListResult

setBuyer(String) - Method in class bb.common.ReturnToVendorItemListResult

setBuyer(String) - Method in class bb.common.ReturnToVendorListResult

setBuyer(String) - Method in class bb.common.ReturnToVendorVO

setBuyer(String) - Method in class bb.common.SwapOrderItemListResult

setBuyer(String) - Method in class bb.common.SwapOrderListResult

setBuyer(String) - Method in class bb.common.SwapOrderVO

setBuyer(String) - Method in class bb.common.SwapReceiverListResult

setBuyer(String) - Method in class bb.common.SwapReceiverVO

setBuyer(String) - Method in class bb.common.SwapShipperListResult

setBuyer(String) - Method in class bb.common.SwapShipperVO

setBuyerCode(String) - Method in class bb.common.BuyerCodeVO

setBuyercode(String) - Method in class bb.common.InventoryListResult

setBuyerCode(String) - Method in class bb.common.MrpReportAgent

setBuyerCode(String) - Method in class bb.common.PartBasicInfo

setBuyerCode(String) - Method in class bb.common.PartVO

setBuyerCode(String) - Method in class bb.common.PartWithInventoryInfoListResult

setBuyerCode(String) - Method in class bb.common.PartWithOnhandsVO

setBuyerCode(String) - Method in class bb.common.POReceiverItemListResult

setBuyerCode(String) - Method in class bb.common.ToolVO

setBuyerCode(String) - Method in class bb.common.ToolWithOnhandsVO

setBuyerGroup(String) - Method in class bb.common.PurchaseOrderVO

setBuyerGroup(String) - Method in class bb.common.SwapOrderItemListResult

setBuyerGroup(String) - Method in class bb.common.SwapOrderListResult

setBuyerGroup(String) - Method in class bb.common.SwapOrderVO

setBuyerGroup(String) - Method in class bb.common.SwapReceiverListResult

setBuyerGroup(String) - Method in class bb.common.SwapReceiverVO

setBuyerGroup(String) - Method in class bb.common.SwapShipperListResult

setBuyerGroup(String) - Method in class bb.common.SwapShipperVO

setBuyerName(String) - Method in class bb.common.BuyerCodeVO

setBuyerName(String) - Method in class bb.common.PurchaseOrderListResult

setBuyor(String) - Method in class bb.common.ReturnToVendorVO

setBuyor(String) - Method in class bb.common.RMAReceiverVO

setBuyorGroup(String) - Method in class bb.common.ReturnToVendorVO

setByInvoice(boolean) - Method in class bb.common.CustomerVendorAddressInfoVO

setByInvoice(boolean) - Method in class bb.common.CustomerVendorAddressVO

setByOnHand(boolean) - Method in class bb.common.WorkOrderItemCanAssyAgent

setByPos(boolean) - Method in class bb.common.ReturnMaterialAuthorizationVO

setByPos(boolean) - Method in class bb.common.SalesOrderVO

setByShipTOID(boolean) - Method in class bb.common.ShipListAgent

setBytes(byte[]) - Method in class bb.common.BB2Document

setByVendor(boolean) - Method in class bb.common.AddRTVAgent

setC7(String) - Method in class bb.common.GlMonthBudgetVO

setC7(String) - Method in class bb.common.GlMonthVO

setCacct1(String) - Method in class bb.common.ProformaInvoiceVO

setCalcLoad(String) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setCalcNet(BigDecimal) - Method in class bb.common.APAuditListResult

setCalcNet(BigDecimal) - Method in class bb.common.ARAuditListResult

setCalibration(String) - Method in class bb.common.ToolBasicInfo

setCalibration(String) - Method in class bb.common.ToolVO

setCalibration(String) - Method in class bb.common.ToolWithManufacturerInfoResult

setCalibration(String) - Method in class bb.common.ToolWithOnhandsVO

setCanApproveOwn(boolean) - Method in class bb.common.NcrApprovalVO

setCanApproveOwn(boolean) - Method in class bb.common.SwapOrderApprovalVO

setCanApproveOwn(boolean) - Method in class bb.common.TransferOrderApprovalVO

setCanApproveOwnBom(boolean) - Method in class bb.common.BomApprovalVO

setCanApproveOwnPurchaseOrder(String) - Method in class bb.common.PurchaseOrderApprovalVO

setCanApproveOwnRTV(String) - Method in class bb.common.RTVApprovalVO

setCanApproveOwnWorkInstruction(boolean) - Method in class bb.common.WorkInstructionApprovalVO

setCanApproveOwnWorkOrder(String) - Method in class bb.common.DisassembleWorkOrderApprovalVO

setCanApproveOwnWorkOrder(String) - Method in class bb.common.WorkOrderApprovalVO

setCanAsm(BigDecimal) - Method in class bb.common.WorkOrderItemListResult

setCancelledEcnCount(Integer) - Method in class bb.common.EngineeringInfoCenterResult

setCanReviewOwnNonproPicking(boolean) - Method in class bb.common.NonproductivePickingApprovalVO

setCanReviewOwnNonproPicking(String) - Method in class bb.common.NonproductivePickingApproveVO

setCanReviewOwnOnloan(String) - Method in class bb.common.OnloanReviewVO

setCanReviewOwnRMA(String) - Method in class bb.common.RMAReviewVO

setCanReviewOwnSalesOrder(String) - Method in class bb.common.SalesOrderReviewVO

setCanUpdateAnything(short) - Method in class bb.common.BizboxUserListResult

setCanUpdateAnything(short) - Method in class bb.common.BizboxUserVO

setCardId(String) - Method in class bb.common.CustomEmployeeVO

setCarNumber(String) - Method in class bb.common.CorrectiveActionRequestVO

setCarrier(String) - Method in class bb.common.AccountsPayableInfoVO

setCarrier(String) - Method in class bb.common.AccountsPayableVO

setCarrier(String) - Method in class bb.common.AccountsReceivableInfoVO

setCarrier(String) - Method in class bb.common.AccountsReceivableVO

setCarrier(String) - Method in class bb.common.CarrierVO

setCarrier(String) - Method in class bb.common.CustomerReturnToVendorVO

setCarrier(String) - Method in class bb.common.OnloanReceiverVO

setCarrier(String) - Method in class bb.common.OnloanShipperVO

setCarrier(String) - Method in class bb.common.OnLoanVO

setCarrier(String) - Method in class bb.common.PfReceiverVO

setCarrier(String) - Method in class bb.common.PO2SOExchange

setCarrier(String) - Method in class bb.common.ProformaInvoiceVO

setCarrier(String) - Method in class bb.common.PurchaseOrderVO

setCarrier(String) - Method in class bb.common.QuoteVO

setCarrier(String) - Method in class bb.common.ReceiverInfoVO

setCarrier(String) - Method in class bb.common.ReceiverVO

setCarrier(String) - Method in class bb.common.RequestForQuoteVO

setCarrier(String) - Method in class bb.common.RequestForRMAVO

setCarrier(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setCarrier(String) - Method in class bb.common.ReturnToVendorVO

setCarrier(String) - Method in class bb.common.RMAReceiverVO

setCarrier(String) - Method in class bb.common.RtvShipperInfoVO

setCarrier(String) - Method in class bb.common.RtvShipperVO

setCarrier(String) - Method in class bb.common.SalesOrderVO

setCarrier(String) - Method in class bb.common.ShipperAgent

setCarrier(String) - Method in class bb.common.ShipperInfoVO

setCarrier(String) - Method in class bb.common.ShipperVO

setCarrier(String) - Method in class bb.common.SwapOrderListResult

setCarrier(String) - Method in class bb.common.SwapOrderVO

setCarrier(String) - Method in class bb.common.SwapReceiverListResult

setCarrier(String) - Method in class bb.common.SwapReceiverVO

setCarrier(String) - Method in class bb.common.SwapShipperListResult

setCarrier(String) - Method in class bb.common.SwapShipperVO

setCarrier(String) - Method in class bb.common.TransferOrderListResult

setCarrier(String) - Method in class bb.common.TransferOrderVO

setCarrier(String) - Method in class bb.common.TransferReceiverListResult

setCarrier(String) - Method in class bb.common.TransferReceiverVO

setCarrier(String) - Method in class bb.common.TransferShipperListResult

setCarrier(String) - Method in class bb.common.TransferShipperVO

setCarrierAccount(String) - Method in class bb.common.AccountsPayableInfoVO

setCarrierAccount(String) - Method in class bb.common.AccountsPayableVO

setCarrierAccount(String) - Method in class bb.common.CarrierVO

setCarrierAccount(String) - Method in class bb.common.MakeInvoiceAgent

setCarrierAccount(String) - Method in class bb.common.OnloanReceiverVO

setCarrierAccount(String) - Method in class bb.common.OnloanShipperVO

setCarrierAccount(String) - Method in class bb.common.PfReceiverVO

setCarrierAccount(String) - Method in class bb.common.ProformaInvoiceVO

setCarrierAccount(String) - Method in class bb.common.PurchaseOrderVO

setCarrierAccount(String) - Method in class bb.common.QuoteVO

setCarrierAccount(String) - Method in class bb.common.ReceiverInfoVO

setCarrierAccount(String) - Method in class bb.common.ReceiverVO

setCarrierAccount(String) - Method in class bb.common.ReturnToVendorVO

setCarrierAccount(String) - Method in class bb.common.RtvShipperInfoVO

setCarrierAccount(String) - Method in class bb.common.RtvShipperVO

setCarrierAccount(String) - Method in class bb.common.SalesOrderVO

setCarrierAccount(String) - Method in class bb.common.ShipperInfoVO

setCarrierAccount(String) - Method in class bb.common.ShipperVO

setCarrierAccount(String) - Method in class bb.common.SwapOrderListResult

setCarrierAccount(String) - Method in class bb.common.SwapOrderVO

setCarrierAccount(String) - Method in class bb.common.SwapReceiverListResult

setCarrierAccount(String) - Method in class bb.common.SwapReceiverVO

setCarrierAccount(String) - Method in class bb.common.SwapShipperListResult

setCarrierAccount(String) - Method in class bb.common.SwapShipperVO

setCarrierAccount(String) - Method in class bb.common.TransferOrderListResult

setCarrierAccount(String) - Method in class bb.common.TransferOrderVO

setCarrierAccount(String) - Method in class bb.common.TransferReceiverListResult

setCarrierAccount(String) - Method in class bb.common.TransferReceiverVO

setCarrierAccount(String) - Method in class bb.common.TransferShipperListResult

setCarrierAccount(String) - Method in class bb.common.TransferShipperVO

setCarrierAcct(String) - Method in class bb.common.AccountsReceivableInfoVO

setCarrierAcct(String) - Method in class bb.common.AccountsReceivableVO

setCarrierAcct(String) - Method in class bb.common.CustomerReturnToVendorVO

setCarrierAcct(String) - Method in class bb.common.OnLoanVO

setCarrierAcct(String) - Method in class bb.common.RequestForQuoteVO

setCarrierAcct(String) - Method in class bb.common.RequestForRMAVO

setCarrierAcct(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setCarrierAcct(String) - Method in class bb.common.RMAReceiverVO

setCartType(String) - Method in class bb.common.PurchaseWorkSheetItemPK

setCartType(String) - Method in class bb.common.PurchaseWorkSheetPK

setCartType(String) - Method in class bb.common.WorkOrderWorkSheetItemPK

setCartType(String) - Method in class bb.common.WorkOrderWorkSheetPK

setCash(BigDecimal) - Method in class bb.common.AccountingBalanceSheetResult

setCashCheckReceived(String) - Method in class bb.common.ExpenseVO

setCashEndPosition(TreeMap) - Method in class bb.common.TwelveMonthCashFlowReportResult

setCashier(String) - Method in class bb.common.CashierVO

setCashier(String) - Method in class bb.common.GeneralLedgerByDateListResult

setCashPosition(TreeMap) - Method in class bb.common.TwelveMonthCashFlowReportResult

setCashTotal(BigDecimal) - Method in class bb.common.MoneyInDrawResult

setCatalog(String) - Method in class bb.common.PartCatalogAuditResult

setCatalog(String) - Method in class bb.common.PartCatalogVO

setCatalog(String) - Method in class bb.common.PartVO

setCatalog(String) - Method in class bb.common.PartWithOnhandsVO

setCatalog(String) - Method in class bb.common.SGDocPartVO

setCatalog(String) - Method in class bb.common.SGPartCatalogResult

setCatalog(String) - Method in class bb.common.SGSaleItemVO

setCatalogID(String) - Method in class bb.common.CatalogVO

setCatalogRev(String) - Method in class bb.common.SGDocPartVO

setCategory(String) - Method in class bb.common.AddressQualityDocumentsVO

setCategory(String) - Method in class bb.common.MiscDocAgent

setCategory(Collection) - Method in class bb.common.PartTraceableInfoResult

setCategoryDescription(TraceableCategoriesVO) - Method in class bb.common.PartTraceableCategoryVO

setCategoryId(Long) - Method in class bb.common.AccountsChartVO

setCategoryId(String) - Method in class bb.common.JounalEntryListResult

setCategoryId(String) - Method in class bb.common.PartTraceableCategoryVO

setCategoryId(String) - Method in class bb.common.PartTraceableResult

setCategoryId(String) - Method in class bb.common.TraceableCategoriesVO

setCategoryName(String) - Method in class bb.common.AccountsChartCategoryVO

setCategoryName(String) - Method in class bb.common.GeneralLedgerPrintResult

setCategorySequence(Integer) - Method in class bb.common.AssetDepreciateVO

setCategorySequence(Integer) - Method in class bb.common.GeneralLedgerByDateListResult

setCategorySequence(Integer) - Method in class bb.common.GeneralLedgerListResult

setCategorySequence(Integer) - Method in class bb.common.GeneralLedgerPrintResult

setCategorySequence(Integer) - Method in class bb.common.GeneralLedgerVO

setCategorySequence(Integer) - Method in class bb.common.GLApprovalListResult

setCategorySequence(Integer) - Method in class bb.common.GLCatAndSequence

setCategorySequence(int) - Method in class bb.common.JounalEntryListResult

setCategorySequence(Integer) - Method in class bb.common.JounalEntryListResult

setCategoryType(String) - Method in class bb.common.AccountsChartCategoryVO

setCatTest(String) - Method in class bb.common.SGDocPartVO

setCatTestRv(String) - Method in class bb.common.SGDocPartVO

setCause(String) - Method in class bb.common.AccountCreditVO

setCause(String) - Method in class bb.common.AccountDebitVO

setCause(String) - Method in class bb.common.AccountsCreditDebitListResult

setCause(String) - Method in interface bb.common.Alarmable

setCause(String) - Method in class bb.common.APAuditListResult

setCause(String) - Method in class bb.common.ARAuditListResult

setCause(String) - Method in class bb.common.GLItemVO

setCause(String) - Method in class bb.common.LockedCustomerAddressResult

setCause(String) - Method in class bb.common.PartCatalogAuditResult

setCause(String) - Method in class bb.common.PartOnHandAuditResult

setCclimit(boolean) - Method in class bb.common.CustomerCLimitResult

setCCode(String) - Method in class bb.common.PartInventoryVO

setCCode(String) - Method in class bb.common.ToolInventoryVO

setCcTotal(BigDecimal) - Method in class bb.common.MoneyInDrawResult

setCertificateDate(Date) - Method in class bb.common.PartCertificateVO

setCertificateDate(Date) - Method in class bb.common.SerialNumberResult

setCertificateDescription(String) - Method in class bb.common.PartCertificateListResult

setCertificateDescription(String) - Method in class bb.common.PartCertificateVO

setCertificateName(String) - Method in class bb.common.CustomEmployeeTrainVO

setCertificateNumber(String) - Method in class bb.common.PartCertificateListResult

setCertificateNumber(String) - Method in class bb.common.PartCertificateVO

setCertificateNumber(String) - Method in class bb.common.SerialNumberItemVO

setCertificateStatus(String) - Method in class bb.common.CustomAssetVO

setCertificationId(String) - Method in class bb.common.CustomEmployeeTrainVO

setCertificationNumber(String) - Method in class bb.common.ToolCalibrationVO

setCertiName(String) - Method in class bb.common.EmployeeTrainingVO

setCertiNumber(String) - Method in class bb.common.EmployeeTrainingVO

setCf(String) - Method in class bb.common.GlCashFlowBudgetVO

setChangedByEngineer(String) - Method in class bb.common.EngineeringChangeRequestVO

setChangeMfg(String) - Method in class bb.common.CustomerReturnToVendorItemVO

setChangeMfg(String) - Method in class bb.common.PurchaseOrderItemVO

setChangeMfg(String) - Method in class bb.common.RequestForRMAItemVO

setChangeMfg(String) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setChangeMfg(String) - Method in class bb.common.ReturnToVendorItemVO

setChangeNote(BigDecimal) - Method in class bb.common.RunningAccountOrderVO

setChangeOrder(String) - Method in class bb.common.AccountsPayableInfoVO

setChangeOrder(String) - Method in class bb.common.AccountsPayableVO

setChangeOrder(String) - Method in class bb.common.AccountsReceivableInfoVO

setChangeOrder(String) - Method in class bb.common.AccountsReceivableVO

setChangeOrder(String) - Method in class bb.common.CRTVListResult

setChangeOrder(String) - Method in class bb.common.CustomerReturnToVendorItemVO

setChangeOrder(String) - Method in class bb.common.CustomerReturnToVendorVO

setChangeOrder(String) - Method in class bb.common.DisassembleWorkOrderIssuingResult

setChangeOrder(String) - Method in class bb.common.DisassembleWorkOrderItemVO

setChangeOrder(String) - Method in class bb.common.DisassembleWorkOrderListResult

setChangeOrder(String) - Method in class bb.common.DisassembleWorkOrderReceivingResult

setChangeOrder(String) - Method in class bb.common.DisassembleWorkOrderVO

setChangeOrder(String) - Method in class bb.common.IssuingResult

setChangeOrder(String) - Method in class bb.common.LnShipperListResult

setChangeOrder(String) - Method in class bb.common.OnLoanItemVO

setChangeOrder(String) - Method in class bb.common.OnLoanListResult

setChangeOrder(String) - Method in class bb.common.OnloanReceiverVO

setChangeOrder(String) - Method in class bb.common.OnloanShipperVO

setChangeOrder(String) - Method in class bb.common.OnLoanVO

setChangeOrder(String) - Method in class bb.common.PfReceiverVO

setChangeOrder(String) - Method in class bb.common.PrepayAgent

setChangeOrder(String) - Method in class bb.common.ProformaInvoiceVO

setChangeOrder(String) - Method in class bb.common.PurchaseOrderItemVO

setChangeOrder(String) - Method in class bb.common.PurchaseOrderListResult

setChangeOrder(String) - Method in class bb.common.PurchaseOrderVO

setChangeOrder(String) - Method in class bb.common.QuoteItemVO

setChangeOrder(String) - Method in class bb.common.QuoteListResult

setChangeOrder(String) - Method in class bb.common.QuoteVO

setChangeOrder(String) - Method in class bb.common.ReceiverInfoVO

setChangeOrder(String) - Method in class bb.common.ReceiverVO

setChangeOrder(String) - Method in class bb.common.ReceivingResult

setChangeOrder(String) - Method in class bb.common.RequestForQuoteListResult

setChangeOrder(String) - Method in class bb.common.RequestForQuoteVO

setChangeOrder(String) - Method in class bb.common.RequestForRMAItemVO

setChangeOrder(String) - Method in class bb.common.RequestForRMAVO

setChangeOrder(String) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setChangeOrder(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setChangeOrder(String) - Method in class bb.common.ReturnToVendorItemVO

setChangeOrder(String) - Method in class bb.common.ReturnToVendorVO

setChangeOrder(String) - Method in class bb.common.RMAListResult

setChangeOrder(String) - Method in class bb.common.RMAReceiverVO

setChangeOrder(String) - Method in class bb.common.RRMAListResult

setChangeOrder(String) - Method in class bb.common.RtvShipperInfoVO

setChangeOrder(String) - Method in class bb.common.RtvShipperVO

setChangeOrder(String) - Method in class bb.common.SalesOrderItemInfoVO

setChangeOrder(String) - Method in class bb.common.SalesOrderItemVO

setChangeOrder(String) - Method in class bb.common.SalesOrderListResult

setChangeOrder(String) - Method in class bb.common.SalesOrderVO

setChangeOrder(String) - Method in class bb.common.ShipperInfoVO

setChangeOrder(String) - Method in class bb.common.ShipperListResult

setChangeOrder(String) - Method in class bb.common.ShipperVO

setChangeOrder(String) - Method in class bb.common.WoItemPickListResult

setChangeOrder(String) - Method in class bb.common.WorkOrderItemVO

setChangeOrder(String) - Method in class bb.common.WorkOrderListResult

setChangeOrder(String) - Method in class bb.common.WorkOrderVO

setChangePercent(BigDecimal) - Method in class bb.common.ClosingStatementTotalResult

setChangePercent(Double) - Method in class bb.common.ProfitLossStatementItemResult

setChangePercentOfBudget(BigDecimal) - Method in class bb.common.ProfitLossStatementItemResult

setChangeRule(int) - Method in class bb.common.CompanyVO

setChanges(Set) - Method in class bb.common.BizboxBugInfoVO

setChangOrder(String) - Method in class bb.common.ShippingResult

setCheck(String) - Method in class bb.common.ApPrepayVO

setCheck(String) - Method in class bb.common.ArPrepayVO

setCheck(String) - Method in class bb.common.GeneralLedgerResult

setCheckAccountNumber(String) - Method in class bb.common.PayableMethodVO

setCheckAccountNumber(String) - Method in class bb.common.PaymentVO

setCheckAmount(BigDecimal) - Method in class bb.common.PostCheckAgent

setCheckEachOther(boolean) - Method in class bb.common.InspectionReportInfoVO

setCheckEachOther(boolean) - Method in class bb.common.InspectionReportVO

setChecked(String) - Method in class bb.common.AccountPayableCheckRunVO

setChecked(String) - Method in class bb.common.ARPaymentRunVO

setChecked(boolean) - Method in class bb.common.BudgetListResult

setChecked(boolean) - Method in class bb.common.GlCashFlowBudgetVO

setChecked(boolean) - Method in class bb.common.PackingBoxSalesOrderItemResult

setCheckedItem(String) - Method in class bb.common.BudgetListResult

setCheckNo(String) - Method in class bb.common.AccountsReceivableInfoVO

setCheckNo(String) - Method in class bb.common.AccountsReceivableVO

setCheckNo(String) - Method in class bb.common.OnloanReceiverVO

setCheckNo(String) - Method in class bb.common.ProformaInvoiceVO

setCheckNo(String) - Method in class bb.common.ReceiverInfoVO

setCheckNo(String) - Method in class bb.common.ReceiverVO

setCheckNo(String) - Method in class bb.common.RMAReceiverItemVO

setCheckNo(String) - Method in class bb.common.RMAReceiverVO

setCheckNo(String) - Method in class bb.common.RtvShipperItemVO

setCheckNumber(String) - Method in class bb.common.AccountPayableCheckRunItemVO

setCheckNumber(String) - Method in class bb.common.AccountPayableCheckRunVO

setCheckNumber(String) - Method in class bb.common.AccountPayableCheckVO

setCheckNumber(String) - Method in class bb.common.AccountsPayableInfoVO

setCheckNumber(String) - Method in class bb.common.AccountsPayableItemVO

setCheckNumber(String) - Method in class bb.common.AccountsPayableVO

setCheckNumber(String) - Method in class bb.common.AccountsReceivableItemVO

setCheckNumber(String) - Method in class bb.common.ApCheckRunListResult

setCheckNumber(String) - Method in class bb.common.DepositSummaryResult

setCheckNumber(String) - Method in class bb.common.GeneralLedgerByDateListResult

setCheckNumber(String) - Method in class bb.common.GeneralLedgerListResult

setCheckNumber(String) - Method in class bb.common.GeneralLedgerVO

setCheckNumber(String) - Method in class bb.common.MakeCheckAgent

setCheckNumber(String) - Method in class bb.common.MakePrepaymentCheckAgent

setCheckNumber(String) - Method in class bb.common.OnloanReceiverItemVO

setCheckNumber(String) - Method in class bb.common.OnloanShipperItemVO

setCheckNumber(String) - Method in class bb.common.OnloanShipperVO

setCheckNumber(String) - Method in class bb.common.PaymentAgent

setCheckNumber(String) - Method in class bb.common.PaymentInvoicesResult

setCheckNumber(String) - Method in class bb.common.PostCheckAgent

setCheckNumber(String) - Method in class bb.common.PrepayPaymentAgent

setCheckNumber(String) - Method in class bb.common.ReceiverItemVO

setCheckNumber(String) - Method in class bb.common.RtvShipperInfoVO

setCheckNumber(String) - Method in class bb.common.RtvShipperVO

setCheckNumber(String) - Method in class bb.common.RunningAccountOrderItemResult

setCheckNumber(String) - Method in class bb.common.RunningAccountOrderVO

setCheckNumber(String) - Method in class bb.common.ShipperInfoVO

setCheckNumber(String) - Method in class bb.common.ShipperItemVO

setCheckNumber(String) - Method in class bb.common.ShipperVO

setCheckNumberInt(int) - Method in class bb.common.AccountPayableCheckVO

setCheckPaid(String) - Method in class bb.common.ExpenseVO

setCheckPrintAdjust(byte) - Method in class bb.common.AccountingSettingsVO

setCheckPrintAdjustX(byte) - Method in class bb.common.AccountingSettingsVO

setCheckPrintAdjustY(byte) - Method in class bb.common.AccountingSettingsVO

setCheckPrinted(String) - Method in class bb.common.GeneralLedgerListResult

setCheckPrinted(String) - Method in class bb.common.GeneralLedgerResult

setCheckPrinted(String) - Method in class bb.common.GeneralLedgerVO

setCheckReturn(boolean) - Method in class bb.common.RunningAccountOrderItemResult

setCheckReturn(boolean) - Method in class bb.common.RunningAccountOrderVO

setCheckRunItems(Set) - Method in class bb.common.AccountPayableCheckRunVO

setCheckRunNumber(String) - Method in class bb.common.AccountPayableCheckRunVO

setCheckRunNumber(String) - Method in class bb.common.AccountPayableCheckVO

setCheckRunNumber(String) - Method in class bb.common.ApCheckRunListResult

setCheckRunNumber(String) - Method in class bb.common.GeneralLedgerVO

setCheckRunNumber(String) - Method in class bb.common.PayableCheckRunItemPK

setCheckRunNumber(String) - Method in class bb.common.PaymentInvoicesResult

setCheckTime(Date) - Method in class bb.common.CustomCheckUpEmployeeVO

setCheckTotal(BigDecimal) - Method in class bb.common.AccountPayableCheckRunItemVO

setCheckTotal(BigDecimal) - Method in class bb.common.MoneyInDrawResult

setCheckType(String) - Method in class bb.common.GLCheckRegisterResult

setCHold(boolean) - Method in class bb.common.CustomerCLimitResult

setCity(String) - Method in class bb.common.AccountPayableCheckVO

setCity(String) - Method in class bb.common.AccountReceivablePaymentVO

setCity(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setCity(String) - Method in class bb.common.CustomerVendorAddressVO

setCity(String) - Method in class bb.common.CustomerVendorDescriptionVO

setCity(String) - Method in class bb.common.EmployeeEducationVO

setCity(String) - Method in class bb.common.EmployeeHomeVO

setCity(String) - Method in class bb.common.IpAddressVO

setCity(String) - Method in class bb.common.LockedCustomerAddressResult

setCity(String) - Method in class bb.common.ManufacturerAddressInfoVO

setCity(String) - Method in class bb.common.ManufacturerAddressVO

setCity(String) - Method in class bb.common.ManufacturerDescriptionVO

setCity(String) - Method in class bb.common.SalesmanVO

setCity(String) - Method in class bb.common.SGCartCheckOutResult

setCity(String) - Method in class bb.common.SGCustRequestForQuoteListResult

setCity(String) - Method in class bb.common.SGCustRequestForQuoteResult

setCity(String) - Method in class bb.common.SGQuoteAddressResult

setCity(String) - Method in class bb.common.SGQuoteAddressVO

setCityCode(String) - Method in class bb.common.PosZipCodeTaxVO

setCityName(String) - Method in class bb.common.PosZipCodeTaxVO

setCityName(String) - Method in class bb.common.ZipcodeTotalsResult

setCityOrCountyCode(String) - Method in class bb.common.ZipcodeTotalsResult

setCityTaxRate(BigDecimal) - Method in class bb.common.PosZipCodeTaxVO

setClazzName(String) - Method in class bb.common.PrintTemplateVO

setCleanWorker(String) - Method in class bb.common.InspectionReportInfoVO

setCleanWorker(String) - Method in class bb.common.InspectionReportVO

setClear(boolean) - Method in class bb.common.GeneralLedgerByDateListResult

setClear(boolean) - Method in class bb.common.GeneralLedgerVO

setClient(String) - Method in class bb.common.SGClientAccountPK

setClient(String) - Method in class bb.common.SGClientLogin

setClient(String) - Method in class bb.common.SGCompanyPK

setClient(String) - Method in class bb.common.SGCustRequestForQuoteVO

setClient(String) - Method in class bb.common.SGLogLoginVO

setClient(String) - Method in class bb.common.SGQuoteAddressVO

setClient(String) - Method in class bb.common.SGQuoteLoginVO

setClientIP(String) - Method in class bb.common.BB2Login

setClientMAC(String) - Method in class bb.common.BB2Login

setClientProperties(Map) - Method in class bb.common.VO

setClientWanIp(String) - Method in class bb.common.BB2Login

setClinicaLab(String) - Method in class bb.common.CustomCheckUpEmployeeVO

setCloseAR(boolean) - Method in class bb.common.PaymentAgent

setCloseDate(Date) - Method in class bb.common.DesignControlInfoVO

setCloseDate(Date) - Method in class bb.common.DesignControlVO

setClosedDate(Date) - Method in class bb.common.CustomerServiceIncidentItemListResult

setClosedDate(Date) - Method in class bb.common.CustomerServiceIncidentVO

setClosedOutApproval(String) - Method in class bb.common.NonConformanceReportVO

setClosedOutApproval(String) - Method in class bb.common.PreventiveActionRequestVO

setClosedOutBy(String) - Method in class bb.common.CorrectiveActionRequestVO

setClosedOutComments(String) - Method in class bb.common.CorrectiveActionRequestVO

setClosedOutComments(String) - Method in class bb.common.PreventiveActionRequestVO

setClosedOutDate(Date) - Method in class bb.common.CorrectiveActionRequestVO

setClosedOutDate(Date) - Method in class bb.common.EngineeringChangeRequestVO

setClosedOutDate(Date) - Method in class bb.common.IcrItemListResult

setClosedOutDate(Date) - Method in class bb.common.IcrListResult

setClosedOutDate(Date) - Method in class bb.common.InspectionConformanceReportVO

setClosedOutDate(Date) - Method in class bb.common.NcrReportListResult

setClosedOutDate(Date) - Method in class bb.common.NonConformanceReportVO

setClosedOutDate(Date) - Method in class bb.common.PreventiveActionRequestVO

setClosedOutPrivateNotes(String) - Method in class bb.common.CorrectiveActionRequestVO

setClosedOutPrivateNotes(String) - Method in class bb.common.EngineeringChangeRequestListResult

setClosedOutPrivateNotes(String) - Method in class bb.common.EngineeringChangeRequestVO

setClosedOutPrivateNotes(String) - Method in class bb.common.NcrReportListResult

setClosedOutPrivateNotes(String) - Method in class bb.common.NonConformanceReportVO

setClosedOutPrivateNotes(String) - Method in class bb.common.PreventiveActionRequestVO

setCm(String) - Method in class bb.common.RMAReceiverItemListResult

setCm0(String) - Method in class bb.common.GeneralLedgerSettingsVO

setCm1(String) - Method in class bb.common.GeneralLedgerSettingsVO

setCm2(String) - Method in class bb.common.GeneralLedgerSettingsVO

setCmDigits(byte) - Method in class bb.common.CompanyVO

setCmDisc(BigDecimal) - Method in class bb.common.RMAReceiverItemVO

setCmDisc(BigDecimal) - Method in class bb.common.RMAReceiverVO

setCmFreight(BigDecimal) - Method in class bb.common.RMAReceiverVO

setCmGl1Recorded(BigDecimal) - Method in class bb.common.RMAReceiverVO

setCmGl2Paid(BigDecimal) - Method in class bb.common.RMAReceiverVO

setCmNet(BigDecimal) - Method in class bb.common.RMAReceiverItemVO

setCmNet(BigDecimal) - Method in class bb.common.RMAReceiverVO

setCmNetSet(String) - Method in class bb.common.RMAReceiverVO

setCmOpen(BigDecimal) - Method in class bb.common.RMAReceiverItemVO

setCmOpen(BigDecimal) - Method in class bb.common.RMAReceiverVO

setCmPaidGl(BigDecimal) - Method in class bb.common.RMAReceiverVO

setCmPaidRcv(BigDecimal) - Method in class bb.common.RMAReceiverVO

setCmPrefix(String) - Method in class bb.common.CompanyVO

setCmRcvd(BigDecimal) - Method in class bb.common.RMAReceiverItemVO

setCmRcvd(BigDecimal) - Method in class bb.common.RMAReceiverVO

setCmSub(BigDecimal) - Method in class bb.common.RMAReceiverItemVO

setCmSub(BigDecimal) - Method in class bb.common.RMAReceiverVO

setCmTax(BigDecimal) - Method in class bb.common.RMAReceiverItemVO

setCmTax(BigDecimal) - Method in class bb.common.RMAReceiverVO

setCmTaxSet(String) - Method in class bb.common.RMAReceiverVO

setCmTotal(BigDecimal) - Method in class bb.common.RMAReceiverItemVO

setCmTotal(BigDecimal) - Method in class bb.common.RMAReceiverVO

setCoComments(String) - Method in class bb.common.AccountsPayableVO

setCoComments(String) - Method in class bb.common.AccountsReceivableVO

setCoComments(String) - Method in class bb.common.CustomerReturnToVendorVO

setCoComments(String) - Method in class bb.common.DisassembleWorkOrderVO

setCoComments(String) - Method in class bb.common.OnloanReceiverVO

setCoComments(String) - Method in class bb.common.OnloanShipperVO

setCoComments(String) - Method in class bb.common.PurchaseOrderVO

setCoComments(String) - Method in class bb.common.QuoteVO

setCoComments(String) - Method in class bb.common.ReceiverVO

setCoComments(String) - Method in class bb.common.RequestForQuoteVO

setCoComments(String) - Method in class bb.common.RequestForRMAVO

setCoComments(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setCoComments(String) - Method in class bb.common.ReturnToVendorVO

setCoComments(String) - Method in class bb.common.RMAReceiverVO

setCoComments(String) - Method in class bb.common.RtvShipperInfoVO

setCoComments(String) - Method in class bb.common.RtvShipperVO

setCoComments(String) - Method in class bb.common.SalesOrderVO

setCoComments(String) - Method in class bb.common.ShipperVO

setCoComments(String) - Method in class bb.common.SwapReceiverListResult

setCoComments(String) - Method in class bb.common.SwapReceiverVO

setCoComments(String) - Method in class bb.common.SwapShipperListResult

setCoComments(String) - Method in class bb.common.SwapShipperVO

setCoComments(String) - Method in class bb.common.TransferReceiverListResult

setCoComments(String) - Method in class bb.common.TransferReceiverVO

setCoComments(String) - Method in class bb.common.TransferShipperListResult

setCoComments(String) - Method in class bb.common.TransferShipperVO

setCoComments(String) - Method in class bb.common.WorkOrderVO

setCode(String) - Method in class bb.common.NonConformanceCodeDescriptionPK

setCode(String) - Method in class bb.common.NonConformanceCodeVO

setCollect(String) - Method in class bb.common.AccountsPayableInfoVO

setCollect(String) - Method in class bb.common.AccountsPayableVO

setCollect(String) - Method in class bb.common.OnloanReceiverVO

setCollect(String) - Method in class bb.common.ReceiverInfoVO

setCollect(String) - Method in class bb.common.ReceiverVO

setCollect(String) - Method in class bb.common.RMAReceiverVO

setCollege(String) - Method in class bb.common.EmployeeEducationVO

setColumns(LinkedHashSet) - Method in class bb.common.TwelveMonthCashFlowReportResult

setCommanyName(String) - Method in class bb.common.SerialNumberItemPK

setCommanyName(String) - Method in class bb.common.SerialNumberPK

setComment(String) - Method in class bb.common.AccountPayableCheckVO

setComment(String) - Method in class bb.common.BizBoxUserEmployeeResult

setComment(String) - Method in class bb.common.BizboxUserListResult

setComment(String) - Method in class bb.common.BizboxUserVO

setComment(String) - Method in class bb.common.CustomCheckUpEmployeeVO

setComment(String) - Method in class bb.common.EmployeeHomeVO

setComment(String) - Method in class bb.common.ExpenseItemVO

setComment(String) - Method in class bb.common.OperationLogVO

setComment(String) - Method in class bb.common.PartVO

setComment(String) - Method in class bb.common.PartWithOnhandsVO

setComment(String) - Method in class bb.common.PurchaseOrderContractResult

setComment(String) - Method in class bb.common.SalesOrderItemListResult

setComment(String) - Method in class bb.common.ShipperItemAgent

setComment(String) - Method in class bb.common.ToolCalibrationVO

setComment(String) - Method in class bb.common.ToolVO

setComment(String) - Method in class bb.common.ToolWithOnhandsVO

setComment(String) - Method in class bb.common.WorkCalendarVO

setComment(String) - Method in class bb.common.WorkInstructionVO

setComment(String) - Method in class bb.common.WorkOrderWorkInstructionVO

setComments(String) - Method in class bb.common.AccountingInfoDocumentVO

setComments(String) - Method in class bb.common.AccountsChartMappingVO

setComments(String) - Method in class bb.common.AccountsPayableInfoVO

setComments(String) - Method in class bb.common.AccountsPayableItemVO

setComments(String) - Method in class bb.common.AccountsPayableVO

setComments(String) - Method in class bb.common.AllPartDocumentsVO

setComments(String) - Method in class bb.common.ApPrepayItemVO

setComments(String) - Method in class bb.common.ArPrepayItemVO

setComments(String) - Method in class bb.common.AssetVO

setComments(String) - Method in class bb.common.BB2Document

setComments(String) - Method in class bb.common.BillItemVO

setComments(String) - Method in class bb.common.BillItemWithPartInfoResult

setComments(String) - Method in class bb.common.BomApprovalVO

setComments(String) - Method in class bb.common.BuyerCodeVO

setComments(String) - Method in class bb.common.ChangeStdCostWorkSheetVO

setComments(String) - Method in class bb.common.CompanyUnitVO

setComments(String) - Method in class bb.common.ContractPriceItemVO

setComments(String) - Method in class bb.common.CRTVListResult

setComments(String) - Method in class bb.common.CustomAssetVO

setComments(String) - Method in class bb.common.CustomEmployeeVO

setComments(String) - Method in class bb.common.CustomerFeedbackVO

setComments(String) - Method in class bb.common.CustomerReturnToVendorVO

setComments(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setComments(String) - Method in class bb.common.CustomerVendorAddressVO

setComments(String) - Method in class bb.common.CustomerVendorContactVO

setComments(String) - Method in class bb.common.CustomerVendorTypeVO

setComments(String) - Method in class bb.common.CustomGoodsBreedVO

setComments(String) - Method in class bb.common.CustomJobCategoryVO

setComments(String) - Method in class bb.common.DesignControlDocumentVO

setComments(String) - Method in class bb.common.DisassembleWorkOrderDocumentVO

setComments(String) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setComments(String) - Method in class bb.common.DisassembleWorkOrderItemListResult

setComments(String) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

setComments(String) - Method in class bb.common.DocumentInfoAgent

setComments(String) - Method in class bb.common.ECNReviewVO

setComments(String) - Method in class bb.common.ECRReviewVO

setComments(String) - Method in class bb.common.EjbMethodVO

setComments(String) - Method in class bb.common.EmployeeCardVO

setComments(String) - Method in class bb.common.EmployeeLaborAgent

setComments(String) - Method in class bb.common.EmployeeRecordsVO

setComments(String) - Method in class bb.common.EngGroupUserVO

setComments(String) - Method in class bb.common.EngineeringChangeDocumentVO

setComments(String) - Method in class bb.common.EngineeringChangeRequestDocumentVO

setComments(String) - Method in class bb.common.EngineeringSharingVO

setComments(String) - Method in class bb.common.GeneralLedgerApprovalVO

setComments(String) - Method in class bb.common.GeneralLedgerListResult

setComments(String) - Method in class bb.common.GeneralLedgerVO

setComments(String) - Method in class bb.common.IcrItemListResult

setComments(String) - Method in class bb.common.IcrListResult

setComments(String) - Method in class bb.common.InspectionConformanceReportItemVO

setComments(String) - Method in class bb.common.InspectionConformanceReportVO

setComments(String) - Method in class bb.common.InventoryAdjustmentVO

setComments(String) - Method in class bb.common.InventoryPartInOutDetailListResult

setComments(String) - Method in class bb.common.LabelTemplateVO

setComments(String) - Method in class bb.common.LnShipperListResult

setComments(String) - Method in class bb.common.LockedCustomerAddressResult

setComments(String) - Method in class bb.common.LogTaskVO

setComments(String) - Method in class bb.common.ManufacturerAddressInfoVO

setComments(String) - Method in class bb.common.ManufacturerAddressVO

setComments(String) - Method in class bb.common.ManufacturerContactVO

setComments(String) - Method in class bb.common.MiscDocAgent

setComments(String) - Method in class bb.common.NcrApprovalVO

setComments(String) - Method in class bb.common.NCRPictureListResult

setComments(String) - Method in class bb.common.NCRPictureVO

setComments(String) - Method in class bb.common.NonproductivePickingApprovalVO

setComments(String) - Method in class bb.common.NonproductivePickingItemResult

setComments(String) - Method in class bb.common.NonproductivePickingItemVO

setComments(String) - Method in class bb.common.NonproductivePickingVO

setComments(String) - Method in class bb.common.OnloanDocumentVO

setComments(String) - Method in class bb.common.OnLoanListResult

setComments(String) - Method in class bb.common.OnloanReceiverItemListResult

setComments(String) - Method in class bb.common.OnloanReceiverItemVO

setComments(String) - Method in class bb.common.OnloanReceiverListResult

setComments(String) - Method in class bb.common.OnloanReceiverVO

setComments(String) - Method in class bb.common.OrderDocumentVO

setComments(String) - Method in class bb.common.PartCatalogVO

setComments(String) - Method in class bb.common.PartCertificateVO

setComments(String) - Method in class bb.common.PartClassVO

setComments(String) - Method in class bb.common.PartDiscountVO

setComments(String) - Method in class bb.common.PartDocumentVO

setComments(String) - Method in class bb.common.PartInQAAgent

setComments(String) - Method in class bb.common.PartInQAResult

setComments(String) - Method in class bb.common.PartInQAVO

setComments(String) - Method in class bb.common.PaymentAgent

setComments(String) - Method in class bb.common.PfReceiverVO

setComments(String) - Method in class bb.common.PO2SOExchange

setComments(String) - Method in class bb.common.PoMessageItemVO

setComments(String) - Method in class bb.common.PoMessageListResult

setComments(String) - Method in class bb.common.PoMessageVO

setComments(String) - Method in class bb.common.POStatisticsResult

setComments(String) - Method in class bb.common.POSurveyReportVO

setComments(String) - Method in class bb.common.PrepayPaymentAgent

setComments(String) - Method in class bb.common.PrintTemplateVO

setComments(String) - Method in class bb.common.ProformaInvoiceListResult

setComments(String) - Method in class bb.common.ProformaInvoiceVO

setComments(String) - Method in class bb.common.PrReceiverListResult

setComments(String) - Method in class bb.common.PrReceiverWithQualityListResult

setComments(String) - Method in class bb.common.PurchaseOrderApprovalVO

setComments(String) - Method in class bb.common.PurchaseOrderCheckListResult

setComments(String) - Method in class bb.common.PurchaseOrderDocumentVO

setComments(String) - Method in class bb.common.PurchaseOrderListResult

setComments(String) - Method in class bb.common.PurchaseWorkSheetItemVO

setComments(String) - Method in class bb.common.QuoteDocumentVO

setComments(String) - Method in class bb.common.QuoteListResult

setComments(String) - Method in class bb.common.ReceiverItemAgent

setComments(String) - Method in class bb.common.ReceiverItemVO

setComments(String) - Method in class bb.common.ReceiverVO

setComments(String) - Method in class bb.common.ReceivingItemResult

setComments(String) - Method in class bb.common.RequestForQuoteCheckListResult

setComments(String) - Method in class bb.common.RequestForQuoteItemListResult

setComments(String) - Method in class bb.common.RequestForQuoteListResult

setComments(String) - Method in class bb.common.RequestForRMAVO

setComments(String) - Method in class bb.common.ReturnMaterialAuthorizationDocumentVO

setComments(String) - Method in class bb.common.ReturnToVendorCheckListResult

setComments(String) - Method in class bb.common.ReturnToVendorItemListResult

setComments(String) - Method in class bb.common.ReturnToVendorListResult

setComments(String) - Method in class bb.common.RfqMessageItemVO

setComments(String) - Method in class bb.common.RfqMessageListResult

setComments(String) - Method in class bb.common.RfqMessageVO

setComments(String) - Method in class bb.common.RMAListResult

setComments(String) - Method in class bb.common.RMAReceiverItemListResult

setComments(String) - Method in class bb.common.RMAReceiverItemVO

setComments(String) - Method in class bb.common.RMAReceiverListResult

setComments(String) - Method in class bb.common.RMAReceiverVO

setComments(String) - Method in class bb.common.RMAReviewVO

setComments(String) - Method in class bb.common.RRMAListResult

setComments(String) - Method in class bb.common.RTVApprovalVO

setComments(String) - Method in class bb.common.RtvShipperInfoVO

setComments(String) - Method in class bb.common.RtvShipperItemListResult

setComments(String) - Method in class bb.common.RtvShipperItemVO

setComments(String) - Method in class bb.common.RtvShipperListResult

setComments(String) - Method in class bb.common.RtvShipperVO

setComments(String) - Method in class bb.common.RunningAccountOrderItemResult

setComments(String) - Method in class bb.common.RunningAccountOrderVO

setComments(String) - Method in class bb.common.SalesCodeVO

setComments(String) - Method in class bb.common.SalesmanVO

setComments(String) - Method in class bb.common.SalesOrderDocumentVO

setComments(String) - Method in class bb.common.SalesOrderListResult

setComments(String) - Method in class bb.common.SerialNumberResult

setComments(String) - Method in class bb.common.SGCustomerCatalogVO

setComments(String) - Method in class bb.common.SGCustRequestForQuoteListResult

setComments(String) - Method in class bb.common.SGCustRequestForQuoteResult

setComments(String) - Method in class bb.common.SGCustRequestForQuoteVO

setComments(String) - Method in class bb.common.SGPartCatalogResult

setComments(String) - Method in class bb.common.SGSaleItemVO

setComments(String) - Method in class bb.common.ShipListInfoVO

setComments(String) - Method in class bb.common.ShipListItemVO

setComments(String) - Method in class bb.common.ShipListVO

setComments(String) - Method in class bb.common.ShipperListResult

setComments(String) - Method in class bb.common.ShippingItemResult

setComments(String) - Method in class bb.common.SmtpServerVO

setComments(String) - Method in class bb.common.StockTransactionAdjustmentResult

setComments(String) - Method in class bb.common.SwapOrderApprovalVO

setComments(String) - Method in class bb.common.SwapOrderListResult

setComments(String) - Method in class bb.common.SwapOrderVO

setComments(String) - Method in class bb.common.SwapReceiverListResult

setComments(String) - Method in class bb.common.SwapReceiverVO

setComments(String) - Method in class bb.common.SwapShipperListResult

setComments(String) - Method in class bb.common.SwapShipperVO

setComments(String) - Method in class bb.common.TaskVO

setComments(String) - Method in class bb.common.TermAgent

setComments(String) - Method in class bb.common.TermVO

setComments(String) - Method in class bb.common.TransferOrderApprovalVO

setComments(String) - Method in class bb.common.TransferOrderListResult

setComments(String) - Method in class bb.common.TransferOrderVO

setComments(String) - Method in class bb.common.User2UserAgent

setComments(String) - Method in class bb.common.VendorContractPriceItemVO

setComments(String) - Method in class bb.common.WarehouseVO

setComments(String) - Method in class bb.common.WoItemPickListItemResult

setComments(String) - Method in class bb.common.WOReceiverDetail

setComments(String) - Method in class bb.common.WorkInstructionApprovalVO

setComments(String) - Method in class bb.common.WorkInstructionDocumentVO

setComments(String) - Method in class bb.common.WorkOrderCheckListResult

setComments(String) - Method in class bb.common.WorkOrderDocumentVO

setComments(String) - Method in class bb.common.WorkOrderItemIssueVO

setComments(String) - Method in class bb.common.WorkOrderItemListResult

setComments(String) - Method in class bb.common.WorkOrderItemTimeDetailVO

setComments(String) - Method in class bb.common.WorkOrderListResult

setComments(String) - Method in class bb.common.WorkOrderWorkSheetItemVO

setCommission(BigDecimal) - Method in class bb.common.GeneralLedgerListResult

setCommission(BigDecimal) - Method in class bb.common.GeneralLedgerResult

setCommission(BigDecimal) - Method in class bb.common.GeneralLedgerVO

setCommission(BigDecimal) - Method in class bb.common.SalesmanVO

setCommissionRate(BigDecimal) - Method in class bb.common.ArCommissionListResult

setCommissionRate(BigDecimal) - Method in class bb.common.SalesCodeVO

setCommissionTotal(BigDecimal) - Method in class bb.common.ArCommissionTotalResult

setCommissionTotal(BigDecimal) - Method in class bb.common.ArSalesCodeTotalListResult

setCommitted(boolean) - Method in class bb.common.CycleCountListResult

setCommitted(boolean) - Method in class bb.common.CycleCountVO

setCommitted(boolean) - Method in class bb.common.PhysicalInventoryListResult

setCommitted(boolean) - Method in class bb.common.PhysicalInventoryVO

setCommittedBy(String) - Method in class bb.common.ChangeStdCostWorkSheetVO

setCommittedBy(String) - Method in class bb.common.RollUpBomStdCostWorkSheetVO

setCommittedDate(Date) - Method in class bb.common.ChangeStdCostWorkSheetVO

setCommittedDate(Date) - Method in class bb.common.RollUpBomStdCostWorkSheetVO

setCommodityCode(String) - Method in class bb.common.InventoryListResult

setCommodityCode(String) - Method in class bb.common.MrpReportAgent

setCommodityCode(String) - Method in class bb.common.PartBasicInfo

setCommodityCode(String) - Method in class bb.common.PartVO

setCommodityCode(String) - Method in class bb.common.PartWithOnhandsVO

setCommodityCode(String) - Method in class bb.common.PurchaseOrderItemVO

setCommodityCode(String) - Method in class bb.common.RunningAccountOrderItemVO

setCommodityCode(String) - Method in class bb.common.SalesOrderItemGroupByPartListResult

setCommodityCode(String) - Method in class bb.common.SalesOrderItemListResult

setCommodityCode(String) - Method in class bb.common.SalesOrderItemVO

setCommodityCode(String) - Method in class bb.common.SGPartCatalogResult

setCommodityCode(String) - Method in class bb.common.ToolVO

setCommodityCode(String) - Method in class bb.common.ToolWithOnhandsVO

setCompany(String) - Method in class bb.common.RequestForQuoteItemVO

setCompany(String) - Method in class bb.common.SalesmanVO

setCompanyAddressBookName(String) - Method in class bb.common.EmployeeCardVO

setCompanyHome(byte[]) - Method in class bb.common.CompanyVO

setCompanyHomes(String) - Method in class bb.common.SGDocPartVO

setCompanyHomesRev(String) - Method in class bb.common.SGDocPartVO

setCompanyId(String) - Method in class bb.common.CompanyVO

setCompanyId(String) - Method in class bb.common.EngineeringSharingItemPK

setCompanyId(String) - Method in class bb.common.EngineeringSharingVO

setCompanyName(String) - Method in class bb.common.CompanyVO

setCompanyName(String) - Method in class bb.common.CustomEmployeeWorkExperienceVO

setCompanyName(String) - Method in class bb.common.EmployeeWorkExperienceVO

setCompanyName(String) - Method in class bb.common.EngineeringSharingVO

setCompanyName(String) - Method in class bb.common.PartCertificateListResult

setCompanyName(String) - Method in class bb.common.PartCertificateVO

setCompanyName(String) - Method in class bb.common.SerialNumberItemResult

setCompanyName(String) - Method in class bb.common.SerialNumberResult

setCompanyName(String) - Method in class bb.common.SubcompanyVO

setCompanyUnit(String) - Method in class bb.common.AssetAmortizationExpenseAccountVO

setCompanyUnit(String) - Method in class bb.common.GLCheckRegisterResult

setCompanyUnitId(String) - Method in class bb.common.AccountBalanceListResult

setCompanyUnitId(String) - Method in class bb.common.AccountCreditVO

setCompanyUnitId(String) - Method in class bb.common.AccountDebitVO

setCompanyUnitId(String) - Method in class bb.common.AccountingInfoDocumentVO

setCompanyUnitId(String) - Method in class bb.common.AccountMonthPK

setCompanyUnitId(String) - Method in class bb.common.AccountPayableCheckVO

setCompanyUnitId(String) - Method in class bb.common.AccountPayableInfoWithPrepayResult

setCompanyUnitId(String) - Method in class bb.common.AccountReceivableInfoWithPrepayResult

setCompanyUnitId(String) - Method in class bb.common.AccountsPayableInfoVO

setCompanyUnitId(String) - Method in class bb.common.AccountsPayableVO

setCompanyUnitId(String) - Method in class bb.common.AccountsReceivableInfoVO

setCompanyUnitId(String) - Method in class bb.common.AccountsReceivableVO

setCompanyUnitId(String) - Method in class bb.common.AddPayableWithoutReceiverAgent

setCompanyUnitId(String) - Method in class bb.common.APItemListResult

setCompanyUnitId(String) - Method in class bb.common.APPrepayInfoResult

setCompanyUnitId(String) - Method in class bb.common.ApPrepayVO

setCompanyUnitId(String) - Method in class bb.common.ARPrepayInfoResult

setCompanyUnitId(String) - Method in class bb.common.ArPrepayVO

setCompanyUnitId(String) - Method in class bb.common.BizboxUserVO

setCompanyUnitId(String) - Method in class bb.common.ClosingStatementResult

setCompanyUnitId(String) - Method in class bb.common.CompanyUnitAccountPK

setCompanyUnitId(String) - Method in class bb.common.CRTVItemListResult

setCompanyUnitId(String) - Method in class bb.common.CustomerReturnToVendorVO

setCompanyUnitId(String) - Method in class bb.common.DepositSummaryResult

setCompanyUnitId(String) - Method in class bb.common.DisassembleWorkOrderIssueVO

setCompanyUnitId(String) - Method in class bb.common.DisassembleWorkOrderIssuingResult

setCompanyUnitId(String) - Method in class bb.common.DisassembleWorkOrderItemListResult

setCompanyUnitId(String) - Method in class bb.common.DisassembleWorkOrderVO

setCompanyUnitId(String) - Method in class bb.common.DWOIssueDetail

setCompanyUnitId(String) - Method in class bb.common.ExchangeAuditResult

setCompanyUnitId(String) - Method in class bb.common.ExpenseAccountVO

setCompanyUnitId(String) - Method in class bb.common.GeneralLedgerByDateListResult

setCompanyUnitId(String) - Method in class bb.common.GLItemVO

setCompanyUnitId(String) - Method in class bb.common.InvoiceItemListResult

setCompanyUnitId(String) - Method in class bb.common.LogMiscDocumentVO

setCompanyUnitId(String) - Method in class bb.common.MakeBillAndHoldInvoiceAgent

setCompanyUnitId(String) - Method in class bb.common.MakeCreditMemoAgent

setCompanyUnitId(String) - Method in class bb.common.MakeDebitMemoAgent

setCompanyUnitId(String) - Method in class bb.common.MakeInvoiceAgent

setCompanyUnitId(String) - Method in class bb.common.MiscDocAgent

setCompanyUnitId(String) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setCompanyUnitId(String) - Method in class bb.common.NonproductivePickingItemResult

setCompanyUnitId(String) - Method in class bb.common.NonproductivePickingTypeVO

setCompanyUnitId(String) - Method in class bb.common.NonproductivePickingVO

setCompanyUnitId(String) - Method in class bb.common.OnloanReceiverVO

setCompanyUnitId(String) - Method in class bb.common.OnloanShipperVO

setCompanyUnitId(String) - Method in class bb.common.OnLoanVO

setCompanyUnitId(String) - Method in class bb.common.PayableMethodVO

setCompanyUnitId(String) - Method in class bb.common.PaymentAgent

setCompanyUnitId(String) - Method in class bb.common.POReceiverItemListResult

setCompanyUnitId(String) - Method in class bb.common.PrepayPaymentAgent

setCompanyUnitId(String) - Method in class bb.common.ProfitLossStatementResult

setCompanyUnitId(String) - Method in class bb.common.PurchaseOrderItemListResult

setCompanyUnitId(String) - Method in class bb.common.PurchaseOrderVO

setCompanyUnitId(String) - Method in class bb.common.PurchaseWorkSheetVO

setCompanyUnitId(String) - Method in class bb.common.QuoteVO

setCompanyUnitId(String) - Method in class bb.common.ReceiverVO

setCompanyUnitId(String) - Method in class bb.common.ReceivingResult

setCompanyUnitId(String) - Method in class bb.common.RequestForQuoteVO

setCompanyUnitId(String) - Method in class bb.common.RequestForRMAVO

setCompanyUnitId(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setCompanyUnitId(String) - Method in class bb.common.ReturnToVendorByDateListResult

setCompanyUnitId(String) - Method in class bb.common.ReturnToVendorVO

setCompanyUnitId(String) - Method in class bb.common.RMAItemListResult

setCompanyUnitId(String) - Method in class bb.common.RMAReceiverVO

setCompanyUnitId(String) - Method in class bb.common.RRMAItemListResult

setCompanyUnitId(String) - Method in class bb.common.RtvShipperVO

setCompanyUnitId(String) - Method in class bb.common.SalesmanVO

setCompanyUnitId(String) - Method in class bb.common.SalesOrderItemListResult

setCompanyUnitId(String) - Method in class bb.common.SalesOrderVO

setCompanyUnitId(String) - Method in class bb.common.ShipperItemListResult

setCompanyUnitId(String) - Method in class bb.common.ShipperVO

setCompanyUnitId(String) - Method in class bb.common.TempArApAgingVO

setCompanyUnitId(String) - Method in class bb.common.WOReceiverDetail

setCompanyUnitId(String) - Method in class bb.common.WorkOrderItemListResult

setCompanyUnitId(String) - Method in class bb.common.WorkOrderItemPartDetailInWipVO

setCompanyUnitId(String) - Method in class bb.common.WorkOrderReceiverVO

setCompanyUnitId(String) - Method in class bb.common.WorkOrderVO

setCompanyUnitId(String) - Method in class bb.common.WorkOrderWorkSheetVO

setCompanyUnitOfAcc(String) - Method in class bb.common.MakeCheckAgent

setCompanyUnitOfAcc(String) - Method in class bb.common.MakePrepaymentCheckAgent

setCompanyUnitOfAmorExpenseAcc(String) - Method in class bb.common.AssetDepreciateVO

setCompanyUnitOfAmorExpenseAcc(String) - Method in class bb.common.AssetVO

setCompanyUnitOfCreditAcc(String) - Method in class bb.common.ARPrepaymentWireTransferAgent

setCompanyUnitOfCreditAcc(String) - Method in class bb.common.PostCheckAgent

setCompanyUnitOfCreditAcc(String) - Method in class bb.common.PrepaymentWireTransferAgent

setCompanyUnitOfDebitAcc(String) - Method in class bb.common.ARPrepaymentWireTransferAgent

setCompanyUnitOfDebitAcc(String) - Method in class bb.common.MakeAccountPayableAgent

setCompanyUnitOfDebitAcc(String) - Method in class bb.common.MakeCheckAgent

setCompanyUnitOfDebitAcc(String) - Method in class bb.common.PostCheckAgent

setCompanyUnitOfDebitAcc(String) - Method in class bb.common.PrepaymentWireTransferAgent

setCompanyUnitOfGaAp(String) - Method in class bb.common.AccountPayableCheckRunVO

setCompanyUnitOfGaAr(String) - Method in class bb.common.ARPaymentRunVO

setCompanyUnitOfGaChecking(String) - Method in class bb.common.AccountPayableCheckRunVO

setCompanyUnitOfGaChecking(String) - Method in class bb.common.AccountReceivablePaymentVO

setCompanyUnitOfGaChecking(String) - Method in class bb.common.ARPaymentRunVO

setCompanyUnitOfGlAcc(String) - Method in class bb.common.AssetVO

setCompanyUnitOfTransferFeeAcc(String) - Method in class bb.common.ARPrepaymentWireTransferAgent

setCompanyUnitOfTransferFeeAcc(String) - Method in class bb.common.PrepaymentWireTransferAgent

setCompanyUnitOfTransferFeeAcc(String) - Method in class bb.common.WireTransferAgent

setCompanyUnitOfWireFeeAcc(String) - Method in class bb.common.ARPaymentRunVO

setCompletedDate(Date) - Method in class bb.common.DisassembleWorkOrderItemListResult

setCompletedDate(Date) - Method in class bb.common.WorkOrderItemListResult

setCompletePercent(double) - Method in class bb.common.WorkOrderItemSeqWCLoadResult

setCompletePercent(double) - Method in class bb.common.WorkOrderWorkInstructionSequenceDateAgent

setComputeOrpSOWO(boolean) - Method in class bb.common.MrpReportAgent

setComputerId(String) - Method in class bb.common.MoneyInDrawResult

setComputerId(String) - Method in class bb.common.RunningAccountOrderVO

setCondition(String) - Method in class bb.common.AccountsPayableItemVO

setCondition(String) - Method in class bb.common.DisassembleWorkOrderIssueVO

setCondition(String) - Method in class bb.common.OnloanReceiverItemVO

setCondition(String) - Method in class bb.common.ReceiverItemAgent

setCondition(String) - Method in class bb.common.ReceiverItemVO

setCondition(String) - Method in class bb.common.RMAReceiverItemVO

setCondition(String) - Method in class bb.common.WorkOrderReceiverVO

setConditionAcknowledgedBy(String) - Method in class bb.common.CorrectiveActionRequestVO

setConditionDes(String) - Method in class bb.common.SGCustomerCatalogVO

setConditionDes(String) - Method in class bb.common.SGPartCatalogResult

setConditionDescription(String) - Method in class bb.common.CorrectiveActionRequestVO

setConditionDescription(String) - Method in class bb.common.PreventiveActionRequestVO

setConditionNotedBy(String) - Method in class bb.common.CorrectiveActionRequestVO

setConsiderInSTO(boolean) - Method in class bb.common.MrpReportAgent

setConsignedQty(BigDecimal) - Method in class bb.common.HistoricalInventoryVO

setConsignedQty(BigDecimal) - Method in class bb.common.PartInventoryVO

setConsignedQty(BigDecimal) - Method in class bb.common.ToolInventoryVO

setContact(String) - Method in class bb.common.AccountsReceivableInfoVO

setContact(String) - Method in class bb.common.AccountsReceivableVO

setContact(String) - Method in class bb.common.CSRAgent

setContact(String) - Method in class bb.common.CustomerReturnToVendorVO

setContact(String) - Method in class bb.common.DisassembleWorkOrderVO

setContact(String) - Method in class bb.common.EngineeringSharingVO

setContact(String) - Method in class bb.common.OnLoanVO

setContact(String) - Method in class bb.common.PfReceiverVO

setContact(String) - Method in class bb.common.PO2SOExchange

setContact(String) - Method in class bb.common.POStatisticsResult

setContact(String) - Method in class bb.common.ProformaInvoiceVO

setContact(String) - Method in class bb.common.PrReceiverListResult

setContact(String) - Method in class bb.common.PurchaseOrderVO

setContact(String) - Method in class bb.common.QuoteVO

setContact(String) - Method in class bb.common.RequestForQuoteVO

setContact(String) - Method in class bb.common.RequestForRMAVO

setContact(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setContact(String) - Method in class bb.common.ReturnToVendorVO

setContact(String) - Method in class bb.common.RunningAccountOrderItemResult

setContact(String) - Method in class bb.common.RunningAccountOrderVO

setContact(String) - Method in class bb.common.SalesOrderVO

setContact(String) - Method in class bb.common.SGCustomerServiceRequestVO

setContact(String) - Method in class bb.common.SO2SOAgent

setContact(String) - Method in class bb.common.SwapOrderListResult

setContact(String) - Method in class bb.common.SwapOrderVO

setContact(String) - Method in class bb.common.SwapReceiverListResult

setContact(String) - Method in class bb.common.SwapReceiverVO

setContact(String) - Method in class bb.common.SwapShipperListResult

setContact(String) - Method in class bb.common.SwapShipperVO

setContact(String) - Method in class bb.common.TransferOrderListResult

setContact(String) - Method in class bb.common.TransferOrderVO

setContact(String) - Method in class bb.common.TransferShipperVO

setContact(String) - Method in class bb.common.WorkOrderVO

setContactDate(Date) - Method in class bb.common.CustomerFeedbackVO

setContactName(String) - Method in class bb.common.SGCartCheckOutResult

setContactName(String) - Method in class bb.common.SGCustRequestForQuoteListResult

setContactName(String) - Method in class bb.common.SGCustRequestForQuoteResult

setContactName(String) - Method in class bb.common.SGCustRequestForQuoteVO

setContactName(String) - Method in class bb.common.SGQuoteAddressResult

setContactName(String) - Method in class bb.common.SGQuoteAddressVO

setContactPerson(String) - Method in class bb.common.SubcompanyVO

setContacts(Set<CustomerVendorContactVO>) - Method in class bb.common.AllStatementsListResult

setContacts(Set<CustomerVendorContactVO>) - Method in class bb.common.CustomerVendorAddressVO

setContacts(Set) - Method in class bb.common.ManufacturerAddressVO

setContainerNumber(String) - Method in class bb.common.PfReceiverVO

setContainerNumber(String) - Method in class bb.common.ProformaInvoiceVO

setContainerSealNumber(String) - Method in class bb.common.PfReceiverVO

setContainerSealNumber(String) - Method in class bb.common.ProformaInvoiceVO

setContainTax(boolean) - Method in class bb.common.SalesCodeVO

setContent(String) - Method in class bb.common.BB2BugNotice

setContent(String) - Method in class bb.common.EngineeringSharingImportLogVO

setContext(byte[]) - Method in class bb.common.BB2File

setContext(String) - Method in class bb.common.MessageAgent

setContext(String) - Method in class bb.common.MessageVO

setContract(String) - Method in class bb.common.PurchaseOrderContractResult

setContractAmount(BigDecimal) - Method in class bb.common.PurchaseOrderContractResult

setContractDate(Date) - Method in class bb.common.PurchaseOrderContractResult

setContractDate(Date) - Method in class bb.common.PurchaseOrderVO

setContractExpires(Date) - Method in class bb.common.EmployeeCardVO

setContractName(String) - Method in class bb.common.ContractPriceCustomerVO

setContractName(String) - Method in class bb.common.ContractPriceItemVO

setContractName(String) - Method in class bb.common.ContractPriceVO

setContractName(String) - Method in class bb.common.VendorContractPriceItemVO

setContractName(String) - Method in class bb.common.VendorContractPriceVendorVO

setContractName(String) - Method in class bb.common.VendorContractPriceVO

setContractNumber(String) - Method in class bb.common.ContractPriceCustomerPK

setContractNumber(String) - Method in class bb.common.ContractPriceItemPK

setContractNumber(String) - Method in class bb.common.ContractPriceVO

setContractNumber(String) - Method in class bb.common.CPItemFromQuoteResult

setContractNumber(String) - Method in class bb.common.POSurveyReportAgent

setContractNumber(String) - Method in class bb.common.POSurveyReportVO

setContractNumber(String) - Method in class bb.common.VendorContractPriceItemPK

setContractNumber(String) - Method in class bb.common.VendorContractPriceVendorPK

setContractNumber(String) - Method in class bb.common.VendorContractPriceVO

setContractPeriod(String) - Method in class bb.common.PurchaseOrderContractResult

setContractPrice(String) - Method in class bb.common.ImportContractPriceData

setControl(Integer) - Method in class bb.common.SerialNumberItemResult

setControl(Integer) - Method in class bb.common.SerialNumberResult

setControlNumber(long) - Method in class bb.common.LogMiscDocumentVO

setControlNumber(Long) - Method in class bb.common.MiscDocAgent

setControlNumber(Integer) - Method in class bb.common.PartCertificateListResult

setCopyMpn(boolean) - Method in class bb.common.SO2WOAgent

setCopyTo(String[]) - Method in class bb.common.BB2Notice

setCost(BigDecimal) - Method in class bb.common.AccountsPayableItemVO

setCost(BigDecimal) - Method in class bb.common.APItemListResult

setCost(BigDecimal) - Method in class bb.common.DisassembleWorkOrderIssueVO

setCost(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemPartDetailItemResult

setCost(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

setCost(BigDecimal) - Method in class bb.common.EmployeeLaborAgent

setCost(BigDecimal) - Method in class bb.common.InventoryListResult

setCost(BigDecimal) - Method in class bb.common.IssuedFromOrderItem

setCost(BigDecimal) - Method in class bb.common.IssueItemDetailAgent

setCost(BigDecimal) - Method in class bb.common.IssuingItemResult

setCost(BigDecimal) - Method in class bb.common.NonproductivePickingItemIssuedVO

setCost(BigDecimal) - Method in class bb.common.NonproductivePickingItemVO

setCost(BigDecimal) - Method in class bb.common.OnLoanItemVO

setCost(BigDecimal) - Method in class bb.common.PartInQAAgent

setCost(BigDecimal) - Method in class bb.common.PartInQAResult

setCost(BigDecimal) - Method in class bb.common.PartInQAVO

setCost(BigDecimal) - Method in class bb.common.PartIssuedVO

setCost(BigDecimal) - Method in class bb.common.PartReceivedVO

setCost(BigDecimal) - Method in class bb.common.partUsedInfoResult

setCost(BigDecimal) - Method in class bb.common.PullFromWorkOrderPartDetailAgent

setCost(BigDecimal) - Method in class bb.common.PuttoInQAAgent

setCost(BigDecimal) - Method in class bb.common.QuoteItemVO

setCost(BigDecimal) - Method in class bb.common.RebackInQAAgent

setCost(BigDecimal) - Method in class bb.common.ReceiverItemAgent

setCost(BigDecimal) - Method in class bb.common.ReceiverItemDetailAgent

setCost(BigDecimal) - Method in class bb.common.ReturnToVendorItemListResult

setCost(BigDecimal) - Method in class bb.common.SalesOrder12MonthMarginResult

setCost(BigDecimal) - Method in class bb.common.SalesOrderItemInfoVO

setCost(BigDecimal) - Method in class bb.common.SalesOrderItemVO

setCost(BigDecimal) - Method in class bb.common.ScrapReportVO

setCost(BigDecimal) - Method in class bb.common.ShipperItemDetailAgent

setCost(BigDecimal) - Method in class bb.common.WorkOrderItemIssuedTotalResult

setCost(BigDecimal) - Method in class bb.common.WorkOrderItemIssueVO

setCost(BigDecimal) - Method in class bb.common.WorkOrderItemPartDetail

setCost(BigDecimal) - Method in class bb.common.WorkOrderItemPartDetailInWipVO

setCost(BigDecimal) - Method in class bb.common.WorkOrderItemSetupItemAgent

setCost(BigDecimal) - Method in class bb.common.WorkOrderItemTimeDetailVO

setCost(BigDecimal) - Method in class bb.common.WorkOrderReceiverVO

setCostAlarm(boolean) - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

setCostAlarm(boolean) - Method in class bb.common.DisassembleWorkOrderItemVO

setCostAlarm(boolean) - Method in class bb.common.WOItemCostControlAgent

setCostAlarm(boolean) - Method in class bb.common.WorkOrderItemPartDetailResult

setCostAlarm(boolean) - Method in class bb.common.WorkOrderItemVO

setCostCenter(String) - Method in class bb.common.WorkCenterVO

setCostControlAgent(WOItemCostControlAgent) - Method in class bb.common.IssuingResult

setCostCurrency(String) - Method in class bb.common.EquipmentVO

setCostOfGoodsSold(ClosingStatementTotalResult) - Method in class bb.common.ClosingStatementResult

setCostOfGoodsSoldItems(List) - Method in class bb.common.ClosingStatementResult

setCostOfLabor(ClosingStatementTotalResult) - Method in class bb.common.ClosingStatementResult

setCostOfLaborItems(List) - Method in class bb.common.ClosingStatementResult

setCostOfSales(List) - Method in class bb.common.ProfitLossStatementResult

setCostPerUnit(BigDecimal) - Method in class bb.common.CRTVItemListResult

setCostPerUnit(BigDecimal) - Method in class bb.common.CustomerReturnToVendorItemVO

setCostPerUnit(BigDecimal) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setCostPerUnit(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemListResult

setCostPerUnit(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemVO

setCostPerUnit(BigDecimal) - Method in class bb.common.DWOIssueDetail

setCostPerUnit(BigDecimal) - Method in class bb.common.InventoryPartInOutDetailListResult

setCostPerUnit(BigDecimal) - Method in class bb.common.OnloanReceiverItemVO

setCostPerUnit(BigDecimal) - Method in class bb.common.PartOnhandCostVO

setCostPerUnit(BigDecimal) - Method in class bb.common.PoMessageItemVO

setCostPerUnit(BigDecimal) - Method in class bb.common.POReceiverItemListResult

setCostPerUnit(BigDecimal) - Method in class bb.common.PurchaseOrderItemListResult

setCostPerUnit(BigDecimal) - Method in class bb.common.PurchaseOrderItemVO

setCostPerUnit(BigDecimal) - Method in class bb.common.ReceiverItemVO

setCostPerUnit(BigDecimal) - Method in class bb.common.ReceivingItemResult

setCostPerUnit(BigDecimal) - Method in class bb.common.RequestForQuoteItemListResult

setCostPerUnit(BigDecimal) - Method in class bb.common.RequestForQuoteItemVO

setCostPerUnit(BigDecimal) - Method in class bb.common.RequestForRMAItemVO

setCostPerUnit(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setCostPerUnit(BigDecimal) - Method in class bb.common.ReturnToVendorByDateListResult

setCostPerUnit(BigDecimal) - Method in class bb.common.ReturnToVendorItemVO

setCostPerUnit(BigDecimal) - Method in class bb.common.RfqMessageItemVO

setCostPerUnit(BigDecimal) - Method in class bb.common.RMAItemListResult

setCostPerUnit(BigDecimal) - Method in class bb.common.RRMAItemListResult

setCostPerUnit(BigDecimal) - Method in class bb.common.RtvShipperItemListResult

setCostPerUnit(BigDecimal) - Method in class bb.common.WOReceiverDetail

setCostPerUnit(BigDecimal) - Method in class bb.common.WorkOrderItemListResult

setCostPerUnit(BigDecimal) - Method in class bb.common.WorkOrderItemVO

setCostPerUnitWithTax(BigDecimal) - Method in class bb.common.PurchaseOrderItemVO

setCostPerUnitWithTax(BigDecimal) - Method in class bb.common.SalesOrderItemVO

setCostUnit(BigDecimal) - Method in class bb.common.PO2SOExchangeItem

setCoUnitOfAccumulatedDeprAcc(String) - Method in class bb.common.AssetDepreciateVO

setCoUnitOfAccumulatedDeprAcc(String) - Method in class bb.common.AssetVO

setCount(Long) - Method in class bb.common.AccountInfoCenterItemResult

setCount(Integer) - Method in class bb.common.InventoryCycleItemResult

setCount(Integer) - Method in class bb.common.LogPartDwfVO

setCount(Integer) - Method in class bb.common.LogPartDwgVO

setCounted(Date) - Method in class bb.common.StockTransactionAdjustmentResult

setCountedBy(String) - Method in class bb.common.CycleCountListResult

setCountedBy(String) - Method in class bb.common.CycleCountVO

setCountedBy(String) - Method in class bb.common.InventoryAdjustmentVO

setCountedBy(String) - Method in class bb.common.PhysicalInventoryListResult

setCountedBy(String) - Method in class bb.common.PhysicalInventoryVO

setCountedBy(String) - Method in class bb.common.StockTransactionAdjustmentResult

setCountedDate(Date) - Method in class bb.common.CycleCountListResult

setCountedDate(Date) - Method in class bb.common.CycleCountVO

setCountedDate(Date) - Method in class bb.common.InventoryAdjustmentVO

setCountedDate(Date) - Method in class bb.common.PhysicalInventoryListResult

setCountedDate(Date) - Method in class bb.common.PhysicalInventoryVO

setCountry(String) - Method in class bb.common.AccountPayableCheckVO

setCountry(String) - Method in class bb.common.AccountReceivablePaymentVO

setCountry(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setCountry(String) - Method in class bb.common.CustomerVendorAddressVO

setCountry(String) - Method in class bb.common.CustomerVendorDescriptionVO

setCountry(String) - Method in class bb.common.EmployeeHomeVO

setCountry(String) - Method in class bb.common.IpAddressVO

setCountry(String) - Method in class bb.common.LockedCustomerAddressResult

setCountry(String) - Method in class bb.common.ManufacturerAddressInfoVO

setCountry(String) - Method in class bb.common.ManufacturerAddressVO

setCountry(String) - Method in class bb.common.ManufacturerDescriptionVO

setCountry(String) - Method in class bb.common.SalesmanVO

setCountry(String) - Method in class bb.common.SalesMarginListResult

setCountry(String) - Method in class bb.common.SalesOrderItemListResult

setCountry(String) - Method in class bb.common.SGCartCheckOutResult

setCountry(String) - Method in class bb.common.SGCustRequestForQuoteListResult

setCountry(String) - Method in class bb.common.SGCustRequestForQuoteResult

setCountry(String) - Method in class bb.common.SGQuoteAddressResult

setCountry(String) - Method in class bb.common.SGQuoteAddressVO

setCountryCode(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setCountryCode(String) - Method in class bb.common.CustomerVendorAddressVO

setCountryCode(String) - Method in class bb.common.ManufacturerAddressInfoVO

setCountryCode(String) - Method in class bb.common.ManufacturerAddressVO

setCountryCode(String) - Method in class bb.common.SGQuoteAddressVO

setCountryOrigin(String) - Method in class bb.common.AccountsReceivableItemVO

setCountryOrigin(String) - Method in class bb.common.PartBasicInfo

setCountryOrigin(String) - Method in class bb.common.PartVO

setCountyCode(String) - Method in class bb.common.PosZipCodeTaxVO

setCountyName(String) - Method in class bb.common.PosZipCodeTaxVO

setCountyTaxRate(BigDecimal) - Method in class bb.common.PosZipCodeTaxVO

setCpiCurrency(String) - Method in class bb.common.CPItemFromQuoteResult

setCpiDiscount(BigDecimal) - Method in class bb.common.CPItemFromQuoteResult

setCpiListPrice(BigDecimal) - Method in class bb.common.CPItemFromQuoteResult

setCreateBy(String) - Method in class bb.common.WorkFlowVO

setCreateDate(Date) - Method in class bb.common.ContractPriceVO

setCreateDate(Date) - Method in class bb.common.CustomerVendorAddressInfoVO

setCreateDate(Date) - Method in class bb.common.CustomerVendorAddressVO

setCreateDate(Date) - Method in class bb.common.CycleCountStatusVO

setCreateDate(Date) - Method in class bb.common.PhysicalInventoryStatusVO

setCreateDate(Date) - Method in class bb.common.ServerClientPropertyVO

setCreateDate(Date) - Method in class bb.common.SubcompanyVO

setCreatedBy(String) - Method in class bb.common.ChangeStdCostWorkSheetVO

setCreatedBy(String) - Method in class bb.common.RollUpBomStdCostWorkSheetVO

setCreatedDate(Date) - Method in class bb.common.AccountsChartMappingVO

setCreatedDate(Date) - Method in class bb.common.BillVO

setCreatedDate(Date) - Method in class bb.common.BillWithPartInfoResult

setCreatedDate(Date) - Method in class bb.common.ChangeStdCostWorkSheetVO

setCreatedDate(Date) - Method in class bb.common.PartExportInfo

setCreatedDate(Date) - Method in class bb.common.PartVO

setCreatedDate(Date) - Method in class bb.common.PartWithOnhandsVO

setCreatedDate(Date) - Method in class bb.common.RollUpBomStdCostWorkSheetVO

setCreatedDate(Date) - Method in class bb.common.ToolVO

setCreatedDate(Date) - Method in class bb.common.ToolWithOnhandsVO

setCreatedGL(boolean) - Method in class bb.common.DisassembleWorkOrderItemVO

setCreateTime(Date) - Method in class bb.common.BizboxUserListResult

setCreateTime(Date) - Method in class bb.common.BizboxUserVO

setCreateTime(Date) - Method in class bb.common.QualityGroupVO

setCreator(String) - Method in class bb.common.CycleCountStatusVO

setCreator(String) - Method in class bb.common.PhysicalInventoryStatusVO

setCredit(BigDecimal) - Method in class bb.common.AccountBalanceListResult

setCredit(BigDecimal) - Method in class bb.common.AccountCreditVO

setCredit(BigDecimal) - Method in class bb.common.ClosingStatementItemResult

setCredit(BigDecimal) - Method in class bb.common.ExchangeAuditItemResult

setCredit(BigDecimal) - Method in class bb.common.GeneralLedgerByDateListResult

setCredit(BigDecimal) - Method in class bb.common.GeneralLedgerEntry

setCredit(BigDecimal) - Method in class bb.common.GLDebitCreditListResult

setCredit(BigDecimal) - Method in class bb.common.GLItemVO

setCredit(String) - Method in class bb.common.NcrScrapAgent

setCreditAccount(String) - Method in class bb.common.AccountsReceivableInfoVO

setCreditAccount(String) - Method in class bb.common.AccountsReceivableVO

setCreditAccount(String) - Method in class bb.common.ARPrepaymentWireTransferAgent

setCreditAccount(String) - Method in class bb.common.InvoiceItemListResult

setCreditAccount(String) - Method in class bb.common.JounalEntryListResult

setCreditAccount(String) - Method in class bb.common.MakeCreditMemoAgent

setCreditAccount(String) - Method in class bb.common.PostCheckAgent

setCreditAccount(String) - Method in class bb.common.PrepaymentWireTransferAgent

setCreditAccount(String) - Method in class bb.common.QuoteVO

setCreditAccount(String) - Method in class bb.common.SalesOrderVO

setCreditAccount(String) - Method in class bb.common.ScrapReportVO

setCreditAccount(String) - Method in class bb.common.WireTransferAgent

setCreditAccountBalance(Map<CompanyUnitAccountPK, BigDecimal>) - Method in class bb.common.AccountBalanceAgent

setCreditAccounts(String) - Method in class bb.common.GeneralLedgerCategoryVO

setCreditAmount(BigDecimal) - Method in class bb.common.AccountBalanceResult

setCreditAmount(BigDecimal) - Method in class bb.common.JounalEntryListResult

setCreditBalance(BigDecimal) - Method in class bb.common.MonthBalanceResult

setCreditBeginPeriodBalance(BigDecimal) - Method in class bb.common.AccountBalanceResult

setCreditCardNumber(String) - Method in class bb.common.RunningAccountOrderVO

setCreditDebit(BigDecimal) - Method in class bb.common.AccountsCreditDebitListResult

setCreditEndingBalance(BigDecimal) - Method in class bb.common.CurrentBalanceResult

setCreditEndPeriodBalance(BigDecimal) - Method in class bb.common.AccountBalanceResult

setCreditMemoComments(String) - Method in class bb.common.MakeCreditMemoAgent

setCreditMemoNotes(String) - Method in class bb.common.MakeCreditMemoAgent

setCreditMemoNumber(String) - Method in class bb.common.RMAReceiverListResult

setCreditMemoNumber(String) - Method in class bb.common.RMAReceiverVO

setCreditMonthTotal(BigDecimal) - Method in class bb.common.CurrentBalanceResult

setCreditOrDebit(String) - Method in class bb.common.BalanceSheetSideBySideItemResult

setCreditOrDebit(String) - Method in class bb.common.ClosingStatementItemResult

setCreditOrDebit(String) - Method in class bb.common.ExchangeAuditItemResult

setCredits(List<AccountsCreditDebitListResult>) - Method in class bb.common.DebitsCreditsResult

setCreditStartingBalance(BigDecimal) - Method in class bb.common.CurrentBalanceResult

setCreditText(String) - Method in class bb.common.NcrScrapAgent

setCrfqDate(Date) - Method in class bb.common.SGCustRequestForQuoteListResult

setCrfqDate(Date) - Method in class bb.common.SGCustRequestForQuoteVO

setCrfqItemNumber(String) - Method in class bb.common.SGCustRequestForQuoteItemPK

setCrfqNumber(String) - Method in class bb.common.SGCustRequestForQuoteItemPK

setCrfqNumber(String) - Method in class bb.common.SGCustRequestForQuoteListResult

setCrfqNumber(String) - Method in class bb.common.SGCustRequestForQuoteResult

setCrfqNumber(String) - Method in class bb.common.SGCustRequestForQuoteVO

setCriticalityCategory(String) - Method in class bb.common.PartTraceableResult

setCriticalityCategory(String) - Method in class bb.common.TraceableCategoriesVO

setCriticalLevel(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setCriticalLevel(String) - Method in class bb.common.CustomerVendorAddressVO

setCriticalLevel(String) - Method in class bb.common.LockedCustomerAddressResult

setCriticalLevel(String) - Method in class bb.common.VendorCriticalLevelVO

setCrtvDate(Date) - Method in class bb.common.CRTVItemListResult

setCrtvDate(Date) - Method in class bb.common.CRTVListResult

setCrtvDate(Date) - Method in class bb.common.CustomerReturnToVendorVO

setCrtvItem(Set<CustomerReturnToVendorItemVO>) - Method in class bb.common.CustomerReturnToVendorVO

setCrtvItemComments(String) - Method in class bb.common.CustomerReturnToVendorItemVO

setCrtvItemNumber(String) - Method in class bb.common.CRTVItemListResult

setCrtvItemNumber(String) - Method in class bb.common.CustomerReturnToVendorItemPK

setCrtvItemPrivateNotes(String) - Method in class bb.common.CustomerReturnToVendorItemVO

setCrtvNumber(String) - Method in class bb.common.CRTVItemListResult

setCrtvNumber(String) - Method in class bb.common.CRTVListResult

setCrtvNumber(String) - Method in class bb.common.CustomerReturnToVendorItemPK

setCrtvNumber(String) - Method in class bb.common.CustomerReturnToVendorVO

setCrtvNumber(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setCsEmail(String) - Method in class bb.common.CustomerServiceIncidentVO

setCsiNumber(String) - Method in class bb.common.CustomerServiceIncidentItemListResult

setCsiNumber(String) - Method in class bb.common.CustomerServiceIncidentListResult

setCsiNumber(String) - Method in class bb.common.SGCustomerServiceRequestVO

setCsrDate(Date) - Method in class bb.common.SGCustomerServiceRequestVO

setCsrNumber(String) - Method in class bb.common.SGCustomerServiceRequestVO

setCsrReceiverEmail(String) - Method in class bb.common.CompanyVO

setCurrency(String) - Method in class bb.common.AccountAgingTotalResult

setCurrency(String) - Method in class bb.common.AccountAuditAgent

setCurrency(String) - Method in class bb.common.AccountCreditVO

setCurrency(String) - Method in class bb.common.AccountDebitVO

setCurrency(String) - Method in class bb.common.AccountInfoCenterItemResult

setCurrency(String) - Method in class bb.common.AccountingTotalMoneyResult

setCurrency(String) - Method in class bb.common.AccountPayableCheckRunItemVO

setCurrency(String) - Method in class bb.common.AccountPayableCheckVO

setCurrency(String) - Method in class bb.common.AccountReceivablePaymentVO

setCurrency(String) - Method in class bb.common.AccountsPayableInfoVO

setCurrency(String) - Method in class bb.common.AccountsPayableVO

setCurrency(String) - Method in class bb.common.AccountsReceivableInfoVO

setCurrency(String) - Method in class bb.common.AccountsReceivableVO

setCurrency(String) - Method in class bb.common.AddressAccountInfo

setCurrency(String) - Method in class bb.common.APAuditListResult

setCurrency(String) - Method in class bb.common.ApCheckRunItemAgent

setCurrency(String) - Method in class bb.common.ApCheckRunListResult

setCurrency(String) - Method in class bb.common.ApPrepayVO

setCurrency(String) - Method in class bb.common.APTaxForZipcodeListResult

setCurrency(String) - Method in class bb.common.ARAllStatementsListResult

setCurrency(String) - Method in class bb.common.ARAuditListResult

setCurrency(String) - Method in class bb.common.ArCommissionListResult

setCurrency(String) - Method in class bb.common.ArCommissionTotalResult

setCurrency(String) - Method in class bb.common.ARPaymentRunItemVO

setCurrency(String) - Method in class bb.common.ARPaymentRunListResult

setCurrency(String) - Method in class bb.common.ARPrepayAllStatementsListResult

setCurrency(String) - Method in class bb.common.ArPrepayVO

setCurrency(String) - Method in class bb.common.ARTaxForZipcodeListResult

setCurrency(String) - Method in class bb.common.BB2PartByDateResult

setCurrency(String) - Method in class bb.common.BB2tripleString

setCurrency(String) - Method in class bb.common.CompanyVO

setCurrency(String) - Method in class bb.common.ContractPriceVO

setCurrency(String) - Method in class bb.common.CurrencyExchangePK

setCurrency(String) - Method in class bb.common.CurrencyVO

setCurrency(String) - Method in class bb.common.CustomerReturnToVendorVO

setCurrency(String) - Method in class bb.common.CustomerStatementResult

setCurrency(String) - Method in class bb.common.CustomerStatementTotalResult

setCurrency(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setCurrency(String) - Method in class bb.common.CustomerVendorAddressTotalInfo

setCurrency(String) - Method in class bb.common.CustomerVendorAddressVO

setCurrency(String) - Method in class bb.common.DebitsCreditsResult

setCurrency(String) - Method in class bb.common.DepreciateMonthlyReport

setCurrency(String) - Method in class bb.common.DisassembleWorkOrderApprovalVO

setCurrency(String) - Method in class bb.common.DisassembleWorkOrderItemListResult

setCurrency(String) - Method in class bb.common.DisassembleWorkOrderVO

setCurrency(String) - Method in class bb.common.DuePATotalByVendorResult

setCurrency(String) - Method in class bb.common.ExchangeAuditItemResult

setCurrency(String) - Method in class bb.common.ExpenseItemVO

setCurrency(String) - Method in class bb.common.GeneralLedgerListResult

setCurrency(String) - Method in class bb.common.GeneralLedgerVO

setCurrency(String) - Method in class bb.common.GLItemVO

setCurrency(String) - Method in class bb.common.InvoiceItemListResult

setCurrency(String) - Method in class bb.common.JounalEntryListResult

setCurrency(String) - Method in class bb.common.MakeAccountPayableAgent

setCurrency(String) - Method in class bb.common.MakeBillAndHoldInvoiceAgent

setCurrency(String) - Method in class bb.common.MakeCreditMemoAgent

setCurrency(String) - Method in class bb.common.MakeDebitMemoAgent

setCurrency(String) - Method in class bb.common.MakeInvoiceAgent

setCurrency(String) - Method in class bb.common.Money

setCurrency(String) - Method in class bb.common.NonproductivePickingApproveVO

setCurrency(String) - Method in class bb.common.OnloanReceiverVO

setCurrency(String) - Method in class bb.common.OnloanReviewVO

setCurrency(String) - Method in class bb.common.OnloanShipperVO

setCurrency(String) - Method in class bb.common.OnLoanVO

setCurrency(String) - Method in class bb.common.PartIssuedListResult

setCurrency(String) - Method in class bb.common.PartReceivedListResult

setCurrency(String) - Method in class bb.common.PfReceiverVO

setCurrency(String) - Method in class bb.common.PO2SOExchange

setCurrency(String) - Method in class bb.common.POReceiverItemListResult

setCurrency(String) - Method in class bb.common.POStatisticsResult

setCurrency(String) - Method in class bb.common.PrepayAgent

setCurrency(String) - Method in class bb.common.ProformaInvoiceVO

setCurrency(String) - Method in class bb.common.PurchaseOnTimeResult

setCurrency(String) - Method in class bb.common.PurchaseOrderApprovalVO

setCurrency(String) - Method in class bb.common.PurchaseOrderCheckListResult

setCurrency(String) - Method in class bb.common.PurchaseOrderItemListResult

setCurrency(String) - Method in class bb.common.PurchaseOrderOnTimeResult

setCurrency(String) - Method in class bb.common.PurchaseOrderVO

setCurrency(String) - Method in class bb.common.QuoteItemListResult

setCurrency(String) - Method in class bb.common.QuoteVO

setCurrency(String) - Method in class bb.common.ReceiverInfoVO

setCurrency(String) - Method in class bb.common.ReceiverVO

setCurrency(String) - Method in class bb.common.RequestForQuoteCheckListResult

setCurrency(String) - Method in class bb.common.RequestForQuoteVO

setCurrency(String) - Method in class bb.common.RequestForRMAVO

setCurrency(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setCurrency(String) - Method in class bb.common.ReturnToVendorByDateListResult

setCurrency(String) - Method in class bb.common.ReturnToVendorCheckListResult

setCurrency(String) - Method in class bb.common.ReturnToVendorVO

setCurrency(String) - Method in class bb.common.RMAReceiverVO

setCurrency(String) - Method in class bb.common.RMAReviewVO

setCurrency(String) - Method in class bb.common.RTVApprovalVO

setCurrency(String) - Method in class bb.common.RtvShipperInfoVO

setCurrency(String) - Method in class bb.common.RtvShipperVO

setCurrency(String) - Method in class bb.common.RunningAccountOrderVO

setCurrency(String) - Method in class bb.common.SalesInfoCenterResult

setCurrency(String) - Method in class bb.common.SalesMarginListResult

setCurrency(String) - Method in class bb.common.SalesOnTimeResult

setCurrency(String) - Method in class bb.common.SalesOrder12MonthMarginResult

setCurrency(String) - Method in class bb.common.SalesOrderCheckListResult

setCurrency(String) - Method in class bb.common.SalesOrderItemCostResult

setCurrency(String) - Method in class bb.common.SalesOrderItemCustomerTotalResult

setCurrency(String) - Method in class bb.common.SalesOrderItemListResult

setCurrency(String) - Method in class bb.common.SalesOrderListResult

setCurrency(String) - Method in class bb.common.SalesOrderOnTimeResult

setCurrency(String) - Method in class bb.common.SalesOrderReviewVO

setCurrency(String) - Method in class bb.common.SalesOrderVO

setCurrency(String) - Method in class bb.common.SGCompanyVO

setCurrency(String) - Method in class bb.common.SGCustRequestForQuoteListResult

setCurrency(String) - Method in class bb.common.SGCustRequestForQuoteResult

setCurrency(String) - Method in class bb.common.SGCustRequestForQuoteVO

setCurrency(String) - Method in class bb.common.SGQuoteAddressVO

setCurrency(String) - Method in class bb.common.ShipperInfoVO

setCurrency(String) - Method in class bb.common.ShipperItemListResult

setCurrency(String) - Method in class bb.common.ShipperVO

setCurrency(String) - Method in class bb.common.TempArApAgingVO

setCurrency(String) - Method in class bb.common.TempReceiverWithoutAPInfo

setCurrency(String) - Method in class bb.common.TotalByDateResult

setCurrency(String) - Method in class bb.common.TransferOrderListResult

setCurrency(String) - Method in class bb.common.TransferOrderVO

setCurrency(String) - Method in class bb.common.TransferReceiverListResult

setCurrency(String) - Method in class bb.common.TransferReceiverVO

setCurrency(String) - Method in class bb.common.TransferShipperListResult

setCurrency(String) - Method in class bb.common.TransferShipperVO

setCurrency(String) - Method in class bb.common.VendorContractPriceVO

setCurrency(String) - Method in class bb.common.VendorQtyPriceVO

setCurrency(String) - Method in class bb.common.WireTransferAgent

setCurrency(String) - Method in class bb.common.WorkOrderApprovalVO

setCurrency(String) - Method in class bb.common.WorkOrderCheckListResult

setCurrency(String) - Method in class bb.common.WorkOrderItemInWipListResult

setCurrency(String) - Method in class bb.common.WorkOrderItemListResult

setCurrency(String) - Method in class bb.common.WorkOrderOnTimeResult

setCurrency(String) - Method in class bb.common.WorkOrderVO

setCurrent(BigDecimal) - Method in class bb.common.AccountAgingTotalResult

setCurrent(BigDecimal) - Method in class bb.common.CustomerStatementTotalResult

setCurrentAssets(List) - Method in class bb.common.BalanceSheetSideBySideResult

setCurrentAssets(List) - Method in class bb.common.ClosingStatementResult

setCurrentCost(BigDecimal) - Method in class bb.common.CustomerReturnToVendorItemVO

setCurrentCost(BigDecimal) - Method in class bb.common.RequestForRMAItemVO

setCurrentCost(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setCurrentCost(BigDecimal) - Method in class bb.common.RMAReceiverItemVO

setCurrentLiabilities(List) - Method in class bb.common.ClosingStatementResult

setCurrentLiability(List) - Method in class bb.common.BalanceSheetSideBySideResult

setCurrentMonthDepreciate(BigDecimal) - Method in class bb.common.AssetDepreciateVO

setCurrentMonthDepreciate(BigDecimal) - Method in class bb.common.AssetReportSumResult

setCurrentMonthInvoicedAccount(BigDecimal) - Method in class bb.common.SalesInfoCenterResult

setCurrentMonthInvoiceGrossMargin(BigDecimal) - Method in class bb.common.SalesInfoCenterResult

setCurrentMonthPoAddedCount(Integer) - Method in class bb.common.PurchasingInfoCenterResult

setCurrentMonthPoiAddedCount(Integer) - Method in class bb.common.PurchasingInfoCenterResult

setCurrentMonthPurchaseAccount(BigDecimal) - Method in class bb.common.PurchasingInfoCenterResult

setCurrentMonthReceiverAccount(BigDecimal) - Method in class bb.common.PurchasingInfoCenterResult

setCurrentMonthReceiverCount(Integer) - Method in class bb.common.PurchasingInfoCenterResult

setCurrentMonthReceiverCount(Integer) - Method in class bb.common.WareHousingInfoCenterResult

setCurrentMonthReceiverItemCount(Integer) - Method in class bb.common.PurchasingInfoCenterResult

setCurrentMonthReceiverItemCount(Integer) - Method in class bb.common.WareHousingInfoCenterResult

setCurrentMonthRejectQty(BigDecimal) - Method in class bb.common.QualityInfoCenterResult

setCurrentMonthSalesItemCount(Integer) - Method in class bb.common.SalesInfoCenterResult

setCurrentMonthSalesOrderAccount(BigDecimal) - Method in class bb.common.SalesInfoCenterResult

setCurrentMonthSalesOrderCount(Integer) - Method in class bb.common.SalesInfoCenterResult

setCurrentMonthShipperCount(Integer) - Method in class bb.common.WareHousingInfoCenterResult

setCurrentMonthShipperItemCount(Integer) - Method in class bb.common.WareHousingInfoCenterResult

setCurrentOnhand(BigDecimal) - Method in class bb.common.PartIssuedListResult

setCurrentOnhand(BigDecimal) - Method in class bb.common.PartReceivedListResult

setCurrentPeriod(BigDecimal) - Method in class bb.common.ProfitLossStatementItemResult

setCurrentPeriodFrom(Date) - Method in class bb.common.AccountingInfoDocumentVO

setCurrentPeriodFrom(Date) - Method in class bb.common.MiscDocAgent

setCurrentPeriodFrom(Date) - Method in class bb.common.ProfitLossStatementResult

setCurrentPeriodTo(Date) - Method in class bb.common.AccountingInfoDocumentVO

setCurrentPeriodTo(Date) - Method in class bb.common.MiscDocAgent

setCurrentPeriodTo(Date) - Method in class bb.common.ProfitLossStatementResult

setCurrentPosition(String) - Method in class bb.common.CustomEmployeeVO

setCurrentPositionLevel(String) - Method in class bb.common.CustomEmployeeVO

setCurrentRetainedEarning(String) - Method in class bb.common.AccountingSettingsVO

setCurrentRunHours(BigDecimal) - Method in class bb.common.EquipmentListResult

setCurrentRunHours(BigDecimal) - Method in class bb.common.EquipmentVO

setCurrentStdCost(BigDecimal) - Method in class bb.common.CustomerReturnToVendorItemVO

setCurrentStdCost(BigDecimal) - Method in class bb.common.RequestForRMAItemVO

setCurrentStdCost(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setCurrentStdCost(BigDecimal) - Method in class bb.common.RMAReceiverItemVO

setCurrentYearDepreciateTotal(BigDecimal) - Method in class bb.common.AssetDepreciateDetailReport

setCurrentYearDepreciationAccm(BigDecimal) - Method in class bb.common.AssetDepreciateDetailReport

setCurrentYearMonth(String) - Method in class bb.common.AccountingSettingsVO

setCusInvoice(String) - Method in class bb.common.OnloanReceiverVO

setCusInvoiceDate(Date) - Method in class bb.common.OnloanReceiverVO

setCusPackage(String) - Method in class bb.common.OnloanReceiverVO

setCusShipDate(Date) - Method in class bb.common.OnloanReceiverVO

setCustID(String) - Method in class bb.common.ARAuditListResult

setCustID(String) - Method in class bb.common.CSRAgent

setCustID(String) - Method in class bb.common.OnloanReceiverItemListResult

setCustID(String) - Method in class bb.common.OnloanReceiverListResult

setCustID(String) - Method in class bb.common.OnloanReceiverVO

setCustID(String) - Method in class bb.common.RMAReceiverItemListResult

setCustID(String) - Method in class bb.common.RMAReceiverListResult

setCustID(String) - Method in class bb.common.RMAReceiverVO

setCustID(String) - Method in class bb.common.SalesOrderShipDateListResult

setCustID(String) - Method in class bb.common.SgClientProgramUserVO

setCustID(String) - Method in class bb.common.SGCustomerServiceRequestVO

setCustID(String) - Method in class bb.common.SGCustRequestForQuoteListResult

setCustID(String) - Method in class bb.common.SGCustRequestForQuoteResult

setCustID(String) - Method in class bb.common.SGCustRequestForQuoteVO

setCustID(String) - Method in class bb.common.SGPartCatalogResult

setCustID(String) - Method in class bb.common.SGSaleItemVO

setCustId(String) - Method in class bb.common.ShipListItemVOResult

setCustomDepartment(CustomDepartmentVO) - Method in class bb.common.CustomEmployeeVO

setCustomer(String) - Method in class bb.common.SGCustomerCatalogPK

setCustomerAccount(String) - Method in class bb.common.CustomerVendorAddressVO

setCustomerAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.AccountPayableCheckRunItemVO

setCustomerAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.AccountsPayableInfoVO

setCustomerAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.AccountsPayableVO

setCustomerAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.AccountsReceivableInfoVO

setCustomerAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.AccountsReceivableVO

setCustomerAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.ARPaymentRunItemVO

setCustomerAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.ArPrepayVO

setCustomerAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.CustomerFeedbackVO

setCustomerAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.CustomerReturnToVendorVO

setCustomerAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.CustomerServiceIncidentVO

setCustomerAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.OnloanReceiverVO

setCustomerAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.OnloanShipperVO

setCustomerAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.OnLoanVO

setCustomerAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.ProformaInvoiceVO

setCustomerAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.QuoteVO

setCustomerAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.RequestForRMAVO

setCustomerAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.ReturnMaterialAuthorizationVO

setCustomerAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.RMAReceiverVO

setCustomerAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.RunningAccountOrderVO

setCustomerAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.SalesOrderVO

setCustomerAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.SgClientProgramUserVO

setCustomerAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.ShipperVO

setCustomerAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.VendorGroupUserVO

setCustomerCarrier(String) - Method in class bb.common.CustomerVendorAddressVO

setCustomerCarrierAccount(String) - Method in class bb.common.CustomerVendorAddressVO

setCustomerComments(String) - Method in class bb.common.CustomerVendorAddressVO

setCustomerCreditLimit(BigDecimal) - Method in class bb.common.CustomerStatementTotalResult

setCustomerCreditLimit(BigDecimal) - Method in class bb.common.CustomerVendorAddressVO

setCustomerDepositBank(String) - Method in class bb.common.CustomerVendorAddressVO

setCustomerDiscount(BigDecimal) - Method in class bb.common.CustomerVendorAddressVO

setCustomerDm(String) - Method in class bb.common.RMAReceiverVO

setCustomerDmDate(Date) - Method in class bb.common.RMAReceiverVO

setCustomerDmTotal(BigDecimal) - Method in class bb.common.RMAReceiverVO

setCustomerEmail(String) - Method in class bb.common.AccountsReceivableInfoVO

setCustomerEmail(String) - Method in class bb.common.AccountsReceivableVO

setCustomerEmail(String) - Method in class bb.common.CustomerServiceIncidentVO

setCustomerEmail(String) - Method in class bb.common.OnLoanVO

setCustomerEmail(String) - Method in class bb.common.ProformaInvoiceVO

setCustomerEmail(String) - Method in class bb.common.SalesOrderVO

setCustomerFlag(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setCustomerFlag(String) - Method in class bb.common.CustomerVendorAddressVO

setCustomerFlag(String) - Method in class bb.common.LockedCustomerAddressResult

setCustomerHold(boolean) - Method in class bb.common.CustomerStatementTotalResult

setCustomerHold(boolean) - Method in class bb.common.CustomerVendorAddressInfoVO

setCustomerHold(boolean) - Method in class bb.common.CustomerVendorAddressVO

setCustomerId(String) - Method in class bb.common.AccountReceivableInfoWithPrepayResult

setCustomerId(String) - Method in class bb.common.AccountReceivablePaymentVO

setCustomerId(String) - Method in class bb.common.AccountsReceivableInfoVO

setCustomerId(String) - Method in class bb.common.AccountsReceivableVO

setCustomerId(String) - Method in class bb.common.AllStatementsListResult

setCustomerId(String) - Method in class bb.common.ARAllStatementsListResult

setCustomerId(String) - Method in class bb.common.ArCommissionListResult

setCustomerId(String) - Method in class bb.common.ARPaymentRunItemVO

setCustomerId(String) - Method in class bb.common.ARPaymentRunListResult

setCustomerId(String) - Method in class bb.common.ARPrepayAllStatementsListResult

setCustomerId(String) - Method in class bb.common.ARPrepayInfoResult

setCustomerId(String) - Method in class bb.common.ArPrepayVO

setCustomerId(String) - Method in class bb.common.ARTaxForZipcodeListResult

setCustomerId(String) - Method in class bb.common.BB2PartInSipItemResult

setCustomerId(String) - Method in class bb.common.BB2PartInSipOfSoItemResult

setCustomerId(String) - Method in class bb.common.BB2PartOnLoanItemResult

setCustomerID(String) - Method in class bb.common.CPItemFromQuoteResult

setCustomerId(String) - Method in class bb.common.CRTVItemListResult

setCustomerId(String) - Method in class bb.common.CRTVListResult

setCustomerId(String) - Method in class bb.common.CustomerFeedbackVO

setCustomerId(String) - Method in class bb.common.CustomerReturnToVendorVO

setCustomerId(String) - Method in class bb.common.CustomerServiceIncidentItemListResult

setCustomerId(String) - Method in class bb.common.CustomerServiceIncidentListResult

setCustomerId(String) - Method in class bb.common.CustomerServiceIncidentVO

setCustomerId(String) - Method in class bb.common.CustomerStatementResult

setCustomerId(String) - Method in class bb.common.CustomerStatementTotalResult

setCustomerId(String) - Method in class bb.common.DepositSummaryResult

setCustomerId(String) - Method in class bb.common.GeneralLedgerListResult

setCustomerId(String) - Method in class bb.common.GeneralLedgerVO

setCustomerId(String) - Method in class bb.common.InvoiceItemListResult

setCustomerId(String) - Method in class bb.common.LnShipperItemListResult

setCustomerId(String) - Method in class bb.common.LnShipperListResult

setCustomerId(String) - Method in class bb.common.MonthSoOrArByCustomerResult

setCustomerId(String) - Method in class bb.common.MrpReportAgent

setCustomerId(String) - Method in class bb.common.OnLoanItemListResult

setCustomerId(String) - Method in class bb.common.OnLoanListResult

setCustomerId(String) - Method in class bb.common.OnloanShipperVO

setCustomerId(String) - Method in class bb.common.OnLoanVO

setCustomerId(String) - Method in class bb.common.PackingBoxItemListResult

setCustomerId(String) - Method in class bb.common.PackingBoxItemVO

setCustomerId(String) - Method in class bb.common.PackingBoxVO

setCustomerID(String) - Method in class bb.common.PointOfSaleVO

setCustomerId(String) - Method in class bb.common.PostCheckAgent

setCustomerId(String) - Method in class bb.common.ProformaInvoiceItemListResult

setCustomerId(String) - Method in class bb.common.ProformaInvoiceItemVO

setCustomerId(String) - Method in class bb.common.ProformaInvoiceListResult

setCustomerId(String) - Method in class bb.common.ProformaInvoiceVO

setCustomerId(String) - Method in class bb.common.Quote2QuoteAgent

setCustomerId(String) - Method in class bb.common.QuoteItemListResult

setCustomerId(String) - Method in class bb.common.QuoteListResult

setCustomerId(String) - Method in class bb.common.QuoteVO

setCustomerId(String) - Method in class bb.common.RequestForRMAVO

setCustomerId(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setCustomerId(String) - Method in class bb.common.RMAItemListResult

setCustomerId(String) - Method in class bb.common.RMAListResult

setCustomerId(String) - Method in class bb.common.RMAReceiverResult

setCustomerId(String) - Method in class bb.common.RRMAItemListResult

setCustomerId(String) - Method in class bb.common.RRMAListResult

setCustomerId(String) - Method in class bb.common.RunningAccountOrderItemResult

setCustomerId(String) - Method in class bb.common.RunningAccountOrderVO

setCustomerId(String) - Method in class bb.common.RunTaxPaymentResult

setCustomerId(String) - Method in class bb.common.SalesMarginListResult

setCustomerId(String) - Method in class bb.common.SalesOrderCheckListResult

setCustomerId(String) - Method in class bb.common.SalesOrderItemCustomerTotalResult

setCustomerId(String) - Method in class bb.common.SalesOrderItemListResult

setCustomerId(String) - Method in class bb.common.SalesOrderListResult

setCustomerId(String) - Method in class bb.common.SalesOrderOnDemandResult

setCustomerId(String) - Method in class bb.common.SalesOrderVO

setCustomerId(String) - Method in class bb.common.SalesTaxListResult

setCustomerId(String) - Method in class bb.common.ShipListInfoVO

setCustomerId(String) - Method in class bb.common.ShipListOwnerAttributeVO

setCustomerId(String) - Method in class bb.common.ShipListVO

setCustomerId(String) - Method in class bb.common.ShipperInfoVO

setCustomerId(String) - Method in class bb.common.ShipperItemListResult

setCustomerId(String) - Method in class bb.common.ShipperListResult

setCustomerId(String) - Method in class bb.common.ShipperVO

setCustomerId(String) - Method in class bb.common.ShippingResult

setCustomerId(String) - Method in class bb.common.SO2SOAgent

setCustomerId(String) - Method in class bb.common.StockTransactionSOShipperResult

setCustomerId(String) - Method in class bb.common.StockTransactionWOShipperResult

setCustomerId(String) - Method in class bb.common.TempArApAgingVO

setCustomerId(String) - Method in class bb.common.WorkOrderQueryInfo

setCustomerID(String) - Method in class bb.common.ZipcodeTotalsResult

setCustomerIncoterm(String) - Method in class bb.common.CustomerVendorAddressVO

setCustomerIncotermPlacePort(String) - Method in class bb.common.CustomerVendorAddressVO

setCustomerInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.ContractPriceCustomerVO

setCustomerInvoiceDate(Date) - Method in class bb.common.MakeCreditMemoAgent

setCustomerInvoiceNumber(String) - Method in class bb.common.MakeCreditMemoAgent

setCustomerInvoiceTotal(BigDecimal) - Method in class bb.common.MakeCreditMemoAgent

setCustomerName(String) - Method in class bb.common.AccountReceivableInfoWithPrepayResult

setCustomerName(String) - Method in class bb.common.AllStatementsListResult

setCustomerName(String) - Method in class bb.common.ARAllStatementsListResult

setCustomerName(String) - Method in class bb.common.ARPaymentRunListResult

setCustomerName(String) - Method in class bb.common.ARPrepayAllStatementsListResult

setCustomerName(String) - Method in class bb.common.ARPrepayInfoResult

setCustomerName(String) - Method in class bb.common.ARTaxForZipcodeListResult

setCustomerName(String) - Method in class bb.common.CustomerStatementResult

setCustomerName(String) - Method in class bb.common.CustomerStatementTotalResult

setCustomerName(String) - Method in class bb.common.DepositSummaryResult

setCustomerName(String) - Method in class bb.common.LnShipperItemListResult

setCustomerName(String) - Method in class bb.common.LnShipperListResult

setCustomerName(String) - Method in class bb.common.MonthSoOrArByCustomerResult

setCustomerName(String) - Method in class bb.common.SalesMarginListResult

setCustomerName(String) - Method in class bb.common.SalesOrderCheckListResult

setCustomerName(String) - Method in class bb.common.SalesOrderListResult

setCustomerName(String) - Method in class bb.common.ShipperItemListResult

setCustomerName(String) - Method in class bb.common.ShipperListResult

setCustomerName(String) - Method in class bb.common.ShippingResult

setCustomerName(String) - Method in class bb.common.TempArApAgingVO

setCustomerName(String) - Method in class bb.common.ZipcodeTotalsResult

setCustomerParentId(String) - Method in class bb.common.AllStatementsListResult

setCustomerPO(String) - Method in class bb.common.ArCommissionListResult

setCustomerPO(String) - Method in class bb.common.ArPrepayVO

setCustomerPO(String) - Method in class bb.common.CustomerPrepayStatementListResult

setCustomerPo(String) - Method in class bb.common.CustomerStatementListResult

setCustomerPo(String) - Method in class bb.common.GeneralLedgerListResult

setCustomerPO(String) - Method in class bb.common.GeneralLedgerResult

setCustomerPo(String) - Method in class bb.common.GeneralLedgerVO

setCustomerPo(String) - Method in class bb.common.InvoiceItemListResult

setCustomerPo(String) - Method in class bb.common.OnLoanItemListResult

setCustomerPo(String) - Method in class bb.common.OnLoanListResult

setCustomerPo(String) - Method in class bb.common.OnloanShipperVO

setCustomerPo(String) - Method in class bb.common.OnLoanVO

setCustomerPo(String) - Method in class bb.common.ProformaInvoiceListResult

setCustomerPO(String) - Method in class bb.common.ProformaInvoiceVO

setCustomerPo(String) - Method in class bb.common.SalesOrderItemListResult

setCustomerPo(String) - Method in class bb.common.SalesOrderListResult

setCustomerPo(String) - Method in class bb.common.SalesOrderOnDemandResult

setCustomerPo(String) - Method in class bb.common.SalesOrderVO

setCustomerPo(String) - Method in class bb.common.ShipListItemVOResult

setCustomerPo(String) - Method in class bb.common.ShipperInfoVO

setCustomerPo(String) - Method in class bb.common.ShipperVO

setCustomerPo(String) - Method in class bb.common.SO2SOAgent

setCustomerPoNumber(String) - Method in class bb.common.AccountsReceivableInfoVO

setCustomerPoNumber(String) - Method in class bb.common.AccountsReceivableVO

setCustomerRefNumber(String) - Method in class bb.common.QuoteItemListResult

setCustomerRefNumber(String) - Method in class bb.common.QuoteListResult

setCustomerRefNumber(String) - Method in class bb.common.QuoteVO

setCustomerRfqNumber(String) - Method in class bb.common.QuoteItemListResult

setCustomerRFQReceiverEmail(String) - Method in class bb.common.CompanyVO

setCustomers(HashSet<ContractPriceCustomerVO>) - Method in class bb.common.ImportContractPriceData

setCustomerSales(BigDecimal) - Method in class bb.common.PaymentHistoryVO

setCustomerServiceIncidentNumber(String) - Method in class bb.common.CustomerFeedbackVO

setCustomerSet(Set) - Method in class bb.common.ShipListAgent

setCustomerShipper(String) - Method in class bb.common.RMAReceiverVO

setCustomerShipperDate(Date) - Method in class bb.common.RMAReceiverVO

setCustomerShippingDays(byte) - Method in class bb.common.CustomerVendorAddressInfoVO

setCustomerShippingDays(byte) - Method in class bb.common.CustomerVendorAddressVO

setCustomerShipVia(String) - Method in class bb.common.CustomerVendorAddressVO

setCustomerTaxCode(String) - Method in class bb.common.CustomerVendorAddressVO

setCustomerTaxRate(BigDecimal) - Method in class bb.common.CustomerVendorAddressVO

setCustomerTerms(String) - Method in class bb.common.CustomerVendorAddressVO

setCustomerToCountry(String) - Method in class bb.common.InvoiceItemListResult

setCustomerTostate(String) - Method in class bb.common.InvoiceItemListResult

setCustomerType(String) - Method in class bb.common.CustomerVendorTypeVO

setCustomerType(String) - Method in class bb.common.PartDiscountPK

setCustomId(String) - Method in class bb.common.MakeBillAndHoldInvoiceAgent

setCustomId(String) - Method in class bb.common.MakeInvoiceAgent

setCustomJobCategoryGoods(Set) - Method in class bb.common.CustomJobCategoryVO

setCustomProperties(HashMap) - Method in class bb.common.PhysicalInventoryListWithAppDataResult

setCustomProperties(HashMap) - Method in class bb.common.UpdatePhysicalInventoryAgent

setCustomProperties(Map) - Method in class bb.common.VO

setCustomReceiveDepartment(CustomDepartmentVO) - Method in class bb.common.CustomAssetRecordVO

setCustomReturnDepartment(CustomDepartmentVO) - Method in class bb.common.CustomAssetRecordVO

setCustomTranslation(String) - Method in class bb.common.CustomTranslationVO

setCustomTree(byte[]) - Method in class bb.common.CompanyVO

setCusTotal(BigDecimal) - Method in class bb.common.OnloanReceiverVO

setCustPONumber(String) - Method in class bb.common.SGSaleItemVO

setCustQuoteMailto(String) - Method in class bb.common.SGCompanyVO

setCustQuotePriceMailto(String) - Method in class bb.common.SGCompanyVO

setCustRfqMailto(String) - Method in class bb.common.SGCompanyVO

setCustSaleMailto(String) - Method in class bb.common.SGCompanyVO

setCycleCount(int) - Method in class bb.common.PartInventoryVO

setCycleCount(boolean) - Method in class bb.common.PhysicalInventoryStatusVO

setD01_30(BigDecimal) - Method in class bb.common.AccountAgingTotalResult

setD31_60(BigDecimal) - Method in class bb.common.AccountAgingTotalResult

setD61_90(BigDecimal) - Method in class bb.common.AccountAgingTotalResult

setD90_plus(BigDecimal) - Method in class bb.common.AccountAgingTotalResult

setDailyList(Map<String, Map<JounalEntryListResult, Collection<JounalEntryListResult>>>) - Method in class bb.common.GLInfoByPeriodResult

setData(byte[]) - Method in class bb.common.AccountsChartAdvanceCategoryVO

setData(Object) - Method in class bb.common.ImportDataVO

setDataVersion(String) - Method in class bb.common.CompanyVO

setDate(Date) - Method in class bb.common.CustomerStatementListResult

setDate(Date) - Method in class bb.common.DesignControlInfoVO

setDate(Date) - Method in class bb.common.DesignControlVO

setDate(Date) - Method in class bb.common.EmployeeRecordsVO

setDate(Date) - Method in class bb.common.HistoricalInventoryTotalResult

setDate(Date) - Method in class bb.common.HistoricalInventoryVO

setDate(Date) - Method in class bb.common.InventoryTotalCostResult

setDate(Date) - Method in class bb.common.LogInventoryListResult

setDate(Date) - Method in class bb.common.MrpByMonthResult

setDate(Date) - Method in class bb.common.VendorStatementListResult

setDate(Date) - Method in class bb.common.WOIssuedByMonthResult

setDate(Date) - Method in class bb.common.WorkCalendarVO

setDate(Date) - Method in class bb.common.WorkCenterOnDateAgent

setDate(Date) - Method in class bb.common.ZipcodeTotalsResult

setDate1(Date) - Method in class bb.common.AccountPayableCheckRunVO

setDate1(Date) - Method in class bb.common.ARPaymentRunVO

setDate1(Date) - Method in class bb.common.ExpenseVO

setDate1(Date) - Method in class bb.common.ShipListInfoVO

setDate1(Date) - Method in class bb.common.ShipListVO

setDate2(Date) - Method in class bb.common.AccountPayableCheckRunVO

setDate2(Date) - Method in class bb.common.ARPaymentRunVO

setDate2(Date) - Method in class bb.common.ExpenseVO

setDate2(Date) - Method in class bb.common.ShipListInfoVO

setDate2(Date) - Method in class bb.common.ShipListVO

setDateApprovedEng(Date) - Method in class bb.common.NonConformanceReportVO

setDateApprovedMfg(Date) - Method in class bb.common.NonConformanceReportVO

setDateApprovedQa(Date) - Method in class bb.common.NonConformanceReportVO

setDateCheck(Date) - Method in class bb.common.IcrItemListResult

setDateCheck(Date) - Method in class bb.common.InspectionConformanceReportItemVO

setDateCheckPaid(Date) - Method in class bb.common.ApCheckRunListResult

setDateCheckRunPaid(Date) - Method in class bb.common.ApCheckRunListResult

setDateEntered(Date) - Method in class bb.common.CorrectiveActionRequestVO

setDateEntered(Date) - Method in class bb.common.PreventiveActionRequestVO

setDateEntered(Date) - Method in class bb.common.ReturnToVendorVO

setDateFrom(Date) - Method in class bb.common.ExpenseItemVO

setDateFrom(Date) - Method in class bb.common.ExpenseListResult

setDateFrom(Date) - Method in class bb.common.InventoryReportListResult

setDateFrom(Date) - Method in class bb.common.WorkPeriodVO

setDateInvoice(Date) - Method in class bb.common.MakeCreditMemoAgent

setDateInvoiced(Date) - Method in class bb.common.AccountsReceivableInfoVO

setDateInvoiced(Date) - Method in class bb.common.AccountsReceivableItemVO

setDateInvoiced(Date) - Method in class bb.common.AccountsReceivableVO

setDateInvoiced(Date) - Method in class bb.common.ArCommissionListResult

setDateInvoiced(Date) - Method in class bb.common.ARPaymentRunItemVO

setDateInvoiced(Date) - Method in class bb.common.CustomerStatementListResult

setDateInvoiced(Date) - Method in class bb.common.InvoiceItemListResult

setDateInvoiced(Date) - Method in class bb.common.MakeBillAndHoldInvoiceAgent

setDateInvoiced(Date) - Method in class bb.common.MakeInvoiceAgent

setDateInvoiced(Date) - Method in class bb.common.OnloanShipperItemVO

setDateInvoiced(Date) - Method in class bb.common.OnloanShipperVO

setDateInvoiced(Date) - Method in class bb.common.PfReceiverItemVO

setDateInvoiced(Date) - Method in class bb.common.ProformaInvoiceItemVO

setDateInvoiced(Date) - Method in class bb.common.ProformaInvoiceVO

setDateInvoiced(Date) - Method in class bb.common.RtvShipperInfoVO

setDateInvoiced(Date) - Method in class bb.common.RtvShipperItemVO

setDateInvoiced(Date) - Method in class bb.common.RtvShipperVO

setDateInvoiced(Date) - Method in class bb.common.SalesTaxListResult

setDateInvoiced(Date) - Method in class bb.common.ShipperInfoVO

setDateInvoiced(Date) - Method in class bb.common.ShipperItemVO

setDateInvoiced(Date) - Method in class bb.common.ShipperVO

setDateInvoiced(Date) - Method in class bb.common.SOShipperItemListResult

setDateIssue(Date) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setDateIssue(Date) - Method in class bb.common.WorkOrderItemInWipListResult

setDateIssued(Date) - Method in class bb.common.NonproductivePickingItemIssuedVO

setDateIssued(Date) - Method in class bb.common.PartIssuedVO

setDateIssued(Date) - Method in class bb.common.WorkOrderIssuedOrderListResult

setDateIssued(Date) - Method in class bb.common.WorkOrderItemIssueVO

setDateIssued(Date) - Method in class bb.common.WorkOrderItemPartDetail

setDateIssued(Date) - Method in class bb.common.WorkOrderItemPartDetailInWipVO

setDateMade(Date) - Method in class bb.common.DisassembleWorkOrderIssueVO

setDateMade(Date) - Method in class bb.common.DWOIssueDetail

setDateMade(Date) - Method in class bb.common.WOReceiverDetail

setDateMade(Date) - Method in class bb.common.WorkOrderReceiverVO

setDatePaid(Date) - Method in class bb.common.AccountPayableCheckRunVO

setDatePaid(Date) - Method in class bb.common.AccountPayableCheckVO

setDatePaid(Date) - Method in class bb.common.AccountReceivablePaymentVO

setDatePaid(Date) - Method in class bb.common.AccountsPayableInfoVO

setDatePaid(Date) - Method in class bb.common.AccountsPayableItemVO

setDatePaid(Date) - Method in class bb.common.AccountsPayableVO

setDatePaid(Date) - Method in class bb.common.AccountsReceivableInfoVO

setDatePaid(Date) - Method in class bb.common.AccountsReceivableItemVO

setDatePaid(Date) - Method in class bb.common.AccountsReceivableVO

setDatePaid(Date) - Method in class bb.common.APItemListResult

setDatePaid(Date) - Method in class bb.common.ARPaymentRunVO

setDatePaid(Date) - Method in class bb.common.AssetDepreciateDetailReport

setDatePaid(Date) - Method in class bb.common.AssetVO

setDatePaid(Date) - Method in class bb.common.ExpenseVO

setDatePaid(Date) - Method in class bb.common.OnloanReceiverItemVO

setDatePaid(Date) - Method in class bb.common.OnloanReceiverVO

setDatePaid(Date) - Method in class bb.common.OnloanShipperItemVO

setDatePaid(Date) - Method in class bb.common.OnloanShipperVO

setDatePaid(Date) - Method in class bb.common.PaymentAgent

setDatePaid(Date) - Method in class bb.common.PrepayPaymentAgent

setDatePaid(Date) - Method in class bb.common.ProformaInvoiceVO

setDatePaid(Date) - Method in class bb.common.ReceiverInfoVO

setDatePaid(Date) - Method in class bb.common.ReceiverItemVO

setDatePaid(Date) - Method in class bb.common.ReceiverVO

setDatePaid(Date) - Method in class bb.common.RMAReceiverItemVO

setDatePaid(Date) - Method in class bb.common.RMAReceiverVO

setDatePaid(Date) - Method in class bb.common.RtvShipperInfoVO

setDatePaid(Date) - Method in class bb.common.RtvShipperItemVO

setDatePaid(Date) - Method in class bb.common.RtvShipperVO

setDatePaid(Date) - Method in class bb.common.ShipperInfoVO

setDatePaid(Date) - Method in class bb.common.ShipperItemVO

setDatePaid(Date) - Method in class bb.common.ShipperVO

setDateReceived(Date) - Method in class bb.common.AccountsPayableInfoVO

setDateReceived(Date) - Method in class bb.common.AccountsPayableVO

setDateReceived(Date) - Method in class bb.common.APItemListResult

setDateReceived(Date) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

setDateReceived(Date) - Method in class bb.common.OnloanReceiverItemListResult

setDateReceived(Date) - Method in class bb.common.OnloanReceiverListResult

setDateReceived(Date) - Method in class bb.common.OnloanReceiverVO

setDateReceived(Date) - Method in class bb.common.PartReceivedVO

setDateReceived(Date) - Method in class bb.common.PfReceiverVO

setDateReceived(Date) - Method in class bb.common.PrReceiverListResult

setDateReceived(Date) - Method in class bb.common.ReceiverInfoVO

setDateReceived(Date) - Method in class bb.common.ReceiverVO

setDateReceived(Date) - Method in class bb.common.RMAReceiverItemListResult

setDateReceived(Date) - Method in class bb.common.RMAReceiverListResult

setDateReceived(Date) - Method in class bb.common.RMAReceiverVO

setDateReceived(Date) - Method in class bb.common.TempReceiverWithoutAPInfo

setDateRequired(Date) - Method in class bb.common.ApPrepayItemVO

setDateRequired(Date) - Method in class bb.common.ArPrepayItemVO

setDateRequired(Date) - Method in class bb.common.CustomerPrepayStatementListResult

setDateRequired(Date) - Method in class bb.common.DisassembleWorkOrderItemVO

setDateRequired(Date) - Method in class bb.common.DWOIssueDetail

setDateRequired(Date) - Method in class bb.common.PartIssuedListResult

setDateRequired(Date) - Method in class bb.common.PartReceivedListResult

setDateRequired(Date) - Method in class bb.common.PoMessageItemVO

setDateRequired(Date) - Method in class bb.common.PurchaseOrderItemVO

setDateRequired(Date) - Method in class bb.common.PurchaseOrderVO

setDateRequired(Date) - Method in class bb.common.RequestForQuoteItemVO

setDateRequired(Date) - Method in class bb.common.ReturnToVendorByDateListResult

setDateRequired(Date) - Method in class bb.common.ReturnToVendorVO

setDateRequired(Date) - Method in class bb.common.ShoppingCartItem

setDateRequired(Date) - Method in class bb.common.VendorPrepayStatementListResult

setDateRequired(Date) - Method in class bb.common.WO2WOAgent

setDateRequired(Date) - Method in class bb.common.WoItemPickListResult

setDateRequired(Date) - Method in class bb.common.WOReceiverDetail

setDateRequired(Date) - Method in class bb.common.WorkOrderItemCanAssyResult

setDateRequired(Date) - Method in class bb.common.WorkOrderItemReviewCostResult

setDateRequired(Date) - Method in class bb.common.WorkOrderItemVO

setDateRequired(Date) - Method in class bb.common.WorkOrderOverIssueListResult

setDateRequired(Date) - Method in class bb.common.WorkOrderWorkItemDateAgent

setDateRequited(Date) - Method in class bb.common.ShipListItemVOResult

setDateSave(Date) - Method in class bb.common.TempReceiverWithoutAPInfo

setDateShiped(Date) - Method in class bb.common.SalesTaxListResult

setDateShipped(Date) - Method in class bb.common.AccountsReceivableInfoVO

setDateShipped(Date) - Method in class bb.common.AccountsReceivableItemVO

setDateShipped(Date) - Method in class bb.common.AccountsReceivableVO

setDateShipped(Date) - Method in class bb.common.LnShipperItemListResult

setDateShipped(Date) - Method in class bb.common.LnShipperListResult

setDateShipped(Date) - Method in class bb.common.OnloanShipperItemVO

setDateShipped(Date) - Method in class bb.common.OnloanShipperVO

setDateShipped(Date) - Method in class bb.common.PfReceiverItemVO

setDateShipped(Date) - Method in class bb.common.ProformaInvoiceItemListResult

setDateShipped(Date) - Method in class bb.common.ProformaInvoiceItemVO

setDateShipped(Date) - Method in class bb.common.ProformaInvoiceListResult

setDateShipped(Date) - Method in class bb.common.ProformaInvoiceVO

setDateShipped(Date) - Method in class bb.common.RtvShipperInfoVO

setDateShipped(Date) - Method in class bb.common.RtvShipperItemListResult

setDateShipped(Date) - Method in class bb.common.RtvShipperItemVO

setDateShipped(Date) - Method in class bb.common.RtvShipperListResult

setDateShipped(Date) - Method in class bb.common.RtvShipperVO

setDateShipped(Date) - Method in class bb.common.SGSaleItemVO

setDateShipped(Date) - Method in class bb.common.ShipperInfoVO

setDateShipped(Date) - Method in class bb.common.ShipperItemListResult

setDateShipped(Date) - Method in class bb.common.ShipperItemVO

setDateShipped(Date) - Method in class bb.common.ShipperVO

setDateShipped(Date) - Method in class bb.common.SOShipperItemListResult

setDateTo(Date) - Method in class bb.common.ExpenseItemVO

setDateTo(Date) - Method in class bb.common.ExpenseListResult

setDateTo(Date) - Method in class bb.common.InventoryReportListResult

setDateTo(Date) - Method in class bb.common.WorkPeriodVO

setDateUsed(Date) - Method in class bb.common.partUsedInfoResult

setDay(String) - Method in class bb.common.WorkCalendarVO

setDay1(int) - Method in class bb.common.OnTimeAgent

setDay1(int) - Method in class bb.common.PurchaseOnTimeResult

setDay1(int) - Method in class bb.common.SalesOnTimeResult

setDay1(int) - Method in class bb.common.WorkOrderOnTimeResult

setDay2(int) - Method in class bb.common.OnTimeAgent

setDay2(int) - Method in class bb.common.PurchaseOnTimeResult

setDay2(int) - Method in class bb.common.SalesOnTimeResult

setDay2(int) - Method in class bb.common.WorkOrderOnTimeResult

setDays(BigDecimal) - Method in class bb.common.PurchaseOrderOnTimeItemResult

setDays(BigDecimal) - Method in class bb.common.SalesOrderOnTimeItemResult

setDays(Integer) - Method in class bb.common.TermAgent

setDays(Integer) - Method in class bb.common.TermVO

setDays(BigDecimal) - Method in class bb.common.WorkOrderOnTimeItemResult

setDaysCurrent(Short) - Method in class bb.common.CompanyVO

setDaysOverdue(Byte) - Method in class bb.common.CompanyVO

setDaysPerWeek(BigDecimal) - Method in class bb.common.WorkCenterVO

setDcNumber(String) - Method in class bb.common.DesignControlListResult

setDcode(String) - Method in class bb.common.OnLoanItemVO

setDCode(String) - Method in class bb.common.PartDiscountPK

setDCode(String) - Method in class bb.common.PartInventoryVO

setDCode(String) - Method in class bb.common.ToolInventoryVO

setDd(String) - Method in class bb.common.DesignControlInfoVO

setDd(String) - Method in class bb.common.DesignControlVO

setDebit(BigDecimal) - Method in class bb.common.AccountBalanceListResult

setDebit(BigDecimal) - Method in class bb.common.AccountDebitVO

setDebit(BigDecimal) - Method in class bb.common.ClosingStatementItemResult

setDebit(BigDecimal) - Method in class bb.common.ExchangeAuditItemResult

setDebit(BigDecimal) - Method in class bb.common.GeneralLedgerByDateListResult

setDebit(BigDecimal) - Method in class bb.common.GeneralLedgerEntry

setDebit(BigDecimal) - Method in class bb.common.GLDebitCreditListResult

setDebit(BigDecimal) - Method in class bb.common.GLItemVO

setDebit(String) - Method in class bb.common.NcrScrapAgent

setDebitAccount(String) - Method in class bb.common.AccountsPayableInfoVO

setDebitAccount(String) - Method in class bb.common.AccountsPayableVO

setDebitAccount(String) - Method in class bb.common.AddPayableWithoutReceiverAgent

setDebitAccount(String) - Method in class bb.common.APItemListResult

setDebitAccount(String) - Method in class bb.common.ARPrepaymentWireTransferAgent

setDebitAccount(String) - Method in class bb.common.CRTVItemListResult

setDebitAccount(String) - Method in class bb.common.CustomerReturnToVendorVO

setDebitAccount(String) - Method in class bb.common.DisassembleWorkOrderIssuingResult

setDebitAccount(String) - Method in class bb.common.DisassembleWorkOrderVO

setDebitAccount(String) - Method in class bb.common.JounalEntryListResult

setDebitAccount(String) - Method in class bb.common.MakeAccountPayableAgent

setDebitAccount(String) - Method in class bb.common.MakeBillAndHoldInvoiceAgent

setDebitAccount(String) - Method in class bb.common.MakeCheckAgent

setDebitAccount(String) - Method in class bb.common.MakeDebitMemoAgent

setDebitAccount(String) - Method in class bb.common.MakeInvoiceAgent

setDebitAccount(String) - Method in class bb.common.OnloanReceiverVO

setDebitAccount(String) - Method in class bb.common.OnloanShipperVO

setDebitAccount(String) - Method in class bb.common.OnLoanVO

setDebitAccount(String) - Method in class bb.common.PostCheckAgent

setDebitAccount(String) - Method in class bb.common.PrepaymentWireTransferAgent

setDebitAccount(String) - Method in class bb.common.PurchaseOrderVO

setDebitAccount(String) - Method in class bb.common.PurchaseWorkSheetVO

setDebitAccount(String) - Method in class bb.common.ReceiverInfoVO

setDebitAccount(String) - Method in class bb.common.ReceiverVO

setDebitAccount(String) - Method in class bb.common.ReceivingResult

setDebitAccount(String) - Method in class bb.common.RequestForQuoteVO

setDebitAccount(String) - Method in class bb.common.RequestForRMAVO

setDebitAccount(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setDebitAccount(String) - Method in class bb.common.ReturnToVendorByDateListResult

setDebitAccount(String) - Method in class bb.common.ReturnToVendorVO

setDebitAccount(String) - Method in class bb.common.RMAItemListResult

setDebitAccount(String) - Method in class bb.common.RMAReceiverVO

setDebitAccount(String) - Method in class bb.common.RRMAItemListResult

setDebitAccount(String) - Method in class bb.common.RtvShipperInfoVO

setDebitAccount(String) - Method in class bb.common.RtvShipperVO

setDebitAccount(String) - Method in class bb.common.ScrapReportVO

setDebitAccount(String) - Method in class bb.common.ShipperInfoVO

setDebitAccount(String) - Method in class bb.common.ShipperVO

setDebitAccount(String) - Method in class bb.common.WireTransferAgent

setDebitAccount(String) - Method in class bb.common.WorkOrderVO

setDebitAccount(String) - Method in class bb.common.WorkOrderWorkSheetVO

setDebitAccountBalance(Map<CompanyUnitAccountPK, BigDecimal>) - Method in class bb.common.AccountBalanceAgent

setDebitAccounts(String) - Method in class bb.common.GeneralLedgerCategoryVO

setDebitAmount(BigDecimal) - Method in class bb.common.AccountBalanceResult

setDebitAmount(BigDecimal) - Method in class bb.common.JounalEntryListResult

setDebitBalance(BigDecimal) - Method in class bb.common.MonthBalanceResult

setDebitBeginPeriodBalance(BigDecimal) - Method in class bb.common.AccountBalanceResult

setDebitEndingBalance(BigDecimal) - Method in class bb.common.CurrentBalanceResult

setDebitEndPeriodBalance(BigDecimal) - Method in class bb.common.AccountBalanceResult

setDebitMemoComments(String) - Method in class bb.common.MakeDebitMemoAgent

setDebitMemoNotes(String) - Method in class bb.common.MakeDebitMemoAgent

setDebitMonthTotal(BigDecimal) - Method in class bb.common.CurrentBalanceResult

setDebitOrCredit(String) - Method in class bb.common.AccountBalanceResult

setDebitOrCredit(String) - Method in class bb.common.AccountsChartVO

setDebitOrCredit(String) - Method in class bb.common.AddressAccountInfo

setDebitOrCredit(String) - Method in class bb.common.AmountsStatementResult

setDebitOrCredit(String) - Method in class bb.common.GLInfoByPeriodResult

setDebitOrCredit(String) - Method in class bb.common.JounalEntryListResult

setDebitOrCredit(String) - Method in class bb.common.ShareHoldersEquityResult

setDebits(List<AccountsCreditDebitListResult>) - Method in class bb.common.DebitsCreditsResult

setDebitStartingBalance(BigDecimal) - Method in class bb.common.CurrentBalanceResult

setDebitText(String) - Method in class bb.common.NcrScrapAgent

setDecimalLength(int) - Method in class bb.common.CompanyVO

setDeductable(String) - Method in class bb.common.AccountBalanceResult

setDeductable(String) - Method in class bb.common.AccountsChartVO

setDefaultAccount(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setDefaultAccount(String) - Method in class bb.common.CustomerVendorAddressVO

setDefaultMFG(String) - Method in class bb.common.PointOfSaleVO

setDefaultPartUnit(boolean) - Method in class bb.common.PartUnitVO

setDefaultVendor(String) - Method in class bb.common.WorkCenterVendorVO

setDefaultVendorTax(BigDecimal) - Method in class bb.common.CompanyVO

setDefaultWi(String) - Method in class bb.common.WorkInstructionListResult

setDefaultWi(String) - Method in class bb.common.WorkInstructionVO

setDefaultWi(String) - Method in class bb.common.WorkOrderWorkInstructionVO

setDefaultWOVendorID(String) - Method in class bb.common.CompanyVO

setDegree(String) - Method in class bb.common.CustomEmployeeVO

setDegree(String) - Method in class bb.common.EmployeeEducationVO

setDelay(int) - Method in class bb.common.CustomerReturnToVendorItemVO

setDelay(byte) - Method in class bb.common.CustomerReturnToVendorVO

setDelay(int) - Method in class bb.common.DisassembleWorkOrderVO

setDelay(int) - Method in class bb.common.OnLoanItemVO

setDelay(byte) - Method in class bb.common.OnLoanVO

setDelay(int) - Method in class bb.common.PoMessageItemVO

setDelay(byte) - Method in class bb.common.QuoteVO

setDelay(int) - Method in class bb.common.RequestForQuoteItemVO

setDelay(byte) - Method in class bb.common.RequestForQuoteVO

setDelay(int) - Method in class bb.common.RequestForRMAItemVO

setDelay(byte) - Method in class bb.common.RequestForRMAVO

setDelay(int) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setDelay(byte) - Method in class bb.common.ReturnMaterialAuthorizationVO

setDelay(int) - Method in class bb.common.ReturnToVendorItemVO

setDelay(int) - Method in class bb.common.RfqMessageItemVO

setDelay(byte) - Method in class bb.common.SalesOrderVO

setDelay(int) - Method in class bb.common.WorkOrderVO

setDelayDays(int) - Method in class bb.common.DisassembleWorkOrderItemVO

setDelayDays(int) - Method in class bb.common.NonproductivePickingItemVO

setDelayDays(int) - Method in class bb.common.NonproductivePickingOnDemandResult

setDelayDays(int) - Method in class bb.common.OrderApprovalItemsVO

setDelayDays(int) - Method in class bb.common.PO2POAgent

setDelayDays(int) - Method in class bb.common.PO2SOExchangeItem

setDelayDays(int) - Method in class bb.common.POStatisticsResult

setDelayDays(String) - Method in class bb.common.PurchaseOrderContractResult

setDelayDays(int) - Method in class bb.common.PurchaseOrderItemListResult

setDelayDays(int) - Method in class bb.common.PurchaseOrderItemVO

setDelayDays(int) - Method in class bb.common.PurchaseOrderOnOrderResult

setDelayDays(int) - Method in class bb.common.PurchaseOrderOpenDueListResult

setDelayDays(byte) - Method in class bb.common.PurchaseOrderVO

setDelayDays(int) - Method in class bb.common.QuoteItemVO

setDelayDays(byte) - Method in class bb.common.ReturnToVendorVO

setDelayDays(int) - Method in class bb.common.SalesOrderItemInfoVO

setDelayDays(int) - Method in class bb.common.SalesOrderItemListResult

setDelayDays(int) - Method in class bb.common.SalesOrderItemVO

setDelayDays(int) - Method in class bb.common.SalesOrderOnDemandResult

setDelayDays(int) - Method in class bb.common.SO2SOAgent

setDelayDays(int) - Method in class bb.common.SwapOrderItemListResult

setDelayDays(int) - Method in class bb.common.SwapOrderItemVO

setDelayDays(int) - Method in class bb.common.TransferOrderItemListResult

setDelayDays(int) - Method in class bb.common.TransferOrderItemVO

setDelayDays(int) - Method in class bb.common.WorkOrderInWipResult

setDelayDays(int) - Method in class bb.common.WorkOrderItemVO

setDelayDays(int) - Method in class bb.common.WorkOrderOnDemandResult

setDelayDays(int) - Method in class bb.common.WorkOrderOnOrderResult

setDeleted(boolean) - Method in class bb.common.CustomerVendorAddressInfoVO

setDeleted(boolean) - Method in class bb.common.CustomerVendorAddressVO

setDeleted(boolean) - Method in class bb.common.ManufacturerAddressInfoVO

setDeleted(boolean) - Method in class bb.common.ManufacturerAddressVO

setDeleted(boolean) - Method in class bb.common.PartVO

setDeleted(boolean) - Method in class bb.common.PartWithOnhandsVO

setDeleteZeroLocation(boolean) - Method in class bb.common.CompanyVO

setDeleveryDate(Date) - Method in class bb.common.PurchaseOrderItemListResult

setDeleveryDate(Date) - Method in class bb.common.PurchaseOrderOpenDueListResult

setDeliveredTo(String) - Method in class bb.common.AccountsPayableInfoVO

setDeliveredTo(String) - Method in class bb.common.AccountsPayableVO

setDeliveredTo(String) - Method in class bb.common.OnloanReceiverVO

setDeliveredTo(String) - Method in class bb.common.ReceiverInfoVO

setDeliveredTo(String) - Method in class bb.common.ReceiverVO

setDeliveredTo(String) - Method in class bb.common.RMAReceiverVO

setDelivery(Date) - Method in class bb.common.CustomerReturnToVendorItemVO

setDelivery(Date) - Method in class bb.common.CustomerReturnToVendorVO

setDelivery(Date) - Method in class bb.common.DisassembleWorkOrderVO

setDelivery(Date) - Method in class bb.common.EcnPOOrderResult

setDelivery(Date) - Method in class bb.common.EcnWOOrderResult

setDelivery(Date) - Method in class bb.common.OnLoanItemVO

setDelivery(Date) - Method in class bb.common.OnLoanVO

setDelivery(Date) - Method in class bb.common.PurchaseOrderCheckListResult

setDelivery(Date) - Method in class bb.common.PurchaseWorkSheetItemVO

setDelivery(String) - Method in class bb.common.QuoteItemListResult

setDelivery(String) - Method in class bb.common.QuoteItemVO

setDelivery(String) - Method in class bb.common.QuoteVO

setDelivery(Date) - Method in class bb.common.RequestForQuoteCheckListResult

setDelivery(Date) - Method in class bb.common.RequestForQuoteItemListResult

setDelivery(Date) - Method in class bb.common.RequestForQuoteListResult

setDelivery(Date) - Method in class bb.common.RequestForQuoteVO

setDelivery(Date) - Method in class bb.common.RequestForRMAItemVO

setDelivery(Date) - Method in class bb.common.RequestForRMAVO

setDelivery(Date) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setDelivery(Date) - Method in class bb.common.ReturnMaterialAuthorizationVO

setDelivery(Date) - Method in class bb.common.ReturnToVendorCheckListResult

setDelivery(Date) - Method in class bb.common.ReturnToVendorItemListResult

setDelivery(Date) - Method in class bb.common.ReturnToVendorItemVO

setDelivery(Date) - Method in class bb.common.ReturnToVendorListResult

setDelivery(Date) - Method in class bb.common.RMAReceiverResult

setDelivery(Date) - Method in class bb.common.SalesOrderVO

setDelivery(Date) - Method in class bb.common.WCLoadDetailResult

setDelivery(Date) - Method in class bb.common.WorkOrderItemToIssueResult

setDelivery(Date) - Method in class bb.common.WorkOrderItemWCLoadResult

setDelivery(Date) - Method in class bb.common.WorkOrderListResult

setDelivery(Date) - Method in class bb.common.WorkOrderVO

setDelivery(Date) - Method in class bb.common.WorkOrderWorkSheetItemVO

setDelivery(Date) - Method in class bb.common.WorkSheetPartAgent

setDeliveryDate(Date) - Method in class bb.common.BB2PartInSipItemResult

setDeliveryDate(Date) - Method in class bb.common.BB2PartInSipOfSoItemResult

setDeliveryDate(Date) - Method in class bb.common.BB2PartInSitItemResult

setDeliveryDate(Date) - Method in class bb.common.CRTVItemListResult

setDeliveryDate(Date) - Method in class bb.common.NonproductivePickingItemVO

setDeliveryDate(Date) - Method in class bb.common.NonproductivePickingOnDemandResult

setDeliveryDate(Date) - Method in class bb.common.OnLoanItemListResult

setDeliveryDate(Date) - Method in class bb.common.PurchaseOrderOnOrderResult

setDeliveryDate(Date) - Method in class bb.common.RMAItemListResult

setDeliveryDate(Date) - Method in class bb.common.RRMAItemListResult

setDeliveryDate(Date) - Method in class bb.common.SalesOrderItemInfoVO

setDeliveryDate(Date) - Method in class bb.common.SalesOrderItemListResult

setDeliveryDate(Date) - Method in class bb.common.SalesOrderItemVO

setDeliveryDate(Date) - Method in class bb.common.SalesOrderOnDemandResult

setDeliveryDate(Date) - Method in class bb.common.SalesOrderShipDateListResult

setDeliveryDate(Date) - Method in class bb.common.ShipListItemRelatedDocResult

setDeliveryDate(Date) - Method in class bb.common.ShipperItemListResult

setDeliveryDate(Date) - Method in class bb.common.SwapOrderItemListResult

setDeliveryDate(Date) - Method in class bb.common.SwapOrderItemVO

setDeliveryDate(Date) - Method in class bb.common.TransferOrderItemListResult

setDeliveryDate(Date) - Method in class bb.common.TransferOrderItemVO

setDeliveryDate(Date) - Method in class bb.common.WOItemPartDetailNotIssue

setDeliveryDate(Date) - Method in class bb.common.WorkOrderInWipResult

setDeliveryDate(Date) - Method in class bb.common.WorkOrderItemPartDetailResult

setDeliveryDate(Date) - Method in class bb.common.WorkOrderItemTimeDetailResult

setDeliveryDate(Date) - Method in class bb.common.WorkOrderOnDemandResult

setDeliveryDate(Date) - Method in class bb.common.WorkOrderOnOrderResult

setDemand(BigDecimal) - Method in class bb.common.OrderDemandForReceiverResult

setDemand(BigDecimal) - Method in class bb.common.ShippingItemResult

setDepartment(String) - Method in class bb.common.BizBoxUserEmployeeResult

setDepartment(String) - Method in class bb.common.BizboxUserListResult

setDepartment(String) - Method in class bb.common.BuyerCodeVO

setDepartment(String) - Method in class bb.common.CustomAssetVO

setDepartment(String) - Method in class bb.common.CustomEmployeeVO

setDepartment(String) - Method in class bb.common.DesignControlInfoVO

setDepartment(String) - Method in class bb.common.DesignControlVO

setDepartment(String) - Method in class bb.common.EmployeeCardVO

setDepartment(String) - Method in class bb.common.ExpenseVO

setDepartment(String) - Method in class bb.common.NoticeUserEmployeeListResult

setDepartment(String) - Method in class bb.common.SalesmanVO

setDepartment(String) - Method in class bb.common.WorkCenterLoadListResult

setDepartment(String) - Method in class bb.common.WorkCenterVO

setDepartmentAccount(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setDepartmentAccount(String) - Method in class bb.common.CustomerVendorAddressVO

setDepartmentDepositBank(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setDepartmentDepositBank(String) - Method in class bb.common.CustomerVendorAddressVO

setDepartmentID(String) - Method in class bb.common.AssetAddOrDisposalsReport

setDepartmentID(String) - Method in class bb.common.AssetDepreciateDetailReport

setDepartmentID(String) - Method in class bb.common.AssetDepreciateVO

setDepartmentID(String) - Method in class bb.common.AssetVO

setDepartmentId(String) - Method in class bb.common.BuyerCodeVO

setDepartmentId(String) - Method in class bb.common.CorrectiveActionRequestVO

setDepartmentID(String) - Method in class bb.common.DepreciateMonthlyReport

setDepartmentId(String) - Method in class bb.common.EquipmentListResult

setDepartmentId(String) - Method in class bb.common.EquipmentVO

setDepartmentId(String) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setDepartmentId(String) - Method in class bb.common.NonproductivePickingItemIssuedVO

setDepartmentId(String) - Method in class bb.common.NonproductivePickingVO

setDepartmentId(String) - Method in class bb.common.PreventiveActionRequestVO

setDepartmentId(String) - Method in class bb.common.WorkInstructionRequestForChangeVO

setDepartmentLike(String) - Method in class bb.common.WorkCenterLoadAgent

setDepartmentName(String) - Method in class bb.common.PreventiveActionRequestVO

setDepartName(String) - Method in class bb.common.CorrectiveActionRequestVO

setDeposit(boolean) - Method in class bb.common.GeneralLedgerVO

setDepreciate(Map<String, BigDecimal>) - Method in class bb.common.AssetDepreciateDetailReport

setDepreciatedAccm(BigDecimal) - Method in class bb.common.AssetDepreciateDetailReport

setDepreciatedAccm(BigDecimal) - Method in class bb.common.AssetDepreciateVO

setDepreciatedAccm(BigDecimal) - Method in class bb.common.AssetReportSumResult

setDepreciatedAccm(BigDecimal) - Method in class bb.common.AssetVO

setDepreciatedAccmMonths(int) - Method in class bb.common.AssetVO

setDepreciateDate(Date) - Method in class bb.common.AssetDepreciateVO

setDepreciatedCost(BigDecimal) - Method in class bb.common.AssetVO

setDepreciateEndDate(Date) - Method in class bb.common.AssetAddOrDisposalsReport

setDepreciateEndDate(Date) - Method in class bb.common.AssetDepreciateDetailReport

setDepreciateEndDate(Date) - Method in class bb.common.AssetVO

setDepreciateStartDate(Date) - Method in class bb.common.AssetAddOrDisposalsReport

setDepreciateStartDate(Date) - Method in class bb.common.AssetDepreciateDetailReport

setDepreciateStartDate(Date) - Method in class bb.common.AssetVO

setDepreciateStatus(String) - Method in class bb.common.AssetAddOrDisposalsReport

setDepreciateStatus(String) - Method in class bb.common.AssetDepreciateVO

setDepreciateStatus(String) - Method in class bb.common.AssetVO

setDepreciateStatus(String) - Method in class bb.common.DepreciateMonthlyReport

setDepreciations(Set) - Method in class bb.common.AssetVO

setDepreciationType(String) - Method in class bb.common.AssetVO

setDepricateAccount(String) - Method in class bb.common.ScrapAssetAgent

setDesc(String) - Method in class bb.common.BB2BigDecimalAndString

setDesc(String) - Method in class bb.common.InventoryPartInOutDetailListResult

setDesc(String) - Method in class bb.common.RunningAccountOrderItemVO

setDescripiton(String) - Method in class bb.common.BillItemUsagePathResult

setDescripiton(String) - Method in class bb.common.SGBOMItemResult

setDescription(String) - Method in class bb.common.AccountBalanceResult

setDescription(String) - Method in class bb.common.AccountCreditVO

setDescription(String) - Method in class bb.common.AccountDebitVO

setDescription(String) - Method in class bb.common.AccountingTransactionTypeVO

setDescription(String) - Method in class bb.common.AccountsChartVO

setDescription(String) - Method in class bb.common.AccountsCreditDebitListResult

setDescription(String) - Method in class bb.common.AccountsPayableItemVO

setDescription(String) - Method in class bb.common.AccountsReceivableItemVO

setDescription(String) - Method in class bb.common.AddPayableWithoutReceiverAgent

setDescription(String) - Method in class bb.common.AddressAccountInfo

setDescription(String) - Method in class bb.common.AllPartDocumentsVO

setDescription(String) - Method in class bb.common.AmountsStatementResult

setDescription(String) - Method in class bb.common.APItemListResult

setDescription(String) - Method in class bb.common.ARBoilerplateVO

setDescription(String) - Method in class bb.common.AssetAddOrDisposalsReport

setDescription(String) - Method in class bb.common.AssetDepreciateDetailReport

setDescription(String) - Method in class bb.common.AssetDepreciateVO

setDescription(String) - Method in class bb.common.AssetVO

setDescription(String) - Method in class bb.common.AuditOnDemandResult

setDescription(String) - Method in class bb.common.BB2DoubleString

setDescription(String) - Method in class bb.common.BB2PartBasicInfo

setDescription(String) - Method in class bb.common.BB2PartOnDemandListResult

setDescription(String) - Method in class bb.common.BB2Task

setDescription(String) - Method in class bb.common.BillItemSalesCostResult

setDescription(String) - Method in class bb.common.BillItemSalesResult

setDescription(String) - Method in class bb.common.BillItemSalesXResult

setDescription(String) - Method in class bb.common.BillSalesResult

setDescription(String) - Method in class bb.common.BillSalesXResult

setDescription(String) - Method in class bb.common.BillWhereUsedItemResult

setDescription(String) - Method in class bb.common.BillWhereUsedResult

setDescription(String) - Method in class bb.common.BizboxBugChangesInfoVO

setDescription(String) - Method in class bb.common.BizboxBugChangesVO

setDescription(String) - Method in class bb.common.BOMCanAssyListResult

setDescription(String) - Method in class bb.common.BomItemWithOEMResult

setDescription(String) - Method in class bb.common.BomPickListItemResult

setDescription(String) - Method in class bb.common.BomPickListResult

setDescription(String) - Method in class bb.common.BomWithOEMResult

setDescription(String) - Method in class bb.common.BudgetListResult

setDescription(String) - Method in class bb.common.BuyerCodeVO

setDescription(String) - Method in class bb.common.CatalogVO

setDescription(String) - Method in class bb.common.CertificateDescriptionVO

setDescription(String) - Method in class bb.common.ChangeStdCostWorkSheetItemVO

setDescription(String) - Method in class bb.common.ContractPriceItemVO

setDescription(String) - Method in class bb.common.ContractPriceVO

setDescription(String) - Method in class bb.common.CorrectiveActionRequestVO

setDescription(String) - Method in class bb.common.CPItemFromQuoteResult

setDescription(String) - Method in class bb.common.CustomDepartmentVO

setDescription(String) - Method in class bb.common.CustomerReturnToVendorItemVO

setDescription(String) - Method in class bb.common.CustomerServiceIncidentItemListResult

setDescription(String) - Method in class bb.common.CustomerServiceIncidentItemVO

setDescription(String) - Method in class bb.common.CustomerServiceIncidentListResult

setDescription(String) - Method in class bb.common.CustomerServiceIncidentVO

setDescription(String) - Method in class bb.common.CycleCountListResult

setDescription(String) - Method in class bb.common.CycleCountStatusVO

setDescription(String) - Method in class bb.common.DepositSummaryResult

setDescription(String) - Method in class bb.common.DesignControlDocumentVO

setDescription(String) - Method in class bb.common.DisassembleWorkOrderIssueVO

setDescription(String) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setDescription(String) - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

setDescription(String) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

setDescription(String) - Method in class bb.common.DisassembleWorkOrderItemVO

setDescription(String) - Method in class bb.common.DisassembleWorkOrderReceivingResult

setDescription(String) - Method in class bb.common.DWOIssueDetail

setDescription(String) - Method in class bb.common.EcnPOOrderResult

setDescription(String) - Method in class bb.common.EcnWOOrderResult

setDescription(String) - Method in class bb.common.EmployeeEducationVO

setDescription(String) - Method in class bb.common.EmployeeJobDescriptionVO

setDescription(String) - Method in class bb.common.EmployeeRecordsVO

setDescription(String) - Method in class bb.common.EmployeeWorkExperienceVO

setDescription(String) - Method in class bb.common.EngineeringChangeRequestVO

setDescription(String) - Method in class bb.common.EngineeringChangeVO

setDescription(String) - Method in class bb.common.EquipmentListResult

setDescription(String) - Method in class bb.common.EquipmentVO

setDescription(String) - Method in class bb.common.ExpenseAccountVO

setDescription(String) - Method in class bb.common.ExpenseItemVO

setDescription(String) - Method in class bb.common.GeneralLedgerByDateListResult

setDescription(String) - Method in class bb.common.GeneralLedgerEntry

setDescription(String) - Method in class bb.common.GeneralLedgerListResult

setDescription(String) - Method in class bb.common.GeneralLedgerVO

setDescription(String) - Method in class bb.common.GLApprovalListResult

setDescription(String) - Method in class bb.common.GLAutoApproveVO

setDescription(String) - Method in class bb.common.GLItemVO

setDescription(String) - Method in class bb.common.GroupUserVO

setDescription(String) - Method in class bb.common.HelpServerVO

setDescription(String) - Method in class bb.common.HighUsagePartResult

setDescription(String) - Method in class bb.common.HistoricalInventoryVO

setDescription(String) - Method in class bb.common.IncotermVO

setDescription(String) - Method in class bb.common.InspectionReportInspectMethodVO

setDescription(String) - Method in class bb.common.InventoryAdjustmentListResult

setDescription(String) - Method in class bb.common.InventoryCycleResult

setDescription(String) - Method in class bb.common.InventoryListResult

setDescription(String) - Method in class bb.common.InventoryMonthReport

setDescription(String) - Method in class bb.common.InventoryNotUsedInMonthsResult

setDescription(String) - Method in class bb.common.InvoiceItemListResult

setDescription(String) - Method in class bb.common.IssuingItemResult

setDescription(String) - Method in class bb.common.IssuingResult

setDescription(String) - Method in class bb.common.JobProcessSheetListResult

setDescription(String) - Method in class bb.common.JobProcessSheetResult

setDescription(String) - Method in class bb.common.JounalEntryListResult

setDescription(String) - Method in class bb.common.LnShipperItemListResult

setDescription(String) - Method in class bb.common.LogInventoryListResult

setDescription(String) - Method in class bb.common.LogMiscDocumentVO

setDescription(String) - Method in class bb.common.LogPartDocumentVO

setDescription(String) - Method in class bb.common.LogPartDwfVO

setDescription(String) - Method in class bb.common.LogPartDwgVO

setDescription(String) - Method in class bb.common.LogTaskVO

setDescription(String) - Method in class bb.common.LogTrackingVO

setDescription(String) - Method in class bb.common.MultiLanguageAccountsChartVO

setDescription(String) - Method in class bb.common.NonConformanceCodeDescriptionVO

setDescription(String) - Method in class bb.common.NonproductivePickingItemIssuedVO

setDescription(String) - Method in class bb.common.NonproductivePickingItemResult

setDescription(String) - Method in class bb.common.NonproductivePickingItemVO

setDescription(String) - Method in class bb.common.NonproductivePickingOnDemandResult

setDescription(String) - Method in class bb.common.NoticeUserEmployeeListResult

setDescription(String) - Method in class bb.common.OnLoanItemVO

setDescription(String) - Method in class bb.common.OnloanReceiverItemListResult

setDescription(String) - Method in class bb.common.OnloanReceiverItemVO

setDescription(String) - Method in class bb.common.OnloanShipperItemVO

setDescription(String) - Method in class bb.common.OperatingInstructionsInspectStandardVO

setDescription(String) - Method in class bb.common.OperatingInstructionsManualVO

setDescription(String) - Method in class bb.common.OperatingInstructionsTypeVO

setDescription(String) - Method in class bb.common.OperatingOutputFileTypeVO

setDescription(String) - Method in class bb.common.OrderApprovalItemsVO

setDescription(String) - Method in class bb.common.OrderApprovalVO

setDescription(String) - Method in class bb.common.PackingBoxItemListResult

setDescription(String) - Method in class bb.common.PackingBoxItemVO

setDescription(String) - Method in class bb.common.PackingBoxSalesOrderItemResult

setDescription(String) - Method in class bb.common.PartBasicInfo

setDescription(String) - Method in class bb.common.PartCatalogAuditResult

setDescription(String) - Method in class bb.common.PartClassInfoResult

setDescription(String) - Method in class bb.common.PartDescriptionVO

setDescription(String) - Method in class bb.common.PartDocumentVO

setDescription(String) - Method in class bb.common.PartInMrpListResult

setDescription(String) - Method in class bb.common.PartInspectionResult

setDescription(String) - Method in class bb.common.PartInWipForIDListResult

setDescription(String) - Method in class bb.common.PartIssuedVO

setDescription(String) - Method in class bb.common.PartMaterialWhereUsedItemResult

setDescription(String) - Method in class bb.common.PartMaterialWhereUsedResult

setDescription(String) - Method in class bb.common.PartOnHandAuditResult

setDescription(String) - Method in class bb.common.PartOnhandResult

setDescription(String) - Method in class bb.common.PartReceivedVO

setDescription(String) - Method in class bb.common.PartToAuditFlagResult

setDescription(String) - Method in class bb.common.PartTypeVO

setDescription(String) - Method in class bb.common.PartUseTypeVO

setDescription(String) - Method in class bb.common.PartVO

setDescription(String) - Method in class bb.common.PartWhereUsedItemResult

setDescription(String) - Method in class bb.common.PartWithExcessiveInventoryListResult

setDescription(String) - Method in class bb.common.PartWithInventoryInfoListResult

setDescription(String) - Method in class bb.common.PartWithManufacturerInfoResult

setDescription(String) - Method in class bb.common.PartWithOnhandsVO

setDescription(String) - Method in class bb.common.PartWithOnLoanQtyListResult

setDescription(String) - Method in class bb.common.PartWithQAQtyListResult

setDescription(String) - Method in class bb.common.PartWithQtyListResult

setDescription(String) - Method in class bb.common.PartWithSipQtyListResult

setDescription(String) - Method in class bb.common.PartWithSITQtyListResult

setDescription(String) - Method in class bb.common.PartWithSTOQtyListResult

setDescription(String) - Method in class bb.common.PartWithWipQtyListResult

setDescription(String) - Method in class bb.common.PermissionDescriptionVO

setDescription(String) - Method in class bb.common.PermissionListResult

setDescription(String) - Method in class bb.common.PfReceiverItemVO

setDescription(String) - Method in class bb.common.PhysicalInventoryListResult

setDescription(String) - Method in class bb.common.PhysicalInventoryStatusVO

setDescription(String) - Method in class bb.common.POReceiverItemListResult

setDescription(String) - Method in class bb.common.POSurveyReportItemVO

setDescription(String) - Method in class bb.common.PosZipCodeTaxVO

setDescription(String) - Method in class bb.common.PreventiveActionRequestItemVO

setDescription(String) - Method in class bb.common.PreventiveActionRequestVO

setDescription(String) - Method in class bb.common.ProfitAndLossAccountsResult

setDescription(String) - Method in class bb.common.ProfitLossStatementItemResult

setDescription(String) - Method in class bb.common.ProformaInvoiceItemListResult

setDescription(String) - Method in class bb.common.ProformaInvoiceItemVO

setDescription(String) - Method in class bb.common.ProjectVO

setDescription(String) - Method in class bb.common.PrPackingBoxItemVO

setDescription(String) - Method in class bb.common.PrReceiverWithQualityListResult

setDescription(String) - Method in class bb.common.PurchaseOrderBoilerplateVO

setDescription(String) - Method in class bb.common.PurchaseOrderContractResult

setDescription(String) - Method in class bb.common.PurchaseOrderItemVO

setDescription(String) - Method in class bb.common.PurchaseOrderOnOrderResult

setDescription(String) - Method in class bb.common.PurchaseWorkSheetVO

setDescription(String) - Method in class bb.common.QuoteBoilerplateVO

setDescription(String) - Method in class bb.common.QuoteItemVO

setDescription(String) - Method in class bb.common.ReceiverItemAgent

setDescription(String) - Method in class bb.common.ReceiverItemVO

setDescription(String) - Method in class bb.common.ReceivingItemResult

setDescription(String) - Method in class bb.common.RequestForQuoteItemVO

setDescription(String) - Method in class bb.common.RequestForRMAItemVO

setDescription(String) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setDescription(String) - Method in class bb.common.ReturnToVendorByDateListResult

setDescription(String) - Method in class bb.common.ReturnToVendorItemVO

setDescription(String) - Method in class bb.common.RMAReceiverItemListResult

setDescription(String) - Method in class bb.common.RMAReceiverItemVO

setDescription(String) - Method in class bb.common.RMAReceiverResult

setDescription(String) - Method in class bb.common.RoleDescriptionVO

setDescription(String) - Method in class bb.common.RoleListResult

setDescription(String) - Method in class bb.common.RollUpBomStdCostWorkSheetItemVO

setDescription(String) - Method in class bb.common.RollUPPartStandardCostResult

setDescription(String) - Method in class bb.common.RtvShipperItemListResult

setDescription(String) - Method in class bb.common.RtvShipperItemVO

setDescription(String) - Method in class bb.common.SalesBomItemResult

setDescription(String) - Method in class bb.common.SalesBomResult

setDescription(String) - Method in class bb.common.SalesmanVO

setDescription(String) - Method in class bb.common.SalesOrder12MonthMarginResult

setDescription(String) - Method in class bb.common.SalesOrderBoilerplateVO

setDescription(String) - Method in class bb.common.SalesOrderItemGroupByPartListResult

setDescription(String) - Method in class bb.common.SalesOrderOnDemandResult

setDescription(String) - Method in class bb.common.SalesPartListItemResult

setDescription(String) - Method in class bb.common.SalesPartListResult

setDescription(String) - Method in class bb.common.SalesTaxListResult

setDescription(String) - Method in class bb.common.ScrapAssetAgent

setDescription(String) - Method in class bb.common.ScrapReportVO

setDescription(String) - Method in class bb.common.SerialNumberItemResult

setDescription(String) - Method in class bb.common.SerialNumberResult

setDescription(String) - Method in class bb.common.SGCustomerServiceRequestVO

setDescription(String) - Method in class bb.common.SGCustRequestForQuoteItemResult

setDescription(String) - Method in class bb.common.SGCustRequestForQuoteItemVO

setDescription(String) - Method in class bb.common.SGPartCatalogResult

setDescription(String) - Method in class bb.common.SGPartListItemResult

setDescription(String) - Method in class bb.common.SGPartListResult

setDescription(String) - Method in class bb.common.SGQuoteCartListResult

setDescription(String) - Method in class bb.common.SGSaleItemVO

setDescription(String) - Method in class bb.common.ShipListInfoVO

setDescription(String) - Method in class bb.common.ShipListItemRelatedDocResult

setDescription(String) - Method in class bb.common.ShipListItemVOResult

setDescription(String) - Method in class bb.common.ShipListOwnerVO

setDescription(String) - Method in class bb.common.ShipListVO

setDescription(String) - Method in class bb.common.ShipperItemListResult

setDescription(String) - Method in class bb.common.ShipperItemVO

setDescription(String) - Method in class bb.common.ShippingItemResult

setDescription(String) - Method in class bb.common.ShoppingCartItem

setDescription(String) - Method in class bb.common.StockTransactionPartInfoResult

setDescription(String) - Method in class bb.common.SubcompanyVO

setDescription(String) - Method in class bb.common.SwapOrderItemListResult

setDescription(String) - Method in class bb.common.SwapOrderItemVO

setDescription(String) - Method in class bb.common.SwapReceiverItemListResult

setDescription(String) - Method in class bb.common.SwapReceiverItemVO

setDescription(String) - Method in class bb.common.SwapShipperItemListResult

setDescription(String) - Method in class bb.common.SwapShipperItemVO

setDescription(String) - Method in class bb.common.SwapShipperOnOrderResult

setDescription(String) - Method in class bb.common.TakeCycleCountAgent

setDescription(String) - Method in class bb.common.TaskVO

setDescription(String) - Method in class bb.common.ToolDescriptionVO

setDescription(String) - Method in class bb.common.ToolVO

setDescription(String) - Method in class bb.common.ToolWhereUsedItemResult

setDescription(String) - Method in class bb.common.ToolWithOnhandsVO

setDescription(String) - Method in class bb.common.TransferOrderItemListResult

setDescription(String) - Method in class bb.common.TransferOrderItemVO

setDescription(String) - Method in class bb.common.TransferReceiverItemListResult

setDescription(String) - Method in class bb.common.TransferReceiverItemVO

setDescription(String) - Method in class bb.common.TransferShipperItemListResult

setDescription(String) - Method in class bb.common.TransferShipperItemVO

setDescription(String) - Method in class bb.common.UserGroupVO

setDescription(String) - Method in class bb.common.VendorCategoriesVO

setDescription(String) - Method in class bb.common.VendorContractPriceItemVO

setDescription(String) - Method in class bb.common.VendorContractPriceVO

setDescription(String) - Method in class bb.common.VendorCriticalLevelVO

setDescription(String) - Method in class bb.common.WareHousePartPrefixKeeperVO

setDescription(String) - Method in class bb.common.WC2WCAgent

setDescription(String) - Method in class bb.common.WCLoadByDateResult

setDescription(String) - Method in class bb.common.WCLoadDetailResult

setDescription(String) - Method in class bb.common.WOItemPartDetailNotIssue

setDescription(String) - Method in class bb.common.WoItemPickListItemResult

setDescription(String) - Method in class bb.common.WoItemPickListResult

setDescription(String) - Method in class bb.common.WoItemWorkInstructionListResult

setDescription(String) - Method in class bb.common.WOReceiverDetail

setDescription(String) - Method in class bb.common.WorkCenterLoadListResult

setDescription(String) - Method in class bb.common.WorkCenterRunTimeListResult

setDescription(String) - Method in class bb.common.WorkCenterVO

setDescription(String) - Method in class bb.common.WorkFlowVO

setDescription(String) - Method in class bb.common.WorkInstructionSequenceVO

setDescription(String) - Method in class bb.common.WorkInstructionSummaryResult

setDescription(String) - Method in class bb.common.WorkInstructionVO

setDescription(String) - Method in class bb.common.WorkOrderBoilerplateVO

setDescription(String) - Method in class bb.common.WorkOrderIssueStatisticsResult

setDescription(String) - Method in class bb.common.WorkOrderItemCanAssyResult

setDescription(String) - Method in class bb.common.WorkOrderItemInfoResult

setDescription(String) - Method in class bb.common.WorkOrderItemIssuedTotalResult

setDescription(String) - Method in class bb.common.WorkOrderItemIssueVO

setDescription(String) - Method in class bb.common.WorkOrderItemLaborCostListResult

setDescription(String) - Method in class bb.common.WorkOrderItemPartDetailInWipVO

setDescription(String) - Method in class bb.common.WorkOrderItemPartDetailResult

setDescription(String) - Method in class bb.common.WorkOrderItemReviewCostResult

setDescription(String) - Method in class bb.common.WorkOrderItemTimeDetailResult

setDescription(String) - Method in class bb.common.WorkOrderItemTimeDetailVO

setDescription(String) - Method in class bb.common.WorkOrderItemToIssueResult

setDescription(String) - Method in class bb.common.WorkOrderItemVO

setDescription(String) - Method in class bb.common.WorkOrderItemWCLoadResult

setDescription(String) - Method in class bb.common.WorkOrderOnDemandResult

setDescription(String) - Method in class bb.common.WorkOrderOnOrderResult

setDescription(String) - Method in class bb.common.WorkOrderQueryInfo

setDescription(String) - Method in class bb.common.WorkOrderReceiverVO

setDescription(String) - Method in class bb.common.WorkOrderWorkInstructionListResult

setDescription(String) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setDescription(String) - Method in class bb.common.WorkOrderWorkInstructionVO

setDescription(String) - Method in class bb.common.WorkOrderWorkSheetVO

setDescription(String) - Method in class bb.common.ZipcodeTotalsResult

setDescription2(String) - Method in class bb.common.WorkInstructionSequenceVO

setDescription2(String) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setDescription3(String) - Method in class bb.common.WorkInstructionSequenceVO

setDescription3(String) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setDescriptionOfChange(String) - Method in class bb.common.WorkInstructionRequestForChangeVO

setDescriptions(Set<NonConformanceCodeDescriptionVO>) - Method in class bb.common.NonConformanceCodeVO

setDesignControlNumber(String) - Method in class bb.common.DesignControlDocumentVO

setDesignControlNumber(String) - Method in class bb.common.DesignControlInfoVO

setDesignControlNumber(String) - Method in class bb.common.DesignControlVO

setDesignInputDescription(String) - Method in class bb.common.DesignControlInfoVO

setDesignInputDescription(String) - Method in class bb.common.DesignControlVO

setDesignOutputDescription(String) - Method in class bb.common.DesignControlInfoVO

setDesignOutputDescription(String) - Method in class bb.common.DesignControlVO

setDesignReviewDescription(String) - Method in class bb.common.DesignControlInfoVO

setDesignReviewDescription(String) - Method in class bb.common.DesignControlVO

setDesignValidationDescription(String) - Method in class bb.common.DesignControlInfoVO

setDesignValidationDescription(String) - Method in class bb.common.DesignControlVO

setDesignVerificationDescription(String) - Method in class bb.common.DesignControlInfoVO

setDesignVerificationDescription(String) - Method in class bb.common.DesignControlVO

setDesired(Date) - Method in class bb.common.DisassembleWorkOrderItemVO

setDesired(Date) - Method in class bb.common.DisassembleWorkOrderVO

setDesired(Date) - Method in class bb.common.OnLoanItemVO

setDesired(Date) - Method in class bb.common.OnLoanVO

setDesired(String) - Method in class bb.common.QuoteVO

setDesired(Date) - Method in class bb.common.SalesOrderVO

setDesired(Date) - Method in class bb.common.WorkOrderItemVO

setDesired(Date) - Method in class bb.common.WorkOrderVO

setDesiredDate(Date) - Method in class bb.common.NonproductivePickingItemVO

setDesiredDate(Date) - Method in class bb.common.QuoteItemVO

setDesiredDate(Date) - Method in class bb.common.SalesOrderItemInfoVO

setDesiredDate(Date) - Method in class bb.common.SalesOrderItemVO

setDesiredDate(Date) - Method in class bb.common.SwapOrderItemListResult

setDesiredDate(Date) - Method in class bb.common.SwapOrderItemVO

setDesiredDate(Date) - Method in class bb.common.TransferOrderItemListResult

setDesiredDate(Date) - Method in class bb.common.TransferOrderItemVO

setDetailDescription(String) - Method in class bb.common.CustomerServiceIncidentVO

setDetails(List<PartInQAVO>) - Method in class bb.common.BB2PartTotalInQADetailResult

setDetails(ArrayList) - Method in class bb.common.BB2PartTotalInSipDetailResult

setDetails(ArrayList) - Method in class bb.common.BB2PartTotalInSitDetailResult

setDetails(ArrayList) - Method in class bb.common.BB2PartTotalInSTODetailResult

setDetails(ArrayList) - Method in class bb.common.BB2PartTotalInWipDetailResult

setDetails(ArrayList) - Method in class bb.common.BB2PartTotalOnhandDetailResult

setDetails(ArrayList) - Method in class bb.common.BB2PartTotalOnloanDetailResult

setDetails(List) - Method in class bb.common.PartWithOnhandDetailInfoResult

setDetectionStandard(String) - Method in class bb.common.PartBasicInfo

setDetectionStandard(String) - Method in class bb.common.PartVO

setDicount(BigDecimal) - Method in class bb.common.InvoiceItemListResult

setDiffCost(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

setDiffCost(BigDecimal) - Method in class bb.common.WOItemCostControlAgent

setDiffCost(BigDecimal) - Method in class bb.common.WorkOrderItemPartDetailResult

setDiffCost(BigDecimal) - Method in class bb.common.WorkOrderItemReviewCostResult

setDiffcount(BigDecimal) - Method in class bb.common.CycleCountListResult

setDiffCount(BigDecimal) - Method in class bb.common.CycleCountVO

setDiffcount(BigDecimal) - Method in class bb.common.PhysicalInventoryListResult

setDiffCount(BigDecimal) - Method in class bb.common.PhysicalInventoryVO

setDimension(String) - Method in class bb.common.PackingBoxVO

setDimension(String) - Method in class bb.common.PrPackingBoxVO

setDir(String) - Method in class bb.common.DocumentLogVO

setDirectlyPrintAR(boolean) - Method in class bb.common.PointOfSaleVO

setDirectMaterialPriceVarianceAccount(String) - Method in class bb.common.AccountingSettingsVO

setDirectMaterialUsageVarianceAccount(String) - Method in class bb.common.AccountingSettingsVO

setDisassembleIssuingItems(Set<DisassembleWorkOrderIssuingItemResult>) - Method in class bb.common.DisassembleWorkOrderIssuingResult

setDisassembleWorkOrderComments(String) - Method in class bb.common.DisassembleWorkOrderListResult

setDisassembleWorkOrderComments(String) - Method in class bb.common.DisassembleWorkOrderVO

setDisassembleWorkOrderItem(Set) - Method in class bb.common.DisassembleWorkOrderVO

setDisassembleWorkOrderItemComments(String) - Method in class bb.common.DisassembleWorkOrderItemVO

setDisassembleWorkOrderItemNumber(String) - Method in class bb.common.DisassembleWorkOrderIssueVO

setDisassembleWorkOrderItemNumber(String) - Method in class bb.common.DisassembleWorkOrderItemPK

setDisassembleWorkOrderItemNumber(String) - Method in class bb.common.DisassembleWorkOrderItemReceiverPK

setDisassembleWorkOrderItemNumber(String) - Method in class bb.common.DWOIssueDetail

setDisassembleWorkOrderItemNumber(String) - Method in class bb.common.PartReceivedVO

setDisassembleWorkOrderItemPk(DisassembleWorkOrderItemPK) - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

setDisassembleWorkOrderItemPrivateNotes(String) - Method in class bb.common.DisassembleWorkOrderItemVO

setDisassembleWorkOrderNumber(String) - Method in class bb.common.DisassembleWorkOrderIssueVO

setDisassembleWorkOrderNumber(String) - Method in class bb.common.DisassembleWorkOrderItemPK

setDisassembleWorkOrderNumber(String) - Method in class bb.common.DisassembleWorkOrderItemReceiverPK

setDisassembleWorkOrderNumber(String) - Method in class bb.common.DisassembleWorkOrderVO

setDisassembleWorkOrderNumber(String) - Method in class bb.common.DWOIssueDetail

setDisassembleWorkOrderNumber(String) - Method in class bb.common.PartReceivedVO

setDisassembleWorkOrderPrivateNotes(String) - Method in class bb.common.DisassembleWorkOrderListResult

setDisassembleWorkOrderPrivateNotes(String) - Method in class bb.common.DisassembleWorkOrderVO

setDisassembleWorkOrderReceivingItems(Set) - Method in class bb.common.DisassembleWorkOrderReceivingResult

setDiscount(BigDecimal) - Method in class bb.common.AccountsPayableItemVO

setDiscount(BigDecimal) - Method in class bb.common.AccountsReceivableItemVO

setDiscount(BigDecimal) - Method in class bb.common.APItemListResult

setDiscount(BigDecimal) - Method in class bb.common.ContractPriceItemVO

setDiscount(BigDecimal) - Method in class bb.common.CRTVItemListResult

setDiscount(BigDecimal) - Method in class bb.common.CustomerReturnToVendorItemVO

setDiscount(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemVO

setDiscount(BigDecimal) - Method in class bb.common.GeneralLedgerListResult

setDiscount(BigDecimal) - Method in class bb.common.GeneralLedgerResult

setDiscount(BigDecimal) - Method in class bb.common.GeneralLedgerVO

setDiscount(BigDecimal) - Method in class bb.common.OnLoanItemListResult

setDiscount(BigDecimal) - Method in class bb.common.OnLoanItemVO

setDiscount(BigDecimal) - Method in class bb.common.OnloanReceiverItemVO

setDiscount(BigDecimal) - Method in class bb.common.OnloanShipperItemVO

setDiscount(BigDecimal) - Method in class bb.common.OrderApprovalItemsVO

setDiscount(BigDecimal) - Method in class bb.common.PfReceiverItemVO

setDiscount(BigDecimal) - Method in class bb.common.PO2SOExchangeItem

setDiscount(BigDecimal) - Method in class bb.common.PoMessageItemVO

setDiscount(BigDecimal) - Method in class bb.common.POReceiverItemListResult

setDiscount(BigDecimal) - Method in class bb.common.ProformaInvoiceItemVO

setDiscount(BigDecimal) - Method in class bb.common.PurchaseOrderItemListResult

setDiscount(BigDecimal) - Method in class bb.common.PurchaseOrderItemVO

setDiscount(BigDecimal) - Method in class bb.common.QuoteItemListResult

setDiscount(BigDecimal) - Method in class bb.common.QuoteItemVO

setDiscount(BigDecimal) - Method in class bb.common.ReceiverItemVO

setDiscount(BigDecimal) - Method in class bb.common.RequestForQuoteItemListResult

setDiscount(BigDecimal) - Method in class bb.common.RequestForQuoteItemVO

setDiscount(BigDecimal) - Method in class bb.common.RequestForRMAItemVO

setDiscount(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setDiscount(BigDecimal) - Method in class bb.common.ReturnToVendorByDateListResult

setDiscount(BigDecimal) - Method in class bb.common.ReturnToVendorItemListResult

setDiscount(BigDecimal) - Method in class bb.common.ReturnToVendorItemVO

setDiscount(BigDecimal) - Method in class bb.common.RfqMessageItemVO

setDiscount(BigDecimal) - Method in class bb.common.RMAItemListResult

setDiscount(BigDecimal) - Method in class bb.common.RMAReceiverItemVO

setDiscount(BigDecimal) - Method in class bb.common.RRMAItemListResult

setDiscount(BigDecimal) - Method in class bb.common.RtvShipperItemVO

setDiscount(BigDecimal) - Method in class bb.common.RunningAccountOrderItemVO

setDiscount(BigDecimal) - Method in class bb.common.SalesOrderItemInfoVO

setDiscount(BigDecimal) - Method in class bb.common.SalesOrderItemListResult

setDiscount(BigDecimal) - Method in class bb.common.SalesOrderItemVO

setDiscount(BigDecimal) - Method in class bb.common.ShipperItemVO

setDiscount(BigDecimal) - Method in class bb.common.TermAgent

setDiscount(BigDecimal) - Method in class bb.common.TermVO

setDiscount(BigDecimal) - Method in class bb.common.VendorContractPriceItemVO

setDiscount(BigDecimal) - Method in class bb.common.VendorPriceAgent

setDiscount(BigDecimal) - Method in class bb.common.VendorQtyPriceVO

setDiscount(BigDecimal) - Method in class bb.common.WorkOrderItemVO

setDiscountable(boolean) - Method in class bb.common.PartVO

setDiscountable(boolean) - Method in class bb.common.RunningAccountOrderItemVO

setDiscountCode(String) - Method in class bb.common.SalesOrderItemInfoVO

setDiscountCode(String) - Method in class bb.common.SalesOrderItemVO

setDiscountRate(BigDecimal) - Method in class bb.common.PartDiscountVO

setDiscountTotal(BigDecimal) - Method in class bb.common.AccountingTotalMoneyResult

setDiscountTotal(BigDecimal) - Method in class bb.common.ArCommissionTotalResult

setDiscountTotal(BigDecimal) - Method in class bb.common.ArSalesCodeTotalListResult

setDiscountTotal(BigDecimal) - Method in class bb.common.DuePATotalByVendorResult

setDiscountTotal(BigDecimal) - Method in class bb.common.SalesTaxListResult

setDiscRate(BigDecimal) - Method in class bb.common.ShipperItemListResult

setDiscTotal(BigDecimal) - Method in class bb.common.RunningAccountOrderVO

setDisplayName(String) - Method in class bb.common.AppColumnVO

setDisplayName(String) - Method in class bb.common.SmtpServerVO

setDisposalBy(String) - Method in class bb.common.SGCustomerServiceRequestVO

setDisposalDescription(String) - Method in class bb.common.SGCustomerServiceRequestVO

setDispositionApprovedEng(String) - Method in class bb.common.NonConformanceReportVO

setDispositionApprovedMfg(String) - Method in class bb.common.NonConformanceReportVO

setDispositionApprovedQa(String) - Method in class bb.common.NonConformanceReportVO

setDispositionDate(Date) - Method in class bb.common.NonConformanceReportVO

setDispositionOfChange(String) - Method in class bb.common.EngineeringChangeRequestListResult

setDispositionOfChange(String) - Method in class bb.common.EngineeringChangeRequestVO

setDistrict(String) - Method in class bb.common.WareHousePartPrefixKeeperVO

setDivision(String) - Method in class bb.common.SGCompanyPK

setDivision(String) - Method in class bb.common.SGCustRequestForQuoteVO

setDivision(String) - Method in class bb.common.SGLogLoginVO

setDivision(String) - Method in class bb.common.SGQuoteAddressVO

setDivision(String) - Method in class bb.common.SGQuoteLoginVO

setDmDigits(byte) - Method in class bb.common.CompanyVO

setDmPrefix(String) - Method in class bb.common.CompanyVO

setDocDescription(String) - Method in class bb.common.DisassembleWorkOrderDocumentVO

setDocDescription(String) - Method in class bb.common.EngineeringChangeDocumentVO

setDocDescription(String) - Method in class bb.common.EngineeringChangeRequestDocumentVO

setDocDescription(String) - Method in class bb.common.MiscDocAgent

setDocDescription(String) - Method in class bb.common.OnloanDocumentVO

setDocDescription(String) - Method in class bb.common.OrderDocumentVO

setDocDescription(String) - Method in class bb.common.PurchaseOrderDocumentVO

setDocDescription(String) - Method in class bb.common.SalesOrderDocumentVO

setDocDescription(String) - Method in class bb.common.WorkInstructionDocumentVO

setDocDescription(String) - Method in class bb.common.WorkOrderDocumentVO

setDocFileName(String) - Method in class bb.common.DisassembleWorkOrderDocumentVO

setDocFileName(String) - Method in class bb.common.EngineeringChangeDocumentVO

setDocFileName(String) - Method in class bb.common.EngineeringChangeRequestDocumentVO

setDocFileName(String) - Method in class bb.common.LogMiscDocumentVO

setDocFileName(String) - Method in class bb.common.OnloanDocumentVO

setDocFileName(String) - Method in class bb.common.OrderDocumentVO

setDocFileName(String) - Method in class bb.common.PurchaseOrderDocumentVO

setDocFileName(String) - Method in class bb.common.SalesOrderDocumentVO

setDocFileName(String) - Method in class bb.common.WorkInstructionDocumentVO

setDocFileName(String) - Method in class bb.common.WorkOrderDocumentVO

setDocFlags(Set<SGPartDocFlagResult>) - Method in class bb.common.SGPartListResult

setDocLength(long) - Method in class bb.common.AccountingInfoDocumentVO

setDocLength(long) - Method in class bb.common.CustomerServiceIncidentItemVO

setDocLength(long) - Method in class bb.common.DesignControlDocumentVO

setDocLength(long) - Method in class bb.common.DisassembleWorkOrderDocumentVO

setDocLength(long) - Method in class bb.common.EmployeeRecordsVO

setDocLength(long) - Method in class bb.common.EngineeringChangeDocumentVO

setDocLength(long) - Method in class bb.common.EngineeringChangeRequestDocumentVO

setDocLength(long) - Method in class bb.common.LogMiscDocumentVO

setDocLength(long) - Method in class bb.common.MiscDocAgent

setDocLength(long) - Method in class bb.common.OnloanDocumentVO

setDocLength(long) - Method in class bb.common.OrderDocumentVO

setDocLength(long) - Method in class bb.common.PartCertificateListResult

setDocLength(long) - Method in class bb.common.PartCertificateVO

setDocLength(long) - Method in class bb.common.PreventiveActionRequestItemVO

setDocLength(long) - Method in class bb.common.PurchaseOrderDocumentVO

setDocLength(long) - Method in class bb.common.QuoteDocumentVO

setDocLength(long) - Method in class bb.common.ReturnMaterialAuthorizationDocumentVO

setDocLength(long) - Method in class bb.common.SalesOrderDocumentVO

setDocLength(long) - Method in class bb.common.WorkInstructionDocumentVO

setDocLength(long) - Method in class bb.common.WorkOrderDocumentVO

setDocName(String) - Method in class bb.common.AccountingInfoDocumentVO

setDocName(String) - Method in class bb.common.AddressQualityDocumentsVO

setDocName(String) - Method in class bb.common.CustomerServiceIncidentItemVO

setDocName(String) - Method in class bb.common.DesignControlDocumentVO

setDocName(String) - Method in class bb.common.EmployeeRecordsVO

setDocName(String) - Method in class bb.common.MiscDocAgent

setDocName(String) - Method in class bb.common.PartCertificateListResult

setDocName(String) - Method in class bb.common.PartCertificateVO

setDocName(String) - Method in class bb.common.PreventiveActionRequestItemVO

setDocName(String) - Method in class bb.common.QuoteDocumentVO

setDocName(String) - Method in class bb.common.ReturnMaterialAuthorizationDocumentVO

setDocType(String) - Method in class bb.common.AddressQualityDocumentsVO

setDocType(String) - Method in class bb.common.LogMiscDocumentVO

setDocType(String) - Method in class bb.common.MiscDocAgent

setDocType(String) - Method in class bb.common.OrderDocumentVO

setDocType(boolean) - Method in class bb.common.PartTypeVO

setDocument(byte[]) - Method in class bb.common.AccountingInfoDocumentVO

setDocument(byte[]) - Method in class bb.common.MiscDocAgent

setDocument(byte[]) - Method in class bb.common.TermsConditionVO

setDocumentDate(Date) - Method in class bb.common.AccountingInfoDocumentVO

setDocumentDate(Date) - Method in class bb.common.DesignControlDocumentVO

setDocumentDate(Date) - Method in class bb.common.DisassembleWorkOrderDocumentVO

setDocumentDate(Date) - Method in class bb.common.EngineeringChangeDocumentVO

setDocumentDate(Date) - Method in class bb.common.EngineeringChangeRequestDocumentVO

setDocumentDate(Date) - Method in class bb.common.MiscDocAgent

setDocumentDate(Date) - Method in class bb.common.OnloanDocumentVO

setDocumentDate(Date) - Method in class bb.common.OrderDocumentVO

setDocumentDate(Date) - Method in class bb.common.PurchaseOrderDocumentVO

setDocumentDate(Date) - Method in class bb.common.QuoteDocumentVO

setDocumentDate(Date) - Method in class bb.common.ReturnMaterialAuthorizationDocumentVO

setDocumentDate(Date) - Method in class bb.common.SalesOrderDocumentVO

setDocumentDate(Date) - Method in class bb.common.WorkInstructionDocumentVO

setDocumentDate(Date) - Method in class bb.common.WorkOrderDocumentVO

setDocumentDescription(String) - Method in class bb.common.AddressQualityDocumentsVO

setDocumentDescription(String) - Method in class bb.common.QuoteDocumentVO

setDocumentDescription(String) - Method in class bb.common.ReturnMaterialAuthorizationDocumentVO

setDocumentExtension(String) - Method in class bb.common.AddressQualityDocumentsVO

setDocumentLength(Long) - Method in class bb.common.AddressQualityDocumentsVO

setDocumentLengthByte(Long) - Method in class bb.common.AllPartDocumentsVO

setDocumentLengthByte(Long) - Method in class bb.common.LogPartDocumentVO

setDocumentLengthByte(Long) - Method in class bb.common.PartDocumentVO

setDocumentType(String) - Method in class bb.common.AllPartDocumentsPK

setDocumentType(String) - Method in class bb.common.DocumentInfoAgent

setDocumentType(String) - Method in class bb.common.DocumentServerVO

setDocumentType(String) - Method in class bb.common.LogPartDocumentVO

setDocumentType(String) - Method in class bb.common.MiscDocumentSettingVO

setDocumentType(String) - Method in class bb.common.PartDocumentPK

setDocVersion(String) - Method in class bb.common.AllPartDocumentsPK

setDocVersion(String) - Method in class bb.common.LogPartDocumentVO

setDocVersion(String) - Method in class bb.common.PartDocumentVO

setDoNotIssueToWo(String) - Method in class bb.common.PartMRPVO

setDoNotKeepInInventory(String) - Method in class bb.common.PartMRPVO

setDoNotUseInMrp(String) - Method in class bb.common.PartMRPVO

setDrawing(String) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setDrawing(String) - Method in class bb.common.DisassembleWorkOrderReceivingResult

setDrawing(String) - Method in class bb.common.IssuingResult

setDrawing(String) - Method in class bb.common.NonConformanceReportVO

setDrawing(String) - Method in class bb.common.PartBasicInfo

setDrawing(byte[]) - Method in class bb.common.PartDwfAgent

setDrawing(String) - Method in class bb.common.PartVO

setDrawing(String) - Method in class bb.common.PartWhereUsedItemResult

setDrawing(String) - Method in class bb.common.PartWithManufacturerInfoResult

setDrawing(String) - Method in class bb.common.PartWithOnhandsVO

setDrawing(String) - Method in class bb.common.ReceivingItemResult

setDrawing(String) - Method in class bb.common.SalesBomItemResult

setDrawing(String) - Method in class bb.common.SalesBomResult

setDrawing(String) - Method in class bb.common.SGPartCatalogResult

setDrawing(boolean) - Method in class bb.common.SGPartListResult

setDrawing(String) - Method in class bb.common.ShippingItemResult

setDrawing(String) - Method in class bb.common.ToolVO

setDrawing(String) - Method in class bb.common.ToolWhereUsedItemResult

setDrawing(String) - Method in class bb.common.ToolWithOnhandsVO

setDrawingNumber(String) - Method in class bb.common.InspectionReportInfoVO

setDrawingNumber(String) - Method in class bb.common.InspectionReportVO

setDrawingNumber(String) - Method in class bb.common.OperatingInstructionsVO

setDrawingNumber(String) - Method in class bb.common.PartVO

setDrawingNumber(String) - Method in class bb.common.PartWithOnhandsVO

setDrawingRev(String) - Method in class bb.common.PartVO

setDrawingRev(String) - Method in class bb.common.PartWithOnhandsVO

setDrawingRevisedDate(Date) - Method in class bb.common.EngineeringChangeVO

setDrawingRevision(String) - Method in class bb.common.PartDwfAgent

setDrawingType(String) - Method in class bb.common.DwfUploadSettingsVO

setDrawingType(String) - Method in class bb.common.DwgUploadSettingsVO

setDt(String) - Method in class bb.common.DesignControlDocumentVO

setDt(String) - Method in class bb.common.QuoteDocumentVO

setDue(BigDecimal) - Method in class bb.common.AccountPayableCheckRunItemVO

setDue(BigDecimal) - Method in class bb.common.AccountPayableInfoWithPrepayResult

setDue(BigDecimal) - Method in class bb.common.AccountsPayableInfoVO

setDue(BigDecimal) - Method in class bb.common.AccountsPayableItemVO

setDue(BigDecimal) - Method in class bb.common.AccountsPayableVO

setDue(BigDecimal) - Method in class bb.common.AccountsReceivableItemVO

setDue(BigDecimal) - Method in class bb.common.APItemListResult

setDue(BigDecimal) - Method in class bb.common.ARPaymentRunItemVO

setDue(BigDecimal) - Method in class bb.common.InvoiceItemListResult

setDue(BigDecimal) - Method in class bb.common.OnloanReceiverItemVO

setDue(BigDecimal) - Method in class bb.common.OnloanReceiverVO

setDue(BigDecimal) - Method in class bb.common.OnloanShipperItemVO

setDue(BigDecimal) - Method in class bb.common.OnloanShipperVO

setDue(BigDecimal) - Method in class bb.common.ProformaInvoiceVO

setDue(BigDecimal) - Method in class bb.common.ReceiverInfoVO

setDue(BigDecimal) - Method in class bb.common.ReceiverItemVO

setDue(BigDecimal) - Method in class bb.common.ReceiverVO

setDue(BigDecimal) - Method in class bb.common.RMAReceiverItemVO

setDue(BigDecimal) - Method in class bb.common.RMAReceiverVO

setDue(BigDecimal) - Method in class bb.common.RtvShipperInfoVO

setDue(BigDecimal) - Method in class bb.common.RtvShipperItemVO

setDue(BigDecimal) - Method in class bb.common.RtvShipperVO

setDue(BigDecimal) - Method in class bb.common.ShipperInfoVO

setDue(BigDecimal) - Method in class bb.common.ShipperItemVO

setDue(BigDecimal) - Method in class bb.common.ShipperVO

setDue(BigDecimal) - Method in class bb.common.TempArApAgingVO

setDue1To30Total(BigDecimal) - Method in class bb.common.CustomerStatementTotalResult

setDue31To60Total(BigDecimal) - Method in class bb.common.CustomerStatementTotalResult

setDue61To90Total(BigDecimal) - Method in class bb.common.CustomerStatementTotalResult

setDue91Total(BigDecimal) - Method in class bb.common.CustomerStatementTotalResult

setDueDate(Date) - Method in class bb.common.CorrectiveActionRequestVO

setDueDate(Date) - Method in class bb.common.CustomerServiceIncidentItemListResult

setDueDate(Date) - Method in class bb.common.CustomerServiceIncidentListResult

setDueDate(Date) - Method in class bb.common.CustomerServiceIncidentVO

setDueDate(Date) - Method in class bb.common.DesignControlInfoVO

setDueDate(Date) - Method in class bb.common.DesignControlListResult

setDueDate(Date) - Method in class bb.common.DesignControlVO

setDueDate(Date) - Method in class bb.common.DisassembleWorkOrderItemListResult

setDueDate(Date) - Method in class bb.common.EngineeringChangeListResult

setDueDate(Date) - Method in class bb.common.EngineeringChangeRequestListResult

setDueDate(Date) - Method in class bb.common.EngineeringChangeRequestVO

setDueDate(Date) - Method in class bb.common.EngineeringChangeVO

setDueDate(Date) - Method in class bb.common.JobProcessSheetListResult

setDueDate(Date) - Method in class bb.common.JobProcessSheetResult

setDueDate(Date) - Method in class bb.common.NcrNeedToScrapListResult

setDueDate(Date) - Method in class bb.common.NcrReportListResult

setDueDate(Date) - Method in class bb.common.NonConformanceReportVO

setDueDate(Date) - Method in class bb.common.PartTrackingVO

setDueDate(Date) - Method in class bb.common.PreventiveActionRequestVO

setDueDate(Date) - Method in class bb.common.PurchaseOrderOpenDueListResult

setDueDate(Date) - Method in class bb.common.PurchaseWorkSheetVO

setDueDate(Date) - Method in class bb.common.ReceiverItemTrackingLogAgent

setDueDate(Date) - Method in class bb.common.WoItemWorkInstructionListResult

setDueDate(Date) - Method in class bb.common.WorkCenterRunTimeListResult

setDueDate(Date) - Method in class bb.common.WorkInstructionRequestForChangeVO

setDueDate(Date) - Method in class bb.common.WorkOrderCheckListResult

setDueDate(Date) - Method in class bb.common.WorkOrderItemListResult

setDueDate(Date) - Method in class bb.common.WorkOrderQueryInfo

setDueDate(Date) - Method in class bb.common.WorkOrderWorkSheetVO

setDueOriginalPromisePurchaseAccount(BigDecimal) - Method in class bb.common.PurchasingInfoCenterResult

setDueOriginalPromiseSalesAccount(BigDecimal) - Method in class bb.common.SalesInfoCenterResult

setDuePOItemOf12MonthAvg(Integer) - Method in class bb.common.PurchaseOrderOnTimeResult

setDuePOItemOfFiscalYear(Integer) - Method in class bb.common.PurchaseOrderOnTimeResult

setDuePOItemOfLastMonth(Integer) - Method in class bb.common.PurchaseOrderOnTimeResult

setDuePOItemOfThisMonth(Integer) - Method in class bb.common.PurchaseOrderOnTimeResult

setDuePOItemOfYtd(Integer) - Method in class bb.common.PurchaseOrderOnTimeResult

setDuePOTotalof12MonthAvg(BigDecimal) - Method in class bb.common.PurchaseOrderOnTimeResult

setDuePOTotalofFiscalYear(BigDecimal) - Method in class bb.common.PurchaseOrderOnTimeResult

setDuePOTotalofLastMonth(BigDecimal) - Method in class bb.common.PurchaseOrderOnTimeResult

setDuePOTotalofThisMonth(BigDecimal) - Method in class bb.common.PurchaseOrderOnTimeResult

setDuePOTotalofYtd(BigDecimal) - Method in class bb.common.PurchaseOrderOnTimeResult

setDuePurchaseAccount(BigDecimal) - Method in class bb.common.PurchasingInfoCenterResult

setDuePurchaseCount(Integer) - Method in class bb.common.PurchasingInfoCenterResult

setDueSoCount(SalesInfoCenter.DueSoCount) - Method in class bb.common.SalesInfoCenter

setDueSOCount(Integer) - Method in class bb.common.WareHousingInfoCenterResult

setDueSoSum(SalesInfoCenter.DueSoSum) - Method in class bb.common.SalesInfoCenter

setDutyFree(boolean) - Method in class bb.common.CustomerVendorAddressInfoVO

setDutyFree(boolean) - Method in class bb.common.CustomerVendorAddressVO

setDutyFree(boolean) - Method in class bb.common.RunningAccountOrderItemVO

setDutyFreeNumber(String) - Method in class bb.common.RunningAccountOrderVO

setDwfAddedCurrentMonthCount(Integer) - Method in class bb.common.EngineeringInfoCenterResult

setDwfAddedLastMonthCount(Integer) - Method in class bb.common.EngineeringInfoCenterResult

setDwfCount(Integer) - Method in class bb.common.EngineeringInfoCenterResult

setDwfExtension(String) - Method in class bb.common.LogPartDwfVO

setDwfExtension(String) - Method in class bb.common.PartDwfWithPartInfoResult

setDwfLength(long) - Method in class bb.common.LogPartDwfVO

setDwfLength(long) - Method in class bb.common.PartDwfWithPartInfoResult

setDwg(String) - Method in class bb.common.BB2PartInfo

setDwg(String) - Method in class bb.common.BillItemSalesXResult

setDwg(String) - Method in class bb.common.BillSalesXResult

setDwg(String) - Method in class bb.common.BomItemWithOEMResult

setDwg(String) - Method in class bb.common.BomPickListItemResult

setDwg(String) - Method in class bb.common.BomWithOEMResult

setDwg(String) - Method in class bb.common.CustomerReturnToVendorItemVO

setDwg(String) - Method in class bb.common.DisassembleWorkOrderItemVO

setDwg(String) - Method in class bb.common.InventoryNotUsedInMonthsResult

setDwg(String) - Method in class bb.common.NonproductivePickingItemVO

setDwg(String) - Method in class bb.common.OnLoanItemVO

setDwg(String) - Method in class bb.common.OrderApprovalItemsVO

setDwg(String) - Method in class bb.common.PartWithInventoryInfoListResult

setDwg(String) - Method in class bb.common.POSurveyReportItemVO

setDwg(String) - Method in class bb.common.PurchaseOrderItemVO

setDwg(String) - Method in class bb.common.QuoteItemVO

setDwg(String) - Method in class bb.common.RequestForQuoteItemVO

setDwg(String) - Method in class bb.common.RequestForRMAItemVO

setDwg(String) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setDwg(String) - Method in class bb.common.ReturnToVendorItemVO

setDwg(String) - Method in class bb.common.SalesOrderItemInfoVO

setDwg(String) - Method in class bb.common.SalesOrderItemVO

setDwg(String) - Method in class bb.common.SGBOMItemResult

setDwg(String) - Method in class bb.common.StockTransactionPartInfoResult

setDwg(String) - Method in class bb.common.SwapOrderItemVO

setDwg(String) - Method in class bb.common.SwapReceiverItemVO

setDwg(String) - Method in class bb.common.SwapShipperItemVO

setDwg(String) - Method in class bb.common.TransferOrderItemVO

setDwg(String) - Method in class bb.common.TransferReceiverItemListResult

setDwg(String) - Method in class bb.common.TransferReceiverItemVO

setDwg(String) - Method in class bb.common.TransferShipperItemListResult

setDwg(String) - Method in class bb.common.WorkOrderItemVO

setDwgExtension(String) - Method in class bb.common.LogPartDwgVO

setDwgExtension(String) - Method in class bb.common.PartDwfVO

setDwgExtension(String) - Method in class bb.common.PartDwgVO

setDwgExtension(String) - Method in class bb.common.PartDwgWithPartInfoResult

setDwgLength(long) - Method in class bb.common.LogPartDwgVO

setDwgLength(long) - Method in class bb.common.PartDwfVO

setDwgLength(int) - Method in class bb.common.PartDwgAgent

setDwgLength(long) - Method in class bb.common.PartDwgVO

setDwgLength(long) - Method in class bb.common.PartDwgWithPartInfoResult

setDwoDate(Date) - Method in class bb.common.DisassembleWorkOrderListResult

setDwoDetails(ArrayList) - Method in class bb.common.BB2PartTotalInWipDetailResult

setDwoDetails(ArrayList) - Method in class bb.common.BB2PartTotalOndemandDetailResult

setDwoDetails(ArrayList) - Method in class bb.common.BB2PartTotalOnorderDetailResult

setDwoDisc(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemVO

setDwoDisc(BigDecimal) - Method in class bb.common.DisassembleWorkOrderVO

setDwoicCost(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

setDwoisCost(BigDecimal) - Method in class bb.common.DisassembleWorkOrderIssueVO

setDwoisStdCost(BigDecimal) - Method in class bb.common.DisassembleWorkOrderIssueVO

setDwoItemPk(DisassembleWorkOrderItemPK) - Method in class bb.common.DisassembleWorkOrderItemListResult

setDwoMade(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemVO

setDwoMade(BigDecimal) - Method in class bb.common.DisassembleWorkOrderVO

setDwoNumber(String) - Method in class bb.common.DisassembleWorkOrderDocumentVO

setDwoNumber(String) - Method in class bb.common.DisassembleWorkOrderListResult

setDwoOnDemandList(ArrayList) - Method in class bb.common.MrpItemResult

setDwoOnOrderList(ArrayList) - Method in class bb.common.MrpItemResult

setDwoOpen(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemVO

setDwoOpen(BigDecimal) - Method in class bb.common.DisassembleWorkOrderVO

setDwoSub(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemVO

setDwoSub(BigDecimal) - Method in class bb.common.DisassembleWorkOrderVO

setDwoTax(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemVO

setDwoTotal(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemVO

setDynamicSearchFilter(DynamicSearchFilter) - Method in class bb.common.ServerAction

setEAccounts(TreeMap) - Method in class bb.common.TwelveMonthCashFlowReportResult

setEachMonthInvoiceAvgAccount(BigDecimal) - Method in class bb.common.SalesInfoCenterResult

setEachMonthInvoiceAvgGrossMargin(BigDecimal) - Method in class bb.common.SalesInfoCenterResult

setEachMonthSalesItemAvgCount(Integer) - Method in class bb.common.SalesInfoCenterResult

setEachMonthSalesOrderAvgAccount(BigDecimal) - Method in class bb.common.SalesInfoCenterResult

setEachMonthSalesOrderAvgCount(Integer) - Method in class bb.common.SalesInfoCenterResult

setEarNoseTear(String) - Method in class bb.common.CustomCheckUpEmployeeVO

setEc(String) - Method in class bb.common.DesignControlInfoVO

setEc(String) - Method in class bb.common.DesignControlVO

setEcg(String) - Method in class bb.common.CustomCheckUpEmployeeVO

setEcnDescription(String) - Method in class bb.common.EngineeringChangeListResult

setEcnList(List<EngineeringChangeListResult>) - Method in class bb.common.BillItemWithPartInfoResult

setEcnList(List<EngineeringChangeListResult>) - Method in class bb.common.BillWithPartInfoResult

setEcnNumber(String) - Method in class bb.common.EngineeringChangeListResult

setEcnNumber(String) - Method in class bb.common.EngineeringSharingImportLogVO

setECode(String) - Method in class bb.common.PartInventoryVO

setECode(String) - Method in class bb.common.ToolInventoryVO

setEcrDate(Date) - Method in class bb.common.EngineeringChangeRequestVO

setEcrDescription(String) - Method in class bb.common.EngineeringChangeRequestListResult

setEcrEngineer(String) - Method in class bb.common.EngineeringChangeRequestListResult

setEcrNumber(String) - Method in class bb.common.EngineeringChangeRequestListResult

setEcrPriority(String) - Method in class bb.common.EngineeringChangeRequestListResult

setEcrPriority(String) - Method in class bb.common.EngineeringChangeRequestVO

setEdcDigits(byte) - Method in class bb.common.CompanyVO

setEdcDocuments(Set) - Method in class bb.common.DesignControlVO

setEdcPrefix(String) - Method in class bb.common.CompanyVO

setEditable(boolean) - Method in class bb.common.AppColumnVO

setEditDate(Date) - Method in class bb.common.EngineeringSharingItemVO

setEducation(String) - Method in class bb.common.CustomEmployeeVO

setEducation(String) - Method in class bb.common.EmployeeCardVO

setEffectiveDate(Date) - Method in class bb.common.EngineeringChangeVO

setEffectiveDate(Date) - Method in class bb.common.PartVendorVO

setEffectiveDate(Date) - Method in class bb.common.ToolVendorVO

setEffectiveDate(Date) - Method in class bb.common.WorkInstructionListResult

setEffectiveDate(Date) - Method in class bb.common.WorkInstructionRequestForChangeVO

setEffectiveDate(Date) - Method in class bb.common.WorkInstructionVO

setEffectiveDate(Date) - Method in class bb.common.WorkOrderWorkInstructionVO

setEjbMethod(EjbMethodVO) - Method in class bb.common.PermissionMethodVO

setEjbName(String) - Method in class bb.common.EjbMethodVO

setEjbName(String) - Method in class bb.common.LogMethodPK

setElapsedTimeByHour(BigDecimal) - Method in class bb.common.OperatingInstructionsUserStatisticalResult

setElapsedTimeByHour(BigDecimal) - Method in class bb.common.OperatingInstructionsVO

setElecSignature(byte[]) - Method in class bb.common.RunningAccountOrderVO

setEmail(String) - Method in class bb.common.AllStatementsListResult

setEmail(String) - Method in class bb.common.ARAllStatementsListResult

setEmail(String) - Method in class bb.common.ARPrepayAllStatementsListResult

setEmail(String) - Method in class bb.common.BizBoxUserEmployeeResult

setEmail(String) - Method in class bb.common.CSRAgent

setEmail(String) - Method in class bb.common.CustomerFeedbackVO

setEmail(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setEmail(String) - Method in class bb.common.CustomerVendorAddressVO

setEmail(String) - Method in class bb.common.CustomerVendorContactVO

setEmail(String) - Method in class bb.common.EmployeeCardVO

setEmail(String) - Method in class bb.common.ManufacturerAddressInfoVO

setEmail(String) - Method in class bb.common.ManufacturerAddressVO

setEmail(String) - Method in class bb.common.ManufacturerContactVO

setEmail(String) - Method in class bb.common.NoticeUserEmployeeListResult

setEmail(String) - Method in class bb.common.QualityGroupVO

setEmail(String) - Method in class bb.common.SalesmanVO

setEmail(String) - Method in class bb.common.SGCustomerServiceRequestVO

setEmailFrom(String) - Method in class bb.common.CustomerServiceIncidentItemVO

setEmails(Set) - Method in class bb.common.AllStatementsListResult

setEmailSent(Date) - Method in class bb.common.CustomerServiceIncidentItemVO

setEmailTo(String) - Method in class bb.common.CustomerServiceIncidentItemVO

setEmailto(String) - Method in class bb.common.TaskVO

setEmergencyContact(String) - Method in class bb.common.EmployeeHomeVO

setEmergencyContact(String) - Method in class bb.common.SalesmanVO

setEmpId(String) - Method in class bb.common.CustomCheckUpEmployeeVO

setEmpId(String) - Method in class bb.common.EngGroupUserPK

setEmployee(EmployeeCardVO) - Method in class bb.common.AccountsPayableInfoVO

setEmployee(EmployeeCardVO) - Method in class bb.common.AccountsPayableVO

setEmployee(String) - Method in class bb.common.LogInventoryListResult

setEmployee(String) - Method in class bb.common.WorkOrderItemTimeDetailVO

setEmployeeAge(int) - Method in class bb.common.CustomEmployeeVO

setEmployeeAgeLevel(int) - Method in class bb.common.CustomEmployeeVO

setEmployeeEmail(String) - Method in class bb.common.PurchaseWorkSheetVO

setEmployeeEmail(String) - Method in class bb.common.WorkOrderWorkSheetVO

setEmployeeId(String) - Method in class bb.common.ArCommissionListResult

setEmployeeId(String) - Method in class bb.common.BomApprovalVO

setEmployeeId(String) - Method in class bb.common.CustomGoodsRecordVO

setEmployeeId(String) - Method in class bb.common.DisassembleWorkOrderApprovalVO

setEmployeeId(String) - Method in class bb.common.ECNReviewVO

setEmployeeId(String) - Method in class bb.common.ECRReviewVO

setEmployeeId(String) - Method in class bb.common.EmployeeEducationPK

setEmployeeId(String) - Method in class bb.common.EmployeeLaborAgent

setEmployeeId(String) - Method in class bb.common.EmployeePutGoodListResult

setEmployeeId(String) - Method in class bb.common.EmployeeRecordsVO

setEmployeeId(String) - Method in class bb.common.EmployeeTimeCardResult

setEmployeeId(String) - Method in class bb.common.EmployeeWorkExperiencePK

setEmployeeId(String) - Method in class bb.common.ExpenseVO

setEmployeeId(String) - Method in class bb.common.GeneralLedgerApprovalVO

setEmployeeId(String) - Method in class bb.common.GroupUserVO

setEmployeeId(String) - Method in class bb.common.NcrApprovalPK

setEmployeeId(String) - Method in class bb.common.NonproductivePickingApprovalVO

setEmployeeId(String) - Method in class bb.common.NonproductivePickingApproveVO

setEmployeeId(String) - Method in class bb.common.NoticeUserEmployeeListResult

setEmployeeId(String) - Method in class bb.common.OnloanReviewVO

setEmployeeID(String) - Method in class bb.common.OperationLogVO

setEmployeeId(String) - Method in class bb.common.PurchaseOrderApprovalVO

setEmployeeId(String) - Method in class bb.common.PurchaseWorkSheetItemPK

setEmployeeId(String) - Method in class bb.common.PurchaseWorkSheetPK

setEmployeeID(String) - Method in class bb.common.RMAReviewVO

setEmployeeID(String) - Method in class bb.common.RTVApprovalVO

setEmployeeId(String) - Method in class bb.common.SalesCodeVO

setEmployeeId(String) - Method in class bb.common.SalesOrderReviewVO

setEmployeeId(String) - Method in class bb.common.SwapOrderApprovalVO

setEmployeeId(String) - Method in class bb.common.TransferOrderApprovalVO

setEmployeeId(String) - Method in class bb.common.WorkInstructionApprovalVO

setEmployeeId(String) - Method in class bb.common.WorkOrderApprovalVO

setEmployeeId(String) - Method in class bb.common.WorkOrderItemTimeDetailVO

setEmployeeId(String) - Method in class bb.common.WorkOrderTimeCardVO

setEmployeeId(String) - Method in class bb.common.WorkOrderWorkSheetItemPK

setEmployeeId(String) - Method in class bb.common.WorkOrderWorkSheetPK

setEmployeeIdDigits(byte) - Method in class bb.common.CompanyVO

setEmployeeIdPrefix(String) - Method in class bb.common.CompanyVO

setEmployeeLaborCost(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

setEmployeeLaborCost(boolean) - Method in class bb.common.WorkOrderItemTimeDetailVO

setEmployeeLaborCost(BigDecimal) - Method in class bb.common.WorkOrderReceiverVO

setEmployeeName(String) - Method in class bb.common.EmployeePutGoodListResult

setEmployeeName(String) - Method in class bb.common.EmployeeTimeCardResult

setEmployeeName(String) - Method in class bb.common.WorkOrderTimeCardVO

setEmployeeTrain(Set) - Method in class bb.common.CustomEmployeeVO

setEmployeeWorkAge(int) - Method in class bb.common.CustomEmployeeVO

setEmployeeWorkAgeLevel(int) - Method in class bb.common.CustomEmployeeVO

setEmployeeWorkExperience(Set) - Method in class bb.common.CustomEmployeeVO

setEnableTracking(boolean) - Method in class bb.common.CompanyVO

setEndAmount(BigDecimal) - Method in class bb.common.InventoryMonthReport

setEndCost(BigDecimal) - Method in class bb.common.InventoryMonthReport

setEndDate(Date) - Method in class bb.common.BB2FiscalYearDate

setEndDate(Date) - Method in class bb.common.FiscalYearSettingsVO

setEndDate(Date) - Method in class bb.common.LogTaskVO

setEndDate(Date) - Method in class bb.common.OperatingInstructionsUserStatisticalResult

setEndDate(Date) - Method in class bb.common.OperatingInstructionsVO

setEndDate(Date) - Method in class bb.common.OrderApprovalItemsVO

setEndDate(Date) - Method in class bb.common.RollUpBomStdCostWorkSheetVO

setEndDate(Date) - Method in class bb.common.ShipListAgent

setEndDate(Date) - Method in class bb.common.TaskVO

setEndDate(Date) - Method in class bb.common.WCLoadByDateResult

setEndDate(Date) - Method in class bb.common.WorkCenterOnDateAgent

setEndDate(Date) - Method in class bb.common.WorkOrderItemSeqWCLoadResult

setEndDate(Date) - Method in class bb.common.WorkOrderWorkInstructionSequenceDateAgent

setEndDate(Date) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setEndingBalanceCredit(BigDecimal) - Method in class bb.common.GLByDateTotalResult

setEndingBalanceDebit(BigDecimal) - Method in class bb.common.GLByDateTotalResult

setEndMonth(Date) - Method in class bb.common.CurrencyExchangeVO

setEndMonth(Date) - Method in class bb.common.GlMonthBudgetVO

setEndMonth(Date) - Method in class bb.common.GlMonthVO

setEndMonthBudget(BigDecimal) - Method in class bb.common.CashFlowMonthTotalResult

setEndQaAmount(BigDecimal) - Method in class bb.common.InventoryMonthReport

setEndQaQty(BigDecimal) - Method in class bb.common.InventoryMonthReport

setEndQty(BigDecimal) - Method in class bb.common.InventoryMonthReport

setEndWipAmount(BigDecimal) - Method in class bb.common.InventoryMonthReport

setEndWipQty(BigDecimal) - Method in class bb.common.InventoryMonthReport

setEngAcceptEmployee(String) - Method in class bb.common.POSurveyReportVO

setEngGroup(String) - Method in class bb.common.PartBasicInfo

setEngGroup(String) - Method in class bb.common.PartVO

setEngGroup(String) - Method in class bb.common.PartWithOnhandsVO

setEngGroupId(String) - Method in class bb.common.EngGroupUserPK

setEngineeringChangeDate(Date) - Method in class bb.common.EngineeringChangeListResult

setEngineeringChangeDate(Date) - Method in class bb.common.EngineeringChangeVO

setEngineeringChangeDigits(byte) - Method in class bb.common.CompanyVO

setEngineeringChangeDocuments(Set) - Method in class bb.common.EngineeringChangeVO

setEngineeringChangeNoticeNumber(String) - Method in class bb.common.EngineeringChangeRequestVO

setEngineeringChangeNumber(String) - Method in class bb.common.EngineeringChangeDocumentVO

setEngineeringChangeNumber(String) - Method in class bb.common.EngineeringChangeVO

setEngineeringChangePrefix(String) - Method in class bb.common.CompanyVO

setEngineeringChangeRequestDigits(byte) - Method in class bb.common.CompanyVO

setEngineeringChangeRequestDocuments(Set) - Method in class bb.common.EngineeringChangeRequestVO

setEngineeringChangeRequestNumber(String) - Method in class bb.common.EngineeringChangeRequestDocumentVO

setEngineeringChangeRequestNumber(String) - Method in class bb.common.EngineeringChangeRequestVO

setEngineeringChangeRequestPrefix(String) - Method in class bb.common.CompanyVO

setEngineeringDescription(String) - Method in class bb.common.WorkInstructionListResult

setEngineeringNewPartForNewPart(boolean) - Method in class bb.common.CompanyVO

setEngineeringSharingRule(String) - Method in class bb.common.EngineeringSharingVO

setEnglishAbility(String) - Method in class bb.common.CustomEmployeeVO

setEnterBy(String) - Method in class bb.common.NcrReportListResult

setEnterBy(String) - Method in class bb.common.ReturnToVendorByDateListResult

setEnterBy(String) - Method in class bb.common.ReturnToVendorVO

setEnterBy(String) - Method in class bb.common.ScrapReportVO

setEntered(Date) - Method in class bb.common.DisassembleWorkOrderVO

setEntered(Date) - Method in class bb.common.WorkOrderItemLaborCostListResult

setEntered(Date) - Method in class bb.common.WorkOrderVO

setEnteredBy(String) - Method in class bb.common.CorrectiveActionRequestVO

setEnteredBy(String) - Method in class bb.common.NonConformanceReportVO

setEnteredBy(String) - Method in class bb.common.PreventiveActionRequestVO

setEnterSchool(Date) - Method in class bb.common.CustomEmployeeVO

setEntryList(List<GeneralLedgerEntry>) - Method in class bb.common.GeneralLedgerPrintResult

setEquimentId(String) - Method in class bb.common.MaintenanceItemPK

setEquipCondition(String) - Method in class bb.common.CSRAgent

setEquipCondition(String) - Method in class bb.common.SGCustomerServiceRequestVO

setEquipment(EquipmentVO) - Method in class bb.common.WorkCenterVO

setEquipmentId(String) - Method in class bb.common.EquipmentListResult

setEquipmentId(String) - Method in class bb.common.EquipmentVO

setEquipmentID(String) - Method in class bb.common.WorkCenterVO

setEquipmentNotes(String) - Method in class bb.common.EquipmentListResult

setEquipmentNotes(String) - Method in class bb.common.EquipmentVO

setEquity(List) - Method in class bb.common.ClosingStatementResult

setErrorGL(int) - Method in class bb.common.ApprovedGLResult

setErrorGLList(List<String>) - Method in class bb.common.ApprovedGLResult

setErrorMsg(String) - Method in class bb.common.ImportDataVO

setEstHours(BigDecimal) - Method in class bb.common.WorkInstructionSequenceVO

setEstHours(BigDecimal) - Method in class bb.common.WorkOrderItemTimeDetailVO

setEstHoursH(int) - Method in class bb.common.WorkInstructionSequenceVO

setEstHoursM(int) - Method in class bb.common.WorkInstructionSequenceVO

setEstHoursS(int) - Method in class bb.common.WorkInstructionSequenceVO

setEstHrs(BigDecimal) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setEstHrsH(int) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setEstHrsM(int) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setEstHrsS(int) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setEstimatedArrival(Date) - Method in class bb.common.ProformaInvoiceVO

setEstimateDepreciate(BigDecimal) - Method in class bb.common.AssetDepreciateDetailReport

setEstimateNetSalRate(BigDecimal) - Method in class bb.common.AssetDepreciateVO

setEstimateNetSalRate(BigDecimal) - Method in class bb.common.AssetVO

setEstRunHrs(BigDecimal) - Method in class bb.common.WorkInstructionSummaryItemResult

setEstSetup(BigDecimal) - Method in class bb.common.WCLoadByDateResult

setEstSetup(BigDecimal) - Method in class bb.common.WorkInstructionSequenceVO

setEstSetup(BigDecimal) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setEstSetupH(int) - Method in class bb.common.WorkInstructionSequenceVO

setEstSetupH(int) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setEstSetupHrs(BigDecimal) - Method in class bb.common.WorkInstructionSummaryItemResult

setEstSetupM(int) - Method in class bb.common.WorkInstructionSequenceVO

setEstSetupM(int) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setEstSetupS(int) - Method in class bb.common.WorkInstructionSequenceVO

setEstSetupS(int) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setETotalBudget(BigDecimal) - Method in class bb.common.CashFlowMonthTotalResult

setEtran(String) - Method in class bb.common.AccountsPayableInfoVO

setEtran(String) - Method in class bb.common.AccountsPayableVO

setEtran(String) - Method in class bb.common.OnloanReceiverVO

setEtran(String) - Method in class bb.common.ReceiverInfoVO

setEtran(String) - Method in class bb.common.ReceiverVO

setEtran(String) - Method in class bb.common.RMAReceiverVO

setExcessiveQty(BigDecimal) - Method in class bb.common.PartWithExcessiveInventoryListResult

setExcessiveTotalAvgCost(BigDecimal) - Method in class bb.common.PartWithExcessiveInventoryListResult

setExcessiveTotalStdCost(BigDecimal) - Method in class bb.common.PartWithExcessiveInventoryListResult

setExchange(BigDecimal) - Method in class bb.common.AccountCreditVO

setExchange(BigDecimal) - Method in class bb.common.AccountDebitVO

setExchange(BigDecimal) - Method in class bb.common.AccountPayableCheckRunItemVO

setExchange(BigDecimal) - Method in class bb.common.AccountPayableCheckVO

setExchange(BigDecimal) - Method in class bb.common.AccountReceivablePaymentVO

setExchange(BigDecimal) - Method in class bb.common.AccountsPayableInfoVO

setExchange(BigDecimal) - Method in class bb.common.AccountsPayableVO

setExchange(BigDecimal) - Method in class bb.common.AccountsReceivableInfoVO

setExchange(BigDecimal) - Method in class bb.common.AccountsReceivableVO

setExchange(BigDecimal) - Method in class bb.common.AddressAccountInfo

setExchange(BigDecimal) - Method in class bb.common.APAuditListResult

setExchange(BigDecimal) - Method in class bb.common.ApPrepayVO

setExchange(BigDecimal) - Method in class bb.common.ARAuditListResult

setExchange(BigDecimal) - Method in class bb.common.ARPaymentRunItemVO

setExchange(BigDecimal) - Method in class bb.common.ArPrepayVO

setExchange(BigDecimal) - Method in class bb.common.CPItemFromQuoteResult

setExchange(BigDecimal) - Method in class bb.common.CurrencyExchangeVO

setExchange(BigDecimal) - Method in class bb.common.CurrencyVO

setExchange(BigDecimal) - Method in class bb.common.CustomerReturnToVendorVO

setExchange(BigDecimal) - Method in class bb.common.ExchangeAuditItemResult

setExchange(BigDecimal) - Method in class bb.common.GeneralLedgerEntry

setExchange(BigDecimal) - Method in class bb.common.GeneralLedgerListResult

setExchange(BigDecimal) - Method in class bb.common.GeneralLedgerVO

setExchange(BigDecimal) - Method in class bb.common.GLItemVO

setExchange(BigDecimal) - Method in class bb.common.JounalEntryListResult

setExchange(BigDecimal) - Method in class bb.common.MakePrepaymentCheckAgent

setExchange(BigDecimal) - Method in class bb.common.OnloanReceiverVO

setExchange(BigDecimal) - Method in class bb.common.PrepayPaymentAgent

setExchange(BigDecimal) - Method in class bb.common.PurchaseOrderVO

setExchange(BigDecimal) - Method in class bb.common.QuoteVO

setExchange(BigDecimal) - Method in class bb.common.ReceiverVO

setExchange(BigDecimal) - Method in class bb.common.RequestForRMAVO

setExchange(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationVO

setExchange(BigDecimal) - Method in class bb.common.RMAReceiverVO

setExchange(BigDecimal) - Method in class bb.common.RunningAccountOrderVO

setExchange(BigDecimal) - Method in class bb.common.SalesMarginListResult

setExchange(BigDecimal) - Method in class bb.common.SalesOrderVO

setExchange(BigDecimal) - Method in class bb.common.TempArApAgingVO

setExchangeRate(String) - Method in class bb.common.CompanyVO

setExchangeRate(Set) - Method in class bb.common.CurrencyVO

setExchangeRate(BigDecimal) - Method in class bb.common.PartOnhandCostVO

setExchangeRate(BigDecimal) - Method in class bb.common.PaymentAgent

setExchangeRate(BigDecimal) - Method in class bb.common.POReceiverItemListResult

setExclude(String) - Method in class bb.common.AccountPayableCheckRunVO

setExclude(String) - Method in class bb.common.ARPaymentRunVO

setExcludeVendorId(String[]) - Method in class bb.common.ApCheckRunItemAgent

setExcludeVendorId(String[]) - Method in class bb.common.ApPrepaymentCheckRunItemAgent

setExcludeVendorId(String[]) - Method in class bb.common.ArPaymentRunItemAgent

setExcludeVendorId(String[]) - Method in class bb.common.ArPrepaymentRunItemAgent

setExcludeVendorId(String[]) - Method in class bb.common.ARPrepaymentWireTransferAgent

setExcludeVendorId(String[]) - Method in class bb.common.PrepaymentWireTransferAgent

setExcludeVendorId(String[]) - Method in class bb.common.WireTransferAgent

setExpectDeliveryDate(Date) - Method in class bb.common.PurchaseOrderContractResult

setExpensesItems(Set) - Method in class bb.common.ExpenseVO

setExpenseStatement(String) - Method in class bb.common.ExpenseItemPK

setExpenseStatement(String) - Method in class bb.common.ExpenseListResult

setExpenseStatement(String) - Method in class bb.common.ExpenseVO

setExpireDate(Date) - Method in class bb.common.AddressQualityDocumentsVO

setExpireDate(Date) - Method in class bb.common.BizboxUserListResult

setExpireDate(Date) - Method in class bb.common.BizboxUserVO

setExpireDate(Date) - Method in class bb.common.ContractPriceVO

setExpireDate(Date) - Method in class bb.common.CustomEmployeeTrainVO

setExpireDate(Date) - Method in class bb.common.EmployeeTrainingVO

setExpireDate(Date) - Method in class bb.common.MiscDocAgent

setExpireDate(Date) - Method in class bb.common.VendorContractPriceVO

setExt(String) - Method in class bb.common.BB2File

setExtAvgCost(BigDecimal) - Method in class bb.common.InventoryNotUsedInMonthsResult

setExtendedCost(BigDecimal) - Method in class bb.common.POReceiverItemListResult

setExtendPrice(BigDecimal) - Method in class bb.common.CustomerReturnToVendorItemVO

setExtendPrice(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemListResult

setExtendPrice(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemVO

setExtendPrice(BigDecimal) - Method in class bb.common.OnloanReceiverItemVO

setExtendPrice(BigDecimal) - Method in class bb.common.OrderApprovalItemsVO

setExtendPrice(BigDecimal) - Method in class bb.common.PurchaseOrderItemListResult

setExtendPrice(BigDecimal) - Method in class bb.common.QuoteItemVO

setExtendPrice(BigDecimal) - Method in class bb.common.ReceiverItemVO

setExtendPrice(BigDecimal) - Method in class bb.common.RequestForRMAItemVO

setExtendPrice(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setExtendPrice(BigDecimal) - Method in class bb.common.SalesOrderItemInfoVO

setExtendPrice(BigDecimal) - Method in class bb.common.SalesOrderItemListResult

setExtendPrice(BigDecimal) - Method in class bb.common.SalesOrderItemVO

setExtendPrice(BigDecimal) - Method in class bb.common.WorkOrderItemListResult

setExtendPrice(BigDecimal) - Method in class bb.common.WorkOrderItemVO

setExtendsPrice(BigDecimal) - Method in class bb.common.QuoteItemListResult

setExtension(String) - Method in class bb.common.AccountingInfoDocumentVO

setExtension(String) - Method in class bb.common.AllPartDocumentsVO

setExtension(String) - Method in class bb.common.BizboxBugChangesInfoVO

setExtension(String) - Method in class bb.common.BizboxBugChangesVO

setExtension(String) - Method in class bb.common.BizboxBugInfoVO

setExtension(String) - Method in class bb.common.BizboxBugVO

setExtension(String) - Method in class bb.common.CustomerServiceIncidentItemVO

setExtension(String) - Method in class bb.common.DesignControlDocumentVO

setExtension(String) - Method in class bb.common.DisassembleWorkOrderDocumentVO

setExtension(String) - Method in class bb.common.EmployeeCardVO

setExtension(String) - Method in class bb.common.EmployeeRecordsVO

setExtension(String) - Method in class bb.common.EngineeringChangeDocumentVO

setExtension(String) - Method in class bb.common.EngineeringChangeRequestDocumentVO

setExtension(String) - Method in class bb.common.LogMiscDocumentVO

setExtension(String) - Method in class bb.common.LogPartDocumentVO

setExtension(String) - Method in class bb.common.MiscDocAgent

setExtension(String) - Method in class bb.common.NCRPictureListResult

setExtension(String) - Method in class bb.common.NCRPictureVO

setExtension(String) - Method in class bb.common.OnloanDocumentVO

setExtension(String) - Method in class bb.common.OrderDocumentVO

setExtension(String) - Method in class bb.common.PartCertificateListResult

setExtension(String) - Method in class bb.common.PartCertificateVO

setExtension(String) - Method in class bb.common.PartDocumentVO

setExtension(String) - Method in class bb.common.PartDwfAgent

setExtension(String) - Method in class bb.common.PartDwgAgent

setExtension(String) - Method in class bb.common.PartDwgPK

setExtension(String) - Method in class bb.common.PartPictureVO

setExtension(String) - Method in class bb.common.PreventiveActionRequestItemVO

setExtension(String) - Method in class bb.common.PrintLogoVO

setExtension(String) - Method in class bb.common.PurchaseOrderDocumentVO

setExtension(String) - Method in class bb.common.QuoteDocumentVO

setExtension(String) - Method in class bb.common.ReturnMaterialAuthorizationDocumentVO

setExtension(String) - Method in class bb.common.SalesmanVO

setExtension(String) - Method in class bb.common.SalesOrderDocumentVO

setExtension(String) - Method in class bb.common.SGDwgPictureVO

setExtension(String) - Method in class bb.common.SGPictureVO

setExtension(String) - Method in class bb.common.TaskFileResult

setExtension(String) - Method in class bb.common.TermsConditionVO

setExtension(String) - Method in class bb.common.WorkInstructionDocumentVO

setExtension(String) - Method in class bb.common.WorkInstructionPictureVO

setExtension(String) - Method in class bb.common.WorkOrderDocumentVO

setExtent(String) - Method in class bb.common.EmployeeCardVO

setExtention(String) - Method in class bb.common.DocumentInfoAgent

setExtentPrice(BigDecimal) - Method in class bb.common.RequestForQuoteItemVO

setExtPrice(BigDecimal) - Method in class bb.common.APItemListResult

setExtPrice(BigDecimal) - Method in class bb.common.InvoiceItemListResult

setExtPrice(BigDecimal) - Method in class bb.common.ReturnToVendorItemListResult

setExtPrice(BigDecimal) - Method in class bb.common.ShipperItemListResult

setExtStdCost(BigDecimal) - Method in class bb.common.InventoryNotUsedInMonthsResult

setFailEmailto(String) - Method in class bb.common.TaskVO

setFailNoticeReceivers(String) - Method in class bb.common.TaskVO

setFailRepeat(int) - Method in class bb.common.TaskVO

setFax(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setFax(String) - Method in class bb.common.CustomerVendorAddressVO

setFax(String) - Method in class bb.common.CustomerVendorContactVO

setFax(String) - Method in class bb.common.EmployeeCardVO

setFax(String) - Method in class bb.common.ManufacturerAddressInfoVO

setFax(String) - Method in class bb.common.ManufacturerAddressVO

setFax(String) - Method in class bb.common.ManufacturerContactVO

setFax(String) - Method in class bb.common.SGCartCheckOutResult

setFax(String) - Method in class bb.common.SgClientProgramUserVO

setFax(String) - Method in class bb.common.SGCustRequestForQuoteListResult

setFax(String) - Method in class bb.common.SGCustRequestForQuoteResult

setFax(String) - Method in class bb.common.SGCustRequestForQuoteVO

setFax(String) - Method in class bb.common.SGQuoteAddressResult

setFax(String) - Method in class bb.common.SGQuoteAddressVO

setFax(String) - Method in class bb.common.VendorGroupUserVO

setFDate(Date) - Method in class bb.common.WCLoadAgent

setFeedbackItems(Set) - Method in class bb.common.CustomerFeedbackVO

setFeedbackNumber(String) - Method in class bb.common.CustomerFeedbackVO

setFeedBackNumber(String) - Method in class bb.common.FeedBackItemPK

setFeedbackQuestion(FeedbackQuestionVO) - Method in class bb.common.FeedbackAnswerVO

setFifoDate(Date) - Method in class bb.common.PartOnhandCostVO

setFifoOnhand(BigDecimal) - Method in class bb.common.PartOnhandCostVO

setFile(byte[]) - Method in class bb.common.BB2AttachFile

setFile(byte[]) - Method in class bb.common.PrintTemplateVO

setFileDate(Date) - Method in class bb.common.TaskFileResult

setFilename(String) - Method in class bb.common.BB2AttachFile

setFilename(String) - Method in class bb.common.BB2File

setFileName(String) - Method in class bb.common.DocumentLogVO

setFileName(String) - Method in class bb.common.PrintTemplateVO

setFileName(String) - Method in class bb.common.TaskFileResult

setFilter(String) - Method in class bb.common.DynamicSearchFilter

setFilterCondition(String) - Method in class bb.common.DataFilterVO

setFilterPO(String) - Method in class bb.common.DataFilterVO

setFilterSQL(String) - Method in class bb.common.DataFilterVO

setFilterType(String) - Method in class bb.common.DataFilterVO

setFinancingExpensesAccount(String) - Method in class bb.common.AccountingSettingsVO

setFinish(boolean) - Method in class bb.common.WorkOrderItemSeqWCLoadResult

setFinishable(boolean) - Method in class bb.common.WorkOrderItemWCLoadResult

setFinishDateOfSeqWithPOBefore(Date) - Method in class bb.common.WCLoadDetailResult

setFinished(boolean) - Method in class bb.common.WCLoadDetailResult

setFinished(boolean) - Method in class bb.common.WorkOrderTimeCardVO

setFinished(boolean) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setFinishedDate(Date) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setFinishPercent(BigDecimal) - Method in class bb.common.WCLoadDetailResult

setFinishPercent(BigDecimal) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setFirstInCost(BigDecimal) - Method in class bb.common.PartInventoryVO

setFirstInCost(BigDecimal) - Method in class bb.common.ToolInventoryVO

setFirstLevelAccountNumber(String) - Method in class bb.common.GeneralLedgerEntry

setFirstLevelAccountNumberDescription(String) - Method in class bb.common.GeneralLedgerEntry

setFirstName(String) - Method in class bb.common.BizBoxUserEmployeeResult

setFirstName(String) - Method in class bb.common.CashierVO

setFirstName(String) - Method in class bb.common.EmployeeCardVO

setFirstName(String) - Method in class bb.common.EmployeeEducationResult

setFirstName(String) - Method in class bb.common.GroupUserVO

setFirstName(String) - Method in class bb.common.NoticeUserEmployeeListResult

setFirstName(String) - Method in class bb.common.SalesmanVO

setFiscalYear(int) - Method in class bb.common.SalesInfoCenter.DueSoCount

setFiscalYear(double) - Method in class bb.common.SalesInfoCenter.DueSoSum

setFiscalYear(float) - Method in class bb.common.SalesInfoCenter.GrossMargin

setFiscalYear(double) - Method in class bb.common.SalesInfoCenter.InvoicedSum

setFiscalYear(double) - Method in class bb.common.SalesInfoCenter.OpenSoSum

setFiscalYear(int) - Method in class bb.common.SalesInfoCenter.SoCount

setFiscalYear(int) - Method in class bb.common.SalesInfoCenter.SoCountWithPartsOnhold

setFiscalYear(int) - Method in class bb.common.SalesInfoCenter.SoItemCount

setFiscalYear(double) - Method in class bb.common.SalesInfoCenter.SoTotalSum

setFiscalYearInvoiceAccount(BigDecimal) - Method in class bb.common.SalesInfoCenterResult

setFiscalYearInvoiceGrossMargin(BigDecimal) - Method in class bb.common.SalesInfoCenterResult

setFiscalYearSalesItemCount(Integer) - Method in class bb.common.SalesInfoCenterResult

setFiscalYearSalesOrderAccount(BigDecimal) - Method in class bb.common.SalesInfoCenterResult

setFiscalYearSalesOrderCount(Integer) - Method in class bb.common.SalesInfoCenterResult

setFiscalYearSettingsVO(FiscalYearSettingsVO) - Method in class bb.common.CurrencyAgent

setFitemNumber(String) - Method in class bb.common.BB2RefdocPK

setFitemNumber(String) - Method in class bb.common.PosRefdocVO

setFitemNumber(String) - Method in class bb.common.RefdocVO

setFixedAssets(List) - Method in class bb.common.BalanceSheetSideBySideResult

setFixedAssets(List) - Method in class bb.common.ClosingStatementResult

setFixedBy(String) - Method in class bb.common.BizboxBugChangesInfoVO

setFixedBy(String) - Method in class bb.common.BizboxBugChangesVO

setFixedDate(Date) - Method in class bb.common.BizboxBugChangesInfoVO

setFixedDate(Date) - Method in class bb.common.BizboxBugChangesVO

setFixedQty(BigDecimal) - Method in class bb.common.BillItemUsageResult

setFlagString(String) - Method in class bb.common.PartToAuditFlagResult

setFloorStock(String) - Method in class bb.common.PartMRPVO

setFm0(String) - Method in class bb.common.GeneralLedgerSettingsVO

setFm1(String) - Method in class bb.common.GeneralLedgerSettingsVO

setFm2(String) - Method in class bb.common.GeneralLedgerSettingsVO

setFMonthYear(String) - Method in class bb.common.GLCheckRegisterResult

setFob(String) - Method in class bb.common.AccountsReceivableInfoVO

setFob(String) - Method in class bb.common.AccountsReceivableVO

setFob(String) - Method in class bb.common.OnLoanItemVO

setFob(String) - Method in class bb.common.OnLoanVO

setFocusWC(boolean) - Method in class bb.common.WorkOrderItemSeqWCLoadResult

setFont(String) - Method in class bb.common.LabelTemplateItemVO

setFontSize(int) - Method in class bb.common.LabelTemplateItemVO

setForderNumber(String) - Method in class bb.common.BB2RefdocPK

setForderNumber(String) - Method in class bb.common.PosRefdocVO

setForderNumber(String) - Method in class bb.common.RefdocVO

setForeignCost(BigDecimal) - Method in class bb.common.PartOnhandCostVO

setForeignCurrency(String) - Method in class bb.common.AssetVO

setForeignCurrency(String) - Method in class bb.common.PartOnhandCostVO

setForeignCurrencyAcc(boolean) - Method in class bb.common.AccountsChartVO

setForeignCurrencyCost(BigDecimal) - Method in class bb.common.AssetVO

setFormula(String) - Method in class bb.common.AccountsChartCategoryVO

setFormula(String) - Method in class bb.common.AppColumnVO

setFreight(BigDecimal) - Method in class bb.common.DisassembleWorkOrderIssuingResult

setFreight(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemVO

setFreight(BigDecimal) - Method in class bb.common.GeneralLedgerListResult

setFreight(BigDecimal) - Method in class bb.common.GeneralLedgerVO

setFreight(BigDecimal) - Method in class bb.common.MakeAccountPayableAgent

setFreight(BigDecimal) - Method in class bb.common.MakeBillAndHoldInvoiceAgent

setFreight(BigDecimal) - Method in class bb.common.MakeInvoiceAgent

setFreight(BigDecimal) - Method in class bb.common.ReceiverAgent

setFreight(BigDecimal) - Method in class bb.common.ReceiverItemAgent

setFreight(BigDecimal) - Method in class bb.common.ReceiverShipAgent

setFreight(BigDecimal) - Method in class bb.common.ReceivingResult

setFreight(BigDecimal) - Method in class bb.common.RequestForQuoteItemVO

setFreight(BigDecimal) - Method in class bb.common.RfqMessageItemVO

setFreight(BigDecimal) - Method in class bb.common.RunningAccountOrderItemResult

setFreight(BigDecimal) - Method in class bb.common.RunningAccountOrderItemVO

setFreight(BigDecimal) - Method in class bb.common.RunningAccountOrderVO

setFreight(BigDecimal) - Method in class bb.common.ShippingResult

setFreight(BigDecimal) - Method in class bb.common.SwapOrderListResult

setFreight(BigDecimal) - Method in class bb.common.SwapOrderVO

setFreight(BigDecimal) - Method in class bb.common.SwapReceiverListResult

setFreight(BigDecimal) - Method in class bb.common.SwapReceiverVO

setFreight(BigDecimal) - Method in class bb.common.SwapShipperListResult

setFreight(BigDecimal) - Method in class bb.common.SwapShipperVO

setFreight(BigDecimal) - Method in class bb.common.TransferOrderListResult

setFreight(BigDecimal) - Method in class bb.common.TransferOrderVO

setFreight(BigDecimal) - Method in class bb.common.WorkOrderItemVO

setFreightBill(String) - Method in class bb.common.AccountsPayableInfoVO

setFreightBill(String) - Method in class bb.common.AccountsPayableVO

setFreightBill(String) - Method in class bb.common.AccountsReceivableInfoVO

setFreightBill(String) - Method in class bb.common.AccountsReceivableVO

setFreightBill(String) - Method in class bb.common.OnloanReceiverVO

setFreightBill(String) - Method in class bb.common.OnloanShipperVO

setFreightBill(String) - Method in class bb.common.ProformaInvoiceVO

setFreightBill(String) - Method in class bb.common.ReceiverInfoVO

setFreightBill(String) - Method in class bb.common.ReceiverVO

setFreightBill(String) - Method in class bb.common.RMAReceiverVO

setFreightBill(String) - Method in class bb.common.RtvShipperInfoVO

setFreightBill(String) - Method in class bb.common.RtvShipperVO

setFreightBill(String) - Method in class bb.common.ShipperInfoVO

setFreightBill(String) - Method in class bb.common.ShipperVO

setFreightRateCode(String) - Method in class bb.common.MakeInvoiceAgent

setFreightRateCode(String) - Method in class bb.common.OnloanShipperVO

setFreightRateCode(String) - Method in class bb.common.RtvShipperInfoVO

setFreightRateCode(String) - Method in class bb.common.RtvShipperVO

setFreightRateCode(String) - Method in class bb.common.ShipperAgent

setFreightRateCode(String) - Method in class bb.common.ShipperInfoVO

setFreightRateCode(String) - Method in class bb.common.ShipperVO

setFreightRateCode(String) - Method in class bb.common.SwapShipperListResult

setFreightRateCode(String) - Method in class bb.common.SwapShipperVO

setFreightRateCode(String) - Method in class bb.common.TransferShipperListResult

setFreightRateCode(String) - Method in class bb.common.TransferShipperVO

setFreightTotal(BigDecimal) - Method in class bb.common.AccountingTotalMoneyResult

setFreightTotal(BigDecimal) - Method in class bb.common.AccountsReceivableInfoVO

setFreightTotal(BigDecimal) - Method in class bb.common.AccountsReceivableVO

setFreightTotal(BigDecimal) - Method in class bb.common.ArCommissionListResult

setFreightTotal(BigDecimal) - Method in class bb.common.ArCommissionTotalResult

setFreightTotal(BigDecimal) - Method in class bb.common.ArSalesCodeTotalListResult

setFreightTotal(BigDecimal) - Method in class bb.common.DuePATotalByVendorResult

setFreightWho(String) - Method in class bb.common.AccountsPayableInfoVO

setFreightWho(String) - Method in class bb.common.AccountsPayableVO

setFreightWho(String) - Method in class bb.common.AccountsReceivableInfoVO

setFreightWho(String) - Method in class bb.common.AccountsReceivableVO

setFreightWho(String) - Method in class bb.common.OnLoanItemVO

setFreightWho(String) - Method in class bb.common.OnLoanVO

setFrequency(int) - Method in class bb.common.CustomJobCategoryGoodsVO

setFrom(String) - Method in class bb.common.BB2Document

setFromAddressId(String) - Method in class bb.common.TransferOrderListResult

setFromAddressId(String) - Method in class bb.common.TransferOrderVO

setFromAddressId(String) - Method in class bb.common.TransferReceiverItemListResult

setFromAddressId(String) - Method in class bb.common.TransferReceiverListResult

setFromAddressId(String) - Method in class bb.common.TransferReceiverVO

setFromAddressId(String) - Method in class bb.common.TransferShipperListResult

setFromAddressId(String) - Method in class bb.common.TransferShipperVO

setFromAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.TransferOrderVO

setFromAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.TransferReceiverVO

setFromAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.TransferShipperVO

setFromAddressName(String) - Method in class bb.common.TransferShipperListResult

setFromDate(Date) - Method in class bb.common.ApCheckRunItemAgent

setFromDate(Date) - Method in class bb.common.ApPrepaymentCheckRunItemAgent

setFromDate(Date) - Method in class bb.common.ArPaymentRunItemAgent

setFromDate(Date) - Method in class bb.common.ArPrepaymentRunItemAgent

setFromDate(Date) - Method in class bb.common.ARPrepaymentWireTransferAgent

setFromDate(Date) - Method in class bb.common.CustomEmployeeWorkExperienceVO

setFromDate(Date) - Method in class bb.common.EmployeeEducationVO

setFromDate(Date) - Method in class bb.common.EmployeeWorkExperienceVO

setFromDate(Date) - Method in class bb.common.POAndWOStatusResult

setFromDate(Date) - Method in class bb.common.PrepaymentWireTransferAgent

setFromDate(Date) - Method in class bb.common.WireTransferAgent

setFromDate(Date) - Method in class bb.common.WorkCenterLoadAgent

setFromDate(Date) - Method in class bb.common.WorkCenterRunTimeAgent

setFromDate(Date) - Method in class bb.common.WorkCenterRunTimeTotalResult

setFromLocation(String) - Method in class bb.common.TransferOrderItemListResult

setFromLocation(String) - Method in class bb.common.TransferOrderItemVO

setFromQty(BigDecimal) - Method in class bb.common.VendorQtyPriceVO

setFtpPath(String) - Method in class bb.common.DocumentServerVO

setFtpPath(String) - Method in class bb.common.DwfUploadSettingsVO

setFtpPath(String) - Method in class bb.common.DwgUploadSettingsVO

setFtpPath(String) - Method in class bb.common.MiscDocumentSettingVO

setFullload(boolean) - Method in class bb.common.WorkCenterLoadAgent

setFullName(String) - Method in class bb.common.BizBoxUserEmployeeResult

setFullName(String) - Method in class bb.common.NoticeUserEmployeeListResult

setFullName(String) - Method in class bb.common.SgClientProgramUserVO

setFullName(String) - Method in class bb.common.VendorGroupUserVO

setFy(String) - Method in class bb.common.FiscalYearSettingsVO

setFy(String) - Method in class bb.common.GeneralLedgerSettingsVO

setFy(String) - Method in class bb.common.GlMonthVO

setFy1(int) - Method in class bb.common.GeneralLedgerSettingsVO

setFy2(int) - Method in class bb.common.GeneralLedgerSettingsVO

setFyPoAddedCount(Integer) - Method in class bb.common.PurchasingInfoCenterResult

setFyPoiAddedCount(Integer) - Method in class bb.common.PurchasingInfoCenterResult

setFyPurchaserAccount(BigDecimal) - Method in class bb.common.PurchasingInfoCenterResult

setFyReceiverAccount(BigDecimal) - Method in class bb.common.PurchasingInfoCenterResult

setFyReceiverCount(Integer) - Method in class bb.common.PurchasingInfoCenterResult

setFyReceiverCount(Integer) - Method in class bb.common.WareHousingInfoCenterResult

setFyReceiverItemCount(Integer) - Method in class bb.common.PurchasingInfoCenterResult

setFyShippperCount(Integer) - Method in class bb.common.WareHousingInfoCenterResult

setGa(String) - Method in class bb.common.ExpenseItemVO

setGa(String) - Method in class bb.common.PartInventoryVO

setGa(String) - Method in class bb.common.ToolInventoryVO

setGaAp(String) - Method in class bb.common.AccountingSettingsVO

setGaAp(String) - Method in class bb.common.AccountPayableCheckRunVO

setGaAr(String) - Method in class bb.common.AccountingSettingsVO

setGaAr(String) - Method in class bb.common.ARPaymentRunVO

setGaBusinessIncome(String) - Method in class bb.common.AccountingSettingsVO

setGaChecking(String) - Method in class bb.common.AccountingSettingsVO

setGaChecking(String) - Method in class bb.common.AccountPayableCheckRunVO

setGaChecking(String) - Method in class bb.common.AccountReceivablePaymentVO

setGaChecking(String) - Method in class bb.common.ARPaymentRunVO

setGaCheckNo(String) - Method in class bb.common.AccountingSettingsVO

setGaCogs(String) - Method in class bb.common.AccountingSettingsVO

setGaCogsContra(String) - Method in class bb.common.AccountingSettingsVO

setGaDep(String) - Method in class bb.common.AccountingSettingsVO

setGaEmployeeLabor(String) - Method in class bb.common.AccountingSettingsVO

setGaExchangeGainsAndLoss(String) - Method in class bb.common.AccountingSettingsVO

setGageSet(String) - Method in class bb.common.ToolCalibrationVO

setGaInboundFreight(String) - Method in class bb.common.AccountingSettingsVO

setGaOutboundFreight(String) - Method in class bb.common.AccountingSettingsVO

setGaProfitForCurrentYear(String) - Method in class bb.common.AccountingSettingsVO

setGaPurchaseDiscount(String) - Method in class bb.common.AccountingSettingsVO

setGaScrap(String) - Method in class bb.common.AccountingSettingsVO

setGaWip(String) - Method in class bb.common.AccountingSettingsVO

setGaWoic(String) - Method in class bb.common.AccountingSettingsVO

setGaZero(BigDecimal) - Method in class bb.common.AccountingSettingsVO

setGender(String) - Method in class bb.common.CustomEmployeeVO

setGender(boolean) - Method in class bb.common.EmployeeCardVO

setGeneralAdmin(List) - Method in class bb.common.ProfitLossStatementResult

setGeneralDocument(String) - Method in class bb.common.SGDocPartVO

setGeneralDocumentRev(String) - Method in class bb.common.SGDocPartVO

setGeneralLedgerBalance(List) - Method in class bb.common.ClosingStatementResult

setGlAccountNumber(String) - Method in class bb.common.AssetVO

setGlCat(String) - Method in class bb.common.GLAutoApproveVO

setGlCategory(String) - Method in class bb.common.AssetDepreciateVO

setGlCategory(String) - Method in class bb.common.GeneralLedgerByDateListResult

setGlCategory(String) - Method in class bb.common.GeneralLedgerListResult

setGlCategory(String) - Method in class bb.common.GeneralLedgerPrintResult

setGlCategory(String) - Method in class bb.common.GeneralLedgerVO

setGlCategory(String) - Method in class bb.common.GLApprovalListResult

setGlCategory(String) - Method in class bb.common.GLCatAndSequence

setGlDigits(byte) - Method in class bb.common.CompanyVO

setGlNdaysOk(int) - Method in class bb.common.AccountingSettingsVO

setGlNumber(String) - Method in class bb.common.DepositSummaryResult

setGlNumber(String) - Method in class bb.common.GeneralLedgerByDateListResult

setGlNumber(String) - Method in class bb.common.GLApprovalListResult

setGlNumber(String) - Method in class bb.common.GLCatAndSequence

setGlNumber(String) - Method in class bb.common.ShipperItemVO

setGlNumber(String) - Method in class bb.common.TransferShipperVO

setGlobal(boolean) - Method in class bb.common.UserGroupVO

setGlPrefix(String) - Method in class bb.common.CompanyVO

setGlStyle(String) - Method in class bb.common.AccountingConfigurationVO

setGlSummary(String) - Method in class bb.common.AccountBalanceAgent

setGlSummary(String) - Method in class bb.common.AddPayableWithoutReceiverAgent

setGlSummary(String) - Method in class bb.common.ExchangeAuditResult

setGlSummary(String) - Method in class bb.common.MakeAccountPayableAgent

setGlSummary(String) - Method in class bb.common.MakeBillAndHoldInvoiceAgent

setGlSummary(String) - Method in class bb.common.MakeCheckAgent

setGlSummary(String) - Method in class bb.common.MakeCreditMemoAgent

setGlSummary(String) - Method in class bb.common.MakeDebitMemoAgent

setGlSummary(String) - Method in class bb.common.MakeInvoiceAgent

setGlSummary(String) - Method in class bb.common.MakePrepaymentCheckAgent

setGlSummary(String) - Method in class bb.common.NcrScrapAgent

setGlSummary(String) - Method in class bb.common.PaymentAgent

setGlSummary(String) - Method in class bb.common.PostCheckAgent

setGlSummary(String) - Method in class bb.common.PrepayPaymentAgent

setGlSummary(String) - Method in class bb.common.ReceiverAgent

setGlType(String) - Method in class bb.common.GeneralLedgerCategoryVO

setGlType(String) - Method in class bb.common.GLAutoApproveVO

setGoodQty(BigDecimal) - Method in class bb.common.InspectionReportInfoVO

setGoodQty(BigDecimal) - Method in class bb.common.InspectionReportVO

setGoodQty(BigDecimal) - Method in class bb.common.JobProcessSheetItemResult

setGoodsId(String) - Method in class bb.common.CustomGoodsRecordVO

setGoodsId(String) - Method in class bb.common.CustomJobCategoryGoodsPK

setGoodsId(String) - Method in class bb.common.EmployeePutGoodListResult

setGoodsName(String) - Method in class bb.common.EmployeePutGoodListResult

setGotoCatalog(String) - Method in class bb.common.SGCompanyVO

setGotoManual(String) - Method in class bb.common.SGCompanyVO

setGotoOverview(String) - Method in class bb.common.SGCompanyVO

setGotoPic(String) - Method in class bb.common.SGCompanyVO

setGotoTechSheet(String) - Method in class bb.common.SGCompanyVO

setGotoTroubleshooting(String) - Method in class bb.common.SGCompanyVO

setGraduateDate(Date) - Method in class bb.common.CustomEmployeeVO

setGraduateSchool(String) - Method in class bb.common.CustomEmployeeVO

setGrandTotal(BigDecimal) - Method in class bb.common.AccountingTotalMoneyResult

setGrandTotal(BigDecimal) - Method in class bb.common.AccountReceivableInfoWithPrepayResult

setGrandTotal(BigDecimal) - Method in class bb.common.AccountsReceivableInfoVO

setGrandTotal(BigDecimal) - Method in class bb.common.AccountsReceivableItemResult

setGrandTotal(BigDecimal) - Method in class bb.common.AccountsReceivableVO

setGrandTotal(BigDecimal) - Method in class bb.common.ArCommissionListResult

setGrandTotal(BigDecimal) - Method in class bb.common.ArCommissionTotalResult

setGrandTotal(BigDecimal) - Method in class bb.common.ArSalesCodeTotalListResult

setGrandTotal(BigDecimal) - Method in class bb.common.DuePATotalByVendorResult

setGrandTotal(BigDecimal) - Method in class bb.common.SalesTaxListResult

setGrandTotal(BigDecimal) - Method in class bb.common.TotalByDateResult

setGrandTotal(BigDecimal) - Method in class bb.common.VendorTotalAmountInPO

setGrandTotal(BigDecimal) - Method in class bb.common.ZipcodeTotalsResult

setGrantTotal(BigDecimal) - Method in class bb.common.CustomerReturnToVendorVO

setGrantTotal(BigDecimal) - Method in class bb.common.DisassembleWorkOrderListResult

setGrantTotal(BigDecimal) - Method in class bb.common.DisassembleWorkOrderVO

setGrantTotal(BigDecimal) - Method in class bb.common.OnloanReceiverVO

setGrantTotal(BigDecimal) - Method in class bb.common.PoMessageVO

setGrantTotal(BigDecimal) - Method in class bb.common.POStatisticsResult

setGrantTotal(BigDecimal) - Method in class bb.common.ProformaInvoiceListResult

setGrantTotal(BigDecimal) - Method in class bb.common.PurchaseOrderVO

setGrantTotal(BigDecimal) - Method in class bb.common.QuoteVO

setGrantTotal(BigDecimal) - Method in class bb.common.ReceiverInfoVO

setGrantTotal(BigDecimal) - Method in class bb.common.ReceiverVO

setGrantTotal(BigDecimal) - Method in class bb.common.RequestForQuoteVO

setGrantTotal(BigDecimal) - Method in class bb.common.RequestForRMAVO

setGrantTotal(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationVO

setGrantTotal(BigDecimal) - Method in class bb.common.ReturnToVendorVO

setGrantTotal(BigDecimal) - Method in class bb.common.SalesOrderListResult

setGrantTotal(BigDecimal) - Method in class bb.common.SalesOrderVO

setGrantTotal(BigDecimal) - Method in class bb.common.TempReceiverWithoutAPInfo

setGrantTotal(BigDecimal) - Method in class bb.common.WorkOrderVO

setGrossMargin(BigDecimal) - Method in class bb.common.ProfitLossStatementResult

setGrossMargin(SalesInfoCenter.GrossMargin) - Method in class bb.common.SalesInfoCenter

setGrossMargin(BigDecimal) - Method in class bb.common.SalesOrder12MonthMarginResult

setGrossMarginPct12MonthAvg(BigDecimal) - Method in class bb.common.SalesOrderOnTimeResult

setGrossMarginPctFysical(BigDecimal) - Method in class bb.common.SalesOrderOnTimeResult

setGrossMarginPctLastMonth(BigDecimal) - Method in class bb.common.SalesOrderOnTimeResult

setGrossMarginPctThisMonth(BigDecimal) - Method in class bb.common.SalesOrderOnTimeResult

setGrossMarginPctYtd(BigDecimal) - Method in class bb.common.SalesOrderOnTimeResult

setGrossMarginShippedOnTime12MonthAvg(BigDecimal) - Method in class bb.common.SalesOrderOnTimeResult

setGrossMarginShippedOnTimeFysical(BigDecimal) - Method in class bb.common.SalesOrderOnTimeResult

setGrossMarginShippedOnTimeLastMonth(BigDecimal) - Method in class bb.common.SalesOrderOnTimeResult

setGrossMarginShippedOnTimeThisMonth(BigDecimal) - Method in class bb.common.SalesOrderOnTimeResult

setGrossMarginShippedOnTimeYtd(BigDecimal) - Method in class bb.common.SalesOrderOnTimeResult

setGrossNetProfit(ClosingStatementTotalResult) - Method in class bb.common.ClosingStatementResult

setGrossProfit(ProfitLossStatementItemResult) - Method in class bb.common.ProfitLossStatementResult

setGrossRevenue(ClosingStatementTotalResult) - Method in class bb.common.ClosingStatementResult

setGrossWeight(String) - Method in class bb.common.OnloanShipperVO

setGrossWeight(BigDecimal) - Method in class bb.common.PackingBoxVO

setGrossWeight(BigDecimal) - Method in class bb.common.PrPackingBoxVO

setGrossWeight(String) - Method in class bb.common.RtvShipperInfoVO

setGrossWeight(String) - Method in class bb.common.RtvShipperVO

setGrossWeight(String) - Method in class bb.common.ShipperAgent

setGrossWeight(String) - Method in class bb.common.ShipperInfoVO

setGrossWeight(String) - Method in class bb.common.ShipperVO

setGrossWeight(String) - Method in class bb.common.SwapShipperListResult

setGrossWeight(String) - Method in class bb.common.SwapShipperVO

setGrossWeight(String) - Method in class bb.common.TransferShipperListResult

setGrossWeight(String) - Method in class bb.common.TransferShipperVO

setGroup(String) - Method in class bb.common.SubcompanyVO

setGroup(boolean) - Method in class bb.common.WorkCenterAgent

setGroup(boolean) - Method in class bb.common.WorkCenterLoadListResult

setHasPicture(String) - Method in class bb.common.SGBOMItemResult

setHaveDrawingRevised(String) - Method in class bb.common.EngineeringChangeVO

setHavePicture(String) - Method in class bb.common.PartBasicInfo

setHavePicture(String) - Method in class bb.common.PartVO

setHavePicture(String) - Method in class bb.common.PartWithOnhandsVO

setHavePicture(String) - Method in class bb.common.SGPartCatalogResult

setHeight(Short) - Method in class bb.common.BB2Picture

setHeight(int) - Method in class bb.common.LabelTemplateItemVO

setHeight(int) - Method in class bb.common.LabelTemplateVO

setHeight(Short) - Method in class bb.common.MiscDocAgent

setHeight(Short) - Method in class bb.common.PartPictureVO

setHeight(Short) - Method in class bb.common.SGPicturePK

setHeight(short) - Method in class bb.common.WorkInstructionPictureVO

setHelpServerIP(String) - Method in class bb.common.HelpServerVO

setHelpServerPort(String) - Method in class bb.common.HelpServerVO

setHighestCost(BigDecimal) - Method in class bb.common.SalesOrderItemCostResult

setHighlight(boolean) - Method in class bb.common.CPItemFromQuoteResult

setHold(String) - Method in class bb.common.BB2PartInfo

setHold(String) - Method in class bb.common.BillItemSalesCostResult

setHold(String) - Method in class bb.common.BillItemSalesXResult

setHold(String) - Method in class bb.common.BillSalesXResult

setHold(boolean) - Method in class bb.common.DisassembleWorkOrderIssuingResult

setHold(String) - Method in class bb.common.DisassembleWorkOrderItemVO

setHold(boolean) - Method in class bb.common.DisassembleWorkOrderReceivingResult

setHold(boolean) - Method in class bb.common.DisassembleWorkOrderVO

setHold(boolean) - Method in class bb.common.EngineeringChangeVO

setHold(String) - Method in class bb.common.PartBasicInfo

setHold(String) - Method in class bb.common.PartVO

setHold(String) - Method in class bb.common.PartWhereUsedItemResult

setHold(String) - Method in class bb.common.PartWithInventoryInfoListResult

setHold(String) - Method in class bb.common.PartWithManufacturerInfoResult

setHold(String) - Method in class bb.common.PartWithOnhandsVO

setHold(boolean) - Method in class bb.common.PurchaseOrderVO

setHold(boolean) - Method in class bb.common.ReceivingResult

setHold(String) - Method in class bb.common.SalesBomItemResult

setHold(String) - Method in class bb.common.SalesBomResult

setHold(boolean) - Method in class bb.common.SalesOrderVO

setHold(boolean) - Method in class bb.common.ShippingResult

setHold(String) - Method in class bb.common.StockTransactionPartInfoResult

setHold(String) - Method in class bb.common.ToolVO

setHold(String) - Method in class bb.common.ToolWhereUsedItemResult

setHold(String) - Method in class bb.common.ToolWithOnhandsVO

setHold(String) - Method in class bb.common.WorkOrderItemVO

setHold(boolean) - Method in class bb.common.WorkOrderVO

setHome(String) - Method in class bb.common.CompanyVO

setHome(String) - Method in class bb.common.SGCompanyVO

setHomeAddress(String) - Method in class bb.common.EmployeeHomeVO

setHomeAddress(String) - Method in class bb.common.SalesmanVO

setHomePhone(String) - Method in class bb.common.BizBoxUserEmployeeResult

setHomePhone(String) - Method in class bb.common.EmployeeCardVO

setHomePhone(String) - Method in class bb.common.EmployeeHomeVO

setHomePhone(String) - Method in class bb.common.NoticeUserEmployeeListResult

setHomePhone(String) - Method in class bb.common.SalesmanVO

setHost(String) - Method in class bb.common.SGCompanyVO

setHost(String) - Method in class bb.common.SmtpServerVO

setHostName(String) - Method in class bb.common.BB2Notice

setHours(BigDecimal) - Method in class bb.common.EmployeeLaborAgent

setHours(BigDecimal) - Method in class bb.common.WCLoadDetailResult

setHours(BigDecimal) - Method in class bb.common.WorkOrderItemSeqWCLoadResult

setHours(BigDecimal) - Method in class bb.common.WorkOrderItemTimeDetailVO

setHours(BigDecimal) - Method in class bb.common.WorkOrderWorkInstructionSequenceDateAgent

setHqa(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemVO

setHqa(BigDecimal) - Method in class bb.common.OnLoanItemVO

setHqa(BigDecimal) - Method in class bb.common.PurchaseOrderItemVO

setHqa(BigDecimal) - Method in class bb.common.QuoteItemVO

setHqa(BigDecimal) - Method in class bb.common.RequestForQuoteItemVO

setHqa(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setHqa(BigDecimal) - Method in class bb.common.ReturnToVendorItemVO

setHqa(BigDecimal) - Method in class bb.common.RMAReceiverItemVO

setHqa(BigDecimal) - Method in class bb.common.SalesOrderItemInfoVO

setHqa(BigDecimal) - Method in class bb.common.SalesOrderItemVO

setHqa(BigDecimal) - Method in class bb.common.TransferReceiverItemListResult

setHqa(BigDecimal) - Method in class bb.common.TransferReceiverItemVO

setHqa(BigDecimal) - Method in class bb.common.WorkOrderItemVO

setHrs(Integer) - Method in class bb.common.EquipmentVO

setIcrDate(Date) - Method in class bb.common.IcrItemListResult

setIcrDate(Date) - Method in class bb.common.IcrListResult

setIcrDate(Date) - Method in class bb.common.InspectionConformanceReportVO

setIcrDocuments(Set<OrderDocumentVO>) - Method in class bb.common.InspectionConformanceReportVO

setIcrItemChecks(Set) - Method in class bb.common.InspectionConformanceReportItemVO

setIcrItemNumber(String) - Method in class bb.common.IcrItemListResult

setIcrItemNumber(String) - Method in class bb.common.InspectionConformanceReportItemCheckPK

setIcrItemNumber(String) - Method in class bb.common.InspectionConformanceReportItemPK

setIcrItems(Set) - Method in class bb.common.InspectionConformanceReportVO

setIcrNumber(String) - Method in class bb.common.IcrItemListResult

setIcrNumber(String) - Method in class bb.common.IcrListResult

setIcrNumber(String) - Method in class bb.common.InspectionConformanceReportItemCheckPK

setIcrNumber(String) - Method in class bb.common.InspectionConformanceReportItemPK

setIcrNumber(String) - Method in class bb.common.InspectionConformanceReportVO

setIcrRequiredWhenReceiverNa(boolean) - Method in class bb.common.OrderApprovalItemsVO

setIcrRequiredWhenReceiverNa(boolean) - Method in class bb.common.PurchaseOrderItemVO

setIcrRequiredWhenReceiverNa(boolean) - Method in class bb.common.ReceivingItemResult

setIcrRequiredWhenReceiverNa(boolean) - Method in class bb.common.WorkOrderItemVO

setId(String) - Method in class bb.common.AccountingConfigurationVO

setId(String) - Method in class bb.common.AccountingSettingsVO

setId(String) - Method in class bb.common.AddressAccountInfo

setId(String) - Method in class bb.common.AssetTypeVO

setId(BigDecimal) - Method in class bb.common.BB2BigDecimalAndString

setId(Long) - Method in class bb.common.BB2Picture

setId(Integer) - Method in class bb.common.BizboxBugChangesInfoVO

setId(Integer) - Method in class bb.common.BizboxBugChangesVO

setId(Integer) - Method in class bb.common.BizboxBugInfoVO

setId(Integer) - Method in class bb.common.BizboxBugVO

setId(Integer) - Method in class bb.common.BuyerCodeVO

setId(Integer) - Method in class bb.common.CertificateDescriptionVO

setId(int) - Method in class bb.common.CommonPrintTemplateVO

setId(String) - Method in class bb.common.CompanyUnitVO

setId(String) - Method in class bb.common.CompanyVO

setId(String) - Method in class bb.common.ContractPriceCustomerPK

setId(String) - Method in class bb.common.CustomDepartmentVO

setId(String) - Method in class bb.common.CustomEmployeeTrainPK

setId(String) - Method in class bb.common.CustomEmployeeVO

setId(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setId(String) - Method in class bb.common.CustomerVendorAddressVO

setId(String) - Method in class bb.common.CustomerVendorContactPK

setId(String) - Method in class bb.common.CustomerVendorDescriptionPK

setId(String) - Method in class bb.common.CustomGoodsBreedVO

setId(String) - Method in class bb.common.CustomJobCategoryVO

setId(String) - Method in class bb.common.CustomSearchVO

setId(String) - Method in class bb.common.CustomTranslationVO

setId(String) - Method in class bb.common.CV2CVAgent

setId(String) - Method in class bb.common.DataFilterVO

setId(String) - Method in class bb.common.DepartmentLocationForBackflushVO

setId(Long) - Method in class bb.common.DocumentLogVO

setId(String) - Method in class bb.common.EmployeeCardVO

setId(String) - Method in class bb.common.EmployeeHomeVO

setId(String) - Method in class bb.common.EmployeeJobDescriptionVO

setId(String) - Method in class bb.common.EngGroupVO

setId(String) - Method in class bb.common.GeneralLedgerCategoryVO

setId(String) - Method in class bb.common.GeneralLedgerResult

setId(String) - Method in class bb.common.GeneralLedgerSettingsVO

setId(String) - Method in class bb.common.GLCheckRegisterResult

setId(String) - Method in class bb.common.IncotermVO

setId(Long) - Method in class bb.common.IpAddressVO

setId(String) - Method in class bb.common.LockedCustomerAddressResult

setId(String) - Method in class bb.common.ManufacturerAddressInfoVO

setId(String) - Method in class bb.common.ManufacturerAddressVO

setId(String) - Method in class bb.common.ManufacturerContactPK

setId(String) - Method in class bb.common.ManufacturerDescriptionPK

setId(Long) - Method in class bb.common.MessageVO

setId(String) - Method in class bb.common.NonproductivePickingItemResult

setId(String) - Method in class bb.common.NonproductivePickingOnDemandResult

setId(int) - Method in class bb.common.OIPrincipalVO

setId(String) - Method in class bb.common.OntimeDeliveryRateListResult

setId(Long) - Method in class bb.common.OperationLogVO

setId(String) - Method in class bb.common.PartClassVO

setId(Short) - Method in class bb.common.PartTypeVO

setId(String) - Method in class bb.common.PointOfSaleVO

setId(String) - Method in class bb.common.PostCheckAgent

setId(String) - Method in class bb.common.ProjectVO

setId(Object) - Method in class bb.common.ServerAction

setId(String) - Method in class bb.common.ServerClientPropertyPK

setId(long) - Method in class bb.common.UnitVO

setId(String) - Method in class bb.common.UserGroupVO

setId(String) - Method in class bb.common.VendorContractPriceVendorPK

setId(String) - Method in class bb.common.WorkOrderInWipResult

setId(String) - Method in class bb.common.WorkOrderOnDemandResult

setId(String) - Method in class bb.common.WorkOrderOnOrderResult

setIdCard(String) - Method in class bb.common.EmployeeCardVO

setIdentifer(int) - Method in class bb.common.SGQuoteCartVO

setIdentifier(String) - Method in class bb.common.BB2DoubleString

setIdentifier(String) - Method in class bb.common.ClientListItem

setIdentifier(int) - Method in class bb.common.SGLogLoginVO

setIdentifier(int) - Method in class bb.common.SGQuoteLoginVO

setIi(Long) - Method in class bb.common.AccountingInfoDocumentVO

setIi(Long) - Method in class bb.common.AccountPayableCheckVO

setIi(Long) - Method in class bb.common.AccountReceivablePaymentVO

setIi(Long) - Method in class bb.common.AccountsChartCategoryVO

setIi(Short) - Method in class bb.common.AccountsReceivableItemManufacturerPK

setIi(Long) - Method in class bb.common.AddressQualityDocumentsVO

setIi(Short) - Method in class bb.common.AssetUsagePK

setIi(Long) - Method in class bb.common.AuditLogVO

setIi(Long) - Method in class bb.common.BillItemReplacementVO

setIi(Long) - Method in class bb.common.BillLogVO

setIi(Long) - Method in class bb.common.ChangeStdCostWorkSheetItemPK

setIi(Long) - Method in class bb.common.ChangeStdCostWorkSheetVO

setIi(Short) - Method in class bb.common.CustomAssetRecordPK

setIi(Long) - Method in class bb.common.CustomCheckUpEmployeeVO

setIi(Short) - Method in class bb.common.CustomEmployeeTrainPK

setIi(Long) - Method in class bb.common.CustomerServiceIncidentItemVO

setIi(Integer) - Method in class bb.common.CustomerVendorTypeVO

setIi(Long) - Method in class bb.common.CustomGoodsRecordVO

setIi(Long) - Method in class bb.common.DesignControlDocumentVO

setIi(Long) - Method in class bb.common.DisassembleWorkOrderDocumentVO

setIi(Long) - Method in class bb.common.DisassembleWorkOrderIssueVO

setIi(Integer) - Method in class bb.common.DwfUploadSettingsVO

setIi(Integer) - Method in class bb.common.DwgUploadSettingsVO

setIi(Short) - Method in class bb.common.EmployeeEducationPK

setIi(Long) - Method in class bb.common.EmployeeRecordsVO

setIi(Short) - Method in class bb.common.EmployeeWorkExperiencePK

setIi(Long) - Method in class bb.common.EngineeringChangeDocumentVO

setIi(Long) - Method in class bb.common.EngineeringChangeRequestDocumentVO

setIi(Long) - Method in class bb.common.EngineeringSharingImportLogVO

setIi(Integer) - Method in class bb.common.ExpenseItemPK

setIi(Long) - Method in class bb.common.GLAutoApproveVO

setIi(Long) - Method in class bb.common.HelpServerVO

setIi(Long) - Method in class bb.common.HistoricalInventoryVO

setIi(int) - Method in class bb.common.ImportDataVO

setIi(Integer) - Method in class bb.common.InspectionReportInspectMethodItemPK

setIi(Integer) - Method in class bb.common.InspectionReportInspectMethodVO

setIi(Integer) - Method in class bb.common.InspectionReportInspectStandardItemPK

setIi(Byte) - Method in class bb.common.InspectionReportItemQtyPK

setIi(Long) - Method in class bb.common.InventoryAdjustmentVO

setIi(Integer) - Method in class bb.common.LabelTemplateItemPK

setIi(Integer) - Method in class bb.common.LabelTemplateVO

setIi(Long) - Method in class bb.common.LogInventoryVO

setIi(Long) - Method in class bb.common.LogMiscDocumentVO

setIi(Long) - Method in class bb.common.LogPartDocumentVO

setIi(Long) - Method in class bb.common.LogPartDwfVO

setIi(Long) - Method in class bb.common.LogPartDwgVO

setIi(Long) - Method in class bb.common.LogTaskVO

setIi(Long) - Method in class bb.common.LogTrackingVO

setIi(Integer) - Method in class bb.common.MaintenanceItemPK

setIi(Integer) - Method in class bb.common.MiscDocumentSettingVO

setIi(int) - Method in class bb.common.MrpByMonthResult

setIi(int) - Method in class bb.common.NCRPartOnhandPK

setIi(Long) - Method in class bb.common.NCRPictureListResult

setIi(Long) - Method in class bb.common.NCRPictureVO

setIi(Integer) - Method in class bb.common.NonConformanceQuantityPK

setIi(Integer) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setIi(Integer) - Method in class bb.common.NonproductivePickingItemIssuedVO

setIi(int) - Method in class bb.common.NonproductivePickingTypeVO

setIi(Long) - Method in class bb.common.OnloanDocumentVO

setIi(Integer) - Method in class bb.common.OperatingInstructionsInspectMethodItemPK

setIi(Integer) - Method in class bb.common.OperatingInstructionsInspectResultItemPK

setIi(Integer) - Method in class bb.common.OperatingInstructionsInspectStandardItemPK

setIi(Integer) - Method in class bb.common.OperatingInstructionsInspectStandardVO

setIi(Integer) - Method in class bb.common.OperatingInstructionsManualItemPK

setIi(Integer) - Method in class bb.common.OperatingInstructionsManualVO

setIi(Integer) - Method in class bb.common.OperatingInstructionsTypeVO

setIi(Integer) - Method in class bb.common.OperatingOutputFileItemPK

setIi(Integer) - Method in class bb.common.OperatingOutputFileTypeVO

setIi(Long) - Method in class bb.common.OrderApprovalItemsVO

setIi(Long) - Method in class bb.common.OrderApprovalVO

setIi(Byte) - Method in class bb.common.OrderBoilerplatePK

setIi(Long) - Method in class bb.common.OrderDocumentVO

setIi(Integer) - Method in class bb.common.PartCertificateVO

setIi(int) - Method in class bb.common.PartInQAAgent

setIi(Integer) - Method in class bb.common.PartInQAResult

setIi(Integer) - Method in class bb.common.PartInQAVO

setIi(Integer) - Method in class bb.common.PartIssuedVO

setIi(Long) - Method in class bb.common.PartNumberGenerateRuleVO

setIi(Long) - Method in class bb.common.PartOnhandCostVO

setIi(Long) - Method in class bb.common.PartPictureVO

setIi(Integer) - Method in class bb.common.PartReceivedVO

setIi(Long) - Method in class bb.common.PosRefdocVO

setIi(int) - Method in class bb.common.PrintTemplateVO

setIi(Short) - Method in class bb.common.ProformaInvoiceItemManufacturerPK

setIi(Long) - Method in class bb.common.PurchaseOrderDocumentVO

setIi(Long) - Method in class bb.common.QuoteDocumentVO

setIi(Short) - Method in class bb.common.QuoteItemManufacturerPK

setIi(Integer) - Method in class bb.common.RebackInQAAgent

setIi(Short) - Method in class bb.common.ReceiverItemManufacturerPK

setIi(Long) - Method in class bb.common.RefdocVO

setIi(Short) - Method in class bb.common.RequestForQuoteItemManufacturerPK

setIi(Long) - Method in class bb.common.ReturnMaterialAuthorizationDocumentVO

setIi(Long) - Method in class bb.common.RollUpBomStdCostWorkSheetItemPK

setIi(Long) - Method in class bb.common.RollUpBomStdCostWorkSheetVO

setIi(Long) - Method in class bb.common.SalesOrderDocumentVO

setIi(Short) - Method in class bb.common.SalesOrderItemManufacturerPK

setIi(Long) - Method in class bb.common.SGSaleItemVO

setIi(Byte) - Method in class bb.common.ShipListOwnerAttributePK

setIi(Short) - Method in class bb.common.ShipperItemManufacturerPK

setIi(Short) - Method in class bb.common.SmtpServerVO

setIi(Long) - Method in class bb.common.TaskFileResult

setIi(Long) - Method in class bb.common.TaskVO

setIi(Integer) - Method in class bb.common.TaxAccountVO

setIi(Long) - Method in class bb.common.TempArApAgingVO

setIi(Integer) - Method in class bb.common.TermsConditionVO

setIi(Integer) - Method in class bb.common.TermVO

setIi(Long) - Method in class bb.common.ToolCalibrationVO

setIi(Long) - Method in class bb.common.WorkInstructionDocumentVO

setIi(Long) - Method in class bb.common.WorkInstructionPictureVO

setIi(Long) - Method in class bb.common.WorkOrderDocumentVO

setIi(Long) - Method in class bb.common.WorkOrderItemPartDetailInWipVO

setIi(Long) - Method in class bb.common.WorkOrderItemTimeDetailVO

setIi(Long) - Method in class bb.common.WorkOrderReceiverVO

setIi(Long) - Method in class bb.common.WorkOrderTimeCardVO

setIi(long) - Method in class bb.common.WorkPeriodVO

setIi(Integer) - Method in class bb.common.ZipCodeTaxVO

setImplementionDue(Date) - Method in class bb.common.CorrectiveActionRequestVO

setImplementionDue(Date) - Method in class bb.common.PreventiveActionRequestVO

setImportComment(String) - Method in class bb.common.EngineeringChangeVO

setImportCompany(String) - Method in class bb.common.EngineeringChangeVO

setImportCompanyId(String) - Method in class bb.common.EngineeringChangeListResult

setImportDataType(String) - Method in class bb.common.EngineeringSharingImportLogVO

setImportDate(Date) - Method in class bb.common.EngineeringSharingImportLogVO

setImportEc(String) - Method in class bb.common.EngineeringChangeVO

setImportEcnNumber(String) - Method in class bb.common.EngineeringChangeListResult

setImportKey(String) - Method in class bb.common.EngineeringSharingImportLogVO

setImportType(String) - Method in class bb.common.EngineeringSharingImportLogVO

setInactive(boolean) - Method in class bb.common.ToolVO

setInAmount(BigDecimal) - Method in class bb.common.InventoryMonthReport

setIncidentItems(Set) - Method in class bb.common.CustomerServiceIncidentVO

setIncidentNumber(String) - Method in class bb.common.CustomerServiceIncidentItemVO

setIncidentNumber(String) - Method in class bb.common.CustomerServiceIncidentVO

setIncidentType(String) - Method in class bb.common.CustomerServiceIncidentVO

setInclude(String) - Method in class bb.common.AccountPayableCheckRunVO

setInclude(String) - Method in class bb.common.ARPaymentRunVO

setIncludeAssembly(boolean) - Method in class bb.common.MrpReportAgent

setIncludeMPNs(boolean) - Method in class bb.common.SO2POAgent

setIncludePoTax(boolean) - Method in class bb.common.CompanyVO

setIncludeToleranceQty(boolean) - Method in class bb.common.MrpReportAgent

setIncludeVendorId(String[]) - Method in class bb.common.ApCheckRunItemAgent

setIncludeVendorId(String[]) - Method in class bb.common.ApPrepaymentCheckRunItemAgent

setIncludeVendorId(String[]) - Method in class bb.common.ArPaymentRunItemAgent

setIncludeVendorId(String[]) - Method in class bb.common.ArPrepaymentRunItemAgent

setIncludeVendorId(String[]) - Method in class bb.common.ARPrepaymentWireTransferAgent

setIncludeVendorId(String[]) - Method in class bb.common.PrepaymentWireTransferAgent

setIncludeVendorId(String[]) - Method in class bb.common.WireTransferAgent

setIncomeFromOperating(List) - Method in class bb.common.ProfitLossStatementResult

setIncomeTax(ClosingStatementTotalResult) - Method in class bb.common.ClosingStatementResult

setIncomeTaxItems(List) - Method in class bb.common.ClosingStatementResult

setInCost(BigDecimal) - Method in class bb.common.InventoryMonthReport

setInCost(BigDecimal) - Method in class bb.common.LogInventoryListResult

setInCost(BigDecimal) - Method in class bb.common.LogInventoryVO

setIncoterm(String) - Method in class bb.common.AccountsPayableInfoVO

setIncoterm(String) - Method in class bb.common.AccountsPayableVO

setIncoterm(String) - Method in class bb.common.AccountsReceivableInfoVO

setIncoterm(String) - Method in class bb.common.AccountsReceivableVO

setIncoterm(String) - Method in class bb.common.CustomerReturnToVendorVO

setIncoterm(String) - Method in class bb.common.OnloanReceiverVO

setIncoterm(String) - Method in class bb.common.OnloanShipperVO

setIncoterm(String) - Method in class bb.common.OnLoanVO

setIncoterm(String) - Method in class bb.common.PfReceiverVO

setIncoterm(String) - Method in class bb.common.PO2SOExchange

setIncoterm(String) - Method in class bb.common.ProformaInvoiceVO

setIncoterm(String) - Method in class bb.common.PurchaseOrderVO

setIncoterm(String) - Method in class bb.common.QuoteVO

setIncoterm(String) - Method in class bb.common.ReceiverInfoVO

setIncoterm(String) - Method in class bb.common.ReceiverVO

setIncoterm(String) - Method in class bb.common.RequestForQuoteVO

setIncoterm(String) - Method in class bb.common.RequestForRMAVO

setIncoterm(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setIncoterm(String) - Method in class bb.common.ReturnToVendorVO

setIncoterm(String) - Method in class bb.common.RMAReceiverVO

setIncoterm(String) - Method in class bb.common.RtvShipperInfoVO

setIncoterm(String) - Method in class bb.common.RtvShipperVO

setIncoterm(String) - Method in class bb.common.SalesOrderItemListResult

setIncoterm(String) - Method in class bb.common.SalesOrderVO

setIncoterm(String) - Method in class bb.common.ShipperInfoVO

setIncoterm(String) - Method in class bb.common.ShipperVO

setIncoterm(String) - Method in class bb.common.ShippingResult

setIncoterm(String) - Method in class bb.common.SwapOrderListResult

setIncoterm(String) - Method in class bb.common.SwapOrderVO

setIncoterm(String) - Method in class bb.common.SwapReceiverListResult

setIncoterm(String) - Method in class bb.common.SwapReceiverVO

setIncoterm(String) - Method in class bb.common.SwapShipperListResult

setIncoterm(String) - Method in class bb.common.SwapShipperVO

setIncoterm(String) - Method in class bb.common.TransferOrderListResult

setIncoterm(String) - Method in class bb.common.TransferOrderVO

setIncoterm(String) - Method in class bb.common.TransferReceiverListResult

setIncoterm(String) - Method in class bb.common.TransferReceiverVO

setIncoterm(String) - Method in class bb.common.TransferShipperListResult

setIncoterm(String) - Method in class bb.common.TransferShipperVO

setIncotermPlacePort(String) - Method in class bb.common.AccountsPayableInfoVO

setIncotermPlacePort(String) - Method in class bb.common.AccountsPayableVO

setIncotermPlacePort(String) - Method in class bb.common.AccountsReceivableInfoVO

setIncotermPlacePort(String) - Method in class bb.common.AccountsReceivableVO

setIncotermPlacePort(String) - Method in class bb.common.CustomerReturnToVendorVO

setIncotermPlacePort(String) - Method in class bb.common.OnloanReceiverVO

setIncotermPlacePort(String) - Method in class bb.common.OnloanShipperVO

setIncotermPlacePort(String) - Method in class bb.common.OnLoanVO

setIncotermPlacePort(String) - Method in class bb.common.PfReceiverVO

setIncotermPlacePort(String) - Method in class bb.common.ProformaInvoiceVO

setIncotermPlacePort(String) - Method in class bb.common.PurchaseOrderVO

setIncotermPlacePort(String) - Method in class bb.common.QuoteVO

setIncotermPlacePort(String) - Method in class bb.common.ReceiverInfoVO

setIncotermPlacePort(String) - Method in class bb.common.ReceiverVO

setIncotermPlacePort(String) - Method in class bb.common.RequestForQuoteVO

setIncotermPlacePort(String) - Method in class bb.common.RequestForRMAVO

setIncotermPlacePort(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setIncotermPlacePort(String) - Method in class bb.common.ReturnToVendorVO

setIncotermPlacePort(String) - Method in class bb.common.RMAReceiverVO

setIncotermPlacePort(String) - Method in class bb.common.RtvShipperInfoVO

setIncotermPlacePort(String) - Method in class bb.common.RtvShipperVO

setIncotermPlacePort(String) - Method in class bb.common.SalesOrderItemListResult

setIncotermPlacePort(String) - Method in class bb.common.SalesOrderVO

setIncotermPlacePort(String) - Method in class bb.common.ShipperInfoVO

setIncotermPlacePort(String) - Method in class bb.common.ShipperVO

setIncotermPlacePort(String) - Method in class bb.common.SwapOrderListResult

setIncotermPlacePort(String) - Method in class bb.common.SwapOrderVO

setIncotermPlacePort(String) - Method in class bb.common.SwapReceiverListResult

setIncotermPlacePort(String) - Method in class bb.common.SwapReceiverVO

setIncotermPlacePort(String) - Method in class bb.common.SwapShipperListResult

setIncotermPlacePort(String) - Method in class bb.common.SwapShipperVO

setIncotermPlacePort(String) - Method in class bb.common.TransferOrderListResult

setIncotermPlacePort(String) - Method in class bb.common.TransferOrderVO

setIncotermPlacePort(String) - Method in class bb.common.TransferReceiverListResult

setIncotermPlacePort(String) - Method in class bb.common.TransferReceiverVO

setIncotermPlacePort(String) - Method in class bb.common.TransferShipperListResult

setIncotermPlacePort(String) - Method in class bb.common.TransferShipperVO

setIndex(Integer) - Method in class bb.common.AccountsChartCategoryVO

setInfoByMonthMap(Map<Date, BigDecimal>) - Method in class bb.common.IncomeByMonthChartResult

setInfoByMonthMap(Map<String, HashMap<Date, BigDecimal>>) - Method in class bb.common.InfoByFiscalChartResult

setInfoByMonthMap(Map<String, HashMap<Date, InfoByMonthResult>>) - Method in class bb.common.InfoByMonthChartResult

setInfoTotalMap(Map<String, BigDecimal>) - Method in class bb.common.InfoByFiscalChartResult

setInfoTotalMap(Map<String, BigDecimal>) - Method in class bb.common.InfoByMonthChartResult

setInitBranchWarehouse(boolean) - Method in class bb.common.CompanyVO

setInitialDepreciateCost(BigDecimal) - Method in class bb.common.AssetAddOrDisposalsReport

setInitialDepreciateCost(BigDecimal) - Method in class bb.common.AssetDepreciateDetailReport

setInitialDepreciateCost(BigDecimal) - Method in class bb.common.AssetDepreciateVO

setInitialDepreciateCost(BigDecimal) - Method in class bb.common.AssetReportSumResult

setInitialDepreciateCost(BigDecimal) - Method in class bb.common.AssetVO

setInitSom(Date) - Method in class bb.common.GeneralLedgerSettingsVO

setInitStep(String) - Method in class bb.common.CompanyVO

setInnerDiameter(BigDecimal) - Method in class bb.common.PartMaterialListResult

setInnerDiameter(BigDecimal) - Method in class bb.common.PartMaterialReportAgent

setInnerDiameter(BigDecimal) - Method in class bb.common.PartMaterialVO

setInnerDiameter(BigDecimal) - Method in class bb.common.PartMaterialWhereUsedItemResult

setInnerDiameterUnit(String) - Method in class bb.common.PartMaterialListResult

setInnerDiameterUnit(String) - Method in class bb.common.PartMaterialVO

setInnerDiameterUnit(String) - Method in class bb.common.PartMaterialWhereUsedItemResult

setInnerOperator(String) - Method in class bb.common.PartMaterialReportAgent

setInnerUnit(String) - Method in class bb.common.PartMaterialReportAgent

setInQa(BigDecimal) - Method in class bb.common.InventoryListResult

setInQAQty(BigDecimal) - Method in class bb.common.AuditPartInQAResult

setInQAQty(BigDecimal) - Method in class bb.common.PartWithQAQtyListResult

setInQty(BigDecimal) - Method in class bb.common.InventoryMonthReport

setInQty(BigDecimal) - Method in class bb.common.InventoryPartInOutDetailListResult

setInQty(BigDecimal) - Method in class bb.common.LogInventoryListResult

setInQty(BigDecimal) - Method in class bb.common.LogInventoryVO

setInQty(BigDecimal) - Method in class bb.common.LogTrackingVO

setInQualityCheckingQty(BigDecimal) - Method in class bb.common.HistoricalInventoryVO

setInQualityCheckingQty(BigDecimal) - Method in class bb.common.PartInventoryVO

setInQualityCheckingQty(BigDecimal) - Method in class bb.common.PhysicalInventoryListResult

setInQualityCheckingQty(BigDecimal) - Method in class bb.common.PhysicalInventoryVO

setInQualityCheckingQty(BigDecimal) - Method in class bb.common.ToolInventoryVO

setInSip(BigDecimal) - Method in class bb.common.BB2PartInfo

setInsip(BigDecimal) - Method in class bb.common.BB2PartOnDemandListResult

setInSip(BigDecimal) - Method in class bb.common.BillItemOnHandUsageResult

setInSip(BigDecimal) - Method in class bb.common.BillItemOnHandWithPartInfoResult

setInSip(BigDecimal) - Method in class bb.common.BillOnHandWithPartInfoResult

setInSip(BigDecimal) - Method in class bb.common.InventoryListResult

setInSIP(BigDecimal) - Method in class bb.common.PartOnhandResult

setInSip(BigDecimal) - Method in class bb.common.PartOnHandWithMfgInfoResult

setInSIP(BigDecimal) - Method in class bb.common.SalesOrderItemGroupByPartListResult

setInSipCount(Integer) - Method in class bb.common.WareHousingInfoCenterResult

setInSIPInSO(BigDecimal) - Method in class bb.common.SalesOrderItemGroupByPartListResult

setInSipQty(BigDecimal) - Method in class bb.common.PartWithSipQtyListResult

setInSipTotal(Money) - Method in class bb.common.WareHousingInfoCenterResult

setInSit(BigDecimal) - Method in class bb.common.BB2PartInfo

setInsit(BigDecimal) - Method in class bb.common.BB2PartOnDemandListResult

setInSit(BigDecimal) - Method in class bb.common.BillItemOnHandUsageResult

setInSit(BigDecimal) - Method in class bb.common.BillItemOnHandWithPartInfoResult

setInSit(BigDecimal) - Method in class bb.common.BillOnHandWithPartInfoResult

setInSit(BigDecimal) - Method in class bb.common.PartOnHandWithMfgInfoResult

setInSitCount(Integer) - Method in class bb.common.WareHousingInfoCenterResult

setInSITQty(BigDecimal) - Method in class bb.common.PartWithSITQtyListResult

setInSitTotal(Money) - Method in class bb.common.WareHousingInfoCenterResult

setInspectedBy(String) - Method in class bb.common.JobProcessSheetItemResult

setInspectedBy(String) - Method in class bb.common.ToolCalibrationVO

setInspectedDate(Date) - Method in class bb.common.JobProcessSheetItemResult

setInspectedQty(BigDecimal) - Method in class bb.common.NcrNeedToScrapListResult

setInspectedQty(BigDecimal) - Method in class bb.common.NonConformanceReportVO

setInspectionContent(String) - Method in class bb.common.OperatingInstructionsVO

setInspectionDate(Date) - Method in class bb.common.OperatingInstructionsInspectResultItemVO

setInspectionDescription(String) - Method in class bb.common.InspectionItemVO

setInspectionOutputFile(boolean) - Method in class bb.common.OperatingInstructionsVO

setInspectionOutputFileNumber(String) - Method in class bb.common.OperatingInstructionsVO

setInspectionPeriod(String) - Method in class bb.common.ToolCalibrationVO

setInspectionPeriodUnit(String) - Method in class bb.common.ToolCalibrationVO

setInspectionReportDate(Date) - Method in class bb.common.InspectionReportInfoVO

setInspectionReportDate(Date) - Method in class bb.common.InspectionReportVO

setInspectionReportInspectMethod(InspectionReportInspectMethodVO) - Method in class bb.common.InspectionReportInspectMethodItemVO

setInspectionReportInspectMethodItems(Set<InspectionReportInspectMethodItemVO>) - Method in class bb.common.InspectionReportVO

setInspectionReportInspectStandard(OperatingInstructionsInspectStandardVO) - Method in class bb.common.InspectionReportInspectStandardItemVO

setInspectionReportInspectStandardItems(Set<InspectionReportInspectStandardItemVO>) - Method in class bb.common.InspectionReportVO

setInspectionReportItems(Set<InspectionReportItemVO>) - Method in class bb.common.InspectionReportVO

setInspectionReportNumber(String) - Method in class bb.common.InspectionReportInfoVO

setInspectionReportNumber(String) - Method in class bb.common.InspectionReportInspectMethodItemPK

setInspectionReportNumber(String) - Method in class bb.common.InspectionReportInspectStandardItemPK

setInspectionReportNumber(String) - Method in class bb.common.InspectionReportItemPK

setInspectionReportNumber(String) - Method in class bb.common.InspectionReportItemQtyPK

setInspectionReportNumber(String) - Method in class bb.common.InspectionReportVO

setInspectionReportNumber(String) - Method in class bb.common.OperatingInstructionsInspectResultItemVO

setInspectionReportNumber(String) - Method in class bb.common.OperatingInstructionsVO

setInspectionRequest(String) - Method in class bb.common.InspectionItemVO

setInspectionResult(String) - Method in class bb.common.InspectionReportInfoVO

setInspectionResult(String) - Method in class bb.common.InspectionReportVO

setInspectionResult(String) - Method in class bb.common.OperatingInstructionsInspectResultItemVO

setInspectionResult(String) - Method in class bb.common.OperatingInstructionsVO

setInspectionResultSign(String) - Method in class bb.common.OperatingInstructionsInspectResultItemVO

setInspectionResultSign(String) - Method in class bb.common.OperatingInstructionsVO

setInspections(Set) - Method in class bb.common.PartInspectionResult

setInspections(Set) - Method in class bb.common.ToolVO

setInspectionType(String) - Method in class bb.common.InspectionTypeItemPK

setInspectionType(String) - Method in class bb.common.InspectionTypeVO

setInspectionType(String) - Method in class bb.common.PartInspectionResult

setInspectionType(String) - Method in class bb.common.PartVO

setInspectionType(String) - Method in class bb.common.ToolVO

setInspectionTypeItems(Set) - Method in class bb.common.InspectionTypeVO

setInspector(String) - Method in class bb.common.IcrItemListResult

setInspector(String) - Method in class bb.common.InspectionConformanceReportItemVO

setInspector(String) - Method in class bb.common.InspectionReportInfoVO

setInspector(String) - Method in class bb.common.InspectionReportVO

setInspectProject(String) - Method in class bb.common.InspectionConformanceReportItemCheckVO

setInspectProject(String) - Method in class bb.common.InspectionTypeItemVO

setInspectProject(String) - Method in class bb.common.PartInspectionVO

setInstalledDate(Date) - Method in class bb.common.EquipmentVO

setInSTO(BigDecimal) - Method in class bb.common.InventoryListResult

setInSTO(BigDecimal) - Method in class bb.common.PartInventoryVO

setInSTO(BigDecimal) - Method in class bb.common.ToolInventoryVO

setInSTOQty(BigDecimal) - Method in class bb.common.PartWithSTOQtyListResult

setInternalSalesMailto(String) - Method in class bb.common.SGCompanyVO

setInTOQty(BigDecimal) - Method in class bb.common.HistoricalInventoryVO

setInTotalCost(BigDecimal) - Method in class bb.common.InventoryPartInOutDetailListResult

setInUse(boolean) - Method in class bb.common.DataFilterVO

setInventory(BigDecimal) - Method in class bb.common.AccountingBalanceSheetResult

setInventoryAction(String) - Method in class bb.common.EngineeringChangeVO

setInventoryModify(String) - Method in class bb.common.EngineeringChangeVO

setInventoryScrap(String) - Method in class bb.common.EngineeringChangeVO

setInventoryUseAsIs(String) - Method in class bb.common.EngineeringChangeVO

setInventoryValuation(String) - Method in class bb.common.AccountingSettingsVO

setInvoiceBoilerplate(String) - Method in class bb.common.AccountsReceivableInfoVO

setInvoiceBoilerplate(String) - Method in class bb.common.AccountsReceivableVO

setInvoiceComments(String) - Method in class bb.common.AccountsReceivableInfoVO

setInvoiceComments(String) - Method in class bb.common.AccountsReceivableItemVO

setInvoiceComments(String) - Method in class bb.common.AccountsReceivableVO

setInvoiceDate(Date) - Method in class bb.common.AddPayableWithoutReceiverAgent

setInvoiceDate(Date) - Method in class bb.common.CustomerFeedbackVO

setInvoicedBy(String) - Method in class bb.common.AccountsReceivableInfoVO

setInvoicedBy(String) - Method in class bb.common.AccountsReceivableVO

setInvoicedBy(String) - Method in class bb.common.OnloanShipperVO

setInvoicedBy(String) - Method in class bb.common.ProformaInvoiceVO

setInvoicedBy(String) - Method in class bb.common.RtvShipperInfoVO

setInvoicedBy(String) - Method in class bb.common.RtvShipperVO

setInvoicedBy(String) - Method in class bb.common.ShipperInfoVO

setInvoicedBy(String) - Method in class bb.common.ShipperVO

setInvoicedDate(Date) - Method in class bb.common.AccountsReceivableInfoVO

setInvoicedDate(Date) - Method in class bb.common.AccountsReceivableVO

setInvoicedDate(Date) - Method in class bb.common.OnloanShipperVO

setInvoicedDate(Date) - Method in class bb.common.ProformaInvoiceVO

setInvoicedDate(Date) - Method in class bb.common.RtvShipperInfoVO

setInvoicedDate(Date) - Method in class bb.common.RtvShipperVO

setInvoicedDate(Date) - Method in class bb.common.ShipperInfoVO

setInvoicedDate(Date) - Method in class bb.common.ShipperVO

setInvoicedSum(SalesInfoCenter.InvoicedSum) - Method in class bb.common.SalesInfoCenter

setInvoicedTotal(BigDecimal) - Method in class bb.common.SalesOrder12MonthMarginResult

setInvoiceItemNumber(String) - Method in class bb.common.AccountsReceivableItemPK

setInvoiceItemNumber(String) - Method in class bb.common.InvoiceItemListResult

setInvoiceItemNumber(String) - Method in class bb.common.SalesTaxListResult

setInvoiceNotes(String) - Method in class bb.common.AccountsReceivableInfoVO

setInvoiceNotes(String) - Method in class bb.common.AccountsReceivableVO

setInvoiceNumber(String) - Method in class bb.common.AccountReceivableInfoWithPrepayResult

setInvoiceNumber(String) - Method in class bb.common.AccountsReceivableInfoVO

setInvoiceNumber(String) - Method in class bb.common.AccountsReceivableItemManufacturerPK

setInvoiceNumber(String) - Method in class bb.common.AccountsReceivableItemPK

setInvoiceNumber(String) - Method in class bb.common.AccountsReceivableVO

setInvoiceNumber(String) - Method in class bb.common.AddProformaReceiverItemAgent

setInvoiceNumber(String) - Method in class bb.common.ArCommissionListResult

setInvoiceNumber(String) - Method in class bb.common.CRTVItemListResult

setInvoiceNumber(String) - Method in class bb.common.CRTVListResult

setInvoiceNumber(String) - Method in class bb.common.CustomerReturnToVendorVO

setInvoiceNumber(String) - Method in class bb.common.CustomerStatementListResult

setInvoiceNumber(String) - Method in class bb.common.GeneralLedgerListResult

setInvoiceNumber(String) - Method in class bb.common.GeneralLedgerResult

setInvoiceNumber(String) - Method in class bb.common.GeneralLedgerVO

setInvoiceNumber(String) - Method in class bb.common.InvoiceItemListResult

setInvoiceNumber(String) - Method in class bb.common.PostCheckAgent

setInvoiceNumber(String) - Method in class bb.common.RequestForRMAVO

setInvoiceNumber(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setInvoiceNumber(String) - Method in class bb.common.RMAItemListResult

setInvoiceNumber(String) - Method in class bb.common.RMAListResult

setInvoiceNumber(String) - Method in class bb.common.RRMAItemListResult

setInvoiceNumber(String) - Method in class bb.common.RRMAListResult

setInvoiceNumber(String) - Method in class bb.common.RunningAccountOrderVO

setInvoiceNumber(String) - Method in class bb.common.SalesTaxListResult

setInvoiceNumber(String) - Method in class bb.common.ShipperItemVO

setInvoiceNumber(String) - Method in class bb.common.SOShipperItemListResult

setInvoicePrivateNotes(String) - Method in class bb.common.AccountsReceivableItemVO

setInvoiceStatus(String) - Method in class bb.common.SalesOrderItemListResult

setInvoiceTotal(BigDecimal) - Method in class bb.common.MoneyInDrawResult

setInWip(BigDecimal) - Method in class bb.common.BB2PartInfo

setInwip(BigDecimal) - Method in class bb.common.BB2PartOnDemandListResult

setInWip(BigDecimal) - Method in class bb.common.BillItemOnHandUsageResult

setInWip(BigDecimal) - Method in class bb.common.BillItemOnHandWithPartInfoResult

setInWip(BigDecimal) - Method in class bb.common.BillOnHandWithPartInfoResult

setInWip(BigDecimal) - Method in class bb.common.InventoryListResult

setInWIP(BigDecimal) - Method in class bb.common.PartOnhandResult

setInWip(BigDecimal) - Method in class bb.common.PartOnHandWithMfgInfoResult

setInwip(BigDecimal) - Method in class bb.common.PartWithInventoryInfoListResult

setInWip(BigDecimal) - Method in class bb.common.StockTransactionPartInfoResult

setInWip(BigDecimal) - Method in class bb.common.WorkOrderItemIssueVO

setInWIPQty(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemListResult

setInWipQty(BigDecimal) - Method in class bb.common.PartInWipForIDListResult

setInWipQty(BigDecimal) - Method in class bb.common.PartWithWipQtyListResult

setInWIPQty(BigDecimal) - Method in class bb.common.WorkOrderItemListResult

setIp(String) - Method in class bb.common.BizboxUserListResult

setIp(String) - Method in class bb.common.BizboxUserVO

setIp1(Long) - Method in class bb.common.IpAddressVO

setIp2(Long) - Method in class bb.common.IpAddressVO

setIpAddr(String) - Method in class bb.common.RunningAccountOrderVO

setIpAddress(String) - Method in class bb.common.SubcompanyVO

setIrNumber(String) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

setIrNumber(String) - Method in class bb.common.ReceiverItemAgent

setIrNumber(String) - Method in class bb.common.ReceivingItemResult

setIrNumber(String) - Method in class bb.common.WorkOrderReceiverVO

setIrTotalRefQty(BigDecimal) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setIrTotalRefQty(BigDecimal) - Method in class bb.common.ReceivingItemResult

setIrType(String) - Method in class bb.common.PartVO

setIrType(String) - Method in class bb.common.ToolVO

setIsActivePart(String) - Method in class bb.common.PartVO

setIsActivePart(String) - Method in class bb.common.PartWithOnhandsVO

setIsGroup(Boolean) - Method in class bb.common.IssueItemAgent

setIsGroup(Boolean) - Method in class bb.common.IssuingItemResult

setIsGroup(Boolean) - Method in class bb.common.ReceivedToOrderItem

setIsGroup(Boolean) - Method in class bb.common.ReceiverItemDetailAgent

setIssueAvgCost(BigDecimal) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setIssueAvgCost(BigDecimal) - Method in class bb.common.WorkOrderItemInWipListResult

setIssueCost(BigDecimal) - Method in class bb.common.WOIssuedByMonthResult

setIssueDate(Date) - Method in class bb.common.DisassembleWorkOrderIssuingResult

setIssuedByMonthList(ArrayList<WOIssuedByMonthResult>) - Method in class bb.common.WOIssuedByMonthChartResult

setIssuedCost(BigDecimal) - Method in class bb.common.WorkOrderItemPartDetailResult

setIssuedDate(Date) - Method in class bb.common.StockTransactionWOShipperResult

setIssuedFrom(String) - Method in class bb.common.IssuedFromOrderItem

setIssuedFrom(String) - Method in class bb.common.IssueItemDetailAgent

setIssuedFrom(String) - Method in class bb.common.ShipperItemDetailAgent

setIssuedLocate(String) - Method in class bb.common.IssuedFromOrderItem

setIssuedQty(BigDecimal) - Method in class bb.common.IssueItemDetailAgent

setIssuedQty(BigDecimal) - Method in class bb.common.MasterWorkOrderTreeItemResult

setIssuedQty(BigDecimal) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setIssuedQty(BigDecimal) - Method in class bb.common.PartInWipForIDListResult

setIssuedQty(BigDecimal) - Method in class bb.common.StockTransactionWOShipperResult

setIssuedQty(BigDecimal) - Method in class bb.common.WorkOrderItemInWipListResult

setIssuedQuantity(BigDecimal) - Method in class bb.common.NonproductivePickingItemResult

setIssuedQuantity(BigDecimal) - Method in class bb.common.NonproductivePickingItemVO

setIssuedRate(BigDecimal) - Method in class bb.common.WCLoadDetailResult

setIssuedStdCost(BigDecimal) - Method in class bb.common.WorkOrderItemPartDetailResult

setIssuedToOrderItems(Set) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setIssuedTotal(BigDecimal) - Method in class bb.common.WorkOrderItemIssuedTotalResult

setIssueItemDetails(Set) - Method in class bb.common.IssueItemAgent

setIssueQuantity(BigDecimal) - Method in class bb.common.WOIssuedByMonthResult

setIssueQuantity(BigDecimal) - Method in class bb.common.WOItemPartDetailNotIssue

setIssueQuantity(BigDecimal) - Method in class bb.common.WorkOrderItemIssuedTotalResult

setIssueQuantity(BigDecimal) - Method in class bb.common.WorkOrderItemIssueVO

setIssueQuantity(BigDecimal) - Method in class bb.common.WorkOrderItemPartDetail

setIssueQuantity(BigDecimal) - Method in class bb.common.WorkOrderOverIssueListResult

setIssueVo(WorkOrderItemIssueVO) - Method in class bb.common.WorkOrderItemPartDetailItemResult

setIssuingItems(Set) - Method in class bb.common.IssuingResult

setItalic(boolean) - Method in class bb.common.LabelTemplateItemVO

setItem(String) - Method in class bb.common.AssetAmortizationExpenseAccountPK

setItem(Short) - Method in class bb.common.CustomerVendorContactPK

setItem(InspectionConformanceReportItemVO) - Method in class bb.common.InspectionConformanceReportItemInfo

setItem(Short) - Method in class bb.common.ManufacturerContactPK

setItem(String) - Method in class bb.common.ZipcodeTotalsResult

setItemAndQuantity(String) - Method in class bb.common.PurchaseOrderContractResult

setItemComments(String) - Method in class bb.common.BillItemReplacementVO

setItemComments(String) - Method in class bb.common.BillItemUsagePathResult

setItemComments(String) - Method in class bb.common.JobProcessSheetResult

setItemComments(String) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setItemComments(String) - Method in class bb.common.OnLoanItemVO

setItemComments(String) - Method in class bb.common.OrderApprovalItemsVO

setItemComments(String) - Method in class bb.common.PfReceiverItemVO

setItemComments(String) - Method in class bb.common.PO2SOExchangeItem

setItemComments(String) - Method in class bb.common.ProformaInvoiceItemVO

setItemComments(String) - Method in class bb.common.PurchaseOrderItemVO

setItemComments(String) - Method in class bb.common.ReturnToVendorItemVO

setItemComments(String) - Method in class bb.common.SGCustRequestForQuoteItemVO

setItemComments(String) - Method in class bb.common.SwapOrderItemListResult

setItemComments(String) - Method in class bb.common.SwapOrderItemVO

setItemComments(String) - Method in class bb.common.SwapReceiverItemListResult

setItemComments(String) - Method in class bb.common.SwapReceiverItemVO

setItemComments(String) - Method in class bb.common.SwapShipperItemListResult

setItemComments(String) - Method in class bb.common.SwapShipperItemVO

setItemComments(String) - Method in class bb.common.TransferOrderItemListResult

setItemComments(String) - Method in class bb.common.TransferOrderItemVO

setItemComments(String) - Method in class bb.common.TransferReceiverItemListResult

setItemComments(String) - Method in class bb.common.TransferReceiverItemVO

setItemComments(String) - Method in class bb.common.TransferShipperItemListResult

setItemComments(String) - Method in class bb.common.TransferShipperItemVO

setItemComments(String) - Method in class bb.common.WorkOrderItemLaborCostListResult

setItemCount(Integer) - Method in class bb.common.ChangeStdCostWorkSheetVO

setItemCounts(Long) - Method in class bb.common.POStatisticsResult

setItemDescription(String) - Method in class bb.common.CRTVItemListResult

setItemDescription(String) - Method in class bb.common.OnLoanItemListResult

setItemDescription(String) - Method in class bb.common.PurchaseOrderItemListResult

setItemDescription(String) - Method in class bb.common.QuoteItemListResult

setItemDescription(String) - Method in class bb.common.RMAItemListResult

setItemDescription(String) - Method in class bb.common.RRMAItemListResult

setItemDescription(String) - Method in class bb.common.SalesOrderItemListResult

setItemGrandTotal(BigDecimal) - Method in class bb.common.ReceiverItemVO

setItemGrandTotal(BigDecimal) - Method in class bb.common.ReturnToVendorItemVO

setItemGrandTotal(BigDecimal) - Method in class bb.common.RtvShipperItemVO

setItemManf(Set) - Method in class bb.common.PO2SOExchangeItem

setItemNotes(String) - Method in class bb.common.OnLoanItemVO

setItemNotes(String) - Method in class bb.common.PurchaseWorkSheetItemVO

setItemNumber(Integer) - Method in class bb.common.AccountCreditDebitPK

setItemNumber(Short) - Method in class bb.common.AccountsPayableItemManufacturerPK

setItemNumber(String) - Method in class bb.common.BillItemUsagePathResult

setItemNumber(String) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setItemNumber(Short) - Method in class bb.common.DisassembleWorkOrderItemReceiverPK

setItemNumber(String) - Method in class bb.common.DisassembleWorkOrderReceivingResult

setItemNumber(String) - Method in class bb.common.InspectionConformanceReportItemCheckPK

setItemNumber(String) - Method in class bb.common.InspectionItemPK

setItemNumber(String) - Method in class bb.common.InspectionReportItemPK

setItemNumber(String) - Method in class bb.common.InspectionReportItemQtyPK

setItemNumber(String) - Method in class bb.common.InspectionTypeItemPK

setItemNumber(String) - Method in class bb.common.IssuedFromOrderItem

setItemNumber(Short) - Method in class bb.common.IssueItemAgent

setItemNumber(Short) - Method in class bb.common.IssuingItemResult

setItemNumber(String) - Method in class bb.common.IssuingResult

setItemNumber(String) - Method in class bb.common.LabelTemplateItemPK

setItemNumber(String) - Method in class bb.common.MakePrepaymentCheckAgent

setItemNumber(Short) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setItemNumber(Short) - Method in class bb.common.NonproductivePickingItemIssuedVO

setItemNumber(String) - Method in class bb.common.OrderDemandForReceiverResult

setItemNumber(String) - Method in class bb.common.OrderPK

setItemNumber(String) - Method in class bb.common.PartInspectionPK

setItemNumber(Short) - Method in class bb.common.PartIssuedVO

setItemNumber(Short) - Method in class bb.common.PartReceivedVO

setItemNumber(String) - Method in class bb.common.PO2SOExchangeItem

setItemNumber(String) - Method in class bb.common.PO2SOExchangeItemManufacturer

setItemNumber(String) - Method in class bb.common.PoMessageItemPK

setItemNumber(String) - Method in class bb.common.POReceiverItemListResult

setItemNumber(String) - Method in class bb.common.PurchaseOrderContractResult

setItemNumber(Short) - Method in class bb.common.PurchaseOrderItemManufacturerPK

setItemNumber(Integer) - Method in class bb.common.PurchaseWorkSheetItemPK

setItemNumber(Short) - Method in class bb.common.ReceivedToOrderItem

setItemNumber(Short) - Method in class bb.common.ReceiverItemAgent

setItemNumber(Short) - Method in class bb.common.ReceiverItemDetailAgent

setItemNumber(Short) - Method in class bb.common.ReceivingItemResult

setItemNumber(String) - Method in class bb.common.RefdocElement

setItemNumber(Short) - Method in class bb.common.ReturnMaterialAuthorizationItemManufacturerPK

setItemNumber(Short) - Method in class bb.common.ReturnToVendorItemManufacturerPK

setItemNumber(String) - Method in class bb.common.RfqMessageItemPK

setItemNumber(String) - Method in class bb.common.RMAReceiverItemListResult

setItemNumber(String) - Method in class bb.common.RMAReceiverItemPK

setItemNumber(String) - Method in class bb.common.SerialNumberItemResult

setItemNumber(String) - Method in class bb.common.SGBillItemPK

setItemNumber(String) - Method in class bb.common.SGPartListItemResult

setItemNumber(String) - Method in class bb.common.ShipperItemAgent

setItemNumber(String) - Method in class bb.common.ShippingItemResult

setItemNumber(String) - Method in class bb.common.StockTransactionPOReceiverResult

setItemNumber(String) - Method in class bb.common.StockTransactionSOShipperResult

setItemNumber(String) - Method in class bb.common.StockTransactionWOReceiverResult

setItemNumber(String) - Method in class bb.common.StockTransactionWOShipperResult

setItemNumber(String) - Method in class bb.common.WCLoadDetailResult

setItemNumber(String) - Method in class bb.common.WorkInstructionPictureVO

setItemNumber(Short) - Method in class bb.common.WorkOrderItemInWipListResult

setItemNumber(Short) - Method in class bb.common.WorkOrderItemIssuePK

setItemNumber(Short) - Method in class bb.common.WorkOrderItemPartDetailInWipVO

setItemNumber(Integer) - Method in class bb.common.WorkOrderWorkSheetItemPK

setItemPrincipal(String) - Method in class bb.common.OIPrincipalVO

setItemPrivateNotes(String) - Method in class bb.common.OrderApprovalItemsVO

setItemPrivateNotes(String) - Method in class bb.common.PfReceiverItemVO

setItemPrivateNotes(String) - Method in class bb.common.ProformaInvoiceItemVO

setItemPrivateNotes(String) - Method in class bb.common.PurchaseOrderItemVO

setItemPrivateNotes(String) - Method in class bb.common.ReturnToVendorItemVO

setItemPrivateNotes(String) - Method in class bb.common.SwapOrderItemVO

setItemPrivateNotes(String) - Method in class bb.common.SwapReceiverItemListResult

setItemPrivateNotes(String) - Method in class bb.common.SwapReceiverItemVO

setItemPrivateNotes(String) - Method in class bb.common.SwapShipperItemListResult

setItemPrivateNotes(String) - Method in class bb.common.SwapShipperItemVO

setItemPrivateNotes(String) - Method in class bb.common.TransferOrderItemListResult

setItemPrivateNotes(String) - Method in class bb.common.TransferOrderItemVO

setItemPrivateNotes(String) - Method in class bb.common.TransferReceiverItemListResult

setItemPrivateNotes(String) - Method in class bb.common.TransferReceiverItemVO

setItemPrivateNotes(String) - Method in class bb.common.TransferShipperItemListResult

setItemPrivateNotes(String) - Method in class bb.common.TransferShipperItemVO

setItemQty(BigDecimal) - Method in class bb.common.BillItemUsagePathResult

setItemQty(BigDecimal) - Method in class bb.common.POStatisticsResult

setItemQty(BigDecimal) - Method in class bb.common.SGBillItemVO

setItemReceivable(boolean) - Method in class bb.common.ReceivingItemResult

setItemReceivableAll(boolean) - Method in class bb.common.ReceivingItemResult

setItems(byte) - Method in class bb.common.AccountBalanceResult

setItems(byte) - Method in class bb.common.AccountsChartVO

setItems(LinkedHashSet<AddProformaReceiverItemAgent>) - Method in class bb.common.AddProformaReceiverAgent

setItems(byte) - Method in class bb.common.BalanceSheetSideBySideItemResult

setItems(Set) - Method in class bb.common.BillSalesResult

setItems(Set) - Method in class bb.common.BillSalesXResult

setItems(Set<List<BillWhereUsedItemResult>>) - Method in class bb.common.BillWhereUsedResult

setItems(Set) - Method in class bb.common.BomPickListResult

setItems(Set) - Method in class bb.common.BomWithOEMResult

setItems(byte) - Method in class bb.common.BudgetListResult

setItems(byte) - Method in class bb.common.ClosingStatementItemResult

setItems(Set<DisassembleWorkOrderItemPartDetailItemResult>) - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

setItems(byte) - Method in class bb.common.ExchangeAuditItemResult

setItems(HashSet<ContractPriceItemVO>) - Method in class bb.common.ImportContractPriceData

setItems(Set<InspectionReportItemQtyVO>) - Method in class bb.common.InspectionReportItemVO

setItems(Set) - Method in class bb.common.InventoryCycleResult

setItems(Set<LabelTemplateItemVO>) - Method in class bb.common.LabelTemplateVO

setItems(Set) - Method in class bb.common.OrderApprovalVO

setItems(Set) - Method in class bb.common.PartMaterialBomListResult

setItems(Set) - Method in class bb.common.PartMaterialWhereUsedResult

setItems(Set) - Method in class bb.common.PfReceiverVO

setItems(Set) - Method in class bb.common.PO2SOExchange

setItems(Set<PoMessageItemVO>) - Method in class bb.common.PoMessageVO

setItems(byte) - Method in class bb.common.ProfitLossStatementItemResult

setItems(List<PurchaseOrderOnTimeItemResult>) - Method in class bb.common.PurchaseOnTimeResult

setItems(Set<ReceiverItemAgent>) - Method in class bb.common.ReceiverAgent

setItems(Set) - Method in class bb.common.RfqMessageVO

setItems(Set) - Method in class bb.common.RMAReceiverVO

setItems(Set) - Method in class bb.common.SalesBomResult

setItems(List<SalesOrderOnTimeItemResult>) - Method in class bb.common.SalesOnTimeResult

setItems(Set) - Method in class bb.common.SalesPartListResult

setItems(ArrayList) - Method in class bb.common.SerialNumberResult

setItems(List<SGBOMItemResult>) - Method in class bb.common.SGBOMResult

setItems(List<SGQuoteCartListResult>) - Method in class bb.common.SGCartCheckOutResult

setItems(Set<SGCustRequestForQuoteItemResult>) - Method in class bb.common.SGCustRequestForQuoteResult

setItems(Set) - Method in class bb.common.SGCustRequestForQuoteVO

setItems(Set<SGPartListItemResult>) - Method in class bb.common.SGPartListResult

setItems(ArrayList<OrderVendorItem>) - Method in class bb.common.ShipListItemRelatedDocResult

setItems(Set) - Method in class bb.common.ShipperAgent

setItems(Set) - Method in class bb.common.SoPickListResult

setItems(Set) - Method in class bb.common.ToolListVO

setItems(Set<WarehouseTransferVO>) - Method in class bb.common.WarehouseVO

setItems(Set<WoItemPickListItemResult>) - Method in class bb.common.WoItemPickListResult

setItems(List) - Method in class bb.common.WorkInstructionSummaryResult

setItems(Set<WorkOrderItemPartDetailItemResult>) - Method in class bb.common.WorkOrderItemPartDetailResult

setItems(List<WorkOrderItemTimeDetailVO>) - Method in class bb.common.WorkOrderItemTimeDetailResult

setItems(List<WorkOrderItemSeqWCLoadResult>) - Method in class bb.common.WorkOrderItemWCLoadResult

setItems(List<WorkOrderOnTimeItemResult>) - Method in class bb.common.WorkOrderOnTimeResult

setItemStatus(String) - Method in class bb.common.DisassembleWorkOrderReceivingResult

setItemStatus(String) - Method in class bb.common.IssuingResult

setItemStatus(String) - Method in class bb.common.SwapOrderItemListResult

setItemSubTotal(BigDecimal) - Method in class bb.common.PoMessageItemVO

setItemSubTotal(BigDecimal) - Method in class bb.common.PurchaseOrderItemVO

setItemTotalCount(Integer) - Method in class bb.common.InfoByMonthResult

setItemTotalDiscount(BigDecimal) - Method in class bb.common.PoMessageItemVO

setItemTotalDiscount(BigDecimal) - Method in class bb.common.PurchaseOrderItemVO

setItemTotalTax(BigDecimal) - Method in class bb.common.PoMessageItemVO

setItemTotalTax(BigDecimal) - Method in class bb.common.PurchaseOrderItemListResult

setItemTotalTax(BigDecimal) - Method in class bb.common.PurchaseOrderItemVO

setItemType(String) - Method in class bb.common.LabelTemplateItemVO

setItran(String) - Method in class bb.common.AccountsPayableInfoVO

setItran(String) - Method in class bb.common.AccountsPayableVO

setItran(String) - Method in class bb.common.OnloanReceiverVO

setItran(String) - Method in class bb.common.ReceiverInfoVO

setItran(String) - Method in class bb.common.ReceiverVO

setItran(String) - Method in class bb.common.RMAReceiverVO

setJj(Byte) - Method in class bb.common.VendorQtyPricePK

setJobId(String) - Method in class bb.common.CustomEmployeeVO

setJobId(String) - Method in class bb.common.CustomJobCategoryGoodsPK

setJobId(String) - Method in class bb.common.EmployeeCardVO

setJobId(String) - Method in class bb.common.EmployeePutGoodListResult

setJobId(String) - Method in class bb.common.SalesmanVO

setJobName(String) - Method in class bb.common.EmployeePutGoodListResult

setJobTitle(String) - Method in class bb.common.CustomEmployeeWorkExperienceVO

setJobTitle(String) - Method in class bb.common.EmployeeWorkExperienceVO

setJreVersion(String) - Method in class bb.common.BizboxBugInfoVO

setJreVersion(String) - Method in class bb.common.BizboxBugVO

setKeeper(String) - Method in class bb.common.WareHousePartPrefixKeeperVO

setKey(String) - Method in class bb.common.PartDwgAgent

setKg(double) - Method in class bb.common.SGWeightUnitVO

setKg(double) - Method in class bb.common.WeightUnitVO

setKitNumber(Integer) - Method in class bb.common.BillItemVO

setKitNumber(Integer) - Method in class bb.common.BillItemWithPartInfoResult

setLabelPosition(int) - Method in class bb.common.LabelTemplateItemVO

setLabelType(String) - Method in class bb.common.LabelTemplateVO

setLabelVisible(boolean) - Method in class bb.common.LabelTemplateItemVO

setLaborCost(boolean) - Method in class bb.common.AccountingSettingsVO

setLanguage(String) - Method in class bb.common.AccountPayableCheckRunItemVO

setLanguage(String) - Method in class bb.common.AccountPayableCheckVO

setLanguage(String) - Method in class bb.common.AccountReceivablePaymentVO

setLanguage(String) - Method in class bb.common.AccountsReceivableInfoVO

setLanguage(String) - Method in class bb.common.AccountsReceivableVO

setLanguage(String) - Method in class bb.common.AllPartDocumentsPK

setLanguage(String) - Method in class bb.common.ARPaymentRunItemVO

setLanguage(String) - Method in class bb.common.BB2Login

setLanguage(String) - Method in class bb.common.CompanyVO

setLanguage(String) - Method in class bb.common.CustomerReturnToVendorVO

setLanguage(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setLanguage(String) - Method in class bb.common.CustomerVendorAddressVO

setLanguage(String) - Method in class bb.common.CustomerVendorDescriptionPK

setLanguage(String) - Method in class bb.common.DisassembleWorkOrderVO

setLanguage(String) - Method in class bb.common.DocumentInfoAgent

setLanguage(String) - Method in class bb.common.HelpServerVO

setLanguage(String) - Method in class bb.common.LogPartDocumentVO

setLanguage(String) - Method in class bb.common.LogPartDwfVO

setLanguage(String) - Method in class bb.common.ManufacturerDescriptionPK

setLanguage(String) - Method in class bb.common.MiscDocAgent

setLanguage(String) - Method in class bb.common.MultiLanguageAccountsChartPK

setLanguage(String) - Method in class bb.common.NonConformanceCodeDescriptionPK

setLanguage(String) - Method in class bb.common.OnloanShipperVO

setLanguage(String) - Method in class bb.common.OnLoanVO

setLanguage(String) - Method in class bb.common.PartDocumentPK

setLanguage(String) - Method in class bb.common.PartDwfAgent

setLanguage(String) - Method in class bb.common.PartDwfPK

setLanguage(String) - Method in class bb.common.PartDwfWithPartInfoResult

setLanguage(String) - Method in class bb.common.PermissionDescriptionPK

setLanguage(String) - Method in class bb.common.ProformaInvoiceVO

setLanguage(String) - Method in class bb.common.PurchaseOrderVO

setLanguage(String) - Method in class bb.common.QuoteVO

setLanguage(String) - Method in class bb.common.RequestForQuoteVO

setLanguage(String) - Method in class bb.common.RequestForRMAVO

setLanguage(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setLanguage(String) - Method in class bb.common.ReturnToVendorVO

setLanguage(String) - Method in class bb.common.RMAReceiverVO

setLanguage(String) - Method in class bb.common.RoleDescriptionPK

setLanguage(String) - Method in class bb.common.RtvShipperInfoVO

setLanguage(String) - Method in class bb.common.RtvShipperVO

setLanguage(String) - Method in class bb.common.SalesmanVO

setLanguage(String) - Method in class bb.common.SalesOrderVO

setLanguage(String) - Method in class bb.common.SgClientProgramUserVO

setLanguage(String) - Method in class bb.common.SGCustRequestForQuoteListResult

setLanguage(String) - Method in class bb.common.SGCustRequestForQuoteResult

setLanguage(String) - Method in class bb.common.SGDocPartPK

setLanguage(String) - Method in class bb.common.SGDwgPicturePK

setLanguage(String) - Method in class bb.common.SGPartDocFlagResult

setLanguage(String) - Method in class bb.common.SGQuoteAddressVO

setLanguage(String) - Method in class bb.common.ShipperInfoVO

setLanguage(String) - Method in class bb.common.ShipperVO

setLanguage(String) - Method in class bb.common.SwapOrderListResult

setLanguage(String) - Method in class bb.common.SwapOrderVO

setLanguage(String) - Method in class bb.common.SwapReceiverListResult

setLanguage(String) - Method in class bb.common.SwapReceiverVO

setLanguage(String) - Method in class bb.common.SwapShipperListResult

setLanguage(String) - Method in class bb.common.SwapShipperVO

setLanguage(String) - Method in class bb.common.TransferOrderListResult

setLanguage(String) - Method in class bb.common.TransferOrderVO

setLanguage(String) - Method in class bb.common.TransferReceiverListResult

setLanguage(String) - Method in class bb.common.TransferReceiverVO

setLanguage(String) - Method in class bb.common.TransferShipperListResult

setLanguage(String) - Method in class bb.common.TransferShipperVO

setLanguage(String) - Method in class bb.common.VendorGroupUserVO

setLanguage(String) - Method in class bb.common.WorkOrderVO

setLanguage2(String) - Method in class bb.common.WorkInstructionSequenceVO

setLanguage2(String) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setLanguage3(String) - Method in class bb.common.WorkInstructionSequenceVO

setLanguage3(String) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setLanguageCode(String) - Method in class bb.common.BizBoxServer

setLanguageCode(String) - Method in class bb.common.PartDescriptionPK

setLanguageCode(String) - Method in class bb.common.SubcompanyLoginAgent

setLanIp(String) - Method in class bb.common.BizboxUserVO

setLanIp(String) - Method in class bb.common.DocumentInfoAgent

setLanIp(String) - Method in class bb.common.LogMiscDocumentVO

setLanIp(String) - Method in class bb.common.LogPartDocumentVO

setLanIp(String) - Method in class bb.common.LogPartDwfVO

setLanIp(String) - Method in class bb.common.LogPartDwgVO

setLanIp(String) - Method in class bb.common.MiscDocAgent

setLanIp(String) - Method in class bb.common.OperationLogVO

setLanIp(String) - Method in class bb.common.PartDwfAgent

setLanIp(String) - Method in class bb.common.PartDwgAgent

setLastAdjustment(InventoryAdjustmentVO) - Method in class bb.common.InventoryAdjustmentDetailResult

setLastBy(String) - Method in class bb.common.WorkFlowVO

setLastCahgeDate(Date) - Method in class bb.common.ShipListInfoVO

setLastCahgeDate(Date) - Method in class bb.common.ShipListVO

setLastChangeBy(String) - Method in class bb.common.SubcompanyVO

setLastChangeDate(Date) - Method in class bb.common.AccountingConfigurationVO

setLastChangeDate(Date) - Method in class bb.common.AccountingInfoDocumentVO

setLastChangeDate(Date) - Method in class bb.common.AccountingSettingsVO

setLastChangeDate(Date) - Method in class bb.common.AccountPayableCheckRunItemVO

setLastChangeDate(Date) - Method in class bb.common.AccountPayableCheckVO

setLastChangeDate(Date) - Method in class bb.common.AccountReceivablePaymentVO

setLastChangeDate(Date) - Method in class bb.common.AccountsChartMappingVO

setLastChangeDate(Date) - Method in class bb.common.AccountsChartVO

setLastChangeDate(Date) - Method in class bb.common.AccountsPayableInfoVO

setLastChangeDate(Date) - Method in class bb.common.AccountsPayableVO

setLastChangeDate(Date) - Method in class bb.common.AccountsReceivableInfoVO

setLastChangeDate(Date) - Method in class bb.common.AccountsReceivableVO

setLastChangeDate(Date) - Method in class bb.common.AddressQualityDocumentsVO

setLastChangeDate(Date) - Method in class bb.common.AllPartDocumentsVO

setLastChangeDate(Date) - Method in class bb.common.ApPrepayVO

setLastChangeDate(Date) - Method in class bb.common.ARPaymentRunItemVO

setLastChangeDate(Date) - Method in class bb.common.ArPrepayVO

setLastChangeDate(Date) - Method in class bb.common.AssetTypeVO

setLastChangeDate(Date) - Method in class bb.common.AssetVO

setLastChangeDate(Date) - Method in class bb.common.BillSalesCostResult

setLastChangeDate(Date) - Method in class bb.common.BillVO

setLastChangeDate(Date) - Method in class bb.common.BillWithPartInfoResult

setLastChangeDate(Date) - Method in class bb.common.CommonPrintTemplateVO

setLastChangeDate(Date) - Method in class bb.common.CompanyUnitAccountVO

setLastChangeDate(Date) - Method in class bb.common.CompanyUnitVO

setLastChangeDate(Date) - Method in class bb.common.CompanyVO

setLastChangeDate(Date) - Method in class bb.common.ContractPriceVO

setLastChangeDate(Date) - Method in class bb.common.CorrectiveActionRequestVO

setLastChangeDate(Date) - Method in class bb.common.CustomAssetVO

setLastChangeDate(Date) - Method in class bb.common.CustomEmployeeVO

setLastChangeDate(Date) - Method in class bb.common.CustomerFeedbackVO

setLastChangeDate(Date) - Method in class bb.common.CustomerReturnToVendorVO

setLastChangeDate(Date) - Method in class bb.common.CustomerServiceIncidentVO

setLastChangeDate(Date) - Method in class bb.common.CustomerVendorAddressInfoVO

setLastChangeDate(Date) - Method in class bb.common.CustomerVendorAddressVO

setLastChangeDate(Date) - Method in class bb.common.CycleCountStatusVO

setLastChangeDate(Date) - Method in class bb.common.DesignControlDocumentVO

setLastChangeDate(Date) - Method in class bb.common.DesignControlInfoVO

setLastChangeDate(Date) - Method in class bb.common.DesignControlVO

setLastChangeDate(Date) - Method in class bb.common.DisassembleWorkOrderDocumentVO

setLastChangeDate(Date) - Method in class bb.common.DisassembleWorkOrderIssueVO

setLastChangeDate(Date) - Method in class bb.common.DisassembleWorkOrderVO

setLastChangeDate(Date) - Method in class bb.common.EmployeeCardVO

setLastChangeDate(Date) - Method in class bb.common.EngineeringChangeDocumentVO

setLastChangeDate(Date) - Method in class bb.common.EngineeringChangeRequestDocumentVO

setLastChangeDate(Date) - Method in class bb.common.EngineeringChangeRequestVO

setLastChangeDate(Date) - Method in class bb.common.EngineeringChangeVO

setLastChangeDate(Date) - Method in class bb.common.EngineeringSharingVO

setLastChangeDate(Date) - Method in class bb.common.ExpenseVO

setLastChangeDate(Date) - Method in class bb.common.GeneralLedgerListResult

setLastChangeDate(Date) - Method in class bb.common.GeneralLedgerSettingsVO

setLastChangeDate(Date) - Method in class bb.common.GeneralLedgerVO

setLastChangeDate(Date) - Method in class bb.common.InspectionConformanceReportVO

setLastChangeDate(Date) - Method in class bb.common.InspectionReportInfoVO

setLastChangeDate(Date) - Method in class bb.common.InspectionReportVO

setLastChangeDate(Date) - Method in class bb.common.InventoryAdjustmentVO

setLastChangeDate(Date) - Method in class bb.common.LabelTemplateVO

setLastChangeDate(Date) - Method in class bb.common.LogInventoryVO

setLastchangeDate(Date) - Method in class bb.common.LogMiscDocumentVO

setLastChangeDate(Date) - Method in class bb.common.LogPartDocumentVO

setLastChangeDate(Date) - Method in class bb.common.LogPartDwfVO

setLastChangeDate(Date) - Method in class bb.common.LogPartDwgVO

setLastChangeDate(Date) - Method in class bb.common.LogTrackingVO

setLastChangeDate(Date) - Method in class bb.common.ManufacturerAddressInfoVO

setLastChangeDate(Date) - Method in class bb.common.ManufacturerAddressVO

setLastChangeDate(Date) - Method in class bb.common.MyPrintListVO

setLastChangeDate(Date) - Method in class bb.common.NcrNeedToScrapListResult

setLastChangeDate(Date) - Method in class bb.common.NonConformanceCodeVO

setLastChangeDate(Date) - Method in class bb.common.NonConformanceReportVO

setLastChangeDate(Date) - Method in class bb.common.NonproductivePickingVO

setLastChangeDate(Date) - Method in class bb.common.OnloanDocumentVO

setLastChangeDate(Date) - Method in class bb.common.OnloanReceiverVO

setLastChangedate(Date) - Method in class bb.common.OnloanShipperVO

setLastChangeDate(Date) - Method in class bb.common.OnLoanVO

setLastChangeDate(Date) - Method in class bb.common.OperatingInstructionsVO

setLastChangeDate(Date) - Method in class bb.common.OrderBoilerplateVO

setLastChangeDate(Date) - Method in class bb.common.OrderDocumentVO

setLastChangeDate(Date) - Method in class bb.common.PartBasicInfo

setLastChangeDate(Date) - Method in class bb.common.PartCertificateVO

setLastChangeDate(Date) - Method in class bb.common.PartDocumentVO

setLastChangeDate(Date) - Method in class bb.common.PartDwfVO

setLastChangeDate(Date) - Method in class bb.common.PartDwfWithPartInfoResult

setLastChangeDate(Date) - Method in class bb.common.PartDwgVO

setLastChangeDate(Date) - Method in class bb.common.PartDwgWithPartInfoResult

setLastChangeDate(Date) - Method in class bb.common.PartPictureVO

setLastChangeDate(Date) - Method in class bb.common.PartTrackingVO

setLastChangeDate(Date) - Method in class bb.common.PartVO

setLastChangeDate(Date) - Method in class bb.common.PartWithOnhandsVO

setLastChangeDate(Date) - Method in class bb.common.PaymentHistoryVO

setLastChangeDate(Date) - Method in class bb.common.PfReceiverVO

setLastChangeDate(Date) - Method in class bb.common.PhysicalInventoryStatusVO

setLastChangeDate(Date) - Method in class bb.common.PointOfSaleVO

setLastChangeDate(Date) - Method in class bb.common.PosRefdocVO

setLastChangeDate(Date) - Method in class bb.common.POSurveyReportVO

setLastChangeDate(Date) - Method in class bb.common.PreventiveActionRequestVO

setLastChangeDate(Date) - Method in class bb.common.PrintLogoVO

setLastChangeDate(Date) - Method in class bb.common.PrintTemplateVO

setLastChangeDate(Date) - Method in class bb.common.ProformaInvoiceVO

setLastChangeDate(Date) - Method in class bb.common.PurchaseOrderDocumentVO

setLastChangeDate(Date) - Method in class bb.common.PurchaseOrderVO

setLastChangeDate(Date) - Method in class bb.common.PurchaseWorkSheetItemVO

setLastChangeDate(Date) - Method in class bb.common.QuoteDocumentVO

setLastChangeDate(Date) - Method in class bb.common.QuoteVO

setLastChangeDate(Date) - Method in class bb.common.ReceiverInfoVO

setLastChangeDate(Date) - Method in class bb.common.ReceiverVO

setLastChangeDate(Date) - Method in class bb.common.RefdocVO

setLastChangeDate(Date) - Method in class bb.common.RequestForQuoteVO

setLastChangeDate(Date) - Method in class bb.common.RequestForRMAVO

setLastChangeDate(Date) - Method in class bb.common.ReturnMaterialAuthorizationDocumentVO

setLastChangeDate(Date) - Method in class bb.common.ReturnMaterialAuthorizationVO

setLastChangeDate(Date) - Method in class bb.common.ReturnToVendorVO

setLastChangeDate(Date) - Method in class bb.common.RMAReceiverVO

setLastChangeDate(Date) - Method in class bb.common.RtvShipperInfoVO

setLastChangeDate(Date) - Method in class bb.common.RtvShipperVO

setLastChangeDate(Date) - Method in class bb.common.SalesCodeVO

setLastChangeDate(Date) - Method in class bb.common.SalesmanVO

setLastChangeDate(Date) - Method in class bb.common.SalesOrderDocumentVO

setLastChangeDate(Date) - Method in class bb.common.SalesOrderVO

setLastChangeDate(Date) - Method in class bb.common.ScrapReportVO

setLastChangeDate(Date) - Method in class bb.common.SerialNumberVO

setLastChangeDate(Date) - Method in class bb.common.ServerClientPropertyVO

setLastChangeDate(Date) - Method in class bb.common.SGCompanyVO

setLastChangeDate(Date) - Method in class bb.common.SGCustomerServiceRequestVO

setLastChangeDate(Date) - Method in class bb.common.SGCustRequestForQuoteVO

setLastChangeDate(Date) - Method in class bb.common.SGDocPartVO

setLastChangeDate(Date) - Method in class bb.common.SGDwgPictureVO

setLastChangeDate(Date) - Method in class bb.common.SGLogLoginVO

setLastChangeDate(Date) - Method in class bb.common.SGPictureVO

setLastChangeDate(Date) - Method in class bb.common.SGQuoteCartVO

setLastChangeDate(Date) - Method in class bb.common.SGQuoteLoginVO

setLastChangeDate(Date) - Method in class bb.common.ShipListOwnerVO

setLastChangedate(Date) - Method in class bb.common.ShipperInfoVO

setLastChangedate(Date) - Method in class bb.common.ShipperVO

setLastChangeDate(Date) - Method in class bb.common.SubcompanyVO

setLastChangeDate(Date) - Method in class bb.common.SwapOrderListResult

setLastChangeDate(Date) - Method in class bb.common.SwapOrderVO

setLastChangeDate(Date) - Method in class bb.common.SwapReceiverListResult

setLastChangeDate(Date) - Method in class bb.common.SwapReceiverVO

setLastChangeDate(Date) - Method in class bb.common.SwapShipperListResult

setLastChangeDate(Date) - Method in class bb.common.SwapShipperVO

setLastChangeDate(Date) - Method in class bb.common.TempArApAgingVO

setLastChangeDate(Date) - Method in class bb.common.TermsConditionVO

setLastChangeDate(Date) - Method in class bb.common.ToolListInfoVO

setLastChangeDate(Date) - Method in class bb.common.ToolListVO

setLastChangeDate(Date) - Method in class bb.common.ToolListWithToolInfoResult

setLastChangeDate(Date) - Method in class bb.common.ToolVO

setLastChangeDate(Date) - Method in class bb.common.ToolWithOnhandsVO

setLastChangeDate(Date) - Method in class bb.common.TransferOrderListResult

setLastChangeDate(Date) - Method in class bb.common.TransferOrderVO

setLastChangeDate(Date) - Method in class bb.common.TransferReceiverListResult

setLastChangeDate(Date) - Method in class bb.common.TransferReceiverVO

setLastChangeDate(Date) - Method in class bb.common.TransferShipperListResult

setLastChangeDate(Date) - Method in class bb.common.TransferShipperVO

setLastChangeDate(Date) - Method in class bb.common.VendorContractPriceVO

setLastChangeDate(Date) - Method in class bb.common.WarehouseVO

setLastChangeDate(Date) - Method in class bb.common.WorkCenterVO

setLastChangeDate(Date) - Method in class bb.common.WorkFlowVO

setLastChangeDate(Date) - Method in class bb.common.WorkInstructionDocumentVO

setLastChangeDate(Date) - Method in class bb.common.WorkInstructionRequestForChangeVO

setLastChangeDate(Date) - Method in class bb.common.WorkInstructionVO

setLastChangeDate(Date) - Method in class bb.common.WorkOrderDocumentVO

setLastChangeDate(Date) - Method in class bb.common.WorkOrderItemPartDetailInWipVO

setLastChangeDate(Date) - Method in class bb.common.WorkOrderItemTimeDetailVO

setLastChangeDate(Date) - Method in class bb.common.WorkOrderReceiverVO

setLastChangeDate(Date) - Method in class bb.common.WorkOrderVO

setLastChangeDate(Date) - Method in class bb.common.WorkOrderWorkInstructionVO

setLastChangeDate(Date) - Method in class bb.common.WorkOrderWorkSheetItemVO

setLastChangePassword(Date) - Method in class bb.common.BizboxUserVO

setLastChangeTime(Date) - Method in class bb.common.BillLogVO

setLastChangeTime(int) - Method in class bb.common.OnloanShipperVO

setLastChangeTime(Integer) - Method in class bb.common.PosRefdocVO

setLastChangeTime(Integer) - Method in class bb.common.RefdocVO

setLastChangeTime(Integer) - Method in class bb.common.SGCompanyVO

setLastChangeTime(Date) - Method in class bb.common.SGLogLoginVO

setLastChangeTime(int) - Method in class bb.common.ShipperVO

setLastChangeTime(int) - Method in class bb.common.TransferReceiverListResult

setLastChangeTime(int) - Method in class bb.common.TransferReceiverVO

setLastChangeTime(int) - Method in class bb.common.TransferShipperListResult

setLastChangeTime(int) - Method in class bb.common.TransferShipperVO

setLastChangeTimes(int) - Method in class bb.common.AccountsChartVO

setLastChangeTimes(int) - Method in class bb.common.AssetDepreciateVO

setLastChangeTimes(Integer) - Method in class bb.common.AssetTypeVO

setLastChangeTimes(int) - Method in class bb.common.AssetVO

setLastChangeTimes(Integer) - Method in class bb.common.CompanyUnitVO

setLastChangeTimes(Integer) - Method in class bb.common.CompanyVO

setLastChangeTimes(int) - Method in class bb.common.ContractPriceVO

setLastChangeTimes(int) - Method in class bb.common.CustomerVendorAddressInfoVO

setLastChangeTimes(int) - Method in class bb.common.DesignControlInfoVO

setLastChangeTimes(int) - Method in class bb.common.DisassembleWorkOrderVO

setLastChangeTimes(Integer) - Method in class bb.common.GeneralLedgerListResult

setLastChangeTimes(Integer) - Method in class bb.common.GeneralLedgerVO

setLastChangeTimes(int) - Method in class bb.common.MakeAccountPayableAgent

setLastChangeTimes(int) - Method in class bb.common.MakeBillAndHoldInvoiceAgent

setLastChangeTimes(int) - Method in class bb.common.MakeCreditMemoAgent

setLastChangeTimes(int) - Method in class bb.common.MakeInvoiceAgent

setLastChangeTimes(int) - Method in class bb.common.ManufacturerAddressInfoVO

setLastChangeTimes(int) - Method in class bb.common.OnloanReceiverVO

setLastChangeTimes(int) - Method in class bb.common.PfReceiverVO

setLastChangeTimes(Integer) - Method in class bb.common.PointOfSaleVO

setLastChangeTimes(int) - Method in class bb.common.POSurveyReportVO

setLastChangeTimes(int) - Method in class bb.common.ProformaInvoiceVO

setLastChangeTimes(int) - Method in class bb.common.PurchaseOrderVO

setLastChangeTimes(int) - Method in class bb.common.ReceiverInfoVO

setLastChangeTimes(int) - Method in class bb.common.ReceiverVO

setLastChangeTimes(int) - Method in class bb.common.RequestForQuoteVO

setLastChangeTimes(Integer) - Method in class bb.common.ReturnToVendorVO

setLastChangeTimes(Integer) - Method in class bb.common.SalesCodeVO

setLastChangeTimes(int) - Method in class bb.common.SalesmanVO

setLastChangeTimes(Integer) - Method in class bb.common.ScrapReportVO

setLastChangeTimes(int) - Method in class bb.common.ShipListInfoVO

setLastChangeTimes(int) - Method in class bb.common.VendorContractPriceVO

setLastChangeTimes(int) - Method in class bb.common.WarehouseVO

setLastChangeTimes(int) - Method in class bb.common.WorkInstructionRequestForChangeVO

setLastChangeTimes(int) - Method in class bb.common.WorkOrderVO

setLastChangeUser(String) - Method in class bb.common.AccountingConfigurationVO

setLastChangeUser(String) - Method in class bb.common.AccountingSettingsVO

setLastChangeUser(String) - Method in class bb.common.AccountPayableCheckRunItemVO

setLastChangeUser(String) - Method in class bb.common.AccountPayableCheckVO

setLastChangeUser(String) - Method in class bb.common.AccountReceivablePaymentVO

setLastChangeUser(String) - Method in class bb.common.AccountsChartMappingVO

setLastChangeUser(String) - Method in class bb.common.AccountsChartVO

setLastChangeUser(String) - Method in class bb.common.AccountsPayableInfoVO

setLastChangeUser(String) - Method in class bb.common.AccountsPayableVO

setLastChangeUser(String) - Method in class bb.common.AccountsReceivableInfoVO

setLastChangeUser(String) - Method in class bb.common.AccountsReceivableVO

setLastChangeUser(String) - Method in class bb.common.AddressQualityDocumentsVO

setLastChangeUser(String) - Method in class bb.common.AllPartDocumentsVO

setLastChangeUser(String) - Method in class bb.common.ApPrepayVO

setLastChangeUser(String) - Method in class bb.common.ARPaymentRunItemVO

setLastChangeUser(String) - Method in class bb.common.ArPrepayVO

setLastChangeUser(String) - Method in class bb.common.AssetTypeVO

setLastChangeUser(String) - Method in class bb.common.AssetVO

setLastChangeUser(String) - Method in class bb.common.BillLogVO

setLastChangeUser(String) - Method in class bb.common.BillSalesCostResult

setLastChangeUser(String) - Method in class bb.common.BillVO

setLastChangeUser(String) - Method in class bb.common.BillWithPartInfoResult

setLastChangeUser(String) - Method in class bb.common.CommonPrintTemplateVO

setLastChangeUser(String) - Method in class bb.common.CompanyUnitAccountVO

setLastChangeUser(String) - Method in class bb.common.CompanyUnitVO

setLastChangeUser(String) - Method in class bb.common.CompanyVO

setLastChangeUser(String) - Method in class bb.common.ContractPriceVO

setLastChangeUser(String) - Method in class bb.common.CorrectiveActionRequestVO

setLastChangeUser(String) - Method in class bb.common.CustomAssetVO

setLastChangeUser(String) - Method in class bb.common.CustomEmployeeVO

setLastChangeUser(String) - Method in class bb.common.CustomerFeedbackVO

setLastChangeUser(String) - Method in class bb.common.CustomerReturnToVendorVO

setLastChangeUser(String) - Method in class bb.common.CustomerServiceIncidentVO

setLastChangeUser(String) - Method in class bb.common.CycleCountStatusVO

setLastChangeUser(String) - Method in class bb.common.DesignControlDocumentVO

setLastChangeUser(String) - Method in class bb.common.DesignControlInfoVO

setLastChangeUser(String) - Method in class bb.common.DesignControlVO

setLastChangeUser(String) - Method in class bb.common.DisassembleWorkOrderDocumentVO

setLastChangeUser(String) - Method in class bb.common.DisassembleWorkOrderIssueVO

setLastChangeUser(String) - Method in class bb.common.DisassembleWorkOrderVO

setLastChangeUser(String) - Method in class bb.common.DWOIssueDetail

setLastChangeUser(String) - Method in class bb.common.EmployeeCardVO

setLastChangeUser(String) - Method in class bb.common.EngineeringChangeDocumentVO

setLastChangeUser(String) - Method in class bb.common.EngineeringChangeRequestDocumentVO

setLastChangeUser(String) - Method in class bb.common.EngineeringSharingVO

setLastChangeUser(String) - Method in class bb.common.ExpenseVO

setLastChangeUser(String) - Method in class bb.common.GeneralLedgerListResult

setLastChangeUser(String) - Method in class bb.common.GeneralLedgerSettingsVO

setLastChangeUser(String) - Method in class bb.common.GeneralLedgerVO

setLastChangeUser(String) - Method in class bb.common.InspectionConformanceReportItemInfo

setLastChangeUser(String) - Method in class bb.common.InspectionConformanceReportVO

setLastChangeUser(String) - Method in class bb.common.InspectionReportInfoVO

setLastChangeUser(String) - Method in class bb.common.InspectionReportVO

setLastChangeUser(String) - Method in class bb.common.InventoryAdjustmentVO

setLastChangeUser(String) - Method in class bb.common.LabelTemplateVO

setLastChangeUser(String) - Method in class bb.common.LogInventoryVO

setLastChangeUser(String) - Method in class bb.common.LogMiscDocumentVO

setLastChangeUser(String) - Method in class bb.common.LogPartDocumentVO

setLastChangeUser(String) - Method in class bb.common.LogPartDwfVO

setLastChangeUser(String) - Method in class bb.common.LogPartDwgVO

setLastChangeUser(String) - Method in class bb.common.LogTrackingVO

setLastChangeUser(String) - Method in class bb.common.ManufacturerAddressInfoVO

setLastChangeUser(String) - Method in class bb.common.ManufacturerAddressVO

setLastChangeUser(String) - Method in class bb.common.NcrNeedToScrapListResult

setLastChangeUser(String) - Method in class bb.common.NonConformanceCodeVO

setLastChangeUser(String) - Method in class bb.common.NonConformanceReportVO

setLastChangeUser(String) - Method in class bb.common.OnloanDocumentVO

setLastChangeUser(String) - Method in class bb.common.OnloanReceiverVO

setLastChangeUser(String) - Method in class bb.common.OnloanShipperVO

setLastChangeUser(String) - Method in class bb.common.OnLoanVO

setLastChangeUser(String) - Method in class bb.common.OperatingInstructionsVO

setLastChangeUser(String) - Method in class bb.common.OrderDocumentVO

setLastChangeUser(String) - Method in class bb.common.PartCertificateVO

setLastChangeUser(String) - Method in class bb.common.PartDocumentVO

setLastChangeUser(String) - Method in class bb.common.PartDwfVO

setLastChangeUser(String) - Method in class bb.common.PartDwfWithPartInfoResult

setLastChangeUser(String) - Method in class bb.common.PartDwgVO

setLastChangeUser(String) - Method in class bb.common.PartDwgWithPartInfoResult

setLastChangeUser(String) - Method in class bb.common.PartPictureVO

setLastChangeUser(String) - Method in class bb.common.PfReceiverVO

setLastChangeUser(String) - Method in class bb.common.PhysicalInventoryStatusVO

setLastChangeUser(String) - Method in class bb.common.PointOfSaleVO

setLastChangeUser(String) - Method in class bb.common.PosRefdocVO

setLastChangeUser(String) - Method in class bb.common.POSurveyReportVO

setLastChangeUser(String) - Method in class bb.common.PreventiveActionRequestVO

setLastChangeUser(String) - Method in class bb.common.PrintTemplateVO

setLastChangeUser(String) - Method in class bb.common.ProformaInvoiceVO

setLastChangeUser(String) - Method in class bb.common.PurchaseOrderDocumentVO

setLastChangeUser(String) - Method in class bb.common.PurchaseOrderVO

setLastChangeUser(String) - Method in class bb.common.PurchaseWorkSheetItemVO

setLastChangeUser(String) - Method in class bb.common.ReceiverInfoVO

setLastChangeUser(String) - Method in class bb.common.ReceiverVO

setLastChangeUser(String) - Method in class bb.common.RefdocVO

setLastChangeUser(String) - Method in class bb.common.RequestForQuoteVO

setLastChangeUser(String) - Method in class bb.common.RequestForRMAVO

setLastChangeUser(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setLastChangeUser(String) - Method in class bb.common.ReturnToVendorVO

setLastChangeUser(String) - Method in class bb.common.RMAReceiverVO

setLastChangeUser(String) - Method in class bb.common.RtvShipperInfoVO

setLastChangeUser(String) - Method in class bb.common.RtvShipperVO

setLastChangeUser(String) - Method in class bb.common.SalesCodeVO

setLastChangeUser(String) - Method in class bb.common.SalesmanVO

setLastChangeUser(String) - Method in class bb.common.SalesOrderDocumentVO

setLastChangeUser(String) - Method in class bb.common.ScrapReportVO

setLastChangeUser(String) - Method in class bb.common.SerialNumberVO

setLastChangeUser(String) - Method in class bb.common.ServerClientPropertyVO

setLastChangeUser(String) - Method in class bb.common.SGCustomerServiceRequestVO

setLastChangeUser(String) - Method in class bb.common.ShipListOwnerVO

setLastChangeUser(String) - Method in class bb.common.ShipperInfoVO

setLastChangeUser(String) - Method in class bb.common.ShipperVO

setLastChangeUser(String) - Method in class bb.common.SwapOrderListResult

setLastChangeUser(String) - Method in class bb.common.SwapOrderVO

setLastChangeUser(String) - Method in class bb.common.SwapReceiverListResult

setLastChangeUser(String) - Method in class bb.common.SwapReceiverVO

setLastChangeUser(String) - Method in class bb.common.SwapShipperListResult

setLastChangeUser(String) - Method in class bb.common.SwapShipperVO

setLastChangeUser(String) - Method in class bb.common.ToolListInfoVO

setLastChangeUser(String) - Method in class bb.common.ToolListVO

setLastChangeUser(String) - Method in class bb.common.ToolListWithToolInfoResult

setLastChangeUser(String) - Method in class bb.common.VendorContractPriceVO

setLastChangeUser(String) - Method in class bb.common.WarehouseVO

setLastChangeUser(String) - Method in class bb.common.WOReceiverDetail

setLastChangeUser(String) - Method in class bb.common.WorkCenterVO

setLastChangeUser(String) - Method in class bb.common.WorkInstructionDocumentVO

setLastChangeUser(String) - Method in class bb.common.WorkInstructionPictureVO

setLastChangeUser(String) - Method in class bb.common.WorkInstructionRequestForChangeVO

setLastChangeUser(String) - Method in class bb.common.WorkInstructionVO

setLastChangeUser(String) - Method in class bb.common.WorkOrderDocumentVO

setLastChangeUser(String) - Method in class bb.common.WorkOrderItemPartDetailInWipVO

setLastChangeUser(String) - Method in class bb.common.WorkOrderItemTimeDetailVO

setLastChangeUser(String) - Method in class bb.common.WorkOrderReceiverVO

setLastChangeUser(String) - Method in class bb.common.WorkOrderVO

setLastChangeUser(String) - Method in class bb.common.WorkOrderWorkInstructionVO

setLastChangeUser(String) - Method in class bb.common.WorkOrderWorkSheetItemVO

setLastCount(Date) - Method in class bb.common.PartInventoryVO

setLastCycleCount(Date) - Method in class bb.common.PartClassVO

setLastDate(Date) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

setLastDate(Date) - Method in class bb.common.WoItemPickListItemResult

setLastDate(Date) - Method in class bb.common.WorkOrderItemIssueVO

setLastDate(Date) - Method in class bb.common.WorkOrderItemPartDetail

setLastFiscalYearInvoiceAccount(BigDecimal) - Method in class bb.common.SalesInfoCenterResult

setLastFiscalYearSalesAccount(BigDecimal) - Method in class bb.common.SalesInfoCenterResult

setLastInDate(Date) - Method in class bb.common.HistoricalInventoryVO

setLastInDate(Date) - Method in class bb.common.InventoryListResult

setLastInDate(Date) - Method in class bb.common.InventoryNotUsedInMonthsResult

setLastInDate(Date) - Method in class bb.common.PartInventoryVO

setLastInspection(Date) - Method in class bb.common.ToolCalibrationVO

setLastInventory(Date) - Method in class bb.common.CompanyVO

setLastInvoiceNumber(String) - Method in class bb.common.SalesOrderItemListResult

setLastLogin(Date) - Method in class bb.common.BizboxUserListResult

setLastLogin(Date) - Method in class bb.common.BizboxUserVO

setLastLogout(Date) - Method in class bb.common.BizboxUserListResult

setLastLogout(Date) - Method in class bb.common.BizboxUserVO

setLastMaintenanceDate(Date) - Method in class bb.common.EquipmentListResult

setLastMaintenanceDate(Date) - Method in class bb.common.EquipmentVO

setLastMonth(int) - Method in class bb.common.SalesInfoCenter.DueSoCount

setLastMonth(double) - Method in class bb.common.SalesInfoCenter.DueSoSum

setLastMonth(float) - Method in class bb.common.SalesInfoCenter.GrossMargin

setLastMonth(double) - Method in class bb.common.SalesInfoCenter.InvoicedSum

setLastMonth(double) - Method in class bb.common.SalesInfoCenter.OpenSoSum

setLastMonth(int) - Method in class bb.common.SalesInfoCenter.SoCount

setLastMonth(int) - Method in class bb.common.SalesInfoCenter.SoCountWithPartsOnhold

setLastMonth(int) - Method in class bb.common.SalesInfoCenter.SoItemCount

setLastMonth(double) - Method in class bb.common.SalesInfoCenter.SoTotalSum

setLastMonthInvoiceAccount(BigDecimal) - Method in class bb.common.SalesInfoCenterResult

setLastMonthInvoiceGrossMargin(BigDecimal) - Method in class bb.common.SalesInfoCenterResult

setLastMonthPoAddedCount(Integer) - Method in class bb.common.PurchasingInfoCenterResult

setLastMonthPoiAddedCount(Integer) - Method in class bb.common.PurchasingInfoCenterResult

setLastMonthPurchaseAccount(BigDecimal) - Method in class bb.common.PurchasingInfoCenterResult

setLastMonthReceiverAccount(BigDecimal) - Method in class bb.common.PurchasingInfoCenterResult

setLastMonthReceiverCount(Integer) - Method in class bb.common.PurchasingInfoCenterResult

setLastMonthReceiverItemCount(Integer) - Method in class bb.common.PurchasingInfoCenterResult

setLastMonthRejectQty(BigDecimal) - Method in class bb.common.QualityInfoCenterResult

setLastMonthSalesItemCount(Integer) - Method in class bb.common.SalesInfoCenterResult

setLastMonthSalesOrderAccount(BigDecimal) - Method in class bb.common.SalesInfoCenterResult

setLastMonthSalesOrderCount(Integer) - Method in class bb.common.SalesInfoCenterResult

setLastName(String) - Method in class bb.common.BizBoxUserEmployeeResult

setLastName(String) - Method in class bb.common.CashierVO

setLastName(String) - Method in class bb.common.EmployeeCardVO

setLastName(String) - Method in class bb.common.EmployeeEducationResult

setLastName(String) - Method in class bb.common.GroupUserVO

setLastName(String) - Method in class bb.common.NoticeUserEmployeeListResult

setLastName(String) - Method in class bb.common.SalesmanVO

setLastOutDate(Date) - Method in class bb.common.HistoricalInventoryVO

setLastOutDate(Date) - Method in class bb.common.InventoryListResult

setLastOutDate(Date) - Method in class bb.common.InventoryNotUsedInMonthsResult

setLastOutDate(Date) - Method in class bb.common.PartInventoryVO

setLastOutDate(Date) - Method in class bb.common.PartOnhandCostVO

setLastOutDate(Date) - Method in class bb.common.PartOnhandResult

setLastPurchaseCost(BigDecimal) - Method in class bb.common.PartInventoryVO

setLastPurchaseCost(BigDecimal) - Method in class bb.common.PartVendorVO

setLastPurchaseCost(BigDecimal) - Method in class bb.common.ToolInventoryVO

setLastPurchaseCost(BigDecimal) - Method in class bb.common.ToolVendorVO

setLastPurchaseOrderItemNumber(String) - Method in class bb.common.PartInventoryVO

setLastPurchaseOrderItemNumber(String) - Method in class bb.common.PartVendorVO

setLastPurchaseOrderItemNumber(String) - Method in class bb.common.ToolInventoryVO

setLastPurchaseOrderItemNumber(String) - Method in class bb.common.ToolVendorVO

setLastPurchaseOrderNumber(String) - Method in class bb.common.PartInventoryVO

setLastPurchaseOrderNumber(String) - Method in class bb.common.PartVendorVO

setLastPurchaseOrderNumber(String) - Method in class bb.common.ToolInventoryVO

setLastPurchaseOrderNumber(String) - Method in class bb.common.ToolVendorVO

setLastPurchaseOrderNumberAndItemNumber(String) - Method in class bb.common.PartCostVarianceListResult

setLastPurchaseOrderVendorID(String) - Method in class bb.common.PartCostVarianceListResult

setLastPurchaseOrderVendorName(String) - Method in class bb.common.PartCostVarianceListResult

setLastPurchasePrice(BigDecimal) - Method in class bb.common.PartCostVarianceListResult

setLastReceiveDate(Date) - Method in class bb.common.PurchaseOrderItemListResult

setLastShippedDate(Date) - Method in class bb.common.SalesOrderItemListResult

setLastSOPrice(String) - Method in class bb.common.RunningAccountOrderItemVO

setLastSyncDate(Date) - Method in class bb.common.SubcompanyVO

setLastTwevMonthsTotalSalesGrossMargin(BigDecimal) - Method in class bb.common.SalesInfoCenterResult

setLastUsedDate(Date) - Method in class bb.common.InventoryNotUsedInMonthsResult

setLastUser(String) - Method in class bb.common.AccountingInfoDocumentVO

setLastUser(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setLastUser(String) - Method in class bb.common.CustomerVendorAddressVO

setLastUser(String) - Method in class bb.common.EngineeringChangeRequestVO

setLastUser(String) - Method in class bb.common.EngineeringChangeVO

setLastUser(String) - Method in class bb.common.NonproductivePickingVO

setLastUser(String) - Method in class bb.common.PartBasicInfo

setLastUser(String) - Method in class bb.common.PartVO

setLastUser(String) - Method in class bb.common.PartWithOnhandsVO

setLastUser(String) - Method in class bb.common.QuoteDocumentVO

setLastUser(String) - Method in class bb.common.QuoteVO

setLastUser(String) - Method in class bb.common.ReturnMaterialAuthorizationDocumentVO

setLastUser(String) - Method in class bb.common.SalesOrderVO

setLastUser(String) - Method in class bb.common.ShipListInfoVO

setLastUser(String) - Method in class bb.common.ShipListVO

setLastUser(String) - Method in class bb.common.ToolVO

setLastUser(String) - Method in class bb.common.ToolWithOnhandsVO

setLastUser(String) - Method in class bb.common.TransferOrderListResult

setLastUser(String) - Method in class bb.common.TransferOrderVO

setLastUser(String) - Method in class bb.common.TransferReceiverListResult

setLastUser(String) - Method in class bb.common.TransferReceiverVO

setLastUser(String) - Method in class bb.common.TransferShipperListResult

setLastUser(String) - Method in class bb.common.TransferShipperVO

setLastUserName(String) - Method in class bb.common.SGCompanyVO

setLastUserName(String) - Method in class bb.common.SGCustRequestForQuoteVO

setLastUserName(String) - Method in class bb.common.SGDocPartVO

setLastUserName(String) - Method in class bb.common.SGDwgPictureVO

setLastUserName(String) - Method in class bb.common.SGPictureVO

setLastYeardepreciatedAccm(BigDecimal) - Method in class bb.common.AssetDepreciateVO

setLastYearDepreciationAccm(BigDecimal) - Method in class bb.common.AssetDepreciateDetailReport

setLateItemPk(OrderPK) - Method in class bb.common.MrpItemResult

setLatestReceiverDate(Date) - Method in class bb.common.POStatisticsResult

setLatestShipDate(Date) - Method in class bb.common.POStatisticsResult

setLbs(double) - Method in class bb.common.SGWeightUnitVO

setLbs(double) - Method in class bb.common.WeightUnitVO

setLdate(Date) - Method in class bb.common.WorkInstructionPictureVO

setLeadtime(BigDecimal) - Method in class bb.common.BB2PartInfo

setLeadTime(boolean) - Method in class bb.common.MrpReportAgent

setLeadTime(BigDecimal) - Method in class bb.common.PartBasicInfo

setLeadTime(BigDecimal) - Method in class bb.common.PartInventoryVO

setLeadTime(BigDecimal) - Method in class bb.common.PurchaseOrderItemVO

setLeadTime(int) - Method in class bb.common.RequestForQuoteItemVO

setLeadTime(int) - Method in class bb.common.RfqMessageItemVO

setLeadTime(BigDecimal) - Method in class bb.common.ToolInventoryVO

setLeadTime(BigDecimal) - Method in class bb.common.WorkOrderItemVO

setLeadTimeFrom(BigDecimal) - Method in class bb.common.MrpReportAgent

setLeadTimeTo(BigDecimal) - Method in class bb.common.MrpReportAgent

setLendTime(BigDecimal) - Method in class bb.common.StockTransactionPartInfoResult

setLength(Integer) - Method in class bb.common.BizboxBugChangesInfoVO

setLength(Integer) - Method in class bb.common.BizboxBugInfoVO

setLength(BigDecimal) - Method in class bb.common.PartMaterialListResult

setLength(BigDecimal) - Method in class bb.common.PartMaterialReportAgent

setLength(BigDecimal) - Method in class bb.common.PartMaterialVO

setLength(BigDecimal) - Method in class bb.common.PartMaterialWhereUsedItemResult

setLength(Integer) - Method in class bb.common.PrintLogoVO

setLength(Long) - Method in class bb.common.SerialNumberItemResult

setLength(Long) - Method in class bb.common.SerialNumberResult

setLength(Integer) - Method in class bb.common.TermsConditionVO

setLengthOperator(String) - Method in class bb.common.PartMaterialReportAgent

setLengthUnit(String) - Method in class bb.common.PartMaterialListResult

setLengthUnit(String) - Method in class bb.common.PartMaterialReportAgent

setLengthUnit(String) - Method in class bb.common.PartMaterialVO

setLengthUnit(String) - Method in class bb.common.PartMaterialWhereUsedItemResult

setLessDepreciation(List) - Method in class bb.common.ClosingStatementResult

setLevel(String) - Method in class bb.common.AccountBalanceResult

setLevel(String) - Method in class bb.common.AccountsChartVO

setLevel(String) - Method in class bb.common.BalanceSheetSideBySideItemResult

setLevel(String) - Method in class bb.common.BudgetListResult

setLevel(String) - Method in class bb.common.ClosingStatementItemResult

setLevel(String) - Method in class bb.common.CompanyUnitVO

setLevel(String) - Method in class bb.common.ExchangeAuditItemResult

setLevel(int) - Method in class bb.common.MrpReportAgent

setLevel(Integer) - Method in class bb.common.PermissionVO

setLevel(String) - Method in class bb.common.ProfitLossStatementItemResult

setLevel(Integer) - Method in class bb.common.RollUpBomStdCostWorkSheetItemVO

setLevel(String) - Method in class bb.common.SalesmanVO

setLevel(String) - Method in class bb.common.SGClientAccountVO

setLevel(String) - Method in class bb.common.SGLogLoginVO

setLevel(String) - Method in class bb.common.SGQuoteAddressVO

setLevel(String) - Method in class bb.common.SGQuoteLoginVO

setLevelDescription(String) - Method in class bb.common.PartSecurityLevelVO

setLevelId(String) - Method in class bb.common.PartSecurityLevelVO

setLevels(String) - Method in class bb.common.PartVO

setLevels(String) - Method in class bb.common.PartWithOnhandsVO

setLicense(byte[]) - Method in class bb.common.CompanyVO

setLine(int) - Method in class bb.common.OnhandQualityResult

setLinkOrRef(short) - Method in class bb.common.PosRefdocVO

setLinkOrRef(short) - Method in class bb.common.RefdocVO

setList(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemVO

setList(List) - Method in class bb.common.ExchangeAuditResult

setList(BigDecimal) - Method in class bb.common.WorkOrderItemVO

setList12MonthAvg(boolean) - Method in class bb.common.OnTimeAgent

setListAllDemand(boolean) - Method in class bb.common.MrpReportAgent

setListAllPart(boolean) - Method in class bb.common.MrpReportAgent

setListBOM(boolean) - Method in class bb.common.BOMCanAssyAgent

setListCost(BigDecimal) - Method in class bb.common.BillDetailCostResult

setListCost(BigDecimal) - Method in class bb.common.ToolListDetailCostResult

setListFiscalYear(boolean) - Method in class bb.common.OnTimeAgent

setListInAddressBook(String) - Method in class bb.common.EmployeeCardVO

setListOtherLocationsForSamePart(boolean) - Method in class bb.common.PartOnhandResult

setListPastDue(boolean) - Method in class bb.common.MrpReportAgent

setListPrice(BigDecimal) - Method in class bb.common.AccountsReceivableItemVO

setListPrice(BigDecimal) - Method in class bb.common.BillDetailCostWithPartInfoResult

setListPrice(BigDecimal) - Method in class bb.common.BillItemDetailCostWithPartInfoResult

setListPrice(BigDecimal) - Method in class bb.common.BillItemSalesCostResult

setListPrice(BigDecimal) - Method in class bb.common.BillItemSalesXResult

setListPrice(BigDecimal) - Method in class bb.common.BillItemUsageResult

setListPrice(BigDecimal) - Method in class bb.common.BillItemWithPartInfoResult

setListPrice(BigDecimal) - Method in class bb.common.BillSalesCostResult

setListPrice(BigDecimal) - Method in class bb.common.BillSalesXResult

setListPrice(BigDecimal) - Method in class bb.common.BomItemWithOEMResult

setListPrice(BigDecimal) - Method in class bb.common.BomWithOEMResult

setListPrice(BigDecimal) - Method in class bb.common.ContractPriceItemVO

setListPrice(BigDecimal) - Method in class bb.common.HistoricalInventoryVO

setListPrice(BigDecimal) - Method in class bb.common.InventoryListResult

setListPrice(BigDecimal) - Method in class bb.common.LnShipperItemListResult

setListPrice(BigDecimal) - Method in class bb.common.OnloanShipperItemVO

setListPrice(BigDecimal) - Method in class bb.common.PartBasicInfoWithNewListPrice

setListPrice(BigDecimal) - Method in class bb.common.PartInventoryVO

setListPrice(BigDecimal) - Method in class bb.common.PartOnHandWithPartBasicInfoResult

setListPrice(BigDecimal) - Method in class bb.common.PartUnitVO

setListPrice(BigDecimal) - Method in class bb.common.PartWithQAQtyListResult

setListPrice(BigDecimal) - Method in class bb.common.PartWithQtyListResult

setListPrice(BigDecimal) - Method in class bb.common.PartWithSipQtyListResult

setListPrice(BigDecimal) - Method in class bb.common.PartWithSITQtyListResult

setListPrice(BigDecimal) - Method in class bb.common.PartWithSTOQtyListResult

setListPrice(BigDecimal) - Method in class bb.common.PartWithWipQtyListResult

setListPrice(BigDecimal) - Method in class bb.common.PfReceiverItemVO

setListPrice(BigDecimal) - Method in class bb.common.ProformaInvoiceItemListResult

setListPrice(BigDecimal) - Method in class bb.common.ProformaInvoiceItemVO

setListPrice(BigDecimal) - Method in class bb.common.RtvShipperItemVO

setListPrice(BigDecimal) - Method in class bb.common.SalesOrderItemCostResult

setListPrice(BigDecimal) - Method in class bb.common.ShipperItemListResult

setListPrice(BigDecimal) - Method in class bb.common.ShipperItemVO

setListPrice(BigDecimal) - Method in class bb.common.ToolInventoryVO

setListPrice(BigDecimal) - Method in class bb.common.ToolListDetailCostWithToolInfoResult

setListPrice(BigDecimal) - Method in class bb.common.ToolListItemDetailCostWithToolInfoResult

setListPrice(BigDecimal) - Method in class bb.common.VendorContractPriceItemVO

setListSO(boolean) - Method in class bb.common.BOMCanAssyAgent

setListUsage(String) - Method in class bb.common.MrpReportAgent

setListWO(boolean) - Method in class bb.common.BOMCanAssyAgent

setListYearToDate(boolean) - Method in class bb.common.OnTimeAgent

setListZeroNeedBefore(boolean) - Method in class bb.common.MrpReportAgent

setLnNumber(String) - Method in class bb.common.OnloanReceiverItemListResult

setLnReceiverDigits(byte) - Method in class bb.common.CompanyVO

setLnReceiverPrefix(String) - Method in class bb.common.CompanyVO

setLnShipperDigits(byte) - Method in class bb.common.CompanyVO

setLnShipperItemNumber(String) - Method in class bb.common.LnShipperItemListResult

setLnShipperItemNumber(String) - Method in class bb.common.OnloanShipperItemPK

setLnShipperNumber(String) - Method in class bb.common.LnShipperItemListResult

setLnShipperNumber(String) - Method in class bb.common.LnShipperListResult

setLnShipperNumber(String) - Method in class bb.common.OnloanReceiverItemListResult

setLnShipperNumber(String) - Method in class bb.common.OnloanReceiverItemVO

setLnShipperNumber(String) - Method in class bb.common.OnloanReceiverListResult

setLnShipperNumber(String) - Method in class bb.common.OnloanReceiverVO

setLnShipperNumber(String) - Method in class bb.common.OnloanShipperItemPK

setLnShipperNumber(String) - Method in class bb.common.OnloanShipperVO

setLnShipperPrefix(String) - Method in class bb.common.CompanyVO

setLoadDetailList(List<WCLoadDetailResult>) - Method in class bb.common.WorkCenterLoadListResult

setLoadHrs(BigDecimal) - Method in class bb.common.WorkCenterLoadListResult

setLoanComments(String) - Method in class bb.common.OnLoanVO

setLoanDate(Date) - Method in class bb.common.OnLoanItemListResult

setLoanDate(Date) - Method in class bb.common.OnLoanListResult

setLoanDate(Date) - Method in class bb.common.OnLoanVO

setLoanItemNumber(String) - Method in class bb.common.OnLoanItemListResult

setLoanItemNumber(String) - Method in class bb.common.OnLoanItemPK

setLoanNotes(String) - Method in class bb.common.OnLoanVO

setLoanNumber(String) - Method in class bb.common.LnShipperItemListResult

setLoanNumber(String) - Method in class bb.common.LnShipperListResult

setLoanNumber(String) - Method in class bb.common.OnLoanItemListResult

setLoanNumber(String) - Method in class bb.common.OnLoanItemPK

setLoanNumber(String) - Method in class bb.common.OnLoanListResult

setLoanNumber(String) - Method in class bb.common.OnloanShipperItemVO

setLoanNumber(String) - Method in class bb.common.OnloanShipperVO

setLoanNumber(String) - Method in class bb.common.OnLoanVO

setLoanQty(BigDecimal) - Method in class bb.common.OnLoanItemListResult

setLoanQuantity(BigDecimal) - Method in class bb.common.OnLoanItemVO

setLoanQuantity(BigDecimal) - Method in class bb.common.OnloanShipperItemVO

setLocalCurrency(String) - Method in class bb.common.PartOnhandCostVO

setLocalDescription(String) - Method in class bb.common.NonConformanceCodeVO

setLocalPath(String) - Method in class bb.common.DocumentServerVO

setLocalPath(String) - Method in class bb.common.DwfUploadSettingsVO

setLocalPath(String) - Method in class bb.common.DwgUploadSettingsVO

setLocalPath(String) - Method in class bb.common.MiscDocumentSettingVO

setLocalSettings(String) - Method in class bb.common.AccountingConfigurationVO

setLocate(String) - Method in class bb.common.AccountsReceivableItemVO

setLocate(String) - Method in class bb.common.CustomerReturnToVendorItemVO

setLocate(String) - Method in class bb.common.CustomerReturnToVendorVO

setLocate(String) - Method in class bb.common.CycleCountVO

setLocate(String) - Method in class bb.common.InventoryNotUsedInMonthsResult

setLocate(String) - Method in class bb.common.IssueItemDetailAgent

setLocate(String) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setLocate(String) - Method in class bb.common.OnLoanVO

setLocate(String) - Method in class bb.common.PartIssuedVO

setLocate(String) - Method in class bb.common.PartReceivedVO

setLocate(String) - Method in class bb.common.PhysicalInventoryVO

setLocate(String) - Method in class bb.common.ProformaInvoiceItemVO

setLocate(String) - Method in class bb.common.PurchaseOrderItemVO

setLocate(String) - Method in class bb.common.PurchaseOrderVO

setLocate(String) - Method in class bb.common.PuttoInQAAgent

setLocate(String) - Method in class bb.common.QuoteItemVO

setLocate(String) - Method in class bb.common.QuoteVO

setLocate(String) - Method in class bb.common.RebackInQAAgent

setLocate(String) - Method in class bb.common.RequestForRMAItemVO

setLocate(String) - Method in class bb.common.RequestForRMAVO

setLocate(String) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setLocate(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setLocate(String) - Method in class bb.common.ReturnToVendorItemVO

setLocate(String) - Method in class bb.common.ReturnToVendorVO

setLocate(String) - Method in class bb.common.RMAReceiverItemVO

setLocate(String) - Method in class bb.common.RtvShipperItemVO

setLocate(String) - Method in class bb.common.SalesOrderItemInfoVO

setLocate(String) - Method in class bb.common.SalesOrderItemVO

setLocate(String) - Method in class bb.common.SalesOrderVO

setLocate(String) - Method in class bb.common.ShipperItemDetailAgent

setLocate(String) - Method in class bb.common.TransferOrderListResult

setLocate(String) - Method in class bb.common.TransferOrderVO

setLocate(String) - Method in class bb.common.TransferReceiverListResult

setLocate(String) - Method in class bb.common.TransferReceiverVO

setLocates(Map<String, PartOnhandAndCostResult>) - Method in class bb.common.PartOnhandResult

setLocation(String) - Method in class bb.common.AccountsPayableItemVO

setLocation(String) - Method in class bb.common.AddPhysicalInventoryAgent

setLocation(String) - Method in class bb.common.AssetAddOrDisposalsReport

setLocation(String) - Method in class bb.common.AssetDepreciateVO

setLocation(String) - Method in class bb.common.AssetVO

setLocation(String) - Method in class bb.common.BomPickListItemResult

setLocation(String) - Method in class bb.common.CSRAgent

setLocation(String) - Method in class bb.common.CustomerServiceIncidentVO

setLocation(String) - Method in class bb.common.CycleCountAgent

setLocation(String) - Method in class bb.common.CycleCountListResult

setLocation(String) - Method in class bb.common.DepartmentLocationForBackflushVO

setLocation(String) - Method in class bb.common.DisassembleWorkOrderItemVO

setLocation(String) - Method in class bb.common.DisassembleWorkOrderVO

setLocation(LinkedHashMap) - Method in class bb.common.DWOIssueDetail

setLocation(String) - Method in class bb.common.EmployeeWorkExperienceVO

setLocation(String) - Method in class bb.common.InventoryCycleItemResult

setLocation(String) - Method in class bb.common.InventoryListResult

setLocation(String) - Method in class bb.common.InventoryMonthReport

setLocation(String) - Method in class bb.common.LocationResult

setLocation(String) - Method in class bb.common.LogInventoryListResult

setLocation(String) - Method in class bb.common.LogInventoryVO

setLocation(String) - Method in class bb.common.LogTrackingVO

setLocation(String) - Method in class bb.common.OnLoanItemVO

setLocation(String) - Method in class bb.common.OnloanReceiverItemVO

setLocation(String) - Method in class bb.common.OnloanShipperItemVO

setLocation(String) - Method in class bb.common.PartOnhandCostVO

setLocation(String) - Method in class bb.common.PartOnhandPK

setLocation(String) - Method in class bb.common.PhysicalInventoryListResult

setLocation(String) - Method in class bb.common.POReceiverItemListResult

setLocation(String) - Method in class bb.common.ReceiverItemDetailAgent

setLocation(String) - Method in class bb.common.ReceiverItemVO

setLocation(String) - Method in class bb.common.RequestForQuoteItemVO

setLocation(String) - Method in class bb.common.RequestForQuoteVO

setLocation(String) - Method in class bb.common.SGCustomerServiceRequestVO

setLocation(String) - Method in class bb.common.ShipperItemListResult

setLocation(String) - Method in class bb.common.ShipperItemVO

setLocation(String) - Method in class bb.common.SwapReceiverItemVO

setLocation(String) - Method in class bb.common.SwapShipperItemVO

setLocation(String) - Method in class bb.common.ToolCalibrationVO

setLocation(String) - Method in class bb.common.TransferReceiverItemVO

setLocation(String) - Method in class bb.common.TransferShipperItemVO

setLocation(String) - Method in class bb.common.UpdatePhysicalInventoryAgent

setLocation(String) - Method in class bb.common.WoItemPickListItemResult

setLocation(String) - Method in class bb.common.WOReceiverDetail

setLocation(String) - Method in class bb.common.WorkOrderItemVO

setLocation(String) - Method in class bb.common.WorkOrderReceiverVO

setLocation(String) - Method in class bb.common.WorkOrderVO

setLocationCount(Integer) - Method in class bb.common.LocationResult

setLocationForReturnMaterial(String) - Method in class bb.common.PointOfSaleVO

setLocationOnhand(BigDecimal) - Method in class bb.common.BillOnHandWithPartInfoResult

setLocationPrefix(String) - Method in class bb.common.WoItemPickListResult

setLocations(Map) - Method in class bb.common.DisassembleWorkOrderIssueVO

setLocations(Map) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

setLocations(Map) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setLocations(Map) - Method in class bb.common.NonproductivePickingItemIssuedVO

setLocations(Map<String, BigDecimal>) - Method in class bb.common.NonproductivePickingOnDemandResult

setLocations(Map) - Method in class bb.common.OnloanReceiverItemVO

setLocations(Map) - Method in class bb.common.OnloanShipperItemVO

setLocations(Map) - Method in class bb.common.PackingBoxItemVO

setLocations(Map) - Method in class bb.common.POReceiverItemListResult

setLocations(Map) - Method in class bb.common.ReceiverItemVO

setLocations(Map<String, String>) - Method in class bb.common.ReceiverShipAgent

setLocations(Map) - Method in class bb.common.RMAReceiverItemVO

setLocations(Map<String, BigDecimal>) - Method in class bb.common.RMAReceiverResult

setLocations(Map) - Method in class bb.common.RtvShipperItemVO

setLocations(Map) - Method in class bb.common.SalesOrderOnDemandResult

setLocations(Map) - Method in class bb.common.ShipperItemListResult

setLocations(Map) - Method in class bb.common.ShipperItemVO

setLocations(Map) - Method in class bb.common.SwapReceiverItemVO

setLocations(Map) - Method in class bb.common.SwapShipperItemVO

setLocations(Map) - Method in class bb.common.TransferReceiverItemVO

setLocations(Map) - Method in class bb.common.TransferShipperItemVO

setLocations(Map) - Method in class bb.common.WorkOrderOnDemandResult

setLock(String) - Method in class bb.common.DocumentServerVO

setLocked(boolean) - Method in class bb.common.BizBoxUserEmployeeResult

setLocked(boolean) - Method in class bb.common.BizboxUserListResult

setLocked(boolean) - Method in class bb.common.BizboxUserVO

setLocked(boolean) - Method in class bb.common.MiscDocumentSettingVO

setLocked(boolean) - Method in class bb.common.PartClassVO

setLockedTransactionDate(Date) - Method in class bb.common.GeneralLedgerSettingsVO

setLoction(String, String) - Method in class bb.common.ReceiverShipAgent

setLog(String) - Method in class bb.common.RollUpBomStdCostWorkSheetVO

setLoginName(String) - Method in class bb.common.SGClientLogin

setLoginType(String) - Method in class bb.common.BB2Login

setLogo(byte[]) - Method in class bb.common.CompanyVO

setLogo(byte[]) - Method in class bb.common.PointOfSaleVO

setLogo(byte[]) - Method in class bb.common.PrintLogoVO

setLogo(String) - Method in class bb.common.SGCompanyVO

setLogoName(String) - Method in class bb.common.PrintLogoVO

setLongDescription(Blob) - Method in class bb.common.EmployeeJobDescriptionVO

setLongTermAssets(BigDecimal) - Method in class bb.common.AccountingBalanceSheetResult

setLongTermLiabilities(List) - Method in class bb.common.ClosingStatementResult

setLot(String) - Method in class bb.common.DisassembleWorkOrderIssueVO

setLot(String) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

setLot(String) - Method in class bb.common.IssueItemAgent

setLot(String) - Method in class bb.common.IssuingItemResult

setLot(String) - Method in class bb.common.PartIssuedVO

setLot(String) - Method in class bb.common.PartOnhandCostVO

setLot(String) - Method in class bb.common.PartReceivedVO

setLot(String) - Method in class bb.common.ReceiverItemAgent

setLot(String) - Method in class bb.common.WorkOrderItemIssueVO

setLot(String) - Method in class bb.common.WorkOrderItemTimeDetailVO

setLot(String) - Method in class bb.common.WorkOrderReceiverVO

setLowestCost(BigDecimal) - Method in class bb.common.SalesOrderItemCostResult

setMacAdd(String) - Method in class bb.common.DocumentInfoAgent

setMacAdd(String) - Method in class bb.common.MiscDocAgent

setMacAdd(String) - Method in class bb.common.PartDwfAgent

setMacAdd(String) - Method in class bb.common.PartDwgAgent

setMacAddress(String) - Method in class bb.common.BizboxUserVO

setMacAddress(String) - Method in class bb.common.LogMiscDocumentVO

setMacAddress(String) - Method in class bb.common.LogPartDocumentVO

setMacAddress(String) - Method in class bb.common.LogPartDwfVO

setMacAddress(String) - Method in class bb.common.LogPartDwgVO

setMacAddress(String) - Method in class bb.common.OperationLogVO

setMachineCost(boolean) - Method in class bb.common.AccountingSettingsVO

setMachineCost(BigDecimal) - Method in class bb.common.WorkOrderItemLaborCostListResult

setMachineHoursPerDay(BigDecimal) - Method in class bb.common.WorkCenterVO

setMachinePay(BigDecimal) - Method in class bb.common.WorkCenterVO

setMachinePerformance(BigDecimal) - Method in class bb.common.WorkCenterVO

setMachineQty(BigDecimal) - Method in class bb.common.WorkCenterVO

setMadeBy(String) - Method in class bb.common.AccountPayableCheckRunVO

setMadeBy(String) - Method in class bb.common.ARPaymentRunVO

setMadeGL(boolean) - Method in class bb.common.PhysicalInventoryVO

setMainPicture(boolean) - Method in class bb.common.BB2Picture

setMainPicture(boolean) - Method in class bb.common.MiscDocAgent

setMainPicture(boolean) - Method in class bb.common.PartPictureVO

setMaintemanceBy(String) - Method in class bb.common.MaintenanceItemVO

setMaintemanceNotes(String) - Method in class bb.common.MaintenanceItemVO

setMaintenanceBy(String) - Method in class bb.common.EquipmentListResult

setMaintenanceBy(String) - Method in class bb.common.EquipmentVO

setMaintenanceDate(Date) - Method in class bb.common.MaintenanceItemVO

setMaintenanceItems(Set) - Method in class bb.common.EquipmentVO

setMaintencePeriod(Integer) - Method in class bb.common.EquipmentVO

setMajor(String) - Method in class bb.common.EmployeeEducationVO

setMakeBuy(String) - Method in class bb.common.BillItemSalesXResult

setMakeBuy(String) - Method in class bb.common.BillWhereUsedResult

setMakeBuy(String) - Method in class bb.common.ChangeStdCostWorkSheetItemVO

setMakeBuy(String) - Method in class bb.common.MrpReportAgent

setMakeBuy(String) - Method in class bb.common.PartBasicInfo

setMakeBuy(String) - Method in class bb.common.PartCostVarianceListResult

setMakeBuy(String) - Method in class bb.common.PartMRPVO

setMakeBuy(String) - Method in class bb.common.PartVO

setMakeBuy(String) - Method in class bb.common.PartWithOnhandsVO

setMakeBuy(String) - Method in class bb.common.ToolVO

setMakeBuy(String) - Method in class bb.common.ToolWithOnhandsVO

setMakeBuyForNewPart(String) - Method in class bb.common.CompanyVO

setMakeDate(Date) - Method in class bb.common.MakeCheckAgent

setMakeDate(Date) - Method in class bb.common.MakePrepaymentCheckAgent

setMakeDate(Date) - Method in class bb.common.PostCheckAgent

setMakeGLWhenReceivingWO(boolean) - Method in class bb.common.CompanyVO

setMakePo(String) - Method in class bb.common.PurchaseWorkSheetItemVO

setMakeRfq(String) - Method in class bb.common.PurchaseWorkSheetItemVO

setMakeRfq(String) - Method in class bb.common.WorkOrderWorkSheetItemVO

setMakeWo(String) - Method in class bb.common.WorkOrderWorkSheetItemVO

setManager(String) - Method in class bb.common.EmployeeCardVO

setManager(String) - Method in class bb.common.ExpenseVO

setManual(String) - Method in class bb.common.SGDocPartVO

setManual(boolean) - Method in class bb.common.SGPartDocFlagResult

setManualRev(String) - Method in class bb.common.SGDocPartVO

setManufacture(String) - Method in class bb.common.CustomAssetVO

setManufactureId(String) - Method in class bb.common.CustomAssetVO

setManufacturerId(String) - Method in class bb.common.EquipmentListResult

setManufacturerId(String) - Method in class bb.common.EquipmentVO

setManufacturerId(String) - Method in class bb.common.PartManufacturerVO

setManufacturerId(String) - Method in class bb.common.PartOnHandWithMfgInfoResult

setManufacturerId(String) - Method in class bb.common.PartWithManufacturerInfoResult

setManufacturerId(String) - Method in class bb.common.ToolManufacturerVO

setManufacturerItem(Short) - Method in class bb.common.PartManufacturerPK

setManufacturerItem(Short) - Method in class bb.common.PartWithManufacturerInfoResult

setManufacturerName(String) - Method in class bb.common.AccountsPayableItemManufacturerVO

setManufacturerName(String) - Method in class bb.common.AccountsReceivableItemManufacturerVO

setManufacturerName(String) - Method in class bb.common.PartManufacturerVO

setManufacturerName(String) - Method in class bb.common.PartOnHandWithMfgInfoResult

setManufacturerName(String) - Method in class bb.common.PartWithManufacturerInfoResult

setManufacturerName(String) - Method in class bb.common.PO2SOExchangeItemManufacturer

setManufacturerName(String) - Method in class bb.common.ProformaInvoiceItemManufacturerVO

setManufacturerName(String) - Method in class bb.common.PurchaseOrderItemManufacturerVO

setManufacturerName(String) - Method in class bb.common.QuoteItemManufacturerVO

setManufacturerName(String) - Method in class bb.common.ReceiverItemManufacturerVO

setManufacturerName(String) - Method in class bb.common.RequestForQuoteItemManufacturerVO

setManufacturerName(String) - Method in class bb.common.ReturnMaterialAuthorizationItemManufacturerVO

setManufacturerName(String) - Method in class bb.common.ReturnToVendorItemManufacturerVO

setManufacturerName(String) - Method in class bb.common.SalesOrderItemManufacturerVO

setManufacturerName(String) - Method in class bb.common.ShipperItemManufacturerVO

setManufacturerName(String) - Method in class bb.common.ToolCalibrationVO

setManufacturerName(String) - Method in class bb.common.ToolManufacturerVO

setManufacturerPartNumber(String) - Method in class bb.common.AccountsPayableItemManufacturerVO

setManufacturerPartNumber(String) - Method in class bb.common.AccountsReceivableItemManufacturerVO

setManufacturerPartNumber(String) - Method in class bb.common.PartManufacturerVO

setManufacturerPartNumber(String) - Method in class bb.common.PartOnHandWithMfgInfoResult

setManufacturerPartNumber(String) - Method in class bb.common.PartWithManufacturerInfoResult

setManufacturerPartNumber(String) - Method in class bb.common.ProformaInvoiceItemManufacturerVO

setManufacturerPartNumber(String) - Method in class bb.common.PurchaseOrderItemManufacturerVO

setManufacturerPartNumber(String) - Method in class bb.common.QuoteItemManufacturerVO

setManufacturerPartNumber(String) - Method in class bb.common.ReceiverItemManufacturerVO

setManufacturerPartNumber(String) - Method in class bb.common.RequestForQuoteItemManufacturerVO

setManufacturerPartNumber(String) - Method in class bb.common.ReturnMaterialAuthorizationItemManufacturerVO

setManufacturerPartNumber(String) - Method in class bb.common.ReturnToVendorItemManufacturerVO

setManufacturerPartNumber(String) - Method in class bb.common.SalesOrderItemManufacturerVO

setManufacturerPartNumber(String) - Method in class bb.common.ShipperItemManufacturerVO

setManufacturerPartNumber(String) - Method in class bb.common.ToolManufacturerVO

setManufacturerPartRev(String) - Method in class bb.common.PartManufacturerVO

setManufacturerPartRev(String) - Method in class bb.common.ToolManufacturerVO

setManufacturerPN(String) - Method in class bb.common.PO2SOExchangeItemManufacturer

setManufacturers(Set) - Method in class bb.common.PartVO

setManufacturers(Set) - Method in class bb.common.ToolVO

setMap(Map<AssetDepreciatePK, AccountCreditVO>) - Method in class bb.common.ExchangeAuditResult

setMap(HashMap<String, BigDecimal>) - Method in class bb.common.OnhandQualityResult

setMap(HashMap) - Method in class bb.common.PurchaseOrderContractResult

setMap(HashMap) - Method in class bb.common.WorkOrderIssueStatisticsResult

setMargin(BigDecimal) - Method in class bb.common.AccountsReceivableInfoVO

setMargin(BigDecimal) - Method in class bb.common.AccountsReceivableItemVO

setMargin(BigDecimal) - Method in class bb.common.AccountsReceivableVO

setMargin(BigDecimal) - Method in class bb.common.InvoiceItemListResult

setMargin(BigDecimal) - Method in class bb.common.QuoteItemVO

setMargin(BigDecimal) - Method in class bb.common.QuoteVO

setMargin(BigDecimal) - Method in class bb.common.SalesOrderItemVO

setMargin(BigDecimal) - Method in class bb.common.SalesOrderVO

setMarginByStdCost(BigDecimal) - Method in class bb.common.AccountsReceivableInfoVO

setMarginByStdCost(BigDecimal) - Method in class bb.common.AccountsReceivableItemVO

setMarginByStdCost(BigDecimal) - Method in class bb.common.AccountsReceivableVO

setMarginByStdCost(BigDecimal) - Method in class bb.common.QuoteItemVO

setMarginByStdCost(BigDecimal) - Method in class bb.common.QuoteVO

setMarginByStdCost(BigDecimal) - Method in class bb.common.SalesOrderItemVO

setMarginByStdCost(BigDecimal) - Method in class bb.common.SalesOrderVO

setMarginPercent(BigDecimal) - Method in class bb.common.AccountsReceivableInfoVO

setMarginPercent(BigDecimal) - Method in class bb.common.AccountsReceivableItemVO

setMarginPercent(BigDecimal) - Method in class bb.common.AccountsReceivableVO

setMarginPercent(BigDecimal) - Method in class bb.common.InvoiceItemListResult

setMarginPercent(BigDecimal) - Method in class bb.common.QuoteItemVO

setMarginPercent(BigDecimal) - Method in class bb.common.QuoteVO

setMarginPercent(BigDecimal) - Method in class bb.common.SalesOrderItemVO

setMarginPercent(BigDecimal) - Method in class bb.common.SalesOrderVO

setMarginPercentByStdCost(BigDecimal) - Method in class bb.common.AccountsReceivableInfoVO

setMarginPercentByStdCost(BigDecimal) - Method in class bb.common.AccountsReceivableItemVO

setMarginPercentByStdCost(BigDecimal) - Method in class bb.common.AccountsReceivableVO

setMarginPercentByStdCost(BigDecimal) - Method in class bb.common.QuoteItemVO

setMarginPercentByStdCost(BigDecimal) - Method in class bb.common.QuoteVO

setMarginPercentByStdCost(BigDecimal) - Method in class bb.common.SalesOrderItemVO

setMarginPercentByStdCost(BigDecimal) - Method in class bb.common.SalesOrderVO

setMasterWorkOrder(boolean) - Method in class bb.common.WorkOrderItemInfoResult

setMasterWorkOrder(boolean) - Method in class bb.common.WorkOrderItemVO

setMaterial(String) - Method in class bb.common.PartBasicInfo

setMaterial(String) - Method in class bb.common.PartMaterialListResult

setMaterial(String) - Method in class bb.common.PartMaterialReportAgent

setMaterial(String) - Method in class bb.common.PartMaterialVO

setMaterial(String) - Method in class bb.common.PartVO

setMaterial(String) - Method in class bb.common.PartWithOnhandsVO

setMaterialShare(BigDecimal) - Method in class bb.common.WorkOrderIssueStatisticsResult

setMaterialValuationStorageVarianceAccount(String) - Method in class bb.common.AccountingSettingsVO

setMaxAssyQty(BigDecimal) - Method in class bb.common.WorkOrderItemCanAssyResult

setMaxDate(Date) - Method in class bb.common.WorkCenterAgent

setMaxIssued(BigDecimal) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setMaxIssued(BigDecimal) - Method in class bb.common.IssuingItemResult

setMaxLoad(BigDecimal) - Method in class bb.common.WorkCenterLoadListResult

setMaxQty(BigDecimal) - Method in class bb.common.BB2PartInfo

setMaxQty(BigDecimal) - Method in class bb.common.BB2PartTotalOnhandDetailResult

setMaxQty(BigDecimal) - Method in class bb.common.InventoryListResult

setMaxQty(BigDecimal) - Method in class bb.common.PartInventoryVO

setMaxQty(BigDecimal) - Method in class bb.common.PartWithExcessiveInventoryListResult

setMaxQty(BigDecimal) - Method in class bb.common.PartWithOnhandDetailInfoResult

setMaxQty(BigDecimal) - Method in class bb.common.StockTransactionPartInfoResult

setMaxQty(BigDecimal) - Method in class bb.common.ToolInventoryVO

setMaxQtyByAvgCost(BigDecimal) - Method in class bb.common.InventoryTotalResult

setMaxQtyByStdCost(BigDecimal) - Method in class bb.common.InventoryTotalResult

setMaxReceived(BigDecimal) - Method in class bb.common.ReceivingItemResult

setMeasureWorker(String) - Method in class bb.common.InspectionReportInfoVO

setMeasureWorker(String) - Method in class bb.common.InspectionReportVO

setMemo(String) - Method in class bb.common.AccountPayableCheckRunItemVO

setMemo(String) - Method in class bb.common.AccountPayableCheckVO

setMemo(String) - Method in class bb.common.AccountReceivablePaymentVO

setMemo(String) - Method in class bb.common.ARPaymentRunItemVO

setMemo(String) - Method in class bb.common.DepositSummaryResult

setMemo(String) - Method in class bb.common.GeneralLedgerListResult

setMemo(String) - Method in class bb.common.GeneralLedgerVO

setMemo(String) - Method in class bb.common.MakeCheckAgent

setMemo(String) - Method in class bb.common.MakePrepaymentCheckAgent

setMemo(String) - Method in class bb.common.PostCheckAgent

setMemo(String) - Method in class bb.common.TraceableSpecsVO

setMessageI18nKey(String) - Method in class bb.common.I18nEvent

setMessageI18nParams(String[]) - Method in class bb.common.I18nEvent

setMessageNumber(String) - Method in class bb.common.BB2Notice

setMethodId(Long) - Method in class bb.common.EjbMethodVO

setMethodId(Long) - Method in class bb.common.PermissionMethodPK

setMethodName(String) - Method in class bb.common.DynamicSearchFilter

setMethodName(String) - Method in class bb.common.EjbMethodVO

setMethodName(String) - Method in class bb.common.LogMethodPK

setMfg(String) - Method in class bb.common.AccountsPayableItemVO

setMfg(String) - Method in class bb.common.AccountsReceivableItemVO

setMfg(String) - Method in class bb.common.CustomerReturnToVendorItemVO

setMfg(String) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setMfg(String) - Method in class bb.common.OnLoanItemVO

setMfg(String) - Method in class bb.common.OnloanReceiverItemVO

setMfg(String) - Method in class bb.common.OnloanShipperItemVO

setMfg(String) - Method in class bb.common.OrderApprovalItemsVO

setMfg(String) - Method in class bb.common.PartManufacturerAgent

setMfg(String) - Method in class bb.common.PfReceiverItemVO

setMfg(String) - Method in class bb.common.ProformaInvoiceItemVO

setMfg(String) - Method in class bb.common.PurchaseOrderItemVO

setMfg(String) - Method in class bb.common.QuoteItemVO

setMfg(String) - Method in class bb.common.ReceiverItemVO

setMfg(String) - Method in class bb.common.ReceivingItemResult

setMfg(String) - Method in class bb.common.RequestForQuoteItemVO

setMfg(String) - Method in class bb.common.RequestForRMAItemVO

setMfg(String) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setMfg(String) - Method in class bb.common.ReturnToVendorItemVO

setMfg(String) - Method in class bb.common.RMAReceiverItemVO

setMfg(String) - Method in class bb.common.RtvShipperItemVO

setMfg(String) - Method in class bb.common.SalesOrderItemInfoVO

setMfg(String) - Method in class bb.common.SalesOrderItemListResult

setMfg(String) - Method in class bb.common.SalesOrderItemVO

setMfg(String) - Method in class bb.common.SGSaleItemVO

setMfg(String) - Method in class bb.common.ShipperItemVO

setMfg(String) - Method in class bb.common.ShippingItemResult

setMfg(String) - Method in class bb.common.SwapOrderItemVO

setMfg(String) - Method in class bb.common.SwapReceiverItemVO

setMfg(String) - Method in class bb.common.SwapShipperItemVO

setMfg(String) - Method in class bb.common.TransferOrderItemVO

setMfg(String) - Method in class bb.common.TransferReceiverItemListResult

setMfg(String) - Method in class bb.common.TransferReceiverItemVO

setMfg(String) - Method in class bb.common.TransferShipperItemListResult

setMfg(String) - Method in class bb.common.TransferShipperItemVO

setMfg(String) - Method in class bb.common.WorkOrderItemIssueVO

setMfg(String) - Method in class bb.common.WorkOrderItemVO

setMfgBillSetupInfo(String) - Method in class bb.common.BillVO

setMfgCode(String) - Method in class bb.common.AssetVO

setMfgDate(Date) - Method in class bb.common.CustomAssetVO

setMfgID(String) - Method in class bb.common.AssetVO

setMfgID(String) - Method in class bb.common.BomItemWithOEMResult

setMfgID(String) - Method in class bb.common.BomWithOEMResult

setMfgId(short) - Method in class bb.common.PurchaseWorkSheetItemVO

setMfgId(short) - Method in class bb.common.WorkOrderWorkSheetItemVO

setMfgIds(String) - Method in class bb.common.PurchaseWorkSheetItemVO

setMfgIds(String) - Method in class bb.common.WorkOrderWorkSheetItemVO

setMfgPartNumber(String) - Method in class bb.common.ContractPriceItemVO

setMfgPartNumber(String) - Method in class bb.common.ReceiverItemAgent

setMfgPartNumber(String) - Method in class bb.common.RunningAccountOrderItemVO

setMfgPartNumbers(Collection) - Method in class bb.common.CPItemFromQuoteResult

setMfgStatus(String) - Method in class bb.common.DisassembleWorkOrderItemListResult

setMfgStatus(String) - Method in class bb.common.DisassembleWorkOrderItemVO

setMfgStatus(String) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setMfgStatus(String) - Method in class bb.common.WorkOrderItemCanAssyResult

setMfgStatus(String) - Method in class bb.common.WorkOrderItemInWipListResult

setMfgStatus(String) - Method in class bb.common.WorkOrderItemListResult

setMfgStatus(String) - Method in class bb.common.WorkOrderItemPartDetail

setMfgStatus(String) - Method in class bb.common.WorkOrderItemVO

setMfrName(String) - Method in class bb.common.MfrMpnListResult

setMiddleName(String) - Method in class bb.common.BizBoxUserEmployeeResult

setMiddleName(String) - Method in class bb.common.CashierVO

setMiddleName(String) - Method in class bb.common.EmployeeCardVO

setMiddleName(String) - Method in class bb.common.GroupUserVO

setMiddleName(String) - Method in class bb.common.NoticeUserEmployeeListResult

setMinDate(Date) - Method in class bb.common.WorkCenterAgent

setMinIssued(BigDecimal) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setMinIssued(BigDecimal) - Method in class bb.common.IssuingItemResult

setMinOrder(BigDecimal) - Method in class bb.common.InventoryListResult

setMinQty(BigDecimal) - Method in class bb.common.BB2PartInfo

setMinQty(BigDecimal) - Method in class bb.common.BB2PartTotalOnhandDetailResult

setMinQty(BigDecimal) - Method in class bb.common.InventoryListResult

setMinQty(boolean) - Method in class bb.common.MrpReportAgent

setMinQty(BigDecimal) - Method in class bb.common.PartInventoryVO

setMinQty(BigDecimal) - Method in class bb.common.PartWithExcessiveInventoryListResult

setMinQty(BigDecimal) - Method in class bb.common.PartWithOnhandDetailInfoResult

setMinQty(BigDecimal) - Method in class bb.common.StockTransactionPartInfoResult

setMinQty(BigDecimal) - Method in class bb.common.ToolInventoryVO

setMinQtyByAvgCost(BigDecimal) - Method in class bb.common.InventoryTotalResult

setMinQtyByStdCost(BigDecimal) - Method in class bb.common.InventoryTotalResult

setMinReceived(BigDecimal) - Method in class bb.common.ReceivingItemResult

setMissingItems(Integer) - Method in class bb.common.BillDetailCostResult

setMissingItems(Integer) - Method in class bb.common.BillSalesOfCostResult

setMissingItems(Integer) - Method in class bb.common.BillSalesXResult

setMissingItems(Integer) - Method in class bb.common.ToolListDetailCostResult

setMn(String) - Method in class bb.common.CycleCountVO

setMn(String) - Method in class bb.common.PhysicalInventoryVO

setMobile(String) - Method in class bb.common.BizBoxUserEmployeeResult

setMobile(String) - Method in class bb.common.CustomerVendorContactVO

setMobile(String) - Method in class bb.common.EmployeeCardVO

setMobile(String) - Method in class bb.common.ManufacturerContactVO

setMobile(String) - Method in class bb.common.NoticeUserEmployeeListResult

setMobile(String) - Method in class bb.common.SgClientProgramUserVO

setMobile(String) - Method in class bb.common.SGCustRequestForQuoteVO

setMobile(String) - Method in class bb.common.VendorGroupUserVO

setModel(String) - Method in class bb.common.EquipmentListResult

setModel(String) - Method in class bb.common.EquipmentVO

setModel(String) - Method in class bb.common.InventoryPartInOutDetailListResult

setModel(String) - Method in class bb.common.RMAReceiverItemVO

setModelNO(String) - Method in class bb.common.AssetVO

setModelNumber(String) - Method in class bb.common.AccountsReceivableItemVO

setModelNumber(String) - Method in class bb.common.CorrectiveActionRequestVO

setModelNumber(String) - Method in class bb.common.CustomAssetVO

setModelNumber(String) - Method in class bb.common.CustomerReturnToVendorItemVO

setModelNumber(String) - Method in class bb.common.DisassembleWorkOrderIssueVO

setModelNumber(String) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

setModelNumber(String) - Method in class bb.common.DisassembleWorkOrderItemVO

setModelNumber(String) - Method in class bb.common.EngineeringChangeVO

setModelNumber(String) - Method in class bb.common.InventoryListResult

setModelNumber(String) - Method in class bb.common.InventoryNotUsedInMonthsforAppResult

setModelNumber(String) - Method in class bb.common.NonConformanceReportVO

setModelNumber(String) - Method in class bb.common.OnLoanItemVO

setModelNumber(String) - Method in class bb.common.OnloanReceiverItemVO

setModelNumber(String) - Method in class bb.common.OnloanShipperItemVO

setModelNumber(String) - Method in class bb.common.PartBasicInfo

setModelNumber(String) - Method in class bb.common.PartInventoryVO

setModelNumber(String) - Method in class bb.common.PartOnhandVO

setModelNumber(String) - Method in class bb.common.PartVO

setModelNumber(String) - Method in class bb.common.PartWithOnhandsVO

setModelNumber(String) - Method in class bb.common.PfReceiverItemVO

setModelNumber(String) - Method in class bb.common.PhysicalInventoryListWithAppDataResult

setModelNumber(String) - Method in class bb.common.PreventiveActionRequestVO

setModelNumber(String) - Method in class bb.common.ProformaInvoiceItemVO

setModelNumber(String) - Method in class bb.common.PurchaseOrderItemVO

setModelNumber(String) - Method in class bb.common.QuoteItemVO

setModelNumber(String) - Method in class bb.common.ReceiverItemVO

setModelNumber(String) - Method in class bb.common.RequestForQuoteItemVO

setModelNumber(String) - Method in class bb.common.RequestForRMAItemVO

setModelNumber(String) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setModelNumber(String) - Method in class bb.common.ReturnToVendorItemVO

setModelNumber(String) - Method in class bb.common.RunningAccountOrderItemVO

setModelNumber(String) - Method in class bb.common.SalesOrderItemInfoVO

setModelNumber(String) - Method in class bb.common.SalesOrderItemVO

setModelNumber(String) - Method in class bb.common.SGSaleItemVO

setModelNumber(String) - Method in class bb.common.ShipperItemVO

setModelNumber(String) - Method in class bb.common.ToolCalibrationVO

setModelNumber(String) - Method in class bb.common.ToolInventoryVO

setModelNumber(String) - Method in class bb.common.ToolOnhandVO

setModelNumber(String) - Method in class bb.common.ToolVO

setModelNumber(String) - Method in class bb.common.ToolWithOnhandsVO

setModelNumber(String) - Method in class bb.common.WorkOrderItemIssuedTotalResult

setModelNumber(String) - Method in class bb.common.WorkOrderItemIssueVO

setModelNumber(String) - Method in class bb.common.WorkOrderItemTimeDetailVO

setModelNumber(String) - Method in class bb.common.WorkOrderItemVO

setModelNumber(String) - Method in class bb.common.WorkOrderReceiverVO

setModule(String) - Method in class bb.common.CustomSearchVO

setModuleName(String) - Method in class bb.common.BizboxBugInfoVO

setModuleName(String) - Method in class bb.common.BizboxBugVO

setMoldeNumber(String) - Method in class bb.common.AccountsPayableItemVO

setMoldNumber(String) - Method in class bb.common.RtvShipperItemVO

setMoney(Money) - Method in class bb.common.QtyAndMoney

setMonth(String) - Method in class bb.common.AccountMonthPK

setMonth(String) - Method in class bb.common.AssetDepreciatePK

setMonth(String) - Method in class bb.common.CashFlowMonthTotalResult

setMonth(String) - Method in class bb.common.PurchaseOrderOnTimeItemResult

setMonth(String) - Method in class bb.common.SalesOrderOnTimeItemResult

setMonth(String) - Method in class bb.common.WorkOrderOnTimeItemResult

setMonthAmountMap(Map<String, BigDecimal>) - Method in class bb.common.MonthSoOrArByCustomerResult

setMonthCount(int) - Method in class bb.common.BB2FiscalYearDate

setMonthDepreciation(BigDecimal) - Method in class bb.common.AssetVO

setMonthDepreciationRate(BigDecimal) - Method in class bb.common.AssetDepreciateDetailReport

setMonthDepreciationRate(BigDecimal) - Method in class bb.common.AssetDepreciateVO

setMonthDepreciationRate(BigDecimal) - Method in class bb.common.AssetVO

setMonthName(String) - Method in class bb.common.MrpByMonthResult

setMonthOutputValues(Map<Date, BigDecimal>) - Method in class bb.common.OutputValueByMonthResult

setMonthQty(BigDecimal) - Method in class bb.common.PurchaseWorkSheetItemVO

setMonthQty(BigDecimal) - Method in class bb.common.WorkOrderWorkSheetItemVO

setMonths(int) - Method in class bb.common.OnTimeAgent

setMonths(Integer) - Method in class bb.common.PurchaseWorkSheetItemVO

setMonths(int) - Method in class bb.common.WorkOrderWorkSheetItemVO

setMonths(Integer) - Method in class bb.common.WorkSheetPartAgent

setMonthsInfo(LinkedList) - Method in class bb.common.MrpItemResult

setMonthToDate(BigDecimal) - Method in class bb.common.ClosingStatementItemResult

setMonthToDate(BigDecimal) - Method in class bb.common.ClosingStatementTotalResult

setMonthYear(String) - Method in class bb.common.AccountBalanceAgent

setMonthYear(String) - Method in class bb.common.AccountsChartAdvanceCategoryVO

setMonthYear(String) - Method in class bb.common.BalanceSheetSideBySideResult

setMonthYear(String) - Method in class bb.common.ClosingStatementResult

setMonthYear(String) - Method in class bb.common.CurrencyExchangePK

setMonthYear(String) - Method in class bb.common.ExchangeAuditResult

setMonthYear(String) - Method in class bb.common.GlMonthBudgetVO

setMonthYear(String) - Method in class bb.common.GlMonthVO

setMothedParm(String) - Method in class bb.common.TempArApAgingVO

setMpn(String) - Method in class bb.common.AccountsPayableItemVO

setMpn(String) - Method in class bb.common.AccountsReceivableItemVO

setMpn(String) - Method in class bb.common.BomItemWithOEMResult

setMpn(String) - Method in class bb.common.BomWithOEMResult

setMpn(String) - Method in class bb.common.CustomerReturnToVendorItemVO

setMpn(String) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setMpn(String) - Method in class bb.common.MfrMpnListResult

setMpn(String) - Method in class bb.common.OnLoanItemVO

setMpn(String) - Method in class bb.common.OnloanReceiverItemVO

setMpn(String) - Method in class bb.common.OnloanShipperItemVO

setMpn(String) - Method in class bb.common.OrderApprovalItemsVO

setMpn(String) - Method in class bb.common.PartManufacturerAgent

setMpn(String) - Method in class bb.common.PfReceiverItemVO

setMpn(String) - Method in class bb.common.ProformaInvoiceItemVO

setMpn(String) - Method in class bb.common.PurchaseOrderItemVO

setMpn(String) - Method in class bb.common.QuoteItemVO

setMpn(String) - Method in class bb.common.ReceiverItemVO

setMpn(String) - Method in class bb.common.ReceivingItemResult

setMpn(String) - Method in class bb.common.RequestForQuoteItemVO

setMpn(String) - Method in class bb.common.RequestForRMAItemVO

setMpn(String) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setMpn(String) - Method in class bb.common.ReturnToVendorItemVO

setMpn(String) - Method in class bb.common.RMAReceiverItemVO

setMpn(String) - Method in class bb.common.RtvShipperItemVO

setMpn(String) - Method in class bb.common.SalesOrderItemInfoVO

setMpn(String) - Method in class bb.common.SalesOrderItemListResult

setMpn(String) - Method in class bb.common.SalesOrderItemVO

setMpn(String) - Method in class bb.common.SGSaleItemVO

setMpn(String) - Method in class bb.common.ShipperItemVO

setMpn(String) - Method in class bb.common.ShippingItemResult

setMpn(String) - Method in class bb.common.SwapOrderItemVO

setMpn(String) - Method in class bb.common.SwapReceiverItemVO

setMpn(String) - Method in class bb.common.SwapShipperItemVO

setMpn(String) - Method in class bb.common.TransferOrderItemVO

setMpn(String) - Method in class bb.common.TransferReceiverItemListResult

setMpn(String) - Method in class bb.common.TransferReceiverItemVO

setMpn(String) - Method in class bb.common.TransferShipperItemListResult

setMpn(String) - Method in class bb.common.TransferShipperItemVO

setMpn(String) - Method in class bb.common.WorkOrderItemIssueVO

setMpn(String) - Method in class bb.common.WorkOrderItemVO

setMpnRev(String) - Method in class bb.common.PartManufacturerAgent

setMpnRev(String) - Method in class bb.common.WorkOrderItemVO

setMpnUsedOneTime(boolean) - Method in class bb.common.CompanyVO

setMpoDebitAccount(String) - Method in class bb.common.AccountingSettingsVO

setMultiCompanyUnit(String) - Method in class bb.common.BizboxUserVO

setMultiDescription(Set) - Method in class bb.common.CustomerVendorAddressVO

setMultiDescription(Set) - Method in class bb.common.ManufacturerAddressVO

setMultiLanguage(Set) - Method in class bb.common.PartVO

setMultiLanguage(Set) - Method in class bb.common.PartWithOnhandsVO

setMultiLanguage(Set) - Method in class bb.common.PermissionVO

setMultiLanguage(Set) - Method in class bb.common.RoleVO

setMultiLanguage(Set) - Method in class bb.common.ToolVO

setMultiLanguage(Set) - Method in class bb.common.ToolWithOnhandsVO

setMultiLanuageDescription(Set<MultiLanguageAccountsChartVO>) - Method in class bb.common.AccountsChartVO

setMultiplier(String) - Method in class bb.common.PartUnitVO

setMultiQtyforApplying(BigDecimal) - Method in class bb.common.BillItemWithPartInfoResult

setMultiQtyforApplying(BigDecimal) - Method in class bb.common.PartVO

setMultiQtyforApplying(BigDecimal) - Method in class bb.common.WorkOrderItemSetupItemAgent

setMustOrder(BigDecimal) - Method in class bb.common.MrpItemResult

setMustOrderBefore(BigDecimal) - Method in class bb.common.MrpItemResult

setName(String) - Method in class bb.common.AccountPayableCheckVO

setName(String) - Method in class bb.common.AccountReceivablePaymentVO

setName(String) - Method in class bb.common.AddressAccountInfo

setName(String) - Method in class bb.common.AppColumnVO

setName(String) - Method in class bb.common.AssetTypeVO

setName(String) - Method in class bb.common.BB2Task

setName(String) - Method in class bb.common.CompanyUnitVO

setName(String) - Method in class bb.common.CustomCheckUpEmployeeVO

setName(String) - Method in class bb.common.CustomDepartmentVO

setName(String) - Method in class bb.common.CustomEmployeeVO

setName(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setName(String) - Method in class bb.common.CustomerVendorAddressVO

setName(String) - Method in class bb.common.CustomerVendorContactVO

setName(String) - Method in class bb.common.CustomerVendorDescriptionVO

setName(String) - Method in class bb.common.CustomGoodsBreedVO

setName(String) - Method in class bb.common.CustomJobCategoryVO

setName(String) - Method in class bb.common.CustomSearchVO

setName(String) - Method in class bb.common.CV2CVAgent

setName(String) - Method in class bb.common.EngGroupVO

setName(String) - Method in class bb.common.GeneralLedgerCategoryVO

setName(String) - Method in class bb.common.GeneralLedgerListResult

setName(String) - Method in class bb.common.GeneralLedgerResult

setName(String) - Method in class bb.common.GeneralLedgerVO

setName(String) - Method in class bb.common.LabelTemplateItemVO

setName(String) - Method in class bb.common.LabelTemplateVO

setName(String) - Method in class bb.common.LockedCustomerAddressResult

setName(String) - Method in class bb.common.LogTaskVO

setName(String) - Method in class bb.common.MakeCheckAgent

setName(String) - Method in class bb.common.ManufacturerAddressInfoVO

setName(String) - Method in class bb.common.ManufacturerAddressVO

setName(String) - Method in class bb.common.ManufacturerContactVO

setName(String) - Method in class bb.common.ManufacturerDescriptionVO

setName(String) - Method in class bb.common.NonproductivePickingTypeVO

setName(String) - Method in class bb.common.OntimeDeliveryRateListResult

setName(String) - Method in class bb.common.PartCatagoryVO

setName(String) - Method in class bb.common.PartCatalogAuditResult

setName(String) - Method in class bb.common.PartCatalogVO

setName(String) - Method in class bb.common.SalesOrderItemCustomerTotalResult

setName(String) - Method in class bb.common.SGCartCheckOutResult

setName(String) - Method in class bb.common.SGCompanyVO

setName(String) - Method in class bb.common.SGCustRequestForQuoteListResult

setName(String) - Method in class bb.common.SGCustRequestForQuoteResult

setName(String) - Method in class bb.common.SGPartCatalogResult

setName(String) - Method in class bb.common.SGQuoteAddressResult

setName(String) - Method in class bb.common.SGQuoteAddressVO

setName(String) - Method in class bb.common.TaskVO

setName(String) - Method in class bb.common.VendorTotalAmountInPO

setName(String) - Method in class bb.common.WarehouseVO

setName(String) - Method in class bb.common.WorkInstructionApprovalVO

setNaRecTo(String) - Method in class bb.common.ReceiverItemAgent

setNativePlace(String) - Method in class bb.common.CustomEmployeeVO

setNcCodeOnlyOneLetterOrTwoNumber(boolean) - Method in class bb.common.CompanyVO

setNcode(String) - Method in class bb.common.NcrReportListResult

setNcr(String) - Method in class bb.common.NCRPartOnhandPK

setNcr(String) - Method in class bb.common.ReturnToVendorByDateListResult

setNcr(Set<Map<String, BigDecimal>>) - Method in class bb.common.WorkOrderOverIssueListResult

setNcrDate(Date) - Method in class bb.common.NcrNeedToScrapListResult

setNcrDate(Date) - Method in class bb.common.NcrReportListResult

setNcrDate(Date) - Method in class bb.common.NonConformanceReportVO

setNcrNumber(String) - Method in class bb.common.AuditPartInQAResult

setNcrNumber(String) - Method in class bb.common.NcrNeedToScrapListResult

setNcrNumber(String) - Method in class bb.common.NCRPictureListResult

setNcrNumber(String) - Method in class bb.common.NCRPictureVO

setNcrNumber(String) - Method in class bb.common.NcrReportListResult

setNcrNumber(String) - Method in class bb.common.NcrScrapAgent

setNcrNumber(String) - Method in class bb.common.NonConformanceQuantityPK

setNcrNumber(String) - Method in class bb.common.NonConformanceReportVO

setNcrNumber(String) - Method in class bb.common.PartInQAAgent

setNcrNumber(String) - Method in class bb.common.PartInQAResult

setNcrNumber(String) - Method in class bb.common.PartInQAVO

setNcrNumber(String) - Method in class bb.common.RebackInQAAgent

setNcrNumber(String) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setNcrNumber(String) - Method in class bb.common.ReturnToVendorItemVO

setNcrNumber(String) - Method in class bb.common.RMAItemListResult

setNcrNumber(String) - Method in class bb.common.ScrapReportVO

setNcrNumber(String) - Method in class bb.common.ShipperItemDetailAgent

setNcrNumber(String) - Method in class bb.common.ShippingItemResult

setNcrPictures(Set) - Method in class bb.common.NonConformanceReportVO

setNCRReferenceDocOne(String, String) - Method in interface bb.common.box.QualityBox

setNCRReferenceDocTwo(String, String) - Method in interface bb.common.box.QualityBox

setNcrScrapApprovedBy(String) - Method in class bb.common.AccountingConfigurationVO

setNcrStatus(String) - Method in class bb.common.AuditPartInQAResult

setNeedLog(boolean) - Method in class bb.common.LogMethodVO

setNeedLog(boolean) - Method in class bb.common.TaskVO

setNeedPassforIssuingWO(boolean) - Method in class bb.common.CompanyVO

setNeedPickerforIssuingWO(boolean) - Method in class bb.common.CompanyVO

setNeedReply(boolean) - Method in class bb.common.BB2Notice

setNeedToSetFLAG(boolean) - Method in class bb.common.PartToAuditFlagResult

setNetBookValue(BigDecimal) - Method in class bb.common.AssetAddOrDisposalsReport

setNetProfit(ClosingStatementTotalResult) - Method in class bb.common.ClosingStatementResult

setNetProfit(ProfitLossStatementItemResult) - Method in class bb.common.ProfitLossStatementResult

setNetProfitBeforeOtherIncome(ClosingStatementTotalResult) - Method in class bb.common.ClosingStatementResult

setNetProfitBeforeWriteOffs(ClosingStatementTotalResult) - Method in class bb.common.ClosingStatementResult

setNetProfiteBeforeIncomeTax(ClosingStatementTotalResult) - Method in class bb.common.ClosingStatementResult

setNetSalvage(BigDecimal) - Method in class bb.common.AssetAddOrDisposalsReport

setNetSalvage(BigDecimal) - Method in class bb.common.AssetDepreciateDetailReport

setNetSalvage(BigDecimal) - Method in class bb.common.AssetDepreciateVO

setNetSalvage(BigDecimal) - Method in class bb.common.AssetReportSumResult

setNetSalvage(BigDecimal) - Method in class bb.common.AssetVO

setNetTaxableSales(BigDecimal) - Method in class bb.common.ZipcodeTotalsResult

setNetTotal(BigDecimal) - Method in class bb.common.ArCommissionTotalResult

setNetTotal(BigDecimal) - Method in class bb.common.ArSalesCodeTotalListResult

setNetTotal(BigDecimal) - Method in class bb.common.RunningAccountOrderItemVO

setNetTotal(BigDecimal) - Method in class bb.common.RunningAccountOrderVO

setNetWeight(BigDecimal) - Method in class bb.common.PackingBoxVO

setNetWeight(BigDecimal) - Method in class bb.common.PrPackingBoxVO

setNewAvgHrs(BigDecimal) - Method in class bb.common.WorkInstructionSeqAuditListResult

setNewCost(BigDecimal) - Method in class bb.common.InventoryAdjustmentVO

setNewCost(BigDecimal) - Method in class bb.common.LogInventoryListResult

setNewCost(BigDecimal) - Method in class bb.common.LogInventoryVO

setNewEngGroup(String) - Method in class bb.common.PartBasicInfoWithNewEngGroup

setNewInQA(BigDecimal) - Method in class bb.common.LogInventoryListResult

setNewInQA(BigDecimal) - Method in class bb.common.LogInventoryVO

setNewInTO(BigDecimal) - Method in class bb.common.LogInventoryListResult

setNewListPrice(BigDecimal) - Method in class bb.common.PartBasicInfoWithNewListPrice

setNewLnQty(BigDecimal) - Method in class bb.common.InventoryReportListResult

setNewLocation(String) - Method in class bb.common.CycleCountListResult

setNewLocation(String) - Method in class bb.common.CycleCountVO

setNewLocation(String) - Method in class bb.common.PhysicalInventoryListResult

setNewLocation(String) - Method in class bb.common.PhysicalInventoryVO

setNewOnhand(BigDecimal) - Method in class bb.common.AddPhysicalInventoryAgent

setNewOnhand(BigDecimal) - Method in class bb.common.BB2PartByDateResult

setNewOnhand(BigDecimal) - Method in class bb.common.CycleCountListResult

setNewOnhand(BigDecimal) - Method in class bb.common.CycleCountVO

setNewOnhand(BigDecimal) - Method in class bb.common.LogInventoryListResult

setNewOnhand(BigDecimal) - Method in class bb.common.LogInventoryVO

setNewOnhand(BigDecimal) - Method in class bb.common.PhysicalInventoryListResult

setNewOnhand(BigDecimal) - Method in class bb.common.PhysicalInventoryVO

setNewOnhand(BigDecimal) - Method in class bb.common.StockTransactionAdjustmentResult

setNewOnhandQty(BigDecimal) - Method in class bb.common.InventoryAdjustmentVO

setNewPart(String) - Method in class bb.common.PartTraceableListResult

setNewPart(String) - Method in class bb.common.PartVO

setNewPart(String) - Method in class bb.common.PartWithOnhandsVO

setNewPartNumber(String) - Method in class bb.common.BillLogVO

setNewPartQuantity(BigDecimal) - Method in class bb.common.BillLogVO

setNewPartType(String) - Method in class bb.common.BillLogVO

setNewQaQty(BigDecimal) - Method in class bb.common.InventoryReportListResult

setNewQtyPicked(BigDecimal) - Method in class bb.common.PartTrackingVO

setNewRev(String) - Method in class bb.common.EngineeringChangeVO

setNewRevision(String) - Method in class bb.common.EngineeringChangeListResult

setNewShipListDescription(String) - Method in class bb.common.ShipListAgent

setNewSip(BigDecimal) - Method in class bb.common.LogInventoryListResult

setNewSip(BigDecimal) - Method in class bb.common.LogInventoryVO

setNewSipQty(BigDecimal) - Method in class bb.common.InventoryReportListResult

setNewSit(BigDecimal) - Method in class bb.common.LogInventoryListResult

setNewSit(BigDecimal) - Method in class bb.common.LogInventoryVO

setNewSitQty(BigDecimal) - Method in class bb.common.InventoryReportListResult

setNewSparePart(String) - Method in class bb.common.BillLogVO

setNewStdCost(BigDecimal) - Method in class bb.common.ChangeStdCostWorkSheetItemVO

setNewTotal(BigDecimal) - Method in class bb.common.PhysicalInventoryListWithAppDataResult

setNewTotalCost(BigDecimal) - Method in class bb.common.BB2PartByDateResult

setNewWip(BigDecimal) - Method in class bb.common.LogInventoryListResult

setNewWip(BigDecimal) - Method in class bb.common.LogInventoryVO

setNextCycleCount(Date) - Method in class bb.common.PartClassVO

setNextInspection(Date) - Method in class bb.common.ToolCalibrationVO

setNextScheduledMaintenanceDate(Date) - Method in class bb.common.EquipmentListResult

setNextScheduledMaintenanceDate(Date) - Method in class bb.common.EquipmentVO

setNnAr(byte) - Method in class bb.common.AccountReceivablePaymentVO

setNonConformanceCode(String) - Method in class bb.common.NCQRejectResult

setNonConformanceCode(String) - Method in class bb.common.NonConformanceQuantityVO

setNonConformanceCodeName(NonConformanceCodeVO) - Method in class bb.common.NonConformanceQuantityVO

setNonConformanceQuantity(Set) - Method in class bb.common.NonConformanceReportVO

setNonConformanceReport(NonConformanceReportVO) - Method in class bb.common.NonConformanceQuantityVO

setNonEnglishAllowed(boolean) - Method in class bb.common.CompanyVO

setNonIssueQty(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemListResult

setNonIssueQty(BigDecimal) - Method in class bb.common.WorkOrderItemListResult

setNonproPickingOnDemandList(ArrayList) - Method in class bb.common.MrpItemResult

setNoPayAmount(BigDecimal) - Method in class bb.common.PurchaseOrderContractResult

setNoStorageAmount(BigDecimal) - Method in class bb.common.PurchaseOrderContractResult

setNotApproveEcnCount(Integer) - Method in class bb.common.EngineeringInfoCenterResult

setNotAsmQty(BigDecimal) - Method in class bb.common.WCLoadDetailResult

setNotCompletedQty(BigDecimal) - Method in class bb.common.WorkCenterRunTimeListResult

setNotCompletedSeqBefore(int) - Method in class bb.common.WCLoadDetailResult

setNotCompletedSeqWithPOBefore(int) - Method in class bb.common.WCLoadDetailResult

setNote(String) - Method in class bb.common.InspectionTypeVO

setNote(String) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setNote(String) - Method in class bb.common.NonproductivePickingItemIssuedVO

setNote(String) - Method in class bb.common.PartIssuedVO

setNote(String) - Method in class bb.common.PartReceivedVO

setNotedBy(String) - Method in class bb.common.PreventiveActionRequestVO

setNotes(String) - Method in class bb.common.AccountsPayableInfoVO

setNotes(String) - Method in class bb.common.AccountsPayableItemVO

setNotes(String) - Method in class bb.common.AccountsPayableVO

setNotes(String) - Method in class bb.common.DisassembleWorkOrderItemListResult

setNotes(String) - Method in class bb.common.GeneralLedgerListResult

setNotes(String) - Method in class bb.common.GeneralLedgerVO

setNotes(String) - Method in class bb.common.NonproductivePickingItemResult

setNotes(String) - Method in class bb.common.NonproductivePickingItemVO

setNotes(String) - Method in class bb.common.NonproductivePickingVO

setNotes(String) - Method in class bb.common.OnloanReceiverItemListResult

setNotes(String) - Method in class bb.common.OnloanReceiverListResult

setNotes(String) - Method in class bb.common.PosZipCodeTaxVO

setNotes(String) - Method in class bb.common.ProformaInvoiceVO

setNotes(String) - Method in class bb.common.PurchaseOrderOnOrderResult

setNotes(String) - Method in class bb.common.RMAReceiverItemListResult

setNotes(String) - Method in class bb.common.RMAReceiverItemVO

setNotes(String) - Method in class bb.common.RMAReceiverListResult

setNotes(String) - Method in class bb.common.RMAReceiverVO

setNotes(String) - Method in class bb.common.RtvShipperInfoVO

setNotes(String) - Method in class bb.common.RtvShipperItemListResult

setNotes(String) - Method in class bb.common.RtvShipperItemVO

setNotes(String) - Method in class bb.common.RtvShipperListResult

setNotes(String) - Method in class bb.common.RtvShipperVO

setNotes(String) - Method in class bb.common.RunningAccountOrderItemResult

setNotes(String) - Method in class bb.common.RunningAccountOrderVO

setNotes(String) - Method in class bb.common.SwapOrderListResult

setNotes(String) - Method in class bb.common.SwapOrderVO

setNotes(String) - Method in class bb.common.SwapReceiverListResult

setNotes(String) - Method in class bb.common.SwapReceiverVO

setNotes(String) - Method in class bb.common.SwapShipperListResult

setNotes(String) - Method in class bb.common.SwapShipperVO

setNotes(String) - Method in class bb.common.WorkOrderItemListResult

setNoticeReceiveGap(int) - Method in class bb.common.CompanyVO

setNoticeReceivers(String) - Method in class bb.common.TaskVO

setNoticeText(String) - Method in class bb.common.BB2Notice

setNotRecItemsOnTimeQty(BigDecimal) - Method in class bb.common.PurchaseOrderOnTimeItemResult

setNotRecItemsOnTimeQty(BigDecimal) - Method in class bb.common.WorkOrderOnTimeItemResult

setNotRecTotalOnTime(BigDecimal) - Method in class bb.common.PurchaseOrderOnTimeItemResult

setNotRecTotalOnTime(BigDecimal) - Method in class bb.common.WorkOrderOnTimeItemResult

setNotReviewedOnDemandQty(BigDecimal) - Method in class bb.common.MrpItemResult

setNotReviewedOnOrderQty(BigDecimal) - Method in class bb.common.MrpItemResult

setNotShippedOnTimeQty(BigDecimal) - Method in class bb.common.SalesOrderOnTimeItemResult

setNotShippedOnTimeTotal(BigDecimal) - Method in class bb.common.SalesOrderOnTimeItemResult

setNotShippedQty(BigDecimal) - Method in class bb.common.SalesOrderItemGroupByPartListResult

setNpDetails(ArrayList<NonproductivePickingOnDemandResult>) - Method in class bb.common.BB2PartTotalOndemandDetailResult

setNudeSighRight(BigDecimal) - Method in class bb.common.CustomCheckUpEmployeeVO

setNudeSightLeft(BigDecimal) - Method in class bb.common.CustomCheckUpEmployeeVO

setNumberOfAPs(Long) - Method in class bb.common.AccountPayableCheckVO

setNumOfItems(Integer) - Method in class bb.common.PartIssueTotalResult

setNumOfItems(int) - Method in class bb.common.SalesOrderItemCustomerTotalResult

setNumOfMissingItems(int) - Method in class bb.common.SalesOrderItemCostResult

setObsoleteEcnCount(Integer) - Method in class bb.common.EngineeringInfoCenterResult

setOCode(String) - Method in class bb.common.PartInventoryVO

setOCode(String) - Method in class bb.common.ToolInventoryVO

setOfBoxNumber(int) - Method in class bb.common.ShipperItemDetailAgent

setOffsetUnbilledGLNumber(String) - Method in class bb.common.ShipperItemVO

setOldAvgCost(BigDecimal) - Method in class bb.common.PhysicalInventoryListResult

setOldAvgHrs(BigDecimal) - Method in class bb.common.WorkInstructionSeqAuditListResult

setOldCost(BigDecimal) - Method in class bb.common.InventoryAdjustmentVO

setOldCost(BigDecimal) - Method in class bb.common.LogInventoryListResult

setOldCost(BigDecimal) - Method in class bb.common.LogInventoryVO

setOldId(String) - Method in class bb.common.CV2CVAgent

setOldInQA(BigDecimal) - Method in class bb.common.LogInventoryListResult

setOldInQA(BigDecimal) - Method in class bb.common.LogInventoryVO

setOldInTO(BigDecimal) - Method in class bb.common.LogInventoryListResult

setOldLnQty(BigDecimal) - Method in class bb.common.InventoryReportListResult

setOldOnhand(BigDecimal) - Method in class bb.common.BB2PartByDateResult

setOldOnhand(BigDecimal) - Method in class bb.common.LogInventoryListResult

setOldOnhand(BigDecimal) - Method in class bb.common.LogInventoryVO

setOldOnhand(BigDecimal) - Method in class bb.common.StockTransactionAdjustmentResult

setOldOnhandQty(BigDecimal) - Method in class bb.common.InventoryAdjustmentVO

setOldOnloanQty(BigDecimal) - Method in class bb.common.PhysicalInventoryListResult

setOldQaQty(BigDecimal) - Method in class bb.common.InventoryReportListResult

setOldRev(String) - Method in class bb.common.EngineeringChangeVO

setOldRevision(String) - Method in class bb.common.EngineeringChangeListResult

setOldSip(BigDecimal) - Method in class bb.common.LogInventoryListResult

setOldSip(BigDecimal) - Method in class bb.common.LogInventoryVO

setOldSip(BigDecimal) - Method in class bb.common.PhysicalInventoryListResult

setOldSipQty(BigDecimal) - Method in class bb.common.InventoryReportListResult

setOldSit(BigDecimal) - Method in class bb.common.LogInventoryListResult

setOldSit(BigDecimal) - Method in class bb.common.LogInventoryVO

setOldSitQty(BigDecimal) - Method in class bb.common.InventoryReportListResult

setOldStadCost(BigDecimal) - Method in class bb.common.PhysicalInventoryListResult

setOldTotalCost(BigDecimal) - Method in class bb.common.BB2PartByDateResult

setOldWip(BigDecimal) - Method in class bb.common.LogInventoryListResult

setOldWip(BigDecimal) - Method in class bb.common.LogInventoryVO

setOldWorkCenterId(String) - Method in class bb.common.WC2WCAgent

setOndemand(BigDecimal) - Method in class bb.common.BB2PartInfo

setOndemand(BigDecimal) - Method in class bb.common.BB2PartOnDemandListResult

setOndemand(BigDecimal) - Method in class bb.common.BillItemOnHandUsageResult

setOndemand(BigDecimal) - Method in class bb.common.BillItemOnHandWithPartInfoResult

setOndemand(BigDecimal) - Method in class bb.common.BillOnHandWithPartInfoResult

setOndemand(BigDecimal) - Method in class bb.common.BillWhereUsedResult

setOndemand(BigDecimal) - Method in class bb.common.BOMCanAssyListResult

setOndemand(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemPartDetailItemResult

setOndemand(BigDecimal) - Method in class bb.common.EcnPOOrderResult

setOndemand(BigDecimal) - Method in class bb.common.EcnWOOrderResult

setOnDemand(BigDecimal) - Method in class bb.common.InventoryListResult

setOndemand(BigDecimal) - Method in class bb.common.IssuingItemResult

setOndemand(BigDecimal) - Method in class bb.common.PartOnHandWithMfgInfoResult

setOnDemand(BigDecimal) - Method in class bb.common.PartWhereUsedItemResult

setOnDemand(BigDecimal) - Method in class bb.common.PartWithExcessiveInventoryListResult

setOndemand(BigDecimal) - Method in class bb.common.PartWithInventoryInfoListResult

setOnDemand(BigDecimal) - Method in class bb.common.SalesOrderItemGroupByPartListResult

setOndemand(BigDecimal) - Method in class bb.common.StockTransactionPartInfoResult

setOndemand(BigDecimal) - Method in class bb.common.WOItemPartDetailNotIssue

setOndemand(BigDecimal) - Method in class bb.common.WorkOrderItemPartDetailItemResult

setOndemandByAvgCost(BigDecimal) - Method in class bb.common.InventoryTotalResult

setOndemandByStdCost(BigDecimal) - Method in class bb.common.InventoryTotalResult

setOnDemandInSO(BigDecimal) - Method in class bb.common.SalesOrderItemGroupByPartListResult

setOnDemandQty(BigDecimal) - Method in class bb.common.BB2PartInventoryResult

setOnDemandQty(BigDecimal) - Method in class bb.common.CRTVItemListResult

setOnDemandQty(BigDecimal) - Method in class bb.common.HistoricalInventoryVO

setOnDemandQty(BigDecimal) - Method in class bb.common.MrpItemResult

setOnDemandQty(BigDecimal) - Method in class bb.common.OnLoanItemListResult

setOnDemandQty(BigDecimal) - Method in class bb.common.PartInventoryVO

setOnDemandQty(BigDecimal) - Method in class bb.common.PartOnHandWithPartBasicInfoResult

setOnDemandQty(BigDecimal) - Method in class bb.common.PurchaseOrderItemListResult

setOnDemandQty(BigDecimal) - Method in class bb.common.PurchaseOrderOpenDueListResult

setOnDemandQty(BigDecimal) - Method in class bb.common.QuoteItemListResult

setOnDemandQty(BigDecimal) - Method in class bb.common.RMAItemListResult

setOnDemandQty(BigDecimal) - Method in class bb.common.RRMAItemListResult

setOnDemandQty(BigDecimal) - Method in class bb.common.SalesOrderItemListResult

setOnDemandQty(BigDecimal) - Method in class bb.common.ToolInventoryVO

setOneGLForBatchPayment(boolean) - Method in class bb.common.CompanyVO

setOnhand(BigDecimal) - Method in class bb.common.BB2PartInfo

setOnhand(BigDecimal) - Method in class bb.common.BB2PartInventoryResult

setOnhand(BigDecimal) - Method in class bb.common.BB2PartOnDemandListResult

setOnhand(BigDecimal) - Method in class bb.common.BillItemOnHandUsageResult

setOnhand(BigDecimal) - Method in class bb.common.BillItemOnHandWithPartInfoResult

setOnHand(BigDecimal) - Method in class bb.common.BillItemReplacementVO

setOnhand(BigDecimal) - Method in class bb.common.BillOnHandWithPartInfoResult

setOnhand(BigDecimal) - Method in class bb.common.BillWhereUsedItemResult

setOnhand(BigDecimal) - Method in class bb.common.BillWhereUsedResult

setOnhand(BigDecimal) - Method in class bb.common.BOMCanAssyListResult

setOnhand(BigDecimal) - Method in class bb.common.BomPickListItemResult

setOnHand(BigDecimal) - Method in class bb.common.ChangeStdCostWorkSheetItemVO

setOnhand(BigDecimal) - Method in class bb.common.CycleCountVO

setOnhand(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemPartDetailItemResult

setOnhand(BigDecimal) - Method in class bb.common.EcnPOOrderResult

setOnhand(BigDecimal) - Method in class bb.common.EcnWOOrderResult

setOnhand(BigDecimal) - Method in class bb.common.HistoricalInventoryVO

setOnhand(BigDecimal) - Method in class bb.common.InSipAudittListResult

setOnhand(BigDecimal) - Method in class bb.common.InventoryCycleItemResult

setOnhand(BigDecimal) - Method in class bb.common.InventoryListResult

setOnhand(BigDecimal) - Method in class bb.common.InventoryNotUsedInMonthsResult

setOnhand(BigDecimal) - Method in class bb.common.PartInventoryVO

setOnhand(BigDecimal) - Method in class bb.common.PartMaterialWhereUsedItemResult

setOnhand(BigDecimal) - Method in class bb.common.PartOnHandAuditResult

setOnhand(BigDecimal) - Method in class bb.common.PartOnhandCostVO

setOnhand(BigDecimal) - Method in class bb.common.PartOnHandWithMfgInfoResult

setOnhand(BigDecimal) - Method in class bb.common.PartOnHandWithPartBasicInfoResult

setOnhand(BigDecimal) - Method in class bb.common.PartWhereUsedItemResult

setOnHand(BigDecimal) - Method in class bb.common.PartWithExcessiveInventoryListResult

setOnhand(BigDecimal) - Method in class bb.common.PartWithInventoryInfoListResult

setOnhand(BigDecimal) - Method in class bb.common.PartWithoutLocateResult

setOnHand(BigDecimal) - Method in class bb.common.PartWithQAQtyListResult

setOnHand(BigDecimal) - Method in class bb.common.PartWithQtyListResult

setOnHand(BigDecimal) - Method in class bb.common.PartWithSipQtyListResult

setOnHand(BigDecimal) - Method in class bb.common.PartWithSITQtyListResult

setOnHand(BigDecimal) - Method in class bb.common.PartWithSTOQtyListResult

setOnHand(BigDecimal) - Method in class bb.common.PartWithWipQtyListResult

setOnhand(BigDecimal) - Method in class bb.common.PhysicalInventoryVO

setOnHand(BigDecimal) - Method in class bb.common.RollUpBomStdCostWorkSheetItemVO

setOnhand(BigDecimal) - Method in class bb.common.SalesOrderItemGroupByPartListResult

setOnhand(BigDecimal) - Method in class bb.common.SGBOMItemResult

setOnhand(BigDecimal) - Method in class bb.common.ShipListItemRelatedDocResult

setOnhand(BigDecimal) - Method in class bb.common.ShippingItemResult

setOnhand(BigDecimal) - Method in class bb.common.StockTransactionPartInfoResult

setOnhand(BigDecimal) - Method in class bb.common.ToolInventoryVO

setOnhand(BigDecimal) - Method in class bb.common.ToolWhereUsedItemResult

setOnhand(BigDecimal) - Method in class bb.common.WOItemPartDetailNotIssue

setOnhand(BigDecimal) - Method in class bb.common.WoItemPickListItemResult

setOnhand(BigDecimal) - Method in class bb.common.WorkOrderItemPartDetailItemResult

setOnhandLocation(Collection) - Method in class bb.common.BillItemOnHandUsageResult

setOnhandLocation(Collection) - Method in class bb.common.BillItemOnHandWithPartInfoResult

setOnHandLocations(Set<PartOnhandVO>) - Method in class bb.common.PartWithOnhandsVO

setOnHandLocations(Set) - Method in class bb.common.ToolWithOnhandsVO

setOnhandQty(BigDecimal) - Method in class bb.common.AuditOnDemandResult

setOnhandQty(BigDecimal) - Method in class bb.common.CRTVItemListResult

setOnhandQty(BigDecimal) - Method in class bb.common.OnLoanItemListResult

setOnHandQty(BigDecimal) - Method in class bb.common.PurchaseOrderItemListResult

setOnhandQty(BigDecimal) - Method in class bb.common.PurchaseOrderOpenDueListResult

setOnhandQty(BigDecimal) - Method in class bb.common.QuoteItemListResult

setOnhandQty(BigDecimal) - Method in class bb.common.RMAItemListResult

setOnhandQty(BigDecimal) - Method in class bb.common.RRMAItemListResult

setOnHandQty(BigDecimal) - Method in class bb.common.SalesOrderItemListResult

setOnHandQuantity(BigDecimal) - Method in class bb.common.PartOnhandVO

setOnHandQuantity(BigDecimal) - Method in class bb.common.ToolOnhandVO

setOnhandTotal(BigDecimal) - Method in class bb.common.PartOnHandAuditResult

setOnLoan(BigDecimal) - Method in class bb.common.InventoryListResult

setOnLoan(BigDecimal) - Method in class bb.common.PartOnhandResult

setOnLoanDocuments(Set) - Method in class bb.common.OnLoanVO

setOnLoanItemReferenceDocOne(OnLoanItemPK, String) - Method in interface bb.common.box.WarehouseBox

setOnLoanItemReferenceDocTwo(OnLoanItemPK, String) - Method in interface bb.common.box.WarehouseBox

setOnLoanItems(Set) - Method in class bb.common.OnLoanVO

setOnloanNumber(String) - Method in class bb.common.OnloanDocumentVO

setOnloanQty(BigDecimal) - Method in class bb.common.HistoricalInventoryVO

setOnloanQty(BigDecimal) - Method in class bb.common.PartInventoryVO

setOnLoanQty(BigDecimal) - Method in class bb.common.PartWithOnLoanQtyListResult

setOnloanQty(BigDecimal) - Method in class bb.common.PhysicalInventoryVO

setOnloanQty(BigDecimal) - Method in class bb.common.ToolInventoryVO

setOnloanShipperItems(Set) - Method in class bb.common.OnloanShipperVO

setOnorder(BigDecimal) - Method in class bb.common.BB2PartInfo

setOnorder(BigDecimal) - Method in class bb.common.BB2PartOnDemandListResult

setOnorder(BigDecimal) - Method in class bb.common.BillItemOnHandUsageResult

setOnorder(BigDecimal) - Method in class bb.common.BillItemOnHandWithPartInfoResult

setOnorder(BigDecimal) - Method in class bb.common.BillOnHandWithPartInfoResult

setOnorder(BigDecimal) - Method in class bb.common.BillWhereUsedResult

setOnOrder(BigDecimal) - Method in class bb.common.BOMCanAssyListResult

setOnorder(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemPartDetailItemResult

setOnorder(BigDecimal) - Method in class bb.common.EcnPOOrderResult

setOnorder(BigDecimal) - Method in class bb.common.EcnWOOrderResult

setOnOrder(BigDecimal) - Method in class bb.common.InventoryListResult

setOnorder(BigDecimal) - Method in class bb.common.PartOnHandWithMfgInfoResult

setOnOrder(BigDecimal) - Method in class bb.common.PartWhereUsedItemResult

setOnOrder(BigDecimal) - Method in class bb.common.PartWithExcessiveInventoryListResult

setOnorder(BigDecimal) - Method in class bb.common.PartWithInventoryInfoListResult

setOnOrder(BigDecimal) - Method in class bb.common.SalesOrderItemGroupByPartListResult

setOnorder(BigDecimal) - Method in class bb.common.StockTransactionPartInfoResult

setOnorder(BigDecimal) - Method in class bb.common.WOItemPartDetailNotIssue

setOnorder(BigDecimal) - Method in class bb.common.WorkOrderItemPartDetailItemResult

setOnorderAction(String) - Method in class bb.common.EngineeringChangeVO

setOnorderByAvgCost(BigDecimal) - Method in class bb.common.InventoryTotalResult

setOnorderByStdCost(BigDecimal) - Method in class bb.common.InventoryTotalResult

setOnorderModify(String) - Method in class bb.common.EngineeringChangeVO

setOnOrderQty(BigDecimal) - Method in class bb.common.BB2PartInventoryResult

setOnorderQty(BigDecimal) - Method in class bb.common.CRTVItemListResult

setOnOrderQty(BigDecimal) - Method in class bb.common.HistoricalInventoryVO

setOnorderQty(BigDecimal) - Method in class bb.common.OnLoanItemListResult

setOnOrderQty(BigDecimal) - Method in class bb.common.PartInventoryVO

setOnOrderQty(BigDecimal) - Method in class bb.common.PartOnHandWithPartBasicInfoResult

setOnOrderQty(BigDecimal) - Method in class bb.common.PurchaseOrderItemListResult

setOnOrderQty(BigDecimal) - Method in class bb.common.PurchaseOrderOpenDueListResult

setOnorderQty(BigDecimal) - Method in class bb.common.QuoteItemListResult

setOnorderQty(BigDecimal) - Method in class bb.common.RMAItemListResult

setOnorderQty(BigDecimal) - Method in class bb.common.RRMAItemListResult

setOnOrderQty(BigDecimal) - Method in class bb.common.SalesOrderItemListResult

setOnOrderQty(BigDecimal) - Method in class bb.common.ToolInventoryVO

setOnorderScrap(String) - Method in class bb.common.EngineeringChangeVO

setOnorderUseAsIs(String) - Method in class bb.common.EngineeringChangeVO

setOnTimeDelivedItemCount(BigDecimal) - Method in class bb.common.OntimeDeliveryRateListResult

setOnTimeDelivedItemCount(BigDecimal) - Method in class bb.common.OntimeDeliveryRateResult

setOnTimeDeliveryRate(BigDecimal) - Method in class bb.common.OntimeDeliveryRateListResult

setOnTimeDeliveryRate(BigDecimal) - Method in class bb.common.OntimeDeliveryRateResult

setOntimeReceiverItemsof12MonthAvg(Integer) - Method in class bb.common.PurchaseOrderOnTimeResult

setOntimeReceiverItemsofFiscalYear(Integer) - Method in class bb.common.PurchaseOrderOnTimeResult

setOntimeReceiverItemsofLastMonth(Integer) - Method in class bb.common.PurchaseOrderOnTimeResult

setOntimeReceiverItemsofThisMonth(Integer) - Method in class bb.common.PurchaseOrderOnTimeResult

setOntimeReceiverItemsofYtd(Integer) - Method in class bb.common.PurchaseOrderOnTimeResult

setOntimeReceiverTotalOf12MonthAvg(BigDecimal) - Method in class bb.common.PurchaseOrderOnTimeResult

setOntimeReceiverTotalOfFiscalYear(BigDecimal) - Method in class bb.common.PurchaseOrderOnTimeResult

setOntimeReceiverTotalOfLastMonth(BigDecimal) - Method in class bb.common.PurchaseOrderOnTimeResult

setOntimeReceiverTotalOfThisMonth(BigDecimal) - Method in class bb.common.PurchaseOrderOnTimeResult

setOntimeReceiverTotalOfYtd(BigDecimal) - Method in class bb.common.PurchaseOrderOnTimeResult

setOpCodeShortcutPK(OpCodeShortcutPK) - Method in class bb.common.OpCodeShortcutVO

setOpenDate(Date) - Method in class bb.common.CustomerServiceIncidentItemListResult

setOpenDate(Date) - Method in class bb.common.CustomerServiceIncidentListResult

setOpenDate(Date) - Method in class bb.common.CustomerServiceIncidentVO

setOpenDate(Date) - Method in class bb.common.DesignControlInfoVO

setOpenDate(Date) - Method in class bb.common.DesignControlListResult

setOpenDate(Date) - Method in class bb.common.DesignControlVO

setOpenEcnCount(Integer) - Method in class bb.common.EngineeringInfoCenterResult

setOpenEcrCount(Integer) - Method in class bb.common.EngineeringInfoCenterResult

setOpenEdcCount(Integer) - Method in class bb.common.EngineeringInfoCenterResult

setOpenNcrCount(Integer) - Method in class bb.common.QualityInfoCenterResult

setOpenPo(Map<String, BigDecimal>) - Method in class bb.common.CashFlowByMonthReportResult

setOpenPos(TreeMap) - Method in class bb.common.TwelveMonthCashFlowReportResult

setOpenPurchaseAccount(BigDecimal) - Method in class bb.common.PurchasingInfoCenterResult

setOpenSalesAccount(BigDecimal) - Method in class bb.common.SalesInfoCenterResult

setOpenSo(Map<String, BigDecimal>) - Method in class bb.common.CashFlowByMonthReportResult

setOpenSo(TreeMap) - Method in class bb.common.TwelveMonthCashFlowReportResult

setOpenSoSum(SalesInfoCenter.OpenSoSum) - Method in class bb.common.SalesInfoCenter

setOpenTotal(BigDecimal) - Method in class bb.common.AccountingTotalMoneyResult

setOpenTotal(BigDecimal) - Method in class bb.common.DuePATotalByVendorResult

setOpenWOAccount(BigDecimal) - Method in class bb.common.WorkOrderInfoCenterResult

setOpenWOCount(Integer) - Method in class bb.common.WorkOrderInfoCenterResult

setOperateCode(String) - Method in class bb.common.OpCodeShortcutPK

setOperatingEnvironment(boolean) - Method in class bb.common.InspectionReportInfoVO

setOperatingEnvironment(boolean) - Method in class bb.common.InspectionReportVO

setOperatingEnvironment(boolean) - Method in class bb.common.OperatingInstructionsVO

setOperatingExpenseItems(List) - Method in class bb.common.ClosingStatementResult

setOperatingExpenses(ClosingStatementTotalResult) - Method in class bb.common.ClosingStatementResult

setOperatingInstructionsDescription(String) - Method in class bb.common.OperatingInstructionsUserStatisticalResult

setOperatingInstructionsDescription(String) - Method in class bb.common.OperatingInstructionsVO

setOperatingInstructionsInspectMethod(InspectionReportInspectMethodVO) - Method in class bb.common.OperatingInstructionsInspectMethodItemVO

setOperatingInstructionsInspectMethodItems(Set<OperatingInstructionsInspectMethodItemVO>) - Method in class bb.common.OperatingInstructionsVO

setOperatingInstructionsInspectResultItems(Set<OperatingInstructionsInspectResultItemVO>) - Method in class bb.common.OperatingInstructionsVO

setOperatingInstructionsInspectStandard(OperatingInstructionsInspectStandardVO) - Method in class bb.common.OperatingInstructionsInspectStandardItemVO

setOperatingInstructionsInspectStandardItems(Set<OperatingInstructionsInspectStandardItemVO>) - Method in class bb.common.OperatingInstructionsVO

setOperatingInstructionsManual(OperatingInstructionsManualVO) - Method in class bb.common.OperatingInstructionsManualItemVO

setOperatingInstructionsManuals(Set<OperatingInstructionsManualItemVO>) - Method in class bb.common.OperatingInstructionsVO

setOperatingInstructionsNotes(String) - Method in class bb.common.OperatingInstructionsVO

setOperatingInstructionsNumber(String) - Method in class bb.common.InspectionReportInfoVO

setOperatingInstructionsNumber(String) - Method in class bb.common.InspectionReportVO

setOperatingInstructionsNumber(String) - Method in class bb.common.OperatingInstructionsInspectMethodItemPK

setOperatingInstructionsNumber(String) - Method in class bb.common.OperatingInstructionsInspectResultItemPK

setOperatingInstructionsNumber(String) - Method in class bb.common.OperatingInstructionsInspectStandardItemPK

setOperatingInstructionsNumber(String) - Method in class bb.common.OperatingInstructionsManualItemPK

setOperatingInstructionsNumber(String) - Method in class bb.common.OperatingInstructionsUserStatisticalResult

setOperatingInstructionsNumber(String) - Method in class bb.common.OperatingInstructionsVO

setOperatingInstructionsNumber(String) - Method in class bb.common.OperatingOutputFileItemPK

setOperatingInstructionsType(OperatingInstructionsTypeVO) - Method in class bb.common.InspectionReportInfoVO

setOperatingInstructionsType(OperatingInstructionsTypeVO) - Method in class bb.common.InspectionReportVO

setOperatingInstructionsType(OperatingInstructionsTypeVO) - Method in class bb.common.OperatingInstructionsVO

setOperatingInstructionsTypeDescription(String) - Method in class bb.common.OperatingInstructionsUserStatisticalResult

setOperatingInstructionsTypeId(Integer) - Method in class bb.common.InspectionItemPK

setOperatingInstructionsTypeId(Integer) - Method in class bb.common.InspectionReportInfoVO

setOperatingInstructionsTypeId(Integer) - Method in class bb.common.InspectionReportVO

setOperatingInstructionsTypeId(Integer) - Method in class bb.common.OperatingInstructionsVO

setOperatingOutputFiles(Set<OperatingOutputFileItemVO>) - Method in class bb.common.OperatingInstructionsVO

setOperatingOutputFileType(OperatingOutputFileTypeVO) - Method in class bb.common.OperatingOutputFileItemVO

setOperatingProcessNotes(String) - Method in class bb.common.OperatingInstructionsVO

setOperatingProcessRecord(String) - Method in class bb.common.OperatingInstructionsVO

setOperationType(int) - Method in class bb.common.LogTrackingVO

setOperator(String) - Method in class bb.common.DisassembleWorkOrderIssueVO

setOperator(String) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setOperator(String) - Method in class bb.common.NonproductivePickingItemIssuedVO

setOperator(String) - Method in class bb.common.PartIssuedVO

setOperator(String) - Method in class bb.common.PartReceivedVO

setOperator(String) - Method in class bb.common.WorkOrderIssuedOrderListResult

setOpinion(String) - Method in class bb.common.SalesOrderVO

setOptWho(String) - Method in class bb.common.EngineeringSharingItemVO

setOrderApproval(OrderApprovalVO) - Method in class bb.common.OrderApprovalItemsVO

setOrderApprovalID(Long) - Method in class bb.common.OrderApprovalItemsVO

setOrderBy(String) - Method in class bb.common.DynamicSearchFilter

setOrderBy(LinkedHashMap) - Method in class bb.common.OrderBy

setOrderBy(String) - Method in class bb.common.PurchaseWorkSheetVO

setOrderBy(OrderBy) - Method in class bb.common.ServerAction

setOrderBy(String) - Method in class bb.common.TakeCycleCountAgent

setOrderDate(Date) - Method in class bb.common.DisassembleWorkOrderReceivingResult

setOrderDate(Date) - Method in class bb.common.IssuingResult

setOrderedQty(BigDecimal) - Method in class bb.common.CRTVItemListResult

setOrderedQty(BigDecimal) - Method in class bb.common.QuoteItemListResult

setOrderedQty(BigDecimal) - Method in class bb.common.RMAItemListResult

setOrderedQty(BigDecimal) - Method in class bb.common.RRMAItemListResult

setOrderedQty(BigDecimal) - Method in class bb.common.SalesOrderItemListResult

setOrderItemNumber(String) - Method in class bb.common.LogMiscDocumentVO

setOrderItemNumber(String) - Method in class bb.common.MiscDocAgent

setOrderItemNumber(String) - Method in class bb.common.ReceiverItemAgent

setOrderItemNumber(String) - Method in class bb.common.ReceivingItemResult

setOrderNumber(String) - Method in class bb.common.BB2Notice

setOrderNumber(String) - Method in class bb.common.DebitsCreditsResult

setOrderNumber(Long) - Method in class bb.common.DisassembleWorkOrderIssueVO

setOrderNumber(String) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setOrderNumber(String) - Method in class bb.common.DisassembleWorkOrderIssuingResult

setOrderNumber(String) - Method in class bb.common.DisassembleWorkOrderReceivingResult

setOrderNumber(String) - Method in class bb.common.InventoryPartInOutDetailListResult

setOrderNumber(String) - Method in class bb.common.IssuedFromOrderItem

setOrderNumber(String) - Method in class bb.common.IssueItemDetailAgent

setOrderNumber(String) - Method in class bb.common.IssuingResult

setOrderNumber(String) - Method in class bb.common.LogMiscDocumentVO

setOrderNumber(String) - Method in class bb.common.MiscDocAgent

setOrderNumber(String) - Method in class bb.common.MyPrintListPK

setOrderNumber(Integer) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setOrderNumber(Integer) - Method in class bb.common.NonproductivePickingItemIssuedVO

setOrderNumber(String) - Method in class bb.common.OrderApprovalVO

setOrderNumber(String) - Method in class bb.common.OrderBoilerplatePK

setOrderNumber(String) - Method in class bb.common.OrderDemandForReceiverResult

setOrderNumber(String) - Method in class bb.common.OrderDocumentVO

setOrderNumber(String) - Method in class bb.common.OrderPK

setOrderNumber(Integer) - Method in class bb.common.PartIssuedVO

setOrderNumber(Integer) - Method in class bb.common.PartReceivedVO

setOrderNumber(String) - Method in class bb.common.PrepayAgent

setOrderNumber(String) - Method in class bb.common.ReceiverAgent

setOrderNumber(String) - Method in class bb.common.ReceiverItemAgent

setOrderNumber(String) - Method in class bb.common.ReceiverShipAgent

setOrderNumber(String) - Method in class bb.common.ReceivingItemResult

setOrderNumber(String) - Method in class bb.common.ReceivingResult

setOrderNumber(String) - Method in class bb.common.RefdocElement

setOrderNumber(String) - Method in class bb.common.ShipperAgent

setOrderNumber(String) - Method in class bb.common.ShippingItemResult

setOrderNumber(String) - Method in class bb.common.ShippingResult

setOrderNumber(String) - Method in class bb.common.WorkOrderIssuedOrderListResult

setOrderNumber(String) - Method in class bb.common.ZipcodeTotalsResult

setOrderNumLike(String) - Method in class bb.common.AccountAuditAgent

setOrderPk(OrderPK) - Method in class bb.common.IssueItemAgent

setOrderQty(BigDecimal) - Method in class bb.common.MasterWorkOrderTreeItemResult

setOrderQty(BigDecimal) - Method in class bb.common.MrpByMonthResult

setOrderQty(BigDecimal) - Method in class bb.common.PurchaseOrderItemListResult

setOrderRelatedDoc(String) - Method in class bb.common.DisassembleWorkOrderItemListResult

setOrderRelatedDoc(String) - Method in class bb.common.WorkOrderItemListResult

setOrderStatus(String) - Method in class bb.common.DisassembleWorkOrderReceivingResult

setOrderStatus(String) - Method in class bb.common.IssuingResult

setOrderType(String) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setOrderType(String) - Method in class bb.common.NonproductivePickingItemResult

setOrderType(String) - Method in class bb.common.NonproductivePickingVO

setOrderType(String) - Method in class bb.common.OrderApprovalVO

setOrderType(String) - Method in class bb.common.TermsConditionVO

setOrderUsageQty(BigDecimal) - Method in class bb.common.MrpByMonthResult

setOrgAuditExchange(BigDecimal) - Method in class bb.common.CurrencyExchangeVO

setOrgBalance(BigDecimal) - Method in class bb.common.ExchangeAuditItemResult

setOrgCredit(BigDecimal) - Method in class bb.common.ExchangeAuditItemResult

setOrgCreditAccountBalance(Map<CompanyUnitAccountPK, BigDecimal>) - Method in class bb.common.AccountBalanceAgent

setOrgCreditBalance(BigDecimal) - Method in class bb.common.MonthBalanceResult

setOrgDebit(BigDecimal) - Method in class bb.common.ExchangeAuditItemResult

setOrgDebitAccountBalance(Map<CompanyUnitAccountPK, BigDecimal>) - Method in class bb.common.AccountBalanceAgent

setOrgDebitBalance(BigDecimal) - Method in class bb.common.MonthBalanceResult

setOrigialShipDate(Date) - Method in class bb.common.POReceiverItemListResult

setOrigin(String) - Method in class bb.common.AccountPayableCheckVO

setOrigin(String) - Method in class bb.common.AccountReceivablePaymentVO

setOrigin(String) - Method in class bb.common.AccountsChartMappingVO

setOrigin(String) - Method in class bb.common.AccountsChartVO

setOrigin(String) - Method in class bb.common.AccountsPayableInfoVO

setOrigin(String) - Method in class bb.common.AccountsPayableVO

setOrigin(String) - Method in class bb.common.AccountsReceivableInfoVO

setOrigin(String) - Method in class bb.common.AccountsReceivableVO

setOrigin(String) - Method in class bb.common.AssetVO

setOrigin(String) - Method in class bb.common.BillVO

setOrigin(String) - Method in class bb.common.CommonPrintTemplateVO

setOrigin(String) - Method in class bb.common.ContractPriceVO

setOrigin(String) - Method in class bb.common.CorrectiveActionRequestVO

setOrigin(String) - Method in class bb.common.CustomerReturnToVendorVO

setOrigin(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setOrigin(String) - Method in class bb.common.CustomerVendorAddressVO

setOrigin(String) - Method in class bb.common.DesignControlInfoVO

setOrigin(String) - Method in class bb.common.DesignControlVO

setOrigin(String) - Method in class bb.common.DisassembleWorkOrderVO

setOrigin(String) - Method in class bb.common.EngineeringChangeVO

setOrigin(String) - Method in class bb.common.GeneralLedgerPrintResult

setOrigin(String) - Method in class bb.common.GeneralLedgerVO

setOrigin(String) - Method in class bb.common.GLApprovalListResult

setOrigin(String) - Method in class bb.common.InspectionConformanceReportVO

setOrigin(String) - Method in class bb.common.InspectionReportInfoVO

setOrigin(String) - Method in class bb.common.InspectionReportVO

setOrigin(String) - Method in class bb.common.LabelTemplateVO

setOrigin(String) - Method in class bb.common.ManufacturerAddressInfoVO

setOrigin(String) - Method in class bb.common.ManufacturerAddressVO

setOrigin(String) - Method in class bb.common.NonConformanceCodeVO

setOrigin(String) - Method in class bb.common.NonConformanceReportVO

setOrigin(String) - Method in class bb.common.NonproductivePickingVO

setOrigin(String) - Method in class bb.common.OnloanReceiverVO

setOrigin(String) - Method in class bb.common.OnloanShipperVO

setOrigin(String) - Method in class bb.common.OnLoanVO

setOrigin(String) - Method in class bb.common.OperatingInstructionsVO

setOrigin(String) - Method in class bb.common.PartBasicInfo

setOrigin(String) - Method in class bb.common.PartVO

setOrigin(String) - Method in class bb.common.PartWithOnhandsVO

setOrigin(String) - Method in class bb.common.PfReceiverVO

setOrigin(String) - Method in class bb.common.POSurveyReportVO

setOrigin(String) - Method in class bb.common.PreventiveActionRequestVO

setOrigin(String) - Method in class bb.common.PrintTemplateVO

setOrigin(String) - Method in class bb.common.ProformaInvoiceVO

setOrigin(String) - Method in class bb.common.PurchaseOrderVO

setOrigin(String) - Method in class bb.common.QuoteVO

setOrigin(String) - Method in class bb.common.ReceiverInfoVO

setOrigin(String) - Method in class bb.common.ReceiverVO

setOrigin(String) - Method in class bb.common.RequestForRMAVO

setOrigin(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setOrigin(String) - Method in class bb.common.ReturnToVendorVO

setOrigin(String) - Method in class bb.common.RMAReceiverVO

setOrigin(String) - Method in class bb.common.RtvShipperInfoVO

setOrigin(String) - Method in class bb.common.RtvShipperVO

setOrigin(String) - Method in class bb.common.SalesOrderVO

setOrigin(String) - Method in class bb.common.ShipperInfoVO

setOrigin(String) - Method in class bb.common.ShipperVO

setOrigin(String) - Method in class bb.common.SwapOrderListResult

setOrigin(String) - Method in class bb.common.SwapOrderVO

setOrigin(String) - Method in class bb.common.SwapReceiverListResult

setOrigin(String) - Method in class bb.common.SwapReceiverVO

setOrigin(String) - Method in class bb.common.SwapShipperListResult

setOrigin(String) - Method in class bb.common.SwapShipperVO

setOrigin(String) - Method in class bb.common.ToolListVO

setOrigin(String) - Method in class bb.common.ToolVO

setOrigin(String) - Method in class bb.common.ToolWithOnhandsVO

setOrigin(String) - Method in class bb.common.TransferOrderListResult

setOrigin(String) - Method in class bb.common.TransferOrderVO

setOrigin(String) - Method in class bb.common.TransferReceiverListResult

setOrigin(String) - Method in class bb.common.TransferReceiverVO

setOrigin(String) - Method in class bb.common.TransferShipperListResult

setOrigin(String) - Method in class bb.common.TransferShipperVO

setOrigin(String) - Method in class bb.common.VendorContractPriceVO

setOrigin(String) - Method in class bb.common.WarehouseVO

setOrigin(String) - Method in class bb.common.WorkCenterVO

setOrigin(String) - Method in class bb.common.WorkInstructionRequestForChangeVO

setOrigin(String) - Method in class bb.common.WorkOrderVO

setOriginal(Date) - Method in class bb.common.CustomerReturnToVendorItemVO

setOriginal(Date) - Method in class bb.common.CustomerReturnToVendorVO

setOriginal(Date) - Method in class bb.common.DisassembleWorkOrderItemVO

setOriginal(Date) - Method in class bb.common.DisassembleWorkOrderVO

setOriginal(Date) - Method in class bb.common.NonproductivePickingItemVO

setOriginal(Date) - Method in class bb.common.OnLoanItemVO

setOriginal(Date) - Method in class bb.common.OnLoanVO

setOriginal(Date) - Method in class bb.common.OrderApprovalItemsVO

setOriginal(Date) - Method in class bb.common.PurchaseOrderItemVO

setOriginal(Date) - Method in class bb.common.PurchaseOrderVO

setOriginal(String) - Method in class bb.common.QuoteItemVO

setOriginal(String) - Method in class bb.common.QuoteVO

setOriginal(Date) - Method in class bb.common.RequestForQuoteItemVO

setOriginal(Date) - Method in class bb.common.RequestForQuoteVO

setOriginal(Date) - Method in class bb.common.RequestForRMAItemVO

setOriginal(Date) - Method in class bb.common.RequestForRMAVO

setOriginal(Date) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setOriginal(Date) - Method in class bb.common.ReturnMaterialAuthorizationVO

setOriginal(Date) - Method in class bb.common.ReturnToVendorItemVO

setOriginal(Date) - Method in class bb.common.ReturnToVendorVO

setOriginal(Date) - Method in class bb.common.SalesOrderItemInfoVO

setOriginal(Date) - Method in class bb.common.SalesOrderItemVO

setOriginal(Date) - Method in class bb.common.SalesOrderShipDateListResult

setOriginal(Date) - Method in class bb.common.SalesOrderVO

setOriginal(Date) - Method in class bb.common.WorkOrderItemPartDetail

setOriginal(Date) - Method in class bb.common.WorkOrderItemVO

setOriginal(Date) - Method in class bb.common.WorkOrderVO

setOriginalAvgCost(BigDecimal) - Method in class bb.common.OrderApprovalItemsVO

setOriginalBalance(BigDecimal) - Method in class bb.common.JounalEntryListResult

setOriginalCost(BigDecimal) - Method in class bb.common.CustomAssetVO

setOriginalCost(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemVO

setOriginalCost(BigDecimal) - Method in class bb.common.EquipmentVO

setOriginalCost(BigDecimal) - Method in class bb.common.WorkOrderItemReviewCostResult

setOriginalCost(BigDecimal) - Method in class bb.common.WorkOrderItemVO

setOriginalCredit(BigDecimal) - Method in class bb.common.AccountCreditVO

setOriginalCredit(BigDecimal) - Method in class bb.common.GeneralLedgerEntry

setOriginalCredit(BigDecimal) - Method in class bb.common.GLItemVO

setOriginalCreditAmount(BigDecimal) - Method in class bb.common.JounalEntryListResult

setOriginalDate(Date) - Method in class bb.common.PO2POAgent

setOriginalDate(Date) - Method in class bb.common.SO2SOAgent

setOriginalDebit(BigDecimal) - Method in class bb.common.AccountDebitVO

setOriginalDebit(BigDecimal) - Method in class bb.common.GeneralLedgerEntry

setOriginalDebit(BigDecimal) - Method in class bb.common.GLItemVO

setOriginalDebitAmount(BigDecimal) - Method in class bb.common.JounalEntryListResult

setOriginalDelivery(Date) - Method in class bb.common.SalesOrderItemListResult

setOriginalDiscount(BigDecimal) - Method in class bb.common.OrderApprovalItemsVO

setOriginalEndDate(Date) - Method in class bb.common.OrderApprovalItemsVO

setOriginalExtendPrice(BigDecimal) - Method in class bb.common.OrderApprovalItemsVO

setOriginalIcrRequiredWhenReceiverNa(boolean) - Method in class bb.common.OrderApprovalItemsVO

setOriginalInvoice(String) - Method in class bb.common.CustomerServiceIncidentItemListResult

setOriginalInvoice(String) - Method in class bb.common.CustomerServiceIncidentVO

setOriginalInvoiceNumber(String) - Method in class bb.common.CustomerFeedbackVO

setOriginalNumber(String) - Method in class bb.common.RunningAccountOrderVO

setOriginalOrderItem(String) - Method in class bb.common.OrderApprovalItemsVO

setOriginalPartDesc(String) - Method in class bb.common.OrderApprovalItemsVO

setOriginalPartNumber(String) - Method in class bb.common.OrderApprovalItemsVO

setOriginalPartType(String) - Method in class bb.common.OrderApprovalItemsVO

setOriginalPoQty(BigDecimal) - Method in class bb.common.OrderApprovalItemsVO

setOriginalPosition(String) - Method in class bb.common.CustomEmployeeVO

setOriginalQty(BigDecimal) - Method in class bb.common.OrderApprovalItemsVO

setOriginalSalesOrderNumber(String) - Method in class bb.common.CustomerFeedbackVO

setOriginalSalesOrderNumber(String) - Method in class bb.common.CustomerServiceIncidentItemListResult

setOriginalSalesOrderNumber(String) - Method in class bb.common.CustomerServiceIncidentVO

setOriginalShipperNumber(String) - Method in class bb.common.CustomerServiceIncidentItemListResult

setOriginalShipperNumber(String) - Method in class bb.common.CustomerServiceIncidentVO

setOriginalStartDate(Date) - Method in class bb.common.OrderApprovalItemsVO

setOriginalStatus(String) - Method in class bb.common.OrderApprovalItemsVO

setOriginalStdCost(BigDecimal) - Method in class bb.common.OrderApprovalItemsVO

setOriginalTaxRate(BigDecimal) - Method in class bb.common.OrderApprovalItemsVO

setOriginalTranslation(String) - Method in class bb.common.CustomTranslationVO

setOriginalUserName(String) - Method in class bb.common.User2UserAgent

setOriginalWorkOrderNumber(String) - Method in class bb.common.CustomerFeedbackVO

setOriginalWorkOrderNumber(String) - Method in class bb.common.CustomerServiceIncidentItemListResult

setOriginalWorkOrderNumber(String) - Method in class bb.common.CustomerServiceIncidentVO

setOriginatedDate(Date) - Method in class bb.common.WorkInstructionRequestForChangeVO

setOriginator(String) - Method in class bb.common.DisassembleWorkOrderItemListResult

setOriginator(String) - Method in class bb.common.DisassembleWorkOrderListResult

setOriginator(String) - Method in class bb.common.DisassembleWorkOrderVO

setOriginator(String) - Method in class bb.common.EngineeringChangeListResult

setOriginator(String) - Method in class bb.common.EngineeringChangeRequestListResult

setOriginator(String) - Method in class bb.common.EngineeringChangeRequestVO

setOriginator(String) - Method in class bb.common.EngineeringChangeVO

setOriginator(String) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setOriginator(String) - Method in class bb.common.WorkInstructionRequestForChangeVO

setOriginator(String) - Method in class bb.common.WorkOrderCheckListResult

setOriginator(String) - Method in class bb.common.WorkOrderItemInWipListResult

setOriginator(String) - Method in class bb.common.WorkOrderItemListResult

setOriginator(String) - Method in class bb.common.WorkOrderListResult

setOriginator(String) - Method in class bb.common.WorkOrderVO

setOrphan(boolean) - Method in class bb.common.MasterWorkOrderTreeItemResult

setOrphanedSoOnDemandList(ArrayList) - Method in class bb.common.MrpItemOrderDemandRecordsResult

setOrphanedSoOnDemandList(ArrayList) - Method in class bb.common.MrpItemResult

setOrphanedWoOnDemandList(ArrayList) - Method in class bb.common.MrpItemOrderDemandRecordsResult

setOrphanedWoOnDemandList(ArrayList) - Method in class bb.common.MrpItemResult

setOsType(String) - Method in class bb.common.BizboxBugInfoVO

setOsType(String) - Method in class bb.common.BizboxBugVO

setOtherAssets(List) - Method in class bb.common.BalanceSheetSideBySideResult

setOtherAssets(List) - Method in class bb.common.ClosingStatementResult

setOtherCurrentAssets(BigDecimal) - Method in class bb.common.AccountingBalanceSheetResult

setOtherExpenseItemsItems(List) - Method in class bb.common.ClosingStatementResult

setOtherExpenses(ClosingStatementTotalResult) - Method in class bb.common.ClosingStatementResult

setOtherIncome(ClosingStatementTotalResult) - Method in class bb.common.ClosingStatementResult

setOtherIncome(List) - Method in class bb.common.ProfitLossStatementResult

setOtherLiabilities(List) - Method in class bb.common.ClosingStatementResult

setOtherLiability(List) - Method in class bb.common.BalanceSheetSideBySideResult

setOthersLocations(Set) - Method in class bb.common.IssuingItemResult

setOthersLocations(Set) - Method in class bb.common.ShippingItemResult

setOtran(String) - Method in class bb.common.AccountsReceivableInfoVO

setOtran(String) - Method in class bb.common.AccountsReceivableVO

setOTran(String) - Method in class bb.common.OnloanShipperVO

setOtran(String) - Method in class bb.common.ProformaInvoiceVO

setOtran(String) - Method in class bb.common.RtvShipperInfoVO

setOtran(String) - Method in class bb.common.RtvShipperVO

setOTran(String) - Method in class bb.common.ShipperInfoVO

setOTran(String) - Method in class bb.common.ShipperVO

setOurPO(String) - Method in class bb.common.GeneralLedgerResult

setOurPoNumber(String) - Method in class bb.common.APItemListResult

setOurPoNumber(String) - Method in class bb.common.VendorPrepayStatementListResult

setOurPoNumber(String) - Method in class bb.common.VendorStatementListResult

setOurRefQuote(String) - Method in class bb.common.QuoteListResult

setOutAmount(BigDecimal) - Method in class bb.common.InventoryMonthReport

setOutCost(BigDecimal) - Method in class bb.common.InventoryMonthReport

setOutCost(BigDecimal) - Method in class bb.common.LogInventoryListResult

setOutCost(BigDecimal) - Method in class bb.common.LogInventoryVO

setOuterDiameter(BigDecimal) - Method in class bb.common.PartMaterialListResult

setOuterDiameter(BigDecimal) - Method in class bb.common.PartMaterialReportAgent

setOuterDiameter(BigDecimal) - Method in class bb.common.PartMaterialVO

setOuterDiameter(BigDecimal) - Method in class bb.common.PartMaterialWhereUsedItemResult

setOuterDiameterUnit(String) - Method in class bb.common.PartMaterialListResult

setOuterDiameterUnit(String) - Method in class bb.common.PartMaterialVO

setOuterDiameterUnit(String) - Method in class bb.common.PartMaterialWhereUsedItemResult

setOuterUnit(String) - Method in class bb.common.PartMaterialReportAgent

setOutQty(BigDecimal) - Method in class bb.common.InventoryMonthReport

setOutQty(BigDecimal) - Method in class bb.common.InventoryPartInOutDetailListResult

setOutQty(BigDecimal) - Method in class bb.common.LogInventoryListResult

setOutQty(BigDecimal) - Method in class bb.common.LogInventoryVO

setOutQty(BigDecimal) - Method in class bb.common.LogTrackingVO

setOutSourcing(String) - Method in class bb.common.WorkInstructionSequenceVO

setOutSourcing(String) - Method in class bb.common.WorkOrderItemSeqWCLoadResult

setOutSourcing(String) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setOutterOperator(String) - Method in class bb.common.PartMaterialReportAgent

setOutTotalCost(BigDecimal) - Method in class bb.common.InventoryPartInOutDetailListResult

setOverageAmount(BigDecimal) - Method in class bb.common.InventoryMonthReport

setOverageAmount(BigDecimal) - Method in class bb.common.InventoryPartInOutDetailListResult

setOverageQty(BigDecimal) - Method in class bb.common.InventoryMonthReport

setOverageQty(BigDecimal) - Method in class bb.common.InventoryPartInOutDetailListResult

setOverageQty(BigDecimal) - Method in class bb.common.PhysicalInventoryListWithAppDataResult

setOverageTotal(BigDecimal) - Method in class bb.common.PhysicalInventoryListWithAppDataResult

setOverCarryPL(boolean) - Method in class bb.common.GeneralLedgerVO

setOverdueDate(Date) - Method in class bb.common.PartVendorVO

setOverdueDate(Date) - Method in class bb.common.ToolVendorVO

setOverdueList(List<String>) - Method in class bb.common.ApprovedGLResult

setOverPercent(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemVO

setOverPercent(BigDecimal) - Method in class bb.common.WorkOrderItemReviewCostResult

setOverPercent(BigDecimal) - Method in class bb.common.WorkOrderItemVO

setOverview(String) - Method in class bb.common.SGDocPartVO

setOverview(boolean) - Method in class bb.common.SGPartDocFlagResult

setOverviewRev(String) - Method in class bb.common.SGDocPartVO

setOwner(String) - Method in class bb.common.PartClassVO

setOwner(String) - Method in class bb.common.PartExportInfo

setOwner(String) - Method in class bb.common.PartVO

setOwner(String) - Method in class bb.common.PartWithOnhandsVO

setOwner(String) - Method in class bb.common.ServerClientPropertyPK

setOwner(String) - Method in class bb.common.ToolVO

setOwner(String) - Method in class bb.common.ToolWithOnhandsVO

setOwner(String) - Method in class bb.common.UserGroupVO

setOwnerName(String) - Method in class bb.common.ShipListAgent

setOwnerName(String) - Method in class bb.common.ShipListInfoVO

setOwnerName(String) - Method in class bb.common.ShipListOwnerAttributePK

setOwnerName(String) - Method in class bb.common.ShipListOwnerVO

setOwnerName(String) - Method in class bb.common.ShipListVO

setOwnersEquity(List) - Method in class bb.common.BalanceSheetSideBySideResult

setOwnershipPercent(float) - Method in class bb.common.SubcompanyVO

setPa(String) - Method in class bb.common.CompanyVO

setPackBoxItemPk(PackingBoxItemPK) - Method in class bb.common.BB2PartInSipItemResult

setPackBoxItemPk(PrPackingBoxItemPK) - Method in class bb.common.BB2PartInSitItemResult

setPackCondition(String) - Method in class bb.common.POSurveyReportItemVO

setPackingBoxes(Set) - Method in class bb.common.ProformaInvoiceVO

setPackingBoxItemPk(PackingBoxItemPK) - Method in class bb.common.PackingBoxItemListResult

setPackingBoxItems(Set) - Method in class bb.common.PackingBoxVO

setPackingBoxItems(Set) - Method in class bb.common.PrPackingBoxVO

setPackingBoxNumber(Integer) - Method in class bb.common.AddProformaReceiverItemAgent

setPackingBoxNumber(Integer) - Method in class bb.common.PackingBoxItemPK

setPackingBoxNumber(Integer) - Method in class bb.common.PackingBoxPK

setPackingBoxNumber(Integer) - Method in class bb.common.PrPackingBoxItemPK

setPackingBoxNumber(Integer) - Method in class bb.common.PrPackingBoxPK

setPackingBoxNumbers(int) - Method in class bb.common.PfReceiverVO

setPackingBoxNumbers(int) - Method in class bb.common.ProformaInvoiceVO

setPackingBoxPk(PackingBoxPK) - Method in class bb.common.PackingBoxSalesOrderItemAgent

setPageNumber(Integer) - Method in class bb.common.AddPhysicalInventoryAgent

setPageNumber(Integer) - Method in class bb.common.CycleCountPK

setPageNumber(Integer) - Method in class bb.common.PhysicalInventoryPK

setPaid(BigDecimal) - Method in class bb.common.AccountPayableCheckRunItemVO

setPaid(BigDecimal) - Method in class bb.common.AccountPayableCheckVO

setPaid(BigDecimal) - Method in class bb.common.AccountReceivablePaymentVO

setPaid(BigDecimal) - Method in class bb.common.AccountsPayableInfoVO

setPaid(BigDecimal) - Method in class bb.common.AccountsPayableItemVO

setPaid(BigDecimal) - Method in class bb.common.AccountsPayableVO

setPaid(BigDecimal) - Method in class bb.common.AccountsReceivableInfoVO

setPaid(BigDecimal) - Method in class bb.common.AccountsReceivableItemVO

setPaid(BigDecimal) - Method in class bb.common.AccountsReceivableVO

setPaid(BigDecimal) - Method in class bb.common.ARPaymentRunItemVO

setPaid(BigDecimal) - Method in class bb.common.GeneralLedgerByDateListResult

setPaid(BigDecimal) - Method in class bb.common.GeneralLedgerListResult

setPaid(BigDecimal) - Method in class bb.common.GeneralLedgerVO

setPaid(BigDecimal) - Method in class bb.common.OnloanReceiverItemVO

setPaid(BigDecimal) - Method in class bb.common.OnloanReceiverVO

setPaid(BigDecimal) - Method in class bb.common.OnloanShipperItemVO

setPaid(BigDecimal) - Method in class bb.common.OnloanShipperVO

setPaid(BigDecimal) - Method in class bb.common.ProformaInvoiceVO

setPaid(BigDecimal) - Method in class bb.common.ReceiverInfoVO

setPaid(BigDecimal) - Method in class bb.common.ReceiverItemVO

setPaid(BigDecimal) - Method in class bb.common.ReceiverVO

setPaid(BigDecimal) - Method in class bb.common.RMAReceiverItemVO

setPaid(BigDecimal) - Method in class bb.common.RMAReceiverVO

setPaid(BigDecimal) - Method in class bb.common.RtvShipperInfoVO

setPaid(BigDecimal) - Method in class bb.common.RtvShipperItemVO

setPaid(BigDecimal) - Method in class bb.common.RtvShipperVO

setPaid(BigDecimal) - Method in class bb.common.ShipperInfoVO

setPaid(BigDecimal) - Method in class bb.common.ShipperItemVO

setPaid(BigDecimal) - Method in class bb.common.ShipperVO

setPaid(BigDecimal) - Method in class bb.common.TempArApAgingVO

setPaidDate(Date) - Method in class bb.common.ArCommissionListResult

setPaidDate(Date) - Method in class bb.common.InvoiceItemListResult

setPaidExactly(String) - Method in class bb.common.AccountPayableCheckVO

setPaidExactly(String) - Method in class bb.common.AccountReceivablePaymentVO

setPaidToDate(BigDecimal) - Method in class bb.common.ARPaymentRunItemVO

setPaOffsetType(String) - Method in class bb.common.CompanyVO

setParameter(Object) - Method in exception bb.common.BB2ServerException

setParameter(Object) - Method in exception bb.common.BizException

setParams(String) - Method in class bb.common.BB2Task

setParams(String) - Method in class bb.common.TaskVO

setParent(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setParent(String) - Method in class bb.common.CustomerVendorAddressVO

setParent(BillPK) - Method in class bb.common.WorkOrderItemSetupItemAgent

setParentBill(BillVO, BillItemVO) - Method in interface bb.common.box.EngineeringBox

setParentCategory(Long) - Method in class bb.common.AccountsChartCategoryVO

setParentId(String) - Method in class bb.common.EngGroupVO

setParentId(String) - Method in class bb.common.PermissionVO

setParentName(String) - Method in class bb.common.ZipcodeTotalsResult

setParentToolList(ToolListVO, ToolListItemVO) - Method in interface bb.common.box.ManufacturingBox

setParentWorkCenter(WorkCenterVO) - Method in class bb.common.WorkCenterVO

setParItemNumber(Long) - Method in class bb.common.PreventiveActionRequestItemVO

setParNumber(String) - Method in class bb.common.PreventiveActionRequestItemVO

setParNumber(String) - Method in class bb.common.PreventiveActionRequestVO

setPart(BB2Part) - Method in class bb.common.BB2PartBasicInfo

setPart(BB2Part) - Method in class bb.common.BB2PartByDateResult

setPart(BB2Part) - Method in class bb.common.BB2PartInventoryResult

setPart(BB2Part) - Method in class bb.common.BB2PartOnDemandListResult

setPart(BB2Part) - Method in class bb.common.BB2WeightInfoResult

setPart(BB2Part) - Method in class bb.common.EcnCheckOrderResult

setPart(BB2Part) - Method in class bb.common.HighUsagePartResult

setPart(BB2Part) - Method in class bb.common.InventoryCycleResult

setPart(BB2Part) - Method in class bb.common.InventoryListResult

setPart(BB2Part) - Method in class bb.common.InventoryNotUsedInMonthsResult

setPart(PartPK) - Method in class bb.common.MrpItemOrderDemandRecordsResult

setPart(PartPK) - Method in class bb.common.MrpItemResult

setPart(BB2Part) - Method in class bb.common.NcrReportListResult

setPart(PartVO) - Method in class bb.common.OnloanReceiverItemVO

setPart(BB2Part) - Method in class bb.common.PartClassInfoResult

setPart(BB2Part) - Method in class bb.common.PartInQAAgent

setPart(BB2Part) - Method in class bb.common.PartInWipForIDListResult

setPart(BB2Part) - Method in class bb.common.PartOnhandResult

setPart(String) - Method in class bb.common.PrReceiverWithQualityListResult

setPart(BB2Part) - Method in class bb.common.PullFromWorkOrderPartDetailAgent

setPart(BB2Part) - Method in class bb.common.PuttoInQAAgent

setPart(BB2Part) - Method in class bb.common.RebackInQAAgent

setPart(BB2Part) - Method in class bb.common.ReceiverItemAgent

setPart(PartVO) - Method in class bb.common.ReceiverItemVO

setPart(BB2Part) - Method in class bb.common.SalesOrder12MonthMarginResult

setPart(BB2Part) - Method in class bb.common.SerialNumberItemResult

setPart(BB2Part) - Method in class bb.common.SerialNumberResult

setPart(BB2Part) - Method in class bb.common.ShipListItemRelatedDocResult

setPart(BB2Part) - Method in class bb.common.StockTransactionAdjustmentResult

setPart(BB2Part) - Method in class bb.common.StockTransactionPartInfoResult

setPart(BB2Part) - Method in class bb.common.StockTransactionPOReceiverResult

setPart(BB2Part) - Method in class bb.common.StockTransactionSOShipperResult

setPart(BB2Part) - Method in class bb.common.StockTransactionWOReceiverResult

setPart(BB2Part) - Method in class bb.common.StockTransactionWOShipperResult

setPart(BB2Part) - Method in class bb.common.WCLoadByDateResult

setPart(BB2Part) - Method in class bb.common.WOItemCostControlAgent

setPart(BB2Part) - Method in class bb.common.WOItemPartDetailNotIssue

setPart(BB2Part) - Method in class bb.common.WoItemWorkInstructionListResult

setPart(BB2Part) - Method in class bb.common.WorkCenterRunTimeListResult

setPart(BB2Part) - Method in class bb.common.WorkInstructionSummaryResult

setPart(BB2Part) - Method in class bb.common.WorkOrderItemWCLoadResult

setPartAvgCost(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemListResult

setPartAvgCost(BigDecimal) - Method in class bb.common.WorkOrderItemIssueVO

setPartAvgCost(BigDecimal) - Method in class bb.common.WorkOrderItemListResult

setPartBasicInfo(PartBasicInfo) - Method in class bb.common.MrpItemResult

setPartBasicInfo(PartBasicInfo) - Method in class bb.common.PartTraceableInfoResult

setPartBasicInfo(PartBasicInfo) - Method in class bb.common.PartWhereUsedResult

setPartBasicInfo(PartBasicInfo) - Method in class bb.common.PurchaseWorkSheetItemWithRelatedInfoResult

setPartBasicInfo(PartBasicInfo) - Method in class bb.common.WorkOrderWorkSheetItemWithRelatedInfoResult

setPartBigCatagoryLength(int) - Method in class bb.common.CompanyVO

setPartClass(String) - Method in class bb.common.CycleCountListResult

setPartClass(String) - Method in class bb.common.CycleCountStatusVO

setPartClass(String) - Method in class bb.common.CycleCountVO

setPartClass(String) - Method in class bb.common.PartClassInfoResult

setPartClass(String) - Method in class bb.common.PartInventoryVO

setPartClass(String) - Method in class bb.common.TakeCycleCountAgent

setPartDesc(String) - Method in class bb.common.DisassembleWorkOrderItemListResult

setPartDesc(String) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setPartDesc(String) - Method in class bb.common.RequestForQuoteItemListResult

setPartDesc(String) - Method in class bb.common.ReturnToVendorItemListResult

setPartDesc(String) - Method in class bb.common.WorkInstructionSeqAuditListResult

setPartDesc(String) - Method in class bb.common.WorkOrderItemInWipListResult

setPartDesc(String) - Method in class bb.common.WorkOrderItemListResult

setPartDesc(String) - Method in class bb.common.WorkOrderItemPartDetail

setPartDescription(String) - Method in class bb.common.CustomerFeedbackVO

setPartDescription(String) - Method in class bb.common.CustomerServiceIncidentItemListResult

setPartDescription(String) - Method in class bb.common.CustomerServiceIncidentListResult

setPartDescription(String) - Method in class bb.common.DesignControlListResult

setPartDescription(String) - Method in class bb.common.EngineeringChangeListResult

setPartDescription(String) - Method in class bb.common.EngineeringChangeRequestListResult

setPartDescription(String) - Method in class bb.common.EngineeringSharingItemVO

setPartDescription(String) - Method in class bb.common.IcrItemListResult

setPartDescription(String) - Method in class bb.common.InSipAudittListResult

setPartDescription(String) - Method in class bb.common.InspectionConformanceReportItemVO

setPartDescription(String) - Method in class bb.common.InventoryReportListResult

setPartDescription(String) - Method in class bb.common.NcrReportListResult

setPartDescription(String) - Method in class bb.common.NonConformanceReportVO

setPartDescription(String) - Method in class bb.common.PartCertificateListResult

setPartDescription(String) - Method in class bb.common.PartCostVarianceListResult

setPartDescription(String) - Method in class bb.common.PartDwfWithPartInfoResult

setPartDescription(String) - Method in class bb.common.PartDwgWithPartInfoResult

setPartDescription(String) - Method in class bb.common.PartInQAResult

setPartDescription(String) - Method in class bb.common.PO2SOExchangeItem

setPartDescription(String) - Method in class bb.common.SerialNumberItemResult

setPartDescription(String) - Method in class bb.common.SerialNumberResult

setPartDescription(String) - Method in class bb.common.SOShipperItemListResult

setPartDescription(String) - Method in class bb.common.WorkInstructionSequenceListResult

setPartDescription(String) - Method in class bb.common.WorkOrderOverIssueListResult

setPartExist(boolean) - Method in class bb.common.ProformaReceiverPackingBoxItemAgent

setPartFrom(String) - Method in class bb.common.AccountsPayableItemVO

setPartFrom(String) - Method in class bb.common.AccountsReceivableItemVO

setPartFrom(String) - Method in class bb.common.APItemListResult

setPartFrom(String) - Method in class bb.common.AuditPartInQAResult

setPartFrom(String) - Method in class bb.common.BB2Part

setPartFrom(String) - Method in class bb.common.BB2PartOnhandPK

setPartFrom(String) - Method in class bb.common.BomPickListItemResult

setPartFrom(String) - Method in class bb.common.BomPickListResult

setPartFrom(String) - Method in class bb.common.ContractPriceItemPK

setPartFrom(String) - Method in class bb.common.CorrectiveActionRequestVO

setPartFrom(String) - Method in class bb.common.CPItemFromQuoteResult

setPartFrom(String) - Method in class bb.common.CRTVItemListResult

setPartFrom(String) - Method in class bb.common.CSRAgent

setPartFrom(String) - Method in class bb.common.CustomerFeedbackVO

setPartFrom(String) - Method in class bb.common.CustomerReturnToVendorItemVO

setPartFrom(String) - Method in class bb.common.CustomerServiceIncidentItemListResult

setPartFrom(String) - Method in class bb.common.CustomerServiceIncidentListResult

setPartFrom(String) - Method in class bb.common.CustomerServiceIncidentVO

setPartFrom(String) - Method in class bb.common.DisassembleWorkOrderIssueVO

setPartFrom(String) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setPartFrom(String) - Method in class bb.common.DisassembleWorkOrderItemListResult

setPartFrom(String) - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

setPartFrom(String) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

setPartFrom(String) - Method in class bb.common.DisassembleWorkOrderItemVO

setPartFrom(String) - Method in class bb.common.DisassembleWorkOrderReceivingResult

setPartFrom(String) - Method in class bb.common.DWOIssueDetail

setPartFrom(String) - Method in class bb.common.EngineeringChangeListResult

setPartFrom(String) - Method in class bb.common.EngineeringChangeRequestListResult

setPartFrom(String) - Method in class bb.common.EngineeringChangeRequestVO

setPartFrom(String) - Method in class bb.common.EngineeringChangeVO

setPartFrom(String) - Method in class bb.common.IcrItemListResult

setPartFrom(String) - Method in class bb.common.InSipAudittListResult

setPartFrom(String) - Method in class bb.common.InspectionConformanceReportItemVO

setPartFrom(String) - Method in class bb.common.InventoryAdjustmentDetailResult

setPartFrom(String) - Method in class bb.common.InventoryAdjustmentVO

setPartFrom(String) - Method in class bb.common.InventoryPartInOutDetailListResult

setPartFrom(String) - Method in class bb.common.InvoiceItemListResult

setPartFrom(String) - Method in class bb.common.IssueItemAgent

setPartFrom(String) - Method in class bb.common.IssuingItemResult

setPartFrom(String) - Method in class bb.common.IssuingResult

setPartFrom(String) - Method in class bb.common.JobProcessSheetListResult

setPartFrom(String) - Method in class bb.common.JobProcessSheetResult

setPartFrom(String) - Method in class bb.common.LnShipperItemListResult

setPartFrom(String) - Method in class bb.common.LogInventoryListResult

setPartFrom(String) - Method in class bb.common.LogInventoryVO

setPartFrom(String) - Method in class bb.common.LogMiscDocumentVO

setPartFrom(String) - Method in class bb.common.LogPartDwfVO

setPartFrom(String) - Method in class bb.common.LogPartDwgVO

setPartFrom(String) - Method in class bb.common.MiscDocAgent

setPartFrom(String) - Method in class bb.common.NcrNeedToScrapListResult

setPartFrom(String) - Method in class bb.common.NonConformanceReportVO

setPartFrom(String) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setPartFrom(String) - Method in class bb.common.NonproductivePickingItemIssuedVO

setPartFrom(String) - Method in class bb.common.NonproductivePickingItemResult

setPartFrom(String) - Method in class bb.common.NonproductivePickingItemVO

setPartFrom(String) - Method in class bb.common.NonproductivePickingOnDemandResult

setPartFrom(String) - Method in class bb.common.OnLoanItemListResult

setPartFrom(String) - Method in class bb.common.OnLoanItemVO

setPartFrom(String) - Method in class bb.common.OnloanReceiverItemListResult

setPartFrom(String) - Method in class bb.common.OnloanReceiverItemVO

setPartFrom(String) - Method in class bb.common.OnloanShipperItemVO

setPartFrom(String) - Method in class bb.common.OrderDemandForReceiverResult

setPartFrom(String) - Method in class bb.common.PackingBoxItemListResult

setPartFrom(String) - Method in class bb.common.PackingBoxItemVO

setPartFrom(String) - Method in class bb.common.PackingBoxSalesOrderItemResult

setPartFrom(String) - Method in class bb.common.PartCatalogAuditResult

setPartFrom(String) - Method in class bb.common.PartCatalogPK

setPartFrom(String) - Method in class bb.common.PartCertificateListResult

setPartFrom(String) - Method in class bb.common.PartCertificateVO

setPartFrom(String) - Method in class bb.common.PartDwfAgent

setPartFrom(String) - Method in class bb.common.PartDwfPK

setPartFrom(String) - Method in class bb.common.PartDwfWithPartInfoResult

setPartFrom(String) - Method in class bb.common.PartDwgAgent

setPartFrom(String) - Method in class bb.common.PartDwgPK

setPartFrom(String) - Method in class bb.common.PartDwgWithPartInfoResult

setPartFrom(String) - Method in class bb.common.PartInQAResult

setPartFrom(String) - Method in class bb.common.PartInQAVO

setPartFrom(String) - Method in class bb.common.PartInspectionPK

setPartFrom(String) - Method in class bb.common.PartInspectionResult

setPartFrom(String) - Method in class bb.common.PartIssuedVO

setPartFrom(String) - Method in class bb.common.PartOnhandCostVO

setPartFrom(String) - Method in class bb.common.PartReceivedVO

setPartFrom(String) - Method in class bb.common.PartToAuditFlagResult

setPartFrom(String) - Method in class bb.common.PartUseTypeVO

setPartFrom(String) - Method in class bb.common.PartWithExcessiveInventoryListResult

setPartFrom(String) - Method in class bb.common.PartWithInventoryInfoListResult

setPartFrom(String) - Method in class bb.common.PartWithQAQtyListResult

setPartFrom(String) - Method in class bb.common.PartWithQtyListResult

setPartFrom(String) - Method in class bb.common.PartWithSipQtyListResult

setPartFrom(String) - Method in class bb.common.PartWithSITQtyListResult

setPartFrom(String) - Method in class bb.common.PartWithSTOQtyListResult

setPartFrom(String) - Method in class bb.common.PartWithWipQtyListResult

setPartFrom(String) - Method in class bb.common.PfReceiverItemVO

setPartFrom(String) - Method in class bb.common.PO2SOExchangeItem

setPartFrom(String) - Method in class bb.common.POReceiverItemListResult

setPartFrom(String) - Method in class bb.common.POSurveyReportItemVO

setPartFrom(String) - Method in class bb.common.PreventiveActionRequestVO

setPartFrom(String) - Method in class bb.common.ProformaInvoiceItemListResult

setPartFrom(String) - Method in class bb.common.ProformaInvoiceItemVO

setPartFrom(String) - Method in class bb.common.PrPackingBoxItemVO

setPartFrom(String) - Method in class bb.common.PurchaseOrderItemVO

setPartFrom(String) - Method in class bb.common.PurchaseOrderOnOrderResult

setPartFrom(String) - Method in class bb.common.QuoteItemListResult

setPartFrom(String) - Method in class bb.common.QuoteItemVO

setPartFrom(String) - Method in class bb.common.ReceiverItemVO

setPartFrom(String) - Method in class bb.common.ReceivingItemResult

setPartFrom(String) - Method in class bb.common.RequestForQuoteItemListResult

setPartFrom(String) - Method in class bb.common.RequestForQuoteItemVO

setPartFrom(String) - Method in class bb.common.RequestForRMAItemVO

setPartFrom(String) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setPartFrom(String) - Method in class bb.common.ReturnToVendorItemListResult

setPartFrom(String) - Method in class bb.common.ReturnToVendorItemVO

setPartFrom(String) - Method in class bb.common.RMAItemListResult

setPartFrom(String) - Method in class bb.common.RMAReceiverItemListResult

setPartFrom(String) - Method in class bb.common.RMAReceiverItemVO

setPartFrom(String) - Method in class bb.common.RRMAItemListResult

setPartFrom(String) - Method in class bb.common.RtvShipperItemListResult

setPartFrom(String) - Method in class bb.common.RtvShipperItemVO

setPartFrom(String) - Method in class bb.common.SalesBomItemResult

setPartFrom(String) - Method in class bb.common.SalesOrderItemGroupByPartListResult

setPartFrom(String) - Method in class bb.common.SalesOrderItemInfoVO

setPartFrom(String) - Method in class bb.common.SalesOrderItemListResult

setPartFrom(String) - Method in class bb.common.SalesOrderItemVO

setPartFrom(String) - Method in class bb.common.SalesOrderOnDemandResult

setPartFrom(String) - Method in class bb.common.SalesOrderShipDateListResult

setPartFrom(String) - Method in class bb.common.SalesPartListItemResult

setPartFrom(String) - Method in class bb.common.SalesTaxListResult

setPartFrom(String) - Method in class bb.common.ScrapReportVO

setPartFrom(String) - Method in class bb.common.SGBOMItemResult

setPartFrom(String) - Method in class bb.common.SGCustomerCatalogPK

setPartFrom(String) - Method in class bb.common.SGCustomerServiceRequestVO

setPartFrom(String) - Method in class bb.common.SGCustRequestForQuoteItemVO

setPartFrom(String) - Method in class bb.common.SGSaleItemVO

setPartFrom(String) - Method in class bb.common.ShipListItemVOResult

setPartFrom(String) - Method in class bb.common.ShipperItemListResult

setPartFrom(String) - Method in class bb.common.ShipperItemVO

setPartFrom(String) - Method in class bb.common.ShippingItemResult

setPartFrom(String) - Method in class bb.common.ShoppingCartItem

setPartFrom(String) - Method in class bb.common.SwapOrderItemListResult

setPartFrom(String) - Method in class bb.common.SwapOrderItemVO

setPartFrom(String) - Method in class bb.common.SwapReceiverItemListResult

setPartFrom(String) - Method in class bb.common.SwapReceiverItemVO

setPartFrom(String) - Method in class bb.common.SwapShipperItemListResult

setPartFrom(String) - Method in class bb.common.SwapShipperItemVO

setPartFrom(String) - Method in class bb.common.SwapShipperOnOrderResult

setPartFrom(String) - Method in class bb.common.TransferOrderItemListResult

setPartFrom(String) - Method in class bb.common.TransferOrderItemVO

setPartFrom(String) - Method in class bb.common.TransferReceiverItemListResult

setPartFrom(String) - Method in class bb.common.TransferReceiverItemVO

setPartFrom(String) - Method in class bb.common.TransferShipperItemListResult

setPartFrom(String) - Method in class bb.common.TransferShipperItemVO

setPartFrom(String) - Method in class bb.common.VendorContractPriceItemPK

setPartFrom(String) - Method in class bb.common.VendorPartVO

setPartFrom(String) - Method in class bb.common.VendorQtyPricePK

setPartFrom(String) - Method in class bb.common.WCLoadDetailResult

setPartFrom(String) - Method in class bb.common.WoItemPickListItemResult

setPartFrom(String) - Method in class bb.common.WoItemPickListResult

setPartFrom(String) - Method in class bb.common.WOReceiverDetail

setPartFrom(String) - Method in class bb.common.WorkInstructionDocumentVO

setPartFrom(String) - Method in class bb.common.WorkInstructionListResult

setPartFrom(String) - Method in class bb.common.WorkInstructionPictureVO

setPartFrom(String) - Method in class bb.common.WorkInstructionPK

setPartFrom(String) - Method in class bb.common.WorkInstructionRequestForChangeVO

setPartFrom(String) - Method in class bb.common.WorkInstructionSequenceListResult

setPartFrom(String) - Method in class bb.common.WorkInstructionSequencePK

setPartFrom(String) - Method in class bb.common.WorkOrderInWipResult

setPartFrom(String) - Method in class bb.common.WorkOrderIssueStatisticsResult

setPartFrom(String) - Method in class bb.common.WorkOrderItemAgent

setPartFrom(String) - Method in class bb.common.WorkOrderItemCanAssyResult

setPartFrom(String) - Method in class bb.common.WorkOrderItemInWipListResult

setPartFrom(String) - Method in class bb.common.WorkOrderItemIssuedTotalResult

setPartFrom(String) - Method in class bb.common.WorkOrderItemIssueVO

setPartFrom(String) - Method in class bb.common.WorkOrderItemLaborCostListResult

setPartFrom(String) - Method in class bb.common.WorkOrderItemListResult

setPartFrom(String) - Method in class bb.common.WorkOrderItemPartDetail

setPartFrom(String) - Method in class bb.common.WorkOrderItemPartDetailInWipVO

setPartFrom(String) - Method in class bb.common.WorkOrderItemPartDetailResult

setPartFrom(String) - Method in class bb.common.WorkOrderItemReviewCostResult

setPartFrom(String) - Method in class bb.common.WorkOrderItemSetupItemAgent

setPartFrom(String) - Method in class bb.common.WorkOrderItemTimeDetailResult

setPartFrom(String) - Method in class bb.common.WorkOrderItemTimeDetailVO

setPartFrom(String) - Method in class bb.common.WorkOrderItemToIssueResult

setPartFrom(String) - Method in class bb.common.WorkOrderItemVO

setPartFrom(String) - Method in class bb.common.WorkOrderOnDemandResult

setPartFrom(String) - Method in class bb.common.WorkOrderOnOrderResult

setPartFrom(String) - Method in class bb.common.WorkOrderOverIssueListResult

setPartFrom(String) - Method in class bb.common.WorkOrderReceiverVO

setPartFrom(String) - Method in class bb.common.WorkOrderTimeCardVO

setPartFrom(String) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setPartFrom(String) - Method in class bb.common.WorkOrderWorkInstructionVO

setPartInfo(PartBasicInfo) - Method in class bb.common.InventoryAdjustmentDetailResult

setPartInQAII(int) - Method in class bb.common.IssuedFromOrderItem

setPartInQAII(int) - Method in class bb.common.ShipperItemDetailAgent

setPartInqaItems(List) - Method in class bb.common.PartInQAResult

setPartInventory(PartInventoryVO) - Method in class bb.common.MrpItemResult

setPartInventory(PartInventoryVO) - Method in class bb.common.PartVO

setPartInventory(PartInventoryVO) - Method in class bb.common.PartWithOnhandsVO

setPartInventory(ToolInventoryVO) - Method in class bb.common.ToolVO

setPartInventory(ToolInventoryVO) - Method in class bb.common.ToolWithOnhandsVO

setPartInventoryInfo(PartInventoryVO) - Method in class bb.common.InventoryAdjustmentDetailResult

setPartInventoryVO(PartInventoryVO) - Method in class bb.common.PurchaseWorkSheetItemWithRelatedInfoResult

setPartInventoryVO(PartInventoryVO) - Method in class bb.common.WorkOrderWorkSheetItemWithRelatedInfoResult

setPartInWip(BB2Part) - Method in class bb.common.PartInWipForIDListResult

setPartInWipDescription(String) - Method in class bb.common.PartInWipForIDListResult

setPartLocations(Set) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setPartLocations(Set) - Method in class bb.common.IssuingItemResult

setPartLocations(Set) - Method in class bb.common.ReceivingItemResult

setPartLocations(Set) - Method in class bb.common.ShipListItemVOResult

setPartManufacturer(List<PartManufacturerVO>) - Method in class bb.common.BillItemSalesCostResult

setPartManufacturer(List<PartManufacturerVO>) - Method in class bb.common.BillItemWithPartInfoResult

setPartManufacturer(List<PartManufacturerVO>) - Method in class bb.common.BillWithPartInfoResult

setPartManufacturers(Set<PartManufacturerVO>) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setPartManufacturers(List) - Method in class bb.common.PurchaseWorkSheetItemWithRelatedInfoResult

setPartManufacturers(Set<PartManufacturerVO>) - Method in class bb.common.ReceivingItemResult

setPartManufacturers(List) - Method in class bb.common.WorkOrderWorkSheetItemWithRelatedInfoResult

setPartNumber(String) - Method in class bb.common.AccountsPayableItemVO

setPartNumber(String) - Method in class bb.common.AccountsReceivableItemVO

setPartNumber(String) - Method in class bb.common.AllPartDocumentsPK

setPartNumber(String) - Method in class bb.common.APItemListResult

setPartNumber(String) - Method in class bb.common.AuditPartInQAResult

setPartNumber(String) - Method in class bb.common.BillItemSalesResult

setPartNumber(String) - Method in class bb.common.BillItemSalesXResult

setPartNumber(String) - Method in class bb.common.BillItemVO

setPartNumber(String) - Method in class bb.common.BillLogVO

setPartNumber(String) - Method in class bb.common.ChangeStdCostWorkSheetItemPK

setPartNumber(String) - Method in class bb.common.ContractPriceItemPK

setPartNumber(String) - Method in class bb.common.CorrectiveActionRequestVO

setPartNumber(String) - Method in class bb.common.CPItemFromQuoteResult

setPartNumber(String) - Method in class bb.common.CSRAgent

setPartNumber(String) - Method in class bb.common.CustomerFeedbackVO

setPartNumber(String) - Method in class bb.common.CustomerReturnToVendorItemVO

setPartNumber(String) - Method in class bb.common.CustomerServiceIncidentItemListResult

setPartNumber(String) - Method in class bb.common.CustomerServiceIncidentListResult

setPartNumber(String) - Method in class bb.common.CustomerServiceIncidentVO

setPartNumber(String) - Method in class bb.common.CycleCountListResult

setPartNumber(String) - Method in class bb.common.CycleCountVO

setPartNumber(String) - Method in class bb.common.DesignControlInfoVO

setPartNumber(String) - Method in class bb.common.DesignControlVO

setPartNumber(String) - Method in class bb.common.DisassembleWorkOrderIssueVO

setPartNumber(String) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

setPartNumber(String) - Method in class bb.common.DisassembleWorkOrderItemVO

setPartNumber(String) - Method in class bb.common.DocumentInfoAgent

setPartNumber(String) - Method in class bb.common.DWOIssueDetail

setPartNumber(String) - Method in class bb.common.EngineeringChangeRequestVO

setPartNumber(String) - Method in class bb.common.EngineeringChangeVO

setPartNumber(String) - Method in class bb.common.EngineeringSharingImportLogVO

setPartNumber(String) - Method in class bb.common.EngineeringSharingItemPK

setPartNumber(String) - Method in class bb.common.HistoricalInventoryVO

setPartNumber(String) - Method in class bb.common.IcrItemListResult

setPartNumber(String) - Method in class bb.common.InspectionConformanceReportItemVO

setPartNumber(String) - Method in class bb.common.InventoryAdjustmentVO

setPartNumber(String) - Method in class bb.common.InventoryMonthReport

setPartNumber(String) - Method in class bb.common.InventoryNotUsedInMonthsforAppResult

setPartNumber(String) - Method in class bb.common.InventoryPartInOutDetailListResult

setPartNumber(String) - Method in class bb.common.InventoryReportListResult

setPartNumber(String) - Method in class bb.common.InvoiceItemListResult

setPartNumber(String) - Method in class bb.common.LnShipperItemListResult

setPartNumber(String) - Method in class bb.common.LogInventoryListResult

setPartNumber(String) - Method in class bb.common.LogInventoryVO

setPartNumber(String) - Method in class bb.common.LogMiscDocumentVO

setPartNumber(String) - Method in class bb.common.LogPartDocumentVO

setPartNumber(String) - Method in class bb.common.LogPartDwfVO

setPartNumber(String) - Method in class bb.common.LogPartDwgVO

setPartNumber(String) - Method in class bb.common.LogTrackingVO

setPartNumber(String) - Method in class bb.common.MiscDocAgent

setPartNumber(String) - Method in class bb.common.NcrNeedToScrapListResult

setPartNumber(String) - Method in class bb.common.NonConformanceReportVO

setPartNumber(String) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setPartNumber(String) - Method in class bb.common.NonproductivePickingItemIssuedVO

setPartNumber(String) - Method in class bb.common.NonproductivePickingItemResult

setPartNumber(String) - Method in class bb.common.NonproductivePickingItemVO

setPartNumber(String) - Method in class bb.common.OnLoanItemVO

setPartNumber(String) - Method in class bb.common.OnloanReceiverItemListResult

setPartNumber(String) - Method in class bb.common.OnloanReceiverItemVO

setPartNumber(String) - Method in class bb.common.OnloanShipperItemVO

setPartNumber(String) - Method in class bb.common.OrderApprovalItemsVO

setPartNumber(String) - Method in class bb.common.OrderDemandForReceiverResult

setPartNumber(String) - Method in class bb.common.PackingBoxItemListResult

setPartNumber(String) - Method in class bb.common.PackingBoxItemVO

setPartNumber(String) - Method in class bb.common.PackingBoxSalesOrderItemResult

setPartNumber(String) - Method in class bb.common.PartCatalogAuditResult

setPartNumber(String) - Method in class bb.common.PartCatalogPK

setPartNumber(String) - Method in class bb.common.PartCertificateListResult

setPartNumber(String) - Method in class bb.common.PartCertificateVO

setPartNumber(String) - Method in class bb.common.PartCostVarianceListResult

setPartNumber(String) - Method in class bb.common.PartDescriptionPK

setPartNumber(String) - Method in class bb.common.PartDocumentPK

setPartNumber(String) - Method in class bb.common.PartDwfAgent

setPartNumber(String) - Method in class bb.common.PartDwfPK

setPartNumber(String) - Method in class bb.common.PartDwfWithPartInfoResult

setPartNumber(String) - Method in class bb.common.PartDwgAgent

setPartNumber(String) - Method in class bb.common.PartDwgPK

setPartNumber(String) - Method in class bb.common.PartDwgWithPartInfoResult

setPartNumber(String) - Method in class bb.common.PartInQAResult

setPartNumber(String) - Method in class bb.common.PartInQAVO

setPartNumber(String) - Method in class bb.common.PartInspectionPK

setPartNumber(String) - Method in class bb.common.PartInspectionResult

setPartNumber(String) - Method in class bb.common.PartIssuedVO

setPartNumber(String) - Method in class bb.common.PartManufacturerPK

setPartNumber(String) - Method in class bb.common.PartOnHandAuditAgent

setPartNumber(String) - Method in class bb.common.PartOnhandCostVO

setPartNumber(String) - Method in class bb.common.PartOnhandPK

setPartNumber(String) - Method in class bb.common.PartPictureVO

setPartNumber(String) - Method in class bb.common.PartPK

setPartNumber(String) - Method in class bb.common.PartReceivedVO

setPartNumber(String) - Method in class bb.common.PartTraceableCategoryPK

setPartNumber(String) - Method in class bb.common.PartTraceableSpecPK

setPartNumber(String) - Method in class bb.common.PartTrackingPK

setPartNumber(String) - Method in class bb.common.PartUnitPK

setPartNumber(String) - Method in class bb.common.partUsedInfoResult

setPartNumber(String) - Method in class bb.common.PartUseTypeVO

setPartNumber(String) - Method in class bb.common.PartVendorPK

setPartNumber(String) - Method in class bb.common.PartWithInventoryInfoListResult

setPartNumber(String) - Method in class bb.common.PartWithManufacturerInfoResult

setPartNumber(String) - Method in class bb.common.PfReceiverItemVO

setPartNumber(String) - Method in class bb.common.PhysicalInventoryListResult

setPartNumber(String) - Method in class bb.common.PhysicalInventoryVO

setPartNumber(String) - Method in class bb.common.POReceiverItemListResult

setPartNumber(String) - Method in class bb.common.POSurveyReportItemVO

setPartNumber(String) - Method in class bb.common.PreventiveActionRequestVO

setPartNumber(String) - Method in class bb.common.ProformaInvoiceItemListResult

setPartNumber(String) - Method in class bb.common.ProformaInvoiceItemVO

setPartNumber(String) - Method in class bb.common.PrPackingBoxItemVO

setPartNumber(String) - Method in class bb.common.PurchaseOrderContractResult

setPartNumber(String) - Method in class bb.common.PurchaseOrderItemVO

setPartNumber(String) - Method in class bb.common.PurchaseWorkSheetItemVO

setPartNumber(String) - Method in class bb.common.QuoteItemVO

setPartNumber(String) - Method in class bb.common.ReceiverItemVO

setPartNumber(String) - Method in class bb.common.RequestForQuoteItemVO

setPartNumber(String) - Method in class bb.common.RequestForRMAItemVO

setPartNumber(String) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setPartNumber(String) - Method in class bb.common.ReturnToVendorItemVO

setPartNumber(String) - Method in class bb.common.RMAReceiverItemListResult

setPartNumber(String) - Method in class bb.common.RMAReceiverItemVO

setPartNumber(String) - Method in class bb.common.RtvShipperItemListResult

setPartNumber(String) - Method in class bb.common.RtvShipperItemVO

setPartNumber(String) - Method in class bb.common.RunningAccountOrderItemVO

setPartNumber(String) - Method in class bb.common.SalesOrderItemGroupByPartListResult

setPartNumber(String) - Method in class bb.common.SalesOrderItemInfoVO

setPartNumber(String) - Method in class bb.common.SalesOrderItemVO

setPartNumber(String) - Method in class bb.common.SalesOrderShipDateListResult

setPartNumber(String) - Method in class bb.common.SalesTaxListResult

setPartNumber(String) - Method in class bb.common.ScrapReportVO

setPartNumber(String) - Method in class bb.common.SGBillItemVO

setPartNumber(String) - Method in class bb.common.SGBOMItemResult

setPartNumber(String) - Method in class bb.common.SGCustomerCatalogPK

setPartNumber(String) - Method in class bb.common.SGCustomerServiceRequestVO

setPartNumber(String) - Method in class bb.common.SGCustRequestForQuoteItemResult

setPartNumber(String) - Method in class bb.common.SGCustRequestForQuoteItemVO

setPartNumber(String) - Method in class bb.common.SGDocPartPK

setPartNumber(String) - Method in class bb.common.SGDwgPicturePK

setPartNumber(String) - Method in class bb.common.SGPartCartAgent

setPartNumber(String) - Method in class bb.common.SGPartCatalogResult

setPartNumber(String) - Method in class bb.common.SGPartDocFlagResult

setPartNumber(String) - Method in class bb.common.SGPartListItemResult

setPartNumber(String) - Method in class bb.common.SGPartListResult

setPartNumber(String) - Method in class bb.common.SGPicturePK

setPartNumber(String) - Method in class bb.common.SGQuoteCartListResult

setPartNumber(String) - Method in class bb.common.SGQuoteCartVO

setPartNumber(String) - Method in class bb.common.SGSaleItemVO

setPartNumber(String) - Method in class bb.common.ShipListItemVOResult

setPartNumber(String) - Method in class bb.common.ShipperItemListResult

setPartNumber(String) - Method in class bb.common.ShipperItemVO

setPartNumber(String) - Method in class bb.common.ShoppingCartItem

setPartNumber(String) - Method in class bb.common.SOShipperItemListResult

setPartNumber(String) - Method in class bb.common.SwapOrderItemListResult

setPartNumber(String) - Method in class bb.common.SwapOrderItemVO

setPartNumber(String) - Method in class bb.common.SwapReceiverItemListResult

setPartNumber(String) - Method in class bb.common.SwapReceiverItemVO

setPartNumber(String) - Method in class bb.common.SwapShipperItemListResult

setPartNumber(String) - Method in class bb.common.SwapShipperItemVO

setPartNumber(String) - Method in class bb.common.ToolCalibrationVO

setPartNumber(String) - Method in class bb.common.ToolListItemVO

setPartNumber(String) - Method in class bb.common.TransferOrderItemListResult

setPartNumber(String) - Method in class bb.common.TransferOrderItemVO

setPartNumber(String) - Method in class bb.common.TransferReceiverItemListResult

setPartNumber(String) - Method in class bb.common.TransferReceiverItemVO

setPartNumber(String) - Method in class bb.common.TransferShipperItemListResult

setPartNumber(String) - Method in class bb.common.TransferShipperItemVO

setPartNumber(String) - Method in class bb.common.VendorContractPriceItemPK

setPartNumber(String) - Method in class bb.common.VendorPartVO

setPartNumber(String) - Method in class bb.common.VendorQtyPricePK

setPartNumber(String) - Method in class bb.common.WCLoadDetailResult

setPartNumber(String) - Method in class bb.common.WOReceiverDetail

setPartNumber(String) - Method in class bb.common.WorkInstructionDocumentVO

setPartNumber(String) - Method in class bb.common.WorkInstructionListResult

setPartNumber(String) - Method in class bb.common.WorkInstructionPictureVO

setPartNumber(String) - Method in class bb.common.WorkInstructionPK

setPartNumber(String) - Method in class bb.common.WorkInstructionRequestForChangeVO

setPartNumber(String) - Method in class bb.common.WorkInstructionSequenceListResult

setPartNumber(String) - Method in class bb.common.WorkInstructionSequencePK

setPartNumber(String) - Method in class bb.common.WorkOrderIssueStatisticsResult

setPartNumber(String) - Method in class bb.common.WorkOrderItemCanAssyAgent

setPartNumber(String) - Method in class bb.common.WorkOrderItemCanAssyResult

setPartNumber(String) - Method in class bb.common.WorkOrderItemInfoResult

setPartNumber(String) - Method in class bb.common.WorkOrderItemInWipListResult

setPartNumber(String) - Method in class bb.common.WorkOrderItemIssuedTotalResult

setPartNumber(String) - Method in class bb.common.WorkOrderItemIssueVO

setPartNumber(String) - Method in class bb.common.WorkOrderItemLaborCostListResult

setPartNumber(String) - Method in class bb.common.WorkOrderItemPartDetailInWipVO

setPartNumber(String) - Method in class bb.common.WorkOrderItemReviewCostResult

setPartNumber(String) - Method in class bb.common.WorkOrderItemTimeDetailVO

setPartNumber(String) - Method in class bb.common.WorkOrderItemToIssueResult

setPartNumber(String) - Method in class bb.common.WorkOrderItemVO

setPartNumber(String) - Method in class bb.common.WorkOrderQueryInfo

setPartNumber(String) - Method in class bb.common.WorkOrderReceiverVO

setPartNumber(String) - Method in class bb.common.WorkOrderTimeCardVO

setPartNumber(String) - Method in class bb.common.WorkOrderWorkInstructionListResult

setPartNumber(String) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setPartNumber(String) - Method in class bb.common.WorkOrderWorkInstructionVO

setPartNumber(String) - Method in class bb.common.WorkOrderWorkSheetItemVO

setPartNumberFrom(String) - Method in class bb.common.MrpReportAgent

setPartNumberGenerateType(String) - Method in class bb.common.CompanyVO

setPartNumberMaxLength(byte) - Method in class bb.common.CompanyVO

setPartNumberMinLength(byte) - Method in class bb.common.CompanyVO

setPartNumbers(String[]) - Method in class bb.common.MrpReportAgent

setPartNumberSeqLength(int) - Method in class bb.common.CompanyVO

setPartNumberTo(String) - Method in class bb.common.MrpReportAgent

setPartNums(List<String>) - Method in class bb.common.BOMCanAssyAgent

setPartOnhand(List) - Method in class bb.common.PartInQAResult

setPartOnhand(BigDecimal) - Method in class bb.common.RunningAccountOrderItemVO

setPartOnhandLocations(Set) - Method in class bb.common.ShippingItemResult

setPartOnhands(List) - Method in class bb.common.WoItemPickListItemResult

setPartOnhandVo(PartOnhandVO) - Method in class bb.common.PartOnhandWithAverageCostResult

setPartOnholdCount(Integer) - Method in class bb.common.EngineeringInfoCenterResult

setPartOrAssy(String) - Method in class bb.common.SalesOrderItemListResult

setPartPk(PartPK) - Method in class bb.common.AddPhysicalInventoryAgent

setPartPk(PartPK) - Method in class bb.common.AuditOnDemandResult

setPartPk(PartPK) - Method in class bb.common.BB2Part

setPartPk(PartPK) - Method in class bb.common.BillSalesCostResult

setPartPk(PartPK) - Method in class bb.common.BillSalesResult

setPartPk(PartPK) - Method in class bb.common.BillSalesXResult

setPartPk(PartPK) - Method in class bb.common.BillWhereUsedResult

setPartPk(PartPK) - Method in class bb.common.BomItemWithOEMResult

setPartPk(PartPK) - Method in class bb.common.BomPickListItemResult

setPartPk(PartPK) - Method in class bb.common.CRTVItemListResult

setPartPk(PartPK) - Method in class bb.common.DesignControlListResult

setPartPk(PartPK) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setPartPk(PartPK) - Method in class bb.common.DisassembleWorkOrderItemListResult

setPartPk(PartPK) - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

setPartPk(PartPK) - Method in class bb.common.DisassembleWorkOrderReceivingResult

setPartPk(PartPK) - Method in class bb.common.EngineeringChangeListResult

setPartPk(PartPK) - Method in class bb.common.EngineeringChangeRequestListResult

setPartPk(PartPK) - Method in class bb.common.IssueItemAgent

setPartPk(PartPK) - Method in class bb.common.IssuingItemResult

setPartPk(PartPK) - Method in class bb.common.IssuingResult

setPartPk(PartPK) - Method in class bb.common.JobProcessSheetListResult

setPartPK(PartPK) - Method in class bb.common.JobProcessSheetResult

setPartPk(PartPK) - Method in class bb.common.NonproductivePickingOnDemandResult

setPartPk(PartPK) - Method in class bb.common.OnLoanItemListResult

setPartPk(PartPK) - Method in class bb.common.PartBasicInfo

setPartPk(PartPK) - Method in class bb.common.PartInMrpListResult

setPartPk(PartPK) - Method in class bb.common.PartMaterialReportAgent

setPartPk(PartPK) - Method in class bb.common.PartMaterialWhereUsedResult

setPartPk(PartPK) - Method in class bb.common.PartWithExcessiveInventoryListResult

setPartPk(PartPK) - Method in class bb.common.PartWithOnLoanQtyListResult

setPartPk(PartPK) - Method in class bb.common.PartWithQAQtyListResult

setPartPk(PartPK) - Method in class bb.common.PartWithQtyListResult

setPartPk(PartPK) - Method in class bb.common.PartWithSipQtyListResult

setPartPk(PartPK) - Method in class bb.common.PartWithSITQtyListResult

setPartPk(PartPK) - Method in class bb.common.PartWithSTOQtyListResult

setPartPk(PartPK) - Method in class bb.common.PartWithWipQtyListResult

setPartPK(PartPK) - Method in class bb.common.PO2SOExchangeItem

setPartPk(BB2Part) - Method in class bb.common.PurchaseOrderItemListResult

setPartPk(PartPK) - Method in class bb.common.PurchaseOrderOnOrderResult

setPartPk(BB2Part) - Method in class bb.common.PurchaseOrderOpenDueListResult

setPartPk(PartPK) - Method in class bb.common.QuoteItemListResult

setPartPk(PartPK) - Method in class bb.common.ReceivingItemResult

setPartPk(PartPK) - Method in class bb.common.RequestForQuoteItemListResult

setPartPk(BB2Part) - Method in class bb.common.ReturnToVendorByDateListResult

setPartPk(PartPK) - Method in class bb.common.ReturnToVendorItemListResult

setPartPk(PartPK) - Method in class bb.common.RMAItemListResult

setPartPk(PartPK) - Method in class bb.common.RRMAItemListResult

setPartPk(PartPK) - Method in class bb.common.SalesBomItemResult

setPartPk(PartPK) - Method in class bb.common.SalesOrderItemListResult

setPartPk(PartPK) - Method in class bb.common.SalesOrderOnDemandResult

setPartPk(PartPK) - Method in class bb.common.SalesPartListItemResult

setPartPk(PartPK) - Method in class bb.common.ShippingItemResult

setPartPk(PartPK) - Method in class bb.common.SwapShipperOnOrderResult

setPartPk(PartPK) - Method in class bb.common.UpdatePhysicalInventoryAgent

setPartPk(PartPK) - Method in class bb.common.WoItemPickListItemResult

setPartPk(PartPK) - Method in class bb.common.WoItemPickListResult

setPartPk(PartPK) - Method in class bb.common.WorkOrderInWipResult

setPartPk(PartPK) - Method in class bb.common.WorkOrderItemAgent

setPartPk(PartPK) - Method in class bb.common.WorkOrderItemListResult

setPartPk(PartPK) - Method in class bb.common.WorkOrderItemPartDetail

setPartPk(PartPK) - Method in class bb.common.WorkOrderItemPartDetailResult

setPartPk(PartPK) - Method in class bb.common.WorkOrderItemSetupItemAgent

setPartPk(PartPK) - Method in class bb.common.WorkOrderItemTimeDetailResult

setPartPk(PartPK) - Method in class bb.common.WorkOrderOnDemandResult

setPartPk(PartPK) - Method in class bb.common.WorkOrderOnOrderResult

setPartPk(PartPK) - Method in class bb.common.WorkOrderOverIssueListResult

setPartPk(PartPK) - Method in class bb.common.WorkSheetPartAgent

setPartPoUnit(String) - Method in class bb.common.PartVO

setPartPoUnit(String) - Method in class bb.common.PartWithOnhandsVO

setPartPoUnitRate(BigDecimal) - Method in class bb.common.PartVO

setPartPoUnitRate(BigDecimal) - Method in class bb.common.PartWithOnhandsVO

setPartPrefix(String) - Method in class bb.common.WareHousePartPrefixKeeperVO

setPartPutBackToStock(BigDecimal) - Method in class bb.common.NcrNeedToScrapListResult

setPartPutBackToStock(BigDecimal) - Method in class bb.common.NcrReportListResult

setPartPutBackToStock(BigDecimal) - Method in class bb.common.NonConformanceReportResult

setPartPutBackToStock(BigDecimal) - Method in class bb.common.NonConformanceReportVO

setPartPutBackToStockDate(Date) - Method in class bb.common.NonConformanceReportVO

setPartQuantity(BigDecimal) - Method in class bb.common.BillItemVO

setPartQuantity(BigDecimal) - Method in class bb.common.BillItemWithPartInfoResult

setPartQuantity(BigDecimal) - Method in class bb.common.BillLogVO

setPartQuantity(BigDecimal) - Method in class bb.common.PartWhereUsedItemResult

setPartQuantity(BigDecimal) - Method in class bb.common.ToolListItemVO

setPartQuantity(BigDecimal) - Method in class bb.common.ToolListItemWithToolInfoResult

setPartQuantity(BigDecimal) - Method in class bb.common.ToolWhereUsedItemResult

setPartRev(String) - Method in class bb.common.WorkInstructionListResult

setPartRevision(String) - Method in class bb.common.DocumentInfoAgent

setPartRevision(String) - Method in class bb.common.IcrItemListResult

setPartRevision(String) - Method in class bb.common.InspectionConformanceReportItemVO

setPartRevision(String) - Method in class bb.common.NonConformanceReportVO

setPartRevision(String) - Method in class bb.common.PartDwfWithPartInfoResult

setPartRevision(String) - Method in class bb.common.PartDwgWithPartInfoResult

setPartSerialNumber(String) - Method in class bb.common.NonConformanceReportVO

setPartSmallCatagoryLength(int) - Method in class bb.common.CompanyVO

setPartSplitChar(String) - Method in class bb.common.CompanyVO

setPartsPulledFromStock(BigDecimal) - Method in class bb.common.NcrNeedToScrapListResult

setPartsPulledFromStock(BigDecimal) - Method in class bb.common.NcrReportListResult

setPartsPulledFromStock(BigDecimal) - Method in class bb.common.NonConformanceReportResult

setPartsPulledFromStock(BigDecimal) - Method in class bb.common.NonConformanceReportVO

setPartsPulledFromStockDate(Date) - Method in class bb.common.NonConformanceReportVO

setPartsToDeletedNotUsed(List<PartBasicInfo>) - Method in class bb.common.PartsToDeleteResult

setPartsToDeleteInPO(List<PurchaseOrderItemListResult>) - Method in class bb.common.PartsToDeleteResult

setPartsToDeleteInSO(List<SalesOrderItemListResult>) - Method in class bb.common.PartsToDeleteResult

setPartsToDeleteInWO(List<WorkOrderItemListResult>) - Method in class bb.common.PartsToDeleteResult

setPartsToDeleteInWOItemDetail(List<WorkOrderItemPartDetail>) - Method in class bb.common.PartsToDeleteResult

setPartTaxExempt(boolean) - Method in class bb.common.RunningAccountOrderItemVO

setPartTraceableSpecItem(Short) - Method in class bb.common.PartTraceableSpecPK

setPartTracking(Set<PartTrackingVO>) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setPartTracking(Set<PartTrackingVO>) - Method in class bb.common.IssuingItemResult

setPartTracking(Set<PartTrackingVO>) - Method in class bb.common.ReceivingItemResult

setPartTracking(Set<PartTrackingVO>) - Method in class bb.common.ShippingItemResult

setPartType(String) - Method in class bb.common.AccountsPayableItemVO

setPartType(String) - Method in class bb.common.AccountsReceivableItemVO

setPartType(String) - Method in class bb.common.APItemListResult

setPartType(String) - Method in class bb.common.AuditPartInQAResult

setPartType(String) - Method in class bb.common.BillItemSalesResult

setPartType(String) - Method in class bb.common.BillItemSalesXResult

setPartType(String) - Method in class bb.common.BillItemVO

setPartType(String) - Method in class bb.common.BillLogVO

setPartType(String) - Method in class bb.common.ChangeStdCostWorkSheetItemPK

setPartType(String) - Method in class bb.common.ContractPriceItemPK

setPartType(String) - Method in class bb.common.CorrectiveActionRequestVO

setPartType(String) - Method in class bb.common.CPItemFromQuoteResult

setPartType(String) - Method in class bb.common.CSRAgent

setPartType(String) - Method in class bb.common.CustomerFeedbackVO

setPartType(String) - Method in class bb.common.CustomerReturnToVendorItemVO

setPartType(String) - Method in class bb.common.CustomerServiceIncidentItemListResult

setPartType(String) - Method in class bb.common.CustomerServiceIncidentListResult

setPartType(String) - Method in class bb.common.CustomerServiceIncidentVO

setPartType(String) - Method in class bb.common.CycleCountListResult

setPartType(String) - Method in class bb.common.CycleCountVO

setPartType(String) - Method in class bb.common.DesignControlInfoVO

setPartType(String) - Method in class bb.common.DesignControlVO

setPartType(String) - Method in class bb.common.DisassembleWorkOrderIssueVO

setPartType(String) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

setPartType(String) - Method in class bb.common.DisassembleWorkOrderItemVO

setPartType(String) - Method in class bb.common.DWOIssueDetail

setPartType(String) - Method in class bb.common.EngineeringChangeRequestVO

setPartType(String) - Method in class bb.common.EngineeringChangeVO

setPartType(String) - Method in class bb.common.EngineeringSharingImportLogVO

setPartType(String) - Method in class bb.common.EngineeringSharingItemPK

setPartType(String) - Method in class bb.common.HistoricalInventoryVO

setPartType(String) - Method in class bb.common.IcrItemListResult

setPartType(String) - Method in class bb.common.InspectionConformanceReportItemVO

setPartType(String) - Method in class bb.common.InventoryAdjustmentVO

setPartType(String) - Method in class bb.common.InventoryMonthReport

setPartType(String) - Method in class bb.common.InventoryNotUsedInMonthsforAppResult

setPartType(String) - Method in class bb.common.InventoryPartInOutDetailListResult

setPartType(String) - Method in class bb.common.InventoryReportListResult

setPartType(String) - Method in class bb.common.InvoiceItemListResult

setPartType(String) - Method in class bb.common.LnShipperItemListResult

setPartType(String) - Method in class bb.common.LogInventoryListResult

setPartType(String) - Method in class bb.common.LogInventoryVO

setPartType(String) - Method in class bb.common.LogMiscDocumentVO

setPartType(String) - Method in class bb.common.LogPartDwfVO

setPartType(String) - Method in class bb.common.LogPartDwgVO

setPartType(String) - Method in class bb.common.LogTrackingVO

setPartType(String) - Method in class bb.common.MiscDocAgent

setPartType(String) - Method in class bb.common.MrpReportAgent

setPartType(String) - Method in class bb.common.NcrNeedToScrapListResult

setPartType(String) - Method in class bb.common.NonConformanceReportVO

setPartType(String) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setPartType(String) - Method in class bb.common.NonproductivePickingItemIssuedVO

setPartType(String) - Method in class bb.common.NonproductivePickingItemResult

setPartType(String) - Method in class bb.common.NonproductivePickingItemVO

setPartType(String) - Method in class bb.common.OnLoanItemVO

setPartType(String) - Method in class bb.common.OnloanReceiverItemListResult

setPartType(String) - Method in class bb.common.OnloanReceiverItemVO

setPartType(String) - Method in class bb.common.OnloanShipperItemVO

setPartType(String) - Method in class bb.common.OrderApprovalItemsVO

setPartType(String) - Method in class bb.common.OrderDemandForReceiverResult

setPartType(String) - Method in class bb.common.PackingBoxItemListResult

setPartType(String) - Method in class bb.common.PackingBoxItemVO

setPartType(String) - Method in class bb.common.PackingBoxSalesOrderItemResult

setPartType(String) - Method in class bb.common.PartCatalogAuditResult

setPartType(String) - Method in class bb.common.PartCatalogPK

setPartType(String) - Method in class bb.common.PartCertificateListResult

setPartType(String) - Method in class bb.common.PartCertificateVO

setPartType(String) - Method in class bb.common.PartCostVarianceListResult

setPartType(String) - Method in class bb.common.PartDescriptionPK

setPartType(String) - Method in class bb.common.PartDwfAgent

setPartType(String) - Method in class bb.common.PartDwfPK

setPartType(String) - Method in class bb.common.PartDwfWithPartInfoResult

setPartType(String) - Method in class bb.common.PartDwgAgent

setPartType(String) - Method in class bb.common.PartDwgPK

setPartType(String) - Method in class bb.common.PartDwgWithPartInfoResult

setPartType(String) - Method in class bb.common.PartInQAResult

setPartType(String) - Method in class bb.common.PartInQAVO

setPartType(String) - Method in class bb.common.PartInspectionPK

setPartType(String) - Method in class bb.common.PartInspectionResult

setPartType(String) - Method in class bb.common.PartIssuedVO

setPartType(String) - Method in class bb.common.PartManufacturerPK

setPartType(String) - Method in class bb.common.PartOnhandCostVO

setPartType(String) - Method in class bb.common.PartOnhandPK

setPartType(String) - Method in class bb.common.PartPictureVO

setPartType(String) - Method in class bb.common.PartPK

setPartType(String) - Method in class bb.common.PartReceivedVO

setPartType(String) - Method in class bb.common.PartTraceableCategoryPK

setPartType(String) - Method in class bb.common.PartTraceableSpecPK

setPartType(String) - Method in class bb.common.PartTrackingPK

setPartType(String) - Method in class bb.common.PartTypeVO

setPartType(String) - Method in class bb.common.PartUnitPK

setPartType(String) - Method in class bb.common.PartUseTypeVO

setPartType(String) - Method in class bb.common.PartVendorPK

setPartType(String) - Method in class bb.common.PartWithInventoryInfoListResult

setPartType(String) - Method in class bb.common.PartWithManufacturerInfoResult

setPartType(String) - Method in class bb.common.PfReceiverItemVO

setPartType(String) - Method in class bb.common.PhysicalInventoryListResult

setPartType(String) - Method in class bb.common.PhysicalInventoryVO

setPartType(String) - Method in class bb.common.POReceiverItemListResult

setPartType(String) - Method in class bb.common.POSurveyReportItemVO

setPartType(String) - Method in class bb.common.PreventiveActionRequestVO

setPartType(String) - Method in class bb.common.ProformaInvoiceItemListResult

setPartType(String) - Method in class bb.common.ProformaInvoiceItemVO

setPartType(String) - Method in class bb.common.PrPackingBoxItemVO

setPartType(String) - Method in class bb.common.PurchaseOrderContractResult

setPartType(String) - Method in class bb.common.PurchaseOrderItemVO

setPartType(String) - Method in class bb.common.PurchaseWorkSheetItemVO

setPartType(String) - Method in class bb.common.QuoteItemVO

setPartType(String) - Method in class bb.common.ReceiverItemVO

setPartType(String) - Method in class bb.common.RequestForQuoteItemVO

setPartType(String) - Method in class bb.common.RequestForRMAItemVO

setPartType(String) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setPartType(String) - Method in class bb.common.ReturnToVendorItemVO

setPartType(String) - Method in class bb.common.RMAReceiverItemListResult

setPartType(String) - Method in class bb.common.RMAReceiverItemVO

setPartType(String) - Method in class bb.common.RtvShipperItemListResult

setPartType(String) - Method in class bb.common.RtvShipperItemVO

setPartType(String) - Method in class bb.common.RunningAccountOrderItemVO

setPartType(String) - Method in class bb.common.SalesOrderItemGroupByPartListResult

setPartType(String) - Method in class bb.common.SalesOrderItemInfoVO

setPartType(String) - Method in class bb.common.SalesOrderItemVO

setPartType(String) - Method in class bb.common.SalesOrderShipDateListResult

setPartType(String) - Method in class bb.common.SalesTaxListResult

setPartType(String) - Method in class bb.common.ScrapReportVO

setPartType(String) - Method in class bb.common.SGBillItemVO

setPartType(String) - Method in class bb.common.SGBOMItemResult

setPartType(String) - Method in class bb.common.SGCustomerCatalogPK

setPartType(String) - Method in class bb.common.SGCustomerServiceRequestVO

setPartType(String) - Method in class bb.common.SGCustRequestForQuoteItemResult

setPartType(String) - Method in class bb.common.SGCustRequestForQuoteItemVO

setPartType(String) - Method in class bb.common.SGPartCartAgent

setPartType(String) - Method in class bb.common.SGPartCatalogResult

setPartType(String) - Method in class bb.common.SGPartListItemResult

setPartType(String) - Method in class bb.common.SGPartListResult

setPartType(String) - Method in class bb.common.SGQuoteCartListResult

setPartType(String) - Method in class bb.common.SGQuoteCartVO

setPartType(String) - Method in class bb.common.SGSaleItemVO

setPartType(String) - Method in class bb.common.ShipListItemVOResult

setPartType(String) - Method in class bb.common.ShipperItemListResult

setPartType(String) - Method in class bb.common.ShipperItemVO

setPartType(String) - Method in class bb.common.ShoppingCartItem

setPartType(String) - Method in class bb.common.SOShipperItemListResult

setPartType(String) - Method in class bb.common.SwapOrderItemListResult

setPartType(String) - Method in class bb.common.SwapOrderItemVO

setPartType(String) - Method in class bb.common.SwapReceiverItemListResult

setPartType(String) - Method in class bb.common.SwapReceiverItemVO

setPartType(String) - Method in class bb.common.SwapShipperItemListResult

setPartType(String) - Method in class bb.common.SwapShipperItemVO

setPartType(String) - Method in class bb.common.ToolCalibrationVO

setPartType(String) - Method in class bb.common.ToolListItemVO

setPartType(String) - Method in class bb.common.TransferOrderItemListResult

setPartType(String) - Method in class bb.common.TransferOrderItemVO

setPartType(String) - Method in class bb.common.TransferReceiverItemListResult

setPartType(String) - Method in class bb.common.TransferReceiverItemVO

setPartType(String) - Method in class bb.common.TransferShipperItemListResult

setPartType(String) - Method in class bb.common.TransferShipperItemVO

setPartType(String) - Method in class bb.common.VendorContractPriceItemPK

setPartType(String) - Method in class bb.common.VendorPartVO

setPartType(String) - Method in class bb.common.VendorQtyPricePK

setPartType(String) - Method in class bb.common.WCLoadDetailResult

setPartType(String) - Method in class bb.common.WOReceiverDetail

setPartType(String) - Method in class bb.common.WorkInstructionDocumentVO

setPartType(String) - Method in class bb.common.WorkInstructionListResult

setPartType(String) - Method in class bb.common.WorkInstructionPictureVO

setPartType(String) - Method in class bb.common.WorkInstructionPK

setPartType(String) - Method in class bb.common.WorkInstructionRequestForChangeVO

setPartType(String) - Method in class bb.common.WorkInstructionSequenceListResult

setPartType(String) - Method in class bb.common.WorkInstructionSequencePK

setPartType(String) - Method in class bb.common.WorkOrderIssueStatisticsResult

setPartType(String) - Method in class bb.common.WorkOrderItemCanAssyResult

setPartType(String) - Method in class bb.common.WorkOrderItemInfoResult

setPartType(String) - Method in class bb.common.WorkOrderItemInWipListResult

setPartType(String) - Method in class bb.common.WorkOrderItemIssuedTotalResult

setPartType(String) - Method in class bb.common.WorkOrderItemIssueVO

setPartType(String) - Method in class bb.common.WorkOrderItemLaborCostListResult

setPartType(String) - Method in class bb.common.WorkOrderItemPartDetailInWipVO

setPartType(String) - Method in class bb.common.WorkOrderItemReviewCostResult

setPartType(String) - Method in class bb.common.WorkOrderItemTimeDetailVO

setPartType(String) - Method in class bb.common.WorkOrderItemToIssueResult

setPartType(String) - Method in class bb.common.WorkOrderItemVO

setPartType(String) - Method in class bb.common.WorkOrderReceiverVO

setPartType(String) - Method in class bb.common.WorkOrderTimeCardVO

setPartType(String) - Method in class bb.common.WorkOrderWorkInstructionListResult

setPartType(String) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setPartType(String) - Method in class bb.common.WorkOrderWorkInstructionVO

setPartType(String) - Method in class bb.common.WorkOrderWorkSheetItemVO

setPartUnit(String) - Method in class bb.common.BomPickListItemResult

setPartUnit(String) - Method in class bb.common.CompanyVO

setPartUnit(String) - Method in class bb.common.DisassembleWorkOrderItemVO

setPartUnit(String) - Method in class bb.common.InventoryCycleResult

setPartUnit(String) - Method in class bb.common.PartBasicInfo

setPartUnit(String) - Method in class bb.common.PartInMrpListResult

setPartUnit(String) - Method in class bb.common.PartOnhandResult

setPartUnit(String) - Method in class bb.common.PartVO

setPartUnit(String) - Method in class bb.common.PartWithOnhandsVO

setPartUnit(String) - Method in class bb.common.ToolVO

setPartUnit(String) - Method in class bb.common.ToolWithOnhandsVO

setPartUnit(String) - Method in class bb.common.WoItemPickListItemResult

setPartUnit(String) - Method in class bb.common.WoItemPickListResult

setPartUnit(String) - Method in class bb.common.WorkOrderItemVO

setPartVendors(List) - Method in class bb.common.PurchaseWorkSheetItemWithRelatedInfoResult

setPartVendors(List) - Method in class bb.common.WorkOrderWorkSheetItemWithRelatedInfoResult

setPartWhereUsedItemResult(List) - Method in class bb.common.PartWhereUsedResult

setPassword(String) - Method in class bb.common.BB2Login

setPassword(String) - Method in class bb.common.BizBoxServer

setPassword(String) - Method in class bb.common.BizboxUserVO

setPassword(String) - Method in class bb.common.CashierVO

setPassword(String) - Method in class bb.common.CustomerVendorAddressVO

setPassword(String) - Method in class bb.common.QualityGroupVO

setPassword(String) - Method in class bb.common.SalesmanVO

setPassword(String) - Method in class bb.common.SGCartLogin

setPassword(String) - Method in class bb.common.SGClientAccountVO

setPassword(String) - Method in class bb.common.SGClientLogin

setPassword(String) - Method in class bb.common.SgClientProgramUserVO

setPassword(String) - Method in class bb.common.SGQuoteAddressVO

setPassword(String) - Method in class bb.common.SmtpServerVO

setPassword(String) - Method in class bb.common.SubcompanyLoginAgent

setPassword(String) - Method in class bb.common.User2UserAgent

setPassword(String) - Method in class bb.common.VendorGroupUserVO

setPasswordEncrypt(boolean) - Method in class bb.common.CompanyVO

setPasswordEncrypt(Boolean) - Method in class bb.common.PasswordPolicyAgent

setPasswordLifetime(int) - Method in class bb.common.CompanyVO

setPasswordLifetime(Integer) - Method in class bb.common.PasswordPolicyAgent

setPasswordMinLength(int) - Method in class bb.common.CompanyVO

setPasswordMinLength(Integer) - Method in class bb.common.PasswordPolicyAgent

setPastDueAmount(BigDecimal) - Method in class bb.common.IncomeByMonthChartResult

setPastDueEcnCount(Integer) - Method in class bb.common.EngineeringInfoCenterResult

setPastDueNcrCount(Integer) - Method in class bb.common.QualityInfoCenterResult

setPastDueSalesAccount(BigDecimal) - Method in class bb.common.SalesInfoCenterResult

setPastDueSalesCount(Integer) - Method in class bb.common.SalesInfoCenterResult

setPastDueWOAccount(BigDecimal) - Method in class bb.common.WorkOrderInfoCenterResult

setPastDueWOCount(Integer) - Method in class bb.common.WorkOrderInfoCenterResult

setPath(String) - Method in class bb.common.TaskFileResult

setPausedTime(Date) - Method in class bb.common.OperatingInstructionsUserStatisticalResult

setPausedTime(Date) - Method in class bb.common.OperatingInstructionsVO

setPausedTimeByHour(BigDecimal) - Method in class bb.common.OperatingInstructionsUserStatisticalResult

setPausedTimeByHour(BigDecimal) - Method in class bb.common.OperatingInstructionsVO

setPayableMethod(String) - Method in class bb.common.RunningAccountOrderItemResult

setPayableMethod(String) - Method in class bb.common.RunningAccountOrderVO

setPayableMethodID(int) - Method in class bb.common.PayableMethodVO

setPayableMethodName(String) - Method in class bb.common.PayableMethodVO

setPayAmount(BigDecimal) - Method in class bb.common.PurchaseOrderContractResult

setPaybyVendorInvoiceTotal(boolean) - Method in class bb.common.APAuditListResult

setPayDate(Date) - Method in class bb.common.AccountPayableCheckRunItemVO

setPayDate(Date) - Method in class bb.common.AccountPayableInfoWithPrepayResult

setPayDate(Date) - Method in class bb.common.AccountReceivableInfoWithPrepayResult

setPayDate(Date) - Method in class bb.common.AccountsPayableInfoVO

setPayDate(Date) - Method in class bb.common.AccountsPayableVO

setPaydate(Date) - Method in class bb.common.AccountsReceivableInfoVO

setPaydate(Date) - Method in class bb.common.AccountsReceivableVO

setPayDate(Date) - Method in class bb.common.ApCheckRunListResult

setPayDate(Date) - Method in class bb.common.APItemListResult

setPayDate(Date) - Method in class bb.common.APPrepayInfoResult

setPayDate(Date) - Method in class bb.common.ArCommissionListResult

setPayDate(Date) - Method in class bb.common.ARPaymentRunItemVO

setPayDate(Date) - Method in class bb.common.ARPaymentRunListResult

setPayDate(Date) - Method in class bb.common.ARPrepayInfoResult

setPayDate(Date) - Method in class bb.common.InvoiceItemListResult

setPaydate(Date) - Method in class bb.common.OnloanReceiverVO

setPayDate(Date) - Method in class bb.common.OnloanShipperVO

setPaydate(Date) - Method in class bb.common.ProformaInvoiceVO

setPayDate(Date) - Method in class bb.common.PurchaseOrderContractResult

setPaydate(Date) - Method in class bb.common.ReceiverInfoVO

setPaydate(Date) - Method in class bb.common.ReceiverVO

setPaydate(Date) - Method in class bb.common.RMAReceiverVO

setPaydate(Date) - Method in class bb.common.RtvShipperInfoVO

setPaydate(Date) - Method in class bb.common.RtvShipperVO

setPayDate(Date) - Method in class bb.common.SalesTaxListResult

setPayDate(Date) - Method in class bb.common.ShipperInfoVO

setPayDate(Date) - Method in class bb.common.ShipperVO

setPayDate(Date) - Method in class bb.common.TempArApAgingVO

setPaymentAmount(BigDecimal) - Method in class bb.common.CustomerStatementResult

setPaymentID(int) - Method in class bb.common.PaymentVO

setPaymentInvoices(List<PaymentInvoicesResult>) - Method in class bb.common.CustomerStatementResult

setPaymentInvoices(List<GeneralLedgerVO>) - Method in class bb.common.PaymentInvoicesResult

setPaymentName(String) - Method in class bb.common.PaymentVO

setPaymentNeeded(BigDecimal) - Method in class bb.common.ExpenseVO

setPaymentNoInt(int) - Method in class bb.common.AccountReceivablePaymentVO

setPaymentNumber(String) - Method in class bb.common.AccountReceivablePaymentVO

setPaymentNumber(String) - Method in class bb.common.ARPaymentRunItemVO

setPaymentNumber(String) - Method in class bb.common.ARPaymentRunListResult

setPaymentNumber(String) - Method in class bb.common.ARPaymentRunVO

setPaymentRunItems(Set) - Method in class bb.common.ARPaymentRunVO

setPaymentRunNumber(String) - Method in class bb.common.AccountReceivablePaymentVO

setPaymentRunNumber(String) - Method in class bb.common.ARPaymentRunItemPK

setPaymentRunNumber(String) - Method in class bb.common.ARPaymentRunListResult

setPaymentRunNumber(String) - Method in class bb.common.ARPaymentRunVO

setPaymentVariance(BigDecimal) - Method in class bb.common.AccountsPayableVO

setPaymentVariance(BigDecimal) - Method in class bb.common.AccountsReceivableVO

setPaymentVarianceGL(String) - Method in class bb.common.AccountsReceivableVO

setPayMethod(String) - Method in class bb.common.PointOfSaleVO

setPayThisTotal(BigDecimal) - Method in class bb.common.MakeAccountPayableAgent

setPayThisTotal(BigDecimal) - Method in class bb.common.MakeDebitMemoAgent

setPBItem(PackingBoxItemVO) - Method in class bb.common.ProformaReceiverPackingBoxItemAgent

setPbItems(LinkedHashMap<PackingBoxPK, ArrayList<ProformaReceiverPackingBoxItemAgent>>) - Method in class bb.common.ProformaReceiverPackingBoxAgent

setPbs(LinkedHashMap<PackingBoxPK, PrPackingBoxVO>) - Method in class bb.common.ProformaReceiverPackingBoxAgent

setPCode(String) - Method in class bb.common.PartInventoryVO

setPcode(String) - Method in class bb.common.RollUPPartStandardCostResult

setPCode(String) - Method in class bb.common.ToolInventoryVO

setPctMargin(BigDecimal) - Method in class bb.common.SalesOrder12MonthMarginResult

setPercent(BigDecimal) - Method in class bb.common.AssetAmortizationExpenseAccountVO

setPercentage(Double) - Method in class bb.common.BalanceSheetSideBySideItemResult

setPerDayDiffAccount(String) - Method in class bb.common.PointOfSaleVO

setPeriod(int) - Method in class bb.common.PartClassVO

setPeriodBalance(BigDecimal) - Method in class bb.common.GlBalanceInfoResult

setPeriodBalance(Map<String, GlBalanceInfoResult>) - Method in class bb.common.GLInfoByPeriodResult

setPeriodCreditAmount(BigDecimal) - Method in class bb.common.GlBalanceInfoResult

setPeriodDC(String) - Method in class bb.common.GlBalanceInfoResult

setPeriodDebitAmount(BigDecimal) - Method in class bb.common.GlBalanceInfoResult

setPeriodNumber(BigDecimal) - Method in class bb.common.InventoryPartInOutDetailListResult

setPeriodTotalCost(BigDecimal) - Method in class bb.common.InventoryPartInOutDetailListResult

setPeriodUnit(String) - Method in class bb.common.EquipmentVO

setPeriodUnit(String) - Method in class bb.common.PartClassVO

setPermission(boolean) - Method in class bb.common.PermissionVO

setPermissionId(String) - Method in class bb.common.PermissionDescriptionPK

setPermissionId(String) - Method in class bb.common.PermissionListResult

setPermissionId(String) - Method in class bb.common.PermissionMethodPK

setPermissionId(String) - Method in class bb.common.PermissionVO

setPermissionId(String) - Method in class bb.common.RolePermissionPK

setPermissionId(String) - Method in class bb.common.UserRolePermissionListResult

setPermissionName(String) - Method in class bb.common.PermissionDescriptionVO

setPermissionName(String) - Method in class bb.common.PermissionListResult

setPermissionName(String) - Method in class bb.common.UserRolePermissionListResult

setPfInvoiceItemNumber(String) - Method in class bb.common.ProformaInvoiceItemListResult

setPfInvoiceItemNumber(String) - Method in class bb.common.ProformaInvoiceItemVO

setPfInvoiceNumber(String) - Method in class bb.common.AccountsReceivableInfoVO

setPfInvoiceNumber(String) - Method in class bb.common.AccountsReceivableVO

setPfInvoiceNumber(String) - Method in class bb.common.PackingBoxItemPK

setPfInvoiceNumber(String) - Method in class bb.common.PackingBoxPK

setPfInvoiceNumber(String) - Method in class bb.common.ProformaInvoiceItemListResult

setPfInvoiceNumber(String) - Method in class bb.common.ProformaInvoiceItemManufacturerPK

setPfInvoiceNumber(String) - Method in class bb.common.ProformaInvoiceItemPK

setPfInvoiceNumber(String) - Method in class bb.common.ProformaInvoiceVO

setPfInvoiceNumber(String) - Method in class bb.common.ShipperVO

setPfnumber(String) - Method in class bb.common.ProformaInvoiceListResult

setPfReceiverItemNumber(String) - Method in class bb.common.PfReceiverItemVO

setPfReceiverItemNumber(String) - Method in class bb.common.PfReceiverItemWithNumberPK

setPfReceiverNumber(String) - Method in class bb.common.PfReceiverItemPK

setPfReceiverNumber(String) - Method in class bb.common.PfReceiverVO

setPfReceiverNumber(String) - Method in class bb.common.PrPackingBoxItemPK

setPfReceiverNumber(String) - Method in class bb.common.PrPackingBoxPK

setPfVo(ProformaInvoiceVO) - Method in class bb.common.ProformaReceiverPackingBoxAgent

setPhone(String) - Method in class bb.common.BizBoxUserEmployeeResult

setPhone(String) - Method in class bb.common.CSRAgent

setPhone(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setPhone(String) - Method in class bb.common.CustomerVendorAddressVO

setPhone(String) - Method in class bb.common.CustomerVendorContactVO

setPhone(String) - Method in class bb.common.EmployeeCardVO

setPhone(String) - Method in class bb.common.ManufacturerAddressInfoVO

setPhone(String) - Method in class bb.common.ManufacturerAddressVO

setPhone(String) - Method in class bb.common.ManufacturerContactVO

setPhone(String) - Method in class bb.common.NoticeUserEmployeeListResult

setPhone(String) - Method in class bb.common.SalesmanVO

setPhone(String) - Method in class bb.common.SGCartCheckOutResult

setPhone(String) - Method in class bb.common.SgClientProgramUserVO

setPhone(String) - Method in class bb.common.SGCustomerServiceRequestVO

setPhone(String) - Method in class bb.common.SGCustRequestForQuoteListResult

setPhone(String) - Method in class bb.common.SGCustRequestForQuoteResult

setPhone(String) - Method in class bb.common.SGCustRequestForQuoteVO

setPhone(String) - Method in class bb.common.SGQuoteAddressResult

setPhone(String) - Method in class bb.common.SGQuoteAddressVO

setPhone(String) - Method in class bb.common.VendorGroupUserVO

setPhone2(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setPhone2(String) - Method in class bb.common.CustomerVendorAddressVO

setPhone2(String) - Method in class bb.common.ManufacturerAddressInfoVO

setPhone2(String) - Method in class bb.common.ManufacturerAddressVO

setPhoneExtension(String) - Method in class bb.common.SalesmanVO

setPhysicalCount(BigDecimal) - Method in class bb.common.CycleCountAgent

setPhysicalCount(BigDecimal) - Method in class bb.common.UpdatePhysicalInventoryAgent

setPhysicalInventoryDate(Date) - Method in class bb.common.CycleCountVO

setPhysicalInventoryDate(Date) - Method in class bb.common.PhysicalInventoryVO

setPi(String) - Method in class bb.common.ReturnToVendorItemVO

setPicker(String) - Method in class bb.common.DisassembleWorkOrderIssueVO

setPicker(String) - Method in class bb.common.IssueItemAgent

setPicker(String) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setPicker(String) - Method in class bb.common.NonproductivePickingItemIssuedVO

setPicker(String) - Method in class bb.common.PartIssuedVO

setPickingItemNumber(String) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setPickingItemNumber(String) - Method in class bb.common.NonproductivePickingItemIssuedVO

setPickingItemNumber(String) - Method in class bb.common.NonproductivePickingItemPK

setPickingItemNumber(String) - Method in class bb.common.NonproductivePickingItemResult

setPickingItems(Set<NonproductivePickingItemVO>) - Method in class bb.common.NonproductivePickingVO

setPickingNumber(String) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setPickingNumber(String) - Method in class bb.common.NonproductivePickingItemIssuedVO

setPickingNumber(String) - Method in class bb.common.NonproductivePickingItemPK

setPickingNumber(String) - Method in class bb.common.NonproductivePickingItemResult

setPickingNumber(String) - Method in class bb.common.NonproductivePickingVO

setPickListOrderNumber(String) - Method in class bb.common.InspectionReportInfoVO

setPickListOrderNumber(String) - Method in class bb.common.InspectionReportVO

setPickListOrderNumber(String) - Method in class bb.common.OperatingInstructionsVO

setPicture(byte[]) - Method in class bb.common.EmployeeCardVO

setPicture(byte[]) - Method in class bb.common.MiscDocAgent

setPicture(byte[]) - Method in class bb.common.PartDwfAgent

setPicture(byte[]) - Method in class bb.common.PartDwfVO

setPicture(byte[]) - Method in class bb.common.PartDwfWithPartInfoResult

setPicture(byte[]) - Method in class bb.common.PartDwgAgent

setPicture(byte[]) - Method in class bb.common.PartDwgVO

setPicture(byte[]) - Method in class bb.common.PartDwgWithPartInfoResult

setPicture(byte[]) - Method in class bb.common.PartPictureVO

setPicture(byte[]) - Method in class bb.common.SalesmanVO

setPicture(Blob) - Method in class bb.common.SGDwgPictureVO

setPicture(boolean) - Method in class bb.common.SGPartListItemResult

setPicture(boolean) - Method in class bb.common.SGPartListResult

setPicture(Blob) - Method in class bb.common.SGPictureVO

setPicture(byte[]) - Method in class bb.common.WorkInstructionPictureVO

setPictureLength(long) - Method in class bb.common.NCRPictureVO

setPictureName(String) - Method in class bb.common.NCRPictureVO

setPk(AccountCreditDebitPK) - Method in class bb.common.AccountCreditVO

setPk(AccountCreditDebitPK) - Method in class bb.common.AccountDebitVO

setPk(PayableCheckRunItemPK) - Method in class bb.common.AccountPayableCheckRunItemVO

setPk(AccountsChartMappingPK) - Method in class bb.common.AccountsChartMappingVO

setPk(AccountsPayableItemManufacturerPK) - Method in class bb.common.AccountsPayableItemManufacturerVO

setPk(AccountsPayableItemPK) - Method in class bb.common.AccountsPayableItemVO

setPk(AccountsReceivableItemManufacturerPK) - Method in class bb.common.AccountsReceivableItemManufacturerVO

setPk(AccountsReceivableItemPK) - Method in class bb.common.AccountsReceivableItemVO

setPk(PurchaseOrderItemPK) - Method in class bb.common.AddProformaReceiverItemAgent

setPk(AllPartDocumentsPK) - Method in class bb.common.AllPartDocumentsVO

setPk(ApPrepayItemPK) - Method in class bb.common.APPrepayInfoResult

setPk(ApPrepayItemPK) - Method in class bb.common.ApPrepayItemVO

setPk(ARPaymentRunItemPK) - Method in class bb.common.ARPaymentRunItemVO

setPk(ArPrepayItemPK) - Method in class bb.common.ARPrepayInfoResult

setPk(ArPrepayItemPK) - Method in class bb.common.ArPrepayItemVO

setPk(AssetAmortizationExpenseAccountPK) - Method in class bb.common.AssetAmortizationExpenseAccountVO

setPk(AssetDepreciatePK) - Method in class bb.common.AssetDepreciateVO

setPk(AssetUsagePK) - Method in class bb.common.AssetUsageVO

setPk(AccountMonthPK) - Method in class bb.common.BankReconciliationReportVO

setPk(SalesOrderItemPK) - Method in class bb.common.BB2PartInSipOfSoItemResult

setPk(TransferShipperItemPK) - Method in class bb.common.BB2PartInSTOItemResult

setPk(PartOnhandPK) - Method in class bb.common.BB2PartOnhandPK

setPk(OnloanShipperItemPK) - Method in class bb.common.BB2PartOnLoanItemResult

setPk(PartPK) - Method in class bb.common.BillItemUsagePathResult

setPk(BillItemPK) - Method in class bb.common.BillItemVO

setPk(BillPK) - Method in class bb.common.BillVO

setPk(PartPK) - Method in class bb.common.BOMCanAssyListResult

setPk(CarrierPK) - Method in class bb.common.CarrierVO

setPk(ChangeStdCostWorkSheetItemPK) - Method in class bb.common.ChangeStdCostWorkSheetItemVO

setPk(CompanyUnitAccountPK) - Method in class bb.common.CompanyUnitAccountVO

setPk(ContractPriceCustomerPK) - Method in class bb.common.ContractPriceCustomerVO

setPk(ContractPriceItemPK) - Method in class bb.common.ContractPriceItemVO

setPk(CurrencyExchangePK) - Method in class bb.common.CurrencyExchangeVO

setPk(CustomAssetRecordPK) - Method in class bb.common.CustomAssetRecordVO

setPk(CustomEmployeeTrainPK) - Method in class bb.common.CustomEmployeeTrainVO

setPk(CustomEmployeeTrainPK) - Method in class bb.common.CustomEmployeeWorkExperienceVO

setPk(ArPrepayItemPK) - Method in class bb.common.CustomerPrepayStatementListResult

setPk(CustomerReturnToVendorItemPK) - Method in class bb.common.CustomerReturnToVendorItemVO

setPk(CustomerVendorContactPK) - Method in class bb.common.CustomerVendorContactVO

setPk(CustomerVendorDescriptionPK) - Method in class bb.common.CustomerVendorDescriptionVO

setPk(CustomJobCategoryGoodsPK) - Method in class bb.common.CustomJobCategoryGoodsVO

setPk(CycleCountPK) - Method in class bb.common.CycleCountAgent

setPk(CycleCountPK) - Method in class bb.common.CycleCountListResult

setPk(CycleCountPK) - Method in class bb.common.CycleCountVO

setPk(DisassembleWorkOrderItemReceiverPK) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

setPk(DisassembleWorkOrderItemPK) - Method in class bb.common.DisassembleWorkOrderItemVO

setPk(EmployeeEducationPK) - Method in class bb.common.EmployeeEducationVO

setPk(EmployeeWorkExperiencePK) - Method in class bb.common.EmployeeTrainingVO

setPk(EmployeeWorkExperiencePK) - Method in class bb.common.EmployeeWorkExperienceVO

setPk(EngGroupUserPK) - Method in class bb.common.EngGroupUserVO

setPk(EngineeringSharingItemPK) - Method in class bb.common.EngineeringSharingItemVO

setPk(ExpenseItemPK) - Method in class bb.common.ExpenseItemVO

setPk(FeedbackAnswerPK) - Method in class bb.common.FeedbackAnswerVO

setPk(FeedBackItemPK) - Method in class bb.common.FeedbackItemVO

setPk(AccountMonthPK) - Method in class bb.common.GlCashFlowBudgetVO

setPk(AccountMonthPK) - Method in class bb.common.GlFiscalYearBudgetVO

setPk(AccountCreditDebitPK) - Method in class bb.common.GLItemVO

setPk(GroupUserPK) - Method in class bb.common.GroupUserVO

setPk(PartPK) - Method in class bb.common.InSipAudittListResult

setPk(InspectionConformanceReportItemCheckPK) - Method in class bb.common.InspectionConformanceReportItemCheckVO

setPk(InspectionConformanceReportItemPK) - Method in class bb.common.InspectionConformanceReportItemVO

setPk(InspectionItemPK) - Method in class bb.common.InspectionItemVO

setPk(InspectionReportInspectMethodItemPK) - Method in class bb.common.InspectionReportInspectMethodItemVO

setPk(InspectionReportInspectStandardItemPK) - Method in class bb.common.InspectionReportInspectStandardItemVO

setPk(InspectionReportItemQtyPK) - Method in class bb.common.InspectionReportItemQtyVO

setPk(InspectionReportItemPK) - Method in class bb.common.InspectionReportItemVO

setPk(InspectionTypeItemPK) - Method in class bb.common.InspectionTypeItemVO

setPk(LabelTemplateItemPK) - Method in class bb.common.LabelTemplateItemVO

setPk(LogMethodPK) - Method in class bb.common.LogMethodVO

setPk(MaintenanceItemPK) - Method in class bb.common.MaintenanceItemVO

setPk(ManufacturerContactPK) - Method in class bb.common.ManufacturerContactVO

setPk(ManufacturerDescriptionPK) - Method in class bb.common.ManufacturerDescriptionVO

setPk(MultiLanguageAccountsChartPK) - Method in class bb.common.MultiLanguageAccountsChartVO

setPk(MyPrintListPK) - Method in class bb.common.MyPrintListVO

setPk(NcrApprovalPK) - Method in class bb.common.NcrApprovalVO

setPk(PartOnhandPK) - Method in class bb.common.NCRPartOnhandPK

setPk(NonConformanceCodeDescriptionPK) - Method in class bb.common.NonConformanceCodeDescriptionVO

setPk(NonConformanceQuantityPK) - Method in class bb.common.NonConformanceQuantityVO

setPk(NonproductivePickingItemPK) - Method in class bb.common.NonproductivePickingItemVO

setPk(NonproductivePickingItemPK) - Method in class bb.common.NonproductivePickingOnDemandResult

setPk(OnLoanItemPK) - Method in class bb.common.OnLoanItemVO

setPk(OnloanReceiverItemPK) - Method in class bb.common.OnloanReceiverItemVO

setPk(OnloanShipperItemPK) - Method in class bb.common.OnloanShipperItemVO

setPk(OperatingInstructionsInspectMethodItemPK) - Method in class bb.common.OperatingInstructionsInspectMethodItemVO

setPk(OperatingInstructionsInspectResultItemPK) - Method in class bb.common.OperatingInstructionsInspectResultItemVO

setPk(OperatingInstructionsInspectStandardItemPK) - Method in class bb.common.OperatingInstructionsInspectStandardItemVO

setPk(OperatingInstructionsManualItemPK) - Method in class bb.common.OperatingInstructionsManualItemVO

setPk(OperatingOutputFileItemPK) - Method in class bb.common.OperatingOutputFileItemVO

setPk(OrderBoilerplatePK) - Method in class bb.common.OrderBoilerplateVO

setPk(OrderPK) - Method in class bb.common.OrderVendorItem

setPk(PackingBoxItemPK) - Method in class bb.common.PackingBoxItemVO

setPk(PackingBoxPK) - Method in class bb.common.PackingBoxVO

setPk(PartCatagoryPK) - Method in class bb.common.PartCatagoryVO

setPk(PartCatalogPK) - Method in class bb.common.PartCatalogVO

setPk(PartDescriptionPK) - Method in class bb.common.PartDescriptionVO

setPk(PartDiscountPK) - Method in class bb.common.PartDiscountVO

setPk(PartDocumentPK) - Method in class bb.common.PartDocumentVO

setPk(PartDwfPK) - Method in class bb.common.PartDwfVO

setPk(PartDwgPK) - Method in class bb.common.PartDwgVO

setPk(PartInspectionPK) - Method in class bb.common.PartInspectionVO

setPk(PartPK) - Method in class bb.common.PartInventoryVO

setPk(PartManufacturerPK) - Method in class bb.common.PartManufacturerVO

setPk(PartPK) - Method in class bb.common.PartMaterialVO

setPk(PartPK) - Method in class bb.common.PartMRPVO

setPk(PartPK) - Method in class bb.common.PartOnHandAuditResult

setPk(PartOnhandPK) - Method in class bb.common.PartOnhandVO

setPk(PartPK) - Method in class bb.common.PartToAuditFlagResult

setPk(PartTraceableCategoryPK) - Method in class bb.common.PartTraceableCategoryVO

setPk(PartTraceableSpecPK) - Method in class bb.common.PartTraceableSpecVO

setPk(PartTrackingPK) - Method in class bb.common.PartTrackingVO

setPk(PartUnitPK) - Method in class bb.common.PartUnitVO

setPk(PartVendorPK) - Method in class bb.common.PartVendorVO

setPk(PartPK) - Method in class bb.common.PartVO

setPk(BillItemPK) - Method in class bb.common.PartWhereUsedItemResult

setPk(PartPK) - Method in class bb.common.PartWithOnhandsVO

setPk(PermissionDescriptionPK) - Method in class bb.common.PermissionDescriptionVO

setPk(PermissionMethodPK) - Method in class bb.common.PermissionMethodVO

setPk(PfReceiverItemPK) - Method in class bb.common.PfReceiverItemVO

setPk(PfReceiverItemPK) - Method in class bb.common.PfReceiverItemWithNumberPK

setPk(PhysicalInventoryPK) - Method in class bb.common.PhysicalInventoryListResult

setPk(PhysicalInventoryPK) - Method in class bb.common.PhysicalInventoryVO

setPk(PoMessageItemPK) - Method in class bb.common.PoMessageItemVO

setPk(POSurveyReportItemPK) - Method in class bb.common.POSurveyReportItemVO

setPk(PosZipCodeTaxPK) - Method in class bb.common.PosZipCodeTaxVO

setPk(ProformaInvoiceItemManufacturerPK) - Method in class bb.common.ProformaInvoiceItemManufacturerVO

setPk(ProformaInvoiceItemPK) - Method in class bb.common.ProformaInvoiceItemVO

setPk(PrPackingBoxItemPK) - Method in class bb.common.PrPackingBoxItemVO

setPk(PrPackingBoxPK) - Method in class bb.common.PrPackingBoxVO

setPk(WorkOrderItemIssuePK) - Method in class bb.common.PullFromWorkOrderPartDetailAgent

setPk(PurchaseOrderItemManufacturerPK) - Method in class bb.common.PurchaseOrderItemManufacturerVO

setPk(PurchaseOrderItemPK) - Method in class bb.common.PurchaseOrderItemVO

setPk(PurchaseWorkSheetItemPK) - Method in class bb.common.PurchaseWorkSheetItemVO

setPk(PurchaseWorkSheetPK) - Method in class bb.common.PurchaseWorkSheetVO

setPk(QualityGroupPK) - Method in class bb.common.QualityGroupVO

setPk(QuoteItemManufacturerPK) - Method in class bb.common.QuoteItemManufacturerVO

setPk(QuoteItemPK) - Method in class bb.common.QuoteItemVO

setPk(ReceiverItemManufacturerPK) - Method in class bb.common.ReceiverItemManufacturerVO

setPk(ReceiverItemPK) - Method in class bb.common.ReceiverItemVO

setPk(PartPK) - Method in class bb.common.RecursiveBillPath

setPk(RequestForQuoteItemManufacturerPK) - Method in class bb.common.RequestForQuoteItemManufacturerVO

setPk(RequestForQuoteItemPK) - Method in class bb.common.RequestForQuoteItemVO

setPk(RequestForRMAItemPK) - Method in class bb.common.RequestForRMAItemVO

setPk(ReturnMaterialAuthorizationItemManufacturerPK) - Method in class bb.common.ReturnMaterialAuthorizationItemManufacturerVO

setPk(ReturnMaterialAuthorizationItemPK) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setPk(ReturnToVendorItemManufacturerPK) - Method in class bb.common.ReturnToVendorItemManufacturerVO

setPk(ReturnToVendorItemPK) - Method in class bb.common.ReturnToVendorItemVO

setPk(RfqMessageItemPK) - Method in class bb.common.RfqMessageItemVO

setPk(RMAReceiverItemPK) - Method in class bb.common.RMAReceiverItemVO

setPk(ReturnMaterialAuthorizationItemPK) - Method in class bb.common.RMAReceiverResult

setPk(RoleDescriptionPK) - Method in class bb.common.RoleDescriptionVO

setPk(RolePermissionPK) - Method in class bb.common.RolePermissionVO

setPk(RollUpBomStdCostWorkSheetItemPK) - Method in class bb.common.RollUpBomStdCostWorkSheetItemVO

setPk(PartPK) - Method in class bb.common.RollUPPartStandardCostResult

setPk(RtvShipperItemPK) - Method in class bb.common.RtvShipperItemVO

setPk(RunningAccountOrderItemPK) - Method in class bb.common.RunningAccountOrderItemVO

setPk(SalesOrderItemPK) - Method in class bb.common.SalesOrderItemInfoVO

setPk(SalesOrderItemManufacturerPK) - Method in class bb.common.SalesOrderItemManufacturerVO

setPk(SalesOrderItemPK) - Method in class bb.common.SalesOrderItemVO

setPk(SalesOrderItemPK) - Method in class bb.common.SalesOrderShipDateListResult

setPk(SerialNumberItemPK) - Method in class bb.common.SerialNumberItemVO

setPk(SerialNumberPK) - Method in class bb.common.SerialNumberVO

setPk(ServerClientPropertyPK) - Method in class bb.common.ServerClientPropertyVO

setPk(SGBillItemPK) - Method in class bb.common.SGBillItemVO

setPk(SGClientAccountPK) - Method in class bb.common.SGClientAccountVO

setPk(SGCompanyPK) - Method in class bb.common.SGCompanyVO

setPk(SGCustomerCatalogPK) - Method in class bb.common.SGCustomerCatalogVO

setPk(SGCustRequestForQuoteItemPK) - Method in class bb.common.SGCustRequestForQuoteItemResult

setPk(SGCustRequestForQuoteItemPK) - Method in class bb.common.SGCustRequestForQuoteItemVO

setPk(SGDocPartPK) - Method in class bb.common.SGDocPartVO

setPk(SGDwgPicturePK) - Method in class bb.common.SGDwgPictureVO

setPk(SGPicturePK) - Method in class bb.common.SGPictureVO

setPk(SalesOrderItemPK) - Method in class bb.common.ShipListItemRelatedDocResult

setPk(ShipListItemPK) - Method in class bb.common.ShipListItemVO

setPk(ShipListItemPK) - Method in class bb.common.ShipListItemVOResult

setPk(ShipListOwnerAttributePK) - Method in class bb.common.ShipListOwnerAttributeVO

setPk(ShipperItemManufacturerPK) - Method in class bb.common.ShipperItemManufacturerVO

setPk(ShipperItemPK) - Method in class bb.common.ShipperItemVO

setPk(SwapOrderItemPK) - Method in class bb.common.SwapOrderItemVO

setPk(SwapReceiverItemPK) - Method in class bb.common.SwapReceiverItemVO

setPk(SwapShipperItemPK) - Method in class bb.common.SwapShipperItemVO

setPk(PartDescriptionPK) - Method in class bb.common.ToolDescriptionVO

setPk(PartPK) - Method in class bb.common.ToolInventoryVO

setPk(BillPK) - Method in class bb.common.ToolListInfoVO

setPk(BillItemPK) - Method in class bb.common.ToolListItemVO

setPk(BillPK) - Method in class bb.common.ToolListVO

setPk(PartManufacturerPK) - Method in class bb.common.ToolManufacturerVO

setPk(PartOnhandPK) - Method in class bb.common.ToolOnhandVO

setPk(PartVendorPK) - Method in class bb.common.ToolVendorVO

setPk(PartPK) - Method in class bb.common.ToolVO

setPk(BillItemPK) - Method in class bb.common.ToolWhereUsedItemResult

setPk(PartPK) - Method in class bb.common.ToolWithOnhandsVO

setPk(TransferOrderItemPK) - Method in class bb.common.TransferOrderItemVO

setPk(TransferReceiverItemPK) - Method in class bb.common.TransferReceiverItemVO

setPk(TransferShipperItemPK) - Method in class bb.common.TransferShipperItemVO

setPk(PhysicalInventoryPK) - Method in class bb.common.UpdatePhysicalInventoryAgent

setPk(VendorContractPriceItemPK) - Method in class bb.common.VendorContractPriceItemVO

setPk(VendorContractPriceVendorPK) - Method in class bb.common.VendorContractPriceVendorVO

setPk(VendorPartPK) - Method in class bb.common.VendorPartVO

setPk(ApPrepayItemPK) - Method in class bb.common.VendorPrepayStatementListResult

setPk(VendorQtyPricePK) - Method in class bb.common.VendorQtyPriceVO

setPk(WarehouseTransferPK) - Method in class bb.common.WarehouseTransferVO

setPk(WorkOrderWorkInstructionSequencePK) - Method in class bb.common.WCLoadByDateResult

setPk(WorkOrderItemPK) - Method in class bb.common.WOItemCostControlAgent

setPk(WorkCenterGroupItemPK) - Method in class bb.common.WorkCenterGroupItemVO

setPk(WorkCenterVendorPK) - Method in class bb.common.WorkCenterVendorVO

setPk(WorkInstructionSequencePK) - Method in class bb.common.WorkInstructionSequenceVO

setPk(WorkInstructionPK) - Method in class bb.common.WorkInstructionVO

setPk(WorkOrderItemPK) - Method in class bb.common.WorkOrderItemCanAssyResult

setPk(WorkOrderItemIssuePK) - Method in class bb.common.WorkOrderItemIssueVO

setPk(WorkOrderItemPK) - Method in class bb.common.WorkOrderItemReviewCostResult

setPk(WorkOrderItemPK) - Method in class bb.common.WorkOrderItemSeqWCLoadResult

setPk(WorkOrderItemPK) - Method in class bb.common.WorkOrderItemToIssueResult

setPk(WorkOrderItemPK) - Method in class bb.common.WorkOrderItemVO

setPk(WorkOrderItemPK) - Method in class bb.common.WorkOrderItemWCLoadResult

setPk(WorkOrderWorkInstructionSequencePK) - Method in class bb.common.WorkOrderWorkInstructionSequenceDateAgent

setPk(WorkOrderWorkInstructionSequencePK) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setPk(WorkOrderWorkInstructionPK) - Method in class bb.common.WorkOrderWorkInstructionVO

setPk(WorkOrderItemPK) - Method in class bb.common.WorkOrderWorkItemDateAgent

setPk(WorkOrderWorkSheetItemPK) - Method in class bb.common.WorkOrderWorkSheetItemVO

setPk(WorkOrderWorkSheetPK) - Method in class bb.common.WorkOrderWorkSheetVO

setPlAccountNumber(String) - Method in class bb.common.ProfitAndLossAccountsResult

setPlace(String) - Method in class bb.common.CustomEmployeeTrainVO

setPlace(String) - Method in class bb.common.EmployeeTrainingVO

setPlace(String) - Method in class bb.common.IncotermVO

setPlacePort(String) - Method in class bb.common.ShippingResult

setPlDescription(String) - Method in class bb.common.ProfitAndLossAccountsResult

setPleaseRespondBy(Date) - Method in class bb.common.RequestForQuoteVO

setPmList(List) - Method in class bb.common.WOItemPartDetailNotIssue

setPmtMethod(String) - Method in class bb.common.DepositSummaryResult

setPo(String) - Method in class bb.common.DisassembleWorkOrderVO

setPo(String) - Method in class bb.common.ReturnToVendorByDateListResult

setPo(String) - Method in class bb.common.ReturnToVendorVO

setPo(String) - Method in class bb.common.WorkOrderVO

setPoAcceptEmployee(String) - Method in class bb.common.POSurveyReportVO

setPoBoilerplate(String) - Method in class bb.common.PurchaseOrderBoilerplateVO

setPoBoilerplate(String) - Method in class bb.common.PurchaseOrderVO

setPoClass(String) - Method in class bb.common.AppColumnVO

setPoClass(String) - Method in class bb.common.DataFilterVO

setPoDate(Date) - Method in class bb.common.PO2SOExchange

setPoDate(Date) - Method in class bb.common.POStatisticsResult

setPoDate(Date) - Method in class bb.common.PurchaseOrderCheckListResult

setPoDate(Date) - Method in class bb.common.PurchaseOrderItemListResult

setPoDate(Date) - Method in class bb.common.PurchaseOrderListResult

setPoDate(Date) - Method in class bb.common.PurchaseOrderOpenDueListResult

setPoDate(Date) - Method in class bb.common.PurchaseOrderVO

setPoDebitAccount(String) - Method in class bb.common.AccountingSettingsVO

setPoDetails(ArrayList) - Method in class bb.common.BB2PartTotalOnorderDetailResult

setPoDigits(byte) - Method in class bb.common.CompanyVO

setPoGrandTotal(BigDecimal) - Method in class bb.common.AccountsPayableVO

setPoItem(PurchaseOrderItemVO) - Method in class bb.common.PoMessageItemVO

setPoItemDescription(String) - Method in class bb.common.PurchaseOrderOpenDueListResult

setPoItemNumber(String) - Method in class bb.common.POReceiverItemListResult

setPoItemNumber(String) - Method in class bb.common.PrReceiverWithQualityListResult

setPoItemNumber(String) - Method in class bb.common.PurchaseOrderItemListResult

setPoItemNumber(String) - Method in class bb.common.PurchaseOrderOpenDueListResult

setPoItemNumber(String) - Method in class bb.common.ReceiverItemVO

setPoItemNumber(String) - Method in class bb.common.ReturnToVendorItemListResult

setPoItemPk(List<PurchaseOrderItemPK>) - Method in class bb.common.AddRTVAgent

setPoItemPk(PurchaseOrderItemPK) - Method in class bb.common.EcnPOOrderResult

setPOItems(LinkedHashSet<PurchaseOrderItemPK>) - Method in class bb.common.ProformaReceiverPackingBoxItemAgent

setPoItemShipDate(Date) - Method in class bb.common.ReceivingItemResult

setPoItemStatus(String) - Method in class bb.common.PurchaseOrderItemListResult

setPolityVisage(String) - Method in class bb.common.CustomEmployeeVO

setPoMail(boolean) - Method in class bb.common.CustomerVendorContactVO

setPoMessageDate(Date) - Method in class bb.common.PoMessageListResult

setPoMessageDate(Date) - Method in class bb.common.PoMessageVO

setPoMessageNumber(String) - Method in class bb.common.PoMessageItemPK

setPoMessageNumber(String) - Method in class bb.common.PoMessageListResult

setPoMessageNumber(String) - Method in class bb.common.PoMessageVO

setPoNotApprovedOnOrderList(ArrayList) - Method in class bb.common.MrpItemResult

setPoNumber(String) - Method in class bb.common.AccountPayableCheckRunItemVO

setPoNumber(String) - Method in class bb.common.AccountPayableInfoWithPrepayResult

setPoNumber(String) - Method in class bb.common.AccountsPayableInfoVO

setPoNumber(String) - Method in class bb.common.AccountsPayableItemVO

setPoNumber(String) - Method in class bb.common.AccountsPayableVO

setPoNumber(String) - Method in class bb.common.ApCheckRunListResult

setPoNumber(String) - Method in class bb.common.APPrepayInfoResult

setPoNumber(String) - Method in class bb.common.ApPrepayItemVO

setPoNumber(String) - Method in class bb.common.ARPaymentRunItemVO

setPoNumber(String) - Method in class bb.common.GeneralLedgerByDateListResult

setPoNumber(String) - Method in class bb.common.MakeCheckAgent

setPoNumber(String) - Method in class bb.common.MiscDocAgent

setPoNumber(String) - Method in class bb.common.NcrReportListResult

setPoNumber(String) - Method in class bb.common.PO2POAgent

setPoNumber(String) - Method in class bb.common.PoMessageItemVO

setPoNumber(String) - Method in class bb.common.PoMessageListResult

setPoNumber(String) - Method in class bb.common.PoMessageVO

setPoNumber(String) - Method in class bb.common.POReceiverItemListResult

setPoNumber(String) - Method in class bb.common.POStatisticsResult

setPoNumber(String) - Method in class bb.common.POSurveyReportAgent

setPoNumber(String) - Method in class bb.common.PrReceiverWithQualityListResult

setPoNumber(String) - Method in class bb.common.PurchaseOrderCheckListResult

setPoNumber(String) - Method in class bb.common.PurchaseOrderDocumentVO

setPoNumber(String) - Method in class bb.common.PurchaseOrderItemListResult

setPoNumber(String) - Method in class bb.common.PurchaseOrderListResult

setPoNumber(String) - Method in class bb.common.PurchaseOrderOpenDueListResult

setPoNumber(String) - Method in class bb.common.ReturnToVendorCheckListResult

setPoNumber(String) - Method in class bb.common.ReturnToVendorListResult

setPoNumber(String) - Method in class bb.common.RtvShipperInfoVO

setPoNumber(String) - Method in class bb.common.RtvShipperItemListResult

setPoNumber(String) - Method in class bb.common.RtvShipperListResult

setPoNumber(String) - Method in class bb.common.RtvShipperVO

setPoNumber(String) - Method in class bb.common.RunningAccountOrderItemResult

setPoNumber(String) - Method in class bb.common.RunningAccountOrderVO

setPoNumber(String) - Method in class bb.common.ScrapReportVO

setPoNumber(String) - Method in class bb.common.SerialNumberResult

setPoNumber(String) - Method in class bb.common.StockTransactionPOReceiverResult

setPoNumber(String) - Method in class bb.common.TempArApAgingVO

setPoOnOrderList(ArrayList) - Method in class bb.common.MrpItemOrderDemandRecordsResult

setPoOnOrderList(ArrayList) - Method in class bb.common.MrpItemResult

setPoOrderItems(Set) - Method in class bb.common.EcnCheckOrderResult

setPoPastDue(BigDecimal) - Method in class bb.common.CashFlowByMonthReportResult

setPoPrefix(String) - Method in class bb.common.CompanyVO

setPoPrice(BigDecimal) - Method in class bb.common.RunningAccountOrderItemVO

setPoPriceProfit(BigDecimal) - Method in class bb.common.RunningAccountOrderItemVO

setPoPriceProfitPercent(BigDecimal) - Method in class bb.common.RunningAccountOrderItemVO

setPopup(boolean) - Method in class bb.common.BB2Event

setPoQty(BigDecimal) - Method in class bb.common.OrderApprovalItemsVO

setPoQty(BigDecimal) - Method in class bb.common.PartVendorVO

setPoQty(BigDecimal) - Method in class bb.common.PurchaseOrderOpenDueListResult

setPoQty(BigDecimal) - Method in class bb.common.ToolVendorVO

setPoReceived(BigDecimal) - Method in class bb.common.POReceiverItemListResult

setPoRecQty(BigDecimal) - Method in class bb.common.AccountsPayableItemVO

setPoRelateDoc(String) - Method in class bb.common.LogInventoryListResult

setPoRequestionNumber(String) - Method in class bb.common.PurchaseOrderVO

setPort(String) - Method in class bb.common.BizBoxServer

setPort(String) - Method in class bb.common.OperationLogVO

setPort(int) - Method in class bb.common.SmtpServerVO

setPort(String) - Method in class bb.common.SubcompanyLoginAgent

setPort(String) - Method in class bb.common.SubcompanyVO

setPortraitOrientation(boolean) - Method in class bb.common.LabelTemplateVO

setPoShipDate(Date) - Method in class bb.common.POReceiverItemListResult

setPosition(String) - Method in class bb.common.CustomEmployeeVO

setPosition(String) - Method in class bb.common.EmployeeCardVO

setPosition(String) - Method in class bb.common.ExpenseVO

setPositionLevel(String) - Method in class bb.common.CustomEmployeeVO

setPosOnhand(BigDecimal) - Method in class bb.common.PartOnHandWithPartBasicInfoResult

setPoStatus(Collection) - Method in class bb.common.POAndWOStatusResult

setPoStatus(String) - Method in class bb.common.PurchaseOrderListResult

setPosted(boolean) - Method in class bb.common.GeneralLedgerVO

setPosted(boolean) - Method in class bb.common.JounalEntryListResult

setPostedBy(String) - Method in class bb.common.GeneralLedgerPrintResult

setPostedBy(String) - Method in class bb.common.GeneralLedgerVO

setPoSurveyReportItem(Set<POSurveyReportItemVO>) - Method in class bb.common.POSurveyReportAgent

setPoSurveyReportItem(Set<POSurveyReportItemVO>) - Method in class bb.common.POSurveyReportVO

setPoTotal(BigDecimal) - Method in class bb.common.ApPrepayVO

setPoType(String) - Method in class bb.common.PurchaseOrderVO

setPoUnit(String) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setPoUnit(String) - Method in class bb.common.OrderApprovalItemsVO

setPoUnit(String) - Method in class bb.common.PartVendorVO

setPoUnit(String) - Method in class bb.common.PurchaseOrderItemVO

setPoUnit(String) - Method in class bb.common.ReceivingItemResult

setPoUnit(String) - Method in class bb.common.ReturnToVendorItemVO

setPoUnit(String) - Method in class bb.common.ShippingItemResult

setPoUnit(String) - Method in class bb.common.ToolVendorVO

setPoUnitQty(BigDecimal) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setPoUnitQty(BigDecimal) - Method in class bb.common.PurchaseOrderItemVO

setPoUnitQty(BigDecimal) - Method in class bb.common.ReceivingItemResult

setPoUnitQty(BigDecimal) - Method in class bb.common.ReturnToVendorItemVO

setPoUnitQty(BigDecimal) - Method in class bb.common.ShippingItemResult

setPoUnitRate(BigDecimal) - Method in class bb.common.OrderApprovalItemsVO

setPoUnitRate(BigDecimal) - Method in class bb.common.PurchaseOrderItemVO

setPoVAT(String) - Method in class bb.common.AccountingSettingsVO

setPoVender(String) - Method in class bb.common.LogInventoryListResult

setPoweredBy(String) - Method in class bb.common.CompanyVO

setPoweredBy(String) - Method in class bb.common.SGCompanyVO

setPowerUnit(String) - Method in class bb.common.EquipmentVO

setPp(String) - Method in class bb.common.AccountReceivablePaymentVO

setPqty(BigDecimal) - Method in class bb.common.WorkOrderItemTimeDetailVO

setPrapayItemNumber(String) - Method in class bb.common.PrepayPaymentAgent

setPrDate(Date) - Method in class bb.common.AddProformaReceiverAgent

setPrDate(Date) - Method in class bb.common.PfReceiverVO

setPredefined(boolean) - Method in class bb.common.AccountsChartCategoryVO

setPreferred(boolean) - Method in class bb.common.PartVendorVO

setPreferred(boolean) - Method in class bb.common.ToolVendorVO

setPreferredPo(boolean) - Method in class bb.common.PartManufacturerVO

setPreferredPo(boolean) - Method in class bb.common.ToolManufacturerVO

setPreferredSo(boolean) - Method in class bb.common.PartManufacturerVO

setPreferredSo(boolean) - Method in class bb.common.ToolManufacturerVO

setPrepayAmountPaid(BigDecimal) - Method in class bb.common.AllStatementsListResult

setPrepayApply(BigDecimal) - Method in class bb.common.AllStatementsListResult

setPrepayApply(boolean) - Method in class bb.common.MakeAccountPayableAgent

setPrepayApply(boolean) - Method in class bb.common.MakeBillAndHoldInvoiceAgent

setPrepayApply(boolean) - Method in class bb.common.MakeInvoiceAgent

setPrepayApplyPoNumbers(ArrayList<String>) - Method in class bb.common.MakeAccountPayableAgent

setPrepayApplySoNumbers(ArrayList<String>) - Method in class bb.common.MakeInvoiceAgent

setPrepayBalenceDue(BigDecimal) - Method in class bb.common.AllStatementsListResult

setPrepayCurrency(String) - Method in class bb.common.AllStatementsListResult

setPrepayNumber(String) - Method in class bb.common.PrepayPaymentAgent

setPrepayTotalDue(BigDecimal) - Method in class bb.common.AllStatementsListResult

setPreventiveActionRequestItems(Set) - Method in class bb.common.PreventiveActionRequestVO

setPreviousInspection(Date) - Method in class bb.common.ToolCalibrationVO

setPreviousMonthTotal(BigDecimal) - Method in class bb.common.ClosingStatementTotalResult

setPreviousMonthYear(String) - Method in class bb.common.ClosingStatementResult

setPrice(BigDecimal) - Method in class bb.common.RMAReceiverItemVO

setPrice(BigDecimal) - Method in class bb.common.RunningAccountOrderItemVO

setPrice(Money) - Method in class bb.common.VendorPriceAgent

setPrice(BigDecimal) - Method in class bb.common.VendorQtyPriceVO

setPricePerUnit(BigDecimal) - Method in class bb.common.OnLoanItemListResult

setPricePerUnit(BigDecimal) - Method in class bb.common.OnLoanItemVO

setPricePerUnit(BigDecimal) - Method in class bb.common.QuoteItemListResult

setPricePerUnit(BigDecimal) - Method in class bb.common.QuoteItemVO

setPricePerUnit(BigDecimal) - Method in class bb.common.SalesOrderItemInfoVO

setPricePerUnit(BigDecimal) - Method in class bb.common.SalesOrderItemListResult

setPricePerUnit(BigDecimal) - Method in class bb.common.SalesOrderItemVO

setPrincipal(String) - Method in class bb.common.CustomAssetVO

setPrintAmount(int) - Method in class bb.common.PointOfSaleVO

setPrintBarCodeForOrder(boolean) - Method in class bb.common.CompanyVO

setPrintedBoardNumber(String) - Method in class bb.common.InspectionReportInfoVO

setPrintedBoardNumber(String) - Method in class bb.common.InspectionReportVO

setPrintInvoice(boolean) - Method in class bb.common.CustomerVendorAddressInfoVO

setPrintInvoice(boolean) - Method in class bb.common.CustomerVendorAddressVO

setPrintReturnNumber(String) - Method in class bb.common.RunningAccountOrderVO

setPriority(String) - Method in class bb.common.BizboxBugInfoVO

setPriority(String) - Method in class bb.common.BizboxBugVO

setPriority(String) - Method in class bb.common.CSRAgent

setPriority(String) - Method in class bb.common.CustomerReturnToVendorItemVO

setPriority(String) - Method in class bb.common.CustomerReturnToVendorVO

setPriority(String) - Method in class bb.common.CustomerServiceIncidentItemListResult

setPriority(String) - Method in class bb.common.CustomerServiceIncidentListResult

setPriority(String) - Method in class bb.common.CustomerServiceIncidentVO

setPriority(String) - Method in class bb.common.DisassembleWorkOrderItemListResult

setPriority(String) - Method in class bb.common.DisassembleWorkOrderItemVO

setPriority(String) - Method in class bb.common.DisassembleWorkOrderListResult

setPriority(String) - Method in class bb.common.DisassembleWorkOrderVO

setPriority(String) - Method in class bb.common.OnLoanItemVO

setPriority(String) - Method in class bb.common.OnLoanVO

setPriority(String) - Method in class bb.common.PurchaseOrderItemVO

setPriority(String) - Method in class bb.common.PurchaseOrderVO

setPriority(String) - Method in class bb.common.QuoteItemVO

setPriority(String) - Method in class bb.common.QuoteVO

setPriority(String) - Method in class bb.common.RequestForQuoteItemVO

setPriority(String) - Method in class bb.common.RequestForQuoteVO

setPriority(String) - Method in class bb.common.RequestForRMAItemVO

setPriority(String) - Method in class bb.common.RequestForRMAVO

setPriority(String) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setPriority(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setPriority(String) - Method in class bb.common.ReturnToVendorItemVO

setPriority(String) - Method in class bb.common.ReturnToVendorVO

setPriority(String) - Method in class bb.common.SalesOrderItemInfoVO

setPriority(String) - Method in class bb.common.SalesOrderItemVO

setPriority(String) - Method in class bb.common.SalesOrderVO

setPriority(String) - Method in class bb.common.SGCustomerServiceRequestVO

setPriority(String) - Method in class bb.common.WorkOrderCheckListResult

setPriority(String) - Method in class bb.common.WorkOrderItemListResult

setPriority(String) - Method in class bb.common.WorkOrderItemVO

setPriority(String) - Method in class bb.common.WorkOrderListResult

setPriority(String) - Method in class bb.common.WorkOrderVO

setPriorPeriod(BigDecimal) - Method in class bb.common.ProfitLossStatementItemResult

setPriorPeriodFrom(Date) - Method in class bb.common.AccountingInfoDocumentVO

setPriorPeriodFrom(Date) - Method in class bb.common.MiscDocAgent

setPriorPeriodFrom(Date) - Method in class bb.common.ProfitLossStatementResult

setPriorPeriodTo(Date) - Method in class bb.common.AccountingInfoDocumentVO

setPriorPeriodTo(Date) - Method in class bb.common.MiscDocAgent

setPriorPeriodTo(Date) - Method in class bb.common.ProfitLossStatementResult

setPrItemNumber(String) - Method in class bb.common.PrReceiverWithQualityListResult

setPrivateNote(String) - Method in class bb.common.CRTVListResult

setPrivateNote(String) - Method in class bb.common.OnLoanListResult

setPrivateNote(String) - Method in class bb.common.QuoteListResult

setPrivateNote(String) - Method in class bb.common.RMAListResult

setPrivateNote(String) - Method in class bb.common.RRMAListResult

setPrivateNote(String) - Method in class bb.common.SalesOrderListResult

setPrivateNotes(String) - Method in class bb.common.CustomerReturnToVendorVO

setPrivateNotes(String) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setPrivateNotes(String) - Method in class bb.common.OnloanReceiverItemVO

setPrivateNotes(String) - Method in class bb.common.OnloanReceiverVO

setPrivateNotes(String) - Method in class bb.common.PfReceiverVO

setPrivateNotes(String) - Method in class bb.common.ProformaInvoiceListResult

setPrivateNotes(String) - Method in class bb.common.PrReceiverListResult

setPrivateNotes(String) - Method in class bb.common.PurchaseOrderListResult

setPrivateNotes(String) - Method in class bb.common.ReceiverItemVO

setPrivateNotes(String) - Method in class bb.common.ReceiverVO

setPrivateNotes(String) - Method in class bb.common.ReceivingItemResult

setPrivateNotes(String) - Method in class bb.common.RequestForRMAVO

setPrivateNotes(String) - Method in class bb.common.ShippingItemResult

setPrivateNotes(String) - Method in class bb.common.TransferOrderListResult

setPrivateNotes(String) - Method in class bb.common.TransferOrderVO

setPrivateNotes(String) - Method in class bb.common.WorkOrderWorkSheetItemVO

setPrNumber(String) - Method in class bb.common.PrReceiverListResult

setPrNumber(String) - Method in class bb.common.PrReceiverWithQualityListResult

setProblemDescription(String) - Method in class bb.common.NcrReportListResult

setProblemDescription(String) - Method in class bb.common.NonConformanceReportVO

setProblemDescription(String) - Method in class bb.common.ScrapReportVO

setProblemDisposition(String) - Method in class bb.common.NcrReportListResult

setProblemDisposition(String) - Method in class bb.common.NonConformanceReportVO

setProcessInspection(boolean) - Method in class bb.common.InspectionConformanceReportVO

setProduct(String) - Method in class bb.common.CustomerServiceIncidentVO

setProductCode(String) - Method in class bb.common.AccountsPayableItemVO

setProductCode(String) - Method in class bb.common.AccountsReceivableItemVO

setProductCode(String) - Method in class bb.common.APItemListResult

setProductCode(String) - Method in class bb.common.InventoryListResult

setProductCode(String) - Method in class bb.common.InvoiceItemListResult

setProductCode(String) - Method in class bb.common.PartBasicInfo

setProductCode(String) - Method in class bb.common.PartVO

setProductCode(String) - Method in class bb.common.PartWithOnhandsVO

setProductCode(String) - Method in class bb.common.PurchaseOrderItemListResult

setProductCode(String) - Method in class bb.common.PurchaseOrderItemVO

setProductCode(String) - Method in class bb.common.ReceiverItemVO

setProductCode(String) - Method in class bb.common.RunningAccountOrderItemVO

setProductCode(String) - Method in class bb.common.SalesOrderItemListResult

setProductCode(String) - Method in class bb.common.SalesOrderItemVO

setProductCode(String) - Method in class bb.common.SGPartCatalogResult

setProductCode(String) - Method in class bb.common.ShipperItemVO

setProfit(BigDecimal) - Method in class bb.common.RunningAccountOrderItemVO

setProfitByStdCost(BigDecimal) - Method in class bb.common.RunningAccountOrderItemVO

setProfitMarginByAvgCost(BigDecimal) - Method in class bb.common.InventoryListResult

setProfitPercent(BigDecimal) - Method in class bb.common.RunningAccountOrderItemVO

setProfitPercentByStdCost(BigDecimal) - Method in class bb.common.RunningAccountOrderItemVO

setProfitPercentTotal(BigDecimal) - Method in class bb.common.RunningAccountOrderVO

setProfitPercentTotalByStdCost(BigDecimal) - Method in class bb.common.RunningAccountOrderVO

setProfitTotal(BigDecimal) - Method in class bb.common.RunningAccountOrderVO

setProfitTotalByStdCost(BigDecimal) - Method in class bb.common.RunningAccountOrderVO

setProformaInvoiceItemManufacturer(Set) - Method in class bb.common.ProformaInvoiceItemVO

setProformaInvoiceItems(Set) - Method in class bb.common.ProformaInvoiceVO

setProject(String) - Method in class bb.common.AccountsPayableInfoVO

setProject(String) - Method in class bb.common.AccountsPayableVO

setProject(String) - Method in class bb.common.AssetVO

setProject(String) - Method in class bb.common.CRTVListResult

setProject(String) - Method in class bb.common.CustomAssetVO

setProject(String) - Method in class bb.common.DisassembleWorkOrderIssuingResult

setProject(String) - Method in class bb.common.DisassembleWorkOrderItemListResult

setProject(String) - Method in class bb.common.DisassembleWorkOrderListResult

setProject(String) - Method in class bb.common.DisassembleWorkOrderReceivingResult

setProject(String) - Method in class bb.common.DisassembleWorkOrderVO

setProject(String) - Method in class bb.common.IssuingResult

setProject(String) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setProject(String) - Method in class bb.common.NonproductivePickingItemResult

setProject(String) - Method in class bb.common.NonproductivePickingVO

setProject(String) - Method in class bb.common.OnhandQualityResult

setProject(String) - Method in class bb.common.OnLoanListResult

setProject(String) - Method in class bb.common.OnloanReceiverListResult

setProject(String) - Method in class bb.common.OnLoanVO

setProject(String) - Method in class bb.common.OperatingInstructionsVO

setProject(String) - Method in class bb.common.PartIssuedListResult

setProject(String) - Method in class bb.common.PartReceivedListResult

setProject(String) - Method in class bb.common.POAndWOStatusResult

setProject(String) - Method in class bb.common.POStatisticsResult

setProject(String) - Method in class bb.common.PurchaseOrderCheckListResult

setProject(String) - Method in class bb.common.PurchaseOrderItemListResult

setProject(String) - Method in class bb.common.PurchaseOrderListResult

setProject(String) - Method in class bb.common.QuoteListResult

setProject(String) - Method in class bb.common.ReceivingResult

setProject(String) - Method in class bb.common.RequestForQuoteCheckListResult

setProject(String) - Method in class bb.common.RequestForQuoteListResult

setProject(String) - Method in class bb.common.ReturnToVendorByDateListResult

setProject(String) - Method in class bb.common.ReturnToVendorCheckListResult

setProject(String) - Method in class bb.common.ReturnToVendorListResult

setProject(String) - Method in class bb.common.ReturnToVendorVO

setProject(String) - Method in class bb.common.RMAListResult

setProject(String) - Method in class bb.common.RMAReceiverListResult

setProject(String) - Method in class bb.common.RMAReceiverVO

setProject(String) - Method in class bb.common.RRMAListResult

setProject(String) - Method in class bb.common.SalesOrderListResult

setProject(String) - Method in class bb.common.ShipperItemListResult

setProject(String) - Method in class bb.common.ShipperVO

setProject(String) - Method in class bb.common.TotalAmountInPOByRefDoc

setProject(String) - Method in class bb.common.WoItemPickListResult

setProject(String) - Method in class bb.common.WOReceiverDetail

setProject(String) - Method in class bb.common.WorkOrderCheckListResult

setProject(String) - Method in class bb.common.WorkOrderIssueStatisticsResult

setProject(String) - Method in class bb.common.WorkOrderItemListResult

setProject(String) - Method in class bb.common.WorkOrderListResult

setProject(String) - Method in class bb.common.WorkOrderVO

setProjectClass(String) - Method in class bb.common.DesignControlInfoVO

setProjectClass(String) - Method in class bb.common.DesignControlVO

setProjectDescription(String) - Method in class bb.common.DesignControlInfoVO

setProjectDescription(String) - Method in class bb.common.DesignControlListResult

setProjectDescription(String) - Method in class bb.common.DesignControlVO

setProjectDescription(String) - Method in class bb.common.TotalAmountInPOByRefDoc

setProjectEngineer(String) - Method in class bb.common.DesignControlInfoVO

setProjectEngineer(String) - Method in class bb.common.DesignControlListResult

setProjectEngineer(String) - Method in class bb.common.DesignControlVO

setProjectName(String) - Method in class bb.common.CustomerReturnToVendorVO

setProjectName(String) - Method in class bb.common.OnloanReceiverVO

setProjectName(String) - Method in class bb.common.PfReceiverVO

setProjectName(String) - Method in class bb.common.POReceiverItemListResult

setProjectName(String) - Method in class bb.common.POSurveyReportAgent

setProjectName(String) - Method in class bb.common.POSurveyReportVO

setProjectName(String) - Method in class bb.common.PurchaseOrderVO

setProjectName(String) - Method in class bb.common.QuoteVO

setProjectName(String) - Method in class bb.common.ReceiverInfoVO

setProjectName(String) - Method in class bb.common.ReceiverVO

setProjectName(String) - Method in class bb.common.RequestForQuoteVO

setProjectName(String) - Method in class bb.common.RequestForRMAVO

setProjectName(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setProjectName(String) - Method in class bb.common.SalesOrderItemListResult

setProjectName(String) - Method in class bb.common.SalesOrderVO

setProjectName(String) - Method in class bb.common.SwapOrderItemListResult

setProjectName(String) - Method in class bb.common.SwapOrderListResult

setProjectName(String) - Method in class bb.common.SwapOrderVO

setProjectName(String) - Method in class bb.common.SwapReceiverListResult

setProjectName(String) - Method in class bb.common.SwapReceiverVO

setProjectName(String) - Method in class bb.common.SwapShipperListResult

setProjectName(String) - Method in class bb.common.SwapShipperVO

setProjectNumber(String) - Method in class bb.common.PurchaseOrderContractResult

setProjectTeam(String) - Method in class bb.common.DesignControlInfoVO

setProjectTeam(String) - Method in class bb.common.DesignControlVO

setProofreader(String) - Method in class bb.common.WorkInstructionListResult

setProofreader(String) - Method in class bb.common.WorkInstructionVO

setProofreader(String) - Method in class bb.common.WorkOrderWorkInstructionVO

setPropertyEquipments(BigDecimal) - Method in class bb.common.AccountingBalanceSheetResult

setProposedAction(String) - Method in class bb.common.CorrectiveActionRequestVO

setProposedAction(String) - Method in class bb.common.PreventiveActionRequestVO

setProposedActionDate(Date) - Method in class bb.common.CorrectiveActionRequestVO

setProposedActionDate(Date) - Method in class bb.common.PreventiveActionRequestVO

setProposedBy(String) - Method in class bb.common.CorrectiveActionRequestVO

setProposedBy(String) - Method in class bb.common.PreventiveActionRequestVO

setPrPackingBoxes(Set) - Method in class bb.common.PfReceiverVO

setPrPBItem(PrPackingBoxItemVO) - Method in class bb.common.ProformaReceiverPackingBoxItemAgent

setPtSipQty(BigDecimal) - Method in class bb.common.PackingBoxSalesOrderItemResult

setPublic(boolean) - Method in class bb.common.DocumentInfoAgent

setPublicDoc(boolean) - Method in class bb.common.AllPartDocumentsVO

setPublicDoc(boolean) - Method in class bb.common.LogPartDocumentVO

setPublicDoc(boolean) - Method in class bb.common.PartDocumentVO

setPublicToEvery(boolean) - Method in class bb.common.PurchaseWorkSheetVO

setPublicToEvery(boolean) - Method in class bb.common.WorkOrderWorkSheetVO

setPublicToUser(String) - Method in class bb.common.PurchaseWorkSheetVO

setPublicToUser(String) - Method in class bb.common.WorkOrderWorkSheetVO

setPublicWorkSheet(boolean) - Method in class bb.common.PurchaseWorkSheetVO

setPublicWorkSheet(boolean) - Method in class bb.common.WorkOrderWorkSheetVO

setPurchaerName(String) - Method in class bb.common.PO2SOExchange

setPurchaseContent(String) - Method in class bb.common.PurchaseOrderContractResult

setPurchaseCost(BigDecimal) - Method in class bb.common.PartInventoryVO

setPurchaseCost(BigDecimal) - Method in class bb.common.ToolInventoryVO

setPurchaseMethod(String) - Method in class bb.common.PurchaseOrderContractResult

setPurchaseMethod(String) - Method in class bb.common.PurchaseOrderVO

setPurchaseOrder(String) - Method in class bb.common.IcrItemListResult

setPurchaseOrder(String) - Method in class bb.common.IcrListResult

setPurchaseOrder(String) - Method in class bb.common.InspectionConformanceReportItemInfo

setPurchaseOrder(String) - Method in class bb.common.InspectionConformanceReportVO

setPurchaseOrderComments(String) - Method in class bb.common.PurchaseOrderVO

setPurchaseOrderDocuments(Set) - Method in class bb.common.PurchaseOrderVO

setPurchaseOrderItem(Set<PurchaseOrderItemVO>) - Method in class bb.common.PurchaseOrderVO

setPurchaseOrderItemManufacturer(Set) - Method in class bb.common.PurchaseOrderItemVO

setPurchaseOrderItemNumber(String) - Method in class bb.common.AccountsPayableItemManufacturerPK

setPurchaseOrderItemNumber(String) - Method in class bb.common.PfReceiverItemPK

setPurchaseOrderItemNumber(String) - Method in class bb.common.PrPackingBoxItemPK

setPurchaseOrderItemNumber(String) - Method in class bb.common.PurchaseOrderItemManufacturerPK

setPurchaseOrderItemNumber(String) - Method in class bb.common.PurchaseOrderItemPK

setPurchaseOrderItemNumber(String) - Method in class bb.common.ReceiverItemManufacturerPK

setPurchaseOrderItemPk(PurchaseOrderItemPK) - Method in class bb.common.PurchaseOrderOnOrderResult

setPurchaseOrderItemReferenceDocOne(PurchaseOrderItemPK, String) - Method in interface bb.common.box.ManufacturingBox

setPurchaseOrderItemReferenceDocOne(PurchaseOrderItemPK, String) - Method in interface bb.common.box.PurchasingBox

setPurchaseOrderItemReferenceDocTwo(PurchaseOrderItemPK, String) - Method in interface bb.common.box.ManufacturingBox

setPurchaseOrderItemReferenceDocTwo(PurchaseOrderItemPK, String) - Method in interface bb.common.box.PurchasingBox

setPurchaseOrderNumber(String) - Method in class bb.common.ApPrepayVO

setPurchaseOrderNumber(String) - Method in class bb.common.AssetVO

setPurchaseOrderNumber(String) - Method in class bb.common.CustomerFeedbackVO

setPurchaseOrderNumber(String) - Method in class bb.common.GeneralLedgerListResult

setPurchaseOrderNumber(String) - Method in class bb.common.GeneralLedgerVO

setPurchaseOrderNumber(String) - Method in class bb.common.NcrNeedToScrapListResult

setPurchaseOrderNumber(String) - Method in class bb.common.NonConformanceReportVO

setPurchaseOrderNumber(String) - Method in class bb.common.PackingBoxItemVO

setPurchaseOrderNumber(String) - Method in class bb.common.PartCertificateListResult

setPurchaseOrderNumber(String) - Method in class bb.common.PartCertificateVO

setPurchaseOrderNumber(String) - Method in class bb.common.PfReceiverItemPK

setPurchaseOrderNumber(String) - Method in class bb.common.PO2SOExchange

setPurchaseOrderNumber(String) - Method in class bb.common.POSurveyReportVO

setPurchaseOrderNumber(String) - Method in class bb.common.ProformaInvoiceItemListResult

setPurchaseOrderNumber(String) - Method in class bb.common.ProformaInvoiceItemVO

setPurchaseOrderNumber(String) - Method in class bb.common.PrPackingBoxItemPK

setPurchaseOrderNumber(String) - Method in class bb.common.PurchaseOrderContractResult

setPurchaseOrderNumber(String) - Method in class bb.common.PurchaseOrderItemManufacturerPK

setPurchaseOrderNumber(String) - Method in class bb.common.PurchaseOrderItemPK

setPurchaseOrderNumber(String) - Method in class bb.common.PurchaseOrderVO

setPurchaseOrderNumber(String) - Method in class bb.common.ReceiverInfoVO

setPurchaseOrderNumber(String) - Method in class bb.common.ReceiverItemVO

setPurchaseOrderNumber(String) - Method in class bb.common.ReceiverVO

setPurchaseOrderNumber(String) - Method in class bb.common.TempReceiverWithoutAPInfo

setPurchaseOrderOnOrderResult(ArrayList) - Method in class bb.common.BB2PartMrpResult

setPurchaseOrderPrepay(String) - Method in class bb.common.AccountingSettingsVO

setPurchaseOrderPrivateNotes(String) - Method in class bb.common.PurchaseOrderVO

setPurchaseOrderUnit(String) - Method in class bb.common.PartInventoryVO

setPurchaseOrderUnit(boolean) - Method in class bb.common.PartUnitVO

setPurchaseOrderUnit(String) - Method in class bb.common.ToolInventoryVO

setPurchaseRefdoc(Map) - Method in class bb.common.PurchaseWorkSheetItemVO

setPurchaseRequestNumber(String) - Method in class bb.common.PurchaseOrderContractResult

setPurchaserId(String) - Method in class bb.common.PO2SOExchange

setPurchaseTaxRate(BigDecimal) - Method in class bb.common.TaxAccountVO

setPurchaseWithPartOnHoldCount(Integer) - Method in class bb.common.PurchasingInfoCenterResult

setPurchaseWorkSheetItem(Set) - Method in class bb.common.PurchaseWorkSheetVO

setPurItemCount(int) - Method in class bb.common.PurchaseOrderOnTimeItemResult

setPurTotal(BigDecimal) - Method in class bb.common.PurchaseOrderOnTimeItemResult

setPutDate(Date) - Method in class bb.common.CustomGoodsRecordVO

setPutDate(Date) - Method in class bb.common.EmployeePutGoodListResult

setQaAcceptEmployee(String) - Method in class bb.common.POSurveyReportVO

setQc(String) - Method in class bb.common.NonConformanceReportVO

setQCode(String) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setQCode(String) - Method in class bb.common.ReceivingItemResult

setQCPrincipal(String) - Method in class bb.common.OIPrincipalVO

setQr(String) - Method in class bb.common.AccountsPayableItemVO

setQr(String) - Method in class bb.common.CustomerReturnToVendorItemVO

setQr(String) - Method in class bb.common.DisassembleWorkOrderItemVO

setQr(String) - Method in class bb.common.NonConformanceReportVO

setQr(String) - Method in class bb.common.OnLoanItemVO

setQr(String) - Method in class bb.common.OnloanReceiverItemVO

setQr(String) - Method in class bb.common.PurchaseOrderItemVO

setQr(String) - Method in class bb.common.QuoteItemVO

setQr(String) - Method in class bb.common.ReceiverItemVO

setQr(String) - Method in class bb.common.RequestForQuoteItemVO

setQr(String) - Method in class bb.common.RequestForRMAItemVO

setQr(String) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setQr(String) - Method in class bb.common.ReturnToVendorItemVO

setQr(String) - Method in class bb.common.RMAReceiverItemVO

setQr(String) - Method in class bb.common.SalesOrderItemInfoVO

setQr(String) - Method in class bb.common.SalesOrderItemVO

setQr(String) - Method in class bb.common.WorkOrderItemVO

setQrQty(BigDecimal) - Method in class bb.common.PartWithExcessiveInventoryListResult

setQt(String) - Method in class bb.common.OnLoanVO

setQtBoilerplate(String) - Method in class bb.common.QuoteBoilerplateVO

setQtDate(Date) - Method in class bb.common.QuoteItemListResult

setQtDate(Date) - Method in class bb.common.QuoteListResult

setQtDigits(byte) - Method in class bb.common.CompanyVO

setQtItemNumber(String) - Method in class bb.common.QuoteItemListResult

setQtMail(boolean) - Method in class bb.common.CustomerVendorContactVO

setQtNumber(String) - Method in class bb.common.QuoteItemListResult

setQtNumber(String) - Method in class bb.common.QuoteListResult

setQtPrefix(String) - Method in class bb.common.CompanyVO

setQtr1Qty(BigDecimal) - Method in class bb.common.HighUsagePartResult

setQtr2Qty(BigDecimal) - Method in class bb.common.HighUsagePartResult

setQtr3Qty(BigDecimal) - Method in class bb.common.HighUsagePartResult

setQtr4Qty(BigDecimal) - Method in class bb.common.HighUsagePartResult

setQtrUsage(BigDecimal) - Method in class bb.common.BB2PartInfo

setQtrUsage(BigDecimal) - Method in class bb.common.BB2PartTotalOnhandDetailResult

setQtrUsage(BigDecimal) - Method in class bb.common.PartMaterialListResult

setQtrUsage(BigDecimal) - Method in class bb.common.PartMaterialWhereUsedItemResult

setQtrUsage(BigDecimal) - Method in class bb.common.StockTransactionPartInfoResult

setQty(BigDecimal) - Method in class bb.common.AddProformaReceiverItemAgent

setQty(BigDecimal) - Method in class bb.common.AssetReportSumResult

setQty(BigDecimal) - Method in class bb.common.BB2PartInSTOItemResult

setQty(BigDecimal) - Method in class bb.common.BB2PartOnLoanItemResult

setQty(BigDecimal) - Method in class bb.common.BillItemSalesCostResult

setQty(BigDecimal) - Method in class bb.common.BillItemSalesResult

setQty(BigDecimal) - Method in class bb.common.BillItemSalesXResult

setQty(BigDecimal) - Method in class bb.common.BillWhereUsedItemResult

setQty(BigDecimal) - Method in class bb.common.BOMCanAssyListResult

setQty(BigDecimal) - Method in class bb.common.BomItemWithOEMResult

setQty(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemListResult

setQty(BigDecimal) - Method in class bb.common.EcnPOOrderResult

setQty(BigDecimal) - Method in class bb.common.EcnWOOrderResult

setQty(BigDecimal) - Method in class bb.common.JobProcessSheetResult

setQty(BigDecimal) - Method in class bb.common.NcrScrapAgent

setQty(BigDecimal) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setQty(BigDecimal) - Method in class bb.common.OrderApprovalItemsVO

setQty(BigDecimal) - Method in class bb.common.PackingBoxSalesOrderItemResult

setQty(BigDecimal) - Method in class bb.common.PartInQAAgent

setQty(BigDecimal) - Method in class bb.common.PartMaterialWhereUsedItemResult

setQty(BigDecimal) - Method in class bb.common.PartOnhandAndCostResult

setQty(BigDecimal) - Method in class bb.common.PartTrackingVO

setQty(BigDecimal) - Method in class bb.common.partUsedInfoResult

setQty(BigDecimal) - Method in class bb.common.PartWithQtyListResult

setQty(BigDecimal) - Method in class bb.common.PosRefdocVO

setQty(BigDecimal) - Method in class bb.common.PullFromWorkOrderPartDetailAgent

setQty(BigDecimal) - Method in class bb.common.PuttoInQAAgent

setQty(BigDecimal) - Method in class bb.common.QtyAndMoney

setQty(BigDecimal) - Method in class bb.common.QtyDetailResult

setQty(BigDecimal) - Method in class bb.common.ReceiverItemTrackingLogAgent

setQty(BigDecimal) - Method in class bb.common.RefdocElement

setQty(BigDecimal) - Method in class bb.common.RefdocVO

setQty(BigDecimal) - Method in class bb.common.RequestForQuoteItemListResult

setQty(BigDecimal) - Method in class bb.common.ReturnToVendorItemListResult

setQty(BigDecimal) - Method in class bb.common.RtvShipperItemListResult

setQty(BigDecimal) - Method in class bb.common.RtvShipperItemVO

setQty(BigDecimal) - Method in class bb.common.SalesOrder12MonthMarginResult

setQty(BigDecimal) - Method in class bb.common.SGBOMItemResult

setQty(BigDecimal) - Method in class bb.common.SGCustRequestForQuoteItemResult

setQty(BigDecimal) - Method in class bb.common.SGCustRequestForQuoteItemVO

setQty(BigDecimal) - Method in class bb.common.SGPartCartAgent

setQty(BigDecimal) - Method in class bb.common.SGPartListItemResult

setQty(BigDecimal) - Method in class bb.common.SGPartListResult

setQty(BigDecimal) - Method in class bb.common.SGQuoteCartListResult

setQty(BigDecimal) - Method in class bb.common.SGQuoteCartVO

setQty(BigDecimal) - Method in class bb.common.ShipListItemRelatedDocResult

setQty(BigDecimal) - Method in class bb.common.WOItemCostControlAgent

setQty(BigDecimal) - Method in class bb.common.WoItemWorkInstructionListResult

setQty(BigDecimal) - Method in class bb.common.WorkOrderItemAgent

setQty(BigDecimal) - Method in class bb.common.WorkOrderItemCanAssyResult

setQty(BigDecimal) - Method in class bb.common.WorkOrderItemInWipListResult

setQty(BigDecimal) - Method in class bb.common.WorkOrderItemListResult

setQty(BigDecimal) - Method in class bb.common.WorkOrderItemSetupItemAgent

setQty(BigDecimal) - Method in class bb.common.WorkOrderItemTimeDetailVO

setQty(BigDecimal) - Method in class bb.common.WorkOrderItemToIssueResult

setQty(BigDecimal) - Method in class bb.common.WorkOrderItemWCLoadResult

setQty(BigDecimal) - Method in class bb.common.WorkOrderWorkInstructionVO

setQty(BigDecimal) - Method in class bb.common.WorkSheetPartAgent

setQtyAsm(BigDecimal) - Method in class bb.common.WoItemPickListResult

setQtyAssy(BigDecimal) - Method in class bb.common.WOReceiverDetail

setQtyAssy(BigDecimal) - Method in class bb.common.WorkOrderReceiverVO

setQtyCheck(BigDecimal) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setQtyCheck(BigDecimal) - Method in class bb.common.IcrItemListResult

setQtyCheck(BigDecimal) - Method in class bb.common.InspectionConformanceReportItemVO

setQtyCheck(BigDecimal) - Method in class bb.common.ReceivingItemResult

setQtyInSip(BigDecimal) - Method in class bb.common.BB2PartInSipItemResult

setQtyInSip(BigDecimal) - Method in class bb.common.BB2PartInSipOfSoItemResult

setQtyInSit(BigDecimal) - Method in class bb.common.BB2PartInSitItemResult

setQtyInspected(BigDecimal) - Method in class bb.common.NcrReportListResult

setQtyInWip(BigDecimal) - Method in class bb.common.WorkOrderItemPartDetailInWipVO

setQtyIssued(BigDecimal) - Method in class bb.common.NonproductivePickingItemIssuedVO

setQtyIssued(BigDecimal) - Method in class bb.common.PartIssuedVO

setQtyIssued(BigDecimal) - Method in class bb.common.WoItemPickListItemResult

setQtyMonths(BigDecimal) - Method in class bb.common.WorkSheetPartAgent

setQtyNeedtoScrap(BigDecimal) - Method in class bb.common.NcrNeedToScrapListResult

setQtyOrdered(BigDecimal) - Method in class bb.common.AccountsReceivableItemVO

setQtyOrdered(BigDecimal) - Method in class bb.common.APItemListResult

setQtyOrdered(BigDecimal) - Method in class bb.common.BB2PartInSipOfSoItemResult

setQtyOrdered(BigDecimal) - Method in class bb.common.InvoiceItemListResult

setQtyOrdered(BigDecimal) - Method in class bb.common.PO2SOExchangeItem

setQtyOrdered(BigDecimal) - Method in class bb.common.POReceiverItemListResult

setQtyOrdered(BigDecimal) - Method in class bb.common.PrReceiverWithQualityListResult

setQtyPicked(BigDecimal) - Method in class bb.common.BomPickListItemResult

setQtyPicked(BigDecimal) - Method in class bb.common.WoItemPickListItemResult

setQtyQualified(BigDecimal) - Method in class bb.common.IcrItemListResult

setQtyQualified(BigDecimal) - Method in class bb.common.InspectionConformanceReportItemVO

setQtyQualified(BigDecimal) - Method in class bb.common.ReceivingItemResult

setQtyReceived(BigDecimal) - Method in class bb.common.AccountsPayableItemVO

setQtyReceived(BigDecimal) - Method in class bb.common.APItemListResult

setQtyReceived(BigDecimal) - Method in class bb.common.PartReceivedVO

setQtyReceived(BigDecimal) - Method in class bb.common.PfReceiverItemVO

setQtyReceived(BigDecimal) - Method in class bb.common.POReceiverItemListResult

setQtyReceived(BigDecimal) - Method in class bb.common.PrReceiverWithQualityListResult

setQtyRegrade(BigDecimal) - Method in class bb.common.NcrNeedToScrapListResult

setQtyRegrade(BigDecimal) - Method in class bb.common.NonConformanceReportVO

setQtyReject(BigDecimal) - Method in class bb.common.InspectionConformanceReportItemVO

setQtyReject(BigDecimal) - Method in class bb.common.NcrNeedToScrapListResult

setQtyReject(BigDecimal) - Method in class bb.common.NonConformanceReportVO

setQtyRejected(BigDecimal) - Method in class bb.common.NcrReportListResult

setQtyRequested(BigDecimal) - Method in class bb.common.BomPickListItemResult

setQtyRequired(BigDecimal) - Method in class bb.common.WoItemPickListItemResult

setQtyRework(BigDecimal) - Method in class bb.common.NcrNeedToScrapListResult

setQtyRework(BigDecimal) - Method in class bb.common.NonConformanceReportVO

setQtyScrap(BigDecimal) - Method in class bb.common.NcrNeedToScrapListResult

setQtyScrap(BigDecimal) - Method in class bb.common.NonConformanceReportVO

setQtyScraped(BigDecimal) - Method in class bb.common.NcrNeedToScrapListResult

setQtyScraped(BigDecimal) - Method in class bb.common.NcrReportListResult

setQtyShip(BigDecimal) - Method in class bb.common.DisassembleWorkOrderIssueVO

setQtyShip(BigDecimal) - Method in class bb.common.RtvShipperItemListResult

setQtyShip(BigDecimal) - Method in class bb.common.RtvShipperItemVO

setQtyShip(BigDecimal) - Method in class bb.common.TransferOrderItemVO

setQtyShiped(BigDecimal) - Method in class bb.common.SalesTaxListResult

setQtyShipped(BigDecimal) - Method in class bb.common.AccountsReceivableItemVO

setQtyShipped(BigDecimal) - Method in class bb.common.BB2PartInSipOfSoItemResult

setQtyShipped(BigDecimal) - Method in class bb.common.DWOIssueDetail

setQtyShipped(BigDecimal) - Method in class bb.common.InvoiceItemListResult

setQtyShipped(BigDecimal) - Method in class bb.common.PfReceiverItemVO

setQtyShipped(BigDecimal) - Method in class bb.common.ProformaInvoiceItemListResult

setQtyShipped(BigDecimal) - Method in class bb.common.ProformaInvoiceItemVO

setQtyShipped(BigDecimal) - Method in class bb.common.ReceivedToOrderItem

setQtySit(BigDecimal) - Method in class bb.common.PrReceiverWithQualityListResult

setQtyToAsm(BigDecimal) - Method in class bb.common.WCLoadDetailResult

setQtyTraced(BigDecimal) - Method in class bb.common.AccountsPayableItemVO

setQtyWaiver(BigDecimal) - Method in class bb.common.NcrNeedToScrapListResult

setQtyWaiver(BigDecimal) - Method in class bb.common.NonConformanceReportVO

setQualityCode(String) - Method in class bb.common.PartManufacturerVO

setQualityCode(String) - Method in class bb.common.PartVendorVO

setQualityCode(String) - Method in class bb.common.ToolManufacturerVO

setQualityCode(String) - Method in class bb.common.ToolVendorVO

setQualityId(Short) - Method in class bb.common.TraceableSpecsVO

setQualitySpecification(String) - Method in class bb.common.PartTraceableResult

setQualitySpecification(String) - Method in class bb.common.TraceableSpecsVO

setQualityStatus(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setQualityStatus(String) - Method in class bb.common.CustomerVendorAddressVO

setQualityStatus(String) - Method in class bb.common.LockedCustomerAddressResult

setQuantituInSip(BigDecimal) - Method in class bb.common.SalesOrderOnDemandResult

setQuantity(BigDecimal) - Method in class bb.common.AccountsPayableItemVO

setQuantity(BigDecimal) - Method in class bb.common.AssetAddOrDisposalsReport

setQuantity(BigDecimal) - Method in class bb.common.AssetDepreciateDetailReport

setQuantity(BigDecimal) - Method in class bb.common.AssetVO

setQuantity(BigDecimal) - Method in class bb.common.AuditPartInQAResult

setQuantity(BigDecimal) - Method in class bb.common.BomPickListResult

setQuantity(BigDecimal) - Method in class bb.common.CustomerReturnToVendorItemVO

setQuantity(BigDecimal) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setQuantity(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemPartDetailItemResult

setQuantity(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

setQuantity(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

setQuantity(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemVO

setQuantity(BigDecimal) - Method in class bb.common.DisassembleWorkOrderReceivingResult

setQuantity(BigDecimal) - Method in class bb.common.DWOIssueDetail

setQuantity(BigDecimal) - Method in class bb.common.InspectionReportInfoVO

setQuantity(BigDecimal) - Method in class bb.common.InspectionReportVO

setQuantity(BigDecimal) - Method in class bb.common.IssuingItemResult

setQuantity(BigDecimal) - Method in class bb.common.IssuingResult

setQuantity(BigDecimal) - Method in class bb.common.JobProcessSheetListResult

setQuantity(BigDecimal) - Method in class bb.common.LnShipperItemListResult

setQuantity(BigDecimal) - Method in class bb.common.NonproductivePickingItemResult

setQuantity(BigDecimal) - Method in class bb.common.NonproductivePickingItemVO

setQuantity(BigDecimal) - Method in class bb.common.NonproductivePickingOnDemandResult

setQuantity(BigDecimal) - Method in class bb.common.OnloanReceiverItemListResult

setQuantity(BigDecimal) - Method in class bb.common.OnloanReceiverItemVO

setQuantity(BigDecimal) - Method in class bb.common.OperatingInstructionsUserStatisticalResult

setQuantity(BigDecimal) - Method in class bb.common.OperatingInstructionsVO

setQuantity(BigDecimal) - Method in class bb.common.PackingBoxItemListResult

setQuantity(BigDecimal) - Method in class bb.common.PackingBoxItemVO

setQuantity(BigDecimal) - Method in class bb.common.PartInQAResult

setQuantity(BigDecimal) - Method in class bb.common.PartInQAVO

setQuantity(BigDecimal) - Method in class bb.common.PfReceiverItemVO

setQuantity(BigDecimal) - Method in class bb.common.ProformaInvoiceItemListResult

setQuantity(BigDecimal) - Method in class bb.common.ProformaInvoiceItemVO

setQuantity(BigDecimal) - Method in class bb.common.PrPackingBoxItemVO

setQuantity(BigDecimal) - Method in class bb.common.PurchaseWorkSheetItemVO

setQuantity(BigDecimal) - Method in class bb.common.RebackInQAAgent

setQuantity(BigDecimal) - Method in class bb.common.ReceiverItemVO

setQuantity(BigDecimal) - Method in class bb.common.ReceivingItemResult

setQuantity(BigDecimal) - Method in class bb.common.RequestForQuoteItemVO

setQuantity(BigDecimal) - Method in class bb.common.RequestForRMAItemVO

setQuantity(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setQuantity(BigDecimal) - Method in class bb.common.ReturnToVendorByDateListResult

setQuantity(BigDecimal) - Method in class bb.common.ReturnToVendorItemVO

setQuantity(BigDecimal) - Method in class bb.common.RMAReceiverItemListResult

setQuantity(BigDecimal) - Method in class bb.common.RMAReceiverItemVO

setQuantity(BigDecimal) - Method in class bb.common.RMAReceiverResult

setQuantity(BigDecimal) - Method in class bb.common.RunningAccountOrderItemVO

setQuantity(BigDecimal) - Method in class bb.common.SalesBomItemResult

setQuantity(BigDecimal) - Method in class bb.common.SalesPartListItemResult

setQuantity(BigDecimal) - Method in class bb.common.SGSaleItemAgent

setQuantity(BigDecimal) - Method in class bb.common.SGSaleItemVO

setQuantity(BigDecimal) - Method in class bb.common.ShipperItemListResult

setQuantity(BigDecimal) - Method in class bb.common.ShippingItemResult

setQuantity(BigDecimal) - Method in class bb.common.ShoppingCartItem

setQuantity(BigDecimal) - Method in class bb.common.WOItemPartDetailNotIssue

setQuantity(BigDecimal) - Method in class bb.common.WoItemPickListItemResult

setQuantity(BigDecimal) - Method in class bb.common.WoItemPickListResult

setQuantity(BigDecimal) - Method in class bb.common.WOReceiverDetail

setQuantity(BigDecimal) - Method in class bb.common.WorkOrderItemInfoResult

setQuantity(BigDecimal) - Method in class bb.common.WorkOrderItemIssuedTotalResult

setQuantity(BigDecimal) - Method in class bb.common.WorkOrderItemIssueVO

setQuantity(BigDecimal) - Method in class bb.common.WorkOrderItemPartDetail

setQuantity(BigDecimal) - Method in class bb.common.WorkOrderItemPartDetailItemResult

setQuantity(BigDecimal) - Method in class bb.common.WorkOrderItemPartDetailResult

setQuantity(BigDecimal) - Method in class bb.common.WorkOrderItemReviewCostResult

setQuantity(BigDecimal) - Method in class bb.common.WorkOrderItemTimeDetailResult

setQuantity(BigDecimal) - Method in class bb.common.WorkOrderItemVO

setQuantity(BigDecimal) - Method in class bb.common.WorkOrderQueryInfo

setQuantity(BigDecimal) - Method in class bb.common.WorkOrderTimeCardVO

setQuantity(BigDecimal) - Method in class bb.common.WorkOrderWorkSheetItemVO

setQuantityAsm(BigDecimal) - Method in class bb.common.IssuingResult

setQuantityAsm(BigDecimal) - Method in class bb.common.JobProcessSheetListResult

setQuantityAsm(BigDecimal) - Method in class bb.common.WOItemPartDetailNotIssue

setQuantityAsm(BigDecimal) - Method in class bb.common.WOReceiverDetail

setQuantityAsm(BigDecimal) - Method in class bb.common.WorkOrderItemInfoResult

setQuantityAsm(BigDecimal) - Method in class bb.common.WorkOrderItemReviewCostResult

setQuantityAsm(BigDecimal) - Method in class bb.common.WorkOrderItemVO

setQuantityAsm(BigDecimal) - Method in class bb.common.WorkOrderOnDemandResult

setQuantityAsm(BigDecimal) - Method in class bb.common.WorkOrderOnOrderResult

setQuantityAsm(BigDecimal) - Method in class bb.common.WorkOrderQueryInfo

setQuantityDemanded(BigDecimal) - Method in class bb.common.WorkOrderInWipResult

setQuantityDemanded(BigDecimal) - Method in class bb.common.WorkOrderOnDemandResult

setQuantityInWip(BigDecimal) - Method in class bb.common.WorkOrderInWipResult

setQuantityIssued(BigDecimal) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setQuantityIssued(BigDecimal) - Method in class bb.common.IssuingItemResult

setQuantityIssued(BigDecimal) - Method in class bb.common.NonproductivePickingOnDemandResult

setQuantityIssued(BigDecimal) - Method in class bb.common.WorkOrderInWipResult

setQuantityIssued(BigDecimal) - Method in class bb.common.WorkOrderOnDemandResult

setQuantityNotAsm(BigDecimal) - Method in class bb.common.WorkOrderOnDemandResult

setQuantityNotShipped(BigDecimal) - Method in class bb.common.SalesOrderOrphanedResult

setQuantityOnDemand(BigDecimal) - Method in class bb.common.NonproductivePickingOnDemandResult

setQuantityOnDemand(BigDecimal) - Method in class bb.common.SalesOrderOnDemandResult

setQuantityOnDemand(BigDecimal) - Method in class bb.common.WorkOrderOnDemandResult

setQuantityOnOrder(BigDecimal) - Method in class bb.common.PurchaseOrderOnOrderResult

setQuantityOnOrder(BigDecimal) - Method in class bb.common.SwapShipperOnOrderResult

setQuantityOnOrder(BigDecimal) - Method in class bb.common.WorkOrderOnOrderResult

setQuantityOrdered(BigDecimal) - Method in class bb.common.POSurveyReportItemVO

setQuantityOrdered(BigDecimal) - Method in class bb.common.PurchaseOrderItemVO

setQuantityOrdered(BigDecimal) - Method in class bb.common.PurchaseOrderOnOrderResult

setQuantityOrdered(BigDecimal) - Method in class bb.common.SalesOrderItemGroupByPartListResult

setQuantityOrdered(BigDecimal) - Method in class bb.common.SalesOrderItemInfoVO

setQuantityOrdered(BigDecimal) - Method in class bb.common.SalesOrderItemVO

setQuantityOrdered(BigDecimal) - Method in class bb.common.SalesOrderOnDemandResult

setQuantityOrdered(BigDecimal) - Method in class bb.common.SalesOrderShipDateListResult

setQuantityOrdered(BigDecimal) - Method in class bb.common.WorkOrderOnOrderResult

setQuantityQualified(BigDecimal) - Method in class bb.common.POSurveyReportItemVO

setQuantityRcv(BigDecimal) - Method in class bb.common.RMAReceiverItemListResult

setQuantityRcv(BigDecimal) - Method in class bb.common.RMAReceiverItemVO

setQuantityRec(BigDecimal) - Method in class bb.common.OnloanShipperItemVO

setQuantityReceived(BigDecimal) - Method in class bb.common.OnloanReceiverItemListResult

setQuantityReceived(BigDecimal) - Method in class bb.common.OnloanReceiverItemVO

setQuantityReceived(BigDecimal) - Method in class bb.common.POSurveyReportItemVO

setQuantityReceived(BigDecimal) - Method in class bb.common.PurchaseOrderItemVO

setQuantityReceived(BigDecimal) - Method in class bb.common.PurchaseOrderOnOrderResult

setQuantityReceived(BigDecimal) - Method in class bb.common.PurchaseOrderOpenDueListResult

setQuantityReceived(BigDecimal) - Method in class bb.common.ReceiverItemVO

setQuantityReceived(BigDecimal) - Method in class bb.common.ReceivingItemResult

setQuantityShip(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemVO

setQuantityShip(BigDecimal) - Method in class bb.common.LnShipperItemListResult

setQuantityShip(BigDecimal) - Method in class bb.common.OnloanShipperItemVO

setQuantityShip(BigDecimal) - Method in class bb.common.ShipperItemListResult

setQuantityShip(BigDecimal) - Method in class bb.common.ShipperItemVO

setQuantityShip(BigDecimal) - Method in class bb.common.ShippingItemResult

setQuantityShipped(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemListResult

setQuantityShipped(BigDecimal) - Method in class bb.common.DisassembleWorkOrderReceivingResult

setQuantityShipped(BigDecimal) - Method in class bb.common.PurchaseOrderItemVO

setQuantityShipped(BigDecimal) - Method in class bb.common.QuoteItemVO

setQuantityShipped(BigDecimal) - Method in class bb.common.SalesOrderItemGroupByPartListResult

setQuantityShipped(BigDecimal) - Method in class bb.common.SalesOrderItemInfoVO

setQuantityShipped(BigDecimal) - Method in class bb.common.SalesOrderItemVO

setQuantityShipped(BigDecimal) - Method in class bb.common.SalesOrderOnDemandResult

setQuantityShipped(BigDecimal) - Method in class bb.common.SalesOrderShipDateListResult

setQuantityShipped(BigDecimal) - Method in class bb.common.SOShipperItemListResult

setQuantityShippedTotal(BigDecimal) - Method in class bb.common.DWOIssueDetail

setQuantitySip(BigDecimal) - Method in class bb.common.ShippingItemResult

setQuantityTraced(BigDecimal) - Method in class bb.common.OnloanReceiverItemVO

setQuantityTraced(BigDecimal) - Method in class bb.common.ReceiverItemVO

setQuantityTraced(BigDecimal) - Method in class bb.common.RMAReceiverItemVO

setQuarterUsage(BigDecimal) - Method in class bb.common.PartInventoryVO

setQuarterUsage(BigDecimal) - Method in class bb.common.PartWithOnhandDetailInfoResult

setQuarterUsage(BigDecimal) - Method in class bb.common.ToolInventoryVO

setQuestion(String) - Method in class bb.common.CustomerServiceIncidentItemVO

setQuestionCn(String) - Method in class bb.common.FeedbackQuestionVO

setQuestionEn(String) - Method in class bb.common.FeedbackQuestionVO

setQuestionId(String) - Method in class bb.common.FeedbackAnswerPK

setQuestionId(String) - Method in class bb.common.FeedBackItemPK

setQuestionId(String) - Method in class bb.common.FeedbackQuestionVO

setQuoteComments(String) - Method in class bb.common.QuoteVO

setQuoteCurrency(String) - Method in class bb.common.CPItemFromQuoteResult

setQuoteDate(Date) - Method in class bb.common.QuoteVO

setQuoteDiscount(BigDecimal) - Method in class bb.common.CPItemFromQuoteResult

setQuoteDocuments(Set) - Method in class bb.common.QuoteVO

setQuoteItemComments(String) - Method in class bb.common.QuoteItemVO

setQuoteItemManufacturer(Set) - Method in class bb.common.QuoteItemVO

setQuoteItemNumber(String) - Method in class bb.common.CPItemFromQuoteResult

setQuoteItemNumber(String) - Method in class bb.common.QuoteItemManufacturerPK

setQuoteItemNumber(String) - Method in class bb.common.QuoteItemPK

setQuoteItemPrivateNotes(String) - Method in class bb.common.QuoteItemVO

setQuoteItems(Set) - Method in class bb.common.QuoteVO

setQuoteListPrice(BigDecimal) - Method in class bb.common.CPItemFromQuoteResult

setQuoteNumber(String) - Method in class bb.common.Quote2QuoteAgent

setQuoteNumber(String) - Method in class bb.common.QuoteDocumentVO

setQuoteNumber(String) - Method in class bb.common.QuoteItemManufacturerPK

setQuoteNumber(String) - Method in class bb.common.QuoteItemPK

setQuoteNumber(String) - Method in class bb.common.QuoteVO

setQuoteNumber(String) - Method in class bb.common.SalesOrderVO

setQuoteNumber(String) - Method in class bb.common.SGCustRequestForQuoteListResult

setQuoteNumber(String) - Method in class bb.common.SGCustRequestForQuoteResult

setQuoteNumber(String) - Method in class bb.common.SGCustRequestForQuoteVO

setQuotePrivateNotes(String) - Method in class bb.common.QuoteVO

setQuoteQuantity(BigDecimal) - Method in class bb.common.QuoteItemVO

setRAccounts(TreeMap) - Method in class bb.common.TwelveMonthCashFlowReportResult

setRaoiNumber(String) - Method in class bb.common.RunningAccountOrderItemResult

setRaoNumber(String) - Method in class bb.common.CheckInvoiceItemListResult

setRaoNumber(String) - Method in class bb.common.RunningAccountOrderItemResult

setRate(BigDecimal) - Method in class bb.common.EquipmentVO

setRatingCode(String) - Method in class bb.common.PartManufacturerVO

setRatingCode(String) - Method in class bb.common.PartVendorVO

setRatingCode(String) - Method in class bb.common.ToolManufacturerVO

setRatingCode(String) - Method in class bb.common.ToolVendorVO

setRatio(BigDecimal) - Method in class bb.common.BillItemReplacementVO

setRbFlag(String) - Method in class bb.common.BillVO

setRCode(String) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setRCode(String) - Method in class bb.common.ReceivingItemResult

setRealReceivable(BigDecimal) - Method in class bb.common.RunningAccountOrderVO

setRealTimeOnhand(BigDecimal) - Method in class bb.common.RunningAccountOrderItemVO

setReason(String) - Method in exception bb.common.PermissionException

setReason(String) - Method in exception bb.common.ServerException

setReCalcSubTotal(boolean) - Method in class bb.common.AccountsPayableVO

setReCalcTax(boolean) - Method in class bb.common.AccountsPayableVO

setReCalSubTotal(Boolean) - Method in class bb.common.MakeAccountPayableAgent

setReCalSubTotal(Boolean) - Method in class bb.common.MakeBillAndHoldInvoiceAgent

setReCalSubTotal(Boolean) - Method in class bb.common.MakeDebitMemoAgent

setReCalSubTotal(Boolean) - Method in class bb.common.MakeInvoiceAgent

setReCalTax(Boolean) - Method in class bb.common.MakeAccountPayableAgent

setReCalTax(Boolean) - Method in class bb.common.MakeBillAndHoldInvoiceAgent

setReCalTax(Boolean) - Method in class bb.common.MakeDebitMemoAgent

setReCalTax(Boolean) - Method in class bb.common.MakeInvoiceAgent

setRecCost(BigDecimal) - Method in class bb.common.WOIssuedByMonthResult

setReceiptNumber(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setReceiptNumber(String) - Method in class bb.common.SalesOrderVO

setReceiptTemplateID(int) - Method in class bb.common.PointOfSaleVO

setReceiveAll(Boolean) - Method in class bb.common.ReceiverShipAgent

setReceiveAllSo(boolean) - Method in class bb.common.FinishProformaReceiverAgent

setReceiveAllSo(Boolean) - Method in class bb.common.ReceiverShipAgent

setReceiveAllWo(boolean) - Method in class bb.common.FinishProformaReceiverAgent

setReceiveAllWo(Boolean) - Method in class bb.common.ReceiverShipAgent

setReceiveComment(String) - Method in class bb.common.AssetUsageVO

setReceiveComment(String) - Method in class bb.common.CustomAssetRecordVO

setReceived(BigDecimal) - Method in class bb.common.GeneralLedgerByDateListResult

setReceived(BigDecimal) - Method in class bb.common.GeneralLedgerListResult

setReceived(BigDecimal) - Method in class bb.common.GeneralLedgerVO

setReceived(BigDecimal) - Method in class bb.common.PaymentInvoicesResult

setReceiveDate(Date) - Method in class bb.common.AssetUsageVO

setReceiveDate(Date) - Method in class bb.common.AssetVO

setReceiveDate(Date) - Method in class bb.common.CustomAssetRecordVO

setReceiveDate(Date) - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

setReceivedBy(String) - Method in class bb.common.AccountsPayableInfoVO

setReceivedBy(String) - Method in class bb.common.AccountsPayableItemVO

setReceivedBy(String) - Method in class bb.common.AccountsPayableVO

setReceivedBy(String) - Method in class bb.common.OnloanReceiverItemListResult

setReceivedBy(String) - Method in class bb.common.OnloanReceiverItemVO

setReceivedBy(String) - Method in class bb.common.OnloanReceiverListResult

setReceivedBy(String) - Method in class bb.common.OnloanReceiverVO

setReceivedBy(String) - Method in class bb.common.PartInQAResult

setReceivedBy(String) - Method in class bb.common.PartInQAVO

setReceivedBy(String) - Method in class bb.common.PfReceiverVO

setReceivedBy(String) - Method in class bb.common.ReceiverInfoVO

setReceivedBy(String) - Method in class bb.common.ReceiverItemVO

setReceivedBy(String) - Method in class bb.common.ReceiverVO

setReceivedBy(String) - Method in class bb.common.RMAReceiverItemListResult

setReceivedBy(String) - Method in class bb.common.RMAReceiverItemVO

setReceivedBy(String) - Method in class bb.common.RMAReceiverListResult

setReceivedBy(String) - Method in class bb.common.RMAReceiverVO

setReceivedBy(String) - Method in class bb.common.StockTransactionPOReceiverResult

setReceivedBy(String) - Method in class bb.common.SwapReceiverListResult

setReceivedBy(String) - Method in class bb.common.SwapReceiverVO

setReceivedBy(String) - Method in class bb.common.TempReceiverWithoutAPInfo

setReceivedBy(String) - Method in class bb.common.TransferReceiverListResult

setReceivedBy(String) - Method in class bb.common.TransferReceiverVO

setReceivedCost(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

setReceivedDate(Date) - Method in class bb.common.PartInQAResult

setReceivedDate(Date) - Method in class bb.common.PartInQAVO

setReceivedDate(Date) - Method in class bb.common.PartOnhandCostVO

setReceivedDate(Date) - Method in class bb.common.POReceiverItemListResult

setReceivedDate(Date) - Method in class bb.common.ReceiverAgent

setReceivedDate(Date) - Method in class bb.common.ReceiverShipAgent

setReceivedDate(Date) - Method in class bb.common.StockTransactionPOReceiverResult

setReceivedDate(Date) - Method in class bb.common.StockTransactionWOReceiverResult

setReceivedDate(Date) - Method in class bb.common.SwapReceiverItemListResult

setReceivedDate(Date) - Method in class bb.common.SwapReceiverItemVO

setReceivedDate(Date) - Method in class bb.common.SwapReceiverListResult

setReceivedDate(Date) - Method in class bb.common.SwapReceiverVO

setReceivedDate(Date) - Method in class bb.common.TransferReceiverItemListResult

setReceivedDate(Date) - Method in class bb.common.TransferReceiverItemVO

setReceivedDate(Date) - Method in class bb.common.TransferReceiverListResult

setReceivedDate(Date) - Method in class bb.common.TransferReceiverVO

setReceiveDepartment(String) - Method in class bb.common.AssetUsageVO

setReceiveDepartment(String) - Method in class bb.common.CustomAssetRecordVO

setReceivedFrom(String) - Method in class bb.common.PartInQAAgent

setReceivedFrom(String) - Method in class bb.common.PartInQAResult

setReceivedFrom(String) - Method in class bb.common.PartInQAVO

setReceivedQty(BigDecimal) - Method in class bb.common.OnLoanItemListResult

setReceivedQty(BigDecimal) - Method in class bb.common.PartInventoryVO

setReceivedQty(BigDecimal) - Method in class bb.common.PartOnhandCostVO

setReceivedQty(BigDecimal) - Method in class bb.common.PurchaseOrderItemListResult

setReceivedQty(BigDecimal) - Method in class bb.common.ReceiverItemDetailAgent

setReceivedQty(BigDecimal) - Method in class bb.common.ReturnToVendorItemVO

setReceivedQty(BigDecimal) - Method in class bb.common.RMAItemListResult

setReceivedQty(BigDecimal) - Method in class bb.common.SwapOrderItemListResult

setReceivedQty(BigDecimal) - Method in class bb.common.SwapOrderItemVO

setReceivedQty(BigDecimal) - Method in class bb.common.SwapReceiverItemListResult

setReceivedQty(BigDecimal) - Method in class bb.common.SwapReceiverItemVO

setReceivedQty(BigDecimal) - Method in class bb.common.SwapShipperItemListResult

setReceivedQty(BigDecimal) - Method in class bb.common.SwapShipperItemVO

setReceivedQty(BigDecimal) - Method in class bb.common.SwapShipperOnOrderResult

setReceivedQty(BigDecimal) - Method in class bb.common.ToolInventoryVO

setReceivedQty(BigDecimal) - Method in class bb.common.TransferOrderItemListResult

setReceivedQty(BigDecimal) - Method in class bb.common.TransferOrderItemVO

setReceivedQty(BigDecimal) - Method in class bb.common.TransferReceiverItemListResult

setReceivedQty(BigDecimal) - Method in class bb.common.TransferReceiverItemVO

setReceivedQty(BigDecimal) - Method in class bb.common.TransferShipperItemListResult

setReceivedQty(BigDecimal) - Method in class bb.common.TransferShipperItemVO

setReceivedQuantity(BigDecimal) - Method in class bb.common.CustomerReturnToVendorItemVO

setReceivedQuantity(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

setReceivedQuantity(BigDecimal) - Method in class bb.common.OnLoanItemVO

setReceivedQuantity(BigDecimal) - Method in class bb.common.RequestForQuoteItemVO

setReceivedQuantity(BigDecimal) - Method in class bb.common.RequestForRMAItemVO

setReceivedQuantity(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setReceivedQuantity(BigDecimal) - Method in class bb.common.RMAReceiverResult

setReceivedStdCost(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

setReceivedTo(String) - Method in class bb.common.ReceivedToOrderItem

setReceivedTo(String) - Method in class bb.common.ReceiverItemDetailAgent

setReceivedToDetails(Set<ReceiverItemDetailAgent>) - Method in class bb.common.ReceiverItemAgent

setReceivedToOrderItems(Set) - Method in class bb.common.ReceivingItemResult

setReceiveNeedIr(boolean) - Method in class bb.common.CompanyVO

setReceiver(String) - Method in class bb.common.DisassembleWorkOrderIssuingResult

setReceiver(String) - Method in class bb.common.MessageVO

setReceiver(String) - Method in class bb.common.PartReceivedVO

setReceiver(String) - Method in class bb.common.PfReceiverItemVO

setReceiver(String) - Method in class bb.common.ReceivingResult

setReceiver(String) - Method in class bb.common.SgClientProgramUserVO

setReceiverComments(String) - Method in class bb.common.MakeAccountPayableAgent

setReceiverComments(String) - Method in class bb.common.ReceiverInfoVO

setReceiverComments(String) - Method in class bb.common.TransferReceiverListResult

setReceiverComments(String) - Method in class bb.common.TransferReceiverVO

setReceiverDigits(byte) - Method in class bb.common.CompanyVO

setReceiverItem(Set) - Method in class bb.common.OnloanReceiverVO

setReceiverItem(Set) - Method in class bb.common.ReceiverVO

setReceiverItemManufacturer(Set) - Method in class bb.common.ReceiverItemVO

setReceiverItemNumber(String) - Method in class bb.common.AccountsPayableItemVO

setReceiverItemNumber(String) - Method in class bb.common.OnloanReceiverItemListResult

setReceiverItemNumber(String) - Method in class bb.common.OnloanReceiverItemPK

setReceiverItemNumber(String) - Method in class bb.common.ReceiverItemPK

setReceiverItems(ArrayList<ReceiverItemPK>) - Method in class bb.common.MakeAccountPayableAgent

setReceiverNotes(String) - Method in class bb.common.MakeAccountPayableAgent

setReceiverNumber(String) - Method in class bb.common.AccountPayableCheckRunItemVO

setReceiverNumber(String) - Method in class bb.common.AccountPayableInfoWithPrepayResult

setReceiverNumber(String) - Method in class bb.common.AccountsPayableInfoVO

setReceiverNumber(String) - Method in class bb.common.AccountsPayableItemVO

setReceiverNumber(String) - Method in class bb.common.AccountsPayableVO

setReceiverNumber(String) - Method in class bb.common.APItemListResult

setReceiverNumber(String) - Method in class bb.common.GeneralLedgerListResult

setReceiverNumber(String) - Method in class bb.common.GeneralLedgerResult

setReceiverNumber(String) - Method in class bb.common.GeneralLedgerVO

setReceiverNumber(String) - Method in class bb.common.MakeAccountPayableAgent

setReceiverNumber(String) - Method in class bb.common.NcrNeedToScrapListResult

setReceiverNumber(String) - Method in class bb.common.NonConformanceReportVO

setReceiverNumber(String) - Method in class bb.common.OnloanReceiverItemListResult

setReceiverNumber(String) - Method in class bb.common.OnloanReceiverItemPK

setReceiverNumber(String) - Method in class bb.common.OnloanReceiverListResult

setReceiverNumber(String) - Method in class bb.common.OnloanReceiverVO

setReceiverNumber(String) - Method in class bb.common.PartCertificateListResult

setReceiverNumber(String) - Method in class bb.common.PartCertificateVO

setReceiverNumber(String) - Method in class bb.common.PartInQAVO

setReceiverNumber(String) - Method in class bb.common.POReceiverItemListResult

setReceiverNumber(String) - Method in class bb.common.ReceiverInfoVO

setReceiverNumber(String) - Method in class bb.common.ReceiverItemAgent

setReceiverNumber(String) - Method in class bb.common.ReceiverItemManufacturerPK

setReceiverNumber(String) - Method in class bb.common.ReceiverItemPK

setReceiverNumber(String) - Method in class bb.common.ReceiverVO

setReceiverNumber(String) - Method in class bb.common.RMAReceiverItemListResult

setReceiverNumber(String) - Method in class bb.common.RMAReceiverItemPK

setReceiverNumber(String) - Method in class bb.common.RMAReceiverListResult

setReceiverNumber(String) - Method in class bb.common.RMAReceiverVO

setReceiverNumber(String) - Method in class bb.common.StockTransactionPOReceiverResult

setReceiverNumber(String) - Method in class bb.common.TempReceiverWithoutAPInfo

setReceiverPrefix(String) - Method in class bb.common.CompanyVO

setReceiverPrivateNotes(String) - Method in class bb.common.ReceiverInfoVO

setReceiverPrivateNotes(String) - Method in class bb.common.TransferReceiverListResult

setReceiverPrivateNotes(String) - Method in class bb.common.TransferReceiverVO

setReceivers(String) - Method in class bb.common.MessageAgent

setReceiverUserName(String) - Method in class bb.common.MessageVO

setReceiveSign(String) - Method in class bb.common.AssetUsageVO

setReceiveSign(String) - Method in class bb.common.CustomAssetRecordVO

setReceiveSign(String) - Method in class bb.common.CustomAssetVO

setReceiveVo(DisassembleWorkOrderItemReceiverVO) - Method in class bb.common.DisassembleWorkOrderItemPartDetailItemResult

setReceivingItems(Set) - Method in class bb.common.ReceivingResult

setReceivingPOZeroCost(boolean) - Method in class bb.common.CompanyVO

setReceNumber(String) - Method in class bb.common.SerialNumberResult

setRecItemsOnTimeCount(int) - Method in class bb.common.PurchaseOrderOnTimeItemResult

setRecItemsOnTimeCount(int) - Method in class bb.common.WorkOrderOnTimeItemResult

setRecNumber(String) - Method in class bb.common.MiscDocAgent

setRecoil(boolean) - Method in class bb.common.CompanyVO

setRecoil(boolean) - Method in class bb.common.PartVO

setRecoil(boolean) - Method in class bb.common.PartWithOnhandsVO

setReconciledDate(Date) - Method in class bb.common.GeneralLedgerVO

setRecorder(String) - Method in class bb.common.CustomCheckUpEmployeeVO

setRecorder(String) - Method in class bb.common.CustomEmployeeTrainVO

setRecorder(String) - Method in class bb.common.EmployeeTrainingVO

setRecordNumber(String) - Method in class bb.common.OperatingOutputFileItemVO

setRecordType(String) - Method in class bb.common.EmployeeRecordsVO

setRecordType(String) - Method in class bb.common.MiscDocAgent

setRecostedDate(Date) - Method in class bb.common.PartInventoryVO

setRecQty(BigDecimal) - Method in class bb.common.EcnPOOrderResult

setRecQty(BigDecimal) - Method in class bb.common.StockTransactionPOReceiverResult

setRecQty(BigDecimal) - Method in class bb.common.StockTransactionWOReceiverResult

setRecQuantity(BigDecimal) - Method in class bb.common.WOIssuedByMonthResult

setRectifySightLeft(BigDecimal) - Method in class bb.common.CustomCheckUpEmployeeVO

setRectifySightRight(BigDecimal) - Method in class bb.common.CustomCheckUpEmployeeVO

setRecTotalOnTime(BigDecimal) - Method in class bb.common.PurchaseOrderOnTimeItemResult

setRecTotalOnTime(BigDecimal) - Method in class bb.common.WorkOrderOnTimeItemResult

setRecWoApprovedBy(String) - Method in class bb.common.AccountingConfigurationVO

setRef(String) - Method in class bb.common.EquipmentListResult

setRef(String) - Method in class bb.common.EquipmentVO

setRef(String) - Method in class bb.common.WorkInstructionSequenceVO

setRef(String) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setRefAcct(String) - Method in class bb.common.NonConformanceReportVO

setRefDoc(String) - Method in class bb.common.PartInQAAgent

setRefDoc(String) - Method in class bb.common.PartInQAVO

setRefDoc(String) - Method in class bb.common.PartOnhandCostVO

setRefdoc(Map) - Method in class bb.common.PurchaseWorkSheetItemVO

setRefDoc(Set) - Method in class bb.common.RunningAccountOrderItemVO

setRefdoc(String) - Method in class bb.common.TotalAmountInPOByRefDoc

setRefDoc(Set<RefdocVO>) - Method in class bb.common.WorkOrderWorkInstructionListResult

setRefDoc1(String) - Method in class bb.common.AccountsPayableItemVO

setRefDoc1(String) - Method in class bb.common.AccountsReceivableItemVO

setRefDoc1(String) - Method in class bb.common.AssetVO

setRefDoc1(String) - Method in class bb.common.CorrectiveActionRequestVO

setRefDoc1(String) - Method in class bb.common.CustomerReturnToVendorItemVO

setRefDoc1(String) - Method in class bb.common.CustomerServiceIncidentVO

setRefDoc1(String) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setRefDoc1(Set<RefdocElement>) - Method in class bb.common.DisassembleWorkOrderItemListResult

setRefDoc1(String) - Method in class bb.common.DisassembleWorkOrderReceivingResult

setRefDoc1(String) - Method in class bb.common.EngineeringChangeVO

setRefDoc1(String) - Method in class bb.common.IssuingResult

setRefDoc1(String) - Method in class bb.common.JobProcessSheetListResult

setRefDoc1(String) - Method in class bb.common.LogInventoryListResult

setRefDoc1(String) - Method in class bb.common.LogInventoryVO

setRefDoc1(String) - Method in class bb.common.LogTrackingVO

setRefDoc1(String) - Method in class bb.common.NonConformanceReportVO

setRefDoc1(String) - Method in class bb.common.OnLoanItemVO

setRefDoc1(String) - Method in class bb.common.POItemByRefDoc1ListResult

setRefDoc1(String) - Method in class bb.common.PreventiveActionRequestVO

setRefDoc1(String) - Method in class bb.common.ProformaInvoiceItemVO

setRefDoc1(String) - Method in class bb.common.PurchaseOrderOnOrderResult

setRefDoc1(String) - Method in class bb.common.ReceivingItemResult

setRefDoc1(String) - Method in class bb.common.RequestForQuoteItemListResult

setRefDoc1(String) - Method in class bb.common.RequestForRMAItemVO

setRefDoc1(String) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setRefDoc1(String) - Method in class bb.common.ReturnToVendorItemListResult

setRefDoc1(String) - Method in class bb.common.ReturnToVendorItemVO

setRefDoc1(String) - Method in class bb.common.RMAReceiverItemVO

setRefDoc1(String) - Method in class bb.common.RtvShipperItemVO

setRefDoc1(String) - Method in class bb.common.SalesOrderOnDemandResult

setRefDoc1(String) - Method in class bb.common.ShippingItemResult

setRefDoc1(String) - Method in class bb.common.SwapOrderItemVO

setRefDoc1(String) - Method in class bb.common.SwapReceiverItemVO

setRefDoc1(String) - Method in class bb.common.SwapShipperItemVO

setRefDoc1(String) - Method in class bb.common.TransferOrderItemVO

setRefDoc1(String) - Method in class bb.common.TransferReceiverItemListResult

setRefDoc1(String) - Method in class bb.common.TransferReceiverItemVO

setRefDoc1(String) - Method in class bb.common.TransferShipperItemListResult

setRefDoc1(String) - Method in class bb.common.TransferShipperItemVO

setRefDoc1(Set<RefdocElement>) - Method in class bb.common.WorkOrderItemListResult

setRefDoc1(String) - Method in class bb.common.WorkOrderOnDemandResult

setRefDoc1(String) - Method in class bb.common.WorkOrderOnOrderResult

setRefDoc1Set(Set) - Method in class bb.common.DisassembleWorkOrderItemPartDetailItemResult

setRefDoc1Set(Set) - Method in class bb.common.WorkOrderItemPartDetailItemResult

setRefDoc2(String) - Method in class bb.common.AccountsPayableItemVO

setRefDoc2(String) - Method in class bb.common.AccountsReceivableItemVO

setRefDoc2(String) - Method in class bb.common.AssetVO

setRefDoc2(String) - Method in class bb.common.CorrectiveActionRequestVO

setRefDoc2(String) - Method in class bb.common.CustomerReturnToVendorItemVO

setRefDoc2(String) - Method in class bb.common.CustomerServiceIncidentVO

setRefDoc2(String) - Method in class bb.common.DisassembleWorkOrderIssueVO

setRefDoc2(String) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setRefDoc2(Set<RefdocElement>) - Method in class bb.common.DisassembleWorkOrderItemListResult

setRefDoc2(String) - Method in class bb.common.DisassembleWorkOrderReceivingResult

setRefDoc2(String) - Method in class bb.common.EngineeringChangeVO

setRefDoc2(String) - Method in class bb.common.IssuingResult

setRefDoc2(String) - Method in class bb.common.JobProcessSheetListResult

setRefDoc2(String) - Method in class bb.common.LogInventoryListResult

setRefDoc2(String) - Method in class bb.common.LogInventoryVO

setRefDoc2(String) - Method in class bb.common.LogTrackingVO

setRefDoc2(String) - Method in class bb.common.NonConformanceReportVO

setRefDoc2(String) - Method in class bb.common.OnLoanItemVO

setRefDoc2(String) - Method in class bb.common.PreventiveActionRequestVO

setRefDoc2(String) - Method in class bb.common.ProformaInvoiceItemVO

setRefDoc2(String) - Method in class bb.common.PurchaseOrderOnOrderResult

setRefDoc2(String) - Method in class bb.common.ReceivingItemResult

setRefDoc2(String) - Method in class bb.common.RequestForQuoteItemListResult

setRefDoc2(String) - Method in class bb.common.RequestForRMAItemVO

setRefDoc2(String) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setRefDoc2(String) - Method in class bb.common.ReturnToVendorByDateListResult

setRefDoc2(String) - Method in class bb.common.ReturnToVendorItemListResult

setRefDoc2(String) - Method in class bb.common.ReturnToVendorItemVO

setRefDoc2(String) - Method in class bb.common.RMAReceiverItemVO

setRefDoc2(String) - Method in class bb.common.RtvShipperItemVO

setRefDoc2(String) - Method in class bb.common.SalesOrderOnDemandResult

setRefDoc2(String) - Method in class bb.common.ShippingItemResult

setRefDoc2(String) - Method in class bb.common.SwapOrderItemVO

setRefDoc2(String) - Method in class bb.common.SwapReceiverItemVO

setRefDoc2(String) - Method in class bb.common.SwapShipperItemVO

setRefDoc2(String) - Method in class bb.common.TransferOrderItemVO

setRefDoc2(String) - Method in class bb.common.TransferReceiverItemListResult

setRefDoc2(String) - Method in class bb.common.TransferReceiverItemVO

setRefDoc2(String) - Method in class bb.common.TransferShipperItemListResult

setRefDoc2(String) - Method in class bb.common.TransferShipperItemVO

setRefDoc2(Set<RefdocElement>) - Method in class bb.common.WorkOrderItemListResult

setRefDoc2(String) - Method in class bb.common.WorkOrderOnDemandResult

setRefDoc2(String) - Method in class bb.common.WorkOrderOnOrderResult

setRefDoc2(String) - Method in class bb.common.WorkOrderReceiverVO

setRefDocDetails(Set<RefdocVO>) - Method in class bb.common.PartWithQAQtyListResult

setRefDocDetails(Set<RefdocVO>) - Method in class bb.common.PartWithQtyListResult

setRefDocDetails(Set<RefdocVO>) - Method in class bb.common.PartWithSipQtyListResult

setRefDocDetails(Set<RefdocVO>) - Method in class bb.common.PartWithSITQtyListResult

setRefDocDetails(Set<RefdocVO>) - Method in class bb.common.PartWithSTOQtyListResult

setRefDocDetails(Set<RefdocVO>) - Method in class bb.common.PartWithWipQtyListResult

setRefDocOnes(Set) - Method in class bb.common.AccountsPayableItemVO

setRefDocOnes(Set) - Method in class bb.common.AccountsReceivableItemVO

setRefDocOnes(Set) - Method in class bb.common.DisassembleWorkOrderItemListResult

setRefDocOnes(Set) - Method in class bb.common.DisassembleWorkOrderItemVO

setRefDocOnes(Set) - Method in class bb.common.InspectionConformanceReportItemVO

setRefDocOnes(Set) - Method in class bb.common.PurchaseOrderItemListResult

setRefDocOnes(Set) - Method in class bb.common.PurchaseOrderItemVO

setRefDocOnes(Set) - Method in class bb.common.QuoteItemVO

setRefDocOnes(Set) - Method in class bb.common.ReceiverItemVO

setRefDocOnes(Set) - Method in class bb.common.RtvShipperItemVO

setRefDocOnes(Set) - Method in class bb.common.SalesOrderItemListResult

setRefDocOnes(Set) - Method in class bb.common.SalesOrderItemVO

setRefDocOnes(Set) - Method in class bb.common.ShipperItemVO

setRefDocOnes(Set) - Method in class bb.common.WorkOrderItemListResult

setRefDocOnes(Set) - Method in class bb.common.WorkOrderItemVO

setRefDocReceiver(String) - Method in class bb.common.PartOnhandCostVO

setRefDocTwo(RefdocVO, String) - Static method in class bb.common.BB2Util

setRefDocTwoes(Set) - Method in class bb.common.AccountsPayableItemVO

setRefDocTwoes(Set) - Method in class bb.common.AccountsReceivableItemVO

setRefDocTwoes(Set) - Method in class bb.common.DisassembleWorkOrderItemListResult

setRefDocTwoes(Set) - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

setRefDocTwoes(Set) - Method in class bb.common.DisassembleWorkOrderItemVO

setRefDocTwoes(Set) - Method in class bb.common.InspectionConformanceReportItemVO

setRefDocTwoes(Set) - Method in class bb.common.PurchaseOrderItemListResult

setRefDocTwoes(Set) - Method in class bb.common.PurchaseOrderItemVO

setRefDocTwoes(Set) - Method in class bb.common.QuoteItemVO

setRefDocTwoes(Set) - Method in class bb.common.ReceiverItemVO

setRefDocTwoes(Set) - Method in class bb.common.RtvShipperItemVO

setRefDocTwoes(Set) - Method in class bb.common.SalesOrderItemListResult

setRefDocTwoes(Set) - Method in class bb.common.SalesOrderItemVO

setRefDocTwoes(Set) - Method in class bb.common.ShipperItemVO

setRefDocTwoes(Set) - Method in class bb.common.SwapOrderItemVO

setRefDocTwoes(Set) - Method in class bb.common.SwapReceiverItemVO

setRefDocTwoes(Set) - Method in class bb.common.SwapShipperItemVO

setRefDocTwoes(Set) - Method in class bb.common.TransferOrderItemVO

setRefDocTwoes(Set) - Method in class bb.common.TransferShipperItemVO

setRefDocTwoes(Set) - Method in class bb.common.WoItemPickListResult

setRefDocTwoes(Set) - Method in class bb.common.WorkOrderItemListResult

setRefDocTwoes(Set) - Method in class bb.common.WorkOrderItemPartDetailResult

setRefDocTwoes(Set) - Method in class bb.common.WorkOrderItemVO

setReferenceDoc1(String) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

setReferenceDoc1(String) - Method in class bb.common.DisassembleWorkOrderItemVO

setReferenceDoc1(String) - Method in class bb.common.OnloanReceiverItemVO

setReferenceDoc1(String) - Method in class bb.common.OnloanShipperItemVO

setReferenceDoc1(String) - Method in class bb.common.OrderApprovalItemsVO

setReferenceDoc1(String) - Method in class bb.common.PurchaseOrderItemVO

setReferenceDoc1(String) - Method in class bb.common.QuoteItemVO

setReferenceDoc1(String) - Method in class bb.common.ReceiverItemVO

setReferenceDoc1(String) - Method in class bb.common.RequestForQuoteItemVO

setReferenceDoc1(String) - Method in class bb.common.SalesOrderItemInfoVO

setReferenceDoc1(String) - Method in class bb.common.SalesOrderItemVO

setReferenceDoc1(String) - Method in class bb.common.ShipperItemVO

setReferenceDoc1(String) - Method in class bb.common.WorkOrderItemIssueVO

setReferenceDoc1(String) - Method in class bb.common.WorkOrderItemVO

setReferenceDoc2(String) - Method in class bb.common.DisassembleWorkOrderItemVO

setReferenceDoc2(String) - Method in class bb.common.OnloanReceiverItemVO

setReferenceDoc2(String) - Method in class bb.common.OnloanShipperItemVO

setReferenceDoc2(String) - Method in class bb.common.OrderApprovalItemsVO

setReferenceDoc2(String) - Method in class bb.common.PurchaseOrderItemVO

setReferenceDoc2(String) - Method in class bb.common.QuoteItemVO

setReferenceDoc2(String) - Method in class bb.common.ReceiverItemVO

setReferenceDoc2(String) - Method in class bb.common.RequestForQuoteItemVO

setReferenceDoc2(String) - Method in class bb.common.SalesOrderItemInfoVO

setReferenceDoc2(String) - Method in class bb.common.SalesOrderItemVO

setReferenceDoc2(String) - Method in class bb.common.ShipperItemVO

setReferenceDoc2(String) - Method in class bb.common.WorkOrderItemVO

setReferenceNumber(String) - Method in class bb.common.PartCertificateListResult

setReferenceNumber(String) - Method in class bb.common.PartCertificateVO

setReferenceSalesOrder(String) - Method in class bb.common.SalesOrderVO

setReferer(String) - Method in class bb.common.SGQuoteLoginVO

setRefId(String) - Method in class bb.common.BizBoxUserEmployeeResult

setRefId(String) - Method in class bb.common.BizboxUserListResult

setRefId(String) - Method in class bb.common.BizboxUserVO

setRefId(Long) - Method in class bb.common.MessageAgent

setRefId(Long) - Method in class bb.common.MessageVO

setRefId(String) - Method in class bb.common.User2UserAgent

setRefId(String) - Method in class bb.common.UserRolePermissionListResult

setRefNAPO(boolean) - Method in class bb.common.CompanyVO

setRefNumber(String) - Method in class bb.common.MiscDocAgent

setRefNumber(String) - Method in class bb.common.SerialNumberResult

setRegion(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setRegion(String) - Method in class bb.common.CustomerVendorAddressVO

setRegion(String) - Method in class bb.common.SalesOrderItemListResult

setRegulared(boolean) - Method in class bb.common.InspectionConformanceReportItemCheckVO

setReimbursement(BigDecimal) - Method in class bb.common.ExpenseVO

setReject(BigDecimal) - Method in class bb.common.WorkOrderItemTimeDetailVO

setRejectPercent(BigDecimal) - Method in class bb.common.NCQRejectResult

setRejectQty(BigDecimal) - Method in class bb.common.InspectionReportInfoVO

setRejectQty(BigDecimal) - Method in class bb.common.InspectionReportVO

setRejectQty(BigDecimal) - Method in class bb.common.JobProcessSheetItemResult

setRejectQty(BigDecimal) - Method in class bb.common.WorkOrderTimeCardVO

setRejectQuantity(BigDecimal) - Method in class bb.common.NCQRejectResult

setRejectQuantity(BigDecimal) - Method in class bb.common.NonConformanceQuantityVO

setRejectReason(String) - Method in class bb.common.InspectionReportInfoVO

setRejectReason(String) - Method in class bb.common.InspectionReportVO

setRelatedDoc(String) - Method in class bb.common.CustomerReturnToVendorVO

setRelatedDoc(String) - Method in class bb.common.DisassembleWorkOrderIssuingResult

setRelatedDoc(String) - Method in class bb.common.DisassembleWorkOrderItemListResult

setRelatedDoc(String) - Method in class bb.common.DisassembleWorkOrderItemVO

setRelatedDoc(String) - Method in class bb.common.DisassembleWorkOrderVO

setRelatedDoc(String) - Method in class bb.common.OnloanReceiverVO

setRelatedDoc(String) - Method in class bb.common.OnloanShipperVO

setRelatedDoc(String) - Method in class bb.common.PartIssuedListResult

setRelatedDoc(String) - Method in class bb.common.PartReceivedListResult

setRelatedDoc(String) - Method in class bb.common.PfReceiverVO

setRelatedDoc(String) - Method in class bb.common.POStatisticsResult

setRelatedDoc(String) - Method in class bb.common.PrReceiverListResult

setRelatedDoc(String) - Method in class bb.common.PurchaseOrderItemListResult

setRelatedDoc(String) - Method in class bb.common.PurchaseOrderListResult

setRelatedDoc(String) - Method in class bb.common.PurchaseOrderVO

setRelatedDoc(String) - Method in class bb.common.ReceiverInfoVO

setRelatedDoc(String) - Method in class bb.common.ReceiverVO

setRelatedDoc(String) - Method in class bb.common.ReceivingResult

setRelatedDoc(String) - Method in class bb.common.RequestForQuoteVO

setRelatedDoc(String) - Method in class bb.common.RequestForRMAVO

setRelatedDoc(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setRelatedDoc(String) - Method in class bb.common.SalesOrderItemListResult

setRelatedDoc(String) - Method in class bb.common.ShipperInfoVO

setRelatedDoc(String) - Method in class bb.common.ShipperVO

setRelatedDoc(String) - Method in class bb.common.SwapOrderItemListResult

setRelatedDoc(String) - Method in class bb.common.SwapOrderListResult

setRelatedDoc(String) - Method in class bb.common.SwapOrderVO

setRelatedDoc(String) - Method in class bb.common.SwapReceiverListResult

setRelatedDoc(String) - Method in class bb.common.SwapReceiverVO

setRelatedDoc(String) - Method in class bb.common.SwapShipperListResult

setRelatedDoc(String) - Method in class bb.common.SwapShipperVO

setRelatedDoc(String) - Method in class bb.common.TotalAmountInPOByRefDoc

setRelatedDoc(String) - Method in class bb.common.WorkOrderItemInfoResult

setRelatedDoc(String) - Method in class bb.common.WorkOrderItemInWipListResult

setRelatedDoc(String) - Method in class bb.common.WorkOrderItemIssuedTotalResult

setRelatedDoc(String) - Method in class bb.common.WorkOrderItemListResult

setRelatedDoc(String) - Method in class bb.common.WorkOrderItemPartDetail

setRelatedDoc(String) - Method in class bb.common.WorkOrderItemVO

setRelatedDoc(String) - Method in class bb.common.WorkOrderQueryInfo

setRelatedDoc(String) - Method in class bb.common.WorkOrderVO

setRelatedDocument(String) - Method in class bb.common.QuoteVO

setRelatedDocument(String) - Method in class bb.common.SalesOrderListResult

setRelatedDocument(String) - Method in class bb.common.SalesOrderVO

setRelatedDocument(String) - Method in class bb.common.TransferOrderListResult

setRelatedDocument(String) - Method in class bb.common.TransferOrderVO

setRelatedDocument(String) - Method in class bb.common.TransferReceiverListResult

setRelatedDocument(String) - Method in class bb.common.TransferReceiverVO

setRelatedDocument(String) - Method in class bb.common.TransferShipperListResult

setRelatedDocument(String) - Method in class bb.common.TransferShipperVO

setRelatedInspectorSign(String) - Method in class bb.common.OperatingInstructionsVO

setReldoc(String) - Method in class bb.common.AccountsPayableInfoVO

setReldoc(String) - Method in class bb.common.AccountsPayableVO

setReldoc(String) - Method in class bb.common.AccountsReceivableInfoVO

setReldoc(String) - Method in class bb.common.AccountsReceivableVO

setReldoc(String) - Method in class bb.common.GeneralLedgerListResult

setReldoc(String) - Method in class bb.common.GeneralLedgerVO

setReldoc(String) - Method in class bb.common.OnLoanVO

setReldoc(String) - Method in class bb.common.ProformaInvoiceVO

setReldoc(String) - Method in class bb.common.ReturnToVendorVO

setReldoc(String) - Method in class bb.common.RMAReceiverVO

setReldoc(String) - Method in class bb.common.RtvShipperInfoVO

setReldoc(String) - Method in class bb.common.RtvShipperVO

setRelevantAccount(String) - Method in class bb.common.JounalEntryListResult

setRelevantAccountDescription(String) - Method in class bb.common.JounalEntryListResult

setRemarks(String) - Method in class bb.common.CarrierVO

setRemarks(String) - Method in class bb.common.DocumentServerVO

setRemarks(String) - Method in class bb.common.DwfUploadSettingsVO

setRemarks(String) - Method in class bb.common.DwgUploadSettingsVO

setRemarks(String) - Method in class bb.common.MiscDocumentSettingVO

setRemarks(String) - Method in class bb.common.PartManufacturerVO

setRemarks(String) - Method in class bb.common.PartVendorVO

setRemarks(String) - Method in class bb.common.ToolManufacturerVO

setRemarks(String) - Method in class bb.common.ToolVendorVO

setRemitAddressId(String) - Method in class bb.common.CompanyVO

setRemitId(String) - Method in class bb.common.AccountPayableCheckVO

setRemitId(String) - Method in class bb.common.AccountReceivablePaymentVO

setRemitId(String) - Method in class bb.common.AccountsReceivableInfoVO

setRemitId(String) - Method in class bb.common.AccountsReceivableVO

setRemitId(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setRemitId(String) - Method in class bb.common.CustomerVendorAddressVO

setRemitId(String) - Method in class bb.common.OnloanShipperVO

setRemitId(String) - Method in class bb.common.ProformaInvoiceVO

setRemitId(String) - Method in class bb.common.RtvShipperInfoVO

setRemitId(String) - Method in class bb.common.RtvShipperVO

setRemitId(String) - Method in class bb.common.ShipperInfoVO

setRemitId(String) - Method in class bb.common.ShipperVO

setRemoved(boolean) - Method in class bb.common.MessageVO

setRemovedItem(String) - Method in class bb.common.SalesBomItemResult

setRepeatDelay(int) - Method in class bb.common.TaskVO

setReplaceDesc(String) - Method in class bb.common.BillItemReplacementVO

setReplacedItem(String) - Method in class bb.common.WorkOrderItemIssueVO

setReplacedItem(String) - Method in class bb.common.WorkOrderItemSetupItemAgent

setReplaceItem(String) - Method in class bb.common.WorkOrderItemSetupItemAgent

setReplacePartNumber(String) - Method in class bb.common.BillItemReplacementVO

setReplacePartType(String) - Method in class bb.common.BillItemReplacementVO

setReportBugEmail(String) - Method in class bb.common.CompanyVO

setReportBy(String) - Method in class bb.common.BizboxBugInfoVO

setReportBy(String) - Method in class bb.common.BizboxBugVO

setReportBy(String) - Method in class bb.common.CustomerServiceIncidentItemListResult

setReportBy(String) - Method in class bb.common.CustomerServiceIncidentVO

setReportDate(Date) - Method in class bb.common.BizboxBugInfoVO

setReportDate(Date) - Method in class bb.common.BizboxBugVO

setReportedBy(String) - Method in class bb.common.CustomerFeedbackVO

setReportType(String) - Method in class bb.common.AccountsChartCategoryVO

setReqDescription(String) - Method in class bb.common.CSRAgent

setReqDescription(String) - Method in class bb.common.SGCustomerServiceRequestVO

setRequester(String) - Method in class bb.common.ApPrepayVO

setRequester(String) - Method in class bb.common.ArPrepayVO

setRequester(String) - Method in class bb.common.CRTVListResult

setRequester(String) - Method in class bb.common.CustomerReturnToVendorVO

setRequester(String) - Method in class bb.common.OnloanReceiverVO

setRequester(String) - Method in class bb.common.PfReceiverVO

setRequester(String) - Method in class bb.common.POStatisticsResult

setRequester(String) - Method in class bb.common.PurchaseOrderContractResult

setRequester(String) - Method in class bb.common.PurchaseOrderItemListResult

setRequester(String) - Method in class bb.common.PurchaseOrderListResult

setRequester(String) - Method in class bb.common.PurchaseOrderVO

setRequester(String) - Method in class bb.common.QuoteVO

setRequester(String) - Method in class bb.common.ReceiverInfoVO

setRequester(String) - Method in class bb.common.ReceiverVO

setRequester(String) - Method in class bb.common.RequestForQuoteVO

setRequester(String) - Method in class bb.common.RequestForRMAVO

setRequester(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setRequester(String) - Method in class bb.common.RMAListResult

setRequester(String) - Method in class bb.common.RRMAListResult

setRequester(String) - Method in class bb.common.SalesOrderVO

setRequester(String) - Method in class bb.common.TransferOrderListResult

setRequester(String) - Method in class bb.common.TransferOrderVO

setRequestForQuote(String) - Method in class bb.common.PartVendorVO

setRequestForQuote(String) - Method in class bb.common.ToolVendorVO

setRequestForQuoteItem(Set) - Method in class bb.common.RequestForQuoteVO

setRequestForQuoteItemManufacturer(Set) - Method in class bb.common.RequestForQuoteItemVO

setRequestForQuoteItemNumber(String) - Method in class bb.common.RequestForQuoteItemManufacturerPK

setRequestForQuoteItemNumber(String) - Method in class bb.common.RequestForQuoteItemPK

setRequestForQuoteNumber(String) - Method in class bb.common.RequestForQuoteItemManufacturerPK

setRequestForQuoteNumber(String) - Method in class bb.common.RequestForQuoteItemPK

setRequestForQuoteNumber(String) - Method in class bb.common.RequestForQuoteVO

setRequestInspectionDate(Date) - Method in class bb.common.OperatingInstructionsVO

setRequestor(String) - Method in class bb.common.AccountsPayableInfoVO

setRequestor(String) - Method in class bb.common.AccountsPayableVO

setRequestor(String) - Method in class bb.common.AccountsReceivableInfoVO

setRequestor(String) - Method in class bb.common.AccountsReceivableVO

setRequestor(String) - Method in class bb.common.CSRAgent

setRequestor(String) - Method in class bb.common.DisassembleWorkOrderVO

setRequestor(String) - Method in class bb.common.OnLoanVO

setRequestor(String) - Method in class bb.common.ReturnToVendorByDateListResult

setRequestor(String) - Method in class bb.common.ReturnToVendorVO

setRequestor(String) - Method in class bb.common.RMAReceiverVO

setRequestor(String) - Method in class bb.common.SGCustomerServiceRequestVO

setRequestor(String) - Method in class bb.common.WorkOrderVO

setRequireAuth(boolean) - Method in class bb.common.SmtpServerVO

setRequireDate(Date) - Method in class bb.common.CSRAgent

setRequireDate(Date) - Method in class bb.common.DisassembleWorkOrderReceivingResult

setRequireDate(Date) - Method in class bb.common.IssuingResult

setRequireDate(Date) - Method in class bb.common.SGCustomerServiceRequestVO

setRequireDate(Date) - Method in class bb.common.SGCustRequestForQuoteItemVO

setRequiredDate(Date) - Method in class bb.common.JobProcessSheetItemResult

setRequiredDate(Date) - Method in class bb.common.WorkOrderWorkInstructionListResult

setRequiredQty(BigDecimal) - Method in class bb.common.ShipListItemVOResult

setResearchDevelopment(List) - Method in class bb.common.ProfitLossStatementResult

setReSend(boolean) - Method in class bb.common.AccountingInfoDocumentVO

setResolveResult(String) - Method in class bb.common.OperatingInstructionsVO

setResolveResultSign(String) - Method in class bb.common.OperatingInstructionsVO

setRespondDate(Date) - Method in class bb.common.RequestForQuoteListResult

setResponsibility(String) - Method in class bb.common.CorrectiveActionRequestVO

setResponsibility(String) - Method in class bb.common.NcrNeedToScrapListResult

setResponsibility(String) - Method in class bb.common.NcrReportListResult

setResponsibility(String) - Method in class bb.common.NonConformanceReportVO

setResponsibility(String) - Method in class bb.common.OperatingInstructionsUserStatisticalResult

setResponsibility(String) - Method in class bb.common.OperatingInstructionsVO

setResult(String) - Method in class bb.common.CustomEmployeeTrainVO

setResult(String) - Method in class bb.common.EmployeeTrainingVO

setResults(String) - Method in class bb.common.CustomerServiceIncidentItemVO

setResults(Collection<GeneralLedgerByDateListResult>) - Method in class bb.common.GLCheckRegisterResult

setRetainedEarnings(BigDecimal) - Method in class bb.common.AccountingBalanceSheetResult

setRetainedEarningTotal(ClosingStatementTotalResult) - Method in class bb.common.ClosingStatementResult

setRetainedEqrning(BigDecimal) - Method in class bb.common.ClosingStatementResult

setReturnAddressId(String) - Method in class bb.common.CompanyVO

setReturnComment(String) - Method in class bb.common.AssetUsageVO

setReturnComment(String) - Method in class bb.common.CustomAssetRecordVO

setReturnDate(Date) - Method in class bb.common.AssetUsageVO

setReturnDate(Date) - Method in class bb.common.CustomAssetRecordVO

setReturnDepartment(String) - Method in class bb.common.AssetUsageVO

setReturnDepartment(String) - Method in class bb.common.CustomAssetRecordVO

setReturnMaterialAuthorizationItemManufacturer(Set) - Method in class bb.common.CustomerReturnToVendorItemVO

setReturnMaterialAuthorizationItemManufacturer(Set) - Method in class bb.common.RequestForRMAItemVO

setReturnMaterialAuthorizationItemManufacturer(Set) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setReturnOnSales(BigDecimal) - Method in class bb.common.ProfitLossStatementResult

setReturnSign(String) - Method in class bb.common.AssetUsageVO

setReturnSign(String) - Method in class bb.common.CustomAssetRecordVO

setReturnTemplateID(int) - Method in class bb.common.PointOfSaleVO

setReturnToVendorItemManufacturer(Set) - Method in class bb.common.ReturnToVendorItemVO

setReturnToVendorItemNumber(String) - Method in class bb.common.ReturnToVendorItemManufacturerPK

setReturnToVendorItemNumber(String) - Method in class bb.common.ReturnToVendorItemPK

setReturnToVendorNumber(String) - Method in class bb.common.ReturnToVendorItemManufacturerPK

setReturnToVendorNumber(String) - Method in class bb.common.ReturnToVendorItemPK

setReturnToVendorNumber(String) - Method in class bb.common.ReturnToVendorVO

setRev(String) - Method in class bb.common.BB2PartInfo

setRev(String) - Method in class bb.common.BillItemSalesResult

setRev(String) - Method in class bb.common.BillItemSalesXResult

setRev(String) - Method in class bb.common.BillSalesResult

setRev(String) - Method in class bb.common.BillSalesXResult

setRev(String) - Method in class bb.common.BomItemWithOEMResult

setRev(String) - Method in class bb.common.BomWithOEMResult

setRev(String) - Method in class bb.common.InventoryNotUsedInMonthsResult

setRev(String) - Method in class bb.common.PartWithInventoryInfoListResult

setRev(String) - Method in class bb.common.SGCustRequestForQuoteItemVO

setRev(String) - Method in class bb.common.ShoppingCartItem

setRev(String) - Method in class bb.common.StockTransactionPartInfoResult

setRev(String) - Method in class bb.common.WorkInstructionSummaryResult

setRev(String) - Method in class bb.common.WorkOrderItemCanAssyResult

setRevenueItems(List) - Method in class bb.common.ClosingStatementResult

setRevenueTotal(ClosingStatementTotalResult) - Method in class bb.common.ClosingStatementResult

setReviewDescription(String) - Method in class bb.common.DisassembleWorkOrderItemVO

setReviewDescription(String) - Method in class bb.common.WorkOrderItemReviewCostResult

setReviewDescription(String) - Method in class bb.common.WorkOrderItemVO

setReviewed(Date) - Method in class bb.common.EngineeringSharingImportLogVO

setReviewed(Date) - Method in class bb.common.OnLoanVO

setReviewed(Date) - Method in class bb.common.QuoteVO

setReviewedBy(String) - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

setReviewedBy(String) - Method in class bb.common.DisassembleWorkOrderItemVO

setReviewedBy(String) - Method in class bb.common.EngineeringSharingImportLogVO

setReviewedBy(String) - Method in class bb.common.OnLoanVO

setReviewedBy(String) - Method in class bb.common.QuoteVO

setReviewedBy(String) - Method in class bb.common.SalesOrderVO

setReviewedBy(String) - Method in class bb.common.WOItemCostControlAgent

setReviewedBy(String) - Method in class bb.common.WorkOrderItemPartDetailResult

setReviewedBy(String) - Method in class bb.common.WorkOrderItemReviewCostResult

setReviewedBy(String) - Method in class bb.common.WorkOrderItemVO

setReviewedDate(Date) - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

setReviewedDate(Date) - Method in class bb.common.DisassembleWorkOrderItemVO

setReviewedDate(Date) - Method in class bb.common.SalesOrderVO

setReviewedDate(Date) - Method in class bb.common.WOItemCostControlAgent

setReviewedDate(Date) - Method in class bb.common.WorkOrderItemPartDetailResult

setReviewedDate(Date) - Method in class bb.common.WorkOrderItemReviewCostResult

setReviewedDate(Date) - Method in class bb.common.WorkOrderItemVO

setReviewedDesc(String) - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

setReviewedDesc(String) - Method in class bb.common.WOItemCostControlAgent

setReviewedDesc(String) - Method in class bb.common.WorkOrderItemPartDetailResult

setReviewLimit(BigDecimal) - Method in class bb.common.NonproductivePickingApproveVO

setReviewLimit(BigDecimal) - Method in class bb.common.OnloanReviewVO

setReviewLimit(BigDecimal) - Method in class bb.common.RMAReviewVO

setReviewLimit(BigDecimal) - Method in class bb.common.SalesOrderReviewVO

setRevision(String) - Method in class bb.common.AccountsPayableItemVO

setRevision(String) - Method in class bb.common.AccountsReceivableItemVO

setRevision(String) - Method in class bb.common.BomPickListItemResult

setRevision(String) - Method in class bb.common.CorrectiveActionRequestVO

setRevision(String) - Method in class bb.common.CustomerReturnToVendorItemVO

setRevision(String) - Method in class bb.common.CustomerServiceIncidentVO

setRevision(String) - Method in class bb.common.DisassembleWorkOrderIssueVO

setRevision(String) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setRevision(String) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

setRevision(String) - Method in class bb.common.DisassembleWorkOrderItemVO

setRevision(String) - Method in class bb.common.DisassembleWorkOrderReceivingResult

setRevision(String) - Method in class bb.common.EngineeringChangeRequestVO

setRevision(String) - Method in class bb.common.IssuingItemResult

setRevision(String) - Method in class bb.common.IssuingResult

setRevision(String) - Method in class bb.common.LogPartDwfVO

setRevision(String) - Method in class bb.common.LogPartDwgVO

setRevision(String) - Method in class bb.common.MiscDocAgent

setRevision(String) - Method in class bb.common.NonproductivePickingItemVO

setRevision(String) - Method in class bb.common.OnLoanItemVO

setRevision(String) - Method in class bb.common.OnloanReceiverItemVO

setRevision(String) - Method in class bb.common.OnloanShipperItemVO

setRevision(String) - Method in class bb.common.OrderApprovalItemsVO

setRevision(String) - Method in class bb.common.PackingBoxSalesOrderItemResult

setRevision(String) - Method in class bb.common.PartBasicInfo

setRevision(String) - Method in class bb.common.PartCertificateVO

setRevision(String) - Method in class bb.common.PartDwfVO

setRevision(String) - Method in class bb.common.PartDwfWithPartInfoResult

setRevision(String) - Method in class bb.common.PartDwgAgent

setRevision(String) - Method in class bb.common.PartDwgPK

setRevision(String) - Method in class bb.common.PartDwgWithPartInfoResult

setRevision(String) - Method in class bb.common.PartVO

setRevision(String) - Method in class bb.common.PartWithOnhandsVO

setRevision(String) - Method in class bb.common.PfReceiverItemVO

setRevision(String) - Method in class bb.common.PreventiveActionRequestVO

setRevision(String) - Method in class bb.common.ProformaInvoiceItemVO

setRevision(String) - Method in class bb.common.PurchaseOrderItemVO

setRevision(String) - Method in class bb.common.QuoteItemVO

setRevision(String) - Method in class bb.common.ReceiverItemVO

setRevision(String) - Method in class bb.common.ReceivingItemResult

setRevision(String) - Method in class bb.common.RequestForQuoteItemVO

setRevision(String) - Method in class bb.common.RequestForRMAItemVO

setRevision(String) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setRevision(String) - Method in class bb.common.ReturnToVendorItemVO

setRevision(String) - Method in class bb.common.RMAReceiverItemVO

setRevision(String) - Method in class bb.common.RtvShipperItemVO

setRevision(String) - Method in class bb.common.SalesBomItemResult

setRevision(String) - Method in class bb.common.SalesBomResult

setRevision(String) - Method in class bb.common.SalesOrderItemInfoVO

setRevision(String) - Method in class bb.common.SalesOrderItemVO

setRevision(String) - Method in class bb.common.SalesOrderShipDateListResult

setRevision(String) - Method in class bb.common.SalesPartListItemResult

setRevision(String) - Method in class bb.common.SalesPartListResult

setRevision(String) - Method in class bb.common.SerialNumberResult

setRevision(String) - Method in class bb.common.SGBOMItemResult

setRevision(String) - Method in class bb.common.SGDwgPictureVO

setRevision(String) - Method in class bb.common.SGPartCatalogResult

setRevision(String) - Method in class bb.common.SGSaleItemVO

setRevision(String) - Method in class bb.common.ShipperItemVO

setRevision(String) - Method in class bb.common.ShippingItemResult

setRevision(String) - Method in class bb.common.SwapOrderItemVO

setRevision(String) - Method in class bb.common.SwapReceiverItemVO

setRevision(String) - Method in class bb.common.SwapShipperItemVO

setRevision(String) - Method in class bb.common.ToolVO

setRevision(String) - Method in class bb.common.ToolWithOnhandsVO

setRevision(String) - Method in class bb.common.TransferOrderItemVO

setRevision(String) - Method in class bb.common.TransferReceiverItemListResult

setRevision(String) - Method in class bb.common.TransferReceiverItemVO

setRevision(String) - Method in class bb.common.TransferShipperItemListResult

setRevision(String) - Method in class bb.common.TransferShipperItemVO

setRevision(String) - Method in class bb.common.WoItemPickListItemResult

setRevision(String) - Method in class bb.common.WoItemPickListResult

setRevision(String) - Method in class bb.common.WorkOrderItemIssueVO

setRevision(String) - Method in class bb.common.WorkOrderItemTimeDetailVO

setRevision(String) - Method in class bb.common.WorkOrderItemVO

setRevision(String) - Method in class bb.common.WorkOrderReceiverVO

setRevision(String) - Method in class bb.common.WorkOrderTimeCardVO

setRevisionDate(Date) - Method in class bb.common.PartExportInfo

setRevisionDate(Date) - Method in class bb.common.PartVO

setRevisionDate(Date) - Method in class bb.common.PartWithOnhandsVO

setRevisionDate(Date) - Method in class bb.common.SGPartCatalogResult

setRevisionDate(Date) - Method in class bb.common.ToolVO

setRevisionDate(Date) - Method in class bb.common.ToolWithOnhandsVO

setRevsion(String) - Method in class bb.common.SGCustomerServiceRequestVO

setRfcNumber(String) - Method in class bb.common.WorkInstructionRequestForChangeVO

setRfqComments(String) - Method in class bb.common.RequestForQuoteVO

setRfqDate(Date) - Method in class bb.common.RequestForQuoteCheckListResult

setRfqDate(Date) - Method in class bb.common.RequestForQuoteItemListResult

setRfqDate(Date) - Method in class bb.common.RequestForQuoteListResult

setRfqDate(Date) - Method in class bb.common.RequestForQuoteVO

setRfqDigits(byte) - Method in class bb.common.CompanyVO

setRfqIds(String) - Method in class bb.common.PurchaseWorkSheetItemVO

setRfqIds(String) - Method in class bb.common.WorkOrderWorkSheetItemVO

setRfqIdWritein(String) - Method in class bb.common.PurchaseWorkSheetItemVO

setRfqIdWritein(String) - Method in class bb.common.WorkOrderWorkSheetItemVO

setRfqItem(RequestForQuoteItemVO) - Method in class bb.common.RfqMessageItemVO

setRfqItemComments(String) - Method in class bb.common.RequestForQuoteItemVO

setRfqItemPk(RequestForQuoteItemPK) - Method in class bb.common.RequestForQuoteItemListResult

setRfqItemPrivateNotes(String) - Method in class bb.common.RequestForQuoteItemVO

setRfqMail(boolean) - Method in class bb.common.CustomerVendorContactVO

setRfqMessageDate(Date) - Method in class bb.common.RfqMessageListResult

setRfqMessageDate(Date) - Method in class bb.common.RfqMessageVO

setRfqMessageNumber(String) - Method in class bb.common.RfqMessageItemPK

setRfqMessageNumber(String) - Method in class bb.common.RfqMessageListResult

setRfqMessageNumber(String) - Method in class bb.common.RfqMessageVO

setRfqNumber(String) - Method in class bb.common.RequestForQuoteCheckListResult

setRfqNumber(String) - Method in class bb.common.RequestForQuoteListResult

setRfqNumber(String) - Method in class bb.common.RfqMessageItemVO

setRfqNumber(String) - Method in class bb.common.RfqMessageListResult

setRfqNumber(String) - Method in class bb.common.RfqMessageVO

setRfqPrefix(String) - Method in class bb.common.CompanyVO

setRfqPrivateNotes(String) - Method in class bb.common.RequestForQuoteVO

setRis(String) - Method in class bb.common.CustomCheckUpEmployeeVO

setRmaComments(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setRmaDate(Date) - Method in class bb.common.ReturnMaterialAuthorizationVO

setRmaDate(Date) - Method in class bb.common.RMAItemListResult

setRmaDate(Date) - Method in class bb.common.RMAListResult

setRmaDebitAccount(String) - Method in class bb.common.PointOfSaleVO

setRmaDetails(ArrayList<RMAReceiverResult>) - Method in class bb.common.BB2PartTotalOndemandDetailResult

setRmaDigits(byte) - Method in class bb.common.CompanyVO

setRmaDocment(Set) - Method in class bb.common.ReturnMaterialAuthorizationVO

setRmaItem(Set) - Method in class bb.common.ReturnMaterialAuthorizationVO

setRmaItemComments(String) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setRmaItemNumber(String) - Method in class bb.common.ReturnMaterialAuthorizationItemManufacturerPK

setRmaItemNumber(String) - Method in class bb.common.ReturnMaterialAuthorizationItemPK

setRmaItemNumber(String) - Method in class bb.common.RMAItemListResult

setRmaItemPrivateNotes(String) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setRmaNumber(String) - Method in class bb.common.CustomerReturnToVendorVO

setRmaNumber(String) - Method in class bb.common.NcrNeedToScrapListResult

setRmaNumber(String) - Method in class bb.common.NonConformanceReportVO

setRmaNumber(String) - Method in class bb.common.RequestForRMAVO

setRmaNumber(String) - Method in class bb.common.ReturnMaterialAuthorizationDocumentVO

setRmaNumber(String) - Method in class bb.common.ReturnMaterialAuthorizationItemManufacturerPK

setRmaNumber(String) - Method in class bb.common.ReturnMaterialAuthorizationItemPK

setRmaNumber(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setRmaNumber(String) - Method in class bb.common.RMAItemListResult

setRmaNumber(String) - Method in class bb.common.RMAListResult

setRmaNumber(String) - Method in class bb.common.RMAReceiverItemListResult

setRmaNumber(String) - Method in class bb.common.RMAReceiverItemVO

setRmaNumber(String) - Method in class bb.common.RMAReceiverListResult

setRmaNumber(String) - Method in class bb.common.RMAReceiverVO

setRmaPrefix(String) - Method in class bb.common.CompanyVO

setRmaPrivateNotes(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setRmaReceiverDigits(byte) - Method in class bb.common.CompanyVO

setRmaReceiverNumber(String) - Method in class bb.common.MakeCreditMemoAgent

setRmaReceiverPrefix(String) - Method in class bb.common.CompanyVO

setRoleId(String) - Method in class bb.common.RoleDescriptionPK

setRoleId(String) - Method in class bb.common.RoleListResult

setRoleId(String) - Method in class bb.common.RolePermissionPK

setRoleId(String) - Method in class bb.common.RoleVO

setRoleId(String) - Method in class bb.common.UserRolePermissionListResult

setRoleId(String) - Method in class bb.common.UserRolePK

setRoleName(String) - Method in class bb.common.RoleDescriptionVO

setRoleName(String) - Method in class bb.common.RoleListResult

setRoleName(String) - Method in class bb.common.UserRolePermissionListResult

setRolePermissions(Set) - Method in class bb.common.RoleVO

setRollUpCost(BigDecimal) - Method in class bb.common.RollUpBomStdCostWorkSheetItemVO

setRollUpCount(Integer) - Method in class bb.common.RollUpBomStdCostWorkSheetVO

setRollupStdCost(BigDecimal) - Method in class bb.common.RollUPPartStandardCostResult

setRootBOM(boolean) - Method in class bb.common.BOMCanAssyAgent

setRoundToIntForSetup(boolean) - Method in class bb.common.BillItemVO

setRowNumber(Integer) - Method in class bb.common.CycleCountPK

setRowNumber(Integer) - Method in class bb.common.PhysicalInventoryPK

setRrmaDate(Date) - Method in class bb.common.RequestForRMAVO

setRrmaDate(Date) - Method in class bb.common.RRMAItemListResult

setRrmaDate(Date) - Method in class bb.common.RRMAListResult

setRrmaItem(Set<RequestForRMAItemVO>) - Method in class bb.common.RequestForRMAVO

setRrmaItemComments(String) - Method in class bb.common.RequestForRMAItemVO

setRrmaItemNumber(String) - Method in class bb.common.RequestForRMAItemPK

setRrmaItemNumber(String) - Method in class bb.common.RRMAItemListResult

setRrmaItemPrivateNotes(String) - Method in class bb.common.RequestForRMAItemVO

setRrmaNumber(String) - Method in class bb.common.RequestForRMAItemPK

setRrmaNumber(String) - Method in class bb.common.RequestForRMAVO

setRrmaNumber(String) - Method in class bb.common.RRMAItemListResult

setRrmaNumber(String) - Method in class bb.common.RRMAListResult

setRTotalBudget(BigDecimal) - Method in class bb.common.CashFlowMonthTotalResult

setRtran(String) - Method in class bb.common.AccountsReceivableInfoVO

setRtran(String) - Method in class bb.common.AccountsReceivableVO

setRTran(String) - Method in class bb.common.OnloanShipperVO

setRtran(String) - Method in class bb.common.ProformaInvoiceVO

setRtran(String) - Method in class bb.common.RtvShipperInfoVO

setRtran(String) - Method in class bb.common.RtvShipperVO

setRTran(String) - Method in class bb.common.ShipperInfoVO

setRTran(String) - Method in class bb.common.ShipperVO

setRtvComments(String) - Method in class bb.common.ReturnToVendorByDateListResult

setRtvComments(String) - Method in class bb.common.ReturnToVendorVO

setRtvDate(Date) - Method in class bb.common.ReturnToVendorByDateListResult

setRtvDate(Date) - Method in class bb.common.ReturnToVendorCheckListResult

setRtvDate(Date) - Method in class bb.common.ReturnToVendorItemListResult

setRtvDate(Date) - Method in class bb.common.ReturnToVendorListResult

setRtvDigits(byte) - Method in class bb.common.CompanyVO

setRtvistatus(String) - Method in class bb.common.ReturnToVendorByDateListResult

setRtvItemPk(ReturnToVendorItemPK) - Method in class bb.common.ReturnToVendorByDateListResult

setRtvItemPk(ReturnToVendorItemPK) - Method in class bb.common.ReturnToVendorItemListResult

setRtvItems(Set) - Method in class bb.common.ReturnToVendorVO

setRtvNumber(String) - Method in class bb.common.NcrNeedToScrapListResult

setRtvNumber(String) - Method in class bb.common.NcrReportListResult

setRtvNumber(String) - Method in class bb.common.NonConformanceReportVO

setRtvNumber(String) - Method in class bb.common.ReturnToVendorCheckListResult

setRtvNumber(String) - Method in class bb.common.ReturnToVendorListResult

setRtvNumber(String) - Method in class bb.common.RtvShipperInfoVO

setRtvNumber(String) - Method in class bb.common.RtvShipperItemListResult

setRtvNumber(String) - Method in class bb.common.RtvShipperItemVO

setRtvNumber(String) - Method in class bb.common.RtvShipperListResult

setRtvNumber(String) - Method in class bb.common.RtvShipperVO

setRtvPrefix(String) - Method in class bb.common.CompanyVO

setRtvPrivateNotes(String) - Method in class bb.common.ReturnToVendorVO

setRtvShipperDigits(byte) - Method in class bb.common.CompanyVO

setRtvShipperItemNumber(String) - Method in class bb.common.RtvShipperItemListResult

setRtvShipperItemNumber(String) - Method in class bb.common.RtvShipperItemPK

setRtvShipperItems(Set) - Method in class bb.common.RtvShipperVO

setRtvShipperNumber(String) - Method in class bb.common.MakeDebitMemoAgent

setRtvShipperNumber(String) - Method in class bb.common.RtvShipperInfoVO

setRtvShipperNumber(String) - Method in class bb.common.RtvShipperItemListResult

setRtvShipperNumber(String) - Method in class bb.common.RtvShipperItemPK

setRtvShipperNumber(String) - Method in class bb.common.RtvShipperListResult

setRtvShipperNumber(String) - Method in class bb.common.RtvShipperVO

setRtvShipperPrefix(String) - Method in class bb.common.CompanyVO

setRtvShipperVendorPicked(RtvShipperVO) - Method in interface bb.common.box.WarehouseBox

setRunHoursLimit(Integer) - Method in class bb.common.EquipmentListResult

setRunHoursLimit(Integer) - Method in class bb.common.EquipmentVO

setRunning(boolean) - Method in class bb.common.WCLoadDetailResult

setRunningAccountNumber(String) - Method in class bb.common.ZipcodeTotalsResult

setRunningAccountOrderItemNumber(String) - Method in class bb.common.RunningAccountOrderItemPK

setRunningAccountOrderItems(Set) - Method in class bb.common.RunningAccountOrderVO

setRunningAccountOrderNumber(String) - Method in class bb.common.RunningAccountOrderItemPK

setRunningAccountOrderNumber(String) - Method in class bb.common.RunningAccountOrderVO

setRunningAccountOrderNumber(String) - Method in class bb.common.RunTaxPaymentResult

setRv(String) - Method in class bb.common.LogMiscDocumentVO

setSaleable(String) - Method in class bb.common.BillSalesCostResult

setSaleable(String) - Method in class bb.common.PartBasicInfo

setSaleable(String) - Method in class bb.common.PartCatalogAuditResult

setSaleable(String) - Method in class bb.common.PartVO

setSaleable(String) - Method in class bb.common.PartWithOnhandsVO

setSaleable(String) - Method in class bb.common.SalesBomItemResult

setSaleable(String) - Method in class bb.common.SalesBomResult

setSaleable(String) - Method in class bb.common.ToolVO

setSaleable(String) - Method in class bb.common.ToolWithOnhandsVO

setSaleableForNewPart(boolean) - Method in class bb.common.CompanyVO

setSalesable(String) - Method in class bb.common.BillItemSalesCostResult

setSalesable(String) - Method in class bb.common.BillItemSalesXResult

setSalesable(String) - Method in class bb.common.BillSalesXResult

setSalesCodeId(String) - Method in class bb.common.AccountsReceivableInfoVO

setSalesCodeId(String) - Method in class bb.common.AccountsReceivableVO

setSalesCodeId(String) - Method in class bb.common.ArCommissionListResult

setSalesCodeId(String) - Method in class bb.common.CustomerReturnToVendorVO

setSalesCodeId(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setSalesCodeId(String) - Method in class bb.common.RequestForRMAVO

setSalesCodeId(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setSalesCodeId(String) - Method in class bb.common.SalesCodeVO

setSalesCodeId(String) - Method in class bb.common.SalesOrderItemListResult

setSalesCodeId(String) - Method in class bb.common.SalesOrderVO

setSalesCodeIds(Set) - Method in class bb.common.SalesCodeVO

setSalesCodeName(String) - Method in class bb.common.ArCommissionListResult

setSalesCodeName(String) - Method in class bb.common.SalesCodeVO

setSalesCost(BigDecimal) - Method in class bb.common.CustomerReturnToVendorItemVO

setSalesCost(BigDecimal) - Method in class bb.common.RequestForRMAItemVO

setSalesCost(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setSalesCost(BigDecimal) - Method in class bb.common.RMAReceiverItemListResult

setSalesCost(BigDecimal) - Method in class bb.common.RMAReceiverItemVO

setSalesCountWithPartOnHold(Integer) - Method in class bb.common.SalesInfoCenterResult

setSalesDate(Date) - Method in class bb.common.RunningAccountOrderItemResult

setSalesDate(Date) - Method in class bb.common.RunningAccountOrderVO

setSalesDrawing(String) - Method in class bb.common.PartBasicInfo

setSalesDrawing(String) - Method in class bb.common.PartVO

setSalesDrawing(String) - Method in class bb.common.PartWithOnhandsVO

setSalesGroutQuoteNumber(String) - Method in class bb.common.QuoteVO

setSalesItemCount(int) - Method in class bb.common.SalesOrderOnTimeItemResult

setSalesItemDescription(String) - Method in class bb.common.SalesOrderItemInfoVO

setSalesItemDescription(String) - Method in class bb.common.SalesOrderItemVO

setSalesItemDescription(String) - Method in class bb.common.SalesOrderShipDateListResult

setSalesItemPks(ArrayList<SalesOrderItemPK>) - Method in class bb.common.MakeBillAndHoldInvoiceAgent

setSalesItemPks(ArrayList<SalesOrderItemPK>) - Method in class bb.common.MakeInvoiceAgent

setSalesman(String) - Method in class bb.common.AccountsReceivableInfoVO

setSalesman(String) - Method in class bb.common.AccountsReceivableVO

setSalesman(String) - Method in class bb.common.CRTVItemListResult

setSalesman(String) - Method in class bb.common.CRTVListResult

setSalesman(String) - Method in class bb.common.CustomerReturnToVendorVO

setSalesman(String) - Method in class bb.common.CustomerVendorAddressVO

setSalesman(String) - Method in class bb.common.DisassembleWorkOrderVO

setSalesman(String) - Method in class bb.common.GeneralLedgerListResult

setSalesman(String) - Method in class bb.common.GeneralLedgerVO

setSalesman(String) - Method in class bb.common.LnShipperListResult

setSalesman(String) - Method in class bb.common.OnloanShipperVO

setSalesman(String) - Method in class bb.common.OnLoanVO

setSalesman(String) - Method in class bb.common.ProformaInvoiceVO

setSalesman(String) - Method in class bb.common.QuoteListResult

setSalesman(String) - Method in class bb.common.QuoteVO

setSalesman(String) - Method in class bb.common.RequestForRMAVO

setSalesman(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setSalesman(String) - Method in class bb.common.RMAItemListResult

setSalesman(String) - Method in class bb.common.RMAListResult

setSalesman(String) - Method in class bb.common.RRMAItemListResult

setSalesman(String) - Method in class bb.common.RRMAListResult

setSalesman(String) - Method in class bb.common.RtvShipperInfoVO

setSalesman(String) - Method in class bb.common.RtvShipperVO

setSalesman(String) - Method in class bb.common.RunningAccountOrderItemResult

setSalesman(String) - Method in class bb.common.RunningAccountOrderVO

setSalesman(String) - Method in class bb.common.RunTaxPaymentResult

setSalesMan(String) - Method in class bb.common.SalesOrderCheckListResult

setSalesman(String) - Method in class bb.common.SalesOrderItemListResult

setSalesman(String) - Method in class bb.common.SalesOrderListResult

setSalesman(String) - Method in class bb.common.SalesOrderVO

setSalesman(String) - Method in class bb.common.ShipperInfoVO

setSalesman(String) - Method in class bb.common.ShipperListResult

setSalesman(String) - Method in class bb.common.ShipperVO

setSalesman(String) - Method in class bb.common.WorkOrderVO

setSalesmanId(short) - Method in class bb.common.OnLoanVO

setSalesmanId(short) - Method in class bb.common.QuoteVO

setSalesmanId(int) - Method in class bb.common.SalesmanVO

setSalesManId(short) - Method in class bb.common.SalesOrderCheckListResult

setSalesmanId(short) - Method in class bb.common.SalesOrderVO

setSalesMarginPct(BigDecimal) - Method in class bb.common.SalesOrderOnTimeItemResult

setSalesMarketing(List) - Method in class bb.common.ProfitLossStatementResult

setSalesOrder(String) - Method in class bb.common.CustomerPrepayStatementListResult

setSalesOrder(String) - Method in class bb.common.CustomerStatementListResult

setSalesOrder(String) - Method in class bb.common.RunningAccountOrderItemResult

setSalesOrder(String) - Method in class bb.common.RunningAccountOrderVO

setSalesOrder(String) - Method in class bb.common.ShipperItemVO

setSalesOrderBoilerplate(String) - Method in class bb.common.SalesOrderVO

setSalesOrderComments(String) - Method in class bb.common.SalesOrderVO

setSalesOrderDate(Date) - Method in class bb.common.SalesOrderVO

setSalesOrderDocuments(Set) - Method in class bb.common.SalesOrderVO

setSalesOrderItem(String) - Method in class bb.common.ProformaInvoiceItemListResult

setSalesOrderItem(String) - Method in class bb.common.ProformaInvoiceItemPK

setSalesOrderItemComments(String) - Method in class bb.common.SalesOrderItemInfoVO

setSalesOrderItemComments(String) - Method in class bb.common.SalesOrderItemVO

setSalesOrderItemManufacturer(Set) - Method in class bb.common.SalesOrderItemVO

setSalesOrderItemNumber(String) - Method in class bb.common.AccountsReceivableItemManufacturerPK

setSalesOrderItemNumber(String) - Method in class bb.common.AccountsReceivableItemVO

setSalesOrderItemNumber(String) - Method in class bb.common.CSRAgent

setSalesOrderItemNumber(String) - Method in class bb.common.PackingBoxItemPK

setSalesOrderItemNumber(String) - Method in class bb.common.PackingBoxSalesOrderItemResult

setSalesOrderItemNumber(String) - Method in class bb.common.ProformaInvoiceItemManufacturerPK

setSalesOrderItemNumber(String) - Method in class bb.common.SalesOrderItemManufacturerPK

setSalesOrderItemNumber(String) - Method in class bb.common.SalesOrderItemPK

setSalesOrderItemNumber(String) - Method in class bb.common.SGCustomerServiceRequestVO

setSalesOrderItemNumber(String) - Method in class bb.common.SGSaleItemAgent

setSalesOrderItemNumber(String) - Method in class bb.common.SGSaleItemVO

setSalesOrderItemNumber(String) - Method in class bb.common.ShipListItemPK

setSalesOrderItemNumber(String) - Method in class bb.common.ShipListItemVOResult

setSalesOrderItemNumber(String) - Method in class bb.common.ShipperItemListResult

setSalesOrderItemNumber(String) - Method in class bb.common.ShipperItemManufacturerPK

setSalesOrderItemPk(SalesOrderItemPK) - Method in class bb.common.SalesOrderOnDemandResult

setSalesOrderItemPrivateNotes(String) - Method in class bb.common.SalesOrderItemInfoVO

setSalesOrderItemPrivateNotes(String) - Method in class bb.common.SalesOrderItemVO

setSalesOrderItemReferenceDocOne(SalesOrderItemPK, String) - Method in interface bb.common.box.SalesBox

setSalesOrderItemReferenceDocTwo(SalesOrderItemPK, String) - Method in interface bb.common.box.SalesBox

setSalesOrderItems(Set<SalesOrderItemVO>) - Method in class bb.common.SalesOrderVO

setSalesOrderNumber(String) - Method in class bb.common.AccountReceivableInfoWithPrepayResult

setSalesOrderNumber(String) - Method in class bb.common.AccountsReceivableInfoVO

setSalesOrderNumber(String) - Method in class bb.common.AccountsReceivableItemVO

setSalesOrderNumber(String) - Method in class bb.common.AccountsReceivableVO

setSalesOrderNumber(String) - Method in class bb.common.ArCommissionListResult

setSalesOrderNumber(String) - Method in class bb.common.ARPrepayInfoResult

setSalesOrderNumber(String) - Method in class bb.common.ArPrepayVO

setSalesOrderNumber(String) - Method in class bb.common.CRTVItemListResult

setSalesOrderNumber(String) - Method in class bb.common.CRTVListResult

setSalesOrderNumber(String) - Method in class bb.common.CSRAgent

setSalesOrderNumber(String) - Method in class bb.common.CustomerReturnToVendorVO

setSalesOrderNumber(String) - Method in class bb.common.DesignControlInfoVO

setSalesOrderNumber(String) - Method in class bb.common.DesignControlVO

setSalesOrderNumber(String) - Method in class bb.common.GeneralLedgerListResult

setSalesOrderNumber(String) - Method in class bb.common.GeneralLedgerResult

setSalesOrderNumber(String) - Method in class bb.common.GeneralLedgerVO

setSalesOrderNumber(String) - Method in class bb.common.InvoiceItemListResult

setSalesOrderNumber(String) - Method in class bb.common.MrpReportAgent

setSalesOrderNumber(String) - Method in class bb.common.NcrNeedToScrapListResult

setSalesOrderNumber(String) - Method in class bb.common.NonConformanceReportVO

setSalesOrderNumber(String) - Method in class bb.common.PackingBoxItemPK

setSalesOrderNumber(String) - Method in class bb.common.PackingBoxSalesOrderItemResult

setSalesOrderNumber(String) - Method in class bb.common.PartCertificateListResult

setSalesOrderNumber(String) - Method in class bb.common.PartCertificateVO

setSalesOrderNumber(String) - Method in class bb.common.PfReceiverItemVO

setSalesOrderNumber(String) - Method in class bb.common.ProformaInvoiceItemListResult

setSalesOrderNumber(String) - Method in class bb.common.ProformaInvoiceItemManufacturerPK

setSalesOrderNumber(String) - Method in class bb.common.ProformaInvoiceItemPK

setSalesOrderNumber(String) - Method in class bb.common.PrPackingBoxItemVO

setSalesOrderNumber(String) - Method in class bb.common.PurchaseOrderVO

setSalesOrderNumber(String) - Method in class bb.common.RequestForQuoteVO

setSalesOrderNumber(String) - Method in class bb.common.RequestForRMAVO

setSalesOrderNumber(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setSalesOrderNumber(String) - Method in class bb.common.RMAItemListResult

setSalesOrderNumber(String) - Method in class bb.common.RMAListResult

setSalesOrderNumber(String) - Method in class bb.common.RRMAItemListResult

setSalesOrderNumber(String) - Method in class bb.common.RRMAListResult

setSalesOrderNumber(String) - Method in class bb.common.SalesOrderItemManufacturerPK

setSalesOrderNumber(String) - Method in class bb.common.SalesOrderItemPK

setSalesOrderNumber(String) - Method in class bb.common.SalesOrderVO

setSalesOrderNumber(String) - Method in class bb.common.SalesTaxListResult

setSalesOrderNumber(String) - Method in class bb.common.SGCustomerServiceRequestVO

setSalesOrderNumber(String) - Method in class bb.common.SGSaleItemAgent

setSalesOrderNumber(String) - Method in class bb.common.SGSaleItemVO

setSalesOrderNumber(String) - Method in class bb.common.ShipListItemPK

setSalesOrderNumber(String) - Method in class bb.common.ShipListItemVOResult

setSalesOrderNumber(String) - Method in class bb.common.ShipperInfoVO

setSalesOrderNumber(String) - Method in class bb.common.ShipperItemListResult

setSalesOrderNumber(String) - Method in class bb.common.ShipperListResult

setSalesOrderNumber(String) - Method in class bb.common.ShipperVO

setSalesOrderNumber(String) - Method in class bb.common.SoPickListResult

setSalesOrderNumber(String) - Method in class bb.common.SOShipperItemListResult

setSalesOrderOnDemandResult(ArrayList) - Method in class bb.common.BB2PartMrpResult

setSalesOrderOrphanedResult(ArrayList) - Method in class bb.common.BB2PartMrpResult

setSalesOrderPrepay(String) - Method in class bb.common.AccountingSettingsVO

setSalesOrderPrivateNotes(String) - Method in class bb.common.SalesOrderVO

setSalesOrderSet(Set) - Method in class bb.common.ShipListAgent

setSalesOrderUnit(String) - Method in class bb.common.PartInventoryVO

setSalesOrderUnit(boolean) - Method in class bb.common.PartUnitVO

setSalesOrderUnit(String) - Method in class bb.common.ToolInventoryVO

setSalesPercent(Double) - Method in class bb.common.ProfitLossStatementItemResult

setSalesPrice(BigDecimal) - Method in class bb.common.CustomerReturnToVendorItemVO

setSalesPrice(BigDecimal) - Method in class bb.common.RequestForRMAItemVO

setSalesPrice(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setSalesPrice(BigDecimal) - Method in class bb.common.RunningAccountOrderItemVO

setSalesPrice(BigDecimal) - Method in class bb.common.SalesOrderItemVO

setSalesQty(BigDecimal) - Method in class bb.common.CustomerReturnToVendorItemVO

setSalesQty(BigDecimal) - Method in class bb.common.RequestForRMAItemVO

setSalesQty(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setSalesQty(BigDecimal) - Method in class bb.common.SalesOrderItemVO

setSalesRevenue(List) - Method in class bb.common.ProfitLossStatementResult

setSalesStdCost(BigDecimal) - Method in class bb.common.CustomerReturnToVendorItemVO

setSalesStdCost(BigDecimal) - Method in class bb.common.RequestForRMAItemVO

setSalesStdCost(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setSalesStdCost(BigDecimal) - Method in class bb.common.RMAReceiverItemVO

setSalesTax(BigDecimal) - Method in class bb.common.GeneralLedgerListResult

setSalesTax(BigDecimal) - Method in class bb.common.GeneralLedgerResult

setSalesTax(BigDecimal) - Method in class bb.common.GeneralLedgerVO

setSalesTaxNumber(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setSalesTaxNumber(String) - Method in class bb.common.CustomerVendorAddressVO

setSalesTaxRate(BigDecimal) - Method in class bb.common.TaxAccountVO

setSalesTotal(BigDecimal) - Method in class bb.common.SalesOrderOnTimeItemResult

setSalesUnit(String) - Method in class bb.common.CustomerReturnToVendorItemVO

setSalesUnit(String) - Method in class bb.common.RequestForRMAItemVO

setSalesUnit(String) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setSalesUnit(String) - Method in class bb.common.SalesOrderItemVO

setSaveToFtp(boolean) - Method in class bb.common.DocumentServerVO

setSaveToFtp(boolean) - Method in class bb.common.DwfUploadSettingsVO

setSaveToFtp(boolean) - Method in class bb.common.DwgUploadSettingsVO

setSaveToFtp(boolean) - Method in class bb.common.MiscDocumentSettingVO

setScannerPrefix(String) - Method in class bb.common.PointOfSaleVO

setScannerSuffix(String) - Method in class bb.common.PointOfSaleVO

setScrapQty(BigDecimal) - Method in class bb.common.BillItemWithPartInfoResult

setScrapQty(BigDecimal) - Method in class bb.common.IssuingItemResult

setScrapQty(BigDecimal) - Method in class bb.common.ScrapReportVO

setScrapQty(BigDecimal) - Method in class bb.common.WorkOrderItemIssueVO

setScrapQty(BigDecimal) - Method in class bb.common.WorkOrderItemSetupItemAgent

setScrapRate(BigDecimal) - Method in class bb.common.BillItemReplacementVO

setScrapRate(BigDecimal) - Method in class bb.common.BillItemVO

setScrapRate(BigDecimal) - Method in class bb.common.BillItemWithPartInfoResult

setScrapRate(BigDecimal) - Method in class bb.common.WorkOrderItemSetupItemAgent

setScreenSize(String) - Method in class bb.common.BizboxBugInfoVO

setScreenSize(String) - Method in class bb.common.BizboxBugVO

setSealWorker(String) - Method in class bb.common.InspectionReportInfoVO

setSealWorker(String) - Method in class bb.common.InspectionReportVO

setSearchBuyer(String) - Method in class bb.common.TempReceiverWithoutAPInfo

setSearchCurrency(String) - Method in class bb.common.TempReceiverWithoutAPInfo

setSearchDateFrom(Date) - Method in class bb.common.TempReceiverWithoutAPInfo

setSearchDateTo(Date) - Method in class bb.common.TempReceiverWithoutAPInfo

setSearchId(String) - Method in class bb.common.TempReceiverWithoutAPInfo

setSecurityLevel(String) - Method in class bb.common.EmployeeCardVO

setSecurityLevel(String) - Method in class bb.common.PartBasicInfo

setSecurityLevel(String) - Method in class bb.common.PartVO

setSecurityLevel(String) - Method in class bb.common.PartWithOnhandsVO

setSecurityLevel(String) - Method in class bb.common.SalesmanVO

setSellerId(String) - Method in class bb.common.PO2SOExchange

setSellerName(String) - Method in class bb.common.PO2SOExchange

setSendDate(Date) - Method in class bb.common.MessageVO

setSendFrom(String) - Method in class bb.common.BB2BugNotice

setSendFrom(String) - Method in class bb.common.BB2Notice

setSendFrom(String) - Method in class bb.common.MessageVO

setSendFrom(String) - Method in class bb.common.SmtpServerVO

setSendNotice(boolean) - Method in class bb.common.TaskVO

setSendTo(String) - Method in class bb.common.BB2BugNotice

setSendUsername(String) - Method in class bb.common.MessageVO

setSentTo(String) - Method in class bb.common.AccountsPayableItemVO

setSentTo(String[]) - Method in class bb.common.BB2Notice

setSentTo(String) - Method in class bb.common.OnloanReceiverItemVO

setSentTo(String) - Method in class bb.common.ReceiverItemVO

setSentTo(String) - Method in class bb.common.RMAReceiverItemVO

setSeparateCostBetweenWarehouse(boolean) - Method in class bb.common.CompanyVO

setSeparateCV(boolean) - Method in class bb.common.CompanyVO

setSeq(String) - Method in class bb.common.CarrierPK

setSeqActualBeginDate(Date) - Method in class bb.common.WCLoadDetailResult

setSeqActualFinishedDate(Date) - Method in class bb.common.WCLoadDetailResult

setSeqEndDate(Date) - Method in class bb.common.WCLoadDetailResult

setSeqNumber(String) - Method in class bb.common.JobProcessSheetItemResult

setSeqNumber(String) - Method in class bb.common.WCLoadDetailResult

setSeqNumber(String) - Method in class bb.common.WorkCenterRunTimeListResult

setSeqNumber(String) - Method in class bb.common.WorkInstructionSummaryItemResult

setSeqNumber(String) - Method in class bb.common.WorkOrderItemSeqWCLoadResult

setSeqRev(String) - Method in class bb.common.WorkInstructionSummaryItemResult

setSeqs(Set) - Method in class bb.common.JobProcessSheetResult

setSeqStartDate(Date) - Method in class bb.common.WCLoadDetailResult

setSequanceRev(String) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setSequence(String) - Method in class bb.common.DesignControlDocumentVO

setSequence(String) - Method in class bb.common.MiscDocAgent

setSequence(int) - Method in class bb.common.WorkOrderItemIssuedTotalResult

setSequenceNumber(String) - Method in class bb.common.WorkInstructionPictureVO

setSequenceNumber(String) - Method in class bb.common.WorkInstructionSequencePK

setSequenceRev(String) - Method in class bb.common.WorkInstructionSequenceVO

setSequences(Set) - Method in class bb.common.WorkInstructionVO

setSequences(Set<WorkOrderWorkInstructionSequenceVO>) - Method in class bb.common.WorkOrderWorkInstructionListResult

setSequences(Set) - Method in class bb.common.WorkOrderWorkInstructionVO

setSequenceStatus(String) - Method in class bb.common.WorkInstructionSequenceListResult

setSeqWC(String) - Method in class bb.common.WCLoadDetailResult

setSer(int) - Method in class bb.common.InventoryPartInOutDetailListResult

setSerial(String) - Method in class bb.common.AccountsPayableItemVO

setSerial(String) - Method in class bb.common.AccountsReceivableItemVO

setSerial(String) - Method in class bb.common.CSRAgent

setSerial(String) - Method in class bb.common.DisassembleWorkOrderIssueVO

setSerial(String) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

setSerial(String) - Method in class bb.common.EquipmentVO

setSerial(String) - Method in class bb.common.IssueItemAgent

setSerial(String) - Method in class bb.common.IssuingItemResult

setSerial(String) - Method in class bb.common.LogInventoryVO

setSerial(String) - Method in class bb.common.OnloanReceiverItemVO

setSerial(String) - Method in class bb.common.OperatingInstructionsVO

setSerial(String) - Method in class bb.common.PartIssuedVO

setSerial(String) - Method in class bb.common.PartReceivedVO

setSerial(String) - Method in class bb.common.PfReceiverItemVO

setSerial(String) - Method in class bb.common.ProformaInvoiceItemVO

setSerial(String) - Method in class bb.common.ReceiverItemAgent

setSerial(String) - Method in class bb.common.ReceiverItemVO

setSerial(String, String) - Method in class bb.common.ReceiverShipAgent

setSerial(String) - Method in class bb.common.RMAReceiverItemVO

setSerial(String) - Method in class bb.common.RtvShipperItemVO

setSerial(String) - Method in class bb.common.SGCustomerServiceRequestVO

setSerial(String) - Method in class bb.common.ShipperItemAgent

setSerial(String) - Method in class bb.common.WorkOrderItemIssueVO

setSerial(String) - Method in class bb.common.WorkOrderReceiverVO

setSerialNo(String) - Method in class bb.common.PartInQAAgent

setSerialNo(String) - Method in class bb.common.PartInQAVO

setSerialNubmer(String) - Method in class bb.common.SerialNumberResult

setSerialNumber(String) - Method in class bb.common.AssetVO

setSerialNumber(String) - Method in class bb.common.CustomAssetVO

setSerialNumber(String) - Method in class bb.common.CustomerServiceIncidentVO

setSerialNumber(int) - Method in class bb.common.InventoryNotUsedInMonthsforAppResult

setSerialNumber(String) - Method in class bb.common.LnShipperItemListResult

setSerialNumber(String) - Method in class bb.common.OnloanShipperItemVO

setSerialNumber(String) - Method in class bb.common.PartOnhandCostVO

setSerialNumber(String) - Method in class bb.common.SerialNumberItemPK

setSerialNumber(String) - Method in class bb.common.SerialNumberItemResult

setSerialNumber(String) - Method in class bb.common.SerialNumberPK

setSerialNumber(String) - Method in class bb.common.SGSaleItemAgent

setSerialNumber(String) - Method in class bb.common.SGSaleItemVO

setSerialNumber(String) - Method in class bb.common.ShipperItemListResult

setSerialNumber(String) - Method in class bb.common.ShipperItemVO

setSerialNumber(String) - Method in class bb.common.ToolCalibrationVO

setSerialNumber(String) - Method in class bb.common.WorkOrderItemTimeDetailVO

setSerialNumberItemNumber(String) - Method in class bb.common.SerialNumberItemPK

setSerialNumberItems(Set) - Method in class bb.common.SerialNumberVO

setSerialNumberType(String) - Method in class bb.common.OperatingInstructionsTypeVO

setSerials(Map<String, String>) - Method in class bb.common.ReceiverShipAgent

setSeriveType(String) - Method in class bb.common.CSRAgent

setServer(String) - Method in class bb.common.BizBoxServer

setServer(String) - Method in class bb.common.OperationLogVO

setServer(String) - Method in class bb.common.SubcompanyLoginAgent

setServerAccountNumber(String) - Method in class bb.common.AccountsChartMappingPK

setServerIp(String) - Method in class bb.common.DocumentServerVO

setServerIp(String) - Method in class bb.common.DwfUploadSettingsVO

setServerIp(String) - Method in class bb.common.DwgUploadSettingsVO

setServerIp(String) - Method in class bb.common.MiscDocumentSettingVO

setServerLocation(String) - Method in class bb.common.SubcompanyVO

setServerPort(String) - Method in class bb.common.DocumentServerVO

setServerPort(String) - Method in class bb.common.DwfUploadSettingsVO

setServerPort(String) - Method in class bb.common.DwgUploadSettingsVO

setServerPort(String) - Method in class bb.common.MiscDocumentSettingVO

setServiceCharge(BigDecimal) - Method in class bb.common.CustomerStatementResult

setServiceType(String) - Method in class bb.common.SGCustomerServiceRequestVO

setSessionId(String) - Method in class bb.common.SGLogLoginVO

setSessionId(String) - Method in class bb.common.SGQuoteLoginVO

setSet(Set<WCLoadByDateResult>) - Method in class bb.common.WCLoadOnDateResult

setSetId(String) - Method in class bb.common.DisassembleWorkOrderItemListResult

setSetId(String) - Method in class bb.common.DisassembleWorkOrderItemVO

setSetId(String) - Method in class bb.common.JobProcessSheetListResult

setSetId(String) - Method in class bb.common.JobProcessSheetResult

setSetId(String) - Method in class bb.common.MiscDocAgent

setSetId(String) - Method in class bb.common.WorkInstructionDocumentVO

setSetId(String) - Method in class bb.common.WorkInstructionListResult

setSetId(String) - Method in class bb.common.WorkInstructionPictureVO

setSetId(String) - Method in class bb.common.WorkInstructionPK

setSetId(String) - Method in class bb.common.WorkInstructionRequestForChangeVO

setSetId(String) - Method in class bb.common.WorkInstructionSequenceListResult

setSetId(String) - Method in class bb.common.WorkInstructionSequencePK

setSetId(String) - Method in class bb.common.WorkInstructionSummaryResult

setSetId(String) - Method in class bb.common.WorkOrderItemListResult

setSetId(String) - Method in class bb.common.WorkOrderItemVO

setSetId(String) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setSetId(String) - Method in class bb.common.WorkOrderWorkInstructionVO

setSetup(BigDecimal) - Method in class bb.common.WCLoadDetailResult

setSetupHrs(BigDecimal) - Method in class bb.common.WorkCenterLoadListResult

setSetupInventoryForNewPart(boolean) - Method in class bb.common.CompanyVO

setSetupQty(BigDecimal) - Method in class bb.common.MasterWorkOrderTreeItemResult

setSetupQty(BigDecimal) - Method in class bb.common.WorkOrderOverIssueListResult

setSeverity(String) - Method in class bb.common.BizboxBugInfoVO

setSeverity(String) - Method in class bb.common.BizboxBugVO

setSg(String) - Method in class bb.common.CompanyVO

setSgSo(String) - Method in class bb.common.OnLoanVO

setShareholders(Set) - Method in class bb.common.AccountingBalanceSheetResult

setShBplate(String) - Method in class bb.common.RtvShipperInfoVO

setShBplate(String) - Method in class bb.common.RtvShipperVO

setShip(BigDecimal) - Method in class bb.common.CustomerReturnToVendorItemVO

setShip(BigDecimal) - Method in class bb.common.RequestForRMAItemVO

setShip(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setShip(BigDecimal) - Method in class bb.common.ReturnToVendorByDateListResult

setShip(BigDecimal) - Method in class bb.common.ReturnToVendorItemVO

setShipAccount(String) - Method in class bb.common.RequestForQuoteVO

setShipAccount(String) - Method in class bb.common.ReturnToVendorVO

setShipAccout(String) - Method in class bb.common.SalesOrderVO

setShipAccout(String) - Method in class bb.common.TransferOrderListResult

setShipAccout(String) - Method in class bb.common.TransferOrderVO

setShipAccout(String) - Method in class bb.common.TransferShipperListResult

setShipAccout(String) - Method in class bb.common.TransferShipperVO

setShipAcct(String) - Method in class bb.common.OnLoanVO

setShipDate(Date) - Method in class bb.common.AddProformaReceiverItemAgent

setShipDate(Date) - Method in class bb.common.BB2PartInSTOItemResult

setShipDate(Date) - Method in class bb.common.BB2PartOnLoanItemResult

setShipDate(Date) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setShipDate(Date) - Method in class bb.common.PfReceiverVO

setShipDate(Date) - Method in class bb.common.PO2POAgent

setShipDate(Date) - Method in class bb.common.PO2SOExchangeItem

setShipDate(Date) - Method in class bb.common.ShippingItemResult

setShipDate(Date) - Method in class bb.common.SO2SOAgent

setShipDate(Date) - Method in class bb.common.WorkOrderWorkInstructionListResult

setShipFromAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.ProformaInvoiceVO

setShipFromId(String) - Method in class bb.common.ProformaInvoiceVO

setShipId(String) - Method in class bb.common.DisassembleWorkOrderReceivingResult

setShipId(String) - Method in class bb.common.IssuingResult

setShipInProcessQty(BigDecimal) - Method in class bb.common.BB2PartInventoryResult

setShipInProcessQty(BigDecimal) - Method in class bb.common.HistoricalInventoryVO

setShipInProcessQty(BigDecimal) - Method in class bb.common.PartInventoryVO

setShipInProcessQty(BigDecimal) - Method in class bb.common.PartOnHandWithPartBasicInfoResult

setShipInProcessQty(BigDecimal) - Method in class bb.common.PhysicalInventoryVO

setShipInProcessQty(BigDecimal) - Method in class bb.common.ToolInventoryVO

setShipInTransactionQty(BigDecimal) - Method in class bb.common.BB2PartInventoryResult

setShipInTransactionQty(BigDecimal) - Method in class bb.common.HistoricalInventoryVO

setShipInTransactionQty(BigDecimal) - Method in class bb.common.PartInventoryVO

setShipInTransactionQty(BigDecimal) - Method in class bb.common.PartOnHandWithPartBasicInfoResult

setShipInTransactionQty(BigDecimal) - Method in class bb.common.ToolInventoryVO

setShipList(String) - Method in class bb.common.ShipListInfoVO

setShipList(String) - Method in class bb.common.ShipListVO

setShipListItems(Set) - Method in class bb.common.ShipListVO

setShipListNumber(String) - Method in class bb.common.ShipListItemPK

setShipListOwner(ShipListOwnerVO) - Method in class bb.common.ShipListOwnerAttributeVO

setShipListOwnerAttributes(Set) - Method in class bb.common.ShipListOwnerVO

setShipped(Date) - Method in class bb.common.AccountsReceivableInfoVO

setShipped(Date) - Method in class bb.common.AccountsReceivableVO

setShipped(Date) - Method in class bb.common.ProformaInvoiceVO

setShipped(BigDecimal) - Method in class bb.common.ReturnToVendorItemListResult

setShippedBy(String) - Method in class bb.common.AccountsReceivableInfoVO

setShippedBy(String) - Method in class bb.common.AccountsReceivableVO

setShippedBy(String) - Method in class bb.common.OnloanShipperVO

setShippedBy(String) - Method in class bb.common.ProformaInvoiceVO

setShippedBy(String) - Method in class bb.common.RtvShipperInfoVO

setShippedBy(String) - Method in class bb.common.RtvShipperListResult

setShippedBy(String) - Method in class bb.common.RtvShipperVO

setShippedBy(String) - Method in class bb.common.ShipperInfoVO

setShippedBy(String) - Method in class bb.common.ShipperVO

setShippedBy(String) - Method in class bb.common.StockTransactionSOShipperResult

setShippedBy(String) - Method in class bb.common.SwapShipperListResult

setShippedBy(String) - Method in class bb.common.SwapShipperVO

setShippedBy(String) - Method in class bb.common.TransferShipperListResult

setShippedBy(String) - Method in class bb.common.TransferShipperVO

setShippedDate(Date) - Method in class bb.common.OnloanShipperVO

setShippedDate(Date) - Method in class bb.common.RtvShipperInfoVO

setShippedDate(Date) - Method in class bb.common.RtvShipperListResult

setShippedDate(Date) - Method in class bb.common.RtvShipperVO

setShippedDate(Date) - Method in class bb.common.SalesOrderShipDateListResult

setShippedDate(Date) - Method in class bb.common.ShipperInfoVO

setShippedDate(Date) - Method in class bb.common.ShipperVO

setShippedDate(Date) - Method in class bb.common.StockTransactionSOShipperResult

setShippedDate(Date) - Method in class bb.common.SwapShipperItemListResult

setShippedDate(Date) - Method in class bb.common.SwapShipperItemVO

setShippedDate(Date) - Method in class bb.common.SwapShipperListResult

setShippedDate(Date) - Method in class bb.common.SwapShipperOnOrderResult

setShippedDate(Date) - Method in class bb.common.SwapShipperVO

setShippedDate(Date) - Method in class bb.common.TransferShipperItemListResult

setShippedDate(Date) - Method in class bb.common.TransferShipperItemVO

setShippedDate(Date) - Method in class bb.common.TransferShipperListResult

setShippedDate(Date) - Method in class bb.common.TransferShipperVO

setShippedItemCount(int) - Method in class bb.common.SalesOrderOnTimeItemResult

setShippedMarginPct(BigDecimal) - Method in class bb.common.SalesOrderOnTimeItemResult

setShippedQty(BigDecimal) - Method in class bb.common.OnLoanItemListResult

setShippedQty(BigDecimal) - Method in class bb.common.PartInventoryVO

setShippedQty(BigDecimal) - Method in class bb.common.SalesOrderItemGroupByPartListResult

setShippedQty(BigDecimal) - Method in class bb.common.SalesOrderItemListResult

setShippedQty(BigDecimal) - Method in class bb.common.ShipperItemDetailAgent

setShippedQty(BigDecimal) - Method in class bb.common.StockTransactionSOShipperResult

setShippedQty(BigDecimal) - Method in class bb.common.SwapOrderItemListResult

setShippedQty(BigDecimal) - Method in class bb.common.SwapOrderItemVO

setShippedQty(BigDecimal) - Method in class bb.common.SwapReceiverItemListResult

setShippedQty(BigDecimal) - Method in class bb.common.SwapReceiverItemVO

setShippedQty(BigDecimal) - Method in class bb.common.SwapShipperItemListResult

setShippedQty(BigDecimal) - Method in class bb.common.SwapShipperItemVO

setShippedQty(BigDecimal) - Method in class bb.common.SwapShipperOnOrderResult

setShippedQty(BigDecimal) - Method in class bb.common.ToolInventoryVO

setShippedQty(BigDecimal) - Method in class bb.common.TransferOrderItemListResult

setShippedQty(BigDecimal) - Method in class bb.common.TransferOrderItemVO

setShippedQty(BigDecimal) - Method in class bb.common.TransferReceiverItemListResult

setShippedQty(BigDecimal) - Method in class bb.common.TransferReceiverItemVO

setShippedQty(BigDecimal) - Method in class bb.common.TransferShipperItemListResult

setShippedQty(BigDecimal) - Method in class bb.common.TransferShipperItemVO

setShippedQuantity(BigDecimal) - Method in class bb.common.OnLoanItemVO

setShippedTotalOnTime(BigDecimal) - Method in class bb.common.SalesOrderOnTimeItemResult

setShippedVia(String) - Method in class bb.common.AccountsPayableInfoVO

setShippedVia(String) - Method in class bb.common.AccountsPayableVO

setShippedVia(String) - Method in class bb.common.OnloanReceiverVO

setShippedVia(String) - Method in class bb.common.PfReceiverVO

setShippedVia(String) - Method in class bb.common.ReceiverInfoVO

setShippedVia(String) - Method in class bb.common.ReceiverVO

setShippedVia(String) - Method in class bb.common.RMAReceiverVO

setShipperBp(String) - Method in class bb.common.OnloanShipperVO

setShipperBp(String) - Method in class bb.common.ShipperVO

setShipperComments(String) - Method in class bb.common.OnloanShipperVO

setShipperComments(String) - Method in class bb.common.ShipperInfoVO

setShipperComments(String) - Method in class bb.common.ShipperVO

setShipperComments(String) - Method in class bb.common.TransferShipperListResult

setShipperComments(String) - Method in class bb.common.TransferShipperVO

setShipperDate(Date) - Method in class bb.common.ShipperListResult

setShipperDigits(byte) - Method in class bb.common.CompanyVO

setShipperItemComments(String) - Method in class bb.common.OnloanShipperItemVO

setShipperItemComments(String) - Method in class bb.common.ShipperItemVO

setShipperItemDetails(Set<ShipperItemDetailAgent>) - Method in class bb.common.ShipperItemAgent

setShipperItemManufacturer(Set) - Method in class bb.common.OnloanShipperItemVO

setShipperItemManufacturer(Set) - Method in class bb.common.ShipperItemVO

setShipperItemNumber(String) - Method in class bb.common.AccountsReceivableItemVO

setShipperItemNumber(String) - Method in class bb.common.ShipperItemListResult

setShipperItemNumber(String) - Method in class bb.common.ShipperItemPK

setShipperItemPk(ShipperItemPK) - Method in class bb.common.SOShipperItemListResult

setShipperItemPks(ArrayList<ShipperItemPK>) - Method in class bb.common.MakeInvoiceAgent

setShipperItemPrivateNotes(String) - Method in class bb.common.OnloanShipperItemVO

setShipperItemPrivateNotes(String) - Method in class bb.common.ShipperItemVO

setShipperItems(Set) - Method in class bb.common.ShipperVO

setShipperNumber(String) - Method in class bb.common.AccountsReceivableInfoVO

setShipperNumber(String) - Method in class bb.common.AccountsReceivableItemVO

setShipperNumber(String) - Method in class bb.common.AccountsReceivableVO

setShipperNumber(String) - Method in class bb.common.GeneralLedgerListResult

setShipperNumber(String) - Method in class bb.common.GeneralLedgerResult

setShipperNumber(String) - Method in class bb.common.GeneralLedgerVO

setShipperNumber(String) - Method in class bb.common.InvoiceItemListResult

setShipperNumber(String) - Method in class bb.common.MakeBillAndHoldInvoiceAgent

setShipperNumber(String) - Method in class bb.common.MakeInvoiceAgent

setShipperNumber(String) - Method in class bb.common.ProformaInvoiceItemVO

setShipperNumber(String) - Method in class bb.common.ReceivedToOrderItem

setShipperNumber(String) - Method in class bb.common.ReceiverItemDetailAgent

setShipperNumber(String, String) - Method in class bb.common.ReceiverShipAgent

setShipperNumber(String) - Method in class bb.common.SalesOrderShipDateListResult

setShipperNumber(String) - Method in class bb.common.ShipperInfoVO

setShipperNumber(String) - Method in class bb.common.ShipperItemAgent

setShipperNumber(String) - Method in class bb.common.ShipperItemListResult

setShipperNumber(String) - Method in class bb.common.ShipperItemManufacturerPK

setShipperNumber(String) - Method in class bb.common.ShipperItemPK

setShipperNumber(String) - Method in class bb.common.ShipperListResult

setShipperNumber(String) - Method in class bb.common.ShipperVO

setShipperNumber(String) - Method in class bb.common.StockTransactionSOShipperResult

setShipperNumbers(Map<String, String>) - Method in class bb.common.ReceiverShipAgent

setShipperPrefix(String) - Method in class bb.common.CompanyVO

setShipperPrivateNotes(String) - Method in class bb.common.OnloanShipperVO

setShipperPrivateNotes(String) - Method in class bb.common.ShipperInfoVO

setShipperPrivateNotes(String) - Method in class bb.common.ShipperVO

setShipperPrivateNotes(String) - Method in class bb.common.TransferShipperListResult

setShipperPrivateNotes(String) - Method in class bb.common.TransferShipperVO

setShippingAccount(String) - Method in class bb.common.DisassembleWorkOrderVO

setShippingAccount(String) - Method in class bb.common.WorkOrderVO

setShippingDepth(BigDecimal) - Method in class bb.common.PartVO

setShippingDepth(BigDecimal) - Method in class bb.common.PartWithOnhandsVO

setShippingDepth(BigDecimal) - Method in class bb.common.ToolVO

setShippingDepth(BigDecimal) - Method in class bb.common.ToolWithOnhandsVO

setShippingItems(Set) - Method in class bb.common.ShippingResult

setShippingLength(BigDecimal) - Method in class bb.common.PartVO

setShippingLength(BigDecimal) - Method in class bb.common.PartWithOnhandsVO

setShippingLength(BigDecimal) - Method in class bb.common.ToolVO

setShippingLength(BigDecimal) - Method in class bb.common.ToolWithOnhandsVO

setShippingMark(String) - Method in class bb.common.PfReceiverVO

setShippingMark(String) - Method in class bb.common.ProformaInvoiceVO

setShippingStatus(String) - Method in class bb.common.PackingBoxSalesOrderItemResult

setShippingStatus(String) - Method in class bb.common.PurchaseOrderItemVO

setShippingStatus(String) - Method in class bb.common.PurchaseOrderOpenDueListResult

setShippingStatus(String) - Method in class bb.common.PurchaseOrderVO

setShippingStatus(String) - Method in class bb.common.SalesOrderItemInfoVO

setShippingStatus(String) - Method in class bb.common.SalesOrderItemVO

setShippingStatus(String) - Method in class bb.common.SalesOrderVO

setShippingWeight(BigDecimal) - Method in class bb.common.InventoryMonthReport

setShippingWeight(String) - Method in class bb.common.PartExportInfo

setShippingWeight(Float) - Method in class bb.common.PartOnhandResult

setShippingWeight(float) - Method in class bb.common.PartVO

setShippingWeight(float) - Method in class bb.common.PartWithOnhandsVO

setShippingWeight(String) - Method in class bb.common.ShipListItemVOResult

setShippingWeight(float) - Method in class bb.common.ToolVO

setShippingWeight(float) - Method in class bb.common.ToolWithOnhandsVO

setShippingWeightUnit(String) - Method in class bb.common.CompanyVO

setShippingWeightUnit(String) - Method in class bb.common.InventoryMonthReport

setShippingWeightUnit(String) - Method in class bb.common.PartExportInfo

setShippingWeightUnit(String) - Method in class bb.common.PartOnhandResult

setShippingWeightUnit(String) - Method in class bb.common.PartVO

setShippingWeightUnit(String) - Method in class bb.common.PartWithOnhandsVO

setShippingWeightUnit(String) - Method in class bb.common.ToolVO

setShippingWeightUnit(String) - Method in class bb.common.ToolWithOnhandsVO

setShippingWidth(BigDecimal) - Method in class bb.common.PartVO

setShippingWidth(BigDecimal) - Method in class bb.common.PartWithOnhandsVO

setShippingWidth(BigDecimal) - Method in class bb.common.ToolVO

setShippingWidth(BigDecimal) - Method in class bb.common.ToolWithOnhandsVO

setShipQty(BigDecimal) - Method in class bb.common.PackingBoxSalesOrderItemResult

setShipQuantity(BigDecimal) - Method in class bb.common.RequestForQuoteItemVO

setShipTo(String) - Method in class bb.common.AccountsReceivableInfoVO

setShipTo(String) - Method in class bb.common.AccountsReceivableItemVO

setShipTo(String) - Method in class bb.common.AccountsReceivableVO

setShipTo(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setShipTo(String) - Method in class bb.common.CustomerVendorAddressVO

setShipTo(String) - Method in class bb.common.PackingBoxItemVO

setShipTo(String) - Method in class bb.common.ProformaInvoiceItemVO

setShipTo(String) - Method in class bb.common.ProformaInvoiceVO

setShipto(String) - Method in class bb.common.PurchaseOrderItemListResult

setShipTo(String) - Method in class bb.common.ReturnToVendorByDateListResult

setShipTo(String) - Method in class bb.common.ReturnToVendorVO

setShipto(String) - Method in class bb.common.RtvShipperItemVO

setShipTo(String) - Method in class bb.common.RunningAccountOrderItemResult

setShipTo(String) - Method in class bb.common.RunningAccountOrderVO

setShipTo(String) - Method in class bb.common.ShipListItemVOResult

setShipToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.AccountsReceivableVO

setShipToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.ArPrepayVO

setShipToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.CustomerReturnToVendorVO

setShipToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.DisassembleWorkOrderVO

setShipToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.OnloanShipperVO

setShipToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.OnLoanVO

setShipToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.ProformaInvoiceVO

setShipToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.PurchaseOrderVO

setShipToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.QuoteVO

setShipToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.RequestForQuoteVO

setShipToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.RequestForRMAVO

setShipToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.ReturnMaterialAuthorizationVO

setShipToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.ReturnToVendorVO

setShipToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.RtvShipperInfoVO

setShipToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.RtvShipperVO

setShipToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.SalesOrderVO

setShipToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.ShipperInfoVO

setShipToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.ShipperVO

setShipToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.WorkOrderVO

setShipToCountry(String) - Method in class bb.common.InvoiceItemListResult

setShipToId(String) - Method in class bb.common.ArPrepayVO

setShipToId(String) - Method in class bb.common.BB2PartInSitItemResult

setShipToId(String) - Method in class bb.common.CompanyVO

setShipToId(String) - Method in class bb.common.CustomerFeedbackVO

setShipToId(String) - Method in class bb.common.CustomerReturnToVendorVO

setShipToId(String) - Method in class bb.common.DisassembleWorkOrderVO

setShipToId(String) - Method in class bb.common.InvoiceItemListResult

setShipToId(String) - Method in class bb.common.MakeBillAndHoldInvoiceAgent

setShipToId(String) - Method in class bb.common.MakeInvoiceAgent

setShipToId(String) - Method in class bb.common.OnloanShipperItemVO

setShipToId(String) - Method in class bb.common.OnloanShipperVO

setShiptoId(String) - Method in class bb.common.OnLoanVO

setShiptoId(String) - Method in class bb.common.PO2SOExchange

setShipToId(String) - Method in class bb.common.ProformaInvoiceListResult

setShipToId(String) - Method in class bb.common.PurchaseOrderOnOrderResult

setShipToId(String) - Method in class bb.common.PurchaseOrderVO

setShipToId(String) - Method in class bb.common.Quote2QuoteAgent

setShipToId(String) - Method in class bb.common.QuoteVO

setShipToId(String) - Method in class bb.common.RequestForQuoteVO

setShipToId(String) - Method in class bb.common.RequestForRMAVO

setShipToId(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setShipToId(String) - Method in class bb.common.RMAReceiverResult

setShipToId(String) - Method in class bb.common.RMAReceiverVO

setShipToId(String) - Method in class bb.common.RtvShipperInfoVO

setShipToId(String) - Method in class bb.common.RtvShipperListResult

setShipToId(String) - Method in class bb.common.RtvShipperVO

setShipToId(String) - Method in class bb.common.SalesOrderVO

setShipToId(String) - Method in class bb.common.ShipperInfoVO

setShipToId(String) - Method in class bb.common.ShipperItemVO

setShipToId(String) - Method in class bb.common.ShipperVO

setShipToId(String) - Method in class bb.common.SO2SOAgent

setShipToId(String) - Method in class bb.common.WorkOrderOnOrderResult

setShipToId(String) - Method in class bb.common.WorkOrderVO

setShipToID(String) - Method in class bb.common.ZipcodeTotalsResult

setShipToInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.RMAReceiverVO

setShiptoName(String) - Method in class bb.common.PO2SOExchange

setShipToName(String) - Method in class bb.common.ZipcodeTotalsResult

setShipToState(String) - Method in class bb.common.InvoiceItemListResult

setShipTotal(BigDecimal) - Method in class bb.common.AccountingTotalMoneyResult

setShipTotal(BigDecimal) - Method in class bb.common.DuePATotalByVendorResult

setShipVia(String) - Method in class bb.common.AccountsReceivableInfoVO

setShipVia(String) - Method in class bb.common.AccountsReceivableItemVO

setShipVia(String) - Method in class bb.common.AccountsReceivableVO

setShipvia(String) - Method in class bb.common.CustomerReturnToVendorItemVO

setShipVia(String) - Method in class bb.common.CustomerReturnToVendorVO

setShipVia(String) - Method in class bb.common.DisassembleWorkOrderItemVO

setShipvia(String) - Method in class bb.common.DisassembleWorkOrderReceivingResult

setShipVia(String) - Method in class bb.common.DisassembleWorkOrderVO

setShipvia(String) - Method in class bb.common.IssuingResult

setShipVia(String) - Method in class bb.common.MakeBillAndHoldInvoiceAgent

setShipVia(String) - Method in class bb.common.MakeInvoiceAgent

setShipVia(String) - Method in class bb.common.NonproductivePickingOnDemandResult

setShipVia(String) - Method in class bb.common.OnLoanItemListResult

setShipVia(String) - Method in class bb.common.OnLoanItemVO

setShipVia(String) - Method in class bb.common.OnloanShipperItemVO

setShipVia(String) - Method in class bb.common.OnloanShipperVO

setShipVia(String) - Method in class bb.common.OnLoanVO

setShipVia(String) - Method in class bb.common.OrderApprovalItemsVO

setShipVia(String) - Method in class bb.common.PackingBoxItemVO

setShipVia(String) - Method in class bb.common.PfReceiverItemVO

setShipVia(String) - Method in class bb.common.PO2SOExchangeItem

setShipVia(String) - Method in class bb.common.PoMessageItemVO

setShipVia(String) - Method in class bb.common.ProformaInvoiceItemVO

setShipVia(String) - Method in class bb.common.ProformaInvoiceVO

setShipVia(String) - Method in class bb.common.PrPackingBoxItemVO

setShipVia(String) - Method in class bb.common.PurchaseOrderItemVO

setShipVia(String) - Method in class bb.common.PurchaseOrderOpenDueListResult

setShipVia(String) - Method in class bb.common.PurchaseOrderVO

setShipVia(String) - Method in class bb.common.QuoteItemListResult

setShipVia(String) - Method in class bb.common.QuoteItemVO

setShipVia(String) - Method in class bb.common.QuoteVO

setShipVia(String) - Method in class bb.common.RequestForQuoteItemVO

setShipVia(String) - Method in class bb.common.RequestForQuoteVO

setShipvia(String) - Method in class bb.common.RequestForRMAItemVO

setShipVia(String) - Method in class bb.common.RequestForRMAVO

setShipvia(String) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setShipVia(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setShipVia(String) - Method in class bb.common.ReturnToVendorItemVO

setShipVia(String) - Method in class bb.common.ReturnToVendorVO

setShipVia(String) - Method in class bb.common.RfqMessageItemVO

setShipVia(String) - Method in class bb.common.RtvShipperInfoVO

setShipvia(String) - Method in class bb.common.RtvShipperItemListResult

setShipvia(String) - Method in class bb.common.RtvShipperItemVO

setShipVia(String) - Method in class bb.common.RtvShipperListResult

setShipVia(String) - Method in class bb.common.RtvShipperVO

setShipVia(String) - Method in class bb.common.SalesOrderItemInfoVO

setShipVia(String) - Method in class bb.common.SalesOrderItemListResult

setShipVia(String) - Method in class bb.common.SalesOrderItemVO

setShipVia(String) - Method in class bb.common.SalesOrderOnDemandResult

setShipVia(String) - Method in class bb.common.SalesOrderVO

setShipVia(String) - Method in class bb.common.ShipListItemVOResult

setShipVia(String) - Method in class bb.common.ShipperAgent

setShipVia(String) - Method in class bb.common.ShipperInfoVO

setShipVia(String) - Method in class bb.common.ShipperItemVO

setShipVia(String) - Method in class bb.common.ShipperVO

setShipVia(String) - Method in class bb.common.SO2POAgent

setShipVia(String) - Method in class bb.common.SwapOrderListResult

setShipVia(String) - Method in class bb.common.SwapOrderVO

setShipVia(String) - Method in class bb.common.SwapReceiverListResult

setShipVia(String) - Method in class bb.common.SwapReceiverVO

setShipVia(String) - Method in class bb.common.SwapShipperListResult

setShipVia(String) - Method in class bb.common.SwapShipperVO

setShipVia(String) - Method in class bb.common.TransferOrderListResult

setShipVia(String) - Method in class bb.common.TransferOrderVO

setShipVia(String) - Method in class bb.common.TransferReceiverItemListResult

setShipVia(String) - Method in class bb.common.TransferReceiverItemVO

setShipVia(String) - Method in class bb.common.TransferReceiverListResult

setShipVia(String) - Method in class bb.common.TransferReceiverVO

setShipVia(String) - Method in class bb.common.TransferShipperItemListResult

setShipVia(String) - Method in class bb.common.TransferShipperItemVO

setShipVia(String) - Method in class bb.common.TransferShipperListResult

setShipVia(String) - Method in class bb.common.TransferShipperVO

setShipVia(String) - Method in class bb.common.WorkOrderItemVO

setShipVia(String) - Method in class bb.common.WorkOrderVO

setShortage(BigDecimal) - Method in class bb.common.InventoryListResult

setShortageAmount(BigDecimal) - Method in class bb.common.InventoryMonthReport

setShortageAmount(BigDecimal) - Method in class bb.common.InventoryPartInOutDetailListResult

setShortageCost(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

setShortageCost(BigDecimal) - Method in class bb.common.WorkOrderItemPartDetailResult

setShortageQty(BigDecimal) - Method in class bb.common.InventoryMonthReport

setShortageQty(BigDecimal) - Method in class bb.common.InventoryPartInOutDetailListResult

setShortageQty(BigDecimal) - Method in class bb.common.PhysicalInventoryListWithAppDataResult

setShortAgeQty(BigDecimal) - Method in class bb.common.SalesOrderItemListResult

setShortageStdCost(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

setShortageStdCost(BigDecimal) - Method in class bb.common.WorkOrderItemPartDetailResult

setShortageTotal(BigDecimal) - Method in class bb.common.PhysicalInventoryListWithAppDataResult

setShortcut(String) - Method in class bb.common.OpCodeShortcutVO

setShortDescription(String) - Method in class bb.common.WorkInstructionSummaryItemResult

setShortItemPk(OrderPK) - Method in class bb.common.MrpItemResult

setShortQty(BigDecimal) - Method in class bb.common.MrpByMonthResult

setShortQty(BigDecimal) - Method in class bb.common.OrderVendorItem

setShortQty(BigDecimal) - Method in class bb.common.PackingBoxSalesOrderItemResult

setShortQuantity(BigDecimal) - Method in class bb.common.ReceivedToOrderItem

setShowFax(String) - Method in class bb.common.EmployeeCardVO

setShowHomePhone(String) - Method in class bb.common.EmployeeCardVO

setShowMobile(String) - Method in class bb.common.EmployeeCardVO

setShowNotReviewOrder(boolean) - Method in class bb.common.MrpReportAgent

setShowNumberTailZero(boolean) - Method in class bb.common.CompanyVO

setShowOnDemand(boolean) - Method in class bb.common.MrpReportAgent

setShowOnOrder(boolean) - Method in class bb.common.MrpReportAgent

setShowOrgAndLevelForPart(boolean) - Method in class bb.common.CompanyVO

setShowOriginal(boolean) - Method in class bb.common.GLInfoByPeriodResult

setShowTimeZone(boolean) - Method in class bb.common.CompanyVO

setShowZeroMustOrder(boolean) - Method in class bb.common.MrpReportAgent

setSignature(byte[]) - Method in class bb.common.AccountsReceivableVO

setSignature(byte[]) - Method in class bb.common.CheckInvoiceItemListResult

setSip(BigDecimal) - Method in class bb.common.PartOnHandAuditResult

setSipQty(BigDecimal) - Method in class bb.common.PackingBoxSalesOrderItemResult

setSipQty(BigDecimal) - Method in class bb.common.PurchaseOrderItemListResult

setSipQty(BigDecimal) - Method in class bb.common.QuoteItemListResult

setSipQty(BigDecimal) - Method in class bb.common.SalesOrderItemInfoVO

setSipQty(BigDecimal) - Method in class bb.common.SalesOrderItemListResult

setSipQty(BigDecimal) - Method in class bb.common.SalesOrderItemVO

setSitQty(BigDecimal) - Method in class bb.common.PurchaseOrderItemListResult

setSitQty(BigDecimal) - Method in class bb.common.PurchaseOrderItemVO

setSitQty(BigDecimal) - Method in class bb.common.PurchaseOrderOnOrderResult

setSitQty(BigDecimal) - Method in class bb.common.SalesOrderItemListResult

setSize(long) - Method in class bb.common.TaskFileResult

setSmallCatagory(String) - Method in class bb.common.PartCatagoryPK

setSmtpServer(SmtpServerVO) - Method in interface bb.common.box.CompanyBox

setSn(String) - Method in class bb.common.ARPaymentRunItemVO

setSoBoilerplate(String) - Method in class bb.common.SalesOrderBoilerplateVO

setSoComments(String) - Method in class bb.common.ShipListItemVOResult

setSoCount(SalesInfoCenter.SoCount) - Method in class bb.common.SalesInfoCenter

setSoCountWithPartsOnhold(SalesInfoCenter.SoCountWithPartsOnhold) - Method in class bb.common.SalesInfoCenter

setSoCreditAccount(String) - Method in class bb.common.AccountingSettingsVO

setSoDate(Date) - Method in class bb.common.SalesOrderCheckListResult

setSoDate(Date) - Method in class bb.common.SalesOrderItemListResult

setSoDate(Date) - Method in class bb.common.SalesOrderListResult

setSoDetails(ArrayList) - Method in class bb.common.BB2PartTotalOndemandDetailResult

setSoDetails(ArrayList) - Method in class bb.common.PartInMrpListResult

setSoDigits(byte) - Method in class bb.common.CompanyVO

setSoDueItems12MonthAvg(BigDecimal) - Method in class bb.common.SalesOrderOnTimeResult

setSoDueItemsFysical(BigDecimal) - Method in class bb.common.SalesOrderOnTimeResult

setSoDueItemsLastMonth(BigDecimal) - Method in class bb.common.SalesOrderOnTimeResult

setSoDueItemsThisMonth(BigDecimal) - Method in class bb.common.SalesOrderOnTimeResult

setSoDueItemsYtd(BigDecimal) - Method in class bb.common.SalesOrderOnTimeResult

setSoDueTotal12MonthAvg(BigDecimal) - Method in class bb.common.SalesOrderOnTimeResult

setSoDueTotalFysical(BigDecimal) - Method in class bb.common.SalesOrderOnTimeResult

setSoDueTotalLastMonth(BigDecimal) - Method in class bb.common.SalesOrderOnTimeResult

setSoDueTotalThisMonth(BigDecimal) - Method in class bb.common.SalesOrderOnTimeResult

setSoDueTotalYtd(BigDecimal) - Method in class bb.common.SalesOrderOnTimeResult

setSoItemCount(SalesInfoCenter.SoItemCount) - Method in class bb.common.SalesInfoCenter

setSoItemNumber(String) - Method in class bb.common.SalesOrderItemListResult

setSoItemPk(SalesOrderItemPK) - Method in class bb.common.PackingBoxSalesOrderItemAgent

setSold(BigDecimal) - Method in class bb.common.InventoryListResult

setSoMail(boolean) - Method in class bb.common.CustomerVendorContactVO

setSoNotReviewedOnDemandList(ArrayList) - Method in class bb.common.MrpItemResult

setSoNumber(String) - Method in class bb.common.ARPaymentRunItemVO

setSoNumber(String) - Method in class bb.common.ARPaymentRunListResult

setSoNumber(String) - Method in class bb.common.ArPrepayItemVO

setSoNumber(String) - Method in class bb.common.GeneralLedgerByDateListResult

setSoNumber(String) - Method in class bb.common.MiscDocAgent

setSoNumber(String) - Method in class bb.common.NcrReportListResult

setSoNumber(String) - Method in class bb.common.PostCheckAgent

setSoNumber(String) - Method in class bb.common.RMAReceiverItemListResult

setSoNumber(String) - Method in class bb.common.SalesOrderCheckListResult

setSoNumber(String) - Method in class bb.common.SalesOrderDocumentVO

setSoNumber(String) - Method in class bb.common.SalesOrderItemListResult

setSoNumber(String) - Method in class bb.common.SalesOrderListResult

setSoNumber(String) - Method in class bb.common.SerialNumberResult

setSoNumber(String) - Method in class bb.common.SO2POAgent

setSoNumber(String) - Method in class bb.common.SO2SOAgent

setSoNumber(String) - Method in class bb.common.SO2WOAgent

setSoNumber(String) - Method in class bb.common.StockTransactionSOShipperResult

setSoOnDemandList(ArrayList) - Method in class bb.common.MrpItemOrderDemandRecordsResult

setSoOnDemandList(ArrayList) - Method in class bb.common.MrpItemResult

setSoPastDue(BigDecimal) - Method in class bb.common.CashFlowByMonthReportResult

setSoPrefix(String) - Method in class bb.common.CompanyVO

setSoQuantity(BigDecimal) - Method in class bb.common.ShipperItemVO

setSoQuantity(BigDecimal) - Method in class bb.common.SOShipperItemListResult

setSoShippedItemOntime12MonthAvg(BigDecimal) - Method in class bb.common.SalesOrderOnTimeResult

setSoShippedItemOntimeFysical(BigDecimal) - Method in class bb.common.SalesOrderOnTimeResult

setSoShippedItemOntimeLastMonth(BigDecimal) - Method in class bb.common.SalesOrderOnTimeResult

setSoShippedItemOntimeThisMonth(BigDecimal) - Method in class bb.common.SalesOrderOnTimeResult

setSoShippedItemOntimeYtd(BigDecimal) - Method in class bb.common.SalesOrderOnTimeResult

setSoShippedTotalOntime12MonthAvg(BigDecimal) - Method in class bb.common.SalesOrderOnTimeResult

setSoShippedTotalOntimeFysical(BigDecimal) - Method in class bb.common.SalesOrderOnTimeResult

setSoShippedTotalOntimeLastMonth(BigDecimal) - Method in class bb.common.SalesOrderOnTimeResult

setSoShippedTotalOntimeThisMonth(BigDecimal) - Method in class bb.common.SalesOrderOnTimeResult

setSoShippedTotalOntimeYtd(BigDecimal) - Method in class bb.common.SalesOrderOnTimeResult

setSoSip(BigDecimal) - Method in class bb.common.PartOnHandAuditResult

setSoSipQty(BigDecimal) - Method in class bb.common.SalesOrderItemListResult

setSoTotal(BigDecimal) - Method in class bb.common.ArPrepayVO

setSoTotalSum(SalesInfoCenter.SoTotalSum) - Method in class bb.common.SalesInfoCenter

setSource(String) - Method in class bb.common.CustomEmployeeVO

setSource(String) - Method in class bb.common.EmployeeCardVO

setSoVAT(String) - Method in class bb.common.AccountingSettingsVO

setSoWithPartOnHoldCount(Integer) - Method in class bb.common.WareHousingInfoCenterResult

setSpaceHomePage(String) - Method in class bb.common.HelpServerVO

setSparePart(String) - Method in class bb.common.BillItemSalesCostResult

setSparePart(String) - Method in class bb.common.BillItemSalesResult

setSparePart(String) - Method in class bb.common.BillItemSalesXResult

setSparePart(String) - Method in class bb.common.BillItemUsagePathResult

setSparePart(String) - Method in class bb.common.BillItemVO

setSparePart(String) - Method in class bb.common.BillItemWithPartInfoResult

setSparePart(String) - Method in class bb.common.BillLogVO

setSparePart(String) - Method in class bb.common.SalesBomItemResult

setSpareQty(BigDecimal) - Method in class bb.common.BillItemUsageResult

setSpeaker(String) - Method in class bb.common.CustomEmployeeTrainVO

setSpeaker(String) - Method in class bb.common.EmployeeTrainingVO

setSpec(Collection) - Method in class bb.common.PartTraceableInfoResult

setSpecialCustomerCode(String) - Method in class bb.common.CustomerVendorAddressVO

setSpecialProcess(String) - Method in class bb.common.WorkInstructionSequenceVO

setSpecialProcess(String) - Method in class bb.common.WorkOrderTimeCardVO

setSpecialProcess(String) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setSpecialTitle(String) - Method in class bb.common.CustomEmployeeVO

setSpecialty(String) - Method in class bb.common.CustomEmployeeVO

setSpecialVendorCode(String) - Method in class bb.common.CustomerVendorAddressVO

setSpecialWork(String) - Method in class bb.common.CustomEmployeeVO

setSpecification(TraceableSpecsVO) - Method in class bb.common.PartTraceableSpecVO

setSpecification(String) - Method in class bb.common.POSurveyReportItemVO

setSpecificationId(short) - Method in class bb.common.PartTraceableResult

setSpecificationId(short) - Method in class bb.common.PartTraceableSpecVO

setSpouseName(String) - Method in class bb.common.EmployeeHomeVO

setSrDate(Date) - Method in class bb.common.ScrapReportVO

setSrItemNumber(String) - Method in class bb.common.POSurveyReportItemPK

setSrNumber(String) - Method in class bb.common.POSurveyReportItemPK

setSrNumber(String) - Method in class bb.common.POSurveyReportVO

setSrNumber(String) - Method in class bb.common.ScrapReportVO

setSrResult(String) - Method in class bb.common.POSurveyReportItemVO

setStaff(String) - Method in class bb.common.OperatingInstructionsUserStatisticalResult

setStaff(String) - Method in class bb.common.OperatingInstructionsVO

setStaff(String) - Method in class bb.common.StaffWorkingInformationResult

setStaffSign(String) - Method in class bb.common.OperatingInstructionsVO

setStandardCost(BigDecimal) - Method in class bb.common.BillDetailCostResult

setStandardCost(BigDecimal) - Method in class bb.common.BillDetailCostWithPartInfoResult

setStandardCost(BigDecimal) - Method in class bb.common.BillItemDetailCostWithPartInfoResult

setStandardCost(BigDecimal) - Method in class bb.common.BillItemSalesCostResult

setStandardCost(BigDecimal) - Method in class bb.common.BillItemSalesXResult

setStandardCost(BigDecimal) - Method in class bb.common.BillItemUsageResult

setStandardCost(BigDecimal) - Method in class bb.common.BillSalesCostResult

setStandardCost(BigDecimal) - Method in class bb.common.BillSalesXResult

setStandardCost(BigDecimal) - Method in class bb.common.DWOIssueDetail

setStandardCost(BigDecimal) - Method in class bb.common.HistoricalInventoryVO

setStandardCost(BigDecimal) - Method in class bb.common.InventoryListResult

setStandardCost(BigDecimal) - Method in class bb.common.PartCostVarianceListResult

setStandardCost(BigDecimal) - Method in class bb.common.PartInventoryVO

setStandardCost(BigDecimal) - Method in class bb.common.PartOnHandWithMfgInfoResult

setStandardCost(BigDecimal) - Method in class bb.common.PhysicalInventoryVO

setStandardCost(BigDecimal) - Method in class bb.common.POReceiverItemListResult

setStandardCost(BigDecimal) - Method in class bb.common.RollUPPartStandardCostResult

setStandardCost(BigDecimal) - Method in class bb.common.ToolInventoryVO

setStandardCost(BigDecimal) - Method in class bb.common.ToolListDetailCostResult

setStandardCost(BigDecimal) - Method in class bb.common.ToolListDetailCostWithToolInfoResult

setStandardCost(BigDecimal) - Method in class bb.common.ToolListItemDetailCostWithToolInfoResult

setStandardCost(BigDecimal) - Method in class bb.common.WOReceiverDetail

setStandardCost(BigDecimal) - Method in class bb.common.WorkOrderItemListResult

setStandardExtendedCost(BigDecimal) - Method in class bb.common.POReceiverItemListResult

setStartAmount(BigDecimal) - Method in class bb.common.InventoryMonthReport

setStartCost(BigDecimal) - Method in class bb.common.InventoryMonthReport

setStartDate(Date) - Method in class bb.common.AccountAuditAgent

setStartDate(Date) - Method in class bb.common.BB2FiscalYearDate

setStartDate(Date) - Method in class bb.common.ContractPriceVO

setStartDate(Date) - Method in class bb.common.CycleCountListResult

setStartDate(Date) - Method in class bb.common.DisassembleWorkOrderItemListResult

setStartDate(Date) - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

setStartDate(Date) - Method in class bb.common.DisassembleWorkOrderItemVO

setStartDate(Date) - Method in class bb.common.EmployeeCardVO

setStartDate(Date) - Method in class bb.common.FiscalYearSettingsVO

setStartDate(Date) - Method in class bb.common.LogTaskVO

setStartDate(Date) - Method in class bb.common.OperatingInstructionsUserStatisticalResult

setStartDate(Date) - Method in class bb.common.OperatingInstructionsVO

setStartDate(Date) - Method in class bb.common.OrderApprovalItemsVO

setStartDate(Date) - Method in class bb.common.PartOnHandAuditAgent

setStartDate(Date) - Method in class bb.common.PhysicalInventoryListResult

setStartDate(Date) - Method in class bb.common.RollUpBomStdCostWorkSheetVO

setStartDate(Date) - Method in class bb.common.SalesmanVO

setStartDate(Date) - Method in class bb.common.ShipListAgent

setStartDate(Date) - Method in class bb.common.TaskVO

setStartDate(Date) - Method in class bb.common.VendorContractPriceVO

setStartDate(Date) - Method in class bb.common.WCLoadByDateResult

setStartDate(Date) - Method in class bb.common.WCLoadDetailResult

setStartDate(Date) - Method in class bb.common.WO2WOAgent

setStartDate(Date) - Method in class bb.common.WOItemPartDetailNotIssue

setStartDate(Date) - Method in class bb.common.WoItemPickListResult

setStartDate(Date) - Method in class bb.common.WorkOrderItemCanAssyResult

setStartDate(Date) - Method in class bb.common.WorkOrderItemListResult

setStartDate(Date) - Method in class bb.common.WorkOrderItemPartDetailResult

setStartDate(Date) - Method in class bb.common.WorkOrderItemReviewCostResult

setStartDate(Date) - Method in class bb.common.WorkOrderItemSeqWCLoadResult

setStartDate(Date) - Method in class bb.common.WorkOrderItemTimeDetailResult

setStartDate(Date) - Method in class bb.common.WorkOrderItemToIssueResult

setStartDate(Date) - Method in class bb.common.WorkOrderItemVO

setStartDate(Date) - Method in class bb.common.WorkOrderItemWCLoadResult

setStartDate(Date) - Method in class bb.common.WorkOrderOnDemandResult

setStartDate(Date) - Method in class bb.common.WorkOrderOverIssueListResult

setStartDate(Date) - Method in class bb.common.WorkOrderQueryInfo

setStartDate(Date) - Method in class bb.common.WorkOrderWorkInstructionSequenceDateAgent

setStartDate(Date) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setStartDate(Date) - Method in class bb.common.WorkOrderWorkItemDateAgent

setStartingBalanceCredit(BigDecimal) - Method in class bb.common.GLByDateTotalResult

setStartingBalanceDebit(BigDecimal) - Method in class bb.common.GLByDateTotalResult

setStartMonth(Date) - Method in class bb.common.CurrencyExchangeVO

setStartMonth(Date) - Method in class bb.common.GlMonthBudgetVO

setStartMonth(Date) - Method in class bb.common.GlMonthVO

setStartMonthBudget(BigDecimal) - Method in class bb.common.CashFlowMonthTotalResult

setStartNumberForSeq(String) - Method in class bb.common.PartNumberGenerateRuleVO

setStartQaAmount(BigDecimal) - Method in class bb.common.InventoryMonthReport

setStartQaQty(BigDecimal) - Method in class bb.common.InventoryMonthReport

setStartQty(BigDecimal) - Method in class bb.common.InventoryMonthReport

setStartWipAmount(BigDecimal) - Method in class bb.common.InventoryMonthReport

setStartWipDate(Date) - Method in class bb.common.AccountingSettingsVO

setStartWipQty(BigDecimal) - Method in class bb.common.InventoryMonthReport

setState(String) - Method in class bb.common.AccountPayableCheckVO

setState(String) - Method in class bb.common.AccountReceivablePaymentVO

setState(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setState(String) - Method in class bb.common.CustomerVendorAddressVO

setState(String) - Method in class bb.common.CustomerVendorDescriptionVO

setState(String) - Method in class bb.common.EmployeeHomeVO

setState(String) - Method in class bb.common.LockedCustomerAddressResult

setState(String) - Method in class bb.common.ManufacturerAddressInfoVO

setState(String) - Method in class bb.common.ManufacturerAddressVO

setState(String) - Method in class bb.common.ManufacturerDescriptionVO

setState(String) - Method in class bb.common.SalesmanVO

setState(String) - Method in class bb.common.SalesMarginListResult

setState(String) - Method in class bb.common.SalesOrderItemListResult

setState(String) - Method in class bb.common.SGCartCheckOutResult

setState(String) - Method in class bb.common.SGCustRequestForQuoteListResult

setState(String) - Method in class bb.common.SGCustRequestForQuoteResult

setState(String) - Method in class bb.common.SGQuoteAddressResult

setState(String) - Method in class bb.common.SGQuoteAddressVO

setStateName(String) - Method in class bb.common.PosZipCodeTaxVO

setStateTaxRate(BigDecimal) - Method in class bb.common.PosZipCodeTaxVO

setStature(Integer) - Method in class bb.common.CustomCheckUpEmployeeVO

setStature(int) - Method in class bb.common.CustomCheckUpEmployeeVO

setStatus(String) - Method in class bb.common.AccountPayableCheckRunItemVO

setStatus(String) - Method in class bb.common.AccountPayableCheckRunVO

setStatus(String) - Method in class bb.common.AccountPayableCheckVO

setStatus(String) - Method in class bb.common.AccountPayableInfoWithPrepayResult

setStatus(String) - Method in class bb.common.AccountReceivablePaymentVO

setStatus(String) - Method in class bb.common.AccountsPayableInfoVO

setStatus(String) - Method in class bb.common.AccountsPayableItemVO

setStatus(String) - Method in class bb.common.AccountsPayableVO

setStatus(String) - Method in class bb.common.AccountsReceivableInfoVO

setStatus(String) - Method in class bb.common.AccountsReceivableItemVO

setStatus(String) - Method in class bb.common.AccountsReceivableVO

setStatus(String) - Method in class bb.common.APAuditListResult

setStatus(String) - Method in class bb.common.APItemListResult

setStatus(String) - Method in class bb.common.ApPrepayItemVO

setStatus(String) - Method in class bb.common.ApPrepayVO

setStatus(String) - Method in class bb.common.ARAuditListResult

setStatus(String) - Method in class bb.common.ArCommissionListResult

setStatus(String) - Method in class bb.common.ARPaymentRunItemVO

setStatus(String) - Method in class bb.common.ARPaymentRunVO

setStatus(String) - Method in class bb.common.ArPrepayItemVO

setStatus(String) - Method in class bb.common.ArPrepayVO

setStatus(String) - Method in class bb.common.AssetDepreciateDetailReport

setStatus(String) - Method in class bb.common.AssetVO

setStatus(String) - Method in class bb.common.BankReconciliationReportVO

setStatus(String) - Method in class bb.common.BB2PartInSTOItemResult

setStatus(String) - Method in class bb.common.BB2PartOnLoanItemResult

setStatus(String) - Method in class bb.common.BillVO

setStatus(String) - Method in class bb.common.BillWithPartInfoResult

setStatus(String) - Method in class bb.common.BizboxBugChangesInfoVO

setStatus(String) - Method in class bb.common.BizboxBugChangesVO

setStatus(String) - Method in class bb.common.BizboxBugInfoVO

setStatus(String) - Method in class bb.common.BizboxBugVO

setStatus(int) - Method in class bb.common.BizboxUserListResult

setStatus(int) - Method in class bb.common.BizboxUserVO

setStatus(String) - Method in class bb.common.ChangeStdCostWorkSheetVO

setStatus(String) - Method in class bb.common.ContractPriceVO

setStatus(String) - Method in class bb.common.CorrectiveActionRequestVO

setStatus(String) - Method in class bb.common.CRTVItemListResult

setStatus(String) - Method in class bb.common.CRTVListResult

setStatus(String) - Method in class bb.common.CustomerFeedbackVO

setStatus(String) - Method in class bb.common.CustomerReturnToVendorItemVO

setStatus(String) - Method in class bb.common.CustomerReturnToVendorVO

setStatus(String) - Method in class bb.common.CustomerServiceIncidentItemListResult

setStatus(String) - Method in class bb.common.CustomerServiceIncidentItemVO

setStatus(String) - Method in class bb.common.CustomerServiceIncidentListResult

setStatus(String) - Method in class bb.common.CustomerServiceIncidentVO

setStatus(String) - Method in class bb.common.CustomerVendorDescriptionVO

setStatus(String) - Method in class bb.common.CycleCountStatusVO

setStatus(String) - Method in class bb.common.DesignControlInfoVO

setStatus(String) - Method in class bb.common.DesignControlListResult

setStatus(String) - Method in class bb.common.DesignControlVO

setStatus(String) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setStatus(String) - Method in class bb.common.DisassembleWorkOrderIssuingResult

setStatus(String) - Method in class bb.common.DisassembleWorkOrderItemListResult

setStatus(String) - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

setStatus(String) - Method in class bb.common.DisassembleWorkOrderItemVO

setStatus(String) - Method in class bb.common.DisassembleWorkOrderListResult

setStatus(String) - Method in class bb.common.DisassembleWorkOrderVO

setStatus(String) - Method in class bb.common.EmployeeCardVO

setStatus(String) - Method in class bb.common.EngineeringChangeListResult

setStatus(String) - Method in class bb.common.EngineeringChangeRequestListResult

setStatus(String) - Method in class bb.common.EngineeringChangeRequestVO

setStatus(String) - Method in class bb.common.EngineeringChangeVO

setStatus(String) - Method in class bb.common.EngineeringSharingImportLogVO

setStatus(String) - Method in class bb.common.EquipmentListResult

setStatus(String) - Method in class bb.common.EquipmentVO

setStatus(String) - Method in class bb.common.ExpenseListResult

setStatus(String) - Method in class bb.common.ExpenseVO

setStatus(String) - Method in class bb.common.FiscalYearSettingsVO

setStatus(String) - Method in class bb.common.GeneralLedgerSettingsVO

setStatus(String) - Method in class bb.common.GlMonthBudgetVO

setStatus(String) - Method in class bb.common.GlMonthVO

setStatus(String) - Method in class bb.common.IcrItemListResult

setStatus(String) - Method in class bb.common.IcrListResult

setStatus(String) - Method in class bb.common.InspectionConformanceReportItemVO

setStatus(String) - Method in class bb.common.InspectionConformanceReportVO

setStatus(String) - Method in class bb.common.InvoiceItemListResult

setStatus(String) - Method in class bb.common.JobProcessSheetListResult

setStatus(String) - Method in class bb.common.LnShipperItemListResult

setStatus(String) - Method in class bb.common.LnShipperListResult

setStatus(String) - Method in class bb.common.ManufacturerDescriptionVO

setStatus(String) - Method in class bb.common.MessageVO

setStatus(String) - Method in class bb.common.MiscDocAgent

setStatus(String) - Method in class bb.common.NcrNeedToScrapListResult

setStatus(String) - Method in class bb.common.NcrReportListResult

setStatus(String) - Method in class bb.common.NonConformanceReportVO

setStatus(String) - Method in class bb.common.NonproductivePickingItemResult

setStatus(String) - Method in class bb.common.NonproductivePickingItemVO

setStatus(String) - Method in class bb.common.NonproductivePickingVO

setStatus(String) - Method in class bb.common.OnLoanItemListResult

setStatus(String) - Method in class bb.common.OnLoanItemVO

setStatus(String) - Method in class bb.common.OnLoanListResult

setStatus(String) - Method in class bb.common.OnloanReceiverItemListResult

setStatus(String) - Method in class bb.common.OnloanReceiverItemVO

setStatus(String) - Method in class bb.common.OnloanReceiverListResult

setStatus(String) - Method in class bb.common.OnloanReceiverVO

setStatus(String) - Method in class bb.common.OnloanShipperItemVO

setStatus(String) - Method in class bb.common.OnloanShipperVO

setStatus(String) - Method in class bb.common.OnLoanVO

setStatus(String) - Method in class bb.common.OperatingInstructionsUserStatisticalResult

setStatus(String) - Method in class bb.common.OperatingInstructionsVO

setStatus(String) - Method in class bb.common.OrderApprovalItemsVO

setStatus(String) - Method in class bb.common.OrderApprovalVO

setStatus(String) - Method in class bb.common.PackingBoxItemListResult

setStatus(String) - Method in class bb.common.PackingBoxItemVO

setStatus(String) - Method in class bb.common.PackingBoxSalesOrderItemResult

setStatus(String) - Method in class bb.common.PackingBoxVO

setStatus(String) - Method in class bb.common.PartDescriptionVO

setStatus(String) - Method in class bb.common.PfReceiverItemVO

setStatus(String) - Method in class bb.common.PfReceiverVO

setStatus(String) - Method in class bb.common.PhysicalInventoryStatusVO

setStatus(String) - Method in class bb.common.PoMessageItemVO

setStatus(String) - Method in class bb.common.PoMessageListResult

setStatus(String) - Method in class bb.common.PoMessageVO

setStatus(String) - Method in class bb.common.POReceiverItemListResult

setStatus(String) - Method in class bb.common.POStatisticsResult

setStatus(String) - Method in class bb.common.PreventiveActionRequestItemVO

setStatus(String) - Method in class bb.common.PreventiveActionRequestVO

setStatus(String) - Method in class bb.common.ProformaInvoiceItemListResult

setStatus(String) - Method in class bb.common.ProformaInvoiceItemVO

setStatus(String) - Method in class bb.common.ProformaInvoiceListResult

setStatus(String) - Method in class bb.common.ProformaInvoiceVO

setStatus(String) - Method in class bb.common.PrPackingBoxItemVO

setStatus(String) - Method in class bb.common.PrPackingBoxVO

setStatus(String) - Method in class bb.common.PrReceiverListResult

setStatus(String) - Method in class bb.common.PurchaseOrderCheckListResult

setStatus(String) - Method in class bb.common.PurchaseOrderItemVO

setStatus(String) - Method in class bb.common.PurchaseOrderVO

setStatus(String) - Method in class bb.common.QuoteItemListResult

setStatus(String) - Method in class bb.common.QuoteItemVO

setStatus(String) - Method in class bb.common.QuoteListResult

setStatus(String) - Method in class bb.common.QuoteVO

setStatus(String) - Method in class bb.common.ReceiverInfoVO

setStatus(String) - Method in class bb.common.ReceiverItemVO

setStatus(String) - Method in class bb.common.ReceiverVO

setStatus(String) - Method in class bb.common.ReceivingItemResult

setStatus(String) - Method in class bb.common.RequestForQuoteCheckListResult

setStatus(String) - Method in class bb.common.RequestForQuoteItemListResult

setStatus(String) - Method in class bb.common.RequestForQuoteItemVO

setStatus(String) - Method in class bb.common.RequestForQuoteListResult

setStatus(String) - Method in class bb.common.RequestForQuoteVO

setStatus(String) - Method in class bb.common.RequestForRMAItemVO

setStatus(String) - Method in class bb.common.RequestForRMAVO

setStatus(String) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setStatus(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setStatus(String) - Method in class bb.common.ReturnToVendorCheckListResult

setStatus(String) - Method in class bb.common.ReturnToVendorItemListResult

setStatus(String) - Method in class bb.common.ReturnToVendorItemVO

setStatus(String) - Method in class bb.common.ReturnToVendorListResult

setStatus(String) - Method in class bb.common.ReturnToVendorVO

setStatus(String) - Method in class bb.common.RfqMessageItemVO

setStatus(String) - Method in class bb.common.RfqMessageListResult

setStatus(String) - Method in class bb.common.RfqMessageVO

setStatus(String) - Method in class bb.common.RMAItemListResult

setStatus(String) - Method in class bb.common.RMAListResult

setStatus(String) - Method in class bb.common.RMAReceiverItemListResult

setStatus(String) - Method in class bb.common.RMAReceiverItemVO

setStatus(String) - Method in class bb.common.RMAReceiverListResult

setStatus(String) - Method in class bb.common.RMAReceiverVO

setStatus(String) - Method in class bb.common.RollUpBomStdCostWorkSheetVO

setStatus(String) - Method in class bb.common.RRMAItemListResult

setStatus(String) - Method in class bb.common.RRMAListResult

setStatus(String) - Method in class bb.common.RtvShipperInfoVO

setStatus(String) - Method in class bb.common.RtvShipperItemListResult

setStatus(String) - Method in class bb.common.RtvShipperItemVO

setStatus(String) - Method in class bb.common.RtvShipperListResult

setStatus(String) - Method in class bb.common.RtvShipperVO

setStatus(String) - Method in class bb.common.SalesmanVO

setStatus(String) - Method in class bb.common.SalesOrderCheckListResult

setStatus(String) - Method in class bb.common.SalesOrderItemInfoVO

setStatus(String) - Method in class bb.common.SalesOrderItemListResult

setStatus(String) - Method in class bb.common.SalesOrderItemVO

setStatus(String) - Method in class bb.common.SalesOrderListResult

setStatus(String) - Method in class bb.common.SalesOrderShipDateListResult

setStatus(String) - Method in class bb.common.SalesOrderVO

setStatus(String) - Method in class bb.common.ScrapReportVO

setStatus(String) - Method in class bb.common.SGCustomerServiceRequestVO

setStatus(String) - Method in class bb.common.SGCustRequestForQuoteVO

setStatus(String) - Method in class bb.common.ShipListInfoVO

setStatus(String) - Method in class bb.common.ShipListItemVO

setStatus(String) - Method in class bb.common.ShipListVO

setStatus(String) - Method in class bb.common.ShipperInfoVO

setStatus(String) - Method in class bb.common.ShipperItemListResult

setStatus(String) - Method in class bb.common.ShipperItemVO

setStatus(String) - Method in class bb.common.ShipperListResult

setStatus(String) - Method in class bb.common.ShipperVO

setStatus(String) - Method in class bb.common.ShippingItemResult

setStatus(String) - Method in class bb.common.SoPickListResult

setStatus(String) - Method in class bb.common.SOShipperItemListResult

setStatus(String) - Method in class bb.common.SwapOrderItemVO

setStatus(String) - Method in class bb.common.SwapOrderListResult

setStatus(String) - Method in class bb.common.SwapOrderVO

setStatus(String) - Method in class bb.common.SwapReceiverItemListResult

setStatus(String) - Method in class bb.common.SwapReceiverItemVO

setStatus(String) - Method in class bb.common.SwapReceiverListResult

setStatus(String) - Method in class bb.common.SwapReceiverVO

setStatus(String) - Method in class bb.common.SwapShipperItemListResult

setStatus(String) - Method in class bb.common.SwapShipperItemVO

setStatus(String) - Method in class bb.common.SwapShipperListResult

setStatus(String) - Method in class bb.common.SwapShipperVO

setStatus(String) - Method in class bb.common.TempArApAgingVO

setStatus(String) - Method in class bb.common.TempReceiverWithoutAPInfo

setStatus(String) - Method in class bb.common.ToolCalibrationVO

setStatus(String) - Method in class bb.common.ToolDescriptionVO

setStatus(String) - Method in class bb.common.TransferOrderItemListResult

setStatus(String) - Method in class bb.common.TransferOrderItemVO

setStatus(String) - Method in class bb.common.TransferOrderListResult

setStatus(String) - Method in class bb.common.TransferOrderVO

setStatus(String) - Method in class bb.common.TransferReceiverItemListResult

setStatus(String) - Method in class bb.common.TransferReceiverItemVO

setStatus(String) - Method in class bb.common.TransferReceiverListResult

setStatus(String) - Method in class bb.common.TransferReceiverVO

setStatus(String) - Method in class bb.common.TransferShipperItemListResult

setStatus(String) - Method in class bb.common.TransferShipperItemVO

setStatus(String) - Method in class bb.common.TransferShipperListResult

setStatus(String) - Method in class bb.common.TransferShipperVO

setStatus(String) - Method in class bb.common.VendorContractPriceVO

setStatus(String) - Method in class bb.common.WorkInstructionListResult

setStatus(String) - Method in class bb.common.WorkInstructionRequestForChangeVO

setStatus(String) - Method in class bb.common.WorkInstructionSequenceVO

setStatus(String) - Method in class bb.common.WorkInstructionSummaryItemResult

setStatus(String) - Method in class bb.common.WorkInstructionVO

setStatus(String) - Method in class bb.common.WorkOrderCheckListResult

setStatus(String) - Method in class bb.common.WorkOrderItemListResult

setStatus(String) - Method in class bb.common.WorkOrderItemPartDetail

setStatus(String) - Method in class bb.common.WorkOrderItemPartDetailResult

setStatus(String) - Method in class bb.common.WorkOrderItemReviewCostResult

setStatus(String) - Method in class bb.common.WorkOrderItemTimeDetailResult

setStatus(String) - Method in class bb.common.WorkOrderItemVO

setStatus(String) - Method in class bb.common.WorkOrderListResult

setStatus(String) - Method in class bb.common.WorkOrderQueryInfo

setStatus(String) - Method in class bb.common.WorkOrderTimeCardVO

setStatus(String) - Method in class bb.common.WorkOrderVO

setStatus(String) - Method in class bb.common.WorkOrderWorkInstructionListResult

setStatus(String) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setStatus(String) - Method in class bb.common.WorkOrderWorkInstructionVO

setStdAmount(BigDecimal) - Method in class bb.common.BB2DoubleCost

setStdCost(BigDecimal) - Method in class bb.common.AccountsPayableItemVO

setStdCost(BigDecimal) - Method in class bb.common.AccountsReceivableItemVO

setStdCost(BigDecimal) - Method in class bb.common.ChangeStdCostWorkSheetItemVO

setStdCost(BigDecimal) - Method in class bb.common.DisassembleWorkOrderIssueVO

setStdCost(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemPartDetailItemResult

setStdCost(BigDecimal) - Method in class bb.common.InSipAudittListResult

setStdCost(Map<String, BigDecimal>) - Method in class bb.common.InventoryAmountByMonth

setStdCost(BigDecimal) - Method in class bb.common.InventoryMonthReport

setStdCost(BigDecimal) - Method in class bb.common.InventoryNotUsedInMonthsResult

setStdCost(BigDecimal) - Method in class bb.common.LogInventoryVO

setStdCost(BigDecimal) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setStdCost(BigDecimal) - Method in class bb.common.NonproductivePickingItemIssuedVO

setStdCost(BigDecimal) - Method in class bb.common.NonproductivePickingItemVO

setStdCost(BigDecimal) - Method in class bb.common.OrderApprovalItemsVO

setStdCost(BigDecimal) - Method in class bb.common.PartBasicInfoWithNewListPrice

setStdCost(BigDecimal) - Method in class bb.common.PartInWipForIDListResult

setStdCost(BigDecimal) - Method in class bb.common.PartIssuedVO

setStdCost(BigDecimal) - Method in class bb.common.PartOnhandAndCostResult

setStdCost(BigDecimal) - Method in class bb.common.PartOnhandResult

setStdCost(BigDecimal) - Method in class bb.common.PartReceivedVO

setStdCost(BigDecimal) - Method in class bb.common.PartWithExcessiveInventoryListResult

setStdCost(BigDecimal) - Method in class bb.common.PartWithOnLoanQtyListResult

setStdCost(BigDecimal) - Method in class bb.common.PartWithQAQtyListResult

setStdCost(BigDecimal) - Method in class bb.common.PartWithQtyListResult

setStdCost(BigDecimal) - Method in class bb.common.PartWithSipQtyListResult

setStdCost(BigDecimal) - Method in class bb.common.PartWithSITQtyListResult

setStdCost(BigDecimal) - Method in class bb.common.PartWithSTOQtyListResult

setStdCost(BigDecimal) - Method in class bb.common.PartWithWipQtyListResult

setStdCost(BigDecimal) - Method in class bb.common.QuoteItemVO

setStdCost(BigDecimal) - Method in class bb.common.ReceiverItemVO

setStdCost(BigDecimal) - Method in class bb.common.RollUpBomStdCostWorkSheetItemVO

setStdCost(BigDecimal) - Method in class bb.common.RtvShipperItemVO

setStdCost(BigDecimal) - Method in class bb.common.RunningAccountOrderItemVO

setStdCost(BigDecimal) - Method in class bb.common.SalesOrderItemCostResult

setStdCost(BigDecimal) - Method in class bb.common.SalesOrderItemVO

setStdCost(BigDecimal) - Method in class bb.common.ShipperItemVO

setStdCost(BigDecimal) - Method in class bb.common.SwapOrderItemListResult

setStdCost(BigDecimal) - Method in class bb.common.SwapOrderItemVO

setStdCost(BigDecimal) - Method in class bb.common.SwapReceiverItemListResult

setStdCost(BigDecimal) - Method in class bb.common.SwapReceiverItemVO

setStdCost(BigDecimal) - Method in class bb.common.SwapShipperItemListResult

setStdCost(BigDecimal) - Method in class bb.common.SwapShipperItemVO

setStdCost(BigDecimal) - Method in class bb.common.TransferOrderItemListResult

setStdCost(BigDecimal) - Method in class bb.common.TransferOrderItemVO

setStdCost(BigDecimal) - Method in class bb.common.TransferReceiverItemListResult

setStdCost(BigDecimal) - Method in class bb.common.TransferReceiverItemVO

setStdCost(BigDecimal) - Method in class bb.common.TransferShipperItemListResult

setStdCost(BigDecimal) - Method in class bb.common.TransferShipperItemVO

setStdCost(BigDecimal) - Method in class bb.common.WOItemPartDetailNotIssue

setStdCost(BigDecimal) - Method in class bb.common.WorkOrderItemInWipListResult

setStdCost(BigDecimal) - Method in class bb.common.WorkOrderItemPartDetailInWipVO

setStdCost(BigDecimal) - Method in class bb.common.WorkOrderItemPartDetailItemResult

setStdCost(BigDecimal) - Method in class bb.common.WorkOrderReceiverVO

setStdCostApprovedBy(String) - Method in class bb.common.AccountingConfigurationVO

setStdCostPerUnit(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemVO

setStdCostPerUnit(BigDecimal) - Method in class bb.common.WorkOrderItemVO

setStdHours(BigDecimal) - Method in class bb.common.WorkInstructionSequenceVO

setStdHoursH(int) - Method in class bb.common.WorkInstructionSequenceVO

setStdHoursM(int) - Method in class bb.common.WorkInstructionSequenceVO

setStdHoursS(int) - Method in class bb.common.WorkInstructionSequenceVO

setStdHrs(BigDecimal) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setStdHrsH(int) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setStdHrsM(int) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setStdHrsS(int) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setStdMargin(BigDecimal) - Method in class bb.common.AccountingTotalMoneyResult

setStdMargin(BigDecimal) - Method in class bb.common.DuePATotalByVendorResult

setStdMarginPercent(BigDecimal) - Method in class bb.common.AccountingTotalMoneyResult

setStdMarginPercent(BigDecimal) - Method in class bb.common.DuePATotalByVendorResult

setStdSetup(BigDecimal) - Method in class bb.common.WorkInstructionSequenceVO

setStdSetup(BigDecimal) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setStdSetupH(int) - Method in class bb.common.WorkInstructionSequenceVO

setStdSetupH(int) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setStdSetupM(int) - Method in class bb.common.WorkInstructionSequenceVO

setStdSetupM(int) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setStdSetupS(int) - Method in class bb.common.WorkInstructionSequenceVO

setStdTotal(BigDecimal) - Method in class bb.common.NonproductivePickingItemVO

setStdTotal(BigDecimal) - Method in class bb.common.NonproductivePickingVO

setStdTotalAmount(BigDecimal) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setStdTotalAmount(BigDecimal) - Method in class bb.common.WorkOrderItemInWipListResult

setStepsToReproduce(String) - Method in class bb.common.CustomerServiceIncidentVO

setStockMonth(Integer) - Method in class bb.common.InventoryNotUsedInMonthsforAppResult

setStockOnDemandList(ArrayList) - Method in class bb.common.MrpItemOrderDemandRecordsResult

setStockOnDemandList(ArrayList) - Method in class bb.common.MrpItemResult

setStorageDate(Date) - Method in class bb.common.PurchaseOrderContractResult

setStr(String) - Method in class bb.common.ClientListItem

setStr(String) - Method in class bb.common.QtyDetailResult

setStrikeThrough(boolean) - Method in class bb.common.LabelTemplateItemVO

setSubAccountNumber(String) - Method in class bb.common.AccountsChartMappingPK

setSubcompanyId(String) - Method in class bb.common.AccountsChartMappingPK

setSubDiscountTotal(BigDecimal) - Method in class bb.common.AccountsReceivableInfoVO

setSubDiscountTotal(BigDecimal) - Method in class bb.common.AccountsReceivableVO

setSubDiscountTotal(BigDecimal) - Method in class bb.common.ArCommissionListResult

setSubject(String) - Method in class bb.common.BB2BugNotice

setSubject(String) - Method in class bb.common.BB2Notice

setSubject(String) - Method in class bb.common.MessageAgent

setSubject(String) - Method in class bb.common.MessageVO

setSubmitDate(Date) - Method in class bb.common.PurchaseOrderContractResult

setSubmitDate(Date) - Method in class bb.common.PurchaseOrderVO

setSubNetTotal(BigDecimal) - Method in class bb.common.AccountingTotalMoneyResult

setSubNetTotal(BigDecimal) - Method in class bb.common.AccountsReceivableInfoVO

setSubNetTotal(BigDecimal) - Method in class bb.common.AccountsReceivableVO

setSubNetTotal(BigDecimal) - Method in class bb.common.ArCommissionListResult

setSubNetTotal(BigDecimal) - Method in class bb.common.DuePATotalByVendorResult

setSubNetTotal(BigDecimal) - Method in class bb.common.SalesTaxListResult

setSubTotal(BigDecimal) - Method in class bb.common.AccountsReceivableItemResult

setSubTotal(BigDecimal) - Method in class bb.common.ArCommissionTotalResult

setSubTotal(BigDecimal) - Method in class bb.common.ArSalesCodeTotalListResult

setSubTotal(BigDecimal) - Method in class bb.common.CustomerReturnToVendorVO

setSubTotal(BigDecimal) - Method in class bb.common.DisassembleWorkOrderListResult

setSubTotal(BigDecimal) - Method in class bb.common.DisassembleWorkOrderVO

setSubTotal(BigDecimal) - Method in class bb.common.MakeAccountPayableAgent

setSubTotal(BigDecimal) - Method in class bb.common.MakeBillAndHoldInvoiceAgent

setSubTotal(BigDecimal) - Method in class bb.common.MakeInvoiceAgent

setSubTotal(BigDecimal) - Method in class bb.common.OnloanReceiverVO

setSubTotal(BigDecimal) - Method in class bb.common.PoMessageVO

setSubTotal(BigDecimal) - Method in class bb.common.PurchaseOrderVO

setSubTotal(BigDecimal) - Method in class bb.common.QuoteVO

setSubTotal(BigDecimal) - Method in class bb.common.ReceiverInfoVO

setSubTotal(BigDecimal) - Method in class bb.common.ReceiverVO

setSubTotal(BigDecimal) - Method in class bb.common.RequestForQuoteItemListResult

setSubTotal(BigDecimal) - Method in class bb.common.RequestForQuoteVO

setSubTotal(BigDecimal) - Method in class bb.common.RequestForRMAVO

setSubTotal(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationVO

setSubTotal(BigDecimal) - Method in class bb.common.ReturnToVendorVO

setSubTotal(BigDecimal) - Method in class bb.common.RunningAccountOrderItemVO

setSubTotal(BigDecimal) - Method in class bb.common.RunningAccountOrderVO

setSubTotal(BigDecimal) - Method in class bb.common.SalesOrderVO

setSubTotal(BigDecimal) - Method in class bb.common.SalesTaxListResult

setSubTotal(BigDecimal) - Method in class bb.common.TempReceiverWithoutAPInfo

setSubTotal(BigDecimal) - Method in class bb.common.TotalByDateResult

setSubTotal(BigDecimal) - Method in class bb.common.VendorTotalAmountInPO

setSubTotal(BigDecimal) - Method in class bb.common.WorkOrderIssueStatisticsResult

setSubTotal(BigDecimal) - Method in class bb.common.WorkOrderVO

setSubUnitTotal(BigDecimal) - Method in class bb.common.AccountsReceivableInfoVO

setSubUnitTotal(BigDecimal) - Method in class bb.common.AccountsReceivableVO

setSubUnitTotal(BigDecimal) - Method in class bb.common.ArCommissionListResult

setSuccess(boolean) - Method in class bb.common.LogTaskVO

setSumCost(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

setSumCost(BigDecimal) - Method in class bb.common.WOItemCostControlAgent

setSumCost(BigDecimal) - Method in class bb.common.WorkOrderItemPartDetailResult

setSumCost(BigDecimal) - Method in class bb.common.WorkOrderItemReviewCostResult

setSumHrs(BigDecimal) - Method in class bb.common.WorkCenterRunTimeListResult

setSummary(String) - Method in class bb.common.GeneralLedgerByDateListResult

setSummary(String) - Method in class bb.common.JounalEntryListResult

setSummary(String) - Method in class bb.common.TermsConditionVO

setSumRunTime(BigDecimal) - Method in class bb.common.WorkCenterRunTimeTotalResult

setSumSetup(BigDecimal) - Method in class bb.common.WorkCenterRunTimeListResult

setSumSetupTime(BigDecimal) - Method in class bb.common.WorkCenterRunTimeTotalResult

setSumTime(BigDecimal) - Method in class bb.common.WorkCenterRunTimeListResult

setSumTime(BigDecimal) - Method in class bb.common.WorkCenterRunTimeTotalResult

setSuppressPartOnorderEqualOrLargeOndemand(boolean) - Method in class bb.common.MrpReportAgent

setSwapDate(Date) - Method in class bb.common.SwapOrderItemListResult

setSwapDate(Date) - Method in class bb.common.SwapOrderListResult

setSwapDate(Date) - Method in class bb.common.SwapOrderVO

setSwapOrder(String) - Method in class bb.common.SwapOrderItemPK

setSwapOrderItem(String) - Method in class bb.common.SwapOrderItemPK

setSwapOrderItems(Set<SwapOrderItemVO>) - Method in class bb.common.SwapOrderVO

setSwapOrderNumber(String) - Method in class bb.common.SwapOrderListResult

setSwapOrderNumber(String) - Method in class bb.common.SwapOrderVO

setSwapOrderNumber(String) - Method in class bb.common.SwapReceiverItemListResult

setSwapOrderNumber(String) - Method in class bb.common.SwapReceiverListResult

setSwapOrderNumber(String) - Method in class bb.common.SwapReceiverVO

setSwapOrderNumber(String) - Method in class bb.common.SwapShipperItemListResult

setSwapOrderNumber(String) - Method in class bb.common.SwapShipperListResult

setSwapOrderNumber(String) - Method in class bb.common.SwapShipperVO

setSwapQty(BigDecimal) - Method in class bb.common.SwapOrderItemListResult

setSwapQty(BigDecimal) - Method in class bb.common.SwapOrderItemVO

setSwapQty(BigDecimal) - Method in class bb.common.SwapReceiverItemListResult

setSwapQty(BigDecimal) - Method in class bb.common.SwapReceiverItemVO

setSwapQty(BigDecimal) - Method in class bb.common.SwapShipperItemListResult

setSwapQty(BigDecimal) - Method in class bb.common.SwapShipperItemVO

setSwapQty(BigDecimal) - Method in class bb.common.SwapShipperOnOrderResult

setSwapReceiverItemNumber(String) - Method in class bb.common.SwapReceiverItemListResult

setSwapReceiverItemNumber(String) - Method in class bb.common.SwapReceiverItemPK

setSwapReceiverItems(Set<SwapReceiverItemVO>) - Method in class bb.common.SwapReceiverVO

setSwapReceiverNumber(String) - Method in class bb.common.SwapReceiverItemListResult

setSwapReceiverNumber(String) - Method in class bb.common.SwapReceiverItemPK

setSwapReceiverNumber(String) - Method in class bb.common.SwapReceiverListResult

setSwapReceiverNumber(String) - Method in class bb.common.SwapReceiverVO

setSwapShipperItemNumber(String) - Method in class bb.common.SwapShipperItemListResult

setSwapShipperItemNumber(String) - Method in class bb.common.SwapShipperItemPK

setSwapShipperItemPk(SwapShipperItemPK) - Method in class bb.common.SwapShipperOnOrderResult

setSwapShipperItems(Set<SwapShipperItemVO>) - Method in class bb.common.SwapShipperVO

setSwapShipperNumber(String) - Method in class bb.common.SwapReceiverItemListResult

setSwapShipperNumber(String) - Method in class bb.common.SwapReceiverListResult

setSwapShipperNumber(String) - Method in class bb.common.SwapReceiverVO

setSwapShipperNumber(String) - Method in class bb.common.SwapShipperItemListResult

setSwapShipperNumber(String) - Method in class bb.common.SwapShipperItemPK

setSwapShipperNumber(String) - Method in class bb.common.SwapShipperListResult

setSwapShipperNumber(String) - Method in class bb.common.SwapShipperVO

setSwoDigits(byte) - Method in class bb.common.CompanyVO

setSwoItemNumber(String) - Method in class bb.common.SwapOrderItemListResult

setSwoNumber(String) - Method in class bb.common.SwapOrderItemListResult

setSwoPrefix(String) - Method in class bb.common.CompanyVO

setSwrDigits(byte) - Method in class bb.common.CompanyVO

setSwrPrefix(String) - Method in class bb.common.CompanyVO

setSwsDetails(ArrayList) - Method in class bb.common.BB2PartTotalOnorderDetailResult

setSwsDigits(byte) - Method in class bb.common.CompanyVO

setSwsOnOrderList(ArrayList) - Method in class bb.common.MrpItemResult

setSwsPrefix(String) - Method in class bb.common.CompanyVO

setSymbol(String) - Method in class bb.common.CurrencyVO

setSystem(String) - Method in class bb.common.BB2Login

setSystem(String) - Method in class bb.common.BizBoxServer

setSystem(String) - Method in class bb.common.OperationLogVO

setSystem(boolean) - Method in class bb.common.RoleListResult

setSystem(boolean) - Method in class bb.common.RoleVO

setSystem(String) - Method in class bb.common.SubcompanyLoginAgent

setSystem(String) - Method in class bb.common.SubcompanyVO

setSystemLanguage(String) - Method in class bb.common.CompanyVO

setSystemName(String) - Method in class bb.common.UserRolePermissionListResult

setSystemOndemand(BigDecimal) - Method in class bb.common.AuditOnDemandResult

setSystemOnhand(BigDecimal) - Method in class bb.common.CycleCountListResult

setSystemOnhand(BigDecimal) - Method in class bb.common.PhysicalInventoryListResult

setSystemOnorder(BigDecimal) - Method in class bb.common.AuditOnDemandResult

setSystemQtrUsage(BigDecimal) - Method in class bb.common.AuditOnDemandResult

setSystemTotal(BigDecimal) - Method in class bb.common.PhysicalInventoryListWithAppDataResult

setSystemUserName(String) - Method in class bb.common.BizBoxUserEmployeeResult

setSystemUserName(String) - Method in class bb.common.BizboxUserListResult

setSystemUserName(String) - Method in class bb.common.NoticeUserEmployeeListResult

setSystemWip(BigDecimal) - Method in class bb.common.AuditOnDemandResult

setSystemYrUsage(BigDecimal) - Method in class bb.common.AuditOnDemandResult

setTableName(String) - Method in class bb.common.AppColumnVO

setTableName(String) - Method in class bb.common.DataFilterVO

setTagNumber(String) - Method in class bb.common.AddPhysicalInventoryAgent

setTagNumber(String) - Method in class bb.common.PhysicalInventoryListResult

setTagNumber(String) - Method in class bb.common.PhysicalInventoryVO

setTagNumber(String) - Method in class bb.common.UpdatePhysicalInventoryAgent

setTarget(String) - Method in class bb.common.OperationLogVO

setTaskClass(String) - Method in class bb.common.BB2Task

setTaskId(Long) - Method in class bb.common.LogTaskVO

setTax(BigDecimal) - Method in class bb.common.MakeAccountPayableAgent

setTax(BigDecimal) - Method in class bb.common.MakeBillAndHoldInvoiceAgent

setTax(BigDecimal) - Method in class bb.common.MakeInvoiceAgent

setTax(BigDecimal) - Method in class bb.common.PO2SOExchangeItem

setTax(List) - Method in class bb.common.ProfitLossStatementResult

setTax(BigDecimal) - Method in class bb.common.RunningAccountOrderItemVO

setTax(BigDecimal) - Method in class bb.common.RunningAccountOrderVO

setTax(BigDecimal) - Method in class bb.common.SalesTaxListResult

setTaxExempt(boolean) - Method in class bb.common.PartVO

setTaxExempt(boolean) - Method in class bb.common.ZipcodeTotalsResult

setTaxId(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setTaxId(String) - Method in class bb.common.CustomerVendorAddressVO

setTaxNumber(String) - Method in class bb.common.ZipcodeTotalsResult

setTaxPayerIDCode(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setTaxPayerIDCode(String) - Method in class bb.common.CustomerVendorAddressVO

setTaxr(BigDecimal) - Method in class bb.common.RMAReceiverItemVO

setTaxRate(BigDecimal) - Method in class bb.common.AccountsPayableItemVO

setTaxRate(BigDecimal) - Method in class bb.common.AccountsReceivableItemVO

setTaxRate(BigDecimal) - Method in class bb.common.AddPayableWithoutReceiverAgent

setTaxRate(BigDecimal) - Method in class bb.common.APItemListResult

setTaxRate(BigDecimal) - Method in class bb.common.CustomerReturnToVendorItemVO

setTaxRate(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemVO

setTaxRate(BigDecimal) - Method in class bb.common.InvoiceItemListResult

setTaxRate(BigDecimal) - Method in class bb.common.OnLoanItemVO

setTaxRate(BigDecimal) - Method in class bb.common.OnloanReceiverItemVO

setTaxRate(BigDecimal) - Method in class bb.common.OnloanShipperItemVO

setTaxRate(BigDecimal) - Method in class bb.common.OrderApprovalItemsVO

setTaxRate(BigDecimal) - Method in class bb.common.PfReceiverItemVO

setTaxRate(BigDecimal) - Method in class bb.common.PoMessageItemVO

setTaxRate(BigDecimal) - Method in class bb.common.POReceiverItemListResult

setTaxRate(BigDecimal) - Method in class bb.common.PosZipCodeTaxVO

setTaxRate(BigDecimal) - Method in class bb.common.ProformaInvoiceItemVO

setTaxRate(BigDecimal) - Method in class bb.common.PurchaseOrderItemVO

setTaxRate(BigDecimal) - Method in class bb.common.QuoteItemVO

setTaxRate(BigDecimal) - Method in class bb.common.ReceiverItemVO

setTaxRate(BigDecimal) - Method in class bb.common.RequestForQuoteItemVO

setTaxRate(String) - Method in class bb.common.RequestForQuoteVO

setTaxRate(BigDecimal) - Method in class bb.common.RequestForRMAItemVO

setTaxRate(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setTaxRate(BigDecimal) - Method in class bb.common.ReturnToVendorByDateListResult

setTaxRate(BigDecimal) - Method in class bb.common.ReturnToVendorItemVO

setTaxRate(BigDecimal) - Method in class bb.common.RfqMessageItemVO

setTaxRate(BigDecimal) - Method in class bb.common.RtvShipperItemVO

setTaxRate(BigDecimal) - Method in class bb.common.RunningAccountOrderItemResult

setTaxRate(BigDecimal) - Method in class bb.common.RunningAccountOrderVO

setTaxRate(BigDecimal) - Method in class bb.common.SalesOrderItemInfoVO

setTaxRate(BigDecimal) - Method in class bb.common.SalesOrderItemVO

setTaxRate(BigDecimal) - Method in class bb.common.ShipperItemListResult

setTaxRate(BigDecimal) - Method in class bb.common.ShipperItemVO

setTaxRate(BigDecimal) - Method in class bb.common.WorkOrderItemVO

setTaxRate(BigDecimal) - Method in class bb.common.ZipCodeTaxVO

setTaxRate(BigDecimal) - Method in class bb.common.ZipcodeTotalsResult

setTaxTotal(BigDecimal) - Method in class bb.common.AccountsReceivableInfoVO

setTaxTotal(BigDecimal) - Method in class bb.common.AccountsReceivableVO

setTaxTotal(BigDecimal) - Method in class bb.common.ArCommissionListResult

setTaxTotal(BigDecimal) - Method in class bb.common.ArCommissionTotalResult

setTaxTotal(BigDecimal) - Method in class bb.common.ArSalesCodeTotalListResult

setTaxTotal(BigDecimal) - Method in class bb.common.RunningAccountOrderItemVO

setTaxTotal(BigDecimal) - Method in class bb.common.RunningAccountOrderVO

setTaxTotal(String) - Method in class bb.common.RunTaxPaymentResult

setTaxType(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setTaxType(String) - Method in class bb.common.CustomerVendorAddressVO

setTaxType(String) - Method in class bb.common.RunningAccountOrderVO

setTaxType(String) - Method in class bb.common.ZipCodeTaxVO

setTaxType(String) - Method in class bb.common.ZipcodeTotalsResult

setTDate(Date) - Method in class bb.common.MrpReportAgent

setTdate(String) - Method in class bb.common.TaskVO

setTDate(Date) - Method in class bb.common.WCLoadAgent

setTday(String) - Method in class bb.common.TaskVO

setTechnolgyStandard(String) - Method in class bb.common.InspectionConformanceReportItemCheckVO

setTechnolgyStandard(String) - Method in class bb.common.InspectionTypeItemVO

setTechnolgyStandard(String) - Method in class bb.common.PartInspectionVO

setTechRev(String) - Method in class bb.common.SGDocPartVO

setTechSheet(String) - Method in class bb.common.SGDocPartVO

setTechSheet(boolean) - Method in class bb.common.SGPartDocFlagResult

setTemplate(byte[]) - Method in class bb.common.CommonPrintTemplateVO

setTemplateName(String) - Method in class bb.common.CommonPrintTemplateVO

setTemplateName(String) - Method in class bb.common.PrintTemplateVO

setTempOnhand(BigDecimal) - Method in class bb.common.RunningAccountOrderItemVO

setTempWorker(boolean) - Method in class bb.common.EmployeeCardVO

setTempWorkerDigits(byte) - Method in class bb.common.CompanyVO

setTempWorkerPrefix(String) - Method in class bb.common.CompanyVO

setTerm(Integer) - Method in class bb.common.TermAgent

setTerm(Integer) - Method in class bb.common.TermVO

setTermAlias(String) - Method in class bb.common.TermAgent

setTermAlias(String) - Method in class bb.common.TermVO

setTerminatedDate(Date) - Method in class bb.common.EmployeeCardVO

setTerms(String) - Method in class bb.common.AccountsPayableInfoVO

setTerms(String) - Method in class bb.common.AccountsPayableVO

setTerms(String) - Method in class bb.common.AccountsReceivableInfoVO

setTerms(String) - Method in class bb.common.AccountsReceivableVO

setTerms(String) - Method in class bb.common.APItemListResult

setTerms(String) - Method in class bb.common.CustomerReturnToVendorVO

setTerms(String) - Method in class bb.common.CustomerStatementTotalResult

setTerms(String) - Method in class bb.common.DisassembleWorkOrderVO

setTerms(String) - Method in class bb.common.MakeAccountPayableAgent

setTerms(String) - Method in class bb.common.MakeBillAndHoldInvoiceAgent

setTerms(String) - Method in class bb.common.MakeCreditMemoAgent

setTerms(String) - Method in class bb.common.MakeDebitMemoAgent

setTerms(String) - Method in class bb.common.MakeInvoiceAgent

setTerms(String) - Method in class bb.common.OnloanReceiverVO

setTerms(String) - Method in class bb.common.OnloanShipperVO

setTerms(String) - Method in class bb.common.OnLoanVO

setTerms(String) - Method in class bb.common.PfReceiverVO

setTerms(String) - Method in class bb.common.PO2SOExchange

setTerms(String) - Method in class bb.common.ProformaInvoiceVO

setTerms(String) - Method in class bb.common.PurchaseOrderVO

setTerms(String) - Method in class bb.common.QuoteVO

setTerms(String) - Method in class bb.common.ReceiverInfoVO

setTerms(String) - Method in class bb.common.ReceiverVO

setTerms(String) - Method in class bb.common.RequestForQuoteVO

setTerms(String) - Method in class bb.common.RequestForRMAVO

setTerms(String) - Method in class bb.common.ReturnMaterialAuthorizationVO

setTerms(String) - Method in class bb.common.ReturnToVendorVO

setTerms(String) - Method in class bb.common.RMAReceiverVO

setTerms(String) - Method in class bb.common.RtvShipperInfoVO

setTerms(String) - Method in class bb.common.RtvShipperVO

setTerms(String) - Method in class bb.common.SalesOrderVO

setTerms(String) - Method in class bb.common.ShipperInfoVO

setTerms(String) - Method in class bb.common.ShipperVO

setTerms(String) - Method in class bb.common.TransferOrderListResult

setTerms(String) - Method in class bb.common.TransferOrderVO

setTerms(String) - Method in class bb.common.TransferReceiverListResult

setTerms(String) - Method in class bb.common.TransferReceiverVO

setTerms(String) - Method in class bb.common.TransferShipperListResult

setTerms(String) - Method in class bb.common.TransferShipperVO

setTerms(String) - Method in class bb.common.WorkOrderVO

setTermsDiscount(BigDecimal) - Method in class bb.common.AccountsPayableInfoVO

setTermsDiscount(BigDecimal) - Method in class bb.common.AccountsPayableVO

setTermsDiscountDay(String) - Method in class bb.common.AccountsPayableInfoVO

setTermsDiscountDay(String) - Method in class bb.common.AccountsPayableVO

setTermsDiscountPercent(String) - Method in class bb.common.AccountsPayableInfoVO

setTermsDiscountPercent(String) - Method in class bb.common.AccountsPayableVO

setTermValue(String) - Method in class bb.common.TermAgent

setTermValue(String) - Method in class bb.common.TermVO

setTerritory(String) - Method in class bb.common.CustomerVendorAddressVO

setTerritory(String) - Method in class bb.common.SalesOrderItemListResult

setTestingMailto(String) - Method in class bb.common.SGCompanyVO

setTestReport(String) - Method in class bb.common.POSurveyReportItemVO

setThirdParty(String) - Method in class bb.common.CorrectiveActionRequestVO

setThirdParty(String) - Method in class bb.common.PreventiveActionRequestVO

setThisMonth(int) - Method in class bb.common.SalesInfoCenter.DueSoCount

setThisMonth(double) - Method in class bb.common.SalesInfoCenter.DueSoSum

setThisMonth(float) - Method in class bb.common.SalesInfoCenter.GrossMargin

setThisMonth(double) - Method in class bb.common.SalesInfoCenter.InvoicedSum

setThisMonth(double) - Method in class bb.common.SalesInfoCenter.OpenSoSum

setThisMonth(int) - Method in class bb.common.SalesInfoCenter.SoCount

setThisMonth(int) - Method in class bb.common.SalesInfoCenter.SoCountWithPartsOnhold

setThisMonth(int) - Method in class bb.common.SalesInfoCenter.SoItemCount

setThisMonth(double) - Method in class bb.common.SalesInfoCenter.SoTotalSum

setThrs(String) - Method in class bb.common.TaskVO

setTimeCards(List<WorkOrderTimeCardVO>) - Method in class bb.common.EmployeeTimeCardResult

setTimeOff(Date) - Method in class bb.common.WorkOrderItemTimeDetailVO

setTimeOff(Date) - Method in class bb.common.WorkOrderTimeCardVO

setTimeOn(Date) - Method in class bb.common.WorkOrderItemTimeDetailVO

setTimeOn(Date) - Method in class bb.common.WorkOrderTimeCardVO

setTimePeriod(Set) - Method in class bb.common.WCLoadByDateResult

setTimePeriod(Set) - Method in class bb.common.WCLoadOnDateResult

setTimePeriod(Set) - Method in class bb.common.WorkCalendarVO

setTimestamp(Timestamp) - Method in class bb.common.DocumentLogVO

setTimezero(String) - Method in class bb.common.SGCompanyVO

setTimeZone(String) - Method in class bb.common.CompanyVO

setTitemNumber(String) - Method in class bb.common.BB2RefdocPK

setTitemNumber(String) - Method in class bb.common.PosRefdocVO

setTitemNumber(String) - Method in class bb.common.RefdocVO

setTitle(String) - Method in class bb.common.CustomEmployeeTrainVO

setTitle(String) - Method in class bb.common.CustomerVendorContactVO

setTitle(String) - Method in class bb.common.EmployeeTrainingVO

setTitle(String) - Method in class bb.common.ManufacturerContactVO

setTmin(String) - Method in class bb.common.TaskVO

setTmonth(String) - Method in class bb.common.TaskVO

setTMonthYear(String) - Method in class bb.common.GLCheckRegisterResult

setTn1(String) - Method in class bb.common.AccountPayableCheckVO

setTn1(String) - Method in class bb.common.AccountReceivablePaymentVO

setTn2(String) - Method in class bb.common.AccountPayableCheckVO

setTn2(String) - Method in class bb.common.AccountReceivablePaymentVO

setTnDate(Date) - Method in class bb.common.CustomAssetVO

setToAddressId(String) - Method in class bb.common.BB2PartInSTOItemResult

setToAddressId(String) - Method in class bb.common.TransferOrderListResult

setToAddressId(String) - Method in class bb.common.TransferOrderVO

setToAddressId(String) - Method in class bb.common.TransferReceiverItemListResult

setToAddressId(String) - Method in class bb.common.TransferReceiverListResult

setToAddressId(String) - Method in class bb.common.TransferReceiverVO

setToAddressId(String) - Method in class bb.common.TransferShipperListResult

setToAddressId(String) - Method in class bb.common.TransferShipperVO

setToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.TransferOrderVO

setToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.TransferReceiverVO

setToAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.TransferShipperVO

setToAddressName(String) - Method in class bb.common.TransferShipperListResult

setToBeAsm(BigDecimal) - Method in class bb.common.WorkOrderItemListResult

setToBePaid(BigDecimal) - Method in class bb.common.AccountPayableCheckRunItemVO

setToCompanyTime(Date) - Method in class bb.common.CustomEmployeeVO

setToDate(Date) - Method in class bb.common.ApCheckRunItemAgent

setToDate(Date) - Method in class bb.common.ApPrepaymentCheckRunItemAgent

setToDate(Date) - Method in class bb.common.ArPaymentRunItemAgent

setToDate(Date) - Method in class bb.common.ArPrepaymentRunItemAgent

setToDate(Date) - Method in class bb.common.ARPrepaymentWireTransferAgent

setToDate(Date) - Method in class bb.common.EmployeeEducationVO

setToDate(Date) - Method in class bb.common.EmployeeWorkExperienceVO

setToDate(Date) - Method in class bb.common.POAndWOStatusResult

setToDate(Date) - Method in class bb.common.PrepaymentWireTransferAgent

setToDate(Date) - Method in class bb.common.WireTransferAgent

setToDate(Date) - Method in class bb.common.WorkCenterLoadAgent

setToDate(Date) - Method in class bb.common.WorkCenterRunTimeAgent

setToDate(Date) - Method in class bb.common.WorkCenterRunTimeTotalResult

setToDate(Date) - Method in class bb.common.WorkOrderItemCanAssyAgent

setToDefaultWorkInstruction(WorkInstructionPK) - Method in interface bb.common.box.ManufacturingBox

setToItemNumber(String) - Method in class bb.common.ReceivedToOrderItem

setToItemNumber(String) - Method in class bb.common.ReceiverItemDetailAgent

setToLocation(String) - Method in class bb.common.TransferOrderItemListResult

setToLocation(String) - Method in class bb.common.TransferOrderItemVO

setTool(ToolVO) - Method in class bb.common.ToolListInfoVO

setToolBasicInfo(ToolBasicInfo) - Method in class bb.common.PurchaseWorkSheetItemWithRelatedInfoResult

setToolBasicInfo(ToolBasicInfo) - Method in class bb.common.ToolWhereUsedResult

setToolBasicInfo(ToolBasicInfo) - Method in class bb.common.WorkOrderWorkSheetItemWithRelatedInfoResult

setToolDescription(String) - Method in class bb.common.ToolCalibrateListResult

setToolInfo(ToolBasicInfo) - Method in class bb.common.InventoryAdjustmentDetailResult

setToolInventoryInfo(ToolInventoryVO) - Method in class bb.common.InventoryAdjustmentDetailResult

setToolInventoryVO(ToolInventoryVO) - Method in class bb.common.PurchaseWorkSheetItemWithRelatedInfoResult

setToolInventoryVO(ToolInventoryVO) - Method in class bb.common.WorkOrderWorkSheetItemWithRelatedInfoResult

setToolListInfo(ToolListDetailCostWithToolInfoResult) - Method in class bb.common.ToolListDetailCostResult

setToolListInfo(ToolListVO) - Method in class bb.common.ToolListItemVO

setToolListItems(Set) - Method in class bb.common.ToolListDetailCostResult

setToolNumber(String) - Method in class bb.common.WorkInstructionSequenceVO

setToolNumber(String) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setToolOnhandVo(ToolOnhandVO) - Method in class bb.common.ToolOnhandWithAverageCostResult

setToolUnit(String) - Method in class bb.common.CompanyVO

setToolWhereUsedItemResult(List) - Method in class bb.common.ToolWhereUsedResult

setToOrderNumber(String) - Method in class bb.common.ReceivedToOrderItem

setToOrderNumber(String) - Method in class bb.common.ReceiverItemDetailAgent

setTopOrder(String) - Method in class bb.common.WoItemPickListResult

setToPositionTime(Date) - Method in class bb.common.CustomEmployeeVO

setToQty(BigDecimal) - Method in class bb.common.VendorQtyPriceVO

setTorderNumber(String) - Method in class bb.common.BB2RefdocPK

setTorderNumber(String) - Method in class bb.common.PosRefdocVO

setTorderNumber(String) - Method in class bb.common.RefdocVO

setTotal(BigDecimal) - Method in class bb.common.AccountInfoCenterItemResult

setTotal(BigDecimal) - Method in class bb.common.BudgetListResult

setTotal(BigDecimal) - Method in class bb.common.ExpenseVO

setTotal(BigDecimal) - Method in class bb.common.MoneyInDrawResult

setTotal(BigDecimal) - Method in class bb.common.OnhandQualityResult

setTotal(BigDecimal) - Method in class bb.common.PrepayAgent

setTotal(BigDecimal) - Method in class bb.common.SalesOrderItemCustomerTotalResult

setTotal(BigDecimal) - Method in class bb.common.WCLoadDetailResult

setTotal(BigDecimal) - Method in class bb.common.WorkOrderItemTimeDetailResult

setTotalAdjustMoney(BigDecimal) - Method in class bb.common.InventoryAuditReportResult

setTotalAdjustQty(BigDecimal) - Method in class bb.common.InventoryAuditReportResult

setTotalAmount(BigDecimal) - Method in class bb.common.AmountsStatementResult

setTotalAmount(BigDecimal) - Method in class bb.common.GeneralLedgerPrintResult

setTotalAmount(BigDecimal) - Method in class bb.common.IncomeByMonthChartResult

setTotalApply(BigDecimal) - Method in class bb.common.ARPrepayAllStatementsListResult

setTotalAsmStandardCost(BigDecimal) - Method in class bb.common.WorkOrderItemListResult

setTotalAsmWeight(double) - Method in class bb.common.WorkOrderItemListResult

setTotalAssets(BigDecimal) - Method in class bb.common.AccountingBalanceSheetResult

setTotalAssets(BalanceSheetSideBySideItemResult) - Method in class bb.common.BalanceSheetSideBySideResult

setTotalAssets(BigDecimal) - Method in class bb.common.ClosingStatementResult

setTotalaverageCost(BigDecimal) - Method in class bb.common.BillSalesOfCostResult

setTotalaverageCost(BigDecimal) - Method in class bb.common.BillSalesXResult

setTotalAvgCost(BigDecimal) - Method in class bb.common.BillItemSalesCostResult

setTotalAvgCost(BigDecimal) - Method in class bb.common.InventoryNotUsedTotal

setTotalAvgCost(BigDecimal) - Method in class bb.common.PartOnhandResult

setTotalAvgCost(BigDecimal) - Method in class bb.common.PartWithOnLoanQtyListResult

setTotalAvgCost(BigDecimal) - Method in class bb.common.PartWithQtyListResult

setTotalAvgCost(Money) - Method in class bb.common.PoReceiverByDateSummaryResult

setTotalBalance(BigDecimal) - Method in class bb.common.CustomerStatementTotalResult

setTotalByAvgCost(BigDecimal) - Method in class bb.common.HistoricalInventoryTotalResult

setTotalByStdCost(BigDecimal) - Method in class bb.common.HistoricalInventoryTotalResult

setTotalCashAvailiable(TreeMap) - Method in class bb.common.TwelveMonthCashFlowReportResult

setTotalCheck(BigDecimal) - Method in class bb.common.PaymentRunItemTotalResult

setTotalCommission(BigDecimal) - Method in class bb.common.ArCommissionListResult

setTotalCost(BigDecimal) - Method in class bb.common.AccountsReceivableInfoVO

setTotalCost(BigDecimal) - Method in class bb.common.AccountsReceivableVO

setTotalCost(BigDecimal) - Method in class bb.common.InventoryPartInOutDetailListResult

setTotalCost(BigDecimal) - Method in class bb.common.QuoteVO

setTotalCost(BigDecimal) - Method in class bb.common.SalesMarginListResult

setTotalCost(BigDecimal) - Method in class bb.common.SalesOrderVO

setTotalCost(BigDecimal) - Method in class bb.common.ScrapReportVO

setTotalCost(BigDecimal) - Method in class bb.common.TransferOrderListResult

setTotalCost(BigDecimal) - Method in class bb.common.TransferOrderVO

setTotalCost(BigDecimal) - Method in class bb.common.TransferReceiverVO

setTotalCost(BigDecimal) - Method in class bb.common.TransferShipperListResult

setTotalCost(BigDecimal) - Method in class bb.common.TransferShipperVO

setTotalCost(BigDecimal) - Method in class bb.common.WorkOrderItemTimeDetailResult

setTotalCostOfSales(ProfitLossStatementItemResult) - Method in class bb.common.ProfitLossStatementResult

setTotalCount(Integer) - Method in class bb.common.InfoByMonthResult

setTotalCountOnhandQty(BigDecimal) - Method in class bb.common.InventoryAuditReportResult

setTotalCredit(BigDecimal) - Method in class bb.common.GLApprovalListResult

setTotalCredit(BigDecimal) - Method in class bb.common.GLByDateTotalResult

setTotalCurrentAssets(BigDecimal) - Method in class bb.common.AccountingBalanceSheetResult

setTotalCurrentAssets(BalanceSheetSideBySideItemResult) - Method in class bb.common.BalanceSheetSideBySideResult

setTotalCurrentAssets(BigDecimal) - Method in class bb.common.ClosingStatementResult

setTotalCurrentLiabilities(BigDecimal) - Method in class bb.common.AccountingBalanceSheetResult

setTotalCurrentLiabilities(BigDecimal) - Method in class bb.common.ClosingStatementResult

setTotalCurrentLiability(BalanceSheetSideBySideItemResult) - Method in class bb.common.BalanceSheetSideBySideResult

setTotalDebit(BigDecimal) - Method in class bb.common.GLApprovalListResult

setTotalDebit(BigDecimal) - Method in class bb.common.GLByDateTotalResult

setTotalDepreciation(BigDecimal) - Method in class bb.common.ClosingStatementResult

setTotalDiscount(BigDecimal) - Method in class bb.common.CustomerReturnToVendorVO

setTotalDiscount(BigDecimal) - Method in class bb.common.OnloanReceiverVO

setTotalDiscount(BigDecimal) - Method in class bb.common.PoMessageVO

setTotalDiscount(BigDecimal) - Method in class bb.common.PurchaseOrderVO

setTotalDiscount(BigDecimal) - Method in class bb.common.QuoteVO

setTotalDiscount(BigDecimal) - Method in class bb.common.ReceiverInfoVO

setTotalDiscount(BigDecimal) - Method in class bb.common.ReceiverVO

setTotalDiscount(BigDecimal) - Method in class bb.common.RequestForRMAVO

setTotalDiscount(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationVO

setTotalDiscount(BigDecimal) - Method in class bb.common.SalesOrderVO

setTotalDiscount(BigDecimal) - Method in class bb.common.TotalByDateResult

setTotalDiscount(BigDecimal) - Method in class bb.common.VendorTotalAmountInPO

setTotalDue(BigDecimal) - Method in class bb.common.AccountAgingTotalResult

setTotalDue(BigDecimal) - Method in class bb.common.ARAllStatementsListResult

setTotalDue(BigDecimal) - Method in class bb.common.ARPrepayAllStatementsListResult

setTotalDue(BigDecimal) - Method in class bb.common.CheckRunItemTotalResult

setTotalDue(BigDecimal) - Method in class bb.common.CustomerPrepayStatementListResult

setTotalDue(BigDecimal) - Method in class bb.common.CustomerStatementListResult

setTotalDue(BigDecimal) - Method in class bb.common.PaymentRunItemTotalResult

setTotalDue(BigDecimal) - Method in class bb.common.TotalAmountInPOByRefDoc

setTotalDue(BigDecimal) - Method in class bb.common.VendorPrepayStatementListResult

setTotalDue(BigDecimal) - Method in class bb.common.VendorStatementListResult

setTotalE(BigDecimal) - Method in class bb.common.APAuditListResult

setTotalEquity(BigDecimal) - Method in class bb.common.ClosingStatementResult

setTotalExemptions(BigDecimal) - Method in class bb.common.ZipcodeTotalsResult

setTotalFixedAssets(BalanceSheetSideBySideItemResult) - Method in class bb.common.BalanceSheetSideBySideResult

setTotalFixedAssets(BigDecimal) - Method in class bb.common.ClosingStatementResult

setTotalFreight(BigDecimal) - Method in class bb.common.CustomerReturnToVendorVO

setTotalFreight(BigDecimal) - Method in class bb.common.DisassembleWorkOrderVO

setTotalFreight(BigDecimal) - Method in class bb.common.OnloanReceiverVO

setTotalFreight(BigDecimal) - Method in class bb.common.PoMessageVO

setTotalFreight(BigDecimal) - Method in class bb.common.POStatisticsResult

setTotalFreight(BigDecimal) - Method in class bb.common.PurchaseOrderVO

setTotalFreight(BigDecimal) - Method in class bb.common.QuoteVO

setTotalFreight(BigDecimal) - Method in class bb.common.ReceiverInfoVO

setTotalFreight(BigDecimal) - Method in class bb.common.ReceiverVO

setTotalFreight(BigDecimal) - Method in class bb.common.RequestForQuoteVO

setTotalFreight(BigDecimal) - Method in class bb.common.RequestForRMAVO

setTotalFreight(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationVO

setTotalFreight(BigDecimal) - Method in class bb.common.ReturnToVendorVO

setTotalFreight(BigDecimal) - Method in class bb.common.SalesOrderVO

setTotalFreight(BigDecimal) - Method in class bb.common.TotalByDateResult

setTotalFreight(BigDecimal) - Method in class bb.common.VendorTotalAmountInPO

setTotalFreight(BigDecimal) - Method in class bb.common.WorkOrderVO

setTotalGeneralAdmin(ProfitLossStatementItemResult) - Method in class bb.common.ProfitLossStatementResult

setTotalGeneralLedgerBalance(TreeMap) - Method in class bb.common.ClosingStatementResult

setTotalGL(int) - Method in class bb.common.ApprovedGLResult

setTotalHrs(BigDecimal) - Method in class bb.common.WorkCenterLoadListResult

setTotalI(BigDecimal) - Method in class bb.common.APAuditListResult

setTotalIncomeFromOperating(ProfitLossStatementItemResult) - Method in class bb.common.ProfitLossStatementResult

setTotalInQA(BigDecimal) - Method in class bb.common.BB2PartTotalInQADetailResult

setTotalInQaAvgCost(BigDecimal) - Method in class bb.common.InventoryTotalCostResult

setTotalInQaByAvgCost(BigDecimal) - Method in class bb.common.InventoryTotalResult

setTotalInQaByCost(BigDecimal) - Method in class bb.common.QualityInfoCenterResult

setTotalInQaByStdCost(BigDecimal) - Method in class bb.common.InventoryTotalResult

setTotalInQaListPrice(BigDecimal) - Method in class bb.common.InventoryTotalCostResult

setTotalInQaStdCost(BigDecimal) - Method in class bb.common.InventoryTotalCostResult

setTotalInShippingNotArByAvgCost(BigDecimal) - Method in class bb.common.InventoryTotalResult

setTotalInShippingNotArByStdCost(BigDecimal) - Method in class bb.common.InventoryTotalResult

setTotalInSip(BigDecimal) - Method in class bb.common.BB2PartTotalInSipDetailResult

setTotalInSipAvgCost(BigDecimal) - Method in class bb.common.InventoryTotalCostResult

setTotalInSipListPrice(BigDecimal) - Method in class bb.common.InventoryTotalCostResult

setTotalInSipStdCost(BigDecimal) - Method in class bb.common.InventoryTotalCostResult

setTotalInSit(BigDecimal) - Method in class bb.common.BB2PartTotalInSitDetailResult

setTotalInSTO(BigDecimal) - Method in class bb.common.BB2PartTotalInSTODetailResult

setTotalInSTOAvgCost(BigDecimal) - Method in class bb.common.InventoryTotalCostResult

setTotalInSTOListPrice(BigDecimal) - Method in class bb.common.InventoryTotalCostResult

setTotalInSTOStdCost(BigDecimal) - Method in class bb.common.InventoryTotalCostResult

setTotalInventory(BigDecimal) - Method in class bb.common.InventoryListResult

setTotalInventoryAvgCost(BigDecimal) - Method in class bb.common.InventoryTotalCostResult

setTotalInventoryListPrice(BigDecimal) - Method in class bb.common.InventoryTotalCostResult

setTotalInventoryStdCost(BigDecimal) - Method in class bb.common.InventoryTotalCostResult

setTotalInWareHouseByAvgCost(BigDecimal) - Method in class bb.common.InventoryTotalResult

setTotalInWareHouseByStdCost(BigDecimal) - Method in class bb.common.InventoryTotalResult

setTotalInWip(BigDecimal) - Method in class bb.common.BB2PartTotalInWipDetailResult

setTotalInWipAvgCost(BigDecimal) - Method in class bb.common.InventoryTotalCostResult

setTotalInWipByAvgCost(BigDecimal) - Method in class bb.common.InventoryTotalResult

setTotalInWipByStdCost(BigDecimal) - Method in class bb.common.InventoryTotalResult

setTotalInWipListPrice(BigDecimal) - Method in class bb.common.InventoryTotalCostResult

setTotalInWipStdCost(BigDecimal) - Method in class bb.common.InventoryTotalCostResult

setTotalIssue(BigDecimal) - Method in class bb.common.WorkOrderIssueStatisticsResult

setTotalIssued(BigDecimal) - Method in class bb.common.InventoryReportListResult

setTotalIssued(BigDecimal) - Method in class bb.common.PartIssuedListResult

setTotalIssued(BigDecimal) - Method in class bb.common.WOIssuedByMonthChartResult

setTotalIssuedCost(BigDecimal) - Method in class bb.common.BB2PartByDateResult

setTotalIssuedCost(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemListResult

setTotalIssuedCost(BigDecimal) - Method in class bb.common.WOIssuedByMonthChartResult

setTotalIssuedCost(BigDecimal) - Method in class bb.common.WorkOrderIssuedOrderListResult

setTotalIssuedCost(BigDecimal) - Method in class bb.common.WorkOrderItemListResult

setTotalIssuedMoney(BigDecimal) - Method in class bb.common.InventoryReportListResult

setTotalIssuedQty(BigDecimal) - Method in class bb.common.BB2PartByDateResult

setTotalItemCount(BigDecimal) - Method in class bb.common.OntimeDeliveryRateListResult

setTotalItemCount(BigDecimal) - Method in class bb.common.OntimeDeliveryRateResult

setTotalItems(int) - Method in class bb.common.CurrentBalanceResult

setTotalItems(Long) - Method in class bb.common.PartDueAddressListResult

setTotalLabor(BigDecimal) - Method in class bb.common.WorkOrderItemTimeDetailResult

setTotalLiabilities(BigDecimal) - Method in class bb.common.AccountingBalanceSheetResult

setTotalLiability(BalanceSheetSideBySideItemResult) - Method in class bb.common.BalanceSheetSideBySideResult

setTotalLiabilityEquity(BalanceSheetSideBySideItemResult) - Method in class bb.common.BalanceSheetSideBySideResult

setTotalLiabilityesEquity(BigDecimal) - Method in class bb.common.AccountingBalanceSheetResult

setTotalLiabilityesEquity(BigDecimal) - Method in class bb.common.ClosingStatementResult

setTotallistCost(BigDecimal) - Method in class bb.common.BillSalesOfCostResult

setTotallistCost(BigDecimal) - Method in class bb.common.BillSalesXResult

setTotalListPrice(BigDecimal) - Method in class bb.common.BillItemSalesCostResult

setTotalLongTermLiabilities(BigDecimal) - Method in class bb.common.ClosingStatementResult

setTotalMargin(BigDecimal) - Method in class bb.common.SalesMarginListResult

setTotalMfgTime(BigDecimal) - Method in class bb.common.WorkOrderItemLaborCostListResult

setTotalMoney(BigDecimal) - Method in class bb.common.InfoByMonthResult

setTotalMoney(BigDecimal) - Method in class bb.common.SalesOrderItemCostResult

setTotalNet(BigDecimal) - Method in class bb.common.AccountingTotalMoneyResult

setTotalNet(BigDecimal) - Method in class bb.common.DuePATotalByVendorResult

setTotalNet(BigDecimal) - Method in class bb.common.SalesMarginListResult

setTotalNewCost(BigDecimal) - Method in class bb.common.InventoryReportListResult

setTotalNewOnhand(BigDecimal) - Method in class bb.common.InventoryReportListResult

setTotalNewOnhand(BigDecimal) - Method in class bb.common.PhysicalInventoryListResult

setTotalNewOnhand(BigDecimal) - Method in class bb.common.PhysicalInventoryVO

setTotalNonIssueCost(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemListResult

setTotalNonIssueCost(BigDecimal) - Method in class bb.common.WorkOrderItemListResult

setTotalNotCompletedSeqBefore(BigDecimal) - Method in class bb.common.WCLoadDetailResult

setTotalO(BigDecimal) - Method in class bb.common.ARAuditListResult

setTotalOldCost(BigDecimal) - Method in class bb.common.InventoryReportListResult

setTotalOldOnhand(BigDecimal) - Method in class bb.common.InventoryReportListResult

setTotalOnconsignmentByAvgCost(BigDecimal) - Method in class bb.common.InventoryTotalResult

setTotalOnconsignmentByStdCost(BigDecimal) - Method in class bb.common.InventoryTotalResult

setTotalOndemand(BigDecimal) - Method in class bb.common.BB2PartTotalOndemandDetailResult

setTotalOnDemand(BigDecimal) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setTotalOndemand(BigDecimal) - Method in class bb.common.PartInMrpListResult

setTotalOnDemand(BigDecimal) - Method in class bb.common.ReceivingItemResult

setTotalOndemand(BigDecimal) - Method in class bb.common.ShipListItemVOResult

setTotalOnhand(BigDecimal) - Method in class bb.common.BB2PartTotalOnhandDetailResult

setTotalOnhand(BigDecimal) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setTotalOnhand(BigDecimal) - Method in class bb.common.InventoryAdjustmentDetailResult

setTotalOnhand(BigDecimal) - Method in class bb.common.IssuingItemResult

setTotalOnhand(BigDecimal) - Method in class bb.common.PartOnhandResult

setTotalOnhand(BigDecimal) - Method in class bb.common.PartWithOnhandDetailInfoResult

setTotalOnhand(BigDecimal) - Method in class bb.common.ReceivingItemResult

setTotalOnhand(BigDecimal) - Method in class bb.common.ShipListItemVOResult

setTotalOnhandAvgCost(BigDecimal) - Method in class bb.common.InventoryTotalCostResult

setTotalOnhandListPrice(BigDecimal) - Method in class bb.common.InventoryTotalCostResult

setTotalOnhandStdCost(BigDecimal) - Method in class bb.common.InventoryTotalCostResult

setTotalOnloan(BigDecimal) - Method in class bb.common.BB2PartTotalOnloanDetailResult

setTotalOnLoanAvgCost(BigDecimal) - Method in class bb.common.InventoryTotalCostResult

setTotalOnloanByAvgCost(BigDecimal) - Method in class bb.common.InventoryTotalResult

setTotalOnloanByStdCost(BigDecimal) - Method in class bb.common.InventoryTotalResult

setTotalOnLoanListPrice(BigDecimal) - Method in class bb.common.InventoryTotalCostResult

setTotalOnLoanStdCost(BigDecimal) - Method in class bb.common.InventoryTotalCostResult

setTotalOnorder(BigDecimal) - Method in class bb.common.BB2PartTotalOnorderDetailResult

setTotalOpen(BigDecimal) - Method in class bb.common.TotalByDateResult

setTotalOpen(BigDecimal) - Method in class bb.common.VendorTotalAmountInPO

setTotalOperatingExpense(ProfitLossStatementItemResult) - Method in class bb.common.ProfitLossStatementResult

setTotalOtherAssets(BalanceSheetSideBySideItemResult) - Method in class bb.common.BalanceSheetSideBySideResult

setTotalOtherAssets(BigDecimal) - Method in class bb.common.ClosingStatementResult

setTotalOtherIncome(ProfitLossStatementItemResult) - Method in class bb.common.ProfitLossStatementResult

setTotalOtherLiabilities(BigDecimal) - Method in class bb.common.ClosingStatementResult

setTotalOtherLiability(BalanceSheetSideBySideItemResult) - Method in class bb.common.BalanceSheetSideBySideResult

setTotalOutputValue(BigDecimal) - Method in class bb.common.OutputValueByMonthResult

setTotalOwnersEquity(BalanceSheetSideBySideItemResult) - Method in class bb.common.BalanceSheetSideBySideResult

setTotalPages(int) - Method in class bb.common.CycleCountStatusVO

setTotalPages(int) - Method in class bb.common.PhysicalInventoryStatusVO

setTotalPaid(BigDecimal) - Method in class bb.common.AccountingTotalMoneyResult

setTotalPaid(BigDecimal) - Method in class bb.common.CheckRunItemTotalResult

setTotalPaid(BigDecimal) - Method in class bb.common.DuePATotalByVendorResult

setTotalPaid(BigDecimal) - Method in class bb.common.PaymentAgent

setTotalPaid(BigDecimal) - Method in class bb.common.PaymentRunItemTotalResult

setTotalPaid(BigDecimal) - Method in class bb.common.PrepayPaymentAgent

setTotalPaidInvoice(BigDecimal) - Method in class bb.common.SalesOrderVO

setTotalPaidMap(Map<String, BigDecimal>) - Method in class bb.common.PaymentAgent

setTotalPayOut(TreeMap) - Method in class bb.common.TwelveMonthCashFlowReportResult

setTotalPower(BigDecimal) - Method in class bb.common.EquipmentVO

setTotalQty(BigDecimal) - Method in class bb.common.AuditPartInQAResult

setTotalQty(BigDecimal) - Method in class bb.common.BillItemUsageResult

setTotalQty(BigDecimal) - Method in class bb.common.BillWhereUsedResult

setTotalQty(BigDecimal) - Method in class bb.common.InventoryPartInOutDetailListResult

setTotalQtyShip(BigDecimal) - Method in class bb.common.ShipperItemListResult

setTotalR(BigDecimal) - Method in class bb.common.ARAuditListResult

setTotalRec(BigDecimal) - Method in class bb.common.WOIssuedByMonthChartResult

setTotalRecCost(BigDecimal) - Method in class bb.common.WOIssuedByMonthChartResult

setTotalReceipts(TreeMap) - Method in class bb.common.TwelveMonthCashFlowReportResult

setTotalReceived(BigDecimal) - Method in class bb.common.InventoryReportListResult

setTotalReceived(BigDecimal) - Method in class bb.common.PartReceivedListResult

setTotalReceived(BigDecimal) - Method in class bb.common.VendorTotalAmountInPO

setTotalReceivedCost(BigDecimal) - Method in class bb.common.BB2PartByDateResult

setTotalReceivedCost(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemListResult

setTotalReceiveQty(BigDecimal) - Method in class bb.common.BB2PartByDateResult

setTotalRecMoney(BigDecimal) - Method in class bb.common.InventoryReportListResult

setTotalRecOrShip(BigDecimal) - Method in class bb.common.TotalByDateResult

setTotalResearchDevelopment(ProfitLossStatementItemResult) - Method in class bb.common.ProfitLossStatementResult

setTotalReturainedEarnings(BalanceSheetSideBySideItemResult) - Method in class bb.common.BalanceSheetSideBySideResult

setTotalSales(BigDecimal) - Method in class bb.common.SalesMarginListResult

setTotalSales(BigDecimal) - Method in class bb.common.ZipcodeTotalsResult

setTotalSalesMarketing(ProfitLossStatementItemResult) - Method in class bb.common.ProfitLossStatementResult

setTotalSalesRevenue(ProfitLossStatementItemResult) - Method in class bb.common.ProfitLossStatementResult

setTotalShareholdersEquity(BigDecimal) - Method in class bb.common.AccountingBalanceSheetResult

setTotalstandardCost(BigDecimal) - Method in class bb.common.BillSalesOfCostResult

setTotalstandardCost(BigDecimal) - Method in class bb.common.BillSalesXResult

setTotalStandardCost(BigDecimal) - Method in class bb.common.TotalByDateResult

setTotalStdCost(BigDecimal) - Method in class bb.common.AccountsReceivableInfoVO

setTotalStdCost(BigDecimal) - Method in class bb.common.AccountsReceivableVO

setTotalStdCost(BigDecimal) - Method in class bb.common.BillItemSalesCostResult

setTotalStdCost(BigDecimal) - Method in class bb.common.InventoryNotUsedTotal

setTotalStdCost(BigDecimal) - Method in class bb.common.PartOnhandResult

setTotalStdCost(BigDecimal) - Method in class bb.common.PartWithOnLoanQtyListResult

setTotalStdCost(BigDecimal) - Method in class bb.common.PartWithQtyListResult

setTotalStdCost(Money) - Method in class bb.common.PoReceiverByDateSummaryResult

setTotalStdCost(BigDecimal) - Method in class bb.common.QuoteVO

setTotalStdCost(BigDecimal) - Method in class bb.common.SalesOrderVO

setTotalTax(BigDecimal) - Method in class bb.common.AccountingTotalMoneyResult

setTotaltax(BigDecimal) - Method in class bb.common.APTaxForZipcodeListResult

setTotaltax(BigDecimal) - Method in class bb.common.ARTaxForZipcodeListResult

setTotalTax(BigDecimal) - Method in class bb.common.CustomerReturnToVendorVO

setTotalTax(BigDecimal) - Method in class bb.common.DisassembleWorkOrderVO

setTotalTax(BigDecimal) - Method in class bb.common.DuePATotalByVendorResult

setTotalTax(BigDecimal) - Method in class bb.common.OnloanReceiverVO

setTotalTax(BigDecimal) - Method in class bb.common.PoMessageVO

setTotalTax(BigDecimal) - Method in class bb.common.POStatisticsResult

setTotalTax(ProfitLossStatementItemResult) - Method in class bb.common.ProfitLossStatementResult

setTotalTax(BigDecimal) - Method in class bb.common.PurchaseOrderVO

setTotalTax(BigDecimal) - Method in class bb.common.QuoteVO

setTotalTax(BigDecimal) - Method in class bb.common.ReceiverInfoVO

setTotalTax(BigDecimal) - Method in class bb.common.ReceiverVO

setTotalTax(BigDecimal) - Method in class bb.common.RequestForQuoteVO

setTotalTax(BigDecimal) - Method in class bb.common.RequestForRMAVO

setTotalTax(BigDecimal) - Method in class bb.common.ReturnMaterialAuthorizationVO

setTotalTax(BigDecimal) - Method in class bb.common.ReturnToVendorVO

setTotalTax(BigDecimal) - Method in class bb.common.SalesOrderVO

setTotalTax(BigDecimal) - Method in class bb.common.TotalByDateResult

setTotalTax(BigDecimal) - Method in class bb.common.VendorTotalAmountInPO

setTotalTax(BigDecimal) - Method in class bb.common.WorkOrderVO

setTotalTax(BigDecimal) - Method in class bb.common.ZipcodeTotalsResult

setTotalToBeAsmStandardCost(BigDecimal) - Method in class bb.common.WorkOrderItemListResult

setTotalToBeAsmWeight(double) - Method in class bb.common.WorkOrderItemListResult

setTotalToBePaid(BigDecimal) - Method in class bb.common.CheckRunItemTotalResult

setTotalToPaid(BigDecimal) - Method in class bb.common.MakeCheckAgent

setTotalToPaid(BigDecimal) - Method in class bb.common.MakePrepaymentCheckAgent

setTotalVarOnhandQty(BigDecimal) - Method in class bb.common.InventoryAuditReportResult

setTotalWageLabor(ProfitLossStatementItemResult) - Method in class bb.common.ProfitLossStatementResult

setTotalWeight(double) - Method in class bb.common.WOReceiverDetail

setTotalWeight(double) - Method in class bb.common.WorkOrderItemListResult

setTotalWireFee(BigDecimal) - Method in class bb.common.ARPaymentRunVO

setTotControlCost(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

setTotControlCost(BigDecimal) - Method in class bb.common.WOItemCostControlAgent

setTotControlCost(BigDecimal) - Method in class bb.common.WorkOrderItemPartDetailResult

setTotControlCost(BigDecimal) - Method in class bb.common.WorkOrderItemReviewCostResult

setTotCurrentMDepreciate(BigDecimal) - Method in class bb.common.DepreciateMonthlyReport

setTotInSIPQty(BigDecimal) - Method in class bb.common.InSipAudittListResult

setTotIssued(BigDecimal) - Method in class bb.common.PartIssueTotalResult

setTotIssuedAvgCost(BigDecimal) - Method in class bb.common.PartIssueTotalResult

setTotIssuedStdCost(BigDecimal) - Method in class bb.common.PartIssueTotalResult

setTotLastMDepreciate(BigDecimal) - Method in class bb.common.DepreciateMonthlyReport

setTotNewCost(BigDecimal) - Method in class bb.common.CycleCountListTotalResult

setTotNewCost(BigDecimal) - Method in class bb.common.PhysicalInventoryListTotalResult

setTotNewOnhand(BigDecimal) - Method in class bb.common.CycleCountListTotalResult

setTotNewOnhand(BigDecimal) - Method in class bb.common.PhysicalInventoryListTotalResult

setTotOnhand(BigDecimal) - Method in class bb.common.InventoryCycleResult

setTotPFSIPQty(BigDecimal) - Method in class bb.common.InSipAudittListResult

setTotSoSIPQty(BigDecimal) - Method in class bb.common.InSipAudittListResult

setTotSystemCost(BigDecimal) - Method in class bb.common.CycleCountListTotalResult

setTotSystemCost(BigDecimal) - Method in class bb.common.PhysicalInventoryListTotalResult

setTotSystemOnhand(BigDecimal) - Method in class bb.common.CycleCountListTotalResult

setTotSystemOnhand(BigDecimal) - Method in class bb.common.PhysicalInventoryListTotalResult

setTotVarCost(BigDecimal) - Method in class bb.common.DepreciateMonthlyReport

setTotVarDepreciate(BigDecimal) - Method in class bb.common.DepreciateMonthlyReport

setTraceable(String) - Method in class bb.common.BomItemWithOEMResult

setTraceable(boolean) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setTraceable(boolean) - Method in class bb.common.IssuingItemResult

setTraceable(String) - Method in class bb.common.PartBasicInfo

setTraceable(String) - Method in class bb.common.PartVO

setTraceable(String) - Method in class bb.common.PartWhereUsedItemResult

setTraceable(String) - Method in class bb.common.PartWithManufacturerInfoResult

setTraceable(String) - Method in class bb.common.PartWithOnhandsVO

setTraceable(String) - Method in class bb.common.PurchaseOrderItemVO

setTraceable(boolean) - Method in class bb.common.ReceivingItemResult

setTraceable(String) - Method in class bb.common.SalesOrderItemVO

setTraceable(boolean) - Method in class bb.common.ShippingItemResult

setTraceableCategoryItem(Short) - Method in class bb.common.PartTraceableCategoryPK

setTraceableLevel(Byte) - Method in class bb.common.BillItemWithPartInfoResult

setTraceableLevel(Byte) - Method in class bb.common.BillWithPartInfoResult

setTraceableLevel(Byte) - Method in class bb.common.PartTraceableInfoResult

setTraceableLevel(Byte) - Method in class bb.common.PartTraceableListResult

setTraceableLevel(Byte) - Method in class bb.common.PartTraceableResult

setTraceableLevel(Byte) - Method in class bb.common.PartVO

setTraceableLevel(Byte) - Method in class bb.common.PartWhereUsedItemResult

setTraceableLevel(Byte) - Method in class bb.common.PartWithOnhandDetailInfoResult

setTraceableLevel(Byte) - Method in class bb.common.PartWithOnhandsVO

setTraceableLevel(Byte) - Method in class bb.common.PurchaseOrderItemVO

setTraceableLevel(Byte) - Method in class bb.common.SalesOrderItemVO

setTracking(String) - Method in class bb.common.AccountsPayableInfoVO

setTracking(String) - Method in class bb.common.AccountsPayableVO

setTracking(String) - Method in class bb.common.AccountsReceivableInfoVO

setTracking(String) - Method in class bb.common.AccountsReceivableVO

setTracking(String) - Method in class bb.common.MakeInvoiceAgent

setTracking(String) - Method in class bb.common.OnloanReceiverVO

setTracking(String) - Method in class bb.common.OnloanShipperVO

setTracking(String) - Method in class bb.common.PfReceiverVO

setTracking(String) - Method in class bb.common.ProformaInvoiceVO

setTracking(String) - Method in class bb.common.ReceiverInfoVO

setTracking(String) - Method in class bb.common.ReceiverVO

setTracking(String) - Method in class bb.common.RMAReceiverVO

setTracking(String) - Method in class bb.common.RtvShipperInfoVO

setTracking(String) - Method in class bb.common.RtvShipperVO

setTracking(String) - Method in class bb.common.ShipperAgent

setTracking(String) - Method in class bb.common.ShipperInfoVO

setTracking(String) - Method in class bb.common.ShipperVO

setTracking(String) - Method in class bb.common.SwapReceiverListResult

setTracking(String) - Method in class bb.common.SwapReceiverVO

setTracking(String) - Method in class bb.common.SwapShipperListResult

setTracking(String) - Method in class bb.common.SwapShipperVO

setTracking(String) - Method in class bb.common.TransferReceiverListResult

setTracking(String) - Method in class bb.common.TransferReceiverVO

setTracking(String) - Method in class bb.common.TransferShipperListResult

setTracking(String) - Method in class bb.common.TransferShipperVO

setTrackingLog(Set<ReceiverItemTrackingLogAgent>) - Method in class bb.common.IssueItemDetailAgent

setTrackingLog(Set<ReceiverItemTrackingLogAgent>) - Method in class bb.common.PuttoInQAAgent

setTrackingLog(Set<ReceiverItemTrackingLogAgent>) - Method in class bb.common.RebackInQAAgent

setTrackingLog(Set<ReceiverItemTrackingLogAgent>) - Method in class bb.common.ReceiverItemDetailAgent

setTrackingLog(Set<ReceiverItemTrackingLogAgent>) - Method in class bb.common.ShipperItemDetailAgent

setTrackingNumber(String) - Method in class bb.common.LogTrackingVO

setTrackingNumber(String) - Method in class bb.common.PartTrackingPK

setTrackingNumber(String) - Method in class bb.common.ReceiverAgent

setTrackingNumber(String) - Method in class bb.common.ReceiverItemTrackingLogAgent

setTrackings(Map) - Method in class bb.common.DisassembleWorkOrderIssueVO

setTrackings(Map) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

setTrackings(Map) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setTrackings(Map) - Method in class bb.common.NonproductivePickingItemIssuedVO

setTrackings(Map) - Method in class bb.common.OnloanReceiverItemVO

setTrackings(Map) - Method in class bb.common.OnloanShipperItemVO

setTrackings(Map) - Method in class bb.common.PackingBoxItemVO

setTrackings(HashMap<String, BigDecimal>) - Method in class bb.common.PackingBoxSalesOrderItemAgent

setTrackings(Map) - Method in class bb.common.PartIssuedVO

setTrackings(Map) - Method in class bb.common.PartReceivedVO

setTrackings(Map) - Method in class bb.common.ReceiverItemVO

setTrackings(Map) - Method in class bb.common.RMAReceiverItemVO

setTrackings(Map) - Method in class bb.common.RtvShipperItemVO

setTrackings(Map) - Method in class bb.common.ShipperItemVO

setTrackings(Map) - Method in class bb.common.SwapReceiverItemVO

setTrackings(Map) - Method in class bb.common.SwapShipperItemVO

setTrackings(Map) - Method in class bb.common.TransferReceiverItemVO

setTrackings(Map) - Method in class bb.common.TransferShipperItemVO

setTrackings(Map) - Method in class bb.common.WorkOrderReceiverVO

setTradeAccount(BigDecimal) - Method in class bb.common.AccountingBalanceSheetResult

setTrainComments(String) - Method in class bb.common.CustomEmployeeVO

setTrainDate(Date) - Method in class bb.common.CustomEmployeeTrainVO

setTrainDate(Date) - Method in class bb.common.EmployeeTrainingVO

setTransactionAmount(BigDecimal) - Method in class bb.common.CustomerStatementResult

setTransactionDate(Date) - Method in class bb.common.AccountCreditVO

setTransactionDate(Date) - Method in class bb.common.AccountDebitVO

setTransactionDate(Date) - Method in class bb.common.AccountPayableCheckRunVO

setTransactionDate(Date) - Method in class bb.common.AccountsCreditDebitListResult

setTransactionDate(Date) - Method in class bb.common.AddPayableWithoutReceiverAgent

setTransactionDate(Date) - Method in class bb.common.ARPaymentRunVO

setTransactionDate(Date) - Method in class bb.common.ARPrepaymentWireTransferAgent

setTransactionDate(Date) - Method in class bb.common.GeneralLedgerByDateListResult

setTransactionDate(Date) - Method in class bb.common.GeneralLedgerListResult

setTransactionDate(Date) - Method in class bb.common.GeneralLedgerPrintResult

setTransactionDate(Date) - Method in class bb.common.GeneralLedgerResult

setTransactionDate(Date) - Method in class bb.common.GeneralLedgerVO

setTransactionDate(Date) - Method in class bb.common.GLApprovalListResult

setTransactionDate(Date) - Method in class bb.common.GLItemVO

setTransactionDate(Date) - Method in class bb.common.JounalEntryListResult

setTransactionDate(Date) - Method in class bb.common.PrepaymentWireTransferAgent

setTransactionDate(Date) - Method in class bb.common.WireTransferAgent

setTransactionEDate(Date) - Method in class bb.common.APAuditListResult

setTransactionIDate(Date) - Method in class bb.common.APAuditListResult

setTransactionInvoices(List<AccountsReceivableVO>) - Method in class bb.common.CustomerStatementResult

setTransactionNo(String) - Method in class bb.common.AccountPayableCheckRunItemVO

setTransactionNo(String) - Method in class bb.common.AccountsCreditDebitListResult

setTransactionNo(String) - Method in class bb.common.ARPaymentRunItemVO

setTransactionNumber(String) - Method in class bb.common.AccountCreditDebitPK

setTransactionNumber(String) - Method in class bb.common.ApCheckRunListResult

setTransactionNumber(String) - Method in class bb.common.ARPaymentRunListResult

setTransactionNumber(String) - Method in class bb.common.AssetDepreciateVO

setTransactionNumber(String) - Method in class bb.common.ChangeStdCostWorkSheetVO

setTransactionNumber(String) - Method in class bb.common.DisassembleWorkOrderIssueVO

setTransactionNumber(String) - Method in class bb.common.ExchangeAuditResult

setTransactionNumber(String) - Method in class bb.common.GeneralLedgerListResult

setTransactionNumber(String) - Method in class bb.common.GeneralLedgerResult

setTransactionNumber(String) - Method in class bb.common.GeneralLedgerVO

setTransactionNumber(String) - Method in class bb.common.JounalEntryListResult

setTransactionNumber(String) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setTransactionNumber(String) - Method in class bb.common.NonproductivePickingItemIssuedVO

setTransactionNumber(String) - Method in class bb.common.NonproductivePickingItemVO

setTransactionNumber(String) - Method in class bb.common.PartIssuedVO

setTransactionNumber(String) - Method in class bb.common.PartReceivedVO

setTransactionNumber(String) - Method in class bb.common.RollUpBomStdCostWorkSheetVO

setTransactionNumber(String) - Method in class bb.common.ScrapReportVO

setTransactionNumber(String) - Method in class bb.common.WorkOrderItemPartDetailInWipVO

setTransactionNumber(String) - Method in class bb.common.WorkOrderReceiverVO

setTransactionODate(Date) - Method in class bb.common.ARAuditListResult

setTransactionRDate(Date) - Method in class bb.common.ARAuditListResult

setTransactionType(String) - Method in class bb.common.AccountCreditVO

setTransactionType(String) - Method in class bb.common.AccountDebitVO

setTransactionType(String) - Method in class bb.common.AccountingTransactionTypeVO

setTransactionType(String) - Method in class bb.common.AccountsCreditDebitListResult

setTransactionType(String) - Method in class bb.common.GeneralLedgerListResult

setTransactionType(String) - Method in class bb.common.GeneralLedgerResult

setTransactionType(String) - Method in class bb.common.GeneralLedgerVO

setTransactionType(String) - Method in class bb.common.GLItemVO

setTransactionTypeDescription(String) - Method in class bb.common.GeneralLedgerListResult

setTransactionTypeDescription(AccountingTransactionTypeVO) - Method in class bb.common.GeneralLedgerVO

setTransferDate(Date) - Method in class bb.common.CustomEmployeeVO

setTransferDate(Date) - Method in class bb.common.EmployeeCardVO

setTransferOrderDate(Date) - Method in class bb.common.TransferOrderListResult

setTransferOrderDate(Date) - Method in class bb.common.TransferOrderVO

setTransferOrderItemNumber(String) - Method in class bb.common.TransferOrderItemListResult

setTransferOrderItemNumber(String) - Method in class bb.common.TransferOrderItemPK

setTransferOrderItems(Set<TransferOrderItemVO>) - Method in class bb.common.TransferOrderVO

setTransferOrderNumber(String) - Method in class bb.common.TransferOrderItemListResult

setTransferOrderNumber(String) - Method in class bb.common.TransferOrderItemPK

setTransferOrderNumber(String) - Method in class bb.common.TransferOrderListResult

setTransferOrderNumber(String) - Method in class bb.common.TransferOrderVO

setTransferOrderNumber(String) - Method in class bb.common.TransferReceiverListResult

setTransferOrderNumber(String) - Method in class bb.common.TransferReceiverVO

setTransferOrderNumber(String) - Method in class bb.common.TransferShipperListResult

setTransferOrderNumber(String) - Method in class bb.common.TransferShipperVO

setTransferQty(BigDecimal) - Method in class bb.common.TransferOrderItemListResult

setTransferQty(BigDecimal) - Method in class bb.common.TransferOrderItemVO

setTransferQty(BigDecimal) - Method in class bb.common.TransferReceiverItemListResult

setTransferQty(BigDecimal) - Method in class bb.common.TransferReceiverItemVO

setTransferQty(BigDecimal) - Method in class bb.common.TransferShipperItemListResult

setTransferQty(BigDecimal) - Method in class bb.common.TransferShipperItemVO

setTransferReceiverItemNumber(String) - Method in class bb.common.TransferReceiverItemListResult

setTransferReceiverItemNumber(String) - Method in class bb.common.TransferReceiverItemPK

setTransferReceiverItems(Set<TransferReceiverItemVO>) - Method in class bb.common.TransferReceiverVO

setTransferReceiverNumber(String) - Method in class bb.common.TransferReceiverItemListResult

setTransferReceiverNumber(String) - Method in class bb.common.TransferReceiverItemPK

setTransferReceiverNumber(String) - Method in class bb.common.TransferReceiverListResult

setTransferReceiverNumber(String) - Method in class bb.common.TransferReceiverVO

setTransferShipperItemNumber(String) - Method in class bb.common.TransferShipperItemListResult

setTransferShipperItemNumber(String) - Method in class bb.common.TransferShipperItemPK

setTransferShipperItems(Set<TransferShipperItemVO>) - Method in class bb.common.TransferShipperVO

setTransferShipperNumber(String) - Method in class bb.common.InspectionConformanceReportVO

setTransferShipperNumber(String) - Method in class bb.common.TransferReceiverListResult

setTransferShipperNumber(String) - Method in class bb.common.TransferReceiverVO

setTransferShipperNumber(String) - Method in class bb.common.TransferShipperItemListResult

setTransferShipperNumber(String) - Method in class bb.common.TransferShipperItemPK

setTransferShipperNumber(String) - Method in class bb.common.TransferShipperListResult

setTransferShipperNumber(String) - Method in class bb.common.TransferShipperVO

setTransferType(String) - Method in class bb.common.TransferOrderVO

setTroubleRev(String) - Method in class bb.common.SGDocPartVO

setTroubleshooting(String) - Method in class bb.common.SGDocPartVO

setTroubleshooting(boolean) - Method in class bb.common.SGPartDocFlagResult

setTrueName(String) - Method in class bb.common.OperationLogVO

setType(String) - Method in class bb.common.AccountsChartAdvanceCategoryVO

setType(String) - Method in class bb.common.AccountsChartVO

setType(String) - Method in class bb.common.AppColumnVO

setType(int) - Method in class bb.common.BizBoxUserEmployeeResult

setType(int) - Method in class bb.common.BizboxUserListResult

setType(int) - Method in class bb.common.BizboxUserVO

setType(String) - Method in class bb.common.CompanyUnitVO

setType(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setType(String) - Method in class bb.common.CustomerVendorAddressVO

setType(String) - Method in class bb.common.CustomerVendorContactVO

setType(String) - Method in class bb.common.CV2CVAgent

setType(String) - Method in class bb.common.EquipmentListResult

setType(String) - Method in class bb.common.EquipmentVO

setType(String) - Method in class bb.common.ExpenseAccountVO

setType(String) - Method in class bb.common.ExpenseItemVO

setType(String) - Method in class bb.common.MaintenanceItemVO

setType(byte) - Method in class bb.common.OperationLogVO

setType(String) - Method in class bb.common.PartMaterialListResult

setType(String) - Method in class bb.common.PartMaterialReportAgent

setType(String) - Method in class bb.common.PartMaterialVO

setType(String) - Method in class bb.common.ProfitLossStatementItemResult

setType(String) - Method in class bb.common.PurchaseOrderContractResult

setType(String) - Method in class bb.common.SgClientProgramUserVO

setType(int) - Method in class bb.common.User2UserAgent

setUnbilled(boolean) - Method in class bb.common.CompanyVO

setUnbilledAccount(String) - Method in class bb.common.AccountingSettingsVO

setUnbilledExchange(BigDecimal) - Method in class bb.common.ShipperItemVO

setUnbilledIncomeAccount(String) - Method in class bb.common.AccountingSettingsVO

setUnDepreciatedAccm(BigDecimal) - Method in class bb.common.AssetDepreciateVO

setUndepreciatedBalance(BigDecimal) - Method in class bb.common.AssetDepreciateDetailReport

setUndepreciatedBalance(BigDecimal) - Method in class bb.common.AssetDepreciateVO

setUnderline(boolean) - Method in class bb.common.LabelTemplateItemVO

setUnit(String) - Method in class bb.common.AccountsPayableItemVO

setUnit(String) - Method in class bb.common.AccountsReceivableItemVO

setUnit(String) - Method in class bb.common.BB2PartByDateResult

setUnit(String) - Method in class bb.common.BB2PartTotalOnhandDetailResult

setUnit(String) - Method in class bb.common.BillItemSalesResult

setUnit(String) - Method in class bb.common.BillItemSalesXResult

setUnit(String) - Method in class bb.common.BillSalesResult

setUnit(String) - Method in class bb.common.BillSalesXResult

setUnit(String) - Method in class bb.common.BomItemWithOEMResult

setUnit(String) - Method in class bb.common.BomWithOEMResult

setUnit(String) - Method in class bb.common.CustomEmployeeVO

setUnit(String) - Method in class bb.common.CustomerReturnToVendorItemVO

setUnit(String) - Method in class bb.common.CustomGoodsBreedVO

setUnit(String) - Method in class bb.common.CycleCountListResult

setUnit(String) - Method in class bb.common.DisassembleWorkOrderIssueVO

setUnit(String) - Method in class bb.common.DisassembleWorkOrderIssuingItemResult

setUnit(String) - Method in class bb.common.DisassembleWorkOrderItemListResult

setUnit(String) - Method in class bb.common.DisassembleWorkOrderItemReceiverVO

setUnit(String) - Method in class bb.common.DisassembleWorkOrderItemVO

setUnit(String) - Method in class bb.common.DisassembleWorkOrderReceivingResult

setUnit(String) - Method in class bb.common.InspectionConformanceReportItemCheckVO

setUnit(String) - Method in class bb.common.InspectionTypeItemVO

setUnit(String) - Method in class bb.common.InventoryNotUsedInMonthsforAppResult

setUnit(String) - Method in class bb.common.InventoryPartInOutDetailListResult

setUnit(String) - Method in class bb.common.IssuingResult

setUnit(String) - Method in class bb.common.NonproductivePickingItemIssuedListResult

setUnit(String) - Method in class bb.common.NonproductivePickingItemIssuedVO

setUnit(String) - Method in class bb.common.NonproductivePickingItemResult

setUnit(String) - Method in class bb.common.NonproductivePickingItemVO

setUnit(String) - Method in class bb.common.OnLoanItemVO

setUnit(String) - Method in class bb.common.OnloanReceiverItemListResult

setUnit(String) - Method in class bb.common.OnloanReceiverItemVO

setUnit(String) - Method in class bb.common.OnloanShipperItemVO

setUnit(String) - Method in class bb.common.OrderApprovalItemsVO

setUnit(String) - Method in class bb.common.OrderDemandForReceiverResult

setUnit(String) - Method in class bb.common.PartInspectionVO

setUnit(String) - Method in class bb.common.PartIssuedVO

setUnit(String) - Method in class bb.common.PartManufacturerVO

setUnit(String) - Method in class bb.common.PartOnhandCostVO

setUnit(String) - Method in class bb.common.PartReceivedVO

setUnit(String) - Method in class bb.common.PartUnitPK

setUnit(String) - Method in class bb.common.PartWithInventoryInfoListResult

setUnit(String) - Method in class bb.common.PfReceiverItemVO

setUnit(String) - Method in class bb.common.PhysicalInventoryListResult

setUnit(String) - Method in class bb.common.POSurveyReportItemVO

setUnit(String) - Method in class bb.common.ProformaInvoiceItemListResult

setUnit(String) - Method in class bb.common.ProformaInvoiceItemVO

setUnit(String) - Method in class bb.common.PurchaseOrderItemListResult

setUnit(String) - Method in class bb.common.PurchaseOrderItemVO

setUnit(String) - Method in class bb.common.QuoteItemListResult

setUnit(String) - Method in class bb.common.QuoteItemVO

setUnit(String) - Method in class bb.common.ReceiverItemVO

setUnit(String) - Method in class bb.common.ReceivingItemResult

setUnit(String) - Method in class bb.common.RequestForQuoteItemListResult

setUnit(String) - Method in class bb.common.RequestForQuoteItemVO

setUnit(String) - Method in class bb.common.RequestForRMAItemVO

setUnit(String) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setUnit(String) - Method in class bb.common.ReturnToVendorByDateListResult

setUnit(String) - Method in class bb.common.ReturnToVendorItemListResult

setUnit(String) - Method in class bb.common.ReturnToVendorItemVO

setUnit(String) - Method in class bb.common.RMAReceiverItemListResult

setUnit(String) - Method in class bb.common.RMAReceiverItemVO

setUnit(String) - Method in class bb.common.RtvShipperItemVO

setUnit(String) - Method in class bb.common.RunningAccountOrderItemVO

setUnit(String) - Method in class bb.common.SalesBomItemResult

setUnit(String) - Method in class bb.common.SalesBomResult

setUnit(String) - Method in class bb.common.SalesOrderItemInfoVO

setUnit(String) - Method in class bb.common.SalesOrderItemListResult

setUnit(String) - Method in class bb.common.SalesOrderItemVO

setUnit(String) - Method in class bb.common.SalesOrderShipDateListResult

setUnit(String) - Method in class bb.common.SalesPartListItemResult

setUnit(String) - Method in class bb.common.SalesPartListResult

setUnit(String) - Method in class bb.common.SGBOMItemResult

setUnit(String) - Method in class bb.common.SGCustRequestForQuoteItemResult

setUnit(String) - Method in class bb.common.SGPartCatalogResult

setUnit(String) - Method in class bb.common.SGPartListItemResult

setUnit(String) - Method in class bb.common.SGPartListResult

setUnit(String) - Method in class bb.common.SGQuoteCartListResult

setUnit(String) - Method in class bb.common.SGSaleItemVO

setUnit(String) - Method in class bb.common.ShipperItemVO

setUnit(String) - Method in class bb.common.ShippingItemResult

setUnit(String) - Method in class bb.common.SwapOrderItemVO

setUnit(String) - Method in class bb.common.SwapReceiverItemVO

setUnit(String) - Method in class bb.common.SwapShipperItemVO

setUnit(String) - Method in class bb.common.TransferOrderItemVO

setUnit(String) - Method in class bb.common.TransferReceiverItemListResult

setUnit(String) - Method in class bb.common.TransferReceiverItemVO

setUnit(String) - Method in class bb.common.TransferShipperItemListResult

setUnit(String) - Method in class bb.common.TransferShipperItemVO

setUnit(String) - Method in class bb.common.WorkOrderItemIssuedTotalResult

setUnit(String) - Method in class bb.common.WorkOrderItemIssueVO

setUnit(String) - Method in class bb.common.WorkOrderItemListResult

setUnit(String) - Method in class bb.common.WorkOrderItemPartDetail

setUnit(String) - Method in class bb.common.WorkOrderItemTimeDetailVO

setUnit(String) - Method in class bb.common.WorkOrderItemVO

setUnit(String) - Method in class bb.common.WorkOrderReceiverVO

setUnitName(String) - Method in class bb.common.UnitVO

setUnitPrice(BigDecimal) - Method in class bb.common.InvoiceItemListResult

setUnitPrice(BigDecimal) - Method in class bb.common.RunningAccountOrderItemVO

setUnitQty(BigDecimal) - Method in class bb.common.RunningAccountOrderItemVO

setUnits(Set<PartUnitVO>) - Method in class bb.common.PartVO

setUnits(Set<PartUnitVO>) - Method in class bb.common.RunningAccountOrderItemVO

setUnitTotal(BigDecimal) - Method in class bb.common.AccountingTotalMoneyResult

setUnitTotal(BigDecimal) - Method in class bb.common.DuePATotalByVendorResult

setUnixHome(String) - Method in class bb.common.SGCompanyVO

SetUp - Static variable in class bb.common.Constant.Status

setupAPPrepayWireTransfer(PrepaymentWireTransferAgent) - Method in interface bb.common.box.AccountingBox

setupAPWireTransfer(WireTransferAgent) - Method in interface bb.common.box.AccountingBox

SetUpARPrepaymentWireTransferExecuter(ARPrepaymentWireTransferAgent) - Method in interface bb.common.box.AccountingBox

setupARWireTransfer(WireTransferAgent) - Method in interface bb.common.box.AccountingBox

setUpcaseDescription(String) - Method in class bb.common.CompanyVO

setUpcaseWorkInstructionSeq(String) - Method in class bb.common.CompanyVO

setupCheckRunPayment(ApCheckRunItemAgent) - Method in interface bb.common.box.AccountingBox

setupCheckRunPrepayment(ApPrepaymentCheckRunItemAgent) - Method in interface bb.common.box.AccountingBox

setupDisassembleWorkOrderItem(DisassembleWorkOrderItemPK, ArrayList) - Method in interface bb.common.box.WorkOrderBox

setUpLevelAccount(String) - Method in class bb.common.AccountBalanceResult

setUpLevelAccount(String) - Method in class bb.common.AccountsChartVO

setUpLevelAccount(String) - Method in class bb.common.BudgetListResult

setUpLevelAccountNumber(String) - Method in class bb.common.BalanceSheetSideBySideItemResult

setUpLevelAccountNumber(String) - Method in class bb.common.ClosingStatementItemResult

setUpLevelAccountNumber(String) - Method in class bb.common.ExchangeAuditItemResult

setUpLevelAccountNumber(String) - Method in class bb.common.ProfitLossStatementItemResult

setUpLevelUnitId(String) - Method in class bb.common.CompanyUnitVO

setUploadDate(Date) - Method in class bb.common.AddressQualityDocumentsVO

setUploadTime(Date) - Method in class bb.common.NCRPictureVO

setupReceivablePayment(ArPaymentRunItemAgent) - Method in interface bb.common.box.AccountingBox

setupReceivablePrepayment(ArPrepaymentRunItemAgent) - Method in interface bb.common.box.AccountingBox

setupWorkOrderItem(WorkOrderItemPK, ArrayList, boolean) - Method in interface bb.common.box.WorkOrderBox

setUsageQty(BigDecimal) - Method in class bb.common.BillItemUsagePathResult

setUsageQty(BigDecimal) - Method in class bb.common.MrpByMonthResult

setUseAccountPeriod(boolean) - Method in class bb.common.FiscalYearSettingsVO

setUseApprovalGl(boolean) - Method in class bb.common.AccountingConfigurationVO

setUseAutoApprovalGl(boolean) - Method in class bb.common.AccountingConfigurationVO

setUseAutoApprovalGL(boolean) - Method in class bb.common.PointOfSaleVO

setUseAutoCreateOrder(boolean) - Method in class bb.common.PointOfSaleVO

setUseAvgCostToRollUp(boolean) - Method in class bb.common.RollUpBomStdCostWorkSheetVO

setUseBackflush(boolean) - Method in class bb.common.CustomerVendorAddressInfoVO

setUseBackflush(boolean) - Method in class bb.common.CustomerVendorAddressVO

setUseBackflush(boolean) - Method in class bb.common.PartVO

setUseBackflush(boolean) - Method in class bb.common.PartWithOnhandsVO

setUseBomApproval(boolean) - Method in class bb.common.CompanyVO

setUseBranchWarehouse(boolean) - Method in class bb.common.CompanyVO

setUseCarryOverPL(boolean) - Method in class bb.common.AccountingConfigurationVO

setUseCloseEntry(boolean) - Method in class bb.common.AccountingConfigurationVO

setUseCTaxRate(boolean) - Method in class bb.common.CustomerVendorAddressVO

setUsedDate(Date) - Method in class bb.common.BOMCanAssyAgent

setUseEcStartWithYear(boolean) - Method in class bb.common.CompanyVO

setUseEngGroupUser(boolean) - Method in class bb.common.CompanyVO

setUseIncludeTaxCostforPO(boolean) - Method in class bb.common.CompanyVO

setUseJournalAccount(boolean) - Method in class bb.common.AccountingConfigurationVO

setUseMultiQtyforApplying(boolean) - Method in class bb.common.CompanyVO

setUseOperationScrap(boolean) - Method in class bb.common.CompanyVO

setUseOrderChangeApproval(boolean) - Method in class bb.common.CompanyVO

setUsePOSReceive(boolean) - Method in class bb.common.PointOfSaleVO

setUsePostGl(boolean) - Method in class bb.common.AccountingConfigurationVO

setUsePriceWithTax(boolean) - Method in class bb.common.PurchaseOrderItemVO

setUsePriceWithTax(boolean) - Method in class bb.common.SalesOrderItemVO

setUsePriceWithTaxAsListPriceInVCP(boolean) - Method in class bb.common.CompanyVO

setUsePriceWithTaxDefault(boolean) - Method in class bb.common.CompanyVO

setUser(String) - Method in class bb.common.AssetUsageVO

setUser(String) - Method in class bb.common.CustomAssetRecordVO

setUser(String) - Method in class bb.common.SGClientAccountPK

setUser(String) - Method in class bb.common.SGLogLoginVO

setUser(String) - Method in class bb.common.TempArApAgingVO

setUserCompany(String) - Method in class bb.common.SGClientAccountVO

setUserCompany(String) - Method in class bb.common.SGLogLoginVO

setUserEmail(String) - Method in class bb.common.SGCartCheckOutResult

setUserEmail(String) - Method in class bb.common.SGCartLogin

setUserEmail(String) - Method in class bb.common.SgClientProgramUserVO

setUserEmail(String) - Method in class bb.common.SGCustRequestForQuoteListResult

setUserEmail(String) - Method in class bb.common.SGCustRequestForQuoteResult

setUserEmail(String) - Method in class bb.common.SGCustRequestForQuoteVO

setUserEmail(String) - Method in class bb.common.SGQuoteAddressResult

setUserEmail(String) - Method in class bb.common.SGQuoteAddressVO

setUserEmail(String) - Method in class bb.common.SGQuoteCartVO

setUserEmail(String) - Method in class bb.common.SGQuoteLoginVO

setUserEmail(String) - Method in class bb.common.VendorGroupUserVO

setUserGroup(String) - Method in class bb.common.GroupUserPK

setUserIp(String) - Method in class bb.common.SGLogLoginVO

setUserIp(String) - Method in class bb.common.SGQuoteLoginVO

setUserLanguage(String) - Method in class bb.common.SGLogLoginVO

setUserName(String) - Method in class bb.common.AccountingInfoDocumentVO

setUserName(String) - Method in class bb.common.BB2Login

setUsername(String) - Method in class bb.common.BizBoxServer

setUserName(String) - Method in class bb.common.BizBoxUserEmployeeResult

setUserName(String) - Method in class bb.common.BizboxUserListResult

setUserName(String) - Method in class bb.common.BizboxUserVO

setUserName(String) - Method in class bb.common.BomApprovalVO

setUserName(String) - Method in class bb.common.DisassembleWorkOrderApprovalVO

setUserName(String) - Method in class bb.common.DisassembleWorkOrderIssuingResult

setUserName(String) - Method in class bb.common.DocumentLogVO

setUserName(String) - Method in class bb.common.DocumentServerVO

setUserName(String) - Method in class bb.common.DwfUploadSettingsVO

setUserName(String) - Method in class bb.common.DwgUploadSettingsVO

setUserName(String) - Method in class bb.common.ECNReviewVO

setUserName(String) - Method in class bb.common.ECRReviewVO

setUserName(String) - Method in class bb.common.EmployeeCardVO

setUserName(String) - Method in class bb.common.EmployeeEducationResult

setUserName(String) - Method in class bb.common.EngGroupUserVO

setUserName(String) - Method in class bb.common.ExpenseListResult

setUserName(String) - Method in class bb.common.ExpenseVO

setUserName(String) - Method in class bb.common.GeneralLedgerApprovalVO

setUserName(String) - Method in class bb.common.GroupUserPK

setUserName(String) - Method in class bb.common.MiscDocumentSettingVO

setUserName(String) - Method in class bb.common.MyPrintListPK

setUserName(String) - Method in class bb.common.NcrApprovalVO

setUserName(String) - Method in class bb.common.NonproductivePickingApprovalVO

setUserName(String) - Method in class bb.common.NonproductivePickingApproveVO

setUserName(String) - Method in class bb.common.NoticeUserEmployeeListResult

setUserName(String) - Method in class bb.common.OnloanReviewVO

setUserName(String) - Method in class bb.common.OpCodeShortcutPK

setUserName(String) - Method in class bb.common.OperationLogVO

setUserName(String) - Method in class bb.common.PurchaseOrderApprovalVO

setUserName(String) - Method in class bb.common.QualityGroupPK

setUserName(String) - Method in class bb.common.ReceivingResult

setUserName(String) - Method in class bb.common.RMAReviewVO

setUserName(String) - Method in class bb.common.RTVApprovalVO

setUserName(String) - Method in class bb.common.SalesmanVO

setUserName(String) - Method in class bb.common.SalesOrderReviewVO

setUserName(String) - Method in class bb.common.SGClientAccountVO

setUserName(String) - Method in class bb.common.SgClientProgramUserVO

setUserName(String) - Method in class bb.common.SGLogLoginVO

setUserName(String) - Method in class bb.common.SmtpServerVO

setUserName(String) - Method in class bb.common.SubcompanyLoginAgent

setUserName(String) - Method in class bb.common.SwapOrderApprovalVO

setUserName(String) - Method in class bb.common.TransferOrderApprovalVO

setUserName(String) - Method in class bb.common.User2UserAgent

setUserName(String) - Method in class bb.common.UserRolePermissionListResult

setUserName(String) - Method in class bb.common.UserRolePK

setUserName(String) - Method in class bb.common.VendorGroupUserVO

setUserName(String) - Method in class bb.common.WorkOrderApprovalVO

setUserPassword(String) - Method in class bb.common.DocumentServerVO

setUserPassword(String) - Method in class bb.common.DwfUploadSettingsVO

setUserPassword(String) - Method in class bb.common.DwgUploadSettingsVO

setUserPassword(String) - Method in class bb.common.MiscDocumentSettingVO

setUseTaxReport(boolean) - Method in class bb.common.AccountingConfigurationVO

setUseType(String) - Method in class bb.common.PartUseTypeVO

setUseUppercaseSystemUserName(boolean) - Method in class bb.common.CompanyVO

setUseVTaxRate(boolean) - Method in class bb.common.CustomerVendorAddressVO

setUseWip(boolean) - Method in class bb.common.DisassembleWorkOrderVO

setUseWip(boolean) - Method in class bb.common.WorkOrderVO

setUseWorkOrderCostControl(boolean) - Method in class bb.common.CompanyVO

setUseZipCode(boolean) - Method in class bb.common.AccountingSettingsVO

setUsingDate(Date) - Method in class bb.common.CustomAssetVO

setUsingLife(int) - Method in class bb.common.AssetDepreciateDetailReport

setUsingLife(int) - Method in class bb.common.AssetDepreciateVO

setUsingLife(int) - Method in class bb.common.AssetVO

setUsingStatus(String) - Method in class bb.common.AssetDepreciateVO

setUsingStatus(String) - Method in class bb.common.AssetVO

setUsingStatus(String) - Method in class bb.common.DepreciateMonthlyReport

setUsingUnit(String) - Method in class bb.common.CustomAssetVO

setValidate(String) - Method in class bb.common.DataFilterVO

setValidateCode(String) - Method in class bb.common.BB2Notice

setValidateCode(String) - Method in class bb.common.PoMessageListResult

setValidateCode(String) - Method in class bb.common.PoMessageVO

setValidateCode(String) - Method in class bb.common.RfqMessageListResult

setValidateCode(String) - Method in class bb.common.RfqMessageVO

setValidDate(Date) - Method in class bb.common.CustomerVendorAddressInfoVO

setValidDate(Date) - Method in class bb.common.CustomerVendorAddressVO

setValidDate(Date) - Method in class bb.common.RunningAccountOrderVO

setValidDate(Date) - Method in class bb.common.ZipcodeTotalsResult

setValidFrom(Date) - Method in class bb.common.EngineeringSharingVO

setValidThru(Date) - Method in class bb.common.CPItemFromQuoteResult

setValidThru(Date) - Method in class bb.common.QuoteListResult

setValidThru(Date) - Method in class bb.common.QuoteVO

setValidTo(Date) - Method in class bb.common.EngineeringSharingVO

setValidTransactionDate(Date) - Method in class bb.common.GeneralLedgerSettingsVO

setValuationStorage(boolean) - Method in class bb.common.CompanyVO

setValuationStorageAccount(String) - Method in class bb.common.AccountingSettingsVO

setValue(String) - Method in class bb.common.AddRTVAgent

setValue(BigDecimal) - Method in class bb.common.Money

setValue(String) - Method in class bb.common.ServerClientPropertyVO

setValueOfCustomField(String, Object) - Method in class bb.common.VO

setVariance(BigDecimal) - Method in class bb.common.ExchangeAuditItemResult

setVariance(BigDecimal) - Method in class bb.common.PartCostVarianceListResult

setVarianceAmount(BigDecimal) - Method in class bb.common.ChangeStdCostWorkSheetVO

setVarianceAmount(BigDecimal) - Method in class bb.common.RollUpBomStdCostWorkSheetVO

setVarianceAMT(Map) - Method in class bb.common.BudgetListResult

setVarianceAMTTotal(BigDecimal) - Method in class bb.common.BudgetListResult

setVarianceAMTYTD(Map) - Method in class bb.common.BudgetListResult

setVarianceCost(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

setVarianceCost(BigDecimal) - Method in class bb.common.PartInventoryVO

setVarianceCost(BigDecimal) - Method in class bb.common.WOItemCostControlAgent

setVarianceCost(BigDecimal) - Method in class bb.common.WorkOrderItemPartDetailResult

setVarianceCost(BigDecimal) - Method in class bb.common.WorkOrderItemReviewCostResult

setVarianceCount(Integer) - Method in class bb.common.RollUpBomStdCostWorkSheetVO

setVariancePercent(BigDecimal) - Method in class bb.common.ChangeStdCostWorkSheetItemVO

setVariancePercent(BigDecimal) - Method in class bb.common.PartCostVarianceListResult

setVariancePercentage(Map) - Method in class bb.common.BudgetListResult

setVariancePercentageTotal(BigDecimal) - Method in class bb.common.BudgetListResult

setVariancePercentageYTD(Map) - Method in class bb.common.BudgetListResult

setVendId(Byte) - Method in class bb.common.PurchaseWorkSheetItemVO

setVendId(Byte) - Method in class bb.common.WorkOrderWorkSheetItemVO

setVendIdWritein(String) - Method in class bb.common.PurchaseWorkSheetItemVO

setVendIdWritein(String) - Method in class bb.common.WorkOrderWorkSheetItemVO

setVendor(String) - Method in class bb.common.PurchaseOrderContractResult

setVendorAcknowledge(String) - Method in class bb.common.PurchaseOrderVO

setVendorAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.ApPrepayVO

setVendorAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.DisassembleWorkOrderVO

setVendorAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.InspectionConformanceReportVO

setVendorAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.PfReceiverVO

setVendorAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.PurchaseOrderVO

setVendorAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.ReceiverInfoVO

setVendorAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.ReceiverVO

setVendorAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.RequestForQuoteVO

setVendorAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.ReturnToVendorVO

setVendorAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.RtvShipperVO

setVendorAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.SwapOrderVO

setVendorAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.SwapReceiverVO

setVendorAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.SwapShipperVO

setVendorAddressInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.WorkOrderVO

setVendorAmount(BigDecimal) - Method in class bb.common.AddPayableWithoutReceiverAgent

setVendorApproved(Date) - Method in class bb.common.PoMessageVO

setVendorApprovedBy(String) - Method in class bb.common.PoMessageVO

setVendorAverageCost(BigDecimal) - Method in class bb.common.BillDetailCostResult

setVendorAverageCost(BigDecimal) - Method in class bb.common.BillSalesOfCostResult

setVendorAverageCost(BigDecimal) - Method in class bb.common.BillSalesXResult

setVendorAverageCost(BigDecimal) - Method in class bb.common.ToolListDetailCostResult

setVendorCarrier(String) - Method in class bb.common.CustomerVendorAddressVO

setVendorCarrierAccount(String) - Method in class bb.common.CustomerVendorAddressVO

setVendorCategory(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setVendorCategory(String) - Method in class bb.common.CustomerVendorAddressVO

setVendorCategory(String) - Method in class bb.common.LockedCustomerAddressResult

setVendorCategory(String) - Method in class bb.common.VendorCategoriesVO

setVendorComments(String) - Method in class bb.common.CustomerVendorAddressVO

setVendorCreditLimit(BigDecimal) - Method in class bb.common.CustomerVendorAddressVO

setVendorCurrency(String) - Method in class bb.common.PartVendorVO

setVendorCurrency(String) - Method in class bb.common.ToolVendorVO

setVendorDepositBank(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setVendorDepositBank(String) - Method in class bb.common.CustomerVendorAddressVO

setVendorDiscount(BigDecimal) - Method in class bb.common.CustomerVendorAddressVO

setVendorEmail(String) - Method in class bb.common.PfReceiverVO

setVendorFlag(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setVendorFlag(String) - Method in class bb.common.CustomerVendorAddressVO

setVendorFlag(String) - Method in class bb.common.LockedCustomerAddressResult

setVendorHighestCost(BigDecimal) - Method in class bb.common.BillDetailCostResult

setVendorHighestCost(BigDecimal) - Method in class bb.common.BillSalesOfCostResult

setVendorHighestCost(BigDecimal) - Method in class bb.common.BillSalesXResult

setVendorHighestCost(BigDecimal) - Method in class bb.common.ToolListDetailCostResult

setVendorId(String) - Method in class bb.common.AccountPayableCheckRunItemVO

setVendorId(String) - Method in class bb.common.AccountPayableCheckVO

setVendorId(String) - Method in class bb.common.AccountPayableInfoWithPrepayResult

setVendorId(String) - Method in class bb.common.AccountsPayableInfoVO

setVendorId(String) - Method in class bb.common.AccountsPayableVO

setVendorId(String) - Method in class bb.common.AddPayableWithoutReceiverAgent

setVendorId(String) - Method in class bb.common.AddProformaReceiverAgent

setVendorID(String) - Method in class bb.common.APAuditListResult

setVendorId(String) - Method in class bb.common.ApCheckRunListResult

setVendorId(String) - Method in class bb.common.APItemListResult

setVendorId(String) - Method in class bb.common.APPrepayInfoResult

setVendorId(String) - Method in class bb.common.ApPrepayVO

setVendorId(String) - Method in class bb.common.APTaxForZipcodeListResult

setVendorId(String) - Method in class bb.common.BB2PartInSitItemResult

setVendorId(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setVendorId(String) - Method in class bb.common.CustomerVendorAddressVO

setVendorID(String) - Method in class bb.common.DisassembleWorkOrderIssueVO

setVendorId(String) - Method in class bb.common.DisassembleWorkOrderIssuingResult

setVendorId(String) - Method in class bb.common.DisassembleWorkOrderItemListResult

setVendorId(String) - Method in class bb.common.DisassembleWorkOrderListResult

setVendorId(String) - Method in class bb.common.DisassembleWorkOrderReceivingResult

setVendorId(String) - Method in class bb.common.DisassembleWorkOrderVO

setVendorId(String) - Method in class bb.common.DWOIssueDetail

setVendorId(String) - Method in class bb.common.EcnPOOrderResult

setVendorId(String) - Method in class bb.common.EcnWOOrderResult

setVendorId(String) - Method in class bb.common.IcrItemListResult

setVendorId(String) - Method in class bb.common.IcrListResult

setVendorId(String) - Method in class bb.common.InspectionConformanceReportItemInfo

setVendorId(String) - Method in class bb.common.InspectionConformanceReportVO

setVendorId(String) - Method in class bb.common.IssuingResult

setVendorId(String) - Method in class bb.common.JobProcessSheetListResult

setVendorId(String) - Method in class bb.common.JobProcessSheetResult

setVendorId(String) - Method in class bb.common.MakeAccountPayableAgent

setVendorId(String) - Method in class bb.common.MakeCheckAgent

setVendorId(String) - Method in class bb.common.NcrReportListResult

setVendorId(String) - Method in class bb.common.NonConformanceReportVO

setVendorID(String) - Method in class bb.common.OrderVendorItem

setVendorId(String) - Method in class bb.common.PartInWipForIDListResult

setVendorId(String) - Method in class bb.common.PartIssuedVO

setVendorId(String) - Method in class bb.common.PartOnhandCostVO

setVendorId(String) - Method in class bb.common.PartReceivedVO

setVendorId(String) - Method in class bb.common.PartVendorVO

setVendorId(String) - Method in class bb.common.PfReceiverItemVO

setVendorId(String) - Method in class bb.common.PfReceiverVO

setVendorId(String) - Method in class bb.common.PO2POAgent

setVendorId(String) - Method in class bb.common.PoMessageListResult

setVendorId(String) - Method in class bb.common.PoMessageVO

setVendorId(String) - Method in class bb.common.POReceiverItemListResult

setVendorId(String) - Method in class bb.common.POStatisticsResult

setVendorId(String) - Method in class bb.common.POSurveyReportAgent

setVendorId(String) - Method in class bb.common.POSurveyReportVO

setVendorId(String) - Method in class bb.common.PrepayAgent

setVendorId(String) - Method in class bb.common.ProformaReceiverPackingBoxAgent

setVendorId(String) - Method in class bb.common.PrPackingBoxItemVO

setVendorId(String) - Method in class bb.common.PrPackingBoxVO

setVendorId(String) - Method in class bb.common.PrReceiverListResult

setVendorId(String) - Method in class bb.common.PurchaseOrderCheckListResult

setVendorId(String) - Method in class bb.common.PurchaseOrderItemListResult

setVendorId(String) - Method in class bb.common.PurchaseOrderListResult

setVendorId(String) - Method in class bb.common.PurchaseOrderOnOrderResult

setVendorId(String) - Method in class bb.common.PurchaseOrderOpenDueListResult

setVendorId(String) - Method in class bb.common.PurchaseOrderVO

setVendorId(String) - Method in class bb.common.ReceiverInfoVO

setVendorId(String) - Method in class bb.common.ReceiverVO

setVendorId(String) - Method in class bb.common.ReceivingResult

setVendorId(String) - Method in class bb.common.RequestForQuoteCheckListResult

setVendorId(String) - Method in class bb.common.RequestForQuoteItemListResult

setVendorId(String) - Method in class bb.common.RequestForQuoteListResult

setVendorId(String) - Method in class bb.common.RequestForQuoteVO

setVendorId(String) - Method in class bb.common.ReturnToVendorByDateListResult

setVendorId(String) - Method in class bb.common.ReturnToVendorCheckListResult

setVendorId(String) - Method in class bb.common.ReturnToVendorItemListResult

setVendorId(String) - Method in class bb.common.ReturnToVendorListResult

setVendorId(String) - Method in class bb.common.ReturnToVendorVO

setVendorId(String) - Method in class bb.common.RfqMessageListResult

setVendorId(String) - Method in class bb.common.RfqMessageVO

setVendorId(String) - Method in class bb.common.RtvShipperInfoVO

setVendorId(String) - Method in class bb.common.RtvShipperItemListResult

setVendorId(String) - Method in class bb.common.RtvShipperListResult

setVendorId(String) - Method in class bb.common.RtvShipperVO

setVendorId(String) - Method in class bb.common.ShipListOwnerAttributeVO

setVendorId(String) - Method in class bb.common.SO2POAgent

setVendorId(String) - Method in class bb.common.SO2WOAgent

setVendorId(String) - Method in class bb.common.StockTransactionPOReceiverResult

setVendorId(String) - Method in class bb.common.StockTransactionWOReceiverResult

setVendorId(String) - Method in class bb.common.SwapOrderItemListResult

setVendorId(String) - Method in class bb.common.SwapOrderListResult

setVendorId(String) - Method in class bb.common.SwapOrderVO

setVendorId(String) - Method in class bb.common.SwapReceiverListResult

setVendorId(String) - Method in class bb.common.SwapReceiverVO

setVendorId(String) - Method in class bb.common.SwapShipperListResult

setVendorId(String) - Method in class bb.common.SwapShipperOnOrderResult

setVendorId(String) - Method in class bb.common.SwapShipperVO

setVendorId(String) - Method in class bb.common.TempReceiverWithoutAPInfo

setVendorId(String) - Method in class bb.common.ToolVendorVO

setVendorId(String) - Method in class bb.common.VendorGroupUserVO

setVendorId(String) - Method in class bb.common.VendorPartPK

setVendorId(String) - Method in class bb.common.VendorQtyPricePK

setVendorId(String) - Method in class bb.common.VendorTotalAmountInPO

setVendorId(String) - Method in class bb.common.WO2WOAgent

setVendorId(String) - Method in class bb.common.WoItemPickListResult

setVendorId(String) - Method in class bb.common.WOReceiverDetail

setVendorId(String) - Method in class bb.common.WorkCenterRunTimeListResult

setVendorId(String) - Method in class bb.common.WorkCenterVendorPK

setVendorId(String) - Method in class bb.common.WorkOrderCheckListResult

setVendorID(String) - Method in class bb.common.WorkOrderItemCanAssyAgent

setVendorId(String) - Method in class bb.common.WorkOrderItemLaborCostListResult

setVendorId(String) - Method in class bb.common.WorkOrderItemListResult

setVendorId(String) - Method in class bb.common.WorkOrderItemReviewCostResult

setVendorId(String) - Method in class bb.common.WorkOrderItemTimeDetailVO

setVendorID(String) - Method in class bb.common.WorkOrderItemToIssueResult

setVendorId(String) - Method in class bb.common.WorkOrderListResult

setVendorId(String) - Method in class bb.common.WorkOrderOverIssueListResult

setVendorId(String) - Method in class bb.common.WorkOrderTimeCardVO

setVendorId(String) - Method in class bb.common.WorkOrderVO

setVendorIncoterm(String) - Method in class bb.common.CustomerVendorAddressVO

setVendorIncotermPlacePort(String) - Method in class bb.common.CustomerVendorAddressVO

setVendorInfo(CustomerVendorAddressInfoVO) - Method in class bb.common.VendorContractPriceVendorVO

setVendorInvoice(String) - Method in class bb.common.AccountPayableCheckRunItemVO

setVendorInvoice(String) - Method in class bb.common.AccountPayableCheckVO

setVendorInvoice(String) - Method in class bb.common.AccountPayableInfoWithPrepayResult

setVendorInvoice(String) - Method in class bb.common.AccountsPayableInfoVO

setVendorInvoice(String) - Method in class bb.common.AccountsPayableVO

setVendorInvoice(String) - Method in class bb.common.AddPayableWithoutReceiverAgent

setVendorInvoice(String) - Method in class bb.common.APItemListResult

setVendorInvoice(String) - Method in class bb.common.ApPrepayVO

setVendorInvoice(String) - Method in class bb.common.GeneralLedgerByDateListResult

setVendorInvoice(String) - Method in class bb.common.GeneralLedgerListResult

setVendorInvoice(String) - Method in class bb.common.GeneralLedgerResult

setVendorInvoice(String) - Method in class bb.common.GeneralLedgerVO

setVendorInvoice(String) - Method in class bb.common.ReceiverAgent

setVendorInvoice(String) - Method in class bb.common.ReceiverInfoVO

setVendorInvoice(String) - Method in class bb.common.ReceiverShipAgent

setVendorInvoice(String) - Method in class bb.common.ReceiverVO

setVendorInvoice(String) - Method in class bb.common.TempArApAgingVO

setVendorInvoice(String) - Method in class bb.common.VendorStatementListResult

setVendorInvoiceDate(Date) - Method in class bb.common.AccountPayableCheckRunItemVO

setVendorInvoiceDate(Date) - Method in class bb.common.AccountsPayableInfoVO

setVendorInvoiceDate(Date) - Method in class bb.common.AccountsPayableVO

setVendorInvoiceDate(Date) - Method in class bb.common.APAgingItemListResult

setVendorInvoiceDate(Date) - Method in class bb.common.APItemListResult

setVendorInvoiceDate(Date) - Method in class bb.common.MakeAccountPayableAgent

setVendorInvoiceDate(Date) - Method in class bb.common.MakeDebitMemoAgent

setVendorInvoiceDate(Date) - Method in class bb.common.ReceiverAgent

setVendorInvoiceDate(Date) - Method in class bb.common.ReceiverInfoVO

setVendorInvoiceDate(Date) - Method in class bb.common.ReceiverShipAgent

setVendorInvoiceDate(Date) - Method in class bb.common.ReceiverVO

setVendorInvoiceNumber(String) - Method in class bb.common.MakeAccountPayableAgent

setVendorInvoiceNumber(String) - Method in class bb.common.MakeDebitMemoAgent

setVendorInvoiceNumber(String) - Method in class bb.common.PfReceiverItemVO

setVendorInvoiceTotal(BigDecimal) - Method in class bb.common.ApPrepayVO

setVendorInvoiceTotal(BigDecimal) - Method in class bb.common.MakeAccountPayableAgent

setVendorInvoiceTotal(BigDecimal) - Method in class bb.common.MakeDebitMemoAgent

setVendorItem(Byte) - Method in class bb.common.PartVendorPK

setVendorItems(Set) - Method in class bb.common.ShipListItemVOResult

setVendorLeadTime(BigDecimal) - Method in class bb.common.PartVendorVO

setVendorLeadTime(short) - Method in class bb.common.ToolVendorVO

setVendorLowestCost(BigDecimal) - Method in class bb.common.BillDetailCostResult

setVendorLowestCost(BigDecimal) - Method in class bb.common.BillSalesOfCostResult

setVendorLowestCost(BigDecimal) - Method in class bb.common.BillSalesXResult

setVendorLowestCost(BigDecimal) - Method in class bb.common.ToolListDetailCostResult

setVendorName(String) - Method in class bb.common.AccountPayableInfoWithPrepayResult

setVendorName(String) - Method in class bb.common.ApCheckRunListResult

setVendorName(String) - Method in class bb.common.APPrepayInfoResult

setVendorName(String) - Method in class bb.common.APTaxForZipcodeListResult

setVendorName(String) - Method in class bb.common.DisassembleWorkOrderIssuingResult

setVendorName(String) - Method in class bb.common.DisassembleWorkOrderItemListResult

setVendorName(String) - Method in class bb.common.DisassembleWorkOrderListResult

setVendorName(String) - Method in class bb.common.IcrItemListResult

setVendorName(String) - Method in class bb.common.IcrListResult

setVendorName(String) - Method in class bb.common.InspectionConformanceReportItemInfo

setVendorName(String) - Method in class bb.common.PartVendorVO

setVendorName(String) - Method in class bb.common.POStatisticsResult

setVendorName(String) - Method in class bb.common.POSurveyReportAgent

setVendorName(String) - Method in class bb.common.POSurveyReportVO

setVendorName(String) - Method in class bb.common.PrepayAgent

setVendorName(String) - Method in class bb.common.PrReceiverListResult

setVendorName(String) - Method in class bb.common.PurchaseOrderCheckListResult

setVendorName(String) - Method in class bb.common.PurchaseOrderListResult

setVendorName(String) - Method in class bb.common.ReceivingResult

setVendorName(String) - Method in class bb.common.RequestForQuoteCheckListResult

setVendorName(String) - Method in class bb.common.RequestForQuoteItemListResult

setVendorName(String) - Method in class bb.common.RequestForQuoteListResult

setVendorName(String) - Method in class bb.common.ReturnToVendorCheckListResult

setVendorName(String) - Method in class bb.common.ReturnToVendorItemListResult

setVendorName(String) - Method in class bb.common.ReturnToVendorListResult

setVendorName(String) - Method in class bb.common.SwapOrderListResult

setVendorName(String) - Method in class bb.common.SwapReceiverListResult

setVendorName(String) - Method in class bb.common.SwapShipperListResult

setVendorName(String) - Method in class bb.common.TempReceiverWithoutAPInfo

setVendorName(String) - Method in class bb.common.ToolVendorVO

setVendorName(String) - Method in class bb.common.WoItemPickListResult

setVendorName(String) - Method in class bb.common.WorkCenterVendorVO

setVendorName(String) - Method in class bb.common.WorkOrderCheckListResult

setVendorName(String) - Method in class bb.common.WorkOrderItemListResult

setVendorName(String) - Method in class bb.common.WorkOrderListResult

setVendorPackage(String) - Method in class bb.common.AccountsPayableInfoVO

setVendorPackage(String) - Method in class bb.common.AccountsPayableVO

setVendorPackage(String) - Method in class bb.common.POReceiverItemListResult

setVendorPackage(String) - Method in class bb.common.ReceiverInfoVO

setVendorPackage(String) - Method in class bb.common.ReceiverVO

setVendorPartFrom(String) - Method in class bb.common.VendorPartPK

setVendorPartNumber(String) - Method in class bb.common.VendorPartPK

setVendorPartType(String) - Method in class bb.common.VendorPartPK

setVendorPaymentVarianceAccount(String) - Method in class bb.common.AccountingSettingsVO

setVendorPicked(boolean) - Method in class bb.common.RtvShipperInfoVO

setVendorPicked(boolean) - Method in class bb.common.RtvShipperVO

setVendorPrice(BigDecimal) - Method in class bb.common.PartVendorVO

setVendorPrice(BigDecimal) - Method in class bb.common.ToolVendorVO

setVendorPurchases(BigDecimal) - Method in class bb.common.PaymentHistoryVO

setVendors(List<String>) - Method in class bb.common.HighUsagePartResult

setVendors(Set) - Method in class bb.common.PartVO

setVendors(Set) - Method in class bb.common.ToolVO

setVendorSalesOrder(String) - Method in class bb.common.POStatisticsResult

setVendorSalesOrder(String) - Method in class bb.common.POSurveyReportAgent

setVendorSalesOrder(String) - Method in class bb.common.POSurveyReportVO

setVendorSalesOrder(String) - Method in class bb.common.PurchaseOrderVO

setVendorSet(Set) - Method in class bb.common.ShipListAgent

setVendorShipDate(Date) - Method in class bb.common.POReceiverItemListResult

setVendorShipDate(Date) - Method in class bb.common.ReceiverAgent

setVendorShipDate(Date) - Method in class bb.common.ReceiverInfoVO

setVendorShipDate(Date) - Method in class bb.common.ReceiverVO

setVendorShipper(String) - Method in class bb.common.MakeAccountPayableAgent

setVendorShipperNumber(String) - Method in class bb.common.PfReceiverItemVO

setVendorShipperNumber(String) - Method in class bb.common.ReceiverAgent

setVendorShipperNumber(String) - Method in class bb.common.ReceiverShipAgent

setVendorShippingDays(byte) - Method in class bb.common.CustomerVendorAddressInfoVO

setVendorShippingDays(byte) - Method in class bb.common.CustomerVendorAddressVO

setVendorShipVia(String) - Method in class bb.common.CustomerVendorAddressVO

setVendorSO(String) - Method in class bb.common.ApPrepayVO

setVendorSO(String) - Method in class bb.common.PfReceiverVO

setVendorSO(String) - Method in class bb.common.PrReceiverListResult

setVendorSO(String) - Method in class bb.common.PrReceiverWithQualityListResult

setVendorSO(String) - Method in class bb.common.PurchaseOrderContractResult

setVendorSO(String) - Method in class bb.common.PurchaseOrderListResult

setVendorTaxRate(BigDecimal) - Method in class bb.common.CustomerVendorAddressVO

setVendorTerms(String) - Method in class bb.common.CustomerVendorAddressVO

setVendorTotal(BigDecimal) - Method in class bb.common.AccountPayableCheckRunItemVO

setVendorTotal(BigDecimal) - Method in class bb.common.AccountPayableInfoWithPrepayResult

setVendorTotal(BigDecimal) - Method in class bb.common.AccountsPayableInfoVO

setVendorTotal(BigDecimal) - Method in class bb.common.AccountsPayableVO

setVendorTotal(BigDecimal) - Method in class bb.common.APAuditListResult

setVendorTotal(BigDecimal) - Method in class bb.common.CheckRunItemTotalResult

setVendorTotal(BigDecimal) - Method in class bb.common.ReceiverInfoVO

setVendorTotal(BigDecimal) - Method in class bb.common.ReceiverVO

setVendorType(String) - Method in class bb.common.CustomerVendorTypeVO

setVendPartExist(boolean) - Method in class bb.common.ProformaReceiverPackingBoxItemAgent

setVersion(Integer) - Method in class bb.common.AccountingSettingsVO

setVersion(int) - Method in class bb.common.AccountPayableCheckRunItemVO

setVersion(int) - Method in class bb.common.AccountPayableCheckVO

setVersion(int) - Method in class bb.common.AccountReceivablePaymentVO

setVersion(Integer) - Method in class bb.common.AccountsPayableInfoVO

setVersion(Integer) - Method in class bb.common.AccountsPayableVO

setVersion(Integer) - Method in class bb.common.AccountsReceivableInfoVO

setVersion(Integer) - Method in class bb.common.AccountsReceivableVO

setVersion(int) - Method in class bb.common.ARPaymentRunItemVO

setVersion(Integer) - Method in class bb.common.BillVO

setVersion(Integer) - Method in class bb.common.CommonPrintTemplateVO

setVersion(Integer) - Method in class bb.common.CorrectiveActionRequestVO

setVersion(Integer) - Method in class bb.common.CustomerFeedbackVO

setVersion(Integer) - Method in class bb.common.CustomerReturnToVendorVO

setVersion(Integer) - Method in class bb.common.CustomerServiceIncidentVO

setVersion(Integer) - Method in class bb.common.CustomerVendorAddressVO

setVersion(Integer) - Method in class bb.common.DesignControlVO

setVersion(Integer) - Method in class bb.common.EmployeeCardVO

setVersion(Integer) - Method in class bb.common.EngineeringChangeRequestVO

setVersion(Integer) - Method in class bb.common.EngineeringChangeVO

setVersion(int) - Method in class bb.common.ExpenseVO

setVersion(int) - Method in class bb.common.GeneralLedgerSettingsVO

setVersion(Integer) - Method in class bb.common.InspectionConformanceReportVO

setVersion(Integer) - Method in class bb.common.InspectionReportInfoVO

setVersion(Integer) - Method in class bb.common.InspectionReportVO

setVersion(Integer) - Method in class bb.common.InventoryAdjustmentVO

setVersion(Integer) - Method in class bb.common.LabelTemplateVO

setVersion(Integer) - Method in class bb.common.ManufacturerAddressVO

setVersion(Integer) - Method in class bb.common.NonConformanceCodeVO

setVersion(Integer) - Method in class bb.common.NonConformanceReportVO

setVersion(Integer) - Method in class bb.common.NonproductivePickingVO

setVersion(Integer) - Method in class bb.common.OnLoanItemVO

setVersion(Integer) - Method in class bb.common.OnLoanVO

setVersion(Integer) - Method in class bb.common.OperatingInstructionsVO

setVersion(Integer) - Method in class bb.common.PartCertificateVO

setVersion(Integer) - Method in class bb.common.PartDescriptionVO

setVersion(Integer) - Method in class bb.common.PartInventoryVO

setVersion(Integer) - Method in class bb.common.PartManufacturerVO

setVersion(Integer) - Method in class bb.common.PartVendorVO

setVersion(Integer) - Method in class bb.common.PartVO

setVersion(Integer) - Method in class bb.common.PartWithOnhandsVO

setVersion(Integer) - Method in class bb.common.PreventiveActionRequestVO

setVersion(Integer) - Method in class bb.common.PrintTemplateVO

setVersion(Integer) - Method in class bb.common.QuoteVO

setVersion(Integer) - Method in class bb.common.RequestForRMAVO

setVersion(Integer) - Method in class bb.common.ReturnMaterialAuthorizationItemVO

setVersion(Integer) - Method in class bb.common.ReturnMaterialAuthorizationVO

setVersion(Integer) - Method in class bb.common.RMAReceiverVO

setVersion(int) - Method in class bb.common.RtvShipperInfoVO

setVersion(int) - Method in class bb.common.RtvShipperVO

setVersion(Integer) - Method in class bb.common.SalesOrderItemInfoVO

setVersion(Integer) - Method in class bb.common.SalesOrderItemVO

setVersion(Integer) - Method in class bb.common.SalesOrderVO

setVersion(Integer) - Method in class bb.common.SerialNumberVO

setVersion(Integer) - Method in class bb.common.ShipListOwnerVO

setVersion(Integer) - Method in class bb.common.ShipListVO

setVersion(int) - Method in class bb.common.SwapReceiverListResult

setVersion(int) - Method in class bb.common.SwapReceiverVO

setVersion(int) - Method in class bb.common.SwapShipperListResult

setVersion(int) - Method in class bb.common.SwapShipperVO

setVersion(Integer) - Method in class bb.common.ToolDescriptionVO

setVersion(Integer) - Method in class bb.common.ToolInventoryVO

setVersion(Integer) - Method in class bb.common.ToolListVO

setVersion(Integer) - Method in class bb.common.ToolManufacturerVO

setVersion(Integer) - Method in class bb.common.ToolVendorVO

setVersion(Integer) - Method in class bb.common.ToolVO

setVersion(Integer) - Method in class bb.common.ToolWithOnhandsVO

setVersion(int) - Method in class bb.common.TransferOrderVO

setVersion(Integer) - Method in class bb.common.WorkInstructionVO

setVersion(Integer) - Method in class bb.common.WorkOrderWorkInstructionVO

setVgAddress(String) - Method in class bb.common.CompanyVO

setVgPrincipalUserId(String) - Method in class bb.common.CompanyVO

setVgPrincipalUserName(String) - Method in class bb.common.CompanyVO

setVisibleInReport(boolean) - Method in class bb.common.AccountsChartCategoryVO

setVo(CurrencyVO) - Method in class bb.common.CurrencyAgent

setVolume(BigDecimal) - Method in class bb.common.BB2WeightInfoResult

setVolume(BigDecimal) - Method in class bb.common.PartBasicInfo

setVolume(BigDecimal) - Method in class bb.common.PartVO

setVolume(BigDecimal) - Method in class bb.common.PartWithOnhandsVO

setVolume(BigDecimal) - Method in class bb.common.SGBOMItemResult

setVolume(BigDecimal) - Method in class bb.common.ToolVO

setVolume(BigDecimal) - Method in class bb.common.ToolWithOnhandsVO

setVolumeUnit(String) - Method in class bb.common.BB2WeightInfoResult

setVolumeUnit(String) - Method in class bb.common.PartBasicInfo

setVolumeUnit(String) - Method in class bb.common.PartVO

setVolumeUnit(String) - Method in class bb.common.PartWithOnhandsVO

setVolumeUnit(String) - Method in class bb.common.SGBOMItemResult

setVolumeUnit(String) - Method in class bb.common.ToolVO

setVolumeUnit(String) - Method in class bb.common.ToolWithOnhandsVO

setWageLabor(List) - Method in class bb.common.ProfitLossStatementResult

setWallDiameter(BigDecimal) - Method in class bb.common.PartMaterialReportAgent

setWallOperator(String) - Method in class bb.common.PartMaterialReportAgent

setWanIp(String) - Method in class bb.common.DocumentInfoAgent

setWanIp(String) - Method in class bb.common.LogMiscDocumentVO

setWanIp(String) - Method in class bb.common.LogPartDocumentVO

setWanIp(String) - Method in class bb.common.LogPartDwfVO

setWanIp(String) - Method in class bb.common.LogPartDwgVO

setWanIp(String) - Method in class bb.common.MiscDocAgent

setWanIp(String) - Method in class bb.common.OperationLogVO

setWanIp(String) - Method in class bb.common.PartDwfAgent

setWanIp(String) - Method in class bb.common.PartDwgAgent

setWareAcceptEmployee(String) - Method in class bb.common.POSurveyReportVO

setWarehouse(String) - Method in class bb.common.PartOnhandVO

setWareHouse(String) - Method in class bb.common.ReceiverAgent

setWareHouse(String) - Method in class bb.common.ReceiverShipAgent

setWarehouse(String) - Method in class bb.common.ToolOnhandVO

setWarehouseLocationSplitChar(String) - Method in class bb.common.CompanyVO

setWarehouseName(String) - Method in class bb.common.WareHousePartPrefixKeeperVO

setWarehousePrefix(String) - Method in class bb.common.WarehouseTransferPK

setWarehousePrefix(String) - Method in class bb.common.WarehouseVO

setWarehousePrefix(String) - Method in class bb.common.WoItemPickListItemResult

setWarehousePrefixTransferTo(String) - Method in class bb.common.WarehouseTransferPK

setWarning(String) - Method in class bb.common.DataFilterVO

setWarning(boolean) - Method in class bb.common.EquipmentListResult

setWarningWhenTwoPartInOneLocation(boolean) - Method in class bb.common.CompanyVO

setWasWiRevised(String) - Method in class bb.common.WorkInstructionRequestForChangeVO

setWcActivity(String) - Method in class bb.common.WorkOrderItemTimeDetailVO

setWcDesc(String) - Method in class bb.common.WorkInstructionSeqAuditListResult

setWcDescription(String) - Method in class bb.common.JobProcessSheetItemResult

setWcDescription(String) - Method in class bb.common.WorkInstructionSummaryItemResult

setWcID(String) - Method in class bb.common.WorkCenterAgent

setWebSite(String) - Method in class bb.common.CustomerVendorAddressVO

setWebSite(String) - Method in class bb.common.ManufacturerAddressInfoVO

setWebSite(String) - Method in class bb.common.ManufacturerAddressVO

setWeight(BigDecimal) - Method in class bb.common.BB2PartTotalOnhandDetailResult

setWeight(BigDecimal) - Method in class bb.common.BB2WeightInfoResult

setWeight(String) - Method in class bb.common.PackingBoxItemVO

setWeight(float) - Method in class bb.common.PartBasicInfo

setWeight(float) - Method in class bb.common.PartWithOnhandDetailInfoResult

setWeight(float) - Method in class bb.common.SGBOMItemResult

setWeight(BigDecimal) - Method in class bb.common.SGCustRequestForQuoteItemResult

setWeight(float) - Method in class bb.common.SGPartCatalogResult

setWeight(Float) - Method in class bb.common.SGQuoteCartListResult

setWeight(float) - Method in class bb.common.WOReceiverDetail

setWeight(float) - Method in class bb.common.WorkOrderItemListResult

setWeightUnit(String) - Method in class bb.common.BB2PartTotalOnhandDetailResult

setWeightUnit(String) - Method in class bb.common.BB2WeightInfoResult

setWeightUnit(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setWeightUnit(String) - Method in class bb.common.CustomerVendorAddressVO

setWeightUnit(String) - Method in class bb.common.PackingBoxVO

setWeightUnit(String) - Method in class bb.common.PartBasicInfo

setWeightUnit(String) - Method in class bb.common.PartWithOnhandDetailInfoResult

setWeightUnit(String) - Method in class bb.common.PrPackingBoxVO

setWeightUnit(String) - Method in class bb.common.SGBOMItemResult

setWeightUnit(String) - Method in class bb.common.SGCustRequestForQuoteItemResult

setWeightUnit(String) - Method in class bb.common.SGPartCatalogResult

setWeightUnit(String) - Method in class bb.common.SGQuoteCartListResult

setWeightUnit(String) - Method in class bb.common.SGQuoteCartVO

setWeightUnit(String) - Method in class bb.common.SGWeightUnitVO

setWeightUnit(String) - Method in class bb.common.WOReceiverDetail

setWeightUnit(String) - Method in class bb.common.WorkOrderItemListResult

setWeightUnitName(String) - Method in class bb.common.WeightUnitVO

setWi(String) - Method in class bb.common.BomItemWithOEMResult

setWi(String) - Method in class bb.common.PartBasicInfo

setWi(String) - Method in class bb.common.PartVO

setWi(String) - Method in class bb.common.PartWhereUsedItemResult

setWi(String) - Method in class bb.common.PartWithInventoryInfoListResult

setWi(String) - Method in class bb.common.PartWithOnhandsVO

setWi(String) - Method in class bb.common.ToolVO

setWi(String) - Method in class bb.common.ToolWhereUsedItemResult

setWi(String) - Method in class bb.common.ToolWithOnhandsVO

setWiDescription(String) - Method in class bb.common.WorkInstructionListResult

setWiDescription(String) - Method in class bb.common.WorkInstructionRequestForChangeVO

setWidth(Short) - Method in class bb.common.BB2Picture

setWidth(int) - Method in class bb.common.CommonPrintTemplateVO

setWidth(int) - Method in class bb.common.LabelTemplateItemVO

setWidth(int) - Method in class bb.common.LabelTemplateVO

setWidth(Short) - Method in class bb.common.MiscDocAgent

setWidth(Short) - Method in class bb.common.PartPictureVO

setWidth(Short) - Method in class bb.common.SGPicturePK

setWidth(short) - Method in class bb.common.WorkInstructionPictureVO

setWifeName(String) - Method in class bb.common.SalesmanVO

setWiFlag(String) - Method in class bb.common.DisassembleWorkOrderItemVO

setWiFlag(String) - Method in class bb.common.WorkOrderItemVO

setWikiSpaceName(String) - Method in class bb.common.HelpServerVO

setWiNumber(String) - Method in class bb.common.WorkInstructionListResult

setWiNumber(String) - Method in class bb.common.WorkInstructionSequenceListResult

setWipQty(BigDecimal) - Method in class bb.common.PurchaseOrderItemListResult

setWipQty(BigDecimal) - Method in class bb.common.QuoteItemListResult

setWipQty(BigDecimal) - Method in class bb.common.SalesOrderItemListResult

setWireFeeAccount(String) - Method in class bb.common.ARPaymentRunVO

setWireFeeApNumber(String) - Method in class bb.common.ARPaymentRunVO

setWireTransferNo(String) - Method in class bb.common.ARPrepaymentWireTransferAgent

setWireTransferNo(String) - Method in class bb.common.PrepaymentWireTransferAgent

setWireTransferNo(String) - Method in class bb.common.WireTransferAgent

setWiRevisedDate(Date) - Method in class bb.common.WorkInstructionRequestForChangeVO

setWiSeqLength(int) - Method in class bb.common.CompanyVO

setWiSeqPk(WorkInstructionSequencePK) - Method in class bb.common.WorkInstructionSeqAuditListResult

setWiSequence(String) - Method in class bb.common.WorkInstructionRequestForChangeVO

setWiSequenceNumber(String) - Method in class bb.common.WorkInstructionSequenceListResult

setWiSetId(String) - Method in class bb.common.DisassembleWorkOrderItemPartDetailResult

setWiSetId(String) - Method in class bb.common.WorkOrderItemPartDetailResult

setWiSetId(String) - Method in class bb.common.WorkOrderItemTimeDetailResult

setWithPartHoldWOCount(Integer) - Method in class bb.common.WorkOrderInfoCenterResult

setWO(String) - Method in class bb.common.WorkOrderQueryInfo

setWoBoilerplate(String) - Method in class bb.common.WorkOrderBoilerplateVO

setWoComments(String) - Method in class bb.common.DisassembleWorkOrderItemListResult

setWoComments(String) - Method in class bb.common.JobProcessSheetResult

setWoComments(String) - Method in class bb.common.WorkOrderItemListResult

setWoDate(Date) - Method in class bb.common.WoItemPickListResult

setWoDate(Date) - Method in class bb.common.WorkOrderCheckListResult

setWoDate(Date) - Method in class bb.common.WorkOrderListResult

setWoDebitAccount(String) - Method in class bb.common.AccountingSettingsVO

setWoDetails(ArrayList) - Method in class bb.common.BB2PartTotalOndemandDetailResult

setWoDetails(ArrayList) - Method in class bb.common.BB2PartTotalOnorderDetailResult

setWoDetails(ArrayList) - Method in class bb.common.PartInMrpListResult

setWoDigits(byte) - Method in class bb.common.CompanyVO

setWoDisc(BigDecimal) - Method in class bb.common.WorkOrderItemVO

setWoDisc(BigDecimal) - Method in class bb.common.WorkOrderVO

setWOI(String) - Method in class bb.common.WorkOrderQueryInfo

setWoicCost(BigDecimal) - Method in class bb.common.WorkOrderReceiverVO

setWoicItem(short) - Method in class bb.common.WorkOrderTimeCardVO

setWoiQquantity(BigDecimal) - Method in class bb.common.WOItemPartDetailNotIssue

setWoiQty(BigDecimal) - Method in class bb.common.WorkOrderInWipResult

setWoiQtyAsm(BigDecimal) - Method in class bb.common.WorkOrderInWipResult

setWoisCost(BigDecimal) - Method in class bb.common.WorkOrderItemPartDetailInWipVO

setWoisCost(BigDecimal) - Method in class bb.common.WorkOrderReceiverVO

setWoisii(Short) - Method in class bb.common.PartIssuedVO

setWoisItem(short) - Method in class bb.common.WorkOrderTimeCardVO

setWoisStdCost(BigDecimal) - Method in class bb.common.WorkOrderItemPartDetailInWipVO

setWoisStdCost(BigDecimal) - Method in class bb.common.WorkOrderReceiverVO

setWoItemCount(int) - Method in class bb.common.WorkOrderOnTimeItemResult

setWoItemIssuePk(WorkOrderItemIssuePK) - Method in class bb.common.WoItemPickListItemResult

setWoItemItemPk(WorkOrderItemPK) - Method in class bb.common.JobProcessSheetListResult

setWoItemNumber(String) - Method in class bb.common.JobProcessSheetResult

setWoItemPk(WorkOrderItemPK) - Method in class bb.common.EcnWOOrderResult

setWoItemPk(WorkOrderItemPK) - Method in class bb.common.WoItemPickListResult

setWoItemPk(WorkOrderItemPK) - Method in class bb.common.WorkOrderItemListResult

setWoItemPk(WorkOrderItemPK) - Method in class bb.common.WorkOrderItemPartDetail

setWoItemPk(WorkOrderItemPK) - Method in class bb.common.WorkOrderItemPartDetailResult

setWoItemPk(WorkOrderItemPK) - Method in class bb.common.WorkOrderItemTimeDetailResult

setWoItems(List) - Method in class bb.common.WOItemPartDetailNotIssue

setWoItemStatus(String) - Method in class bb.common.WoItemPickListResult

setWoMade(BigDecimal) - Method in class bb.common.WorkOrderItemVO

setWoMade(BigDecimal) - Method in class bb.common.WorkOrderVO

setWoNotApprovedOnOrderList(ArrayList) - Method in class bb.common.MrpItemResult

setWoNumber(String) - Method in class bb.common.JobProcessSheetResult

setWoNumber(String) - Method in class bb.common.MiscDocAgent

setWoNumber(String) - Method in class bb.common.NcrReportListResult

setWoNumber(String) - Method in class bb.common.ScrapReportVO

setWoNumber(String) - Method in class bb.common.SerialNumberResult

setWoNumber(String) - Method in class bb.common.StockTransactionWOReceiverResult

setWoNumber(String) - Method in class bb.common.StockTransactionWOShipperResult

setWoNumber(String) - Method in class bb.common.WCLoadDetailResult

setWoNumber(String) - Method in class bb.common.WO2WOAgent

setWoNumber(String) - Method in class bb.common.WorkOrderCheckListResult

setWoNumber(String) - Method in class bb.common.WorkOrderDocumentVO

setWoNumber(String) - Method in class bb.common.WorkOrderItemCanAssyAgent

setWoNumber(String) - Method in class bb.common.WorkOrderListResult

setWoOnOrderList(ArrayList) - Method in class bb.common.MrpItemOrderDemandRecordsResult

setWoOnOrderList(ArrayList) - Method in class bb.common.MrpItemResult

setWoOpen(BigDecimal) - Method in class bb.common.WorkOrderItemVO

setWoOpen(BigDecimal) - Method in class bb.common.WorkOrderVO

setWoOrderItems(Set) - Method in class bb.common.EcnCheckOrderResult

setWoPrefix(String) - Method in class bb.common.CompanyVO

setWoProject(String) - Method in class bb.common.MrpReportAgent

setWoRequireDate(Date) - Method in class bb.common.WorkOrderWorkInstructionVO

setWorkAddress(String) - Method in class bb.common.EmployeeCardVO

setWorkAddress(String) - Method in class bb.common.SalesmanVO

setWorkCenter(String) - Method in class bb.common.JobProcessSheetItemResult

setWorkCenter(String) - Method in class bb.common.WCLoadDetailResult

setWorkCenter(WorkCenterVO) - Method in class bb.common.WorkCenterGroupItemVO

setWorkCenter(String) - Method in class bb.common.WorkCenterLoadListResult

setWorkCenter(String) - Method in class bb.common.WorkCenterRunTimeAgent

setWorkCenter(String) - Method in class bb.common.WorkCenterRunTimeListResult

setWorkCenter(String) - Method in class bb.common.WorkCenterRunTimeTotalResult

setWorkCenter(String) - Method in class bb.common.WorkInstructionSeqAuditListResult

setWorkCenter(String) - Method in class bb.common.WorkInstructionSequenceListResult

setWorkCenter(String) - Method in class bb.common.WorkInstructionSequenceVO

setWorkCenter(String) - Method in class bb.common.WorkInstructionSummaryItemResult

setWorkCenter(String) - Method in class bb.common.WorkOrderItemSeqWCLoadResult

setWorkCenter(String) - Method in class bb.common.WorkOrderItemTimeDetailVO

setWorkCenter(String) - Method in class bb.common.WorkOrderTimeCardVO

setWorkCenterGroupFlag(String) - Method in class bb.common.WorkCenterVO

setWorkCenterGroupId(String) - Method in class bb.common.WorkCenterGroupItemPK

setWorkCenterGroupId(String) - Method in class bb.common.WorkCenterVO

setWorkCenterGroupItemNumber(String) - Method in class bb.common.WorkCenterGroupItemPK

setWorkCenterId(String) - Method in class bb.common.EquipmentListResult

setWorkCenterId(String) - Method in class bb.common.EquipmentVO

setWorkCenterId(String) - Method in class bb.common.ShipListOwnerAttributeVO

setWorkCenterId(String) - Method in class bb.common.WC2WCAgent

setWorkCenterId(String) - Method in class bb.common.WCLoadByDateResult

setWorkCenterId(String) - Method in class bb.common.WorkCenterGroupItemVO

setWorkCenterId(String) - Method in class bb.common.WorkCenterVendorPK

setWorkCenterId(String) - Method in class bb.common.WorkCenterVO

setWorkCenterId(String) - Method in class bb.common.WorkInstructionRequestForChangeVO

setWorkCenterId(String) - Method in class bb.common.WorkOrderItemLaborCostListResult

setWorkCenterId(String) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setWorkCenterItem(int) - Method in class bb.common.WorkOrderItemSeqWCLoadResult

setWorkCenterItem(int) - Method in class bb.common.WorkOrderWorkInstructionSequenceDateAgent

setWorkCenterItem(int) - Method in class bb.common.WorkOrderWorkInstructionSequenceVO

setWorkCenterItems(Set<WorkCenterVO>) - Method in class bb.common.WorkCenterVO

setWorkCenterLike(String) - Method in class bb.common.WorkCenterLoadAgent

setWorkCenterSet(Set) - Method in class bb.common.ShipListAgent

setWorkCenterType(String) - Method in class bb.common.WorkCenterVO

setWorkCenterVendors(Set) - Method in class bb.common.WorkCenterVO

setWorkComments(String) - Method in class bb.common.CustomEmployeeVO

setWorkDate(Long) - Method in class bb.common.WorkCalendarVO

setWorkDate(Long) - Method in class bb.common.WorkPeriodVO

setWorkerCost(BigDecimal) - Method in class bb.common.WorkOrderItemLaborCostListResult

setWorkerHoursPerDay(BigDecimal) - Method in class bb.common.WorkCenterVO

setWorkerOrderNumber(String) - Method in class bb.common.PartCertificateVO

setWorkerPay(BigDecimal) - Method in class bb.common.WorkCenterVO

setWorkerPerformance(BigDecimal) - Method in class bb.common.WorkCenterVO

setWorkerQty(BigDecimal) - Method in class bb.common.WorkCenterVO

setWorkFlowData(byte[]) - Method in class bb.common.WorkFlowVO

setWorkFlowName(String) - Method in class bb.common.WorkFlowVO

setWorking(boolean) - Method in class bb.common.StaffWorkingInformationResult

setWorkingInfo(String) - Method in class bb.common.StaffWorkingInformationResult

setWorkInProcessQty(BigDecimal) - Method in class bb.common.BB2PartInventoryResult

setWorkInProcessQty(BigDecimal) - Method in class bb.common.HistoricalInventoryVO

setWorkInProcessQty(BigDecimal) - Method in class bb.common.PartInventoryVO

setWorkInProcessQty(BigDecimal) - Method in class bb.common.PartOnHandWithPartBasicInfoResult

setWorkInProcessQty(BigDecimal) - Method in class bb.common.PhysicalInventoryListResult

setWorkInProcessQty(BigDecimal) - Method in class bb.common.PhysicalInventoryVO

setWorkInProcessQty(BigDecimal) - Method in class bb.common.ToolInventoryVO

setWorkInsctructionSequence(String) - Method in class bb.common.WorkOrderTimeCardVO

setWorkInstructionPictures(Set) - Method in class bb.common.WorkInstructionSequenceVO

setWorkInstructionRev(String) - Method in class bb.common.WorkInstructionListResult

setWorkInstructionRev(String) - Method in class bb.common.WorkInstructionSequenceListResult

setWorkInstructionRev(String) - Method in class bb.common.WorkInstructionVO

setWorkInstructionRev(String) - Method in class bb.common.WorkOrderWorkInstructionVO

setWorkInstructionSequence(String) - Method in class bb.common.WorkOrderItemTimeDetailVO

setWorkInstructionSequence(String) - Method in class bb.common.WorkOrderWorkInstructionSequencePK

setWorkOrder(String) - Method in class bb.common.IcrItemListResult

setWorkOrder(String) - Method in class bb.common.IcrListResult

setWorkOrder(String) - Method in class bb.common.InspectionConformanceReportItemInfo

setWorkOrder(String) - Method in class bb.common.InspectionConformanceReportVO

setWorkOrder(String) - Method in class bb.common.WorkCenterAgent

setWorkOrderAndItemNumber(String) - Method in class bb.common.OperatingInstructionsUserStatisticalResult

setWorkOrderAndItemNumber(String) - Method in class bb.common.OperatingInstructionsVO

setWorkOrderComments(String) - Method in class bb.common.WorkOrderVO

setWorkOrderCostControlBy(String) - Method in class bb.common.CompanyVO

setWorkOrderCostStart(BigDecimal) - Method in class bb.common.CompanyVO

setWorkOrderItem(Set) - Method in class bb.common.WorkOrderVO

setWorkOrderItemComments(String) - Method in class bb.common.WoItemPickListResult

setWorkOrderItemComments(String) - Method in class bb.common.WorkOrderItemIssuedTotalResult

setWorkOrderItemComments(String) - Method in class bb.common.WorkOrderItemVO

setWorkOrderItemIssueReferenceDocOne(WorkOrderItemIssuePK, String) - Method in interface bb.common.box.WorkOrderBox

setWorkOrderItemNumber(String) - Method in class bb.common.EmployeeLaborAgent

setWorkorderItemNumber(String) - Method in class bb.common.PartInWipForIDListResult

setWorkOrderItemNumber(String) - Method in class bb.common.PartIssuedVO

setWorkOrderItemNumber(String) - Method in class bb.common.SGSaleItemVO

setWorkOrderItemNumber(String) - Method in class bb.common.WOItemPartDetailNotIssue

setWorkOrderItemNumber(String) - Method in class bb.common.WoItemWorkInstructionListResult

setWorkOrderItemNumber(String) - Method in class bb.common.WOReceiverDetail

setWorkOrderItemNumber(String) - Method in class bb.common.WorkCenterRunTimeListResult

setWorkOrderItemNumber(String) - Method in class bb.common.WorkOrderIssuedOrderListResult

setWorkOrderItemNumber(String) - Method in class bb.common.WorkOrderItemInfoResult

setWorkOrderItemNumber(String) - Method in class bb.common.WorkOrderItemInWipListResult

setWorkOrderItemNumber(String) - Method in class bb.common.WorkOrderItemIssuedTotalResult

setWorkOrderItemNumber(String) - Method in class bb.common.WorkOrderItemIssuePK

setWorkOrderItemNumber(String) - Method in class bb.common.WorkOrderItemLaborCostListResult

setWorkOrderItemNumber(String) - Method in class bb.common.WorkOrderItemPartDetailInWipVO

setWorkOrderItemNumber(String) - Method in class bb.common.WorkOrderItemPK

setWorkOrderItemNumber(String) - Method in class bb.common.WorkOrderItemTimeDetailVO

setWorkOrderItemNumber(String) - Method in class bb.common.WorkOrderOverIssueListResult

setWorkOrderItemNumber(String) - Method in class bb.common.WorkOrderReceiverVO

setWorkOrderItemNumber(String) - Method in class bb.common.WorkOrderTimeCardVO

setWorkOrderItemNumber(String) - Method in class bb.common.WorkOrderWorkInstructionListResult

setWorkOrderItemNumber(String) - Method in class bb.common.WorkOrderWorkInstructionPK

setWorkOrderItemNumber(String) - Method in class bb.common.WorkOrderWorkInstructionSequencePK

setWorkOrderItemPk(WorkOrderItemPK) - Method in class bb.common.IssueItemAgent

setWorkOrderItemPK(WorkOrderItemPK) - Method in class bb.common.IssuingItemResult

setWorkOrderItemPk(WorkOrderItemPK) - Method in class bb.common.WorkOrderInWipResult

setWorkOrderItemPk(WorkOrderItemPK) - Method in class bb.common.WorkOrderOnDemandResult

setWorkOrderItemPk(WorkOrderItemPK) - Method in class bb.common.WorkOrderOnOrderResult

setWorkOrderItemPrivateNotes(String) - Method in class bb.common.WoItemPickListResult

setWorkOrderItemPrivateNotes(String) - Method in class bb.common.WorkOrderItemVO

setWorkOrderItemQuantity(BigDecimal) - Method in class bb.common.WorkOrderOnDemandResult

setWorkOrderItemReferenceDocOne(WorkOrderItemPK, String) - Method in interface bb.common.box.WorkOrderBox

setWorkOrderItemReferenceDocTwo(WorkOrderItemPK, String) - Method in interface bb.common.box.WorkOrderBox

setWorkOrderNumber(String) - Method in class bb.common.DesignControlInfoVO

setWorkOrderNumber(String) - Method in class bb.common.DesignControlVO

setWorkOrderNumber(String) - Method in class bb.common.EmployeeLaborAgent

setWorkOrderNumber(String) - Method in class bb.common.MrpReportAgent

setWorkOrderNumber(String) - Method in class bb.common.NcrNeedToScrapListResult

setWorkOrderNumber(String) - Method in class bb.common.NonConformanceReportVO

setWorkOrderNumber(String) - Method in class bb.common.PartCertificateListResult

setWorkOrderNumber(String) - Method in class bb.common.PartInWipForIDListResult

setWorkOrderNumber(String) - Method in class bb.common.PartIssuedVO

setWorkOrderNumber(String) - Method in class bb.common.SGSaleItemVO

setWorkOrderNumber(String) - Method in class bb.common.WOItemPartDetailNotIssue

setWorkOrderNumber(String) - Method in class bb.common.WoItemWorkInstructionListResult

setWorkOrderNumber(String) - Method in class bb.common.WOReceiverDetail

setWorkOrderNumber(String) - Method in class bb.common.WorkCenterRunTimeListResult

setWorkOrderNumber(String) - Method in class bb.common.WorkOrderIssuedOrderListResult

setWorkOrderNumber(String) - Method in class bb.common.WorkOrderItemInfoResult

setWorkOrderNumber(String) - Method in class bb.common.WorkOrderItemInWipListResult

setWorkOrderNumber(String) - Method in class bb.common.WorkOrderItemIssuedTotalResult

setWorkOrderNumber(String) - Method in class bb.common.WorkOrderItemIssuePK

setWorkOrderNumber(String) - Method in class bb.common.WorkOrderItemLaborCostListResult

setWorkOrderNumber(String) - Method in class bb.common.WorkOrderItemPartDetailInWipVO

setWorkOrderNumber(String) - Method in class bb.common.WorkOrderItemPK

setWorkOrderNumber(String) - Method in class bb.common.WorkOrderItemTimeDetailVO

setWorkOrderNumber(String) - Method in class bb.common.WorkOrderOverIssueListResult

setWorkOrderNumber(String) - Method in class bb.common.WorkOrderReceiverVO

setWorkOrderNumber(String) - Method in class bb.common.WorkOrderTimeCardVO

setWorkOrderNumber(String) - Method in class bb.common.WorkOrderVO

setWorkOrderNumber(String) - Method in class bb.common.WorkOrderWorkInstructionListResult

setWorkOrderNumber(String) - Method in class bb.common.WorkOrderWorkInstructionPK

setWorkOrderNumber(String) - Method in class bb.common.WorkOrderWorkInstructionSequencePK

setWorkOrderOnDemandResult(ArrayList) - Method in class bb.common.BB2PartMrpResult

setWorkOrderOnOrderResult(ArrayList) - Method in class bb.common.BB2PartMrpResult

setWorkOrderOverPercent(BigDecimal) - Method in class bb.common.CompanyVO

setWorkOrderPrivateNotes(String) - Method in class bb.common.WorkOrderVO

setWorkOrderWorkSheetItem(Set) - Method in class bb.common.WorkOrderWorkSheetVO

setWorkSheetItem(PurchaseWorkSheetItemVO) - Method in class bb.common.PurchaseWorkSheetItemWithRelatedInfoResult

setWorkSheetItem(WorkOrderWorkSheetItemVO) - Method in class bb.common.WorkOrderWorkSheetItemWithRelatedInfoResult

setWorkSheetNumber(Integer) - Method in class bb.common.AddPhysicalInventoryAgent

setWorkSheetNumber(Integer) - Method in class bb.common.CycleCountPK

setWorkSheetNumber(Integer) - Method in class bb.common.CycleCountStatusVO

setWorkSheetNumber(Integer) - Method in class bb.common.PhysicalInventoryPK

setWorkSheetNumber(Integer) - Method in class bb.common.PhysicalInventoryStatusVO

setWorkSheetNumber(Integer) - Method in class bb.common.PurchaseWorkSheetItemPK

setWorkSheetNumber(Integer) - Method in class bb.common.PurchaseWorkSheetPK

setWorkSheetNumber(int) - Method in class bb.common.TakeCycleCountAgent

setWorkSheetNumber(Integer) - Method in class bb.common.WorkOrderWorkSheetItemPK

setWorkSheetNumber(Integer) - Method in class bb.common.WorkOrderWorkSheetPK

setWorkTime(Date) - Method in class bb.common.CustomEmployeeVO

setWorkTime(String) - Method in class bb.common.WCLoadOnDateResult

setWorkTimePeriod(String) - Method in class bb.common.CompanyVO

setWorkType(String) - Method in class bb.common.CustomEmployeeVO

setWorkTypeAfter(String) - Method in class bb.common.CustomEmployeeVO

setWoStartDate(Date) - Method in class bb.common.WorkOrderWorkInstructionVO

setWoStatus(Collection) - Method in class bb.common.POAndWOStatusResult

setWoStatus(String) - Method in class bb.common.WoItemPickListResult

setWoSub(BigDecimal) - Method in class bb.common.WorkOrderItemVO

setWoSub(BigDecimal) - Method in class bb.common.WorkOrderVO

setWoTax(BigDecimal) - Method in class bb.common.WorkOrderItemVO

setWoTotal(BigDecimal) - Method in class bb.common.WorkOrderItemVO

setWoTotal(BigDecimal) - Method in class bb.common.WorkOrderOnTimeItemResult

setWowiCurrentInstrucationSeq(String) - Method in class bb.common.WorkOrderItemListResult

setWowiCurrentInstrucationSeq(String) - Method in class bb.common.WorkOrderItemVO

setWowiCurrentInstrucationSeqWC(String) - Method in class bb.common.WorkOrderItemListResult

setWowiCurrentInstrucationSeqWC(String) - Method in class bb.common.WorkOrderItemVO

setWowiCurrentInstrucationSeqWCDesc(String) - Method in class bb.common.WorkOrderItemListResult

setWowiCurrentInstrucationSeqWCDesc(String) - Method in class bb.common.WorkOrderItemVO

setWowiPartAvgCost(BigDecimal) - Method in class bb.common.DisassembleWorkOrderItemListResult

setWowiPartAvgCost(BigDecimal) - Method in class bb.common.WorkOrderItemListResult

setWriteOffExpenseItems(List) - Method in class bb.common.ClosingStatementResult

setWriteOffExpenses(ClosingStatementTotalResult) - Method in class bb.common.ClosingStatementResult

setX(int) - Method in class bb.common.LabelTemplateItemVO

setXml(String) - Method in class bb.common.CustomSearchVO

setXregrade(String) - Method in class bb.common.NonConformanceReportVO

setXreject(String) - Method in class bb.common.NonConformanceReportVO

setXrework(String) - Method in class bb.common.NonConformanceReportVO

setXscrap(String) - Method in class bb.common.NonConformanceReportVO

setXwaiver(String) - Method in class bb.common.NonConformanceReportVO

setY(int) - Method in class bb.common.LabelTemplateItemVO

setYearBalance(BigDecimal) - Method in class bb.common.AccountsChartCategoryListResult

setYearBalance(BigDecimal) - Method in class bb.common.GlBalanceInfoResult

setYearBalanceFormula(String) - Method in class bb.common.AccountsChartCategoryVO

setYearCode(String) - Method in class bb.common.AccountingInfoDocumentVO

setYearCode(String) - Method in class bb.common.LogMiscDocumentVO

setYearCode(String) - Method in class bb.common.MiscDocAgent

setYearCreditAmount(BigDecimal) - Method in class bb.common.GlBalanceInfoResult

setYearDC(String) - Method in class bb.common.GlBalanceInfoResult

setYearDebitAmount(BigDecimal) - Method in class bb.common.GlBalanceInfoResult

setYearStorageAmount(BigDecimal) - Method in class bb.common.PurchaseOrderContractResult

setYearToDate(BigDecimal) - Method in class bb.common.ClosingStatementItemResult

setYearToDate(BigDecimal) - Method in class bb.common.ClosingStatementTotalResult

setYearUsage(BigDecimal) - Method in class bb.common.PartInventoryVO

setYearUsage(BigDecimal) - Method in class bb.common.PartWithOnhandDetailInfoResult

setYearUsage(BigDecimal) - Method in class bb.common.PurchaseOrderOpenDueListResult

setYearUsage(BigDecimal) - Method in class bb.common.ToolInventoryVO

setYrQty(BigDecimal) - Method in class bb.common.PartWithExcessiveInventoryListResult

setYrUsage(BigDecimal) - Method in class bb.common.BB2PartInfo

setYrUsage(BigDecimal) - Method in class bb.common.BB2PartTotalOnhandDetailResult

setYrUsage(BigDecimal) - Method in class bb.common.PartMaterialListResult

setYrUsage(BigDecimal) - Method in class bb.common.PartMaterialWhereUsedItemResult

setYtdReceiverCount(Integer) - Method in class bb.common.WareHousingInfoCenterResult

setYtdShipperCount(Integer) - Method in class bb.common.WareHousingInfoCenterResult

setYtrQty(BigDecimal) - Method in class bb.common.HighUsagePartResult

setYUsage(BigDecimal) - Method in class bb.common.StockTransactionPartInfoResult

setZerolocation(boolean) - Method in class bb.common.TakeCycleCountAgent

setZip(String) - Method in class bb.common.AccountPayableCheckVO

setZip(String) - Method in class bb.common.AccountReceivablePaymentVO

setZip(String) - Method in class bb.common.CustomerVendorAddressInfoVO

setZip(String) - Method in class bb.common.CustomerVendorAddressVO

setZip(String) - Method in class bb.common.CustomerVendorDescriptionVO

setZip(String) - Method in class bb.common.EmployeeHomeVO

setZip(String) - Method in class bb.common.LockedCustomerAddressResult

setZip(String) - Method in class bb.common.ManufacturerAddressInfoVO

setZip(String) - Method in class bb.common.ManufacturerAddressVO

setZip(String) - Method in class bb.common.ManufacturerDescriptionVO

setZip(String) - Method in class bb.common.SalesmanVO

setZip(String) - Method in class bb.common.SGCartCheckOutResult

setZip(String) - Method in class bb.common.SGCustRequestForQuoteListResult

setZip(String) - Method in class bb.common.SGCustRequestForQuoteResult

setZip(String) - Method in class bb.common.SGQuoteAddressResult

setZip(String) - Method in class bb.common.SGQuoteAddressVO

setZipcode(String) - Method in class bb.common.APTaxForZipcodeListResult

setZipcode(String) - Method in class bb.common.ARTaxForZipcodeListResult

setZipCode(String) - Method in class bb.common.ZipcodeTotalsResult

setZipCodeEnd(String) - Method in class bb.common.PosZipCodeTaxPK

setZipCodeFrom(String) - Method in class bb.common.ZipcodeTotalsResult

setZipCodeStart(String) - Method in class bb.common.PosZipCodeTaxPK

setZipCodeTo(String) - Method in class bb.common.ZipcodeTotalsResult

setZipId(String) - Method in class bb.common.ZipCodeVO

setZipName(String) - Method in class bb.common.ZipCodeVO

setZipTo(String) - Method in class bb.common.ZipCodeTaxVO

SEVENLEVEL - Static variable in class bb.common.Constant.AgeLevel

SEVENLEVEL - Static variable in class bb.common.Constant.WorkLevel

SG_CLIENT_ACCOUNT_ALREADY_EXIST - Static variable in class bb.common.BIZReason

SG_CLIENT_ACCOUNT_NOT_EXIST - Static variable in class bb.common.BIZReason

SG_CLIENT_PROGRAM_USER_ALREADY_EXIST - Static variable in class bb.common.BIZReason

SG_CLIENT_PROGRAM_USER_INFO_NOT_EXACT - Static variable in class bb.common.BIZReason

SG_CLIENT_PROGRAM_USER_NOT_EXIST - Static variable in class bb.common.BIZReason

SG_COMPANY_ALREADY_EXIST - Static variable in class bb.common.BIZReason

SG_COMPANY_NOT_EXIST - Static variable in class bb.common.BIZReason

SG_CUST_RFQ_ALREADY_EXIST - Static variable in class bb.common.BIZReason

SG_CUST_RFQ_ALREADY_QUOTED - Static variable in class bb.common.BIZReason

SG_CUST_RFQ_NOT_EXIST - Static variable in class bb.common.BIZReason

SG_CUST_RFQ_NOT_QUOTED - Static variable in class bb.common.BIZReason

SG_QUOTE_ADDRESS_ALREADY_EXIST - Static variable in class bb.common.BIZReason

SG_QUOTE_ADDRESS_NOT_EXIST - Static variable in class bb.common.BIZReason

SG_SALE_ITEM_NOT_EXIST - Static variable in class bb.common.BIZReason

SGBillItemPK - Class in bb.common

SGBillItemPK(String, String, String) - Constructor for class bb.common.SGBillItemPK
full constructor
SGBillItemPK() - Constructor for class bb.common.SGBillItemPK
default constructor
SGBillItemVO - Class in bb.common

SGBillItemVO() - Constructor for class bb.common.SGBillItemVO

SGBOMItemResult - Class in bb.common

SGBOMItemResult() - Constructor for class bb.common.SGBOMItemResult

SGBOMResult - Class in bb.common

SGBOMResult() - Constructor for class bb.common.SGBOMResult

SGCartCheckOutResult - Class in bb.common

SGCartCheckOutResult() - Constructor for class bb.common.SGCartCheckOutResult

SGCartLogin - Class in bb.common

SGCartLogin() - Constructor for class bb.common.SGCartLogin

SGClientAccountPK - Class in bb.common

SGClientAccountPK(String, String) - Constructor for class bb.common.SGClientAccountPK
full constructor
SGClientAccountPK() - Constructor for class bb.common.SGClientAccountPK
default constructor
SGClientAccountVO - Class in bb.common

SGClientAccountVO() - Constructor for class bb.common.SGClientAccountVO

SGClientLogin - Class in bb.common

SGClientLogin() - Constructor for class bb.common.SGClientLogin

SgClientProgramUserVO - Class in bb.common

SgClientProgramUserVO() - Constructor for class bb.common.SgClientProgramUserVO

SGCompanyPK - Class in bb.common

SGCompanyPK(String, String) - Constructor for class bb.common.SGCompanyPK
full constructor
SGCompanyPK() - Constructor for class bb.common.SGCompanyPK
default constructor
SGCompanyVO - Class in bb.common

SGCompanyVO() - Constructor for class bb.common.SGCompanyVO

SGCustomerCatalogPK - Class in bb.common

SGCustomerCatalogPK(String, String, String, String) - Constructor for class bb.common.SGCustomerCatalogPK
full constructor
SGCustomerCatalogPK(String, String, String) - Constructor for class bb.common.SGCustomerCatalogPK

SGCustomerCatalogPK() - Constructor for class bb.common.SGCustomerCatalogPK
default constructor
SGCustomerCatalogVO - Class in bb.common

SGCustomerCatalogVO(SGCustomerCatalogPK, String) - Constructor for class bb.common.SGCustomerCatalogVO
full constructor
SGCustomerCatalogVO() - Constructor for class bb.common.SGCustomerCatalogVO
default constructor
SGCustomerServiceRequestVO - Class in bb.common

SGCustomerServiceRequestVO() - Constructor for class bb.common.SGCustomerServiceRequestVO

SGCustRequestForQuoteItemPK - Class in bb.common

SGCustRequestForQuoteItemPK(String, String) - Constructor for class bb.common.SGCustRequestForQuoteItemPK
full constructor
SGCustRequestForQuoteItemPK() - Constructor for class bb.common.SGCustRequestForQuoteItemPK
default constructor
SGCustRequestForQuoteItemResult - Class in bb.common

SGCustRequestForQuoteItemResult() - Constructor for class bb.common.SGCustRequestForQuoteItemResult

SGCustRequestForQuoteItemVO - Class in bb.common

SGCustRequestForQuoteItemVO(SGCustRequestForQuoteItemPK, String, String, String, BigDecimal) - Constructor for class bb.common.SGCustRequestForQuoteItemVO
full constructor
SGCustRequestForQuoteItemVO() - Constructor for class bb.common.SGCustRequestForQuoteItemVO
default constructor
SGCustRequestForQuoteItemVO(SGCustRequestForQuoteItemPK, String, String, String) - Constructor for class bb.common.SGCustRequestForQuoteItemVO
minimal constructor
SGCustRequestForQuoteListResult - Class in bb.common

SGCustRequestForQuoteListResult() - Constructor for class bb.common.SGCustRequestForQuoteListResult

SGCustRequestForQuoteResult - Class in bb.common

SGCustRequestForQuoteResult() - Constructor for class bb.common.SGCustRequestForQuoteResult

SGCustRequestForQuoteVO - Class in bb.common

SGCustRequestForQuoteVO() - Constructor for class bb.common.SGCustRequestForQuoteVO
default constructor
SGDocPartPK - Class in bb.common

SGDocPartPK(String, String) - Constructor for class bb.common.SGDocPartPK
full constructor
SGDocPartPK() - Constructor for class bb.common.SGDocPartPK
default constructor
SGDocPartVO - Class in bb.common

SGDocPartVO() - Constructor for class bb.common.SGDocPartVO

SGDwgPicturePK - Class in bb.common

SGDwgPicturePK(String, String) - Constructor for class bb.common.SGDwgPicturePK
full constructor
SGDwgPicturePK() - Constructor for class bb.common.SGDwgPicturePK
default constructor
SGDwgPictureVO - Class in bb.common

SGDwgPictureVO() - Constructor for class bb.common.SGDwgPictureVO

SGLogLoginVO - Class in bb.common

SGLogLoginVO() - Constructor for class bb.common.SGLogLoginVO

SGPartCartAgent - Class in bb.common

SGPartCartAgent() - Constructor for class bb.common.SGPartCartAgent

SGPartCatalogResult - Class in bb.common

SGPartCatalogResult() - Constructor for class bb.common.SGPartCatalogResult

SGPartDocFlagResult - Class in bb.common

SGPartDocFlagResult() - Constructor for class bb.common.SGPartDocFlagResult

SGPartListItemResult - Class in bb.common

SGPartListItemResult() - Constructor for class bb.common.SGPartListItemResult

SGPartListResult - Class in bb.common

SGPartListResult() - Constructor for class bb.common.SGPartListResult

SGPicturePK - Class in bb.common

SGPicturePK(String, Short, Short) - Constructor for class bb.common.SGPicturePK
full constructor
SGPicturePK() - Constructor for class bb.common.SGPicturePK
default constructor
SGPictureVO - Class in bb.common

SGPictureVO() - Constructor for class bb.common.SGPictureVO

SGQuoteAddressResult - Class in bb.common

SGQuoteAddressResult() - Constructor for class bb.common.SGQuoteAddressResult

SGQuoteAddressVO - Class in bb.common

SGQuoteAddressVO() - Constructor for class bb.common.SGQuoteAddressVO

SGQuoteCartListResult - Class in bb.common

SGQuoteCartListResult() - Constructor for class bb.common.SGQuoteCartListResult

SGQuoteCartVO - Class in bb.common

SGQuoteCartVO() - Constructor for class bb.common.SGQuoteCartVO

SGQuoteLoginVO - Class in bb.common

SGQuoteLoginVO() - Constructor for class bb.common.SGQuoteLoginVO

SGSaleItemAgent - Class in bb.common

SGSaleItemAgent() - Constructor for class bb.common.SGSaleItemAgent

SGSaleItemVO - Class in bb.common

SGSaleItemVO() - Constructor for class bb.common.SGSaleItemVO

SGWeightUnitVO - Class in bb.common

SGWeightUnitVO() - Constructor for class bb.common.SGWeightUnitVO

SH - Static variable in class bb.common.Constant.Prefix

ShareHoldersEquityResult - Class in bb.common

ShareHoldersEquityResult() - Constructor for class bb.common.ShareHoldersEquityResult

SHIP - Static variable in class bb.common.Constant.NoticeAction

SHIP_LIST - Static variable in class bb.common.BizTarget

SHIP_LIST_HAS_EXIST - Static variable in class bb.common.BIZReason

SHIP_LIST_ITEM - Static variable in class bb.common.BizTarget

SHIP_LIST_NOT_EXIST - Static variable in class bb.common.BIZReason

SHIP_LIST_OWNER - Static variable in class bb.common.BizTarget

SHIP_LIST_OWNER_HAS_EXIST - Static variable in class bb.common.BIZReason

SHIP_LIST_OWNER_ITEM - Static variable in class bb.common.BizTarget

SHIP_LIST_OWNER_NOT_EXIST - Static variable in class bb.common.BIZReason

SHIP_QTY_IS_OVER_THAN_DWO_ITEM_ORDERED - Static variable in class bb.common.BIZReason

SHIP_QTY_IS_OVER_THAN_LOCATION_ONHAND - Static variable in class bb.common.BIZReason

SHIP_QTY_IS_OVER_THAN_ONHAND - Static variable in class bb.common.BIZReason

SHIP_QTY_IS_OVER_THAN_ONLOAN_ITEM_ORDERED - Static variable in class bb.common.BIZReason

SHIP_QTY_IS_OVER_THAN_RTV_ITEM_ORDERED - Static variable in class bb.common.BIZReason

SHIP_QTY_IS_OVER_THAN_SO_ITEM_ORDERED - Static variable in class bb.common.BIZReason

SHIP_QTY_IS_OVER_THAN_SWAP_ITEM_ORDERED - Static variable in class bb.common.BIZReason

SHIP_QTY_IS_OVER_THAN_TRANSFER_ITEM_ORDERED - Static variable in class bb.common.BIZReason

SHIP_QTY_IS_SMALLER_THAN_RECEIVE_QTY - Static variable in class bb.common.BIZReason

SHIP_TO_ID_IS_NOT_EXIST - Static variable in class bb.common.BIZReason

SHIPDATE - Static variable in class bb.common.Constant.DateType

ShipListAgent - Class in bb.common

ShipListAgent() - Constructor for class bb.common.ShipListAgent

ShipListInfoVO - Class in bb.common

ShipListInfoVO() - Constructor for class bb.common.ShipListInfoVO
default constructor
ShipListItemPK - Class in bb.common

ShipListItemPK(String, String, String) - Constructor for class bb.common.ShipListItemPK
full constructor
ShipListItemPK() - Constructor for class bb.common.ShipListItemPK
default constructor
ShipListItemRelatedDocResult - Class in bb.common

ShipListItemRelatedDocResult() - Constructor for class bb.common.ShipListItemRelatedDocResult

ShipListItemVO - Class in bb.common

ShipListItemVO() - Constructor for class bb.common.ShipListItemVO
default constructor
ShipListItemVOResult - Class in bb.common

ShipListItemVOResult() - Constructor for class bb.common.ShipListItemVOResult

ShipListOwnerAttributePK - Class in bb.common

ShipListOwnerAttributePK(String, Byte) - Constructor for class bb.common.ShipListOwnerAttributePK
full constructor
ShipListOwnerAttributePK() - Constructor for class bb.common.ShipListOwnerAttributePK
default constructor
ShipListOwnerAttributePK(String) - Constructor for class bb.common.ShipListOwnerAttributePK

ShipListOwnerAttributeVO - Class in bb.common

ShipListOwnerAttributeVO() - Constructor for class bb.common.ShipListOwnerAttributeVO
default constructor
ShipListOwnerVO - Class in bb.common

ShipListOwnerVO() - Constructor for class bb.common.ShipListOwnerVO
default constructor
ShipListVO - Class in bb.common

ShipListVO() - Constructor for class bb.common.ShipListVO
default constructor
shipPartToNCR(String, Set<PuttoInQAAgent>, Set) - Method in interface bb.common.box.WarehouseBox

Shipped - Static variable in class bb.common.Constant.Status

SHIPPED_QTY_IS_OVER - Static variable in class bb.common.BIZReason

SHIPPED_QTY_IS_ZERO - Static variable in class bb.common.BIZReason

SHIPPER - Static variable in class bb.common.BizTarget

SHIPPER - Static variable in class bb.common.Constant.PrintTemplateType

SHIPPER_HAS_BEEN_CLOSED - Static variable in class bb.common.BIZReason

SHIPPER_HAS_EXIST - Static variable in class bb.common.BIZReason

SHIPPER_ITEM - Static variable in class bb.common.BizTarget

SHIPPER_ITEM_HAS_BEEN_CLOSED - Static variable in class bb.common.BIZReason

SHIPPER_ITEM_HAS_BEEN_CREATED_INVOICE - Static variable in class bb.common.BIZReason

SHIPPER_ITEM_HAS_MADE_UNBILLED - Static variable in class bb.common.BIZReason

SHIPPER_ITEM_HAS_SHIPPED_COMPLETELY - Static variable in class bb.common.BIZReason

SHIPPER_ITEM_NOT_EXIST - Static variable in class bb.common.BIZReason

SHIPPER_NOT_EXIST - Static variable in class bb.common.BIZReason

SHIPPER_NOT_FOR_SALES_ORDER - Static variable in class bb.common.BIZReason

ShipperAgent - Class in bb.common

ShipperAgent() - Constructor for class bb.common.ShipperAgent

ShipperInfoVO - Class in bb.common

ShipperInfoVO() - Constructor for class bb.common.ShipperInfoVO

ShipperItemAgent - Class in bb.common

ShipperItemAgent() - Constructor for class bb.common.ShipperItemAgent

ShipperItemDetailAgent - Class in bb.common

ShipperItemDetailAgent() - Constructor for class bb.common.ShipperItemDetailAgent

ShipperItemListResult - Class in bb.common

ShipperItemListResult() - Constructor for class bb.common.ShipperItemListResult

ShipperItemManufacturerPK - Class in bb.common

ShipperItemManufacturerPK() - Constructor for class bb.common.ShipperItemManufacturerPK

ShipperItemManufacturerPK(String, String, Short) - Constructor for class bb.common.ShipperItemManufacturerPK

ShipperItemManufacturerVO - Class in bb.common

ShipperItemManufacturerVO() - Constructor for class bb.common.ShipperItemManufacturerVO

ShipperItemPK - Class in bb.common

ShipperItemPK() - Constructor for class bb.common.ShipperItemPK

ShipperItemPK(String, String) - Constructor for class bb.common.ShipperItemPK

ShipperItemVO - Class in bb.common

ShipperItemVO() - Constructor for class bb.common.ShipperItemVO

ShipperListResult - Class in bb.common

ShipperListResult() - Constructor for class bb.common.ShipperListResult

ShipperVO - Class in bb.common

ShipperVO() - Constructor for class bb.common.ShipperVO

SHIPPING_NP - Static variable in class bb.common.Constant.TrackingNumberType

SHIPPING_ONLOAN - Static variable in class bb.common.Constant.TrackingNumberType

SHIPPING_RTV - Static variable in class bb.common.Constant.TrackingNumberType

SHIPPING_SO - Static variable in class bb.common.Constant.TrackingNumberType

SHIPPING_SO_NUMBER - Static variable in class bb.common.LabelTemplateConstant

SHIPPING_SWAP_ORDER - Static variable in class bb.common.Constant.TrackingNumberType

SHIPPING_TRANSFER_ORDER - Static variable in class bb.common.Constant.TrackingNumberType

ShippingItemResult - Class in bb.common

ShippingItemResult() - Constructor for class bb.common.ShippingItemResult

ShippingResult - Class in bb.common

ShippingResult() - Constructor for class bb.common.ShippingResult

shipSOOfBillAndHoldInvoice(String) - Method in interface bb.common.box.AccountingBox

ShoppingCartItem - Class in bb.common

ShoppingCartItem() - Constructor for class bb.common.ShoppingCartItem

ShoppingCartItem(String, String, String, BigDecimal, String) - Constructor for class bb.common.ShoppingCartItem

showDashboard() - Method in interface bb.common.box.CompanyBox

SINGLE - Static variable in class bb.common.Constant.OITypeSerialNumberType

SIXLEVEL - Static variable in class bb.common.Constant.AgeLevel

SIXLEVEL - Static variable in class bb.common.Constant.WorkLevel

SmtpServerVO - Class in bb.common

SmtpServerVO() - Constructor for class bb.common.SmtpServerVO

SO - Static variable in class bb.common.Constant.NoticeType

SO - Static variable in class bb.common.Constant.Prefix

SO - Static variable in class bb.common.Constant.PrintTemplateType

SO - Static variable in class bb.common.Constant.TermsConditonType

SO2POAgent - Class in bb.common

SO2POAgent() - Constructor for class bb.common.SO2POAgent

SO2SOAgent - Class in bb.common

SO2SOAgent() - Constructor for class bb.common.SO2SOAgent

SO2WOAgent - Class in bb.common

SO2WOAgent() - Constructor for class bb.common.SO2WOAgent

SO_ACTION - Static variable in class bb.common.Constant.NoticeAction

SO_DOC - Static variable in class bb.common.BizTarget

SO_DOC - Static variable in class bb.common.Constant.MiscDocType

SO_DOC_NOT_FIND - Static variable in class bb.common.BIZReason

SO_ITEM_NOT_TOTALLY_SHIPPED - Static variable in class bb.common.BIZReason

SO_MAIL - Static variable in class bb.common.Constant.CustomerVendorMailType

SO_TOTAL_SMALLER_THAN_AR_PREPAY_PAID_TOTAL - Static variable in class bb.common.BIZReason

SODATE - Static variable in class bb.common.Constant.DateType

SOME_BODY_ELSE_WORK_ON_IT - Static variable in class bb.common.DBReason

SOME_ORDER_IS_ALREADY_HOLD - Static variable in class bb.common.BIZReason

SOME_PARTS_HAVE_BEEN_ISSUED_TO_WO - Static variable in class bb.common.BIZReason

SOMEONE_ELSE_HAVE_UPDATED_IT - Static variable in class bb.common.BIZReason

SOMEONE_ELSE_IS_CHANGING_SERVER_TIME - Static variable in class bb.common.BIZReason

SoPickListResult - Class in bb.common

SoPickListResult() - Constructor for class bb.common.SoPickListResult

SOShipperItemListResult - Class in bb.common

SOShipperItemListResult() - Constructor for class bb.common.SOShipperItemListResult

SPEC_ID_HAS_EXIST - Static variable in class bb.common.BIZReason

SPEC_ID_NOT_EXIST - Static variable in class bb.common.BIZReason

SPEC_ID_STILL_USED - Static variable in class bb.common.BIZReason

Spiderman - Class in bb.common

Spiderman(BizBoxServer) - Constructor for class bb.common.Spiderman

Spiderman(BizBoxServer, boolean) - Constructor for class bb.common.Spiderman

splitStrings(String, String) - Static method in class bb.common.BB2Util

Spotcheck - Static variable in class bb.common.Constant.IRType

SR_NUMBER - Static variable in class bb.common.BizTarget

StaffWorkingInformationResult - Class in bb.common

StaffWorkingInformationResult() - Constructor for class bb.common.StaffWorkingInformationResult

STANDARD - Static variable in class bb.common.Constant.InventoryCostMothed

START_DATE_SHOULD_BE_AFTER_THE_PRIOR_FISCAL_YEAR_END_DATE - Static variable in class bb.common.BIZReason

START_DATE_SHOULD_BE_BEFORE_THE_END_DATE - Static variable in class bb.common.BIZReason

STARTDATE - Static variable in class bb.common.Constant.DateType

status - Variable in class bb.common.SoPickListResult

STATUS_ONLY_CAN_CHANGE_TO_CLOSE - Static variable in class bb.common.BIZReason

STATUS_ONLY_CAN_CHANGE_TO_CLOSE_OR_CANCELLED - Static variable in class bb.common.BIZReason

STATUS_ONLY_CAN_CHANGE_TO_NOTAPPROVED - Static variable in class bb.common.BIZReason

STATUS_ONLY_CAN_CHANGE_TO_NOTREVIEWED - Static variable in class bb.common.BIZReason

STATUS_ONLY_CAN_NOT_CHANGE_TO_CLOSE - Static variable in class bb.common.BIZReason

STATUS_READ - Static variable in class bb.common.MessageVO

STATUS_REMOVED - Static variable in class bb.common.MessageVO

STATUS_UNREAD - Static variable in class bb.common.MessageVO

STD_COST_APPROVED_BY_CAN_NOT_BE_EMPTY - Static variable in class bb.common.BIZReason

STD_COST_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY - Static variable in class bb.common.BIZReason

STDCOST - Static variable in class bb.common.Constant.CostControl

STDCOST - Static variable in class bb.common.Constant.GLApprovedType

StockTransactionAdjustmentResult - Class in bb.common

StockTransactionAdjustmentResult() - Constructor for class bb.common.StockTransactionAdjustmentResult

StockTransactionPartInfoResult - Class in bb.common

StockTransactionPartInfoResult() - Constructor for class bb.common.StockTransactionPartInfoResult

StockTransactionPOReceiverResult - Class in bb.common

StockTransactionPOReceiverResult() - Constructor for class bb.common.StockTransactionPOReceiverResult

StockTransactionSOShipperResult - Class in bb.common

StockTransactionSOShipperResult() - Constructor for class bb.common.StockTransactionSOShipperResult

StockTransactionWOReceiverResult - Class in bb.common

StockTransactionWOReceiverResult() - Constructor for class bb.common.StockTransactionWOReceiverResult

StockTransactionWOShipperResult - Class in bb.common

StockTransactionWOShipperResult() - Constructor for class bb.common.StockTransactionWOShipperResult

STRAIGHT_LINEMETHOD - Static variable in class bb.common.Constant.Depreciation.DepreciationMethod

StringListConvertor - Class in bb.common

StringListConvertor() - Constructor for class bb.common.StringListConvertor

strToList(String) - Method in class bb.common.StringListConvertor

SUB_COMPANY_UNIT_HAS_THE_ACCOUNT_NUMBER - Static variable in class bb.common.BIZReason

SUBCOMPANY_ALREADY_EXIST - Static variable in class bb.common.BIZReason

SUBCOMPANY_NOT_EXIST - Static variable in class bb.common.BIZReason

SubcompanyLoginAgent - Class in bb.common

SubcompanyLoginAgent() - Constructor for class bb.common.SubcompanyLoginAgent

SubcompanyVO - Class in bb.common

SubcompanyVO() - Constructor for class bb.common.SubcompanyVO

SUBMIT_DOCUMENT - Static variable in class bb.common.BB2Event

subtractPartOnOder(PurchaseOrderItemVO) - Method in interface bb.common.box.WarehouseBox

subtractToolOnOder(PurchaseOrderItemVO) - Method in interface bb.common.box.WarehouseBox

Succeed - Static variable in class bb.common.Constant.Download

Succeed - Static variable in class bb.common.Constant.Upload

SummaryStatement - Static variable in class bb.common.Constant.StatementType

SW - Static variable in class bb.common.Constant.Prefix

SWAP_ORDER - Static variable in class bb.common.BizTarget

SWAP_ORDER_APPROVAL - Static variable in class bb.common.BizTarget

SWAP_ORDER_APPROVAL_ALREADY_EXIST - Static variable in class bb.common.BIZReason

SWAP_ORDER_APPROVAL_NOT_EXIST - Static variable in class bb.common.BIZReason

SWAP_ORDER_ITEM - Static variable in class bb.common.BizTarget

SWAP_ORDER_ITEM_ALREADY_SHIPPED - Static variable in class bb.common.BIZReason

SWAP_ORDER_ITEM_NOT_EXIST_FOR_THIS_SWAP_SHIPPER_ITEM - Static variable in class bb.common.BIZReason

SWAP_ORDER_NOT_EXIST - Static variable in class bb.common.BIZReason

SWAP_RECEIVER - Static variable in class bb.common.BizTarget

SWAP_RECEIVER_ITEM - Static variable in class bb.common.BizTarget

SWAP_RECEIVER_NOT_EXIST - Static variable in class bb.common.BIZReason

SWAP_SHIPPER - Static variable in class bb.common.BizTarget

SWAP_SHIPPER_ITEM - Static variable in class bb.common.BizTarget

SWAP_SHIPPER_ITEM_NOT_EXIST - Static variable in class bb.common.BIZReason

SWAP_SHIPPER_NOT_EXIST - Static variable in class bb.common.BIZReason

SWAPDATE - Static variable in class bb.common.Constant.DateType

SwapOrderApprovalVO - Class in bb.common

SwapOrderApprovalVO() - Constructor for class bb.common.SwapOrderApprovalVO

SwapOrderItemListResult - Class in bb.common

SwapOrderItemListResult() - Constructor for class bb.common.SwapOrderItemListResult

SwapOrderItemPK - Class in bb.common

SwapOrderItemPK() - Constructor for class bb.common.SwapOrderItemPK

SwapOrderItemPK(String, String) - Constructor for class bb.common.SwapOrderItemPK

SwapOrderItemVO - Class in bb.common

SwapOrderItemVO() - Constructor for class bb.common.SwapOrderItemVO

SwapOrderListResult - Class in bb.common

SwapOrderListResult() - Constructor for class bb.common.SwapOrderListResult

SwapOrderVO - Class in bb.common

SwapOrderVO() - Constructor for class bb.common.SwapOrderVO

SwapReceiverItemListResult - Class in bb.common

SwapReceiverItemListResult() - Constructor for class bb.common.SwapReceiverItemListResult

SwapReceiverItemPK - Class in bb.common

SwapReceiverItemPK() - Constructor for class bb.common.SwapReceiverItemPK

SwapReceiverItemPK(String, String) - Constructor for class bb.common.SwapReceiverItemPK

SwapReceiverItemVO - Class in bb.common

SwapReceiverItemVO() - Constructor for class bb.common.SwapReceiverItemVO

SwapReceiverListResult - Class in bb.common

SwapReceiverListResult() - Constructor for class bb.common.SwapReceiverListResult

SwapReceiverVO - Class in bb.common

SwapReceiverVO() - Constructor for class bb.common.SwapReceiverVO

SwapShipperItemListResult - Class in bb.common

SwapShipperItemListResult() - Constructor for class bb.common.SwapShipperItemListResult

SwapShipperItemPK - Class in bb.common

SwapShipperItemPK() - Constructor for class bb.common.SwapShipperItemPK

SwapShipperItemPK(String, String) - Constructor for class bb.common.SwapShipperItemPK

SwapShipperItemVO - Class in bb.common

SwapShipperItemVO() - Constructor for class bb.common.SwapShipperItemVO

SwapShipperListResult - Class in bb.common

SwapShipperListResult() - Constructor for class bb.common.SwapShipperListResult

SwapShipperOnOrderResult - Class in bb.common

SwapShipperOnOrderResult() - Constructor for class bb.common.SwapShipperOnOrderResult

SwapShipperVO - Class in bb.common

SwapShipperVO() - Constructor for class bb.common.SwapShipperVO

SWR - Static variable in class bb.common.Constant.Prefix

SWS - Static variable in class bb.common.Constant.Prefix

synchronizeWiSeqToWowiSeq(WorkInstructionPK, WorkOrderItemPK) - Method in interface bb.common.box.WorkOrderBox

SYSTEM_LOGIN_LOCKED - Static variable in class bb.common.BIZReason

Overview

Package

Class

Use

Tree

Deprecated

Index

Help

PREV LETTER NEXT LETTER

FRAMES NO FRAMES

A B C D E F G H I J L M N O P Q R S T U V W X Y Z


SmtpServerVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SmtpServerVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SmtpServerVO
All Implemented Interfaces:
java.io.Serializable
public class SmtpServerVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SmtpServerVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.lang.String | getDisplayName()
java.lang.String | getHost()
java.lang.Short | getIi()
java.lang.String | getPassword()
int | getPort()
java.lang.String | getSendFrom()
java.lang.String | getUserName()
int | hashCode()
boolean | isRequireAuth()
void | setComments(java.lang.String comments)
void | setDisplayName(java.lang.String displayName)
void | setHost(java.lang.String host)
void | setIi(java.lang.Short ii)
void | setPassword(java.lang.String password)
void | setPort(int port)
void | setRequireAuth(boolean requireAuth)
void | setSendFrom(java.lang.String sendFrom)
void | setUserName(java.lang.String userName)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SmtpServerVO

public SmtpServerVO()
Method Detail

getIi

public java.lang.Short getIi()

setIi

public void setIi(java.lang.Short ii)

getHost

public java.lang.String getHost()

setHost

public void setHost(java.lang.String host)

getPort

public int getPort()

setPort

public void setPort(int port)

getDisplayName

public java.lang.String getDisplayName()

setDisplayName

public void setDisplayName(java.lang.String displayName)

isRequireAuth

public boolean isRequireAuth()

setRequireAuth

public void setRequireAuth(boolean requireAuth)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getPassword

public java.lang.String getPassword()

getComments

public java.lang.String getComments()

getSendFrom

public java.lang.String getSendFrom()

setPassword

public void setPassword(java.lang.String password)

setComments

public void setComments(java.lang.String comments)

setSendFrom

public void setSendFrom(java.lang.String sendFrom)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SO2POAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SO2POAgent

java.lang.Object
    extended by  bb.common.SO2POAgent
All Implemented Interfaces:
java.io.Serializable
public class SO2POAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SO2POAgent()
Method Summary
java.lang.String | getShipVia()
java.lang.String | getSoNumber()
java.lang.String | getVendorId()
boolean | isIncludeMPNs()
void | setIncludeMPNs(boolean includeMPNs)
void | setShipVia(java.lang.String shipVia)
void | setSoNumber(java.lang.String soNumber)
void | setVendorId(java.lang.String vendorId)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SO2POAgent

public SO2POAgent()
Method Detail

getSoNumber

public java.lang.String getSoNumber()

setSoNumber

public void setSoNumber(java.lang.String soNumber)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

isIncludeMPNs

public boolean isIncludeMPNs()

setIncludeMPNs

public void setIncludeMPNs(boolean includeMPNs)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SO2SOAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SO2SOAgent

java.lang.Object
    extended by  bb.common.SO2SOAgent
All Implemented Interfaces:
java.io.Serializable
public class SO2SOAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SO2SOAgent()
Method Summary
java.util.Date | getArriveDate()
java.lang.String | getBillToId()
java.lang.String | getContact()
java.lang.String | getCustomerId()
java.lang.String | getCustomerPo()
int | getDelayDays()
java.util.Date | getOriginalDate()
java.util.Date | getShipDate()
java.lang.String | getShipToId()
java.lang.String | getSoNumber()
void | setArriveDate(java.util.Date arriveDate)
void | setBillToId(java.lang.String billToId)
void | setContact(java.lang.String contact)
void | setCustomerId(java.lang.String customerId)
void | setCustomerPo(java.lang.String customerPo)
void | setDelayDays(int delayDays)
void | setOriginalDate(java.util.Date originalDate)
void | setShipDate(java.util.Date shipDate)
void | setShipToId(java.lang.String shipToId)
void | setSoNumber(java.lang.String soNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SO2SOAgent

public SO2SOAgent()
Method Detail

getDelayDays

public int getDelayDays()

setDelayDays

public void setDelayDays(int delayDays)

getBillToId

public java.lang.String getBillToId()

setBillToId

public void setBillToId(java.lang.String billToId)

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getCustomerId

public java.lang.String getCustomerId()

setCustomerId

public void setCustomerId(java.lang.String customerId)

getCustomerPo

public java.lang.String getCustomerPo()

setCustomerPo

public void setCustomerPo(java.lang.String customerPo)

getShipToId

public java.lang.String getShipToId()

setShipToId

public void setShipToId(java.lang.String shipToId)

getSoNumber

public java.lang.String getSoNumber()

setSoNumber

public void setSoNumber(java.lang.String soNumber)

getArriveDate

public java.util.Date getArriveDate()

setArriveDate

public void setArriveDate(java.util.Date arriveDate)

getOriginalDate

public java.util.Date getOriginalDate()

setOriginalDate

public void setOriginalDate(java.util.Date originalDate)

getShipDate

public java.util.Date getShipDate()

setShipDate

public void setShipDate(java.util.Date shipDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SO2WOAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SO2WOAgent

java.lang.Object
    extended by  bb.common.SO2WOAgent
All Implemented Interfaces:
java.io.Serializable
public class SO2WOAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SO2WOAgent()
Method Summary
java.lang.String | getSoNumber()
java.lang.String | getVendorId()
boolean | isCopyMpn()
void | setCopyMpn(boolean isCopyMpn)
void | setSoNumber(java.lang.String soNumber)
void | setVendorId(java.lang.String vendorId)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SO2WOAgent

public SO2WOAgent()
Method Detail

getSoNumber

public java.lang.String getSoNumber()

setSoNumber

public void setSoNumber(java.lang.String soNumber)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

isCopyMpn

public boolean isCopyMpn()

setCopyMpn

public void setCopyMpn(boolean isCopyMpn)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SoPickListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SoPickListResult

java.lang.Object
    extended by  bb.common.SoPickListResult
All Implemented Interfaces:
java.io.Serializable
public class SoPickListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
java.lang.String | salesOrderNumber
java.lang.String | status
Constructor Summary
SoPickListResult()
Method Summary
java.util.Set | getItems()
java.lang.String | getSalesOrderNumber()
java.lang.String | getStatus()
void | setItems(java.util.Set items)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setStatus(java.lang.String status)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

salesOrderNumber

public java.lang.String salesOrderNumber

status

public java.lang.String status
Constructor Detail

SoPickListResult

public SoPickListResult()
Method Detail

getItems

public java.util.Set getItems()

setItems

public void setItems(java.util.Set items)

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SOShipperItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SOShipperItemListResult

java.lang.Object
    extended by  bb.common.SOShipperItemListResult
All Implemented Interfaces:
java.io.Serializable
public class SOShipperItemListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DATEINVOICED
static java.lang.String | ORDER_BY_DATESHIPPED
static java.lang.String | ORDER_BY_INVOICENUMBER
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_QUANTITYSHIPPED
static java.lang.String | ORDER_BY_SALESORDERNUMBER
static java.lang.String | ORDER_BY_SHIPPERITEMPK
static java.lang.String | ORDER_BY_SOQUANTITY
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
SOShipperItemListResult()
Method Summary
java.util.Date | getDateInvoiced()
java.util.Date | getDateShipped()
java.lang.String | getInvoiceNumber()
java.lang.String | getPartDescription()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getQuantityShipped()
java.lang.String | getSalesOrderNumber()
ShipperItemPK | getShipperItemPk()
java.math.BigDecimal | getSoQuantity()
java.lang.String | getStatus()
void | setDateInvoiced(java.util.Date dateInvoiced)
void | setDateShipped(java.util.Date dateShipped)
void | setInvoiceNumber(java.lang.String invoiceNumber)
void | setPartDescription(java.lang.String partDescription)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setQuantityShipped(java.math.BigDecimal quantityShipped)
void | setSalesOrderNumber(java.lang.String salesOrderNumber)
void | setShipperItemPk(ShipperItemPK shipperItemPk)
void | setSoQuantity(java.math.BigDecimal soQuantity)
void | setStatus(java.lang.String status)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_SHIPPERITEMPK

public static final java.lang.String ORDER_BY_SHIPPERITEMPK
See Also:
Constant Field Values

ORDER_BY_SALESORDERNUMBER

public static final java.lang.String ORDER_BY_SALESORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_SOQUANTITY

public static final java.lang.String ORDER_BY_SOQUANTITY
See Also:
Constant Field Values

ORDER_BY_QUANTITYSHIPPED

public static final java.lang.String ORDER_BY_QUANTITYSHIPPED
See Also:
Constant Field Values

ORDER_BY_DATESHIPPED

public static final java.lang.String ORDER_BY_DATESHIPPED
See Also:
Constant Field Values

ORDER_BY_INVOICENUMBER

public static final java.lang.String ORDER_BY_INVOICENUMBER
See Also:
Constant Field Values

ORDER_BY_DATEINVOICED

public static final java.lang.String ORDER_BY_DATEINVOICED
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values
Constructor Detail

SOShipperItemListResult

public SOShipperItemListResult()
Method Detail

setShipperItemPk

public void setShipperItemPk(ShipperItemPK shipperItemPk)

setSalesOrderNumber

public void setSalesOrderNumber(java.lang.String salesOrderNumber)

setSoQuantity

public void setSoQuantity(java.math.BigDecimal soQuantity)

setQuantityShipped

public void setQuantityShipped(java.math.BigDecimal quantityShipped)

setDateShipped

public void setDateShipped(java.util.Date dateShipped)

setInvoiceNumber

public void setInvoiceNumber(java.lang.String invoiceNumber)

setDateInvoiced

public void setDateInvoiced(java.util.Date dateInvoiced)

setStatus

public void setStatus(java.lang.String status)

getShipperItemPk

public ShipperItemPK getShipperItemPk()

getSalesOrderNumber

public java.lang.String getSalesOrderNumber()

getSoQuantity

public java.math.BigDecimal getSoQuantity()

getQuantityShipped

public java.math.BigDecimal getQuantityShipped()

getDateShipped

public java.util.Date getDateShipped()

getInvoiceNumber

public java.lang.String getInvoiceNumber()

getDateInvoiced

public java.util.Date getDateInvoiced()

getStatus

public java.lang.String getStatus()

getPartDescription

public java.lang.String getPartDescription()

setPartDescription

public void setPartDescription(java.lang.String partDescription)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Spiderman

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class Spiderman

java.lang.Object
    extended by  bb.common.Spiderman

public class Spiderman
extends java.lang.Object

Constructor Summary
Spiderman(BizBoxServer targetServer)
Spiderman(BizBoxServer targetServer, boolean login)
Method Summary
void | distroy()
long | getServerTime()
java.util.TimeZone | getServerTimeZone()
java.lang.String | getVersionInfo()
java.lang.Object | invoke(ServerAction action)
void | login(BB2Login loginData)
static void | main(java.lang.String[] args)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Spiderman

public Spiderman(BizBoxServer targetServer)
          throws java.lang.Exception
Throws:
java.lang.Exception

Spiderman

public Spiderman(BizBoxServer targetServer,
                 boolean login)
          throws java.lang.Exception
Throws:
java.lang.Exception
Method Detail

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
Throws:
java.lang.Exception

login

public void login(BB2Login loginData)
           throws java.lang.Exception
Throws:
java.lang.Exception

invoke

public java.lang.Object invoke(ServerAction action)
                        throws java.lang.Exception
Throws:
java.lang.Exception

getVersionInfo

public java.lang.String getVersionInfo()
                                throws java.lang.Exception
Throws:
java.lang.Exception

getServerTime

public long getServerTime()
                   throws java.lang.Exception
Throws:
java.lang.Exception

getServerTimeZone

public java.util.TimeZone getServerTimeZone()
                                     throws java.lang.Exception
Throws:
java.lang.Exception

distroy

public void distroy()
             throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StaffWorkingInformationResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class StaffWorkingInformationResult

java.lang.Object
    extended by  bb.common.StaffWorkingInformationResult
All Implemented Interfaces:
java.io.Serializable
public class StaffWorkingInformationResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
StaffWorkingInformationResult()
Method Summary
java.lang.String | getStaff()
java.lang.String | getWorkingInfo()
boolean | isWorking()
void | setStaff(java.lang.String staff)
void | setWorking(boolean working)
void | setWorkingInfo(java.lang.String workingInfo)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StaffWorkingInformationResult

public StaffWorkingInformationResult()
Method Detail

getStaff

public java.lang.String getStaff()

setStaff

public void setStaff(java.lang.String staff)

isWorking

public boolean isWorking()

setWorking

public void setWorking(boolean working)

getWorkingInfo

public java.lang.String getWorkingInfo()

setWorkingInfo

public void setWorkingInfo(java.lang.String workingInfo)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StockTransactionAdjustmentResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class StockTransactionAdjustmentResult

java.lang.Object
    extended by  bb.common.StockTransactionAdjustmentResult
All Implemented Interfaces:
java.io.Serializable
public class StockTransactionAdjustmentResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
StockTransactionAdjustmentResult()
Method Summary
java.math.BigDecimal | getAdjustedQty()
java.lang.String | getComments()
java.util.Date | getCounted()
java.lang.String | getCountedBy()
java.math.BigDecimal | getNewOnhand()
java.math.BigDecimal | getOldOnhand()
BB2Part | getPart()
void | setAdjustedQty(java.math.BigDecimal adjustedQty)
void | setComments(java.lang.String comments)
void | setCounted(java.util.Date counted)
void | setCountedBy(java.lang.String countedBy)
void | setNewOnhand(java.math.BigDecimal newOnhand)
void | setOldOnhand(java.math.BigDecimal oldOnhand)
void | setPart(BB2Part part)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StockTransactionAdjustmentResult

public StockTransactionAdjustmentResult()
Method Detail

setComments

public void setComments(java.lang.String comments)

setCountedBy

public void setCountedBy(java.lang.String countedBy)

setCounted

public void setCounted(java.util.Date counted)

setNewOnhand

public void setNewOnhand(java.math.BigDecimal newOnhand)

setOldOnhand

public void setOldOnhand(java.math.BigDecimal oldOnhand)

setAdjustedQty

public void setAdjustedQty(java.math.BigDecimal adjustedQty)

setPart

public void setPart(BB2Part part)

getComments

public java.lang.String getComments()

getCountedBy

public java.lang.String getCountedBy()

getCounted

public java.util.Date getCounted()

getNewOnhand

public java.math.BigDecimal getNewOnhand()

getOldOnhand

public java.math.BigDecimal getOldOnhand()

getAdjustedQty

public java.math.BigDecimal getAdjustedQty()

getPart

public BB2Part getPart()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StockTransactionPartInfoResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class StockTransactionPartInfoResult

java.lang.Object
    extended by  bb.common.StockTransactionPartInfoResult
All Implemented Interfaces:
java.io.Serializable
public class StockTransactionPartInfoResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
StockTransactionPartInfoResult()
Method Summary
java.lang.String | getBill()
java.lang.String | getDescription()
java.lang.String | getDwg()
java.lang.String | getHold()
java.math.BigDecimal | getInWip()
java.math.BigDecimal | getLendTime()
java.math.BigDecimal | getMaxQty()
java.math.BigDecimal | getMinQty()
java.math.BigDecimal | getOndemand()
java.math.BigDecimal | getOnhand()
java.math.BigDecimal | getOnorder()
BB2Part | getPart()
java.math.BigDecimal | getQtrUsage()
java.lang.String | getRev()
java.math.BigDecimal | getYUsage()
void | setBill(java.lang.String bill)
void | setDescription(java.lang.String description)
void | setDwg(java.lang.String dwg)
void | setHold(java.lang.String hold)
void | setInWip(java.math.BigDecimal inWip)
void | setLendTime(java.math.BigDecimal lendTime)
void | setMaxQty(java.math.BigDecimal maxQty)
void | setMinQty(java.math.BigDecimal minQty)
void | setOndemand(java.math.BigDecimal ondemand)
void | setOnhand(java.math.BigDecimal onhand)
void | setOnorder(java.math.BigDecimal onorder)
void | setPart(BB2Part part)
void | setQtrUsage(java.math.BigDecimal qtrUsage)
void | setRev(java.lang.String rev)
void | setYUsage(java.math.BigDecimal yUsage)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StockTransactionPartInfoResult

public StockTransactionPartInfoResult()
Method Detail

setPart

public void setPart(BB2Part part)

setRev

public void setRev(java.lang.String rev)

setHold

public void setHold(java.lang.String hold)

setDwg

public void setDwg(java.lang.String dwg)

setBill

public void setBill(java.lang.String bill)

setDescription

public void setDescription(java.lang.String description)

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

setOnorder

public void setOnorder(java.math.BigDecimal onorder)

setOndemand

public void setOndemand(java.math.BigDecimal ondemand)

setInWip

public void setInWip(java.math.BigDecimal inWip)

setLendTime

public void setLendTime(java.math.BigDecimal lendTime)

setYUsage

public void setYUsage(java.math.BigDecimal yUsage)

setQtrUsage

public void setQtrUsage(java.math.BigDecimal qtrUsage)

setMaxQty

public void setMaxQty(java.math.BigDecimal maxQty)

setMinQty

public void setMinQty(java.math.BigDecimal minQty)

getPart

public BB2Part getPart()

getRev

public java.lang.String getRev()

getHold

public java.lang.String getHold()

getDwg

public java.lang.String getDwg()

getBill

public java.lang.String getBill()

getDescription

public java.lang.String getDescription()

getOnhand

public java.math.BigDecimal getOnhand()

getOnorder

public java.math.BigDecimal getOnorder()

getOndemand

public java.math.BigDecimal getOndemand()

getInWip

public java.math.BigDecimal getInWip()

getLendTime

public java.math.BigDecimal getLendTime()

getYUsage

public java.math.BigDecimal getYUsage()

getQtrUsage

public java.math.BigDecimal getQtrUsage()

getMaxQty

public java.math.BigDecimal getMaxQty()

getMinQty

public java.math.BigDecimal getMinQty()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StockTransactionPOReceiverResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class StockTransactionPOReceiverResult

java.lang.Object
    extended by  bb.common.StockTransactionPOReceiverResult
All Implemented Interfaces:
java.io.Serializable
public class StockTransactionPOReceiverResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
StockTransactionPOReceiverResult()
Method Summary
java.lang.String | getItemNumber()
BB2Part | getPart()
java.lang.String | getPoNumber()
java.lang.String | getReceivedBy()
java.util.Date | getReceivedDate()
java.lang.String | getReceiverNumber()
java.math.BigDecimal | getRecQty()
java.lang.String | getVendorId()
void | setItemNumber(java.lang.String itemNumber)
void | setPart(BB2Part part)
void | setPoNumber(java.lang.String poNumber)
void | setReceivedBy(java.lang.String receivedBy)
void | setReceivedDate(java.util.Date receivedDate)
void | setReceiverNumber(java.lang.String receiverNumber)
void | setRecQty(java.math.BigDecimal recQty)
void | setVendorId(java.lang.String vendorId)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StockTransactionPOReceiverResult

public StockTransactionPOReceiverResult()
Method Detail

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

setPart

public void setPart(BB2Part part)

setPoNumber

public void setPoNumber(java.lang.String poNumber)

setVendorId

public void setVendorId(java.lang.String vendorId)

setReceivedBy

public void setReceivedBy(java.lang.String receivedBy)

setReceivedDate

public void setReceivedDate(java.util.Date receivedDate)

setRecQty

public void setRecQty(java.math.BigDecimal recQty)

getReceiverNumber

public java.lang.String getReceiverNumber()

getItemNumber

public java.lang.String getItemNumber()

getPart

public BB2Part getPart()

getPoNumber

public java.lang.String getPoNumber()

getVendorId

public java.lang.String getVendorId()

getReceivedBy

public java.lang.String getReceivedBy()

getReceivedDate

public java.util.Date getReceivedDate()

getRecQty

public java.math.BigDecimal getRecQty()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StockTransactionSOShipperResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class StockTransactionSOShipperResult

java.lang.Object
    extended by  bb.common.StockTransactionSOShipperResult
All Implemented Interfaces:
java.io.Serializable
public class StockTransactionSOShipperResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
StockTransactionSOShipperResult()
Method Summary
java.lang.String | getCustomerId()
java.lang.String | getItemNumber()
BB2Part | getPart()
java.lang.String | getShippedBy()
java.util.Date | getShippedDate()
java.math.BigDecimal | getShippedQty()
java.lang.String | getShipperNumber()
java.lang.String | getSoNumber()
void | setCustomerId(java.lang.String customerId)
void | setItemNumber(java.lang.String itemNumber)
void | setPart(BB2Part part)
void | setShippedBy(java.lang.String shippedBy)
void | setShippedDate(java.util.Date shippedDate)
void | setShippedQty(java.math.BigDecimal shippedQty)
void | setShipperNumber(java.lang.String shipperNumber)
void | setSoNumber(java.lang.String soNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StockTransactionSOShipperResult

public StockTransactionSOShipperResult()
Method Detail

setShipperNumber

public void setShipperNumber(java.lang.String shipperNumber)

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

setSoNumber

public void setSoNumber(java.lang.String soNumber)

setCustomerId

public void setCustomerId(java.lang.String customerId)

setShippedBy

public void setShippedBy(java.lang.String shippedBy)

setShippedQty

public void setShippedQty(java.math.BigDecimal shippedQty)

setShippedDate

public void setShippedDate(java.util.Date shippedDate)

setPart

public void setPart(BB2Part part)

getShipperNumber

public java.lang.String getShipperNumber()

getItemNumber

public java.lang.String getItemNumber()

getSoNumber

public java.lang.String getSoNumber()

getCustomerId

public java.lang.String getCustomerId()

getShippedBy

public java.lang.String getShippedBy()

getShippedQty

public java.math.BigDecimal getShippedQty()

getShippedDate

public java.util.Date getShippedDate()

getPart

public BB2Part getPart()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StockTransactionWOReceiverResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class StockTransactionWOReceiverResult

java.lang.Object
    extended by  bb.common.StockTransactionWOReceiverResult
All Implemented Interfaces:
java.io.Serializable
public class StockTransactionWOReceiverResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
StockTransactionWOReceiverResult()
Method Summary
java.lang.String | getItemNumber()
BB2Part | getPart()
java.util.Date | getReceivedDate()
java.math.BigDecimal | getRecQty()
java.lang.String | getVendorId()
java.lang.String | getWoNumber()
void | setItemNumber(java.lang.String itemNumber)
void | setPart(BB2Part part)
void | setReceivedDate(java.util.Date receivedDate)
void | setRecQty(java.math.BigDecimal recQty)
void | setVendorId(java.lang.String vendorId)
void | setWoNumber(java.lang.String woNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StockTransactionWOReceiverResult

public StockTransactionWOReceiverResult()
Method Detail

getWoNumber

public java.lang.String getWoNumber()

getItemNumber

public java.lang.String getItemNumber()

getVendorId

public java.lang.String getVendorId()

getRecQty

public java.math.BigDecimal getRecQty()

getReceivedDate

public java.util.Date getReceivedDate()

getPart

public BB2Part getPart()

setWoNumber

public void setWoNumber(java.lang.String woNumber)

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

setVendorId

public void setVendorId(java.lang.String vendorId)

setRecQty

public void setRecQty(java.math.BigDecimal recQty)

setReceivedDate

public void setReceivedDate(java.util.Date receivedDate)

setPart

public void setPart(BB2Part part)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StockTransactionWOShipperResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class StockTransactionWOShipperResult

java.lang.Object
    extended by  bb.common.StockTransactionWOShipperResult
All Implemented Interfaces:
java.io.Serializable
public class StockTransactionWOShipperResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
StockTransactionWOShipperResult()
Method Summary
java.lang.String | getCustomerId()
java.util.Date | getIssuedDate()
java.math.BigDecimal | getIssuedQty()
java.lang.String | getItemNumber()
BB2Part | getPart()
java.lang.String | getWoNumber()
void | setCustomerId(java.lang.String customerId)
void | setIssuedDate(java.util.Date issuedDate)
void | setIssuedQty(java.math.BigDecimal issuedQty)
void | setItemNumber(java.lang.String itemNumber)
void | setPart(BB2Part part)
void | setWoNumber(java.lang.String woNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StockTransactionWOShipperResult

public StockTransactionWOShipperResult()
Method Detail

setWoNumber

public void setWoNumber(java.lang.String woNumber)

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

setCustomerId

public void setCustomerId(java.lang.String customerId)

setIssuedQty

public void setIssuedQty(java.math.BigDecimal issuedQty)

setIssuedDate

public void setIssuedDate(java.util.Date issuedDate)

setPart

public void setPart(BB2Part part)

getWoNumber

public java.lang.String getWoNumber()

getItemNumber

public java.lang.String getItemNumber()

getCustomerId

public java.lang.String getCustomerId()

getIssuedQty

public java.math.BigDecimal getIssuedQty()

getIssuedDate

public java.util.Date getIssuedDate()

getPart

public BB2Part getPart()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StringListConvertor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class StringListConvertor

java.lang.Object
    extended by  bb.common.StringListConvertor

public class StringListConvertor
extends java.lang.Object

Constructor Summary
StringListConvertor()
Method Summary
static StringListConvertor | getInstance()
java.lang.String | listToStr(java.util.List list)
java.util.List | strToList(java.lang.String context)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StringListConvertor

public StringListConvertor()
Method Detail

getInstance

public static StringListConvertor getInstance()

strToList

public java.util.List strToList(java.lang.String context)

listToStr

public java.lang.String listToStr(java.util.List list)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SubcompanyLoginAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SubcompanyLoginAgent

java.lang.Object
    extended by  bb.common.SubcompanyLoginAgent
All Implemented Interfaces:
java.io.Serializable
public class SubcompanyLoginAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SubcompanyLoginAgent()
Method Summary
java.lang.String | getLanguageCode()
java.lang.String | getPassword()
java.lang.String | getPort()
java.lang.String | getServer()
java.lang.String | getSystem()
java.lang.String | getUserName()
void | setLanguageCode(java.lang.String languageCode)
void | setPassword(java.lang.String password)
void | setPort(java.lang.String port)
void | setServer(java.lang.String server)
void | setSystem(java.lang.String system)
void | setUserName(java.lang.String userName)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SubcompanyLoginAgent

public SubcompanyLoginAgent()
Method Detail

getLanguageCode

public java.lang.String getLanguageCode()

setLanguageCode

public void setLanguageCode(java.lang.String languageCode)

getPassword

public java.lang.String getPassword()

setPassword

public void setPassword(java.lang.String password)

getPort

public java.lang.String getPort()

setPort

public void setPort(java.lang.String port)

getServer

public java.lang.String getServer()

setServer

public void setServer(java.lang.String server)

getSystem

public java.lang.String getSystem()

setSystem

public void setSystem(java.lang.String system)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SubcompanyVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SubcompanyVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SubcompanyVO
All Implemented Interfaces:
java.io.Serializable
public class SubcompanyVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SubcompanyVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAccessPassword()
java.lang.String | getAccessUserName()
java.lang.String | getAddressID()
java.lang.String | getCompanyName()
java.lang.String | getContactPerson()
java.util.Date | getCreateDate()
java.lang.String | getDescription()
java.lang.String | getGroup()
java.lang.String | getIpAddress()
java.lang.String | getLastChangeBy()
java.util.Date | getLastChangeDate()
java.util.Date | getLastSyncDate()
float | getOwnershipPercent()
java.lang.String | getPort()
java.lang.String | getServerLocation()
java.lang.String | getSystem()
int | hashCode()
void | setAccessPassword(java.lang.String accessPassword)
void | setAccessUserName(java.lang.String accessUserName)
void | setAddressID(java.lang.String addressID)
void | setCompanyName(java.lang.String companyName)
void | setContactPerson(java.lang.String contactPerson)
void | setCreateDate(java.util.Date createDate)
void | setDescription(java.lang.String description)
void | setGroup(java.lang.String group)
void | setIpAddress(java.lang.String ipAddress)
void | setLastChangeBy(java.lang.String lastChangeBy)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastSyncDate(java.util.Date lastSyncDate)
void | setOwnershipPercent(float ownershipPercent)
void | setPort(java.lang.String port)
void | setServerLocation(java.lang.String serverLocation)
void | setSystem(java.lang.String system)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SubcompanyVO

public SubcompanyVO()
Method Detail

getAccessPassword

public java.lang.String getAccessPassword()

setAccessPassword

public void setAccessPassword(java.lang.String accessPassword)

getAccessUserName

public java.lang.String getAccessUserName()

setAccessUserName

public void setAccessUserName(java.lang.String accessUserName)

getAddressID

public java.lang.String getAddressID()

setAddressID

public void setAddressID(java.lang.String addressID)

getCompanyName

public java.lang.String getCompanyName()

setCompanyName

public void setCompanyName(java.lang.String companyName)

getContactPerson

public java.lang.String getContactPerson()

setContactPerson

public void setContactPerson(java.lang.String contactPerson)

getCreateDate

public java.util.Date getCreateDate()

setCreateDate

public void setCreateDate(java.util.Date createDate)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getGroup

public java.lang.String getGroup()

setGroup

public void setGroup(java.lang.String group)

getIpAddress

public java.lang.String getIpAddress()

setIpAddress

public void setIpAddress(java.lang.String ipAddress)

getLastChangeBy

public java.lang.String getLastChangeBy()

setLastChangeBy

public void setLastChangeBy(java.lang.String lastChangeBy)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastSyncDate

public java.util.Date getLastSyncDate()

setLastSyncDate

public void setLastSyncDate(java.util.Date lastSyncDate)

getOwnershipPercent

public float getOwnershipPercent()

setOwnershipPercent

public void setOwnershipPercent(float ownershipPercent)

getServerLocation

public java.lang.String getServerLocation()

setServerLocation

public void setServerLocation(java.lang.String serverLocation)

getSystem

public java.lang.String getSystem()

setSystem

public void setSystem(java.lang.String system)

getPort

public java.lang.String getPort()

setPort

public void setPort(java.lang.String port)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SwapOrderApprovalVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SwapOrderApprovalVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SwapOrderApprovalVO
All Implemented Interfaces:
java.io.Serializable
public class SwapOrderApprovalVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CANAPPROVEOWN
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_EMPLOYEEID
static java.lang.String | ORDER_BY_USERNAME
Constructor Summary
SwapOrderApprovalVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.lang.String | getEmployeeId()
java.lang.String | getUserName()
int | hashCode()
boolean | isCanApproveOwn()
void | setCanApproveOwn(boolean canApproveOwn)
void | setComments(java.lang.String comments)
void | setEmployeeId(java.lang.String employeeId)
void | setUserName(java.lang.String userName)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_EMPLOYEEID

public static final java.lang.String ORDER_BY_EMPLOYEEID
See Also:
Constant Field Values

ORDER_BY_USERNAME

public static final java.lang.String ORDER_BY_USERNAME
See Also:
Constant Field Values

ORDER_BY_CANAPPROVEOWN

public static final java.lang.String ORDER_BY_CANAPPROVEOWN
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values
Constructor Detail

SwapOrderApprovalVO

public SwapOrderApprovalVO()
Method Detail

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

isCanApproveOwn

public boolean isCanApproveOwn()

setCanApproveOwn

public void setCanApproveOwn(boolean canApproveOwn)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SwapOrderItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SwapOrderItemListResult

java.lang.Object
    extended by  bb.common.SwapOrderItemListResult
All Implemented Interfaces:
java.io.Serializable
public class SwapOrderItemListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_PARTFROM
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_SWOITEMNUMBER
Constructor Summary
SwapOrderItemListResult()
Method Summary
java.util.Date | getArriveDate()
java.math.BigDecimal | getAvgCost()
java.lang.String | getBuyer()
java.lang.String | getBuyerGroup()
int | getDelayDays()
java.util.Date | getDeliveryDate()
java.lang.String | getDescription()
java.util.Date | getDesiredDate()
java.lang.String | getItemComments()
java.lang.String | getItemStatus()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getProjectName()
java.math.BigDecimal | getReceivedQty()
java.lang.String | getRelatedDoc()
java.math.BigDecimal | getShippedQty()
java.math.BigDecimal | getStdCost()
java.util.Date | getSwapDate()
java.math.BigDecimal | getSwapQty()
java.lang.String | getSwoItemNumber()
java.lang.String | getSwoNumber()
java.lang.String | getVendorId()
void | setArriveDate(java.util.Date arriveDate)
void | setAvgCost(java.math.BigDecimal avgCost)
void | setBuyer(java.lang.String buyer)
void | setBuyerGroup(java.lang.String buyerGroup)
void | setDelayDays(int delayDays)
void | setDeliveryDate(java.util.Date deliveryDate)
void | setDescription(java.lang.String description)
void | setDesiredDate(java.util.Date desiredDate)
void | setItemComments(java.lang.String itemComments)
void | setItemStatus(java.lang.String itemStatus)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setProjectName(java.lang.String projectName)
void | setReceivedQty(java.math.BigDecimal receivedQty)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setShippedQty(java.math.BigDecimal shippedQty)
void | setStdCost(java.math.BigDecimal stdCost)
void | setSwapDate(java.util.Date swapDate)
void | setSwapQty(java.math.BigDecimal swapQty)
void | setSwoItemNumber(java.lang.String swoItemNumber)
void | setSwoNumber(java.lang.String swoNumber)
void | setVendorId(java.lang.String vendorId)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_SWOITEMNUMBER

public static final java.lang.String ORDER_BY_SWOITEMNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_PARTFROM

public static final java.lang.String ORDER_BY_PARTFROM
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

SwapOrderItemListResult

public SwapOrderItemListResult()
Method Detail

getSwoNumber

public java.lang.String getSwoNumber()

setSwoNumber

public void setSwoNumber(java.lang.String swoNumber)

getSwoItemNumber

public java.lang.String getSwoItemNumber()

setSwoItemNumber

public void setSwoItemNumber(java.lang.String swoItemNumber)

getItemComments

public java.lang.String getItemComments()

setItemComments

public void setItemComments(java.lang.String itemComments)

getSwapQty

public java.math.BigDecimal getSwapQty()

setSwapQty

public void setSwapQty(java.math.BigDecimal swapQty)

getShippedQty

public java.math.BigDecimal getShippedQty()

setShippedQty

public void setShippedQty(java.math.BigDecimal shippedQty)

getReceivedQty

public java.math.BigDecimal getReceivedQty()

setReceivedQty

public void setReceivedQty(java.math.BigDecimal receivedQty)

getAvgCost

public java.math.BigDecimal getAvgCost()

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getDeliveryDate

public java.util.Date getDeliveryDate()

setDeliveryDate

public void setDeliveryDate(java.util.Date deliveryDate)

getDesiredDate

public java.util.Date getDesiredDate()

setDesiredDate

public void setDesiredDate(java.util.Date desiredDate)

getDelayDays

public int getDelayDays()

setDelayDays

public void setDelayDays(int delayDays)

getArriveDate

public java.util.Date getArriveDate()

setArriveDate

public void setArriveDate(java.util.Date arriveDate)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getSwapDate

public java.util.Date getSwapDate()

setSwapDate

public void setSwapDate(java.util.Date swapDate)

getBuyer

public java.lang.String getBuyer()

setBuyer

public void setBuyer(java.lang.String buyer)

getBuyerGroup

public java.lang.String getBuyerGroup()

setBuyerGroup

public void setBuyerGroup(java.lang.String buyerGroup)

getProjectName

public java.lang.String getProjectName()

setProjectName

public void setProjectName(java.lang.String projectName)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getItemStatus

public java.lang.String getItemStatus()

setItemStatus

public void setItemStatus(java.lang.String itemStatus)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SwapOrderItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SwapOrderItemPK

java.lang.Object
    extended by  bb.common.SwapOrderItemPK
All Implemented Interfaces:
java.io.Serializable
public class SwapOrderItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SwapOrderItemPK()
SwapOrderItemPK(java.lang.String swapOrder, java.lang.String swapOrderItem)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getSwapOrder()
java.lang.String | getSwapOrderItem()
int | hashCode()
void | setSwapOrder(java.lang.String swapOrder)
void | setSwapOrderItem(java.lang.String swapOrderItem)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SwapOrderItemPK

public SwapOrderItemPK()

SwapOrderItemPK

public SwapOrderItemPK(java.lang.String swapOrder,
                       java.lang.String swapOrderItem)
Method Detail

getSwapOrder

public java.lang.String getSwapOrder()

setSwapOrder

public void setSwapOrder(java.lang.String swapOrder)

getSwapOrderItem

public java.lang.String getSwapOrderItem()

setSwapOrderItem

public void setSwapOrderItem(java.lang.String swapOrderItem)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SwapOrderItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SwapOrderItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SwapOrderItemVO
All Implemented Interfaces:
java.io.Serializable
public class SwapOrderItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SwapOrderItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getArriveDate()
java.math.BigDecimal | getAvgCost()
int | getDelayDays()
java.util.Date | getDeliveryDate()
java.lang.String | getDescription()
java.util.Date | getDesiredDate()
java.lang.String | getDwg()
java.lang.String | getItemComments()
java.lang.String | getItemPrivateNotes()
java.lang.String | getMfg()
java.lang.String | getMpn()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
SwapOrderItemPK | getPk()
java.math.BigDecimal | getReceivedQty()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.util.Set | getRefDocTwoes()
java.lang.String | getRevision()
java.math.BigDecimal | getShippedQty()
java.lang.String | getStatus()
java.math.BigDecimal | getStdCost()
java.math.BigDecimal | getSwapQty()
java.lang.String | getUnit()
int | hashCode()
void | setArriveDate(java.util.Date arriveDate)
void | setAvgCost(java.math.BigDecimal avgCost)
void | setDelayDays(int delayDays)
void | setDeliveryDate(java.util.Date deliveryDate)
void | setDescription(java.lang.String description)
void | setDesiredDate(java.util.Date desiredDate)
void | setDwg(java.lang.String dwg)
void | setItemComments(java.lang.String itemComments)
void | setItemPrivateNotes(java.lang.String itemPrivateNotes)
void | setMfg(java.lang.String mfg)
void | setMpn(java.lang.String mpn)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(SwapOrderItemPK pk)
void | setReceivedQty(java.math.BigDecimal receivedQty)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setRefDocTwoes(java.util.Set refDocTwoes)
void | setRevision(java.lang.String revision)
void | setShippedQty(java.math.BigDecimal shippedQty)
void | setStatus(java.lang.String status)
void | setStdCost(java.math.BigDecimal stdCost)
void | setSwapQty(java.math.BigDecimal swapQty)
void | setUnit(java.lang.String unit)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SwapOrderItemVO

public SwapOrderItemVO()
Method Detail

getPk

public SwapOrderItemPK getPk()

setPk

public void setPk(SwapOrderItemPK pk)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getSwapQty

public java.math.BigDecimal getSwapQty()

setSwapQty

public void setSwapQty(java.math.BigDecimal swapQty)

getShippedQty

public java.math.BigDecimal getShippedQty()

setShippedQty

public void setShippedQty(java.math.BigDecimal shippedQty)

getReceivedQty

public java.math.BigDecimal getReceivedQty()

setReceivedQty

public void setReceivedQty(java.math.BigDecimal receivedQty)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getAvgCost

public java.math.BigDecimal getAvgCost()

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getDeliveryDate

public java.util.Date getDeliveryDate()

setDeliveryDate

public void setDeliveryDate(java.util.Date deliveryDate)

getDesiredDate

public java.util.Date getDesiredDate()

setDesiredDate

public void setDesiredDate(java.util.Date desiredDate)

getDelayDays

public int getDelayDays()

setDelayDays

public void setDelayDays(int delayDays)

getArriveDate

public java.util.Date getArriveDate()

setArriveDate

public void setArriveDate(java.util.Date arriveDate)

getItemComments

public java.lang.String getItemComments()

setItemComments

public void setItemComments(java.lang.String itemComments)

getItemPrivateNotes

public java.lang.String getItemPrivateNotes()

setItemPrivateNotes

public void setItemPrivateNotes(java.lang.String itemPrivateNotes)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getDwg

public java.lang.String getDwg()

setDwg

public void setDwg(java.lang.String dwg)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getRefDocTwoes

public java.util.Set getRefDocTwoes()

setRefDocTwoes

public void setRefDocTwoes(java.util.Set refDocTwoes)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SwapOrderListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SwapOrderListResult

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SwapOrderVO
            extended by  bb.common.SwapOrderListResult
All Implemented Interfaces:
java.io.Serializable
public class SwapOrderListResult
extends SwapOrderVO

See Also:
Serialized Form

Constructor Summary
SwapOrderListResult()
Method Summary
java.util.Date | getAdate()
java.lang.String | getApprovedBy()
java.util.Date | getApprovedDate()
java.lang.String | getBuyer()
java.lang.String | getBuyerGroup()
java.lang.String | getCarrier()
java.lang.String | getCarrierAccount()
java.lang.String | getComments()
java.lang.String | getContact()
java.math.BigDecimal | getFreight()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getNotes()
java.lang.String | getOrigin()
java.lang.String | getProjectName()
java.lang.String | getRelatedDoc()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.util.Date | getSwapDate()
java.lang.String | getSwapOrderNumber()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
void | setAdate(java.util.Date adate)
void | setApprovedBy(java.lang.String approvedBy)
void | setApprovedDate(java.util.Date approvedDate)
void | setBuyer(java.lang.String buyer)
void | setBuyerGroup(java.lang.String buyerGroup)
void | setCarrier(java.lang.String carrier)
void | setCarrierAccount(java.lang.String carrierAccount)
void | setComments(java.lang.String comments)
void | setContact(java.lang.String contact)
void | setFreight(java.math.BigDecimal freight)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setNotes(java.lang.String notes)
void | setOrigin(java.lang.String origin)
void | setProjectName(java.lang.String projectName)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setSwapDate(java.util.Date swapDate)
void | setSwapOrderNumber(java.lang.String swapOrderNumber)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
Methods inherited from class bb.common.SwapOrderVO
equals, getSwapOrderItems, getVendorAddressInfo, hashCode, setSwapOrderItems, setVendorAddressInfo, toString
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SwapOrderListResult

public SwapOrderListResult()
Method Detail

getVendorName

public java.lang.String getVendorName()

setVendorName

public void setVendorName(java.lang.String vendorName)

getSwapOrderNumber

public java.lang.String getSwapOrderNumber()
Overrides:
getSwapOrderNumber in class SwapOrderVO

setSwapOrderNumber

public void setSwapOrderNumber(java.lang.String swapOrderNumber)
Overrides:
setSwapOrderNumber in class SwapOrderVO

getLastChangeUser

public java.lang.String getLastChangeUser()
Overrides:
getLastChangeUser in class SwapOrderVO

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)
Overrides:
setLastChangeUser in class SwapOrderVO

getLastChangeDate

public java.util.Date getLastChangeDate()
Overrides:
getLastChangeDate in class SwapOrderVO

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)
Overrides:
setLastChangeDate in class SwapOrderVO

getAdate

public java.util.Date getAdate()
Overrides:
getAdate in class SwapOrderVO

setAdate

public void setAdate(java.util.Date adate)
Overrides:
setAdate in class SwapOrderVO

getOrigin

public java.lang.String getOrigin()
Overrides:
getOrigin in class SwapOrderVO

setOrigin

public void setOrigin(java.lang.String origin)
Overrides:
setOrigin in class SwapOrderVO

getVendorId

public java.lang.String getVendorId()
Overrides:
getVendorId in class SwapOrderVO

setVendorId

public void setVendorId(java.lang.String vendorId)
Overrides:
setVendorId in class SwapOrderVO

getContact

public java.lang.String getContact()
Overrides:
getContact in class SwapOrderVO

setContact

public void setContact(java.lang.String contact)
Overrides:
setContact in class SwapOrderVO

getStatus

public java.lang.String getStatus()
Overrides:
getStatus in class SwapOrderVO

setStatus

public void setStatus(java.lang.String status)
Overrides:
setStatus in class SwapOrderVO

getApprovedDate

public java.util.Date getApprovedDate()
Overrides:
getApprovedDate in class SwapOrderVO

setApprovedDate

public void setApprovedDate(java.util.Date approvedDate)
Overrides:
setApprovedDate in class SwapOrderVO

getApprovedBy

public java.lang.String getApprovedBy()
Overrides:
getApprovedBy in class SwapOrderVO

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)
Overrides:
setApprovedBy in class SwapOrderVO

getLanguage

public java.lang.String getLanguage()
Overrides:
getLanguage in class SwapOrderVO

setLanguage

public void setLanguage(java.lang.String language)
Overrides:
setLanguage in class SwapOrderVO

getSwapDate

public java.util.Date getSwapDate()
Overrides:
getSwapDate in class SwapOrderVO

setSwapDate

public void setSwapDate(java.util.Date swapDate)
Overrides:
setSwapDate in class SwapOrderVO

getBuyer

public java.lang.String getBuyer()
Overrides:
getBuyer in class SwapOrderVO

setBuyer

public void setBuyer(java.lang.String buyer)
Overrides:
setBuyer in class SwapOrderVO

getBuyerGroup

public java.lang.String getBuyerGroup()
Overrides:
getBuyerGroup in class SwapOrderVO

setBuyerGroup

public void setBuyerGroup(java.lang.String buyerGroup)
Overrides:
setBuyerGroup in class SwapOrderVO

getProjectName

public java.lang.String getProjectName()
Overrides:
getProjectName in class SwapOrderVO

setProjectName

public void setProjectName(java.lang.String projectName)
Overrides:
setProjectName in class SwapOrderVO

getRelatedDoc

public java.lang.String getRelatedDoc()
Overrides:
getRelatedDoc in class SwapOrderVO

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)
Overrides:
setRelatedDoc in class SwapOrderVO

getComments

public java.lang.String getComments()
Overrides:
getComments in class SwapOrderVO

setComments

public void setComments(java.lang.String comments)
Overrides:
setComments in class SwapOrderVO

getNotes

public java.lang.String getNotes()
Overrides:
getNotes in class SwapOrderVO

setNotes

public void setNotes(java.lang.String notes)
Overrides:
setNotes in class SwapOrderVO

getFreight

public java.math.BigDecimal getFreight()
Overrides:
getFreight in class SwapOrderVO

setFreight

public void setFreight(java.math.BigDecimal freight)
Overrides:
setFreight in class SwapOrderVO

getCarrier

public java.lang.String getCarrier()
Overrides:
getCarrier in class SwapOrderVO

setCarrier

public void setCarrier(java.lang.String carrier)
Overrides:
setCarrier in class SwapOrderVO

getCarrierAccount

public java.lang.String getCarrierAccount()
Overrides:
getCarrierAccount in class SwapOrderVO

setCarrierAccount

public void setCarrierAccount(java.lang.String carrierAccount)
Overrides:
setCarrierAccount in class SwapOrderVO

getIncoterm

public java.lang.String getIncoterm()
Overrides:
getIncoterm in class SwapOrderVO

setIncoterm

public void setIncoterm(java.lang.String incoterm)
Overrides:
setIncoterm in class SwapOrderVO

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()
Overrides:
getIncotermPlacePort in class SwapOrderVO

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)
Overrides:
setIncotermPlacePort in class SwapOrderVO

getShipVia

public java.lang.String getShipVia()
Overrides:
getShipVia in class SwapOrderVO

setShipVia

public void setShipVia(java.lang.String shipVia)
Overrides:
setShipVia in class SwapOrderVO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SwapOrderVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SwapOrderVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SwapOrderVO
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
SwapOrderListResult
public class SwapOrderVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SwapOrderVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.lang.String | getApprovedBy()
java.util.Date | getApprovedDate()
java.lang.String | getBuyer()
java.lang.String | getBuyerGroup()
java.lang.String | getCarrier()
java.lang.String | getCarrierAccount()
java.lang.String | getComments()
java.lang.String | getContact()
java.math.BigDecimal | getFreight()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getNotes()
java.lang.String | getOrigin()
java.lang.String | getProjectName()
java.lang.String | getRelatedDoc()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.util.Date | getSwapDate()
java.util.Set<SwapOrderItemVO> | getSwapOrderItems()
java.lang.String | getSwapOrderNumber()
CustomerVendorAddressInfoVO | getVendorAddressInfo()
java.lang.String | getVendorId()
int | hashCode()
void | setAdate(java.util.Date adate)
void | setApprovedBy(java.lang.String approvedBy)
void | setApprovedDate(java.util.Date approvedDate)
void | setBuyer(java.lang.String buyer)
void | setBuyerGroup(java.lang.String buyerGroup)
void | setCarrier(java.lang.String carrier)
void | setCarrierAccount(java.lang.String carrierAccount)
void | setComments(java.lang.String comments)
void | setContact(java.lang.String contact)
void | setFreight(java.math.BigDecimal freight)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setNotes(java.lang.String notes)
void | setOrigin(java.lang.String origin)
void | setProjectName(java.lang.String projectName)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setSwapDate(java.util.Date swapDate)
void | setSwapOrderItems(java.util.Set<SwapOrderItemVO> swapOrderItems)
void | setSwapOrderNumber(java.lang.String swapOrderNumber)
void | setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)
void | setVendorId(java.lang.String vendorId)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SwapOrderVO

public SwapOrderVO()
Method Detail

getSwapOrderNumber

public java.lang.String getSwapOrderNumber()

setSwapOrderNumber

public void setSwapOrderNumber(java.lang.String swapOrderNumber)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getApprovedDate

public java.util.Date getApprovedDate()

setApprovedDate

public void setApprovedDate(java.util.Date approvedDate)

getApprovedBy

public java.lang.String getApprovedBy()

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getSwapDate

public java.util.Date getSwapDate()

setSwapDate

public void setSwapDate(java.util.Date swapDate)

getBuyer

public java.lang.String getBuyer()

setBuyer

public void setBuyer(java.lang.String buyer)

getBuyerGroup

public java.lang.String getBuyerGroup()

setBuyerGroup

public void setBuyerGroup(java.lang.String buyerGroup)

getProjectName

public java.lang.String getProjectName()

setProjectName

public void setProjectName(java.lang.String projectName)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getNotes

public java.lang.String getNotes()

setNotes

public void setNotes(java.lang.String notes)

getVendorAddressInfo

public CustomerVendorAddressInfoVO getVendorAddressInfo()

setVendorAddressInfo

public void setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)

getSwapOrderItems

public java.util.Set<SwapOrderItemVO> getSwapOrderItems()

setSwapOrderItems

public void setSwapOrderItems(java.util.Set<SwapOrderItemVO> swapOrderItems)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getFreight

public java.math.BigDecimal getFreight()

setFreight

public void setFreight(java.math.BigDecimal freight)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAccount

public java.lang.String getCarrierAccount()

setCarrierAccount

public void setCarrierAccount(java.lang.String carrierAccount)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SwapReceiverItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SwapReceiverItemListResult

java.lang.Object
    extended by  bb.common.SwapReceiverItemListResult
All Implemented Interfaces:
java.io.Serializable
public class SwapReceiverItemListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AVGCOST
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_PARTFROM
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_RECEIVEDDATE
static java.lang.String | ORDER_BY_RECEIVEDQTY
static java.lang.String | ORDER_BY_SHIPPEDQTY
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_STDCOST
static java.lang.String | ORDER_BY_SWAPORDERNUMBER
static java.lang.String | ORDER_BY_SWAPQTY
static java.lang.String | ORDER_BY_SWAPRECEIVERITEMNUMBER
static java.lang.String | ORDER_BY_SWAPRECEIVERNUMBER
static java.lang.String | ORDER_BY_SWAPSHIPPERNUMBER
Constructor Summary
SwapReceiverItemListResult()
Method Summary
java.math.BigDecimal | getAvgCost()
java.lang.String | getDescription()
java.lang.String | getItemComments()
java.lang.String | getItemPrivateNotes()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.util.Date | getReceivedDate()
java.math.BigDecimal | getReceivedQty()
java.math.BigDecimal | getShippedQty()
java.lang.String | getStatus()
java.math.BigDecimal | getStdCost()
java.lang.String | getSwapOrderNumber()
java.math.BigDecimal | getSwapQty()
java.lang.String | getSwapReceiverItemNumber()
java.lang.String | getSwapReceiverNumber()
java.lang.String | getSwapShipperNumber()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setDescription(java.lang.String description)
void | setItemComments(java.lang.String itemComments)
void | setItemPrivateNotes(java.lang.String itemPrivateNotes)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setReceivedDate(java.util.Date receivedDate)
void | setReceivedQty(java.math.BigDecimal receivedQty)
void | setShippedQty(java.math.BigDecimal shippedQty)
void | setStatus(java.lang.String status)
void | setStdCost(java.math.BigDecimal stdCost)
void | setSwapOrderNumber(java.lang.String swapOrderNumber)
void | setSwapQty(java.math.BigDecimal swapQty)
void | setSwapReceiverItemNumber(java.lang.String swapReceiverItemNumber)
void | setSwapReceiverNumber(java.lang.String swapReceiverNumber)
void | setSwapShipperNumber(java.lang.String swapShipperNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_SWAPRECEIVERNUMBER

public static final java.lang.String ORDER_BY_SWAPRECEIVERNUMBER
See Also:
Constant Field Values

ORDER_BY_SWAPSHIPPERNUMBER

public static final java.lang.String ORDER_BY_SWAPSHIPPERNUMBER
See Also:
Constant Field Values

ORDER_BY_SWAPORDERNUMBER

public static final java.lang.String ORDER_BY_SWAPORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_SWAPRECEIVERITEMNUMBER

public static final java.lang.String ORDER_BY_SWAPRECEIVERITEMNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_PARTFROM

public static final java.lang.String ORDER_BY_PARTFROM
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_SWAPQTY

public static final java.lang.String ORDER_BY_SWAPQTY
See Also:
Constant Field Values

ORDER_BY_SHIPPEDQTY

public static final java.lang.String ORDER_BY_SHIPPEDQTY
See Also:
Constant Field Values

ORDER_BY_RECEIVEDQTY

public static final java.lang.String ORDER_BY_RECEIVEDQTY
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_AVGCOST

public static final java.lang.String ORDER_BY_AVGCOST
See Also:
Constant Field Values

ORDER_BY_STDCOST

public static final java.lang.String ORDER_BY_STDCOST
See Also:
Constant Field Values

ORDER_BY_RECEIVEDDATE

public static final java.lang.String ORDER_BY_RECEIVEDDATE
See Also:
Constant Field Values
Constructor Detail

SwapReceiverItemListResult

public SwapReceiverItemListResult()
Method Detail

getSwapReceiverNumber

public java.lang.String getSwapReceiverNumber()

setSwapReceiverNumber

public void setSwapReceiverNumber(java.lang.String swapReceiverNumber)

getSwapShipperNumber

public java.lang.String getSwapShipperNumber()

setSwapShipperNumber

public void setSwapShipperNumber(java.lang.String swapShipperNumber)

getSwapOrderNumber

public java.lang.String getSwapOrderNumber()

setSwapOrderNumber

public void setSwapOrderNumber(java.lang.String swapOrderNumber)

getSwapReceiverItemNumber

public java.lang.String getSwapReceiverItemNumber()

setSwapReceiverItemNumber

public void setSwapReceiverItemNumber(java.lang.String swapReceiverItemNumber)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getSwapQty

public java.math.BigDecimal getSwapQty()

setSwapQty

public void setSwapQty(java.math.BigDecimal swapQty)

getShippedQty

public java.math.BigDecimal getShippedQty()

setShippedQty

public void setShippedQty(java.math.BigDecimal shippedQty)

getReceivedQty

public java.math.BigDecimal getReceivedQty()

setReceivedQty

public void setReceivedQty(java.math.BigDecimal receivedQty)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getAvgCost

public java.math.BigDecimal getAvgCost()

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getReceivedDate

public java.util.Date getReceivedDate()

setReceivedDate

public void setReceivedDate(java.util.Date receivedDate)

getItemComments

public java.lang.String getItemComments()

setItemComments

public void setItemComments(java.lang.String itemComments)

getItemPrivateNotes

public java.lang.String getItemPrivateNotes()

setItemPrivateNotes

public void setItemPrivateNotes(java.lang.String itemPrivateNotes)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SwapReceiverItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SwapReceiverItemPK

java.lang.Object
    extended by  bb.common.SwapReceiverItemPK
All Implemented Interfaces:
java.io.Serializable
public class SwapReceiverItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SwapReceiverItemPK()
SwapReceiverItemPK(java.lang.String swapReceiverNumber, java.lang.String swapReceiverItemNumber)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getSwapReceiverItemNumber()
java.lang.String | getSwapReceiverNumber()
int | hashCode()
void | setSwapReceiverItemNumber(java.lang.String swapReceiverItemNumber)
void | setSwapReceiverNumber(java.lang.String swapReceiverNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SwapReceiverItemPK

public SwapReceiverItemPK()

SwapReceiverItemPK

public SwapReceiverItemPK(java.lang.String swapReceiverNumber,
                          java.lang.String swapReceiverItemNumber)
Method Detail

getSwapReceiverNumber

public java.lang.String getSwapReceiverNumber()

setSwapReceiverNumber

public void setSwapReceiverNumber(java.lang.String swapReceiverNumber)

getSwapReceiverItemNumber

public java.lang.String getSwapReceiverItemNumber()

setSwapReceiverItemNumber

public void setSwapReceiverItemNumber(java.lang.String swapReceiverItemNumber)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SwapReceiverItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SwapReceiverItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SwapReceiverItemVO
All Implemented Interfaces:
java.io.Serializable
public class SwapReceiverItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SwapReceiverItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getAvgCost()
java.lang.String | getDescription()
java.lang.String | getDwg()
java.lang.String | getItemComments()
java.lang.String | getItemPrivateNotes()
java.lang.String | getLocation()
java.util.Map | getLocations()
java.lang.String | getMfg()
java.lang.String | getMpn()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
SwapReceiverItemPK | getPk()
java.util.Date | getReceivedDate()
java.math.BigDecimal | getReceivedQty()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.util.Set | getRefDocTwoes()
java.lang.String | getRevision()
java.math.BigDecimal | getShippedQty()
java.lang.String | getStatus()
java.math.BigDecimal | getStdCost()
java.math.BigDecimal | getSwapQty()
java.util.Map | getTrackings()
java.lang.String | getUnit()
int | hashCode()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setDescription(java.lang.String description)
void | setDwg(java.lang.String dwg)
void | setItemComments(java.lang.String itemComments)
void | setItemPrivateNotes(java.lang.String itemPrivateNotes)
void | setLocation(java.lang.String location)
void | setLocations(java.util.Map locations)
void | setMfg(java.lang.String mfg)
void | setMpn(java.lang.String mpn)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(SwapReceiverItemPK pk)
void | setReceivedDate(java.util.Date receivedDate)
void | setReceivedQty(java.math.BigDecimal receivedQty)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setRefDocTwoes(java.util.Set refDocTwoes)
void | setRevision(java.lang.String revision)
void | setShippedQty(java.math.BigDecimal shippedQty)
void | setStatus(java.lang.String status)
void | setStdCost(java.math.BigDecimal stdCost)
void | setSwapQty(java.math.BigDecimal swapQty)
void | setTrackings(java.util.Map trackings)
void | setUnit(java.lang.String unit)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SwapReceiverItemVO

public SwapReceiverItemVO()
Method Detail

getPk

public SwapReceiverItemPK getPk()

setPk

public void setPk(SwapReceiverItemPK pk)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getSwapQty

public java.math.BigDecimal getSwapQty()

setSwapQty

public void setSwapQty(java.math.BigDecimal swapQty)

getShippedQty

public java.math.BigDecimal getShippedQty()

setShippedQty

public void setShippedQty(java.math.BigDecimal shippedQty)

getReceivedQty

public java.math.BigDecimal getReceivedQty()

setReceivedQty

public void setReceivedQty(java.math.BigDecimal receivedQty)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getAvgCost

public java.math.BigDecimal getAvgCost()

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getReceivedDate

public java.util.Date getReceivedDate()

setReceivedDate

public void setReceivedDate(java.util.Date receivedDate)

getItemComments

public java.lang.String getItemComments()

setItemComments

public void setItemComments(java.lang.String itemComments)

getItemPrivateNotes

public java.lang.String getItemPrivateNotes()

setItemPrivateNotes

public void setItemPrivateNotes(java.lang.String itemPrivateNotes)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getDwg

public java.lang.String getDwg()

setDwg

public void setDwg(java.lang.String dwg)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getRefDocTwoes

public java.util.Set getRefDocTwoes()

setRefDocTwoes

public void setRefDocTwoes(java.util.Set refDocTwoes)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

getLocations

public java.util.Map getLocations()

setLocations

public void setLocations(java.util.Map locations)

getTrackings

public java.util.Map getTrackings()

setTrackings

public void setTrackings(java.util.Map trackings)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SwapReceiverListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SwapReceiverListResult

java.lang.Object
    extended by  bb.common.SwapReceiverListResult
All Implemented Interfaces:
java.io.Serializable
public class SwapReceiverListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ADATE
static java.lang.String | ORDER_BY_BUYER
static java.lang.String | ORDER_BY_BUYERGROUP
static java.lang.String | ORDER_BY_CARRIER
static java.lang.String | ORDER_BY_CARRIERACCOUNT
static java.lang.String | ORDER_BY_COCOMMENTS
static java.lang.String | ORDER_BY_CONTACT
static java.lang.String | ORDER_BY_FREIGHT
static java.lang.String | ORDER_BY_INCOTERM
static java.lang.String | ORDER_BY_INCOTERMPLACEPORT
static java.lang.String | ORDER_BY_ORIGIN
static java.lang.String | ORDER_BY_PROJECTNAME
static java.lang.String | ORDER_BY_RECEIVEDBY
static java.lang.String | ORDER_BY_RECEIVEDDATE
static java.lang.String | ORDER_BY_RELATEDDOC
static java.lang.String | ORDER_BY_SHIPVIA
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_SWAPORDERNUMBER
static java.lang.String | ORDER_BY_SWAPRECEIVERNUMBER
static java.lang.String | ORDER_BY_SWAPSHIPPERNUMBER
static java.lang.String | ORDER_BY_TRACKING
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_VENDORNAME
Constructor Summary
SwapReceiverListResult()
Method Summary
java.util.Date | getAdate()
java.lang.String | getBuyer()
java.lang.String | getBuyerGroup()
java.lang.String | getCarrier()
java.lang.String | getCarrierAccount()
java.lang.String | getCoComments()
java.lang.String | getComments()
java.lang.String | getContact()
java.math.BigDecimal | getFreight()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getNotes()
java.lang.String | getOrigin()
java.lang.String | getProjectName()
java.lang.String | getReceivedBy()
java.util.Date | getReceivedDate()
java.lang.String | getRelatedDoc()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.lang.String | getSwapOrderNumber()
java.lang.String | getSwapReceiverNumber()
java.lang.String | getSwapShipperNumber()
java.lang.String | getTracking()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
int | getVersion()
void | setAdate(java.util.Date adate)
void | setBuyer(java.lang.String buyer)
void | setBuyerGroup(java.lang.String buyerGroup)
void | setCarrier(java.lang.String carrier)
void | setCarrierAccount(java.lang.String carrierAccount)
void | setCoComments(java.lang.String coComments)
void | setComments(java.lang.String comments)
void | setContact(java.lang.String contact)
void | setFreight(java.math.BigDecimal freight)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setNotes(java.lang.String notes)
void | setOrigin(java.lang.String origin)
void | setProjectName(java.lang.String projectName)
void | setReceivedBy(java.lang.String receivedBy)
void | setReceivedDate(java.util.Date receivedDate)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setSwapOrderNumber(java.lang.String swapOrderNumber)
void | setSwapReceiverNumber(java.lang.String swapReceiverNumber)
void | setSwapShipperNumber(java.lang.String swapShipperNumber)
void | setTracking(java.lang.String tracking)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
void | setVersion(int version)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_VENDORNAME

public static final java.lang.String ORDER_BY_VENDORNAME
See Also:
Constant Field Values

ORDER_BY_SWAPRECEIVERNUMBER

public static final java.lang.String ORDER_BY_SWAPRECEIVERNUMBER
See Also:
Constant Field Values

ORDER_BY_SWAPSHIPPERNUMBER

public static final java.lang.String ORDER_BY_SWAPSHIPPERNUMBER
See Also:
Constant Field Values

ORDER_BY_SWAPORDERNUMBER

public static final java.lang.String ORDER_BY_SWAPORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_ADATE

public static final java.lang.String ORDER_BY_ADATE
See Also:
Constant Field Values

ORDER_BY_ORIGIN

public static final java.lang.String ORDER_BY_ORIGIN
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_CONTACT

public static final java.lang.String ORDER_BY_CONTACT
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_RECEIVEDDATE

public static final java.lang.String ORDER_BY_RECEIVEDDATE
See Also:
Constant Field Values

ORDER_BY_RECEIVEDBY

public static final java.lang.String ORDER_BY_RECEIVEDBY
See Also:
Constant Field Values

ORDER_BY_BUYER

public static final java.lang.String ORDER_BY_BUYER
See Also:
Constant Field Values

ORDER_BY_BUYERGROUP

public static final java.lang.String ORDER_BY_BUYERGROUP
See Also:
Constant Field Values

ORDER_BY_PROJECTNAME

public static final java.lang.String ORDER_BY_PROJECTNAME
See Also:
Constant Field Values

ORDER_BY_RELATEDDOC

public static final java.lang.String ORDER_BY_RELATEDDOC
See Also:
Constant Field Values

ORDER_BY_FREIGHT

public static final java.lang.String ORDER_BY_FREIGHT
See Also:
Constant Field Values

ORDER_BY_COCOMMENTS

public static final java.lang.String ORDER_BY_COCOMMENTS
See Also:
Constant Field Values

ORDER_BY_TRACKING

public static final java.lang.String ORDER_BY_TRACKING
See Also:
Constant Field Values

ORDER_BY_SHIPVIA

public static final java.lang.String ORDER_BY_SHIPVIA
See Also:
Constant Field Values

ORDER_BY_INCOTERM

public static final java.lang.String ORDER_BY_INCOTERM
See Also:
Constant Field Values

ORDER_BY_INCOTERMPLACEPORT

public static final java.lang.String ORDER_BY_INCOTERMPLACEPORT
See Also:
Constant Field Values

ORDER_BY_CARRIER

public static final java.lang.String ORDER_BY_CARRIER
See Also:
Constant Field Values

ORDER_BY_CARRIERACCOUNT

public static final java.lang.String ORDER_BY_CARRIERACCOUNT
See Also:
Constant Field Values
Constructor Detail

SwapReceiverListResult

public SwapReceiverListResult()
Method Detail

getVendorName

public java.lang.String getVendorName()

setVendorName

public void setVendorName(java.lang.String vendorName)

getSwapReceiverNumber

public java.lang.String getSwapReceiverNumber()

setSwapReceiverNumber

public void setSwapReceiverNumber(java.lang.String swapReceiverNumber)

getSwapShipperNumber

public java.lang.String getSwapShipperNumber()

setSwapShipperNumber

public void setSwapShipperNumber(java.lang.String swapShipperNumber)

getSwapOrderNumber

public java.lang.String getSwapOrderNumber()

setSwapOrderNumber

public void setSwapOrderNumber(java.lang.String swapOrderNumber)

getVersion

public int getVersion()

setVersion

public void setVersion(int version)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getReceivedDate

public java.util.Date getReceivedDate()

setReceivedDate

public void setReceivedDate(java.util.Date receivedDate)

getReceivedBy

public java.lang.String getReceivedBy()

setReceivedBy

public void setReceivedBy(java.lang.String receivedBy)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getBuyer

public java.lang.String getBuyer()

setBuyer

public void setBuyer(java.lang.String buyer)

getBuyerGroup

public java.lang.String getBuyerGroup()

setBuyerGroup

public void setBuyerGroup(java.lang.String buyerGroup)

getProjectName

public java.lang.String getProjectName()

setProjectName

public void setProjectName(java.lang.String projectName)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getNotes

public java.lang.String getNotes()

setNotes

public void setNotes(java.lang.String notes)

getFreight

public java.math.BigDecimal getFreight()

setFreight

public void setFreight(java.math.BigDecimal freight)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAccount

public java.lang.String getCarrierAccount()

setCarrierAccount

public void setCarrierAccount(java.lang.String carrierAccount)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getCoComments

public java.lang.String getCoComments()

setCoComments

public void setCoComments(java.lang.String coComments)

getTracking

public java.lang.String getTracking()

setTracking

public void setTracking(java.lang.String tracking)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SwapReceiverVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SwapReceiverVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SwapReceiverVO
All Implemented Interfaces:
java.io.Serializable
public class SwapReceiverVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SwapReceiverVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.lang.String | getBuyer()
java.lang.String | getBuyerGroup()
java.lang.String | getCarrier()
java.lang.String | getCarrierAccount()
java.lang.String | getCoComments()
java.lang.String | getComments()
java.lang.String | getContact()
java.math.BigDecimal | getFreight()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getNotes()
java.lang.String | getOrigin()
java.lang.String | getProjectName()
java.lang.String | getReceivedBy()
java.util.Date | getReceivedDate()
java.lang.String | getRelatedDoc()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.lang.String | getSwapOrderNumber()
java.util.Set<SwapReceiverItemVO> | getSwapReceiverItems()
java.lang.String | getSwapReceiverNumber()
java.lang.String | getSwapShipperNumber()
java.lang.String | getTracking()
CustomerVendorAddressInfoVO | getVendorAddressInfo()
java.lang.String | getVendorId()
int | getVersion()
int | hashCode()
void | setAdate(java.util.Date adate)
void | setBuyer(java.lang.String buyer)
void | setBuyerGroup(java.lang.String buyerGroup)
void | setCarrier(java.lang.String carrier)
void | setCarrierAccount(java.lang.String carrierAccount)
void | setCoComments(java.lang.String coComments)
void | setComments(java.lang.String comments)
void | setContact(java.lang.String contact)
void | setFreight(java.math.BigDecimal freight)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setNotes(java.lang.String notes)
void | setOrigin(java.lang.String origin)
void | setProjectName(java.lang.String projectName)
void | setReceivedBy(java.lang.String receivedBy)
void | setReceivedDate(java.util.Date receivedDate)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setSwapOrderNumber(java.lang.String swapOrderNumber)
void | setSwapReceiverItems(java.util.Set<SwapReceiverItemVO> swapReceiverItems)
void | setSwapReceiverNumber(java.lang.String swapReceiverNumber)
void | setSwapShipperNumber(java.lang.String swapShipperNumber)
void | setTracking(java.lang.String tracking)
void | setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)
void | setVendorId(java.lang.String vendorId)
void | setVersion(int version)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SwapReceiverVO

public SwapReceiverVO()
Method Detail

getSwapReceiverNumber

public java.lang.String getSwapReceiverNumber()

setSwapReceiverNumber

public void setSwapReceiverNumber(java.lang.String swapReceiverNumber)

getSwapShipperNumber

public java.lang.String getSwapShipperNumber()

setSwapShipperNumber

public void setSwapShipperNumber(java.lang.String swapShipperNumber)

getSwapOrderNumber

public java.lang.String getSwapOrderNumber()

setSwapOrderNumber

public void setSwapOrderNumber(java.lang.String swapOrderNumber)

getVersion

public int getVersion()

setVersion

public void setVersion(int version)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getReceivedDate

public java.util.Date getReceivedDate()

setReceivedDate

public void setReceivedDate(java.util.Date receivedDate)

getReceivedBy

public java.lang.String getReceivedBy()

setReceivedBy

public void setReceivedBy(java.lang.String receivedBy)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getBuyer

public java.lang.String getBuyer()

setBuyer

public void setBuyer(java.lang.String buyer)

getBuyerGroup

public java.lang.String getBuyerGroup()

setBuyerGroup

public void setBuyerGroup(java.lang.String buyerGroup)

getProjectName

public java.lang.String getProjectName()

setProjectName

public void setProjectName(java.lang.String projectName)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getNotes

public java.lang.String getNotes()

setNotes

public void setNotes(java.lang.String notes)

getFreight

public java.math.BigDecimal getFreight()

setFreight

public void setFreight(java.math.BigDecimal freight)

getVendorAddressInfo

public CustomerVendorAddressInfoVO getVendorAddressInfo()

setVendorAddressInfo

public void setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)

getSwapReceiverItems

public java.util.Set<SwapReceiverItemVO> getSwapReceiverItems()

setSwapReceiverItems

public void setSwapReceiverItems(java.util.Set<SwapReceiverItemVO> swapReceiverItems)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAccount

public java.lang.String getCarrierAccount()

setCarrierAccount

public void setCarrierAccount(java.lang.String carrierAccount)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getCoComments

public java.lang.String getCoComments()

setCoComments

public void setCoComments(java.lang.String coComments)

getTracking

public java.lang.String getTracking()

setTracking

public void setTracking(java.lang.String tracking)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SwapShipperItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SwapShipperItemListResult

java.lang.Object
    extended by  bb.common.SwapShipperItemListResult
All Implemented Interfaces:
java.io.Serializable
public class SwapShipperItemListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AVGCOST
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_ITEMCOMMENTS
static java.lang.String | ORDER_BY_ITEMPRIVATENOTES
static java.lang.String | ORDER_BY_PARTFROM
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_RECEIVEDQTY
static java.lang.String | ORDER_BY_SHIPPEDATE
static java.lang.String | ORDER_BY_SHIPPEDQTY
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_STDCOST
static java.lang.String | ORDER_BY_SWAPORDERNUMBER
static java.lang.String | ORDER_BY_SWAPQTY
static java.lang.String | ORDER_BY_SWAPSHIPPERITEMNUMBER
static java.lang.String | ORDER_BY_SWAPSHIPPERNUMBER
Constructor Summary
SwapShipperItemListResult()
Method Summary
java.math.BigDecimal | getAvgCost()
java.lang.String | getDescription()
java.lang.String | getItemComments()
java.lang.String | getItemPrivateNotes()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getReceivedQty()
java.util.Date | getShippedDate()
java.math.BigDecimal | getShippedQty()
java.lang.String | getStatus()
java.math.BigDecimal | getStdCost()
java.lang.String | getSwapOrderNumber()
java.math.BigDecimal | getSwapQty()
java.lang.String | getSwapShipperItemNumber()
java.lang.String | getSwapShipperNumber()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setDescription(java.lang.String description)
void | setItemComments(java.lang.String itemComments)
void | setItemPrivateNotes(java.lang.String itemPrivateNotes)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setReceivedQty(java.math.BigDecimal receivedQty)
void | setShippedDate(java.util.Date shippedDate)
void | setShippedQty(java.math.BigDecimal shippedQty)
void | setStatus(java.lang.String status)
void | setStdCost(java.math.BigDecimal stdCost)
void | setSwapOrderNumber(java.lang.String swapOrderNumber)
void | setSwapQty(java.math.BigDecimal swapQty)
void | setSwapShipperItemNumber(java.lang.String swapShipperItemNumber)
void | setSwapShipperNumber(java.lang.String swapShipperNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_SWAPSHIPPERNUMBER

public static final java.lang.String ORDER_BY_SWAPSHIPPERNUMBER
See Also:
Constant Field Values

ORDER_BY_SWAPORDERNUMBER

public static final java.lang.String ORDER_BY_SWAPORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_SWAPSHIPPERITEMNUMBER

public static final java.lang.String ORDER_BY_SWAPSHIPPERITEMNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_PARTFROM

public static final java.lang.String ORDER_BY_PARTFROM
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_SWAPQTY

public static final java.lang.String ORDER_BY_SWAPQTY
See Also:
Constant Field Values

ORDER_BY_SHIPPEDQTY

public static final java.lang.String ORDER_BY_SHIPPEDQTY
See Also:
Constant Field Values

ORDER_BY_RECEIVEDQTY

public static final java.lang.String ORDER_BY_RECEIVEDQTY
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_AVGCOST

public static final java.lang.String ORDER_BY_AVGCOST
See Also:
Constant Field Values

ORDER_BY_STDCOST

public static final java.lang.String ORDER_BY_STDCOST
See Also:
Constant Field Values

ORDER_BY_SHIPPEDATE

public static final java.lang.String ORDER_BY_SHIPPEDATE
See Also:
Constant Field Values

ORDER_BY_ITEMCOMMENTS

public static final java.lang.String ORDER_BY_ITEMCOMMENTS
See Also:
Constant Field Values

ORDER_BY_ITEMPRIVATENOTES

public static final java.lang.String ORDER_BY_ITEMPRIVATENOTES
See Also:
Constant Field Values
Constructor Detail

SwapShipperItemListResult

public SwapShipperItemListResult()
Method Detail

getSwapShipperNumber

public java.lang.String getSwapShipperNumber()

setSwapShipperNumber

public void setSwapShipperNumber(java.lang.String swapShipperNumber)

getSwapOrderNumber

public java.lang.String getSwapOrderNumber()

setSwapOrderNumber

public void setSwapOrderNumber(java.lang.String swapOrderNumber)

getSwapShipperItemNumber

public java.lang.String getSwapShipperItemNumber()

setSwapShipperItemNumber

public void setSwapShipperItemNumber(java.lang.String swapShipperItemNumber)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getSwapQty

public java.math.BigDecimal getSwapQty()

setSwapQty

public void setSwapQty(java.math.BigDecimal swapQty)

getShippedQty

public java.math.BigDecimal getShippedQty()

setShippedQty

public void setShippedQty(java.math.BigDecimal shippedQty)

getReceivedQty

public java.math.BigDecimal getReceivedQty()

setReceivedQty

public void setReceivedQty(java.math.BigDecimal receivedQty)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getAvgCost

public java.math.BigDecimal getAvgCost()

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getShippedDate

public java.util.Date getShippedDate()

setShippedDate

public void setShippedDate(java.util.Date shippedDate)

getItemComments

public java.lang.String getItemComments()

setItemComments

public void setItemComments(java.lang.String itemComments)

getItemPrivateNotes

public java.lang.String getItemPrivateNotes()

setItemPrivateNotes

public void setItemPrivateNotes(java.lang.String itemPrivateNotes)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SwapShipperItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SwapShipperItemPK

java.lang.Object
    extended by  bb.common.SwapShipperItemPK
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<SwapShipperItemPK>
public class SwapShipperItemPK
extends java.lang.Object
implements java.io.Serializable, java.lang.Comparable<SwapShipperItemPK>

See Also:
Serialized Form

Constructor Summary
SwapShipperItemPK()
SwapShipperItemPK(java.lang.String swapShipperNumber, java.lang.String swapShipperItemNumber)
Method Summary
int | compareTo(SwapShipperItemPK other)
boolean | equals(java.lang.Object other)
java.lang.String | getSwapShipperItemNumber()
java.lang.String | getSwapShipperNumber()
int | hashCode()
void | setSwapShipperItemNumber(java.lang.String swapShipperItemNumber)
void | setSwapShipperNumber(java.lang.String swapShipperNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SwapShipperItemPK

public SwapShipperItemPK()

SwapShipperItemPK

public SwapShipperItemPK(java.lang.String swapShipperNumber,
                         java.lang.String swapShipperItemNumber)
Method Detail

getSwapShipperNumber

public java.lang.String getSwapShipperNumber()

setSwapShipperNumber

public void setSwapShipperNumber(java.lang.String swapShipperNumber)

getSwapShipperItemNumber

public java.lang.String getSwapShipperItemNumber()

setSwapShipperItemNumber

public void setSwapShipperItemNumber(java.lang.String swapShipperItemNumber)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

compareTo

public int compareTo(SwapShipperItemPK other)
Specified by:
compareTo in interface java.lang.Comparable<SwapShipperItemPK>
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SwapShipperItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SwapShipperItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SwapShipperItemVO
All Implemented Interfaces:
java.io.Serializable
public class SwapShipperItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SwapShipperItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getAvgCost()
java.lang.String | getDescription()
java.lang.String | getDwg()
java.lang.String | getItemComments()
java.lang.String | getItemPrivateNotes()
java.lang.String | getLocation()
java.util.Map | getLocations()
java.lang.String | getMfg()
java.lang.String | getMpn()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
SwapShipperItemPK | getPk()
java.math.BigDecimal | getReceivedQty()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.util.Set | getRefDocTwoes()
java.lang.String | getRevision()
java.util.Date | getShippedDate()
java.math.BigDecimal | getShippedQty()
java.lang.String | getStatus()
java.math.BigDecimal | getStdCost()
java.math.BigDecimal | getSwapQty()
java.util.Map | getTrackings()
java.lang.String | getUnit()
int | hashCode()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setDescription(java.lang.String description)
void | setDwg(java.lang.String dwg)
void | setItemComments(java.lang.String itemComments)
void | setItemPrivateNotes(java.lang.String itemPrivateNotes)
void | setLocation(java.lang.String location)
void | setLocations(java.util.Map locations)
void | setMfg(java.lang.String mfg)
void | setMpn(java.lang.String mpn)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(SwapShipperItemPK pk)
void | setReceivedQty(java.math.BigDecimal receivedQty)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setRefDocTwoes(java.util.Set refDocTwoes)
void | setRevision(java.lang.String revision)
void | setShippedDate(java.util.Date shippedDate)
void | setShippedQty(java.math.BigDecimal shippedQty)
void | setStatus(java.lang.String status)
void | setStdCost(java.math.BigDecimal stdCost)
void | setSwapQty(java.math.BigDecimal swapQty)
void | setTrackings(java.util.Map trackings)
void | setUnit(java.lang.String unit)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SwapShipperItemVO

public SwapShipperItemVO()
Method Detail

getPk

public SwapShipperItemPK getPk()

setPk

public void setPk(SwapShipperItemPK pk)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getSwapQty

public java.math.BigDecimal getSwapQty()

setSwapQty

public void setSwapQty(java.math.BigDecimal swapQty)

getShippedQty

public java.math.BigDecimal getShippedQty()

setShippedQty

public void setShippedQty(java.math.BigDecimal shippedQty)

getReceivedQty

public java.math.BigDecimal getReceivedQty()

setReceivedQty

public void setReceivedQty(java.math.BigDecimal receivedQty)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getAvgCost

public java.math.BigDecimal getAvgCost()

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getShippedDate

public java.util.Date getShippedDate()

setShippedDate

public void setShippedDate(java.util.Date shippedDate)

getItemComments

public java.lang.String getItemComments()

setItemComments

public void setItemComments(java.lang.String itemComments)

getItemPrivateNotes

public java.lang.String getItemPrivateNotes()

setItemPrivateNotes

public void setItemPrivateNotes(java.lang.String itemPrivateNotes)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getDwg

public java.lang.String getDwg()

setDwg

public void setDwg(java.lang.String dwg)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getRefDocTwoes

public java.util.Set getRefDocTwoes()

setRefDocTwoes

public void setRefDocTwoes(java.util.Set refDocTwoes)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

getLocations

public java.util.Map getLocations()

setLocations

public void setLocations(java.util.Map locations)

getTrackings

public java.util.Map getTrackings()

setTrackings

public void setTrackings(java.util.Map trackings)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SwapShipperListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SwapShipperListResult

java.lang.Object
    extended by  bb.common.SwapShipperListResult
All Implemented Interfaces:
java.io.Serializable
public class SwapShipperListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ADATE
static java.lang.String | ORDER_BY_BUYER
static java.lang.String | ORDER_BY_BUYERGROUP
static java.lang.String | ORDER_BY_CARRIER
static java.lang.String | ORDER_BY_CARRIERACCOUNT
static java.lang.String | ORDER_BY_COCOMMENTS
static java.lang.String | ORDER_BY_CONTACT
static java.lang.String | ORDER_BY_FREIGHT
static java.lang.String | ORDER_BY_FREIGHTRATECODE
static java.lang.String | ORDER_BY_GROSSWEIGHT
static java.lang.String | ORDER_BY_INCOTERM
static java.lang.String | ORDER_BY_INCOTERMPLACEPORT
static java.lang.String | ORDER_BY_PROJECTNAME
static java.lang.String | ORDER_BY_RELATEDDOC
static java.lang.String | ORDER_BY_SHIPPEDBY
static java.lang.String | ORDER_BY_SHIPPEDDATE
static java.lang.String | ORDER_BY_SHIPVIA
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_SWAPORDERNUMBER
static java.lang.String | ORDER_BY_SWAPSHIPPERNUMBER
static java.lang.String | ORDER_BY_TRACKING
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_VENDORNAME
Constructor Summary
SwapShipperListResult()
Method Summary
java.util.Date | getAdate()
java.lang.String | getBuyer()
java.lang.String | getBuyerGroup()
java.lang.String | getCarrier()
java.lang.String | getCarrierAccount()
java.lang.String | getCoComments()
java.lang.String | getComments()
java.lang.String | getContact()
java.math.BigDecimal | getFreight()
java.lang.String | getFreightRateCode()
java.lang.String | getGrossWeight()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getNotes()
java.lang.String | getOrigin()
java.lang.String | getProjectName()
java.lang.String | getRelatedDoc()
java.lang.String | getShippedBy()
java.util.Date | getShippedDate()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.lang.String | getSwapOrderNumber()
java.lang.String | getSwapShipperNumber()
java.lang.String | getTracking()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
int | getVersion()
void | setAdate(java.util.Date adate)
void | setBuyer(java.lang.String buyer)
void | setBuyerGroup(java.lang.String buyerGroup)
void | setCarrier(java.lang.String carrier)
void | setCarrierAccount(java.lang.String carrierAccount)
void | setCoComments(java.lang.String coComments)
void | setComments(java.lang.String comments)
void | setContact(java.lang.String contact)
void | setFreight(java.math.BigDecimal freight)
void | setFreightRateCode(java.lang.String freightRateCode)
void | setGrossWeight(java.lang.String grossWeight)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setNotes(java.lang.String notes)
void | setOrigin(java.lang.String origin)
void | setProjectName(java.lang.String projectName)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setShippedBy(java.lang.String shippedBy)
void | setShippedDate(java.util.Date shippedDate)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setSwapOrderNumber(java.lang.String swapOrderNumber)
void | setSwapShipperNumber(java.lang.String swapShipperNumber)
void | setTracking(java.lang.String tracking)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
void | setVersion(int version)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_VENDORNAME

public static final java.lang.String ORDER_BY_VENDORNAME
See Also:
Constant Field Values

ORDER_BY_SWAPSHIPPERNUMBER

public static final java.lang.String ORDER_BY_SWAPSHIPPERNUMBER
See Also:
Constant Field Values

ORDER_BY_SWAPORDERNUMBER

public static final java.lang.String ORDER_BY_SWAPORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_ADATE

public static final java.lang.String ORDER_BY_ADATE
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_CONTACT

public static final java.lang.String ORDER_BY_CONTACT
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_SHIPPEDDATE

public static final java.lang.String ORDER_BY_SHIPPEDDATE
See Also:
Constant Field Values

ORDER_BY_SHIPPEDBY

public static final java.lang.String ORDER_BY_SHIPPEDBY
See Also:
Constant Field Values

ORDER_BY_BUYER

public static final java.lang.String ORDER_BY_BUYER
See Also:
Constant Field Values

ORDER_BY_BUYERGROUP

public static final java.lang.String ORDER_BY_BUYERGROUP
See Also:
Constant Field Values

ORDER_BY_PROJECTNAME

public static final java.lang.String ORDER_BY_PROJECTNAME
See Also:
Constant Field Values

ORDER_BY_RELATEDDOC

public static final java.lang.String ORDER_BY_RELATEDDOC
See Also:
Constant Field Values

ORDER_BY_FREIGHT

public static final java.lang.String ORDER_BY_FREIGHT
See Also:
Constant Field Values

ORDER_BY_COCOMMENTS

public static final java.lang.String ORDER_BY_COCOMMENTS
See Also:
Constant Field Values

ORDER_BY_TRACKING

public static final java.lang.String ORDER_BY_TRACKING
See Also:
Constant Field Values

ORDER_BY_SHIPVIA

public static final java.lang.String ORDER_BY_SHIPVIA
See Also:
Constant Field Values

ORDER_BY_INCOTERM

public static final java.lang.String ORDER_BY_INCOTERM
See Also:
Constant Field Values

ORDER_BY_INCOTERMPLACEPORT

public static final java.lang.String ORDER_BY_INCOTERMPLACEPORT
See Also:
Constant Field Values

ORDER_BY_CARRIER

public static final java.lang.String ORDER_BY_CARRIER
See Also:
Constant Field Values

ORDER_BY_CARRIERACCOUNT

public static final java.lang.String ORDER_BY_CARRIERACCOUNT
See Also:
Constant Field Values

ORDER_BY_FREIGHTRATECODE

public static final java.lang.String ORDER_BY_FREIGHTRATECODE
See Also:
Constant Field Values

ORDER_BY_GROSSWEIGHT

public static final java.lang.String ORDER_BY_GROSSWEIGHT
See Also:
Constant Field Values
Constructor Detail

SwapShipperListResult

public SwapShipperListResult()
Method Detail

getVendorName

public java.lang.String getVendorName()

setVendorName

public void setVendorName(java.lang.String vendorName)

getSwapShipperNumber

public java.lang.String getSwapShipperNumber()

setSwapShipperNumber

public void setSwapShipperNumber(java.lang.String swapShipperNumber)

getSwapOrderNumber

public java.lang.String getSwapOrderNumber()

setSwapOrderNumber

public void setSwapOrderNumber(java.lang.String swapOrderNumber)

getVersion

public int getVersion()

setVersion

public void setVersion(int version)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getShippedDate

public java.util.Date getShippedDate()

setShippedDate

public void setShippedDate(java.util.Date shippedDate)

getShippedBy

public java.lang.String getShippedBy()

setShippedBy

public void setShippedBy(java.lang.String shippedBy)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getBuyer

public java.lang.String getBuyer()

setBuyer

public void setBuyer(java.lang.String buyer)

getBuyerGroup

public java.lang.String getBuyerGroup()

setBuyerGroup

public void setBuyerGroup(java.lang.String buyerGroup)

getProjectName

public java.lang.String getProjectName()

setProjectName

public void setProjectName(java.lang.String projectName)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getNotes

public java.lang.String getNotes()

setNotes

public void setNotes(java.lang.String notes)

getFreight

public java.math.BigDecimal getFreight()

setFreight

public void setFreight(java.math.BigDecimal freight)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAccount

public java.lang.String getCarrierAccount()

setCarrierAccount

public void setCarrierAccount(java.lang.String carrierAccount)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getCoComments

public java.lang.String getCoComments()

setCoComments

public void setCoComments(java.lang.String coComments)

getTracking

public java.lang.String getTracking()

setTracking

public void setTracking(java.lang.String tracking)

getFreightRateCode

public java.lang.String getFreightRateCode()

setFreightRateCode

public void setFreightRateCode(java.lang.String freightRateCode)

getGrossWeight

public java.lang.String getGrossWeight()

setGrossWeight

public void setGrossWeight(java.lang.String grossWeight)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SwapShipperOnOrderResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SwapShipperOnOrderResult

java.lang.Object
    extended by  bb.common.SwapShipperOnOrderResult
All Implemented Interfaces:
java.io.Serializable
public class SwapShipperOnOrderResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SwapShipperOnOrderResult()
Method Summary
java.lang.String | getDescription()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.math.BigDecimal | getQuantityOnOrder()
java.math.BigDecimal | getReceivedQty()
java.util.Date | getShippedDate()
java.math.BigDecimal | getShippedQty()
java.math.BigDecimal | getSwapQty()
SwapShipperItemPK | getSwapShipperItemPk()
java.lang.String | getVendorId()
void | setDescription(java.lang.String description)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setQuantityOnOrder(java.math.BigDecimal quantityOnOrder)
void | setReceivedQty(java.math.BigDecimal receivedQty)
void | setShippedDate(java.util.Date shippedDate)
void | setShippedQty(java.math.BigDecimal shippedQty)
void | setSwapQty(java.math.BigDecimal swapQty)
void | setSwapShipperItemPk(SwapShipperItemPK swapShipperItemPk)
void | setVendorId(java.lang.String vendorId)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SwapShipperOnOrderResult

public SwapShipperOnOrderResult()
Method Detail

getPartPk

public PartPK getPartPk()

setPartPk

public void setPartPk(PartPK partPk)

getSwapShipperItemPk

public SwapShipperItemPK getSwapShipperItemPk()

setSwapShipperItemPk

public void setSwapShipperItemPk(SwapShipperItemPK swapShipperItemPk)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getSwapQty

public java.math.BigDecimal getSwapQty()

setSwapQty

public void setSwapQty(java.math.BigDecimal swapQty)

getReceivedQty

public java.math.BigDecimal getReceivedQty()

setReceivedQty

public void setReceivedQty(java.math.BigDecimal receivedQty)

getShippedQty

public java.math.BigDecimal getShippedQty()

setShippedQty

public void setShippedQty(java.math.BigDecimal shippedQty)

getQuantityOnOrder

public java.math.BigDecimal getQuantityOnOrder()

setQuantityOnOrder

public void setQuantityOnOrder(java.math.BigDecimal quantityOnOrder)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getShippedDate

public java.util.Date getShippedDate()

setShippedDate

public void setShippedDate(java.util.Date shippedDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SwapShipperVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class SwapShipperVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.SwapShipperVO
All Implemented Interfaces:
java.io.Serializable
public class SwapShipperVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
SwapShipperVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.lang.String | getBuyer()
java.lang.String | getBuyerGroup()
java.lang.String | getCarrier()
java.lang.String | getCarrierAccount()
java.lang.String | getCoComments()
java.lang.String | getComments()
java.lang.String | getContact()
java.math.BigDecimal | getFreight()
java.lang.String | getFreightRateCode()
java.lang.String | getGrossWeight()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getNotes()
java.lang.String | getOrigin()
java.lang.String | getProjectName()
java.lang.String | getRelatedDoc()
java.lang.String | getShippedBy()
java.util.Date | getShippedDate()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.lang.String | getSwapOrderNumber()
java.util.Set<SwapShipperItemVO> | getSwapShipperItems()
java.lang.String | getSwapShipperNumber()
java.lang.String | getTracking()
CustomerVendorAddressInfoVO | getVendorAddressInfo()
java.lang.String | getVendorId()
int | getVersion()
int | hashCode()
void | setAdate(java.util.Date adate)
void | setBuyer(java.lang.String buyer)
void | setBuyerGroup(java.lang.String buyerGroup)
void | setCarrier(java.lang.String carrier)
void | setCarrierAccount(java.lang.String carrierAccount)
void | setCoComments(java.lang.String coComments)
void | setComments(java.lang.String comments)
void | setContact(java.lang.String contact)
void | setFreight(java.math.BigDecimal freight)
void | setFreightRateCode(java.lang.String freightRateCode)
void | setGrossWeight(java.lang.String grossWeight)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setNotes(java.lang.String notes)
void | setOrigin(java.lang.String origin)
void | setProjectName(java.lang.String projectName)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setShippedBy(java.lang.String shippedBy)
void | setShippedDate(java.util.Date shippedDate)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setSwapOrderNumber(java.lang.String swapOrderNumber)
void | setSwapShipperItems(java.util.Set<SwapShipperItemVO> swapShipperItems)
void | setSwapShipperNumber(java.lang.String swapShipperNumber)
void | setTracking(java.lang.String tracking)
void | setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)
void | setVendorId(java.lang.String vendorId)
void | setVersion(int version)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SwapShipperVO

public SwapShipperVO()
Method Detail

getSwapShipperNumber

public java.lang.String getSwapShipperNumber()

setSwapShipperNumber

public void setSwapShipperNumber(java.lang.String swapShipperNumber)

getSwapOrderNumber

public java.lang.String getSwapOrderNumber()

setSwapOrderNumber

public void setSwapOrderNumber(java.lang.String swapOrderNumber)

getVersion

public int getVersion()

setVersion

public void setVersion(int version)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getShippedDate

public java.util.Date getShippedDate()

setShippedDate

public void setShippedDate(java.util.Date shippedDate)

getShippedBy

public java.lang.String getShippedBy()

setShippedBy

public void setShippedBy(java.lang.String shippedBy)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getBuyer

public java.lang.String getBuyer()

setBuyer

public void setBuyer(java.lang.String buyer)

getBuyerGroup

public java.lang.String getBuyerGroup()

setBuyerGroup

public void setBuyerGroup(java.lang.String buyerGroup)

getProjectName

public java.lang.String getProjectName()

setProjectName

public void setProjectName(java.lang.String projectName)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getNotes

public java.lang.String getNotes()

setNotes

public void setNotes(java.lang.String notes)

getFreight

public java.math.BigDecimal getFreight()

setFreight

public void setFreight(java.math.BigDecimal freight)

getVendorAddressInfo

public CustomerVendorAddressInfoVO getVendorAddressInfo()

setVendorAddressInfo

public void setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)

getSwapShipperItems

public java.util.Set<SwapShipperItemVO> getSwapShipperItems()

setSwapShipperItems

public void setSwapShipperItems(java.util.Set<SwapShipperItemVO> swapShipperItems)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAccount

public java.lang.String getCarrierAccount()

setCarrierAccount

public void setCarrierAccount(java.lang.String carrierAccount)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getCoComments

public java.lang.String getCoComments()

setCoComments

public void setCoComments(java.lang.String coComments)

getTracking

public java.lang.String getTracking()

setTracking

public void setTracking(java.lang.String tracking)

getFreightRateCode

public java.lang.String getFreightRateCode()

setFreightRateCode

public void setFreightRateCode(java.lang.String freightRateCode)

getGrossWeight

public java.lang.String getGrossWeight()

setGrossWeight

public void setGrossWeight(java.lang.String grossWeight)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TakeCycleCountAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class TakeCycleCountAgent

java.lang.Object
    extended by  bb.common.TakeCycleCountAgent
All Implemented Interfaces:
java.io.Serializable
public class TakeCycleCountAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
TakeCycleCountAgent()
Method Summary
java.lang.String | getDescription()
java.lang.String | getOrderBy()
java.lang.String | getPartClass()
int | getWorkSheetNumber()
boolean | isZerolocation()
void | setDescription(java.lang.String description)
void | setOrderBy(java.lang.String orderBy)
void | setPartClass(java.lang.String partClass)
void | setWorkSheetNumber(int workSheetNumber)
void | setZerolocation(boolean zerolocation)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TakeCycleCountAgent

public TakeCycleCountAgent()
Method Detail

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getOrderBy

public java.lang.String getOrderBy()

setOrderBy

public void setOrderBy(java.lang.String orderBy)

getPartClass

public java.lang.String getPartClass()

setPartClass

public void setPartClass(java.lang.String partClass)

getWorkSheetNumber

public int getWorkSheetNumber()

setWorkSheetNumber

public void setWorkSheetNumber(int workSheetNumber)

isZerolocation

public boolean isZerolocation()

setZerolocation

public void setZerolocation(boolean zerolocation)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TaskFileResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class TaskFileResult

java.lang.Object
    extended by  bb.common.TaskFileResult
All Implemented Interfaces:
java.io.Serializable
public class TaskFileResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
TaskFileResult()
Method Summary
java.lang.String | getExtension()
java.util.Date | getFileDate()
java.lang.String | getFileName()
java.lang.Long | getIi()
java.lang.String | getPath()
long | getSize()
void | setExtension(java.lang.String extension)
void | setFileDate(java.util.Date fileDate)
void | setFileName(java.lang.String fileName)
void | setIi(java.lang.Long ii)
void | setPath(java.lang.String path)
void | setSize(long size)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TaskFileResult

public TaskFileResult()
Method Detail

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

getFileDate

public java.util.Date getFileDate()

setFileDate

public void setFileDate(java.util.Date fileDate)

getFileName

public java.lang.String getFileName()

setFileName

public void setFileName(java.lang.String fileName)

getPath

public java.lang.String getPath()

setPath

public void setPath(java.lang.String path)

getSize

public long getSize()

setSize

public void setSize(long size)

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TaskVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class TaskVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.TaskVO
All Implemented Interfaces:
java.io.Serializable
public class TaskVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
TaskVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.lang.String | getDescription()
java.lang.String | getEmailto()
java.util.Date | getEndDate()
java.lang.String | getFailEmailto()
java.lang.String | getFailNoticeReceivers()
int | getFailRepeat()
java.lang.Long | getIi()
java.lang.String | getName()
java.lang.String | getNoticeReceivers()
java.lang.String | getParams()
int | getRepeatDelay()
java.util.Date | getStartDate()
java.lang.String | getTdate()
java.lang.String | getTday()
java.lang.String | getThrs()
java.lang.String | getTmin()
java.lang.String | getTmonth()
int | hashCode()
boolean | isNeedLog()
boolean | isSendNotice()
void | setComments(java.lang.String comments)
void | setDescription(java.lang.String description)
void | setEmailto(java.lang.String emailto)
void | setEndDate(java.util.Date endDate)
void | setFailEmailto(java.lang.String failEmailto)
void | setFailNoticeReceivers(java.lang.String failNoticeReceivers)
void | setFailRepeat(int failRepeat)
void | setIi(java.lang.Long ii)
void | setName(java.lang.String name)
void | setNeedLog(boolean needLog)
void | setNoticeReceivers(java.lang.String noticeReceivers)
void | setParams(java.lang.String params)
void | setRepeatDelay(int repeatDelay)
void | setSendNotice(boolean sendNotice)
void | setStartDate(java.util.Date startDate)
void | setTdate(java.lang.String tdate)
void | setTday(java.lang.String tday)
void | setThrs(java.lang.String thrs)
void | setTmin(java.lang.String tmin)
void | setTmonth(java.lang.String tmonth)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

TaskVO

public TaskVO()
default constructor

Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getTmin

public java.lang.String getTmin()

setTmin

public void setTmin(java.lang.String tmin)

getThrs

public java.lang.String getThrs()

setThrs

public void setThrs(java.lang.String thrs)

getTdate

public java.lang.String getTdate()

setTdate

public void setTdate(java.lang.String tdate)

getTmonth

public java.lang.String getTmonth()

setTmonth

public void setTmonth(java.lang.String tmonth)

getTday

public java.lang.String getTday()

setTday

public void setTday(java.lang.String tday)

getParams

public java.lang.String getParams()

setParams

public void setParams(java.lang.String params)

getEmailto

public java.lang.String getEmailto()

setEmailto

public void setEmailto(java.lang.String emailto)

getFailEmailto

public java.lang.String getFailEmailto()

setFailEmailto

public void setFailEmailto(java.lang.String failEmailto)

getFailRepeat

public int getFailRepeat()

setFailRepeat

public void setFailRepeat(int failRepeat)

getRepeatDelay

public int getRepeatDelay()

setRepeatDelay

public void setRepeatDelay(int repeatDelay)

isNeedLog

public boolean isNeedLog()

setNeedLog

public void setNeedLog(boolean needLog)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getEndDate

public java.util.Date getEndDate()

setEndDate

public void setEndDate(java.util.Date endDate)

getStartDate

public java.util.Date getStartDate()

setStartDate

public void setStartDate(java.util.Date startDate)

getFailNoticeReceivers

public java.lang.String getFailNoticeReceivers()

setFailNoticeReceivers

public void setFailNoticeReceivers(java.lang.String failNoticeReceivers)

getNoticeReceivers

public java.lang.String getNoticeReceivers()

setNoticeReceivers

public void setNoticeReceivers(java.lang.String noticeReceivers)

isSendNotice

public boolean isSendNotice()

setSendNotice

public void setSendNotice(boolean sendNotice)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TaxAccountVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class TaxAccountVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.TaxAccountVO
All Implemented Interfaces:
java.io.Serializable
public class TaxAccountVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
TaxAccountVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAccountNumber()
java.lang.Integer | getIi()
java.math.BigDecimal | getPurchaseTaxRate()
java.math.BigDecimal | getSalesTaxRate()
int | hashCode()
void | setAccountNumber(java.lang.String accountNumber)
void | setIi(java.lang.Integer ii)
void | setPurchaseTaxRate(java.math.BigDecimal purchaseTaxRate)
void | setSalesTaxRate(java.math.BigDecimal salesTaxRate)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TaxAccountVO

public TaxAccountVO()
Method Detail

setIi

public void setIi(java.lang.Integer ii)

setSalesTaxRate

public void setSalesTaxRate(java.math.BigDecimal salesTaxRate)

setPurchaseTaxRate

public void setPurchaseTaxRate(java.math.BigDecimal purchaseTaxRate)

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getIi

public java.lang.Integer getIi()

getSalesTaxRate

public java.math.BigDecimal getSalesTaxRate()

getPurchaseTaxRate

public java.math.BigDecimal getPurchaseTaxRate()

getAccountNumber

public java.lang.String getAccountNumber()

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TempArApAgingVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class TempArApAgingVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.TempArApAgingVO
All Implemented Interfaces:
java.io.Serializable
public class TempArApAgingVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ARAPDATE
static java.lang.String | ORDER_BY_ARAPNUMBER
static java.lang.String | ORDER_BY_COMPANYUNITID
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_CUSTOMERID
static java.lang.String | ORDER_BY_CUSTOMERNAME
static java.lang.String | ORDER_BY_PAYDATE
static java.lang.String | ORDER_BY_PONUMBER
static java.lang.String | ORDER_BY_VENDORINVOICE
Constructor Summary
TempArApAgingVO()
Method Summary
java.util.Date | getArApDate()
java.lang.String | getArApNumber()
java.math.BigDecimal | getArApTotal()
java.lang.String | getCompanyUnitId()
java.lang.String | getCurrency()
java.lang.String | getCustomerId()
java.lang.String | getCustomerName()
java.math.BigDecimal | getDue()
java.math.BigDecimal | getExchange()
java.lang.Long | getIi()
java.util.Date | getLastChangeDate()
java.lang.String | getMothedParm()
java.math.BigDecimal | getPaid()
java.util.Date | getPayDate()
java.lang.String | getPoNumber()
java.lang.String | getStatus()
java.lang.String | getUser()
java.lang.String | getVendorInvoice()
void | setArApDate(java.util.Date arApDate)
void | setArApNumber(java.lang.String arApNumber)
void | setArApTotal(java.math.BigDecimal arApTotal)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCurrency(java.lang.String currency)
void | setCustomerId(java.lang.String customerId)
void | setCustomerName(java.lang.String customerName)
void | setDue(java.math.BigDecimal due)
void | setExchange(java.math.BigDecimal exchange)
void | setIi(java.lang.Long ii)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setMothedParm(java.lang.String mothedParm)
void | setPaid(java.math.BigDecimal paid)
void | setPayDate(java.util.Date payDate)
void | setPoNumber(java.lang.String poNumber)
void | setStatus(java.lang.String status)
void | setUser(java.lang.String user)
void | setVendorInvoice(java.lang.String vendorInvoice)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_CUSTOMERID

public static final java.lang.String ORDER_BY_CUSTOMERID
See Also:
Constant Field Values

ORDER_BY_CUSTOMERNAME

public static final java.lang.String ORDER_BY_CUSTOMERNAME
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values

ORDER_BY_ARAPNUMBER

public static final java.lang.String ORDER_BY_ARAPNUMBER
See Also:
Constant Field Values

ORDER_BY_ARAPDATE

public static final java.lang.String ORDER_BY_ARAPDATE
See Also:
Constant Field Values

ORDER_BY_PAYDATE

public static final java.lang.String ORDER_BY_PAYDATE
See Also:
Constant Field Values

ORDER_BY_PONUMBER

public static final java.lang.String ORDER_BY_PONUMBER
See Also:
Constant Field Values

ORDER_BY_COMPANYUNITID

public static final java.lang.String ORDER_BY_COMPANYUNITID
See Also:
Constant Field Values

ORDER_BY_VENDORINVOICE

public static final java.lang.String ORDER_BY_VENDORINVOICE
See Also:
Constant Field Values
Constructor Detail

TempArApAgingVO

public TempArApAgingVO()
Method Detail

setIi

public void setIi(java.lang.Long ii)

setUser

public void setUser(java.lang.String user)

setMothedParm

public void setMothedParm(java.lang.String mothedParm)

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

setArApNumber

public void setArApNumber(java.lang.String arApNumber)

setArApDate

public void setArApDate(java.util.Date arApDate)

setPayDate

public void setPayDate(java.util.Date payDate)

setCustomerId

public void setCustomerId(java.lang.String customerId)

setCustomerName

public void setCustomerName(java.lang.String customerName)

setCurrency

public void setCurrency(java.lang.String currency)

setExchange

public void setExchange(java.math.BigDecimal exchange)

setArApTotal

public void setArApTotal(java.math.BigDecimal arApTotal)

setPaid

public void setPaid(java.math.BigDecimal paid)

setDue

public void setDue(java.math.BigDecimal due)

setPoNumber

public void setPoNumber(java.lang.String poNumber)

setStatus

public void setStatus(java.lang.String status)

getIi

public java.lang.Long getIi()

getUser

public java.lang.String getUser()

getMothedParm

public java.lang.String getMothedParm()

getLastChangeDate

public java.util.Date getLastChangeDate()

getArApNumber

public java.lang.String getArApNumber()

getArApDate

public java.util.Date getArApDate()

getPayDate

public java.util.Date getPayDate()

getCustomerId

public java.lang.String getCustomerId()

getCustomerName

public java.lang.String getCustomerName()

getCurrency

public java.lang.String getCurrency()

getExchange

public java.math.BigDecimal getExchange()

getArApTotal

public java.math.BigDecimal getArApTotal()

getPaid

public java.math.BigDecimal getPaid()

getDue

public java.math.BigDecimal getDue()

getPoNumber

public java.lang.String getPoNumber()

getStatus

public java.lang.String getStatus()

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getVendorInvoice

public java.lang.String getVendorInvoice()

setVendorInvoice

public void setVendorInvoice(java.lang.String vendorInvoice)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TempReceiverWithoutAPInfo

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class TempReceiverWithoutAPInfo

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.TempReceiverWithoutAPInfo
All Implemented Interfaces:
java.io.Serializable
public class TempReceiverWithoutAPInfo
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_DATERECEIVED
static java.lang.String | ORDER_BY_DATESAVE
static java.lang.String | ORDER_BY_GRANTTOTAL
static java.lang.String | ORDER_BY_PURCHASEORDERNUMBER
static java.lang.String | ORDER_BY_RECEIVEDBY
static java.lang.String | ORDER_BY_RECEIVERNUMBER
static java.lang.String | ORDER_BY_SEARCHBUYER
static java.lang.String | ORDER_BY_SEARCHCURRENCY
static java.lang.String | ORDER_BY_SEARCHDATEFROM
static java.lang.String | ORDER_BY_SEARCHDATETO
static java.lang.String | ORDER_BY_SEARCHID
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_SUBTOTAL
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_VENDORNAME
Constructor Summary
TempReceiverWithoutAPInfo()
Method Summary
java.lang.String | getCurrency()
java.util.Date | getDateReceived()
java.util.Date | getDateSave()
java.math.BigDecimal | getGrantTotal()
java.lang.String | getPurchaseOrderNumber()
java.lang.String | getReceivedBy()
java.lang.String | getReceiverNumber()
java.lang.String | getSearchBuyer()
java.lang.String | getSearchCurrency()
java.util.Date | getSearchDateFrom()
java.util.Date | getSearchDateTo()
java.lang.String | getSearchId()
java.lang.String | getStatus()
java.math.BigDecimal | getSubTotal()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
void | setCurrency(java.lang.String currency)
void | setDateReceived(java.util.Date dateReceived)
void | setDateSave(java.util.Date dateSave)
void | setGrantTotal(java.math.BigDecimal grantTotal)
void | setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)
void | setReceivedBy(java.lang.String receivedBy)
void | setReceiverNumber(java.lang.String receiverNumber)
void | setSearchBuyer(java.lang.String searchBuyer)
void | setSearchCurrency(java.lang.String searchCurrency)
void | setSearchDateFrom(java.util.Date searchDateFrom)
void | setSearchDateTo(java.util.Date searchDateTo)
void | setSearchId(java.lang.String searchId)
void | setStatus(java.lang.String status)
void | setSubTotal(java.math.BigDecimal subTotal)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_DATESAVE

public static final java.lang.String ORDER_BY_DATESAVE
See Also:
Constant Field Values

ORDER_BY_SEARCHDATEFROM

public static final java.lang.String ORDER_BY_SEARCHDATEFROM
See Also:
Constant Field Values

ORDER_BY_SEARCHDATETO

public static final java.lang.String ORDER_BY_SEARCHDATETO
See Also:
Constant Field Values

ORDER_BY_SEARCHID

public static final java.lang.String ORDER_BY_SEARCHID
See Also:
Constant Field Values

ORDER_BY_SEARCHBUYER

public static final java.lang.String ORDER_BY_SEARCHBUYER
See Also:
Constant Field Values

ORDER_BY_SEARCHCURRENCY

public static final java.lang.String ORDER_BY_SEARCHCURRENCY
See Also:
Constant Field Values

ORDER_BY_RECEIVERNUMBER

public static final java.lang.String ORDER_BY_RECEIVERNUMBER
See Also:
Constant Field Values

ORDER_BY_PURCHASEORDERNUMBER

public static final java.lang.String ORDER_BY_PURCHASEORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_VENDORNAME

public static final java.lang.String ORDER_BY_VENDORNAME
See Also:
Constant Field Values

ORDER_BY_SUBTOTAL

public static final java.lang.String ORDER_BY_SUBTOTAL
See Also:
Constant Field Values

ORDER_BY_GRANTTOTAL

public static final java.lang.String ORDER_BY_GRANTTOTAL
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values

ORDER_BY_DATERECEIVED

public static final java.lang.String ORDER_BY_DATERECEIVED
See Also:
Constant Field Values

ORDER_BY_RECEIVEDBY

public static final java.lang.String ORDER_BY_RECEIVEDBY
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values
Constructor Detail

TempReceiverWithoutAPInfo

public TempReceiverWithoutAPInfo()
Method Detail

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getDateReceived

public java.util.Date getDateReceived()

setDateReceived

public void setDateReceived(java.util.Date dateReceived)

getDateSave

public java.util.Date getDateSave()

setDateSave

public void setDateSave(java.util.Date dateSave)

getGrantTotal

public java.math.BigDecimal getGrantTotal()

setGrantTotal

public void setGrantTotal(java.math.BigDecimal grantTotal)

getPurchaseOrderNumber

public java.lang.String getPurchaseOrderNumber()

setPurchaseOrderNumber

public void setPurchaseOrderNumber(java.lang.String purchaseOrderNumber)

getReceivedBy

public java.lang.String getReceivedBy()

setReceivedBy

public void setReceivedBy(java.lang.String receivedBy)

getReceiverNumber

public java.lang.String getReceiverNumber()

setReceiverNumber

public void setReceiverNumber(java.lang.String receiverNumber)

getSearchBuyer

public java.lang.String getSearchBuyer()

setSearchBuyer

public void setSearchBuyer(java.lang.String searchBuyer)

getSearchCurrency

public java.lang.String getSearchCurrency()

setSearchCurrency

public void setSearchCurrency(java.lang.String searchCurrency)

getSearchDateFrom

public java.util.Date getSearchDateFrom()

setSearchDateFrom

public void setSearchDateFrom(java.util.Date searchDateFrom)

getSearchDateTo

public java.util.Date getSearchDateTo()

setSearchDateTo

public void setSearchDateTo(java.util.Date searchDateTo)

getSearchId

public java.lang.String getSearchId()

setSearchId

public void setSearchId(java.lang.String searchId)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getSubTotal

public java.math.BigDecimal getSubTotal()

setSubTotal

public void setSubTotal(java.math.BigDecimal subTotal)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getVendorName

public java.lang.String getVendorName()

setVendorName

public void setVendorName(java.lang.String vendorName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TermAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class TermAgent

java.lang.Object
    extended by  bb.common.TermAgent
All Implemented Interfaces:
java.io.Serializable
public final class TermAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
TermAgent()
Method Summary
java.lang.String | getComments()
java.lang.Integer | getDays()
java.math.BigDecimal | getDiscount()
java.lang.Integer | getTerm()
java.lang.String | getTermAlias()
java.lang.String | getTermValue()
void | setComments(java.lang.String comments)
void | setDays(java.lang.Integer days)
void | setDiscount(java.math.BigDecimal discount)
void | setTerm(java.lang.Integer term)
void | setTermAlias(java.lang.String termAlias)
void | setTermValue(java.lang.String termValue)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TermAgent

public TermAgent()
Method Detail

getTerm

public java.lang.Integer getTerm()

setTerm

public void setTerm(java.lang.Integer term)

getDays

public java.lang.Integer getDays()

setDays

public void setDays(java.lang.Integer days)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getTermAlias

public java.lang.String getTermAlias()

setTermAlias

public void setTermAlias(java.lang.String termAlias)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getTermValue

public java.lang.String getTermValue()

setTermValue

public void setTermValue(java.lang.String termValue)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TermsConditionVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class TermsConditionVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.TermsConditionVO
All Implemented Interfaces:
java.io.Serializable
public class TermsConditionVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_EXTENSION
static java.lang.String | ORDER_BY_LENGTH
static java.lang.String | ORDER_BY_ORDERTYPE
static java.lang.String | ORDER_BY_SUMMARY
Constructor Summary
TermsConditionVO()
default constructor
TermsConditionVO(java.lang.Integer ii, java.util.Date lastChangeDate, java.lang.String orderType, byte[] document, java.lang.String extension, java.lang.String summary)
full constructor
TermsConditionVO(java.lang.Integer ii, java.lang.String orderType, java.lang.String extension)
minimal constructor
Method Summary
boolean | equals(java.lang.Object other)
byte[] | getDocument()
java.lang.String | getExtension()
java.lang.Integer | getIi()
java.util.Date | getLastChangeDate()
java.lang.Integer | getLength()
java.lang.String | getOrderType()
java.lang.String | getSummary()
int | hashCode()
void | setDocument(byte[] document)
void | setExtension(java.lang.String extension)
void | setIi(java.lang.Integer ii)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLength(java.lang.Integer length)
void | setOrderType(java.lang.String orderType)
void | setSummary(java.lang.String summary)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ORDERTYPE

public static final java.lang.String ORDER_BY_ORDERTYPE
See Also:
Constant Field Values

ORDER_BY_EXTENSION

public static final java.lang.String ORDER_BY_EXTENSION
See Also:
Constant Field Values

ORDER_BY_LENGTH

public static final java.lang.String ORDER_BY_LENGTH
See Also:
Constant Field Values

ORDER_BY_SUMMARY

public static final java.lang.String ORDER_BY_SUMMARY
See Also:
Constant Field Values
Constructor Detail

TermsConditionVO

public TermsConditionVO(java.lang.Integer ii,
                        java.util.Date lastChangeDate,
                        java.lang.String orderType,
                        byte[] document,
                        java.lang.String extension,
                        java.lang.String summary)
full constructor

TermsConditionVO

public TermsConditionVO()
default constructor

TermsConditionVO

public TermsConditionVO(java.lang.Integer ii,
                        java.lang.String orderType,
                        java.lang.String extension)
minimal constructor

Method Detail

getIi

public java.lang.Integer getIi()

setIi

public void setIi(java.lang.Integer ii)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getOrderType

public java.lang.String getOrderType()

setOrderType

public void setOrderType(java.lang.String orderType)

getDocument

public byte[] getDocument()

setDocument

public void setDocument(byte[] document)

getExtension

public java.lang.String getExtension()

getLength

public java.lang.Integer getLength()

setExtension

public void setExtension(java.lang.String extension)

setLength

public void setLength(java.lang.Integer length)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getSummary

public java.lang.String getSummary()

setSummary

public void setSummary(java.lang.String summary)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TermVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class TermVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.TermVO
All Implemented Interfaces:
java.io.Serializable
public class TermVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_DAYS
static java.lang.String | ORDER_BY_II
static java.lang.String | ORDER_BY_TERMVALUE
Constructor Summary
TermVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.lang.Integer | getDays()
java.math.BigDecimal | getDiscount()
java.lang.Integer | getIi()
java.lang.Integer | getTerm()
java.lang.String | getTermAlias()
java.lang.String | getTermValue()
int | hashCode()
void | setComments(java.lang.String comments)
void | setDays(java.lang.Integer days)
void | setDiscount(java.math.BigDecimal discount)
void | setIi(java.lang.Integer ii)
void | setTerm(java.lang.Integer term)
void | setTermAlias(java.lang.String termAlias)
void | setTermValue(java.lang.String termValue)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_II

public static final java.lang.String ORDER_BY_II
See Also:
Constant Field Values

ORDER_BY_TERMVALUE

public static final java.lang.String ORDER_BY_TERMVALUE
See Also:
Constant Field Values

ORDER_BY_DAYS

public static final java.lang.String ORDER_BY_DAYS
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values
Constructor Detail

TermVO

public TermVO()
Method Detail

getIi

public java.lang.Integer getIi()

setIi

public void setIi(java.lang.Integer ii)

getTerm

public java.lang.Integer getTerm()

setTerm

public void setTerm(java.lang.Integer term)

getDays

public java.lang.Integer getDays()

setDays

public void setDays(java.lang.Integer days)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getTermValue

public java.lang.String getTermValue()

setTermValue

public void setTermValue(java.lang.String termValue)

getTermAlias

public java.lang.String getTermAlias()

setTermAlias

public void setTermAlias(java.lang.String termAlias)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


T-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M N O P Q R S T U V W X Y Z

T

T - Static variable in class bb.common.Constant.Prefix
TakeCycleCountAgent - Class in bb.common
TakeCycleCountAgent() - Constructor for class bb.common.TakeCycleCountAgent
takeInitCycleCount(TakeCycleCountAgent) - Method in interface bb.common.box.WarehouseBox
takeInitCycleCount(Collection<Map>, int, int, String, String, boolean, boolean) - Method in interface bb.common.box.WarehouseBox
takeInitPhysicalInventory(int, String, String, boolean, boolean, boolean, boolean) - Method in interface bb.common.box.WarehouseBox
TASK - Static variable in class bb.common.BizTarget
TaskFileResult - Class in bb.common
TaskFileResult() - Constructor for class bb.common.TaskFileResult
TaskVO - Class in bb.common
TaskVO() - Constructor for class bb.common.TaskVO
default constructor
TAX_DETAIL - Static variable in class bb.common.Constant.CategoryReportType
TAX_DETAIL_PRE - Static variable in class bb.common.Constant.CategoryReportType
TAXABLE_SALES - Static variable in class bb.common.Constant.SalesTaxReportType
TaxAccountVO - Class in bb.common
TaxAccountVO() - Constructor for class bb.common.TaxAccountVO
TempArApAgingVO - Class in bb.common
TempArApAgingVO() - Constructor for class bb.common.TempArApAgingVO
TEMPLATE_ERROR - Static variable in class bb.common.BIZReason
TEMPORARYEMPLOYEE - Static variable in class bb.common.BizTarget
TEMPORARYEMPLOYEE_ALREADY_ADDED - Static variable in class bb.common.BIZReason
TEMPORARYEMPLOYEE_ID_NOT_EXIST - Static variable in class bb.common.BIZReason
TEMPORARYWORKER - Static variable in class bb.common.Constant.EmployeeStatus
TempReceiverWithoutAPInfo - Class in bb.common
TempReceiverWithoutAPInfo() - Constructor for class bb.common.TempReceiverWithoutAPInfo
TENLEVEL - Static variable in class bb.common.Constant.AgeLevel
TERM - Static variable in class bb.common.BizTarget
TERM_ALIAS_ALREADY_EXIST - Static variable in class bb.common.BIZReason
TERM_ALREADY_EXIST - Static variable in class bb.common.BIZReason
TERM_NOT_EXIST - Static variable in class bb.common.BIZReason
TERM_VALUE_NOT_LEGAL - Static variable in class bb.common.BIZReason
TERM_WITH_SAME_ALIAS_ALREADY_EXIST - Static variable in class bb.common.BIZReason
TermAgent - Class in bb.common
TermAgent() - Constructor for class bb.common.TermAgent
TERMINATED - Static variable in class bb.common.Constant.EmployeeSecurityLevel
TERMINATED - Static variable in class bb.common.Constant.EmployeeStatus
TERMINATED_DATE_CAN_NOT_BE_NULL - Static variable in class bb.common.BIZReason
TermsConditionVO - Class in bb.common
TermsConditionVO(Integer, Date, String, byte[], String, String) - Constructor for class bb.common.TermsConditionVO
full constructor
TermsConditionVO() - Constructor for class bb.common.TermsConditionVO
default constructor
TermsConditionVO(Integer, String, String) - Constructor for class bb.common.TermsConditionVO
minimal constructor
TermVO - Class in bb.common
TermVO() - Constructor for class bb.common.TermVO
testSmtpConnect(String, int, boolean, String, String) - Method in interface bb.common.box.CompanyBox
THE_CURRENT_FISCAL_YEAR_DID_NOT_SET - Static variable in class bb.common.BIZReason
THE_CUSTOMER_ALREADY_HAS_A_SALES_CODE - Static variable in class bb.common.BIZReason
THERE_IS_A_RUNNING_WORKSHEET - Static variable in class bb.common.BIZReason
THERE_IS_A_WAITING_WORKSHEET - Static variable in class bb.common.BIZReason
THERE_IS_NO_PART_ONHAND - Static variable in class bb.common.BIZReason
THIRD - Static variable in class bb.common.Constant.ECRPriority
THREELEVEL - Static variable in class bb.common.Constant.AgeLevel
THREELEVEL - Static variable in class bb.common.Constant.WorkLevel
TIME_CARDS - Static variable in class bb.common.BizTarget
TIME_CARDS_ALREADY_EXIST - Static variable in class bb.common.BIZReason
TIME_CARDS_NOT_EXIST - Static variable in class bb.common.BIZReason
TIME_OUT - Static variable in exception bb.common.BB2DocumentException
TO_lOCATION_SHOULD_BE_TO_ADDRESS_ID - Static variable in class bb.common.BIZReason
toDate(String) - Static method in class bb.common.BB2Util
TOO_MUCH_DATA_TO_SEARCH - Static variable in class bb.common.BizTarget
TOOL - Static variable in class bb.common.BizTarget
TOOL_CALIBRATION - Static variable in class bb.common.BizTarget
TOOL_CALIBRATION_CONTROL_NUMBER_WRONG - Static variable in class bb.common.BIZReason
TOOL_HAS_ONDEMAND - Static variable in class bb.common.BIZReason
TOOL_HAS_ONHAND - Static variable in class bb.common.BIZReason
TOOL_HAS_ONLOAN - Static variable in class bb.common.BIZReason
TOOL_HAS_ONORDER - Static variable in class bb.common.BIZReason
TOOL_HAS_QA - Static variable in class bb.common.BIZReason
TOOL_HAS_SIP - Static variable in class bb.common.BIZReason
TOOL_HAS_SIT - Static variable in class bb.common.BIZReason
TOOL_HAS_WIP - Static variable in class bb.common.BIZReason
TOOL_INVENTORY_NOT_ENOUGH - Static variable in class bb.common.BIZReason
TOOL_IS_INACTIVE - Static variable in class bb.common.BIZReason
TOOL_IS_TOOL_LIST - Static variable in class bb.common.BIZReason
TOOL_NOT_EXIST - Static variable in class bb.common.BIZReason
TOOL_ONHAND - Static variable in class bb.common.BizTarget
TOOL_ONHAND_NOT_EXIST - Static variable in class bb.common.BIZReason
TOOL_USED_IN_API - Static variable in class bb.common.BIZReason
TOOL_USED_IN_ARI - Static variable in class bb.common.BIZReason
TOOL_USED_IN_ECN - Static variable in class bb.common.BIZReason
TOOL_USED_IN_ECR - Static variable in class bb.common.BIZReason
TOOL_USED_IN_LNI - Static variable in class bb.common.BIZReason
TOOL_USED_IN_POI - Static variable in class bb.common.BIZReason
TOOL_USED_IN_QTI - Static variable in class bb.common.BIZReason
TOOL_USED_IN_RFQI - Static variable in class bb.common.BIZReason
TOOL_USED_IN_RMAI - Static variable in class bb.common.BIZReason
TOOL_USED_IN_RTVI - Static variable in class bb.common.BIZReason
TOOL_USED_IN_SOI - Static variable in class bb.common.BIZReason
TOOL_USED_IN_SWSI - Static variable in class bb.common.BIZReason
TOOL_USED_IN_TOI - Static variable in class bb.common.BIZReason
TOOL_USED_IN_TOOL_LIST - Static variable in class bb.common.BIZReason
TOOL_USED_IN_WI - Static variable in class bb.common.BIZReason
TOOL_USED_IN_WIS - Static variable in class bb.common.BIZReason
TOOL_USED_IN_WOI - Static variable in class bb.common.BIZReason
ToolBasicInfo - Class in bb.common
ToolBasicInfo() - Constructor for class bb.common.ToolBasicInfo
ToolCalibrateListResult - Class in bb.common
ToolCalibrateListResult() - Constructor for class bb.common.ToolCalibrateListResult
ToolCalibrationVO - Class in bb.common
ToolCalibrationVO() - Constructor for class bb.common.ToolCalibrationVO
default constructor
ToolDescriptionVO - Class in bb.common
ToolDescriptionVO() - Constructor for class bb.common.ToolDescriptionVO
ToolInventoryVO - Class in bb.common
ToolInventoryVO() - Constructor for class bb.common.ToolInventoryVO
ToolListDetailCostResult - Class in bb.common
ToolListDetailCostResult() - Constructor for class bb.common.ToolListDetailCostResult
ToolListDetailCostWithToolInfoResult - Class in bb.common
ToolListDetailCostWithToolInfoResult() - Constructor for class bb.common.ToolListDetailCostWithToolInfoResult
ToolListDetailCostWithToolInfoResult(ToolListWithToolInfoResult) - Constructor for class bb.common.ToolListDetailCostWithToolInfoResult
ToolListInfoVO - Class in bb.common
ToolListInfoVO(BillPK, String, ToolVO) - Constructor for class bb.common.ToolListInfoVO
full constructor
ToolListInfoVO() - Constructor for class bb.common.ToolListInfoVO
default constructor
ToolListItemDetailCostWithToolInfoResult - Class in bb.common
ToolListItemDetailCostWithToolInfoResult() - Constructor for class bb.common.ToolListItemDetailCostWithToolInfoResult
ToolListItemDetailCostWithToolInfoResult(ToolListItemWithToolInfoResult) - Constructor for class bb.common.ToolListItemDetailCostWithToolInfoResult
ToolListItemVO - Class in bb.common
ToolListItemVO() - Constructor for class bb.common.ToolListItemVO
ToolListItemWithToolInfoResult - Class in bb.common
ToolListItemWithToolInfoResult() - Constructor for class bb.common.ToolListItemWithToolInfoResult
ToolListVO - Class in bb.common
ToolListVO() - Constructor for class bb.common.ToolListVO
ToolListWithToolInfoResult - Class in bb.common
ToolListWithToolInfoResult() - Constructor for class bb.common.ToolListWithToolInfoResult
ToolManufacturerVO - Class in bb.common
ToolManufacturerVO() - Constructor for class bb.common.ToolManufacturerVO
default constructor
ToolManufacturerVO(PartPK) - Constructor for class bb.common.ToolManufacturerVO
ToolOnhandVO - Class in bb.common
ToolOnhandVO() - Constructor for class bb.common.ToolOnhandVO
default constructor
ToolOnhandWithAverageCostResult - Class in bb.common
ToolOnhandWithAverageCostResult() - Constructor for class bb.common.ToolOnhandWithAverageCostResult
ToolRoom - Static variable in class bb.common.Constant.DrawingType
ToolRoom - Static variable in class bb.common.Constant.PartFrom
ToolVendorVO - Class in bb.common
ToolVendorVO() - Constructor for class bb.common.ToolVendorVO
default constructor
ToolVendorVO(PartPK) - Constructor for class bb.common.ToolVendorVO
ToolVO - Class in bb.common
ToolVO() - Constructor for class bb.common.ToolVO
ToolWhereUsedItemResult - Class in bb.common
ToolWhereUsedItemResult() - Constructor for class bb.common.ToolWhereUsedItemResult
ToolWhereUsedResult - Class in bb.common
ToolWhereUsedResult() - Constructor for class bb.common.ToolWhereUsedResult
ToolWithManufacturerInfoResult - Class in bb.common
ToolWithManufacturerInfoResult() - Constructor for class bb.common.ToolWithManufacturerInfoResult
ToolWithOnhandsVO - Class in bb.common
ToolWithOnhandsVO() - Constructor for class bb.common.ToolWithOnhandsVO
toString() - Method in class bb.common.AccountCreditDebitPK
toString() - Method in class bb.common.AccountCreditVO
toString() - Method in class bb.common.AccountDebitVO
toString() - Method in class bb.common.AccountingConfigurationVO
toString() - Method in class bb.common.AccountingSettingsVO
toString() - Method in class bb.common.AccountingTransactionTypeVO
toString() - Method in class bb.common.AccountMonthPK
toString() - Method in class bb.common.AccountPayableCheckRunItemVO
toString() - Method in class bb.common.AccountPayableCheckRunVO
toString() - Method in class bb.common.AccountReceivablePaymentVO
toString() - Method in class bb.common.AccountsChartCategoryVO
toString() - Method in class bb.common.AccountsChartMappingPK
toString() - Method in class bb.common.AccountsChartMappingVO
toString() - Method in class bb.common.AccountsChartVO
toString() - Method in class bb.common.AccountsPayableInfoVO
toString() - Method in class bb.common.AccountsPayableItemManufacturerPK
toString() - Method in class bb.common.AccountsPayableItemManufacturerVO
toString() - Method in class bb.common.AccountsPayableItemPK
toString() - Method in class bb.common.AccountsPayableItemVO
toString() - Method in class bb.common.AccountsPayableVO
toString() - Method in class bb.common.AccountsReceivableInfoVO
toString() - Method in class bb.common.AccountsReceivableItemManufacturerPK
toString() - Method in class bb.common.AccountsReceivableItemManufacturerVO
toString() - Method in class bb.common.AccountsReceivableItemPK
toString() - Method in class bb.common.AccountsReceivableItemVO
toString() - Method in class bb.common.AccountsReceivableVO
toString() - Method in class bb.common.AddProformaReceiverItemAgent
toString() - Method in class bb.common.AllPartDocumentsPK
toString() - Method in class bb.common.AllPartDocumentsVO
toString() - Method in class bb.common.ApPrepayItemPK
toString() - Method in class bb.common.ApPrepayItemVO
toString() - Method in class bb.common.ApPrepayVO
toString() - Method in class bb.common.ARBoilerplateVO
toString() - Method in class bb.common.ARPaymentRunItemPK
toString() - Method in class bb.common.ARPaymentRunItemVO
toString() - Method in class bb.common.ARPaymentRunVO
toString() - Method in class bb.common.ArPrepayItemPK
toString() - Method in class bb.common.ArPrepayItemVO
toString() - Method in class bb.common.ArPrepayVO
toString() - Method in class bb.common.AssetDepreciatePK
toString() - Method in class bb.common.AssetDepreciateVO
toString() - Method in class bb.common.AssetTypeVO
toString() - Method in class bb.common.AssetUsagePK
toString() - Method in class bb.common.AssetVO
toString() - Method in class bb.common.AuditLogVO
toString() - Method in class bb.common.BankReconciliationReportVO
toString() - Method in class bb.common.BB2BigDecimalAndString
toString() - Method in class bb.common.BB2DoubleString
toString() - Method in class bb.common.BB2Event
toString() - Method in class bb.common.BB2Part
toString() - Method in class bb.common.BB2RefdocPK
toString() - Method in class bb.common.BB2tripleString
toString() - Method in class bb.common.BillItemPK
toString() - Method in class bb.common.BillItemVO
toString() - Method in class bb.common.BillItemWithPartInfoResult
toString() - Method in class bb.common.BillLogVO
toString() - Method in class bb.common.BillPK
toString() - Method in class bb.common.BillVO
toString() - Method in class bb.common.BizboxBugChangesInfoVO
toString() - Method in class bb.common.BizboxBugChangesVO
toString() - Method in class bb.common.BizboxBugInfoVO
toString() - Method in class bb.common.BizboxBugVO
toString() - Method in class bb.common.BizboxUserVO
toString() - Method in class bb.common.BuyerCodeVO
toString() - Method in class bb.common.CarrierPK
toString() - Method in class bb.common.CarrierVO
toString() - Method in class bb.common.CatalogVO
toString() - Method in class bb.common.CertificateDescriptionVO
toString() - Method in class bb.common.ChangeStdCostWorkSheetItemPK
toString() - Method in class bb.common.ChangeStdCostWorkSheetItemVO
toString() - Method in class bb.common.ChangeStdCostWorkSheetVO
toString() - Method in class bb.common.CompanyUnitAccountPK
toString() - Method in class bb.common.CompanyUnitAccountVO
toString() - Method in class bb.common.CompanyUnitVO
toString() - Method in class bb.common.CompanyVO
toString() - Method in class bb.common.ContractPriceCustomerPK
toString() - Method in class bb.common.ContractPriceCustomerVO
toString() - Method in class bb.common.ContractPriceItemPK
toString() - Method in class bb.common.ContractPriceItemVO
toString() - Method in class bb.common.ContractPriceVO
toString() - Method in class bb.common.CorrectiveActionRequestVO
toString() - Method in class bb.common.CurrencyExchangePK
toString() - Method in class bb.common.CurrencyExchangeVO
toString() - Method in class bb.common.CurrencyVO
toString() - Method in class bb.common.CustomAssetRecordPK
toString() - Method in class bb.common.CustomAssetRecordVO
toString() - Method in class bb.common.CustomAssetVO
toString() - Method in class bb.common.CustomCheckUpEmployeeVO
toString() - Method in class bb.common.CustomDepartmentVO
toString() - Method in class bb.common.CustomEmployeeTrainPK
toString() - Method in class bb.common.CustomEmployeeTrainVO
toString() - Method in class bb.common.CustomEmployeeVO
toString() - Method in class bb.common.CustomEmployeeWorkExperienceVO
toString() - Method in class bb.common.CustomerFeedbackVO
toString() - Method in class bb.common.CustomerReturnToVendorItemPK
toString() - Method in class bb.common.CustomerReturnToVendorItemVO
toString() - Method in class bb.common.CustomerReturnToVendorVO
toString() - Method in class bb.common.CustomerServiceIncidentVO
toString() - Method in class bb.common.CustomerVendorAddressInfoVO
toString() - Method in class bb.common.CustomerVendorAddressVO
toString() - Method in class bb.common.CustomerVendorContactPK
toString() - Method in class bb.common.CustomerVendorContactVO
toString() - Method in class bb.common.CustomerVendorDescriptionPK
toString() - Method in class bb.common.CustomerVendorDescriptionVO
toString() - Method in class bb.common.CustomerVendorTypeVO
toString() - Method in class bb.common.CustomGoodsBreedVO
toString() - Method in class bb.common.CustomGoodsRecordVO
toString() - Method in class bb.common.CustomJobCategoryGoodsPK
toString() - Method in class bb.common.CustomJobCategoryGoodsVO
toString() - Method in class bb.common.CustomJobCategoryVO
toString() - Method in class bb.common.CycleCountPK
toString() - Method in class bb.common.CycleCountVO
toString() - Method in class bb.common.DepartmentLocationForBackflushVO
toString() - Method in class bb.common.DesignControlDocumentVO
toString() - Method in class bb.common.DesignControlInfoVO
toString() - Method in class bb.common.DesignControlVO
toString() - Method in class bb.common.DisassembleWorkOrderApprovalVO
toString() - Method in class bb.common.DisassembleWorkOrderIssueVO
toString() - Method in class bb.common.DisassembleWorkOrderItemPK
toString() - Method in class bb.common.DisassembleWorkOrderItemReceiverVO
toString() - Method in class bb.common.DisassembleWorkOrderItemVO
toString() - Method in class bb.common.DisassembleWorkOrderVO
toString() - Method in class bb.common.DocumentInfoAgent
toString() - Method in class bb.common.DocumentLogVO
toString() - Method in class bb.common.DocumentServerVO
toString() - Method in class bb.common.DwfUploadSettingsVO
toString() - Method in class bb.common.DwgUploadSettingsVO
toString() - Method in class bb.common.ECNReviewVO
toString() - Method in class bb.common.ECRReviewVO
toString() - Method in class bb.common.EjbMethodVO
toString() - Method in class bb.common.EmployeeCardVO
toString() - Method in class bb.common.EmployeeEducationPK
toString() - Method in class bb.common.EmployeeJobDescriptionVO
toString() - Method in class bb.common.EmployeeWorkExperiencePK
toString() - Method in class bb.common.EngGroupUserVO
toString() - Method in class bb.common.EngGroupVO
toString() - Method in class bb.common.EngineeringChangeDocumentVO
toString() - Method in class bb.common.EngineeringChangeRequestDocumentVO
toString() - Method in class bb.common.EngineeringChangeRequestVO
toString() - Method in class bb.common.EngineeringChangeVO
toString() - Method in class bb.common.EngineeringSharingItemPK
toString() - Method in class bb.common.EngineeringSharingItemVO
toString() - Method in class bb.common.EngineeringSharingVO
toString() - Method in class bb.common.EquipmentVO
toString() - Method in class bb.common.ExpenseAccountVO
toString() - Method in class bb.common.ExpenseItemPK
toString() - Method in class bb.common.ExpenseItemVO
toString() - Method in class bb.common.ExpenseVO
toString() - Method in class bb.common.FeedbackAnswerPK
toString() - Method in class bb.common.FeedbackAnswerVO
toString() - Method in class bb.common.FeedBackItemPK
toString() - Method in class bb.common.FeedbackItemVO
toString() - Method in class bb.common.FeedbackQuestionVO
toString() - Method in class bb.common.FiscalYearSettingsVO
toString() - Method in class bb.common.GeneralLedgerSettingsVO
toString() - Method in class bb.common.GeneralLedgerVO
toString() - Method in class bb.common.GLAutoApproveVO
toString() - Method in class bb.common.GlCashFlowBudgetVO
toString() - Method in class bb.common.GLCatAndSequence
toString() - Method in class bb.common.GlFiscalYearBudgetVO
toString() - Method in class bb.common.GLItemVO
toString() - Method in class bb.common.GlMonthBudgetVO
toString() - Method in class bb.common.GlMonthVO
toString() - Method in class bb.common.HelpServerVO
toString() - Method in class bb.common.HistoricalInventoryVO
toString() - Method in class bb.common.IncotermVO
toString() - Method in class bb.common.InspectionConformanceReportItemCheckPK
toString() - Method in class bb.common.InspectionConformanceReportItemCheckVO
toString() - Method in class bb.common.InspectionConformanceReportItemPK
toString() - Method in class bb.common.InspectionConformanceReportItemVO
toString() - Method in class bb.common.InspectionConformanceReportVO
toString() - Method in class bb.common.InspectionItemPK
toString() - Method in class bb.common.InspectionItemVO
toString() - Method in class bb.common.InspectionReportInfoVO
toString() - Method in class bb.common.InspectionReportInspectMethodItemPK
toString() - Method in class bb.common.InspectionReportInspectMethodItemVO
toString() - Method in class bb.common.InspectionReportInspectMethodVO
toString() - Method in class bb.common.InspectionReportInspectStandardItemPK
toString() - Method in class bb.common.InspectionReportInspectStandardItemVO
toString() - Method in class bb.common.InspectionReportItemPK
toString() - Method in class bb.common.InspectionReportItemQtyPK
toString() - Method in class bb.common.InspectionReportItemQtyVO
toString() - Method in class bb.common.InspectionReportItemVO
toString() - Method in class bb.common.InspectionReportVO
toString() - Method in class bb.common.InspectionTypeItemPK
toString() - Method in class bb.common.IpAddressVO
toString() - Method in class bb.common.LabelTemplateItemPK
toString() - Method in class bb.common.LabelTemplateItemVO
toString() - Method in class bb.common.LabelTemplateVO
toString() - Method in class bb.common.LogInventoryVO
toString() - Method in class bb.common.LogMethodPK
toString() - Method in class bb.common.LogMethodVO
toString() - Method in class bb.common.LogPartDocumentVO
toString() - Method in class bb.common.LogTrackingVO
toString() - Method in class bb.common.MaintenanceItemPK
toString() - Method in class bb.common.MaintenanceItemVO
toString() - Method in class bb.common.ManufacturerAddressInfoVO
toString() - Method in class bb.common.ManufacturerAddressVO
toString() - Method in class bb.common.ManufacturerContactPK
toString() - Method in class bb.common.ManufacturerContactVO
toString() - Method in class bb.common.ManufacturerDescriptionPK
toString() - Method in class bb.common.ManufacturerDescriptionVO
toString() - Method in class bb.common.MessageVO
toString() - Method in class bb.common.Money
toString() - Method in class bb.common.MultiLanguageAccountsChartPK
toString() - Method in class bb.common.MultiLanguageAccountsChartVO
toString() - Method in class bb.common.MyPrintListPK
toString() - Method in class bb.common.MyPrintListVO
toString() - Method in class bb.common.NcrApprovalPK
toString() - Method in class bb.common.NcrApprovalVO
toString() - Method in class bb.common.NCRPartOnhandPK
toString() - Method in class bb.common.NCRPictureVO
toString() - Method in class bb.common.NonConformanceCodeDescriptionPK
toString() - Method in class bb.common.NonConformanceCodeVO
toString() - Method in class bb.common.NonConformanceQuantityPK
toString() - Method in class bb.common.NonConformanceQuantityVO
toString() - Method in class bb.common.NonConformanceReportVO
toString() - Method in class bb.common.NonproductivePickingItemIssuedVO
toString() - Method in class bb.common.NonproductivePickingItemPK
toString() - Method in class bb.common.NonproductivePickingItemVO
toString() - Method in class bb.common.NonproductivePickingTypeVO
toString() - Method in class bb.common.NonproductivePickingVO
toString() - Method in class bb.common.OnLoanItemPK
toString() - Method in class bb.common.OnLoanItemVO
toString() - Method in class bb.common.OnloanReceiverItemPK
toString() - Method in class bb.common.OnloanReceiverItemVO
toString() - Method in class bb.common.OnloanReceiverVO
toString() - Method in class bb.common.OnloanReviewVO
toString() - Method in class bb.common.OnloanShipperItemPK
toString() - Method in class bb.common.OnloanShipperItemVO
toString() - Method in class bb.common.OnloanShipperVO
toString() - Method in class bb.common.OnLoanVO
toString() - Method in class bb.common.OpCodeShortcutPK
toString() - Method in class bb.common.OperatingInstructionsInspectMethodItemPK
toString() - Method in class bb.common.OperatingInstructionsInspectMethodItemVO
toString() - Method in class bb.common.OperatingInstructionsInspectResultItemPK
toString() - Method in class bb.common.OperatingInstructionsInspectStandardItemPK
toString() - Method in class bb.common.OperatingInstructionsInspectStandardItemVO
toString() - Method in class bb.common.OperatingInstructionsInspectStandardVO
toString() - Method in class bb.common.OperatingInstructionsManualItemPK
toString() - Method in class bb.common.OperatingInstructionsManualItemVO
toString() - Method in class bb.common.OperatingInstructionsManualVO
toString() - Method in class bb.common.OperatingInstructionsTypeVO
toString() - Method in class bb.common.OperatingInstructionsVO
toString() - Method in class bb.common.OperatingOutputFileItemPK
toString() - Method in class bb.common.OperatingOutputFileItemVO
toString() - Method in class bb.common.OperatingOutputFileTypeVO
toString() - Method in class bb.common.OperationLogVO
toString() - Method in class bb.common.OrderApprovalItemsVO
toString() - Method in class bb.common.OrderBoilerplatePK
toString() - Method in class bb.common.OrderBoilerplateVO
toString() - Method in class bb.common.OrderPK
toString() - Method in class bb.common.PackingBoxItemPK
toString() - Method in class bb.common.PackingBoxItemVO
toString() - Method in class bb.common.PackingBoxPK
toString() - Method in class bb.common.PackingBoxSalesOrderItemAgent
toString() - Method in class bb.common.PackingBoxVO
toString() - Method in class bb.common.PartBasicInfo
toString() - Method in class bb.common.PartCatalogAuditResult
toString() - Method in class bb.common.PartCatalogPK
toString() - Method in class bb.common.PartCatalogVO
toString() - Method in class bb.common.PartCertificateVO
toString() - Method in class bb.common.PartClassVO
toString() - Method in class bb.common.PartDescriptionPK
toString() - Method in class bb.common.PartDescriptionVO
toString() - Method in class bb.common.PartDiscountPK
toString() - Method in class bb.common.PartDiscountVO
toString() - Method in class bb.common.PartDocumentPK
toString() - Method in class bb.common.PartDocumentVO
toString() - Method in class bb.common.PartDwfAgent
toString() - Method in class bb.common.PartDwfPK
toString() - Method in class bb.common.PartDwfVO
toString() - Method in class bb.common.PartDwgPK
toString() - Method in class bb.common.PartDwgVO
toString() - Method in class bb.common.PartExportInfo
toString() - Method in class bb.common.PartInQAResult
toString() - Method in class bb.common.PartInQAVO
toString() - Method in class bb.common.PartInspectionPK
toString() - Method in class bb.common.PartInspectionVO
toString() - Method in class bb.common.PartInventoryVO
toString() - Method in class bb.common.PartIssuedVO
toString() - Method in class bb.common.PartManufacturerPK
toString() - Method in class bb.common.PartManufacturerVO
toString() - Method in class bb.common.PartMaterialVO
toString() - Method in class bb.common.PartMRPVO
toString() - Method in class bb.common.PartOnhandPK
toString() - Method in class bb.common.PartOnhandVO
toString() - Method in class bb.common.PartPictureVO
toString() - Method in class bb.common.PartPK
toString() - Method in class bb.common.PartReceivedVO
toString() - Method in class bb.common.PartSecurityLevelVO
toString() - Method in class bb.common.PartTraceableCategoryPK
toString() - Method in class bb.common.PartTraceableCategoryVO
toString() - Method in class bb.common.PartTraceableSpecPK
toString() - Method in class bb.common.PartTraceableSpecVO
toString() - Method in class bb.common.PartTrackingPK
toString() - Method in class bb.common.PartTrackingVO
toString() - Method in class bb.common.PartTypeVO
toString() - Method in class bb.common.PartUseTypeVO
toString() - Method in class bb.common.PartVendorPK
toString() - Method in class bb.common.PartVendorVO
toString() - Method in class bb.common.PartVO
toString() - Method in class bb.common.PartWhereUsedItemResult
toString() - Method in class bb.common.PartWhereUsedResult
toString() - Method in class bb.common.PartWithManufacturerInfoResult
toString() - Method in class bb.common.PartWithOnhandsVO
toString() - Method in class bb.common.PartWithoutLocateResult
toString() - Method in class bb.common.PayableCheckRunItemPK
toString() - Method in class bb.common.PayableMethodVO
toString() - Method in class bb.common.PaymentHistoryVO
toString() - Method in class bb.common.PermissionDescriptionVO
toString() - Method in class bb.common.PermissionMethodPK
toString() - Method in class bb.common.PermissionMethodVO
toString() - Method in class bb.common.PermissionVO
toString() - Method in class bb.common.PfReceiverItemPK
toString() - Method in class bb.common.PfReceiverItemWithNumberPK
toString() - Method in class bb.common.PfReceiverVO
toString() - Method in class bb.common.PhysicalInventoryPK
toString() - Method in class bb.common.PhysicalInventoryVO
toString() - Method in class bb.common.PointOfSaleVO
toString() - Method in class bb.common.PoMessageItemPK
toString() - Method in class bb.common.PoMessageItemVO
toString() - Method in class bb.common.PoMessageVO
toString() - Method in class bb.common.PosRefdocVO
toString() - Method in class bb.common.POSurveyReportItemPK
toString() - Method in class bb.common.POSurveyReportItemVO
toString() - Method in class bb.common.POSurveyReportVO
toString() - Method in class bb.common.PosZipCodeTaxPK
toString() - Method in class bb.common.PosZipCodeTaxVO
toString() - Method in class bb.common.PreventiveActionRequestItemVO
toString() - Method in class bb.common.PreventiveActionRequestVO
toString() - Method in class bb.common.PrintLogoVO
toString() - Method in class bb.common.ProformaInvoiceItemManufacturerPK
toString() - Method in class bb.common.ProformaInvoiceItemManufacturerVO
toString() - Method in class bb.common.ProformaInvoiceItemPK
toString() - Method in class bb.common.ProformaInvoiceItemVO
toString() - Method in class bb.common.ProformaInvoiceVO
toString() - Method in class bb.common.PrPackingBoxItemPK
toString() - Method in class bb.common.PrPackingBoxItemVO
toString() - Method in class bb.common.PrPackingBoxPK
toString() - Method in class bb.common.PrPackingBoxVO
toString() - Method in class bb.common.PurchaseOrderApprovalVO
toString() - Method in class bb.common.PurchaseOrderBoilerplateVO
toString() - Method in class bb.common.PurchaseOrderItemManufacturerPK
toString() - Method in class bb.common.PurchaseOrderItemManufacturerVO
toString() - Method in class bb.common.PurchaseOrderItemPK
toString() - Method in class bb.common.PurchaseOrderItemVO
toString() - Method in class bb.common.PurchaseOrderVO
toString() - Method in class bb.common.PurchaseWorkSheetItemPK
toString() - Method in class bb.common.PurchaseWorkSheetItemVO
toString() - Method in class bb.common.PurchaseWorkSheetPK
toString() - Method in class bb.common.PurchaseWorkSheetVO
toString() - Method in class bb.common.QualityGroupPK
toString() - Method in class bb.common.QualityGroupVO
toString() - Method in class bb.common.QuoteBoilerplateVO
toString() - Method in class bb.common.QuoteItemManufacturerPK
toString() - Method in class bb.common.QuoteItemManufacturerVO
toString() - Method in class bb.common.QuoteItemPK
toString() - Method in class bb.common.QuoteItemVO
toString() - Method in class bb.common.QuoteVO
toString() - Method in class bb.common.Reason
toString() - Method in class bb.common.ReceiverInfoVO
toString() - Method in class bb.common.ReceiverItemAgent
toString() - Method in class bb.common.ReceiverItemManufacturerPK
toString() - Method in class bb.common.ReceiverItemManufacturerVO
toString() - Method in class bb.common.ReceiverItemPK
toString() - Method in class bb.common.ReceiverItemTrackingLogAgent
toString() - Method in class bb.common.ReceiverItemVO
toString() - Method in class bb.common.ReceiverVO
toString() - Method in class bb.common.RefdocVO
toString() - Method in class bb.common.RequestForQuoteItemManufacturerPK
toString() - Method in class bb.common.RequestForQuoteItemManufacturerVO
toString() - Method in class bb.common.RequestForQuoteItemPK
toString() - Method in class bb.common.RequestForQuoteItemVO
toString() - Method in class bb.common.RequestForQuoteVO
toString() - Method in class bb.common.RequestForRMAItemPK
toString() - Method in class bb.common.RequestForRMAItemVO
toString() - Method in class bb.common.RequestForRMAVO
toString() - Method in class bb.common.ReturnMaterialAuthorizationItemManufacturerPK
toString() - Method in class bb.common.ReturnMaterialAuthorizationItemManufacturerVO
toString() - Method in class bb.common.ReturnMaterialAuthorizationItemPK
toString() - Method in class bb.common.ReturnMaterialAuthorizationItemVO
toString() - Method in class bb.common.ReturnMaterialAuthorizationVO
toString() - Method in class bb.common.ReturnToVendorItemManufacturerPK
toString() - Method in class bb.common.ReturnToVendorItemManufacturerVO
toString() - Method in class bb.common.ReturnToVendorItemPK
toString() - Method in class bb.common.ReturnToVendorItemVO
toString() - Method in class bb.common.ReturnToVendorVO
toString() - Method in class bb.common.RfqMessageItemPK
toString() - Method in class bb.common.RfqMessageItemVO
toString() - Method in class bb.common.RfqMessageVO
toString() - Method in class bb.common.RMAReceiverItemPK
toString() - Method in class bb.common.RMAReceiverItemVO
toString() - Method in class bb.common.RMAReceiverVO
toString() - Method in class bb.common.RMAReviewVO
toString() - Method in class bb.common.RoleDescriptionVO
toString() - Method in class bb.common.RolePermissionPK
toString() - Method in class bb.common.RolePermissionVO
toString() - Method in class bb.common.RoleVO
toString() - Method in class bb.common.RollUpBomStdCostWorkSheetItemPK
toString() - Method in class bb.common.RollUpBomStdCostWorkSheetItemVO
toString() - Method in class bb.common.RollUpBomStdCostWorkSheetVO
toString() - Method in class bb.common.RollUPPartStandardCostResult
toString() - Method in class bb.common.RTVApprovalVO
toString() - Method in class bb.common.RtvShipperInfoVO
toString() - Method in class bb.common.RtvShipperItemPK
toString() - Method in class bb.common.RtvShipperItemVO
toString() - Method in class bb.common.RtvShipperVO
toString() - Method in class bb.common.RunningAccountOrderItemPK
toString() - Method in class bb.common.RunningAccountOrderItemVO
toString() - Method in class bb.common.RunningAccountOrderVO
toString() - Method in class bb.common.SalesCodeVO
toString() - Method in class bb.common.SalesmanVO
toString() - Method in class bb.common.SalesOrderBoilerplateVO
toString() - Method in class bb.common.SalesOrderItemInfoVO
toString() - Method in class bb.common.SalesOrderItemManufacturerPK
toString() - Method in class bb.common.SalesOrderItemManufacturerVO
toString() - Method in class bb.common.SalesOrderItemPK
toString() - Method in class bb.common.SalesOrderItemVO
toString() - Method in class bb.common.SalesOrderReviewVO
toString() - Method in class bb.common.SalesOrderVO
toString() - Method in class bb.common.ScrapReportVO
toString() - Method in class bb.common.SerialNumberItemPK
toString() - Method in class bb.common.SerialNumberItemVO
toString() - Method in class bb.common.SerialNumberPK
toString() - Method in class bb.common.SerialNumberVO
toString() - Method in class bb.common.ServerAction
toString() - Method in class bb.common.SGBillItemPK
toString() - Method in class bb.common.SGBillItemVO
toString() - Method in class bb.common.SGClientAccountPK
toString() - Method in class bb.common.SGClientAccountVO
toString() - Method in class bb.common.SgClientProgramUserVO
toString() - Method in class bb.common.SGCompanyPK
toString() - Method in class bb.common.SGCompanyVO
toString() - Method in class bb.common.SGCustomerCatalogPK
toString() - Method in class bb.common.SGCustomerCatalogVO
toString() - Method in class bb.common.SGCustomerServiceRequestVO
toString() - Method in class bb.common.SGCustRequestForQuoteItemPK
toString() - Method in class bb.common.SGCustRequestForQuoteItemVO
toString() - Method in class bb.common.SGCustRequestForQuoteVO
toString() - Method in class bb.common.SGDocPartPK
toString() - Method in class bb.common.SGDocPartVO
toString() - Method in class bb.common.SGDwgPicturePK
toString() - Method in class bb.common.SGDwgPictureVO
toString() - Method in class bb.common.SGLogLoginVO
toString() - Method in class bb.common.SGPicturePK
toString() - Method in class bb.common.SGPictureVO
toString() - Method in class bb.common.SGQuoteAddressVO
toString() - Method in class bb.common.SGQuoteCartVO
toString() - Method in class bb.common.SGQuoteLoginVO
toString() - Method in class bb.common.SGSaleItemVO
toString() - Method in class bb.common.SGWeightUnitVO
toString() - Method in class bb.common.ShipListInfoVO
toString() - Method in class bb.common.ShipListItemPK
toString() - Method in class bb.common.ShipListItemVO
toString() - Method in class bb.common.ShipListOwnerAttributePK
toString() - Method in class bb.common.ShipListOwnerAttributeVO
toString() - Method in class bb.common.ShipListOwnerVO
toString() - Method in class bb.common.ShipListVO
toString() - Method in class bb.common.ShipperInfoVO
toString() - Method in class bb.common.ShipperItemManufacturerPK
toString() - Method in class bb.common.ShipperItemManufacturerVO
toString() - Method in class bb.common.ShipperItemPK
toString() - Method in class bb.common.ShipperItemVO
toString() - Method in class bb.common.ShipperVO
toString() - Method in class bb.common.SmtpServerVO
toString() - Method in class bb.common.SubcompanyVO
toString() - Method in class bb.common.SwapOrderItemPK
toString() - Method in class bb.common.SwapOrderItemVO
toString() - Method in class bb.common.SwapOrderVO
toString() - Method in class bb.common.SwapReceiverItemPK
toString() - Method in class bb.common.SwapReceiverItemVO
toString() - Method in class bb.common.SwapReceiverVO
toString() - Method in class bb.common.SwapShipperItemPK
toString() - Method in class bb.common.SwapShipperItemVO
toString() - Method in class bb.common.SwapShipperVO
toString() - Method in class bb.common.TaskVO
toString() - Method in class bb.common.TermsConditionVO
toString() - Method in class bb.common.TermVO
toString() - Method in class bb.common.ToolCalibrationVO
toString() - Method in class bb.common.ToolDescriptionVO
toString() - Method in class bb.common.ToolInventoryVO
toString() - Method in class bb.common.ToolListInfoVO
toString() - Method in class bb.common.ToolListItemVO
toString() - Method in class bb.common.ToolListItemWithToolInfoResult
toString() - Method in class bb.common.ToolListVO
toString() - Method in class bb.common.ToolManufacturerVO
toString() - Method in class bb.common.ToolOnhandVO
toString() - Method in class bb.common.ToolVendorVO
toString() - Method in class bb.common.ToolVO
toString() - Method in class bb.common.ToolWhereUsedItemResult
toString() - Method in class bb.common.ToolWhereUsedResult
toString() - Method in class bb.common.ToolWithOnhandsVO
toString() - Method in class bb.common.TraceableCategoriesVO
toString() - Method in class bb.common.TraceableSpecsVO
toString() - Method in class bb.common.TransferOrderItemPK
toString() - Method in class bb.common.TransferOrderItemVO
toString() - Method in class bb.common.TransferOrderVO
toString() - Method in class bb.common.TransferReceiverItemPK
toString() - Method in class bb.common.TransferReceiverItemVO
toString() - Method in class bb.common.TransferReceiverVO
toString() - Method in class bb.common.TransferShipperItemPK
toString() - Method in class bb.common.TransferShipperItemVO
toString() - Method in class bb.common.TransferShipperVO
toString() - Method in class bb.common.UnitVO
toString() - Method in class bb.common.UserGroupVO
toString() - Method in class bb.common.UserRolePK
toString() - Method in class bb.common.UserRoleVO
toString() - Method in class bb.common.VendorCategoriesVO
toString() - Method in class bb.common.VendorContractPriceItemPK
toString() - Method in class bb.common.VendorContractPriceItemVO
toString() - Method in class bb.common.VendorContractPriceVendorPK
toString() - Method in class bb.common.VendorContractPriceVendorVO
toString() - Method in class bb.common.VendorContractPriceVO
toString() - Method in class bb.common.VendorCriticalLevelVO
toString() - Method in class bb.common.VendorGroupUserVO
toString() - Method in class bb.common.VendorPartPK
toString() - Method in class bb.common.VendorPartVO
toString() - Method in class bb.common.VendorQtyPricePK
toString() - Method in class bb.common.VendorQtyPriceVO
toString() - Method in class bb.common.VersionInformation
toString() - Method in class bb.common.WarehouseTransferPK
toString() - Method in class bb.common.WarehouseTransferVO
toString() - Method in class bb.common.WarehouseVO
toString() - Method in class bb.common.WeightUnitVO
toString() - Method in class bb.common.WorkCenterAgent
toString() - Method in class bb.common.WorkCenterGroupItemPK
toString() - Method in class bb.common.WorkCenterGroupItemVO
toString() - Method in class bb.common.WorkCenterVendorPK
toString() - Method in class bb.common.WorkCenterVendorVO
toString() - Method in class bb.common.WorkCenterVO
toString() - Method in class bb.common.WorkInstructionApprovalVO
toString() - Method in class bb.common.WorkInstructionPictureVO
toString() - Method in class bb.common.WorkInstructionPK
toString() - Method in class bb.common.WorkInstructionRequestForChangeVO
toString() - Method in class bb.common.WorkInstructionSequencePK
toString() - Method in class bb.common.WorkInstructionSequenceVO
toString() - Method in class bb.common.WorkInstructionVO
toString() - Method in class bb.common.WorkOrderApprovalVO
toString() - Method in class bb.common.WorkOrderBoilerplateVO
toString() - Method in class bb.common.WorkOrderItemAgent
toString() - Method in class bb.common.WorkOrderItemIssuePK
toString() - Method in class bb.common.WorkOrderItemIssueVO
toString() - Method in class bb.common.WorkOrderItemPartDetailInWipVO
toString() - Method in class bb.common.WorkOrderItemPK
toString() - Method in class bb.common.WorkOrderItemSetupItemAgent
toString() - Method in class bb.common.WorkOrderItemVO
toString() - Method in class bb.common.WorkOrderReceiverVO
toString() - Method in class bb.common.WorkOrderVO
toString() - Method in class bb.common.WorkOrderWorkInstructionPK
toString() - Method in class bb.common.WorkOrderWorkInstructionSequencePK
toString() - Method in class bb.common.WorkOrderWorkInstructionSequenceVO
toString() - Method in class bb.common.WorkOrderWorkInstructionVO
toString() - Method in class bb.common.WorkOrderWorkSheetItemPK
toString() - Method in class bb.common.WorkOrderWorkSheetItemVO
toString() - Method in class bb.common.WorkOrderWorkSheetPK
toString() - Method in class bb.common.WorkOrderWorkSheetVO
toString() - Method in class bb.common.ZipCodeTaxVO
toString() - Method in class bb.common.ZipCodeVO
TotalAmountInPOByRefDoc - Class in bb.common
TotalAmountInPOByRefDoc() - Constructor for class bb.common.TotalAmountInPOByRefDoc
TotalByDateResult - Class in bb.common
TotalByDateResult() - Constructor for class bb.common.TotalByDateResult
TR - Static variable in class bb.common.Constant.Prefix
TRACEABLE - Static variable in class bb.common.BizTarget
TRACEABLE_CATEGORIES - Static variable in class bb.common.BizTarget
TRACEABLE_SPECIFITIONS - Static variable in class bb.common.BizTarget
TraceableCategoriesVO - Class in bb.common
TraceableCategoriesVO() - Constructor for class bb.common.TraceableCategoriesVO
TraceableSpecsVO - Class in bb.common
TraceableSpecsVO() - Constructor for class bb.common.TraceableSpecsVO
TRACKING - Static variable in class bb.common.BizTarget
TRACKING_ALREADY_EXIST - Static variable in class bb.common.BIZReason
TRACKING_NOT_EXIST - Static variable in class bb.common.BIZReason
TRACKING_QTY_IS_NEGATIVE - Static variable in class bb.common.BIZReason
TRACKING_QTY_IS_NOT_ENOUGH - Static variable in class bb.common.BIZReason
TRACKING_QTY_IS_ZERO - Static variable in class bb.common.BIZReason
TRACKING_QTY_OVER - Static variable in class bb.common.BIZReason
TRANSACTION_DATE_OVER_GL_NDAYS_OK_OLD - Static variable in class bb.common.BIZReason
TRANSACTION_IS_TOO_OLD - Static variable in class bb.common.BIZReason
TRANSFER_ORDER - Static variable in class bb.common.BizTarget
TRANSFER_ORDER_APPROVAL - Static variable in class bb.common.BizTarget
TRANSFER_ORDER_APPROVAL_ALREADY_EXIST - Static variable in class bb.common.BIZReason
TRANSFER_ORDER_APPROVAL_NOT_EXIST - Static variable in class bb.common.BIZReason
TRANSFER_ORDER_ITEM - Static variable in class bb.common.BizTarget
TRANSFER_ORDER_ITEM_NOT_EXIST_FOR_THIS_TRANSFER_SHIPPER_ITEM - Static variable in class bb.common.BIZReason
TRANSFER_ORDER_ITEM_SHOULD_BE_BACKFLUSH_MATERIAL - Static variable in class bb.common.BIZReason
TRANSFER_ORDER_NOT_EXIST - Static variable in class bb.common.BIZReason
TRANSFER_ORDER_NOT_INNER - Static variable in class bb.common.BIZReason
TRANSFER_ORDER_NOT_OPEN - Static variable in class bb.common.BIZReason
TRANSFER_RECEIVER_NOT_EXIST - Static variable in class bb.common.BIZReason
TRANSFER_RECIEVER - Static variable in class bb.common.BizTarget
TRANSFER_RECIEVER_ITEM - Static variable in class bb.common.BizTarget
TRANSFER_SHIPPER - Static variable in class bb.common.BizTarget
TRANSFER_SHIPPER_ALREADY_EXIST - Static variable in class bb.common.BIZReason
TRANSFER_SHIPPER_ITEM - Static variable in class bb.common.BizTarget
TRANSFER_SHIPPER_ITEM_NOT_EXIST - Static variable in class bb.common.BIZReason
TRANSFER_SHIPPER_NOT_EXIST - Static variable in class bb.common.BIZReason
TRANSFERGL - Static variable in class bb.common.Constant.GLType
TransferOrderApprovalVO - Class in bb.common
TransferOrderApprovalVO() - Constructor for class bb.common.TransferOrderApprovalVO
TRANSFERORDERDATE - Static variable in class bb.common.Constant.DateType
TransferOrderItemListResult - Class in bb.common
TransferOrderItemListResult() - Constructor for class bb.common.TransferOrderItemListResult
TransferOrderItemPK - Class in bb.common
TransferOrderItemPK() - Constructor for class bb.common.TransferOrderItemPK
TransferOrderItemPK(String, String) - Constructor for class bb.common.TransferOrderItemPK
TransferOrderItemVO - Class in bb.common
TransferOrderItemVO() - Constructor for class bb.common.TransferOrderItemVO
TransferOrderListResult - Class in bb.common
TransferOrderListResult() - Constructor for class bb.common.TransferOrderListResult
TransferOrderVO - Class in bb.common
TransferOrderVO() - Constructor for class bb.common.TransferOrderVO
transferPart(String) - Method in interface bb.common.box.WarehouseBox
TransferReceiverItemListResult - Class in bb.common
TransferReceiverItemListResult() - Constructor for class bb.common.TransferReceiverItemListResult
TransferReceiverItemPK - Class in bb.common
TransferReceiverItemPK() - Constructor for class bb.common.TransferReceiverItemPK
TransferReceiverItemPK(String, String) - Constructor for class bb.common.TransferReceiverItemPK
TransferReceiverItemVO - Class in bb.common
TransferReceiverItemVO() - Constructor for class bb.common.TransferReceiverItemVO
TransferReceiverListResult - Class in bb.common
TransferReceiverListResult() - Constructor for class bb.common.TransferReceiverListResult
TransferReceiverVO - Class in bb.common
TransferReceiverVO() - Constructor for class bb.common.TransferReceiverVO
TransferShipperItemListResult - Class in bb.common
TransferShipperItemListResult() - Constructor for class bb.common.TransferShipperItemListResult
TransferShipperItemPK - Class in bb.common
TransferShipperItemPK() - Constructor for class bb.common.TransferShipperItemPK
TransferShipperItemPK(String, String) - Constructor for class bb.common.TransferShipperItemPK
TransferShipperItemVO - Class in bb.common
TransferShipperItemVO() - Constructor for class bb.common.TransferShipperItemVO
TransferShipperListResult - Class in bb.common
TransferShipperListResult() - Constructor for class bb.common.TransferShipperListResult
TransferShipperVO - Class in bb.common
TransferShipperVO() - Constructor for class bb.common.TransferShipperVO
trim(String, String, boolean, boolean) - Static method in class bb.common.BB2Util
trim(String, String) - Static method in class bb.common.BB2Util
TSH - Static variable in class bb.common.Constant.Prefix
TwelveMonthCashFlowReportResult - Class in bb.common
TwelveMonthCashFlowReportResult() - Constructor for class bb.common.TwelveMonthCashFlowReportResult
TWOLEVEL - Static variable in class bb.common.Constant.AgeLevel
TWOLEVEL - Static variable in class bb.common.Constant.WorkLevel
TYPE_CUSTOMER - Static variable in class bb.common.Configure.UserType
TYPE_EMPLOYEE - Static variable in class bb.common.Configure.UserType
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M N O P Q R S T U V W X Y Z


ToolBasicInfo

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ToolBasicInfo

java.lang.Object
    extended by  bb.common.PartBasicInfo
        extended by  bb.common.ToolBasicInfo
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
ToolListItemWithToolInfoResult, ToolListWithToolInfoResult
public class ToolBasicInfo
extends PartBasicInfo
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
Fields inherited from class bb.common.PartBasicInfo
ORDER_BY_BILL, ORDER_BY_BUYERCODE, ORDER_BY_COMMODITYCODE, ORDER_BY_DESCRIPTION, ORDER_BY_DRAWING, ORDER_BY_HOLD, ORDER_BY_LASTCHANGEDATE, ORDER_BY_LASTUSER, ORDER_BY_MAKEBUY, ORDER_BY_MODELNUMBER, ORDER_BY_ORGANIZATION, ORDER_BY_ORIGIN, ORDER_BY_PARTNUMBER, ORDER_BY_PARTTYPE, ORDER_BY_PARTUNIT, ORDER_BY_PRODUCTCODE, ORDER_BY_SECURITYLEVEL, ORDER_BY_WEIGHT
Constructor Summary
ToolBasicInfo()
Method Summary
java.lang.String | getCalibration()
void | setCalibration(java.lang.String calibration)
Methods inherited from class bb.common.PartBasicInfo
equals, getBill, getBuyerCode, getCommodityCode, getCountryOrigin, getDescription, getDetectionStandard, getDrawing, getEngGroup, getHavePicture, getHold, getLastChangeDate, getLastUser, getLeadTime, getMakeBuy, getMaterial, getModelNumber, getOrigin, getPartPk, getPartUnit, getProductCode, getRevision, getSaleable, getSalesDrawing, getSecurityLevel, getTraceable, getVolume, getVolumeUnit, getWeight, getWeightUnit, getWi, hashCode, setBill, setBuyerCode, setCommodityCode, setCountryOrigin, setDescription, setDetectionStandard, setDrawing, setEngGroup, setHavePicture, setHold, setLastChangeDate, setLastUser, setLeadTime, setMakeBuy, setMaterial, setModelNumber, setOrigin, setPartPk, setPartUnit, setProductCode, setRevision, setSaleable, setSalesDrawing, setSecurityLevel, setTraceable, setVolume, setVolumeUnit, setWeight, setWeightUnit, setWi, toString
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ToolBasicInfo

public ToolBasicInfo()
Method Detail

setCalibration

public void setCalibration(java.lang.String calibration)

getCalibration

public java.lang.String getCalibration()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ToolCalibrateListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ToolCalibrateListResult

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ToolCalibrationVO
            extended by  bb.common.ToolCalibrateListResult
All Implemented Interfaces:
java.io.Serializable
public class ToolCalibrateListResult
extends ToolCalibrationVO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ASSIGNEDTO
static java.lang.String | ORDER_BY_COMMENT
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_II
static java.lang.String | ORDER_BY_INSPECTEDBY
static java.lang.String | ORDER_BY_INSPECTIONPERIOD
static java.lang.String | ORDER_BY_LASTINSPECTION
static java.lang.String | ORDER_BY_LOCATION
static java.lang.String | ORDER_BY_MANUFACTURERNAME
static java.lang.String | ORDER_BY_NEXTINSPECTION
static java.lang.String | ORDER_BY_PK
static java.lang.String | ORDER_BY_SERIALNUMBER
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
ToolCalibrateListResult()
Method Summary
java.lang.String | getToolDescription()
void | setToolDescription(java.lang.String toolDescription)
Methods inherited from class bb.common.ToolCalibrationVO
equals, getAssignedTo, getCertificationNumber, getComment, getGageSet, getIi, getInspectedBy, getInspectionPeriod, getInspectionPeriodUnit, getLastInspection, getLocation, getManufacturerName, getModelNumber, getNextInspection, getPartNumber, getPartType, getPreviousInspection, getSerialNumber, getStatus, hashCode, setAssignedTo, setCertificationNumber, setComment, setGageSet, setIi, setInspectedBy, setInspectionPeriod, setInspectionPeriodUnit, setLastInspection, setLocation, setManufacturerName, setModelNumber, setNextInspection, setPartNumber, setPartType, setPreviousInspection, setSerialNumber, setStatus, toString, uniqueStr
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_PK

public static final java.lang.String ORDER_BY_PK
See Also:
Constant Field Values

ORDER_BY_MANUFACTURERNAME

public static final java.lang.String ORDER_BY_MANUFACTURERNAME
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_LOCATION

public static final java.lang.String ORDER_BY_LOCATION
See Also:
Constant Field Values

ORDER_BY_ASSIGNEDTO

public static final java.lang.String ORDER_BY_ASSIGNEDTO
See Also:
Constant Field Values

ORDER_BY_INSPECTEDBY

public static final java.lang.String ORDER_BY_INSPECTEDBY
See Also:
Constant Field Values

ORDER_BY_LASTINSPECTION

public static final java.lang.String ORDER_BY_LASTINSPECTION
See Also:
Constant Field Values

ORDER_BY_NEXTINSPECTION

public static final java.lang.String ORDER_BY_NEXTINSPECTION
See Also:
Constant Field Values

ORDER_BY_INSPECTIONPERIOD

public static final java.lang.String ORDER_BY_INSPECTIONPERIOD
See Also:
Constant Field Values

ORDER_BY_SERIALNUMBER

public static final java.lang.String ORDER_BY_SERIALNUMBER
See Also:
Constant Field Values

ORDER_BY_COMMENT

public static final java.lang.String ORDER_BY_COMMENT
See Also:
Constant Field Values

ORDER_BY_II

public static final java.lang.String ORDER_BY_II
See Also:
Constant Field Values
Constructor Detail

ToolCalibrateListResult

public ToolCalibrateListResult()
Method Detail

setToolDescription

public void setToolDescription(java.lang.String toolDescription)

getToolDescription

public java.lang.String getToolDescription()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ToolCalibrationVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ToolCalibrationVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ToolCalibrationVO
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
ToolCalibrateListResult
public class ToolCalibrationVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ASSIGNEDTO
static java.lang.String | ORDER_BY_II
static java.lang.String | ORDER_BY_INSPECTEDBY
static java.lang.String | ORDER_BY_INSPECTIONPERIOD
static java.lang.String | ORDER_BY_LASTINSPECTION
static java.lang.String | ORDER_BY_LOCATION
static java.lang.String | ORDER_BY_MANUFACTURERNAME
static java.lang.String | ORDER_BY_NEXTINSPECTION
static java.lang.String | ORDER_BY_PK
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
ToolCalibrationVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getAssignedTo()
java.lang.String | getCertificationNumber()
java.lang.String | getComment()
java.lang.String | getGageSet()
java.lang.Long | getIi()
java.lang.String | getInspectedBy()
java.lang.String | getInspectionPeriod()
java.lang.String | getInspectionPeriodUnit()
java.util.Date | getLastInspection()
java.lang.String | getLocation()
java.lang.String | getManufacturerName()
java.lang.String | getModelNumber()
java.util.Date | getNextInspection()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.util.Date | getPreviousInspection()
java.lang.String | getSerialNumber()
java.lang.String | getStatus()
int | hashCode()
void | setAssignedTo(java.lang.String assignedTo)
void | setCertificationNumber(java.lang.String certificationNumber)
void | setComment(java.lang.String comment)
void | setGageSet(java.lang.String gageSet)
void | setIi(java.lang.Long ii)
void | setInspectedBy(java.lang.String inspectedBy)
void | setInspectionPeriod(java.lang.String inspectionPeriod)
void | setInspectionPeriodUnit(java.lang.String inspectionPeriodUnit)
void | setLastInspection(java.util.Date lastInspection)
void | setLocation(java.lang.String location)
void | setManufacturerName(java.lang.String manufacturerName)
void | setModelNumber(java.lang.String modelNumber)
void | setNextInspection(java.util.Date nextInspection)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPreviousInspection(java.util.Date previousInspection)
void | setSerialNumber(java.lang.String serialNumber)
void | setStatus(java.lang.String status)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PK

public static final java.lang.String ORDER_BY_PK
See Also:
Constant Field Values

ORDER_BY_MANUFACTURERNAME

public static final java.lang.String ORDER_BY_MANUFACTURERNAME
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_LOCATION

public static final java.lang.String ORDER_BY_LOCATION
See Also:
Constant Field Values

ORDER_BY_ASSIGNEDTO

public static final java.lang.String ORDER_BY_ASSIGNEDTO
See Also:
Constant Field Values

ORDER_BY_INSPECTEDBY

public static final java.lang.String ORDER_BY_INSPECTEDBY
See Also:
Constant Field Values

ORDER_BY_LASTINSPECTION

public static final java.lang.String ORDER_BY_LASTINSPECTION
See Also:
Constant Field Values

ORDER_BY_NEXTINSPECTION

public static final java.lang.String ORDER_BY_NEXTINSPECTION
See Also:
Constant Field Values

ORDER_BY_INSPECTIONPERIOD

public static final java.lang.String ORDER_BY_INSPECTIONPERIOD
See Also:
Constant Field Values

ORDER_BY_II

public static final java.lang.String ORDER_BY_II
See Also:
Constant Field Values
Constructor Detail

ToolCalibrationVO

public ToolCalibrationVO()
default constructor

Method Detail

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getAssignedTo

public java.lang.String getAssignedTo()

setAssignedTo

public void setAssignedTo(java.lang.String assignedTo)

getSerialNumber

public java.lang.String getSerialNumber()

setSerialNumber

public void setSerialNumber(java.lang.String serialNumber)

getGageSet

public java.lang.String getGageSet()

setGageSet

public void setGageSet(java.lang.String gageSet)

getManufacturerName

public java.lang.String getManufacturerName()

setManufacturerName

public void setManufacturerName(java.lang.String manufacturerName)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getPreviousInspection

public java.util.Date getPreviousInspection()

setPreviousInspection

public void setPreviousInspection(java.util.Date previousInspection)

getLastInspection

public java.util.Date getLastInspection()

setLastInspection

public void setLastInspection(java.util.Date lastInspection)

getNextInspection

public java.util.Date getNextInspection()

setNextInspection

public void setNextInspection(java.util.Date nextInspection)

getInspectionPeriod

public java.lang.String getInspectionPeriod()

setInspectionPeriod

public void setInspectionPeriod(java.lang.String inspectionPeriod)

getInspectionPeriodUnit

public java.lang.String getInspectionPeriodUnit()

setInspectionPeriodUnit

public void setInspectionPeriodUnit(java.lang.String inspectionPeriodUnit)

getCertificationNumber

public java.lang.String getCertificationNumber()

setCertificationNumber

public void setCertificationNumber(java.lang.String certificationNumber)

getComment

public java.lang.String getComment()

getInspectedBy

public java.lang.String getInspectedBy()

setComment

public void setComment(java.lang.String comment)

setInspectedBy

public void setInspectedBy(java.lang.String inspectedBy)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ToolDescriptionVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ToolDescriptionVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ToolDescriptionVO
All Implemented Interfaces:
java.io.Serializable
public class ToolDescriptionVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ToolDescriptionVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDescription()
PartDescriptionPK | getPk()
java.lang.String | getStatus()
java.lang.Integer | getVersion()
int | hashCode()
void | setDescription(java.lang.String description)
void | setPk(PartDescriptionPK pk)
void | setStatus(java.lang.String status)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ToolDescriptionVO

public ToolDescriptionVO()
Method Detail

getPk

public PartDescriptionPK getPk()

setPk

public void setPk(PartDescriptionPK pk)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getDescription

public java.lang.String getDescription()

getVersion

public java.lang.Integer getVersion()

setDescription

public void setDescription(java.lang.String description)

setVersion

public void setVersion(java.lang.Integer version)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ToolInventoryVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ToolInventoryVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ToolInventoryVO
All Implemented Interfaces:
java.io.Serializable
public class ToolInventoryVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
ToolInventoryVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getActive()
java.math.BigDecimal | getAverageCost()
java.lang.String | getCCode()
java.math.BigDecimal | getConsignedQty()
java.lang.String | getDCode()
java.lang.String | getECode()
java.math.BigDecimal | getFirstInCost()
java.lang.String | getGa()
java.math.BigDecimal | getInQualityCheckingQty()
java.math.BigDecimal | getInSTO()
java.math.BigDecimal | getLastPurchaseCost()
java.lang.String | getLastPurchaseOrderItemNumber()
java.lang.String | getLastPurchaseOrderNumber()
java.math.BigDecimal | getLeadTime()
java.math.BigDecimal | getListPrice()
java.math.BigDecimal | getMaxQty()
java.math.BigDecimal | getMinQty()
java.lang.String | getModelNumber()
java.lang.String | getOCode()
java.math.BigDecimal | getOnDemandQty()
java.math.BigDecimal | getOnhand()
java.math.BigDecimal | getOnloanQty()
java.math.BigDecimal | getOnOrderQty()
java.lang.String | getPCode()
PartPK | getPk()
java.math.BigDecimal | getPurchaseCost()
java.lang.String | getPurchaseOrderUnit()
java.math.BigDecimal | getQuarterUsage()
java.math.BigDecimal | getReceivedQty()
java.lang.String | getSalesOrderUnit()
java.math.BigDecimal | getShipInProcessQty()
java.math.BigDecimal | getShipInTransactionQty()
java.math.BigDecimal | getShippedQty()
java.math.BigDecimal | getStandardCost()
java.lang.Integer | getVersion()
java.math.BigDecimal | getWorkInProcessQty()
java.math.BigDecimal | getYearUsage()
int | hashCode()
void | setActive(java.lang.String active)
void | setAverageCost(java.math.BigDecimal averageCost)
void | setCCode(java.lang.String CCode)
void | setConsignedQty(java.math.BigDecimal consignedQty)
void | setDCode(java.lang.String DCode)
void | setECode(java.lang.String ECode)
void | setFirstInCost(java.math.BigDecimal firstInCost)
void | setGa(java.lang.String ga)
void | setInQualityCheckingQty(java.math.BigDecimal inQualityCheckingQty)
void | setInSTO(java.math.BigDecimal inSTO)
void | setLastPurchaseCost(java.math.BigDecimal lastPurchaseCost)
void | setLastPurchaseOrderItemNumber(java.lang.String lastPurchaseOrderItemNumber)
void | setLastPurchaseOrderNumber(java.lang.String lastPurchaseOrderNumber)
void | setLeadTime(java.math.BigDecimal leadTime)
void | setListPrice(java.math.BigDecimal listPrice)
void | setMaxQty(java.math.BigDecimal maxQty)
void | setMinQty(java.math.BigDecimal minQty)
void | setModelNumber(java.lang.String modelNumber)
void | setOCode(java.lang.String OCode)
void | setOnDemandQty(java.math.BigDecimal onDemandQty)
void | setOnhand(java.math.BigDecimal onhand)
void | setOnloanQty(java.math.BigDecimal onloanQty)
void | setOnOrderQty(java.math.BigDecimal onOrderQty)
void | setPCode(java.lang.String PCode)
void | setPk(PartPK pk)
void | setPurchaseCost(java.math.BigDecimal purchaseCost)
void | setPurchaseOrderUnit(java.lang.String purchaseOrderUnit)
void | setQuarterUsage(java.math.BigDecimal quarterUsage)
void | setReceivedQty(java.math.BigDecimal receivedQty)
void | setSalesOrderUnit(java.lang.String salesOrderUnit)
void | setShipInProcessQty(java.math.BigDecimal shipInProcessQty)
void | setShipInTransactionQty(java.math.BigDecimal shipInTransactionQty)
void | setShippedQty(java.math.BigDecimal shippedQty)
void | setStandardCost(java.math.BigDecimal standardCost)
void | setVersion(java.lang.Integer version)
void | setWorkInProcessQty(java.math.BigDecimal workInProcessQty)
void | setYearUsage(java.math.BigDecimal yearUsage)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ToolInventoryVO

public ToolInventoryVO()
Method Detail

getPk

public PartPK getPk()

setPk

public void setPk(PartPK pk)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getActive

public java.lang.String getActive()

setActive

public void setActive(java.lang.String active)

getOnhand

public java.math.BigDecimal getOnhand()

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

getShippedQty

public java.math.BigDecimal getShippedQty()

setShippedQty

public void setShippedQty(java.math.BigDecimal shippedQty)

getReceivedQty

public java.math.BigDecimal getReceivedQty()

setReceivedQty

public void setReceivedQty(java.math.BigDecimal receivedQty)

getWorkInProcessQty

public java.math.BigDecimal getWorkInProcessQty()

setWorkInProcessQty

public void setWorkInProcessQty(java.math.BigDecimal workInProcessQty)

getOnloanQty

public java.math.BigDecimal getOnloanQty()

setOnloanQty

public void setOnloanQty(java.math.BigDecimal onloanQty)

getConsignedQty

public java.math.BigDecimal getConsignedQty()

setConsignedQty

public void setConsignedQty(java.math.BigDecimal consignedQty)

getInQualityCheckingQty

public java.math.BigDecimal getInQualityCheckingQty()

setInQualityCheckingQty

public void setInQualityCheckingQty(java.math.BigDecimal inQualityCheckingQty)

getOnDemandQty

public java.math.BigDecimal getOnDemandQty()

setOnDemandQty

public void setOnDemandQty(java.math.BigDecimal onDemandQty)

getOnOrderQty

public java.math.BigDecimal getOnOrderQty()

setOnOrderQty

public void setOnOrderQty(java.math.BigDecimal onOrderQty)

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

getAverageCost

public java.math.BigDecimal getAverageCost()

setAverageCost

public void setAverageCost(java.math.BigDecimal averageCost)

getStandardCost

public java.math.BigDecimal getStandardCost()

setStandardCost

public void setStandardCost(java.math.BigDecimal standardCost)

getPCode

public java.lang.String getPCode()

setPCode

public void setPCode(java.lang.String PCode)

getCCode

public java.lang.String getCCode()

setCCode

public void setCCode(java.lang.String CCode)

getOCode

public java.lang.String getOCode()

setOCode

public void setOCode(java.lang.String OCode)

getDCode

public java.lang.String getDCode()

setDCode

public void setDCode(java.lang.String DCode)

getECode

public java.lang.String getECode()

setECode

public void setECode(java.lang.String ECode)

getPurchaseOrderUnit

public java.lang.String getPurchaseOrderUnit()

setPurchaseOrderUnit

public void setPurchaseOrderUnit(java.lang.String purchaseOrderUnit)

getSalesOrderUnit

public java.lang.String getSalesOrderUnit()

setSalesOrderUnit

public void setSalesOrderUnit(java.lang.String salesOrderUnit)

getLeadTime

public java.math.BigDecimal getLeadTime()

setLeadTime

public void setLeadTime(java.math.BigDecimal leadTime)

getMinQty

public java.math.BigDecimal getMinQty()

setMinQty

public void setMinQty(java.math.BigDecimal minQty)

getMaxQty

public java.math.BigDecimal getMaxQty()

setMaxQty

public void setMaxQty(java.math.BigDecimal maxQty)

getYearUsage

public java.math.BigDecimal getYearUsage()

setYearUsage

public void setYearUsage(java.math.BigDecimal yearUsage)

getQuarterUsage

public java.math.BigDecimal getQuarterUsage()

setQuarterUsage

public void setQuarterUsage(java.math.BigDecimal quarterUsage)

getGa

public java.lang.String getGa()

setGa

public void setGa(java.lang.String ga)

getPurchaseCost

public java.math.BigDecimal getPurchaseCost()

getVersion

public java.lang.Integer getVersion()

getShipInProcessQty

public java.math.BigDecimal getShipInProcessQty()

setPurchaseCost

public void setPurchaseCost(java.math.BigDecimal purchaseCost)

setVersion

public void setVersion(java.lang.Integer version)

setShipInProcessQty

public void setShipInProcessQty(java.math.BigDecimal shipInProcessQty)

getShipInTransactionQty

public java.math.BigDecimal getShipInTransactionQty()

setShipInTransactionQty

public void setShipInTransactionQty(java.math.BigDecimal shipInTransactionQty)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getFirstInCost

public java.math.BigDecimal getFirstInCost()

setFirstInCost

public void setFirstInCost(java.math.BigDecimal firstInCost)

getLastPurchaseCost

public java.math.BigDecimal getLastPurchaseCost()

setLastPurchaseCost

public void setLastPurchaseCost(java.math.BigDecimal lastPurchaseCost)

getLastPurchaseOrderItemNumber

public java.lang.String getLastPurchaseOrderItemNumber()

setLastPurchaseOrderItemNumber

public void setLastPurchaseOrderItemNumber(java.lang.String lastPurchaseOrderItemNumber)

getLastPurchaseOrderNumber

public java.lang.String getLastPurchaseOrderNumber()

setLastPurchaseOrderNumber

public void setLastPurchaseOrderNumber(java.lang.String lastPurchaseOrderNumber)

getInSTO

public java.math.BigDecimal getInSTO()

setInSTO

public void setInSTO(java.math.BigDecimal inSTO)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ToolListDetailCostResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ToolListDetailCostResult

java.lang.Object
    extended by  bb.common.ToolListDetailCostResult
All Implemented Interfaces:
java.io.Serializable
public class ToolListDetailCostResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ToolListDetailCostResult()
Method Summary
java.math.BigDecimal | getAverageCost()
java.math.BigDecimal | getListCost()
java.lang.Integer | getMissingItems()
java.math.BigDecimal | getStandardCost()
ToolListDetailCostWithToolInfoResult | getToolListInfo()
java.util.Set | getToolListItems()
java.math.BigDecimal | getVendorAverageCost()
java.math.BigDecimal | getVendorHighestCost()
java.math.BigDecimal | getVendorLowestCost()
void | setAverageCost(java.math.BigDecimal averageCost)
void | setListCost(java.math.BigDecimal listCost)
void | setMissingItems(java.lang.Integer missingItems)
void | setStandardCost(java.math.BigDecimal standardCost)
void | setToolListInfo(ToolListDetailCostWithToolInfoResult toolListInfo)
void | setToolListItems(java.util.Set ToolListItems)
void | setVendorAverageCost(java.math.BigDecimal vendorAverageCost)
void | setVendorHighestCost(java.math.BigDecimal vendorHighestCost)
void | setVendorLowestCost(java.math.BigDecimal vendorLowestCost)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ToolListDetailCostResult

public ToolListDetailCostResult()
Method Detail

getAverageCost

public java.math.BigDecimal getAverageCost()

getListCost

public java.math.BigDecimal getListCost()

getMissingItems

public java.lang.Integer getMissingItems()

getStandardCost

public java.math.BigDecimal getStandardCost()

getVendorAverageCost

public java.math.BigDecimal getVendorAverageCost()

getVendorHighestCost

public java.math.BigDecimal getVendorHighestCost()

getVendorLowestCost

public java.math.BigDecimal getVendorLowestCost()

getToolListInfo

public ToolListDetailCostWithToolInfoResult getToolListInfo()

getToolListItems

public java.util.Set getToolListItems()

setAverageCost

public void setAverageCost(java.math.BigDecimal averageCost)

setListCost

public void setListCost(java.math.BigDecimal listCost)

setMissingItems

public void setMissingItems(java.lang.Integer missingItems)

setStandardCost

public void setStandardCost(java.math.BigDecimal standardCost)

setVendorAverageCost

public void setVendorAverageCost(java.math.BigDecimal vendorAverageCost)

setVendorHighestCost

public void setVendorHighestCost(java.math.BigDecimal vendorHighestCost)

setVendorLowestCost

public void setVendorLowestCost(java.math.BigDecimal vendorLowestCost)

setToolListInfo

public void setToolListInfo(ToolListDetailCostWithToolInfoResult toolListInfo)

setToolListItems

public void setToolListItems(java.util.Set ToolListItems)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ToolListDetailCostWithToolInfoResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ToolListDetailCostWithToolInfoResult

java.lang.Object
    extended by  bb.common.PartBasicInfo
        extended by  bb.common.ToolBasicInfo
            extended by  bb.common.ToolListWithToolInfoResult
                extended by  bb.common.ToolListDetailCostWithToolInfoResult
All Implemented Interfaces:
java.io.Serializable
public class ToolListDetailCostWithToolInfoResult
extends ToolListWithToolInfoResult
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
Fields inherited from class bb.common.ToolListWithToolInfoResult
ORDER_BY_BILLPK, ORDER_BY_LASTCHANGEDATE, ORDER_BY_LASTCHANGEUSER
Fields inherited from class bb.common.PartBasicInfo
ORDER_BY_BILL, ORDER_BY_BUYERCODE, ORDER_BY_COMMODITYCODE, ORDER_BY_DESCRIPTION, ORDER_BY_DRAWING, ORDER_BY_HOLD, ORDER_BY_LASTUSER, ORDER_BY_MAKEBUY, ORDER_BY_MODELNUMBER, ORDER_BY_ORGANIZATION, ORDER_BY_ORIGIN, ORDER_BY_PARTNUMBER, ORDER_BY_PARTTYPE, ORDER_BY_PARTUNIT, ORDER_BY_PRODUCTCODE, ORDER_BY_SECURITYLEVEL, ORDER_BY_WEIGHT
Constructor Summary
ToolListDetailCostWithToolInfoResult()
ToolListDetailCostWithToolInfoResult(ToolListWithToolInfoResult vo)
Method Summary
java.math.BigDecimal | getAverageCost()
java.math.BigDecimal | getListPrice()
java.math.BigDecimal | getStandardCost()
void | setAverageCost(java.math.BigDecimal averageCost)
void | setListPrice(java.math.BigDecimal listPrice)
void | setStandardCost(java.math.BigDecimal standardCost)
Methods inherited from class bb.common.ToolListWithToolInfoResult
getBillPk, getLastChangeDate, getLastChangeUser, setBillPk, setLastChangeDate, setLastChangeUser
Methods inherited from class bb.common.ToolBasicInfo
getCalibration, setCalibration
Methods inherited from class bb.common.PartBasicInfo
equals, getBill, getBuyerCode, getCommodityCode, getCountryOrigin, getDescription, getDetectionStandard, getDrawing, getEngGroup, getHavePicture, getHold, getLastUser, getLeadTime, getMakeBuy, getMaterial, getModelNumber, getOrigin, getPartPk, getPartUnit, getProductCode, getRevision, getSaleable, getSalesDrawing, getSecurityLevel, getTraceable, getVolume, getVolumeUnit, getWeight, getWeightUnit, getWi, hashCode, setBill, setBuyerCode, setCommodityCode, setCountryOrigin, setDescription, setDetectionStandard, setDrawing, setEngGroup, setHavePicture, setHold, setLastUser, setLeadTime, setMakeBuy, setMaterial, setModelNumber, setOrigin, setPartPk, setPartUnit, setProductCode, setRevision, setSaleable, setSalesDrawing, setSecurityLevel, setTraceable, setVolume, setVolumeUnit, setWeight, setWeightUnit, setWi, toString
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ToolListDetailCostWithToolInfoResult

public ToolListDetailCostWithToolInfoResult()

ToolListDetailCostWithToolInfoResult

public ToolListDetailCostWithToolInfoResult(ToolListWithToolInfoResult vo)
Method Detail

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

getAverageCost

public java.math.BigDecimal getAverageCost()

setAverageCost

public void setAverageCost(java.math.BigDecimal averageCost)

getStandardCost

public java.math.BigDecimal getStandardCost()

setStandardCost

public void setStandardCost(java.math.BigDecimal standardCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ToolListInfoVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ToolListInfoVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ToolListInfoVO
All Implemented Interfaces:
java.io.Serializable
public class ToolListInfoVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ToolListInfoVO()
default constructor
ToolListInfoVO(BillPK pk, java.lang.String lastChangeUser, ToolVO toolVO)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
BillPK | getPk()
ToolVO | getTool()
int | hashCode()
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setPk(BillPK pk)
void | setTool(ToolVO toolVO)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ToolListInfoVO

public ToolListInfoVO(BillPK pk,
                      java.lang.String lastChangeUser,
                      ToolVO toolVO)
full constructor

ToolListInfoVO

public ToolListInfoVO()
default constructor

Method Detail

getPk

public BillPK getPk()

setPk

public void setPk(BillPK pk)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getTool

public ToolVO getTool()

setTool

public void setTool(ToolVO toolVO)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ToolListItemDetailCostWithToolInfoResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ToolListItemDetailCostWithToolInfoResult

java.lang.Object
    extended by  bb.common.PartBasicInfo
        extended by  bb.common.ToolBasicInfo
            extended by  bb.common.ToolListItemWithToolInfoResult
                extended by  bb.common.ToolListItemDetailCostWithToolInfoResult
All Implemented Interfaces:
java.io.Serializable
public class ToolListItemDetailCostWithToolInfoResult
extends ToolListItemWithToolInfoResult
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
Fields inherited from class bb.common.PartBasicInfo
ORDER_BY_BILL, ORDER_BY_BUYERCODE, ORDER_BY_COMMODITYCODE, ORDER_BY_DESCRIPTION, ORDER_BY_DRAWING, ORDER_BY_HOLD, ORDER_BY_LASTCHANGEDATE, ORDER_BY_LASTUSER, ORDER_BY_MAKEBUY, ORDER_BY_MODELNUMBER, ORDER_BY_ORGANIZATION, ORDER_BY_ORIGIN, ORDER_BY_PARTNUMBER, ORDER_BY_PARTTYPE, ORDER_BY_PARTUNIT, ORDER_BY_PRODUCTCODE, ORDER_BY_SECURITYLEVEL, ORDER_BY_WEIGHT
Constructor Summary
ToolListItemDetailCostWithToolInfoResult()
ToolListItemDetailCostWithToolInfoResult(ToolListItemWithToolInfoResult vo)
Method Summary
java.math.BigDecimal | getAverageCost()
java.math.BigDecimal | getListPrice()
java.math.BigDecimal | getStandardCost()
void | setAverageCost(java.math.BigDecimal averageCost)
void | setListPrice(java.math.BigDecimal listPrice)
void | setStandardCost(java.math.BigDecimal standardCost)
Methods inherited from class bb.common.ToolListItemWithToolInfoResult
equals, getBillItemPk, getPartQuantity, hashCode, setBillItemPk, setPartQuantity, toString
Methods inherited from class bb.common.ToolBasicInfo
getCalibration, setCalibration
Methods inherited from class bb.common.PartBasicInfo
getBill, getBuyerCode, getCommodityCode, getCountryOrigin, getDescription, getDetectionStandard, getDrawing, getEngGroup, getHavePicture, getHold, getLastChangeDate, getLastUser, getLeadTime, getMakeBuy, getMaterial, getModelNumber, getOrigin, getPartPk, getPartUnit, getProductCode, getRevision, getSaleable, getSalesDrawing, getSecurityLevel, getTraceable, getVolume, getVolumeUnit, getWeight, getWeightUnit, getWi, setBill, setBuyerCode, setCommodityCode, setCountryOrigin, setDescription, setDetectionStandard, setDrawing, setEngGroup, setHavePicture, setHold, setLastChangeDate, setLastUser, setLeadTime, setMakeBuy, setMaterial, setModelNumber, setOrigin, setPartPk, setPartUnit, setProductCode, setRevision, setSaleable, setSalesDrawing, setSecurityLevel, setTraceable, setVolume, setVolumeUnit, setWeight, setWeightUnit, setWi
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ToolListItemDetailCostWithToolInfoResult

public ToolListItemDetailCostWithToolInfoResult()

ToolListItemDetailCostWithToolInfoResult

public ToolListItemDetailCostWithToolInfoResult(ToolListItemWithToolInfoResult vo)
Method Detail

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

getAverageCost

public java.math.BigDecimal getAverageCost()

setAverageCost

public void setAverageCost(java.math.BigDecimal averageCost)

getStandardCost

public java.math.BigDecimal getStandardCost()

setStandardCost

public void setStandardCost(java.math.BigDecimal standardCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ToolListItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ToolListItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ToolListItemVO
All Implemented Interfaces:
java.io.Serializable
public class ToolListItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ToolListItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getBc()
java.lang.String | getPartNumber()
java.math.BigDecimal | getPartQuantity()
java.lang.String | getPartType()
BillItemPK | getPk()
ToolListVO | getToolListInfo()
int | hashCode()
void | setBc(java.lang.String bc)
void | setPartNumber(java.lang.String partNumber)
void | setPartQuantity(java.math.BigDecimal partQuantity)
void | setPartType(java.lang.String partType)
void | setPk(BillItemPK pk)
void | setToolListInfo(ToolListVO toolListInfo)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ToolListItemVO

public ToolListItemVO()
Method Detail

getPk

public BillItemPK getPk()

setPk

public void setPk(BillItemPK pk)

getBc

public java.lang.String getBc()

setBc

public void setBc(java.lang.String bc)

getPartQuantity

public java.math.BigDecimal getPartQuantity()

setPartQuantity

public void setPartQuantity(java.math.BigDecimal partQuantity)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

getToolListInfo

public ToolListVO getToolListInfo()

setPartType

public void setPartType(java.lang.String partType)

setToolListInfo

public void setToolListInfo(ToolListVO toolListInfo)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ToolListItemWithToolInfoResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ToolListItemWithToolInfoResult

java.lang.Object
    extended by  bb.common.PartBasicInfo
        extended by  bb.common.ToolBasicInfo
            extended by  bb.common.ToolListItemWithToolInfoResult
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
ToolListItemDetailCostWithToolInfoResult
public class ToolListItemWithToolInfoResult
extends ToolBasicInfo
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
Fields inherited from class bb.common.PartBasicInfo
ORDER_BY_BILL, ORDER_BY_BUYERCODE, ORDER_BY_COMMODITYCODE, ORDER_BY_DESCRIPTION, ORDER_BY_DRAWING, ORDER_BY_HOLD, ORDER_BY_LASTCHANGEDATE, ORDER_BY_LASTUSER, ORDER_BY_MAKEBUY, ORDER_BY_MODELNUMBER, ORDER_BY_ORGANIZATION, ORDER_BY_ORIGIN, ORDER_BY_PARTNUMBER, ORDER_BY_PARTTYPE, ORDER_BY_PARTUNIT, ORDER_BY_PRODUCTCODE, ORDER_BY_SECURITYLEVEL, ORDER_BY_WEIGHT
Constructor Summary
ToolListItemWithToolInfoResult()
Method Summary
boolean | equals(java.lang.Object other)
BillItemPK | getBillItemPk()
java.math.BigDecimal | getPartQuantity()
int | hashCode()
void | setBillItemPk(BillItemPK billItemPk)
void | setPartQuantity(java.math.BigDecimal partQuantity)
java.lang.String | toString()
Methods inherited from class bb.common.ToolBasicInfo
getCalibration, setCalibration
Methods inherited from class bb.common.PartBasicInfo
getBill, getBuyerCode, getCommodityCode, getCountryOrigin, getDescription, getDetectionStandard, getDrawing, getEngGroup, getHavePicture, getHold, getLastChangeDate, getLastUser, getLeadTime, getMakeBuy, getMaterial, getModelNumber, getOrigin, getPartPk, getPartUnit, getProductCode, getRevision, getSaleable, getSalesDrawing, getSecurityLevel, getTraceable, getVolume, getVolumeUnit, getWeight, getWeightUnit, getWi, setBill, setBuyerCode, setCommodityCode, setCountryOrigin, setDescription, setDetectionStandard, setDrawing, setEngGroup, setHavePicture, setHold, setLastChangeDate, setLastUser, setLeadTime, setMakeBuy, setMaterial, setModelNumber, setOrigin, setPartPk, setPartUnit, setProductCode, setRevision, setSaleable, setSalesDrawing, setSecurityLevel, setTraceable, setVolume, setVolumeUnit, setWeight, setWeightUnit, setWi
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ToolListItemWithToolInfoResult

public ToolListItemWithToolInfoResult()
Method Detail

getBillItemPk

public BillItemPK getBillItemPk()

setBillItemPk

public void setBillItemPk(BillItemPK billItemPk)

getPartQuantity

public java.math.BigDecimal getPartQuantity()

setPartQuantity

public void setPartQuantity(java.math.BigDecimal partQuantity)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class PartBasicInfo

hashCode

public int hashCode()
Overrides:
hashCode in class PartBasicInfo

toString

public java.lang.String toString()
Overrides:
toString in class PartBasicInfo
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ToolListVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ToolListVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ToolListVO
All Implemented Interfaces:
java.io.Serializable
public class ToolListVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ToolListVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Set | getItems()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getOrigin()
BillPK | getPk()
java.lang.Integer | getVersion()
int | hashCode()
void | setItems(java.util.Set items)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setOrigin(java.lang.String origin)
void | setPk(BillPK pk)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ToolListVO

public ToolListVO()
Method Detail

getPk

public BillPK getPk()

setPk

public void setPk(BillPK pk)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getItems

public java.util.Set getItems()

setItems

public void setItems(java.util.Set items)

getVersion

public java.lang.Integer getVersion()

setVersion

public void setVersion(java.lang.Integer version)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ToolListWithToolInfoResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ToolListWithToolInfoResult

java.lang.Object
    extended by  bb.common.PartBasicInfo
        extended by  bb.common.ToolBasicInfo
            extended by  bb.common.ToolListWithToolInfoResult
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
ToolListDetailCostWithToolInfoResult
public class ToolListWithToolInfoResult
extends ToolBasicInfo
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_BILLPK
static java.lang.String | ORDER_BY_LASTCHANGEDATE
static java.lang.String | ORDER_BY_LASTCHANGEUSER
Fields inherited from class bb.common.PartBasicInfo
ORDER_BY_BILL, ORDER_BY_BUYERCODE, ORDER_BY_COMMODITYCODE, ORDER_BY_DESCRIPTION, ORDER_BY_DRAWING, ORDER_BY_HOLD, ORDER_BY_LASTUSER, ORDER_BY_MAKEBUY, ORDER_BY_MODELNUMBER, ORDER_BY_ORGANIZATION, ORDER_BY_ORIGIN, ORDER_BY_PARTNUMBER, ORDER_BY_PARTTYPE, ORDER_BY_PARTUNIT, ORDER_BY_PRODUCTCODE, ORDER_BY_SECURITYLEVEL, ORDER_BY_WEIGHT
Constructor Summary
ToolListWithToolInfoResult()
Method Summary
BillPK | getBillPk()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
void | setBillPk(BillPK billPk)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
Methods inherited from class bb.common.ToolBasicInfo
getCalibration, setCalibration
Methods inherited from class bb.common.PartBasicInfo
equals, getBill, getBuyerCode, getCommodityCode, getCountryOrigin, getDescription, getDetectionStandard, getDrawing, getEngGroup, getHavePicture, getHold, getLastUser, getLeadTime, getMakeBuy, getMaterial, getModelNumber, getOrigin, getPartPk, getPartUnit, getProductCode, getRevision, getSaleable, getSalesDrawing, getSecurityLevel, getTraceable, getVolume, getVolumeUnit, getWeight, getWeightUnit, getWi, hashCode, setBill, setBuyerCode, setCommodityCode, setCountryOrigin, setDescription, setDetectionStandard, setDrawing, setEngGroup, setHavePicture, setHold, setLastUser, setLeadTime, setMakeBuy, setMaterial, setModelNumber, setOrigin, setPartPk, setPartUnit, setProductCode, setRevision, setSaleable, setSalesDrawing, setSecurityLevel, setTraceable, setVolume, setVolumeUnit, setWeight, setWeightUnit, setWi, toString
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_BILLPK

public static final java.lang.String ORDER_BY_BILLPK
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEUSER

public static final java.lang.String ORDER_BY_LASTCHANGEUSER
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEDATE

public static final java.lang.String ORDER_BY_LASTCHANGEDATE
See Also:
Constant Field Values
Constructor Detail

ToolListWithToolInfoResult

public ToolListWithToolInfoResult()
Method Detail

getBillPk

public BillPK getBillPk()

setBillPk

public void setBillPk(BillPK billPk)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()
Overrides:
getLastChangeDate in class PartBasicInfo

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)
Overrides:
setLastChangeDate in class PartBasicInfo
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ToolManufacturerVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ToolManufacturerVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ToolManufacturerVO
All Implemented Interfaces:
java.io.Serializable
public class ToolManufacturerVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ToolManufacturerVO()
default constructor
ToolManufacturerVO(PartPK partPk)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getManufacturerId()
java.lang.String | getManufacturerName()
java.lang.String | getManufacturerPartNumber()
java.lang.String | getManufacturerPartRev()
PartManufacturerPK | getPk()
java.lang.String | getQualityCode()
java.lang.String | getRatingCode()
java.lang.String | getRemarks()
java.lang.Integer | getVersion()
int | hashCode()
boolean | isPreferredPo()
boolean | isPreferredSo()
void | setManufacturerId(java.lang.String manufacturerId)
void | setManufacturerName(java.lang.String manufacturerName)
void | setManufacturerPartNumber(java.lang.String manufacturerPartNumber)
void | setManufacturerPartRev(java.lang.String manufacturerPartRev)
void | setPk(PartManufacturerPK pk)
void | setPreferredPo(boolean preferredPo)
void | setPreferredSo(boolean preferredSo)
void | setQualityCode(java.lang.String qualityCode)
void | setRatingCode(java.lang.String ratingCode)
void | setRemarks(java.lang.String remarks)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ToolManufacturerVO

public ToolManufacturerVO()
default constructor

ToolManufacturerVO

public ToolManufacturerVO(PartPK partPk)
Method Detail

getPk

public PartManufacturerPK getPk()

setPk

public void setPk(PartManufacturerPK pk)

getManufacturerId

public java.lang.String getManufacturerId()

setManufacturerId

public void setManufacturerId(java.lang.String manufacturerId)

getQualityCode

public java.lang.String getQualityCode()

setQualityCode

public void setQualityCode(java.lang.String qualityCode)

getRatingCode

public java.lang.String getRatingCode()

setRatingCode

public void setRatingCode(java.lang.String ratingCode)

getManufacturerName

public java.lang.String getManufacturerName()

setManufacturerName

public void setManufacturerName(java.lang.String manufacturerName)

getManufacturerPartNumber

public java.lang.String getManufacturerPartNumber()

setManufacturerPartNumber

public void setManufacturerPartNumber(java.lang.String manufacturerPartNumber)

getRemarks

public java.lang.String getRemarks()

setRemarks

public void setRemarks(java.lang.String remarks)

getVersion

public java.lang.Integer getVersion()

getManufacturerPartRev

public java.lang.String getManufacturerPartRev()

setVersion

public void setVersion(java.lang.Integer version)

setManufacturerPartRev

public void setManufacturerPartRev(java.lang.String manufacturerPartRev)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

isPreferredPo

public boolean isPreferredPo()

setPreferredPo

public void setPreferredPo(boolean preferredPo)

isPreferredSo

public boolean isPreferredSo()

setPreferredSo

public void setPreferredSo(boolean preferredSo)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ToolOnhandVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ToolOnhandVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ToolOnhandVO
All Implemented Interfaces:
java.io.Serializable
public class ToolOnhandVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ToolOnhandVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getActive()
java.math.BigDecimal | getAverageCost()
java.lang.String | getModelNumber()
java.math.BigDecimal | getOnHandQuantity()
PartOnhandPK | getPk()
java.lang.String | getWarehouse()
int | hashCode()
void | setActive(java.lang.String active)
void | setAverageCost(java.math.BigDecimal averageCost)
void | setModelNumber(java.lang.String modelNumber)
void | setOnHandQuantity(java.math.BigDecimal onHandQuantity)
void | setPk(PartOnhandPK pk)
void | setWarehouse(java.lang.String warehouse)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ToolOnhandVO

public ToolOnhandVO()
default constructor

Method Detail

getPk

public PartOnhandPK getPk()

setPk

public void setPk(PartOnhandPK pk)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getActive

public java.lang.String getActive()

setActive

public void setActive(java.lang.String active)

getOnHandQuantity

public java.math.BigDecimal getOnHandQuantity()

setOnHandQuantity

public void setOnHandQuantity(java.math.BigDecimal onHandQuantity)

getAverageCost

public java.math.BigDecimal getAverageCost()

setAverageCost

public void setAverageCost(java.math.BigDecimal averageCost)

getWarehouse

public java.lang.String getWarehouse()

setWarehouse

public void setWarehouse(java.lang.String warehouse)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ToolOnhandWithAverageCostResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ToolOnhandWithAverageCostResult

java.lang.Object
    extended by  bb.common.ToolOnhandWithAverageCostResult
All Implemented Interfaces:
java.io.Serializable
public class ToolOnhandWithAverageCostResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ToolOnhandWithAverageCostResult()
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getAverageCost()
ToolOnhandVO | getToolOnhandVo()
int | hashCode()
void | setAverageCost(java.math.BigDecimal averageCost)
void | setToolOnhandVo(ToolOnhandVO toolOnhandVo)
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ToolOnhandWithAverageCostResult

public ToolOnhandWithAverageCostResult()
Method Detail

setAverageCost

public void setAverageCost(java.math.BigDecimal averageCost)

getAverageCost

public java.math.BigDecimal getAverageCost()

getToolOnhandVo

public ToolOnhandVO getToolOnhandVo()

setToolOnhandVo

public void setToolOnhandVo(ToolOnhandVO toolOnhandVo)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ToolVendorVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ToolVendorVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ToolVendorVO
All Implemented Interfaces:
java.io.Serializable
public class ToolVendorVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ToolVendorVO()
default constructor
ToolVendorVO(PartPK partPk)
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getEffectiveDate()
java.math.BigDecimal | getLastPurchaseCost()
java.lang.String | getLastPurchaseOrderItemNumber()
java.lang.String | getLastPurchaseOrderNumber()
java.util.Date | getOverdueDate()
PartVendorPK | getPk()
java.math.BigDecimal | getPoQty()
java.lang.String | getPoUnit()
java.lang.String | getQualityCode()
java.lang.String | getRatingCode()
java.lang.String | getRemarks()
java.lang.String | getRequestForQuote()
java.lang.String | getVendorCurrency()
java.lang.String | getVendorId()
short | getVendorLeadTime()
java.lang.String | getVendorName()
java.math.BigDecimal | getVendorPrice()
java.lang.Integer | getVersion()
int | hashCode()
boolean | isPreferred()
void | setEffectiveDate(java.util.Date effectiveDate)
void | setLastPurchaseCost(java.math.BigDecimal lastPurchaseCost)
void | setLastPurchaseOrderItemNumber(java.lang.String lastPurchaseOrderItemNumber)
void | setLastPurchaseOrderNumber(java.lang.String lastPurchaseOrderNumber)
void | setOverdueDate(java.util.Date overdueDate)
void | setPk(PartVendorPK pk)
void | setPoQty(java.math.BigDecimal poQty)
void | setPoUnit(java.lang.String poUnit)
void | setPreferred(boolean preferred)
void | setQualityCode(java.lang.String qualityCode)
void | setRatingCode(java.lang.String ratingCode)
void | setRemarks(java.lang.String remarks)
void | setRequestForQuote(java.lang.String requestForQuote)
void | setVendorCurrency(java.lang.String vendorCurrency)
void | setVendorId(java.lang.String vendorId)
void | setVendorLeadTime(short vendorLeadTime)
void | setVendorName(java.lang.String vendorName)
void | setVendorPrice(java.math.BigDecimal vendorPrice)
void | setVersion(java.lang.Integer version)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ToolVendorVO

public ToolVendorVO()
default constructor

ToolVendorVO

public ToolVendorVO(PartPK partPk)
Method Detail

getPk

public PartVendorPK getPk()

setPk

public void setPk(PartVendorPK pk)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getQualityCode

public java.lang.String getQualityCode()

setQualityCode

public void setQualityCode(java.lang.String qualityCode)

getRatingCode

public java.lang.String getRatingCode()

setRatingCode

public void setRatingCode(java.lang.String ratingCode)

getVendorName

public java.lang.String getVendorName()

setVendorName

public void setVendorName(java.lang.String vendorName)

getVendorPrice

public java.math.BigDecimal getVendorPrice()

setVendorPrice

public void setVendorPrice(java.math.BigDecimal vendorPrice)

getVendorCurrency

public java.lang.String getVendorCurrency()

setVendorCurrency

public void setVendorCurrency(java.lang.String vendorCurrency)

getPoUnit

public java.lang.String getPoUnit()

setPoUnit

public void setPoUnit(java.lang.String poUnit)

getPoQty

public java.math.BigDecimal getPoQty()

setPoQty

public void setPoQty(java.math.BigDecimal poQty)

getVendorLeadTime

public short getVendorLeadTime()

setVendorLeadTime

public void setVendorLeadTime(short vendorLeadTime)

getEffectiveDate

public java.util.Date getEffectiveDate()

setEffectiveDate

public void setEffectiveDate(java.util.Date effectiveDate)

getRemarks

public java.lang.String getRemarks()

setRemarks

public void setRemarks(java.lang.String remarks)

getVersion

public java.lang.Integer getVersion()

setVersion

public void setVersion(java.lang.Integer version)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getRequestForQuote

public java.lang.String getRequestForQuote()

setRequestForQuote

public void setRequestForQuote(java.lang.String requestForQuote)

getOverdueDate

public java.util.Date getOverdueDate()

setOverdueDate

public void setOverdueDate(java.util.Date overdueDate)

isPreferred

public boolean isPreferred()

setPreferred

public void setPreferred(boolean preferred)

getLastPurchaseCost

public java.math.BigDecimal getLastPurchaseCost()

setLastPurchaseCost

public void setLastPurchaseCost(java.math.BigDecimal lastPurchaseCost)

getLastPurchaseOrderItemNumber

public java.lang.String getLastPurchaseOrderItemNumber()

setLastPurchaseOrderItemNumber

public void setLastPurchaseOrderItemNumber(java.lang.String lastPurchaseOrderItemNumber)

getLastPurchaseOrderNumber

public java.lang.String getLastPurchaseOrderNumber()

setLastPurchaseOrderNumber

public void setLastPurchaseOrderNumber(java.lang.String lastPurchaseOrderNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ToolVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ToolVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ToolVO
All Implemented Interfaces:
java.io.Serializable
public class ToolVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
ToolVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getBill()
java.lang.String | getBuyerCode()
java.lang.String | getCalibration()
java.lang.String | getComment()
java.lang.String | getCommodityCode()
java.util.Date | getCreatedDate()
java.lang.String | getDescription()
java.lang.String | getDrawing()
java.lang.String | getHold()
java.util.Set | getInspections()
java.lang.String | getInspectionType()
java.lang.String | getIrType()
java.util.Date | getLastChangeDate()
java.lang.String | getLastUser()
java.lang.String | getMakeBuy()
java.util.Set | getManufacturers()
java.lang.String | getModelNumber()
java.util.Set | getMultiLanguage()
java.lang.String | getOrigin()
java.lang.String | getOwner()
ToolInventoryVO | getPartInventory()
java.lang.String | getPartUnit()
PartPK | getPk()
java.lang.String | getRevision()
java.util.Date | getRevisionDate()
java.lang.String | getSaleable()
java.math.BigDecimal | getShippingDepth()
java.math.BigDecimal | getShippingLength()
float | getShippingWeight()
java.lang.String | getShippingWeightUnit()
java.math.BigDecimal | getShippingWidth()
java.util.Set | getVendors()
java.lang.Integer | getVersion()
java.math.BigDecimal | getVolume()
java.lang.String | getVolumeUnit()
java.lang.String | getWi()
int | hashCode()
boolean | isInactive()
void | setBill(java.lang.String bill)
void | setBuyerCode(java.lang.String buyerCode)
void | setCalibration(java.lang.String calibration)
void | setComment(java.lang.String comment)
void | setCommodityCode(java.lang.String commodityCode)
void | setCreatedDate(java.util.Date createdDate)
void | setDescription(java.lang.String description)
void | setDrawing(java.lang.String drawing)
void | setHold(java.lang.String hold)
void | setInactive(boolean inactive)
void | setInspections(java.util.Set inspections)
void | setInspectionType(java.lang.String inspectionType)
void | setIrType(java.lang.String irType)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastUser(java.lang.String lastUser)
void | setMakeBuy(java.lang.String makeBuy)
void | setManufacturers(java.util.Set manufacturers)
void | setModelNumber(java.lang.String modelNumber)
void | setMultiLanguage(java.util.Set multiLanguage)
void | setOrigin(java.lang.String origin)
void | setOwner(java.lang.String owner)
void | setPartInventory(ToolInventoryVO partInventory)
void | setPartUnit(java.lang.String partUnit)
void | setPk(PartPK pk)
void | setRevision(java.lang.String revision)
void | setRevisionDate(java.util.Date revisionDate)
void | setSaleable(java.lang.String saleable)
void | setShippingDepth(java.math.BigDecimal shippingDepth)
void | setShippingLength(java.math.BigDecimal shippingLength)
void | setShippingWeight(float shippingWeight)
void | setShippingWeightUnit(java.lang.String shippingWeightUnit)
void | setShippingWidth(java.math.BigDecimal shippingWidth)
void | setVendors(java.util.Set vendors)
void | setVersion(java.lang.Integer version)
void | setVolume(java.math.BigDecimal volume)
void | setVolumeUnit(java.lang.String volumeUnit)
void | setWi(java.lang.String wi)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ToolVO

public ToolVO()
Method Detail

getPk

public PartPK getPk()

setPk

public void setPk(PartPK pk)

getLastUser

public java.lang.String getLastUser()

setLastUser

public void setLastUser(java.lang.String lastUser)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getCreatedDate

public java.util.Date getCreatedDate()

setCreatedDate

public void setCreatedDate(java.util.Date createdDate)

getOwner

public java.lang.String getOwner()

setOwner

public void setOwner(java.lang.String owner)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getCommodityCode

public java.lang.String getCommodityCode()

setCommodityCode

public void setCommodityCode(java.lang.String commodityCode)

getBuyerCode

public java.lang.String getBuyerCode()

setBuyerCode

public void setBuyerCode(java.lang.String buyerCode)

getMakeBuy

public java.lang.String getMakeBuy()

setMakeBuy

public void setMakeBuy(java.lang.String makeBuy)

getSaleable

public java.lang.String getSaleable()

setSaleable

public void setSaleable(java.lang.String saleable)

getCalibration

public java.lang.String getCalibration()

setCalibration

public void setCalibration(java.lang.String calibration)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getRevisionDate

public java.util.Date getRevisionDate()

setRevisionDate

public void setRevisionDate(java.util.Date revisionDate)

getHold

public java.lang.String getHold()

setHold

public void setHold(java.lang.String hold)

getShippingWeight

public float getShippingWeight()

setShippingWeight

public void setShippingWeight(float shippingWeight)

getShippingWeightUnit

public java.lang.String getShippingWeightUnit()

setShippingWeightUnit

public void setShippingWeightUnit(java.lang.String shippingWeightUnit)

getPartUnit

public java.lang.String getPartUnit()

setPartUnit

public void setPartUnit(java.lang.String partUnit)

getComment

public java.lang.String getComment()

setComment

public void setComment(java.lang.String comment)

getDrawing

public java.lang.String getDrawing()

setDrawing

public void setDrawing(java.lang.String drawing)

getBill

public java.lang.String getBill()

setBill

public void setBill(java.lang.String bill)

getWi

public java.lang.String getWi()

setWi

public void setWi(java.lang.String wi)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getMultiLanguage

public java.util.Set getMultiLanguage()

setMultiLanguage

public void setMultiLanguage(java.util.Set multiLanguage)

getVendors

public java.util.Set getVendors()

setVendors

public void setVendors(java.util.Set vendors)

getManufacturers

public java.util.Set getManufacturers()

getPartInventory

public ToolInventoryVO getPartInventory()

getVersion

public java.lang.Integer getVersion()

setManufacturers

public void setManufacturers(java.util.Set manufacturers)

setPartInventory

public void setPartInventory(ToolInventoryVO partInventory)

setVersion

public void setVersion(java.lang.Integer version)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getShippingDepth

public java.math.BigDecimal getShippingDepth()

setShippingDepth

public void setShippingDepth(java.math.BigDecimal shippingDepth)

getShippingLength

public java.math.BigDecimal getShippingLength()

setShippingLength

public void setShippingLength(java.math.BigDecimal shippingLength)

getShippingWidth

public java.math.BigDecimal getShippingWidth()

setShippingWidth

public void setShippingWidth(java.math.BigDecimal shippingWidth)

getVolume

public java.math.BigDecimal getVolume()

setVolume

public void setVolume(java.math.BigDecimal volume)

getVolumeUnit

public java.lang.String getVolumeUnit()

setVolumeUnit

public void setVolumeUnit(java.lang.String volumeUnit)

isInactive

public boolean isInactive()

setInactive

public void setInactive(boolean inactive)

getInspections

public java.util.Set getInspections()

setInspections

public void setInspections(java.util.Set inspections)

getInspectionType

public java.lang.String getInspectionType()

setInspectionType

public void setInspectionType(java.lang.String inspectionType)

getIrType

public java.lang.String getIrType()

setIrType

public void setIrType(java.lang.String irType)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ToolWhereUsedItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ToolWhereUsedItemResult

java.lang.Object
    extended by  bb.common.ToolWhereUsedItemResult
All Implemented Interfaces:
java.io.Serializable
public class ToolWhereUsedItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ToolWhereUsedItemResult()
Method Summary
java.lang.String | getBill()
java.lang.String | getDescription()
java.lang.String | getDrawing()
java.lang.String | getHold()
java.math.BigDecimal | getOnhand()
java.math.BigDecimal | getPartQuantity()
BillItemPK | getPk()
java.lang.String | getWi()
void | setBill(java.lang.String bill)
void | setDescription(java.lang.String description)
void | setDrawing(java.lang.String drawing)
void | setHold(java.lang.String hold)
void | setOnhand(java.math.BigDecimal onhand)
void | setPartQuantity(java.math.BigDecimal partQuantity)
void | setPk(BillItemPK pk)
void | setWi(java.lang.String wi)
java.lang.String | toString()
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ToolWhereUsedItemResult

public ToolWhereUsedItemResult()
Method Detail

getPk

public BillItemPK getPk()

setPk

public void setPk(BillItemPK pk)

getPartQuantity

public java.math.BigDecimal getPartQuantity()

setPartQuantity

public void setPartQuantity(java.math.BigDecimal partQuantity)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getHold

public java.lang.String getHold()

setHold

public void setHold(java.lang.String hold)

getDrawing

public java.lang.String getDrawing()

setDrawing

public void setDrawing(java.lang.String drawing)

getBill

public java.lang.String getBill()

setBill

public void setBill(java.lang.String bill)

getWi

public java.lang.String getWi()

setWi

public void setWi(java.lang.String wi)

getOnhand

public java.math.BigDecimal getOnhand()

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ToolWhereUsedResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ToolWhereUsedResult

java.lang.Object
    extended by  bb.common.ToolWhereUsedResult
All Implemented Interfaces:
java.io.Serializable
public class ToolWhereUsedResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ToolWhereUsedResult()
Method Summary
ToolBasicInfo | getToolBasicInfo()
java.util.List | getToolWhereUsedItemResult()
void | setToolBasicInfo(ToolBasicInfo toolBasicInfo)
void | setToolWhereUsedItemResult(java.util.List toolWhereUsedItemResult)
java.lang.String | toString()
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ToolWhereUsedResult

public ToolWhereUsedResult()
Method Detail

getToolWhereUsedItemResult

public java.util.List getToolWhereUsedItemResult()

getToolBasicInfo

public ToolBasicInfo getToolBasicInfo()

setToolBasicInfo

public void setToolBasicInfo(ToolBasicInfo toolBasicInfo)

setToolWhereUsedItemResult

public void setToolWhereUsedItemResult(java.util.List toolWhereUsedItemResult)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ToolWithManufacturerInfoResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ToolWithManufacturerInfoResult

java.lang.Object
    extended by  bb.common.PartWithManufacturerInfoResult
        extended by  bb.common.ToolWithManufacturerInfoResult
All Implemented Interfaces:
java.io.Serializable
public class ToolWithManufacturerInfoResult
extends PartWithManufacturerInfoResult
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
Fields inherited from class bb.common.PartWithManufacturerInfoResult
ORDER_BY_BILL, ORDER_BY_MANUFACTURERID, ORDER_BY_MANUFACTURERNAME, ORDER_BY_MANUFACTURERPARTNUMBER, ORDER_BY_PARTNUMBER, ORDER_BY_PARTTYPE
Constructor Summary
ToolWithManufacturerInfoResult()
Method Summary
java.lang.String | getCalibration()
void | setCalibration(java.lang.String calibration)
Methods inherited from class bb.common.PartWithManufacturerInfoResult
getBill, getDescription, getDrawing, getHold, getManufacturerId, getManufacturerItem, getManufacturerName, getManufacturerPartNumber, getPartNumber, getPartType, getTraceable, setBill, setDescription, setDrawing, setHold, setManufacturerId, setManufacturerItem, setManufacturerName, setManufacturerPartNumber, setPartNumber, setPartType, setTraceable, toString
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ToolWithManufacturerInfoResult

public ToolWithManufacturerInfoResult()
Method Detail

setCalibration

public void setCalibration(java.lang.String calibration)

getCalibration

public java.lang.String getCalibration()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ToolWithOnhandsVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ToolWithOnhandsVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ToolWithOnhandsVO
All Implemented Interfaces:
java.io.Serializable
public class ToolWithOnhandsVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
ToolWithOnhandsVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getBill()
java.lang.String | getBuyerCode()
java.lang.String | getCalibration()
java.lang.String | getComment()
java.lang.String | getCommodityCode()
java.util.Date | getCreatedDate()
java.lang.String | getDescription()
java.lang.String | getDrawing()
java.lang.String | getHold()
java.util.Date | getLastChangeDate()
java.lang.String | getLastUser()
java.lang.String | getMakeBuy()
java.lang.String | getModelNumber()
java.util.Set | getMultiLanguage()
java.util.Set | getOnHandLocations()
java.lang.String | getOrigin()
java.lang.String | getOwner()
ToolInventoryVO | getPartInventory()
java.lang.String | getPartUnit()
PartPK | getPk()
java.lang.String | getRevision()
java.util.Date | getRevisionDate()
java.lang.String | getSaleable()
java.math.BigDecimal | getShippingDepth()
java.math.BigDecimal | getShippingLength()
float | getShippingWeight()
java.lang.String | getShippingWeightUnit()
java.math.BigDecimal | getShippingWidth()
java.lang.Integer | getVersion()
java.math.BigDecimal | getVolume()
java.lang.String | getVolumeUnit()
java.lang.String | getWi()
int | hashCode()
void | setBill(java.lang.String bill)
void | setBuyerCode(java.lang.String buyerCode)
void | setCalibration(java.lang.String calibration)
void | setComment(java.lang.String comment)
void | setCommodityCode(java.lang.String commodityCode)
void | setCreatedDate(java.util.Date createdDate)
void | setDescription(java.lang.String description)
void | setDrawing(java.lang.String drawing)
void | setHold(java.lang.String hold)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastUser(java.lang.String lastUser)
void | setMakeBuy(java.lang.String makeBuy)
void | setModelNumber(java.lang.String modelNumber)
void | setMultiLanguage(java.util.Set multiLanguage)
void | setOnHandLocations(java.util.Set onHandLocations)
void | setOrigin(java.lang.String origin)
void | setOwner(java.lang.String owner)
void | setPartInventory(ToolInventoryVO partInventory)
void | setPartUnit(java.lang.String partUnit)
void | setPk(PartPK pk)
void | setRevision(java.lang.String revision)
void | setRevisionDate(java.util.Date revisionDate)
void | setSaleable(java.lang.String saleable)
void | setShippingDepth(java.math.BigDecimal shippingDepth)
void | setShippingLength(java.math.BigDecimal shippingLength)
void | setShippingWeight(float shippingWeight)
void | setShippingWeightUnit(java.lang.String shippingWeightUnit)
void | setShippingWidth(java.math.BigDecimal shippingWidth)
void | setVersion(java.lang.Integer version)
void | setVolume(java.math.BigDecimal volume)
void | setVolumeUnit(java.lang.String volumeUnit)
void | setWi(java.lang.String wi)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ToolWithOnhandsVO

public ToolWithOnhandsVO()
Method Detail

getPk

public PartPK getPk()

setPk

public void setPk(PartPK pk)

getLastUser

public java.lang.String getLastUser()

setLastUser

public void setLastUser(java.lang.String lastUser)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getCreatedDate

public java.util.Date getCreatedDate()

setCreatedDate

public void setCreatedDate(java.util.Date createdDate)

getOwner

public java.lang.String getOwner()

setOwner

public void setOwner(java.lang.String owner)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getCommodityCode

public java.lang.String getCommodityCode()

setCommodityCode

public void setCommodityCode(java.lang.String commodityCode)

getBuyerCode

public java.lang.String getBuyerCode()

setBuyerCode

public void setBuyerCode(java.lang.String buyerCode)

getMakeBuy

public java.lang.String getMakeBuy()

setMakeBuy

public void setMakeBuy(java.lang.String makeBuy)

getSaleable

public java.lang.String getSaleable()

setSaleable

public void setSaleable(java.lang.String saleable)

getCalibration

public java.lang.String getCalibration()

setCalibration

public void setCalibration(java.lang.String calibration)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getRevisionDate

public java.util.Date getRevisionDate()

setRevisionDate

public void setRevisionDate(java.util.Date revisionDate)

getHold

public java.lang.String getHold()

setHold

public void setHold(java.lang.String hold)

getShippingWeight

public float getShippingWeight()

setShippingWeight

public void setShippingWeight(float shippingWeight)

getShippingWeightUnit

public java.lang.String getShippingWeightUnit()

setShippingWeightUnit

public void setShippingWeightUnit(java.lang.String shippingWeightUnit)

getPartUnit

public java.lang.String getPartUnit()

setPartUnit

public void setPartUnit(java.lang.String partUnit)

getComment

public java.lang.String getComment()

setComment

public void setComment(java.lang.String comment)

getDrawing

public java.lang.String getDrawing()

setDrawing

public void setDrawing(java.lang.String drawing)

getBill

public java.lang.String getBill()

setBill

public void setBill(java.lang.String bill)

getWi

public java.lang.String getWi()

setWi

public void setWi(java.lang.String wi)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getMultiLanguage

public java.util.Set getMultiLanguage()

setMultiLanguage

public void setMultiLanguage(java.util.Set multiLanguage)

getPartInventory

public ToolInventoryVO getPartInventory()

getVersion

public java.lang.Integer getVersion()

setPartInventory

public void setPartInventory(ToolInventoryVO partInventory)

setVersion

public void setVersion(java.lang.Integer version)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getShippingDepth

public java.math.BigDecimal getShippingDepth()

setShippingDepth

public void setShippingDepth(java.math.BigDecimal shippingDepth)

getShippingLength

public java.math.BigDecimal getShippingLength()

setShippingLength

public void setShippingLength(java.math.BigDecimal shippingLength)

getShippingWidth

public java.math.BigDecimal getShippingWidth()

setShippingWidth

public void setShippingWidth(java.math.BigDecimal shippingWidth)

getVolume

public java.math.BigDecimal getVolume()

setVolume

public void setVolume(java.math.BigDecimal volume)

getVolumeUnit

public java.lang.String getVolumeUnit()

setVolumeUnit

public void setVolumeUnit(java.lang.String volumeUnit)

getOnHandLocations

public java.util.Set getOnHandLocations()

setOnHandLocations

public void setOnHandLocations(java.util.Set onHandLocations)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TotalAmountInPOByRefDoc

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class TotalAmountInPOByRefDoc

java.lang.Object
    extended by  bb.common.VendorTotalAmountInPO
        extended by  bb.common.TotalAmountInPOByRefDoc
All Implemented Interfaces:
java.io.Serializable
public class TotalAmountInPOByRefDoc
extends VendorTotalAmountInPO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_PROJECT
static java.lang.String | ORDER_BY_PROJECTDESCRIPTION
static java.lang.String | ORDER_BY_REFDOC
static java.lang.String | ORDER_BY_RELATEDDOC
Fields inherited from class bb.common.VendorTotalAmountInPO
ORDER_BY_GRANDTOTAL, ORDER_BY_NAME, ORDER_BY_SUBTOTAL, ORDER_BY_TOTALDISCOUNT, ORDER_BY_TOTALFREIGHT, ORDER_BY_TOTALOPEN, ORDER_BY_TOTALRECEIVED, ORDER_BY_TOTALTAX, ORDER_BY_VENDORID
Constructor Summary
TotalAmountInPOByRefDoc()
Method Summary
java.lang.String | getProject()
java.lang.String | getProjectDescription()
java.lang.String | getRefdoc()
java.lang.String | getRelatedDoc()
java.math.BigDecimal | getTotalDue()
void | setProject(java.lang.String project)
void | setProjectDescription(java.lang.String projectDescription)
void | setRefdoc(java.lang.String refdoc)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setTotalDue(java.math.BigDecimal totalDue)
Methods inherited from class bb.common.VendorTotalAmountInPO
getGrandTotal, getName, getSubTotal, getTotalDiscount, getTotalFreight, getTotalOpen, getTotalReceived, getTotalTax, getVendorId, setGrandTotal, setName, setSubTotal, setTotalDiscount, setTotalFreight, setTotalOpen, setTotalReceived, setTotalTax, setVendorId
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_RELATEDDOC

public static final java.lang.String ORDER_BY_RELATEDDOC
See Also:
Constant Field Values

ORDER_BY_REFDOC

public static final java.lang.String ORDER_BY_REFDOC
See Also:
Constant Field Values

ORDER_BY_PROJECT

public static final java.lang.String ORDER_BY_PROJECT
See Also:
Constant Field Values

ORDER_BY_PROJECTDESCRIPTION

public static final java.lang.String ORDER_BY_PROJECTDESCRIPTION
See Also:
Constant Field Values
Constructor Detail

TotalAmountInPOByRefDoc

public TotalAmountInPOByRefDoc()
Method Detail

getRefdoc

public java.lang.String getRefdoc()

setRefdoc

public void setRefdoc(java.lang.String refdoc)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getTotalDue

public java.math.BigDecimal getTotalDue()

setTotalDue

public void setTotalDue(java.math.BigDecimal totalDue)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

getProjectDescription

public java.lang.String getProjectDescription()

setProjectDescription

public void setProjectDescription(java.lang.String projectDescription)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TotalByDateResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class TotalByDateResult

java.lang.Object
    extended by  bb.common.TotalByDateResult
All Implemented Interfaces:
java.io.Serializable
public class TotalByDateResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
TotalByDateResult()
Method Summary
java.lang.String | getCurrency()
java.math.BigDecimal | getGrandTotal()
java.math.BigDecimal | getSubTotal()
java.math.BigDecimal | getTotalDiscount()
java.math.BigDecimal | getTotalFreight()
java.math.BigDecimal | getTotalOpen()
java.math.BigDecimal | getTotalRecOrShip()
java.math.BigDecimal | getTotalStandardCost()
java.math.BigDecimal | getTotalTax()
void | setCurrency(java.lang.String currency)
void | setGrandTotal(java.math.BigDecimal grandTotal)
void | setSubTotal(java.math.BigDecimal subTotal)
void | setTotalDiscount(java.math.BigDecimal totalDiscount)
void | setTotalFreight(java.math.BigDecimal totalFreight)
void | setTotalOpen(java.math.BigDecimal totalOpen)
void | setTotalRecOrShip(java.math.BigDecimal totalRecOrShip)
void | setTotalStandardCost(java.math.BigDecimal totalStandardCost)
void | setTotalTax(java.math.BigDecimal totalTax)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TotalByDateResult

public TotalByDateResult()
Method Detail

setSubTotal

public void setSubTotal(java.math.BigDecimal subTotal)

setTotalRecOrShip

public void setTotalRecOrShip(java.math.BigDecimal totalRecOrShip)

setTotalOpen

public void setTotalOpen(java.math.BigDecimal totalOpen)

setTotalTax

public void setTotalTax(java.math.BigDecimal totalTax)

setGrandTotal

public void setGrandTotal(java.math.BigDecimal grandTotal)

setCurrency

public void setCurrency(java.lang.String currency)

getSubTotal

public java.math.BigDecimal getSubTotal()

getTotalRecOrShip

public java.math.BigDecimal getTotalRecOrShip()

getTotalOpen

public java.math.BigDecimal getTotalOpen()

getTotalTax

public java.math.BigDecimal getTotalTax()

getGrandTotal

public java.math.BigDecimal getGrandTotal()

getCurrency

public java.lang.String getCurrency()

getTotalDiscount

public java.math.BigDecimal getTotalDiscount()

setTotalDiscount

public void setTotalDiscount(java.math.BigDecimal totalDiscount)

getTotalStandardCost

public java.math.BigDecimal getTotalStandardCost()

setTotalStandardCost

public void setTotalStandardCost(java.math.BigDecimal totalStandardCost)

getTotalFreight

public java.math.BigDecimal getTotalFreight()

setTotalFreight

public void setTotalFreight(java.math.BigDecimal totalFreight)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TraceableCategoriesVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class TraceableCategoriesVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.TraceableCategoriesVO
All Implemented Interfaces:
java.io.Serializable
public class TraceableCategoriesVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
TraceableCategoriesVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCategoryId()
java.lang.String | getCriticalityCategory()
int | hashCode()
void | setCategoryId(java.lang.String categoryId)
void | setCriticalityCategory(java.lang.String criticalityCategory)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

TraceableCategoriesVO

public TraceableCategoriesVO()
Method Detail

getCategoryId

public java.lang.String getCategoryId()

setCategoryId

public void setCategoryId(java.lang.String categoryId)

getCriticalityCategory

public java.lang.String getCriticalityCategory()

setCriticalityCategory

public void setCriticalityCategory(java.lang.String criticalityCategory)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TraceableSpecsVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class TraceableSpecsVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.TraceableSpecsVO
All Implemented Interfaces:
java.io.Serializable
public class TraceableSpecsVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
TraceableSpecsVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getMemo()
java.lang.Short | getQualityId()
java.lang.String | getQualitySpecification()
int | hashCode()
void | setMemo(java.lang.String memo)
void | setQualityId(java.lang.Short qualityId)
void | setQualitySpecification(java.lang.String qualitySpecification)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

TraceableSpecsVO

public TraceableSpecsVO()
Method Detail

getQualityId

public java.lang.Short getQualityId()

setQualityId

public void setQualityId(java.lang.Short qualityId)

getQualitySpecification

public java.lang.String getQualitySpecification()

setQualitySpecification

public void setQualitySpecification(java.lang.String qualitySpecification)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getMemo

public java.lang.String getMemo()

setMemo

public void setMemo(java.lang.String memo)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TransferOrderApprovalVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class TransferOrderApprovalVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.TransferOrderApprovalVO
All Implemented Interfaces:
java.io.Serializable
public class TransferOrderApprovalVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CANAPPROVEOWN
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_EMPLOYEEID
static java.lang.String | ORDER_BY_USERNAME
Constructor Summary
TransferOrderApprovalVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.lang.String | getEmployeeId()
java.lang.String | getUserName()
int | hashCode()
boolean | isCanApproveOwn()
void | setCanApproveOwn(boolean canApproveOwn)
void | setComments(java.lang.String comments)
void | setEmployeeId(java.lang.String employeeId)
void | setUserName(java.lang.String userName)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_EMPLOYEEID

public static final java.lang.String ORDER_BY_EMPLOYEEID
See Also:
Constant Field Values

ORDER_BY_USERNAME

public static final java.lang.String ORDER_BY_USERNAME
See Also:
Constant Field Values

ORDER_BY_CANAPPROVEOWN

public static final java.lang.String ORDER_BY_CANAPPROVEOWN
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values
Constructor Detail

TransferOrderApprovalVO

public TransferOrderApprovalVO()
Method Detail

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

isCanApproveOwn

public boolean isCanApproveOwn()

setCanApproveOwn

public void setCanApproveOwn(boolean canApproveOwn)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TransferOrderItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class TransferOrderItemListResult

java.lang.Object
    extended by  bb.common.TransferOrderItemListResult
All Implemented Interfaces:
java.io.Serializable
public class TransferOrderItemListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ARRIVEDATE
static java.lang.String | ORDER_BY_AVGCOST
static java.lang.String | ORDER_BY_DELAYDAYS
static java.lang.String | ORDER_BY_DELIVERYDATE
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_DESIREDDATE
static java.lang.String | ORDER_BY_FROMLOCATION
static java.lang.String | ORDER_BY_ITEMCOMMENTS
static java.lang.String | ORDER_BY_ITEMPRIVATENOTES
static java.lang.String | ORDER_BY_PARTFROM
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_RECEIVEDQTY
static java.lang.String | ORDER_BY_SHIPPEDQTY
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_STDCOST
static java.lang.String | ORDER_BY_TOLOCATION
static java.lang.String | ORDER_BY_TRANSFERORDERITEMNUMBER
static java.lang.String | ORDER_BY_TRANSFERORDERNUMBER
static java.lang.String | ORDER_BY_TRANSFERQTY
Constructor Summary
TransferOrderItemListResult()
Method Summary
java.util.Date | getArriveDate()
java.math.BigDecimal | getAvgCost()
int | getDelayDays()
java.util.Date | getDeliveryDate()
java.lang.String | getDescription()
java.util.Date | getDesiredDate()
java.lang.String | getFromLocation()
java.lang.String | getItemComments()
java.lang.String | getItemPrivateNotes()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getReceivedQty()
java.math.BigDecimal | getShippedQty()
java.lang.String | getStatus()
java.math.BigDecimal | getStdCost()
java.lang.String | getToLocation()
java.lang.String | getTransferOrderItemNumber()
java.lang.String | getTransferOrderNumber()
java.math.BigDecimal | getTransferQty()
void | setArriveDate(java.util.Date arriveDate)
void | setAvgCost(java.math.BigDecimal avgCost)
void | setDelayDays(int delayDays)
void | setDeliveryDate(java.util.Date deliveryDate)
void | setDescription(java.lang.String description)
void | setDesiredDate(java.util.Date desiredDate)
void | setFromLocation(java.lang.String fromLocation)
void | setItemComments(java.lang.String itemComments)
void | setItemPrivateNotes(java.lang.String itemPrivateNotes)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setReceivedQty(java.math.BigDecimal receivedQty)
void | setShippedQty(java.math.BigDecimal shippedQty)
void | setStatus(java.lang.String status)
void | setStdCost(java.math.BigDecimal stdCost)
void | setToLocation(java.lang.String toLocation)
void | setTransferOrderItemNumber(java.lang.String transferOrderItemNumber)
void | setTransferOrderNumber(java.lang.String transferOrderNumber)
void | setTransferQty(java.math.BigDecimal transferQty)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_TRANSFERORDERNUMBER

public static final java.lang.String ORDER_BY_TRANSFERORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_TRANSFERORDERITEMNUMBER

public static final java.lang.String ORDER_BY_TRANSFERORDERITEMNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_PARTFROM

public static final java.lang.String ORDER_BY_PARTFROM
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_TRANSFERQTY

public static final java.lang.String ORDER_BY_TRANSFERQTY
See Also:
Constant Field Values

ORDER_BY_SHIPPEDQTY

public static final java.lang.String ORDER_BY_SHIPPEDQTY
See Also:
Constant Field Values

ORDER_BY_RECEIVEDQTY

public static final java.lang.String ORDER_BY_RECEIVEDQTY
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_AVGCOST

public static final java.lang.String ORDER_BY_AVGCOST
See Also:
Constant Field Values

ORDER_BY_STDCOST

public static final java.lang.String ORDER_BY_STDCOST
See Also:
Constant Field Values

ORDER_BY_DELIVERYDATE

public static final java.lang.String ORDER_BY_DELIVERYDATE
See Also:
Constant Field Values

ORDER_BY_DESIREDDATE

public static final java.lang.String ORDER_BY_DESIREDDATE
See Also:
Constant Field Values

ORDER_BY_DELAYDAYS

public static final java.lang.String ORDER_BY_DELAYDAYS
See Also:
Constant Field Values

ORDER_BY_ARRIVEDATE

public static final java.lang.String ORDER_BY_ARRIVEDATE
See Also:
Constant Field Values

ORDER_BY_ITEMCOMMENTS

public static final java.lang.String ORDER_BY_ITEMCOMMENTS
See Also:
Constant Field Values

ORDER_BY_ITEMPRIVATENOTES

public static final java.lang.String ORDER_BY_ITEMPRIVATENOTES
See Also:
Constant Field Values

ORDER_BY_FROMLOCATION

public static final java.lang.String ORDER_BY_FROMLOCATION
See Also:
Constant Field Values

ORDER_BY_TOLOCATION

public static final java.lang.String ORDER_BY_TOLOCATION
See Also:
Constant Field Values
Constructor Detail

TransferOrderItemListResult

public TransferOrderItemListResult()
Method Detail

getArriveDate

public java.util.Date getArriveDate()

setArriveDate

public void setArriveDate(java.util.Date arriveDate)

getAvgCost

public java.math.BigDecimal getAvgCost()

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

getDelayDays

public int getDelayDays()

setDelayDays

public void setDelayDays(int delayDays)

getDeliveryDate

public java.util.Date getDeliveryDate()

setDeliveryDate

public void setDeliveryDate(java.util.Date deliveryDate)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getDesiredDate

public java.util.Date getDesiredDate()

setDesiredDate

public void setDesiredDate(java.util.Date desiredDate)

getFromLocation

public java.lang.String getFromLocation()

setFromLocation

public void setFromLocation(java.lang.String fromLocation)

getItemComments

public java.lang.String getItemComments()

setItemComments

public void setItemComments(java.lang.String itemComments)

getItemPrivateNotes

public java.lang.String getItemPrivateNotes()

setItemPrivateNotes

public void setItemPrivateNotes(java.lang.String itemPrivateNotes)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getReceivedQty

public java.math.BigDecimal getReceivedQty()

setReceivedQty

public void setReceivedQty(java.math.BigDecimal receivedQty)

getShippedQty

public java.math.BigDecimal getShippedQty()

setShippedQty

public void setShippedQty(java.math.BigDecimal shippedQty)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getToLocation

public java.lang.String getToLocation()

setToLocation

public void setToLocation(java.lang.String toLocation)

getTransferOrderItemNumber

public java.lang.String getTransferOrderItemNumber()

setTransferOrderItemNumber

public void setTransferOrderItemNumber(java.lang.String transferOrderItemNumber)

getTransferOrderNumber

public java.lang.String getTransferOrderNumber()

setTransferOrderNumber

public void setTransferOrderNumber(java.lang.String transferOrderNumber)

getTransferQty

public java.math.BigDecimal getTransferQty()

setTransferQty

public void setTransferQty(java.math.BigDecimal transferQty)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TransferOrderItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class TransferOrderItemPK

java.lang.Object
    extended by  bb.common.TransferOrderItemPK
All Implemented Interfaces:
java.io.Serializable
public class TransferOrderItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
TransferOrderItemPK()
TransferOrderItemPK(java.lang.String transferOrderNumber, java.lang.String transferOrderItemNumber)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getTransferOrderItemNumber()
java.lang.String | getTransferOrderNumber()
int | hashCode()
void | setTransferOrderItemNumber(java.lang.String transferOrderItemNumber)
void | setTransferOrderNumber(java.lang.String transferOrderNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

TransferOrderItemPK

public TransferOrderItemPK()

TransferOrderItemPK

public TransferOrderItemPK(java.lang.String transferOrderNumber,
                           java.lang.String transferOrderItemNumber)
Method Detail

getTransferOrderItemNumber

public java.lang.String getTransferOrderItemNumber()

setTransferOrderItemNumber

public void setTransferOrderItemNumber(java.lang.String transferOrderItemNumber)

getTransferOrderNumber

public java.lang.String getTransferOrderNumber()

setTransferOrderNumber

public void setTransferOrderNumber(java.lang.String transferOrderNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TransferOrderItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class TransferOrderItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.TransferOrderItemVO
All Implemented Interfaces:
java.io.Serializable
public class TransferOrderItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
TransferOrderItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getArriveDate()
java.math.BigDecimal | getAvgCost()
int | getDelayDays()
java.util.Date | getDeliveryDate()
java.lang.String | getDescription()
java.util.Date | getDesiredDate()
java.lang.String | getDwg()
java.lang.String | getFromLocation()
java.lang.String | getItemComments()
java.lang.String | getItemPrivateNotes()
java.lang.String | getMfg()
java.lang.String | getMpn()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
TransferOrderItemPK | getPk()
java.math.BigDecimal | getQtyShip()
java.math.BigDecimal | getReceivedQty()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.util.Set | getRefDocTwoes()
java.lang.String | getRevision()
java.math.BigDecimal | getShippedQty()
java.lang.String | getStatus()
java.math.BigDecimal | getStdCost()
java.lang.String | getToLocation()
java.math.BigDecimal | getTransferQty()
java.lang.String | getUnit()
int | hashCode()
void | setArriveDate(java.util.Date arriveDate)
void | setAvgCost(java.math.BigDecimal avgCost)
void | setDelayDays(int delayDays)
void | setDeliveryDate(java.util.Date deliveryDate)
void | setDescription(java.lang.String description)
void | setDesiredDate(java.util.Date desiredDate)
void | setDwg(java.lang.String dwg)
void | setFromLocation(java.lang.String fromLocation)
void | setItemComments(java.lang.String itemComments)
void | setItemPrivateNotes(java.lang.String itemPrivateNotes)
void | setMfg(java.lang.String mfg)
void | setMpn(java.lang.String mpn)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(TransferOrderItemPK pk)
void | setQtyShip(java.math.BigDecimal qtyShip)
void | setReceivedQty(java.math.BigDecimal receivedQty)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setRefDocTwoes(java.util.Set refDocTwoes)
void | setRevision(java.lang.String revision)
void | setShippedQty(java.math.BigDecimal shippedQty)
void | setStatus(java.lang.String status)
void | setStdCost(java.math.BigDecimal stdCost)
void | setToLocation(java.lang.String toLocation)
void | setTransferQty(java.math.BigDecimal transferQty)
void | setUnit(java.lang.String unit)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

TransferOrderItemVO

public TransferOrderItemVO()
Method Detail

getPk

public TransferOrderItemPK getPk()

setPk

public void setPk(TransferOrderItemPK pk)

getArriveDate

public java.util.Date getArriveDate()

setArriveDate

public void setArriveDate(java.util.Date arriveDate)

getAvgCost

public java.math.BigDecimal getAvgCost()

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

getDelayDays

public int getDelayDays()

setDelayDays

public void setDelayDays(int delayDays)

getDeliveryDate

public java.util.Date getDeliveryDate()

setDeliveryDate

public void setDeliveryDate(java.util.Date deliveryDate)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getDesiredDate

public java.util.Date getDesiredDate()

setDesiredDate

public void setDesiredDate(java.util.Date desiredDate)

getItemComments

public java.lang.String getItemComments()

setItemComments

public void setItemComments(java.lang.String itemComments)

getItemPrivateNotes

public java.lang.String getItemPrivateNotes()

setItemPrivateNotes

public void setItemPrivateNotes(java.lang.String itemPrivateNotes)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getReceivedQty

public java.math.BigDecimal getReceivedQty()

setReceivedQty

public void setReceivedQty(java.math.BigDecimal receivedQty)

getShippedQty

public java.math.BigDecimal getShippedQty()

setShippedQty

public void setShippedQty(java.math.BigDecimal shippedQty)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getTransferQty

public java.math.BigDecimal getTransferQty()

setTransferQty

public void setTransferQty(java.math.BigDecimal transferQty)

getFromLocation

public java.lang.String getFromLocation()

setFromLocation

public void setFromLocation(java.lang.String fromLocation)

getToLocation

public java.lang.String getToLocation()

setToLocation

public void setToLocation(java.lang.String toLocation)

getDwg

public java.lang.String getDwg()

setDwg

public void setDwg(java.lang.String dwg)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getQtyShip

public java.math.BigDecimal getQtyShip()

setQtyShip

public void setQtyShip(java.math.BigDecimal qtyShip)

getRefDocTwoes

public java.util.Set getRefDocTwoes()

setRefDocTwoes

public void setRefDocTwoes(java.util.Set refDocTwoes)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TransferOrderListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class TransferOrderListResult

java.lang.Object
    extended by  bb.common.TransferOrderListResult
All Implemented Interfaces:
java.io.Serializable
public class TransferOrderListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ADATE
static java.lang.String | ORDER_BY_APPROVEDATE
static java.lang.String | ORDER_BY_APPROVEDBY
static java.lang.String | ORDER_BY_CARRIER
static java.lang.String | ORDER_BY_CARRIERACCOUNT
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_CONTACT
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_FREIGHT
static java.lang.String | ORDER_BY_FROMADDRESSID
static java.lang.String | ORDER_BY_INCOTERM
static java.lang.String | ORDER_BY_INCOTERMPLACEPORT
static java.lang.String | ORDER_BY_LANGUAGE
static java.lang.String | ORDER_BY_LASTCHANGEDATE
static java.lang.String | ORDER_BY_LASTUSER
static java.lang.String | ORDER_BY_LOCATE
static java.lang.String | ORDER_BY_ORIGIN
static java.lang.String | ORDER_BY_PRIVATENOTES
static java.lang.String | ORDER_BY_RELATEDDOCUMENT
static java.lang.String | ORDER_BY_REQUESTER
static java.lang.String | ORDER_BY_SHIPACCOUT
static java.lang.String | ORDER_BY_SHIPVIA
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_TERMS
static java.lang.String | ORDER_BY_TOADDRESSID
static java.lang.String | ORDER_BY_TOTALCOST
static java.lang.String | ORDER_BY_TRANSFERORDERDATE
static java.lang.String | ORDER_BY_TRANSFERORDERNUMBER
Constructor Summary
TransferOrderListResult()
Method Summary
java.util.Date | getAdate()
java.util.Date | getApproveDate()
java.lang.String | getApprovedBy()
java.lang.String | getCarrier()
java.lang.String | getCarrierAccount()
java.lang.String | getComments()
java.lang.String | getContact()
java.lang.String | getCurrency()
java.math.BigDecimal | getFreight()
java.lang.String | getFromAddressId()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
java.lang.String | getLastUser()
java.lang.String | getLocate()
java.lang.String | getOrigin()
java.lang.String | getPrivateNotes()
java.lang.String | getRelatedDocument()
java.lang.String | getRequester()
java.lang.String | getShipAccout()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.lang.String | getTerms()
java.lang.String | getToAddressId()
java.math.BigDecimal | getTotalCost()
java.util.Date | getTransferOrderDate()
java.lang.String | getTransferOrderNumber()
void | setAdate(java.util.Date adate)
void | setApproveDate(java.util.Date approveDate)
void | setApprovedBy(java.lang.String approvedBy)
void | setCarrier(java.lang.String carrier)
void | setCarrierAccount(java.lang.String carrierAccount)
void | setComments(java.lang.String comments)
void | setContact(java.lang.String contact)
void | setCurrency(java.lang.String currency)
void | setFreight(java.math.BigDecimal freight)
void | setFromAddressId(java.lang.String fromAddressId)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastUser(java.lang.String lastUser)
void | setLocate(java.lang.String locate)
void | setOrigin(java.lang.String origin)
void | setPrivateNotes(java.lang.String privateNotes)
void | setRelatedDocument(java.lang.String relatedDocument)
void | setRequester(java.lang.String requester)
void | setShipAccout(java.lang.String shipAccout)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setTerms(java.lang.String terms)
void | setToAddressId(java.lang.String toAddressId)
void | setTotalCost(java.math.BigDecimal totalCost)
void | setTransferOrderDate(java.util.Date transferOrderDate)
void | setTransferOrderNumber(java.lang.String transferOrderNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_TRANSFERORDERNUMBER

public static final java.lang.String ORDER_BY_TRANSFERORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_ADATE

public static final java.lang.String ORDER_BY_ADATE
See Also:
Constant Field Values

ORDER_BY_ORIGIN

public static final java.lang.String ORDER_BY_ORIGIN
See Also:
Constant Field Values

ORDER_BY_LASTUSER

public static final java.lang.String ORDER_BY_LASTUSER
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEDATE

public static final java.lang.String ORDER_BY_LASTCHANGEDATE
See Also:
Constant Field Values

ORDER_BY_TOTALCOST

public static final java.lang.String ORDER_BY_TOTALCOST
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_APPROVEDBY

public static final java.lang.String ORDER_BY_APPROVEDBY
See Also:
Constant Field Values

ORDER_BY_APPROVEDATE

public static final java.lang.String ORDER_BY_APPROVEDATE
See Also:
Constant Field Values

ORDER_BY_CARRIER

public static final java.lang.String ORDER_BY_CARRIER
See Also:
Constant Field Values

ORDER_BY_CARRIERACCOUNT

public static final java.lang.String ORDER_BY_CARRIERACCOUNT
See Also:
Constant Field Values

ORDER_BY_INCOTERM

public static final java.lang.String ORDER_BY_INCOTERM
See Also:
Constant Field Values

ORDER_BY_INCOTERMPLACEPORT

public static final java.lang.String ORDER_BY_INCOTERMPLACEPORT
See Also:
Constant Field Values

ORDER_BY_SHIPACCOUT

public static final java.lang.String ORDER_BY_SHIPACCOUT
See Also:
Constant Field Values

ORDER_BY_LOCATE

public static final java.lang.String ORDER_BY_LOCATE
See Also:
Constant Field Values

ORDER_BY_LANGUAGE

public static final java.lang.String ORDER_BY_LANGUAGE
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values

ORDER_BY_SHIPVIA

public static final java.lang.String ORDER_BY_SHIPVIA
See Also:
Constant Field Values

ORDER_BY_CONTACT

public static final java.lang.String ORDER_BY_CONTACT
See Also:
Constant Field Values

ORDER_BY_FREIGHT

public static final java.lang.String ORDER_BY_FREIGHT
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values

ORDER_BY_PRIVATENOTES

public static final java.lang.String ORDER_BY_PRIVATENOTES
See Also:
Constant Field Values

ORDER_BY_FROMADDRESSID

public static final java.lang.String ORDER_BY_FROMADDRESSID
See Also:
Constant Field Values

ORDER_BY_TOADDRESSID

public static final java.lang.String ORDER_BY_TOADDRESSID
See Also:
Constant Field Values

ORDER_BY_TRANSFERORDERDATE

public static final java.lang.String ORDER_BY_TRANSFERORDERDATE
See Also:
Constant Field Values

ORDER_BY_TERMS

public static final java.lang.String ORDER_BY_TERMS
See Also:
Constant Field Values

ORDER_BY_REQUESTER

public static final java.lang.String ORDER_BY_REQUESTER
See Also:
Constant Field Values

ORDER_BY_RELATEDDOCUMENT

public static final java.lang.String ORDER_BY_RELATEDDOCUMENT
See Also:
Constant Field Values
Constructor Detail

TransferOrderListResult

public TransferOrderListResult()
Method Detail

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getApproveDate

public java.util.Date getApproveDate()

setApproveDate

public void setApproveDate(java.util.Date approveDate)

getApprovedBy

public java.lang.String getApprovedBy()

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAccount

public java.lang.String getCarrierAccount()

setCarrierAccount

public void setCarrierAccount(java.lang.String carrierAccount)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getFreight

public java.math.BigDecimal getFreight()

setFreight

public void setFreight(java.math.BigDecimal freight)

getFromAddressId

public java.lang.String getFromAddressId()

setFromAddressId

public void setFromAddressId(java.lang.String fromAddressId)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastUser

public java.lang.String getLastUser()

setLastUser

public void setLastUser(java.lang.String lastUser)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getPrivateNotes

public java.lang.String getPrivateNotes()

setPrivateNotes

public void setPrivateNotes(java.lang.String privateNotes)

getRelatedDocument

public java.lang.String getRelatedDocument()

setRelatedDocument

public void setRelatedDocument(java.lang.String relatedDocument)

getRequester

public java.lang.String getRequester()

setRequester

public void setRequester(java.lang.String requester)

getShipAccout

public java.lang.String getShipAccout()

setShipAccout

public void setShipAccout(java.lang.String shipAccout)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getToAddressId

public java.lang.String getToAddressId()

setToAddressId

public void setToAddressId(java.lang.String toAddressId)

getTotalCost

public java.math.BigDecimal getTotalCost()

setTotalCost

public void setTotalCost(java.math.BigDecimal totalCost)

getTransferOrderDate

public java.util.Date getTransferOrderDate()

setTransferOrderDate

public void setTransferOrderDate(java.util.Date transferOrderDate)

getTransferOrderNumber

public java.lang.String getTransferOrderNumber()

setTransferOrderNumber

public void setTransferOrderNumber(java.lang.String transferOrderNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TransferOrderVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class TransferOrderVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.TransferOrderVO
All Implemented Interfaces:
java.io.Serializable
public class TransferOrderVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ADATE
static java.lang.String | ORDER_BY_APPROVEDATE
static java.lang.String | ORDER_BY_APPROVEDBY
static java.lang.String | ORDER_BY_CARRIER
static java.lang.String | ORDER_BY_CARRIERACCOUNT
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_CONTACT
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_FREIGHT
static java.lang.String | ORDER_BY_FROMADDRESSID
static java.lang.String | ORDER_BY_INCOTERM
static java.lang.String | ORDER_BY_INCOTERMPLACEPORT
static java.lang.String | ORDER_BY_LANGUAGE
static java.lang.String | ORDER_BY_LASTCHANGEDATE
static java.lang.String | ORDER_BY_LASTUSER
static java.lang.String | ORDER_BY_LOCATE
static java.lang.String | ORDER_BY_ORIGIN
static java.lang.String | ORDER_BY_PRIVATENOTES
static java.lang.String | ORDER_BY_RELATEDDOCUMENT
static java.lang.String | ORDER_BY_REQUESTER
static java.lang.String | ORDER_BY_SHIPACCOUT
static java.lang.String | ORDER_BY_SHIPVIA
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_TERMS
static java.lang.String | ORDER_BY_TOADDRESSID
static java.lang.String | ORDER_BY_TOTALCOST
static java.lang.String | ORDER_BY_TRANSFERORDERDATE
static java.lang.String | ORDER_BY_TRANSFERORDERNUMBER
Constructor Summary
TransferOrderVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.util.Date | getApproveDate()
java.lang.String | getApprovedBy()
java.lang.String | getCarrier()
java.lang.String | getCarrierAccount()
java.lang.String | getComments()
java.lang.String | getContact()
java.lang.String | getCurrency()
java.math.BigDecimal | getFreight()
java.lang.String | getFromAddressId()
CustomerVendorAddressInfoVO | getFromAddressInfo()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
java.lang.String | getLastUser()
java.lang.String | getLocate()
java.lang.String | getOrigin()
java.lang.String | getPrivateNotes()
java.lang.String | getRelatedDocument()
java.lang.String | getRequester()
java.lang.String | getShipAccout()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.lang.String | getTerms()
java.lang.String | getToAddressId()
CustomerVendorAddressInfoVO | getToAddressInfo()
java.math.BigDecimal | getTotalCost()
java.util.Date | getTransferOrderDate()
java.util.Set<TransferOrderItemVO> | getTransferOrderItems()
java.lang.String | getTransferOrderNumber()
java.lang.String | getTransferType()
int | getVersion()
int | hashCode()
void | setAdate(java.util.Date adate)
void | setApproveDate(java.util.Date approveDate)
void | setApprovedBy(java.lang.String approvedBy)
void | setCarrier(java.lang.String carrier)
void | setCarrierAccount(java.lang.String carrierAccount)
void | setComments(java.lang.String comments)
void | setContact(java.lang.String contact)
void | setCurrency(java.lang.String currency)
void | setFreight(java.math.BigDecimal freight)
void | setFromAddressId(java.lang.String fromAddressId)
void | setFromAddressInfo(CustomerVendorAddressInfoVO fromAddressInfo)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastUser(java.lang.String lastUser)
void | setLocate(java.lang.String locate)
void | setOrigin(java.lang.String origin)
void | setPrivateNotes(java.lang.String privateNotes)
void | setRelatedDocument(java.lang.String relatedDocument)
void | setRequester(java.lang.String requester)
void | setShipAccout(java.lang.String shipAccout)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setTerms(java.lang.String terms)
void | setToAddressId(java.lang.String toAddressId)
void | setToAddressInfo(CustomerVendorAddressInfoVO toAddressInfo)
void | setTotalCost(java.math.BigDecimal totalCost)
void | setTransferOrderDate(java.util.Date transferOrderDate)
void | setTransferOrderItems(java.util.Set<TransferOrderItemVO> transferOrderItems)
void | setTransferOrderNumber(java.lang.String transferOrderNumber)
void | setTransferType(java.lang.String transferType)
void | setVersion(int version)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_TRANSFERORDERNUMBER

public static final java.lang.String ORDER_BY_TRANSFERORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_ADATE

public static final java.lang.String ORDER_BY_ADATE
See Also:
Constant Field Values

ORDER_BY_ORIGIN

public static final java.lang.String ORDER_BY_ORIGIN
See Also:
Constant Field Values

ORDER_BY_LASTUSER

public static final java.lang.String ORDER_BY_LASTUSER
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEDATE

public static final java.lang.String ORDER_BY_LASTCHANGEDATE
See Also:
Constant Field Values

ORDER_BY_TOTALCOST

public static final java.lang.String ORDER_BY_TOTALCOST
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_APPROVEDBY

public static final java.lang.String ORDER_BY_APPROVEDBY
See Also:
Constant Field Values

ORDER_BY_APPROVEDATE

public static final java.lang.String ORDER_BY_APPROVEDATE
See Also:
Constant Field Values

ORDER_BY_CARRIER

public static final java.lang.String ORDER_BY_CARRIER
See Also:
Constant Field Values

ORDER_BY_CARRIERACCOUNT

public static final java.lang.String ORDER_BY_CARRIERACCOUNT
See Also:
Constant Field Values

ORDER_BY_INCOTERM

public static final java.lang.String ORDER_BY_INCOTERM
See Also:
Constant Field Values

ORDER_BY_INCOTERMPLACEPORT

public static final java.lang.String ORDER_BY_INCOTERMPLACEPORT
See Also:
Constant Field Values

ORDER_BY_SHIPACCOUT

public static final java.lang.String ORDER_BY_SHIPACCOUT
See Also:
Constant Field Values

ORDER_BY_LOCATE

public static final java.lang.String ORDER_BY_LOCATE
See Also:
Constant Field Values

ORDER_BY_LANGUAGE

public static final java.lang.String ORDER_BY_LANGUAGE
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values

ORDER_BY_SHIPVIA

public static final java.lang.String ORDER_BY_SHIPVIA
See Also:
Constant Field Values

ORDER_BY_CONTACT

public static final java.lang.String ORDER_BY_CONTACT
See Also:
Constant Field Values

ORDER_BY_FREIGHT

public static final java.lang.String ORDER_BY_FREIGHT
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values

ORDER_BY_PRIVATENOTES

public static final java.lang.String ORDER_BY_PRIVATENOTES
See Also:
Constant Field Values

ORDER_BY_FROMADDRESSID

public static final java.lang.String ORDER_BY_FROMADDRESSID
See Also:
Constant Field Values

ORDER_BY_TOADDRESSID

public static final java.lang.String ORDER_BY_TOADDRESSID
See Also:
Constant Field Values

ORDER_BY_TRANSFERORDERDATE

public static final java.lang.String ORDER_BY_TRANSFERORDERDATE
See Also:
Constant Field Values

ORDER_BY_TERMS

public static final java.lang.String ORDER_BY_TERMS
See Also:
Constant Field Values

ORDER_BY_REQUESTER

public static final java.lang.String ORDER_BY_REQUESTER
See Also:
Constant Field Values

ORDER_BY_RELATEDDOCUMENT

public static final java.lang.String ORDER_BY_RELATEDDOCUMENT
See Also:
Constant Field Values
Constructor Detail

TransferOrderVO

public TransferOrderVO()
Method Detail

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getApproveDate

public java.util.Date getApproveDate()

setApproveDate

public void setApproveDate(java.util.Date approveDate)

getApprovedBy

public java.lang.String getApprovedBy()

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAccount

public java.lang.String getCarrierAccount()

setCarrierAccount

public void setCarrierAccount(java.lang.String carrierAccount)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastUser

public java.lang.String getLastUser()

setLastUser

public void setLastUser(java.lang.String lastUser)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getPrivateNotes

public java.lang.String getPrivateNotes()

setPrivateNotes

public void setPrivateNotes(java.lang.String privateNotes)

getShipAccout

public java.lang.String getShipAccout()

setShipAccout

public void setShipAccout(java.lang.String shipAccout)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getTotalCost

public java.math.BigDecimal getTotalCost()

setTotalCost

public void setTotalCost(java.math.BigDecimal totalCost)

getTransferOrderNumber

public java.lang.String getTransferOrderNumber()

setTransferOrderNumber

public void setTransferOrderNumber(java.lang.String transferOrderNumber)

getFreight

public java.math.BigDecimal getFreight()

setFreight

public void setFreight(java.math.BigDecimal freight)

getFromAddressId

public java.lang.String getFromAddressId()

setFromAddressId

public void setFromAddressId(java.lang.String fromAddressId)

getFromAddressInfo

public CustomerVendorAddressInfoVO getFromAddressInfo()

setFromAddressInfo

public void setFromAddressInfo(CustomerVendorAddressInfoVO fromAddressInfo)

getToAddressId

public java.lang.String getToAddressId()

setToAddressId

public void setToAddressId(java.lang.String toAddressId)

getToAddressInfo

public CustomerVendorAddressInfoVO getToAddressInfo()

setToAddressInfo

public void setToAddressInfo(CustomerVendorAddressInfoVO toAddressInfo)

getRelatedDocument

public java.lang.String getRelatedDocument()

setRelatedDocument

public void setRelatedDocument(java.lang.String relatedDocument)

getRequester

public java.lang.String getRequester()

setRequester

public void setRequester(java.lang.String requester)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getTransferOrderDate

public java.util.Date getTransferOrderDate()

setTransferOrderDate

public void setTransferOrderDate(java.util.Date transferOrderDate)

getTransferOrderItems

public java.util.Set<TransferOrderItemVO> getTransferOrderItems()

setTransferOrderItems

public void setTransferOrderItems(java.util.Set<TransferOrderItemVO> transferOrderItems)

getVersion

public int getVersion()

setVersion

public void setVersion(int version)

getTransferType

public java.lang.String getTransferType()

setTransferType

public void setTransferType(java.lang.String transferType)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TransferReceiverItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class TransferReceiverItemListResult

java.lang.Object
    extended by  bb.common.TransferReceiverItemListResult
All Implemented Interfaces:
java.io.Serializable
public class TransferReceiverItemListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AVGCOST
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_DWG
static java.lang.String | ORDER_BY_FROMADDRESSID
static java.lang.String | ORDER_BY_HQA
static java.lang.String | ORDER_BY_ITEMCOMMENTS
static java.lang.String | ORDER_BY_ITEMPRIVATENOTES
static java.lang.String | ORDER_BY_MFG
static java.lang.String | ORDER_BY_MPN
static java.lang.String | ORDER_BY_PARTFROM
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_RECEIVEDDATE
static java.lang.String | ORDER_BY_RECEIVEDQTY
static java.lang.String | ORDER_BY_REFDOC1
static java.lang.String | ORDER_BY_REFDOC2
static java.lang.String | ORDER_BY_REVISION
static java.lang.String | ORDER_BY_SHIPPEDQTY
static java.lang.String | ORDER_BY_SHIPVIA
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_STDCOST
static java.lang.String | ORDER_BY_TOADDRESSID
static java.lang.String | ORDER_BY_TRANSFERQTY
static java.lang.String | ORDER_BY_TRANSFERRECEIVERITEMNUMBER
static java.lang.String | ORDER_BY_TRANSFERRECEIVERNUMBER
static java.lang.String | ORDER_BY_UNIT
Constructor Summary
TransferReceiverItemListResult()
Method Summary
java.math.BigDecimal | getAvgCost()
java.lang.String | getDescription()
java.lang.String | getDwg()
java.lang.String | getFromAddressId()
java.math.BigDecimal | getHqa()
java.lang.String | getItemComments()
java.lang.String | getItemPrivateNotes()
java.lang.String | getMfg()
java.lang.String | getMpn()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.util.Date | getReceivedDate()
java.math.BigDecimal | getReceivedQty()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.lang.String | getRevision()
java.math.BigDecimal | getShippedQty()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.math.BigDecimal | getStdCost()
java.lang.String | getToAddressId()
java.math.BigDecimal | getTransferQty()
java.lang.String | getTransferReceiverItemNumber()
java.lang.String | getTransferReceiverNumber()
java.lang.String | getUnit()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setDescription(java.lang.String description)
void | setDwg(java.lang.String dwg)
void | setFromAddressId(java.lang.String fromAddressId)
void | setHqa(java.math.BigDecimal hqa)
void | setItemComments(java.lang.String itemComments)
void | setItemPrivateNotes(java.lang.String itemPrivateNotes)
void | setMfg(java.lang.String mfg)
void | setMpn(java.lang.String mpn)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setReceivedDate(java.util.Date receivedDate)
void | setReceivedQty(java.math.BigDecimal receivedQty)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setRevision(java.lang.String revision)
void | setShippedQty(java.math.BigDecimal shippedQty)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setStdCost(java.math.BigDecimal stdCost)
void | setToAddressId(java.lang.String toAddressId)
void | setTransferQty(java.math.BigDecimal transferQty)
void | setTransferReceiverItemNumber(java.lang.String transferReceiverItemNumber)
void | setTransferReceiverNumber(java.lang.String transferReceiverNumber)
void | setUnit(java.lang.String unit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_TRANSFERRECEIVERNUMBER

public static final java.lang.String ORDER_BY_TRANSFERRECEIVERNUMBER
See Also:
Constant Field Values

ORDER_BY_TRANSFERRECEIVERITEMNUMBER

public static final java.lang.String ORDER_BY_TRANSFERRECEIVERITEMNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_PARTFROM

public static final java.lang.String ORDER_BY_PARTFROM
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_TRANSFERQTY

public static final java.lang.String ORDER_BY_TRANSFERQTY
See Also:
Constant Field Values

ORDER_BY_SHIPPEDQTY

public static final java.lang.String ORDER_BY_SHIPPEDQTY
See Also:
Constant Field Values

ORDER_BY_RECEIVEDQTY

public static final java.lang.String ORDER_BY_RECEIVEDQTY
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_AVGCOST

public static final java.lang.String ORDER_BY_AVGCOST
See Also:
Constant Field Values

ORDER_BY_STDCOST

public static final java.lang.String ORDER_BY_STDCOST
See Also:
Constant Field Values

ORDER_BY_ITEMCOMMENTS

public static final java.lang.String ORDER_BY_ITEMCOMMENTS
See Also:
Constant Field Values

ORDER_BY_ITEMPRIVATENOTES

public static final java.lang.String ORDER_BY_ITEMPRIVATENOTES
See Also:
Constant Field Values

ORDER_BY_REVISION

public static final java.lang.String ORDER_BY_REVISION
See Also:
Constant Field Values

ORDER_BY_DWG

public static final java.lang.String ORDER_BY_DWG
See Also:
Constant Field Values

ORDER_BY_MFG

public static final java.lang.String ORDER_BY_MFG
See Also:
Constant Field Values

ORDER_BY_MPN

public static final java.lang.String ORDER_BY_MPN
See Also:
Constant Field Values

ORDER_BY_UNIT

public static final java.lang.String ORDER_BY_UNIT
See Also:
Constant Field Values

ORDER_BY_REFDOC1

public static final java.lang.String ORDER_BY_REFDOC1
See Also:
Constant Field Values

ORDER_BY_REFDOC2

public static final java.lang.String ORDER_BY_REFDOC2
See Also:
Constant Field Values

ORDER_BY_RECEIVEDDATE

public static final java.lang.String ORDER_BY_RECEIVEDDATE
See Also:
Constant Field Values

ORDER_BY_SHIPVIA

public static final java.lang.String ORDER_BY_SHIPVIA
See Also:
Constant Field Values

ORDER_BY_HQA

public static final java.lang.String ORDER_BY_HQA
See Also:
Constant Field Values

ORDER_BY_FROMADDRESSID

public static final java.lang.String ORDER_BY_FROMADDRESSID
See Also:
Constant Field Values

ORDER_BY_TOADDRESSID

public static final java.lang.String ORDER_BY_TOADDRESSID
See Also:
Constant Field Values
Constructor Detail

TransferReceiverItemListResult

public TransferReceiverItemListResult()
Method Detail

getAvgCost

public java.math.BigDecimal getAvgCost()

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getDwg

public java.lang.String getDwg()

setDwg

public void setDwg(java.lang.String dwg)

getHqa

public java.math.BigDecimal getHqa()

setHqa

public void setHqa(java.math.BigDecimal hqa)

getItemComments

public java.lang.String getItemComments()

setItemComments

public void setItemComments(java.lang.String itemComments)

getItemPrivateNotes

public java.lang.String getItemPrivateNotes()

setItemPrivateNotes

public void setItemPrivateNotes(java.lang.String itemPrivateNotes)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getReceivedDate

public java.util.Date getReceivedDate()

setReceivedDate

public void setReceivedDate(java.util.Date receivedDate)

getReceivedQty

public java.math.BigDecimal getReceivedQty()

setReceivedQty

public void setReceivedQty(java.math.BigDecimal receivedQty)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getShippedQty

public java.math.BigDecimal getShippedQty()

setShippedQty

public void setShippedQty(java.math.BigDecimal shippedQty)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getTransferQty

public java.math.BigDecimal getTransferQty()

setTransferQty

public void setTransferQty(java.math.BigDecimal transferQty)

getTransferReceiverItemNumber

public java.lang.String getTransferReceiverItemNumber()

setTransferReceiverItemNumber

public void setTransferReceiverItemNumber(java.lang.String transferReceiverItemNumber)

getTransferReceiverNumber

public java.lang.String getTransferReceiverNumber()

setTransferReceiverNumber

public void setTransferReceiverNumber(java.lang.String transferReceiverNumber)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getFromAddressId

public java.lang.String getFromAddressId()

setFromAddressId

public void setFromAddressId(java.lang.String fromAddressId)

getToAddressId

public java.lang.String getToAddressId()

setToAddressId

public void setToAddressId(java.lang.String toAddressId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TransferReceiverItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class TransferReceiverItemPK

java.lang.Object
    extended by  bb.common.TransferReceiverItemPK
All Implemented Interfaces:
java.io.Serializable
public class TransferReceiverItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
TransferReceiverItemPK()
TransferReceiverItemPK(java.lang.String transferReceiverNumber, java.lang.String transferReceiverItemNumber)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getTransferReceiverItemNumber()
java.lang.String | getTransferReceiverNumber()
int | hashCode()
void | setTransferReceiverItemNumber(java.lang.String transferReceiverItemNumber)
void | setTransferReceiverNumber(java.lang.String transferReceiverNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

TransferReceiverItemPK

public TransferReceiverItemPK()

TransferReceiverItemPK

public TransferReceiverItemPK(java.lang.String transferReceiverNumber,
                              java.lang.String transferReceiverItemNumber)
Method Detail

getTransferReceiverItemNumber

public java.lang.String getTransferReceiverItemNumber()

setTransferReceiverItemNumber

public void setTransferReceiverItemNumber(java.lang.String transferReceiverItemNumber)

getTransferReceiverNumber

public java.lang.String getTransferReceiverNumber()

setTransferReceiverNumber

public void setTransferReceiverNumber(java.lang.String transferReceiverNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TransferReceiverItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class TransferReceiverItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.TransferReceiverItemVO
All Implemented Interfaces:
java.io.Serializable
public class TransferReceiverItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
TransferReceiverItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getAvgCost()
java.lang.String | getDescription()
java.lang.String | getDwg()
java.math.BigDecimal | getHqa()
java.lang.String | getItemComments()
java.lang.String | getItemPrivateNotes()
java.lang.String | getLocation()
java.util.Map | getLocations()
java.lang.String | getMfg()
java.lang.String | getMpn()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
TransferReceiverItemPK | getPk()
java.util.Date | getReceivedDate()
java.math.BigDecimal | getReceivedQty()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.lang.String | getRevision()
java.math.BigDecimal | getShippedQty()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.math.BigDecimal | getStdCost()
java.util.Map | getTrackings()
java.math.BigDecimal | getTransferQty()
java.lang.String | getUnit()
int | hashCode()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setDescription(java.lang.String description)
void | setDwg(java.lang.String dwg)
void | setHqa(java.math.BigDecimal hqa)
void | setItemComments(java.lang.String itemComments)
void | setItemPrivateNotes(java.lang.String itemPrivateNotes)
void | setLocation(java.lang.String location)
void | setLocations(java.util.Map locations)
void | setMfg(java.lang.String mfg)
void | setMpn(java.lang.String mpn)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(TransferReceiverItemPK pk)
void | setReceivedDate(java.util.Date receivedDate)
void | setReceivedQty(java.math.BigDecimal receivedQty)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setRevision(java.lang.String revision)
void | setShippedQty(java.math.BigDecimal shippedQty)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setStdCost(java.math.BigDecimal stdCost)
void | setTrackings(java.util.Map trackings)
void | setTransferQty(java.math.BigDecimal transferQty)
void | setUnit(java.lang.String unit)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

TransferReceiverItemVO

public TransferReceiverItemVO()
Method Detail

getAvgCost

public java.math.BigDecimal getAvgCost()

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getItemComments

public java.lang.String getItemComments()

setItemComments

public void setItemComments(java.lang.String itemComments)

getItemPrivateNotes

public java.lang.String getItemPrivateNotes()

setItemPrivateNotes

public void setItemPrivateNotes(java.lang.String itemPrivateNotes)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPk

public TransferReceiverItemPK getPk()

setPk

public void setPk(TransferReceiverItemPK pk)

getReceivedQty

public java.math.BigDecimal getReceivedQty()

setReceivedQty

public void setReceivedQty(java.math.BigDecimal receivedQty)

getShippedQty

public java.math.BigDecimal getShippedQty()

setShippedQty

public void setShippedQty(java.math.BigDecimal shippedQty)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getTransferQty

public java.math.BigDecimal getTransferQty()

setTransferQty

public void setTransferQty(java.math.BigDecimal transferQty)

getDwg

public java.lang.String getDwg()

setDwg

public void setDwg(java.lang.String dwg)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getReceivedDate

public java.util.Date getReceivedDate()

setReceivedDate

public void setReceivedDate(java.util.Date receivedDate)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getHqa

public java.math.BigDecimal getHqa()

setHqa

public void setHqa(java.math.BigDecimal hqa)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getLocations

public java.util.Map getLocations()

setLocations

public void setLocations(java.util.Map locations)

getTrackings

public java.util.Map getTrackings()

setTrackings

public void setTrackings(java.util.Map trackings)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TransferReceiverListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class TransferReceiverListResult

java.lang.Object
    extended by  bb.common.TransferReceiverListResult
All Implemented Interfaces:
java.io.Serializable
public class TransferReceiverListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ADATE
static java.lang.String | ORDER_BY_ARFREIGHT
static java.lang.String | ORDER_BY_CARRIER
static java.lang.String | ORDER_BY_CARRIERACCOUNT
static java.lang.String | ORDER_BY_COCOMMENTS
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_FROMADDRESSID
static java.lang.String | ORDER_BY_INCOTERM
static java.lang.String | ORDER_BY_INCOTERMPLACEPORT
static java.lang.String | ORDER_BY_LANGUAGE
static java.lang.String | ORDER_BY_LASTCHANGEDATE
static java.lang.String | ORDER_BY_LASTCHANGETIME
static java.lang.String | ORDER_BY_LASTUSER
static java.lang.String | ORDER_BY_LOCATE
static java.lang.String | ORDER_BY_ORIGIN
static java.lang.String | ORDER_BY_RECEIVEDBY
static java.lang.String | ORDER_BY_RECEIVEDDATE
static java.lang.String | ORDER_BY_RECEIVERCOMMENTS
static java.lang.String | ORDER_BY_RECEIVERPRIVATENOTES
static java.lang.String | ORDER_BY_RELATEDDOCUMENT
static java.lang.String | ORDER_BY_SHIPVIA
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_TERMS
static java.lang.String | ORDER_BY_TOADDRESSID
static java.lang.String | ORDER_BY_TRACKING
static java.lang.String | ORDER_BY_TRANSFERORDERNUMBER
static java.lang.String | ORDER_BY_TRANSFERRECEIVERNUMBER
static java.lang.String | ORDER_BY_TRANSFERSHIPPERNUMBER
Constructor Summary
TransferReceiverListResult()
Method Summary
java.util.Date | getAdate()
java.math.BigDecimal | getArFreight()
java.lang.String | getCarrier()
java.lang.String | getCarrierAccount()
java.lang.String | getCoComments()
java.lang.String | getCurrency()
java.lang.String | getFromAddressId()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
int | getLastChangeTime()
java.lang.String | getLastUser()
java.lang.String | getLocate()
java.lang.String | getOrigin()
java.lang.String | getReceivedBy()
java.util.Date | getReceivedDate()
java.lang.String | getReceiverComments()
java.lang.String | getReceiverPrivateNotes()
java.lang.String | getRelatedDocument()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.lang.String | getTerms()
java.lang.String | getToAddressId()
java.lang.String | getTracking()
java.lang.String | getTransferOrderNumber()
java.lang.String | getTransferReceiverNumber()
java.lang.String | getTransferShipperNumber()
void | setAdate(java.util.Date adate)
void | setArFreight(java.math.BigDecimal arFreight)
void | setCarrier(java.lang.String carrier)
void | setCarrierAccount(java.lang.String carrierAccount)
void | setCoComments(java.lang.String coComments)
void | setCurrency(java.lang.String currency)
void | setFromAddressId(java.lang.String fromAddressId)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTime(int lastChangeTime)
void | setLastUser(java.lang.String lastUser)
void | setLocate(java.lang.String locate)
void | setOrigin(java.lang.String origin)
void | setReceivedBy(java.lang.String receivedBy)
void | setReceivedDate(java.util.Date receivedDate)
void | setReceiverComments(java.lang.String receiverComments)
void | setReceiverPrivateNotes(java.lang.String receiverPrivateNotes)
void | setRelatedDocument(java.lang.String relatedDocument)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setTerms(java.lang.String terms)
void | setToAddressId(java.lang.String toAddressId)
void | setTracking(java.lang.String tracking)
void | setTransferOrderNumber(java.lang.String transferOrderNumber)
void | setTransferReceiverNumber(java.lang.String transferReceiverNumber)
void | setTransferShipperNumber(java.lang.String transferShipperNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_TRANSFERRECEIVERNUMBER

public static final java.lang.String ORDER_BY_TRANSFERRECEIVERNUMBER
See Also:
Constant Field Values

ORDER_BY_TRANSFERSHIPPERNUMBER

public static final java.lang.String ORDER_BY_TRANSFERSHIPPERNUMBER
See Also:
Constant Field Values

ORDER_BY_TRANSFERORDERNUMBER

public static final java.lang.String ORDER_BY_TRANSFERORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_ADATE

public static final java.lang.String ORDER_BY_ADATE
See Also:
Constant Field Values

ORDER_BY_ORIGIN

public static final java.lang.String ORDER_BY_ORIGIN
See Also:
Constant Field Values

ORDER_BY_LASTUSER

public static final java.lang.String ORDER_BY_LASTUSER
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEDATE

public static final java.lang.String ORDER_BY_LASTCHANGEDATE
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_CARRIER

public static final java.lang.String ORDER_BY_CARRIER
See Also:
Constant Field Values

ORDER_BY_CARRIERACCOUNT

public static final java.lang.String ORDER_BY_CARRIERACCOUNT
See Also:
Constant Field Values

ORDER_BY_INCOTERM

public static final java.lang.String ORDER_BY_INCOTERM
See Also:
Constant Field Values

ORDER_BY_INCOTERMPLACEPORT

public static final java.lang.String ORDER_BY_INCOTERMPLACEPORT
See Also:
Constant Field Values

ORDER_BY_LOCATE

public static final java.lang.String ORDER_BY_LOCATE
See Also:
Constant Field Values

ORDER_BY_LANGUAGE

public static final java.lang.String ORDER_BY_LANGUAGE
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values

ORDER_BY_SHIPVIA

public static final java.lang.String ORDER_BY_SHIPVIA
See Also:
Constant Field Values

ORDER_BY_FROMADDRESSID

public static final java.lang.String ORDER_BY_FROMADDRESSID
See Also:
Constant Field Values

ORDER_BY_TOADDRESSID

public static final java.lang.String ORDER_BY_TOADDRESSID
See Also:
Constant Field Values

ORDER_BY_RECEIVEDDATE

public static final java.lang.String ORDER_BY_RECEIVEDDATE
See Also:
Constant Field Values

ORDER_BY_ARFREIGHT

public static final java.lang.String ORDER_BY_ARFREIGHT
See Also:
Constant Field Values

ORDER_BY_COCOMMENTS

public static final java.lang.String ORDER_BY_COCOMMENTS
See Also:
Constant Field Values

ORDER_BY_TRACKING

public static final java.lang.String ORDER_BY_TRACKING
See Also:
Constant Field Values

ORDER_BY_TERMS

public static final java.lang.String ORDER_BY_TERMS
See Also:
Constant Field Values

ORDER_BY_LASTCHANGETIME

public static final java.lang.String ORDER_BY_LASTCHANGETIME
See Also:
Constant Field Values

ORDER_BY_RELATEDDOCUMENT

public static final java.lang.String ORDER_BY_RELATEDDOCUMENT
See Also:
Constant Field Values

ORDER_BY_RECEIVERCOMMENTS

public static final java.lang.String ORDER_BY_RECEIVERCOMMENTS
See Also:
Constant Field Values

ORDER_BY_RECEIVERPRIVATENOTES

public static final java.lang.String ORDER_BY_RECEIVERPRIVATENOTES
See Also:
Constant Field Values

ORDER_BY_RECEIVEDBY

public static final java.lang.String ORDER_BY_RECEIVEDBY
See Also:
Constant Field Values
Constructor Detail

TransferReceiverListResult

public TransferReceiverListResult()
Method Detail

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getArFreight

public java.math.BigDecimal getArFreight()

setArFreight

public void setArFreight(java.math.BigDecimal arFreight)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAccount

public java.lang.String getCarrierAccount()

setCarrierAccount

public void setCarrierAccount(java.lang.String carrierAccount)

getCoComments

public java.lang.String getCoComments()

setCoComments

public void setCoComments(java.lang.String coComments)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getFromAddressId

public java.lang.String getFromAddressId()

setFromAddressId

public void setFromAddressId(java.lang.String fromAddressId)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeTime

public int getLastChangeTime()

setLastChangeTime

public void setLastChangeTime(int lastChangeTime)

getLastUser

public java.lang.String getLastUser()

setLastUser

public void setLastUser(java.lang.String lastUser)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getReceivedBy

public java.lang.String getReceivedBy()

setReceivedBy

public void setReceivedBy(java.lang.String receivedBy)

getReceivedDate

public java.util.Date getReceivedDate()

setReceivedDate

public void setReceivedDate(java.util.Date receivedDate)

getReceiverComments

public java.lang.String getReceiverComments()

setReceiverComments

public void setReceiverComments(java.lang.String receiverComments)

getReceiverPrivateNotes

public java.lang.String getReceiverPrivateNotes()

setReceiverPrivateNotes

public void setReceiverPrivateNotes(java.lang.String receiverPrivateNotes)

getRelatedDocument

public java.lang.String getRelatedDocument()

setRelatedDocument

public void setRelatedDocument(java.lang.String relatedDocument)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getToAddressId

public java.lang.String getToAddressId()

setToAddressId

public void setToAddressId(java.lang.String toAddressId)

getTracking

public java.lang.String getTracking()

setTracking

public void setTracking(java.lang.String tracking)

getTransferOrderNumber

public java.lang.String getTransferOrderNumber()

setTransferOrderNumber

public void setTransferOrderNumber(java.lang.String transferOrderNumber)

getTransferReceiverNumber

public java.lang.String getTransferReceiverNumber()

setTransferReceiverNumber

public void setTransferReceiverNumber(java.lang.String transferReceiverNumber)

getTransferShipperNumber

public java.lang.String getTransferShipperNumber()

setTransferShipperNumber

public void setTransferShipperNumber(java.lang.String transferShipperNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TransferReceiverVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class TransferReceiverVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.TransferReceiverVO
All Implemented Interfaces:
java.io.Serializable
public class TransferReceiverVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
TransferReceiverVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.math.BigDecimal | getArFreight()
java.lang.String | getCarrier()
java.lang.String | getCarrierAccount()
java.lang.String | getCoComments()
java.lang.String | getCurrency()
java.lang.String | getFromAddressId()
CustomerVendorAddressInfoVO | getFromAddressInfo()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
int | getLastChangeTime()
java.lang.String | getLastUser()
java.lang.String | getLocate()
java.lang.String | getOrigin()
java.lang.String | getReceivedBy()
java.util.Date | getReceivedDate()
java.lang.String | getReceiverComments()
java.lang.String | getReceiverPrivateNotes()
java.lang.String | getRelatedDocument()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.lang.String | getTerms()
java.lang.String | getToAddressId()
CustomerVendorAddressInfoVO | getToAddressInfo()
java.math.BigDecimal | getTotalCost()
java.lang.String | getTracking()
java.lang.String | getTransferOrderNumber()
java.util.Set<TransferReceiverItemVO> | getTransferReceiverItems()
java.lang.String | getTransferReceiverNumber()
java.lang.String | getTransferShipperNumber()
int | hashCode()
void | setAdate(java.util.Date adate)
void | setArFreight(java.math.BigDecimal arFreight)
void | setCarrier(java.lang.String carrier)
void | setCarrierAccount(java.lang.String carrierAccount)
void | setCoComments(java.lang.String coComments)
void | setCurrency(java.lang.String currency)
void | setFromAddressId(java.lang.String fromAddressId)
void | setFromAddressInfo(CustomerVendorAddressInfoVO fromAddressInfo)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTime(int lastChangeTime)
void | setLastUser(java.lang.String lastUser)
void | setLocate(java.lang.String locate)
void | setOrigin(java.lang.String origin)
void | setReceivedBy(java.lang.String receivedBy)
void | setReceivedDate(java.util.Date receivedDate)
void | setReceiverComments(java.lang.String receiverComments)
void | setReceiverPrivateNotes(java.lang.String receiverPrivateNotes)
void | setRelatedDocument(java.lang.String relatedDocument)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setTerms(java.lang.String terms)
void | setToAddressId(java.lang.String toAddressId)
void | setToAddressInfo(CustomerVendorAddressInfoVO toAddressInfo)
void | setTotalCost(java.math.BigDecimal totalCost)
void | setTracking(java.lang.String tracking)
void | setTransferOrderNumber(java.lang.String transferOrderNumber)
void | setTransferReceiverItems(java.util.Set<TransferReceiverItemVO> transferReceiverItems)
void | setTransferReceiverNumber(java.lang.String transferReceiverNumber)
void | setTransferShipperNumber(java.lang.String transferShipperNumber)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

TransferReceiverVO

public TransferReceiverVO()
Method Detail

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAccount

public java.lang.String getCarrierAccount()

setCarrierAccount

public void setCarrierAccount(java.lang.String carrierAccount)

getCurrency

public java.lang.String getCurrency()

getReceivedDate

public java.util.Date getReceivedDate()

setReceivedDate

public void setReceivedDate(java.util.Date receivedDate)

setCurrency

public void setCurrency(java.lang.String currency)

getFromAddressId

public java.lang.String getFromAddressId()

setFromAddressId

public void setFromAddressId(java.lang.String fromAddressId)

getFromAddressInfo

public CustomerVendorAddressInfoVO getFromAddressInfo()

setFromAddressInfo

public void setFromAddressInfo(CustomerVendorAddressInfoVO fromAddressInfo)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastUser

public java.lang.String getLastUser()

setLastUser

public void setLastUser(java.lang.String lastUser)

getLocate

public java.lang.String getLocate()

setLocate

public void setLocate(java.lang.String locate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getToAddressId

public java.lang.String getToAddressId()

setToAddressId

public void setToAddressId(java.lang.String toAddressId)

getToAddressInfo

public CustomerVendorAddressInfoVO getToAddressInfo()

setToAddressInfo

public void setToAddressInfo(CustomerVendorAddressInfoVO toAddressInfo)

getTotalCost

public java.math.BigDecimal getTotalCost()

setTotalCost

public void setTotalCost(java.math.BigDecimal totalCost)

getTransferOrderNumber

public java.lang.String getTransferOrderNumber()

setTransferOrderNumber

public void setTransferOrderNumber(java.lang.String transferOrderNumber)

getTransferReceiverNumber

public java.lang.String getTransferReceiverNumber()

setTransferReceiverNumber

public void setTransferReceiverNumber(java.lang.String transferReceiverNumber)

getTransferShipperNumber

public java.lang.String getTransferShipperNumber()

setTransferShipperNumber

public void setTransferShipperNumber(java.lang.String transferShipperNumber)

getTransferReceiverItems

public java.util.Set<TransferReceiverItemVO> getTransferReceiverItems()

setTransferReceiverItems

public void setTransferReceiverItems(java.util.Set<TransferReceiverItemVO> transferReceiverItems)

getReceivedBy

public java.lang.String getReceivedBy()

setReceivedBy

public void setReceivedBy(java.lang.String receivedBy)

getArFreight

public java.math.BigDecimal getArFreight()

setArFreight

public void setArFreight(java.math.BigDecimal arFreight)

getCoComments

public java.lang.String getCoComments()

setCoComments

public void setCoComments(java.lang.String coComments)

getLastChangeTime

public int getLastChangeTime()

setLastChangeTime

public void setLastChangeTime(int lastChangeTime)

getRelatedDocument

public java.lang.String getRelatedDocument()

setRelatedDocument

public void setRelatedDocument(java.lang.String relatedDocument)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getTracking

public java.lang.String getTracking()

setTracking

public void setTracking(java.lang.String tracking)

getReceiverComments

public java.lang.String getReceiverComments()

setReceiverComments

public void setReceiverComments(java.lang.String receiverComments)

getReceiverPrivateNotes

public java.lang.String getReceiverPrivateNotes()

setReceiverPrivateNotes

public void setReceiverPrivateNotes(java.lang.String receiverPrivateNotes)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TransferShipperItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class TransferShipperItemListResult

java.lang.Object
    extended by  bb.common.TransferShipperItemListResult
All Implemented Interfaces:
java.io.Serializable
public class TransferShipperItemListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AVGCOST
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_DWG
static java.lang.String | ORDER_BY_ITEMCOMMENTS
static java.lang.String | ORDER_BY_ITEMPRIVATENOTES
static java.lang.String | ORDER_BY_MFG
static java.lang.String | ORDER_BY_MPN
static java.lang.String | ORDER_BY_PARTFROM
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_RECEIVEDQTY
static java.lang.String | ORDER_BY_REFDOC1
static java.lang.String | ORDER_BY_REFDOC2
static java.lang.String | ORDER_BY_REVISION
static java.lang.String | ORDER_BY_SHIPPEDDATE
static java.lang.String | ORDER_BY_SHIPPEDQTY
static java.lang.String | ORDER_BY_SHIPVIA
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_STDCOST
static java.lang.String | ORDER_BY_TRANSFERQTY
static java.lang.String | ORDER_BY_TRANSFERSHIPPERITEMNUMBER
static java.lang.String | ORDER_BY_TRANSFERSHIPPERNUMBER
static java.lang.String | ORDER_BY_UNIT
Constructor Summary
TransferShipperItemListResult()
Method Summary
java.math.BigDecimal | getAvgCost()
java.lang.String | getDescription()
java.lang.String | getDwg()
java.lang.String | getItemComments()
java.lang.String | getItemPrivateNotes()
java.lang.String | getMfg()
java.lang.String | getMpn()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getReceivedQty()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.lang.String | getRevision()
java.util.Date | getShippedDate()
java.math.BigDecimal | getShippedQty()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.math.BigDecimal | getStdCost()
java.math.BigDecimal | getTransferQty()
java.lang.String | getTransferShipperItemNumber()
java.lang.String | getTransferShipperNumber()
java.lang.String | getUnit()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setDescription(java.lang.String description)
void | setDwg(java.lang.String dwg)
void | setItemComments(java.lang.String itemComments)
void | setItemPrivateNotes(java.lang.String itemPrivateNotes)
void | setMfg(java.lang.String mfg)
void | setMpn(java.lang.String mpn)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setReceivedQty(java.math.BigDecimal receivedQty)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setRevision(java.lang.String revision)
void | setShippedDate(java.util.Date shippedDate)
void | setShippedQty(java.math.BigDecimal shippedQty)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setStdCost(java.math.BigDecimal stdCost)
void | setTransferQty(java.math.BigDecimal transferQty)
void | setTransferShipperItemNumber(java.lang.String transferShipperItemNumber)
void | setTransferShipperNumber(java.lang.String transferShipperNumber)
void | setUnit(java.lang.String unit)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_TRANSFERSHIPPERNUMBER

public static final java.lang.String ORDER_BY_TRANSFERSHIPPERNUMBER
See Also:
Constant Field Values

ORDER_BY_TRANSFERSHIPPERITEMNUMBER

public static final java.lang.String ORDER_BY_TRANSFERSHIPPERITEMNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_PARTFROM

public static final java.lang.String ORDER_BY_PARTFROM
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_TRANSFERQTY

public static final java.lang.String ORDER_BY_TRANSFERQTY
See Also:
Constant Field Values

ORDER_BY_SHIPPEDQTY

public static final java.lang.String ORDER_BY_SHIPPEDQTY
See Also:
Constant Field Values

ORDER_BY_RECEIVEDQTY

public static final java.lang.String ORDER_BY_RECEIVEDQTY
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_AVGCOST

public static final java.lang.String ORDER_BY_AVGCOST
See Also:
Constant Field Values

ORDER_BY_STDCOST

public static final java.lang.String ORDER_BY_STDCOST
See Also:
Constant Field Values

ORDER_BY_ITEMCOMMENTS

public static final java.lang.String ORDER_BY_ITEMCOMMENTS
See Also:
Constant Field Values

ORDER_BY_ITEMPRIVATENOTES

public static final java.lang.String ORDER_BY_ITEMPRIVATENOTES
See Also:
Constant Field Values

ORDER_BY_REVISION

public static final java.lang.String ORDER_BY_REVISION
See Also:
Constant Field Values

ORDER_BY_DWG

public static final java.lang.String ORDER_BY_DWG
See Also:
Constant Field Values

ORDER_BY_MFG

public static final java.lang.String ORDER_BY_MFG
See Also:
Constant Field Values

ORDER_BY_MPN

public static final java.lang.String ORDER_BY_MPN
See Also:
Constant Field Values

ORDER_BY_UNIT

public static final java.lang.String ORDER_BY_UNIT
See Also:
Constant Field Values

ORDER_BY_REFDOC1

public static final java.lang.String ORDER_BY_REFDOC1
See Also:
Constant Field Values

ORDER_BY_REFDOC2

public static final java.lang.String ORDER_BY_REFDOC2
See Also:
Constant Field Values

ORDER_BY_SHIPPEDDATE

public static final java.lang.String ORDER_BY_SHIPPEDDATE
See Also:
Constant Field Values

ORDER_BY_SHIPVIA

public static final java.lang.String ORDER_BY_SHIPVIA
See Also:
Constant Field Values
Constructor Detail

TransferShipperItemListResult

public TransferShipperItemListResult()
Method Detail

getAvgCost

public java.math.BigDecimal getAvgCost()

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getDwg

public java.lang.String getDwg()

setDwg

public void setDwg(java.lang.String dwg)

getItemComments

public java.lang.String getItemComments()

setItemComments

public void setItemComments(java.lang.String itemComments)

getItemPrivateNotes

public java.lang.String getItemPrivateNotes()

setItemPrivateNotes

public void setItemPrivateNotes(java.lang.String itemPrivateNotes)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getReceivedQty

public java.math.BigDecimal getReceivedQty()

setReceivedQty

public void setReceivedQty(java.math.BigDecimal receivedQty)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getShippedDate

public java.util.Date getShippedDate()

setShippedDate

public void setShippedDate(java.util.Date shippedDate)

getShippedQty

public java.math.BigDecimal getShippedQty()

setShippedQty

public void setShippedQty(java.math.BigDecimal shippedQty)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getTransferQty

public java.math.BigDecimal getTransferQty()

setTransferQty

public void setTransferQty(java.math.BigDecimal transferQty)

getTransferShipperItemNumber

public java.lang.String getTransferShipperItemNumber()

setTransferShipperItemNumber

public void setTransferShipperItemNumber(java.lang.String transferShipperItemNumber)

getTransferShipperNumber

public java.lang.String getTransferShipperNumber()

setTransferShipperNumber

public void setTransferShipperNumber(java.lang.String transferShipperNumber)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TransferShipperItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class TransferShipperItemPK

java.lang.Object
    extended by  bb.common.TransferShipperItemPK
All Implemented Interfaces:
java.io.Serializable
public class TransferShipperItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
TransferShipperItemPK()
TransferShipperItemPK(java.lang.String transferShipperNumber, java.lang.String transferShipperItemNumber)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getTransferShipperItemNumber()
java.lang.String | getTransferShipperNumber()
int | hashCode()
void | setTransferShipperItemNumber(java.lang.String transferShipperItemNumber)
void | setTransferShipperNumber(java.lang.String transferShipperNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

TransferShipperItemPK

public TransferShipperItemPK()

TransferShipperItemPK

public TransferShipperItemPK(java.lang.String transferShipperNumber,
                             java.lang.String transferShipperItemNumber)
Method Detail

getTransferShipperItemNumber

public java.lang.String getTransferShipperItemNumber()

setTransferShipperItemNumber

public void setTransferShipperItemNumber(java.lang.String transferShipperItemNumber)

getTransferShipperNumber

public java.lang.String getTransferShipperNumber()

setTransferShipperNumber

public void setTransferShipperNumber(java.lang.String transferShipperNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TransferShipperItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class TransferShipperItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.TransferShipperItemVO
All Implemented Interfaces:
java.io.Serializable
public class TransferShipperItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
TransferShipperItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getAvgCost()
java.lang.String | getDescription()
java.lang.String | getItemComments()
java.lang.String | getItemPrivateNotes()
java.lang.String | getLocation()
java.util.Map | getLocations()
java.lang.String | getMfg()
java.lang.String | getMpn()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
TransferShipperItemPK | getPk()
java.math.BigDecimal | getReceivedQty()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.util.Set | getRefDocTwoes()
java.lang.String | getRevision()
java.util.Date | getShippedDate()
java.math.BigDecimal | getShippedQty()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.math.BigDecimal | getStdCost()
java.util.Map | getTrackings()
java.math.BigDecimal | getTransferQty()
java.lang.String | getUnit()
int | hashCode()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setDescription(java.lang.String description)
void | setItemComments(java.lang.String itemComments)
void | setItemPrivateNotes(java.lang.String itemPrivateNotes)
void | setLocation(java.lang.String location)
void | setLocations(java.util.Map locations)
void | setMfg(java.lang.String mfg)
void | setMpn(java.lang.String mpn)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(TransferShipperItemPK pk)
void | setReceivedQty(java.math.BigDecimal receivedQty)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setRefDocTwoes(java.util.Set refDocTwoes)
void | setRevision(java.lang.String revision)
void | setShippedDate(java.util.Date shippedDate)
void | setShippedQty(java.math.BigDecimal shippedQty)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setStdCost(java.math.BigDecimal stdCost)
void | setTrackings(java.util.Map trackings)
void | setTransferQty(java.math.BigDecimal transferQty)
void | setUnit(java.lang.String unit)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

TransferShipperItemVO

public TransferShipperItemVO()
Method Detail

getAvgCost

public java.math.BigDecimal getAvgCost()

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getItemComments

public java.lang.String getItemComments()

setItemComments

public void setItemComments(java.lang.String itemComments)

getItemPrivateNotes

public java.lang.String getItemPrivateNotes()

setItemPrivateNotes

public void setItemPrivateNotes(java.lang.String itemPrivateNotes)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPk

public TransferShipperItemPK getPk()

setPk

public void setPk(TransferShipperItemPK pk)

getReceivedQty

public java.math.BigDecimal getReceivedQty()

setReceivedQty

public void setReceivedQty(java.math.BigDecimal receivedQty)

getShippedQty

public java.math.BigDecimal getShippedQty()

setShippedQty

public void setShippedQty(java.math.BigDecimal shippedQty)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getTransferQty

public java.math.BigDecimal getTransferQty()

setTransferQty

public void setTransferQty(java.math.BigDecimal transferQty)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getShippedDate

public java.util.Date getShippedDate()

setShippedDate

public void setShippedDate(java.util.Date shippedDate)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getRefDocTwoes

public java.util.Set getRefDocTwoes()

setRefDocTwoes

public void setRefDocTwoes(java.util.Set refDocTwoes)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getLocations

public java.util.Map getLocations()

setLocations

public void setLocations(java.util.Map locations)

getTrackings

public java.util.Map getTrackings()

setTrackings

public void setTrackings(java.util.Map trackings)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TransferShipperListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class TransferShipperListResult

java.lang.Object
    extended by  bb.common.TransferShipperListResult
All Implemented Interfaces:
java.io.Serializable
public class TransferShipperListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ADATE
static java.lang.String | ORDER_BY_ARFREIGHT
static java.lang.String | ORDER_BY_CARRIER
static java.lang.String | ORDER_BY_CARRIERACCOUNT
static java.lang.String | ORDER_BY_COCOMMENTS
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_FREIGHTRATECODE
static java.lang.String | ORDER_BY_FROMADDRESSID
static java.lang.String | ORDER_BY_FROMADDRESSNAME
static java.lang.String | ORDER_BY_GROSSWEIGHT
static java.lang.String | ORDER_BY_INCOTERM
static java.lang.String | ORDER_BY_INCOTERMPLACEPORT
static java.lang.String | ORDER_BY_LANGUAGE
static java.lang.String | ORDER_BY_LASTCHANGEDATE
static java.lang.String | ORDER_BY_LASTCHANGETIME
static java.lang.String | ORDER_BY_LASTUSER
static java.lang.String | ORDER_BY_ORIGIN
static java.lang.String | ORDER_BY_RELATEDDOCUMENT
static java.lang.String | ORDER_BY_SHIPACCOUT
static java.lang.String | ORDER_BY_SHIPPEDBY
static java.lang.String | ORDER_BY_SHIPPEDDATE
static java.lang.String | ORDER_BY_SHIPPERCOMMENTS
static java.lang.String | ORDER_BY_SHIPPERPRIVATENOTES
static java.lang.String | ORDER_BY_SHIPVIA
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_TERMS
static java.lang.String | ORDER_BY_TOADDRESSID
static java.lang.String | ORDER_BY_TOADDRESSNAME
static java.lang.String | ORDER_BY_TOTALCOST
static java.lang.String | ORDER_BY_TRACKING
static java.lang.String | ORDER_BY_TRANSFERORDERNUMBER
static java.lang.String | ORDER_BY_TRANSFERSHIPPERNUMBER
Constructor Summary
TransferShipperListResult()
Method Summary
java.util.Date | getAdate()
java.math.BigDecimal | getArFreight()
java.lang.String | getCarrier()
java.lang.String | getCarrierAccount()
java.lang.String | getCoComments()
java.lang.String | getCurrency()
java.lang.String | getFreightRateCode()
java.lang.String | getFromAddressId()
java.lang.String | getFromAddressName()
java.lang.String | getGrossWeight()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
int | getLastChangeTime()
java.lang.String | getLastUser()
java.lang.String | getOrigin()
java.lang.String | getRelatedDocument()
java.lang.String | getShipAccout()
java.lang.String | getShippedBy()
java.util.Date | getShippedDate()
java.lang.String | getShipperComments()
java.lang.String | getShipperPrivateNotes()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.lang.String | getTerms()
java.lang.String | getToAddressId()
java.lang.String | getToAddressName()
java.math.BigDecimal | getTotalCost()
java.lang.String | getTracking()
java.lang.String | getTransferOrderNumber()
java.lang.String | getTransferShipperNumber()
void | setAdate(java.util.Date adate)
void | setArFreight(java.math.BigDecimal arFreight)
void | setCarrier(java.lang.String carrier)
void | setCarrierAccount(java.lang.String carrierAccount)
void | setCoComments(java.lang.String coComments)
void | setCurrency(java.lang.String currency)
void | setFreightRateCode(java.lang.String freightRateCode)
void | setFromAddressId(java.lang.String fromAddressId)
void | setFromAddressName(java.lang.String fromAddressName)
void | setGrossWeight(java.lang.String grossWeight)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTime(int lastChangeTime)
void | setLastUser(java.lang.String lastUser)
void | setOrigin(java.lang.String origin)
void | setRelatedDocument(java.lang.String relatedDocument)
void | setShipAccout(java.lang.String shipAccout)
void | setShippedBy(java.lang.String shippedBy)
void | setShippedDate(java.util.Date shippedDate)
void | setShipperComments(java.lang.String shipperComments)
void | setShipperPrivateNotes(java.lang.String shipperPrivateNotes)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setTerms(java.lang.String terms)
void | setToAddressId(java.lang.String toAddressId)
void | setToAddressName(java.lang.String toAddressName)
void | setTotalCost(java.math.BigDecimal totalCost)
void | setTracking(java.lang.String tracking)
void | setTransferOrderNumber(java.lang.String transferOrderNumber)
void | setTransferShipperNumber(java.lang.String transferShipperNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_TRANSFERSHIPPERNUMBER

public static final java.lang.String ORDER_BY_TRANSFERSHIPPERNUMBER
See Also:
Constant Field Values

ORDER_BY_TRANSFERORDERNUMBER

public static final java.lang.String ORDER_BY_TRANSFERORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_ADATE

public static final java.lang.String ORDER_BY_ADATE
See Also:
Constant Field Values

ORDER_BY_ORIGIN

public static final java.lang.String ORDER_BY_ORIGIN
See Also:
Constant Field Values

ORDER_BY_LASTUSER

public static final java.lang.String ORDER_BY_LASTUSER
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEDATE

public static final java.lang.String ORDER_BY_LASTCHANGEDATE
See Also:
Constant Field Values

ORDER_BY_TOTALCOST

public static final java.lang.String ORDER_BY_TOTALCOST
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_CARRIER

public static final java.lang.String ORDER_BY_CARRIER
See Also:
Constant Field Values

ORDER_BY_CARRIERACCOUNT

public static final java.lang.String ORDER_BY_CARRIERACCOUNT
See Also:
Constant Field Values

ORDER_BY_INCOTERM

public static final java.lang.String ORDER_BY_INCOTERM
See Also:
Constant Field Values

ORDER_BY_INCOTERMPLACEPORT

public static final java.lang.String ORDER_BY_INCOTERMPLACEPORT
See Also:
Constant Field Values

ORDER_BY_SHIPACCOUT

public static final java.lang.String ORDER_BY_SHIPACCOUT
See Also:
Constant Field Values

ORDER_BY_LANGUAGE

public static final java.lang.String ORDER_BY_LANGUAGE
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values

ORDER_BY_SHIPVIA

public static final java.lang.String ORDER_BY_SHIPVIA
See Also:
Constant Field Values

ORDER_BY_ARFREIGHT

public static final java.lang.String ORDER_BY_ARFREIGHT
See Also:
Constant Field Values

ORDER_BY_COCOMMENTS

public static final java.lang.String ORDER_BY_COCOMMENTS
See Also:
Constant Field Values

ORDER_BY_FROMADDRESSID

public static final java.lang.String ORDER_BY_FROMADDRESSID
See Also:
Constant Field Values

ORDER_BY_TOADDRESSID

public static final java.lang.String ORDER_BY_TOADDRESSID
See Also:
Constant Field Values

ORDER_BY_FROMADDRESSNAME

public static final java.lang.String ORDER_BY_FROMADDRESSNAME
See Also:
Constant Field Values

ORDER_BY_TOADDRESSNAME

public static final java.lang.String ORDER_BY_TOADDRESSNAME
See Also:
Constant Field Values

ORDER_BY_SHIPPEDDATE

public static final java.lang.String ORDER_BY_SHIPPEDDATE
See Also:
Constant Field Values

ORDER_BY_SHIPPEDBY

public static final java.lang.String ORDER_BY_SHIPPEDBY
See Also:
Constant Field Values

ORDER_BY_TRACKING

public static final java.lang.String ORDER_BY_TRACKING
See Also:
Constant Field Values

ORDER_BY_FREIGHTRATECODE

public static final java.lang.String ORDER_BY_FREIGHTRATECODE
See Also:
Constant Field Values

ORDER_BY_GROSSWEIGHT

public static final java.lang.String ORDER_BY_GROSSWEIGHT
See Also:
Constant Field Values

ORDER_BY_TERMS

public static final java.lang.String ORDER_BY_TERMS
See Also:
Constant Field Values

ORDER_BY_LASTCHANGETIME

public static final java.lang.String ORDER_BY_LASTCHANGETIME
See Also:
Constant Field Values

ORDER_BY_RELATEDDOCUMENT

public static final java.lang.String ORDER_BY_RELATEDDOCUMENT
See Also:
Constant Field Values

ORDER_BY_SHIPPERCOMMENTS

public static final java.lang.String ORDER_BY_SHIPPERCOMMENTS
See Also:
Constant Field Values

ORDER_BY_SHIPPERPRIVATENOTES

public static final java.lang.String ORDER_BY_SHIPPERPRIVATENOTES
See Also:
Constant Field Values
Constructor Detail

TransferShipperListResult

public TransferShipperListResult()
Method Detail

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAccount

public java.lang.String getCarrierAccount()

setCarrierAccount

public void setCarrierAccount(java.lang.String carrierAccount)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getFromAddressId

public java.lang.String getFromAddressId()

setFromAddressId

public void setFromAddressId(java.lang.String fromAddressId)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastUser

public java.lang.String getLastUser()

setLastUser

public void setLastUser(java.lang.String lastUser)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getShipAccout

public java.lang.String getShipAccout()

setShipAccout

public void setShipAccout(java.lang.String shipAccout)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getToAddressId

public java.lang.String getToAddressId()

setToAddressId

public void setToAddressId(java.lang.String toAddressId)

getTotalCost

public java.math.BigDecimal getTotalCost()

setTotalCost

public void setTotalCost(java.math.BigDecimal totalCost)

getTransferOrderNumber

public java.lang.String getTransferOrderNumber()

setTransferOrderNumber

public void setTransferOrderNumber(java.lang.String transferOrderNumber)

getTransferShipperNumber

public java.lang.String getTransferShipperNumber()

setTransferShipperNumber

public void setTransferShipperNumber(java.lang.String transferShipperNumber)

getShippedDate

public java.util.Date getShippedDate()

setShippedDate

public void setShippedDate(java.util.Date shippedDate)

getFreightRateCode

public java.lang.String getFreightRateCode()

setFreightRateCode

public void setFreightRateCode(java.lang.String freightRateCode)

getGrossWeight

public java.lang.String getGrossWeight()

setGrossWeight

public void setGrossWeight(java.lang.String grossWeight)

getTracking

public java.lang.String getTracking()

setTracking

public void setTracking(java.lang.String tracking)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getShippedBy

public java.lang.String getShippedBy()

setShippedBy

public void setShippedBy(java.lang.String shippedBy)

getLastChangeTime

public int getLastChangeTime()

setLastChangeTime

public void setLastChangeTime(int lastChangeTime)

getRelatedDocument

public java.lang.String getRelatedDocument()

setRelatedDocument

public void setRelatedDocument(java.lang.String relatedDocument)

getShipperComments

public java.lang.String getShipperComments()

setShipperComments

public void setShipperComments(java.lang.String shipperComments)

getShipperPrivateNotes

public java.lang.String getShipperPrivateNotes()

setShipperPrivateNotes

public void setShipperPrivateNotes(java.lang.String shipperPrivateNotes)

getCoComments

public java.lang.String getCoComments()

setCoComments

public void setCoComments(java.lang.String coComments)

getArFreight

public java.math.BigDecimal getArFreight()

setArFreight

public void setArFreight(java.math.BigDecimal arFreight)

getFromAddressName

public java.lang.String getFromAddressName()

setFromAddressName

public void setFromAddressName(java.lang.String fromAddressName)

getToAddressName

public java.lang.String getToAddressName()

setToAddressName

public void setToAddressName(java.lang.String toAddressName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TransferShipperVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class TransferShipperVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.TransferShipperVO
All Implemented Interfaces:
java.io.Serializable
public class TransferShipperVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
TransferShipperVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.math.BigDecimal | getArFreight()
java.lang.String | getCarrier()
java.lang.String | getCarrierAccount()
java.lang.String | getCoComments()
java.lang.String | getContact()
java.lang.String | getCurrency()
java.lang.String | getFreightRateCode()
java.lang.String | getFromAddressId()
CustomerVendorAddressInfoVO | getFromAddressInfo()
java.lang.String | getGlNumber()
java.lang.String | getGrossWeight()
java.lang.String | getIncoterm()
java.lang.String | getIncotermPlacePort()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
int | getLastChangeTime()
java.lang.String | getLastUser()
java.lang.String | getOrigin()
java.lang.String | getRelatedDocument()
java.lang.String | getShipAccout()
java.lang.String | getShippedBy()
java.util.Date | getShippedDate()
java.lang.String | getShipperComments()
java.lang.String | getShipperPrivateNotes()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.lang.String | getTerms()
java.lang.String | getToAddressId()
CustomerVendorAddressInfoVO | getToAddressInfo()
java.math.BigDecimal | getTotalCost()
java.lang.String | getTracking()
java.lang.String | getTransferOrderNumber()
java.util.Set<TransferShipperItemVO> | getTransferShipperItems()
java.lang.String | getTransferShipperNumber()
int | hashCode()
void | setAdate(java.util.Date adate)
void | setArFreight(java.math.BigDecimal arFreight)
void | setCarrier(java.lang.String carrier)
void | setCarrierAccount(java.lang.String carrierAccount)
void | setCoComments(java.lang.String coComments)
void | setContact(java.lang.String contact)
void | setCurrency(java.lang.String currency)
void | setFreightRateCode(java.lang.String freightRateCode)
void | setFromAddressId(java.lang.String fromAddressId)
void | setFromAddressInfo(CustomerVendorAddressInfoVO fromAddressInfo)
void | setGlNumber(java.lang.String glNumber)
void | setGrossWeight(java.lang.String grossWeight)
void | setIncoterm(java.lang.String incoterm)
void | setIncotermPlacePort(java.lang.String incotermPlacePort)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTime(int lastChangeTime)
void | setLastUser(java.lang.String lastUser)
void | setOrigin(java.lang.String origin)
void | setRelatedDocument(java.lang.String relatedDocument)
void | setShipAccout(java.lang.String shipAccout)
void | setShippedBy(java.lang.String shippedBy)
void | setShippedDate(java.util.Date shippedDate)
void | setShipperComments(java.lang.String shipperComments)
void | setShipperPrivateNotes(java.lang.String shipperPrivateNotes)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setTerms(java.lang.String terms)
void | setToAddressId(java.lang.String toAddressId)
void | setToAddressInfo(CustomerVendorAddressInfoVO toAddressInfo)
void | setTotalCost(java.math.BigDecimal totalCost)
void | setTracking(java.lang.String tracking)
void | setTransferOrderNumber(java.lang.String transferOrderNumber)
void | setTransferShipperItems(java.util.Set<TransferShipperItemVO> transferShipperItems)
void | setTransferShipperNumber(java.lang.String transferShipperNumber)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

TransferShipperVO

public TransferShipperVO()
Method Detail

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getCarrier

public java.lang.String getCarrier()

setCarrier

public void setCarrier(java.lang.String carrier)

getCarrierAccount

public java.lang.String getCarrierAccount()

setCarrierAccount

public void setCarrierAccount(java.lang.String carrierAccount)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getFromAddressId

public java.lang.String getFromAddressId()

setFromAddressId

public void setFromAddressId(java.lang.String fromAddressId)

getFromAddressInfo

public CustomerVendorAddressInfoVO getFromAddressInfo()

setFromAddressInfo

public void setFromAddressInfo(CustomerVendorAddressInfoVO fromAddressInfo)

getIncoterm

public java.lang.String getIncoterm()

setIncoterm

public void setIncoterm(java.lang.String incoterm)

getIncotermPlacePort

public java.lang.String getIncotermPlacePort()

setIncotermPlacePort

public void setIncotermPlacePort(java.lang.String incotermPlacePort)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastUser

public java.lang.String getLastUser()

setLastUser

public void setLastUser(java.lang.String lastUser)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getShipAccout

public java.lang.String getShipAccout()

setShipAccout

public void setShipAccout(java.lang.String shipAccout)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getToAddressId

public java.lang.String getToAddressId()

setToAddressId

public void setToAddressId(java.lang.String toAddressId)

getToAddressInfo

public CustomerVendorAddressInfoVO getToAddressInfo()

setToAddressInfo

public void setToAddressInfo(CustomerVendorAddressInfoVO toAddressInfo)

getTotalCost

public java.math.BigDecimal getTotalCost()

setTotalCost

public void setTotalCost(java.math.BigDecimal totalCost)

getTransferOrderNumber

public java.lang.String getTransferOrderNumber()

setTransferOrderNumber

public void setTransferOrderNumber(java.lang.String transferOrderNumber)

getTransferShipperNumber

public java.lang.String getTransferShipperNumber()

setTransferShipperNumber

public void setTransferShipperNumber(java.lang.String transferShipperNumber)

getShippedDate

public java.util.Date getShippedDate()

setShippedDate

public void setShippedDate(java.util.Date shippedDate)

getFreightRateCode

public java.lang.String getFreightRateCode()

setFreightRateCode

public void setFreightRateCode(java.lang.String freightRateCode)

getGrossWeight

public java.lang.String getGrossWeight()

setGrossWeight

public void setGrossWeight(java.lang.String grossWeight)

getTracking

public java.lang.String getTracking()

setTracking

public void setTracking(java.lang.String tracking)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getShippedBy

public java.lang.String getShippedBy()

setShippedBy

public void setShippedBy(java.lang.String shippedBy)

getTransferShipperItems

public java.util.Set<TransferShipperItemVO> getTransferShipperItems()

setTransferShipperItems

public void setTransferShipperItems(java.util.Set<TransferShipperItemVO> transferShipperItems)

getLastChangeTime

public int getLastChangeTime()

setLastChangeTime

public void setLastChangeTime(int lastChangeTime)

getRelatedDocument

public java.lang.String getRelatedDocument()

setRelatedDocument

public void setRelatedDocument(java.lang.String relatedDocument)

getShipperComments

public java.lang.String getShipperComments()

setShipperComments

public void setShipperComments(java.lang.String shipperComments)

getShipperPrivateNotes

public java.lang.String getShipperPrivateNotes()

setShipperPrivateNotes

public void setShipperPrivateNotes(java.lang.String shipperPrivateNotes)

getCoComments

public java.lang.String getCoComments()

setCoComments

public void setCoComments(java.lang.String coComments)

getArFreight

public java.math.BigDecimal getArFreight()

setArFreight

public void setArFreight(java.math.BigDecimal arFreight)

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getGlNumber

public java.lang.String getGlNumber()

setGlNumber

public void setGlNumber(java.lang.String glNumber)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TwelveMonthCashFlowReportResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class TwelveMonthCashFlowReportResult

java.lang.Object
    extended by  bb.common.TwelveMonthCashFlowReportResult
All Implemented Interfaces:
java.io.Serializable
public class TwelveMonthCashFlowReportResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
TwelveMonthCashFlowReportResult()
Method Summary
java.util.TreeMap | getAp()
java.util.TreeMap | getAr()
java.util.TreeMap | getCashEndPosition()
java.util.TreeMap | getCashPosition()
java.util.LinkedHashSet | getColumns()
java.util.TreeMap | getEAccounts()
java.util.TreeMap | getOpenPos()
java.util.TreeMap | getOpenSo()
java.util.TreeMap | getRAccounts()
java.util.TreeMap | getTotalCashAvailiable()
java.util.TreeMap | getTotalPayOut()
java.util.TreeMap | getTotalReceipts()
void | setAp(java.util.TreeMap ap)
void | setAr(java.util.TreeMap ar)
void | setCashEndPosition(java.util.TreeMap cashEndPosition)
void | setCashPosition(java.util.TreeMap cashPosition)
void | setColumns(java.util.LinkedHashSet columns)
void | setEAccounts(java.util.TreeMap eAccounts)
void | setOpenPos(java.util.TreeMap openPos)
void | setOpenSo(java.util.TreeMap openSo)
void | setRAccounts(java.util.TreeMap rAccounts)
void | setTotalCashAvailiable(java.util.TreeMap totalCashAvailiable)
void | setTotalPayOut(java.util.TreeMap totalPayOut)
void | setTotalReceipts(java.util.TreeMap totalReceipts)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TwelveMonthCashFlowReportResult

public TwelveMonthCashFlowReportResult()
Method Detail

getTotalPayOut

public java.util.TreeMap getTotalPayOut()

getAr

public java.util.TreeMap getAr()

getTotalCashAvailiable

public java.util.TreeMap getTotalCashAvailiable()

getOpenSo

public java.util.TreeMap getOpenSo()

getCashPosition

public java.util.TreeMap getCashPosition()

getTotalReceipts

public java.util.TreeMap getTotalReceipts()

getOpenPos

public java.util.TreeMap getOpenPos()

getAp

public java.util.TreeMap getAp()

setCashEndPosition

public void setCashEndPosition(java.util.TreeMap cashEndPosition)

setTotalPayOut

public void setTotalPayOut(java.util.TreeMap totalPayOut)

setAr

public void setAr(java.util.TreeMap ar)

setTotalCashAvailiable

public void setTotalCashAvailiable(java.util.TreeMap totalCashAvailiable)

setOpenSo

public void setOpenSo(java.util.TreeMap openSo)

setCashPosition

public void setCashPosition(java.util.TreeMap cashPosition)

setTotalReceipts

public void setTotalReceipts(java.util.TreeMap totalReceipts)

setOpenPos

public void setOpenPos(java.util.TreeMap openPos)

setAp

public void setAp(java.util.TreeMap ap)

setColumns

public void setColumns(java.util.LinkedHashSet columns)

setRAccounts

public void setRAccounts(java.util.TreeMap rAccounts)

setEAccounts

public void setEAccounts(java.util.TreeMap eAccounts)

getCashEndPosition

public java.util.TreeMap getCashEndPosition()

getColumns

public java.util.LinkedHashSet getColumns()

getRAccounts

public java.util.TreeMap getRAccounts()

getEAccounts

public java.util.TreeMap getEAccounts()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


U-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M N O P Q R S T U V W X Y Z

U

UNBILLED - Static variable in class bb.common.BizTarget
Unbilled - Static variable in class bb.common.Constant.Status
UNBILLED_ITEMS_SHOULD_BE_WITH_THE_SAME_UNBILLED_EXCHANGE_FOR_OFFSET - Static variable in class bb.common.BIZReason
UNDEPRECIATE - Static variable in class bb.common.Constant.Depreciation.DepreciateStatus
uniqueStr() - Method in class bb.common.AccountsPayableItemManufacturerVO
uniqueStr() - Method in class bb.common.AccountsReceivableItemManufacturerVO
uniqueStr() - Method in class bb.common.AssetDepreciateVO
uniqueStr() - Method in class bb.common.AssetVO
uniqueStr() - Method in class bb.common.BillItemVO
uniqueStr() - Method in class bb.common.BillVO
uniqueStr() - Method in class bb.common.BizboxUserVO
uniqueStr() - Method in class bb.common.BuyerCodeVO
uniqueStr() - Method in class bb.common.CertificateDescriptionVO
uniqueStr() - Method in class bb.common.CompanyVO
uniqueStr() - Method in class bb.common.ContractPriceCustomerVO
uniqueStr() - Method in class bb.common.ContractPriceItemVO
uniqueStr() - Method in class bb.common.ContractPriceVO
uniqueStr() - Method in class bb.common.CorrectiveActionRequestVO
uniqueStr() - Method in class bb.common.CurrencyExchangePK
uniqueStr() - Method in class bb.common.CurrencyExchangeVO
uniqueStr() - Method in class bb.common.CurrencyVO
uniqueStr() - Method in class bb.common.CustomerVendorAddressInfoVO
uniqueStr() - Method in class bb.common.CustomerVendorAddressVO
uniqueStr() - Method in class bb.common.CustomerVendorContactVO
uniqueStr() - Method in class bb.common.CustomerVendorDescriptionVO
uniqueStr() - Method in class bb.common.DesignControlDocumentVO
uniqueStr() - Method in class bb.common.DesignControlInfoVO
uniqueStr() - Method in class bb.common.DesignControlVO
uniqueStr() - Method in class bb.common.DocumentLogVO
uniqueStr() - Method in class bb.common.DocumentServerVO
uniqueStr() - Method in class bb.common.ECNReviewVO
uniqueStr() - Method in class bb.common.ECRReviewVO
uniqueStr() - Method in class bb.common.EmployeeHomeVO
uniqueStr() - Method in class bb.common.EngGroupVO
uniqueStr() - Method in class bb.common.EngineeringChangeRequestVO
uniqueStr() - Method in class bb.common.EngineeringChangeVO
uniqueStr() - Method in class bb.common.IncotermVO
uniqueStr() - Method in class bb.common.ManufacturerAddressInfoVO
uniqueStr() - Method in class bb.common.ManufacturerAddressVO
uniqueStr() - Method in class bb.common.ManufacturerContactVO
uniqueStr() - Method in class bb.common.ManufacturerDescriptionVO
uniqueStr() - Method in class bb.common.NonConformanceCodeVO
uniqueStr() - Method in class bb.common.NonConformanceQuantityVO
uniqueStr() - Method in class bb.common.NonConformanceReportVO
uniqueStr() - Method in class bb.common.OnloanReviewVO
uniqueStr() - Method in class bb.common.OnloanShipperItemVO
uniqueStr() - Method in class bb.common.OnloanShipperVO
uniqueStr() - Method in class bb.common.OperationLogVO
uniqueStr() - Method in class bb.common.PackingBoxItemVO
uniqueStr() - Method in class bb.common.PackingBoxVO
uniqueStr() - Method in class bb.common.PartCertificateVO
uniqueStr() - Method in class bb.common.PartDescriptionVO
uniqueStr() - Method in class bb.common.PartInventoryVO
uniqueStr() - Method in class bb.common.PartManufacturerVO
uniqueStr() - Method in class bb.common.PartOnhandVO
uniqueStr() - Method in class bb.common.PartPictureVO
uniqueStr() - Method in class bb.common.PartPK
uniqueStr() - Method in class bb.common.PartSecurityLevelVO
uniqueStr() - Method in class bb.common.PartTraceableCategoryVO
uniqueStr() - Method in class bb.common.PartTraceableSpecVO
uniqueStr() - Method in class bb.common.PartTypeVO
uniqueStr() - Method in class bb.common.PartVendorVO
uniqueStr() - Method in class bb.common.PartVO
uniqueStr() - Method in class bb.common.PartWithOnhandsVO
uniqueStr() - Method in class bb.common.PfReceiverVO
uniqueStr() - Method in class bb.common.POSurveyReportItemVO
uniqueStr() - Method in class bb.common.POSurveyReportVO
uniqueStr() - Method in class bb.common.ProformaInvoiceItemManufacturerVO
uniqueStr() - Method in class bb.common.ProformaInvoiceItemVO
uniqueStr() - Method in class bb.common.ProformaInvoiceVO
uniqueStr() - Method in class bb.common.PrPackingBoxItemVO
uniqueStr() - Method in class bb.common.PrPackingBoxVO
uniqueStr() - Method in class bb.common.PurchaseOrderApprovalVO
uniqueStr() - Method in class bb.common.PurchaseOrderItemManufacturerVO
uniqueStr() - Method in class bb.common.PurchaseOrderItemVO
uniqueStr() - Method in class bb.common.PurchaseOrderVO
uniqueStr() - Method in class bb.common.PurchaseWorkSheetItemVO
uniqueStr() - Method in class bb.common.PurchaseWorkSheetVO
uniqueStr() - Method in class bb.common.QuoteItemManufacturerVO
uniqueStr() - Method in class bb.common.QuoteItemVO
uniqueStr() - Method in class bb.common.QuoteVO
uniqueStr() - Method in class bb.common.ReceiverInfoVO
uniqueStr() - Method in class bb.common.ReceiverItemManufacturerVO
uniqueStr() - Method in class bb.common.ReceiverItemVO
uniqueStr() - Method in class bb.common.ReceiverVO
uniqueStr() - Method in class bb.common.RequestForQuoteItemManufacturerVO
uniqueStr() - Method in class bb.common.RequestForQuoteItemVO
uniqueStr() - Method in class bb.common.RequestForQuoteVO
uniqueStr() - Method in class bb.common.ReturnMaterialAuthorizationItemVO
uniqueStr() - Method in class bb.common.ReturnMaterialAuthorizationVO
uniqueStr() - Method in class bb.common.ReturnToVendorItemPK
uniqueStr() - Method in class bb.common.ReturnToVendorItemVO
uniqueStr() - Method in class bb.common.ReturnToVendorVO
uniqueStr() - Method in class bb.common.SalesCodeVO
uniqueStr() - Method in class bb.common.SalesmanVO
uniqueStr() - Method in class bb.common.SalesOrderItemInfoVO
uniqueStr() - Method in class bb.common.SalesOrderItemManufacturerVO
uniqueStr() - Method in class bb.common.SalesOrderItemVO
uniqueStr() - Method in class bb.common.SalesOrderReviewVO
uniqueStr() - Method in class bb.common.SalesOrderVO
uniqueStr() - Method in class bb.common.SerialNumberItemVO
uniqueStr() - Method in class bb.common.SerialNumberVO
uniqueStr() - Method in class bb.common.ShipListInfoVO
uniqueStr() - Method in class bb.common.ShipListItemVO
uniqueStr() - Method in class bb.common.ShipListOwnerAttributeVO
uniqueStr() - Method in class bb.common.ShipListOwnerVO
uniqueStr() - Method in class bb.common.ShipListVO
uniqueStr() - Method in class bb.common.ShipperInfoVO
uniqueStr() - Method in class bb.common.ShipperItemManufacturerVO
uniqueStr() - Method in class bb.common.ShipperItemVO
uniqueStr() - Method in class bb.common.ShipperVO
uniqueStr() - Method in class bb.common.ToolCalibrationVO
uniqueStr() - Method in class bb.common.ToolDescriptionVO
uniqueStr() - Method in class bb.common.ToolInventoryVO
uniqueStr() - Method in class bb.common.ToolListInfoVO
uniqueStr() - Method in class bb.common.ToolListItemVO
uniqueStr() - Method in class bb.common.ToolListVO
uniqueStr() - Method in class bb.common.ToolManufacturerVO
uniqueStr() - Method in class bb.common.ToolVendorVO
uniqueStr() - Method in class bb.common.ToolVO
uniqueStr() - Method in class bb.common.ToolWithOnhandsVO
uniqueStr() - Method in class bb.common.TraceableCategoriesVO
uniqueStr() - Method in class bb.common.TraceableSpecsVO
uniqueStr() - Method in class bb.common.UserRoleVO
uniqueStr() - Method in class bb.common.VO
uniqueStr() - Method in class bb.common.WeightUnitVO
uniqueStr() - Method in class bb.common.WorkCenterVO
uniqueStr() - Method in class bb.common.WorkInstructionPictureVO
uniqueStr() - Method in class bb.common.WorkInstructionRequestForChangeVO
uniqueStr() - Method in class bb.common.WorkOrderApprovalVO
uniqueStr() - Method in class bb.common.WorkOrderItemIssueVO
uniqueStr() - Method in class bb.common.WorkOrderItemTimeDetailVO
uniqueStr() - Method in class bb.common.WorkOrderItemVO
uniqueStr() - Method in class bb.common.WorkOrderReceiverVO
uniqueStr() - Method in class bb.common.WorkOrderTimeCardVO
uniqueStr() - Method in class bb.common.WorkOrderVO
uniqueStr() - Method in class bb.common.WorkOrderWorkSheetItemVO
uniqueStr() - Method in class bb.common.WorkOrderWorkSheetVO
uniqueStr() - Method in class bb.common.ZipCodeVO
UnitVO - Class in bb.common
UnitVO() - Constructor for class bb.common.UnitVO
UnitVO(long, String) - Constructor for class bb.common.UnitVO
UNKNOWN_EXCEPTION - Static variable in exception bb.common.BB2ServerException
UNKNOWN_EXCEPTION - Static variable in exception bb.common.ServerException
UNLOCKED - Static variable in class bb.common.Configure.UserLocked
unlockUser(String) - Method in interface bb.common.box.SecurityBox
UNUSE - Static variable in class bb.common.Constant.Depreciation.UsingType
UnUsual - Static variable in class bb.common.Constant.Status
unzipFile(byte[]) - Static method in class bb.common.BB2Util
unzipObject(byte[]) - Static method in class bb.common.BB2Util
UPC_MFG_IS_EMPTY - Static variable in class bb.common.BIZReason
UPDATE - Static variable in class bb.common.Constant.EngineeringSharingImportType
UPDATE - Static variable in class bb.common.Constant.NoticeAction
UPDATE - Static variable in class bb.common.DocumentAction.DwfAndDwgDocAction
UPDATE - Static variable in class bb.common.DocumentAction.MiscDocAction
UPDATE_CURRENCY_ERROR - Static variable in class bb.common.BIZReason
UPDATE_ECN - Static variable in class bb.common.Constant.SystemUserGroup
UPDATE_NCR - Static variable in class bb.common.Constant.SystemUserGroup
UPDATE_ONDEMAND_ERROR - Static variable in class bb.common.BIZReason
UPDATE_PO - Static variable in class bb.common.Constant.SystemUserGroup
UPDATE_SO - Static variable in class bb.common.Constant.SystemUserGroup
updateAccountChartBalanceSheetAdvanceCategory(AccountsChartAdvanceCategoryVO) - Method in interface bb.common.box.AccountingBox
updateAccountChartProfitLossAdvanceCategory(AccountsChartAdvanceCategoryVO) - Method in interface bb.common.box.AccountingBox
updateAccountChartTaxPayableAdvanceCategory(AccountsChartAdvanceCategoryVO) - Method in interface bb.common.box.AccountingBox
updateAccountingConfiguration(AccountingConfigurationVO) - Method in interface bb.common.box.CompanyBox
updateAccountNumber(String, String) - Method in interface bb.common.box.CompanyBox
updateAccountPayableCheck(AccountPayableCheckVO) - Method in interface bb.common.box.AccountingBox
updateAccountReceivablePayment(AccountReceivablePaymentVO) - Method in interface bb.common.box.AccountingBox
updateAccountsChart(AccountsChartVO) - Method in interface bb.common.box.AccountingBox
updateAccountsChartCategoryForBalanceSheet(AccountsChartCategoryVO) - Method in interface bb.common.box.AccountingBox
updateAccountsChartCategoryForEbitda(AccountsChartCategoryVO) - Method in interface bb.common.box.AccountingBox
updateAccountsChartCategoryForProfitLoss(AccountsChartCategoryVO) - Method in interface bb.common.box.AccountingBox
updateAccountsChartCategoryForTaxDetail(AccountsChartCategoryVO) - Method in interface bb.common.box.AccountingBox
updateAccountsChartMapping(AccountsChartMappingVO) - Method in interface bb.common.box.AccountingBox
updateAccoutingSettings(AccountingSettingsVO) - Method in interface bb.common.box.CompanyBox
updateAddressQualityDocuments(AddressQualityDocumentsVO) - Method in interface bb.common.box.QualityBox
updateAddressQualityDocumentsInfo(AddressQualityDocumentsVO) - Method in interface bb.common.box.QualityBox
updateAddressQualityInfo(CustomerVendorAddressVO) - Method in interface bb.common.box.AddressBox
updateAP(AccountsPayableVO) - Method in interface bb.common.box.AccountingBox
updateApCheckRun(AccountPayableCheckRunVO) - Method in interface bb.common.box.AccountingBox
updateAppData(String, HashMap) - Method in interface bb.common.box.CompanyBox
updateAppData(Collection<Object[]>) - Method in interface bb.common.box.CompanyBox
updateApPrepay(ApPrepayVO) - Method in interface bb.common.box.AccountingBox
updateAR(AccountsReceivableVO) - Method in interface bb.common.box.AccountingBox
updateArBP(ARBoilerplateVO) - Method in interface bb.common.box.AccountingBox
updateArPrepay(ArPrepayVO) - Method in interface bb.common.box.AccountingBox
updateAsset(AssetVO) - Method in interface bb.common.box.AccountingBox
updateAssetDepreciate(ArrayList<AssetDepreciateVO>, String) - Method in interface bb.common.box.AccountingBox
updateAssetType(AssetTypeVO) - Method in interface bb.common.box.AccountingBox
updateAssetUsage(AssetUsageVO) - Method in interface bb.common.box.AccountingBox
updateBill(BillVO) - Method in interface bb.common.box.EngineeringBox
updateBillItem(BillItemVO) - Method in interface bb.common.box.EngineeringBox
updateBomApproval(BomApprovalVO) - Method in interface bb.common.box.EngineeringBox
updateBuyerCode(BuyerCodeVO) - Method in interface bb.common.box.CompanyBox
updateBySql(String) - Method in interface bb.common.box.CompanyBox
updateCar(CorrectiveActionRequestVO) - Method in interface bb.common.box.QualityBox
updateCarrier(CarrierVO) - Method in interface bb.common.box.AddressBox
updateCarrier(Vector, String) - Method in interface bb.common.box.AddressBox
updateCashFlowFromFiscalYearBudget(String) - Method in interface bb.common.box.AccountingBox
updateCashier(CashierVO) - Method in interface bb.common.box.CompanyBox
updateCatalog(CatalogVO) - Method in interface bb.common.box.SalesBox
updateCertificateDescription(CertificateDescriptionVO) - Method in interface bb.common.box.QualityBox
updateChangeStdCostWorkSheet(ChangeStdCostWorkSheetVO) - Method in interface bb.common.box.AccountingBox
updateChangeStdCostWorkSheetItem(ChangeStdCostWorkSheetItemVO) - Method in interface bb.common.box.AccountingBox
updateCommonPrintTemplate(CommonPrintTemplateVO) - Method in interface bb.common.box.CompanyBox
updateCompanyHome(byte[]) - Method in interface bb.common.box.CompanyBox
updateCompanyId(String) - Method in interface bb.common.box.CompanyBox
updateCompanySettings(CompanyVO) - Method in interface bb.common.box.CompanyBox
updateCompanyUnit(CompanyUnitVO) - Method in interface bb.common.box.CompanyBox
updateCompanyUnitAccount(CompanyUnitAccountVO) - Method in interface bb.common.box.CompanyBox
updateContractPrice(ContractPriceVO) - Method in interface bb.common.box.SalesBox
updateContractPriceCustomer(ContractPriceCustomerVO) - Method in interface bb.common.box.SalesBox
updateContractPriceItem(ContractPriceItemVO) - Method in interface bb.common.box.SalesBox
updateCreditMemo(AccountsReceivableVO) - Method in interface bb.common.box.AccountingBox
updateCurrency(String, String) - Method in interface bb.common.box.CompanyBox
updateCurrencyById(String, String, boolean) - Method in interface bb.common.box.CompanyBox
updateCurrencyBySql(String, String) - Method in interface bb.common.box.CompanyBox
updateCustomAsset(CustomAssetVO) - Method in interface bb.common.box.HumanResourceBox
updateCustomAssetRecord(CustomAssetRecordVO) - Method in interface bb.common.box.HumanResourceBox
updateCustomCheckUpEmployee(CustomCheckUpEmployeeVO) - Method in interface bb.common.box.HumanResourceBox
updateCustomColumn(AppColumnVO) - Method in interface bb.common.box.CompanyBox
updateCustomDepartment(CustomDepartmentVO) - Method in interface bb.common.box.HumanResourceBox
updateCustomEmployee(CustomEmployeeVO) - Method in interface bb.common.box.HumanResourceBox
updateCustomEmployeeTrain(CustomEmployeeTrainVO) - Method in interface bb.common.box.HumanResourceBox
updateCustomEmployeeWorkExperience(CustomEmployeeWorkExperienceVO) - Method in interface bb.common.box.HumanResourceBox
updateCustomer(CustomerVendorAddressVO) - Method in interface bb.common.box.AddressBox
updateCustomerDeletedFlag(String, boolean) - Method in interface bb.common.box.AddressBox
updateCustomerFeedback(CustomerFeedbackVO) - Method in interface bb.common.box.CustomerServiceBox
updateCustomerFeedbackItem(FeedbackItemVO) - Method in interface bb.common.box.CustomerServiceBox
updateCustomerFeedbackItem(ArrayList, String) - Method in interface bb.common.box.CustomerServiceBox
updateCustomerHold(String, boolean) - Method in interface bb.common.box.AddressBox
updateCustomerToAllType(CustomerVendorAddressVO) - Method in interface bb.common.box.AddressBox
updateCustomerVendorAddress(CustomerVendorAddressVO) - Method in interface bb.common.box.AddressBox
updateCustomerVendorDeletedFlag(String, boolean) - Method in interface bb.common.box.AddressBox
updateCustomerVendorType(HashSet, String) - Method in interface bb.common.box.AddressBox
updateCustomerVendorType(CustomerVendorTypeVO) - Method in interface bb.common.box.AddressBox
updateCustomGoodsBreed(CustomGoodsBreedVO) - Method in interface bb.common.box.HumanResourceBox
updateCustomGoodsRecord(CustomGoodsRecordVO) - Method in interface bb.common.box.HumanResourceBox
updateCustomJobCategory(CustomJobCategoryVO) - Method in interface bb.common.box.HumanResourceBox
updateCustomSearch(CustomSearchVO) - Method in interface bb.common.box.CompanyBox
updateCustomTranslation(Set<CustomTranslationVO>) - Method in interface bb.common.box.CompanyBox
updateCycleCount(ArrayList<CycleCountAgent>) - Method in interface bb.common.box.WarehouseBox
updateCycleCountStatus(CycleCountStatusVO) - Method in interface bb.common.box.WarehouseBox
updateDataFilter(DataFilterVO) - Method in interface bb.common.box.CompanyBox
updateDC(DesignControlVO) - Method in interface bb.common.box.EngineeringBox
updateDCDoc(MiscDocAgent) - Method in interface bb.common.box.EngineeringBox
updateDebitMemo(AccountsPayableVO) - Method in interface bb.common.box.AccountingBox
updateDefaultStatus(WorkInstructionVO) - Method in interface bb.common.box.ManufacturingBox
updateDeletedFlag(PartPK, boolean) - Method in interface bb.common.box.EngineeringBox
updateDepartment(CustomerVendorAddressVO) - Method in interface bb.common.box.AddressBox
updateDepartmentDeletedFlag(String, boolean) - Method in interface bb.common.box.AddressBox
updateDepartmentLocationForBackflush(DepartmentLocationForBackflushVO) - Method in interface bb.common.box.WarehouseBox
updateDisassembleWorkOrder(DisassembleWorkOrderVO) - Method in interface bb.common.box.WorkOrderBox
updateDisassembleWorkOrderApproval(DisassembleWorkOrderApprovalVO) - Method in interface bb.common.box.WorkOrderBox
updateDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemReceiverVO) - Method in interface bb.common.box.WorkOrderBox
updateDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemPK, LinkedHashMap<BB2Part, BigDecimal>) - Method in interface bb.common.box.WorkOrderBox
updateDocumentServerSettings(DocumentServerVO) - Method in interface bb.common.box.CompanyBox
updateDwfUploadSettings(DwfUploadSettingsVO) - Method in interface bb.common.box.CompanyBox
updateDwgUploadSettings(DwgUploadSettingsVO) - Method in interface bb.common.box.CompanyBox
updateECNControl(ECNReviewVO) - Method in interface bb.common.box.EngineeringBox
updateECRControl(ECRReviewVO) - Method in interface bb.common.box.EngineeringBox
updateECRequest(EngineeringChangeRequestVO) - Method in interface bb.common.box.EngineeringBox
updateEjbMethod(EjbMethodVO) - Method in interface bb.common.box.SecurityBox
updateEmployeeCard(EmployeeCardVO) - Method in interface bb.common.box.HumanResourceBox
updateEmployeeEducation(EmployeeEducationVO) - Method in interface bb.common.box.HumanResourceBox
updateEmployeeHome(EmployeeHomeVO) - Method in interface bb.common.box.HumanResourceBox
updateEmployeeTraining(EmployeeTrainingVO) - Method in interface bb.common.box.HumanResourceBox
updateEmployeeWorkExperience(EmployeeWorkExperienceVO) - Method in interface bb.common.box.HumanResourceBox
updateEngGroup(EngGroupVO) - Method in interface bb.common.box.EngineeringBox
updateEngGroupUser(EngGroupUserVO) - Method in interface bb.common.box.EngineeringBox
updateEngineeringChange(EngineeringChangeVO) - Method in interface bb.common.box.EngineeringBox
updateEngineeringSharing(EngineeringSharingVO) - Method in interface bb.common.box.EngineeringBox
updateEngineeringSharingItem(EngineeringSharingItemVO) - Method in interface bb.common.box.EngineeringBox
updateEP(AccountsPayableVO) - Method in interface bb.common.box.AccountingBox
updateEquipment(EquipmentVO) - Method in interface bb.common.box.ManufacturingBox
updateExchangeByfiscalYear(CurrencyAgent) - Method in interface bb.common.box.CompanyBox
updateExpense(ExpenseVO) - Method in interface bb.common.box.AccountingBox
updateExpenseAccount(ExpenseAccountVO) - Method in interface bb.common.box.AccountingBox
updateFeedbackQuestion(FeedbackQuestionVO) - Method in interface bb.common.box.CustomerServiceBox
updateFiscalYearSettings(FiscalYearSettingsVO) - Method in interface bb.common.box.AccountingBox
updateGeneralLedger(GeneralLedgerVO) - Method in interface bb.common.box.AccountingBox
updateGeneralLedgerApproval(GeneralLedgerApprovalVO) - Method in interface bb.common.box.AccountingBox
updateGLAutoApprove(GLAutoApproveVO) - Method in interface bb.common.box.AccountingBox
updateGlCashFlowBudget(String, ArrayList) - Method in interface bb.common.box.AccountingBox
updateGLCategory(GeneralLedgerCategoryVO) - Method in interface bb.common.box.AccountingBox
updateGlfiscalYearBudget(String, ArrayList) - Method in interface bb.common.box.AccountingBox
updateGroupUser(GroupUserVO) - Method in interface bb.common.box.CompanyBox
updateHelpServer(HelpServerVO) - Method in interface bb.common.box.CompanyBox
updateICR(InspectionConformanceReportVO) - Method in interface bb.common.box.QualityBox
updateICRItem(InspectionConformanceReportItemVO) - Method in interface bb.common.box.QualityBox
updateInactiveTool(PartPK, boolean) - Method in interface bb.common.box.ManufacturingBox
updateIncident(CustomerServiceIncidentVO) - Method in interface bb.common.box.CustomerServiceBox
updateIncoterm(IncotermVO) - Method in interface bb.common.box.SalesBox
updateInitStep(String) - Method in interface bb.common.box.CompanyBox
updateInspectionItem(InspectionItemVO) - Method in interface bb.common.box.ManufacturingBox
updateInspectionReport(InspectionReportVO) - Method in interface bb.common.box.ManufacturingBox
updateInspectionReportInspectMethod(InspectionReportInspectMethodVO) - Method in interface bb.common.box.ManufacturingBox
updateInspectionType(InspectionTypeVO) - Method in interface bb.common.box.QualityBox
updateLabelTemplate(LabelTemplateVO) - Method in interface bb.common.box.WarehouseBox
updateLicense(byte[]) - Method in interface bb.common.box.CompanyBox
updateLogInventory(LogInventoryVO) - Method in interface bb.common.box.WarehouseBox
updateMaintenanceItem(MaintenanceItemVO) - Method in interface bb.common.box.ManufacturingBox
updateManufacturerAddress(ManufacturerAddressVO) - Method in interface bb.common.box.AddressBox
updateManufacturerAddressDeletedFlag(String, boolean) - Method in interface bb.common.box.AddressBox
updateManufacturerECRequest(EngineeringChangeRequestVO) - Method in interface bb.common.box.ManufacturingBox
updateManufacturerEngineeringChange(EngineeringChangeVO) - Method in interface bb.common.box.ManufacturingBox
updateMiscDocSetting(MiscDocumentSettingVO) - Method in interface bb.common.box.CompanyBox
updateMyPassword(String) - Method in interface bb.common.box.SecurityBox
updateNCC(NonConformanceCodeVO) - Method in interface bb.common.box.QualityBox
updateNCR(NonConformanceReportVO, HashSet<PuttoInQAAgent>, HashSet<PullFromWorkOrderPartDetailAgent>, HashSet<RebackInQAAgent>) - Method in interface bb.common.box.QualityBox
updateNcrApproval(NcrApprovalVO) - Method in interface bb.common.box.QualityBox
updateNCRPicture(NCRPictureVO) - Method in interface bb.common.box.QualityBox
updateNonproductivePicking(NonproductivePickingVO) - Method in interface bb.common.box.WarehouseBox
updateNonproductivePickingAprroval(NonproductivePickingApprovalVO) - Method in interface bb.common.box.WarehouseBox
updateNonproductivePickingType(NonproductivePickingTypeVO) - Method in interface bb.common.box.WarehouseBox
updateOIPrincipal(OIPrincipalVO) - Method in interface bb.common.box.ManufacturingBox
updateOnLoan(OnLoanVO) - Method in interface bb.common.box.WarehouseBox
updateOnloanControl(OnloanReviewVO) - Method in interface bb.common.box.WarehouseBox
updateOnloanReceiver(OnloanReceiverVO) - Method in interface bb.common.box.WarehouseBox
updateOnloanShipper(OnloanShipperVO) - Method in interface bb.common.box.WarehouseBox
updateOpCodeShortcut(ArrayList<OpCodeShortcutVO>, String) - Method in interface bb.common.box.CompanyBox
updateOperatingInstructions(OperatingInstructionsVO) - Method in interface bb.common.box.ManufacturingBox
updateOperatingInstructionsInspectStandard(OperatingInstructionsInspectStandardVO) - Method in interface bb.common.box.ManufacturingBox
updateOperatingInstructionsManual(OperatingInstructionsManualVO) - Method in interface bb.common.box.ManufacturingBox
updateOperatingInstructionsType(OperatingInstructionsTypeVO) - Method in interface bb.common.box.ManufacturingBox
updateOperatingOutputFileType(OperatingOutputFileTypeVO) - Method in interface bb.common.box.ManufacturingBox
updatePackingBox(PackingBoxVO) - Method in interface bb.common.box.WarehouseBox
updatePackingBoxItem(PackingBoxItemPK, Map) - Method in interface bb.common.box.WarehouseBox
updatePackingBoxItems(HashMap, PackingBoxPK) - Method in interface bb.common.box.WarehouseBox
updatePAR(PreventiveActionRequestVO) - Method in interface bb.common.box.QualityBox
updatePart(PartVO) - Method in interface bb.common.box.EngineeringBox
updatePartCatagory(PartCatagoryVO) - Method in interface bb.common.box.EngineeringBox
updatePartCatalog(PartCatalogVO) - Method in interface bb.common.box.SalesBox
updatePartCatalog(ArrayList<PartCatalogVO>) - Method in interface bb.common.box.SalesBox
updatePartClass(PartClassVO, boolean) - Method in interface bb.common.box.WarehouseBox
updatePartDiscount(PartDiscountVO) - Method in interface bb.common.box.SalesBox
updatePartEngGroupAndLevel(PartPK, String, String) - Method in interface bb.common.box.EngineeringBox
updatePartInspection(PartInspectionResult) - Method in interface bb.common.box.QualityBox
updatePartInventory(PartInventoryVO) - Method in interface bb.common.box.EngineeringBox
updatePartManufacturer(HashSet, PartPK) - Method in interface bb.common.box.EngineeringBox
updatePartMaterial(PartMaterialVO) - Method in interface bb.common.box.EngineeringBox
updatePartNumberGenerateRule(String) - Method in interface bb.common.box.CompanyBox
updatePartOnhand(PartOnhandVO) - Method in interface bb.common.box.WarehouseBox
updatePartPartClass(HashSet<PartPK>, String) - Method in interface bb.common.box.WarehouseBox
updatePartSecurityLevel(PartSecurityLevelVO) - Method in interface bb.common.box.EngineeringBox
updatePartTraceableInfoResult(PartTraceableInfoResult) - Method in interface bb.common.box.EngineeringBox
updatePartType(PartTypeVO) - Method in interface bb.common.box.CompanyBox
updatePartType(PartPK, PartPK) - Method in interface bb.common.box.EngineeringBox
updatePartUseType(PartUseTypeVO) - Method in interface bb.common.box.WorkOrderBox
updatePartVendor(HashSet, PartPK) - Method in interface bb.common.box.EngineeringBox
updatePartVendor(PartVendorVO) - Method in interface bb.common.box.EngineeringBox
updatePartWithInspectionType(HashSet<BB2Part>, String) - Method in interface bb.common.box.QualityBox
updatePartWithOnhands(PartWithOnhandsVO) - Method in interface bb.common.box.EngineeringBox
updatePasswordPolicy(PasswordPolicyAgent) - Method in interface bb.common.box.CompanyBox
updatePayment(PayableMethodVO) - Method in interface bb.common.box.CompanyBox
updatePaymentRun(ARPaymentRunVO) - Method in interface bb.common.box.AccountingBox
updatePermission(PermissionVO) - Method in interface bb.common.box.SecurityBox
updatePermissionMethod(PermissionMethodVO) - Method in interface bb.common.box.SecurityBox
updatePfReceiver(PfReceiverVO) - Method in interface bb.common.box.PurchasingBox
updatePhysicalInventory(ArrayList) - Method in interface bb.common.box.WarehouseBox
UpdatePhysicalInventoryAgent - Class in bb.common
UpdatePhysicalInventoryAgent() - Constructor for class bb.common.UpdatePhysicalInventoryAgent
updatePhysicalInventoryStatus(PhysicalInventoryStatusVO) - Method in interface bb.common.box.WarehouseBox
updatePointOfSale(PointOfSaleVO) - Method in interface bb.common.box.CompanyBox
updatePoMessageByVendor(PoMessageVO) - Method in interface bb.common.box.PurchasingBox
updatePOSurveyReport(POSurveyReportVO) - Method in interface bb.common.box.QualityBox
updatePosZipCodeTaxs(Collection<PosZipCodeTaxVO>) - Method in interface bb.common.box.CompanyBox
updatePrintLogo(PrintLogoVO) - Method in interface bb.common.box.CompanyBox
updatePrintTemplate(PrintTemplateVO) - Method in interface bb.common.box.CompanyBox
updateProformaInvoice(ProformaInvoiceVO) - Method in interface bb.common.box.WarehouseBox
updateProject(ProjectVO) - Method in interface bb.common.box.SalesBox
updatePurchaseOrder(PurchaseOrderVO) - Method in interface bb.common.box.ManufacturingBox
updatePurchaseOrder(PurchaseOrderVO) - Method in interface bb.common.box.PurchasingBox
updatePurchaseOrderApproval(PurchaseOrderApprovalVO) - Method in interface bb.common.box.ManufacturingBox
updatePurchaseOrderApproval(PurchaseOrderApprovalVO) - Method in interface bb.common.box.PurchasingBox
updatePurchaseOrderBP(PurchaseOrderBoilerplateVO) - Method in interface bb.common.box.PurchasingBox
updatePurchaseOrderItem(PurchaseOrderItemVO) - Method in interface bb.common.box.ManufacturingBox
updatePurchaseOrderItem(PurchaseOrderItemVO) - Method in interface bb.common.box.PurchasingBox
updatePurchaseWorkSheet(PurchaseWorkSheetVO) - Method in interface bb.common.box.ManufacturingBox
updatePurchaseWorkSheet(PurchaseWorkSheetVO) - Method in interface bb.common.box.PurchasingBox
updatePurchaseWorkSheetItem(PurchaseWorkSheetItemVO) - Method in interface bb.common.box.PurchasingBox
updateQualityGroup(QualityGroupVO) - Method in interface bb.common.box.QualityBox
updateQuote(QuoteVO) - Method in interface bb.common.box.SalesBox
updateQuoteBP(QuoteBoilerplateVO) - Method in interface bb.common.box.SalesBox
updateReceiver(ReceiverVO) - Method in interface bb.common.box.WarehouseBox
updateRefdocOne(RefdocVO) - Method in interface bb.common.box.SalesBox
updateRefdocOne(RefdocVO) - Method in interface bb.common.box.WorkOrderBox
updateRefdocTwo(RefdocVO) - Method in interface bb.common.box.AccountingBox
updateRefdocTwo(RefdocVO) - Method in interface bb.common.box.PurchasingBox
updateRefdocTwo(RefdocVO) - Method in interface bb.common.box.WarehouseBox
updateRefdocTwo(RefdocVO) - Method in interface bb.common.box.WorkOrderBox
updateRequestForQuote(RequestForQuoteVO) - Method in interface bb.common.box.ManufacturingBox
updateRequestForQuote(RequestForQuoteVO) - Method in interface bb.common.box.PurchasingBox
updateReturnToVendor(ReturnToVendorVO) - Method in interface bb.common.box.ManufacturingBox
updateReturnToVendor(ReturnToVendorVO) - Method in interface bb.common.box.PurchasingBox
updateRFC(WorkInstructionRequestForChangeVO) - Method in interface bb.common.box.ManufacturingBox
updateRfqMessage(RfqMessageVO) - Method in interface bb.common.box.PurchasingBox
updateRma(ReturnMaterialAuthorizationVO) - Method in interface bb.common.box.SalesBox
updateRMAReceiver(RMAReceiverVO) - Method in interface bb.common.box.WarehouseBox
updateRMAReview(RMAReviewVO) - Method in interface bb.common.box.SalesBox
updateRole(RoleVO) - Method in interface bb.common.box.SecurityBox
updateRollUpBomStdCostWorkSheet(RollUpBomStdCostWorkSheetVO) - Method in interface bb.common.box.AccountingBox
updateRTVApproval(RTVApprovalVO) - Method in interface bb.common.box.PurchasingBox
updateRtvShipper(RtvShipperVO) - Method in interface bb.common.box.WarehouseBox
updateSaleableFlag(PartPK, boolean, boolean) - Method in interface bb.common.box.EngineeringBox
updateSalesCode(SalesCodeVO) - Method in interface bb.common.box.SalesBox
updateSalesman(SalesmanVO) - Method in interface bb.common.box.SalesBox
updateSalesOrder(SalesOrderVO) - Method in interface bb.common.box.SalesBox
updateSalesOrderBP(SalesOrderBoilerplateVO) - Method in interface bb.common.box.SalesBox
updateSalesOrderControl(SalesOrderReviewVO) - Method in interface bb.common.box.SalesBox
updateSerialNumber(SerialNumberVO) - Method in interface bb.common.box.QualityBox
updateSgClientProgramUser(SgClientProgramUserVO) - Method in interface bb.common.box.AddressBox
updateSGCustomerCatalog(SGCustomerCatalogVO) - Method in interface bb.common.box.SalesBox
updateSGCustomerCatalog(ArrayList<SGCustomerCatalogVO>) - Method in interface bb.common.box.SalesBox
updateSGCustomerServiceRequest(SGCustomerServiceRequestVO) - Method in interface bb.common.box.SalesBox
updateSGSaleItem(SGSaleItemVO) - Method in interface bb.common.box.SalesBox
updateShipList(ShipListVO) - Method in interface bb.common.box.PlanningBox
updateShipListItem(ShipListItemVO) - Method in interface bb.common.box.PlanningBox
updateShipListOwner(ShipListOwnerVO) - Method in interface bb.common.box.PlanningBox
updateShipper(ShipperVO) - Method in interface bb.common.box.WarehouseBox
updateSignature(List<CheckInvoiceItemListResult>, byte[]) - Method in interface bb.common.box.CompanyBox
updateSmtpServer(SmtpServerVO) - Method in interface bb.common.box.CompanyBox
updateSubcompany(SubcompanyVO) - Method in interface bb.common.box.CompanyBox
updateSwapOrder(SwapOrderVO) - Method in interface bb.common.box.PurchasingBox
updateSwapOrderApproval(SwapOrderApprovalVO) - Method in interface bb.common.box.PurchasingBox
updateSwapReceiver(SwapReceiverVO) - Method in interface bb.common.box.WarehouseBox
updateSwapShipper(SwapShipperVO) - Method in interface bb.common.box.WarehouseBox
updateTask(TaskVO) - Method in interface bb.common.box.CompanyBox
updateTaxAccount(TaxAccountVO) - Method in interface bb.common.box.CompanyBox
updateTempAddress(ImportDataVO) - Method in interface bb.common.box.CompanyBox
updateTempBOM(ImportDataVO) - Method in interface bb.common.box.CompanyBox
updateTempEmployee(ImportDataVO) - Method in interface bb.common.box.CompanyBox
updateTempInventory(ImportDataVO) - Method in interface bb.common.box.CompanyBox
updateTempManufacture(ImportDataVO) - Method in interface bb.common.box.CompanyBox
updateTempMaterial(ImportDataVO) - Method in interface bb.common.box.CompanyBox
updateTempMPN(ImportDataVO) - Method in interface bb.common.box.CompanyBox
updateTempNccode(ImportDataVO) - Method in interface bb.common.box.CompanyBox
updateTemporaryEmployee(EmployeeCardVO) - Method in interface bb.common.box.HumanResourceBox
updateTempPart(ImportDataVO) - Method in interface bb.common.box.CompanyBox
updateTempTool(ImportDataVO) - Method in interface bb.common.box.CompanyBox
updateTempToolInventory(ImportDataVO) - Method in interface bb.common.box.CompanyBox
updateTerm(TermVO) - Method in interface bb.common.box.CompanyBox
updateTermsCondition(TermsConditionVO) - Method in interface bb.common.box.CompanyBox
updateTimeCard(WorkOrderTimeCardVO) - Method in interface bb.common.box.ManufacturingBox
updateTimeCard(ArrayList) - Method in interface bb.common.box.ManufacturingBox
updateTool(ToolVO) - Method in interface bb.common.box.ManufacturingBox
updateToolCalibration(ArrayList, PartPK) - Method in interface bb.common.box.ManufacturingBox
updateToolList(ToolListVO) - Method in interface bb.common.box.ManufacturingBox
updateToolListItem(ToolListItemVO) - Method in interface bb.common.box.ManufacturingBox
updateToolManufacturer(Set, PartPK) - Method in interface bb.common.box.ManufacturingBox
updateToolOnhandDetail(HashSet, PartPK) - Method in interface bb.common.box.WarehouseBox
updateToolVendor(Set, PartPK) - Method in interface bb.common.box.ManufacturingBox
updateToolWithOnhands(ToolWithOnhandsVO) - Method in interface bb.common.box.ManufacturingBox
updateTraceableCategories(String, TraceableCategoriesVO) - Method in interface bb.common.box.EngineeringBox
updateTraceableSpecs(Short, TraceableSpecsVO) - Method in interface bb.common.box.EngineeringBox
updateTransactionLockDate(Date) - Method in interface bb.common.box.AccountingBox
updateTransactionType(AccountingTransactionTypeVO) - Method in interface bb.common.box.AccountingBox
updateTransferOrder(TransferOrderVO) - Method in interface bb.common.box.WarehouseBox
updateTransferOrderApproval(TransferOrderApprovalVO) - Method in interface bb.common.box.WarehouseBox
updateTransferReceiver(TransferReceiverVO) - Method in interface bb.common.box.WarehouseBox
updateTransferShipper(TransferShipperVO) - Method in interface bb.common.box.WarehouseBox
updateUnit(UnitVO) - Method in interface bb.common.box.EngineeringBox
updateUser(BizboxUserVO, String[]) - Method in interface bb.common.box.SecurityBox
updateUserGroup(UserGroupVO) - Method in interface bb.common.box.CompanyBox
updateUserPassword(String, String) - Method in interface bb.common.box.SecurityBox
updateUserRefId(String, String) - Method in interface bb.common.box.SecurityBox
updateVendor(CustomerVendorAddressVO) - Method in interface bb.common.box.AddressBox
updateVendorCategories(VendorCategoriesVO) - Method in interface bb.common.box.AddressBox
updateVendorContractPrice(VendorContractPriceVO) - Method in interface bb.common.box.PurchasingBox
updateVendorContractPriceItem(VendorContractPriceItemVO) - Method in interface bb.common.box.PurchasingBox
updateVendorContractPriceVendor(VendorContractPriceVendorVO) - Method in interface bb.common.box.PurchasingBox
updateVendorCriticalLevel(VendorCriticalLevelVO) - Method in interface bb.common.box.AddressBox
updateVendorDeletedFlag(String, boolean) - Method in interface bb.common.box.AddressBox
updateVendorGroupUser(VendorGroupUserVO) - Method in interface bb.common.box.AddressBox
updateVendorPart(VendorPartVO) - Method in interface bb.common.box.WarehouseBox
updateVendorQtyPrice(VendorQtyPriceVO) - Method in interface bb.common.box.EngineeringBox
updateVendorQualityInfo(CustomerVendorAddressVO) - Method in interface bb.common.box.AddressBox
updateVendorToAllType(CustomerVendorAddressVO) - Method in interface bb.common.box.AddressBox
updateWarehouse(WarehouseVO) - Method in interface bb.common.box.WarehouseBox
updateWeightUnit(WeightUnitVO) - Method in interface bb.common.box.CompanyBox
updateWOReceiver(WorkOrderReceiverVO) - Method in interface bb.common.box.WarehouseBox
updateWorkCalendar(WorkCalendarVO) - Method in interface bb.common.box.ManufacturingBox
updateWorkCenter(WorkCenterVO) - Method in interface bb.common.box.ManufacturingBox
updateWorkFlow(WorkFlowVO) - Method in interface bb.common.box.CompanyBox
updateWorkInstruction(WorkInstructionVO) - Method in interface bb.common.box.ManufacturingBox
updateWorkInstructionApproval(WorkInstructionApprovalVO) - Method in interface bb.common.box.ManufacturingBox
updateWorkOrder(WorkOrderVO) - Method in interface bb.common.box.WorkOrderBox
updateWorkOrderApproval(WorkOrderApprovalVO) - Method in interface bb.common.box.WorkOrderBox
updateWorkOrderBP(WorkOrderBoilerplateVO) - Method in interface bb.common.box.WorkOrderBox
updateWorkOrderItemIssue(WorkOrderItemIssueVO) - Method in interface bb.common.box.WorkOrderBox
updateWorkOrderItemIssue(WorkOrderItemPK, LinkedHashMap<BB2Part, BigDecimal>, LinkedHashMap<BB2Part, String>) - Method in interface bb.common.box.WorkOrderBox
updateWorkOrderItemTimeDetail(WorkOrderItemTimeDetailVO) - Method in interface bb.common.box.WorkOrderBox
updateWorkOrderWorkInstruction(WorkOrderWorkInstructionVO) - Method in interface bb.common.box.WorkOrderBox
updateWorkOrderWorkInstructionSequence(WorkOrderWorkInstructionSequenceVO) - Method in interface bb.common.box.WorkOrderBox
updateWorkOrderWorkSheet(WorkOrderWorkSheetVO) - Method in interface bb.common.box.WorkOrderBox
updateWorkOrderWorkSheetItem(WorkOrderWorkSheetItemVO) - Method in interface bb.common.box.WorkOrderBox
updateZipCode(ZipCodeVO) - Method in interface bb.common.box.CompanyBox
updateZipCodeTax(ZipCodeTaxVO) - Method in interface bb.common.box.CompanyBox
UPLOAD - Static variable in class bb.common.BB2Event
upLoad() - Method in interface bb.common.box.DocumentBox
UPLOAD - Static variable in class bb.common.DocumentAction.DwfAndDwgDocAction
UPLOAD - Static variable in class bb.common.DocumentAction.MiscDocAction
UPLOAD - Static variable in class bb.common.DocumentAction.PartDocAction
uploadDCDoc(MiscDocAgent) - Method in interface bb.common.box.EngineeringBox
upLoadDWG(String, String) - Method in interface bb.common.box.EngineeringBox
uploadFtpDWF(PartDwfAgent) - Method in interface bb.common.box.EngineeringBox
uploadOrUpdateAccInfoDocument(MiscDocAgent) - Method in interface bb.common.box.AccountingBox
uploadOrUpdateAddressQualityDocuments(MiscDocAgent) - Method in interface bb.common.box.QualityBox
uploadOrUpdateEmployeeRecord(MiscDocAgent) - Method in interface bb.common.box.HumanResourceBox
uploadOrUpdateFTPDWODoc(MiscDocAgent) - Method in interface bb.common.box.WorkOrderBox
uploadOrUpdateFTPECDoc(MiscDocAgent) - Method in interface bb.common.box.EngineeringBox
uploadOrUpdateFTPECRDoc(MiscDocAgent) - Method in interface bb.common.box.EngineeringBox
uploadOrUpdateFTPOrderDoc(MiscDocAgent) - Method in interface bb.common.box.CompanyBox
uploadOrUpdateFTPRMADoc(MiscDocAgent) - Method in interface bb.common.box.SalesBox
uploadOrUpdateFTPSODoc(MiscDocAgent) - Method in interface bb.common.box.SalesBox
uploadOrUpdateFTPWODoc(MiscDocAgent) - Method in interface bb.common.box.WorkOrderBox
uploadOrUpdateIncidentItemDoc(CustomerServiceIncidentItemVO, MiscDocAgent) - Method in interface bb.common.box.CustomerServiceBox
uploadOrUpdateNCRPicture(MiscDocAgent) - Method in interface bb.common.box.QualityBox
uploadOrUpdateOnloanDoc(MiscDocAgent) - Method in interface bb.common.box.ManufacturingBox
uploadOrUpdatePARDoc(MiscDocAgent) - Method in interface bb.common.box.QualityBox
uploadOrUpdatePODoc(MiscDocAgent) - Method in interface bb.common.box.PurchasingBox
uploadOrUpdateQuoteDocument(MiscDocAgent) - Method in interface bb.common.box.SalesBox
uploadPartCertificate(MiscDocAgent) - Method in interface bb.common.box.QualityBox
uploadPartPicture(MiscDocAgent) - Method in interface bb.common.box.EngineeringBox
uploadWorkInstructionDocument(MiscDocAgent) - Method in interface bb.common.box.ManufacturingBox
uploadWorkInstructionPicture(MiscDocAgent) - Method in interface bb.common.box.ManufacturingBox
upperCaseFirstLetter(String) - Static method in class bb.common.BB2Util
USA - Static variable in class bb.common.Constant.LocalSettings
USE_TYPE_IS_EXIST - Static variable in class bb.common.BIZReason
User2UserAgent - Class in bb.common
User2UserAgent() - Constructor for class bb.common.User2UserAgent
USER_GROUP - Static variable in class bb.common.BizTarget
USER_GROUP_EXIST - Static variable in class bb.common.BIZReason
USER_GROUP_NOT_EXIST - Static variable in class bb.common.BIZReason
USER_HAS_NO_PERMISSION_TO_UPDATE_ENG_GROUP_PART - Static variable in class bb.common.BIZReason
USER_LOCKED - Static variable in class bb.common.BIZReason
USER_NOT_EXIST - Static variable in class bb.common.BIZReason
USER_TRUE_NAME - Static variable in class bb.common.BizTarget
USER_ZIPCODE_TAX - Static variable in class bb.common.BizTarget
UserGroupVO - Class in bb.common
UserGroupVO() - Constructor for class bb.common.UserGroupVO
UserRolePermissionListResult - Class in bb.common
UserRolePermissionListResult() - Constructor for class bb.common.UserRolePermissionListResult
UserRolePK - Class in bb.common
UserRolePK(String, String) - Constructor for class bb.common.UserRolePK
full constructor
UserRolePK() - Constructor for class bb.common.UserRolePK
default constructor
UserRoleVO - Class in bb.common
UserRoleVO(UserRolePK) - Constructor for class bb.common.UserRoleVO
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M N O P Q R S T U V W X Y Z


UnitVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class UnitVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.UnitVO
All Implemented Interfaces:
java.io.Serializable
public class UnitVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ID
static java.lang.String | ORDER_BY_UNITNAME
Constructor Summary
UnitVO()
UnitVO(long id, java.lang.String unitName)
Method Summary
boolean | equals(java.lang.Object other)
long | getId()
java.lang.String | getUnitName()
int | hashCode()
void | setId(long id)
void | setUnitName(java.lang.String unitName)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ID

public static final java.lang.String ORDER_BY_ID
See Also:
Constant Field Values

ORDER_BY_UNITNAME

public static final java.lang.String ORDER_BY_UNITNAME
See Also:
Constant Field Values
Constructor Detail

UnitVO

public UnitVO()

UnitVO

public UnitVO(long id,
              java.lang.String unitName)
Method Detail

getId

public long getId()

setId

public void setId(long id)

getUnitName

public java.lang.String getUnitName()

setUnitName

public void setUnitName(java.lang.String unitName)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UpdatePhysicalInventoryAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class UpdatePhysicalInventoryAgent

java.lang.Object
    extended by  bb.common.UpdatePhysicalInventoryAgent
All Implemented Interfaces:
java.io.Serializable
public class UpdatePhysicalInventoryAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
UpdatePhysicalInventoryAgent()
Method Summary
boolean | equals(java.lang.Object other)
java.util.HashMap | getCustomProperties()
java.lang.String | getLocation()
PartPK | getPartPk()
java.math.BigDecimal | getPhysicalCount()
PhysicalInventoryPK | getPk()
java.lang.String | getTagNumber()
int | hashCode()
void | setCustomProperties(java.util.HashMap customProperties)
void | setLocation(java.lang.String location)
void | setPartPk(PartPK partPk)
void | setPhysicalCount(java.math.BigDecimal physicalCount)
void | setPk(PhysicalInventoryPK pk)
void | setTagNumber(java.lang.String tagNumber)
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

UpdatePhysicalInventoryAgent

public UpdatePhysicalInventoryAgent()
Method Detail

setPk

public void setPk(PhysicalInventoryPK pk)

setPhysicalCount

public void setPhysicalCount(java.math.BigDecimal physicalCount)

getPk

public PhysicalInventoryPK getPk()

getPhysicalCount

public java.math.BigDecimal getPhysicalCount()

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getTagNumber

public java.lang.String getTagNumber()

setTagNumber

public void setTagNumber(java.lang.String tagNumber)

getPartPk

public PartPK getPartPk()

setPartPk

public void setPartPk(PartPK partPk)

getCustomProperties

public java.util.HashMap getCustomProperties()

setCustomProperties

public void setCustomProperties(java.util.HashMap customProperties)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


User2UserAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class User2UserAgent

java.lang.Object
    extended by  bb.common.User2UserAgent
All Implemented Interfaces:
java.io.Serializable
public class User2UserAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
User2UserAgent()
Method Summary
java.lang.String | getComments()
java.lang.String | getOriginalUserName()
java.lang.String | getPassword()
java.lang.String | getRefId()
int | getType()
java.lang.String | getUserName()
void | setComments(java.lang.String comments)
void | setOriginalUserName(java.lang.String originalUserName)
void | setPassword(java.lang.String password)
void | setRefId(java.lang.String refId)
void | setType(int type)
void | setUserName(java.lang.String userName)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

User2UserAgent

public User2UserAgent()
Method Detail

getOriginalUserName

public java.lang.String getOriginalUserName()

setOriginalUserName

public void setOriginalUserName(java.lang.String originalUserName)

getPassword

public java.lang.String getPassword()

setPassword

public void setPassword(java.lang.String password)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getRefId

public java.lang.String getRefId()

setRefId

public void setRefId(java.lang.String refId)

getType

public int getType()

setType

public void setType(int type)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UserGroupVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class UserGroupVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.UserGroupVO
All Implemented Interfaces:
java.io.Serializable
public class UserGroupVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
UserGroupVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDescription()
java.lang.String | getId()
java.lang.String | getOwner()
int | hashCode()
boolean | isGlobal()
void | setDescription(java.lang.String description)
void | setGlobal(boolean global)
void | setId(java.lang.String id)
void | setOwner(java.lang.String owner)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

UserGroupVO

public UserGroupVO()
Method Detail

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getOwner

public java.lang.String getOwner()

setOwner

public void setOwner(java.lang.String owner)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

isGlobal

public boolean isGlobal()

setGlobal

public void setGlobal(boolean global)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UserRolePermissionListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class UserRolePermissionListResult

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.UserRolePermissionListResult
All Implemented Interfaces:
java.io.Serializable
public class UserRolePermissionListResult
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_PERMISSIONID
static java.lang.String | ORDER_BY_PERMISSIONNAME
static java.lang.String | ORDER_BY_REFID
static java.lang.String | ORDER_BY_ROLEID
static java.lang.String | ORDER_BY_ROLENAME
static java.lang.String | ORDER_BY_USERNAME
Constructor Summary
UserRolePermissionListResult()
Method Summary
java.lang.String | getPermissionId()
java.lang.String | getPermissionName()
java.lang.String | getRefId()
java.lang.String | getRoleId()
java.lang.String | getRoleName()
java.lang.String | getSystemName()
java.lang.String | getUserName()
void | setPermissionId(java.lang.String permissionId)
void | setPermissionName(java.lang.String permissionName)
void | setRefId(java.lang.String refId)
void | setRoleId(java.lang.String roleId)
void | setRoleName(java.lang.String roleName)
void | setSystemName(java.lang.String systemName)
void | setUserName(java.lang.String userName)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_USERNAME

public static final java.lang.String ORDER_BY_USERNAME
See Also:
Constant Field Values

ORDER_BY_ROLENAME

public static final java.lang.String ORDER_BY_ROLENAME
See Also:
Constant Field Values

ORDER_BY_ROLEID

public static final java.lang.String ORDER_BY_ROLEID
See Also:
Constant Field Values

ORDER_BY_PERMISSIONID

public static final java.lang.String ORDER_BY_PERMISSIONID
See Also:
Constant Field Values

ORDER_BY_PERMISSIONNAME

public static final java.lang.String ORDER_BY_PERMISSIONNAME
See Also:
Constant Field Values

ORDER_BY_REFID

public static final java.lang.String ORDER_BY_REFID
See Also:
Constant Field Values
Constructor Detail

UserRolePermissionListResult

public UserRolePermissionListResult()
Method Detail

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getPermissionId

public java.lang.String getPermissionId()

setPermissionId

public void setPermissionId(java.lang.String permissionId)

getPermissionName

public java.lang.String getPermissionName()

setPermissionName

public void setPermissionName(java.lang.String permissionName)

getRoleId

public java.lang.String getRoleId()

setRoleId

public void setRoleId(java.lang.String roleId)

getRoleName

public java.lang.String getRoleName()

setRoleName

public void setRoleName(java.lang.String roleName)

getRefId

public java.lang.String getRefId()

setRefId

public void setRefId(java.lang.String refId)

getSystemName

public java.lang.String getSystemName()

setSystemName

public void setSystemName(java.lang.String systemName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UserRolePK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class UserRolePK

java.lang.Object
    extended by  bb.common.UserRolePK
All Implemented Interfaces:
java.io.Serializable
public class UserRolePK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
UserRolePK()
default constructor
UserRolePK(java.lang.String userName, java.lang.String roleId)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getRoleId()
java.lang.String | getUserName()
int | hashCode()
void | setRoleId(java.lang.String roleId)
void | setUserName(java.lang.String userName)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

UserRolePK

public UserRolePK(java.lang.String userName,
                  java.lang.String roleId)
full constructor

UserRolePK

public UserRolePK()
default constructor

Method Detail

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getRoleId

public java.lang.String getRoleId()

setRoleId

public void setRoleId(java.lang.String roleId)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UserRoleVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class UserRoleVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.UserRoleVO
All Implemented Interfaces:
java.io.Serializable
public class UserRoleVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
UserRoleVO(UserRolePK pk)
Method Summary
boolean | equals(java.lang.Object other)
UserRolePK | getPk()
int | hashCode()
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

UserRoleVO

public UserRoleVO(UserRolePK pk)
Method Detail

getPk

public UserRolePK getPk()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class bb.common.AccountAgingTotalResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountAgingTotalResult

Packages that use AccountAgingTotalResult
bb.common.box

Uses of AccountAgingTotalResult in bb.common.box

Methods in bb.common.box that return types with arguments of type AccountAgingTotalResult
java.util.Collection<AccountAgingTotalResult> | AccountingBox.findAccountAgingTotalResult(java.lang.String[] includeIds, java.lang.String[] excludeIds, boolean useAsOf, java.util.Date asOf)
java.util.Collection<AccountAgingTotalResult> | AccountingBox.findAPAgingTotalResult(java.lang.String[] includeIds, java.lang.String[] excludeIds, boolean useAsOf, java.util.Date asOf)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountAuditAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountAuditAgent

Packages that use AccountAuditAgent
bb.common.box

Uses of AccountAuditAgent in bb.common.box

Methods in bb.common.box with parameters of type AccountAuditAgent
java.util.Collection<java.lang.String> | AccountingBox.getAPNumbers(AccountAuditAgent agent)
java.util.Collection<java.lang.String> | AccountingBox.getARNumbers(AccountAuditAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountBalanceAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountBalanceAgent

Packages that use AccountBalanceAgent
bb.common.box

Uses of AccountBalanceAgent in bb.common.box

Methods in bb.common.box with parameters of type AccountBalanceAgent
 java.lang.String AccountingBox.addAccountBalanceGL(AccountBalanceAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountBalanceListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountBalanceListResult

Packages that use AccountBalanceListResult
bb.common.box

Uses of AccountBalanceListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type AccountBalanceListResult
 java.util.Collection<AccountBalanceListResult> AccountingBox.findAccountBalanceById(java.lang.String companyUnitId, java.lang.String accountNumber, java.lang.String language, java.util.Date fromDate, java.util.Date toDate, java.lang.String addressIdLike, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountBalanceResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountBalanceResult

Packages that use AccountBalanceResult
bb.common.box

Uses of AccountBalanceResult in bb.common.box

Methods in bb.common.box that return types with arguments of type AccountBalanceResult
 java.util.Collection<AccountBalanceResult> AccountingBox.getAccountBalance(java.lang.String fMonthYear, java.lang.String tMonthYear, java.lang.String companyUnitId, boolean usePost)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountCreditDebitPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountCreditDebitPK

Packages that use AccountCreditDebitPK
bb.common

Uses of AccountCreditDebitPK in bb.common

Methods in bb.common that return AccountCreditDebitPK
AccountCreditDebitPK | GLItemVO.getPk()
AccountCreditDebitPK | AccountDebitVO.getPk()
AccountCreditDebitPK | AccountCreditVO.getPk()

Methods in bb.common with parameters of type AccountCreditDebitPK
void | GLItemVO.setPk(AccountCreditDebitPK pk)
void | AccountDebitVO.setPk(AccountCreditDebitPK pk)
void | AccountCreditVO.setPk(AccountCreditDebitPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountCreditVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountCreditVO

Packages that use AccountCreditVO
bb.common

Uses of AccountCreditVO in bb.common

Methods in bb.common that return types with arguments of type AccountCreditVO
 java.util.Map<AssetDepreciatePK,AccountCreditVO> ExchangeAuditResult.getMap()

Method parameters in bb.common with type arguments of type AccountCreditVO
 void ExchangeAuditResult.setMap(java.util.Map<AssetDepreciatePK,AccountCreditVO> map)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountDebitVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountDebitVO

No usage of bb.common.AccountDebitVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountInfoCenterItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountInfoCenterItemResult

No usage of bb.common.AccountInfoCenterItemResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountInfoCenterResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountInfoCenterResult

Packages that use AccountInfoCenterResult
bb.common.box

Uses of AccountInfoCenterResult in bb.common.box

Methods in bb.common.box that return AccountInfoCenterResult
AccountInfoCenterResult | ManagementBox.getAccountInfoCenterResult()
AccountInfoCenterResult | ManagementBox.getAccountInfoDashBoardResult()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountingBalanceSheetResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountingBalanceSheetResult

Packages that use AccountingBalanceSheetResult
bb.common.box

Uses of AccountingBalanceSheetResult in bb.common.box

Methods in bb.common.box that return AccountingBalanceSheetResult
 AccountingBalanceSheetResult AccountingBox.findBalanceSheet(java.lang.String monthYear)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountingConfigurationVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountingConfigurationVO

Packages that use AccountingConfigurationVO
bb.common.box

Uses of AccountingConfigurationVO in bb.common.box

Methods in bb.common.box that return AccountingConfigurationVO
AccountingConfigurationVO | CompanyBox.getAccountingConfiguration()
AccountingConfigurationVO | CompanyBox.updateAccountingConfiguration(AccountingConfigurationVO vo)

Methods in bb.common.box with parameters of type AccountingConfigurationVO
 AccountingConfigurationVO CompanyBox.updateAccountingConfiguration(AccountingConfigurationVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountingInfoDocumentVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountingInfoDocumentVO

Packages that use AccountingInfoDocumentVO
bb.common.box

Uses of AccountingInfoDocumentVO in bb.common.box

Methods in bb.common.box that return AccountingInfoDocumentVO
 AccountingInfoDocumentVO AccountingBox.getAccInfoDocumentByID(java.lang.String yearCode, java.lang.String companyUnitId, java.lang.String accountingReportType)

Methods in bb.common.box that return types with arguments of type AccountingInfoDocumentVO
java.util.List<AccountingInfoDocumentVO> | AccountingBox.findAccountingInfoDocument(java.lang.String yearCode, java.lang.String companyUnitId, java.lang.String accountingReportType, int firstIndex, int maxLength)
java.util.List<AccountingInfoDocumentVO> | AccountingBox.uploadOrUpdateAccInfoDocument(MiscDocAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountingSettingsVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountingSettingsVO

Packages that use AccountingSettingsVO
bb.common.box

Uses of AccountingSettingsVO in bb.common.box

Methods in bb.common.box that return AccountingSettingsVO
AccountingSettingsVO | CompanyBox.getAccountingSettings()
AccountingSettingsVO | CompanyBox.updateAccoutingSettings(AccountingSettingsVO vo)

Methods in bb.common.box with parameters of type AccountingSettingsVO
 AccountingSettingsVO CompanyBox.updateAccoutingSettings(AccountingSettingsVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountingTotalMoneyResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountingTotalMoneyResult

Packages that use AccountingTotalMoneyResult
bb.common.box

Uses of AccountingTotalMoneyResult in bb.common.box

Methods in bb.common.box that return AccountingTotalMoneyResult
AccountingTotalMoneyResult | CompanyBox.findRaoTotal(java.lang.String raoNumber, java.lang.String[] includeVendorId, java.lang.String[] excludeVendorId, java.lang.String payableMethod, java.util.Date fromDate, java.util.Date toDate, java.lang.String orderType, boolean isMakeOrder, java.lang.String partNumber, java.lang.String partType, boolean showNegative)
AccountingTotalMoneyResult | CompanyBox.findReceiptOrderTotal(java.lang.String raoNumber, java.lang.String[] includeVendorId, java.lang.String[] excludeVendorId, java.lang.String payableMethod, java.util.Date fromDate, java.util.Date toDate, java.lang.String orderType, boolean isMakeOrder)

Methods in bb.common.box that return types with arguments of type AccountingTotalMoneyResult
java.util.Collection<AccountingTotalMoneyResult> | AccountingBox.findAPsTotalMoneyByVendorId(java.lang.String vendorId)
java.util.Collection<AccountingTotalMoneyResult> | AccountingBox.findAPTotalMoneyByDate(java.lang.String apNumber, java.lang.String partNumberLike, java.lang.String partType, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String vendorId, java.lang.String vendorInvoice, java.lang.String status, java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String productCode)
java.util.Collection<AccountingTotalMoneyResult> | AccountingBox.findARsTotalMoneyByCustomerId(java.lang.String customerId)
java.util.Collection<AccountingTotalMoneyResult> | AccountingBox.findARTotalMoneyByDate(java.lang.String arNumber, java.lang.String pnLike, boolean partNumberlike, java.lang.String pa, java.lang.String productCode, java.lang.String customerId, boolean customerLike, java.lang.String invoiceBy, java.lang.String status, java.lang.String dateType, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isCludeCmNumber, java.util.Date fromDate, java.util.Date toDate, java.math.BigDecimal lessThanMargin, java.math.BigDecimal highThanMargin, boolean billAndHold, java.util.Map moreParameters)
java.util.Collection<AccountingTotalMoneyResult> | AccountingBox.findDMTotalMoneyByDate(java.lang.String apNumber, java.lang.String partNumberLike, java.lang.String partType, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String vendorId, java.lang.String vendorInvoice, java.lang.String status, java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate)
java.util.Collection<AccountingTotalMoneyResult> | AccountingBox.findEPTotalMoneyByDate(java.lang.String apNumber, java.lang.String partNumberLike, java.lang.String partType, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String vendorId, java.lang.String vendorInvoice, java.lang.String status, java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String productCode, java.lang.String receiverNumber)
java.util.Collection<AccountingTotalMoneyResult> | AccountingBox.findSalesTaxTotalMoneyByDate(java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String reportType, boolean isCM)
java.util.Collection<AccountingTotalMoneyResult> | AccountingBox.getOpenARsTotalMoneyByVendor(java.lang.String vendorId, boolean includeCM)
java.util.Collection<AccountingTotalMoneyResult> | AccountingBox.getPastDueARsTotalMoney()
java.util.Collection<AccountingTotalMoneyResult> | AccountingBox.getPastDueARsTotalMoneyByVendor(java.lang.String vendorId, boolean includeCM)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountingTransactionTypeVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountingTransactionTypeVO

Packages that use AccountingTransactionTypeVO
bb.common
bb.common.box

Uses of AccountingTransactionTypeVO in bb.common

Methods in bb.common that return AccountingTransactionTypeVO
 AccountingTransactionTypeVO GeneralLedgerVO.getTransactionTypeDescription()

Methods in bb.common with parameters of type AccountingTransactionTypeVO
 void GeneralLedgerVO.setTransactionTypeDescription(AccountingTransactionTypeVO transactionTypeDescription)

Uses of AccountingTransactionTypeVO in bb.common.box

Methods in bb.common.box that return AccountingTransactionTypeVO
AccountingTransactionTypeVO | AccountingBox.addTransactionType(AccountingTransactionTypeVO vo)
AccountingTransactionTypeVO | AccountingBox.findAccountingTransactionTypeByPk(java.lang.String transactionType)

Methods in bb.common.box that return types with arguments of type AccountingTransactionTypeVO
java.util.Collection<AccountingTransactionTypeVO> | AccountingBox.findAccountingTransactionTypes()
java.util.Collection<AccountingTransactionTypeVO> | AccountingBox.findAccountingTransactionTypesByType(java.lang.String transactionType, int firstIndex, int maxLength)
java.util.Collection<AccountingTransactionTypeVO> | AccountingBox.findAllAccountingTransactionTypes(boolean showJType, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type AccountingTransactionTypeVO
AccountingTransactionTypeVO | AccountingBox.addTransactionType(AccountingTransactionTypeVO vo)
void | AccountingBox.deleteTransactionType(AccountingTransactionTypeVO vo)
void | AccountingBox.updateTransactionType(AccountingTransactionTypeVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountMonthPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountMonthPK

Packages that use AccountMonthPK
bb.common
bb.common.box

Uses of AccountMonthPK in bb.common

Methods in bb.common that return AccountMonthPK
AccountMonthPK | GlFiscalYearBudgetVO.getPk()
AccountMonthPK | GlCashFlowBudgetVO.getPk()
AccountMonthPK | BankReconciliationReportVO.getPk()

Methods in bb.common with parameters of type AccountMonthPK
void | GlFiscalYearBudgetVO.setPk(AccountMonthPK pk)
void | GlCashFlowBudgetVO.setPk(AccountMonthPK pk)
void | BankReconciliationReportVO.setPk(AccountMonthPK pk)

Uses of AccountMonthPK in bb.common.box

Methods in bb.common.box with parameters of type AccountMonthPK
void | AccountingBox.clearGeneralLedgers(AccountMonthPK pk, java.util.Map<java.lang.String,java.lang.Boolean> glNumbers)
boolean | AccountingBox.isBankReconciliationReportExistent(AccountMonthPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountPayableCheckRunItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountPayableCheckRunItemVO

Packages that use AccountPayableCheckRunItemVO
bb.common.box

Uses of AccountPayableCheckRunItemVO in bb.common.box

Methods in bb.common.box that return types with arguments of type AccountPayableCheckRunItemVO
java.util.Collection<AccountPayableCheckRunItemVO> | AccountingBox.findAPCheckRunItemByCheckRunNumber(java.lang.String checkRunNumber)
java.util.Collection<AccountPayableCheckRunItemVO> | AccountingBox.findCheckRunItemByCheckNo(java.lang.String checkRunNo, java.lang.String checkNo, java.lang.String vendorId)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountPayableCheckRunVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountPayableCheckRunVO

Packages that use AccountPayableCheckRunVO
bb.common.box

Uses of AccountPayableCheckRunVO in bb.common.box

Methods in bb.common.box that return AccountPayableCheckRunVO
 AccountPayableCheckRunVO AccountingBox.getAccountPayableCheckRunByPk(java.lang.String checkRunNumber)

Methods in bb.common.box that return types with arguments of type AccountPayableCheckRunVO
java.util.Collection<AccountPayableCheckRunVO> | AccountingBox.findAllAccountPayableCheckRuns(int firstIndex, int maxLength)
java.util.Collection<AccountPayableCheckRunVO> | AccountingBox.findAPCheckRunsByCheckRunNumberLike(java.lang.String checkRunNumberLike, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type AccountPayableCheckRunVO
 java.lang.String AccountingBox.updateApCheckRun(AccountPayableCheckRunVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountPayableCheckVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountPayableCheckVO

Packages that use AccountPayableCheckVO
bb.common.box

Uses of AccountPayableCheckVO in bb.common.box

Methods in bb.common.box that return AccountPayableCheckVO
AccountPayableCheckVO | AccountingBox.addSingleCheck(MakeCheckAgent agent)
AccountPayableCheckVO | AccountingBox.addSinglePrepaymentCheck(MakePrepaymentCheckAgent agent)
AccountPayableCheckVO | AccountingBox.getAccountPayableCheckByCheckNo(java.lang.String checkNumber)

Methods in bb.common.box that return types with arguments of type AccountPayableCheckVO
java.util.Collection<AccountPayableCheckVO> | AccountingBox.findAccountPayableChecksByCheckNumber(java.lang.String checkNumber, int firstIndex, int maxLength)
java.util.Collection<AccountPayableCheckVO> | AccountingBox.findAccountPayableChecksByCheckRunNumber(java.lang.String checkRunNumber, int firstIndex, int maxLength)
java.util.Collection<AccountPayableCheckVO> | AccountingBox.findAllAccountPayableChecks(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type AccountPayableCheckVO
void | AccountingBox.deleteAccountPayableCheck(AccountPayableCheckVO vo)
void | AccountingBox.updateAccountPayableCheck(AccountPayableCheckVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountPayableInfoWithPrepayResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountPayableInfoWithPrepayResult

Packages that use AccountPayableInfoWithPrepayResult
bb.common.box

Uses of AccountPayableInfoWithPrepayResult in bb.common.box

Methods in bb.common.box that return types with arguments of type AccountPayableInfoWithPrepayResult
 java.util.Collection<AccountPayableInfoWithPrepayResult> AccountingBox.findAPToBatchPaymentbyAddressIdSet(java.lang.String[] includeVendorId, java.lang.String[] excludeVendorId, java.lang.String companyUnitId, java.lang.String currency, java.util.Date fromDate, java.util.Date toDate)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountReceivableInfoWithPrepayResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountReceivableInfoWithPrepayResult

Packages that use AccountReceivableInfoWithPrepayResult
bb.common.box

Uses of AccountReceivableInfoWithPrepayResult in bb.common.box

Methods in bb.common.box that return types with arguments of type AccountReceivableInfoWithPrepayResult
java.util.Collection<AccountReceivableInfoWithPrepayResult> | AccountingBox.findARToBatchReceivebyAddressId(java.lang.String customerId, java.lang.String companyUnitId, java.lang.String currency, java.util.Date fromDate, java.util.Date toDate)
java.util.Collection<AccountReceivableInfoWithPrepayResult> | AccountingBox.findARToBatchReceivebyAddressIdSet(java.lang.String[] includeCustomerId, java.lang.String[] excludeCustomerId, java.lang.String companyUnitId, java.lang.String currency, java.util.Date fromDate, java.util.Date toDate)

Method parameters in bb.common.box with type arguments of type AccountReceivableInfoWithPrepayResult
java.lang.String | AccountingBox.arPaymentRunByCustomer(java.util.List<AccountReceivableInfoWithPrepayResult> list, java.lang.Object[] info)
void | AccountingBox.batchApplyPrepay(java.util.List<AccountReceivableInfoWithPrepayResult> list)
void | AccountingBox.offsetARWithCM(java.util.List<AccountReceivableInfoWithPrepayResult> cmList, java.util.List<AccountReceivableInfoWithPrepayResult> arList, java.lang.Object[] info)
void | AccountingBox.offsetARWithCM(java.util.List<AccountReceivableInfoWithPrepayResult> cmList, java.util.List<AccountReceivableInfoWithPrepayResult> arList, java.lang.Object[] info)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountReceivablePaymentVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountReceivablePaymentVO

Packages that use AccountReceivablePaymentVO
bb.common.box

Uses of AccountReceivablePaymentVO in bb.common.box

Methods in bb.common.box that return AccountReceivablePaymentVO
AccountReceivablePaymentVO | AccountingBox.addAccountReceivablePayment(AccountReceivablePaymentVO vo)
AccountReceivablePaymentVO | AccountingBox.getARPaymentByPk(java.lang.Long ii)

Methods in bb.common.box that return types with arguments of type AccountReceivablePaymentVO
java.util.Collection<AccountReceivablePaymentVO> | AccountingBox.findAllAccountReceivablePayments(int firstIndex, int maxLength)
java.util.Collection<AccountReceivablePaymentVO> | AccountingBox.findARPaymentsByPaymentNumberLike(java.lang.String paymentNumberLike, int firstIndex, int maxLength)
java.util.Collection<AccountReceivablePaymentVO> | AccountingBox.findARPaymentsByPaymentRunNumber(java.lang.String paymentRunNumber, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type AccountReceivablePaymentVO
AccountReceivablePaymentVO | AccountingBox.addAccountReceivablePayment(AccountReceivablePaymentVO vo)
void | AccountingBox.deleteAccountReceivablePayment(AccountReceivablePaymentVO vo)
void | AccountingBox.updateAccountReceivablePayment(AccountReceivablePaymentVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountsChartAdvanceCategoryVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountsChartAdvanceCategoryVO

Packages that use AccountsChartAdvanceCategoryVO
bb.common.box

Uses of AccountsChartAdvanceCategoryVO in bb.common.box

Methods in bb.common.box that return AccountsChartAdvanceCategoryVO
AccountsChartAdvanceCategoryVO | AccountingBox.getAccountChartBalanceSheetAdvanceCategoryByPk()
AccountsChartAdvanceCategoryVO | AccountingBox.getAccountChartBalanceSheetAdvanceCategoryReportByPk(java.lang.String monthYear)
AccountsChartAdvanceCategoryVO | AccountingBox.getAccountChartProfitLossAdvanceCategoryByPk()
AccountsChartAdvanceCategoryVO | AccountingBox.getAccountChartProfitLossAdvanceCategoryReportByPk(java.lang.String monthYear)
AccountsChartAdvanceCategoryVO | AccountingBox.getAccountChartTaxPayableAdvanceCategoryByPk()
AccountsChartAdvanceCategoryVO | AccountingBox.getAccountChartTaxPayableAdvanceCategoryReportByPk(java.lang.String monthYear)

Methods in bb.common.box with parameters of type AccountsChartAdvanceCategoryVO
void | AccountingBox.addAccountChartBalanceSheetAdvanceCategory(AccountsChartAdvanceCategoryVO vo)
void | AccountingBox.addAccountChartProfitLossAdvanceCategory(AccountsChartAdvanceCategoryVO vo)
void | AccountingBox.addAccountChartTaxPayableAdvanceCategory(AccountsChartAdvanceCategoryVO vo)
void | AccountingBox.updateAccountChartBalanceSheetAdvanceCategory(AccountsChartAdvanceCategoryVO vo)
void | AccountingBox.updateAccountChartProfitLossAdvanceCategory(AccountsChartAdvanceCategoryVO vo)
void | AccountingBox.updateAccountChartTaxPayableAdvanceCategory(AccountsChartAdvanceCategoryVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountsChartCategoryListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountsChartCategoryListResult

Packages that use AccountsChartCategoryListResult
bb.common.box

Uses of AccountsChartCategoryListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type AccountsChartCategoryListResult
java.util.Collection<AccountsChartCategoryListResult> | AccountingBox.findBalanceSheetOfCategory(java.lang.String monthYear)
java.util.Collection<AccountsChartCategoryListResult> | AccountingBox.findProfitLossOfCategory(java.lang.String monthYear)
java.util.Collection<AccountsChartCategoryListResult> | AccountingBox.getAccountsChartCategoryReport(java.lang.String monthYear)
java.util.Collection<AccountsChartCategoryListResult> | AccountingBox.getTaxOfCategory(java.lang.String monthYear)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountsChartCategoryVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountsChartCategoryVO

Packages that use AccountsChartCategoryVO
bb.common
bb.common.box

Uses of AccountsChartCategoryVO in bb.common

Subclasses of AccountsChartCategoryVO in bb.common
 class AccountsChartCategoryListResult

Uses of AccountsChartCategoryVO in bb.common.box

Methods in bb.common.box that return AccountsChartCategoryVO
AccountsChartCategoryVO | AccountingBox.addAccountsChartCategoryForBalanceSheet(AccountsChartCategoryVO vo)
AccountsChartCategoryVO | AccountingBox.addAccountsChartCategoryForEbitda(AccountsChartCategoryVO vo)
AccountsChartCategoryVO | AccountingBox.addAccountsChartCategoryForProfitLoss(AccountsChartCategoryVO vo)
AccountsChartCategoryVO | AccountingBox.addAccountsChartCategoryForTaxDetail(AccountsChartCategoryVO vo)
AccountsChartCategoryVO | AccountingBox.getAccountsChartCategoryForBalanceSheetByPk(java.lang.Long pk)
AccountsChartCategoryVO | AccountingBox.getAccountsChartCategoryForEbitdaByPk(java.lang.Long pk)
AccountsChartCategoryVO | AccountingBox.getAccountsChartCategoryForProfitLossByPk(java.lang.Long pk)
AccountsChartCategoryVO | AccountingBox.getAccountsChartCategoryForTaxDetailByPk(java.lang.Long pk)

Methods in bb.common.box that return types with arguments of type AccountsChartCategoryVO
java.util.Collection<AccountsChartCategoryVO> | AccountingBox.findAccountsChartCategoryForBalanceSheetByCategoryName(java.lang.String categoryName, int firstIndex, int maxLength)
java.util.Collection<AccountsChartCategoryVO> | AccountingBox.findAccountsChartCategoryForBalanceSheetPredefineByCategoryName(java.lang.String categoryName, int firstIndex, int maxLength)
java.util.Collection<AccountsChartCategoryVO> | AccountingBox.findAccountsChartCategoryForProfitLossByCategoryName(java.lang.String categoryName, int firstIndex, int maxLength)
java.util.Collection<AccountsChartCategoryVO> | AccountingBox.findAccountsChartCategoryForProfitLossPredefineByCategoryName(java.lang.String categoryName, int firstIndex, int maxLength)
java.util.Collection<AccountsChartCategoryVO> | AccountingBox.findAccountsChartCategoryForTaxDetailByCategoryName(java.lang.String categoryName, int firstIndex, int maxLength)
java.util.Collection<AccountsChartCategoryVO> | AccountingBox.findAccountsChartCategoryForTaxDetailPredefineByCategoryName(java.lang.String categoryName, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type AccountsChartCategoryVO
AccountsChartCategoryVO | AccountingBox.addAccountsChartCategoryForBalanceSheet(AccountsChartCategoryVO vo)
AccountsChartCategoryVO | AccountingBox.addAccountsChartCategoryForEbitda(AccountsChartCategoryVO vo)
AccountsChartCategoryVO | AccountingBox.addAccountsChartCategoryForProfitLoss(AccountsChartCategoryVO vo)
AccountsChartCategoryVO | AccountingBox.addAccountsChartCategoryForTaxDetail(AccountsChartCategoryVO vo)
void | AccountingBox.updateAccountsChartCategoryForBalanceSheet(AccountsChartCategoryVO vo)
void | AccountingBox.updateAccountsChartCategoryForEbitda(AccountsChartCategoryVO vo)
void | AccountingBox.updateAccountsChartCategoryForProfitLoss(AccountsChartCategoryVO vo)
void | AccountingBox.updateAccountsChartCategoryForTaxDetail(AccountsChartCategoryVO vo)

Method parameters in bb.common.box with type arguments of type AccountsChartCategoryVO
void | AccountingBox.batchAddAccountsChartCategorysForBalanceSheet(java.util.List<AccountsChartCategoryVO> voList)
void | AccountingBox.batchAddAccountsChartCategorysForEbitda(java.util.List<AccountsChartCategoryVO> voList)
void | AccountingBox.batchAddAccountsChartCategorysForProfitLoss(java.util.List<AccountsChartCategoryVO> voList)
void | AccountingBox.batchAddAccountsChartCategorysForTaxDetail(java.util.List<AccountsChartCategoryVO> voList)
void | AccountingBox.batchUpdateAccountsChartCategorysForBalanceSheet(java.util.List<AccountsChartCategoryVO> list)
void | AccountingBox.batchUpdateAccountsChartCategorysForEbitda(java.util.List<AccountsChartCategoryVO> volist)
void | AccountingBox.batchUpdateAccountsChartCategorysForProfitLoss(java.util.List<AccountsChartCategoryVO> list)
void | AccountingBox.batchUpdateAccountsChartCategorysForTaxDetail(java.util.List<AccountsChartCategoryVO> volist)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountsChartMappingPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountsChartMappingPK

Packages that use AccountsChartMappingPK
bb.common
bb.common.box

Uses of AccountsChartMappingPK in bb.common

Methods in bb.common that return AccountsChartMappingPK
 AccountsChartMappingPK AccountsChartMappingVO.getPk()

Methods in bb.common with parameters of type AccountsChartMappingPK
 void AccountsChartMappingVO.setPk(AccountsChartMappingPK pk)

Uses of AccountsChartMappingPK in bb.common.box

Methods in bb.common.box with parameters of type AccountsChartMappingPK
 void AccountingBox.deleteAccountsChartMapping(AccountsChartMappingPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountsChartMappingVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountsChartMappingVO

Packages that use AccountsChartMappingVO
bb.common.box

Uses of AccountsChartMappingVO in bb.common.box

Methods in bb.common.box that return types with arguments of type AccountsChartMappingVO
 java.util.Collection<AccountsChartMappingVO> AccountingBox.findAccountsChartMappingBySubcompanyId(java.lang.String subcompanyId, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type AccountsChartMappingVO
void | AccountingBox.addAccountsChartMapping(AccountsChartMappingVO vo)
void | AccountingBox.updateAccountsChartMapping(AccountsChartMappingVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountsChartResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountsChartResult

Packages that use AccountsChartResult
bb.common.box

Uses of AccountsChartResult in bb.common.box

Methods in bb.common.box that return AccountsChartResult
 AccountsChartResult AccountingBox.findFiscalYearBudgetAndActualAmountByCharts(java.lang.String[] accountNumber, java.lang.String companyUnitId)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountsChartVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountsChartVO

Packages that use AccountsChartVO
bb.common
bb.common.box

Uses of AccountsChartVO in bb.common

Methods in bb.common that return AccountsChartVO
AccountsChartVO | GLItemVO.getAccountsChart()
AccountsChartVO | AccountDebitVO.getAccountsChart()
AccountsChartVO | AccountCreditVO.getAccountsChart()
AccountsChartVO | MonthBalanceResult.getAccountsChartVO()
AccountsChartVO | AccountsChartResult.getAccountsChartVO()
AccountsChartVO | CurrentBalanceResult.getAccountVo()

Methods in bb.common with parameters of type AccountsChartVO
void | GLItemVO.setAccountsChart(AccountsChartVO accountsChart)
void | AccountDebitVO.setAccountsChart(AccountsChartVO accountsChart)
void | AccountCreditVO.setAccountsChart(AccountsChartVO accountsChart)
void | MonthBalanceResult.setAccountsChartVO(AccountsChartVO accountsChartVO)
void | AccountsChartResult.setAccountsChartVO(AccountsChartVO accountsChartVO)
void | CurrentBalanceResult.setAccountVo(AccountsChartVO accountVo)

Uses of AccountsChartVO in bb.common.box

Methods in bb.common.box that return AccountsChartVO
 AccountsChartVO AccountingBox.getAccountsChartByPk(java.lang.String accountNumber)

Methods in bb.common.box that return types with arguments of type AccountsChartVO
java.util.Collection<AccountsChartVO> | AccountingBox.findAccountsChartsByCompanyUnit(java.lang.String accountNumber, java.lang.String language, java.lang.String accountType, java.lang.String companyUnitId, int firstIndex, int maxLength)
java.util.Collection<AccountsChartVO> | AccountingBox.findAccountsChartsById(java.lang.String accountNumber, int firstIndex, int maxLength)
java.util.Collection<AccountsChartVO> | AccountingBox.findAccountsChartsBySubType(java.lang.String accountNumber, java.lang.String language, java.lang.String companyUnitId, java.lang.String accountSubType, int firstIndex, int maxLength)
java.util.Collection<AccountsChartVO> | AccountingBox.findAccountsChartsByType(java.lang.String accountNumber, java.lang.String language, java.lang.String accountType, int firstIndex, int maxLength)
java.util.Collection<AccountsChartVO> | AccountingBox.findAccountsChartsByType(java.lang.String accountNumber, java.lang.String language, java.lang.String accountType, java.lang.String categoryReportType, int firstIndex, int maxLength)
java.util.Collection<AccountsChartVO> | AccountingBox.findAllAccountsCharts(boolean showInactive, int firstIndex, int maxLength)
java.util.Collection<AccountsChartVO> | AccountingBox.findArPaymentAccounts()
java.util.Collection<AccountsChartVO> | AccountingBox.getAllFirstLevelAccountCharts()

Methods in bb.common.box with parameters of type AccountsChartVO
java.lang.String | AccountingBox.addAccountsChart(AccountsChartVO vo)
java.lang.String | AccountingBox.updateAccountsChart(AccountsChartVO vo)

Method parameters in bb.common.box with type arguments of type AccountsChartVO
 void AccountingBox.addBatchAccountsChart(java.util.Collection<AccountsChartVO> chartVO)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountsCreditDebitListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountsCreditDebitListResult

Packages that use AccountsCreditDebitListResult
bb.common
bb.common.box

Uses of AccountsCreditDebitListResult in bb.common

Methods in bb.common that return types with arguments of type AccountsCreditDebitListResult
java.util.List<AccountsCreditDebitListResult> | DebitsCreditsResult.getCredits()
java.util.List<AccountsCreditDebitListResult> | DebitsCreditsResult.getDebits()

Method parameters in bb.common with type arguments of type AccountsCreditDebitListResult
void | DebitsCreditsResult.setCredits(java.util.List<AccountsCreditDebitListResult> credits)
void | DebitsCreditsResult.setDebits(java.util.List<AccountsCreditDebitListResult> debits)

Uses of AccountsCreditDebitListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type AccountsCreditDebitListResult
java.util.Collection<AccountsCreditDebitListResult> | AccountingBox.findCreditListByApNumber(java.lang.String apNumber, java.lang.String language, int firstIndex, int maxLength)
java.util.Collection<AccountsCreditDebitListResult> | AccountingBox.findCreditListByAppNumber(java.lang.String appNumber, int firstIndex, int maxLength)
java.util.Collection<AccountsCreditDebitListResult> | AccountingBox.findCreditListByArNumber(java.lang.String arNumber, java.lang.String language, int firstIndex, int maxLength)
java.util.Collection<AccountsCreditDebitListResult> | AccountingBox.findDebitListByApNumber(java.lang.String apNumber, java.lang.String language, int firstIndex, int maxLength)
java.util.Collection<AccountsCreditDebitListResult> | AccountingBox.findDebitListByAppNumber(java.lang.String appNumber, int firstIndex, int maxLength)
java.util.Collection<AccountsCreditDebitListResult> | AccountingBox.findDebitListByArNumber(java.lang.String arNumber, java.lang.String language, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountsPayableInfoVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountsPayableInfoVO

Packages that use AccountsPayableInfoVO
bb.common.box

Uses of AccountsPayableInfoVO in bb.common.box

Methods in bb.common.box that return types with arguments of type AccountsPayableInfoVO
java.util.Collection<AccountsPayableInfoVO> | AccountingBox.findAllAPs(int firstIndex, int maxLength)
java.util.Collection<AccountsPayableInfoVO> | AccountingBox.findAP(java.lang.String apNumber, java.lang.String vendorId, java.lang.String buyer, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)
java.util.Collection<AccountsPayableInfoVO> | AccountingBox.findAPs(java.lang.String apNumber, java.lang.String vendorId, java.lang.String buyer, java.lang.String status)
java.util.Collection<AccountsPayableInfoVO> | AccountingBox.findAPsByAddressIdAndStatus(java.lang.String addressId, java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<AccountsPayableInfoVO> | AccountingBox.findAPsByApNumber(java.lang.String apNumber, int firstIndex, int maxLength)
java.util.Collection<AccountsPayableInfoVO> | AccountingBox.findAPsByVendorId(java.lang.String vendorId, int firstIndex, int maxLength)
java.util.Collection<AccountsPayableInfoVO> | AccountingBox.findAPsByVendorInvoice(java.lang.String vendorInvoice, int firstIndex, int maxLength)
java.util.Collection<AccountsPayableInfoVO> | AccountingBox.findDM(java.lang.String apNumber, java.lang.String vendorId, java.lang.String buyer, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)
java.util.Collection<AccountsPayableInfoVO> | AccountingBox.findEP(java.lang.String apNumber, java.lang.String vendorId, java.lang.String buyer, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)
java.util.Collection<AccountsPayableInfoVO> | AccountingBox.findOpenAPs(int firstIndex, int maxLength)
java.util.Collection<AccountsPayableInfoVO> | AccountingBox.findOpenAPsByApNumber(java.lang.String apNumber, int firstIndex, int maxLength)
java.util.Collection<AccountsPayableInfoVO> | AccountingBox.findOpenAPsByVendorId(int firstIndex, int maxLength, java.lang.String vendorId)
java.util.Collection<AccountsPayableInfoVO> | AccountingBox.findPastDueAPs(int firstIndex, int maxLength)
java.util.Collection<AccountsPayableInfoVO> | AccountingBox.findPastdueAPsByVendorId(java.lang.String vendorId, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountsPayableItemManufacturerPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountsPayableItemManufacturerPK

Packages that use AccountsPayableItemManufacturerPK
bb.common

Uses of AccountsPayableItemManufacturerPK in bb.common

Methods in bb.common that return AccountsPayableItemManufacturerPK
 AccountsPayableItemManufacturerPK AccountsPayableItemManufacturerVO.getPk()

Methods in bb.common with parameters of type AccountsPayableItemManufacturerPK
 void AccountsPayableItemManufacturerVO.setPk(AccountsPayableItemManufacturerPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountsPayableItemManufacturerVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountsPayableItemManufacturerVO

No usage of bb.common.AccountsPayableItemManufacturerVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountsPayableItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountsPayableItemPK

Packages that use AccountsPayableItemPK
bb.common
bb.common.box

Uses of AccountsPayableItemPK in bb.common

Methods in bb.common that return AccountsPayableItemPK
 AccountsPayableItemPK AccountsPayableItemVO.getPk()

Methods in bb.common with parameters of type AccountsPayableItemPK
 void AccountsPayableItemVO.setPk(AccountsPayableItemPK pk)

Uses of AccountsPayableItemPK in bb.common.box

Methods in bb.common.box with parameters of type AccountsPayableItemPK
RefdocVO | AccountingBox.addRefdocTwo(AccountsPayableItemPK apItemPk, java.lang.String orderNumber, java.lang.String itemNumber)
AccountsPayableItemVO | AccountingBox.findAPItemsByPk(AccountsPayableItemPK pk)
java.math.BigDecimal | AccountingBox.getPoRecQty(AccountsPayableItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountsPayableItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountsPayableItemVO

Packages that use AccountsPayableItemVO
bb.common
bb.common.box

Uses of AccountsPayableItemVO in bb.common

Methods in bb.common that return types with arguments of type AccountsPayableItemVO
 java.util.Set<AccountsPayableItemVO> AccountsPayableVO.getAccountsPayableItems()

Method parameters in bb.common with type arguments of type AccountsPayableItemVO
 void AccountsPayableVO.setAccountsPayableItems(java.util.Set<AccountsPayableItemVO> accountsPayableItems)

Uses of AccountsPayableItemVO in bb.common.box

Methods in bb.common.box that return AccountsPayableItemVO
 AccountsPayableItemVO AccountingBox.findAPItemsByPk(AccountsPayableItemPK pk)

Methods in bb.common.box that return types with arguments of type AccountsPayableItemVO
 java.util.Collection<AccountsPayableItemVO> AccountingBox.findAPItemsByApNumber(java.lang.String apNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountsPayableVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountsPayableVO

Packages that use AccountsPayableVO
bb.common.box

Uses of AccountsPayableVO in bb.common.box

Methods in bb.common.box that return AccountsPayableVO
AccountsPayableVO | AccountingBox.findAPByPk(java.lang.String pk)
AccountsPayableVO | AccountingBox.findDMByPk(java.lang.String pk)
AccountsPayableVO | AccountingBox.findEPByPk(java.lang.String pk)
AccountsPayableVO | AccountingBox.voidAPPayment(java.lang.String apNumber, java.lang.String glNumber)
AccountsPayableVO | AccountingBox.voidAPPaymentWithMultiplePrepay(java.lang.String apNumber, java.lang.String glNumber)
AccountsPayableVO | AccountingBox.voidAPPaymentWithPrepay(java.lang.String apNumber, java.lang.String appNumber, java.lang.String glNumber)

Methods in bb.common.box with parameters of type AccountsPayableVO
void | AccountingBox.deleteAP(AccountsPayableVO vo)
java.lang.String | AccountingBox.updateAP(AccountsPayableVO vo)
java.lang.String | AccountingBox.updateDebitMemo(AccountsPayableVO vo)
java.lang.String | AccountingBox.updateEP(AccountsPayableVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountsReceivableInfoVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountsReceivableInfoVO

Packages that use AccountsReceivableInfoVO
bb.common.box

Uses of AccountsReceivableInfoVO in bb.common.box

Methods in bb.common.box that return types with arguments of type AccountsReceivableInfoVO
java.util.Collection<AccountsReceivableInfoVO> | AccountingBox.findAllARInvoicces(int firstIndex, int maxLength)
java.util.Collection<AccountsReceivableInfoVO> | AccountingBox.findAllARWithoutTracking(int firstIndex, int maxLength)
java.util.Collection<AccountsReceivableInfoVO> | AccountingBox.findARsByCustomerId(java.lang.String customerId, int firstIndex, int maxLength)
java.util.Collection<AccountsReceivableInfoVO> | AccountingBox.findARsByInvoiceNumber(java.lang.String invoiceNumber, java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<AccountsReceivableInfoVO> | AccountingBox.findCMByDate(java.lang.String[] cmNumbers, int firstIndex, int maxLength)
java.util.Collection<AccountsReceivableInfoVO> | AccountingBox.findCMByDate(java.lang.String invoiceId, java.lang.String customerId, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isInvoiceDate, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<AccountsReceivableInfoVO> | AccountingBox.findCMsByCMNumber(java.lang.String invoiceNumber, int firstIndex, int maxLength)
java.util.Collection<AccountsReceivableInfoVO> | AccountingBox.findCMsByCustomerId(java.lang.String customerId, int firstIndex, int maxLength)
java.util.Collection<AccountsReceivableInfoVO> | AccountingBox.findMyARPrintList()
java.util.Collection<AccountsReceivableInfoVO> | AccountingBox.findOpenARs(int firstIndex, int maxLength)
java.util.Collection<AccountsReceivableInfoVO> | AccountingBox.findOpenARsByVendorId(int firstIndex, int maxLength, java.lang.String vendorId, boolean includeCM)
java.util.Collection<AccountsReceivableInfoVO> | AccountingBox.findPastDueARs(int firstIndex, int maxLength)
java.util.Collection<AccountsReceivableInfoVO> | AccountingBox.findPastDueARsByVendor(java.lang.String vendorId, boolean includeCM, int firstIndex, int length)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountsReceivableItemManufacturerPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountsReceivableItemManufacturerPK

Packages that use AccountsReceivableItemManufacturerPK
bb.common

Uses of AccountsReceivableItemManufacturerPK in bb.common

Methods in bb.common that return AccountsReceivableItemManufacturerPK
 AccountsReceivableItemManufacturerPK AccountsReceivableItemManufacturerVO.getPk()

Methods in bb.common with parameters of type AccountsReceivableItemManufacturerPK
 void AccountsReceivableItemManufacturerVO.setPk(AccountsReceivableItemManufacturerPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountsReceivableItemManufacturerVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountsReceivableItemManufacturerVO

No usage of bb.common.AccountsReceivableItemManufacturerVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountsReceivableItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountsReceivableItemPK

Packages that use AccountsReceivableItemPK
bb.common
bb.common.box

Uses of AccountsReceivableItemPK in bb.common

Methods in bb.common that return AccountsReceivableItemPK
 AccountsReceivableItemPK AccountsReceivableItemVO.getPk()

Methods in bb.common with parameters of type AccountsReceivableItemPK
 void AccountsReceivableItemVO.setPk(AccountsReceivableItemPK pk)

Uses of AccountsReceivableItemPK in bb.common.box

Methods in bb.common.box with parameters of type AccountsReceivableItemPK
RefdocVO | AccountingBox.addRefdocTwo(AccountsReceivableItemPK arItemPk, java.lang.String orderNumber, java.lang.String itemNumber)
AccountsReceivableItemVO | AccountingBox.findARItemsByPk(AccountsReceivableItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountsReceivableItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountsReceivableItemResult

Packages that use AccountsReceivableItemResult
bb.common.box

Uses of AccountsReceivableItemResult in bb.common.box

Methods in bb.common.box that return types with arguments of type AccountsReceivableItemResult
 java.util.Collection<AccountsReceivableItemResult> AccountingBox.findARItemByPartAndDate(java.util.Date fromDate, java.util.Date toDate, BB2Part part, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountsReceivableItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountsReceivableItemVO

Packages that use AccountsReceivableItemVO
bb.common
bb.common.box

Uses of AccountsReceivableItemVO in bb.common

Subclasses of AccountsReceivableItemVO in bb.common
 class AccountsReceivableItemResult

Uses of AccountsReceivableItemVO in bb.common.box

Methods in bb.common.box that return AccountsReceivableItemVO
AccountsReceivableItemVO | AccountingBox.findARItemsByPk(AccountsReceivableItemPK pk)
AccountsReceivableItemVO | AccountingBox.initAccountsReceivableItemVO(AccountsReceivableVO vo, BB2Part part, java.math.BigDecimal qty)

Methods in bb.common.box that return types with arguments of type AccountsReceivableItemVO
java.util.Collection<AccountsReceivableItemVO> | AccountingBox.findARItemsByInvoiceNumber(java.lang.String invoiceNumber)
java.util.Collection<AccountsReceivableItemVO> | AccountingBox.findARItemsByPartNumber(java.lang.String partNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AccountsReceivableVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AccountsReceivableVO

Packages that use AccountsReceivableVO
bb.common
bb.common.box

Uses of AccountsReceivableVO in bb.common

Methods in bb.common that return types with arguments of type AccountsReceivableVO
 java.util.List<AccountsReceivableVO> CustomerStatementResult.getTransactionInvoices()

Method parameters in bb.common with type arguments of type AccountsReceivableVO
 void CustomerStatementResult.setTransactionInvoices(java.util.List<AccountsReceivableVO> transactionInvoices)

Uses of AccountsReceivableVO in bb.common.box

Methods in bb.common.box that return AccountsReceivableVO
AccountsReceivableVO | AccountingBox.addCreditMemo(java.lang.String invoiceNumber, java.lang.String summary)
AccountsReceivableVO | AccountingBox.findARByPk(java.lang.String pk)
AccountsReceivableVO | AccountingBox.getCMByPk(java.lang.String pk)
AccountsReceivableVO | AccountingBox.updateCreditMemo(AccountsReceivableVO vo)
AccountsReceivableVO | AccountingBox.voidARPayment(java.lang.String arNumber, java.lang.String glNumber)
AccountsReceivableVO | AccountingBox.voidARPaymentWithMultiplePrepay(java.lang.String arNumber, java.lang.String glNumber)
AccountsReceivableVO | AccountingBox.voidARPaymentWithPrepay(java.lang.String arNumber, java.lang.String arpNumber, java.lang.String glNumber)

Methods in bb.common.box that return types with arguments of type AccountsReceivableVO
 java.util.Collection<AccountsReceivableVO> AccountingBox.findARs(java.lang.String customerId, java.util.Date fromDate, java.util.Date toDate)

Methods in bb.common.box with parameters of type AccountsReceivableVO
java.lang.String | AccountingBox.addARWithoutShipper(AccountsReceivableVO vo)
java.lang.String | AccountingBox.addCreditMemoWithoutInvoice(AccountsReceivableVO vo)
void | AccountingBox.deleteAR(AccountsReceivableVO vo)
AccountsReceivableItemVO | AccountingBox.initAccountsReceivableItemVO(AccountsReceivableVO vo, BB2Part part, java.math.BigDecimal qty)
void | AccountingBox.updateAR(AccountsReceivableVO vo)
AccountsReceivableVO | AccountingBox.updateCreditMemo(AccountsReceivableVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AddPayableWithoutReceiverAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AddPayableWithoutReceiverAgent

Packages that use AddPayableWithoutReceiverAgent
bb.common.box

Uses of AddPayableWithoutReceiverAgent in bb.common.box

Methods in bb.common.box with parameters of type AddPayableWithoutReceiverAgent
 java.lang.String AccountingBox.addPayableWithoutReceiver(AddPayableWithoutReceiverAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AddPhysicalInventoryAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AddPhysicalInventoryAgent

Packages that use AddPhysicalInventoryAgent
bb.common.box

Uses of AddPhysicalInventoryAgent in bb.common.box

Methods in bb.common.box with parameters of type AddPhysicalInventoryAgent
CycleCountPK | WarehouseBox.addCycleCount(AddPhysicalInventoryAgent agent)
PhysicalInventoryPK | WarehouseBox.addPhysicalInventory(AddPhysicalInventoryAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AddProformaReceiverAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AddProformaReceiverAgent

No usage of bb.common.AddProformaReceiverAgent

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AddProformaReceiverItemAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AddProformaReceiverItemAgent

Packages that use AddProformaReceiverItemAgent
bb.common

Uses of AddProformaReceiverItemAgent in bb.common

Methods in bb.common that return types with arguments of type AddProformaReceiverItemAgent
 java.util.LinkedHashSet<AddProformaReceiverItemAgent> AddProformaReceiverAgent.getItems()

Method parameters in bb.common with type arguments of type AddProformaReceiverItemAgent
 void AddProformaReceiverAgent.setItems(java.util.LinkedHashSet<AddProformaReceiverItemAgent> items)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AddressAccountInfo

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AddressAccountInfo

Packages that use AddressAccountInfo
bb.common.box

Uses of AddressAccountInfo in bb.common.box

Methods in bb.common.box that return types with arguments of type AddressAccountInfo
 java.util.Collection<AddressAccountInfo> AccountingBox.findAddressAccountInfo(java.lang.String id, java.util.Date from, java.util.Date to, boolean includeUnpost, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AddressQualityDocumentsVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AddressQualityDocumentsVO

Packages that use AddressQualityDocumentsVO
bb.common.box

Uses of AddressQualityDocumentsVO in bb.common.box

Methods in bb.common.box that return AddressQualityDocumentsVO
AddressQualityDocumentsVO | QualityBox.addAddressQualityDocuments(AddressQualityDocumentsVO vo)
AddressQualityDocumentsVO | QualityBox.getAddressQualityDocument(java.lang.Long ii)
AddressQualityDocumentsVO | QualityBox.getAddressQualityDocumentInfo(java.lang.Long ii)
AddressQualityDocumentsVO | QualityBox.updateAddressQualityDocuments(AddressQualityDocumentsVO vo)
AddressQualityDocumentsVO | QualityBox.updateAddressQualityDocumentsInfo(AddressQualityDocumentsVO vo)

Methods in bb.common.box that return types with arguments of type AddressQualityDocumentsVO
java.util.Collection<AddressQualityDocumentsVO> | QualityBox.deleteAddressQualityDocuments(MiscDocAgent agent)
java.util.Collection<AddressQualityDocumentsVO> | QualityBox.findAddressQualityDocumentsByCategory(java.lang.String category, java.lang.String id)
java.util.Collection<AddressQualityDocumentsVO> | QualityBox.findAddressQualityDocumentsInfo(java.lang.String addressId, boolean useLikeMatch, int firstIndex, int maxLength)
java.util.Collection<AddressQualityDocumentsVO> | AddressBox.findAllExpireDateDoc(java.lang.String searchText, java.lang.String type, java.lang.String dateType, java.util.Date from, java.util.Date to, java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<AddressQualityDocumentsVO> | QualityBox.uploadOrUpdateAddressQualityDocuments(MiscDocAgent agent)

Methods in bb.common.box with parameters of type AddressQualityDocumentsVO
AddressQualityDocumentsVO | QualityBox.addAddressQualityDocuments(AddressQualityDocumentsVO vo)
AddressQualityDocumentsVO | QualityBox.updateAddressQualityDocuments(AddressQualityDocumentsVO vo)
AddressQualityDocumentsVO | QualityBox.updateAddressQualityDocumentsInfo(AddressQualityDocumentsVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AddRTVAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AddRTVAgent

Packages that use AddRTVAgent
bb.common.box

Uses of AddRTVAgent in bb.common.box

Methods in bb.common.box with parameters of type AddRTVAgent
 java.lang.String PurchasingBox.addReturnToVendor(AddRTVAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AllBudgetResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AllBudgetResult

Packages that use AllBudgetResult
bb.common.box

Uses of AllBudgetResult in bb.common.box

Methods in bb.common.box that return AllBudgetResult
AllBudgetResult | AccountingBox.findCashFlowBudget(java.lang.String companyUnitId, java.lang.String month1, java.lang.String month2, boolean isCheck)
AllBudgetResult | AccountingBox.findFiscalYearBudget(java.lang.String fiscalYear, java.lang.String companyUnitId)
AllBudgetResult | AccountingBox.findFiscalYearBudget(java.lang.String fiscalYear, java.lang.String companyUnitId, boolean oldYear)
AllBudgetResult | AccountingBox.findFiscalYearBudgetByMonth(java.lang.String fiscalYear, java.util.Date startDate, java.util.Date endDate, java.lang.String companyUnitId, boolean includeInactive)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AllPartDocumentsPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AllPartDocumentsPK

Packages that use AllPartDocumentsPK
bb.common
bb.common.box

Uses of AllPartDocumentsPK in bb.common

Methods in bb.common that return AllPartDocumentsPK
AllPartDocumentsPK | DocumentInfoAgent.getDocumentPk()
AllPartDocumentsPK | AllPartDocumentsVO.getPk()

Methods in bb.common with parameters of type AllPartDocumentsPK
 void AllPartDocumentsVO.setPk(AllPartDocumentsPK pk)

Constructors in bb.common with parameters of type AllPartDocumentsPK
AllPartDocumentsVO(AllPartDocumentsPK pk, java.util.Date lastChangeDate, java.lang.String lastChangeUser, boolean publicDoc, java.lang.String description, java.lang.String comments)
full constructor

Uses of AllPartDocumentsPK in bb.common.box

Methods in bb.common.box with parameters of type AllPartDocumentsPK
AllPartDocumentsVO | DocumentBox.getPartDocumentInfo(AllPartDocumentsPK pk)
boolean | DocumentBox.isPartDocumentExist(AllPartDocumentsPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AllPartDocumentsVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AllPartDocumentsVO

Packages that use AllPartDocumentsVO
bb.common.box

Uses of AllPartDocumentsVO in bb.common.box

Methods in bb.common.box that return AllPartDocumentsVO
 AllPartDocumentsVO DocumentBox.getPartDocumentInfo(AllPartDocumentsPK pk)

Methods in bb.common.box that return types with arguments of type AllPartDocumentsVO
 java.util.Collection<AllPartDocumentsVO> DocumentBox.findAllDocuments(java.lang.String pnLike, java.lang.String documentType, java.lang.String language, java.lang.String isPublic, java.lang.String description, java.lang.String comments, boolean isCurrentVersion, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AllStatementsListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AllStatementsListResult

Packages that use AllStatementsListResult
bb.common.box

Uses of AllStatementsListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type AllStatementsListResult
 java.util.Collection<AllStatementsListResult> AccountingBox.findAllStatements()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AmountsStatementResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AmountsStatementResult

Packages that use AmountsStatementResult
bb.common.box

Uses of AmountsStatementResult in bb.common.box

Methods in bb.common.box that return types with arguments of type AmountsStatementResult
java.util.Collection<AmountsStatementResult> | AccountingBox.findAllFirstLevelAccountFiscalYearBalance()
java.util.Collection<AmountsStatementResult> | AccountingBox.getAllFirstLevelAccountBalanceByMonth(java.lang.String monthYear)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.APAgingItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.APAgingItemListResult

Packages that use APAgingItemListResult
bb.common.box

Uses of APAgingItemListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type APAgingItemListResult
 java.util.Collection<APAgingItemListResult> AccountingBox.findAgingAPItems(java.lang.String[] includeCustomerId, java.lang.String[] excludeCustomerId, boolean useAsOf, java.util.Date asOf, int firstIndex, int length)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.APAuditListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.APAuditListResult

Packages that use APAuditListResult
bb.common.box

Uses of APAuditListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type APAuditListResult
 java.util.Collection<APAuditListResult> AccountingBox.getAPAuditListResults(java.util.ArrayList<java.lang.String> list, java.lang.String currency)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ApCheckRunItemAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ApCheckRunItemAgent

Packages that use ApCheckRunItemAgent
bb.common.box

Uses of ApCheckRunItemAgent in bb.common.box

Methods in bb.common.box with parameters of type ApCheckRunItemAgent
 java.lang.String AccountingBox.setupCheckRunPayment(ApCheckRunItemAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ApCheckRunListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ApCheckRunListResult

Packages that use ApCheckRunListResult
bb.common.box

Uses of ApCheckRunListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type ApCheckRunListResult
 java.util.Collection<ApCheckRunListResult> AccountingBox.findApCheckRunByDate(java.util.Date fromDate, java.util.Date toDate, java.lang.String checkNumber, java.lang.String vendorId, java.lang.String debitAccount, java.lang.String creditAccount, java.lang.String dateColumn, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.APItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.APItemListResult

Packages that use APItemListResult
bb.common
bb.common.box

Uses of APItemListResult in bb.common

Subclasses of APItemListResult in bb.common
 class APAgingItemListResult

Uses of APItemListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type APItemListResult
java.util.Collection<APItemListResult> | AccountingBox.findApByDate(java.lang.String partNumberLike, java.lang.String partType, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String vendorId, java.lang.String vendorInvoice, java.lang.String status, java.lang.String Datetype, java.util.Date fromDate, java.util.Date toDate, java.lang.String productCode, int firstIndex, int maxLength)
java.util.Collection<APItemListResult> | AccountingBox.findApByDate(java.lang.String apNumber, java.lang.String partNumberLike, java.lang.String partType, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String vendorId, java.lang.String vendorInvoice, java.lang.String status, java.lang.String Datetype, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<APItemListResult> | AccountingBox.findDMByDate(java.lang.String partNumberLike, java.lang.String partType, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String vendorId, java.lang.String vendorInvoice, java.lang.String status, java.lang.String Datetype, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<APItemListResult> | AccountingBox.findDMByDate(java.lang.String apNumber, java.lang.String partNumberLike, java.lang.String partType, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String vendorId, java.lang.String vendorInvoice, java.lang.String status, java.lang.String Datetype, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<APItemListResult> | AccountingBox.findEPByDate(java.lang.String partNumberLike, java.lang.String partType, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String vendorId, java.lang.String vendorInvoice, java.lang.String status, java.lang.String datetype, java.util.Date fromDate, java.util.Date toDate, java.lang.String productCode, java.lang.String receiverNumber, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AppColumnVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AppColumnVO

Packages that use AppColumnVO
bb.common.box

Uses of AppColumnVO in bb.common.box

Methods in bb.common.box that return AppColumnVO
 AppColumnVO CompanyBox.getAppColumnByTableNameAndColumnName(java.lang.String tableName, java.lang.String columnName)

Methods in bb.common.box that return types with arguments of type AppColumnVO
 java.util.HashMap<java.lang.String,java.util.ArrayList<AppColumnVO>> CompanyBox.findAllAppColumns()

Methods in bb.common.box with parameters of type AppColumnVO
void | CompanyBox.addCustomColumn(AppColumnVO vo)
void | CompanyBox.deleteCustomColumn(AppColumnVO vo)
void | CompanyBox.updateCustomColumn(AppColumnVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AppException

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AppException

No usage of bb.common.AppException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.APPrepayInfoResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.APPrepayInfoResult

Packages that use APPrepayInfoResult
bb.common.box

Uses of APPrepayInfoResult in bb.common.box

Methods in bb.common.box that return types with arguments of type APPrepayInfoResult
 java.util.Collection<APPrepayInfoResult> AccountingBox.findAPPrepayToBatchPaymentbyAddressIdSet(java.lang.String[] includeCustomerId, java.lang.String[] excludeCustomerId, java.lang.String companyUnitId, java.util.Date fromDate, java.util.Date toDate)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ApPrepayItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ApPrepayItemPK

Packages that use ApPrepayItemPK
bb.common

Uses of ApPrepayItemPK in bb.common

Methods in bb.common that return ApPrepayItemPK
ApPrepayItemPK[] | PrepaymentWireTransferAgent.getAppiPk()
ApPrepayItemPK[] | ApPrepaymentCheckRunItemAgent.getAppiPk()
ApPrepayItemPK | VendorPrepayStatementListResult.getPk()
ApPrepayItemPK | ApPrepayItemVO.getPk()
ApPrepayItemPK | APPrepayInfoResult.getPk()

Methods in bb.common with parameters of type ApPrepayItemPK
void | PrepaymentWireTransferAgent.setAppiPk(ApPrepayItemPK[] appiPk)
void | ApPrepaymentCheckRunItemAgent.setAppiPk(ApPrepayItemPK[] appiPk)
void | VendorPrepayStatementListResult.setPk(ApPrepayItemPK pk)
void | ApPrepayItemVO.setPk(ApPrepayItemPK pk)
void | APPrepayInfoResult.setPk(ApPrepayItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ApPrepayItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ApPrepayItemVO

Packages that use ApPrepayItemVO
bb.common

Uses of ApPrepayItemVO in bb.common

Methods in bb.common that return types with arguments of type ApPrepayItemVO
 java.util.Set<ApPrepayItemVO> ApPrepayVO.getApPrepayItem()

Method parameters in bb.common with type arguments of type ApPrepayItemVO
 void ApPrepayVO.setApPrepayItem(java.util.Set<ApPrepayItemVO> apPrepayItem)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ApPrepaymentCheckRunItemAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ApPrepaymentCheckRunItemAgent

Packages that use ApPrepaymentCheckRunItemAgent
bb.common.box

Uses of ApPrepaymentCheckRunItemAgent in bb.common.box

Methods in bb.common.box with parameters of type ApPrepaymentCheckRunItemAgent
 java.lang.String AccountingBox.setupCheckRunPrepayment(ApPrepaymentCheckRunItemAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ApPrepayVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ApPrepayVO

Packages that use ApPrepayVO
bb.common.box

Uses of ApPrepayVO in bb.common.box

Methods in bb.common.box that return ApPrepayVO
ApPrepayVO | AccountingBox.getApPrepayByPK(java.lang.String prepayNumber)
ApPrepayVO | AccountingBox.voidAPPrepayPayment(java.lang.String appNumber, java.lang.String appItemNumber, java.lang.String glNumber)

Methods in bb.common.box that return types with arguments of type ApPrepayVO
java.util.Collection<ApPrepayVO> | AccountingBox.findApPrepay(java.lang.String appNumber, java.lang.String vendorId, java.lang.String status, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)
java.util.Collection<ApPrepayVO> | AccountingBox.findApPrepayTotal(java.lang.String appNumber, java.lang.String vendorId, java.lang.String status, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type ApPrepayVO
 java.lang.String AccountingBox.updateApPrepay(ApPrepayVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ApprovedGLResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ApprovedGLResult

Packages that use ApprovedGLResult
bb.common.box

Uses of ApprovedGLResult in bb.common.box

Methods in bb.common.box that return ApprovedGLResult
ApprovedGLResult | AccountingBox.batchApprovalGL(java.util.List<java.lang.String> transactionNumber)
ApprovedGLResult | AccountingBox.batchCancelApprovalGL(java.util.List<java.lang.String> transactionNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.APTaxForZipcodeListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.APTaxForZipcodeListResult

Packages that use APTaxForZipcodeListResult
bb.common.box

Uses of APTaxForZipcodeListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type APTaxForZipcodeListResult
 java.util.Collection<APTaxForZipcodeListResult> AccountingBox.findAPbyZipcodeTaxList(java.lang.String apNumber, java.lang.String vendor, java.lang.String zipcode, java.lang.String status, java.util.Date from, java.util.Date to)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ARAllStatementsListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ARAllStatementsListResult

No usage of bb.common.ARAllStatementsListResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ARAuditListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ARAuditListResult

Packages that use ARAuditListResult
bb.common.box

Uses of ARAuditListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type ARAuditListResult
 java.util.Collection<ARAuditListResult> AccountingBox.getARAuditListResults(java.util.ArrayList<java.lang.String> list, java.lang.String currency)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ARBoilerplateVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ARBoilerplateVO

Packages that use ARBoilerplateVO
bb.common.box

Uses of ARBoilerplateVO in bb.common.box

Methods in bb.common.box that return ARBoilerplateVO
ARBoilerplateVO | AccountingBox.addArBP(ARBoilerplateVO vo)
ARBoilerplateVO | AccountingBox.getArBPByPk(java.lang.String arBoilerplateId)
ARBoilerplateVO | AccountingBox.updateArBP(ARBoilerplateVO vo)

Methods in bb.common.box that return types with arguments of type ARBoilerplateVO
java.util.Collection<ARBoilerplateVO> | AccountingBox.findAllArBP(int firstIndex, int maxLength)
java.util.Collection<ARBoilerplateVO> | AccountingBox.findArBPByBPId(java.lang.String bpId, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type ARBoilerplateVO
ARBoilerplateVO | AccountingBox.addArBP(ARBoilerplateVO vo)
ARBoilerplateVO | AccountingBox.updateArBP(ARBoilerplateVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ArCommissionListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ArCommissionListResult

Packages that use ArCommissionListResult
bb.common.box

Uses of ArCommissionListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type ArCommissionListResult
 java.util.Collection<ArCommissionListResult> AccountingBox.findArCommissionByDate(java.lang.String dateType, java.lang.String status, java.lang.String salesCodeId, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ArCommissionTotalResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ArCommissionTotalResult

Packages that use ArCommissionTotalResult
bb.common.box

Uses of ArCommissionTotalResult in bb.common.box

Methods in bb.common.box that return types with arguments of type ArCommissionTotalResult
 java.util.Collection<ArCommissionTotalResult> AccountingBox.getArCommissionTotalAmountByDate(java.lang.String dateType, java.lang.String status, java.lang.String salesCodeId, java.util.Date fromDate, java.util.Date toDate)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ArPaymentRunItemAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ArPaymentRunItemAgent

Packages that use ArPaymentRunItemAgent
bb.common.box

Uses of ArPaymentRunItemAgent in bb.common.box

Methods in bb.common.box with parameters of type ArPaymentRunItemAgent
 java.lang.String AccountingBox.setupReceivablePayment(ArPaymentRunItemAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ARPaymentRunItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ARPaymentRunItemPK

Packages that use ARPaymentRunItemPK
bb.common

Uses of ARPaymentRunItemPK in bb.common

Methods in bb.common that return ARPaymentRunItemPK
 ARPaymentRunItemPK ARPaymentRunItemVO.getPk()

Methods in bb.common with parameters of type ARPaymentRunItemPK
 void ARPaymentRunItemVO.setPk(ARPaymentRunItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ARPaymentRunItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ARPaymentRunItemVO

Packages that use ARPaymentRunItemVO
bb.common.box

Uses of ARPaymentRunItemVO in bb.common.box

Methods in bb.common.box that return types with arguments of type ARPaymentRunItemVO
 java.util.Collection<ARPaymentRunItemVO> AccountingBox.findPaymentRunItemByPaymentNo(java.lang.String paymentRunNo, java.lang.String paymentNumber, java.lang.String customerId)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ARPaymentRunListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ARPaymentRunListResult

Packages that use ARPaymentRunListResult
bb.common.box

Uses of ARPaymentRunListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type ARPaymentRunListResult
java.util.Collection<ARPaymentRunListResult> | AccountingBox.findArPaymentByDate(java.util.Date fromDate, java.util.Date toDate, java.lang.String paymentNumber, java.lang.String customerId, java.lang.String debitAccount, java.lang.String creditAccount, int firstIndex, int maxLength)
java.util.Collection<ARPaymentRunListResult> | AccountingBox.getArPaymentByDateTotal(java.util.Date fromDate, java.util.Date toDate, java.lang.String paymentNumber, java.lang.String customerId, java.lang.String debitAccount, java.lang.String creditAccount)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ARPaymentRunVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ARPaymentRunVO

Packages that use ARPaymentRunVO
bb.common.box

Uses of ARPaymentRunVO in bb.common.box

Methods in bb.common.box that return ARPaymentRunVO
 ARPaymentRunVO AccountingBox.getARPaymentRunByPk(java.lang.String paymentRunNumber)

Methods in bb.common.box that return types with arguments of type ARPaymentRunVO
java.util.Collection<ARPaymentRunVO> | AccountingBox.findAllARPaymentRuns(int firstIndex, int maxLength)
java.util.Collection<ARPaymentRunVO> | AccountingBox.findARPaymentRunsByPaymentNumberLike(java.lang.String paymentRunNumberLike, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type ARPaymentRunVO
void | AccountingBox.deleteARPaymentRun(ARPaymentRunVO vo)
java.lang.String | AccountingBox.updatePaymentRun(ARPaymentRunVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ARPrepayAllStatementsListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ARPrepayAllStatementsListResult

No usage of bb.common.ARPrepayAllStatementsListResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ARPrepayInfoResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ARPrepayInfoResult

Packages that use ARPrepayInfoResult
bb.common.box

Uses of ARPrepayInfoResult in bb.common.box

Methods in bb.common.box that return types with arguments of type ARPrepayInfoResult
 java.util.Collection<ARPrepayInfoResult> AccountingBox.findARPrepayToBatchReceivebyAddressIdSet(java.lang.String[] includeCustomerId, java.lang.String[] excludeCustomerId, java.lang.String companyUnitId, java.util.Date fromDate, java.util.Date toDate)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ArPrepayItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ArPrepayItemPK

Packages that use ArPrepayItemPK
bb.common

Uses of ArPrepayItemPK in bb.common

Methods in bb.common that return ArPrepayItemPK
ArPrepayItemPK[] | ArPrepaymentRunItemAgent.getArpiNumber()
ArPrepayItemPK[] | ARPrepaymentWireTransferAgent.getArpiPk()
ArPrepayItemPK | CustomerPrepayStatementListResult.getPk()
ArPrepayItemPK | ArPrepayItemVO.getPk()
ArPrepayItemPK | ARPrepayInfoResult.getPk()

Methods in bb.common with parameters of type ArPrepayItemPK
void | ArPrepaymentRunItemAgent.setArpiNumber(ArPrepayItemPK[] arpiNumber)
void | ARPrepaymentWireTransferAgent.setArpiPk(ArPrepayItemPK[] arpiPk)
void | CustomerPrepayStatementListResult.setPk(ArPrepayItemPK pk)
void | ArPrepayItemVO.setPk(ArPrepayItemPK pk)
void | ARPrepayInfoResult.setPk(ArPrepayItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ArPrepayItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ArPrepayItemVO

Packages that use ArPrepayItemVO
bb.common

Uses of ArPrepayItemVO in bb.common

Methods in bb.common that return types with arguments of type ArPrepayItemVO
 java.util.Set<ArPrepayItemVO> ArPrepayVO.getArPrepayItem()

Method parameters in bb.common with type arguments of type ArPrepayItemVO
 void ArPrepayVO.setArPrepayItem(java.util.Set<ArPrepayItemVO> arPrepayItem)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ArPrepaymentRunItemAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ArPrepaymentRunItemAgent

Packages that use ArPrepaymentRunItemAgent
bb.common.box

Uses of ArPrepaymentRunItemAgent in bb.common.box

Methods in bb.common.box with parameters of type ArPrepaymentRunItemAgent
 java.lang.String AccountingBox.setupReceivablePrepayment(ArPrepaymentRunItemAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ARPrepaymentWireTransferAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ARPrepaymentWireTransferAgent

Packages that use ARPrepaymentWireTransferAgent
bb.common.box

Uses of ARPrepaymentWireTransferAgent in bb.common.box

Methods in bb.common.box with parameters of type ARPrepaymentWireTransferAgent
 java.lang.String AccountingBox.SetUpARPrepaymentWireTransferExecuter(ARPrepaymentWireTransferAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ArPrepayVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ArPrepayVO

Packages that use ArPrepayVO
bb.common.box

Uses of ArPrepayVO in bb.common.box

Methods in bb.common.box that return ArPrepayVO
ArPrepayVO | AccountingBox.getArPrepayByPK(java.lang.String prepayNumber)
ArPrepayVO | AccountingBox.voidARPrepayPayment(java.lang.String arpNumber, java.lang.String glNumber)

Methods in bb.common.box that return types with arguments of type ArPrepayVO
java.util.Collection<ArPrepayVO> | AccountingBox.findArPrepay(java.lang.String arpNumber, java.lang.String customerId, java.lang.String status, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)
java.util.Collection<ArPrepayVO> | AccountingBox.findArPrepayTotal(java.lang.String arpNumber, java.lang.String customerId, java.lang.String status, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type ArPrepayVO
 java.lang.String AccountingBox.updateArPrepay(ArPrepayVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ArSalesCodeTotalListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ArSalesCodeTotalListResult

Packages that use ArSalesCodeTotalListResult
bb.common.box

Uses of ArSalesCodeTotalListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type ArSalesCodeTotalListResult
 java.util.Collection<ArSalesCodeTotalListResult> AccountingBox.findArSalesCodeTotalByDate(java.lang.String dateType, java.lang.String status, java.lang.String salesCodeId, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ARTaxForZipcodeListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ARTaxForZipcodeListResult

Packages that use ARTaxForZipcodeListResult
bb.common.box

Uses of ARTaxForZipcodeListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type ARTaxForZipcodeListResult
 java.util.Collection<ARTaxForZipcodeListResult> AccountingBox.findARbyZipcodeTaxList(java.lang.String arNumber, java.lang.String customer, java.lang.String zipcode, java.lang.String status, java.util.Date from, java.util.Date to)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AssetAddOrDisposalsReport

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AssetAddOrDisposalsReport

Packages that use AssetAddOrDisposalsReport
bb.common.box

Uses of AssetAddOrDisposalsReport in bb.common.box

Methods in bb.common.box that return types with arguments of type AssetAddOrDisposalsReport
java.util.Collection<AssetAddOrDisposalsReport> | AccountingBox.findAssetAdditions(java.lang.String assetNumber, java.lang.String assetType, java.lang.String departmentID, java.lang.String location, java.util.Date fDate, java.util.Date tDate, int firstIndex, int maxLength)
java.util.Collection<AssetAddOrDisposalsReport> | AccountingBox.findAssetDisposals(java.lang.String assetNumber, java.lang.String assetType, java.lang.String departmentID, java.lang.String location, java.util.Date fDate, java.util.Date tDate, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AssetAmortizationExpenseAccountPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AssetAmortizationExpenseAccountPK

Packages that use AssetAmortizationExpenseAccountPK
bb.common

Uses of AssetAmortizationExpenseAccountPK in bb.common

Methods in bb.common that return AssetAmortizationExpenseAccountPK
 AssetAmortizationExpenseAccountPK AssetAmortizationExpenseAccountVO.getPk()

Methods in bb.common with parameters of type AssetAmortizationExpenseAccountPK
 void AssetAmortizationExpenseAccountVO.setPk(AssetAmortizationExpenseAccountPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AssetAmortizationExpenseAccountVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AssetAmortizationExpenseAccountVO

Packages that use AssetAmortizationExpenseAccountVO
bb.common

Uses of AssetAmortizationExpenseAccountVO in bb.common

Methods in bb.common that return types with arguments of type AssetAmortizationExpenseAccountVO
java.util.Set<AssetAmortizationExpenseAccountVO> | AssetVO.getAmortizationExpenseAccounts()
java.util.Set<AssetAmortizationExpenseAccountVO> | AssetDepreciateVO.getAmortizationExpenseAccounts()

Methods in bb.common with parameters of type AssetAmortizationExpenseAccountVO
 int AssetAmortizationExpenseAccountVO.compareTo(AssetAmortizationExpenseAccountVO o)

Method parameters in bb.common with type arguments of type AssetAmortizationExpenseAccountVO
void | AssetVO.setAmortizationExpenseAccounts(java.util.Set<AssetAmortizationExpenseAccountVO> amortizationExpenseAccounts)
void | AssetDepreciateVO.setAmortizationExpenseAccounts(java.util.Set<AssetAmortizationExpenseAccountVO> amortizationExpenseAccounts)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AssetDepreciateDetailReport

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AssetDepreciateDetailReport

Packages that use AssetDepreciateDetailReport
bb.common.box

Uses of AssetDepreciateDetailReport in bb.common.box

Methods in bb.common.box that return types with arguments of type AssetDepreciateDetailReport
 java.util.Collection<AssetDepreciateDetailReport> AccountingBox.findAssetDepreciateDetails(java.lang.String fiscalYear, java.lang.String assetNumber, java.lang.String assetType, java.lang.String departmentID, java.lang.String location, java.lang.String amortizationExpenseAccount, java.lang.String status)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AssetDepreciatePK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AssetDepreciatePK

Packages that use AssetDepreciatePK
bb.common

Uses of AssetDepreciatePK in bb.common

Methods in bb.common that return AssetDepreciatePK
 AssetDepreciatePK AssetDepreciateVO.getPk()

Methods in bb.common that return types with arguments of type AssetDepreciatePK
 java.util.Map<AssetDepreciatePK,AccountCreditVO> ExchangeAuditResult.getMap()

Methods in bb.common with parameters of type AssetDepreciatePK
 void AssetDepreciateVO.setPk(AssetDepreciatePK pk)

Method parameters in bb.common with type arguments of type AssetDepreciatePK
 void ExchangeAuditResult.setMap(java.util.Map<AssetDepreciatePK,AccountCreditVO> map)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AssetDepreciateVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AssetDepreciateVO

Packages that use AssetDepreciateVO
bb.common.box

Uses of AssetDepreciateVO in bb.common.box

Methods in bb.common.box that return types with arguments of type AssetDepreciateVO
java.util.Collection<AssetDepreciateVO> | AccountingBox.findAssetDepreciates(java.lang.String assetNumber, java.lang.String monthYear, java.lang.String departmentID, java.lang.String location, java.lang.String usingStatus, java.lang.String assetType, java.lang.String amortizationExpenseAccount, java.lang.String transactionNumber, int firstIndex, int maxLength)
java.util.Collection<AssetDepreciateVO> | AccountingBox.initAssetDepreciate(java.lang.String monthYear, java.lang.String assetNumber, java.lang.String assetType, java.lang.String location, java.lang.String departmentID, java.lang.String amortizationExpenseAccount, java.lang.String usingStatus, boolean showAll, int firstIndex, int maxLength)

Method parameters in bb.common.box with type arguments of type AssetDepreciateVO
 java.lang.String AccountingBox.updateAssetDepreciate(java.util.ArrayList<AssetDepreciateVO> voSet, java.lang.String summary)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AssetReportSumResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AssetReportSumResult

Packages that use AssetReportSumResult
bb.common.box

Uses of AssetReportSumResult in bb.common.box

Methods in bb.common.box that return AssetReportSumResult
AssetReportSumResult | AccountingBox.getAssetAdditionsSum(java.lang.String assetNumber, java.lang.String assetType, java.lang.String departmentID, java.lang.String location, java.util.Date fDate, java.util.Date tDate)
AssetReportSumResult | AccountingBox.getAssetDepreciatesSum(java.lang.String assetNumber, java.lang.String monthYear, java.lang.String departmentID, java.lang.String location, java.lang.String usingStatus, java.lang.String assetType, java.lang.String amortizationExpenseAccount, java.lang.String transactionNumber)
AssetReportSumResult | AccountingBox.getAssetDisposalsSum(java.lang.String assetNumber, java.lang.String assetType, java.lang.String departmentID, java.lang.String location, java.util.Date fDate, java.util.Date tDate)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AssetTypeVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AssetTypeVO

Packages that use AssetTypeVO
bb.common.box

Uses of AssetTypeVO in bb.common.box

Methods in bb.common.box that return AssetTypeVO
 AssetTypeVO AccountingBox.getAssetType(java.lang.String id)

Methods in bb.common.box that return types with arguments of type AssetTypeVO
 java.util.Collection<AssetTypeVO> AccountingBox.findAllAssetTypes(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type AssetTypeVO
void | AccountingBox.addAssetType(AssetTypeVO vo)
void | AccountingBox.updateAssetType(AssetTypeVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AssetUsagePK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AssetUsagePK

Packages that use AssetUsagePK
bb.common
bb.common.box

Uses of AssetUsagePK in bb.common

Methods in bb.common that return AssetUsagePK
 AssetUsagePK AssetUsageVO.getPk()

Methods in bb.common with parameters of type AssetUsagePK
 void AssetUsageVO.setPk(AssetUsagePK pk)

Uses of AssetUsagePK in bb.common.box

Methods in bb.common.box with parameters of type AssetUsagePK
void | AccountingBox.deleteAssetUsage(AssetUsagePK pk)
AssetUsageVO | AccountingBox.getAssetUsagebyPk(AssetUsagePK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AssetUsageVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AssetUsageVO

Packages that use AssetUsageVO
bb.common.box

Uses of AssetUsageVO in bb.common.box

Methods in bb.common.box that return AssetUsageVO
 AssetUsageVO AccountingBox.getAssetUsagebyPk(AssetUsagePK pk)

Methods in bb.common.box that return types with arguments of type AssetUsageVO
java.util.Collection<AssetUsageVO> | AccountingBox.addAssetUsage(AssetUsageVO vo)
java.util.Collection<AssetUsageVO> | AccountingBox.getAssetUsageById(java.lang.String assetNumber)

Methods in bb.common.box with parameters of type AssetUsageVO
java.util.Collection<AssetUsageVO> | AccountingBox.addAssetUsage(AssetUsageVO vo)
void | AccountingBox.updateAssetUsage(AssetUsageVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AssetVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AssetVO

Packages that use AssetVO
bb.common.box

Uses of AssetVO in bb.common.box

Methods in bb.common.box that return AssetVO
 AssetVO AccountingBox.findAssetByPk(java.lang.String assetNumber)

Methods in bb.common.box that return types with arguments of type AssetVO
java.util.Collection<AssetVO> | AccountingBox.findAllAssets(int firstIndex, int maxLength)
java.util.Collection<AssetVO> | AccountingBox.findAssetsByAssetNumber(java.lang.String assetNumber, int firstIndex, int maxLength)
java.util.Collection<AssetVO> | AccountingBox.findAssetsList(java.lang.String assetNumber, java.lang.String assetType, java.lang.String depreciationType, java.lang.String depreciationStatus, java.lang.String location, java.lang.String departmentID, java.lang.String amortizationExpenseAccount, java.lang.String usingStatus, java.lang.String status, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type AssetVO
void | AccountingBox.addAsset(AssetVO vo)
void | AccountingBox.deleteAsset(AssetVO vo)
java.lang.String | AccountingBox.scrapAsset(AssetVO vo, ScrapAssetAgent agent)
java.lang.String | AccountingBox.updateAsset(AssetVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AuditLogVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AuditLogVO

Packages that use AuditLogVO
bb.common.box

Uses of AuditLogVO in bb.common.box

Methods in bb.common.box that return AuditLogVO
 AuditLogVO PurchasingBox.getAuditLog()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AuditOnDemandResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AuditOnDemandResult

Packages that use AuditOnDemandResult
bb.common.box

Uses of AuditOnDemandResult in bb.common.box

Methods in bb.common.box that return types with arguments of type AuditOnDemandResult
java.util.Collection<AuditOnDemandResult> | PurchasingBox.auditing(java.util.ArrayList list)
java.util.Collection<AuditOnDemandResult> | WarehouseBox.findAllOnHandAudit(java.lang.String partNumber, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<AuditOnDemandResult> | PurchasingBox.getAuditResults()

Method parameters in bb.common.box with type arguments of type AuditOnDemandResult
java.util.Collection<java.util.Map> | WarehouseBox.findNeedCycleCountParts(java.util.ArrayList<AuditOnDemandResult> audits, int firstIndex, int maxLength)
int | WarehouseBox.getNeedCycleCountPartsCount(java.util.ArrayList<AuditOnDemandResult> audits)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.AuditPartInQAResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.AuditPartInQAResult

Packages that use AuditPartInQAResult
bb.common.box

Uses of AuditPartInQAResult in bb.common.box

Methods in bb.common.box that return types with arguments of type AuditPartInQAResult
java.util.Collection<AuditPartInQAResult> | WarehouseBox.findTotalAuditPartInQA(java.lang.String pnLike, java.lang.String pnType, java.lang.String pnFrom, int firstIndex, int maxLength)
java.util.Collection<AuditPartInQAResult> | WarehouseBox.getAuditPartInQA(java.lang.String pnLike, java.lang.String pnType, java.lang.String pnFrom)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BalanceSheetSideBySideItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BalanceSheetSideBySideItemResult

Packages that use BalanceSheetSideBySideItemResult
bb.common

Uses of BalanceSheetSideBySideItemResult in bb.common

Methods in bb.common that return BalanceSheetSideBySideItemResult
BalanceSheetSideBySideItemResult | BalanceSheetSideBySideResult.getTotalAssets()
BalanceSheetSideBySideItemResult | BalanceSheetSideBySideResult.getTotalCurrentAssets()
BalanceSheetSideBySideItemResult | BalanceSheetSideBySideResult.getTotalCurrentLiability()
BalanceSheetSideBySideItemResult | BalanceSheetSideBySideResult.getTotalFixedAssets()
BalanceSheetSideBySideItemResult | BalanceSheetSideBySideResult.getTotalLiability()
BalanceSheetSideBySideItemResult | BalanceSheetSideBySideResult.getTotalLiabilityEquity()
BalanceSheetSideBySideItemResult | BalanceSheetSideBySideResult.getTotalOtherAssets()
BalanceSheetSideBySideItemResult | BalanceSheetSideBySideResult.getTotalOtherLiability()
BalanceSheetSideBySideItemResult | BalanceSheetSideBySideResult.getTotalOwnersEquity()
BalanceSheetSideBySideItemResult | BalanceSheetSideBySideResult.getTotalReturainedEarnings()

Methods in bb.common with parameters of type BalanceSheetSideBySideItemResult
void | BalanceSheetSideBySideResult.setTotalAssets(BalanceSheetSideBySideItemResult totalAssets)
void | BalanceSheetSideBySideResult.setTotalCurrentAssets(BalanceSheetSideBySideItemResult totalCurrentAssets)
void | BalanceSheetSideBySideResult.setTotalCurrentLiability(BalanceSheetSideBySideItemResult totalCurrentLiability)
void | BalanceSheetSideBySideResult.setTotalFixedAssets(BalanceSheetSideBySideItemResult totalFixedAssets)
void | BalanceSheetSideBySideResult.setTotalLiability(BalanceSheetSideBySideItemResult totalLiability)
void | BalanceSheetSideBySideResult.setTotalLiabilityEquity(BalanceSheetSideBySideItemResult totalLiabilityEquity)
void | BalanceSheetSideBySideResult.setTotalOtherAssets(BalanceSheetSideBySideItemResult totalOtherAssets)
void | BalanceSheetSideBySideResult.setTotalOtherLiability(BalanceSheetSideBySideItemResult totalOtherLiability)
void | BalanceSheetSideBySideResult.setTotalOwnersEquity(BalanceSheetSideBySideItemResult totalOwnersEquity)
void | BalanceSheetSideBySideResult.setTotalReturainedEarnings(BalanceSheetSideBySideItemResult totalReturainedEarnings)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BalanceSheetSideBySideResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BalanceSheetSideBySideResult

Packages that use BalanceSheetSideBySideResult
bb.common.box

Uses of BalanceSheetSideBySideResult in bb.common.box

Methods in bb.common.box that return BalanceSheetSideBySideResult
 BalanceSheetSideBySideResult AccountingBox.findBalanceSheetSBS(java.lang.String monthYear)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BankReconciliationReportVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BankReconciliationReportVO

Packages that use BankReconciliationReportVO
bb.common.box

Uses of BankReconciliationReportVO in bb.common.box

Methods in bb.common.box that return BankReconciliationReportVO
 BankReconciliationReportVO AccountingBox.addBankReconciliationReport(BankReconciliationReportVO vo)

Methods in bb.common.box that return types with arguments of type BankReconciliationReportVO
 java.util.Collection<BankReconciliationReportVO> AccountingBox.findBankReconciliationReport(java.lang.String month, java.lang.String accountNumber, java.lang.String companyUnitID, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type BankReconciliationReportVO
BankReconciliationReportVO | AccountingBox.addBankReconciliationReport(BankReconciliationReportVO vo)
void | AccountingBox.deleteBankReconciliationReport(BankReconciliationReportVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2AttachFile

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2AttachFile

Packages that use BB2AttachFile
bb.common

Uses of BB2AttachFile in bb.common

Methods in bb.common that return types with arguments of type BB2AttachFile
java.util.ArrayList<BB2AttachFile> | BB2Notice.getAttach()
java.util.ArrayList<BB2AttachFile> | BB2BugNotice.getAttach()

Method parameters in bb.common with type arguments of type BB2AttachFile
void | BB2Notice.setAttach(java.util.ArrayList<BB2AttachFile> attach)
void | BB2BugNotice.setAttach(java.util.ArrayList<BB2AttachFile> attach)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2BigDecimalAndString

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2BigDecimalAndString

No usage of bb.common.BB2BigDecimalAndString

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2BugNotice

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2BugNotice

Packages that use BB2BugNotice
bb.common.box

Uses of BB2BugNotice in bb.common.box

Methods in bb.common.box with parameters of type BB2BugNotice
 void CompanyBox.sendBugNotice(BB2BugNotice notice)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2Document

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2Document

No usage of bb.common.BB2Document

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2DocumentException

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2DocumentException

No usage of bb.common.BB2DocumentException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2DoubleCost

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2DoubleCost

Packages that use BB2DoubleCost
bb.common.box

Uses of BB2DoubleCost in bb.common.box

Methods in bb.common.box that return BB2DoubleCost
BB2DoubleCost | WarehouseBox.getNonproductivePickingItemIssuedTotal(java.lang.String monthYear)
BB2DoubleCost | WarehouseBox.getPartOnDemandTotalAmount()
BB2DoubleCost | WarehouseBox.getPartOnOrderTotalAmount()
BB2DoubleCost | WarehouseBox.getPartWithMaxQtyTotalAmount()
BB2DoubleCost | WarehouseBox.getPartWithMinQtyTotalAmount()
BB2DoubleCost | WorkOrderBox.getWorkOrderItemPartInWipTotal(java.lang.String monthYear)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2DoubleString

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2DoubleString

Packages that use BB2DoubleString
bb.common.box

Uses of BB2DoubleString in bb.common.box

Methods in bb.common.box that return types with arguments of type BB2DoubleString
java.util.Collection<BB2DoubleString> | EngineeringBox.findAllPartNumbers()
java.util.Collection<BB2DoubleString> | EngineeringBox.findAllPartNumbers(java.lang.String language, java.lang.String partType)
java.util.Collection<BB2DoubleString> | SalesBox.findAllSalesCodeName(int firstIndex, int maxLength)
java.util.Collection<BB2DoubleString> | SalesBox.getAllCatalogsId()
java.util.Map<java.lang.String,java.util.Set<BB2DoubleString>> | CompanyBox.getAllCompanyUnitsByAccountNumber()
java.util.Collection<BB2DoubleString> | HumanResourceBox.getAllEmployeeIDs()
java.util.Collection<BB2DoubleString> | CompanyBox.getAllTerms()
java.util.Collection<BB2DoubleString> | WorkOrderBox.getTotalWorkOrderInstructionSeq(java.lang.String partNumber, java.lang.String partType, java.lang.String workOrderNumber, java.lang.String status)
java.util.Collection<BB2DoubleString> | CompanyBox.getUserPasswordPairs(java.lang.String userName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2Event

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2Event

Packages that use BB2Event
bb.common

Uses of BB2Event in bb.common

Subclasses of BB2Event in bb.common
 class I18nEvent

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2File

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2File

Packages that use BB2File
bb.common
bb.common.box

Uses of BB2File in bb.common

Subclasses of BB2File in bb.common
 class BB2Picture

Uses of BB2File in bb.common.box

Methods in bb.common.box that return BB2File
BB2File | QualityBox.downLoadNCRPicture(MiscDocAgent agent)
BB2File | ManufacturingBox.downloadOnloanDoc(MiscDocAgent agent)
BB2File | QualityBox.downloadPARDoc(MiscDocAgent agent)
BB2File | QualityBox.downloadPartCertificateFile(MiscDocAgent agent)
BB2File | PurchasingBox.downloadPODoc(MiscDocAgent agent)
BB2File | CompanyBox.getTermsConditionFiles(java.lang.String type)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2FiscalYearDate

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2FiscalYearDate

No usage of bb.common.BB2FiscalYearDate

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2Login

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2Login

Packages that use BB2Login
bb.common

Uses of BB2Login in bb.common

Methods in bb.common with parameters of type BB2Login
void | Spiderman.login(BB2Login loginData)
boolean | Facade.login(BB2Login bb2login)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2MessagingException

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2MessagingException

No usage of bb.common.BB2MessagingException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2Notice

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2Notice

Packages that use BB2Notice
bb.common.box

Uses of BB2Notice in bb.common.box

Methods in bb.common.box with parameters of type BB2Notice
void | CompanyBox.sendARStatement(BB2Notice notice)
void | CompanyBox.sendNotice(BB2Notice notice)
void | CompanyBox.sendPoNotice(BB2Notice notice)
void | CompanyBox.sendQuoteNotice(BB2Notice notice)
void | CompanyBox.sendRfqNotice(BB2Notice notice)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2Part

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2Part

Packages that use BB2Part
bb.common
bb.common.box

Uses of BB2Part in bb.common

Methods in bb.common that return BB2Part
BB2Part | WOItemPartDetailNotIssue.getAsmPart()
BB2Part | OrderDemandForReceiverResult.getBB2Part()
static BB2Part | BB2Util.getBB2PartFromOrderItem(java.lang.Object item)
BB2Part | WorkOrderItemWCLoadResult.getPart()
BB2Part | WorkInstructionSummaryResult.getPart()
BB2Part | WorkCenterRunTimeListResult.getPart()
BB2Part | WoItemWorkInstructionListResult.getPart()
BB2Part | WOItemPartDetailNotIssue.getPart()
BB2Part | WOItemCostControlAgent.getPart()
BB2Part | WCLoadByDateResult.getPart()
BB2Part | StockTransactionWOShipperResult.getPart()
BB2Part | StockTransactionWOReceiverResult.getPart()
BB2Part | StockTransactionSOShipperResult.getPart()
BB2Part | StockTransactionPOReceiverResult.getPart()
BB2Part | StockTransactionPartInfoResult.getPart()
BB2Part | StockTransactionAdjustmentResult.getPart()
BB2Part | ShipListItemRelatedDocResult.getPart()
BB2Part | SGPartCatalogResult.getPart()
BB2Part | SerialNumberResult.getPart()
BB2Part | SerialNumberItemResult.getPart()
BB2Part | SalesOrder12MonthMarginResult.getPart()
BB2Part | ReceiverItemAgent.getPart()
BB2Part | RebackInQAAgent.getPart()
BB2Part | PuttoInQAAgent.getPart()
BB2Part | PullFromWorkOrderPartDetailAgent.getPart()
BB2Part | PartOnhandResult.getPart()
BB2Part | PartInWipForIDListResult.getPart()
BB2Part | PartInQAAgent.getPart()
BB2Part | PartClassInfoResult.getPart()
BB2Part | NcrReportListResult.getPart()
BB2Part | InventoryNotUsedInMonthsResult.getPart()
BB2Part | InventoryListResult.getPart()
BB2Part | InventoryCycleResult.getPart()
BB2Part | HighUsagePartResult.getPart()
BB2Part | EcnCheckOrderResult.getPart()
BB2Part | BB2WeightInfoResult.getPart()
BB2Part | BB2PartOnDemandListResult.getPart()
BB2Part | BB2PartInventoryResult.getPart()
BB2Part | BB2PartByDateResult.getPart()
BB2Part | BB2PartBasicInfo.getPart()
BB2Part | PartInWipForIDListResult.getPartInWip()
BB2Part | ReturnToVendorByDateListResult.getPartPk()
BB2Part | PurchaseOrderOpenDueListResult.getPartPk()
BB2Part | PurchaseOrderItemListResult.getPartPk()

Methods in bb.common with parameters of type BB2Part
int | BB2Part.compareTo(BB2Part other)
void | WOItemPartDetailNotIssue.setAsmPart(BB2Part asmPart)
void | WorkOrderItemWCLoadResult.setPart(BB2Part part)
void | WorkInstructionSummaryResult.setPart(BB2Part part)
void | WorkCenterRunTimeListResult.setPart(BB2Part part)
void | WoItemWorkInstructionListResult.setPart(BB2Part part)
void | WOItemPartDetailNotIssue.setPart(BB2Part part)
void | WOItemCostControlAgent.setPart(BB2Part part)
void | WCLoadByDateResult.setPart(BB2Part part)
void | StockTransactionWOShipperResult.setPart(BB2Part part)
void | StockTransactionWOReceiverResult.setPart(BB2Part part)
void | StockTransactionSOShipperResult.setPart(BB2Part part)
void | StockTransactionPOReceiverResult.setPart(BB2Part part)
void | StockTransactionPartInfoResult.setPart(BB2Part part)
void | StockTransactionAdjustmentResult.setPart(BB2Part part)
void | ShipListItemRelatedDocResult.setPart(BB2Part part)
void | SerialNumberResult.setPart(BB2Part part)
void | SerialNumberItemResult.setPart(BB2Part part)
void | SalesOrder12MonthMarginResult.setPart(BB2Part part)
void | ReceiverItemAgent.setPart(BB2Part part)
void | RebackInQAAgent.setPart(BB2Part part)
void | PuttoInQAAgent.setPart(BB2Part part)
void | PullFromWorkOrderPartDetailAgent.setPart(BB2Part part)
void | PartOnhandResult.setPart(BB2Part part)
void | PartInWipForIDListResult.setPart(BB2Part part)
void | PartInQAAgent.setPart(BB2Part part)
void | PartClassInfoResult.setPart(BB2Part part)
void | NcrReportListResult.setPart(BB2Part part)
void | InventoryNotUsedInMonthsResult.setPart(BB2Part part)
void | InventoryListResult.setPart(BB2Part part)
void | InventoryCycleResult.setPart(BB2Part part)
void | HighUsagePartResult.setPart(BB2Part part)
void | EcnCheckOrderResult.setPart(BB2Part part)
void | BB2WeightInfoResult.setPart(BB2Part part)
void | BB2PartOnDemandListResult.setPart(BB2Part part)
void | BB2PartInventoryResult.setPart(BB2Part part)
void | BB2PartByDateResult.setPart(BB2Part part)
void | BB2PartBasicInfo.setPart(BB2Part part)
void | PartInWipForIDListResult.setPartInWip(BB2Part partInWip)
void | ReturnToVendorByDateListResult.setPartPk(BB2Part partPk)
void | PurchaseOrderOpenDueListResult.setPartPk(BB2Part partPk)
void | PurchaseOrderItemListResult.setPartPk(BB2Part partPk)

Constructors in bb.common with parameters of type BB2Part
BB2PartInventoryResult(BB2Part part)
BB2PartOnhandPK(BB2Part part, java.lang.String location)

Uses of BB2Part in bb.common.box

Methods in bb.common.box that return types with arguments of type BB2Part
 java.util.HashMap<BB2Part,BB2WeightInfoResult> SalesBox.getWeightInfo(java.util.HashSet<BB2Part> pks)

Methods in bb.common.box with parameters of type BB2Part
DisassembleWorkOrderItemPartDetailItemResult | WorkOrderBox.addDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemPK itemPk, BB2Part partPk, java.math.BigDecimal qty, java.math.BigDecimal cost)
PartOnhandPK | WarehouseBox.addNewLocation(BB2Part part, java.lang.String location, java.lang.String warehouse)
WorkOrderItemPartDetailItemResult | WorkOrderBox.addWorkOrderItemIssue(WorkOrderItemPK itemPk, BB2Part part, java.math.BigDecimal qty)
PartWithOnhandDetailInfoResult | WarehouseBox.adjustInventory(java.util.ArrayList partOnhandWithAverageCostList, BB2Part part, java.lang.String comments)
void | WarehouseBox.auditInSTO(BB2Part part)
void | WarehouseBox.auditInWip(BB2Part part)
void | WarehouseBox.auditOnDemand(BB2Part part)
void | WarehouseBox.auditOnOrder(BB2Part part)
void | WarehouseBox.auditUsage(BB2Part part)
void | EngineeringBox.deleteVendorQtyPrices(BB2Part pk, java.lang.String vendorId)
java.util.Collection<PartInQAVO> | WarehouseBox.findAllPartInQAsWithoutNCR(BB2Part part, int firstIndex, int maxLength)
java.util.Collection<AccountsReceivableItemResult> | AccountingBox.findARItemByPartAndDate(java.util.Date fromDate, java.util.Date toDate, BB2Part part, int firstIndex, int maxLength)
java.util.Collection<BB2PartInSipItemResult> | WarehouseBox.findBB2PartInSipItemResults(BB2Part part)
java.util.Collection<PartReceivedVO> | WorkOrderBox.findDisassembleWorkOrderReceivedDetail(DisassembleWorkOrderItemPK pk, BB2Part part, java.lang.String description, int firstIndex, int maxLength)
java.util.Collection<InventoryAdjustmentListResult> | WarehouseBox.findInventoryAdjustmentRecords(BB2Part part, int firstIndex, int maxLength)
java.util.Collection<LogInventoryListResult> | WarehouseBox.findLogInventoryByPart(BB2Part part, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemIssueVO> | WorkOrderBox.findOpenAndIssuedWorkOrderItemIssues(java.lang.String woNumber, java.lang.String itemNumber, BB2Part part)
java.util.Collection<PartIssuedVO> | WorkOrderBox.findWorkOrderIssuedDetail(WorkOrderItemPK pk, BB2Part part, java.lang.String description, int firstIndex, int maxLength)
java.util.Collection<PartInQAVO> | WarehouseBox.getAllPartInQAsfor(BB2Part part, java.lang.String ncrNumber)
java.util.Collection<PartInQAVO> | WarehouseBox.getAllPartInQAsWithoutNCR(BB2Part part)
int | WarehouseBox.getAllPartInQAsWithoutNCRCount(BB2Part part)
int | AccountingBox.getARItemCountByPartAndDate(java.util.Date fromDate, java.util.Date toDate, BB2Part part)
java.lang.String | QualityBox.getBB2PartDescription(BB2Part part, java.lang.String language)
java.lang.String | EngineeringBox.getBB2PartDescription(BB2Part part, java.lang.String language)
java.lang.String | ManufacturingBox.getDefaultWISetId(BB2Part part)
WorkInstructionVO | ManufacturingBox.getDefaultWorkInstructionByPartPk(BB2Part part)
int | WorkOrderBox.getDisassembleWorkOrderReceivedDetail(DisassembleWorkOrderItemPK pk, BB2Part part, java.lang.String description)
java.lang.Object[] | WorkOrderBox.getDisassembleWorkOrderReceivedDetailTotal(DisassembleWorkOrderItemPK pk, BB2Part part, java.lang.String description)
EcnCheckOrderResult | EngineeringBox.getEcnCheckOrderResult(BB2Part pk)
java.math.BigDecimal | PurchasingBox.getInitDefaultCostPerUnit(BB2Part part, java.lang.String poNumber)
java.math.BigDecimal[] | SalesBox.getInitDefaultPricePerUnit(BB2Part part, java.lang.String soNumber)
InventoryAdjustmentDetailResult | WarehouseBox.getInventoryAdjustmentDetail(BB2Part part)
InventoryAdjustmentListResult | WarehouseBox.getInventoryAdjustmentListResult(BB2Part part)
int | WarehouseBox.getInventoryAdjustmentRecordsCount(BB2Part part)
BB2PartInventoryResult | WarehouseBox.getInventoryByBB2Part(BB2Part partpk)
int | WarehouseBox.getLogInventoryCountByPart(BB2Part part)
WorkInstructionVO | WorkOrderBox.getManWorkInstructionByWoItemPk(BB2Part part, java.lang.String setId)
BB2PartMrpResult | WarehouseBox.getMrpResult(BB2Part part)
BB2PartMrpResult | PurchasingBox.getMrpResult(BB2Part part)
BB2PartMrpResult | ManufacturingBox.getMrpResult(BB2Part part)
PartWithOnhandDetailInfoResult | WarehouseBox.getPartOnhandDetailInfoByPartPk(BB2Part part)
PartInQAResult | WarehouseBox.getPartsInQAsWithoutNCR(BB2Part part)
BB2PartTotalInQADetailResult | WarehouseBox.getTotalInQAResult(BB2Part part)
BB2PartTotalInSipDetailResult | WarehouseBox.getTotalInSipDetail(BB2Part part)
BB2PartTotalInSitDetailResult | WarehouseBox.getTotalInSitDetail(BB2Part part)
BB2PartTotalInSTODetailResult | WarehouseBox.getTotalInSTODetail(BB2Part part)
BB2PartTotalInWipDetailResult | WarehouseBox.getTotalInWipDetail(BB2Part part)
BB2PartTotalOndemandDetailResult | WarehouseBox.getTotalOndemandDetail(BB2Part part)
BB2PartTotalOnhandDetailResult | WarehouseBox.getTotalOnhandDetail(BB2Part part)
BB2PartTotalOnloanDetailResult | WarehouseBox.getTotalOnLoanResult(BB2Part part)
BB2PartTotalOnorderDetailResult | WarehouseBox.getTotalOnorderDetail(BB2Part part)
java.util.Collection<BB2PartInSipOfSoItemResult> | SalesBox.getTotalSOInSipDetail(BB2Part part)
BB2PartTotalOndemandDetailResult | WarehouseBox.getTotalUsageDetail(BB2Part part, boolean isYr)
java.util.Collection<VendorQtyPriceVO> | EngineeringBox.getVendorQtyPrices(BB2Part pk, java.lang.String vendorId)
java.util.Collection<java.lang.String> | WorkOrderBox.getWISetIDs(BB2Part part)
WorkInstructionVO | ManufacturingBox.getWorkInstructionByPart(BB2Part part, java.lang.String setId)
WorkInstructionSummaryResult | ManufacturingBox.getWorkInstructionSummaryResult(BB2Part part, java.lang.String setId)
int | WorkOrderBox.getWorkOrderIssuedDetail(WorkOrderItemPK pk, BB2Part part, java.lang.String description)
PartIssueTotalResult | WorkOrderBox.getWorkOrderIssuedDetailTotal(WorkOrderItemPK pk, BB2Part part, java.lang.String description)
AccountsReceivableItemVO | AccountingBox.initAccountsReceivableItemVO(AccountsReceivableVO vo, BB2Part part, java.math.BigDecimal qty)
NonproductivePickingItemVO | WarehouseBox.InitNonproductivePickingItem(NonproductivePickingVO vo, BB2Part part, java.math.BigDecimal quantity)
boolean | WarehouseBox.isMakeNcr(BB2Part part, java.lang.String receivedFrom)
void | EngineeringBox.resetBB2PartAvgCost(BB2Part part)

Method parameters in bb.common.box with type arguments of type BB2Part
void | WorkOrderBox.addDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemPK itemPk, java.util.LinkedHashMap<BB2Part,java.math.BigDecimal> map)
void | WorkOrderBox.addWorkOrderItemIssue(WorkOrderItemPK itemPk, java.util.LinkedHashMap<BB2Part,java.math.BigDecimal> map, java.util.LinkedHashMap<BB2Part,java.lang.String> commentsMap)
void | WorkOrderBox.addWorkOrderItemIssue(WorkOrderItemPK itemPk, java.util.LinkedHashMap<BB2Part,java.math.BigDecimal> map, java.util.LinkedHashMap<BB2Part,java.lang.String> commentsMap)
void | EngineeringBox.auditPartDwgFlag(java.util.HashSet<BB2Part> bb2Parts)
java.util.HashMap<BB2Part,BB2WeightInfoResult> | SalesBox.getWeightInfo(java.util.HashSet<BB2Part> pks)
void | WorkOrderBox.updateDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemPK itemPk, java.util.LinkedHashMap<BB2Part,java.math.BigDecimal> map)
void | QualityBox.updatePartWithInspectionType(java.util.HashSet<BB2Part> set, java.lang.String inspectionType)
void | WorkOrderBox.updateWorkOrderItemIssue(WorkOrderItemPK itemPk, java.util.LinkedHashMap<BB2Part,java.math.BigDecimal> map, java.util.LinkedHashMap<BB2Part,java.lang.String> updateCommentsMap)
void | WorkOrderBox.updateWorkOrderItemIssue(WorkOrderItemPK itemPk, java.util.LinkedHashMap<BB2Part,java.math.BigDecimal> map, java.util.LinkedHashMap<BB2Part,java.lang.String> updateCommentsMap)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2PartBasicInfo

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2PartBasicInfo

Packages that use BB2PartBasicInfo
bb.common

Uses of BB2PartBasicInfo in bb.common

Subclasses of BB2PartBasicInfo in bb.common
class | BB2PartInfo
class | BB2PartMrpResult
class | BB2PartTotalInQADetailResult
class | BB2PartTotalInSipDetailResult
class | BB2PartTotalInSitDetailResult
class | BB2PartTotalInSTODetailResult
class | BB2PartTotalInWipDetailResult
class | BB2PartTotalOndemandDetailResult
class | BB2PartTotalOnhandDetailResult
class | BB2PartTotalOnloanDetailResult
class | BB2PartTotalOnorderDetailResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2PartByDateResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2PartByDateResult

No usage of bb.common.BB2PartByDateResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2PartInfo

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2PartInfo

Packages that use BB2PartInfo
bb.common

Uses of BB2PartInfo in bb.common

Subclasses of BB2PartInfo in bb.common
 class BB2PartMrpResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2PartInSipItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2PartInSipItemResult

Packages that use BB2PartInSipItemResult
bb.common.box

Uses of BB2PartInSipItemResult in bb.common.box

Methods in bb.common.box that return types with arguments of type BB2PartInSipItemResult
 java.util.Collection<BB2PartInSipItemResult> WarehouseBox.findBB2PartInSipItemResults(BB2Part part)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2PartInSipOfSoItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2PartInSipOfSoItemResult

Packages that use BB2PartInSipOfSoItemResult
bb.common.box

Uses of BB2PartInSipOfSoItemResult in bb.common.box

Methods in bb.common.box that return types with arguments of type BB2PartInSipOfSoItemResult
 java.util.Collection<BB2PartInSipOfSoItemResult> SalesBox.getTotalSOInSipDetail(BB2Part part)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2PartInSitItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2PartInSitItemResult

No usage of bb.common.BB2PartInSitItemResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2PartInSTOItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2PartInSTOItemResult

No usage of bb.common.BB2PartInSTOItemResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2PartInventoryResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2PartInventoryResult

Packages that use BB2PartInventoryResult
bb.common.box

Uses of BB2PartInventoryResult in bb.common.box

Methods in bb.common.box that return BB2PartInventoryResult
 BB2PartInventoryResult WarehouseBox.getInventoryByBB2Part(BB2Part partpk)

Methods in bb.common.box that return types with arguments of type BB2PartInventoryResult
 java.util.Collection<BB2PartInventoryResult> WarehouseBox.findBB2PartInventoryResults(java.util.HashSet bb2Parts)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2PartMrpResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2PartMrpResult

Packages that use BB2PartMrpResult
bb.common.box

Uses of BB2PartMrpResult in bb.common.box

Methods in bb.common.box that return BB2PartMrpResult
BB2PartMrpResult | WarehouseBox.getMrpResult(BB2Part part)
BB2PartMrpResult | PurchasingBox.getMrpResult(BB2Part part)
BB2PartMrpResult | ManufacturingBox.getMrpResult(BB2Part part)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2PartOnDemandListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2PartOnDemandListResult

Packages that use BB2PartOnDemandListResult
bb.common.box

Uses of BB2PartOnDemandListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type BB2PartOnDemandListResult
 java.util.Collection<BB2PartOnDemandListResult> PurchasingBox.findBB2PartOnDemandListResultForPart(boolean compessSuff, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2PartOnhandPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2PartOnhandPK

No usage of bb.common.BB2PartOnhandPK

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2PartOnLoanItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2PartOnLoanItemResult

No usage of bb.common.BB2PartOnLoanItemResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2PartTotalInQADetailResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2PartTotalInQADetailResult

Packages that use BB2PartTotalInQADetailResult
bb.common.box

Uses of BB2PartTotalInQADetailResult in bb.common.box

Methods in bb.common.box that return BB2PartTotalInQADetailResult
 BB2PartTotalInQADetailResult WarehouseBox.getTotalInQAResult(BB2Part part)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2PartTotalInSipDetailResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2PartTotalInSipDetailResult

Packages that use BB2PartTotalInSipDetailResult
bb.common.box

Uses of BB2PartTotalInSipDetailResult in bb.common.box

Methods in bb.common.box that return BB2PartTotalInSipDetailResult
 BB2PartTotalInSipDetailResult WarehouseBox.getTotalInSipDetail(BB2Part part)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2PartTotalInSitDetailResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2PartTotalInSitDetailResult

Packages that use BB2PartTotalInSitDetailResult
bb.common.box

Uses of BB2PartTotalInSitDetailResult in bb.common.box

Methods in bb.common.box that return BB2PartTotalInSitDetailResult
 BB2PartTotalInSitDetailResult WarehouseBox.getTotalInSitDetail(BB2Part part)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2PartTotalInSTODetailResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2PartTotalInSTODetailResult

Packages that use BB2PartTotalInSTODetailResult
bb.common.box

Uses of BB2PartTotalInSTODetailResult in bb.common.box

Methods in bb.common.box that return BB2PartTotalInSTODetailResult
 BB2PartTotalInSTODetailResult WarehouseBox.getTotalInSTODetail(BB2Part part)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2PartTotalInWipDetailResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2PartTotalInWipDetailResult

Packages that use BB2PartTotalInWipDetailResult
bb.common.box

Uses of BB2PartTotalInWipDetailResult in bb.common.box

Methods in bb.common.box that return BB2PartTotalInWipDetailResult
 BB2PartTotalInWipDetailResult WarehouseBox.getTotalInWipDetail(BB2Part part)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2PartTotalOndemandDetailResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2PartTotalOndemandDetailResult

Packages that use BB2PartTotalOndemandDetailResult
bb.common.box

Uses of BB2PartTotalOndemandDetailResult in bb.common.box

Methods in bb.common.box that return BB2PartTotalOndemandDetailResult
BB2PartTotalOndemandDetailResult | WarehouseBox.getTotalOndemandDetail(BB2Part part)
BB2PartTotalOndemandDetailResult | WarehouseBox.getTotalUsageDetail(BB2Part part, boolean isYr)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2PartTotalOnhandDetailResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2PartTotalOnhandDetailResult

Packages that use BB2PartTotalOnhandDetailResult
bb.common.box

Uses of BB2PartTotalOnhandDetailResult in bb.common.box

Methods in bb.common.box that return BB2PartTotalOnhandDetailResult
 BB2PartTotalOnhandDetailResult WarehouseBox.getTotalOnhandDetail(BB2Part part)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2PartTotalOnloanDetailResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2PartTotalOnloanDetailResult

Packages that use BB2PartTotalOnloanDetailResult
bb.common.box

Uses of BB2PartTotalOnloanDetailResult in bb.common.box

Methods in bb.common.box that return BB2PartTotalOnloanDetailResult
 BB2PartTotalOnloanDetailResult WarehouseBox.getTotalOnLoanResult(BB2Part part)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2PartTotalOnorderDetailResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2PartTotalOnorderDetailResult

Packages that use BB2PartTotalOnorderDetailResult
bb.common.box

Uses of BB2PartTotalOnorderDetailResult in bb.common.box

Methods in bb.common.box that return BB2PartTotalOnorderDetailResult
 BB2PartTotalOnorderDetailResult WarehouseBox.getTotalOnorderDetail(BB2Part part)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2Picture

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2Picture

Packages that use BB2Picture
bb.common.box

Uses of BB2Picture in bb.common.box

Methods in bb.common.box that return BB2Picture
BB2Picture | EngineeringBox.downloadMainPartPicture(MiscDocAgent agent)
BB2Picture | ManufacturingBox.downloadWorkInstructionPicture(MiscDocAgent agent)

Methods in bb.common.box that return types with arguments of type BB2Picture
 java.util.Collection<BB2Picture> EngineeringBox.downloadAllPartPictureByPk(MiscDocAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2QtyAndMoneyMap

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2QtyAndMoneyMap

No usage of bb.common.BB2QtyAndMoneyMap

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2RefdocPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2RefdocPK

Packages that use BB2RefdocPK
bb.common.box

Uses of BB2RefdocPK in bb.common.box

Methods in bb.common.box with parameters of type BB2RefdocPK
void | WorkOrderBox.deleteRefdocOne(BB2RefdocPK pk)
void | SalesBox.deleteRefdocOne(BB2RefdocPK pk)
void | WorkOrderBox.deleteRefdocTwo(BB2RefdocPK pk)
void | WarehouseBox.deleteRefdocTwo(BB2RefdocPK pk)
void | PurchasingBox.deleteRefdocTwo(BB2RefdocPK pk)
void | AccountingBox.deleteRefdocTwo(BB2RefdocPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2ServerException

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2ServerException

Packages that use BB2ServerException
bb.common

Uses of BB2ServerException in bb.common

Subclasses of BB2ServerException in bb.common
class | AppException
class | BB2DocumentException
class | BB2MessagingException
class | BizException
class | DBAccessException
class | InvokeException
class | LoginException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2Task

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2Task

Packages that use BB2Task
bb.common.box

Uses of BB2Task in bb.common.box

Methods in bb.common.box that return types with arguments of type BB2Task
 java.util.Map<java.lang.String,BB2Task> CompanyBox.getAllTasksList()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2TimeFactory

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2TimeFactory

No usage of bb.common.BB2TimeFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2tripleString

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2tripleString

No usage of bb.common.BB2tripleString

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2Util

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2Util

No usage of bb.common.BB2Util

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2WeightInfoResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2WeightInfoResult

Packages that use BB2WeightInfoResult
bb.common.box

Uses of BB2WeightInfoResult in bb.common.box

Methods in bb.common.box that return types with arguments of type BB2WeightInfoResult
 java.util.HashMap<BB2Part,BB2WeightInfoResult> SalesBox.getWeightInfo(java.util.HashSet<BB2Part> pks)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BB2Zip

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BB2Zip

No usage of bb.common.BB2Zip

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BillDetailCostResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BillDetailCostResult

Packages that use BillDetailCostResult
bb.common.box

Uses of BillDetailCostResult in bb.common.box

Methods in bb.common.box that return BillDetailCostResult
 BillDetailCostResult EngineeringBox.getBillDetailCostResult(BillPK billPk, java.lang.String languageCode)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BillDetailCostWithPartInfoResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BillDetailCostWithPartInfoResult

Packages that use BillDetailCostWithPartInfoResult
bb.common

Uses of BillDetailCostWithPartInfoResult in bb.common

Methods in bb.common that return BillDetailCostWithPartInfoResult
 BillDetailCostWithPartInfoResult BillDetailCostResult.getBillInfo()

Methods in bb.common with parameters of type BillDetailCostWithPartInfoResult
 void BillDetailCostResult.setBillInfo(BillDetailCostWithPartInfoResult billInfo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BillItemDetailCostWithPartInfoResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BillItemDetailCostWithPartInfoResult

No usage of bb.common.BillItemDetailCostWithPartInfoResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BillItemOnHandUsageResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BillItemOnHandUsageResult

Packages that use BillItemOnHandUsageResult
bb.common.box

Uses of BillItemOnHandUsageResult in bb.common.box

Methods in bb.common.box that return types with arguments of type BillItemOnHandUsageResult
 java.util.Collection<BillItemOnHandUsageResult> EngineeringBox.getBillItemOnHandUsageResults(BillPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BillItemOnHandWithPartInfoResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BillItemOnHandWithPartInfoResult

Packages that use BillItemOnHandWithPartInfoResult
bb.common
bb.common.box

Uses of BillItemOnHandWithPartInfoResult in bb.common

Subclasses of BillItemOnHandWithPartInfoResult in bb.common
 class MasterWorkOrderTreeItemResult

Constructors in bb.common with parameters of type BillItemOnHandWithPartInfoResult
MasterWorkOrderTreeItemResult(BillItemOnHandWithPartInfoResult superResult)

Uses of BillItemOnHandWithPartInfoResult in bb.common.box

Methods in bb.common.box that return BillItemOnHandWithPartInfoResult
 BillItemOnHandWithPartInfoResult EngineeringBox.getBillItemOnHandWithPartInfoByBillItemPk(BillItemPK billItemPk, java.lang.String languageCode)

Methods in bb.common.box that return types with arguments of type BillItemOnHandWithPartInfoResult
 java.util.Collection<BillItemOnHandWithPartInfoResult> EngineeringBox.findBillItemOnHandWithPartInfoByBillPk(BillPK billPk, java.lang.String languageCode, boolean needOnhandLocation, java.lang.String locationPrefix)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BillItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BillItemPK

Packages that use BillItemPK
bb.common
bb.common.box

Uses of BillItemPK in bb.common

Methods in bb.common that return BillItemPK
BillItemPK | ToolListItemWithToolInfoResult.getBillItemPk()
BillItemPK | SalesPartListItemResult.getBillItemPk()
BillItemPK | SalesBomItemResult.getBillItemPk()
BillItemPK | PartMaterialWhereUsedItemResult.getBillItemPk()
BillItemPK | BomPickListItemResult.getBillItemPk()
BillItemPK | BomItemWithOEMResult.getBillItemPk()
BillItemPK | BillWhereUsedItemResult.getBillItemPk()
BillItemPK | BillItemWithPartInfoResult.getBillItemPk()
BillItemPK | BillItemSalesXResult.getBillItemPk()
BillItemPK | BillItemSalesResult.getBillItemPk()
BillItemPK | BillItemSalesCostResult.getBillItemPk()
BillItemPK | ToolWhereUsedItemResult.getPk()
BillItemPK | ToolListItemVO.getPk()
BillItemPK | PartWhereUsedItemResult.getPk()
BillItemPK | BillItemVO.getPk()

Methods in bb.common with parameters of type BillItemPK
void | ToolListItemWithToolInfoResult.setBillItemPk(BillItemPK billItemPk)
void | SalesPartListItemResult.setBillItemPk(BillItemPK billItemPk)
void | SalesBomItemResult.setBillItemPk(BillItemPK billItemPk)
void | PartMaterialWhereUsedItemResult.setBillItemPk(BillItemPK billItemPk)
void | BomPickListItemResult.setBillItemPk(BillItemPK billItemPk)
void | BomItemWithOEMResult.setBillItemPk(BillItemPK billItemPk)
void | BillWhereUsedItemResult.setBillItemPk(BillItemPK billItemPk)
void | BillItemWithPartInfoResult.setBillItemPk(BillItemPK billItemPk)
void | BillItemSalesXResult.setBillItemPk(BillItemPK billItemPk)
void | BillItemSalesResult.setBillItemPk(BillItemPK billItemPk)
void | BillItemSalesCostResult.setBillItemPk(BillItemPK billItemPk)
void | ToolWhereUsedItemResult.setPk(BillItemPK pk)
void | ToolListItemVO.setPk(BillItemPK pk)
void | PartWhereUsedItemResult.setPk(BillItemPK pk)
void | BillItemVO.setPk(BillItemPK pk)

Uses of BillItemPK in bb.common.box

Methods in bb.common.box with parameters of type BillItemPK
BillItemOnHandWithPartInfoResult | EngineeringBox.getBillItemOnHandWithPartInfoByBillItemPk(BillItemPK billItemPk, java.lang.String languageCode)
BillItemVO | EngineeringBox.getBillItems(BillItemPK itemPk)
BillItemWithPartInfoResult | EngineeringBox.getBillItemWithPartInfoByBillItemPk(BillItemPK billItemPk, java.lang.String languageCode)
ToolListItemVO | ManufacturingBox.getToolListItems(BillItemPK itemPk)
ToolListItemWithToolInfoResult | ManufacturingBox.getToolListItemWithToolInfoByBillItemPk(BillItemPK billItemPk, java.lang.String languageCode)
ToolListItemWithToolInfoResult | ManufacturingBox.initToolListItemWithToolInfo(PartPK partPk, BillItemPK pk, java.math.BigDecimal qty)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BillItemReplacementVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BillItemReplacementVO

Packages that use BillItemReplacementVO
bb.common

Uses of BillItemReplacementVO in bb.common

Methods in bb.common that return types with arguments of type BillItemReplacementVO
java.util.Set<BillItemReplacementVO> | BillItemWithPartInfoResult.getBillItemReplacements()
java.util.Set<BillItemReplacementVO> | BillItemVO.getBillItemReplacements()

Method parameters in bb.common with type arguments of type BillItemReplacementVO
void | BillItemWithPartInfoResult.setBillItemReplacements(java.util.Set<BillItemReplacementVO> billItemReplacements)
void | BillItemVO.setBillItemReplacements(java.util.Set<BillItemReplacementVO> billItemReplacements)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BillItemSalesCostResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BillItemSalesCostResult

Packages that use BillItemSalesCostResult
bb.common.box

Uses of BillItemSalesCostResult in bb.common.box

Methods in bb.common.box that return types with arguments of type BillItemSalesCostResult
 java.util.Collection<BillItemSalesCostResult> EngineeringBox.findSalesBillItemWithPartInfoByBillPk(BillPK billPk, java.lang.String languageCode, boolean needMfg)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BillItemSalesResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BillItemSalesResult

No usage of bb.common.BillItemSalesResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BillItemSalesXResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BillItemSalesXResult

No usage of bb.common.BillItemSalesXResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BillItemUsagePathResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BillItemUsagePathResult

Packages that use BillItemUsagePathResult
bb.common

Uses of BillItemUsagePathResult in bb.common

Methods in bb.common that return types with arguments of type BillItemUsagePathResult
 java.util.Iterator<java.util.ArrayList<BillItemUsagePathResult>> BillItemUsageResult.getItems()

Method parameters in bb.common with type arguments of type BillItemUsagePathResult
void | BillItemUsageResult.addItem(java.util.ArrayList<BillItemUsagePathResult> item)
void | BillItemUsageResult.addItems(java.util.ArrayList<java.util.ArrayList<BillItemUsagePathResult>> items)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BillItemUsageResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BillItemUsageResult

Packages that use BillItemUsageResult
bb.common
bb.common.box

Uses of BillItemUsageResult in bb.common

Subclasses of BillItemUsageResult in bb.common
 class BillItemOnHandUsageResult

Uses of BillItemUsageResult in bb.common.box

Methods in bb.common.box that return types with arguments of type BillItemUsageResult
java.util.Collection<BillItemUsageResult> | EngineeringBox.getBillItemUsageResults(BillPK pk)
java.util.Collection<BillItemUsageResult> | EngineeringBox.getBillItemUsageResultsWitCost(BillPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BillItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BillItemVO

Packages that use BillItemVO
bb.common.box

Uses of BillItemVO in bb.common.box

Methods in bb.common.box that return BillItemVO
 BillItemVO EngineeringBox.getBillItems(BillItemPK itemPk)

Methods in bb.common.box with parameters of type BillItemVO
void | EngineeringBox.addBillItem(BillItemVO itemVO)
void | EngineeringBox.deleteBillItem(BillItemVO billItemVO)
BillVO | EngineeringBox.getParentBill(BillItemVO billItemVO)
void | EngineeringBox.setParentBill(BillVO billVO, BillItemVO billItemVO)
void | EngineeringBox.updateBillItem(BillItemVO billItemVO)

Method parameters in bb.common.box with type arguments of type BillItemVO
 void CompanyBox.importTempBOM(java.util.ArrayList<BillItemVO> bills)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BillItemWithPartInfoResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BillItemWithPartInfoResult

Packages that use BillItemWithPartInfoResult
bb.common
bb.common.box

Uses of BillItemWithPartInfoResult in bb.common

Subclasses of BillItemWithPartInfoResult in bb.common
class | BillItemDetailCostWithPartInfoResult
class | BillItemOnHandWithPartInfoResult
class | MasterWorkOrderTreeItemResult

Constructors in bb.common with parameters of type BillItemWithPartInfoResult
BillItemDetailCostWithPartInfoResult(BillItemWithPartInfoResult vo)

Uses of BillItemWithPartInfoResult in bb.common.box

Methods in bb.common.box that return BillItemWithPartInfoResult
 BillItemWithPartInfoResult EngineeringBox.getBillItemWithPartInfoByBillItemPk(BillItemPK billItemPk, java.lang.String languageCode)

Methods in bb.common.box that return types with arguments of type BillItemWithPartInfoResult
java.util.Collection<BillItemWithPartInfoResult> | EngineeringBox.findBillItemWithPartInfoByBillPk(BillPK billPk, java.lang.String languageCode, boolean needMfg)
java.util.Collection<BillItemWithPartInfoResult> | EngineeringBox.findBillItemWithPartInfoByBillPk(BillPK billPk, java.lang.String languageCode, boolean needMfg, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BillLogVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BillLogVO

Packages that use BillLogVO
bb.common.box

Uses of BillLogVO in bb.common.box

Methods in bb.common.box that return types with arguments of type BillLogVO
 java.util.Collection<BillLogVO> EngineeringBox.findBillLog(java.lang.String billNumber, java.lang.String billType, java.lang.String userName, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BillOnHandWithPartInfoResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BillOnHandWithPartInfoResult

Packages that use BillOnHandWithPartInfoResult
bb.common.box

Uses of BillOnHandWithPartInfoResult in bb.common.box

Methods in bb.common.box that return BillOnHandWithPartInfoResult
 BillOnHandWithPartInfoResult EngineeringBox.getBillOnHandWithPartInfoResultByBillPk(BillPK billPk, java.lang.String languageCode, java.lang.String locationPrefix)

Methods in bb.common.box that return types with arguments of type BillOnHandWithPartInfoResult
 java.util.Collection<BillOnHandWithPartInfoResult> EngineeringBox.findAllBomsToDelete(int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BillPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BillPK

Packages that use BillPK
bb.common
bb.common.box

Uses of BillPK in bb.common

Methods in bb.common that return BillPK
BillPK | ToolListWithToolInfoResult.getBillPk()
BillPK | SalesPartListResult.getBillPk()
BillPK | SalesBomResult.getBillPk()
BillPK | MrpReportAgent.getBillPk()
BillPK | BomWithOEMResult.getBillPk()
BillPK | BomPickListResult.getBillPk()
BillPK | BillWithPartInfoResult.getBillPk()
BillPK | BillSalesCostResult.getBillPk()
BillPK | WorkOrderItemSetupItemAgent.getParent()
BillPK | ToolListVO.getPk()
BillPK | ToolListInfoVO.getPk()
BillPK | BillVO.getPk()

Methods in bb.common with parameters of type BillPK
void | ToolListWithToolInfoResult.setBillPk(BillPK billPk)
void | SalesPartListResult.setBillPk(BillPK billPk)
void | SalesBomResult.setBillPk(BillPK billPk)
void | MrpReportAgent.setBillPk(BillPK billPk)
void | BomWithOEMResult.setBillPk(BillPK billPk)
void | BomPickListResult.setBillPk(BillPK billPk)
void | BillWithPartInfoResult.setBillPk(BillPK billPk)
void | BillSalesCostResult.setBillPk(BillPK billPk)
void | WorkOrderItemSetupItemAgent.setParent(BillPK parent)
void | ToolListVO.setPk(BillPK pk)
void | ToolListInfoVO.setPk(BillPK pk)
void | BillVO.setPk(BillPK pk)

Constructors in bb.common with parameters of type BillPK
BillVO(BillPK pk, java.lang.String lastChangeUser, java.lang.String origin, java.util.Date lastChangeDate, java.util.Date createdDate, java.util.Set billItem)
full constructor
BillVO(BillPK pk, java.lang.String lastChangeUser, java.lang.String origin, java.util.Set billItem)
ToolListInfoVO(BillPK pk, java.lang.String lastChangeUser, ToolVO toolVO)
full constructor

Uses of BillPK in bb.common.box

Methods in bb.common.box that return BillPK
 BillPK EngineeringBox.copyBill(BillPK fpk, BillPK tpk)

Methods in bb.common.box that return types with arguments of type BillPK
java.util.Collection<BillPK> | EngineeringBox.getBillPKsToRollUP(java.lang.String bill, boolean root)
java.util.Map<BillPK,java.util.List> | EngineeringBox.getPartUseds(java.util.ArrayList<BillPK> list, PartPK oPartPk)

Methods in bb.common.box with parameters of type BillPK
BillPK | EngineeringBox.copyBill(BillPK fpk, BillPK tpk)
java.util.Collection<BillItemOnHandWithPartInfoResult> | EngineeringBox.findBillItemOnHandWithPartInfoByBillPk(BillPK billPk, java.lang.String languageCode, boolean needOnhandLocation, java.lang.String locationPrefix)
java.util.Collection<BillItemWithPartInfoResult> | EngineeringBox.findBillItemWithPartInfoByBillPk(BillPK billPk, java.lang.String languageCode, boolean needMfg)
java.util.Collection<BillItemWithPartInfoResult> | EngineeringBox.findBillItemWithPartInfoByBillPk(BillPK billPk, java.lang.String languageCode, boolean needMfg, int firstIndex, int maxLength)
java.util.Collection<BillItemSalesCostResult> | EngineeringBox.findSalesBillItemWithPartInfoByBillPk(BillPK billPk, java.lang.String languageCode, boolean needMfg)
java.util.Collection<ToolListItemWithToolInfoResult> | ManufacturingBox.findToolListItemWithToolInfoByBillPk(BillPK billPk, java.lang.String languageCode)
java.util.Collection<ToolListItemWithToolInfoResult> | ManufacturingBox.findToolListItemWithToolInfoByBillPk(BillPK billPk, java.lang.String languageCode, int firstIndex, int maxLength)
BillVO | EngineeringBox.getBill(BillPK billPk)
BillDetailCostResult | EngineeringBox.getBillDetailCostResult(BillPK billPk, java.lang.String languageCode)
int | EngineeringBox.getBillItemCount(BillPK billPk)
java.util.Collection<BillItemOnHandUsageResult> | EngineeringBox.getBillItemOnHandUsageResults(BillPK pk)
java.util.Collection<BillItemUsageResult> | EngineeringBox.getBillItemUsageResults(BillPK pk)
java.util.Collection<BillItemUsageResult> | EngineeringBox.getBillItemUsageResultsWitCost(BillPK pk)
BillOnHandWithPartInfoResult | EngineeringBox.getBillOnHandWithPartInfoResultByBillPk(BillPK billPk, java.lang.String languageCode, java.lang.String locationPrefix)
BillSalesResult | EngineeringBox.getBillSalesResult(BillPK pk)
BillSalesXResult | EngineeringBox.getBillSalesXResult(BillPK pk, java.lang.String languageCode)
BillWhereUsedResult | EngineeringBox.getBillWhereUsedResult(PartPK pk, BillPK billPk)
java.util.Collection<BillWhereUsedResult> | EngineeringBox.getBillWhereUsedResults(java.util.ArrayList<PartPK> pkList, BillPK billPk)
BillWithPartInfoResult | EngineeringBox.getBillWithPartInfoByBillPk(BillPK billPk, java.lang.String languageCode)
BomPickListResult | WarehouseBox.getBomPickList(BillPK pk, java.math.BigDecimal qty)
BomWithOEMResult | EngineeringBox.getBomWithOEMResult(BillPK pk, java.lang.String mfgId)
BOMTreeRollUPMap | EngineeringBox.getFullBOMTreeRollUPMap(BillPK pk)
java.util.Collection<MasterWorkOrderTreeItemResult> | WorkOrderBox.getMasterWorkOrderTreeItem(BillPK billPk, WorkOrderItemPK woItemPk, java.math.BigDecimal qty, boolean calculateOrphan, java.lang.String languageCode)
java.lang.String | EngineeringBox.getMfgBillSetupInfo(BillPK billPk)
java.util.Collection<RollUPPartStandardCostResult> | EngineeringBox.getPartsToRollUPunder(BillPK pk)
SalesBomResult | SalesBox.getSalesBomResult(BillPK billPk, java.lang.String partFrom)
SalesPartListResult | SalesBox.getSalesPartListResult(BillPK billPk, java.lang.String partFrom)
ToolListVO | ManufacturingBox.getToolList(BillPK billPk)
ToolListDetailCostResult | ManufacturingBox.getToolListDetailCostResult(BillPK billPk, java.lang.String languageCode)
int | ManufacturingBox.getToolListItemCount(BillPK billPk)
BomPickListResult | WarehouseBox.getToolListsPickList(BillPK pk, java.math.BigDecimal qty)
ToolListWithToolInfoResult | ManufacturingBox.getToolListWithToolInfoByBillPk(BillPK billPk, java.lang.String languageCode)
boolean | EngineeringBox.isBillExistent(BillPK pk)
boolean | ManufacturingBox.isToolListExistent(BillPK pk)

Method parameters in bb.common.box with type arguments of type BillPK
void | EngineeringBox.deleteBillWithoutItems(java.util.ArrayList<BillPK> set)
java.util.Map<BillPK,java.util.List> | EngineeringBox.getPartUseds(java.util.ArrayList<BillPK> list, PartPK oPartPk)
PartPK | EngineeringBox.replacePartForBOM(java.util.ArrayList<BillPK> list, PartPK oPartPk, PartPK dPartPk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BillSalesCostResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BillSalesCostResult

No usage of bb.common.BillSalesCostResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BillSalesOfCostResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BillSalesOfCostResult

No usage of bb.common.BillSalesOfCostResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BillSalesResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BillSalesResult

Packages that use BillSalesResult
bb.common.box

Uses of BillSalesResult in bb.common.box

Methods in bb.common.box that return BillSalesResult
 BillSalesResult EngineeringBox.getBillSalesResult(BillPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BillSalesXResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BillSalesXResult

Packages that use BillSalesXResult
bb.common.box

Uses of BillSalesXResult in bb.common.box

Methods in bb.common.box that return BillSalesXResult
 BillSalesXResult EngineeringBox.getBillSalesXResult(BillPK pk, java.lang.String languageCode)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BillVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BillVO

Packages that use BillVO
bb.common.box

Uses of BillVO in bb.common.box

Methods in bb.common.box that return BillVO
BillVO | EngineeringBox.addBill(BillVO billVO) **************above are EngineeringChange, below about Bill and BillItem
BillVO | EngineeringBox.approvalBill(BillVO billVO)
BillVO | EngineeringBox.getBill(BillPK billPk)
BillVO | EngineeringBox.getParentBill(BillItemVO billItemVO)
BillVO | EngineeringBox.updateBill(BillVO billVO)

Methods in bb.common.box with parameters of type BillVO
BillVO | EngineeringBox.addBill(BillVO billVO) **************above are EngineeringChange, below about Bill and BillItem
BillVO | EngineeringBox.approvalBill(BillVO billVO)
void | EngineeringBox.deleteBill(BillVO billVO)
void | EngineeringBox.setParentBill(BillVO billVO, BillItemVO billItemVO)
BillVO | EngineeringBox.updateBill(BillVO billVO)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BillWhereUsedItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BillWhereUsedItemResult

Packages that use BillWhereUsedItemResult
bb.common

Uses of BillWhereUsedItemResult in bb.common

Methods in bb.common that return types with arguments of type BillWhereUsedItemResult
 java.util.Set<java.util.List<BillWhereUsedItemResult>> BillWhereUsedResult.getItems()

Method parameters in bb.common with type arguments of type BillWhereUsedItemResult
 void BillWhereUsedResult.setItems(java.util.Set<java.util.List<BillWhereUsedItemResult>> items)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BillWhereUsedResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BillWhereUsedResult

Packages that use BillWhereUsedResult
bb.common.box

Uses of BillWhereUsedResult in bb.common.box

Methods in bb.common.box that return BillWhereUsedResult
 BillWhereUsedResult EngineeringBox.getBillWhereUsedResult(PartPK pk, BillPK billPk)

Methods in bb.common.box that return types with arguments of type BillWhereUsedResult
 java.util.Collection<BillWhereUsedResult> EngineeringBox.getBillWhereUsedResults(java.util.ArrayList<PartPK> pkList, BillPK billPk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BillWithPartInfoResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BillWithPartInfoResult

Packages that use BillWithPartInfoResult
bb.common
bb.common.box

Uses of BillWithPartInfoResult in bb.common

Subclasses of BillWithPartInfoResult in bb.common
class | BillDetailCostWithPartInfoResult
class | BillOnHandWithPartInfoResult

Methods in bb.common that return types with arguments of type BillWithPartInfoResult
 java.util.List<BillWithPartInfoResult> PartsToDeleteResult.getBomToDeletedNotUsed()

Method parameters in bb.common with type arguments of type BillWithPartInfoResult
 void PartsToDeleteResult.setBomToDeletedNotUsed(java.util.List<BillWithPartInfoResult> bomToDeletedNotUsed)

Constructors in bb.common with parameters of type BillWithPartInfoResult
BillDetailCostWithPartInfoResult(BillWithPartInfoResult vo)

Uses of BillWithPartInfoResult in bb.common.box

Methods in bb.common.box that return BillWithPartInfoResult
 BillWithPartInfoResult EngineeringBox.getBillWithPartInfoByBillPk(BillPK billPk, java.lang.String languageCode)

Methods in bb.common.box that return types with arguments of type BillWithPartInfoResult
java.util.Collection<BillWithPartInfoResult> | EngineeringBox.findAllBillsWithPartInfo(java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<BillWithPartInfoResult> | EngineeringBox.findBillswithPartInfoByBillNumberLike(boolean dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String bnRegex, java.lang.String billType, java.lang.String languageCode, boolean isPFEP, java.lang.String lastChangeUser, java.lang.String origin, java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<BillWithPartInfoResult> | EngineeringBox.getBillWithoutItems(java.lang.String pnLike)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BizboxBugChangesInfoVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BizboxBugChangesInfoVO

No usage of bb.common.BizboxBugChangesInfoVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BizboxBugChangesVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BizboxBugChangesVO

No usage of bb.common.BizboxBugChangesVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BizboxBugInfoVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BizboxBugInfoVO

No usage of bb.common.BizboxBugInfoVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BizboxBugVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BizboxBugVO

No usage of bb.common.BizboxBugVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BizBoxServer

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BizBoxServer

Packages that use BizBoxServer
bb.common

Uses of BizBoxServer in bb.common

Constructors in bb.common with parameters of type BizBoxServer
Spiderman(BizBoxServer targetServer)
Spiderman(BizBoxServer targetServer, boolean login)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BizBoxUserEmployeeResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BizBoxUserEmployeeResult

Packages that use BizBoxUserEmployeeResult
bb.common.box

Uses of BizBoxUserEmployeeResult in bb.common.box

Methods in bb.common.box that return types with arguments of type BizBoxUserEmployeeResult
java.util.Collection<BizBoxUserEmployeeResult> | SecurityBox.findAllUsersEmployeeInfo(java.lang.String userName, java.lang.String systemUserName, boolean withoutLocked, int firstIndex, int maxLength)
java.util.Collection<BizBoxUserEmployeeResult> | SecurityBox.findAllUsersEmployeeInfo(java.lang.String userName, java.lang.String systemUserName, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BizboxUserListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BizboxUserListResult

Packages that use BizboxUserListResult
bb.common.box

Uses of BizboxUserListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type BizboxUserListResult
java.util.Collection<BizboxUserListResult> | SecurityBox.findAllOnlineUsers(int firstIndex, int maxLength)
java.util.Collection<BizboxUserListResult> | SecurityBox.findAllUsers(int firstIndex, int maxLength)
java.util.Collection<BizboxUserListResult> | SecurityBox.findOnlineUsersByUserName(java.lang.String userName, int firstIndex, int maxLength)
java.util.Collection<BizboxUserListResult> | SecurityBox.findUsers(java.lang.String userName, int status, java.util.Date lastLoginFrom, java.util.Date lastLoginTo, int type, int locked, int firstIndex, int maxLength)
java.util.Collection<BizboxUserListResult> | SecurityBox.findUsersByEmployeeId(java.lang.String employeeId, int firstIndex, int maxLength)
java.util.Collection<BizboxUserListResult> | SecurityBox.findUsersByPermission(java.lang.String permissionId, int firstIndex, int maxLength)
java.util.Collection<BizboxUserListResult> | SecurityBox.findUsersByRole(java.lang.String roleId, int firstIndex, int maxLength)
java.util.Collection<BizboxUserListResult> | SecurityBox.findUsersByUserName(java.lang.String userName, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BizboxUserVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BizboxUserVO

Packages that use BizboxUserVO
bb.common.box

Uses of BizboxUserVO in bb.common.box

Methods in bb.common.box that return BizboxUserVO
BizboxUserVO | SecurityBox.addUser(BizboxUserVO vo)
BizboxUserVO | SecurityBox.getUserByPk(java.lang.String userName)
BizboxUserVO | SecurityBox.getUserBySelf()

Methods in bb.common.box with parameters of type BizboxUserVO
BizboxUserVO | SecurityBox.addUser(BizboxUserVO vo)
void | SecurityBox.updateUser(BizboxUserVO vo, java.lang.String[] roleIDs)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BizException

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BizException

Packages that use BizException
bb.common

Uses of BizException in bb.common

Methods in bb.common that return BizException
static BizException BizException.getBizException(DBAccessException ex, java.lang.String target, Reason reason)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BIZReason

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BIZReason

No usage of bb.common.BIZReason

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BizTarget

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BizTarget

No usage of bb.common.BizTarget

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BomApprovalVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BomApprovalVO

Packages that use BomApprovalVO
bb.common.box

Uses of BomApprovalVO in bb.common.box

Methods in bb.common.box that return BomApprovalVO
BomApprovalVO | EngineeringBox.addBomApproval(java.lang.String employeeId)
BomApprovalVO | EngineeringBox.getBomApprovalByEmployeeId(java.lang.String employeeId)

Methods in bb.common.box that return types with arguments of type BomApprovalVO
 java.util.Collection<BomApprovalVO> EngineeringBox.findAllBomApprovals(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type BomApprovalVO
 void EngineeringBox.updateBomApproval(BomApprovalVO bomApprovalVO)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BOMCanAssyAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BOMCanAssyAgent

Packages that use BOMCanAssyAgent
bb.common.box

Uses of BOMCanAssyAgent in bb.common.box

Methods in bb.common.box with parameters of type BOMCanAssyAgent
 java.util.Collection<PartPK> WorkOrderBox.getPartCanAssy(BOMCanAssyAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BOMCanAssyListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BOMCanAssyListResult

Packages that use BOMCanAssyListResult
bb.common.box

Uses of BOMCanAssyListResult in bb.common.box

Methods in bb.common.box that return BOMCanAssyListResult
 BOMCanAssyListResult WorkOrderBox.getBOMCanAssyListResult(PartPK pk)

Methods in bb.common.box that return types with arguments of type BOMCanAssyListResult
 java.util.Collection<BOMCanAssyListResult> WorkOrderBox.getBOMCanAssyListResults(java.util.ArrayList<PartPK> pks)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BomItemWithOEMResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BomItemWithOEMResult

No usage of bb.common.BomItemWithOEMResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BomPickListItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BomPickListItemResult

No usage of bb.common.BomPickListItemResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BomPickListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BomPickListResult

Packages that use BomPickListResult
bb.common.box

Uses of BomPickListResult in bb.common.box

Methods in bb.common.box that return BomPickListResult
BomPickListResult | WarehouseBox.getBomPickList(BillPK pk, java.math.BigDecimal qty)
BomPickListResult | WarehouseBox.getToolListsPickList(BillPK pk, java.math.BigDecimal qty)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BOMTreeRollUPMap

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BOMTreeRollUPMap

Packages that use BOMTreeRollUPMap
bb.common.box

Uses of BOMTreeRollUPMap in bb.common.box

Methods in bb.common.box that return BOMTreeRollUPMap
 BOMTreeRollUPMap EngineeringBox.getFullBOMTreeRollUPMap(BillPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BomWithOEMResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BomWithOEMResult

Packages that use BomWithOEMResult
bb.common.box

Uses of BomWithOEMResult in bb.common.box

Methods in bb.common.box that return BomWithOEMResult
 BomWithOEMResult EngineeringBox.getBomWithOEMResult(BillPK pk, java.lang.String mfgId)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BudgetListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BudgetListResult

Packages that use BudgetListResult
bb.common

Uses of BudgetListResult in bb.common

Methods in bb.common that return types with arguments of type BudgetListResult
java.util.List<BudgetListResult> | AllBudgetResult.getBudgetForExpenseListResult()
java.util.List<BudgetListResult> | AllBudgetResult.getBudgetForRevenueListResult()

Method parameters in bb.common with type arguments of type BudgetListResult
void | AllBudgetResult.setBudgetForExpenseListResult(java.util.List<BudgetListResult> budgetForExpenseListResult)
void | AllBudgetResult.setBudgetForRevenueListResult(java.util.List<BudgetListResult> budgetForRevenueListResult)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.BuyerCodeVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.BuyerCodeVO

Packages that use BuyerCodeVO
bb.common.box

Uses of BuyerCodeVO in bb.common.box

Methods in bb.common.box that return BuyerCodeVO
BuyerCodeVO | CompanyBox.addBuyerCode(BuyerCodeVO vo)
BuyerCodeVO | CompanyBox.getBuyerCodeByBuyerCode(java.lang.String buyerCode)
BuyerCodeVO | CompanyBox.updateBuyerCode(BuyerCodeVO vo)

Methods in bb.common.box that return types with arguments of type BuyerCodeVO
java.util.Collection<BuyerCodeVO> | CompanyBox.findAllBuyerCode(int firstIndex, int maxLength)
java.util.Collection<BuyerCodeVO> | CompanyBox.findBuyerCodeByBuyerCodeLike(java.lang.String buyerCodeReg, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type BuyerCodeVO
BuyerCodeVO | CompanyBox.addBuyerCode(BuyerCodeVO vo)
BuyerCodeVO | CompanyBox.updateBuyerCode(BuyerCodeVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CarrierPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CarrierPK

Packages that use CarrierPK
bb.common
bb.common.box

Uses of CarrierPK in bb.common

Methods in bb.common that return CarrierPK
 CarrierPK CarrierVO.getPk()

Methods in bb.common with parameters of type CarrierPK
 void CarrierVO.setPk(CarrierPK pk)

Constructors in bb.common with parameters of type CarrierPK
CarrierVO(CarrierPK pk, java.lang.String carrier, java.lang.String carrierAccount, java.lang.String remarks)
full constructor

Uses of CarrierPK in bb.common.box

Methods in bb.common.box with parameters of type CarrierPK
 CarrierVO AddressBox.getCarrierByPk(CarrierPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CarrierVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CarrierVO

Packages that use CarrierVO
bb.common.box

Uses of CarrierVO in bb.common.box

Methods in bb.common.box that return CarrierVO
CarrierVO | AddressBox.addCarrier(CarrierVO vo)
CarrierVO | AddressBox.getCarrierByPk(CarrierPK pk)

Methods in bb.common.box that return types with arguments of type CarrierVO
java.util.Collection<CarrierVO> | AddressBox.findCarrierByAddressIds(java.lang.String[] addressIds)
java.util.Collection<CarrierVO> | AddressBox.findCarriersByAddressId(java.lang.String addressId)
java.util.Collection<CarrierVO> | AddressBox.updateCarrier(CarrierVO vo)
java.util.Collection<CarrierVO> | AddressBox.updateCarrier(java.util.Vector carrierVoList, java.lang.String addressId)

Methods in bb.common.box with parameters of type CarrierVO
CarrierVO | AddressBox.addCarrier(CarrierVO vo)
void | AddressBox.deleteCarrier(CarrierVO vo)
java.util.Collection<CarrierVO> | AddressBox.updateCarrier(CarrierVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CashFlowByMonthReportResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CashFlowByMonthReportResult

Packages that use CashFlowByMonthReportResult
bb.common.box

Uses of CashFlowByMonthReportResult in bb.common.box

Methods in bb.common.box that return CashFlowByMonthReportResult
 CashFlowByMonthReportResult AccountingBox.findCashFlowByMonthReport(java.lang.String companyUnitId, java.lang.String startMonth, java.lang.String endMonth)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CashFlowMonthTotalResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CashFlowMonthTotalResult

Packages that use CashFlowMonthTotalResult
bb.common.box

Uses of CashFlowMonthTotalResult in bb.common.box

Methods in bb.common.box that return types with arguments of type CashFlowMonthTotalResult
 java.util.Collection<CashFlowMonthTotalResult> AccountingBox.findCashFlowMonthTotalBudget(java.lang.String companyUnitId, java.lang.String startMonth, java.lang.String endMonth)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CashierVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CashierVO

Packages that use CashierVO
bb.common.box

Uses of CashierVO in bb.common.box

Methods in bb.common.box that return CashierVO
CashierVO | CompanyBox.addCashier(CashierVO vo)
CashierVO | CompanyBox.getCashier(java.lang.String cashier)
CashierVO | CompanyBox.updateCashier(CashierVO vo)

Methods in bb.common.box that return types with arguments of type CashierVO
 java.util.Collection<CashierVO> CompanyBox.findAllCashier(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type CashierVO
CashierVO | CompanyBox.addCashier(CashierVO vo)
void | CompanyBox.deleteCashier(CashierVO vo)
CashierVO | CompanyBox.updateCashier(CashierVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CatalogVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CatalogVO

Packages that use CatalogVO
bb.common.box

Uses of CatalogVO in bb.common.box

Methods in bb.common.box that return CatalogVO
 CatalogVO SalesBox.getCatalog(java.lang.String catalogID)

Methods in bb.common.box that return types with arguments of type CatalogVO
 java.util.Collection<CatalogVO> SalesBox.findCatalogs(java.lang.String catalogID, java.lang.String description, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type CatalogVO
java.lang.String | SalesBox.addCatalog(CatalogVO vo)
java.lang.String | SalesBox.updateCatalog(CatalogVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CertificateDescriptionVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CertificateDescriptionVO

Packages that use CertificateDescriptionVO
bb.common.box

Uses of CertificateDescriptionVO in bb.common.box

Methods in bb.common.box that return CertificateDescriptionVO
CertificateDescriptionVO | QualityBox.addCertificateDescription(CertificateDescriptionVO vo)
CertificateDescriptionVO | QualityBox.findCertificateDescByPk(int pk)
CertificateDescriptionVO | QualityBox.updateCertificateDescription(CertificateDescriptionVO vo)

Methods in bb.common.box that return types with arguments of type CertificateDescriptionVO
java.util.Collection<CertificateDescriptionVO> | QualityBox.findAllCertificateDescs()
java.util.Collection<CertificateDescriptionVO> | QualityBox.findCertificateDescs(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type CertificateDescriptionVO
CertificateDescriptionVO | QualityBox.addCertificateDescription(CertificateDescriptionVO vo)
void | QualityBox.deleteCertificateDescription(CertificateDescriptionVO vo)
CertificateDescriptionVO | QualityBox.updateCertificateDescription(CertificateDescriptionVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ChangeStdCostWorkSheetItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ChangeStdCostWorkSheetItemPK

Packages that use ChangeStdCostWorkSheetItemPK
bb.common
bb.common.box

Uses of ChangeStdCostWorkSheetItemPK in bb.common

Methods in bb.common that return ChangeStdCostWorkSheetItemPK
 ChangeStdCostWorkSheetItemPK ChangeStdCostWorkSheetItemVO.getPk()

Methods in bb.common with parameters of type ChangeStdCostWorkSheetItemPK
 void ChangeStdCostWorkSheetItemVO.setPk(ChangeStdCostWorkSheetItemPK pk)

Uses of ChangeStdCostWorkSheetItemPK in bb.common.box

Methods in bb.common.box with parameters of type ChangeStdCostWorkSheetItemPK
void | AccountingBox.deleteChangeStdCostWorkSheetItem(ChangeStdCostWorkSheetItemPK pk)
boolean | AccountingBox.isChangeStdCostWorkSheetItemExistent(ChangeStdCostWorkSheetItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ChangeStdCostWorkSheetItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ChangeStdCostWorkSheetItemVO

Packages that use ChangeStdCostWorkSheetItemVO
bb.common.box

Uses of ChangeStdCostWorkSheetItemVO in bb.common.box

Methods in bb.common.box that return types with arguments of type ChangeStdCostWorkSheetItemVO
 java.util.Collection<ChangeStdCostWorkSheetItemVO> AccountingBox.findChangeStdCostWorkSheetItem(java.lang.Long ii, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type ChangeStdCostWorkSheetItemVO
void | AccountingBox.addChangeStdCostWorkSheetItem(ChangeStdCostWorkSheetItemVO vo)
void | AccountingBox.updateChangeStdCostWorkSheetItem(ChangeStdCostWorkSheetItemVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ChangeStdCostWorkSheetVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ChangeStdCostWorkSheetVO

Packages that use ChangeStdCostWorkSheetVO
bb.common.box

Uses of ChangeStdCostWorkSheetVO in bb.common.box

Methods in bb.common.box that return ChangeStdCostWorkSheetVO
 ChangeStdCostWorkSheetVO AccountingBox.getChangeStdCostWorkSheet(java.lang.Long ii)

Methods in bb.common.box that return types with arguments of type ChangeStdCostWorkSheetVO
 java.util.Collection<ChangeStdCostWorkSheetVO> AccountingBox.findChangeStdCostWorkSheet(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type ChangeStdCostWorkSheetVO
java.lang.Long | AccountingBox.addChangeStdCostWorkSheet(ChangeStdCostWorkSheetVO vo)
void | AccountingBox.updateChangeStdCostWorkSheet(ChangeStdCostWorkSheetVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CheckInvoiceItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CheckInvoiceItemListResult

Packages that use CheckInvoiceItemListResult
bb.common.box

Uses of CheckInvoiceItemListResult in bb.common.box

Method parameters in bb.common.box with type arguments of type CheckInvoiceItemListResult
 void CompanyBox.updateSignature(java.util.List<CheckInvoiceItemListResult> results, byte[] elecSignature)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CheckRunItemTotalResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CheckRunItemTotalResult

Packages that use CheckRunItemTotalResult
bb.common.box

Uses of CheckRunItemTotalResult in bb.common.box

Methods in bb.common.box that return CheckRunItemTotalResult
 CheckRunItemTotalResult AccountingBox.getCheckRunItemTotal(java.lang.String checkRunNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ClientAutoInvokeMethodsManager

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ClientAutoInvokeMethodsManager

No usage of bb.common.ClientAutoInvokeMethodsManager

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ClientListItem

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ClientListItem

Packages that use ClientListItem
bb.common.box

Uses of ClientListItem in bb.common.box

Methods in bb.common.box that return types with arguments of type ClientListItem
java.util.Collection<ClientListItem> | CustomerServiceBox.getActiveQuestionList(java.lang.String language)
java.util.Collection<ClientListItem> | CustomerServiceBox.getAnswerList(java.lang.String questionId, java.lang.String language)
java.util.Collection<ClientListItem> | CustomerServiceBox.getQuestionList(java.lang.String language)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ClosingStatementItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ClosingStatementItemResult

No usage of bb.common.ClosingStatementItemResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ClosingStatementResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ClosingStatementResult

Packages that use ClosingStatementResult
bb.common.box

Uses of ClosingStatementResult in bb.common.box

Methods in bb.common.box that return ClosingStatementResult
 ClosingStatementResult AccountingBox.findClosingStatement(java.lang.String monthYear, java.lang.String companyUnitId)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ClosingStatementTotalResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ClosingStatementTotalResult

Packages that use ClosingStatementTotalResult
bb.common

Uses of ClosingStatementTotalResult in bb.common

Methods in bb.common that return ClosingStatementTotalResult
ClosingStatementTotalResult | ClosingStatementResult.getCostOfGoodsSold()
ClosingStatementTotalResult | ClosingStatementResult.getCostOfLabor()
ClosingStatementTotalResult | ClosingStatementResult.getGrossNetProfit()
ClosingStatementTotalResult | ClosingStatementResult.getGrossRevenue()
ClosingStatementTotalResult | ClosingStatementResult.getIncomeTax()
ClosingStatementTotalResult | ClosingStatementResult.getNetProfit()
ClosingStatementTotalResult | ClosingStatementResult.getNetProfitBeforeOtherIncome()
ClosingStatementTotalResult | ClosingStatementResult.getNetProfitBeforeWriteOffs()
ClosingStatementTotalResult | ClosingStatementResult.getNetProfiteBeforeIncomeTax()
ClosingStatementTotalResult | ClosingStatementResult.getOperatingExpenses()
ClosingStatementTotalResult | ClosingStatementResult.getOtherExpenses()
ClosingStatementTotalResult | ClosingStatementResult.getOtherIncome()
ClosingStatementTotalResult | ClosingStatementResult.getRetainedEarningTotal()
ClosingStatementTotalResult | ClosingStatementResult.getRevenueTotal()
ClosingStatementTotalResult | ClosingStatementResult.getWriteOffExpenses()

Methods in bb.common with parameters of type ClosingStatementTotalResult
void | ClosingStatementResult.setCostOfGoodsSold(ClosingStatementTotalResult costOfGoodsSold)
void | ClosingStatementResult.setCostOfLabor(ClosingStatementTotalResult costOfLabor)
void | ClosingStatementResult.setGrossNetProfit(ClosingStatementTotalResult grossNetProfit)
void | ClosingStatementResult.setGrossRevenue(ClosingStatementTotalResult grossRevenue)
void | ClosingStatementResult.setIncomeTax(ClosingStatementTotalResult incomeTax)
void | ClosingStatementResult.setNetProfit(ClosingStatementTotalResult netProfit)
void | ClosingStatementResult.setNetProfitBeforeOtherIncome(ClosingStatementTotalResult netProfitBeforeOtherIncome)
void | ClosingStatementResult.setNetProfitBeforeWriteOffs(ClosingStatementTotalResult netProfitBeforeWriteOffs)
void | ClosingStatementResult.setNetProfiteBeforeIncomeTax(ClosingStatementTotalResult netProfiteBeforeIncomeTax)
void | ClosingStatementResult.setOperatingExpenses(ClosingStatementTotalResult operatingExpenses)
void | ClosingStatementResult.setOtherExpenses(ClosingStatementTotalResult otherExpenses)
void | ClosingStatementResult.setOtherIncome(ClosingStatementTotalResult otherIncome)
void | ClosingStatementResult.setRetainedEarningTotal(ClosingStatementTotalResult retainedEarningTotal)
void | ClosingStatementResult.setRevenueTotal(ClosingStatementTotalResult revenueTotal)
void | ClosingStatementResult.setWriteOffExpenses(ClosingStatementTotalResult writeOffExpenses)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CommonPrintTemplateVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CommonPrintTemplateVO

Packages that use CommonPrintTemplateVO
bb.common.box

Uses of CommonPrintTemplateVO in bb.common.box

Methods in bb.common.box that return CommonPrintTemplateVO
CommonPrintTemplateVO | CompanyBox.addCommonPrintTemplate(CommonPrintTemplateVO vo)
CommonPrintTemplateVO | CompanyBox.getCommonPrintTemplate(int id)
CommonPrintTemplateVO | CompanyBox.updateCommonPrintTemplate(CommonPrintTemplateVO vo)

Methods in bb.common.box that return types with arguments of type CommonPrintTemplateVO
 java.util.Collection<CommonPrintTemplateVO> CompanyBox.findCommonPrintTemplate(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type CommonPrintTemplateVO
CommonPrintTemplateVO | CompanyBox.addCommonPrintTemplate(CommonPrintTemplateVO vo)
void | CompanyBox.deleteCommonPrintTemplate(CommonPrintTemplateVO vo)
CommonPrintTemplateVO | CompanyBox.updateCommonPrintTemplate(CommonPrintTemplateVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CompanyUnitAccountPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CompanyUnitAccountPK

Packages that use CompanyUnitAccountPK
bb.common
bb.common.box

Uses of CompanyUnitAccountPK in bb.common

Methods in bb.common that return CompanyUnitAccountPK
 CompanyUnitAccountPK CompanyUnitAccountVO.getPk()

Methods in bb.common that return types with arguments of type CompanyUnitAccountPK
java.util.Map<CompanyUnitAccountPK,java.math.BigDecimal> | AccountBalanceAgent.getCreditAccountBalance()
java.util.Map<CompanyUnitAccountPK,java.math.BigDecimal> | AccountBalanceAgent.getDebitAccountBalance()
java.util.Map<CompanyUnitAccountPK,java.math.BigDecimal> | AccountBalanceAgent.getOrgCreditAccountBalance()
java.util.Map<CompanyUnitAccountPK,java.math.BigDecimal> | AccountBalanceAgent.getOrgDebitAccountBalance()

Methods in bb.common with parameters of type CompanyUnitAccountPK
 void CompanyUnitAccountVO.setPk(CompanyUnitAccountPK pk)

Method parameters in bb.common with type arguments of type CompanyUnitAccountPK
void | AccountBalanceAgent.setCreditAccountBalance(java.util.Map<CompanyUnitAccountPK,java.math.BigDecimal> creditAccountBalance)
void | AccountBalanceAgent.setDebitAccountBalance(java.util.Map<CompanyUnitAccountPK,java.math.BigDecimal> debitAccountBalance)
void | AccountBalanceAgent.setOrgCreditAccountBalance(java.util.Map<CompanyUnitAccountPK,java.math.BigDecimal> orgCreditAccountBalance)
void | AccountBalanceAgent.setOrgDebitAccountBalance(java.util.Map<CompanyUnitAccountPK,java.math.BigDecimal> orgDebitAccountBalance)

Constructors in bb.common with parameters of type CompanyUnitAccountPK
CompanyUnitAccountVO(CompanyUnitAccountPK pk)
full constructor

Uses of CompanyUnitAccountPK in bb.common.box

Methods in bb.common.box with parameters of type CompanyUnitAccountPK
void | CompanyBox.deleteCompanyUnitAccount(CompanyUnitAccountPK pk)
CompanyUnitAccountVO | CompanyBox.getCompanyUnitAccountByPk(CompanyUnitAccountPK pk)
boolean | CompanyBox.isCompanyUnitAccountExistent(CompanyUnitAccountPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CompanyUnitAccountVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CompanyUnitAccountVO

Packages that use CompanyUnitAccountVO
bb.common.box

Uses of CompanyUnitAccountVO in bb.common.box

Methods in bb.common.box that return CompanyUnitAccountVO
CompanyUnitAccountVO | CompanyBox.addCompanyUnitAccount(CompanyUnitAccountVO vo)
CompanyUnitAccountVO | CompanyBox.getCompanyUnitAccountByPk(CompanyUnitAccountPK pk)

Methods in bb.common.box that return types with arguments of type CompanyUnitAccountVO
java.util.Collection<CompanyUnitAccountVO> | CompanyBox.findAllCompanyUnitAccount(int firstIndex, int maxLength)
java.util.Collection<CompanyUnitAccountVO> | CompanyBox.getCompanyUnitAccountByCompanyUnit(java.lang.String companyUnitId)

Methods in bb.common.box with parameters of type CompanyUnitAccountVO
CompanyUnitAccountVO | CompanyBox.addCompanyUnitAccount(CompanyUnitAccountVO vo)
void | CompanyBox.updateCompanyUnitAccount(CompanyUnitAccountVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CompanyUnitVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CompanyUnitVO

Packages that use CompanyUnitVO
bb.common.box

Uses of CompanyUnitVO in bb.common.box

Methods in bb.common.box that return CompanyUnitVO
CompanyUnitVO | CompanyBox.addCompanyUnit(CompanyUnitVO vo)
CompanyUnitVO | CompanyBox.getCompanyUnitByPk(java.lang.String id)
CompanyUnitVO | CompanyBox.updateCompanyUnit(CompanyUnitVO vo)

Methods in bb.common.box that return types with arguments of type CompanyUnitVO
java.util.Collection<CompanyUnitVO> | CompanyBox.findAllCompanyUnit(int firstIndex, int maxLength)
java.util.Collection<CompanyUnitVO> | CompanyBox.findCompanyUnitList(java.lang.String id, java.lang.String name, java.lang.String type, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type CompanyUnitVO
CompanyUnitVO | CompanyBox.addCompanyUnit(CompanyUnitVO vo)
CompanyUnitVO | CompanyBox.updateCompanyUnit(CompanyUnitVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CompanyVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CompanyVO

Packages that use CompanyVO
bb.common.box

Uses of CompanyVO in bb.common.box

Methods in bb.common.box that return CompanyVO
CompanyVO | CompanyBox.getCompanySettings()
CompanyVO | CompanyBox.updateCompanyId(java.lang.String addressId)
CompanyVO | CompanyBox.updateCompanySettings(CompanyVO vo)
CompanyVO | CompanyBox.updateInitStep(java.lang.String initStep)

Methods in bb.common.box with parameters of type CompanyVO
 CompanyVO CompanyBox.updateCompanySettings(CompanyVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Configure

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Configure

No usage of bb.common.Configure

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Configure.LoginStatus

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Configure.LoginStatus

No usage of bb.common.Configure.LoginStatus

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Configure.Module

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Configure.Module

No usage of bb.common.Configure.Module

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Configure.Organization

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Configure.Organization

No usage of bb.common.Configure.Organization

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Configure.UpdatePermission

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Configure.UpdatePermission

No usage of bb.common.Configure.UpdatePermission

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Configure.UserLocked

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Configure.UserLocked

No usage of bb.common.Configure.UserLocked

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Configure.UserType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Configure.UserType

No usage of bb.common.Configure.UserType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant

No usage of bb.common.Constant

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.ActiveStatus

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.ActiveStatus

No usage of bb.common.Constant.ActiveStatus

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.AddressType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.AddressType

No usage of bb.common.Constant.AddressType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.AgeLevel

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.AgeLevel

No usage of bb.common.Constant.AgeLevel

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.AmountType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.AmountType

No usage of bb.common.Constant.AmountType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.ARDiscountMethod

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.ARDiscountMethod

No usage of bb.common.Constant.ARDiscountMethod

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.CategoryReportType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.CategoryReportType

No usage of bb.common.Constant.CategoryReportType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.CategoryType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.CategoryType

No usage of bb.common.Constant.CategoryType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.ChartOfAccountSubType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.ChartOfAccountSubType

No usage of bb.common.Constant.ChartOfAccountSubType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.ChartOfAccountType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.ChartOfAccountType

No usage of bb.common.Constant.ChartOfAccountType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.CheckType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.CheckType

No usage of bb.common.Constant.CheckType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.CostControl

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.CostControl

No usage of bb.common.Constant.CostControl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.CustomerVendorMailType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.CustomerVendorMailType

No usage of bb.common.Constant.CustomerVendorMailType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.CVAddressType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.CVAddressType

No usage of bb.common.Constant.CVAddressType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.CycleCountPeriodUnit

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.CycleCountPeriodUnit

No usage of bb.common.Constant.CycleCountPeriodUnit

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.DataFilterType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.DataFilterType

No usage of bb.common.Constant.DataFilterType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.DateType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.DateType

No usage of bb.common.Constant.DateType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.DebitOrCredit

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.DebitOrCredit

No usage of bb.common.Constant.DebitOrCredit

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.Depreciation

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.Depreciation

No usage of bb.common.Constant.Depreciation

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.Depreciation.DepreciateStatus

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.Depreciation.DepreciateStatus

No usage of bb.common.Constant.Depreciation.DepreciateStatus

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.Depreciation.DepreciationMethod

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.Depreciation.DepreciationMethod

No usage of bb.common.Constant.Depreciation.DepreciationMethod

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.Depreciation.UsingType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.Depreciation.UsingType

No usage of bb.common.Constant.Depreciation.UsingType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.Download

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.Download

No usage of bb.common.Constant.Download

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.DrawingType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.DrawingType

No usage of bb.common.Constant.DrawingType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.ECRPriority

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.ECRPriority

No usage of bb.common.Constant.ECRPriority

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.EmployeeSecurityLevel

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.EmployeeSecurityLevel

No usage of bb.common.Constant.EmployeeSecurityLevel

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.EmployeeStatus

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.EmployeeStatus

No usage of bb.common.Constant.EmployeeStatus

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.EngineeringSharingImportDataType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.EngineeringSharingImportDataType

No usage of bb.common.Constant.EngineeringSharingImportDataType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.EngineeringSharingImportType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.EngineeringSharingImportType

No usage of bb.common.Constant.EngineeringSharingImportType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.EquipmentStatus

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.EquipmentStatus

No usage of bb.common.Constant.EquipmentStatus

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.ExchangeRateType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.ExchangeRateType

No usage of bb.common.Constant.ExchangeRateType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.FileExt

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.FileExt

No usage of bb.common.Constant.FileExt

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.GLApprovedType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.GLApprovedType

No usage of bb.common.Constant.GLApprovedType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.GLStyle

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.GLStyle

No usage of bb.common.Constant.GLStyle

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.GLType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.GLType

No usage of bb.common.Constant.GLType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.InventoryCostMothed

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.InventoryCostMothed

No usage of bb.common.Constant.InventoryCostMothed

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.InventoryWorkSheetOrderBy

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.InventoryWorkSheetOrderBy

No usage of bb.common.Constant.InventoryWorkSheetOrderBy

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.IrDateType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.IrDateType

No usage of bb.common.Constant.IrDateType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.IRType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.IRType

No usage of bb.common.Constant.IRType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.IssuedFrom

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.IssuedFrom

No usage of bb.common.Constant.IssuedFrom

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.LanguageCode

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.LanguageCode

No usage of bb.common.Constant.LanguageCode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.LocalSettings

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.LocalSettings

No usage of bb.common.Constant.LocalSettings

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.LoginType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.LoginType

No usage of bb.common.Constant.LoginType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.MakeBuy

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.MakeBuy

No usage of bb.common.Constant.MakeBuy

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.MiscDocType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.MiscDocType

No usage of bb.common.Constant.MiscDocType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.NaRecTo

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.NaRecTo

No usage of bb.common.Constant.NaRecTo

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.NcrApprovableType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.NcrApprovableType

No usage of bb.common.Constant.NcrApprovableType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.NoticeAction

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.NoticeAction

No usage of bb.common.Constant.NoticeAction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.NoticeType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.NoticeType

No usage of bb.common.Constant.NoticeType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.OITypeSerialNumberType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.OITypeSerialNumberType

No usage of bb.common.Constant.OITypeSerialNumberType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.OrderType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.OrderType

No usage of bb.common.Constant.OrderType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.Package

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.Package

No usage of bb.common.Constant.Package

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.PageCycleCount

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.PageCycleCount

No usage of bb.common.Constant.PageCycleCount

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.PAOffsetType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.PAOffsetType

No usage of bb.common.Constant.PAOffsetType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.PartFrom

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.PartFrom

No usage of bb.common.Constant.PartFrom

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.PartNumberGenerateType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.PartNumberGenerateType

No usage of bb.common.Constant.PartNumberGenerateType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.PartQtyType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.PartQtyType

No usage of bb.common.Constant.PartQtyType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.PayableMethod

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.PayableMethod

No usage of bb.common.Constant.PayableMethod

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.PeriodUnit

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.PeriodUnit

No usage of bb.common.Constant.PeriodUnit

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.PosOrderType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.PosOrderType

No usage of bb.common.Constant.PosOrderType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.Prefix

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.Prefix

No usage of bb.common.Constant.Prefix

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.PrintTemplateType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.PrintTemplateType

No usage of bb.common.Constant.PrintTemplateType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.ReceiveCondition

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.ReceiveCondition

No usage of bb.common.Constant.ReceiveCondition

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.ReceivedTo

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.ReceivedTo

No usage of bb.common.Constant.ReceivedTo

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.SalesTaxReportType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.SalesTaxReportType

No usage of bb.common.Constant.SalesTaxReportType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.SGType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.SGType

No usage of bb.common.Constant.SGType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.StatementType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.StatementType

No usage of bb.common.Constant.StatementType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.Status

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.Status

No usage of bb.common.Constant.Status

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.SystemUserGroup

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.SystemUserGroup

No usage of bb.common.Constant.SystemUserGroup

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.TaxType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.TaxType

No usage of bb.common.Constant.TaxType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.TermsConditonType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.TermsConditonType

No usage of bb.common.Constant.TermsConditonType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.TrackingNumberType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.TrackingNumberType

No usage of bb.common.Constant.TrackingNumberType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.TransactionType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.TransactionType

No usage of bb.common.Constant.TransactionType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.TransferType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.TransferType

No usage of bb.common.Constant.TransferType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.Upload

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.Upload

No usage of bb.common.Constant.Upload

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.VendorQualityStatus

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.VendorQualityStatus

No usage of bb.common.Constant.VendorQualityStatus

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.WorkCenterSearchType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.WorkCenterSearchType

No usage of bb.common.Constant.WorkCenterSearchType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.WorkCenterType

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.WorkCenterType

No usage of bb.common.Constant.WorkCenterType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.WorkLevel

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.WorkLevel

No usage of bb.common.Constant.WorkLevel

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Constant.YesNO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Constant.YesNO

No usage of bb.common.Constant.YesNO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ContractPriceCustomerPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ContractPriceCustomerPK

Packages that use ContractPriceCustomerPK
bb.common
bb.common.box

Uses of ContractPriceCustomerPK in bb.common

Methods in bb.common that return ContractPriceCustomerPK
 ContractPriceCustomerPK ContractPriceCustomerVO.getPk()

Methods in bb.common with parameters of type ContractPriceCustomerPK
 void ContractPriceCustomerVO.setPk(ContractPriceCustomerPK pk)

Uses of ContractPriceCustomerPK in bb.common.box

Methods in bb.common.box with parameters of type ContractPriceCustomerPK
ContractPriceCustomerVO | SalesBox.getContractPriceCustomer(ContractPriceCustomerPK pk)
boolean | SalesBox.isContractPriceCustomerExistent(ContractPriceCustomerPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ContractPriceCustomerVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ContractPriceCustomerVO

Packages that use ContractPriceCustomerVO
bb.common
bb.common.box

Uses of ContractPriceCustomerVO in bb.common

Methods in bb.common that return types with arguments of type ContractPriceCustomerVO
 java.util.HashSet<ContractPriceCustomerVO> ImportContractPriceData.getCustomers()

Method parameters in bb.common with type arguments of type ContractPriceCustomerVO
 void ImportContractPriceData.setCustomers(java.util.HashSet<ContractPriceCustomerVO> customers)

Constructor parameters in bb.common with type arguments of type ContractPriceCustomerVO
ImportContractPriceData(java.lang.String contractPrice, java.util.HashSet<ContractPriceItemVO> items, java.util.HashSet<ContractPriceCustomerVO> customers)

Uses of ContractPriceCustomerVO in bb.common.box

Methods in bb.common.box that return ContractPriceCustomerVO
ContractPriceCustomerVO | SalesBox.addContractPriceCustomer(ContractPriceCustomerVO vo)
ContractPriceCustomerVO | SalesBox.getContractPriceCustomer(ContractPriceCustomerPK pk)
ContractPriceCustomerVO | SalesBox.updateContractPriceCustomer(ContractPriceCustomerVO vo)

Methods in bb.common.box that return types with arguments of type ContractPriceCustomerVO
java.util.Collection<ContractPriceCustomerVO> | SalesBox.findContractCustomersByContractNumber(java.lang.String contractNumber, int firstIndex, int maxLength)
java.util.HashMap<java.lang.String,ContractPriceCustomerVO> | CompanyBox.findContractPriceCustomerByCustomList(java.lang.String contractNumber, java.util.HashSet<java.lang.String> ids)
java.util.Collection<ContractPriceCustomerVO> | SalesBox.findContractsByAddressId(java.lang.String addressIdRegex, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type ContractPriceCustomerVO
ContractPriceCustomerVO | SalesBox.addContractPriceCustomer(ContractPriceCustomerVO vo)
void | SalesBox.deleteContractPriceCustomer(ContractPriceCustomerVO cpcVO)
ContractPriceCustomerVO | SalesBox.updateContractPriceCustomer(ContractPriceCustomerVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ContractPriceItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ContractPriceItemPK

Packages that use ContractPriceItemPK
bb.common
bb.common.box

Uses of ContractPriceItemPK in bb.common

Methods in bb.common that return ContractPriceItemPK
 ContractPriceItemPK ContractPriceItemVO.getPk()

Methods in bb.common with parameters of type ContractPriceItemPK
 void ContractPriceItemVO.setPk(ContractPriceItemPK pk)

Uses of ContractPriceItemPK in bb.common.box

Methods in bb.common.box with parameters of type ContractPriceItemPK
ContractPriceItemVO | SalesBox.getContractPriceItem(ContractPriceItemPK pk)
boolean | SalesBox.isContractPriceItemExistent(ContractPriceItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ContractPriceItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ContractPriceItemVO

Packages that use ContractPriceItemVO
bb.common
bb.common.box

Uses of ContractPriceItemVO in bb.common

Methods in bb.common that return types with arguments of type ContractPriceItemVO
 java.util.HashSet<ContractPriceItemVO> ImportContractPriceData.getItems()

Method parameters in bb.common with type arguments of type ContractPriceItemVO
 void ImportContractPriceData.setItems(java.util.HashSet<ContractPriceItemVO> items)

Constructor parameters in bb.common with type arguments of type ContractPriceItemVO
ImportContractPriceData(java.lang.String contractPrice, java.util.HashSet<ContractPriceItemVO> items, java.util.HashSet<ContractPriceCustomerVO> customers)

Uses of ContractPriceItemVO in bb.common.box

Methods in bb.common.box that return ContractPriceItemVO
ContractPriceItemVO | SalesBox.addContractPriceItem(ContractPriceItemVO vo)
ContractPriceItemVO | SalesBox.getContractPriceItem(ContractPriceItemPK pk)
ContractPriceItemVO | SalesBox.updateContractPriceItem(ContractPriceItemVO vo)

Methods in bb.common.box that return types with arguments of type ContractPriceItemVO
java.util.Collection<ContractPriceItemVO> | SalesBox.addContractPriceItems(java.util.ArrayList list)
java.util.Collection<ContractPriceItemVO> | SalesBox.findContractItemsByContractNumber(java.lang.String contractNumber, int firstIndex, int maxLength)
java.util.HashMap<PartPK,ContractPriceItemVO> | CompanyBox.findContractPriceItemByPartNumberList(java.lang.String contractNumber, java.util.HashSet<PartPK> pks)

Methods in bb.common.box with parameters of type ContractPriceItemVO
ContractPriceItemVO | SalesBox.addContractPriceItem(ContractPriceItemVO vo)
void | SalesBox.deleteContractPriceItem(ContractPriceItemVO cpiVO)
ContractPriceItemVO | SalesBox.updateContractPriceItem(ContractPriceItemVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ContractPriceVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ContractPriceVO

Packages that use ContractPriceVO
bb.common.box

Uses of ContractPriceVO in bb.common.box

Methods in bb.common.box that return ContractPriceVO
 ContractPriceVO SalesBox.getContractPriceById(java.lang.String cpNumber)

Methods in bb.common.box that return types with arguments of type ContractPriceVO
java.util.Collection<ContractPriceVO> | SalesBox.findAllContracts(int firstIndex, int maxLength)
java.util.Collection<ContractPriceVO> | SalesBox.findContractsByContractNumber(java.lang.String contractNumber, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type ContractPriceVO
java.lang.String | SalesBox.addContractPrice(ContractPriceVO vo)
void | SalesBox.deleteContractPrice(ContractPriceVO cpVO)
java.lang.String | SalesBox.updateContractPrice(ContractPriceVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CopyUtil

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CopyUtil

No usage of bb.common.CopyUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CorrectiveActionRequestVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CorrectiveActionRequestVO

Packages that use CorrectiveActionRequestVO
bb.common.box

Uses of CorrectiveActionRequestVO in bb.common.box

Methods in bb.common.box that return CorrectiveActionRequestVO
CorrectiveActionRequestVO | QualityBox.addCar(CorrectiveActionRequestVO vo)
CorrectiveActionRequestVO | QualityBox.findCarByPk(java.lang.String carNumber)
CorrectiveActionRequestVO | QualityBox.updateCar(CorrectiveActionRequestVO vo)

Methods in bb.common.box that return types with arguments of type CorrectiveActionRequestVO
java.util.Collection<CorrectiveActionRequestVO> | QualityBox.findAllCars(int firstIndex, int maxLength)
java.util.Collection<CorrectiveActionRequestVO> | QualityBox.findCars(java.lang.String carNumber, java.lang.String pn, java.lang.String pa, java.lang.String id, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<CorrectiveActionRequestVO> | QualityBox.findCarsByCarNumber(java.lang.String carNumber, int firstIndex, int maxLength)
java.util.Collection<CorrectiveActionRequestVO> | QualityBox.findCarsByPastDue(int firstIndex, int maxLength)
java.util.Collection<CorrectiveActionRequestVO> | QualityBox.findCarsByPn(java.lang.String pn, java.lang.String pa, int firstIndex, int maxLength)
java.util.Collection<CorrectiveActionRequestVO> | QualityBox.findCarsByStatus(java.lang.String status, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type CorrectiveActionRequestVO
CorrectiveActionRequestVO | QualityBox.addCar(CorrectiveActionRequestVO vo)
void | QualityBox.deleteCar(CorrectiveActionRequestVO vo)
CorrectiveActionRequestVO | QualityBox.updateCar(CorrectiveActionRequestVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CPItemFromQuoteResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CPItemFromQuoteResult

Packages that use CPItemFromQuoteResult
bb.common.box

Uses of CPItemFromQuoteResult in bb.common.box

Methods in bb.common.box that return types with arguments of type CPItemFromQuoteResult
 java.util.Collection<CPItemFromQuoteResult> SalesBox.findContractItemFromQuoteItem(java.lang.String contractNumber, java.lang.String quoteNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CRTVItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CRTVItemListResult

No usage of bb.common.CRTVItemListResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CRTVListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CRTVListResult

No usage of bb.common.CRTVListResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CSRAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CSRAgent

No usage of bb.common.CSRAgent

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CurrencyAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CurrencyAgent

Packages that use CurrencyAgent
bb.common.box

Uses of CurrencyAgent in bb.common.box

Methods in bb.common.box with parameters of type CurrencyAgent
 void CompanyBox.updateExchangeByfiscalYear(CurrencyAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CurrencyExchangePK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CurrencyExchangePK

Packages that use CurrencyExchangePK
bb.common

Uses of CurrencyExchangePK in bb.common

Methods in bb.common that return CurrencyExchangePK
 CurrencyExchangePK CurrencyExchangeVO.getPk()

Methods in bb.common with parameters of type CurrencyExchangePK
int | CurrencyExchangePK.compareTo(CurrencyExchangePK other)
void | CurrencyExchangeVO.setPk(CurrencyExchangePK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CurrencyExchangeVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CurrencyExchangeVO

Packages that use CurrencyExchangeVO
bb.common.box

Uses of CurrencyExchangeVO in bb.common.box

Methods in bb.common.box that return types with arguments of type CurrencyExchangeVO
java.util.Collection<CurrencyExchangeVO> | CompanyBox.findCurrencyExchangeByMonth(java.lang.String monthYear)
java.util.Collection<CurrencyExchangeVO> | CompanyBox.findExchangeByfiscalYear(java.lang.String currency, java.lang.String fiscalYear)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CurrencyVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CurrencyVO

Packages that use CurrencyVO
bb.common
bb.common.box

Uses of CurrencyVO in bb.common

Methods in bb.common that return CurrencyVO
 CurrencyVO CurrencyAgent.getVo()

Methods in bb.common with parameters of type CurrencyVO
 void CurrencyAgent.setVo(CurrencyVO vo)

Uses of CurrencyVO in bb.common.box

Methods in bb.common.box that return CurrencyVO
CurrencyVO | CompanyBox.addCurrency(CurrencyVO vo)
CurrencyVO | CompanyBox.getCurrency(java.lang.String currency, java.lang.String fyNumber)
CurrencyVO | CompanyBox.getCurrencyByPk(java.lang.String currency)
CurrencyVO | CompanyBox.updateCurrency(java.lang.String currency, java.lang.String symbol)

Methods in bb.common.box that return types with arguments of type CurrencyVO
java.util.Collection<CurrencyVO> | CompanyBox.findAllCurrency(int firstIndex, int maxLength)
java.util.Collection<CurrencyVO> | CompanyBox.findAllCurrentCurrency(int firstIndex, int maxLength)
java.util.Map<CurrencyVO,java.math.BigDecimal> | AccountingBox.getReceiverWithOutApTotals(java.lang.String vendorId, java.lang.String buyer, java.lang.String currency, java.util.Date fromDate, java.util.Date toDate)

Methods in bb.common.box with parameters of type CurrencyVO
 CurrencyVO CompanyBox.addCurrency(CurrencyVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CurrentBalanceResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CurrentBalanceResult

Packages that use CurrentBalanceResult
bb.common.box

Uses of CurrentBalanceResult in bb.common.box

Methods in bb.common.box that return CurrentBalanceResult
 CurrentBalanceResult AccountingBox.getCurrentBalanceResult(java.lang.String companyUnitId, java.lang.String accountNumber, java.lang.String monthName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomAssetRecordPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomAssetRecordPK

Packages that use CustomAssetRecordPK
bb.common
bb.common.box

Uses of CustomAssetRecordPK in bb.common

Methods in bb.common that return CustomAssetRecordPK
 CustomAssetRecordPK CustomAssetRecordVO.getPk()

Methods in bb.common with parameters of type CustomAssetRecordPK
 void CustomAssetRecordVO.setPk(CustomAssetRecordPK pk)

Uses of CustomAssetRecordPK in bb.common.box

Methods in bb.common.box with parameters of type CustomAssetRecordPK
void | HumanResourceBox.deleteCustomAssetRecord(CustomAssetRecordPK pk)
CustomAssetRecordVO | HumanResourceBox.getCustomAssetRecordByPk(CustomAssetRecordPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomAssetRecordVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomAssetRecordVO

Packages that use CustomAssetRecordVO
bb.common.box

Uses of CustomAssetRecordVO in bb.common.box

Methods in bb.common.box that return CustomAssetRecordVO
CustomAssetRecordVO | HumanResourceBox.addCustomAssetRecord(CustomAssetRecordVO vo)
CustomAssetRecordVO | HumanResourceBox.getCustomAssetRecordByPk(CustomAssetRecordPK pk)

Methods in bb.common.box with parameters of type CustomAssetRecordVO
CustomAssetRecordVO | HumanResourceBox.addCustomAssetRecord(CustomAssetRecordVO vo)
void | HumanResourceBox.updateCustomAssetRecord(CustomAssetRecordVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomAssetVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomAssetVO

Packages that use CustomAssetVO
bb.common.box

Uses of CustomAssetVO in bb.common.box

Methods in bb.common.box that return CustomAssetVO
CustomAssetVO | HumanResourceBox.addCustomAsset(CustomAssetVO vo)
CustomAssetVO | HumanResourceBox.getCustomAssetByPk(java.lang.String assetNumber)

Methods in bb.common.box that return types with arguments of type CustomAssetVO
 java.util.Collection<CustomAssetVO> HumanResourceBox.findCustomAssetByName(java.lang.String assetName, java.lang.String assetNumber, java.lang.String department, java.lang.String receiveSign, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type CustomAssetVO
CustomAssetVO | HumanResourceBox.addCustomAsset(CustomAssetVO vo)
void | HumanResourceBox.updateCustomAsset(CustomAssetVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomCheckUpEmployeeVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomCheckUpEmployeeVO

Packages that use CustomCheckUpEmployeeVO
bb.common.box

Uses of CustomCheckUpEmployeeVO in bb.common.box

Methods in bb.common.box that return CustomCheckUpEmployeeVO
CustomCheckUpEmployeeVO | HumanResourceBox.addCustomCheckUpEmployee(CustomCheckUpEmployeeVO vo)
CustomCheckUpEmployeeVO | HumanResourceBox.getCustomCheckUpEmployee(java.lang.Long ii)

Methods in bb.common.box that return types with arguments of type CustomCheckUpEmployeeVO
 java.util.Collection<CustomCheckUpEmployeeVO> HumanResourceBox.findCustomCheckUpByName(java.lang.String id, java.lang.String userName, java.util.Date fromDate, java.util.Date toDate, int ageLevel, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type CustomCheckUpEmployeeVO
CustomCheckUpEmployeeVO | HumanResourceBox.addCustomCheckUpEmployee(CustomCheckUpEmployeeVO vo)
void | HumanResourceBox.updateCustomCheckUpEmployee(CustomCheckUpEmployeeVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomDepartmentVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomDepartmentVO

Packages that use CustomDepartmentVO
bb.common
bb.common.box

Uses of CustomDepartmentVO in bb.common

Methods in bb.common that return CustomDepartmentVO
CustomDepartmentVO | CustomEmployeeVO.getCustomDepartment()
CustomDepartmentVO | CustomAssetRecordVO.getCustomReceiveDepartment()
CustomDepartmentVO | CustomAssetRecordVO.getCustomReturnDepartment()

Methods in bb.common with parameters of type CustomDepartmentVO
void | CustomEmployeeVO.setCustomDepartment(CustomDepartmentVO customDepartment)
void | CustomAssetRecordVO.setCustomReceiveDepartment(CustomDepartmentVO customReceiveDepartment)
void | CustomAssetRecordVO.setCustomReturnDepartment(CustomDepartmentVO customReturnDepartment)

Uses of CustomDepartmentVO in bb.common.box

Methods in bb.common.box that return CustomDepartmentVO
CustomDepartmentVO | HumanResourceBox.addCustomDepartment(CustomDepartmentVO vo)
CustomDepartmentVO | HumanResourceBox.getCustomDepartmentByPk(java.lang.String id)

Methods in bb.common.box that return types with arguments of type CustomDepartmentVO
 java.util.Collection<CustomDepartmentVO> HumanResourceBox.findAllCustomDepartment(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type CustomDepartmentVO
CustomDepartmentVO | HumanResourceBox.addCustomDepartment(CustomDepartmentVO vo)
void | HumanResourceBox.updateCustomDepartment(CustomDepartmentVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomEmployeeTrainPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomEmployeeTrainPK

Packages that use CustomEmployeeTrainPK
bb.common
bb.common.box

Uses of CustomEmployeeTrainPK in bb.common

Methods in bb.common that return CustomEmployeeTrainPK
CustomEmployeeTrainPK | CustomEmployeeWorkExperienceVO.getPk()
CustomEmployeeTrainPK | CustomEmployeeTrainVO.getPk()

Methods in bb.common with parameters of type CustomEmployeeTrainPK
void | CustomEmployeeWorkExperienceVO.setPk(CustomEmployeeTrainPK pk)
void | CustomEmployeeTrainVO.setPk(CustomEmployeeTrainPK pk)

Uses of CustomEmployeeTrainPK in bb.common.box

Methods in bb.common.box with parameters of type CustomEmployeeTrainPK
void | HumanResourceBox.deleteCustomEmployeeTrain(CustomEmployeeTrainPK pk)
void | HumanResourceBox.deleteCustomEmployeeWorkExperience(CustomEmployeeTrainPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomEmployeeTrainVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomEmployeeTrainVO

Packages that use CustomEmployeeTrainVO
bb.common.box

Uses of CustomEmployeeTrainVO in bb.common.box

Methods in bb.common.box that return CustomEmployeeTrainVO
 CustomEmployeeTrainVO HumanResourceBox.addCustomEmployeeTrain(CustomEmployeeTrainVO vo)

Methods in bb.common.box that return types with arguments of type CustomEmployeeTrainVO
 java.util.Collection<CustomEmployeeTrainVO> HumanResourceBox.findCustomEmployeeTrain(java.lang.String title, java.lang.String certificateName, java.lang.String certificationId, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type CustomEmployeeTrainVO
CustomEmployeeTrainVO | HumanResourceBox.addCustomEmployeeTrain(CustomEmployeeTrainVO vo)
void | HumanResourceBox.updateCustomEmployeeTrain(CustomEmployeeTrainVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomEmployeeVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomEmployeeVO

Packages that use CustomEmployeeVO
bb.common.box

Uses of CustomEmployeeVO in bb.common.box

Methods in bb.common.box that return CustomEmployeeVO
CustomEmployeeVO | HumanResourceBox.addCustomEmployee(CustomEmployeeVO vo)
CustomEmployeeVO | HumanResourceBox.getCustomEmployeeByPk(java.lang.String id)

Methods in bb.common.box that return types with arguments of type CustomEmployeeVO
 java.util.Collection<CustomEmployeeVO> HumanResourceBox.findCustomEmployeeByCondition(java.lang.String id, java.lang.String gender, int ageLevel, java.lang.String polityVisage, java.lang.String education, java.lang.String specialTitle, java.lang.String specialWork, java.lang.String workType, java.lang.String workTypeAfter, int workAgeLevel, java.lang.String fromPostion, java.lang.String toPosition, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type CustomEmployeeVO
CustomEmployeeVO | HumanResourceBox.addCustomEmployee(CustomEmployeeVO vo)
void | HumanResourceBox.updateCustomEmployee(CustomEmployeeVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomEmployeeWorkExperienceVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomEmployeeWorkExperienceVO

Packages that use CustomEmployeeWorkExperienceVO
bb.common.box

Uses of CustomEmployeeWorkExperienceVO in bb.common.box

Methods in bb.common.box that return CustomEmployeeWorkExperienceVO
 CustomEmployeeWorkExperienceVO HumanResourceBox.addCustomEmployeeWorkExperience(CustomEmployeeWorkExperienceVO vo)

Methods in bb.common.box with parameters of type CustomEmployeeWorkExperienceVO
CustomEmployeeWorkExperienceVO | HumanResourceBox.addCustomEmployeeWorkExperience(CustomEmployeeWorkExperienceVO vo)
void | HumanResourceBox.updateCustomEmployeeWorkExperience(CustomEmployeeWorkExperienceVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomerCLimitResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomerCLimitResult

Packages that use CustomerCLimitResult
bb.common.box

Uses of CustomerCLimitResult in bb.common.box

Methods in bb.common.box that return CustomerCLimitResult
 CustomerCLimitResult AddressBox.isCustomerHold(java.lang.String customerId)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomerFeedbackVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomerFeedbackVO

Packages that use CustomerFeedbackVO
bb.common.box

Uses of CustomerFeedbackVO in bb.common.box

Methods in bb.common.box that return CustomerFeedbackVO
CustomerFeedbackVO | CustomerServiceBox.addCustomerFeedback(CustomerFeedbackVO vo)
CustomerFeedbackVO | CustomerServiceBox.addCustomerFeedback(java.lang.String invoiceNumber)
CustomerFeedbackVO | CustomerServiceBox.addCustomerFeedbackByCustomerId(java.lang.String customerId)
CustomerFeedbackVO | CustomerServiceBox.addCustomerFeedbackBySoNumber(java.lang.String soNumber)
CustomerFeedbackVO | CustomerServiceBox.getCustomerFeedbackById(java.lang.String feedbackNumber)
CustomerFeedbackVO | CustomerServiceBox.updateCustomerFeedback(CustomerFeedbackVO vo)

Methods in bb.common.box that return types with arguments of type CustomerFeedbackVO
java.util.Collection<CustomerFeedbackVO> | CustomerServiceBox.findAllCustomerFeedback(int firstIndex, int maxLength)
java.util.Collection<CustomerFeedbackVO> | CustomerServiceBox.findCustomerFeedbackByDate(java.lang.String feedbackNumberLike, java.lang.String customerId, java.lang.String status, java.lang.String csiNumber, java.lang.String comments, boolean isCFBDate, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<CustomerFeedbackVO> | CustomerServiceBox.findCustomerFeedbacksByFeedBackNumber(java.lang.String feedbackNumberLike, int firstIndex, int maxLength)
java.util.Collection<CustomerFeedbackVO> | CustomerServiceBox.findOpenCustomerFeedback(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type CustomerFeedbackVO
CustomerFeedbackVO | CustomerServiceBox.addCustomerFeedback(CustomerFeedbackVO vo)
CustomerFeedbackVO | CustomerServiceBox.updateCustomerFeedback(CustomerFeedbackVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomerPrepayStatementListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomerPrepayStatementListResult

Packages that use CustomerPrepayStatementListResult
bb.common.box

Uses of CustomerPrepayStatementListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type CustomerPrepayStatementListResult
java.util.Collection<CustomerPrepayStatementListResult> | AccountingBox.find1To30PrepayStatementByCustomerId(java.lang.String customerId, java.lang.String idType, java.lang.String currency, java.util.Date asOf, int firstIndex, int maxLength)
java.util.Collection<CustomerPrepayStatementListResult> | AccountingBox.find31To60PrepayStatementByCustomerId(java.lang.String customerId, java.lang.String idType, java.lang.String currency, java.util.Date asOf, int firstIndex, int maxLength)
java.util.Collection<CustomerPrepayStatementListResult> | AccountingBox.find61To90PrepayStatementByCustomerId(java.lang.String customerId, java.lang.String idType, java.lang.String currency, java.util.Date asOf, int firstIndex, int maxLength)
java.util.Collection<CustomerPrepayStatementListResult> | AccountingBox.find90PlusPrepayStatementByCustomerId(java.lang.String customerId, java.lang.String idType, java.lang.String currency, java.util.Date asOf, int firstIndex, int maxLength)
java.util.Collection<CustomerPrepayStatementListResult> | AccountingBox.findCustomerPrepayStatementById(java.lang.String customerId, java.lang.String currency, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<CustomerPrepayStatementListResult> | AccountingBox.findCustomerPrepayStatementById(java.lang.String customerId, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<CustomerPrepayStatementListResult> | AccountingBox.findCustomerPrepayStatementById(java.lang.String customerId, java.lang.String idType, java.lang.String currency, java.util.Date toDate, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomerReturnToVendorItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomerReturnToVendorItemPK

Packages that use CustomerReturnToVendorItemPK
bb.common

Uses of CustomerReturnToVendorItemPK in bb.common

Methods in bb.common that return CustomerReturnToVendorItemPK
 CustomerReturnToVendorItemPK CustomerReturnToVendorItemVO.getPk()

Methods in bb.common with parameters of type CustomerReturnToVendorItemPK
 void CustomerReturnToVendorItemVO.setPk(CustomerReturnToVendorItemPK pk)

Constructors in bb.common with parameters of type CustomerReturnToVendorItemPK
CustomerReturnToVendorItemVO(CustomerReturnToVendorItemPK pk, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom)
minimal constructor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomerReturnToVendorItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomerReturnToVendorItemVO

Packages that use CustomerReturnToVendorItemVO
bb.common

Uses of CustomerReturnToVendorItemVO in bb.common

Methods in bb.common that return types with arguments of type CustomerReturnToVendorItemVO
 java.util.Set<CustomerReturnToVendorItemVO> CustomerReturnToVendorVO.getCrtvItem()

Method parameters in bb.common with type arguments of type CustomerReturnToVendorItemVO
 void CustomerReturnToVendorVO.setCrtvItem(java.util.Set<CustomerReturnToVendorItemVO> crtvItem)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomerReturnToVendorVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomerReturnToVendorVO

No usage of bb.common.CustomerReturnToVendorVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomerServiceIncidentItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomerServiceIncidentItemListResult

Packages that use CustomerServiceIncidentItemListResult
bb.common.box

Uses of CustomerServiceIncidentItemListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type CustomerServiceIncidentItemListResult
 java.util.Collection<CustomerServiceIncidentItemListResult> CustomerServiceBox.findIncidentsByDate(java.lang.String csiNumber, PartPK partPk, java.lang.String customerId, java.lang.String priority, java.lang.String status, java.lang.String shipperNumber, java.lang.String workOrderNumber, java.lang.String salesOrderNumber, boolean isOpenDate, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomerServiceIncidentItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomerServiceIncidentItemVO

Packages that use CustomerServiceIncidentItemVO
bb.common.box

Uses of CustomerServiceIncidentItemVO in bb.common.box

Methods in bb.common.box that return types with arguments of type CustomerServiceIncidentItemVO
java.util.Collection<CustomerServiceIncidentItemVO> | CustomerServiceBox.deleteIncidentItemDoc(MiscDocAgent agent)
java.util.Collection<CustomerServiceIncidentItemVO> | CustomerServiceBox.findAllIncidentItem(int firstIndex, int maxLength)
java.util.Collection<CustomerServiceIncidentItemVO> | CustomerServiceBox.findIncidentItemInfosByCsi(java.lang.String csiNumber)
java.util.Collection<CustomerServiceIncidentItemVO> | CustomerServiceBox.uploadOrUpdateIncidentItemDoc(CustomerServiceIncidentItemVO vo, MiscDocAgent agent)

Methods in bb.common.box with parameters of type CustomerServiceIncidentItemVO
 java.util.Collection<CustomerServiceIncidentItemVO> CustomerServiceBox.uploadOrUpdateIncidentItemDoc(CustomerServiceIncidentItemVO vo, MiscDocAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomerServiceIncidentListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomerServiceIncidentListResult

Packages that use CustomerServiceIncidentListResult
bb.common.box

Uses of CustomerServiceIncidentListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type CustomerServiceIncidentListResult
java.util.Collection<CustomerServiceIncidentListResult> | CustomerServiceBox.findAllIncidents(int firstIndex, int maxLength)
java.util.Collection<CustomerServiceIncidentListResult> | CustomerServiceBox.findDueIncidents(int firstIndex, int maxLength)
java.util.Collection<CustomerServiceIncidentListResult> | CustomerServiceBox.findIncidentsByCsiNumber(java.lang.String csi, int firstIndex, int maxLength)
java.util.Collection<CustomerServiceIncidentListResult> | CustomerServiceBox.findIncidentsByCustomerId(java.lang.String customerId, int firstIndex, int maxLength)
java.util.Collection<CustomerServiceIncidentListResult> | CustomerServiceBox.findIncidentsByDate(java.lang.String csiNumber, PartPK partPk, java.lang.String customerId, java.lang.String priority, java.lang.String status, boolean isOpenDate, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<CustomerServiceIncidentListResult> | CustomerServiceBox.findIncidentsByPartLike(java.lang.String pn, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<CustomerServiceIncidentListResult> | CustomerServiceBox.findOpenIncidents(int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomerServiceIncidentVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomerServiceIncidentVO

Packages that use CustomerServiceIncidentVO
bb.common.box

Uses of CustomerServiceIncidentVO in bb.common.box

Methods in bb.common.box that return CustomerServiceIncidentVO
CustomerServiceIncidentVO | CustomerServiceBox.addIncident(CustomerServiceIncidentVO vo)
CustomerServiceIncidentVO | CustomerServiceBox.findIncidentByPk(java.lang.String csiNumber)
CustomerServiceIncidentVO | CustomerServiceBox.updateIncident(CustomerServiceIncidentVO vo)

Methods in bb.common.box with parameters of type CustomerServiceIncidentVO
CustomerServiceIncidentVO | CustomerServiceBox.addIncident(CustomerServiceIncidentVO vo)
CustomerServiceIncidentVO | CustomerServiceBox.updateIncident(CustomerServiceIncidentVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomerStatementListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomerStatementListResult

Packages that use CustomerStatementListResult
bb.common.box

Uses of CustomerStatementListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type CustomerStatementListResult
java.util.Collection<CustomerStatementListResult> | AccountingBox.find1To30StatementByCustomerId(java.lang.String customerId, java.lang.String idType, java.lang.String currency, java.util.Date asOf, int firstIndex, int maxLength)
java.util.Collection<CustomerStatementListResult> | AccountingBox.find31To60StatementByCustomerId(java.lang.String customerId, java.lang.String idType, java.lang.String currency, java.util.Date asOf, int firstIndex, int maxLength)
java.util.Collection<CustomerStatementListResult> | AccountingBox.find61To90StatementByCustomerId(java.lang.String customerId, java.lang.String idType, java.lang.String currency, java.util.Date asOf, int firstIndex, int maxLength)
java.util.Collection<CustomerStatementListResult> | AccountingBox.find90PlusStatementByCustomerId(java.lang.String customerId, java.lang.String idType, java.lang.String currency, java.util.Date asOf, int firstIndex, int maxLength)
java.util.Collection<CustomerStatementListResult> | AccountingBox.findCurrentStatementByCustomerId(java.lang.String customerId, java.lang.String currency, java.util.Date asOf, int firstIndex, int maxLength)
java.util.Collection<CustomerStatementListResult> | AccountingBox.findStatementById(java.lang.String customerId, java.lang.String currency, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<CustomerStatementListResult> | AccountingBox.findStatementById(java.lang.String customerId, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<CustomerStatementListResult> | AccountingBox.findStatementById(java.lang.String customerId, java.lang.String idType, java.lang.String currency, java.util.Date toDate, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomerStatementResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomerStatementResult

Packages that use CustomerStatementResult
bb.common.box

Uses of CustomerStatementResult in bb.common.box

Methods in bb.common.box that return CustomerStatementResult
 CustomerStatementResult AccountingBox.getCustomerStatementByDate(java.lang.String customer, java.util.Date startDate, java.util.Date endDate, java.lang.String currency)

Methods in bb.common.box that return types with arguments of type CustomerStatementResult
 java.util.List<CustomerStatementResult> AccountingBox.findCustomerStatementTotalByDate(java.lang.String customer, java.util.Date startDate, java.util.Date endDate, java.lang.String currency)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomerStatementTotalResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomerStatementTotalResult

Packages that use CustomerStatementTotalResult
bb.common
bb.common.box

Uses of CustomerStatementTotalResult in bb.common

Methods in bb.common that return types with arguments of type CustomerStatementTotalResult
 java.util.Collection<CustomerStatementTotalResult> CustomerStatementResult.getArAging()

Method parameters in bb.common with type arguments of type CustomerStatementTotalResult
 void CustomerStatementResult.setArAging(java.util.Collection<CustomerStatementTotalResult> arAging)

Uses of CustomerStatementTotalResult in bb.common.box

Methods in bb.common.box that return CustomerStatementTotalResult
 CustomerStatementTotalResult AccountingBox.getCustomerStatementTotalResult(java.lang.String customerId)

Methods in bb.common.box that return types with arguments of type CustomerStatementTotalResult
java.util.Collection<CustomerStatementTotalResult> | AccountingBox.findAgingAps(java.lang.String[] includeVendorId, java.lang.String[] excludeVendorId, boolean useAsOf, java.util.Date asOf, int firstIndex, int maxLength)
java.util.Collection<CustomerStatementTotalResult> | AccountingBox.findAgingARs(java.lang.String[] includeCustomerId, java.lang.String[] excludeCustomerId, boolean useAsOf, java.util.Date asOf, int firstIndex, int length)
java.util.Collection<CustomerStatementTotalResult> | AccountingBox.findCustomerPrepayStatementsTotal(java.lang.String customerId, java.util.Date asOf, java.lang.String currency)
java.util.Collection<CustomerStatementTotalResult> | AccountingBox.findCustomerPrepayStatementsTotal(java.lang.String customerId, java.lang.String idType, java.util.Date asOf, java.lang.String currency)
java.util.Collection<CustomerStatementTotalResult> | AccountingBox.findCustomerStatementsTotal(java.lang.String customerId, java.util.Date asOf, java.lang.String currency)
java.util.Collection<CustomerStatementTotalResult> | AccountingBox.findCustomerStatementsTotal(java.lang.String customerId, java.lang.String idType, java.util.Date asOf, java.lang.String currency)
java.util.Collection<CustomerStatementTotalResult> | AccountingBox.findVendorPrepayStatementsTotal(java.lang.String vendorId, java.lang.String currency)
java.util.Collection<CustomerStatementTotalResult> | AccountingBox.findVendorPrepayStatementsTotal(java.lang.String vendorId, java.lang.String currency, java.util.Date toDate)
java.util.Collection<CustomerStatementTotalResult> | AccountingBox.findVendorStatementsTotal(java.lang.String vendorId, java.lang.String currency)
java.util.Collection<CustomerStatementTotalResult> | AccountingBox.findVendorStatementsTotal(java.lang.String vendorId, java.lang.String currency, java.util.Date toDate)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomerVendorAddressInfoVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomerVendorAddressInfoVO

Packages that use CustomerVendorAddressInfoVO
bb.common
bb.common.box

Uses of CustomerVendorAddressInfoVO in bb.common

Methods in bb.common that return CustomerVendorAddressInfoVO
CustomerVendorAddressInfoVO | OntimeDeliveryRateResult.getAddressInfo()
CustomerVendorAddressInfoVO | NonproductivePickingVO.getAddressInfo()
CustomerVendorAddressInfoVO | CustomerStatementResult.getAddrInfo()
CustomerVendorAddressInfoVO | WorkOrderVO.getBillToAddressInfo()
CustomerVendorAddressInfoVO | ShipperVO.getBillToAddressInfo()
CustomerVendorAddressInfoVO | ShipperInfoVO.getBillToAddressInfo()
CustomerVendorAddressInfoVO | SalesOrderVO.getBillToAddressInfo()
CustomerVendorAddressInfoVO | RtvShipperVO.getBillToAddressInfo()
CustomerVendorAddressInfoVO | RtvShipperInfoVO.getBillToAddressInfo()
CustomerVendorAddressInfoVO | ReturnToVendorVO.getBillToAddressInfo()
CustomerVendorAddressInfoVO | ReturnMaterialAuthorizationVO.getBillToAddressInfo()
CustomerVendorAddressInfoVO | RequestForRMAVO.getBillToAddressInfo()
CustomerVendorAddressInfoVO | RequestForQuoteVO.getBillToAddressInfo()
CustomerVendorAddressInfoVO | QuoteVO.getBillToAddressInfo()
CustomerVendorAddressInfoVO | PurchaseOrderVO.getBillToAddressInfo()
CustomerVendorAddressInfoVO | ProformaInvoiceVO.getBillToAddressInfo()
CustomerVendorAddressInfoVO | OnLoanVO.getBillToAddressInfo()
CustomerVendorAddressInfoVO | OnloanShipperVO.getBillToAddressInfo()
CustomerVendorAddressInfoVO | DisassembleWorkOrderVO.getBillToAddressInfo()
CustomerVendorAddressInfoVO | CustomerReturnToVendorVO.getBillToAddressInfo()
CustomerVendorAddressInfoVO | ArPrepayVO.getBillToAddressInfo()
CustomerVendorAddressInfoVO | AccountsReceivableVO.getBillToAddressInfo()
CustomerVendorAddressInfoVO | RMAReceiverVO.getBillToInfo()
CustomerVendorAddressInfoVO | VendorGroupUserVO.getCustomerAddressInfo()
CustomerVendorAddressInfoVO | ShipperVO.getCustomerAddressInfo()
CustomerVendorAddressInfoVO | SgClientProgramUserVO.getCustomerAddressInfo()
CustomerVendorAddressInfoVO | SalesOrderVO.getCustomerAddressInfo()
CustomerVendorAddressInfoVO | RunningAccountOrderVO.getCustomerAddressInfo()
CustomerVendorAddressInfoVO | RMAReceiverVO.getCustomerAddressInfo()
CustomerVendorAddressInfoVO | ReturnMaterialAuthorizationVO.getCustomerAddressInfo()
CustomerVendorAddressInfoVO | RequestForRMAVO.getCustomerAddressInfo()
CustomerVendorAddressInfoVO | QuoteVO.getCustomerAddressInfo()
CustomerVendorAddressInfoVO | ProformaInvoiceVO.getCustomerAddressInfo()
CustomerVendorAddressInfoVO | OnLoanVO.getCustomerAddressInfo()
CustomerVendorAddressInfoVO | OnloanShipperVO.getCustomerAddressInfo()
CustomerVendorAddressInfoVO | OnloanReceiverVO.getCustomerAddressInfo()
CustomerVendorAddressInfoVO | CustomerServiceIncidentVO.getCustomerAddressInfo()
CustomerVendorAddressInfoVO | CustomerReturnToVendorVO.getCustomerAddressInfo()
CustomerVendorAddressInfoVO | CustomerFeedbackVO.getCustomerAddressInfo()
CustomerVendorAddressInfoVO | ArPrepayVO.getCustomerAddressInfo()
CustomerVendorAddressInfoVO | ARPaymentRunItemVO.getCustomerAddressInfo()
CustomerVendorAddressInfoVO | AccountsReceivableVO.getCustomerAddressInfo()
CustomerVendorAddressInfoVO | AccountsReceivableInfoVO.getCustomerAddressInfo()
CustomerVendorAddressInfoVO | AccountsPayableVO.getCustomerAddressInfo()
CustomerVendorAddressInfoVO | AccountsPayableInfoVO.getCustomerAddressInfo()
CustomerVendorAddressInfoVO | AccountPayableCheckRunItemVO.getCustomerAddressInfo()
CustomerVendorAddressInfoVO | ContractPriceCustomerVO.getCustomerInfo()
CustomerVendorAddressInfoVO | TransferShipperVO.getFromAddressInfo()
CustomerVendorAddressInfoVO | TransferReceiverVO.getFromAddressInfo()
CustomerVendorAddressInfoVO | TransferOrderVO.getFromAddressInfo()
CustomerVendorAddressInfoVO | ProformaInvoiceVO.getShipFromAddressInfo()
CustomerVendorAddressInfoVO | WorkOrderVO.getShipToAddressInfo()
CustomerVendorAddressInfoVO | ShipperVO.getShipToAddressInfo()
CustomerVendorAddressInfoVO | ShipperInfoVO.getShipToAddressInfo()
CustomerVendorAddressInfoVO | SalesOrderVO.getShipToAddressInfo()
CustomerVendorAddressInfoVO | RtvShipperVO.getShipToAddressInfo()
CustomerVendorAddressInfoVO | RtvShipperInfoVO.getShipToAddressInfo()
CustomerVendorAddressInfoVO | ReturnToVendorVO.getShipToAddressInfo()
CustomerVendorAddressInfoVO | ReturnMaterialAuthorizationVO.getShipToAddressInfo()
CustomerVendorAddressInfoVO | RequestForRMAVO.getShipToAddressInfo()
CustomerVendorAddressInfoVO | RequestForQuoteVO.getShipToAddressInfo()
CustomerVendorAddressInfoVO | QuoteVO.getShipToAddressInfo()
CustomerVendorAddressInfoVO | PurchaseOrderVO.getShipToAddressInfo()
CustomerVendorAddressInfoVO | ProformaInvoiceVO.getShipToAddressInfo()
CustomerVendorAddressInfoVO | OnLoanVO.getShipToAddressInfo()
CustomerVendorAddressInfoVO | OnloanShipperVO.getShipToAddressInfo()
CustomerVendorAddressInfoVO | DisassembleWorkOrderVO.getShipToAddressInfo()
CustomerVendorAddressInfoVO | CustomerReturnToVendorVO.getShipToAddressInfo()
CustomerVendorAddressInfoVO | ArPrepayVO.getShipToAddressInfo()
CustomerVendorAddressInfoVO | AccountsReceivableVO.getShipToAddressInfo()
CustomerVendorAddressInfoVO | RMAReceiverVO.getShipToInfo()
CustomerVendorAddressInfoVO | TransferShipperVO.getToAddressInfo()
CustomerVendorAddressInfoVO | TransferReceiverVO.getToAddressInfo()
CustomerVendorAddressInfoVO | TransferOrderVO.getToAddressInfo()
CustomerVendorAddressInfoVO | WorkOrderVO.getVendorAddressInfo()
CustomerVendorAddressInfoVO | SwapShipperVO.getVendorAddressInfo()
CustomerVendorAddressInfoVO | SwapReceiverVO.getVendorAddressInfo()
CustomerVendorAddressInfoVO | SwapOrderVO.getVendorAddressInfo()
CustomerVendorAddressInfoVO | RtvShipperVO.getVendorAddressInfo()
CustomerVendorAddressInfoVO | ReturnToVendorVO.getVendorAddressInfo()
CustomerVendorAddressInfoVO | RequestForQuoteVO.getVendorAddressInfo()
CustomerVendorAddressInfoVO | ReceiverVO.getVendorAddressInfo()
CustomerVendorAddressInfoVO | PurchaseOrderVO.getVendorAddressInfo()
CustomerVendorAddressInfoVO | PfReceiverVO.getVendorAddressInfo()
CustomerVendorAddressInfoVO | InspectionConformanceReportVO.getVendorAddressInfo()
CustomerVendorAddressInfoVO | DisassembleWorkOrderVO.getVendorAddressInfo()
CustomerVendorAddressInfoVO | ApPrepayVO.getVendorAddressInfo()
CustomerVendorAddressInfoVO | ReceiverInfoVO.getVendorAddressInfoVO()
CustomerVendorAddressInfoVO | VendorContractPriceVendorVO.getVendorInfo()

Methods in bb.common with parameters of type CustomerVendorAddressInfoVO
void | OntimeDeliveryRateResult.setAddressInfo(CustomerVendorAddressInfoVO addressInfo)
void | NonproductivePickingVO.setAddressInfo(CustomerVendorAddressInfoVO addressInfo)
void | CustomerStatementResult.setAddrInfo(CustomerVendorAddressInfoVO addrInfo)
void | WorkOrderVO.setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | ShipperVO.setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | ShipperInfoVO.setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | SalesOrderVO.setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | RtvShipperVO.setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | RtvShipperInfoVO.setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | ReturnToVendorVO.setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | ReturnMaterialAuthorizationVO.setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | RequestForRMAVO.setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | RequestForQuoteVO.setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | QuoteVO.setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | PurchaseOrderVO.setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | ProformaInvoiceVO.setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | OnLoanVO.setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | OnloanShipperVO.setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | DisassembleWorkOrderVO.setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | CustomerReturnToVendorVO.setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | ArPrepayVO.setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | AccountsReceivableVO.setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | RMAReceiverVO.setBillToInfo(CustomerVendorAddressInfoVO billToInfo)
void | VendorGroupUserVO.setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | ShipperVO.setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | SgClientProgramUserVO.setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | SalesOrderVO.setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | RunningAccountOrderVO.setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | RMAReceiverVO.setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | ReturnMaterialAuthorizationVO.setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | RequestForRMAVO.setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | QuoteVO.setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | ProformaInvoiceVO.setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | OnLoanVO.setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | OnloanShipperVO.setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | OnloanReceiverVO.setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | CustomerServiceIncidentVO.setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | CustomerReturnToVendorVO.setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | CustomerFeedbackVO.setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | ArPrepayVO.setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | ARPaymentRunItemVO.setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | AccountsReceivableVO.setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | AccountsReceivableInfoVO.setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | AccountsPayableVO.setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | AccountsPayableInfoVO.setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | AccountPayableCheckRunItemVO.setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | ContractPriceCustomerVO.setCustomerInfo(CustomerVendorAddressInfoVO customerVendor)
void | TransferShipperVO.setFromAddressInfo(CustomerVendorAddressInfoVO fromAddressInfo)
void | TransferReceiverVO.setFromAddressInfo(CustomerVendorAddressInfoVO fromAddressInfo)
void | TransferOrderVO.setFromAddressInfo(CustomerVendorAddressInfoVO fromAddressInfo)
void | ProformaInvoiceVO.setShipFromAddressInfo(CustomerVendorAddressInfoVO shipFromAddressInfo)
void | WorkOrderVO.setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | ShipperVO.setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | ShipperInfoVO.setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | SalesOrderVO.setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | RtvShipperVO.setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | RtvShipperInfoVO.setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | ReturnToVendorVO.setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | ReturnMaterialAuthorizationVO.setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | RequestForRMAVO.setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | RequestForQuoteVO.setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | QuoteVO.setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | PurchaseOrderVO.setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | ProformaInvoiceVO.setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | OnLoanVO.setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | OnloanShipperVO.setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | DisassembleWorkOrderVO.setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | CustomerReturnToVendorVO.setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | ArPrepayVO.setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | AccountsReceivableVO.setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | RMAReceiverVO.setShipToInfo(CustomerVendorAddressInfoVO shipToInfo)
void | TransferShipperVO.setToAddressInfo(CustomerVendorAddressInfoVO toAddressInfo)
void | TransferReceiverVO.setToAddressInfo(CustomerVendorAddressInfoVO toAddressInfo)
void | TransferOrderVO.setToAddressInfo(CustomerVendorAddressInfoVO toAddressInfo)
void | WorkOrderVO.setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)
void | SwapShipperVO.setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)
void | SwapReceiverVO.setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)
void | SwapOrderVO.setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)
void | RtvShipperVO.setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)
void | ReturnToVendorVO.setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)
void | RequestForQuoteVO.setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)
void | ReceiverVO.setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)
void | ReceiverInfoVO.setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfoVO)
void | PurchaseOrderVO.setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)
void | PfReceiverVO.setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)
void | InspectionConformanceReportVO.setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)
void | DisassembleWorkOrderVO.setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)
void | ApPrepayVO.setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)
void | VendorContractPriceVendorVO.setVendorInfo(CustomerVendorAddressInfoVO vendorInfo)

Constructors in bb.common with parameters of type CustomerVendorAddressInfoVO
DisassembleWorkOrderVO(java.lang.String disassembleWorkOrderNumber, java.lang.String lastChangeUser, java.util.Date lastChangeDate, java.util.Date adate, java.lang.String origin, java.math.BigDecimal dwoSub, java.math.BigDecimal dwoDisc, java.math.BigDecimal subTotal, java.math.BigDecimal dwoMade, java.math.BigDecimal dwoOpen, java.math.BigDecimal totalTax, java.math.BigDecimal totalFreight, java.math.BigDecimal grantTotal, java.lang.String changeOrder, java.lang.String vendorId, java.lang.String billToId, java.lang.String po, java.lang.String contact, java.lang.String status, java.util.Date approved, java.lang.String approvedBy, java.lang.String originator, java.util.Date delivery, java.util.Date desired, int delay, java.lang.String priority, java.util.Date original, java.lang.String actual, java.lang.String shipToId, java.lang.String shipVia, java.lang.String shippingAccount, java.lang.String location, java.lang.String language, java.lang.String currency, java.lang.String terms, java.util.Date entered, java.lang.String salesman, java.lang.String requestor, java.lang.String project, java.lang.String relatedDoc, java.lang.String debitAccount, java.lang.String bp, java.lang.String disassembleWorkOrderComments, java.lang.String disassembleWorkOrderPrivateNotes, java.lang.String companyUnitId, boolean useWip, int lastChangeTimes, CustomerVendorAddressInfoVO vendorAddressInfo, CustomerVendorAddressInfoVO shipToAddressInfo, CustomerVendorAddressInfoVO billToAddressInfo, java.util.Set disassembleWorkOrderItem, java.util.Set boilerplates, java.lang.String coComments, boolean hold)
OnloanReceiverVO(java.lang.String receiverNumber, java.lang.String lnShipperNumber, java.lang.String accountPayableNumber, java.lang.String custID, java.lang.String lastChangeUser, java.util.Date lastChangeDate, java.util.Date adate, java.lang.String origin, java.math.BigDecimal apSub, java.math.BigDecimal apReceived, java.math.BigDecimal apOpen, java.math.BigDecimal totalDiscount, java.math.BigDecimal subTotal, java.math.BigDecimal totalTax, java.math.BigDecimal totalFreight, java.math.BigDecimal grantTotal, java.math.BigDecimal apPaidReceived, java.math.BigDecimal apPaidGl, java.math.BigDecimal apGl1Recorded, java.math.BigDecimal apGl2Paid, java.lang.String changeOrder, java.lang.String status, java.lang.String collect, java.lang.String receivedBy, java.util.Date dateReceived, java.lang.String deliveredTo, java.lang.String freightBill, java.lang.String shippedVia, java.lang.String carrier, java.lang.String carrierAccount, java.lang.String tracking, java.lang.String incoterm, java.lang.String incotermPlacePort, java.lang.String currency, java.lang.String terms, java.lang.String requester, java.lang.String projectName, java.lang.String relatedDoc, java.lang.String debitAccount, java.lang.String bp, java.lang.String receiverComments, java.lang.String receiverPrivateNotes, java.math.BigDecimal due, java.lang.String cusInvoice, java.lang.String cusPackage, java.math.BigDecimal cusTotal, java.util.Date cusInvoiceDate, java.util.Date paydate, java.util.Date datePaid, java.lang.String checkNo, java.math.BigDecimal paid, java.lang.String itran, java.lang.String etran, int lastChangeTimes, CustomerVendorAddressInfoVO customerAddressInfo, java.util.Set receiverItem)
full constructor
ProformaInvoiceVO(java.lang.String pfInvoiceNumber, int packingBoxNumbers, java.lang.String customerId, java.lang.String customerPO, java.lang.String billTo, java.lang.String customerEmail, java.lang.String contact, java.lang.String lastChangeUser, java.util.Date lastChangeDate, java.util.Date adate, java.lang.String origin, java.math.BigDecimal arSub, java.math.BigDecimal arShip, java.math.BigDecimal arOpen, java.math.BigDecimal arDisc, java.math.BigDecimal arNet, java.math.BigDecimal arTax, java.math.BigDecimal arFreight, java.math.BigDecimal arTotal, java.math.BigDecimal arPaid, java.math.BigDecimal arPaidInv, java.math.BigDecimal arPaidGl, java.math.BigDecimal arGl1Recorded, java.math.BigDecimal arGl2Paid, java.lang.String changeOrder, java.lang.String status, java.lang.String salesman, java.util.Date shipped, java.lang.String shippedBy, java.util.Date invoicedDate, java.lang.String invoicedBy, java.lang.String shipTo, java.lang.String remitId, java.lang.String shipVia, java.util.Date estimatedArrival, java.lang.String carrier, java.lang.String carrierAccount, java.lang.String tracking, java.lang.String billOfLading, java.lang.String containerNumber, java.lang.String containerSealNumber, java.lang.String shippingMark, java.lang.String incoterm, java.lang.String incotermPlacePort, java.util.Date dateShipped, java.util.Date dateInvoiced, java.lang.String freightBill, java.lang.String currency, java.lang.String language, java.lang.String terms, java.lang.String reldoc, java.lang.String cacct1, java.lang.String bp, java.lang.String comments, java.lang.String notes, java.math.BigDecimal due, java.util.Date paydate, java.util.Date datePaid, java.lang.String checkNo, java.math.BigDecimal paid, java.lang.String otran, java.lang.String rtran, int lastChangeTimes, CustomerVendorAddressInfoVO customerAddressInfo, CustomerVendorAddressInfoVO shipToAddressInfo, CustomerVendorAddressInfoVO billToAddressInfo, java.util.Set proformaInvoiceItems, java.util.Set packingBoxes)
full constructor
ReceiverInfoVO(java.lang.String receiverNumber, java.lang.String purchaseOrderNumber, java.lang.String accountPayableNumber, java.lang.String vendorId, java.lang.String lastChangeUser, java.util.Date lastChangeDate, java.util.Date adate, java.lang.String origin, java.math.BigDecimal apSub, java.math.BigDecimal apReceived, java.math.BigDecimal apOpen, java.math.BigDecimal totalDiscount, java.math.BigDecimal subTotal, java.math.BigDecimal totalTax, java.math.BigDecimal totalFreight, java.math.BigDecimal grantTotal, java.math.BigDecimal apPaidReceived, java.math.BigDecimal apPaidGl, java.math.BigDecimal apGl1Recorded, java.math.BigDecimal apGl2Paid, java.lang.String changeOrder, java.lang.String status, java.lang.String collect, java.lang.String receivedBy, java.util.Date dateReceived, java.lang.String deliveredTo, java.lang.String freightBill, java.lang.String shippedVia, java.lang.String carrier, java.lang.String carrierAccount, java.lang.String tracking, java.lang.String incoterm, java.lang.String incotermPlacePort, java.lang.String currency, java.lang.String terms, java.lang.String requester, java.lang.String projectName, java.lang.String relatedDoc, java.lang.String debitAccount, java.lang.String bp, java.lang.String receiverComments, java.lang.String receiverPrivateNotes, java.math.BigDecimal due, java.lang.String vendorInvoice, java.lang.String vendorPackage, java.math.BigDecimal vendorTotal, java.util.Date vendorInvoiceDate, java.util.Date paydate, java.util.Date datePaid, java.lang.String checkNo, java.math.BigDecimal paid, java.lang.String itran, java.lang.String etran, int lastChangeTimes, CustomerVendorAddressInfoVO vendorAddressInfoVO)
full constructor
VendorContractPriceVendorVO(VendorContractPriceVendorPK pk, java.lang.String contractName, CustomerVendorAddressInfoVO vendorInfo)
full constructor

Uses of CustomerVendorAddressInfoVO in bb.common.box

Methods in bb.common.box that return CustomerVendorAddressInfoVO
CustomerVendorAddressInfoVO | AddressBox.getCustomerVendorInfoVoById(java.lang.String id)
CustomerVendorAddressInfoVO | AddressBox.getCustomerVendorInfoVoById(java.lang.String id, java.lang.String languageCode)

Methods in bb.common.box that return types with arguments of type CustomerVendorAddressInfoVO
java.util.Collection<CustomerVendorAddressInfoVO> | AddressBox.findAllCustomers(int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | AddressBox.findAllCustomerVendorAddresses(int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | AddressBox.findAllCVAddress()
java.util.Collection<CustomerVendorAddressInfoVO> | AddressBox.findAllLockedCustomer(boolean lockTypeIsOverCreditLimit, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | AddressBox.findAllVendors(int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | AddressBox.findCustomerAddressesById(java.lang.String idRegex, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | AddressBox.findCustomerAddressesByName(java.lang.String nameRegex, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | AddressBox.findCustomersList(java.lang.String addrId, java.lang.String name, java.lang.String customerType, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | AddressBox.findCustomerVendorAddressesById(java.lang.String idRegex, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | AddressBox.findCustomerVendorAddressesById(java.lang.String addrId, java.lang.String withoutId, java.lang.String addressType)
java.util.Collection<CustomerVendorAddressInfoVO> | AddressBox.findCustomerVendorAddressesByName(java.lang.String nameRegex, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | AddressBox.findCustomerVendorbyType(java.lang.String[] types, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | AddressBox.findCustomerVendors(java.lang.String addrId, java.lang.String name, java.lang.String customerType, java.lang.String vendorType, java.lang.String vendorCategory, java.lang.String criticalLevel, java.lang.String qualityStatus, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | AddressBox.findDeletedCustomersById(java.lang.String customerId, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | AddressBox.findDeletedCustomerVendorAddressesById(java.lang.String idRegex, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | AddressBox.findDeletedVendorsById(java.lang.String vendorId, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | AddressBox.findDepartmentsList(java.lang.String addrId, java.lang.String name, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | AddressBox.findSgClientProgramUser(java.lang.String addressId, java.lang.String addressName, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | AddressBox.findVendorAddressesById(java.lang.String idRegex, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | AddressBox.findVendorAddressesByName(java.lang.String nameRegex, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | AddressBox.findVendorsList(java.lang.String vendorId, java.lang.String name, java.lang.String vendorType, java.lang.String vendorCategory, java.lang.String criticalLevel, java.lang.String qualityStatus, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressInfoVO> | AddressBox.findVendorsListForSeparate(java.lang.String vendorId, java.lang.String name, java.lang.String vendorType, java.lang.String vendorCategory, java.lang.String criticalLevel, java.lang.String qualityStatus, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomerVendorAddressTotalInfo

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomerVendorAddressTotalInfo

Packages that use CustomerVendorAddressTotalInfo
bb.common.box

Uses of CustomerVendorAddressTotalInfo in bb.common.box

Methods in bb.common.box that return CustomerVendorAddressTotalInfo
CustomerVendorAddressTotalInfo | AddressBox.getCustomerTotalInfo(java.lang.String vendorId)
CustomerVendorAddressTotalInfo | AddressBox.getCVAddressTotalInfo(java.lang.String vendorId)
CustomerVendorAddressTotalInfo | AddressBox.getDepartmentTotalInfo(java.lang.String vendorId)
CustomerVendorAddressTotalInfo | AddressBox.getVendorTotalInfo(java.lang.String vendorId)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomerVendorAddressVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomerVendorAddressVO

Packages that use CustomerVendorAddressVO
bb.common.box

Uses of CustomerVendorAddressVO in bb.common.box

Methods in bb.common.box that return CustomerVendorAddressVO
CustomerVendorAddressVO | AddressBox.addCustomer(CustomerVendorAddressVO vo)
CustomerVendorAddressVO | AddressBox.addCustomerAndVendor(CustomerVendorAddressVO vo)
CustomerVendorAddressVO | AddressBox.addCustomerVendorAddress(CustomerVendorAddressVO cvAddress)
CustomerVendorAddressVO | AddressBox.addDepartment(CustomerVendorAddressVO vo)
CustomerVendorAddressVO | AddressBox.addVendor(CustomerVendorAddressVO vo)
CustomerVendorAddressVO | AddressBox.constructCustomerVendorAddressForCRFQ(java.lang.String crfqNumber)
CustomerVendorAddressVO | CompanyBox.getAddressOfCompanyID()
CustomerVendorAddressVO | AddressBox.getCustomerById(java.lang.String addressId)
CustomerVendorAddressVO | AddressBox.getCustomerVendorAddressById(java.lang.String id)
CustomerVendorAddressVO | AddressBox.getDepartmentById(java.lang.String id)
CustomerVendorAddressVO | AddressBox.getVendorById(java.lang.String addressId)
CustomerVendorAddressVO | AddressBox.updateAddressQualityInfo(CustomerVendorAddressVO cvAddress)
CustomerVendorAddressVO | AddressBox.updateCustomer(CustomerVendorAddressVO vo)
CustomerVendorAddressVO | AddressBox.updateCustomerVendorAddress(CustomerVendorAddressVO cvAddress)
CustomerVendorAddressVO | AddressBox.updateDepartment(CustomerVendorAddressVO vo)
CustomerVendorAddressVO | AddressBox.updateVendor(CustomerVendorAddressVO vo)
CustomerVendorAddressVO | AddressBox.updateVendorQualityInfo(CustomerVendorAddressVO vo)

Methods in bb.common.box that return types with arguments of type CustomerVendorAddressVO
java.util.Collection<CustomerVendorAddressVO> | AddressBox.findAllDepartments(int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressVO> | AddressBox.findDeletedDepartmentsById(java.lang.String id, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressVO> | AddressBox.findDepartmentsById(java.lang.String id, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorAddressVO> | AddressBox.findDepartmentsByName(java.lang.String name, java.lang.String languageCode, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type CustomerVendorAddressVO
CustomerVendorAddressVO | AddressBox.addCustomer(CustomerVendorAddressVO vo)
CustomerVendorAddressVO | AddressBox.addCustomerAndVendor(CustomerVendorAddressVO vo)
CustomerVendorAddressVO | AddressBox.addCustomerVendorAddress(CustomerVendorAddressVO cvAddress)
CustomerVendorAddressVO | AddressBox.addDepartment(CustomerVendorAddressVO vo)
CustomerVendorAddressVO | AddressBox.addVendor(CustomerVendorAddressVO vo)
CustomerVendorAddressVO | AddressBox.updateAddressQualityInfo(CustomerVendorAddressVO cvAddress)
CustomerVendorAddressVO | AddressBox.updateCustomer(CustomerVendorAddressVO vo)
void | AddressBox.updateCustomerToAllType(CustomerVendorAddressVO vo)
CustomerVendorAddressVO | AddressBox.updateCustomerVendorAddress(CustomerVendorAddressVO cvAddress)
CustomerVendorAddressVO | AddressBox.updateDepartment(CustomerVendorAddressVO vo)
CustomerVendorAddressVO | AddressBox.updateVendor(CustomerVendorAddressVO vo)
CustomerVendorAddressVO | AddressBox.updateVendorQualityInfo(CustomerVendorAddressVO vo)
void | AddressBox.updateVendorToAllType(CustomerVendorAddressVO vo)

Method parameters in bb.common.box with type arguments of type CustomerVendorAddressVO
void | CompanyBox.importTempAddress(java.util.ArrayList<CustomerVendorAddressVO> address)
void | CompanyBox.importTempCustomer(java.util.ArrayList<CustomerVendorAddressVO> address)
void | CompanyBox.importTempDepartment(java.util.ArrayList<CustomerVendorAddressVO> address)
void | CompanyBox.importTempVendor(java.util.ArrayList<CustomerVendorAddressVO> address)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomerVendorContactPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomerVendorContactPK

Packages that use CustomerVendorContactPK
bb.common

Uses of CustomerVendorContactPK in bb.common

Methods in bb.common that return CustomerVendorContactPK
 CustomerVendorContactPK CustomerVendorContactVO.getPk()

Methods in bb.common with parameters of type CustomerVendorContactPK
 void CustomerVendorContactVO.setPk(CustomerVendorContactPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomerVendorContactVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomerVendorContactVO

Packages that use CustomerVendorContactVO
bb.common
bb.common.box

Uses of CustomerVendorContactVO in bb.common

Methods in bb.common that return types with arguments of type CustomerVendorContactVO
java.util.Set<CustomerVendorContactVO> | CustomerVendorAddressVO.getContacts()
java.util.Set<CustomerVendorContactVO> | AllStatementsListResult.getContacts()

Method parameters in bb.common with type arguments of type CustomerVendorContactVO
void | CustomerVendorAddressVO.setContacts(java.util.Set<CustomerVendorContactVO> contacts)
void | AllStatementsListResult.setContacts(java.util.Set<CustomerVendorContactVO> contacts)

Uses of CustomerVendorContactVO in bb.common.box

Methods in bb.common.box that return types with arguments of type CustomerVendorContactVO
java.util.Collection<CustomerVendorContactVO> | AddressBox.findAllAddressContact(java.lang.String addressID, java.lang.String addressName, boolean idLike, int firstIndex, int maxLength)
java.util.Collection<CustomerVendorContactVO> | AddressBox.findAllAddressContact(java.lang.String addressID, java.lang.String addressName, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomerVendorDescriptionPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomerVendorDescriptionPK

Packages that use CustomerVendorDescriptionPK
bb.common

Uses of CustomerVendorDescriptionPK in bb.common

Methods in bb.common that return CustomerVendorDescriptionPK
 CustomerVendorDescriptionPK CustomerVendorDescriptionVO.getPk()

Methods in bb.common with parameters of type CustomerVendorDescriptionPK
 void CustomerVendorDescriptionVO.setPk(CustomerVendorDescriptionPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomerVendorDescriptionVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomerVendorDescriptionVO

No usage of bb.common.CustomerVendorDescriptionVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomerVendorTypeVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomerVendorTypeVO

Packages that use CustomerVendorTypeVO
bb.common.box

Uses of CustomerVendorTypeVO in bb.common.box

Methods in bb.common.box that return CustomerVendorTypeVO
CustomerVendorTypeVO | AddressBox.getCustomerTypeByType(java.lang.String customerType)
CustomerVendorTypeVO | AddressBox.getCustomerVendorTypeByID(int id)
CustomerVendorTypeVO | AddressBox.getVendorTypeByType(java.lang.String vendorType)
CustomerVendorTypeVO | AddressBox.updateCustomerVendorType(CustomerVendorTypeVO vo)

Methods in bb.common.box that return types with arguments of type CustomerVendorTypeVO
java.util.Collection<CustomerVendorTypeVO> | AddressBox.findAllCustomerType(int firstIndex, int maxLength)
java.util.Collection<CustomerVendorTypeVO> | AddressBox.findAllVendorType(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type CustomerVendorTypeVO
void | AddressBox.deleteCustomerVendorType(CustomerVendorTypeVO vo)
CustomerVendorTypeVO | AddressBox.updateCustomerVendorType(CustomerVendorTypeVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomGoodsBreedVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomGoodsBreedVO

Packages that use CustomGoodsBreedVO
bb.common.box

Uses of CustomGoodsBreedVO in bb.common.box

Methods in bb.common.box that return CustomGoodsBreedVO
CustomGoodsBreedVO | HumanResourceBox.addCustomGoodsBreed(CustomGoodsBreedVO vo)
CustomGoodsBreedVO | HumanResourceBox.getCustomGoodsBreedByPk(java.lang.String id)

Methods in bb.common.box that return types with arguments of type CustomGoodsBreedVO
 java.util.Collection<CustomGoodsBreedVO> HumanResourceBox.findCustomGoodsBreedById(java.lang.String id, java.lang.String name, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type CustomGoodsBreedVO
CustomGoodsBreedVO | HumanResourceBox.addCustomGoodsBreed(CustomGoodsBreedVO vo)
void | HumanResourceBox.updateCustomGoodsBreed(CustomGoodsBreedVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomGoodsRecordVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomGoodsRecordVO

Packages that use CustomGoodsRecordVO
bb.common.box

Uses of CustomGoodsRecordVO in bb.common.box

Methods in bb.common.box that return CustomGoodsRecordVO
CustomGoodsRecordVO | HumanResourceBox.addCustomGoodsRecord(CustomGoodsRecordVO vo)
CustomGoodsRecordVO | HumanResourceBox.getCustomGoodsRecordByPk(java.lang.Long ii)

Methods in bb.common.box that return types with arguments of type CustomGoodsRecordVO
 java.util.Collection<CustomGoodsRecordVO> HumanResourceBox.findCustomGoodsRecordByDate(java.lang.String employeeId, java.lang.String goodsId, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type CustomGoodsRecordVO
CustomGoodsRecordVO | HumanResourceBox.addCustomGoodsRecord(CustomGoodsRecordVO vo)
void | HumanResourceBox.updateCustomGoodsRecord(CustomGoodsRecordVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomJobCategoryGoodsPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomJobCategoryGoodsPK

Packages that use CustomJobCategoryGoodsPK
bb.common

Uses of CustomJobCategoryGoodsPK in bb.common

Methods in bb.common that return CustomJobCategoryGoodsPK
 CustomJobCategoryGoodsPK CustomJobCategoryGoodsVO.getPk()

Methods in bb.common with parameters of type CustomJobCategoryGoodsPK
 void CustomJobCategoryGoodsVO.setPk(CustomJobCategoryGoodsPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomJobCategoryGoodsVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomJobCategoryGoodsVO

No usage of bb.common.CustomJobCategoryGoodsVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomJobCategoryVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomJobCategoryVO

Packages that use CustomJobCategoryVO
bb.common.box

Uses of CustomJobCategoryVO in bb.common.box

Methods in bb.common.box that return CustomJobCategoryVO
CustomJobCategoryVO | HumanResourceBox.addCustomJobCategory(CustomJobCategoryVO vo)
CustomJobCategoryVO | HumanResourceBox.getCustomJobCategoryByPk(java.lang.String id)

Methods in bb.common.box that return types with arguments of type CustomJobCategoryVO
 java.util.Collection<CustomJobCategoryVO> HumanResourceBox.findCustomJobCategoryById(java.lang.String id, java.lang.String name, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type CustomJobCategoryVO
CustomJobCategoryVO | HumanResourceBox.addCustomJobCategory(CustomJobCategoryVO vo)
void | HumanResourceBox.updateCustomJobCategory(CustomJobCategoryVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomSearchVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomSearchVO

Packages that use CustomSearchVO
bb.common.box

Uses of CustomSearchVO in bb.common.box

Methods in bb.common.box that return CustomSearchVO
 CustomSearchVO CompanyBox.getCustomSearch(java.lang.String id)

Methods in bb.common.box that return types with arguments of type CustomSearchVO
 java.util.Collection<CustomSearchVO> CompanyBox.findAllCustomSearch()

Methods in bb.common.box with parameters of type CustomSearchVO
void | CompanyBox.addCustomSearch(CustomSearchVO vo)
void | CompanyBox.deleteCustomSearch(CustomSearchVO vo)
void | CompanyBox.updateCustomSearch(CustomSearchVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CustomTranslationVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CustomTranslationVO

Packages that use CustomTranslationVO
bb.common.box

Uses of CustomTranslationVO in bb.common.box

Methods in bb.common.box that return types with arguments of type CustomTranslationVO
 java.util.Collection<CustomTranslationVO> CompanyBox.findAllCustomTranslation()

Method parameters in bb.common.box with type arguments of type CustomTranslationVO
 void CompanyBox.updateCustomTranslation(java.util.Set<CustomTranslationVO> customTranslations)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CV2CVAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CV2CVAgent

Packages that use CV2CVAgent
bb.common.box

Uses of CV2CVAgent in bb.common.box

Methods in bb.common.box with parameters of type CV2CVAgent
 java.lang.String AddressBox.copyCVFormCV(CV2CVAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CycleCountAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CycleCountAgent

Packages that use CycleCountAgent
bb.common.box

Uses of CycleCountAgent in bb.common.box

Method parameters in bb.common.box with type arguments of type CycleCountAgent
 java.util.Collection<CycleCountPK> WarehouseBox.updateCycleCount(java.util.ArrayList<CycleCountAgent> list)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CycleCountListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CycleCountListResult

Packages that use CycleCountListResult
bb.common.box

Uses of CycleCountListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type CycleCountListResult
java.util.Collection<CycleCountListResult> | WarehouseBox.findCommitCycleCountListResults(int worksheetNumber, boolean showUnCommittedOnly, int firstIndex, int maxLength)
java.util.Collection<CycleCountListResult> | WarehouseBox.findCycleCountListByPartNumber(int worksheetNumber, java.lang.String pnLike, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<CycleCountListResult> | WarehouseBox.findCycleCountListResults(int worksheetNumber, int firstIndex, int maxLength)
java.util.Collection<CycleCountListResult> | WarehouseBox.findCycleCountListResults(int worksheetNumber, int pageNubmer, int firstIndex, int maxLength)
java.util.Collection<CycleCountListResult> | WarehouseBox.findCycleCountListResultsWithAvgCost(int worksheetNumber, int pageNubmer, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CycleCountListTotalResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CycleCountListTotalResult

Packages that use CycleCountListTotalResult
bb.common.box

Uses of CycleCountListTotalResult in bb.common.box

Methods in bb.common.box that return CycleCountListTotalResult
CycleCountListTotalResult | WarehouseBox.getCycleCountListTotalResultWithAvgCost(int worksheetNumber, int pageNubmer)
CycleCountListTotalResult | WarehouseBox.getCycleCountTotalResultWithAvgCost(int worksheetNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CycleCountPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CycleCountPK

Packages that use CycleCountPK
bb.common
bb.common.box

Uses of CycleCountPK in bb.common

Methods in bb.common that return CycleCountPK
CycleCountPK | CycleCountVO.getPk()
CycleCountPK | CycleCountListResult.getPk()
CycleCountPK | CycleCountAgent.getPk()

Methods in bb.common with parameters of type CycleCountPK
void | CycleCountVO.setPk(CycleCountPK pk)
void | CycleCountListResult.setPk(CycleCountPK pk)
void | CycleCountAgent.setPk(CycleCountPK pk)

Uses of CycleCountPK in bb.common.box

Methods in bb.common.box that return CycleCountPK
 CycleCountPK WarehouseBox.addCycleCount(AddPhysicalInventoryAgent agent)

Methods in bb.common.box that return types with arguments of type CycleCountPK
 java.util.Collection<CycleCountPK> WarehouseBox.updateCycleCount(java.util.ArrayList<CycleCountAgent> list)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CycleCountStatusVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CycleCountStatusVO

Packages that use CycleCountStatusVO
bb.common.box

Uses of CycleCountStatusVO in bb.common.box

Methods in bb.common.box that return CycleCountStatusVO
 CycleCountStatusVO WarehouseBox.getCycleCountStatusVO(int workSheetNumber)

Methods in bb.common.box that return types with arguments of type CycleCountStatusVO
java.util.Collection<CycleCountStatusVO> | WarehouseBox.findCycleWorkSheetListResults(int firstIndex, int maxLength)
java.util.Collection<CycleCountStatusVO> | WarehouseBox.findCycleWorkSheetListResults(int workSheetNumber, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type CycleCountStatusVO
 int WarehouseBox.updateCycleCountStatus(CycleCountStatusVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.CycleCountVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.CycleCountVO

No usage of bb.common.CycleCountVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DataFilterVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DataFilterVO

Packages that use DataFilterVO
bb.common.box

Uses of DataFilterVO in bb.common.box

Methods in bb.common.box that return DataFilterVO
 DataFilterVO CompanyBox.getDataFilter(java.lang.String id)

Methods in bb.common.box that return types with arguments of type DataFilterVO
 java.util.Collection<DataFilterVO> CompanyBox.findAllDataFilter(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type DataFilterVO
void | CompanyBox.addDataFilter(DataFilterVO vo)
void | CompanyBox.updateDataFilter(DataFilterVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DBAccessException

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DBAccessException

Packages that use DBAccessException
bb.common

Uses of DBAccessException in bb.common

Methods in bb.common with parameters of type DBAccessException
static BizException BizException.getBizException(DBAccessException ex, java.lang.String target, Reason reason)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DBReason

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DBReason

No usage of bb.common.DBReason

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DebitsCreditsResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DebitsCreditsResult

Packages that use DebitsCreditsResult
bb.common.box

Uses of DebitsCreditsResult in bb.common.box

Methods in bb.common.box that return DebitsCreditsResult
DebitsCreditsResult | AccountingBox.getDebitsCreditsResultForAP(java.lang.String apNumber, java.lang.String language)
DebitsCreditsResult | AccountingBox.getDebitsCreditsResultForApp(java.lang.String appNumber)
DebitsCreditsResult | AccountingBox.getDebitsCreditsResultForAR(java.lang.String arNumber, java.lang.String language)
DebitsCreditsResult | AccountingBox.getDebitsCreditsResultForArp(java.lang.String arpNumber)
DebitsCreditsResult | AccountingBox.getDebitsCreditsResultForDM(java.lang.String apNumber, java.lang.String language)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DepartmentLocationForBackflushVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DepartmentLocationForBackflushVO

Packages that use DepartmentLocationForBackflushVO
bb.common.box

Uses of DepartmentLocationForBackflushVO in bb.common.box

Methods in bb.common.box that return DepartmentLocationForBackflushVO
DepartmentLocationForBackflushVO | WarehouseBox.addDepartmentLocationForBackflush(DepartmentLocationForBackflushVO vo)
DepartmentLocationForBackflushVO | WarehouseBox.getDepartmentLocationForBackflushByPk(java.lang.String pk)
DepartmentLocationForBackflushVO | WarehouseBox.updateDepartmentLocationForBackflush(DepartmentLocationForBackflushVO vo)

Methods in bb.common.box that return types with arguments of type DepartmentLocationForBackflushVO
 java.util.List<DepartmentLocationForBackflushVO> WarehouseBox.findAllDepartmentLocationForBackflushs(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type DepartmentLocationForBackflushVO
DepartmentLocationForBackflushVO | WarehouseBox.addDepartmentLocationForBackflush(DepartmentLocationForBackflushVO vo)
DepartmentLocationForBackflushVO | WarehouseBox.updateDepartmentLocationForBackflush(DepartmentLocationForBackflushVO vo)

Method parameters in bb.common.box with type arguments of type DepartmentLocationForBackflushVO
 void WarehouseBox.deleteDepartmentLocationForBackflush(java.util.ArrayList<DepartmentLocationForBackflushVO> list)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DepositSummaryResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DepositSummaryResult

Packages that use DepositSummaryResult
bb.common.box

Uses of DepositSummaryResult in bb.common.box

Methods in bb.common.box that return types with arguments of type DepositSummaryResult
 java.util.List<DepositSummaryResult> AccountingBox.findDepositSummary(java.lang.String[] includableAccount, java.util.Date fromDate, java.util.Date toDate)

Method parameters in bb.common.box with type arguments of type DepositSummaryResult
 java.lang.String AccountingBox.makeDepositGL(java.util.List<DepositSummaryResult> list, java.util.ArrayList<PaymentAgent> agentList)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DepreciateMonthlyReport

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DepreciateMonthlyReport

No usage of bb.common.DepreciateMonthlyReport

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DesignControlDocumentVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DesignControlDocumentVO

Packages that use DesignControlDocumentVO
bb.common.box

Uses of DesignControlDocumentVO in bb.common.box

Methods in bb.common.box that return DesignControlDocumentVO
 DesignControlDocumentVO EngineeringBox.getDCDocByPk(java.lang.Long pk)

Methods in bb.common.box that return types with arguments of type DesignControlDocumentVO
java.util.Collection<DesignControlDocumentVO> | EngineeringBox.deleteDCDoc(MiscDocAgent agent)
java.util.Collection<DesignControlDocumentVO> | EngineeringBox.updateDCDoc(MiscDocAgent agent)
java.util.Collection<DesignControlDocumentVO> | EngineeringBox.uploadDCDoc(MiscDocAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DesignControlInfoVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DesignControlInfoVO

No usage of bb.common.DesignControlInfoVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DesignControlListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DesignControlListResult

Packages that use DesignControlListResult
bb.common.box

Uses of DesignControlListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type DesignControlListResult
java.util.Collection<DesignControlListResult> | EngineeringBox.findDCsByDcNumber(java.lang.String dc, int firstIndex, int maxLength)
java.util.Collection<DesignControlListResult> | EngineeringBox.findDCsByEngineerNameLike(java.lang.String engineerNameLike, int firstIndex, int maxLength)
java.util.Collection<DesignControlListResult> | EngineeringBox.findDCsByPartLike(java.lang.String pnRegex, java.lang.String partType, java.lang.String projectDescription, int firstIndex, int maxLength)
java.util.Collection<DesignControlListResult> | EngineeringBox.findOpenDCs(int firstIndex, int maxLength)
java.util.Collection<DesignControlListResult> | EngineeringBox.findPastDueDCs(int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DesignControlVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DesignControlVO

Packages that use DesignControlVO
bb.common.box

Uses of DesignControlVO in bb.common.box

Methods in bb.common.box that return DesignControlVO
DesignControlVO | EngineeringBox.addDC(DesignControlVO vo)
DesignControlVO | EngineeringBox.getDCByDcNumber(java.lang.String dcNumber)
DesignControlVO | EngineeringBox.updateDC(DesignControlVO vo)

Methods in bb.common.box with parameters of type DesignControlVO
DesignControlVO | EngineeringBox.addDC(DesignControlVO vo)
void | EngineeringBox.deleteDc(DesignControlVO vo)
DesignControlVO | EngineeringBox.updateDC(DesignControlVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DisassembleWorkOrderApprovalVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DisassembleWorkOrderApprovalVO

Packages that use DisassembleWorkOrderApprovalVO
bb.common.box

Uses of DisassembleWorkOrderApprovalVO in bb.common.box

Methods in bb.common.box that return DisassembleWorkOrderApprovalVO
DisassembleWorkOrderApprovalVO | WorkOrderBox.addDisassembleWorkOrderApproval(java.lang.String employeeId)
DisassembleWorkOrderApprovalVO | WorkOrderBox.getDisassembleWorkOrderApprovalByEmployeeId(java.lang.String employeeId)
DisassembleWorkOrderApprovalVO | WorkOrderBox.getDisassembleWorkOrderApprovalByUserNumber(java.lang.String userName)
DisassembleWorkOrderApprovalVO | WorkOrderBox.updateDisassembleWorkOrderApproval(DisassembleWorkOrderApprovalVO dwoApprovalVO)

Methods in bb.common.box that return types with arguments of type DisassembleWorkOrderApprovalVO
 java.util.Collection<DisassembleWorkOrderApprovalVO> WorkOrderBox.findAllDisassembleWorkOrderApprovals(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type DisassembleWorkOrderApprovalVO
void | WorkOrderBox.deleteDisassembleWorkOrderApproval(DisassembleWorkOrderApprovalVO woApprovalVO)
DisassembleWorkOrderApprovalVO | WorkOrderBox.updateDisassembleWorkOrderApproval(DisassembleWorkOrderApprovalVO dwoApprovalVO)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DisassembleWorkOrderDocumentVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DisassembleWorkOrderDocumentVO

Packages that use DisassembleWorkOrderDocumentVO
bb.common.box

Uses of DisassembleWorkOrderDocumentVO in bb.common.box

Methods in bb.common.box that return DisassembleWorkOrderDocumentVO
 DisassembleWorkOrderDocumentVO WorkOrderBox.getDisassembleWorkOrderDocumentByID(java.lang.Long controlNumber)

Methods in bb.common.box that return types with arguments of type DisassembleWorkOrderDocumentVO
java.util.Collection<DisassembleWorkOrderDocumentVO> | WorkOrderBox.findDisassembleWorkOrderDocumentInfo(java.lang.String disassembleWorkOrderNumber)
java.util.Collection<DisassembleWorkOrderDocumentVO> | WorkOrderBox.uploadOrUpdateFTPDWODoc(MiscDocAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DisassembleWorkOrderIssueVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DisassembleWorkOrderIssueVO

Packages that use DisassembleWorkOrderIssueVO
bb.common.box

Uses of DisassembleWorkOrderIssueVO in bb.common.box

Methods in bb.common.box that return types with arguments of type DisassembleWorkOrderIssueVO
 java.util.Collection<DisassembleWorkOrderIssueVO> WorkOrderBox.getDWOShipperItemListResultsOfDisassembleWorkOrder(java.lang.String disassembleWorkOrderNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DisassembleWorkOrderIssuingItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DisassembleWorkOrderIssuingItemResult

Packages that use DisassembleWorkOrderIssuingItemResult
bb.common

Uses of DisassembleWorkOrderIssuingItemResult in bb.common

Methods in bb.common that return types with arguments of type DisassembleWorkOrderIssuingItemResult
 java.util.Set<DisassembleWorkOrderIssuingItemResult> DisassembleWorkOrderIssuingResult.getDisassembleIssuingItems()

Method parameters in bb.common with type arguments of type DisassembleWorkOrderIssuingItemResult
 void DisassembleWorkOrderIssuingResult.setDisassembleIssuingItems(java.util.Set<DisassembleWorkOrderIssuingItemResult> disassembleIssuingItems)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DisassembleWorkOrderIssuingResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DisassembleWorkOrderIssuingResult

Packages that use DisassembleWorkOrderIssuingResult
bb.common.box

Uses of DisassembleWorkOrderIssuingResult in bb.common.box

Methods in bb.common.box that return DisassembleWorkOrderIssuingResult
 DisassembleWorkOrderIssuingResult WarehouseBox.getDisassembleWorkOrderItemIssuingResult(java.lang.String disassembleWorkOrderNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DisassembleWorkOrderItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DisassembleWorkOrderItemListResult

Packages that use DisassembleWorkOrderItemListResult
bb.common.box

Uses of DisassembleWorkOrderItemListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type DisassembleWorkOrderItemListResult
java.util.Collection<DisassembleWorkOrderItemListResult> | WorkOrderBox.findCancelledDisassembleWorkOrderListResults(int firstIndex, int maxLength)
java.util.Collection<DisassembleWorkOrderItemListResult> | WorkOrderBox.findDisassembleWorkOrderListResultsByDate(java.lang.String dateType, java.util.Date dateFrom, java.util.Date dateTo, java.lang.String partNumber, java.lang.String partType, java.lang.String vendorId, java.lang.String project, java.lang.String creater, java.lang.String docRef, java.lang.String contact, java.lang.String status, boolean isLock, java.lang.String accounting, java.lang.String companyUnit, int firstIndex, int maxLength)
java.util.Collection<DisassembleWorkOrderItemListResult> | WorkOrderBox.findDisassembleWorkOrderListResultsByDwoNumber(java.lang.String dwoNumber, int firstIndex, int maxLength)
java.util.Collection<DisassembleWorkOrderItemListResult> | WorkOrderBox.findDisassembleWorkOrderListResultsByPN(java.lang.String pn, java.lang.String pa, int firstIndex, int maxLength)
java.util.Collection<DisassembleWorkOrderItemListResult> | WorkOrderBox.findNotCreateGlOfDisassembleWorkOrderItem(java.lang.String dateType, java.util.Date dateFrom, java.util.Date dateTo, java.lang.String partNumber, java.lang.String partType, java.lang.String vendorId, java.lang.String project, java.lang.String creater, java.lang.String docRef, java.lang.String contact, java.lang.String accounting, java.lang.String companyUnit)
java.util.Collection<DisassembleWorkOrderItemListResult> | WorkOrderBox.findOpenDisassembleWorkOrderItemListResultsByPartPK(PartPK partPk, int firstIndex, int maxLength)
java.util.Collection<DisassembleWorkOrderItemListResult> | WorkOrderBox.findOpenDisassembleWorkOrderListResultsByDwoNumber(java.lang.String dwoNumber, int firstIndex, int maxLength)
java.util.Collection<DisassembleWorkOrderItemListResult> | WorkOrderBox.findOpenDisassembleWorkOrderListResultsByVendorId(java.lang.String vendorId, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DisassembleWorkOrderItemPartDetailItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DisassembleWorkOrderItemPartDetailItemResult

Packages that use DisassembleWorkOrderItemPartDetailItemResult
bb.common
bb.common.box

Uses of DisassembleWorkOrderItemPartDetailItemResult in bb.common

Methods in bb.common that return types with arguments of type DisassembleWorkOrderItemPartDetailItemResult
 java.util.Set<DisassembleWorkOrderItemPartDetailItemResult> DisassembleWorkOrderItemPartDetailResult.getItems()

Method parameters in bb.common with type arguments of type DisassembleWorkOrderItemPartDetailItemResult
 void DisassembleWorkOrderItemPartDetailResult.setItems(java.util.Set<DisassembleWorkOrderItemPartDetailItemResult> items)

Uses of DisassembleWorkOrderItemPartDetailItemResult in bb.common.box

Methods in bb.common.box that return DisassembleWorkOrderItemPartDetailItemResult
DisassembleWorkOrderItemPartDetailItemResult | WorkOrderBox.addDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemPK itemPk, BB2Part partPk, java.math.BigDecimal qty, java.math.BigDecimal cost)
DisassembleWorkOrderItemPartDetailItemResult | WorkOrderBox.addDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemPK itemPk, java.math.BigDecimal qty, java.math.BigDecimal qtyReceived, java.math.BigDecimal cost, java.lang.String description)
DisassembleWorkOrderItemPartDetailItemResult | WorkOrderBox.getDisassembleWorkOrderItemPartDetailItemResult(DisassembleWorkOrderItemReceiverPK pk)
DisassembleWorkOrderItemPartDetailItemResult | WorkOrderBox.updateDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemReceiverVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DisassembleWorkOrderItemPartDetailResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DisassembleWorkOrderItemPartDetailResult

Packages that use DisassembleWorkOrderItemPartDetailResult
bb.common.box

Uses of DisassembleWorkOrderItemPartDetailResult in bb.common.box

Methods in bb.common.box that return DisassembleWorkOrderItemPartDetailResult
 DisassembleWorkOrderItemPartDetailResult WorkOrderBox.getDwoPartDetailResult(DisassembleWorkOrderItemPK woItemPk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DisassembleWorkOrderItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DisassembleWorkOrderItemPK

Packages that use DisassembleWorkOrderItemPK
bb.common
bb.common.box

Uses of DisassembleWorkOrderItemPK in bb.common

Methods in bb.common that return DisassembleWorkOrderItemPK
DisassembleWorkOrderItemPK | DisassembleWorkOrderItemPartDetailResult.getDisassembleWorkOrderItemPk()
DisassembleWorkOrderItemPK | DisassembleWorkOrderItemListResult.getDwoItemPk()
DisassembleWorkOrderItemPK | DisassembleWorkOrderItemVO.getPk()

Methods in bb.common with parameters of type DisassembleWorkOrderItemPK
int | DisassembleWorkOrderItemPK.compareTo(DisassembleWorkOrderItemPK other)
void | DisassembleWorkOrderItemPartDetailResult.setDisassembleWorkOrderItemPk(DisassembleWorkOrderItemPK disassembleWorkOrderItemPk)
void | DisassembleWorkOrderItemListResult.setDwoItemPk(DisassembleWorkOrderItemPK dwoItemPk)
void | DisassembleWorkOrderItemVO.setPk(DisassembleWorkOrderItemPK pk)

Uses of DisassembleWorkOrderItemPK in bb.common.box

Methods in bb.common.box that return DisassembleWorkOrderItemPK
DisassembleWorkOrderItemPK | WarehouseBox.makeDisassembleWorkOrderReceiver(java.util.Set<ReceiverItemAgent> agent)
DisassembleWorkOrderItemPK | WorkOrderBox.setupDisassembleWorkOrderItem(DisassembleWorkOrderItemPK itemPk, java.util.ArrayList items)

Methods in bb.common.box with parameters of type DisassembleWorkOrderItemPK
DisassembleWorkOrderItemPartDetailItemResult | WorkOrderBox.addDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemPK itemPk, BB2Part partPk, java.math.BigDecimal qty, java.math.BigDecimal cost)
DisassembleWorkOrderItemPartDetailItemResult | WorkOrderBox.addDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemPK itemPk, java.math.BigDecimal qty, java.math.BigDecimal qtyReceived, java.math.BigDecimal cost, java.lang.String description)
void | WorkOrderBox.addDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemPK itemPk, java.util.LinkedHashMap<BB2Part,java.math.BigDecimal> map)
GeneralLedgerVO | WorkOrderBox.batchDisassembelWorkOrderGLByDwoItem(DisassembleWorkOrderItemPK[] pks, java.lang.String companyUnitId, java.lang.String glSummary)
java.util.Collection<PartReceivedVO> | WorkOrderBox.findDisassembleWorkOrderReceivedDetail(DisassembleWorkOrderItemPK pk, BB2Part part, java.lang.String description, int firstIndex, int maxLength)
DisassembleWorkOrderItemVO | WorkOrderBox.getDisassembleWorkOrderItemById(DisassembleWorkOrderItemPK itemPk)
int | WorkOrderBox.getDisassembleWorkOrderReceivedDetail(DisassembleWorkOrderItemPK pk, BB2Part part, java.lang.String description)
java.lang.Object[] | WorkOrderBox.getDisassembleWorkOrderReceivedDetailTotal(DisassembleWorkOrderItemPK pk, BB2Part part, java.lang.String description)
DisassembleWorkOrderReceivingResult | WarehouseBox.getDisassembleWorkOrderReceivingResult(DisassembleWorkOrderItemPK itemPk, boolean withOtherLocation)
java.math.BigDecimal | WorkOrderBox.getDWIPartDetailTotalReceivedCost(DisassembleWorkOrderItemPK dwiPk)
DisassembleWorkOrderItemPartDetailResult | WorkOrderBox.getDwoPartDetailResult(DisassembleWorkOrderItemPK woItemPk)
boolean | WorkOrderBox.isDisassembleWorkOrderItemExist(DisassembleWorkOrderItemPK pk)
DisassembleWorkOrderItemPK | WorkOrderBox.setupDisassembleWorkOrderItem(DisassembleWorkOrderItemPK itemPk, java.util.ArrayList items)
void | WorkOrderBox.updateDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemPK itemPk, java.util.LinkedHashMap<BB2Part,java.math.BigDecimal> map)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DisassembleWorkOrderItemReceiverPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DisassembleWorkOrderItemReceiverPK

Packages that use DisassembleWorkOrderItemReceiverPK
bb.common
bb.common.box

Uses of DisassembleWorkOrderItemReceiverPK in bb.common

Methods in bb.common that return DisassembleWorkOrderItemReceiverPK
DisassembleWorkOrderItemReceiverPK | DisassembleWorkOrderItemPartDetailItemResult.getItemReceivePk()
DisassembleWorkOrderItemReceiverPK | DisassembleWorkOrderItemReceiverVO.getPk()

Methods in bb.common with parameters of type DisassembleWorkOrderItemReceiverPK
 void DisassembleWorkOrderItemReceiverVO.setPk(DisassembleWorkOrderItemReceiverPK pk)

Uses of DisassembleWorkOrderItemReceiverPK in bb.common.box

Methods in bb.common.box with parameters of type DisassembleWorkOrderItemReceiverPK
void | WorkOrderBox.deleteDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemReceiverPK issuePk)
DisassembleWorkOrderItemPartDetailItemResult | WorkOrderBox.getDisassembleWorkOrderItemPartDetailItemResult(DisassembleWorkOrderItemReceiverPK pk)

Method parameters in bb.common.box with type arguments of type DisassembleWorkOrderItemReceiverPK
 void WorkOrderBox.deleteDisassembleWorkOrderItemReceivers(java.util.ArrayList<DisassembleWorkOrderItemReceiverPK> items)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DisassembleWorkOrderItemReceiverVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DisassembleWorkOrderItemReceiverVO

Packages that use DisassembleWorkOrderItemReceiverVO
bb.common
bb.common.box

Uses of DisassembleWorkOrderItemReceiverVO in bb.common

Methods in bb.common that return DisassembleWorkOrderItemReceiverVO
 DisassembleWorkOrderItemReceiverVO DisassembleWorkOrderItemPartDetailItemResult.getReceiveVo()

Methods in bb.common with parameters of type DisassembleWorkOrderItemReceiverVO
 void DisassembleWorkOrderItemPartDetailItemResult.setReceiveVo(DisassembleWorkOrderItemReceiverVO receiveVo)

Uses of DisassembleWorkOrderItemReceiverVO in bb.common.box

Methods in bb.common.box with parameters of type DisassembleWorkOrderItemReceiverVO
void | WorkOrderBox.deleteDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemReceiverVO vo)
DisassembleWorkOrderItemPartDetailItemResult | WorkOrderBox.updateDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemReceiverVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DisassembleWorkOrderItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DisassembleWorkOrderItemVO

Packages that use DisassembleWorkOrderItemVO
bb.common.box

Uses of DisassembleWorkOrderItemVO in bb.common.box

Methods in bb.common.box that return DisassembleWorkOrderItemVO
DisassembleWorkOrderItemVO | WorkOrderBox.getDisassembleWorkOrderItemById(DisassembleWorkOrderItemPK itemPk)
DisassembleWorkOrderItemVO | WorkOrderBox.initDisassembleWorkOrderItem(java.lang.String dwoNumber, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty, java.lang.String partFrom, java.lang.String naDesc)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DisassembleWorkOrderListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DisassembleWorkOrderListResult

Packages that use DisassembleWorkOrderListResult
bb.common.box

Uses of DisassembleWorkOrderListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type DisassembleWorkOrderListResult
 java.util.List<DisassembleWorkOrderListResult> WorkOrderBox.findDisassembleWorkOrderListResultById(java.lang.String dwoNumber, java.lang.String[] status, java.lang.String vendorId, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DisassembleWorkOrderReceivingResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DisassembleWorkOrderReceivingResult

Packages that use DisassembleWorkOrderReceivingResult
bb.common.box

Uses of DisassembleWorkOrderReceivingResult in bb.common.box

Methods in bb.common.box that return DisassembleWorkOrderReceivingResult
 DisassembleWorkOrderReceivingResult WarehouseBox.getDisassembleWorkOrderReceivingResult(DisassembleWorkOrderItemPK itemPk, boolean withOtherLocation)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DisassembleWorkOrderVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DisassembleWorkOrderVO

Packages that use DisassembleWorkOrderVO
bb.common.box

Uses of DisassembleWorkOrderVO in bb.common.box

Methods in bb.common.box that return DisassembleWorkOrderVO
DisassembleWorkOrderVO | WorkOrderBox.approveDisassembleWorkOrder(DisassembleWorkOrderVO vo)
DisassembleWorkOrderVO | WorkOrderBox.getDisassembleWorkOrderByDwo(java.lang.String id)
DisassembleWorkOrderVO | WorkOrderBox.getDisassembleWorkOrderWithOrderApplyByDwo(java.lang.Long orderApplyID)

Methods in bb.common.box with parameters of type DisassembleWorkOrderVO
DisassembleWorkOrderVO | WorkOrderBox.approveDisassembleWorkOrder(DisassembleWorkOrderVO vo)
java.lang.String | WorkOrderBox.updateDisassembleWorkOrder(DisassembleWorkOrderVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DocumentAction

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DocumentAction

No usage of bb.common.DocumentAction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DocumentAction.DwfAndDwgDocAction

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DocumentAction.DwfAndDwgDocAction

No usage of bb.common.DocumentAction.DwfAndDwgDocAction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DocumentAction.MiscDocAction

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DocumentAction.MiscDocAction

No usage of bb.common.DocumentAction.MiscDocAction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DocumentAction.PartDocAction

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DocumentAction.PartDocAction

No usage of bb.common.DocumentAction.PartDocAction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DocumentInfoAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DocumentInfoAgent

Packages that use DocumentInfoAgent
bb.common.box

Uses of DocumentInfoAgent in bb.common.box

Methods in bb.common.box with parameters of type DocumentInfoAgent
 void DocumentBox.deleteFtpDocument(DocumentInfoAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DocumentLogVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DocumentLogVO

No usage of bb.common.DocumentLogVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DocumentServerVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DocumentServerVO

Packages that use DocumentServerVO
bb.common.box

Uses of DocumentServerVO in bb.common.box

Methods in bb.common.box that return DocumentServerVO
DocumentServerVO | CompanyBox.addDocumentServerSettings(DocumentServerVO vo)
DocumentServerVO | CompanyBox.getDocumentServerSettingsByDocType(java.lang.String documentType)

Methods in bb.common.box that return types with arguments of type DocumentServerVO
 java.util.Collection<DocumentServerVO> CompanyBox.findAllDocumentServerSettings(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type DocumentServerVO
DocumentServerVO | CompanyBox.addDocumentServerSettings(DocumentServerVO vo)
void | CompanyBox.updateDocumentServerSettings(DocumentServerVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DuePATotalByVendorResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DuePATotalByVendorResult

Packages that use DuePATotalByVendorResult
bb.common.box

Uses of DuePATotalByVendorResult in bb.common.box

Methods in bb.common.box that return types with arguments of type DuePATotalByVendorResult
java.util.Collection<DuePATotalByVendorResult> | AccountingBox.getAPDueTotal(java.lang.String vendorId)
java.util.Collection<DuePATotalByVendorResult> | AccountingBox.getAPOpenByVendorIdTotal(java.lang.String vendorId)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DwfUploadSettingsVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DwfUploadSettingsVO

Packages that use DwfUploadSettingsVO
bb.common.box

Uses of DwfUploadSettingsVO in bb.common.box

Methods in bb.common.box that return DwfUploadSettingsVO
DwfUploadSettingsVO | CompanyBox.addDwfUploadSettings(DwfUploadSettingsVO vo)
DwfUploadSettingsVO | CompanyBox.getDwfUploadSettingsVO(java.lang.String drawingType)

Methods in bb.common.box with parameters of type DwfUploadSettingsVO
DwfUploadSettingsVO | CompanyBox.addDwfUploadSettings(DwfUploadSettingsVO vo)
void | CompanyBox.updateDwfUploadSettings(DwfUploadSettingsVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DwgUploadSettingsVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DwgUploadSettingsVO

Packages that use DwgUploadSettingsVO
bb.common.box

Uses of DwgUploadSettingsVO in bb.common.box

Methods in bb.common.box that return DwgUploadSettingsVO
DwgUploadSettingsVO | CompanyBox.addDwgUploadSettings(DwgUploadSettingsVO vo)
DwgUploadSettingsVO | CompanyBox.getDwgUploadSettingsVO(java.lang.String drawingType)

Methods in bb.common.box with parameters of type DwgUploadSettingsVO
DwgUploadSettingsVO | CompanyBox.addDwgUploadSettings(DwgUploadSettingsVO vo)
void | CompanyBox.updateDwgUploadSettings(DwgUploadSettingsVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DWOIssueDetail

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DWOIssueDetail

Packages that use DWOIssueDetail
bb.common.box

Uses of DWOIssueDetail in bb.common.box

Methods in bb.common.box that return types with arguments of type DWOIssueDetail
 java.util.Collection<DWOIssueDetail> WarehouseBox.findDWOIssueItems(java.lang.String disassembleWorkOrder, java.lang.String disassembleWorkOrderItem, java.lang.String customerId, java.lang.String pn, java.lang.String pa, java.util.Date fromDate, java.util.Date toDate, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String[] branchWarehouses, boolean isIncludeNA, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.DynamicSearchFilter

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.DynamicSearchFilter

Packages that use DynamicSearchFilter
bb.common

Uses of DynamicSearchFilter in bb.common

Methods in bb.common that return DynamicSearchFilter
 DynamicSearchFilter ServerAction.getDynamicSearchFilter()

Methods in bb.common with parameters of type DynamicSearchFilter
 void ServerAction.setDynamicSearchFilter(DynamicSearchFilter dynamicSearchFilter)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EcnCheckOrderResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EcnCheckOrderResult

Packages that use EcnCheckOrderResult
bb.common.box

Uses of EcnCheckOrderResult in bb.common.box

Methods in bb.common.box that return EcnCheckOrderResult
 EcnCheckOrderResult EngineeringBox.getEcnCheckOrderResult(BB2Part pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EcnPOOrderResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EcnPOOrderResult

No usage of bb.common.EcnPOOrderResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ECNReviewVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ECNReviewVO

Packages that use ECNReviewVO
bb.common.box

Uses of ECNReviewVO in bb.common.box

Methods in bb.common.box that return ECNReviewVO
ECNReviewVO | EngineeringBox.addECNControl(java.lang.String employeeId)
ECNReviewVO | EngineeringBox.getECNControlByBizBoxUserNumber(java.lang.String bizboxUserName)
ECNReviewVO | EngineeringBox.getECNControlByEmployeeId(java.lang.String employeeId)
ECNReviewVO | EngineeringBox.getECNControlByUserName(java.lang.String userName)

Methods in bb.common.box that return types with arguments of type ECNReviewVO
java.util.Collection<ECNReviewVO> | EngineeringBox.findAllECNControl(int firstIndex, int maxLength)
java.util.Collection<ECNReviewVO> | EngineeringBox.findECNControlByUserName(java.lang.String userNameLike, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type ECNReviewVO
 void EngineeringBox.updateECNControl(ECNReviewVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EcnWOOrderResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EcnWOOrderResult

No usage of bb.common.EcnWOOrderResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ECRReviewVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ECRReviewVO

Packages that use ECRReviewVO
bb.common.box

Uses of ECRReviewVO in bb.common.box

Methods in bb.common.box that return ECRReviewVO
ECRReviewVO | EngineeringBox.addECRControl(java.lang.String employeeId)
ECRReviewVO | EngineeringBox.getECRControlByBizBoxUserNumber(java.lang.String bizboxUserName)
ECRReviewVO | EngineeringBox.getECRControlByEmployeeId(java.lang.String employeeId)
ECRReviewVO | EngineeringBox.getECRControlByUserName(java.lang.String userName)

Methods in bb.common.box that return types with arguments of type ECRReviewVO
java.util.Collection<ECRReviewVO> | EngineeringBox.findAllECRControl(int firstIndex, int maxLength)
java.util.Collection<ECRReviewVO> | EngineeringBox.findECRControlByUserName(java.lang.String userNameLike, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type ECRReviewVO
 void EngineeringBox.updateECRControl(ECRReviewVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EjbMethodVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EjbMethodVO

Packages that use EjbMethodVO
bb.common
bb.common.box

Uses of EjbMethodVO in bb.common

Methods in bb.common that return EjbMethodVO
 EjbMethodVO PermissionMethodVO.getEjbMethod()

Methods in bb.common with parameters of type EjbMethodVO
 void PermissionMethodVO.setEjbMethod(EjbMethodVO ejbMethod)

Uses of EjbMethodVO in bb.common.box

Methods in bb.common.box that return types with arguments of type EjbMethodVO
java.util.Collection<EjbMethodVO> | SecurityBox.findAllMethod(int firstIndex, int maxLength)
java.util.Collection<EjbMethodVO> | SecurityBox.findMethodsByEjbName(java.lang.String ejbName, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type EjbMethodVO
void | SecurityBox.addEjbMethod(EjbMethodVO ejbMethodVo)
void | SecurityBox.deleteEjbMethod(EjbMethodVO ejbMethodVo)
void | SecurityBox.updateEjbMethod(EjbMethodVO ejbMethodVo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EmployeeCardVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EmployeeCardVO

Packages that use EmployeeCardVO
bb.common
bb.common.box

Uses of EmployeeCardVO in bb.common

Methods in bb.common that return EmployeeCardVO
EmployeeCardVO | AccountsPayableVO.getEmployee()
EmployeeCardVO | AccountsPayableInfoVO.getEmployee()

Methods in bb.common with parameters of type EmployeeCardVO
void | AccountsPayableVO.setEmployee(EmployeeCardVO employee)
void | AccountsPayableInfoVO.setEmployee(EmployeeCardVO employee)

Uses of EmployeeCardVO in bb.common.box

Methods in bb.common.box that return EmployeeCardVO
EmployeeCardVO | HumanResourceBox.getEmployeeBasicInfoAndPic(java.lang.String employeeID)
EmployeeCardVO | HumanResourceBox.getEmployeeCardById(java.lang.String id)
EmployeeCardVO | HumanResourceBox.getEmployeeCardById(java.lang.String employeeId, boolean tempworker)
EmployeeCardVO | HumanResourceBox.getEmployeeSelf()

Methods in bb.common.box that return types with arguments of type EmployeeCardVO
java.util.Collection<EmployeeCardVO> | HumanResourceBox.findAllEmployeeCards(int firstIndex, int maxLength)
java.util.Collection<EmployeeCardVO> | HumanResourceBox.findCompanyAddressBook(int firstIndex, int maxLength)
java.util.Collection<EmployeeCardVO> | HumanResourceBox.findEmployeeCards(java.lang.String employeeIdExp, java.lang.String lastName, java.lang.String departmentExp, java.lang.String[] status, boolean listInAddressBook, boolean tempworker, int firstIndex, int maxLength)
java.util.Collection<EmployeeCardVO> | HumanResourceBox.findEmployeeCardsByDepartment(java.lang.String department, boolean tempworker, int firstIndex, int maxLength)
java.util.Collection<EmployeeCardVO> | HumanResourceBox.findEmployeeCardsByEmployeeId(java.lang.String employeeIdLike, boolean tempworker, int firstIndex, int maxLength)
java.util.Collection<EmployeeCardVO> | HumanResourceBox.findEmployeeCardsByLastName(java.lang.String lastName, boolean tempworker, int firstIndex, int maxLength)
java.util.Collection<EmployeeCardVO> | HumanResourceBox.findEmployeeCardsByName(java.lang.String name, boolean tempworker, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type EmployeeCardVO
java.lang.String | HumanResourceBox.addEmployeeCard(EmployeeCardVO vo, boolean autoEmployeeId)
java.lang.String | HumanResourceBox.addTemporaryEmployee(EmployeeCardVO vo)
java.lang.String | HumanResourceBox.addTempToEmployeeCard(EmployeeCardVO vo, java.lang.String employeeId)
java.lang.String | HumanResourceBox.updateEmployeeCard(EmployeeCardVO vo)
java.lang.String | HumanResourceBox.updateTemporaryEmployee(EmployeeCardVO vo)

Method parameters in bb.common.box with type arguments of type EmployeeCardVO
 void CompanyBox.importTempEmployee(java.util.ArrayList<EmployeeCardVO> employees)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EmployeeEducationPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EmployeeEducationPK

Packages that use EmployeeEducationPK
bb.common
bb.common.box

Uses of EmployeeEducationPK in bb.common

Methods in bb.common that return EmployeeEducationPK
 EmployeeEducationPK EmployeeEducationVO.getPk()

Methods in bb.common with parameters of type EmployeeEducationPK
 void EmployeeEducationVO.setPk(EmployeeEducationPK pk)

Uses of EmployeeEducationPK in bb.common.box

Methods in bb.common.box with parameters of type EmployeeEducationPK
void | HumanResourceBox.deleteEmployeeEducation(EmployeeEducationPK pk)
EmployeeEducationVO | HumanResourceBox.getEmployeeEducationByPK(EmployeeEducationPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EmployeeEducationResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EmployeeEducationResult

Packages that use EmployeeEducationResult
bb.common.box

Uses of EmployeeEducationResult in bb.common.box

Methods in bb.common.box that return types with arguments of type EmployeeEducationResult
 java.util.Collection<EmployeeEducationResult> HumanResourceBox.findEmployeeEducation(boolean isTempWork, java.lang.String degree, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EmployeeEducationVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EmployeeEducationVO

Packages that use EmployeeEducationVO
bb.common
bb.common.box

Uses of EmployeeEducationVO in bb.common

Subclasses of EmployeeEducationVO in bb.common
 class EmployeeEducationResult

Uses of EmployeeEducationVO in bb.common.box

Methods in bb.common.box that return EmployeeEducationVO
 EmployeeEducationVO HumanResourceBox.getEmployeeEducationByPK(EmployeeEducationPK pk)

Methods in bb.common.box that return types with arguments of type EmployeeEducationVO
java.util.Collection<EmployeeEducationVO> | HumanResourceBox.addEmployeeEducation(EmployeeEducationVO vo)
java.util.Collection<EmployeeEducationVO> | HumanResourceBox.getEEByEmployeeId(java.lang.String employeeId)

Methods in bb.common.box with parameters of type EmployeeEducationVO
java.util.Collection<EmployeeEducationVO> | HumanResourceBox.addEmployeeEducation(EmployeeEducationVO vo)
void | HumanResourceBox.updateEmployeeEducation(EmployeeEducationVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EmployeeHomeVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EmployeeHomeVO

Packages that use EmployeeHomeVO
bb.common.box

Uses of EmployeeHomeVO in bb.common.box

Methods in bb.common.box that return EmployeeHomeVO
EmployeeHomeVO | HumanResourceBox.addEmployeeHome(EmployeeHomeVO vo)
EmployeeHomeVO | HumanResourceBox.getEmployeeHomeByPk(java.lang.String employeeId)

Methods in bb.common.box with parameters of type EmployeeHomeVO
EmployeeHomeVO | HumanResourceBox.addEmployeeHome(EmployeeHomeVO vo)
void | HumanResourceBox.updateEmployeeHome(EmployeeHomeVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EmployeeJobDescriptionVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EmployeeJobDescriptionVO

No usage of bb.common.EmployeeJobDescriptionVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EmployeeLaborAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EmployeeLaborAgent

Packages that use EmployeeLaborAgent
bb.common.box

Uses of EmployeeLaborAgent in bb.common.box

Methods in bb.common.box with parameters of type EmployeeLaborAgent
 java.lang.Long WorkOrderBox.addEmployeeLabor(EmployeeLaborAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EmployeePutGoodListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EmployeePutGoodListResult

Packages that use EmployeePutGoodListResult
bb.common.box

Uses of EmployeePutGoodListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type EmployeePutGoodListResult
 java.util.Collection<EmployeePutGoodListResult> HumanResourceBox.findEmployeeDoNotPutGoodsByDate(java.lang.String employee, java.lang.String goodsId, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EmployeeRecordsVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EmployeeRecordsVO

Packages that use EmployeeRecordsVO
bb.common.box

Uses of EmployeeRecordsVO in bb.common.box

Methods in bb.common.box that return types with arguments of type EmployeeRecordsVO
java.util.Collection<EmployeeRecordsVO> | HumanResourceBox.deleteEmployeeRecord(MiscDocAgent agent)
java.util.Collection<EmployeeRecordsVO> | HumanResourceBox.findEmployeeRecords(java.lang.String employeeId, java.lang.String recordType, boolean isTempWork, int firstIndex, int maxLength)
java.util.Collection<EmployeeRecordsVO> | HumanResourceBox.getEmployeeRecordsOfEmployee(java.lang.String employeeId)
java.util.Collection<EmployeeRecordsVO> | HumanResourceBox.uploadOrUpdateEmployeeRecord(MiscDocAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EmployeeTimeCardResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EmployeeTimeCardResult

Packages that use EmployeeTimeCardResult
bb.common.box

Uses of EmployeeTimeCardResult in bb.common.box

Methods in bb.common.box that return EmployeeTimeCardResult
 EmployeeTimeCardResult ManufacturingBox.findOpenTimeCardsById(java.lang.String employeeId)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EmployeeTrainingVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EmployeeTrainingVO

Packages that use EmployeeTrainingVO
bb.common.box

Uses of EmployeeTrainingVO in bb.common.box

Methods in bb.common.box that return EmployeeTrainingVO
 EmployeeTrainingVO HumanResourceBox.getEmployeeTrainingbyPk(EmployeeWorkExperiencePK pk)

Methods in bb.common.box that return types with arguments of type EmployeeTrainingVO
java.util.List<EmployeeTrainingVO> | HumanResourceBox.addEmployeeTraining(EmployeeTrainingVO vo)
java.util.List<EmployeeTrainingVO> | HumanResourceBox.getEmployeeTrainingById(java.lang.String employeeId)

Methods in bb.common.box with parameters of type EmployeeTrainingVO
java.util.List<EmployeeTrainingVO> | HumanResourceBox.addEmployeeTraining(EmployeeTrainingVO vo)
void | HumanResourceBox.updateEmployeeTraining(EmployeeTrainingVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EmployeeWorkExperiencePK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EmployeeWorkExperiencePK

Packages that use EmployeeWorkExperiencePK
bb.common
bb.common.box

Uses of EmployeeWorkExperiencePK in bb.common

Methods in bb.common that return EmployeeWorkExperiencePK
EmployeeWorkExperiencePK | EmployeeWorkExperienceVO.getPk()
EmployeeWorkExperiencePK | EmployeeTrainingVO.getPk()

Methods in bb.common with parameters of type EmployeeWorkExperiencePK
void | EmployeeWorkExperienceVO.setPk(EmployeeWorkExperiencePK pk)
void | EmployeeTrainingVO.setPk(EmployeeWorkExperiencePK pk)

Uses of EmployeeWorkExperiencePK in bb.common.box

Methods in bb.common.box with parameters of type EmployeeWorkExperiencePK
void | HumanResourceBox.deleteEmployeeTraining(EmployeeWorkExperiencePK pk)
void | HumanResourceBox.deleteEmployeeWorkExperience(EmployeeWorkExperiencePK pk)
EmployeeTrainingVO | HumanResourceBox.getEmployeeTrainingbyPk(EmployeeWorkExperiencePK pk)
EmployeeWorkExperienceVO | HumanResourceBox.getEmployeeWorkExperience(EmployeeWorkExperiencePK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EmployeeWorkExperienceVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EmployeeWorkExperienceVO

Packages that use EmployeeWorkExperienceVO
bb.common.box

Uses of EmployeeWorkExperienceVO in bb.common.box

Methods in bb.common.box that return EmployeeWorkExperienceVO
 EmployeeWorkExperienceVO HumanResourceBox.getEmployeeWorkExperience(EmployeeWorkExperiencePK pk)

Methods in bb.common.box that return types with arguments of type EmployeeWorkExperienceVO
java.util.Collection<EmployeeWorkExperienceVO> | HumanResourceBox.addEmployeeWorkExperience(EmployeeWorkExperienceVO vo)
java.util.Collection<EmployeeWorkExperienceVO> | HumanResourceBox.getEWEByEmployeeId(java.lang.String employeeId)

Methods in bb.common.box with parameters of type EmployeeWorkExperienceVO
java.util.Collection<EmployeeWorkExperienceVO> | HumanResourceBox.addEmployeeWorkExperience(EmployeeWorkExperienceVO vo)
void | HumanResourceBox.updateEmployeeWorkExperience(EmployeeWorkExperienceVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EngGroupUserPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EngGroupUserPK

Packages that use EngGroupUserPK
bb.common
bb.common.box

Uses of EngGroupUserPK in bb.common

Methods in bb.common that return EngGroupUserPK
 EngGroupUserPK EngGroupUserVO.getPk()

Methods in bb.common with parameters of type EngGroupUserPK
 void EngGroupUserVO.setPk(EngGroupUserPK pk)

Uses of EngGroupUserPK in bb.common.box

Methods in bb.common.box with parameters of type EngGroupUserPK
void | EngineeringBox.deleteEngGroupUser(EngGroupUserPK pk)
EngGroupUserVO | EngineeringBox.getEngGroupUserByPk(EngGroupUserPK pk)
boolean | EngineeringBox.isEngGroupUserExist(EngGroupUserPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EngGroupUserVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EngGroupUserVO

Packages that use EngGroupUserVO
bb.common.box

Uses of EngGroupUserVO in bb.common.box

Methods in bb.common.box that return EngGroupUserVO
EngGroupUserVO | EngineeringBox.addEngGroupUser(EngGroupUserVO vo)
EngGroupUserVO | EngineeringBox.getEngGroupUserByPk(EngGroupUserPK pk)

Methods in bb.common.box that return types with arguments of type EngGroupUserVO
 java.util.Collection<EngGroupUserVO> EngineeringBox.findEngGroupUserByEmployeeId(java.lang.String engGroupId, java.lang.String empId, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type EngGroupUserVO
EngGroupUserVO | EngineeringBox.addEngGroupUser(EngGroupUserVO vo)
void | EngineeringBox.updateEngGroupUser(EngGroupUserVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EngGroupVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EngGroupVO

Packages that use EngGroupVO
bb.common.box

Uses of EngGroupVO in bb.common.box

Methods in bb.common.box that return EngGroupVO
EngGroupVO | EngineeringBox.addEngGroup(EngGroupVO vo)
EngGroupVO | EngineeringBox.getEngGroupByPK(java.lang.String id)

Methods in bb.common.box that return types with arguments of type EngGroupVO
java.util.Collection<EngGroupVO> | EngineeringBox.findAllEngGroup(int firstIndex, int maxLength)
java.util.Collection<EngGroupVO> | EngineeringBox.findEngGroupListById(java.lang.String id, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type EngGroupVO
EngGroupVO | EngineeringBox.addEngGroup(EngGroupVO vo)
void | EngineeringBox.updateEngGroup(EngGroupVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EngineeringChangeDocumentVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EngineeringChangeDocumentVO

Packages that use EngineeringChangeDocumentVO
bb.common.box

Uses of EngineeringChangeDocumentVO in bb.common.box

Methods in bb.common.box that return EngineeringChangeDocumentVO
 EngineeringChangeDocumentVO EngineeringBox.getEngineeringChangeDocumentByID(java.lang.Long controlNumber)

Methods in bb.common.box that return types with arguments of type EngineeringChangeDocumentVO
java.util.Collection<EngineeringChangeDocumentVO> | EngineeringBox.deleteFTPECDoc(MiscDocAgent agent)
java.util.Collection<EngineeringChangeDocumentVO> | EngineeringBox.uploadOrUpdateFTPECDoc(MiscDocAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EngineeringChangeListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EngineeringChangeListResult

Packages that use EngineeringChangeListResult
bb.common
bb.common.box

Uses of EngineeringChangeListResult in bb.common

Methods in bb.common that return types with arguments of type EngineeringChangeListResult
java.util.List<EngineeringChangeListResult> | BillWithPartInfoResult.getEcnList()
java.util.List<EngineeringChangeListResult> | BillItemWithPartInfoResult.getEcnList()

Method parameters in bb.common with type arguments of type EngineeringChangeListResult
void | BillWithPartInfoResult.setEcnList(java.util.List<EngineeringChangeListResult> ecnList)
void | BillItemWithPartInfoResult.setEcnList(java.util.List<EngineeringChangeListResult> ecnList)

Uses of EngineeringChangeListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type EngineeringChangeListResult
java.util.Collection<EngineeringChangeListResult> | EngineeringBox.findAllEngineeringChanges(java.lang.String languageFlag, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | ManufacturingBox.findAllManufacturerEngineeringChanges(java.lang.String languageFlag, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | EngineeringBox.findDueEngineerningChange(java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | ManufacturingBox.findDueManufacturerEngineerningChange(java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | EngineeringBox.findEcnByConditions(java.lang.String ecNumberLike, java.lang.String partNumber, java.lang.String partType, java.lang.String originator, java.lang.String status, java.lang.String languageCode, java.lang.String importECN, java.lang.String importCompanyId, java.lang.String ecnDescription, java.lang.String dateType, java.util.Date dateFrom, java.util.Date dateTo, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | EngineeringBox.findEngineeringChangeByEcnNumberLike(java.lang.String ecRegex, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | EngineeringBox.findEngineeringChangeByPartLike(java.lang.String pnRegex, java.lang.String partType, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | EngineeringBox.findEngineeringChangeByPartPk(PartPK partPk, java.lang.String languageFlag, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | EngineeringBox.findEngineeringChangeByStatus(java.lang.String status, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | ManufacturingBox.findManufacturerEngineeringChangeByEcnNumberLike(java.lang.String ecRegex, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | ManufacturingBox.findManufacturerEngineeringChangeByPart(PartPK partPk, java.lang.String languageFlag, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | ManufacturingBox.findManufacturerEngineeringChangeByPartLike(java.lang.String pnRegex, java.lang.String partType, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | ManufacturingBox.findManufacturerEngineeringChangeByPartPk(PartPK partPk, java.lang.String languageFlag, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | EngineeringBox.findOpenEngineeringChange(java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | ManufacturingBox.findOpenManufacturerEngineeringChange(java.lang.String languageCode, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EngineeringChangeRequestDocumentVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EngineeringChangeRequestDocumentVO

Packages that use EngineeringChangeRequestDocumentVO
bb.common.box

Uses of EngineeringChangeRequestDocumentVO in bb.common.box

Methods in bb.common.box that return EngineeringChangeRequestDocumentVO
 EngineeringChangeRequestDocumentVO EngineeringBox.getEngineeringChangeRequestDocumentByID(java.lang.Long controlNumber)

Methods in bb.common.box that return types with arguments of type EngineeringChangeRequestDocumentVO
java.util.Collection<EngineeringChangeRequestDocumentVO> | EngineeringBox.deleteFTPECRDoc(MiscDocAgent agent)
java.util.Collection<EngineeringChangeRequestDocumentVO> | EngineeringBox.uploadOrUpdateFTPECRDoc(MiscDocAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EngineeringChangeRequestListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EngineeringChangeRequestListResult

Packages that use EngineeringChangeRequestListResult
bb.common.box

Uses of EngineeringChangeRequestListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type EngineeringChangeRequestListResult
java.util.Collection<EngineeringChangeRequestListResult> | EngineeringBox.findAllECRequests(java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeRequestListResult> | ManufacturingBox.findAllManufacturerECRequests(java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeRequestListResult> | EngineeringBox.findDueECRequest(java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeRequestListResult> | ManufacturingBox.findDueManufacturerECRequest(java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeRequestListResult> | EngineeringBox.findECRequestByEcrNumberLike(java.lang.String ecrNumberLike, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeRequestListResult> | EngineeringBox.findECRequestByPartLike(java.lang.String pnRegex, java.lang.String partType, java.lang.String languageCode, java.lang.String description, java.lang.String disposition, java.lang.String notes, java.lang.String status, java.lang.String ecrPriority, java.lang.String originator, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeRequestListResult> | ManufacturingBox.findManufacturerECRequestByEcrNumberLike(java.lang.String ecrNumberLike, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeRequestListResult> | ManufacturingBox.findManufacturerECRequestByPartLike(java.lang.String pnRegex, java.lang.String partType, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeRequestListResult> | EngineeringBox.findOpenECRequest(java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeRequestListResult> | ManufacturingBox.findOpenManufacturerECRequest(java.lang.String languageCode, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EngineeringChangeRequestVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EngineeringChangeRequestVO

Packages that use EngineeringChangeRequestVO
bb.common.box

Uses of EngineeringChangeRequestVO in bb.common.box

Methods in bb.common.box that return EngineeringChangeRequestVO
EngineeringChangeRequestVO | EngineeringBox.addECRequest(EngineeringChangeRequestVO ecRequestVO)
EngineeringChangeRequestVO | ManufacturingBox.addMECRequest(EngineeringChangeRequestVO ecRequestVO)
EngineeringChangeRequestVO | ManufacturingBox.addMECRequest(PartPK pk)
EngineeringChangeRequestVO | EngineeringBox.approvedECR(java.lang.String ecrNumber)
EngineeringChangeRequestVO | EngineeringBox.getECRequest(java.lang.String ecrNumber)
EngineeringChangeRequestVO | ManufacturingBox.getMECRequest(java.lang.String mecrNumber)
EngineeringChangeRequestVO | EngineeringBox.updateECRequest(EngineeringChangeRequestVO ecRequestVO)
EngineeringChangeRequestVO | ManufacturingBox.updateManufacturerECRequest(EngineeringChangeRequestVO ecRequestVO)

Methods in bb.common.box with parameters of type EngineeringChangeRequestVO
EngineeringChangeRequestVO | EngineeringBox.addECRequest(EngineeringChangeRequestVO ecRequestVO)
EngineeringChangeRequestVO | ManufacturingBox.addMECRequest(EngineeringChangeRequestVO ecRequestVO)
void | EngineeringBox.deleteECRequest(EngineeringChangeRequestVO ecRequestVO)
void | ManufacturingBox.deleteManufacturerECRequest(EngineeringChangeRequestVO ecRequestVO)
EngineeringChangeRequestVO | EngineeringBox.updateECRequest(EngineeringChangeRequestVO ecRequestVO)
EngineeringChangeRequestVO | ManufacturingBox.updateManufacturerECRequest(EngineeringChangeRequestVO ecRequestVO)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EngineeringChangeVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EngineeringChangeVO

Packages that use EngineeringChangeVO
bb.common.box

Uses of EngineeringChangeVO in bb.common.box

Methods in bb.common.box that return EngineeringChangeVO
EngineeringChangeVO | EngineeringBox.addEngineeringChange(EngineeringChangeVO engChangeVO)
EngineeringChangeVO | ManufacturingBox.addManufacturerEngineeringChange(EngineeringChangeVO engChangeVO)
EngineeringChangeVO | EngineeringBox.approveEngineeringChange(java.lang.String ecNumber)
EngineeringChangeVO | EngineeringBox.getEngineeringChangeById(java.lang.String ec)
EngineeringChangeVO | ManufacturingBox.getManufacturerEngineeringChangeById(java.lang.String ec)
EngineeringChangeVO | EngineeringBox.updateEngineeringChange(EngineeringChangeVO engChangeVO)
EngineeringChangeVO | ManufacturingBox.updateManufacturerEngineeringChange(EngineeringChangeVO engChange)

Methods in bb.common.box with parameters of type EngineeringChangeVO
EngineeringChangeVO | EngineeringBox.addEngineeringChange(EngineeringChangeVO engChangeVO)
EngineeringChangeVO | ManufacturingBox.addManufacturerEngineeringChange(EngineeringChangeVO engChangeVO)
void | EngineeringBox.deleteEngineeringChange(EngineeringChangeVO engChange)
void | ManufacturingBox.deleteManufacturerEngineeringChange(EngineeringChangeVO engChange)
EngineeringChangeVO | EngineeringBox.updateEngineeringChange(EngineeringChangeVO engChangeVO)
EngineeringChangeVO | ManufacturingBox.updateManufacturerEngineeringChange(EngineeringChangeVO engChange)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EngineeringInfoCenterResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EngineeringInfoCenterResult

Packages that use EngineeringInfoCenterResult
bb.common.box

Uses of EngineeringInfoCenterResult in bb.common.box

Methods in bb.common.box that return EngineeringInfoCenterResult
 EngineeringInfoCenterResult ManagementBox.getEngineeringInfoCenterResult()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EngineeringSharingImportLogVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EngineeringSharingImportLogVO

Packages that use EngineeringSharingImportLogVO
bb.common.box

Uses of EngineeringSharingImportLogVO in bb.common.box

Methods in bb.common.box that return types with arguments of type EngineeringSharingImportLogVO
 java.util.Collection<EngineeringSharingImportLogVO> EngineeringBox.findEngineeringSharingImportLogs(java.lang.String partNumber, java.lang.String partType, java.util.Date startDate, java.util.Date endDate, java.lang.String status, java.lang.String importType, java.lang.String importDataType, java.lang.String ecnNumber, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type EngineeringSharingImportLogVO
 void EngineeringBox.reviewEngineeringSharingImportLog(EngineeringSharingImportLogVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EngineeringSharingItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EngineeringSharingItemPK

Packages that use EngineeringSharingItemPK
bb.common
bb.common.box

Uses of EngineeringSharingItemPK in bb.common

Methods in bb.common that return EngineeringSharingItemPK
 EngineeringSharingItemPK EngineeringSharingItemVO.getPk()

Methods in bb.common with parameters of type EngineeringSharingItemPK
 void EngineeringSharingItemVO.setPk(EngineeringSharingItemPK pk)

Uses of EngineeringSharingItemPK in bb.common.box

Methods in bb.common.box with parameters of type EngineeringSharingItemPK
void | EngineeringBox.deletedEngineeringSharingItem(EngineeringSharingItemPK pk)
EngineeringSharingItemVO | EngineeringBox.getEngineeringSharingItemByPk(EngineeringSharingItemPK pk)
boolean | EngineeringBox.isEngineeringSharingItemExist(EngineeringSharingItemPK pk)

Method parameters in bb.common.box with type arguments of type EngineeringSharingItemPK
 void EngineeringBox.deletedBatchEngineeringSharingItem(java.util.ArrayList<EngineeringSharingItemPK> pkList)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EngineeringSharingItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EngineeringSharingItemVO

Packages that use EngineeringSharingItemVO
bb.common.box

Uses of EngineeringSharingItemVO in bb.common.box

Methods in bb.common.box that return EngineeringSharingItemVO
EngineeringSharingItemVO | EngineeringBox.addEngineeringSharingItem(EngineeringSharingItemVO vo)
EngineeringSharingItemVO | EngineeringBox.getEngineeringSharingItemByPk(EngineeringSharingItemPK pk)

Methods in bb.common.box that return types with arguments of type EngineeringSharingItemVO
 java.util.Collection<EngineeringSharingItemVO> EngineeringBox.findEngineeringSharingItemByCompanyId(java.lang.String addressId, java.lang.String partNumber, java.lang.String partType, java.lang.String languageCode, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type EngineeringSharingItemVO
EngineeringSharingItemVO | EngineeringBox.addEngineeringSharingItem(EngineeringSharingItemVO vo)
void | EngineeringBox.updateEngineeringSharingItem(EngineeringSharingItemVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EngineeringSharingVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EngineeringSharingVO

Packages that use EngineeringSharingVO
bb.common.box

Uses of EngineeringSharingVO in bb.common.box

Methods in bb.common.box that return EngineeringSharingVO
EngineeringSharingVO | EngineeringBox.addEngineeringSharing(EngineeringSharingVO vo)
EngineeringSharingVO | EngineeringBox.getEngineeringSharingsById(java.lang.String addressId)

Methods in bb.common.box that return types with arguments of type EngineeringSharingVO
java.util.Collection<EngineeringSharingVO> | EngineeringBox.findEngineeringSharingsByCompanyId(java.lang.String companyId, int firstIndex, int maxLength)
java.util.Collection<EngineeringSharingVO> | EngineeringBox.findEngineeringSharingsByCompanyName(java.lang.String companyName, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type EngineeringSharingVO
EngineeringSharingVO | EngineeringBox.addEngineeringSharing(EngineeringSharingVO vo)
void | EngineeringBox.updateEngineeringSharing(EngineeringSharingVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EquipmentListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EquipmentListResult

Packages that use EquipmentListResult
bb.common.box

Uses of EquipmentListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type EquipmentListResult
java.util.Collection<EquipmentListResult> | ManufacturingBox.findAllEquipments(int firstIndex, int maxLength)
java.util.Collection<EquipmentListResult> | ManufacturingBox.findEquipmentByWorkCenterId(java.lang.String workCenterId, int firstIndex, int maxLength)
java.util.Collection<EquipmentListResult> | ManufacturingBox.findEquipmentsByEquipmentId(java.lang.String equipmentId, java.lang.String type, java.lang.String workCenterId, java.lang.String maintenanceBy, int firstIndex, int maxLength)
java.util.Collection<EquipmentListResult> | ManufacturingBox.findEquipmentsByHours(int hours, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.EquipmentVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.EquipmentVO

Packages that use EquipmentVO
bb.common
bb.common.box

Uses of EquipmentVO in bb.common

Methods in bb.common that return EquipmentVO
 EquipmentVO WorkCenterVO.getEquipment()

Methods in bb.common with parameters of type EquipmentVO
 void WorkCenterVO.setEquipment(EquipmentVO equipment)

Uses of EquipmentVO in bb.common.box

Methods in bb.common.box that return EquipmentVO
EquipmentVO | ManufacturingBox.addEquipment(EquipmentVO vo)
EquipmentVO | ManufacturingBox.getEquipmentById(java.lang.String id)
EquipmentVO | ManufacturingBox.updateEquipment(EquipmentVO vo)

Methods in bb.common.box with parameters of type EquipmentVO
EquipmentVO | ManufacturingBox.addEquipment(EquipmentVO vo)
EquipmentVO | ManufacturingBox.updateEquipment(EquipmentVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ExchangeAuditItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ExchangeAuditItemResult

No usage of bb.common.ExchangeAuditItemResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ExchangeAuditResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ExchangeAuditResult

Packages that use ExchangeAuditResult
bb.common.box

Uses of ExchangeAuditResult in bb.common.box

Methods in bb.common.box that return ExchangeAuditResult
ExchangeAuditResult | AccountingBox.getExchangeRatePreview(java.lang.String yearCode, java.util.Map map)
ExchangeAuditResult | AccountingBox.makeExchangeRateAudit(ExchangeAuditResult result)

Methods in bb.common.box with parameters of type ExchangeAuditResult
 ExchangeAuditResult AccountingBox.makeExchangeRateAudit(ExchangeAuditResult result)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ExpenseAccountVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ExpenseAccountVO

Packages that use ExpenseAccountVO
bb.common.box

Uses of ExpenseAccountVO in bb.common.box

Methods in bb.common.box that return ExpenseAccountVO
ExpenseAccountVO | AccountingBox.addExpenseAccount(ExpenseAccountVO vo)
ExpenseAccountVO | AccountingBox.getExpenseAccountByPk(java.lang.String type)
ExpenseAccountVO | AccountingBox.updateExpenseAccount(ExpenseAccountVO vo)

Methods in bb.common.box that return types with arguments of type ExpenseAccountVO
 java.util.Collection<ExpenseAccountVO> AccountingBox.findAllExpenseAccount(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type ExpenseAccountVO
ExpenseAccountVO | AccountingBox.addExpenseAccount(ExpenseAccountVO vo)
ExpenseAccountVO | AccountingBox.updateExpenseAccount(ExpenseAccountVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ExpenseItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ExpenseItemPK

Packages that use ExpenseItemPK
bb.common

Uses of ExpenseItemPK in bb.common

Methods in bb.common that return ExpenseItemPK
 ExpenseItemPK ExpenseItemVO.getPk()

Methods in bb.common with parameters of type ExpenseItemPK
 void ExpenseItemVO.setPk(ExpenseItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ExpenseItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ExpenseItemVO

No usage of bb.common.ExpenseItemVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ExpenseListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ExpenseListResult

Packages that use ExpenseListResult
bb.common.box

Uses of ExpenseListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type ExpenseListResult
java.util.Collection<ExpenseListResult> | AccountingBox.findAllExpenses(int firstIndex, int maxLength)
java.util.Collection<ExpenseListResult> | AccountingBox.findExpensesByExpenseNumber(java.lang.String expenseNumberLike, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ExpenseVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ExpenseVO

Packages that use ExpenseVO
bb.common.box

Uses of ExpenseVO in bb.common.box

Methods in bb.common.box that return ExpenseVO
ExpenseVO | AccountingBox.addExpense()
ExpenseVO | AccountingBox.getExpenseByPk(java.lang.String expenseNumber)
ExpenseVO | AccountingBox.updateExpense(ExpenseVO vo)

Methods in bb.common.box with parameters of type ExpenseVO
 ExpenseVO AccountingBox.updateExpense(ExpenseVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.FeedbackAnswerPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.FeedbackAnswerPK

Packages that use FeedbackAnswerPK
bb.common

Uses of FeedbackAnswerPK in bb.common

Methods in bb.common that return FeedbackAnswerPK
 FeedbackAnswerPK FeedbackAnswerVO.getPk()

Methods in bb.common with parameters of type FeedbackAnswerPK
 void FeedbackAnswerVO.setPk(FeedbackAnswerPK pk)

Constructors in bb.common with parameters of type FeedbackAnswerPK
FeedbackAnswerVO(FeedbackAnswerPK pk, java.lang.String answerEn, java.lang.String answerCn)
minimal constructor
FeedbackAnswerVO(FeedbackAnswerPK pk, java.lang.String answerEn, java.lang.String answerCn, FeedbackQuestionVO feedbackQuestion)
full constructor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.FeedbackAnswerVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.FeedbackAnswerVO

No usage of bb.common.FeedbackAnswerVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.FeedBackItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.FeedBackItemPK

Packages that use FeedBackItemPK
bb.common
bb.common.box

Uses of FeedBackItemPK in bb.common

Methods in bb.common that return FeedBackItemPK
 FeedBackItemPK FeedbackItemVO.getPk()

Methods in bb.common with parameters of type FeedBackItemPK
 void FeedbackItemVO.setPk(FeedBackItemPK pk)

Constructors in bb.common with parameters of type FeedBackItemPK
FeedbackItemVO(FeedBackItemPK pk, java.lang.String answerItem)
minimal constructor

Uses of FeedBackItemPK in bb.common.box

Methods in bb.common.box with parameters of type FeedBackItemPK
 void CustomerServiceBox.deleteCustomerFeedbackItem(FeedBackItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.FeedbackItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.FeedbackItemVO

Packages that use FeedbackItemVO
bb.common.box

Uses of FeedbackItemVO in bb.common.box

Methods in bb.common.box that return FeedbackItemVO
FeedbackItemVO | CustomerServiceBox.addCustomerFeedbackItem(FeedbackItemVO vo)
FeedbackItemVO | CustomerServiceBox.updateCustomerFeedbackItem(FeedbackItemVO vo)

Methods in bb.common.box that return types with arguments of type FeedbackItemVO
 java.util.Collection<FeedbackItemVO> CustomerServiceBox.addCustomerFeedbackItem(java.util.ArrayList list)

Methods in bb.common.box with parameters of type FeedbackItemVO
FeedbackItemVO | CustomerServiceBox.addCustomerFeedbackItem(FeedbackItemVO vo)
FeedbackItemVO | CustomerServiceBox.updateCustomerFeedbackItem(FeedbackItemVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.FeedbackQuestionVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.FeedbackQuestionVO

Packages that use FeedbackQuestionVO
bb.common
bb.common.box

Uses of FeedbackQuestionVO in bb.common

Methods in bb.common that return FeedbackQuestionVO
 FeedbackQuestionVO FeedbackAnswerVO.getFeedbackQuestion()

Methods in bb.common with parameters of type FeedbackQuestionVO
 void FeedbackAnswerVO.setFeedbackQuestion(FeedbackQuestionVO feedbackQuestion)

Constructors in bb.common with parameters of type FeedbackQuestionVO
FeedbackAnswerVO(FeedbackAnswerPK pk, java.lang.String answerEn, java.lang.String answerCn, FeedbackQuestionVO feedbackQuestion)
full constructor

Uses of FeedbackQuestionVO in bb.common.box

Methods in bb.common.box that return FeedbackQuestionVO
FeedbackQuestionVO | CustomerServiceBox.addFeedbackQuestion(FeedbackQuestionVO vo)
FeedbackQuestionVO | CustomerServiceBox.deleteFeedbackQuestion(FeedbackQuestionVO vo)
FeedbackQuestionVO | CustomerServiceBox.getQuestionById(java.lang.String questionId)
FeedbackQuestionVO | CustomerServiceBox.updateFeedbackQuestion(FeedbackQuestionVO vo)

Methods in bb.common.box that return types with arguments of type FeedbackQuestionVO
 java.util.Collection<FeedbackQuestionVO> CustomerServiceBox.findAllQuestions(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type FeedbackQuestionVO
FeedbackQuestionVO | CustomerServiceBox.addFeedbackQuestion(FeedbackQuestionVO vo)
FeedbackQuestionVO | CustomerServiceBox.deleteFeedbackQuestion(FeedbackQuestionVO vo)
FeedbackQuestionVO | CustomerServiceBox.updateFeedbackQuestion(FeedbackQuestionVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.FinishProformaReceiverAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.FinishProformaReceiverAgent

Packages that use FinishProformaReceiverAgent
bb.common.box

Uses of FinishProformaReceiverAgent in bb.common.box

Methods in bb.common.box with parameters of type FinishProformaReceiverAgent
 java.lang.String PurchasingBox.finishProformaReceiver(java.lang.String pfReceiverNumber, FinishProformaReceiverAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.FiscalYearSettingsVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.FiscalYearSettingsVO

Packages that use FiscalYearSettingsVO
bb.common
bb.common.box

Uses of FiscalYearSettingsVO in bb.common

Methods in bb.common that return FiscalYearSettingsVO
 FiscalYearSettingsVO CurrencyAgent.getFiscalYearSettingsVO()

Methods in bb.common with parameters of type FiscalYearSettingsVO
 void CurrencyAgent.setFiscalYearSettingsVO(FiscalYearSettingsVO fiscalYearSettingsVO)

Uses of FiscalYearSettingsVO in bb.common.box

Methods in bb.common.box that return FiscalYearSettingsVO
FiscalYearSettingsVO | AccountingBox.addFiscalYearSettings(FiscalYearSettingsVO vo)
FiscalYearSettingsVO | AccountingBox.findFiscalYearSettingsByDate(java.util.Date date)
FiscalYearSettingsVO | AccountingBox.findFiscalYearSettingsByPk(java.lang.String fyNumber)
FiscalYearSettingsVO | AccountingBox.getCurrentFiscalYearSettings()

Methods in bb.common.box that return types with arguments of type FiscalYearSettingsVO
 java.util.Collection<FiscalYearSettingsVO> AccountingBox.findAllFiscalYearSettings(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type FiscalYearSettingsVO
FiscalYearSettingsVO | AccountingBox.addFiscalYearSettings(FiscalYearSettingsVO vo)
void | AccountingBox.deleteFiscalYearSetting(FiscalYearSettingsVO vo, boolean direct)
void | AccountingBox.updateFiscalYearSettings(FiscalYearSettingsVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.GeneralLedgerApprovalVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.GeneralLedgerApprovalVO

Packages that use GeneralLedgerApprovalVO
bb.common.box

Uses of GeneralLedgerApprovalVO in bb.common.box

Methods in bb.common.box that return GeneralLedgerApprovalVO
GeneralLedgerApprovalVO | AccountingBox.addGeneralLedgerApproval(java.lang.String employeeId)
GeneralLedgerApprovalVO | AccountingBox.getCurrentUserApprovalInfo()
GeneralLedgerApprovalVO | AccountingBox.getGeneralLedgerApprovalByPk(java.lang.String employeeId)

Methods in bb.common.box that return types with arguments of type GeneralLedgerApprovalVO
java.util.Collection<GeneralLedgerApprovalVO> | AccountingBox.findAllGeneralLedgerApproval(int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerApprovalVO> | AccountingBox.findGeneralLedgerApprovalById(java.lang.String employeeId, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerApprovalVO> | AccountingBox.findGeneralLedgerApprovalByName(java.lang.String userName, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type GeneralLedgerApprovalVO
 void AccountingBox.updateGeneralLedgerApproval(GeneralLedgerApprovalVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.GeneralLedgerByDateListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.GeneralLedgerByDateListResult

Packages that use GeneralLedgerByDateListResult
bb.common
bb.common.box

Uses of GeneralLedgerByDateListResult in bb.common

Methods in bb.common that return types with arguments of type GeneralLedgerByDateListResult
 java.util.Collection<GeneralLedgerByDateListResult> GLCheckRegisterResult.getResults()

Method parameters in bb.common with type arguments of type GeneralLedgerByDateListResult
 void GLCheckRegisterResult.setResults(java.util.Collection<GeneralLedgerByDateListResult> results)

Uses of GeneralLedgerByDateListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type GeneralLedgerByDateListResult
java.util.Collection<GeneralLedgerByDateListResult> | AccountingBox.findBackOrCashCheckRegisterDetail(java.lang.String fMonthYear, java.lang.String tMonthYear, java.lang.String companyUnit, java.lang.String accountNumber, java.lang.String id, java.lang.String checkNum, java.lang.String checkType)
java.util.Collection<GeneralLedgerByDateListResult> | AccountingBox.findCurrentBalanceResult(java.lang.String companyUnitId, java.lang.String accountNumber, java.lang.String language, java.lang.String monthName, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerByDateListResult> | AccountingBox.findGeneralLedgerByDate(java.lang.String companyUnitId, java.lang.String accountNumber, java.lang.String language, java.util.Date fromDate, java.util.Date toDate, java.lang.String accountType, java.lang.String[] include, java.lang.String[] exclude, int orderBy, java.lang.String checkNumber, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerByDateListResult> | AccountingBox.findGeneralLedgerByDate(java.lang.String companyUnitId, java.lang.String accountNumber, java.lang.String language, java.util.Date fromDate, java.util.Date toDate, java.lang.String clearedStatus, java.lang.String addressId, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.GeneralLedgerCategoryVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.GeneralLedgerCategoryVO

Packages that use GeneralLedgerCategoryVO
bb.common.box

Uses of GeneralLedgerCategoryVO in bb.common.box

Methods in bb.common.box that return GeneralLedgerCategoryVO
GeneralLedgerCategoryVO | AccountingBox.addGLCategory(GeneralLedgerCategoryVO vo)
GeneralLedgerCategoryVO | AccountingBox.getGLCategoryById(java.lang.String id)
GeneralLedgerCategoryVO | AccountingBox.updateGLCategory(GeneralLedgerCategoryVO vo)

Methods in bb.common.box that return types with arguments of type GeneralLedgerCategoryVO
 java.util.Collection<GeneralLedgerCategoryVO> AccountingBox.findAllGLCategories(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type GeneralLedgerCategoryVO
GeneralLedgerCategoryVO | AccountingBox.addGLCategory(GeneralLedgerCategoryVO vo)
GeneralLedgerCategoryVO | AccountingBox.updateGLCategory(GeneralLedgerCategoryVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.GeneralLedgerEntry

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.GeneralLedgerEntry

Packages that use GeneralLedgerEntry
bb.common

Uses of GeneralLedgerEntry in bb.common

Methods in bb.common that return types with arguments of type GeneralLedgerEntry
 java.util.List<GeneralLedgerEntry> GeneralLedgerPrintResult.getEntryList()

Method parameters in bb.common with type arguments of type GeneralLedgerEntry
 void GeneralLedgerPrintResult.setEntryList(java.util.List<GeneralLedgerEntry> entryList)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.GeneralLedgerListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.GeneralLedgerListResult

Packages that use GeneralLedgerListResult
bb.common
bb.common.box

Uses of GeneralLedgerListResult in bb.common

Subclasses of GeneralLedgerListResult in bb.common
 class GLDebitCreditListResult

Uses of GeneralLedgerListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type GeneralLedgerListResult
java.util.Collection<GeneralLedgerListResult> | AccountingBox.findGLByConditions(java.lang.String addressId, java.lang.String apNumber, java.lang.String arNumber, java.lang.String soOrWONumber, java.lang.String shipperNumber, java.lang.String receiverNumber, java.lang.String ourPOorWONumber, java.util.Date fromDate, java.util.Date toDate, java.math.BigDecimal amount, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerListResult> | AccountingBox.findGLById(java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerListResult> | AccountingBox.getRelatedGL(java.lang.String glNumber, java.lang.String apNumber, java.lang.String poNumber, java.lang.String receiverNumber, java.lang.String arNumber, java.lang.String soNumber, java.lang.String shipperNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.GeneralLedgerPrintResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.GeneralLedgerPrintResult

Packages that use GeneralLedgerPrintResult
bb.common.box

Uses of GeneralLedgerPrintResult in bb.common.box

Methods in bb.common.box that return GeneralLedgerPrintResult
 GeneralLedgerPrintResult AccountingBox.getGLPrintByGlCategory(java.lang.String glCategory, int categorySequence)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.GeneralLedgerResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.GeneralLedgerResult

Packages that use GeneralLedgerResult
bb.common.box

Uses of GeneralLedgerResult in bb.common.box

Methods in bb.common.box that return GeneralLedgerResult
 GeneralLedgerResult AccountingBox.getGeneralLedgerResult(java.lang.String transactionNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.GeneralLedgerSettingsVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.GeneralLedgerSettingsVO

Packages that use GeneralLedgerSettingsVO
bb.common.box

Uses of GeneralLedgerSettingsVO in bb.common.box

Methods in bb.common.box that return GeneralLedgerSettingsVO
GeneralLedgerSettingsVO | AccountingBox.getGS()
GeneralLedgerSettingsVO | AccountingBox.updateTransactionLockDate(java.util.Date date)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.GeneralLedgerVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.GeneralLedgerVO

Packages that use GeneralLedgerVO
bb.common
bb.common.box

Uses of GeneralLedgerVO in bb.common

Methods in bb.common that return types with arguments of type GeneralLedgerVO
 java.util.List<GeneralLedgerVO> PaymentInvoicesResult.getPaymentInvoices()

Method parameters in bb.common with type arguments of type GeneralLedgerVO
 void PaymentInvoicesResult.setPaymentInvoices(java.util.List<GeneralLedgerVO> paymentInvoices)

Uses of GeneralLedgerVO in bb.common.box

Methods in bb.common.box that return GeneralLedgerVO
GeneralLedgerVO | AccountingBox.addGeneralLedger(GeneralLedgerVO vo)
GeneralLedgerVO | AccountingBox.approveGeneralLedger(java.lang.String transactionNumber)
GeneralLedgerVO | WorkOrderBox.batchDisassembelWorkOrderGLByDwoItem(DisassembleWorkOrderItemPK[] pks, java.lang.String companyUnitId, java.lang.String glSummary)
GeneralLedgerVO | AccountingBox.getGeneralLedgerByPk(java.lang.String transactionNumber)
GeneralLedgerVO | AccountingBox.overCarryProfitAndLoss(java.lang.String monthYear, java.lang.String description, java.util.Date glDate, java.lang.String glCategory)

Methods in bb.common.box that return types with arguments of type GeneralLedgerVO
java.util.Collection<GeneralLedgerVO> | AccountingBox.findAllGeneralLedgers(java.lang.String glCategory, java.lang.String sequenceFrom, java.lang.String sequenceTo, java.lang.String id, java.lang.String accounts, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | AccountingBox.findAPAccountInfo(java.lang.String apNumber, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | AccountingBox.findARAccountInfo(java.lang.String arNumber, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | AccountingBox.findDMAccountInfo(java.lang.String apNumber, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | AccountingBox.findTransactionByAPNumber(java.lang.String apNumber, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | AccountingBox.findTransactionByAppNumber(java.lang.String appNumber, boolean showVoid, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | AccountingBox.findTransactionByAppNumber(java.lang.String appNumber, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | AccountingBox.findTransactionByARNumber(java.lang.String arNumber, boolean showVoid, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | AccountingBox.findTransactionByARNumber(java.lang.String arNumber, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | AccountingBox.findTransactionByArpNumber(java.lang.String arpNumber, boolean showVoid, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | AccountingBox.findTransactionByArpNumber(java.lang.String arpNumber, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | AccountingBox.findTransactionByDMNumber(java.lang.String apNumber, boolean showVoid, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | AccountingBox.findTransactionByDMNumber(java.lang.String apNumber, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | AccountingBox.findTransactionByMPONumber(java.lang.String poNumber, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | AccountingBox.findTransactionByPONumber(java.lang.String poNumber, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | AccountingBox.findTransactionBySONumber(java.lang.String soNumber, int firstIndex, int maxLength)
java.util.Collection<GeneralLedgerVO> | QualityBox.getTransactionByNCRNumber(java.lang.String ncrNumber)

Methods in bb.common.box with parameters of type GeneralLedgerVO
GeneralLedgerVO | AccountingBox.addGeneralLedger(GeneralLedgerVO vo)
java.lang.String | AccountingBox.addNewGeneralLedger(GeneralLedgerVO vo)
void | AccountingBox.deleteGeneralLedger(GeneralLedgerVO vo)
java.lang.String | AccountingBox.updateGeneralLedger(GeneralLedgerVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.GLApprovalListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.GLApprovalListResult

Packages that use GLApprovalListResult
bb.common.box

Uses of GLApprovalListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type GLApprovalListResult
java.util.Collection<GLApprovalListResult> | AccountingBox.getNeedtoApproveGL(java.lang.String monthYear, java.lang.String original)
java.util.Collection<GLApprovalListResult> | AccountingBox.getNeedtoCancelApprovedGL(java.lang.String monthYear, java.lang.String original)
java.util.Collection<GLApprovalListResult> | AccountingBox.getNeedtoCancelPostGL(java.lang.String fromMonthYear, java.lang.String toMonthYear, java.lang.String original, java.lang.String approvedBy)
java.util.Collection<GLApprovalListResult> | AccountingBox.getNeedtoPostGL(java.lang.String fromMonthYear, java.lang.String toMonthYear, java.lang.String original, java.lang.String approvedBy)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.GLAutoApproveVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.GLAutoApproveVO

Packages that use GLAutoApproveVO
bb.common.box

Uses of GLAutoApproveVO in bb.common.box

Methods in bb.common.box that return GLAutoApproveVO
GLAutoApproveVO | AccountingBox.addGLAutoApprove(GLAutoApproveVO vo)
GLAutoApproveVO | AccountingBox.getGLAutoApproveByGlType(java.lang.String glType)
GLAutoApproveVO | AccountingBox.getGLAutoApproveById(java.lang.Long id)
GLAutoApproveVO | AccountingBox.updateGLAutoApprove(GLAutoApproveVO vo)

Methods in bb.common.box that return types with arguments of type GLAutoApproveVO
 java.util.Collection<GLAutoApproveVO> AccountingBox.findAllGLAutoApproves(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type GLAutoApproveVO
GLAutoApproveVO | AccountingBox.addGLAutoApprove(GLAutoApproveVO vo)
GLAutoApproveVO | AccountingBox.updateGLAutoApprove(GLAutoApproveVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.GlBalanceInfoResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.GlBalanceInfoResult

Packages that use GlBalanceInfoResult
bb.common

Uses of GlBalanceInfoResult in bb.common

Methods in bb.common that return types with arguments of type GlBalanceInfoResult
 java.util.Map<java.lang.String,GlBalanceInfoResult> GLInfoByPeriodResult.getPeriodBalance()

Method parameters in bb.common with type arguments of type GlBalanceInfoResult
 void GLInfoByPeriodResult.setPeriodBalance(java.util.Map<java.lang.String,GlBalanceInfoResult> periodBalance)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.GLByDateTotalResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.GLByDateTotalResult

Packages that use GLByDateTotalResult
bb.common.box

Uses of GLByDateTotalResult in bb.common.box

Methods in bb.common.box that return GLByDateTotalResult
GLByDateTotalResult | AccountingBox.getGeneralLedgerTotalByDate(java.lang.String companyUnitId, java.lang.String accountNumber, java.util.Date fromDate, java.util.Date toDate, java.lang.String clearedStatus, java.lang.String addressId)
GLByDateTotalResult | AccountingBox.getGeneralLedgerTotalByDate(java.lang.String companyUnitId, java.lang.String accountNumber, java.util.Date fromDate, java.util.Date toDate, java.lang.String accountType, java.lang.String[] include, java.lang.String[] exclude, java.lang.String checkNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.GlCashFlowBudgetVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.GlCashFlowBudgetVO

No usage of bb.common.GlCashFlowBudgetVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.GLCatAndSequence

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.GLCatAndSequence

No usage of bb.common.GLCatAndSequence

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.GLCheckRegisterResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.GLCheckRegisterResult

Packages that use GLCheckRegisterResult
bb.common.box

Uses of GLCheckRegisterResult in bb.common.box

Methods in bb.common.box that return GLCheckRegisterResult
 GLCheckRegisterResult AccountingBox.findBackOrCashCheckRegister(java.lang.String fMonthYear, java.lang.String tMonthYear, java.lang.String companyUnit, java.lang.String accountNumber, java.lang.String id, java.lang.String checkType)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.GLDebitCreditListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.GLDebitCreditListResult

Packages that use GLDebitCreditListResult
bb.common.box

Uses of GLDebitCreditListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type GLDebitCreditListResult
 java.util.Collection<GLDebitCreditListResult> AccountingBox.findGLCreditDebitByConditions(java.lang.String addressId, java.lang.String apNumber, java.lang.String arNumber, java.lang.String soOrWONumber, java.lang.String shipperNumber, java.lang.String receiverNumber, java.lang.String ourPOorWONumber, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.GlFiscalYearBudgetVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.GlFiscalYearBudgetVO

No usage of bb.common.GlFiscalYearBudgetVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.GLInfoByPeriodResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.GLInfoByPeriodResult

Packages that use GLInfoByPeriodResult
bb.common.box

Uses of GLInfoByPeriodResult in bb.common.box

Methods in bb.common.box that return GLInfoByPeriodResult
GLInfoByPeriodResult | AccountingBox.findAllBankOrCashGLByDate(java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String fMonthYear, java.lang.String tMonthYear, boolean includeUnpostGL, boolean showOriginal, int firstIndex, int maxLength)
GLInfoByPeriodResult | AccountingBox.findAllDetailAccountTransaction(java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String fMonthYear, java.lang.String tMonthYear, boolean includeUnpostGL, boolean showOpposeAcct, java.lang.String customerId, boolean showOriginal)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.GLItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.GLItemVO

No usage of bb.common.GLItemVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.GlMonthBudgetVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.GlMonthBudgetVO

Packages that use GlMonthBudgetVO
bb.common.box

Uses of GlMonthBudgetVO in bb.common.box

Methods in bb.common.box that return GlMonthBudgetVO
GlMonthBudgetVO | AccountingBox.getCurrentMonthYear()
GlMonthBudgetVO | AccountingBox.getMonthYearAfter12Month()

Methods in bb.common.box that return types with arguments of type GlMonthBudgetVO
java.util.Collection<GlMonthBudgetVO> | AccountingBox.findMonthList(java.lang.String month1, java.lang.String month2)
java.util.Collection<GlMonthBudgetVO> | AccountingBox.get15MonthYear()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.GlMonthVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.GlMonthVO

Packages that use GlMonthVO
bb.common.box

Uses of GlMonthVO in bb.common.box

Methods in bb.common.box that return GlMonthVO
 GlMonthVO AccountingBox.getFirstOpenMonth()

Methods in bb.common.box that return types with arguments of type GlMonthVO
java.util.Collection<GlMonthVO> | AccountingBox.findAllGlMonth(int firstIndex, int maxLength)
java.util.Collection<GlMonthVO> | AccountingBox.findClosedGlMonth(int firstIndex, int maxLength)
java.util.Collection<GlMonthVO> | AccountingBox.findCurrentAllGlMonth(int firstIndex, int maxLength)
java.util.Collection<GlMonthVO> | AccountingBox.findGlMonthByFyNumber(java.lang.String fyNumber, int firstIndex, int maxLength)
java.util.Collection<GlMonthVO> | AccountingBox.findGlMonthsByFyNumber(java.lang.String fyNumber)
java.util.Collection<GlMonthVO> | AccountingBox.findLatestOpenFYGlMonth(int firstIndex, int maxLength)
java.util.Collection<GlMonthVO> | AccountingBox.findOpenGlMonth(int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.GroupUserPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.GroupUserPK

Packages that use GroupUserPK
bb.common

Uses of GroupUserPK in bb.common

Methods in bb.common that return GroupUserPK
 GroupUserPK GroupUserVO.getPk()

Methods in bb.common with parameters of type GroupUserPK
 void GroupUserVO.setPk(GroupUserPK pk)

Constructors in bb.common with parameters of type GroupUserPK
GroupUserVO(GroupUserPK pk, java.lang.String description, java.lang.String employeeId)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.GroupUserVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.GroupUserVO

Packages that use GroupUserVO
bb.common.box

Uses of GroupUserVO in bb.common.box

Methods in bb.common.box that return GroupUserVO
 GroupUserVO CompanyBox.addGroupUser(GroupUserVO vo)

Methods in bb.common.box that return types with arguments of type GroupUserVO
 java.util.Collection<GroupUserVO> CompanyBox.findGroupUserList(java.lang.String userName, java.lang.String userGroup, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type GroupUserVO
GroupUserVO | CompanyBox.addGroupUser(GroupUserVO vo)
void | CompanyBox.deleteGroupUser(GroupUserVO vo)
void | CompanyBox.updateGroupUser(GroupUserVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.HelpServerVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.HelpServerVO

Packages that use HelpServerVO
bb.common.box

Uses of HelpServerVO in bb.common.box

Methods in bb.common.box that return HelpServerVO
HelpServerVO | CompanyBox.addHelpServer(HelpServerVO vo)
HelpServerVO | CompanyBox.getActiveHelpServer()
HelpServerVO | CompanyBox.getHelpServerByPk(java.lang.Long pk)

Methods in bb.common.box that return types with arguments of type HelpServerVO
 java.util.Collection<HelpServerVO> CompanyBox.findAllHelpServers(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type HelpServerVO
HelpServerVO | CompanyBox.addHelpServer(HelpServerVO vo)
void | CompanyBox.updateHelpServer(HelpServerVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.HighUsagePartResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.HighUsagePartResult

Packages that use HighUsagePartResult
bb.common.box

Uses of HighUsagePartResult in bb.common.box

Methods in bb.common.box that return types with arguments of type HighUsagePartResult
 java.util.Collection<HighUsagePartResult> WarehouseBox.findHighUsagePartResults(int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.HistoricalInventoryTotalResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.HistoricalInventoryTotalResult

Packages that use HistoricalInventoryTotalResult
bb.common.box

Uses of HistoricalInventoryTotalResult in bb.common.box

Methods in bb.common.box that return types with arguments of type HistoricalInventoryTotalResult
 java.util.Collection<HistoricalInventoryTotalResult> WarehouseBox.getHistoricalInventoryTotalResults(java.lang.String pnLike, java.lang.String paLike, java.util.Date fDate, java.util.Date tDate)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.HistoricalInventoryVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.HistoricalInventoryVO

Packages that use HistoricalInventoryVO
bb.common.box

Uses of HistoricalInventoryVO in bb.common.box

Methods in bb.common.box that return types with arguments of type HistoricalInventoryVO
 java.util.Collection<HistoricalInventoryVO> WarehouseBox.findHistoricalInventorys(java.lang.String pnLike, java.lang.String paLike, java.util.Date date, boolean isShowOnHand, int firstIndex, int maxlength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.I18nEvent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.I18nEvent

No usage of bb.common.I18nEvent

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.IcrItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.IcrItemListResult

Packages that use IcrItemListResult
bb.common.box

Uses of IcrItemListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type IcrItemListResult
 java.util.Collection<IcrItemListResult> QualityBox.findIcrItemsByDate(java.lang.String icrNumber, java.lang.String vendorId, java.lang.String pn, java.lang.String inspector, java.lang.String wo, java.lang.String po, java.util.Date from, java.util.Date to, java.lang.String status, java.lang.String dateType, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.IcrListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.IcrListResult

Packages that use IcrListResult
bb.common.box

Uses of IcrListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type IcrListResult
java.util.Collection<IcrListResult> | QualityBox.findIcrsById(java.lang.String icrNumber, int firstIndex, int maxLength)
java.util.Collection<IcrListResult> | QualityBox.findIcrsByVendorId(java.lang.String vendorId, int firstIndex, int maxLength)
java.util.Collection<IcrListResult> | QualityBox.findOpenIcrs(java.lang.String icrNumber, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ImportContractPriceData

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ImportContractPriceData

Packages that use ImportContractPriceData
bb.common.box

Uses of ImportContractPriceData in bb.common.box

Method parameters in bb.common.box with type arguments of type ImportContractPriceData
 void CompanyBox.importContractPrice(java.util.ArrayList<ImportContractPriceData> datas)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ImportDataVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ImportDataVO

Packages that use ImportDataVO
bb.common.box

Uses of ImportDataVO in bb.common.box

Methods in bb.common.box that return types with arguments of type ImportDataVO
java.util.Collection<ImportDataVO> | CompanyBox.findBOMItemNotPart()
java.util.Collection<ImportDataVO> | CompanyBox.findBOMNotPart()
java.util.Collection<ImportDataVO> | CompanyBox.findDuplicateTempAddress(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | CompanyBox.findDuplicateTempBOM(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | CompanyBox.findDuplicateTempEmployee(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | CompanyBox.findDuplicateTempInventory(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | CompanyBox.findDuplicateTempManufacture(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | CompanyBox.findDuplicateTempMaterial(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | CompanyBox.findDuplicateTempNccode(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | CompanyBox.findDuplicateTempPart(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | CompanyBox.findDuplicateTempTool(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | CompanyBox.findDuplicateTempToolInventory(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | CompanyBox.findExistAddress(java.lang.String type)
java.util.Collection<ImportDataVO> | CompanyBox.findExistBOM()
java.util.Collection<ImportDataVO> | CompanyBox.findExistEmployee()
java.util.Collection<ImportDataVO> | CompanyBox.findExistInventory()
java.util.Collection<ImportDataVO> | CompanyBox.findExistManufacture()
java.util.Collection<ImportDataVO> | CompanyBox.findExistMaterial()
java.util.Collection<ImportDataVO> | CompanyBox.findExistNccode()
java.util.Collection<ImportDataVO> | CompanyBox.findExistPart()
java.util.Collection<ImportDataVO> | CompanyBox.findExistTool()
java.util.Collection<ImportDataVO> | CompanyBox.findExistToolInventory()
java.util.Collection<ImportDataVO> | CompanyBox.findNotPartInventory()
java.util.Collection<ImportDataVO> | CompanyBox.findNotPartTempMaterial()
java.util.Collection<ImportDataVO> | CompanyBox.findNotToolInventory()
java.util.Collection<ImportDataVO> | CompanyBox.findTempAddress(java.lang.String type, int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | CompanyBox.findTempBOM(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | CompanyBox.findTempEmployee(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | CompanyBox.findTempInventory(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | CompanyBox.findTempManufacture(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | CompanyBox.findTempMaterial(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | CompanyBox.findTempMPN(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | CompanyBox.findTempNccode(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | CompanyBox.findTempPart(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | CompanyBox.findTempTool(int firstIndex, int maxLength)
java.util.Collection<ImportDataVO> | CompanyBox.findTempToolInventory(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type ImportDataVO
void | CompanyBox.updateTempAddress(ImportDataVO vo)
void | CompanyBox.updateTempBOM(ImportDataVO vo)
void | CompanyBox.updateTempEmployee(ImportDataVO vo)
void | CompanyBox.updateTempInventory(ImportDataVO vo)
void | CompanyBox.updateTempManufacture(ImportDataVO vo)
void | CompanyBox.updateTempMaterial(ImportDataVO vo)
void | CompanyBox.updateTempMPN(ImportDataVO vo)
void | CompanyBox.updateTempNccode(ImportDataVO vo)
void | CompanyBox.updateTempPart(ImportDataVO info)
void | CompanyBox.updateTempTool(ImportDataVO vo)
void | CompanyBox.updateTempToolInventory(ImportDataVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.IncomeByMonthChartResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.IncomeByMonthChartResult

Packages that use IncomeByMonthChartResult
bb.common.box

Uses of IncomeByMonthChartResult in bb.common.box

Methods in bb.common.box that return IncomeByMonthChartResult
IncomeByMonthChartResult | PurchasingBox.getNext12MonthPoShipAmount()
IncomeByMonthChartResult | SalesBox.getNext12MonthSoShipAmount()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.IncotermVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.IncotermVO

Packages that use IncotermVO
bb.common.box

Uses of IncotermVO in bb.common.box

Methods in bb.common.box that return IncotermVO
IncotermVO | SalesBox.addIncoterm(IncotermVO vo)
IncotermVO | SalesBox.getIncotermById(java.lang.String id)
IncotermVO | SalesBox.updateIncoterm(IncotermVO vo)

Methods in bb.common.box that return types with arguments of type IncotermVO
 java.util.Collection<IncotermVO> SalesBox.findAllIncoterms(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type IncotermVO
IncotermVO | SalesBox.addIncoterm(IncotermVO vo)
void | SalesBox.deleteIncoterm(IncotermVO vo)
IncotermVO | SalesBox.updateIncoterm(IncotermVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InfoByFiscalChartResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InfoByFiscalChartResult

Packages that use InfoByFiscalChartResult
bb.common.box

Uses of InfoByFiscalChartResult in bb.common.box

Methods in bb.common.box that return InfoByFiscalChartResult
 InfoByFiscalChartResult ManagementBox.getPOFiscalYearInfoCenter()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InfoByMonthChartResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InfoByMonthChartResult

Packages that use InfoByMonthChartResult
bb.common.box

Uses of InfoByMonthChartResult in bb.common.box

Methods in bb.common.box that return InfoByMonthChartResult
InfoByMonthChartResult | ManagementBox.getInvoicesInfoByFiscalYear(java.lang.String fyNumber)
InfoByMonthChartResult | ManagementBox.getInvoicesInfoByMonth(int monthCount)
InfoByMonthChartResult | ManagementBox.getPurchaseInfoByFiscalYear()
InfoByMonthChartResult | ManagementBox.getPurchaseInfoByMonth(int monthCount)
InfoByMonthChartResult | ManagementBox.getPurchaseOrderBacklogInfoByMonth(int monthCount)
InfoByMonthChartResult | ManagementBox.getReceiversInfoByFiscalYear()
InfoByMonthChartResult | ManagementBox.getReceiversInfoByMonth(int monthCount)
InfoByMonthChartResult | ManagementBox.getSalesInfoByFiscalYear(java.lang.String fyNumber)
InfoByMonthChartResult | ManagementBox.getSalesInfoByMonth(int monthCount, boolean includeCancel)
InfoByMonthChartResult | ManagementBox.getSalesInfoDashBoardByFiscalYear()
InfoByMonthChartResult | ManagementBox.getSalesOrderBacklogInfoByMonth(int monthCount)
InfoByMonthChartResult | ManagementBox.getWOInfoByFiscalYear()
InfoByMonthChartResult | ManagementBox.getWOInfoByMonth(int monthCount)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InfoByMonthResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InfoByMonthResult

Packages that use InfoByMonthResult
bb.common

Uses of InfoByMonthResult in bb.common

Methods in bb.common that return types with arguments of type InfoByMonthResult
 java.util.Map<java.lang.String,java.util.HashMap<java.util.Date,InfoByMonthResult>> InfoByMonthChartResult.getInfoByMonthMap()

Method parameters in bb.common with type arguments of type InfoByMonthResult
 void InfoByMonthChartResult.setInfoByMonthMap(java.util.Map<java.lang.String,java.util.HashMap<java.util.Date,InfoByMonthResult>> infoByMonthMap)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InSipAudittListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InSipAudittListResult

Packages that use InSipAudittListResult
bb.common.box

Uses of InSipAudittListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type InSipAudittListResult
 java.util.Collection<InSipAudittListResult> WarehouseBox.findInSipAuditReport(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, int firstIndex, int maxlength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InspectionConformanceReportItemCheckPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InspectionConformanceReportItemCheckPK

Packages that use InspectionConformanceReportItemCheckPK
bb.common

Uses of InspectionConformanceReportItemCheckPK in bb.common

Methods in bb.common that return InspectionConformanceReportItemCheckPK
 InspectionConformanceReportItemCheckPK InspectionConformanceReportItemCheckVO.getPk()

Methods in bb.common with parameters of type InspectionConformanceReportItemCheckPK
 void InspectionConformanceReportItemCheckVO.setPk(InspectionConformanceReportItemCheckPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InspectionConformanceReportItemCheckVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InspectionConformanceReportItemCheckVO

No usage of bb.common.InspectionConformanceReportItemCheckVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InspectionConformanceReportItemInfo

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InspectionConformanceReportItemInfo

Packages that use InspectionConformanceReportItemInfo
bb.common.box

Uses of InspectionConformanceReportItemInfo in bb.common.box

Methods in bb.common.box that return InspectionConformanceReportItemInfo
 InspectionConformanceReportItemInfo QualityBox.getIcrItemInfoByPk(InspectionConformanceReportItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InspectionConformanceReportItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InspectionConformanceReportItemPK

Packages that use InspectionConformanceReportItemPK
bb.common
bb.common.box

Uses of InspectionConformanceReportItemPK in bb.common

Methods in bb.common that return InspectionConformanceReportItemPK
 InspectionConformanceReportItemPK InspectionConformanceReportItemVO.getPk()

Methods in bb.common with parameters of type InspectionConformanceReportItemPK
 void InspectionConformanceReportItemVO.setPk(InspectionConformanceReportItemPK pk)

Uses of InspectionConformanceReportItemPK in bb.common.box

Methods in bb.common.box with parameters of type InspectionConformanceReportItemPK
InspectionConformanceReportItemVO | QualityBox.findIcrItemByPk(InspectionConformanceReportItemPK pk)
InspectionConformanceReportItemInfo | QualityBox.getIcrItemInfoByPk(InspectionConformanceReportItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InspectionConformanceReportItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InspectionConformanceReportItemVO

Packages that use InspectionConformanceReportItemVO
bb.common
bb.common.box

Uses of InspectionConformanceReportItemVO in bb.common

Methods in bb.common that return InspectionConformanceReportItemVO
 InspectionConformanceReportItemVO InspectionConformanceReportItemInfo.getItem()

Methods in bb.common with parameters of type InspectionConformanceReportItemVO
 void InspectionConformanceReportItemInfo.setItem(InspectionConformanceReportItemVO item)

Uses of InspectionConformanceReportItemVO in bb.common.box

Methods in bb.common.box that return InspectionConformanceReportItemVO
 InspectionConformanceReportItemVO QualityBox.findIcrItemByPk(InspectionConformanceReportItemPK pk)

Methods in bb.common.box with parameters of type InspectionConformanceReportItemVO
 void QualityBox.updateICRItem(InspectionConformanceReportItemVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InspectionConformanceReportVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InspectionConformanceReportVO

Packages that use InspectionConformanceReportVO
bb.common.box

Uses of InspectionConformanceReportVO in bb.common.box

Methods in bb.common.box that return InspectionConformanceReportVO
 InspectionConformanceReportVO QualityBox.findIcrById(java.lang.String icrNumber)

Methods in bb.common.box with parameters of type InspectionConformanceReportVO
java.lang.String | QualityBox.addICR(InspectionConformanceReportVO vo)
void | QualityBox.updateICR(InspectionConformanceReportVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InspectionItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InspectionItemPK

Packages that use InspectionItemPK
bb.common
bb.common.box

Uses of InspectionItemPK in bb.common

Methods in bb.common that return InspectionItemPK
 InspectionItemPK InspectionItemVO.getPk()

Methods in bb.common with parameters of type InspectionItemPK
 void InspectionItemVO.setPk(InspectionItemPK pk)

Uses of InspectionItemPK in bb.common.box

Methods in bb.common.box with parameters of type InspectionItemPK
void | ManufacturingBox.deleteInspectionItem(InspectionItemPK pk)
InspectionItemVO | ManufacturingBox.getInspectionItem(InspectionItemPK pk)
boolean | ManufacturingBox.isInspectionItemExist(InspectionItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InspectionItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InspectionItemVO

Packages that use InspectionItemVO
bb.common.box

Uses of InspectionItemVO in bb.common.box

Methods in bb.common.box that return InspectionItemVO
InspectionItemVO | ManufacturingBox.addInspectionItem(InspectionItemVO vo)
InspectionItemVO | ManufacturingBox.getInspectionItem(InspectionItemPK pk)

Methods in bb.common.box that return types with arguments of type InspectionItemVO
 java.util.Collection<InspectionItemVO> ManufacturingBox.findAllInspectionItem(int operatingInstructionsTypeId, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type InspectionItemVO
InspectionItemVO | ManufacturingBox.addInspectionItem(InspectionItemVO vo)
void | ManufacturingBox.updateInspectionItem(InspectionItemVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InspectionReportInfoVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InspectionReportInfoVO

Packages that use InspectionReportInfoVO
bb.common.box

Uses of InspectionReportInfoVO in bb.common.box

Methods in bb.common.box that return types with arguments of type InspectionReportInfoVO
 java.util.Collection<InspectionReportInfoVO> ManufacturingBox.findInspectionReport(java.lang.String irNumber, java.lang.String oiNumber, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InspectionReportInspectMethodItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InspectionReportInspectMethodItemPK

Packages that use InspectionReportInspectMethodItemPK
bb.common

Uses of InspectionReportInspectMethodItemPK in bb.common

Methods in bb.common that return InspectionReportInspectMethodItemPK
 InspectionReportInspectMethodItemPK InspectionReportInspectMethodItemVO.getPk()

Methods in bb.common with parameters of type InspectionReportInspectMethodItemPK
 void InspectionReportInspectMethodItemVO.setPk(InspectionReportInspectMethodItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InspectionReportInspectMethodItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InspectionReportInspectMethodItemVO

Packages that use InspectionReportInspectMethodItemVO
bb.common

Uses of InspectionReportInspectMethodItemVO in bb.common

Methods in bb.common that return types with arguments of type InspectionReportInspectMethodItemVO
 java.util.Set<InspectionReportInspectMethodItemVO> InspectionReportVO.getInspectionReportInspectMethodItems()

Method parameters in bb.common with type arguments of type InspectionReportInspectMethodItemVO
 void InspectionReportVO.setInspectionReportInspectMethodItems(java.util.Set<InspectionReportInspectMethodItemVO> inspectionReportInspectMethodItems)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InspectionReportInspectMethodVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InspectionReportInspectMethodVO

Packages that use InspectionReportInspectMethodVO
bb.common
bb.common.box

Uses of InspectionReportInspectMethodVO in bb.common

Methods in bb.common that return InspectionReportInspectMethodVO
InspectionReportInspectMethodVO | InspectionReportInspectMethodItemVO.getInspectionReportInspectMethod()
InspectionReportInspectMethodVO | OperatingInstructionsInspectMethodItemVO.getOperatingInstructionsInspectMethod()

Methods in bb.common with parameters of type InspectionReportInspectMethodVO
void | InspectionReportInspectMethodItemVO.setInspectionReportInspectMethod(InspectionReportInspectMethodVO inspectionReportInspectMethod)
void | OperatingInstructionsInspectMethodItemVO.setOperatingInstructionsInspectMethod(InspectionReportInspectMethodVO operatingInstructionsInspectMethod)

Uses of InspectionReportInspectMethodVO in bb.common.box

Methods in bb.common.box that return InspectionReportInspectMethodVO
InspectionReportInspectMethodVO | ManufacturingBox.addInspectionReportInspectMethod(InspectionReportInspectMethodVO vo)
InspectionReportInspectMethodVO | ManufacturingBox.getInspectionReportInspectMethod(int ii)

Methods in bb.common.box that return types with arguments of type InspectionReportInspectMethodVO
 java.util.Collection<InspectionReportInspectMethodVO> ManufacturingBox.findAllInspectionReportInspectMethod(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type InspectionReportInspectMethodVO
InspectionReportInspectMethodVO | ManufacturingBox.addInspectionReportInspectMethod(InspectionReportInspectMethodVO vo)
void | ManufacturingBox.updateInspectionReportInspectMethod(InspectionReportInspectMethodVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InspectionReportInspectStandardItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InspectionReportInspectStandardItemPK

Packages that use InspectionReportInspectStandardItemPK
bb.common

Uses of InspectionReportInspectStandardItemPK in bb.common

Methods in bb.common that return InspectionReportInspectStandardItemPK
 InspectionReportInspectStandardItemPK InspectionReportInspectStandardItemVO.getPk()

Methods in bb.common with parameters of type InspectionReportInspectStandardItemPK
 void InspectionReportInspectStandardItemVO.setPk(InspectionReportInspectStandardItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InspectionReportInspectStandardItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InspectionReportInspectStandardItemVO

Packages that use InspectionReportInspectStandardItemVO
bb.common

Uses of InspectionReportInspectStandardItemVO in bb.common

Methods in bb.common that return types with arguments of type InspectionReportInspectStandardItemVO
 java.util.Set<InspectionReportInspectStandardItemVO> InspectionReportVO.getInspectionReportInspectStandardItems()

Method parameters in bb.common with type arguments of type InspectionReportInspectStandardItemVO
 void InspectionReportVO.setInspectionReportInspectStandardItems(java.util.Set<InspectionReportInspectStandardItemVO> inspectionReportInspectStandardItems)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InspectionReportItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InspectionReportItemPK

Packages that use InspectionReportItemPK
bb.common

Uses of InspectionReportItemPK in bb.common

Methods in bb.common that return InspectionReportItemPK
 InspectionReportItemPK InspectionReportItemVO.getPk()

Methods in bb.common with parameters of type InspectionReportItemPK
 void InspectionReportItemVO.setPk(InspectionReportItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InspectionReportItemQtyPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InspectionReportItemQtyPK

Packages that use InspectionReportItemQtyPK
bb.common

Uses of InspectionReportItemQtyPK in bb.common

Methods in bb.common that return InspectionReportItemQtyPK
 InspectionReportItemQtyPK InspectionReportItemQtyVO.getPk()

Methods in bb.common with parameters of type InspectionReportItemQtyPK
 void InspectionReportItemQtyVO.setPk(InspectionReportItemQtyPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InspectionReportItemQtyVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InspectionReportItemQtyVO

Packages that use InspectionReportItemQtyVO
bb.common

Uses of InspectionReportItemQtyVO in bb.common

Methods in bb.common that return types with arguments of type InspectionReportItemQtyVO
 java.util.Set<InspectionReportItemQtyVO> InspectionReportItemVO.getItems()

Method parameters in bb.common with type arguments of type InspectionReportItemQtyVO
 void InspectionReportItemVO.setItems(java.util.Set<InspectionReportItemQtyVO> items)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InspectionReportItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InspectionReportItemVO

Packages that use InspectionReportItemVO
bb.common

Uses of InspectionReportItemVO in bb.common

Methods in bb.common that return types with arguments of type InspectionReportItemVO
 java.util.Set<InspectionReportItemVO> InspectionReportVO.getInspectionReportItems()

Method parameters in bb.common with type arguments of type InspectionReportItemVO
 void InspectionReportVO.setInspectionReportItems(java.util.Set<InspectionReportItemVO> inspectionReportItems)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InspectionReportVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InspectionReportVO

Packages that use InspectionReportVO
bb.common.box

Uses of InspectionReportVO in bb.common.box

Methods in bb.common.box that return InspectionReportVO
InspectionReportVO | ManufacturingBox.addInspectionReport(InspectionReportVO vo)
InspectionReportVO | ManufacturingBox.getInspectionReport(java.lang.String inspectionReportNumber)

Methods in bb.common.box with parameters of type InspectionReportVO
InspectionReportVO | ManufacturingBox.addInspectionReport(InspectionReportVO vo)
void | ManufacturingBox.updateInspectionReport(InspectionReportVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InspectionTypeItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InspectionTypeItemPK

Packages that use InspectionTypeItemPK
bb.common

Uses of InspectionTypeItemPK in bb.common

Methods in bb.common that return InspectionTypeItemPK
 InspectionTypeItemPK InspectionTypeItemVO.getPk()

Methods in bb.common with parameters of type InspectionTypeItemPK
 void InspectionTypeItemVO.setPk(InspectionTypeItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InspectionTypeItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InspectionTypeItemVO

No usage of bb.common.InspectionTypeItemVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InspectionTypeVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InspectionTypeVO

Packages that use InspectionTypeVO
bb.common.box

Uses of InspectionTypeVO in bb.common.box

Methods in bb.common.box that return InspectionTypeVO
InspectionTypeVO | QualityBox.addInspectionType(InspectionTypeVO inspectionType)
InspectionTypeVO | QualityBox.getInspectionType(java.lang.String type)
InspectionTypeVO | QualityBox.updateInspectionType(InspectionTypeVO vo)

Methods in bb.common.box that return types with arguments of type InspectionTypeVO
 java.util.Collection<InspectionTypeVO> QualityBox.findInspectionType(java.lang.String type, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type InspectionTypeVO
InspectionTypeVO | QualityBox.addInspectionType(InspectionTypeVO inspectionType)
void | QualityBox.deleteInspectionType(InspectionTypeVO inspectionType)
InspectionTypeVO | QualityBox.updateInspectionType(InspectionTypeVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InventoryAdjustmentDetailResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InventoryAdjustmentDetailResult

Packages that use InventoryAdjustmentDetailResult
bb.common.box

Uses of InventoryAdjustmentDetailResult in bb.common.box

Methods in bb.common.box that return InventoryAdjustmentDetailResult
 InventoryAdjustmentDetailResult WarehouseBox.getInventoryAdjustmentDetail(BB2Part part)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InventoryAdjustmentListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InventoryAdjustmentListResult

Packages that use InventoryAdjustmentListResult
bb.common.box

Uses of InventoryAdjustmentListResult in bb.common.box

Methods in bb.common.box that return InventoryAdjustmentListResult
 InventoryAdjustmentListResult WarehouseBox.getInventoryAdjustmentListResult(BB2Part part)

Methods in bb.common.box that return types with arguments of type InventoryAdjustmentListResult
java.util.Collection<InventoryAdjustmentListResult> | WarehouseBox.findInventoryAdjustmentRecords(BB2Part part, int firstIndex, int maxLength)
java.util.Collection<InventoryAdjustmentListResult> | WarehouseBox.findInventoryAdjustmentRecords(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String countedBy, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InventoryAdjustmentVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InventoryAdjustmentVO

Packages that use InventoryAdjustmentVO
bb.common
bb.common.box

Uses of InventoryAdjustmentVO in bb.common

Subclasses of InventoryAdjustmentVO in bb.common
 class InventoryAdjustmentListResult

Methods in bb.common that return InventoryAdjustmentVO
 InventoryAdjustmentVO InventoryAdjustmentDetailResult.getLastAdjustment()

Methods in bb.common with parameters of type InventoryAdjustmentVO
 void InventoryAdjustmentDetailResult.setLastAdjustment(InventoryAdjustmentVO lastAdjustment)

Uses of InventoryAdjustmentVO in bb.common.box

Methods in bb.common.box that return InventoryAdjustmentVO
 InventoryAdjustmentVO WarehouseBox.getInventoryAdjustment(java.lang.Long pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InventoryAmountByMonth

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InventoryAmountByMonth

Packages that use InventoryAmountByMonth
bb.common.box

Uses of InventoryAmountByMonth in bb.common.box

Methods in bb.common.box that return InventoryAmountByMonth
 InventoryAmountByMonth ManagementBox.getInventoryAmountByDate(java.util.Date startDate, java.util.Date endDate)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InventoryAuditReportResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InventoryAuditReportResult

Packages that use InventoryAuditReportResult
bb.common.box

Uses of InventoryAuditReportResult in bb.common.box

Methods in bb.common.box that return InventoryAuditReportResult
InventoryAuditReportResult | WarehouseBox.getAuditInventoryReport(PartPK pk, java.util.Date fDate, java.util.Date tDate)
InventoryAuditReportResult | WarehouseBox.makeAuditInventoryByPhyInventory(PartPK pk, java.util.Date fDate, java.util.Date tDate)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InventoryCycleItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InventoryCycleItemResult

No usage of bb.common.InventoryCycleItemResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InventoryCycleResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InventoryCycleResult

Packages that use InventoryCycleResult
bb.common.box

Uses of InventoryCycleResult in bb.common.box

Methods in bb.common.box that return types with arguments of type InventoryCycleResult
 java.util.Collection<InventoryCycleResult> WarehouseBox.findInventoryCycleResults(java.lang.String select, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InventoryListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InventoryListResult

Packages that use InventoryListResult
bb.common.box

Uses of InventoryListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type InventoryListResult
java.util.Collection<InventoryListResult> | WarehouseBox.findInventoryListResultGTMaxQty(java.lang.String productCode, java.lang.String commodityCode, int firstIndex, int maxLength)
java.util.Collection<InventoryListResult> | WarehouseBox.findInventoryListResultOnlyWithMinQty(java.lang.String productCode, java.lang.String commodityCode, int firstIndex, int maxLength)
java.util.Collection<InventoryListResult> | WarehouseBox.findInventoryListResults(boolean showOnhandPartsOnly, boolean showInWipOnly, boolean showInSipOnly, boolean showInQaOnly, java.lang.String descriptionLike, java.lang.String pnFrom, java.lang.String pnTo, java.lang.String includePart, java.lang.String partType, java.lang.String partComeFrom, java.lang.String comCodeLike, java.lang.String languageCode, java.lang.String modelNumberLike, java.lang.String productCode, int firstIndex, int maxLength)
java.util.Collection<InventoryListResult> | WarehouseBox.findInventoryListResultsByCommodityCode(java.lang.String pnLike, java.lang.String partType, java.lang.String comCodeLike, java.lang.String buyercode, int firstIndex, int maxLength)
java.util.Collection<InventoryListResult> | WarehouseBox.findInventoryListResultWithMinAndMaxQty(int firstIndex, int maxLength)
java.util.Collection<InventoryListResult> | WarehouseBox.findInventoryListWithMinAndMaxQty(java.lang.String productCode, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<InventoryListResult> | WarehouseBox.findInventoryTotalByProductCode(java.lang.String productCode, int firstIndex, int length)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InventoryMonthReport

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InventoryMonthReport

Packages that use InventoryMonthReport
bb.common.box

Uses of InventoryMonthReport in bb.common.box

Methods in bb.common.box that return InventoryMonthReport
 InventoryMonthReport WarehouseBox.getLocationInventoryReportTotal(java.util.Date startDate, java.util.Date endDate, java.lang.String partNumber, java.lang.String partType, java.lang.String location)

Methods in bb.common.box that return types with arguments of type InventoryMonthReport
java.util.Collection<InventoryMonthReport> | WarehouseBox.findInventoryMonthReport(java.util.Date bDate, java.util.Date eDate, java.lang.String partNumberLike, java.lang.String partTypeLike, int firstIndex, int maxLength)
java.util.Collection<InventoryMonthReport> | WarehouseBox.findInventoryMonthReportTotal(java.util.Date bDate, java.util.Date eDate, java.lang.String partNumberLike, java.lang.String partTypeLike)
java.util.Collection<InventoryMonthReport> | WarehouseBox.findLocationInventoryReport(java.util.Date startDate, java.util.Date endDate, java.lang.String partNumber, java.lang.String partType, java.lang.String location, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InventoryNotUsedInMonthsforAppResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InventoryNotUsedInMonthsforAppResult

No usage of bb.common.InventoryNotUsedInMonthsforAppResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InventoryNotUsedInMonthsResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InventoryNotUsedInMonthsResult

Packages that use InventoryNotUsedInMonthsResult
bb.common
bb.common.box

Uses of InventoryNotUsedInMonthsResult in bb.common

Subclasses of InventoryNotUsedInMonthsResult in bb.common
 class InventoryNotUsedInMonthsforAppResult

Uses of InventoryNotUsedInMonthsResult in bb.common.box

Methods in bb.common.box that return types with arguments of type InventoryNotUsedInMonthsResult
java.util.Collection<InventoryNotUsedInMonthsResult> | WarehouseBox.findInventoryNotUsedInMonthsResults(java.util.Date fromDate, boolean showZeroOnhandItems, int firstIndex, int maxlenth)
java.util.Collection<InventoryNotUsedInMonthsResult> | WarehouseBox.findInventoryNotUsedInMonthsResults(int months, boolean showZeroOnhandItems, int firstIndex, int maxlenth)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InventoryNotUsedTotal

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InventoryNotUsedTotal

Packages that use InventoryNotUsedTotal
bb.common.box

Uses of InventoryNotUsedTotal in bb.common.box

Methods in bb.common.box that return InventoryNotUsedTotal
InventoryNotUsedTotal | WarehouseBox.getInventoryNotUsedCostInMonths(java.util.Date fromDate)
InventoryNotUsedTotal | WarehouseBox.getInventoryNotUsedCostInMonths(int months)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InventoryPartInOutDetailListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InventoryPartInOutDetailListResult

No usage of bb.common.InventoryPartInOutDetailListResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InventoryReportListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InventoryReportListResult

Packages that use InventoryReportListResult
bb.common
bb.common.box

Uses of InventoryReportListResult in bb.common

Subclasses of InventoryReportListResult in bb.common
 class InventoryAuditReportResult

Uses of InventoryReportListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type InventoryReportListResult
 java.util.Collection<InventoryReportListResult> WarehouseBox.findInventoryReportList(java.lang.String pnLike, java.lang.String paLike, java.util.Date fDate, java.util.Date tDate, int firstIndex, int maxlength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InventoryTotalCostResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InventoryTotalCostResult

Packages that use InventoryTotalCostResult
bb.common.box

Uses of InventoryTotalCostResult in bb.common.box

Methods in bb.common.box that return InventoryTotalCostResult
 InventoryTotalCostResult WarehouseBox.getInventoryListResultsCost(boolean showOnhandPartsOnly, boolean showInWipOnly, boolean showInSipOnly, boolean showInQaOnly, java.lang.String descriptionLike, java.lang.String pnFrom, java.lang.String pnTo, java.lang.String includePart, java.lang.String partType, java.lang.String partComeFrom, java.lang.String comCodeLike, java.lang.String modelNumberLike, java.lang.String productCode)

Methods in bb.common.box that return types with arguments of type InventoryTotalCostResult
 java.util.Collection<InventoryTotalCostResult> WarehouseBox.findHistoricalInventorysTotal(java.lang.String pnLike, java.lang.String paLike, java.util.Date fDate, java.util.Date tDate, boolean isShowOnHand)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InventoryTotalResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InventoryTotalResult

Packages that use InventoryTotalResult
bb.common.box

Uses of InventoryTotalResult in bb.common.box

Methods in bb.common.box that return InventoryTotalResult
 InventoryTotalResult WarehouseBox.getInventoryTotalResult()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InvoiceAgingItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InvoiceAgingItemListResult

Packages that use InvoiceAgingItemListResult
bb.common.box

Uses of InvoiceAgingItemListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type InvoiceAgingItemListResult
 java.util.Collection<InvoiceAgingItemListResult> AccountingBox.findAgingARItems(java.lang.String[] includeCustomerId, java.lang.String[] excludeCustomerId, boolean useAsOf, java.util.Date asOf, int firstIndex, int length)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InvoiceItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InvoiceItemListResult

Packages that use InvoiceItemListResult
bb.common
bb.common.box

Uses of InvoiceItemListResult in bb.common

Subclasses of InvoiceItemListResult in bb.common
class | CheckInvoiceItemListResult
class | InvoiceAgingItemListResult

Uses of InvoiceItemListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type InvoiceItemListResult
java.util.Collection<InvoiceItemListResult> | AccountingBox.findCMItemByDate(java.lang.String partNumberLike, java.lang.String partType, java.lang.String customerId, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isInvoiceDate, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<InvoiceItemListResult> | AccountingBox.findInvoiceByDate(java.lang.String partNumberLike, boolean partNumberlike, java.lang.String partType, java.lang.String pf, java.lang.String productCode, java.lang.String customerId, boolean customerLike, java.lang.String invoiceBy, java.lang.String status, java.lang.String dateType, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isCludeCmNumber, java.util.Date fromDate, java.util.Date toDate, java.math.BigDecimal lessThanMargin, java.math.BigDecimal highThanMargin, boolean billAndHold, java.util.Map moreParameters, int firstIndex, int maxLength)
java.util.Collection<InvoiceItemListResult> | AccountingBox.findInvoiceItemsByPartPK(PartPK partPk, int firstIndex, int maxLength)
java.util.Collection<InvoiceItemListResult> | AccountingBox.findOpenInvoiceItemsByPartPK(PartPK partPk, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.InvokeException

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.InvokeException

Packages that use InvokeException
bb.common.box

Uses of InvokeException in bb.common.box

Methods in bb.common.box that throw InvokeException
java.lang.String | WorkOrderBox.getWorkOrderVendorIDByWo(java.lang.String id)
WorkOrderWorkSheetItemWithRelatedInfoResult | WorkOrderBox.initWorkOrderWorkSheetItemForPart(WorkOrderWorkSheetPK pk, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
WorkOrderWorkSheetItemWithRelatedInfoResult | WorkOrderBox.initWorkOrderWorkSheetItemForTool(WorkOrderWorkSheetPK pk, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.IpAddressVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.IpAddressVO

Packages that use IpAddressVO
bb.common.box

Uses of IpAddressVO in bb.common.box

Methods in bb.common.box that return IpAddressVO
 IpAddressVO LogBox.getIpAddressInfo(java.lang.String ipv4Address)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.IssuedFromOrderItem

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.IssuedFromOrderItem

No usage of bb.common.IssuedFromOrderItem

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.IssueItemAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.IssueItemAgent

Packages that use IssueItemAgent
bb.common.box

Uses of IssueItemAgent in bb.common.box

Methods in bb.common.box with parameters of type IssueItemAgent
void | WarehouseBox.issuePartsToDisassembleWorkOrder(IssueItemAgent issueItemAgent)
void | WarehouseBox.issuePartsToWorkOrderItem(IssueItemAgent issueItemAgent)

Method parameters in bb.common.box with type arguments of type IssueItemAgent
 java.lang.Object[] WarehouseBox.addWorkOrderAndIssueParts(WorkOrderVO vo, WorkOrderItemVO item, java.util.ArrayList<WorkOrderItemSetupItemAgent> setupList, java.util.Set<IssueItemAgent> issueItemAgents, ReceiverAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.IssueItemDetailAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.IssueItemDetailAgent

Packages that use IssueItemDetailAgent
bb.common

Uses of IssueItemDetailAgent in bb.common

Methods in bb.common that return types with arguments of type IssueItemDetailAgent
 java.util.Set<IssueItemDetailAgent> IssueItemAgent.getIssueItemDetails()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.IssuingItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.IssuingItemResult

Packages that use IssuingItemResult
bb.common.box

Uses of IssuingItemResult in bb.common.box

Methods in bb.common.box that return types with arguments of type IssuingItemResult
 java.util.Collection<IssuingItemResult> WarehouseBox.getIssuingItemResultForWorkOrderItem(WorkOrderItemPK itemPk)

Methods in bb.common.box with parameters of type IssuingItemResult
 void WorkOrderBox.deleteWorkOrderItemIssue(IssuingItemResult item)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.IssuingResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.IssuingResult

Packages that use IssuingResult
bb.common.box

Uses of IssuingResult in bb.common.box

Methods in bb.common.box that return IssuingResult
 IssuingResult WarehouseBox.getWorkOrderItemIssuingResult(WorkOrderItemPK itemPk, boolean withOtherLocation)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.JobProcessSheetItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.JobProcessSheetItemResult

No usage of bb.common.JobProcessSheetItemResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.JobProcessSheetListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.JobProcessSheetListResult

Packages that use JobProcessSheetListResult
bb.common.box

Uses of JobProcessSheetListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type JobProcessSheetListResult
java.util.Collection<JobProcessSheetListResult> | ManufacturingBox.findJobProcessSheetListResults(java.lang.String woNumberLike, int firstIndex, int maxLength)
java.util.Collection<JobProcessSheetListResult> | ManufacturingBox.findJobProcessSheetListResultsByLookup(java.lang.String woNumber, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.JobProcessSheetResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.JobProcessSheetResult

Packages that use JobProcessSheetResult
bb.common.box

Uses of JobProcessSheetResult in bb.common.box

Methods in bb.common.box that return JobProcessSheetResult
 JobProcessSheetResult ManufacturingBox.getJobProcessSheetResult(PartPK partPk, boolean isTool, java.lang.String setId)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.JounalEntryListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.JounalEntryListResult

Packages that use JounalEntryListResult
bb.common

Uses of JounalEntryListResult in bb.common

Methods in bb.common that return types with arguments of type JounalEntryListResult
java.util.Map<java.lang.String,java.util.Map<JounalEntryListResult,java.util.Collection<JounalEntryListResult>>> | GLInfoByPeriodResult.getDailyList()
java.util.Map<java.lang.String,java.util.Map<JounalEntryListResult,java.util.Collection<JounalEntryListResult>>> | GLInfoByPeriodResult.getDailyList()

Method parameters in bb.common with type arguments of type JounalEntryListResult
void | GLInfoByPeriodResult.setDailyList(java.util.Map<java.lang.String,java.util.Map<JounalEntryListResult,java.util.Collection<JounalEntryListResult>>> dailyList)
void | GLInfoByPeriodResult.setDailyList(java.util.Map<java.lang.String,java.util.Map<JounalEntryListResult,java.util.Collection<JounalEntryListResult>>> dailyList)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.LabelTemplateConstant

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.LabelTemplateConstant

No usage of bb.common.LabelTemplateConstant

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.LabelTemplateItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.LabelTemplateItemPK

Packages that use LabelTemplateItemPK
bb.common

Uses of LabelTemplateItemPK in bb.common

Methods in bb.common that return LabelTemplateItemPK
 LabelTemplateItemPK LabelTemplateItemVO.getPk()

Methods in bb.common with parameters of type LabelTemplateItemPK
 void LabelTemplateItemVO.setPk(LabelTemplateItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.LabelTemplateItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.LabelTemplateItemVO

Packages that use LabelTemplateItemVO
bb.common

Uses of LabelTemplateItemVO in bb.common

Methods in bb.common that return types with arguments of type LabelTemplateItemVO
 java.util.Set<LabelTemplateItemVO> LabelTemplateVO.getItems()

Methods in bb.common with parameters of type LabelTemplateItemVO
 int LabelTemplateItemVO.compareTo(LabelTemplateItemVO o)

Method parameters in bb.common with type arguments of type LabelTemplateItemVO
 void LabelTemplateVO.setItems(java.util.Set<LabelTemplateItemVO> items)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.LabelTemplateVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.LabelTemplateVO

Packages that use LabelTemplateVO
bb.common.box

Uses of LabelTemplateVO in bb.common.box

Methods in bb.common.box that return LabelTemplateVO
LabelTemplateVO | WarehouseBox.addLabelTemplate(LabelTemplateVO vo)
LabelTemplateVO | WarehouseBox.getActiveLabelTemplateByType(java.lang.String labelType)
LabelTemplateVO | WarehouseBox.getLabelTemplate(int ii)

Methods in bb.common.box that return types with arguments of type LabelTemplateVO
 java.util.Collection<LabelTemplateVO> WarehouseBox.findAllLabelTemplate(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type LabelTemplateVO
LabelTemplateVO | WarehouseBox.addLabelTemplate(LabelTemplateVO vo)
void | WarehouseBox.updateLabelTemplate(LabelTemplateVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ListCache

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ListCache

No usage of bb.common.ListCache

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.LnShipperItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.LnShipperItemListResult

Packages that use LnShipperItemListResult
bb.common.box

Uses of LnShipperItemListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type LnShipperItemListResult
java.util.Collection<LnShipperItemListResult> | WarehouseBox.findLnShipperItemListResults(java.util.Date fromDate, java.util.Date toDate, java.lang.String lnShipperNumber, java.lang.String loanNumber, java.lang.String partNumber, java.lang.String partType, java.lang.String customerId, java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<LnShipperItemListResult> | WarehouseBox.findLnShipperItemListResultsByCustomerId(java.lang.String customerId, int firstIndex, int maxLength)
java.util.Collection<LnShipperItemListResult> | WarehouseBox.findLnShipperItemListResultsByLnNumber(java.lang.String loanNumber, int firstIndex, int maxLength)
java.util.Collection<LnShipperItemListResult> | WarehouseBox.findLnShipperItemListResultsByPartNumber(java.lang.String partNumber, java.lang.String partType, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.LnShipperListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.LnShipperListResult

Packages that use LnShipperListResult
bb.common.box

Uses of LnShipperListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type LnShipperListResult
java.util.Collection<LnShipperListResult> | WarehouseBox.findOnloanShipperListResultsByCustomerId(java.lang.String customerId, int firstIndex, int maxLength)
java.util.Collection<LnShipperListResult> | WarehouseBox.findOnloanShipperListResultsByLoanNumber(java.lang.String loanNumber, int firstIndex, int maxLength)
java.util.Collection<LnShipperListResult> | WarehouseBox.findOnloanShipperListResultsByOnloanShipperNumber(java.lang.String lnShipperNumber, int firstIndex, int maxLength)
java.util.Collection<LnShipperListResult> | WarehouseBox.findOnloanShipperListResultsBySalesman(java.lang.String salesman, int firstIndex, int maxLength)
java.util.Collection<LnShipperListResult> | WarehouseBox.findOpenOnloanShipperForReceiver(java.lang.String startWith, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.LocationResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.LocationResult

Packages that use LocationResult
bb.common.box

Uses of LocationResult in bb.common.box

Methods in bb.common.box that return types with arguments of type LocationResult
 java.util.Collection<LocationResult> WarehouseBox.findLocationResultWithoutWarehouse()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.LockedCustomerAddressResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.LockedCustomerAddressResult

No usage of bb.common.LockedCustomerAddressResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.LoginException

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.LoginException

No usage of bb.common.LoginException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.LogInventoryListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.LogInventoryListResult

Packages that use LogInventoryListResult
bb.common.box

Uses of LogInventoryListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type LogInventoryListResult
java.util.Collection<LogInventoryListResult> | WarehouseBox.findAllLogInventory(int firstIndex, int maxLength)
java.util.Collection<LogInventoryListResult> | WarehouseBox.findLogInventoryByPart(BB2Part part, int firstIndex, int maxLength)
java.util.Collection<LogInventoryListResult> | WarehouseBox.findLogInventoryByPartLike(java.lang.String partNumberLike, java.lang.String partType, java.lang.String partFrom, java.lang.String operator, java.lang.String location, java.util.Date fromDate, java.util.Date toDate, boolean listOtherLocationsForSamePart, int firstIndex, int maxLength)
java.util.Collection<LogInventoryListResult> | WarehouseBox.findLogInventorySimpleByPartLike(java.lang.String partNumberLike, java.lang.String partType, java.lang.String partFrom, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.LogInventoryVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.LogInventoryVO

Packages that use LogInventoryVO
bb.common.box

Uses of LogInventoryVO in bb.common.box

Methods in bb.common.box that return LogInventoryVO
LogInventoryVO | WarehouseBox.addLogInventory(LogInventoryVO vo)
LogInventoryVO | WarehouseBox.getLogInventoryByPk(java.lang.Long logItemNumber)

Methods in bb.common.box with parameters of type LogInventoryVO
LogInventoryVO | WarehouseBox.addLogInventory(LogInventoryVO vo)
void | WarehouseBox.deleteLogInventory(LogInventoryVO vo)
void | WarehouseBox.updateLogInventory(LogInventoryVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.LogMethodPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.LogMethodPK

Packages that use LogMethodPK
bb.common

Uses of LogMethodPK in bb.common

Methods in bb.common that return LogMethodPK
 LogMethodPK LogMethodVO.getPk()

Methods in bb.common with parameters of type LogMethodPK
 void LogMethodVO.setPk(LogMethodPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.LogMethodVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.LogMethodVO

No usage of bb.common.LogMethodVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.LogMiscDocumentVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.LogMiscDocumentVO

Packages that use LogMiscDocumentVO
bb.common.box

Uses of LogMiscDocumentVO in bb.common.box

Methods in bb.common.box that return types with arguments of type LogMiscDocumentVO
 java.util.Collection<LogMiscDocumentVO> CompanyBox.findMiscDocLog(java.lang.String docType, java.lang.String docFileName, java.lang.String action, java.lang.String operator, java.lang.String wanIp, java.lang.String lanIp, java.lang.String macAddress, java.lang.String description, java.lang.String extension, java.lang.String orderNumber, java.util.Date dateFrom, java.util.Date dateTo, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.LogPartDocumentVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.LogPartDocumentVO

Packages that use LogPartDocumentVO
bb.common.box

Uses of LogPartDocumentVO in bb.common.box

Methods in bb.common.box that return types with arguments of type LogPartDocumentVO
 java.util.Collection<LogPartDocumentVO> DocumentBox.findPartDocumentLog(java.lang.String partNumber, java.lang.String docType, java.lang.String language, java.lang.String action, java.lang.String operator, java.lang.String wanIp, java.lang.String lanIp, java.lang.String macAddress, java.lang.String isPublicDoc, java.lang.String description, java.util.Date dateFrom, java.util.Date dateTo, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.LogPartDwfVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.LogPartDwfVO

Packages that use LogPartDwfVO
bb.common.box

Uses of LogPartDwfVO in bb.common.box

Methods in bb.common.box that return types with arguments of type LogPartDwfVO
 java.util.Collection<LogPartDwfVO> EngineeringBox.findPartDwfLog(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String action, java.lang.String operator, java.lang.String wanIp, java.lang.String lanIp, java.lang.String macAddress, java.lang.String description, java.util.Date dateFrom, java.util.Date dateTo, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.LogPartDwgVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.LogPartDwgVO

Packages that use LogPartDwgVO
bb.common.box

Uses of LogPartDwgVO in bb.common.box

Methods in bb.common.box that return types with arguments of type LogPartDwgVO
 java.util.Collection<LogPartDwgVO> EngineeringBox.findPartDwgLog(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String action, java.lang.String operator, java.lang.String wanIp, java.lang.String lanIp, java.lang.String macAddress, java.lang.String description, java.util.Date dateFrom, java.util.Date dateTo, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.LogTaskVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.LogTaskVO

Packages that use LogTaskVO
bb.common.box

Uses of LogTaskVO in bb.common.box

Methods in bb.common.box that return types with arguments of type LogTaskVO
 java.util.Collection<LogTaskVO> CompanyBox.findLogTasks(java.lang.String name, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.LogTrackingVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.LogTrackingVO

Packages that use LogTrackingVO
bb.common.box

Uses of LogTrackingVO in bb.common.box

Methods in bb.common.box that return types with arguments of type LogTrackingVO
 java.util.Collection<LogTrackingVO> QualityBox.findLogTrackings(java.lang.String partNumber, java.lang.String partType, java.lang.String trackingNumber, java.lang.String refDoc1, java.lang.String refDoc2, java.lang.String operator, java.lang.String location, java.util.Date fromDate, java.util.Date toDate, int operationType, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.MaintenanceItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.MaintenanceItemPK

Packages that use MaintenanceItemPK
bb.common
bb.common.box

Uses of MaintenanceItemPK in bb.common

Methods in bb.common that return MaintenanceItemPK
 MaintenanceItemPK MaintenanceItemVO.getPk()

Methods in bb.common with parameters of type MaintenanceItemPK
 void MaintenanceItemVO.setPk(MaintenanceItemPK pk)

Uses of MaintenanceItemPK in bb.common.box

Methods in bb.common.box with parameters of type MaintenanceItemPK
 void ManufacturingBox.deleteMaintenanceItem(MaintenanceItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.MaintenanceItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.MaintenanceItemVO

Packages that use MaintenanceItemVO
bb.common.box

Uses of MaintenanceItemVO in bb.common.box

Methods in bb.common.box that return MaintenanceItemVO
MaintenanceItemVO | ManufacturingBox.addMaintenanceItem(MaintenanceItemVO vo)
MaintenanceItemVO | ManufacturingBox.updateMaintenanceItem(MaintenanceItemVO vo)

Methods in bb.common.box with parameters of type MaintenanceItemVO
MaintenanceItemVO | ManufacturingBox.addMaintenanceItem(MaintenanceItemVO vo)
MaintenanceItemVO | ManufacturingBox.updateMaintenanceItem(MaintenanceItemVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.MakeAccountPayableAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.MakeAccountPayableAgent

Packages that use MakeAccountPayableAgent
bb.common.box

Uses of MakeAccountPayableAgent in bb.common.box

Methods in bb.common.box with parameters of type MakeAccountPayableAgent
java.lang.String | AccountingBox.addEstimatedPayableWithReceiverItems(MakeAccountPayableAgent agent)
java.lang.String | AccountingBox.addPayableWithReceiver(MakeAccountPayableAgent agent)
java.lang.String | AccountingBox.addPayableWithReceiverItems(MakeAccountPayableAgent agent)
java.lang.String | AccountingBox.writeOffEstimatedPayable(java.lang.String apNumber, MakeAccountPayableAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.MakeBillAndHoldInvoiceAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.MakeBillAndHoldInvoiceAgent

No usage of bb.common.MakeBillAndHoldInvoiceAgent

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.MakeCheckAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.MakeCheckAgent

Packages that use MakeCheckAgent
bb.common.box

Uses of MakeCheckAgent in bb.common.box

Methods in bb.common.box with parameters of type MakeCheckAgent
 AccountPayableCheckVO AccountingBox.addSingleCheck(MakeCheckAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.MakeCreditMemoAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.MakeCreditMemoAgent

Packages that use MakeCreditMemoAgent
bb.common.box

Uses of MakeCreditMemoAgent in bb.common.box

Methods in bb.common.box with parameters of type MakeCreditMemoAgent
 java.lang.String AccountingBox.makeCreditMemoWithRMAReceiver(MakeCreditMemoAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.MakeDebitMemoAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.MakeDebitMemoAgent

Packages that use MakeDebitMemoAgent
bb.common.box

Uses of MakeDebitMemoAgent in bb.common.box

Methods in bb.common.box with parameters of type MakeDebitMemoAgent
 java.lang.String AccountingBox.makeDebitMemoWithRtvShipper(MakeDebitMemoAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.MakeInvoiceAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.MakeInvoiceAgent

Packages that use MakeInvoiceAgent
bb.common.box

Uses of MakeInvoiceAgent in bb.common.box

Methods in bb.common.box with parameters of type MakeInvoiceAgent
java.lang.String | AccountingBox.addARWithShipper(MakeInvoiceAgent agent)
java.lang.String | AccountingBox.addARWithShipperItems(MakeInvoiceAgent agent)
java.lang.String | AccountingBox.makeBillAndHoldInvoiceWithSOItems(MakeInvoiceAgent agent)
java.lang.String | AccountingBox.makeUnbilledWithShipperItems(MakeInvoiceAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.MakePrepaymentCheckAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.MakePrepaymentCheckAgent

Packages that use MakePrepaymentCheckAgent
bb.common.box

Uses of MakePrepaymentCheckAgent in bb.common.box

Methods in bb.common.box with parameters of type MakePrepaymentCheckAgent
 AccountPayableCheckVO AccountingBox.addSinglePrepaymentCheck(MakePrepaymentCheckAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ManufacturerAddressInfoVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ManufacturerAddressInfoVO

Packages that use ManufacturerAddressInfoVO
bb.common.box

Uses of ManufacturerAddressInfoVO in bb.common.box

Methods in bb.common.box that return types with arguments of type ManufacturerAddressInfoVO
java.util.Collection<ManufacturerAddressInfoVO> | AddressBox.findAllManufacturerAddresses(int firstIndex, int maxLength) *********************below is about ManufacturerAddress*********************
java.util.Collection<ManufacturerAddressInfoVO> | AddressBox.findDeletedManufacturerAddresses(java.lang.String manufacturerId, java.lang.String name, int firstIndex, int maxLength)
java.util.Collection<ManufacturerAddressInfoVO> | AddressBox.findManufacturerAddressesById(java.lang.String idRegex, int firstIndex, int maxLength)
java.util.Collection<ManufacturerAddressInfoVO> | AddressBox.findManufacturerAddressesByName(java.lang.String nameRegex, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ManufacturerAddressVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ManufacturerAddressVO

Packages that use ManufacturerAddressVO
bb.common.box

Uses of ManufacturerAddressVO in bb.common.box

Methods in bb.common.box that return ManufacturerAddressVO
ManufacturerAddressVO | AddressBox.addManufacturerAddress(ManufacturerAddressVO vo)
ManufacturerAddressVO | AddressBox.getManufacturerAddressById(java.lang.String id)
ManufacturerAddressVO | AddressBox.getManufacturerAddressById(java.lang.String id, java.lang.String languageCode)
ManufacturerAddressVO | AddressBox.updateManufacturerAddress(ManufacturerAddressVO vo)

Methods in bb.common.box with parameters of type ManufacturerAddressVO
ManufacturerAddressVO | AddressBox.addManufacturerAddress(ManufacturerAddressVO vo)
ManufacturerAddressVO | AddressBox.updateManufacturerAddress(ManufacturerAddressVO vo)

Method parameters in bb.common.box with type arguments of type ManufacturerAddressVO
 void CompanyBox.importTempManufacture(java.util.ArrayList<ManufacturerAddressVO> address)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ManufacturerContactPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ManufacturerContactPK

Packages that use ManufacturerContactPK
bb.common

Uses of ManufacturerContactPK in bb.common

Methods in bb.common that return ManufacturerContactPK
 ManufacturerContactPK ManufacturerContactVO.getPk()

Methods in bb.common with parameters of type ManufacturerContactPK
 void ManufacturerContactVO.setPk(ManufacturerContactPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ManufacturerContactVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ManufacturerContactVO

No usage of bb.common.ManufacturerContactVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ManufacturerDescriptionPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ManufacturerDescriptionPK

Packages that use ManufacturerDescriptionPK
bb.common

Uses of ManufacturerDescriptionPK in bb.common

Methods in bb.common that return ManufacturerDescriptionPK
 ManufacturerDescriptionPK ManufacturerDescriptionVO.getPk()

Methods in bb.common with parameters of type ManufacturerDescriptionPK
 void ManufacturerDescriptionVO.setPk(ManufacturerDescriptionPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ManufacturerDescriptionVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ManufacturerDescriptionVO

No usage of bb.common.ManufacturerDescriptionVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.MasterWorkOrderTreeItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.MasterWorkOrderTreeItemResult

Packages that use MasterWorkOrderTreeItemResult
bb.common.box

Uses of MasterWorkOrderTreeItemResult in bb.common.box

Methods in bb.common.box that return types with arguments of type MasterWorkOrderTreeItemResult
 java.util.Collection<MasterWorkOrderTreeItemResult> WorkOrderBox.getMasterWorkOrderTreeItem(BillPK billPk, WorkOrderItemPK woItemPk, java.math.BigDecimal qty, boolean calculateOrphan, java.lang.String languageCode)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.MessageAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.MessageAgent

Packages that use MessageAgent
bb.common.box

Uses of MessageAgent in bb.common.box

Methods in bb.common.box with parameters of type MessageAgent
 void CompanyBox.addMessage(MessageAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.MessageVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.MessageVO

Packages that use MessageVO
bb.common.box

Uses of MessageVO in bb.common.box

Methods in bb.common.box that return MessageVO
 MessageVO CompanyBox.getMessage(java.lang.Long ii)

Methods in bb.common.box that return types with arguments of type MessageVO
java.util.Collection<MessageVO> | CompanyBox.findAllReceivedMessages(java.lang.String sendUserName, java.lang.String sendFrom, java.lang.String subject, java.lang.String content, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int length)
java.util.Collection<MessageVO> | CompanyBox.findAllSentMessages(java.lang.String receiver, java.lang.String subject, java.lang.String content, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int length)
java.util.Collection<MessageVO> | CompanyBox.findMessages(java.lang.String subject, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int length)
java.util.Collection<MessageVO> | CompanyBox.findUnreadReceivedMessages(int firstIndex, int length)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.MfrMpnListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.MfrMpnListResult

Packages that use MfrMpnListResult
bb.common.box

Uses of MfrMpnListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type MfrMpnListResult
java.util.Collection<MfrMpnListResult> | WarehouseBox.getMfrMpnListResultsFor(PurchaseOrderItemPK itemPk)
java.util.Collection<MfrMpnListResult> | WarehouseBox.getMfrMpnListResultsFor(SalesOrderItemPK itemPk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.MiscDocAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.MiscDocAgent

Packages that use MiscDocAgent
bb.common.box

Uses of MiscDocAgent in bb.common.box

Methods in bb.common.box with parameters of type MiscDocAgent
java.util.Collection<AddressQualityDocumentsVO> | QualityBox.deleteAddressQualityDocuments(MiscDocAgent agent)
java.util.Collection<DesignControlDocumentVO> | EngineeringBox.deleteDCDoc(MiscDocAgent agent)
java.util.Collection<EmployeeRecordsVO> | HumanResourceBox.deleteEmployeeRecord(MiscDocAgent agent)
void | WorkOrderBox.deleteFTPDWODoc(MiscDocAgent agent)
java.util.Collection<EngineeringChangeDocumentVO> | EngineeringBox.deleteFTPECDoc(MiscDocAgent agent)
java.util.Collection<EngineeringChangeRequestDocumentVO> | EngineeringBox.deleteFTPECRDoc(MiscDocAgent agent)
void | CompanyBox.deleteFTPOrderDoc(MiscDocAgent agent)
java.util.Collection<ReturnMaterialAuthorizationDocumentVO> | SalesBox.deleteFTPRMADoc(MiscDocAgent agent)
java.util.Collection<SalesOrderDocumentVO> | SalesBox.deleteFTPSODoc(MiscDocAgent agent)
void | WorkOrderBox.deleteFTPWODoc(MiscDocAgent agent)
java.util.Collection<CustomerServiceIncidentItemVO> | CustomerServiceBox.deleteIncidentItemDoc(MiscDocAgent agent)
java.util.Collection<NCRPictureVO> | QualityBox.deleteNCRPicture(MiscDocAgent agent)
java.util.Collection<OnloanDocumentVO> | ManufacturingBox.deleteOnloanDoc(MiscDocAgent agent)
java.util.Collection<PreventiveActionRequestItemVO> | QualityBox.deletePARDoc(MiscDocAgent agent)
void | QualityBox.deletePartCertificate(MiscDocAgent agent)
void | EngineeringBox.deletePartPicture(MiscDocAgent agent)
java.util.Collection<PurchaseOrderDocumentVO> | PurchasingBox.deletePODoc(MiscDocAgent agent)
java.util.Collection<QuoteDocumentVO> | SalesBox.deleteQuoteDocument(MiscDocAgent agent)
void | ManufacturingBox.deleteWorkInstructionDocument(MiscDocAgent agent)
void | ManufacturingBox.deleteWorkInstructionPicture(MiscDocAgent agent)
byte[] | AccountingBox.downloadAccInfoDocument(MiscDocAgent agent)
byte[] | QualityBox.downloadAddressQualityDocuments(MiscDocAgent agent)
java.util.Collection<BB2Picture> | EngineeringBox.downloadAllPartPictureByPk(MiscDocAgent agent)
byte[] | EngineeringBox.downloadDCDoc(MiscDocAgent agent)
byte[] | HumanResourceBox.downloadEmployeeRecord(MiscDocAgent agent)
byte[] | WorkOrderBox.downloadFTPDWODoc(MiscDocAgent agent)
byte[] | EngineeringBox.downloadFTPECDoc(MiscDocAgent agent)
byte[] | EngineeringBox.downloadFTPECRDoc(MiscDocAgent agent)
byte[] | CompanyBox.downloadFTPOrderDoc(MiscDocAgent agent)
byte[] | SalesBox.downloadFTPRMADoc(MiscDocAgent agent)
byte[] | SalesBox.downloadFTPSODoc(MiscDocAgent agent)
byte[] | WorkOrderBox.downloadFTPWODoc(MiscDocAgent agent)
byte[] | CustomerServiceBox.downloadIncidentItemDoc(MiscDocAgent agent)
BB2Picture | EngineeringBox.downloadMainPartPicture(MiscDocAgent agent)
BB2File | QualityBox.downLoadNCRPicture(MiscDocAgent agent)
BB2File | ManufacturingBox.downloadOnloanDoc(MiscDocAgent agent)
BB2File | QualityBox.downloadPARDoc(MiscDocAgent agent)
BB2File | QualityBox.downloadPartCertificateFile(MiscDocAgent agent)
BB2File | PurchasingBox.downloadPODoc(MiscDocAgent agent)
byte[] | SalesBox.downloadQuoteDocument(MiscDocAgent agent)
BB2Picture | ManufacturingBox.downloadWorkInstructionPicture(MiscDocAgent agent)
byte[] | ManufacturingBox.downWorkInstructionDocument(MiscDocAgent agent)
boolean | CompanyBox.isFileExistent(MiscDocAgent agent, java.lang.String docType)
java.util.Collection<DesignControlDocumentVO> | EngineeringBox.updateDCDoc(MiscDocAgent agent)
java.util.Collection<DesignControlDocumentVO> | EngineeringBox.uploadDCDoc(MiscDocAgent agent)
java.util.List<AccountingInfoDocumentVO> | AccountingBox.uploadOrUpdateAccInfoDocument(MiscDocAgent agent)
java.util.Collection<AddressQualityDocumentsVO> | QualityBox.uploadOrUpdateAddressQualityDocuments(MiscDocAgent agent)
java.util.Collection<EmployeeRecordsVO> | HumanResourceBox.uploadOrUpdateEmployeeRecord(MiscDocAgent agent)
java.util.Collection<DisassembleWorkOrderDocumentVO> | WorkOrderBox.uploadOrUpdateFTPDWODoc(MiscDocAgent agent)
java.util.Collection<EngineeringChangeDocumentVO> | EngineeringBox.uploadOrUpdateFTPECDoc(MiscDocAgent agent)
java.util.Collection<EngineeringChangeRequestDocumentVO> | EngineeringBox.uploadOrUpdateFTPECRDoc(MiscDocAgent agent)
java.util.Collection<OrderDocumentVO> | CompanyBox.uploadOrUpdateFTPOrderDoc(MiscDocAgent agent)
java.util.Collection<ReturnMaterialAuthorizationDocumentVO> | SalesBox.uploadOrUpdateFTPRMADoc(MiscDocAgent agent)
java.util.Collection<SalesOrderDocumentVO> | SalesBox.uploadOrUpdateFTPSODoc(MiscDocAgent agent)
java.util.Collection<WorkOrderDocumentVO> | WorkOrderBox.uploadOrUpdateFTPWODoc(MiscDocAgent agent)
java.util.Collection<CustomerServiceIncidentItemVO> | CustomerServiceBox.uploadOrUpdateIncidentItemDoc(CustomerServiceIncidentItemVO vo, MiscDocAgent agent)
java.util.Collection<NCRPictureVO> | QualityBox.uploadOrUpdateNCRPicture(MiscDocAgent agent)
java.util.Collection<OnloanDocumentVO> | ManufacturingBox.uploadOrUpdateOnloanDoc(MiscDocAgent agent)
java.util.Collection<PreventiveActionRequestItemVO> | QualityBox.uploadOrUpdatePARDoc(MiscDocAgent agent)
java.util.Collection<PurchaseOrderDocumentVO> | PurchasingBox.uploadOrUpdatePODoc(MiscDocAgent agent)
java.util.Collection<QuoteDocumentVO> | SalesBox.uploadOrUpdateQuoteDocument(MiscDocAgent agent)
PartCertificateVO | QualityBox.uploadPartCertificate(MiscDocAgent agent)
void | EngineeringBox.uploadPartPicture(MiscDocAgent agent)
java.util.Collection<WorkInstructionDocumentVO> | ManufacturingBox.uploadWorkInstructionDocument(MiscDocAgent agent)
WorkInstructionPictureVO | ManufacturingBox.uploadWorkInstructionPicture(MiscDocAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.MiscDocumentSettingVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.MiscDocumentSettingVO

Packages that use MiscDocumentSettingVO
bb.common.box

Uses of MiscDocumentSettingVO in bb.common.box

Methods in bb.common.box that return MiscDocumentSettingVO
MiscDocumentSettingVO | CompanyBox.addMiscDocSetting(MiscDocumentSettingVO vo)
MiscDocumentSettingVO | CompanyBox.findMiscDocSettingByType(java.lang.String docType)
MiscDocumentSettingVO | CompanyBox.updateMiscDocSetting(MiscDocumentSettingVO vo)

Methods in bb.common.box that return types with arguments of type MiscDocumentSettingVO
 java.util.Collection<MiscDocumentSettingVO> CompanyBox.findAllMiscDocSetting(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type MiscDocumentSettingVO
MiscDocumentSettingVO | CompanyBox.addMiscDocSetting(MiscDocumentSettingVO vo)
void | CompanyBox.deleteMiscDocSetting(MiscDocumentSettingVO vo)
MiscDocumentSettingVO | CompanyBox.updateMiscDocSetting(MiscDocumentSettingVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Money

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Money

Packages that use Money
bb.common
bb.common.box

Uses of Money in bb.common

Methods in bb.common that return Money
Money | WareHousingInfoCenterResult.getInSipTotal()
Money | WareHousingInfoCenterResult.getInSitTotal()
Money | QtyAndMoney.getMoney()
Money | VendorPriceAgent.getPrice()
Money | PoReceiverByDateSummaryResult.getTotalAvgCost()
Money | PoReceiverByDateSummaryResult.getTotalStdCost()

Methods in bb.common with parameters of type Money
void | WareHousingInfoCenterResult.setInSipTotal(Money inSipTotal)
void | WareHousingInfoCenterResult.setInSitTotal(Money inSitTotal)
void | QtyAndMoney.setMoney(Money money)
void | VendorPriceAgent.setPrice(Money price)
void | PoReceiverByDateSummaryResult.setTotalAvgCost(Money totalAvgCost)
void | PoReceiverByDateSummaryResult.setTotalStdCost(Money totalStdCost)

Uses of Money in bb.common.box

Methods in bb.common.box that return Money
Money | SalesBox.getAllDueSalesOrdersTotalMoneyValue()
Money | SalesBox.getAllDueSalesOrdersTotalMoneyValue(java.lang.String customerId)
Money | SalesBox.getAllOpenSalesOrdersTotalMoneyValue()
Money | SalesBox.getAllOpenSalesOrdersTotalMoneyValue(java.lang.String customerId)
Money | SalesBox.getDueSalesOrdersTotalMoneyValueByDate(java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate)
Money | WarehouseBox.getPartWithWipQtyTotal()

Methods in bb.common.box that return types with arguments of type Money
java.util.Collection<Money> | PurchasingBox.findOpenPurchaseOrderTotal()
java.util.Collection<Money> | PurchasingBox.findPastDuePurchaseOrderTotal()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.MoneyInDrawResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.MoneyInDrawResult

Packages that use MoneyInDrawResult
bb.common.box

Uses of MoneyInDrawResult in bb.common.box

Methods in bb.common.box that return types with arguments of type MoneyInDrawResult
java.util.List<MoneyInDrawResult> | CompanyBox.findMoneyInDrawByComputer()
java.util.List<MoneyInDrawResult> | CompanyBox.getMoneyInDrawByComputerTotal()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.MonthBalanceResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.MonthBalanceResult

Packages that use MonthBalanceResult
bb.common.box

Uses of MonthBalanceResult in bb.common.box

Methods in bb.common.box that return types with arguments of type MonthBalanceResult
 java.util.Collection<MonthBalanceResult> AccountingBox.getAllAccountsChartBalanceByMonth(java.lang.String monthYear)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.MonthSoOrArByCustomerResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.MonthSoOrArByCustomerResult

Packages that use MonthSoOrArByCustomerResult
bb.common.box

Uses of MonthSoOrArByCustomerResult in bb.common.box

Methods in bb.common.box that return types with arguments of type MonthSoOrArByCustomerResult
java.util.Collection<MonthSoOrArByCustomerResult> | AccountingBox.findMonthARByCustomer(java.util.Date fromMonth, java.util.Date toMonth, java.lang.String ARStatus, java.lang.String customerId, boolean includeCM, int firstIndex, int maxLength)
java.util.Collection<MonthSoOrArByCustomerResult> | SalesBox.findMonthSOByCustomer(java.util.Date fromMonth, java.util.Date toMonth, java.lang.String salesOrderStatus, java.lang.String customerId, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.MrpByMonthResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.MrpByMonthResult

No usage of bb.common.MrpByMonthResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.MrpItemOrderDemandRecordsResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.MrpItemOrderDemandRecordsResult

Packages that use MrpItemOrderDemandRecordsResult
bb.common.box

Uses of MrpItemOrderDemandRecordsResult in bb.common.box

Methods in bb.common.box that return MrpItemOrderDemandRecordsResult
 MrpItemOrderDemandRecordsResult PurchasingBox.getMrpItemOrderDemandRecordsResult(PartPK part, MrpReportAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.MrpItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.MrpItemResult

Packages that use MrpItemResult
bb.common.box

Uses of MrpItemResult in bb.common.box

Methods in bb.common.box that return MrpItemResult
MrpItemResult | PurchasingBox.getMrpItemResult(PartPK pk, boolean minQty, boolean includeTolerance)
MrpItemResult | PurchasingBox.getMrpItemResult(PartPK part, MrpReportAgent tmp)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.MrpReportAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.MrpReportAgent

Packages that use MrpReportAgent
bb.common.box

Uses of MrpReportAgent in bb.common.box

Methods in bb.common.box with parameters of type MrpReportAgent
MrpItemOrderDemandRecordsResult | PurchasingBox.getMrpItemOrderDemandRecordsResult(PartPK part, MrpReportAgent agent)
MrpItemResult | PurchasingBox.getMrpItemResult(PartPK part, MrpReportAgent tmp)
java.util.Collection<PartPK> | PurchasingBox.getPartPKList(MrpReportAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.MultiLanguageAccountsChartPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.MultiLanguageAccountsChartPK

Packages that use MultiLanguageAccountsChartPK
bb.common

Uses of MultiLanguageAccountsChartPK in bb.common

Methods in bb.common that return MultiLanguageAccountsChartPK
 MultiLanguageAccountsChartPK MultiLanguageAccountsChartVO.getPk()

Methods in bb.common with parameters of type MultiLanguageAccountsChartPK
 void MultiLanguageAccountsChartVO.setPk(MultiLanguageAccountsChartPK pk)

Constructors in bb.common with parameters of type MultiLanguageAccountsChartPK
MultiLanguageAccountsChartVO(MultiLanguageAccountsChartPK pk, java.lang.String description)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.MultiLanguageAccountsChartVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.MultiLanguageAccountsChartVO

Packages that use MultiLanguageAccountsChartVO
bb.common

Uses of MultiLanguageAccountsChartVO in bb.common

Methods in bb.common that return types with arguments of type MultiLanguageAccountsChartVO
 java.util.Set<MultiLanguageAccountsChartVO> AccountsChartVO.getMultiLanuageDescription()

Method parameters in bb.common with type arguments of type MultiLanguageAccountsChartVO
 void AccountsChartVO.setMultiLanuageDescription(java.util.Set<MultiLanguageAccountsChartVO> multiLanuageDescriptionVO)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.MyPrintListPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.MyPrintListPK

Packages that use MyPrintListPK
bb.common

Uses of MyPrintListPK in bb.common

Methods in bb.common that return MyPrintListPK
 MyPrintListPK MyPrintListVO.getPk()

Methods in bb.common with parameters of type MyPrintListPK
 void MyPrintListVO.setPk(MyPrintListPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.MyPrintListVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.MyPrintListVO

Packages that use MyPrintListVO
bb.common.box

Uses of MyPrintListVO in bb.common.box

Methods in bb.common.box that return MyPrintListVO
MyPrintListVO | SalesBox.addMyPrintList(java.lang.String soNumber)
MyPrintListVO | PurchasingBox.addMyPrintList(java.lang.String soNumber)
MyPrintListVO | AccountingBox.addMyPrintList(java.lang.String arNumber)
MyPrintListVO | WarehouseBox.addReceiverToMyPrintList(java.lang.String receiverNumber)
MyPrintListVO | WarehouseBox.addShipperToMyPrintList(java.lang.String shipperNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.NCQRejectResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.NCQRejectResult

Packages that use NCQRejectResult
bb.common.box

Uses of NCQRejectResult in bb.common.box

Methods in bb.common.box that return types with arguments of type NCQRejectResult
java.util.Collection<NCQRejectResult> | QualityBox.findNCQsByNCCode(java.lang.String[] nCCodes, java.util.Date dateFrom, java.util.Date dateTo, int firstIndex, int maxLength)
java.util.Collection<NCQRejectResult> | QualityBox.findNCQsByNCCode(java.lang.String nCCode, java.util.Date dateFrom, java.util.Date dateTo, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.NcrApprovalPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.NcrApprovalPK

Packages that use NcrApprovalPK
bb.common
bb.common.box

Uses of NcrApprovalPK in bb.common

Methods in bb.common that return NcrApprovalPK
 NcrApprovalPK NcrApprovalVO.getPk()

Methods in bb.common with parameters of type NcrApprovalPK
 void NcrApprovalVO.setPk(NcrApprovalPK pk)

Uses of NcrApprovalPK in bb.common.box

Methods in bb.common.box with parameters of type NcrApprovalPK
void | QualityBox.deleteNcrApproval(NcrApprovalPK pk)
NcrApprovalVO | QualityBox.getNcrApprovalByEmployeeId(NcrApprovalPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.NcrApprovalVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.NcrApprovalVO

Packages that use NcrApprovalVO
bb.common.box

Uses of NcrApprovalVO in bb.common.box

Methods in bb.common.box that return NcrApprovalVO
NcrApprovalVO | QualityBox.addNcrApproval(java.lang.String employeeId, java.lang.String approvableType)
NcrApprovalVO | QualityBox.getNcrApprovalByEmployeeId(NcrApprovalPK pk)

Methods in bb.common.box that return types with arguments of type NcrApprovalVO
 java.util.Collection<NcrApprovalVO> QualityBox.findNcrApprovals(java.lang.String approvableType, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type NcrApprovalVO
 void QualityBox.updateNcrApproval(NcrApprovalVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.NcrNeedToScrapListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.NcrNeedToScrapListResult

Packages that use NcrNeedToScrapListResult
bb.common.box

Uses of NcrNeedToScrapListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type NcrNeedToScrapListResult
 java.util.Collection<NcrNeedToScrapListResult> QualityBox.findNCRsToCreateScrapGlByDate(java.lang.String pnLike, java.lang.String partType, java.util.Date fromDate, java.util.Date toDate, java.lang.String status, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.NCRPartOnhandPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.NCRPartOnhandPK

No usage of bb.common.NCRPartOnhandPK

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.NCRPictureListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.NCRPictureListResult

Packages that use NCRPictureListResult
bb.common.box

Uses of NCRPictureListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type NCRPictureListResult
 java.util.Collection<NCRPictureListResult> QualityBox.getNCRPictureListResults(java.lang.String ncrNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.NCRPictureVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.NCRPictureVO

Packages that use NCRPictureVO
bb.common.box

Uses of NCRPictureVO in bb.common.box

Methods in bb.common.box that return NCRPictureVO
 NCRPictureVO QualityBox.getNCRPicture(java.lang.Long ii)

Methods in bb.common.box that return types with arguments of type NCRPictureVO
java.util.Collection<NCRPictureVO> | QualityBox.deleteNCRPicture(MiscDocAgent agent)
java.util.Collection<NCRPictureVO> | QualityBox.uploadOrUpdateNCRPicture(MiscDocAgent agent)

Methods in bb.common.box with parameters of type NCRPictureVO
void | QualityBox.addNCRPicture(NCRPictureVO vo)
void | QualityBox.updateNCRPicture(NCRPictureVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.NcrReportListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.NcrReportListResult

Packages that use NcrReportListResult
bb.common.box

Uses of NcrReportListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type NcrReportListResult
java.util.Collection<NcrReportListResult> | QualityBox.findAllCanClosedNcrs(java.lang.String pnLike, java.lang.String partType, java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, boolean isListNotZero, boolean isListEquals, int firstIndex, int maxLength)
java.util.Collection<NcrReportListResult> | QualityBox.findNCRListByNCCode(java.lang.String nCCode, java.util.Date dateFrom, java.util.Date dateTo, int firstIndex, int maxLength)
java.util.Collection<NcrReportListResult> | QualityBox.findNCRsByDate(java.lang.String pnLike, java.lang.String partType, java.lang.String id, java.lang.String ncCode, java.lang.String purchaseOrderNumber, java.lang.String workOrderNumber, java.lang.String salesOrderNumber, java.lang.String rtvNumber, java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String status, java.lang.String enterBy, java.lang.String responsibility, java.lang.String problemDescription, java.lang.String problemDisposition, java.lang.String closedOutPrivateNotes, java.lang.String buyer, java.lang.String approvalType, java.lang.String approvedType, java.lang.String approval, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.NcrScrapAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.NcrScrapAgent

Packages that use NcrScrapAgent
bb.common.box

Uses of NcrScrapAgent in bb.common.box

Methods in bb.common.box with parameters of type NcrScrapAgent
 java.lang.String QualityBox.makeNcrScrapGl(NcrScrapAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.NonConformanceCodeDescriptionPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.NonConformanceCodeDescriptionPK

Packages that use NonConformanceCodeDescriptionPK
bb.common

Uses of NonConformanceCodeDescriptionPK in bb.common

Methods in bb.common that return NonConformanceCodeDescriptionPK
 NonConformanceCodeDescriptionPK NonConformanceCodeDescriptionVO.getPk()

Methods in bb.common with parameters of type NonConformanceCodeDescriptionPK
 void NonConformanceCodeDescriptionVO.setPk(NonConformanceCodeDescriptionPK pk)

Constructors in bb.common with parameters of type NonConformanceCodeDescriptionPK
NonConformanceCodeDescriptionVO(NonConformanceCodeDescriptionPK pk, java.lang.String description)
minimal constructor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.NonConformanceCodeDescriptionVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.NonConformanceCodeDescriptionVO

Packages that use NonConformanceCodeDescriptionVO
bb.common

Uses of NonConformanceCodeDescriptionVO in bb.common

Methods in bb.common that return types with arguments of type NonConformanceCodeDescriptionVO
 java.util.Set<NonConformanceCodeDescriptionVO> NonConformanceCodeVO.getDescriptions()

Method parameters in bb.common with type arguments of type NonConformanceCodeDescriptionVO
 void NonConformanceCodeVO.setDescriptions(java.util.Set<NonConformanceCodeDescriptionVO> descriptions)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.NonConformanceCodeVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.NonConformanceCodeVO

Packages that use NonConformanceCodeVO
bb.common
bb.common.box

Uses of NonConformanceCodeVO in bb.common

Methods in bb.common that return NonConformanceCodeVO
 NonConformanceCodeVO NonConformanceQuantityVO.getNonConformanceCodeName()

Methods in bb.common with parameters of type NonConformanceCodeVO
 void NonConformanceQuantityVO.setNonConformanceCodeName(NonConformanceCodeVO nonConformanceCodeNameVO)

Constructors in bb.common with parameters of type NonConformanceCodeVO
NonConformanceQuantityVO(NonConformanceQuantityPK pk, java.math.BigDecimal rejectQuantity, java.lang.String nonConformanceCode, NonConformanceCodeVO nonConformanceCodeNameVO, NonConformanceReportVO nonConformanceReportVO)
full constructor

Uses of NonConformanceCodeVO in bb.common.box

Methods in bb.common.box that return NonConformanceCodeVO
NonConformanceCodeVO | QualityBox.addNCC(NonConformanceCodeVO vo)
NonConformanceCodeVO | QualityBox.findNccById(java.lang.String code)
NonConformanceCodeVO | QualityBox.updateNCC(NonConformanceCodeVO vo)

Methods in bb.common.box that return types with arguments of type NonConformanceCodeVO
 java.util.Collection<NonConformanceCodeVO> QualityBox.findAllNCCs(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type NonConformanceCodeVO
NonConformanceCodeVO | QualityBox.addNCC(NonConformanceCodeVO vo)
void | QualityBox.deleteNCC(NonConformanceCodeVO vo)
NonConformanceCodeVO | QualityBox.updateNCC(NonConformanceCodeVO vo)

Method parameters in bb.common.box with type arguments of type NonConformanceCodeVO
 void CompanyBox.importTempNccode(java.util.ArrayList<NonConformanceCodeVO> nccodes)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.NonConformanceQuantityPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.NonConformanceQuantityPK

Packages that use NonConformanceQuantityPK
bb.common

Uses of NonConformanceQuantityPK in bb.common

Methods in bb.common that return NonConformanceQuantityPK
 NonConformanceQuantityPK NonConformanceQuantityVO.getPk()

Methods in bb.common with parameters of type NonConformanceQuantityPK
 void NonConformanceQuantityVO.setPk(NonConformanceQuantityPK pk)

Constructors in bb.common with parameters of type NonConformanceQuantityPK
NonConformanceQuantityVO(NonConformanceQuantityPK pk, java.math.BigDecimal rejectQuantity, java.lang.String nonConformanceCode)
minimal constructor
NonConformanceQuantityVO(NonConformanceQuantityPK pk, java.math.BigDecimal rejectQuantity, java.lang.String nonConformanceCode, NonConformanceCodeVO nonConformanceCodeNameVO, NonConformanceReportVO nonConformanceReportVO)
full constructor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.NonConformanceQuantityVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.NonConformanceQuantityVO

No usage of bb.common.NonConformanceQuantityVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.NonConformanceReportResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.NonConformanceReportResult

No usage of bb.common.NonConformanceReportResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.NonConformanceReportVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.NonConformanceReportVO

Packages that use NonConformanceReportVO
bb.common
bb.common.box

Uses of NonConformanceReportVO in bb.common

Methods in bb.common that return NonConformanceReportVO
 NonConformanceReportVO NonConformanceQuantityVO.getNonConformanceReport()

Methods in bb.common with parameters of type NonConformanceReportVO
 void NonConformanceQuantityVO.setNonConformanceReport(NonConformanceReportVO nonConformanceReportVO)

Constructors in bb.common with parameters of type NonConformanceReportVO
NonConformanceQuantityVO(NonConformanceQuantityPK pk, java.math.BigDecimal rejectQuantity, java.lang.String nonConformanceCode, NonConformanceCodeVO nonConformanceCodeNameVO, NonConformanceReportVO nonConformanceReportVO)
full constructor

Uses of NonConformanceReportVO in bb.common.box

Methods in bb.common.box that return NonConformanceReportVO
NonConformanceReportVO | QualityBox.approvalNcrForEng(NonConformanceReportVO ncrVo)
NonConformanceReportVO | QualityBox.approvalNcrForMfg(NonConformanceReportVO ncrVo)
NonConformanceReportVO | QualityBox.approvalNcrForQa(NonConformanceReportVO ncrVo)
NonConformanceReportVO | QualityBox.findCustomerVendorIDByOrderNumber(java.lang.String orderNumber)
NonConformanceReportVO | QualityBox.findNcrById(java.lang.String ncrNumber)
NonConformanceReportVO | QualityBox.updateNCR(NonConformanceReportVO vo, java.util.HashSet<PuttoInQAAgent> putToInQAAgentSet, java.util.HashSet<PullFromWorkOrderPartDetailAgent> pullFromWorkOrderPartDetailAgentSet, java.util.HashSet<RebackInQAAgent> reBackInQAAgentSet)

Methods in bb.common.box that return types with arguments of type NonConformanceReportVO
java.util.Collection<NonConformanceReportVO> | QualityBox.findAllNCRs(int firstIndex, int maxLength)
java.util.Collection<NonConformanceReportVO> | QualityBox.findDueNCRs(int firstIndex, int maxLength)
java.util.Collection<NonConformanceReportVO> | QualityBox.findNCRsByNcrNumber(java.lang.String ncrNumberRegexp, int firstIndex, int maxLength)
java.util.Collection<NonConformanceReportVO> | QualityBox.findNCRsByPart(PartPK pk, int firstIndex, int maxLength)
java.util.Collection<NonConformanceReportVO> | QualityBox.findOpenNCRs(int firstIndex, int maxLength)
java.util.Collection<NonConformanceReportVO> | QualityBox.findOpenNCRsByPartPK(PartPK pk, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type NonConformanceReportVO
java.lang.String | QualityBox.addNCR(NonConformanceReportVO vo)
java.lang.String | QualityBox.addNCR(NonConformanceReportVO vo, java.util.HashSet<java.lang.Integer> sets)
NonConformanceReportVO | QualityBox.approvalNcrForEng(NonConformanceReportVO ncrVo)
NonConformanceReportVO | QualityBox.approvalNcrForMfg(NonConformanceReportVO ncrVo)
NonConformanceReportVO | QualityBox.approvalNcrForQa(NonConformanceReportVO ncrVo)
void | QualityBox.deleteNCR(NonConformanceReportVO vo)
NonConformanceReportVO | QualityBox.updateNCR(NonConformanceReportVO vo, java.util.HashSet<PuttoInQAAgent> putToInQAAgentSet, java.util.HashSet<PullFromWorkOrderPartDetailAgent> pullFromWorkOrderPartDetailAgentSet, java.util.HashSet<RebackInQAAgent> reBackInQAAgentSet)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.NonproductivePickingApprovalVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.NonproductivePickingApprovalVO

Packages that use NonproductivePickingApprovalVO
bb.common.box

Uses of NonproductivePickingApprovalVO in bb.common.box

Methods in bb.common.box that return NonproductivePickingApprovalVO
NonproductivePickingApprovalVO | WarehouseBox.addNonproductivePickingApproval(java.lang.String employee)
NonproductivePickingApprovalVO | WarehouseBox.getNonproductivePickingApprovalByPk(java.lang.String pk)
NonproductivePickingApprovalVO | WarehouseBox.updateNonproductivePickingAprroval(NonproductivePickingApprovalVO vo)

Methods in bb.common.box that return types with arguments of type NonproductivePickingApprovalVO
 java.util.List<NonproductivePickingApprovalVO> WarehouseBox.findAllNonproductivePickingApprovals(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type NonproductivePickingApprovalVO
void | WarehouseBox.deleteNonproductivePickingApproval(NonproductivePickingApprovalVO vo)
NonproductivePickingApprovalVO | WarehouseBox.updateNonproductivePickingAprroval(NonproductivePickingApprovalVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.NonproductivePickingApproveVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.NonproductivePickingApproveVO

No usage of bb.common.NonproductivePickingApproveVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.NonproductivePickingItemIssuedListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.NonproductivePickingItemIssuedListResult

Packages that use NonproductivePickingItemIssuedListResult
bb.common.box

Uses of NonproductivePickingItemIssuedListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type NonproductivePickingItemIssuedListResult
 java.util.Collection<NonproductivePickingItemIssuedListResult> WarehouseBox.findNonproductivePickingItemIssuedList(java.lang.String monthYear, int firstIndex, int maxLength)

Method parameters in bb.common.box with type arguments of type NonproductivePickingItemIssuedListResult
 java.lang.String AccountingBox.makeNonproductivePickingGl(java.lang.String creditAccountNumber, java.lang.String monthYear, java.util.ArrayList<NonproductivePickingItemIssuedListResult> list, java.lang.String glCategory)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.NonproductivePickingItemIssuedVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.NonproductivePickingItemIssuedVO

No usage of bb.common.NonproductivePickingItemIssuedVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.NonproductivePickingItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.NonproductivePickingItemPK

Packages that use NonproductivePickingItemPK
bb.common

Uses of NonproductivePickingItemPK in bb.common

Methods in bb.common that return NonproductivePickingItemPK
NonproductivePickingItemPK | NonproductivePickingOnDemandResult.getPk()
NonproductivePickingItemPK | NonproductivePickingItemVO.getPk()

Methods in bb.common with parameters of type NonproductivePickingItemPK
void | NonproductivePickingOnDemandResult.setPk(NonproductivePickingItemPK pk)
void | NonproductivePickingItemVO.setPk(NonproductivePickingItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.NonproductivePickingItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.NonproductivePickingItemResult

Packages that use NonproductivePickingItemResult
bb.common.box

Uses of NonproductivePickingItemResult in bb.common.box

Methods in bb.common.box that return types with arguments of type NonproductivePickingItemResult
 java.util.Collection<NonproductivePickingItemResult> WarehouseBox.findNonproductivePickingItemResults(java.lang.String pickingNumber, java.lang.String status, java.lang.String id, java.lang.String orderType, java.util.Date fromDate, java.util.Date toDate, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String project, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.NonproductivePickingItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.NonproductivePickingItemVO

Packages that use NonproductivePickingItemVO
bb.common
bb.common.box

Uses of NonproductivePickingItemVO in bb.common

Methods in bb.common that return types with arguments of type NonproductivePickingItemVO
 java.util.Set<NonproductivePickingItemVO> NonproductivePickingVO.getPickingItems()

Method parameters in bb.common with type arguments of type NonproductivePickingItemVO
 void NonproductivePickingVO.setPickingItems(java.util.Set<NonproductivePickingItemVO> pickingItems)

Uses of NonproductivePickingItemVO in bb.common.box

Methods in bb.common.box that return NonproductivePickingItemVO
 NonproductivePickingItemVO WarehouseBox.InitNonproductivePickingItem(NonproductivePickingVO vo, BB2Part part, java.math.BigDecimal quantity)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.NonproductivePickingOnDemandResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.NonproductivePickingOnDemandResult

Packages that use NonproductivePickingOnDemandResult
bb.common

Uses of NonproductivePickingOnDemandResult in bb.common

Methods in bb.common that return types with arguments of type NonproductivePickingOnDemandResult
 java.util.ArrayList<NonproductivePickingOnDemandResult> BB2PartTotalOndemandDetailResult.getNpDetails()

Method parameters in bb.common with type arguments of type NonproductivePickingOnDemandResult
 void BB2PartTotalOndemandDetailResult.setNpDetails(java.util.ArrayList<NonproductivePickingOnDemandResult> npDetails)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.NonproductivePickingTypeVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.NonproductivePickingTypeVO

Packages that use NonproductivePickingTypeVO
bb.common.box

Uses of NonproductivePickingTypeVO in bb.common.box

Methods in bb.common.box that return NonproductivePickingTypeVO
NonproductivePickingTypeVO | WarehouseBox.addNonproductivePickingType(NonproductivePickingTypeVO vo)
NonproductivePickingTypeVO | WarehouseBox.findNonproductivePickingTypeByKey(int key)
NonproductivePickingTypeVO | WarehouseBox.findNonproductivePickingTypeByName(java.lang.String name)
NonproductivePickingTypeVO | WarehouseBox.updateNonproductivePickingType(NonproductivePickingTypeVO vo)

Methods in bb.common.box that return types with arguments of type NonproductivePickingTypeVO
 java.util.List<NonproductivePickingTypeVO> WarehouseBox.findAllNonproductivePickingTypes(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type NonproductivePickingTypeVO
NonproductivePickingTypeVO | WarehouseBox.addNonproductivePickingType(NonproductivePickingTypeVO vo)
void | WarehouseBox.deleteNonproductivePickingType(NonproductivePickingTypeVO vo)
NonproductivePickingTypeVO | WarehouseBox.updateNonproductivePickingType(NonproductivePickingTypeVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.NonproductivePickingVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.NonproductivePickingVO

Packages that use NonproductivePickingVO
bb.common.box

Uses of NonproductivePickingVO in bb.common.box

Methods in bb.common.box that return NonproductivePickingVO
NonproductivePickingVO | WarehouseBox.addNonproductivePicking(NonproductivePickingVO vo)
NonproductivePickingVO | WarehouseBox.approveNonproductivePicking(NonproductivePickingVO vo)
NonproductivePickingVO | WarehouseBox.getNonproductivePickingByPk(java.lang.String pickingNumber)

Methods in bb.common.box that return types with arguments of type NonproductivePickingVO
 java.util.Collection<NonproductivePickingVO> WarehouseBox.findNonproductivePickings(java.lang.String pickingNumber, java.lang.String status, java.lang.String id, java.lang.String orderType, java.util.Date fromDate, java.util.Date toDate, java.lang.String project, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type NonproductivePickingVO
NonproductivePickingVO | WarehouseBox.addNonproductivePicking(NonproductivePickingVO vo)
NonproductivePickingVO | WarehouseBox.approveNonproductivePicking(NonproductivePickingVO vo)
NonproductivePickingItemVO | WarehouseBox.InitNonproductivePickingItem(NonproductivePickingVO vo, BB2Part part, java.math.BigDecimal quantity)
void | WarehouseBox.updateNonproductivePicking(NonproductivePickingVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.NoticeUserEmployeeListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.NoticeUserEmployeeListResult

Packages that use NoticeUserEmployeeListResult
bb.common.box

Uses of NoticeUserEmployeeListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type NoticeUserEmployeeListResult
 java.util.Collection<NoticeUserEmployeeListResult> CompanyBox.findNoticeUserEmployee(java.lang.String userName, java.lang.String systemUserName, java.lang.String userGroup, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OIPrincipalVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OIPrincipalVO

Packages that use OIPrincipalVO
bb.common.box

Uses of OIPrincipalVO in bb.common.box

Methods in bb.common.box that return OIPrincipalVO
OIPrincipalVO | ManufacturingBox.addOIPrincipal(OIPrincipalVO vo)
OIPrincipalVO | ManufacturingBox.getOIPrincipal()

Methods in bb.common.box with parameters of type OIPrincipalVO
OIPrincipalVO | ManufacturingBox.addOIPrincipal(OIPrincipalVO vo)
void | ManufacturingBox.updateOIPrincipal(OIPrincipalVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OnhandQualityResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OnhandQualityResult

No usage of bb.common.OnhandQualityResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OnloanDocumentVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OnloanDocumentVO

Packages that use OnloanDocumentVO
bb.common.box

Uses of OnloanDocumentVO in bb.common.box

Methods in bb.common.box that return OnloanDocumentVO
 OnloanDocumentVO ManufacturingBox.getOnloanDocumentByID(java.lang.Long controlNumber)

Methods in bb.common.box that return types with arguments of type OnloanDocumentVO
java.util.Collection<OnloanDocumentVO> | ManufacturingBox.deleteOnloanDoc(MiscDocAgent agent)
java.util.Collection<OnloanDocumentVO> | ManufacturingBox.uploadOrUpdateOnloanDoc(MiscDocAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OnLoanItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OnLoanItemListResult

Packages that use OnLoanItemListResult
bb.common.box

Uses of OnLoanItemListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type OnLoanItemListResult
java.util.Collection<OnLoanItemListResult> | WarehouseBox.findAllDueLoan(int firstIndex, int maxLength)
java.util.Collection<OnLoanItemListResult> | WarehouseBox.findAllOnLoanByAddressId(java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<OnLoanItemListResult> | WarehouseBox.findAllOpenLoan(int firstIndex, int maxLength)
java.util.Collection<OnLoanItemListResult> | WarehouseBox.findAllOpenOnLoanByAddressId(java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<OnLoanItemListResult> | WarehouseBox.findAllPastDueLoanByAddressId(java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<OnLoanItemListResult> | WarehouseBox.findLoanItemByPartPk(PartPK pk, java.lang.String partFromType, int firstIndex, int maxLength)
java.util.Collection<OnLoanItemListResult> | WarehouseBox.findOnLoanItemsByDate(PartPK partPk, java.lang.String customerId, java.lang.String salesMan, java.lang.String status, boolean isDeliveryDate, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OnLoanItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OnLoanItemPK

Packages that use OnLoanItemPK
bb.common
bb.common.box

Uses of OnLoanItemPK in bb.common

Methods in bb.common that return OnLoanItemPK
 OnLoanItemPK OnLoanItemVO.getPk()

Methods in bb.common with parameters of type OnLoanItemPK
 void OnLoanItemVO.setPk(OnLoanItemPK pk)

Uses of OnLoanItemPK in bb.common.box

Methods in bb.common.box with parameters of type OnLoanItemPK
boolean | WarehouseBox.isOnLoanItemExist(OnLoanItemPK pk)
void | WarehouseBox.setOnLoanItemReferenceDocOne(OnLoanItemPK pk, java.lang.String referenceDoc)
void | WarehouseBox.setOnLoanItemReferenceDocTwo(OnLoanItemPK pk, java.lang.String referenceDoc)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OnLoanItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OnLoanItemVO

Packages that use OnLoanItemVO
bb.common.box

Uses of OnLoanItemVO in bb.common.box

Methods in bb.common.box that return OnLoanItemVO
 OnLoanItemVO WarehouseBox.initOnLoanItem(OnLoanVO onloanVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OnLoanListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OnLoanListResult

Packages that use OnLoanListResult
bb.common.box

Uses of OnLoanListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type OnLoanListResult
java.util.Collection<OnLoanListResult> | WarehouseBox.findAllOnLoans(int firstIndex, int maxLength)
java.util.Collection<OnLoanListResult> | WarehouseBox.findCheckList(int firstIndex, int maxLength)
java.util.Collection<OnLoanListResult> | WarehouseBox.findOnLoansByLoanNumber(java.lang.String loanNumberExp, int firstIndex, int maxLength)
java.util.Collection<OnLoanListResult> | WarehouseBox.findOnLoansByPoNumber(java.lang.String poNumberExp, int firstIndex, int maxLength)
java.util.Collection<OnLoanListResult> | WarehouseBox.findOpenOnLoansForShipper(java.lang.String loanNumberExp, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OnloanReceiverItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OnloanReceiverItemListResult

Packages that use OnloanReceiverItemListResult
bb.common.box

Uses of OnloanReceiverItemListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type OnloanReceiverItemListResult
java.util.Collection<OnloanReceiverItemListResult> | WarehouseBox.findOnloanReceiverItemListResultsByCustID(java.lang.String custID, int firstIndex, int maxLength)
java.util.Collection<OnloanReceiverItemListResult> | WarehouseBox.findOnloanReceiverItemListResultsByLnNumber(java.lang.String loanNumber, int firstIndex, int maxLength)
java.util.Collection<OnloanReceiverItemListResult> | WarehouseBox.findOnloanReceiverItemListResultsByLnShipperNumber(java.lang.String lnShipperNumber, int firstIndex, int maxLength)
java.util.Collection<OnloanReceiverItemListResult> | WarehouseBox.findOnloanReceiverItemListResultsByOnloanReceiverNumber(java.lang.String receiverNumber, int firstIndex, int maxLength)
java.util.Collection<OnloanReceiverItemListResult> | WarehouseBox.findOnloanReceiverItemListResultsByPartNumber(java.lang.String partNumber, java.lang.String partType, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OnloanReceiverItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OnloanReceiverItemPK

Packages that use OnloanReceiverItemPK
bb.common
bb.common.box

Uses of OnloanReceiverItemPK in bb.common

Methods in bb.common that return OnloanReceiverItemPK
 OnloanReceiverItemPK OnloanReceiverItemVO.getPk()

Methods in bb.common with parameters of type OnloanReceiverItemPK
 void OnloanReceiverItemVO.setPk(OnloanReceiverItemPK pk)

Constructors in bb.common with parameters of type OnloanReceiverItemPK
OnloanReceiverItemVO(OnloanReceiverItemPK pk, java.lang.String lnShipperNumber, java.math.BigDecimal apSub, java.math.BigDecimal apReceived, java.math.BigDecimal apOpen, java.math.BigDecimal apDiscount, java.math.BigDecimal extendPrice, java.math.BigDecimal apTax, java.math.BigDecimal apTotal, java.lang.String referenceDoc1, java.lang.String referenceDoc2, java.lang.String qr, java.lang.String sentTo, java.lang.String receivedBy, java.lang.String condition, java.lang.String status, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String modelNumber, java.lang.String revision, java.lang.String location, java.math.BigDecimal quantity, java.math.BigDecimal quantityTraced, java.math.BigDecimal quantityReceived, java.math.BigDecimal costPerUnit, java.lang.String unit, java.math.BigDecimal discount, java.math.BigDecimal taxRate, java.lang.String description, java.lang.String mfg, java.lang.String mpn, java.lang.String serial)
minimal constructor
OnloanReceiverItemVO(OnloanReceiverItemPK pk, java.lang.String lnShipperNumber, java.math.BigDecimal apSub, java.math.BigDecimal apReceived, java.math.BigDecimal apOpen, java.math.BigDecimal apDiscount, java.math.BigDecimal extendPrice, java.math.BigDecimal apTax, java.math.BigDecimal apTotal, java.lang.String referenceDoc1, java.lang.String referenceDoc2, java.lang.String qr, java.lang.String sentTo, java.lang.String receivedBy, java.lang.String condition, java.lang.String status, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String modelNumber, java.lang.String revision, java.lang.String location, java.math.BigDecimal quantity, java.math.BigDecimal quantityTraced, java.math.BigDecimal quantityReceived, java.math.BigDecimal costPerUnit, java.lang.String unit, java.math.BigDecimal discount, java.math.BigDecimal taxRate, java.lang.String description, java.lang.String mfg, java.lang.String mpn, java.lang.String serial, java.lang.String receiverItemComments, java.lang.String receiverItemPrivateNotes)
full constructor

Uses of OnloanReceiverItemPK in bb.common.box

Methods in bb.common.box with parameters of type OnloanReceiverItemPK
 OnloanReceiverItemVO WarehouseBox.getOnloanReceiverItemByPk(OnloanReceiverItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OnloanReceiverItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OnloanReceiverItemVO

Packages that use OnloanReceiverItemVO
bb.common.box

Uses of OnloanReceiverItemVO in bb.common.box

Methods in bb.common.box that return OnloanReceiverItemVO
 OnloanReceiverItemVO WarehouseBox.getOnloanReceiverItemByPk(OnloanReceiverItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OnloanReceiverListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OnloanReceiverListResult

Packages that use OnloanReceiverListResult
bb.common.box

Uses of OnloanReceiverListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type OnloanReceiverListResult
java.util.Collection<OnloanReceiverListResult> | WarehouseBox.findOnloanReceiverListResultsByCustID(java.lang.String custID, int firstIndex, int maxLength)
java.util.Collection<OnloanReceiverListResult> | WarehouseBox.findOnloanReceiverListResultsByLnShipperNumber(java.lang.String lnShipperNumber, int firstIndex, int maxLength)
java.util.Collection<OnloanReceiverListResult> | WarehouseBox.findOnloanReceiverListResultsByOnloanReceiverNumber(java.lang.String receiverNumber, int firstIndex, int maxLength)
java.util.Collection<OnloanReceiverListResult> | WarehouseBox.getOnloanReceiversByLn(java.lang.String onLoanNumber)
java.util.Collection<OnloanReceiverListResult> | WarehouseBox.makeOnloanReceiver(ReceiverAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OnloanReceiverVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OnloanReceiverVO

Packages that use OnloanReceiverVO
bb.common.box

Uses of OnloanReceiverVO in bb.common.box

Methods in bb.common.box that return OnloanReceiverVO
 OnloanReceiverVO WarehouseBox.getOnloanReceiver(java.lang.String receiverNumber)

Methods in bb.common.box with parameters of type OnloanReceiverVO
 java.lang.String WarehouseBox.updateOnloanReceiver(OnloanReceiverVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OnloanReviewVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OnloanReviewVO

Packages that use OnloanReviewVO
bb.common.box

Uses of OnloanReviewVO in bb.common.box

Methods in bb.common.box that return OnloanReviewVO
OnloanReviewVO | WarehouseBox.addOnloanControl(java.lang.String employeeId)
OnloanReviewVO | WarehouseBox.getOnloanControlByEmoloyeeTrueName(java.lang.String emoloyeeTrueName)
OnloanReviewVO | WarehouseBox.getOnloanControlByEmployeeId(java.lang.String employeeId)
OnloanReviewVO | WarehouseBox.updateOnloanControl(OnloanReviewVO vo)

Methods in bb.common.box that return types with arguments of type OnloanReviewVO
java.util.Collection<OnloanReviewVO> | WarehouseBox.findAllOnloanControl(int firstIndex, int maxLength)
java.util.Collection<OnloanReviewVO> | WarehouseBox.findOnloanControlByUserTrueNameLike(java.lang.String userTrueNameLike, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type OnloanReviewVO
 OnloanReviewVO WarehouseBox.updateOnloanControl(OnloanReviewVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OnloanShipperItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OnloanShipperItemPK

Packages that use OnloanShipperItemPK
bb.common
bb.common.box

Uses of OnloanShipperItemPK in bb.common

Methods in bb.common that return OnloanShipperItemPK
OnloanShipperItemPK | OnloanShipperItemVO.getPk()
OnloanShipperItemPK | BB2PartOnLoanItemResult.getPk()

Methods in bb.common with parameters of type OnloanShipperItemPK
void | OnloanShipperItemVO.setPk(OnloanShipperItemPK pk)
void | BB2PartOnLoanItemResult.setPk(OnloanShipperItemPK pk)

Constructors in bb.common with parameters of type OnloanShipperItemPK
OnloanShipperItemVO(OnloanShipperItemPK pk, java.lang.String loanNumber, java.math.BigDecimal arSub, java.math.BigDecimal arShip, java.math.BigDecimal arOpen, java.math.BigDecimal arDiscount, java.math.BigDecimal arNet, java.math.BigDecimal arTax, java.math.BigDecimal arTotal, java.lang.String referenceDoc1, java.lang.String referenceDoc2, java.util.Date dateShipped, java.util.Date dateInvoiced, java.lang.String shipVia, java.lang.String shipToId, java.lang.String status, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String modelNumber, java.lang.String revision, java.lang.String location, java.math.BigDecimal loanQuantity, java.math.BigDecimal quantityShip, java.math.BigDecimal listPrice, java.math.BigDecimal averageCost, java.lang.String unit, java.math.BigDecimal discount, java.math.BigDecimal taxRate, java.lang.String description, java.lang.String mfg, java.lang.String mpn, java.lang.String serialNumber, java.lang.String shipperItemComments, java.lang.String shipperItemPrivateNotes)
full constructor
OnloanShipperItemVO(OnloanShipperItemPK pk, java.lang.String loanNumber, java.lang.String status, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom)
minimal constructor

Uses of OnloanShipperItemPK in bb.common.box

Methods in bb.common.box with parameters of type OnloanShipperItemPK
 OnloanShipperItemVO WarehouseBox.getOnloanShipperItemByPK(OnloanShipperItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OnloanShipperItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OnloanShipperItemVO

Packages that use OnloanShipperItemVO
bb.common.box

Uses of OnloanShipperItemVO in bb.common.box

Methods in bb.common.box that return OnloanShipperItemVO
 OnloanShipperItemVO WarehouseBox.getOnloanShipperItemByPK(OnloanShipperItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OnloanShipperVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OnloanShipperVO

Packages that use OnloanShipperVO
bb.common.box

Uses of OnloanShipperVO in bb.common.box

Methods in bb.common.box that return OnloanShipperVO
OnloanShipperVO | WarehouseBox.getOnloanShipperById(java.lang.String lnShipperNumber)
OnloanShipperVO | WarehouseBox.updateOnloanShipper(OnloanShipperVO vo)

Methods in bb.common.box that return types with arguments of type OnloanShipperVO
java.util.Collection<OnloanShipperVO> | WarehouseBox.findAllOnloanShippers(int firstIndex, int maxLength)
java.util.Collection<OnloanShipperVO> | WarehouseBox.findOnloanShippersByLn(java.lang.String loanNumber, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type OnloanShipperVO
 OnloanShipperVO WarehouseBox.updateOnloanShipper(OnloanShipperVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OnLoanVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OnLoanVO

Packages that use OnLoanVO
bb.common.box

Uses of OnLoanVO in bb.common.box

Methods in bb.common.box that return OnLoanVO
OnLoanVO | WarehouseBox.addOnLoan(OnLoanVO vo)
OnLoanVO | WarehouseBox.getOnLoanByLoanNumber(java.lang.String loanNumber)

Methods in bb.common.box with parameters of type OnLoanVO
OnLoanVO | WarehouseBox.addOnLoan(OnLoanVO vo)
OnLoanItemVO | WarehouseBox.initOnLoanItem(OnLoanVO onloanVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool)
java.lang.String | WarehouseBox.reviewOnLoan(OnLoanVO loanVo)
java.lang.String | WarehouseBox.updateOnLoan(OnLoanVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OnTimeAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OnTimeAgent

Packages that use OnTimeAgent
bb.common.box

Uses of OnTimeAgent in bb.common.box

Methods in bb.common.box with parameters of type OnTimeAgent
PurchaseOnTimeResult | ManagementBox.getPurchaseOnTimeResult(OnTimeAgent agent)
SalesOnTimeResult | ManagementBox.getSalesOnTimeResult(OnTimeAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OntimeDeliveryRateListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OntimeDeliveryRateListResult

Packages that use OntimeDeliveryRateListResult
bb.common.box

Uses of OntimeDeliveryRateListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type OntimeDeliveryRateListResult
java.util.Collection<OntimeDeliveryRateListResult> | SalesBox.findCustomerOnTimeDeliveryRateByCustomerId(java.lang.String customerId, java.util.Date from, java.util.Date to, java.lang.String dateType, int delayDays, int beforeDays, java.lang.String salesman, java.lang.String partNumber, java.lang.String partType, java.lang.String incoterm, int firstIndex, int maxLength)
java.util.Collection<OntimeDeliveryRateListResult> | WorkOrderBox.findVendorOnTimeDeliveryRateByVendorId(java.lang.String vendorId, java.util.Date from, java.util.Date to, int delayDays, int beforeDays, int firstIndex, int maxLength)
java.util.Collection<OntimeDeliveryRateListResult> | PurchasingBox.findVendorOnTimeDeliveryRateByVendorId(java.lang.String vendorId, java.util.Date from, java.util.Date to, java.lang.String dateType, int delayDays, int beforeDays, boolean includeInSit, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OntimeDeliveryRateResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OntimeDeliveryRateResult

Packages that use OntimeDeliveryRateResult
bb.common.box

Uses of OntimeDeliveryRateResult in bb.common.box

Methods in bb.common.box that return OntimeDeliveryRateResult
OntimeDeliveryRateResult | SalesBox.getCustomerOnTimeDeliveryRate(java.lang.String customerId, java.util.Date from, java.util.Date to, java.lang.String dateType, int delayDays, int beforeDays, java.lang.String salesman, java.lang.String partNumber, java.lang.String partType, java.lang.String incoterm)
OntimeDeliveryRateResult | WorkOrderBox.getVendorOnTimeDeliveryRate(java.lang.String vendorId, java.util.Date from, java.util.Date to, int delayDays, int beforeDays)
OntimeDeliveryRateResult | PurchasingBox.getVendorOnTimeDeliveryRate(java.lang.String vendorId, java.util.Date from, java.util.Date to, java.lang.String dateType, int delayDays, int beforeDays, boolean includeInSit)

Methods in bb.common.box that return types with arguments of type OntimeDeliveryRateResult
java.util.Map<java.util.Date,OntimeDeliveryRateResult> | WorkOrderBox.getLast12MonthOntimeDeliveryRate(java.lang.String vendorId, int overDueDays, int advanceDays)
java.util.Map<java.util.Date,OntimeDeliveryRateResult> | PurchasingBox.getLast12MonthOntimeDeliveryRate(java.lang.String vendorId, java.lang.String dateType, int overDueDays, int advanceDays)
java.util.Map<java.util.Date,OntimeDeliveryRateResult> | SalesBox.getLast12MonthOntimeDeliveryRate(java.lang.String customerId, java.lang.String dateType, int overDueDays, int advanceDays, java.lang.String salesman, java.lang.String partNumber, java.lang.String partType, java.lang.String incoterm)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OpCodeShortcutPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OpCodeShortcutPK

Packages that use OpCodeShortcutPK
bb.common

Uses of OpCodeShortcutPK in bb.common

Methods in bb.common that return OpCodeShortcutPK
 OpCodeShortcutPK OpCodeShortcutVO.getOpCodeShortcutPK()

Methods in bb.common with parameters of type OpCodeShortcutPK
int | OpCodeShortcutPK.compareTo(OpCodeShortcutPK other)
void | OpCodeShortcutVO.setOpCodeShortcutPK(OpCodeShortcutPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OpCodeShortcutVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OpCodeShortcutVO

Packages that use OpCodeShortcutVO
bb.common.box

Uses of OpCodeShortcutVO in bb.common.box

Methods in bb.common.box that return types with arguments of type OpCodeShortcutVO
 java.util.Collection<OpCodeShortcutVO> CompanyBox.getOpCodeShortcutByUserName(java.lang.String userName)

Method parameters in bb.common.box with type arguments of type OpCodeShortcutVO
 void CompanyBox.updateOpCodeShortcut(java.util.ArrayList<OpCodeShortcutVO> opCodeShortcuts, java.lang.String userName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OperatingInstructionsInspectMethodItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OperatingInstructionsInspectMethodItemPK

Packages that use OperatingInstructionsInspectMethodItemPK
bb.common

Uses of OperatingInstructionsInspectMethodItemPK in bb.common

Methods in bb.common that return OperatingInstructionsInspectMethodItemPK
 OperatingInstructionsInspectMethodItemPK OperatingInstructionsInspectMethodItemVO.getPk()

Methods in bb.common with parameters of type OperatingInstructionsInspectMethodItemPK
 void OperatingInstructionsInspectMethodItemVO.setPk(OperatingInstructionsInspectMethodItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OperatingInstructionsInspectMethodItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OperatingInstructionsInspectMethodItemVO

Packages that use OperatingInstructionsInspectMethodItemVO
bb.common

Uses of OperatingInstructionsInspectMethodItemVO in bb.common

Methods in bb.common that return types with arguments of type OperatingInstructionsInspectMethodItemVO
 java.util.Set<OperatingInstructionsInspectMethodItemVO> OperatingInstructionsVO.getOperatingInstructionsInspectMethodItems()

Method parameters in bb.common with type arguments of type OperatingInstructionsInspectMethodItemVO
 void OperatingInstructionsVO.setOperatingInstructionsInspectMethodItems(java.util.Set<OperatingInstructionsInspectMethodItemVO> operatingInstructionsInspectMethodItems)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OperatingInstructionsInspectResultItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OperatingInstructionsInspectResultItemPK

Packages that use OperatingInstructionsInspectResultItemPK
bb.common

Uses of OperatingInstructionsInspectResultItemPK in bb.common

Methods in bb.common that return OperatingInstructionsInspectResultItemPK
 OperatingInstructionsInspectResultItemPK OperatingInstructionsInspectResultItemVO.getPk()

Methods in bb.common with parameters of type OperatingInstructionsInspectResultItemPK
 void OperatingInstructionsInspectResultItemVO.setPk(OperatingInstructionsInspectResultItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OperatingInstructionsInspectResultItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OperatingInstructionsInspectResultItemVO

Packages that use OperatingInstructionsInspectResultItemVO
bb.common

Uses of OperatingInstructionsInspectResultItemVO in bb.common

Methods in bb.common that return types with arguments of type OperatingInstructionsInspectResultItemVO
 java.util.Set<OperatingInstructionsInspectResultItemVO> OperatingInstructionsVO.getOperatingInstructionsInspectResultItems()

Method parameters in bb.common with type arguments of type OperatingInstructionsInspectResultItemVO
 void OperatingInstructionsVO.setOperatingInstructionsInspectResultItems(java.util.Set<OperatingInstructionsInspectResultItemVO> operatingInstructionsInspectResultItems)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OperatingInstructionsInspectStandardItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OperatingInstructionsInspectStandardItemPK

Packages that use OperatingInstructionsInspectStandardItemPK
bb.common

Uses of OperatingInstructionsInspectStandardItemPK in bb.common

Methods in bb.common that return OperatingInstructionsInspectStandardItemPK
 OperatingInstructionsInspectStandardItemPK OperatingInstructionsInspectStandardItemVO.getPk()

Methods in bb.common with parameters of type OperatingInstructionsInspectStandardItemPK
 void OperatingInstructionsInspectStandardItemVO.setPk(OperatingInstructionsInspectStandardItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OperatingInstructionsInspectStandardItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OperatingInstructionsInspectStandardItemVO

Packages that use OperatingInstructionsInspectStandardItemVO
bb.common

Uses of OperatingInstructionsInspectStandardItemVO in bb.common

Methods in bb.common that return types with arguments of type OperatingInstructionsInspectStandardItemVO
 java.util.Set<OperatingInstructionsInspectStandardItemVO> OperatingInstructionsVO.getOperatingInstructionsInspectStandardItems()

Method parameters in bb.common with type arguments of type OperatingInstructionsInspectStandardItemVO
 void OperatingInstructionsVO.setOperatingInstructionsInspectStandardItems(java.util.Set<OperatingInstructionsInspectStandardItemVO> operatingInstructionsInspectStandardItems)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OperatingInstructionsInspectStandardVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OperatingInstructionsInspectStandardVO

Packages that use OperatingInstructionsInspectStandardVO
bb.common
bb.common.box

Uses of OperatingInstructionsInspectStandardVO in bb.common

Methods in bb.common that return OperatingInstructionsInspectStandardVO
OperatingInstructionsInspectStandardVO | InspectionReportInspectStandardItemVO.getInspectionReportInspectStandard()
OperatingInstructionsInspectStandardVO | OperatingInstructionsInspectStandardItemVO.getOperatingInstructionsInspectStandard()

Methods in bb.common with parameters of type OperatingInstructionsInspectStandardVO
void | InspectionReportInspectStandardItemVO.setInspectionReportInspectStandard(OperatingInstructionsInspectStandardVO inspectionReportInspectStandard)
void | OperatingInstructionsInspectStandardItemVO.setOperatingInstructionsInspectStandard(OperatingInstructionsInspectStandardVO operatingInstructionsInspectStandard)

Uses of OperatingInstructionsInspectStandardVO in bb.common.box

Methods in bb.common.box that return OperatingInstructionsInspectStandardVO
OperatingInstructionsInspectStandardVO | ManufacturingBox.addOperatingInstructionsInspectStandard(OperatingInstructionsInspectStandardVO vo)
OperatingInstructionsInspectStandardVO | ManufacturingBox.getOperatingInstructionsInspectStandard(int ii)

Methods in bb.common.box that return types with arguments of type OperatingInstructionsInspectStandardVO
 java.util.Collection<OperatingInstructionsInspectStandardVO> ManufacturingBox.findAllOperatingInstructionsInspectStandard(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type OperatingInstructionsInspectStandardVO
OperatingInstructionsInspectStandardVO | ManufacturingBox.addOperatingInstructionsInspectStandard(OperatingInstructionsInspectStandardVO vo)
void | ManufacturingBox.updateOperatingInstructionsInspectStandard(OperatingInstructionsInspectStandardVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OperatingInstructionsManualItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OperatingInstructionsManualItemPK

Packages that use OperatingInstructionsManualItemPK
bb.common

Uses of OperatingInstructionsManualItemPK in bb.common

Methods in bb.common that return OperatingInstructionsManualItemPK
 OperatingInstructionsManualItemPK OperatingInstructionsManualItemVO.getPk()

Methods in bb.common with parameters of type OperatingInstructionsManualItemPK
 void OperatingInstructionsManualItemVO.setPk(OperatingInstructionsManualItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OperatingInstructionsManualItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OperatingInstructionsManualItemVO

Packages that use OperatingInstructionsManualItemVO
bb.common

Uses of OperatingInstructionsManualItemVO in bb.common

Methods in bb.common that return types with arguments of type OperatingInstructionsManualItemVO
 java.util.Set<OperatingInstructionsManualItemVO> OperatingInstructionsVO.getOperatingInstructionsManuals()

Method parameters in bb.common with type arguments of type OperatingInstructionsManualItemVO
 void OperatingInstructionsVO.setOperatingInstructionsManuals(java.util.Set<OperatingInstructionsManualItemVO> operatingInstructionsManuals)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OperatingInstructionsManualVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OperatingInstructionsManualVO

Packages that use OperatingInstructionsManualVO
bb.common
bb.common.box

Uses of OperatingInstructionsManualVO in bb.common

Methods in bb.common that return OperatingInstructionsManualVO
 OperatingInstructionsManualVO OperatingInstructionsManualItemVO.getOperatingInstructionsManual()

Methods in bb.common with parameters of type OperatingInstructionsManualVO
 void OperatingInstructionsManualItemVO.setOperatingInstructionsManual(OperatingInstructionsManualVO operatingInstructionsManual)

Uses of OperatingInstructionsManualVO in bb.common.box

Methods in bb.common.box that return OperatingInstructionsManualVO
OperatingInstructionsManualVO | ManufacturingBox.addOperatingInstructionsManual(OperatingInstructionsManualVO vo)
OperatingInstructionsManualVO | ManufacturingBox.getOperatingInstructionsManual(int ii)

Methods in bb.common.box that return types with arguments of type OperatingInstructionsManualVO
 java.util.Collection<OperatingInstructionsManualVO> ManufacturingBox.findAllOperatingInstructionsManual(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type OperatingInstructionsManualVO
OperatingInstructionsManualVO | ManufacturingBox.addOperatingInstructionsManual(OperatingInstructionsManualVO vo)
void | ManufacturingBox.updateOperatingInstructionsManual(OperatingInstructionsManualVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OperatingInstructionsTypeVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OperatingInstructionsTypeVO

Packages that use OperatingInstructionsTypeVO
bb.common
bb.common.box

Uses of OperatingInstructionsTypeVO in bb.common

Methods in bb.common that return OperatingInstructionsTypeVO
OperatingInstructionsTypeVO | OperatingInstructionsVO.getOperatingInstructionsType()
OperatingInstructionsTypeVO | InspectionReportVO.getOperatingInstructionsType()
OperatingInstructionsTypeVO | InspectionReportInfoVO.getOperatingInstructionsType()

Methods in bb.common with parameters of type OperatingInstructionsTypeVO
void | OperatingInstructionsVO.setOperatingInstructionsType(OperatingInstructionsTypeVO operatingInstructionsType)
void | InspectionReportVO.setOperatingInstructionsType(OperatingInstructionsTypeVO operatingInstructionsType)
void | InspectionReportInfoVO.setOperatingInstructionsType(OperatingInstructionsTypeVO operatingInstructionsType)

Uses of OperatingInstructionsTypeVO in bb.common.box

Methods in bb.common.box that return OperatingInstructionsTypeVO
OperatingInstructionsTypeVO | ManufacturingBox.addOperatingInstructionsType(OperatingInstructionsTypeVO vo)
OperatingInstructionsTypeVO | ManufacturingBox.getOperatingInstructionsType(int ii)

Methods in bb.common.box that return types with arguments of type OperatingInstructionsTypeVO
 java.util.Collection<OperatingInstructionsTypeVO> ManufacturingBox.findAllOperatingInstructionsType(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type OperatingInstructionsTypeVO
OperatingInstructionsTypeVO | ManufacturingBox.addOperatingInstructionsType(OperatingInstructionsTypeVO vo)
void | ManufacturingBox.updateOperatingInstructionsType(OperatingInstructionsTypeVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OperatingInstructionsUserStatisticalResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OperatingInstructionsUserStatisticalResult

No usage of bb.common.OperatingInstructionsUserStatisticalResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OperatingInstructionsVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OperatingInstructionsVO

Packages that use OperatingInstructionsVO
bb.common.box

Uses of OperatingInstructionsVO in bb.common.box

Methods in bb.common.box that return OperatingInstructionsVO
OperatingInstructionsVO | ManufacturingBox.addOperatingInstructions(OperatingInstructionsVO vo)
OperatingInstructionsVO | ManufacturingBox.getOperatingInstructions(java.lang.String operatingInstructionsNumber)

Methods in bb.common.box that return types with arguments of type OperatingInstructionsVO
java.util.Collection<OperatingInstructionsVO> | ManufacturingBox.findNotApprovedOperatingInstructions(int firstIndex, int maxLength)
java.util.Collection<OperatingInstructionsVO> | ManufacturingBox.findOpenOperatingInstructions(int firstIndex, int maxLength)
java.util.Collection<OperatingInstructionsVO> | ManufacturingBox.findOperatingInstructions(java.lang.String oiNumber, java.lang.String woAndItemNumber, java.lang.String type, java.lang.String responsibility, java.lang.String project, java.lang.String serial, java.lang.String staff, java.lang.String status, java.lang.String irNumber, int firstIndex, int maxLength)
java.util.Collection<OperatingInstructionsVO> | ManufacturingBox.findOperatingInstructionsCanClose(int firstIndex, int maxLength)
java.util.Collection<OperatingInstructionsVO> | ManufacturingBox.findOperatingInstructionsUserStatistical(java.lang.String userName, java.lang.String type, java.lang.String responsibility, int firstIndex, int maxLength)
java.util.Collection<OperatingInstructionsVO> | ManufacturingBox.findPausedOperatingInstructions(int firstIndex, int maxLength)
java.util.Collection<OperatingInstructionsVO> | ManufacturingBox.findRequestInspectionOperatingInstructions(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type OperatingInstructionsVO
OperatingInstructionsVO | ManufacturingBox.addOperatingInstructions(OperatingInstructionsVO vo)
void | ManufacturingBox.approveOperatingInstructions(OperatingInstructionsVO vo)
void | ManufacturingBox.cancelFinishOperatingInstructions(OperatingInstructionsVO vo)
void | ManufacturingBox.changeOperatingInstructionsStatusToCancel(OperatingInstructionsVO vo)
void | ManufacturingBox.closeOperatingInstructions(OperatingInstructionsVO vo)
void | ManufacturingBox.continueOperatingInstructions(OperatingInstructionsVO vo)
void | ManufacturingBox.finishOperatingInstructions(OperatingInstructionsVO vo)
void | ManufacturingBox.pauseOperatingInstructions(OperatingInstructionsVO vo)
void | ManufacturingBox.requestInspectionForOperatingInstructions(OperatingInstructionsVO vo)
void | ManufacturingBox.updateOperatingInstructions(OperatingInstructionsVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OperatingOutputFileItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OperatingOutputFileItemPK

Packages that use OperatingOutputFileItemPK
bb.common

Uses of OperatingOutputFileItemPK in bb.common

Methods in bb.common that return OperatingOutputFileItemPK
 OperatingOutputFileItemPK OperatingOutputFileItemVO.getPk()

Methods in bb.common with parameters of type OperatingOutputFileItemPK
 void OperatingOutputFileItemVO.setPk(OperatingOutputFileItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OperatingOutputFileItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OperatingOutputFileItemVO

Packages that use OperatingOutputFileItemVO
bb.common

Uses of OperatingOutputFileItemVO in bb.common

Methods in bb.common that return types with arguments of type OperatingOutputFileItemVO
 java.util.Set<OperatingOutputFileItemVO> OperatingInstructionsVO.getOperatingOutputFiles()

Method parameters in bb.common with type arguments of type OperatingOutputFileItemVO
 void OperatingInstructionsVO.setOperatingOutputFiles(java.util.Set<OperatingOutputFileItemVO> operatingOutputFiles)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OperatingOutputFileTypeVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OperatingOutputFileTypeVO

Packages that use OperatingOutputFileTypeVO
bb.common
bb.common.box

Uses of OperatingOutputFileTypeVO in bb.common

Methods in bb.common that return OperatingOutputFileTypeVO
 OperatingOutputFileTypeVO OperatingOutputFileItemVO.getOperatingOutputFileType()

Methods in bb.common with parameters of type OperatingOutputFileTypeVO
 void OperatingOutputFileItemVO.setOperatingOutputFileType(OperatingOutputFileTypeVO operatingOutputFileType)

Uses of OperatingOutputFileTypeVO in bb.common.box

Methods in bb.common.box that return OperatingOutputFileTypeVO
OperatingOutputFileTypeVO | ManufacturingBox.addOperatingOutputFileType(OperatingOutputFileTypeVO vo)
OperatingOutputFileTypeVO | ManufacturingBox.getOperatingOutputFileType(int ii)

Methods in bb.common.box that return types with arguments of type OperatingOutputFileTypeVO
 java.util.Collection<OperatingOutputFileTypeVO> ManufacturingBox.findAllOperatingOutputFileType(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type OperatingOutputFileTypeVO
OperatingOutputFileTypeVO | ManufacturingBox.addOperatingOutputFileType(OperatingOutputFileTypeVO vo)
void | ManufacturingBox.updateOperatingOutputFileType(OperatingOutputFileTypeVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OperationLogVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OperationLogVO

Packages that use OperationLogVO
bb.common.box

Uses of OperationLogVO in bb.common.box

Methods in bb.common.box that return OperationLogVO
 OperationLogVO LogBox.findLogByPk(java.lang.Long pk)

Methods in bb.common.box that return types with arguments of type OperationLogVO
java.util.Collection<OperationLogVO> | LogBox.findAllEmployeeLogs(int firstIndex, int maxLength)
java.util.Collection<OperationLogVO> | LogBox.findAllLogs(int firstIndex, int maxLength)
java.util.Collection<OperationLogVO> | LogBox.findAllNotEmployeeLogs(int firstIndex, int maxLength)
java.util.Collection<OperationLogVO> | LogBox.findLogs(java.lang.String userName, java.lang.String trueName, boolean isEmployee, java.lang.String action, java.lang.String target, java.lang.String comment, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<OperationLogVO> | LogBox.findLogsByAction(java.lang.String action, int firstIndex, int maxLength)
java.util.Collection<OperationLogVO> | LogBox.findLogsByLastName(java.lang.String lastName, int firstIndex, int maxLength)
java.util.Collection<OperationLogVO> | LogBox.findLogsByTarget(java.lang.String target, int firstIndex, int maxLength)
java.util.Collection<OperationLogVO> | LogBox.findLogsByTrueName(java.lang.String trueName, int firstIndex, int maxLength)
java.util.Collection<OperationLogVO> | LogBox.findLogsByUserName(java.lang.String userName, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OrderApprovalItemsVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OrderApprovalItemsVO

No usage of bb.common.OrderApprovalItemsVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OrderApprovalVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OrderApprovalVO

Packages that use OrderApprovalVO
bb.common
bb.common.box

Uses of OrderApprovalVO in bb.common

Methods in bb.common that return OrderApprovalVO
 OrderApprovalVO OrderApprovalItemsVO.getOrderApproval()

Methods in bb.common with parameters of type OrderApprovalVO
 void OrderApprovalItemsVO.setOrderApproval(OrderApprovalVO orderApproval)

Uses of OrderApprovalVO in bb.common.box

Methods in bb.common.box that return OrderApprovalVO
 OrderApprovalVO WorkOrderBox.getOrderApprovalByOrder(java.lang.String orderNumber)

Methods in bb.common.box that return types with arguments of type OrderApprovalVO
 java.util.Collection<OrderApprovalVO> WorkOrderBox.findOrderApprovalByVO(OrderApprovalVO vo, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type OrderApprovalVO
 java.util.Collection<OrderApprovalVO> WorkOrderBox.findOrderApprovalByVO(OrderApprovalVO vo, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OrderBoilerplatePK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OrderBoilerplatePK

Packages that use OrderBoilerplatePK
bb.common

Uses of OrderBoilerplatePK in bb.common

Methods in bb.common that return OrderBoilerplatePK
 OrderBoilerplatePK OrderBoilerplateVO.getPk()

Methods in bb.common with parameters of type OrderBoilerplatePK
 void OrderBoilerplateVO.setPk(OrderBoilerplatePK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OrderBoilerplateVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OrderBoilerplateVO

No usage of bb.common.OrderBoilerplateVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OrderBy

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OrderBy

Packages that use OrderBy
bb.common

Uses of OrderBy in bb.common

Methods in bb.common that return OrderBy
 OrderBy ServerAction.getOrderBy()

Methods in bb.common with parameters of type OrderBy
 void ServerAction.setOrderBy(OrderBy orderBy)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OrderDemandForReceiverResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OrderDemandForReceiverResult

No usage of bb.common.OrderDemandForReceiverResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OrderDocumentVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OrderDocumentVO

Packages that use OrderDocumentVO
bb.common
bb.common.box

Uses of OrderDocumentVO in bb.common

Methods in bb.common that return types with arguments of type OrderDocumentVO
 java.util.Set<OrderDocumentVO> InspectionConformanceReportVO.getIcrDocuments()

Method parameters in bb.common with type arguments of type OrderDocumentVO
 void InspectionConformanceReportVO.setIcrDocuments(java.util.Set<OrderDocumentVO> icrDocuments)

Uses of OrderDocumentVO in bb.common.box

Methods in bb.common.box that return types with arguments of type OrderDocumentVO
java.util.Collection<OrderDocumentVO> | CompanyBox.findOrderDocListByOrderNumber(java.lang.String orderNumber)
java.util.Collection<OrderDocumentVO> | CompanyBox.uploadOrUpdateFTPOrderDoc(MiscDocAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OrderPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OrderPK

Packages that use OrderPK
bb.common
bb.common.box

Uses of OrderPK in bb.common

Methods in bb.common that return OrderPK
OrderPK | MrpItemResult.getLateItemPk()
OrderPK | IssueItemAgent.getOrderPk()
static OrderPK | BB2Util.getOrderPkFromRefDoc(java.lang.String refDoc)
OrderPK | OrderVendorItem.getPk()
OrderPK | MrpItemResult.getShortItemPk()

Methods in bb.common with parameters of type OrderPK
void | MrpItemResult.setLateItemPk(OrderPK lateItemPk)
void | IssueItemAgent.setOrderPk(OrderPK orderPk)
void | OrderVendorItem.setPk(OrderPK pk)
void | MrpItemResult.setShortItemPk(OrderPK shortItemPk)

Uses of OrderPK in bb.common.box

Methods in bb.common.box with parameters of type OrderPK
 boolean PurchasingBox.checkOrderItemExist(OrderPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OrderVendorItem

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OrderVendorItem

Packages that use OrderVendorItem
bb.common

Uses of OrderVendorItem in bb.common

Methods in bb.common that return types with arguments of type OrderVendorItem
 java.util.ArrayList<OrderVendorItem> ShipListItemRelatedDocResult.getItems()

Method parameters in bb.common with type arguments of type OrderVendorItem
 void ShipListItemRelatedDocResult.setItems(java.util.ArrayList<OrderVendorItem> items)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.OutputValueByMonthResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.OutputValueByMonthResult

Packages that use OutputValueByMonthResult
bb.common.box

Uses of OutputValueByMonthResult in bb.common.box

Methods in bb.common.box that return OutputValueByMonthResult
 OutputValueByMonthResult ManagementBox.getFiscalYearOutputValue()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PackingBoxItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PackingBoxItemListResult

Packages that use PackingBoxItemListResult
bb.common.box

Uses of PackingBoxItemListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type PackingBoxItemListResult
java.util.Collection<PackingBoxItemListResult> | WarehouseBox.findPackingBoxItemListResultsByPfNumbe(java.lang.String pfNumberExp, int firstIndex, int maxLength)
java.util.Collection<PackingBoxItemListResult> | WarehouseBox.findPackingBoxItemListResultsByPfNumbeAndPBNumber(java.lang.String pfNumberExp, int packingBoxNumber, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PackingBoxItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PackingBoxItemPK

Packages that use PackingBoxItemPK
bb.common
bb.common.box

Uses of PackingBoxItemPK in bb.common

Methods in bb.common that return PackingBoxItemPK
PackingBoxItemPK | BB2PartInSipItemResult.getPackBoxItemPk()
PackingBoxItemPK | PackingBoxItemListResult.getPackingBoxItemPk()
PackingBoxItemPK | PackingBoxItemVO.getPk()

Methods in bb.common with parameters of type PackingBoxItemPK
void | BB2PartInSipItemResult.setPackBoxItemPk(PackingBoxItemPK packBoxItemPk)
void | PackingBoxItemListResult.setPackingBoxItemPk(PackingBoxItemPK packingBoxItemPk)
void | PackingBoxItemVO.setPk(PackingBoxItemPK pk)

Uses of PackingBoxItemPK in bb.common.box

Methods in bb.common.box with parameters of type PackingBoxItemPK
PackingBoxPK | WarehouseBox.removeSalesOrderItemToPackingBox(PackingBoxItemPK pk)
PackingBoxItemVO | WarehouseBox.updatePackingBoxItem(PackingBoxItemPK pk, java.util.Map newQty)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PackingBoxItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PackingBoxItemVO

Packages that use PackingBoxItemVO
bb.common
bb.common.box

Uses of PackingBoxItemVO in bb.common

Methods in bb.common that return PackingBoxItemVO
 PackingBoxItemVO ProformaReceiverPackingBoxItemAgent.getPBItem()

Methods in bb.common with parameters of type PackingBoxItemVO
 void ProformaReceiverPackingBoxItemAgent.setPBItem(PackingBoxItemVO item)

Uses of PackingBoxItemVO in bb.common.box

Methods in bb.common.box that return PackingBoxItemVO
PackingBoxItemVO | WarehouseBox.initPackingBoxItemVO(PackingBoxPK boxPk, SalesOrderItemPK itemPk, java.math.BigDecimal qty)
PackingBoxItemVO | WarehouseBox.updatePackingBoxItem(PackingBoxItemPK pk, java.util.Map newQty)

Methods in bb.common.box that return types with arguments of type PackingBoxItemVO
 java.util.Collection<PackingBoxItemVO> WarehouseBox.findPackingBoxItem(java.lang.String pfNumber, PartPK partPk, java.lang.String partFrom)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PackingBoxPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PackingBoxPK

Packages that use PackingBoxPK
bb.common
bb.common.box

Uses of PackingBoxPK in bb.common

Methods in bb.common that return PackingBoxPK
PackingBoxPK | PackingBoxSalesOrderItemAgent.getPackingBoxPk()
PackingBoxPK | PackingBoxVO.getPk()

Methods in bb.common that return types with arguments of type PackingBoxPK
java.util.LinkedHashMap<PackingBoxPK,java.util.ArrayList<ProformaReceiverPackingBoxItemAgent>> | ProformaReceiverPackingBoxAgent.getPbItems()
java.util.LinkedHashMap<PackingBoxPK,PrPackingBoxVO> | ProformaReceiverPackingBoxAgent.getPbs()

Methods in bb.common with parameters of type PackingBoxPK
void | PackingBoxSalesOrderItemAgent.setPackingBoxPk(PackingBoxPK packingBoxPk)
void | PackingBoxVO.setPk(PackingBoxPK pk)

Method parameters in bb.common with type arguments of type PackingBoxPK
void | ProformaReceiverPackingBoxAgent.setPbItems(java.util.LinkedHashMap<PackingBoxPK,java.util.ArrayList<ProformaReceiverPackingBoxItemAgent>> pbItems)
void | ProformaReceiverPackingBoxAgent.setPbs(java.util.LinkedHashMap<PackingBoxPK,PrPackingBoxVO> pbs)

Uses of PackingBoxPK in bb.common.box

Methods in bb.common.box that return PackingBoxPK
PackingBoxPK | WarehouseBox.addPackingBox(java.lang.String pfNumber)
PackingBoxPK | WarehouseBox.addSalesOrderItemToPackingBox(PackingBoxSalesOrderItemAgent agent)
PackingBoxPK | WarehouseBox.addSalesOrderToPackingBox(java.util.ArrayList list)
PackingBoxPK | WarehouseBox.removeSalesOrderItemToPackingBox(PackingBoxItemPK pk)

Methods in bb.common.box with parameters of type PackingBoxPK
void | WarehouseBox.deletePackingBox(PackingBoxPK pk)
PackingBoxVO | WarehouseBox.getPackingBoxByPk(PackingBoxPK pk)
PackingBoxItemVO | WarehouseBox.initPackingBoxItemVO(PackingBoxPK boxPk, SalesOrderItemPK itemPk, java.math.BigDecimal qty)
PackingBoxVO | WarehouseBox.updatePackingBoxItems(java.util.HashMap map, PackingBoxPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PackingBoxSalesOrderItemAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PackingBoxSalesOrderItemAgent

Packages that use PackingBoxSalesOrderItemAgent
bb.common.box

Uses of PackingBoxSalesOrderItemAgent in bb.common.box

Methods in bb.common.box with parameters of type PackingBoxSalesOrderItemAgent
 PackingBoxPK WarehouseBox.addSalesOrderItemToPackingBox(PackingBoxSalesOrderItemAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PackingBoxSalesOrderItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PackingBoxSalesOrderItemResult

Packages that use PackingBoxSalesOrderItemResult
bb.common.box

Uses of PackingBoxSalesOrderItemResult in bb.common.box

Methods in bb.common.box that return types with arguments of type PackingBoxSalesOrderItemResult
 java.util.Collection<PackingBoxSalesOrderItemResult> WarehouseBox.findPackingBoxSalesOrderItemResults(java.lang.String soNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PackingBoxVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PackingBoxVO

Packages that use PackingBoxVO
bb.common.box

Uses of PackingBoxVO in bb.common.box

Methods in bb.common.box that return PackingBoxVO
PackingBoxVO | WarehouseBox.getPackingBoxByPk(PackingBoxPK pk)
PackingBoxVO | WarehouseBox.updatePackingBox(PackingBoxVO vo)
PackingBoxVO | WarehouseBox.updatePackingBoxItems(java.util.HashMap map, PackingBoxPK pk)

Methods in bb.common.box that return types with arguments of type PackingBoxVO
java.util.Collection<PackingBoxVO> | WarehouseBox.findAllPackingBox(int firstIndex, int length)
java.util.Collection<PackingBoxVO> | WarehouseBox.findPackingBoxesByPfNumber(java.lang.String pfNumberRegex, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type PackingBoxVO
 PackingBoxVO WarehouseBox.updatePackingBox(PackingBoxVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartBasicInfo

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartBasicInfo

Packages that use PartBasicInfo
bb.common
bb.common.box

Uses of PartBasicInfo in bb.common

Subclasses of PartBasicInfo in bb.common
class | BillDetailCostWithPartInfoResult
class | BillItemDetailCostWithPartInfoResult
class | BillItemOnHandUsageResult
class | BillItemOnHandWithPartInfoResult
class | BillItemSalesCostResult
class | BillItemUsageResult
class | BillItemWithPartInfoResult
class | BillOnHandWithPartInfoResult
class | BillSalesCostResult
class | BillWithPartInfoResult
class | MasterWorkOrderTreeItemResult
class | PartBasicInfoWithNewEngGroup
class | PartBasicInfoWithNewListPrice
class | PartExportInfo
class | PartMaterialBomListResult
class | PartMaterialListResult
class | PartOnHandWithMfgInfoResult
class | PartOnHandWithPartBasicInfoResult
class | PartTraceableListResult
class | PartTraceableResult
class | PartWithOnhandDetailInfoResult
class | PartWithoutLocateResult
class | ToolBasicInfo
class | ToolListDetailCostWithToolInfoResult
class | ToolListItemDetailCostWithToolInfoResult
class | ToolListItemWithToolInfoResult
class | ToolListWithToolInfoResult

Methods in bb.common that return PartBasicInfo
PartBasicInfo | WorkOrderWorkSheetItemWithRelatedInfoResult.getPartBasicInfo()
PartBasicInfo | PurchaseWorkSheetItemWithRelatedInfoResult.getPartBasicInfo()
PartBasicInfo | PartWhereUsedResult.getPartBasicInfo()
PartBasicInfo | PartTraceableInfoResult.getPartBasicInfo()
PartBasicInfo | MrpItemResult.getPartBasicInfo()
PartBasicInfo | InventoryAdjustmentDetailResult.getPartInfo()

Methods in bb.common that return types with arguments of type PartBasicInfo
java.util.List<PartBasicInfo> | PartsToDeleteResult.getPartsToDeletedNotUsed()
java.util.Iterator<java.util.ArrayList<PartBasicInfo>> | RecursiveBillPath.getPaths()

Methods in bb.common with parameters of type PartBasicInfo
void | WorkOrderWorkSheetItemWithRelatedInfoResult.setPartBasicInfo(PartBasicInfo partBasicInfo)
void | PurchaseWorkSheetItemWithRelatedInfoResult.setPartBasicInfo(PartBasicInfo partBasicInfo)
void | PartWhereUsedResult.setPartBasicInfo(PartBasicInfo partBasicInfo)
void | PartTraceableInfoResult.setPartBasicInfo(PartBasicInfo partBasicInfo)
void | MrpItemResult.setPartBasicInfo(PartBasicInfo partBasicInfo)
void | InventoryAdjustmentDetailResult.setPartInfo(PartBasicInfo partInfo)

Method parameters in bb.common with type arguments of type PartBasicInfo
void | RecursiveBillPath.addPath(java.util.ArrayList<PartBasicInfo> path)
void | RecursiveBillPath.addPath(java.util.HashSet<java.util.ArrayList<PartBasicInfo>> paths)
void | PartsToDeleteResult.setPartsToDeletedNotUsed(java.util.List<PartBasicInfo> partsToDeletedNotUsed)

Uses of PartBasicInfo in bb.common.box

Methods in bb.common.box that return PartBasicInfo
PartBasicInfo | EngineeringBox.getPartBasicInfo(PartPK pk)
PartBasicInfo | EngineeringBox.getPartBasicInfo(PartPK pk, java.lang.String languageCode)

Methods in bb.common.box that return types with arguments of type PartBasicInfo
java.util.Collection<PartBasicInfo> | EngineeringBox.findAllParts(int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | SalesBox.findAvailablePartsForCGCustomer(java.lang.String customerID, java.lang.String partFrom, java.lang.String partTo, java.lang.String commodityCode, java.lang.String descLike, java.lang.String productCode, boolean ignoreCatalog, int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | SalesBox.findAvailablePartsToSalesCatalog(java.lang.String pnRegex, java.lang.String pn2Regex, java.lang.String commodityCodeLike, java.lang.String descLike, java.lang.String productCode, int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | EngineeringBox.findEngSharingPartsByPnAndEngGroup(java.lang.String partFrom, java.lang.String partTo, java.lang.String partType, java.lang.String engGroup, int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | EngineeringBox.findPartBasicInfoToRollUP(java.lang.String bill, int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | EngineeringBox.findPartBasicInfoToRollUP(java.lang.String bill, java.lang.String bnType, int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | EngineeringBox.findPartsByDescriptionAndLang(java.lang.String[] descLike, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | EngineeringBox.findPartsByDescriptionInside(java.lang.String pnRegex, java.lang.String partType, java.lang.String edRegex, java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | EngineeringBox.findPartsByDescriptionStart(java.lang.String edRegex, int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | EngineeringBox.findPartsByEngineeringSharingRule(java.lang.String companyId, int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | EngineeringBox.findPartsByPartAndDesc(java.lang.String fPn, java.lang.String tPn, java.lang.String pType, java.lang.String descriptionRegex, java.lang.String modelNumberLike, java.lang.String commodityCode, java.lang.String productCode, java.lang.String language, java.lang.String engGroup, java.lang.String securityLevel, java.lang.String makebuy, int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | EngineeringBox.findPartsByPartLike(java.lang.String pnRegex, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | EngineeringBox.findPartsOnHold(int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | EngineeringBox.findPartsWithBom(int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | EngineeringBox.findPartsWithDeleted(int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | EngineeringBox.findPartsWithDrawing(int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | EngineeringBox.findPartsWithWi(int firstIndex, int maxLength)
java.util.Collection<PartBasicInfo> | SalesBox.getSpareSaleableParts(java.lang.String pnLike, java.lang.String description)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartBasicInfoWithNewEngGroup

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartBasicInfoWithNewEngGroup

Packages that use PartBasicInfoWithNewEngGroup
bb.common.box

Uses of PartBasicInfoWithNewEngGroup in bb.common.box

Methods in bb.common.box that return types with arguments of type PartBasicInfoWithNewEngGroup
 java.util.Collection<PartBasicInfoWithNewEngGroup> EngineeringBox.findPartsByPartEngGroup(java.lang.String partNumber, java.lang.String partType, java.lang.String engGroup, java.lang.String newEngGroup, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartBasicInfoWithNewListPrice

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartBasicInfoWithNewListPrice

Packages that use PartBasicInfoWithNewListPrice
bb.common.box

Uses of PartBasicInfoWithNewListPrice in bb.common.box

Methods in bb.common.box that return types with arguments of type PartBasicInfoWithNewListPrice
 java.util.Collection<PartBasicInfoWithNewListPrice> EngineeringBox.findPartsByPartCommodityCode(java.math.BigDecimal listPricePercent, java.lang.String commodityCodeLike, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartCatagoryPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartCatagoryPK

Packages that use PartCatagoryPK
bb.common
bb.common.box

Uses of PartCatagoryPK in bb.common

Methods in bb.common that return PartCatagoryPK
 PartCatagoryPK PartCatagoryVO.getPk()

Methods in bb.common with parameters of type PartCatagoryPK
 void PartCatagoryVO.setPk(PartCatagoryPK pk)

Constructors in bb.common with parameters of type PartCatagoryPK
PartCatagoryVO(PartCatagoryPK pk, java.lang.String name)

Uses of PartCatagoryPK in bb.common.box

Methods in bb.common.box with parameters of type PartCatagoryPK
void | EngineeringBox.deletePartCatagory(PartCatagoryPK pk)
PartCatagoryVO | EngineeringBox.getPartCatagoryByPk(PartCatagoryPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartCatagoryVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartCatagoryVO

Packages that use PartCatagoryVO
bb.common.box

Uses of PartCatagoryVO in bb.common.box

Methods in bb.common.box that return PartCatagoryVO
PartCatagoryVO | EngineeringBox.addPartCatagory(PartCatagoryVO vo)
PartCatagoryVO | EngineeringBox.getPartCatagoryByPk(PartCatagoryPK pk)

Methods in bb.common.box that return types with arguments of type PartCatagoryVO
 java.util.Collection<PartCatagoryVO> EngineeringBox.findAllPartCatagorys()

Methods in bb.common.box with parameters of type PartCatagoryVO
PartCatagoryVO | EngineeringBox.addPartCatagory(PartCatagoryVO vo)
void | EngineeringBox.updatePartCatagory(PartCatagoryVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartCatalogAuditResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartCatalogAuditResult

Packages that use PartCatalogAuditResult
bb.common.box

Uses of PartCatalogAuditResult in bb.common.box

Methods in bb.common.box that return types with arguments of type PartCatalogAuditResult
 java.util.Collection<PartCatalogAuditResult> SalesBox.getPartCatalogAuditResults(java.lang.String pnLike)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartCatalogPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartCatalogPK

Packages that use PartCatalogPK
bb.common
bb.common.box

Uses of PartCatalogPK in bb.common

Methods in bb.common that return PartCatalogPK
PartCatalogPK | SGPartCatalogResult.getPartCatalogPK()
PartCatalogPK | PartCatalogVO.getPk()

Methods in bb.common with parameters of type PartCatalogPK
 void PartCatalogVO.setPk(PartCatalogPK pk)

Constructors in bb.common with parameters of type PartCatalogPK
PartCatalogVO(PartCatalogPK pk, java.lang.String name, java.lang.String catalog, java.lang.String comments)
full constructor

Uses of PartCatalogPK in bb.common.box

Methods in bb.common.box with parameters of type PartCatalogPK
void | SalesBox.addSGCustomerCatalog(java.lang.String cusID, PartCatalogPK pk)
void | SalesBox.deletePartCatalog(PartCatalogPK pk)

Method parameters in bb.common.box with type arguments of type PartCatalogPK
void | SalesBox.addPartCatalog(java.lang.String catalogID, java.util.HashSet<PartCatalogPK> items)
void | SalesBox.addSGCustomerCatalog(java.lang.String cusID, java.util.ArrayList<PartCatalogPK> pks, boolean checkCatalog)
void | SalesBox.deletePartCatalog(java.util.ArrayList<PartCatalogPK> pks)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartCatalogVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartCatalogVO

Packages that use PartCatalogVO
bb.common
bb.common.box

Uses of PartCatalogVO in bb.common

Methods in bb.common that return PartCatalogVO
 PartCatalogVO SGPartCatalogResult.getPartCatalogVO()

Uses of PartCatalogVO in bb.common.box

Methods in bb.common.box that return types with arguments of type PartCatalogVO
 java.util.Collection<PartCatalogVO> SalesBox.getPartCatalogs(java.lang.String catalogID)

Methods in bb.common.box with parameters of type PartCatalogVO
 void SalesBox.updatePartCatalog(PartCatalogVO vo)

Method parameters in bb.common.box with type arguments of type PartCatalogVO
 void SalesBox.updatePartCatalog(java.util.ArrayList<PartCatalogVO> volist)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartCertificateListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartCertificateListResult

Packages that use PartCertificateListResult
bb.common.box

Uses of PartCertificateListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type PartCertificateListResult
java.util.Collection<PartCertificateListResult> | QualityBox.findAllPartCertificates(int firstIndex, int maxLength)
java.util.Collection<PartCertificateListResult> | QualityBox.findPartCertificatesByCertificateDesc(java.lang.String cn, int firstIndex, int maxLength)
java.util.Collection<PartCertificateListResult> | QualityBox.findPartCertificatesByCn(java.lang.String cn, int firstIndex, int maxLength)
java.util.Collection<PartCertificateListResult> | QualityBox.findPartCertificatesByPn(java.lang.String partNumberRegex, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<PartCertificateListResult> | QualityBox.findPartCertificatesByPo(java.lang.String po, int firstIndex, int maxLength)
java.util.Collection<PartCertificateListResult> | QualityBox.findPartCertificatesByRef(java.lang.String ref, int firstIndex, int maxLength)
java.util.Collection<PartCertificateListResult> | QualityBox.findPartCertificatesByRn(java.lang.String rn, int firstIndex, int maxLength)
java.util.Collection<PartCertificateListResult> | QualityBox.findPartCertificatesByWo(java.lang.String wo, int firstIndex, int maxLength)
java.util.Collection<PartCertificateListResult> | QualityBox.findSerialNumbersBySerialNumber(java.lang.String serialNumberLike, java.lang.String partNumber, java.lang.String partType, java.lang.String workerOrderNumber, java.lang.String purchaseOrderNumber, java.lang.String salesOrderNumber, java.lang.String referenceNumber, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartCertificateVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartCertificateVO

Packages that use PartCertificateVO
bb.common.box

Uses of PartCertificateVO in bb.common.box

Methods in bb.common.box that return PartCertificateVO
PartCertificateVO | QualityBox.findPartCertificateByPk(int pk)
PartCertificateVO | QualityBox.getPartCertificateByCertificateNumber(java.lang.String cnNumber)
PartCertificateVO | QualityBox.uploadPartCertificate(MiscDocAgent agent)

Methods in bb.common.box that return types with arguments of type PartCertificateVO
java.util.Collection<PartCertificateVO> | QualityBox.findPartCertificateByCertificateNumber(java.lang.String partCertificateNumber, java.lang.String comments, java.lang.String partCertificateDesc, int firstIndex, int maxLength)
java.util.Collection<PartCertificateVO> | QualityBox.findSerialNumberByPn(java.lang.String partNumberRegex, java.lang.String partType, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type PartCertificateVO
SerialNumberPK | QualityBox.addSerialNumber(PartCertificateVO partCertificateVo)
SerialNumberPK | QualityBox.addSerialNumber(PartCertificateVO partCertificateVo, java.lang.String originalCertificateNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartClassInfoResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartClassInfoResult

Packages that use PartClassInfoResult
bb.common.box

Uses of PartClassInfoResult in bb.common.box

Methods in bb.common.box that return types with arguments of type PartClassInfoResult
java.util.Collection<PartClassInfoResult> | WarehouseBox.findPartClassInfoResult(java.lang.String pnLike, java.lang.String partType, java.lang.String partClass, int firstIndex, int maxLength)
java.util.Collection<PartClassInfoResult> | WarehouseBox.findPartWithoutClassInfoResult(java.lang.String pnLike, java.lang.String description, java.lang.String partType, java.lang.String commodity, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartClassVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartClassVO

Packages that use PartClassVO
bb.common.box

Uses of PartClassVO in bb.common.box

Methods in bb.common.box that return PartClassVO
PartClassVO | WarehouseBox.addPartClass(PartClassVO vo)
PartClassVO | WarehouseBox.getPartClassByID(java.lang.String id)
PartClassVO | WarehouseBox.updatePartClass(PartClassVO vo, boolean autoCount)

Methods in bb.common.box that return types with arguments of type PartClassVO
 java.util.Collection<PartClassVO> WarehouseBox.findPartClasses(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type PartClassVO
PartClassVO | WarehouseBox.addPartClass(PartClassVO vo)
PartClassVO | WarehouseBox.updatePartClass(PartClassVO vo, boolean autoCount)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartCostVarianceListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartCostVarianceListResult

Packages that use PartCostVarianceListResult
bb.common.box

Uses of PartCostVarianceListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type PartCostVarianceListResult
 java.util.Collection<PartCostVarianceListResult> WarehouseBox.findInventoryCostVarianceCount(java.lang.String partNumber, java.lang.String partType, java.lang.String makeBuy, java.math.BigDecimal variancePercent, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartDescriptionPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartDescriptionPK

Packages that use PartDescriptionPK
bb.common

Uses of PartDescriptionPK in bb.common

Methods in bb.common that return PartDescriptionPK
PartDescriptionPK | ToolDescriptionVO.getPk()
PartDescriptionPK | PartDescriptionVO.getPk()

Methods in bb.common with parameters of type PartDescriptionPK
void | ToolDescriptionVO.setPk(PartDescriptionPK pk)
void | PartDescriptionVO.setPk(PartDescriptionPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartDescriptionVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartDescriptionVO

No usage of bb.common.PartDescriptionVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartDiscountPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartDiscountPK

Packages that use PartDiscountPK
bb.common
bb.common.box

Uses of PartDiscountPK in bb.common

Methods in bb.common that return PartDiscountPK
 PartDiscountPK PartDiscountVO.getPk()

Methods in bb.common with parameters of type PartDiscountPK
 void PartDiscountVO.setPk(PartDiscountPK pk)

Uses of PartDiscountPK in bb.common.box

Methods in bb.common.box with parameters of type PartDiscountPK
 PartDiscountVO SalesBox.getPartDiscountVOByPk(PartDiscountPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartDiscountVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartDiscountVO

Packages that use PartDiscountVO
bb.common.box

Uses of PartDiscountVO in bb.common.box

Methods in bb.common.box that return PartDiscountVO
PartDiscountVO | SalesBox.addPartDiscount(PartDiscountVO vo)
PartDiscountVO | SalesBox.getPartDiscountVOByPk(PartDiscountPK pk)

Methods in bb.common.box that return types with arguments of type PartDiscountVO
 java.util.Collection<PartDiscountVO> SalesBox.findAllPartDiscount(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type PartDiscountVO
PartDiscountVO | SalesBox.addPartDiscount(PartDiscountVO vo)
void | SalesBox.deletePartDiscount(PartDiscountVO vo)
void | SalesBox.updatePartDiscount(PartDiscountVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartDocumentPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartDocumentPK

Packages that use PartDocumentPK
bb.common
bb.common.box

Uses of PartDocumentPK in bb.common

Methods in bb.common that return PartDocumentPK
 PartDocumentPK PartDocumentVO.getPk()

Methods in bb.common with parameters of type PartDocumentPK
 void PartDocumentVO.setPk(PartDocumentPK pk)

Uses of PartDocumentPK in bb.common.box

Methods in bb.common.box with parameters of type PartDocumentPK
 PartDocumentVO DocumentBox.getPartDocumentByPk(PartDocumentPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartDocumentVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartDocumentVO

Packages that use PartDocumentVO
bb.common.box

Uses of PartDocumentVO in bb.common.box

Methods in bb.common.box that return PartDocumentVO
 PartDocumentVO DocumentBox.getPartDocumentByPk(PartDocumentPK pk)

Methods in bb.common.box that return types with arguments of type PartDocumentVO
java.util.Collection<PartDocumentVO> | DocumentBox.findAllDocument(int firstIndex, int maxLength)
java.util.Collection<PartDocumentVO> | DocumentBox.findAllDocumentByDocumentType(java.lang.String documentType, int firstIndex, int maxLength)
java.util.Collection<PartDocumentVO> | DocumentBox.findPartDocumentByPartNumber(java.lang.String partNumber, int firstIndex, int maxLength)
java.util.Collection<PartDocumentVO> | DocumentBox.findPartDocumentByPartNumber(java.lang.String partNumber, java.lang.String documentType, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartDueAddressListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartDueAddressListResult

Packages that use PartDueAddressListResult
bb.common.box

Uses of PartDueAddressListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type PartDueAddressListResult
 java.util.Collection<PartDueAddressListResult> PurchasingBox.findPoDueVendors()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartDwfAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartDwfAgent

Packages that use PartDwfAgent
bb.common.box

Uses of PartDwfAgent in bb.common.box

Methods in bb.common.box that return types with arguments of type PartDwfAgent
java.util.Collection<PartDwfAgent> | PurchasingBox.getPurchaseOrderItemDwf(java.lang.String purchaseOrderNumber)
java.util.Collection<PartDwfAgent> | PurchasingBox.getRfqOrderItemDwf(java.lang.String rfqNumber)

Methods in bb.common.box with parameters of type PartDwfAgent
void | EngineeringBox.deleteFtpDWF(PartDwfAgent agent)
byte[] | EngineeringBox.downloadFtpDWF(PartDwfAgent agent)
byte[] | EngineeringBox.downloadFtpDWFForView(PartDwfAgent agent)
void | EngineeringBox.uploadFtpDWF(PartDwfAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartDwfPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartDwfPK

Packages that use PartDwfPK
bb.common
bb.common.box

Uses of PartDwfPK in bb.common

Methods in bb.common that return PartDwfPK
PartDwfPK | PartDwfAgent.getPartDwfPk()
PartDwfPK | PartDwfVO.getPk()

Methods in bb.common with parameters of type PartDwfPK
 void PartDwfVO.setPk(PartDwfPK pk)

Uses of PartDwfPK in bb.common.box

Methods in bb.common.box with parameters of type PartDwfPK
PartDwfWithPartInfoResult | EngineeringBox.getPartDwfWithPartInfoResult(PartDwfPK pk)
boolean | EngineeringBox.isPartDwfExist(PartDwfPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartDwfVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartDwfVO

No usage of bb.common.PartDwfVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartDwfWithPartInfoResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartDwfWithPartInfoResult

Packages that use PartDwfWithPartInfoResult
bb.common.box

Uses of PartDwfWithPartInfoResult in bb.common.box

Methods in bb.common.box that return PartDwfWithPartInfoResult
 PartDwfWithPartInfoResult EngineeringBox.getPartDwfWithPartInfoResult(PartDwfPK pk)

Methods in bb.common.box that return types with arguments of type PartDwfWithPartInfoResult
java.util.Collection<PartDwfWithPartInfoResult> | EngineeringBox.findDwfDrawingByPartPk(PartPK pk, java.lang.String partFrom, int firstIndex, int maxLength)
java.util.Collection<PartDwfWithPartInfoResult> | EngineeringBox.findMismatchedPartDrawingWithPartInfoResults(java.lang.String partFrom, int firstIndex, int maxLength)
java.util.Collection<PartDwfWithPartInfoResult> | EngineeringBox.findPartDwf(java.lang.String pnLike, java.lang.String partType, java.lang.String partFrom, java.lang.String description, boolean onlyShowMissmatchedDWF, int firstIndex, int maxLength)
java.util.Collection<PartDwfWithPartInfoResult> | EngineeringBox.findPartDwfFullMatch(java.lang.String pnLike, java.lang.String partType, java.lang.String partFrom, java.lang.String description, boolean onlyShowMissmatchedDWF, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartDwgAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartDwgAgent

Packages that use PartDwgAgent
bb.common.box

Uses of PartDwgAgent in bb.common.box

Methods in bb.common.box with parameters of type PartDwgAgent
 void EngineeringBox.deleteFtpDWG(PartDwgAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartDwgPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartDwgPK

Packages that use PartDwgPK
bb.common
bb.common.box

Uses of PartDwgPK in bb.common

Methods in bb.common that return PartDwgPK
PartDwgPK | PartDwgAgent.getPartDwgPk()
PartDwgPK | PartDwgVO.getPk()

Methods in bb.common with parameters of type PartDwgPK
 void PartDwgVO.setPk(PartDwgPK pk)

Constructors in bb.common with parameters of type PartDwgPK
PartDwgVO(PartDwgPK pk, java.lang.String lastChangeUser, java.util.Date lastChangeDate, long dwgLength, java.lang.String dwgExtension)
full constructor
PartDwgVO(PartDwgPK pk, java.lang.String lastChangeUser, long dwgLength, java.lang.String dwgExtension)
minimal constructor

Uses of PartDwgPK in bb.common.box

Methods in bb.common.box with parameters of type PartDwgPK
PartDwgWithPartInfoResult | EngineeringBox.getPartDwgWithPartInfoResult(PartDwgPK pk)
boolean | EngineeringBox.isPartDwgExist(PartDwgPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartDwgVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartDwgVO

No usage of bb.common.PartDwgVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartDwgWithPartInfoResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartDwgWithPartInfoResult

Packages that use PartDwgWithPartInfoResult
bb.common.box

Uses of PartDwgWithPartInfoResult in bb.common.box

Methods in bb.common.box that return PartDwgWithPartInfoResult
 PartDwgWithPartInfoResult EngineeringBox.getPartDwgWithPartInfoResult(PartDwgPK pk)

Methods in bb.common.box that return types with arguments of type PartDwgWithPartInfoResult
 java.util.Collection<PartDwgWithPartInfoResult> EngineeringBox.findPartDwg(java.lang.String pnLike, java.lang.String partType, java.lang.String partFrom, java.lang.String description, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartExportInfo

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartExportInfo

No usage of bb.common.PartExportInfo

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartInMrpListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartInMrpListResult

Packages that use PartInMrpListResult
bb.common.box

Uses of PartInMrpListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type PartInMrpListResult
 java.util.Collection<PartInMrpListResult> PurchasingBox.findPartInMrpListResult(java.util.List<PartPK> partPks)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartInQAAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartInQAAgent

No usage of bb.common.PartInQAAgent

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartInQAResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartInQAResult

Packages that use PartInQAResult
bb.common.box

Uses of PartInQAResult in bb.common.box

Methods in bb.common.box that return PartInQAResult
 PartInQAResult WarehouseBox.getPartsInQAsWithoutNCR(BB2Part part)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartInQAVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartInQAVO

Packages that use PartInQAVO
bb.common
bb.common.box

Uses of PartInQAVO in bb.common

Methods in bb.common that return types with arguments of type PartInQAVO
 java.util.List<PartInQAVO> BB2PartTotalInQADetailResult.getDetails()

Method parameters in bb.common with type arguments of type PartInQAVO
 void BB2PartTotalInQADetailResult.setDetails(java.util.List<PartInQAVO> details)

Uses of PartInQAVO in bb.common.box

Methods in bb.common.box that return types with arguments of type PartInQAVO
java.util.Collection<PartInQAVO> | QualityBox.findAllPartInQAsToMakeNCR(java.lang.String partNumber, int firstIndex, int maxLength)
java.util.Collection<PartInQAVO> | WarehouseBox.findAllPartInQAsWithoutNCR(BB2Part part, int firstIndex, int maxLength)
java.util.Collection<PartInQAVO> | WarehouseBox.getAllPartInQAsfor(BB2Part part, java.lang.String ncrNumber)
java.util.Collection<PartInQAVO> | WarehouseBox.getAllPartInQAsWithoutNCR(BB2Part part)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartInspectionPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartInspectionPK

Packages that use PartInspectionPK
bb.common
bb.common.box

Uses of PartInspectionPK in bb.common

Methods in bb.common that return PartInspectionPK
 PartInspectionPK PartInspectionVO.getPk()

Methods in bb.common with parameters of type PartInspectionPK
 void PartInspectionVO.setPk(PartInspectionPK pk)

Uses of PartInspectionPK in bb.common.box

Methods in bb.common.box with parameters of type PartInspectionPK
void | QualityBox.deletePartInspection(PartInspectionPK pk)
PartInspectionVO | QualityBox.getPartInspection(PartInspectionPK pk)
boolean | QualityBox.isPartInspectionExist(PartInspectionPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartInspectionResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartInspectionResult

Packages that use PartInspectionResult
bb.common.box

Uses of PartInspectionResult in bb.common.box

Methods in bb.common.box that return PartInspectionResult
 PartInspectionResult QualityBox.getPartInspection(PartInspectionResult result)

Methods in bb.common.box that return types with arguments of type PartInspectionResult
java.util.Collection<PartInspectionResult> | QualityBox.findPartWithInspection(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, int firstIndex, int maxLength)
java.util.Collection<PartInspectionResult> | QualityBox.findPartWithInspectionType(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String inspectionType, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type PartInspectionResult
PartInspectionResult | QualityBox.getPartInspection(PartInspectionResult result)
void | QualityBox.updatePartInspection(PartInspectionResult result)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartInspectionVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartInspectionVO

Packages that use PartInspectionVO
bb.common.box

Uses of PartInspectionVO in bb.common.box

Methods in bb.common.box that return PartInspectionVO
PartInspectionVO | QualityBox.addPartInspection(PartInspectionVO vo)
PartInspectionVO | QualityBox.getPartInspection(PartInspectionPK pk)

Methods in bb.common.box that return types with arguments of type PartInspectionVO
 java.util.Collection<PartInspectionVO> QualityBox.findPartInspectionByPartPk(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type PartInspectionVO
 PartInspectionVO QualityBox.addPartInspection(PartInspectionVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartInventoryVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartInventoryVO

Packages that use PartInventoryVO
bb.common
bb.common.box

Uses of PartInventoryVO in bb.common

Methods in bb.common that return PartInventoryVO
PartInventoryVO | PartWithOnhandsVO.getPartInventory()
PartInventoryVO | PartVO.getPartInventory()
PartInventoryVO | MrpItemResult.getPartInventory()
PartInventoryVO | InventoryAdjustmentDetailResult.getPartInventoryInfo()
PartInventoryVO | WorkOrderWorkSheetItemWithRelatedInfoResult.getPartInventoryVO()
PartInventoryVO | PurchaseWorkSheetItemWithRelatedInfoResult.getPartInventoryVO()

Methods in bb.common with parameters of type PartInventoryVO
void | PartWithOnhandsVO.setPartInventory(PartInventoryVO partInventory)
void | PartVO.setPartInventory(PartInventoryVO partInventory)
void | MrpItemResult.setPartInventory(PartInventoryVO partInventory)
void | InventoryAdjustmentDetailResult.setPartInventoryInfo(PartInventoryVO partInventoryInfo)
void | WorkOrderWorkSheetItemWithRelatedInfoResult.setPartInventoryVO(PartInventoryVO partInventoryVO)
void | PurchaseWorkSheetItemWithRelatedInfoResult.setPartInventoryVO(PartInventoryVO partInventoryVO)

Uses of PartInventoryVO in bb.common.box

Methods in bb.common.box that return PartInventoryVO
PartInventoryVO | EngineeringBox.getPartInventoryByPk(PartPK partPk)
PartInventoryVO | EngineeringBox.updatePartInventory(PartInventoryVO vo)

Methods in bb.common.box with parameters of type PartInventoryVO
 PartInventoryVO EngineeringBox.updatePartInventory(PartInventoryVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartInWipForIDListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartInWipForIDListResult

Packages that use PartInWipForIDListResult
bb.common.box

Uses of PartInWipForIDListResult in bb.common.box

Methods in bb.common.box that return PartInWipForIDListResult
 PartInWipForIDListResult WarehouseBox.getPartInWipForIDListResultsTotalByVendorID(java.lang.String woLike, java.lang.String pnLike, java.lang.String partType, java.lang.String vendorIdLike)

Methods in bb.common.box that return types with arguments of type PartInWipForIDListResult
 java.util.Collection<PartInWipForIDListResult> WarehouseBox.findPartInWipForIDListResultsByVendorID(java.lang.String woLike, java.lang.String pnLike, java.lang.String partType, java.lang.String vendorIdLike, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartIssuedListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartIssuedListResult

Packages that use PartIssuedListResult
bb.common.box

Uses of PartIssuedListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type PartIssuedListResult
java.util.Collection<PartIssuedListResult> | WarehouseBox.findA2PartIssuedByDate(java.util.Date from, java.util.Date to, java.lang.String id, java.lang.String woNumber, java.lang.String woItemNumber, java.lang.String relatedDoc, java.lang.String picker, java.lang.String pnLike, java.lang.String paLike, java.lang.String orderNumber, java.lang.String project, boolean showCurrentOnhand, java.lang.String[] branchWarehouses, int firstIndex, int maxLength)
java.util.Collection<PartIssuedListResult> | WarehouseBox.findPartIssuedByDate(java.util.Date from, java.util.Date to, java.lang.String id, java.lang.String woNumber, java.lang.String woItemNumber, java.lang.String relatedDoc, java.lang.String picker, java.lang.String pnLike, java.lang.String paLike, java.lang.String orderNumber, java.lang.String project, boolean showCurrentOnhand, java.lang.String[] branchWarehouses, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartIssuedVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartIssuedVO

Packages that use PartIssuedVO
bb.common
bb.common.box

Uses of PartIssuedVO in bb.common

Subclasses of PartIssuedVO in bb.common
 class PartIssuedListResult

Uses of PartIssuedVO in bb.common.box

Methods in bb.common.box that return types with arguments of type PartIssuedVO
 java.util.Collection<PartIssuedVO> WorkOrderBox.findWorkOrderIssuedDetail(WorkOrderItemPK pk, BB2Part part, java.lang.String description, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartIssueTotalResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartIssueTotalResult

Packages that use PartIssueTotalResult
bb.common.box

Uses of PartIssueTotalResult in bb.common.box

Methods in bb.common.box that return PartIssueTotalResult
PartIssueTotalResult | WarehouseBox.getNonproductivePickingIssueTotalResult(java.util.Date from, java.util.Date to, java.lang.String id, java.lang.String npNumber, java.lang.String npItemNumber, java.lang.String pnLike, java.lang.String paLike, java.lang.String orderNumber, java.lang.String[] branchWarehouses, java.lang.String project)
PartIssueTotalResult | WarehouseBox.getPartIssueTotalResult(java.util.Date from, java.util.Date to, java.lang.String id, java.lang.String woNumber, java.lang.String woItemNumber, java.lang.String relatedDoc, java.lang.String picker, java.lang.String pnLike, java.lang.String paLike, java.lang.String orderNumber, java.lang.String project, java.lang.String[] branchWarehouses)
PartIssueTotalResult | WorkOrderBox.getWorkOrderIssuedDetailTotal(WorkOrderItemPK pk, BB2Part part, java.lang.String description)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartManufacturerAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartManufacturerAgent

No usage of bb.common.PartManufacturerAgent

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartManufacturerPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartManufacturerPK

Packages that use PartManufacturerPK
bb.common

Uses of PartManufacturerPK in bb.common

Methods in bb.common that return PartManufacturerPK
PartManufacturerPK | ToolManufacturerVO.getPk()
PartManufacturerPK | PartManufacturerVO.getPk()

Methods in bb.common with parameters of type PartManufacturerPK
void | ToolManufacturerVO.setPk(PartManufacturerPK pk)
void | PartManufacturerVO.setPk(PartManufacturerPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartManufacturerVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartManufacturerVO

Packages that use PartManufacturerVO
bb.common
bb.common.box

Uses of PartManufacturerVO in bb.common

Methods in bb.common that return types with arguments of type PartManufacturerVO
java.util.List<PartManufacturerVO> | BillWithPartInfoResult.getPartManufacturer()
java.util.List<PartManufacturerVO> | BillItemWithPartInfoResult.getPartManufacturer()
java.util.List<PartManufacturerVO> | BillItemSalesCostResult.getPartManufacturer()
java.util.Set<PartManufacturerVO> | ReceivingItemResult.getPartManufacturers()
java.util.Set<PartManufacturerVO> | DisassembleWorkOrderIssuingItemResult.getPartManufacturers()

Method parameters in bb.common with type arguments of type PartManufacturerVO
void | BillWithPartInfoResult.setPartManufacturer(java.util.List<PartManufacturerVO> partManufacturer)
void | BillItemWithPartInfoResult.setPartManufacturer(java.util.List<PartManufacturerVO> partManufacturer)
void | BillItemSalesCostResult.setPartManufacturer(java.util.List<PartManufacturerVO> partManufacturer)
void | ReceivingItemResult.setPartManufacturers(java.util.Set<PartManufacturerVO> partManufacturers)
void | DisassembleWorkOrderIssuingItemResult.setPartManufacturers(java.util.Set<PartManufacturerVO> partManufacturers)

Uses of PartManufacturerVO in bb.common.box

Methods in bb.common.box that return PartManufacturerVO
 PartManufacturerVO EngineeringBox.InitPartManufacturerVoByAddressId(PartPK partPk, java.lang.String manufacturerId)

Methods in bb.common.box that return types with arguments of type PartManufacturerVO
java.util.Collection<PartManufacturerVO> | EngineeringBox.findPartManufacturersByPartPk(PartPK partPk)
java.util.Collection<PartManufacturerVO> | EngineeringBox.updatePartManufacturer(java.util.HashSet partManufacturerSet, PartPK partPk)

Method parameters in bb.common.box with type arguments of type PartManufacturerVO
 void CompanyBox.importTempMPN(java.util.ArrayList<PartManufacturerVO> mpns)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartMaterialBomListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartMaterialBomListResult

Packages that use PartMaterialBomListResult
bb.common.box

Uses of PartMaterialBomListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type PartMaterialBomListResult
 java.util.Collection<PartMaterialBomListResult> EngineeringBox.findPartMaterialBomListResults(java.lang.String billNumber, java.lang.String billType, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartMaterialListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartMaterialListResult

Packages that use PartMaterialListResult
bb.common
bb.common.box

Uses of PartMaterialListResult in bb.common

Subclasses of PartMaterialListResult in bb.common
 class PartMaterialBomListResult

Uses of PartMaterialListResult in bb.common.box

Methods in bb.common.box that return PartMaterialListResult
 PartMaterialListResult EngineeringBox.getPartMaterialInfo(PartPK pk)

Methods in bb.common.box that return types with arguments of type PartMaterialListResult
java.util.Collection<PartMaterialListResult> | EngineeringBox.findPartMaterial(PartMaterialReportAgent agent, int firstIndex, int maxLength)
java.util.Collection<PartMaterialListResult> | EngineeringBox.findPartMaterialByPartLike(PartPK partPk, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartMaterialReportAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartMaterialReportAgent

Packages that use PartMaterialReportAgent
bb.common.box

Uses of PartMaterialReportAgent in bb.common.box

Methods in bb.common.box with parameters of type PartMaterialReportAgent
java.util.Collection<PartMaterialListResult> | EngineeringBox.findPartMaterial(PartMaterialReportAgent agent, int firstIndex, int maxLength)
int | EngineeringBox.getPartMaterialCount(PartMaterialReportAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartMaterialVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartMaterialVO

Packages that use PartMaterialVO
bb.common.box

Uses of PartMaterialVO in bb.common.box

Methods in bb.common.box that return PartMaterialVO
PartMaterialVO | EngineeringBox.addPartMaterial(PartPK partPk)
PartMaterialVO | EngineeringBox.copyPartMaterial(PartPK partPk, PartMaterialVO vo)
PartMaterialVO | EngineeringBox.getPartMaterialByPk(PartPK partPk)
PartMaterialVO | EngineeringBox.updatePartMaterial(PartMaterialVO partMaterialVo)

Methods in bb.common.box with parameters of type PartMaterialVO
PartMaterialVO | EngineeringBox.copyPartMaterial(PartPK partPk, PartMaterialVO vo)
PartMaterialVO | EngineeringBox.updatePartMaterial(PartMaterialVO partMaterialVo)

Method parameters in bb.common.box with type arguments of type PartMaterialVO
 void CompanyBox.importTempMaterial(java.util.ArrayList<PartMaterialVO> materials)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartMaterialWhereUsedItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartMaterialWhereUsedItemResult

No usage of bb.common.PartMaterialWhereUsedItemResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartMaterialWhereUsedResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartMaterialWhereUsedResult

Packages that use PartMaterialWhereUsedResult
bb.common.box

Uses of PartMaterialWhereUsedResult in bb.common.box

Methods in bb.common.box that return PartMaterialWhereUsedResult
 PartMaterialWhereUsedResult EngineeringBox.getPartMaterialWhereUsedResult(PartPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartMRPVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartMRPVO

No usage of bb.common.PartMRPVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartNumberGenerateRuleVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartNumberGenerateRuleVO

No usage of bb.common.PartNumberGenerateRuleVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartOnhandAndCostResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartOnhandAndCostResult

Packages that use PartOnhandAndCostResult
bb.common

Uses of PartOnhandAndCostResult in bb.common

Methods in bb.common that return types with arguments of type PartOnhandAndCostResult
 java.util.Map<java.lang.String,PartOnhandAndCostResult> PartOnhandResult.getLocates()

Method parameters in bb.common with type arguments of type PartOnhandAndCostResult
 void PartOnhandResult.setLocates(java.util.Map<java.lang.String,PartOnhandAndCostResult> locates)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartOnHandAuditAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartOnHandAuditAgent

No usage of bb.common.PartOnHandAuditAgent

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartOnHandAuditResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartOnHandAuditResult

Packages that use PartOnHandAuditResult
bb.common.box

Uses of PartOnHandAuditResult in bb.common.box

Methods in bb.common.box that return PartOnHandAuditResult
 PartOnHandAuditResult WarehouseBox.getPartOnHandAuditResult(PartPK pk, java.util.Date date)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartOnhandCostVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartOnhandCostVO

No usage of bb.common.PartOnhandCostVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartOnhandPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartOnhandPK

Packages that use PartOnhandPK
bb.common
bb.common.box

Uses of PartOnhandPK in bb.common

Methods in bb.common that return PartOnhandPK
PartOnhandPK | ToolOnhandVO.getPk()
PartOnhandPK | PartOnhandVO.getPk()
PartOnhandPK | NCRPartOnhandPK.getPk()
PartOnhandPK | BB2PartOnhandPK.getPk()

Methods in bb.common with parameters of type PartOnhandPK
void | ToolOnhandVO.setPk(PartOnhandPK pk)
void | PartOnhandVO.setPk(PartOnhandPK pk)
void | NCRPartOnhandPK.setPk(PartOnhandPK pk)
void | BB2PartOnhandPK.setPk(PartOnhandPK pk)

Constructors in bb.common with parameters of type PartOnhandPK
NCRPartOnhandPK(PartOnhandPK pk, java.lang.String ncr)
NCRPartOnhandPK(PartOnhandPK pk, java.lang.String ncr, int ii)

Uses of PartOnhandPK in bb.common.box

Methods in bb.common.box that return PartOnhandPK
 PartOnhandPK WarehouseBox.addNewLocation(BB2Part part, java.lang.String location, java.lang.String warehouse)

Methods in bb.common.box with parameters of type PartOnhandPK
 PartOnhandVO WarehouseBox.findPartOnhandByPk(PartOnhandPK pk)

Method parameters in bb.common.box with type arguments of type PartOnhandPK
 void WarehouseBox.batchMoveLocation(java.util.Map<PartOnhandPK,java.math.BigDecimal> data, java.lang.String warehousePrefix)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartOnhandResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartOnhandResult

Packages that use PartOnhandResult
bb.common.box

Uses of PartOnhandResult in bb.common.box

Methods in bb.common.box that return PartOnhandResult
 PartOnhandResult WarehouseBox.findPartOnhandTotalResultsByLocate(java.lang.String locate, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, boolean listZeroOnhand)

Methods in bb.common.box that return types with arguments of type PartOnhandResult
java.util.Collection<PartOnhandResult> | WarehouseBox.findNegativePartOnhandResults(java.lang.String pn1, java.lang.String pn2, java.lang.String pnType, boolean listOtherLocationsForSamePart, int firstIndex, int maxLength)
java.util.Collection<PartOnhandResult> | WarehouseBox.findPartOnhandResultsByLocate(java.lang.String locate, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, boolean listZeroOnhand, boolean listOtherLocationsForSamePart, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartOnhandVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartOnhandVO

Packages that use PartOnhandVO
bb.common
bb.common.box

Uses of PartOnhandVO in bb.common

Methods in bb.common that return PartOnhandVO
 PartOnhandVO PartOnhandWithAverageCostResult.getPartOnhandVo()

Methods in bb.common that return types with arguments of type PartOnhandVO
 java.util.Set<PartOnhandVO> PartWithOnhandsVO.getOnHandLocations()

Methods in bb.common with parameters of type PartOnhandVO
 void PartOnhandWithAverageCostResult.setPartOnhandVo(PartOnhandVO partOnhandVo)

Method parameters in bb.common with type arguments of type PartOnhandVO
 void PartWithOnhandsVO.setOnHandLocations(java.util.Set<PartOnhandVO> onHandLocations)

Uses of PartOnhandVO in bb.common.box

Methods in bb.common.box that return PartOnhandVO
 PartOnhandVO WarehouseBox.findPartOnhandByPk(PartOnhandPK pk)

Methods in bb.common.box that return types with arguments of type PartOnhandVO
java.util.Collection<PartOnhandVO> | WarehouseBox.findAllPartOnhand(int firstIndex, int maxLength)
java.util.Collection<PartOnhandVO> | WarehouseBox.findPartOnHandByLocation(java.lang.String location)
java.util.Collection<PartOnhandVO> | WarehouseBox.findPartOnhandByPk(PartPK pk)
java.util.Collection<PartOnhandVO> | WarehouseBox.findPartOnhandIsZeroByPart(PartPK pk, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type PartOnhandVO
void | WarehouseBox.addPartOnhand(PartOnhandVO vo)
void | WarehouseBox.deletePartOnhand(PartOnhandVO vo)
void | WarehouseBox.updatePartOnhand(PartOnhandVO vo)

Method parameters in bb.common.box with type arguments of type PartOnhandVO
 void EngineeringBox.batchUpdatePartWithOnhands(java.util.Map<PartPK,java.util.HashSet<PartOnhandVO>> allPartWithOnhands)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartOnhandWithAverageCostResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartOnhandWithAverageCostResult

Packages that use PartOnhandWithAverageCostResult
bb.common.box

Uses of PartOnhandWithAverageCostResult in bb.common.box

Method parameters in bb.common.box with type arguments of type PartOnhandWithAverageCostResult
 void CompanyBox.importTempInventory(java.util.ArrayList<PartOnhandWithAverageCostResult> inventorys)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartOnHandWithMfgInfoResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartOnHandWithMfgInfoResult

Packages that use PartOnHandWithMfgInfoResult
bb.common.box

Uses of PartOnHandWithMfgInfoResult in bb.common.box

Methods in bb.common.box that return types with arguments of type PartOnHandWithMfgInfoResult
 java.util.Collection<PartOnHandWithMfgInfoResult> EngineeringBox.findAllBomItems(java.lang.String[] billNumbers, java.lang.String billType, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartOnHandWithPartBasicInfoResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartOnHandWithPartBasicInfoResult

Packages that use PartOnHandWithPartBasicInfoResult
bb.common.box

Uses of PartOnHandWithPartBasicInfoResult in bb.common.box

Methods in bb.common.box that return types with arguments of type PartOnHandWithPartBasicInfoResult
java.util.Collection<PartOnHandWithPartBasicInfoResult> | EngineeringBox.findAllPartsToDelete(int firstIndex, int maxLength)
java.util.Collection<PartOnHandWithPartBasicInfoResult> | EngineeringBox.findAllPartsWithOnhandInfo(java.lang.String partNumber, java.lang.String partDescription, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<PartOnHandWithPartBasicInfoResult> | EngineeringBox.findAllPartsWithOnhandInfo(java.lang.String fPn, java.lang.String tPn, java.lang.String partType, java.lang.String descLike, java.lang.String modelNumLike, java.lang.String commodityCodeLike, java.lang.String productCodeLike, java.lang.String language, java.lang.String makeBuy, boolean posOnhand, boolean onlyShowFlushMaterial, int firstIndex, int maxLength)
java.util.Collection<PartOnHandWithPartBasicInfoResult> | EngineeringBox.findInBillPartsWithOnhandInfo(java.lang.String partNumber, java.lang.String partDescription, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<PartOnHandWithPartBasicInfoResult> | EngineeringBox.findNotBillPartsWithOnhandInfo(java.lang.String partNumber, java.lang.String partDescription, java.lang.String partType, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartPictureVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartPictureVO

Packages that use PartPictureVO
bb.common.box

Uses of PartPictureVO in bb.common.box

Methods in bb.common.box that return PartPictureVO
 PartPictureVO EngineeringBox.getMainPartPicture(PartPK pk)

Methods in bb.common.box that return types with arguments of type PartPictureVO
 java.util.Collection<PartPictureVO> EngineeringBox.getPartPictureByPk(PartPK pk)

Methods in bb.common.box with parameters of type PartPictureVO
 void EngineeringBox.addPartPicture(PartPictureVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartPK

Packages that use PartPK
bb.common
bb.common.box

Uses of PartPK in bb.common

Methods in bb.common that return PartPK
PartPK | MrpItemResult.getPart()
PartPK | MrpItemOrderDemandRecordsResult.getPart()
PartPK | WorkSheetPartAgent.getPartPk()
PartPK | WorkOrderOverIssueListResult.getPartPk()
PartPK | WorkOrderOnOrderResult.getPartPk()
PartPK | WorkOrderOnDemandResult.getPartPk()
PartPK | WorkOrderItemTimeDetailResult.getPartPk()
PartPK | WorkOrderItemSetupItemAgent.getPartPk()
PartPK | WorkOrderItemPartDetailResult.getPartPk()
PartPK | WorkOrderItemPartDetailItemResult.getPartPk()
PartPK | WorkOrderItemPartDetail.getPartPk()
PartPK | WorkOrderItemListResult.getPartPk()
PartPK | WorkOrderItemAgent.getPartPk()
PartPK | WorkOrderInWipResult.getPartPk()
PartPK | WoItemPickListResult.getPartPk()
PartPK | WoItemPickListItemResult.getPartPk()
PartPK | UpdatePhysicalInventoryAgent.getPartPk()
PartPK | SwapShipperOnOrderResult.getPartPk()
PartPK | ShippingItemResult.getPartPk()
PartPK | SalesPartListItemResult.getPartPk()
PartPK | SalesOrderOnDemandResult.getPartPk()
PartPK | SalesOrderItemListResult.getPartPk()
PartPK | SalesBomItemResult.getPartPk()
PartPK | RRMAItemListResult.getPartPk()
PartPK | RMAItemListResult.getPartPk()
PartPK | ReturnToVendorItemListResult.getPartPk()
PartPK | RequestForQuoteItemListResult.getPartPk()
PartPK | ReceivingItemResult.getPartPk()
PartPK | QuoteItemListResult.getPartPk()
PartPK | PurchaseOrderOnOrderResult.getPartPk()
PartPK | PartWithWipQtyListResult.getPartPk()
PartPK | PartWithSTOQtyListResult.getPartPk()
PartPK | PartWithSITQtyListResult.getPartPk()
PartPK | PartWithSipQtyListResult.getPartPk()
PartPK | PartWithQtyListResult.getPartPk()
PartPK | PartWithQAQtyListResult.getPartPk()
PartPK | PartWithOnLoanQtyListResult.getPartPk()
PartPK | PartWithExcessiveInventoryListResult.getPartPk()
PartPK | PartMaterialWhereUsedResult.getPartPk()
PartPK | PartMaterialReportAgent.getPartPk()
PartPK | PartInMrpListResult.getPartPk()
PartPK | PartBasicInfo.getPartPk()
PartPK | OrderDemandForReceiverResult.getPartPk()
PartPK | OnLoanItemListResult.getPartPk()
PartPK | NonproductivePickingOnDemandResult.getPartPk()
PartPK | JobProcessSheetListResult.getPartPk()
PartPK | IssuingResult.getPartPk()
PartPK | IssuingItemResult.getPartPk()
PartPK | IssueItemAgent.getPartPk()
PartPK | EngineeringChangeRequestListResult.getPartPk()
PartPK | EngineeringChangeListResult.getPartPk()
PartPK | DisassembleWorkOrderReceivingResult.getPartPk()
PartPK | DisassembleWorkOrderItemPartDetailResult.getPartPk()
PartPK | DisassembleWorkOrderItemPartDetailItemResult.getPartPk()
PartPK | DisassembleWorkOrderItemListResult.getPartPk()
PartPK | DisassembleWorkOrderIssuingItemResult.getPartPk()
PartPK | DesignControlListResult.getPartPk()
PartPK | CRTVItemListResult.getPartPk()
PartPK | BomPickListItemResult.getPartPk()
PartPK | BomItemWithOEMResult.getPartPk()
PartPK | BillWhereUsedResult.getPartPk()
PartPK | BillSalesXResult.getPartPk()
PartPK | BillSalesResult.getPartPk()
PartPK | BB2Part.getPartPk()
PartPK | AuditOnDemandResult.getPartPk()
PartPK | AddPhysicalInventoryAgent.getPartPk()
PartPK | PO2SOExchangeItem.getPartPK()
PartPK | JobProcessSheetResult.getPartPK()
PartPK | InventoryReportListResult.getPartPK()
PartPK | ToolWithOnhandsVO.getPk()
PartPK | ToolVO.getPk()
PartPK | ToolInventoryVO.getPk()
PartPK | RollUPPartStandardCostResult.getPk()
PartPK | RecursiveBillPath.getPk()
PartPK | PartWithOnhandsVO.getPk()
PartPK | PartVO.getPk()
PartPK | PartToAuditFlagResult.getPk()
PartPK | PartOnHandAuditResult.getPk()
PartPK | PartMRPVO.getPk()
PartPK | PartMaterialVO.getPk()
PartPK | PartInventoryVO.getPk()
PartPK | InSipAudittListResult.getPk()
PartPK | BOMCanAssyListResult.getPk()
PartPK | BillItemUsagePathResult.getPk()

Methods in bb.common that return types with arguments of type PartPK
 java.util.Iterator<PartPK> BOMTreeRollUPMap.getPartPKs()

Methods in bb.common with parameters of type PartPK
void | BOMTreeRollUPMap.addRollUPCost(PartPK pk, java.math.BigDecimal value)
void | BOMTreeRollUPMap.addStdCost(PartPK pk, java.math.BigDecimal value)
void | BOMTreeRollUPMap.addStdRollUPCost(PartPK pk, java.math.BigDecimal val, java.math.BigDecimal val2)
int | PartPK.compareTo(PartPK other)
boolean | BOMTreeRollUPMap.contain(PartPK pk)
java.math.BigDecimal | BOMTreeRollUPMap.getRollUPCost(PartPK pk)
java.math.BigDecimal | BOMTreeRollUPMap.getStdCost(PartPK pk)
void | MrpItemResult.setPart(PartPK part)
void | MrpItemOrderDemandRecordsResult.setPart(PartPK part)
void | WorkSheetPartAgent.setPartPk(PartPK partPk)
void | WorkOrderOverIssueListResult.setPartPk(PartPK partPk)
void | WorkOrderOnOrderResult.setPartPk(PartPK partPk)
void | WorkOrderOnDemandResult.setPartPk(PartPK partPk)
void | WorkOrderItemTimeDetailResult.setPartPk(PartPK partPk)
void | WorkOrderItemSetupItemAgent.setPartPk(PartPK partPk)
void | WorkOrderItemPartDetailResult.setPartPk(PartPK partPk)
void | WorkOrderItemPartDetail.setPartPk(PartPK partPk)
void | WorkOrderItemListResult.setPartPk(PartPK partPk)
void | WorkOrderItemAgent.setPartPk(PartPK partPk)
void | WorkOrderInWipResult.setPartPk(PartPK partPk)
void | WoItemPickListResult.setPartPk(PartPK partPk)
void | WoItemPickListItemResult.setPartPk(PartPK partPk)
void | UpdatePhysicalInventoryAgent.setPartPk(PartPK partPk)
void | SwapShipperOnOrderResult.setPartPk(PartPK partPk)
void | ShippingItemResult.setPartPk(PartPK partPk)
void | SalesPartListItemResult.setPartPk(PartPK partPk)
void | SalesOrderOnDemandResult.setPartPk(PartPK partPk)
void | SalesOrderItemListResult.setPartPk(PartPK partPk)
void | SalesBomItemResult.setPartPk(PartPK partPk)
void | RRMAItemListResult.setPartPk(PartPK partPk)
void | RMAItemListResult.setPartPk(PartPK partPk)
void | ReturnToVendorItemListResult.setPartPk(PartPK partPk)
void | RequestForQuoteItemListResult.setPartPk(PartPK partPk)
void | ReceivingItemResult.setPartPk(PartPK partPk)
void | QuoteItemListResult.setPartPk(PartPK partPk)
void | PurchaseOrderOnOrderResult.setPartPk(PartPK partPk)
void | PartWithWipQtyListResult.setPartPk(PartPK partPk)
void | PartWithSTOQtyListResult.setPartPk(PartPK partPk)
void | PartWithSITQtyListResult.setPartPk(PartPK partPk)
void | PartWithSipQtyListResult.setPartPk(PartPK partPk)
void | PartWithQtyListResult.setPartPk(PartPK partPk)
void | PartWithQAQtyListResult.setPartPk(PartPK partPk)
void | PartWithOnLoanQtyListResult.setPartPk(PartPK partPk)
void | PartWithExcessiveInventoryListResult.setPartPk(PartPK partPk)
void | PartMaterialWhereUsedResult.setPartPk(PartPK partPk)
void | PartMaterialReportAgent.setPartPk(PartPK partPk)
void | PartInMrpListResult.setPartPk(PartPK partPk)
void | PartBasicInfo.setPartPk(PartPK partPk)
void | OnLoanItemListResult.setPartPk(PartPK partPk)
void | NonproductivePickingOnDemandResult.setPartPk(PartPK partPk)
void | JobProcessSheetListResult.setPartPk(PartPK partPk)
void | IssuingResult.setPartPk(PartPK partPk)
void | IssuingItemResult.setPartPk(PartPK partPk)
void | IssueItemAgent.setPartPk(PartPK partPk)
void | EngineeringChangeRequestListResult.setPartPk(PartPK partPk)
void | EngineeringChangeListResult.setPartPk(PartPK partPk)
void | DisassembleWorkOrderReceivingResult.setPartPk(PartPK partPk)
void | DisassembleWorkOrderItemPartDetailResult.setPartPk(PartPK partPk)
void | DisassembleWorkOrderItemListResult.setPartPk(PartPK partPk)
void | DisassembleWorkOrderIssuingItemResult.setPartPk(PartPK partPk)
void | DesignControlListResult.setPartPk(PartPK partPk)
void | CRTVItemListResult.setPartPk(PartPK partPk)
void | BomPickListItemResult.setPartPk(PartPK partPk)
void | BomItemWithOEMResult.setPartPk(PartPK partPk)
void | BillWhereUsedResult.setPartPk(PartPK partPk)
void | BillSalesXResult.setPartPk(PartPK partPk)
void | BillSalesResult.setPartPk(PartPK partPk)
void | BillSalesCostResult.setPartPk(PartPK partPk)
void | BB2Part.setPartPk(PartPK partPk)
void | AuditOnDemandResult.setPartPk(PartPK partPk)
void | AddPhysicalInventoryAgent.setPartPk(PartPK partPk)
void | PO2SOExchangeItem.setPartPK(PartPK partPK)
void | JobProcessSheetResult.setPartPK(PartPK partPK)
void | ToolWithOnhandsVO.setPk(PartPK pk)
void | ToolVO.setPk(PartPK pk)
void | ToolInventoryVO.setPk(PartPK pk)
void | RollUPPartStandardCostResult.setPk(PartPK pk)
void | RecursiveBillPath.setPk(PartPK pk)
void | PartWithOnhandsVO.setPk(PartPK pk)
void | PartVO.setPk(PartPK pk)
void | PartToAuditFlagResult.setPk(PartPK pk)
void | PartOnHandAuditResult.setPk(PartPK pk)
void | PartMRPVO.setPk(PartPK pk)
void | PartMaterialVO.setPk(PartPK pk)
void | PartInventoryVO.setPk(PartPK pk)
void | InSipAudittListResult.setPk(PartPK pk)
void | BOMCanAssyListResult.setPk(PartPK pk)
void | BillItemUsagePathResult.setPk(PartPK pk)

Constructors in bb.common with parameters of type PartPK
BB2Part(PartPK partPk, java.lang.String partFrom)
BB2PartOnhandPK(PartPK pk, java.lang.String partFrom, java.lang.String location)
BillPK(PartPK partPk)
PartBasicInfo(PartPK pk)
PartManufacturerVO(PartPK partPk)
PartUnitPK(PartPK partPk, java.lang.String unit)
PartVendorVO(PartPK partPk)
PartWithoutLocateResult(PartPK pk)
RecursiveBillPath(PartPK pk)
ToolManufacturerVO(PartPK partPk)
ToolVendorVO(PartPK partPk)

Uses of PartPK in bb.common.box

Methods in bb.common.box that return PartPK
PartPK | EngineeringBox.addPart(PartVO vo)
PartPK | EngineeringBox.replacePartForBOM(java.util.ArrayList<BillPK> list, PartPK oPartPk, PartPK dPartPk)
PartPK | EngineeringBox.updatePart(PartVO partVO)
PartPK | EngineeringBox.updatePartType(PartPK oldPartPk, PartPK newPartPk)

Methods in bb.common.box that return types with arguments of type PartPK
java.util.Collection<PartPK> | WarehouseBox.auditLastInventoryDate(java.lang.String pnLike, java.lang.String paType, java.util.Date start)
java.util.HashMap<PartPK,ContractPriceItemVO> | CompanyBox.findContractPriceItemByPartNumberList(java.lang.String contractNumber, java.util.HashSet<PartPK> pks)
java.util.Collection<PartPK> | WarehouseBox.findPhysicalInventoryPart(java.lang.String pnLike, java.lang.String paLike, java.util.Date fDate, java.util.Date tDate)
java.util.Collection<PartPK> | WorkOrderBox.getPartCanAssy(BOMCanAssyAgent agent)
java.util.Collection<PartPK> | PurchasingBox.getPartPKList(MrpReportAgent agent)
java.util.Collection<PartPK> | WarehouseBox.getPartPKsToAudit(java.lang.String pnPrefix, java.util.Date startDate)
java.util.Collection<PartPK> | WarehouseBox.getPartsByHistoricalInventorys(java.lang.String pnLike, java.lang.String paLike, java.util.Date fDate, java.util.Date tDate)
java.util.Collection<PartPK> | EngineeringBox.getRecursivePartPKs(java.lang.String bill)
java.util.Collection<PartPK> | EngineeringBox.getRootBOMPartPKs(java.lang.String bill)
java.util.Collection<PartPK> | EngineeringBox.rollupPartStandardCost(PartPK pk)

Methods in bb.common.box with parameters of type PartPK
EngineeringChangeRequestVO | ManufacturingBox.addMECRequest(PartPK pk)
PartMaterialVO | EngineeringBox.addPartMaterial(PartPK partPk)
ToolCalibrationVO | ManufacturingBox.addToolCalibration(PartPK partPk, java.lang.String serialNumber)
PartVO | EngineeringBox.copyPart(PartPK pk, java.lang.String rev, java.lang.String partUnit, java.lang.String description, PartPK oldPk, boolean onlyChangeParType)
PartMaterialVO | EngineeringBox.copyPartMaterial(PartPK partPk, PartMaterialVO vo)
void | EngineeringBox.deletePartMaterial(PartPK partPk)
void | EngineeringBox.deletePartTraceable(PartPK pk)
void | EngineeringBox.deletePartTraceableCategories(PartPK partPk)
void | EngineeringBox.deletePartTraceableSpecs(PartPK partPk)
java.util.Collection<ToolCalibrateListResult> | ManufacturingBox.findCalibrationsByDate(java.util.Date fromDate, java.util.Date toDate, boolean isLast, PartPK partPk, java.lang.String assign, int firstIndex, int maxLength)
java.util.Collection<PartDwfWithPartInfoResult> | EngineeringBox.findDwfDrawingByPartPk(PartPK pk, java.lang.String partFrom, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | EngineeringBox.findEngineeringChangeByPartPk(PartPK partPk, java.lang.String languageFlag, int firstIndex, int maxLength)
java.util.Collection<CustomerServiceIncidentListResult> | CustomerServiceBox.findIncidentsByDate(java.lang.String csiNumber, PartPK partPk, java.lang.String customerId, java.lang.String priority, java.lang.String status, boolean isOpenDate, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<CustomerServiceIncidentItemListResult> | CustomerServiceBox.findIncidentsByDate(java.lang.String csiNumber, PartPK partPk, java.lang.String customerId, java.lang.String priority, java.lang.String status, java.lang.String shipperNumber, java.lang.String workOrderNumber, java.lang.String salesOrderNumber, boolean isOpenDate, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<InvoiceItemListResult> | AccountingBox.findInvoiceItemsByPartPK(PartPK partPk, int firstIndex, int maxLength)
java.util.ArrayList<WorkOrderItemIssuedTotalResult> | WarehouseBox.findIssuedPartTotal(WorkOrderItemPK pk, PartPK partPk, java.lang.String relatedDoc, java.lang.String modelNumber, java.lang.String common, java.lang.String dateType, java.util.Date dateFrom, java.util.Date dateTo, int firstIndex, int maxLength)
java.util.Collection<OnLoanItemListResult> | WarehouseBox.findLoanItemByPartPk(PartPK pk, java.lang.String partFromType, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | ManufacturingBox.findManufacturerEngineeringChangeByPart(PartPK partPk, java.lang.String languageFlag, int firstIndex, int maxLength)
java.util.Collection<EngineeringChangeListResult> | ManufacturingBox.findManufacturerEngineeringChangeByPartPk(PartPK partPk, java.lang.String languageFlag, int firstIndex, int maxLength)
java.util.Collection<NonConformanceReportVO> | QualityBox.findNCRsByPart(PartPK pk, int firstIndex, int maxLength)
java.util.Collection<OnLoanItemListResult> | WarehouseBox.findOnLoanItemsByDate(PartPK partPk, java.lang.String customerId, java.lang.String salesMan, java.lang.String status, boolean isDeliveryDate, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<DisassembleWorkOrderItemListResult> | WorkOrderBox.findOpenDisassembleWorkOrderItemListResultsByPartPK(PartPK partPk, int firstIndex, int maxLength)
java.util.Collection<InvoiceItemListResult> | AccountingBox.findOpenInvoiceItemsByPartPK(PartPK partPk, int firstIndex, int maxLength)
java.util.Collection<NonConformanceReportVO> | QualityBox.findOpenNCRsByPartPK(PartPK pk, int firstIndex, int maxLength)
java.util.Collection<POReceiverItemListResult> | WarehouseBox.findOpenPOReceiverItemsByPartPK(PartPK partPk, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | PurchasingBox.findOpenPurchaseOrderItemsByPartPk(PartPK pk, int firstIndex, int maxLength)
java.util.Collection<QuoteItemListResult> | SalesBox.findOpenQuoteItemByPartPk(PartPK partPk, int firstIndex, int maxLength)
java.util.Collection<RMAItemListResult> | SalesBox.findOpenRMAsByPartPk(PartPK pk, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | SalesBox.findOpenSaleOrderItemByPartPk(PartPK partPk, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | WorkOrderBox.findOpenWorkOrderItemListResultsByPartPK(PartPK partPk, int firstIndex, int maxLength)
java.util.Collection<PackingBoxItemVO> | WarehouseBox.findPackingBoxItem(java.lang.String pfNumber, PartPK partPk, java.lang.String partFrom)
PartVO | EngineeringBox.findPart(PartPK pk)
java.util.Collection<PartManufacturerVO> | EngineeringBox.findPartManufacturersByPartPk(PartPK partPk)
java.util.Collection<PartMaterialListResult> | EngineeringBox.findPartMaterialByPartLike(PartPK partPk, int firstIndex, int maxLength)
java.util.Collection<PartOnhandVO> | WarehouseBox.findPartOnhandByPk(PartPK pk)
java.util.Collection<PartOnhandVO> | WarehouseBox.findPartOnhandIsZeroByPart(PartPK pk, int firstIndex, int maxLength)
java.util.Collection<PartVO> | EngineeringBox.findPartsByPK(PartPK pk, int firstIndex, int maxLength)
PartTraceableInfoResult | EngineeringBox.findPartTraceableByPk(PartPK pk)
java.util.Collection<PartTrackingVO> | QualityBox.findPartTracking(PartPK pk)
java.util.Collection<PartVendorVO> | EngineeringBox.findPartVendorsByPartPk(PartPK partPk)
PartWhereUsedResult | EngineeringBox.findPartWhereIsUsed(PartPK pk)
java.util.Collection<PartWithoutLocateResult> | WarehouseBox.findPartWithoutLocationList(PartPK pk, int firstIndex, int maxLength)
java.util.Collection<POReceiverItemListResult> | WarehouseBox.findPOReceiverItemsByPartPK(PartPK partPk, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | PurchasingBox.findPurchaseOrderItemsByPartPk(PartPK pk, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | ManufacturingBox.findPurchaseOrderItemsByPartPk(PartPK pk, int firstIndex, int maxLength)
java.util.Collection<QuoteItemListResult> | SalesBox.findQuoteItemByDate(PartPK partPk, java.lang.String quoteNumber, java.lang.String customerRFQNumber, java.lang.String customerId, java.lang.String includeCustomerIds, java.lang.String excludeCustomerIds, java.lang.String salesMan, java.util.Date fromDate, java.util.Date toDate, java.lang.String status, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<QuoteItemListResult> | SalesBox.findQuoteItemByPartPk(PartPK pk, int firstIndex, int maxLength)
java.util.Collection<TotalByDateResult> | SalesBox.findQuoteTotalByDateResults(PartPK partPk, java.lang.String quoteNumber, java.lang.String customerRFQNumber, java.lang.String customerId, java.lang.String includeCustomerIds, java.lang.String excludeCustomerIds, java.lang.String salesMan, java.util.Date fromDate, java.util.Date toDate, java.lang.String status, java.lang.String currency)
java.util.Collection<RMAItemListResult> | SalesBox.findRmaItemByPartPk(PartPK partPk, int firstIndex, int maxLength)
java.util.Collection<RMAItemListResult> | SalesBox.findRmaItemsByDate(PartPK partPk, java.lang.String rmaNumber, java.lang.String rmaItemNumber, java.lang.String customerId, java.lang.String salesMan, java.lang.String ncrNumber, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isRequireDate, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<RMAItemListResult> | SalesBox.findRMAsByPartPk(PartPK pk, int firstIndex, int maxLength)
java.util.Collection<RRMAItemListResult> | SalesBox.findRRMAItemListResult(PartPK partPk, java.lang.String rrmaNumber, java.lang.String rrmaItemNumber, java.lang.String customerId, java.lang.String salesMan, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isRequireDate, java.util.Date fromDate, java.util.Date toDate, boolean incluedInventory, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | SalesBox.findSalesOrderItemByPartPk(PartPK pk, int firstIndex, int maxLength)
java.util.Collection<SwapOrderItemListResult> | PurchasingBox.findSwapOrderByDate(java.lang.String swoNumber, PartPK partPk, java.lang.String dateType, java.util.Date startDate, java.util.Date toDate, java.lang.String vendorId, java.lang.String buyer, java.lang.String projectName, java.lang.String relatedDoc, java.lang.String status, java.lang.String partFrom, int firstIndex, int maxLength)
java.util.Collection<ToolCalibrateListResult> | ManufacturingBox.findToolCalibrationsByPart(PartPK partPk, int firstIndex, int maxLength)
java.util.Collection<ToolManufacturerVO> | ManufacturingBox.findToolManufacturersByPartPk(PartPK partPk)
java.util.Collection<ToolOnhandVO> | WarehouseBox.findToolOnhandByPk(PartPK pk)
java.util.Collection<ToolVendorVO> | ManufacturingBox.findToolVendorsByPartPk(PartPK partPk)
ToolWhereUsedResult | ManufacturingBox.findToolWhereIsUsed(PartPK pk)
InventoryAuditReportResult | WarehouseBox.getAuditInventoryReport(PartPK pk, java.util.Date fDate, java.util.Date tDate)
BillWhereUsedResult | EngineeringBox.getBillWhereUsedResult(PartPK pk, BillPK billPk)
BOMCanAssyListResult | WorkOrderBox.getBOMCanAssyListResult(PartPK pk)
int | ManufacturingBox.getCalibrationsCountByDate(java.util.Date fromDate, java.util.Date toDate, boolean isLast, PartPK partPk, java.lang.String assign)
int | EngineeringBox.getDwfDrawingCountByPartPk(PartPK pk, java.lang.String partFrom)
int | EngineeringBox.getEngineeringChangesCountByPartPk(PartPK partPk)
int | CustomerServiceBox.getIncidentCountByDate(java.lang.String csiNumber, PartPK partPk, java.lang.String customerId, java.lang.String priority, java.lang.String status, boolean isOpenDate, java.util.Date fromDate, java.util.Date toDate)
int | CustomerServiceBox.getIncidentCountByDate(java.lang.String csiNumber, PartPK partPk, java.lang.String customerId, java.lang.String priority, java.lang.String status, java.lang.String shipperNumber, java.lang.String workOrderNumber, java.lang.String salesOrderNumber, boolean isOpenDate, java.util.Date fromDate, java.util.Date toDate)
int | AccountingBox.getInvoiceItemsByPartPKCount(PartPK partPk)
int | WarehouseBox.getIssuedPartTotalCount(WorkOrderItemPK pk, PartPK partPk, java.lang.String relatedDoc, java.lang.String modelNumber, java.lang.String common, java.lang.String dateType, java.util.Date dateFrom, java.util.Date dateTo)
JobProcessSheetResult | ManufacturingBox.getJobProcessSheetResult(PartPK partPk, boolean isTool, java.lang.String setId)
int | WarehouseBox.getLoanItemByPartPkCount(PartPK pk, java.lang.String partFromType)
PartPictureVO | EngineeringBox.getMainPartPicture(PartPK pk)
int | ManufacturingBox.getManufacturerEngineeringChangesCountByPart(PartPK partPk)
int | ManufacturingBox.getManufacturerEngineeringChangesCountByPartPk(PartPK partPk)
java.lang.String | EngineeringBox.getManufacturerPartNoMfgExistent(java.lang.String mfgName, PartPK partPk)
MrpItemOrderDemandRecordsResult | PurchasingBox.getMrpItemOrderDemandRecordsResult(PartPK part, MrpReportAgent agent)
MrpItemResult | PurchasingBox.getMrpItemResult(PartPK pk, boolean minQty, boolean includeTolerance)
MrpItemResult | PurchasingBox.getMrpItemResult(PartPK part, MrpReportAgent tmp)
int | QualityBox.getNCRSCountByPart(PartPK pk)
int | WarehouseBox.getOnLoanItemsCountByDate(PartPK partPk, java.lang.String customerId, java.lang.String salesMan, java.lang.String status, boolean isDeliveryDate, java.util.Date fromDate, java.util.Date toDate)
int | WorkOrderBox.getOpenDisassembleWorkOrderItemListResultsByPartPkCount(PartPK partPk)
int | AccountingBox.getOpenInvoiceItemsByPartPKCount(PartPK partPk)
int | QualityBox.getOpenNCRsCountByPartPK(PartPK pk)
int | WarehouseBox.getOpenPOReceiverItemsCountByPartPK(PartPK partPk)
int | PurchasingBox.getOpenPurchaseOrderItemCountByPartPk(PartPK pk)
int | SalesBox.getOpenQuoteItemCountByPartPk(PartPK partPk)
int | SalesBox.getOpenRMAsCountByPartPk(PartPK pk)
int | SalesBox.getOpenSaleOrderItemByPartPkCount(PartPK partPk)
int | WorkOrderBox.getOpenWorkOrderItemListResultsByPartPkCount(PartPK partPk)
int | WarehouseBox.getPageNumberInWorkSheetByPart(PartPK partPK, java.lang.String location, int workSheetNumber, java.lang.String tagNumber)
PartBasicInfo | EngineeringBox.getPartBasicInfo(PartPK pk)
PartBasicInfo | EngineeringBox.getPartBasicInfo(PartPK pk, java.lang.String languageCode)
PartInventoryVO | EngineeringBox.getPartInventoryByPk(PartPK partPk)
PartMaterialVO | EngineeringBox.getPartMaterialByPk(PartPK partPk)
int | EngineeringBox.getPartMaterialCountByPartLike(PartPK partPk)
PartMaterialListResult | EngineeringBox.getPartMaterialInfo(PartPK pk)
PartMaterialWhereUsedResult | EngineeringBox.getPartMaterialWhereUsedResult(PartPK pk)
PartOnHandAuditResult | WarehouseBox.getPartOnHandAuditResult(PartPK pk, java.util.Date date)
int | WarehouseBox.getPartOnhandIsZeroByPartCount(PartPK pk)
java.util.Collection<PartPictureVO> | EngineeringBox.getPartPictureByPk(PartPK pk)
int | EngineeringBox.getPartsCountByPK(PartPK pk)
java.util.Map<BillPK,java.util.List> | EngineeringBox.getPartUseds(java.util.ArrayList<BillPK> list, PartPK oPartPk)
PartWithOnhandsVO | EngineeringBox.getPartWithOnhands(PartPK pk)
int | WarehouseBox.getPartWithoutLocationCount(PartPK pk)
int | WarehouseBox.getPOReceiverItemsCountByPartPK(PartPK partPk)
int | PurchasingBox.getPurchaseOrderItemCountByPartPk(PartPK pk)
int | ManufacturingBox.getPurchaseOrderItemCountByPartPk(PartPK pk)
int | SalesBox.getQuoteItemCountByDate(PartPK partPk, java.lang.String quoteNumber, java.lang.String customerRFQNumber, java.lang.String customerId, java.lang.String includeCustomerIds, java.lang.String excludeCustomerIds, java.lang.String salesMan, java.util.Date fromDate, java.util.Date toDate, java.lang.String status, java.lang.String currency)
int | SalesBox.getQuoteItemCountByPartPK(PartPK pk)
java.util.Collection<RecursiveBillPath> | EngineeringBox.getRecursiveBill(PartPK pk)
int | SalesBox.getRmaItemByPartPkCount(PartPK partPk)
int | SalesBox.getRmaItemsCountByDate(PartPK partPk, java.lang.String rmaNumber, java.lang.String rmaItemNumber, java.lang.String customerId, java.lang.String salesMan, java.lang.String ncrNumber, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isRequireDate, java.util.Date fromDate, java.util.Date toDate)
int | SalesBox.getRMAsCountByPartPk(PartPK pk)
int | SalesBox.getRRMAItemListResultCount(PartPK partPk, java.lang.String rrmaNumber, java.lang.String rrmaItemNumber, java.lang.String customerId, java.lang.String salesMan, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isRequireDate, java.util.Date fromDate, java.util.Date toDate)
RunningAccountOrderItemVO | CompanyBox.getRunningAccountOrderItemByPartPK(PartPK pk)
RunningAccountOrderItemVO | CompanyBox.getRunningAccountOrderItemByPartPK(PartPK pk, java.lang.String customerId, java.lang.String mfgPartNumber)
RunningAccountOrderItemVO | CompanyBox.getRunningAccountOrderItemByRaoNumberandPartPK(java.lang.String raoNumber, PartPK pk)
int | SalesBox.getSalesOrderItemByPartPkCount(PartPK pk)
StockTransactionPartInfoResult | WarehouseBox.getStockTransactionPartInfoResultByPartPk(PartPK pk)
int | PurchasingBox.getSwapOrderCountByDate(java.lang.String swoNumber, PartPK partPk, java.lang.String dateType, java.util.Date startDate, java.util.Date toDate, java.lang.String vendorId, java.lang.String buyer, java.lang.String projectName, java.lang.String relatedDoc, java.lang.String status, java.lang.String partFrom)
ToolBasicInfo | ManufacturingBox.getToolBasicInfo(PartPK pk)
ToolBasicInfo | ManufacturingBox.getToolBasicInfo(PartPK pk, java.lang.String languageCode)
ToolVO | ManufacturingBox.getToolByPk(PartPK pk)
int | ManufacturingBox.getToolCalibrationsByPartCount(PartPK partPk)
ToolInventoryVO | ManufacturingBox.getToolInventoryByPk(PartPK partPk)
ToolWithOnhandsVO | ManufacturingBox.getToolOnhands(PartPK pk)
boolean | ManufacturingBox.hasToolList(PartPK partPk)
DisassembleWorkOrderItemVO | WorkOrderBox.initDisassembleWorkOrderItem(java.lang.String dwoNumber, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty, java.lang.String partFrom, java.lang.String naDesc)
OnLoanItemVO | WarehouseBox.initOnLoanItem(OnLoanVO onloanVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool)
PartManufacturerVO | EngineeringBox.InitPartManufacturerVoByAddressId(PartPK partPk, java.lang.String manufacturerId)
PartVendorVO | EngineeringBox.InitPartVendorVoByAddressId(PartPK partPk, java.lang.String vendorId)
PurchaseOrderItemVO | PurchasingBox.initPurchaseOrderItemForPart(java.lang.String purchaseOrderNumber, java.lang.String itemNumber, PartPK partPk, java.math.BigDecimal qty)
PurchaseOrderItemVO | ManufacturingBox.initPurchaseOrderItemForTool(java.lang.String purchaseOrderNumber, java.lang.String itemNumber, PartPK partPk, java.math.BigDecimal qty)
PurchaseWorkSheetItemWithRelatedInfoResult | PurchasingBox.initPurchaseWorkSheetItemForPart(PurchaseWorkSheetPK pk, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
PurchaseWorkSheetItemWithRelatedInfoResult | ManufacturingBox.initPurchaseWorkSheetItemForTool(PurchaseWorkSheetPK pk, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
QuoteItemVO | SalesBox.initQuoteItem(QuoteVO soVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool)
RequestForQuoteItemVO | PurchasingBox.initRequestForQuoteItemForPart(java.lang.String requestForQuoteNumber, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty, java.lang.String languageCode)
RequestForQuoteItemVO | PurchasingBox.initRequestForQuoteItemForTool(java.lang.String requestForQuoteNumber, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty, java.lang.String languageCode)
RequestForQuoteItemVO | ManufacturingBox.initRequestForQuoteItemForTool(java.lang.String requestForQuoteNumber, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty, java.lang.String languageCode)
ReturnToVendorItemVO | PurchasingBox.initReturnToVendorItemForPart(java.lang.String rtvNumber, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
ReturnToVendorItemVO | ManufacturingBox.initReturnToVendorItemForPart(java.lang.String rtvNumber, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
ReturnToVendorItemVO | PurchasingBox.initReturnToVendorItemForTool(java.lang.String rtvNumber, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
ReturnToVendorItemVO | ManufacturingBox.initReturnToVendorItemForTool(java.lang.String rtvNumber, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
ReturnMaterialAuthorizationItemVO | SalesBox.initRmaItem(ReturnMaterialAuthorizationVO rmaVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool)
ReturnMaterialAuthorizationItemVO | SalesBox.initRmaItem(ReturnMaterialAuthorizationVO rmaVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool, boolean isPOS)
SalesOrderItemVO | SalesBox.initSalesOrderItem(SalesOrderVO soVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool)
SalesOrderItemVO | SalesBox.initSalesOrderItem(SalesOrderVO soVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool, boolean isPOS)
SwapOrderItemVO | PurchasingBox.initSwapOrderItem(SwapOrderVO toVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool)
ToolListItemWithToolInfoResult | ManufacturingBox.initToolListItemWithToolInfo(PartPK partPk, BillItemPK pk, java.math.BigDecimal qty)
ToolManufacturerVO | ManufacturingBox.InitToolManufacturerVoByAddressId(PartPK partPk, java.lang.String manufacturerId)
ToolVendorVO | ManufacturingBox.InitToolVendorVoByAddressId(PartPK partPk, java.lang.String vendorId)
TransferOrderItemVO | WarehouseBox.initTransferOrderItem(TransferOrderVO toVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool)
WorkOrderItemVO | WorkOrderBox.initWorkOrderItemForPart(java.lang.String woNumber, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
WorkOrderItemVO | WorkOrderBox.initWorkOrderItemForTool(java.lang.String woNumber, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
WorkOrderWorkSheetItemWithRelatedInfoResult | WorkOrderBox.initWorkOrderWorkSheetItemForPart(WorkOrderWorkSheetPK pk, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
WorkOrderWorkSheetItemWithRelatedInfoResult | WorkOrderBox.initWorkOrderWorkSheetItemForTool(WorkOrderWorkSheetPK pk, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
boolean | EngineeringBox.isCurrentUserHasEngGroupPermission(PartPK pk)
boolean | WorkOrderBox.isExistPartInUseType(PartPK pk)
boolean | EngineeringBox.isPartExist(PartPK pk)
boolean | EngineeringBox.isPartExistent(PartPK pk)
boolean | EngineeringBox.isPartMaterialExist(PartPK partPk)
boolean | ManufacturingBox.isToolExistent(PartPK pk)
InventoryAuditReportResult | WarehouseBox.makeAuditInventoryByPhyInventory(PartPK pk, java.util.Date fDate, java.util.Date tDate)
java.lang.Long | ManufacturingBox.makeToolCalibration(PartPK partPk)
PartPK | EngineeringBox.replacePartForBOM(java.util.ArrayList<BillPK> list, PartPK oPartPk, PartPK dPartPk)
java.util.Collection<PartPK> | EngineeringBox.rollupPartStandardCost(PartPK pk)
void | EngineeringBox.updateDeletedFlag(PartPK pk, boolean isDeleted)
void | ManufacturingBox.updateInactiveTool(PartPK pk, boolean inactive)
void | EngineeringBox.updatePartEngGroupAndLevel(PartPK pk, java.lang.String organization, java.lang.String levelId)
java.util.Collection<PartManufacturerVO> | EngineeringBox.updatePartManufacturer(java.util.HashSet partManufacturerSet, PartPK partPk)
PartPK | EngineeringBox.updatePartType(PartPK oldPartPk, PartPK newPartPk)
java.util.Collection<PartVendorVO> | EngineeringBox.updatePartVendor(java.util.HashSet partVendorVoSet, PartPK partPk)
void | EngineeringBox.updateSaleableFlag(PartPK pk, boolean saleable, boolean salesDWG)
java.util.Collection<ToolCalibrateListResult> | ManufacturingBox.updateToolCalibration(java.util.ArrayList toolCalibrationList, PartPK partPk)
ToolManufacturerVO | ManufacturingBox.updateToolManufacturer(java.util.Set partManufacturerSet, PartPK partPk)
java.util.Collection<ToolOnhandVO> | WarehouseBox.updateToolOnhandDetail(java.util.HashSet onhandDetailVo, PartPK pk)
ToolVendorVO | ManufacturingBox.updateToolVendor(java.util.Set partVendorVoSet, PartPK partPk)

Method parameters in bb.common.box with type arguments of type PartPK
void | EngineeringBox.addEngineeringSharingItems(java.util.ArrayList<PartPK> pks, java.lang.String id)
void | EngineeringBox.auditPartBomFlag(java.util.HashSet<PartPK> partPKs)
void | EngineeringBox.auditPartPictureFlag(java.util.HashSet<PartPK> partPKs)
void | EngineeringBox.auditPartWIFlag(java.util.HashSet<PartPK> partPKs)
void | EngineeringBox.batchUpdatePartWithOnhands(java.util.Map<PartPK,java.util.HashSet<PartOnhandVO>> allPartWithOnhands)
java.util.HashMap<PartPK,ContractPriceItemVO> | CompanyBox.findContractPriceItemByPartNumberList(java.lang.String contractNumber, java.util.HashSet<PartPK> pks)
java.util.Collection<PartInMrpListResult> | PurchasingBox.findPartInMrpListResult(java.util.List<PartPK> partPks)
java.util.Collection<BillWhereUsedResult> | EngineeringBox.getBillWhereUsedResults(java.util.ArrayList<PartPK> pkList, BillPK billPk)
java.util.Collection<BOMCanAssyListResult> | WorkOrderBox.getBOMCanAssyListResults(java.util.ArrayList<PartPK> pks)
void | WarehouseBox.updatePartPartClass(java.util.HashSet<PartPK> set, java.lang.String partClass)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartReceivedListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartReceivedListResult

Packages that use PartReceivedListResult
bb.common.box

Uses of PartReceivedListResult in bb.common.box

Methods in bb.common.box that return PartReceivedListResult
 PartReceivedListResult WarehouseBox.getPartReceivedTotalResult(java.util.Date from, java.util.Date to, java.lang.String id, java.lang.String dwoNumber, java.lang.String dwoItemNumber, java.lang.String relatedDoc, java.lang.String pnLike, java.lang.String paLike, java.lang.String receiverNumber, java.lang.String project, java.lang.String[] branchWarehouses)

Methods in bb.common.box that return types with arguments of type PartReceivedListResult
 java.util.Collection<PartReceivedListResult> WarehouseBox.findPartReceivedByDate(java.util.Date from, java.util.Date to, java.lang.String id, java.lang.String woNumber, java.lang.String woItemNumber, java.lang.String relatedDoc, java.lang.String pnLike, java.lang.String paLike, java.lang.String receiverNumber, java.lang.String project, boolean showCurrentOnhand, java.lang.String[] branchWarehouses, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartReceivedVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartReceivedVO

Packages that use PartReceivedVO
bb.common
bb.common.box

Uses of PartReceivedVO in bb.common

Subclasses of PartReceivedVO in bb.common
 class PartReceivedListResult

Uses of PartReceivedVO in bb.common.box

Methods in bb.common.box that return types with arguments of type PartReceivedVO
 java.util.Collection<PartReceivedVO> WorkOrderBox.findDisassembleWorkOrderReceivedDetail(DisassembleWorkOrderItemPK pk, BB2Part part, java.lang.String description, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartSecurityLevelVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartSecurityLevelVO

Packages that use PartSecurityLevelVO
bb.common.box

Uses of PartSecurityLevelVO in bb.common.box

Methods in bb.common.box that return PartSecurityLevelVO
PartSecurityLevelVO | EngineeringBox.addPartSecurityLevel(PartSecurityLevelVO vo)
PartSecurityLevelVO | EngineeringBox.getPartSecurityLevelByPk(java.lang.String levelId)

Methods in bb.common.box that return types with arguments of type PartSecurityLevelVO
java.util.Collection<PartSecurityLevelVO> | EngineeringBox.findAllPartSecurityLevel(int firstIndex, int maxLength)
java.util.Collection<PartSecurityLevelVO> | EngineeringBox.findPartSecurityLevelById(java.lang.String levelId, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type PartSecurityLevelVO
PartSecurityLevelVO | EngineeringBox.addPartSecurityLevel(PartSecurityLevelVO vo)
void | EngineeringBox.updatePartSecurityLevel(PartSecurityLevelVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartsToDeleteResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartsToDeleteResult

No usage of bb.common.PartsToDeleteResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartToAuditFlagResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartToAuditFlagResult

Packages that use PartToAuditFlagResult
bb.common.box

Uses of PartToAuditFlagResult in bb.common.box

Methods in bb.common.box that return types with arguments of type PartToAuditFlagResult
java.util.Collection<PartToAuditFlagResult> | EngineeringBox.getPartToAuditFlagResultsForBOM(java.lang.String pnLike)
java.util.Collection<PartToAuditFlagResult> | EngineeringBox.getPartToAuditFlagResultsForDrawing(java.lang.String pnLike)
java.util.Collection<PartToAuditFlagResult> | EngineeringBox.getPartToAuditFlagResultsForPicture(java.lang.String pnLike)
java.util.Collection<PartToAuditFlagResult> | EngineeringBox.getPartToAuditFlagResultsForWI(java.lang.String pnLike)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartTraceableCategoryPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartTraceableCategoryPK

Packages that use PartTraceableCategoryPK
bb.common
bb.common.box

Uses of PartTraceableCategoryPK in bb.common

Methods in bb.common that return PartTraceableCategoryPK
 PartTraceableCategoryPK PartTraceableCategoryVO.getPk()

Methods in bb.common with parameters of type PartTraceableCategoryPK
 void PartTraceableCategoryVO.setPk(PartTraceableCategoryPK pk)

Uses of PartTraceableCategoryPK in bb.common.box

Methods in bb.common.box with parameters of type PartTraceableCategoryPK
 PartTraceableCategoryVO EngineeringBox.getPartTraceableCategoryByPk(PartTraceableCategoryPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartTraceableCategoryVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartTraceableCategoryVO

Packages that use PartTraceableCategoryVO
bb.common.box

Uses of PartTraceableCategoryVO in bb.common.box

Methods in bb.common.box that return PartTraceableCategoryVO
PartTraceableCategoryVO | EngineeringBox.addPartTraceableCategory(PartTraceableCategoryVO partTraceableCategoryVO)
PartTraceableCategoryVO | EngineeringBox.getPartTraceableCategoryByPk(PartTraceableCategoryPK pk)

Methods in bb.common.box with parameters of type PartTraceableCategoryVO
PartTraceableCategoryVO | EngineeringBox.addPartTraceableCategory(PartTraceableCategoryVO partTraceableCategoryVO)
void | EngineeringBox.deletePartTraceableCategory(PartTraceableCategoryVO partTraceableCategoryVO)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartTraceableInfoResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartTraceableInfoResult

Packages that use PartTraceableInfoResult
bb.common.box

Uses of PartTraceableInfoResult in bb.common.box

Methods in bb.common.box that return PartTraceableInfoResult
PartTraceableInfoResult | EngineeringBox.findPartTraceableByPk(PartPK pk)
PartTraceableInfoResult | EngineeringBox.updatePartTraceableInfoResult(PartTraceableInfoResult vo)

Methods in bb.common.box that return types with arguments of type PartTraceableInfoResult
java.util.Collection<PartTraceableInfoResult> | PurchasingBox.findAllPartTraceableByPN(java.lang.String poNumber)
java.util.Collection<PartTraceableInfoResult> | SalesBox.findAllPartTraceableBySN(java.lang.String soNumber)

Methods in bb.common.box with parameters of type PartTraceableInfoResult
 PartTraceableInfoResult EngineeringBox.updatePartTraceableInfoResult(PartTraceableInfoResult vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartTraceableListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartTraceableListResult

Packages that use PartTraceableListResult
bb.common.box

Uses of PartTraceableListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type PartTraceableListResult
 java.util.Collection<PartTraceableListResult> EngineeringBox.findPartTraceableListResults(java.lang.String partNumber, java.lang.String partType, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartTraceableResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartTraceableResult

Packages that use PartTraceableResult
bb.common.box

Uses of PartTraceableResult in bb.common.box

Methods in bb.common.box that return types with arguments of type PartTraceableResult
 java.util.Collection<PartTraceableResult> EngineeringBox.findTraceableCategoriesByPart(java.lang.String partNumber, java.lang.String partType, int traceableLevel, java.lang.String[] categoryIds, java.lang.Short[] specificationIds, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartTraceableSpecPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartTraceableSpecPK

Packages that use PartTraceableSpecPK
bb.common
bb.common.box

Uses of PartTraceableSpecPK in bb.common

Methods in bb.common that return PartTraceableSpecPK
 PartTraceableSpecPK PartTraceableSpecVO.getPk()

Methods in bb.common with parameters of type PartTraceableSpecPK
 void PartTraceableSpecVO.setPk(PartTraceableSpecPK pk)

Uses of PartTraceableSpecPK in bb.common.box

Methods in bb.common.box with parameters of type PartTraceableSpecPK
void | EngineeringBox.deletePartTraceableSpec(PartTraceableSpecPK pk)
PartTraceableSpecVO | EngineeringBox.getPartTraceableSpecByPk(PartTraceableSpecPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartTraceableSpecVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartTraceableSpecVO

Packages that use PartTraceableSpecVO
bb.common.box

Uses of PartTraceableSpecVO in bb.common.box

Methods in bb.common.box that return PartTraceableSpecVO
PartTraceableSpecVO | EngineeringBox.addPartTraceableSpec(PartTraceableSpecVO partTraceableSpecVO)
PartTraceableSpecVO | EngineeringBox.getPartTraceableSpecByPk(PartTraceableSpecPK pk)

Methods in bb.common.box with parameters of type PartTraceableSpecVO
PartTraceableSpecVO | EngineeringBox.addPartTraceableSpec(PartTraceableSpecVO partTraceableSpecVO)
void | EngineeringBox.deletePartTraceableSpec(PartTraceableSpecVO partTraceableSpecVO)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartTrackingPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartTrackingPK

Packages that use PartTrackingPK
bb.common
bb.common.box

Uses of PartTrackingPK in bb.common

Methods in bb.common that return PartTrackingPK
 PartTrackingPK PartTrackingVO.getPk()

Methods in bb.common with parameters of type PartTrackingPK
 void PartTrackingVO.setPk(PartTrackingPK pk)

Uses of PartTrackingPK in bb.common.box

Methods in bb.common.box with parameters of type PartTrackingPK
 PartTrackingVO QualityBox.findPartTrackingByPk(PartTrackingPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartTrackingVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartTrackingVO

Packages that use PartTrackingVO
bb.common
bb.common.box

Uses of PartTrackingVO in bb.common

Methods in bb.common that return types with arguments of type PartTrackingVO
java.util.Set<PartTrackingVO> | ShippingItemResult.getPartTracking()
java.util.Set<PartTrackingVO> | ReceivingItemResult.getPartTracking()
java.util.Set<PartTrackingVO> | IssuingItemResult.getPartTracking()
java.util.Set<PartTrackingVO> | DisassembleWorkOrderIssuingItemResult.getPartTracking()

Method parameters in bb.common with type arguments of type PartTrackingVO
void | ShippingItemResult.setPartTracking(java.util.Set<PartTrackingVO> partTracking)
void | ReceivingItemResult.setPartTracking(java.util.Set<PartTrackingVO> partTracking)
void | IssuingItemResult.setPartTracking(java.util.Set<PartTrackingVO> partTracking)
void | DisassembleWorkOrderIssuingItemResult.setPartTracking(java.util.Set<PartTrackingVO> partTracking)

Uses of PartTrackingVO in bb.common.box

Methods in bb.common.box that return PartTrackingVO
 PartTrackingVO QualityBox.findPartTrackingByPk(PartTrackingPK pk)

Methods in bb.common.box that return types with arguments of type PartTrackingVO
 java.util.Collection<PartTrackingVO> QualityBox.findPartTracking(PartPK pk)

Method parameters in bb.common.box with type arguments of type PartTrackingVO
 void QualityBox.addMultiplePartTracking(java.util.Collection<PartTrackingVO> partTrackings)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartTypeVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartTypeVO

Packages that use PartTypeVO
bb.common.box

Uses of PartTypeVO in bb.common.box

Methods in bb.common.box that return PartTypeVO
PartTypeVO | CompanyBox.addPartType(PartTypeVO vo)
PartTypeVO | CompanyBox.getPartTypeByID(java.lang.String partType)

Methods in bb.common.box that return types with arguments of type PartTypeVO
java.util.Collection<PartTypeVO> | CompanyBox.deletePartType(java.lang.String partType)
java.util.Collection<PartTypeVO> | CompanyBox.findAllDocumentType()
java.util.Collection<PartTypeVO> | CompanyBox.findAllPartType(int firstIndex, int maxLength)
java.util.Collection<PartTypeVO> | CompanyBox.findPartTypeByTypeLike(java.lang.String partTypeLike, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type PartTypeVO
PartTypeVO | CompanyBox.addPartType(PartTypeVO vo)
void | CompanyBox.updatePartType(PartTypeVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartUnitPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartUnitPK

Packages that use PartUnitPK
bb.common

Uses of PartUnitPK in bb.common

Methods in bb.common that return PartUnitPK
 PartUnitPK PartUnitVO.getPk()

Methods in bb.common with parameters of type PartUnitPK
 void PartUnitVO.setPk(PartUnitPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartUnitVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartUnitVO

Packages that use PartUnitVO
bb.common

Uses of PartUnitVO in bb.common

Methods in bb.common that return types with arguments of type PartUnitVO
java.util.Set<PartUnitVO> | RunningAccountOrderItemVO.getUnits()
java.util.Set<PartUnitVO> | PartVO.getUnits()

Method parameters in bb.common with type arguments of type PartUnitVO
void | RunningAccountOrderItemVO.setUnits(java.util.Set<PartUnitVO> units)
void | PartVO.setUnits(java.util.Set<PartUnitVO> units)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.partUsedInfoResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.partUsedInfoResult

No usage of bb.common.partUsedInfoResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartUseTypeVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartUseTypeVO

Packages that use PartUseTypeVO
bb.common.box

Uses of PartUseTypeVO in bb.common.box

Methods in bb.common.box that return PartUseTypeVO
PartUseTypeVO | WorkOrderBox.addPartUseType(PartUseTypeVO vo)
PartUseTypeVO | WorkOrderBox.findPartUseTypeByPK(java.lang.String useType)
PartUseTypeVO | WorkOrderBox.updatePartUseType(PartUseTypeVO vo)

Methods in bb.common.box that return types with arguments of type PartUseTypeVO
java.util.Collection<PartUseTypeVO> | WorkOrderBox.findAllPartUseType()
java.util.Collection<PartUseTypeVO> | WorkOrderBox.findPartUseType(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String useType, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type PartUseTypeVO
PartUseTypeVO | WorkOrderBox.addPartUseType(PartUseTypeVO vo)
void | WorkOrderBox.deletePartUseType(PartUseTypeVO vo)
PartUseTypeVO | WorkOrderBox.updatePartUseType(PartUseTypeVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartVendorPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartVendorPK

Packages that use PartVendorPK
bb.common

Uses of PartVendorPK in bb.common

Methods in bb.common that return PartVendorPK
PartVendorPK | ToolVendorVO.getPk()
PartVendorPK | PartVendorVO.getPk()

Methods in bb.common with parameters of type PartVendorPK
void | ToolVendorVO.setPk(PartVendorPK pk)
void | PartVendorVO.setPk(PartVendorPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartVendorVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartVendorVO

Packages that use PartVendorVO
bb.common.box

Uses of PartVendorVO in bb.common.box

Methods in bb.common.box that return PartVendorVO
PartVendorVO | EngineeringBox.addPartVendor(PartVendorVO vo)
PartVendorVO | EngineeringBox.InitPartVendorVoByAddressId(PartPK partPk, java.lang.String vendorId)
PartVendorVO | EngineeringBox.updatePartVendor(PartVendorVO vo)

Methods in bb.common.box that return types with arguments of type PartVendorVO
java.util.Collection<PartVendorVO> | EngineeringBox.findPartVendorsByPartPk(PartPK partPk)
java.util.Collection<PartVendorVO> | EngineeringBox.updatePartVendor(java.util.HashSet partVendorVoSet, PartPK partPk)

Methods in bb.common.box with parameters of type PartVendorVO
PartVendorVO | EngineeringBox.addPartVendor(PartVendorVO vo)
PartVendorVO | EngineeringBox.updatePartVendor(PartVendorVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartVO

Packages that use PartVO
bb.common
bb.common.box

Uses of PartVO in bb.common

Methods in bb.common that return PartVO
PartVO | ReceiverItemVO.getPart()
PartVO | OnloanReceiverItemVO.getPart()

Methods in bb.common with parameters of type PartVO
void | ReceiverItemVO.setPart(PartVO part)
void | OnloanReceiverItemVO.setPart(PartVO part)

Uses of PartVO in bb.common.box

Methods in bb.common.box that return PartVO
PartVO | EngineeringBox.copyPart(PartPK pk, java.lang.String rev, java.lang.String partUnit, java.lang.String description, PartPK oldPk, boolean onlyChangeParType)
PartVO | EngineeringBox.findPart(PartPK pk)

Methods in bb.common.box that return types with arguments of type PartVO
java.util.List<PartVO> | EngineeringBox.findPartPKByMpn(java.lang.String mpn)
java.util.Collection<PartVO> | EngineeringBox.findPartPKByPartNumber(java.lang.String partNumber)
java.util.Collection<PartVO> | EngineeringBox.findPartsByPK(PartPK pk, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type PartVO
PartPK | EngineeringBox.addPart(PartVO vo)
PartPK | EngineeringBox.updatePart(PartVO partVO)

Method parameters in bb.common.box with type arguments of type PartVO
void | CompanyBox.importPartMinMaxQty(java.util.ArrayList<PartVO> parts)
void | CompanyBox.importTempPart(java.util.ArrayList<PartVO> datas)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartWhereUsedItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartWhereUsedItemResult

No usage of bb.common.PartWhereUsedItemResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartWhereUsedResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartWhereUsedResult

Packages that use PartWhereUsedResult
bb.common.box

Uses of PartWhereUsedResult in bb.common.box

Methods in bb.common.box that return PartWhereUsedResult
 PartWhereUsedResult EngineeringBox.findPartWhereIsUsed(PartPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartWithExcessiveInventoryListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartWithExcessiveInventoryListResult

Packages that use PartWithExcessiveInventoryListResult
bb.common.box

Uses of PartWithExcessiveInventoryListResult in bb.common.box

Methods in bb.common.box that return PartWithExcessiveInventoryListResult
 PartWithExcessiveInventoryListResult WarehouseBox.getPartWithExcessiveInventoryTotal(boolean addMaxQty)

Methods in bb.common.box that return types with arguments of type PartWithExcessiveInventoryListResult
java.util.Collection<PartWithExcessiveInventoryListResult> | WarehouseBox.findPartWithExcessiveInventoryListResults(boolean addMaxQty, int firstIndex, int length)
java.util.Collection<PartWithExcessiveInventoryListResult> | WarehouseBox.findPartWithExcessiveInventoryListResults(java.lang.String pnExp, java.lang.String paExp, int firstIndex, int length)
java.util.Collection<PartWithExcessiveInventoryListResult> | WarehouseBox.findToolWithExcessiveInventoryListResults(java.lang.String pnExp, java.lang.String paExp, int firstIndex, int length)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartWithInventoryInfoListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartWithInventoryInfoListResult

Packages that use PartWithInventoryInfoListResult
bb.common.box

Uses of PartWithInventoryInfoListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type PartWithInventoryInfoListResult
 java.util.Collection<PartWithInventoryInfoListResult> PurchasingBox.findPartByBuyerCode(java.lang.String buyerCode, java.lang.String languageCode, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartWithManufacturerInfoResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartWithManufacturerInfoResult

Packages that use PartWithManufacturerInfoResult
bb.common
bb.common.box

Uses of PartWithManufacturerInfoResult in bb.common

Subclasses of PartWithManufacturerInfoResult in bb.common
 class ToolWithManufacturerInfoResult

Uses of PartWithManufacturerInfoResult in bb.common.box

Methods in bb.common.box that return types with arguments of type PartWithManufacturerInfoResult
java.util.Collection<PartWithManufacturerInfoResult> | EngineeringBox.findPartsByManufacturerId(java.lang.String mfgIdRegex, int firstIndex, int maxLength)
java.util.Collection<PartWithManufacturerInfoResult> | EngineeringBox.findPartsByManufacturerPn(java.lang.String mpnRegex, int firstIndex, int maxLength)
java.util.Collection<PartWithManufacturerInfoResult> | EngineeringBox.findPartsByManufacturerPnStartWith(java.lang.String mpnRegex, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartWithOnhandDetailInfoResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartWithOnhandDetailInfoResult

Packages that use PartWithOnhandDetailInfoResult
bb.common.box

Uses of PartWithOnhandDetailInfoResult in bb.common.box

Methods in bb.common.box that return PartWithOnhandDetailInfoResult
PartWithOnhandDetailInfoResult | WarehouseBox.adjustInventory(java.util.ArrayList partOnhandWithAverageCostList, BB2Part part, java.lang.String comments)
PartWithOnhandDetailInfoResult | WarehouseBox.getPartOnhandDetailInfoByPartPk(BB2Part part)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartWithOnhandsVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartWithOnhandsVO

Packages that use PartWithOnhandsVO
bb.common.box

Uses of PartWithOnhandsVO in bb.common.box

Methods in bb.common.box that return PartWithOnhandsVO
 PartWithOnhandsVO EngineeringBox.getPartWithOnhands(PartPK pk)

Methods in bb.common.box with parameters of type PartWithOnhandsVO
 void EngineeringBox.updatePartWithOnhands(PartWithOnhandsVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartWithOnLoanQtyListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartWithOnLoanQtyListResult

Packages that use PartWithOnLoanQtyListResult
bb.common.box

Uses of PartWithOnLoanQtyListResult in bb.common.box

Methods in bb.common.box that return PartWithOnLoanQtyListResult
 PartWithOnLoanQtyListResult WarehouseBox.getPartOnLoanTotalAmount()

Methods in bb.common.box that return types with arguments of type PartWithOnLoanQtyListResult
 java.util.Collection<PartWithOnLoanQtyListResult> WarehouseBox.findPartOnLoanQtyListResults(int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartWithoutLocateResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartWithoutLocateResult

Packages that use PartWithoutLocateResult
bb.common.box

Uses of PartWithoutLocateResult in bb.common.box

Methods in bb.common.box that return types with arguments of type PartWithoutLocateResult
 java.util.Collection<PartWithoutLocateResult> WarehouseBox.findPartWithoutLocationList(PartPK pk, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartWithQAQtyListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartWithQAQtyListResult

Packages that use PartWithQAQtyListResult
bb.common.box

Uses of PartWithQAQtyListResult in bb.common.box

Methods in bb.common.box that return PartWithQAQtyListResult
 PartWithQAQtyListResult WarehouseBox.getPartWithQAQtyTotal()

Methods in bb.common.box that return types with arguments of type PartWithQAQtyListResult
 java.util.Collection<PartWithQAQtyListResult> WarehouseBox.findPartWithQAQtyListResults(boolean includesDetails, int firstIndex, int length)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartWithQtyListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartWithQtyListResult

Packages that use PartWithQtyListResult
bb.common.box

Uses of PartWithQtyListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type PartWithQtyListResult
java.util.Collection<PartWithQtyListResult> | WarehouseBox.findPartOnDemandQtyListResults(int firstIndex, int maxLength)
java.util.Collection<PartWithQtyListResult> | WarehouseBox.findPartOnOrderQtyListResults(int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartWithSipQtyListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartWithSipQtyListResult

Packages that use PartWithSipQtyListResult
bb.common.box

Uses of PartWithSipQtyListResult in bb.common.box

Methods in bb.common.box that return PartWithSipQtyListResult
 PartWithSipQtyListResult WarehouseBox.getPartWithSipQtyTotal()

Methods in bb.common.box that return types with arguments of type PartWithSipQtyListResult
 java.util.Collection<PartWithSipQtyListResult> WarehouseBox.findPartWithSipQtyListResults(boolean includesDetails, int firstIndex, int length)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartWithSITQtyListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartWithSITQtyListResult

Packages that use PartWithSITQtyListResult
bb.common.box

Uses of PartWithSITQtyListResult in bb.common.box

Methods in bb.common.box that return PartWithSITQtyListResult
 PartWithSITQtyListResult WarehouseBox.getPartWithSITQtyTotal(java.lang.String pnExp, java.lang.String paExp, boolean isTool)

Methods in bb.common.box that return types with arguments of type PartWithSITQtyListResult
 java.util.Collection<PartWithSITQtyListResult> WarehouseBox.findPartWithSITQtyListResults(java.lang.String pnExp, java.lang.String paExp, boolean isTool, boolean includesRefDetails, int firstIndex, int length)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartWithSTOQtyListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartWithSTOQtyListResult

Packages that use PartWithSTOQtyListResult
bb.common.box

Uses of PartWithSTOQtyListResult in bb.common.box

Methods in bb.common.box that return PartWithSTOQtyListResult
 PartWithSTOQtyListResult WarehouseBox.getPartWithSTOQtyTotal(java.lang.String pnExp, java.lang.String paExp, boolean isTool)

Methods in bb.common.box that return types with arguments of type PartWithSTOQtyListResult
 java.util.Collection<PartWithSTOQtyListResult> WarehouseBox.findPartWithSTOQtyListResults(java.lang.String pnExp, java.lang.String paExp, boolean isIncludeRefDetails, boolean isTool, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PartWithWipQtyListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PartWithWipQtyListResult

Packages that use PartWithWipQtyListResult
bb.common.box

Uses of PartWithWipQtyListResult in bb.common.box

Methods in bb.common.box that return PartWithWipQtyListResult
 PartWithWipQtyListResult WarehouseBox.getTotalPartWithWipQtyCost()

Methods in bb.common.box that return types with arguments of type PartWithWipQtyListResult
java.util.Collection<PartWithWipQtyListResult> | WarehouseBox.findPartWithWipQtyListResults(boolean includesDetails, int firstIndex, int length)
java.util.Collection<PartWithWipQtyListResult> | WarehouseBox.findPartWithWipQtyListResults(java.lang.String pnExp, java.lang.String paExp, int firstIndex, int length)
java.util.Collection<PartWithWipQtyListResult> | WarehouseBox.findToolWithWipQtyListResults(java.lang.String pnExp, java.lang.String paExp, int firstIndex, int length)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PasswordPolicyAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PasswordPolicyAgent

Packages that use PasswordPolicyAgent
bb.common.box

Uses of PasswordPolicyAgent in bb.common.box

Methods in bb.common.box with parameters of type PasswordPolicyAgent
 java.lang.Boolean CompanyBox.updatePasswordPolicy(PasswordPolicyAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PayableCheckRunItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PayableCheckRunItemPK

Packages that use PayableCheckRunItemPK
bb.common

Uses of PayableCheckRunItemPK in bb.common

Methods in bb.common that return PayableCheckRunItemPK
 PayableCheckRunItemPK AccountPayableCheckRunItemVO.getPk()

Methods in bb.common with parameters of type PayableCheckRunItemPK
 void AccountPayableCheckRunItemVO.setPk(PayableCheckRunItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PayableMethodVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PayableMethodVO

Packages that use PayableMethodVO
bb.common.box

Uses of PayableMethodVO in bb.common.box

Methods in bb.common.box that return PayableMethodVO
PayableMethodVO | CompanyBox.addPayment(PayableMethodVO vo)
PayableMethodVO | CompanyBox.getPayment()
PayableMethodVO | CompanyBox.getPaymentById(int paymentId)
PayableMethodVO | CompanyBox.getPaymentByName(java.lang.String paymentName)
PayableMethodVO | CompanyBox.updatePayment(PayableMethodVO vo)

Methods in bb.common.box that return types with arguments of type PayableMethodVO
 java.util.Collection<PayableMethodVO> CompanyBox.findPayment(java.lang.String paymentName)

Methods in bb.common.box with parameters of type PayableMethodVO
PayableMethodVO | CompanyBox.addPayment(PayableMethodVO vo)
void | CompanyBox.deletePayment(PayableMethodVO vo)
PayableMethodVO | CompanyBox.updatePayment(PayableMethodVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PaymentAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PaymentAgent

Packages that use PaymentAgent
bb.common.box

Uses of PaymentAgent in bb.common.box

Methods in bb.common.box with parameters of type PaymentAgent
void | AccountingBox.addAPPayment(PaymentAgent apPaymentAgent)
void | AccountingBox.addAPPaymentWithMultiplePrepay(PaymentAgent apPaymentAgent)
void | AccountingBox.addAPPaymentWithPrepay(PaymentAgent apPaymentAgent)
void | AccountingBox.addArPayment(PaymentAgent arPaymentAgent)
void | AccountingBox.addARPaymentWithMultiplePrepay(PaymentAgent arPaymentAgent)
void | AccountingBox.addARPaymentWithPrepay(PaymentAgent arPaymentAgent)

Method parameters in bb.common.box with type arguments of type PaymentAgent
 java.lang.String AccountingBox.makeDepositGL(java.util.List<DepositSummaryResult> list, java.util.ArrayList<PaymentAgent> agentList)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PaymentHistoryVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PaymentHistoryVO

Packages that use PaymentHistoryVO
bb.common.box

Uses of PaymentHistoryVO in bb.common.box

Methods in bb.common.box that return types with arguments of type PaymentHistoryVO
 java.util.Collection<PaymentHistoryVO> AccountingBox.findPaymentHistory(int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PaymentInvoicesResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PaymentInvoicesResult

Packages that use PaymentInvoicesResult
bb.common

Uses of PaymentInvoicesResult in bb.common

Methods in bb.common that return types with arguments of type PaymentInvoicesResult
 java.util.List<PaymentInvoicesResult> CustomerStatementResult.getPaymentInvoices()

Method parameters in bb.common with type arguments of type PaymentInvoicesResult
 void CustomerStatementResult.setPaymentInvoices(java.util.List<PaymentInvoicesResult> paymentInvoices)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PaymentRunItemTotalResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PaymentRunItemTotalResult

Packages that use PaymentRunItemTotalResult
bb.common.box

Uses of PaymentRunItemTotalResult in bb.common.box

Methods in bb.common.box that return PaymentRunItemTotalResult
 PaymentRunItemTotalResult AccountingBox.getPaymentRunItemTotal(java.lang.String paymentRunNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PaymentVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PaymentVO

No usage of bb.common.PaymentVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PermissionDescriptionPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PermissionDescriptionPK

Packages that use PermissionDescriptionPK
bb.common

Uses of PermissionDescriptionPK in bb.common

Methods in bb.common that return PermissionDescriptionPK
 PermissionDescriptionPK PermissionDescriptionVO.getPk()

Methods in bb.common with parameters of type PermissionDescriptionPK
 void PermissionDescriptionVO.setPk(PermissionDescriptionPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PermissionDescriptionVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PermissionDescriptionVO

No usage of bb.common.PermissionDescriptionVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PermissionException

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PermissionException

No usage of bb.common.PermissionException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PermissionListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PermissionListResult

Packages that use PermissionListResult
bb.common.box

Uses of PermissionListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type PermissionListResult
java.util.Collection<PermissionListResult> | SecurityBox.findAllPermissionWithLanguage(boolean leaf, java.lang.String language, int firstIndex, int maxLength)
java.util.Collection<PermissionListResult> | SecurityBox.findPermissionsById(java.lang.String permissionId, java.lang.String language, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PermissionMethodPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PermissionMethodPK

Packages that use PermissionMethodPK
bb.common
bb.common.box

Uses of PermissionMethodPK in bb.common

Methods in bb.common that return PermissionMethodPK
 PermissionMethodPK PermissionMethodVO.getPk()

Methods in bb.common with parameters of type PermissionMethodPK
 void PermissionMethodVO.setPk(PermissionMethodPK pk)

Constructors in bb.common with parameters of type PermissionMethodPK
PermissionMethodVO(PermissionMethodPK pk)
full constructor

Uses of PermissionMethodPK in bb.common.box

Methods in bb.common.box with parameters of type PermissionMethodPK
 PermissionMethodVO SecurityBox.getPermissionMethodByPk(PermissionMethodPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PermissionMethodVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PermissionMethodVO

Packages that use PermissionMethodVO
bb.common.box

Uses of PermissionMethodVO in bb.common.box

Methods in bb.common.box that return PermissionMethodVO
 PermissionMethodVO SecurityBox.getPermissionMethodByPk(PermissionMethodPK pk)

Methods in bb.common.box that return types with arguments of type PermissionMethodVO
java.util.Collection<PermissionMethodVO> | SecurityBox.findAllPermissionMethod(int firstIndex, int maxLength)
java.util.Collection<PermissionMethodVO> | SecurityBox.findAllPermissionMethodsByUserName(java.lang.String username)
java.util.Collection<PermissionMethodVO> | SecurityBox.findEjbMethodsByPermissionId(java.lang.String permissionId, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type PermissionMethodVO
void | SecurityBox.addPermissionMethod(PermissionMethodVO permissionMethodVo)
void | SecurityBox.deletePermissionMethod(PermissionMethodVO permissionMethodVo)
void | SecurityBox.updatePermissionMethod(PermissionMethodVO permissionMethodVo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PermissionVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PermissionVO

Packages that use PermissionVO
bb.common.box

Uses of PermissionVO in bb.common.box

Methods in bb.common.box that return PermissionVO
 PermissionVO SecurityBox.getPermissionByPK(java.lang.String permissionId)

Methods in bb.common.box that return types with arguments of type PermissionVO
java.util.Collection<PermissionVO> | SecurityBox.findAllPermission(boolean leaf, int firstIndex, int maxLength)
java.util.Collection<PermissionVO> | SecurityBox.findPermissionsByRole(java.lang.String roleId, int firstIndex, int maxLength)
java.util.Collection<PermissionVO> | SecurityBox.findPermissionsBySelf(int firstIndex, int maxLength)
java.util.Collection<PermissionVO> | SecurityBox.findPermissionsByUser(java.lang.String userName, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type PermissionVO
void | SecurityBox.addPermission(PermissionVO permissionVo)
void | SecurityBox.deletePermission(PermissionVO permissionVo)
void | SecurityBox.updatePermission(PermissionVO permissionVo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PfReceiverItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PfReceiverItemPK

Packages that use PfReceiverItemPK
bb.common

Uses of PfReceiverItemPK in bb.common

Methods in bb.common that return PfReceiverItemPK
PfReceiverItemPK | PfReceiverItemWithNumberPK.getPk()
PfReceiverItemPK | PfReceiverItemVO.getPk()

Methods in bb.common with parameters of type PfReceiverItemPK
void | PfReceiverItemWithNumberPK.setPk(PfReceiverItemPK pk)
void | PfReceiverItemVO.setPk(PfReceiverItemPK pk)

Constructors in bb.common with parameters of type PfReceiverItemPK
PfReceiverItemWithNumberPK(PfReceiverItemPK pk, java.lang.String pfReceiverItemNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PfReceiverItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PfReceiverItemVO

Packages that use PfReceiverItemVO
bb.common.box

Uses of PfReceiverItemVO in bb.common.box

Methods in bb.common.box with parameters of type PfReceiverItemVO
 java.lang.String PurchasingBox.finishProformaReceiver(java.lang.String pfReceiverNumber, PfReceiverItemVO itemVO, java.util.HashSet<PrPackingBoxItemVO> boxItemVOs, java.lang.String receiverNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PfReceiverItemWithNumberPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PfReceiverItemWithNumberPK

No usage of bb.common.PfReceiverItemWithNumberPK

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PfReceiverVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PfReceiverVO

Packages that use PfReceiverVO
bb.common.box

Uses of PfReceiverVO in bb.common.box

Methods in bb.common.box that return PfReceiverVO
 PfReceiverVO PurchasingBox.getPfReceiver(java.lang.String pfReceiverNumber)

Methods in bb.common.box with parameters of type PfReceiverVO
 void PurchasingBox.updatePfReceiver(PfReceiverVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PhysicalInventoryListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PhysicalInventoryListResult

Packages that use PhysicalInventoryListResult
bb.common
bb.common.box

Uses of PhysicalInventoryListResult in bb.common

Subclasses of PhysicalInventoryListResult in bb.common
 class PhysicalInventoryListWithAppDataResult

Uses of PhysicalInventoryListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type PhysicalInventoryListResult
java.util.Collection<PhysicalInventoryListResult> | WarehouseBox.findCommitPhysicalInventoryListResults(int worksheetNumber, boolean showUnCommittedOnly, int firstIndex, int maxLength)
java.util.Collection<PhysicalInventoryListResult> | WarehouseBox.findPhysicalInventoryListByPartNumber(int worksheetNumber, java.lang.String pnLike, java.lang.String partType, java.lang.String location, int firstIndex, int maxLength)
java.util.Collection<PhysicalInventoryListResult> | WarehouseBox.findPhysicalInventoryListResults(int worksheetNumber, int firstIndex, int maxLength)
java.util.Collection<PhysicalInventoryListResult> | WarehouseBox.findPhysicalInventoryListResults(int worksheetNumber, int pageNubmer, int firstIndex, int maxLength)
java.util.Collection<PhysicalInventoryListResult> | WarehouseBox.findPhysicalInventoryListResultsByLocation(int worksheetNumber, java.lang.String location)
java.util.Collection<PhysicalInventoryListResult> | WarehouseBox.findPhysicalInventoryListResultsWithAvgCost(int worksheetNumber, int pageNubmer, int firstIndex, int maxLength)

Method parameters in bb.common.box with type arguments of type PhysicalInventoryListResult
 java.lang.String WarehouseBox.makePhysicalInventoryGL(java.math.BigDecimal commitTotal, java.util.ArrayList<PhysicalInventoryListResult> result, java.lang.String glCategory, java.lang.String[] inventoryAccount, java.lang.String[] assetLossesAccount)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PhysicalInventoryListTotalResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PhysicalInventoryListTotalResult

Packages that use PhysicalInventoryListTotalResult
bb.common.box

Uses of PhysicalInventoryListTotalResult in bb.common.box

Methods in bb.common.box that return PhysicalInventoryListTotalResult
PhysicalInventoryListTotalResult | WarehouseBox.getPhysicalInventoryListTotalResultWithAvgCost(int worksheetNumber, int pageNubmer)
PhysicalInventoryListTotalResult | WarehouseBox.getPhysicalInventoryTotalResultWithAvgCost(int worksheetNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PhysicalInventoryListWithAppDataResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PhysicalInventoryListWithAppDataResult

No usage of bb.common.PhysicalInventoryListWithAppDataResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PhysicalInventoryPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PhysicalInventoryPK

Packages that use PhysicalInventoryPK
bb.common
bb.common.box

Uses of PhysicalInventoryPK in bb.common

Methods in bb.common that return PhysicalInventoryPK
PhysicalInventoryPK | UpdatePhysicalInventoryAgent.getPk()
PhysicalInventoryPK | PhysicalInventoryVO.getPk()
PhysicalInventoryPK | PhysicalInventoryListResult.getPk()

Methods in bb.common with parameters of type PhysicalInventoryPK
void | UpdatePhysicalInventoryAgent.setPk(PhysicalInventoryPK pk)
void | PhysicalInventoryVO.setPk(PhysicalInventoryPK pk)
void | PhysicalInventoryListResult.setPk(PhysicalInventoryPK pk)

Uses of PhysicalInventoryPK in bb.common.box

Methods in bb.common.box that return PhysicalInventoryPK
 PhysicalInventoryPK WarehouseBox.addPhysicalInventory(AddPhysicalInventoryAgent agent)

Methods in bb.common.box that return types with arguments of type PhysicalInventoryPK
 java.util.Collection<PhysicalInventoryPK> WarehouseBox.updatePhysicalInventory(java.util.ArrayList list)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PhysicalInventoryStatusVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PhysicalInventoryStatusVO

Packages that use PhysicalInventoryStatusVO
bb.common.box

Uses of PhysicalInventoryStatusVO in bb.common.box

Methods in bb.common.box that return PhysicalInventoryStatusVO
 PhysicalInventoryStatusVO WarehouseBox.getPhysicalInventoryStatusVO(int workSheetNumber)

Methods in bb.common.box that return types with arguments of type PhysicalInventoryStatusVO
 java.util.Collection<PhysicalInventoryStatusVO> WarehouseBox.findPhysicalWorkSheetListResults(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type PhysicalInventoryStatusVO
 int WarehouseBox.updatePhysicalInventoryStatus(PhysicalInventoryStatusVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PhysicalInventoryVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PhysicalInventoryVO

No usage of bb.common.PhysicalInventoryVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PO2POAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PO2POAgent

Packages that use PO2POAgent
bb.common.box

Uses of PO2POAgent in bb.common.box

Methods in bb.common.box with parameters of type PO2POAgent
 java.lang.String PurchasingBox.copyPurchaseOrderFromPurchaseOrder(PO2POAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PO2SOExchange

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PO2SOExchange

Packages that use PO2SOExchange
bb.common.box

Uses of PO2SOExchange in bb.common.box

Methods in bb.common.box that return PO2SOExchange
 PO2SOExchange PurchasingBox.createPO2SOExchange(java.lang.String poNumber)

Methods in bb.common.box with parameters of type PO2SOExchange
 SalesOrderVO SalesBox.createSalesOrderByExchange(PO2SOExchange exchange)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PO2SOExchangeItem

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PO2SOExchangeItem

No usage of bb.common.PO2SOExchangeItem

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PO2SOExchangeItemManufacturer

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PO2SOExchangeItemManufacturer

No usage of bb.common.PO2SOExchangeItemManufacturer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.POAndWOStatusResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.POAndWOStatusResult

Packages that use POAndWOStatusResult
bb.common.box

Uses of POAndWOStatusResult in bb.common.box

Methods in bb.common.box that return POAndWOStatusResult
 POAndWOStatusResult WorkOrderBox.findPOAndWOStatus(java.util.Date fromDate, java.util.Date toDate, java.lang.String project)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.POForWISeqAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.POForWISeqAgent

Packages that use POForWISeqAgent
bb.common.box

Uses of POForWISeqAgent in bb.common.box

Methods in bb.common.box with parameters of type POForWISeqAgent
java.util.Collection<java.lang.String> | PurchasingBox.addPurchaseOrderFromWISeq(POForWISeqAgent agent)
java.util.Collection<java.lang.String> | ManufacturingBox.addPurchaseOrderFromWISeq(POForWISeqAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PointOfSaleVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PointOfSaleVO

Packages that use PointOfSaleVO
bb.common.box

Uses of PointOfSaleVO in bb.common.box

Methods in bb.common.box that return PointOfSaleVO
PointOfSaleVO | CompanyBox.getPointOfSale()
PointOfSaleVO | CompanyBox.updatePointOfSale(PointOfSaleVO vo)

Methods in bb.common.box with parameters of type PointOfSaleVO
 PointOfSaleVO CompanyBox.updatePointOfSale(PointOfSaleVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.POItemByRefDoc1ListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.POItemByRefDoc1ListResult

Packages that use POItemByRefDoc1ListResult
bb.common.box

Uses of POItemByRefDoc1ListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type POItemByRefDoc1ListResult
 java.util.Collection<POItemByRefDoc1ListResult> PurchasingBox.findPurchaseOrderItemsByRefDoc1(java.lang.String startWith, java.lang.String status, java.lang.String dateType, java.util.Date startDate, java.util.Date toDate, java.lang.String refDoc, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PoMessageItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PoMessageItemPK

Packages that use PoMessageItemPK
bb.common

Uses of PoMessageItemPK in bb.common

Methods in bb.common that return PoMessageItemPK
 PoMessageItemPK PoMessageItemVO.getPk()

Methods in bb.common with parameters of type PoMessageItemPK
 void PoMessageItemVO.setPk(PoMessageItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PoMessageItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PoMessageItemVO

Packages that use PoMessageItemVO
bb.common

Uses of PoMessageItemVO in bb.common

Methods in bb.common that return types with arguments of type PoMessageItemVO
 java.util.Set<PoMessageItemVO> PoMessageVO.getItems()

Method parameters in bb.common with type arguments of type PoMessageItemVO
 void PoMessageVO.setItems(java.util.Set<PoMessageItemVO> items)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PoMessageListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PoMessageListResult

Packages that use PoMessageListResult
bb.common.box

Uses of PoMessageListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type PoMessageListResult
java.util.Collection<PoMessageListResult> | PurchasingBox.findAllPoMessages()
java.util.Collection<PoMessageListResult> | PurchasingBox.findPoMessagesByStatusAndID(java.lang.String[] status, java.lang.String vendorIdLike, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PoMessageVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PoMessageVO

Packages that use PoMessageVO
bb.common.box

Uses of PoMessageVO in bb.common.box

Methods in bb.common.box that return PoMessageVO
PoMessageVO | PurchasingBox.acceptPoMessage(java.lang.String poMessageNumber, java.lang.String comments, java.util.Hashtable itemComments)
PoMessageVO | PurchasingBox.addPoMessage(java.lang.String poNumber)
PoMessageVO | PurchasingBox.getPoMessage(java.lang.String poMessageNumber)
PoMessageVO | PurchasingBox.getPoMessageByPoNumber(java.lang.String poNumber)
PoMessageVO | PurchasingBox.refusePoMessage(java.lang.String poMessageNumber, java.lang.String comments, java.util.Hashtable itemComments, boolean updatePo)
PoMessageVO | PurchasingBox.savePoMessage(java.lang.String poMessageNumber, java.lang.String comments, java.util.Hashtable itemComments)
PoMessageVO | PurchasingBox.updatePoMessageByVendor(PoMessageVO vo)

Methods in bb.common.box with parameters of type PoMessageVO
 PoMessageVO PurchasingBox.updatePoMessageByVendor(PoMessageVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PoReceiverByDateSummaryResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PoReceiverByDateSummaryResult

Packages that use PoReceiverByDateSummaryResult
bb.common.box

Uses of PoReceiverByDateSummaryResult in bb.common.box

Methods in bb.common.box that return PoReceiverByDateSummaryResult
 PoReceiverByDateSummaryResult WarehouseBox.getPoReceiverByDateSummaryResult(java.lang.String vendorId, java.lang.String pnLike, java.lang.String paType, java.util.Date fromDate, java.util.Date toDate, java.lang.String rstatus)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.POReceiverItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.POReceiverItemListResult

Packages that use POReceiverItemListResult
bb.common.box

Uses of POReceiverItemListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type POReceiverItemListResult
java.util.Collection<POReceiverItemListResult> | WarehouseBox.findOpenPOReceiverItemsByPartPK(PartPK partPk, int firstIndex, int maxLength)
java.util.Collection<POReceiverItemListResult> | WarehouseBox.findPOReceiverItems(java.lang.String poNumber, java.lang.String project, java.lang.String vendorId, java.lang.String pn, java.lang.String pa, java.lang.String paFrom, java.util.Date fromDate, java.util.Date toDate, java.lang.String status, java.lang.String currency, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String[] branchWarehouses, int firstIndex, int maxLength)
java.util.Collection<POReceiverItemListResult> | WarehouseBox.findPOReceiverItemsByPartPK(PartPK partPk, int firstIndex, int maxLength)
java.util.Collection<POReceiverItemListResult> | WarehouseBox.findPoReceiverItemsByPoNumber(java.lang.String poNumber)
java.util.Collection<POReceiverItemListResult> | WarehouseBox.findPoReceiverItemWithAPListResultsByDate(java.lang.String recNumber, java.lang.String vendorId, java.lang.String pnLike, java.lang.String paType, java.lang.String paFrom, java.util.Date fromDate, java.util.Date toDate, java.lang.String rstatus, java.lang.String currency, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String apNumber, java.lang.String apItemStatus, int firstIndex, int maxLength)
java.util.List<POReceiverItemListResult> | WarehouseBox.findReceiversByBuyerCode(java.lang.String buyerCode, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PosRefdocVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PosRefdocVO

No usage of bb.common.PosRefdocVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.POStatisticsResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.POStatisticsResult

Packages that use POStatisticsResult
bb.common.box

Uses of POStatisticsResult in bb.common.box

Methods in bb.common.box that return types with arguments of type POStatisticsResult
 java.util.Collection<POStatisticsResult> PurchasingBox.findAllPurchaseOrderStatistics(java.lang.String project, java.lang.String relatedDoc, java.lang.String vendorName, java.lang.String requester, java.lang.String contact, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PostCheckAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PostCheckAgent

Packages that use PostCheckAgent
bb.common.box

Uses of PostCheckAgent in bb.common.box

Methods in bb.common.box with parameters of type PostCheckAgent
 void AccountingBox.postCheck(PostCheckAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.POSurveyReportAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.POSurveyReportAgent

Packages that use POSurveyReportAgent
bb.common.box

Uses of POSurveyReportAgent in bb.common.box

Methods in bb.common.box with parameters of type POSurveyReportAgent
 java.lang.String QualityBox.addPOSurveyReportWithPO(POSurveyReportAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.POSurveyReportItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.POSurveyReportItemPK

Packages that use POSurveyReportItemPK
bb.common

Uses of POSurveyReportItemPK in bb.common

Methods in bb.common that return POSurveyReportItemPK
 POSurveyReportItemPK POSurveyReportItemVO.getPk()

Methods in bb.common with parameters of type POSurveyReportItemPK
 void POSurveyReportItemVO.setPk(POSurveyReportItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.POSurveyReportItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.POSurveyReportItemVO

Packages that use POSurveyReportItemVO
bb.common

Uses of POSurveyReportItemVO in bb.common

Methods in bb.common that return types with arguments of type POSurveyReportItemVO
java.util.Set<POSurveyReportItemVO> | POSurveyReportVO.getPoSurveyReportItem()
java.util.Set<POSurveyReportItemVO> | POSurveyReportAgent.getPoSurveyReportItem()

Method parameters in bb.common with type arguments of type POSurveyReportItemVO
void | POSurveyReportVO.setPoSurveyReportItem(java.util.Set<POSurveyReportItemVO> poSurveyReportItem)
void | POSurveyReportAgent.setPoSurveyReportItem(java.util.Set<POSurveyReportItemVO> poSurveyReportItem)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.POSurveyReportVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.POSurveyReportVO

Packages that use POSurveyReportVO
bb.common.box

Uses of POSurveyReportVO in bb.common.box

Methods in bb.common.box that return POSurveyReportVO
POSurveyReportVO | QualityBox.getPOSurveyReport(java.lang.String srNumber)
POSurveyReportVO | QualityBox.updatePOSurveyReport(POSurveyReportVO vo)

Methods in bb.common.box that return types with arguments of type POSurveyReportVO
 java.util.Collection<POSurveyReportVO> QualityBox.findPOSurveyReport(java.lang.String srNumber, java.lang.String purchaseOrderNumber, java.lang.String vendorId, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type POSurveyReportVO
 POSurveyReportVO QualityBox.updatePOSurveyReport(POSurveyReportVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PosZipCodeTaxPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PosZipCodeTaxPK

Packages that use PosZipCodeTaxPK
bb.common
bb.common.box

Uses of PosZipCodeTaxPK in bb.common

Methods in bb.common that return PosZipCodeTaxPK
 PosZipCodeTaxPK PosZipCodeTaxVO.getPk()

Methods in bb.common with parameters of type PosZipCodeTaxPK
 void PosZipCodeTaxVO.setPk(PosZipCodeTaxPK pk)

Uses of PosZipCodeTaxPK in bb.common.box

Methods in bb.common.box with parameters of type PosZipCodeTaxPK
 PosZipCodeTaxVO CompanyBox.getPosZipCodeTaxByPK(PosZipCodeTaxPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PosZipCodeTaxVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PosZipCodeTaxVO

Packages that use PosZipCodeTaxVO
bb.common.box

Uses of PosZipCodeTaxVO in bb.common.box

Methods in bb.common.box that return PosZipCodeTaxVO
PosZipCodeTaxVO | CompanyBox.addPosZipCodeTax(PosZipCodeTaxVO vo)
PosZipCodeTaxVO | CompanyBox.getPosZipCodeTaxByPK(PosZipCodeTaxPK pk)
PosZipCodeTaxVO | CompanyBox.getPosZipCodeTaxByZipCode(java.lang.String zipCode)

Methods in bb.common.box that return types with arguments of type PosZipCodeTaxVO
 java.util.Collection<PosZipCodeTaxVO> CompanyBox.findPosZipCodeTaxsList()

Methods in bb.common.box with parameters of type PosZipCodeTaxVO
 PosZipCodeTaxVO CompanyBox.addPosZipCodeTax(PosZipCodeTaxVO vo)

Method parameters in bb.common.box with type arguments of type PosZipCodeTaxVO
 void CompanyBox.updatePosZipCodeTaxs(java.util.Collection<PosZipCodeTaxVO> list)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PrepayAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PrepayAgent

Packages that use PrepayAgent
bb.common.box

Uses of PrepayAgent in bb.common.box

Methods in bb.common.box with parameters of type PrepayAgent
java.lang.String | AccountingBox.makePurchaseOrderPrepayNumber(PrepayAgent agent)
java.lang.String | AccountingBox.makeSalesOrderPrepayNumber(PrepayAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PrepaymentWireTransferAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PrepaymentWireTransferAgent

Packages that use PrepaymentWireTransferAgent
bb.common.box

Uses of PrepaymentWireTransferAgent in bb.common.box

Methods in bb.common.box with parameters of type PrepaymentWireTransferAgent
 java.lang.String AccountingBox.setupAPPrepayWireTransfer(PrepaymentWireTransferAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PrepayPaymentAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PrepayPaymentAgent

Packages that use PrepayPaymentAgent
bb.common.box

Uses of PrepayPaymentAgent in bb.common.box

Methods in bb.common.box with parameters of type PrepayPaymentAgent
java.lang.String | AccountingBox.addApPrepayPayment(PrepayPaymentAgent agent)
java.lang.String | AccountingBox.addArPrepayPayment(PrepayPaymentAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PreventiveActionRequestItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PreventiveActionRequestItemVO

Packages that use PreventiveActionRequestItemVO
bb.common.box

Uses of PreventiveActionRequestItemVO in bb.common.box

Methods in bb.common.box that return types with arguments of type PreventiveActionRequestItemVO
java.util.Collection<PreventiveActionRequestItemVO> | QualityBox.deletePARDoc(MiscDocAgent agent)
java.util.Collection<PreventiveActionRequestItemVO> | QualityBox.findPARItemsByPAR(java.lang.String parNumber)
java.util.Collection<PreventiveActionRequestItemVO> | QualityBox.uploadOrUpdatePARDoc(MiscDocAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PreventiveActionRequestVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PreventiveActionRequestVO

Packages that use PreventiveActionRequestVO
bb.common.box

Uses of PreventiveActionRequestVO in bb.common.box

Methods in bb.common.box that return PreventiveActionRequestVO
PreventiveActionRequestVO | QualityBox.addPAR(PreventiveActionRequestVO vo)
PreventiveActionRequestVO | QualityBox.findPARByPk(java.lang.String pk)
PreventiveActionRequestVO | QualityBox.updatePAR(PreventiveActionRequestVO vo)

Methods in bb.common.box that return types with arguments of type PreventiveActionRequestVO
java.util.Collection<PreventiveActionRequestVO> | QualityBox.findAllPars(int firstIndex, int maxLength)
java.util.Collection<PreventiveActionRequestVO> | QualityBox.findDuePARs(int firstIndex, int maxLength)
java.util.Collection<PreventiveActionRequestVO> | QualityBox.findOpenPARs(int firstIndex, int maxLength)
java.util.Collection<PreventiveActionRequestVO> | QualityBox.findPARsByDate(java.lang.String pn, java.lang.String pa, java.lang.String customerId, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<PreventiveActionRequestVO> | QualityBox.findPARsByParNumber(java.lang.String parNumber, int firstIndex, int maxLength)
java.util.Collection<PreventiveActionRequestVO> | QualityBox.findPARsByPn(java.lang.String pn, java.lang.String pa, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type PreventiveActionRequestVO
PreventiveActionRequestVO | QualityBox.addPAR(PreventiveActionRequestVO vo)
PreventiveActionRequestVO | QualityBox.updatePAR(PreventiveActionRequestVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PrintLogoVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PrintLogoVO

Packages that use PrintLogoVO
bb.common.box

Uses of PrintLogoVO in bb.common.box

Methods in bb.common.box that return PrintLogoVO
PrintLogoVO | CompanyBox.getPrintLogoByName(java.lang.String logoName)
PrintLogoVO | CompanyBox.getPrintLogoInfoByName(java.lang.String logoName)

Methods in bb.common.box that return types with arguments of type PrintLogoVO
 java.util.Collection<PrintLogoVO> CompanyBox.findAllPrintLogo()

Methods in bb.common.box with parameters of type PrintLogoVO
void | CompanyBox.addPrintLogo(PrintLogoVO vo)
void | CompanyBox.updatePrintLogo(PrintLogoVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PrintTemplateVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PrintTemplateVO

Packages that use PrintTemplateVO
bb.common.box

Uses of PrintTemplateVO in bb.common.box

Methods in bb.common.box that return PrintTemplateVO
PrintTemplateVO | CompanyBox.addPrintTemplate(PrintTemplateVO vo)
PrintTemplateVO | CompanyBox.getPrintTemplate(int id)

Methods in bb.common.box that return types with arguments of type PrintTemplateVO
java.util.Collection<PrintTemplateVO> | CompanyBox.findAllPrintTemplate(int firstIndex, int maxLength)
java.util.Collection<PrintTemplateVO> | CompanyBox.findPrintTemplatebyClazz(java.lang.String clazz, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type PrintTemplateVO
PrintTemplateVO | CompanyBox.addPrintTemplate(PrintTemplateVO vo)
void | CompanyBox.updatePrintTemplate(PrintTemplateVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ProfitAndLossAccountsResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ProfitAndLossAccountsResult

Packages that use ProfitAndLossAccountsResult
bb.common.box

Uses of ProfitAndLossAccountsResult in bb.common.box

Methods in bb.common.box that return types with arguments of type ProfitAndLossAccountsResult
 java.util.Collection<ProfitAndLossAccountsResult> AccountingBox.getAllProfitAndLossAccounts()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ProfitLossStatementItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ProfitLossStatementItemResult

Packages that use ProfitLossStatementItemResult
bb.common

Uses of ProfitLossStatementItemResult in bb.common

Methods in bb.common that return ProfitLossStatementItemResult
ProfitLossStatementItemResult | ProfitLossStatementResult.getGrossProfit()
ProfitLossStatementItemResult | ProfitLossStatementResult.getNetProfit()
ProfitLossStatementItemResult | ProfitLossStatementResult.getTotalCostOfSales()
ProfitLossStatementItemResult | ProfitLossStatementResult.getTotalGeneralAdmin()
ProfitLossStatementItemResult | ProfitLossStatementResult.getTotalIncomeFromOperating()
ProfitLossStatementItemResult | ProfitLossStatementResult.getTotalOperatingExpense()
ProfitLossStatementItemResult | ProfitLossStatementResult.getTotalOtherIncome()
ProfitLossStatementItemResult | ProfitLossStatementResult.getTotalResearchDevelopment()
ProfitLossStatementItemResult | ProfitLossStatementResult.getTotalSalesMarketing()
ProfitLossStatementItemResult | ProfitLossStatementResult.getTotalSalesRevenue()
ProfitLossStatementItemResult | ProfitLossStatementResult.getTotalTax()
ProfitLossStatementItemResult | ProfitLossStatementResult.getTotalWageLabor()

Methods in bb.common with parameters of type ProfitLossStatementItemResult
void | ProfitLossStatementResult.setGrossProfit(ProfitLossStatementItemResult grossProfit)
void | ProfitLossStatementResult.setNetProfit(ProfitLossStatementItemResult netProfit)
void | ProfitLossStatementResult.setTotalCostOfSales(ProfitLossStatementItemResult totalCostOfSales)
void | ProfitLossStatementResult.setTotalGeneralAdmin(ProfitLossStatementItemResult totalGeneralAdmin)
void | ProfitLossStatementResult.setTotalIncomeFromOperating(ProfitLossStatementItemResult totalIncomeFromOperating)
void | ProfitLossStatementResult.setTotalOperatingExpense(ProfitLossStatementItemResult totalOperatingExpense)
void | ProfitLossStatementResult.setTotalOtherIncome(ProfitLossStatementItemResult totalOtherIncome)
void | ProfitLossStatementResult.setTotalResearchDevelopment(ProfitLossStatementItemResult totalResearchDevelopment)
void | ProfitLossStatementResult.setTotalSalesMarketing(ProfitLossStatementItemResult totalSalesMarketing)
void | ProfitLossStatementResult.setTotalSalesRevenue(ProfitLossStatementItemResult totalSalesRevenue)
void | ProfitLossStatementResult.setTotalTax(ProfitLossStatementItemResult totalTax)
void | ProfitLossStatementResult.setTotalWageLabor(ProfitLossStatementItemResult totalWageLabor)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ProfitLossStatementResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ProfitLossStatementResult

Packages that use ProfitLossStatementResult
bb.common.box

Uses of ProfitLossStatementResult in bb.common.box

Methods in bb.common.box that return ProfitLossStatementResult
ProfitLossStatementResult | AccountingBox.findProfitLossStatement()
ProfitLossStatementResult | AccountingBox.findProfitLossStatement(java.lang.String companyUnitId, java.util.Date currentPeriodFrom, java.util.Date currentPeriodTo, java.util.Date priorPeriodFrom, java.util.Date priorPeriodTo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ProformaInvoiceItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ProformaInvoiceItemListResult

Packages that use ProformaInvoiceItemListResult
bb.common.box

Uses of ProformaInvoiceItemListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type ProformaInvoiceItemListResult
 java.util.Collection<ProformaInvoiceItemListResult> WarehouseBox.findProformaInvoiceItems(java.util.Date from, java.util.Date to, java.lang.String pfNumberLike, java.lang.String pnLike, java.lang.String paLike, java.lang.String soNumberLike, java.lang.String customerIdLike, java.lang.String status, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ProformaInvoiceItemManufacturerPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ProformaInvoiceItemManufacturerPK

Packages that use ProformaInvoiceItemManufacturerPK
bb.common

Uses of ProformaInvoiceItemManufacturerPK in bb.common

Methods in bb.common that return ProformaInvoiceItemManufacturerPK
 ProformaInvoiceItemManufacturerPK ProformaInvoiceItemManufacturerVO.getPk()

Methods in bb.common with parameters of type ProformaInvoiceItemManufacturerPK
 void ProformaInvoiceItemManufacturerVO.setPk(ProformaInvoiceItemManufacturerPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ProformaInvoiceItemManufacturerVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ProformaInvoiceItemManufacturerVO

No usage of bb.common.ProformaInvoiceItemManufacturerVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ProformaInvoiceItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ProformaInvoiceItemPK

Packages that use ProformaInvoiceItemPK
bb.common
bb.common.box

Uses of ProformaInvoiceItemPK in bb.common

Methods in bb.common that return ProformaInvoiceItemPK
 ProformaInvoiceItemPK ProformaInvoiceItemVO.getPk()

Methods in bb.common with parameters of type ProformaInvoiceItemPK
 void ProformaInvoiceItemVO.setPk(ProformaInvoiceItemPK pk)

Constructors in bb.common with parameters of type ProformaInvoiceItemPK
ProformaInvoiceItemVO(ProformaInvoiceItemPK pk, java.lang.String pfInvoiceItemNumber, java.lang.String customerId, java.lang.String purchaseOrderNumber, java.lang.String shipperNumber, java.lang.String ar, java.math.BigDecimal arSub, java.math.BigDecimal arShip, java.math.BigDecimal arOpen, java.math.BigDecimal arDisc, java.math.BigDecimal arNet, java.math.BigDecimal arTax, java.math.BigDecimal arTotal, java.lang.String refDoc1, java.lang.String refDoc2, java.util.Date dateShipped, java.util.Date dateInvoiced, java.lang.String shipVia, java.lang.String shipTo, java.lang.String status, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String modelNumber, java.lang.String revision, java.lang.String locate, java.math.BigDecimal quantity, java.math.BigDecimal qtyShipped, java.math.BigDecimal listPrice, java.math.BigDecimal avgCost, java.lang.String unit, java.math.BigDecimal discount, java.math.BigDecimal taxRate, java.lang.String description, java.lang.String mfg, java.lang.String mpn, java.lang.String serial)
minimal constructor
ProformaInvoiceItemVO(ProformaInvoiceItemPK pk, java.lang.String pfInvoiceItemNumber, java.lang.String customerId, java.lang.String purchaseOrderNumber, java.lang.String shipperNumber, java.lang.String ar, java.math.BigDecimal arSub, java.math.BigDecimal arShip, java.math.BigDecimal arOpen, java.math.BigDecimal arDisc, java.math.BigDecimal arNet, java.math.BigDecimal arTax, java.math.BigDecimal arTotal, java.lang.String refDoc1, java.lang.String refDoc2, java.util.Date dateShipped, java.util.Date dateInvoiced, java.lang.String shipVia, java.lang.String shipTo, java.lang.String status, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String modelNumber, java.lang.String revision, java.lang.String locate, java.math.BigDecimal quantity, java.math.BigDecimal qtyShipped, java.math.BigDecimal listPrice, java.math.BigDecimal avgCost, java.lang.String unit, java.math.BigDecimal discount, java.math.BigDecimal taxRate, java.lang.String description, java.lang.String mfg, java.lang.String mpn, java.lang.String serial, java.lang.String itemComments, java.lang.String itemPrivateNotes)
full constructor

Uses of ProformaInvoiceItemPK in bb.common.box

Methods in bb.common.box with parameters of type ProformaInvoiceItemPK
 void WarehouseBox.removeProformaInvoiceItem(ProformaInvoiceItemPK itemPk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ProformaInvoiceItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ProformaInvoiceItemVO

No usage of bb.common.ProformaInvoiceItemVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ProformaInvoiceListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ProformaInvoiceListResult

Packages that use ProformaInvoiceListResult
bb.common.box

Uses of ProformaInvoiceListResult in bb.common.box

Methods in bb.common.box that return ProformaInvoiceListResult
 ProformaInvoiceListResult WarehouseBox.checkCloseProformaInvoice(java.lang.String pfNum)

Methods in bb.common.box that return types with arguments of type ProformaInvoiceListResult
java.util.Collection<ProformaInvoiceListResult> | WarehouseBox.findAllNotClosedProformaInvoices(int firstIndex, int maxLength)
java.util.Collection<ProformaInvoiceListResult> | WarehouseBox.findAllProformaInvoices(int firstIndex, int maxLength)
java.util.Collection<ProformaInvoiceListResult> | WarehouseBox.findOpenProformaInvoiceListResults(int firstIndex, int maxLength)
java.util.Collection<ProformaInvoiceListResult> | WarehouseBox.findProformaInvoiceListResultsByCustomerId(java.lang.String customerId, int firstIndex, int maxLength)
java.util.Collection<ProformaInvoiceListResult> | WarehouseBox.findProformaInvoiceListResultsByPfNumber(java.lang.String pfNumberExp, int firstIndex, int maxLength)
java.util.Collection<ProformaInvoiceListResult> | WarehouseBox.getProformaInvoiceListResults(java.util.ArrayList<java.lang.String> pfnums)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ProformaInvoiceVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ProformaInvoiceVO

Packages that use ProformaInvoiceVO
bb.common
bb.common.box

Uses of ProformaInvoiceVO in bb.common

Methods in bb.common that return ProformaInvoiceVO
 ProformaInvoiceVO ProformaReceiverPackingBoxAgent.getPfVo()

Methods in bb.common with parameters of type ProformaInvoiceVO
 void ProformaReceiverPackingBoxAgent.setPfVo(ProformaInvoiceVO pfVo)

Uses of ProformaInvoiceVO in bb.common.box

Methods in bb.common.box that return ProformaInvoiceVO
ProformaInvoiceVO | WarehouseBox.addProformaInvoice(ProformaInvoiceVO vo)
ProformaInvoiceVO | WarehouseBox.getPFInvoiceByPFNumber(java.lang.String pfNumber)
ProformaInvoiceVO | WarehouseBox.refreshProformaInvoice(ProformaInvoiceVO vo)
ProformaInvoiceVO | WarehouseBox.updateProformaInvoice(ProformaInvoiceVO vo)

Methods in bb.common.box with parameters of type ProformaInvoiceVO
ProformaInvoiceVO | WarehouseBox.addProformaInvoice(ProformaInvoiceVO vo)
void | WarehouseBox.deleteProformaInvoice(ProformaInvoiceVO vo)
java.lang.String | WarehouseBox.finishProformaShipper(ProformaInvoiceVO pfVo, boolean deleteZero, boolean withoutBoxInfo)
java.lang.Integer | WarehouseBox.getNextPackingBoxNumber(ProformaInvoiceVO vo)
ProformaReceiverPackingBoxAgent | PurchasingBox.initProformaReceiverPackingBoxs(ProformaInvoiceVO pfVo, java.lang.String vendorId)
ProformaInvoiceVO | WarehouseBox.refreshProformaInvoice(ProformaInvoiceVO vo)
ProformaInvoiceVO | WarehouseBox.updateProformaInvoice(ProformaInvoiceVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ProformaReceiverPackingBoxAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ProformaReceiverPackingBoxAgent

Packages that use ProformaReceiverPackingBoxAgent
bb.common.box

Uses of ProformaReceiverPackingBoxAgent in bb.common.box

Methods in bb.common.box that return ProformaReceiverPackingBoxAgent
 ProformaReceiverPackingBoxAgent PurchasingBox.initProformaReceiverPackingBoxs(ProformaInvoiceVO pfVo, java.lang.String vendorId)

Methods in bb.common.box with parameters of type ProformaReceiverPackingBoxAgent
 java.lang.String PurchasingBox.addPfReceiver(ProformaReceiverPackingBoxAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ProformaReceiverPackingBoxItemAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ProformaReceiverPackingBoxItemAgent

Packages that use ProformaReceiverPackingBoxItemAgent
bb.common

Uses of ProformaReceiverPackingBoxItemAgent in bb.common

Methods in bb.common that return types with arguments of type ProformaReceiverPackingBoxItemAgent
 java.util.LinkedHashMap<PackingBoxPK,java.util.ArrayList<ProformaReceiverPackingBoxItemAgent>> ProformaReceiverPackingBoxAgent.getPbItems()

Method parameters in bb.common with type arguments of type ProformaReceiverPackingBoxItemAgent
 void ProformaReceiverPackingBoxAgent.setPbItems(java.util.LinkedHashMap<PackingBoxPK,java.util.ArrayList<ProformaReceiverPackingBoxItemAgent>> pbItems)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ProjectVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ProjectVO

Packages that use ProjectVO
bb.common.box

Uses of ProjectVO in bb.common.box

Methods in bb.common.box that return ProjectVO
 ProjectVO SalesBox.getProjectByID(java.lang.String id)

Methods in bb.common.box that return types with arguments of type ProjectVO
 java.util.Collection<ProjectVO> SalesBox.findProjectById(java.lang.String id, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type ProjectVO
void | SalesBox.addProject(ProjectVO vo)
void | SalesBox.updateProject(ProjectVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PrPackingBoxItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PrPackingBoxItemPK

Packages that use PrPackingBoxItemPK
bb.common

Uses of PrPackingBoxItemPK in bb.common

Methods in bb.common that return PrPackingBoxItemPK
PrPackingBoxItemPK | BB2PartInSitItemResult.getPackBoxItemPk()
PrPackingBoxItemPK | PrPackingBoxItemVO.getPk()

Methods in bb.common with parameters of type PrPackingBoxItemPK
void | BB2PartInSitItemResult.setPackBoxItemPk(PrPackingBoxItemPK packBoxItemPk)
void | PrPackingBoxItemVO.setPk(PrPackingBoxItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PrPackingBoxItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PrPackingBoxItemVO

Packages that use PrPackingBoxItemVO
bb.common
bb.common.box

Uses of PrPackingBoxItemVO in bb.common

Methods in bb.common that return PrPackingBoxItemVO
 PrPackingBoxItemVO ProformaReceiverPackingBoxItemAgent.getPrPBItem()

Methods in bb.common with parameters of type PrPackingBoxItemVO
 void ProformaReceiverPackingBoxItemAgent.setPrPBItem(PrPackingBoxItemVO prPBItem)

Uses of PrPackingBoxItemVO in bb.common.box

Method parameters in bb.common.box with type arguments of type PrPackingBoxItemVO
 java.lang.String PurchasingBox.finishProformaReceiver(java.lang.String pfReceiverNumber, PfReceiverItemVO itemVO, java.util.HashSet<PrPackingBoxItemVO> boxItemVOs, java.lang.String receiverNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PrPackingBoxPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PrPackingBoxPK

Packages that use PrPackingBoxPK
bb.common
bb.common.box

Uses of PrPackingBoxPK in bb.common

Methods in bb.common that return PrPackingBoxPK
 PrPackingBoxPK PrPackingBoxVO.getPk()

Methods in bb.common with parameters of type PrPackingBoxPK
 void PrPackingBoxVO.setPk(PrPackingBoxPK pk)

Uses of PrPackingBoxPK in bb.common.box

Methods in bb.common.box with parameters of type PrPackingBoxPK
 PrPackingBoxVO PurchasingBox.getPrPackingBox(PrPackingBoxPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PrPackingBoxVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PrPackingBoxVO

Packages that use PrPackingBoxVO
bb.common
bb.common.box

Uses of PrPackingBoxVO in bb.common

Methods in bb.common that return types with arguments of type PrPackingBoxVO
 java.util.LinkedHashMap<PackingBoxPK,PrPackingBoxVO> ProformaReceiverPackingBoxAgent.getPbs()

Method parameters in bb.common with type arguments of type PrPackingBoxVO
 void ProformaReceiverPackingBoxAgent.setPbs(java.util.LinkedHashMap<PackingBoxPK,PrPackingBoxVO> pbs)

Uses of PrPackingBoxVO in bb.common.box

Methods in bb.common.box that return PrPackingBoxVO
 PrPackingBoxVO PurchasingBox.getPrPackingBox(PrPackingBoxPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PrReceiverListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PrReceiverListResult

Packages that use PrReceiverListResult
bb.common.box

Uses of PrReceiverListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type PrReceiverListResult
java.util.Collection<PrReceiverListResult> | PurchasingBox.findAllPfReceivers(int firstIndex, int maxLength)
java.util.Collection<PrReceiverListResult> | PurchasingBox.findPfReceiversByPfNumber(java.lang.String pfReceiverNumberLike, int firstIndex, int maxLength)
java.util.Collection<PrReceiverListResult> | PurchasingBox.findPfReceiversByVendorId(java.lang.String vendorId, int firstIndex, int maxLength)
java.util.Collection<PrReceiverListResult> | PurchasingBox.findPfReceiversOpenByVendorId(java.lang.String vendorId, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PrReceiverWithQualityListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PrReceiverWithQualityListResult

No usage of bb.common.PrReceiverWithQualityListResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PullFromWorkOrderPartDetailAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PullFromWorkOrderPartDetailAgent

Packages that use PullFromWorkOrderPartDetailAgent
bb.common.box

Uses of PullFromWorkOrderPartDetailAgent in bb.common.box

Method parameters in bb.common.box with type arguments of type PullFromWorkOrderPartDetailAgent
void | WarehouseBox.pullFromWorkOrderPartDetail(java.util.HashSet<PullFromWorkOrderPartDetailAgent> sets, java.lang.String ncrNumber)
NonConformanceReportVO | QualityBox.updateNCR(NonConformanceReportVO vo, java.util.HashSet<PuttoInQAAgent> putToInQAAgentSet, java.util.HashSet<PullFromWorkOrderPartDetailAgent> pullFromWorkOrderPartDetailAgentSet, java.util.HashSet<RebackInQAAgent> reBackInQAAgentSet)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PurchaseOnTimeResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PurchaseOnTimeResult

Packages that use PurchaseOnTimeResult
bb.common.box

Uses of PurchaseOnTimeResult in bb.common.box

Methods in bb.common.box that return PurchaseOnTimeResult
 PurchaseOnTimeResult ManagementBox.getPurchaseOnTimeResult(OnTimeAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PurchaseOrderApprovalVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PurchaseOrderApprovalVO

Packages that use PurchaseOrderApprovalVO
bb.common.box

Uses of PurchaseOrderApprovalVO in bb.common.box

Methods in bb.common.box that return PurchaseOrderApprovalVO
PurchaseOrderApprovalVO | PurchasingBox.addPurchaseOrderApproval(java.lang.String employeeId)
PurchaseOrderApprovalVO | ManufacturingBox.addPurchaseOrderApproval(java.lang.String approvalUserName)
PurchaseOrderApprovalVO | PurchasingBox.getPurchaseOrderApprovalByEmployeeId(java.lang.String employeeId)
PurchaseOrderApprovalVO | ManufacturingBox.getPurchaseOrderApprovalByEmployeeId(java.lang.String employeeId)
PurchaseOrderApprovalVO | PurchasingBox.getPurchaseOrderApprovalByUserNumber(java.lang.String userName)
PurchaseOrderApprovalVO | ManufacturingBox.getPurchaseOrderApprovalByUserNumber(java.lang.String userName)
PurchaseOrderApprovalVO | PurchasingBox.updatePurchaseOrderApproval(PurchaseOrderApprovalVO purApprovalVO)
PurchaseOrderApprovalVO | ManufacturingBox.updatePurchaseOrderApproval(PurchaseOrderApprovalVO purApprovalVO)

Methods in bb.common.box that return types with arguments of type PurchaseOrderApprovalVO
java.util.Collection<PurchaseOrderApprovalVO> | PurchasingBox.findAllPurchaseOrderApprovals(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderApprovalVO> | ManufacturingBox.findAllPurchaseOrderApprovals(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type PurchaseOrderApprovalVO
PurchaseOrderApprovalVO | PurchasingBox.updatePurchaseOrderApproval(PurchaseOrderApprovalVO purApprovalVO)
PurchaseOrderApprovalVO | ManufacturingBox.updatePurchaseOrderApproval(PurchaseOrderApprovalVO purApprovalVO)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PurchaseOrderBoilerplateVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PurchaseOrderBoilerplateVO

Packages that use PurchaseOrderBoilerplateVO
bb.common.box

Uses of PurchaseOrderBoilerplateVO in bb.common.box

Methods in bb.common.box that return PurchaseOrderBoilerplateVO
PurchaseOrderBoilerplateVO | PurchasingBox.addPurchaseOrderBP(PurchaseOrderBoilerplateVO vo)
PurchaseOrderBoilerplateVO | PurchasingBox.getPurchaseOrderBPByPk(java.lang.String purchaseOrderBoilerplateId)
PurchaseOrderBoilerplateVO | PurchasingBox.updatePurchaseOrderBP(PurchaseOrderBoilerplateVO vo)

Methods in bb.common.box that return types with arguments of type PurchaseOrderBoilerplateVO
java.util.Collection<PurchaseOrderBoilerplateVO> | PurchasingBox.findAllPurchaseOrderBP(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderBoilerplateVO> | ManufacturingBox.findAllPurchaseOrderBP(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderBoilerplateVO> | PurchasingBox.findPurchaseOrderBPBybpID(java.lang.String bpId, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type PurchaseOrderBoilerplateVO
PurchaseOrderBoilerplateVO | PurchasingBox.addPurchaseOrderBP(PurchaseOrderBoilerplateVO vo)
PurchaseOrderBoilerplateVO | PurchasingBox.updatePurchaseOrderBP(PurchaseOrderBoilerplateVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PurchaseOrderCheckListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PurchaseOrderCheckListResult

Packages that use PurchaseOrderCheckListResult
bb.common.box

Uses of PurchaseOrderCheckListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type PurchaseOrderCheckListResult
java.util.Collection<PurchaseOrderCheckListResult> | PurchasingBox.findAllPurchaseOrderCheckListResults(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderCheckListResult> | ManufacturingBox.findAllPurchaseOrderCheckListResults(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderCheckListResult> | PurchasingBox.findPurchaseOrderCheckListResults(java.lang.String startWith, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderCheckListResult> | ManufacturingBox.findPurchaseOrderCheckListResults(java.lang.String startWith, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PurchaseOrderContractResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PurchaseOrderContractResult

Packages that use PurchaseOrderContractResult
bb.common.box

Uses of PurchaseOrderContractResult in bb.common.box

Methods in bb.common.box that return types with arguments of type PurchaseOrderContractResult
 java.util.Collection<PurchaseOrderContractResult> PurchasingBox.findPurchaseContract(java.util.Date fromDate, java.util.Date toDate, java.lang.String currency, java.lang.String type)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PurchaseOrderDocumentVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PurchaseOrderDocumentVO

Packages that use PurchaseOrderDocumentVO
bb.common.box

Uses of PurchaseOrderDocumentVO in bb.common.box

Methods in bb.common.box that return PurchaseOrderDocumentVO
 PurchaseOrderDocumentVO PurchasingBox.getPurchaseOrderDocumentByID(java.lang.Long controlNumber)

Methods in bb.common.box that return types with arguments of type PurchaseOrderDocumentVO
java.util.Collection<PurchaseOrderDocumentVO> | PurchasingBox.deletePODoc(MiscDocAgent agent)
java.util.Collection<PurchaseOrderDocumentVO> | PurchasingBox.uploadOrUpdatePODoc(MiscDocAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PurchaseOrderItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PurchaseOrderItemListResult

Packages that use PurchaseOrderItemListResult
bb.common
bb.common.box

Uses of PurchaseOrderItemListResult in bb.common

Subclasses of PurchaseOrderItemListResult in bb.common
 class POItemByRefDoc1ListResult

Methods in bb.common that return types with arguments of type PurchaseOrderItemListResult
 java.util.List<PurchaseOrderItemListResult> PartsToDeleteResult.getPartsToDeleteInPO()

Method parameters in bb.common with type arguments of type PurchaseOrderItemListResult
 void PartsToDeleteResult.setPartsToDeleteInPO(java.util.List<PurchaseOrderItemListResult> partsToDeleteInPO)

Uses of PurchaseOrderItemListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type PurchaseOrderItemListResult
java.util.Collection<PurchaseOrderItemListResult> | PurchasingBox.findAllPurchaseOrderItems(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | ManufacturingBox.findAllPurchaseOrderItems(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | PurchasingBox.findAllPurchaseOrderItemsByAddressId(java.lang.String startWith, java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | PurchasingBox.findCancelledPurchaseOrderItems(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | PurchasingBox.findOpenPurchaseOrderItemsByAddressId(java.lang.String startWith, java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | PurchasingBox.findOpenPurchaseOrderItemsByPartPk(PartPK pk, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | EngineeringBox.findPartsToDeleteInPo(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | PurchasingBox.findPastDuePurchaseOrderItemsByAddressId(java.lang.String startWith, java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | PurchasingBox.findPurchaseOrderItemByDate(java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String status, java.lang.String partNumberLike, java.lang.String partType, java.lang.String shipto, java.lang.String vendorId, java.lang.String project, java.lang.String requester, java.lang.String buyer, java.lang.String currency, java.lang.String relatedDoc, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isHold, java.lang.String productCode, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | ManufacturingBox.findPurchaseOrderItemByDate(java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String status, java.lang.String partNumberLike, java.lang.String partType, java.lang.String shipto, java.lang.String vendorId, java.lang.String project, java.lang.String requester, java.lang.String buyer, java.lang.String currency, java.lang.String relatedDoc, java.lang.String accountNumber, java.lang.String companyUnitId, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | PurchasingBox.findPurchaseOrderItemsByPartNumberLike(java.lang.String partNumberReg, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | ManufacturingBox.findPurchaseOrderItemsByPartNumberLike(java.lang.String partNumberReg, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | PurchasingBox.findPurchaseOrderItemsByPartPk(PartPK pk, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | ManufacturingBox.findPurchaseOrderItemsByPartPk(PartPK pk, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | PurchasingBox.findPurchaseOrderItemsByProject(java.lang.String startWith, java.lang.String status, java.lang.String dateType, java.util.Date startDate, java.util.Date toDate, java.lang.String project, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | PurchasingBox.findPurchaseOrderItemsByRelatedDoc(java.lang.String startWith, java.lang.String status, java.lang.String dateType, java.util.Date startDate, java.util.Date toDate, java.lang.String relatedDoc, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | PurchasingBox.findPurchaseOrdersByRefdoc(java.lang.String poNumber, java.lang.String status, java.lang.String refdoc, java.util.Date dateFrom, java.util.Date dateTo, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | PurchasingBox.findVendorPurchaseOrderItems(java.lang.String vendorId, java.util.Date from, java.util.Date to, java.lang.String dateType, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderItemListResult> | PurchasingBox.findVendorPurchaseOrderItemsByDate(java.lang.String vendorId, java.util.Date from, java.util.Date to, java.lang.String dateType, java.lang.String status, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PurchaseOrderItemManufacturerPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PurchaseOrderItemManufacturerPK

Packages that use PurchaseOrderItemManufacturerPK
bb.common

Uses of PurchaseOrderItemManufacturerPK in bb.common

Methods in bb.common that return PurchaseOrderItemManufacturerPK
 PurchaseOrderItemManufacturerPK PurchaseOrderItemManufacturerVO.getPk()

Methods in bb.common with parameters of type PurchaseOrderItemManufacturerPK
 void PurchaseOrderItemManufacturerVO.setPk(PurchaseOrderItemManufacturerPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PurchaseOrderItemManufacturerVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PurchaseOrderItemManufacturerVO

No usage of bb.common.PurchaseOrderItemManufacturerVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PurchaseOrderItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PurchaseOrderItemPK

Packages that use PurchaseOrderItemPK
bb.common
bb.common.box

Uses of PurchaseOrderItemPK in bb.common

Methods in bb.common that return PurchaseOrderItemPK
PurchaseOrderItemPK | PurchaseOrderItemVO.getPk()
PurchaseOrderItemPK | AddProformaReceiverItemAgent.getPk()
PurchaseOrderItemPK | EcnPOOrderResult.getPoItemPk()
PurchaseOrderItemPK | PurchaseOrderOnOrderResult.getPurchaseOrderItemPk()

Methods in bb.common that return types with arguments of type PurchaseOrderItemPK
java.util.List<PurchaseOrderItemPK> | AddRTVAgent.getPoItemPk()
java.util.LinkedHashSet<PurchaseOrderItemPK> | ProformaReceiverPackingBoxItemAgent.getPOItems()

Methods in bb.common with parameters of type PurchaseOrderItemPK
void | PurchaseOrderItemVO.setPk(PurchaseOrderItemPK pk)
void | AddProformaReceiverItemAgent.setPk(PurchaseOrderItemPK pk)
void | EcnPOOrderResult.setPoItemPk(PurchaseOrderItemPK poItemPk)
void | PurchaseOrderOnOrderResult.setPurchaseOrderItemPk(PurchaseOrderItemPK purchaseOrderPk)

Method parameters in bb.common with type arguments of type PurchaseOrderItemPK
void | AddRTVAgent.setPoItemPk(java.util.List<PurchaseOrderItemPK> poItemPk)
void | ProformaReceiverPackingBoxItemAgent.setPOItems(java.util.LinkedHashSet<PurchaseOrderItemPK> items)

Uses of PurchaseOrderItemPK in bb.common.box

Methods in bb.common.box with parameters of type PurchaseOrderItemPK
RefdocVO | PurchasingBox.addRefdocTwo(PurchaseOrderItemPK poItemPk, java.lang.String orderNumber, java.lang.String itemNumber, java.math.BigDecimal refdocQty)
void | PurchasingBox.clearAllReferenceDocOnesToPurchaseOrderItem(PurchaseOrderItemPK pk)
void | ManufacturingBox.clearAllReferenceDocOnesToPurchaseOrderItem(PurchaseOrderItemPK pk)
void | PurchasingBox.clearAllReferenceDocTwoesToPurchaseOrderItem(PurchaseOrderItemPK pk)
void | ManufacturingBox.clearAllReferenceDocTwoesToPurchaseOrderItem(PurchaseOrderItemPK pk)
java.util.Collection<MfrMpnListResult> | WarehouseBox.getMfrMpnListResultsFor(PurchaseOrderItemPK itemPk)
PurchaseOrderItemVO | PurchasingBox.getPurchaseOrderItemByPk(PurchaseOrderItemPK pk)
boolean | PurchasingBox.isPurchaseOrderItemExistent(PurchaseOrderItemPK pk)
boolean | ManufacturingBox.isPurchaseOrderItemExistent(PurchaseOrderItemPK pk)
void | PurchasingBox.setPurchaseOrderItemReferenceDocOne(PurchaseOrderItemPK pk, java.lang.String referenceDoc)
void | ManufacturingBox.setPurchaseOrderItemReferenceDocOne(PurchaseOrderItemPK pk, java.lang.String referenceDoc)
void | PurchasingBox.setPurchaseOrderItemReferenceDocTwo(PurchaseOrderItemPK pk, java.lang.String referenceDoc)
void | ManufacturingBox.setPurchaseOrderItemReferenceDocTwo(PurchaseOrderItemPK pk, java.lang.String referenceDoc)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PurchaseOrderItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PurchaseOrderItemVO

Packages that use PurchaseOrderItemVO
bb.common
bb.common.box

Uses of PurchaseOrderItemVO in bb.common

Methods in bb.common that return PurchaseOrderItemVO
 PurchaseOrderItemVO PoMessageItemVO.getPoItem()

Methods in bb.common that return types with arguments of type PurchaseOrderItemVO
 java.util.Set<PurchaseOrderItemVO> PurchaseOrderVO.getPurchaseOrderItem()

Methods in bb.common with parameters of type PurchaseOrderItemVO
 void PoMessageItemVO.setPoItem(PurchaseOrderItemVO poItem)

Method parameters in bb.common with type arguments of type PurchaseOrderItemVO
 void PurchaseOrderVO.setPurchaseOrderItem(java.util.Set<PurchaseOrderItemVO> purchaseOrderItem)

Uses of PurchaseOrderItemVO in bb.common.box

Methods in bb.common.box that return PurchaseOrderItemVO
PurchaseOrderItemVO | PurchasingBox.addPurchaseOrderItem(PurchaseOrderItemVO purItemVO)
PurchaseOrderItemVO | ManufacturingBox.addPurchaseOrderItem(PurchaseOrderItemVO purItemVO)
PurchaseOrderItemVO | PurchasingBox.getPurchaseOrderItemByPk(PurchaseOrderItemPK pk)
PurchaseOrderItemVO | PurchasingBox.initPurchaseOrderItemForPart(java.lang.String purchaseOrderNumber, java.lang.String itemNumber, PartPK partPk, java.math.BigDecimal qty)
PurchaseOrderItemVO | ManufacturingBox.initPurchaseOrderItemForTool(java.lang.String purchaseOrderNumber, java.lang.String itemNumber, PartPK partPk, java.math.BigDecimal qty)

Methods in bb.common.box that return types with arguments of type PurchaseOrderItemVO
java.util.Collection<PurchaseOrderItemVO> | PurchasingBox.findPurchaseOrderItemsByPoNumber(java.lang.String poNumber)
java.util.Collection<PurchaseOrderItemVO> | ManufacturingBox.findPurchaseOrderItemsByPoNumber(java.lang.String poNumber)
java.util.Collection<PurchaseOrderItemVO> | PurchasingBox.getPOItemsforRtv(java.lang.String purchaseNumber)

Methods in bb.common.box with parameters of type PurchaseOrderItemVO
void | WarehouseBox.addPartOnOder(PurchaseOrderItemVO item)
PurchaseOrderItemVO | PurchasingBox.addPurchaseOrderItem(PurchaseOrderItemVO purItemVO)
PurchaseOrderItemVO | ManufacturingBox.addPurchaseOrderItem(PurchaseOrderItemVO purItemVO)
void | WarehouseBox.addToolOnOder(PurchaseOrderItemVO item)
void | PurchasingBox.deletePurchaseOrderItem(PurchaseOrderItemVO purItemVO)
void | ManufacturingBox.deletePurchaseOrderItem(PurchaseOrderItemVO purItemVO)
void | WarehouseBox.subtractPartOnOder(PurchaseOrderItemVO item)
void | WarehouseBox.subtractToolOnOder(PurchaseOrderItemVO item)
void | PurchasingBox.updatePurchaseOrderItem(PurchaseOrderItemVO purItemVO)
void | ManufacturingBox.updatePurchaseOrderItem(PurchaseOrderItemVO purItemVO)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PurchaseOrderListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PurchaseOrderListResult

Packages that use PurchaseOrderListResult
bb.common.box

Uses of PurchaseOrderListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type PurchaseOrderListResult
java.util.Collection<PurchaseOrderListResult> | PurchasingBox.findAllPurchaseOrderByAddressId(java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | ManufacturingBox.findAllPurchaseOrderByAddressId(java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | PurchasingBox.findAllPurchaseOrders(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | ManufacturingBox.findAllPurchaseOrders(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | PurchasingBox.findMyPoPrintList()
java.util.Collection<PurchaseOrderListResult> | PurchasingBox.findOpenPurchaseOrder(java.lang.String startWith, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | PurchasingBox.findOpenPurchaseOrderByAddressId(java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | ManufacturingBox.findOpenPurchaseOrderByAddressId(java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | PurchasingBox.findOpenPurchaseOrderByProjectLike(java.lang.String projectLike, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | PurchasingBox.findOpenPurchaseOrderByRequesterLike(java.lang.String requesterLike, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | PurchasingBox.findOpenPurchaseOrderForReceiver(java.lang.String startWith, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | PurchasingBox.findOpenPurchaseOrderNotAcknowledged(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | PurchasingBox.findOpenPurchaseOrdertRelatedDoc(java.lang.String startWith, java.lang.String refDoc, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | PurchasingBox.findOpenPurchaseOrderwithPrepay(java.lang.String startWith, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | PurchasingBox.findPurchaseOrderByPoNumber(java.lang.String poNumber, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | ManufacturingBox.findPurchaseOrderByPoNumber(java.lang.String poNumber, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | PurchasingBox.findPurchaseOrderByRange(java.lang.String poStart, java.lang.String poEnd, java.lang.String vendorIdLike, java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | PurchasingBox.findPurchaseOrdersForReceiving(java.lang.String refDoc, java.lang.String vendorNameLike, java.lang.String partNumberLike, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderListResult> | PurchasingBox.makePurchaseOrders(PurchaseWorkSheetVO pwsVO)
java.util.Collection<PurchaseOrderListResult> | ManufacturingBox.makePurchaseOrders(PurchaseWorkSheetVO pwsVO)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PurchaseOrderOnOrderResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PurchaseOrderOnOrderResult

No usage of bb.common.PurchaseOrderOnOrderResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PurchaseOrderOnTimeItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PurchaseOrderOnTimeItemResult

Packages that use PurchaseOrderOnTimeItemResult
bb.common

Uses of PurchaseOrderOnTimeItemResult in bb.common

Methods in bb.common that return types with arguments of type PurchaseOrderOnTimeItemResult
 java.util.List<PurchaseOrderOnTimeItemResult> PurchaseOnTimeResult.getItems()

Method parameters in bb.common with type arguments of type PurchaseOrderOnTimeItemResult
 void PurchaseOnTimeResult.setItems(java.util.List<PurchaseOrderOnTimeItemResult> items)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PurchaseOrderOnTimeResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PurchaseOrderOnTimeResult

Packages that use PurchaseOrderOnTimeResult
bb.common.box

Uses of PurchaseOrderOnTimeResult in bb.common.box

Methods in bb.common.box that return PurchaseOrderOnTimeResult
 PurchaseOrderOnTimeResult ManagementBox.getPurchaseOrderOnTimeResult()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PurchaseOrderOpenDueListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PurchaseOrderOpenDueListResult

Packages that use PurchaseOrderOpenDueListResult
bb.common.box

Uses of PurchaseOrderOpenDueListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type PurchaseOrderOpenDueListResult
java.util.Collection<PurchaseOrderOpenDueListResult> | PurchasingBox.findDuePurchaseOrderItemByBuyerCode(java.lang.String buyerCode, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderOpenDueListResult> | PurchasingBox.findOpenPurchaseOrderByBuyer(java.lang.String buyer, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderOpenDueListResult> | PurchasingBox.findOpenPurchaseOrderItemByBuyerCode(java.lang.String buyerCode, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderOpenDueListResult> | PurchasingBox.findOpenPurchaseOrderItemByShipVia(java.lang.String vendorId, java.lang.String shipVia, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderOpenDueListResult> | PurchasingBox.findOpenPurchaseOrderItems(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderOpenDueListResult> | ManufacturingBox.findOpenPurchaseOrderItems(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderOpenDueListResult> | PurchasingBox.findPastDuePurchaseOrderByBuyer(java.lang.String buyer, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderOpenDueListResult> | PurchasingBox.findPastDuePurchaseOrderItemByShipVia(java.lang.String vendorId, java.lang.String shipVia, int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderOpenDueListResult> | PurchasingBox.findPastDuePurchaseOrderItems(int firstIndex, int maxLength)
java.util.Collection<PurchaseOrderOpenDueListResult> | ManufacturingBox.findPastDuePurchaseOrderItems(int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PurchaseOrderVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PurchaseOrderVO

Packages that use PurchaseOrderVO
bb.common.box

Uses of PurchaseOrderVO in bb.common.box

Methods in bb.common.box that return PurchaseOrderVO
PurchaseOrderVO | PurchasingBox.addPurchaseOrder(java.lang.String vendorId)
PurchaseOrderVO | ManufacturingBox.addPurchaseOrder(java.lang.String vendorId)
PurchaseOrderVO | ManufacturingBox.addPurchaseOrderFromRequestForQuote(java.lang.String rfqNumber)
PurchaseOrderVO | PurchasingBox.approvePurchaseOrder(PurchaseOrderVO purVO)
PurchaseOrderVO | ManufacturingBox.approvePurchaseOrder(PurchaseOrderVO purVO)
PurchaseOrderVO | PurchasingBox.approvePurchaseOrder(java.lang.String purchaseOrderNumber)
PurchaseOrderVO | ManufacturingBox.approvePurchaseOrder(java.lang.String purchaseOrderNumber)
PurchaseOrderVO | SalesBox.copyPurchaseOrderFromSalesOrder(SO2POAgent agent)
PurchaseOrderVO | PurchasingBox.copyPurchaseOrderFromSalesOrder(SO2POAgent agent)
PurchaseOrderVO | PurchasingBox.getPurchaseOrderByPoNumber(java.lang.String poNumber)
PurchaseOrderVO | ManufacturingBox.getPurchaseOrderByPoNumber(java.lang.String poNumber)
PurchaseOrderVO | QualityBox.getPurchaseOrderByPoNumberForIR(java.lang.String poNumber)
PurchaseOrderVO | ManufacturingBox.getPurchaseOrderWithOrderApplyByID(java.lang.Long ID)

Methods in bb.common.box with parameters of type PurchaseOrderVO
PurchaseOrderVO | PurchasingBox.approvePurchaseOrder(PurchaseOrderVO purVO)
PurchaseOrderVO | ManufacturingBox.approvePurchaseOrder(PurchaseOrderVO purVO)
void | PurchasingBox.deletePurchaseOrder(PurchaseOrderVO purVO)
void | ManufacturingBox.deletePurchaseOrder(PurchaseOrderVO purVO)
java.lang.String | PurchasingBox.updatePurchaseOrder(PurchaseOrderVO purVO)
java.lang.String | ManufacturingBox.updatePurchaseOrder(PurchaseOrderVO purVO)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PurchaseWorkSheetItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PurchaseWorkSheetItemPK

Packages that use PurchaseWorkSheetItemPK
bb.common

Uses of PurchaseWorkSheetItemPK in bb.common

Methods in bb.common that return PurchaseWorkSheetItemPK
 PurchaseWorkSheetItemPK PurchaseWorkSheetItemVO.getPk()

Methods in bb.common with parameters of type PurchaseWorkSheetItemPK
 void PurchaseWorkSheetItemVO.setPk(PurchaseWorkSheetItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PurchaseWorkSheetItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PurchaseWorkSheetItemVO

Packages that use PurchaseWorkSheetItemVO
bb.common
bb.common.box

Uses of PurchaseWorkSheetItemVO in bb.common

Methods in bb.common that return PurchaseWorkSheetItemVO
 PurchaseWorkSheetItemVO PurchaseWorkSheetItemWithRelatedInfoResult.getWorkSheetItem()

Methods in bb.common with parameters of type PurchaseWorkSheetItemVO
 void PurchaseWorkSheetItemWithRelatedInfoResult.setWorkSheetItem(PurchaseWorkSheetItemVO workSheetItem)

Uses of PurchaseWorkSheetItemVO in bb.common.box

Methods in bb.common.box that return PurchaseWorkSheetItemVO
 PurchaseWorkSheetItemVO PurchasingBox.addPurchaseWorkSheetItem(PurchaseWorkSheetItemVO pwsItemVO)

Methods in bb.common.box with parameters of type PurchaseWorkSheetItemVO
PurchaseWorkSheetItemVO | PurchasingBox.addPurchaseWorkSheetItem(PurchaseWorkSheetItemVO pwsItemVO)
void | PurchasingBox.deletePurchaseWorkSheetItem(PurchaseWorkSheetItemVO pwsItemVO)
void | PurchasingBox.updatePurchaseWorkSheetItem(PurchaseWorkSheetItemVO pwsItemVO)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PurchaseWorkSheetItemWithRelatedInfoResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PurchaseWorkSheetItemWithRelatedInfoResult

Packages that use PurchaseWorkSheetItemWithRelatedInfoResult
bb.common.box

Uses of PurchaseWorkSheetItemWithRelatedInfoResult in bb.common.box

Methods in bb.common.box that return PurchaseWorkSheetItemWithRelatedInfoResult
PurchaseWorkSheetItemWithRelatedInfoResult | PurchasingBox.initPurchaseWorkSheetItemForPart(PurchaseWorkSheetPK pk, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
PurchaseWorkSheetItemWithRelatedInfoResult | ManufacturingBox.initPurchaseWorkSheetItemForTool(PurchaseWorkSheetPK pk, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)

Methods in bb.common.box that return types with arguments of type PurchaseWorkSheetItemWithRelatedInfoResult
 java.util.Collection<PurchaseWorkSheetItemWithRelatedInfoResult> PurchasingBox.findPurchaseWorkSheetItemsByWorkSheetPk(PurchaseWorkSheetPK workSheetPk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PurchaseWorkSheetPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PurchaseWorkSheetPK

Packages that use PurchaseWorkSheetPK
bb.common
bb.common.box

Uses of PurchaseWorkSheetPK in bb.common

Methods in bb.common that return PurchaseWorkSheetPK
 PurchaseWorkSheetPK PurchaseWorkSheetVO.getPk()

Methods in bb.common with parameters of type PurchaseWorkSheetPK
 void PurchaseWorkSheetVO.setPk(PurchaseWorkSheetPK pk)

Uses of PurchaseWorkSheetPK in bb.common.box

Methods in bb.common.box with parameters of type PurchaseWorkSheetPK
java.util.Collection<PurchaseWorkSheetItemWithRelatedInfoResult> | PurchasingBox.findPurchaseWorkSheetItemsByWorkSheetPk(PurchaseWorkSheetPK workSheetPk)
PurchaseWorkSheetVO | PurchasingBox.getPurchaseWorkSheetByPk(PurchaseWorkSheetPK pk)
PurchaseWorkSheetVO | ManufacturingBox.getPurchaseWorkSheetByPk(PurchaseWorkSheetPK pk)
PurchaseWorkSheetItemWithRelatedInfoResult | PurchasingBox.initPurchaseWorkSheetItemForPart(PurchaseWorkSheetPK pk, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
PurchaseWorkSheetItemWithRelatedInfoResult | ManufacturingBox.initPurchaseWorkSheetItemForTool(PurchaseWorkSheetPK pk, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
boolean | PurchasingBox.isPurchaseWorkSheetExistent(PurchaseWorkSheetPK pk)
boolean | ManufacturingBox.isPurchaseWorkSheetExistent(PurchaseWorkSheetPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PurchaseWorkSheetVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PurchaseWorkSheetVO

Packages that use PurchaseWorkSheetVO
bb.common.box

Uses of PurchaseWorkSheetVO in bb.common.box

Methods in bb.common.box that return PurchaseWorkSheetVO
PurchaseWorkSheetVO | PurchasingBox.addPOWSFromQuote(java.lang.String qtNumber)
PurchaseWorkSheetVO | PurchasingBox.addPOWSFromSO(java.lang.String soNumber)
PurchaseWorkSheetVO | PurchasingBox.addPurchaseWorkSheet()
PurchaseWorkSheetVO | ManufacturingBox.addPurchaseWorkSheet()
PurchaseWorkSheetVO | PurchasingBox.addPurchaseWorkSheet(java.util.ArrayList list)
PurchaseWorkSheetVO | PurchasingBox.addPurchaseWorkSheet(PurchaseWorkSheetVO pwsVO)
PurchaseWorkSheetVO | ManufacturingBox.addPurchaseWorkSheet(PurchaseWorkSheetVO pwsVO)
PurchaseWorkSheetVO | PurchasingBox.getPurchaseWorkSheetByPk(PurchaseWorkSheetPK pk)
PurchaseWorkSheetVO | ManufacturingBox.getPurchaseWorkSheetByPk(PurchaseWorkSheetPK pk)
PurchaseWorkSheetVO | PurchasingBox.updatePurchaseWorkSheet(PurchaseWorkSheetVO pwsVO)
PurchaseWorkSheetVO | ManufacturingBox.updatePurchaseWorkSheet(PurchaseWorkSheetVO pwsVO)

Methods in bb.common.box that return types with arguments of type PurchaseWorkSheetVO
java.util.Collection<PurchaseWorkSheetVO> | PurchasingBox.findAllPurchaseWorkSheet(int firstIndex, int maxLength)
java.util.Collection<PurchaseWorkSheetVO> | ManufacturingBox.findAllPurchaseWorkSheet(int firstIndex, int maxLength)
java.util.Collection<PurchaseWorkSheetVO> | PurchasingBox.findMyPurchaseWorkSheet(int firstIndex, int maxLength)
java.util.Collection<PurchaseWorkSheetVO> | ManufacturingBox.findMyPurchaseWorkSheet(int firstIndex, int maxLength)
java.util.Collection<PurchaseWorkSheetVO> | PurchasingBox.findPurchaseWorkSheetByEmployeeEmailLike(java.lang.String employeeEmailLike, int firstIndex, int maxLength)
java.util.Collection<PurchaseWorkSheetVO> | ManufacturingBox.findPurchaseWorkSheetByEmployeeEmailLike(java.lang.String employeeEmailLike, int firstIndex, int maxLength)
java.util.Collection<PurchaseWorkSheetVO> | PurchasingBox.findPurchaseWorkSheetByEmployeeId(java.lang.String employeeId, boolean isMfrPurchaseWorkSheet, int firstIndex, int maxLength)
java.util.Collection<PurchaseWorkSheetVO> | ManufacturingBox.findPurchaseWorkSheetByEmployeeId(java.lang.String employeeId, boolean isMfrPurchaseWorkSheet, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type PurchaseWorkSheetVO
PurchaseWorkSheetVO | PurchasingBox.addPurchaseWorkSheet(PurchaseWorkSheetVO pwsVO)
PurchaseWorkSheetVO | ManufacturingBox.addPurchaseWorkSheet(PurchaseWorkSheetVO pwsVO)
void | PurchasingBox.deletePurchaseWorkSheet(PurchaseWorkSheetVO pwsVO)
void | ManufacturingBox.deletePurchaseWorkSheet(PurchaseWorkSheetVO pwsVO)
java.util.Collection<PurchaseOrderListResult> | PurchasingBox.makePurchaseOrders(PurchaseWorkSheetVO pwsVO)
java.util.Collection<PurchaseOrderListResult> | ManufacturingBox.makePurchaseOrders(PurchaseWorkSheetVO pwsVO)
java.util.Collection<RequestForQuoteListResult> | PurchasingBox.makeRequestForQuotes(PurchaseWorkSheetVO pwsVO)
java.util.Collection<RequestForQuoteListResult> | ManufacturingBox.makeRequestForQuotes(PurchaseWorkSheetVO pwsVO)
PurchaseWorkSheetVO | PurchasingBox.updatePurchaseWorkSheet(PurchaseWorkSheetVO pwsVO)
PurchaseWorkSheetVO | ManufacturingBox.updatePurchaseWorkSheet(PurchaseWorkSheetVO pwsVO)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PurchasingInfoCenterResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PurchasingInfoCenterResult

Packages that use PurchasingInfoCenterResult
bb.common.box

Uses of PurchasingInfoCenterResult in bb.common.box

Methods in bb.common.box that return PurchasingInfoCenterResult
 PurchasingInfoCenterResult ManagementBox.getPurchasingInfoCenterResult()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.PuttoInQAAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.PuttoInQAAgent

Packages that use PuttoInQAAgent
bb.common.box

Uses of PuttoInQAAgent in bb.common.box

Method parameters in bb.common.box with type arguments of type PuttoInQAAgent
void | WarehouseBox.putParttoInQA(java.util.HashSet<PuttoInQAAgent> sets, java.lang.String ncrNumber)
void | WarehouseBox.shipPartToNCR(java.lang.String ncrNumber, java.util.Set<PuttoInQAAgent> putToInQAAgentSet, java.util.Set pullFromWorkOrderPartDetailAgentSet)
NonConformanceReportVO | QualityBox.updateNCR(NonConformanceReportVO vo, java.util.HashSet<PuttoInQAAgent> putToInQAAgentSet, java.util.HashSet<PullFromWorkOrderPartDetailAgent> pullFromWorkOrderPartDetailAgentSet, java.util.HashSet<RebackInQAAgent> reBackInQAAgentSet)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.QtyAndMoney

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.QtyAndMoney

Packages that use QtyAndMoney
bb.common

Uses of QtyAndMoney in bb.common

Methods in bb.common that return QtyAndMoney
 QtyAndMoney BB2QtyAndMoneyMap.get(java.lang.String key)

Methods in bb.common with parameters of type QtyAndMoney
 void BB2QtyAndMoneyMap.put(java.lang.String key, QtyAndMoney value)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.QtyDetailResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.QtyDetailResult

No usage of bb.common.QtyDetailResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.QualityGroupPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.QualityGroupPK

Packages that use QualityGroupPK
bb.common
bb.common.box

Uses of QualityGroupPK in bb.common

Methods in bb.common that return QualityGroupPK
 QualityGroupPK QualityGroupVO.getPk()

Methods in bb.common with parameters of type QualityGroupPK
 void QualityGroupVO.setPk(QualityGroupPK pk)

Constructors in bb.common with parameters of type QualityGroupPK
QualityGroupVO(QualityGroupPK pk)
full constructor

Uses of QualityGroupPK in bb.common.box

Methods in bb.common.box with parameters of type QualityGroupPK
 QualityGroupVO QualityBox.findQualityGroupByPk(QualityGroupPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.QualityGroupVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.QualityGroupVO

Packages that use QualityGroupVO
bb.common.box

Uses of QualityGroupVO in bb.common.box

Methods in bb.common.box that return QualityGroupVO
QualityGroupVO | QualityBox.addQualityGroup(QualityGroupVO vo)
QualityGroupVO | QualityBox.findQualityGroupByPk(QualityGroupPK pk)
QualityGroupVO | QualityBox.updateQualityGroup(QualityGroupVO vo)

Methods in bb.common.box that return types with arguments of type QualityGroupVO
 java.util.Collection<QualityGroupVO> QualityBox.findAllQualityGroups(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type QualityGroupVO
QualityGroupVO | QualityBox.addQualityGroup(QualityGroupVO vo)
void | QualityBox.deleteQualityGroup(QualityGroupVO vo)
QualityGroupVO | QualityBox.updateQualityGroup(QualityGroupVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.QualityInfoCenterResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.QualityInfoCenterResult

Packages that use QualityInfoCenterResult
bb.common.box

Uses of QualityInfoCenterResult in bb.common.box

Methods in bb.common.box that return QualityInfoCenterResult
 QualityInfoCenterResult ManagementBox.getQualityInfoCenterResult()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Quote2QuoteAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Quote2QuoteAgent

Packages that use Quote2QuoteAgent
bb.common.box

Uses of Quote2QuoteAgent in bb.common.box

Methods in bb.common.box with parameters of type Quote2QuoteAgent
 java.lang.String SalesBox.copyQuoteToQuote(Quote2QuoteAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.QuoteBoilerplateVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.QuoteBoilerplateVO

Packages that use QuoteBoilerplateVO
bb.common.box

Uses of QuoteBoilerplateVO in bb.common.box

Methods in bb.common.box that return QuoteBoilerplateVO
QuoteBoilerplateVO | SalesBox.addQuoteBP(QuoteBoilerplateVO vo)
QuoteBoilerplateVO | SalesBox.getQuoteBPByPk(java.lang.String quoteBoilerplateId)
QuoteBoilerplateVO | SalesBox.updateQuoteBP(QuoteBoilerplateVO vo)

Methods in bb.common.box that return types with arguments of type QuoteBoilerplateVO
java.util.Collection<QuoteBoilerplateVO> | SalesBox.findAllQuoteBP(int firstIndex, int maxLength)
java.util.Collection<QuoteBoilerplateVO> | SalesBox.findQuoteBPByBPId(java.lang.String bpId, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type QuoteBoilerplateVO
QuoteBoilerplateVO | SalesBox.addQuoteBP(QuoteBoilerplateVO vo)
QuoteBoilerplateVO | SalesBox.updateQuoteBP(QuoteBoilerplateVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.QuoteDocumentVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.QuoteDocumentVO

Packages that use QuoteDocumentVO
bb.common.box

Uses of QuoteDocumentVO in bb.common.box

Methods in bb.common.box that return QuoteDocumentVO
 QuoteDocumentVO SalesBox.getQuoteDocumentByID(java.lang.Long controlNumber)

Methods in bb.common.box that return types with arguments of type QuoteDocumentVO
java.util.Collection<QuoteDocumentVO> | SalesBox.deleteQuoteDocument(MiscDocAgent agent)
java.util.Collection<QuoteDocumentVO> | SalesBox.findQuoteDocumentInfo(java.lang.String quoteNumber, int firstIndex, int maxLength)
java.util.Collection<QuoteDocumentVO> | SalesBox.uploadOrUpdateQuoteDocument(MiscDocAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.QuoteItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.QuoteItemListResult

Packages that use QuoteItemListResult
bb.common.box

Uses of QuoteItemListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type QuoteItemListResult
java.util.Collection<QuoteItemListResult> | SalesBox.findCancelledQuoteItem(int firstIndex, int maxLength)
java.util.Collection<QuoteItemListResult> | SalesBox.findOpenQuoteItemByAddressId(java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<QuoteItemListResult> | SalesBox.findOpenQuoteItemByPartPk(PartPK partPk, int firstIndex, int maxLength)
java.util.Collection<QuoteItemListResult> | SalesBox.findQuoteItemByAddressId(java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<QuoteItemListResult> | SalesBox.findQuoteItemByDate(PartPK partPk, java.lang.String quoteNumber, java.lang.String customerRFQNumber, java.lang.String customerId, java.lang.String includeCustomerIds, java.lang.String excludeCustomerIds, java.lang.String salesMan, java.util.Date fromDate, java.util.Date toDate, java.lang.String status, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<QuoteItemListResult> | SalesBox.findQuoteItemByPartLike(java.lang.String partNumber, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<QuoteItemListResult> | SalesBox.findQuoteItemByPartPk(PartPK pk, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.QuoteItemManufacturerPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.QuoteItemManufacturerPK

Packages that use QuoteItemManufacturerPK
bb.common

Uses of QuoteItemManufacturerPK in bb.common

Methods in bb.common that return QuoteItemManufacturerPK
 QuoteItemManufacturerPK QuoteItemManufacturerVO.getPk()

Methods in bb.common with parameters of type QuoteItemManufacturerPK
 void QuoteItemManufacturerVO.setPk(QuoteItemManufacturerPK pk)

Constructors in bb.common with parameters of type QuoteItemManufacturerPK
QuoteItemManufacturerVO(QuoteItemManufacturerPK pk, java.lang.String manufacturerName, java.lang.String manufacturerPartNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.QuoteItemManufacturerVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.QuoteItemManufacturerVO

No usage of bb.common.QuoteItemManufacturerVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.QuoteItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.QuoteItemPK

Packages that use QuoteItemPK
bb.common
bb.common.box

Uses of QuoteItemPK in bb.common

Methods in bb.common that return QuoteItemPK
 QuoteItemPK QuoteItemVO.getPk()

Methods in bb.common with parameters of type QuoteItemPK
 void QuoteItemVO.setPk(QuoteItemPK pk)

Uses of QuoteItemPK in bb.common.box

Methods in bb.common.box with parameters of type QuoteItemPK
 QuoteItemVO SalesBox.getQuoteItemVo(QuoteItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.QuoteItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.QuoteItemVO

Packages that use QuoteItemVO
bb.common.box

Uses of QuoteItemVO in bb.common.box

Methods in bb.common.box that return QuoteItemVO
QuoteItemVO | SalesBox.getQuoteItemVo(QuoteItemPK pk)
QuoteItemVO | SalesBox.initQuoteItem(QuoteVO soVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.QuoteListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.QuoteListResult

Packages that use QuoteListResult
bb.common.box

Uses of QuoteListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type QuoteListResult
java.util.Collection<QuoteListResult> | SalesBox.findAllOpenQuote(int firstIndex, int maxLength)
java.util.Collection<QuoteListResult> | SalesBox.findAllPastedQuotes(int firstIndex, int maxLength)
java.util.Collection<QuoteListResult> | SalesBox.findAllQuotes(int firstIndex, int maxLength)
java.util.Collection<QuoteListResult> | SalesBox.findOpenQuoteByAddressId(java.lang.String id, int firstIndex, int maxLength)
java.util.Collection<QuoteListResult> | SalesBox.findQuoteByAddressId(java.lang.String id, int firstIndex, int maxLength)
java.util.Collection<QuoteListResult> | SalesBox.findQuoteByQuoteNumberLike(java.lang.String qtNumberLike, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.QuoteVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.QuoteVO

Packages that use QuoteVO
bb.common.box

Uses of QuoteVO in bb.common.box

Methods in bb.common.box that return QuoteVO
QuoteVO | SalesBox.addQuote(QuoteVO vo)
QuoteVO | SalesBox.getQuoteById(java.lang.String qtNumber)
QuoteVO | SalesBox.quoteForCRFQ(java.lang.String crfqNumber)
QuoteVO | SalesBox.reviewQuote(java.lang.String qtNumber)
QuoteVO | SalesBox.updateQuote(QuoteVO vo)

Methods in bb.common.box with parameters of type QuoteVO
QuoteVO | SalesBox.addQuote(QuoteVO vo)
QuoteItemVO | SalesBox.initQuoteItem(QuoteVO soVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool)
QuoteVO | SalesBox.updateQuote(QuoteVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Reason

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Reason

Packages that use Reason
bb.common

Uses of Reason in bb.common

Fields in bb.common declared as Reason
static Reason | BIZReason.ACCOUNT_CHART_CATEGORY_ALREADY_EXIST
static Reason | BIZReason.ACCOUNT_CHART_CATEGORY_NAME_ALREADY_EXIST
static Reason | BIZReason.ACCOUNT_CHART_CATEGORY_NAME_NOT_EXIST
static Reason | BIZReason.ACCOUNT_CHART_CATEGORY_NOT_EXIST
static Reason | BIZReason.ACCOUNT_CHART_MAPPING_ALREADY_EXIST
static Reason | BIZReason.ACCOUNT_CHART_MAPPING_NOT_EXIST
static Reason | BIZReason.ACCOUNT_CREDIT_DEBIT_WRONG
static Reason | BIZReason.ACCOUNT_FISCALYEAR_SETTING_NOT_EXIST
static Reason | BIZReason.ACCOUNT_MUST_BE_CURRENT_ASSET
static Reason | BIZReason.ACCOUNT_NUMBER_ALREADY_EXIST
static Reason | BIZReason.ACCOUNT_NUMBER_HAS_CHILD
static Reason | BIZReason.ACCOUNT_NUMBER_IN_USE
static Reason | BIZReason.ACCOUNT_NUMBER_IS_NOT_EXPENSE_ACCOUNT
static Reason | BIZReason.ACCOUNT_NUMBER_IS_USED_IN_ASSET
static Reason | BIZReason.ACCOUNT_NUMBER_IS_USED_IN_CREDIT
static Reason | BIZReason.ACCOUNT_NUMBER_IS_USED_IN_DEBIT
static Reason | BIZReason.ACCOUNT_NUMBER_NOT_EXIST
static Reason | BIZReason.ACCOUNT_NUMBER_USING_IN_OPEN_FISCAL_YEAR
static Reason | BIZReason.ACCOUNT_PAYABLE_NOT_EXIST
static Reason | BIZReason.ACCOUNT_SETTINGS_DID_NOT_SET_WIP_START_DATE
static Reason | BIZReason.ACCOUNT_SETTINGS_GA_COGS_WRONG
static Reason | BIZReason.ACCOUNT_SETTINGS_GA_PROFIT_FOR_CURRENT_YEAR_WRONG
static Reason | BIZReason.ACCOUNT_SETTINGS_GA_WIP_WRONG
static Reason | BIZReason.ACCOUNT_SETTINGS_NOT_EXIST
static Reason | BIZReason.ACCOUNT_SETTINGS_UNKNOWN_INVENTORY_COST_MOTHED
static Reason | BIZReason.ACCOUNT_TRANSACTION_TYPE_ALREADY_EXIST
static Reason | BIZReason.ACCOUNT_TRANSACTION_TYPE_NOT_EXIST
static Reason | BIZReason.ACCOUNT_TYPE_EMPTY
static Reason | BIZReason.ACCOUNTING_INFO_DOC_NOT_FIND
static Reason | BIZReason.ACCOUNTING_PERIOD_ALREADY_EXISTS
static Reason | BIZReason.ACCOUNTING_REPORTS_IN_THIS_FISCAL_YEAR__NEED_TO_BACK_UP
static Reason | BIZReason.ACCT_OF_PAYABLE_METHOD_IS_NULL
static Reason | BIZReason.ACCUMULATED_DEPR_ACCOUNT_EMPTY
static Reason | BIZReason.ADDRESS_CAN_NOT_USE_BACKFLUSH
static Reason | BIZReason.ADDRESS_ID_DOES_NOT_EXIST
static Reason | BIZReason.ADDRESS_ID_IS_DELETED
static Reason | BIZReason.ADDRESS_ID_IS_NOT_CUSTOMER
static Reason | BIZReason.ADDRESS_ID_USED_IN_AP
static Reason | BIZReason.ADDRESS_ID_USED_IN_AR
static Reason | BIZReason.ADDRESS_ID_USED_IN_PO
static Reason | BIZReason.ADDRESS_ID_USED_IN_QUOTE
static Reason | BIZReason.ADDRESS_ID_USED_IN_RFQ
static Reason | BIZReason.ADDRESS_ID_USED_IN_RMA
static Reason | BIZReason.ADDRESS_ID_USED_IN_RTV
static Reason | BIZReason.ADDRESS_ID_USED_IN_SO
static Reason | BIZReason.ADDRESS_ID_USED_IN_WO
static Reason | BIZReason.ADDRESS_QA_DOC_NOT_FIND
static Reason | BIZReason.ADMIN_ACCOUNT_CAN_NOT_BE_REMOVED
static Reason | BIZReason.ALREADY_LOGOUT
static Reason | BIZReason.ALREADY_WRITE_OFF
static Reason | BIZReason.AMORTIZATION_EXPENSE_ACCOUNT_EMPTY
static Reason | BIZReason.AP_PREPAY_ALREADY_CANCELLED
static Reason | BIZReason.AP_PREPAY_ALREADY_EXIST
static Reason | BIZReason.AP_PREPAY_ALREDAY_APPLY
static Reason | BIZReason.AP_PREPAY_ALREDAY_PAID
static Reason | BIZReason.AP_PREPAY_BIGGER_THAN_PO_TOTAL
static Reason | BIZReason.AP_PREPAY_GL_IS_NOT_ENOUGH
static Reason | BIZReason.AP_PREPAY_PAID_BIGGER_THAN_PO_TOTAL
static Reason | BIZReason.APDM_APPROVED_BY_CAN_NOT_BE_EMPTY
static Reason | BIZReason.APDM_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY
static Reason | BIZReason.APP_COLUMN_NAME_SHOULD_START_WITH_APP
static Reason | BIZReason.APP_ITEM_NOT_EXIST
static Reason | BIZReason.APP_TABLE_NAME_SHOULD_START_WITH_APP
static Reason | BIZReason.APPROVED_ACTION_IS_FORBIDDEN_WHEN_UPDATE
static Reason | BIZReason.APPROVED_IS_FORBIDDEN_WHEN_UPDATE
static Reason | BIZReason.APPROVED_OBJECT_NOT_ALLOW_UPDATE_AGAIN
static Reason | BIZReason.AR_IS_CLOSED
static Reason | BIZReason.AR_PREPAY_ALREADY_EXIST
static Reason | BIZReason.AR_PREPAY_ALREDAY_PAID
static Reason | BIZReason.AR_PREPAY_BIGGER_THAN_SO_TOTAL
static Reason | BIZReason.AR_PREPAY_GL_IS_NOT_ENOUGH
static Reason | BIZReason.ARCM_APPROVED_BY_CAN_NOT_BE_EMPTY
static Reason | BIZReason.ARCM_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY
static Reason | BIZReason.ASSET_ACCUMULATED_DEPRECIATION_OVER
static Reason | BIZReason.ASSET_ACQUISITION_COST_LESS_THAN_INITIAL_DEPRECIATE_COST
static Reason | BIZReason.ASSET_APPROVED_BY_CAN_NOT_BE_EMPTY
static Reason | BIZReason.ASSET_DEPRECIATE_ALREADY_EXIST
static Reason | BIZReason.ASSET_DEPRECIATE_HAVE_MADE_GL
static Reason | BIZReason.ASSET_HAS_EXIST
static Reason | BIZReason.ASSET_INITIAL_DEPRECIATE_COST_LESS_THAN_DEPRECIATED_ACCM
static Reason | BIZReason.ASSET_NOT_EXIST
static Reason | BIZReason.ASSET_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY
static Reason | BIZReason.ASSET_TYPE_ALREADY_EXIST
static Reason | BIZReason.ASSET_TYPE_IS_ALREADY_USED
static Reason | BIZReason.AUTHORIZATION_REQUIRED
static Reason | BIZReason.BACKFLUSH_LOCATION_FOR_DEPARTMENT_NOT_EXIST
static Reason | BIZReason.BANK_RECONCILIATION_REPORT_HAS_EXIST
static Reason | BIZReason.BANK_RECONCILIATION_REPORT_NOT_EXIST
static Reason | BIZReason.BILL_CAN_NOT_CONTAINS_ITSELF
static Reason | BIZReason.BILL_TO_ID_IS_NOT_EXIST
static Reason | BIZReason.BIZBOX_USER_ALREADY_EXIST
static Reason | BIZReason.BIZBOX_USER_HAS_NO_RULES
static Reason | BIZReason.BIZBOX_USER_IS_EMPLOYEE
static Reason | BIZReason.BIZBOX_USER_IS_LOCKED
static Reason | BIZReason.BIZBOX_USER_NOT_EMPLOYEE
static Reason | BIZReason.BIZBOX_USER_NOT_EXIST
static Reason | BIZReason.BIZBOX_USER_NOT_EXIST_FOR_THIS_EMPLOYEE
static Reason | BIZReason.BOM_ALREADY_EXIST
static Reason | BIZReason.BOM_APPROVAL_ALREADY_EXIST
static Reason | BIZReason.BOM_APPROVAL_NOT_EXIST
static Reason | BIZReason.BOM_NOT_EXIST
static Reason | BIZReason.BUYER_CODE_ALREADY_EXIST
static Reason | BIZReason.BUYER_CODE_DO_NOT_EXIST
static Reason | BIZReason.BUYER_CODE_IS_USING
static Reason | BIZReason.CALCULATE_NEW_CSI_NUMBER_ERROR
static Reason | BIZReason.CALCULATE_NEW_DEBIT_MEMO_NUMBER_ERROR
static Reason | BIZReason.CALCULATE_NEW_EXPENSES_NUMBER_ERROR
static Reason | BIZReason.CALCULATE_NEW_LOAN_NUMBER_ERROR
static Reason | BIZReason.CALCULATE_NEW_PAYMENT_RUN_NUMBER_ERROR
static Reason | BIZReason.CALCULATE_NEW_QUOTE_ERROR
static Reason | BIZReason.CALCULATE_NEW_RFC_NUMBER_ERROR
static Reason | BIZReason.CALCULATE_NEW_RRMA_NUMBER_ERROR
static Reason | BIZReason.CALCULATE_NEW_SALES_ORDER_ERROR
static Reason | BIZReason.CAN_NOT_ADD_NEW_IR_ITEM
static Reason | BIZReason.CAN_NOT_ADD_NEW_PAYABLE_METHOD
static Reason | BIZReason.CAN_NOT_APPROVE_ERROR_GL
static Reason | BIZReason.CAN_NOT_APPROVE_GL_CREATED_BY_YOURSELF
static Reason | BIZReason.CAN_NOT_BE_RECEIVED
static Reason | BIZReason.CAN_NOT_CANCEL_AP_WITH_PAYMENT
static Reason | BIZReason.CAN_NOT_CANCEL_AR_WITH_RECEIVED_PAYMENT
static Reason | BIZReason.CAN_NOT_CANCEL_GL_APPROVED_BY_OTHER
static Reason | BIZReason.CAN_NOT_CANCEL_THE_OPEN_ORDER
static Reason | BIZReason.CAN_NOT_CHANGE_DISASSEMBLE_WORK_ORDER_ITEM_QTY_ISSUED
static Reason | BIZReason.CAN_NOT_CHANGE_IR_QUALITIFY_QTY
static Reason | BIZReason.CAN_NOT_CHANGE_PART_FOR_DWO_HAS_ISSUED
static Reason | BIZReason.CAN_NOT_CHANGE_PART_FOR_HAS_ISSUED
static Reason | BIZReason.CAN_NOT_CHANGE_PART_FOR_HAS_RECEIVED
static Reason | BIZReason.CAN_NOT_CHANGE_PART_FOR_HAS_SHIPPED
static Reason | BIZReason.CAN_NOT_CHANGE_STATUS
static Reason | BIZReason.CAN_NOT_CHANGE_THE_FISCAL_YEAR_SETTINGS
static Reason | BIZReason.CAN_NOT_CHANGE_THIS_MONTH_EXCHANGE_RATE
static Reason | BIZReason.CAN_NOT_CHANGE_TRANSFER_TYPE
static Reason | BIZReason.CAN_NOT_CHANGE_WORK_ORDER_ITEM_QTY_ASM
static Reason | BIZReason.CAN_NOT_COPY_NOT_APPROVED_ECR
static Reason | BIZReason.CAN_NOT_COPY_PURCHASE_ORDER_FROM_CLOSED_SALES_ORDER_OR_NOT_REVIEW_SALES_ORDER
static Reason | BIZReason.CAN_NOT_COPY_WORK_ORDER_FROM_CLOSED_SALES_ORDER_OR_NOT_REVIEW_SALES_ORDER
static Reason | BIZReason.CAN_NOT_DELETE_DEFAULT_WI
static Reason | BIZReason.CAN_NOT_DELETE_DISASSEMBLE_WORK_ORDER_ITEM
static Reason | BIZReason.CAN_NOT_DELETE_ISSUED_RECORD
static Reason | BIZReason.CAN_NOT_DELETE_NONPRODUCTIVE_PICKING_ITEM
static Reason | BIZReason.CAN_NOT_DELETE_PREDEFINED_CHART_ACCOUNT_CATEGORY
static Reason | BIZReason.CAN_NOT_DELETE_REF_DOC_IN_IR
static Reason | BIZReason.CAN_NOT_DELETE_SWA_SHIPPER_ITEM
static Reason | BIZReason.CAN_NOT_DELETE_SWAP_ORDER_ITEM
static Reason | BIZReason.CAN_NOT_DELETE_THE_FISCAL_YEAR_SETTINGS
static Reason | BIZReason.CAN_NOT_DELETE_TRANSFER_ORDER_ITEM
static Reason | BIZReason.CAN_NOT_DELETE_TRANSFER_SHIPPER_ITEM
static Reason | BIZReason.CAN_NOT_DELETE_WORK_ORDER_ITEM
static Reason | BIZReason.CAN_NOT_ERROR_OR_CANCEL_GL_CREATED_BY_YOURSELF
static Reason | BIZReason.CAN_NOT_FIND_ACCOUNTING_INFO_DOC_SETTINGS
static Reason | BIZReason.CAN_NOT_FIND_ADDRESS_QA_DOC_SETTINGS
static Reason | BIZReason.CAN_NOT_FIND_CS_ITEM_DOC_SETTINGS
static Reason | BIZReason.CAN_NOT_FIND_CUSTOMER_DOC_SETTINGS
static Reason | BIZReason.CAN_NOT_FIND_DOCUMENT
static Reason | BIZReason.CAN_NOT_FIND_DOCUMENT_SETTINGS
static Reason | BIZReason.CAN_NOT_FIND_DWF_SETTINGS
static Reason | BIZReason.CAN_NOT_FIND_DWG_SETTINGS
static Reason | BIZReason.CAN_NOT_FIND_EDC_DOC_SETTINGS
static Reason | BIZReason.CAN_NOT_FIND_EMP_TRAINING_RECORDS_SETTINGS
static Reason | BIZReason.CAN_NOT_FIND_INIT_FILE
static Reason | BIZReason.CAN_NOT_FIND_QT_DOC_SETTINGS
static Reason | BIZReason.CAN_NOT_FIND_RMA_DOC_SETTINGS
static Reason | BIZReason.CAN_NOT_FIND_SO_DOC_SETTINGS
static Reason | BIZReason.CAN_NOT_FIND_VENDOR_DOC_SETTINGS
static Reason | BIZReason.CAN_NOT_FIND_VENDOR_PART
static Reason | BIZReason.CAN_NOT_FIND_YOUR_TRUE_NAME
static Reason | BIZReason.CAN_NOT_GET_SYSTEM_INFO
static Reason | BIZReason.CAN_NOT_HAVE_WORK_ORDER_ITEM_QTY_ASM
static Reason | BIZReason.CAN_NOT_LINK_TO_MORE_THAN_ONE_ORDERS
static Reason | BIZReason.CAN_NOT_NULL
static Reason | BIZReason.CAN_NOT_RECEIVE_NA_AND_OTHER_PART_AT_SAME_TIME
static Reason | BIZReason.CAN_NOT_UPDATE_SHIPPED_PACKING_BOX
static Reason | BIZReason.CAN_NOT_ZERO_SIZE_FILE
static Reason | BIZReason.CAN_ONLY_APPROVE_NOT_APPROVED_OPERATING_INSTRUCTION
static Reason | BIZReason.CAN_ONLY_CLOSE_FINISH_INSPECTIONFOR_OPERATING_INSTRUCTION
static Reason | BIZReason.CAN_ONLY_COMMIT_FINISHED_WORKSHEET
static Reason | BIZReason.CAN_ONLY_COMMIT_OPEN_WORKSHEET
static Reason | BIZReason.CAN_ONLY_CONTINUE_PAUSED_OPERATING_INSTRUCTION
static Reason | BIZReason.CAN_ONLY_CREATE_INSPECTION_REPORT_FROM_REQUEST_INSPECTIONFOR_OPERATING_INSTRUCTION
static Reason | BIZReason.CAN_ONLY_FINISH_OPEN_OPERATING_INSTRUCTION
static Reason | BIZReason.CAN_ONLY_OVER_CARRYING_COMMITTED_WORKSHEET
static Reason | BIZReason.CAN_ONLY_PAUSE_OPEN_OPERATING_INSTRUCTION
static Reason | BIZReason.CAN_ONLY_REQUEST_INSPECTIONFOR_FINISH_OPERATING_INSTRUCTION
static Reason | BIZReason.CAN_ONLY_UPDATE_WAITING_WORKSHEET
static Reason | BIZReason.CARRIER_ALREADY_EXIST
static Reason | BIZReason.CARRIER_NOT_EXIST
static Reason | BIZReason.CARRIER_USING_BY_PO
static Reason | BIZReason.CARRIER_USING_BY_RMA
static Reason | BIZReason.CARRIER_USING_BY_RTV
static Reason | BIZReason.CARRIER_USING_BY_SO
static Reason | BIZReason.CASH_OR_BANK_BALANCE_CAN_BE_NEGATIVE
static Reason | BIZReason.CASHIER_ALREADY_EXIST
static Reason | BIZReason.CATALOG_ALREADY_EXIST
static Reason | BIZReason.CATALOG_IS_USED
static Reason | BIZReason.CATALOG_NOT_EXIST
static Reason | BIZReason.CATEGORY_ID_HAS_EXIST
static Reason | BIZReason.CATEGORY_ID_NOT_EXIST
static Reason | BIZReason.CATEGORY_ID_STILL_USED
static Reason | BIZReason.CATEGORY_INDEX_ALREADY_EXIST_IN_PARENT_CATEGORY
static Reason | BIZReason.CERTIFICATE_DESCRIPTION_ALREADY_EXIST
static Reason | BIZReason.CERTIFICATE_DESCRIPTION_IS_NOT_USING
static Reason | BIZReason.CERTIFICATE_DESCRIPTION_IS_USING
static Reason | BIZReason.CERTIFICATE_DESCRIPTION_NOT_EXIST
static Reason | BIZReason.CERTIFICATE_DOC_NOT_FIND
static Reason | BIZReason.CERTIFICATE_NUMBER_IS_USED
static Reason | BIZReason.CHANGE_STD_COST_WORKSHEET_NOT_EXIST
static Reason | BIZReason.CHECK_NUMBER_ALREADY_EXIST
static Reason | BIZReason.CHECK_NUMBER_NOT_EXIST
static Reason | BIZReason.CHECK_NUMBER_NOT_MATCH
static Reason | BIZReason.CHECK_OBJECT_EXIST_ERROR
static Reason | BIZReason.CHECK_RUN_ALREADY_COMMITTED
static Reason | BIZReason.CHECK_RUN_ALREADY_EXIST
static Reason | BIZReason.CHECK_RUN_NOT_EXIST
static Reason | BIZReason.CLEAR_REFERENCE_DOC_ERROR
static Reason | BIZReason.CLOSED_OBJECT_CAN_NOT_ALLOWED_IF_ITEM_NOT_FINISHED
static Reason | BIZReason.CLOSED_OBJECT_NOT_ALLOW_UPDATE_AGAIN
static Reason | BIZReason.CLOSEING_STATEMENT_WRONG
static Reason | BIZReason.COMPANY_NOT_EXIST
static Reason | BIZReason.COMPANY_UNIT_ACCOUNT_ALREADY_EXIST
static Reason | BIZReason.COMPANY_UNIT_ACCOUNT_NOT_EXIST
static Reason | BIZReason.COMPANY_UNIT_ALREADY_EXIST
static Reason | BIZReason.COMPANY_UNIT_DOES_NOT_MATCH
static Reason | BIZReason.COMPANY_UNIT_NOT_EXIST
static Reason | BIZReason.CONTRACT_PRICE_CUSTOMER_HAS_EXIST
static Reason | BIZReason.CONTRACT_PRICE_CUSTOMER_NOT_EXIST
static Reason | BIZReason.CONTRACT_PRICE_HAS_EXIST
static Reason | BIZReason.CONTRACT_PRICE_ITEM_HAS_EXIST
static Reason | BIZReason.CONTRACT_PRICE_ITEM_NOT_EXIST
static Reason | BIZReason.CONTRACT_PRICE_NOT_EXIST
static Reason | BIZReason.COST_CAN_NOT_BE_ZERO
static Reason | BIZReason.CREATE_DIRECTORY_FAILED
static Reason | BIZReason.CREDIT_MEMO_ALREADY_EXIST
static Reason | BIZReason.CREDIT_MEMO_NOT_EXIST
static Reason | BIZReason.CS_ITEM_DOC_NOT_FIND
static Reason | BIZReason.CURRENCY_ALREADY_EXIST
static Reason | BIZReason.CURRENCY_EXCHANGE_MUST_BE_ONE
static Reason | BIZReason.CURRENCY_EXCHANGE_NOT_EXIST
static Reason | BIZReason.CURRENCY_EXCHANGE_SHOULD_BE_POSITIVE
static Reason | BIZReason.CURRENCY_NOT_EXIST
static Reason | BIZReason.CUSTOMER_DOC_NOT_FIND
static Reason | BIZReason.CUSTOMER_FEEDBACK_ALREADY_EXIST
static Reason | BIZReason.CUSTOMER_FEEDBACK_ITEM_ALREADY_EXIST
static Reason | BIZReason.CUSTOMER_FEEDBACK_ITEM_NOT_EXIST
static Reason | BIZReason.CUSTOMER_FEEDBACK_NOT_EXIST
static Reason | BIZReason.CUSTOMER_NOT_EXIST_TERM
static Reason | BIZReason.CUSTOMER_PART_CATALOG_ALREADY_EXIST
static Reason | BIZReason.CUSTOMER_PART_CATALOG_NOT_EXIST
static Reason | BIZReason.CUSTOMER_PART_NOT_EXIST
static Reason | BIZReason.CUSTOMER_SERVICE_INCIDENT_ALREADY_EXIST
static Reason | BIZReason.CUSTOMER_SERVICE_INCIDENT_NOT_EXIST
static Reason | BIZReason.CUSTOMER_SERVICE_REQUEST_NOT_EXIST
static Reason | BIZReason.CUSTOMER_VENDOR_TYPE_ALREADY_EXIST
static Reason | BIZReason.CUSTOMER_VENDOR_TYPE_NOT_EXIST
static Reason | BIZReason.CYCLE_WORK_SHEET_ALREADY_CLOSED
static Reason | BIZReason.CYCLE_WORK_SHEET_HAS_EXIST
static Reason | BIZReason.CYCLE_WORK_SHEET_NOT_EXIST
static Reason | BIZReason.CYCLE_WORK_SHEET_NUMBER_REQUIRE
static Reason | BIZReason.CYCLE_WORK_SHEET_PAGE_NUMBER_HAS_EXIST
static Reason | BIZReason.CYCLE_WORK_SHEET_PAGE_NUMBER_NOT_EXIST
static Reason | BIZReason.DATE_CAN_NOT_BE_NULL
static Reason | BIZReason.DATE_WRONG
static Reason | DBReason.DBA_SYS_EXCEPTION
static Reason | BIZReason.DEBITS_NOT_MATCH_CREDITS
static Reason | BIZReason.DEBITS_OR_CREDIT_DOES_NOT_ZERO
static Reason | BIZReason.DEFAULT_MFG_IS_EMPTY
static Reason | BIZReason.DELETE_FROM_DB_ERROR
static Reason | BIZReason.DELETE_ON_LOAN_ITEM_ERROR
static Reason | BIZReason.DELETE_PICTURE_FIRST
static Reason | BIZReason.DELETE_QUOTE_ITEM_ERROR
static Reason | BIZReason.DELETE_RMA_ITEM_ERROR
static Reason | BIZReason.DELETE_SALES_ORDER_ITEM_ERROR
static Reason | BIZReason.DEPARTMENT_LOCATION_FOR_BACKFLUSH_ALREADY_ADDED
static Reason | BIZReason.DEPARTMENT_LOCATION_FOR_BACKFLUSH_NOT_EXIST
static Reason | BIZReason.DESIGN_CONTROL_NOT_EXIST
static Reason | BIZReason.DESTINATION_NOT_EXIST
static Reason | BIZReason.DIRECTORY_NOT_EXIST
static Reason | BIZReason.DISASSEMBLE_WORK_ORDER_ALREADY_SETUP_OR_RUN
static Reason | BIZReason.DISASSEMBLE_WORK_ORDER_APPROVAL_ALREADY_EXIST
static Reason | BIZReason.DISASSEMBLE_WORK_ORDER_APPROVAL_NOT_EXIST
static Reason | BIZReason.DISASSEMBLE_WORK_ORDER_ITEM_GL_HAS_CREATED
static Reason | BIZReason.DISASSEMBLE_WORK_ORDER_ITEM_HAS_CLOSED
static Reason | BIZReason.DISASSEMBLE_WORK_ORDER_ITEM_HAS_NOT_CLOSED
static Reason | BIZReason.DISASSEMBLE_WORK_ORDER_ITEM_NOT_EXIST
static Reason | BIZReason.DISASSEMBLE_WORK_ORDER_ITEM_NOT_OPEN
static Reason | BIZReason.DISASSEMBLE_WORK_ORDER_ITEM_RECEIVED_QTY_IS_OVER
static Reason | BIZReason.DISASSEMBLE_WORK_ORDER_ITEM_RECEIVER_NOT_EXIST
static Reason | BIZReason.DISASSEMBLE_WORK_ORDER_NOT_EXIST
static Reason | BIZReason.DISASSEMBLE_WORK_ORDER_NOT_OPEN
static Reason | BIZReason.DOCUMENT_NOT_FOUND
static Reason | BIZReason.DOCUMENT_SERVER_SETTINGS_ALREADY_EXIST
static Reason | BIZReason.DOCUMENT_SETTINGS_NOT_EXIST
static Reason | BIZReason.DOCUMENT_SETTINGS_NOT_SAVE_TO_FTP
static Reason | BIZReason.DOCUMENT_SETTINGS_WRONG
static Reason | BIZReason.DOES_NOT_SET_UNBILLED_ACCOUNT
static Reason | BIZReason.DOES_NOT_SET_UNBILLED_INCOME_ACCOUNT
static Reason | BIZReason.DRAWING_WAS_DAMEDAGED
static Reason | BIZReason.DUPLICATE_ITEM
static Reason | DBReason.DUPLICATE_KEY_EXCEPTION
static Reason | BIZReason.DUPLICATE_KEY_ITEM
static Reason | BIZReason.DUPLICATE_LOGIN
static Reason | BIZReason.DUPLICATE_MPN
static Reason | BIZReason.DUPLICATE_PERIOD_ID
static Reason | BIZReason.DUPLICATE_REVISION_LETTERS
static Reason | BIZReason.DWO_ITEM_RETURN_QTY_IS_OVER
static Reason | BIZReason.ECN_REVIEW_ALREADY_EXIST
static Reason | BIZReason.ECN_REVIEW_NOT_EXIST
static Reason | BIZReason.ECR_APPROVAL_ALREADY_EXIST
static Reason | BIZReason.ECR_APPROVAL_NOT_EXIST
static Reason | BIZReason.EDC_DOC_NOT_FIND
static Reason | BIZReason.EJB_INVOKE_FAILED
static Reason | BIZReason.EMP_TRAINING_RECORDS_NOT_FIND
static Reason | BIZReason.EMPLOYEE_ALREADY_ADDED
static Reason | BIZReason.EMPLOYEE_ALREADY_HAS_BIZBOX_USER_ACCOUNT
static Reason | BIZReason.EMPLOYEE_HAS_NO_BIZBOX_USER_ACCOUNT
static Reason | BIZReason.EMPLOYEE_ID_NOT_EXIST
static Reason | BIZReason.EMPLOYEE_TRAINING_ID_HAS_EXIST
static Reason | BIZReason.EMPLOYEE_TRAINING_ID_NOT_EXIST
static Reason | BIZReason.EMPTY_COLLECTION
static Reason | BIZReason.EMPTY_DOCUMENT
static Reason | BIZReason.EMPTY_GL_OR_ZERO_GL_ITEM
static Reason | BIZReason.EMPTY_ITEM_COLLECTION
static Reason | BIZReason.END_DATE_SHOULD_BE_BEFORE_THE_FOLLOW_FISCAL_YEAR_START_DATE
static Reason | BIZReason.END_MONTH_CAN_NOT_BE_EARLIER_THAN_START_MONTH
static Reason | BIZReason.ENG_GROUP_USED_IN_ENG_GROUP_USER
static Reason | BIZReason.ENG_GROUP_USED_IN_PART
static Reason | BIZReason.ENGINEERING_CHANGE_NOTICE_NOT_CLOSED_EXIST_FOR_THIS_PART
static Reason | BIZReason.ENGINEERING_CHANGE_NOTICE_NOT_EXIST
static Reason | BIZReason.ENGINEERING_CHANGE_REQUEST_NOT_EXIST
static Reason | BIZReason.ENGINEERING_SHARING_ALREADY_EXIST
static Reason | BIZReason.ENGINEERING_SHARING_ITEM_ALREADY_EXIST
static Reason | BIZReason.ENGINEERING_SHARING_NOT_EXIST
static Reason | BIZReason.ENGROUP_EXIST
static Reason | BIZReason.ENGROUP_HAS_ITEM
static Reason | BIZReason.ENGROUP_NOT_EXIST
static Reason | BIZReason.ENGROUP_USER_EXIST
static Reason | BIZReason.ENGROUP_USER_NOT_EXIST
static Reason | BIZReason.EQUIPMENT_ALREADY_EXIST
static Reason | BIZReason.EQUIPMENT_ALREADY_REF_TO_ASSET
static Reason | BIZReason.EQUIPMENT_ALREADY_USED_IN_WORK_CENTER
static Reason | BIZReason.EQUIPMENT_NOT_EXIST
static Reason | BIZReason.ERROR_GL_CAN_NOT_POST
static Reason | BIZReason.EXCEED_AUTHORIZED_APPROVAL_LIMIT
static Reason | BIZReason.EXCHANGE_RATE_IN_FISCAL_YEAR
static Reason | BIZReason.EXCHANGE_RATE_NOT_SETUP
static Reason | BIZReason.EXCHANGERATE_APPROVED_BY_BY_CAN_NOT_BE_EMPTY
static Reason | BIZReason.EXCHANGERATE_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY
static Reason | BIZReason.EXPENSE_ACCOUNT_ALREADY_EXIST
static Reason | BIZReason.EXPENSE_ACCOUNT_NOT_EXIST
static Reason | BIZReason.EXPENSE_ALREADY_EXIST
static Reason | BIZReason.EXPENSE_NOT_EXIST
static Reason | BIZReason.FAIL_LOGIN
static Reason | BIZReason.FEEDBACK_QUESTION_ALREADY_EXIST
static Reason | BIZReason.FEEDBACK_QUESTION_IN_USING
static Reason | BIZReason.FEEDBACK_QUESTION_NOT_EXIST
static Reason | BB2DocumentException.FILE_ALREADY_EXIST
static Reason | BB2DocumentException.FILE_IN_PROCESS
static Reason | BB2DocumentException.FILE_NOT_EXIST
static Reason | BIZReason.FILE_SYSTEM_OPERATION_FAILED
static Reason | BIZReason.FINANCING_EXPENSE_ACCOUNT_NOT_EXIST
static Reason | BIZReason.FIND_ACCOUNT_NUMBER_ERROR
static Reason | BIZReason.FIND_ACCOUNTING_SETTINGS_ERROR
static Reason | BIZReason.FIND_ADDRESS_ID_ERROR
static Reason | BIZReason.FIND_AP_CHECK_RUN_ERROR
static Reason | BIZReason.FIND_AP_ERROR
static Reason | BIZReason.FIND_APP_ERROR
static Reason | BIZReason.FIND_APP_ITEM_ERROR
static Reason | BIZReason.FIND_ARP_ERROR
static Reason | BIZReason.FIND_ARP_ITEM_ERROR
static Reason | BIZReason.FIND_BALANCE_SHEET_ERROR
static Reason | BIZReason.FIND_BIZBOX_USER_ERROR
static Reason | BIZReason.FIND_CAR_ERROR
static Reason | BIZReason.FIND_CARRIER_ERROR
static Reason | BIZReason.FIND_COMPANY_SETTINGS_ERROR
static Reason | BIZReason.FIND_CONTRACT_PRICE_ERROR
static Reason | BIZReason.FIND_CREDIT_MEMO_ERROR
static Reason | BIZReason.FIND_CURRENCY_ERROR
static Reason | BIZReason.FIND_DB_ERROR
static Reason | BIZReason.FIND_DEBIT_MEMO_ERROR
static Reason | BIZReason.FIND_EMPLOYEE_ID_ERROR
static Reason | BIZReason.FIND_FISCALYEAR_ERROR
static Reason | BIZReason.FIND_GENERAL_LEDGER_ERROR
static Reason | BIZReason.FIND_GENERAL_LEDGER_SETTINGS
static Reason | BIZReason.FIND_INCOTERMS_ERROR
static Reason | BIZReason.FIND_INSPECTION_TYPE_ERROR
static Reason | BIZReason.FIND_INVOICE_ERROR
static Reason | BIZReason.FIND_MANUFACTURER_ID_ERROR
static Reason | BIZReason.FIND_NCR_ERROR
static Reason | BIZReason.FIND_ON_LOAN_ERROR
static Reason | BIZReason.FIND_ON_LOAN_ITEM_ERROR
static Reason | BIZReason.FIND_PAR_ERROR
static Reason | BIZReason.FIND_PART_DESCRIPTION_ERROR
static Reason | BIZReason.FIND_PART_DISCOUNT_ERROR
static Reason | BIZReason.FIND_PARTPK_ERROR
static Reason | BIZReason.FIND_PAYMENT_RUN_ERROR
static Reason | BIZReason.FIND_POS_ERROR
static Reason | BIZReason.FIND_PURCHASE_ORDER_ERROR
static Reason | BIZReason.FIND_QUOTE_ERROR
static Reason | BIZReason.FIND_QUOTE_ITEM_ERROR
static Reason | BIZReason.FIND_RECEIVER_ERROR
static Reason | BIZReason.FIND_RMA_ERROR
static Reason | BIZReason.FIND_RMA_ITEM_ERROR
static Reason | BIZReason.FIND_RRMA_ERROR
static Reason | BIZReason.FIND_RRMA_ITEM_ERROR
static Reason | BIZReason.FIND_RTV_ERROR
static Reason | BIZReason.FIND_SALES_CODE_ERROR
static Reason | BIZReason.FIND_SALES_ORDER_ERROR
static Reason | BIZReason.FIND_SALES_ORDER_ID_ERROR
static Reason | BIZReason.FIND_SALES_ORDER_ITEM_ERROR
static Reason | BIZReason.FIND_SALESMAN_ERROR
static Reason | BIZReason.FIND_SHIPPER_ERROR
static Reason | BIZReason.FIND_SRUNNING_ACCOUNT_ORDER_ERROR
static Reason | BIZReason.FIND_TEMPORARYEMPLOYEE_ID_ERROR
static Reason | BIZReason.FIND_USER_GROUP_ERROR
static Reason | BIZReason.FIND_USER_ZIPCODE_TAX_ERROR
static Reason | BIZReason.FIND_VENDOR_ID_ERROR
static Reason | BIZReason.FIND_WEIGHT_UNIT_ERROR
static Reason | BIZReason.FIND_WORK_CENTER_ERROR
static Reason | BIZReason.FIND_WORK_INSTRUCTION_ERROR
static Reason | BIZReason.FIND_WORK_ORDER_ERROR
static Reason | BIZReason.FISCAL_YEAR_NOT_EXIST
static Reason | BIZReason.FISCAL_YEAR_SETTINGS_ALREADY_EXISTS
static Reason | BIZReason.FISCAL_YEAR_SETTINGS_CAN_NOT_BE_NULL
static Reason | BIZReason.FISCAL_YEAR_SETTINGS_STATUS_AFTER_NEED_TO_CHANGE
static Reason | BIZReason.FISCAL_YEAR_SETTINGS_STATUS_BEFORE_NEED_TO_CHANGE
static Reason | BIZReason.FISCAL_YEAR_SETTINGS_STATUS_SHOULD_BE_OPEN
static Reason | BIZReason.FTP_OPERATION_FAILED
static Reason | BIZReason.GENERAL_LEDGER_ALREADY_APPROVED
static Reason | BIZReason.GENERAL_LEDGER_ALREADY_EXIST
static Reason | BIZReason.GENERAL_LEDGER_APPROVAL_ALREADY_EXIST
static Reason | BIZReason.GENERAL_LEDGER_APPROVAL_NOT_EXIST
static Reason | BIZReason.GENERAL_LEDGER_BEEN_LOCKED
static Reason | BIZReason.GENERAL_LEDGER_CREDIT_DESRIPTION_IS_NULL
static Reason | BIZReason.GENERAL_LEDGER_DEBIT_DESRIPTION_IS_NULL
static Reason | BIZReason.GENERAL_LEDGER_NOT_BEEN_LOCKED
static Reason | BIZReason.GENERAL_LEDGER_NOT_EXIST
static Reason | BIZReason.GENERAL_LEDGER_SEQUENCE_ALREADY_EXIST
static Reason | BIZReason.GENERAL_LEDGER_SEQUENCE_CAN_NOT_BE_EMPTY
static Reason | BIZReason.GENERAL_LEDGER_SEQUENCE_NOT_EXIST
static Reason | BIZReason.GET_AP_PREPAY_ERROR
static Reason | BIZReason.GET_AR_PREPAY_ERROR
static Reason | BIZReason.GET_CG_CSRNUMBER_FAIL
static Reason | BIZReason.GET_CG_CUST_RFQNUMBER_FAIL
static Reason | BIZReason.GET_CUSTOMER_PART_ERROR
static Reason | BIZReason.GET_DISASSEMBLE_WORK_ORDER_APPROVAL_ERROR
static Reason | BIZReason.GET_ENGINEERING_CHANGE_REQUEST_WRONG
static Reason | BIZReason.GET_NEW_PURCHASE_WORK_SHEET_NUMBER_ERROR
static Reason | BIZReason.GET_ONLOAN_REVIEW_ERROR
static Reason | BIZReason.GET_ORDER_ITEM_ERROR
static Reason | BIZReason.GET_PART_STANDARD_COST_ERROR
static Reason | BIZReason.GET_PART_VERSION_ERROR
static Reason | BIZReason.GET_PROFORMA_RECEIVER_ERROR
static Reason | BIZReason.GET_PURCHASE_ORDER_APPROVAL_ERROR
static Reason | BIZReason.GET_PURCHASE_ORDER_ERROR
static Reason | BIZReason.GET_PURCHASE_WORK_SHEET_ERROR
static Reason | BIZReason.GET_REQUEST_FOR_QUOTE_ERROR
static Reason | BIZReason.GET_RETURN_TO_VENDOR_APPROVAL_ERROR
static Reason | BIZReason.GET_RETURN_TO_VENDOR_ERROR
static Reason | BIZReason.GET_RFQ_MESSAGE_ERROR
static Reason | BIZReason.GET_RMA_REVIEW_ERROR
static Reason | BIZReason.GET_SALES_ORDER_REVIEW_ERROR
static Reason | BIZReason.GET_USER_TRUENAME_WRONG
static Reason | BIZReason.GET_VENDOR_ERROR
static Reason | BIZReason.GET_VENDOR_PART_ERROR
static Reason | BIZReason.GET_VERSION_ERROR
static Reason | BIZReason.GET_WORK_ORDER_APPROVAL_ERROR
static Reason | BIZReason.GET_WORK_ORDER_ERROR
static Reason | BIZReason.GET_WORK_WORK_SHEET_ERROR
static Reason | BIZReason.GL_IN_FISCAL_YEAR
static Reason | BIZReason.GL_LOCKED_DATE_SHOULD_BE_AFTER_FY_END_DATE
static Reason | BIZReason.GL_MONTH_ALREADY_CLOSED
static Reason | BIZReason.GL_MONTH_NOT_EXIST
static Reason | BIZReason.HAVE_CALIBRATION_RECORDS
static Reason | BIZReason.HAVE_ITEMS_NOT_CLOSED
static Reason | BIZReason.HAVE_NO_CALIBRATION_RECORDS
static Reason | BIZReason.HAVE_NOT_ENOUGH_QTY_TO_REC_IN_IR
static Reason | BIZReason.HAVE_NOT_INVENTORY
static Reason | DBReason.HIBERNATE_EXCEPTION
static Reason | BIZReason.ILEGAL_CREDIT_MEMO
static Reason | BIZReason.ILLEGAL_ACCOUNT_NUMBER
static Reason | BIZReason.ILLEGAL_CARRIER_ID
static Reason | BIZReason.ILLEGAL_CATEGORY_ID
static Reason | BIZReason.ILLEGAL_CCODE
static Reason | BIZReason.ILLEGAL_CONTRACT_PRICE_NUMBER
static Reason | BIZReason.ILLEGAL_DCODE
static Reason | BIZReason.ILLEGAL_DESIGN_CONTROL_DOCUMENT_EXTENSION
static Reason | BIZReason.ILLEGAL_DESIGN_CONTROL_DOCUMENT_SEQUENCE
static Reason | BIZReason.ILLEGAL_DRAWING_EXTENSION
static Reason | BIZReason.ILLEGAL_ECODE
static Reason | BIZReason.ILLEGAL_EDC_NUMBER
static Reason | BIZReason.ILLEGAL_ENGINEERING_CHANGE_REQUEST
static Reason | BIZReason.ILLEGAL_INCOTERM_ID
static Reason | BIZReason.ILLEGAL_MAKE_BUY_X
static Reason | BIZReason.ILLEGAL_OCODE
static Reason | BIZReason.ILLEGAL_PART_NUMBER_FORMAT
static Reason | BIZReason.ILLEGAL_PART_REVISION
static Reason | BIZReason.ILLEGAL_PCODE
static Reason | BIZReason.ILLEGAL_PO_MESSAGE_NUMBER
static Reason | BIZReason.ILLEGAL_PROFORMA_INVOICE_NUMBER
static Reason | BIZReason.ILLEGAL_PURCHASE_ORDER_ITEM_NUMBER
static Reason | BIZReason.ILLEGAL_PURCHASE_ORDER_MESSAGE_ITEM_NUMBER
static Reason | BIZReason.ILLEGAL_PURCHASE_ORDER_NUMBER
static Reason | BIZReason.ILLEGAL_QUOTE_ITEM_NUMBER
static Reason | BIZReason.ILLEGAL_REQUEST_FOR_QUOTE_ITEM_NUMBER
static Reason | BIZReason.ILLEGAL_REQUEST_FOR_QUOTE_NUMBER
static Reason | BIZReason.ILLEGAL_RETURN_TO_VENDOR_ITEM_NUMBER
static Reason | BIZReason.ILLEGAL_RETURN_TO_VENDOR_NUMBER
static Reason | BIZReason.ILLEGAL_REVISION_NUMBER_FORMAT
static Reason | BIZReason.ILLEGAL_RFQ_MESSAGE_ITEM_NUMBER
static Reason | BIZReason.ILLEGAL_RFQ_MESSAGE_NUMBER
static Reason | BIZReason.ILLEGAL_SALES_ORDER_ITEM_NUMBER
static Reason | BIZReason.ILLEGAL_SHIP_LIST_NUMBER
static Reason | BIZReason.ILLEGAL_SHIPPER_NUMBER
static Reason | BIZReason.ILLEGAL_SPECIFICATION_ID
static Reason | BIZReason.ILLEGAL_UNIT_NAME
static Reason | BIZReason.ILLEGAL_WORK_INSTRUCTION_SEQUENCE_NUMBER
static Reason | BIZReason.ILLEGAL_WORK_INSTRUCTION_SET_NUMBER
static Reason | BIZReason.ILLEGAL_WORK_ORDER_ITEM_NUMBER
static Reason | BIZReason.ILLEGAL_WORK_ORDER_NUMBER
static Reason | BIZReason.INCLUDE_BOM_SELF
static Reason | BIZReason.INCOTERM_ALREADY_EXIST
static Reason | BIZReason.INCOTERM_NOT_EXIST
static Reason | BIZReason.INCOTERM_USING_BY_PO
static Reason | BIZReason.INCOTERM_USING_BY_RMA
static Reason | BIZReason.INCOTERM_USING_BY_RTV
static Reason | BIZReason.INCOTERM_USING_BY_SO
static Reason | BIZReason.INPUT_CAN_NOT_BE_EMPTY_STRING
static Reason | BIZReason.INPUT_MUST_BE_EMPTY_STRING
static Reason | BIZReason.INQA_ALREADY_CREATE_NCR
static Reason | BIZReason.INSPECTION_REPORT_NOT_EXIST
static Reason | BIZReason.INSPECTION_TYPE_IS_EXISTENT
static Reason | BIZReason.INSPECTION_TYPE_IS_NOT_EXISTENT
static Reason | BIZReason.INSPECTION_TYPE_IS_USED
static Reason | BIZReason.INTERNAL_COMPANY_EMPLOYID_CAN_NOT_BE_NULL
static Reason | BIZReason.INVALID_ARGUMENT
static Reason | BIZReason.INVALID_PAY_DATE
static Reason | BIZReason.INVALID_USER
static Reason | BIZReason.INVOICE_NOT_CONSISTENT
static Reason | BIZReason.INVOICE_NOT_EXIST
static Reason | BIZReason.INVOKE_FAILED
static Reason | BIZReason.IR_ALREADY_EXIST
static Reason | BIZReason.IR_NOT_EXIST
static Reason | BIZReason.IRNUMBER_HAS_BEEN_USED
static Reason | BIZReason.IRNUMBER_IS_NOT_FOR_THIS_PURCHASE_ORDER_ITEM
static Reason | BIZReason.IRNUMBER_IS_NOT_FOR_THIS_WORK_ORDER_ITEM
static Reason | BIZReason.IRNUMBER_NOT_EXIST
static Reason | BIZReason.IRNUMBER_NOT_MATCH_PURCHASE_ORDER
static Reason | BIZReason.IRNUMBER_NOT_MATCH_WORK_ORDER
static Reason | BIZReason.ISSUED_QTY_IS_OVER_THAN_WO_ITEM_PART_DETAIL_QTY
static Reason | BIZReason.IT_HAS_NO_GL_TO_OVER_CARRY
static Reason | BIZReason.ITEM_QTY_IS_NOT_RIGHT
static Reason | BIZReason.ITEM_STATUS_IS_FORBIDDEN_TO_CHANGE_CURRENTLY
static Reason | BIZReason.JOB_CATEGORY_IS_USED
static Reason | BIZReason.LAST_PACKING_BOX_IS_EMPTY
static Reason | BIZReason.LEVEL_OR_UP_ACCOUNT_NUMBER_WRONG
static Reason | BIZReason.LINED_QTY_IS_OVER
static Reason | BIZReason.LINKED_ITEM_NOT_EXIST
static Reason | BIZReason.LINKED_ITEM_STATUS_IS_CLOSED
static Reason | BIZReason.LN_RECEIVER_NOT_EXIST
static Reason | BIZReason.LN_SHIPPER_EXIST
static Reason | BIZReason.LN_SHIPPER_ITEM_NOT_EXIST
static Reason | BIZReason.LN_SHIPPER_NOT_EXIST
static Reason | BIZReason.LOCATE_ALREADY_EXIST
static Reason | BIZReason.LOCATION_FOR_RETURN_MASTERIAL_IS_NOT_CONFIGURED
static Reason | BIZReason.LOCATION_OF_DEPARTMENT_LOCATION_FOR_BACKFLUSH_ALREADY_ADDED
static Reason | BIZReason.LOGIN_DATA_NOT_COMPLETED
static Reason | BIZReason.MAINTENANCE_ITEM_ALREADY_EXIST
static Reason | BIZReason.MAINTENANCE_ITEM_NOT_EXIST
static Reason | BIZReason.MANUFACTURE_ENGINEERING_CHANGE_NOTICE_NOT_CLOSED_EXIST_FOR_THIS_PART
static Reason | BIZReason.MANUFACTURER_ID_ALREADY_EXIST
static Reason | BIZReason.MANUFACTURER_ID_IS_DELETED
static Reason | BIZReason.MANUFACTURER_ID_NOT_EXIST
static Reason | BIZReason.MANUFACTURER_ID_USED_IN_PART
static Reason | BIZReason.MANUFACTURER_PART_NUMBER_NOT_EXIST
static Reason | BIZReason.MESSAGE_ALREADY_READ_BY_RECEIVER
static Reason | BIZReason.MESSAGE_IN_MONTH_NEED_REMAIN
static Reason | BIZReason.MESSAGE_NOT_EXIST
static Reason | BIZReason.METHOD_NOT_EXIST
static Reason | BIZReason.MISSING_OR_WRONG_ACCOUNT_FOR_RETAINED_ERANINGS
static Reason | BIZReason.MODIFY_ONHAND_INQA_ERROR
static Reason | BIZReason.MUST_NULL_OR_EMPTY
static Reason | BIZReason.MYSELF_CAN_NOT_BE_REMOVED
static Reason | BIZReason.NA_PART_NUMBER_CAN_NOT_ALLOW
static Reason | BIZReason.NCR_ALREADY_EXIST
static Reason | BIZReason.NCR_APPROVAL_ALREADY_EXIST
static Reason | BIZReason.NCR_APPROVAL_ENG_ALREADY_EXIST
static Reason | BIZReason.NCR_APPROVAL_MFG_ALREADY_EXIST
static Reason | BIZReason.NCR_APPROVAL_NOT_EXIST
static Reason | BIZReason.NCR_APPROVAL_QA_ALREADY_EXIST
static Reason | BIZReason.NCR_APPROVED_BY_CAN_NOT_BE_EMPTY
static Reason | BIZReason.NCR_HAS_NO_IN_QA_QTY_TO_SCRAP
static Reason | BIZReason.NCR_IN_QA_COST_CAN_NOT_BE_ZERO
static Reason | BIZReason.NCR_NOT_EXIST
static Reason | BIZReason.NCR_PART_IN_DEAL_QTY_ALREADY_BIGGER_THAN_TOTAL_QTY
static Reason | BIZReason.NCR_PARTNUMBER_CANNOT_BE_CHANGED
static Reason | BIZReason.NCR_SCRAP_QTY_CAN_NOT_BE_ZERO
static Reason | BIZReason.NCR_SCRAP_QTY_MORE_THAN_IN_QA_QTY
static Reason | BIZReason.NCR_SCRAP_QTY_MORE_THAN_PULLED_QTY
static Reason | BIZReason.NCR_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY
static Reason | BIZReason.NEED_TO_CREATE_NEXT_FISCAL_YEAR
static Reason | BIZReason.NEW_FISCAL_YEAR_SETTINGS_CLOSED
static Reason | BIZReason.NEW_QTY_RECEIVED_IS_MORE_THAN_QTY_SHORTAGE
static Reason | BIZReason.NEW_TRANSACTION_ARE_FUTURE_DATE
static Reason | BIZReason.NEW_TRANSACTION_DATE_LOCKED
static Reason | BIZReason.NEW_TRANSACTION_DATE_OVER_GL_NDAYS_OK_OLD
static Reason | BIZReason.NO_CUSTOMER_IS_CHOISE
static Reason | BIZReason.NO_ITEM_TO_TRANSFER
static Reason | BIZReason.NO_OPEN_SALES_ORDER_FOUND
static Reason | BIZReason.NO_PERMISSION_TO_UPDATE_CLOSED_ORDER
static Reason | BIZReason.NO_RECEIVERS
static Reason | BIZReason.NO_RIGHT_WORK_INSTRUCTION_SET_ID
static Reason | BIZReason.NO_SELECT_OBJECT
static Reason | BIZReason.NO_SUCH_ORDER
static Reason | BIZReason.NO_WAREHOUSE_FOR_LOCATION
static Reason | BIZReason.NO_WORK_INSTRUCTION_SEQUENCES
static Reason | BIZReason.NON_CONFORMANCE_CODE_ALREADY_EXIST
static Reason | BIZReason.NON_CONFORMANCE_CODE_DESCRIPTION_CANNOT_BE_EMPTY
static Reason | BIZReason.NON_CONFORMANCE_CODE_NOT_EXIST
static Reason | BIZReason.NONPRODUCTIVE_PICKING_APPROVAL_ALREADY_ADDED
static Reason | BIZReason.NONPRODUCTIVE_PICKING_APPROVAL_NOT_EXIST
static Reason | BIZReason.NONPRODUCTIVE_PICKING_NOT_EXIST
static Reason | BIZReason.NONPRODUCTIVE_PICKING_NOT_OPEN
static Reason | BIZReason.NONPRODUCTIVE_PICKING_TYPE_ALREADY_ADDED
static Reason | BIZReason.NONPRODUCTIVE_PICKING_TYPE_CAN_BE_DELETE
static Reason | BIZReason.NONPRODUCTIVE_PICKING_TYPE_IS_USED
static Reason | BIZReason.NONPRODUCTIVE_PICKING_TYPE_NOT_EXIST
static Reason | BIZReason.NOT_APPROVED_GL_CAN_NOT_POST
static Reason | BIZReason.NOT_APPROVED_GL_TO_CANCEL
static Reason | BIZReason.NOT_APPROVED_OBJECT_ONLY_ALLOW_UPDATE
static Reason | BIZReason.NOT_APPROVED_REQUEST_FOR_QUOTE_IS_NOT_ALLOWED_TO_PURCHASE_ORDER
static Reason | BIZReason.NOT_APPROVED_WORK_ORDER_ITEM_WILL_BE_SETUP
static Reason | BIZReason.NOT_AUTHORIZED_APPROVER
static Reason | BIZReason.NOT_AUTHORIZED_APPROVER_TO_APPROVE_SELF
static Reason | BIZReason.NOT_CHARACTER
static Reason | BIZReason.NOT_DIGDECIMAL
static Reason | BIZReason.NOT_ENOUGH_ONHAND
static Reason | BIZReason.NOT_EQUALS
static Reason | BIZReason.NOT_EXIST_ITEM_TO_RECEIVE_OR_SHIP
static Reason | BIZReason.NOT_FOUND_APPROVED_BY_IN_SETTINGS
static Reason | BIZReason.NOT_FOUND_TAX_RATE_ACCOUNT
static Reason | BIZReason.NOT_GROUP_ISSUE_ITEM_AGENT_ITEM_NUMBER_NOT_RIGHT
static Reason | BIZReason.NOT_IDENTITY_EMPLOYEE_ID
static Reason | BIZReason.NOT_INVOICE_NUMBER
static Reason | BIZReason.NOT_LETTER
static Reason | BIZReason.NOT_MATCH_BIZBOX_USER_EXIST
static Reason | BIZReason.NOT_MATCH_EMPLOYEE_ID_WITH_BIZBOX_USER
static Reason | BIZReason.NOT_MATCH_OWNER_NAME_WITH_SHIP_LIST_OWNER
static Reason | BIZReason.NOT_MATCH_PART_WiTH_SALES_ORDER_ITEM
static Reason | BIZReason.NOT_MATCH_PART_WiTH_WORK_ORDER_ITEM
static Reason | BIZReason.NOT_MATCH_SHIP_LIST_NUMBER_WITH_SHIP_LIST
static Reason | BIZReason.NOT_NUMBER
static Reason | BIZReason.NOT_NUMBER_STRING
static Reason | BIZReason.NOT_OBJECT_TO_APPROVED
static Reason | BIZReason.NOT_OPEN_NCR_TO_SHIP
static Reason | BIZReason.NOT_OPEN_SALES_ORDER_ITEM_ADD_TO_SHIPPER
static Reason | BIZReason.NOT_OPEN_SALES_ORDER_ITEM_TO_SHIP
static Reason | BIZReason.NOT_OPEN_SALES_ORDER_TO_MAKE_SHIPPER
static Reason | BIZReason.NOT_OPEN_SALES_ORDER_TO_SHIP
static Reason | BIZReason.NOT_OPEN_WORK_ORDER_ITEM_TO_ISSUE_PART
static Reason | BIZReason.NOT_OPEN_WORK_ORDER_TO_ISSUE_PART
static Reason | BIZReason.NOT_RIGHT_AP_PREPAY_ITEM
static Reason | BIZReason.NOT_RIGHT_AR_PREPAY_ITEM
static Reason | BIZReason.NOT_RIGHT_BOM_ITEM
static Reason | BIZReason.NOT_RIGHT_DESIGN_CONTROL_NUMBER_OF_DOCUMENT
static Reason | BIZReason.NOT_RIGHT_MANUFACTURERS_GROUP_FORMAT
static Reason | BIZReason.NOT_RIGHT_PACKING_BOX_NUMBER
static Reason | BIZReason.NOT_RIGHT_PART_TRACEABLE_CATEGORY_ITEM
static Reason | BIZReason.NOT_RIGHT_PART_TRACEABLE_SPECIFICATION_ITEM
static Reason | BIZReason.NOT_RIGHT_PROFORMA_INVOICE_NUMBER
static Reason | BIZReason.NOT_RIGHT_PURCHASE_ORDER_ITEM
static Reason | BIZReason.NOT_RIGHT_PURCHASE_ORDER_ITEM_MANUFACTURER
static Reason | BIZReason.NOT_RIGHT_PURCHASE_ORDER_MESSAGE_ITEM
static Reason | BIZReason.NOT_RIGHT_PURCHASE_WORK_SHEET_ITEM
static Reason | BIZReason.NOT_RIGHT_REQUEST_FOR_QUOTE_ITEM
static Reason | BIZReason.NOT_RIGHT_REQUEST_FOR_QUOTE_ITEM_MANUFACTURER
static Reason | BIZReason.NOT_RIGHT_RETURN_MATERIAL_AUTHORIZATION_ITEM_MANUFACTURER
static Reason | BIZReason.NOT_RIGHT_RETURN_TO_VENDOR_ITEM
static Reason | BIZReason.NOT_RIGHT_RETURN_TO_VENDOR_ITEM_MANUFACTURER
static Reason | BIZReason.NOT_RIGHT_RFQ_MESSAGE_ITEM
static Reason | BIZReason.NOT_RIGHT_SALES_ORDER_ADD_TO_SHIPPER
static Reason | BIZReason.NOT_RIGHT_SALES_ORDER_ITEM_ADD_TO_SHIPPER
static Reason | BIZReason.NOT_RIGHT_SPECIFY_FOR_WHAT_TO_ADD_TYPE
static Reason | BIZReason.NOT_RIGHT_VENDORS_GROUP_FORMAT
static Reason | BIZReason.NOT_RIGHT_WORK_ORDER_ITEM
static Reason | BIZReason.NOT_RIGHT_WORK_ORDER_WORK_INSTRUCTION_SEQUENCE
static Reason | BIZReason.NOT_RIGHT_WORK_WORK_SHEET_ITEM
static Reason | BIZReason.NOT_SAME_ADDRESS_ID_WITH_PROFROMA_INVOICE
static Reason | BIZReason.NOT_SAME_PART_FROM
static Reason | BIZReason.NOT_STRING
static Reason | BIZReason.NOTICE_USER_EXIST
static Reason | BIZReason.NOTICE_USER_NOT_EXIST
static Reason | BIZReason.NUMBER_CAN_NOT_BE_ZERO
static Reason | BIZReason.NUMBER_CAN_NOT_LESS_THEN_ZERO
static Reason | BIZReason.OBJECT_ALREADY_APPROVED
static Reason | BIZReason.OLD_FISCAL_YEAR_SETTINGS_CLOSED
static Reason | BIZReason.OLD_TRANSACTION_DATE_LOCKED
static Reason | BIZReason.ON_LOAN_ALREADY_EXIST
static Reason | BIZReason.ON_LOAN_ALREADY_REVIEWED
static Reason | BIZReason.ON_lOAN_ITEM_ALREADY_EXIST
static Reason | BIZReason.ON_LOAN_ITEM_NOT_EXIST
static Reason | BIZReason.ON_LOAN_ITEM_PK_ERROR
static Reason | BIZReason.ON_LOAN_NOT_EXIST
static Reason | BIZReason.ONHAND_IS_NOT_ENOUGH
static Reason | BIZReason.ONLINE_USER_CAN_NOT_BE_REMOVED
static Reason | BIZReason.ONLOAN_REVIEW_ALREADY_EXIST
static Reason | BIZReason.ONLOAN_REVIEW_NOT_EXIST
static Reason | BIZReason.ONLY_APP_COLUMN_CAN_BE_DROP
static Reason | BIZReason.ONLY_APP_TABLE_CAN_BE_DROP
static Reason | BIZReason.ONLY_ONE_PRIMARY_KEY_PERMITTED
static Reason | BIZReason.OPERATING_INSTRUCTION_NOT_EXIST
static Reason | BIZReason.OPERATING_INSTRUCTION_TYPE_NOT_EXIST
static Reason | BIZReason.ORDER_ALREADY_IN_MY_PRINTLIST
static Reason | BIZReason.ORDER_CAN_NOT_LINK_TO_ITSELF
static Reason | BIZReason.ORDER_HAS_BEEN_CLOSED_ENTRY
static Reason | BIZReason.ORDER_IS_HOLD
static Reason | BIZReason.ORDER_NOT_IN_MY_PRINTLIST
static Reason | BIZReason.ORDER_WAS_CHANGED
static Reason | BIZReason.OTHER_PEOPLE_IS_RECEIVING_PLEASE_TRY_AGAIN
static Reason | BIZReason.OTHER_PEOPLE_IS_RUNNING_AUDIT_ONDEMAND_PLEASE_TRY_AGAIN_LATER
static Reason | BIZReason.OTHER_PEOPLE_IS_RUNNING_MRP_PLEASE_TRY_AGAIN_LATER
static Reason | BIZReason.OUTSIDE_COMPANY_EMPLOYID_MUST_BE_NULL
static Reason | BIZReason.OVER_CARRY_PROFIT_AND_LOSS_APPROVED_BY_BY_CAN_NOT_BE_EMPTY
static Reason | BIZReason.OVER_CARRY_PROFIT_AND_LOSS_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY
static Reason | BIZReason.PACKING_BOX_ALREADY_EXIST
static Reason | BIZReason.PACKING_BOX_BOX_INFO_NOT_COMPLETED
static Reason | BIZReason.PACKING_BOX_IS_NOT_EMPTY
static Reason | BIZReason.PACKING_BOX_ITEM_ALREADY_EXIST
static Reason | BIZReason.PACKING_BOX_ITEM_NOT_EXIST
static Reason | BIZReason.PACKING_BOX_NOT_EXIST
static Reason | BIZReason.PAID_TOTAL_IS_NOT_EAUAL
static Reason | BIZReason.PAR_ALREADY_EXIST
static Reason | BIZReason.PAR_ITEM_ALREADY_EXIST
static Reason | BIZReason.PAR_ITEM_NOT_EXIST
static Reason | BIZReason.PAR_NOT_EXIST
static Reason | BIZReason.PART_ALREADY_BOM
static Reason | BIZReason.PART_ALREADY_EXIST
static Reason | BIZReason.PART_ALREADY_USED
static Reason | BIZReason.PART_CATALOG_ALREADY_EXIST
static Reason | BIZReason.PART_CATALOG_NOT_EXIST
static Reason | BIZReason.PART_CATEGORY_NOT_EXIST
static Reason | BIZReason.PART_CERTIFICATE_ALREADY_EXIST
static Reason | BIZReason.PART_CERTIFICATE_NOT_EXIST
static Reason | BIZReason.PART_CLASS_ALREADY_EXIST
static Reason | BIZReason.PART_CLASS_IS_USED
static Reason | BIZReason.PART_CLASS_NEED_BE_A_LETTER
static Reason | BIZReason.PART_CLASS_NOT_EXIST
static Reason | BIZReason.PART_EXIST
static Reason | BIZReason.PART_FROM_NOT_EXIST
static Reason | BIZReason.PART_HAS_BEAN_RETURN
static Reason | BIZReason.PART_HAS_DRAWING
static Reason | BIZReason.PART_HAS_MANUFACTURER
static Reason | BIZReason.PART_HAS_MATERIAL
static Reason | BIZReason.PART_HAS_ONDEMAND
static Reason | BIZReason.PART_HAS_ONHAND
static Reason | BIZReason.PART_HAS_ONLOAN
static Reason | BIZReason.PART_HAS_ONORDER
static Reason | BIZReason.PART_HAS_PICTURE
static Reason | BIZReason.PART_HAS_QA
static Reason | BIZReason.PART_HAS_SIP
static Reason | BIZReason.PART_HAS_SIT
static Reason | BIZReason.PART_HAS_VENDOR
static Reason | BIZReason.PART_HAS_WIP
static Reason | BIZReason.PART_HAS_WORK_INSTRUCTION
static Reason | BIZReason.PART_IMPORT_FROM_OTHER_COMPANY_CANT_EDIT_REV
static Reason | BIZReason.PART_IN_QA_NOT_EXIST
static Reason | BIZReason.PART_IN_SIP
static Reason | BIZReason.PART_INVENTORY_NOT_ENOUGH
static Reason | BIZReason.PART_IS_BOM
static Reason | BIZReason.PART_IS_DELETED
static Reason | BIZReason.PART_IS_LOCKED
static Reason | BIZReason.PART_IS_NOT_BACKFLUSH_MATERIAL
static Reason | BIZReason.PART_MATERIAL_ALREADY_EXIST
static Reason | BIZReason.PART_MATERIAL_NOT_EXIST
static Reason | BIZReason.PART_NOT_BOM
static Reason | BIZReason.PART_NOT_EXIST
static Reason | BIZReason.PART_NOT_SALEABLE
static Reason | BIZReason.PART_NOT_SAME_BETWEEN_TWO_ORDERS
static Reason | BIZReason.PART_NUMBER_ALREADY_IN_USE
static Reason | BIZReason.PART_NUMBER_FOR_CATEGORY_IS_USED_UP
static Reason | BIZReason.PART_NUMBER_IS_USED_UP
static Reason | BIZReason.PART_NUMBER_MAX_LENGTH_CAN_NOT_SAMLLER_THAN
static Reason | BIZReason.PART_ONHAND_NOT_ENOUGH
static Reason | BIZReason.PART_ONHAND_NOT_EXIST
static Reason | BIZReason.PART_PICTURE_EXIST
static Reason | BIZReason.PART_PICTURE_WITHOUT_LENGTH
static Reason | BIZReason.PART_SECURITY_LEVEL_EXIST
static Reason | BIZReason.PART_SECURITY_LEVEL_NOT_EXIST
static Reason | BIZReason.PART_SECURITY_LEVEL_USED_IN_PART
static Reason | BIZReason.PART_SHARE_COMPANY_ID_DOES_NOT_EXIST
static Reason | BIZReason.PART_STILL_IS_HOLD
static Reason | BIZReason.PART_TPYE_IS_USING
static Reason | BIZReason.PART_TYPE_ALREADY_EXIST
static Reason | BIZReason.PART_TYPE_NOT_EXIST
static Reason | BIZReason.PART_USE_TYPE_IS_EXIST
static Reason | BIZReason.PART_USE_TYPE_NOT_EXIST
static Reason | BIZReason.PART_USED_IN_API
static Reason | BIZReason.PART_USED_IN_ARI
static Reason | BIZReason.PART_USED_IN_BOM
static Reason | BIZReason.PART_USED_IN_ECN
static Reason | BIZReason.PART_USED_IN_ECR
static Reason | BIZReason.PART_USED_IN_EDC
static Reason | BIZReason.PART_USED_IN_LNI
static Reason | BIZReason.PART_USED_IN_POI
static Reason | BIZReason.PART_USED_IN_QTI
static Reason | BIZReason.PART_USED_IN_RFQI
static Reason | BIZReason.PART_USED_IN_RMAI
static Reason | BIZReason.PART_USED_IN_RTVI
static Reason | BIZReason.PART_USED_IN_SOI
static Reason | BIZReason.PART_USED_IN_SWSI
static Reason | BIZReason.PART_USED_IN_TOI
static Reason | BIZReason.PART_USED_IN_WOI
static Reason | BIZReason.PART_VENDOR_EXIST
static Reason | BIZReason.PART_VENDOR_NOT_EXIST
static Reason | BIZReason.PART_WITH_NCR
static Reason | BIZReason.PART_WITHOUT_INVENTORY
static Reason | BIZReason.PARTCATALOG_NOT_EXIST
static Reason | BIZReason.PARTDWF_NOT_FOUND
static Reason | BIZReason.PARTDWG_NOT_FOUND
static Reason | BIZReason.PASSWORD_IS_TOO_SHORT
static Reason | BIZReason.PAY_DATE_SHOULD_BE_AFTER_GL_LOCKED_DATE
static Reason | BIZReason.PAYMENT_RUN_ALREADY_COMMITTED
static Reason | BIZReason.PAYMENT_RUN_ALREADY_EXIST
static Reason | BIZReason.PAYMENT_RUN_NOT_EXIST
static Reason | BIZReason.PAYMENT_VARIANCE_OVER_THAN_GA_ZERO_CAN_NOT_CLOSE
static Reason | BIZReason.PHYSICAL_WORK_SHEET_ALREADY_CLOSED
static Reason | BIZReason.PHYSICAL_WORK_SHEET_HAS_EXIST
static Reason | BIZReason.PHYSICAL_WORK_SHEET_NOT_EXIST
static Reason | BIZReason.PHYSICAL_WORK_SHEET_PAGE_NUMBER_HAS_EXIST
static Reason | BIZReason.PHYSICAL_WORK_SHEET_PAGE_NUMBER_NOT_EXIST
static Reason | BIZReason.PICTURE_NOT_FOUND
static Reason | BIZReason.PLEASE_CHANGE_CONDITION_THEN_SEARCH_AGAIN
static Reason | BIZReason.PLEASE_CHECK_WORK_INSTRUCTION_SEQUENCE
static Reason | BIZReason.PLEASE_CHECK_WORK_INSTRUCTION_SEQUENCE_OR_WORK_CENTER
static Reason | BIZReason.PLEASE_FILL_IN_UOM
static Reason | BIZReason.PLEASE_INPUT_A_OPEN_WORK_ORDER
static Reason | BIZReason.PLEASE_LOGIN_FIRST
static Reason | BIZReason.POS_NOT_EXIST
static Reason | BIZReason.POSTED_GL_CAN_NOT_BE_CANCEL_APPROVE
static Reason | BIZReason.PROFORMA_INVOICE_HAS_EXIST
static Reason | BIZReason.PROFORMA_INVOICE_ITEM_NOT_EXIST
static Reason | BIZReason.PROFORMA_INVOICE_NOT_EXIST
static Reason | BIZReason.PROFORMA_INVOICE_NOT_OPEN
static Reason | BIZReason.PROFORMA_RECEIVER_HAS_EXIST
static Reason | BIZReason.PROFORMA_RECEIVER_NOT_EXIST
static Reason | BIZReason.PULL_OUT_ON_DEMAND_ERROR
static Reason | BIZReason.PURCHASE_ORDER_ALREADY_RECEIVED
static Reason | BIZReason.PURCHASE_ORDER_APPROVAL_ALREADY_EXIST
static Reason | BIZReason.PURCHASE_ORDER_APPROVAL_NOT_EXIST
static Reason | BIZReason.PURCHASE_ORDER_HAS_EXIST
static Reason | BIZReason.PURCHASE_ORDER_ITEM_ALREADY_RECEIVED_OR_IN_SIT
static Reason | BIZReason.PURCHASE_ORDER_ITEM_HAS_REFERENCE
static Reason | BIZReason.PURCHASE_ORDER_ITEM_NOT_CONTAINS_THIS_PART
static Reason | BIZReason.PURCHASE_ORDER_ITEM_NOT_EXIST
static Reason | BIZReason.PURCHASE_ORDER_ITEM_STATUS_NOT_OPEN
static Reason | BIZReason.PURCHASE_ORDER_MESSAGE_HAS_EXIST
static Reason | BIZReason.PURCHASE_ORDER_MESSAGE_NOT_EXIST
static Reason | BIZReason.PURCHASE_ORDER_NOT_APPROVED
static Reason | BIZReason.PURCHASE_ORDER_NOT_EXIST
static Reason | BIZReason.PURCHASE_ORDER_NOT_OPEN
static Reason | BIZReason.PURCHASE_WORK_SHEET_HAS_EXIST
static Reason | BIZReason.PURCHASE_WORK_SHEET_ITEM_NOT_EXIST
static Reason | BIZReason.PURCHASE_WORK_SHEET_NOT_EXIST
static Reason | BIZReason.QT_DOC_NOT_FIND
static Reason | BIZReason.QTY_RECEIVED_CAN_NOT_MORE_THAN_QTY_PURCHASED
static Reason | BIZReason.QTY_RECEIVED_CAN_NOT_MORE_THAN_QTY_QUALIFIED
static Reason | BIZReason.QTY_SHOULD_BE_BIGGER_THAN_ISSUED_QTY
static Reason | BIZReason.QTY_SHOULD_HAS_SAME_POSITIVE_NEGATIVE_WITH_ISSUED_QTY
static Reason | BIZReason.QUANTIRY_CAN_NOT_BE_ZERO
static Reason | BIZReason.QUANTITY_CAN_NOT_LESS_THAN_ZERO
static Reason | BIZReason.QUOTE_ALREADY_REVIEWED
static Reason | BIZReason.QUOTE_ITEM_PK_WRONG
static Reason | BIZReason.QUOTE_NOT_EXIST
static Reason | BIZReason.QUOTE_WITHOUT_ITEMS
static Reason | BIZReason.RECEIVE_ITEM_DOSE_NOT_EXIST_IN_WO_PART_DETAIL
static Reason | BIZReason.RECEIVE_QTY_IS_NOT_SAME_WITH_WO_PART_DETAIL_QTY
static Reason | BIZReason.RECEIVE_QTY_IS_OVER_THAN_RMA_ITEM_ORDERED
static Reason | BIZReason.RECEIVE_TO_WRONG_WAREHOUSE
static Reason | BIZReason.RECEIVED_TOTAL_IS_NOT_EAUAL
static Reason | BIZReason.RECEIVER_HAS_BEEN_CLOSED
static Reason | BIZReason.RECEIVER_HAS_EXIST
static Reason | BIZReason.RECEIVER_IS_NOT_FOR_THIS_PO
static Reason | BIZReason.RECEIVER_ITEM_HAS_BEEN_CLOSED
static Reason | BIZReason.RECEIVER_ITEM_HAS_BEEN_CREATED_AP
static Reason | BIZReason.RECEIVER_ITEM_HAS_EXIST
static Reason | BIZReason.RECEIVER_ITEM_NOT_EXIST
static Reason | BIZReason.RECEIVER_NOT_EXIST
static Reason | BIZReason.RECEIVER_QTY_CAN_NOT_BE_CHANGED
static Reason | BIZReason.RECEIVER_REF_DOC_NUMBER_CAN_NOT_BE_CHANGED
static Reason | BIZReason.RECURSIVE_BOM_NOT_ALLOWED
static Reason | BIZReason.REF_DOC_CLOSED
static Reason | BIZReason.REF_DOC_HAS_EXIST
static Reason | BIZReason.REF_DOC_LINK_TO_NOT_EXIST_ORDER
static Reason | BIZReason.REF_DOC_NOT_EXIST
static Reason | BIZReason.REF_DOC_TOTAL_QTY_MORE_THAN_QTY_OF_FROM_ORDER
static Reason | BIZReason.REF_DOC_TOTAL_QTY_MORE_THAN_QTY_OF_TO_ORDER
static Reason | BIZReason.REPLACEMENT_PART_ITEMS_ERROR
static Reason | BIZReason.REQUEST_FOR_QUOTE_ITEM_NOT_EXIST
static Reason | BIZReason.REQUEST_FOR_QUOTE_NOT_EXIST
static Reason | BIZReason.RETURN_ADDRESS_ID_TO_ID_IS_NOT_EXIST
static Reason | BIZReason.RETURN_TO_VENDOR_ITEM_NOT_EXIST
static Reason | BIZReason.RETURN_TO_VENDOR_NOT_EXIST
static Reason | BIZReason.RFQ_MESSAGE_HAS_EXIST
static Reason | BIZReason.RFQ_MESSAGE_NOT_EXIST
static Reason | BIZReason.RMA_ALREADY_REVIEWED
static Reason | BIZReason.RMA_DEBIT_ACCOUNT_IS_NOT_CONFIGURED
static Reason | BIZReason.RMA_DOC_NOT_FIND
static Reason | BIZReason.RMA_HAS_EXIST
static Reason | BIZReason.RMA_ITEM_HAS_EXIST
static Reason | BIZReason.RMA_ITEM_NOT_EXIST
static Reason | BIZReason.RMA_NOT_EXIST
static Reason | BIZReason.RMA_NOT_REVIEWED
static Reason | BIZReason.RMA_ORDER_ITEM_ALREADY_RECEIVED
static Reason | BIZReason.RMA_PK_WRONG
static Reason | BIZReason.RMA_RECEIVER_HAS_HAVED_CREDITMEMO
static Reason | BIZReason.RMA_RECEIVER_NOT_EXIST
static Reason | BIZReason.RMA_REVIEW_ALREADY_EXIST
static Reason | BIZReason.RMA_REVIEW_NOT_EXIST
static Reason | BIZReason.ROLL_UP_BOM_STD_COST_WORKSHEET_NOT_EXIST
static Reason | BIZReason.RRMA_ALREADY_REVIEWED
static Reason | BIZReason.RRMA_CUSTOMERID_NOT_MATCH
static Reason | BIZReason.RRMA_NOT_EXIST
static Reason | BIZReason.RRMA_NOT_OPEN
static Reason | BIZReason.RRMA_PK_WRONG
static Reason | BIZReason.RTV_APPROVAL_ALREADY_EXIST
static Reason | BIZReason.RTV_APPROVAL_NOT_EXIST
static Reason | BIZReason.RTV_ITEM_ALREADY_SHIPPER
static Reason | BIZReason.RTV_ORDER_ITEM_ALREADY_SHIPPED
static Reason | BIZReason.RTV_SHIPPER_NOT_EXIST
static Reason | BIZReason.SALES_CODE_ALREADY_EXIST
static Reason | BIZReason.SALES_CODE_NOT_EXIST
static Reason | BIZReason.SALES_ITEM_HAS_BEEN_CLOSED
static Reason | BIZReason.SALES_ITEM_HAS_BEEN_CREATED_INVOICE
static Reason | BIZReason.SALES_ORDER_ALREADY_CLOSED
static Reason | BIZReason.SALES_ORDER_ALREADY_REVIEWED
static Reason | BIZReason.SALES_ORDER_ALREADY_SHIPPED
static Reason | BIZReason.SALES_ORDER_HAS_BEEN_CLOSED
static Reason | BIZReason.SALES_ORDER_HAS_BEEN_HOLD
static Reason | BIZReason.SALES_ORDER_IS_BILL_AND_HOLD
static Reason | BIZReason.SALES_ORDER_IS_NOT_REVIEWED
static Reason | BIZReason.SALES_ORDER_ITEM_ALREADY_COMPLETED
static Reason | BIZReason.SALES_ORDER_ITEM_ALREADY_SHIPPED_OR_IN_SIP
static Reason | BIZReason.SALES_ORDER_ITEM_HAS_EXIST
static Reason | BIZReason.SALES_ORDER_ITEM_MFG_PK_WRONG
static Reason | BIZReason.SALES_ORDER_ITEM_NOT_EXIST
static Reason | BIZReason.SALES_ORDER_ITEM_NOT_EXIST_FOR_THIS_SHIPPER_ITEM
static Reason | BIZReason.SALES_ORDER_ITEM_NOT_OPEN
static Reason | BIZReason.SALES_ORDER_ITEM_PK_WRONG
static Reason | BIZReason.SALES_ORDER_ITEM_WITHOUT_SUCH_QTY_TO_SHIPPED
static Reason | BIZReason.SALES_ORDER_NOT_EXIST
static Reason | BIZReason.SALES_ORDER_NOT_OPEN
static Reason | BIZReason.SALES_ORDER_REVIEW_ALREADY_EXIST
static Reason | BIZReason.SALES_ORDER_REVIEW_NOT_EXIST
static Reason | BIZReason.SALES_ORDER_SHIPPER_NOT_EXIST
static Reason | BIZReason.SALESMAN_NOT_EXIST
static Reason | BIZReason.SAVE_TO_DB_ERROR
static Reason | BIZReason.SECURITY_ACCESS_TO_METHOD
static Reason | BIZReason.SEND_MAIL_ERROR
static Reason | BIZReason.SERIAL_NUMBER_ALREADY_EXIST
static Reason | BIZReason.SERIAL_NUMBER_NOT_EXIST
static Reason | BIZReason.SERVER_TIME_ERROR
static Reason | BIZReason.SG_CLIENT_ACCOUNT_ALREADY_EXIST
static Reason | BIZReason.SG_CLIENT_ACCOUNT_NOT_EXIST
static Reason | BIZReason.SG_CLIENT_PROGRAM_USER_ALREADY_EXIST
static Reason | BIZReason.SG_CLIENT_PROGRAM_USER_INFO_NOT_EXACT
static Reason | BIZReason.SG_CLIENT_PROGRAM_USER_NOT_EXIST
static Reason | BIZReason.SG_COMPANY_ALREADY_EXIST
static Reason | BIZReason.SG_COMPANY_NOT_EXIST
static Reason | BIZReason.SG_CUST_RFQ_ALREADY_EXIST
static Reason | BIZReason.SG_CUST_RFQ_ALREADY_QUOTED
static Reason | BIZReason.SG_CUST_RFQ_NOT_EXIST
static Reason | BIZReason.SG_CUST_RFQ_NOT_QUOTED
static Reason | BIZReason.SG_QUOTE_ADDRESS_ALREADY_EXIST
static Reason | BIZReason.SG_QUOTE_ADDRESS_NOT_EXIST
static Reason | BIZReason.SG_SALE_ITEM_NOT_EXIST
static Reason | BIZReason.SHIP_LIST_HAS_EXIST
static Reason | BIZReason.SHIP_LIST_NOT_EXIST
static Reason | BIZReason.SHIP_LIST_OWNER_HAS_EXIST
static Reason | BIZReason.SHIP_LIST_OWNER_NOT_EXIST
static Reason | BIZReason.SHIP_QTY_IS_OVER_THAN_DWO_ITEM_ORDERED
static Reason | BIZReason.SHIP_QTY_IS_OVER_THAN_LOCATION_ONHAND
static Reason | BIZReason.SHIP_QTY_IS_OVER_THAN_ONHAND
static Reason | BIZReason.SHIP_QTY_IS_OVER_THAN_ONLOAN_ITEM_ORDERED
static Reason | BIZReason.SHIP_QTY_IS_OVER_THAN_RTV_ITEM_ORDERED
static Reason | BIZReason.SHIP_QTY_IS_OVER_THAN_SO_ITEM_ORDERED
static Reason | BIZReason.SHIP_QTY_IS_OVER_THAN_SWAP_ITEM_ORDERED
static Reason | BIZReason.SHIP_QTY_IS_OVER_THAN_TRANSFER_ITEM_ORDERED
static Reason | BIZReason.SHIP_QTY_IS_SMALLER_THAN_RECEIVE_QTY
static Reason | BIZReason.SHIP_TO_ID_IS_NOT_EXIST
static Reason | BIZReason.SHIPPED_QTY_IS_OVER
static Reason | BIZReason.SHIPPED_QTY_IS_ZERO
static Reason | BIZReason.SHIPPER_HAS_BEEN_CLOSED
static Reason | BIZReason.SHIPPER_HAS_EXIST
static Reason | BIZReason.SHIPPER_ITEM_HAS_BEEN_CLOSED
static Reason | BIZReason.SHIPPER_ITEM_HAS_BEEN_CREATED_INVOICE
static Reason | BIZReason.SHIPPER_ITEM_HAS_MADE_UNBILLED
static Reason | BIZReason.SHIPPER_ITEM_HAS_SHIPPED_COMPLETELY
static Reason | BIZReason.SHIPPER_ITEM_NOT_EXIST
static Reason | BIZReason.SHIPPER_NOT_EXIST
static Reason | BIZReason.SHIPPER_NOT_FOR_SALES_ORDER
static Reason | BIZReason.SO_DOC_NOT_FIND
static Reason | BIZReason.SO_ITEM_NOT_TOTALLY_SHIPPED
static Reason | BIZReason.SO_TOTAL_SMALLER_THAN_AR_PREPAY_PAID_TOTAL
static Reason | DBReason.SOME_BODY_ELSE_WORK_ON_IT
static Reason | BIZReason.SOME_ORDER_IS_ALREADY_HOLD
static Reason | BIZReason.SOME_PARTS_HAVE_BEEN_ISSUED_TO_WO
static Reason | BIZReason.SOMEONE_ELSE_HAVE_UPDATED_IT
static Reason | BIZReason.SOMEONE_ELSE_IS_CHANGING_SERVER_TIME
static Reason | BIZReason.SPEC_ID_HAS_EXIST
static Reason | BIZReason.SPEC_ID_NOT_EXIST
static Reason | BIZReason.SPEC_ID_STILL_USED
static Reason | BIZReason.START_DATE_SHOULD_BE_AFTER_THE_PRIOR_FISCAL_YEAR_END_DATE
static Reason | BIZReason.START_DATE_SHOULD_BE_BEFORE_THE_END_DATE
static Reason | BIZReason.STATUS_ONLY_CAN_CHANGE_TO_CLOSE
static Reason | BIZReason.STATUS_ONLY_CAN_CHANGE_TO_CLOSE_OR_CANCELLED
static Reason | BIZReason.STATUS_ONLY_CAN_CHANGE_TO_NOTAPPROVED
static Reason | BIZReason.STATUS_ONLY_CAN_CHANGE_TO_NOTREVIEWED
static Reason | BIZReason.STATUS_ONLY_CAN_NOT_CHANGE_TO_CLOSE
static Reason | BIZReason.STD_COST_APPROVED_BY_CAN_NOT_BE_EMPTY
static Reason | BIZReason.STD_COST_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY
static Reason | BIZReason.SUB_COMPANY_UNIT_HAS_THE_ACCOUNT_NUMBER
static Reason | BIZReason.SUBCOMPANY_ALREADY_EXIST
static Reason | BIZReason.SUBCOMPANY_NOT_EXIST
static Reason | BIZReason.SWAP_ORDER_APPROVAL_ALREADY_EXIST
static Reason | BIZReason.SWAP_ORDER_APPROVAL_NOT_EXIST
static Reason | BIZReason.SWAP_ORDER_ITEM_ALREADY_SHIPPED
static Reason | BIZReason.SWAP_ORDER_ITEM_NOT_EXIST_FOR_THIS_SWAP_SHIPPER_ITEM
static Reason | BIZReason.SWAP_ORDER_NOT_EXIST
static Reason | BIZReason.SWAP_RECEIVER_NOT_EXIST
static Reason | BIZReason.SWAP_SHIPPER_ITEM_NOT_EXIST
static Reason | BIZReason.SWAP_SHIPPER_NOT_EXIST
static Reason | BIZReason.SYSTEM_LOGIN_LOCKED
static Reason | BIZReason.TEMPLATE_ERROR
static Reason | BIZReason.TEMPORARYEMPLOYEE_ALREADY_ADDED
static Reason | BIZReason.TEMPORARYEMPLOYEE_ID_NOT_EXIST
static Reason | BIZReason.TERM_ALIAS_ALREADY_EXIST
static Reason | BIZReason.TERM_ALREADY_EXIST
static Reason | BIZReason.TERM_NOT_EXIST
static Reason | BIZReason.TERM_VALUE_NOT_LEGAL
static Reason | BIZReason.TERM_WITH_SAME_ALIAS_ALREADY_EXIST
static Reason | BIZReason.TERMINATED_DATE_CAN_NOT_BE_NULL
static Reason | BIZReason.THE_CURRENT_FISCAL_YEAR_DID_NOT_SET
static Reason | BIZReason.THE_CUSTOMER_ALREADY_HAS_A_SALES_CODE
static Reason | BIZReason.THERE_IS_A_RUNNING_WORKSHEET
static Reason | BIZReason.THERE_IS_A_WAITING_WORKSHEET
static Reason | BIZReason.THERE_IS_NO_PART_ONHAND
static Reason | BIZReason.TIME_CARDS_ALREADY_EXIST
static Reason | BIZReason.TIME_CARDS_NOT_EXIST
static Reason | BB2DocumentException.TIME_OUT
static Reason | BIZReason.TO_lOCATION_SHOULD_BE_TO_ADDRESS_ID
static Reason | BIZReason.TOOL_CALIBRATION_CONTROL_NUMBER_WRONG
static Reason | BIZReason.TOOL_HAS_ONDEMAND
static Reason | BIZReason.TOOL_HAS_ONHAND
static Reason | BIZReason.TOOL_HAS_ONLOAN
static Reason | BIZReason.TOOL_HAS_ONORDER
static Reason | BIZReason.TOOL_HAS_QA
static Reason | BIZReason.TOOL_HAS_SIP
static Reason | BIZReason.TOOL_HAS_SIT
static Reason | BIZReason.TOOL_HAS_WIP
static Reason | BIZReason.TOOL_INVENTORY_NOT_ENOUGH
static Reason | BIZReason.TOOL_IS_INACTIVE
static Reason | BIZReason.TOOL_IS_TOOL_LIST
static Reason | BIZReason.TOOL_NOT_EXIST
static Reason | BIZReason.TOOL_ONHAND_NOT_EXIST
static Reason | BIZReason.TOOL_USED_IN_API
static Reason | BIZReason.TOOL_USED_IN_ARI
static Reason | BIZReason.TOOL_USED_IN_ECN
static Reason | BIZReason.TOOL_USED_IN_ECR
static Reason | BIZReason.TOOL_USED_IN_LNI
static Reason | BIZReason.TOOL_USED_IN_POI
static Reason | BIZReason.TOOL_USED_IN_QTI
static Reason | BIZReason.TOOL_USED_IN_RFQI
static Reason | BIZReason.TOOL_USED_IN_RMAI
static Reason | BIZReason.TOOL_USED_IN_RTVI
static Reason | BIZReason.TOOL_USED_IN_SOI
static Reason | BIZReason.TOOL_USED_IN_SWSI
static Reason | BIZReason.TOOL_USED_IN_TOI
static Reason | BIZReason.TOOL_USED_IN_TOOL_LIST
static Reason | BIZReason.TOOL_USED_IN_WI
static Reason | BIZReason.TOOL_USED_IN_WIS
static Reason | BIZReason.TOOL_USED_IN_WOI
static Reason | BIZReason.TRACKING_ALREADY_EXIST
static Reason | BIZReason.TRACKING_NOT_EXIST
static Reason | BIZReason.TRACKING_QTY_IS_NEGATIVE
static Reason | BIZReason.TRACKING_QTY_IS_NOT_ENOUGH
static Reason | BIZReason.TRACKING_QTY_IS_ZERO
static Reason | BIZReason.TRACKING_QTY_OVER
static Reason | BIZReason.TRANSACTION_DATE_OVER_GL_NDAYS_OK_OLD
static Reason | BIZReason.TRANSACTION_IS_TOO_OLD
static Reason | BIZReason.TRANSFER_ORDER_APPROVAL_ALREADY_EXIST
static Reason | BIZReason.TRANSFER_ORDER_APPROVAL_NOT_EXIST
static Reason | BIZReason.TRANSFER_ORDER_ITEM_NOT_EXIST_FOR_THIS_TRANSFER_SHIPPER_ITEM
static Reason | BIZReason.TRANSFER_ORDER_ITEM_SHOULD_BE_BACKFLUSH_MATERIAL
static Reason | BIZReason.TRANSFER_ORDER_NOT_EXIST
static Reason | BIZReason.TRANSFER_ORDER_NOT_INNER
static Reason | BIZReason.TRANSFER_ORDER_NOT_OPEN
static Reason | BIZReason.TRANSFER_RECEIVER_NOT_EXIST
static Reason | BIZReason.TRANSFER_SHIPPER_ALREADY_EXIST
static Reason | BIZReason.TRANSFER_SHIPPER_ITEM_NOT_EXIST
static Reason | BIZReason.TRANSFER_SHIPPER_NOT_EXIST
static Reason | BIZReason.UNBILLED_ITEMS_SHOULD_BE_WITH_THE_SAME_UNBILLED_EXCHANGE_FOR_OFFSET
static Reason | BB2ServerException.UNKNOWN_EXCEPTION
static Reason | BIZReason.UPC_MFG_IS_EMPTY
static Reason | BIZReason.UPDATE_CURRENCY_ERROR
static Reason | BIZReason.UPDATE_ONDEMAND_ERROR
static Reason | BIZReason.USE_TYPE_IS_EXIST
static Reason | BIZReason.USER_GROUP_EXIST
static Reason | BIZReason.USER_GROUP_NOT_EXIST
static Reason | BIZReason.USER_HAS_NO_PERMISSION_TO_UPDATE_ENG_GROUP_PART
static Reason | BIZReason.USER_LOCKED
static Reason | BIZReason.USER_NOT_EXIST
static Reason | BIZReason.VALUE_NOT_MATCH_SUCH_PATTERN
static Reason | BIZReason.VARIANCE_CAN_NOT_BE_ZERO
static Reason | BIZReason.VENDOR_CATALOG_ALREADY_EXIST
static Reason | BIZReason.VENDOR_CATALOG_ALREADY_USED
static Reason | BIZReason.VENDOR_CONTRACT_PRICE_HAS_EXIST
static Reason | BIZReason.VENDOR_CONTRACT_PRICE_ITEM_HAS_EXIST
static Reason | BIZReason.VENDOR_CONTRACT_PRICE_ITEM_NOT_EXIST
static Reason | BIZReason.VENDOR_CONTRACT_PRICE_NOT_EXIST
static Reason | BIZReason.VENDOR_CONTRACT_PRICE_VENDOR_HAS_EXIST
static Reason | BIZReason.VENDOR_CONTRACT_PRICE_VENDOR_NOT_EXIST
static Reason | BIZReason.VENDOR_DOC_NOT_FIND
static Reason | BIZReason.VENDOR_GROUP_USER_ALREADY_EXISTS
static Reason | BIZReason.VENDOR_HAS_BEEN_LOCKED
static Reason | BIZReason.VENDOR_ID_NOT_EXIST
static Reason | BIZReason.VERSION_NOT_SET
static Reason | BIZReason.WEIGHT_UNIT_NOT_EXIST
static Reason | BIZReason.WITHOUT_IRNUMBER
static Reason | BIZReason.WITHOUT_RECEIVER_ITEM_DETAILS
static Reason | BIZReason.WITHOUT_SUCH_METHOD
static Reason | BIZReason.WO_APPROVED_BY_CAN_NOT_BE_EMPTY
static Reason | BIZReason.WO_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY
static Reason | BIZReason.WORK_CENTER_GROUP_ALREADY_EXIST
static Reason | BIZReason.WORK_CENTER_GROUP_ITEM_IS_EMPTY
static Reason | BIZReason.WORK_CENTER_GROUP_ITEM_NUMBER_WRONG
static Reason | BIZReason.WORK_CENTER_GROUP_NOT_EXIST
static Reason | BIZReason.WORK_CENTER_HAS_EXIST
static Reason | BIZReason.WORK_CENTER_IS_BEING_USED
static Reason | BIZReason.WORK_CENTER_NOT_EXIST
static Reason | BIZReason.WORK_CENTER_UNIT_NUMBER_WRONG
static Reason | BIZReason.WORK_INSTRUCTION_ALREADY_EXIST
static Reason | BIZReason.WORK_INSTRUCTION_APPROVAL_ALREADY_EXIST
static Reason | BIZReason.WORK_INSTRUCTION_APPROVAL_NOT_EXIST
static Reason | BIZReason.WORK_INSTRUCTION_NOT_EXIST
static Reason | BIZReason.WORK_ORDER_ALREADY_SETUP_OR_RUN
static Reason | BIZReason.WORK_ORDER_APPROVAL_ALREADY_EXIST
static Reason | BIZReason.WORK_ORDER_APPROVAL_NOT_EXIST
static Reason | BIZReason.WORK_ORDER_ITEM_CAN_NOT_LINK_TO_ITSELF
static Reason | BIZReason.WORK_ORDER_ITEM_HAS_CLOSED
static Reason | BIZReason.WORK_ORDER_ITEM_ISSUE_NOT_EXIST
static Reason | BIZReason.WORK_ORDER_ITEM_ISSUE_NOT_FINISHED
static Reason | BIZReason.WORK_ORDER_ITEM_MFG_STATUS_HAS_SETUP
static Reason | BIZReason.WORK_ORDER_ITEM_MFG_STATUS_NOT_SETUP
static Reason | BIZReason.WORK_ORDER_ITEM_NOT_EXIST
static Reason | BIZReason.WORK_ORDER_ITEM_NOT_OPEN
static Reason | BIZReason.WORK_ORDER_ITEM_QTY_CAN_NOT_CHANGE_TO_ZERO
static Reason | BIZReason.WORK_ORDER_ITEM_QTY_CAN_NOT_LESS_THAN_QTY_ASM
static Reason | BIZReason.WORK_ORDER_ITEM_TIME_DETAIL_NOT_EXIST
static Reason | BIZReason.WORK_ORDER_NOT_EXIST
static Reason | BIZReason.WORK_ORDER_NOT_OPEN
static Reason | BIZReason.WORK_ORDER_WORK_INSTRUCTION_HAS_EXIST
static Reason | BIZReason.WORK_ORDER_WORK_INSTRUCTION_HAS_FINISHED
static Reason | BIZReason.WORK_ORDER_WORK_INSTRUCTION_NOT_EXIST
static Reason | BIZReason.WORK_WORK_SHEET_HAS_EXIST
static Reason | BIZReason.WORK_WORK_SHEET_NOT_EXIST
static Reason | BIZReason.WRONG_CURRENCY_FOR_CUSTOMER
static Reason | BIZReason.WRONG_DOCUMENT_SETTINGS
static Reason | BIZReason.WRONG_DOCUMENT_TYPE
static Reason | BIZReason.WRONG_MONTH_YEAR_NAME
static Reason | BIZReason.WRONG_PASSWORD
static Reason | BIZReason.WRONG_SHIPPER_FOR_SALES_ORDER
static Reason | BIZReason.YOU_CAN_NOT_CHANGE_THE_OTHERS_EXPENSE
static Reason | BIZReason.YOU_CAN_NOT_CHANGE_TOTAL_ONHAND
static Reason | BIZReason.YOU_DID_NOT_LOG_OFF
static Reason | BIZReason.YOU_HAVE_NO_PERMISSION_APPROVAL_OWN_RMA
static Reason | BIZReason.YOU_HAVE_NO_PERMISSION_REVIEW_OWN_ONLOAN
static Reason | BIZReason.YOU_HAVE_NO_PERMISSION_REVIEW_OWN_QUOTE
static Reason | BIZReason.YOU_HAVE_NO_PERMISSION_REVIEW_OWN_SALES_ORDER
static Reason | BIZReason.YOU_HAVE_NOT_APPROVED_GL
static Reason | BIZReason.YOU_HAVE_NOT_OVER_CARRY_ALL_PROFIT_AND_LOSS_ACCOUNT
static Reason | BIZReason.YOU_HAVE_NOT_POST_GL
static Reason | BIZReason.YOUR_ACCOUNT_EXPIRED

Methods in bb.common that return Reason
Reason | ReceiverAgent.getIllegalSettingReason()
static Reason | Reason.getInstance(java.lang.String reason)
Reason | BB2ServerException.getReason()

Methods in bb.common with parameters of type Reason
static BizException BizException.getBizException(DBAccessException ex, java.lang.String target, Reason reason)

Constructors in bb.common with parameters of type Reason
BB2DocumentException(java.lang.Exception e, java.lang.String target, Reason reason)
BB2DocumentException(java.lang.String target, Reason reason)
BB2MessagingException(Reason reason)
BB2ServerException(java.lang.Exception e, Reason reason)
BB2ServerException(java.lang.Exception e, Reason reason, java.lang.Object parameter)
BB2ServerException(Reason reason)
BB2ServerException(Reason reason, java.lang.Object parameter)
BB2ServerException(java.lang.String message, Reason reason)
BB2ServerException(java.lang.String message, Reason reason, java.lang.Object parameter)
BizException(java.lang.Exception e, java.lang.String target, Reason reason)
BizException(java.lang.Exception e, java.lang.String target, Reason reason, java.lang.Object parameter)
BizException(java.lang.String target, Reason reason)
BizException(java.lang.String target, Reason reason, java.lang.Object parameter)
DBAccessException(java.lang.Exception e, Reason reason)
DBAccessException(java.lang.Exception e, Reason reason, java.lang.Object parameter)
DBAccessException(Reason reason)
DBAccessException(Reason reason, java.lang.Object parameter)
DBAccessException(java.lang.String message, Reason reason)
DBAccessException(java.lang.String message, Reason reason, java.lang.Object parameter)
InvokeException(java.lang.Exception e, Reason reason)
InvokeException(Reason reason)
InvokeException(java.lang.String message, Reason reason)
LoginException(java.lang.Exception e, Reason reason)
LoginException(Reason reason)
LoginException(Reason reason, java.lang.Object parameter)
LoginException(java.lang.String message, Reason reason)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RebackInQAAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RebackInQAAgent

Packages that use RebackInQAAgent
bb.common.box

Uses of RebackInQAAgent in bb.common.box

Method parameters in bb.common.box with type arguments of type RebackInQAAgent
void | WarehouseBox.rebackInQAtoWareHouse(java.util.HashSet<RebackInQAAgent> sets)
NonConformanceReportVO | QualityBox.updateNCR(NonConformanceReportVO vo, java.util.HashSet<PuttoInQAAgent> putToInQAAgentSet, java.util.HashSet<PullFromWorkOrderPartDetailAgent> pullFromWorkOrderPartDetailAgentSet, java.util.HashSet<RebackInQAAgent> reBackInQAAgentSet)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ReceivedToOrderItem

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ReceivedToOrderItem

No usage of bb.common.ReceivedToOrderItem

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ReceiverAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ReceiverAgent

Packages that use ReceiverAgent
bb.common.box

Uses of ReceiverAgent in bb.common.box

Methods in bb.common.box with parameters of type ReceiverAgent
java.lang.Object[] | WarehouseBox.addWorkOrderAndIssueParts(WorkOrderVO vo, WorkOrderItemVO item, java.util.ArrayList<WorkOrderItemSetupItemAgent> setupList, java.util.Set<IssueItemAgent> issueItemAgents, ReceiverAgent agent)
java.util.Collection<OnloanReceiverListResult> | WarehouseBox.makeOnloanReceiver(ReceiverAgent agent)
java.util.Collection<java.lang.String> | WarehouseBox.makePurchaseOrderReceiver(ReceiverAgent agent)
java.util.Collection<RMAReceiverListResult> | WarehouseBox.makeRmaReceiver(ReceiverAgent agent)
java.util.List<SwapReceiverListResult> | WarehouseBox.makeSwapReceiver(ReceiverAgent agent)
java.util.Collection<TransferReceiverListResult> | WarehouseBox.makeTransferReceiver(ReceiverAgent agent)
java.lang.String | WarehouseBox.makeWorkOrderReceiver(ReceiverAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ReceiverInfoVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ReceiverInfoVO

Packages that use ReceiverInfoVO
bb.common.box

Uses of ReceiverInfoVO in bb.common.box

Methods in bb.common.box that return types with arguments of type ReceiverInfoVO
java.util.Collection<ReceiverInfoVO> | WarehouseBox.findOpenReceiversByRn(java.lang.String rn, int firstIndex, int maxLength)
java.util.Collection<ReceiverInfoVO> | WarehouseBox.findReceiverInfoByReceiverNumber(java.util.ArrayList receiverNumber)
java.util.Collection<ReceiverInfoVO> | WarehouseBox.findReceiversByRn(java.lang.String rn, int firstIndex, int maxLength)
java.util.Collection<ReceiverInfoVO> | AccountingBox.findReceiverWithOutAP(java.lang.String vendorId, java.lang.String buyer, java.lang.String currency, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<ReceiverInfoVO> | WarehouseBox.getMyReceiverPrintList()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ReceiverItemAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ReceiverItemAgent

Packages that use ReceiverItemAgent
bb.common
bb.common.box

Uses of ReceiverItemAgent in bb.common

Methods in bb.common that return types with arguments of type ReceiverItemAgent
 java.util.Set<ReceiverItemAgent> ReceiverAgent.getItems()

Method parameters in bb.common with type arguments of type ReceiverItemAgent
 void ReceiverAgent.setItems(java.util.Set<ReceiverItemAgent> items)

Uses of ReceiverItemAgent in bb.common.box

Method parameters in bb.common.box with type arguments of type ReceiverItemAgent
 DisassembleWorkOrderItemPK WarehouseBox.makeDisassembleWorkOrderReceiver(java.util.Set<ReceiverItemAgent> agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ReceiverItemDetailAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ReceiverItemDetailAgent

Packages that use ReceiverItemDetailAgent
bb.common

Uses of ReceiverItemDetailAgent in bb.common

Methods in bb.common that return types with arguments of type ReceiverItemDetailAgent
 java.util.Set<ReceiverItemDetailAgent> ReceiverItemAgent.getReceivedToDetails()

Method parameters in bb.common with type arguments of type ReceiverItemDetailAgent
 void ReceiverItemAgent.setReceivedToDetails(java.util.Set<ReceiverItemDetailAgent> receivedToDetails)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ReceiverItemManufacturerPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ReceiverItemManufacturerPK

Packages that use ReceiverItemManufacturerPK
bb.common

Uses of ReceiverItemManufacturerPK in bb.common

Methods in bb.common that return ReceiverItemManufacturerPK
 ReceiverItemManufacturerPK ReceiverItemManufacturerVO.getPk()

Methods in bb.common with parameters of type ReceiverItemManufacturerPK
 void ReceiverItemManufacturerVO.setPk(ReceiverItemManufacturerPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ReceiverItemManufacturerVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ReceiverItemManufacturerVO

No usage of bb.common.ReceiverItemManufacturerVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ReceiverItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ReceiverItemPK

Packages that use ReceiverItemPK
bb.common
bb.common.box

Uses of ReceiverItemPK in bb.common

Methods in bb.common that return ReceiverItemPK
 ReceiverItemPK ReceiverItemVO.getPk()

Methods in bb.common that return types with arguments of type ReceiverItemPK
 java.util.ArrayList<ReceiverItemPK> MakeAccountPayableAgent.getReceiverItems()

Methods in bb.common with parameters of type ReceiverItemPK
 void ReceiverItemVO.setPk(ReceiverItemPK pk)

Method parameters in bb.common with type arguments of type ReceiverItemPK
 void MakeAccountPayableAgent.setReceiverItems(java.util.ArrayList<ReceiverItemPK> receiverItemPKs)

Uses of ReceiverItemPK in bb.common.box

Methods in bb.common.box with parameters of type ReceiverItemPK
RefdocVO | WarehouseBox.addRefdocTwo(ReceiverItemPK rnItemPk, java.lang.String orderNumber, java.lang.String itemNumber)
ReceiverItemVO | WarehouseBox.getReceiverItemByPK(ReceiverItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ReceiverItemTrackingLogAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ReceiverItemTrackingLogAgent

Packages that use ReceiverItemTrackingLogAgent
bb.common

Uses of ReceiverItemTrackingLogAgent in bb.common

Methods in bb.common that return types with arguments of type ReceiverItemTrackingLogAgent
java.util.Set<ReceiverItemTrackingLogAgent> | ShipperItemDetailAgent.getTrackingLog()
java.util.Set<ReceiverItemTrackingLogAgent> | ReceiverItemDetailAgent.getTrackingLog()
java.util.Set<ReceiverItemTrackingLogAgent> | RebackInQAAgent.getTrackingLog()
java.util.Set<ReceiverItemTrackingLogAgent> | PuttoInQAAgent.getTrackingLog()
java.util.Set<ReceiverItemTrackingLogAgent> | IssueItemDetailAgent.getTrackingLog()

Method parameters in bb.common with type arguments of type ReceiverItemTrackingLogAgent
void | ShipperItemDetailAgent.setTrackingLog(java.util.Set<ReceiverItemTrackingLogAgent> trackingLog)
void | ReceiverItemDetailAgent.setTrackingLog(java.util.Set<ReceiverItemTrackingLogAgent> trackingLog)
void | RebackInQAAgent.setTrackingLog(java.util.Set<ReceiverItemTrackingLogAgent> trackingLog)
void | PuttoInQAAgent.setTrackingLog(java.util.Set<ReceiverItemTrackingLogAgent> trackingLog)
void | IssueItemDetailAgent.setTrackingLog(java.util.Set<ReceiverItemTrackingLogAgent> trackingLog)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ReceiverItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ReceiverItemVO

Packages that use ReceiverItemVO
bb.common.box

Uses of ReceiverItemVO in bb.common.box

Methods in bb.common.box that return ReceiverItemVO
 ReceiverItemVO WarehouseBox.getReceiverItemByPK(ReceiverItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ReceiverShipAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ReceiverShipAgent

Packages that use ReceiverShipAgent
bb.common.box

Uses of ReceiverShipAgent in bb.common.box

Methods in bb.common.box with parameters of type ReceiverShipAgent
 java.lang.String WarehouseBox.makePurchaseOrderReceiver(ReceiverShipAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ReceiverVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ReceiverVO

Packages that use ReceiverVO
bb.common.box

Uses of ReceiverVO in bb.common.box

Methods in bb.common.box that return ReceiverVO
ReceiverVO | WarehouseBox.addReceiver(ReceiverVO vo)
ReceiverVO | WarehouseBox.getReceiverById(java.lang.String pk)

Methods in bb.common.box that return types with arguments of type ReceiverVO
 java.util.Collection<ReceiverVO> AccountingBox.findReceiverItemsWithOutAP(java.lang.String vendorId, java.lang.String currency, java.lang.String buyer, java.util.Date fromDate, java.util.Date toDate, java.lang.String poNumber, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type ReceiverVO
ReceiverVO | WarehouseBox.addReceiver(ReceiverVO vo)
void | WarehouseBox.deleteReceiver(ReceiverVO vo)
java.lang.String | WarehouseBox.updateReceiver(ReceiverVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ReceivingItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ReceivingItemResult

No usage of bb.common.ReceivingItemResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ReceivingResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ReceivingResult

Packages that use ReceivingResult
bb.common.box

Uses of ReceivingResult in bb.common.box

Methods in bb.common.box that return ReceivingResult
ReceivingResult | WarehouseBox.getOnloanReceivingResult(java.lang.String lnShipperNumber)
ReceivingResult | WarehouseBox.getPurchaseOrderReceivingResult(java.lang.String purchaseOrderNumber)
ReceivingResult | WarehouseBox.getRmaReceivingResult(java.lang.String rmaNumber)
ReceivingResult | WarehouseBox.getSwapReceivingResult(java.lang.String swapShipperNumber)
ReceivingResult | WarehouseBox.getTransferReceivingResult(java.lang.String transferShipperNumber)
ReceivingResult | WarehouseBox.getWorkOrderReceivingResult(java.lang.String workOrderNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RecursiveBillPath

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RecursiveBillPath

Packages that use RecursiveBillPath
bb.common.box

Uses of RecursiveBillPath in bb.common.box

Methods in bb.common.box that return types with arguments of type RecursiveBillPath
 java.util.Collection<RecursiveBillPath> EngineeringBox.getRecursiveBill(PartPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RefdocElement

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RefdocElement

Packages that use RefdocElement
bb.common

Uses of RefdocElement in bb.common

Methods in bb.common that return types with arguments of type RefdocElement
java.util.Set<RefdocElement> | WorkOrderItemListResult.getRefDoc1()
java.util.Set<RefdocElement> | DisassembleWorkOrderItemListResult.getRefDoc1()
java.util.Set<RefdocElement> | WorkOrderItemListResult.getRefDoc2()
java.util.Set<RefdocElement> | DisassembleWorkOrderItemListResult.getRefDoc2()

Method parameters in bb.common with type arguments of type RefdocElement
void | WorkOrderItemListResult.setRefDoc1(java.util.Set<RefdocElement> refDoc1)
void | DisassembleWorkOrderItemListResult.setRefDoc1(java.util.Set<RefdocElement> refDoc1)
void | WorkOrderItemListResult.setRefDoc2(java.util.Set<RefdocElement> refDoc2)
void | DisassembleWorkOrderItemListResult.setRefDoc2(java.util.Set<RefdocElement> refDoc2)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RefdocVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RefdocVO

Packages that use RefdocVO
bb.common
bb.common.box

Uses of RefdocVO in bb.common

Methods in bb.common that return types with arguments of type RefdocVO
java.util.Set<RefdocVO> | WorkOrderWorkInstructionListResult.getRefDoc()
java.util.Set<RefdocVO> | PartWithWipQtyListResult.getRefDocDetails()
java.util.Set<RefdocVO> | PartWithSTOQtyListResult.getRefDocDetails()
java.util.Set<RefdocVO> | PartWithSITQtyListResult.getRefDocDetails()
java.util.Set<RefdocVO> | PartWithSipQtyListResult.getRefDocDetails()
java.util.Set<RefdocVO> | PartWithQtyListResult.getRefDocDetails()
java.util.Set<RefdocVO> | PartWithQAQtyListResult.getRefDocDetails()

Methods in bb.common with parameters of type RefdocVO
static java.lang.Object | BB2Util.getFItemPK(RefdocVO vo, java.lang.Class<?> clazz)
static java.lang.String | BB2Util.getFRefDocString(RefdocVO vo)
static java.lang.String | BB2Util.getRefDocTwo(RefdocVO vo)
static java.lang.Object | BB2Util.getTItemPK(RefdocVO vo, java.lang.Class<?> clazz)
static java.lang.String | BB2Util.getTRefDocString(RefdocVO vo)
static void | BB2Util.setRefDocTwo(RefdocVO vo, java.lang.String refString)

Method parameters in bb.common with type arguments of type RefdocVO
void | WorkOrderWorkInstructionListResult.setRefDoc(java.util.Set<RefdocVO> refDoc)
void | PartWithWipQtyListResult.setRefDocDetails(java.util.Set<RefdocVO> refDocDetails)
void | PartWithSTOQtyListResult.setRefDocDetails(java.util.Set<RefdocVO> refDocDetails)
void | PartWithSITQtyListResult.setRefDocDetails(java.util.Set<RefdocVO> refDocDetails)
void | PartWithSipQtyListResult.setRefDocDetails(java.util.Set<RefdocVO> refDocDetails)
void | PartWithQtyListResult.setRefDocDetails(java.util.Set<RefdocVO> refDocDetails)
void | PartWithQAQtyListResult.setRefDocDetails(java.util.Set<RefdocVO> refDocDetails)

Constructors in bb.common with parameters of type RefdocVO
BB2RefdocPK(RefdocVO vo)

Uses of RefdocVO in bb.common.box

Methods in bb.common.box that return RefdocVO
RefdocVO | SalesBox.addRefdocOne(SalesOrderItemPK soItemPk, java.lang.String forderNumber, java.lang.String fItemNumber, java.math.BigDecimal refdocQty)
RefdocVO | WorkOrderBox.addRefdocOne(WorkOrderItemPK woItemPk, java.lang.String forderNumber, java.lang.String fItemNumber, java.math.BigDecimal refdocQty)
RefdocVO | AccountingBox.addRefdocTwo(AccountsPayableItemPK apItemPk, java.lang.String orderNumber, java.lang.String itemNumber)
RefdocVO | AccountingBox.addRefdocTwo(AccountsReceivableItemPK arItemPk, java.lang.String orderNumber, java.lang.String itemNumber)
RefdocVO | PurchasingBox.addRefdocTwo(PurchaseOrderItemPK poItemPk, java.lang.String orderNumber, java.lang.String itemNumber, java.math.BigDecimal refdocQty)
RefdocVO | WarehouseBox.addRefdocTwo(ReceiverItemPK rnItemPk, java.lang.String orderNumber, java.lang.String itemNumber)
RefdocVO | WarehouseBox.addRefdocTwo(ShipperItemPK shItemPk, java.lang.String orderNumber, java.lang.String itemNumber)
RefdocVO | WorkOrderBox.addRefdocTwo(WorkOrderItemPK woItemPk, java.lang.String orderNumber, java.lang.String itemNumber, java.math.BigDecimal refdocQty)
RefdocVO | WorkOrderBox.updateRefdocOne(RefdocVO vo)
RefdocVO | SalesBox.updateRefdocOne(RefdocVO vo)
RefdocVO | WorkOrderBox.updateRefdocTwo(RefdocVO vo)
RefdocVO | WarehouseBox.updateRefdocTwo(RefdocVO vo)
RefdocVO | PurchasingBox.updateRefdocTwo(RefdocVO vo)
RefdocVO | AccountingBox.updateRefdocTwo(RefdocVO vo)

Methods in bb.common.box that return types with arguments of type RefdocVO
java.util.Collection<RefdocVO> | WorkOrderBox.getParentOrder(java.lang.String orderNumber, java.lang.String orderItemNumber)
java.util.Collection<RefdocVO> | WorkOrderBox.getSubOrders(java.lang.String orderNumber, java.lang.String orderItemNumber)

Methods in bb.common.box with parameters of type RefdocVO
RefdocVO | WorkOrderBox.updateRefdocOne(RefdocVO vo)
RefdocVO | SalesBox.updateRefdocOne(RefdocVO vo)
RefdocVO | WorkOrderBox.updateRefdocTwo(RefdocVO vo)
RefdocVO | WarehouseBox.updateRefdocTwo(RefdocVO vo)
RefdocVO | PurchasingBox.updateRefdocTwo(RefdocVO vo)
RefdocVO | AccountingBox.updateRefdocTwo(RefdocVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RequestForQuoteCheckListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RequestForQuoteCheckListResult

Packages that use RequestForQuoteCheckListResult
bb.common.box

Uses of RequestForQuoteCheckListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type RequestForQuoteCheckListResult
java.util.Collection<RequestForQuoteCheckListResult> | PurchasingBox.findAllRfqCheckListResults(int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteCheckListResult> | ManufacturingBox.findAllRfqCheckListResults(int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteCheckListResult> | PurchasingBox.findRfqCheckListResults(java.lang.String startWith, int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteCheckListResult> | ManufacturingBox.findRfqCheckListResults(java.lang.String startWith, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RequestForQuoteItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RequestForQuoteItemListResult

Packages that use RequestForQuoteItemListResult
bb.common.box

Uses of RequestForQuoteItemListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type RequestForQuoteItemListResult
java.util.Collection<RequestForQuoteItemListResult> | PurchasingBox.findCancelledRequestForQuoteItemListResults(int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteItemListResult> | PurchasingBox.findDueRequestForQuoteItemListResults(int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteItemListResult> | ManufacturingBox.findDueRequestForQuoteItemListResults(int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteItemListResult> | PurchasingBox.findOpenRequestForQuoteItemListResults(int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteItemListResult> | ManufacturingBox.findOpenRequestForQuoteItemListResults(int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteItemListResult> | PurchasingBox.findRequestForQuoteItemListResults(java.lang.String partNumberLike, java.lang.String partType, java.lang.String status, boolean isDue, int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteItemListResult> | ManufacturingBox.findRequestForQuoteItemListResults(java.lang.String partNumberLike, java.lang.String partType, java.lang.String status, boolean isDue, int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteItemListResult> | PurchasingBox.findRequestForQuoteItemListResults(java.lang.String partNumberLike, java.lang.String partType, java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteItemListResult> | ManufacturingBox.findRequestForQuoteItemListResults(java.lang.String partNumberLike, java.lang.String partType, java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteItemListResult> | PurchasingBox.findRequestForQuoteItemListResultsByPartNumberAndDateLike(java.lang.String searchText, java.lang.String partType, java.lang.String dateType, java.util.Date dateBigin, java.util.Date dateEnd, java.lang.String vendorId, boolean vendorIdLike, int firstIndex, int length)
java.util.Collection<RequestForQuoteItemListResult> | PurchasingBox.findRequestForQuoteItemListResultsByPartNumberAndDateLike(java.lang.String searchText, java.lang.String partType, java.lang.String dateType, java.util.Date dateBigin, java.util.Date dateEnd, java.lang.String vendorId, java.lang.String buyer, int firstIndex, int length)
java.util.Collection<RequestForQuoteItemListResult> | PurchasingBox.findRequestForQuoteItemListResultsByPartNumberLike(java.lang.String partNumberLike, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteItemListResult> | ManufacturingBox.findRequestForQuoteItemListResultsByPartNumberLike(java.lang.String partNumberLike, java.lang.String partType, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RequestForQuoteItemManufacturerPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RequestForQuoteItemManufacturerPK

Packages that use RequestForQuoteItemManufacturerPK
bb.common

Uses of RequestForQuoteItemManufacturerPK in bb.common

Methods in bb.common that return RequestForQuoteItemManufacturerPK
 RequestForQuoteItemManufacturerPK RequestForQuoteItemManufacturerVO.getPk()

Methods in bb.common with parameters of type RequestForQuoteItemManufacturerPK
 void RequestForQuoteItemManufacturerVO.setPk(RequestForQuoteItemManufacturerPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RequestForQuoteItemManufacturerVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RequestForQuoteItemManufacturerVO

No usage of bb.common.RequestForQuoteItemManufacturerVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RequestForQuoteItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RequestForQuoteItemPK

Packages that use RequestForQuoteItemPK
bb.common
bb.common.box

Uses of RequestForQuoteItemPK in bb.common

Methods in bb.common that return RequestForQuoteItemPK
RequestForQuoteItemPK | RequestForQuoteItemVO.getPk()
RequestForQuoteItemPK | RequestForQuoteItemListResult.getRfqItemPk()

Methods in bb.common with parameters of type RequestForQuoteItemPK
void | RequestForQuoteItemVO.setPk(RequestForQuoteItemPK pk)
void | RequestForQuoteItemListResult.setRfqItemPk(RequestForQuoteItemPK rfqItemPk)

Uses of RequestForQuoteItemPK in bb.common.box

Methods in bb.common.box with parameters of type RequestForQuoteItemPK
 boolean PurchasingBox.isRFQMessageItemExist(RequestForQuoteItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RequestForQuoteItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RequestForQuoteItemVO

Packages that use RequestForQuoteItemVO
bb.common
bb.common.box

Uses of RequestForQuoteItemVO in bb.common

Methods in bb.common that return RequestForQuoteItemVO
 RequestForQuoteItemVO RfqMessageItemVO.getRfqItem()

Methods in bb.common with parameters of type RequestForQuoteItemVO
 void RfqMessageItemVO.setRfqItem(RequestForQuoteItemVO rfqItem)

Uses of RequestForQuoteItemVO in bb.common.box

Methods in bb.common.box that return RequestForQuoteItemVO
RequestForQuoteItemVO | PurchasingBox.initRequestForQuoteItemForPart(java.lang.String requestForQuoteNumber, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty, java.lang.String languageCode)
RequestForQuoteItemVO | PurchasingBox.initRequestForQuoteItemForTool(java.lang.String requestForQuoteNumber, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty, java.lang.String languageCode)
RequestForQuoteItemVO | ManufacturingBox.initRequestForQuoteItemForTool(java.lang.String requestForQuoteNumber, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty, java.lang.String languageCode)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RequestForQuoteListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RequestForQuoteListResult

Packages that use RequestForQuoteListResult
bb.common.box

Uses of RequestForQuoteListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type RequestForQuoteListResult
java.util.Collection<RequestForQuoteListResult> | PurchasingBox.findRequestForQuoteListResults(java.lang.String rfqNumber, java.lang.String status, java.lang.String vendId, int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteListResult> | ManufacturingBox.findRequestForQuoteListResults(java.lang.String rfqNumber, java.lang.String status, java.lang.String vendId, int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteListResult> | PurchasingBox.findRequestForQuoteListResultsByRfqNumber(java.lang.String rfqNumber, int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteListResult> | ManufacturingBox.findRequestForQuoteListResultsByRfqNumber(java.lang.String rfqNumber, int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteListResult> | PurchasingBox.findRequestForQuoteListResultsByVendorId(java.lang.String vendorId, int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteListResult> | ManufacturingBox.findRequestForQuoteListResultsByVendorId(java.lang.String vendorId, int firstIndex, int maxLength)
java.util.Collection<RequestForQuoteListResult> | PurchasingBox.makeRequestForQuotes(PurchaseWorkSheetVO pwsVO)
java.util.Collection<RequestForQuoteListResult> | ManufacturingBox.makeRequestForQuotes(PurchaseWorkSheetVO pwsVO)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RequestForQuoteVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RequestForQuoteVO

Packages that use RequestForQuoteVO
bb.common.box

Uses of RequestForQuoteVO in bb.common.box

Methods in bb.common.box that return RequestForQuoteVO
RequestForQuoteVO | PurchasingBox.addRequestForQuote(java.lang.String vendorId)
RequestForQuoteVO | ManufacturingBox.addRequestForQuote(java.lang.String vendorId)
RequestForQuoteVO | PurchasingBox.addRequestForQuote(java.lang.String vendorId, java.lang.String oldRFQNumber, boolean includeItems)
RequestForQuoteVO | PurchasingBox.addRfqFromQuote(java.lang.String vendorId, java.lang.String quoteNumber)
RequestForQuoteVO | PurchasingBox.addRfqFromSO(java.lang.String vendorId, java.lang.String soNumber, boolean isCopyMpn)
RequestForQuoteVO | PurchasingBox.approveRequestForQuote(RequestForQuoteVO rfqVo)
RequestForQuoteVO | ManufacturingBox.approveRequestForQuote(RequestForQuoteVO rfqVo)
RequestForQuoteVO | PurchasingBox.approveRequestForQuote(java.lang.String rfqNumber)
RequestForQuoteVO | ManufacturingBox.approveRequestForQuote(java.lang.String rfqNumber)
RequestForQuoteVO | PurchasingBox.getRequestForQuoteByRfqNumber(java.lang.String rfqNumber)
RequestForQuoteVO | ManufacturingBox.getRequestForQuoteByRfqNumber(java.lang.String rfqNumber)
RequestForQuoteVO | ManufacturingBox.updateRequestForQuote(RequestForQuoteVO rfqVO)

Methods in bb.common.box with parameters of type RequestForQuoteVO
RequestForQuoteVO | PurchasingBox.approveRequestForQuote(RequestForQuoteVO rfqVo)
RequestForQuoteVO | ManufacturingBox.approveRequestForQuote(RequestForQuoteVO rfqVo)
void | PurchasingBox.deleteRequestForQuote(RequestForQuoteVO rfqVO)
void | ManufacturingBox.deleteRequestForQuote(RequestForQuoteVO rfqVO)
java.lang.String | PurchasingBox.updateRequestForQuote(RequestForQuoteVO rfqVO)
RequestForQuoteVO | ManufacturingBox.updateRequestForQuote(RequestForQuoteVO rfqVO)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RequestForRMAItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RequestForRMAItemPK

Packages that use RequestForRMAItemPK
bb.common
bb.common.box

Uses of RequestForRMAItemPK in bb.common

Methods in bb.common that return RequestForRMAItemPK
 RequestForRMAItemPK RequestForRMAItemVO.getPk()

Methods in bb.common with parameters of type RequestForRMAItemPK
 void RequestForRMAItemVO.setPk(RequestForRMAItemPK pk)

Constructors in bb.common with parameters of type RequestForRMAItemPK
RequestForRMAItemVO(RequestForRMAItemPK pk, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom)
minimal constructor

Uses of RequestForRMAItemPK in bb.common.box

Methods in bb.common.box with parameters of type RequestForRMAItemPK
RequestForRMAItemVO | SalesBox.getRRMAItemByPk(RequestForRMAItemPK pk)
boolean | SalesBox.isRrmaItemExist(RequestForRMAItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RequestForRMAItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RequestForRMAItemVO

Packages that use RequestForRMAItemVO
bb.common
bb.common.box

Uses of RequestForRMAItemVO in bb.common

Methods in bb.common that return types with arguments of type RequestForRMAItemVO
 java.util.Set<RequestForRMAItemVO> RequestForRMAVO.getRrmaItem()

Method parameters in bb.common with type arguments of type RequestForRMAItemVO
 void RequestForRMAVO.setRrmaItem(java.util.Set<RequestForRMAItemVO> rrmaItem)

Uses of RequestForRMAItemVO in bb.common.box

Methods in bb.common.box that return RequestForRMAItemVO
 RequestForRMAItemVO SalesBox.getRRMAItemByPk(RequestForRMAItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RequestForRMAVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RequestForRMAVO

Packages that use RequestForRMAVO
bb.common.box

Uses of RequestForRMAVO in bb.common.box

Methods in bb.common.box that return RequestForRMAVO
RequestForRMAVO | SalesBox.getRRMAById(java.lang.String rrmaNumber)
RequestForRMAVO | SalesBox.reviewRrma(RequestForRMAVO rrma)

Methods in bb.common.box with parameters of type RequestForRMAVO
 RequestForRMAVO SalesBox.reviewRrma(RequestForRMAVO rrma)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ReturnMaterialAuthorizationDocumentVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ReturnMaterialAuthorizationDocumentVO

Packages that use ReturnMaterialAuthorizationDocumentVO
bb.common.box

Uses of ReturnMaterialAuthorizationDocumentVO in bb.common.box

Methods in bb.common.box that return types with arguments of type ReturnMaterialAuthorizationDocumentVO
java.util.Collection<ReturnMaterialAuthorizationDocumentVO> | SalesBox.deleteFTPRMADoc(MiscDocAgent agent)
java.util.Collection<ReturnMaterialAuthorizationDocumentVO> | SalesBox.uploadOrUpdateFTPRMADoc(MiscDocAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ReturnMaterialAuthorizationItemManufacturerPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ReturnMaterialAuthorizationItemManufacturerPK

Packages that use ReturnMaterialAuthorizationItemManufacturerPK
bb.common

Uses of ReturnMaterialAuthorizationItemManufacturerPK in bb.common

Methods in bb.common that return ReturnMaterialAuthorizationItemManufacturerPK
 ReturnMaterialAuthorizationItemManufacturerPK ReturnMaterialAuthorizationItemManufacturerVO.getPk()

Methods in bb.common with parameters of type ReturnMaterialAuthorizationItemManufacturerPK
 void ReturnMaterialAuthorizationItemManufacturerVO.setPk(ReturnMaterialAuthorizationItemManufacturerPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ReturnMaterialAuthorizationItemManufacturerVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ReturnMaterialAuthorizationItemManufacturerVO

No usage of bb.common.ReturnMaterialAuthorizationItemManufacturerVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ReturnMaterialAuthorizationItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ReturnMaterialAuthorizationItemPK

Packages that use ReturnMaterialAuthorizationItemPK
bb.common

Uses of ReturnMaterialAuthorizationItemPK in bb.common

Methods in bb.common that return ReturnMaterialAuthorizationItemPK
ReturnMaterialAuthorizationItemPK | RMAReceiverResult.getPk()
ReturnMaterialAuthorizationItemPK | ReturnMaterialAuthorizationItemVO.getPk()

Methods in bb.common with parameters of type ReturnMaterialAuthorizationItemPK
void | RMAReceiverResult.setPk(ReturnMaterialAuthorizationItemPK pk)
void | ReturnMaterialAuthorizationItemVO.setPk(ReturnMaterialAuthorizationItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ReturnMaterialAuthorizationItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ReturnMaterialAuthorizationItemVO

Packages that use ReturnMaterialAuthorizationItemVO
bb.common.box

Uses of ReturnMaterialAuthorizationItemVO in bb.common.box

Methods in bb.common.box that return ReturnMaterialAuthorizationItemVO
ReturnMaterialAuthorizationItemVO | SalesBox.initRmaItem(ReturnMaterialAuthorizationVO rmaVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool)
ReturnMaterialAuthorizationItemVO | SalesBox.initRmaItem(ReturnMaterialAuthorizationVO rmaVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool, boolean isPOS)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ReturnMaterialAuthorizationVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ReturnMaterialAuthorizationVO

Packages that use ReturnMaterialAuthorizationVO
bb.common.box

Uses of ReturnMaterialAuthorizationVO in bb.common.box

Methods in bb.common.box that return ReturnMaterialAuthorizationVO
ReturnMaterialAuthorizationVO | SalesBox.findRmaById(java.lang.String rmaNumber)
ReturnMaterialAuthorizationVO | SalesBox.makeRMAFromRRMANumber(java.lang.String rrmaNumber)
ReturnMaterialAuthorizationVO | SalesBox.reviewRma(ReturnMaterialAuthorizationVO rmaVo)

Methods in bb.common.box with parameters of type ReturnMaterialAuthorizationVO
ReturnMaterialAuthorizationItemVO | SalesBox.initRmaItem(ReturnMaterialAuthorizationVO rmaVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool)
ReturnMaterialAuthorizationItemVO | SalesBox.initRmaItem(ReturnMaterialAuthorizationVO rmaVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool, boolean isPOS)
ReturnMaterialAuthorizationVO | SalesBox.reviewRma(ReturnMaterialAuthorizationVO rmaVo)
java.lang.String | SalesBox.updateRma(ReturnMaterialAuthorizationVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ReturnToVendorByDateListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ReturnToVendorByDateListResult

Packages that use ReturnToVendorByDateListResult
bb.common.box

Uses of ReturnToVendorByDateListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type ReturnToVendorByDateListResult
java.util.Collection<ReturnToVendorByDateListResult> | PurchasingBox.findCancelledReturnToVendorItemsListResults(int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorByDateListResult> | PurchasingBox.findReturnToVendorItemsListResults(java.lang.String partnumber, java.lang.String parttype, java.lang.String status, java.lang.String shipto, java.lang.String vendorId, java.lang.String po, java.lang.String ncrNumber, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isRtvDate, java.util.Date startDate, java.util.Date toDate, java.lang.String project, java.lang.String requester, java.lang.String buyer, java.lang.String enterBy, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorByDateListResult> | PurchasingBox.findReturnToVendorItemsListResults(java.lang.String partnumber, java.lang.String parttype, java.lang.String status, java.lang.String shipto, java.lang.String vendorId, java.lang.String po, java.lang.String ncrNumber, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isRtvDate, java.util.Date startDate, java.util.Date toDate, java.lang.String project, java.lang.String requester, java.lang.String buyer, java.lang.String enterBy, java.lang.String refDoc, java.lang.String currency, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ReturnToVendorCheckListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ReturnToVendorCheckListResult

Packages that use ReturnToVendorCheckListResult
bb.common.box

Uses of ReturnToVendorCheckListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type ReturnToVendorCheckListResult
java.util.Collection<ReturnToVendorCheckListResult> | PurchasingBox.findAllRtvCheckListResults(int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorCheckListResult> | ManufacturingBox.findAllRtvCheckListResults(int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorCheckListResult> | PurchasingBox.findRtvCheckListResults(java.lang.String startWith, int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorCheckListResult> | ManufacturingBox.findRtvCheckListResults(java.lang.String startWith, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ReturnToVendorItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ReturnToVendorItemListResult

Packages that use ReturnToVendorItemListResult
bb.common.box

Uses of ReturnToVendorItemListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type ReturnToVendorItemListResult
java.util.Collection<ReturnToVendorItemListResult> | PurchasingBox.findDueReturnToVendorItemListResults(int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorItemListResult> | ManufacturingBox.findDueReturnToVendorItemListResults(int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorItemListResult> | PurchasingBox.findOpenReturnToVendorItemListResults(int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorItemListResult> | ManufacturingBox.findOpenReturnToVendorItemListResults(int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorItemListResult> | PurchasingBox.findReturnToVendorItemListResults(java.lang.String partNumberLike, java.lang.String partType, java.lang.String status, boolean isDue, int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorItemListResult> | ManufacturingBox.findReturnToVendorItemListResults(java.lang.String partNumberLike, java.lang.String partType, java.lang.String status, boolean isDue, int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorItemListResult> | PurchasingBox.findReturnToVendorItemListResults(java.lang.String partNumberLike, java.lang.String partType, java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorItemListResult> | ManufacturingBox.findReturnToVendorItemListResults(java.lang.String partNumberLike, java.lang.String partType, java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorItemListResult> | PurchasingBox.findReturnToVendorItemListResultsByPartNumberLike(java.lang.String partNumberLike, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorItemListResult> | ManufacturingBox.findReturnToVendorItemListResultsByPartNumberLike(java.lang.String partNumberLike, java.lang.String partType, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ReturnToVendorItemManufacturerPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ReturnToVendorItemManufacturerPK

Packages that use ReturnToVendorItemManufacturerPK
bb.common

Uses of ReturnToVendorItemManufacturerPK in bb.common

Methods in bb.common that return ReturnToVendorItemManufacturerPK
 ReturnToVendorItemManufacturerPK ReturnToVendorItemManufacturerVO.getPk()

Methods in bb.common with parameters of type ReturnToVendorItemManufacturerPK
 void ReturnToVendorItemManufacturerVO.setPk(ReturnToVendorItemManufacturerPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ReturnToVendorItemManufacturerVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ReturnToVendorItemManufacturerVO

No usage of bb.common.ReturnToVendorItemManufacturerVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ReturnToVendorItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ReturnToVendorItemPK

Packages that use ReturnToVendorItemPK
bb.common

Uses of ReturnToVendorItemPK in bb.common

Methods in bb.common that return ReturnToVendorItemPK
ReturnToVendorItemPK | ReturnToVendorItemVO.getPk()
ReturnToVendorItemPK | ReturnToVendorItemListResult.getRtvItemPk()
ReturnToVendorItemPK | ReturnToVendorByDateListResult.getRtvItemPk()

Methods in bb.common with parameters of type ReturnToVendorItemPK
void | ReturnToVendorItemVO.setPk(ReturnToVendorItemPK pk)
void | ReturnToVendorItemListResult.setRtvItemPk(ReturnToVendorItemPK rtvItemPk)
void | ReturnToVendorByDateListResult.setRtvItemPk(ReturnToVendorItemPK rtvItemPk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ReturnToVendorItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ReturnToVendorItemVO

Packages that use ReturnToVendorItemVO
bb.common.box

Uses of ReturnToVendorItemVO in bb.common.box

Methods in bb.common.box that return ReturnToVendorItemVO
ReturnToVendorItemVO | PurchasingBox.initReturnToVendorItemForPart(java.lang.String rtvNumber, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
ReturnToVendorItemVO | ManufacturingBox.initReturnToVendorItemForPart(java.lang.String rtvNumber, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
ReturnToVendorItemVO | PurchasingBox.initReturnToVendorItemForTool(java.lang.String rtvNumber, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
ReturnToVendorItemVO | ManufacturingBox.initReturnToVendorItemForTool(java.lang.String rtvNumber, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ReturnToVendorListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ReturnToVendorListResult

Packages that use ReturnToVendorListResult
bb.common.box

Uses of ReturnToVendorListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type ReturnToVendorListResult
java.util.Collection<ReturnToVendorListResult> | PurchasingBox.findOpenReturnToVendorListResultsByRtvNumber(java.lang.String rtvNumber, int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorListResult> | PurchasingBox.findReturnToVendorListResults(java.lang.String rtvNumber, java.lang.String status, java.lang.String vendId, int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorListResult> | ManufacturingBox.findReturnToVendorListResults(java.lang.String rtvNumber, java.lang.String status, java.lang.String vendId, int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorListResult> | PurchasingBox.findReturnToVendorListResultsByRtvNumber(java.lang.String rtvNumber, int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorListResult> | ManufacturingBox.findReturnToVendorListResultsByRtvNumber(java.lang.String rtvNumber, int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorListResult> | PurchasingBox.findReturnToVendorListResultsByVendorId(java.lang.String vendorId, int firstIndex, int maxLength)
java.util.Collection<ReturnToVendorListResult> | ManufacturingBox.findReturnToVendorListResultsByVendorId(java.lang.String vendorId, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ReturnToVendorVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ReturnToVendorVO

Packages that use ReturnToVendorVO
bb.common.box

Uses of ReturnToVendorVO in bb.common.box

Methods in bb.common.box that return ReturnToVendorVO
ReturnToVendorVO | ManufacturingBox.addReturnToVendor(java.lang.String vendorID)
ReturnToVendorVO | ManufacturingBox.approveReturnToVendor(ReturnToVendorVO rtvVO)
ReturnToVendorVO | ManufacturingBox.approveReturnToVendor(java.lang.String rtvNumber)
ReturnToVendorVO | PurchasingBox.getReturnToVendorByRtvNumber(java.lang.String rtvNumber)
ReturnToVendorVO | ManufacturingBox.getReturnToVendorByRtvNumber(java.lang.String rtvNumber)
ReturnToVendorVO | ManufacturingBox.updateReturnToVendor(ReturnToVendorVO rtvVO)

Methods in bb.common.box with parameters of type ReturnToVendorVO
java.lang.String | PurchasingBox.approveReturnToVendor(ReturnToVendorVO rtvVO)
ReturnToVendorVO | ManufacturingBox.approveReturnToVendor(ReturnToVendorVO rtvVO)
void | PurchasingBox.deleteReturnToVendor(ReturnToVendorVO rtvVO)
void | ManufacturingBox.deleteReturnToVendor(ReturnToVendorVO rtvVO)
java.lang.String | PurchasingBox.updateReturnToVendor(ReturnToVendorVO rtvVO)
ReturnToVendorVO | ManufacturingBox.updateReturnToVendor(ReturnToVendorVO rtvVO)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RfqMessageItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RfqMessageItemPK

Packages that use RfqMessageItemPK
bb.common

Uses of RfqMessageItemPK in bb.common

Methods in bb.common that return RfqMessageItemPK
 RfqMessageItemPK RfqMessageItemVO.getPk()

Methods in bb.common with parameters of type RfqMessageItemPK
 void RfqMessageItemVO.setPk(RfqMessageItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RfqMessageItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RfqMessageItemVO

No usage of bb.common.RfqMessageItemVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RfqMessageListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RfqMessageListResult

Packages that use RfqMessageListResult
bb.common.box

Uses of RfqMessageListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type RfqMessageListResult
java.util.Collection<RfqMessageListResult> | PurchasingBox.findAllRfqMessages()
java.util.Collection<RfqMessageListResult> | PurchasingBox.findRfqMessagesByStatusAndID(java.lang.String[] status, java.lang.String vendorIdLike, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RfqMessageVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RfqMessageVO

Packages that use RfqMessageVO
bb.common.box

Uses of RfqMessageVO in bb.common.box

Methods in bb.common.box that return RfqMessageVO
RfqMessageVO | PurchasingBox.acceptRfqMessage(java.lang.String rfqMessageNumber, java.lang.String comments, java.util.Hashtable itemComments, boolean updatePartVendor)
RfqMessageVO | PurchasingBox.addRfqMessage(java.lang.String rfqNumber)
RfqMessageVO | PurchasingBox.getRfqMessage(java.lang.String rfqMessageNumber)
RfqMessageVO | PurchasingBox.getRfqMessageByRfqNumber(java.lang.String rfqNumber)
RfqMessageVO | PurchasingBox.refuseRfqMessage(java.lang.String rfqMessageNumber, java.lang.String comments, java.util.Hashtable itemComments, boolean resend, boolean updateRfq)
RfqMessageVO | PurchasingBox.saveRfqMessage(java.lang.String rfqMessageNumber, java.lang.String comments, java.util.Hashtable itemComments)
RfqMessageVO | PurchasingBox.updateRfqMessage(RfqMessageVO vo)

Methods in bb.common.box with parameters of type RfqMessageVO
 RfqMessageVO PurchasingBox.updateRfqMessage(RfqMessageVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RMAItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RMAItemListResult

Packages that use RMAItemListResult
bb.common.box

Uses of RMAItemListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type RMAItemListResult
java.util.Collection<RMAItemListResult> | SalesBox.findAllDueRma(int firstIndex, int maxLength)
java.util.Collection<RMAItemListResult> | SalesBox.findAllOpenRma(int firstIndex, int maxLength)
java.util.Collection<RMAItemListResult> | SalesBox.findCancelledRmaItems(int firstIndex, int maxLength)
java.util.Collection<RMAItemListResult> | SalesBox.findOpenRMAsByPartPk(PartPK pk, int firstIndex, int maxLength)
java.util.Collection<RMAItemListResult> | SalesBox.findRmaItemByCustomerIdLike(java.lang.String customerIdLike, int firstIndex, int maxLength)
java.util.Collection<RMAItemListResult> | SalesBox.findRmaItemByPartPk(PartPK partPk, int firstIndex, int maxLength)
java.util.Collection<RMAItemListResult> | SalesBox.findRmaItemsByDate(PartPK partPk, java.lang.String rmaNumber, java.lang.String rmaItemNumber, java.lang.String customerId, java.lang.String salesMan, java.lang.String ncrNumber, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isRequireDate, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<RMAItemListResult> | SalesBox.findRMAsByPartPk(PartPK pk, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RMAListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RMAListResult

Packages that use RMAListResult
bb.common.box

Uses of RMAListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type RMAListResult
java.util.Collection<RMAListResult> | SalesBox.findAllRmas(int firstIndex, int maxLength)
java.util.Collection<RMAListResult> | SalesBox.findOpenRMAs(java.lang.String rmaNumberExp, int firstIndex, int maxLength)
java.util.Collection<RMAListResult> | SalesBox.findRmaCheckList(int firstIndex, int maxLength)
java.util.Collection<RMAListResult> | SalesBox.findRMAsByIvoiceNumber(java.lang.String invoiceNumber, int firstIndex, int maxLength)
java.util.Collection<RMAListResult> | SalesBox.findRMAsByRmaNumber(java.lang.String rmaNumberExp, int firstIndex, int maxLength)
java.util.Collection<RMAListResult> | SalesBox.findRMAsBySoNumber(java.lang.String salesOrderNumberExp, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RMAReceiverItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RMAReceiverItemListResult

Packages that use RMAReceiverItemListResult
bb.common.box

Uses of RMAReceiverItemListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type RMAReceiverItemListResult
java.util.Collection<RMAReceiverItemListResult> | WarehouseBox.findRMAReceiverItemListResultsByCustID(java.lang.String custID, int firstIndex, int maxLength)
java.util.Collection<RMAReceiverItemListResult> | WarehouseBox.findRMAReceiverItemListResultsByPartNumber(java.lang.String partNumber, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<RMAReceiverItemListResult> | WarehouseBox.findRMAReceiverItemListResultsByRMAReceiverNumber(java.lang.String rmaRecNumber, int firstIndex, int maxLength)
java.util.Collection<RMAReceiverItemListResult> | WarehouseBox.findRMAReceiverItemListResultsBySONumber(java.lang.String soNumber, int firstIndex, int maxLength)
java.util.Collection<RMAReceiverItemListResult> | SalesBox.getRmaReceiverBySoNumber(java.lang.String soNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RMAReceiverItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RMAReceiverItemPK

Packages that use RMAReceiverItemPK
bb.common
bb.common.box

Uses of RMAReceiverItemPK in bb.common

Methods in bb.common that return RMAReceiverItemPK
 RMAReceiverItemPK RMAReceiverItemVO.getPk()

Methods in bb.common with parameters of type RMAReceiverItemPK
 void RMAReceiverItemVO.setPk(RMAReceiverItemPK pk)

Uses of RMAReceiverItemPK in bb.common.box

Methods in bb.common.box with parameters of type RMAReceiverItemPK
 RMAReceiverItemVO WarehouseBox.getRMAReceiverItemByPk(RMAReceiverItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RMAReceiverItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RMAReceiverItemVO

Packages that use RMAReceiverItemVO
bb.common
bb.common.box

Uses of RMAReceiverItemVO in bb.common

Methods in bb.common that return types with arguments of type RMAReceiverItemVO
 java.util.List<RMAReceiverItemVO> ReturnMaterialAuthorizationVO.getBb2RmaReceiverItems()

Method parameters in bb.common with type arguments of type RMAReceiverItemVO
 void ReturnMaterialAuthorizationVO.setBb2RmaReceiverItems(java.util.List<RMAReceiverItemVO> bb2RmaReceiverItems)

Uses of RMAReceiverItemVO in bb.common.box

Methods in bb.common.box that return RMAReceiverItemVO
 RMAReceiverItemVO WarehouseBox.getRMAReceiverItemByPk(RMAReceiverItemPK pk)

Methods in bb.common.box that return types with arguments of type RMAReceiverItemVO
 java.util.Collection<RMAReceiverItemVO> WarehouseBox.getRMAReceiverItemsforRMANumber(java.lang.String rmaNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RMAReceiverListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RMAReceiverListResult

Packages that use RMAReceiverListResult
bb.common.box

Uses of RMAReceiverListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type RMAReceiverListResult
java.util.Collection<RMAReceiverListResult> | WarehouseBox.findRMAReceiverListResultsByCustID(java.lang.String custID, int firstIndex, int maxLength)
java.util.Collection<RMAReceiverListResult> | WarehouseBox.findRMAReceiverListResultsByRMAReceiverNumber(java.lang.String rmaRecNumber, int firstIndex, int maxLength)
java.util.Collection<RMAReceiverListResult> | WarehouseBox.findRMAReceiverWithoutCMListResults(java.lang.String rmaRecNumber, int firstIndex, int maxLength)
java.util.Collection<RMAReceiverListResult> | WarehouseBox.makeRmaReceiver(ReceiverAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RMAReceiverResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RMAReceiverResult

Packages that use RMAReceiverResult
bb.common

Uses of RMAReceiverResult in bb.common

Methods in bb.common that return types with arguments of type RMAReceiverResult
 java.util.ArrayList<RMAReceiverResult> BB2PartTotalOndemandDetailResult.getRmaDetails()

Method parameters in bb.common with type arguments of type RMAReceiverResult
 void BB2PartTotalOndemandDetailResult.setRmaDetails(java.util.ArrayList<RMAReceiverResult> rmaDetails)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RMAReceiverVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RMAReceiverVO

Packages that use RMAReceiverVO
bb.common.box

Uses of RMAReceiverVO in bb.common.box

Methods in bb.common.box that return RMAReceiverVO
 RMAReceiverVO WarehouseBox.getRMAReceiver(java.lang.String receiverNumber)

Methods in bb.common.box with parameters of type RMAReceiverVO
 java.lang.String WarehouseBox.updateRMAReceiver(RMAReceiverVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RMAReviewVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RMAReviewVO

Packages that use RMAReviewVO
bb.common.box

Uses of RMAReviewVO in bb.common.box

Methods in bb.common.box that return RMAReviewVO
 RMAReviewVO SalesBox.getRMAReview(java.lang.String employeeID)

Methods in bb.common.box that return types with arguments of type RMAReviewVO
 java.util.Collection<RMAReviewVO> SalesBox.findAllRMAReviews(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type RMAReviewVO
 java.lang.String SalesBox.updateRMAReview(RMAReviewVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RoleDescriptionPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RoleDescriptionPK

Packages that use RoleDescriptionPK
bb.common

Uses of RoleDescriptionPK in bb.common

Methods in bb.common that return RoleDescriptionPK
 RoleDescriptionPK RoleDescriptionVO.getPk()

Methods in bb.common with parameters of type RoleDescriptionPK
 void RoleDescriptionVO.setPk(RoleDescriptionPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RoleDescriptionVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RoleDescriptionVO

No usage of bb.common.RoleDescriptionVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RoleListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RoleListResult

Packages that use RoleListResult
bb.common.box

Uses of RoleListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type RoleListResult
java.util.Collection<RoleListResult> | SecurityBox.findAllRoles(java.lang.String language, int firstIndex, int maxLength)
java.util.Collection<RoleListResult> | SecurityBox.findAllRolesByRoleId(java.lang.String roleId, java.lang.String language, int firstIndex, int maxLength)
java.util.Collection<RoleListResult> | SecurityBox.findRolesByPermission(java.lang.String permissionId, java.lang.String language, int firstIndex, int maxLength)
java.util.Collection<RoleListResult> | SecurityBox.findRolesBySelf(java.lang.String language, int firstIndex, int maxLength)
java.util.Collection<RoleListResult> | SecurityBox.findRolesByUser(java.lang.String userName, java.lang.String language, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RolePermissionPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RolePermissionPK

Packages that use RolePermissionPK
bb.common

Uses of RolePermissionPK in bb.common

Methods in bb.common that return RolePermissionPK
 RolePermissionPK RolePermissionVO.getPk()

Methods in bb.common with parameters of type RolePermissionPK
 void RolePermissionVO.setPk(RolePermissionPK pk)

Constructors in bb.common with parameters of type RolePermissionPK
RolePermissionVO(RolePermissionPK pk)
full constructor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RolePermissionVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RolePermissionVO

No usage of bb.common.RolePermissionVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RoleVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RoleVO

Packages that use RoleVO
bb.common.box

Uses of RoleVO in bb.common.box

Methods in bb.common.box that return RoleVO
RoleVO | SecurityBox.copyRoleToRole(java.lang.String oldRoleId, java.lang.String roleId)
RoleVO | SecurityBox.getRoleByPk(java.lang.String roleId)

Methods in bb.common.box with parameters of type RoleVO
void | SecurityBox.addRole(RoleVO vo)
void | SecurityBox.updateRole(RoleVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RollUpBomStdCostWorkSheetItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RollUpBomStdCostWorkSheetItemPK

Packages that use RollUpBomStdCostWorkSheetItemPK
bb.common

Uses of RollUpBomStdCostWorkSheetItemPK in bb.common

Methods in bb.common that return RollUpBomStdCostWorkSheetItemPK
 RollUpBomStdCostWorkSheetItemPK RollUpBomStdCostWorkSheetItemVO.getPk()

Methods in bb.common with parameters of type RollUpBomStdCostWorkSheetItemPK
 void RollUpBomStdCostWorkSheetItemVO.setPk(RollUpBomStdCostWorkSheetItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RollUpBomStdCostWorkSheetItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RollUpBomStdCostWorkSheetItemVO

Packages that use RollUpBomStdCostWorkSheetItemVO
bb.common.box

Uses of RollUpBomStdCostWorkSheetItemVO in bb.common.box

Methods in bb.common.box that return types with arguments of type RollUpBomStdCostWorkSheetItemVO
 java.util.Collection<RollUpBomStdCostWorkSheetItemVO> AccountingBox.findRollUpBomStdCostWorkSheetItem(java.lang.Long ii, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RollUpBomStdCostWorkSheetVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RollUpBomStdCostWorkSheetVO

Packages that use RollUpBomStdCostWorkSheetVO
bb.common.box

Uses of RollUpBomStdCostWorkSheetVO in bb.common.box

Methods in bb.common.box that return RollUpBomStdCostWorkSheetVO
 RollUpBomStdCostWorkSheetVO AccountingBox.getRollUpBomStdCostWorkSheet(java.lang.Long ii)

Methods in bb.common.box that return types with arguments of type RollUpBomStdCostWorkSheetVO
 java.util.Collection<RollUpBomStdCostWorkSheetVO> AccountingBox.findRollUpBomStdCostWorkSheet(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type RollUpBomStdCostWorkSheetVO
java.lang.Long | AccountingBox.addRollUpBomStdCostWorkSheet(RollUpBomStdCostWorkSheetVO vo)
void | AccountingBox.updateRollUpBomStdCostWorkSheet(RollUpBomStdCostWorkSheetVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RollUPPartStandardCostResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RollUPPartStandardCostResult

Packages that use RollUPPartStandardCostResult
bb.common.box

Uses of RollUPPartStandardCostResult in bb.common.box

Methods in bb.common.box that return types with arguments of type RollUPPartStandardCostResult
 java.util.Collection<RollUPPartStandardCostResult> EngineeringBox.getPartsToRollUPunder(BillPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RRMAItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RRMAItemListResult

Packages that use RRMAItemListResult
bb.common.box

Uses of RRMAItemListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type RRMAItemListResult
 java.util.Collection<RRMAItemListResult> SalesBox.findRRMAItemListResult(PartPK partPk, java.lang.String rrmaNumber, java.lang.String rrmaItemNumber, java.lang.String customerId, java.lang.String salesMan, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isRequireDate, java.util.Date fromDate, java.util.Date toDate, boolean incluedInventory, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RRMAListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RRMAListResult

Packages that use RRMAListResult
bb.common.box

Uses of RRMAListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type RRMAListResult
 java.util.Collection<RRMAListResult> SalesBox.findRRMAListResult(java.lang.String rrmaNumberLike, java.lang.String status, java.lang.String project, java.lang.String requester, java.lang.String soNumber, java.lang.String invNumber, java.lang.String customerID, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RTVApprovalVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RTVApprovalVO

Packages that use RTVApprovalVO
bb.common.box

Uses of RTVApprovalVO in bb.common.box

Methods in bb.common.box that return RTVApprovalVO
 RTVApprovalVO PurchasingBox.getRTVApproval(java.lang.String employeeID)

Methods in bb.common.box that return types with arguments of type RTVApprovalVO
 java.util.Collection<RTVApprovalVO> PurchasingBox.findAllRTVApprovals(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type RTVApprovalVO
 java.lang.String PurchasingBox.updateRTVApproval(RTVApprovalVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RtvShipperInfoVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RtvShipperInfoVO

Packages that use RtvShipperInfoVO
bb.common.box

Uses of RtvShipperInfoVO in bb.common.box

Methods in bb.common.box that return types with arguments of type RtvShipperInfoVO
 java.util.Collection<RtvShipperInfoVO> AccountingBox.findRTVShipperWithOutDebitMemo(java.lang.String vendorId, java.lang.String currency, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RtvShipperItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RtvShipperItemListResult

Packages that use RtvShipperItemListResult
bb.common
bb.common.box

Uses of RtvShipperItemListResult in bb.common

Methods in bb.common that return types with arguments of type RtvShipperItemListResult
 java.util.List<RtvShipperItemListResult> ReturnToVendorVO.getBb2ShipperItems()

Method parameters in bb.common with type arguments of type RtvShipperItemListResult
 void ReturnToVendorVO.setBb2ShipperItems(java.util.List<RtvShipperItemListResult> bb2ShipperItems)

Uses of RtvShipperItemListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type RtvShipperItemListResult
java.util.Collection<RtvShipperItemListResult> | WarehouseBox.findRtvShipperItemListResultsByDate(java.lang.String rtvShipperNumber, java.lang.String rtvNumber, java.lang.String vendorId, java.lang.String partNumber, java.lang.String partType, java.lang.String status, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<RtvShipperItemListResult> | WarehouseBox.findRtvShipperItemListResultsByPartNumber(java.lang.String partNumber, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<RtvShipperItemListResult> | WarehouseBox.findRtvShipperItemListResultsByPONumber(java.lang.String poNumber, int firstIndex, int maxLength)
java.util.Collection<RtvShipperItemListResult> | WarehouseBox.findRtvShipperItemListResultsByRTVNumber(java.lang.String rtvNumber, int firstIndex, int maxLength)
java.util.Collection<RtvShipperItemListResult> | WarehouseBox.findRtvShipperItemListResultsByRTVShipperNumber(java.lang.String rtvShipperNumber, int firstIndex, int maxLength)
java.util.Collection<RtvShipperItemListResult> | WarehouseBox.findRtvShipperItemListResultsByVendorID(java.lang.String vendorID, int firstIndex, int maxLength)
java.util.Collection<RtvShipperItemListResult> | PurchasingBox.getRtvShipperByPoNumber(java.lang.String poNumber)
java.util.Collection<RtvShipperItemListResult> | ManufacturingBox.getRtvShipperByPoNumber(java.lang.String poNumber)
java.util.Collection<RtvShipperItemListResult> | WarehouseBox.getRtvShipperItemListResultsOfRtv(java.lang.String rtvNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RtvShipperItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RtvShipperItemPK

Packages that use RtvShipperItemPK
bb.common
bb.common.box

Uses of RtvShipperItemPK in bb.common

Methods in bb.common that return RtvShipperItemPK
 RtvShipperItemPK RtvShipperItemVO.getPk()

Methods in bb.common with parameters of type RtvShipperItemPK
 void RtvShipperItemVO.setPk(RtvShipperItemPK pk)

Uses of RtvShipperItemPK in bb.common.box

Methods in bb.common.box with parameters of type RtvShipperItemPK
 RtvShipperItemVO WarehouseBox.getRtvShipperItemByPk(RtvShipperItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RtvShipperItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RtvShipperItemVO

Packages that use RtvShipperItemVO
bb.common.box

Uses of RtvShipperItemVO in bb.common.box

Methods in bb.common.box that return RtvShipperItemVO
 RtvShipperItemVO WarehouseBox.getRtvShipperItemByPk(RtvShipperItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RtvShipperListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RtvShipperListResult

Packages that use RtvShipperListResult
bb.common.box

Uses of RtvShipperListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type RtvShipperListResult
java.util.Collection<RtvShipperListResult> | WarehouseBox.findRtvShipperListResultsByPONumber(java.lang.String poNumber, int firstIndex, int maxLength)
java.util.Collection<RtvShipperListResult> | WarehouseBox.findRtvShipperListResultsByRTVNumber(java.lang.String rtvNumber, int firstIndex, int maxLength)
java.util.Collection<RtvShipperListResult> | WarehouseBox.findRtvShipperListResultsByRTVShipperNumber(java.lang.String rtvShipperNumber, int firstIndex, int maxLength)
java.util.Collection<RtvShipperListResult> | WarehouseBox.findRtvShipperListResultsByShippedBy(java.lang.String shippedby, int firstIndex, int maxLength)
java.util.Collection<RtvShipperListResult> | WarehouseBox.findRtvShipperListResultsByVendorID(java.lang.String vendorID, int firstIndex, int maxLength)
java.util.Collection<RtvShipperListResult> | WarehouseBox.findVendorNotPickRtvShippers(int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RtvShipperVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RtvShipperVO

Packages that use RtvShipperVO
bb.common.box

Uses of RtvShipperVO in bb.common.box

Methods in bb.common.box that return RtvShipperVO
 RtvShipperVO WarehouseBox.getRtvShipperById(java.lang.String rtvShipperNumber)

Methods in bb.common.box with parameters of type RtvShipperVO
void | WarehouseBox.setRtvShipperVendorPicked(RtvShipperVO vo)
java.lang.String | WarehouseBox.updateRtvShipper(RtvShipperVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RunningAccountOrderItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RunningAccountOrderItemPK

Packages that use RunningAccountOrderItemPK
bb.common
bb.common.box

Uses of RunningAccountOrderItemPK in bb.common

Methods in bb.common that return RunningAccountOrderItemPK
 RunningAccountOrderItemPK RunningAccountOrderItemVO.getPk()

Methods in bb.common with parameters of type RunningAccountOrderItemPK
 void RunningAccountOrderItemVO.setPk(RunningAccountOrderItemPK pk)

Uses of RunningAccountOrderItemPK in bb.common.box

Methods in bb.common.box with parameters of type RunningAccountOrderItemPK
 RunningAccountOrderItemVO CompanyBox.getRunningAccountOrderItem(RunningAccountOrderItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RunningAccountOrderItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RunningAccountOrderItemResult

Packages that use RunningAccountOrderItemResult
bb.common.box

Uses of RunningAccountOrderItemResult in bb.common.box

Methods in bb.common.box that return types with arguments of type RunningAccountOrderItemResult
java.util.Collection<RunningAccountOrderItemResult> | CompanyBox.findReceiptItemsByNegativeOnhand(java.lang.String raoNumber, java.lang.String[] includeVendorId, java.lang.String[] excludeVendorId, java.lang.String payableMethod, java.util.Date fromDate, java.util.Date toDate, java.lang.String orderType, boolean isMakeOrder, java.lang.String partNumber, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<RunningAccountOrderItemResult> | CompanyBox.findRunningAccountOrderItems(java.lang.String raoNumber, java.lang.String[] includeVendorId, java.lang.String[] excludeVendorId, java.lang.String payableMethod, java.util.Date fromDate, java.util.Date toDate, java.lang.String orderType, boolean isMakeOrder, java.lang.String partNumber, java.lang.String partType, java.lang.String description, java.lang.String modelNumber, java.lang.String commodityCode, java.lang.String productCode, boolean showNegative, int firstIndex, int maxLength)

Method parameters in bb.common.box with type arguments of type RunningAccountOrderItemResult
void | CompanyBox.AdjustInventoryByPos(java.util.Collection<RunningAccountOrderItemResult> result)
java.util.List<java.lang.String> | CompanyBox.makeReturnMaterialAuthorization(java.util.ArrayList<RunningAccountOrderItemResult> result)
java.util.List<java.lang.String> | CompanyBox.makeSalesOrder(java.util.ArrayList<RunningAccountOrderItemResult> result)
java.lang.String | CompanyBox.makeSalesOrder(java.util.ArrayList<RunningAccountOrderItemResult> result, boolean onlyInvoice)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RunningAccountOrderItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RunningAccountOrderItemVO

Packages that use RunningAccountOrderItemVO
bb.common
bb.common.box

Uses of RunningAccountOrderItemVO in bb.common

Subclasses of RunningAccountOrderItemVO in bb.common
 class RunningAccountOrderItemResult

Uses of RunningAccountOrderItemVO in bb.common.box

Methods in bb.common.box that return RunningAccountOrderItemVO
RunningAccountOrderItemVO | CompanyBox.getRunningAccountOrderItem(RunningAccountOrderItemPK pk)
RunningAccountOrderItemVO | CompanyBox.getRunningAccountOrderItemByPartPK(PartPK pk)
RunningAccountOrderItemVO | CompanyBox.getRunningAccountOrderItemByPartPK(PartPK pk, java.lang.String customerId, java.lang.String mfgPartNumber)
RunningAccountOrderItemVO | CompanyBox.getRunningAccountOrderItemByRaoNumberandPartPK(java.lang.String raoNumber, PartPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RunningAccountOrderVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RunningAccountOrderVO

Packages that use RunningAccountOrderVO
bb.common.box

Uses of RunningAccountOrderVO in bb.common.box

Methods in bb.common.box that return RunningAccountOrderVO
RunningAccountOrderVO | CompanyBox.addReturnOrder(RunningAccountOrderVO vo, java.lang.String raoNumber)
RunningAccountOrderVO[] | CompanyBox.addRunningAccountOrder(RunningAccountOrderVO vo)
RunningAccountOrderVO | CompanyBox.getCaneRunningAccountOrder(java.lang.String raoNumber)
RunningAccountOrderVO | CompanyBox.getRunningAccountOrderById(java.lang.String raoNumber)

Methods in bb.common.box that return types with arguments of type RunningAccountOrderVO
 java.util.Collection<RunningAccountOrderVO> CompanyBox.findReceiptOrders(java.lang.String raoNumber, java.lang.String[] includeVendorId, java.lang.String[] excludeVendorId, java.lang.String payableMethod, java.util.Date fromDate, java.util.Date toDate, java.lang.String orderType, boolean isMakeOrder, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type RunningAccountOrderVO
RunningAccountOrderVO | CompanyBox.addReturnOrder(RunningAccountOrderVO vo, java.lang.String raoNumber)
RunningAccountOrderVO[] | CompanyBox.addRunningAccountOrder(RunningAccountOrderVO vo)
java.lang.String[] | CompanyBox.makeAllActionForReceiptFromAdding(RunningAccountOrderVO raVO)
java.lang.String | CompanyBox.makeAllActionForReturnFromAdding(RunningAccountOrderVO raVO, java.lang.String originalReceiptNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.RunTaxPaymentResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.RunTaxPaymentResult

No usage of bb.common.RunTaxPaymentResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesBomItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesBomItemResult

No usage of bb.common.SalesBomItemResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesBomResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesBomResult

Packages that use SalesBomResult
bb.common.box

Uses of SalesBomResult in bb.common.box

Methods in bb.common.box that return SalesBomResult
 SalesBomResult SalesBox.getSalesBomResult(BillPK billPk, java.lang.String partFrom)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesCodeVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesCodeVO

Packages that use SalesCodeVO
bb.common
bb.common.box

Uses of SalesCodeVO in bb.common

Subclasses of SalesCodeVO in bb.common
 class ArSalesCodeTotalListResult

Uses of SalesCodeVO in bb.common.box

Methods in bb.common.box that return SalesCodeVO
SalesCodeVO | SalesBox.addSalesCodeByAddressId(java.lang.String salesCodeId, java.lang.String addressId)
SalesCodeVO | SalesBox.addSalesCodeByEmployeeId(java.lang.String salesCodeId, java.lang.String employeeId)
SalesCodeVO | SalesBox.getSalesCodeByPk(java.lang.String salesCodeId)
SalesCodeVO | SalesBox.updateSalesCode(SalesCodeVO vo)

Methods in bb.common.box that return types with arguments of type SalesCodeVO
java.util.Collection<SalesCodeVO> | SalesBox.findAllSalesCode(int firstIndex, int maxLength)
java.util.Collection<SalesCodeVO> | SalesBox.findSalesCodeById(java.lang.String salesCodeId, java.lang.String salesCodeName, java.lang.String addressId, java.lang.String employeeId, java.math.BigDecimal commissionRate, int firstIndex, int maxLength)
java.util.Collection<SalesCodeVO> | SalesBox.getSalesCodeByAddressId(java.lang.String addressId)

Methods in bb.common.box with parameters of type SalesCodeVO
 SalesCodeVO SalesBox.updateSalesCode(SalesCodeVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesInfoCenter

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesInfoCenter

No usage of bb.common.SalesInfoCenter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesInfoCenter.DueSoCount

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesInfoCenter.DueSoCount

Packages that use SalesInfoCenter.DueSoCount
bb.common

Uses of SalesInfoCenter.DueSoCount in bb.common

Methods in bb.common that return SalesInfoCenter.DueSoCount
 SalesInfoCenter.DueSoCount SalesInfoCenter.getDueSoCount()

Methods in bb.common with parameters of type SalesInfoCenter.DueSoCount
 void SalesInfoCenter.setDueSoCount(SalesInfoCenter.DueSoCount dueSoCount)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesInfoCenter.DueSoSum

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesInfoCenter.DueSoSum

Packages that use SalesInfoCenter.DueSoSum
bb.common

Uses of SalesInfoCenter.DueSoSum in bb.common

Methods in bb.common that return SalesInfoCenter.DueSoSum
 SalesInfoCenter.DueSoSum SalesInfoCenter.getDueSoSum()

Methods in bb.common with parameters of type SalesInfoCenter.DueSoSum
 void SalesInfoCenter.setDueSoSum(SalesInfoCenter.DueSoSum dueSoSum)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesInfoCenter.GrossMargin

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesInfoCenter.GrossMargin

Packages that use SalesInfoCenter.GrossMargin
bb.common

Uses of SalesInfoCenter.GrossMargin in bb.common

Methods in bb.common that return SalesInfoCenter.GrossMargin
 SalesInfoCenter.GrossMargin SalesInfoCenter.getGrossMargin()

Methods in bb.common with parameters of type SalesInfoCenter.GrossMargin
 void SalesInfoCenter.setGrossMargin(SalesInfoCenter.GrossMargin grossMargin)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesInfoCenter.InvoicedSum

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesInfoCenter.InvoicedSum

Packages that use SalesInfoCenter.InvoicedSum
bb.common

Uses of SalesInfoCenter.InvoicedSum in bb.common

Methods in bb.common that return SalesInfoCenter.InvoicedSum
 SalesInfoCenter.InvoicedSum SalesInfoCenter.getInvoicedSum()

Methods in bb.common with parameters of type SalesInfoCenter.InvoicedSum
 void SalesInfoCenter.setInvoicedSum(SalesInfoCenter.InvoicedSum invoicedSum)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesInfoCenter.OpenSoSum

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesInfoCenter.OpenSoSum

Packages that use SalesInfoCenter.OpenSoSum
bb.common

Uses of SalesInfoCenter.OpenSoSum in bb.common

Methods in bb.common that return SalesInfoCenter.OpenSoSum
 SalesInfoCenter.OpenSoSum SalesInfoCenter.getOpenSoSum()

Methods in bb.common with parameters of type SalesInfoCenter.OpenSoSum
 void SalesInfoCenter.setOpenSoSum(SalesInfoCenter.OpenSoSum openSoSum)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesInfoCenter.SoCount

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesInfoCenter.SoCount

Packages that use SalesInfoCenter.SoCount
bb.common

Uses of SalesInfoCenter.SoCount in bb.common

Methods in bb.common that return SalesInfoCenter.SoCount
 SalesInfoCenter.SoCount SalesInfoCenter.getSoCount()

Methods in bb.common with parameters of type SalesInfoCenter.SoCount
 void SalesInfoCenter.setSoCount(SalesInfoCenter.SoCount soCount)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesInfoCenter.SoCountWithPartsOnhold

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesInfoCenter.SoCountWithPartsOnhold

Packages that use SalesInfoCenter.SoCountWithPartsOnhold
bb.common

Uses of SalesInfoCenter.SoCountWithPartsOnhold in bb.common

Methods in bb.common that return SalesInfoCenter.SoCountWithPartsOnhold
 SalesInfoCenter.SoCountWithPartsOnhold SalesInfoCenter.getSoCountWithPartsOnhold()

Methods in bb.common with parameters of type SalesInfoCenter.SoCountWithPartsOnhold
 void SalesInfoCenter.setSoCountWithPartsOnhold(SalesInfoCenter.SoCountWithPartsOnhold soCountWithPartsOnhold)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesInfoCenter.SoItemCount

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesInfoCenter.SoItemCount

Packages that use SalesInfoCenter.SoItemCount
bb.common

Uses of SalesInfoCenter.SoItemCount in bb.common

Methods in bb.common that return SalesInfoCenter.SoItemCount
 SalesInfoCenter.SoItemCount SalesInfoCenter.getSoItemCount()

Methods in bb.common with parameters of type SalesInfoCenter.SoItemCount
 void SalesInfoCenter.setSoItemCount(SalesInfoCenter.SoItemCount soItemCount)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesInfoCenter.SoTotalSum

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesInfoCenter.SoTotalSum

Packages that use SalesInfoCenter.SoTotalSum
bb.common

Uses of SalesInfoCenter.SoTotalSum in bb.common

Methods in bb.common that return SalesInfoCenter.SoTotalSum
 SalesInfoCenter.SoTotalSum SalesInfoCenter.getSoTotalSum()

Methods in bb.common with parameters of type SalesInfoCenter.SoTotalSum
 void SalesInfoCenter.setSoTotalSum(SalesInfoCenter.SoTotalSum soTotalSum)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesInfoCenterResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesInfoCenterResult

Packages that use SalesInfoCenterResult
bb.common.box

Uses of SalesInfoCenterResult in bb.common.box

Methods in bb.common.box that return SalesInfoCenterResult
 SalesInfoCenterResult ManagementBox.getSalesInfoCenterResult()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesmanVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesmanVO

Packages that use SalesmanVO
bb.common.box

Uses of SalesmanVO in bb.common.box

Methods in bb.common.box that return SalesmanVO
SalesmanVO | SalesBox.addSalesman(SalesmanVO vo)
SalesmanVO | SalesBox.addSalesman(java.lang.String lastName)
SalesmanVO | SalesBox.getSalesmanByPk(int id)
SalesmanVO | SalesBox.updateSalesman(SalesmanVO vo)

Methods in bb.common.box that return types with arguments of type SalesmanVO
java.util.Collection<SalesmanVO> | SalesBox.findAllSalesmen(int firstIndex, int maxLength)
java.util.Collection<SalesmanVO> | SalesBox.findSalesmanById(java.lang.String idRegex, int firstIndex, int maxLength)
java.util.Collection<SalesmanVO> | SalesBox.findSalesmanByLastName(java.lang.String lastNameLike, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type SalesmanVO
SalesmanVO | SalesBox.addSalesman(SalesmanVO vo)
void | SalesBox.deleteSalesman(SalesmanVO vo)
SalesmanVO | SalesBox.updateSalesman(SalesmanVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesMarginListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesMarginListResult

Packages that use SalesMarginListResult
bb.common.box

Uses of SalesMarginListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type SalesMarginListResult
java.util.Collection<SalesMarginListResult> | AccountingBox.findGrossMarginByID(java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<SalesMarginListResult> | AccountingBox.findGrossMarginTotalByID(java.util.Date fromDate, java.util.Date toDate)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesOnTimeResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesOnTimeResult

Packages that use SalesOnTimeResult
bb.common.box

Uses of SalesOnTimeResult in bb.common.box

Methods in bb.common.box that return SalesOnTimeResult
 SalesOnTimeResult ManagementBox.getSalesOnTimeResult(OnTimeAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesOrder12MonthMarginResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesOrder12MonthMarginResult

Packages that use SalesOrder12MonthMarginResult
bb.common.box

Uses of SalesOrder12MonthMarginResult in bb.common.box

Methods in bb.common.box that return types with arguments of type SalesOrder12MonthMarginResult
 java.util.Collection<SalesOrder12MonthMarginResult> ManagementBox.findSalesOrder12MonthMarginResults(int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesOrderBoilerplateVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesOrderBoilerplateVO

Packages that use SalesOrderBoilerplateVO
bb.common.box

Uses of SalesOrderBoilerplateVO in bb.common.box

Methods in bb.common.box that return SalesOrderBoilerplateVO
SalesOrderBoilerplateVO | SalesBox.addSalesOrderBP(SalesOrderBoilerplateVO vo)
SalesOrderBoilerplateVO | SalesBox.getSalesOrderBPByPk(java.lang.String salesOrderBoilerplateId)
SalesOrderBoilerplateVO | SalesBox.updateSalesOrderBP(SalesOrderBoilerplateVO vo)

Methods in bb.common.box that return types with arguments of type SalesOrderBoilerplateVO
java.util.Collection<SalesOrderBoilerplateVO> | SalesBox.findAllSalesOrderBP(int firstIndex, int maxLength)
java.util.Collection<SalesOrderBoilerplateVO> | SalesBox.findSalesOrderBPByBPId(java.lang.String boilerplateId, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type SalesOrderBoilerplateVO
SalesOrderBoilerplateVO | SalesBox.addSalesOrderBP(SalesOrderBoilerplateVO vo)
SalesOrderBoilerplateVO | SalesBox.updateSalesOrderBP(SalesOrderBoilerplateVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesOrderCheckListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesOrderCheckListResult

Packages that use SalesOrderCheckListResult
bb.common.box

Uses of SalesOrderCheckListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type SalesOrderCheckListResult
 java.util.Collection<SalesOrderCheckListResult> SalesBox.findCheckList(int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesOrderDocumentVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesOrderDocumentVO

Packages that use SalesOrderDocumentVO
bb.common.box

Uses of SalesOrderDocumentVO in bb.common.box

Methods in bb.common.box that return SalesOrderDocumentVO
 SalesOrderDocumentVO SalesBox.getSaleOrderDocumentByID(java.lang.Long controlNumber)

Methods in bb.common.box that return types with arguments of type SalesOrderDocumentVO
java.util.Collection<SalesOrderDocumentVO> | SalesBox.deleteFTPSODoc(MiscDocAgent agent)
java.util.Collection<SalesOrderDocumentVO> | SalesBox.uploadOrUpdateFTPSODoc(MiscDocAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesOrderItemCostResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesOrderItemCostResult

Packages that use SalesOrderItemCostResult
bb.common.box

Uses of SalesOrderItemCostResult in bb.common.box

Methods in bb.common.box that return SalesOrderItemCostResult
 SalesOrderItemCostResult SalesBox.getSalesOrderItemCostResult(java.lang.String status)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesOrderItemCustomerTotalResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesOrderItemCustomerTotalResult

Packages that use SalesOrderItemCustomerTotalResult
bb.common.box

Uses of SalesOrderItemCustomerTotalResult in bb.common.box

Methods in bb.common.box that return types with arguments of type SalesOrderItemCustomerTotalResult
java.util.Collection<SalesOrderItemCustomerTotalResult> | SalesBox.findDueSalesOrderItemCustomerTotalResultsByCustomerId(java.lang.String customerIdLike, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemCustomerTotalResult> | SalesBox.findOpenSalesOrderItemCustomerTotalResultsByCustomerId(java.lang.String customerIdLike, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesOrderItemGroupByPartListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesOrderItemGroupByPartListResult

Packages that use SalesOrderItemGroupByPartListResult
bb.common.box

Uses of SalesOrderItemGroupByPartListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type SalesOrderItemGroupByPartListResult
java.util.Collection<SalesOrderItemGroupByPartListResult> | SalesBox.findSalesOrderItemGroupByPart(java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemGroupByPartListResult> | SalesBox.findSalesOrderItemGroupByPart(java.lang.String partNumber, java.lang.String partType, java.lang.String status, java.lang.String dateTpey, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesOrderItemInfoVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesOrderItemInfoVO

No usage of bb.common.SalesOrderItemInfoVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesOrderItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesOrderItemListResult

Packages that use SalesOrderItemListResult
bb.common
bb.common.box

Uses of SalesOrderItemListResult in bb.common

Methods in bb.common that return types with arguments of type SalesOrderItemListResult
 java.util.List<SalesOrderItemListResult> PartsToDeleteResult.getPartsToDeleteInSO()

Method parameters in bb.common with type arguments of type SalesOrderItemListResult
 void PartsToDeleteResult.setPartsToDeleteInSO(java.util.List<SalesOrderItemListResult> partsToDeleteInSO)

Uses of SalesOrderItemListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type SalesOrderItemListResult
java.util.Collection<SalesOrderItemListResult> | SalesBox.findAllDueSoItems(int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | SalesBox.findAllOpenSoItems(boolean orderByDeliveryDateAsc, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | SalesBox.findAllOpenSoItemsByAddressId(java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | SalesBox.findAllOpenSoItemsByAddressIdandShipVia(java.lang.String addressId, java.lang.String shipVia, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | SalesBox.findAllPastDueSoItemsByAddressId(java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | SalesBox.findAllSoItemsByAddressId(java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | SalesBox.findAllSOItemsCanShip(java.lang.String partFrom, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | SalesBox.findDueShortageSalesOrderItems(java.lang.String partNumberLike, java.lang.String partType, java.lang.String salesOrderNumber, java.lang.String customerID, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | SalesBox.findDueSoItemsByDateType(java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | SalesBox.findOpenSaleOrderItemByPartPk(PartPK partPk, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | SalesBox.findOpenShipViaSalesOrderItems(java.lang.String partNumberLike, java.lang.String partType, java.lang.String salesOrderNumber, java.lang.String customerID, java.lang.String shipVia, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | SalesBox.findOpenShortageSalesOrderItems(java.lang.String partNumberLike, java.lang.String partType, java.lang.String salesOrderNumber, java.lang.String customerID, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | EngineeringBox.findPartsToDeleteInSo(int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | SalesBox.findSalesOrderItemByPartPk(PartPK pk, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | SalesBox.findSalesOrderItemsByCustomerId(java.lang.String customerId, java.util.Date from, java.util.Date to, java.lang.String dateType, java.lang.String salesman, java.lang.String partNumber, java.lang.String partType, java.lang.String incoterm, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | SalesBox.findSalesOrderItemsByDate(java.lang.String partNumberLike, java.lang.String partType, java.lang.String customerId, java.lang.String includeCustomerIds, java.lang.String excludeCustomerIds, java.lang.String salesMan, java.lang.String status, java.lang.String productCode, java.lang.String commodityCode, java.lang.String projectName, java.lang.String dateColumn, java.util.Date fromDate, java.util.Date toDate, java.lang.String currency, java.lang.String salesCodeId, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isHold, java.lang.String state, java.lang.String incotermPort, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | SalesBox.findSalesOrderItemsByDates(java.lang.String partNumberLike, java.lang.String partType, java.lang.String customerId, java.lang.String includeCustomerIds, java.lang.String excludeCustomerIds, java.lang.String salesMan, java.lang.String status, java.lang.String productCode, java.lang.String projectName, java.lang.String relatedDoc, java.lang.String dateColumn, java.util.Date fromDate, java.util.Date toDate, java.lang.String currency, java.lang.String salesCodeID, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isHold, java.lang.String state, java.lang.String incoterm, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | SalesBox.findSalesOrderItemsByDates(java.lang.String partNumberLike, java.lang.String partType, java.lang.String customerId, java.lang.String includeCustomerIds, java.lang.String excludeCustomerIds, java.lang.String salesMan, java.lang.String status, java.lang.String productCode, java.lang.String projectName, java.lang.String relatedDoc, java.lang.String dateColumn, java.util.Date fromDate, java.util.Date toDate, java.lang.String currency, java.lang.String salesCodeID, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String state, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | SalesBox.findSalesOrderItemsBySalesman(java.lang.String salesmanLike, int firstIndex, int maxLength)
java.util.Collection<SalesOrderItemListResult> | SalesBox.findSalesOrderItemsCost(java.lang.String status, int firstIndex, int maxLenggh)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesOrderItemManufacturerPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesOrderItemManufacturerPK

Packages that use SalesOrderItemManufacturerPK
bb.common

Uses of SalesOrderItemManufacturerPK in bb.common

Methods in bb.common that return SalesOrderItemManufacturerPK
 SalesOrderItemManufacturerPK SalesOrderItemManufacturerVO.getPk()

Methods in bb.common with parameters of type SalesOrderItemManufacturerPK
 void SalesOrderItemManufacturerVO.setPk(SalesOrderItemManufacturerPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesOrderItemManufacturerVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesOrderItemManufacturerVO

No usage of bb.common.SalesOrderItemManufacturerVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesOrderItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesOrderItemPK

Packages that use SalesOrderItemPK
bb.common
bb.common.box

Uses of SalesOrderItemPK in bb.common

Methods in bb.common that return SalesOrderItemPK
SalesOrderItemPK | ShipListItemRelatedDocResult.getPk()
SalesOrderItemPK | SalesOrderShipDateListResult.getPk()
SalesOrderItemPK | SalesOrderItemVO.getPk()
SalesOrderItemPK | SalesOrderItemInfoVO.getPk()
SalesOrderItemPK | BB2PartInSipOfSoItemResult.getPk()
SalesOrderItemPK | SalesOrderOnDemandResult.getSalesOrderItemPk()
SalesOrderItemPK | PackingBoxSalesOrderItemAgent.getSoItemPk()

Methods in bb.common that return types with arguments of type SalesOrderItemPK
java.util.ArrayList<SalesOrderItemPK> | MakeInvoiceAgent.getSalesItemPks()
java.util.ArrayList<SalesOrderItemPK> | MakeBillAndHoldInvoiceAgent.getSalesItemPks()

Methods in bb.common with parameters of type SalesOrderItemPK
void | ShipListItemRelatedDocResult.setPk(SalesOrderItemPK pk)
void | SalesOrderShipDateListResult.setPk(SalesOrderItemPK pk)
void | SalesOrderItemVO.setPk(SalesOrderItemPK pk)
void | SalesOrderItemInfoVO.setPk(SalesOrderItemPK pk)
void | BB2PartInSipOfSoItemResult.setPk(SalesOrderItemPK pk)
void | SalesOrderOnDemandResult.setSalesOrderItemPk(SalesOrderItemPK salesOrderItemPk)
void | PackingBoxSalesOrderItemAgent.setSoItemPk(SalesOrderItemPK soItemPk)

Method parameters in bb.common with type arguments of type SalesOrderItemPK
void | MakeInvoiceAgent.setSalesItemPks(java.util.ArrayList<SalesOrderItemPK> salesItemPks)
void | MakeBillAndHoldInvoiceAgent.setSalesItemPks(java.util.ArrayList<SalesOrderItemPK> salesItemPks)

Uses of SalesOrderItemPK in bb.common.box

Methods in bb.common.box with parameters of type SalesOrderItemPK
RefdocVO | SalesBox.addRefdocOne(SalesOrderItemPK soItemPk, java.lang.String forderNumber, java.lang.String fItemNumber, java.math.BigDecimal refdocQty)
java.util.Collection<MfrMpnListResult> | WarehouseBox.getMfrMpnListResultsFor(SalesOrderItemPK itemPk)
SalesOrderItemVO | SalesBox.getSalesOrderItemByPk(SalesOrderItemPK pk)
ShipListItemRelatedDocResult | PlanningBox.getShipListItemRelatedDocResult(SalesOrderItemPK pk)
ShippingItemResult | WarehouseBox.getShippingItemResult(SalesOrderItemPK pk)
PackingBoxItemVO | WarehouseBox.initPackingBoxItemVO(PackingBoxPK boxPk, SalesOrderItemPK itemPk, java.math.BigDecimal qty)
ShipListItemVOResult | PlanningBox.initShipListItem(java.lang.String shipListNumber, SalesOrderItemPK itemPk)
boolean | SalesBox.isSalesOrderAndSoItemOpen(SalesOrderItemPK pk)
boolean | SalesBox.isSalesOrderItemExist(SalesOrderItemPK pk)
void | SalesBox.setSalesOrderItemReferenceDocOne(SalesOrderItemPK pk, java.lang.String referenceDoc)
void | SalesBox.setSalesOrderItemReferenceDocTwo(SalesOrderItemPK pk, java.lang.String referenceDoc)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesOrderItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesOrderItemVO

Packages that use SalesOrderItemVO
bb.common
bb.common.box

Uses of SalesOrderItemVO in bb.common

Methods in bb.common that return types with arguments of type SalesOrderItemVO
 java.util.Set<SalesOrderItemVO> SalesOrderVO.getSalesOrderItems()

Method parameters in bb.common with type arguments of type SalesOrderItemVO
 void SalesOrderVO.setSalesOrderItems(java.util.Set<SalesOrderItemVO> salesOrderItem)

Uses of SalesOrderItemVO in bb.common.box

Methods in bb.common.box that return SalesOrderItemVO
SalesOrderItemVO | SalesBox.getSalesOrderItemByPk(SalesOrderItemPK pk)
SalesOrderItemVO | SalesBox.initSalesOrderItem(SalesOrderVO soVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool)
SalesOrderItemVO | SalesBox.initSalesOrderItem(SalesOrderVO soVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool, boolean isPOS)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesOrderListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesOrderListResult

Packages that use SalesOrderListResult
bb.common.box

Uses of SalesOrderListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type SalesOrderListResult
java.util.Collection<SalesOrderListResult> | SalesBox.findAllSalesOrders(int firstIndex, int maxLength)
java.util.Collection<SalesOrderListResult> | SalesBox.findAllSalesOrdersByAddressId(java.lang.String customerIdExp, int firstIndex, int maxLength)
java.util.Collection<SalesOrderListResult> | SalesBox.findDueSalesOrdersByAddressId(java.lang.String customerIdExp, int firstIndex, int maxLength)
java.util.Collection<SalesOrderListResult> | SalesBox.findMySoPrintList()
java.util.Collection<SalesOrderListResult> | SalesBox.findOpenNotReviewedSalesOrders(java.lang.String soNumberLike, int firstIndex, int maxLength)
java.util.Collection<SalesOrderListResult> | SalesBox.findOpenSalesOrdersByAddressId(java.lang.String customerIdExp, int firstIndex, int maxLength)
java.util.Collection<SalesOrderListResult> | SalesBox.findOpenSalesOrdersForShippingBySoNumber(java.lang.String soIdExp, int firstIndex, int maxLength)
java.util.Collection<SalesOrderListResult> | SalesBox.findOpenSalesOrderWithPrepay(java.lang.String startWith, int firstIndex, int maxLength)
java.util.Collection<SalesOrderListResult> | PlanningBox.findSalesOrderListResultsforShipList(java.lang.String soNumberLike, java.lang.String[] customers, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)
java.util.Collection<SalesOrderListResult> | SalesBox.findSalesOrdersByPoNumber(java.lang.String poNumberExp, int firstIndex, int maxLength)
java.util.Collection<SalesOrderListResult> | SalesBox.findSalesOrdersBySalesman(java.lang.String salesmanExp, int firstIndex, int maxLength)
java.util.Collection<SalesOrderListResult> | SalesBox.findSalesOrdersBySoNumber(java.lang.String soNumberExp, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesOrderOnDemandResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesOrderOnDemandResult

Packages that use SalesOrderOnDemandResult
bb.common

Uses of SalesOrderOnDemandResult in bb.common

Subclasses of SalesOrderOnDemandResult in bb.common
 class SalesOrderOrphanedResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesOrderOnTimeItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesOrderOnTimeItemResult

Packages that use SalesOrderOnTimeItemResult
bb.common

Uses of SalesOrderOnTimeItemResult in bb.common

Methods in bb.common that return types with arguments of type SalesOrderOnTimeItemResult
 java.util.List<SalesOrderOnTimeItemResult> SalesOnTimeResult.getItems()

Method parameters in bb.common with type arguments of type SalesOrderOnTimeItemResult
 void SalesOnTimeResult.setItems(java.util.List<SalesOrderOnTimeItemResult> items)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesOrderOnTimeResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesOrderOnTimeResult

Packages that use SalesOrderOnTimeResult
bb.common.box

Uses of SalesOrderOnTimeResult in bb.common.box

Methods in bb.common.box that return SalesOrderOnTimeResult
 SalesOrderOnTimeResult ManagementBox.getSalesOrderOnTimeResult()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesOrderOrphanedResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesOrderOrphanedResult

No usage of bb.common.SalesOrderOrphanedResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesOrderReviewVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesOrderReviewVO

Packages that use SalesOrderReviewVO
bb.common.box

Uses of SalesOrderReviewVO in bb.common.box

Methods in bb.common.box that return SalesOrderReviewVO
SalesOrderReviewVO | SalesBox.addSalesOrderControl(java.lang.String employeeId)
SalesOrderReviewVO | SalesBox.getSalesOrderControlByEmoloyeeTrueName(java.lang.String emoloyeeTrueName)
SalesOrderReviewVO | SalesBox.getSalesOrderControlByEmployeeId(java.lang.String employeeId)
SalesOrderReviewVO | SalesBox.updateSalesOrderControl(SalesOrderReviewVO vo)

Methods in bb.common.box that return types with arguments of type SalesOrderReviewVO
java.util.Collection<SalesOrderReviewVO> | SalesBox.findAllSalesOrderControl(int firstIndex, int maxLength)
java.util.Collection<SalesOrderReviewVO> | SalesBox.findSalesOrderControlByUserTrueNameLike(java.lang.String userTrueNameLike, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type SalesOrderReviewVO
 SalesOrderReviewVO SalesBox.updateSalesOrderControl(SalesOrderReviewVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesOrderShipDateListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesOrderShipDateListResult

Packages that use SalesOrderShipDateListResult
bb.common.box

Uses of SalesOrderShipDateListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type SalesOrderShipDateListResult
 java.util.Collection<SalesOrderShipDateListResult> WarehouseBox.findSalesOrderShipDateListResultsByDate(java.lang.String soNumber, java.lang.String custID, java.lang.String partNumber, java.util.Date fDate, java.util.Date tDate, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesOrderVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesOrderVO

Packages that use SalesOrderVO
bb.common.box

Uses of SalesOrderVO in bb.common.box

Methods in bb.common.box that return SalesOrderVO
SalesOrderVO | SalesBox.addSalesOrder(SalesOrderVO vo)
SalesOrderVO | SalesBox.createSalesOrderByExchange(PO2SOExchange exchange)
SalesOrderVO | SalesBox.getSalesOrderById(java.lang.String soNumber)
SalesOrderVO | SalesBox.getSalesOrderByIdForPrintSOLabel(java.lang.String soNumber)
SalesOrderVO | SalesBox.getSalesOrderWithOrderApplyByWo(java.lang.Long orderApplyID)
SalesOrderVO | SalesBox.reviewSalesOrder(SalesOrderVO soVo)

Methods in bb.common.box that return types with arguments of type SalesOrderVO
 java.util.Collection<SalesOrderVO> SalesBox.findSalesOrderItemsWithoutInvoice(java.lang.String customerId, java.lang.String currency, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type SalesOrderVO
SalesOrderVO | SalesBox.addSalesOrder(SalesOrderVO vo)
SalesOrderItemVO | SalesBox.initSalesOrderItem(SalesOrderVO soVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool)
SalesOrderItemVO | SalesBox.initSalesOrderItem(SalesOrderVO soVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool, boolean isPOS)
SalesOrderVO | SalesBox.reviewSalesOrder(SalesOrderVO soVo)
java.lang.String | SalesBox.updateSalesOrder(SalesOrderVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesPartListItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesPartListItemResult

No usage of bb.common.SalesPartListItemResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesPartListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesPartListResult

Packages that use SalesPartListResult
bb.common.box

Uses of SalesPartListResult in bb.common.box

Methods in bb.common.box that return SalesPartListResult
 SalesPartListResult SalesBox.getSalesPartListResult(BillPK billPk, java.lang.String partFrom)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SalesTaxListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SalesTaxListResult

Packages that use SalesTaxListResult
bb.common.box

Uses of SalesTaxListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type SalesTaxListResult
 java.util.Collection<SalesTaxListResult> AccountingBox.findSalesTaxByDate(java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String orderBy, java.lang.String reportType, boolean isCM, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ScrapAssetAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ScrapAssetAgent

Packages that use ScrapAssetAgent
bb.common.box

Uses of ScrapAssetAgent in bb.common.box

Methods in bb.common.box with parameters of type ScrapAssetAgent
 java.lang.String AccountingBox.scrapAsset(AssetVO vo, ScrapAssetAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ScrapReportVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ScrapReportVO

No usage of bb.common.ScrapReportVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SerialNumberItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SerialNumberItemPK

Packages that use SerialNumberItemPK
bb.common

Uses of SerialNumberItemPK in bb.common

Methods in bb.common that return SerialNumberItemPK
 SerialNumberItemPK SerialNumberItemVO.getPk()

Methods in bb.common with parameters of type SerialNumberItemPK
 void SerialNumberItemVO.setPk(SerialNumberItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SerialNumberItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SerialNumberItemResult

No usage of bb.common.SerialNumberItemResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SerialNumberItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SerialNumberItemVO

No usage of bb.common.SerialNumberItemVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SerialNumberPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SerialNumberPK

Packages that use SerialNumberPK
bb.common
bb.common.box

Uses of SerialNumberPK in bb.common

Methods in bb.common that return SerialNumberPK
 SerialNumberPK SerialNumberVO.getPk()

Methods in bb.common with parameters of type SerialNumberPK
 void SerialNumberVO.setPk(SerialNumberPK pk)

Uses of SerialNumberPK in bb.common.box

Methods in bb.common.box that return SerialNumberPK
SerialNumberPK | QualityBox.addSerialNumber(PartCertificateVO partCertificateVo)
SerialNumberPK | QualityBox.addSerialNumber(PartCertificateVO partCertificateVo, java.lang.String originalCertificateNumber)

Methods in bb.common.box with parameters of type SerialNumberPK
SerialNumberVO | QualityBox.findSerialNumberByPk(SerialNumberPK pk)
SerialNumberResult | QualityBox.getSerialNumberResult(SerialNumberPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SerialNumberResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SerialNumberResult

Packages that use SerialNumberResult
bb.common.box

Uses of SerialNumberResult in bb.common.box

Methods in bb.common.box that return SerialNumberResult
 SerialNumberResult QualityBox.getSerialNumberResult(SerialNumberPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SerialNumberVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SerialNumberVO

Packages that use SerialNumberVO
bb.common.box

Uses of SerialNumberVO in bb.common.box

Methods in bb.common.box that return SerialNumberVO
SerialNumberVO | QualityBox.findSerialNumberByPk(SerialNumberPK pk)
SerialNumberVO | QualityBox.updateSerialNumber(SerialNumberVO vo)

Methods in bb.common.box that return types with arguments of type SerialNumberVO
 java.util.Collection<SerialNumberVO> QualityBox.findAllSerialNumbers(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type SerialNumberVO
 SerialNumberVO QualityBox.updateSerialNumber(SerialNumberVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ServerAction

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ServerAction

Packages that use ServerAction
bb.common

Uses of ServerAction in bb.common

Methods in bb.common with parameters of type ServerAction
java.lang.Object | Spiderman.invoke(ServerAction action)
java.lang.Object | Facade.invoke(ServerAction action)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ServerClientPropertyPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ServerClientPropertyPK

Packages that use ServerClientPropertyPK
bb.common

Uses of ServerClientPropertyPK in bb.common

Methods in bb.common that return ServerClientPropertyPK
 ServerClientPropertyPK ServerClientPropertyVO.getPk()

Methods in bb.common with parameters of type ServerClientPropertyPK
 void ServerClientPropertyVO.setPk(ServerClientPropertyPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ServerClientPropertyVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ServerClientPropertyVO

Packages that use ServerClientPropertyVO
bb.common.box

Uses of ServerClientPropertyVO in bb.common.box

Methods in bb.common.box that return ServerClientPropertyVO
 ServerClientPropertyVO CompanyBox.getMyServerClientProperty(java.lang.String id)

Methods in bb.common.box that return types with arguments of type ServerClientPropertyVO
 java.util.Collection<ServerClientPropertyVO> CompanyBox.getServerClientProperties(java.lang.String id)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ServerException

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ServerException

No usage of bb.common.ServerException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGBillItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGBillItemPK

Packages that use SGBillItemPK
bb.common

Uses of SGBillItemPK in bb.common

Methods in bb.common that return SGBillItemPK
 SGBillItemPK SGBillItemVO.getPk()

Methods in bb.common with parameters of type SGBillItemPK
 void SGBillItemVO.setPk(SGBillItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGBillItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGBillItemVO

No usage of bb.common.SGBillItemVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGBOMItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGBOMItemResult

Packages that use SGBOMItemResult
bb.common

Uses of SGBOMItemResult in bb.common

Methods in bb.common that return SGBOMItemResult
 SGBOMItemResult SGBOMResult.getBom()

Methods in bb.common that return types with arguments of type SGBOMItemResult
 java.util.List<SGBOMItemResult> SGBOMResult.getItems()

Methods in bb.common with parameters of type SGBOMItemResult
 void SGBOMResult.setBom(SGBOMItemResult bom)

Method parameters in bb.common with type arguments of type SGBOMItemResult
 void SGBOMResult.setItems(java.util.List<SGBOMItemResult> items)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGBOMResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGBOMResult

No usage of bb.common.SGBOMResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGCartCheckOutResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGCartCheckOutResult

No usage of bb.common.SGCartCheckOutResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGCartLogin

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGCartLogin

No usage of bb.common.SGCartLogin

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGClientAccountPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGClientAccountPK

Packages that use SGClientAccountPK
bb.common

Uses of SGClientAccountPK in bb.common

Methods in bb.common that return SGClientAccountPK
 SGClientAccountPK SGClientAccountVO.getPk()

Methods in bb.common with parameters of type SGClientAccountPK
 void SGClientAccountVO.setPk(SGClientAccountPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGClientAccountVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGClientAccountVO

No usage of bb.common.SGClientAccountVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGClientLogin

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGClientLogin

No usage of bb.common.SGClientLogin

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SgClientProgramUserVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SgClientProgramUserVO

Packages that use SgClientProgramUserVO
bb.common
bb.common.box

Uses of SgClientProgramUserVO in bb.common

Methods in bb.common with parameters of type SgClientProgramUserVO
static java.lang.String BB2Util.getSgUserName(SgClientProgramUserVO sgUser)

Uses of SgClientProgramUserVO in bb.common.box

Methods in bb.common.box that return SgClientProgramUserVO
SgClientProgramUserVO | AddressBox.addSgClientProgramUser(SgClientProgramUserVO vo)
SgClientProgramUserVO | AddressBox.getSgClientProgramUser(java.lang.String addressId)

Methods in bb.common.box that return types with arguments of type SgClientProgramUserVO
 java.util.Collection<SgClientProgramUserVO> AddressBox.findSGClientProgramUsers(java.lang.String addressID, java.lang.String userName, java.lang.Object[] parameters, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type SgClientProgramUserVO
SgClientProgramUserVO | AddressBox.addSgClientProgramUser(SgClientProgramUserVO vo)
void | AddressBox.updateSgClientProgramUser(SgClientProgramUserVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGCompanyPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGCompanyPK

Packages that use SGCompanyPK
bb.common

Uses of SGCompanyPK in bb.common

Methods in bb.common that return SGCompanyPK
 SGCompanyPK SGCompanyVO.getPk()

Methods in bb.common with parameters of type SGCompanyPK
 void SGCompanyVO.setPk(SGCompanyPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGCompanyVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGCompanyVO

No usage of bb.common.SGCompanyVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGCustomerCatalogPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGCustomerCatalogPK

Packages that use SGCustomerCatalogPK
bb.common
bb.common.box

Uses of SGCustomerCatalogPK in bb.common

Methods in bb.common that return SGCustomerCatalogPK
SGCustomerCatalogPK | SGCustomerCatalogVO.getPk()
SGCustomerCatalogPK | SGPartCatalogResult.getSGCustomerCatalogPK()

Methods in bb.common with parameters of type SGCustomerCatalogPK
 void SGCustomerCatalogVO.setPk(SGCustomerCatalogPK pk)

Constructors in bb.common with parameters of type SGCustomerCatalogPK
SGCustomerCatalogVO(SGCustomerCatalogPK pk, java.lang.String comments)
full constructor

Uses of SGCustomerCatalogPK in bb.common.box

Methods in bb.common.box with parameters of type SGCustomerCatalogPK
void | SalesBox.deleteSGCustomerCatalog(SGCustomerCatalogPK pk)
SGCustomerCatalogVO | SalesBox.getSGCustomerCatalog(SGCustomerCatalogPK pk)

Method parameters in bb.common.box with type arguments of type SGCustomerCatalogPK
 void SalesBox.deleteSGCustomerCatalog(java.util.ArrayList<SGCustomerCatalogPK> pks)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGCustomerCatalogVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGCustomerCatalogVO

Packages that use SGCustomerCatalogVO
bb.common
bb.common.box

Uses of SGCustomerCatalogVO in bb.common

Methods in bb.common that return SGCustomerCatalogVO
 SGCustomerCatalogVO SGPartCatalogResult.getSGCustomerCatalogVO()

Uses of SGCustomerCatalogVO in bb.common.box

Methods in bb.common.box that return SGCustomerCatalogVO
 SGCustomerCatalogVO SalesBox.getSGCustomerCatalog(SGCustomerCatalogPK pk)

Methods in bb.common.box with parameters of type SGCustomerCatalogVO
 void SalesBox.updateSGCustomerCatalog(SGCustomerCatalogVO vo)

Method parameters in bb.common.box with type arguments of type SGCustomerCatalogVO
 void SalesBox.updateSGCustomerCatalog(java.util.ArrayList<SGCustomerCatalogVO> vos)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGCustomerServiceRequestVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGCustomerServiceRequestVO

Packages that use SGCustomerServiceRequestVO
bb.common.box

Uses of SGCustomerServiceRequestVO in bb.common.box

Methods in bb.common.box that return SGCustomerServiceRequestVO
 SGCustomerServiceRequestVO SalesBox.getSGCustomerServiceRequest(java.lang.String csrNumber)

Methods in bb.common.box that return types with arguments of type SGCustomerServiceRequestVO
java.util.Collection<SGCustomerServiceRequestVO> | SalesBox.findOpenSGCustomerServiceRequests(int firstIndex, int maxLength)
java.util.Collection<SGCustomerServiceRequestVO> | SalesBox.findPendingSGCustomerServiceRequests(int firstIndex, int maxLength)
java.util.Collection<SGCustomerServiceRequestVO> | SalesBox.findSGCustomerServiceRequestsByDate(java.lang.String csrNumber, java.lang.String custID, java.lang.String pnLike, java.lang.String soLike, java.lang.String serial, java.lang.String status, java.lang.String csiNum, java.util.Date fDate, java.util.Date tDate, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type SGCustomerServiceRequestVO
 java.lang.String SalesBox.updateSGCustomerServiceRequest(SGCustomerServiceRequestVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGCustRequestForQuoteItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGCustRequestForQuoteItemPK

Packages that use SGCustRequestForQuoteItemPK
bb.common

Uses of SGCustRequestForQuoteItemPK in bb.common

Methods in bb.common that return SGCustRequestForQuoteItemPK
SGCustRequestForQuoteItemPK | SGCustRequestForQuoteItemVO.getPk()
SGCustRequestForQuoteItemPK | SGCustRequestForQuoteItemResult.getPk()

Methods in bb.common with parameters of type SGCustRequestForQuoteItemPK
void | SGCustRequestForQuoteItemVO.setPk(SGCustRequestForQuoteItemPK pk)
void | SGCustRequestForQuoteItemResult.setPk(SGCustRequestForQuoteItemPK pk)

Constructors in bb.common with parameters of type SGCustRequestForQuoteItemPK
SGCustRequestForQuoteItemVO(SGCustRequestForQuoteItemPK pk, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom)
minimal constructor
SGCustRequestForQuoteItemVO(SGCustRequestForQuoteItemPK pk, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.math.BigDecimal qty)
full constructor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGCustRequestForQuoteItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGCustRequestForQuoteItemResult

Packages that use SGCustRequestForQuoteItemResult
bb.common

Uses of SGCustRequestForQuoteItemResult in bb.common

Methods in bb.common that return types with arguments of type SGCustRequestForQuoteItemResult
 java.util.Set<SGCustRequestForQuoteItemResult> SGCustRequestForQuoteResult.getItems()

Method parameters in bb.common with type arguments of type SGCustRequestForQuoteItemResult
 void SGCustRequestForQuoteResult.setItems(java.util.Set<SGCustRequestForQuoteItemResult> items)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGCustRequestForQuoteItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGCustRequestForQuoteItemVO

No usage of bb.common.SGCustRequestForQuoteItemVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGCustRequestForQuoteListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGCustRequestForQuoteListResult

Packages that use SGCustRequestForQuoteListResult
bb.common.box

Uses of SGCustRequestForQuoteListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type SGCustRequestForQuoteListResult
java.util.Collection<SGCustRequestForQuoteListResult> | SalesBox.findNeedQuoteSGCustRequestForQuoteListResults(java.lang.String crfqNumber, int firstIndex, int maxLength)
java.util.Collection<SGCustRequestForQuoteListResult> | SalesBox.findQuoteedSGCustRequestForQuoteListResults(java.lang.String userEmail, java.lang.String contactName, java.lang.String custID, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGCustRequestForQuoteResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGCustRequestForQuoteResult

Packages that use SGCustRequestForQuoteResult
bb.common.box

Uses of SGCustRequestForQuoteResult in bb.common.box

Methods in bb.common.box that return SGCustRequestForQuoteResult
 SGCustRequestForQuoteResult SalesBox.getSGCustRequestForQuoteResult(java.lang.String crfqNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGCustRequestForQuoteVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGCustRequestForQuoteVO

No usage of bb.common.SGCustRequestForQuoteVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGDocPartPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGDocPartPK

Packages that use SGDocPartPK
bb.common

Uses of SGDocPartPK in bb.common

Methods in bb.common that return SGDocPartPK
 SGDocPartPK SGDocPartVO.getPk()

Methods in bb.common with parameters of type SGDocPartPK
 void SGDocPartVO.setPk(SGDocPartPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGDocPartVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGDocPartVO

No usage of bb.common.SGDocPartVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGDwgPicturePK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGDwgPicturePK

Packages that use SGDwgPicturePK
bb.common

Uses of SGDwgPicturePK in bb.common

Methods in bb.common that return SGDwgPicturePK
 SGDwgPicturePK SGDwgPictureVO.getPk()

Methods in bb.common with parameters of type SGDwgPicturePK
 void SGDwgPictureVO.setPk(SGDwgPicturePK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGDwgPictureVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGDwgPictureVO

No usage of bb.common.SGDwgPictureVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGLogLoginVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGLogLoginVO

No usage of bb.common.SGLogLoginVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGPartCartAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGPartCartAgent

No usage of bb.common.SGPartCartAgent

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGPartCatalogResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGPartCatalogResult

Packages that use SGPartCatalogResult
bb.common.box

Uses of SGPartCatalogResult in bb.common.box

Methods in bb.common.box that return types with arguments of type SGPartCatalogResult
java.util.Collection<SGPartCatalogResult> | SalesBox.findSGPartCatalogResults(java.lang.String catalog, java.lang.String pnLike, int firstIndex, int maxLength)
java.util.Collection<SGPartCatalogResult> | SalesBox.findSGPartCatalogResultsforCustomerID(java.lang.String customerID, java.lang.String catalog, int firstIndex, int maxLength)
java.util.Collection<SGPartCatalogResult> | SalesBox.findSGPartCatalogResultsforCustomerIDByPart(java.lang.String catalogID, java.lang.String partNum, int firstIndex, int maxLength)
java.util.Collection<SGPartCatalogResult> | SalesBox.getSGCustomerCatalogByPN(java.lang.String customerID, java.lang.String pnLike)
java.util.Collection<SGPartCatalogResult> | SalesBox.getSGPartCatalogResults(java.lang.String catalogID)
java.util.Collection<SGPartCatalogResult> | SalesBox.getSGPartCatalogResultsforCustomerID(java.lang.String customerID, int firstIndex, int maxLength)
java.util.Collection<SGPartCatalogResult> | SalesBox.getSGPartCatalogResultsforCustomerID(java.lang.String customerID, java.lang.String catalogID)
java.util.Collection<SGPartCatalogResult> | SalesBox.getSGPartCatalogResultsNotforCustomerID(java.lang.String customerID, java.lang.String catalogID)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGPartDocFlagResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGPartDocFlagResult

Packages that use SGPartDocFlagResult
bb.common

Uses of SGPartDocFlagResult in bb.common

Methods in bb.common that return types with arguments of type SGPartDocFlagResult
 java.util.Set<SGPartDocFlagResult> SGPartListResult.getDocFlags()

Method parameters in bb.common with type arguments of type SGPartDocFlagResult
 void SGPartListResult.setDocFlags(java.util.Set<SGPartDocFlagResult> docFlags)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGPartListItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGPartListItemResult

Packages that use SGPartListItemResult
bb.common

Uses of SGPartListItemResult in bb.common

Methods in bb.common that return types with arguments of type SGPartListItemResult
 java.util.Set<SGPartListItemResult> SGPartListResult.getItems()

Method parameters in bb.common with type arguments of type SGPartListItemResult
 void SGPartListResult.setItems(java.util.Set<SGPartListItemResult> items)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGPartListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGPartListResult

No usage of bb.common.SGPartListResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGPicturePK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGPicturePK

Packages that use SGPicturePK
bb.common

Uses of SGPicturePK in bb.common

Methods in bb.common that return SGPicturePK
 SGPicturePK SGPictureVO.getPk()

Methods in bb.common with parameters of type SGPicturePK
 void SGPictureVO.setPk(SGPicturePK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGPictureVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGPictureVO

No usage of bb.common.SGPictureVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGQuoteAddressResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGQuoteAddressResult

No usage of bb.common.SGQuoteAddressResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGQuoteAddressVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGQuoteAddressVO

No usage of bb.common.SGQuoteAddressVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGQuoteCartListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGQuoteCartListResult

Packages that use SGQuoteCartListResult
bb.common

Uses of SGQuoteCartListResult in bb.common

Methods in bb.common that return types with arguments of type SGQuoteCartListResult
 java.util.List<SGQuoteCartListResult> SGCartCheckOutResult.getItems()

Method parameters in bb.common with type arguments of type SGQuoteCartListResult
 void SGCartCheckOutResult.setItems(java.util.List<SGQuoteCartListResult> items)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGQuoteCartVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGQuoteCartVO

No usage of bb.common.SGQuoteCartVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGQuoteLoginVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGQuoteLoginVO

No usage of bb.common.SGQuoteLoginVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGSaleItemAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGSaleItemAgent

Packages that use SGSaleItemAgent
bb.common.box

Uses of SGSaleItemAgent in bb.common.box

Methods in bb.common.box with parameters of type SGSaleItemAgent
 SGSaleItemVO SalesBox.addSGSaleItem(SGSaleItemAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGSaleItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGSaleItemVO

Packages that use SGSaleItemVO
bb.common.box

Uses of SGSaleItemVO in bb.common.box

Methods in bb.common.box that return SGSaleItemVO
SGSaleItemVO | SalesBox.addSGSaleItem(SGSaleItemAgent agent)
SGSaleItemVO | SalesBox.getSGSaleItem(int ii)
SGSaleItemVO | SalesBox.updateSGSaleItem(SGSaleItemVO vo)

Methods in bb.common.box that return types with arguments of type SGSaleItemVO
 java.util.Collection<SGSaleItemVO> SalesBox.findSGSaleItems(java.lang.String custID, java.lang.String soNumber, java.lang.String poNumber, java.lang.String pnNumber, java.lang.String paType, java.lang.String serial, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type SGSaleItemVO
 SGSaleItemVO SalesBox.updateSGSaleItem(SGSaleItemVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SGWeightUnitVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SGWeightUnitVO

No usage of bb.common.SGWeightUnitVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ShareHoldersEquityResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ShareHoldersEquityResult

No usage of bb.common.ShareHoldersEquityResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ShipListAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ShipListAgent

Packages that use ShipListAgent
bb.common.box

Uses of ShipListAgent in bb.common.box

Methods in bb.common.box with parameters of type ShipListAgent
 java.lang.String PlanningBox.addShipList(ShipListAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ShipListInfoVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ShipListInfoVO

Packages that use ShipListInfoVO
bb.common.box

Uses of ShipListInfoVO in bb.common.box

Methods in bb.common.box that return ShipListInfoVO
 ShipListInfoVO PlanningBox.findShipListByShipList(java.lang.String pk)

Methods in bb.common.box that return types with arguments of type ShipListInfoVO
java.util.Collection<ShipListInfoVO> | PlanningBox.findAllShipLists(int firstIndex, int length)
java.util.Collection<ShipListInfoVO> | PlanningBox.findShipLists(java.lang.String hql, int firstIndex, int maxLength)
java.util.Collection<ShipListInfoVO> | PlanningBox.findShipListsById(java.lang.String id, int firstIndex, int length)
java.util.Collection<ShipListInfoVO> | PlanningBox.findShipListsByOwner(java.lang.String owner, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ShipListItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ShipListItemPK

Packages that use ShipListItemPK
bb.common

Uses of ShipListItemPK in bb.common

Methods in bb.common that return ShipListItemPK
ShipListItemPK | ShipListItemVOResult.getPk()
ShipListItemPK | ShipListItemVO.getPk()

Methods in bb.common with parameters of type ShipListItemPK
void | ShipListItemVOResult.setPk(ShipListItemPK pk)
void | ShipListItemVO.setPk(ShipListItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ShipListItemRelatedDocResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ShipListItemRelatedDocResult

Packages that use ShipListItemRelatedDocResult
bb.common.box

Uses of ShipListItemRelatedDocResult in bb.common.box

Methods in bb.common.box that return ShipListItemRelatedDocResult
 ShipListItemRelatedDocResult PlanningBox.getShipListItemRelatedDocResult(SalesOrderItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ShipListItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ShipListItemVO

Packages that use ShipListItemVO
bb.common
bb.common.box

Uses of ShipListItemVO in bb.common

Subclasses of ShipListItemVO in bb.common
 class ShipListItemVOResult

Methods in bb.common that return ShipListItemVO
 ShipListItemVO ShipListItemVOResult.getShipListItemVO()

Uses of ShipListItemVO in bb.common.box

Methods in bb.common.box that return types with arguments of type ShipListItemVO
 java.util.Collection<ShipListItemVO> PlanningBox.findShipListItems(java.lang.String shipList, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type ShipListItemVO
void | PlanningBox.addShipListItem(ShipListItemVO vo)
void | PlanningBox.deleteShipListItem(ShipListItemVO vo)
void | PlanningBox.updateShipListItem(ShipListItemVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ShipListItemVOResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ShipListItemVOResult

Packages that use ShipListItemVOResult
bb.common.box

Uses of ShipListItemVOResult in bb.common.box

Methods in bb.common.box that return ShipListItemVOResult
 ShipListItemVOResult PlanningBox.initShipListItem(java.lang.String shipListNumber, SalesOrderItemPK itemPk)

Methods in bb.common.box that return types with arguments of type ShipListItemVOResult
 java.util.Collection<ShipListItemVOResult> PlanningBox.initSOItemsToshiplist(java.lang.String shipList, java.lang.String ownerName, java.util.Date startDate, java.util.Date endDate, java.util.List salesOrderNumberSet, java.util.List customerIdSet, boolean custIsShipTOID, java.util.List vendorIdSet, java.util.List workCenterIdSet)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ShipListOwnerAttributePK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ShipListOwnerAttributePK

Packages that use ShipListOwnerAttributePK
bb.common

Uses of ShipListOwnerAttributePK in bb.common

Methods in bb.common that return ShipListOwnerAttributePK
 ShipListOwnerAttributePK ShipListOwnerAttributeVO.getPk()

Methods in bb.common with parameters of type ShipListOwnerAttributePK
 void ShipListOwnerAttributeVO.setPk(ShipListOwnerAttributePK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ShipListOwnerAttributeVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ShipListOwnerAttributeVO

Packages that use ShipListOwnerAttributeVO
bb.common.box

Uses of ShipListOwnerAttributeVO in bb.common.box

Methods in bb.common.box that return types with arguments of type ShipListOwnerAttributeVO
 java.util.Collection<ShipListOwnerAttributeVO> PlanningBox.constructShipListOwnerAttributes(java.lang.String ownerName, java.util.List customerIdSet, java.util.List vendorIdSet, java.util.List workCenterIdSet)

Methods in bb.common.box with parameters of type ShipListOwnerAttributeVO
void | PlanningBox.addShipListOwnerAttribute(ShipListOwnerAttributeVO vo)
void | PlanningBox.deleteShipListOwnerAttribute(ShipListOwnerAttributeVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ShipListOwnerVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ShipListOwnerVO

Packages that use ShipListOwnerVO
bb.common
bb.common.box

Uses of ShipListOwnerVO in bb.common

Methods in bb.common that return ShipListOwnerVO
 ShipListOwnerVO ShipListOwnerAttributeVO.getShipListOwner()

Methods in bb.common with parameters of type ShipListOwnerVO
 void ShipListOwnerAttributeVO.setShipListOwner(ShipListOwnerVO shipListOwner)

Uses of ShipListOwnerVO in bb.common.box

Methods in bb.common.box that return ShipListOwnerVO
ShipListOwnerVO | PlanningBox.addShipListOwner(ShipListOwnerVO vo)
ShipListOwnerVO | PlanningBox.addShipListOwner(java.lang.String ownerName)
ShipListOwnerVO | PlanningBox.getShipListOwnerByName(java.lang.String pk)
ShipListOwnerVO | PlanningBox.updateShipListOwner(ShipListOwnerVO vo)

Methods in bb.common.box that return types with arguments of type ShipListOwnerVO
java.util.Collection<ShipListOwnerVO> | PlanningBox.findAllShipListOwners(int firstIndex, int maxLength)
java.util.Collection<ShipListOwnerVO> | PlanningBox.findShipListOwnersByName(java.lang.String owner, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type ShipListOwnerVO
ShipListOwnerVO | PlanningBox.addShipListOwner(ShipListOwnerVO vo)
void | PlanningBox.deleteShipListOwner(ShipListOwnerVO vo)
ShipListOwnerVO | PlanningBox.updateShipListOwner(ShipListOwnerVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ShipListVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ShipListVO

Packages that use ShipListVO
bb.common.box

Uses of ShipListVO in bb.common.box

Methods in bb.common.box that return ShipListVO
ShipListVO | PlanningBox.addShipList(ShipListVO vo)
ShipListVO | PlanningBox.getShipListByShipListNumber(java.lang.String shipListNumber)

Methods in bb.common.box with parameters of type ShipListVO
ShipListVO | PlanningBox.addShipList(ShipListVO vo)
void | PlanningBox.deleteShipList(ShipListVO vo)
java.lang.String | PlanningBox.updateShipList(ShipListVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ShipperAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ShipperAgent

Packages that use ShipperAgent
bb.common.box

Uses of ShipperAgent in bb.common.box

Methods in bb.common.box with parameters of type ShipperAgent
java.lang.Integer | WarehouseBox.makeNonproductivePickingShipper(ShipperAgent agent)
java.lang.String | WarehouseBox.makeOnLoanShipper(ShipperAgent vo)
java.lang.String | WarehouseBox.makeRtvShipper(ShipperAgent vo)
java.lang.String | WarehouseBox.makeSaleOrderShipper(ShipperAgent vo)
java.lang.String | WarehouseBox.makeSwapOrderShipper(ShipperAgent agent)
java.lang.String | WarehouseBox.makeTransferOrderShipper(ShipperAgent vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ShipperInfoVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ShipperInfoVO

Packages that use ShipperInfoVO
bb.common.box

Uses of ShipperInfoVO in bb.common.box

Methods in bb.common.box that return types with arguments of type ShipperInfoVO
java.util.Collection<ShipperInfoVO> | WarehouseBox.findAllShippers(int firstIndex, int maxLength)
java.util.Collection<ShipperInfoVO> | WarehouseBox.findShippersByShipperNumber(java.lang.String shipperNumber, int firstIndex, int maxLength)
java.util.Collection<ShipperInfoVO> | WarehouseBox.findShippersBySo(java.lang.String soNumber, int firstIndex, int maxLength)
java.util.Collection<ShipperInfoVO> | AccountingBox.findShipperWithOutInvoice(java.lang.String customerId, java.lang.String shippedBy, java.lang.String salesMan, java.lang.String currency, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ShipperItemAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ShipperItemAgent

No usage of bb.common.ShipperItemAgent

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ShipperItemDetailAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ShipperItemDetailAgent

Packages that use ShipperItemDetailAgent
bb.common

Uses of ShipperItemDetailAgent in bb.common

Methods in bb.common that return types with arguments of type ShipperItemDetailAgent
 java.util.Set<ShipperItemDetailAgent> ShipperItemAgent.getShipperItemDetails()

Method parameters in bb.common with type arguments of type ShipperItemDetailAgent
 void ShipperItemAgent.setShipperItemDetails(java.util.Set<ShipperItemDetailAgent> shipperItemDetails)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ShipperItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ShipperItemListResult

Packages that use ShipperItemListResult
bb.common.box

Uses of ShipperItemListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type ShipperItemListResult
java.util.Collection<ShipperItemListResult> | WarehouseBox.findShipperItemListResults(java.util.Date fromDate, java.util.Date toDate, java.lang.String snNumber, java.lang.String soNumber, java.lang.String project, java.lang.String partNumber, java.lang.String partType, java.lang.String customerId, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String[] branchWarehouses, int firstIndex, int maxLength)
java.util.Collection<ShipperItemListResult> | WarehouseBox.findShipperItemListResultsByCustomerId(java.lang.String customerId, int firstIndex, int maxLength)
java.util.Collection<ShipperItemListResult> | WarehouseBox.findShipperItemListResultsByPartNumber(java.lang.String partNumber, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<ShipperItemListResult> | WarehouseBox.findShipperItemListResultsBySalesOrderNumber(java.lang.String soNumber, int firstIndex, int maxLength)
java.util.Collection<ShipperItemListResult> | WarehouseBox.findShipperItemListResultsBySerialNumber(java.lang.String snNumber, java.lang.String soNumber, java.lang.String partNumber, java.lang.String partType, java.lang.String customerId, java.lang.String arNumber, java.lang.String serialNumber, java.lang.String[] branchWarehouses, int firstIndex, int maxLength)
java.util.Collection<ShipperItemListResult> | WarehouseBox.findShipperItemListResultsByShipperNumber(java.lang.String snNumber, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ShipperItemManufacturerPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ShipperItemManufacturerPK

Packages that use ShipperItemManufacturerPK
bb.common

Uses of ShipperItemManufacturerPK in bb.common

Methods in bb.common that return ShipperItemManufacturerPK
 ShipperItemManufacturerPK ShipperItemManufacturerVO.getPk()

Methods in bb.common with parameters of type ShipperItemManufacturerPK
 void ShipperItemManufacturerVO.setPk(ShipperItemManufacturerPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ShipperItemManufacturerVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ShipperItemManufacturerVO

No usage of bb.common.ShipperItemManufacturerVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ShipperItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ShipperItemPK

Packages that use ShipperItemPK
bb.common
bb.common.box

Uses of ShipperItemPK in bb.common

Methods in bb.common that return ShipperItemPK
ShipperItemPK | ShipperItemVO.getPk()
ShipperItemPK | SOShipperItemListResult.getShipperItemPk()

Methods in bb.common that return types with arguments of type ShipperItemPK
 java.util.ArrayList<ShipperItemPK> MakeInvoiceAgent.getShipperItemPks()

Methods in bb.common with parameters of type ShipperItemPK
void | ShipperItemVO.setPk(ShipperItemPK pk)
void | SOShipperItemListResult.setShipperItemPk(ShipperItemPK shipperItemPk)

Method parameters in bb.common with type arguments of type ShipperItemPK
 void MakeInvoiceAgent.setShipperItemPks(java.util.ArrayList<ShipperItemPK> shipperItemPks)

Uses of ShipperItemPK in bb.common.box

Methods in bb.common.box with parameters of type ShipperItemPK
RefdocVO | WarehouseBox.addRefdocTwo(ShipperItemPK shItemPk, java.lang.String orderNumber, java.lang.String itemNumber)
ShipperItemVO | WarehouseBox.getShipperItemByPK(ShipperItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ShipperItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ShipperItemVO

Packages that use ShipperItemVO
bb.common.box

Uses of ShipperItemVO in bb.common.box

Methods in bb.common.box that return ShipperItemVO
 ShipperItemVO WarehouseBox.getShipperItemByPK(ShipperItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ShipperListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ShipperListResult

Packages that use ShipperListResult
bb.common.box

Uses of ShipperListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type ShipperListResult
java.util.Collection<ShipperListResult> | WarehouseBox.findShipperListResultsByCustomerId(java.lang.String customerId, int firstIndex, int maxLength)
java.util.Collection<ShipperListResult> | WarehouseBox.findShipperListResultsBySalesman(java.lang.String salesman, int firstIndex, int maxLength)
java.util.Collection<ShipperListResult> | WarehouseBox.findShipperListResultsBySalesOrderNumber(java.lang.String soNumber, int firstIndex, int maxLength)
java.util.Collection<ShipperListResult> | WarehouseBox.findShipperListResultsByShipperNumber(java.lang.String snNumber, int firstIndex, int maxLength)
java.util.Collection<ShipperListResult> | WarehouseBox.getMyShipperPrintList()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ShipperVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ShipperVO

Packages that use ShipperVO
bb.common.box

Uses of ShipperVO in bb.common.box

Methods in bb.common.box that return ShipperVO
ShipperVO | WarehouseBox.addShipper(ShipperVO vo)
ShipperVO | WarehouseBox.getShipperById(java.lang.String id)
ShipperVO | WarehouseBox.updateShipper(ShipperVO vo)

Methods in bb.common.box that return types with arguments of type ShipperVO
java.util.Collection<ShipperVO> | AccountingBox.findShipperWithItemsWithOutInvoice(java.lang.String customerId, java.lang.String shippedBy, java.lang.String salesMan, java.lang.String currency, java.util.Date fromDate, java.util.Date toDate, java.lang.String salesOrderNumber, int firstIndex, int maxLength)
java.util.Collection<ShipperVO> | AccountingBox.findShipperWithItemsWithOutUnbilled(java.lang.String customerId, java.lang.String shippedBy, java.lang.String salesMan, java.lang.String currency, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type ShipperVO
ShipperVO | WarehouseBox.addShipper(ShipperVO vo)
void | WarehouseBox.deleteShipper(ShipperVO vo)
ShipperVO | WarehouseBox.updateShipper(ShipperVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ShippingItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ShippingItemResult

Packages that use ShippingItemResult
bb.common.box

Uses of ShippingItemResult in bb.common.box

Methods in bb.common.box that return ShippingItemResult
 ShippingItemResult WarehouseBox.getShippingItemResult(SalesOrderItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ShippingResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ShippingResult

Packages that use ShippingResult
bb.common.box

Uses of ShippingResult in bb.common.box

Methods in bb.common.box that return ShippingResult
ShippingResult | WarehouseBox.getNonproductivePickingShippingResult(java.lang.String pickingNumber)
ShippingResult | WarehouseBox.getOnLoanShippingResult(java.lang.String loanNumber)
ShippingResult | WarehouseBox.getRtvShippingResult(java.lang.String rtvNumber)
ShippingResult | WarehouseBox.getSalesOrderShippingResult(java.lang.String salesOrderNumber)
ShippingResult | WarehouseBox.getSwapOrderShippingResult(java.lang.String swoNumber)
ShippingResult | WarehouseBox.getTransferOrderShippingResult(java.lang.String transferOrderNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ShoppingCartItem

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ShoppingCartItem

No usage of bb.common.ShoppingCartItem

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SmtpServerVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SmtpServerVO

Packages that use SmtpServerVO
bb.common.box

Uses of SmtpServerVO in bb.common.box

Methods in bb.common.box that return SmtpServerVO
SmtpServerVO | CompanyBox.getSmtpServer()
SmtpServerVO | CompanyBox.setSmtpServer(SmtpServerVO vo)
SmtpServerVO | CompanyBox.updateSmtpServer(SmtpServerVO vo)

Methods in bb.common.box with parameters of type SmtpServerVO
SmtpServerVO | CompanyBox.setSmtpServer(SmtpServerVO vo)
SmtpServerVO | CompanyBox.updateSmtpServer(SmtpServerVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SO2POAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SO2POAgent

Packages that use SO2POAgent
bb.common.box

Uses of SO2POAgent in bb.common.box

Methods in bb.common.box with parameters of type SO2POAgent
PurchaseOrderVO | SalesBox.copyPurchaseOrderFromSalesOrder(SO2POAgent agent)
PurchaseOrderVO | PurchasingBox.copyPurchaseOrderFromSalesOrder(SO2POAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SO2SOAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SO2SOAgent

Packages that use SO2SOAgent
bb.common.box

Uses of SO2SOAgent in bb.common.box

Methods in bb.common.box with parameters of type SO2SOAgent
 java.lang.String SalesBox.copySalesOrderFromSalesOrder(SO2SOAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SO2WOAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SO2WOAgent

Packages that use SO2WOAgent
bb.common.box

Uses of SO2WOAgent in bb.common.box

Methods in bb.common.box with parameters of type SO2WOAgent
 WorkOrderVO SalesBox.copyWorkOrderFromSalesOrder(SO2WOAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SoPickListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SoPickListResult

Packages that use SoPickListResult
bb.common.box

Uses of SoPickListResult in bb.common.box

Methods in bb.common.box that return SoPickListResult
 SoPickListResult WarehouseBox.getSoPickListResult(java.lang.String salesOrderNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SOShipperItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SOShipperItemListResult

Packages that use SOShipperItemListResult
bb.common.box

Uses of SOShipperItemListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type SOShipperItemListResult
 java.util.Collection<SOShipperItemListResult> SalesBox.getSOShipperItemListResultsOfSalesOrder(java.lang.String soNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.Spiderman

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.Spiderman

No usage of bb.common.Spiderman

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.StaffWorkingInformationResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.StaffWorkingInformationResult

No usage of bb.common.StaffWorkingInformationResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.StockTransactionAdjustmentResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.StockTransactionAdjustmentResult

Packages that use StockTransactionAdjustmentResult
bb.common.box

Uses of StockTransactionAdjustmentResult in bb.common.box

Methods in bb.common.box that return types with arguments of type StockTransactionAdjustmentResult
 java.util.Collection<StockTransactionAdjustmentResult> WarehouseBox.findStockTransactionAdjustmentResults(java.util.Date from, java.util.Date to, java.lang.String pnLike, java.lang.String pnType, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.StockTransactionPartInfoResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.StockTransactionPartInfoResult

Packages that use StockTransactionPartInfoResult
bb.common.box

Uses of StockTransactionPartInfoResult in bb.common.box

Methods in bb.common.box that return StockTransactionPartInfoResult
 StockTransactionPartInfoResult WarehouseBox.getStockTransactionPartInfoResultByPartPk(PartPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.StockTransactionPOReceiverResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.StockTransactionPOReceiverResult

Packages that use StockTransactionPOReceiverResult
bb.common.box

Uses of StockTransactionPOReceiverResult in bb.common.box

Methods in bb.common.box that return types with arguments of type StockTransactionPOReceiverResult
 java.util.Collection<StockTransactionPOReceiverResult> WarehouseBox.findStockTransactionPOReceiverResults(java.util.Date from, java.util.Date to, java.lang.String pnLike, java.lang.String pnType, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.StockTransactionSOShipperResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.StockTransactionSOShipperResult

Packages that use StockTransactionSOShipperResult
bb.common.box

Uses of StockTransactionSOShipperResult in bb.common.box

Methods in bb.common.box that return types with arguments of type StockTransactionSOShipperResult
 java.util.Collection<StockTransactionSOShipperResult> WarehouseBox.findStockTransactionSOShipperResults(java.util.Date from, java.util.Date to, java.lang.String pnLike, java.lang.String pnType, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.StockTransactionWOReceiverResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.StockTransactionWOReceiverResult

Packages that use StockTransactionWOReceiverResult
bb.common.box

Uses of StockTransactionWOReceiverResult in bb.common.box

Methods in bb.common.box that return types with arguments of type StockTransactionWOReceiverResult
 java.util.Collection<StockTransactionWOReceiverResult> WarehouseBox.findStockTransactionWOReceiverResults(java.util.Date from, java.util.Date to, java.lang.String pnLike, java.lang.String pnType, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.StockTransactionWOShipperResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.StockTransactionWOShipperResult

Packages that use StockTransactionWOShipperResult
bb.common.box

Uses of StockTransactionWOShipperResult in bb.common.box

Methods in bb.common.box that return types with arguments of type StockTransactionWOShipperResult
 java.util.Collection<StockTransactionWOShipperResult> WarehouseBox.findStockTransactionWOShipperResults(java.util.Date from, java.util.Date to, java.lang.String pnLike, java.lang.String pnType, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.StringListConvertor

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.StringListConvertor

Packages that use StringListConvertor
bb.common

Uses of StringListConvertor in bb.common

Methods in bb.common that return StringListConvertor
static StringListConvertor StringListConvertor.getInstance()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SubcompanyLoginAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SubcompanyLoginAgent

No usage of bb.common.SubcompanyLoginAgent

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SubcompanyVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SubcompanyVO

Packages that use SubcompanyVO
bb.common.box

Uses of SubcompanyVO in bb.common.box

Methods in bb.common.box that return SubcompanyVO
 SubcompanyVO CompanyBox.getSubcompanyById(java.lang.String addressId)

Methods in bb.common.box that return types with arguments of type SubcompanyVO
 java.util.Collection<SubcompanyVO> CompanyBox.findAllSubcompanysById(java.lang.String addressId, int firstIndex, int length)

Methods in bb.common.box with parameters of type SubcompanyVO
void | CompanyBox.addSubcompany(SubcompanyVO vo)
void | CompanyBox.updateSubcompany(SubcompanyVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SwapOrderApprovalVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SwapOrderApprovalVO

Packages that use SwapOrderApprovalVO
bb.common.box

Uses of SwapOrderApprovalVO in bb.common.box

Methods in bb.common.box that return SwapOrderApprovalVO
SwapOrderApprovalVO | PurchasingBox.addSwapOrderApproval(java.lang.String employeeId)
SwapOrderApprovalVO | PurchasingBox.getSwapOrderApprovalByEmployeeId(java.lang.String employeeId)

Methods in bb.common.box that return types with arguments of type SwapOrderApprovalVO
 java.util.Collection<SwapOrderApprovalVO> PurchasingBox.findAllSwapOrderApproval(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type SwapOrderApprovalVO
 void PurchasingBox.updateSwapOrderApproval(SwapOrderApprovalVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SwapOrderItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SwapOrderItemListResult

Packages that use SwapOrderItemListResult
bb.common.box

Uses of SwapOrderItemListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type SwapOrderItemListResult
java.util.Collection<SwapOrderItemListResult> | PurchasingBox.findCancelledSwapOrder(int firstIndex, int maxLength)
java.util.Collection<SwapOrderItemListResult> | PurchasingBox.findSwapOrderByDate(java.lang.String swoNumber, PartPK partPk, java.lang.String dateType, java.util.Date startDate, java.util.Date toDate, java.lang.String vendorId, java.lang.String buyer, java.lang.String projectName, java.lang.String relatedDoc, java.lang.String status, java.lang.String partFrom, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SwapOrderItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SwapOrderItemPK

Packages that use SwapOrderItemPK
bb.common

Uses of SwapOrderItemPK in bb.common

Methods in bb.common that return SwapOrderItemPK
 SwapOrderItemPK SwapOrderItemVO.getPk()

Methods in bb.common with parameters of type SwapOrderItemPK
 void SwapOrderItemVO.setPk(SwapOrderItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SwapOrderItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SwapOrderItemVO

Packages that use SwapOrderItemVO
bb.common
bb.common.box

Uses of SwapOrderItemVO in bb.common

Methods in bb.common that return types with arguments of type SwapOrderItemVO
 java.util.Set<SwapOrderItemVO> SwapOrderVO.getSwapOrderItems()

Method parameters in bb.common with type arguments of type SwapOrderItemVO
 void SwapOrderVO.setSwapOrderItems(java.util.Set<SwapOrderItemVO> swapOrderItems)

Uses of SwapOrderItemVO in bb.common.box

Methods in bb.common.box that return SwapOrderItemVO
 SwapOrderItemVO PurchasingBox.initSwapOrderItem(SwapOrderVO toVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SwapOrderListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SwapOrderListResult

Packages that use SwapOrderListResult
bb.common.box

Uses of SwapOrderListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type SwapOrderListResult
java.util.Collection<SwapOrderListResult> | PurchasingBox.findOpenSwapOrder(java.lang.String swoNumber, int firstIndex, int maxLength)
java.util.Collection<SwapOrderListResult> | WarehouseBox.findOpenSwapOrderForShipper(java.lang.String swoNumber, int firstIndex, int maxLength)
java.util.Collection<SwapOrderListResult> | PurchasingBox.findSwapOrders(java.lang.String swoNumber, java.lang.String vendorId, java.lang.String buyer, java.lang.String projectName, java.lang.String relatedDoc, java.lang.String[] status, java.util.Date startDate, java.util.Date toDate, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SwapOrderVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SwapOrderVO

Packages that use SwapOrderVO
bb.common
bb.common.box

Uses of SwapOrderVO in bb.common

Subclasses of SwapOrderVO in bb.common
 class SwapOrderListResult

Uses of SwapOrderVO in bb.common.box

Methods in bb.common.box that return SwapOrderVO
SwapOrderVO | PurchasingBox.approvalSwapOrder(SwapOrderVO toVO)
SwapOrderVO | PurchasingBox.getSwapOrderVOBySwapNumber(java.lang.String swapNumber)
SwapOrderVO | PurchasingBox.updateSwapOrder(SwapOrderVO vo)

Methods in bb.common.box with parameters of type SwapOrderVO
SwapOrderVO | PurchasingBox.approvalSwapOrder(SwapOrderVO toVO)
void | PurchasingBox.deleteSwapOrder(SwapOrderVO vo)
SwapOrderItemVO | PurchasingBox.initSwapOrderItem(SwapOrderVO toVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool)
SwapOrderVO | PurchasingBox.updateSwapOrder(SwapOrderVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SwapReceiverItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SwapReceiverItemListResult

Packages that use SwapReceiverItemListResult
bb.common.box

Uses of SwapReceiverItemListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type SwapReceiverItemListResult
 java.util.Collection<SwapReceiverItemListResult> WarehouseBox.findSwapReceiverItemByDate(java.lang.String swapReceiverNumber, java.lang.String swapShipperNumber, java.lang.String swoNumber, java.lang.String vendorId, java.lang.String status, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SwapReceiverItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SwapReceiverItemPK

Packages that use SwapReceiverItemPK
bb.common
bb.common.box

Uses of SwapReceiverItemPK in bb.common

Methods in bb.common that return SwapReceiverItemPK
 SwapReceiverItemPK SwapReceiverItemVO.getPk()

Methods in bb.common with parameters of type SwapReceiverItemPK
 void SwapReceiverItemVO.setPk(SwapReceiverItemPK pk)

Uses of SwapReceiverItemPK in bb.common.box

Methods in bb.common.box with parameters of type SwapReceiverItemPK
 SwapReceiverItemVO WarehouseBox.getSwapReceiverItemByPk(SwapReceiverItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SwapReceiverItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SwapReceiverItemVO

Packages that use SwapReceiverItemVO
bb.common
bb.common.box

Uses of SwapReceiverItemVO in bb.common

Methods in bb.common that return types with arguments of type SwapReceiverItemVO
 java.util.Set<SwapReceiverItemVO> SwapReceiverVO.getSwapReceiverItems()

Method parameters in bb.common with type arguments of type SwapReceiverItemVO
 void SwapReceiverVO.setSwapReceiverItems(java.util.Set<SwapReceiverItemVO> swapReceiverItems)

Uses of SwapReceiverItemVO in bb.common.box

Methods in bb.common.box that return SwapReceiverItemVO
 SwapReceiverItemVO WarehouseBox.getSwapReceiverItemByPk(SwapReceiverItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SwapReceiverListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SwapReceiverListResult

Packages that use SwapReceiverListResult
bb.common.box

Uses of SwapReceiverListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type SwapReceiverListResult
java.util.Collection<SwapReceiverListResult> | WarehouseBox.findSwapReceivers(java.lang.String swapReceiverNumber, java.lang.String swapShipperNumber, java.lang.String swoNumber, java.lang.String vendorId, java.lang.String status, java.lang.String buyer, java.lang.String project, java.lang.String relatedDoc, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.List<SwapReceiverListResult> | WarehouseBox.makeSwapReceiver(ReceiverAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SwapReceiverVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SwapReceiverVO

Packages that use SwapReceiverVO
bb.common.box

Uses of SwapReceiverVO in bb.common.box

Methods in bb.common.box that return SwapReceiverVO
 SwapReceiverVO WarehouseBox.getSwapReceiverVO(java.lang.String swapReceiverNumber)

Methods in bb.common.box with parameters of type SwapReceiverVO
 java.lang.String WarehouseBox.updateSwapReceiver(SwapReceiverVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SwapShipperItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SwapShipperItemListResult

Packages that use SwapShipperItemListResult
bb.common.box

Uses of SwapShipperItemListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type SwapShipperItemListResult
 java.util.Collection<SwapShipperItemListResult> WarehouseBox.findSwapShipperItemsByDate(java.lang.String swapShipperNumber, java.lang.String swoNumber, java.lang.String vendorId, java.lang.String status, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SwapShipperItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SwapShipperItemPK

Packages that use SwapShipperItemPK
bb.common
bb.common.box

Uses of SwapShipperItemPK in bb.common

Methods in bb.common that return SwapShipperItemPK
SwapShipperItemPK | SwapShipperItemVO.getPk()
SwapShipperItemPK | SwapShipperOnOrderResult.getSwapShipperItemPk()

Methods in bb.common with parameters of type SwapShipperItemPK
int | SwapShipperItemPK.compareTo(SwapShipperItemPK other)
void | SwapShipperItemVO.setPk(SwapShipperItemPK pk)
void | SwapShipperOnOrderResult.setSwapShipperItemPk(SwapShipperItemPK swapShipperItemPk)

Uses of SwapShipperItemPK in bb.common.box

Methods in bb.common.box with parameters of type SwapShipperItemPK
 SwapShipperItemVO WarehouseBox.getSwapShipperItemByPk(SwapShipperItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SwapShipperItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SwapShipperItemVO

Packages that use SwapShipperItemVO
bb.common
bb.common.box

Uses of SwapShipperItemVO in bb.common

Methods in bb.common that return types with arguments of type SwapShipperItemVO
 java.util.Set<SwapShipperItemVO> SwapShipperVO.getSwapShipperItems()

Method parameters in bb.common with type arguments of type SwapShipperItemVO
 void SwapShipperVO.setSwapShipperItems(java.util.Set<SwapShipperItemVO> swapShipperItems)

Uses of SwapShipperItemVO in bb.common.box

Methods in bb.common.box that return SwapShipperItemVO
 SwapShipperItemVO WarehouseBox.getSwapShipperItemByPk(SwapShipperItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SwapShipperListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SwapShipperListResult

Packages that use SwapShipperListResult
bb.common.box

Uses of SwapShipperListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type SwapShipperListResult
 java.util.Collection<SwapShipperListResult> WarehouseBox.findSwapShippers(java.lang.String swapShipperNumber, java.lang.String swoNumber, java.lang.String vendorId, java.lang.String status, java.lang.String buyer, java.lang.String project, java.lang.String relatedDoc, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SwapShipperOnOrderResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SwapShipperOnOrderResult

No usage of bb.common.SwapShipperOnOrderResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.SwapShipperVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.SwapShipperVO

Packages that use SwapShipperVO
bb.common.box

Uses of SwapShipperVO in bb.common.box

Methods in bb.common.box that return SwapShipperVO
SwapShipperVO | WarehouseBox.getSwapShipperVO(java.lang.String swapShipperNumber)
SwapShipperVO | WarehouseBox.updateSwapShipper(SwapShipperVO vo)

Methods in bb.common.box with parameters of type SwapShipperVO
 SwapShipperVO WarehouseBox.updateSwapShipper(SwapShipperVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.TakeCycleCountAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.TakeCycleCountAgent

Packages that use TakeCycleCountAgent
bb.common.box

Uses of TakeCycleCountAgent in bb.common.box

Methods in bb.common.box with parameters of type TakeCycleCountAgent
 int WarehouseBox.takeInitCycleCount(TakeCycleCountAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.TaskFileResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.TaskFileResult

Packages that use TaskFileResult
bb.common.box

Uses of TaskFileResult in bb.common.box

Methods in bb.common.box that return types with arguments of type TaskFileResult
 java.util.Collection<TaskFileResult> CompanyBox.getAllFileByTaskId(java.lang.Long ii)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.TaskVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.TaskVO

Packages that use TaskVO
bb.common.box

Uses of TaskVO in bb.common.box

Methods in bb.common.box that return TaskVO
 TaskVO CompanyBox.getTask(java.lang.Long ii)

Methods in bb.common.box that return types with arguments of type TaskVO
 java.util.Collection<TaskVO> CompanyBox.findAllTasks(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type TaskVO
void | CompanyBox.addTask(TaskVO vo)
void | CompanyBox.updateTask(TaskVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.TaxAccountVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.TaxAccountVO

Packages that use TaxAccountVO
bb.common.box

Uses of TaxAccountVO in bb.common.box

Methods in bb.common.box that return TaxAccountVO
 TaxAccountVO CompanyBox.addTaxAccount(TaxAccountVO vo)

Methods in bb.common.box that return types with arguments of type TaxAccountVO
java.util.Collection<TaxAccountVO> | CompanyBox.findAllPurchaseTaxAccount(int firstIndex, int maxLength)
java.util.Collection<TaxAccountVO> | CompanyBox.findAllSalesTaxAccount(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type TaxAccountVO
TaxAccountVO | CompanyBox.addTaxAccount(TaxAccountVO vo)
void | CompanyBox.deleteTaxAccount(TaxAccountVO vo)
void | CompanyBox.updateTaxAccount(TaxAccountVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.TempArApAgingVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.TempArApAgingVO

Packages that use TempArApAgingVO
bb.common.box

Uses of TempArApAgingVO in bb.common.box

Methods in bb.common.box that return types with arguments of type TempArApAgingVO
java.util.Collection<TempArApAgingVO> | AccountingBox.findAPbyAddressIdSet(java.lang.String[] includeVendorId, java.lang.String[] excludeVendorId, boolean useAsOf, java.util.Date asOf, int firstIndex, int maxLength)
java.util.Collection<TempArApAgingVO> | AccountingBox.findARbyAddressIdSet(java.lang.String[] includeCustomerId, java.lang.String[] excludeCustomerId, boolean useAsOf, java.util.Date asOf, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.TempReceiverWithoutAPInfo

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.TempReceiverWithoutAPInfo

Packages that use TempReceiverWithoutAPInfo
bb.common.box

Uses of TempReceiverWithoutAPInfo in bb.common.box

Methods in bb.common.box that return types with arguments of type TempReceiverWithoutAPInfo
java.util.Collection<TempReceiverWithoutAPInfo> | AccountingBox.findReceiverWithoutAPSaveRecordDetails(java.util.Date saveDate, int firstIndex, int maxLength)
java.util.Collection<TempReceiverWithoutAPInfo> | AccountingBox.findReceiverWithoutAPSaveRecords(int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.TermAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.TermAgent

Packages that use TermAgent
bb.common.box

Uses of TermAgent in bb.common.box

Methods in bb.common.box with parameters of type TermAgent
 TermVO CompanyBox.addTerm(TermAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.TermsConditionVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.TermsConditionVO

Packages that use TermsConditionVO
bb.common.box

Uses of TermsConditionVO in bb.common.box

Methods in bb.common.box that return TermsConditionVO
TermsConditionVO | CompanyBox.getTermsConditionsByOrderType(java.lang.String type)
TermsConditionVO | CompanyBox.getTermsConditionsInfoByOrderType(java.lang.String type)

Methods in bb.common.box that return types with arguments of type TermsConditionVO
 java.util.Collection<TermsConditionVO> CompanyBox.findAllTermsConditions()

Methods in bb.common.box with parameters of type TermsConditionVO
void | CompanyBox.addTermsConditions(TermsConditionVO vo)
void | CompanyBox.deleteTermsCondition(TermsConditionVO vo)
void | CompanyBox.updateTermsCondition(TermsConditionVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.TermVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.TermVO

Packages that use TermVO
bb.common.box

Uses of TermVO in bb.common.box

Methods in bb.common.box that return TermVO
TermVO | CompanyBox.addTerm(TermAgent agent)
TermVO | CompanyBox.getTerm(int ii)
TermVO | CompanyBox.getTerm(java.lang.String termValue)
TermVO | CompanyBox.updateTerm(TermVO vo)

Methods in bb.common.box that return types with arguments of type TermVO
 java.util.Collection<TermVO> CompanyBox.findAllTerms(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type TermVO
 TermVO CompanyBox.updateTerm(TermVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ToolBasicInfo

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ToolBasicInfo

Packages that use ToolBasicInfo
bb.common
bb.common.box

Uses of ToolBasicInfo in bb.common

Subclasses of ToolBasicInfo in bb.common
class | ToolListDetailCostWithToolInfoResult
class | ToolListItemDetailCostWithToolInfoResult
class | ToolListItemWithToolInfoResult
class | ToolListWithToolInfoResult

Methods in bb.common that return ToolBasicInfo
ToolBasicInfo | WorkOrderWorkSheetItemWithRelatedInfoResult.getToolBasicInfo()
ToolBasicInfo | ToolWhereUsedResult.getToolBasicInfo()
ToolBasicInfo | PurchaseWorkSheetItemWithRelatedInfoResult.getToolBasicInfo()
ToolBasicInfo | InventoryAdjustmentDetailResult.getToolInfo()

Methods in bb.common with parameters of type ToolBasicInfo
void | WorkOrderWorkSheetItemWithRelatedInfoResult.setToolBasicInfo(ToolBasicInfo toolBasicInfo)
void | ToolWhereUsedResult.setToolBasicInfo(ToolBasicInfo toolBasicInfo)
void | PurchaseWorkSheetItemWithRelatedInfoResult.setToolBasicInfo(ToolBasicInfo toolBasicInfo)
void | InventoryAdjustmentDetailResult.setToolInfo(ToolBasicInfo toolInfo)

Uses of ToolBasicInfo in bb.common.box

Methods in bb.common.box that return ToolBasicInfo
ToolBasicInfo | ManufacturingBox.getToolBasicInfo(PartPK pk)
ToolBasicInfo | ManufacturingBox.getToolBasicInfo(PartPK pk, java.lang.String languageCode)

Methods in bb.common.box that return types with arguments of type ToolBasicInfo
java.util.Collection<ToolBasicInfo> | ManufacturingBox.findAllTools(int firstIndex, int maxLength)
java.util.Collection<ToolBasicInfo> | ManufacturingBox.findInactiveTool(java.lang.String toolNumber, int firstIndex, int maxLength)
java.util.Collection<ToolBasicInfo> | ManufacturingBox.findToolsByDescriptionInside(java.lang.String edRegex, int firstIndex, int maxLength)
java.util.Collection<ToolBasicInfo> | ManufacturingBox.findToolsByDescriptionStart(java.lang.String edRegex, int firstIndex, int maxLength)
java.util.Collection<ToolBasicInfo> | ManufacturingBox.findToolsByToolLike(java.lang.String partNum, java.lang.String toolDes, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<ToolBasicInfo> | ManufacturingBox.findToolsOnHold(int firstIndex, int maxLength)
java.util.Collection<ToolBasicInfo> | ManufacturingBox.findToolsWithDrawing(int firstIndex, int maxLength)
java.util.Collection<ToolBasicInfo> | ManufacturingBox.findToolsWithToolList(int firstIndex, int maxLength)
java.util.Collection<ToolBasicInfo> | ManufacturingBox.findToolsWithWI(int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ToolCalibrateListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ToolCalibrateListResult

Packages that use ToolCalibrateListResult
bb.common.box

Uses of ToolCalibrateListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type ToolCalibrateListResult
java.util.Collection<ToolCalibrateListResult> | ManufacturingBox.findAllCalibrations(int firstIndex, int maxLength)
java.util.Collection<ToolCalibrateListResult> | ManufacturingBox.findCalibrationsByAssignedTo(java.lang.String assignedTo, int firstIndex, int maxLength)
java.util.Collection<ToolCalibrateListResult> | ManufacturingBox.findCalibrationsByDate(java.util.Date fromDate, java.util.Date toDate, boolean isLast, PartPK partPk, java.lang.String assign, int firstIndex, int maxLength)
java.util.Collection<ToolCalibrateListResult> | ManufacturingBox.findCalibrationsByInspectedBy(java.lang.String inspectedBy, int firstIndex, int maxLength)
java.util.Collection<ToolCalibrateListResult> | ManufacturingBox.findCalibrationsByLocation(java.lang.String location, int firstIndex, int maxLength)
java.util.Collection<ToolCalibrateListResult> | ManufacturingBox.findCalibrationsByNextInspectionInDays(int day, int firstIndex, int maxLength)
java.util.Collection<ToolCalibrateListResult> | ManufacturingBox.findCalibrationsDue(int firstIndex, int maxLength)
java.util.Collection<ToolCalibrateListResult> | ManufacturingBox.findToolCalibrationsByPart(PartPK partPk, int firstIndex, int maxLength)
java.util.Collection<ToolCalibrateListResult> | ManufacturingBox.updateToolCalibration(java.util.ArrayList toolCalibrationList, PartPK partPk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ToolCalibrationVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ToolCalibrationVO

Packages that use ToolCalibrationVO
bb.common
bb.common.box

Uses of ToolCalibrationVO in bb.common

Subclasses of ToolCalibrationVO in bb.common
 class ToolCalibrateListResult

Uses of ToolCalibrationVO in bb.common.box

Methods in bb.common.box that return ToolCalibrationVO
 ToolCalibrationVO ManufacturingBox.addToolCalibration(PartPK partPk, java.lang.String serialNumber)

Methods in bb.common.box that return types with arguments of type ToolCalibrationVO
 java.util.Collection<ToolCalibrationVO> ManufacturingBox.findCalibrationByPart(java.lang.String pnLike, java.lang.String partType)

Methods in bb.common.box with parameters of type ToolCalibrationVO
 void ManufacturingBox.deleteCalibration(ToolCalibrationVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ToolDescriptionVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ToolDescriptionVO

No usage of bb.common.ToolDescriptionVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ToolInventoryVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ToolInventoryVO

Packages that use ToolInventoryVO
bb.common
bb.common.box

Uses of ToolInventoryVO in bb.common

Methods in bb.common that return ToolInventoryVO
ToolInventoryVO | ToolWithOnhandsVO.getPartInventory()
ToolInventoryVO | ToolVO.getPartInventory()
ToolInventoryVO | InventoryAdjustmentDetailResult.getToolInventoryInfo()
ToolInventoryVO | WorkOrderWorkSheetItemWithRelatedInfoResult.getToolInventoryVO()
ToolInventoryVO | PurchaseWorkSheetItemWithRelatedInfoResult.getToolInventoryVO()

Methods in bb.common with parameters of type ToolInventoryVO
void | ToolWithOnhandsVO.setPartInventory(ToolInventoryVO partInventory)
void | ToolVO.setPartInventory(ToolInventoryVO partInventory)
void | InventoryAdjustmentDetailResult.setToolInventoryInfo(ToolInventoryVO toolInventoryInfo)
void | WorkOrderWorkSheetItemWithRelatedInfoResult.setToolInventoryVO(ToolInventoryVO toolInventoryVO)
void | PurchaseWorkSheetItemWithRelatedInfoResult.setToolInventoryVO(ToolInventoryVO toolInventoryVO)

Uses of ToolInventoryVO in bb.common.box

Methods in bb.common.box that return ToolInventoryVO
 ToolInventoryVO ManufacturingBox.getToolInventoryByPk(PartPK partPk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ToolListDetailCostResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ToolListDetailCostResult

Packages that use ToolListDetailCostResult
bb.common.box

Uses of ToolListDetailCostResult in bb.common.box

Methods in bb.common.box that return ToolListDetailCostResult
 ToolListDetailCostResult ManufacturingBox.getToolListDetailCostResult(BillPK billPk, java.lang.String languageCode)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ToolListDetailCostWithToolInfoResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ToolListDetailCostWithToolInfoResult

Packages that use ToolListDetailCostWithToolInfoResult
bb.common

Uses of ToolListDetailCostWithToolInfoResult in bb.common

Methods in bb.common that return ToolListDetailCostWithToolInfoResult
 ToolListDetailCostWithToolInfoResult ToolListDetailCostResult.getToolListInfo()

Methods in bb.common with parameters of type ToolListDetailCostWithToolInfoResult
 void ToolListDetailCostResult.setToolListInfo(ToolListDetailCostWithToolInfoResult toolListInfo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ToolListInfoVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ToolListInfoVO

No usage of bb.common.ToolListInfoVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ToolListItemDetailCostWithToolInfoResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ToolListItemDetailCostWithToolInfoResult

No usage of bb.common.ToolListItemDetailCostWithToolInfoResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ToolListItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ToolListItemVO

Packages that use ToolListItemVO
bb.common.box

Uses of ToolListItemVO in bb.common.box

Methods in bb.common.box that return ToolListItemVO
 ToolListItemVO ManufacturingBox.getToolListItems(BillItemPK itemPk)

Methods in bb.common.box with parameters of type ToolListItemVO
void | ManufacturingBox.addToolListItem(ToolListItemVO itemVO)
void | ManufacturingBox.deleteToolListItem(ToolListItemVO billItemVO)
ToolListVO | ManufacturingBox.getParentToolList(ToolListItemVO billItemVO)
void | ManufacturingBox.setParentToolList(ToolListVO billVO, ToolListItemVO billItemVO)
void | ManufacturingBox.updateToolListItem(ToolListItemVO billItemVO)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ToolListItemWithToolInfoResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ToolListItemWithToolInfoResult

Packages that use ToolListItemWithToolInfoResult
bb.common
bb.common.box

Uses of ToolListItemWithToolInfoResult in bb.common

Subclasses of ToolListItemWithToolInfoResult in bb.common
 class ToolListItemDetailCostWithToolInfoResult

Constructors in bb.common with parameters of type ToolListItemWithToolInfoResult
ToolListItemDetailCostWithToolInfoResult(ToolListItemWithToolInfoResult vo)

Uses of ToolListItemWithToolInfoResult in bb.common.box

Methods in bb.common.box that return ToolListItemWithToolInfoResult
ToolListItemWithToolInfoResult | ManufacturingBox.getToolListItemWithToolInfoByBillItemPk(BillItemPK billItemPk, java.lang.String languageCode)
ToolListItemWithToolInfoResult | ManufacturingBox.initToolListItemWithToolInfo(PartPK partPk, BillItemPK pk, java.math.BigDecimal qty)

Methods in bb.common.box that return types with arguments of type ToolListItemWithToolInfoResult
java.util.Collection<ToolListItemWithToolInfoResult> | ManufacturingBox.findToolListItemWithToolInfoByBillPk(BillPK billPk, java.lang.String languageCode)
java.util.Collection<ToolListItemWithToolInfoResult> | ManufacturingBox.findToolListItemWithToolInfoByBillPk(BillPK billPk, java.lang.String languageCode, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ToolListVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ToolListVO

Packages that use ToolListVO
bb.common
bb.common.box

Uses of ToolListVO in bb.common

Methods in bb.common that return ToolListVO
 ToolListVO ToolListItemVO.getToolListInfo()

Methods in bb.common with parameters of type ToolListVO
 void ToolListItemVO.setToolListInfo(ToolListVO toolListInfo)

Uses of ToolListVO in bb.common.box

Methods in bb.common.box that return ToolListVO
ToolListVO | ManufacturingBox.addToolList(ToolListVO billVO)
ToolListVO | ManufacturingBox.getParentToolList(ToolListItemVO billItemVO)
ToolListVO | ManufacturingBox.getToolList(BillPK billPk)
ToolListVO | ManufacturingBox.updateToolList(ToolListVO billVO)

Methods in bb.common.box with parameters of type ToolListVO
ToolListVO | ManufacturingBox.addToolList(ToolListVO billVO)
void | ManufacturingBox.deleteToolList(ToolListVO billVO)
void | ManufacturingBox.setParentToolList(ToolListVO billVO, ToolListItemVO billItemVO)
ToolListVO | ManufacturingBox.updateToolList(ToolListVO billVO)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ToolListWithToolInfoResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ToolListWithToolInfoResult

Packages that use ToolListWithToolInfoResult
bb.common
bb.common.box

Uses of ToolListWithToolInfoResult in bb.common

Subclasses of ToolListWithToolInfoResult in bb.common
 class ToolListDetailCostWithToolInfoResult

Constructors in bb.common with parameters of type ToolListWithToolInfoResult
ToolListDetailCostWithToolInfoResult(ToolListWithToolInfoResult vo)

Uses of ToolListWithToolInfoResult in bb.common.box

Methods in bb.common.box that return ToolListWithToolInfoResult
 ToolListWithToolInfoResult ManufacturingBox.getToolListWithToolInfoByBillPk(BillPK billPk, java.lang.String languageCode)

Methods in bb.common.box that return types with arguments of type ToolListWithToolInfoResult
java.util.Collection<ToolListWithToolInfoResult> | ManufacturingBox.findAllToolListsWithToolInfo(java.lang.String languageCode, int firstIndex, int maxLength)
java.util.Collection<ToolListWithToolInfoResult> | ManufacturingBox.findToolListswithToolInfoByBillNumberLike(java.lang.String bnRegex, java.lang.String billType, java.lang.String languageCode, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ToolManufacturerVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ToolManufacturerVO

Packages that use ToolManufacturerVO
bb.common.box

Uses of ToolManufacturerVO in bb.common.box

Methods in bb.common.box that return ToolManufacturerVO
ToolManufacturerVO | ManufacturingBox.InitToolManufacturerVoByAddressId(PartPK partPk, java.lang.String manufacturerId)
ToolManufacturerVO | ManufacturingBox.updateToolManufacturer(java.util.Set partManufacturerSet, PartPK partPk)

Methods in bb.common.box that return types with arguments of type ToolManufacturerVO
 java.util.Collection<ToolManufacturerVO> ManufacturingBox.findToolManufacturersByPartPk(PartPK partPk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ToolOnhandVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ToolOnhandVO

Packages that use ToolOnhandVO
bb.common
bb.common.box

Uses of ToolOnhandVO in bb.common

Methods in bb.common that return ToolOnhandVO
 ToolOnhandVO ToolOnhandWithAverageCostResult.getToolOnhandVo()

Methods in bb.common with parameters of type ToolOnhandVO
 void ToolOnhandWithAverageCostResult.setToolOnhandVo(ToolOnhandVO toolOnhandVo)

Uses of ToolOnhandVO in bb.common.box

Methods in bb.common.box that return types with arguments of type ToolOnhandVO
java.util.Collection<ToolOnhandVO> | WarehouseBox.findToolOnhandByPk(PartPK pk)
java.util.Collection<ToolOnhandVO> | WarehouseBox.updateToolOnhandDetail(java.util.HashSet onhandDetailVo, PartPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ToolOnhandWithAverageCostResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ToolOnhandWithAverageCostResult

Packages that use ToolOnhandWithAverageCostResult
bb.common.box

Uses of ToolOnhandWithAverageCostResult in bb.common.box

Method parameters in bb.common.box with type arguments of type ToolOnhandWithAverageCostResult
 void CompanyBox.importTempToolInventory(java.util.ArrayList<ToolOnhandWithAverageCostResult> datas)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ToolVendorVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ToolVendorVO

Packages that use ToolVendorVO
bb.common.box

Uses of ToolVendorVO in bb.common.box

Methods in bb.common.box that return ToolVendorVO
ToolVendorVO | ManufacturingBox.InitToolVendorVoByAddressId(PartPK partPk, java.lang.String vendorId)
ToolVendorVO | ManufacturingBox.updateToolVendor(java.util.Set partVendorVoSet, PartPK partPk)

Methods in bb.common.box that return types with arguments of type ToolVendorVO
 java.util.Collection<ToolVendorVO> ManufacturingBox.findToolVendorsByPartPk(PartPK partPk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ToolVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ToolVO

Packages that use ToolVO
bb.common
bb.common.box

Uses of ToolVO in bb.common

Methods in bb.common that return ToolVO
 ToolVO ToolListInfoVO.getTool()

Methods in bb.common with parameters of type ToolVO
 void ToolListInfoVO.setTool(ToolVO toolVO)

Constructors in bb.common with parameters of type ToolVO
ToolListInfoVO(BillPK pk, java.lang.String lastChangeUser, ToolVO toolVO)
full constructor

Uses of ToolVO in bb.common.box

Methods in bb.common.box that return ToolVO
ToolVO | ManufacturingBox.addTool(ToolVO vo)
ToolVO | ManufacturingBox.getToolByPk(PartPK pk)
ToolVO | ManufacturingBox.updateTool(ToolVO toolVO)

Methods in bb.common.box with parameters of type ToolVO
ToolVO | ManufacturingBox.addTool(ToolVO vo)
ToolVO | ManufacturingBox.updateTool(ToolVO toolVO)

Method parameters in bb.common.box with type arguments of type ToolVO
 void CompanyBox.importTempTool(java.util.ArrayList<ToolVO> datas)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ToolWhereUsedItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ToolWhereUsedItemResult

No usage of bb.common.ToolWhereUsedItemResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ToolWhereUsedResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ToolWhereUsedResult

Packages that use ToolWhereUsedResult
bb.common.box

Uses of ToolWhereUsedResult in bb.common.box

Methods in bb.common.box that return ToolWhereUsedResult
 ToolWhereUsedResult ManufacturingBox.findToolWhereIsUsed(PartPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ToolWithManufacturerInfoResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ToolWithManufacturerInfoResult

Packages that use ToolWithManufacturerInfoResult
bb.common.box

Uses of ToolWithManufacturerInfoResult in bb.common.box

Methods in bb.common.box that return types with arguments of type ToolWithManufacturerInfoResult
java.util.Collection<ToolWithManufacturerInfoResult> | ManufacturingBox.findToolsByManufacturerId(java.lang.String mfgIdRegex, int firstIndex, int maxLength)
java.util.Collection<ToolWithManufacturerInfoResult> | ManufacturingBox.findToolsByManufacturerPn(java.lang.String mpnRegex, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ToolWithOnhandsVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ToolWithOnhandsVO

Packages that use ToolWithOnhandsVO
bb.common.box

Uses of ToolWithOnhandsVO in bb.common.box

Methods in bb.common.box that return ToolWithOnhandsVO
 ToolWithOnhandsVO ManufacturingBox.getToolOnhands(PartPK pk)

Methods in bb.common.box with parameters of type ToolWithOnhandsVO
 void ManufacturingBox.updateToolWithOnhands(ToolWithOnhandsVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.TotalAmountInPOByRefDoc

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.TotalAmountInPOByRefDoc

Packages that use TotalAmountInPOByRefDoc
bb.common.box

Uses of TotalAmountInPOByRefDoc in bb.common.box

Methods in bb.common.box that return types with arguments of type TotalAmountInPOByRefDoc
java.util.Collection<TotalAmountInPOByRefDoc> | PurchasingBox.findTotalPOByProject(java.lang.String startWith, java.lang.String project, java.util.Date fromDate, java.util.Date toDate, java.lang.String dateType, java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<TotalAmountInPOByRefDoc> | PurchasingBox.findTotalPOByRelatedDoc(java.lang.String startWith, java.lang.String refDoc, java.util.Date fromDate, java.util.Date toDate, java.lang.String dateType, java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<TotalAmountInPOByRefDoc> | PurchasingBox.findTotalPOItemByRefDoc1(java.lang.String startWith, java.lang.String refDoc, java.util.Date fromDate, java.util.Date toDate, java.lang.String dateType, java.lang.String status, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.TotalByDateResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.TotalByDateResult

Packages that use TotalByDateResult
bb.common.box

Uses of TotalByDateResult in bb.common.box

Methods in bb.common.box that return types with arguments of type TotalByDateResult
java.util.Collection<TotalByDateResult> | PurchasingBox.findPoTotalByDateResults(java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String status, java.lang.String partNumberLike, java.lang.String partType, java.lang.String shipto, java.lang.String vendorId, java.lang.String project, java.lang.String requester, java.lang.String buyer, java.lang.String currency, java.lang.String relatedDoc, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isHold, java.lang.String productCode)
java.util.Collection<TotalByDateResult> | SalesBox.findQuoteTotalByDateResults(PartPK partPk, java.lang.String quoteNumber, java.lang.String customerRFQNumber, java.lang.String customerId, java.lang.String includeCustomerIds, java.lang.String excludeCustomerIds, java.lang.String salesMan, java.util.Date fromDate, java.util.Date toDate, java.lang.String status, java.lang.String currency)
java.util.Collection<TotalByDateResult> | WarehouseBox.findShipperItemListResultsTotal(java.util.Date fromDate, java.util.Date toDate, java.lang.String snNumber, java.lang.String soNumber, java.lang.String partNumber, java.lang.String partType, java.lang.String customerId, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String[] branchWarehouses)
java.util.Collection<TotalByDateResult> | SalesBox.findSoTotalByDateResults(java.lang.String partNumberLike, java.lang.String partType, java.lang.String customerIdLike, java.lang.String includeCustomerIds, java.lang.String excludeCustomerIds, java.lang.String salesMan, java.lang.String status, java.lang.String productCode, java.lang.String commodityCode, java.lang.String projectName, java.lang.String dateColumn, java.util.Date fromDate, java.util.Date toDate, java.lang.String currency, java.lang.String salesCodeId, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isHold, java.lang.String state, java.lang.String incotermPort)
java.util.Collection<TotalByDateResult> | PurchasingBox.getAllPurchaseOrderStatisticsTotal(java.lang.String project, java.lang.String relatedDoc, java.lang.String vendorName, java.lang.String requester, java.lang.String contact)
java.util.Collection<TotalByDateResult> | AccountingBox.getAPTotal(java.lang.String apNumber, java.lang.String vendorId, java.lang.String buyer, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, java.util.Date from, java.util.Date to)
java.util.Collection<TotalByDateResult> | AccountingBox.getDMTotal(java.lang.String apNumber, java.lang.String vendorId, java.lang.String buyer, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, java.util.Date from, java.util.Date to)
java.util.Collection<TotalByDateResult> | AccountingBox.getEPTotal(java.lang.String apNumber, java.lang.String vendorId, java.lang.String buyer, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, java.util.Date from, java.util.Date to)
java.util.Collection<TotalByDateResult> | PurchasingBox.getOpenPurchaseOrderItemByShipViaTotal(java.lang.String vendorId, java.lang.String shipVia)
java.util.Collection<TotalByDateResult> | PurchasingBox.getPastDuePurchaseOrderItemByShipViaTotal(java.lang.String vendorId, java.lang.String shipVia)
java.util.Collection<TotalByDateResult> | PurchasingBox.getPurchaseOrderTotalResultByRelatedDoc(java.lang.String startWith, java.lang.String status, java.lang.String dateType, java.util.Date startDate, java.util.Date toDate, java.lang.String relatedDoc)
java.util.Collection<TotalByDateResult> | WarehouseBox.getTotalPOReceiverResult(java.lang.String poNumber, java.lang.String project, java.lang.String vendorId, java.lang.String pn, java.lang.String pa, java.lang.String paFrom, java.util.Date fromDate, java.util.Date toDate, java.lang.String status, java.lang.String currency, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String[] branchWarehouses)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.TraceableCategoriesVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.TraceableCategoriesVO

Packages that use TraceableCategoriesVO
bb.common
bb.common.box

Uses of TraceableCategoriesVO in bb.common

Methods in bb.common that return TraceableCategoriesVO
 TraceableCategoriesVO PartTraceableCategoryVO.getCategoryDescription()

Methods in bb.common with parameters of type TraceableCategoriesVO
 void PartTraceableCategoryVO.setCategoryDescription(TraceableCategoriesVO categoryDescriptionVO)

Uses of TraceableCategoriesVO in bb.common.box

Methods in bb.common.box that return TraceableCategoriesVO
TraceableCategoriesVO | EngineeringBox.addTraceableCategories(TraceableCategoriesVO traceableCategoriesVO) Traceable****************************************************************
TraceableCategoriesVO | EngineeringBox.getTraceableCategoriesByPk(java.lang.String categoryId)
TraceableCategoriesVO | EngineeringBox.updateTraceableCategories(java.lang.String oldCategoryId, TraceableCategoriesVO traceableCategoriesVO)

Methods in bb.common.box that return types with arguments of type TraceableCategoriesVO
 java.util.Collection<TraceableCategoriesVO> EngineeringBox.findAllTraceableCategories(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type TraceableCategoriesVO
TraceableCategoriesVO | EngineeringBox.addTraceableCategories(TraceableCategoriesVO traceableCategoriesVO) Traceable****************************************************************
void | EngineeringBox.deleteTraceableCategories(TraceableCategoriesVO traceableCategoriesVO)
TraceableCategoriesVO | EngineeringBox.updateTraceableCategories(java.lang.String oldCategoryId, TraceableCategoriesVO traceableCategoriesVO)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.TraceableSpecsVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.TraceableSpecsVO

Packages that use TraceableSpecsVO
bb.common
bb.common.box

Uses of TraceableSpecsVO in bb.common

Methods in bb.common that return TraceableSpecsVO
 TraceableSpecsVO PartTraceableSpecVO.getSpecification()

Methods in bb.common with parameters of type TraceableSpecsVO
 void PartTraceableSpecVO.setSpecification(TraceableSpecsVO specificationVO)

Uses of TraceableSpecsVO in bb.common.box

Methods in bb.common.box that return TraceableSpecsVO
TraceableSpecsVO | EngineeringBox.addTraceableSpecs(TraceableSpecsVO traceableSpecsVO)
TraceableSpecsVO | EngineeringBox.getTraceableSpecsByPk(java.lang.Short specId)
TraceableSpecsVO | EngineeringBox.updateTraceableSpecs(java.lang.Short oldSpecId, TraceableSpecsVO traceableSpecsVO)

Methods in bb.common.box that return types with arguments of type TraceableSpecsVO
 java.util.Collection<TraceableSpecsVO> EngineeringBox.findAllTraceableSpecs(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type TraceableSpecsVO
TraceableSpecsVO | EngineeringBox.addTraceableSpecs(TraceableSpecsVO traceableSpecsVO)
void | EngineeringBox.deleteTraceableSpecs(TraceableSpecsVO traceableSpecsVO)
TraceableSpecsVO | EngineeringBox.updateTraceableSpecs(java.lang.Short oldSpecId, TraceableSpecsVO traceableSpecsVO)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.TransferOrderApprovalVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.TransferOrderApprovalVO

Packages that use TransferOrderApprovalVO
bb.common.box

Uses of TransferOrderApprovalVO in bb.common.box

Methods in bb.common.box that return TransferOrderApprovalVO
TransferOrderApprovalVO | WarehouseBox.addTransferOrderApproval(TransferOrderApprovalVO vo)
TransferOrderApprovalVO | WarehouseBox.getTransferOrderApprovalByEmployeeId(java.lang.String employeeId)

Methods in bb.common.box that return types with arguments of type TransferOrderApprovalVO
 java.util.Collection<TransferOrderApprovalVO> WarehouseBox.findAllTransferOrderApproval(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type TransferOrderApprovalVO
TransferOrderApprovalVO | WarehouseBox.addTransferOrderApproval(TransferOrderApprovalVO vo)
void | WarehouseBox.updateTransferOrderApproval(TransferOrderApprovalVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.TransferOrderItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.TransferOrderItemListResult

Packages that use TransferOrderItemListResult
bb.common.box

Uses of TransferOrderItemListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type TransferOrderItemListResult
 java.util.Collection<TransferOrderItemListResult> WarehouseBox.findTransferOrderItemsByDate(java.lang.String transferOrderNumber, java.lang.String transferType, java.lang.String partNumber, java.lang.String partType, java.lang.String status, java.lang.String dateType, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.TransferOrderItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.TransferOrderItemPK

Packages that use TransferOrderItemPK
bb.common

Uses of TransferOrderItemPK in bb.common

Methods in bb.common that return TransferOrderItemPK
 TransferOrderItemPK TransferOrderItemVO.getPk()

Methods in bb.common with parameters of type TransferOrderItemPK
 void TransferOrderItemVO.setPk(TransferOrderItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.TransferOrderItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.TransferOrderItemVO

Packages that use TransferOrderItemVO
bb.common
bb.common.box

Uses of TransferOrderItemVO in bb.common

Methods in bb.common that return types with arguments of type TransferOrderItemVO
 java.util.Set<TransferOrderItemVO> TransferOrderVO.getTransferOrderItems()

Method parameters in bb.common with type arguments of type TransferOrderItemVO
 void TransferOrderVO.setTransferOrderItems(java.util.Set<TransferOrderItemVO> transferOrderItems)

Uses of TransferOrderItemVO in bb.common.box

Methods in bb.common.box that return TransferOrderItemVO
 TransferOrderItemVO WarehouseBox.initTransferOrderItem(TransferOrderVO toVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.TransferOrderListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.TransferOrderListResult

Packages that use TransferOrderListResult
bb.common.box

Uses of TransferOrderListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type TransferOrderListResult
java.util.Collection<TransferOrderListResult> | WarehouseBox.findOpenTransferOrderForShipper(java.lang.String toNumber, int firstIndex, int maxLength)
java.util.Collection<TransferOrderListResult> | WarehouseBox.findTransferOrderByDate(java.lang.String transferOrderNumber, java.lang.String fromAddressId, java.lang.String toAddressId, java.lang.String transferType, java.lang.String status, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.TransferOrderVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.TransferOrderVO

Packages that use TransferOrderVO
bb.common.box

Uses of TransferOrderVO in bb.common.box

Methods in bb.common.box that return TransferOrderVO
TransferOrderVO | WarehouseBox.addTransferOrder(TransferOrderVO vo)
TransferOrderVO | WarehouseBox.approvalTransferOrder(TransferOrderVO toVO)
TransferOrderVO | WarehouseBox.getTransferOrderByPk(java.lang.String transferOrderNumber)

Methods in bb.common.box with parameters of type TransferOrderVO
TransferOrderVO | WarehouseBox.addTransferOrder(TransferOrderVO vo)
TransferOrderVO | WarehouseBox.approvalTransferOrder(TransferOrderVO toVO)
TransferOrderItemVO | WarehouseBox.initTransferOrderItem(TransferOrderVO toVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool)
void | WarehouseBox.updateTransferOrder(TransferOrderVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.TransferReceiverItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.TransferReceiverItemListResult

Packages that use TransferReceiverItemListResult
bb.common.box

Uses of TransferReceiverItemListResult in bb.common.box

Methods in bb.common.box that return TransferReceiverItemListResult
 TransferReceiverItemListResult WarehouseBox.findTransferReceiverItemsTotalByDate(java.lang.String transferReceiverNumber, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String status, java.util.Date from, java.util.Date to, java.lang.String fromAddressId, java.lang.String toAddressId)

Methods in bb.common.box that return types with arguments of type TransferReceiverItemListResult
java.util.Collection<TransferReceiverItemListResult> | WarehouseBox.findTransferReceiverItems(java.lang.String transferOrderNumber)
java.util.Collection<TransferReceiverItemListResult> | WarehouseBox.findTransferReceiverItemsByDate(java.lang.String transferReceiverNumber, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String status, java.util.Date from, java.util.Date to, java.lang.String fromAddressId, java.lang.String toAddressId, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.TransferReceiverItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.TransferReceiverItemPK

Packages that use TransferReceiverItemPK
bb.common
bb.common.box

Uses of TransferReceiverItemPK in bb.common

Methods in bb.common that return TransferReceiverItemPK
 TransferReceiverItemPK TransferReceiverItemVO.getPk()

Methods in bb.common with parameters of type TransferReceiverItemPK
 void TransferReceiverItemVO.setPk(TransferReceiverItemPK pk)

Uses of TransferReceiverItemPK in bb.common.box

Methods in bb.common.box with parameters of type TransferReceiverItemPK
 TransferReceiverItemVO WarehouseBox.getTransferReceiverItemByPk(TransferReceiverItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.TransferReceiverItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.TransferReceiverItemVO

Packages that use TransferReceiverItemVO
bb.common
bb.common.box

Uses of TransferReceiverItemVO in bb.common

Methods in bb.common that return types with arguments of type TransferReceiverItemVO
 java.util.Set<TransferReceiverItemVO> TransferReceiverVO.getTransferReceiverItems()

Method parameters in bb.common with type arguments of type TransferReceiverItemVO
 void TransferReceiverVO.setTransferReceiverItems(java.util.Set<TransferReceiverItemVO> transferReceiverItems)

Uses of TransferReceiverItemVO in bb.common.box

Methods in bb.common.box that return TransferReceiverItemVO
 TransferReceiverItemVO WarehouseBox.getTransferReceiverItemByPk(TransferReceiverItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.TransferReceiverListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.TransferReceiverListResult

Packages that use TransferReceiverListResult
bb.common.box

Uses of TransferReceiverListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type TransferReceiverListResult
java.util.Collection<TransferReceiverListResult> | WarehouseBox.findTransferReceiverListResultsbyDate(java.lang.String transferReceiverNumber, java.lang.String transferShipperNumber, java.lang.String transferOrderNumber, java.lang.String status, java.lang.String fromAddressId, java.lang.String toAddressId, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)
java.util.Collection<TransferReceiverListResult> | WarehouseBox.makeTransferReceiver(ReceiverAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.TransferReceiverVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.TransferReceiverVO

Packages that use TransferReceiverVO
bb.common.box

Uses of TransferReceiverVO in bb.common.box

Methods in bb.common.box that return TransferReceiverVO
 TransferReceiverVO WarehouseBox.getTransferReceiverById(java.lang.String receiverNumber)

Methods in bb.common.box with parameters of type TransferReceiverVO
 java.lang.String WarehouseBox.updateTransferReceiver(TransferReceiverVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.TransferShipperItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.TransferShipperItemListResult

Packages that use TransferShipperItemListResult
bb.common.box

Uses of TransferShipperItemListResult in bb.common.box

Methods in bb.common.box that return TransferShipperItemListResult
 TransferShipperItemListResult WarehouseBox.findTransferShipperItemsTotalByDate(java.lang.String transferShipperNumber, java.lang.String transferOrderNumber, java.lang.String fromAddressId, java.lang.String toAddressId, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String status, java.util.Date from, java.util.Date to)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.TransferShipperItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.TransferShipperItemPK

Packages that use TransferShipperItemPK
bb.common
bb.common.box

Uses of TransferShipperItemPK in bb.common

Methods in bb.common that return TransferShipperItemPK
TransferShipperItemPK | TransferShipperItemVO.getPk()
TransferShipperItemPK | BB2PartInSTOItemResult.getPk()

Methods in bb.common with parameters of type TransferShipperItemPK
void | TransferShipperItemVO.setPk(TransferShipperItemPK pk)
void | BB2PartInSTOItemResult.setPk(TransferShipperItemPK pk)

Uses of TransferShipperItemPK in bb.common.box

Methods in bb.common.box with parameters of type TransferShipperItemPK
 TransferShipperItemVO WarehouseBox.getTransferShipperItemByPk(TransferShipperItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.TransferShipperItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.TransferShipperItemVO

Packages that use TransferShipperItemVO
bb.common
bb.common.box

Uses of TransferShipperItemVO in bb.common

Methods in bb.common that return types with arguments of type TransferShipperItemVO
 java.util.Set<TransferShipperItemVO> TransferShipperVO.getTransferShipperItems()

Method parameters in bb.common with type arguments of type TransferShipperItemVO
 void TransferShipperVO.setTransferShipperItems(java.util.Set<TransferShipperItemVO> transferShipperItems)

Uses of TransferShipperItemVO in bb.common.box

Methods in bb.common.box that return TransferShipperItemVO
 TransferShipperItemVO WarehouseBox.getTransferShipperItemByPk(TransferShipperItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.TransferShipperListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.TransferShipperListResult

Packages that use TransferShipperListResult
bb.common.box

Uses of TransferShipperListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type TransferShipperListResult
java.util.Collection<TransferShipperListResult> | WarehouseBox.findTransferShipperByDate(java.lang.String transferShipperNumber, java.lang.String transferOrderNumber, java.lang.String fromAddressId, java.lang.String toAddressId, java.lang.String status, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)
java.util.Collection<TransferShipperListResult> | WarehouseBox.findTransferShipperItems(java.lang.String transferOrderNumber)
java.util.Collection<TransferShipperListResult> | WarehouseBox.findTransferShipperItemsByDate(java.lang.String transferShipperNumber, java.lang.String transferOrderNumber, java.lang.String fromAddressId, java.lang.String toAddressId, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String status, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.TransferShipperVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.TransferShipperVO

Packages that use TransferShipperVO
bb.common.box

Uses of TransferShipperVO in bb.common.box

Methods in bb.common.box that return TransferShipperVO
TransferShipperVO | WarehouseBox.getTransferShipper(java.lang.String transferShipperNumber)
TransferShipperVO | WarehouseBox.updateTransferShipper(TransferShipperVO vo)

Methods in bb.common.box with parameters of type TransferShipperVO
 TransferShipperVO WarehouseBox.updateTransferShipper(TransferShipperVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.TwelveMonthCashFlowReportResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.TwelveMonthCashFlowReportResult

Packages that use TwelveMonthCashFlowReportResult
bb.common.box

Uses of TwelveMonthCashFlowReportResult in bb.common.box

Methods in bb.common.box that return TwelveMonthCashFlowReportResult
 TwelveMonthCashFlowReportResult AccountingBox.findTwelveMonthCashFlowReport(java.lang.String monthYear, java.lang.String companyUnitId, int grace)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.UnitVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.UnitVO

Packages that use UnitVO
bb.common.box

Uses of UnitVO in bb.common.box

Methods in bb.common.box that return UnitVO
UnitVO | EngineeringBox.addUnit(UnitVO vo)
UnitVO | EngineeringBox.getUnitByPk(java.lang.Long id)
UnitVO | EngineeringBox.updateUnit(UnitVO vo)

Methods in bb.common.box that return types with arguments of type UnitVO
 java.util.Collection<UnitVO> EngineeringBox.findUnit(java.lang.String unitName, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type UnitVO
UnitVO | EngineeringBox.addUnit(UnitVO vo)
void | EngineeringBox.deleteUnit(UnitVO vo)
UnitVO | EngineeringBox.updateUnit(UnitVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.UpdatePhysicalInventoryAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.UpdatePhysicalInventoryAgent

No usage of bb.common.UpdatePhysicalInventoryAgent

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.User2UserAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.User2UserAgent

Packages that use User2UserAgent
bb.common.box

Uses of User2UserAgent in bb.common.box

Methods in bb.common.box with parameters of type User2UserAgent
 java.lang.String SecurityBox.copyUserToUser(User2UserAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.UserGroupVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.UserGroupVO

Packages that use UserGroupVO
bb.common.box

Uses of UserGroupVO in bb.common.box

Methods in bb.common.box that return UserGroupVO
UserGroupVO | CompanyBox.addUserGroup(UserGroupVO vo)
UserGroupVO | CompanyBox.getUserGroupByPk(java.lang.String id)

Methods in bb.common.box that return types with arguments of type UserGroupVO
java.util.Collection<UserGroupVO> | CompanyBox.findGroupsBySelf(int firstIndex, int maxLength)
java.util.Collection<UserGroupVO> | CompanyBox.findGroupsByUserName(java.lang.String userName, int firstIndex, int maxLength)
java.util.Collection<UserGroupVO> | CompanyBox.findSystemUserGroup(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type UserGroupVO
UserGroupVO | CompanyBox.addUserGroup(UserGroupVO vo)
void | CompanyBox.deleteUserGroup(UserGroupVO vo)
void | CompanyBox.updateUserGroup(UserGroupVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.UserRolePermissionListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.UserRolePermissionListResult

Packages that use UserRolePermissionListResult
bb.common.box

Uses of UserRolePermissionListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type UserRolePermissionListResult
 java.util.Collection<UserRolePermissionListResult> SecurityBox.findUserRoleByPermission(java.lang.String permissionId, java.lang.String language, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.UserRolePK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.UserRolePK

Packages that use UserRolePK
bb.common

Uses of UserRolePK in bb.common

Methods in bb.common that return UserRolePK
 UserRolePK UserRoleVO.getPk()

Constructors in bb.common with parameters of type UserRolePK
UserRoleVO(UserRolePK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.UserRoleVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.UserRoleVO

No usage of bb.common.UserRoleVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.VendorCategoriesVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.VendorCategoriesVO

Packages that use VendorCategoriesVO
bb.common.box

Uses of VendorCategoriesVO in bb.common.box

Methods in bb.common.box that return VendorCategoriesVO
VendorCategoriesVO | AddressBox.addVendorCategories(VendorCategoriesVO vo)
VendorCategoriesVO | AddressBox.getVendorCategoriesById(java.lang.String vendorCategory)
VendorCategoriesVO | AddressBox.updateVendorCategories(VendorCategoriesVO vo)

Methods in bb.common.box that return types with arguments of type VendorCategoriesVO
 java.util.Collection<VendorCategoriesVO> AddressBox.findVendorCategories(java.lang.String vendorCategory, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type VendorCategoriesVO
VendorCategoriesVO | AddressBox.addVendorCategories(VendorCategoriesVO vo)
VendorCategoriesVO | AddressBox.updateVendorCategories(VendorCategoriesVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.VendorContractPriceItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.VendorContractPriceItemPK

Packages that use VendorContractPriceItemPK
bb.common
bb.common.box

Uses of VendorContractPriceItemPK in bb.common

Methods in bb.common that return VendorContractPriceItemPK
 VendorContractPriceItemPK VendorContractPriceItemVO.getPk()

Methods in bb.common with parameters of type VendorContractPriceItemPK
 void VendorContractPriceItemVO.setPk(VendorContractPriceItemPK pk)

Constructors in bb.common with parameters of type VendorContractPriceItemPK
VendorContractPriceItemVO(VendorContractPriceItemPK pk, java.lang.String contractName, java.math.BigDecimal listPrice, java.math.BigDecimal discount, java.lang.String comments)
minimal constructor

Uses of VendorContractPriceItemPK in bb.common.box

Methods in bb.common.box with parameters of type VendorContractPriceItemPK
VendorContractPriceItemVO | PurchasingBox.getVendorContractPriceItem(VendorContractPriceItemPK pk)
boolean | PurchasingBox.isVendorContractPriceItemExistent(VendorContractPriceItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.VendorContractPriceItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.VendorContractPriceItemVO

Packages that use VendorContractPriceItemVO
bb.common.box

Uses of VendorContractPriceItemVO in bb.common.box

Methods in bb.common.box that return VendorContractPriceItemVO
VendorContractPriceItemVO | PurchasingBox.addVendorContractPriceItem(VendorContractPriceItemVO vo)
VendorContractPriceItemVO | PurchasingBox.getVendorContractPriceItem(VendorContractPriceItemPK pk)
VendorContractPriceItemVO | PurchasingBox.updateVendorContractPriceItem(VendorContractPriceItemVO vo)

Methods in bb.common.box that return types with arguments of type VendorContractPriceItemVO
java.util.Collection<VendorContractPriceItemVO> | PurchasingBox.addVendorContractPriceItems(java.util.ArrayList list)
java.util.Collection<VendorContractPriceItemVO> | PurchasingBox.findVendorContractItemsByContractNumber(java.lang.String contractNumber, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type VendorContractPriceItemVO
VendorContractPriceItemVO | PurchasingBox.addVendorContractPriceItem(VendorContractPriceItemVO vo)
void | PurchasingBox.deleteVendorContractPriceItem(VendorContractPriceItemVO cpiVO)
VendorContractPriceItemVO | PurchasingBox.updateVendorContractPriceItem(VendorContractPriceItemVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.VendorContractPriceVendorPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.VendorContractPriceVendorPK

Packages that use VendorContractPriceVendorPK
bb.common
bb.common.box

Uses of VendorContractPriceVendorPK in bb.common

Methods in bb.common that return VendorContractPriceVendorPK
 VendorContractPriceVendorPK VendorContractPriceVendorVO.getPk()

Methods in bb.common with parameters of type VendorContractPriceVendorPK
 void VendorContractPriceVendorVO.setPk(VendorContractPriceVendorPK pk)

Constructors in bb.common with parameters of type VendorContractPriceVendorPK
VendorContractPriceVendorVO(VendorContractPriceVendorPK pk, java.lang.String contractName)
minimal constructor
VendorContractPriceVendorVO(VendorContractPriceVendorPK pk, java.lang.String contractName, CustomerVendorAddressInfoVO vendorInfo)
full constructor

Uses of VendorContractPriceVendorPK in bb.common.box

Methods in bb.common.box with parameters of type VendorContractPriceVendorPK
VendorContractPriceVendorVO | PurchasingBox.getVendorContractPriceVendor(VendorContractPriceVendorPK pk)
boolean | PurchasingBox.isVendorContractPriceVendorExistent(VendorContractPriceVendorPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.VendorContractPriceVendorVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.VendorContractPriceVendorVO

Packages that use VendorContractPriceVendorVO
bb.common.box

Uses of VendorContractPriceVendorVO in bb.common.box

Methods in bb.common.box that return VendorContractPriceVendorVO
VendorContractPriceVendorVO | PurchasingBox.addVendorContractPriceVendor(VendorContractPriceVendorVO vo)
VendorContractPriceVendorVO | PurchasingBox.getVendorContractPriceVendor(VendorContractPriceVendorPK pk)
VendorContractPriceVendorVO | PurchasingBox.updateVendorContractPriceVendor(VendorContractPriceVendorVO vo)

Methods in bb.common.box that return types with arguments of type VendorContractPriceVendorVO
java.util.Collection<VendorContractPriceVendorVO> | PurchasingBox.findContractVendorsByContractNumber(java.lang.String contractNumber, int firstIndex, int maxLength)
java.util.Collection<VendorContractPriceVendorVO> | PurchasingBox.findVendorContractsByAddressId(java.lang.String addressIdRegex, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type VendorContractPriceVendorVO
VendorContractPriceVendorVO | PurchasingBox.addVendorContractPriceVendor(VendorContractPriceVendorVO vo)
void | PurchasingBox.deleteVendorContractPriceVendor(VendorContractPriceVendorVO cpcVO)
VendorContractPriceVendorVO | PurchasingBox.updateVendorContractPriceVendor(VendorContractPriceVendorVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.VendorContractPriceVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.VendorContractPriceVO

Packages that use VendorContractPriceVO
bb.common.box

Uses of VendorContractPriceVO in bb.common.box

Methods in bb.common.box that return VendorContractPriceVO
 VendorContractPriceVO PurchasingBox.getVendorContractPriceById(java.lang.String cpNumber)

Methods in bb.common.box that return types with arguments of type VendorContractPriceVO
java.util.Collection<VendorContractPriceVO> | PurchasingBox.findAllVendorContracts(int firstIndex, int maxLength)
java.util.Collection<VendorContractPriceVO> | PurchasingBox.findVendorContractsByContractNumber(java.lang.String contractNumber, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type VendorContractPriceVO
java.lang.String | PurchasingBox.addVendorContractPrice(VendorContractPriceVO vo)
void | PurchasingBox.deleteVendorContractPrice(VendorContractPriceVO cpVO)
java.lang.String | PurchasingBox.updateVendorContractPrice(VendorContractPriceVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.VendorCriticalLevelVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.VendorCriticalLevelVO

Packages that use VendorCriticalLevelVO
bb.common.box

Uses of VendorCriticalLevelVO in bb.common.box

Methods in bb.common.box that return VendorCriticalLevelVO
VendorCriticalLevelVO | AddressBox.addVendorCriticalLevel(VendorCriticalLevelVO vo)
VendorCriticalLevelVO | AddressBox.getVendorCriticalLevelById(java.lang.String vendorCategory)
VendorCriticalLevelVO | AddressBox.updateVendorCriticalLevel(VendorCriticalLevelVO vo)

Methods in bb.common.box that return types with arguments of type VendorCriticalLevelVO
 java.util.Collection<VendorCriticalLevelVO> AddressBox.findVendorCriticalLevel(java.lang.String vendorCategory, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type VendorCriticalLevelVO
VendorCriticalLevelVO | AddressBox.addVendorCriticalLevel(VendorCriticalLevelVO vo)
VendorCriticalLevelVO | AddressBox.updateVendorCriticalLevel(VendorCriticalLevelVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.VendorGroupUserVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.VendorGroupUserVO

Packages that use VendorGroupUserVO
bb.common.box

Uses of VendorGroupUserVO in bb.common.box

Methods in bb.common.box that return VendorGroupUserVO
VendorGroupUserVO | AddressBox.addVendorGroupUser(VendorGroupUserVO vo)
VendorGroupUserVO | AddressBox.getVendorGroupUser(java.lang.String userName)

Methods in bb.common.box that return types with arguments of type VendorGroupUserVO
 java.util.Collection<VendorGroupUserVO> AddressBox.findVgUser(java.lang.String addressId, java.lang.String userName, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type VendorGroupUserVO
VendorGroupUserVO | AddressBox.addVendorGroupUser(VendorGroupUserVO vo)
void | AddressBox.updateVendorGroupUser(VendorGroupUserVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.VendorPartPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.VendorPartPK

Packages that use VendorPartPK
bb.common
bb.common.box

Uses of VendorPartPK in bb.common

Methods in bb.common that return VendorPartPK
 VendorPartPK VendorPartVO.getPk()

Methods in bb.common with parameters of type VendorPartPK
 void VendorPartVO.setPk(VendorPartPK pk)

Constructors in bb.common with parameters of type VendorPartPK
VendorPartVO(VendorPartPK pk)
minimal constructor
VendorPartVO(VendorPartPK pk, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom)
full constructor

Uses of VendorPartPK in bb.common.box

Methods in bb.common.box with parameters of type VendorPartPK
void | WarehouseBox.deleteVendorPart(VendorPartPK pk)
VendorPartVO | WarehouseBox.getVendorPart(VendorPartPK pk)
boolean | WarehouseBox.isVendorPartExistent(VendorPartPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.VendorPartVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.VendorPartVO

Packages that use VendorPartVO
bb.common.box

Uses of VendorPartVO in bb.common.box

Methods in bb.common.box that return VendorPartVO
VendorPartVO | WarehouseBox.addVendorPart(VendorPartVO vo)
VendorPartVO | WarehouseBox.getVendorPart(VendorPartPK pk)

Methods in bb.common.box that return types with arguments of type VendorPartVO
 java.util.Collection<VendorPartVO> WarehouseBox.findVendorParts(java.lang.String vendorPartNumber, java.lang.String vendorPartType, java.lang.String vendorPartFrom, java.lang.String vendorId, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type VendorPartVO
VendorPartVO | WarehouseBox.addVendorPart(VendorPartVO vo)
void | WarehouseBox.updateVendorPart(VendorPartVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.VendorPrepayStatementListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.VendorPrepayStatementListResult

Packages that use VendorPrepayStatementListResult
bb.common.box

Uses of VendorPrepayStatementListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type VendorPrepayStatementListResult
java.util.Collection<VendorPrepayStatementListResult> | AccountingBox.find1To30PrepayStatementByVendorId(java.lang.String vendorId, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<VendorPrepayStatementListResult> | AccountingBox.find31To60PrepayStatementByVendorId(java.lang.String vendorId, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<VendorPrepayStatementListResult> | AccountingBox.find61To90PrepayStatementByVendorId(java.lang.String vendorId, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<VendorPrepayStatementListResult> | AccountingBox.find90PlusPrepayStatementByVendorId(java.lang.String vendorId, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<VendorPrepayStatementListResult> | AccountingBox.findCurrentPrepayStatementByVendorId(java.lang.String vendorId, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<VendorPrepayStatementListResult> | AccountingBox.findVendorPrepayStatementById(java.lang.String vendorId, java.lang.String currency, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<VendorPrepayStatementListResult> | AccountingBox.findVendorPrepayStatementById(java.lang.String vendorId, java.lang.String currency, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.VendorPriceAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.VendorPriceAgent

No usage of bb.common.VendorPriceAgent

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.VendorQtyPricePK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.VendorQtyPricePK

Packages that use VendorQtyPricePK
bb.common
bb.common.box

Uses of VendorQtyPricePK in bb.common

Methods in bb.common that return VendorQtyPricePK
 VendorQtyPricePK VendorQtyPriceVO.getPk()

Methods in bb.common with parameters of type VendorQtyPricePK
 void VendorQtyPriceVO.setPk(VendorQtyPricePK pk)

Uses of VendorQtyPricePK in bb.common.box

Methods in bb.common.box with parameters of type VendorQtyPricePK
void | EngineeringBox.deleteVendorQtyPrice(VendorQtyPricePK pk)
VendorQtyPriceVO | EngineeringBox.getVendorQtyPrice(VendorQtyPricePK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.VendorQtyPriceVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.VendorQtyPriceVO

Packages that use VendorQtyPriceVO
bb.common.box

Uses of VendorQtyPriceVO in bb.common.box

Methods in bb.common.box that return VendorQtyPriceVO
 VendorQtyPriceVO EngineeringBox.getVendorQtyPrice(VendorQtyPricePK pk)

Methods in bb.common.box that return types with arguments of type VendorQtyPriceVO
 java.util.Collection<VendorQtyPriceVO> EngineeringBox.getVendorQtyPrices(BB2Part pk, java.lang.String vendorId)

Methods in bb.common.box with parameters of type VendorQtyPriceVO
void | EngineeringBox.addVendorQtyPrice(VendorQtyPriceVO vo)
void | EngineeringBox.updateVendorQtyPrice(VendorQtyPriceVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.VendorStatementListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.VendorStatementListResult

Packages that use VendorStatementListResult
bb.common.box

Uses of VendorStatementListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type VendorStatementListResult
java.util.Collection<VendorStatementListResult> | AccountingBox.find1To30StatementByVendorId(java.lang.String vendorId, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<VendorStatementListResult> | AccountingBox.find31To60StatementByVendorId(java.lang.String vendorId, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<VendorStatementListResult> | AccountingBox.find61To90StatementByVendorId(java.lang.String vendorId, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<VendorStatementListResult> | AccountingBox.find90PlusStatementByVendorId(java.lang.String vendorId, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<VendorStatementListResult> | AccountingBox.findCurrentStatementByVendorId(java.lang.String vendorId, java.lang.String currency, int firstIndex, int maxLength)
java.util.Collection<VendorStatementListResult> | AccountingBox.findVendorStatementById(java.lang.String vendorId, java.lang.String currency, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<VendorStatementListResult> | AccountingBox.findVendorStatementById(java.lang.String vendorId, java.lang.String currency, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.VendorTotalAmountInPO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.VendorTotalAmountInPO

Packages that use VendorTotalAmountInPO
bb.common
bb.common.box

Uses of VendorTotalAmountInPO in bb.common

Subclasses of VendorTotalAmountInPO in bb.common
 class TotalAmountInPOByRefDoc

Uses of VendorTotalAmountInPO in bb.common.box

Methods in bb.common.box that return types with arguments of type VendorTotalAmountInPO
 java.util.Collection<VendorTotalAmountInPO> PurchasingBox.findVendorPurchaseOrderByDate(java.lang.String vendorId, java.util.Date fromDate, java.util.Date toDate, java.lang.String dateType, java.lang.String status, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.VersionInformation

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.VersionInformation

No usage of bb.common.VersionInformation

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.VO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.VO

Packages that use VO
bb.common

Uses of VO in bb.common

Subclasses of VO in bb.common
class | AccountCreditVO
class | AccountDebitVO
class | AccountingConfigurationVO
class | AccountingInfoDocumentVO
class | AccountingSettingsVO
class | AccountingTransactionTypeVO
class | AccountPayableCheckRunItemVO
class | AccountPayableCheckRunVO
class | AccountPayableCheckVO
class | AccountReceivablePaymentVO
class | AccountsChartAdvanceCategoryVO
class | AccountsChartCategoryListResult
class | AccountsChartCategoryVO
class | AccountsChartMappingVO
class | AccountsChartVO
class | AccountsPayableInfoVO
class | AccountsPayableItemManufacturerVO
class | AccountsPayableItemVO
class | AccountsPayableVO
class | AccountsReceivableInfoVO
class | AccountsReceivableItemManufacturerVO
class | AccountsReceivableItemResult
class | AccountsReceivableItemVO
class | AccountsReceivableVO
class | AddressQualityDocumentsVO
class | AllPartDocumentsVO
class | AppColumnVO
class | ApPrepayItemVO
class | ApPrepayVO
class | ARBoilerplateVO
class | ARPaymentRunItemVO
class | ARPaymentRunVO
class | ArPrepayItemVO
class | ArPrepayVO
class | ArSalesCodeTotalListResult
class | AssetAmortizationExpenseAccountVO
class | AssetDepreciateDetailReport
class | AssetDepreciateVO
class | AssetReportSumResult
class | AssetTypeVO
class | AssetUsageVO
class | AssetVO
class | AuditLogVO
class | AuditPartInQAResult
class | BankReconciliationReportVO
class | BillItemReplacementVO
class | BillItemVO
class | BillLogVO
class | BillVO
class | BizboxBugChangesInfoVO
class | BizboxBugChangesVO
class | BizboxBugInfoVO
class | BizboxBugVO
class | BizboxUserListResult
class | BizboxUserVO
class | BomApprovalVO
class | BuyerCodeVO
class | CarrierVO
class | CashierVO
class | CatalogVO
class | CertificateDescriptionVO
class | ChangeStdCostWorkSheetItemVO
class | ChangeStdCostWorkSheetVO
class | CommonPrintTemplateVO
class | CompanyUnitAccountVO
class | CompanyUnitVO
class | CompanyVO
class | ContractPriceCustomerVO
class | ContractPriceItemVO
class | ContractPriceVO
class | CorrectiveActionRequestVO
class | CurrencyAgent
class | CurrencyExchangeVO
class | CurrencyVO
class | CustomAssetRecordVO
class | CustomAssetVO
class | CustomCheckUpEmployeeVO
class | CustomDepartmentVO
class | CustomEmployeeTrainVO
class | CustomEmployeeVO
class | CustomEmployeeWorkExperienceVO
class | CustomerFeedbackVO
class | CustomerReturnToVendorItemVO
class | CustomerReturnToVendorVO
class | CustomerServiceIncidentItemVO
class | CustomerServiceIncidentVO
class | CustomerVendorAddressInfoVO
class | CustomerVendorAddressVO
class | CustomerVendorContactVO
class | CustomerVendorDescriptionVO
class | CustomerVendorTypeVO
class | CustomGoodsBreedVO
class | CustomGoodsRecordVO
class | CustomJobCategoryGoodsVO
class | CustomJobCategoryVO
class | CustomSearchVO
class | CustomTranslationVO
class | CycleCountStatusVO
class | CycleCountVO
class | DataFilterVO
class | DepartmentLocationForBackflushVO
class | DesignControlDocumentVO
class | DesignControlInfoVO
class | DesignControlVO
class | DisassembleWorkOrderApprovalVO
class | DisassembleWorkOrderDocumentVO
class | DisassembleWorkOrderIssueVO
class | DisassembleWorkOrderItemReceiverVO
class | DisassembleWorkOrderItemVO
class | DisassembleWorkOrderVO
class | DocumentLogVO
class | DocumentServerVO
class | DwfUploadSettingsVO
class | DwgUploadSettingsVO
class | ECNReviewVO
class | ECRReviewVO
class | EjbMethodVO
class | EmployeeCardVO
class | EmployeeEducationResult
class | EmployeeEducationVO
class | EmployeeHomeVO
class | EmployeeJobDescriptionVO
class | EmployeeRecordsVO
class | EmployeeTrainingVO
class | EmployeeWorkExperienceVO
class | EngGroupUserVO
class | EngGroupVO
class | EngineeringChangeDocumentVO
class | EngineeringChangeRequestDocumentVO
class | EngineeringChangeRequestVO
class | EngineeringChangeVO
class | EngineeringSharingImportLogVO
class | EngineeringSharingItemVO
class | EngineeringSharingVO
class | EquipmentVO
class | ExpenseAccountVO
class | ExpenseItemVO
class | ExpenseVO
class | FeedbackAnswerVO
class | FeedbackItemVO
class | FeedbackQuestionVO
class | FiscalYearSettingsVO
class | GeneralLedgerApprovalVO
class | GeneralLedgerCategoryVO
class | GeneralLedgerSettingsVO
class | GeneralLedgerVO
class | GLAutoApproveVO
class | GlCashFlowBudgetVO
class | GlFiscalYearBudgetVO
class | GLItemVO
class | GlMonthBudgetVO
class | GlMonthVO
class | GroupUserVO
class | HelpServerVO
class | HistoricalInventoryVO
class | IcrItemListResult
class | ImportContractPriceData
class | ImportDataVO
class | IncotermVO
class | InspectionConformanceReportItemCheckVO
class | InspectionConformanceReportItemVO
class | InspectionConformanceReportVO
class | InspectionItemVO
class | InspectionReportInfoVO
class | InspectionReportInspectMethodItemVO
class | InspectionReportInspectMethodVO
class | InspectionReportInspectStandardItemVO
class | InspectionReportItemQtyVO
class | InspectionReportItemVO
class | InspectionReportVO
class | InspectionTypeItemVO
class | InspectionTypeVO
class | InventoryAdjustmentListResult
class | InventoryAdjustmentVO
class | InventoryPartInOutDetailListResult
class | IpAddressVO
class | LabelTemplateItemVO
class | LabelTemplateVO
class | LogInventoryVO
class | LogMethodVO
class | LogMiscDocumentVO
class | LogPartDocumentVO
class | LogPartDwfVO
class | LogPartDwgVO
class | LogTaskVO
class | LogTrackingVO
class | MaintenanceItemVO
class | ManufacturerAddressInfoVO
class | ManufacturerAddressVO
class | ManufacturerContactVO
class | ManufacturerDescriptionVO
class | MessageVO
class | MiscDocumentSettingVO
class | MultiLanguageAccountsChartVO
class | MyPrintListVO
class | NcrApprovalVO
class | NCRPictureVO
class | NonConformanceCodeDescriptionVO
class | NonConformanceCodeVO
class | NonConformanceQuantityVO
class | NonConformanceReportVO
class | NonproductivePickingApprovalVO
class | NonproductivePickingApproveVO
class | NonproductivePickingItemIssuedVO
class | NonproductivePickingItemVO
class | NonproductivePickingTypeVO
class | NonproductivePickingVO
class | OIPrincipalVO
class | OnloanDocumentVO
class | OnLoanItemVO
class | OnloanReceiverItemVO
class | OnloanReceiverVO
class | OnloanReviewVO
class | OnloanShipperItemVO
class | OnloanShipperVO
class | OnLoanVO
class | OpCodeShortcutVO
class | OperatingInstructionsInspectMethodItemVO
class | OperatingInstructionsInspectResultItemVO
class | OperatingInstructionsInspectStandardItemVO
class | OperatingInstructionsInspectStandardVO
class | OperatingInstructionsManualItemVO
class | OperatingInstructionsManualVO
class | OperatingInstructionsTypeVO
class | OperatingInstructionsVO
class | OperatingOutputFileItemVO
class | OperatingOutputFileTypeVO
class | OperationLogVO
class | OrderApprovalItemsVO
class | OrderApprovalVO OrderApproval generated by MyEclipse Persistence Tools
class | OrderBoilerplateVO
class | OrderDocumentVO
class | PackingBoxItemVO
class | PackingBoxVO
class | PartCatagoryVO
class | PartCatalogVO
class | PartCertificateVO
class | PartClassVO
class | PartDescriptionVO
class | PartDiscountVO
class | PartDocumentVO
class | PartDwfVO
class | PartDwgVO
class | PartInQAResult
class | PartInQAVO
class | PartInspectionVO
class | PartInventoryVO
class | PartIssuedListResult
class | PartIssuedVO
class | PartManufacturerVO
class | PartMaterialVO
class | PartMRPVO
class | PartNumberGenerateRuleVO
class | PartOnhandCostVO
class | PartOnhandVO
class | PartPictureVO
class | PartReceivedListResult
class | PartReceivedVO
class | PartSecurityLevelVO
class | PartTraceableCategoryVO
class | PartTraceableSpecVO
class | PartTrackingVO
class | PartTypeVO
class | PartUnitVO
class | PartUseTypeVO
class | PartVendorVO
class | PartVO
class | PartWithOnhandsVO
class | PayableMethodVO
class | PaymentHistoryVO
class | PaymentVO
class | PermissionDescriptionVO
class | PermissionMethodVO
class | PermissionVO
class | PfReceiverItemVO
class | PfReceiverVO
class | PhysicalInventoryStatusVO
class | PhysicalInventoryVO
class | PointOfSaleVO
class | PoMessageItemVO
class | PoMessageVO
class | PosRefdocVO
class | POSurveyReportItemVO
class | POSurveyReportVO
class | PosZipCodeTaxVO
class | PreventiveActionRequestItemVO
class | PreventiveActionRequestVO
class | PrintLogoVO
class | PrintTemplateVO
class | ProformaInvoiceItemManufacturerVO
class | ProformaInvoiceItemVO
class | ProformaInvoiceVO
class | ProjectVO
class | PrPackingBoxItemVO
class | PrPackingBoxVO
class | PurchaseOrderApprovalVO
class | PurchaseOrderBoilerplateVO
class | PurchaseOrderDocumentVO
class | PurchaseOrderItemManufacturerVO
class | PurchaseOrderItemVO
class | PurchaseOrderVO
class | PurchaseWorkSheetItemVO
class | PurchaseWorkSheetVO
class | QualityGroupVO
class | QuoteBoilerplateVO
class | QuoteDocumentVO
class | QuoteItemManufacturerVO
class | QuoteItemVO
class | QuoteVO
class | ReceiverInfoVO
class | ReceiverItemManufacturerVO
class | ReceiverItemVO
class | ReceiverVO
class | RefdocVO
class | RequestForQuoteItemManufacturerVO
class | RequestForQuoteItemVO
class | RequestForQuoteVO
class | RequestForRMAItemVO
class | RequestForRMAVO
class | ReturnMaterialAuthorizationDocumentVO
class | ReturnMaterialAuthorizationItemManufacturerVO
class | ReturnMaterialAuthorizationItemVO
class | ReturnMaterialAuthorizationVO
class | ReturnToVendorItemManufacturerVO
class | ReturnToVendorItemVO
class | ReturnToVendorVO
class | RfqMessageItemVO
class | RfqMessageVO
class | RMAReceiverItemVO
class | RMAReceiverVO
class | RMAReviewVO
class | RoleDescriptionVO
class | RolePermissionVO
class | RoleVO
class | RollUpBomStdCostWorkSheetItemVO
class | RollUpBomStdCostWorkSheetVO
class | RTVApprovalVO
class | RtvShipperInfoVO
class | RtvShipperItemVO
class | RtvShipperVO
class | RunningAccountOrderItemResult
class | RunningAccountOrderItemVO
class | RunningAccountOrderVO
class | SalesCodeVO
class | SalesmanVO
class | SalesOrderBoilerplateVO
class | SalesOrderDocumentVO
class | SalesOrderItemInfoVO
class | SalesOrderItemManufacturerVO
class | SalesOrderItemVO
class | SalesOrderReviewVO
class | SalesOrderVO
class | ScrapReportVO
class | SerialNumberItemVO
class | SerialNumberVO
class | ServerClientPropertyVO
class | SGBillItemVO
class | SGClientAccountVO
class | SgClientProgramUserVO
class | SGCompanyVO
class | SGCustomerCatalogVO
class | SGCustomerServiceRequestVO
class | SGCustRequestForQuoteItemVO
class | SGCustRequestForQuoteVO
class | SGDocPartVO
class | SGDwgPictureVO
class | SGLogLoginVO
class | SGPictureVO
class | SGQuoteAddressVO
class | SGQuoteCartVO
class | SGQuoteLoginVO
class | SGSaleItemVO
class | SGWeightUnitVO
class | ShipListInfoVO
class | ShipListItemVO
class | ShipListItemVOResult
class | ShipListOwnerAttributeVO
class | ShipListOwnerVO
class | ShipListVO
class | ShipperInfoVO
class | ShipperItemManufacturerVO
class | ShipperItemVO
class | ShipperVO
class | SmtpServerVO
class | SubcompanyVO
class | SwapOrderApprovalVO
class | SwapOrderItemVO
class | SwapOrderListResult
class | SwapOrderVO
class | SwapReceiverItemVO
class | SwapReceiverVO
class | SwapShipperItemVO
class | SwapShipperVO
class | TaskVO
class | TaxAccountVO
class | TempArApAgingVO
class | TempReceiverWithoutAPInfo
class | TermsConditionVO
class | TermVO
class | ToolCalibrateListResult
class | ToolCalibrationVO
class | ToolDescriptionVO
class | ToolInventoryVO
class | ToolListInfoVO
class | ToolListItemVO
class | ToolListVO
class | ToolManufacturerVO
class | ToolOnhandVO
class | ToolVendorVO
class | ToolVO
class | ToolWithOnhandsVO
class | TraceableCategoriesVO
class | TraceableSpecsVO
class | TransferOrderApprovalVO
class | TransferOrderItemVO
class | TransferOrderVO
class | TransferReceiverItemVO
class | TransferReceiverVO
class | TransferShipperItemVO
class | TransferShipperVO
class | UnitVO
class | UserGroupVO
class | UserRolePermissionListResult
class | UserRoleVO
class | VendorCategoriesVO
class | VendorContractPriceItemVO
class | VendorContractPriceVendorVO
class | VendorContractPriceVO
class | VendorCriticalLevelVO
class | VendorGroupUserVO
class | VendorPartVO
class | VendorQtyPriceVO
class | WareHousePartPrefixKeeperVO
class | WarehouseTransferVO
class | WarehouseVO
class | WeightUnitVO
class | WorkCalendarVO
class | WorkCenterGroupItemVO
class | WorkCenterVendorVO
class | WorkCenterVO Title:
class | WorkFlowVO
class | WorkInstructionApprovalVO
class | WorkInstructionDocumentVO
class | WorkInstructionPictureVO
class | WorkInstructionRequestForChangeVO
class | WorkInstructionSequenceVO
class | WorkInstructionVO
class | WorkOrderApprovalVO
class | WorkOrderBoilerplateVO
class | WorkOrderDocumentVO
class | WorkOrderItemIssueVO
class | WorkOrderItemPartDetailInWipVO
class | WorkOrderItemTimeDetailVO
class | WorkOrderItemVO
class | WorkOrderReceiverVO
class | WorkOrderTimeCardVO
class | WorkOrderVO
class | WorkOrderWorkInstructionSequenceVO
class | WorkOrderWorkInstructionVO
class | WorkOrderWorkSheetItemVO
class | WorkOrderWorkSheetVO
class | WorkPeriodVO
class | ZipCodeTaxVO
class | ZipCodeVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WareHousePartPrefixKeeperVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WareHousePartPrefixKeeperVO

No usage of bb.common.WareHousePartPrefixKeeperVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WarehouseTransferPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WarehouseTransferPK

Packages that use WarehouseTransferPK
bb.common

Uses of WarehouseTransferPK in bb.common

Methods in bb.common that return WarehouseTransferPK
 WarehouseTransferPK WarehouseTransferVO.getPk()

Methods in bb.common with parameters of type WarehouseTransferPK
 void WarehouseTransferVO.setPk(WarehouseTransferPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WarehouseTransferVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WarehouseTransferVO

Packages that use WarehouseTransferVO
bb.common

Uses of WarehouseTransferVO in bb.common

Methods in bb.common that return types with arguments of type WarehouseTransferVO
 java.util.Set<WarehouseTransferVO> WarehouseVO.getItems()

Method parameters in bb.common with type arguments of type WarehouseTransferVO
 void WarehouseVO.setItems(java.util.Set<WarehouseTransferVO> items)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WarehouseVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WarehouseVO

Packages that use WarehouseVO
bb.common.box

Uses of WarehouseVO in bb.common.box

Methods in bb.common.box that return WarehouseVO
 WarehouseVO WarehouseBox.getWarehouseByPK(java.lang.String warehousePrefix)

Methods in bb.common.box that return types with arguments of type WarehouseVO
 java.util.Collection<WarehouseVO> WarehouseBox.findAllWarehouses(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type WarehouseVO
void | WarehouseBox.addWarehouse(WarehouseVO vo)
void | WarehouseBox.updateWarehouse(WarehouseVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WareHousingInfoCenterResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WareHousingInfoCenterResult

Packages that use WareHousingInfoCenterResult
bb.common.box

Uses of WareHousingInfoCenterResult in bb.common.box

Methods in bb.common.box that return WareHousingInfoCenterResult
 WareHousingInfoCenterResult ManagementBox.getWareHousingInfoCenterResult()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WC2WCAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WC2WCAgent

Packages that use WC2WCAgent
bb.common.box

Uses of WC2WCAgent in bb.common.box

Methods in bb.common.box with parameters of type WC2WCAgent
 WorkCenterVO ManufacturingBox.copyWorkCenterFromWorkCenter(WC2WCAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WCLoadAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WCLoadAgent

Packages that use WCLoadAgent
bb.common
bb.common.box

Uses of WCLoadAgent in bb.common

Methods in bb.common that return WCLoadAgent
 WCLoadAgent WCLoadAgent.copyWith(WorkCenterAgent item)

Uses of WCLoadAgent in bb.common.box

Methods in bb.common.box with parameters of type WCLoadAgent
java.util.Collection<WCLoadDetailResult> | ManufacturingBox.getWCLoadDetailResults(WCLoadAgent agnet)
java.util.Collection<WorkCenterLoadListResult> | ManufacturingBox.getWorkCenterLoadListResult(WCLoadAgent cAgent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WCLoadByDateResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WCLoadByDateResult

Packages that use WCLoadByDateResult
bb.common

Uses of WCLoadByDateResult in bb.common

Methods in bb.common that return types with arguments of type WCLoadByDateResult
 java.util.Set<WCLoadByDateResult> WCLoadOnDateResult.getSet()

Method parameters in bb.common with type arguments of type WCLoadByDateResult
 void WCLoadOnDateResult.setSet(java.util.Set<WCLoadByDateResult> set)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WCLoadDetailResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WCLoadDetailResult

Packages that use WCLoadDetailResult
bb.common
bb.common.box

Uses of WCLoadDetailResult in bb.common

Methods in bb.common that return types with arguments of type WCLoadDetailResult
 java.util.List<WCLoadDetailResult> WorkCenterLoadListResult.getLoadDetailList()

Method parameters in bb.common with type arguments of type WCLoadDetailResult
 void WorkCenterLoadListResult.setLoadDetailList(java.util.List<WCLoadDetailResult> loadDetailList)

Uses of WCLoadDetailResult in bb.common.box

Methods in bb.common.box that return types with arguments of type WCLoadDetailResult
java.util.Collection<WCLoadDetailResult> | ManufacturingBox.getWCLoadDetailResults(java.lang.String wcID)
java.util.Collection<WCLoadDetailResult> | ManufacturingBox.getWCLoadDetailResults(WCLoadAgent agnet)
java.util.Collection<WCLoadDetailResult> | ManufacturingBox.getWCLoadDetailResultsforWOItem(WorkOrderItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WCLoadOnDateResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WCLoadOnDateResult

Packages that use WCLoadOnDateResult
bb.common.box

Uses of WCLoadOnDateResult in bb.common.box

Methods in bb.common.box that return WCLoadOnDateResult
 WCLoadOnDateResult ManufacturingBox.getWCLoadOnDate(WorkCenterOnDateAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WeightUnitVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WeightUnitVO

Packages that use WeightUnitVO
bb.common.box

Uses of WeightUnitVO in bb.common.box

Methods in bb.common.box that return WeightUnitVO
WeightUnitVO | CompanyBox.addWeightUnit(WeightUnitVO vo)
WeightUnitVO | CompanyBox.getWeightUnitByPk(java.lang.String weightUnit)
WeightUnitVO | CompanyBox.updateWeightUnit(WeightUnitVO vo)

Methods in bb.common.box that return types with arguments of type WeightUnitVO
java.util.Collection<WeightUnitVO> | CompanyBox.findAllWeightUnit(int firstIndex, int maxLength)
java.util.Collection<WeightUnitVO> | CompanyBox.findAllWeightUnit(java.lang.String weighUnit, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type WeightUnitVO
WeightUnitVO | CompanyBox.addWeightUnit(WeightUnitVO vo)
WeightUnitVO | CompanyBox.updateWeightUnit(WeightUnitVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WireTransferAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WireTransferAgent

Packages that use WireTransferAgent
bb.common.box

Uses of WireTransferAgent in bb.common.box

Methods in bb.common.box with parameters of type WireTransferAgent
java.lang.String | AccountingBox.setupAPWireTransfer(WireTransferAgent agent)
java.lang.String | AccountingBox.setupARWireTransfer(WireTransferAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WO2WOAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WO2WOAgent

Packages that use WO2WOAgent
bb.common.box

Uses of WO2WOAgent in bb.common.box

Methods in bb.common.box with parameters of type WO2WOAgent
 java.lang.String WorkOrderBox.copyWorkOrderFromWorkOrder(WO2WOAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WOIssuedByMonthChartResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WOIssuedByMonthChartResult

Packages that use WOIssuedByMonthChartResult
bb.common.box

Uses of WOIssuedByMonthChartResult in bb.common.box

Methods in bb.common.box that return WOIssuedByMonthChartResult
 WOIssuedByMonthChartResult ManagementBox.getOverIssueItemByMonth(int monthCount)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WOIssuedByMonthResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WOIssuedByMonthResult

Packages that use WOIssuedByMonthResult
bb.common

Uses of WOIssuedByMonthResult in bb.common

Methods in bb.common that return types with arguments of type WOIssuedByMonthResult
 java.util.ArrayList<WOIssuedByMonthResult> WOIssuedByMonthChartResult.getIssuedByMonthList()

Method parameters in bb.common with type arguments of type WOIssuedByMonthResult
 void WOIssuedByMonthChartResult.setIssuedByMonthList(java.util.ArrayList<WOIssuedByMonthResult> issuedByMonthList)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WOItemCostControlAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WOItemCostControlAgent

Packages that use WOItemCostControlAgent
bb.common

Uses of WOItemCostControlAgent in bb.common

Methods in bb.common that return WOItemCostControlAgent
 WOItemCostControlAgent IssuingResult.getCostControlAgent()

Methods in bb.common with parameters of type WOItemCostControlAgent
 void IssuingResult.setCostControlAgent(WOItemCostControlAgent costControlAgent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WOItemPartDetailNotIssue

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WOItemPartDetailNotIssue

Packages that use WOItemPartDetailNotIssue
bb.common.box

Uses of WOItemPartDetailNotIssue in bb.common.box

Methods in bb.common.box that return types with arguments of type WOItemPartDetailNotIssue
java.util.Collection<WOItemPartDetailNotIssue> | WorkOrderBox.findPartInWorkOrderPartDetail(java.lang.String woNumber, java.lang.String pnLike, java.lang.String paLike, java.lang.String pfLike, java.lang.String ProjectName, boolean isRefDoc, java.lang.String dateType, java.util.Date dateFrom, java.util.Date dateTo, int firstIndex, int maxLength)
java.util.Collection<WOItemPartDetailNotIssue> | WorkOrderBox.findWorkOrderItemPartDetailNotIssues(java.lang.String woNumber, java.lang.String vendorId, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WoItemPickListItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WoItemPickListItemResult

Packages that use WoItemPickListItemResult
bb.common

Uses of WoItemPickListItemResult in bb.common

Methods in bb.common that return types with arguments of type WoItemPickListItemResult
 java.util.Set<WoItemPickListItemResult> WoItemPickListResult.getItems()

Method parameters in bb.common with type arguments of type WoItemPickListItemResult
 void WoItemPickListResult.setItems(java.util.Set<WoItemPickListItemResult> items)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WoItemPickListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WoItemPickListResult

Packages that use WoItemPickListResult
bb.common.box

Uses of WoItemPickListResult in bb.common.box

Methods in bb.common.box that return WoItemPickListResult
 WoItemPickListResult WarehouseBox.getWoItemPickListResult(WorkOrderItemPK itemPk, java.math.BigDecimal qty, java.lang.String locationsPrefix)

Methods in bb.common.box that return types with arguments of type WoItemPickListResult
java.util.Collection<WoItemPickListResult> | WarehouseBox.findWoItemPickListResultsByDate(java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String partNumberLike, java.lang.String partType, java.lang.String vendorId)
java.util.Collection<WoItemPickListResult> | WarehouseBox.findWoItemPickListResultsByVendorId(java.lang.String vendorId)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WoItemWorkInstructionListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WoItemWorkInstructionListResult

Packages that use WoItemWorkInstructionListResult
bb.common.box

Uses of WoItemWorkInstructionListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type WoItemWorkInstructionListResult
java.util.Collection<WoItemWorkInstructionListResult> | ManufacturingBox.findWoItemWorkInstructionListResults(java.util.Date from, java.util.Date to, int firstIndex, int maxLength)
java.util.Collection<WoItemWorkInstructionListResult> | ManufacturingBox.findWoItemWorkInstructionListResults(java.lang.String woNumberLike, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WOReceiverDetail

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WOReceiverDetail

Packages that use WOReceiverDetail
bb.common.box

Uses of WOReceiverDetail in bb.common.box

Methods in bb.common.box that return types with arguments of type WOReceiverDetail
java.util.Collection<WOReceiverDetail> | WarehouseBox.findWOReceiverItems(java.lang.String workOrder, java.lang.String workOrderItem, java.lang.String customerId, java.lang.String pn, java.lang.String pa, java.lang.String partFrom, java.util.Date fromDate, java.util.Date toDate, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String[] branchWarehouses, boolean isIncludeNA, java.lang.String project, int firstIndex, int maxLength)
java.util.Collection<WOReceiverDetail> | WarehouseBox.findWOReceiverItemsTotal(java.lang.String workOrder, java.lang.String workOrderItem, java.lang.String customerId, java.lang.String pn, java.lang.String pa, java.lang.String partFrom, java.util.Date fromDate, java.util.Date toDate, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String[] branchWarehouses, boolean isIncludeNA, java.lang.String project)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkCalendarVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkCalendarVO

Packages that use WorkCalendarVO
bb.common.box

Uses of WorkCalendarVO in bb.common.box

Methods in bb.common.box that return WorkCalendarVO
WorkCalendarVO | ManufacturingBox.addWorkCalendar(WorkCalendarVO vo)
WorkCalendarVO | ManufacturingBox.getWorkCalendarByPK(java.lang.Long workDate)
WorkCalendarVO | ManufacturingBox.updateWorkCalendar(WorkCalendarVO vo)

Methods in bb.common.box that return types with arguments of type WorkCalendarVO
 java.util.Collection<WorkCalendarVO> ManufacturingBox.findAllWorkCalendar(java.util.Date dateFrom, java.util.Date dateTo, int work, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type WorkCalendarVO
WorkCalendarVO | ManufacturingBox.addWorkCalendar(WorkCalendarVO vo)
void | ManufacturingBox.deleteWorkCalendar(WorkCalendarVO vo)
WorkCalendarVO | ManufacturingBox.updateWorkCalendar(WorkCalendarVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkCenterAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkCenterAgent

Packages that use WorkCenterAgent
bb.common
bb.common.box

Uses of WorkCenterAgent in bb.common

Subclasses of WorkCenterAgent in bb.common
 class WorkCenterOnDateAgent

Methods in bb.common that return WorkCenterAgent
WorkCenterAgent | WCLoadAgent.getWorkCenterAgent()
WorkCenterAgent | WCLoadAgent.getWorkCenterAgent(java.lang.String wcID)

Methods in bb.common that return types with arguments of type WorkCenterAgent
 java.util.Iterator<WorkCenterAgent> WCLoadAgent.getItems()

Methods in bb.common with parameters of type WorkCenterAgent
void | WCLoadAgent.addItem(WorkCenterAgent agent)
WCLoadAgent | WCLoadAgent.copyWith(WorkCenterAgent item)

Method parameters in bb.common with type arguments of type WorkCenterAgent
 void WCLoadAgent.addItems(java.util.Collection<WorkCenterAgent> items)

Constructors in bb.common with parameters of type WorkCenterAgent
WCLoadAgent(WorkCenterAgent agent)

Uses of WorkCenterAgent in bb.common.box

Methods in bb.common.box that return types with arguments of type WorkCenterAgent
 java.util.Collection<WorkCenterAgent> ManufacturingBox.getWCLoadIDs(java.lang.String wcLike, java.lang.String departLike)

Methods in bb.common.box with parameters of type WorkCenterAgent
 java.util.Collection<WorkOrderItemWCLoadResult> ManufacturingBox.getWorkOrderItemWCLoadResults(WorkCenterAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkCenterGroupItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkCenterGroupItemPK

Packages that use WorkCenterGroupItemPK
bb.common

Uses of WorkCenterGroupItemPK in bb.common

Methods in bb.common that return WorkCenterGroupItemPK
 WorkCenterGroupItemPK WorkCenterGroupItemVO.getPk()

Methods in bb.common with parameters of type WorkCenterGroupItemPK
 void WorkCenterGroupItemVO.setPk(WorkCenterGroupItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkCenterGroupItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkCenterGroupItemVO

No usage of bb.common.WorkCenterGroupItemVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkCenterLoadAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkCenterLoadAgent

Packages that use WorkCenterLoadAgent
bb.common.box

Uses of WorkCenterLoadAgent in bb.common.box

Methods in bb.common.box with parameters of type WorkCenterLoadAgent
java.util.Collection<WorkCenterLoadListResult> | ManufacturingBox.findWorkCenterLoadResults(WorkCenterLoadAgent agent, int firstIndex, int maxLength)
int | ManufacturingBox.getWorkCenterLoadResultsCount(WorkCenterLoadAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkCenterLoadListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkCenterLoadListResult

Packages that use WorkCenterLoadListResult
bb.common.box

Uses of WorkCenterLoadListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type WorkCenterLoadListResult
java.util.Collection<WorkCenterLoadListResult> | ManufacturingBox.findWorkCenterLoadResults(WorkCenterLoadAgent agent, int firstIndex, int maxLength)
java.util.Collection<WorkCenterLoadListResult> | ManufacturingBox.getWorkCenterLoadListResult(WCLoadAgent cAgent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkCenterOnDateAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkCenterOnDateAgent

Packages that use WorkCenterOnDateAgent
bb.common.box

Uses of WorkCenterOnDateAgent in bb.common.box

Methods in bb.common.box with parameters of type WorkCenterOnDateAgent
 WCLoadOnDateResult ManufacturingBox.getWCLoadOnDate(WorkCenterOnDateAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkCenterRunTimeAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkCenterRunTimeAgent

Packages that use WorkCenterRunTimeAgent
bb.common.box

Uses of WorkCenterRunTimeAgent in bb.common.box

Methods in bb.common.box with parameters of type WorkCenterRunTimeAgent
java.util.Collection<WorkCenterRunTimeListResult> | ManufacturingBox.findWorkCenterRunTimeListResults(WorkCenterRunTimeAgent agent, int firstIndex, int maxLength)
int | ManufacturingBox.getWorkCenterRunTimeListResultsCount(WorkCenterRunTimeAgent agent)
WorkCenterRunTimeTotalResult | ManufacturingBox.getWorkCenterRunTimeTotalResult(WorkCenterRunTimeAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkCenterRunTimeListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkCenterRunTimeListResult

Packages that use WorkCenterRunTimeListResult
bb.common.box

Uses of WorkCenterRunTimeListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type WorkCenterRunTimeListResult
 java.util.Collection<WorkCenterRunTimeListResult> ManufacturingBox.findWorkCenterRunTimeListResults(WorkCenterRunTimeAgent agent, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkCenterRunTimeTotalResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkCenterRunTimeTotalResult

Packages that use WorkCenterRunTimeTotalResult
bb.common.box

Uses of WorkCenterRunTimeTotalResult in bb.common.box

Methods in bb.common.box that return WorkCenterRunTimeTotalResult
 WorkCenterRunTimeTotalResult ManufacturingBox.getWorkCenterRunTimeTotalResult(WorkCenterRunTimeAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkCenterVendorPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkCenterVendorPK

Packages that use WorkCenterVendorPK
bb.common

Uses of WorkCenterVendorPK in bb.common

Methods in bb.common that return WorkCenterVendorPK
 WorkCenterVendorPK WorkCenterVendorVO.getPk()

Methods in bb.common with parameters of type WorkCenterVendorPK
 void WorkCenterVendorVO.setPk(WorkCenterVendorPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkCenterVendorVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkCenterVendorVO

No usage of bb.common.WorkCenterVendorVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkCenterVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkCenterVO

Packages that use WorkCenterVO
bb.common
bb.common.box

Uses of WorkCenterVO in bb.common

Methods in bb.common that return WorkCenterVO
WorkCenterVO | WorkCenterVO.getParentWorkCenter()
WorkCenterVO | WorkCenterGroupItemVO.getWorkCenter()

Methods in bb.common that return types with arguments of type WorkCenterVO
 java.util.Set<WorkCenterVO> WorkCenterVO.getWorkCenterItems()

Methods in bb.common with parameters of type WorkCenterVO
void | WorkCenterVO.setParentWorkCenter(WorkCenterVO parentWorkCenter)
void | WorkCenterGroupItemVO.setWorkCenter(WorkCenterVO workCenter)

Method parameters in bb.common with type arguments of type WorkCenterVO
 void WorkCenterVO.setWorkCenterItems(java.util.Set<WorkCenterVO> workCenterItems)

Uses of WorkCenterVO in bb.common.box

Methods in bb.common.box that return WorkCenterVO
WorkCenterVO | ManufacturingBox.addWorkCenter(WorkCenterVO vo)
WorkCenterVO | ManufacturingBox.copyWorkCenterFromWorkCenter(WC2WCAgent agent)
WorkCenterVO | ManufacturingBox.getWorkCenterById(java.lang.String id)
WorkCenterVO | ManufacturingBox.getWorkCenterById(java.lang.String id, boolean isGroup)
WorkCenterVO | ManufacturingBox.getWorkCenterOrGroupById(java.lang.String id)
WorkCenterVO | ManufacturingBox.updateWorkCenter(WorkCenterVO vo)

Methods in bb.common.box that return types with arguments of type WorkCenterVO
 java.util.Collection<WorkCenterVO> ManufacturingBox.findWorkCenterByWcNumber(java.lang.String wcNumber, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type WorkCenterVO
WorkCenterVO | ManufacturingBox.addWorkCenter(WorkCenterVO vo)
void | ManufacturingBox.deleteWorkCenter(WorkCenterVO vo)
WorkCenterVO | ManufacturingBox.updateWorkCenter(WorkCenterVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkFlowVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkFlowVO

Packages that use WorkFlowVO
bb.common.box

Uses of WorkFlowVO in bb.common.box

Methods in bb.common.box that return WorkFlowVO
 WorkFlowVO CompanyBox.getWorkFlowByName(java.lang.String workFlowName)

Methods in bb.common.box that return types with arguments of type WorkFlowVO
 java.util.Collection<WorkFlowVO> CompanyBox.findAllWorkFlow(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type WorkFlowVO
void | CompanyBox.addWorkFlow(WorkFlowVO workFlowVO)
void | CompanyBox.updateWorkFlow(WorkFlowVO workFlowVO)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkInstructionApprovalVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkInstructionApprovalVO

Packages that use WorkInstructionApprovalVO
bb.common.box

Uses of WorkInstructionApprovalVO in bb.common.box

Methods in bb.common.box that return WorkInstructionApprovalVO
WorkInstructionApprovalVO | ManufacturingBox.addWorkInstructionApproval(java.lang.String employeeId)
WorkInstructionApprovalVO | ManufacturingBox.getWorkInstructionApprovalByEmployeeID(java.lang.String employeeId)
WorkInstructionApprovalVO | ManufacturingBox.updateWorkInstructionApproval(WorkInstructionApprovalVO vo)

Methods in bb.common.box that return types with arguments of type WorkInstructionApprovalVO
 java.util.Collection<WorkInstructionApprovalVO> ManufacturingBox.findWorkInstructionApprovalByEmployeeID(java.lang.String employeeId, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type WorkInstructionApprovalVO
 WorkInstructionApprovalVO ManufacturingBox.updateWorkInstructionApproval(WorkInstructionApprovalVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkInstructionDocumentVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkInstructionDocumentVO

Packages that use WorkInstructionDocumentVO
bb.common.box

Uses of WorkInstructionDocumentVO in bb.common.box

Methods in bb.common.box that return WorkInstructionDocumentVO
 WorkInstructionDocumentVO ManufacturingBox.getWorkInstructionDocByID(java.lang.Long controlNumber)

Methods in bb.common.box that return types with arguments of type WorkInstructionDocumentVO
java.util.Collection<WorkInstructionDocumentVO> | ManufacturingBox.findWorkInstructionDocInfo(WorkInstructionPK pk)
java.util.Collection<WorkInstructionDocumentVO> | ManufacturingBox.uploadWorkInstructionDocument(MiscDocAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkInstructionListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkInstructionListResult

Packages that use WorkInstructionListResult
bb.common.box

Uses of WorkInstructionListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type WorkInstructionListResult
java.util.Collection<WorkInstructionListResult> | ManufacturingBox.findAllWorkInstructions(int firstIndex, int maxLength)
java.util.Collection<WorkInstructionListResult> | ManufacturingBox.findWorkInstructionByAuthor(java.lang.String author, int firstIndex, int maxLength)
java.util.Collection<WorkInstructionListResult> | ManufacturingBox.findWorkInstructionByStatus(java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<WorkInstructionListResult> | ManufacturingBox.findWorkInstructionsByPartLike(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String setID, java.lang.String status, boolean revMismatched, int firstIndex, int maxLength)
java.util.Collection<WorkInstructionListResult> | ManufacturingBox.findWorkInstructionsByPartLike(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String setID, java.lang.String status, boolean revMismatched, int firstIndex, int maxLength, boolean isLike)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkInstructionPictureVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkInstructionPictureVO

Packages that use WorkInstructionPictureVO
bb.common.box

Uses of WorkInstructionPictureVO in bb.common.box

Methods in bb.common.box that return WorkInstructionPictureVO
WorkInstructionPictureVO | ManufacturingBox.addWorkInstructionPicture(WorkInstructionPictureVO vo)
WorkInstructionPictureVO | ManufacturingBox.uploadWorkInstructionPicture(MiscDocAgent agent)

Methods in bb.common.box with parameters of type WorkInstructionPictureVO
 WorkInstructionPictureVO ManufacturingBox.addWorkInstructionPicture(WorkInstructionPictureVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkInstructionPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkInstructionPK

Packages that use WorkInstructionPK
bb.common
bb.common.box

Uses of WorkInstructionPK in bb.common

Methods in bb.common that return WorkInstructionPK
 WorkInstructionPK WorkInstructionVO.getPk()

Methods in bb.common with parameters of type WorkInstructionPK
 void WorkInstructionVO.setPk(WorkInstructionPK pk)

Constructors in bb.common with parameters of type WorkInstructionPK
WorkInstructionVO(WorkInstructionPK pk, java.lang.String lastChangeUser, java.lang.String workInstructionRev, java.lang.String defaultWi, java.lang.String author, java.lang.String approvedBy, java.util.Date effectiveDate, java.lang.String status, java.util.Set sequences)
minimal constructor

Uses of WorkInstructionPK in bb.common.box

Methods in bb.common.box that return WorkInstructionPK
 WorkInstructionPK ManufacturingBox.updateWorkInstruction(WorkInstructionVO vo)

Methods in bb.common.box with parameters of type WorkInstructionPK
WorkInstructionVO | ManufacturingBox.addWorkInstruction(WorkInstructionPK pk)
WorkOrderWorkInstructionVO | WorkOrderBox.addWorkOrderWorkInstruction(WorkOrderItemPK woItemPk, WorkInstructionPK wiPk)
WorkInstructionVO | ManufacturingBox.copyWorkInstruction(WorkInstructionPK oldPk, WorkInstructionPK newPk)
void | ManufacturingBox.deleteWorkInstruction(WorkInstructionPK pk)
java.util.Collection<WorkInstructionDocumentVO> | ManufacturingBox.findWorkInstructionDocInfo(WorkInstructionPK pk)
WorkInstructionVO | ManufacturingBox.getWorkInstructionByPk(WorkInstructionPK pk)
boolean | WorkOrderBox.isRequiredDateExpired(WorkInstructionPK pk, java.util.Date startDate, java.util.Date requiredDate)
boolean | ManufacturingBox.isWorkInstructionExist(WorkInstructionPK pk)
boolean | WorkOrderBox.isWorkInstructionExist(WorkOrderItemPK itemPk, WorkInstructionPK pk)
void | ManufacturingBox.setToDefaultWorkInstruction(WorkInstructionPK wiPk)
void | WorkOrderBox.synchronizeWiSeqToWowiSeq(WorkInstructionPK wiPK, WorkOrderItemPK woiPK)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkInstructionRequestForChangeVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkInstructionRequestForChangeVO

Packages that use WorkInstructionRequestForChangeVO
bb.common.box

Uses of WorkInstructionRequestForChangeVO in bb.common.box

Methods in bb.common.box that return WorkInstructionRequestForChangeVO
WorkInstructionRequestForChangeVO | ManufacturingBox.addRFC(WorkInstructionRequestForChangeVO vo)
WorkInstructionRequestForChangeVO | ManufacturingBox.findRFCByPk(java.lang.String pk)
WorkInstructionRequestForChangeVO | ManufacturingBox.updateRFC(WorkInstructionRequestForChangeVO vo)

Methods in bb.common.box that return types with arguments of type WorkInstructionRequestForChangeVO
java.util.Collection<WorkInstructionRequestForChangeVO> | ManufacturingBox.findAllRfcs(int firstIndex, int maxLength)
java.util.Collection<WorkInstructionRequestForChangeVO> | ManufacturingBox.findOpenRFCs(int firstIndex, int maxLength)
java.util.Collection<WorkInstructionRequestForChangeVO> | ManufacturingBox.findPastDueRFCs(int firstIndex, int maxLength)
java.util.Collection<WorkInstructionRequestForChangeVO> | ManufacturingBox.findRFCsByRFC(java.lang.String rfc, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type WorkInstructionRequestForChangeVO
WorkInstructionRequestForChangeVO | ManufacturingBox.addRFC(WorkInstructionRequestForChangeVO vo)
void | ManufacturingBox.deleteRFC(WorkInstructionRequestForChangeVO vo)
WorkInstructionRequestForChangeVO | ManufacturingBox.updateRFC(WorkInstructionRequestForChangeVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkInstructionSeqAuditListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkInstructionSeqAuditListResult

Packages that use WorkInstructionSeqAuditListResult
bb.common.box

Uses of WorkInstructionSeqAuditListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type WorkInstructionSeqAuditListResult
java.util.Collection<WorkInstructionSeqAuditListResult> | ManufacturingBox.findWorkInstructionSeqAuditListResults(int firstIndex, int maxLength)
java.util.Collection<WorkInstructionSeqAuditListResult> | ManufacturingBox.findWorkInstructionSeqAuditListResults(java.lang.String pnLike, java.lang.String partType, java.lang.String setId, java.lang.String seqNum, java.lang.String wcLike, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkInstructionSequenceListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkInstructionSequenceListResult

Packages that use WorkInstructionSequenceListResult
bb.common.box

Uses of WorkInstructionSequenceListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type WorkInstructionSequenceListResult
java.util.Collection<WorkInstructionSequenceListResult> | ManufacturingBox.findWorkInstructionSeqByAuthor(java.lang.String author, int firstIndex, int maxLength)
java.util.Collection<WorkInstructionSequenceListResult> | ManufacturingBox.findWorkInstructionSeqByWorkCenter(java.lang.String workCenter, int firstIndex, int maxLength)
java.util.Collection<WorkInstructionSequenceListResult> | ManufacturingBox.findWorkInstructionSeqOnHold(int firstIndex, int maxLength)
java.util.Collection<WorkInstructionSequenceListResult> | ManufacturingBox.findWorkInstructionSeqWithZeroEstHours(int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkInstructionSequencePK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkInstructionSequencePK

Packages that use WorkInstructionSequencePK
bb.common

Uses of WorkInstructionSequencePK in bb.common

Methods in bb.common that return WorkInstructionSequencePK
WorkInstructionSequencePK | WorkInstructionSequenceVO.getPk()
WorkInstructionSequencePK | WorkInstructionSeqAuditListResult.getWiSeqPk()

Methods in bb.common with parameters of type WorkInstructionSequencePK
void | WorkInstructionSequenceVO.setPk(WorkInstructionSequencePK pk)
void | WorkInstructionSeqAuditListResult.setWiSeqPk(WorkInstructionSequencePK wiSeqPk)

Constructors in bb.common with parameters of type WorkInstructionSequencePK
WorkInstructionSequenceVO(WorkInstructionSequencePK pk, java.lang.String sequenceRev, java.lang.String specialProcess, java.lang.String toolNumber, java.lang.String workCenter, java.lang.String description, java.math.BigDecimal estSetup, java.math.BigDecimal avgSetup, java.math.BigDecimal stdSetup, java.math.BigDecimal estHours, java.math.BigDecimal avgHours, java.math.BigDecimal stdHours, java.lang.String ref, java.lang.String status, java.util.Set workInstructionPictures)
minimal constructor
WorkInstructionSequenceVO(WorkInstructionSequencePK pk, java.lang.String sequenceRev, java.lang.String specialProcess, java.lang.String toolNumber, java.lang.String workCenter, java.lang.String description, java.lang.String language2, java.lang.String description2, java.lang.String language3, java.lang.String description3, java.math.BigDecimal estSetup, java.math.BigDecimal avgSetup, java.math.BigDecimal stdSetup, java.math.BigDecimal estHours, java.math.BigDecimal avgHours, java.math.BigDecimal stdHours, java.lang.String ref, java.lang.String status, java.util.Set workInstructionPictures)
full constructor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkInstructionSequenceVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkInstructionSequenceVO

Packages that use WorkInstructionSequenceVO
bb.common.box

Uses of WorkInstructionSequenceVO in bb.common.box

Methods in bb.common.box that return WorkInstructionSequenceVO
 WorkInstructionSequenceVO ManufacturingBox.getWorkInstructionSequence(WorkOrderItemPK itemPk, java.lang.String seqNumber)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkInstructionSummaryItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkInstructionSummaryItemResult

No usage of bb.common.WorkInstructionSummaryItemResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkInstructionSummaryResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkInstructionSummaryResult

Packages that use WorkInstructionSummaryResult
bb.common.box

Uses of WorkInstructionSummaryResult in bb.common.box

Methods in bb.common.box that return WorkInstructionSummaryResult
 WorkInstructionSummaryResult ManufacturingBox.getWorkInstructionSummaryResult(BB2Part part, java.lang.String setId)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkInstructionVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkInstructionVO

Packages that use WorkInstructionVO
bb.common.box

Uses of WorkInstructionVO in bb.common.box

Methods in bb.common.box that return WorkInstructionVO
WorkInstructionVO | ManufacturingBox.addWorkInstruction(WorkInstructionPK pk)
WorkInstructionVO | ManufacturingBox.approveWorkInstruction(WorkInstructionVO vo)
WorkInstructionVO | ManufacturingBox.copyToAddWorkInstruction(WorkInstructionVO vo)
WorkInstructionVO | ManufacturingBox.copyWorkInstruction(WorkInstructionPK oldPk, WorkInstructionPK newPk)
WorkInstructionVO | ManufacturingBox.getDefaultWorkInstructionByPartPk(BB2Part part)
WorkInstructionVO | WorkOrderBox.getManWorkInstructionByWoItemPk(BB2Part part, java.lang.String setId)
WorkInstructionVO | ManufacturingBox.getWorkInstructionByPart(BB2Part part, java.lang.String setId)
WorkInstructionVO | ManufacturingBox.getWorkInstructionByPk(WorkInstructionPK pk)

Methods in bb.common.box that return types with arguments of type WorkInstructionVO
 java.util.Collection<WorkInstructionVO> ManufacturingBox.findOpenWorkInstructions(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type WorkInstructionVO
WorkInstructionVO | ManufacturingBox.approveWorkInstruction(WorkInstructionVO vo)
WorkInstructionVO | ManufacturingBox.copyToAddWorkInstruction(WorkInstructionVO vo)
void | ManufacturingBox.updateDefaultStatus(WorkInstructionVO vo)
WorkInstructionPK | ManufacturingBox.updateWorkInstruction(WorkInstructionVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderApprovalVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderApprovalVO

Packages that use WorkOrderApprovalVO
bb.common.box

Uses of WorkOrderApprovalVO in bb.common.box

Methods in bb.common.box that return WorkOrderApprovalVO
WorkOrderApprovalVO | WorkOrderBox.addWorkOrderApproval(java.lang.String employeeId)
WorkOrderApprovalVO | WorkOrderBox.getWorkOrderApprovalByEmployeeId(java.lang.String employeeId)
WorkOrderApprovalVO | WorkOrderBox.getWorkOrderApprovalByUserNumber(java.lang.String userName)
WorkOrderApprovalVO | WorkOrderBox.updateWorkOrderApproval(WorkOrderApprovalVO woApprovalVO)

Methods in bb.common.box that return types with arguments of type WorkOrderApprovalVO
 java.util.Collection<WorkOrderApprovalVO> WorkOrderBox.findAllWorkOrderApprovals(int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type WorkOrderApprovalVO
void | WorkOrderBox.deleteWorkOrderApproval(WorkOrderApprovalVO woApprovalVO)
WorkOrderApprovalVO | WorkOrderBox.updateWorkOrderApproval(WorkOrderApprovalVO woApprovalVO)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderBoilerplateVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderBoilerplateVO

Packages that use WorkOrderBoilerplateVO
bb.common.box

Uses of WorkOrderBoilerplateVO in bb.common.box

Methods in bb.common.box that return WorkOrderBoilerplateVO
WorkOrderBoilerplateVO | WorkOrderBox.addWorkOrderBP(WorkOrderBoilerplateVO vo)
WorkOrderBoilerplateVO | WorkOrderBox.getWorkOrderBPByPk(java.lang.String workOrderBoilerplateId)
WorkOrderBoilerplateVO | WorkOrderBox.updateWorkOrderBP(WorkOrderBoilerplateVO vo)

Methods in bb.common.box that return types with arguments of type WorkOrderBoilerplateVO
java.util.Collection<WorkOrderBoilerplateVO> | WorkOrderBox.findAllWorkOrderBP(int firstIndex, int maxLength)
java.util.Collection<WorkOrderBoilerplateVO> | WorkOrderBox.findWorkOrderBPByBPId(java.lang.String boilerplateId, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type WorkOrderBoilerplateVO
WorkOrderBoilerplateVO | WorkOrderBox.addWorkOrderBP(WorkOrderBoilerplateVO vo)
WorkOrderBoilerplateVO | WorkOrderBox.updateWorkOrderBP(WorkOrderBoilerplateVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderCheckListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderCheckListResult

Packages that use WorkOrderCheckListResult
bb.common.box

Uses of WorkOrderCheckListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type WorkOrderCheckListResult
java.util.Collection<WorkOrderCheckListResult> | WorkOrderBox.findAllWorkOrderCheckListResults(int firstIndex, int maxLength)
java.util.Collection<WorkOrderCheckListResult> | WorkOrderBox.findWorkOrderCheckListResults(java.lang.String startWith, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderDocumentVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderDocumentVO

Packages that use WorkOrderDocumentVO
bb.common.box

Uses of WorkOrderDocumentVO in bb.common.box

Methods in bb.common.box that return WorkOrderDocumentVO
 WorkOrderDocumentVO WorkOrderBox.getWorkOrderDocumentByID(java.lang.Long controlNumber)

Methods in bb.common.box that return types with arguments of type WorkOrderDocumentVO
java.util.Collection<WorkOrderDocumentVO> | WorkOrderBox.findWorkOrderDocumentInfo(java.lang.String workOrderNumber)
java.util.Collection<WorkOrderDocumentVO> | WorkOrderBox.uploadOrUpdateFTPWODoc(MiscDocAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderInfoCenterResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderInfoCenterResult

Packages that use WorkOrderInfoCenterResult
bb.common.box

Uses of WorkOrderInfoCenterResult in bb.common.box

Methods in bb.common.box that return WorkOrderInfoCenterResult
 WorkOrderInfoCenterResult ManagementBox.getWorkOrderInfoCenterResult()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderInWipResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderInWipResult

No usage of bb.common.WorkOrderInWipResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderIssuedOrderListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderIssuedOrderListResult

Packages that use WorkOrderIssuedOrderListResult
bb.common.box

Uses of WorkOrderIssuedOrderListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type WorkOrderIssuedOrderListResult
 java.util.Collection<WorkOrderIssuedOrderListResult> WarehouseBox.findWorkOrderIssuedOrderList(WorkOrderItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderIssueStatisticsResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderIssueStatisticsResult

Packages that use WorkOrderIssueStatisticsResult
bb.common.box

Uses of WorkOrderIssueStatisticsResult in bb.common.box

Methods in bb.common.box that return types with arguments of type WorkOrderIssueStatisticsResult
 java.util.Collection<WorkOrderIssueStatisticsResult> WorkOrderBox.findWorkOrderIssueStatisticsResults(java.util.Date from, java.util.Date to, java.lang.String project, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderItemAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderItemAgent

Packages that use WorkOrderItemAgent
bb.common.box

Uses of WorkOrderItemAgent in bb.common.box

Method parameters in bb.common.box with type arguments of type WorkOrderItemAgent
 java.util.Collection<WorkOrderItemListResult> WorkOrderBox.addWorkOrderFromMasterWorkOrder(java.util.Date dueDate, WorkOrderItemPK masterWOPk, java.util.HashMap<java.lang.String,java.util.HashSet<WorkOrderItemAgent>> map)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderItemCanAssyAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderItemCanAssyAgent

Packages that use WorkOrderItemCanAssyAgent
bb.common.box

Uses of WorkOrderItemCanAssyAgent in bb.common.box

Methods in bb.common.box with parameters of type WorkOrderItemCanAssyAgent
 java.util.Collection<WorkOrderItemCanAssyResult> WorkOrderBox.getWorkOrderItemCanAssyResults(WorkOrderItemCanAssyAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderItemCanAssyResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderItemCanAssyResult

Packages that use WorkOrderItemCanAssyResult
bb.common.box

Uses of WorkOrderItemCanAssyResult in bb.common.box

Methods in bb.common.box that return types with arguments of type WorkOrderItemCanAssyResult
 java.util.Collection<WorkOrderItemCanAssyResult> WorkOrderBox.getWorkOrderItemCanAssyResults(WorkOrderItemCanAssyAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderItemInfoResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderItemInfoResult

Packages that use WorkOrderItemInfoResult
bb.common.box

Uses of WorkOrderItemInfoResult in bb.common.box

Methods in bb.common.box that return types with arguments of type WorkOrderItemInfoResult
 java.util.Collection<WorkOrderItemInfoResult> WorkOrderBox.findAllMasterWorkOrder(java.lang.String workOrderNumber, java.lang.String relatedDoc, java.lang.String partNumber, java.lang.String partType, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderItemInWipListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderItemInWipListResult

Packages that use WorkOrderItemInWipListResult
bb.common.box

Uses of WorkOrderItemInWipListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type WorkOrderItemInWipListResult
 java.util.Collection<WorkOrderItemInWipListResult> WorkOrderBox.findWorkOrderItemInWipList(java.lang.String monthYear, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderItemIssuedTotalResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderItemIssuedTotalResult

Packages that use WorkOrderItemIssuedTotalResult
bb.common.box

Uses of WorkOrderItemIssuedTotalResult in bb.common.box

Methods in bb.common.box that return types with arguments of type WorkOrderItemIssuedTotalResult
 java.util.ArrayList<WorkOrderItemIssuedTotalResult> WarehouseBox.findIssuedPartTotal(WorkOrderItemPK pk, PartPK partPk, java.lang.String relatedDoc, java.lang.String modelNumber, java.lang.String common, java.lang.String dateType, java.util.Date dateFrom, java.util.Date dateTo, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderItemIssuePK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderItemIssuePK

Packages that use WorkOrderItemIssuePK
bb.common
bb.common.box

Uses of WorkOrderItemIssuePK in bb.common

Methods in bb.common that return WorkOrderItemIssuePK
WorkOrderItemIssuePK | WorkOrderItemPartDetailItemResult.getItemIssuePk()
WorkOrderItemIssuePK | WorkOrderItemIssueVO.getPk()
WorkOrderItemIssuePK | PullFromWorkOrderPartDetailAgent.getPk()
WorkOrderItemIssuePK | WoItemPickListItemResult.getWoItemIssuePk()

Methods in bb.common with parameters of type WorkOrderItemIssuePK
void | WorkOrderItemIssueVO.setPk(WorkOrderItemIssuePK pk)
void | PullFromWorkOrderPartDetailAgent.setPk(WorkOrderItemIssuePK pk)
void | WoItemPickListItemResult.setWoItemIssuePk(WorkOrderItemIssuePK woItemIssuePk)

Uses of WorkOrderItemIssuePK in bb.common.box

Methods in bb.common.box with parameters of type WorkOrderItemIssuePK
void | WorkOrderBox.deleteWorkOrderItemIssue(WorkOrderItemIssuePK issuePk)
WorkOrderItemIssueVO | WorkOrderBox.getWorkOrderItemIssueByPk(WorkOrderItemIssuePK issuePk)
WorkOrderItemPartDetailItemResult | WorkOrderBox.getWorkOrderItemPartDetailItemResult(WorkOrderItemIssuePK pk)
void | WorkOrderBox.setWorkOrderItemIssueReferenceDocOne(WorkOrderItemIssuePK pk, java.lang.String referenceDoc)

Method parameters in bb.common.box with type arguments of type WorkOrderItemIssuePK
 void WorkOrderBox.deleteWorkOrderItemIssues(java.util.ArrayList<WorkOrderItemIssuePK> items)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderItemIssueVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderItemIssueVO

Packages that use WorkOrderItemIssueVO
bb.common
bb.common.box

Uses of WorkOrderItemIssueVO in bb.common

Methods in bb.common that return WorkOrderItemIssueVO
 WorkOrderItemIssueVO WorkOrderItemPartDetailItemResult.getIssueVo()

Methods in bb.common with parameters of type WorkOrderItemIssueVO
 void WorkOrderItemPartDetailItemResult.setIssueVo(WorkOrderItemIssueVO issueVo)

Uses of WorkOrderItemIssueVO in bb.common.box

Methods in bb.common.box that return WorkOrderItemIssueVO
 WorkOrderItemIssueVO WorkOrderBox.getWorkOrderItemIssueByPk(WorkOrderItemIssuePK issuePk)

Methods in bb.common.box that return types with arguments of type WorkOrderItemIssueVO
java.util.Collection<WorkOrderItemIssueVO> | WorkOrderBox.findOpenAndIssuedWorkOrderItemIssues(java.lang.String woNumber, java.lang.String itemNumber, BB2Part part)
java.util.Collection<WorkOrderItemIssueVO> | WorkOrderBox.findWorkOrderItemIssues(WorkOrderItemPK itemPk)
java.util.Collection<WorkOrderItemIssueVO> | WorkOrderBox.findWorkOrderItemWithWipIssues(WorkOrderItemPK itemPk, java.util.Date fromDate, java.util.Date toDate)

Methods in bb.common.box with parameters of type WorkOrderItemIssueVO
void | WorkOrderBox.deleteWorkOrderItemIssue(WorkOrderItemIssueVO vo)
WorkOrderItemPartDetailItemResult | WorkOrderBox.updateWorkOrderItemIssue(WorkOrderItemIssueVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderItemLaborCostListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderItemLaborCostListResult

Packages that use WorkOrderItemLaborCostListResult
bb.common.box

Uses of WorkOrderItemLaborCostListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type WorkOrderItemLaborCostListResult
 java.util.List<WorkOrderItemLaborCostListResult> WorkOrderBox.findWorkOrderItemLaborCost(java.util.Date dateFrom, java.util.Date dateTo, java.lang.String workOrderNumber, java.lang.String vendorID, java.lang.String workCenter, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderItemListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderItemListResult

Packages that use WorkOrderItemListResult
bb.common
bb.common.box

Uses of WorkOrderItemListResult in bb.common

Methods in bb.common that return types with arguments of type WorkOrderItemListResult
 java.util.List<WorkOrderItemListResult> PartsToDeleteResult.getPartsToDeleteInWO()

Method parameters in bb.common with type arguments of type WorkOrderItemListResult
 void PartsToDeleteResult.setPartsToDeleteInWO(java.util.List<WorkOrderItemListResult> partsToDeleteInWO)

Uses of WorkOrderItemListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type WorkOrderItemListResult
java.util.Collection<WorkOrderItemListResult> | WorkOrderBox.addWorkOrderFromMasterWorkOrder(java.util.Date dueDate, WorkOrderItemPK masterWOPk, java.util.HashMap<java.lang.String,java.util.HashSet<WorkOrderItemAgent>> map)
java.util.Collection<WorkOrderItemListResult> | WorkOrderBox.findAllTopMasterWorkOrder(java.util.Date fromDate, java.util.Date toDate, java.lang.String projectName, java.lang.String workOrderNumber, java.lang.String partNumber, java.lang.String partType, boolean isShowCost, boolean isShowMainWO, java.lang.String status, java.lang.String dateType)
java.util.Collection<WorkOrderItemListResult> | WorkOrderBox.findDueWorkOrderItemListResults(int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | WorkOrderBox.findNotSetupWorkOrderItemListResults(java.lang.String woNumber, boolean onlyApprovedWOItem, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | WorkOrderBox.findNotSetupWorkOrderItemListResults(java.lang.String woNumber, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | WorkOrderBox.findOpenUnHoldWorkOrderItemListResults(java.lang.String woNumberLike, java.lang.String partNumberLike, java.lang.String partType, boolean showAllIssued, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | WorkOrderBox.findOpenWorkOrderByVendorId(java.lang.String addressIdLike, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | WorkOrderBox.findOpenWorkOrderItemListResults(boolean orderByDateRequiredAsc, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | WorkOrderBox.findOpenWorkOrderItemListResults(java.lang.String woNumberLike, java.lang.String partNumberLike, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | WorkOrderBox.findOpenWorkOrderItemListResultsByPartPK(PartPK partPk, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | WorkOrderBox.findOpenWorkOrderListResultsByWoNumber(java.lang.String woNumber, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | WorkOrderBox.findWOItemsCanIssue(java.lang.String partFrom, boolean isDueDateType, java.util.Date fromDate, java.util.Date toDate, boolean showAllIssued, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | WorkOrderBox.findWorkOrderItemByVendorId(java.lang.String vendorId, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | WorkOrderBox.findWorkOrderItemListResults(java.lang.String partNumberLike, java.lang.String partType, java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | WorkOrderBox.findWorkOrderItemListResults(java.lang.String woNumberLike, java.lang.String partNumberLike, java.lang.String partType, java.lang.String status, boolean isDue, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | WorkOrderBox.findWorkOrderItemListResultsByDate(java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String partNumberLike, java.lang.String partType, java.lang.String vendId, java.lang.String[] status, java.lang.String project, java.lang.String originator, java.lang.String relateDoc, java.lang.String contact, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isHold, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | WorkOrderBox.findWorkOrderItemListResultsByDateTotal(java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String partNumberLike, java.lang.String partType, java.lang.String vendId, java.lang.String[] status, java.lang.String project, java.lang.String originator, java.lang.String relateDoc, java.lang.String contact, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isHold)
java.util.Collection<WorkOrderItemListResult> | WorkOrderBox.findWorkOrderItemListResultsByPartNumberLike(java.lang.String partNumberLike, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | WorkOrderBox.findWorkOrderItemListResultsWithPartHold(int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | WorkOrderBox.findWorkOrderListResultsByWoNumber(java.lang.String woNumber, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | WorkOrderBox.makeWorkOrders(WorkOrderWorkSheetVO pwsVO)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderItemPartDetail

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderItemPartDetail

Packages that use WorkOrderItemPartDetail
bb.common
bb.common.box

Uses of WorkOrderItemPartDetail in bb.common

Methods in bb.common that return types with arguments of type WorkOrderItemPartDetail
 java.util.List<WorkOrderItemPartDetail> PartsToDeleteResult.getPartsToDeleteInWOItemDetail()

Method parameters in bb.common with type arguments of type WorkOrderItemPartDetail
 void PartsToDeleteResult.setPartsToDeleteInWOItemDetail(java.util.List<WorkOrderItemPartDetail> partsToDeleteInWOItemDetail)

Uses of WorkOrderItemPartDetail in bb.common.box

Methods in bb.common.box that return types with arguments of type WorkOrderItemPartDetail
 java.util.Collection<WorkOrderItemPartDetail> EngineeringBox.findPartsToDeleteInWoItemDetail(int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderItemPartDetailInWipVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderItemPartDetailInWipVO

Packages that use WorkOrderItemPartDetailInWipVO
bb.common.box

Uses of WorkOrderItemPartDetailInWipVO in bb.common.box

Methods in bb.common.box that return types with arguments of type WorkOrderItemPartDetailInWipVO
 java.util.Collection<WorkOrderItemPartDetailInWipVO> WorkOrderBox.findWoiDetailInWipByGlNumber(java.lang.String glNumber, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderItemPartDetailItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderItemPartDetailItemResult

Packages that use WorkOrderItemPartDetailItemResult
bb.common
bb.common.box

Uses of WorkOrderItemPartDetailItemResult in bb.common

Methods in bb.common that return types with arguments of type WorkOrderItemPartDetailItemResult
 java.util.Set<WorkOrderItemPartDetailItemResult> WorkOrderItemPartDetailResult.getItems()

Method parameters in bb.common with type arguments of type WorkOrderItemPartDetailItemResult
 void WorkOrderItemPartDetailResult.setItems(java.util.Set<WorkOrderItemPartDetailItemResult> items)

Uses of WorkOrderItemPartDetailItemResult in bb.common.box

Methods in bb.common.box that return WorkOrderItemPartDetailItemResult
WorkOrderItemPartDetailItemResult | WorkOrderBox.addWorkOrderItemIssue(WorkOrderItemPK itemPk, BB2Part part, java.math.BigDecimal qty)
WorkOrderItemPartDetailItemResult | WorkOrderBox.addWorkOrderItemIssue(WorkOrderItemPK itemPk, java.math.BigDecimal qty, java.math.BigDecimal qtyIssued, java.math.BigDecimal cost, java.lang.String description)
WorkOrderItemPartDetailItemResult | WorkOrderBox.getWorkOrderItemPartDetailItemResult(WorkOrderItemIssuePK pk)
WorkOrderItemPartDetailItemResult | WorkOrderBox.updateWorkOrderItemIssue(WorkOrderItemIssueVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderItemPartDetailResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderItemPartDetailResult

Packages that use WorkOrderItemPartDetailResult
bb.common.box

Uses of WorkOrderItemPartDetailResult in bb.common.box

Methods in bb.common.box that return WorkOrderItemPartDetailResult
WorkOrderItemPartDetailResult | WorkOrderBox.getPartDetailResult(WorkOrderItemPK itemPk)
WorkOrderItemPartDetailResult | WorkOrderBox.getPartDetailResultNoNA(WorkOrderItemPK woItemPk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderItemPK

Packages that use WorkOrderItemPK
bb.common
bb.common.box

Uses of WorkOrderItemPK in bb.common

Methods in bb.common that return WorkOrderItemPK
WorkOrderItemPK | WorkOrderWorkItemDateAgent.getPk()
WorkOrderItemPK | WorkOrderItemWCLoadResult.getPk()
WorkOrderItemPK | WorkOrderItemVO.getPk()
WorkOrderItemPK | WorkOrderItemToIssueResult.getPk()
WorkOrderItemPK | WorkOrderItemSeqWCLoadResult.getPk()
WorkOrderItemPK | WorkOrderItemReviewCostResult.getPk()
WorkOrderItemPK | WorkOrderItemCanAssyResult.getPk()
WorkOrderItemPK | WOItemCostControlAgent.getPk()
WorkOrderItemPK | POForWISeqAgent.getPk()
WorkOrderItemPK | JobProcessSheetListResult.getWoItemItemPk()
WorkOrderItemPK | WorkOrderItemTimeDetailResult.getWoItemPk()
WorkOrderItemPK | WorkOrderItemPartDetailResult.getWoItemPk()
WorkOrderItemPK | WorkOrderItemPartDetail.getWoItemPk()
WorkOrderItemPK | WorkOrderItemListResult.getWoItemPk()
WorkOrderItemPK | WoItemPickListResult.getWoItemPk()
WorkOrderItemPK | EcnWOOrderResult.getWoItemPk()
WorkOrderItemPK | WorkOrderOnOrderResult.getWorkOrderItemPk()
WorkOrderItemPK | WorkOrderOnDemandResult.getWorkOrderItemPk()
WorkOrderItemPK | WorkOrderInWipResult.getWorkOrderItemPk()
WorkOrderItemPK | IssueItemAgent.getWorkOrderItemPk()
WorkOrderItemPK | IssuingItemResult.getWorkOrderItemPK()

Methods in bb.common with parameters of type WorkOrderItemPK
int | WorkOrderItemPK.compareTo(WorkOrderItemPK other)
void | WorkOrderWorkItemDateAgent.setPk(WorkOrderItemPK pk)
void | WorkOrderItemWCLoadResult.setPk(WorkOrderItemPK pk)
void | WorkOrderItemVO.setPk(WorkOrderItemPK pk)
void | WorkOrderItemToIssueResult.setPk(WorkOrderItemPK pk)
void | WorkOrderItemSeqWCLoadResult.setPk(WorkOrderItemPK pk)
void | WorkOrderItemReviewCostResult.setPk(WorkOrderItemPK pk)
void | WorkOrderItemCanAssyResult.setPk(WorkOrderItemPK pk)
void | WOItemCostControlAgent.setPk(WorkOrderItemPK pk)
void | JobProcessSheetListResult.setWoItemItemPk(WorkOrderItemPK woItemItemPk)
void | WorkOrderItemTimeDetailResult.setWoItemPk(WorkOrderItemPK woItemPk)
void | WorkOrderItemPartDetailResult.setWoItemPk(WorkOrderItemPK woItemPk)
void | WorkOrderItemPartDetail.setWoItemPk(WorkOrderItemPK woItemPk)
void | WorkOrderItemListResult.setWoItemPk(WorkOrderItemPK woItemPk)
void | WoItemPickListResult.setWoItemPk(WorkOrderItemPK woItemPk)
void | EcnWOOrderResult.setWoItemPk(WorkOrderItemPK woItemPk)
void | WorkOrderOnOrderResult.setWorkOrderItemPk(WorkOrderItemPK workOrderItemPk)
void | WorkOrderOnDemandResult.setWorkOrderItemPk(WorkOrderItemPK workOrderItemPk)
void | WorkOrderInWipResult.setWorkOrderItemPk(WorkOrderItemPK workOrderItemPk)
void | IssueItemAgent.setWorkOrderItemPk(WorkOrderItemPK workOrderItemPk)
void | IssuingItemResult.setWorkOrderItemPK(WorkOrderItemPK workOrderItemPK)

Constructors in bb.common with parameters of type WorkOrderItemPK
POForWISeqAgent(WorkOrderItemPK pk)

Uses of WorkOrderItemPK in bb.common.box

Methods in bb.common.box that return WorkOrderItemPK
WorkOrderItemPK | WorkOrderBox.reviewWorkOrderItemCost(WorkOrderItemPK pk, java.lang.String desc)
WorkOrderItemPK | WorkOrderBox.setupWorkOrderItem(WorkOrderItemPK itemPk, java.util.ArrayList items, boolean setupByMfg)

Methods in bb.common.box that return types with arguments of type WorkOrderItemPK
 java.util.HashMap<WorkOrderItemPK,java.math.BigDecimal> WorkOrderBox.getWorkOrderMaxReceivableQty(java.lang.String workOrderNumber)

Methods in bb.common.box with parameters of type WorkOrderItemPK
RefdocVO | WorkOrderBox.addRefdocOne(WorkOrderItemPK woItemPk, java.lang.String forderNumber, java.lang.String fItemNumber, java.math.BigDecimal refdocQty)
RefdocVO | WorkOrderBox.addRefdocTwo(WorkOrderItemPK woItemPk, java.lang.String orderNumber, java.lang.String itemNumber, java.math.BigDecimal refdocQty)
java.util.Collection<WorkOrderItemListResult> | WorkOrderBox.addWorkOrderFromMasterWorkOrder(java.util.Date dueDate, WorkOrderItemPK masterWOPk, java.util.HashMap<java.lang.String,java.util.HashSet<WorkOrderItemAgent>> map)
WorkOrderItemPartDetailItemResult | WorkOrderBox.addWorkOrderItemIssue(WorkOrderItemPK itemPk, BB2Part part, java.math.BigDecimal qty)
WorkOrderItemPartDetailItemResult | WorkOrderBox.addWorkOrderItemIssue(WorkOrderItemPK itemPk, java.math.BigDecimal qty, java.math.BigDecimal qtyIssued, java.math.BigDecimal cost, java.lang.String description)
void | WorkOrderBox.addWorkOrderItemIssue(WorkOrderItemPK itemPk, java.util.LinkedHashMap<BB2Part,java.math.BigDecimal> map, java.util.LinkedHashMap<BB2Part,java.lang.String> commentsMap)
WorkOrderWorkInstructionVO | WorkOrderBox.addWorkOrderWorkInstruction(WorkOrderItemPK woItemPk, WorkInstructionPK wiPk)
java.util.ArrayList<WorkOrderItemIssuedTotalResult> | WarehouseBox.findIssuedPartTotal(WorkOrderItemPK pk, PartPK partPk, java.lang.String relatedDoc, java.lang.String modelNumber, java.lang.String common, java.lang.String dateType, java.util.Date dateFrom, java.util.Date dateTo, int firstIndex, int maxLength)
java.util.Collection<PartIssuedVO> | WorkOrderBox.findWorkOrderIssuedDetail(WorkOrderItemPK pk, BB2Part part, java.lang.String description, int firstIndex, int maxLength)
java.util.Collection<WorkOrderIssuedOrderListResult> | WarehouseBox.findWorkOrderIssuedOrderList(WorkOrderItemPK pk)
java.util.Collection<WorkOrderItemIssueVO> | WorkOrderBox.findWorkOrderItemIssues(WorkOrderItemPK itemPk)
java.util.Collection<WorkOrderItemIssueVO> | WorkOrderBox.findWorkOrderItemWithWipIssues(WorkOrderItemPK itemPk, java.util.Date fromDate, java.util.Date toDate)
java.util.Collection<WorkOrderReceiverVO> | WarehouseBox.findWorkOrderReceiversByWorkOrderItemPk(WorkOrderItemPK woiPk, int firstIndex, int maxLength)
java.util.Collection<WorkOrderTimeCardVO> | WorkOrderBox.findWorkOrderTimeCards(WorkOrderItemPK itemPk)
int | WarehouseBox.getIssuedPartTotalCount(WorkOrderItemPK pk, PartPK partPk, java.lang.String relatedDoc, java.lang.String modelNumber, java.lang.String common, java.lang.String dateType, java.util.Date dateFrom, java.util.Date dateTo)
java.util.Collection<IssuingItemResult> | WarehouseBox.getIssuingItemResultForWorkOrderItem(WorkOrderItemPK itemPk)
java.util.Collection<MasterWorkOrderTreeItemResult> | WorkOrderBox.getMasterWorkOrderTreeItem(BillPK billPk, WorkOrderItemPK woItemPk, java.math.BigDecimal qty, boolean calculateOrphan, java.lang.String languageCode)
java.lang.Short | WorkOrderBox.getNextWorkOrderItemIssueItemNumber(WorkOrderItemPK orderItemPk)
WorkOrderItemPartDetailResult | WorkOrderBox.getPartDetailResult(WorkOrderItemPK itemPk)
WorkOrderItemPartDetailResult | WorkOrderBox.getPartDetailResultNoNA(WorkOrderItemPK woItemPk)
java.util.Collection<WorkOrderItemVO> | WorkOrderBox.getSubWorkOrderByWorkOrderItemPK(WorkOrderItemPK itemPk)
WorkOrderItemTimeDetailResult | WorkOrderBox.getTimeDetailResult(WorkOrderItemPK itemPk)
java.util.Collection<WCLoadDetailResult> | ManufacturingBox.getWCLoadDetailResultsforWOItem(WorkOrderItemPK pk)
WoItemPickListResult | WarehouseBox.getWoItemPickListResult(WorkOrderItemPK itemPk, java.math.BigDecimal qty, java.lang.String locationsPrefix)
WorkInstructionSequenceVO | ManufacturingBox.getWorkInstructionSequence(WorkOrderItemPK itemPk, java.lang.String seqNumber)
int | WorkOrderBox.getWorkOrderIssuedDetail(WorkOrderItemPK pk, BB2Part part, java.lang.String description)
PartIssueTotalResult | WorkOrderBox.getWorkOrderIssuedDetailTotal(WorkOrderItemPK pk, BB2Part part, java.lang.String description)
int | WarehouseBox.getWorkOrderIssuedOrderCount(WorkOrderItemPK pk)
WorkOrderItemVO | WorkOrderBox.getWorkOrderItemById(WorkOrderItemPK itemPk)
WorkOrderItemVO | WorkOrderBox.getWorkOrderItemByIdForWOLabel(WorkOrderItemPK itemPk)
int | WorkOrderBox.getWorkOrderItemIssuesCount(WorkOrderItemPK itemPk)
IssuingResult | WarehouseBox.getWorkOrderItemIssuingResult(WorkOrderItemPK itemPk, boolean withOtherLocation)
java.math.BigDecimal | WorkOrderBox.getWorkOrderItemMaxReceivableQty(WorkOrderItemPK itemPk)
int | WorkOrderBox.getWorkOrderItemTimeDetailsCount(WorkOrderItemPK itemPk)
WorkOrderItemVO | WorkOrderBox.getWorkOrderItemWithWIById(WorkOrderItemPK itemPk, java.util.Date fromDate, java.util.Date toDate)
java.math.BigDecimal | WorkOrderBox.getWorkOrderItemWorkCenterSumCost(WorkOrderItemPK itemPk)
int | WarehouseBox.getWorkOrderReceiversCountByWorkOrderItemPk(WorkOrderItemPK woiPk)
WorkOrderWorkInstructionVO | WorkOrderBox.getWorkOrderWorkInstructionByWoItemPk(WorkOrderItemPK pk)
boolean | WorkOrderBox.isWorkInstructionExist(WorkOrderItemPK itemPk, WorkInstructionPK pk)
boolean | WorkOrderBox.isWorkOrderItemExist(WorkOrderItemPK pk)
WorkOrderItemPK | WorkOrderBox.reviewWorkOrderItemCost(WorkOrderItemPK pk, java.lang.String desc)
WorkOrderItemPK | WorkOrderBox.setupWorkOrderItem(WorkOrderItemPK itemPk, java.util.ArrayList items, boolean setupByMfg)
void | WorkOrderBox.setWorkOrderItemReferenceDocOne(WorkOrderItemPK pk, java.lang.String referenceDoc)
void | WorkOrderBox.setWorkOrderItemReferenceDocTwo(WorkOrderItemPK pk, java.lang.String referenceDoc)
void | WorkOrderBox.synchronizeWiSeqToWowiSeq(WorkInstructionPK wiPK, WorkOrderItemPK woiPK)
void | WorkOrderBox.updateWorkOrderItemIssue(WorkOrderItemPK itemPk, java.util.LinkedHashMap<BB2Part,java.math.BigDecimal> map, java.util.LinkedHashMap<BB2Part,java.lang.String> updateCommentsMap)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderItemReviewCostResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderItemReviewCostResult

Packages that use WorkOrderItemReviewCostResult
bb.common.box

Uses of WorkOrderItemReviewCostResult in bb.common.box

Methods in bb.common.box that return types with arguments of type WorkOrderItemReviewCostResult
java.util.Collection<WorkOrderItemReviewCostResult> | WorkOrderBox.findNotReviewedWorkOrderItemReviewCostResults(java.lang.String woLike, java.lang.String vendorID, java.lang.String pnLike, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemReviewCostResult> | WorkOrderBox.findWorkOrderItemReviewCostResults(java.lang.String woLike, java.lang.String vendorID, java.lang.String pnLike, java.lang.String reviewedBy, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderItemSeqWCLoadResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderItemSeqWCLoadResult

Packages that use WorkOrderItemSeqWCLoadResult
bb.common

Uses of WorkOrderItemSeqWCLoadResult in bb.common

Methods in bb.common that return types with arguments of type WorkOrderItemSeqWCLoadResult
 java.util.List<WorkOrderItemSeqWCLoadResult> WorkOrderItemWCLoadResult.getItems()

Method parameters in bb.common with type arguments of type WorkOrderItemSeqWCLoadResult
 void WorkOrderItemWCLoadResult.setItems(java.util.List<WorkOrderItemSeqWCLoadResult> items)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderItemSetupItemAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderItemSetupItemAgent

Packages that use WorkOrderItemSetupItemAgent
bb.common.box

Uses of WorkOrderItemSetupItemAgent in bb.common.box

Method parameters in bb.common.box with type arguments of type WorkOrderItemSetupItemAgent
 java.lang.Object[] WarehouseBox.addWorkOrderAndIssueParts(WorkOrderVO vo, WorkOrderItemVO item, java.util.ArrayList<WorkOrderItemSetupItemAgent> setupList, java.util.Set<IssueItemAgent> issueItemAgents, ReceiverAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderItemTimeDetailResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderItemTimeDetailResult

Packages that use WorkOrderItemTimeDetailResult
bb.common.box

Uses of WorkOrderItemTimeDetailResult in bb.common.box

Methods in bb.common.box that return WorkOrderItemTimeDetailResult
 WorkOrderItemTimeDetailResult WorkOrderBox.getTimeDetailResult(WorkOrderItemPK itemPk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderItemTimeDetailVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderItemTimeDetailVO

Packages that use WorkOrderItemTimeDetailVO
bb.common
bb.common.box

Uses of WorkOrderItemTimeDetailVO in bb.common

Methods in bb.common that return types with arguments of type WorkOrderItemTimeDetailVO
 java.util.List<WorkOrderItemTimeDetailVO> WorkOrderItemTimeDetailResult.getItems()

Method parameters in bb.common with type arguments of type WorkOrderItemTimeDetailVO
 void WorkOrderItemTimeDetailResult.setItems(java.util.List<WorkOrderItemTimeDetailVO> items)

Uses of WorkOrderItemTimeDetailVO in bb.common.box

Methods in bb.common.box that return WorkOrderItemTimeDetailVO
WorkOrderItemTimeDetailVO | WorkOrderBox.addWorkOrderItemTimeDetail(WorkOrderItemTimeDetailVO vo)
WorkOrderItemTimeDetailVO | WorkOrderBox.getWorkOrderItemTimeDetailByPk(java.lang.Long pk)
WorkOrderItemTimeDetailVO | WorkOrderBox.updateWorkOrderItemTimeDetail(WorkOrderItemTimeDetailVO vo)

Methods in bb.common.box that return types with arguments of type WorkOrderItemTimeDetailVO
 java.util.Collection<WorkOrderItemTimeDetailVO> ManufacturingBox.findCloseTimeCards(java.lang.String employeeId, java.lang.String wo, java.lang.String itemNumberNumber, java.util.Date fromDate, java.util.Date toDate, java.lang.String department, java.lang.String workCenter, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type WorkOrderItemTimeDetailVO
WorkOrderItemTimeDetailVO | WorkOrderBox.addWorkOrderItemTimeDetail(WorkOrderItemTimeDetailVO vo)
WorkOrderItemTimeDetailVO | WorkOrderBox.updateWorkOrderItemTimeDetail(WorkOrderItemTimeDetailVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderItemToIssueResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderItemToIssueResult

No usage of bb.common.WorkOrderItemToIssueResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderItemVO

Packages that use WorkOrderItemVO
bb.common.box

Uses of WorkOrderItemVO in bb.common.box

Methods in bb.common.box that return WorkOrderItemVO
WorkOrderItemVO | WorkOrderBox.getWorkOrderItemById(WorkOrderItemPK itemPk)
WorkOrderItemVO | WorkOrderBox.getWorkOrderItemByIdForWOLabel(WorkOrderItemPK itemPk)
WorkOrderItemVO | WorkOrderBox.getWorkOrderItemWithWIById(WorkOrderItemPK itemPk, java.util.Date fromDate, java.util.Date toDate)
WorkOrderItemVO | WorkOrderBox.initWorkOrderItemForNA(java.lang.String woNumber, java.lang.String itemNum, java.lang.String naDesc, java.math.BigDecimal qty)
WorkOrderItemVO | WorkOrderBox.initWorkOrderItemForPart(java.lang.String woNumber, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
WorkOrderItemVO | WorkOrderBox.initWorkOrderItemForTool(java.lang.String woNumber, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)

Methods in bb.common.box that return types with arguments of type WorkOrderItemVO
 java.util.Collection<WorkOrderItemVO> WorkOrderBox.getSubWorkOrderByWorkOrderItemPK(WorkOrderItemPK itemPk)

Methods in bb.common.box with parameters of type WorkOrderItemVO
 java.lang.Object[] WarehouseBox.addWorkOrderAndIssueParts(WorkOrderVO vo, WorkOrderItemVO item, java.util.ArrayList<WorkOrderItemSetupItemAgent> setupList, java.util.Set<IssueItemAgent> issueItemAgents, ReceiverAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderItemWCLoadResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderItemWCLoadResult

Packages that use WorkOrderItemWCLoadResult
bb.common.box

Uses of WorkOrderItemWCLoadResult in bb.common.box

Methods in bb.common.box that return types with arguments of type WorkOrderItemWCLoadResult
 java.util.Collection<WorkOrderItemWCLoadResult> ManufacturingBox.getWorkOrderItemWCLoadResults(WorkCenterAgent agent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderListResult

Packages that use WorkOrderListResult
bb.common.box

Uses of WorkOrderListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type WorkOrderListResult
java.util.Collection<WorkOrderListResult> | WorkOrderBox.findOpenWorkOrderListResults(java.lang.String woNumber, int firstIndex, int maxLength)
java.util.Collection<WorkOrderListResult> | WorkOrderBox.findWorkOrderListResults(java.lang.String woNumber, java.lang.String[] status, java.lang.String vendId, int firstIndex, int maxLength)
java.util.Collection<WorkOrderListResult> | WorkOrderBox.findWorkOrderListResultsByVendorId(java.lang.String vendorId, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderNotSetupResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderNotSetupResult

No usage of bb.common.WorkOrderNotSetupResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderOnDemandResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderOnDemandResult

Packages that use WorkOrderOnDemandResult
bb.common

Uses of WorkOrderOnDemandResult in bb.common

Subclasses of WorkOrderOnDemandResult in bb.common
 class WorkOrderNotSetupResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderOnOrderResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderOnOrderResult

No usage of bb.common.WorkOrderOnOrderResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderOnTimeItemResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderOnTimeItemResult

Packages that use WorkOrderOnTimeItemResult
bb.common

Uses of WorkOrderOnTimeItemResult in bb.common

Methods in bb.common that return types with arguments of type WorkOrderOnTimeItemResult
 java.util.List<WorkOrderOnTimeItemResult> WorkOrderOnTimeResult.getItems()

Method parameters in bb.common with type arguments of type WorkOrderOnTimeItemResult
 void WorkOrderOnTimeResult.setItems(java.util.List<WorkOrderOnTimeItemResult> items)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderOnTimeResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderOnTimeResult

No usage of bb.common.WorkOrderOnTimeResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderOverIssueListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderOverIssueListResult

Packages that use WorkOrderOverIssueListResult
bb.common.box

Uses of WorkOrderOverIssueListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type WorkOrderOverIssueListResult
 java.util.Collection<WorkOrderOverIssueListResult> WorkOrderBox.findOverIssueItemList(boolean isDueDateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String vendorId, java.lang.String workOrderNumber, java.lang.String workOrderItemNumber, java.lang.String partNumber, java.lang.String partType, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderQueryInfo

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderQueryInfo

No usage of bb.common.WorkOrderQueryInfo

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderReceiverVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderReceiverVO

Packages that use WorkOrderReceiverVO
bb.common.box

Uses of WorkOrderReceiverVO in bb.common.box

Methods in bb.common.box that return WorkOrderReceiverVO
 WorkOrderReceiverVO WarehouseBox.findWOReceiverByPk(java.lang.Long pk)

Methods in bb.common.box that return types with arguments of type WorkOrderReceiverVO
java.util.Collection<WorkOrderReceiverVO> | WarehouseBox.findAllWorkOrderReceivers(int firstIndex, int maxLength)
java.util.Collection<WorkOrderReceiverVO> | WarehouseBox.findWorkOrderReceiversByWorkOrderItemPk(WorkOrderItemPK woiPk, int firstIndex, int maxLength)
java.util.Collection<WorkOrderReceiverVO> | WorkOrderBox.getWOReceiverItemListResultsOfWorkOrder(java.lang.String woNumber)

Methods in bb.common.box with parameters of type WorkOrderReceiverVO
void | WarehouseBox.addWOReceiver(WorkOrderReceiverVO vo)
void | WarehouseBox.deleteWOReceiver(WorkOrderReceiverVO vo)
void | WarehouseBox.updateWOReceiver(WorkOrderReceiverVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderTimeCardVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderTimeCardVO

Packages that use WorkOrderTimeCardVO
bb.common
bb.common.box

Uses of WorkOrderTimeCardVO in bb.common

Methods in bb.common that return types with arguments of type WorkOrderTimeCardVO
 java.util.List<WorkOrderTimeCardVO> EmployeeTimeCardResult.getTimeCards()

Method parameters in bb.common with type arguments of type WorkOrderTimeCardVO
 void EmployeeTimeCardResult.setTimeCards(java.util.List<WorkOrderTimeCardVO> timeCards)

Uses of WorkOrderTimeCardVO in bb.common.box

Methods in bb.common.box that return WorkOrderTimeCardVO
WorkOrderTimeCardVO | ManufacturingBox.addTimeCard(WorkOrderTimeCardVO vo)
WorkOrderTimeCardVO | ManufacturingBox.addTimeCard(WorkOrderTimeCardVO vo, boolean unFinished)
WorkOrderTimeCardVO | ManufacturingBox.findTimeCardByPk(java.lang.Long pk)
WorkOrderTimeCardVO | ManufacturingBox.updateTimeCard(WorkOrderTimeCardVO vo)

Methods in bb.common.box that return types with arguments of type WorkOrderTimeCardVO
java.util.Collection<WorkOrderTimeCardVO> | ManufacturingBox.findAllTimeCards(int firstIndex, int maxLength)
java.util.Collection<WorkOrderTimeCardVO> | ManufacturingBox.findOpenTimeCardsByEmployeeLike(java.lang.String employeeId, int firstIndex, int maxLength)
java.util.Collection<WorkOrderTimeCardVO> | ManufacturingBox.findTimeCardsByVendorId(java.lang.String vendorId, int firstIndex, int maxLength)
java.util.Collection<WorkOrderTimeCardVO> | ManufacturingBox.findTimeCardsByWO(java.lang.String workOrder, int firstIndex, int maxLength)
java.util.Collection<WorkOrderTimeCardVO> | WorkOrderBox.findWorkOrderTimeCards(WorkOrderItemPK itemPk)

Methods in bb.common.box with parameters of type WorkOrderTimeCardVO
WorkOrderTimeCardVO | ManufacturingBox.addTimeCard(WorkOrderTimeCardVO vo)
WorkOrderTimeCardVO | ManufacturingBox.addTimeCard(WorkOrderTimeCardVO vo, boolean unFinished)
void | ManufacturingBox.deleteTimeCard(WorkOrderTimeCardVO vo)
void | ManufacturingBox.logOffTimeCard(WorkOrderTimeCardVO vo)
WorkOrderTimeCardVO | ManufacturingBox.updateTimeCard(WorkOrderTimeCardVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderVO

Packages that use WorkOrderVO
bb.common.box

Uses of WorkOrderVO in bb.common.box

Methods in bb.common.box that return WorkOrderVO
WorkOrderVO | WorkOrderBox.approveWorkOrder(WorkOrderVO vo)
WorkOrderVO | SalesBox.copyWorkOrderFromSalesOrder(SO2WOAgent agent)
WorkOrderVO | WorkOrderBox.getWorkOrderByWo(java.lang.String id)
WorkOrderVO | QualityBox.getWorkOrderByWoForIR(java.lang.String id)
WorkOrderVO | WorkOrderBox.getWorkOrderWithOrderApplyByWo(java.lang.Long orderApplyID)

Methods in bb.common.box with parameters of type WorkOrderVO
java.lang.Object[] | WarehouseBox.addWorkOrderAndIssueParts(WorkOrderVO vo, WorkOrderItemVO item, java.util.ArrayList<WorkOrderItemSetupItemAgent> setupList, java.util.Set<IssueItemAgent> issueItemAgents, ReceiverAgent agent)
java.lang.String | WarehouseBox.addWorkOrderAndReceiveParts(WorkOrderVO clientVO)
WorkOrderVO | WorkOrderBox.approveWorkOrder(WorkOrderVO vo)
void | WorkOrderBox.deleteWorkOrder(WorkOrderVO vo)
java.lang.String | WorkOrderBox.updateWorkOrder(WorkOrderVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderWorkInstructionListResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderWorkInstructionListResult

Packages that use WorkOrderWorkInstructionListResult
bb.common.box

Uses of WorkOrderWorkInstructionListResult in bb.common.box

Methods in bb.common.box that return types with arguments of type WorkOrderWorkInstructionListResult
 java.util.Collection<WorkOrderWorkInstructionListResult> WorkOrderBox.findWorkOrderInstructionSeq(java.lang.String partNumber, java.lang.String partType, java.lang.String workOrderNumber, java.lang.String status, int firstIndex, int maxLength)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderWorkInstructionPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderWorkInstructionPK

Packages that use WorkOrderWorkInstructionPK
bb.common
bb.common.box

Uses of WorkOrderWorkInstructionPK in bb.common

Methods in bb.common that return WorkOrderWorkInstructionPK
 WorkOrderWorkInstructionPK WorkOrderWorkInstructionVO.getPk()

Methods in bb.common with parameters of type WorkOrderWorkInstructionPK
 void WorkOrderWorkInstructionVO.setPk(WorkOrderWorkInstructionPK pk)

Uses of WorkOrderWorkInstructionPK in bb.common.box

Methods in bb.common.box with parameters of type WorkOrderWorkInstructionPK
void | WorkOrderBox.deleteAllWorkOrderWorkInstructionSequences(WorkOrderWorkInstructionPK pk)
void | WorkOrderBox.deleteWorkOrderWorkInstruction(WorkOrderWorkInstructionPK pk)
java.util.Collection<WorkOrderWorkInstructionSequenceVO> | WorkOrderBox.findWorkOrderWorkInstructionSequences(WorkOrderWorkInstructionPK pk)
WorkOrderWorkInstructionVO | WorkOrderBox.getWorkOrderWorkInstructionByPk(WorkOrderWorkInstructionPK pk)
int | WorkOrderBox.getWorkOrderWorkInstructionSequencesCount(WorkOrderWorkInstructionPK pk)
boolean | WorkOrderBox.isWorkOrderWorkInstructionExist(WorkOrderWorkInstructionPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderWorkInstructionSequenceDateAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderWorkInstructionSequenceDateAgent

Packages that use WorkOrderWorkInstructionSequenceDateAgent
bb.common.box

Uses of WorkOrderWorkInstructionSequenceDateAgent in bb.common.box

Method parameters in bb.common.box with type arguments of type WorkOrderWorkInstructionSequenceDateAgent
 void WorkOrderBox.saveWoItemSeqStartDate(java.util.ArrayList<WorkOrderWorkInstructionSequenceDateAgent> wisList)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderWorkInstructionSequencePK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderWorkInstructionSequencePK

Packages that use WorkOrderWorkInstructionSequencePK
bb.common
bb.common.box

Uses of WorkOrderWorkInstructionSequencePK in bb.common

Methods in bb.common that return WorkOrderWorkInstructionSequencePK
WorkOrderWorkInstructionSequencePK | WorkOrderWorkInstructionSequenceVO.getPk()
WorkOrderWorkInstructionSequencePK | WorkOrderWorkInstructionSequenceDateAgent.getPk()
WorkOrderWorkInstructionSequencePK | WCLoadByDateResult.getPk()

Methods in bb.common that return types with arguments of type WorkOrderWorkInstructionSequencePK
java.util.Iterator<WorkOrderWorkInstructionSequencePK> | POForWISeqAgent.getSeqPKs()
java.util.Iterator<WorkOrderWorkInstructionSequencePK> | POForWISeqAgent.getSeqPKs(java.lang.String vendorID)

Methods in bb.common with parameters of type WorkOrderWorkInstructionSequencePK
void | POForWISeqAgent.addItem(java.lang.String vendorID, WorkOrderWorkInstructionSequencePK item)
void | POForWISeqAgent.addItem(java.lang.String vendorID, WorkOrderWorkInstructionSequencePK item, java.util.Date requireDate, java.math.BigDecimal price)
java.math.BigDecimal | POForWISeqAgent.getPrice(WorkOrderWorkInstructionSequencePK pk)
java.util.Date | POForWISeqAgent.getRequireDate(WorkOrderWorkInstructionSequencePK pk)
void | POForWISeqAgent.removeItem(WorkOrderWorkInstructionSequencePK item)
void | WorkOrderWorkInstructionSequenceVO.setPk(WorkOrderWorkInstructionSequencePK pk)
void | WorkOrderWorkInstructionSequenceDateAgent.setPk(WorkOrderWorkInstructionSequencePK pk)
void | WCLoadByDateResult.setPk(WorkOrderWorkInstructionSequencePK pk)

Uses of WorkOrderWorkInstructionSequencePK in bb.common.box

Methods in bb.common.box with parameters of type WorkOrderWorkInstructionSequencePK
java.lang.String | PurchasingBox.addPurchaseOrderFromWISeq(java.lang.String vendorID, WorkOrderWorkInstructionSequencePK seqPk)
void | WorkOrderBox.finishWorkOrderWorkInstructionSequence(WorkOrderWorkInstructionSequencePK pk, boolean finish)
WorkOrderWorkInstructionSequenceVO | WorkOrderBox.getWorkOrderWorkInstructionSequenceByPk(WorkOrderWorkInstructionSequencePK pk)
java.lang.String | WorkOrderBox.getWOWISeqDescription(WorkOrderWorkInstructionSequencePK pk)
boolean | WorkOrderBox.isWorkOrderWorkInstructionSequencesFinished(WorkOrderWorkInstructionSequencePK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderWorkInstructionSequenceVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderWorkInstructionSequenceVO

Packages that use WorkOrderWorkInstructionSequenceVO
bb.common
bb.common.box

Uses of WorkOrderWorkInstructionSequenceVO in bb.common

Methods in bb.common that return types with arguments of type WorkOrderWorkInstructionSequenceVO
 java.util.Set<WorkOrderWorkInstructionSequenceVO> WorkOrderWorkInstructionListResult.getSequences()

Method parameters in bb.common with type arguments of type WorkOrderWorkInstructionSequenceVO
 void WorkOrderWorkInstructionListResult.setSequences(java.util.Set<WorkOrderWorkInstructionSequenceVO> sequences)

Uses of WorkOrderWorkInstructionSequenceVO in bb.common.box

Methods in bb.common.box that return WorkOrderWorkInstructionSequenceVO
WorkOrderWorkInstructionSequenceVO | WorkOrderBox.addWorkOrderWorkInstructionSequence(WorkOrderWorkInstructionSequenceVO vo)
WorkOrderWorkInstructionSequenceVO | WorkOrderBox.getWorkOrderWorkInstructionSequenceByPk(WorkOrderWorkInstructionSequencePK pk)

Methods in bb.common.box that return types with arguments of type WorkOrderWorkInstructionSequenceVO
 java.util.Collection<WorkOrderWorkInstructionSequenceVO> WorkOrderBox.findWorkOrderWorkInstructionSequences(WorkOrderWorkInstructionPK pk)

Methods in bb.common.box with parameters of type WorkOrderWorkInstructionSequenceVO
WorkOrderWorkInstructionSequenceVO | WorkOrderBox.addWorkOrderWorkInstructionSequence(WorkOrderWorkInstructionSequenceVO vo)
void | WorkOrderBox.deleteWorkOrderWorkInstructionSequence(WorkOrderWorkInstructionSequenceVO vo)
void | WorkOrderBox.updateWorkOrderWorkInstructionSequence(WorkOrderWorkInstructionSequenceVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderWorkInstructionVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderWorkInstructionVO

Packages that use WorkOrderWorkInstructionVO
bb.common.box

Uses of WorkOrderWorkInstructionVO in bb.common.box

Methods in bb.common.box that return WorkOrderWorkInstructionVO
WorkOrderWorkInstructionVO | WorkOrderBox.addWorkOrderWorkInstruction(WorkOrderItemPK woItemPk, WorkInstructionPK wiPk)
WorkOrderWorkInstructionVO | WorkOrderBox.addWorkOrderWorkInstruction(WorkOrderWorkInstructionVO vo)
WorkOrderWorkInstructionVO | WorkOrderBox.getWorkOrderWorkInstructionByPk(WorkOrderWorkInstructionPK pk)
WorkOrderWorkInstructionVO | WorkOrderBox.getWorkOrderWorkInstructionByWoItemPk(WorkOrderItemPK pk)
WorkOrderWorkInstructionVO | WorkOrderBox.updateWorkOrderWorkInstruction(WorkOrderWorkInstructionVO vo)

Methods in bb.common.box with parameters of type WorkOrderWorkInstructionVO
WorkOrderWorkInstructionVO | WorkOrderBox.addWorkOrderWorkInstruction(WorkOrderWorkInstructionVO vo)
void | WorkOrderBox.deleteWorkOrderWorkInstruction(WorkOrderWorkInstructionVO vo)
WorkOrderWorkInstructionVO | WorkOrderBox.updateWorkOrderWorkInstruction(WorkOrderWorkInstructionVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderWorkItemDateAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderWorkItemDateAgent

Packages that use WorkOrderWorkItemDateAgent
bb.common.box

Uses of WorkOrderWorkItemDateAgent in bb.common.box

Method parameters in bb.common.box with type arguments of type WorkOrderWorkItemDateAgent
 void WorkOrderBox.saveWorkOrderItemDate(java.util.ArrayList<WorkOrderWorkItemDateAgent> woiList)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderWorkSheetItemPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderWorkSheetItemPK

Packages that use WorkOrderWorkSheetItemPK
bb.common

Uses of WorkOrderWorkSheetItemPK in bb.common

Methods in bb.common that return WorkOrderWorkSheetItemPK
 WorkOrderWorkSheetItemPK WorkOrderWorkSheetItemVO.getPk()

Methods in bb.common with parameters of type WorkOrderWorkSheetItemPK
 void WorkOrderWorkSheetItemVO.setPk(WorkOrderWorkSheetItemPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderWorkSheetItemVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderWorkSheetItemVO

Packages that use WorkOrderWorkSheetItemVO
bb.common
bb.common.box

Uses of WorkOrderWorkSheetItemVO in bb.common

Methods in bb.common that return WorkOrderWorkSheetItemVO
 WorkOrderWorkSheetItemVO WorkOrderWorkSheetItemWithRelatedInfoResult.getWorkSheetItem()

Methods in bb.common with parameters of type WorkOrderWorkSheetItemVO
 void WorkOrderWorkSheetItemWithRelatedInfoResult.setWorkSheetItem(WorkOrderWorkSheetItemVO workSheetItem)

Uses of WorkOrderWorkSheetItemVO in bb.common.box

Methods in bb.common.box that return WorkOrderWorkSheetItemVO
 WorkOrderWorkSheetItemVO WorkOrderBox.addWorkOrderWorkSheetItem(WorkOrderWorkSheetItemVO pwsItemVO)

Methods in bb.common.box with parameters of type WorkOrderWorkSheetItemVO
WorkOrderWorkSheetItemVO | WorkOrderBox.addWorkOrderWorkSheetItem(WorkOrderWorkSheetItemVO pwsItemVO)
void | WorkOrderBox.deleteWorkOrderWorkSheetItem(WorkOrderWorkSheetItemVO pwsItemVO)
void | WorkOrderBox.updateWorkOrderWorkSheetItem(WorkOrderWorkSheetItemVO pwsItemVO)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderWorkSheetItemWithRelatedInfoResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderWorkSheetItemWithRelatedInfoResult

Packages that use WorkOrderWorkSheetItemWithRelatedInfoResult
bb.common.box

Uses of WorkOrderWorkSheetItemWithRelatedInfoResult in bb.common.box

Methods in bb.common.box that return WorkOrderWorkSheetItemWithRelatedInfoResult
WorkOrderWorkSheetItemWithRelatedInfoResult | WorkOrderBox.initWorkOrderWorkSheetItemForPart(WorkOrderWorkSheetPK pk, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
WorkOrderWorkSheetItemWithRelatedInfoResult | WorkOrderBox.initWorkOrderWorkSheetItemForTool(WorkOrderWorkSheetPK pk, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)

Methods in bb.common.box that return types with arguments of type WorkOrderWorkSheetItemWithRelatedInfoResult
 java.util.Collection<WorkOrderWorkSheetItemWithRelatedInfoResult> WorkOrderBox.findWorkOrderWorkSheetItemsByWorkSheetPk(WorkOrderWorkSheetPK workSheetPk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderWorkSheetPK

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderWorkSheetPK

Packages that use WorkOrderWorkSheetPK
bb.common
bb.common.box

Uses of WorkOrderWorkSheetPK in bb.common

Methods in bb.common that return WorkOrderWorkSheetPK
 WorkOrderWorkSheetPK WorkOrderWorkSheetVO.getPk()

Methods in bb.common with parameters of type WorkOrderWorkSheetPK
 void WorkOrderWorkSheetVO.setPk(WorkOrderWorkSheetPK pk)

Uses of WorkOrderWorkSheetPK in bb.common.box

Methods in bb.common.box with parameters of type WorkOrderWorkSheetPK
java.util.Collection<WorkOrderWorkSheetItemWithRelatedInfoResult> | WorkOrderBox.findWorkOrderWorkSheetItemsByWorkSheetPk(WorkOrderWorkSheetPK workSheetPk)
WorkOrderWorkSheetVO | WorkOrderBox.getWorkOrderWorkSheetByPk(WorkOrderWorkSheetPK pk)
WorkOrderWorkSheetItemWithRelatedInfoResult | WorkOrderBox.initWorkOrderWorkSheetItemForPart(WorkOrderWorkSheetPK pk, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
WorkOrderWorkSheetItemWithRelatedInfoResult | WorkOrderBox.initWorkOrderWorkSheetItemForTool(WorkOrderWorkSheetPK pk, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
boolean | WorkOrderBox.isWorkOrderWorkSheetExistent(WorkOrderWorkSheetPK pk)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkOrderWorkSheetVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkOrderWorkSheetVO

Packages that use WorkOrderWorkSheetVO
bb.common.box

Uses of WorkOrderWorkSheetVO in bb.common.box

Methods in bb.common.box that return WorkOrderWorkSheetVO
WorkOrderWorkSheetVO | WorkOrderBox.addWorkOrderWorkSheet()
WorkOrderWorkSheetVO | WorkOrderBox.addWorkOrderWorkSheet(java.util.ArrayList list)
WorkOrderWorkSheetVO | WorkOrderBox.addWorkOrderWorkSheet(WorkOrderWorkSheetVO pwsVO)
WorkOrderWorkSheetVO | WorkOrderBox.getWorkOrderWorkSheetByPk(WorkOrderWorkSheetPK pk)
WorkOrderWorkSheetVO | WorkOrderBox.updateWorkOrderWorkSheet(WorkOrderWorkSheetVO pwsVO)

Methods in bb.common.box that return types with arguments of type WorkOrderWorkSheetVO
java.util.Collection<WorkOrderWorkSheetVO> | WorkOrderBox.findAllMyWorkOrderWorkSheet(int firstIndex, int maxLength)
java.util.Collection<WorkOrderWorkSheetVO> | WorkOrderBox.findAllWorkOrderWorkSheet(int firstIndex, int maxLength)
java.util.Collection<WorkOrderWorkSheetVO> | WorkOrderBox.findWorkOrderWorkSheetByEmployeeEmailLike(java.lang.String employeeEmailLike, int firstIndex, int maxLength)
java.util.Collection<WorkOrderWorkSheetVO> | WorkOrderBox.findWorkOrderWorkSheetByEmployeeId(java.lang.String employeeId, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type WorkOrderWorkSheetVO
WorkOrderWorkSheetVO | WorkOrderBox.addWorkOrderWorkSheet(WorkOrderWorkSheetVO pwsVO)
void | WorkOrderBox.deleteWorkOrderWorkSheet(WorkOrderWorkSheetVO pwsVO)
java.lang.Integer | WorkOrderBox.getNextWorkOrderWorkSheetItemNumber(WorkOrderWorkSheetVO vo)
java.util.Collection<WorkOrderItemListResult> | WorkOrderBox.makeWorkOrders(WorkOrderWorkSheetVO pwsVO)
WorkOrderWorkSheetVO | WorkOrderBox.updateWorkOrderWorkSheet(WorkOrderWorkSheetVO pwsVO)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkPeriodVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkPeriodVO

No usage of bb.common.WorkPeriodVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.WorkSheetPartAgent

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.WorkSheetPartAgent

No usage of bb.common.WorkSheetPartAgent

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.YearMonthManager

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.YearMonthManager

No usage of bb.common.YearMonthManager

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ZipCodeTaxVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ZipCodeTaxVO

Packages that use ZipCodeTaxVO
bb.common.box

Uses of ZipCodeTaxVO in bb.common.box

Methods in bb.common.box that return ZipCodeTaxVO
ZipCodeTaxVO | CompanyBox.addZipCodeTax(ZipCodeTaxVO vo)
ZipCodeTaxVO | CompanyBox.getZipCodeTaxByPK(int ii)
ZipCodeTaxVO | CompanyBox.updateZipCodeTax(ZipCodeTaxVO vo)

Methods in bb.common.box that return types with arguments of type ZipCodeTaxVO
 java.util.Collection<ZipCodeTaxVO> CompanyBox.findAllZipCodeTaxByTaxType(java.lang.String taxType, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type ZipCodeTaxVO
ZipCodeTaxVO | CompanyBox.addZipCodeTax(ZipCodeTaxVO vo)
void | CompanyBox.deleteZipCodeTax(ZipCodeTaxVO vo)
ZipCodeTaxVO | CompanyBox.updateZipCodeTax(ZipCodeTaxVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ZipcodeTotalsResult

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ZipcodeTotalsResult

Packages that use ZipcodeTotalsResult
bb.common
bb.common.box

Uses of ZipcodeTotalsResult in bb.common

Methods in bb.common with parameters of type ZipcodeTotalsResult
 int ZipcodeTotalsResult.compareTo(ZipcodeTotalsResult other)

Uses of ZipcodeTotalsResult in bb.common.box

Methods in bb.common.box that return ZipcodeTotalsResult
ZipcodeTotalsResult | CompanyBox.getStateTotal(java.lang.String state, java.util.Date fromDate, java.util.Date toDate)
ZipcodeTotalsResult | CompanyBox.getTaxTotal(java.util.Date fromDate, java.util.Date toDate)

Methods in bb.common.box that return types with arguments of type ZipcodeTotalsResult
java.util.Collection<ZipcodeTotalsResult> | CompanyBox.findReceiptByCustomer(java.util.Date fromDate, java.util.Date toDate)
java.util.HashMap<java.lang.String,java.util.List<ZipcodeTotalsResult>> | CompanyBox.findTaxComputationByState(java.lang.String state, java.util.Date fromDate, java.util.Date toDate)
java.util.HashMap<java.lang.String,java.util.List<ZipcodeTotalsResult>> | CompanyBox.findTaxComputationByZipCode(java.util.Date fromDate, java.util.Date toDate)
java.util.Collection<ZipcodeTotalsResult> | CompanyBox.findTaxExemptTotalByCity(java.lang.String city, java.util.Date fromDate, java.util.Date toDate)
java.util.Collection<ZipcodeTotalsResult> | CompanyBox.findTaxExemptTotalByCustomerId(java.util.Date fromDate, java.util.Date toDate)
java.util.Collection<ZipcodeTotalsResult> | CompanyBox.findTaxExemptTotalByTaxType(java.util.Date fromDate, java.util.Date toDate)
java.util.Collection<ZipcodeTotalsResult> | CompanyBox.findTaxTotalByCustomerId(java.util.Date fromDate, java.util.Date toDate)
java.util.Collection<ZipcodeTotalsResult> | CompanyBox.findTaxTotalByZipCode(java.util.Date fromDate, java.util.Date toDate)
java.util.List<ZipcodeTotalsResult> | CompanyBox.getAddressesNoTaxInfo(java.util.Date fromDate, java.util.Date toDate)
java.util.List<ZipcodeTotalsResult> | CompanyBox.getStateTotalDetail(java.lang.String state, java.util.Date fromDate, java.util.Date toDate, java.lang.String type)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ZipCodeVO

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ZipCodeVO

Packages that use ZipCodeVO
bb.common.box

Uses of ZipCodeVO in bb.common.box

Methods in bb.common.box that return ZipCodeVO
ZipCodeVO | CompanyBox.addZipCode(ZipCodeVO vo)
ZipCodeVO | CompanyBox.getZipCodeByPk(java.lang.String zipId)
ZipCodeVO | CompanyBox.updateZipCode(ZipCodeVO vo)

Methods in bb.common.box that return types with arguments of type ZipCodeVO
 java.util.Collection<ZipCodeVO> CompanyBox.findAllZipCode(java.lang.String zipId, int firstIndex, int maxLength)

Methods in bb.common.box with parameters of type ZipCodeVO
ZipCodeVO | CompanyBox.addZipCode(ZipCodeVO vo)
ZipCodeVO | CompanyBox.updateZipCode(ZipCodeVO vo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class bb.common.ZippedByteArray

PREV NEXT FRAMES NO FRAMES

Uses of Class
bb.common.ZippedByteArray

No usage of bb.common.ZippedByteArray

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface bb.common.Alarmable

PREV NEXT FRAMES NO FRAMES

Uses of Interface
bb.common.Alarmable

Packages that use Alarmable
bb.common

Uses of Alarmable in bb.common

Classes in bb.common that implement Alarmable
class | AccountCreditVO
class | AccountDebitVO
class | AccountsCreditDebitListResult
class | APAuditListResult
class | ARAuditListResult
class | LockedCustomerAddressResult
class | PartCatalogAuditResult
class | PartOnHandAuditResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface bb.common.box.AccountingBox

PREV NEXT FRAMES NO FRAMES

Uses of Interface
bb.common.box.AccountingBox

No usage of bb.common.box.AccountingBox

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface bb.common.box.AddressBox

PREV NEXT FRAMES NO FRAMES

Uses of Interface
bb.common.box.AddressBox

No usage of bb.common.box.AddressBox

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface bb.common.box.CompanyBox

PREV NEXT FRAMES NO FRAMES

Uses of Interface
bb.common.box.CompanyBox

No usage of bb.common.box.CompanyBox

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface bb.common.box.CustomerServiceBox

PREV NEXT FRAMES NO FRAMES

Uses of Interface
bb.common.box.CustomerServiceBox

No usage of bb.common.box.CustomerServiceBox

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface bb.common.box.DocumentBox

PREV NEXT FRAMES NO FRAMES

Uses of Interface
bb.common.box.DocumentBox

No usage of bb.common.box.DocumentBox

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface bb.common.box.EngineeringBox

PREV NEXT FRAMES NO FRAMES

Uses of Interface
bb.common.box.EngineeringBox

No usage of bb.common.box.EngineeringBox

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface bb.common.box.HumanResourceBox

PREV NEXT FRAMES NO FRAMES

Uses of Interface
bb.common.box.HumanResourceBox

No usage of bb.common.box.HumanResourceBox

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface bb.common.box.LogBox

PREV NEXT FRAMES NO FRAMES

Uses of Interface
bb.common.box.LogBox

No usage of bb.common.box.LogBox

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface bb.common.box.ManagementBox

PREV NEXT FRAMES NO FRAMES

Uses of Interface
bb.common.box.ManagementBox

No usage of bb.common.box.ManagementBox

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface bb.common.box.ManufacturingBox

PREV NEXT FRAMES NO FRAMES

Uses of Interface
bb.common.box.ManufacturingBox

No usage of bb.common.box.ManufacturingBox

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface bb.common.box.PlanningBox

PREV NEXT FRAMES NO FRAMES

Uses of Interface
bb.common.box.PlanningBox

No usage of bb.common.box.PlanningBox

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface bb.common.box.PurchasingBox

PREV NEXT FRAMES NO FRAMES

Uses of Interface
bb.common.box.PurchasingBox

No usage of bb.common.box.PurchasingBox

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface bb.common.box.QualityBox

PREV NEXT FRAMES NO FRAMES

Uses of Interface
bb.common.box.QualityBox

No usage of bb.common.box.QualityBox

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface bb.common.box.SalesBox

PREV NEXT FRAMES NO FRAMES

Uses of Interface
bb.common.box.SalesBox

No usage of bb.common.box.SalesBox

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface bb.common.box.SecurityBox

PREV NEXT FRAMES NO FRAMES

Uses of Interface
bb.common.box.SecurityBox

No usage of bb.common.box.SecurityBox

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface bb.common.box.WarehouseBox

PREV NEXT FRAMES NO FRAMES

Uses of Interface
bb.common.box.WarehouseBox

No usage of bb.common.box.WarehouseBox

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface bb.common.box.WorkOrderBox

PREV NEXT FRAMES NO FRAMES

Uses of Interface
bb.common.box.WorkOrderBox

No usage of bb.common.box.WorkOrderBox

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface bb.common.Facade

PREV NEXT FRAMES NO FRAMES

Uses of Interface
bb.common.Facade

No usage of bb.common.Facade

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Package bb.common

PREV NEXT FRAMES NO FRAMES

Uses of Package
bb.common

Packages that use bb.common
bb.common
bb.common.box

Classes in bb.common used by bb.common
AccountCreditDebitPK
AccountCreditVO
AccountingTransactionTypeVO
AccountMonthPK
AccountsChartCategoryVO
AccountsChartMappingPK
AccountsChartVO
AccountsCreditDebitListResult
AccountsPayableItemManufacturerPK
AccountsPayableItemPK
AccountsPayableItemVO
AccountsReceivableItemManufacturerPK
AccountsReceivableItemPK
AccountsReceivableItemVO
AccountsReceivableVO
AddProformaReceiverItemAgent
Alarmable
AllPartDocumentsPK
APItemListResult
ApPrepayItemPK
ApPrepayItemVO
ARPaymentRunItemPK
ArPrepayItemPK
ArPrepayItemVO
AssetAmortizationExpenseAccountPK
AssetAmortizationExpenseAccountVO
AssetDepreciatePK
AssetUsagePK
BalanceSheetSideBySideItemResult
BB2AttachFile
BB2Event
BB2File
BB2Login
BB2Part
BB2PartBasicInfo
BB2PartInfo
BB2ServerException
BillDetailCostWithPartInfoResult
BillItemOnHandWithPartInfoResult
BillItemPK
BillItemReplacementVO
BillItemUsagePathResult
BillItemUsageResult
BillItemWithPartInfoResult
BillPK
BillWhereUsedItemResult
BillWithPartInfoResult
BizBoxServer
BizException
BudgetListResult
CarrierPK
ChangeStdCostWorkSheetItemPK
ClosingStatementTotalResult
CompanyUnitAccountPK
ContractPriceCustomerPK
ContractPriceCustomerVO
ContractPriceItemPK
ContractPriceItemVO
CurrencyExchangePK
CurrencyVO
CustomAssetRecordPK
CustomDepartmentVO
CustomEmployeeTrainPK
CustomerReturnToVendorItemPK
CustomerReturnToVendorItemVO
CustomerStatementTotalResult
CustomerVendorAddressInfoVO
CustomerVendorContactPK
CustomerVendorContactVO
CustomerVendorDescriptionPK
CustomJobCategoryGoodsPK
CycleCountPK
DBAccessException
DisassembleWorkOrderIssuingItemResult
DisassembleWorkOrderItemPartDetailItemResult
DisassembleWorkOrderItemPK
DisassembleWorkOrderItemReceiverPK
DisassembleWorkOrderItemReceiverVO
DynamicSearchFilter
EjbMethodVO
EmployeeCardVO
EmployeeEducationPK
EmployeeEducationVO
EmployeeWorkExperiencePK
EngGroupUserPK
EngineeringChangeListResult
EngineeringSharingItemPK
EquipmentVO
ExpenseItemPK
FeedbackAnswerPK
FeedBackItemPK
FeedbackQuestionVO
FiscalYearSettingsVO
GeneralLedgerByDateListResult
GeneralLedgerEntry
GeneralLedgerListResult
GeneralLedgerVO
GlBalanceInfoResult
GroupUserPK
InfoByMonthResult
InspectionConformanceReportItemCheckPK
InspectionConformanceReportItemPK
InspectionConformanceReportItemVO
InspectionItemPK
InspectionReportInspectMethodItemPK
InspectionReportInspectMethodItemVO
InspectionReportInspectMethodVO
InspectionReportInspectStandardItemPK
InspectionReportInspectStandardItemVO
InspectionReportItemPK
InspectionReportItemQtyPK
InspectionReportItemQtyVO
InspectionReportItemVO
InspectionTypeItemPK
InventoryAdjustmentVO
InventoryNotUsedInMonthsResult
InventoryReportListResult
InvoiceItemListResult
IssueItemDetailAgent
JounalEntryListResult
LabelTemplateItemPK
LabelTemplateItemVO
LogMethodPK
MaintenanceItemPK
ManufacturerContactPK
ManufacturerDescriptionPK
Money
MultiLanguageAccountsChartPK
MultiLanguageAccountsChartVO
MyPrintListPK
NcrApprovalPK
NonConformanceCodeDescriptionPK
NonConformanceCodeDescriptionVO
NonConformanceCodeVO
NonConformanceQuantityPK
NonConformanceReportVO
NonproductivePickingItemPK
NonproductivePickingItemVO
NonproductivePickingOnDemandResult
OnLoanItemPK
OnloanReceiverItemPK
OnloanShipperItemPK
OpCodeShortcutPK
OperatingInstructionsInspectMethodItemPK
OperatingInstructionsInspectMethodItemVO
OperatingInstructionsInspectResultItemPK
OperatingInstructionsInspectResultItemVO
OperatingInstructionsInspectStandardItemPK
OperatingInstructionsInspectStandardItemVO
OperatingInstructionsInspectStandardVO
OperatingInstructionsManualItemPK
OperatingInstructionsManualItemVO
OperatingInstructionsManualVO
OperatingInstructionsTypeVO
OperatingOutputFileItemPK
OperatingOutputFileItemVO
OperatingOutputFileTypeVO
OrderApprovalVO
OrderApproval generated by MyEclipse Persistence Tools
OrderBoilerplatePK
OrderBy
OrderDocumentVO
OrderPK
OrderVendorItem
PackingBoxItemPK
PackingBoxItemVO
PackingBoxPK
PartBasicInfo
PartCatagoryPK
PartCatalogPK
PartCatalogVO
PartDescriptionPK
PartDiscountPK
PartDocumentPK
PartDwfPK
PartDwgPK
PartInQAVO
PartInspectionPK
PartInventoryVO
PartIssuedVO
PartManufacturerPK
PartManufacturerVO
PartMaterialListResult
PartOnhandAndCostResult
PartOnhandPK
PartOnhandVO
PartPK
PartReceivedVO
PartTraceableCategoryPK
PartTraceableSpecPK
PartTrackingPK
PartTrackingVO
PartUnitPK
PartUnitVO
PartVendorPK
PartVO
PartWithManufacturerInfoResult
PayableCheckRunItemPK
PaymentInvoicesResult
PermissionDescriptionPK
PermissionMethodPK
PfReceiverItemPK
PhysicalInventoryListResult
PhysicalInventoryPK
PoMessageItemPK
PoMessageItemVO
POSurveyReportItemPK
POSurveyReportItemVO
PosZipCodeTaxPK
ProfitLossStatementItemResult
ProformaInvoiceItemManufacturerPK
ProformaInvoiceItemPK
ProformaInvoiceVO
ProformaReceiverPackingBoxItemAgent
PrPackingBoxItemPK
PrPackingBoxItemVO
PrPackingBoxPK
PrPackingBoxVO
PurchaseOrderItemListResult
PurchaseOrderItemManufacturerPK
PurchaseOrderItemPK
PurchaseOrderItemVO
PurchaseOrderOnTimeItemResult
PurchaseWorkSheetItemPK
PurchaseWorkSheetItemVO
PurchaseWorkSheetPK
QtyAndMoney
QualityGroupPK
QuoteItemManufacturerPK
QuoteItemPK
Reason
ReceiverItemAgent
ReceiverItemDetailAgent
ReceiverItemManufacturerPK
ReceiverItemPK
ReceiverItemTrackingLogAgent
RefdocElement
RefdocVO
RequestForQuoteItemManufacturerPK
RequestForQuoteItemPK
RequestForQuoteItemVO
RequestForRMAItemPK
RequestForRMAItemVO
ReturnMaterialAuthorizationItemManufacturerPK
ReturnMaterialAuthorizationItemPK
ReturnToVendorItemManufacturerPK
ReturnToVendorItemPK
RfqMessageItemPK
RMAReceiverItemPK
RMAReceiverItemVO
RMAReceiverResult
RoleDescriptionPK
RolePermissionPK
RollUpBomStdCostWorkSheetItemPK
RtvShipperItemListResult
RtvShipperItemPK
RunningAccountOrderItemPK
RunningAccountOrderItemVO
SalesCodeVO
SalesInfoCenter.DueSoCount
SalesInfoCenter.DueSoSum
SalesInfoCenter.GrossMargin
SalesInfoCenter.InvoicedSum
SalesInfoCenter.OpenSoSum
SalesInfoCenter.SoCount
SalesInfoCenter.SoCountWithPartsOnhold
SalesInfoCenter.SoItemCount
SalesInfoCenter.SoTotalSum
SalesOrderItemListResult
SalesOrderItemManufacturerPK
SalesOrderItemPK
SalesOrderItemVO
SalesOrderOnDemandResult
SalesOrderOnTimeItemResult
SerialNumberItemPK
SerialNumberPK
ServerAction
ServerClientPropertyPK
SGBillItemPK
SGBOMItemResult
SGClientAccountPK
SgClientProgramUserVO
SGCompanyPK
SGCustomerCatalogPK
SGCustomerCatalogVO
SGCustRequestForQuoteItemPK
SGCustRequestForQuoteItemResult
SGDocPartPK
SGDwgPicturePK
SGPartDocFlagResult
SGPartListItemResult
SGPicturePK
SGQuoteCartListResult
ShipListItemPK
ShipListItemVO
ShipListOwnerAttributePK
ShipListOwnerVO
ShipperItemDetailAgent
ShipperItemManufacturerPK
ShipperItemPK
StringListConvertor
SwapOrderItemPK
SwapOrderItemVO
SwapOrderVO
SwapReceiverItemPK
SwapReceiverItemVO
SwapShipperItemPK
SwapShipperItemVO
ToolBasicInfo
ToolCalibrationVO
ToolInventoryVO
ToolListDetailCostWithToolInfoResult
ToolListItemWithToolInfoResult
ToolListVO
ToolListWithToolInfoResult
ToolOnhandVO
ToolVO
TraceableCategoriesVO
TraceableSpecsVO
TransferOrderItemPK
TransferOrderItemVO
TransferReceiverItemPK
TransferReceiverItemVO
TransferShipperItemPK
TransferShipperItemVO
UserRolePK
VendorContractPriceItemPK
VendorContractPriceVendorPK
VendorPartPK
VendorQtyPricePK
VendorTotalAmountInPO
VO
WarehouseTransferPK
WarehouseTransferVO
WCLoadAgent
WCLoadByDateResult
WCLoadDetailResult
WOIssuedByMonthResult
WOItemCostControlAgent
WoItemPickListItemResult
WorkCenterAgent
WorkCenterGroupItemPK
WorkCenterVendorPK
WorkCenterVO
Title:
WorkInstructionPK
WorkInstructionSequencePK
WorkOrderItemIssuePK
WorkOrderItemIssueVO
WorkOrderItemListResult
WorkOrderItemPartDetail
WorkOrderItemPartDetailItemResult
WorkOrderItemPK
WorkOrderItemSeqWCLoadResult
WorkOrderItemTimeDetailVO
WorkOrderOnDemandResult
WorkOrderOnTimeItemResult
WorkOrderTimeCardVO
WorkOrderWorkInstructionPK
WorkOrderWorkInstructionSequencePK
WorkOrderWorkInstructionSequenceVO
WorkOrderWorkSheetItemPK
WorkOrderWorkSheetItemVO
WorkOrderWorkSheetPK
ZipcodeTotalsResult

Classes in bb.common used by bb.common.box
AccountAgingTotalResult
AccountAuditAgent
AccountBalanceAgent
AccountBalanceListResult
AccountBalanceResult
AccountInfoCenterResult
AccountingBalanceSheetResult
AccountingConfigurationVO
AccountingInfoDocumentVO
AccountingSettingsVO
AccountingTotalMoneyResult
AccountingTransactionTypeVO
AccountMonthPK
AccountPayableCheckRunItemVO
AccountPayableCheckRunVO
AccountPayableCheckVO
AccountPayableInfoWithPrepayResult
AccountReceivableInfoWithPrepayResult
AccountReceivablePaymentVO
AccountsChartAdvanceCategoryVO
AccountsChartCategoryListResult
AccountsChartCategoryVO
AccountsChartMappingPK
AccountsChartMappingVO
AccountsChartResult
AccountsChartVO
AccountsCreditDebitListResult
AccountsPayableInfoVO
AccountsPayableItemPK
AccountsPayableItemVO
AccountsPayableVO
AccountsReceivableInfoVO
AccountsReceivableItemPK
AccountsReceivableItemResult
AccountsReceivableItemVO
AccountsReceivableVO
AddPayableWithoutReceiverAgent
AddPhysicalInventoryAgent
AddressAccountInfo
AddressQualityDocumentsVO
AddRTVAgent
AllBudgetResult
AllPartDocumentsPK
AllPartDocumentsVO
AllStatementsListResult
AmountsStatementResult
APAgingItemListResult
APAuditListResult
ApCheckRunItemAgent
ApCheckRunListResult
APItemListResult
AppColumnVO
APPrepayInfoResult
ApPrepaymentCheckRunItemAgent
ApPrepayVO
ApprovedGLResult
APTaxForZipcodeListResult
ARAuditListResult
ARBoilerplateVO
ArCommissionListResult
ArCommissionTotalResult
ArPaymentRunItemAgent
ARPaymentRunItemVO
ARPaymentRunListResult
ARPaymentRunVO
ARPrepayInfoResult
ArPrepaymentRunItemAgent
ARPrepaymentWireTransferAgent
ArPrepayVO
ArSalesCodeTotalListResult
ARTaxForZipcodeListResult
AssetAddOrDisposalsReport
AssetDepreciateDetailReport
AssetDepreciateVO
AssetReportSumResult
AssetTypeVO
AssetUsagePK
AssetUsageVO
AssetVO
AuditLogVO
AuditOnDemandResult
AuditPartInQAResult
BalanceSheetSideBySideResult
BankReconciliationReportVO
BB2BugNotice
BB2DoubleCost
BB2DoubleString
BB2File
BB2Notice
BB2Part
BB2PartInSipItemResult
BB2PartInSipOfSoItemResult
BB2PartInventoryResult
BB2PartMrpResult
BB2PartOnDemandListResult
BB2PartTotalInQADetailResult
BB2PartTotalInSipDetailResult
BB2PartTotalInSitDetailResult
BB2PartTotalInSTODetailResult
BB2PartTotalInWipDetailResult
BB2PartTotalOndemandDetailResult
BB2PartTotalOnhandDetailResult
BB2PartTotalOnloanDetailResult
BB2PartTotalOnorderDetailResult
BB2Picture
BB2RefdocPK
BB2Task
BB2WeightInfoResult
BillDetailCostResult
BillItemOnHandUsageResult
BillItemOnHandWithPartInfoResult
BillItemPK
BillItemSalesCostResult
BillItemUsageResult
BillItemVO
BillItemWithPartInfoResult
BillLogVO
BillOnHandWithPartInfoResult
BillPK
BillSalesResult
BillSalesXResult
BillVO
BillWhereUsedResult
BillWithPartInfoResult
BizBoxUserEmployeeResult
BizboxUserListResult
BizboxUserVO
BomApprovalVO
BOMCanAssyAgent
BOMCanAssyListResult
BomPickListResult
BOMTreeRollUPMap
BomWithOEMResult
BuyerCodeVO
CarrierPK
CarrierVO
CashFlowByMonthReportResult
CashFlowMonthTotalResult
CashierVO
CatalogVO
CertificateDescriptionVO
ChangeStdCostWorkSheetItemPK
ChangeStdCostWorkSheetItemVO
ChangeStdCostWorkSheetVO
CheckInvoiceItemListResult
CheckRunItemTotalResult
ClientListItem
ClosingStatementResult
CommonPrintTemplateVO
CompanyUnitAccountPK
CompanyUnitAccountVO
CompanyUnitVO
CompanyVO
ContractPriceCustomerPK
ContractPriceCustomerVO
ContractPriceItemPK
ContractPriceItemVO
ContractPriceVO
CorrectiveActionRequestVO
CPItemFromQuoteResult
CurrencyAgent
CurrencyExchangeVO
CurrencyVO
CurrentBalanceResult
CustomAssetRecordPK
CustomAssetRecordVO
CustomAssetVO
CustomCheckUpEmployeeVO
CustomDepartmentVO
CustomEmployeeTrainPK
CustomEmployeeTrainVO
CustomEmployeeVO
CustomEmployeeWorkExperienceVO
CustomerCLimitResult
CustomerFeedbackVO
CustomerPrepayStatementListResult
CustomerServiceIncidentItemListResult
CustomerServiceIncidentItemVO
CustomerServiceIncidentListResult
CustomerServiceIncidentVO
CustomerStatementListResult
CustomerStatementResult
CustomerStatementTotalResult
CustomerVendorAddressInfoVO
CustomerVendorAddressTotalInfo
CustomerVendorAddressVO
CustomerVendorContactVO
CustomerVendorTypeVO
CustomGoodsBreedVO
CustomGoodsRecordVO
CustomJobCategoryVO
CustomSearchVO
CustomTranslationVO
CV2CVAgent
CycleCountAgent
CycleCountListResult
CycleCountListTotalResult
CycleCountPK
CycleCountStatusVO
DataFilterVO
DebitsCreditsResult
DepartmentLocationForBackflushVO
DepositSummaryResult
DesignControlDocumentVO
DesignControlListResult
DesignControlVO
DisassembleWorkOrderApprovalVO
DisassembleWorkOrderDocumentVO
DisassembleWorkOrderIssueVO
DisassembleWorkOrderIssuingResult
DisassembleWorkOrderItemListResult
DisassembleWorkOrderItemPartDetailItemResult
DisassembleWorkOrderItemPartDetailResult
DisassembleWorkOrderItemPK
DisassembleWorkOrderItemReceiverPK
DisassembleWorkOrderItemReceiverVO
DisassembleWorkOrderItemVO
DisassembleWorkOrderListResult
DisassembleWorkOrderReceivingResult
DisassembleWorkOrderVO
DocumentInfoAgent
DocumentServerVO
DuePATotalByVendorResult
DwfUploadSettingsVO
DwgUploadSettingsVO
DWOIssueDetail
EcnCheckOrderResult
ECNReviewVO
ECRReviewVO
EjbMethodVO
EmployeeCardVO
EmployeeEducationPK
EmployeeEducationResult
EmployeeEducationVO
EmployeeHomeVO
EmployeeLaborAgent
EmployeePutGoodListResult
EmployeeRecordsVO
EmployeeTimeCardResult
EmployeeTrainingVO
EmployeeWorkExperiencePK
EmployeeWorkExperienceVO
EngGroupUserPK
EngGroupUserVO
EngGroupVO
EngineeringChangeDocumentVO
EngineeringChangeListResult
EngineeringChangeRequestDocumentVO
EngineeringChangeRequestListResult
EngineeringChangeRequestVO
EngineeringChangeVO
EngineeringInfoCenterResult
EngineeringSharingImportLogVO
EngineeringSharingItemPK
EngineeringSharingItemVO
EngineeringSharingVO
EquipmentListResult
EquipmentVO
ExchangeAuditResult
ExpenseAccountVO
ExpenseListResult
ExpenseVO
FeedBackItemPK
FeedbackItemVO
FeedbackQuestionVO
FinishProformaReceiverAgent
FiscalYearSettingsVO
GeneralLedgerApprovalVO
GeneralLedgerByDateListResult
GeneralLedgerCategoryVO
GeneralLedgerListResult
GeneralLedgerPrintResult
GeneralLedgerResult
GeneralLedgerSettingsVO
GeneralLedgerVO
GLApprovalListResult
GLAutoApproveVO
GLByDateTotalResult
GLCheckRegisterResult
GLDebitCreditListResult
GLInfoByPeriodResult
GlMonthBudgetVO
GlMonthVO
GroupUserVO
HelpServerVO
HighUsagePartResult
HistoricalInventoryTotalResult
HistoricalInventoryVO
IcrItemListResult
IcrListResult
ImportContractPriceData
ImportDataVO
IncomeByMonthChartResult
IncotermVO
InfoByFiscalChartResult
InfoByMonthChartResult
InSipAudittListResult
InspectionConformanceReportItemInfo
InspectionConformanceReportItemPK
InspectionConformanceReportItemVO
InspectionConformanceReportVO
InspectionItemPK
InspectionItemVO
InspectionReportInfoVO
InspectionReportInspectMethodVO
InspectionReportVO
InspectionTypeVO
InventoryAdjustmentDetailResult
InventoryAdjustmentListResult
InventoryAdjustmentVO
InventoryAmountByMonth
InventoryAuditReportResult
InventoryCycleResult
InventoryListResult
InventoryMonthReport
InventoryNotUsedInMonthsResult
InventoryNotUsedTotal
InventoryReportListResult
InventoryTotalCostResult
InventoryTotalResult
InvoiceAgingItemListResult
InvoiceItemListResult
InvokeException
IpAddressVO
IssueItemAgent
IssuingItemResult
IssuingResult
JobProcessSheetListResult
JobProcessSheetResult
LabelTemplateVO
LnShipperItemListResult
LnShipperListResult
LocationResult
LogInventoryListResult
LogInventoryVO
LogMiscDocumentVO
LogPartDocumentVO
LogPartDwfVO
LogPartDwgVO
LogTaskVO
LogTrackingVO
MaintenanceItemPK
MaintenanceItemVO
MakeAccountPayableAgent
MakeCheckAgent
MakeCreditMemoAgent
MakeDebitMemoAgent
MakeInvoiceAgent
MakePrepaymentCheckAgent
ManufacturerAddressInfoVO
ManufacturerAddressVO
MasterWorkOrderTreeItemResult
MessageAgent
MessageVO
MfrMpnListResult
MiscDocAgent
MiscDocumentSettingVO
Money
MoneyInDrawResult
MonthBalanceResult
MonthSoOrArByCustomerResult
MrpItemOrderDemandRecordsResult
MrpItemResult
MrpReportAgent
MyPrintListVO
NCQRejectResult
NcrApprovalPK
NcrApprovalVO
NcrNeedToScrapListResult
NCRPictureListResult
NCRPictureVO
NcrReportListResult
NcrScrapAgent
NonConformanceCodeVO
NonConformanceReportVO
NonproductivePickingApprovalVO
NonproductivePickingItemIssuedListResult
NonproductivePickingItemResult
NonproductivePickingItemVO
NonproductivePickingTypeVO
NonproductivePickingVO
NoticeUserEmployeeListResult
OIPrincipalVO
OnloanDocumentVO
OnLoanItemListResult
OnLoanItemPK
OnLoanItemVO
OnLoanListResult
OnloanReceiverItemListResult
OnloanReceiverItemPK
OnloanReceiverItemVO
OnloanReceiverListResult
OnloanReceiverVO
OnloanReviewVO
OnloanShipperItemPK
OnloanShipperItemVO
OnloanShipperVO
OnLoanVO
OnTimeAgent
OntimeDeliveryRateListResult
OntimeDeliveryRateResult
OpCodeShortcutVO
OperatingInstructionsInspectStandardVO
OperatingInstructionsManualVO
OperatingInstructionsTypeVO
OperatingInstructionsVO
OperatingOutputFileTypeVO
OperationLogVO
OrderApprovalVO
OrderApproval generated by MyEclipse Persistence Tools
OrderDocumentVO
OrderPK
OutputValueByMonthResult
PackingBoxItemListResult
PackingBoxItemPK
PackingBoxItemVO
PackingBoxPK
PackingBoxSalesOrderItemAgent
PackingBoxSalesOrderItemResult
PackingBoxVO
PartBasicInfo
PartBasicInfoWithNewEngGroup
PartBasicInfoWithNewListPrice
PartCatagoryPK
PartCatagoryVO
PartCatalogAuditResult
PartCatalogPK
PartCatalogVO
PartCertificateListResult
PartCertificateVO
PartClassInfoResult
PartClassVO
PartCostVarianceListResult
PartDiscountPK
PartDiscountVO
PartDocumentPK
PartDocumentVO
PartDueAddressListResult
PartDwfAgent
PartDwfPK
PartDwfWithPartInfoResult
PartDwgAgent
PartDwgPK
PartDwgWithPartInfoResult
PartInMrpListResult
PartInQAResult
PartInQAVO
PartInspectionPK
PartInspectionResult
PartInspectionVO
PartInventoryVO
PartInWipForIDListResult
PartIssuedListResult
PartIssuedVO
PartIssueTotalResult
PartManufacturerVO
PartMaterialBomListResult
PartMaterialListResult
PartMaterialReportAgent
PartMaterialVO
PartMaterialWhereUsedResult
PartOnHandAuditResult
PartOnhandPK
PartOnhandResult
PartOnhandVO
PartOnhandWithAverageCostResult
PartOnHandWithMfgInfoResult
PartOnHandWithPartBasicInfoResult
PartPictureVO
PartPK
PartReceivedListResult
PartReceivedVO
PartSecurityLevelVO
PartToAuditFlagResult
PartTraceableCategoryPK
PartTraceableCategoryVO
PartTraceableInfoResult
PartTraceableListResult
PartTraceableResult
PartTraceableSpecPK
PartTraceableSpecVO
PartTrackingPK
PartTrackingVO
PartTypeVO
PartUseTypeVO
PartVendorVO
PartVO
PartWhereUsedResult
PartWithExcessiveInventoryListResult
PartWithInventoryInfoListResult
PartWithManufacturerInfoResult
PartWithOnhandDetailInfoResult
PartWithOnhandsVO
PartWithOnLoanQtyListResult
PartWithoutLocateResult
PartWithQAQtyListResult
PartWithQtyListResult
PartWithSipQtyListResult
PartWithSITQtyListResult
PartWithSTOQtyListResult
PartWithWipQtyListResult
PasswordPolicyAgent
PayableMethodVO
PaymentAgent
PaymentHistoryVO
PaymentRunItemTotalResult
PermissionListResult
PermissionMethodPK
PermissionMethodVO
PermissionVO
PfReceiverItemVO
PfReceiverVO
PhysicalInventoryListResult
PhysicalInventoryListTotalResult
PhysicalInventoryPK
PhysicalInventoryStatusVO
PO2POAgent
PO2SOExchange
POAndWOStatusResult
POForWISeqAgent
PointOfSaleVO
POItemByRefDoc1ListResult
PoMessageListResult
PoMessageVO
PoReceiverByDateSummaryResult
POReceiverItemListResult
POStatisticsResult
PostCheckAgent
POSurveyReportAgent
POSurveyReportVO
PosZipCodeTaxPK
PosZipCodeTaxVO
PrepayAgent
PrepaymentWireTransferAgent
PrepayPaymentAgent
PreventiveActionRequestItemVO
PreventiveActionRequestVO
PrintLogoVO
PrintTemplateVO
ProfitAndLossAccountsResult
ProfitLossStatementResult
ProformaInvoiceItemListResult
ProformaInvoiceItemPK
ProformaInvoiceListResult
ProformaInvoiceVO
ProformaReceiverPackingBoxAgent
ProjectVO
PrPackingBoxItemVO
PrPackingBoxPK
PrPackingBoxVO
PrReceiverListResult
PullFromWorkOrderPartDetailAgent
PurchaseOnTimeResult
PurchaseOrderApprovalVO
PurchaseOrderBoilerplateVO
PurchaseOrderCheckListResult
PurchaseOrderContractResult
PurchaseOrderDocumentVO
PurchaseOrderItemListResult
PurchaseOrderItemPK
PurchaseOrderItemVO
PurchaseOrderListResult
PurchaseOrderOnTimeResult
PurchaseOrderOpenDueListResult
PurchaseOrderVO
PurchaseWorkSheetItemVO
PurchaseWorkSheetItemWithRelatedInfoResult
PurchaseWorkSheetPK
PurchaseWorkSheetVO
PurchasingInfoCenterResult
PuttoInQAAgent
QualityGroupPK
QualityGroupVO
QualityInfoCenterResult
Quote2QuoteAgent
QuoteBoilerplateVO
QuoteDocumentVO
QuoteItemListResult
QuoteItemPK
QuoteItemVO
QuoteListResult
QuoteVO
RebackInQAAgent
ReceiverAgent
ReceiverInfoVO
ReceiverItemAgent
ReceiverItemPK
ReceiverItemVO
ReceiverShipAgent
ReceiverVO
ReceivingResult
RecursiveBillPath
RefdocVO
RequestForQuoteCheckListResult
RequestForQuoteItemListResult
RequestForQuoteItemPK
RequestForQuoteItemVO
RequestForQuoteListResult
RequestForQuoteVO
RequestForRMAItemPK
RequestForRMAItemVO
RequestForRMAVO
ReturnMaterialAuthorizationDocumentVO
ReturnMaterialAuthorizationItemVO
ReturnMaterialAuthorizationVO
ReturnToVendorByDateListResult
ReturnToVendorCheckListResult
ReturnToVendorItemListResult
ReturnToVendorItemVO
ReturnToVendorListResult
ReturnToVendorVO
RfqMessageListResult
RfqMessageVO
RMAItemListResult
RMAListResult
RMAReceiverItemListResult
RMAReceiverItemPK
RMAReceiverItemVO
RMAReceiverListResult
RMAReceiverVO
RMAReviewVO
RoleListResult
RoleVO
RollUpBomStdCostWorkSheetItemVO
RollUpBomStdCostWorkSheetVO
RollUPPartStandardCostResult
RRMAItemListResult
RRMAListResult
RTVApprovalVO
RtvShipperInfoVO
RtvShipperItemListResult
RtvShipperItemPK
RtvShipperItemVO
RtvShipperListResult
RtvShipperVO
RunningAccountOrderItemPK
RunningAccountOrderItemResult
RunningAccountOrderItemVO
RunningAccountOrderVO
SalesBomResult
SalesCodeVO
SalesInfoCenterResult
SalesmanVO
SalesMarginListResult
SalesOnTimeResult
SalesOrder12MonthMarginResult
SalesOrderBoilerplateVO
SalesOrderCheckListResult
SalesOrderDocumentVO
SalesOrderItemCostResult
SalesOrderItemCustomerTotalResult
SalesOrderItemGroupByPartListResult
SalesOrderItemListResult
SalesOrderItemPK
SalesOrderItemVO
SalesOrderListResult
SalesOrderOnTimeResult
SalesOrderReviewVO
SalesOrderShipDateListResult
SalesOrderVO
SalesPartListResult
SalesTaxListResult
ScrapAssetAgent
SerialNumberPK
SerialNumberResult
SerialNumberVO
ServerClientPropertyVO
SgClientProgramUserVO
SGCustomerCatalogPK
SGCustomerCatalogVO
SGCustomerServiceRequestVO
SGCustRequestForQuoteListResult
SGCustRequestForQuoteResult
SGPartCatalogResult
SGSaleItemAgent
SGSaleItemVO
ShipListAgent
ShipListInfoVO
ShipListItemRelatedDocResult
ShipListItemVO
ShipListItemVOResult
ShipListOwnerAttributeVO
ShipListOwnerVO
ShipListVO
ShipperAgent
ShipperInfoVO
ShipperItemListResult
ShipperItemPK
ShipperItemVO
ShipperListResult
ShipperVO
ShippingItemResult
ShippingResult
SmtpServerVO
SO2POAgent
SO2SOAgent
SO2WOAgent
SoPickListResult
SOShipperItemListResult
StockTransactionAdjustmentResult
StockTransactionPartInfoResult
StockTransactionPOReceiverResult
StockTransactionSOShipperResult
StockTransactionWOReceiverResult
StockTransactionWOShipperResult
SubcompanyVO
SwapOrderApprovalVO
SwapOrderItemListResult
SwapOrderItemVO
SwapOrderListResult
SwapOrderVO
SwapReceiverItemListResult
SwapReceiverItemPK
SwapReceiverItemVO
SwapReceiverListResult
SwapReceiverVO
SwapShipperItemListResult
SwapShipperItemPK
SwapShipperItemVO
SwapShipperListResult
SwapShipperVO
TakeCycleCountAgent
TaskFileResult
TaskVO
TaxAccountVO
TempArApAgingVO
TempReceiverWithoutAPInfo
TermAgent
TermsConditionVO
TermVO
ToolBasicInfo
ToolCalibrateListResult
ToolCalibrationVO
ToolInventoryVO
ToolListDetailCostResult
ToolListItemVO
ToolListItemWithToolInfoResult
ToolListVO
ToolListWithToolInfoResult
ToolManufacturerVO
ToolOnhandVO
ToolOnhandWithAverageCostResult
ToolVendorVO
ToolVO
ToolWhereUsedResult
ToolWithManufacturerInfoResult
ToolWithOnhandsVO
TotalAmountInPOByRefDoc
TotalByDateResult
TraceableCategoriesVO
TraceableSpecsVO
TransferOrderApprovalVO
TransferOrderItemListResult
TransferOrderItemVO
TransferOrderListResult
TransferOrderVO
TransferReceiverItemListResult
TransferReceiverItemPK
TransferReceiverItemVO
TransferReceiverListResult
TransferReceiverVO
TransferShipperItemListResult
TransferShipperItemPK
TransferShipperItemVO
TransferShipperListResult
TransferShipperVO
TwelveMonthCashFlowReportResult
UnitVO
User2UserAgent
UserGroupVO
UserRolePermissionListResult
VendorCategoriesVO
VendorContractPriceItemPK
VendorContractPriceItemVO
VendorContractPriceVendorPK
VendorContractPriceVendorVO
VendorContractPriceVO
VendorCriticalLevelVO
VendorGroupUserVO
VendorPartPK
VendorPartVO
VendorPrepayStatementListResult
VendorQtyPricePK
VendorQtyPriceVO
VendorStatementListResult
VendorTotalAmountInPO
WarehouseVO
WareHousingInfoCenterResult
WC2WCAgent
WCLoadAgent
WCLoadDetailResult
WCLoadOnDateResult
WeightUnitVO
WireTransferAgent
WO2WOAgent
WOIssuedByMonthChartResult
WOItemPartDetailNotIssue
WoItemPickListResult
WoItemWorkInstructionListResult
WOReceiverDetail
WorkCalendarVO
WorkCenterAgent
WorkCenterLoadAgent
WorkCenterLoadListResult
WorkCenterOnDateAgent
WorkCenterRunTimeAgent
WorkCenterRunTimeListResult
WorkCenterRunTimeTotalResult
WorkCenterVO
Title:
WorkFlowVO
WorkInstructionApprovalVO
WorkInstructionDocumentVO
WorkInstructionListResult
WorkInstructionPictureVO
WorkInstructionPK
WorkInstructionRequestForChangeVO
WorkInstructionSeqAuditListResult
WorkInstructionSequenceListResult
WorkInstructionSequenceVO
WorkInstructionSummaryResult
WorkInstructionVO
WorkOrderApprovalVO
WorkOrderBoilerplateVO
WorkOrderCheckListResult
WorkOrderDocumentVO
WorkOrderInfoCenterResult
WorkOrderIssuedOrderListResult
WorkOrderIssueStatisticsResult
WorkOrderItemAgent
WorkOrderItemCanAssyAgent
WorkOrderItemCanAssyResult
WorkOrderItemInfoResult
WorkOrderItemInWipListResult
WorkOrderItemIssuedTotalResult
WorkOrderItemIssuePK
WorkOrderItemIssueVO
WorkOrderItemLaborCostListResult
WorkOrderItemListResult
WorkOrderItemPartDetail
WorkOrderItemPartDetailInWipVO
WorkOrderItemPartDetailItemResult
WorkOrderItemPartDetailResult
WorkOrderItemPK
WorkOrderItemReviewCostResult
WorkOrderItemSetupItemAgent
WorkOrderItemTimeDetailResult
WorkOrderItemTimeDetailVO
WorkOrderItemVO
WorkOrderItemWCLoadResult
WorkOrderListResult
WorkOrderOverIssueListResult
WorkOrderReceiverVO
WorkOrderTimeCardVO
WorkOrderVO
WorkOrderWorkInstructionListResult
WorkOrderWorkInstructionPK
WorkOrderWorkInstructionSequenceDateAgent
WorkOrderWorkInstructionSequencePK
WorkOrderWorkInstructionSequenceVO
WorkOrderWorkInstructionVO
WorkOrderWorkItemDateAgent
WorkOrderWorkSheetItemVO
WorkOrderWorkSheetItemWithRelatedInfoResult
WorkOrderWorkSheetPK
WorkOrderWorkSheetVO
ZipCodeTaxVO
ZipcodeTotalsResult
ZipCodeVO

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Package bb.common.box

PREV NEXT FRAMES NO FRAMES

Uses of Package
bb.common.box

No usage of bb.common.box

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


VendorCategoriesVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class VendorCategoriesVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.VendorCategoriesVO
All Implemented Interfaces:
java.io.Serializable
public class VendorCategoriesVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String ORDER_BY_VENDORCATEGORY
Constructor Summary
VendorCategoriesVO()
VendorCategoriesVO(java.lang.String vendorCategory)
VendorCategoriesVO(java.lang.String vendorCategory, java.lang.String description)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDescription()
java.lang.String | getVendorCategory()
int | hashCode()
void | setDescription(java.lang.String description)
void | setVendorCategory(java.lang.String vendorCategory)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_VENDORCATEGORY

public static final java.lang.String ORDER_BY_VENDORCATEGORY
See Also:
Constant Field Values
Constructor Detail

VendorCategoriesVO

public VendorCategoriesVO(java.lang.String vendorCategory,
                          java.lang.String description)

VendorCategoriesVO

public VendorCategoriesVO()

VendorCategoriesVO

public VendorCategoriesVO(java.lang.String vendorCategory)
Method Detail

getVendorCategory

public java.lang.String getVendorCategory()

setVendorCategory

public void setVendorCategory(java.lang.String vendorCategory)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VendorContractPriceItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class VendorContractPriceItemPK

java.lang.Object
    extended by  bb.common.VendorContractPriceItemPK
All Implemented Interfaces:
java.io.Serializable
public class VendorContractPriceItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
VendorContractPriceItemPK()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getContractNumber()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
int | hashCode()
void | setContractNumber(java.lang.String contractNumber)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

VendorContractPriceItemPK

public VendorContractPriceItemPK()
Method Detail

getContractNumber

public java.lang.String getContractNumber()

setContractNumber

public void setContractNumber(java.lang.String contractNumber)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

getPartFrom

public java.lang.String getPartFrom()

setPartType

public void setPartType(java.lang.String partType)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VendorContractPriceItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class VendorContractPriceItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.VendorContractPriceItemVO
All Implemented Interfaces:
java.io.Serializable
public class VendorContractPriceItemVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_CONTRACTNAME
static java.lang.String | ORDER_BY_DISCOUNT
static java.lang.String | ORDER_BY_LISTPRICE
static java.lang.String | ORDER_BY_PK
Constructor Summary
VendorContractPriceItemVO()
default constructor
VendorContractPriceItemVO(VendorContractPriceItemPK pk, java.lang.String contractName, java.math.BigDecimal listPrice, java.math.BigDecimal discount, java.lang.String comments)
minimal constructor
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getBb2AvgCost()
java.math.BigDecimal | getBb2ListPrice() nullable persistent field
java.math.BigDecimal | getBb2StdCost()
java.lang.String | getComments()
java.lang.String | getContractName()
java.lang.String | getDescription()
java.math.BigDecimal | getDiscount()
java.math.BigDecimal | getListPrice()
VendorContractPriceItemPK | getPk()
int | hashCode()
void | setBb2AvgCost(java.math.BigDecimal bb2AvgCost)
void | setBb2ListPrice(java.math.BigDecimal bb2ListPrice)
void | setBb2StdCost(java.math.BigDecimal bb2StdCost)
void | setComments(java.lang.String comments)
void | setContractName(java.lang.String contractName)
void | setDescription(java.lang.String description)
void | setDiscount(java.math.BigDecimal discount)
void | setListPrice(java.math.BigDecimal listPrice)
void | setPk(VendorContractPriceItemPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PK

public static final java.lang.String ORDER_BY_PK
See Also:
Constant Field Values

ORDER_BY_CONTRACTNAME

public static final java.lang.String ORDER_BY_CONTRACTNAME
See Also:
Constant Field Values

ORDER_BY_LISTPRICE

public static final java.lang.String ORDER_BY_LISTPRICE
See Also:
Constant Field Values

ORDER_BY_DISCOUNT

public static final java.lang.String ORDER_BY_DISCOUNT
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values
Constructor Detail

VendorContractPriceItemVO

public VendorContractPriceItemVO()
default constructor

VendorContractPriceItemVO

public VendorContractPriceItemVO(VendorContractPriceItemPK pk,
                                 java.lang.String contractName,
                                 java.math.BigDecimal listPrice,
                                 java.math.BigDecimal discount,
                                 java.lang.String comments)
minimal constructor

Method Detail

getBb2ListPrice

public java.math.BigDecimal getBb2ListPrice()
nullable persistent field

setBb2ListPrice

public void setBb2ListPrice(java.math.BigDecimal bb2ListPrice)

getBb2AvgCost

public java.math.BigDecimal getBb2AvgCost()

setBb2AvgCost

public void setBb2AvgCost(java.math.BigDecimal bb2AvgCost)

getBb2StdCost

public java.math.BigDecimal getBb2StdCost()

setBb2StdCost

public void setBb2StdCost(java.math.BigDecimal bb2StdCost)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getPk

public VendorContractPriceItemPK getPk()

setPk

public void setPk(VendorContractPriceItemPK pk)

getContractName

public java.lang.String getContractName()

setContractName

public void setContractName(java.lang.String contractName)

getListPrice

public java.math.BigDecimal getListPrice()

setListPrice

public void setListPrice(java.math.BigDecimal listPrice)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VendorContractPriceVendorPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class VendorContractPriceVendorPK

java.lang.Object
    extended by  bb.common.VendorContractPriceVendorPK
All Implemented Interfaces:
java.io.Serializable
public class VendorContractPriceVendorPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
VendorContractPriceVendorPK()
default constructor
VendorContractPriceVendorPK(java.lang.String contractNumber, java.lang.String id)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getContractNumber()
java.lang.String | getId()
int | hashCode()
void | setContractNumber(java.lang.String contractNumber)
void | setId(java.lang.String id)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

VendorContractPriceVendorPK

public VendorContractPriceVendorPK(java.lang.String contractNumber,
                                   java.lang.String id)
full constructor

VendorContractPriceVendorPK

public VendorContractPriceVendorPK()
default constructor

Method Detail

getContractNumber

public java.lang.String getContractNumber()

setContractNumber

public void setContractNumber(java.lang.String contractNumber)

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VendorContractPriceVendorVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class VendorContractPriceVendorVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.VendorContractPriceVendorVO
All Implemented Interfaces:
java.io.Serializable
public class VendorContractPriceVendorVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CONTRACTNAME
static java.lang.String | ORDER_BY_PK
Constructor Summary
VendorContractPriceVendorVO()
default constructor
VendorContractPriceVendorVO(VendorContractPriceVendorPK pk, java.lang.String contractName)
minimal constructor
VendorContractPriceVendorVO(VendorContractPriceVendorPK pk, java.lang.String contractName, CustomerVendorAddressInfoVO vendorInfo)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getContractName()
VendorContractPriceVendorPK | getPk()
CustomerVendorAddressInfoVO | getVendorInfo()
int | hashCode()
void | setContractName(java.lang.String contractName)
void | setPk(VendorContractPriceVendorPK pk)
void | setVendorInfo(CustomerVendorAddressInfoVO vendorInfo)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PK

public static final java.lang.String ORDER_BY_PK
See Also:
Constant Field Values

ORDER_BY_CONTRACTNAME

public static final java.lang.String ORDER_BY_CONTRACTNAME
See Also:
Constant Field Values
Constructor Detail

VendorContractPriceVendorVO

public VendorContractPriceVendorVO(VendorContractPriceVendorPK pk,
                                   java.lang.String contractName,
                                   CustomerVendorAddressInfoVO vendorInfo)
full constructor

VendorContractPriceVendorVO

public VendorContractPriceVendorVO()
default constructor

VendorContractPriceVendorVO

public VendorContractPriceVendorVO(VendorContractPriceVendorPK pk,
                                   java.lang.String contractName)
minimal constructor

Method Detail

getPk

public VendorContractPriceVendorPK getPk()

setPk

public void setPk(VendorContractPriceVendorPK pk)

getContractName

public java.lang.String getContractName()

setContractName

public void setContractName(java.lang.String contractName)

getVendorInfo

public CustomerVendorAddressInfoVO getVendorInfo()

setVendorInfo

public void setVendorInfo(CustomerVendorAddressInfoVO vendorInfo)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VendorContractPriceVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class VendorContractPriceVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.VendorContractPriceVO
All Implemented Interfaces:
java.io.Serializable
public class VendorContractPriceVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CONTRACTNUMBER
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_EXPIREDATE
static java.lang.String | ORDER_BY_LASTCHANGEDATE
static java.lang.String | ORDER_BY_LASTCHANGEUSER
static java.lang.String | ORDER_BY_STARTDATE
static java.lang.String | ORDER_BY_STATUS
Constructor Summary
VendorContractPriceVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getContractName()
java.lang.String | getContractNumber()
java.lang.String | getCurrency()
java.lang.String | getDescription()
java.util.Date | getExpireDate()
java.util.Date | getLastChangeDate()
int | getLastChangeTimes()
java.lang.String | getLastChangeUser()
java.lang.String | getOrigin()
java.util.Date | getStartDate()
java.lang.String | getStatus()
int | hashCode()
void | setContractName(java.lang.String contractName)
void | setContractNumber(java.lang.String contractNumber)
void | setCurrency(java.lang.String currency)
void | setDescription(java.lang.String description)
void | setExpireDate(java.util.Date expireDate)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTimes(int lastChangeTimes)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setOrigin(java.lang.String origin)
void | setStartDate(java.util.Date startDate)
void | setStatus(java.lang.String status)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_CONTRACTNUMBER

public static final java.lang.String ORDER_BY_CONTRACTNUMBER
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEUSER

public static final java.lang.String ORDER_BY_LASTCHANGEUSER
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEDATE

public static final java.lang.String ORDER_BY_LASTCHANGEDATE
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values

ORDER_BY_STARTDATE

public static final java.lang.String ORDER_BY_STARTDATE
See Also:
Constant Field Values

ORDER_BY_EXPIREDATE

public static final java.lang.String ORDER_BY_EXPIREDATE
See Also:
Constant Field Values
Constructor Detail

VendorContractPriceVO

public VendorContractPriceVO()
Method Detail

getContractNumber

public java.lang.String getContractNumber()

setContractNumber

public void setContractNumber(java.lang.String contractNumber)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeTimes

public int getLastChangeTimes()

setLastChangeTimes

public void setLastChangeTimes(int lastChangeTimes)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getContractName

public java.lang.String getContractName()

setContractName

public void setContractName(java.lang.String contractName)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getStartDate

public java.util.Date getStartDate()

setStartDate

public void setStartDate(java.util.Date startDate)

getExpireDate

public java.util.Date getExpireDate()

setExpireDate

public void setExpireDate(java.util.Date expireDate)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VendorCriticalLevelVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class VendorCriticalLevelVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.VendorCriticalLevelVO
All Implemented Interfaces:
java.io.Serializable
public class VendorCriticalLevelVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
VendorCriticalLevelVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCriticalLevel()
java.lang.String | getDescription()
int | hashCode()
void | setCriticalLevel(java.lang.String criticalLevel)
void | setDescription(java.lang.String description)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

VendorCriticalLevelVO

public VendorCriticalLevelVO()
Method Detail

getCriticalLevel

public java.lang.String getCriticalLevel()

setCriticalLevel

public void setCriticalLevel(java.lang.String criticalLevel)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VendorGroupUserVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class VendorGroupUserVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.VendorGroupUserVO
All Implemented Interfaces:
java.io.Serializable
public class VendorGroupUserVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_EMAIL
static java.lang.String | ORDER_BY_FAX
static java.lang.String | ORDER_BY_FULLNAME
static java.lang.String | ORDER_BY_ID
static java.lang.String | ORDER_BY_MOBILE
static java.lang.String | ORDER_BY_NAME
Constructor Summary
VendorGroupUserVO()
Method Summary
boolean | equals(java.lang.Object other)
CustomerVendorAddressInfoVO | getCustomerAddressInfo()
java.lang.String | getFax()
java.lang.String | getFullName()
java.lang.String | getLanguage()
java.lang.String | getMobile()
java.lang.String | getPassword()
java.lang.String | getPhone()
java.lang.String | getUserEmail()
java.lang.String | getUserName()
java.lang.String | getVendorId()
int | hashCode()
void | setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
void | setFax(java.lang.String fax)
void | setFullName(java.lang.String fullName)
void | setLanguage(java.lang.String language)
void | setMobile(java.lang.String mobile)
void | setPassword(java.lang.String password)
void | setPhone(java.lang.String phone)
void | setUserEmail(java.lang.String userEmail)
void | setUserName(java.lang.String userName)
void | setVendorId(java.lang.String vendorId)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ID

public static final java.lang.String ORDER_BY_ID
See Also:
Constant Field Values

ORDER_BY_NAME

public static final java.lang.String ORDER_BY_NAME
See Also:
Constant Field Values

ORDER_BY_FULLNAME

public static final java.lang.String ORDER_BY_FULLNAME
See Also:
Constant Field Values

ORDER_BY_MOBILE

public static final java.lang.String ORDER_BY_MOBILE
See Also:
Constant Field Values

ORDER_BY_FAX

public static final java.lang.String ORDER_BY_FAX
See Also:
Constant Field Values

ORDER_BY_EMAIL

public static final java.lang.String ORDER_BY_EMAIL
See Also:
Constant Field Values
Constructor Detail

VendorGroupUserVO

public VendorGroupUserVO()
Method Detail

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getPassword

public java.lang.String getPassword()

setPassword

public void setPassword(java.lang.String password)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getFax

public java.lang.String getFax()

setFax

public void setFax(java.lang.String fax)

getFullName

public java.lang.String getFullName()

setFullName

public void setFullName(java.lang.String fullName)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getMobile

public java.lang.String getMobile()

setMobile

public void setMobile(java.lang.String mobile)

getPhone

public java.lang.String getPhone()

setPhone

public void setPhone(java.lang.String phone)

getUserEmail

public java.lang.String getUserEmail()

setUserEmail

public void setUserEmail(java.lang.String userEmail)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getCustomerAddressInfo

public CustomerVendorAddressInfoVO getCustomerAddressInfo()

setCustomerAddressInfo

public void setCustomerAddressInfo(CustomerVendorAddressInfoVO customerAddressInfo)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VendorPartPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class VendorPartPK

java.lang.Object
    extended by  bb.common.VendorPartPK
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable
public class VendorPartPK
extends java.lang.Object
implements java.io.Serializable, java.lang.Comparable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
VendorPartPK()
default constructor
VendorPartPK(java.lang.String vendorPartNumber, java.lang.String vendorPartType, java.lang.String vendorPartFrom, java.lang.String vendorId)
full constructor
Method Summary
int | compareTo(java.lang.Object other)
boolean | equals(java.lang.Object other)
java.lang.String | getVendorId()
java.lang.String | getVendorPartFrom()
java.lang.String | getVendorPartNumber()
java.lang.String | getVendorPartType()
int | hashCode()
void | setVendorId(java.lang.String vendorId)
void | setVendorPartFrom(java.lang.String partFrom)
void | setVendorPartNumber(java.lang.String partNumber)
void | setVendorPartType(java.lang.String partType)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

VendorPartPK

public VendorPartPK(java.lang.String vendorPartNumber,
                    java.lang.String vendorPartType,
                    java.lang.String vendorPartFrom,
                    java.lang.String vendorId)
full constructor

VendorPartPK

public VendorPartPK()
default constructor

Method Detail

getVendorPartNumber

public java.lang.String getVendorPartNumber()

setVendorPartNumber

public void setVendorPartNumber(java.lang.String partNumber)

getVendorPartType

public java.lang.String getVendorPartType()

setVendorPartType

public void setVendorPartType(java.lang.String partType)

getVendorPartFrom

public java.lang.String getVendorPartFrom()

setVendorPartFrom

public void setVendorPartFrom(java.lang.String partFrom)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

compareTo

public int compareTo(java.lang.Object other)
Specified by:
compareTo in interface java.lang.Comparable
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VendorPartVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class VendorPartVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.VendorPartVO
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable
public class VendorPartVO
extends VO
implements java.io.Serializable, java.lang.Comparable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_PARTFROM
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_PK_VENDORID
static java.lang.String | ORDER_BY_PK_VENDORPARTFROM
static java.lang.String | ORDER_BY_PK_VENDORPARTNUMBER
static java.lang.String | ORDER_BY_PK_VENDORPARTTYPE
Constructor Summary
VendorPartVO()
default constructor
VendorPartVO(VendorPartPK pk)
minimal constructor
VendorPartVO(VendorPartPK pk, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom)
full constructor
Method Summary
int | compareTo(java.lang.Object other)
boolean | equals(java.lang.Object other)
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
VendorPartPK | getPk()
int | hashCode()
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(VendorPartPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PK_VENDORPARTNUMBER

public static final java.lang.String ORDER_BY_PK_VENDORPARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PK_VENDORPARTTYPE

public static final java.lang.String ORDER_BY_PK_VENDORPARTTYPE
See Also:
Constant Field Values

ORDER_BY_PK_VENDORPARTFROM

public static final java.lang.String ORDER_BY_PK_VENDORPARTFROM
See Also:
Constant Field Values

ORDER_BY_PK_VENDORID

public static final java.lang.String ORDER_BY_PK_VENDORID
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_PARTFROM

public static final java.lang.String ORDER_BY_PARTFROM
See Also:
Constant Field Values
Constructor Detail

VendorPartVO

public VendorPartVO(VendorPartPK pk,
                    java.lang.String partNumber,
                    java.lang.String partType,
                    java.lang.String partFrom)
full constructor

VendorPartVO

public VendorPartVO()
default constructor

VendorPartVO

public VendorPartVO(VendorPartPK pk)
minimal constructor

Method Detail

getPk

public VendorPartPK getPk()

setPk

public void setPk(VendorPartPK pk)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

compareTo

public int compareTo(java.lang.Object other)
Specified by:
compareTo in interface java.lang.Comparable
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VendorPrepayStatementListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class VendorPrepayStatementListResult

java.lang.Object
    extended by  bb.common.VendorPrepayStatementListResult
All Implemented Interfaces:
java.io.Serializable
public class VendorPrepayStatementListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
VendorPrepayStatementListResult()
Method Summary
java.math.BigDecimal | getAmountPaid()
java.math.BigDecimal | getBalanceDue()
java.util.Date | getDateRequired()
java.lang.String | getOurPoNumber()
ApPrepayItemPK | getPk()
java.math.BigDecimal | getTotalDue()
void | setAmountPaid(java.math.BigDecimal amountPaid)
void | setBalanceDue(java.math.BigDecimal balanceDue)
void | setDateRequired(java.util.Date dateRequired)
void | setOurPoNumber(java.lang.String ourPoNumber)
void | setPk(ApPrepayItemPK pk)
void | setTotalDue(java.math.BigDecimal totalDue)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

VendorPrepayStatementListResult

public VendorPrepayStatementListResult()
Method Detail

getAmountPaid

public java.math.BigDecimal getAmountPaid()

setAmountPaid

public void setAmountPaid(java.math.BigDecimal amountPaid)

getBalanceDue

public java.math.BigDecimal getBalanceDue()

setBalanceDue

public void setBalanceDue(java.math.BigDecimal balanceDue)

getDateRequired

public java.util.Date getDateRequired()

setDateRequired

public void setDateRequired(java.util.Date dateRequired)

getOurPoNumber

public java.lang.String getOurPoNumber()

setOurPoNumber

public void setOurPoNumber(java.lang.String ourPoNumber)

getPk

public ApPrepayItemPK getPk()

setPk

public void setPk(ApPrepayItemPK pk)

getTotalDue

public java.math.BigDecimal getTotalDue()

setTotalDue

public void setTotalDue(java.math.BigDecimal totalDue)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VendorPriceAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class VendorPriceAgent

java.lang.Object
    extended by  bb.common.VendorPriceAgent

public class VendorPriceAgent
extends java.lang.Object

Constructor Summary
VendorPriceAgent()
Method Summary
java.math.BigDecimal | getDiscount()
Money | getPrice()
void | setDiscount(java.math.BigDecimal discount)
void | setPrice(Money price)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

VendorPriceAgent

public VendorPriceAgent()
Method Detail

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getPrice

public Money getPrice()

setPrice

public void setPrice(Money price)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VendorQtyPricePK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class VendorQtyPricePK

java.lang.Object
    extended by  bb.common.VendorQtyPricePK
All Implemented Interfaces:
java.io.Serializable
public class VendorQtyPricePK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
VendorQtyPricePK()
default constructor
VendorQtyPricePK(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String vendorId, java.lang.Byte jj)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Byte | getJj()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getVendorId()
int | hashCode()
void | setJj(java.lang.Byte jj)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setVendorId(java.lang.String vendorId)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

VendorQtyPricePK

public VendorQtyPricePK(java.lang.String partNumber,
                        java.lang.String partType,
                        java.lang.String partFrom,
                        java.lang.String vendorId,
                        java.lang.Byte jj)
full constructor

VendorQtyPricePK

public VendorQtyPricePK()
default constructor

Method Detail

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getJj

public java.lang.Byte getJj()

setJj

public void setJj(java.lang.Byte jj)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VendorQtyPriceVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class VendorQtyPriceVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.VendorQtyPriceVO
All Implemented Interfaces:
java.io.Serializable
public class VendorQtyPriceVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
VendorQtyPriceVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCurrency()
java.math.BigDecimal | getDiscount()
java.math.BigDecimal | getFromQty()
VendorQtyPricePK | getPk()
java.math.BigDecimal | getPrice()
java.math.BigDecimal | getToQty()
int | hashCode()
void | setCurrency(java.lang.String currency)
void | setDiscount(java.math.BigDecimal discount)
void | setFromQty(java.math.BigDecimal fromQty)
void | setPk(VendorQtyPricePK pk)
void | setPrice(java.math.BigDecimal price)
void | setToQty(java.math.BigDecimal toQty)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

VendorQtyPriceVO

public VendorQtyPriceVO()
Method Detail

getPk

public VendorQtyPricePK getPk()

setPk

public void setPk(VendorQtyPricePK pk)

getFromQty

public java.math.BigDecimal getFromQty()

setFromQty

public void setFromQty(java.math.BigDecimal fromQty)

getToQty

public java.math.BigDecimal getToQty()

setToQty

public void setToQty(java.math.BigDecimal toQty)

getPrice

public java.math.BigDecimal getPrice()

setPrice

public void setPrice(java.math.BigDecimal price)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VendorStatementListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class VendorStatementListResult

java.lang.Object
    extended by  bb.common.VendorStatementListResult
All Implemented Interfaces:
java.io.Serializable
public class VendorStatementListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AMOUNTPAID
static java.lang.String | ORDER_BY_APNUMBER
static java.lang.String | ORDER_BY_BALANCEDUE
static java.lang.String | ORDER_BY_DATE
static java.lang.String | ORDER_BY_OURPONUMBER
static java.lang.String | ORDER_BY_TOTALDUE
static java.lang.String | ORDER_BY_VENDORINVOICE
Constructor Summary
VendorStatementListResult()
Method Summary
java.math.BigDecimal | getAmountPaid()
java.lang.String | getApNumber()
java.math.BigDecimal | getBalanceDue()
java.util.Date | getDate()
java.lang.String | getOurPoNumber()
java.math.BigDecimal | getTotalDue()
java.lang.String | getVendorInvoice()
void | setAmountPaid(java.math.BigDecimal amountPaid)
void | setApNumber(java.lang.String apNumber)
void | setBalanceDue(java.math.BigDecimal balanceDue)
void | setDate(java.util.Date date)
void | setOurPoNumber(java.lang.String ourPoNumber)
void | setTotalDue(java.math.BigDecimal totalDue)
void | setVendorInvoice(java.lang.String vendorInvoice)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_APNUMBER

public static final java.lang.String ORDER_BY_APNUMBER
See Also:
Constant Field Values

ORDER_BY_DATE

public static final java.lang.String ORDER_BY_DATE
See Also:
Constant Field Values

ORDER_BY_OURPONUMBER

public static final java.lang.String ORDER_BY_OURPONUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORINVOICE

public static final java.lang.String ORDER_BY_VENDORINVOICE
See Also:
Constant Field Values

ORDER_BY_TOTALDUE

public static final java.lang.String ORDER_BY_TOTALDUE
See Also:
Constant Field Values

ORDER_BY_AMOUNTPAID

public static final java.lang.String ORDER_BY_AMOUNTPAID
See Also:
Constant Field Values

ORDER_BY_BALANCEDUE

public static final java.lang.String ORDER_BY_BALANCEDUE
See Also:
Constant Field Values
Constructor Detail

VendorStatementListResult

public VendorStatementListResult()
Method Detail

getBalanceDue

public java.math.BigDecimal getBalanceDue()

getAmountPaid

public java.math.BigDecimal getAmountPaid()

getTotalDue

public java.math.BigDecimal getTotalDue()

getDate

public java.util.Date getDate()

getVendorInvoice

public java.lang.String getVendorInvoice()

getApNumber

public java.lang.String getApNumber()

setBalanceDue

public void setBalanceDue(java.math.BigDecimal balanceDue)

setAmountPaid

public void setAmountPaid(java.math.BigDecimal amountPaid)

setTotalDue

public void setTotalDue(java.math.BigDecimal totalDue)

setDate

public void setDate(java.util.Date date)

setVendorInvoice

public void setVendorInvoice(java.lang.String vendorInvoice)

setApNumber

public void setApNumber(java.lang.String apNumber)

setOurPoNumber

public void setOurPoNumber(java.lang.String ourPoNumber)

getOurPoNumber

public java.lang.String getOurPoNumber()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VendorTotalAmountInPO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class VendorTotalAmountInPO

java.lang.Object
    extended by  bb.common.VendorTotalAmountInPO
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
TotalAmountInPOByRefDoc
public class VendorTotalAmountInPO
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_GRANDTOTAL
static java.lang.String | ORDER_BY_NAME
static java.lang.String | ORDER_BY_SUBTOTAL
static java.lang.String | ORDER_BY_TOTALDISCOUNT
static java.lang.String | ORDER_BY_TOTALFREIGHT
static java.lang.String | ORDER_BY_TOTALOPEN
static java.lang.String | ORDER_BY_TOTALRECEIVED
static java.lang.String | ORDER_BY_TOTALTAX
static java.lang.String | ORDER_BY_VENDORID
Constructor Summary
VendorTotalAmountInPO()
Method Summary
java.math.BigDecimal | getGrandTotal()
java.lang.String | getName()
java.math.BigDecimal | getSubTotal()
java.math.BigDecimal | getTotalDiscount()
java.math.BigDecimal | getTotalFreight()
java.math.BigDecimal | getTotalOpen()
java.math.BigDecimal | getTotalReceived()
java.math.BigDecimal | getTotalTax()
java.lang.String | getVendorId()
void | setGrandTotal(java.math.BigDecimal grandTotal)
void | setName(java.lang.String name)
void | setSubTotal(java.math.BigDecimal subTotal)
void | setTotalDiscount(java.math.BigDecimal totalDiscount)
void | setTotalFreight(java.math.BigDecimal totalFreight)
void | setTotalOpen(java.math.BigDecimal totalOpen)
void | setTotalReceived(java.math.BigDecimal totalReceived)
void | setTotalTax(java.math.BigDecimal totalTax)
void | setVendorId(java.lang.String vendorId)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_NAME

public static final java.lang.String ORDER_BY_NAME
See Also:
Constant Field Values

ORDER_BY_SUBTOTAL

public static final java.lang.String ORDER_BY_SUBTOTAL
See Also:
Constant Field Values

ORDER_BY_TOTALDISCOUNT

public static final java.lang.String ORDER_BY_TOTALDISCOUNT
See Also:
Constant Field Values

ORDER_BY_TOTALTAX

public static final java.lang.String ORDER_BY_TOTALTAX
See Also:
Constant Field Values

ORDER_BY_TOTALFREIGHT

public static final java.lang.String ORDER_BY_TOTALFREIGHT
See Also:
Constant Field Values

ORDER_BY_GRANDTOTAL

public static final java.lang.String ORDER_BY_GRANDTOTAL
See Also:
Constant Field Values

ORDER_BY_TOTALRECEIVED

public static final java.lang.String ORDER_BY_TOTALRECEIVED
See Also:
Constant Field Values

ORDER_BY_TOTALOPEN

public static final java.lang.String ORDER_BY_TOTALOPEN
See Also:
Constant Field Values
Constructor Detail

VendorTotalAmountInPO

public VendorTotalAmountInPO()
Method Detail

getGrandTotal

public java.math.BigDecimal getGrandTotal()

setGrandTotal

public void setGrandTotal(java.math.BigDecimal grandTotal)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getSubTotal

public java.math.BigDecimal getSubTotal()

setSubTotal

public void setSubTotal(java.math.BigDecimal subTotal)

getTotalDiscount

public java.math.BigDecimal getTotalDiscount()

setTotalDiscount

public void setTotalDiscount(java.math.BigDecimal totalDiscount)

getTotalFreight

public java.math.BigDecimal getTotalFreight()

setTotalFreight

public void setTotalFreight(java.math.BigDecimal totalFreight)

getTotalTax

public java.math.BigDecimal getTotalTax()

setTotalTax

public void setTotalTax(java.math.BigDecimal totalTax)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getTotalOpen

public java.math.BigDecimal getTotalOpen()

setTotalOpen

public void setTotalOpen(java.math.BigDecimal totalOpen)

getTotalReceived

public java.math.BigDecimal getTotalReceived()

setTotalReceived

public void setTotalReceived(java.math.BigDecimal totalReceived)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VersionInformation

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class VersionInformation

java.lang.Object
    extended by  bb.common.VersionInformation

public class VersionInformation
extends java.lang.Object

Method Summary
static java.lang.String | getVersionInfo()
static java.lang.String | getVersionString() the current 2bizbox version string.
static java.lang.String | getWhatsNew() Get the "what's new" information of this version.
static java.lang.String | getWhatsNewAdderss() Get the "what's new" address information of this version.
static boolean | isMandatory() This indicate whether force the GUI to get the update before login system.
java.lang.String | toString()
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

getVersionString

public static java.lang.String getVersionString()
the current 2bizbox version string. GUI and Server need to be the same version normally.

getWhatsNew

public static java.lang.String getWhatsNew()
Get the "what's new" information of this version.

getWhatsNewAdderss

public static java.lang.String getWhatsNewAdderss()
Get the "what's new" address information of this version.

isMandatory

public static boolean isMandatory()
This indicate whether force the GUI to get the update before login system.

getVersionInfo

public static java.lang.String getVersionInfo()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


V-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M N O P Q R S T U V W X Y Z

V

validatePoMessage(String, String) - Method in interface bb.common.box.PurchasingBox
validateRfqMessage(String, String) - Method in interface bb.common.box.PurchasingBox
VALUE_NOT_MATCH_SUCH_PATTERN - Static variable in class bb.common.BIZReason
VARIANCE - Static variable in class bb.common.Constant.PAOffsetType
VARIANCE_CAN_NOT_BE_ZERO - Static variable in class bb.common.BIZReason
VCP - Static variable in class bb.common.Constant.Prefix
VENDOR - Static variable in class bb.common.BizTarget
VENDOR - Static variable in class bb.common.Constant.AddressType
VENDOR - Static variable in class bb.common.Constant.CVAddressType
VENDOR_CATALOG_ALREADY_EXIST - Static variable in class bb.common.BIZReason
VENDOR_CATALOG_ALREADY_USED - Static variable in class bb.common.BIZReason
VENDOR_CONTRACE_PRICE - Static variable in class bb.common.BizTarget
VENDOR_CONTRACE_PRICE_ITEM - Static variable in class bb.common.BizTarget
VENDOR_CONTRACE_PRICE_VENDOR - Static variable in class bb.common.BizTarget
VENDOR_CONTRACT_PRICE_HAS_EXIST - Static variable in class bb.common.BIZReason
VENDOR_CONTRACT_PRICE_ITEM_HAS_EXIST - Static variable in class bb.common.BIZReason
VENDOR_CONTRACT_PRICE_ITEM_NOT_EXIST - Static variable in class bb.common.BIZReason
VENDOR_CONTRACT_PRICE_NOT_EXIST - Static variable in class bb.common.BIZReason
VENDOR_CONTRACT_PRICE_VENDOR_HAS_EXIST - Static variable in class bb.common.BIZReason
VENDOR_CONTRACT_PRICE_VENDOR_NOT_EXIST - Static variable in class bb.common.BIZReason
VENDOR_CRITICAL_LEVEL - Static variable in class bb.common.BizTarget
VENDOR_DOC - Static variable in class bb.common.BizTarget
VENDOR_DOC - Static variable in class bb.common.Constant.MiscDocType
VENDOR_DOC_NOT_FIND - Static variable in class bb.common.BIZReason
VENDOR_GROUP_USER - Static variable in class bb.common.BizTarget
VENDOR_GROUP_USER_ALREADY_EXISTS - Static variable in class bb.common.BIZReason
VENDOR_HAS_BEEN_LOCKED - Static variable in class bb.common.BIZReason
VENDOR_ID_NOT_EXIST - Static variable in class bb.common.BIZReason
VENDOR_PART - Static variable in class bb.common.BizTarget
VendorApproved - Static variable in class bb.common.Constant.Status
VendorCategoriesVO - Class in bb.common
VendorCategoriesVO(String, String) - Constructor for class bb.common.VendorCategoriesVO
VendorCategoriesVO() - Constructor for class bb.common.VendorCategoriesVO
VendorCategoriesVO(String) - Constructor for class bb.common.VendorCategoriesVO
VendorContractPriceItemPK - Class in bb.common
VendorContractPriceItemPK() - Constructor for class bb.common.VendorContractPriceItemPK
VendorContractPriceItemVO - Class in bb.common
VendorContractPriceItemVO() - Constructor for class bb.common.VendorContractPriceItemVO
default constructor
VendorContractPriceItemVO(VendorContractPriceItemPK, String, BigDecimal, BigDecimal, String) - Constructor for class bb.common.VendorContractPriceItemVO
minimal constructor
VendorContractPriceVendorPK - Class in bb.common
VendorContractPriceVendorPK(String, String) - Constructor for class bb.common.VendorContractPriceVendorPK
full constructor
VendorContractPriceVendorPK() - Constructor for class bb.common.VendorContractPriceVendorPK
default constructor
VendorContractPriceVendorVO - Class in bb.common
VendorContractPriceVendorVO(VendorContractPriceVendorPK, String, CustomerVendorAddressInfoVO) - Constructor for class bb.common.VendorContractPriceVendorVO
full constructor
VendorContractPriceVendorVO() - Constructor for class bb.common.VendorContractPriceVendorVO
default constructor
VendorContractPriceVendorVO(VendorContractPriceVendorPK, String) - Constructor for class bb.common.VendorContractPriceVendorVO
minimal constructor
VendorContractPriceVO - Class in bb.common
VendorContractPriceVO() - Constructor for class bb.common.VendorContractPriceVO
VendorCriticalLevelVO - Class in bb.common
VendorCriticalLevelVO() - Constructor for class bb.common.VendorCriticalLevelVO
VendorGroupUserVO - Class in bb.common
VendorGroupUserVO() - Constructor for class bb.common.VendorGroupUserVO
VendorPartPK - Class in bb.common
VendorPartPK(String, String, String, String) - Constructor for class bb.common.VendorPartPK
full constructor
VendorPartPK() - Constructor for class bb.common.VendorPartPK
default constructor
VendorPartVO - Class in bb.common
VendorPartVO(VendorPartPK, String, String, String) - Constructor for class bb.common.VendorPartVO
full constructor
VendorPartVO() - Constructor for class bb.common.VendorPartVO
default constructor
VendorPartVO(VendorPartPK) - Constructor for class bb.common.VendorPartVO
minimal constructor
VendorPrepayStatementListResult - Class in bb.common
VendorPrepayStatementListResult() - Constructor for class bb.common.VendorPrepayStatementListResult
VendorPriceAgent - Class in bb.common
VendorPriceAgent() - Constructor for class bb.common.VendorPriceAgent
VendorQtyPricePK - Class in bb.common
VendorQtyPricePK(String, String, String, String, Byte) - Constructor for class bb.common.VendorQtyPricePK
full constructor
VendorQtyPricePK() - Constructor for class bb.common.VendorQtyPricePK
default constructor
VendorQtyPriceVO - Class in bb.common
VendorQtyPriceVO() - Constructor for class bb.common.VendorQtyPriceVO
VendorStatementListResult - Class in bb.common
VendorStatementListResult() - Constructor for class bb.common.VendorStatementListResult
VendorTotalAmountInPO - Class in bb.common
VendorTotalAmountInPO() - Constructor for class bb.common.VendorTotalAmountInPO
VERSION_NOT_SET - Static variable in class bb.common.BIZReason
VersionInformation - Class in bb.common
VO - Class in bb.common
VO() - Constructor for class bb.common.VO
VOID - Static variable in class bb.common.Constant.Status
voidAP(String) - Method in interface bb.common.box.AccountingBox
voidAPPayment(String, String) - Method in interface bb.common.box.AccountingBox
voidAPPaymentWithMultiplePrepay(String, String) - Method in interface bb.common.box.AccountingBox
voidAPPaymentWithPrepay(String, String, String) - Method in interface bb.common.box.AccountingBox
voidAPPrepay(String) - Method in interface bb.common.box.AccountingBox
voidAPPrepayPayment(String, String, String) - Method in interface bb.common.box.AccountingBox
voidAR(String) - Method in interface bb.common.box.AccountingBox
voidARPayment(String, String) - Method in interface bb.common.box.AccountingBox
voidARPaymentWithMultiplePrepay(String, String) - Method in interface bb.common.box.AccountingBox
voidARPaymentWithPrepay(String, String, String) - Method in interface bb.common.box.AccountingBox
voidARPrepay(String) - Method in interface bb.common.box.AccountingBox
voidARPrepayPayment(String, String) - Method in interface bb.common.box.AccountingBox
voidGlTransaction(String) - Method in interface bb.common.box.AccountingBox
VOPackage - Static variable in class bb.common.Constant.Package
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M N O P Q R S T U V W X Y Z


VO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class VO

java.lang.Object
    extended by  bb.common.VO
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
AccountCreditVO, AccountDebitVO, AccountingConfigurationVO, AccountingInfoDocumentVO, AccountingSettingsVO, AccountingTransactionTypeVO, AccountPayableCheckRunItemVO, AccountPayableCheckRunVO, AccountPayableCheckVO, AccountReceivablePaymentVO, AccountsChartAdvanceCategoryVO, AccountsChartCategoryVO, AccountsChartMappingVO, AccountsChartVO, AccountsPayableInfoVO, AccountsPayableItemManufacturerVO, AccountsPayableItemVO, AccountsPayableVO, AccountsReceivableInfoVO, AccountsReceivableItemManufacturerVO, AccountsReceivableItemVO, AccountsReceivableVO, AddressQualityDocumentsVO, AllPartDocumentsVO, AppColumnVO, ApPrepayItemVO, ApPrepayVO, ARBoilerplateVO, ARPaymentRunItemVO, ARPaymentRunVO, ArPrepayItemVO, ArPrepayVO, AssetAmortizationExpenseAccountVO, AssetDepreciateDetailReport, AssetDepreciateVO, AssetReportSumResult, AssetTypeVO, AssetUsageVO, AssetVO, AuditLogVO, AuditPartInQAResult, BankReconciliationReportVO, BillItemReplacementVO, BillItemVO, BillLogVO, BillVO, BizboxBugChangesInfoVO, BizboxBugChangesVO, BizboxBugInfoVO, BizboxBugVO, BizboxUserListResult, BizboxUserVO, BomApprovalVO, BuyerCodeVO, CarrierVO, CashierVO, CatalogVO, CertificateDescriptionVO, ChangeStdCostWorkSheetItemVO, ChangeStdCostWorkSheetVO, CommonPrintTemplateVO, CompanyUnitAccountVO, CompanyUnitVO, CompanyVO, ContractPriceCustomerVO, ContractPriceItemVO, ContractPriceVO, CorrectiveActionRequestVO, CurrencyAgent, CurrencyExchangeVO, CurrencyVO, CustomAssetRecordVO, CustomAssetVO, CustomCheckUpEmployeeVO, CustomDepartmentVO, CustomEmployeeTrainVO, CustomEmployeeVO, CustomEmployeeWorkExperienceVO, CustomerFeedbackVO, CustomerReturnToVendorItemVO, CustomerReturnToVendorVO, CustomerServiceIncidentItemVO, CustomerServiceIncidentVO, CustomerVendorAddressInfoVO, CustomerVendorAddressVO, CustomerVendorContactVO, CustomerVendorDescriptionVO, CustomerVendorTypeVO, CustomGoodsBreedVO, CustomGoodsRecordVO, CustomJobCategoryGoodsVO, CustomJobCategoryVO, CustomSearchVO, CustomTranslationVO, CycleCountStatusVO, CycleCountVO, DataFilterVO, DepartmentLocationForBackflushVO, DesignControlDocumentVO, DesignControlInfoVO, DesignControlVO, DisassembleWorkOrderApprovalVO, DisassembleWorkOrderDocumentVO, DisassembleWorkOrderIssueVO, DisassembleWorkOrderItemReceiverVO, DisassembleWorkOrderItemVO, DisassembleWorkOrderVO, DocumentLogVO, DocumentServerVO, DwfUploadSettingsVO, DwgUploadSettingsVO, ECNReviewVO, ECRReviewVO, EjbMethodVO, EmployeeCardVO, EmployeeEducationVO, EmployeeHomeVO, EmployeeJobDescriptionVO, EmployeeRecordsVO, EmployeeTrainingVO, EmployeeWorkExperienceVO, EngGroupUserVO, EngGroupVO, EngineeringChangeDocumentVO, EngineeringChangeRequestDocumentVO, EngineeringChangeRequestVO, EngineeringChangeVO, EngineeringSharingImportLogVO, EngineeringSharingItemVO, EngineeringSharingVO, EquipmentVO, ExpenseAccountVO, ExpenseItemVO, ExpenseVO, FeedbackAnswerVO, FeedbackItemVO, FeedbackQuestionVO, FiscalYearSettingsVO, GeneralLedgerApprovalVO, GeneralLedgerCategoryVO, GeneralLedgerSettingsVO, GeneralLedgerVO, GLAutoApproveVO, GlCashFlowBudgetVO, GlFiscalYearBudgetVO, GLItemVO, GlMonthBudgetVO, GlMonthVO, GroupUserVO, HelpServerVO, HistoricalInventoryVO, IcrItemListResult, ImportContractPriceData, ImportDataVO, IncotermVO, InspectionConformanceReportItemCheckVO, InspectionConformanceReportItemVO, InspectionConformanceReportVO, InspectionItemVO, InspectionReportInfoVO, InspectionReportInspectMethodItemVO, InspectionReportInspectMethodVO, InspectionReportInspectStandardItemVO, InspectionReportItemQtyVO, InspectionReportItemVO, InspectionReportVO, InspectionTypeItemVO, InspectionTypeVO, InventoryAdjustmentVO, InventoryPartInOutDetailListResult, IpAddressVO, LabelTemplateItemVO, LabelTemplateVO, LogInventoryVO, LogMethodVO, LogMiscDocumentVO, LogPartDocumentVO, LogPartDwfVO, LogPartDwgVO, LogTaskVO, LogTrackingVO, MaintenanceItemVO, ManufacturerAddressInfoVO, ManufacturerAddressVO, ManufacturerContactVO, ManufacturerDescriptionVO, MessageVO, MiscDocumentSettingVO, MultiLanguageAccountsChartVO, MyPrintListVO, NcrApprovalVO, NCRPictureVO, NonConformanceCodeDescriptionVO, NonConformanceCodeVO, NonConformanceQuantityVO, NonConformanceReportVO, NonproductivePickingApprovalVO, NonproductivePickingApproveVO, NonproductivePickingItemIssuedVO, NonproductivePickingItemVO, NonproductivePickingTypeVO, NonproductivePickingVO, OIPrincipalVO, OnloanDocumentVO, OnLoanItemVO, OnloanReceiverItemVO, OnloanReceiverVO, OnloanReviewVO, OnloanShipperItemVO, OnloanShipperVO, OnLoanVO, OpCodeShortcutVO, OperatingInstructionsInspectMethodItemVO, OperatingInstructionsInspectResultItemVO, OperatingInstructionsInspectStandardItemVO, OperatingInstructionsInspectStandardVO, OperatingInstructionsManualItemVO, OperatingInstructionsManualVO, OperatingInstructionsTypeVO, OperatingInstructionsVO, OperatingOutputFileItemVO, OperatingOutputFileTypeVO, OperationLogVO, OrderApprovalItemsVO, OrderApprovalVO, OrderBoilerplateVO, OrderDocumentVO, PackingBoxItemVO, PackingBoxVO, PartCatagoryVO, PartCatalogVO, PartCertificateVO, PartClassVO, PartDescriptionVO, PartDiscountVO, PartDocumentVO, PartDwfVO, PartDwgVO, PartInQAResult, PartInQAVO, PartInspectionVO, PartInventoryVO, PartIssuedVO, PartManufacturerVO, PartMaterialVO, PartMRPVO, PartNumberGenerateRuleVO, PartOnhandCostVO, PartOnhandVO, PartPictureVO, PartReceivedVO, PartSecurityLevelVO, PartTraceableCategoryVO, PartTraceableSpecVO, PartTrackingVO, PartTypeVO, PartUnitVO, PartUseTypeVO, PartVendorVO, PartVO, PartWithOnhandsVO, PayableMethodVO, PaymentHistoryVO, PaymentVO, PermissionDescriptionVO, PermissionMethodVO, PermissionVO, PfReceiverItemVO, PfReceiverVO, PhysicalInventoryStatusVO, PhysicalInventoryVO, PointOfSaleVO, PoMessageItemVO, PoMessageVO, PosRefdocVO, POSurveyReportItemVO, POSurveyReportVO, PosZipCodeTaxVO, PreventiveActionRequestItemVO, PreventiveActionRequestVO, PrintLogoVO, PrintTemplateVO, ProformaInvoiceItemManufacturerVO, ProformaInvoiceItemVO, ProformaInvoiceVO, ProjectVO, PrPackingBoxItemVO, PrPackingBoxVO, PurchaseOrderApprovalVO, PurchaseOrderBoilerplateVO, PurchaseOrderDocumentVO, PurchaseOrderItemManufacturerVO, PurchaseOrderItemVO, PurchaseOrderVO, PurchaseWorkSheetItemVO, PurchaseWorkSheetVO, QualityGroupVO, QuoteBoilerplateVO, QuoteDocumentVO, QuoteItemManufacturerVO, QuoteItemVO, QuoteVO, ReceiverInfoVO, ReceiverItemManufacturerVO, ReceiverItemVO, ReceiverVO, RefdocVO, RequestForQuoteItemManufacturerVO, RequestForQuoteItemVO, RequestForQuoteVO, RequestForRMAItemVO, RequestForRMAVO, ReturnMaterialAuthorizationDocumentVO, ReturnMaterialAuthorizationItemManufacturerVO, ReturnMaterialAuthorizationItemVO, ReturnMaterialAuthorizationVO, ReturnToVendorItemManufacturerVO, ReturnToVendorItemVO, ReturnToVendorVO, RfqMessageItemVO, RfqMessageVO, RMAReceiverItemVO, RMAReceiverVO, RMAReviewVO, RoleDescriptionVO, RolePermissionVO, RoleVO, RollUpBomStdCostWorkSheetItemVO, RollUpBomStdCostWorkSheetVO, RTVApprovalVO, RtvShipperInfoVO, RtvShipperItemVO, RtvShipperVO, RunningAccountOrderItemVO, RunningAccountOrderVO, SalesCodeVO, SalesmanVO, SalesOrderBoilerplateVO, SalesOrderDocumentVO, SalesOrderItemInfoVO, SalesOrderItemManufacturerVO, SalesOrderItemVO, SalesOrderReviewVO, SalesOrderVO, ScrapReportVO, SerialNumberItemVO, SerialNumberVO, ServerClientPropertyVO, SGBillItemVO, SGClientAccountVO, SgClientProgramUserVO, SGCompanyVO, SGCustomerCatalogVO, SGCustomerServiceRequestVO, SGCustRequestForQuoteItemVO, SGCustRequestForQuoteVO, SGDocPartVO, SGDwgPictureVO, SGLogLoginVO, SGPictureVO, SGQuoteAddressVO, SGQuoteCartVO, SGQuoteLoginVO, SGSaleItemVO, SGWeightUnitVO, ShipListInfoVO, ShipListItemVO, ShipListOwnerAttributeVO, ShipListOwnerVO, ShipListVO, ShipperInfoVO, ShipperItemManufacturerVO, ShipperItemVO, ShipperVO, SmtpServerVO, SubcompanyVO, SwapOrderApprovalVO, SwapOrderItemVO, SwapOrderVO, SwapReceiverItemVO, SwapReceiverVO, SwapShipperItemVO, SwapShipperVO, TaskVO, TaxAccountVO, TempArApAgingVO, TempReceiverWithoutAPInfo, TermsConditionVO, TermVO, ToolCalibrationVO, ToolDescriptionVO, ToolInventoryVO, ToolListInfoVO, ToolListItemVO, ToolListVO, ToolManufacturerVO, ToolOnhandVO, ToolVendorVO, ToolVO, ToolWithOnhandsVO, TraceableCategoriesVO, TraceableSpecsVO, TransferOrderApprovalVO, TransferOrderItemVO, TransferOrderVO, TransferReceiverItemVO, TransferReceiverVO, TransferShipperItemVO, TransferShipperVO, UnitVO, UserGroupVO, UserRolePermissionListResult, UserRoleVO, VendorCategoriesVO, VendorContractPriceItemVO, VendorContractPriceVendorVO, VendorContractPriceVO, VendorCriticalLevelVO, VendorGroupUserVO, VendorPartVO, VendorQtyPriceVO, WareHousePartPrefixKeeperVO, WarehouseTransferVO, WarehouseVO, WeightUnitVO, WorkCalendarVO, WorkCenterGroupItemVO, WorkCenterVendorVO, WorkCenterVO, WorkFlowVO, WorkInstructionApprovalVO, WorkInstructionDocumentVO, WorkInstructionPictureVO, WorkInstructionRequestForChangeVO, WorkInstructionSequenceVO, WorkInstructionVO, WorkOrderApprovalVO, WorkOrderBoilerplateVO, WorkOrderDocumentVO, WorkOrderItemIssueVO, WorkOrderItemPartDetailInWipVO, WorkOrderItemTimeDetailVO, WorkOrderItemVO, WorkOrderReceiverVO, WorkOrderTimeCardVO, WorkOrderVO, WorkOrderWorkInstructionSequenceVO, WorkOrderWorkInstructionVO, WorkOrderWorkSheetItemVO, WorkOrderWorkSheetVO, WorkPeriodVO, ZipCodeTaxVO, ZipCodeVO
public abstract class VO
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
VO()
Method Summary
java.util.Map | getClientProperties()
java.util.Map | getCustomProperties()
java.lang.Object | getValueOfCustomField(java.lang.String name)
void | setClientProperties(java.util.Map clientProperties)
void | setCustomProperties(java.util.Map customProperties)
void | setValueOfCustomField(java.lang.String name, java.lang.Object value)
java.lang.String | uniqueStr()
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

VO

public VO()
Method Detail

getCustomProperties

public java.util.Map getCustomProperties()

setCustomProperties

public void setCustomProperties(java.util.Map customProperties)

getValueOfCustomField

public java.lang.Object getValueOfCustomField(java.lang.String name)

setValueOfCustomField

public void setValueOfCustomField(java.lang.String name,
                                  java.lang.Object value)

uniqueStr

public java.lang.String uniqueStr()

getClientProperties

public java.util.Map getClientProperties()

setClientProperties

public void setClientProperties(java.util.Map clientProperties)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WarehouseBox

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common.box
Interface WarehouseBox

public interface WarehouseBox

Method Summary
void | activeLabelTemplate(int ii)
CycleCountPK | addCycleCount(AddPhysicalInventoryAgent agent)
DepartmentLocationForBackflushVO | addDepartmentLocationForBackflush(DepartmentLocationForBackflushVO vo)
LabelTemplateVO | addLabelTemplate(LabelTemplateVO vo)
LogInventoryVO | addLogInventory(LogInventoryVO vo)
PartOnhandPK | addNewLocation(BB2Part part, java.lang.String location, java.lang.String warehouse)
NonproductivePickingVO | addNonproductivePicking(NonproductivePickingVO vo)
NonproductivePickingApprovalVO | addNonproductivePickingApproval(java.lang.String employee)
NonproductivePickingTypeVO | addNonproductivePickingType(NonproductivePickingTypeVO vo)
OnLoanVO | addOnLoan(OnLoanVO vo)
OnloanReviewVO | addOnloanControl(java.lang.String employeeId)
PackingBoxPK | addPackingBox(java.lang.String pfNumber)
PartClassVO | addPartClass(PartClassVO vo)
void | addPartOnhand(PartOnhandVO vo)
void | addPartOnOder(PurchaseOrderItemVO item)
PhysicalInventoryPK | addPhysicalInventory(AddPhysicalInventoryAgent agent)
ProformaInvoiceVO | addProformaInvoice(ProformaInvoiceVO vo)
java.lang.String | addProformaInvoice(java.lang.String customerId)
ReceiverVO | addReceiver(ReceiverVO vo)
MyPrintListVO | addReceiverToMyPrintList(java.lang.String receiverNumber)
RefdocVO | addRefdocTwo(ReceiverItemPK rnItemPk, java.lang.String orderNumber, java.lang.String itemNumber)
RefdocVO | addRefdocTwo(ShipperItemPK shItemPk, java.lang.String orderNumber, java.lang.String itemNumber)
PackingBoxPK | addSalesOrderItemToPackingBox(PackingBoxSalesOrderItemAgent agent)
PackingBoxPK | addSalesOrderToPackingBox(java.util.ArrayList list)
ShipperVO | addShipper(ShipperVO vo)
MyPrintListVO | addShipperToMyPrintList(java.lang.String shipperNumber)
void | addToolOnOder(PurchaseOrderItemVO item)
TransferOrderVO | addTransferOrder(TransferOrderVO vo)
TransferOrderApprovalVO | addTransferOrderApproval(TransferOrderApprovalVO vo)
VendorPartVO | addVendorPart(VendorPartVO vo)
void | addWarehouse(WarehouseVO vo)
void | addWOReceiver(WorkOrderReceiverVO vo)
java.lang.Object[] | addWorkOrderAndIssueParts(WorkOrderVO vo, WorkOrderItemVO item, java.util.ArrayList<WorkOrderItemSetupItemAgent> setupList, java.util.Set<IssueItemAgent> issueItemAgents, ReceiverAgent agent)
java.lang.String | addWorkOrderAndReceiveParts(WorkOrderVO clientVO)
PartWithOnhandDetailInfoResult | adjustInventory(java.util.ArrayList partOnhandWithAverageCostList, BB2Part part, java.lang.String comments)
TransferOrderVO | approvalTransferOrder(TransferOrderVO toVO)
NonproductivePickingVO | approveNonproductivePicking(NonproductivePickingVO vo)
void | auditAllOnHand()
void | auditInSTO(BB2Part part)
void | auditInWip(BB2Part part)
java.util.Collection<PartPK> | auditLastInventoryDate(java.lang.String pnLike, java.lang.String paType, java.util.Date start)
void | auditOnDemand(BB2Part part)
void | auditOnOrder(BB2Part part)
void | auditUsage(BB2Part part)
void | batchMoveLocation(java.util.Map<PartOnhandPK,java.math.BigDecimal> data, java.lang.String warehousePrefix)
ProformaInvoiceListResult | checkCloseProformaInvoice(java.lang.String pfNum)
void | clearOnLoanItemReferenceDocOne(java.lang.String referenceDoc)
void | clearOnLoanItemReferenceDocTwo(java.lang.String referenceDoc)
java.util.Collection<java.lang.String> | closeProformaInvoices(java.util.ArrayList<java.lang.String> pfNums)
int | commitCycleCount(int worksheetNumber)
int | commitPhysicalInventory(int worksheetNumber, int pageNumber)
void | deleteDepartmentLocationForBackflush(java.util.ArrayList<DepartmentLocationForBackflushVO> list)
void | deleteLabelTemplate(int ii)
void | deleteLogInventory(LogInventoryVO vo)
void | deleteMyReceiverPrintList(java.util.List receiverNumberList)
void | deleteMyShipperPrintList(java.util.List ShipperNumberList)
void | deleteNonproductivePickingApproval(NonproductivePickingApprovalVO vo)
void | deleteNonproductivePickingType(NonproductivePickingTypeVO vo)
void | deleteOnloanControl(java.lang.String employeeId)
void | deletePackingBox(PackingBoxPK pk)
void | deletePartClass(java.lang.String id)
void | deletePartOnhand(PartOnhandVO vo)
void | deleteProformaInvoice(ProformaInvoiceVO vo)
void | deleteReceiver(ReceiverVO vo)
void | deleteReceiver(java.lang.String receiverNumber)
void | deleteRefdocTwo(BB2RefdocPK pk)
void | deleteShipper(ShipperVO vo)
void | deleteTransferOrderApproval(java.lang.String employeeId)
void | deleteVendorPart(VendorPartPK pk)
void | deleteWarehouse(java.lang.String warehousePrefix)
void | deleteWOReceiver(WorkOrderReceiverVO vo)
java.util.Collection<PartIssuedListResult> | findA2PartIssuedByDate(java.util.Date from, java.util.Date to, java.lang.String id, java.lang.String woNumber, java.lang.String woItemNumber, java.lang.String relatedDoc, java.lang.String picker, java.lang.String pnLike, java.lang.String paLike, java.lang.String orderNumber, java.lang.String project, boolean showCurrentOnhand, java.lang.String[] branchWarehouses, int firstIndex, int maxLength)
java.util.List<DepartmentLocationForBackflushVO> | findAllDepartmentLocationForBackflushs(int firstIndex, int maxLength)
java.util.Collection<OnLoanItemListResult> | findAllDueLoan(int firstIndex, int maxLength)
java.util.Collection<LabelTemplateVO> | findAllLabelTemplate(int firstIndex, int maxLength)
java.util.Collection<LogInventoryListResult> | findAllLogInventory(int firstIndex, int maxLength)
java.util.List<NonproductivePickingApprovalVO> | findAllNonproductivePickingApprovals(int firstIndex, int maxLength)
java.util.List<NonproductivePickingTypeVO> | findAllNonproductivePickingTypes(int firstIndex, int maxLength)
java.util.Collection<ProformaInvoiceListResult> | findAllNotClosedProformaInvoices(int firstIndex, int maxLength)
java.util.Collection<AuditOnDemandResult> | findAllOnHandAudit(java.lang.String partNumber, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<OnLoanItemListResult> | findAllOnLoanByAddressId(java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<OnloanReviewVO> | findAllOnloanControl(int firstIndex, int maxLength)
java.util.Collection<OnLoanListResult> | findAllOnLoans(int firstIndex, int maxLength)
java.util.Collection<OnloanShipperVO> | findAllOnloanShippers(int firstIndex, int maxLength)
java.util.Collection<OnLoanItemListResult> | findAllOpenLoan(int firstIndex, int maxLength)
java.util.Collection<OnLoanItemListResult> | findAllOpenOnLoanByAddressId(java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<PackingBoxVO> | findAllPackingBox(int firstIndex, int length)
java.util.Collection<PartInQAVO> | findAllPartInQAsWithoutNCR(BB2Part part, int firstIndex, int maxLength)
java.util.Collection<PartOnhandVO> | findAllPartOnhand(int firstIndex, int maxLength)
java.util.Collection<OnLoanItemListResult> | findAllPastDueLoanByAddressId(java.lang.String addressId, int firstIndex, int maxLength)
java.util.Collection<ProformaInvoiceListResult> | findAllProformaInvoices(int firstIndex, int maxLength)
java.util.Collection<ShipperInfoVO> | findAllShippers(int firstIndex, int maxLength)
java.util.Collection<TransferOrderApprovalVO> | findAllTransferOrderApproval(int firstIndex, int maxLength)
java.util.Collection<WarehouseVO> | findAllWarehouses(int firstIndex, int maxLength)
java.util.Collection<WorkOrderReceiverVO> | findAllWorkOrderReceivers(int firstIndex, int maxLength)
java.util.List | findBackfulshMaterialPartOnhandResults(java.lang.String partNumber, java.lang.String partType, boolean onlyShowBackflushLocate, int firstIndex, int maxLength)
java.util.Collection<BB2PartInSipItemResult> | findBB2PartInSipItemResults(BB2Part part)
java.util.Collection<BB2PartInventoryResult> | findBB2PartInventoryResults(java.util.HashSet bb2Parts)
java.util.Collection<OnLoanListResult> | findCheckList(int firstIndex, int maxLength)
java.util.Collection<CycleCountListResult> | findCommitCycleCountListResults(int worksheetNumber, boolean showUnCommittedOnly, int firstIndex, int maxLength)
java.util.Collection<PhysicalInventoryListResult> | findCommitPhysicalInventoryListResults(int worksheetNumber, boolean showUnCommittedOnly, int firstIndex, int maxLength)
java.util.Collection<CycleCountListResult> | findCycleCountListByPartNumber(int worksheetNumber, java.lang.String pnLike, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<CycleCountListResult> | findCycleCountListResults(int worksheetNumber, int firstIndex, int maxLength)
java.util.Collection<CycleCountListResult> | findCycleCountListResults(int worksheetNumber, int pageNubmer, int firstIndex, int maxLength)
java.util.Collection<CycleCountListResult> | findCycleCountListResultsWithAvgCost(int worksheetNumber, int pageNubmer, int firstIndex, int maxLength)
java.util.Collection<CycleCountStatusVO> | findCycleWorkSheetListResults(int firstIndex, int maxLength)
java.util.Collection<CycleCountStatusVO> | findCycleWorkSheetListResults(int workSheetNumber, int firstIndex, int maxLength)
java.util.Collection<DWOIssueDetail> | findDWOIssueItems(java.lang.String disassembleWorkOrder, java.lang.String disassembleWorkOrderItem, java.lang.String customerId, java.lang.String pn, java.lang.String pa, java.util.Date fromDate, java.util.Date toDate, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String[] branchWarehouses, boolean isIncludeNA, int firstIndex, int maxLength)
java.util.Collection<HighUsagePartResult> | findHighUsagePartResults(int firstIndex, int maxLength)
java.util.Collection<java.util.Date> | findHistoricalInventoryDates(int firstIndex, int maxLength)
java.util.Collection<HistoricalInventoryVO> | findHistoricalInventorys(java.lang.String pnLike, java.lang.String paLike, java.util.Date date, boolean isShowOnHand, int firstIndex, int maxlength)
java.util.Collection<InventoryTotalCostResult> | findHistoricalInventorysTotal(java.lang.String pnLike, java.lang.String paLike, java.util.Date fDate, java.util.Date tDate, boolean isShowOnHand)
java.util.Collection<InSipAudittListResult> | findInSipAuditReport(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, int firstIndex, int maxlength)
java.util.Collection<InventoryAdjustmentListResult> | findInventoryAdjustmentRecords(BB2Part part, int firstIndex, int maxLength)
java.util.Collection<InventoryAdjustmentListResult> | findInventoryAdjustmentRecords(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String countedBy, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<PartCostVarianceListResult> | findInventoryCostVarianceCount(java.lang.String partNumber, java.lang.String partType, java.lang.String makeBuy, java.math.BigDecimal variancePercent, int firstIndex, int maxLength)
java.util.Collection<InventoryCycleResult> | findInventoryCycleResults(java.lang.String select, int firstIndex, int maxLength)
java.util.Collection<InventoryListResult> | findInventoryListResultGTMaxQty(java.lang.String productCode, java.lang.String commodityCode, int firstIndex, int maxLength)
java.util.Collection<InventoryListResult> | findInventoryListResultOnlyWithMinQty(java.lang.String productCode, java.lang.String commodityCode, int firstIndex, int maxLength)
java.util.Collection<InventoryListResult> | findInventoryListResults(boolean showOnhandPartsOnly, boolean showInWipOnly, boolean showInSipOnly, boolean showInQaOnly, java.lang.String descriptionLike, java.lang.String pnFrom, java.lang.String pnTo, java.lang.String includePart, java.lang.String partType, java.lang.String partComeFrom, java.lang.String comCodeLike, java.lang.String languageCode, java.lang.String modelNumberLike, java.lang.String productCode, int firstIndex, int maxLength)
java.util.Collection<InventoryListResult> | findInventoryListResultsByCommodityCode(java.lang.String pnLike, java.lang.String partType, java.lang.String comCodeLike, java.lang.String buyercode, int firstIndex, int maxLength)
java.util.Collection<InventoryListResult> | findInventoryListResultWithMinAndMaxQty(int firstIndex, int maxLength)
java.util.Collection<InventoryListResult> | findInventoryListWithMinAndMaxQty(java.lang.String productCode, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<InventoryMonthReport> | findInventoryMonthReport(java.util.Date bDate, java.util.Date eDate, java.lang.String partNumberLike, java.lang.String partTypeLike, int firstIndex, int maxLength)
java.util.Collection<InventoryMonthReport> | findInventoryMonthReportTotal(java.util.Date bDate, java.util.Date eDate, java.lang.String partNumberLike, java.lang.String partTypeLike)
java.util.Collection<InventoryNotUsedInMonthsResult> | findInventoryNotUsedInMonthsResults(java.util.Date fromDate, boolean showZeroOnhandItems, int firstIndex, int maxlenth)
java.util.Collection<InventoryNotUsedInMonthsResult> | findInventoryNotUsedInMonthsResults(int months, boolean showZeroOnhandItems, int firstIndex, int maxlenth)
java.util.List | findInventoryNotUsedInMonthsResultsforApp(java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<InventoryReportListResult> | findInventoryReportList(java.lang.String pnLike, java.lang.String paLike, java.util.Date fDate, java.util.Date tDate, int firstIndex, int maxlength)
java.util.Collection<InventoryListResult> | findInventoryTotalByProductCode(java.lang.String productCode, int firstIndex, int length)
java.util.ArrayList<WorkOrderItemIssuedTotalResult> | findIssuedPartTotal(WorkOrderItemPK pk, PartPK partPk, java.lang.String relatedDoc, java.lang.String modelNumber, java.lang.String common, java.lang.String dateType, java.util.Date dateFrom, java.util.Date dateTo, int firstIndex, int maxLength)
java.util.Collection<LnShipperItemListResult> | findLnShipperItemListResults(java.util.Date fromDate, java.util.Date toDate, java.lang.String lnShipperNumber, java.lang.String loanNumber, java.lang.String partNumber, java.lang.String partType, java.lang.String customerId, java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<LnShipperItemListResult> | findLnShipperItemListResultsByCustomerId(java.lang.String customerId, int firstIndex, int maxLength)
java.util.Collection<LnShipperItemListResult> | findLnShipperItemListResultsByLnNumber(java.lang.String loanNumber, int firstIndex, int maxLength)
java.util.Collection<LnShipperItemListResult> | findLnShipperItemListResultsByPartNumber(java.lang.String partNumber, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<OnLoanItemListResult> | findLoanItemByPartPk(PartPK pk, java.lang.String partFromType, int firstIndex, int maxLength)
java.util.Collection<InventoryMonthReport> | findLocationInventoryReport(java.util.Date startDate, java.util.Date endDate, java.lang.String partNumber, java.lang.String partType, java.lang.String location, int firstIndex, int maxLength)
java.util.Collection<LocationResult> | findLocationResultWithoutWarehouse()
java.util.Collection<LogInventoryListResult> | findLogInventoryByPart(BB2Part part, int firstIndex, int maxLength)
java.util.Collection<LogInventoryListResult> | findLogInventoryByPartLike(java.lang.String partNumberLike, java.lang.String partType, java.lang.String partFrom, java.lang.String operator, java.lang.String location, java.util.Date fromDate, java.util.Date toDate, boolean listOtherLocationsForSamePart, int firstIndex, int maxLength)
java.util.Collection<LogInventoryListResult> | findLogInventorySimpleByPartLike(java.lang.String partNumberLike, java.lang.String partType, java.lang.String partFrom, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<java.util.Map> | findNeedCycleCountParts(java.util.ArrayList<AuditOnDemandResult> audits, int firstIndex, int maxLength)
java.util.Collection<PartOnhandResult> | findNegativePartOnhandResults(java.lang.String pn1, java.lang.String pn2, java.lang.String pnType, boolean listOtherLocationsForSamePart, int firstIndex, int maxLength)
java.util.List | findNonproductivePickingIssuedItems(java.util.Date from, java.util.Date to, java.lang.String id, java.lang.String npNumber, java.lang.String npItemNumber, java.lang.String pnLike, java.lang.String paLike, java.lang.String pfLike, java.lang.String orderNumber, java.lang.String[] branchWarehouses, java.lang.String project, int firstIndex, int maxLength)
java.util.Collection<NonproductivePickingItemIssuedListResult> | findNonproductivePickingItemIssuedList(java.lang.String monthYear, int firstIndex, int maxLength)
java.util.Collection<NonproductivePickingItemResult> | findNonproductivePickingItemResults(java.lang.String pickingNumber, java.lang.String status, java.lang.String id, java.lang.String orderType, java.util.Date fromDate, java.util.Date toDate, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String project, int firstIndex, int maxLength)
java.util.Collection<NonproductivePickingVO> | findNonproductivePickings(java.lang.String pickingNumber, java.lang.String status, java.lang.String id, java.lang.String orderType, java.util.Date fromDate, java.util.Date toDate, java.lang.String project, int firstIndex, int maxLength)
NonproductivePickingTypeVO | findNonproductivePickingTypeByKey(int key)
NonproductivePickingTypeVO | findNonproductivePickingTypeByName(java.lang.String name)
java.util.List | findOnhandQualityStatue(java.util.Date date)
java.util.Collection<OnloanReviewVO> | findOnloanControlByUserTrueNameLike(java.lang.String userTrueNameLike, int firstIndex, int maxLength)
java.util.Collection<OnLoanItemListResult> | findOnLoanItemsByDate(PartPK partPk, java.lang.String customerId, java.lang.String salesMan, java.lang.String status, boolean isDeliveryDate, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<OnloanReceiverItemListResult> | findOnloanReceiverItemListResultsByCustID(java.lang.String custID, int firstIndex, int maxLength)
java.util.Collection<OnloanReceiverItemListResult> | findOnloanReceiverItemListResultsByLnNumber(java.lang.String loanNumber, int firstIndex, int maxLength)
java.util.Collection<OnloanReceiverItemListResult> | findOnloanReceiverItemListResultsByLnShipperNumber(java.lang.String lnShipperNumber, int firstIndex, int maxLength)
java.util.Collection<OnloanReceiverItemListResult> | findOnloanReceiverItemListResultsByOnloanReceiverNumber(java.lang.String receiverNumber, int firstIndex, int maxLength)
java.util.Collection<OnloanReceiverItemListResult> | findOnloanReceiverItemListResultsByPartNumber(java.lang.String partNumber, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<OnloanReceiverListResult> | findOnloanReceiverListResultsByCustID(java.lang.String custID, int firstIndex, int maxLength)
java.util.Collection<OnloanReceiverListResult> | findOnloanReceiverListResultsByLnShipperNumber(java.lang.String lnShipperNumber, int firstIndex, int maxLength)
java.util.Collection<OnloanReceiverListResult> | findOnloanReceiverListResultsByOnloanReceiverNumber(java.lang.String receiverNumber, int firstIndex, int maxLength)
java.util.Collection<OnLoanListResult> | findOnLoansByLoanNumber(java.lang.String loanNumberExp, int firstIndex, int maxLength)
java.util.Collection<OnLoanListResult> | findOnLoansByPoNumber(java.lang.String poNumberExp, int firstIndex, int maxLength)
java.util.Collection<LnShipperListResult> | findOnloanShipperListResultsByCustomerId(java.lang.String customerId, int firstIndex, int maxLength)
java.util.Collection<LnShipperListResult> | findOnloanShipperListResultsByLoanNumber(java.lang.String loanNumber, int firstIndex, int maxLength)
java.util.Collection<LnShipperListResult> | findOnloanShipperListResultsByOnloanShipperNumber(java.lang.String lnShipperNumber, int firstIndex, int maxLength)
java.util.Collection<LnShipperListResult> | findOnloanShipperListResultsBySalesman(java.lang.String salesman, int firstIndex, int maxLength)
java.util.Collection<OnloanShipperVO> | findOnloanShippersByLn(java.lang.String loanNumber, int firstIndex, int maxLength)
java.util.Collection<OnLoanListResult> | findOpenOnLoansForShipper(java.lang.String loanNumberExp, int firstIndex, int maxLength)
java.util.Collection<LnShipperListResult> | findOpenOnloanShipperForReceiver(java.lang.String startWith, int firstIndex, int maxLength)
java.util.Collection<POReceiverItemListResult> | findOpenPOReceiverItemsByPartPK(PartPK partPk, int firstIndex, int maxLength)
java.util.Collection<ProformaInvoiceListResult> | findOpenProformaInvoiceListResults(int firstIndex, int maxLength)
java.util.Collection<ReceiverInfoVO> | findOpenReceiversByRn(java.lang.String rn, int firstIndex, int maxLength)
java.util.Collection<SwapOrderListResult> | findOpenSwapOrderForShipper(java.lang.String swoNumber, int firstIndex, int maxLength)
java.util.Collection<TransferOrderListResult> | findOpenTransferOrderForShipper(java.lang.String toNumber, int firstIndex, int maxLength)
java.util.Collection<PackingBoxVO> | findPackingBoxesByPfNumber(java.lang.String pfNumberRegex, int firstIndex, int maxLength)
java.util.Collection<PackingBoxItemVO> | findPackingBoxItem(java.lang.String pfNumber, PartPK partPk, java.lang.String partFrom)
java.util.Collection<PackingBoxItemListResult> | findPackingBoxItemListResultsByPfNumbe(java.lang.String pfNumberExp, int firstIndex, int maxLength)
java.util.Collection<PackingBoxItemListResult> | findPackingBoxItemListResultsByPfNumbeAndPBNumber(java.lang.String pfNumberExp, int packingBoxNumber, int firstIndex, int maxLength)
java.util.Collection<PackingBoxSalesOrderItemResult> | findPackingBoxSalesOrderItemResults(java.lang.String soNumber)
java.util.Collection<PartClassVO> | findPartClasses(int firstIndex, int maxLength)
java.util.Collection<PartClassInfoResult> | findPartClassInfoResult(java.lang.String pnLike, java.lang.String partType, java.lang.String partClass, int firstIndex, int maxLength)
java.util.Collection<PartInWipForIDListResult> | findPartInWipForIDListResultsByVendorID(java.lang.String woLike, java.lang.String pnLike, java.lang.String partType, java.lang.String vendorIdLike, int firstIndex, int maxLength)
java.util.Collection<PartIssuedListResult> | findPartIssuedByDate(java.util.Date from, java.util.Date to, java.lang.String id, java.lang.String woNumber, java.lang.String woItemNumber, java.lang.String relatedDoc, java.lang.String picker, java.lang.String pnLike, java.lang.String paLike, java.lang.String orderNumber, java.lang.String project, boolean showCurrentOnhand, java.lang.String[] branchWarehouses, int firstIndex, int maxLength)
java.util.Collection<java.lang.String> | findPartLocation(java.lang.String location, int firstIndex, int maxLength)
java.util.Collection<PartWithQtyListResult> | findPartOnDemandQtyListResults(int firstIndex, int maxLength)
java.util.Collection<PartOnhandVO> | findPartOnHandByLocation(java.lang.String location)
PartOnhandVO | findPartOnhandByPk(PartOnhandPK pk)
java.util.Collection<PartOnhandVO> | findPartOnhandByPk(PartPK pk)
java.util.Collection<PartOnhandVO> | findPartOnhandIsZeroByPart(PartPK pk, int firstIndex, int maxLength)
java.util.Collection<PartOnhandResult> | findPartOnhandResultsByLocate(java.lang.String locate, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, boolean listZeroOnhand, boolean listOtherLocationsForSamePart, int firstIndex, int maxLength)
PartOnhandResult | findPartOnhandTotalResultsByLocate(java.lang.String locate, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, boolean listZeroOnhand)
java.util.Collection<PartWithOnLoanQtyListResult> | findPartOnLoanQtyListResults(int firstIndex, int maxLength)
java.util.Collection<PartWithQtyListResult> | findPartOnOrderQtyListResults(int firstIndex, int maxLength)
java.util.Collection<PartReceivedListResult> | findPartReceivedByDate(java.util.Date from, java.util.Date to, java.lang.String id, java.lang.String woNumber, java.lang.String woItemNumber, java.lang.String relatedDoc, java.lang.String pnLike, java.lang.String paLike, java.lang.String receiverNumber, java.lang.String project, boolean showCurrentOnhand, java.lang.String[] branchWarehouses, int firstIndex, int maxLength)
java.util.Collection<PartWithExcessiveInventoryListResult> | findPartWithExcessiveInventoryListResults(boolean addMaxQty, int firstIndex, int length)
java.util.Collection<PartWithExcessiveInventoryListResult> | findPartWithExcessiveInventoryListResults(java.lang.String pnExp, java.lang.String paExp, int firstIndex, int length)
java.util.Collection<PartClassInfoResult> | findPartWithoutClassInfoResult(java.lang.String pnLike, java.lang.String description, java.lang.String partType, java.lang.String commodity, int firstIndex, int maxLength)
java.util.Collection<PartWithoutLocateResult> | findPartWithoutLocationList(PartPK pk, int firstIndex, int maxLength)
java.util.Collection<PartWithQAQtyListResult> | findPartWithQAQtyListResults(boolean includesDetails, int firstIndex, int length)
java.util.Collection<PartWithSipQtyListResult> | findPartWithSipQtyListResults(boolean includesDetails, int firstIndex, int length)
java.util.Collection<PartWithSITQtyListResult> | findPartWithSITQtyListResults(java.lang.String pnExp, java.lang.String paExp, boolean isTool, boolean includesRefDetails, int firstIndex, int length)
java.util.Collection<PartWithSTOQtyListResult> | findPartWithSTOQtyListResults(java.lang.String pnExp, java.lang.String paExp, boolean isIncludeRefDetails, boolean isTool, int firstIndex, int maxLength)
java.util.Collection<PartWithWipQtyListResult> | findPartWithWipQtyListResults(boolean includesDetails, int firstIndex, int length)
java.util.Collection<PartWithWipQtyListResult> | findPartWithWipQtyListResults(java.lang.String pnExp, java.lang.String paExp, int firstIndex, int length)
java.util.Collection<PhysicalInventoryListResult> | findPhysicalInventoryListByPartNumber(int worksheetNumber, java.lang.String pnLike, java.lang.String partType, java.lang.String location, int firstIndex, int maxLength)
java.util.Collection<PhysicalInventoryListResult> | findPhysicalInventoryListResults(int worksheetNumber, int firstIndex, int maxLength)
java.util.Collection<PhysicalInventoryListResult> | findPhysicalInventoryListResults(int worksheetNumber, int pageNubmer, int firstIndex, int maxLength)
java.util.List | findPhysicalInventoryListResults(int worksheetNumber, int pageNubmer, java.lang.String pnLike, java.lang.String partType, java.lang.String location, java.lang.String countedBy)
java.util.Collection<PhysicalInventoryListResult> | findPhysicalInventoryListResultsByLocation(int worksheetNumber, java.lang.String location)
java.util.List | findPhysicalInventoryListResultsForSpecificWarehouse(int worksheetNumber, int pageNubmer, java.lang.String pnLike, java.lang.String partType, java.lang.String location, java.lang.String countedBy, java.lang.String showUnCommittedOnly, int firstIndex, int maxLength)
java.util.Collection<PhysicalInventoryListResult> | findPhysicalInventoryListResultsWithAvgCost(int worksheetNumber, int pageNubmer, int firstIndex, int maxLength)
java.util.Collection<PartPK> | findPhysicalInventoryPart(java.lang.String pnLike, java.lang.String paLike, java.util.Date fDate, java.util.Date tDate)
java.util.Collection<PhysicalInventoryStatusVO> | findPhysicalWorkSheetListResults(int firstIndex, int maxLength)
java.util.Collection<POReceiverItemListResult> | findPOReceiverItems(java.lang.String poNumber, java.lang.String project, java.lang.String vendorId, java.lang.String pn, java.lang.String pa, java.lang.String paFrom, java.util.Date fromDate, java.util.Date toDate, java.lang.String status, java.lang.String currency, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String[] branchWarehouses, int firstIndex, int maxLength)
java.util.Collection<POReceiverItemListResult> | findPOReceiverItemsByPartPK(PartPK partPk, int firstIndex, int maxLength)
java.util.Collection<POReceiverItemListResult> | findPoReceiverItemsByPoNumber(java.lang.String poNumber)
java.util.List<java.lang.String> | findPoReceiverItemsByPoNumberWithoutAPorPA(java.lang.String poNumber)
java.util.Collection<POReceiverItemListResult> | findPoReceiverItemWithAPListResultsByDate(java.lang.String recNumber, java.lang.String vendorId, java.lang.String pnLike, java.lang.String paType, java.lang.String paFrom, java.util.Date fromDate, java.util.Date toDate, java.lang.String rstatus, java.lang.String currency, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String apNumber, java.lang.String apItemStatus, int firstIndex, int maxLength)
java.util.Collection | findPosAdjustLocationResult(java.lang.String locate)
java.util.Collection<ProformaInvoiceItemListResult> | findProformaInvoiceItems(java.util.Date from, java.util.Date to, java.lang.String pfNumberLike, java.lang.String pnLike, java.lang.String paLike, java.lang.String soNumberLike, java.lang.String customerIdLike, java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<ProformaInvoiceListResult> | findProformaInvoiceListResultsByCustomerId(java.lang.String customerId, int firstIndex, int maxLength)
java.util.Collection<ProformaInvoiceListResult> | findProformaInvoiceListResultsByPfNumber(java.lang.String pfNumberExp, int firstIndex, int maxLength)
java.util.Collection<ReceiverInfoVO> | findReceiverInfoByReceiverNumber(java.util.ArrayList receiverNumber)
java.util.List<POReceiverItemListResult> | findReceiversByBuyerCode(java.lang.String buyerCode, int firstIndex, int maxLength)
java.util.Collection<ReceiverInfoVO> | findReceiversByRn(java.lang.String rn, int firstIndex, int maxLength)
java.util.Collection<RMAReceiverItemListResult> | findRMAReceiverItemListResultsByCustID(java.lang.String custID, int firstIndex, int maxLength)
java.util.Collection<RMAReceiverItemListResult> | findRMAReceiverItemListResultsByPartNumber(java.lang.String partNumber, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<RMAReceiverItemListResult> | findRMAReceiverItemListResultsByRMAReceiverNumber(java.lang.String rmaRecNumber, int firstIndex, int maxLength)
java.util.Collection<RMAReceiverItemListResult> | findRMAReceiverItemListResultsBySONumber(java.lang.String soNumber, int firstIndex, int maxLength)
java.util.Collection<RMAReceiverListResult> | findRMAReceiverListResultsByCustID(java.lang.String custID, int firstIndex, int maxLength)
java.util.Collection<RMAReceiverListResult> | findRMAReceiverListResultsByRMAReceiverNumber(java.lang.String rmaRecNumber, int firstIndex, int maxLength)
java.util.Collection<RMAReceiverListResult> | findRMAReceiverWithoutCMListResults(java.lang.String rmaRecNumber, int firstIndex, int maxLength)
java.util.Collection<RtvShipperItemListResult> | findRtvShipperItemListResultsByDate(java.lang.String rtvShipperNumber, java.lang.String rtvNumber, java.lang.String vendorId, java.lang.String partNumber, java.lang.String partType, java.lang.String status, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<RtvShipperItemListResult> | findRtvShipperItemListResultsByPartNumber(java.lang.String partNumber, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<RtvShipperItemListResult> | findRtvShipperItemListResultsByPONumber(java.lang.String poNumber, int firstIndex, int maxLength)
java.util.Collection<RtvShipperItemListResult> | findRtvShipperItemListResultsByRTVNumber(java.lang.String rtvNumber, int firstIndex, int maxLength)
java.util.Collection<RtvShipperItemListResult> | findRtvShipperItemListResultsByRTVShipperNumber(java.lang.String rtvShipperNumber, int firstIndex, int maxLength)
java.util.Collection<RtvShipperItemListResult> | findRtvShipperItemListResultsByVendorID(java.lang.String vendorID, int firstIndex, int maxLength)
java.util.Collection<RtvShipperListResult> | findRtvShipperListResultsByPONumber(java.lang.String poNumber, int firstIndex, int maxLength)
java.util.Collection<RtvShipperListResult> | findRtvShipperListResultsByRTVNumber(java.lang.String rtvNumber, int firstIndex, int maxLength)
java.util.Collection<RtvShipperListResult> | findRtvShipperListResultsByRTVShipperNumber(java.lang.String rtvShipperNumber, int firstIndex, int maxLength)
java.util.Collection<RtvShipperListResult> | findRtvShipperListResultsByShippedBy(java.lang.String shippedby, int firstIndex, int maxLength)
java.util.Collection<RtvShipperListResult> | findRtvShipperListResultsByVendorID(java.lang.String vendorID, int firstIndex, int maxLength)
java.util.Collection<SalesOrderShipDateListResult> | findSalesOrderShipDateListResultsByDate(java.lang.String soNumber, java.lang.String custID, java.lang.String partNumber, java.util.Date fDate, java.util.Date tDate, int firstIndex, int maxLength)
java.util.Collection<ShipperItemListResult> | findShipperItemListResults(java.util.Date fromDate, java.util.Date toDate, java.lang.String snNumber, java.lang.String soNumber, java.lang.String project, java.lang.String partNumber, java.lang.String partType, java.lang.String customerId, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String[] branchWarehouses, int firstIndex, int maxLength)
java.util.Collection<ShipperItemListResult> | findShipperItemListResultsByCustomerId(java.lang.String customerId, int firstIndex, int maxLength)
java.util.Collection<ShipperItemListResult> | findShipperItemListResultsByPartNumber(java.lang.String partNumber, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<ShipperItemListResult> | findShipperItemListResultsBySalesOrderNumber(java.lang.String soNumber, int firstIndex, int maxLength)
java.util.Collection<ShipperItemListResult> | findShipperItemListResultsBySerialNumber(java.lang.String snNumber, java.lang.String soNumber, java.lang.String partNumber, java.lang.String partType, java.lang.String customerId, java.lang.String arNumber, java.lang.String serialNumber, java.lang.String[] branchWarehouses, int firstIndex, int maxLength)
java.util.Collection<ShipperItemListResult> | findShipperItemListResultsByShipperNumber(java.lang.String snNumber, int firstIndex, int maxLength)
java.util.Collection<TotalByDateResult> | findShipperItemListResultsTotal(java.util.Date fromDate, java.util.Date toDate, java.lang.String snNumber, java.lang.String soNumber, java.lang.String partNumber, java.lang.String partType, java.lang.String customerId, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String[] branchWarehouses)
java.util.Collection<ShipperListResult> | findShipperListResultsByCustomerId(java.lang.String customerId, int firstIndex, int maxLength)
java.util.Collection<ShipperListResult> | findShipperListResultsBySalesman(java.lang.String salesman, int firstIndex, int maxLength)
java.util.Collection<ShipperListResult> | findShipperListResultsBySalesOrderNumber(java.lang.String soNumber, int firstIndex, int maxLength)
java.util.Collection<ShipperListResult> | findShipperListResultsByShipperNumber(java.lang.String snNumber, int firstIndex, int maxLength)
java.util.Collection<ShipperInfoVO> | findShippersByShipperNumber(java.lang.String shipperNumber, int firstIndex, int maxLength)
java.util.Collection<ShipperInfoVO> | findShippersBySo(java.lang.String soNumber, int firstIndex, int maxLength)
java.util.Collection<StockTransactionAdjustmentResult> | findStockTransactionAdjustmentResults(java.util.Date from, java.util.Date to, java.lang.String pnLike, java.lang.String pnType, int firstIndex, int maxLength)
java.util.Collection<StockTransactionPOReceiverResult> | findStockTransactionPOReceiverResults(java.util.Date from, java.util.Date to, java.lang.String pnLike, java.lang.String pnType, int firstIndex, int maxLength)
java.util.Collection<StockTransactionSOShipperResult> | findStockTransactionSOShipperResults(java.util.Date from, java.util.Date to, java.lang.String pnLike, java.lang.String pnType, int firstIndex, int maxLength)
java.util.Collection<StockTransactionWOReceiverResult> | findStockTransactionWOReceiverResults(java.util.Date from, java.util.Date to, java.lang.String pnLike, java.lang.String pnType, int firstIndex, int maxLength)
java.util.Collection<StockTransactionWOShipperResult> | findStockTransactionWOShipperResults(java.util.Date from, java.util.Date to, java.lang.String pnLike, java.lang.String pnType, int firstIndex, int maxLength)
java.util.Collection<SwapReceiverItemListResult> | findSwapReceiverItemByDate(java.lang.String swapReceiverNumber, java.lang.String swapShipperNumber, java.lang.String swoNumber, java.lang.String vendorId, java.lang.String status, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<SwapReceiverListResult> | findSwapReceivers(java.lang.String swapReceiverNumber, java.lang.String swapShipperNumber, java.lang.String swoNumber, java.lang.String vendorId, java.lang.String status, java.lang.String buyer, java.lang.String project, java.lang.String relatedDoc, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<SwapShipperItemListResult> | findSwapShipperItemsByDate(java.lang.String swapShipperNumber, java.lang.String swoNumber, java.lang.String vendorId, java.lang.String status, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<SwapShipperListResult> | findSwapShippers(java.lang.String swapShipperNumber, java.lang.String swoNumber, java.lang.String vendorId, java.lang.String status, java.lang.String buyer, java.lang.String project, java.lang.String relatedDoc, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<ToolOnhandVO> | findToolOnhandByPk(PartPK pk)
java.util.Collection<PartWithExcessiveInventoryListResult> | findToolWithExcessiveInventoryListResults(java.lang.String pnExp, java.lang.String paExp, int firstIndex, int length)
java.util.Collection<PartWithWipQtyListResult> | findToolWithWipQtyListResults(java.lang.String pnExp, java.lang.String paExp, int firstIndex, int length)
java.util.Collection<AuditPartInQAResult> | findTotalAuditPartInQA(java.lang.String pnLike, java.lang.String pnType, java.lang.String pnFrom, int firstIndex, int maxLength)
java.util.Collection<TransferOrderListResult> | findTransferOrderByDate(java.lang.String transferOrderNumber, java.lang.String fromAddressId, java.lang.String toAddressId, java.lang.String transferType, java.lang.String status, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)
java.util.Collection<TransferOrderItemListResult> | findTransferOrderItemsByDate(java.lang.String transferOrderNumber, java.lang.String transferType, java.lang.String partNumber, java.lang.String partType, java.lang.String status, java.lang.String dateType, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)
java.util.Collection<TransferReceiverItemListResult> | findTransferReceiverItems(java.lang.String transferOrderNumber)
java.util.Collection<TransferReceiverItemListResult> | findTransferReceiverItemsByDate(java.lang.String transferReceiverNumber, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String status, java.util.Date from, java.util.Date to, java.lang.String fromAddressId, java.lang.String toAddressId, int firstIndex, int maxLength)
TransferReceiverItemListResult | findTransferReceiverItemsTotalByDate(java.lang.String transferReceiverNumber, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String status, java.util.Date from, java.util.Date to, java.lang.String fromAddressId, java.lang.String toAddressId)
java.util.Collection<TransferReceiverListResult> | findTransferReceiverListResultsbyDate(java.lang.String transferReceiverNumber, java.lang.String transferShipperNumber, java.lang.String transferOrderNumber, java.lang.String status, java.lang.String fromAddressId, java.lang.String toAddressId, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)
java.util.Collection<TransferShipperListResult> | findTransferShipperByDate(java.lang.String transferShipperNumber, java.lang.String transferOrderNumber, java.lang.String fromAddressId, java.lang.String toAddressId, java.lang.String status, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)
java.util.Collection<TransferShipperListResult> | findTransferShipperItems(java.lang.String transferOrderNumber)
java.util.Collection<TransferShipperListResult> | findTransferShipperItemsByDate(java.lang.String transferShipperNumber, java.lang.String transferOrderNumber, java.lang.String fromAddressId, java.lang.String toAddressId, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String status, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)
TransferShipperItemListResult | findTransferShipperItemsTotalByDate(java.lang.String transferShipperNumber, java.lang.String transferOrderNumber, java.lang.String fromAddressId, java.lang.String toAddressId, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String status, java.util.Date from, java.util.Date to)
java.util.Collection<RtvShipperListResult> | findVendorNotPickRtvShippers(int firstIndex, int maxLength)
java.util.Collection<VendorPartVO> | findVendorParts(java.lang.String vendorPartNumber, java.lang.String vendorPartType, java.lang.String vendorPartFrom, java.lang.String vendorId, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, int firstIndex, int maxLength)
java.util.Collection<WoItemPickListResult> | findWoItemPickListResultsByDate(java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String partNumberLike, java.lang.String partType, java.lang.String vendorId)
java.util.Collection<WoItemPickListResult> | findWoItemPickListResultsByVendorId(java.lang.String vendorId)
WorkOrderReceiverVO | findWOReceiverByPk(java.lang.Long pk)
java.util.Collection<WOReceiverDetail> | findWOReceiverItems(java.lang.String workOrder, java.lang.String workOrderItem, java.lang.String customerId, java.lang.String pn, java.lang.String pa, java.lang.String partFrom, java.util.Date fromDate, java.util.Date toDate, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String[] branchWarehouses, boolean isIncludeNA, java.lang.String project, int firstIndex, int maxLength)
java.util.Collection<WOReceiverDetail> | findWOReceiverItemsTotal(java.lang.String workOrder, java.lang.String workOrderItem, java.lang.String customerId, java.lang.String pn, java.lang.String pa, java.lang.String partFrom, java.util.Date fromDate, java.util.Date toDate, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String[] branchWarehouses, boolean isIncludeNA, java.lang.String project)
java.util.Collection<WorkOrderIssuedOrderListResult> | findWorkOrderIssuedOrderList(WorkOrderItemPK pk)
java.util.Collection<WorkOrderReceiverVO> | findWorkOrderReceiversByWorkOrderItemPk(WorkOrderItemPK woiPk, int firstIndex, int maxLength)
java.lang.String | finishProformaShipper(ProformaInvoiceVO pfVo, boolean deleteZero, boolean withoutBoxInfo)
int | getA2PartIssuedCountByDate(java.util.Date from, java.util.Date to, java.lang.String id, java.lang.String woNumber, java.lang.String woItemNumber, java.lang.String relatedDoc, java.lang.String picker, java.lang.String pnLike, java.lang.String paLike, java.lang.String orderNumber, java.lang.String project, java.lang.String[] branchWarehouses)
LabelTemplateVO | getActiveLabelTemplateByType(java.lang.String labelType)
int | getAllDepartmentLocationForBackflushsCount()
int | getAllDueLoanCount()
int | getAllLabelTemplateCount()
int | getAllLogInventoryCount()
int | getAllNonproductivePickingApprovalsCount()
int | getAllNonproductivePickingTypesCount()
java.util.Collection<java.lang.String> | getAllNotClosedPFNumbers()
int | getAllNotClosedProformaInvoicesCount()
int | getAllOnHandAuditCount(java.lang.String partNumber, java.lang.String partType)
int | getAllOnloanControlCount()
int | getAllOnLoanCount()
int | getAllOnLoanCountByAddressId(java.lang.String addressId)
int | getAllOnloanShippersCount()
int | getAllOpenLoanCount()
int | getAllOpenOnLoanCountByAddressId(java.lang.String addressId)
int | getAllPackingBoxsCount()
java.util.Collection<PartInQAVO> | getAllPartInQAsfor(BB2Part part, java.lang.String ncrNumber)
java.util.Collection<PartInQAVO> | getAllPartInQAsWithoutNCR(BB2Part part)
int | getAllPartInQAsWithoutNCRCount(BB2Part part)
int | getAllPartOnhandCount()
int | getAllPastDueLoanCountByAddressId(java.lang.String addressId)
int | getAllProformaInvoicesCount()
int | getAllReceiversCount()
int | getAllShippersCount()
int | getAllTransferOrderApprovalCount()
int | getAllWarehousesCount()
int | getAllWorkOrderReceiversCount()
InventoryAuditReportResult | getAuditInventoryReport(PartPK pk, java.util.Date fDate, java.util.Date tDate)
java.util.Collection<AuditPartInQAResult> | getAuditPartInQA(java.lang.String pnLike, java.lang.String pnType, java.lang.String pnFrom)
int | getBackflushMaterialPartOnhandResultsCount(java.lang.String partNumber, java.lang.String partType, boolean onlyShowBackflushLocate)
BomPickListResult | getBomPickList(BillPK pk, java.math.BigDecimal qty)
int | getCheckListCount()
int | getCommitCycleCountListResultsCount(int worksheetNumber, boolean showUnCommittedOnly)
int | getCommitPhysicalInventoryListResultsCount(int worksheetNumber, boolean showUnCommittedOnly)
int | getCycleCountListByPartNumberCount(int worksheetNumber, java.lang.String pnLike, java.lang.String partType)
int | getCycleCountListResultsCount(int worksheetNumber)
int | getCycleCountListResultsCount(int worksheetNumber, int pageNubmer)
int | getCycleCountListResultsWithAvgCostCount(int worksheetNumber, int pageNubmer)
CycleCountListTotalResult | getCycleCountListTotalResultWithAvgCost(int worksheetNumber, int pageNubmer)
CycleCountStatusVO | getCycleCountStatusVO(int workSheetNumber)
CycleCountListTotalResult | getCycleCountTotalResultWithAvgCost(int worksheetNumber)
int | getCycleWorkSheetListResultsCount()
int | getCycleWorkSheetListResultsCount(int workSheetNumber)
int | getCycleWorkSheetTotalPagesNumber(int workSheetNumber)
DepartmentLocationForBackflushVO | getDepartmentLocationForBackflushByPk(java.lang.String pk)
DisassembleWorkOrderIssuingResult | getDisassembleWorkOrderItemIssuingResult(java.lang.String disassembleWorkOrderNumber)
DisassembleWorkOrderReceivingResult | getDisassembleWorkOrderReceivingResult(DisassembleWorkOrderItemPK itemPk, boolean withOtherLocation)
int | getDWOIssueItemsCount(java.lang.String disassembleWorkOrder, java.lang.String disassembleWorkOrderItem, java.lang.String customerId, java.lang.String pn, java.lang.String pa, java.util.Date fromDate, java.util.Date toDate, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String[] branchWarehouses, boolean isIncludeNA)
java.util.Collection | getDWOIssueListResultsByDwoNumber(java.lang.String input, int firstIndex, int maxLength)
int | getDWOIssueListResultsCountByDwoNumber(java.lang.String input)
java.util.Collection | getDWOReceiverListResultsByDwoNumber(java.lang.String input, int firstIndex, int maxLength)
int | getDWOReceiverListResultsCountByDwoNumber(java.lang.String input)
int | getHighUsagePartResultsCount()
int | getHistoricalInventoryDatesCount()
int | getHistoricalInventorysCount(java.lang.String pnLike, java.lang.String paLike, java.util.Date date, boolean isShowOnHand)
java.util.Collection<HistoricalInventoryTotalResult> | getHistoricalInventoryTotalResults(java.lang.String pnLike, java.lang.String paLike, java.util.Date fDate, java.util.Date tDate)
InventoryAdjustmentVO | getInventoryAdjustment(java.lang.Long pk)
InventoryAdjustmentDetailResult | getInventoryAdjustmentDetail(BB2Part part)
InventoryAdjustmentListResult | getInventoryAdjustmentListResult(BB2Part part)
int | getInventoryAdjustmentRecordsCount(BB2Part part)
int | getInventoryAdjustmentRecordsCount(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String countedBy, java.util.Date fromDate, java.util.Date toDate)
BB2PartInventoryResult | getInventoryByBB2Part(BB2Part partpk)
int | getInventoryCostVarianceCount(java.lang.String partNumber, java.lang.String partType, java.lang.String makeBuy, java.math.BigDecimal variancePercent)
int | getInventoryCycleResults(java.lang.String select)
int | getInventoryListResultCountOnlyWithMinAndMaxQty(java.lang.String productCode)
int | getInventoryListResultCountOnlyWithMinQty(java.lang.String productCode, java.lang.String commodityCode)
int | getInventoryListResultGTMaxQtyCount(java.lang.String productCode, java.lang.String commodityCode)
InventoryTotalCostResult | getInventoryListResultsCost(boolean showOnhandPartsOnly, boolean showInWipOnly, boolean showInSipOnly, boolean showInQaOnly, java.lang.String descriptionLike, java.lang.String pnFrom, java.lang.String pnTo, java.lang.String includePart, java.lang.String partType, java.lang.String partComeFrom, java.lang.String comCodeLike, java.lang.String modelNumberLike, java.lang.String productCode)
int | getInventoryListResultsCount(boolean showOnhandPartsOnly, boolean showInWipOnly, boolean showInSipOnly, boolean showInQaOnly, java.lang.String descriptionLike, java.lang.String pnFrom, java.lang.String pnTo, java.lang.String includePart, java.lang.String partType, java.lang.String partComeFrom, java.lang.String comCodeLike, java.lang.String languageCode, java.lang.String modelNumberLike, java.lang.String productCode)
int | getInventoryListResultsCountByCommodityCode(java.lang.String pnLike, java.lang.String partType, java.lang.String comCodeLike, java.lang.String buyercode)
int | getInventoryListResultWithMinAndMaxQtyCount()
int | getInventoryMonthReportCount(java.util.Date bDate, java.util.Date eDate, java.lang.String partNumberLike, java.lang.String partTypeLike)
InventoryNotUsedTotal | getInventoryNotUsedCostInMonths(java.util.Date fromDate)
InventoryNotUsedTotal | getInventoryNotUsedCostInMonths(int months)
int | getInventoryNotUsedInMonthsResultsCount(java.util.Date fromDate, boolean showZeroOnhandItems)
int | getInventoryNotUsedInMonthsResultsCount(int months, boolean showZeroOnhandItems)
int | getInventoryNotUsedInMonthsResultsforAppCount(java.util.Date toDate)
int | getInventoryReportListCount(java.lang.String pnLike, java.lang.String paLike, java.util.Date fDate, java.util.Date tDate)
int | getInventoryTotalCountByProductCode(java.lang.String productCode)
InventoryTotalResult | getInventoryTotalResult()
int | getIssuedPartTotalCount(WorkOrderItemPK pk, PartPK partPk, java.lang.String relatedDoc, java.lang.String modelNumber, java.lang.String common, java.lang.String dateType, java.util.Date dateFrom, java.util.Date dateTo)
java.util.Collection<IssuingItemResult> | getIssuingItemResultForWorkOrderItem(WorkOrderItemPK itemPk)
LabelTemplateVO | getLabelTemplate(int ii)
int | getLnShipperItemListResultsCount(java.util.Date fromDate, java.util.Date toDate, java.lang.String lnShipperNumber, java.lang.String loanNumber, java.lang.String partNumber, java.lang.String partType, java.lang.String customerId, java.lang.String status)
int | getLnShipperItemListResultsCountByCustomerId(java.lang.String customerId)
int | getLnShipperItemListResultsCountByPartNumber(java.lang.String partNumber, java.lang.String partType)
int | getLoanItemByPartPkCount(PartPK pk, java.lang.String partFromType)
int | getLocationInventoryReportCount(java.util.Date startDate, java.util.Date endDate, java.lang.String partNumber, java.lang.String partType, java.lang.String location)
InventoryMonthReport | getLocationInventoryReportTotal(java.util.Date startDate, java.util.Date endDate, java.lang.String partNumber, java.lang.String partType, java.lang.String location)
LogInventoryVO | getLogInventoryByPk(java.lang.Long logItemNumber)
int | getLogInventoryCountByPart(BB2Part part)
int | getLogInventoryCountByPartLike(java.lang.String partNumberLike, java.lang.String partType, java.lang.String partFrom, java.lang.String operator, java.lang.String location, java.util.Date fromDate, java.util.Date toDate, boolean islistOtherLocations)
int | getLogInventoryCountSimpleByPartLike(java.lang.String partNumberLike, java.lang.String partType, java.lang.String partFrom, java.util.Date fromDate, java.util.Date toDate)
java.util.Collection<MfrMpnListResult> | getMfrMpnListResultsFor(PurchaseOrderItemPK itemPk)
java.util.Collection<MfrMpnListResult> | getMfrMpnListResultsFor(SalesOrderItemPK itemPk)
BB2PartMrpResult | getMrpResult(BB2Part part)
java.util.Collection<ReceiverInfoVO> | getMyReceiverPrintList()
java.util.Collection<ShipperListResult> | getMyShipperPrintList()
int | getNeedCycleCountPartsCount(java.util.ArrayList<AuditOnDemandResult> audits)
int | getNegativePartOnhandResultsCount(java.lang.String pn1, java.lang.String pn2, java.lang.String pnType)
java.lang.Integer | getNextCycleWorkSheetNumber()
java.lang.Integer | getNextPackingBoxNumber(ProformaInvoiceVO vo)
java.lang.Integer | getNextPhysicalWorkSheetNumber()
NonproductivePickingApprovalVO | getNonproductivePickingApprovalByPk(java.lang.String pk)
NonproductivePickingVO | getNonproductivePickingByPk(java.lang.String pickingNumber)
int | getNonproductivePickingIssuedItemsCount(java.util.Date from, java.util.Date to, java.lang.String id, java.lang.String npNumber, java.lang.String npItemNumber, java.lang.String pnLike, java.lang.String paLike, java.lang.String pfLike, java.lang.String orderNumber, java.lang.String[] branchWarehouses, java.lang.String project)
PartIssueTotalResult | getNonproductivePickingIssueTotalResult(java.util.Date from, java.util.Date to, java.lang.String id, java.lang.String npNumber, java.lang.String npItemNumber, java.lang.String pnLike, java.lang.String paLike, java.lang.String orderNumber, java.lang.String[] branchWarehouses, java.lang.String project)
BB2DoubleCost | getNonproductivePickingItemIssuedTotal(java.lang.String monthYear)
int | getNonproductivePickingItemResultsCount(java.lang.String pickingNumber, java.lang.String status, java.lang.String id, java.lang.String orderType, java.util.Date fromDate, java.util.Date toDate, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String project)
int | getNonproductivePickingsCount(java.lang.String pickingNumber, java.lang.String status, java.lang.String id, java.lang.String orderType, java.util.Date fromDate, java.util.Date toDate, java.lang.String project)
ShippingResult | getNonproductivePickingShippingResult(java.lang.String pickingNumber)
OnLoanVO | getOnLoanByLoanNumber(java.lang.String loanNumber)
OnloanReviewVO | getOnloanControlByEmoloyeeTrueName(java.lang.String emoloyeeTrueName)
OnloanReviewVO | getOnloanControlByEmployeeId(java.lang.String employeeId)
int | getOnloanControlCountByUserTrueNameLike(java.lang.String userTrueNameLike)
int | getOnLoanItemsCountByDate(PartPK partPk, java.lang.String customerId, java.lang.String salesMan, java.lang.String status, boolean isDeliveryDate, java.util.Date fromDate, java.util.Date toDate)
OnloanReceiverVO | getOnloanReceiver(java.lang.String receiverNumber)
OnloanReceiverItemVO | getOnloanReceiverItemByPk(OnloanReceiverItemPK pk)
int | getOnloanReceiverItemListResultsCountByCustID(java.lang.String custID)
int | getOnloanReceiverItemListResultsCountByLnShipperNumber(java.lang.String lnShipperNumber)
int | getOnloanReceiverItemListResultsCountByOnloanReceiverNumber(java.lang.String receiverNumber)
int | getOnloanReceiverItemListResultsCountByPartNumber(java.lang.String partNumber, java.lang.String partType)
int | getOnloanReceiverListResultsCountByCustID(java.lang.String custID)
int | getOnloanReceiverListResultsCountByLnShipperNumber(java.lang.String lnShipperNumber)
int | getOnloanReceiverListResultsCountByOnloanReceiverNumber(java.lang.String receiverNumber)
java.util.Collection<OnloanReceiverListResult> | getOnloanReceiversByLn(java.lang.String onLoanNumber)
ReceivingResult | getOnloanReceivingResult(java.lang.String lnShipperNumber)
int | getOnLoansByLoanNumberCount(java.lang.String loanNumberExp)
int | getOnLoansByPoNumberCount(java.lang.String poNumberExp)
OnloanShipperVO | getOnloanShipperById(java.lang.String lnShipperNumber)
OnloanShipperItemVO | getOnloanShipperItemByPK(OnloanShipperItemPK pk)
int | getOnloanShipperListResultsCountByCustomerId(java.lang.String customerId)
int | getOnloanShipperListResultsCountByLoanNumber(java.lang.String loanNumber)
int | getOnloanShipperListResultsCountByOnloanShipperNumber(java.lang.String lnShipperNumber)
int | getOnloanShipperListResultsCountBySalesman(java.lang.String salesman)
int | getOnloanShippersCountByLn(java.lang.String loanNumber)
ShippingResult | getOnLoanShippingResult(java.lang.String loanNumber)
int | getOpenOnLoansForShipperCount(java.lang.String loanNumberExp)
int | getOpenOnloanShipperForReceiverCount(java.lang.String startWith)
int | getOpenPOReceiverItemsCountByPartPK(PartPK partPk)
int | getOpenProformaInvoiceListResultsCountByPfNumber()
int | getOpenReceiversCountByRn(java.lang.String rn)
int | getOpenSwapOrderForShipperCount(java.lang.String swoNumber)
int | getOpenTransferOrderForShipperCount(java.lang.String toNumber)
PackingBoxVO | getPackingBoxByPk(PackingBoxPK pk)
int | getPackingBoxesCountByPfNumber(java.lang.String pfNumberRegex)
int | getPackingBoxItemListResultsCountByPfNumbe(java.lang.String pfNumberExp)
int | getPackingBoxItemListResultsCountByPfNumbeAndPBNumber(java.lang.String pfNumberExp, int packingBoxNumber)
int | getPageNumberInWorkSheetByPart(PartPK partPK, java.lang.String location, int workSheetNumber, java.lang.String tagNumber)
PartClassVO | getPartClassByID(java.lang.String id)
int | getPartClassesCount()
java.util.Collection<java.lang.String> | getPartClassesList()
java.util.Collection<java.lang.String> | getPartClassesToAlarm()
int | getPartClassInfoResultCount(java.lang.String pnLike, java.lang.String partType, java.lang.String partClass)
int | getPartInWipForIDListResultsCountByVendorID(java.lang.String woLike, java.lang.String pnLike, java.lang.String partType, java.lang.String vendorIdLike)
PartInWipForIDListResult | getPartInWipForIDListResultsTotalByVendorID(java.lang.String woLike, java.lang.String pnLike, java.lang.String partType, java.lang.String vendorIdLike)
int | getPartIssuedCountByDate(java.util.Date from, java.util.Date to, java.lang.String id, java.lang.String woNumber, java.lang.String woItemNumber, java.lang.String relatedDoc, java.lang.String picker, java.lang.String pnLike, java.lang.String paLike, java.lang.String orderNumber, java.lang.String project, java.lang.String[] branchWarehouses)
PartIssueTotalResult | getPartIssueTotalResult(java.util.Date from, java.util.Date to, java.lang.String id, java.lang.String woNumber, java.lang.String woItemNumber, java.lang.String relatedDoc, java.lang.String picker, java.lang.String pnLike, java.lang.String paLike, java.lang.String orderNumber, java.lang.String project, java.lang.String[] branchWarehouses)
int | getPartLocationCount(java.lang.String location)
java.util.Collection<java.lang.String> | getPartNumPrefix(int num, java.lang.String pnLike, java.util.Date startDate)
int | getPartOnDemandQtyListResultsCount()
BB2DoubleCost | getPartOnDemandTotalAmount()
PartOnHandAuditResult | getPartOnHandAuditResult(PartPK pk, java.util.Date date)
PartWithOnhandDetailInfoResult | getPartOnhandDetailInfoByPartPk(BB2Part part)
int | getPartOnhandIsZeroByPartCount(PartPK pk)
int | getPartOnhandResultsCountByLocate(java.lang.String locate, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, boolean listZeroOnhand)
int | getPartOnLoanQtyListResultsCount()
PartWithOnLoanQtyListResult | getPartOnLoanTotalAmount()
int | getPartOnOrderQtyListResultsCount()
BB2DoubleCost | getPartOnOrderTotalAmount()
java.util.Collection<PartPK> | getPartPKsToAudit(java.lang.String pnPrefix, java.util.Date startDate)
int | getPartPKsToAuditCount(java.lang.String pnPrefix, java.util.Date startDate)
int | getPartReceivedCountByDate(java.util.Date from, java.util.Date to, java.lang.String id, java.lang.String woNumber, java.lang.String woItemNumber, java.lang.String relatedDoc, java.lang.String pnLike, java.lang.String paLike, java.lang.String receiverNumber, java.lang.String project, java.lang.String[] branchWarehouses)
PartReceivedListResult | getPartReceivedTotalResult(java.util.Date from, java.util.Date to, java.lang.String id, java.lang.String dwoNumber, java.lang.String dwoItemNumber, java.lang.String relatedDoc, java.lang.String pnLike, java.lang.String paLike, java.lang.String receiverNumber, java.lang.String project, java.lang.String[] branchWarehouses)
java.util.Collection<PartPK> | getPartsByHistoricalInventorys(java.lang.String pnLike, java.lang.String paLike, java.util.Date fDate, java.util.Date tDate)
PartInQAResult | getPartsInQAsWithoutNCR(BB2Part part)
int | getPartWithExcessiveInventoryListResultsCount(boolean addMaxQty)
int | getPartWithExcessiveInventoryListResultsCount(java.lang.String pnExp, java.lang.String paExp)
PartWithExcessiveInventoryListResult | getPartWithExcessiveInventoryTotal(boolean addMaxQty)
BB2DoubleCost | getPartWithMaxQtyTotalAmount()
BB2DoubleCost | getPartWithMinQtyTotalAmount()
int | getPartWithoutClassInfoResultCount(java.lang.String pnLike, java.lang.String description, java.lang.String partType, java.lang.String commodity)
int | getPartWithoutLocationCount(PartPK pk)
int | getPartWithQAQtyListResultsCount()
PartWithQAQtyListResult | getPartWithQAQtyTotal()
int | getPartWithSipQtyListResultsCount()
PartWithSipQtyListResult | getPartWithSipQtyTotal()
int | getPartWithSITQtyListResultsCount(java.lang.String pnExp, java.lang.String paExp, boolean isTool)
PartWithSITQtyListResult | getPartWithSITQtyTotal(java.lang.String pnExp, java.lang.String paExp, boolean isTool)
int | getPartWithSTOQtyListResultsCount(java.lang.String pnExp, java.lang.String paExp, boolean isTool)
PartWithSTOQtyListResult | getPartWithSTOQtyTotal(java.lang.String pnExp, java.lang.String paExp, boolean isTool)
int | getPartWithWipQtyListResultsCount()
int | getPartWithWipQtyListResultsCount(java.lang.String pnExp, java.lang.String paExp)
Money | getPartWithWipQtyTotal()
ProformaInvoiceVO | getPFInvoiceByPFNumber(java.lang.String pfNumber)
int | getPhysicalInventoryListByPartNumberCount(int worksheetNumber, java.lang.String pnLike, java.lang.String partType, java.lang.String location)
int | getPhysicalInventoryListResultsCount(int worksheetNumber)
int | getPhysicalInventoryListResultsCount(int worksheetNumber, int pageNubmer)
int | getPhysicalInventoryListResultsWithAvgCostCount(int worksheetNumber, int pageNubmer)
PhysicalInventoryListTotalResult | getPhysicalInventoryListTotalResultWithAvgCost(int worksheetNumber, int pageNubmer)
PhysicalInventoryStatusVO | getPhysicalInventoryStatusVO(int workSheetNumber)
PhysicalInventoryListTotalResult | getPhysicalInventoryTotalResultWithAvgCost(int worksheetNumber)
int | getPhysicalWorkSheetListResultsCount()
int | getPhysicalWorkSheetTotalPagesNumber(int workSheetNumber)
PoReceiverByDateSummaryResult | getPoReceiverByDateSummaryResult(java.lang.String vendorId, java.lang.String pnLike, java.lang.String paType, java.util.Date fromDate, java.util.Date toDate, java.lang.String rstatus)
int | getPOReceiverItemsCount(java.lang.String poNumber, java.lang.String project, java.lang.String vendorId, java.lang.String pn, java.lang.String pa, java.lang.String paFrom, java.util.Date fromDate, java.util.Date toDate, java.lang.String status, java.lang.String currency, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String[] branchWarehouses)
int | getPOReceiverItemsCountByPartPK(PartPK partPk)
int | getPoReceiverItemWithAPListResultByDateCount(java.lang.String recNumber, java.lang.String vendorId, java.lang.String pnLike, java.lang.String paType, java.lang.String paFrom, java.util.Date fromDate, java.util.Date toDate, java.lang.String rstatus, java.lang.String currency, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String apNumber, java.lang.String apItemStatus)
int | getProformaInvoiceItemsCount(java.util.Date from, java.util.Date to, java.lang.String pfNumberLike, java.lang.String pnLike, java.lang.String paLike, java.lang.String soNumberLike, java.lang.String customerIdLike, java.lang.String status)
java.util.Collection<ProformaInvoiceListResult> | getProformaInvoiceListResults(java.util.ArrayList<java.lang.String> pfnums)
int | getProformaInvoiceListResultsCountByCustomerId(java.lang.String customerId)
int | getProformaInvoiceListResultsCountByPfNumber(java.lang.String pfNumberExp)
ReceivingResult | getPurchaseOrderReceivingResult(java.lang.String purchaseOrderNumber)
ReceiverVO | getReceiverById(java.lang.String pk)
int | getReceiverInfoCountByReceiverNumber(java.util.ArrayList receiverNumber)
ReceiverItemVO | getReceiverItemByPK(ReceiverItemPK pk)
int | getReceiversByBuyerCodeCount(java.lang.String buyerCode)
int | getReceiversCountByRn(java.lang.String rn)
RMAReceiverVO | getRMAReceiver(java.lang.String receiverNumber)
RMAReceiverItemVO | getRMAReceiverItemByPk(RMAReceiverItemPK pk)
int | getRMAReceiverItemListResultsCountByCustID(java.lang.String custID)
int | getRMAReceiverItemListResultsCountByPartNumber(java.lang.String partNumber, java.lang.String partType)
int | getRMAReceiverItemListResultsCountByRMAReceiverNumber(java.lang.String rmaRecNumber)
int | getRMAReceiverItemListResultsCountBySONumber(java.lang.String soNumber)
java.util.Collection<RMAReceiverItemVO> | getRMAReceiverItemsforRMANumber(java.lang.String rmaNumber)
int | getRMAReceiverListResultsCountByCustID(java.lang.String custID)
int | getRMAReceiverListResultsCountByRMAReceiverNumber(java.lang.String rmaRecNumber)
int | getRMAReceiverWithoutCMListResultsCount(java.lang.String rmaRecNumber)
ReceivingResult | getRmaReceivingResult(java.lang.String rmaNumber)
RtvShipperVO | getRtvShipperById(java.lang.String rtvShipperNumber)
RtvShipperItemVO | getRtvShipperItemByPk(RtvShipperItemPK pk)
int | getRtvShipperItemListResultsCountByDate(java.lang.String rtvShipperNumber, java.lang.String rtvNumber, java.lang.String vendorId, java.lang.String partNumber, java.lang.String partType, java.lang.String status, java.util.Date fromDate, java.util.Date toDate)
int | getRtvShipperItemListResultsCountByPartNumber(java.lang.String partNumber, java.lang.String partType)
int | getRtvShipperItemListResultsCountByPONumber(java.lang.String poNumber)
int | getRtvShipperItemListResultsCountByRTVNumber(java.lang.String rtvNumber)
int | getRtvShipperItemListResultsCountByRTVShipperNumber(java.lang.String rtvShipperNumber)
int | getRtvShipperItemListResultsCountByVendorID(java.lang.String vendorID)
java.util.Collection<RtvShipperItemListResult> | getRtvShipperItemListResultsOfRtv(java.lang.String rtvNumber)
int | getRtvShipperListResultsCountByPONumber(java.lang.String poNumber)
int | getRtvShipperListResultsCountByRTVNumber(java.lang.String rtvNumber)
int | getRtvShipperListResultsCountByRTVShipperNumber(java.lang.String rtvShipperNumber)
int | getRtvShipperListResultsCountByShippedBy(java.lang.String shippedby)
int | getRtvShipperListResultsCountByVendorID(java.lang.String vendorID)
ShippingResult | getRtvShippingResult(java.lang.String rtvNumber)
int | getSalesOrderShipDateListResultsCountByDate(java.lang.String soNumber, java.lang.String custID, java.lang.String partNumber, java.util.Date fDate, java.util.Date tDate)
ShippingResult | getSalesOrderShippingResult(java.lang.String salesOrderNumber)
ShipperVO | getShipperById(java.lang.String id)
ShipperItemVO | getShipperItemByPK(ShipperItemPK pk)
int | getShipperItemListResultsCount(java.util.Date fromDate, java.util.Date toDate, java.lang.String snNumber, java.lang.String soNumber, java.lang.String project, java.lang.String partNumber, java.lang.String partType, java.lang.String customerId, java.lang.String status, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String[] branchWarehouses)
int | getShipperItemListResultsCountByCustomerId(java.lang.String customerId)
int | getShipperItemListResultsCountByPartNumber(java.lang.String partNumber, java.lang.String partType)
int | getShipperItemListResultsCountBySalesOrderNumber(java.lang.String soNumber)
int | getShipperItemListResultsCountBySerialNumber(java.lang.String snNumber, java.lang.String soNumber, java.lang.String partNumber, java.lang.String partType, java.lang.String customerId, java.lang.String arNumber, java.lang.String serialNumber, java.lang.String[] branchWarehouses)
int | getShipperItemListResultsCountByShipperNumber(java.lang.String snNumber)
int | getShipperListResultsCountByCustomerId(java.lang.String customerId)
int | getShipperListResultsCountBySalesman(java.lang.String salesman)
int | getShipperListResultsCountBySalesOrderNumber(java.lang.String soNumber)
int | getShipperListResultsCountByShipperNumber(java.lang.String snNumber)
int | getShippersCountByShipperNumber(java.lang.String shipperNumber)
int | getShippersCountBySo(java.lang.String soNumber)
ShippingItemResult | getShippingItemResult(SalesOrderItemPK pk)
SoPickListResult | getSoPickListResult(java.lang.String salesOrderNumber)
int | getStockTransactionAdjustmentResultsCount(java.util.Date from, java.util.Date to, java.lang.String pnLike, java.lang.String pnType)
StockTransactionPartInfoResult | getStockTransactionPartInfoResultByPartPk(PartPK pk)
int | getStockTransactionPOReceiverResultsCount(java.util.Date from, java.util.Date to, java.lang.String pnLike, java.lang.String pnType)
int | getStockTransactionSOShipperResultsCount(java.util.Date from, java.util.Date to, java.lang.String pnLike, java.lang.String pnType)
int | getStockTransactionWOReceiverResultsCount(java.util.Date from, java.util.Date to, java.lang.String pnLike, java.lang.String pnType)
int | getStockTransactionWOShipperResultsCount(java.util.Date from, java.util.Date to, java.lang.String pnLike, java.lang.String pnType)
ShippingResult | getSwapOrderShippingResult(java.lang.String swoNumber)
int | getSwapReceiverItemByDateCount(java.lang.String swapReceiverNumber, java.lang.String swapShipperNumber, java.lang.String swoNumber, java.lang.String vendorId, java.lang.String status, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.util.Date fromDate, java.util.Date toDate)
SwapReceiverItemVO | getSwapReceiverItemByPk(SwapReceiverItemPK pk)
int | getSwapReceiversCount(java.lang.String swapReceiverNumber, java.lang.String swapShipperNumber, java.lang.String swoNumber, java.lang.String vendorId, java.lang.String status, java.lang.String buyer, java.lang.String project, java.lang.String relatedDoc, java.util.Date fromDate, java.util.Date toDate)
SwapReceiverVO | getSwapReceiverVO(java.lang.String swapReceiverNumber)
ReceivingResult | getSwapReceivingResult(java.lang.String swapShipperNumber)
SwapShipperItemVO | getSwapShipperItemByPk(SwapShipperItemPK pk)
int | getSwapShipperItemsByDateCount(java.lang.String swapShipperNumber, java.lang.String swoNumber, java.lang.String vendorId, java.lang.String status, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.util.Date fromDate, java.util.Date toDate)
int | getSwapShippersCount(java.lang.String swapShipperNumber, java.lang.String swoNumber, java.lang.String vendorId, java.lang.String status, java.lang.String buyer, java.lang.String project, java.lang.String relatedDoc, java.util.Date fromDate, java.util.Date toDate)
SwapShipperVO | getSwapShipperVO(java.lang.String swapShipperNumber)
BomPickListResult | getToolListsPickList(BillPK pk, java.math.BigDecimal qty)
int | getToolWithExcessiveInventoryListResultsCount(java.lang.String pnExp, java.lang.String paExp)
int | getToolWithWipQtyListResultsCount(java.lang.String pnExp, java.lang.String paExp)
int | getTotalAuditPartInQACount(java.lang.String pnLike, java.lang.String pnType, java.lang.String pnFrom)
BB2PartTotalInQADetailResult | getTotalInQAResult(BB2Part part)
BB2PartTotalInSipDetailResult | getTotalInSipDetail(BB2Part part)
BB2PartTotalInSitDetailResult | getTotalInSitDetail(BB2Part part)
BB2PartTotalInSTODetailResult | getTotalInSTODetail(BB2Part part)
BB2PartTotalInWipDetailResult | getTotalInWipDetail(BB2Part part)
BB2PartTotalOndemandDetailResult | getTotalOndemandDetail(BB2Part part)
BB2PartTotalOnhandDetailResult | getTotalOnhandDetail(BB2Part part)
BB2PartTotalOnloanDetailResult | getTotalOnLoanResult(BB2Part part)
BB2PartTotalOnorderDetailResult | getTotalOnorderDetail(BB2Part part)
int | getTotalPartToAuditCount(java.lang.String pnLike, java.util.Date startDate)
PartWithWipQtyListResult | getTotalPartWithWipQtyCost()
java.util.Collection<TotalByDateResult> | getTotalPOReceiverResult(java.lang.String poNumber, java.lang.String project, java.lang.String vendorId, java.lang.String pn, java.lang.String pa, java.lang.String paFrom, java.util.Date fromDate, java.util.Date toDate, java.lang.String status, java.lang.String currency, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String[] branchWarehouses)
BB2PartTotalOndemandDetailResult | getTotalUsageDetail(BB2Part part, boolean isYr)
TransferOrderApprovalVO | getTransferOrderApprovalByEmployeeId(java.lang.String employeeId)
int | getTransferOrderByDateCount(java.lang.String transferOrderNumber, java.lang.String fromAddressId, java.lang.String toAddressId, java.lang.String transferType, java.lang.String status, java.util.Date from, java.util.Date to)
TransferOrderVO | getTransferOrderByPk(java.lang.String transferOrderNumber)
int | getTransferOrderItemsByDateCount(java.lang.String transferOrderNumber, java.lang.String transferType, java.lang.String partNumber, java.lang.String partType, java.lang.String status, java.lang.String dateType, java.util.Date from, java.util.Date to)
ShippingResult | getTransferOrderShippingResult(java.lang.String transferOrderNumber)
TransferReceiverVO | getTransferReceiverById(java.lang.String receiverNumber)
TransferReceiverItemVO | getTransferReceiverItemByPk(TransferReceiverItemPK pk)
int | getTransferReceiverItemsByDate(java.lang.String transferReceiverNumber, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String status, java.util.Date from, java.util.Date to, java.lang.String fromAddressId, java.lang.String toAddressId)
int | getTransferReceiverListResultsbyDateCount(java.lang.String transferReceiverNumber, java.lang.String transferShipperNumber, java.lang.String transferOrderNumber, java.lang.String status, java.lang.String fromAddressId, java.lang.String toAddressId, java.util.Date from, java.util.Date to)
ReceivingResult | getTransferReceivingResult(java.lang.String transferShipperNumber)
TransferShipperVO | getTransferShipper(java.lang.String transferShipperNumber)
int | getTransferShipperByDateCount(java.lang.String transferShipperNumber, java.lang.String transferOrderNumber, java.lang.String fromAddressId, java.lang.String toAddressId, java.lang.String status, java.util.Date from, java.util.Date to)
TransferShipperItemVO | getTransferShipperItemByPk(TransferShipperItemPK pk)
int | getTransferShipperItemsByDateCount(java.lang.String transferShipperNumber, java.lang.String transferOrderNumber, java.lang.String fromAddressId, java.lang.String toAddressId, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String status, java.util.Date from, java.util.Date to)
int | getVendorNotPickRtvShippersCount()
VendorPartVO | getVendorPart(VendorPartPK pk)
int | getVendorPartsCount(java.lang.String vendorPartNumber, java.lang.String vendorPartType, java.lang.String vendorPartFrom, java.lang.String vendorId, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom)
WarehouseVO | getWarehouseByPK(java.lang.String warehousePrefix)
WoItemPickListResult | getWoItemPickListResult(WorkOrderItemPK itemPk, java.math.BigDecimal qty, java.lang.String locationsPrefix)
int | getWOReceiverItemsCount(java.lang.String workOrder, java.lang.String workOrderItem, java.lang.String customerId, java.lang.String pn, java.lang.String pa, java.lang.String partFrom, java.util.Date fromDate, java.util.Date toDate, java.lang.String accountNumber, java.lang.String companyUnitId, java.lang.String[] branchWarehouses, boolean isIncludeNA, java.lang.String project)
int | getWorkOrderIssuedOrderCount(WorkOrderItemPK pk)
IssuingResult | getWorkOrderItemIssuingResult(WorkOrderItemPK itemPk, boolean withOtherLocation)
int | getWorkOrderReceiversCountByWorkOrderItemPk(WorkOrderItemPK woiPk)
ReceivingResult | getWorkOrderReceivingResult(java.lang.String workOrderNumber)
NonproductivePickingItemVO | InitNonproductivePickingItem(NonproductivePickingVO vo, BB2Part part, java.math.BigDecimal quantity)
OnLoanItemVO | initOnLoanItem(OnLoanVO onloanVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool)
PackingBoxItemVO | initPackingBoxItemVO(PackingBoxPK boxPk, SalesOrderItemPK itemPk, java.math.BigDecimal qty)
TransferOrderItemVO | initTransferOrderItem(TransferOrderVO toVo, PartPK partPk, java.math.BigDecimal quantity, boolean isTool)
void | initWarehouse(java.lang.String locationPrefix, java.lang.String warehouseId, java.lang.String oldLocation)
boolean | isCycleWorkSheetExist(int worksheetNumber)
boolean | isCycleWorkSheetPageExist(int worksheetNumber, int pageNumber)
boolean | isLabelTemplateExist(int ii)
boolean | isLocationExist(java.lang.String location)
boolean | isMakeNcr(BB2Part part, java.lang.String receivedFrom)
boolean | isOnloanControlRecorded(java.lang.String employeeId)
boolean | isOnLoanItemExist(OnLoanItemPK pk)
boolean | isOnloanReceiverExist(java.lang.String receiverNumber)
boolean | isPFFinished(java.lang.String pfInvoiceNumber)
boolean | isPFSOHoldByPFNumber(java.lang.String pfNumber)
boolean | isPhysicalWorkSheetExist(int worksheetNumber)
boolean | isPhysicalWorkSheetPageExist(int worksheetNumber, int pageNumber)
boolean | isReceiverExist(java.lang.String receiverNumber)
boolean | isReceiverInMyPrintList(java.lang.String receiverNumber)
boolean | isShipperExist(java.lang.String shipperNumber)
boolean | isShipperInMyPrintList(java.lang.String shipperNumber)
java.lang.Integer | issuePartsToDisassembleWorkOrder(java.util.ArrayList agents)
void | issuePartsToDisassembleWorkOrder(IssueItemAgent issueItemAgent)
java.lang.Integer | issuePartsToWorkOrderItem(java.util.ArrayList agents)
void | issuePartsToWorkOrderItem(IssueItemAgent issueItemAgent)
boolean | isTransferOrderApprovalExist(java.lang.String employeeId)
boolean | isVendorPartExistent(VendorPartPK pk)
boolean | isWarehouseExist(java.lang.String warehousePrefix)
boolean | isWarehouseUsing(java.lang.String warehousePrefix)
void | linkNCRtoPartInQA(java.util.HashSet<java.lang.Integer> sets, java.lang.String ncrNumber)
InventoryAuditReportResult | makeAuditInventoryByPhyInventory(PartPK pk, java.util.Date fDate, java.util.Date tDate)
DisassembleWorkOrderItemPK | makeDisassembleWorkOrderReceiver(java.util.Set<ReceiverItemAgent> agent)
java.lang.Integer | makeNonproductivePickingShipper(ShipperAgent agent)
java.util.Collection<OnloanReceiverListResult> | makeOnloanReceiver(ReceiverAgent agent)
java.lang.String | makeOnLoanShipper(ShipperAgent vo)
java.lang.String | makePhysicalInventoryGL(java.math.BigDecimal commitTotal, java.util.ArrayList<PhysicalInventoryListResult> result, java.lang.String glCategory, java.lang.String[] inventoryAccount, java.lang.String[] assetLossesAccount)
java.util.Collection<java.lang.String> | makePurchaseOrderReceiver(ReceiverAgent agent)
java.lang.String | makePurchaseOrderReceiver(ReceiverShipAgent agent)
java.util.Collection<RMAReceiverListResult> | makeRmaReceiver(ReceiverAgent agent)
java.lang.String | makeRtvShipper(ShipperAgent vo)
java.lang.String | makeSaleOrderShipper(ShipperAgent vo)
java.lang.String | makeSwapOrderShipper(ShipperAgent agent)
java.util.List<SwapReceiverListResult> | makeSwapReceiver(ReceiverAgent agent)
java.lang.String | makeTransferOrderShipper(ShipperAgent vo)
java.util.Collection<TransferReceiverListResult> | makeTransferReceiver(ReceiverAgent agent)
java.lang.String | makeWorkOrderReceiver(ReceiverAgent agent)
void | moveWarehouse(java.lang.String warehouseFrom, java.lang.String warehouseTo)
void | pullFromWorkOrderPartDetail(java.util.HashSet<PullFromWorkOrderPartDetailAgent> sets, java.lang.String ncrNumber)
void | putParttoInQA(java.util.HashSet<PuttoInQAAgent> sets, java.lang.String ncrNumber)
void | rebackInQAtoWareHouse(java.util.HashSet<RebackInQAAgent> sets)
ProformaInvoiceVO | refreshProformaInvoice(ProformaInvoiceVO vo)
void | removeProformaInvoiceItem(ProformaInvoiceItemPK itemPk)
PackingBoxPK | removeSalesOrderItemToPackingBox(PackingBoxItemPK pk)
java.lang.String | reviewOnLoan(OnLoanVO loanVo)
void | setOnLoanItemReferenceDocOne(OnLoanItemPK pk, java.lang.String referenceDoc)
void | setOnLoanItemReferenceDocTwo(OnLoanItemPK pk, java.lang.String referenceDoc)
void | setRtvShipperVendorPicked(RtvShipperVO vo)
void | shipPartToNCR(java.lang.String ncrNumber, java.util.Set<PuttoInQAAgent> putToInQAAgentSet, java.util.Set pullFromWorkOrderPartDetailAgentSet)
void | subtractPartOnOder(PurchaseOrderItemVO item)
void | subtractToolOnOder(PurchaseOrderItemVO item)
int | takeInitCycleCount(java.util.Collection<java.util.Map> datas, int top, int workSheetNumber, java.lang.String description, java.lang.String orderBy, boolean zerolocation, boolean zeroPhysicalCount)
int | takeInitCycleCount(TakeCycleCountAgent agent)
int | takeInitPhysicalInventory(int workSheetNumber, java.lang.String description, java.lang.String orderBy, boolean zerolocation, boolean zeroPhysicalCount, boolean backflush, boolean onlyBackflushLocation)
java.lang.String | transferPart(java.lang.String transferOrderNumber)
java.util.Collection<CycleCountPK> | updateCycleCount(java.util.ArrayList<CycleCountAgent> list)
int | updateCycleCountStatus(CycleCountStatusVO vo)
DepartmentLocationForBackflushVO | updateDepartmentLocationForBackflush(DepartmentLocationForBackflushVO vo)
void | updateLabelTemplate(LabelTemplateVO vo)
void | updateLogInventory(LogInventoryVO vo)
void | updateNonproductivePicking(NonproductivePickingVO vo)
NonproductivePickingApprovalVO | updateNonproductivePickingAprroval(NonproductivePickingApprovalVO vo)
NonproductivePickingTypeVO | updateNonproductivePickingType(NonproductivePickingTypeVO vo)
java.lang.String | updateOnLoan(OnLoanVO vo)
OnloanReviewVO | updateOnloanControl(OnloanReviewVO vo)
java.lang.String | updateOnloanReceiver(OnloanReceiverVO vo)
OnloanShipperVO | updateOnloanShipper(OnloanShipperVO vo)
PackingBoxVO | updatePackingBox(PackingBoxVO vo)
PackingBoxItemVO | updatePackingBoxItem(PackingBoxItemPK pk, java.util.Map newQty)
PackingBoxVO | updatePackingBoxItems(java.util.HashMap map, PackingBoxPK pk)
PartClassVO | updatePartClass(PartClassVO vo, boolean autoCount)
void | updatePartOnhand(PartOnhandVO vo)
void | updatePartPartClass(java.util.HashSet<PartPK> set, java.lang.String partClass)
java.util.Collection<PhysicalInventoryPK> | updatePhysicalInventory(java.util.ArrayList list)
int | updatePhysicalInventoryStatus(PhysicalInventoryStatusVO vo)
ProformaInvoiceVO | updateProformaInvoice(ProformaInvoiceVO vo)
java.lang.String | updateReceiver(ReceiverVO vo)
RefdocVO | updateRefdocTwo(RefdocVO vo)
java.lang.String | updateRMAReceiver(RMAReceiverVO vo)
java.lang.String | updateRtvShipper(RtvShipperVO vo)
ShipperVO | updateShipper(ShipperVO vo)
java.lang.String | updateSwapReceiver(SwapReceiverVO vo)
SwapShipperVO | updateSwapShipper(SwapShipperVO vo)
java.util.Collection<ToolOnhandVO> | updateToolOnhandDetail(java.util.HashSet onhandDetailVo, PartPK pk)
void | updateTransferOrder(TransferOrderVO vo)
void | updateTransferOrderApproval(TransferOrderApprovalVO vo)
java.lang.String | updateTransferReceiver(TransferReceiverVO vo)
TransferShipperVO | updateTransferShipper(TransferShipperVO vo)
void | updateVendorPart(VendorPartVO vo)
void | updateWarehouse(WarehouseVO vo)
void | updateWOReceiver(WorkOrderReceiverVO vo)

Method Detail

addShipper

ShipperVO addShipper(ShipperVO vo)
                     throws java.lang.Exception
Throws:
java.lang.Exception

makeSaleOrderShipper

java.lang.String makeSaleOrderShipper(ShipperAgent vo)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

makeOnLoanShipper

java.lang.String makeOnLoanShipper(ShipperAgent vo)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

makeRtvShipper

java.lang.String makeRtvShipper(ShipperAgent vo)
                                throws java.lang.Exception
Throws:
java.lang.Exception

updateRtvShipper

java.lang.String updateRtvShipper(RtvShipperVO vo)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

setRtvShipperVendorPicked

void setRtvShipperVendorPicked(RtvShipperVO vo)
                               throws java.lang.Exception
Throws:
java.lang.Exception

deleteShipper

void deleteShipper(ShipperVO vo)
                   throws java.lang.Exception
Throws:
java.lang.Exception

updateShipper

ShipperVO updateShipper(ShipperVO vo)
                        throws java.lang.Exception
Throws:
java.lang.Exception

getShipperById

ShipperVO getShipperById(java.lang.String id)
                         throws java.lang.Exception
Throws:
java.lang.Exception

getShipperItemByPK

ShipperItemVO getShipperItemByPK(ShipperItemPK pk)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

isShipperExist

boolean isShipperExist(java.lang.String shipperNumber)
                       throws java.lang.Exception
Throws:
java.lang.Exception

findVendorNotPickRtvShippers

java.util.Collection<RtvShipperListResult> findVendorNotPickRtvShippers(int firstIndex,
                                                                        int maxLength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getVendorNotPickRtvShippersCount

int getVendorNotPickRtvShippersCount()
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findShippersBySo

java.util.Collection<ShipperInfoVO> findShippersBySo(java.lang.String soNumber,
                                                     int firstIndex,
                                                     int maxLength)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getShippersCountBySo

int getShippersCountBySo(java.lang.String soNumber)
                         throws java.lang.Exception
Throws:
java.lang.Exception

getAllShippersCount

int getAllShippersCount()
                        throws java.lang.Exception
Throws:
java.lang.Exception

findAllShippers

java.util.Collection<ShipperInfoVO> findAllShippers(int firstIndex,
                                                    int maxLength)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

findShippersByShipperNumber

java.util.Collection<ShipperInfoVO> findShippersByShipperNumber(java.lang.String shipperNumber,
                                                                int firstIndex,
                                                                int maxLength)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getShippersCountByShipperNumber

int getShippersCountByShipperNumber(java.lang.String shipperNumber)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

shipPartToNCR

void shipPartToNCR(java.lang.String ncrNumber,
                   java.util.Set<PuttoInQAAgent> putToInQAAgentSet,
                   java.util.Set pullFromWorkOrderPartDetailAgentSet)
                   throws java.lang.Exception
Throws:
java.lang.Exception

getMyShipperPrintList

java.util.Collection<ShipperListResult> getMyShipperPrintList()
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

isShipperInMyPrintList

boolean isShipperInMyPrintList(java.lang.String shipperNumber)
                               throws java.lang.Exception
Throws:
java.lang.Exception

addShipperToMyPrintList

MyPrintListVO addShipperToMyPrintList(java.lang.String shipperNumber)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

deleteMyShipperPrintList

void deleteMyShipperPrintList(java.util.List ShipperNumberList)
                              throws java.lang.Exception
Throws:
java.lang.Exception

findShipperListResultsByShipperNumber

java.util.Collection<ShipperListResult> findShipperListResultsByShipperNumber(java.lang.String snNumber,
                                                                              int firstIndex,
                                                                              int maxLength)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getShipperListResultsCountByShipperNumber

int getShipperListResultsCountByShipperNumber(java.lang.String snNumber)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

findShipperListResultsBySalesOrderNumber

java.util.Collection<ShipperListResult> findShipperListResultsBySalesOrderNumber(java.lang.String soNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getShipperListResultsCountBySalesOrderNumber

int getShipperListResultsCountBySalesOrderNumber(java.lang.String soNumber)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findShipperListResultsBySalesman

java.util.Collection<ShipperListResult> findShipperListResultsBySalesman(java.lang.String salesman,
                                                                         int firstIndex,
                                                                         int maxLength)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getShipperListResultsCountBySalesman

int getShipperListResultsCountBySalesman(java.lang.String salesman)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

findShipperListResultsByCustomerId

java.util.Collection<ShipperListResult> findShipperListResultsByCustomerId(java.lang.String customerId,
                                                                           int firstIndex,
                                                                           int maxLength)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getShipperListResultsCountByCustomerId

int getShipperListResultsCountByCustomerId(java.lang.String customerId)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

findShipperItemListResultsByShipperNumber

java.util.Collection<ShipperItemListResult> findShipperItemListResultsByShipperNumber(java.lang.String snNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getShipperItemListResultsCountByShipperNumber

int getShipperItemListResultsCountByShipperNumber(java.lang.String snNumber)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

findShipperItemListResultsBySalesOrderNumber

java.util.Collection<ShipperItemListResult> findShipperItemListResultsBySalesOrderNumber(java.lang.String soNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getShipperItemListResultsCountBySalesOrderNumber

int getShipperItemListResultsCountBySalesOrderNumber(java.lang.String soNumber)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

findShipperItemListResultsByPartNumber

java.util.Collection<ShipperItemListResult> findShipperItemListResultsByPartNumber(java.lang.String partNumber,
                                                                                java.lang.String partType,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getShipperItemListResultsCountByPartNumber

int getShipperItemListResultsCountByPartNumber(java.lang.String partNumber,
                                               java.lang.String partType)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

findShipperItemListResultsByCustomerId

java.util.Collection<ShipperItemListResult> findShipperItemListResultsByCustomerId(java.lang.String customerId,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getShipperItemListResultsCountByCustomerId

int getShipperItemListResultsCountByCustomerId(java.lang.String customerId)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

findShipperItemListResults

java.util.Collection<ShipperItemListResult> findShipperItemListResults(java.util.Date fromDate,
                                                                       java.util.Date toDate,
                                                                       java.lang.String snNumber,
                                                                       java.lang.String soNumber,
                                                                       java.lang.String project,
                                                                       java.lang.String partNumber,
                                                                       java.lang.String partType,
                                                                       java.lang.String customerId,
                                                                       java.lang.String status,
                                                                       java.lang.String accountNumber,
                                                                       java.lang.String companyUnitId,
                                                                       java.lang.String[] branchWarehouses,
                                                                       int firstIndex,
                                                                       int maxLength)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getShipperItemListResultsCount

int getShipperItemListResultsCount(java.util.Date fromDate,
                                   java.util.Date toDate,
                                   java.lang.String snNumber,
                                   java.lang.String soNumber,
                                   java.lang.String project,
                                   java.lang.String partNumber,
                                   java.lang.String partType,
                                   java.lang.String customerId,
                                   java.lang.String status,
                                   java.lang.String accountNumber,
                                   java.lang.String companyUnitId,
                                   java.lang.String[] branchWarehouses)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findShipperItemListResultsTotal

java.util.Collection<TotalByDateResult> findShipperItemListResultsTotal(java.util.Date fromDate,
                                                                        java.util.Date toDate,
                                                                        java.lang.String snNumber,
                                                                        java.lang.String soNumber,
                                                                        java.lang.String partNumber,
                                                                        java.lang.String partType,
                                                                        java.lang.String customerId,
                                                                        java.lang.String status,
                                                                        java.lang.String accountNumber,
                                                                        java.lang.String companyUnitId,
                                                                        java.lang.String[] branchWarehouses)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

findShipperItemListResultsBySerialNumber

java.util.Collection<ShipperItemListResult> findShipperItemListResultsBySerialNumber(java.lang.String snNumber,
                                                                                java.lang.String soNumber,
                                                                                java.lang.String partNumber,
                                                                                java.lang.String partType,
                                                                                java.lang.String customerId,
                                                                                java.lang.String arNumber,
                                                                                java.lang.String serialNumber,
                                                                                java.lang.String[] branchWarehouses,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getShipperItemListResultsCountBySerialNumber

int getShipperItemListResultsCountBySerialNumber(java.lang.String snNumber,
                                                 java.lang.String soNumber,
                                                 java.lang.String partNumber,
                                                 java.lang.String partType,
                                                 java.lang.String customerId,
                                                 java.lang.String arNumber,
                                                 java.lang.String serialNumber,
                                                 java.lang.String[] branchWarehouses)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getPurchaseOrderReceivingResult

ReceivingResult getPurchaseOrderReceivingResult(java.lang.String purchaseOrderNumber)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderReceivingResult

ReceivingResult getWorkOrderReceivingResult(java.lang.String workOrderNumber)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

getRmaReceivingResult

ReceivingResult getRmaReceivingResult(java.lang.String rmaNumber)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOrderShippingResult

ShippingResult getSalesOrderShippingResult(java.lang.String salesOrderNumber)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

getShippingItemResult

ShippingItemResult getShippingItemResult(SalesOrderItemPK pk)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

getRtvShippingResult

ShippingResult getRtvShippingResult(java.lang.String rtvNumber)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

getOnLoanShippingResult

ShippingResult getOnLoanShippingResult(java.lang.String loanNumber)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderItemIssuingResult

IssuingResult getWorkOrderItemIssuingResult(WorkOrderItemPK itemPk,
                                            boolean withOtherLocation)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

getIssuingItemResultForWorkOrderItem

java.util.Collection<IssuingItemResult> getIssuingItemResultForWorkOrderItem(WorkOrderItemPK itemPk)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

issuePartsToWorkOrderItem

void issuePartsToWorkOrderItem(IssueItemAgent issueItemAgent)
                               throws java.lang.Exception
Throws:
java.lang.Exception

issuePartsToWorkOrderItem

java.lang.Integer issuePartsToWorkOrderItem(java.util.ArrayList agents)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

addWorkOrderAndIssueParts

java.lang.Object[] addWorkOrderAndIssueParts(WorkOrderVO vo,
                                             WorkOrderItemVO item,
                                             java.util.ArrayList<WorkOrderItemSetupItemAgent> setupList,
                                             java.util.Set<IssueItemAgent> issueItemAgents,
                                             ReceiverAgent agent)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

makeWorkOrderReceiver

java.lang.String makeWorkOrderReceiver(ReceiverAgent agent)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

addWorkOrderAndReceiveParts

java.lang.String addWorkOrderAndReceiveParts(WorkOrderVO clientVO)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

addReceiver

ReceiverVO addReceiver(ReceiverVO vo)
                       throws java.lang.Exception
Throws:
java.lang.Exception

isReceiverExist

boolean isReceiverExist(java.lang.String receiverNumber)
                        throws java.lang.Exception
Throws:
java.lang.Exception

getReceiverItemByPK

ReceiverItemVO getReceiverItemByPK(ReceiverItemPK pk)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findReceiverInfoByReceiverNumber

java.util.Collection<ReceiverInfoVO> findReceiverInfoByReceiverNumber(java.util.ArrayList receiverNumber)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getReceiverInfoCountByReceiverNumber

int getReceiverInfoCountByReceiverNumber(java.util.ArrayList receiverNumber)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

makePurchaseOrderReceiver

java.util.Collection<java.lang.String> makePurchaseOrderReceiver(ReceiverAgent agent)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

makePurchaseOrderReceiver

java.lang.String makePurchaseOrderReceiver(ReceiverShipAgent agent)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

deleteReceiver

void deleteReceiver(ReceiverVO vo)
                    throws java.lang.Exception
Throws:
java.lang.Exception

deleteReceiver

void deleteReceiver(java.lang.String receiverNumber)
                    throws java.lang.Exception
Throws:
java.lang.Exception

updateReceiver

java.lang.String updateReceiver(ReceiverVO vo)
                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllReceiversCount

int getAllReceiversCount()
                         throws java.lang.Exception
Throws:
java.lang.Exception

getReceiverById

ReceiverVO getReceiverById(java.lang.String pk)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findReceiversByRn

java.util.Collection<ReceiverInfoVO> findReceiversByRn(java.lang.String rn,
                                                       int firstIndex,
                                                       int maxLength)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getReceiversCountByRn

int getReceiversCountByRn(java.lang.String rn)
                          throws java.lang.Exception
Throws:
java.lang.Exception

findOpenReceiversByRn

java.util.Collection<ReceiverInfoVO> findOpenReceiversByRn(java.lang.String rn,
                                                           int firstIndex,
                                                           int maxLength)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getOpenReceiversCountByRn

int getOpenReceiversCountByRn(java.lang.String rn)
                              throws java.lang.Exception
Throws:
java.lang.Exception

getMyReceiverPrintList

java.util.Collection<ReceiverInfoVO> getMyReceiverPrintList()
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

isReceiverInMyPrintList

boolean isReceiverInMyPrintList(java.lang.String receiverNumber)
                                throws java.lang.Exception
Throws:
java.lang.Exception

addReceiverToMyPrintList

MyPrintListVO addReceiverToMyPrintList(java.lang.String receiverNumber)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

deleteMyReceiverPrintList

void deleteMyReceiverPrintList(java.util.List receiverNumberList)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findPOReceiverItems

java.util.Collection<POReceiverItemListResult> findPOReceiverItems(java.lang.String poNumber,
                                                                   java.lang.String project,
                                                                   java.lang.String vendorId,
                                                                   java.lang.String pn,
                                                                   java.lang.String pa,
                                                                   java.lang.String paFrom,
                                                                   java.util.Date fromDate,
                                                                   java.util.Date toDate,
                                                                   java.lang.String status,
                                                                   java.lang.String currency,
                                                                   java.lang.String accountNumber,
                                                                   java.lang.String companyUnitId,
                                                                   java.lang.String[] branchWarehouses,
                                                                   int firstIndex,
                                                                   int maxLength)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getPOReceiverItemsCount

int getPOReceiverItemsCount(java.lang.String poNumber,
                            java.lang.String project,
                            java.lang.String vendorId,
                            java.lang.String pn,
                            java.lang.String pa,
                            java.lang.String paFrom,
                            java.util.Date fromDate,
                            java.util.Date toDate,
                            java.lang.String status,
                            java.lang.String currency,
                            java.lang.String accountNumber,
                            java.lang.String companyUnitId,
                            java.lang.String[] branchWarehouses)
                            throws java.lang.Exception
Throws:
java.lang.Exception

getPoReceiverItemWithAPListResultByDateCount

int getPoReceiverItemWithAPListResultByDateCount(java.lang.String recNumber,
                                                 java.lang.String vendorId,
                                                 java.lang.String pnLike,
                                                 java.lang.String paType,
                                                 java.lang.String paFrom,
                                                 java.util.Date fromDate,
                                                 java.util.Date toDate,
                                                 java.lang.String rstatus,
                                                 java.lang.String currency,
                                                 java.lang.String accountNumber,
                                                 java.lang.String companyUnitId,
                                                 java.lang.String apNumber,
                                                 java.lang.String apItemStatus)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findPoReceiverItemWithAPListResultsByDate

java.util.Collection<POReceiverItemListResult> findPoReceiverItemWithAPListResultsByDate(java.lang.String recNumber,
                                                                                java.lang.String vendorId,
                                                                                java.lang.String pnLike,
                                                                                java.lang.String paType,
                                                                                java.lang.String paFrom,
                                                                                java.util.Date fromDate,
                                                                                java.util.Date toDate,
                                                                                java.lang.String rstatus,
                                                                                java.lang.String currency,
                                                                                java.lang.String accountNumber,
                                                                                java.lang.String companyUnitId,
                                                                                java.lang.String apNumber,
                                                                                java.lang.String apItemStatus,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getTotalPOReceiverResult

java.util.Collection<TotalByDateResult> getTotalPOReceiverResult(java.lang.String poNumber,
                                                                 java.lang.String project,
                                                                 java.lang.String vendorId,
                                                                 java.lang.String pn,
                                                                 java.lang.String pa,
                                                                 java.lang.String paFrom,
                                                                 java.util.Date fromDate,
                                                                 java.util.Date toDate,
                                                                 java.lang.String status,
                                                                 java.lang.String currency,
                                                                 java.lang.String accountNumber,
                                                                 java.lang.String companyUnitId,
                                                                 java.lang.String[] branchWarehouses)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getPoReceiverByDateSummaryResult

PoReceiverByDateSummaryResult getPoReceiverByDateSummaryResult(java.lang.String vendorId,
                                                               java.lang.String pnLike,
                                                               java.lang.String paType,
                                                               java.util.Date fromDate,
                                                               java.util.Date toDate,
                                                               java.lang.String rstatus)
                                                               throws java.lang.Exception
Throws:
java.lang.Exception

findOpenPOReceiverItemsByPartPK

java.util.Collection<POReceiverItemListResult> findOpenPOReceiverItemsByPartPK(PartPK partPk,
                                                                               int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getOpenPOReceiverItemsCountByPartPK

int getOpenPOReceiverItemsCountByPartPK(PartPK partPk)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findPOReceiverItemsByPartPK

java.util.Collection<POReceiverItemListResult> findPOReceiverItemsByPartPK(PartPK partPk,
                                                                           int firstIndex,
                                                                           int maxLength)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getPOReceiverItemsCountByPartPK

int getPOReceiverItemsCountByPartPK(PartPK partPk)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findPoReceiverItemsByPoNumber

java.util.Collection<POReceiverItemListResult> findPoReceiverItemsByPoNumber(java.lang.String poNumber)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

findPoReceiverItemsByPoNumberWithoutAPorPA

java.util.List<java.lang.String> findPoReceiverItemsByPoNumberWithoutAPorPA(java.lang.String poNumber)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

addWOReceiver

void addWOReceiver(WorkOrderReceiverVO vo)
                   throws java.lang.Exception
Throws:
java.lang.Exception

deleteWOReceiver

void deleteWOReceiver(WorkOrderReceiverVO vo)
                      throws java.lang.Exception
Throws:
java.lang.Exception

updateWOReceiver

void updateWOReceiver(WorkOrderReceiverVO vo)
                      throws java.lang.Exception
Throws:
java.lang.Exception

findAllWorkOrderReceivers

java.util.Collection<WorkOrderReceiverVO> findAllWorkOrderReceivers(int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getAllWorkOrderReceiversCount

int getAllWorkOrderReceiversCount()
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findWorkOrderReceiversByWorkOrderItemPk

java.util.Collection<WorkOrderReceiverVO> findWorkOrderReceiversByWorkOrderItemPk(WorkOrderItemPK woiPk,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderReceiversCountByWorkOrderItemPk

int getWorkOrderReceiversCountByWorkOrderItemPk(WorkOrderItemPK woiPk)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

findWOReceiverByPk

WorkOrderReceiverVO findWOReceiverByPk(java.lang.Long pk)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findWOReceiverItems

java.util.Collection<WOReceiverDetail> findWOReceiverItems(java.lang.String workOrder,
                                                           java.lang.String workOrderItem,
                                                           java.lang.String customerId,
                                                           java.lang.String pn,
                                                           java.lang.String pa,
                                                           java.lang.String partFrom,
                                                           java.util.Date fromDate,
                                                           java.util.Date toDate,
                                                           java.lang.String accountNumber,
                                                           java.lang.String companyUnitId,
                                                           java.lang.String[] branchWarehouses,
                                                           boolean isIncludeNA,
                                                           java.lang.String project,
                                                           int firstIndex,
                                                           int maxLength)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

findWOReceiverItemsTotal

java.util.Collection<WOReceiverDetail> findWOReceiverItemsTotal(java.lang.String workOrder,
                                                                java.lang.String workOrderItem,
                                                                java.lang.String customerId,
                                                                java.lang.String pn,
                                                                java.lang.String pa,
                                                                java.lang.String partFrom,
                                                                java.util.Date fromDate,
                                                                java.util.Date toDate,
                                                                java.lang.String accountNumber,
                                                                java.lang.String companyUnitId,
                                                                java.lang.String[] branchWarehouses,
                                                                boolean isIncludeNA,
                                                                java.lang.String project)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getWOReceiverItemsCount

int getWOReceiverItemsCount(java.lang.String workOrder,
                            java.lang.String workOrderItem,
                            java.lang.String customerId,
                            java.lang.String pn,
                            java.lang.String pa,
                            java.lang.String partFrom,
                            java.util.Date fromDate,
                            java.util.Date toDate,
                            java.lang.String accountNumber,
                            java.lang.String companyUnitId,
                            java.lang.String[] branchWarehouses,
                            boolean isIncludeNA,
                            java.lang.String project)
                            throws java.lang.Exception
Throws:
java.lang.Exception

makeRmaReceiver

java.util.Collection<RMAReceiverListResult> makeRmaReceiver(ReceiverAgent agent)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

updateRMAReceiver

java.lang.String updateRMAReceiver(RMAReceiverVO vo)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

getRMAReceiver

RMAReceiverVO getRMAReceiver(java.lang.String receiverNumber)
                             throws java.lang.Exception
Throws:
java.lang.Exception

getRMAReceiverItemsforRMANumber

java.util.Collection<RMAReceiverItemVO> getRMAReceiverItemsforRMANumber(java.lang.String rmaNumber)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

findRMAReceiverListResultsByRMAReceiverNumber

java.util.Collection<RMAReceiverListResult> findRMAReceiverListResultsByRMAReceiverNumber(java.lang.String rmaRecNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getRMAReceiverListResultsCountByRMAReceiverNumber

int getRMAReceiverListResultsCountByRMAReceiverNumber(java.lang.String rmaRecNumber)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

findRMAReceiverListResultsByCustID

java.util.Collection<RMAReceiverListResult> findRMAReceiverListResultsByCustID(java.lang.String custID,
                                                                               int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getRMAReceiverListResultsCountByCustID

int getRMAReceiverListResultsCountByCustID(java.lang.String custID)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

findRMAReceiverWithoutCMListResults

java.util.Collection<RMAReceiverListResult> findRMAReceiverWithoutCMListResults(java.lang.String rmaRecNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getRMAReceiverWithoutCMListResultsCount

int getRMAReceiverWithoutCMListResultsCount(java.lang.String rmaRecNumber)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

findRMAReceiverItemListResultsByRMAReceiverNumber

java.util.Collection<RMAReceiverItemListResult> findRMAReceiverItemListResultsByRMAReceiverNumber(java.lang.String rmaRecNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getRMAReceiverItemListResultsCountByRMAReceiverNumber

int getRMAReceiverItemListResultsCountByRMAReceiverNumber(java.lang.String rmaRecNumber)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

findRMAReceiverItemListResultsByCustID

java.util.Collection<RMAReceiverItemListResult> findRMAReceiverItemListResultsByCustID(java.lang.String custID,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getRMAReceiverItemListResultsCountByCustID

int getRMAReceiverItemListResultsCountByCustID(java.lang.String custID)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

findRMAReceiverItemListResultsBySONumber

java.util.Collection<RMAReceiverItemListResult> findRMAReceiverItemListResultsBySONumber(java.lang.String soNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getRMAReceiverItemListResultsCountBySONumber

int getRMAReceiverItemListResultsCountBySONumber(java.lang.String soNumber)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findRMAReceiverItemListResultsByPartNumber

java.util.Collection<RMAReceiverItemListResult> findRMAReceiverItemListResultsByPartNumber(java.lang.String partNumber,
                                                                                java.lang.String partType,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getRMAReceiverItemListResultsCountByPartNumber

int getRMAReceiverItemListResultsCountByPartNumber(java.lang.String partNumber,
                                                   java.lang.String partType)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

makeOnloanReceiver

java.util.Collection<OnloanReceiverListResult> makeOnloanReceiver(ReceiverAgent agent)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

updateOnloanReceiver

java.lang.String updateOnloanReceiver(OnloanReceiverVO vo)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

getOnloanReceiver

OnloanReceiverVO getOnloanReceiver(java.lang.String receiverNumber)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

getOnloanReceiversByLn

java.util.Collection<OnloanReceiverListResult> getOnloanReceiversByLn(java.lang.String onLoanNumber)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

isOnloanReceiverExist

boolean isOnloanReceiverExist(java.lang.String receiverNumber)
                              throws java.lang.Exception
Throws:
java.lang.Exception

findOnloanReceiverListResultsByOnloanReceiverNumber

java.util.Collection<OnloanReceiverListResult> findOnloanReceiverListResultsByOnloanReceiverNumber(java.lang.String receiverNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOnloanReceiverListResultsCountByOnloanReceiverNumber

int getOnloanReceiverListResultsCountByOnloanReceiverNumber(java.lang.String receiverNumber)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

findOnloanReceiverListResultsByCustID

java.util.Collection<OnloanReceiverListResult> findOnloanReceiverListResultsByCustID(java.lang.String custID,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOnloanReceiverListResultsCountByCustID

int getOnloanReceiverListResultsCountByCustID(java.lang.String custID)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

findOnloanReceiverListResultsByLnShipperNumber

java.util.Collection<OnloanReceiverListResult> findOnloanReceiverListResultsByLnShipperNumber(java.lang.String lnShipperNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOnloanReceiverListResultsCountByLnShipperNumber

int getOnloanReceiverListResultsCountByLnShipperNumber(java.lang.String lnShipperNumber)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

findOpenOnloanShipperForReceiver

java.util.Collection<LnShipperListResult> findOpenOnloanShipperForReceiver(java.lang.String startWith,
                                                                           int firstIndex,
                                                                           int maxLength)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getOpenOnloanShipperForReceiverCount

int getOpenOnloanShipperForReceiverCount(java.lang.String startWith)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

getOnloanReceivingResult

ReceivingResult getOnloanReceivingResult(java.lang.String lnShipperNumber)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

findOnloanReceiverItemListResultsByOnloanReceiverNumber

java.util.Collection<OnloanReceiverItemListResult> findOnloanReceiverItemListResultsByOnloanReceiverNumber(java.lang.String receiverNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOnloanReceiverItemListResultsCountByOnloanReceiverNumber

int getOnloanReceiverItemListResultsCountByOnloanReceiverNumber(java.lang.String receiverNumber)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findOnloanReceiverItemListResultsByCustID

java.util.Collection<OnloanReceiverItemListResult> findOnloanReceiverItemListResultsByCustID(java.lang.String custID,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOnloanReceiverItemListResultsCountByCustID

int getOnloanReceiverItemListResultsCountByCustID(java.lang.String custID)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

findOnloanReceiverItemListResultsByPartNumber

java.util.Collection<OnloanReceiverItemListResult> findOnloanReceiverItemListResultsByPartNumber(java.lang.String partNumber,
                                                                                java.lang.String partType,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOnloanReceiverItemListResultsCountByPartNumber

int getOnloanReceiverItemListResultsCountByPartNumber(java.lang.String partNumber,
                                                      java.lang.String partType)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

findOnloanReceiverItemListResultsByLnShipperNumber

java.util.Collection<OnloanReceiverItemListResult> findOnloanReceiverItemListResultsByLnShipperNumber(java.lang.String lnShipperNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOnloanReceiverItemListResultsCountByLnShipperNumber

int getOnloanReceiverItemListResultsCountByLnShipperNumber(java.lang.String lnShipperNumber)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

findOnloanReceiverItemListResultsByLnNumber

java.util.Collection<OnloanReceiverItemListResult> findOnloanReceiverItemListResultsByLnNumber(java.lang.String loanNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

addProformaInvoice

java.lang.String addProformaInvoice(java.lang.String customerId)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

addProformaInvoice

ProformaInvoiceVO addProformaInvoice(ProformaInvoiceVO vo)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

deleteProformaInvoice

void deleteProformaInvoice(ProformaInvoiceVO vo)
                           throws java.lang.Exception
Throws:
java.lang.Exception

updateProformaInvoice

ProformaInvoiceVO updateProformaInvoice(ProformaInvoiceVO vo)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

refreshProformaInvoice

ProformaInvoiceVO refreshProformaInvoice(ProformaInvoiceVO vo)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

finishProformaShipper

java.lang.String finishProformaShipper(ProformaInvoiceVO pfVo,
                                       boolean deleteZero,
                                       boolean withoutBoxInfo)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findAllProformaInvoices

java.util.Collection<ProformaInvoiceListResult> findAllProformaInvoices(int firstIndex,
                                                                        int maxLength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getAllProformaInvoicesCount

int getAllProformaInvoicesCount()
                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllNotClosedPFNumbers

java.util.Collection<java.lang.String> getAllNotClosedPFNumbers()
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

checkCloseProformaInvoice

ProformaInvoiceListResult checkCloseProformaInvoice(java.lang.String pfNum)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

closeProformaInvoices

java.util.Collection<java.lang.String> closeProformaInvoices(java.util.ArrayList<java.lang.String> pfNums)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

findAllNotClosedProformaInvoices

java.util.Collection<ProformaInvoiceListResult> findAllNotClosedProformaInvoices(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllNotClosedProformaInvoicesCount

int getAllNotClosedProformaInvoicesCount()
                                         throws java.lang.Exception
Throws:
java.lang.Exception

findPackingBoxItemListResultsByPfNumbeAndPBNumber

java.util.Collection<PackingBoxItemListResult> findPackingBoxItemListResultsByPfNumbeAndPBNumber(java.lang.String pfNumberExp,
                                                                                int packingBoxNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPackingBoxItemListResultsCountByPfNumbeAndPBNumber

int getPackingBoxItemListResultsCountByPfNumbeAndPBNumber(java.lang.String pfNumberExp,
                                                          int packingBoxNumber)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

findPackingBoxItemListResultsByPfNumbe

java.util.Collection<PackingBoxItemListResult> findPackingBoxItemListResultsByPfNumbe(java.lang.String pfNumberExp,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPackingBoxItemListResultsCountByPfNumbe

int getPackingBoxItemListResultsCountByPfNumbe(java.lang.String pfNumberExp)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

findProformaInvoiceListResultsByPfNumber

java.util.Collection<ProformaInvoiceListResult> findProformaInvoiceListResultsByPfNumber(java.lang.String pfNumberExp,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getProformaInvoiceListResultsCountByPfNumber

int getProformaInvoiceListResultsCountByPfNumber(java.lang.String pfNumberExp)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findProformaInvoiceListResultsByCustomerId

java.util.Collection<ProformaInvoiceListResult> findProformaInvoiceListResultsByCustomerId(java.lang.String customerId,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getProformaInvoiceListResultsCountByCustomerId

int getProformaInvoiceListResultsCountByCustomerId(java.lang.String customerId)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

findOpenProformaInvoiceListResults

java.util.Collection<ProformaInvoiceListResult> findOpenProformaInvoiceListResults(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOpenProformaInvoiceListResultsCountByPfNumber

int getOpenProformaInvoiceListResultsCountByPfNumber()
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

findProformaInvoiceItems

java.util.Collection<ProformaInvoiceItemListResult> findProformaInvoiceItems(java.util.Date from,
                                                                             java.util.Date to,
                                                                             java.lang.String pfNumberLike,
                                                                             java.lang.String pnLike,
                                                                             java.lang.String paLike,
                                                                             java.lang.String soNumberLike,
                                                                             java.lang.String customerIdLike,
                                                                             java.lang.String status,
                                                                             int firstIndex,
                                                                             int maxLength)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getProformaInvoiceItemsCount

int getProformaInvoiceItemsCount(java.util.Date from,
                                 java.util.Date to,
                                 java.lang.String pfNumberLike,
                                 java.lang.String pnLike,
                                 java.lang.String paLike,
                                 java.lang.String soNumberLike,
                                 java.lang.String customerIdLike,
                                 java.lang.String status)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

getPFInvoiceByPFNumber

ProformaInvoiceVO getPFInvoiceByPFNumber(java.lang.String pfNumber)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

isPFSOHoldByPFNumber

boolean isPFSOHoldByPFNumber(java.lang.String pfNumber)
                             throws java.lang.Exception
Throws:
java.lang.Exception

getProformaInvoiceListResults

java.util.Collection<ProformaInvoiceListResult> getProformaInvoiceListResults(java.util.ArrayList<java.lang.String> pfnums)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

initPackingBoxItemVO

PackingBoxItemVO initPackingBoxItemVO(PackingBoxPK boxPk,
                                      SalesOrderItemPK itemPk,
                                      java.math.BigDecimal qty)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findPackingBoxItem

java.util.Collection<PackingBoxItemVO> findPackingBoxItem(java.lang.String pfNumber,
                                                          PartPK partPk,
                                                          java.lang.String partFrom)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

removeProformaInvoiceItem

void removeProformaInvoiceItem(ProformaInvoiceItemPK itemPk)
                               throws java.lang.Exception
Throws:
java.lang.Exception

addPackingBox

PackingBoxPK addPackingBox(java.lang.String pfNumber)
                           throws java.lang.Exception
Throws:
java.lang.Exception

updatePackingBox

PackingBoxVO updatePackingBox(PackingBoxVO vo)
                              throws java.lang.Exception
Throws:
java.lang.Exception

addSalesOrderItemToPackingBox

PackingBoxPK addSalesOrderItemToPackingBox(PackingBoxSalesOrderItemAgent agent)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

addSalesOrderToPackingBox

PackingBoxPK addSalesOrderToPackingBox(java.util.ArrayList list)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

removeSalesOrderItemToPackingBox

PackingBoxPK removeSalesOrderItemToPackingBox(PackingBoxItemPK pk)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

updatePackingBoxItem

PackingBoxItemVO updatePackingBoxItem(PackingBoxItemPK pk,
                                      java.util.Map newQty)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

deletePackingBox

void deletePackingBox(PackingBoxPK pk)
                      throws java.lang.Exception
Throws:
java.lang.Exception

updatePackingBoxItems

PackingBoxVO updatePackingBoxItems(java.util.HashMap map,
                                   PackingBoxPK pk)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

getNextPackingBoxNumber

java.lang.Integer getNextPackingBoxNumber(ProformaInvoiceVO vo)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

getAllPackingBoxsCount

int getAllPackingBoxsCount()
                           throws java.lang.Exception
Throws:
java.lang.Exception

findAllPackingBox

java.util.Collection<PackingBoxVO> findAllPackingBox(int firstIndex,
                                                     int length)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getPackingBoxByPk

PackingBoxVO getPackingBoxByPk(PackingBoxPK pk)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findPackingBoxesByPfNumber

java.util.Collection<PackingBoxVO> findPackingBoxesByPfNumber(java.lang.String pfNumberRegex,
                                                              int firstIndex,
                                                              int maxLength)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getPackingBoxesCountByPfNumber

int getPackingBoxesCountByPfNumber(java.lang.String pfNumberRegex)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

updateToolOnhandDetail

java.util.Collection<ToolOnhandVO> updateToolOnhandDetail(java.util.HashSet onhandDetailVo,
                                                          PartPK pk)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

addPartOnhand

void addPartOnhand(PartOnhandVO vo)
                   throws java.lang.Exception
Throws:
java.lang.Exception

updatePartOnhand

void updatePartOnhand(PartOnhandVO vo)
                      throws java.lang.Exception
Throws:
java.lang.Exception

deletePartOnhand

void deletePartOnhand(PartOnhandVO vo)
                      throws java.lang.Exception
Throws:
java.lang.Exception

addNewLocation

PartOnhandPK addNewLocation(BB2Part part,
                            java.lang.String location,
                            java.lang.String warehouse)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findAllPartOnhand

java.util.Collection<PartOnhandVO> findAllPartOnhand(int firstIndex,
                                                     int maxLength)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getAllPartOnhandCount

int getAllPartOnhandCount()
                          throws java.lang.Exception
Throws:
java.lang.Exception

findPartOnhandByPk

PartOnhandVO findPartOnhandByPk(PartOnhandPK pk)
                                throws java.lang.Exception
Throws:
java.lang.Exception

getPartOnhandDetailInfoByPartPk

PartWithOnhandDetailInfoResult getPartOnhandDetailInfoByPartPk(BB2Part part)
                                                               throws java.lang.Exception
Throws:
java.lang.Exception

subtractPartOnOder

void subtractPartOnOder(PurchaseOrderItemVO item)
                        throws java.lang.Exception
Throws:
java.lang.Exception

subtractToolOnOder

void subtractToolOnOder(PurchaseOrderItemVO item)
                        throws java.lang.Exception
Throws:
java.lang.Exception

addPartOnOder

void addPartOnOder(PurchaseOrderItemVO item)
                   throws java.lang.Exception
Throws:
java.lang.Exception

addToolOnOder

void addToolOnOder(PurchaseOrderItemVO item)
                   throws java.lang.Exception
Throws:
java.lang.Exception

addOnLoan

OnLoanVO addOnLoan(OnLoanVO vo)
                   throws java.lang.Exception
Throws:
java.lang.Exception

updateOnLoan

java.lang.String updateOnLoan(OnLoanVO vo)
                              throws java.lang.Exception
Throws:
java.lang.Exception

initOnLoanItem

OnLoanItemVO initOnLoanItem(OnLoanVO onloanVo,
                            PartPK partPk,
                            java.math.BigDecimal quantity,
                            boolean isTool)
                            throws java.lang.Exception
Throws:
java.lang.Exception

reviewOnLoan

java.lang.String reviewOnLoan(OnLoanVO loanVo)
                              throws java.lang.Exception
Throws:
java.lang.Exception

getOnLoanByLoanNumber

OnLoanVO getOnLoanByLoanNumber(java.lang.String loanNumber)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findAllOnLoans

java.util.Collection<OnLoanListResult> findAllOnLoans(int firstIndex,
                                                      int maxLength)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getAllOnLoanCount

int getAllOnLoanCount()
                      throws java.lang.Exception
Throws:
java.lang.Exception

findCheckList

java.util.Collection<OnLoanListResult> findCheckList(int firstIndex,
                                                     int maxLength)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getCheckListCount

int getCheckListCount()
                      throws java.lang.Exception
Throws:
java.lang.Exception

setOnLoanItemReferenceDocOne

void setOnLoanItemReferenceDocOne(OnLoanItemPK pk,
                                  java.lang.String referenceDoc)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

setOnLoanItemReferenceDocTwo

void setOnLoanItemReferenceDocTwo(OnLoanItemPK pk,
                                  java.lang.String referenceDoc)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

clearOnLoanItemReferenceDocOne

void clearOnLoanItemReferenceDocOne(java.lang.String referenceDoc)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

clearOnLoanItemReferenceDocTwo

void clearOnLoanItemReferenceDocTwo(java.lang.String referenceDoc)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findLoanItemByPartPk

java.util.Collection<OnLoanItemListResult> findLoanItemByPartPk(PartPK pk,
                                                                java.lang.String partFromType,
                                                                int firstIndex,
                                                                int maxLength)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getLoanItemByPartPkCount

int getLoanItemByPartPkCount(PartPK pk,
                             java.lang.String partFromType)
                             throws java.lang.Exception
Throws:
java.lang.Exception

findOnLoansByLoanNumber

java.util.Collection<OnLoanListResult> findOnLoansByLoanNumber(java.lang.String loanNumberExp,
                                                               int firstIndex,
                                                               int maxLength)
                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getOnLoansByLoanNumberCount

int getOnLoansByLoanNumberCount(java.lang.String loanNumberExp)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findOpenOnLoansForShipper

java.util.Collection<OnLoanListResult> findOpenOnLoansForShipper(java.lang.String loanNumberExp,
                                                                 int firstIndex,
                                                                 int maxLength)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getOpenOnLoansForShipperCount

int getOpenOnLoansForShipperCount(java.lang.String loanNumberExp)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findOnLoansByPoNumber

java.util.Collection<OnLoanListResult> findOnLoansByPoNumber(java.lang.String poNumberExp,
                                                             int firstIndex,
                                                             int maxLength)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getOnLoansByPoNumberCount

int getOnLoansByPoNumberCount(java.lang.String poNumberExp)
                              throws java.lang.Exception
Throws:
java.lang.Exception

isOnLoanItemExist

boolean isOnLoanItemExist(OnLoanItemPK pk)
                          throws java.lang.Exception
Throws:
java.lang.Exception

findOnLoanItemsByDate

java.util.Collection<OnLoanItemListResult> findOnLoanItemsByDate(PartPK partPk,
                                                                 java.lang.String customerId,
                                                                 java.lang.String salesMan,
                                                                 java.lang.String status,
                                                                 boolean isDeliveryDate,
                                                                 java.util.Date fromDate,
                                                                 java.util.Date toDate,
                                                                 int firstIndex,
                                                                 int maxLength)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getOnLoanItemsCountByDate

int getOnLoanItemsCountByDate(PartPK partPk,
                              java.lang.String customerId,
                              java.lang.String salesMan,
                              java.lang.String status,
                              boolean isDeliveryDate,
                              java.util.Date fromDate,
                              java.util.Date toDate)
                              throws java.lang.Exception
Throws:
java.lang.Exception

findAllOnLoanByAddressId

java.util.Collection<OnLoanItemListResult> findAllOnLoanByAddressId(java.lang.String addressId,
                                                                    int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getAllOnLoanCountByAddressId

int getAllOnLoanCountByAddressId(java.lang.String addressId)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findAllOpenOnLoanByAddressId

java.util.Collection<OnLoanItemListResult> findAllOpenOnLoanByAddressId(java.lang.String addressId,
                                                                        int firstIndex,
                                                                        int maxLength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getAllOpenOnLoanCountByAddressId

int getAllOpenOnLoanCountByAddressId(java.lang.String addressId)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findAllPastDueLoanByAddressId

java.util.Collection<OnLoanItemListResult> findAllPastDueLoanByAddressId(java.lang.String addressId,
                                                                         int firstIndex,
                                                                         int maxLength)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getAllPastDueLoanCountByAddressId

int getAllPastDueLoanCountByAddressId(java.lang.String addressId)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findAllOpenLoan

java.util.Collection<OnLoanItemListResult> findAllOpenLoan(int firstIndex,
                                                           int maxLength)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getAllOpenLoanCount

int getAllOpenLoanCount()
                        throws java.lang.Exception
Throws:
java.lang.Exception

findAllDueLoan

java.util.Collection<OnLoanItemListResult> findAllDueLoan(int firstIndex,
                                                          int maxLength)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getAllDueLoanCount

int getAllDueLoanCount()
                       throws java.lang.Exception
Throws:
java.lang.Exception

addOnloanControl

OnloanReviewVO addOnloanControl(java.lang.String employeeId)
                                throws java.lang.Exception
Throws:
java.lang.Exception

updateOnloanControl

OnloanReviewVO updateOnloanControl(OnloanReviewVO vo)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

deleteOnloanControl

void deleteOnloanControl(java.lang.String employeeId)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findAllOnloanControl

java.util.Collection<OnloanReviewVO> findAllOnloanControl(int firstIndex,
                                                          int maxLength)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getAllOnloanControlCount

int getAllOnloanControlCount()
                             throws java.lang.Exception
Throws:
java.lang.Exception

getOnloanControlByEmployeeId

OnloanReviewVO getOnloanControlByEmployeeId(java.lang.String employeeId)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

getOnloanControlByEmoloyeeTrueName

OnloanReviewVO getOnloanControlByEmoloyeeTrueName(java.lang.String emoloyeeTrueName)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

findOnloanControlByUserTrueNameLike

java.util.Collection<OnloanReviewVO> findOnloanControlByUserTrueNameLike(java.lang.String userTrueNameLike,
                                                                         int firstIndex,
                                                                         int maxLength)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getOnloanControlCountByUserTrueNameLike

int getOnloanControlCountByUserTrueNameLike(java.lang.String userTrueNameLike)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

isOnloanControlRecorded

boolean isOnloanControlRecorded(java.lang.String employeeId)
                                throws java.lang.Exception
Throws:
java.lang.Exception

adjustInventory

PartWithOnhandDetailInfoResult adjustInventory(java.util.ArrayList partOnhandWithAverageCostList,
                                               BB2Part part,
                                               java.lang.String comments)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

batchMoveLocation

void batchMoveLocation(java.util.Map<PartOnhandPK,java.math.BigDecimal> data,
                       java.lang.String warehousePrefix)
                       throws java.lang.Exception
Throws:
java.lang.Exception

getInventoryAdjustmentDetail

InventoryAdjustmentDetailResult getInventoryAdjustmentDetail(BB2Part part)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getInventoryAdjustmentListResult

InventoryAdjustmentListResult getInventoryAdjustmentListResult(BB2Part part)
                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getInventoryAdjustment

InventoryAdjustmentVO getInventoryAdjustment(java.lang.Long pk)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findInventoryAdjustmentRecords

java.util.Collection<InventoryAdjustmentListResult> findInventoryAdjustmentRecords(BB2Part part,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getInventoryAdjustmentRecordsCount

int getInventoryAdjustmentRecordsCount(BB2Part part)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findInventoryAdjustmentRecords

java.util.Collection<InventoryAdjustmentListResult> findInventoryAdjustmentRecords(java.lang.String partNumber,
                                                                                java.lang.String partType,
                                                                                java.lang.String partFrom,
                                                                                java.lang.String countedBy,
                                                                                java.util.Date fromDate,
                                                                                java.util.Date toDate,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getInventoryAdjustmentRecordsCount

int getInventoryAdjustmentRecordsCount(java.lang.String partNumber,
                                       java.lang.String partType,
                                       java.lang.String partFrom,
                                       java.lang.String countedBy,
                                       java.util.Date fromDate,
                                       java.util.Date toDate)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

getPartWithWipQtyTotal

Money getPartWithWipQtyTotal()
                             throws java.lang.Exception
Throws:
java.lang.Exception

findPartWithWipQtyListResults

java.util.Collection<PartWithWipQtyListResult> findPartWithWipQtyListResults(boolean includesDetails,
                                                                             int firstIndex,
                                                                             int length)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getTotalPartWithWipQtyCost

PartWithWipQtyListResult getTotalPartWithWipQtyCost()
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getPartWithWipQtyListResultsCount

int getPartWithWipQtyListResultsCount()
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findPartWithSipQtyListResults

java.util.Collection<PartWithSipQtyListResult> findPartWithSipQtyListResults(boolean includesDetails,
                                                                             int firstIndex,
                                                                             int length)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getPartWithSipQtyListResultsCount

int getPartWithSipQtyListResultsCount()
                                      throws java.lang.Exception
Throws:
java.lang.Exception

getPartWithSipQtyTotal

PartWithSipQtyListResult getPartWithSipQtyTotal()
                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPartWithSITQtyTotal

PartWithSITQtyListResult getPartWithSITQtyTotal(java.lang.String pnExp,
                                                java.lang.String paExp,
                                                boolean isTool)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPartWithSITQtyListResultsCount

int getPartWithSITQtyListResultsCount(java.lang.String pnExp,
                                      java.lang.String paExp,
                                      boolean isTool)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findPartWithSITQtyListResults

java.util.Collection<PartWithSITQtyListResult> findPartWithSITQtyListResults(java.lang.String pnExp,
                                                                             java.lang.String paExp,
                                                                             boolean isTool,
                                                                             boolean includesRefDetails,
                                                                             int firstIndex,
                                                                             int length)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

findPartWithQAQtyListResults

java.util.Collection<PartWithQAQtyListResult> findPartWithQAQtyListResults(boolean includesDetails,
                                                                           int firstIndex,
                                                                           int length)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getPartWithQAQtyListResultsCount

int getPartWithQAQtyListResultsCount()
                                     throws java.lang.Exception
Throws:
java.lang.Exception

getPartWithQAQtyTotal

PartWithQAQtyListResult getPartWithQAQtyTotal()
                                              throws java.lang.Exception
Throws:
java.lang.Exception

findPartOnLoanQtyListResults

java.util.Collection<PartWithOnLoanQtyListResult> findPartOnLoanQtyListResults(int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getPartOnLoanQtyListResultsCount

int getPartOnLoanQtyListResultsCount()
                                     throws java.lang.Exception
Throws:
java.lang.Exception

getPartOnLoanTotalAmount

PartWithOnLoanQtyListResult getPartOnLoanTotalAmount()
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

findPartOnOrderQtyListResults

java.util.Collection<PartWithQtyListResult> findPartOnOrderQtyListResults(int firstIndex,
                                                                          int maxLength)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getPartOnOrderQtyListResultsCount

int getPartOnOrderQtyListResultsCount()
                                      throws java.lang.Exception
Throws:
java.lang.Exception

getPartOnOrderTotalAmount

BB2DoubleCost getPartOnOrderTotalAmount()
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findPartOnDemandQtyListResults

java.util.Collection<PartWithQtyListResult> findPartOnDemandQtyListResults(int firstIndex,
                                                                           int maxLength)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getPartOnDemandQtyListResultsCount

int getPartOnDemandQtyListResultsCount()
                                       throws java.lang.Exception
Throws:
java.lang.Exception

getPartOnDemandTotalAmount

BB2DoubleCost getPartOnDemandTotalAmount()
                                         throws java.lang.Exception
Throws:
java.lang.Exception

findInventoryListResultWithMinAndMaxQty

java.util.Collection<InventoryListResult> findInventoryListResultWithMinAndMaxQty(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getInventoryListResultWithMinAndMaxQtyCount

int getInventoryListResultWithMinAndMaxQtyCount()
                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPartWithMinQtyTotalAmount

BB2DoubleCost getPartWithMinQtyTotalAmount()
                                           throws java.lang.Exception
Throws:
java.lang.Exception

getPartWithMaxQtyTotalAmount

BB2DoubleCost getPartWithMaxQtyTotalAmount()
                                           throws java.lang.Exception
Throws:
java.lang.Exception

findPartInWipForIDListResultsByVendorID

java.util.Collection<PartInWipForIDListResult> findPartInWipForIDListResultsByVendorID(java.lang.String woLike,
                                                                                java.lang.String pnLike,
                                                                                java.lang.String partType,
                                                                                java.lang.String vendorIdLike,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPartInWipForIDListResultsCountByVendorID

int getPartInWipForIDListResultsCountByVendorID(java.lang.String woLike,
                                                java.lang.String pnLike,
                                                java.lang.String partType,
                                                java.lang.String vendorIdLike)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPartInWipForIDListResultsTotalByVendorID

PartInWipForIDListResult getPartInWipForIDListResultsTotalByVendorID(java.lang.String woLike,
                                                                     java.lang.String pnLike,
                                                                     java.lang.String partType,
                                                                     java.lang.String vendorIdLike)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getPartWithExcessiveInventoryTotal

PartWithExcessiveInventoryListResult getPartWithExcessiveInventoryTotal(boolean addMaxQty)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

findPartWithExcessiveInventoryListResults

java.util.Collection<PartWithExcessiveInventoryListResult> findPartWithExcessiveInventoryListResults(boolean addMaxQty,
                                                                                int firstIndex,
                                                                                int length)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPartWithExcessiveInventoryListResultsCount

int getPartWithExcessiveInventoryListResultsCount(boolean addMaxQty)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

findPartWithWipQtyListResults

java.util.Collection<PartWithWipQtyListResult> findPartWithWipQtyListResults(java.lang.String pnExp,
                                                                             java.lang.String paExp,
                                                                             int firstIndex,
                                                                             int length)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getPartWithWipQtyListResultsCount

int getPartWithWipQtyListResultsCount(java.lang.String pnExp,
                                      java.lang.String paExp)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findPartWithExcessiveInventoryListResults

java.util.Collection<PartWithExcessiveInventoryListResult> findPartWithExcessiveInventoryListResults(java.lang.String pnExp,
                                                                                java.lang.String paExp,
                                                                                int firstIndex,
                                                                                int length)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPartWithExcessiveInventoryListResultsCount

int getPartWithExcessiveInventoryListResultsCount(java.lang.String pnExp,
                                                  java.lang.String paExp)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

findToolWithWipQtyListResults

java.util.Collection<PartWithWipQtyListResult> findToolWithWipQtyListResults(java.lang.String pnExp,
                                                                             java.lang.String paExp,
                                                                             int firstIndex,
                                                                             int length)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getToolWithWipQtyListResultsCount

int getToolWithWipQtyListResultsCount(java.lang.String pnExp,
                                      java.lang.String paExp)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findToolWithExcessiveInventoryListResults

java.util.Collection<PartWithExcessiveInventoryListResult> findToolWithExcessiveInventoryListResults(java.lang.String pnExp,
                                                                                java.lang.String paExp,
                                                                                int firstIndex,
                                                                                int length)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getToolWithExcessiveInventoryListResultsCount

int getToolWithExcessiveInventoryListResultsCount(java.lang.String pnExp,
                                                  java.lang.String paExp)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

findLogInventoryByPart

java.util.Collection<LogInventoryListResult> findLogInventoryByPart(BB2Part part,
                                                                    int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getLogInventoryCountByPart

int getLogInventoryCountByPart(BB2Part part)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findLogInventoryByPartLike

java.util.Collection<LogInventoryListResult> findLogInventoryByPartLike(java.lang.String partNumberLike,
                                                                        java.lang.String partType,
                                                                        java.lang.String partFrom,
                                                                        java.lang.String operator,
                                                                        java.lang.String location,
                                                                        java.util.Date fromDate,
                                                                        java.util.Date toDate,
                                                                        boolean listOtherLocationsForSamePart,
                                                                        int firstIndex,
                                                                        int maxLength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getLogInventoryCountByPartLike

int getLogInventoryCountByPartLike(java.lang.String partNumberLike,
                                   java.lang.String partType,
                                   java.lang.String partFrom,
                                   java.lang.String operator,
                                   java.lang.String location,
                                   java.util.Date fromDate,
                                   java.util.Date toDate,
                                   boolean islistOtherLocations)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findLogInventorySimpleByPartLike

java.util.Collection<LogInventoryListResult> findLogInventorySimpleByPartLike(java.lang.String partNumberLike,
                                                                              java.lang.String partType,
                                                                              java.lang.String partFrom,
                                                                              java.util.Date fromDate,
                                                                              java.util.Date toDate,
                                                                              int firstIndex,
                                                                              int maxLength)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getLogInventoryCountSimpleByPartLike

int getLogInventoryCountSimpleByPartLike(java.lang.String partNumberLike,
                                         java.lang.String partType,
                                         java.lang.String partFrom,
                                         java.util.Date fromDate,
                                         java.util.Date toDate)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

addLogInventory

LogInventoryVO addLogInventory(LogInventoryVO vo)
                               throws java.lang.Exception
Throws:
java.lang.Exception

deleteLogInventory

void deleteLogInventory(LogInventoryVO vo)
                        throws java.lang.Exception
Throws:
java.lang.Exception

updateLogInventory

void updateLogInventory(LogInventoryVO vo)
                        throws java.lang.Exception
Throws:
java.lang.Exception

getAllLogInventoryCount

int getAllLogInventoryCount()
                            throws java.lang.Exception
Throws:
java.lang.Exception

findAllLogInventory

java.util.Collection<LogInventoryListResult> findAllLogInventory(int firstIndex,
                                                                 int maxLength)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getLogInventoryByPk

LogInventoryVO getLogInventoryByPk(java.lang.Long logItemNumber)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

getBomPickList

BomPickListResult getBomPickList(BillPK pk,
                                 java.math.BigDecimal qty)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

getToolListsPickList

BomPickListResult getToolListsPickList(BillPK pk,
                                       java.math.BigDecimal qty)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

getWoItemPickListResult

WoItemPickListResult getWoItemPickListResult(WorkOrderItemPK itemPk,
                                             java.math.BigDecimal qty,
                                             java.lang.String locationsPrefix)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findWoItemPickListResultsByVendorId

java.util.Collection<WoItemPickListResult> findWoItemPickListResultsByVendorId(java.lang.String vendorId)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

findWoItemPickListResultsByDate

java.util.Collection<WoItemPickListResult> findWoItemPickListResultsByDate(java.lang.String dateType,
                                                                           java.util.Date fromDate,
                                                                           java.util.Date toDate,
                                                                           java.lang.String partNumberLike,
                                                                           java.lang.String partType,
                                                                           java.lang.String vendorId)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getSoPickListResult

SoPickListResult getSoPickListResult(java.lang.String salesOrderNumber)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

addRefdocTwo

RefdocVO addRefdocTwo(ShipperItemPK shItemPk,
                      java.lang.String orderNumber,
                      java.lang.String itemNumber)
                      throws java.lang.Exception
Throws:
java.lang.Exception

addRefdocTwo

RefdocVO addRefdocTwo(ReceiverItemPK rnItemPk,
                      java.lang.String orderNumber,
                      java.lang.String itemNumber)
                      throws java.lang.Exception
Throws:
java.lang.Exception

updateRefdocTwo

RefdocVO updateRefdocTwo(RefdocVO vo)
                         throws java.lang.Exception
Throws:
java.lang.Exception

deleteRefdocTwo

void deleteRefdocTwo(BB2RefdocPK pk)
                     throws java.lang.Exception
Throws:
java.lang.Exception

findPackingBoxSalesOrderItemResults

java.util.Collection<PackingBoxSalesOrderItemResult> findPackingBoxSalesOrderItemResults(java.lang.String soNumber)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findPartOnHandByLocation

java.util.Collection<PartOnhandVO> findPartOnHandByLocation(java.lang.String location)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

findPartOnhandResultsByLocate

java.util.Collection<PartOnhandResult> findPartOnhandResultsByLocate(java.lang.String locate,
                                                                     java.lang.String partNumber,
                                                                     java.lang.String partType,
                                                                     java.lang.String partFrom,
                                                                     boolean listZeroOnhand,
                                                                     boolean listOtherLocationsForSamePart,
                                                                     int firstIndex,
                                                                     int maxLength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

findPartOnhandTotalResultsByLocate

PartOnhandResult findPartOnhandTotalResultsByLocate(java.lang.String locate,
                                                    java.lang.String partNumber,
                                                    java.lang.String partType,
                                                    java.lang.String partFrom,
                                                    boolean listZeroOnhand)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getPartOnhandResultsCountByLocate

int getPartOnhandResultsCountByLocate(java.lang.String locate,
                                      java.lang.String partNumber,
                                      java.lang.String partType,
                                      java.lang.String partFrom,
                                      boolean listZeroOnhand)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findNegativePartOnhandResults

java.util.Collection<PartOnhandResult> findNegativePartOnhandResults(java.lang.String pn1,
                                                                     java.lang.String pn2,
                                                                     java.lang.String pnType,
                                                                     boolean listOtherLocationsForSamePart,
                                                                     int firstIndex,
                                                                     int maxLength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getNegativePartOnhandResultsCount

int getNegativePartOnhandResultsCount(java.lang.String pn1,
                                      java.lang.String pn2,
                                      java.lang.String pnType)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findInventoryListResultOnlyWithMinQty

java.util.Collection<InventoryListResult> findInventoryListResultOnlyWithMinQty(java.lang.String productCode,
                                                                                java.lang.String commodityCode,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getInventoryListResultCountOnlyWithMinQty

int getInventoryListResultCountOnlyWithMinQty(java.lang.String productCode,
                                              java.lang.String commodityCode)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

findInventoryListResultGTMaxQty

java.util.Collection<InventoryListResult> findInventoryListResultGTMaxQty(java.lang.String productCode,
                                                                          java.lang.String commodityCode,
                                                                          int firstIndex,
                                                                          int maxLength)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getInventoryListResultGTMaxQtyCount

int getInventoryListResultGTMaxQtyCount(java.lang.String productCode,
                                        java.lang.String commodityCode)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findInventoryListResults

java.util.Collection<InventoryListResult> findInventoryListResults(boolean showOnhandPartsOnly,
                                                                   boolean showInWipOnly,
                                                                   boolean showInSipOnly,
                                                                   boolean showInQaOnly,
                                                                   java.lang.String descriptionLike,
                                                                   java.lang.String pnFrom,
                                                                   java.lang.String pnTo,
                                                                   java.lang.String includePart,
                                                                   java.lang.String partType,
                                                                   java.lang.String partComeFrom,
                                                                   java.lang.String comCodeLike,
                                                                   java.lang.String languageCode,
                                                                   java.lang.String modelNumberLike,
                                                                   java.lang.String productCode,
                                                                   int firstIndex,
                                                                   int maxLength)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getInventoryListResultsCount

int getInventoryListResultsCount(boolean showOnhandPartsOnly,
                                 boolean showInWipOnly,
                                 boolean showInSipOnly,
                                 boolean showInQaOnly,
                                 java.lang.String descriptionLike,
                                 java.lang.String pnFrom,
                                 java.lang.String pnTo,
                                 java.lang.String includePart,
                                 java.lang.String partType,
                                 java.lang.String partComeFrom,
                                 java.lang.String comCodeLike,
                                 java.lang.String languageCode,
                                 java.lang.String modelNumberLike,
                                 java.lang.String productCode)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findInventoryListResultsByCommodityCode

java.util.Collection<InventoryListResult> findInventoryListResultsByCommodityCode(java.lang.String pnLike,
                                                                                java.lang.String partType,
                                                                                java.lang.String comCodeLike,
                                                                                java.lang.String buyercode,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getInventoryListResultsCountByCommodityCode

int getInventoryListResultsCountByCommodityCode(java.lang.String pnLike,
                                                java.lang.String partType,
                                                java.lang.String comCodeLike,
                                                java.lang.String buyercode)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

findInventoryCycleResults

java.util.Collection<InventoryCycleResult> findInventoryCycleResults(java.lang.String select,
                                                                     int firstIndex,
                                                                     int maxLength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getInventoryCycleResults

int getInventoryCycleResults(java.lang.String select)
                             throws java.lang.Exception
Throws:
java.lang.Exception

getPartIssueTotalResult

PartIssueTotalResult getPartIssueTotalResult(java.util.Date from,
                                             java.util.Date to,
                                             java.lang.String id,
                                             java.lang.String woNumber,
                                             java.lang.String woItemNumber,
                                             java.lang.String relatedDoc,
                                             java.lang.String picker,
                                             java.lang.String pnLike,
                                             java.lang.String paLike,
                                             java.lang.String orderNumber,
                                             java.lang.String project,
                                             java.lang.String[] branchWarehouses)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findPartIssuedByDate

java.util.Collection<PartIssuedListResult> findPartIssuedByDate(java.util.Date from,
                                                                java.util.Date to,
                                                                java.lang.String id,
                                                                java.lang.String woNumber,
                                                                java.lang.String woItemNumber,
                                                                java.lang.String relatedDoc,
                                                                java.lang.String picker,
                                                                java.lang.String pnLike,
                                                                java.lang.String paLike,
                                                                java.lang.String orderNumber,
                                                                java.lang.String project,
                                                                boolean showCurrentOnhand,
                                                                java.lang.String[] branchWarehouses,
                                                                int firstIndex,
                                                                int maxLength)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPartIssuedCountByDate

int getPartIssuedCountByDate(java.util.Date from,
                             java.util.Date to,
                             java.lang.String id,
                             java.lang.String woNumber,
                             java.lang.String woItemNumber,
                             java.lang.String relatedDoc,
                             java.lang.String picker,
                             java.lang.String pnLike,
                             java.lang.String paLike,
                             java.lang.String orderNumber,
                             java.lang.String project,
                             java.lang.String[] branchWarehouses)
                             throws java.lang.Exception
Throws:
java.lang.Exception

findWorkOrderIssuedOrderList

java.util.Collection<WorkOrderIssuedOrderListResult> findWorkOrderIssuedOrderList(WorkOrderItemPK pk)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderIssuedOrderCount

int getWorkOrderIssuedOrderCount(WorkOrderItemPK pk)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

getInventoryNotUsedCostInMonths

InventoryNotUsedTotal getInventoryNotUsedCostInMonths(int months)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

findInventoryNotUsedInMonthsResults

java.util.Collection<InventoryNotUsedInMonthsResult> findInventoryNotUsedInMonthsResults(int months,
                                                                                boolean showZeroOnhandItems,
                                                                                int firstIndex,
                                                                                int maxlenth)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getInventoryNotUsedInMonthsResultsCount

int getInventoryNotUsedInMonthsResultsCount(int months,
                                            boolean showZeroOnhandItems)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

getInventoryNotUsedCostInMonths

InventoryNotUsedTotal getInventoryNotUsedCostInMonths(java.util.Date fromDate)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

findInventoryNotUsedInMonthsResults

java.util.Collection<InventoryNotUsedInMonthsResult> findInventoryNotUsedInMonthsResults(java.util.Date fromDate,
                                                                                boolean showZeroOnhandItems,
                                                                                int firstIndex,
                                                                                int maxlenth)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getInventoryNotUsedInMonthsResultsCount

int getInventoryNotUsedInMonthsResultsCount(java.util.Date fromDate,
                                            boolean showZeroOnhandItems)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

findStockTransactionPOReceiverResults

java.util.Collection<StockTransactionPOReceiverResult> findStockTransactionPOReceiverResults(java.util.Date from,
                                                                                java.util.Date to,
                                                                                java.lang.String pnLike,
                                                                                java.lang.String pnType,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getStockTransactionPOReceiverResultsCount

int getStockTransactionPOReceiverResultsCount(java.util.Date from,
                                              java.util.Date to,
                                              java.lang.String pnLike,
                                              java.lang.String pnType)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

findStockTransactionWOReceiverResults

java.util.Collection<StockTransactionWOReceiverResult> findStockTransactionWOReceiverResults(java.util.Date from,
                                                                                java.util.Date to,
                                                                                java.lang.String pnLike,
                                                                                java.lang.String pnType,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getStockTransactionWOReceiverResultsCount

int getStockTransactionWOReceiverResultsCount(java.util.Date from,
                                              java.util.Date to,
                                              java.lang.String pnLike,
                                              java.lang.String pnType)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

findStockTransactionSOShipperResults

java.util.Collection<StockTransactionSOShipperResult> findStockTransactionSOShipperResults(java.util.Date from,
                                                                                java.util.Date to,
                                                                                java.lang.String pnLike,
                                                                                java.lang.String pnType,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getStockTransactionSOShipperResultsCount

int getStockTransactionSOShipperResultsCount(java.util.Date from,
                                             java.util.Date to,
                                             java.lang.String pnLike,
                                             java.lang.String pnType)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findStockTransactionWOShipperResults

java.util.Collection<StockTransactionWOShipperResult> findStockTransactionWOShipperResults(java.util.Date from,
                                                                                java.util.Date to,
                                                                                java.lang.String pnLike,
                                                                                java.lang.String pnType,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getStockTransactionWOShipperResultsCount

int getStockTransactionWOShipperResultsCount(java.util.Date from,
                                             java.util.Date to,
                                             java.lang.String pnLike,
                                             java.lang.String pnType)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findStockTransactionAdjustmentResults

java.util.Collection<StockTransactionAdjustmentResult> findStockTransactionAdjustmentResults(java.util.Date from,
                                                                                java.util.Date to,
                                                                                java.lang.String pnLike,
                                                                                java.lang.String pnType,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getStockTransactionAdjustmentResultsCount

int getStockTransactionAdjustmentResultsCount(java.util.Date from,
                                              java.util.Date to,
                                              java.lang.String pnLike,
                                              java.lang.String pnType)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

getStockTransactionPartInfoResultByPartPk

StockTransactionPartInfoResult getStockTransactionPartInfoResultByPartPk(PartPK pk)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getInventoryTotalResult

InventoryTotalResult getInventoryTotalResult()
                                             throws java.lang.Exception
Throws:
java.lang.Exception

getInventoryListResultsCost

InventoryTotalCostResult getInventoryListResultsCost(boolean showOnhandPartsOnly,
                                                     boolean showInWipOnly,
                                                     boolean showInSipOnly,
                                                     boolean showInQaOnly,
                                                     java.lang.String descriptionLike,
                                                     java.lang.String pnFrom,
                                                     java.lang.String pnTo,
                                                     java.lang.String includePart,
                                                     java.lang.String partType,
                                                     java.lang.String partComeFrom,
                                                     java.lang.String comCodeLike,
                                                     java.lang.String modelNumberLike,
                                                     java.lang.String productCode)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getTotalOnhandDetail

BB2PartTotalOnhandDetailResult getTotalOnhandDetail(BB2Part part)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getTotalOnorderDetail

BB2PartTotalOnorderDetailResult getTotalOnorderDetail(BB2Part part)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getTotalOndemandDetail

BB2PartTotalOndemandDetailResult getTotalOndemandDetail(BB2Part part)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getTotalUsageDetail

BB2PartTotalOndemandDetailResult getTotalUsageDetail(BB2Part part,
                                                     boolean isYr)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getTotalInWipDetail

BB2PartTotalInWipDetailResult getTotalInWipDetail(BB2Part part)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getTotalInSipDetail

BB2PartTotalInSipDetailResult getTotalInSipDetail(BB2Part part)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

findBB2PartInSipItemResults

java.util.Collection<BB2PartInSipItemResult> findBB2PartInSipItemResults(BB2Part part)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getTotalInSitDetail

BB2PartTotalInSitDetailResult getTotalInSitDetail(BB2Part part)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getTotalOnLoanResult

BB2PartTotalOnloanDetailResult getTotalOnLoanResult(BB2Part part)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getTotalInQAResult

BB2PartTotalInQADetailResult getTotalInQAResult(BB2Part part)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

auditOnDemand

void auditOnDemand(BB2Part part)
                   throws java.lang.Exception
Throws:
java.lang.Exception

auditOnOrder

void auditOnOrder(BB2Part part)
                  throws java.lang.Exception
Throws:
java.lang.Exception

auditInWip

void auditInWip(BB2Part part)
                throws java.lang.Exception
Throws:
java.lang.Exception

auditUsage

void auditUsage(BB2Part part)
                throws java.lang.Exception
Throws:
java.lang.Exception

auditInSTO

void auditInSTO(BB2Part part)
                throws java.lang.Exception
Throws:
java.lang.Exception

getMrpResult

BB2PartMrpResult getMrpResult(BB2Part part)
                              throws java.lang.Exception
Throws:
java.lang.Exception

getNextPhysicalWorkSheetNumber

java.lang.Integer getNextPhysicalWorkSheetNumber()
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

takeInitPhysicalInventory

int takeInitPhysicalInventory(int workSheetNumber,
                              java.lang.String description,
                              java.lang.String orderBy,
                              boolean zerolocation,
                              boolean zeroPhysicalCount,
                              boolean backflush,
                              boolean onlyBackflushLocation)
                              throws java.lang.Exception
Throws:
java.lang.Exception

addPhysicalInventory

PhysicalInventoryPK addPhysicalInventory(AddPhysicalInventoryAgent agent)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

updatePhysicalInventory

java.util.Collection<PhysicalInventoryPK> updatePhysicalInventory(java.util.ArrayList list)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getPageNumberInWorkSheetByPart

int getPageNumberInWorkSheetByPart(PartPK partPK,
                                   java.lang.String location,
                                   int workSheetNumber,
                                   java.lang.String tagNumber)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

commitPhysicalInventory

int commitPhysicalInventory(int worksheetNumber,
                            int pageNumber)
                            throws java.lang.Exception
Throws:
java.lang.Exception

getPhysicalWorkSheetTotalPagesNumber

int getPhysicalWorkSheetTotalPagesNumber(int workSheetNumber)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

findPhysicalWorkSheetListResults

java.util.Collection<PhysicalInventoryStatusVO> findPhysicalWorkSheetListResults(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPhysicalWorkSheetListResultsCount

int getPhysicalWorkSheetListResultsCount()
                                         throws java.lang.Exception
Throws:
java.lang.Exception

findPhysicalInventoryListResults

java.util.Collection<PhysicalInventoryListResult> findPhysicalInventoryListResults(int worksheetNumber,
                                                                                int pageNubmer,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPhysicalInventoryListResultsCount

int getPhysicalInventoryListResultsCount(int worksheetNumber,
                                         int pageNubmer)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

findPhysicalInventoryListResultsByLocation

java.util.Collection<PhysicalInventoryListResult> findPhysicalInventoryListResultsByLocation(int worksheetNumber,
                                                                                java.lang.String location)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findPhysicalInventoryListByPartNumber

java.util.Collection<PhysicalInventoryListResult> findPhysicalInventoryListByPartNumber(int worksheetNumber,
                                                                                java.lang.String pnLike,
                                                                                java.lang.String partType,
                                                                                java.lang.String location,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPhysicalInventoryListByPartNumberCount

int getPhysicalInventoryListByPartNumberCount(int worksheetNumber,
                                              java.lang.String pnLike,
                                              java.lang.String partType,
                                              java.lang.String location)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

findPhysicalInventoryListResultsWithAvgCost

java.util.Collection<PhysicalInventoryListResult> findPhysicalInventoryListResultsWithAvgCost(int worksheetNumber,
                                                                                int pageNubmer,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPhysicalInventoryListResultsWithAvgCostCount

int getPhysicalInventoryListResultsWithAvgCostCount(int worksheetNumber,
                                                    int pageNubmer)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getPhysicalInventoryListTotalResultWithAvgCost

PhysicalInventoryListTotalResult getPhysicalInventoryListTotalResultWithAvgCost(int worksheetNumber,
                                                                                int pageNubmer)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPhysicalInventoryTotalResultWithAvgCost

PhysicalInventoryListTotalResult getPhysicalInventoryTotalResultWithAvgCost(int worksheetNumber)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

findPhysicalInventoryListResults

java.util.Collection<PhysicalInventoryListResult> findPhysicalInventoryListResults(int worksheetNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPhysicalInventoryListResultsCount

int getPhysicalInventoryListResultsCount(int worksheetNumber)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

findCommitPhysicalInventoryListResults

java.util.Collection<PhysicalInventoryListResult> findCommitPhysicalInventoryListResults(int worksheetNumber,
                                                                                boolean showUnCommittedOnly,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getCommitPhysicalInventoryListResultsCount

int getCommitPhysicalInventoryListResultsCount(int worksheetNumber,
                                               boolean showUnCommittedOnly)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

isPhysicalWorkSheetExist

boolean isPhysicalWorkSheetExist(int worksheetNumber)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

isPhysicalWorkSheetPageExist

boolean isPhysicalWorkSheetPageExist(int worksheetNumber,
                                     int pageNumber)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

getPhysicalInventoryStatusVO

PhysicalInventoryStatusVO getPhysicalInventoryStatusVO(int workSheetNumber)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

updatePhysicalInventoryStatus

int updatePhysicalInventoryStatus(PhysicalInventoryStatusVO vo)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

makeAuditInventoryByPhyInventory

InventoryAuditReportResult makeAuditInventoryByPhyInventory(PartPK pk,
                                                            java.util.Date fDate,
                                                            java.util.Date tDate)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

findPhysicalInventoryPart

java.util.Collection<PartPK> findPhysicalInventoryPart(java.lang.String pnLike,
                                                       java.lang.String paLike,
                                                       java.util.Date fDate,
                                                       java.util.Date tDate)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

findPhysicalInventoryListResults

java.util.List findPhysicalInventoryListResults(int worksheetNumber,
                                                int pageNubmer,
                                                java.lang.String pnLike,
                                                java.lang.String partType,
                                                java.lang.String location,
                                                java.lang.String countedBy)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

getNextCycleWorkSheetNumber

java.lang.Integer getNextCycleWorkSheetNumber()
                                              throws java.lang.Exception
Throws:
java.lang.Exception

takeInitCycleCount

int takeInitCycleCount(TakeCycleCountAgent agent)
                       throws java.lang.Exception
Throws:
java.lang.Exception

addCycleCount

CycleCountPK addCycleCount(AddPhysicalInventoryAgent agent)
                           throws java.lang.Exception
Throws:
java.lang.Exception

updateCycleCount

java.util.Collection<CycleCountPK> updateCycleCount(java.util.ArrayList<CycleCountAgent> list)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

commitCycleCount

int commitCycleCount(int worksheetNumber)
                     throws java.lang.Exception
Throws:
java.lang.Exception

getCycleWorkSheetTotalPagesNumber

int getCycleWorkSheetTotalPagesNumber(int workSheetNumber)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findCycleWorkSheetListResults

java.util.Collection<CycleCountStatusVO> findCycleWorkSheetListResults(int firstIndex,
                                                                       int maxLength)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getCycleWorkSheetListResultsCount

int getCycleWorkSheetListResultsCount()
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findCycleWorkSheetListResults

java.util.Collection<CycleCountStatusVO> findCycleWorkSheetListResults(int workSheetNumber,
                                                                       int firstIndex,
                                                                       int maxLength)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getCycleWorkSheetListResultsCount

int getCycleWorkSheetListResultsCount(int workSheetNumber)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findCycleCountListResults

java.util.Collection<CycleCountListResult> findCycleCountListResults(int worksheetNumber,
                                                                     int pageNubmer,
                                                                     int firstIndex,
                                                                     int maxLength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getCycleCountListResultsCount

int getCycleCountListResultsCount(int worksheetNumber,
                                  int pageNubmer)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findCycleCountListByPartNumber

java.util.Collection<CycleCountListResult> findCycleCountListByPartNumber(int worksheetNumber,
                                                                          java.lang.String pnLike,
                                                                          java.lang.String partType,
                                                                          int firstIndex,
                                                                          int maxLength)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getCycleCountListByPartNumberCount

int getCycleCountListByPartNumberCount(int worksheetNumber,
                                       java.lang.String pnLike,
                                       java.lang.String partType)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findCycleCountListResultsWithAvgCost

java.util.Collection<CycleCountListResult> findCycleCountListResultsWithAvgCost(int worksheetNumber,
                                                                                int pageNubmer,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getCycleCountListResultsWithAvgCostCount

int getCycleCountListResultsWithAvgCostCount(int worksheetNumber,
                                             int pageNubmer)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

getCycleCountListTotalResultWithAvgCost

CycleCountListTotalResult getCycleCountListTotalResultWithAvgCost(int worksheetNumber,
                                                                  int pageNubmer)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getCycleCountTotalResultWithAvgCost

CycleCountListTotalResult getCycleCountTotalResultWithAvgCost(int worksheetNumber)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

findCycleCountListResults

java.util.Collection<CycleCountListResult> findCycleCountListResults(int worksheetNumber,
                                                                     int firstIndex,
                                                                     int maxLength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getCycleCountListResultsCount

int getCycleCountListResultsCount(int worksheetNumber)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findCommitCycleCountListResults

java.util.Collection<CycleCountListResult> findCommitCycleCountListResults(int worksheetNumber,
                                                                           boolean showUnCommittedOnly,
                                                                           int firstIndex,
                                                                           int maxLength)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getCommitCycleCountListResultsCount

int getCommitCycleCountListResultsCount(int worksheetNumber,
                                        boolean showUnCommittedOnly)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

isCycleWorkSheetExist

boolean isCycleWorkSheetExist(int worksheetNumber)
                              throws java.lang.Exception
Throws:
java.lang.Exception

isCycleWorkSheetPageExist

boolean isCycleWorkSheetPageExist(int worksheetNumber,
                                  int pageNumber)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

updateCycleCountStatus

int updateCycleCountStatus(CycleCountStatusVO vo)
                           throws java.lang.Exception
Throws:
java.lang.Exception

getCycleCountStatusVO

CycleCountStatusVO getCycleCountStatusVO(int workSheetNumber)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

getMfrMpnListResultsFor

java.util.Collection<MfrMpnListResult> getMfrMpnListResultsFor(PurchaseOrderItemPK itemPk)
                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getMfrMpnListResultsFor

java.util.Collection<MfrMpnListResult> getMfrMpnListResultsFor(SalesOrderItemPK itemPk)
                                                               throws java.lang.Exception
Throws:
java.lang.Exception

auditLastInventoryDate

java.util.Collection<PartPK> auditLastInventoryDate(java.lang.String pnLike,
                                                    java.lang.String paType,
                                                    java.util.Date start)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

findBB2PartInventoryResults

java.util.Collection<BB2PartInventoryResult> findBB2PartInventoryResults(java.util.HashSet bb2Parts)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getRtvShipperById

RtvShipperVO getRtvShipperById(java.lang.String rtvShipperNumber)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findRtvShipperListResultsByRTVShipperNumber

java.util.Collection<RtvShipperListResult> findRtvShipperListResultsByRTVShipperNumber(java.lang.String rtvShipperNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getRtvShipperListResultsCountByRTVShipperNumber

int getRtvShipperListResultsCountByRTVShipperNumber(java.lang.String rtvShipperNumber)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

findRtvShipperListResultsByRTVNumber

java.util.Collection<RtvShipperListResult> findRtvShipperListResultsByRTVNumber(java.lang.String rtvNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getRtvShipperListResultsCountByRTVNumber

int getRtvShipperListResultsCountByRTVNumber(java.lang.String rtvNumber)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findRtvShipperListResultsByPONumber

java.util.Collection<RtvShipperListResult> findRtvShipperListResultsByPONumber(java.lang.String poNumber,
                                                                               int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getRtvShipperListResultsCountByPONumber

int getRtvShipperListResultsCountByPONumber(java.lang.String poNumber)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

findRtvShipperListResultsByVendorID

java.util.Collection<RtvShipperListResult> findRtvShipperListResultsByVendorID(java.lang.String vendorID,
                                                                               int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getRtvShipperListResultsCountByVendorID

int getRtvShipperListResultsCountByVendorID(java.lang.String vendorID)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

findRtvShipperListResultsByShippedBy

java.util.Collection<RtvShipperListResult> findRtvShipperListResultsByShippedBy(java.lang.String shippedby,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getRtvShipperListResultsCountByShippedBy

int getRtvShipperListResultsCountByShippedBy(java.lang.String shippedby)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findRtvShipperItemListResultsByRTVShipperNumber

java.util.Collection<RtvShipperItemListResult> findRtvShipperItemListResultsByRTVShipperNumber(java.lang.String rtvShipperNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getRtvShipperItemListResultsCountByRTVShipperNumber

int getRtvShipperItemListResultsCountByRTVShipperNumber(java.lang.String rtvShipperNumber)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

findRtvShipperItemListResultsByRTVNumber

java.util.Collection<RtvShipperItemListResult> findRtvShipperItemListResultsByRTVNumber(java.lang.String rtvNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getRtvShipperItemListResultsCountByRTVNumber

int getRtvShipperItemListResultsCountByRTVNumber(java.lang.String rtvNumber)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findRtvShipperItemListResultsByPONumber

java.util.Collection<RtvShipperItemListResult> findRtvShipperItemListResultsByPONumber(java.lang.String poNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getRtvShipperItemListResultsCountByPONumber

int getRtvShipperItemListResultsCountByPONumber(java.lang.String poNumber)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

findRtvShipperItemListResultsByVendorID

java.util.Collection<RtvShipperItemListResult> findRtvShipperItemListResultsByVendorID(java.lang.String vendorID,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getRtvShipperItemListResultsCountByVendorID

int getRtvShipperItemListResultsCountByVendorID(java.lang.String vendorID)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

findRtvShipperItemListResultsByPartNumber

java.util.Collection<RtvShipperItemListResult> findRtvShipperItemListResultsByPartNumber(java.lang.String partNumber,
                                                                                java.lang.String partType,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getRtvShipperItemListResultsCountByPartNumber

int getRtvShipperItemListResultsCountByPartNumber(java.lang.String partNumber,
                                                  java.lang.String partType)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getRtvShipperItemListResultsOfRtv

java.util.Collection<RtvShipperItemListResult> getRtvShipperItemListResultsOfRtv(java.lang.String rtvNumber)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findRtvShipperItemListResultsByDate

java.util.Collection<RtvShipperItemListResult> findRtvShipperItemListResultsByDate(java.lang.String rtvShipperNumber,
                                                                                java.lang.String rtvNumber,
                                                                                java.lang.String vendorId,
                                                                                java.lang.String partNumber,
                                                                                java.lang.String partType,
                                                                                java.lang.String status,
                                                                                java.util.Date fromDate,
                                                                                java.util.Date toDate,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getRtvShipperItemListResultsCountByDate

int getRtvShipperItemListResultsCountByDate(java.lang.String rtvShipperNumber,
                                            java.lang.String rtvNumber,
                                            java.lang.String vendorId,
                                            java.lang.String partNumber,
                                            java.lang.String partType,
                                            java.lang.String status,
                                            java.util.Date fromDate,
                                            java.util.Date toDate)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

updateOnloanShipper

OnloanShipperVO updateOnloanShipper(OnloanShipperVO vo)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

getOnloanShipperById

OnloanShipperVO getOnloanShipperById(java.lang.String lnShipperNumber)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findOnloanShippersByLn

java.util.Collection<OnloanShipperVO> findOnloanShippersByLn(java.lang.String loanNumber,
                                                             int firstIndex,
                                                             int maxLength)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getOnloanShippersCountByLn

int getOnloanShippersCountByLn(java.lang.String loanNumber)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findAllOnloanShippers

java.util.Collection<OnloanShipperVO> findAllOnloanShippers(int firstIndex,
                                                            int maxLength)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getAllOnloanShippersCount

int getAllOnloanShippersCount()
                              throws java.lang.Exception
Throws:
java.lang.Exception

findOnloanShipperListResultsByOnloanShipperNumber

java.util.Collection<LnShipperListResult> findOnloanShipperListResultsByOnloanShipperNumber(java.lang.String lnShipperNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOnloanShipperListResultsCountByOnloanShipperNumber

int getOnloanShipperListResultsCountByOnloanShipperNumber(java.lang.String lnShipperNumber)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

findOnloanShipperListResultsByLoanNumber

java.util.Collection<LnShipperListResult> findOnloanShipperListResultsByLoanNumber(java.lang.String loanNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOnloanShipperListResultsCountByLoanNumber

int getOnloanShipperListResultsCountByLoanNumber(java.lang.String loanNumber)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findOnloanShipperListResultsBySalesman

java.util.Collection<LnShipperListResult> findOnloanShipperListResultsBySalesman(java.lang.String salesman,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOnloanShipperListResultsCountBySalesman

int getOnloanShipperListResultsCountBySalesman(java.lang.String salesman)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

findOnloanShipperListResultsByCustomerId

java.util.Collection<LnShipperListResult> findOnloanShipperListResultsByCustomerId(java.lang.String customerId,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOnloanShipperListResultsCountByCustomerId

int getOnloanShipperListResultsCountByCustomerId(java.lang.String customerId)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findLnShipperItemListResultsByLnNumber

java.util.Collection<LnShipperItemListResult> findLnShipperItemListResultsByLnNumber(java.lang.String loanNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findLnShipperItemListResults

java.util.Collection<LnShipperItemListResult> findLnShipperItemListResults(java.util.Date fromDate,
                                                                           java.util.Date toDate,
                                                                           java.lang.String lnShipperNumber,
                                                                           java.lang.String loanNumber,
                                                                           java.lang.String partNumber,
                                                                           java.lang.String partType,
                                                                           java.lang.String customerId,
                                                                           java.lang.String status,
                                                                           int firstIndex,
                                                                           int maxLength)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getLnShipperItemListResultsCount

int getLnShipperItemListResultsCount(java.util.Date fromDate,
                                     java.util.Date toDate,
                                     java.lang.String lnShipperNumber,
                                     java.lang.String loanNumber,
                                     java.lang.String partNumber,
                                     java.lang.String partType,
                                     java.lang.String customerId,
                                     java.lang.String status)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findLnShipperItemListResultsByPartNumber

java.util.Collection<LnShipperItemListResult> findLnShipperItemListResultsByPartNumber(java.lang.String partNumber,
                                                                                java.lang.String partType,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getLnShipperItemListResultsCountByPartNumber

int getLnShipperItemListResultsCountByPartNumber(java.lang.String partNumber,
                                                 java.lang.String partType)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findLnShipperItemListResultsByCustomerId

java.util.Collection<LnShipperItemListResult> findLnShipperItemListResultsByCustomerId(java.lang.String customerId,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getLnShipperItemListResultsCountByCustomerId

int getLnShipperItemListResultsCountByCustomerId(java.lang.String customerId)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

addVendorPart

VendorPartVO addVendorPart(VendorPartVO vo)
                           throws java.lang.Exception
Throws:
java.lang.Exception

isVendorPartExistent

boolean isVendorPartExistent(VendorPartPK pk)
                             throws java.lang.Exception
Throws:
java.lang.Exception

getVendorPart

VendorPartVO getVendorPart(VendorPartPK pk)
                           throws java.lang.Exception
Throws:
java.lang.Exception

updateVendorPart

void updateVendorPart(VendorPartVO vo)
                      throws java.lang.Exception
Throws:
java.lang.Exception

deleteVendorPart

void deleteVendorPart(VendorPartPK pk)
                      throws java.lang.Exception
Throws:
java.lang.Exception

findVendorParts

java.util.Collection<VendorPartVO> findVendorParts(java.lang.String vendorPartNumber,
                                                   java.lang.String vendorPartType,
                                                   java.lang.String vendorPartFrom,
                                                   java.lang.String vendorId,
                                                   java.lang.String partNumber,
                                                   java.lang.String partType,
                                                   java.lang.String partFrom,
                                                   int firstIndex,
                                                   int maxLength)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getVendorPartsCount

int getVendorPartsCount(java.lang.String vendorPartNumber,
                        java.lang.String vendorPartType,
                        java.lang.String vendorPartFrom,
                        java.lang.String vendorId,
                        java.lang.String partNumber,
                        java.lang.String partType,
                        java.lang.String partFrom)
                        throws java.lang.Exception
Throws:
java.lang.Exception

getAllPartInQAsfor

java.util.Collection<PartInQAVO> getAllPartInQAsfor(BB2Part part,
                                                    java.lang.String ncrNumber)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

rebackInQAtoWareHouse

void rebackInQAtoWareHouse(java.util.HashSet<RebackInQAAgent> sets)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findPartOnhandByPk

java.util.Collection<PartOnhandVO> findPartOnhandByPk(PartPK pk)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

findToolOnhandByPk

java.util.Collection<ToolOnhandVO> findToolOnhandByPk(PartPK pk)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

findPartOnhandIsZeroByPart

java.util.Collection<PartOnhandVO> findPartOnhandIsZeroByPart(PartPK pk,
                                                              int firstIndex,
                                                              int maxLength)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getPartOnhandIsZeroByPartCount

int getPartOnhandIsZeroByPartCount(PartPK pk)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findPartWithoutLocationList

java.util.Collection<PartWithoutLocateResult> findPartWithoutLocationList(PartPK pk,
                                                                          int firstIndex,
                                                                          int maxLength)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getPartWithoutLocationCount

int getPartWithoutLocationCount(PartPK pk)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findInventoryMonthReportTotal

java.util.Collection<InventoryMonthReport> findInventoryMonthReportTotal(java.util.Date bDate,
                                                                         java.util.Date eDate,
                                                                         java.lang.String partNumberLike,
                                                                         java.lang.String partTypeLike)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

findInventoryMonthReport

java.util.Collection<InventoryMonthReport> findInventoryMonthReport(java.util.Date bDate,
                                                                    java.util.Date eDate,
                                                                    java.lang.String partNumberLike,
                                                                    java.lang.String partTypeLike,
                                                                    int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getInventoryMonthReportCount

int getInventoryMonthReportCount(java.util.Date bDate,
                                 java.util.Date eDate,
                                 java.lang.String partNumberLike,
                                 java.lang.String partTypeLike)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

getAllPartInQAsWithoutNCR

java.util.Collection<PartInQAVO> getAllPartInQAsWithoutNCR(BB2Part part)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

putParttoInQA

void putParttoInQA(java.util.HashSet<PuttoInQAAgent> sets,
                   java.lang.String ncrNumber)
                   throws java.lang.Exception
Throws:
java.lang.Exception

pullFromWorkOrderPartDetail

void pullFromWorkOrderPartDetail(java.util.HashSet<PullFromWorkOrderPartDetailAgent> sets,
                                 java.lang.String ncrNumber)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

linkNCRtoPartInQA

void linkNCRtoPartInQA(java.util.HashSet<java.lang.Integer> sets,
                       java.lang.String ncrNumber)
                       throws java.lang.Exception
Throws:
java.lang.Exception

getPartsInQAsWithoutNCR

PartInQAResult getPartsInQAsWithoutNCR(BB2Part part)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findAllPartInQAsWithoutNCR

java.util.Collection<PartInQAVO> findAllPartInQAsWithoutNCR(BB2Part part,
                                                            int firstIndex,
                                                            int maxLength)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getAllPartInQAsWithoutNCRCount

int getAllPartInQAsWithoutNCRCount(BB2Part part)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findTotalAuditPartInQA

java.util.Collection<AuditPartInQAResult> findTotalAuditPartInQA(java.lang.String pnLike,
                                                                 java.lang.String pnType,
                                                                 java.lang.String pnFrom,
                                                                 int firstIndex,
                                                                 int maxLength)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getTotalAuditPartInQACount

int getTotalAuditPartInQACount(java.lang.String pnLike,
                               java.lang.String pnType,
                               java.lang.String pnFrom)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getAuditPartInQA

java.util.Collection<AuditPartInQAResult> getAuditPartInQA(java.lang.String pnLike,
                                                           java.lang.String pnType,
                                                           java.lang.String pnFrom)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getHighUsagePartResultsCount

int getHighUsagePartResultsCount()
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findHighUsagePartResults

java.util.Collection<HighUsagePartResult> findHighUsagePartResults(int firstIndex,
                                                                   int maxLength)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getPartNumPrefix

java.util.Collection<java.lang.String> getPartNumPrefix(int num,
                                                        java.lang.String pnLike,
                                                        java.util.Date startDate)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getTotalPartToAuditCount

int getTotalPartToAuditCount(java.lang.String pnLike,
                             java.util.Date startDate)
                             throws java.lang.Exception
Throws:
java.lang.Exception

getPartPKsToAudit

java.util.Collection<PartPK> getPartPKsToAudit(java.lang.String pnPrefix,
                                               java.util.Date startDate)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

getPartPKsToAuditCount

int getPartPKsToAuditCount(java.lang.String pnPrefix,
                           java.util.Date startDate)
                           throws java.lang.Exception
Throws:
java.lang.Exception

getPartOnHandAuditResult

PartOnHandAuditResult getPartOnHandAuditResult(PartPK pk,
                                               java.util.Date date)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

findSalesOrderShipDateListResultsByDate

java.util.Collection<SalesOrderShipDateListResult> findSalesOrderShipDateListResultsByDate(java.lang.String soNumber,
                                                                                java.lang.String custID,
                                                                                java.lang.String partNumber,
                                                                                java.util.Date fDate,
                                                                                java.util.Date tDate,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getSalesOrderShipDateListResultsCountByDate

int getSalesOrderShipDateListResultsCountByDate(java.lang.String soNumber,
                                                java.lang.String custID,
                                                java.lang.String partNumber,
                                                java.util.Date fDate,
                                                java.util.Date tDate)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

findHistoricalInventoryDates

java.util.Collection<java.util.Date> findHistoricalInventoryDates(int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getHistoricalInventoryDatesCount

int getHistoricalInventoryDatesCount()
                                     throws java.lang.Exception
Throws:
java.lang.Exception

getPartsByHistoricalInventorys

java.util.Collection<PartPK> getPartsByHistoricalInventorys(java.lang.String pnLike,
                                                            java.lang.String paLike,
                                                            java.util.Date fDate,
                                                            java.util.Date tDate)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getHistoricalInventoryTotalResults

java.util.Collection<HistoricalInventoryTotalResult> getHistoricalInventoryTotalResults(java.lang.String pnLike,
                                                                                java.lang.String paLike,
                                                                                java.util.Date fDate,
                                                                                java.util.Date tDate)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findHistoricalInventorys

java.util.Collection<HistoricalInventoryVO> findHistoricalInventorys(java.lang.String pnLike,
                                                                     java.lang.String paLike,
                                                                     java.util.Date date,
                                                                     boolean isShowOnHand,
                                                                     int firstIndex,
                                                                     int maxlength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

findHistoricalInventorysTotal

java.util.Collection<InventoryTotalCostResult> findHistoricalInventorysTotal(java.lang.String pnLike,
                                                                             java.lang.String paLike,
                                                                             java.util.Date fDate,
                                                                             java.util.Date tDate,
                                                                             boolean isShowOnHand)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getHistoricalInventorysCount

int getHistoricalInventorysCount(java.lang.String pnLike,
                                 java.lang.String paLike,
                                 java.util.Date date,
                                 boolean isShowOnHand)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findInventoryReportList

java.util.Collection<InventoryReportListResult> findInventoryReportList(java.lang.String pnLike,
                                                                        java.lang.String paLike,
                                                                        java.util.Date fDate,
                                                                        java.util.Date tDate,
                                                                        int firstIndex,
                                                                        int maxlength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getInventoryReportListCount

int getInventoryReportListCount(java.lang.String pnLike,
                                java.lang.String paLike,
                                java.util.Date fDate,
                                java.util.Date tDate)
                                throws java.lang.Exception
Throws:
java.lang.Exception

getAuditInventoryReport

InventoryAuditReportResult getAuditInventoryReport(PartPK pk,
                                                   java.util.Date fDate,
                                                   java.util.Date tDate)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

findInSipAuditReport

java.util.Collection<InSipAudittListResult> findInSipAuditReport(java.lang.String partNumber,
                                                                 java.lang.String partType,
                                                                 java.lang.String partFrom,
                                                                 int firstIndex,
                                                                 int maxlength)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

addPartClass

PartClassVO addPartClass(PartClassVO vo)
                         throws java.lang.Exception
Throws:
java.lang.Exception

updatePartClass

PartClassVO updatePartClass(PartClassVO vo,
                            boolean autoCount)
                            throws java.lang.Exception
Throws:
java.lang.Exception

getPartClassByID

PartClassVO getPartClassByID(java.lang.String id)
                             throws java.lang.Exception
Throws:
java.lang.Exception

deletePartClass

void deletePartClass(java.lang.String id)
                     throws java.lang.Exception
Throws:
java.lang.Exception

findPartClasses

java.util.Collection<PartClassVO> findPartClasses(int firstIndex,
                                                  int maxLength)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getPartClassesCount

int getPartClassesCount()
                        throws java.lang.Exception
Throws:
java.lang.Exception

getPartClassesList

java.util.Collection<java.lang.String> getPartClassesList()
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getPartClassesToAlarm

java.util.Collection<java.lang.String> getPartClassesToAlarm()
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

updatePartPartClass

void updatePartPartClass(java.util.HashSet<PartPK> set,
                         java.lang.String partClass)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findPartClassInfoResult

java.util.Collection<PartClassInfoResult> findPartClassInfoResult(java.lang.String pnLike,
                                                                  java.lang.String partType,
                                                                  java.lang.String partClass,
                                                                  int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getPartClassInfoResultCount

int getPartClassInfoResultCount(java.lang.String pnLike,
                                java.lang.String partType,
                                java.lang.String partClass)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findPartWithoutClassInfoResult

java.util.Collection<PartClassInfoResult> findPartWithoutClassInfoResult(java.lang.String pnLike,
                                                                         java.lang.String description,
                                                                         java.lang.String partType,
                                                                         java.lang.String commodity,
                                                                         int firstIndex,
                                                                         int maxLength)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getPartWithoutClassInfoResultCount

int getPartWithoutClassInfoResultCount(java.lang.String pnLike,
                                       java.lang.String description,
                                       java.lang.String partType,
                                       java.lang.String commodity)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

getInventoryCostVarianceCount

int getInventoryCostVarianceCount(java.lang.String partNumber,
                                  java.lang.String partType,
                                  java.lang.String makeBuy,
                                  java.math.BigDecimal variancePercent)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findInventoryCostVarianceCount

java.util.Collection<PartCostVarianceListResult> findInventoryCostVarianceCount(java.lang.String partNumber,
                                                                                java.lang.String partType,
                                                                                java.lang.String makeBuy,
                                                                                java.math.BigDecimal variancePercent,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findAllOnHandAudit

java.util.Collection<AuditOnDemandResult> findAllOnHandAudit(java.lang.String partNumber,
                                                             java.lang.String partType,
                                                             int firstIndex,
                                                             int maxLength)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getAllOnHandAuditCount

int getAllOnHandAuditCount(java.lang.String partNumber,
                           java.lang.String partType)
                           throws java.lang.Exception
Throws:
java.lang.Exception

auditAllOnHand

void auditAllOnHand()
                    throws java.lang.Exception
Throws:
java.lang.Exception

addLabelTemplate

LabelTemplateVO addLabelTemplate(LabelTemplateVO vo)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

updateLabelTemplate

void updateLabelTemplate(LabelTemplateVO vo)
                         throws java.lang.Exception
Throws:
java.lang.Exception

getLabelTemplate

LabelTemplateVO getLabelTemplate(int ii)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

isLabelTemplateExist

boolean isLabelTemplateExist(int ii)
                             throws java.lang.Exception
Throws:
java.lang.Exception

deleteLabelTemplate

void deleteLabelTemplate(int ii)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findAllLabelTemplate

java.util.Collection<LabelTemplateVO> findAllLabelTemplate(int firstIndex,
                                                           int maxLength)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getAllLabelTemplateCount

int getAllLabelTemplateCount()
                             throws java.lang.Exception
Throws:
java.lang.Exception

getActiveLabelTemplateByType

LabelTemplateVO getActiveLabelTemplateByType(java.lang.String labelType)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

activeLabelTemplate

void activeLabelTemplate(int ii)
                         throws java.lang.Exception
Throws:
java.lang.Exception

getPartLocationCount

int getPartLocationCount(java.lang.String location)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findPartLocation

java.util.Collection<java.lang.String> findPartLocation(java.lang.String location,
                                                        int firstIndex,
                                                        int maxLength)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

isPFFinished

boolean isPFFinished(java.lang.String pfInvoiceNumber)
                     throws java.lang.Exception
Throws:
java.lang.Exception

getInventoryByBB2Part

BB2PartInventoryResult getInventoryByBB2Part(BB2Part partpk)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

addWarehouse

void addWarehouse(WarehouseVO vo)
                  throws java.lang.Exception
Throws:
java.lang.Exception

updateWarehouse

void updateWarehouse(WarehouseVO vo)
                     throws java.lang.Exception
Throws:
java.lang.Exception

deleteWarehouse

void deleteWarehouse(java.lang.String warehousePrefix)
                     throws java.lang.Exception
Throws:
java.lang.Exception

getWarehouseByPK

WarehouseVO getWarehouseByPK(java.lang.String warehousePrefix)
                             throws java.lang.Exception
Throws:
java.lang.Exception

isWarehouseExist

boolean isWarehouseExist(java.lang.String warehousePrefix)
                         throws java.lang.Exception
Throws:
java.lang.Exception

isWarehouseUsing

boolean isWarehouseUsing(java.lang.String warehousePrefix)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findAllWarehouses

java.util.Collection<WarehouseVO> findAllWarehouses(int firstIndex,
                                                    int maxLength)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getAllWarehousesCount

int getAllWarehousesCount()
                          throws java.lang.Exception
Throws:
java.lang.Exception

moveWarehouse

void moveWarehouse(java.lang.String warehouseFrom,
                   java.lang.String warehouseTo)
                   throws java.lang.Exception
Throws:
java.lang.Exception

findLocationResultWithoutWarehouse

java.util.Collection<LocationResult> findLocationResultWithoutWarehouse()
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

initWarehouse

void initWarehouse(java.lang.String locationPrefix,
                   java.lang.String warehouseId,
                   java.lang.String oldLocation)
                   throws java.lang.Exception
Throws:
java.lang.Exception

addTransferOrder

TransferOrderVO addTransferOrder(TransferOrderVO vo)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

getTransferOrderByPk

TransferOrderVO getTransferOrderByPk(java.lang.String transferOrderNumber)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

updateTransferOrder

void updateTransferOrder(TransferOrderVO vo)
                         throws java.lang.Exception
Throws:
java.lang.Exception

initTransferOrderItem

TransferOrderItemVO initTransferOrderItem(TransferOrderVO toVo,
                                          PartPK partPk,
                                          java.math.BigDecimal quantity,
                                          boolean isTool)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

approvalTransferOrder

TransferOrderVO approvalTransferOrder(TransferOrderVO toVO)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

addTransferOrderApproval

TransferOrderApprovalVO addTransferOrderApproval(TransferOrderApprovalVO vo)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

updateTransferOrderApproval

void updateTransferOrderApproval(TransferOrderApprovalVO vo)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

getTransferOrderApprovalByEmployeeId

TransferOrderApprovalVO getTransferOrderApprovalByEmployeeId(java.lang.String employeeId)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getAllTransferOrderApprovalCount

int getAllTransferOrderApprovalCount()
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findAllTransferOrderApproval

java.util.Collection<TransferOrderApprovalVO> findAllTransferOrderApproval(int firstIndex,
                                                                           int maxLength)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

isTransferOrderApprovalExist

boolean isTransferOrderApprovalExist(java.lang.String employeeId)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

deleteTransferOrderApproval

void deleteTransferOrderApproval(java.lang.String employeeId)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findTransferOrderByDate

java.util.Collection<TransferOrderListResult> findTransferOrderByDate(java.lang.String transferOrderNumber,
                                                                      java.lang.String fromAddressId,
                                                                      java.lang.String toAddressId,
                                                                      java.lang.String transferType,
                                                                      java.lang.String status,
                                                                      java.util.Date from,
                                                                      java.util.Date to,
                                                                      int firstIndex,
                                                                      int maxLength)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getTransferOrderByDateCount

int getTransferOrderByDateCount(java.lang.String transferOrderNumber,
                                java.lang.String fromAddressId,
                                java.lang.String toAddressId,
                                java.lang.String transferType,
                                java.lang.String status,
                                java.util.Date from,
                                java.util.Date to)
                                throws java.lang.Exception
Throws:
java.lang.Exception

findTransferOrderItemsByDate

java.util.Collection<TransferOrderItemListResult> findTransferOrderItemsByDate(java.lang.String transferOrderNumber,
                                                                               java.lang.String transferType,
                                                                               java.lang.String partNumber,
                                                                               java.lang.String partType,
                                                                               java.lang.String status,
                                                                               java.lang.String dateType,
                                                                               java.util.Date from,
                                                                               java.util.Date to,
                                                                               int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getTransferOrderItemsByDateCount

int getTransferOrderItemsByDateCount(java.lang.String transferOrderNumber,
                                     java.lang.String transferType,
                                     java.lang.String partNumber,
                                     java.lang.String partType,
                                     java.lang.String status,
                                     java.lang.String dateType,
                                     java.util.Date from,
                                     java.util.Date to)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

getTransferOrderShippingResult

ShippingResult getTransferOrderShippingResult(java.lang.String transferOrderNumber)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

findOpenTransferOrderForShipper

java.util.Collection<TransferOrderListResult> findOpenTransferOrderForShipper(java.lang.String toNumber,
                                                                              int firstIndex,
                                                                              int maxLength)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getOpenTransferOrderForShipperCount

int getOpenTransferOrderForShipperCount(java.lang.String toNumber)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

makeTransferOrderShipper

java.lang.String makeTransferOrderShipper(ShipperAgent vo)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

getTransferShipper

TransferShipperVO getTransferShipper(java.lang.String transferShipperNumber)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

getTransferReceiverById

TransferReceiverVO getTransferReceiverById(java.lang.String receiverNumber)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

updateTransferShipper

TransferShipperVO updateTransferShipper(TransferShipperVO vo)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findTransferShipperByDate

java.util.Collection<TransferShipperListResult> findTransferShipperByDate(java.lang.String transferShipperNumber,
                                                                          java.lang.String transferOrderNumber,
                                                                          java.lang.String fromAddressId,
                                                                          java.lang.String toAddressId,
                                                                          java.lang.String status,
                                                                          java.util.Date from,
                                                                          java.util.Date to,
                                                                          int firstIndex,
                                                                          int maxLength)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getTransferShipperByDateCount

int getTransferShipperByDateCount(java.lang.String transferShipperNumber,
                                  java.lang.String transferOrderNumber,
                                  java.lang.String fromAddressId,
                                  java.lang.String toAddressId,
                                  java.lang.String status,
                                  java.util.Date from,
                                  java.util.Date to)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

getTransferReceivingResult

ReceivingResult getTransferReceivingResult(java.lang.String transferShipperNumber)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

makeTransferReceiver

java.util.Collection<TransferReceiverListResult> makeTransferReceiver(ReceiverAgent agent)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

findTransferReceiverListResultsbyDate

java.util.Collection<TransferReceiverListResult> findTransferReceiverListResultsbyDate(java.lang.String transferReceiverNumber,
                                                                                java.lang.String transferShipperNumber,
                                                                                java.lang.String transferOrderNumber,
                                                                                java.lang.String status,
                                                                                java.lang.String fromAddressId,
                                                                                java.lang.String toAddressId,
                                                                                java.util.Date from,
                                                                                java.util.Date to,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getTransferReceiverListResultsbyDateCount

int getTransferReceiverListResultsbyDateCount(java.lang.String transferReceiverNumber,
                                              java.lang.String transferShipperNumber,
                                              java.lang.String transferOrderNumber,
                                              java.lang.String status,
                                              java.lang.String fromAddressId,
                                              java.lang.String toAddressId,
                                              java.util.Date from,
                                              java.util.Date to)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

updateTransferReceiver

java.lang.String updateTransferReceiver(TransferReceiverVO vo)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

transferPart

java.lang.String transferPart(java.lang.String transferOrderNumber)
                              throws java.lang.Exception
Throws:
java.lang.Exception

getTotalInSTODetail

BB2PartTotalInSTODetailResult getTotalInSTODetail(BB2Part part)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

findTransferShipperItemsByDate

java.util.Collection<TransferShipperListResult> findTransferShipperItemsByDate(java.lang.String transferShipperNumber,
                                                                               java.lang.String transferOrderNumber,
                                                                               java.lang.String fromAddressId,
                                                                               java.lang.String toAddressId,
                                                                               java.lang.String partNumber,
                                                                               java.lang.String partType,
                                                                               java.lang.String partFrom,
                                                                               java.lang.String status,
                                                                               java.util.Date from,
                                                                               java.util.Date to,
                                                                               int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

findTransferShipperItemsTotalByDate

TransferShipperItemListResult findTransferShipperItemsTotalByDate(java.lang.String transferShipperNumber,
                                                                  java.lang.String transferOrderNumber,
                                                                  java.lang.String fromAddressId,
                                                                  java.lang.String toAddressId,
                                                                  java.lang.String partNumber,
                                                                  java.lang.String partType,
                                                                  java.lang.String partFrom,
                                                                  java.lang.String status,
                                                                  java.util.Date from,
                                                                  java.util.Date to)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getTransferShipperItemsByDateCount

int getTransferShipperItemsByDateCount(java.lang.String transferShipperNumber,
                                       java.lang.String transferOrderNumber,
                                       java.lang.String fromAddressId,
                                       java.lang.String toAddressId,
                                       java.lang.String partNumber,
                                       java.lang.String partType,
                                       java.lang.String partFrom,
                                       java.lang.String status,
                                       java.util.Date from,
                                       java.util.Date to)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findTransferReceiverItemsByDate

java.util.Collection<TransferReceiverItemListResult> findTransferReceiverItemsByDate(java.lang.String transferReceiverNumber,
                                                                                java.lang.String partNumber,
                                                                                java.lang.String partType,
                                                                                java.lang.String partFrom,
                                                                                java.lang.String status,
                                                                                java.util.Date from,
                                                                                java.util.Date to,
                                                                                java.lang.String fromAddressId,
                                                                                java.lang.String toAddressId,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findTransferReceiverItemsTotalByDate

TransferReceiverItemListResult findTransferReceiverItemsTotalByDate(java.lang.String transferReceiverNumber,
                                                                    java.lang.String partNumber,
                                                                    java.lang.String partType,
                                                                    java.lang.String partFrom,
                                                                    java.lang.String status,
                                                                    java.util.Date from,
                                                                    java.util.Date to,
                                                                    java.lang.String fromAddressId,
                                                                    java.lang.String toAddressId)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getTransferReceiverItemsByDate

int getTransferReceiverItemsByDate(java.lang.String transferReceiverNumber,
                                   java.lang.String partNumber,
                                   java.lang.String partType,
                                   java.lang.String partFrom,
                                   java.lang.String status,
                                   java.util.Date from,
                                   java.util.Date to,
                                   java.lang.String fromAddressId,
                                   java.lang.String toAddressId)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

isLocationExist

boolean isLocationExist(java.lang.String location)
                        throws java.lang.Exception
Throws:
java.lang.Exception

isMakeNcr

boolean isMakeNcr(BB2Part part,
                  java.lang.String receivedFrom)
                  throws java.lang.Exception
Throws:
java.lang.Exception

makeSwapOrderShipper

java.lang.String makeSwapOrderShipper(ShipperAgent agent)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

updateSwapShipper

SwapShipperVO updateSwapShipper(SwapShipperVO vo)
                                throws java.lang.Exception
Throws:
java.lang.Exception

getSwapShipperVO

SwapShipperVO getSwapShipperVO(java.lang.String swapShipperNumber)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findSwapShippers

java.util.Collection<SwapShipperListResult> findSwapShippers(java.lang.String swapShipperNumber,
                                                             java.lang.String swoNumber,
                                                             java.lang.String vendorId,
                                                             java.lang.String status,
                                                             java.lang.String buyer,
                                                             java.lang.String project,
                                                             java.lang.String relatedDoc,
                                                             java.util.Date fromDate,
                                                             java.util.Date toDate,
                                                             int firstIndex,
                                                             int maxLength)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getSwapShippersCount

int getSwapShippersCount(java.lang.String swapShipperNumber,
                         java.lang.String swoNumber,
                         java.lang.String vendorId,
                         java.lang.String status,
                         java.lang.String buyer,
                         java.lang.String project,
                         java.lang.String relatedDoc,
                         java.util.Date fromDate,
                         java.util.Date toDate)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findSwapShipperItemsByDate

java.util.Collection<SwapShipperItemListResult> findSwapShipperItemsByDate(java.lang.String swapShipperNumber,
                                                                           java.lang.String swoNumber,
                                                                           java.lang.String vendorId,
                                                                           java.lang.String status,
                                                                           java.lang.String partNumber,
                                                                           java.lang.String partType,
                                                                           java.lang.String partFrom,
                                                                           java.util.Date fromDate,
                                                                           java.util.Date toDate,
                                                                           int firstIndex,
                                                                           int maxLength)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getSwapShipperItemsByDateCount

int getSwapShipperItemsByDateCount(java.lang.String swapShipperNumber,
                                   java.lang.String swoNumber,
                                   java.lang.String vendorId,
                                   java.lang.String status,
                                   java.lang.String partNumber,
                                   java.lang.String partType,
                                   java.lang.String partFrom,
                                   java.util.Date fromDate,
                                   java.util.Date toDate)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findOpenSwapOrderForShipper

java.util.Collection<SwapOrderListResult> findOpenSwapOrderForShipper(java.lang.String swoNumber,
                                                                      int firstIndex,
                                                                      int maxLength)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getOpenSwapOrderForShipperCount

int getOpenSwapOrderForShipperCount(java.lang.String swoNumber)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

getSwapOrderShippingResult

ShippingResult getSwapOrderShippingResult(java.lang.String swoNumber)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

makeSwapReceiver

java.util.List<SwapReceiverListResult> makeSwapReceiver(ReceiverAgent agent)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

updateSwapReceiver

java.lang.String updateSwapReceiver(SwapReceiverVO vo)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

getSwapReceiverVO

SwapReceiverVO getSwapReceiverVO(java.lang.String swapReceiverNumber)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

getSwapReceiverItemByDateCount

int getSwapReceiverItemByDateCount(java.lang.String swapReceiverNumber,
                                   java.lang.String swapShipperNumber,
                                   java.lang.String swoNumber,
                                   java.lang.String vendorId,
                                   java.lang.String status,
                                   java.lang.String partNumber,
                                   java.lang.String partType,
                                   java.lang.String partFrom,
                                   java.util.Date fromDate,
                                   java.util.Date toDate)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findSwapReceiverItemByDate

java.util.Collection<SwapReceiverItemListResult> findSwapReceiverItemByDate(java.lang.String swapReceiverNumber,
                                                                            java.lang.String swapShipperNumber,
                                                                            java.lang.String swoNumber,
                                                                            java.lang.String vendorId,
                                                                            java.lang.String status,
                                                                            java.lang.String partNumber,
                                                                            java.lang.String partType,
                                                                            java.lang.String partFrom,
                                                                            java.util.Date fromDate,
                                                                            java.util.Date toDate,
                                                                            int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getSwapReceiversCount

int getSwapReceiversCount(java.lang.String swapReceiverNumber,
                          java.lang.String swapShipperNumber,
                          java.lang.String swoNumber,
                          java.lang.String vendorId,
                          java.lang.String status,
                          java.lang.String buyer,
                          java.lang.String project,
                          java.lang.String relatedDoc,
                          java.util.Date fromDate,
                          java.util.Date toDate)
                          throws java.lang.Exception
Throws:
java.lang.Exception

findSwapReceivers

java.util.Collection<SwapReceiverListResult> findSwapReceivers(java.lang.String swapReceiverNumber,
                                                               java.lang.String swapShipperNumber,
                                                               java.lang.String swoNumber,
                                                               java.lang.String vendorId,
                                                               java.lang.String status,
                                                               java.lang.String buyer,
                                                               java.lang.String project,
                                                               java.lang.String relatedDoc,
                                                               java.util.Date fromDate,
                                                               java.util.Date toDate,
                                                               int firstIndex,
                                                               int maxLength)
                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getSwapReceivingResult

ReceivingResult getSwapReceivingResult(java.lang.String swapShipperNumber)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findTransferReceiverItems

java.util.Collection<TransferReceiverItemListResult> findTransferReceiverItems(java.lang.String transferOrderNumber)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

findTransferShipperItems

java.util.Collection<TransferShipperListResult> findTransferShipperItems(java.lang.String transferOrderNumber)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

findPosAdjustLocationResult

java.util.Collection findPosAdjustLocationResult(java.lang.String locate)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findReceiversByBuyerCode

java.util.List<POReceiverItemListResult> findReceiversByBuyerCode(java.lang.String buyerCode,
                                                                  int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getReceiversByBuyerCodeCount

int getReceiversByBuyerCodeCount(java.lang.String buyerCode)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findA2PartIssuedByDate

java.util.Collection<PartIssuedListResult> findA2PartIssuedByDate(java.util.Date from,
                                                                  java.util.Date to,
                                                                  java.lang.String id,
                                                                  java.lang.String woNumber,
                                                                  java.lang.String woItemNumber,
                                                                  java.lang.String relatedDoc,
                                                                  java.lang.String picker,
                                                                  java.lang.String pnLike,
                                                                  java.lang.String paLike,
                                                                  java.lang.String orderNumber,
                                                                  java.lang.String project,
                                                                  boolean showCurrentOnhand,
                                                                  java.lang.String[] branchWarehouses,
                                                                  int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getA2PartIssuedCountByDate

int getA2PartIssuedCountByDate(java.util.Date from,
                               java.util.Date to,
                               java.lang.String id,
                               java.lang.String woNumber,
                               java.lang.String woItemNumber,
                               java.lang.String relatedDoc,
                               java.lang.String picker,
                               java.lang.String pnLike,
                               java.lang.String paLike,
                               java.lang.String orderNumber,
                               java.lang.String project,
                               java.lang.String[] branchWarehouses)
                               throws java.lang.Exception
Throws:
java.lang.Exception

findBackfulshMaterialPartOnhandResults

java.util.List findBackfulshMaterialPartOnhandResults(java.lang.String partNumber,
                                                      java.lang.String partType,
                                                      boolean onlyShowBackflushLocate,
                                                      int firstIndex,
                                                      int maxLength)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getBackflushMaterialPartOnhandResultsCount

int getBackflushMaterialPartOnhandResultsCount(java.lang.String partNumber,
                                               java.lang.String partType,
                                               boolean onlyShowBackflushLocate)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

getPartWithSTOQtyListResultsCount

int getPartWithSTOQtyListResultsCount(java.lang.String pnExp,
                                      java.lang.String paExp,
                                      boolean isTool)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

findPartWithSTOQtyListResults

java.util.Collection<PartWithSTOQtyListResult> findPartWithSTOQtyListResults(java.lang.String pnExp,
                                                                             java.lang.String paExp,
                                                                             boolean isIncludeRefDetails,
                                                                             boolean isTool,
                                                                             int firstIndex,
                                                                             int maxLength)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getPartWithSTOQtyTotal

PartWithSTOQtyListResult getPartWithSTOQtyTotal(java.lang.String pnExp,
                                                java.lang.String paExp,
                                                boolean isTool)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

getDisassembleWorkOrderReceivingResult

DisassembleWorkOrderReceivingResult getDisassembleWorkOrderReceivingResult(DisassembleWorkOrderItemPK itemPk,
                                                                           boolean withOtherLocation)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getDisassembleWorkOrderItemIssuingResult

DisassembleWorkOrderIssuingResult getDisassembleWorkOrderItemIssuingResult(java.lang.String disassembleWorkOrderNumber)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getDepartmentLocationForBackflushByPk

DepartmentLocationForBackflushVO getDepartmentLocationForBackflushByPk(java.lang.String pk)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

addDepartmentLocationForBackflush

DepartmentLocationForBackflushVO addDepartmentLocationForBackflush(DepartmentLocationForBackflushVO vo)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

deleteDepartmentLocationForBackflush

void deleteDepartmentLocationForBackflush(java.util.ArrayList<DepartmentLocationForBackflushVO> list)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

updateDepartmentLocationForBackflush

DepartmentLocationForBackflushVO updateDepartmentLocationForBackflush(DepartmentLocationForBackflushVO vo)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

findAllDepartmentLocationForBackflushs

java.util.List<DepartmentLocationForBackflushVO> findAllDepartmentLocationForBackflushs(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllDepartmentLocationForBackflushsCount

int getAllDepartmentLocationForBackflushsCount()
                                               throws java.lang.Exception
Throws:
java.lang.Exception

findNonproductivePickingTypeByKey

NonproductivePickingTypeVO findNonproductivePickingTypeByKey(int key)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

findNonproductivePickingTypeByName

NonproductivePickingTypeVO findNonproductivePickingTypeByName(java.lang.String name)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

addNonproductivePickingType

NonproductivePickingTypeVO addNonproductivePickingType(NonproductivePickingTypeVO vo)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

deleteNonproductivePickingType

void deleteNonproductivePickingType(NonproductivePickingTypeVO vo)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

updateNonproductivePickingType

NonproductivePickingTypeVO updateNonproductivePickingType(NonproductivePickingTypeVO vo)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

findAllNonproductivePickingTypes

java.util.List<NonproductivePickingTypeVO> findAllNonproductivePickingTypes(int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getAllNonproductivePickingTypesCount

int getAllNonproductivePickingTypesCount()
                                         throws java.lang.Exception
Throws:
java.lang.Exception

getNonproductivePickingApprovalByPk

NonproductivePickingApprovalVO getNonproductivePickingApprovalByPk(java.lang.String pk)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

addNonproductivePickingApproval

NonproductivePickingApprovalVO addNonproductivePickingApproval(java.lang.String employee)
                                                               throws java.lang.Exception
Throws:
java.lang.Exception

updateNonproductivePickingAprroval

NonproductivePickingApprovalVO updateNonproductivePickingAprroval(NonproductivePickingApprovalVO vo)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

deleteNonproductivePickingApproval

void deleteNonproductivePickingApproval(NonproductivePickingApprovalVO vo)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findAllNonproductivePickingApprovals

java.util.List<NonproductivePickingApprovalVO> findAllNonproductivePickingApprovals(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllNonproductivePickingApprovalsCount

int getAllNonproductivePickingApprovalsCount()
                                             throws java.lang.Exception
Throws:
java.lang.Exception

makeDisassembleWorkOrderReceiver

DisassembleWorkOrderItemPK makeDisassembleWorkOrderReceiver(java.util.Set<ReceiverItemAgent> agent)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

issuePartsToDisassembleWorkOrder

void issuePartsToDisassembleWorkOrder(IssueItemAgent issueItemAgent)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

issuePartsToDisassembleWorkOrder

java.lang.Integer issuePartsToDisassembleWorkOrder(java.util.ArrayList agents)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

findDWOIssueItems

java.util.Collection<DWOIssueDetail> findDWOIssueItems(java.lang.String disassembleWorkOrder,
                                                       java.lang.String disassembleWorkOrderItem,
                                                       java.lang.String customerId,
                                                       java.lang.String pn,
                                                       java.lang.String pa,
                                                       java.util.Date fromDate,
                                                       java.util.Date toDate,
                                                       java.lang.String accountNumber,
                                                       java.lang.String companyUnitId,
                                                       java.lang.String[] branchWarehouses,
                                                       boolean isIncludeNA,
                                                       int firstIndex,
                                                       int maxLength)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getDWOIssueItemsCount

int getDWOIssueItemsCount(java.lang.String disassembleWorkOrder,
                          java.lang.String disassembleWorkOrderItem,
                          java.lang.String customerId,
                          java.lang.String pn,
                          java.lang.String pa,
                          java.util.Date fromDate,
                          java.util.Date toDate,
                          java.lang.String accountNumber,
                          java.lang.String companyUnitId,
                          java.lang.String[] branchWarehouses,
                          boolean isIncludeNA)
                          throws java.lang.Exception
Throws:
java.lang.Exception

getDWOIssueListResultsByDwoNumber

java.util.Collection getDWOIssueListResultsByDwoNumber(java.lang.String input,
                                                       int firstIndex,
                                                       int maxLength)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getDWOIssueListResultsCountByDwoNumber

int getDWOIssueListResultsCountByDwoNumber(java.lang.String input)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

getDWOReceiverListResultsByDwoNumber

java.util.Collection getDWOReceiverListResultsByDwoNumber(java.lang.String input,
                                                          int firstIndex,
                                                          int maxLength)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getDWOReceiverListResultsCountByDwoNumber

int getDWOReceiverListResultsCountByDwoNumber(java.lang.String input)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

getPartReceivedTotalResult

PartReceivedListResult getPartReceivedTotalResult(java.util.Date from,
                                                  java.util.Date to,
                                                  java.lang.String id,
                                                  java.lang.String dwoNumber,
                                                  java.lang.String dwoItemNumber,
                                                  java.lang.String relatedDoc,
                                                  java.lang.String pnLike,
                                                  java.lang.String paLike,
                                                  java.lang.String receiverNumber,
                                                  java.lang.String project,
                                                  java.lang.String[] branchWarehouses)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

findPartReceivedByDate

java.util.Collection<PartReceivedListResult> findPartReceivedByDate(java.util.Date from,
                                                                    java.util.Date to,
                                                                    java.lang.String id,
                                                                    java.lang.String woNumber,
                                                                    java.lang.String woItemNumber,
                                                                    java.lang.String relatedDoc,
                                                                    java.lang.String pnLike,
                                                                    java.lang.String paLike,
                                                                    java.lang.String receiverNumber,
                                                                    java.lang.String project,
                                                                    boolean showCurrentOnhand,
                                                                    java.lang.String[] branchWarehouses,
                                                                    int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getPartReceivedCountByDate

int getPartReceivedCountByDate(java.util.Date from,
                               java.util.Date to,
                               java.lang.String id,
                               java.lang.String woNumber,
                               java.lang.String woItemNumber,
                               java.lang.String relatedDoc,
                               java.lang.String pnLike,
                               java.lang.String paLike,
                               java.lang.String receiverNumber,
                               java.lang.String project,
                               java.lang.String[] branchWarehouses)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getNonproductivePickingByPk

NonproductivePickingVO getNonproductivePickingByPk(java.lang.String pickingNumber)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

addNonproductivePicking

NonproductivePickingVO addNonproductivePicking(NonproductivePickingVO vo)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

updateNonproductivePicking

void updateNonproductivePicking(NonproductivePickingVO vo)
                                throws java.lang.Exception
Throws:
java.lang.Exception

approveNonproductivePicking

NonproductivePickingVO approveNonproductivePicking(NonproductivePickingVO vo)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

findNonproductivePickings

java.util.Collection<NonproductivePickingVO> findNonproductivePickings(java.lang.String pickingNumber,
                                                                       java.lang.String status,
                                                                       java.lang.String id,
                                                                       java.lang.String orderType,
                                                                       java.util.Date fromDate,
                                                                       java.util.Date toDate,
                                                                       java.lang.String project,
                                                                       int firstIndex,
                                                                       int maxLength)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getNonproductivePickingsCount

int getNonproductivePickingsCount(java.lang.String pickingNumber,
                                  java.lang.String status,
                                  java.lang.String id,
                                  java.lang.String orderType,
                                  java.util.Date fromDate,
                                  java.util.Date toDate,
                                  java.lang.String project)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findNonproductivePickingItemResults

java.util.Collection<NonproductivePickingItemResult> findNonproductivePickingItemResults(java.lang.String pickingNumber,
                                                                                java.lang.String status,
                                                                                java.lang.String id,
                                                                                java.lang.String orderType,
                                                                                java.util.Date fromDate,
                                                                                java.util.Date toDate,
                                                                                java.lang.String partNumber,
                                                                                java.lang.String partType,
                                                                                java.lang.String partFrom,
                                                                                java.lang.String project,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getNonproductivePickingItemResultsCount

int getNonproductivePickingItemResultsCount(java.lang.String pickingNumber,
                                            java.lang.String status,
                                            java.lang.String id,
                                            java.lang.String orderType,
                                            java.util.Date fromDate,
                                            java.util.Date toDate,
                                            java.lang.String partNumber,
                                            java.lang.String partType,
                                            java.lang.String partFrom,
                                            java.lang.String project)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

InitNonproductivePickingItem

NonproductivePickingItemVO InitNonproductivePickingItem(NonproductivePickingVO vo,
                                                        BB2Part part,
                                                        java.math.BigDecimal quantity)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

findNeedCycleCountParts

java.util.Collection<java.util.Map> findNeedCycleCountParts(java.util.ArrayList<AuditOnDemandResult> audits,
                                                            int firstIndex,
                                                            int maxLength)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getNeedCycleCountPartsCount

int getNeedCycleCountPartsCount(java.util.ArrayList<AuditOnDemandResult> audits)
                                throws java.lang.Exception
Throws:
java.lang.Exception

takeInitCycleCount

int takeInitCycleCount(java.util.Collection<java.util.Map> datas,
                       int top,
                       int workSheetNumber,
                       java.lang.String description,
                       java.lang.String orderBy,
                       boolean zerolocation,
                       boolean zeroPhysicalCount)
                       throws java.lang.Exception
Throws:
java.lang.Exception

getNonproductivePickingShippingResult

ShippingResult getNonproductivePickingShippingResult(java.lang.String pickingNumber)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

findNonproductivePickingItemIssuedList

java.util.Collection<NonproductivePickingItemIssuedListResult> findNonproductivePickingItemIssuedList(java.lang.String monthYear,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getNonproductivePickingItemIssuedTotal

BB2DoubleCost getNonproductivePickingItemIssuedTotal(java.lang.String monthYear)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

makeNonproductivePickingShipper

java.lang.Integer makeNonproductivePickingShipper(ShipperAgent agent)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

findNonproductivePickingIssuedItems

java.util.List findNonproductivePickingIssuedItems(java.util.Date from,
                                                   java.util.Date to,
                                                   java.lang.String id,
                                                   java.lang.String npNumber,
                                                   java.lang.String npItemNumber,
                                                   java.lang.String pnLike,
                                                   java.lang.String paLike,
                                                   java.lang.String pfLike,
                                                   java.lang.String orderNumber,
                                                   java.lang.String[] branchWarehouses,
                                                   java.lang.String project,
                                                   int firstIndex,
                                                   int maxLength)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getNonproductivePickingIssuedItemsCount

int getNonproductivePickingIssuedItemsCount(java.util.Date from,
                                            java.util.Date to,
                                            java.lang.String id,
                                            java.lang.String npNumber,
                                            java.lang.String npItemNumber,
                                            java.lang.String pnLike,
                                            java.lang.String paLike,
                                            java.lang.String pfLike,
                                            java.lang.String orderNumber,
                                            java.lang.String[] branchWarehouses,
                                            java.lang.String project)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

getNonproductivePickingIssueTotalResult

PartIssueTotalResult getNonproductivePickingIssueTotalResult(java.util.Date from,
                                                             java.util.Date to,
                                                             java.lang.String id,
                                                             java.lang.String npNumber,
                                                             java.lang.String npItemNumber,
                                                             java.lang.String pnLike,
                                                             java.lang.String paLike,
                                                             java.lang.String orderNumber,
                                                             java.lang.String[] branchWarehouses,
                                                             java.lang.String project)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

makePhysicalInventoryGL

java.lang.String makePhysicalInventoryGL(java.math.BigDecimal commitTotal,
                                         java.util.ArrayList<PhysicalInventoryListResult> result,
                                         java.lang.String glCategory,
                                         java.lang.String[] inventoryAccount,
                                         java.lang.String[] assetLossesAccount)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

findLocationInventoryReport

java.util.Collection<InventoryMonthReport> findLocationInventoryReport(java.util.Date startDate,
                                                                       java.util.Date endDate,
                                                                       java.lang.String partNumber,
                                                                       java.lang.String partType,
                                                                       java.lang.String location,
                                                                       int firstIndex,
                                                                       int maxLength)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getLocationInventoryReportCount

int getLocationInventoryReportCount(java.util.Date startDate,
                                    java.util.Date endDate,
                                    java.lang.String partNumber,
                                    java.lang.String partType,
                                    java.lang.String location)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

getLocationInventoryReportTotal

InventoryMonthReport getLocationInventoryReportTotal(java.util.Date startDate,
                                                     java.util.Date endDate,
                                                     java.lang.String partNumber,
                                                     java.lang.String partType,
                                                     java.lang.String location)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getTransferReceiverItemByPk

TransferReceiverItemVO getTransferReceiverItemByPk(TransferReceiverItemPK pk)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getRMAReceiverItemByPk

RMAReceiverItemVO getRMAReceiverItemByPk(RMAReceiverItemPK pk)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

getSwapReceiverItemByPk

SwapReceiverItemVO getSwapReceiverItemByPk(SwapReceiverItemPK pk)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

getOnloanReceiverItemByPk

OnloanReceiverItemVO getOnloanReceiverItemByPk(OnloanReceiverItemPK pk)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

getRtvShipperItemByPk

RtvShipperItemVO getRtvShipperItemByPk(RtvShipperItemPK pk)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

getSwapShipperItemByPk

SwapShipperItemVO getSwapShipperItemByPk(SwapShipperItemPK pk)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

getTransferShipperItemByPk

TransferShipperItemVO getTransferShipperItemByPk(TransferShipperItemPK pk)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getOnloanShipperItemByPK

OnloanShipperItemVO getOnloanShipperItemByPK(OnloanShipperItemPK pk)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findIssuedPartTotal

java.util.ArrayList<WorkOrderItemIssuedTotalResult> findIssuedPartTotal(WorkOrderItemPK pk,
                                                                        PartPK partPk,
                                                                        java.lang.String relatedDoc,
                                                                        java.lang.String modelNumber,
                                                                        java.lang.String common,
                                                                        java.lang.String dateType,
                                                                        java.util.Date dateFrom,
                                                                        java.util.Date dateTo,
                                                                        int firstIndex,
                                                                        int maxLength)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getIssuedPartTotalCount

int getIssuedPartTotalCount(WorkOrderItemPK pk,
                            PartPK partPk,
                            java.lang.String relatedDoc,
                            java.lang.String modelNumber,
                            java.lang.String common,
                            java.lang.String dateType,
                            java.util.Date dateFrom,
                            java.util.Date dateTo)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findPhysicalInventoryListResultsForSpecificWarehouse

java.util.List findPhysicalInventoryListResultsForSpecificWarehouse(int worksheetNumber,
                                                                    int pageNubmer,
                                                                    java.lang.String pnLike,
                                                                    java.lang.String partType,
                                                                    java.lang.String location,
                                                                    java.lang.String countedBy,
                                                                    java.lang.String showUnCommittedOnly,
                                                                    int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

findInventoryNotUsedInMonthsResultsforApp

java.util.List findInventoryNotUsedInMonthsResultsforApp(java.util.Date toDate,
                                                         int firstIndex,
                                                         int maxLength)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getInventoryNotUsedInMonthsResultsforAppCount

int getInventoryNotUsedInMonthsResultsforAppCount(java.util.Date toDate)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

findOnhandQualityStatue

java.util.List findOnhandQualityStatue(java.util.Date date)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

findInventoryListWithMinAndMaxQty

java.util.Collection<InventoryListResult> findInventoryListWithMinAndMaxQty(java.lang.String productCode,
                                                                            java.util.Date fromDate,
                                                                            java.util.Date toDate,
                                                                            int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getInventoryListResultCountOnlyWithMinAndMaxQty

int getInventoryListResultCountOnlyWithMinAndMaxQty(java.lang.String productCode)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

findInventoryTotalByProductCode

java.util.Collection<InventoryListResult> findInventoryTotalByProductCode(java.lang.String productCode,
                                                                          int firstIndex,
                                                                          int length)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getInventoryTotalCountByProductCode

int getInventoryTotalCountByProductCode(java.lang.String productCode)
                                        throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WareHousePartPrefixKeeperVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WareHousePartPrefixKeeperVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.WareHousePartPrefixKeeperVO
All Implemented Interfaces:
java.io.Serializable
public class WareHousePartPrefixKeeperVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WareHousePartPrefixKeeperVO()
Method Summary
java.lang.String | getDescription()
java.lang.String | getDistrict()
java.lang.String | getKeeper()
java.lang.String | getPartPrefix()
java.lang.String | getWarehouseName()
void | setDescription(java.lang.String description)
void | setDistrict(java.lang.String district)
void | setKeeper(java.lang.String keeper)
void | setPartPrefix(java.lang.String partPrefix)
void | setWarehouseName(java.lang.String warehouseName)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WareHousePartPrefixKeeperVO

public WareHousePartPrefixKeeperVO()
Method Detail

getWarehouseName

public java.lang.String getWarehouseName()

setWarehouseName

public void setWarehouseName(java.lang.String warehouseName)

getDistrict

public java.lang.String getDistrict()

setDistrict

public void setDistrict(java.lang.String district)

getPartPrefix

public java.lang.String getPartPrefix()

setPartPrefix

public void setPartPrefix(java.lang.String partPrefix)

getKeeper

public java.lang.String getKeeper()

setKeeper

public void setKeeper(java.lang.String keeper)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WarehouseTransferPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WarehouseTransferPK

java.lang.Object
    extended by  bb.common.WarehouseTransferPK
All Implemented Interfaces:
java.io.Serializable
public class WarehouseTransferPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WarehouseTransferPK()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getWarehousePrefix()
java.lang.String | getWarehousePrefixTransferTo()
int | hashCode()
void | setWarehousePrefix(java.lang.String warehousePrefix)
void | setWarehousePrefixTransferTo(java.lang.String warehousePrefixTransferTo)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WarehouseTransferPK

public WarehouseTransferPK()
Method Detail

getWarehousePrefix

public java.lang.String getWarehousePrefix()

setWarehousePrefix

public void setWarehousePrefix(java.lang.String warehousePrefix)

getWarehousePrefixTransferTo

public java.lang.String getWarehousePrefixTransferTo()

setWarehousePrefixTransferTo

public void setWarehousePrefixTransferTo(java.lang.String warehousePrefixTransferTo)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WarehouseTransferVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WarehouseTransferVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.WarehouseTransferVO
All Implemented Interfaces:
java.io.Serializable
public class WarehouseTransferVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WarehouseTransferVO()
Method Summary
boolean | equals(java.lang.Object other)
WarehouseTransferPK | getPk()
int | hashCode()
void | setPk(WarehouseTransferPK pk)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WarehouseTransferVO

public WarehouseTransferVO()
Method Detail

getPk

public WarehouseTransferPK getPk()

setPk

public void setPk(WarehouseTransferPK pk)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WarehouseVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WarehouseVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.WarehouseVO
All Implemented Interfaces:
java.io.Serializable
public class WarehouseVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_COMMENTS
static java.lang.String | ORDER_BY_NAME
static java.lang.String | ORDER_BY_WAREHOUSEPREFIX
Constructor Summary
WarehouseVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.lang.String | getComments()
java.util.Set<WarehouseTransferVO> | getItems()
java.util.Date | getLastChangeDate()
int | getLastChangeTimes()
java.lang.String | getLastChangeUser()
java.lang.String | getName()
java.lang.String | getOrigin()
java.lang.String | getWarehousePrefix()
int | hashCode()
void | setAdate(java.util.Date adate)
void | setComments(java.lang.String comments)
void | setItems(java.util.Set<WarehouseTransferVO> items)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTimes(int lastChangeTimes)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setName(java.lang.String name)
void | setOrigin(java.lang.String origin)
void | setWarehousePrefix(java.lang.String warehousePrefix)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_WAREHOUSEPREFIX

public static final java.lang.String ORDER_BY_WAREHOUSEPREFIX
See Also:
Constant Field Values

ORDER_BY_NAME

public static final java.lang.String ORDER_BY_NAME
See Also:
Constant Field Values

ORDER_BY_COMMENTS

public static final java.lang.String ORDER_BY_COMMENTS
See Also:
Constant Field Values
Constructor Detail

WarehouseVO

public WarehouseVO()
Method Detail

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getWarehousePrefix

public java.lang.String getWarehousePrefix()

setWarehousePrefix

public void setWarehousePrefix(java.lang.String warehousePrefix)

getItems

public java.util.Set<WarehouseTransferVO> getItems()

setItems

public void setItems(java.util.Set<WarehouseTransferVO> items)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeTimes

public int getLastChangeTimes()

setLastChangeTimes

public void setLastChangeTimes(int lastChangeTimes)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WareHousingInfoCenterResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WareHousingInfoCenterResult

java.lang.Object
    extended by  bb.common.WareHousingInfoCenterResult
All Implemented Interfaces:
java.io.Serializable
public class WareHousingInfoCenterResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WareHousingInfoCenterResult()
Method Summary
java.lang.Integer | getCurrentMonthReceiverCount()
java.lang.Integer | getCurrentMonthReceiverItemCount()
java.lang.Integer | getCurrentMonthShipperCount()
java.lang.Integer | getCurrentMonthShipperItemCount()
java.lang.Integer | getDueSOCount()
java.lang.Integer | getFyReceiverCount()
java.lang.Integer | getFyShippperCount()
java.lang.Integer | getInSipCount()
Money | getInSipTotal()
java.lang.Integer | getInSitCount()
Money | getInSitTotal()
java.lang.Integer | getSoWithPartOnHoldCount()
java.lang.Integer | getYtdReceiverCount()
java.lang.Integer | getYtdShipperCount()
void | setCurrentMonthReceiverCount(java.lang.Integer currentMonthReceiverCount)
void | setCurrentMonthReceiverItemCount(java.lang.Integer currentMonthReceiverItemCount)
void | setCurrentMonthShipperCount(java.lang.Integer currentMonthShipperCount)
void | setCurrentMonthShipperItemCount(java.lang.Integer currentMonthShipperItemCount)
void | setDueSOCount(java.lang.Integer dueSOCount)
void | setFyReceiverCount(java.lang.Integer fyReceiverCount)
void | setFyShippperCount(java.lang.Integer fyShippperCount)
void | setInSipCount(java.lang.Integer inSipCount)
void | setInSipTotal(Money inSipTotal)
void | setInSitCount(java.lang.Integer inSitCount)
void | setInSitTotal(Money inSitTotal)
void | setSoWithPartOnHoldCount(java.lang.Integer soWithPartOnHoldCount)
void | setYtdReceiverCount(java.lang.Integer ytdReceiverCount)
void | setYtdShipperCount(java.lang.Integer ytdShipperCount)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WareHousingInfoCenterResult

public WareHousingInfoCenterResult()
Method Detail

setCurrentMonthShipperCount

public void setCurrentMonthShipperCount(java.lang.Integer currentMonthShipperCount)

setCurrentMonthShipperItemCount

public void setCurrentMonthShipperItemCount(java.lang.Integer currentMonthShipperItemCount)

setCurrentMonthReceiverCount

public void setCurrentMonthReceiverCount(java.lang.Integer currentMonthReceiverCount)

setCurrentMonthReceiverItemCount

public void setCurrentMonthReceiverItemCount(java.lang.Integer currentMonthReceiverItemCount)

setDueSOCount

public void setDueSOCount(java.lang.Integer dueSOCount)

setSoWithPartOnHoldCount

public void setSoWithPartOnHoldCount(java.lang.Integer soWithPartOnHoldCount)

setFyShippperCount

public void setFyShippperCount(java.lang.Integer fyShippperCount)

setFyReceiverCount

public void setFyReceiverCount(java.lang.Integer fyReceiverCount)

setYtdShipperCount

public void setYtdShipperCount(java.lang.Integer ytdShipperCount)

setYtdReceiverCount

public void setYtdReceiverCount(java.lang.Integer ytdReceiverCount)

setInSipCount

public void setInSipCount(java.lang.Integer inSipCount)

setInSipTotal

public void setInSipTotal(Money inSipTotal)

setInSitCount

public void setInSitCount(java.lang.Integer inSitCount)

setInSitTotal

public void setInSitTotal(Money inSitTotal)

getCurrentMonthShipperCount

public java.lang.Integer getCurrentMonthShipperCount()

getCurrentMonthShipperItemCount

public java.lang.Integer getCurrentMonthShipperItemCount()

getCurrentMonthReceiverCount

public java.lang.Integer getCurrentMonthReceiverCount()

getCurrentMonthReceiverItemCount

public java.lang.Integer getCurrentMonthReceiverItemCount()

getDueSOCount

public java.lang.Integer getDueSOCount()

getSoWithPartOnHoldCount

public java.lang.Integer getSoWithPartOnHoldCount()

getFyShippperCount

public java.lang.Integer getFyShippperCount()

getFyReceiverCount

public java.lang.Integer getFyReceiverCount()

getYtdShipperCount

public java.lang.Integer getYtdShipperCount()

getYtdReceiverCount

public java.lang.Integer getYtdReceiverCount()

getInSipCount

public java.lang.Integer getInSipCount()

getInSipTotal

public Money getInSipTotal()

getInSitCount

public java.lang.Integer getInSitCount()

getInSitTotal

public Money getInSitTotal()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WC2WCAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WC2WCAgent

java.lang.Object
    extended by  bb.common.WC2WCAgent
All Implemented Interfaces:
java.io.Serializable
public class WC2WCAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WC2WCAgent()
Method Summary
java.lang.String | getDescription()
java.lang.String | getOldWorkCenterId()
java.lang.String | getWorkCenterId()
void | setDescription(java.lang.String description)
void | setOldWorkCenterId(java.lang.String oldWorkCenterId)
void | setWorkCenterId(java.lang.String workCenterId)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WC2WCAgent

public WC2WCAgent()
Method Detail

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getOldWorkCenterId

public java.lang.String getOldWorkCenterId()

setOldWorkCenterId

public void setOldWorkCenterId(java.lang.String oldWorkCenterId)

getWorkCenterId

public java.lang.String getWorkCenterId()

setWorkCenterId

public void setWorkCenterId(java.lang.String workCenterId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WCLoadAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WCLoadAgent

java.lang.Object
    extended by  bb.common.WCLoadAgent
All Implemented Interfaces:
java.io.Serializable
public class WCLoadAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WCLoadAgent()
WCLoadAgent(WorkCenterAgent agent)
Method Summary
void | addItem(WorkCenterAgent agent)
void | addItems(java.util.Collection<WorkCenterAgent> items)
void | clearItems()
WCLoadAgent | copyWith(WorkCenterAgent item)
java.util.Date | getFDate()
java.util.Iterator<WorkCenterAgent> | getItems()
int | getNdays()
java.util.Date | getTDate()
WorkCenterAgent | getWorkCenterAgent()
WorkCenterAgent | getWorkCenterAgent(java.lang.String wcID)
boolean | isEmpty()
void | removeItem(java.lang.String wcID)
void | setFDate(java.util.Date date)
void | setTDate(java.util.Date date)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WCLoadAgent

public WCLoadAgent()

WCLoadAgent

public WCLoadAgent(WorkCenterAgent agent)
Method Detail

getFDate

public java.util.Date getFDate()

getTDate

public java.util.Date getTDate()

setFDate

public void setFDate(java.util.Date date)

setTDate

public void setTDate(java.util.Date date)

getNdays

public int getNdays()

addItem

public void addItem(WorkCenterAgent agent)

addItems

public void addItems(java.util.Collection<WorkCenterAgent> items)

getItems

public java.util.Iterator<WorkCenterAgent> getItems()

getWorkCenterAgent

public WorkCenterAgent getWorkCenterAgent()

isEmpty

public boolean isEmpty()

clearItems

public void clearItems()

removeItem

public void removeItem(java.lang.String wcID)

getWorkCenterAgent

public WorkCenterAgent getWorkCenterAgent(java.lang.String wcID)

copyWith

public WCLoadAgent copyWith(WorkCenterAgent item)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WCLoadByDateResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WCLoadByDateResult

java.lang.Object
    extended by  bb.common.WCLoadByDateResult
All Implemented Interfaces:
java.io.Serializable
public class WCLoadByDateResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WCLoadByDateResult()
Method Summary
java.lang.String | getDescription()
java.util.Date | getEndDate()
java.math.BigDecimal | getEstSetup()
BB2Part | getPart()
WorkOrderWorkInstructionSequencePK | getPk()
java.util.Date | getStartDate()
java.util.Set | getTimePeriod()
java.lang.String | getWorkCenterId()
void | setDescription(java.lang.String description)
void | setEndDate(java.util.Date endDate)
void | setEstSetup(java.math.BigDecimal estSetup)
void | setPart(BB2Part part)
void | setPk(WorkOrderWorkInstructionSequencePK pk)
void | setStartDate(java.util.Date startDate)
void | setTimePeriod(java.util.Set timePeriod)
void | setWorkCenterId(java.lang.String workCenterId)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WCLoadByDateResult

public WCLoadByDateResult()
Method Detail

getPart

public BB2Part getPart()

setPart

public void setPart(BB2Part part)

getStartDate

public java.util.Date getStartDate()

setStartDate

public void setStartDate(java.util.Date startDate)

getEndDate

public java.util.Date getEndDate()

setEndDate

public void setEndDate(java.util.Date endDate)

getEstSetup

public java.math.BigDecimal getEstSetup()

setEstSetup

public void setEstSetup(java.math.BigDecimal estSetup)

getPk

public WorkOrderWorkInstructionSequencePK getPk()

setPk

public void setPk(WorkOrderWorkInstructionSequencePK pk)

getTimePeriod

public java.util.Set getTimePeriod()

setTimePeriod

public void setTimePeriod(java.util.Set timePeriod)

getWorkCenterId

public java.lang.String getWorkCenterId()

setWorkCenterId

public void setWorkCenterId(java.lang.String workCenterId)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WCLoadDetailResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WCLoadDetailResult

java.lang.Object
    extended by  bb.common.WCLoadDetailResult
All Implemented Interfaces:
java.io.Serializable
public class WCLoadDetailResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WCLoadDetailResult()
Method Summary
java.util.Date | getDelivery()
java.lang.String | getDescription()
java.util.Date | getFinishDateOfSeqWithPOBefore()
java.math.BigDecimal | getFinishPercent()
java.math.BigDecimal | getHours()
java.math.BigDecimal | getIssuedRate()
java.lang.String | getItemNumber()
java.math.BigDecimal | getNotAsmQty()
int | getNotCompletedSeqBefore()
int | getNotCompletedSeqWithPOBefore()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getQtyToAsm()
java.util.Date | getSeqActualBeginDate()
java.util.Date | getSeqActualFinishedDate()
java.util.Date | getSeqEndDate()
java.lang.String | getSeqNumber()
java.util.Date | getSeqStartDate()
java.lang.String | getSeqWC()
java.math.BigDecimal | getSetup()
java.util.Date | getStartDate()
java.math.BigDecimal | getTotal()
java.math.BigDecimal | getTotalNotCompletedSeqBefore()
java.lang.String | getWoNumber()
java.lang.String | getWorkCenter()
boolean | isFinished()
boolean | isRunning()
void | setDelivery(java.util.Date delivery)
void | setDescription(java.lang.String description)
void | setFinishDateOfSeqWithPOBefore(java.util.Date finishDateOfSeqWithPOBefore)
void | setFinished(boolean finished)
void | setFinishPercent(java.math.BigDecimal finishPercent)
void | setHours(java.math.BigDecimal hours)
void | setIssuedRate(java.math.BigDecimal issuedRate)
void | setItemNumber(java.lang.String itemNumber)
void | setNotAsmQty(java.math.BigDecimal notAsmQty)
void | setNotCompletedSeqBefore(int notCompletedSeqBefore)
void | setNotCompletedSeqWithPOBefore(int notCompletedSeqWithPOBefore)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setQtyToAsm(java.math.BigDecimal qtyToAsm)
void | setRunning(boolean running)
void | setSeqActualBeginDate(java.util.Date seqActualBeginDate)
void | setSeqActualFinishedDate(java.util.Date seqActualFinishedDate)
void | setSeqEndDate(java.util.Date seqEndDate)
void | setSeqNumber(java.lang.String seqNumber)
void | setSeqStartDate(java.util.Date seqStartDate)
void | setSeqWC(java.lang.String seqWC)
void | setSetup(java.math.BigDecimal setup)
void | setStartDate(java.util.Date startDate)
void | setTotal(java.math.BigDecimal total)
void | setTotalNotCompletedSeqBefore(java.math.BigDecimal totalNotCompletedSeqBefore)
void | setWoNumber(java.lang.String woNumber)
void | setWorkCenter(java.lang.String workCenter)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WCLoadDetailResult

public WCLoadDetailResult()
Method Detail

isFinished

public boolean isFinished()

setFinished

public void setFinished(boolean finished)

getWoNumber

public java.lang.String getWoNumber()

getItemNumber

public java.lang.String getItemNumber()

getPartNumber

public java.lang.String getPartNumber()

getPartType

public java.lang.String getPartType()

getPartFrom

public java.lang.String getPartFrom()

getDescription

public java.lang.String getDescription()

getWorkCenter

public java.lang.String getWorkCenter()

getSeqNumber

public java.lang.String getSeqNumber()

getNotAsmQty

public java.math.BigDecimal getNotAsmQty()

getStartDate

public java.util.Date getStartDate()

getDelivery

public java.util.Date getDelivery()

getSetup

public java.math.BigDecimal getSetup()

getHours

public java.math.BigDecimal getHours()

getTotal

public java.math.BigDecimal getTotal()

getQtyToAsm

public java.math.BigDecimal getQtyToAsm()

getIssuedRate

public java.math.BigDecimal getIssuedRate()

getTotalNotCompletedSeqBefore

public java.math.BigDecimal getTotalNotCompletedSeqBefore()

getNotCompletedSeqBefore

public int getNotCompletedSeqBefore()

getNotCompletedSeqWithPOBefore

public int getNotCompletedSeqWithPOBefore()

getFinishDateOfSeqWithPOBefore

public java.util.Date getFinishDateOfSeqWithPOBefore()

setWoNumber

public void setWoNumber(java.lang.String woNumber)

setItemNumber

public void setItemNumber(java.lang.String itemNumber)

setPartNumber

public void setPartNumber(java.lang.String partNumber)

setPartType

public void setPartType(java.lang.String partType)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setDescription

public void setDescription(java.lang.String description)

setWorkCenter

public void setWorkCenter(java.lang.String workCenter)

setSeqNumber

public void setSeqNumber(java.lang.String seqNumber)

setNotAsmQty

public void setNotAsmQty(java.math.BigDecimal notAsmQty)

setStartDate

public void setStartDate(java.util.Date startDate)

setDelivery

public void setDelivery(java.util.Date delivery)

setSetup

public void setSetup(java.math.BigDecimal setup)

setHours

public void setHours(java.math.BigDecimal hours)

setTotal

public void setTotal(java.math.BigDecimal total)

setQtyToAsm

public void setQtyToAsm(java.math.BigDecimal qtyToAsm)

setIssuedRate

public void setIssuedRate(java.math.BigDecimal issuedRate)

setTotalNotCompletedSeqBefore

public void setTotalNotCompletedSeqBefore(java.math.BigDecimal totalNotCompletedSeqBefore)

setNotCompletedSeqBefore

public void setNotCompletedSeqBefore(int notCompletedSeqBefore)

setNotCompletedSeqWithPOBefore

public void setNotCompletedSeqWithPOBefore(int notCompletedSeqWithPOBefore)

setFinishDateOfSeqWithPOBefore

public void setFinishDateOfSeqWithPOBefore(java.util.Date finishDateOfSeqWithPOBefore)

getSeqWC

public java.lang.String getSeqWC()

setSeqWC

public void setSeqWC(java.lang.String seqWC)

isRunning

public boolean isRunning()

setRunning

public void setRunning(boolean running)

getFinishPercent

public java.math.BigDecimal getFinishPercent()

setFinishPercent

public void setFinishPercent(java.math.BigDecimal finishPercent)

getSeqActualBeginDate

public java.util.Date getSeqActualBeginDate()

setSeqActualBeginDate

public void setSeqActualBeginDate(java.util.Date seqActualBeginDate)

getSeqActualFinishedDate

public java.util.Date getSeqActualFinishedDate()

setSeqActualFinishedDate

public void setSeqActualFinishedDate(java.util.Date seqActualFinishedDate)

getSeqEndDate

public java.util.Date getSeqEndDate()

setSeqEndDate

public void setSeqEndDate(java.util.Date seqEndDate)

getSeqStartDate

public java.util.Date getSeqStartDate()

setSeqStartDate

public void setSeqStartDate(java.util.Date seqStartDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WCLoadOnDateResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WCLoadOnDateResult

java.lang.Object
    extended by  bb.common.WCLoadOnDateResult
All Implemented Interfaces:
java.io.Serializable
public class WCLoadOnDateResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WCLoadOnDateResult()
Method Summary
java.util.Set<WCLoadByDateResult> | getSet()
java.util.Set | getTimePeriod()
java.lang.String | getWorkTime()
void | setSet(java.util.Set<WCLoadByDateResult> set)
void | setTimePeriod(java.util.Set timePeriod)
void | setWorkTime(java.lang.String workTime)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WCLoadOnDateResult

public WCLoadOnDateResult()
Method Detail

getTimePeriod

public java.util.Set getTimePeriod()

setTimePeriod

public void setTimePeriod(java.util.Set timePeriod)

getWorkTime

public java.lang.String getWorkTime()

setWorkTime

public void setWorkTime(java.lang.String workTime)

getSet

public java.util.Set<WCLoadByDateResult> getSet()

setSet

public void setSet(java.util.Set<WCLoadByDateResult> set)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WeightUnitVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WeightUnitVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.WeightUnitVO
All Implemented Interfaces:
java.io.Serializable
public class WeightUnitVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_kg
static java.lang.String | ORDER_BY_lbs
static java.lang.String | ORDER_BY_weightUnitName
Constructor Summary
WeightUnitVO()
default constructor
WeightUnitVO(java.lang.String weightUnitName, double kg, double lbs)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
double | getKg()
double | getLbs()
java.lang.String | getWeightUnitName()
int | hashCode()
void | setKg(double kg)
void | setLbs(double lbs)
void | setWeightUnitName(java.lang.String weightUnitName)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_weightUnitName

public static final java.lang.String ORDER_BY_weightUnitName
See Also:
Constant Field Values

ORDER_BY_kg

public static final java.lang.String ORDER_BY_kg
See Also:
Constant Field Values

ORDER_BY_lbs

public static final java.lang.String ORDER_BY_lbs
See Also:
Constant Field Values
Constructor Detail

WeightUnitVO

public WeightUnitVO(java.lang.String weightUnitName,
                    double kg,
                    double lbs)
full constructor

WeightUnitVO

public WeightUnitVO()
default constructor

Method Detail

getWeightUnitName

public java.lang.String getWeightUnitName()

setWeightUnitName

public void setWeightUnitName(java.lang.String weightUnitName)

getKg

public double getKg()

setKg

public void setKg(double kg)

getLbs

public double getLbs()

setLbs

public void setLbs(double lbs)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


W-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M N O P Q R S T U V W X Y Z

W

W - Static variable in class bb.common.Constant.Prefix
WAC - Static variable in class bb.common.Constant.InventoryCostMothed
Waiting - Static variable in class bb.common.Constant.Status
WAREHOUSE - Static variable in class bb.common.BizTarget
WAREHOUSE - Static variable in class bb.common.Configure.Module
WareHouse - Static variable in class bb.common.Constant.IssuedFrom
WareHouse - Static variable in class bb.common.Constant.ReceivedTo
WarehouseBox - Interface in bb.common.box
WareHousePartPrefixKeeperVO - Class in bb.common
WareHousePartPrefixKeeperVO() - Constructor for class bb.common.WareHousePartPrefixKeeperVO
WarehouseTransferPK - Class in bb.common
WarehouseTransferPK() - Constructor for class bb.common.WarehouseTransferPK
WarehouseTransferVO - Class in bb.common
WarehouseTransferVO() - Constructor for class bb.common.WarehouseTransferVO
WarehouseVO - Class in bb.common
WarehouseVO() - Constructor for class bb.common.WarehouseVO
WareHousingInfoCenterResult - Class in bb.common
WareHousingInfoCenterResult() - Constructor for class bb.common.WareHousingInfoCenterResult
WC2WCAgent - Class in bb.common
WC2WCAgent() - Constructor for class bb.common.WC2WCAgent
WCLoadAgent - Class in bb.common
WCLoadAgent() - Constructor for class bb.common.WCLoadAgent
WCLoadAgent(WorkCenterAgent) - Constructor for class bb.common.WCLoadAgent
WCLoadByDateResult - Class in bb.common
WCLoadByDateResult() - Constructor for class bb.common.WCLoadByDateResult
WCLoadDetailResult - Class in bb.common
WCLoadDetailResult() - Constructor for class bb.common.WCLoadDetailResult
WCLoadOnDateResult - Class in bb.common
WCLoadOnDateResult() - Constructor for class bb.common.WCLoadOnDateResult
Web - Static variable in class bb.common.Constant.LoginType
WEEK - Static variable in class bb.common.Constant.CycleCountPeriodUnit
WEEK - Static variable in class bb.common.Constant.PeriodUnit
WEIGHT_UNIT - Static variable in class bb.common.BizTarget
WEIGHT_UNIT_NOT_EXIST - Static variable in class bb.common.BIZReason
WeightUnitVO - Class in bb.common
WeightUnitVO(String, double, double) - Constructor for class bb.common.WeightUnitVO
full constructor
WeightUnitVO() - Constructor for class bb.common.WeightUnitVO
default constructor
WI_DOC - Static variable in class bb.common.Constant.MiscDocType
WI_PICTURE - Static variable in class bb.common.Constant.MiscDocType
WIP_PHYSICAL_WORK_SHEET - Static variable in class bb.common.BizTarget
WireTransferAgent - Class in bb.common
WireTransferAgent() - Constructor for class bb.common.WireTransferAgent
WiSequence - Static variable in class bb.common.Constant
WITHOUT_IRNUMBER - Static variable in class bb.common.BIZReason
WITHOUT_RECEIVER_ITEM_DETAILS - Static variable in class bb.common.BIZReason
WITHOUT_SUCH_METHOD - Static variable in class bb.common.BIZReason
WithoutParent - Static variable in class bb.common.Constant.WorkCenterSearchType
WithoutParentAndNotGroup - Static variable in class bb.common.Constant.WorkCenterSearchType
WO - Static variable in class bb.common.Constant.Prefix
WO - Static variable in class bb.common.Constant.PrintTemplateType
WO2WOAgent - Class in bb.common
WO2WOAgent() - Constructor for class bb.common.WO2WOAgent
WO_APPROVED_BY_CAN_NOT_BE_EMPTY - Static variable in class bb.common.BIZReason
WO_DOC - Static variable in class bb.common.Constant.MiscDocType
WO_SYSTEM_GL_TYPE_CAN_NOT_BE_EMPTY - Static variable in class bb.common.BIZReason
WODATE - Static variable in class bb.common.Constant.DateType
WOIssuedByMonthChartResult - Class in bb.common
WOIssuedByMonthChartResult() - Constructor for class bb.common.WOIssuedByMonthChartResult
WOIssuedByMonthResult - Class in bb.common
WOIssuedByMonthResult() - Constructor for class bb.common.WOIssuedByMonthResult
WOItemCostControlAgent - Class in bb.common
WOItemCostControlAgent() - Constructor for class bb.common.WOItemCostControlAgent
WOItemPartDetailNotIssue - Class in bb.common
WOItemPartDetailNotIssue() - Constructor for class bb.common.WOItemPartDetailNotIssue
WoItemPickListItemResult - Class in bb.common
WoItemPickListItemResult() - Constructor for class bb.common.WoItemPickListItemResult
WoItemPickListResult - Class in bb.common
WoItemPickListResult() - Constructor for class bb.common.WoItemPickListResult
WoItemWorkInstructionListResult - Class in bb.common
WoItemWorkInstructionListResult() - Constructor for class bb.common.WoItemWorkInstructionListResult
WOREC - Static variable in class bb.common.Constant.GLApprovedType
WOReceiverDetail - Class in bb.common
WOReceiverDetail() - Constructor for class bb.common.WOReceiverDetail
WORK_CALENDAR - Static variable in class bb.common.BizTarget
WORK_CENTER - Static variable in class bb.common.BizTarget
WORK_CENTER_GROUP - Static variable in class bb.common.BizTarget
WORK_CENTER_GROUP_ALREADY_EXIST - Static variable in class bb.common.BIZReason
WORK_CENTER_GROUP_ITEM_IS_EMPTY - Static variable in class bb.common.BIZReason
WORK_CENTER_GROUP_ITEM_NUMBER_WRONG - Static variable in class bb.common.BIZReason
WORK_CENTER_GROUP_NOT_EXIST - Static variable in class bb.common.BIZReason
WORK_CENTER_HAS_EXIST - Static variable in class bb.common.BIZReason
WORK_CENTER_IS_BEING_USED - Static variable in class bb.common.BIZReason
WORK_CENTER_NOT_EXIST - Static variable in class bb.common.BIZReason
WORK_CENTER_UNIT_NUMBER_WRONG - Static variable in class bb.common.BIZReason
WORK_INSTRUCTION - Static variable in class bb.common.BizTarget
WORK_INSTRUCTION_ALREADY_EXIST - Static variable in class bb.common.BIZReason
WORK_INSTRUCTION_APPROVAL - Static variable in class bb.common.BizTarget
WORK_INSTRUCTION_APPROVAL_ALREADY_EXIST - Static variable in class bb.common.BIZReason
WORK_INSTRUCTION_APPROVAL_NOT_EXIST - Static variable in class bb.common.BIZReason
WORK_INSTRUCTION_DOC - Static variable in class bb.common.BizTarget
WORK_INSTRUCTION_NOT_EXIST - Static variable in class bb.common.BIZReason
WORK_LOADMETHOD - Static variable in class bb.common.Constant.Depreciation.DepreciationMethod
WORK_ORDER - Static variable in class bb.common.BizTarget
WORK_ORDER_ALREADY_SETUP_OR_RUN - Static variable in class bb.common.BIZReason
WORK_ORDER_APPROVAL - Static variable in class bb.common.BizTarget
WORK_ORDER_APPROVAL_ALREADY_EXIST - Static variable in class bb.common.BIZReason
WORK_ORDER_APPROVAL_NOT_EXIST - Static variable in class bb.common.BIZReason
WORK_ORDER_ITEM - Static variable in class bb.common.BizTarget
WORK_ORDER_ITEM_CAN_NOT_LINK_TO_ITSELF - Static variable in class bb.common.BIZReason
WORK_ORDER_ITEM_HAS_CLOSED - Static variable in class bb.common.BIZReason
WORK_ORDER_ITEM_ISSUE - Static variable in class bb.common.BizTarget
WORK_ORDER_ITEM_ISSUE_NOT_EXIST - Static variable in class bb.common.BIZReason
WORK_ORDER_ITEM_ISSUE_NOT_FINISHED - Static variable in class bb.common.BIZReason
WORK_ORDER_ITEM_MFG_STATUS_HAS_SETUP - Static variable in class bb.common.BIZReason
WORK_ORDER_ITEM_MFG_STATUS_NOT_SETUP - Static variable in class bb.common.BIZReason
WORK_ORDER_ITEM_NOT_EXIST - Static variable in class bb.common.BIZReason
WORK_ORDER_ITEM_NOT_OPEN - Static variable in class bb.common.BIZReason
WORK_ORDER_ITEM_PART_DETAIL - Static variable in class bb.common.BizTarget
WORK_ORDER_ITEM_QTY_CAN_NOT_CHANGE_TO_ZERO - Static variable in class bb.common.BIZReason
WORK_ORDER_ITEM_QTY_CAN_NOT_LESS_THAN_QTY_ASM - Static variable in class bb.common.BIZReason
WORK_ORDER_ITEM_TIME_DETAIL - Static variable in class bb.common.BizTarget
WORK_ORDER_ITEM_TIME_DETAIL_NOT_EXIST - Static variable in class bb.common.BIZReason
WORK_ORDER_NOT_EXIST - Static variable in class bb.common.BIZReason
WORK_ORDER_NOT_OPEN - Static variable in class bb.common.BIZReason
WORK_ORDER_WORK_INSTRUCTION - Static variable in class bb.common.BizTarget
WORK_ORDER_WORK_INSTRUCTION_HAS_EXIST - Static variable in class bb.common.BIZReason
WORK_ORDER_WORK_INSTRUCTION_HAS_FINISHED - Static variable in class bb.common.BIZReason
WORK_ORDER_WORK_INSTRUCTION_NOT_EXIST - Static variable in class bb.common.BIZReason
WORK_ORDER_WORK_INSTRUCTION_SEQ - Static variable in class bb.common.BizTarget
WORK_PERIOD - Static variable in class bb.common.BizTarget
WORK_WORK_SHEET - Static variable in class bb.common.BizTarget
WORK_WORK_SHEET_HAS_EXIST - Static variable in class bb.common.BIZReason
WORK_WORK_SHEET_ITEM - Static variable in class bb.common.BizTarget
WORK_WORK_SHEET_NOT_EXIST - Static variable in class bb.common.BIZReason
WorkCalendarVO - Class in bb.common
WorkCalendarVO() - Constructor for class bb.common.WorkCalendarVO
WorkCenterAgent - Class in bb.common
WorkCenterAgent(String, boolean) - Constructor for class bb.common.WorkCenterAgent
WorkCenterGroupItemPK - Class in bb.common
WorkCenterGroupItemPK() - Constructor for class bb.common.WorkCenterGroupItemPK
WorkCenterGroupItemVO - Class in bb.common
WorkCenterGroupItemVO() - Constructor for class bb.common.WorkCenterGroupItemVO
default constructor
WorkCenterLoadAgent - Class in bb.common
WorkCenterLoadAgent() - Constructor for class bb.common.WorkCenterLoadAgent
WorkCenterLoadListResult - Class in bb.common
WorkCenterLoadListResult() - Constructor for class bb.common.WorkCenterLoadListResult
WorkCenterOnDateAgent - Class in bb.common
WorkCenterOnDateAgent(String, boolean) - Constructor for class bb.common.WorkCenterOnDateAgent
WorkCenterRunTimeAgent - Class in bb.common
WorkCenterRunTimeAgent() - Constructor for class bb.common.WorkCenterRunTimeAgent
WorkCenterRunTimeListResult - Class in bb.common
WorkCenterRunTimeListResult() - Constructor for class bb.common.WorkCenterRunTimeListResult
WorkCenterRunTimeTotalResult - Class in bb.common
WorkCenterRunTimeTotalResult() - Constructor for class bb.common.WorkCenterRunTimeTotalResult
WorkCenterVendorPK - Class in bb.common
WorkCenterVendorPK() - Constructor for class bb.common.WorkCenterVendorPK
WorkCenterVendorPK(String, String) - Constructor for class bb.common.WorkCenterVendorPK
WorkCenterVendorVO - Class in bb.common
WorkCenterVendorVO() - Constructor for class bb.common.WorkCenterVendorVO
WorkCenterVO - Class in bb.common
Title:
WorkCenterVO() - Constructor for class bb.common.WorkCenterVO
default constructor
WorkFlowVO - Class in bb.common
WorkFlowVO() - Constructor for class bb.common.WorkFlowVO
WorkInstructionApprovalVO - Class in bb.common
WorkInstructionApprovalVO(String) - Constructor for class bb.common.WorkInstructionApprovalVO
WorkInstructionApprovalVO() - Constructor for class bb.common.WorkInstructionApprovalVO
WorkInstructionDocumentVO - Class in bb.common
WorkInstructionDocumentVO() - Constructor for class bb.common.WorkInstructionDocumentVO
WorkInstructionListResult - Class in bb.common
WorkInstructionListResult() - Constructor for class bb.common.WorkInstructionListResult
WorkInstructionPictureVO - Class in bb.common
WorkInstructionPictureVO() - Constructor for class bb.common.WorkInstructionPictureVO
default constructor
WorkInstructionPK - Class in bb.common
WorkInstructionPK(String, String, String, String) - Constructor for class bb.common.WorkInstructionPK
full constructor
WorkInstructionPK() - Constructor for class bb.common.WorkInstructionPK
default constructor
WorkInstructionRequestForChangeVO - Class in bb.common
WorkInstructionRequestForChangeVO() - Constructor for class bb.common.WorkInstructionRequestForChangeVO
default constructor
WorkInstructionSeqAuditListResult - Class in bb.common
WorkInstructionSeqAuditListResult() - Constructor for class bb.common.WorkInstructionSeqAuditListResult
WorkInstructionSequenceListResult - Class in bb.common
WorkInstructionSequenceListResult() - Constructor for class bb.common.WorkInstructionSequenceListResult
WorkInstructionSequencePK - Class in bb.common
WorkInstructionSequencePK(String, String, String, String, String) - Constructor for class bb.common.WorkInstructionSequencePK
full constructor
WorkInstructionSequencePK() - Constructor for class bb.common.WorkInstructionSequencePK
default constructor
WorkInstructionSequenceVO - Class in bb.common
WorkInstructionSequenceVO(WorkInstructionSequencePK, String, String, String, String, String, String, String, String, String, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, String, String, Set) - Constructor for class bb.common.WorkInstructionSequenceVO
full constructor
WorkInstructionSequenceVO() - Constructor for class bb.common.WorkInstructionSequenceVO
default constructor
WorkInstructionSequenceVO(WorkInstructionSequencePK, String, String, String, String, String, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, BigDecimal, String, String, Set) - Constructor for class bb.common.WorkInstructionSequenceVO
minimal constructor
WorkInstructionSummaryItemResult - Class in bb.common
WorkInstructionSummaryItemResult() - Constructor for class bb.common.WorkInstructionSummaryItemResult
WorkInstructionSummaryResult - Class in bb.common
WorkInstructionSummaryResult() - Constructor for class bb.common.WorkInstructionSummaryResult
WorkInstructionVO - Class in bb.common
WorkInstructionVO() - Constructor for class bb.common.WorkInstructionVO
defaultWi constructor
WorkInstructionVO(WorkInstructionPK, String, String, String, String, String, Date, String, Set) - Constructor for class bb.common.WorkInstructionVO
minimal constructor
WORKORDER - Static variable in class bb.common.Configure.Module
WORKORDER - Static variable in class bb.common.Constant.OrderType
WorkOrder - Static variable in class bb.common.Constant.ReceivedTo
WorkOrderApprovalVO - Class in bb.common
WorkOrderApprovalVO() - Constructor for class bb.common.WorkOrderApprovalVO
WorkOrderBoilerplateVO - Class in bb.common
WorkOrderBoilerplateVO() - Constructor for class bb.common.WorkOrderBoilerplateVO
default constructor
WorkOrderBox - Interface in bb.common.box
WorkOrderCheckListResult - Class in bb.common
WorkOrderCheckListResult() - Constructor for class bb.common.WorkOrderCheckListResult
WorkOrderDocumentVO - Class in bb.common
WorkOrderDocumentVO() - Constructor for class bb.common.WorkOrderDocumentVO
WorkOrderInfoCenterResult - Class in bb.common
WorkOrderInfoCenterResult() - Constructor for class bb.common.WorkOrderInfoCenterResult
WorkOrderInWipResult - Class in bb.common
WorkOrderInWipResult() - Constructor for class bb.common.WorkOrderInWipResult
WorkOrderIssuedOrderListResult - Class in bb.common
WorkOrderIssuedOrderListResult() - Constructor for class bb.common.WorkOrderIssuedOrderListResult
WorkOrderIssueStatisticsResult - Class in bb.common
WorkOrderIssueStatisticsResult() - Constructor for class bb.common.WorkOrderIssueStatisticsResult
WorkOrderItemAgent - Class in bb.common
WorkOrderItemAgent() - Constructor for class bb.common.WorkOrderItemAgent
WorkOrderItemCanAssyAgent - Class in bb.common
WorkOrderItemCanAssyAgent() - Constructor for class bb.common.WorkOrderItemCanAssyAgent
WorkOrderItemCanAssyResult - Class in bb.common
WorkOrderItemCanAssyResult() - Constructor for class bb.common.WorkOrderItemCanAssyResult
WorkOrderItemInfoResult - Class in bb.common
WorkOrderItemInfoResult() - Constructor for class bb.common.WorkOrderItemInfoResult
WorkOrderItemInWipListResult - Class in bb.common
WorkOrderItemInWipListResult() - Constructor for class bb.common.WorkOrderItemInWipListResult
WorkOrderItemIssuedTotalResult - Class in bb.common
WorkOrderItemIssuedTotalResult() - Constructor for class bb.common.WorkOrderItemIssuedTotalResult
WorkOrderItemIssuePK - Class in bb.common
WorkOrderItemIssuePK() - Constructor for class bb.common.WorkOrderItemIssuePK
WorkOrderItemIssueVO - Class in bb.common
WorkOrderItemIssueVO() - Constructor for class bb.common.WorkOrderItemIssueVO
WorkOrderItemLaborCostListResult - Class in bb.common
WorkOrderItemLaborCostListResult() - Constructor for class bb.common.WorkOrderItemLaborCostListResult
WorkOrderItemListResult - Class in bb.common
WorkOrderItemListResult() - Constructor for class bb.common.WorkOrderItemListResult
WorkOrderItemPartDetail - Class in bb.common
WorkOrderItemPartDetail() - Constructor for class bb.common.WorkOrderItemPartDetail
WorkOrderItemPartDetailInWipVO - Class in bb.common
WorkOrderItemPartDetailInWipVO() - Constructor for class bb.common.WorkOrderItemPartDetailInWipVO
default constructor
WorkOrderItemPartDetailItemResult - Class in bb.common
WorkOrderItemPartDetailItemResult() - Constructor for class bb.common.WorkOrderItemPartDetailItemResult
WorkOrderItemPartDetailResult - Class in bb.common
WorkOrderItemPartDetailResult() - Constructor for class bb.common.WorkOrderItemPartDetailResult
WorkOrderItemPK - Class in bb.common
WorkOrderItemPK() - Constructor for class bb.common.WorkOrderItemPK
WorkOrderItemPK(String, String) - Constructor for class bb.common.WorkOrderItemPK
WorkOrderItemReviewCostResult - Class in bb.common
WorkOrderItemReviewCostResult() - Constructor for class bb.common.WorkOrderItemReviewCostResult
WorkOrderItemSeqWCLoadResult - Class in bb.common
WorkOrderItemSeqWCLoadResult() - Constructor for class bb.common.WorkOrderItemSeqWCLoadResult
WorkOrderItemSetupItemAgent - Class in bb.common
WorkOrderItemSetupItemAgent() - Constructor for class bb.common.WorkOrderItemSetupItemAgent
WorkOrderItemTimeDetailResult - Class in bb.common
WorkOrderItemTimeDetailResult() - Constructor for class bb.common.WorkOrderItemTimeDetailResult
WorkOrderItemTimeDetailVO - Class in bb.common
WorkOrderItemTimeDetailVO() - Constructor for class bb.common.WorkOrderItemTimeDetailVO
WorkOrderItemToIssueResult - Class in bb.common
WorkOrderItemToIssueResult() - Constructor for class bb.common.WorkOrderItemToIssueResult
WorkOrderItemVO - Class in bb.common
WorkOrderItemVO() - Constructor for class bb.common.WorkOrderItemVO
WorkOrderItemWCLoadResult - Class in bb.common
WorkOrderItemWCLoadResult() - Constructor for class bb.common.WorkOrderItemWCLoadResult
WorkOrderListResult - Class in bb.common
WorkOrderListResult() - Constructor for class bb.common.WorkOrderListResult
WorkOrderNotSetupResult - Class in bb.common
WorkOrderNotSetupResult() - Constructor for class bb.common.WorkOrderNotSetupResult
WorkOrderOnDemandResult - Class in bb.common
WorkOrderOnDemandResult() - Constructor for class bb.common.WorkOrderOnDemandResult
WorkOrderOnOrderResult - Class in bb.common
WorkOrderOnOrderResult() - Constructor for class bb.common.WorkOrderOnOrderResult
WorkOrderOnTimeItemResult - Class in bb.common
WorkOrderOnTimeItemResult() - Constructor for class bb.common.WorkOrderOnTimeItemResult
WorkOrderOnTimeResult - Class in bb.common
WorkOrderOnTimeResult() - Constructor for class bb.common.WorkOrderOnTimeResult
WorkOrderOverIssueListResult - Class in bb.common
WorkOrderOverIssueListResult() - Constructor for class bb.common.WorkOrderOverIssueListResult
WorkOrderQueryInfo - Class in bb.common
WorkOrderQueryInfo() - Constructor for class bb.common.WorkOrderQueryInfo
WorkOrderReceiverVO - Class in bb.common
WorkOrderReceiverVO() - Constructor for class bb.common.WorkOrderReceiverVO
default constructor
WorkOrderTimeCardVO - Class in bb.common
WorkOrderTimeCardVO() - Constructor for class bb.common.WorkOrderTimeCardVO
WorkOrderVO - Class in bb.common
WorkOrderVO() - Constructor for class bb.common.WorkOrderVO
WorkOrderWorkInstructionListResult - Class in bb.common
WorkOrderWorkInstructionListResult() - Constructor for class bb.common.WorkOrderWorkInstructionListResult
WorkOrderWorkInstructionPK - Class in bb.common
WorkOrderWorkInstructionPK(String, String) - Constructor for class bb.common.WorkOrderWorkInstructionPK
full constructor
WorkOrderWorkInstructionPK() - Constructor for class bb.common.WorkOrderWorkInstructionPK
default constructor
WorkOrderWorkInstructionSequenceDateAgent - Class in bb.common
WorkOrderWorkInstructionSequenceDateAgent() - Constructor for class bb.common.WorkOrderWorkInstructionSequenceDateAgent
default constructor
WorkOrderWorkInstructionSequencePK - Class in bb.common
WorkOrderWorkInstructionSequencePK(String, String, String) - Constructor for class bb.common.WorkOrderWorkInstructionSequencePK
full constructor
WorkOrderWorkInstructionSequencePK() - Constructor for class bb.common.WorkOrderWorkInstructionSequencePK
default constructor
WorkOrderWorkInstructionSequenceVO - Class in bb.common
WorkOrderWorkInstructionSequenceVO() - Constructor for class bb.common.WorkOrderWorkInstructionSequenceVO
default constructor
WorkOrderWorkInstructionVO - Class in bb.common
WorkOrderWorkInstructionVO() - Constructor for class bb.common.WorkOrderWorkInstructionVO
defaultWi constructor
WorkOrderWorkItemDateAgent - Class in bb.common
WorkOrderWorkItemDateAgent() - Constructor for class bb.common.WorkOrderWorkItemDateAgent
default constructor
WorkOrderWorkSheetItemPK - Class in bb.common
WorkOrderWorkSheetItemPK(String, String, Integer, Integer) - Constructor for class bb.common.WorkOrderWorkSheetItemPK
full constructor
WorkOrderWorkSheetItemPK() - Constructor for class bb.common.WorkOrderWorkSheetItemPK
default constructor
WorkOrderWorkSheetItemVO - Class in bb.common
WorkOrderWorkSheetItemVO() - Constructor for class bb.common.WorkOrderWorkSheetItemVO
WorkOrderWorkSheetItemWithRelatedInfoResult - Class in bb.common
WorkOrderWorkSheetItemWithRelatedInfoResult() - Constructor for class bb.common.WorkOrderWorkSheetItemWithRelatedInfoResult
WorkOrderWorkSheetPK - Class in bb.common
WorkOrderWorkSheetPK(String, String, Integer) - Constructor for class bb.common.WorkOrderWorkSheetPK
full constructor
WorkOrderWorkSheetPK() - Constructor for class bb.common.WorkOrderWorkSheetPK
default constructor
WorkOrderWorkSheetVO - Class in bb.common
WorkOrderWorkSheetVO() - Constructor for class bb.common.WorkOrderWorkSheetVO
WorkPeriodVO - Class in bb.common
WorkPeriodVO() - Constructor for class bb.common.WorkPeriodVO
WorkSheetPartAgent - Class in bb.common
WorkSheetPartAgent() - Constructor for class bb.common.WorkSheetPartAgent
WOWI - Static variable in class bb.common.Constant.PrintTemplateType
WriteOffed - Static variable in class bb.common.Constant.Status
writeOffEstimatedPayable(String, MakeAccountPayableAgent) - Method in interface bb.common.box.AccountingBox
writeToBytes(Object) - Static method in class bb.common.BB2Util
WRONG_CURRENCY_FOR_CUSTOMER - Static variable in class bb.common.BIZReason
WRONG_DOCUMENT_SETTINGS - Static variable in class bb.common.BIZReason
WRONG_DOCUMENT_TYPE - Static variable in class bb.common.BIZReason
WRONG_MONTH_YEAR_NAME - Static variable in class bb.common.BIZReason
WRONG_PASSWORD - Static variable in class bb.common.BIZReason
WRONG_SHIPPER_FOR_SALES_ORDER - Static variable in class bb.common.BIZReason
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M N O P Q R S T U V W X Y Z


WireTransferAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WireTransferAgent

java.lang.Object
    extended by  bb.common.WireTransferAgent
All Implemented Interfaces:
java.io.Serializable
public class WireTransferAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WireTransferAgent()
Method Summary
java.lang.String[] | getArApNumber()
java.lang.String | getBankTransferFeeAccount()
java.lang.String | getCompanyUnitOfTransferFeeAcc()
java.lang.String | getCreditAccount()
java.lang.String | getCurrency()
java.lang.String | getDebitAccount()
java.lang.String[] | getExcludeVendorId()
java.util.Date | getFromDate()
java.lang.String[] | getIncludeVendorId()
java.util.Date | getToDate()
java.util.Date | getTransactionDate()
java.lang.String | getWireTransferNo()
void | setArApNumber(java.lang.String[] arApNumber)
void | setBankTransferFeeAccount(java.lang.String bankTransferFeeAccount)
void | setCompanyUnitOfTransferFeeAcc(java.lang.String companyUnitOfTransferFeeAcc)
void | setCreditAccount(java.lang.String creditAccount)
void | setCurrency(java.lang.String currency)
void | setDebitAccount(java.lang.String debitAccount)
void | setExcludeVendorId(java.lang.String[] excludeVendorId)
void | setFromDate(java.util.Date fromDate)
void | setIncludeVendorId(java.lang.String[] includeVendorId)
void | setToDate(java.util.Date toDate)
void | setTransactionDate(java.util.Date transactionDate)
void | setWireTransferNo(java.lang.String wireTransferNo)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WireTransferAgent

public WireTransferAgent()
Method Detail

getToDate

public java.util.Date getToDate()

getFromDate

public java.util.Date getFromDate()

getExcludeVendorId

public java.lang.String[] getExcludeVendorId()

setIncludeVendorId

public void setIncludeVendorId(java.lang.String[] includeVendorId)

setToDate

public void setToDate(java.util.Date toDate)

setFromDate

public void setFromDate(java.util.Date fromDate)

setExcludeVendorId

public void setExcludeVendorId(java.lang.String[] excludeVendorId)

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

setWireTransferNo

public void setWireTransferNo(java.lang.String wireTransferNo)

setTransactionDate

public void setTransactionDate(java.util.Date transactionDate)

setCreditAccount

public void setCreditAccount(java.lang.String creditAccount)

setArApNumber

public void setArApNumber(java.lang.String[] arApNumber)

getIncludeVendorId

public java.lang.String[] getIncludeVendorId()

getDebitAccount

public java.lang.String getDebitAccount()

getWireTransferNo

public java.lang.String getWireTransferNo()

getTransactionDate

public java.util.Date getTransactionDate()

getCreditAccount

public java.lang.String getCreditAccount()

getArApNumber

public java.lang.String[] getArApNumber()

getBankTransferFeeAccount

public java.lang.String getBankTransferFeeAccount()

setBankTransferFeeAccount

public void setBankTransferFeeAccount(java.lang.String bankTransferFeeAccount)

getCompanyUnitOfTransferFeeAcc

public java.lang.String getCompanyUnitOfTransferFeeAcc()

setCompanyUnitOfTransferFeeAcc

public void setCompanyUnitOfTransferFeeAcc(java.lang.String companyUnitOfTransferFeeAcc)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WO2WOAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WO2WOAgent

java.lang.Object
    extended by  bb.common.WO2WOAgent
All Implemented Interfaces:
java.io.Serializable
public class WO2WOAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WO2WOAgent()
Method Summary
java.util.Date | getDateRequired()
java.util.Date | getStartDate()
java.lang.String | getVendorId()
java.lang.String | getWoNumber()
void | setDateRequired(java.util.Date dateRequired)
void | setStartDate(java.util.Date startDate)
void | setVendorId(java.lang.String vendorId)
void | setWoNumber(java.lang.String woNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WO2WOAgent

public WO2WOAgent()
Method Detail

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getWoNumber

public java.lang.String getWoNumber()

setWoNumber

public void setWoNumber(java.lang.String woNumber)

getDateRequired

public java.util.Date getDateRequired()

setDateRequired

public void setDateRequired(java.util.Date dateRequired)

getStartDate

public java.util.Date getStartDate()

setStartDate

public void setStartDate(java.util.Date startDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WOIssuedByMonthChartResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WOIssuedByMonthChartResult

java.lang.Object
    extended by  bb.common.WOIssuedByMonthChartResult
All Implemented Interfaces:
java.io.Serializable
public class WOIssuedByMonthChartResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WOIssuedByMonthChartResult()
Method Summary
java.util.ArrayList<WOIssuedByMonthResult> | getIssuedByMonthList()
java.math.BigDecimal | getTotalIssued()
java.math.BigDecimal | getTotalIssuedCost()
java.math.BigDecimal | getTotalRec()
java.math.BigDecimal | getTotalRecCost()
void | setIssuedByMonthList(java.util.ArrayList<WOIssuedByMonthResult> issuedByMonthList)
void | setTotalIssued(java.math.BigDecimal totalIssued)
void | setTotalIssuedCost(java.math.BigDecimal totalIssuedCost)
void | setTotalRec(java.math.BigDecimal totalRec)
void | setTotalRecCost(java.math.BigDecimal totalRecCost)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WOIssuedByMonthChartResult

public WOIssuedByMonthChartResult()
Method Detail

getIssuedByMonthList

public java.util.ArrayList<WOIssuedByMonthResult> getIssuedByMonthList()

setIssuedByMonthList

public void setIssuedByMonthList(java.util.ArrayList<WOIssuedByMonthResult> issuedByMonthList)

getTotalIssued

public java.math.BigDecimal getTotalIssued()

setTotalIssued

public void setTotalIssued(java.math.BigDecimal totalIssued)

getTotalRec

public java.math.BigDecimal getTotalRec()

setTotalRec

public void setTotalRec(java.math.BigDecimal totalRec)

getTotalIssuedCost

public java.math.BigDecimal getTotalIssuedCost()

setTotalIssuedCost

public void setTotalIssuedCost(java.math.BigDecimal totalIssuedCost)

getTotalRecCost

public java.math.BigDecimal getTotalRecCost()

setTotalRecCost

public void setTotalRecCost(java.math.BigDecimal totalRecCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WOIssuedByMonthResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WOIssuedByMonthResult

java.lang.Object
    extended by  bb.common.WOIssuedByMonthResult
All Implemented Interfaces:
java.io.Serializable
public class WOIssuedByMonthResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WOIssuedByMonthResult()
Method Summary
java.util.Date | getDate()
java.math.BigDecimal | getIssueCost()
java.math.BigDecimal | getIssueQuantity()
java.math.BigDecimal | getRecCost()
java.math.BigDecimal | getRecQuantity()
void | setDate(java.util.Date date)
void | setIssueCost(java.math.BigDecimal issueCost)
void | setIssueQuantity(java.math.BigDecimal issueQuantity)
void | setRecCost(java.math.BigDecimal recCost)
void | setRecQuantity(java.math.BigDecimal recQuantity)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WOIssuedByMonthResult

public WOIssuedByMonthResult()
Method Detail

getIssueQuantity

public java.math.BigDecimal getIssueQuantity()

setIssueQuantity

public void setIssueQuantity(java.math.BigDecimal issueQuantity)

getDate

public java.util.Date getDate()

setDate

public void setDate(java.util.Date date)

getRecQuantity

public java.math.BigDecimal getRecQuantity()

setRecQuantity

public void setRecQuantity(java.math.BigDecimal recQuantity)

getIssueCost

public java.math.BigDecimal getIssueCost()

setIssueCost

public void setIssueCost(java.math.BigDecimal issueCost)

getRecCost

public java.math.BigDecimal getRecCost()

setRecCost

public void setRecCost(java.math.BigDecimal recCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WOItemCostControlAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WOItemCostControlAgent

java.lang.Object
    extended by  bb.common.WOItemCostControlAgent
All Implemented Interfaces:
java.io.Serializable
public class WOItemCostControlAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WOItemCostControlAgent()
Method Summary
boolean | checkIfOverControl(java.math.BigDecimal newCost)
java.math.BigDecimal | getDiffCost()
BB2Part | getPart()
WorkOrderItemPK | getPk()
java.math.BigDecimal | getQty()
java.lang.String | getReviewedBy()
java.util.Date | getReviewedDate()
java.lang.String | getReviewedDesc()
java.math.BigDecimal | getSumCost()
java.math.BigDecimal | getTotControlCost()
java.math.BigDecimal | getVarianceCost()
boolean | isCostAlarm()
void | setCostAlarm(boolean costAlarm)
void | setDiffCost(java.math.BigDecimal diffCost)
void | setPart(BB2Part part)
void | setPk(WorkOrderItemPK pk)
void | setQty(java.math.BigDecimal qty)
void | setReviewedBy(java.lang.String reviewedBy)
void | setReviewedDate(java.util.Date reviewedDate)
void | setReviewedDesc(java.lang.String reviewedDesc)
void | setSumCost(java.math.BigDecimal sumCost)
void | setTotControlCost(java.math.BigDecimal totControlCost)
void | setVarianceCost(java.math.BigDecimal varianceCost)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WOItemCostControlAgent

public WOItemCostControlAgent()
Method Detail

isCostAlarm

public boolean isCostAlarm()

setCostAlarm

public void setCostAlarm(boolean costAlarm)

getDiffCost

public java.math.BigDecimal getDiffCost()

setDiffCost

public void setDiffCost(java.math.BigDecimal diffCost)

getPart

public BB2Part getPart()

setPart

public void setPart(BB2Part part)

getPk

public WorkOrderItemPK getPk()

setPk

public void setPk(WorkOrderItemPK pk)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

getReviewedBy

public java.lang.String getReviewedBy()

setReviewedBy

public void setReviewedBy(java.lang.String reviewedBy)

getReviewedDate

public java.util.Date getReviewedDate()

setReviewedDate

public void setReviewedDate(java.util.Date reviewedDate)

getReviewedDesc

public java.lang.String getReviewedDesc()

setReviewedDesc

public void setReviewedDesc(java.lang.String reviewedDesc)

getSumCost

public java.math.BigDecimal getSumCost()

setSumCost

public void setSumCost(java.math.BigDecimal sumCost)

getTotControlCost

public java.math.BigDecimal getTotControlCost()

setTotControlCost

public void setTotControlCost(java.math.BigDecimal totControlCost)

getVarianceCost

public java.math.BigDecimal getVarianceCost()

setVarianceCost

public void setVarianceCost(java.math.BigDecimal varianceCost)

checkIfOverControl

public boolean checkIfOverControl(java.math.BigDecimal newCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WOItemPartDetailNotIssue

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WOItemPartDetailNotIssue

java.lang.Object
    extended by  bb.common.WOItemPartDetailNotIssue
All Implemented Interfaces:
java.io.Serializable
public class WOItemPartDetailNotIssue
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ASMPART
static java.lang.String | ORDER_BY_AVGCOST
static java.lang.String | ORDER_BY_DELIVERYDATE
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_ISSUEQUANTITY
static java.lang.String | ORDER_BY_ONDEMAND
static java.lang.String | ORDER_BY_ONHAND
static java.lang.String | ORDER_BY_ONORDER
static java.lang.String | ORDER_BY_PART
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_QUANTITY
static java.lang.String | ORDER_BY_QUANTITYASM
static java.lang.String | ORDER_BY_STARTDATE
static java.lang.String | ORDER_BY_STDCOST
static java.lang.String | ORDER_BY_WOIQQUANTITY
static java.lang.String | ORDER_BY_WORKORDERITEMNUMBER
static java.lang.String | ORDER_BY_WORKORDERNUMBER
Constructor Summary
WOItemPartDetailNotIssue()
Method Summary
BB2Part | getAsmPart()
java.math.BigDecimal | getAvgCost()
java.util.Date | getDeliveryDate()
java.lang.String | getDescription()
java.math.BigDecimal | getIssueQuantity()
java.math.BigDecimal | getOndemand()
java.math.BigDecimal | getOnhand()
java.math.BigDecimal | getOnorder()
BB2Part | getPart()
java.util.List | getPmList()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getQuantityAsm()
java.util.Date | getStartDate()
java.math.BigDecimal | getStdCost()
java.math.BigDecimal | getWoiQquantity()
java.util.List | getWoItems()
java.lang.String | getWorkOrderItemNumber()
java.lang.String | getWorkOrderNumber()
void | setAsmPart(BB2Part asmPart)
void | setAvgCost(java.math.BigDecimal cost)
void | setDeliveryDate(java.util.Date deliveryDate)
void | setDescription(java.lang.String description)
void | setIssueQuantity(java.math.BigDecimal issueQuantity)
void | setOndemand(java.math.BigDecimal ondemand)
void | setOnhand(java.math.BigDecimal onhand)
void | setOnorder(java.math.BigDecimal onorder)
void | setPart(BB2Part part)
void | setPmList(java.util.List pmList)
void | setQuantity(java.math.BigDecimal quantity)
void | setQuantityAsm(java.math.BigDecimal quantityAsm)
void | setStartDate(java.util.Date startDate)
void | setStdCost(java.math.BigDecimal cost)
void | setWoiQquantity(java.math.BigDecimal woiQquantity)
void | setWoItems(java.util.List woItems)
void | setWorkOrderItemNumber(java.lang.String workOrderItemNumber)
void | setWorkOrderNumber(java.lang.String workOrderNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_WORKORDERNUMBER

public static final java.lang.String ORDER_BY_WORKORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_WORKORDERITEMNUMBER

public static final java.lang.String ORDER_BY_WORKORDERITEMNUMBER
See Also:
Constant Field Values

ORDER_BY_WOIQQUANTITY

public static final java.lang.String ORDER_BY_WOIQQUANTITY
See Also:
Constant Field Values

ORDER_BY_QUANTITYASM

public static final java.lang.String ORDER_BY_QUANTITYASM
See Also:
Constant Field Values

ORDER_BY_PART

public static final java.lang.String ORDER_BY_PART
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_ASMPART

public static final java.lang.String ORDER_BY_ASMPART
See Also:
Constant Field Values

ORDER_BY_QUANTITY

public static final java.lang.String ORDER_BY_QUANTITY
See Also:
Constant Field Values

ORDER_BY_ISSUEQUANTITY

public static final java.lang.String ORDER_BY_ISSUEQUANTITY
See Also:
Constant Field Values

ORDER_BY_AVGCOST

public static final java.lang.String ORDER_BY_AVGCOST
See Also:
Constant Field Values

ORDER_BY_STDCOST

public static final java.lang.String ORDER_BY_STDCOST
See Also:
Constant Field Values

ORDER_BY_ONHAND

public static final java.lang.String ORDER_BY_ONHAND
See Also:
Constant Field Values

ORDER_BY_ONORDER

public static final java.lang.String ORDER_BY_ONORDER
See Also:
Constant Field Values

ORDER_BY_ONDEMAND

public static final java.lang.String ORDER_BY_ONDEMAND
See Also:
Constant Field Values

ORDER_BY_STARTDATE

public static final java.lang.String ORDER_BY_STARTDATE
See Also:
Constant Field Values

ORDER_BY_DELIVERYDATE

public static final java.lang.String ORDER_BY_DELIVERYDATE
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

WOItemPartDetailNotIssue

public WOItemPartDetailNotIssue()
Method Detail

setAvgCost

public void setAvgCost(java.math.BigDecimal cost)

getAvgCost

public java.math.BigDecimal getAvgCost()

setStdCost

public void setStdCost(java.math.BigDecimal cost)

getStdCost

public java.math.BigDecimal getStdCost()

getIssueQuantity

public java.math.BigDecimal getIssueQuantity()

setIssueQuantity

public void setIssueQuantity(java.math.BigDecimal issueQuantity)

getOnhand

public java.math.BigDecimal getOnhand()

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getQuantityAsm

public java.math.BigDecimal getQuantityAsm()

setQuantityAsm

public void setQuantityAsm(java.math.BigDecimal quantityAsm)

getWoiQquantity

public java.math.BigDecimal getWoiQquantity()

setWoiQquantity

public void setWoiQquantity(java.math.BigDecimal woiQquantity)

getWorkOrderItemNumber

public java.lang.String getWorkOrderItemNumber()

setWorkOrderItemNumber

public void setWorkOrderItemNumber(java.lang.String workOrderItemNumber)

getWorkOrderNumber

public java.lang.String getWorkOrderNumber()

setWorkOrderNumber

public void setWorkOrderNumber(java.lang.String workOrderNumber)

getDeliveryDate

public java.util.Date getDeliveryDate()

setDeliveryDate

public void setDeliveryDate(java.util.Date deliveryDate)

getStartDate

public java.util.Date getStartDate()

setStartDate

public void setStartDate(java.util.Date startDate)

getAsmPart

public BB2Part getAsmPart()

setAsmPart

public void setAsmPart(BB2Part asmPart)

getPart

public BB2Part getPart()

setPart

public void setPart(BB2Part part)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getOndemand

public java.math.BigDecimal getOndemand()

setOndemand

public void setOndemand(java.math.BigDecimal ondemand)

getOnorder

public java.math.BigDecimal getOnorder()

setOnorder

public void setOnorder(java.math.BigDecimal onorder)

getPmList

public java.util.List getPmList()

setPmList

public void setPmList(java.util.List pmList)

getWoItems

public java.util.List getWoItems()

setWoItems

public void setWoItems(java.util.List woItems)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WoItemPickListItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WoItemPickListItemResult

java.lang.Object
    extended by  bb.common.WoItemPickListItemResult
All Implemented Interfaces:
java.io.Serializable
public class WoItemPickListItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WoItemPickListItemResult()
Method Summary
java.lang.String | getComments()
java.lang.String | getDescription()
java.util.Date | getLastDate()
java.lang.String | getLocation()
java.math.BigDecimal | getOnhand()
java.lang.String | getPartFrom()
java.util.List | getPartOnhands()
PartPK | getPartPk()
java.lang.String | getPartUnit()
java.math.BigDecimal | getQtyIssued()
java.math.BigDecimal | getQtyPicked()
java.math.BigDecimal | getQtyRequired()
java.math.BigDecimal | getQuantity()
java.lang.String | getRevision()
java.lang.String | getWarehousePrefix()
WorkOrderItemIssuePK | getWoItemIssuePk()
void | setComments(java.lang.String comments)
void | setDescription(java.lang.String description)
void | setLastDate(java.util.Date lastDate)
void | setLocation(java.lang.String location)
void | setOnhand(java.math.BigDecimal onhand)
void | setPartFrom(java.lang.String partFrom)
void | setPartOnhands(java.util.List partOnhands)
void | setPartPk(PartPK partPk)
void | setPartUnit(java.lang.String partUnit)
void | setQtyIssued(java.math.BigDecimal qtyIssued)
void | setQtyPicked(java.math.BigDecimal qtyPicked)
void | setQtyRequired(java.math.BigDecimal qtyRequired)
void | setQuantity(java.math.BigDecimal quantity)
void | setRevision(java.lang.String revision)
void | setWarehousePrefix(java.lang.String warehousePrefix)
void | setWoItemIssuePk(WorkOrderItemIssuePK woItemIssuePk)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WoItemPickListItemResult

public WoItemPickListItemResult()
Method Detail

getWoItemIssuePk

public WorkOrderItemIssuePK getWoItemIssuePk()

getPartPk

public PartPK getPartPk()

getPartFrom

public java.lang.String getPartFrom()

getDescription

public java.lang.String getDescription()

getLocation

public java.lang.String getLocation()

getQuantity

public java.math.BigDecimal getQuantity()

getQtyIssued

public java.math.BigDecimal getQtyIssued()

getQtyRequired

public java.math.BigDecimal getQtyRequired()

getOnhand

public java.math.BigDecimal getOnhand()

setWoItemIssuePk

public void setWoItemIssuePk(WorkOrderItemIssuePK woItemIssuePk)

setPartPk

public void setPartPk(PartPK partPk)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setDescription

public void setDescription(java.lang.String description)

setLocation

public void setLocation(java.lang.String location)

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

setQtyIssued

public void setQtyIssued(java.math.BigDecimal qtyIssued)

setQtyRequired

public void setQtyRequired(java.math.BigDecimal qtyRequired)

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getLastDate

public java.util.Date getLastDate()

setLastDate

public void setLastDate(java.util.Date lastDate)

getQtyPicked

public java.math.BigDecimal getQtyPicked()

setQtyPicked

public void setQtyPicked(java.math.BigDecimal qtyPicked)

getPartOnhands

public java.util.List getPartOnhands()

setPartOnhands

public void setPartOnhands(java.util.List partOnhands)

getWarehousePrefix

public java.lang.String getWarehousePrefix()

setWarehousePrefix

public void setWarehousePrefix(java.lang.String warehousePrefix)

getPartUnit

public java.lang.String getPartUnit()

setPartUnit

public void setPartUnit(java.lang.String partUnit)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WoItemPickListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WoItemPickListResult

java.lang.Object
    extended by  bb.common.WoItemPickListResult
All Implemented Interfaces:
java.io.Serializable
public class WoItemPickListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WoItemPickListResult()
Method Summary
java.lang.String | getChangeOrder()
java.util.Date | getDateRequired()
java.lang.String | getDescription()
java.util.Set<WoItemPickListItemResult> | getItems()
java.lang.String | getLocationPrefix()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.lang.String | getPartUnit()
java.lang.String | getProject()
java.math.BigDecimal | getQtyAsm()
java.math.BigDecimal | getQuantity()
java.util.Set | getRefDocTwoes()
java.lang.String | getRevision()
java.util.Date | getStartDate()
java.lang.String | getTopOrder()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
java.util.Date | getWoDate()
WorkOrderItemPK | getWoItemPk()
java.lang.String | getWoItemStatus()
java.lang.String | getWorkOrderItemComments()
java.lang.String | getWorkOrderItemPrivateNotes()
java.lang.String | getWoStatus()
void | setChangeOrder(java.lang.String changeOrder)
void | setDateRequired(java.util.Date dateRequired)
void | setDescription(java.lang.String description)
void | setItems(java.util.Set<WoItemPickListItemResult> items)
void | setLocationPrefix(java.lang.String locationPrefix)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setPartUnit(java.lang.String partUnit)
void | setProject(java.lang.String project)
void | setQtyAsm(java.math.BigDecimal qtyAsm)
void | setQuantity(java.math.BigDecimal quantity)
void | setRefDocTwoes(java.util.Set refDocTwoes)
void | setRevision(java.lang.String revision)
void | setStartDate(java.util.Date startDate)
void | setTopOrder(java.lang.String topOrder)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
void | setWoDate(java.util.Date woDate)
void | setWoItemPk(WorkOrderItemPK woItemPk)
void | setWoItemStatus(java.lang.String woItemStatus)
void | setWorkOrderItemComments(java.lang.String workOrderItemComments)
void | setWorkOrderItemPrivateNotes(java.lang.String workOrderItemPrivateNotes)
void | setWoStatus(java.lang.String woStatus)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WoItemPickListResult

public WoItemPickListResult()
Method Detail

setWoItemPk

public void setWoItemPk(WorkOrderItemPK woItemPk)

setPartPk

public void setPartPk(PartPK partPk)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setDescription

public void setDescription(java.lang.String description)

setWoStatus

public void setWoStatus(java.lang.String woStatus)

setWoItemStatus

public void setWoItemStatus(java.lang.String woItemStatus)

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

setWoDate

public void setWoDate(java.util.Date woDate)

setItems

public void setItems(java.util.Set<WoItemPickListItemResult> items)

setQtyAsm

public void setQtyAsm(java.math.BigDecimal qtyAsm)

getWoItemPk

public WorkOrderItemPK getWoItemPk()

getPartPk

public PartPK getPartPk()

getPartFrom

public java.lang.String getPartFrom()

getDescription

public java.lang.String getDescription()

getWoStatus

public java.lang.String getWoStatus()

getWoItemStatus

public java.lang.String getWoItemStatus()

getQuantity

public java.math.BigDecimal getQuantity()

getWoDate

public java.util.Date getWoDate()

getItems

public java.util.Set<WoItemPickListItemResult> getItems()

getQtyAsm

public java.math.BigDecimal getQtyAsm()

getRefDocTwoes

public java.util.Set getRefDocTwoes()

setRefDocTwoes

public void setRefDocTwoes(java.util.Set refDocTwoes)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getWorkOrderItemComments

public java.lang.String getWorkOrderItemComments()

setWorkOrderItemComments

public void setWorkOrderItemComments(java.lang.String workOrderItemComments)

getWorkOrderItemPrivateNotes

public java.lang.String getWorkOrderItemPrivateNotes()

setWorkOrderItemPrivateNotes

public void setWorkOrderItemPrivateNotes(java.lang.String workOrderItemPrivateNotes)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getVendorName

public java.lang.String getVendorName()

setVendorName

public void setVendorName(java.lang.String vendorName)

getTopOrder

public java.lang.String getTopOrder()

setTopOrder

public void setTopOrder(java.lang.String topOrder)

getDateRequired

public java.util.Date getDateRequired()

setDateRequired

public void setDateRequired(java.util.Date dateRequired)

getStartDate

public java.util.Date getStartDate()

setStartDate

public void setStartDate(java.util.Date startDate)

getPartUnit

public java.lang.String getPartUnit()

setPartUnit

public void setPartUnit(java.lang.String partUnit)

getLocationPrefix

public java.lang.String getLocationPrefix()

setLocationPrefix

public void setLocationPrefix(java.lang.String locationPrefix)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WoItemWorkInstructionListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WoItemWorkInstructionListResult

java.lang.Object
    extended by  bb.common.WoItemWorkInstructionListResult
All Implemented Interfaces:
java.io.Serializable
public class WoItemWorkInstructionListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DUEDATE
static java.lang.String | ORDER_BY_QTYK
static java.lang.String | ORDER_BY_WORKORDERITEMNUMBER
static java.lang.String | ORDER_BY_WORKORDERNUMBER
Constructor Summary
WoItemWorkInstructionListResult()
Method Summary
java.lang.String | getDescription()
java.util.Date | getDueDate()
BB2Part | getPart()
java.math.BigDecimal | getQty()
java.lang.String | getWorkOrderItemNumber()
java.lang.String | getWorkOrderNumber()
void | setDescription(java.lang.String description)
void | setDueDate(java.util.Date dueDate)
void | setPart(BB2Part part)
void | setQty(java.math.BigDecimal qty)
void | setWorkOrderItemNumber(java.lang.String workOrderItemNumber)
void | setWorkOrderNumber(java.lang.String workOrderNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_WORKORDERNUMBER

public static final java.lang.String ORDER_BY_WORKORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_WORKORDERITEMNUMBER

public static final java.lang.String ORDER_BY_WORKORDERITEMNUMBER
See Also:
Constant Field Values

ORDER_BY_QTYK

public static final java.lang.String ORDER_BY_QTYK
See Also:
Constant Field Values

ORDER_BY_DUEDATE

public static final java.lang.String ORDER_BY_DUEDATE
See Also:
Constant Field Values
Constructor Detail

WoItemWorkInstructionListResult

public WoItemWorkInstructionListResult()
Method Detail

setWorkOrderNumber

public void setWorkOrderNumber(java.lang.String workOrderNumber)

setWorkOrderItemNumber

public void setWorkOrderItemNumber(java.lang.String workOrderItemNumber)

setPart

public void setPart(BB2Part part)

setDescription

public void setDescription(java.lang.String description)

setQty

public void setQty(java.math.BigDecimal qty)

setDueDate

public void setDueDate(java.util.Date dueDate)

getWorkOrderNumber

public java.lang.String getWorkOrderNumber()

getWorkOrderItemNumber

public java.lang.String getWorkOrderItemNumber()

getPart

public BB2Part getPart()

getDescription

public java.lang.String getDescription()

getQty

public java.math.BigDecimal getQty()

getDueDate

public java.util.Date getDueDate()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WOReceiverDetail

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WOReceiverDetail

java.lang.Object
    extended by  bb.common.WOReceiverDetail
All Implemented Interfaces:
java.io.Serializable
public class WOReceiverDetail
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACCOUNTNUMBER
static java.lang.String | ORDER_BY_COMPANYUNITID
static java.lang.String | ORDER_BY_LASTCHANGEUSER
static java.lang.String | ORDER_BY_LOCATION
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PROJECT
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_WORKORDERITEMNUMBER
static java.lang.String | ORDER_BY_WORKORDERNUMBER
Constructor Summary
WOReceiverDetail()
Method Summary
java.lang.String | getAccountNumber()
java.lang.String | getComments()
java.lang.String | getCompanyUnitId()
java.math.BigDecimal | getCostPerUnit()
java.util.Date | getDateMade()
java.util.Date | getDateRequired()
java.lang.String | getDescription()
java.lang.String | getLastChangeUser()
java.lang.String | getLocation()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getProject()
java.math.BigDecimal | getQtyAssy()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getQuantityAsm()
java.math.BigDecimal | getStandardCost()
java.math.BigDecimal | getTotalWeight()
java.lang.String | getVendorId()
float | getWeight()
java.lang.String | getWeightUnit()
java.lang.String | getWorkOrderItemNumber()
java.lang.String | getWorkOrderNumber()
void | setAccountNumber(java.lang.String accountNumber)
void | setComments(java.lang.String comments)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCostPerUnit(java.math.BigDecimal costPerUnit)
void | setDateMade(java.util.Date dateMade)
void | setDateRequired(java.util.Date dateRequired)
void | setDescription(java.lang.String description)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLocation(java.lang.String location)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setProject(java.lang.String project)
void | setQtyAssy(java.math.BigDecimal qtyAssy)
void | setQuantity(java.math.BigDecimal quantity)
void | setQuantityAsm(java.math.BigDecimal quantityAsm)
void | setStandardCost(java.math.BigDecimal standardCost)
void | setTotalWeight(double totalWeight)
void | setVendorId(java.lang.String vendorId)
void | setWeight(float weight)
void | setWeightUnit(java.lang.String weightUnit)
void | setWorkOrderItemNumber(java.lang.String workOrderItemNumber)
void | setWorkOrderNumber(java.lang.String workOrderNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_WORKORDERNUMBER

public static final java.lang.String ORDER_BY_WORKORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_WORKORDERITEMNUMBER

public static final java.lang.String ORDER_BY_WORKORDERITEMNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_COMPANYUNITID

public static final java.lang.String ORDER_BY_COMPANYUNITID
See Also:
Constant Field Values

ORDER_BY_ACCOUNTNUMBER

public static final java.lang.String ORDER_BY_ACCOUNTNUMBER
See Also:
Constant Field Values

ORDER_BY_LOCATION

public static final java.lang.String ORDER_BY_LOCATION
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEUSER

public static final java.lang.String ORDER_BY_LASTCHANGEUSER
See Also:
Constant Field Values

ORDER_BY_PROJECT

public static final java.lang.String ORDER_BY_PROJECT
See Also:
Constant Field Values
Constructor Detail

WOReceiverDetail

public WOReceiverDetail()
Method Detail

setDateRequired

public void setDateRequired(java.util.Date dateRequired)

setWorkOrderNumber

public void setWorkOrderNumber(java.lang.String workOrderNumber)

getWorkOrderNumber

public java.lang.String getWorkOrderNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getPartNumber

public java.lang.String getPartNumber()

setWorkOrderItemNumber

public void setWorkOrderItemNumber(java.lang.String workOrderItemNumber)

getWorkOrderItemNumber

public java.lang.String getWorkOrderItemNumber()

getDateRequired

public java.util.Date getDateRequired()

setDateMade

public void setDateMade(java.util.Date dateMade)

getDateMade

public java.util.Date getDateMade()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getQuantity

public java.math.BigDecimal getQuantity()

setStandardCost

public void setStandardCost(java.math.BigDecimal standardCost)

getStandardCost

public java.math.BigDecimal getStandardCost()

setQtyAssy

public void setQtyAssy(java.math.BigDecimal qtyAssy)

getQtyAssy

public java.math.BigDecimal getQtyAssy()

setQuantityAsm

public void setQuantityAsm(java.math.BigDecimal quantityAsm)

getQuantityAsm

public java.math.BigDecimal getQuantityAsm()

setCostPerUnit

public void setCostPerUnit(java.math.BigDecimal costPerUnit)

setDescription

public void setDescription(java.lang.String description)

getCostPerUnit

public java.math.BigDecimal getCostPerUnit()

getDescription

public java.lang.String getDescription()

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

getWeightUnit

public java.lang.String getWeightUnit()

setWeightUnit

public void setWeightUnit(java.lang.String weightUnit)

getWeight

public float getWeight()

setWeight

public void setWeight(float weight)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getTotalWeight

public java.math.BigDecimal getTotalWeight()

setTotalWeight

public void setTotalWeight(double totalWeight)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkCalendarVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkCalendarVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.WorkCalendarVO
All Implemented Interfaces:
java.io.Serializable
public class WorkCalendarVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkCalendarVO()
Method Summary
boolean | equals(java.lang.Object obj)
java.lang.String | getComment()
java.util.Date | getDate()
java.lang.String | getDay()
java.util.Set | getTimePeriod()
java.lang.Long | getWorkDate()
int | hashCode()
void | setComment(java.lang.String comment)
void | setDate(java.util.Date date)
void | setDay(java.lang.String day)
void | setTimePeriod(java.util.Set timePeriod)
void | setWorkDate(java.lang.Long workDate)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkCalendarVO

public WorkCalendarVO()
Method Detail

getComment

public java.lang.String getComment()

setComment

public void setComment(java.lang.String comment)

getWorkDate

public java.lang.Long getWorkDate()

setWorkDate

public void setWorkDate(java.lang.Long workDate)

getTimePeriod

public java.util.Set getTimePeriod()

setTimePeriod

public void setTimePeriod(java.util.Set timePeriod)

getDay

public java.lang.String getDay()

setDay

public void setDay(java.lang.String day)

getDate

public java.util.Date getDate()

setDate

public void setDate(java.util.Date date)

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkCenterAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkCenterAgent

java.lang.Object
    extended by  bb.common.WorkCenterAgent
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
WorkCenterOnDateAgent
public class WorkCenterAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkCenterAgent(java.lang.String wcID, boolean group)
Method Summary
void | addAgent(java.lang.String agent)
void | clearAgent()
boolean | contains(java.lang.String agent)
boolean | equals(java.lang.Object other)
java.lang.String[] | getAgentsArray()
java.util.Date | getMaxDate()
java.util.Date | getMinDate()
java.lang.String | getWcID()
java.lang.String | getWorkOrder()
int | hashCode()
boolean | isEmpty()
boolean | isGroup()
void | setGroup(boolean group)
void | setMaxDate(java.util.Date maxDate)
void | setMinDate(java.util.Date minDate)
void | setWcID(java.lang.String wcID)
void | setWorkOrder(java.lang.String workOrder)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WorkCenterAgent

public WorkCenterAgent(java.lang.String wcID,
                       boolean group)
Method Detail

getWcID

public java.lang.String getWcID()

setWcID

public void setWcID(java.lang.String wcID)

isGroup

public boolean isGroup()

setGroup

public void setGroup(boolean group)

addAgent

public void addAgent(java.lang.String agent)

clearAgent

public void clearAgent()

contains

public boolean contains(java.lang.String agent)

isEmpty

public boolean isEmpty()

getAgentsArray

public java.lang.String[] getAgentsArray()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getMaxDate

public java.util.Date getMaxDate()

setMaxDate

public void setMaxDate(java.util.Date maxDate)

getMinDate

public java.util.Date getMinDate()

setMinDate

public void setMinDate(java.util.Date minDate)

getWorkOrder

public java.lang.String getWorkOrder()

setWorkOrder

public void setWorkOrder(java.lang.String workOrder)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkCenterGroupItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkCenterGroupItemPK

java.lang.Object
    extended by  bb.common.WorkCenterGroupItemPK
All Implemented Interfaces:
java.io.Serializable
public class WorkCenterGroupItemPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkCenterGroupItemPK()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getWorkCenterGroupId()
java.lang.String | getWorkCenterGroupItemNumber()
int | hashCode()
void | setWorkCenterGroupId(java.lang.String workCenterGroupId)
void | setWorkCenterGroupItemNumber(java.lang.String workCenterGroupItemNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WorkCenterGroupItemPK

public WorkCenterGroupItemPK()
Method Detail

setWorkCenterGroupId

public void setWorkCenterGroupId(java.lang.String workCenterGroupId)

getWorkCenterGroupId

public java.lang.String getWorkCenterGroupId()

setWorkCenterGroupItemNumber

public void setWorkCenterGroupItemNumber(java.lang.String workCenterGroupItemNumber)

getWorkCenterGroupItemNumber

public java.lang.String getWorkCenterGroupItemNumber()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkCenterGroupItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkCenterGroupItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.WorkCenterGroupItemVO
All Implemented Interfaces:
java.io.Serializable
public class WorkCenterGroupItemVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_PK
static java.lang.String | ORDER_BY_WORKCENTERID
Constructor Summary
WorkCenterGroupItemVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
WorkCenterGroupItemPK | getPk()
WorkCenterVO | getWorkCenter()
java.lang.String | getWorkCenterId()
int | hashCode()
void | setPk(WorkCenterGroupItemPK pk)
void | setWorkCenter(WorkCenterVO workCenter)
void | setWorkCenterId(java.lang.String workCenterId)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PK

public static final java.lang.String ORDER_BY_PK
See Also:
Constant Field Values

ORDER_BY_WORKCENTERID

public static final java.lang.String ORDER_BY_WORKCENTERID
See Also:
Constant Field Values
Constructor Detail

WorkCenterGroupItemVO

public WorkCenterGroupItemVO()
default constructor

Method Detail

getPk

public WorkCenterGroupItemPK getPk()

setPk

public void setPk(WorkCenterGroupItemPK pk)

getWorkCenterId

public java.lang.String getWorkCenterId()

setWorkCenterId

public void setWorkCenterId(java.lang.String workCenterId)

getWorkCenter

public WorkCenterVO getWorkCenter()

setWorkCenter

public void setWorkCenter(WorkCenterVO workCenter)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkCenterLoadAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkCenterLoadAgent

java.lang.Object
    extended by  bb.common.WorkCenterLoadAgent
All Implemented Interfaces:
java.io.Serializable
public class WorkCenterLoadAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static int n
Constructor Summary
WorkCenterLoadAgent()
Method Summary
java.lang.String | getDepartmentLike()
java.util.Date | getFromDate()
int | getNdays()
java.util.Date | getToDate()
java.lang.String | getWorkCenterLike()
boolean | isFullload()
void | setDepartmentLike(java.lang.String departmentLike)
void | setFromDate(java.util.Date fromDate)
void | setFullload(boolean fullload)
void | setToDate(java.util.Date toDate)
void | setWorkCenterLike(java.lang.String workCenterLike)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

n

public static final int n
See Also:
Constant Field Values
Constructor Detail

WorkCenterLoadAgent

public WorkCenterLoadAgent()
Method Detail

isFullload

public boolean isFullload()

setFullload

public void setFullload(boolean fullload)

setWorkCenterLike

public void setWorkCenterLike(java.lang.String workCenterLike)

setDepartmentLike

public void setDepartmentLike(java.lang.String departmentLike)

setFromDate

public void setFromDate(java.util.Date fromDate)

setToDate

public void setToDate(java.util.Date toDate)

getWorkCenterLike

public java.lang.String getWorkCenterLike()

getDepartmentLike

public java.lang.String getDepartmentLike()

getFromDate

public java.util.Date getFromDate()

getToDate

public java.util.Date getToDate()

getNdays

public int getNdays()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkCenterLoadListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkCenterLoadListResult

java.lang.Object
    extended by  bb.common.WorkCenterLoadListResult
All Implemented Interfaces:
java.io.Serializable
public class WorkCenterLoadListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkCenterLoadListResult()
Method Summary
java.lang.String | getDepartment()
java.lang.String | getDescription()
java.util.List<WCLoadDetailResult> | getLoadDetailList()
java.math.BigDecimal | getLoadHrs()
java.math.BigDecimal | getMaxLoad()
java.math.BigDecimal | getPercent(int length)
java.math.BigDecimal | getSetupHrs()
java.math.BigDecimal | getTotalHrs()
java.lang.String | getWorkCenter()
boolean | isGroup()
void | setDepartment(java.lang.String department)
void | setDescription(java.lang.String description)
void | setGroup(boolean group)
void | setLoadDetailList(java.util.List<WCLoadDetailResult> loadDetailList)
void | setLoadHrs(java.math.BigDecimal loadHrs)
void | setMaxLoad(java.math.BigDecimal maxLoad)
void | setSetupHrs(java.math.BigDecimal setupHrs)
void | setTotalHrs(java.math.BigDecimal totalHrs)
void | setWorkCenter(java.lang.String workCenter)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkCenterLoadListResult

public WorkCenterLoadListResult()
Method Detail

isGroup

public boolean isGroup()

setGroup

public void setGroup(boolean group)

setWorkCenter

public void setWorkCenter(java.lang.String workCenter)

setDescription

public void setDescription(java.lang.String description)

setDepartment

public void setDepartment(java.lang.String department)

setMaxLoad

public void setMaxLoad(java.math.BigDecimal maxLoad)

setSetupHrs

public void setSetupHrs(java.math.BigDecimal setupHrs)

setLoadHrs

public void setLoadHrs(java.math.BigDecimal loadHrs)

setTotalHrs

public void setTotalHrs(java.math.BigDecimal totalHrs)

getWorkCenter

public java.lang.String getWorkCenter()

getDescription

public java.lang.String getDescription()

getDepartment

public java.lang.String getDepartment()

getMaxLoad

public java.math.BigDecimal getMaxLoad()

getSetupHrs

public java.math.BigDecimal getSetupHrs()

getLoadHrs

public java.math.BigDecimal getLoadHrs()

getTotalHrs

public java.math.BigDecimal getTotalHrs()

getPercent

public java.math.BigDecimal getPercent(int length)

getLoadDetailList

public java.util.List<WCLoadDetailResult> getLoadDetailList()

setLoadDetailList

public void setLoadDetailList(java.util.List<WCLoadDetailResult> loadDetailList)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkCenterOnDateAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkCenterOnDateAgent

java.lang.Object
    extended by  bb.common.WorkCenterAgent
        extended by  bb.common.WorkCenterOnDateAgent
All Implemented Interfaces:
java.io.Serializable
public final class WorkCenterOnDateAgent
extends WorkCenterAgent

See Also:
Serialized Form

Constructor Summary
WorkCenterOnDateAgent(java.lang.String wcID, boolean group)
Method Summary
java.util.Date | getDate()
java.util.Date | getEndDate()
void | setDate(java.util.Date date)
void | setEndDate(java.util.Date endDate)
Methods inherited from class bb.common.WorkCenterAgent
addAgent, clearAgent, contains, equals, getAgentsArray, getMaxDate, getMinDate, getWcID, getWorkOrder, hashCode, isEmpty, isGroup, setGroup, setMaxDate, setMinDate, setWcID, setWorkOrder, toString
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WorkCenterOnDateAgent

public WorkCenterOnDateAgent(java.lang.String wcID,
                             boolean group)
Method Detail

getDate

public java.util.Date getDate()

setDate

public void setDate(java.util.Date date)

getEndDate

public java.util.Date getEndDate()

setEndDate

public void setEndDate(java.util.Date endDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkCenterRunTimeAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkCenterRunTimeAgent

java.lang.Object
    extended by  bb.common.WorkCenterRunTimeAgent
All Implemented Interfaces:
java.io.Serializable
public class WorkCenterRunTimeAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkCenterRunTimeAgent()
Method Summary
java.util.Date | getFromDate()
java.util.Date | getToDate()
java.lang.String | getWorkCenter()
void | setFromDate(java.util.Date fromDate)
void | setToDate(java.util.Date toDate)
void | setWorkCenter(java.lang.String workCenter)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkCenterRunTimeAgent

public WorkCenterRunTimeAgent()
Method Detail

setWorkCenter

public void setWorkCenter(java.lang.String workCenter)

setFromDate

public void setFromDate(java.util.Date fromDate)

setToDate

public void setToDate(java.util.Date toDate)

getWorkCenter

public java.lang.String getWorkCenter()

getFromDate

public java.util.Date getFromDate()

getToDate

public java.util.Date getToDate()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkCenterRunTimeListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkCenterRunTimeListResult

java.lang.Object
    extended by  bb.common.WorkCenterRunTimeListResult
All Implemented Interfaces:
java.io.Serializable
public class WorkCenterRunTimeListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AVGHRS
static java.lang.String | ORDER_BY_AVGSETUP
static java.lang.String | ORDER_BY_DUEDATE
static java.lang.String | ORDER_BY_SEQNUMBER
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_WORKCENTER
static java.lang.String | ORDER_BY_WORKORDERITEMNUMBER
static java.lang.String | ORDER_BY_WORKORDERNUMBER
Constructor Summary
WorkCenterRunTimeListResult()
Method Summary
java.math.BigDecimal | getAvgHrs()
java.math.BigDecimal | getAvgSetup()
java.lang.String | getDescription()
java.util.Date | getDueDate()
java.math.BigDecimal | getNotCompletedQty()
BB2Part | getPart()
java.lang.String | getSeqNumber()
java.math.BigDecimal | getSumHrs()
java.math.BigDecimal | getSumSetup()
java.math.BigDecimal | getSumTime()
java.lang.String | getVendorId()
java.lang.String | getWorkCenter()
java.lang.String | getWorkOrderItemNumber()
java.lang.String | getWorkOrderNumber()
void | setAvgHrs(java.math.BigDecimal avgHrs)
void | setAvgSetup(java.math.BigDecimal avgSetup)
void | setDescription(java.lang.String description)
void | setDueDate(java.util.Date dueDate)
void | setNotCompletedQty(java.math.BigDecimal notCompletedQty)
void | setPart(BB2Part part)
void | setSeqNumber(java.lang.String seqNumber)
void | setSumHrs(java.math.BigDecimal sumHrs)
void | setSumSetup(java.math.BigDecimal sumSetup)
void | setSumTime(java.math.BigDecimal sumTime)
void | setVendorId(java.lang.String vendorId)
void | setWorkCenter(java.lang.String workCenter)
void | setWorkOrderItemNumber(java.lang.String workOrderItemNumber)
void | setWorkOrderNumber(java.lang.String workOrderNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_WORKORDERNUMBER

public static final java.lang.String ORDER_BY_WORKORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_WORKORDERITEMNUMBER

public static final java.lang.String ORDER_BY_WORKORDERITEMNUMBER
See Also:
Constant Field Values

ORDER_BY_DUEDATE

public static final java.lang.String ORDER_BY_DUEDATE
See Also:
Constant Field Values

ORDER_BY_SEQNUMBER

public static final java.lang.String ORDER_BY_SEQNUMBER
See Also:
Constant Field Values

ORDER_BY_WORKCENTER

public static final java.lang.String ORDER_BY_WORKCENTER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_AVGSETUP

public static final java.lang.String ORDER_BY_AVGSETUP
See Also:
Constant Field Values

ORDER_BY_AVGHRS

public static final java.lang.String ORDER_BY_AVGHRS
See Also:
Constant Field Values
Constructor Detail

WorkCenterRunTimeListResult

public WorkCenterRunTimeListResult()
Method Detail

setWorkOrderNumber

public void setWorkOrderNumber(java.lang.String workOrderNumber)

setWorkOrderItemNumber

public void setWorkOrderItemNumber(java.lang.String workOrderItemNumber)

setPart

public void setPart(BB2Part part)

setDescription

public void setDescription(java.lang.String description)

setNotCompletedQty

public void setNotCompletedQty(java.math.BigDecimal notCompletedQty)

setDueDate

public void setDueDate(java.util.Date dueDate)

setSeqNumber

public void setSeqNumber(java.lang.String seqNumber)

setWorkCenter

public void setWorkCenter(java.lang.String workCenter)

setVendorId

public void setVendorId(java.lang.String vendorId)

setAvgSetup

public void setAvgSetup(java.math.BigDecimal avgSetup)

setAvgHrs

public void setAvgHrs(java.math.BigDecimal avgHrs)

setSumSetup

public void setSumSetup(java.math.BigDecimal sumSetup)

setSumHrs

public void setSumHrs(java.math.BigDecimal sumHrs)

setSumTime

public void setSumTime(java.math.BigDecimal sumTime)

getWorkOrderNumber

public java.lang.String getWorkOrderNumber()

getWorkOrderItemNumber

public java.lang.String getWorkOrderItemNumber()

getPart

public BB2Part getPart()

getDescription

public java.lang.String getDescription()

getNotCompletedQty

public java.math.BigDecimal getNotCompletedQty()

getDueDate

public java.util.Date getDueDate()

getSeqNumber

public java.lang.String getSeqNumber()

getWorkCenter

public java.lang.String getWorkCenter()

getVendorId

public java.lang.String getVendorId()

getAvgSetup

public java.math.BigDecimal getAvgSetup()

getAvgHrs

public java.math.BigDecimal getAvgHrs()

getSumSetup

public java.math.BigDecimal getSumSetup()

getSumHrs

public java.math.BigDecimal getSumHrs()

getSumTime

public java.math.BigDecimal getSumTime()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkCenterRunTimeTotalResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkCenterRunTimeTotalResult

java.lang.Object
    extended by  bb.common.WorkCenterRunTimeTotalResult
All Implemented Interfaces:
java.io.Serializable
public class WorkCenterRunTimeTotalResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkCenterRunTimeTotalResult()
Method Summary
java.util.Date | getFromDate()
java.math.BigDecimal | getSumRunTime()
java.math.BigDecimal | getSumSetupTime()
java.math.BigDecimal | getSumTime()
java.util.Date | getToDate()
java.lang.String | getWorkCenter()
void | setFromDate(java.util.Date fromDate)
void | setSumRunTime(java.math.BigDecimal sumRunTime)
void | setSumSetupTime(java.math.BigDecimal sumSetupTime)
void | setSumTime(java.math.BigDecimal sumTime)
void | setToDate(java.util.Date toDate)
void | setWorkCenter(java.lang.String workCenter)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkCenterRunTimeTotalResult

public WorkCenterRunTimeTotalResult()
Method Detail

setWorkCenter

public void setWorkCenter(java.lang.String workCenter)

setFromDate

public void setFromDate(java.util.Date fromDate)

setToDate

public void setToDate(java.util.Date toDate)

setSumSetupTime

public void setSumSetupTime(java.math.BigDecimal sumSetupTime)

setSumRunTime

public void setSumRunTime(java.math.BigDecimal sumRunTime)

setSumTime

public void setSumTime(java.math.BigDecimal sumTime)

getWorkCenter

public java.lang.String getWorkCenter()

getFromDate

public java.util.Date getFromDate()

getToDate

public java.util.Date getToDate()

getSumSetupTime

public java.math.BigDecimal getSumSetupTime()

getSumRunTime

public java.math.BigDecimal getSumRunTime()

getSumTime

public java.math.BigDecimal getSumTime()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkCenterVendorPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkCenterVendorPK

java.lang.Object
    extended by  bb.common.WorkCenterVendorPK
All Implemented Interfaces:
java.io.Serializable
public class WorkCenterVendorPK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkCenterVendorPK()
WorkCenterVendorPK(java.lang.String workCenterId, java.lang.String vendorId)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getVendorId()
java.lang.String | getWorkCenterId()
int | hashCode()
void | setVendorId(java.lang.String vendorId)
void | setWorkCenterId(java.lang.String workCenterId)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WorkCenterVendorPK

public WorkCenterVendorPK()

WorkCenterVendorPK

public WorkCenterVendorPK(java.lang.String workCenterId,
                          java.lang.String vendorId)
Method Detail

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getWorkCenterId

public java.lang.String getWorkCenterId()

setWorkCenterId

public void setWorkCenterId(java.lang.String workCenterId)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkCenterVendorVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkCenterVendorVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.WorkCenterVendorVO
All Implemented Interfaces:
java.io.Serializable
public class WorkCenterVendorVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkCenterVendorVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getDefaultVendor()
WorkCenterVendorPK | getPk()
java.lang.String | getVendorName()
int | hashCode()
void | setDefaultVendor(java.lang.String defaultVendor)
void | setPk(WorkCenterVendorPK pk)
void | setVendorName(java.lang.String vendorName)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WorkCenterVendorVO

public WorkCenterVendorVO()
Method Detail

getDefaultVendor

public java.lang.String getDefaultVendor()

setDefaultVendor

public void setDefaultVendor(java.lang.String defaultVendor)

getPk

public WorkCenterVendorPK getPk()

setPk

public void setPk(WorkCenterVendorPK pk)

getVendorName

public java.lang.String getVendorName()

setVendorName

public void setVendorName(java.lang.String vendorName)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkCenterVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkCenterVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.WorkCenterVO
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable
public class WorkCenterVO
extends VO
implements java.io.Serializable, java.lang.Comparable

Title:

Description: same as body of class WorkCenter

Copyright: Copyright (c) 2004

Company:

Version:
1.0
Author:
Henry Liu
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DEPARTMENT
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_LASTCHANGEUSER
static java.lang.String | ORDER_BY_WORKCENTERID
Constructor Summary
WorkCenterVO()
default constructor
Method Summary
int | compareTo(java.lang.Object o)
boolean | equals(java.lang.Object other)
java.lang.String | getCostCenter()
java.math.BigDecimal | getDaysPerWeek()
java.lang.String | getDepartment()
java.lang.String | getDescription()
EquipmentVO | getEquipment()
java.lang.String | getEquipmentID()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.math.BigDecimal | getMachineHoursPerDay()
java.math.BigDecimal | getMachinePay()
java.math.BigDecimal | getMachinePerformance()
java.math.BigDecimal | getMachineQty()
java.lang.String | getOrigin()
WorkCenterVO | getParentWorkCenter()
java.math.BigDecimal | getQty()
java.lang.String | getWorkCenterGroupFlag()
java.lang.String | getWorkCenterGroupId()
java.lang.String | getWorkCenterId()
java.util.Set<WorkCenterVO> | getWorkCenterItems()
java.lang.String | getWorkCenterType()
java.util.Set | getWorkCenterVendors()
java.math.BigDecimal | getWorkerHoursPerDay()
java.math.BigDecimal | getWorkerPay()
java.math.BigDecimal | getWorkerPerformance()
java.math.BigDecimal | getWorkerQty()
java.math.BigDecimal | getWorkLoad()
int | hashCode()
void | setCostCenter(java.lang.String costCenter)
void | setDaysPerWeek(java.math.BigDecimal daysPerWeek)
void | setDepartment(java.lang.String department)
void | setDescription(java.lang.String description)
void | setEquipment(EquipmentVO equipment)
void | setEquipmentID(java.lang.String equipmentID)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setMachineHoursPerDay(java.math.BigDecimal machineHoursPerDay)
void | setMachinePay(java.math.BigDecimal machinePay)
void | setMachinePerformance(java.math.BigDecimal machinePerformance)
void | setMachineQty(java.math.BigDecimal machineQty)
void | setOrigin(java.lang.String origin)
void | setParentWorkCenter(WorkCenterVO parentWorkCenter)
void | setWorkCenterGroupFlag(java.lang.String workCenterGroupFlag)
void | setWorkCenterGroupId(java.lang.String workCenterGroupId)
void | setWorkCenterId(java.lang.String workCenterId)
void | setWorkCenterItems(java.util.Set<WorkCenterVO> workCenterItems)
void | setWorkCenterType(java.lang.String workCenterType)
void | setWorkCenterVendors(java.util.Set workCenterVendors)
void | setWorkerHoursPerDay(java.math.BigDecimal workerHoursPerDay)
void | setWorkerPay(java.math.BigDecimal workerPay)
void | setWorkerPerformance(java.math.BigDecimal workerPerformance)
void | setWorkerQty(java.math.BigDecimal workerQty)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_WORKCENTERID

public static final java.lang.String ORDER_BY_WORKCENTERID
See Also:
Constant Field Values

ORDER_BY_LASTCHANGEUSER

public static final java.lang.String ORDER_BY_LASTCHANGEUSER
See Also:
Constant Field Values

ORDER_BY_DEPARTMENT

public static final java.lang.String ORDER_BY_DEPARTMENT
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

WorkCenterVO

public WorkCenterVO()
default constructor

Method Detail

getWorkLoad

public java.math.BigDecimal getWorkLoad()

getQty

public java.math.BigDecimal getQty()

getWorkCenterId

public java.lang.String getWorkCenterId()

setWorkCenterId

public void setWorkCenterId(java.lang.String workCenterId)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getDaysPerWeek

public java.math.BigDecimal getDaysPerWeek()

setDaysPerWeek

public void setDaysPerWeek(java.math.BigDecimal daysPerWeek)

getDepartment

public java.lang.String getDepartment()

setDepartment

public void setDepartment(java.lang.String department)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getWorkCenterVendors

public java.util.Set getWorkCenterVendors()

setWorkCenterVendors

public void setWorkCenterVendors(java.util.Set workCenterVendors)

getCostCenter

public java.lang.String getCostCenter()

setCostCenter

public void setCostCenter(java.lang.String costCenter)

getMachineHoursPerDay

public java.math.BigDecimal getMachineHoursPerDay()

setMachineHoursPerDay

public void setMachineHoursPerDay(java.math.BigDecimal machineHoursPerDay)

getMachinePay

public java.math.BigDecimal getMachinePay()

setMachinePay

public void setMachinePay(java.math.BigDecimal machinePay)

getMachinePerformance

public java.math.BigDecimal getMachinePerformance()

setMachinePerformance

public void setMachinePerformance(java.math.BigDecimal machinePerformance)

getMachineQty

public java.math.BigDecimal getMachineQty()

setMachineQty

public void setMachineQty(java.math.BigDecimal machineQty)

getWorkCenterType

public java.lang.String getWorkCenterType()

setWorkCenterType

public void setWorkCenterType(java.lang.String workCenterType)

getWorkerPay

public java.math.BigDecimal getWorkerPay()

setWorkerPay

public void setWorkerPay(java.math.BigDecimal workerPay)

getWorkerPerformance

public java.math.BigDecimal getWorkerPerformance()

setWorkerPerformance

public void setWorkerPerformance(java.math.BigDecimal workerPerformance)

getWorkerQty

public java.math.BigDecimal getWorkerQty()

setWorkerQty

public void setWorkerQty(java.math.BigDecimal workerQty)

getWorkerHoursPerDay

public java.math.BigDecimal getWorkerHoursPerDay()

setWorkerHoursPerDay

public void setWorkerHoursPerDay(java.math.BigDecimal workerHoursPerDay)

getWorkCenterGroupId

public java.lang.String getWorkCenterGroupId()

setWorkCenterGroupId

public void setWorkCenterGroupId(java.lang.String workCenterGroupId)

getWorkCenterGroupFlag

public java.lang.String getWorkCenterGroupFlag()

setWorkCenterGroupFlag

public void setWorkCenterGroupFlag(java.lang.String workCenterGroupFlag)

getWorkCenterItems

public java.util.Set<WorkCenterVO> getWorkCenterItems()

setWorkCenterItems

public void setWorkCenterItems(java.util.Set<WorkCenterVO> workCenterItems)

getParentWorkCenter

public WorkCenterVO getParentWorkCenter()

setParentWorkCenter

public void setParentWorkCenter(WorkCenterVO parentWorkCenter)

getEquipment

public EquipmentVO getEquipment()

setEquipment

public void setEquipment(EquipmentVO equipment)

getEquipmentID

public java.lang.String getEquipmentID()

setEquipmentID

public void setEquipmentID(java.lang.String equipmentID)

compareTo

public int compareTo(java.lang.Object o)
Specified by:
compareTo in interface java.lang.Comparable
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkFlowVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkFlowVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.WorkFlowVO
All Implemented Interfaces:
java.io.Serializable
public class WorkFlowVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkFlowVO()
Method Summary
java.lang.String | getCreateBy()
java.lang.String | getDescription()
java.lang.String | getLastBy()
java.util.Date | getLastChangeDate()
byte[] | getWorkFlowData()
java.lang.String | getWorkFlowName()
void | setCreateBy(java.lang.String createBy)
void | setDescription(java.lang.String description)
void | setLastBy(java.lang.String lastBy)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setWorkFlowData(byte[] workFlowData)
void | setWorkFlowName(java.lang.String workFlowName)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkFlowVO

public WorkFlowVO()
Method Detail

setCreateBy

public void setCreateBy(java.lang.String createBy)

getCreateBy

public java.lang.String getCreateBy()

setWorkFlowName

public void setWorkFlowName(java.lang.String workFlowName)

getWorkFlowName

public java.lang.String getWorkFlowName()

setWorkFlowData

public void setWorkFlowData(byte[] workFlowData)

getWorkFlowData

public byte[] getWorkFlowData()

setLastBy

public void setLastBy(java.lang.String lastBy)

getLastBy

public java.lang.String getLastBy()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeDate

public java.util.Date getLastChangeDate()

setDescription

public void setDescription(java.lang.String description)

getDescription

public java.lang.String getDescription()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkInstructionApprovalVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkInstructionApprovalVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.WorkInstructionApprovalVO
All Implemented Interfaces:
java.io.Serializable
public class WorkInstructionApprovalVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_CANAPPROVEOWNWORKINSTRUCTION
static java.lang.String | ORDER_BY_EMPLOYEEID
Constructor Summary
WorkInstructionApprovalVO()
WorkInstructionApprovalVO(java.lang.String employeeId)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.lang.String | getEmployeeId()
java.lang.String | getName()
int | hashCode()
boolean | isCanApproveOwnWorkInstruction()
void | setCanApproveOwnWorkInstruction(boolean canApproveOwnWorkInstruction)
void | setComments(java.lang.String comments)
void | setEmployeeId(java.lang.String employeeId)
void | setName(java.lang.String name)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_EMPLOYEEID

public static final java.lang.String ORDER_BY_EMPLOYEEID
See Also:
Constant Field Values

ORDER_BY_CANAPPROVEOWNWORKINSTRUCTION

public static final java.lang.String ORDER_BY_CANAPPROVEOWNWORKINSTRUCTION
See Also:
Constant Field Values
Constructor Detail

WorkInstructionApprovalVO

public WorkInstructionApprovalVO(java.lang.String employeeId)

WorkInstructionApprovalVO

public WorkInstructionApprovalVO()
Method Detail

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

isCanApproveOwnWorkInstruction

public boolean isCanApproveOwnWorkInstruction()

setCanApproveOwnWorkInstruction

public void setCanApproveOwnWorkInstruction(boolean canApproveOwnWorkInstruction)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkInstructionDocumentVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkInstructionDocumentVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.WorkInstructionDocumentVO
All Implemented Interfaces:
java.io.Serializable
public class WorkInstructionDocumentVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
WorkInstructionDocumentVO()
Method Summary
java.lang.String | getComments()
java.lang.String | getDocDescription()
java.lang.String | getDocFileName()
long | getDocLength()
java.util.Date | getDocumentDate()
java.lang.String | getExtension()
java.lang.Long | getIi()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getSetId()
void | setComments(java.lang.String comments)
void | setDocDescription(java.lang.String docDescription)
void | setDocFileName(java.lang.String docFileName)
void | setDocLength(long docLength)
void | setDocumentDate(java.util.Date documentDate)
void | setExtension(java.lang.String extension)
void | setIi(java.lang.Long ii)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setSetId(java.lang.String setId)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkInstructionDocumentVO

public WorkInstructionDocumentVO()
Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getDocDescription

public java.lang.String getDocDescription()

setDocDescription

public void setDocDescription(java.lang.String docDescription)

getDocFileName

public java.lang.String getDocFileName()

setDocFileName

public void setDocFileName(java.lang.String docFileName)

getDocLength

public long getDocLength()

setDocLength

public void setDocLength(long docLength)

getDocumentDate

public java.util.Date getDocumentDate()

setDocumentDate

public void setDocumentDate(java.util.Date documentDate)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getSetId

public java.lang.String getSetId()

setSetId

public void setSetId(java.lang.String setId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkInstructionListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkInstructionListResult

java.lang.Object
    extended by  bb.common.WorkInstructionListResult
All Implemented Interfaces:
java.io.Serializable
public class WorkInstructionListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_APPROVED
static java.lang.String | ORDER_BY_APPROVEDBY
static java.lang.String | ORDER_BY_AUTHOR
static java.lang.String | ORDER_BY_EFFECTIVEDATE
static java.lang.String | ORDER_BY_ENGINEERINGDESCRIPTION
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PROOFREADER
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_WIDESCRIPTION
Constructor Summary
WorkInstructionListResult()
Method Summary
java.util.Date | getApproved()
java.lang.String | getApprovedBy()
java.lang.String | getAuthor()
java.lang.String | getDefaultWi()
java.util.Date | getEffectiveDate()
java.lang.String | getEngineeringDescription()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartRev()
java.lang.String | getPartType()
java.lang.String | getProofreader()
java.lang.String | getSetId()
java.lang.String | getStatus()
java.lang.String | getWiDescription()
java.lang.String | getWiNumber()
java.lang.String | getWorkInstructionRev()
void | setApproved(java.util.Date approved)
void | setApprovedBy(java.lang.String approvedBy)
void | setAuthor(java.lang.String author)
void | setDefaultWi(java.lang.String defaultWi)
void | setEffectiveDate(java.util.Date effectiveDate)
void | setEngineeringDescription(java.lang.String engineeringDescription)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartRev(java.lang.String partRev)
void | setPartType(java.lang.String partType)
void | setProofreader(java.lang.String proofreader)
void | setSetId(java.lang.String setId)
void | setStatus(java.lang.String status)
void | setWiDescription(java.lang.String wiDescription)
void | setWiNumber(java.lang.String wiNumber)
void | setWorkInstructionRev(java.lang.String workInstructionRev)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_ENGINEERINGDESCRIPTION

public static final java.lang.String ORDER_BY_ENGINEERINGDESCRIPTION
See Also:
Constant Field Values

ORDER_BY_AUTHOR

public static final java.lang.String ORDER_BY_AUTHOR
See Also:
Constant Field Values

ORDER_BY_PROOFREADER

public static final java.lang.String ORDER_BY_PROOFREADER
See Also:
Constant Field Values

ORDER_BY_APPROVEDBY

public static final java.lang.String ORDER_BY_APPROVEDBY
See Also:
Constant Field Values

ORDER_BY_APPROVED

public static final java.lang.String ORDER_BY_APPROVED
See Also:
Constant Field Values

ORDER_BY_EFFECTIVEDATE

public static final java.lang.String ORDER_BY_EFFECTIVEDATE
See Also:
Constant Field Values

ORDER_BY_WIDESCRIPTION

public static final java.lang.String ORDER_BY_WIDESCRIPTION
See Also:
Constant Field Values
Constructor Detail

WorkInstructionListResult

public WorkInstructionListResult()
Method Detail

getWiDescription

public java.lang.String getWiDescription()

setWiDescription

public void setWiDescription(java.lang.String wiDescription)

getWorkInstructionRev

public java.lang.String getWorkInstructionRev()

getSetId

public java.lang.String getSetId()

getPartFrom

public java.lang.String getPartFrom()

getPartType

public java.lang.String getPartType()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

setWorkInstructionRev

public void setWorkInstructionRev(java.lang.String workInstructionRev)

setSetId

public void setSetId(java.lang.String setId)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setPartType

public void setPartType(java.lang.String partType)

setDefaultWi

public void setDefaultWi(java.lang.String defaultWi)

setStatus

public void setStatus(java.lang.String status)

setAuthor

public void setAuthor(java.lang.String author)

setPartRev

public void setPartRev(java.lang.String partRev)

setEngineeringDescription

public void setEngineeringDescription(java.lang.String engineeringDescription)

setWiNumber

public void setWiNumber(java.lang.String wiNumber)

getPartNumber

public java.lang.String getPartNumber()

getDefaultWi

public java.lang.String getDefaultWi()

getStatus

public java.lang.String getStatus()

getAuthor

public java.lang.String getAuthor()

getPartRev

public java.lang.String getPartRev()

getEngineeringDescription

public java.lang.String getEngineeringDescription()

getWiNumber

public java.lang.String getWiNumber()

getProofreader

public java.lang.String getProofreader()

setProofreader

public void setProofreader(java.lang.String proofreader)

getApproved

public java.util.Date getApproved()

setApproved

public void setApproved(java.util.Date approved)

getApprovedBy

public java.lang.String getApprovedBy()

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)

getEffectiveDate

public java.util.Date getEffectiveDate()

setEffectiveDate

public void setEffectiveDate(java.util.Date effectiveDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkInstructionPictureVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkInstructionPictureVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.WorkInstructionPictureVO
All Implemented Interfaces:
java.io.Serializable
public class WorkInstructionPictureVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkInstructionPictureVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getExtension()
short | getHeight()
java.lang.Long | getIi()
java.lang.String | getItemNumber()
java.lang.String | getLastChangeUser()
java.util.Date | getLdate()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
byte[] | getPicture()
java.lang.String | getSequenceNumber()
java.lang.String | getSetId()
short | getWidth()
int | hashCode()
void | setExtension(java.lang.String extension)
void | setHeight(short height)
void | setIi(java.lang.Long ii)
void | setItemNumber(java.lang.String itemNumber)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLdate(java.util.Date ldate)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPicture(byte[] picture)
void | setSequenceNumber(java.lang.String sequenceNumber)
void | setSetId(java.lang.String setId)
void | setWidth(short width)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WorkInstructionPictureVO

public WorkInstructionPictureVO()
default constructor

Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getSequenceNumber

public java.lang.String getSequenceNumber()

setSequenceNumber

public void setSequenceNumber(java.lang.String sequenceNumber)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getWidth

public short getWidth()

setWidth

public void setWidth(short width)

getHeight

public short getHeight()

setHeight

public void setHeight(short height)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

getLdate

public java.util.Date getLdate()

getSetId

public java.lang.String getSetId()

getPicture

public byte[] getPicture()

setLdate

public void setLdate(java.util.Date ldate)

setSetId

public void setSetId(java.lang.String setId)

setPicture

public void setPicture(byte[] picture)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getItemNumber

public java.lang.String getItemNumber()

setItemNumber

public void setItemNumber(java.lang.String itemNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkInstructionPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkInstructionPK

java.lang.Object
    extended by  bb.common.WorkInstructionPK
All Implemented Interfaces:
java.io.Serializable
public class WorkInstructionPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
WorkInstructionPK()
default constructor
WorkInstructionPK(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String setId)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getSetId()
int | hashCode()
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setSetId(java.lang.String setId)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WorkInstructionPK

public WorkInstructionPK(java.lang.String partNumber,
                         java.lang.String partType,
                         java.lang.String partFrom,
                         java.lang.String setId)
full constructor

WorkInstructionPK

public WorkInstructionPK()
default constructor

Method Detail

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getSetId

public java.lang.String getSetId()

setSetId

public void setSetId(java.lang.String setId)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkInstructionRequestForChangeVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkInstructionRequestForChangeVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.WorkInstructionRequestForChangeVO
All Implemented Interfaces:
java.io.Serializable
public class WorkInstructionRequestForChangeVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_APPROVEDBY
static java.lang.String | ORDER_BY_APPROVEDDATE
static java.lang.String | ORDER_BY_DUEDATE
static java.lang.String | ORDER_BY_ORIGINATEDDATE
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_RFCNUMBER
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_WISEQUENCE
static java.lang.String | ORDER_BY_WORKCENTERID
Constructor Summary
WorkInstructionRequestForChangeVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.lang.String | getApprovedBy()
java.util.Date | getApprovedDate()
java.lang.String | getDepartmentId()
java.lang.String | getDescriptionOfChange()
java.util.Date | getDueDate()
java.util.Date | getEffectiveDate()
java.util.Date | getLastChangeDate()
int | getLastChangeTimes()
java.lang.String | getLastChangeUser()
java.lang.String | getOrigin()
java.util.Date | getOriginatedDate()
java.lang.String | getOriginator()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getRfcNumber()
java.lang.String | getSetId()
java.lang.String | getStatus()
java.lang.String | getWasWiRevised()
java.lang.String | getWiDescription()
java.util.Date | getWiRevisedDate()
java.lang.String | getWiSequence()
java.lang.String | getWorkCenterId()
int | hashCode()
void | setAdate(java.util.Date adate)
void | setApprovedBy(java.lang.String approvedBy)
void | setApprovedDate(java.util.Date approvedDate)
void | setDepartmentId(java.lang.String departmentId)
void | setDescriptionOfChange(java.lang.String descriptionOfChange)
void | setDueDate(java.util.Date dueDate)
void | setEffectiveDate(java.util.Date effectiveDate)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTimes(int lastChangeTimes)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setOrigin(java.lang.String origin)
void | setOriginatedDate(java.util.Date originatedDate)
void | setOriginator(java.lang.String originator)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setRfcNumber(java.lang.String rfcNumber)
void | setSetId(java.lang.String setId)
void | setStatus(java.lang.String status)
void | setWasWiRevised(java.lang.String wasWiRevised)
void | setWiDescription(java.lang.String wiDescription)
void | setWiRevisedDate(java.util.Date wiRevisedDate)
void | setWiSequence(java.lang.String wiSequence)
void | setWorkCenterId(java.lang.String workCenterId)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_RFCNUMBER

public static final java.lang.String ORDER_BY_RFCNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_WORKCENTERID

public static final java.lang.String ORDER_BY_WORKCENTERID
See Also:
Constant Field Values

ORDER_BY_WISEQUENCE

public static final java.lang.String ORDER_BY_WISEQUENCE
See Also:
Constant Field Values

ORDER_BY_ORIGINATEDDATE

public static final java.lang.String ORDER_BY_ORIGINATEDDATE
See Also:
Constant Field Values

ORDER_BY_DUEDATE

public static final java.lang.String ORDER_BY_DUEDATE
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_APPROVEDDATE

public static final java.lang.String ORDER_BY_APPROVEDDATE
See Also:
Constant Field Values

ORDER_BY_APPROVEDBY

public static final java.lang.String ORDER_BY_APPROVEDBY
See Also:
Constant Field Values
Constructor Detail

WorkInstructionRequestForChangeVO

public WorkInstructionRequestForChangeVO()
default constructor

Method Detail

getRfcNumber

public java.lang.String getRfcNumber()

setRfcNumber

public void setRfcNumber(java.lang.String rfcNumber)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

setWorkCenterId

public void setWorkCenterId(java.lang.String workCenterId)

getWorkCenterId

public java.lang.String getWorkCenterId()

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getWiSequence

public java.lang.String getWiSequence()

setWiSequence

public void setWiSequence(java.lang.String wiSequence)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getDepartmentId

public java.lang.String getDepartmentId()

setDepartmentId

public void setDepartmentId(java.lang.String departmentId)

getOriginatedDate

public java.util.Date getOriginatedDate()

setOriginatedDate

public void setOriginatedDate(java.util.Date originatedDate)

getOriginator

public java.lang.String getOriginator()

setOriginator

public void setOriginator(java.lang.String originator)

getWiDescription

public java.lang.String getWiDescription()

setWiDescription

public void setWiDescription(java.lang.String wiDescription)

getDescriptionOfChange

public java.lang.String getDescriptionOfChange()

setDescriptionOfChange

public void setDescriptionOfChange(java.lang.String descriptionOfChange)

getDueDate

public java.util.Date getDueDate()

setDueDate

public void setDueDate(java.util.Date dueDate)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getApprovedDate

public java.util.Date getApprovedDate()

setApprovedDate

public void setApprovedDate(java.util.Date approvedDate)

getApprovedBy

public java.lang.String getApprovedBy()

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)

getWasWiRevised

public java.lang.String getWasWiRevised()

setWasWiRevised

public void setWasWiRevised(java.lang.String wasWiRevised)

getWiRevisedDate

public java.util.Date getWiRevisedDate()

setWiRevisedDate

public void setWiRevisedDate(java.util.Date wiRevisedDate)

getEffectiveDate

public java.util.Date getEffectiveDate()

setEffectiveDate

public void setEffectiveDate(java.util.Date effectiveDate)

getLastChangeTimes

public int getLastChangeTimes()

getSetId

public java.lang.String getSetId()

setLastChangeTimes

public void setLastChangeTimes(int lastChangeTimes)

setSetId

public void setSetId(java.lang.String setId)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkInstructionSeqAuditListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkInstructionSeqAuditListResult

java.lang.Object
    extended by  bb.common.WorkInstructionSeqAuditListResult
All Implemented Interfaces:
java.io.Serializable
public class WorkInstructionSeqAuditListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_NEWAVGHRS
static java.lang.String | ORDER_BY_WISEQPK
static java.lang.String | ORDER_BY_WORKCENTER
Constructor Summary
WorkInstructionSeqAuditListResult()
Method Summary
java.math.BigDecimal | getNewAvgHrs()
java.math.BigDecimal | getOldAvgHrs()
java.lang.String | getPartDesc()
java.lang.String | getWcDesc()
WorkInstructionSequencePK | getWiSeqPk()
java.lang.String | getWorkCenter()
boolean | isAudit()
void | setNewAvgHrs(java.math.BigDecimal newAvgHrs)
void | setOldAvgHrs(java.math.BigDecimal oldAvgHrs)
void | setPartDesc(java.lang.String partDesc)
void | setWcDesc(java.lang.String wcDesc)
void | setWiSeqPk(WorkInstructionSequencePK wiSeqPk)
void | setWorkCenter(java.lang.String workCenter)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_WISEQPK

public static final java.lang.String ORDER_BY_WISEQPK
See Also:
Constant Field Values

ORDER_BY_WORKCENTER

public static final java.lang.String ORDER_BY_WORKCENTER
See Also:
Constant Field Values

ORDER_BY_NEWAVGHRS

public static final java.lang.String ORDER_BY_NEWAVGHRS
See Also:
Constant Field Values
Constructor Detail

WorkInstructionSeqAuditListResult

public WorkInstructionSeqAuditListResult()
Method Detail

setWiSeqPk

public void setWiSeqPk(WorkInstructionSequencePK wiSeqPk)

setPartDesc

public void setPartDesc(java.lang.String partDesc)

setWorkCenter

public void setWorkCenter(java.lang.String workCenter)

setWcDesc

public void setWcDesc(java.lang.String wcDesc)

setOldAvgHrs

public void setOldAvgHrs(java.math.BigDecimal oldAvgHrs)

setNewAvgHrs

public void setNewAvgHrs(java.math.BigDecimal newAvgHrs)

getWiSeqPk

public WorkInstructionSequencePK getWiSeqPk()

getPartDesc

public java.lang.String getPartDesc()

getWorkCenter

public java.lang.String getWorkCenter()

getWcDesc

public java.lang.String getWcDesc()

getOldAvgHrs

public java.math.BigDecimal getOldAvgHrs()

getNewAvgHrs

public java.math.BigDecimal getNewAvgHrs()

isAudit

public boolean isAudit()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkInstructionSequenceListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkInstructionSequenceListResult

java.lang.Object
    extended by  bb.common.WorkInstructionSequenceListResult
All Implemented Interfaces:
java.io.Serializable
public class WorkInstructionSequenceListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AUTHOR
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_SEQUENCESTATUS
static java.lang.String | ORDER_BY_WISEQUENCENUMBER
static java.lang.String | ORDER_BY_WORKCENTER
static java.lang.String | ORDER_BY_WORKINSTRUCTIONREV
Constructor Summary
WorkInstructionSequenceListResult()
Method Summary
java.lang.String | getAuthor()
java.lang.String | getPartDescription()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getSequenceStatus()
java.lang.String | getSetId()
java.lang.String | getWiNumber()
java.lang.String | getWiSequenceNumber()
java.lang.String | getWorkCenter()
java.lang.String | getWorkInstructionRev()
void | setAuthor(java.lang.String author)
void | setPartDescription(java.lang.String partDescription)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setSequenceStatus(java.lang.String sequenceStatus)
void | setSetId(java.lang.String setId)
void | setWiNumber(java.lang.String wiNumber)
void | setWiSequenceNumber(java.lang.String wiSequenceNumber)
void | setWorkCenter(java.lang.String workCenter)
void | setWorkInstructionRev(java.lang.String workInstructionRev)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_WISEQUENCENUMBER

public static final java.lang.String ORDER_BY_WISEQUENCENUMBER
See Also:
Constant Field Values

ORDER_BY_WORKCENTER

public static final java.lang.String ORDER_BY_WORKCENTER
See Also:
Constant Field Values

ORDER_BY_AUTHOR

public static final java.lang.String ORDER_BY_AUTHOR
See Also:
Constant Field Values

ORDER_BY_SEQUENCESTATUS

public static final java.lang.String ORDER_BY_SEQUENCESTATUS
See Also:
Constant Field Values

ORDER_BY_WORKINSTRUCTIONREV

public static final java.lang.String ORDER_BY_WORKINSTRUCTIONREV
See Also:
Constant Field Values
Constructor Detail

WorkInstructionSequenceListResult

public WorkInstructionSequenceListResult()
Method Detail

getSequenceStatus

public java.lang.String getSequenceStatus()

getAuthor

public java.lang.String getAuthor()

getPartDescription

public java.lang.String getPartDescription()

getWiSequenceNumber

public java.lang.String getWiSequenceNumber()

getWorkCenter

public java.lang.String getWorkCenter()

getSetId

public java.lang.String getSetId()

getPartFrom

public java.lang.String getPartFrom()

getPartType

public java.lang.String getPartType()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

setSequenceStatus

public void setSequenceStatus(java.lang.String sequenceStatus)

setAuthor

public void setAuthor(java.lang.String author)

setPartDescription

public void setPartDescription(java.lang.String partDescription)

setWiSequenceNumber

public void setWiSequenceNumber(java.lang.String wiSequenceNumber)

setWorkCenter

public void setWorkCenter(java.lang.String workCenter)

setSetId

public void setSetId(java.lang.String setId)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setPartType

public void setPartType(java.lang.String partType)

setWorkInstructionRev

public void setWorkInstructionRev(java.lang.String workInstructionRev)

setWiNumber

public void setWiNumber(java.lang.String wiNumber)

getPartNumber

public java.lang.String getPartNumber()

getWorkInstructionRev

public java.lang.String getWorkInstructionRev()

getWiNumber

public java.lang.String getWiNumber()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkInstructionSequencePK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkInstructionSequencePK

java.lang.Object
    extended by  bb.common.WorkInstructionSequencePK
All Implemented Interfaces:
java.io.Serializable
public class WorkInstructionSequencePK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
WorkInstructionSequencePK()
default constructor
WorkInstructionSequencePK(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String setId, java.lang.String sequenceNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getSequenceNumber()
java.lang.String | getSetId()
int | hashCode()
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setSequenceNumber(java.lang.String sequenceNumber)
void | setSetId(java.lang.String setId)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WorkInstructionSequencePK

public WorkInstructionSequencePK(java.lang.String partNumber,
                                 java.lang.String partType,
                                 java.lang.String partFrom,
                                 java.lang.String setId,
                                 java.lang.String sequenceNumber)
full constructor

WorkInstructionSequencePK

public WorkInstructionSequencePK()
default constructor

Method Detail

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getSetId

public java.lang.String getSetId()

setSetId

public void setSetId(java.lang.String setId)

getSequenceNumber

public java.lang.String getSequenceNumber()

setSequenceNumber

public void setSequenceNumber(java.lang.String sequenceNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkInstructionSequenceVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkInstructionSequenceVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.WorkInstructionSequenceVO
All Implemented Interfaces:
java.io.Serializable
public class WorkInstructionSequenceVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
WorkInstructionSequenceVO()
default constructor
WorkInstructionSequenceVO(WorkInstructionSequencePK pk, java.lang.String sequenceRev, java.lang.String specialProcess, java.lang.String toolNumber, java.lang.String workCenter, java.lang.String description, java.math.BigDecimal estSetup, java.math.BigDecimal avgSetup, java.math.BigDecimal stdSetup, java.math.BigDecimal estHours, java.math.BigDecimal avgHours, java.math.BigDecimal stdHours, java.lang.String ref, java.lang.String status, java.util.Set workInstructionPictures)
minimal constructor
WorkInstructionSequenceVO(WorkInstructionSequencePK pk, java.lang.String sequenceRev, java.lang.String specialProcess, java.lang.String toolNumber, java.lang.String workCenter, java.lang.String description, java.lang.String language2, java.lang.String description2, java.lang.String language3, java.lang.String description3, java.math.BigDecimal estSetup, java.math.BigDecimal avgSetup, java.math.BigDecimal stdSetup, java.math.BigDecimal estHours, java.math.BigDecimal avgHours, java.math.BigDecimal stdHours, java.lang.String ref, java.lang.String status, java.util.Set workInstructionPictures)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getAvgHours()
int | getAvgHoursH()
int | getAvgHoursM()
int | getAvgHoursS()
java.math.BigDecimal | getAvgSetup()
int | getAvgSetupH()
int | getAvgSetupM()
int | getAvgSetupS()
java.lang.String | getDescription()
java.lang.String | getDescription2()
java.lang.String | getDescription3()
java.math.BigDecimal | getEstHours()
int | getEstHoursH()
int | getEstHoursM()
int | getEstHoursS()
java.math.BigDecimal | getEstSetup()
int | getEstSetupH()
int | getEstSetupM()
int | getEstSetupS()
java.lang.String | getLanguage2()
java.lang.String | getLanguage3()
java.lang.String | getOutSourcing()
WorkInstructionSequencePK | getPk()
java.lang.String | getRef()
java.lang.String | getSequenceRev()
java.lang.String | getSpecialProcess()
java.lang.String | getStatus()
java.math.BigDecimal | getStdHours()
int | getStdHoursH()
int | getStdHoursM()
int | getStdHoursS()
java.math.BigDecimal | getStdSetup()
int | getStdSetupH()
int | getStdSetupM()
int | getStdSetupS()
java.lang.String | getToolNumber()
java.lang.String | getWorkCenter()
java.util.Set | getWorkInstructionPictures()
int | hashCode()
void | setAvgHours(java.math.BigDecimal avgHours)
void | setAvgHoursH(int avgHoursH)
void | setAvgHoursM(int avgHoursM)
void | setAvgHoursS(int avgHoursS)
void | setAvgSetup(java.math.BigDecimal avgSetup)
void | setAvgSetupH(int avgSetupH)
void | setAvgSetupM(int avgSetupM)
void | setAvgSetupS(int avgSetupS)
void | setDescription(java.lang.String description)
void | setDescription2(java.lang.String description2)
void | setDescription3(java.lang.String description3)
void | setEstHours(java.math.BigDecimal estHours)
void | setEstHoursH(int estHoursH)
void | setEstHoursM(int estHoursM)
void | setEstHoursS(int estHoursS)
void | setEstSetup(java.math.BigDecimal estSetup)
void | setEstSetupH(int estSetupH)
void | setEstSetupM(int estSetupM)
void | setEstSetupS(int estSetupS)
void | setLanguage2(java.lang.String language2)
void | setLanguage3(java.lang.String language3)
void | setOutSourcing(java.lang.String outSourcing)
void | setPk(WorkInstructionSequencePK pk)
void | setRef(java.lang.String ref)
void | setSequenceRev(java.lang.String sequenceRev)
void | setSpecialProcess(java.lang.String specialProcess)
void | setStatus(java.lang.String status)
void | setStdHours(java.math.BigDecimal stdHours)
void | setStdHoursH(int stdHoursH)
void | setStdHoursM(int stdHoursM)
void | setStdHoursS(int stdHoursS)
void | setStdSetup(java.math.BigDecimal stdSetup)
void | setStdSetupH(int stdSetupH)
void | setStdSetupM(int stdSetupM)
void | setStdSetupS(int stdSetupS)
void | setToolNumber(java.lang.String toolNumber)
void | setWorkCenter(java.lang.String workCenter)
void | setWorkInstructionPictures(java.util.Set workInstructionPictures)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WorkInstructionSequenceVO

public WorkInstructionSequenceVO(WorkInstructionSequencePK pk,
                                 java.lang.String sequenceRev,
                                 java.lang.String specialProcess,
                                 java.lang.String toolNumber,
                                 java.lang.String workCenter,
                                 java.lang.String description,
                                 java.lang.String language2,
                                 java.lang.String description2,
                                 java.lang.String language3,
                                 java.lang.String description3,
                                 java.math.BigDecimal estSetup,
                                 java.math.BigDecimal avgSetup,
                                 java.math.BigDecimal stdSetup,
                                 java.math.BigDecimal estHours,
                                 java.math.BigDecimal avgHours,
                                 java.math.BigDecimal stdHours,
                                 java.lang.String ref,
                                 java.lang.String status,
                                 java.util.Set workInstructionPictures)
full constructor

WorkInstructionSequenceVO

public WorkInstructionSequenceVO()
default constructor

WorkInstructionSequenceVO

public WorkInstructionSequenceVO(WorkInstructionSequencePK pk,
                                 java.lang.String sequenceRev,
                                 java.lang.String specialProcess,
                                 java.lang.String toolNumber,
                                 java.lang.String workCenter,
                                 java.lang.String description,
                                 java.math.BigDecimal estSetup,
                                 java.math.BigDecimal avgSetup,
                                 java.math.BigDecimal stdSetup,
                                 java.math.BigDecimal estHours,
                                 java.math.BigDecimal avgHours,
                                 java.math.BigDecimal stdHours,
                                 java.lang.String ref,
                                 java.lang.String status,
                                 java.util.Set workInstructionPictures)
minimal constructor

Method Detail

getPk

public WorkInstructionSequencePK getPk()

setPk

public void setPk(WorkInstructionSequencePK pk)

getSequenceRev

public java.lang.String getSequenceRev()

setSequenceRev

public void setSequenceRev(java.lang.String sequenceRev)

getSpecialProcess

public java.lang.String getSpecialProcess()

setSpecialProcess

public void setSpecialProcess(java.lang.String specialProcess)

getToolNumber

public java.lang.String getToolNumber()

setToolNumber

public void setToolNumber(java.lang.String toolNumber)

getWorkCenter

public java.lang.String getWorkCenter()

setWorkCenter

public void setWorkCenter(java.lang.String workCenter)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getLanguage2

public java.lang.String getLanguage2()

setLanguage2

public void setLanguage2(java.lang.String language2)

getDescription2

public java.lang.String getDescription2()

setDescription2

public void setDescription2(java.lang.String description2)

getLanguage3

public java.lang.String getLanguage3()

setLanguage3

public void setLanguage3(java.lang.String language3)

getDescription3

public java.lang.String getDescription3()

setDescription3

public void setDescription3(java.lang.String description3)

getEstSetup

public java.math.BigDecimal getEstSetup()

setEstSetup

public void setEstSetup(java.math.BigDecimal estSetup)

getAvgSetup

public java.math.BigDecimal getAvgSetup()

setAvgSetup

public void setAvgSetup(java.math.BigDecimal avgSetup)

getStdSetup

public java.math.BigDecimal getStdSetup()

setStdSetup

public void setStdSetup(java.math.BigDecimal stdSetup)

getEstHours

public java.math.BigDecimal getEstHours()

setEstHours

public void setEstHours(java.math.BigDecimal estHours)

getAvgHours

public java.math.BigDecimal getAvgHours()

setAvgHours

public void setAvgHours(java.math.BigDecimal avgHours)

getStdHours

public java.math.BigDecimal getStdHours()

setStdHours

public void setStdHours(java.math.BigDecimal stdHours)

getRef

public java.lang.String getRef()

setRef

public void setRef(java.lang.String ref)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getWorkInstructionPictures

public java.util.Set getWorkInstructionPictures()

setWorkInstructionPictures

public void setWorkInstructionPictures(java.util.Set workInstructionPictures)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getOutSourcing

public java.lang.String getOutSourcing()

setOutSourcing

public void setOutSourcing(java.lang.String outSourcing)

getAvgHoursH

public int getAvgHoursH()

setAvgHoursH

public void setAvgHoursH(int avgHoursH)

getAvgHoursM

public int getAvgHoursM()

setAvgHoursM

public void setAvgHoursM(int avgHoursM)

getAvgSetupH

public int getAvgSetupH()

setAvgSetupH

public void setAvgSetupH(int avgSetupH)

getAvgSetupM

public int getAvgSetupM()

setAvgSetupM

public void setAvgSetupM(int avgSetupM)

getEstHoursH

public int getEstHoursH()

setEstHoursH

public void setEstHoursH(int estHoursH)

getEstHoursM

public int getEstHoursM()

setEstHoursM

public void setEstHoursM(int estHoursM)

getEstSetupH

public int getEstSetupH()

setEstSetupH

public void setEstSetupH(int estSetupH)

getEstSetupM

public int getEstSetupM()

setEstSetupM

public void setEstSetupM(int estSetupM)

getStdHoursH

public int getStdHoursH()

setStdHoursH

public void setStdHoursH(int stdHoursH)

getStdHoursM

public int getStdHoursM()

setStdHoursM

public void setStdHoursM(int stdHoursM)

getStdSetupH

public int getStdSetupH()

setStdSetupH

public void setStdSetupH(int stdSetupH)

getStdSetupM

public int getStdSetupM()

setStdSetupM

public void setStdSetupM(int stdSetupM)

getAvgHoursS

public int getAvgHoursS()

setAvgHoursS

public void setAvgHoursS(int avgHoursS)

getEstHoursS

public int getEstHoursS()

setEstHoursS

public void setEstHoursS(int estHoursS)

getStdHoursS

public int getStdHoursS()

setStdHoursS

public void setStdHoursS(int stdHoursS)

getStdSetupS

public int getStdSetupS()

setStdSetupS

public void setStdSetupS(int stdSetupS)

getAvgSetupS

public int getAvgSetupS()

setAvgSetupS

public void setAvgSetupS(int avgSetupS)

getEstSetupS

public int getEstSetupS()

setEstSetupS

public void setEstSetupS(int estSetupS)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkInstructionSummaryItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkInstructionSummaryItemResult

java.lang.Object
    extended by  bb.common.WorkInstructionSummaryItemResult
All Implemented Interfaces:
java.io.Serializable
public class WorkInstructionSummaryItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkInstructionSummaryItemResult()
Method Summary
java.math.BigDecimal | getAvgRunHrs()
java.math.BigDecimal | getAvgSetupHrs()
java.math.BigDecimal | getEstRunHrs()
java.math.BigDecimal | getEstSetupHrs()
java.lang.String | getSeqNumber()
java.lang.String | getSeqRev()
java.lang.String | getShortDescription()
java.lang.String | getStatus()
java.lang.String | getWcDescription()
java.lang.String | getWorkCenter()
void | setAvgRunHrs(java.math.BigDecimal avgRunHrs)
void | setAvgSetupHrs(java.math.BigDecimal avgSetupHrs)
void | setEstRunHrs(java.math.BigDecimal estRunHrs)
void | setEstSetupHrs(java.math.BigDecimal estSetupHrs)
void | setSeqNumber(java.lang.String seqNumber)
void | setSeqRev(java.lang.String seqRev)
void | setShortDescription(java.lang.String shortDescription)
void | setStatus(java.lang.String status)
void | setWcDescription(java.lang.String wcDescription)
void | setWorkCenter(java.lang.String workCenter)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkInstructionSummaryItemResult

public WorkInstructionSummaryItemResult()
Method Detail

setSeqNumber

public void setSeqNumber(java.lang.String seqNumber)

setSeqRev

public void setSeqRev(java.lang.String seqRev)

setWorkCenter

public void setWorkCenter(java.lang.String workCenter)

setWcDescription

public void setWcDescription(java.lang.String wcDescription)

setShortDescription

public void setShortDescription(java.lang.String shortDescription)

setEstSetupHrs

public void setEstSetupHrs(java.math.BigDecimal estSetupHrs)

setAvgSetupHrs

public void setAvgSetupHrs(java.math.BigDecimal avgSetupHrs)

setEstRunHrs

public void setEstRunHrs(java.math.BigDecimal estRunHrs)

setAvgRunHrs

public void setAvgRunHrs(java.math.BigDecimal avgRunHrs)

setStatus

public void setStatus(java.lang.String status)

getSeqNumber

public java.lang.String getSeqNumber()

getSeqRev

public java.lang.String getSeqRev()

getWorkCenter

public java.lang.String getWorkCenter()

getWcDescription

public java.lang.String getWcDescription()

getShortDescription

public java.lang.String getShortDescription()

getEstSetupHrs

public java.math.BigDecimal getEstSetupHrs()

getAvgSetupHrs

public java.math.BigDecimal getAvgSetupHrs()

getEstRunHrs

public java.math.BigDecimal getEstRunHrs()

getAvgRunHrs

public java.math.BigDecimal getAvgRunHrs()

getStatus

public java.lang.String getStatus()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkInstructionSummaryResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkInstructionSummaryResult

java.lang.Object
    extended by  bb.common.WorkInstructionSummaryResult
All Implemented Interfaces:
java.io.Serializable
public class WorkInstructionSummaryResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkInstructionSummaryResult()
Method Summary
java.lang.String | getDescription()
java.util.List | getItems()
BB2Part | getPart()
java.lang.String | getRev()
java.lang.String | getSetId()
void | setDescription(java.lang.String description)
void | setItems(java.util.List items)
void | setPart(BB2Part part)
void | setRev(java.lang.String rev)
void | setSetId(java.lang.String setId)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkInstructionSummaryResult

public WorkInstructionSummaryResult()
Method Detail

getSetId

public java.lang.String getSetId()

getPart

public BB2Part getPart()

getRev

public java.lang.String getRev()

getDescription

public java.lang.String getDescription()

getItems

public java.util.List getItems()

setSetId

public void setSetId(java.lang.String setId)

setPart

public void setPart(BB2Part part)

setRev

public void setRev(java.lang.String rev)

setDescription

public void setDescription(java.lang.String description)

setItems

public void setItems(java.util.List items)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkInstructionVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkInstructionVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.WorkInstructionVO
All Implemented Interfaces:
java.io.Serializable
public class WorkInstructionVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
WorkInstructionVO()
defaultWi constructor
WorkInstructionVO(WorkInstructionPK pk, java.lang.String lastChangeUser, java.lang.String workInstructionRev, java.lang.String defaultWi, java.lang.String author, java.lang.String approvedBy, java.util.Date effectiveDate, java.lang.String status, java.util.Set sequences)
minimal constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.util.Date | getApproved()
java.lang.String | getApprovedBy()
java.lang.String | getAuthor()
java.lang.String | getComment()
java.lang.String | getDefaultWi()
java.lang.String | getDescription()
java.util.Date | getEffectiveDate()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
WorkInstructionPK | getPk()
java.lang.String | getProofreader()
java.util.Set | getSequences()
java.lang.String | getStatus()
java.lang.Integer | getVersion()
java.lang.String | getWorkInstructionRev()
int | hashCode()
void | setAdate(java.util.Date adate)
void | setApproved(java.util.Date approved)
void | setApprovedBy(java.lang.String approvedBy)
void | setAuthor(java.lang.String author)
void | setComment(java.lang.String comment)
void | setDefaultWi(java.lang.String defaultWi)
void | setDescription(java.lang.String description)
void | setEffectiveDate(java.util.Date effectiveDate)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setPk(WorkInstructionPK pk)
void | setProofreader(java.lang.String proofreader)
void | setSequences(java.util.Set sequences)
void | setStatus(java.lang.String status)
void | setVersion(java.lang.Integer version)
void | setWorkInstructionRev(java.lang.String workInstructionRev)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WorkInstructionVO

public WorkInstructionVO()
defaultWi constructor

WorkInstructionVO

public WorkInstructionVO(WorkInstructionPK pk,
                         java.lang.String lastChangeUser,
                         java.lang.String workInstructionRev,
                         java.lang.String defaultWi,
                         java.lang.String author,
                         java.lang.String approvedBy,
                         java.util.Date effectiveDate,
                         java.lang.String status,
                         java.util.Set sequences)
minimal constructor

Method Detail

getPk

public WorkInstructionPK getPk()

setPk

public void setPk(WorkInstructionPK pk)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getWorkInstructionRev

public java.lang.String getWorkInstructionRev()

setWorkInstructionRev

public void setWorkInstructionRev(java.lang.String workInstructionRev)

getDefaultWi

public java.lang.String getDefaultWi()

setDefaultWi

public void setDefaultWi(java.lang.String defaultWi)

getAuthor

public java.lang.String getAuthor()

setAuthor

public void setAuthor(java.lang.String author)

getApprovedBy

public java.lang.String getApprovedBy()

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)

getApproved

public java.util.Date getApproved()

setApproved

public void setApproved(java.util.Date approved)

getEffectiveDate

public java.util.Date getEffectiveDate()

setEffectiveDate

public void setEffectiveDate(java.util.Date effectiveDate)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getSequences

public java.util.Set getSequences()

getVersion

public java.lang.Integer getVersion()

setSequences

public void setSequences(java.util.Set sequences)

setVersion

public void setVersion(java.lang.Integer version)

getProofreader

public java.lang.String getProofreader()

setProofreader

public void setProofreader(java.lang.String proofreader)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getComment

public java.lang.String getComment()

setComment

public void setComment(java.lang.String comment)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderApprovalVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderApprovalVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.WorkOrderApprovalVO
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderApprovalVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_APPROVELIMIT
static java.lang.String | ORDER_BY_CANAPPROVEOWNPURCHASEORDER
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_EMPLOYEEID
static java.lang.String | ORDER_BY_USERNAME
Constructor Summary
WorkOrderApprovalVO()
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getApprovalLimit()
java.lang.String | getCanApproveOwnWorkOrder()
java.lang.String | getCurrency()
java.lang.String | getEmployeeId()
java.lang.String | getUserName()
int | hashCode()
void | setApprovalLimit(java.math.BigDecimal approvalLimit)
void | setCanApproveOwnWorkOrder(java.lang.String canApproveOwnWorkOrder)
void | setCurrency(java.lang.String currency)
void | setEmployeeId(java.lang.String employeeId)
void | setUserName(java.lang.String userName)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_EMPLOYEEID

public static final java.lang.String ORDER_BY_EMPLOYEEID
See Also:
Constant Field Values

ORDER_BY_USERNAME

public static final java.lang.String ORDER_BY_USERNAME
See Also:
Constant Field Values

ORDER_BY_APPROVELIMIT

public static final java.lang.String ORDER_BY_APPROVELIMIT
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values

ORDER_BY_CANAPPROVEOWNPURCHASEORDER

public static final java.lang.String ORDER_BY_CANAPPROVEOWNPURCHASEORDER
See Also:
Constant Field Values
Constructor Detail

WorkOrderApprovalVO

public WorkOrderApprovalVO()
Method Detail

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getApprovalLimit

public java.math.BigDecimal getApprovalLimit()

setApprovalLimit

public void setApprovalLimit(java.math.BigDecimal approvalLimit)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getCanApproveOwnWorkOrder

public java.lang.String getCanApproveOwnWorkOrder()

setCanApproveOwnWorkOrder

public void setCanApproveOwnWorkOrder(java.lang.String canApproveOwnWorkOrder)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderBoilerplateVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderBoilerplateVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.WorkOrderBoilerplateVO
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderBoilerplateVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_BOILERPLATEID
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_WOBOILERPLATE
Constructor Summary
WorkOrderBoilerplateVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getBoilerplateId()
java.lang.String | getDescription()
java.lang.String | getWoBoilerplate()
int | hashCode()
void | setBoilerplateId(java.lang.String boilerplateId)
void | setDescription(java.lang.String description)
void | setWoBoilerplate(java.lang.String woBoilerplate)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_BOILERPLATEID

public static final java.lang.String ORDER_BY_BOILERPLATEID
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_WOBOILERPLATE

public static final java.lang.String ORDER_BY_WOBOILERPLATE
See Also:
Constant Field Values
Constructor Detail

WorkOrderBoilerplateVO

public WorkOrderBoilerplateVO()
default constructor

Method Detail

getBoilerplateId

public java.lang.String getBoilerplateId()

setBoilerplateId

public void setBoilerplateId(java.lang.String boilerplateId)

getDescription

public java.lang.String getDescription()

getWoBoilerplate

public java.lang.String getWoBoilerplate()

setDescription

public void setDescription(java.lang.String description)

setWoBoilerplate

public void setWoBoilerplate(java.lang.String woBoilerplate)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderBox

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

bb.common.box
Interface WorkOrderBox

public interface WorkOrderBox

Method Summary
java.lang.String | addDisassembleWorkOrder(java.lang.String addressId)
DisassembleWorkOrderApprovalVO | addDisassembleWorkOrderApproval(java.lang.String employeeId)
DisassembleWorkOrderItemPartDetailItemResult | addDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemPK itemPk, BB2Part partPk, java.math.BigDecimal qty, java.math.BigDecimal cost)
DisassembleWorkOrderItemPartDetailItemResult | addDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemPK itemPk, java.math.BigDecimal qty, java.math.BigDecimal qtyReceived, java.math.BigDecimal cost, java.lang.String description)
void | addDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemPK itemPk, java.util.LinkedHashMap<BB2Part,java.math.BigDecimal> map)
java.lang.Long | addEmployeeLabor(EmployeeLaborAgent agent)
PartUseTypeVO | addPartUseType(PartUseTypeVO vo)
RefdocVO | addRefdocOne(WorkOrderItemPK woItemPk, java.lang.String forderNumber, java.lang.String fItemNumber, java.math.BigDecimal refdocQty)
RefdocVO | addRefdocTwo(WorkOrderItemPK woItemPk, java.lang.String orderNumber, java.lang.String itemNumber, java.math.BigDecimal refdocQty)
java.lang.String | addWorkOrder(java.lang.String addressId)
WorkOrderApprovalVO | addWorkOrderApproval(java.lang.String employeeId)
WorkOrderBoilerplateVO | addWorkOrderBP(WorkOrderBoilerplateVO vo)
java.util.Collection<WorkOrderItemListResult> | addWorkOrderFromMasterWorkOrder(java.util.Date dueDate, WorkOrderItemPK masterWOPk, java.util.HashMap<java.lang.String,java.util.HashSet<WorkOrderItemAgent>> map)
WorkOrderItemPartDetailItemResult | addWorkOrderItemIssue(WorkOrderItemPK itemPk, BB2Part part, java.math.BigDecimal qty)
WorkOrderItemPartDetailItemResult | addWorkOrderItemIssue(WorkOrderItemPK itemPk, java.math.BigDecimal qty, java.math.BigDecimal qtyIssued, java.math.BigDecimal cost, java.lang.String description)
void | addWorkOrderItemIssue(WorkOrderItemPK itemPk, java.util.LinkedHashMap<BB2Part,java.math.BigDecimal> map, java.util.LinkedHashMap<BB2Part,java.lang.String> commentsMap)
WorkOrderItemTimeDetailVO | addWorkOrderItemTimeDetail(WorkOrderItemTimeDetailVO vo)
WorkOrderWorkInstructionVO | addWorkOrderWorkInstruction(WorkOrderItemPK woItemPk, WorkInstructionPK wiPk)
WorkOrderWorkInstructionVO | addWorkOrderWorkInstruction(WorkOrderWorkInstructionVO vo)
WorkOrderWorkInstructionSequenceVO | addWorkOrderWorkInstructionSequence(WorkOrderWorkInstructionSequenceVO vo)
WorkOrderWorkSheetVO | addWorkOrderWorkSheet()
WorkOrderWorkSheetVO | addWorkOrderWorkSheet(java.util.ArrayList list)
WorkOrderWorkSheetVO | addWorkOrderWorkSheet(WorkOrderWorkSheetVO pwsVO)
WorkOrderWorkSheetItemVO | addWorkOrderWorkSheetItem(WorkOrderWorkSheetItemVO pwsItemVO)
DisassembleWorkOrderVO | approveDisassembleWorkOrder(DisassembleWorkOrderVO vo)
void | approveOrderChangeByID(java.lang.Long orderChangeId, java.lang.String reson)
WorkOrderVO | approveWorkOrder(WorkOrderVO vo)
GeneralLedgerVO | batchDisassembelWorkOrderGLByDwoItem(DisassembleWorkOrderItemPK[] pks, java.lang.String companyUnitId, java.lang.String glSummary)
java.lang.String | cancelDisassembleWorkOrder(java.lang.String disassembleWorkOrderNumber)
void | cancelOrderChangeByID(java.lang.Long orderChangeId, java.lang.String reson)
java.lang.String | cancelWorkOrder(java.lang.String woNumber)
void | clearWorkOrderItemIssueReferenceDocOne(java.lang.String referenceDoc)
void | clearWorkOrderItemReferenceDocOne(java.lang.String referenceDoc)
void | clearWorkOrderItemReferenceDocTwo(java.lang.String referenceDoc)
java.lang.String | copyWorkOrderFromWorkOrder(WO2WOAgent agent)
void | deleteAllWorkOrderWorkInstructionSequences(WorkOrderWorkInstructionPK pk)
void | deleteDisassembleWorkOrderApproval(DisassembleWorkOrderApprovalVO woApprovalVO)
void | deleteDisassembleWorkOrderApproval(java.lang.String employeeId)
void | deleteDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemReceiverPK issuePk)
void | deleteDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemReceiverVO vo)
void | deleteDisassembleWorkOrderItemReceivers(java.util.ArrayList<DisassembleWorkOrderItemReceiverPK> items)
void | deleteFTPDWODoc(MiscDocAgent agent)
void | deleteFTPWODoc(MiscDocAgent agent)
void | deleteOrderChangeByID(java.lang.Long orderChangeId)
void | deletePartUseType(PartUseTypeVO vo)
void | deleteRefdocOne(BB2RefdocPK pk)
void | deleteRefdocTwo(BB2RefdocPK pk)
void | deleteWorkOrder(WorkOrderVO vo)
void | deleteWorkOrderApproval(java.lang.String employeeId)
void | deleteWorkOrderApproval(WorkOrderApprovalVO woApprovalVO)
void | deleteWorkOrderBP(java.lang.String bpID)
void | deleteWorkOrderItemIssue(IssuingItemResult item)
void | deleteWorkOrderItemIssue(WorkOrderItemIssuePK issuePk)
void | deleteWorkOrderItemIssue(WorkOrderItemIssueVO vo)
void | deleteWorkOrderItemIssues(java.util.ArrayList<WorkOrderItemIssuePK> items)
void | deleteWorkOrderItemTimeDetail(java.lang.Long pk)
void | deleteWorkOrderWorkInstruction(WorkOrderWorkInstructionPK pk)
void | deleteWorkOrderWorkInstruction(WorkOrderWorkInstructionVO vo)
void | deleteWorkOrderWorkInstructionSequence(WorkOrderWorkInstructionSequenceVO vo)
void | deleteWorkOrderWorkSheet(WorkOrderWorkSheetVO pwsVO)
void | deleteWorkOrderWorkSheetItem(WorkOrderWorkSheetItemVO pwsItemVO)
byte[] | downloadFTPDWODoc(MiscDocAgent agent)
byte[] | downloadFTPWODoc(MiscDocAgent agent)
java.util.Collection<DisassembleWorkOrderApprovalVO> | findAllDisassembleWorkOrderApprovals(int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemInfoResult> | findAllMasterWorkOrder(java.lang.String workOrderNumber, java.lang.String relatedDoc, java.lang.String partNumber, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<WorkOrderWorkSheetVO> | findAllMyWorkOrderWorkSheet(int firstIndex, int maxLength)
java.util.Collection<PartUseTypeVO> | findAllPartUseType()
java.util.Collection<WorkOrderItemListResult> | findAllTopMasterWorkOrder(java.util.Date fromDate, java.util.Date toDate, java.lang.String projectName, java.lang.String workOrderNumber, java.lang.String partNumber, java.lang.String partType, boolean isShowCost, boolean isShowMainWO, java.lang.String status, java.lang.String dateType)
java.util.Collection<WorkOrderApprovalVO> | findAllWorkOrderApprovals(int firstIndex, int maxLength)
java.util.Collection<WorkOrderBoilerplateVO> | findAllWorkOrderBP(int firstIndex, int maxLength)
java.util.Collection<WorkOrderCheckListResult> | findAllWorkOrderCheckListResults(int firstIndex, int maxLength)
java.util.Collection<WorkOrderWorkSheetVO> | findAllWorkOrderWorkSheet(int firstIndex, int maxLength)
java.util.Collection<DisassembleWorkOrderItemListResult> | findCancelledDisassembleWorkOrderListResults(int firstIndex, int maxLength)
java.util.Collection<DisassembleWorkOrderDocumentVO> | findDisassembleWorkOrderDocumentInfo(java.lang.String disassembleWorkOrderNumber)
java.util.List<DisassembleWorkOrderListResult> | findDisassembleWorkOrderListResultById(java.lang.String dwoNumber, java.lang.String[] status, java.lang.String vendorId, int firstIndex, int maxLength)
java.util.Collection<DisassembleWorkOrderItemListResult> | findDisassembleWorkOrderListResultsByDate(java.lang.String dateType, java.util.Date dateFrom, java.util.Date dateTo, java.lang.String partNumber, java.lang.String partType, java.lang.String vendorId, java.lang.String project, java.lang.String creater, java.lang.String docRef, java.lang.String contact, java.lang.String status, boolean isLock, java.lang.String accounting, java.lang.String companyUnit, int firstIndex, int maxLength)
java.util.Collection<DisassembleWorkOrderItemListResult> | findDisassembleWorkOrderListResultsByDwoNumber(java.lang.String dwoNumber, int firstIndex, int maxLength)
java.util.Collection<DisassembleWorkOrderItemListResult> | findDisassembleWorkOrderListResultsByPN(java.lang.String pn, java.lang.String pa, int firstIndex, int maxLength)
java.util.Collection<PartReceivedVO> | findDisassembleWorkOrderReceivedDetail(DisassembleWorkOrderItemPK pk, BB2Part part, java.lang.String description, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | findDueWorkOrderItemListResults(int firstIndex, int maxLength)
java.util.Collection<DisassembleWorkOrderItemListResult> | findNotCreateGlOfDisassembleWorkOrderItem(java.lang.String dateType, java.util.Date dateFrom, java.util.Date dateTo, java.lang.String partNumber, java.lang.String partType, java.lang.String vendorId, java.lang.String project, java.lang.String creater, java.lang.String docRef, java.lang.String contact, java.lang.String accounting, java.lang.String companyUnit)
java.util.Collection<WorkOrderItemReviewCostResult> | findNotReviewedWorkOrderItemReviewCostResults(java.lang.String woLike, java.lang.String vendorID, java.lang.String pnLike, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | findNotSetupWorkOrderItemListResults(java.lang.String woNumber, boolean onlyApprovedWOItem, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | findNotSetupWorkOrderItemListResults(java.lang.String woNumber, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemIssueVO> | findOpenAndIssuedWorkOrderItemIssues(java.lang.String woNumber, java.lang.String itemNumber, BB2Part part)
java.util.Collection<DisassembleWorkOrderItemListResult> | findOpenDisassembleWorkOrderItemListResultsByPartPK(PartPK partPk, int firstIndex, int maxLength)
java.util.Collection<DisassembleWorkOrderItemListResult> | findOpenDisassembleWorkOrderListResultsByDwoNumber(java.lang.String dwoNumber, int firstIndex, int maxLength)
java.util.Collection<DisassembleWorkOrderItemListResult> | findOpenDisassembleWorkOrderListResultsByVendorId(java.lang.String vendorId, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | findOpenUnHoldWorkOrderItemListResults(java.lang.String woNumberLike, java.lang.String partNumberLike, java.lang.String partType, boolean showAllIssued, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | findOpenWorkOrderByVendorId(java.lang.String addressIdLike, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | findOpenWorkOrderItemListResults(boolean orderByDateRequiredAsc, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | findOpenWorkOrderItemListResults(java.lang.String woNumberLike, java.lang.String partNumberLike, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | findOpenWorkOrderItemListResultsByPartPK(PartPK partPk, int firstIndex, int maxLength)
java.util.Collection<WorkOrderListResult> | findOpenWorkOrderListResults(java.lang.String woNumber, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | findOpenWorkOrderListResultsByWoNumber(java.lang.String woNumber, int firstIndex, int maxLength)
java.util.Collection<OrderApprovalVO> | findOrderApprovalByVO(OrderApprovalVO vo, int firstIndex, int maxLength)
java.util.Collection<WorkOrderOverIssueListResult> | findOverIssueItemList(boolean isDueDateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String vendorId, java.lang.String workOrderNumber, java.lang.String workOrderItemNumber, java.lang.String partNumber, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<WOItemPartDetailNotIssue> | findPartInWorkOrderPartDetail(java.lang.String woNumber, java.lang.String pnLike, java.lang.String paLike, java.lang.String pfLike, java.lang.String ProjectName, boolean isRefDoc, java.lang.String dateType, java.util.Date dateFrom, java.util.Date dateTo, int firstIndex, int maxLength)
java.util.Collection<PartUseTypeVO> | findPartUseType(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String useType, int firstIndex, int maxLength)
PartUseTypeVO | findPartUseTypeByPK(java.lang.String useType)
int | findPartUseTypeCount(java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, java.lang.String useType)
POAndWOStatusResult | findPOAndWOStatus(java.util.Date fromDate, java.util.Date toDate, java.lang.String project)
java.util.Collection<OntimeDeliveryRateListResult> | findVendorOnTimeDeliveryRateByVendorId(java.lang.String vendorId, java.util.Date from, java.util.Date to, int delayDays, int beforeDays, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemPartDetailInWipVO> | findWoiDetailInWipByGlNumber(java.lang.String glNumber, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | findWOItemsCanIssue(java.lang.String partFrom, boolean isDueDateType, java.util.Date fromDate, java.util.Date toDate, boolean showAllIssued, int firstIndex, int maxLength)
java.util.Collection<WorkOrderBoilerplateVO> | findWorkOrderBPByBPId(java.lang.String boilerplateId, int firstIndex, int maxLength)
java.util.Collection<WorkOrderCheckListResult> | findWorkOrderCheckListResults(java.lang.String startWith, int firstIndex, int maxLength)
java.util.Collection<WorkOrderDocumentVO> | findWorkOrderDocumentInfo(java.lang.String workOrderNumber)
java.util.Collection<WorkOrderWorkInstructionListResult> | findWorkOrderInstructionSeq(java.lang.String partNumber, java.lang.String partType, java.lang.String workOrderNumber, java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<PartIssuedVO> | findWorkOrderIssuedDetail(WorkOrderItemPK pk, BB2Part part, java.lang.String description, int firstIndex, int maxLength)
java.util.Collection<WorkOrderIssueStatisticsResult> | findWorkOrderIssueStatisticsResults(java.util.Date from, java.util.Date to, java.lang.String project, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | findWorkOrderItemByVendorId(java.lang.String vendorId, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemInWipListResult> | findWorkOrderItemInWipList(java.lang.String monthYear, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemIssueVO> | findWorkOrderItemIssues(WorkOrderItemPK itemPk)
java.util.List<WorkOrderItemLaborCostListResult> | findWorkOrderItemLaborCost(java.util.Date dateFrom, java.util.Date dateTo, java.lang.String workOrderNumber, java.lang.String vendorID, java.lang.String workCenter, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | findWorkOrderItemListResults(java.lang.String partNumberLike, java.lang.String partType, java.lang.String status, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | findWorkOrderItemListResults(java.lang.String woNumberLike, java.lang.String partNumberLike, java.lang.String partType, java.lang.String status, boolean isDue, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | findWorkOrderItemListResultsByDate(java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String partNumberLike, java.lang.String partType, java.lang.String vendId, java.lang.String[] status, java.lang.String project, java.lang.String originator, java.lang.String relateDoc, java.lang.String contact, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isHold, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | findWorkOrderItemListResultsByDateTotal(java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String partNumberLike, java.lang.String partType, java.lang.String vendId, java.lang.String[] status, java.lang.String project, java.lang.String originator, java.lang.String relateDoc, java.lang.String contact, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isHold)
java.util.Collection<WorkOrderItemListResult> | findWorkOrderItemListResultsByPartNumberLike(java.lang.String partNumberLike, java.lang.String partType, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | findWorkOrderItemListResultsWithPartHold(int firstIndex, int maxLength)
java.util.Collection<WOItemPartDetailNotIssue> | findWorkOrderItemPartDetailNotIssues(java.lang.String woNumber, java.lang.String vendorId, java.util.Date from, java.util.Date to, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemReviewCostResult> | findWorkOrderItemReviewCostResults(java.lang.String woLike, java.lang.String vendorID, java.lang.String pnLike, java.lang.String reviewedBy, java.util.Date fromDate, java.util.Date toDate, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemIssueVO> | findWorkOrderItemWithWipIssues(WorkOrderItemPK itemPk, java.util.Date fromDate, java.util.Date toDate)
java.util.Collection<WorkOrderListResult> | findWorkOrderListResults(java.lang.String woNumber, java.lang.String[] status, java.lang.String vendId, int firstIndex, int maxLength)
java.util.Collection<WorkOrderListResult> | findWorkOrderListResultsByVendorId(java.lang.String vendorId, int firstIndex, int maxLength)
java.util.Collection<WorkOrderItemListResult> | findWorkOrderListResultsByWoNumber(java.lang.String woNumber, int firstIndex, int maxLength)
java.util.Collection<WorkOrderTimeCardVO> | findWorkOrderTimeCards(WorkOrderItemPK itemPk)
java.util.Collection<WorkOrderWorkInstructionSequenceVO> | findWorkOrderWorkInstructionSequences(WorkOrderWorkInstructionPK pk)
java.util.Collection<WorkOrderWorkSheetVO> | findWorkOrderWorkSheetByEmployeeEmailLike(java.lang.String employeeEmailLike, int firstIndex, int maxLength)
java.util.Collection<WorkOrderWorkSheetVO> | findWorkOrderWorkSheetByEmployeeId(java.lang.String employeeId, int firstIndex, int maxLength)
java.util.Collection<WorkOrderWorkSheetItemWithRelatedInfoResult> | findWorkOrderWorkSheetItemsByWorkSheetPk(WorkOrderWorkSheetPK workSheetPk)
void | finishWorkOrderWorkInstructionSequence(WorkOrderWorkInstructionSequencePK pk, boolean finish)
int | getAllDisassembleWorkOrderApprovalsCount()
int | getAllMasterWorkOrderCount(java.lang.String workOrderNumber, java.lang.String relatedDoc, java.lang.String partNumber, java.lang.String partType)
int | getAllMyWorkOrderWorkSheetCount()
int | getAllWorkOrderApprovalsCount()
int | getAllWorkOrderBPCount()
int | getAllWorkOrderCheckListResultsCount()
int | getAllWorkOrderWorkSheetCount()
BOMCanAssyListResult | getBOMCanAssyListResult(PartPK pk)
java.util.Collection<BOMCanAssyListResult> | getBOMCanAssyListResults(java.util.ArrayList<PartPK> pks)
int | getCancelledDisassembleWorkOrderListResultsCount()
DisassembleWorkOrderApprovalVO | getDisassembleWorkOrderApprovalByEmployeeId(java.lang.String employeeId)
DisassembleWorkOrderApprovalVO | getDisassembleWorkOrderApprovalByUserNumber(java.lang.String userName)
DisassembleWorkOrderVO | getDisassembleWorkOrderByDwo(java.lang.String id)
DisassembleWorkOrderDocumentVO | getDisassembleWorkOrderDocumentByID(java.lang.Long controlNumber)
DisassembleWorkOrderItemVO | getDisassembleWorkOrderItemById(DisassembleWorkOrderItemPK itemPk)
DisassembleWorkOrderItemPartDetailItemResult | getDisassembleWorkOrderItemPartDetailItemResult(DisassembleWorkOrderItemReceiverPK pk)
int | getDisassembleWorkOrderListResultByIdCount(java.lang.String dwoNumber, java.lang.String[] status, java.lang.String vendorId)
int | getDisassembleWorkOrderListResultsByDateCount(java.lang.String dateType, java.util.Date dateFrom, java.util.Date dateTo, java.lang.String partNumber, java.lang.String partType, java.lang.String vendorId, java.lang.String project, java.lang.String creater, java.lang.String docRef, java.lang.String contact, java.lang.String status, boolean isLock, java.lang.String accounting, java.lang.String companyUnit)
int | getDisassembleWorkOrderListResultsByPNCount(java.lang.String pn, java.lang.String pa)
int | getDisassembleWorkOrderListResultsCountByDwoNumber(java.lang.String dwoNumber)
int | getDisassembleWorkOrderReceivedDetail(DisassembleWorkOrderItemPK pk, BB2Part part, java.lang.String description)
java.lang.Object[] | getDisassembleWorkOrderReceivedDetailTotal(DisassembleWorkOrderItemPK pk, BB2Part part, java.lang.String description)
DisassembleWorkOrderVO | getDisassembleWorkOrderWithOrderApplyByDwo(java.lang.Long orderApplyID)
int | getDueWorkOrderItemListResultsCount()
java.math.BigDecimal | getDWIPartDetailTotalReceivedCost(DisassembleWorkOrderItemPK dwiPk)
DisassembleWorkOrderItemPartDetailResult | getDwoPartDetailResult(DisassembleWorkOrderItemPK woItemPk)
int | getdWorkOrderIssueStatisticsResultsCount(java.util.Date from, java.util.Date to, java.lang.String project, java.lang.String partNumber, java.lang.String partType, java.lang.String partFrom)
java.util.Collection<DisassembleWorkOrderIssueVO> | getDWOShipperItemListResultsOfDisassembleWorkOrder(java.lang.String disassembleWorkOrderNumber)
java.util.Map<java.util.Date,OntimeDeliveryRateResult> | getLast12MonthOntimeDeliveryRate(java.lang.String vendorId, int overDueDays, int advanceDays)
WorkInstructionVO | getManWorkInstructionByWoItemPk(BB2Part part, java.lang.String setId)
java.util.Collection<MasterWorkOrderTreeItemResult> | getMasterWorkOrderTreeItem(BillPK billPk, WorkOrderItemPK woItemPk, java.math.BigDecimal qty, boolean calculateOrphan, java.lang.String languageCode)
java.lang.Short | getNextWorkOrderItemIssueItemNumber(WorkOrderItemPK orderItemPk)
java.lang.Integer | getNextWorkOrderWorkSheetItemNumber(WorkOrderWorkSheetVO vo)
java.lang.Integer | getNextWorkOrderWorkSheetNumber(java.lang.String employeeId)
int | getNotReviewedWorkOrderItemReviewCostResultsCount(java.lang.String woLike, java.lang.String vendorID, java.lang.String pnLike, java.util.Date fromDate, java.util.Date toDate)
int | getNotSetupWorkOrderItemListResultsCount(java.lang.String woNumber)
int | getNotSetupWorkOrderItemListResultsCount(java.lang.String woNumber, boolean onlyApprovedWOItem)
int | getOpenDisassembleWorkOrderItemListResultsByPartPkCount(PartPK partPk)
int | getOpenDisassembleWorkOrderListResultsByDwoNumberCount(java.lang.String dwoNumber)
int | getOpenDisassembleWorkOrderListResultsByVendorIdCount(java.lang.String vendorId)
int | getOpenUnHoldWorkOrderItemListResultsCount(java.lang.String woNumberLike, java.lang.String partNumberLike, java.lang.String partType, boolean showAllIssued)
int | getOpenWorkOrderCountByVendorId(java.lang.String addressIdLike)
int | getOpenWorkOrderItemListResultsByPartPkCount(PartPK partPk)
int | getOpenWorkOrderItemListResultsCount()
int | getOpenWorkOrderItemListResultsCount(java.lang.String woNumberLike, java.lang.String partNumberLike, java.lang.String partType)
int | getOpenWorkOrderListResultsByWoNumberCount(java.lang.String woNumber)
int | getOpenWorkOrderListResultsCount(java.lang.String woNumber)
OrderApprovalVO | getOrderApprovalByOrder(java.lang.String orderNumber)
int | getOverIssueItemListCount(boolean isDueDateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String vendorId, java.lang.String workOrderNumber, java.lang.String workOrderItemNumber, java.lang.String partNumber, java.lang.String partType)
java.util.Collection<RefdocVO> | getParentOrder(java.lang.String orderNumber, java.lang.String orderItemNumber)
java.util.Collection<PartPK> | getPartCanAssy(BOMCanAssyAgent agent)
WorkOrderItemPartDetailResult | getPartDetailResult(WorkOrderItemPK itemPk)
WorkOrderItemPartDetailResult | getPartDetailResultNoNA(WorkOrderItemPK woItemPk)
int | getPartInWorkOrderPartDetailCount(java.lang.String woNumber, java.lang.String pnLike, java.lang.String paLike, java.lang.String pfLike, java.lang.String ProjectName, boolean isRefDoc, java.lang.String dateType, java.util.Date dateFrom, java.util.Date dateTo)
java.util.Collection<RefdocVO> | getSubOrders(java.lang.String orderNumber, java.lang.String orderItemNumber)
java.util.Collection<WorkOrderItemVO> | getSubWorkOrderByWorkOrderItemPK(WorkOrderItemPK itemPk)
WorkOrderItemTimeDetailResult | getTimeDetailResult(WorkOrderItemPK itemPk)
java.util.Collection<BB2DoubleString> | getTotalWorkOrderInstructionSeq(java.lang.String partNumber, java.lang.String partType, java.lang.String workOrderNumber, java.lang.String status)
java.lang.String | getVendorForWorkOrder(java.lang.String woNumber)
OntimeDeliveryRateResult | getVendorOnTimeDeliveryRate(java.lang.String vendorId, java.util.Date from, java.util.Date to, int delayDays, int beforeDays)
int | getVendorOnTimeDeliveryRateCountByVendorId(java.lang.String vendorId, java.util.Date from, java.util.Date to, int delayDays, int beforeDays)
java.util.Collection<java.lang.String> | getWISetIDs(BB2Part part)
int | getWoiDetailInWipCountByGlNumber(java.lang.String glNumber, java.util.Date fromDate, java.util.Date toDate)
int | getWOItemsCanIssueCount(java.lang.String partFrom, boolean isDueDateType, java.util.Date fromDate, java.util.Date toDate, boolean showAllIssued)
java.util.Collection<WorkOrderReceiverVO> | getWOReceiverItemListResultsOfWorkOrder(java.lang.String woNumber)
WorkOrderApprovalVO | getWorkOrderApprovalByEmployeeId(java.lang.String employeeId)
WorkOrderApprovalVO | getWorkOrderApprovalByUserNumber(java.lang.String userName)
WorkOrderBoilerplateVO | getWorkOrderBPByPk(java.lang.String workOrderBoilerplateId)
int | getWorkOrderBPCountByBPId(java.lang.String boilerplateId)
WorkOrderVO | getWorkOrderByWo(java.lang.String id)
int | getWorkOrderCheckListResultsCount(java.lang.String startWith)
WorkOrderDocumentVO | getWorkOrderDocumentByID(java.lang.Long controlNumber)
int | getWorkOrderInstructionSeqCount(java.lang.String partNumber, java.lang.String partType, java.lang.String workOrderNumber, java.lang.String status)
int | getWorkOrderIssuedDetail(WorkOrderItemPK pk, BB2Part part, java.lang.String description)
PartIssueTotalResult | getWorkOrderIssuedDetailTotal(WorkOrderItemPK pk, BB2Part part, java.lang.String description)
WorkOrderItemVO | getWorkOrderItemById(WorkOrderItemPK itemPk)
WorkOrderItemVO | getWorkOrderItemByIdForWOLabel(WorkOrderItemPK itemPk)
int | getWorkOrderItemByVendorIdCount(java.lang.String vendorId, java.util.Date from, java.util.Date to)
java.util.Collection<WorkOrderItemCanAssyResult> | getWorkOrderItemCanAssyResults(WorkOrderItemCanAssyAgent agent)
int | getWorkOrderItemInWipListCount(java.lang.String monthYear)
WorkOrderItemIssueVO | getWorkOrderItemIssueByPk(WorkOrderItemIssuePK issuePk)
int | getWorkOrderItemIssuesCount(WorkOrderItemPK itemPk)
int | getWorkOrderItemLaborCostCount(java.util.Date dateFrom, java.util.Date dateTo, java.lang.String workOrderNumber, java.lang.String vendorID, java.lang.String workCenter)
int | getWorkOrderItemListResultsCount(java.lang.String partNumberLike, java.lang.String partType, java.lang.String status)
int | getWorkOrderItemListResultsCount(java.lang.String woNumberLike, java.lang.String partNumberLike, java.lang.String partType, java.lang.String status, boolean isDue)
int | getWorkOrderItemListResultsCountByDate(java.lang.String dateType, java.util.Date fromDate, java.util.Date toDate, java.lang.String partNumberLike, java.lang.String partType, java.lang.String vendId, java.lang.String[] status, java.lang.String project, java.lang.String originator, java.lang.String relateDoc, java.lang.String contact, java.lang.String accountNumber, java.lang.String companyUnitId, boolean isHold)
int | getWorkOrderItemListResultsCountByPartNumberLike(java.lang.String partNumberLike, java.lang.String partType)
int | getWorkOrderItemListResultsWithoutLikeCount(java.lang.String partNumberLike, java.lang.String partType, java.lang.String status)
int | getWorkOrderItemListResultsWithPartHoldCount()
java.math.BigDecimal | getWorkOrderItemMaxReceivableQty(WorkOrderItemPK itemPk)
WorkOrderItemPartDetailItemResult | getWorkOrderItemPartDetailItemResult(WorkOrderItemIssuePK pk)
int | getWorkOrderItemPartDetailNotIssuesCount(java.lang.String woNumber, java.lang.String vendorId, java.util.Date from, java.util.Date to)
BB2DoubleCost | getWorkOrderItemPartInWipTotal(java.lang.String monthYear)
int | getWorkOrderItemReviewCostResultsCount(java.lang.String woLike, java.lang.String vendorID, java.lang.String pnLike, java.lang.String reviewedBy, java.util.Date fromDate, java.util.Date toDate)
WorkOrderItemTimeDetailVO | getWorkOrderItemTimeDetailByPk(java.lang.Long pk)
int | getWorkOrderItemTimeDetailsCount(WorkOrderItemPK itemPk)
WorkOrderItemVO | getWorkOrderItemWithWIById(WorkOrderItemPK itemPk, java.util.Date fromDate, java.util.Date toDate)
java.math.BigDecimal | getWorkOrderItemWorkCenterSumCost(WorkOrderItemPK itemPk)
int | getWorkOrderListResultsCount(java.lang.String woNumber, java.lang.String[] status, java.lang.String vendId)
int | getWorkOrderListResultsCountByVendorId(java.lang.String vendorId)
int | getWorkOrderListResultsCountByWoNumber(java.lang.String woNumber)
java.util.HashMap<WorkOrderItemPK,java.math.BigDecimal> | getWorkOrderMaxReceivableQty(java.lang.String workOrderNumber)
java.lang.String | getWorkOrderVendorIDByWo(java.lang.String id)
WorkOrderVO | getWorkOrderWithOrderApplyByWo(java.lang.Long orderApplyID)
WorkOrderWorkInstructionVO | getWorkOrderWorkInstructionByPk(WorkOrderWorkInstructionPK pk)
WorkOrderWorkInstructionVO | getWorkOrderWorkInstructionByWoItemPk(WorkOrderItemPK pk)
WorkOrderWorkInstructionSequenceVO | getWorkOrderWorkInstructionSequenceByPk(WorkOrderWorkInstructionSequencePK pk)
int | getWorkOrderWorkInstructionSequencesCount(WorkOrderWorkInstructionPK pk)
int | getWorkOrderWorkSheetByCountByEmployeeId(java.lang.String employeeId)
WorkOrderWorkSheetVO | getWorkOrderWorkSheetByPk(WorkOrderWorkSheetPK pk)
int | getWorkOrderWorkSheetCountByEmployeeEmailLike(java.lang.String employeeEmailLike)
java.lang.String | getWOWISeqDescription(WorkOrderWorkInstructionSequencePK pk)
DisassembleWorkOrderItemVO | initDisassembleWorkOrderItem(java.lang.String dwoNumber, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty, java.lang.String partFrom, java.lang.String naDesc)
WorkOrderItemVO | initWorkOrderItemForNA(java.lang.String woNumber, java.lang.String itemNum, java.lang.String naDesc, java.math.BigDecimal qty)
WorkOrderItemVO | initWorkOrderItemForPart(java.lang.String woNumber, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
WorkOrderItemVO | initWorkOrderItemForTool(java.lang.String woNumber, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
WorkOrderWorkSheetItemWithRelatedInfoResult | initWorkOrderWorkSheetItemForPart(WorkOrderWorkSheetPK pk, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
WorkOrderWorkSheetItemWithRelatedInfoResult | initWorkOrderWorkSheetItemForTool(WorkOrderWorkSheetPK pk, java.lang.String itemNum, PartPK partPk, java.math.BigDecimal qty)
boolean | isDisassembleWorkOrderApprovalExistent(java.lang.String approvalUserName)
boolean | isDisassembleWorkOrderItemExist(DisassembleWorkOrderItemPK pk)
boolean | isExistPartInUseType(PartPK pk)
boolean | isOrderHaveParentOrder(java.lang.String orderNumber, java.lang.String orderItemNumber)
boolean | isOrderHaveSubOrders(java.lang.String orderNumber, java.lang.String orderItemNumber)
boolean | isRequiredDateExpired(WorkInstructionPK pk, java.util.Date startDate, java.util.Date requiredDate)
boolean | isWorkInstructionExist(WorkOrderItemPK itemPk, WorkInstructionPK pk)
boolean | isWorkOrderApprovalExistent(java.lang.String approvalUserName)
boolean | isWorkOrderBoilerplateExist(java.lang.String workOrderBoilerplateId)
boolean | isWorkOrderExist(java.lang.String woNumber)
boolean | isWorkOrderItemExist(WorkOrderItemPK pk)
boolean | isWorkOrderWorkInstructionExist(WorkOrderWorkInstructionPK pk)
boolean | isWorkOrderWorkInstructionSequencesFinished(WorkOrderWorkInstructionSequencePK pk)
boolean | isWorkOrderWorkSheetExistent(WorkOrderWorkSheetPK pk)
java.util.Collection<WorkOrderItemListResult> | makeWorkOrders(WorkOrderWorkSheetVO pwsVO)
WorkOrderItemPK | reviewWorkOrderItemCost(WorkOrderItemPK pk, java.lang.String desc)
void | saveWoItemSeqStartDate(java.util.ArrayList<WorkOrderWorkInstructionSequenceDateAgent> wisList)
void | saveWorkOrderItemDate(java.util.ArrayList<WorkOrderWorkItemDateAgent> woiList)
DisassembleWorkOrderItemPK | setupDisassembleWorkOrderItem(DisassembleWorkOrderItemPK itemPk, java.util.ArrayList items)
WorkOrderItemPK | setupWorkOrderItem(WorkOrderItemPK itemPk, java.util.ArrayList items, boolean setupByMfg)
void | setWorkOrderItemIssueReferenceDocOne(WorkOrderItemIssuePK pk, java.lang.String referenceDoc)
void | setWorkOrderItemReferenceDocOne(WorkOrderItemPK pk, java.lang.String referenceDoc)
void | setWorkOrderItemReferenceDocTwo(WorkOrderItemPK pk, java.lang.String referenceDoc)
void | synchronizeWiSeqToWowiSeq(WorkInstructionPK wiPK, WorkOrderItemPK woiPK)
java.lang.String | updateDisassembleWorkOrder(DisassembleWorkOrderVO vo)
DisassembleWorkOrderApprovalVO | updateDisassembleWorkOrderApproval(DisassembleWorkOrderApprovalVO dwoApprovalVO)
void | updateDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemPK itemPk, java.util.LinkedHashMap<BB2Part,java.math.BigDecimal> map)
DisassembleWorkOrderItemPartDetailItemResult | updateDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemReceiverVO vo)
PartUseTypeVO | updatePartUseType(PartUseTypeVO vo)
RefdocVO | updateRefdocOne(RefdocVO vo)
RefdocVO | updateRefdocTwo(RefdocVO vo)
java.lang.String | updateWorkOrder(WorkOrderVO vo)
WorkOrderApprovalVO | updateWorkOrderApproval(WorkOrderApprovalVO woApprovalVO)
WorkOrderBoilerplateVO | updateWorkOrderBP(WorkOrderBoilerplateVO vo)
WorkOrderItemPartDetailItemResult | updateWorkOrderItemIssue(WorkOrderItemIssueVO vo)
void | updateWorkOrderItemIssue(WorkOrderItemPK itemPk, java.util.LinkedHashMap<BB2Part,java.math.BigDecimal> map, java.util.LinkedHashMap<BB2Part,java.lang.String> updateCommentsMap)
WorkOrderItemTimeDetailVO | updateWorkOrderItemTimeDetail(WorkOrderItemTimeDetailVO vo)
WorkOrderWorkInstructionVO | updateWorkOrderWorkInstruction(WorkOrderWorkInstructionVO vo)
void | updateWorkOrderWorkInstructionSequence(WorkOrderWorkInstructionSequenceVO vo)
WorkOrderWorkSheetVO | updateWorkOrderWorkSheet(WorkOrderWorkSheetVO pwsVO)
void | updateWorkOrderWorkSheetItem(WorkOrderWorkSheetItemVO pwsItemVO)
java.util.Collection<DisassembleWorkOrderDocumentVO> | uploadOrUpdateFTPDWODoc(MiscDocAgent agent)
java.util.Collection<WorkOrderDocumentVO> | uploadOrUpdateFTPWODoc(MiscDocAgent agent)

Method Detail

findWorkOrderListResults

java.util.Collection<WorkOrderListResult> findWorkOrderListResults(java.lang.String woNumber,
                                                                   java.lang.String[] status,
                                                                   java.lang.String vendId,
                                                                   int firstIndex,
                                                                   int maxLength)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderListResultsCount

int getWorkOrderListResultsCount(java.lang.String woNumber,
                                 java.lang.String[] status,
                                 java.lang.String vendId)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

findWorkOrderListResultsByWoNumber

java.util.Collection<WorkOrderItemListResult> findWorkOrderListResultsByWoNumber(java.lang.String woNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderListResultsCountByWoNumber

int getWorkOrderListResultsCountByWoNumber(java.lang.String woNumber)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

findOpenWorkOrderListResultsByWoNumber

java.util.Collection<WorkOrderItemListResult> findOpenWorkOrderListResultsByWoNumber(java.lang.String woNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOpenWorkOrderListResultsByWoNumberCount

int getOpenWorkOrderListResultsByWoNumberCount(java.lang.String woNumber)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

findOpenWorkOrderListResults

java.util.Collection<WorkOrderListResult> findOpenWorkOrderListResults(java.lang.String woNumber,
                                                                       int firstIndex,
                                                                       int maxLength)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getOpenWorkOrderListResultsCount

int getOpenWorkOrderListResultsCount(java.lang.String woNumber)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findAllTopMasterWorkOrder

java.util.Collection<WorkOrderItemListResult> findAllTopMasterWorkOrder(java.util.Date fromDate,
                                                                        java.util.Date toDate,
                                                                        java.lang.String projectName,
                                                                        java.lang.String workOrderNumber,
                                                                        java.lang.String partNumber,
                                                                        java.lang.String partType,
                                                                        boolean isShowCost,
                                                                        boolean isShowMainWO,
                                                                        java.lang.String status,
                                                                        java.lang.String dateType)
                                                                        throws java.lang.Exception
Throws:
java.lang.Exception

findWorkOrderListResultsByVendorId

java.util.Collection<WorkOrderListResult> findWorkOrderListResultsByVendorId(java.lang.String vendorId,
                                                                             int firstIndex,
                                                                             int maxLength)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderListResultsCountByVendorId

int getWorkOrderListResultsCountByVendorId(java.lang.String vendorId)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

findAllMasterWorkOrder

java.util.Collection<WorkOrderItemInfoResult> findAllMasterWorkOrder(java.lang.String workOrderNumber,
                                                                     java.lang.String relatedDoc,
                                                                     java.lang.String partNumber,
                                                                     java.lang.String partType,
                                                                     int firstIndex,
                                                                     int maxLength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getAllMasterWorkOrderCount

int getAllMasterWorkOrderCount(java.lang.String workOrderNumber,
                               java.lang.String relatedDoc,
                               java.lang.String partNumber,
                               java.lang.String partType)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getSubWorkOrderByWorkOrderItemPK

java.util.Collection<WorkOrderItemVO> getSubWorkOrderByWorkOrderItemPK(WorkOrderItemPK itemPk)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderWithOrderApplyByWo

WorkOrderVO getWorkOrderWithOrderApplyByWo(java.lang.Long orderApplyID)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderVendorIDByWo

java.lang.String getWorkOrderVendorIDByWo(java.lang.String id)
                                          throws InvokeException
Throws:
InvokeException

getWorkOrderByWo

WorkOrderVO getWorkOrderByWo(java.lang.String id)
                             throws java.lang.Exception
Throws:
java.lang.Exception

setWorkOrderItemReferenceDocOne

void setWorkOrderItemReferenceDocOne(WorkOrderItemPK pk,
                                     java.lang.String referenceDoc)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

setWorkOrderItemReferenceDocTwo

void setWorkOrderItemReferenceDocTwo(WorkOrderItemPK pk,
                                     java.lang.String referenceDoc)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

clearWorkOrderItemReferenceDocOne

void clearWorkOrderItemReferenceDocOne(java.lang.String referenceDoc)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

clearWorkOrderItemReferenceDocTwo

void clearWorkOrderItemReferenceDocTwo(java.lang.String referenceDoc)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

copyWorkOrderFromWorkOrder

java.lang.String copyWorkOrderFromWorkOrder(WO2WOAgent agent)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

reviewWorkOrderItemCost

WorkOrderItemPK reviewWorkOrderItemCost(WorkOrderItemPK pk,
                                        java.lang.String desc)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

setupWorkOrderItem

WorkOrderItemPK setupWorkOrderItem(WorkOrderItemPK itemPk,
                                   java.util.ArrayList items,
                                   boolean setupByMfg)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderItemById

WorkOrderItemVO getWorkOrderItemById(WorkOrderItemPK itemPk)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderItemByIdForWOLabel

WorkOrderItemVO getWorkOrderItemByIdForWOLabel(WorkOrderItemPK itemPk)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderItemWithWIById

WorkOrderItemVO getWorkOrderItemWithWIById(WorkOrderItemPK itemPk,
                                           java.util.Date fromDate,
                                           java.util.Date toDate)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

saveWorkOrderItemDate

void saveWorkOrderItemDate(java.util.ArrayList<WorkOrderWorkItemDateAgent> woiList)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findNotSetupWorkOrderItemListResults

java.util.Collection<WorkOrderItemListResult> findNotSetupWorkOrderItemListResults(java.lang.String woNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getNotSetupWorkOrderItemListResultsCount

int getNotSetupWorkOrderItemListResultsCount(java.lang.String woNumber)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findNotSetupWorkOrderItemListResults

java.util.Collection<WorkOrderItemListResult> findNotSetupWorkOrderItemListResults(java.lang.String woNumber,
                                                                                boolean onlyApprovedWOItem,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getNotSetupWorkOrderItemListResultsCount

int getNotSetupWorkOrderItemListResultsCount(java.lang.String woNumber,
                                             boolean onlyApprovedWOItem)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findWorkOrderItemListResults

java.util.Collection<WorkOrderItemListResult> findWorkOrderItemListResults(java.lang.String woNumberLike,
                                                                           java.lang.String partNumberLike,
                                                                           java.lang.String partType,
                                                                           java.lang.String status,
                                                                           boolean isDue,
                                                                           int firstIndex,
                                                                           int maxLength)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderItemListResultsCount

int getWorkOrderItemListResultsCount(java.lang.String woNumberLike,
                                     java.lang.String partNumberLike,
                                     java.lang.String partType,
                                     java.lang.String status,
                                     boolean isDue)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findWorkOrderItemListResults

java.util.Collection<WorkOrderItemListResult> findWorkOrderItemListResults(java.lang.String partNumberLike,
                                                                           java.lang.String partType,
                                                                           java.lang.String status,
                                                                           int firstIndex,
                                                                           int maxLength)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderItemListResultsCount

int getWorkOrderItemListResultsCount(java.lang.String partNumberLike,
                                     java.lang.String partType,
                                     java.lang.String status)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderItemListResultsWithoutLikeCount

int getWorkOrderItemListResultsWithoutLikeCount(java.lang.String partNumberLike,
                                                java.lang.String partType,
                                                java.lang.String status)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

findOpenWorkOrderItemListResultsByPartPK

java.util.Collection<WorkOrderItemListResult> findOpenWorkOrderItemListResultsByPartPK(PartPK partPk,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOpenWorkOrderItemListResultsByPartPkCount

int getOpenWorkOrderItemListResultsByPartPkCount(PartPK partPk)
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findWorkOrderItemListResultsByPartNumberLike

java.util.Collection<WorkOrderItemListResult> findWorkOrderItemListResultsByPartNumberLike(java.lang.String partNumberLike,
                                                                                java.lang.String partType,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderItemListResultsCountByPartNumberLike

int getWorkOrderItemListResultsCountByPartNumberLike(java.lang.String partNumberLike,
                                                     java.lang.String partType)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

findOpenWorkOrderItemListResults

java.util.Collection<WorkOrderItemListResult> findOpenWorkOrderItemListResults(boolean orderByDateRequiredAsc,
                                                                               int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getOpenWorkOrderItemListResultsCount

int getOpenWorkOrderItemListResultsCount()
                                         throws java.lang.Exception
Throws:
java.lang.Exception

findWOItemsCanIssue

java.util.Collection<WorkOrderItemListResult> findWOItemsCanIssue(java.lang.String partFrom,
                                                                  boolean isDueDateType,
                                                                  java.util.Date fromDate,
                                                                  java.util.Date toDate,
                                                                  boolean showAllIssued,
                                                                  int firstIndex,
                                                                  int maxLength)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getWOItemsCanIssueCount

int getWOItemsCanIssueCount(java.lang.String partFrom,
                            boolean isDueDateType,
                            java.util.Date fromDate,
                            java.util.Date toDate,
                            boolean showAllIssued)
                            throws java.lang.Exception
Throws:
java.lang.Exception

findOpenWorkOrderItemListResults

java.util.Collection<WorkOrderItemListResult> findOpenWorkOrderItemListResults(java.lang.String woNumberLike,
                                                                               java.lang.String partNumberLike,
                                                                               java.lang.String partType,
                                                                               int firstIndex,
                                                                               int maxLength)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

getOpenWorkOrderItemListResultsCount

int getOpenWorkOrderItemListResultsCount(java.lang.String woNumberLike,
                                         java.lang.String partNumberLike,
                                         java.lang.String partType)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

findOpenUnHoldWorkOrderItemListResults

java.util.Collection<WorkOrderItemListResult> findOpenUnHoldWorkOrderItemListResults(java.lang.String woNumberLike,
                                                                                java.lang.String partNumberLike,
                                                                                java.lang.String partType,
                                                                                boolean showAllIssued,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOpenUnHoldWorkOrderItemListResultsCount

int getOpenUnHoldWorkOrderItemListResultsCount(java.lang.String woNumberLike,
                                               java.lang.String partNumberLike,
                                               java.lang.String partType,
                                               boolean showAllIssued)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

findDueWorkOrderItemListResults

java.util.Collection<WorkOrderItemListResult> findDueWorkOrderItemListResults(int firstIndex,
                                                                              int maxLength)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getDueWorkOrderItemListResultsCount

int getDueWorkOrderItemListResultsCount()
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findWorkOrderItemListResultsByDate

java.util.Collection<WorkOrderItemListResult> findWorkOrderItemListResultsByDate(java.lang.String dateType,
                                                                                java.util.Date fromDate,
                                                                                java.util.Date toDate,
                                                                                java.lang.String partNumberLike,
                                                                                java.lang.String partType,
                                                                                java.lang.String vendId,
                                                                                java.lang.String[] status,
                                                                                java.lang.String project,
                                                                                java.lang.String originator,
                                                                                java.lang.String relateDoc,
                                                                                java.lang.String contact,
                                                                                java.lang.String accountNumber,
                                                                                java.lang.String companyUnitId,
                                                                                boolean isHold,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findWorkOrderItemListResultsByDateTotal

java.util.Collection<WorkOrderItemListResult> findWorkOrderItemListResultsByDateTotal(java.lang.String dateType,
                                                                                java.util.Date fromDate,
                                                                                java.util.Date toDate,
                                                                                java.lang.String partNumberLike,
                                                                                java.lang.String partType,
                                                                                java.lang.String vendId,
                                                                                java.lang.String[] status,
                                                                                java.lang.String project,
                                                                                java.lang.String originator,
                                                                                java.lang.String relateDoc,
                                                                                java.lang.String contact,
                                                                                java.lang.String accountNumber,
                                                                                java.lang.String companyUnitId,
                                                                                boolean isHold)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderItemListResultsCountByDate

int getWorkOrderItemListResultsCountByDate(java.lang.String dateType,
                                           java.util.Date fromDate,
                                           java.util.Date toDate,
                                           java.lang.String partNumberLike,
                                           java.lang.String partType,
                                           java.lang.String vendId,
                                           java.lang.String[] status,
                                           java.lang.String project,
                                           java.lang.String originator,
                                           java.lang.String relateDoc,
                                           java.lang.String contact,
                                           java.lang.String accountNumber,
                                           java.lang.String companyUnitId,
                                           boolean isHold)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

findOpenWorkOrderByVendorId

java.util.Collection<WorkOrderItemListResult> findOpenWorkOrderByVendorId(java.lang.String addressIdLike,
                                                                          int firstIndex,
                                                                          int maxLength)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getOpenWorkOrderCountByVendorId

int getOpenWorkOrderCountByVendorId(java.lang.String addressIdLike)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findAllWorkOrderCheckListResults

java.util.Collection<WorkOrderCheckListResult> findAllWorkOrderCheckListResults(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllWorkOrderCheckListResultsCount

int getAllWorkOrderCheckListResultsCount()
                                         throws java.lang.Exception
Throws:
java.lang.Exception

findWorkOrderCheckListResults

java.util.Collection<WorkOrderCheckListResult> findWorkOrderCheckListResults(java.lang.String startWith,
                                                                             int firstIndex,
                                                                             int maxLength)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderCheckListResultsCount

int getWorkOrderCheckListResultsCount(java.lang.String startWith)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

initWorkOrderItemForNA

WorkOrderItemVO initWorkOrderItemForNA(java.lang.String woNumber,
                                       java.lang.String itemNum,
                                       java.lang.String naDesc,
                                       java.math.BigDecimal qty)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

initWorkOrderItemForPart

WorkOrderItemVO initWorkOrderItemForPart(java.lang.String woNumber,
                                         java.lang.String itemNum,
                                         PartPK partPk,
                                         java.math.BigDecimal qty)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

initWorkOrderItemForTool

WorkOrderItemVO initWorkOrderItemForTool(java.lang.String woNumber,
                                         java.lang.String itemNum,
                                         PartPK partPk,
                                         java.math.BigDecimal qty)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

isWorkOrderItemExist

boolean isWorkOrderItemExist(WorkOrderItemPK pk)
                             throws java.lang.Exception
Throws:
java.lang.Exception

getVendorForWorkOrder

java.lang.String getVendorForWorkOrder(java.lang.String woNumber)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

addWorkOrder

java.lang.String addWorkOrder(java.lang.String addressId)
                              throws java.lang.Exception
Throws:
java.lang.Exception

updateWorkOrder

java.lang.String updateWorkOrder(WorkOrderVO vo)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

cancelWorkOrder

java.lang.String cancelWorkOrder(java.lang.String woNumber)
                                 throws java.lang.Exception
Throws:
java.lang.Exception

approveWorkOrder

WorkOrderVO approveWorkOrder(WorkOrderVO vo)
                             throws java.lang.Exception
Throws:
java.lang.Exception

deleteWorkOrder

void deleteWorkOrder(WorkOrderVO vo)
                     throws java.lang.Exception
Throws:
java.lang.Exception

isWorkOrderExist

boolean isWorkOrderExist(java.lang.String woNumber)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findWorkOrderItemListResultsWithPartHold

java.util.Collection<WorkOrderItemListResult> findWorkOrderItemListResultsWithPartHold(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderItemListResultsWithPartHoldCount

int getWorkOrderItemListResultsWithPartHoldCount()
                                                 throws java.lang.Exception
Throws:
java.lang.Exception

findWorkOrderItemReviewCostResults

java.util.Collection<WorkOrderItemReviewCostResult> findWorkOrderItemReviewCostResults(java.lang.String woLike,
                                                                                java.lang.String vendorID,
                                                                                java.lang.String pnLike,
                                                                                java.lang.String reviewedBy,
                                                                                java.util.Date fromDate,
                                                                                java.util.Date toDate,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderItemReviewCostResultsCount

int getWorkOrderItemReviewCostResultsCount(java.lang.String woLike,
                                           java.lang.String vendorID,
                                           java.lang.String pnLike,
                                           java.lang.String reviewedBy,
                                           java.util.Date fromDate,
                                           java.util.Date toDate)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

findNotReviewedWorkOrderItemReviewCostResults

java.util.Collection<WorkOrderItemReviewCostResult> findNotReviewedWorkOrderItemReviewCostResults(java.lang.String woLike,
                                                                                java.lang.String vendorID,
                                                                                java.lang.String pnLike,
                                                                                java.util.Date fromDate,
                                                                                java.util.Date toDate,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getNotReviewedWorkOrderItemReviewCostResultsCount

int getNotReviewedWorkOrderItemReviewCostResultsCount(java.lang.String woLike,
                                                      java.lang.String vendorID,
                                                      java.lang.String pnLike,
                                                      java.util.Date fromDate,
                                                      java.util.Date toDate)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

addWorkOrderItemIssue

WorkOrderItemPartDetailItemResult addWorkOrderItemIssue(WorkOrderItemPK itemPk,
                                                        BB2Part part,
                                                        java.math.BigDecimal qty)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

addWorkOrderItemIssue

WorkOrderItemPartDetailItemResult addWorkOrderItemIssue(WorkOrderItemPK itemPk,
                                                        java.math.BigDecimal qty,
                                                        java.math.BigDecimal qtyIssued,
                                                        java.math.BigDecimal cost,
                                                        java.lang.String description)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

addWorkOrderItemIssue

void addWorkOrderItemIssue(WorkOrderItemPK itemPk,
                           java.util.LinkedHashMap<BB2Part,java.math.BigDecimal> map,
                           java.util.LinkedHashMap<BB2Part,java.lang.String> commentsMap)
                           throws java.lang.Exception
Throws:
java.lang.Exception

updateWorkOrderItemIssue

WorkOrderItemPartDetailItemResult updateWorkOrderItemIssue(WorkOrderItemIssueVO vo)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

updateWorkOrderItemIssue

void updateWorkOrderItemIssue(WorkOrderItemPK itemPk,
                              java.util.LinkedHashMap<BB2Part,java.math.BigDecimal> map,
                              java.util.LinkedHashMap<BB2Part,java.lang.String> updateCommentsMap)
                              throws java.lang.Exception
Throws:
java.lang.Exception

deleteWorkOrderItemIssue

void deleteWorkOrderItemIssue(WorkOrderItemIssueVO vo)
                              throws java.lang.Exception
Throws:
java.lang.Exception

deleteWorkOrderItemIssues

void deleteWorkOrderItemIssues(java.util.ArrayList<WorkOrderItemIssuePK> items)
                               throws java.lang.Exception
Throws:
java.lang.Exception

deleteWorkOrderItemIssue

void deleteWorkOrderItemIssue(WorkOrderItemIssuePK issuePk)
                              throws java.lang.Exception
Throws:
java.lang.Exception

deleteWorkOrderItemIssue

void deleteWorkOrderItemIssue(IssuingItemResult item)
                              throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderItemIssueByPk

WorkOrderItemIssueVO getWorkOrderItemIssueByPk(WorkOrderItemIssuePK issuePk)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderItemPartDetailItemResult

WorkOrderItemPartDetailItemResult getWorkOrderItemPartDetailItemResult(WorkOrderItemIssuePK pk)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getPartDetailResult

WorkOrderItemPartDetailResult getPartDetailResult(WorkOrderItemPK itemPk)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

findOpenAndIssuedWorkOrderItemIssues

java.util.Collection<WorkOrderItemIssueVO> findOpenAndIssuedWorkOrderItemIssues(java.lang.String woNumber,
                                                                                java.lang.String itemNumber,
                                                                                BB2Part part)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findWorkOrderItemIssues

java.util.Collection<WorkOrderItemIssueVO> findWorkOrderItemIssues(WorkOrderItemPK itemPk)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

findWorkOrderItemWithWipIssues

java.util.Collection<WorkOrderItemIssueVO> findWorkOrderItemWithWipIssues(WorkOrderItemPK itemPk,
                                                                          java.util.Date fromDate,
                                                                          java.util.Date toDate)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderItemIssuesCount

int getWorkOrderItemIssuesCount(WorkOrderItemPK itemPk)
                                throws java.lang.Exception
Throws:
java.lang.Exception

getNextWorkOrderItemIssueItemNumber

java.lang.Short getNextWorkOrderItemIssueItemNumber(WorkOrderItemPK orderItemPk)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

setWorkOrderItemIssueReferenceDocOne

void setWorkOrderItemIssueReferenceDocOne(WorkOrderItemIssuePK pk,
                                          java.lang.String referenceDoc)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

clearWorkOrderItemIssueReferenceDocOne

void clearWorkOrderItemIssueReferenceDocOne(java.lang.String referenceDoc)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

findWorkOrderItemPartDetailNotIssues

java.util.Collection<WOItemPartDetailNotIssue> findWorkOrderItemPartDetailNotIssues(java.lang.String woNumber,
                                                                                java.lang.String vendorId,
                                                                                java.util.Date from,
                                                                                java.util.Date to,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderItemPartDetailNotIssuesCount

int getWorkOrderItemPartDetailNotIssuesCount(java.lang.String woNumber,
                                             java.lang.String vendorId,
                                             java.util.Date from,
                                             java.util.Date to)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findWorkOrderItemInWipList

java.util.Collection<WorkOrderItemInWipListResult> findWorkOrderItemInWipList(java.lang.String monthYear,
                                                                              int firstIndex,
                                                                              int maxLength)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderItemInWipListCount

int getWorkOrderItemInWipListCount(java.lang.String monthYear)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderItemPartInWipTotal

BB2DoubleCost getWorkOrderItemPartInWipTotal(java.lang.String monthYear)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

getWoiDetailInWipCountByGlNumber

int getWoiDetailInWipCountByGlNumber(java.lang.String glNumber,
                                     java.util.Date fromDate,
                                     java.util.Date toDate)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

findWoiDetailInWipByGlNumber

java.util.Collection<WorkOrderItemPartDetailInWipVO> findWoiDetailInWipByGlNumber(java.lang.String glNumber,
                                                                                java.util.Date fromDate,
                                                                                java.util.Date toDate,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findPartInWorkOrderPartDetail

java.util.Collection<WOItemPartDetailNotIssue> findPartInWorkOrderPartDetail(java.lang.String woNumber,
                                                                             java.lang.String pnLike,
                                                                             java.lang.String paLike,
                                                                             java.lang.String pfLike,
                                                                             java.lang.String ProjectName,
                                                                             boolean isRefDoc,
                                                                             java.lang.String dateType,
                                                                             java.util.Date dateFrom,
                                                                             java.util.Date dateTo,
                                                                             int firstIndex,
                                                                             int maxLength)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getPartInWorkOrderPartDetailCount

int getPartInWorkOrderPartDetailCount(java.lang.String woNumber,
                                      java.lang.String pnLike,
                                      java.lang.String paLike,
                                      java.lang.String pfLike,
                                      java.lang.String ProjectName,
                                      boolean isRefDoc,
                                      java.lang.String dateType,
                                      java.util.Date dateFrom,
                                      java.util.Date dateTo)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

addWorkOrderItemTimeDetail

WorkOrderItemTimeDetailVO addWorkOrderItemTimeDetail(WorkOrderItemTimeDetailVO vo)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

addEmployeeLabor

java.lang.Long addEmployeeLabor(EmployeeLaborAgent agent)
                                throws java.lang.Exception
Throws:
java.lang.Exception

updateWorkOrderItemTimeDetail

WorkOrderItemTimeDetailVO updateWorkOrderItemTimeDetail(WorkOrderItemTimeDetailVO vo)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderItemTimeDetailByPk

WorkOrderItemTimeDetailVO getWorkOrderItemTimeDetailByPk(java.lang.Long pk)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

deleteWorkOrderItemTimeDetail

void deleteWorkOrderItemTimeDetail(java.lang.Long pk)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

getTimeDetailResult

WorkOrderItemTimeDetailResult getTimeDetailResult(WorkOrderItemPK itemPk)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

findWorkOrderTimeCards

java.util.Collection<WorkOrderTimeCardVO> findWorkOrderTimeCards(WorkOrderItemPK itemPk)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderItemTimeDetailsCount

int getWorkOrderItemTimeDetailsCount(WorkOrderItemPK itemPk)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderItemWorkCenterSumCost

java.math.BigDecimal getWorkOrderItemWorkCenterSumCost(WorkOrderItemPK itemPk)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

addWorkOrderApproval

WorkOrderApprovalVO addWorkOrderApproval(java.lang.String employeeId)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

updateWorkOrderApproval

WorkOrderApprovalVO updateWorkOrderApproval(WorkOrderApprovalVO woApprovalVO)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

deleteWorkOrderApproval

void deleteWorkOrderApproval(WorkOrderApprovalVO woApprovalVO)
                             throws java.lang.Exception
Throws:
java.lang.Exception

deleteWorkOrderApproval

void deleteWorkOrderApproval(java.lang.String employeeId)
                             throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderApprovalByUserNumber

WorkOrderApprovalVO getWorkOrderApprovalByUserNumber(java.lang.String userName)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderApprovalByEmployeeId

WorkOrderApprovalVO getWorkOrderApprovalByEmployeeId(java.lang.String employeeId)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

isWorkOrderApprovalExistent

boolean isWorkOrderApprovalExistent(java.lang.String approvalUserName)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findAllWorkOrderApprovals

java.util.Collection<WorkOrderApprovalVO> findAllWorkOrderApprovals(int firstIndex,
                                                                    int maxLength)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getAllWorkOrderApprovalsCount

int getAllWorkOrderApprovalsCount()
                                  throws java.lang.Exception
Throws:
java.lang.Exception

addWorkOrderWorkSheet

WorkOrderWorkSheetVO addWorkOrderWorkSheet()
                                           throws java.lang.Exception
Throws:
java.lang.Exception

addWorkOrderWorkSheet

WorkOrderWorkSheetVO addWorkOrderWorkSheet(java.util.ArrayList list)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

addWorkOrderWorkSheet

WorkOrderWorkSheetVO addWorkOrderWorkSheet(WorkOrderWorkSheetVO pwsVO)
                                           throws java.lang.Exception
Throws:
java.lang.Exception

updateWorkOrderWorkSheet

WorkOrderWorkSheetVO updateWorkOrderWorkSheet(WorkOrderWorkSheetVO pwsVO)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

deleteWorkOrderWorkSheet

void deleteWorkOrderWorkSheet(WorkOrderWorkSheetVO pwsVO)
                              throws java.lang.Exception
Throws:
java.lang.Exception

isWorkOrderWorkSheetExistent

boolean isWorkOrderWorkSheetExistent(WorkOrderWorkSheetPK pk)
                                     throws java.lang.Exception
Throws:
java.lang.Exception

getNextWorkOrderWorkSheetNumber

java.lang.Integer getNextWorkOrderWorkSheetNumber(java.lang.String employeeId)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

makeWorkOrders

java.util.Collection<WorkOrderItemListResult> makeWorkOrders(WorkOrderWorkSheetVO pwsVO)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderWorkSheetByPk

WorkOrderWorkSheetVO getWorkOrderWorkSheetByPk(WorkOrderWorkSheetPK pk)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

findAllWorkOrderWorkSheet

java.util.Collection<WorkOrderWorkSheetVO> findAllWorkOrderWorkSheet(int firstIndex,
                                                                     int maxLength)
                                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getAllWorkOrderWorkSheetCount

int getAllWorkOrderWorkSheetCount()
                                  throws java.lang.Exception
Throws:
java.lang.Exception

getAllMyWorkOrderWorkSheetCount

int getAllMyWorkOrderWorkSheetCount()
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findWorkOrderWorkSheetByEmployeeId

java.util.Collection<WorkOrderWorkSheetVO> findWorkOrderWorkSheetByEmployeeId(java.lang.String employeeId,
                                                                              int firstIndex,
                                                                              int maxLength)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

findAllMyWorkOrderWorkSheet

java.util.Collection<WorkOrderWorkSheetVO> findAllMyWorkOrderWorkSheet(int firstIndex,
                                                                       int maxLength)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderWorkSheetByCountByEmployeeId

int getWorkOrderWorkSheetByCountByEmployeeId(java.lang.String employeeId)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findWorkOrderWorkSheetByEmployeeEmailLike

java.util.Collection<WorkOrderWorkSheetVO> findWorkOrderWorkSheetByEmployeeEmailLike(java.lang.String employeeEmailLike,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderWorkSheetCountByEmployeeEmailLike

int getWorkOrderWorkSheetCountByEmployeeEmailLike(java.lang.String employeeEmailLike)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

addWorkOrderWorkSheetItem

WorkOrderWorkSheetItemVO addWorkOrderWorkSheetItem(WorkOrderWorkSheetItemVO pwsItemVO)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

updateWorkOrderWorkSheetItem

void updateWorkOrderWorkSheetItem(WorkOrderWorkSheetItemVO pwsItemVO)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

deleteWorkOrderWorkSheetItem

void deleteWorkOrderWorkSheetItem(WorkOrderWorkSheetItemVO pwsItemVO)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

findWorkOrderWorkSheetItemsByWorkSheetPk

java.util.Collection<WorkOrderWorkSheetItemWithRelatedInfoResult> findWorkOrderWorkSheetItemsByWorkSheetPk(WorkOrderWorkSheetPK workSheetPk)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getNextWorkOrderWorkSheetItemNumber

java.lang.Integer getNextWorkOrderWorkSheetItemNumber(WorkOrderWorkSheetVO vo)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

initWorkOrderWorkSheetItemForPart

WorkOrderWorkSheetItemWithRelatedInfoResult initWorkOrderWorkSheetItemForPart(WorkOrderWorkSheetPK pk,
                                                                              java.lang.String itemNum,
                                                                              PartPK partPk,
                                                                              java.math.BigDecimal qty)
                                                                              throws InvokeException,
                                                                                java.lang.Exception
Throws:
InvokeException
java.lang.Exception

initWorkOrderWorkSheetItemForTool

WorkOrderWorkSheetItemWithRelatedInfoResult initWorkOrderWorkSheetItemForTool(WorkOrderWorkSheetPK pk,
                                                                              java.lang.String itemNum,
                                                                              PartPK partPk,
                                                                              java.math.BigDecimal qty)
                                                                              throws InvokeException,
                                                                                java.lang.Exception
Throws:
InvokeException
java.lang.Exception

getTotalWorkOrderInstructionSeq

java.util.Collection<BB2DoubleString> getTotalWorkOrderInstructionSeq(java.lang.String partNumber,
                                                                      java.lang.String partType,
                                                                      java.lang.String workOrderNumber,
                                                                      java.lang.String status)
                                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderInstructionSeqCount

int getWorkOrderInstructionSeqCount(java.lang.String partNumber,
                                    java.lang.String partType,
                                    java.lang.String workOrderNumber,
                                    java.lang.String status)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findWorkOrderInstructionSeq

java.util.Collection<WorkOrderWorkInstructionListResult> findWorkOrderInstructionSeq(java.lang.String partNumber,
                                                                                java.lang.String partType,
                                                                                java.lang.String workOrderNumber,
                                                                                java.lang.String status,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

addWorkOrderWorkInstruction

WorkOrderWorkInstructionVO addWorkOrderWorkInstruction(WorkOrderItemPK woItemPk,
                                                       WorkInstructionPK wiPk)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

deleteWorkOrderWorkInstruction

void deleteWorkOrderWorkInstruction(WorkOrderWorkInstructionVO vo)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

deleteWorkOrderWorkInstruction

void deleteWorkOrderWorkInstruction(WorkOrderWorkInstructionPK pk)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

updateWorkOrderWorkInstruction

WorkOrderWorkInstructionVO updateWorkOrderWorkInstruction(WorkOrderWorkInstructionVO vo)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

isWorkOrderWorkInstructionExist

boolean isWorkOrderWorkInstructionExist(WorkOrderWorkInstructionPK pk)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

deleteAllWorkOrderWorkInstructionSequences

void deleteAllWorkOrderWorkInstructionSequences(WorkOrderWorkInstructionPK pk)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderWorkInstructionByPk

WorkOrderWorkInstructionVO getWorkOrderWorkInstructionByPk(WorkOrderWorkInstructionPK pk)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

synchronizeWiSeqToWowiSeq

void synchronizeWiSeqToWowiSeq(WorkInstructionPK wiPK,
                               WorkOrderItemPK woiPK)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderWorkInstructionByWoItemPk

WorkOrderWorkInstructionVO getWorkOrderWorkInstructionByWoItemPk(WorkOrderItemPK pk)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

getManWorkInstructionByWoItemPk

WorkInstructionVO getManWorkInstructionByWoItemPk(BB2Part part,
                                                  java.lang.String setId)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

isWorkInstructionExist

boolean isWorkInstructionExist(WorkOrderItemPK itemPk,
                               WorkInstructionPK pk)
                               throws java.lang.Exception
Throws:
java.lang.Exception

addWorkOrderWorkInstruction

WorkOrderWorkInstructionVO addWorkOrderWorkInstruction(WorkOrderWorkInstructionVO vo)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

addWorkOrderWorkInstructionSequence

WorkOrderWorkInstructionSequenceVO addWorkOrderWorkInstructionSequence(WorkOrderWorkInstructionSequenceVO vo)
                                                                       throws java.lang.Exception
Throws:
java.lang.Exception

deleteWorkOrderWorkInstructionSequence

void deleteWorkOrderWorkInstructionSequence(WorkOrderWorkInstructionSequenceVO vo)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

updateWorkOrderWorkInstructionSequence

void updateWorkOrderWorkInstructionSequence(WorkOrderWorkInstructionSequenceVO vo)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

finishWorkOrderWorkInstructionSequence

void finishWorkOrderWorkInstructionSequence(WorkOrderWorkInstructionSequencePK pk,
                                            boolean finish)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderWorkInstructionSequenceByPk

WorkOrderWorkInstructionSequenceVO getWorkOrderWorkInstructionSequenceByPk(WorkOrderWorkInstructionSequencePK pk)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

findWorkOrderWorkInstructionSequences

java.util.Collection<WorkOrderWorkInstructionSequenceVO> findWorkOrderWorkInstructionSequences(WorkOrderWorkInstructionPK pk)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderWorkInstructionSequencesCount

int getWorkOrderWorkInstructionSequencesCount(WorkOrderWorkInstructionPK pk)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

isWorkOrderWorkInstructionSequencesFinished

boolean isWorkOrderWorkInstructionSequencesFinished(WorkOrderWorkInstructionSequencePK pk)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

saveWoItemSeqStartDate

void saveWoItemSeqStartDate(java.util.ArrayList<WorkOrderWorkInstructionSequenceDateAgent> wisList)
                            throws java.lang.Exception
Throws:
java.lang.Exception

getWOWISeqDescription

java.lang.String getWOWISeqDescription(WorkOrderWorkInstructionSequencePK pk)
                                       throws java.lang.Exception
Throws:
java.lang.Exception

getWOReceiverItemListResultsOfWorkOrder

java.util.Collection<WorkOrderReceiverVO> getWOReceiverItemListResultsOfWorkOrder(java.lang.String woNumber)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

addRefdocTwo

RefdocVO addRefdocTwo(WorkOrderItemPK woItemPk,
                      java.lang.String orderNumber,
                      java.lang.String itemNumber,
                      java.math.BigDecimal refdocQty)
                      throws java.lang.Exception
Throws:
java.lang.Exception

updateRefdocTwo

RefdocVO updateRefdocTwo(RefdocVO vo)
                         throws java.lang.Exception
Throws:
java.lang.Exception

deleteRefdocTwo

void deleteRefdocTwo(BB2RefdocPK pk)
                     throws java.lang.Exception
Throws:
java.lang.Exception

addRefdocOne

RefdocVO addRefdocOne(WorkOrderItemPK woItemPk,
                      java.lang.String forderNumber,
                      java.lang.String fItemNumber,
                      java.math.BigDecimal refdocQty)
                      throws java.lang.Exception
Throws:
java.lang.Exception

updateRefdocOne

RefdocVO updateRefdocOne(RefdocVO vo)
                         throws java.lang.Exception
Throws:
java.lang.Exception

deleteRefdocOne

void deleteRefdocOne(BB2RefdocPK pk)
                     throws java.lang.Exception
Throws:
java.lang.Exception

addWorkOrderBP

WorkOrderBoilerplateVO addWorkOrderBP(WorkOrderBoilerplateVO vo)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

updateWorkOrderBP

WorkOrderBoilerplateVO updateWorkOrderBP(WorkOrderBoilerplateVO vo)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

deleteWorkOrderBP

void deleteWorkOrderBP(java.lang.String bpID)
                       throws java.lang.Exception
Throws:
java.lang.Exception

getAllWorkOrderBPCount

int getAllWorkOrderBPCount()
                           throws java.lang.Exception
Throws:
java.lang.Exception

findAllWorkOrderBP

java.util.Collection<WorkOrderBoilerplateVO> findAllWorkOrderBP(int firstIndex,
                                                                int maxLength)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderBPCountByBPId

int getWorkOrderBPCountByBPId(java.lang.String boilerplateId)
                              throws java.lang.Exception
Throws:
java.lang.Exception

findWorkOrderBPByBPId

java.util.Collection<WorkOrderBoilerplateVO> findWorkOrderBPByBPId(java.lang.String boilerplateId,
                                                                   int firstIndex,
                                                                   int maxLength)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderBPByPk

WorkOrderBoilerplateVO getWorkOrderBPByPk(java.lang.String workOrderBoilerplateId)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

isWorkOrderBoilerplateExist

boolean isWorkOrderBoilerplateExist(java.lang.String workOrderBoilerplateId)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

findWorkOrderIssuedDetail

java.util.Collection<PartIssuedVO> findWorkOrderIssuedDetail(WorkOrderItemPK pk,
                                                             BB2Part part,
                                                             java.lang.String description,
                                                             int firstIndex,
                                                             int maxLength)
                                                             throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderIssuedDetail

int getWorkOrderIssuedDetail(WorkOrderItemPK pk,
                             BB2Part part,
                             java.lang.String description)
                             throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderIssuedDetailTotal

PartIssueTotalResult getWorkOrderIssuedDetailTotal(WorkOrderItemPK pk,
                                                   BB2Part part,
                                                   java.lang.String description)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getWISetIDs

java.util.Collection<java.lang.String> getWISetIDs(BB2Part part)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

getSubOrders

java.util.Collection<RefdocVO> getSubOrders(java.lang.String orderNumber,
                                            java.lang.String orderItemNumber)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

getParentOrder

java.util.Collection<RefdocVO> getParentOrder(java.lang.String orderNumber,
                                              java.lang.String orderItemNumber)
                                              throws java.lang.Exception
Throws:
java.lang.Exception

isOrderHaveSubOrders

boolean isOrderHaveSubOrders(java.lang.String orderNumber,
                             java.lang.String orderItemNumber)
                             throws java.lang.Exception
Throws:
java.lang.Exception

isOrderHaveParentOrder

boolean isOrderHaveParentOrder(java.lang.String orderNumber,
                               java.lang.String orderItemNumber)
                               throws java.lang.Exception
Throws:
java.lang.Exception

getMasterWorkOrderTreeItem

java.util.Collection<MasterWorkOrderTreeItemResult> getMasterWorkOrderTreeItem(BillPK billPk,
                                                                               WorkOrderItemPK woItemPk,
                                                                               java.math.BigDecimal qty,
                                                                               boolean calculateOrphan,
                                                                               java.lang.String languageCode)
                                                                               throws java.lang.Exception
Throws:
java.lang.Exception

addWorkOrderFromMasterWorkOrder

java.util.Collection<WorkOrderItemListResult> addWorkOrderFromMasterWorkOrder(java.util.Date dueDate,
                                                                              WorkOrderItemPK masterWOPk,
                                                                              java.util.HashMap<java.lang.String,java.util.HashSet<WorkOrderItemAgent>> map)
                                                                              throws java.lang.Exception
Throws:
java.lang.Exception

findOverIssueItemList

java.util.Collection<WorkOrderOverIssueListResult> findOverIssueItemList(boolean isDueDateType,
                                                                         java.util.Date fromDate,
                                                                         java.util.Date toDate,
                                                                         java.lang.String vendorId,
                                                                         java.lang.String workOrderNumber,
                                                                         java.lang.String workOrderItemNumber,
                                                                         java.lang.String partNumber,
                                                                         java.lang.String partType,
                                                                         int firstIndex,
                                                                         int maxLength)
                                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getOverIssueItemListCount

int getOverIssueItemListCount(boolean isDueDateType,
                              java.util.Date fromDate,
                              java.util.Date toDate,
                              java.lang.String vendorId,
                              java.lang.String workOrderNumber,
                              java.lang.String workOrderItemNumber,
                              java.lang.String partNumber,
                              java.lang.String partType)
                              throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderItemCanAssyResults

java.util.Collection<WorkOrderItemCanAssyResult> getWorkOrderItemCanAssyResults(WorkOrderItemCanAssyAgent agent)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getPartCanAssy

java.util.Collection<PartPK> getPartCanAssy(BOMCanAssyAgent agent)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

getBOMCanAssyListResult

BOMCanAssyListResult getBOMCanAssyListResult(PartPK pk)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

getBOMCanAssyListResults

java.util.Collection<BOMCanAssyListResult> getBOMCanAssyListResults(java.util.ArrayList<PartPK> pks)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

findVendorOnTimeDeliveryRateByVendorId

java.util.Collection<OntimeDeliveryRateListResult> findVendorOnTimeDeliveryRateByVendorId(java.lang.String vendorId,
                                                                                java.util.Date from,
                                                                                java.util.Date to,
                                                                                int delayDays,
                                                                                int beforeDays,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getVendorOnTimeDeliveryRateCountByVendorId

int getVendorOnTimeDeliveryRateCountByVendorId(java.lang.String vendorId,
                                               java.util.Date from,
                                               java.util.Date to,
                                               int delayDays,
                                               int beforeDays)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

getVendorOnTimeDeliveryRate

OntimeDeliveryRateResult getVendorOnTimeDeliveryRate(java.lang.String vendorId,
                                                     java.util.Date from,
                                                     java.util.Date to,
                                                     int delayDays,
                                                     int beforeDays)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

getLast12MonthOntimeDeliveryRate

java.util.Map<java.util.Date,OntimeDeliveryRateResult> getLast12MonthOntimeDeliveryRate(java.lang.String vendorId,
                                                                                int overDueDays,
                                                                                int advanceDays)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findWorkOrderItemByVendorId

java.util.Collection<WorkOrderItemListResult> findWorkOrderItemByVendorId(java.lang.String vendorId,
                                                                          java.util.Date from,
                                                                          java.util.Date to,
                                                                          int firstIndex,
                                                                          int maxLength)
                                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderItemByVendorIdCount

int getWorkOrderItemByVendorIdCount(java.lang.String vendorId,
                                    java.util.Date from,
                                    java.util.Date to)
                                    throws java.lang.Exception
Throws:
java.lang.Exception

isRequiredDateExpired

boolean isRequiredDateExpired(WorkInstructionPK pk,
                              java.util.Date startDate,
                              java.util.Date requiredDate)
                              throws java.lang.Exception
Throws:
java.lang.Exception

uploadOrUpdateFTPWODoc

java.util.Collection<WorkOrderDocumentVO> uploadOrUpdateFTPWODoc(MiscDocAgent agent)
                                                                 throws java.lang.Exception
Throws:
java.lang.Exception

downloadFTPWODoc

byte[] downloadFTPWODoc(MiscDocAgent agent)
                        throws java.lang.Exception
Throws:
java.lang.Exception

deleteFTPWODoc

void deleteFTPWODoc(MiscDocAgent agent)
                    throws java.lang.Exception
Throws:
java.lang.Exception

findWorkOrderDocumentInfo

java.util.Collection<WorkOrderDocumentVO> findWorkOrderDocumentInfo(java.lang.String workOrderNumber)
                                                                    throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderDocumentByID

WorkOrderDocumentVO getWorkOrderDocumentByID(java.lang.Long controlNumber)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

approveOrderChangeByID

void approveOrderChangeByID(java.lang.Long orderChangeId,
                            java.lang.String reson)
                            throws java.lang.Exception
Throws:
java.lang.Exception

cancelOrderChangeByID

void cancelOrderChangeByID(java.lang.Long orderChangeId,
                           java.lang.String reson)
                           throws java.lang.Exception
Throws:
java.lang.Exception

deleteOrderChangeByID

void deleteOrderChangeByID(java.lang.Long orderChangeId)
                           throws java.lang.Exception
Throws:
java.lang.Exception

findOrderApprovalByVO

java.util.Collection<OrderApprovalVO> findOrderApprovalByVO(OrderApprovalVO vo,
                                                            int firstIndex,
                                                            int maxLength)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getOrderApprovalByOrder

OrderApprovalVO getOrderApprovalByOrder(java.lang.String orderNumber)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

findWorkOrderIssueStatisticsResults

java.util.Collection<WorkOrderIssueStatisticsResult> findWorkOrderIssueStatisticsResults(java.util.Date from,
                                                                                java.util.Date to,
                                                                                java.lang.String project,
                                                                                java.lang.String partNumber,
                                                                                java.lang.String partType,
                                                                                java.lang.String partFrom,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getdWorkOrderIssueStatisticsResultsCount

int getdWorkOrderIssueStatisticsResultsCount(java.util.Date from,
                                             java.util.Date to,
                                             java.lang.String project,
                                             java.lang.String partNumber,
                                             java.lang.String partType,
                                             java.lang.String partFrom)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

findPartUseTypeByPK

PartUseTypeVO findPartUseTypeByPK(java.lang.String useType)
                                  throws java.lang.Exception
Throws:
java.lang.Exception

updatePartUseType

PartUseTypeVO updatePartUseType(PartUseTypeVO vo)
                                throws java.lang.Exception
Throws:
java.lang.Exception

addPartUseType

PartUseTypeVO addPartUseType(PartUseTypeVO vo)
                             throws java.lang.Exception
Throws:
java.lang.Exception

deletePartUseType

void deletePartUseType(PartUseTypeVO vo)
                       throws java.lang.Exception
Throws:
java.lang.Exception

findPartUseType

java.util.Collection<PartUseTypeVO> findPartUseType(java.lang.String partNumber,
                                                    java.lang.String partType,
                                                    java.lang.String partFrom,
                                                    java.lang.String useType,
                                                    int firstIndex,
                                                    int maxLength)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

findPartUseTypeCount

int findPartUseTypeCount(java.lang.String partNumber,
                         java.lang.String partType,
                         java.lang.String partFrom,
                         java.lang.String useType)
                         throws java.lang.Exception
Throws:
java.lang.Exception

findAllPartUseType

java.util.Collection<PartUseTypeVO> findAllPartUseType()
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

findPOAndWOStatus

POAndWOStatusResult findPOAndWOStatus(java.util.Date fromDate,
                                      java.util.Date toDate,
                                      java.lang.String project)
                                      throws java.lang.Exception
Throws:
java.lang.Exception

isExistPartInUseType

boolean isExistPartInUseType(PartPK pk)
                             throws java.lang.Exception
Throws:
java.lang.Exception

getPartDetailResultNoNA

WorkOrderItemPartDetailResult getPartDetailResultNoNA(WorkOrderItemPK woItemPk)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

addDisassembleWorkOrder

java.lang.String addDisassembleWorkOrder(java.lang.String addressId)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

getDisassembleWorkOrderByDwo

DisassembleWorkOrderVO getDisassembleWorkOrderByDwo(java.lang.String id)
                                                    throws java.lang.Exception
Throws:
java.lang.Exception

updateDisassembleWorkOrder

java.lang.String updateDisassembleWorkOrder(DisassembleWorkOrderVO vo)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

cancelDisassembleWorkOrder

java.lang.String cancelDisassembleWorkOrder(java.lang.String disassembleWorkOrderNumber)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

getDWOShipperItemListResultsOfDisassembleWorkOrder

java.util.Collection<DisassembleWorkOrderIssueVO> getDWOShipperItemListResultsOfDisassembleWorkOrder(java.lang.String disassembleWorkOrderNumber)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

approveDisassembleWorkOrder

DisassembleWorkOrderVO approveDisassembleWorkOrder(DisassembleWorkOrderVO vo)
                                                   throws java.lang.Exception
Throws:
java.lang.Exception

isDisassembleWorkOrderItemExist

boolean isDisassembleWorkOrderItemExist(DisassembleWorkOrderItemPK pk)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

initDisassembleWorkOrderItem

DisassembleWorkOrderItemVO initDisassembleWorkOrderItem(java.lang.String dwoNumber,
                                                        java.lang.String itemNum,
                                                        PartPK partPk,
                                                        java.math.BigDecimal qty,
                                                        java.lang.String partFrom,
                                                        java.lang.String naDesc)
                                                        throws java.lang.Exception
Throws:
java.lang.Exception

setupDisassembleWorkOrderItem

DisassembleWorkOrderItemPK setupDisassembleWorkOrderItem(DisassembleWorkOrderItemPK itemPk,
                                                         java.util.ArrayList items)
                                                         throws java.lang.Exception
Throws:
java.lang.Exception

getDwoPartDetailResult

DisassembleWorkOrderItemPartDetailResult getDwoPartDetailResult(DisassembleWorkOrderItemPK woItemPk)
                                                                throws java.lang.Exception
Throws:
java.lang.Exception

updateDisassembleWorkOrderItemReceiver

DisassembleWorkOrderItemPartDetailItemResult updateDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemReceiverVO vo)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getDisassembleWorkOrderItemPartDetailItemResult

DisassembleWorkOrderItemPartDetailItemResult getDisassembleWorkOrderItemPartDetailItemResult(DisassembleWorkOrderItemReceiverPK pk)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

addDisassembleWorkOrderItemReceiver

DisassembleWorkOrderItemPartDetailItemResult addDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemPK itemPk,
                                                                                java.math.BigDecimal qty,
                                                                                java.math.BigDecimal qtyReceived,
                                                                                java.math.BigDecimal cost,
                                                                                java.lang.String description)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

addDisassembleWorkOrderItemReceiver

DisassembleWorkOrderItemPartDetailItemResult addDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemPK itemPk,
                                                                                BB2Part partPk,
                                                                                java.math.BigDecimal qty,
                                                                                java.math.BigDecimal cost)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

addDisassembleWorkOrderItemReceiver

void addDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemPK itemPk,
                                         java.util.LinkedHashMap<BB2Part,java.math.BigDecimal> map)
                                         throws java.lang.Exception
Throws:
java.lang.Exception

updateDisassembleWorkOrderItemReceiver

void updateDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemPK itemPk,
                                            java.util.LinkedHashMap<BB2Part,java.math.BigDecimal> map)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

addDisassembleWorkOrderApproval

DisassembleWorkOrderApprovalVO addDisassembleWorkOrderApproval(java.lang.String employeeId)
                                                               throws java.lang.Exception
Throws:
java.lang.Exception

updateDisassembleWorkOrderApproval

DisassembleWorkOrderApprovalVO updateDisassembleWorkOrderApproval(DisassembleWorkOrderApprovalVO dwoApprovalVO)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

deleteDisassembleWorkOrderApproval

void deleteDisassembleWorkOrderApproval(DisassembleWorkOrderApprovalVO woApprovalVO)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

deleteDisassembleWorkOrderApproval

void deleteDisassembleWorkOrderApproval(java.lang.String employeeId)
                                        throws java.lang.Exception
Throws:
java.lang.Exception

getDisassembleWorkOrderApprovalByUserNumber

DisassembleWorkOrderApprovalVO getDisassembleWorkOrderApprovalByUserNumber(java.lang.String userName)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

getDisassembleWorkOrderApprovalByEmployeeId

DisassembleWorkOrderApprovalVO getDisassembleWorkOrderApprovalByEmployeeId(java.lang.String employeeId)
                                                                           throws java.lang.Exception
Throws:
java.lang.Exception

isDisassembleWorkOrderApprovalExistent

boolean isDisassembleWorkOrderApprovalExistent(java.lang.String approvalUserName)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

findAllDisassembleWorkOrderApprovals

java.util.Collection<DisassembleWorkOrderApprovalVO> findAllDisassembleWorkOrderApprovals(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getAllDisassembleWorkOrderApprovalsCount

int getAllDisassembleWorkOrderApprovalsCount()
                                             throws java.lang.Exception
Throws:
java.lang.Exception

uploadOrUpdateFTPDWODoc

java.util.Collection<DisassembleWorkOrderDocumentVO> uploadOrUpdateFTPDWODoc(MiscDocAgent agent)
                                                                             throws java.lang.Exception
Throws:
java.lang.Exception

downloadFTPDWODoc

byte[] downloadFTPDWODoc(MiscDocAgent agent)
                         throws java.lang.Exception
Throws:
java.lang.Exception

deleteFTPDWODoc

void deleteFTPDWODoc(MiscDocAgent agent)
                     throws java.lang.Exception
Throws:
java.lang.Exception

findDisassembleWorkOrderDocumentInfo

java.util.Collection<DisassembleWorkOrderDocumentVO> findDisassembleWorkOrderDocumentInfo(java.lang.String disassembleWorkOrderNumber)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getDisassembleWorkOrderDocumentByID

DisassembleWorkOrderDocumentVO getDisassembleWorkOrderDocumentByID(java.lang.Long controlNumber)
                                                                   throws java.lang.Exception
Throws:
java.lang.Exception

deleteDisassembleWorkOrderItemReceiver

void deleteDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemReceiverVO vo)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

deleteDisassembleWorkOrderItemReceiver

void deleteDisassembleWorkOrderItemReceiver(DisassembleWorkOrderItemReceiverPK issuePk)
                                            throws java.lang.Exception
Throws:
java.lang.Exception

deleteDisassembleWorkOrderItemReceivers

void deleteDisassembleWorkOrderItemReceivers(java.util.ArrayList<DisassembleWorkOrderItemReceiverPK> items)
                                             throws java.lang.Exception
Throws:
java.lang.Exception

getDisassembleWorkOrderItemById

DisassembleWorkOrderItemVO getDisassembleWorkOrderItemById(DisassembleWorkOrderItemPK itemPk)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

findOpenDisassembleWorkOrderListResultsByDwoNumber

java.util.Collection<DisassembleWorkOrderItemListResult> findOpenDisassembleWorkOrderListResultsByDwoNumber(java.lang.String dwoNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOpenDisassembleWorkOrderListResultsByDwoNumberCount

int getOpenDisassembleWorkOrderListResultsByDwoNumberCount(java.lang.String dwoNumber)
                                                           throws java.lang.Exception
Throws:
java.lang.Exception

findDisassembleWorkOrderListResultsByPN

java.util.Collection<DisassembleWorkOrderItemListResult> findDisassembleWorkOrderListResultsByPN(java.lang.String pn,
                                                                                java.lang.String pa,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getDisassembleWorkOrderListResultsByPNCount

int getDisassembleWorkOrderListResultsByPNCount(java.lang.String pn,
                                                java.lang.String pa)
                                                throws java.lang.Exception
Throws:
java.lang.Exception

findOpenDisassembleWorkOrderListResultsByVendorId

java.util.Collection<DisassembleWorkOrderItemListResult> findOpenDisassembleWorkOrderListResultsByVendorId(java.lang.String vendorId,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOpenDisassembleWorkOrderListResultsByVendorIdCount

int getOpenDisassembleWorkOrderListResultsByVendorIdCount(java.lang.String vendorId)
                                                          throws java.lang.Exception
Throws:
java.lang.Exception

getCancelledDisassembleWorkOrderListResultsCount

int getCancelledDisassembleWorkOrderListResultsCount()
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

findDisassembleWorkOrderListResultsByDate

java.util.Collection<DisassembleWorkOrderItemListResult> findDisassembleWorkOrderListResultsByDate(java.lang.String dateType,
                                                                                java.util.Date dateFrom,
                                                                                java.util.Date dateTo,
                                                                                java.lang.String partNumber,
                                                                                java.lang.String partType,
                                                                                java.lang.String vendorId,
                                                                                java.lang.String project,
                                                                                java.lang.String creater,
                                                                                java.lang.String docRef,
                                                                                java.lang.String contact,
                                                                                java.lang.String status,
                                                                                boolean isLock,
                                                                                java.lang.String accounting,
                                                                                java.lang.String companyUnit,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findNotCreateGlOfDisassembleWorkOrderItem

java.util.Collection<DisassembleWorkOrderItemListResult> findNotCreateGlOfDisassembleWorkOrderItem(java.lang.String dateType,
                                                                                java.util.Date dateFrom,
                                                                                java.util.Date dateTo,
                                                                                java.lang.String partNumber,
                                                                                java.lang.String partType,
                                                                                java.lang.String vendorId,
                                                                                java.lang.String project,
                                                                                java.lang.String creater,
                                                                                java.lang.String docRef,
                                                                                java.lang.String contact,
                                                                                java.lang.String accounting,
                                                                                java.lang.String companyUnit)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getDisassembleWorkOrderListResultsByDateCount

int getDisassembleWorkOrderListResultsByDateCount(java.lang.String dateType,
                                                  java.util.Date dateFrom,
                                                  java.util.Date dateTo,
                                                  java.lang.String partNumber,
                                                  java.lang.String partType,
                                                  java.lang.String vendorId,
                                                  java.lang.String project,
                                                  java.lang.String creater,
                                                  java.lang.String docRef,
                                                  java.lang.String contact,
                                                  java.lang.String status,
                                                  boolean isLock,
                                                  java.lang.String accounting,
                                                  java.lang.String companyUnit)
                                                  throws java.lang.Exception
Throws:
java.lang.Exception

findCancelledDisassembleWorkOrderListResults

java.util.Collection<DisassembleWorkOrderItemListResult> findCancelledDisassembleWorkOrderListResults(int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

findOpenDisassembleWorkOrderItemListResultsByPartPK

java.util.Collection<DisassembleWorkOrderItemListResult> findOpenDisassembleWorkOrderItemListResultsByPartPK(PartPK partPk,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getOpenDisassembleWorkOrderItemListResultsByPartPkCount

int getOpenDisassembleWorkOrderItemListResultsByPartPkCount(PartPK partPk)
                                                            throws java.lang.Exception
Throws:
java.lang.Exception

findDisassembleWorkOrderListResultsByDwoNumber

java.util.Collection<DisassembleWorkOrderItemListResult> findDisassembleWorkOrderListResultsByDwoNumber(java.lang.String dwoNumber,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getDisassembleWorkOrderListResultsCountByDwoNumber

int getDisassembleWorkOrderListResultsCountByDwoNumber(java.lang.String dwoNumber)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

findDisassembleWorkOrderReceivedDetail

java.util.Collection<PartReceivedVO> findDisassembleWorkOrderReceivedDetail(DisassembleWorkOrderItemPK pk,
                                                                            BB2Part part,
                                                                            java.lang.String description,
                                                                            int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception

getDisassembleWorkOrderReceivedDetail

int getDisassembleWorkOrderReceivedDetail(DisassembleWorkOrderItemPK pk,
                                          BB2Part part,
                                          java.lang.String description)
                                          throws java.lang.Exception
Throws:
java.lang.Exception

getDisassembleWorkOrderReceivedDetailTotal

java.lang.Object[] getDisassembleWorkOrderReceivedDetailTotal(DisassembleWorkOrderItemPK pk,
                                                              BB2Part part,
                                                              java.lang.String description)
                                                              throws java.lang.Exception
Throws:
java.lang.Exception

getDisassembleWorkOrderWithOrderApplyByDwo

DisassembleWorkOrderVO getDisassembleWorkOrderWithOrderApplyByDwo(java.lang.Long orderApplyID)
                                                                  throws java.lang.Exception
Throws:
java.lang.Exception

getDWIPartDetailTotalReceivedCost

java.math.BigDecimal getDWIPartDetailTotalReceivedCost(DisassembleWorkOrderItemPK dwiPk)
                                                       throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderItemMaxReceivableQty

java.math.BigDecimal getWorkOrderItemMaxReceivableQty(WorkOrderItemPK itemPk)
                                                      throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderMaxReceivableQty

java.util.HashMap<WorkOrderItemPK,java.math.BigDecimal> getWorkOrderMaxReceivableQty(java.lang.String workOrderNumber)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

batchDisassembelWorkOrderGLByDwoItem

GeneralLedgerVO batchDisassembelWorkOrderGLByDwoItem(DisassembleWorkOrderItemPK[] pks,
                                                     java.lang.String companyUnitId,
                                                     java.lang.String glSummary)
                                                     throws java.lang.Exception
Throws:
java.lang.Exception

findDisassembleWorkOrderListResultById

java.util.List<DisassembleWorkOrderListResult> findDisassembleWorkOrderListResultById(java.lang.String dwoNumber,
                                                                                java.lang.String[] status,
                                                                                java.lang.String vendorId,
                                                                                int firstIndex,
                                                                                int maxLength)
                                                                                throws java.lang.Exception
Throws:
java.lang.Exception

getDisassembleWorkOrderListResultByIdCount

int getDisassembleWorkOrderListResultByIdCount(java.lang.String dwoNumber,
                                               java.lang.String[] status,
                                               java.lang.String vendorId)
                                               throws java.lang.Exception
Throws:
java.lang.Exception

getWorkOrderItemLaborCostCount

int getWorkOrderItemLaborCostCount(java.util.Date dateFrom,
                                   java.util.Date dateTo,
                                   java.lang.String workOrderNumber,
                                   java.lang.String vendorID,
                                   java.lang.String workCenter)
                                   throws java.lang.Exception
Throws:
java.lang.Exception

findWorkOrderItemLaborCost

java.util.List<WorkOrderItemLaborCostListResult> findWorkOrderItemLaborCost(java.util.Date dateFrom,
                                                                            java.util.Date dateTo,
                                                                            java.lang.String workOrderNumber,
                                                                            java.lang.String vendorID,
                                                                            java.lang.String workCenter,
                                                                            int firstIndex,
                                                                            int maxLength)
                                                                            throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


WorkOrderCheckListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderCheckListResult

java.lang.Object
    extended by  bb.common.WorkOrderCheckListResult
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderCheckListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_WODATE
static java.lang.String | ORDER_BY_WONUMBER
Constructor Summary
WorkOrderCheckListResult()
Method Summary
java.math.BigDecimal | getApTotal()
java.lang.String | getComments()
java.lang.String | getCurrency()
java.util.Date | getDueDate()
java.lang.String | getOriginator()
java.lang.String | getPriority()
java.lang.String | getProject()
java.lang.String | getStatus()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
java.util.Date | getWoDate()
java.lang.String | getWoNumber()
void | setApTotal(java.math.BigDecimal apTotal)
void | setComments(java.lang.String comments)
void | setCurrency(java.lang.String currency)
void | setDueDate(java.util.Date dueDate)
void | setOriginator(java.lang.String originator)
void | setPriority(java.lang.String priority)
void | setProject(java.lang.String project)
void | setStatus(java.lang.String status)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
void | setWoDate(java.util.Date woDate)
void | setWoNumber(java.lang.String woNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_WONUMBER

public static final java.lang.String ORDER_BY_WONUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_WODATE

public static final java.lang.String ORDER_BY_WODATE
See Also:
Constant Field Values
Constructor Detail

WorkOrderCheckListResult

public WorkOrderCheckListResult()
Method Detail

getWoNumber

public java.lang.String getWoNumber()

getVendorId

public java.lang.String getVendorId()

getOriginator

public java.lang.String getOriginator()

getWoDate

public java.util.Date getWoDate()

getDueDate

public java.util.Date getDueDate()

getStatus

public java.lang.String getStatus()

getApTotal

public java.math.BigDecimal getApTotal()

getCurrency

public java.lang.String getCurrency()

getVendorName

public java.lang.String getVendorName()

getProject

public java.lang.String getProject()

getComments

public java.lang.String getComments()

getPriority

public java.lang.String getPriority()

setWoNumber

public void setWoNumber(java.lang.String woNumber)

setVendorId

public void setVendorId(java.lang.String vendorId)

setOriginator

public void setOriginator(java.lang.String originator)

setWoDate

public void setWoDate(java.util.Date woDate)

setDueDate

public void setDueDate(java.util.Date dueDate)

setStatus

public void setStatus(java.lang.String status)

setApTotal

public void setApTotal(java.math.BigDecimal apTotal)

setCurrency

public void setCurrency(java.lang.String currency)

setVendorName

public void setVendorName(java.lang.String vendorName)

setProject

public void setProject(java.lang.String project)

setComments

public void setComments(java.lang.String comments)

setPriority

public void setPriority(java.lang.String priority)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderDocumentVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderDocumentVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.WorkOrderDocumentVO
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderDocumentVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
WorkOrderDocumentVO()
Method Summary
java.lang.String | getComments()
java.lang.String | getDocDescription()
java.lang.String | getDocFileName()
long | getDocLength()
java.util.Date | getDocumentDate()
java.lang.String | getExtension()
java.lang.Long | getIi()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getWoNumber()
void | setComments(java.lang.String comments)
void | setDocDescription(java.lang.String docDescription)
void | setDocFileName(java.lang.String docFileName)
void | setDocLength(long docLength)
void | setDocumentDate(java.util.Date documentDate)
void | setExtension(java.lang.String extension)
void | setIi(java.lang.Long ii)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setWoNumber(java.lang.String woNumber)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkOrderDocumentVO

public WorkOrderDocumentVO()
Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getWoNumber

public java.lang.String getWoNumber()

setWoNumber

public void setWoNumber(java.lang.String woNumber)

getDocDescription

public java.lang.String getDocDescription()

setDocDescription

public void setDocDescription(java.lang.String docDescription)

getDocumentDate

public java.util.Date getDocumentDate()

setDocumentDate

public void setDocumentDate(java.util.Date documentDate)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getExtension

public java.lang.String getExtension()

setExtension

public void setExtension(java.lang.String extension)

getDocFileName

public java.lang.String getDocFileName()

setDocFileName

public void setDocFileName(java.lang.String docFileName)

getDocLength

public long getDocLength()

setDocLength

public void setDocLength(long docLength)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderInfoCenterResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderInfoCenterResult

java.lang.Object
    extended by  bb.common.WorkOrderInfoCenterResult
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderInfoCenterResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkOrderInfoCenterResult()
Method Summary
java.math.BigDecimal | getOpenWOAccount()
java.lang.Integer | getOpenWOCount()
java.math.BigDecimal | getPastDueWOAccount()
java.lang.Integer | getPastDueWOCount()
java.lang.Integer | getWithPartHoldWOCount()
void | setOpenWOAccount(java.math.BigDecimal openWOAccount)
void | setOpenWOCount(java.lang.Integer openWOCount)
void | setPastDueWOAccount(java.math.BigDecimal pastDueWOAccount)
void | setPastDueWOCount(java.lang.Integer pastDueWOCount)
void | setWithPartHoldWOCount(java.lang.Integer withPartHoldWOCount)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkOrderInfoCenterResult

public WorkOrderInfoCenterResult()
Method Detail

getOpenWOAccount

public java.math.BigDecimal getOpenWOAccount()

setOpenWOAccount

public void setOpenWOAccount(java.math.BigDecimal openWOAccount)

getOpenWOCount

public java.lang.Integer getOpenWOCount()

setOpenWOCount

public void setOpenWOCount(java.lang.Integer openWOCount)

getPastDueWOAccount

public java.math.BigDecimal getPastDueWOAccount()

setPastDueWOAccount

public void setPastDueWOAccount(java.math.BigDecimal pastDueWOAccount)

getPastDueWOCount

public java.lang.Integer getPastDueWOCount()

setPastDueWOCount

public void setPastDueWOCount(java.lang.Integer pastDueWOCount)

getWithPartHoldWOCount

public java.lang.Integer getWithPartHoldWOCount()

setWithPartHoldWOCount

public void setWithPartHoldWOCount(java.lang.Integer withPartHoldWOCount)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderInWipResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderInWipResult

java.lang.Object
    extended by  bb.common.WorkOrderInWipResult
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderInWipResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkOrderInWipResult()
Method Summary
int | getDelayDays()
java.util.Date | getDeliveryDate()
java.lang.String | getId()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.math.BigDecimal | getQuantityDemanded()
java.math.BigDecimal | getQuantityInWip()
java.math.BigDecimal | getQuantityIssued()
java.math.BigDecimal | getWoiQty()
java.math.BigDecimal | getWoiQtyAsm()
WorkOrderItemPK | getWorkOrderItemPk()
void | setDelayDays(int delayDays)
void | setDeliveryDate(java.util.Date deliveryDate)
void | setId(java.lang.String id)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setQuantityDemanded(java.math.BigDecimal quantityDemanded)
void | setQuantityInWip(java.math.BigDecimal quantityInWip)
void | setQuantityIssued(java.math.BigDecimal quantityIssued)
void | setWoiQty(java.math.BigDecimal woiQty)
void | setWoiQtyAsm(java.math.BigDecimal woiQtyAsm)
void | setWorkOrderItemPk(WorkOrderItemPK workOrderItemPk)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkOrderInWipResult

public WorkOrderInWipResult()
Method Detail

getPartPk

public PartPK getPartPk()

setPartPk

public void setPartPk(PartPK partPk)

getWorkOrderItemPk

public WorkOrderItemPK getWorkOrderItemPk()

setWorkOrderItemPk

public void setWorkOrderItemPk(WorkOrderItemPK workOrderItemPk)

getQuantityDemanded

public java.math.BigDecimal getQuantityDemanded()

setQuantityDemanded

public void setQuantityDemanded(java.math.BigDecimal quantityDemanded)

getQuantityIssued

public java.math.BigDecimal getQuantityIssued()

setQuantityIssued

public void setQuantityIssued(java.math.BigDecimal quantityIssued)

getQuantityInWip

public java.math.BigDecimal getQuantityInWip()

setQuantityInWip

public void setQuantityInWip(java.math.BigDecimal quantityInWip)

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getDeliveryDate

public java.util.Date getDeliveryDate()

setDeliveryDate

public void setDeliveryDate(java.util.Date deliveryDate)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getDelayDays

public int getDelayDays()

setDelayDays

public void setDelayDays(int delayDays)

getWoiQty

public java.math.BigDecimal getWoiQty()

setWoiQty

public void setWoiQty(java.math.BigDecimal woiQty)

getWoiQtyAsm

public java.math.BigDecimal getWoiQtyAsm()

setWoiQtyAsm

public void setWoiQtyAsm(java.math.BigDecimal woiQtyAsm)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderIssuedOrderListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderIssuedOrderListResult

java.lang.Object
    extended by  bb.common.WorkOrderIssuedOrderListResult
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderIssuedOrderListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkOrderIssuedOrderListResult()
Method Summary
java.util.Date | getDateIssued()
java.lang.String | getOperator()
java.lang.String | getOrderNumber()
java.math.BigDecimal | getTotalIssuedCost()
java.lang.String | getWorkOrderItemNumber()
java.lang.String | getWorkOrderNumber()
void | setDateIssued(java.util.Date dateIssued)
void | setOperator(java.lang.String operator)
void | setOrderNumber(java.lang.String orderNumber)
void | setTotalIssuedCost(java.math.BigDecimal totalIssuedCost)
void | setWorkOrderItemNumber(java.lang.String workOrderItemNumber)
void | setWorkOrderNumber(java.lang.String workOrderNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkOrderIssuedOrderListResult

public WorkOrderIssuedOrderListResult()
Method Detail

getDateIssued

public java.util.Date getDateIssued()

setDateIssued

public void setDateIssued(java.util.Date dateIssued)

getOperator

public java.lang.String getOperator()

setOperator

public void setOperator(java.lang.String operator)

getOrderNumber

public java.lang.String getOrderNumber()

setOrderNumber

public void setOrderNumber(java.lang.String orderNumber)

getTotalIssuedCost

public java.math.BigDecimal getTotalIssuedCost()

setTotalIssuedCost

public void setTotalIssuedCost(java.math.BigDecimal totalIssuedCost)

getWorkOrderItemNumber

public java.lang.String getWorkOrderItemNumber()

setWorkOrderItemNumber

public void setWorkOrderItemNumber(java.lang.String workOrderItemNumber)

getWorkOrderNumber

public java.lang.String getWorkOrderNumber()

setWorkOrderNumber

public void setWorkOrderNumber(java.lang.String workOrderNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderIssueStatisticsResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderIssueStatisticsResult

java.lang.Object
    extended by  bb.common.WorkOrderIssueStatisticsResult
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderIssueStatisticsResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkOrderIssueStatisticsResult()
Method Summary
java.lang.String | getDescription()
java.util.HashMap | getMap()
java.math.BigDecimal | getMaterialShare()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getProject()
java.math.BigDecimal | getSubTotal()
java.math.BigDecimal | getTotalIssue()
void | setDescription(java.lang.String description)
void | setMap(java.util.HashMap map)
void | setMaterialShare(java.math.BigDecimal materialShare)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setProject(java.lang.String project)
void | setSubTotal(java.math.BigDecimal subTotal)
void | setTotalIssue(java.math.BigDecimal totalIssue)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkOrderIssueStatisticsResult

public WorkOrderIssueStatisticsResult()
Method Detail

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

getTotalIssue

public java.math.BigDecimal getTotalIssue()

setTotalIssue

public void setTotalIssue(java.math.BigDecimal totalIssue)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getMap

public java.util.HashMap getMap()

setMap

public void setMap(java.util.HashMap map)

getMaterialShare

public java.math.BigDecimal getMaterialShare()

setMaterialShare

public void setMaterialShare(java.math.BigDecimal materialShare)

getSubTotal

public java.math.BigDecimal getSubTotal()

setSubTotal

public void setSubTotal(java.math.BigDecimal subTotal)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderItemAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderItemAgent

java.lang.Object
    extended by  bb.common.WorkOrderItemAgent
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderItemAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkOrderItemAgent()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.math.BigDecimal | getQty()
int | hashCode()
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setQty(java.math.BigDecimal qty)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WorkOrderItemAgent

public WorkOrderItemAgent()
Method Detail

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartPk

public PartPK getPartPk()

setPartPk

public void setPartPk(PartPK partPk)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderItemCanAssyAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderItemCanAssyAgent

java.lang.Object
    extended by  bb.common.WorkOrderItemCanAssyAgent
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderItemCanAssyAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkOrderItemCanAssyAgent()
Method Summary
java.lang.String | getPartNumber()
java.util.Date | getToDate()
java.lang.String | getVendorID()
java.lang.String | getWoNumber()
boolean | isByOnHand()
void | setByOnHand(boolean byOnHand)
void | setPartNumber(java.lang.String partNumber)
void | setToDate(java.util.Date toDate)
void | setVendorID(java.lang.String vendorID)
void | setWoNumber(java.lang.String woNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkOrderItemCanAssyAgent

public WorkOrderItemCanAssyAgent()
Method Detail

isByOnHand

public boolean isByOnHand()

setByOnHand

public void setByOnHand(boolean byOnHand)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getToDate

public java.util.Date getToDate()

setToDate

public void setToDate(java.util.Date toDate)

getVendorID

public java.lang.String getVendorID()

setVendorID

public void setVendorID(java.lang.String vendorID)

getWoNumber

public java.lang.String getWoNumber()

setWoNumber

public void setWoNumber(java.lang.String woNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderItemCanAssyResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderItemCanAssyResult

java.lang.Object
    extended by  bb.common.WorkOrderItemCanAssyResult
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderItemCanAssyResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DATEREQUIRED
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PK
static java.lang.String | ORDER_BY_STARTDATE
Constructor Summary
WorkOrderItemCanAssyResult()
Method Summary
java.math.BigDecimal | getAsm()
java.math.BigDecimal | getAvialQty()
java.util.Date | getDateRequired()
java.lang.String | getDescription()
java.math.BigDecimal | getMaxAssyQty()
java.lang.String | getMfgStatus()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
WorkOrderItemPK | getPk()
java.math.BigDecimal | getQty()
java.lang.String | getRev()
java.math.BigDecimal | getShortQty()
java.util.Date | getStartDate()
void | setAsm(java.math.BigDecimal asm)
void | setAvialQty(java.math.BigDecimal avialQty)
void | setDateRequired(java.util.Date dateRequired)
void | setDescription(java.lang.String description)
void | setMaxAssyQty(java.math.BigDecimal maxAssyQty)
void | setMfgStatus(java.lang.String mfgStatus)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(WorkOrderItemPK pk)
void | setQty(java.math.BigDecimal qty)
void | setRev(java.lang.String rev)
void | setStartDate(java.util.Date startDate)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PK

public static final java.lang.String ORDER_BY_PK
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_STARTDATE

public static final java.lang.String ORDER_BY_STARTDATE
See Also:
Constant Field Values

ORDER_BY_DATEREQUIRED

public static final java.lang.String ORDER_BY_DATEREQUIRED
See Also:
Constant Field Values
Constructor Detail

WorkOrderItemCanAssyResult

public WorkOrderItemCanAssyResult()
Method Detail

getMaxAssyQty

public java.math.BigDecimal getMaxAssyQty()

setMaxAssyQty

public void setMaxAssyQty(java.math.BigDecimal maxAssyQty)

getAsm

public java.math.BigDecimal getAsm()

setAsm

public void setAsm(java.math.BigDecimal asm)

getAvialQty

public java.math.BigDecimal getAvialQty()

setAvialQty

public void setAvialQty(java.math.BigDecimal avialQty)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPk

public WorkOrderItemPK getPk()

setPk

public void setPk(WorkOrderItemPK pk)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

getRev

public java.lang.String getRev()

setRev

public void setRev(java.lang.String rev)

getMfgStatus

public java.lang.String getMfgStatus()

setMfgStatus

public void setMfgStatus(java.lang.String mfgStatus)

getDateRequired

public java.util.Date getDateRequired()

setDateRequired

public void setDateRequired(java.util.Date dateRequired)

getStartDate

public java.util.Date getStartDate()

setStartDate

public void setStartDate(java.util.Date startDate)

getShortQty

public java.math.BigDecimal getShortQty()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderItemInfoResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderItemInfoResult

java.lang.Object
    extended by  bb.common.WorkOrderItemInfoResult
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderItemInfoResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_QUANTITY
static java.lang.String | ORDER_BY_RELATEDDOC
static java.lang.String | ORDER_BY_WORKORDERITEMNUMBER
static java.lang.String | ORDER_BY_WORKORDERNUMBER
Constructor Summary
WorkOrderItemInfoResult()
Method Summary
java.lang.String | getDescription()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getQuantityAsm()
java.lang.String | getRelatedDoc()
java.lang.String | getWorkOrderItemNumber()
java.lang.String | getWorkOrderNumber()
boolean | isMasterWorkOrder()
void | setDescription(java.lang.String description)
void | setMasterWorkOrder(boolean masterWorkOrder)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setQuantity(java.math.BigDecimal quantity)
void | setQuantityAsm(java.math.BigDecimal quantityAsm)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setWorkOrderItemNumber(java.lang.String workOrderItemNumber)
void | setWorkOrderNumber(java.lang.String workOrderNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_WORKORDERNUMBER

public static final java.lang.String ORDER_BY_WORKORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_WORKORDERITEMNUMBER

public static final java.lang.String ORDER_BY_WORKORDERITEMNUMBER
See Also:
Constant Field Values

ORDER_BY_RELATEDDOC

public static final java.lang.String ORDER_BY_RELATEDDOC
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_QUANTITY

public static final java.lang.String ORDER_BY_QUANTITY
See Also:
Constant Field Values
Constructor Detail

WorkOrderItemInfoResult

public WorkOrderItemInfoResult()
Method Detail

isMasterWorkOrder

public boolean isMasterWorkOrder()

setMasterWorkOrder

public void setMasterWorkOrder(boolean masterWorkOrder)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getWorkOrderItemNumber

public java.lang.String getWorkOrderItemNumber()

setWorkOrderItemNumber

public void setWorkOrderItemNumber(java.lang.String workOrderItemNumber)

getWorkOrderNumber

public java.lang.String getWorkOrderNumber()

setWorkOrderNumber

public void setWorkOrderNumber(java.lang.String workOrderNumber)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getQuantityAsm

public java.math.BigDecimal getQuantityAsm()

setQuantityAsm

public void setQuantityAsm(java.math.BigDecimal quantityAsm)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderItemInWipListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderItemInWipListResult

java.lang.Object
    extended by  bb.common.WorkOrderItemInWipListResult
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderItemInWipListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_AVGCOST
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_DATEISSUE
static java.lang.String | ORDER_BY_ISSUEAVGCOST
static java.lang.String | ORDER_BY_MFGSTATUS
static java.lang.String | ORDER_BY_ORIGINATOR
static java.lang.String | ORDER_BY_PARTDESC
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_RELATEDDOC
static java.lang.String | ORDER_BY_STDCOST
static java.lang.String | ORDER_BY_WORKORDERNUMBER
Constructor Summary
WorkOrderItemInWipListResult()
Method Summary
java.math.BigDecimal | getAvgCost()
java.math.BigDecimal | getAvgTotalAmount()
java.lang.String | getCurrency()
java.util.Date | getDateIssue()
java.math.BigDecimal | getIssueAvgCost()
java.math.BigDecimal | getIssuedQty()
java.lang.Short | getItemNumber()
java.lang.String | getMfgStatus()
java.lang.String | getOriginator()
java.lang.String | getPartDesc()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getQty()
java.lang.String | getRelatedDoc()
java.math.BigDecimal | getStdCost()
java.math.BigDecimal | getStdTotalAmount()
java.lang.String | getWorkOrderItemNumber()
java.lang.String | getWorkOrderNumber()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setAvgTotalAmount(java.math.BigDecimal avgTotalAmount)
void | setCurrency(java.lang.String currency)
void | setDateIssue(java.util.Date dateIssue)
void | setIssueAvgCost(java.math.BigDecimal issueAvgCost)
void | setIssuedQty(java.math.BigDecimal issuedQty)
void | setItemNumber(java.lang.Short itemNumber)
void | setMfgStatus(java.lang.String mfgStatus)
void | setOriginator(java.lang.String originator)
void | setPartDesc(java.lang.String partDesc)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setQty(java.math.BigDecimal qty)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setStdCost(java.math.BigDecimal stdCost)
void | setStdTotalAmount(java.math.BigDecimal stdTotalAmount)
void | setWorkOrderItemNumber(java.lang.String workOrderItemNumber)
void | setWorkOrderNumber(java.lang.String workOrderNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_WORKORDERNUMBER

public static final java.lang.String ORDER_BY_WORKORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_RELATEDDOC

public static final java.lang.String ORDER_BY_RELATEDDOC
See Also:
Constant Field Values

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_PARTDESC

public static final java.lang.String ORDER_BY_PARTDESC
See Also:
Constant Field Values

ORDER_BY_ORIGINATOR

public static final java.lang.String ORDER_BY_ORIGINATOR
See Also:
Constant Field Values

ORDER_BY_MFGSTATUS

public static final java.lang.String ORDER_BY_MFGSTATUS
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values

ORDER_BY_AVGCOST

public static final java.lang.String ORDER_BY_AVGCOST
See Also:
Constant Field Values

ORDER_BY_STDCOST

public static final java.lang.String ORDER_BY_STDCOST
See Also:
Constant Field Values

ORDER_BY_ISSUEAVGCOST

public static final java.lang.String ORDER_BY_ISSUEAVGCOST
See Also:
Constant Field Values

ORDER_BY_DATEISSUE

public static final java.lang.String ORDER_BY_DATEISSUE
See Also:
Constant Field Values
Constructor Detail

WorkOrderItemInWipListResult

public WorkOrderItemInWipListResult()
Method Detail

getAvgTotalAmount

public java.math.BigDecimal getAvgTotalAmount()

setAvgTotalAmount

public void setAvgTotalAmount(java.math.BigDecimal avgTotalAmount)

getStdTotalAmount

public java.math.BigDecimal getStdTotalAmount()

setStdTotalAmount

public void setStdTotalAmount(java.math.BigDecimal stdTotalAmount)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getMfgStatus

public java.lang.String getMfgStatus()

setMfgStatus

public void setMfgStatus(java.lang.String mfgStatus)

getOriginator

public java.lang.String getOriginator()

setOriginator

public void setOriginator(java.lang.String originator)

getPartDesc

public java.lang.String getPartDesc()

setPartDesc

public void setPartDesc(java.lang.String partDesc)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getWorkOrderItemNumber

public java.lang.String getWorkOrderItemNumber()

setWorkOrderItemNumber

public void setWorkOrderItemNumber(java.lang.String workOrderItemNumber)

getWorkOrderNumber

public java.lang.String getWorkOrderNumber()

setWorkOrderNumber

public void setWorkOrderNumber(java.lang.String workOrderNumber)

getAvgCost

public java.math.BigDecimal getAvgCost()

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

getIssueAvgCost

public java.math.BigDecimal getIssueAvgCost()

setIssueAvgCost

public void setIssueAvgCost(java.math.BigDecimal issueAvgCost)

getIssuedQty

public java.math.BigDecimal getIssuedQty()

setIssuedQty

public void setIssuedQty(java.math.BigDecimal issuedQty)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getDateIssue

public java.util.Date getDateIssue()

setDateIssue

public void setDateIssue(java.util.Date dateIssue)

getItemNumber

public java.lang.Short getItemNumber()

setItemNumber

public void setItemNumber(java.lang.Short itemNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderItemIssuedTotalResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderItemIssuedTotalResult

java.lang.Object
    extended by  bb.common.WorkOrderItemIssuedTotalResult
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderItemIssuedTotalResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_MODELNUMBER
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_RELATEDDOC
static java.lang.String | ORDER_BY_WORKORDERITEMNUMBER
static java.lang.String | ORDER_BY_WORKORDERNUMBER
Constructor Summary
WorkOrderItemIssuedTotalResult()
Method Summary
java.math.BigDecimal | getCost()
java.lang.String | getDescription()
java.math.BigDecimal | getIssuedTotal()
java.math.BigDecimal | getIssueQuantity()
java.lang.String | getModelNumber()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getQuantity()
java.lang.String | getRelatedDoc()
int | getSequence()
java.lang.String | getUnit()
java.lang.String | getWorkOrderItemComments()
java.lang.String | getWorkOrderItemNumber()
java.lang.String | getWorkOrderNumber()
void | setCost(java.math.BigDecimal cost)
void | setDescription(java.lang.String description)
void | setIssuedTotal(java.math.BigDecimal issuedTotal)
void | setIssueQuantity(java.math.BigDecimal issueQuantity)
void | setModelNumber(java.lang.String modelNumber)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setQuantity(java.math.BigDecimal quantity)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setSequence(int sequence)
void | setUnit(java.lang.String unit)
void | setWorkOrderItemComments(java.lang.String workOrderItemComments)
void | setWorkOrderItemNumber(java.lang.String workOrderItemNumber)
void | setWorkOrderNumber(java.lang.String workOrderNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_RELATEDDOC

public static final java.lang.String ORDER_BY_RELATEDDOC
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_MODELNUMBER

public static final java.lang.String ORDER_BY_MODELNUMBER
See Also:
Constant Field Values

ORDER_BY_WORKORDERNUMBER

public static final java.lang.String ORDER_BY_WORKORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_WORKORDERITEMNUMBER

public static final java.lang.String ORDER_BY_WORKORDERITEMNUMBER
See Also:
Constant Field Values
Constructor Detail

WorkOrderItemIssuedTotalResult

public WorkOrderItemIssuedTotalResult()
Method Detail

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getWorkOrderNumber

public java.lang.String getWorkOrderNumber()

setWorkOrderNumber

public void setWorkOrderNumber(java.lang.String workOrderNumber)

getWorkOrderItemNumber

public java.lang.String getWorkOrderItemNumber()

setWorkOrderItemNumber

public void setWorkOrderItemNumber(java.lang.String workOrderItemNumber)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getCost

public java.math.BigDecimal getCost()

setCost

public void setCost(java.math.BigDecimal cost)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getIssueQuantity

public java.math.BigDecimal getIssueQuantity()

setIssueQuantity

public void setIssueQuantity(java.math.BigDecimal issueQuantity)

getIssuedTotal

public java.math.BigDecimal getIssuedTotal()

setIssuedTotal

public void setIssuedTotal(java.math.BigDecimal issuedTotal)

getWorkOrderItemComments

public java.lang.String getWorkOrderItemComments()

setWorkOrderItemComments

public void setWorkOrderItemComments(java.lang.String workOrderItemComments)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getSequence

public int getSequence()

setSequence

public void setSequence(int sequence)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderItemIssuePK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderItemIssuePK

java.lang.Object
    extended by  bb.common.WorkOrderItemIssuePK
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderItemIssuePK
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkOrderItemIssuePK()
Method Summary
boolean | equals(java.lang.Object obj)
java.lang.Short | getItemNumber()
java.lang.String | getWorkOrderItemNumber()
java.lang.String | getWorkOrderNumber()
int | hashCode()
void | setItemNumber(java.lang.Short itemNumber)
void | setWorkOrderItemNumber(java.lang.String workOrderItemNumber)
void | setWorkOrderNumber(java.lang.String workOrderNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WorkOrderItemIssuePK

public WorkOrderItemIssuePK()
Method Detail

getWorkOrderNumber

public java.lang.String getWorkOrderNumber()

setWorkOrderNumber

public void setWorkOrderNumber(java.lang.String workOrderNumber)

getWorkOrderItemNumber

public java.lang.String getWorkOrderItemNumber()

setWorkOrderItemNumber

public void setWorkOrderItemNumber(java.lang.String workOrderItemNumber)

setItemNumber

public void setItemNumber(java.lang.Short itemNumber)

getItemNumber

public java.lang.Short getItemNumber()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object obj)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderItemIssueVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderItemIssueVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.WorkOrderItemIssueVO
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderItemIssueVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkOrderItemIssueVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getBc()
byte | getBnIi()
java.lang.String | getBomColor()
java.lang.String | getBomItemNumber()
java.math.BigDecimal | getBomItemQty()
int | getBomLastChangeTimes()
byte | getBomLevel()
java.lang.String | getBomNumber()
java.math.BigDecimal | getBomScrapQty()
java.lang.String | getComments()
java.math.BigDecimal | getCost()
java.util.Date | getDateIssued()
java.lang.String | getDescription()
java.math.BigDecimal | getInWip()
java.math.BigDecimal | getIssueQuantity()
java.util.Date | getLastDate()
java.lang.String | getLot()
java.lang.String | getMfg()
java.lang.String | getModelNumber()
java.lang.String | getMpn()
java.math.BigDecimal | getPartAvgCost()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
WorkOrderItemIssuePK | getPk()
java.math.BigDecimal | getQuantity()
java.lang.String | getReferenceDoc1()
java.lang.String | getReplacedItem()
java.lang.String | getRevision()
java.math.BigDecimal | getScrapQty()
java.lang.String | getSerial()
java.lang.String | getUnit()
int | hashCode()
void | setBc(java.lang.String bc)
void | setBnIi(byte bnIi)
void | setBomColor(java.lang.String bomColor)
void | setBomItemNumber(java.lang.String bomItemNumber)
void | setBomItemQty(java.math.BigDecimal bomItemQty)
void | setBomLastChangeTimes(int bomLastChangeTimes)
void | setBomLevel(byte bomLevel)
void | setBomNumber(java.lang.String bomNumber)
void | setBomScrapQty(java.math.BigDecimal bomScrapQty)
void | setComments(java.lang.String comments)
void | setCost(java.math.BigDecimal cost)
void | setDateIssued(java.util.Date dateIssued)
void | setDescription(java.lang.String description)
void | setInWip(java.math.BigDecimal inWip)
void | setIssueQuantity(java.math.BigDecimal issueQuantity)
void | setLastDate(java.util.Date lastDate)
void | setLot(java.lang.String lot)
void | setMfg(java.lang.String mfg)
void | setModelNumber(java.lang.String modelNumber)
void | setMpn(java.lang.String mpn)
void | setPartAvgCost(java.math.BigDecimal partAvgCost)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(WorkOrderItemIssuePK pk)
void | setQuantity(java.math.BigDecimal quantity)
void | setReferenceDoc1(java.lang.String referenceDoc1)
void | setReplacedItem(java.lang.String replacedItem)
void | setRevision(java.lang.String revision)
void | setScrapQty(java.math.BigDecimal scrapQty)
void | setSerial(java.lang.String serial)
void | setUnit(java.lang.String unit)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WorkOrderItemIssueVO

public WorkOrderItemIssueVO()
Method Detail

getPk

public WorkOrderItemIssuePK getPk()

setPk

public void setPk(WorkOrderItemIssuePK pk)

getReferenceDoc1

public java.lang.String getReferenceDoc1()

setReferenceDoc1

public void setReferenceDoc1(java.lang.String referenceDoc1)

getBomLastChangeTimes

public int getBomLastChangeTimes()

setBomLastChangeTimes

public void setBomLastChangeTimes(int bomLastChangeTimes)

getBomColor

public java.lang.String getBomColor()

setBomColor

public void setBomColor(java.lang.String bomColor)

getBomLevel

public byte getBomLevel()

setBomLevel

public void setBomLevel(byte bomLevel)

getBomNumber

public java.lang.String getBomNumber()

setBomNumber

public void setBomNumber(java.lang.String bomNumber)

getBnIi

public byte getBnIi()

setBnIi

public void setBnIi(byte bnIi)

getBomItemQty

public java.math.BigDecimal getBomItemQty()

setBomItemQty

public void setBomItemQty(java.math.BigDecimal bomItemQty)

getBomItemNumber

public java.lang.String getBomItemNumber()

setBomItemNumber

public void setBomItemNumber(java.lang.String bomItemNumber)

getBc

public java.lang.String getBc()

setBc

public void setBc(java.lang.String bc)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getIssueQuantity

public java.math.BigDecimal getIssueQuantity()

setIssueQuantity

public void setIssueQuantity(java.math.BigDecimal issueQuantity)

getDateIssued

public java.util.Date getDateIssued()

setDateIssued

public void setDateIssued(java.util.Date dateIssued)

getCost

public java.math.BigDecimal getCost()

setCost

public void setCost(java.math.BigDecimal cost)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getSerial

public java.lang.String getSerial()

setSerial

public void setSerial(java.lang.String serial)

getLot

public java.lang.String getLot()

setLot

public void setLot(java.lang.String lot)

getReplacedItem

public java.lang.String getReplacedItem()

setReplacedItem

public void setReplacedItem(java.lang.String replacedItem)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getInWip

public java.math.BigDecimal getInWip()

setInWip

public void setInWip(java.math.BigDecimal inWip)

getPartAvgCost

public java.math.BigDecimal getPartAvgCost()

setPartAvgCost

public void setPartAvgCost(java.math.BigDecimal partAvgCost)

getLastDate

public java.util.Date getLastDate()

setLastDate

public void setLastDate(java.util.Date lastDate)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getScrapQty

public java.math.BigDecimal getScrapQty()

setScrapQty

public void setScrapQty(java.math.BigDecimal scrapQty)

getBomScrapQty

public java.math.BigDecimal getBomScrapQty()

setBomScrapQty

public void setBomScrapQty(java.math.BigDecimal bomScrapQty)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderItemLaborCostListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderItemLaborCostListResult

java.lang.Object
    extended by  bb.common.WorkOrderItemLaborCostListResult
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderItemLaborCostListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_ENTERED
static java.lang.String | ORDER_BY_ITEMCOMMENTS
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_WORKCENTERID
static java.lang.String | ORDER_BY_WORKORDERITEMNUMBER
static java.lang.String | ORDER_BY_WORKORDERNUMBER
Constructor Summary
WorkOrderItemLaborCostListResult()
Method Summary
java.lang.String | getDescription()
java.util.Date | getEntered()
java.lang.String | getItemComments()
java.math.BigDecimal | getMachineCost()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getTotalMfgTime()
java.lang.String | getVendorId()
java.lang.String | getWorkCenterId()
java.math.BigDecimal | getWorkerCost()
java.lang.String | getWorkOrderItemNumber()
java.lang.String | getWorkOrderNumber()
void | setDescription(java.lang.String description)
void | setEntered(java.util.Date entered)
void | setItemComments(java.lang.String itemComments)
void | setMachineCost(java.math.BigDecimal machineCost)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setTotalMfgTime(java.math.BigDecimal totalMfgTime)
void | setVendorId(java.lang.String vendorId)
void | setWorkCenterId(java.lang.String workCenterId)
void | setWorkerCost(java.math.BigDecimal workerCost)
void | setWorkOrderItemNumber(java.lang.String workOrderItemNumber)
void | setWorkOrderNumber(java.lang.String workOrderNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_WORKORDERITEMNUMBER

public static java.lang.String ORDER_BY_WORKORDERITEMNUMBER

ORDER_BY_WORKORDERNUMBER

public static java.lang.String ORDER_BY_WORKORDERNUMBER

ORDER_BY_ENTERED

public static java.lang.String ORDER_BY_ENTERED

ORDER_BY_VENDORID

public static java.lang.String ORDER_BY_VENDORID

ORDER_BY_PARTNUMBER

public static java.lang.String ORDER_BY_PARTNUMBER

ORDER_BY_PARTTYPE

public static java.lang.String ORDER_BY_PARTTYPE

ORDER_BY_DESCRIPTION

public static java.lang.String ORDER_BY_DESCRIPTION

ORDER_BY_WORKCENTERID

public static java.lang.String ORDER_BY_WORKCENTERID

ORDER_BY_ITEMCOMMENTS

public static java.lang.String ORDER_BY_ITEMCOMMENTS
Constructor Detail

WorkOrderItemLaborCostListResult

public WorkOrderItemLaborCostListResult()
Method Detail

getWorkOrderNumber

public java.lang.String getWorkOrderNumber()

setWorkOrderNumber

public void setWorkOrderNumber(java.lang.String workOrderNumber)

getWorkOrderItemNumber

public java.lang.String getWorkOrderItemNumber()

setWorkOrderItemNumber

public void setWorkOrderItemNumber(java.lang.String workOrderItemNumber)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getEntered

public java.util.Date getEntered()

setEntered

public void setEntered(java.util.Date entered)

getWorkerCost

public java.math.BigDecimal getWorkerCost()

setWorkerCost

public void setWorkerCost(java.math.BigDecimal workerCost)

getMachineCost

public java.math.BigDecimal getMachineCost()

setMachineCost

public void setMachineCost(java.math.BigDecimal machineCost)

getWorkCenterId

public java.lang.String getWorkCenterId()

setWorkCenterId

public void setWorkCenterId(java.lang.String workCenterId)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getItemComments

public java.lang.String getItemComments()

setItemComments

public void setItemComments(java.lang.String itemComments)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getTotalMfgTime

public java.math.BigDecimal getTotalMfgTime()

setTotalMfgTime

public void setTotalMfgTime(java.math.BigDecimal totalMfgTime)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderItemListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderItemListResult

java.lang.Object
    extended by  bb.common.WorkOrderItemListResult
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderItemListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACCOUNTNUMBER
static java.lang.String | ORDER_BY_ASM
static java.lang.String | ORDER_BY_COMPANYUNITID
static java.lang.String | ORDER_BY_COMPLETEDDATE
static java.lang.String | ORDER_BY_COSTPERUNIT
static java.lang.String | ORDER_BY_CURRENCY
static java.lang.String | ORDER_BY_DUEDATE
static java.lang.String | ORDER_BY_EXTENDPRICE
static java.lang.String | ORDER_BY_MFGSTATUS
static java.lang.String | ORDER_BY_ORDERRELATEDDOC
static java.lang.String | ORDER_BY_ORIGINATOR
static java.lang.String | ORDER_BY_PARTDESC
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_PRIORITY
static java.lang.String | ORDER_BY_PROJECT
static java.lang.String | ORDER_BY_QTY
static java.lang.String | ORDER_BY_RELATEDDOC
static java.lang.String | ORDER_BY_STARTDATE
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_STDCOST
static java.lang.String | ORDER_BY_TOBEASM
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_WORKORDERITEMNUMBER
static java.lang.String | ORDER_BY_WORKORDERNUMBER
Constructor Summary
WorkOrderItemListResult()
Method Summary
java.lang.String | getAccountNumber()
java.math.BigDecimal | getAsm()
java.math.BigDecimal | getCanAsm()
java.lang.String | getComments()
java.lang.String | getCompanyUnitId()
java.util.Date | getCompletedDate()
java.math.BigDecimal | getCostPerUnit()
java.lang.String | getCurrency()
java.util.Date | getDueDate()
java.math.BigDecimal | getExtendPrice()
java.math.BigDecimal | getInWIPQty()
java.lang.String | getMfgStatus()
java.math.BigDecimal | getNonIssueQty()
java.lang.String | getNotes()
java.lang.String | getOrderRelatedDoc()
java.lang.String | getOriginator()
java.math.BigDecimal | getPartAvgCost()
java.lang.String | getPartDesc()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.lang.String | getPriority()
java.lang.String | getProject()
java.math.BigDecimal | getQty()
java.util.Set<RefdocElement> | getRefDoc1()
java.util.Set<RefdocElement> | getRefDoc2()
java.util.Set | getRefDocOnes()
java.util.Set | getRefDocTwoes()
java.lang.String | getRelatedDoc()
java.lang.String | getSetId()
java.math.BigDecimal | getStandardCost()
java.util.Date | getStartDate()
java.lang.String | getStatus()
java.math.BigDecimal | getToBeAsm()
java.math.BigDecimal | getTotalAsmStandardCost()
java.math.BigDecimal | getTotalAsmWeight()
java.math.BigDecimal | getTotalCost()
java.math.BigDecimal | getTotalIssuedCost()
java.math.BigDecimal | getTotalNonIssueCost()
java.math.BigDecimal | getTotalToBeAsmStandardCost()
java.math.BigDecimal | getTotalToBeAsmWeight()
java.math.BigDecimal | getTotalWeight()
java.lang.String | getUnit()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
float | getWeight()
java.lang.String | getWeightUnit()
java.lang.String | getWoComments()
WorkOrderItemPK | getWoItemPk()
java.lang.String | getWowiCurrentInstrucationSeq()
java.lang.String | getWowiCurrentInstrucationSeqWC()
java.lang.String | getWowiCurrentInstrucationSeqWCDesc()
java.math.BigDecimal | getWowiPartAvgCost()
void | setAccountNumber(java.lang.String accountNumber)
void | setAsm(java.math.BigDecimal asm)
void | setCanAsm(java.math.BigDecimal canAsm)
void | setComments(java.lang.String comments)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCompletedDate(java.util.Date completedDate)
void | setCostPerUnit(java.math.BigDecimal costPerUnit)
void | setCurrency(java.lang.String currency)
void | setDueDate(java.util.Date dueDate)
void | setExtendPrice(java.math.BigDecimal extendPrice)
void | setInWIPQty(java.math.BigDecimal inWIPQty)
void | setMfgStatus(java.lang.String mfgStatus)
void | setNonIssueQty(java.math.BigDecimal nonIssueQty)
void | setNotes(java.lang.String notes)
void | setOrderRelatedDoc(java.lang.String orderRelatedDoc)
void | setOriginator(java.lang.String originator)
void | setPartAvgCost(java.math.BigDecimal partAvgCost)
void | setPartDesc(java.lang.String partDesc)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setPriority(java.lang.String priority)
void | setProject(java.lang.String project)
void | setQty(java.math.BigDecimal qty)
void | setRefDoc1(java.util.Set<RefdocElement> refDoc1)
void | setRefDoc2(java.util.Set<RefdocElement> refDoc2)
void | setRefDocOnes(java.util.Set refDocOnes)
void | setRefDocTwoes(java.util.Set refDocTwoes)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setSetId(java.lang.String setId)
void | setStandardCost(java.math.BigDecimal standardCost)
void | setStartDate(java.util.Date startDate)
void | setStatus(java.lang.String status)
void | setToBeAsm(java.math.BigDecimal toBeAsm)
void | setTotalAsmStandardCost(java.math.BigDecimal totalAsmStandardCost)
void | setTotalAsmWeight(double totalAsmWeight)
void | setTotalIssuedCost(java.math.BigDecimal totalIssuedCost)
void | setTotalNonIssueCost(java.math.BigDecimal totalNonIssueCost)
void | setTotalToBeAsmStandardCost(java.math.BigDecimal totalToBeAsmStandardCost)
void | setTotalToBeAsmWeight(double totalToBeAsmWeight)
void | setTotalWeight(double totalWeight)
void | setUnit(java.lang.String unit)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
void | setWeight(float weight)
void | setWeightUnit(java.lang.String weightUnit)
void | setWoComments(java.lang.String woComments)
void | setWoItemPk(WorkOrderItemPK woItemPk)
void | setWowiCurrentInstrucationSeq(java.lang.String wowiCurrentInstrucationSeq)
void | setWowiCurrentInstrucationSeqWC(java.lang.String wowiCurrentInstrucationSeqWC)
void | setWowiCurrentInstrucationSeqWCDesc(java.lang.String wowiCurrentInstrucationSeqWCDesc)
void | setWowiPartAvgCost(java.math.BigDecimal wowiPartAvgCost)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_WORKORDERNUMBER

public static final java.lang.String ORDER_BY_WORKORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_WORKORDERITEMNUMBER

public static final java.lang.String ORDER_BY_WORKORDERITEMNUMBER
See Also:
Constant Field Values

ORDER_BY_RELATEDDOC

public static final java.lang.String ORDER_BY_RELATEDDOC
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_DUEDATE

public static final java.lang.String ORDER_BY_DUEDATE
See Also:
Constant Field Values

ORDER_BY_STARTDATE

public static final java.lang.String ORDER_BY_STARTDATE
See Also:
Constant Field Values

ORDER_BY_PARTDESC

public static final java.lang.String ORDER_BY_PARTDESC
See Also:
Constant Field Values

ORDER_BY_ORIGINATOR

public static final java.lang.String ORDER_BY_ORIGINATOR
See Also:
Constant Field Values

ORDER_BY_PRIORITY

public static final java.lang.String ORDER_BY_PRIORITY
See Also:
Constant Field Values

ORDER_BY_PROJECT

public static final java.lang.String ORDER_BY_PROJECT
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_MFGSTATUS

public static final java.lang.String ORDER_BY_MFGSTATUS
See Also:
Constant Field Values

ORDER_BY_COSTPERUNIT

public static final java.lang.String ORDER_BY_COSTPERUNIT
See Also:
Constant Field Values

ORDER_BY_EXTENDPRICE

public static final java.lang.String ORDER_BY_EXTENDPRICE
See Also:
Constant Field Values

ORDER_BY_CURRENCY

public static final java.lang.String ORDER_BY_CURRENCY
See Also:
Constant Field Values

ORDER_BY_ACCOUNTNUMBER

public static final java.lang.String ORDER_BY_ACCOUNTNUMBER
See Also:
Constant Field Values

ORDER_BY_COMPANYUNITID

public static final java.lang.String ORDER_BY_COMPANYUNITID
See Also:
Constant Field Values

ORDER_BY_COMPLETEDDATE

public static final java.lang.String ORDER_BY_COMPLETEDDATE
See Also:
Constant Field Values

ORDER_BY_QTY

public static final java.lang.String ORDER_BY_QTY
See Also:
Constant Field Values

ORDER_BY_ASM

public static final java.lang.String ORDER_BY_ASM
See Also:
Constant Field Values

ORDER_BY_TOBEASM

public static final java.lang.String ORDER_BY_TOBEASM
See Also:
Constant Field Values

ORDER_BY_ORDERRELATEDDOC

public static final java.lang.String ORDER_BY_ORDERRELATEDDOC
See Also:
Constant Field Values

ORDER_BY_STDCOST

public static final java.lang.String ORDER_BY_STDCOST
See Also:
Constant Field Values
Constructor Detail

WorkOrderItemListResult

public WorkOrderItemListResult()
Method Detail

getWoItemPk

public WorkOrderItemPK getWoItemPk()

getPartPk

public PartPK getPartPk()

getPartFrom

public java.lang.String getPartFrom()

getPartDesc

public java.lang.String getPartDesc()

getQty

public java.math.BigDecimal getQty()

getAsm

public java.math.BigDecimal getAsm()

getVendorId

public java.lang.String getVendorId()

getVendorName

public java.lang.String getVendorName()

getStartDate

public java.util.Date getStartDate()

getDueDate

public java.util.Date getDueDate()

getStatus

public java.lang.String getStatus()

getUnit

public java.lang.String getUnit()

getOriginator

public java.lang.String getOriginator()

getComments

public java.lang.String getComments()

getMfgStatus

public java.lang.String getMfgStatus()

getProject

public java.lang.String getProject()

getRefDoc1

public java.util.Set<RefdocElement> getRefDoc1()

getPriority

public java.lang.String getPriority()

getNotes

public java.lang.String getNotes()

getWoComments

public java.lang.String getWoComments()

getSetId

public java.lang.String getSetId()

setWoItemPk

public void setWoItemPk(WorkOrderItemPK woItemPk)

setPartPk

public void setPartPk(PartPK partPk)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setPartDesc

public void setPartDesc(java.lang.String partDesc)

setQty

public void setQty(java.math.BigDecimal qty)

setAsm

public void setAsm(java.math.BigDecimal asm)

setVendorId

public void setVendorId(java.lang.String vendorId)

setVendorName

public void setVendorName(java.lang.String vendorName)

setStartDate

public void setStartDate(java.util.Date startDate)

setDueDate

public void setDueDate(java.util.Date dueDate)

setStatus

public void setStatus(java.lang.String status)

setUnit

public void setUnit(java.lang.String unit)

setOriginator

public void setOriginator(java.lang.String originator)

setComments

public void setComments(java.lang.String comments)

setMfgStatus

public void setMfgStatus(java.lang.String mfgStatus)

setProject

public void setProject(java.lang.String project)

getRefDoc2

public java.util.Set<RefdocElement> getRefDoc2()

setRefDoc2

public void setRefDoc2(java.util.Set<RefdocElement> refDoc2)

setRefDoc1

public void setRefDoc1(java.util.Set<RefdocElement> refDoc1)

setPriority

public void setPriority(java.lang.String priority)

setNotes

public void setNotes(java.lang.String notes)

setWoComments

public void setWoComments(java.lang.String woComments)

setSetId

public void setSetId(java.lang.String setId)

getCompletedDate

public java.util.Date getCompletedDate()

setCompletedDate

public void setCompletedDate(java.util.Date completedDate)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getCostPerUnit

public java.math.BigDecimal getCostPerUnit()

setCostPerUnit

public void setCostPerUnit(java.math.BigDecimal costPerUnit)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getExtendPrice

public java.math.BigDecimal getExtendPrice()

setExtendPrice

public void setExtendPrice(java.math.BigDecimal extendPrice)

getAccountNumber

public java.lang.String getAccountNumber()

setAccountNumber

public void setAccountNumber(java.lang.String accountNumber)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getTotalCost

public java.math.BigDecimal getTotalCost()

getWowiCurrentInstrucationSeq

public java.lang.String getWowiCurrentInstrucationSeq()

setWowiCurrentInstrucationSeq

public void setWowiCurrentInstrucationSeq(java.lang.String wowiCurrentInstrucationSeq)

getWowiCurrentInstrucationSeqWC

public java.lang.String getWowiCurrentInstrucationSeqWC()

setWowiCurrentInstrucationSeqWC

public void setWowiCurrentInstrucationSeqWC(java.lang.String wowiCurrentInstrucationSeqWC)

getWowiCurrentInstrucationSeqWCDesc

public java.lang.String getWowiCurrentInstrucationSeqWCDesc()

setWowiCurrentInstrucationSeqWCDesc

public void setWowiCurrentInstrucationSeqWCDesc(java.lang.String wowiCurrentInstrucationSeqWCDesc)

getTotalIssuedCost

public java.math.BigDecimal getTotalIssuedCost()

setTotalIssuedCost

public void setTotalIssuedCost(java.math.BigDecimal totalIssuedCost)

getNonIssueQty

public java.math.BigDecimal getNonIssueQty()

getInWIPQty

public java.math.BigDecimal getInWIPQty()

setInWIPQty

public void setInWIPQty(java.math.BigDecimal inWIPQty)

getPartAvgCost

public java.math.BigDecimal getPartAvgCost()

setPartAvgCost

public void setPartAvgCost(java.math.BigDecimal partAvgCost)

setNonIssueQty

public void setNonIssueQty(java.math.BigDecimal nonIssueQty)

getTotalNonIssueCost

public java.math.BigDecimal getTotalNonIssueCost()

setTotalNonIssueCost

public void setTotalNonIssueCost(java.math.BigDecimal totalNonIssueCost)

getWowiPartAvgCost

public java.math.BigDecimal getWowiPartAvgCost()

setWowiPartAvgCost

public void setWowiPartAvgCost(java.math.BigDecimal wowiPartAvgCost)

getToBeAsm

public java.math.BigDecimal getToBeAsm()

setToBeAsm

public void setToBeAsm(java.math.BigDecimal toBeAsm)

getCanAsm

public java.math.BigDecimal getCanAsm()

setCanAsm

public void setCanAsm(java.math.BigDecimal canAsm)

getOrderRelatedDoc

public java.lang.String getOrderRelatedDoc()

setOrderRelatedDoc

public void setOrderRelatedDoc(java.lang.String orderRelatedDoc)

getRefDocOnes

public java.util.Set getRefDocOnes()

setRefDocOnes

public void setRefDocOnes(java.util.Set refDocOnes)

getRefDocTwoes

public java.util.Set getRefDocTwoes()

setRefDocTwoes

public void setRefDocTwoes(java.util.Set refDocTwoes)

getWeightUnit

public java.lang.String getWeightUnit()

setWeightUnit

public void setWeightUnit(java.lang.String weightUnit)

getWeight

public float getWeight()

setWeight

public void setWeight(float weight)

getTotalWeight

public java.math.BigDecimal getTotalWeight()

setTotalWeight

public void setTotalWeight(double totalWeight)

getStandardCost

public java.math.BigDecimal getStandardCost()

setStandardCost

public void setStandardCost(java.math.BigDecimal standardCost)

getTotalAsmWeight

public java.math.BigDecimal getTotalAsmWeight()

setTotalAsmWeight

public void setTotalAsmWeight(double totalAsmWeight)

getTotalToBeAsmWeight

public java.math.BigDecimal getTotalToBeAsmWeight()

setTotalToBeAsmWeight

public void setTotalToBeAsmWeight(double totalToBeAsmWeight)

getTotalAsmStandardCost

public java.math.BigDecimal getTotalAsmStandardCost()

setTotalAsmStandardCost

public void setTotalAsmStandardCost(java.math.BigDecimal totalAsmStandardCost)

getTotalToBeAsmStandardCost

public java.math.BigDecimal getTotalToBeAsmStandardCost()

setTotalToBeAsmStandardCost

public void setTotalToBeAsmStandardCost(java.math.BigDecimal totalToBeAsmStandardCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderItemPartDetail

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderItemPartDetail

java.lang.Object
    extended by  bb.common.WorkOrderItemPartDetail
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderItemPartDetail
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ACTUAL
static java.lang.String | ORDER_BY_COST
static java.lang.String | ORDER_BY_ISSUEQUANTITY
static java.lang.String | ORDER_BY_PARTDESC
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_QUANTITY
static java.lang.String | ORDER_BY_RELATEDDOC
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_UNIT
static java.lang.String | ORDER_BY_WOITEMPK
Constructor Summary
WorkOrderItemPartDetail()
Method Summary
java.util.Date | getActual()
java.lang.String | getBomItemNumber()
java.lang.String | getBomNumber()
java.math.BigDecimal | getCost()
java.util.Date | getDateIssued()
java.math.BigDecimal | getIssueQuantity()
java.util.Date | getLastDate()
java.lang.String | getMfgStatus()
java.util.Date | getOriginal()
java.lang.String | getPartDesc()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.math.BigDecimal | getQuantity()
java.lang.String | getRelatedDoc()
java.lang.String | getStatus()
java.lang.String | getUnit()
WorkOrderItemPK | getWoItemPk()
void | setActual(java.util.Date actual)
void | setBomItemNumber(java.lang.String bomItemNumber)
void | setBomNumber(java.lang.String bomNumber)
void | setCost(java.math.BigDecimal cost)
void | setDateIssued(java.util.Date dateIssued)
void | setIssueQuantity(java.math.BigDecimal issueQuantity)
void | setLastDate(java.util.Date lastDate)
void | setMfgStatus(java.lang.String mfgStatus)
void | setOriginal(java.util.Date original)
void | setPartDesc(java.lang.String partDesc)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setQuantity(java.math.BigDecimal quantity)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setStatus(java.lang.String status)
void | setUnit(java.lang.String unit)
void | setWoItemPk(WorkOrderItemPK woItemPk)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_WOITEMPK

public static final java.lang.String ORDER_BY_WOITEMPK
See Also:
Constant Field Values

ORDER_BY_RELATEDDOC

public static final java.lang.String ORDER_BY_RELATEDDOC
See Also:
Constant Field Values

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_PARTDESC

public static final java.lang.String ORDER_BY_PARTDESC
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_COST

public static final java.lang.String ORDER_BY_COST
See Also:
Constant Field Values

ORDER_BY_UNIT

public static final java.lang.String ORDER_BY_UNIT
See Also:
Constant Field Values

ORDER_BY_QUANTITY

public static final java.lang.String ORDER_BY_QUANTITY
See Also:
Constant Field Values

ORDER_BY_ISSUEQUANTITY

public static final java.lang.String ORDER_BY_ISSUEQUANTITY
See Also:
Constant Field Values

ORDER_BY_ACTUAL

public static final java.lang.String ORDER_BY_ACTUAL
See Also:
Constant Field Values
Constructor Detail

WorkOrderItemPartDetail

public WorkOrderItemPartDetail()
Method Detail

getBomItemNumber

public java.lang.String getBomItemNumber()

setBomItemNumber

public void setBomItemNumber(java.lang.String bomItemNumber)

getBomNumber

public java.lang.String getBomNumber()

setBomNumber

public void setBomNumber(java.lang.String bomNumber)

getDateIssued

public java.util.Date getDateIssued()

setDateIssued

public void setDateIssued(java.util.Date dateIssued)

getIssueQuantity

public java.math.BigDecimal getIssueQuantity()

setIssueQuantity

public void setIssueQuantity(java.math.BigDecimal issueQuantity)

getMfgStatus

public java.lang.String getMfgStatus()

setMfgStatus

public void setMfgStatus(java.lang.String mfgStatus)

getPartDesc

public java.lang.String getPartDesc()

setPartDesc

public void setPartDesc(java.lang.String partDesc)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartPk

public PartPK getPartPk()

setPartPk

public void setPartPk(PartPK partPk)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getWoItemPk

public WorkOrderItemPK getWoItemPk()

setWoItemPk

public void setWoItemPk(WorkOrderItemPK woItemPk)

getActual

public java.util.Date getActual()

setActual

public void setActual(java.util.Date actual)

getCost

public java.math.BigDecimal getCost()

setCost

public void setCost(java.math.BigDecimal cost)

getOriginal

public java.util.Date getOriginal()

setOriginal

public void setOriginal(java.util.Date original)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getLastDate

public java.util.Date getLastDate()

setLastDate

public void setLastDate(java.util.Date lastDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderItemPartDetailInWipVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderItemPartDetailInWipVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.WorkOrderItemPartDetailInWipVO
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderItemPartDetailInWipVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_COMPANYUNITID
static java.lang.String | ORDER_BY_COST
static java.lang.String | ORDER_BY_DATEISSUED
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_QTYINWIP
static java.lang.String | ORDER_BY_STDCOST
static java.lang.String | ORDER_BY_TRANSACTIONNUMBER
static java.lang.String | ORDER_BY_WOISCOST
static java.lang.String | ORDER_BY_WOISSTDCOST
static java.lang.String | ORDER_BY_WORKORDERNUMBER
Constructor Summary
WorkOrderItemPartDetailInWipVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCompanyUnitId()
java.math.BigDecimal | getCost()
java.util.Date | getDateIssued()
java.lang.String | getDescription()
java.lang.Long | getIi()
java.lang.Short | getItemNumber()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getQtyInWip()
java.math.BigDecimal | getStdCost()
java.lang.String | getTransactionNumber()
java.math.BigDecimal | getWoisCost()
java.math.BigDecimal | getWoisStdCost()
java.lang.String | getWorkOrderItemNumber()
java.lang.String | getWorkOrderNumber()
int | hashCode()
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCost(java.math.BigDecimal cost)
void | setDateIssued(java.util.Date dateIssued)
void | setDescription(java.lang.String description)
void | setIi(java.lang.Long ii)
void | setItemNumber(java.lang.Short itemNumber)
void | setLastChangeDate(java.util.Date LastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setQtyInWip(java.math.BigDecimal qtyInWip)
void | setStdCost(java.math.BigDecimal stdCost)
void | setTransactionNumber(java.lang.String transactionNumber)
void | setWoisCost(java.math.BigDecimal woisCost)
void | setWoisStdCost(java.math.BigDecimal woisStdCost)
void | setWorkOrderItemNumber(java.lang.String workOrderItemNumber)
void | setWorkOrderNumber(java.lang.String workOrderNumber)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_WORKORDERNUMBER

public static final java.lang.String ORDER_BY_WORKORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_QTYINWIP

public static final java.lang.String ORDER_BY_QTYINWIP
See Also:
Constant Field Values

ORDER_BY_COST

public static final java.lang.String ORDER_BY_COST
See Also:
Constant Field Values

ORDER_BY_STDCOST

public static final java.lang.String ORDER_BY_STDCOST
See Also:
Constant Field Values

ORDER_BY_DATEISSUED

public static final java.lang.String ORDER_BY_DATEISSUED
See Also:
Constant Field Values

ORDER_BY_WOISCOST

public static final java.lang.String ORDER_BY_WOISCOST
See Also:
Constant Field Values

ORDER_BY_WOISSTDCOST

public static final java.lang.String ORDER_BY_WOISSTDCOST
See Also:
Constant Field Values

ORDER_BY_COMPANYUNITID

public static final java.lang.String ORDER_BY_COMPANYUNITID
See Also:
Constant Field Values

ORDER_BY_TRANSACTIONNUMBER

public static final java.lang.String ORDER_BY_TRANSACTIONNUMBER
See Also:
Constant Field Values
Constructor Detail

WorkOrderItemPartDetailInWipVO

public WorkOrderItemPartDetailInWipVO()
default constructor

Method Detail

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date LastChangeDate)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getCost

public java.math.BigDecimal getCost()

setCost

public void setCost(java.math.BigDecimal cost)

getWoisCost

public java.math.BigDecimal getWoisCost()

setWoisCost

public void setWoisCost(java.math.BigDecimal woisCost)

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getWorkOrderItemNumber

public java.lang.String getWorkOrderItemNumber()

setWorkOrderItemNumber

public void setWorkOrderItemNumber(java.lang.String workOrderItemNumber)

getWorkOrderNumber

public java.lang.String getWorkOrderNumber()

setWorkOrderNumber

public void setWorkOrderNumber(java.lang.String workOrderNumber)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getWoisStdCost

public java.math.BigDecimal getWoisStdCost()

setWoisStdCost

public void setWoisStdCost(java.math.BigDecimal woisStdCost)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getQtyInWip

public java.math.BigDecimal getQtyInWip()

setQtyInWip

public void setQtyInWip(java.math.BigDecimal qtyInWip)

getItemNumber

public java.lang.Short getItemNumber()

setItemNumber

public void setItemNumber(java.lang.Short itemNumber)

getTransactionNumber

public java.lang.String getTransactionNumber()

setTransactionNumber

public void setTransactionNumber(java.lang.String transactionNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getDateIssued

public java.util.Date getDateIssued()

setDateIssued

public void setDateIssued(java.util.Date dateIssued)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderItemPartDetailItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderItemPartDetailItemResult

java.lang.Object
    extended by  bb.common.WorkOrderItemPartDetailItemResult
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderItemPartDetailItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkOrderItemPartDetailItemResult()
Method Summary
java.math.BigDecimal | getAvgCost()
java.lang.String | getComments()
java.math.BigDecimal | getCost()
java.util.Date | getDateIssued()
java.lang.String | getDescription()
WorkOrderItemIssueVO | getIssueVo()
WorkOrderItemIssuePK | getItemIssuePk()
java.lang.String | getLot()
java.math.BigDecimal | getOndemand()
java.math.BigDecimal | getOnhand()
java.math.BigDecimal | getOnorder()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getQuantityIssued()
java.lang.String | getRef()
java.util.Set | getRefDoc1Set()
java.lang.String | getSerial()
java.math.BigDecimal | getStdCost()
java.lang.String | getUnit()
void | setAvgCost(java.math.BigDecimal avgCost)
void | setIssueVo(WorkOrderItemIssueVO issueVo)
void | setOndemand(java.math.BigDecimal ondemand)
void | setOnhand(java.math.BigDecimal onhand)
void | setOnorder(java.math.BigDecimal onorder)
void | setQuantity(java.math.BigDecimal qty)
void | setRefDoc1Set(java.util.Set refDoc1Set)
void | setStdCost(java.math.BigDecimal stdCost)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkOrderItemPartDetailItemResult

public WorkOrderItemPartDetailItemResult()
Method Detail

setAvgCost

public void setAvgCost(java.math.BigDecimal avgCost)

setIssueVo

public void setIssueVo(WorkOrderItemIssueVO issueVo)

setOnhand

public void setOnhand(java.math.BigDecimal onhand)

setRefDoc1Set

public void setRefDoc1Set(java.util.Set refDoc1Set)

getAvgCost

public java.math.BigDecimal getAvgCost()

getIssueVo

public WorkOrderItemIssueVO getIssueVo()

getOnhand

public java.math.BigDecimal getOnhand()

getRefDoc1Set

public java.util.Set getRefDoc1Set()

getPartPk

public PartPK getPartPk()

getItemIssuePk

public WorkOrderItemIssuePK getItemIssuePk()

getPartFrom

public java.lang.String getPartFrom()

getDescription

public java.lang.String getDescription()

getComments

public java.lang.String getComments()

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal qty)

getQuantityIssued

public java.math.BigDecimal getQuantityIssued()

getUnit

public java.lang.String getUnit()

getDateIssued

public java.util.Date getDateIssued()

getSerial

public java.lang.String getSerial()

getLot

public java.lang.String getLot()

getRef

public java.lang.String getRef()

getCost

public java.math.BigDecimal getCost()

getOndemand

public java.math.BigDecimal getOndemand()

setOndemand

public void setOndemand(java.math.BigDecimal ondemand)

getOnorder

public java.math.BigDecimal getOnorder()

setOnorder

public void setOnorder(java.math.BigDecimal onorder)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderItemPartDetailResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderItemPartDetailResult

java.lang.Object
    extended by  bb.common.WorkOrderItemPartDetailResult
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderItemPartDetailResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkOrderItemPartDetailResult()
Method Summary
java.math.BigDecimal | getBomCost()
java.math.BigDecimal | getBomStdCost()
java.util.Date | getDeliveryDate()
java.lang.String | getDescription()
java.math.BigDecimal | getDiffCost()
java.math.BigDecimal | getIssuedCost()
java.math.BigDecimal | getIssuedStdCost()
java.util.Set<WorkOrderItemPartDetailItemResult> | getItems()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.math.BigDecimal | getQuantity()
java.util.Set | getRefDocTwoes()
java.lang.String | getReviewedBy()
java.util.Date | getReviewedDate()
java.lang.String | getReviewedDesc()
java.math.BigDecimal | getShortageCost()
java.math.BigDecimal | getShortageStdCost()
java.util.Date | getStartDate()
java.lang.String | getStatus()
java.math.BigDecimal | getSumCost()
java.math.BigDecimal | getTotControlCost()
java.math.BigDecimal | getVarianceCost()
java.lang.String | getWiSetId()
WorkOrderItemPK | getWoItemPk()
boolean | isCostAlarm()
void | setBomCost(java.math.BigDecimal bomCost)
void | setBomStdCost(java.math.BigDecimal bomStdCost)
void | setCostAlarm(boolean costAlarm)
void | setDeliveryDate(java.util.Date deliveryDate)
void | setDescription(java.lang.String description)
void | setDiffCost(java.math.BigDecimal diffCost)
void | setIssuedCost(java.math.BigDecimal issuedCost)
void | setIssuedStdCost(java.math.BigDecimal issuedStdCost)
void | setItems(java.util.Set<WorkOrderItemPartDetailItemResult> items)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setQuantity(java.math.BigDecimal quantity)
void | setRefDocTwoes(java.util.Set refDocTwoes)
void | setReviewedBy(java.lang.String reviewedBy)
void | setReviewedDate(java.util.Date reviewedDate)
void | setReviewedDesc(java.lang.String reviewedDesc)
void | setShortageCost(java.math.BigDecimal shortageCost)
void | setShortageStdCost(java.math.BigDecimal shortageStdCost)
void | setStartDate(java.util.Date startDate)
void | setStatus(java.lang.String status)
void | setSumCost(java.math.BigDecimal sumCost)
void | setTotControlCost(java.math.BigDecimal totControlCost)
void | setVarianceCost(java.math.BigDecimal varianceCost)
void | setWiSetId(java.lang.String wiSetId)
void | setWoItemPk(WorkOrderItemPK woItemPk)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkOrderItemPartDetailResult

public WorkOrderItemPartDetailResult()
Method Detail

setWoItemPk

public void setWoItemPk(WorkOrderItemPK woItemPk)

setPartPk

public void setPartPk(PartPK partPk)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setDescription

public void setDescription(java.lang.String description)

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

setStartDate

public void setStartDate(java.util.Date startDate)

setDeliveryDate

public void setDeliveryDate(java.util.Date deliveryDate)

setWiSetId

public void setWiSetId(java.lang.String wiSetId)

setStatus

public void setStatus(java.lang.String status)

setItems

public void setItems(java.util.Set<WorkOrderItemPartDetailItemResult> items)

setBomCost

public void setBomCost(java.math.BigDecimal bomCost)

setIssuedCost

public void setIssuedCost(java.math.BigDecimal issuedCost)

setShortageCost

public void setShortageCost(java.math.BigDecimal shortageCost)

getWoItemPk

public WorkOrderItemPK getWoItemPk()

getPartPk

public PartPK getPartPk()

getPartFrom

public java.lang.String getPartFrom()

getDescription

public java.lang.String getDescription()

getQuantity

public java.math.BigDecimal getQuantity()

getStartDate

public java.util.Date getStartDate()

getDeliveryDate

public java.util.Date getDeliveryDate()

getWiSetId

public java.lang.String getWiSetId()

getStatus

public java.lang.String getStatus()

getItems

public java.util.Set<WorkOrderItemPartDetailItemResult> getItems()

getBomCost

public java.math.BigDecimal getBomCost()

getIssuedCost

public java.math.BigDecimal getIssuedCost()

getShortageCost

public java.math.BigDecimal getShortageCost()

getRefDocTwoes

public java.util.Set getRefDocTwoes()

setRefDocTwoes

public void setRefDocTwoes(java.util.Set refDocTwoes)

isCostAlarm

public boolean isCostAlarm()

setCostAlarm

public void setCostAlarm(boolean costAlarm)

getReviewedBy

public java.lang.String getReviewedBy()

setReviewedBy

public void setReviewedBy(java.lang.String reviewedBy)

getReviewedDate

public java.util.Date getReviewedDate()

setReviewedDate

public void setReviewedDate(java.util.Date reviewedDate)

getReviewedDesc

public java.lang.String getReviewedDesc()

setReviewedDesc

public void setReviewedDesc(java.lang.String reviewedDesc)

getDiffCost

public java.math.BigDecimal getDiffCost()

setDiffCost

public void setDiffCost(java.math.BigDecimal diffCost)

getSumCost

public java.math.BigDecimal getSumCost()

setSumCost

public void setSumCost(java.math.BigDecimal sumCost)

getTotControlCost

public java.math.BigDecimal getTotControlCost()

setTotControlCost

public void setTotControlCost(java.math.BigDecimal totControlCost)

getVarianceCost

public java.math.BigDecimal getVarianceCost()

setVarianceCost

public void setVarianceCost(java.math.BigDecimal varianceCost)

getBomStdCost

public java.math.BigDecimal getBomStdCost()

setBomStdCost

public void setBomStdCost(java.math.BigDecimal bomStdCost)

getIssuedStdCost

public java.math.BigDecimal getIssuedStdCost()

setIssuedStdCost

public void setIssuedStdCost(java.math.BigDecimal issuedStdCost)

getShortageStdCost

public java.math.BigDecimal getShortageStdCost()

setShortageStdCost

public void setShortageStdCost(java.math.BigDecimal shortageStdCost)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderItemPK

java.lang.Object
    extended by  bb.common.WorkOrderItemPK
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<WorkOrderItemPK>
public class WorkOrderItemPK
extends java.lang.Object
implements java.io.Serializable, java.lang.Comparable<WorkOrderItemPK>

See Also:
Serialized Form

Constructor Summary
WorkOrderItemPK()
WorkOrderItemPK(java.lang.String workOrderNumber, java.lang.String workOrderItemNumber)
Method Summary
int | compareTo(WorkOrderItemPK other)
boolean | equals(java.lang.Object other)
java.lang.String | getWorkOrderItemNumber()
java.lang.String | getWorkOrderNumber()
int | hashCode()
void | setWorkOrderItemNumber(java.lang.String workOrderItemNumber)
void | setWorkOrderNumber(java.lang.String workOrderNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WorkOrderItemPK

public WorkOrderItemPK()

WorkOrderItemPK

public WorkOrderItemPK(java.lang.String workOrderNumber,
                       java.lang.String workOrderItemNumber)
Method Detail

setWorkOrderNumber

public void setWorkOrderNumber(java.lang.String workOrderNumber)

getWorkOrderNumber

public java.lang.String getWorkOrderNumber()

setWorkOrderItemNumber

public void setWorkOrderItemNumber(java.lang.String workOrderItemNumber)

getWorkOrderItemNumber

public java.lang.String getWorkOrderItemNumber()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

compareTo

public int compareTo(WorkOrderItemPK other)
Specified by:
compareTo in interface java.lang.Comparable<WorkOrderItemPK>
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderItemReviewCostResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderItemReviewCostResult

java.lang.Object
    extended by  bb.common.WorkOrderItemReviewCostResult
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderItemReviewCostResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DATEREQUIRED
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_OVERPERCENT
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PK
static java.lang.String | ORDER_BY_REVIEWDESCRIPTION
static java.lang.String | ORDER_BY_REVIEWEDBY
static java.lang.String | ORDER_BY_REVIEWEDDATE
static java.lang.String | ORDER_BY_STARTDATE
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_VENDORID
Constructor Summary
WorkOrderItemReviewCostResult()
Method Summary
java.util.Date | getDateRequired()
java.lang.String | getDescription()
java.math.BigDecimal | getDiffCost()
java.math.BigDecimal | getOriginalCost()
java.math.BigDecimal | getOverPercent()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
WorkOrderItemPK | getPk()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getQuantityAsm()
java.lang.String | getReviewDescription()
java.lang.String | getReviewedBy()
java.util.Date | getReviewedDate()
java.util.Date | getStartDate()
java.lang.String | getStatus()
java.math.BigDecimal | getSumCost()
java.math.BigDecimal | getTotControlCost()
java.math.BigDecimal | getVarianceCost()
java.lang.String | getVendorId()
void | setDateRequired(java.util.Date dateRequired)
void | setDescription(java.lang.String description)
void | setDiffCost(java.math.BigDecimal diffCost)
void | setOriginalCost(java.math.BigDecimal originalCost)
void | setOverPercent(java.math.BigDecimal overPercent)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(WorkOrderItemPK pk)
void | setQuantity(java.math.BigDecimal quantity)
void | setQuantityAsm(java.math.BigDecimal quantityAsm)
void | setReviewDescription(java.lang.String reviewDescription)
void | setReviewedBy(java.lang.String reviewedBy)
void | setReviewedDate(java.util.Date reviewedDate)
void | setStartDate(java.util.Date startDate)
void | setStatus(java.lang.String status)
void | setSumCost(java.math.BigDecimal sumCost)
void | setTotControlCost(java.math.BigDecimal totControlCost)
void | setVarianceCost(java.math.BigDecimal varianceCost)
void | setVendorId(java.lang.String vendorId)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PK

public static final java.lang.String ORDER_BY_PK
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_STARTDATE

public static final java.lang.String ORDER_BY_STARTDATE
See Also:
Constant Field Values

ORDER_BY_DATEREQUIRED

public static final java.lang.String ORDER_BY_DATEREQUIRED
See Also:
Constant Field Values

ORDER_BY_REVIEWEDDATE

public static final java.lang.String ORDER_BY_REVIEWEDDATE
See Also:
Constant Field Values

ORDER_BY_REVIEWEDBY

public static final java.lang.String ORDER_BY_REVIEWEDBY
See Also:
Constant Field Values

ORDER_BY_REVIEWDESCRIPTION

public static final java.lang.String ORDER_BY_REVIEWDESCRIPTION
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values

ORDER_BY_OVERPERCENT

public static final java.lang.String ORDER_BY_OVERPERCENT
See Also:
Constant Field Values
Constructor Detail

WorkOrderItemReviewCostResult

public WorkOrderItemReviewCostResult()
Method Detail

getDateRequired

public java.util.Date getDateRequired()

setDateRequired

public void setDateRequired(java.util.Date dateRequired)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getDiffCost

public java.math.BigDecimal getDiffCost()

setDiffCost

public void setDiffCost(java.math.BigDecimal diffCost)

getOriginalCost

public java.math.BigDecimal getOriginalCost()

setOriginalCost

public void setOriginalCost(java.math.BigDecimal originalCost)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPk

public WorkOrderItemPK getPk()

setPk

public void setPk(WorkOrderItemPK pk)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getQuantityAsm

public java.math.BigDecimal getQuantityAsm()

setQuantityAsm

public void setQuantityAsm(java.math.BigDecimal quantityAsm)

getReviewDescription

public java.lang.String getReviewDescription()

setReviewDescription

public void setReviewDescription(java.lang.String reviewDescription)

getReviewedBy

public java.lang.String getReviewedBy()

setReviewedBy

public void setReviewedBy(java.lang.String reviewedBy)

getReviewedDate

public java.util.Date getReviewedDate()

setReviewedDate

public void setReviewedDate(java.util.Date reviewedDate)

getStartDate

public java.util.Date getStartDate()

setStartDate

public void setStartDate(java.util.Date startDate)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getSumCost

public java.math.BigDecimal getSumCost()

setSumCost

public void setSumCost(java.math.BigDecimal sumCost)

getTotControlCost

public java.math.BigDecimal getTotControlCost()

setTotControlCost

public void setTotControlCost(java.math.BigDecimal totControlCost)

getVarianceCost

public java.math.BigDecimal getVarianceCost()

setVarianceCost

public void setVarianceCost(java.math.BigDecimal varianceCost)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getOverPercent

public java.math.BigDecimal getOverPercent()

setOverPercent

public void setOverPercent(java.math.BigDecimal overPercent)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderItemSeqWCLoadResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderItemSeqWCLoadResult

java.lang.Object
    extended by  bb.common.WorkOrderItemSeqWCLoadResult
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderItemSeqWCLoadResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkOrderItemSeqWCLoadResult()
Method Summary
java.util.Date | getActualEndDate()
java.util.Date | getActualStartDate()
double | getCompletePercent()
java.util.Date | getEndDate()
java.math.BigDecimal | getHours()
java.lang.String | getOutSourcing()
WorkOrderItemPK | getPk()
java.lang.String | getSeqNumber()
java.util.Date | getStartDate()
java.lang.String | getWorkCenter()
int | getWorkCenterItem()
boolean | isFinish()
boolean | isFocusWC()
void | setActualEndDate(java.util.Date actualEndDate)
void | setActualStartDate(java.util.Date actualStartDate)
void | setCompletePercent(double completePercent)
void | setEndDate(java.util.Date endDate)
void | setFinish(boolean finish)
void | setFocusWC(boolean focusWC)
void | setHours(java.math.BigDecimal hours)
void | setOutSourcing(java.lang.String outSourcing)
void | setPk(WorkOrderItemPK pk)
void | setSeqNumber(java.lang.String seqNumber)
void | setStartDate(java.util.Date startDate)
void | setWorkCenter(java.lang.String workCenter)
void | setWorkCenterItem(int workCenterItem)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkOrderItemSeqWCLoadResult

public WorkOrderItemSeqWCLoadResult()
Method Detail

getEndDate

public java.util.Date getEndDate()

setEndDate

public void setEndDate(java.util.Date endDate)

isFinish

public boolean isFinish()

setFinish

public void setFinish(boolean finish)

isFocusWC

public boolean isFocusWC()

setFocusWC

public void setFocusWC(boolean focusWC)

getPk

public WorkOrderItemPK getPk()

setPk

public void setPk(WorkOrderItemPK pk)

getSeqNumber

public java.lang.String getSeqNumber()

setSeqNumber

public void setSeqNumber(java.lang.String seqNumber)

getStartDate

public java.util.Date getStartDate()

setStartDate

public void setStartDate(java.util.Date startDate)

getWorkCenter

public java.lang.String getWorkCenter()

setWorkCenter

public void setWorkCenter(java.lang.String workCenter)

getHours

public java.math.BigDecimal getHours()

setHours

public void setHours(java.math.BigDecimal hours)

getActualEndDate

public java.util.Date getActualEndDate()

setActualEndDate

public void setActualEndDate(java.util.Date actualEndDate)

getActualStartDate

public java.util.Date getActualStartDate()

setActualStartDate

public void setActualStartDate(java.util.Date actualStartDate)

getCompletePercent

public double getCompletePercent()

setCompletePercent

public void setCompletePercent(double completePercent)

getOutSourcing

public java.lang.String getOutSourcing()

setOutSourcing

public void setOutSourcing(java.lang.String outSourcing)

getWorkCenterItem

public int getWorkCenterItem()

setWorkCenterItem

public void setWorkCenterItem(int workCenterItem)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderItemSetupItemAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderItemSetupItemAgent

java.lang.Object
    extended by  bb.common.WorkOrderItemSetupItemAgent
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable
public class WorkOrderItemSetupItemAgent
extends java.lang.Object
implements java.io.Serializable, java.lang.Comparable

See Also:
Serialized Form

Constructor Summary
WorkOrderItemSetupItemAgent()
Method Summary
int | compareTo(java.lang.Object o)
boolean | equals(java.lang.Object other)
java.lang.String | getAsmSequenceNo()
java.math.BigDecimal | getCost()
java.math.BigDecimal | getMultiQtyforApplying()
BillPK | getParent()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.math.BigDecimal | getQty()
java.lang.String | getReplacedItem()
java.lang.String | getReplaceItem()
java.math.BigDecimal | getScrapQty()
java.math.BigDecimal | getScrapRate()
int | hashCode()
void | setAsmSequenceNo(java.lang.String asmSequenceNo)
void | setCost(java.math.BigDecimal cost)
void | setMultiQtyforApplying(java.math.BigDecimal multiQtyforApplying)
void | setParent(BillPK parent)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setQty(java.math.BigDecimal qty)
void | setReplacedItem(java.lang.String replacedItem)
void | setReplaceItem(java.lang.String replaceItem)
void | setScrapQty(java.math.BigDecimal scrapQty)
void | setScrapRate(java.math.BigDecimal scrapRate)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WorkOrderItemSetupItemAgent

public WorkOrderItemSetupItemAgent()
Method Detail

getPartPk

public PartPK getPartPk()

getPartFrom

public java.lang.String getPartFrom()

getQty

public java.math.BigDecimal getQty()

setPartPk

public void setPartPk(PartPK partPk)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setQty

public void setQty(java.math.BigDecimal qty)

setReplaceItem

public void setReplaceItem(java.lang.String replaceItem)

getReplaceItem

public java.lang.String getReplaceItem()

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

compareTo

public int compareTo(java.lang.Object o)
Specified by:
compareTo in interface java.lang.Comparable

getParent

public BillPK getParent()

setParent

public void setParent(BillPK parent)

getScrapQty

public java.math.BigDecimal getScrapQty()

setScrapQty

public void setScrapQty(java.math.BigDecimal scrapQty)

getReplacedItem

public java.lang.String getReplacedItem()

setReplacedItem

public void setReplacedItem(java.lang.String replacedItem)

getCost

public java.math.BigDecimal getCost()

setCost

public void setCost(java.math.BigDecimal cost)

getScrapRate

public java.math.BigDecimal getScrapRate()

setScrapRate

public void setScrapRate(java.math.BigDecimal scrapRate)

getMultiQtyforApplying

public java.math.BigDecimal getMultiQtyforApplying()

setMultiQtyforApplying

public void setMultiQtyforApplying(java.math.BigDecimal multiQtyforApplying)

getAsmSequenceNo

public java.lang.String getAsmSequenceNo()

setAsmSequenceNo

public void setAsmSequenceNo(java.lang.String asmSequenceNo)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderItemTimeDetailResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderItemTimeDetailResult

java.lang.Object
    extended by  bb.common.WorkOrderItemTimeDetailResult
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderItemTimeDetailResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkOrderItemTimeDetailResult()
Method Summary
java.util.Date | getDeliveryDate()
java.lang.String | getDescription()
java.util.List<WorkOrderItemTimeDetailVO> | getItems()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.math.BigDecimal | getQuantity()
java.util.Date | getStartDate()
java.lang.String | getStatus()
java.math.BigDecimal | getTotal()
java.math.BigDecimal | getTotalCost()
java.math.BigDecimal | getTotalLabor()
java.lang.String | getWiSetId()
WorkOrderItemPK | getWoItemPk()
void | setDeliveryDate(java.util.Date deliveryDate)
void | setDescription(java.lang.String description)
void | setItems(java.util.List<WorkOrderItemTimeDetailVO> items)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setQuantity(java.math.BigDecimal quantity)
void | setStartDate(java.util.Date startDate)
void | setStatus(java.lang.String status)
void | setTotal(java.math.BigDecimal total)
void | setTotalCost(java.math.BigDecimal totalCost)
void | setTotalLabor(java.math.BigDecimal totalLabor)
void | setWiSetId(java.lang.String wiSetId)
void | setWoItemPk(WorkOrderItemPK woItemPk)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkOrderItemTimeDetailResult

public WorkOrderItemTimeDetailResult()
Method Detail

setWoItemPk

public void setWoItemPk(WorkOrderItemPK woItemPk)

setPartPk

public void setPartPk(PartPK partPk)

setPartFrom

public void setPartFrom(java.lang.String partFrom)

setDescription

public void setDescription(java.lang.String description)

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

setStartDate

public void setStartDate(java.util.Date startDate)

setDeliveryDate

public void setDeliveryDate(java.util.Date deliveryDate)

setWiSetId

public void setWiSetId(java.lang.String wiSetId)

setStatus

public void setStatus(java.lang.String status)

setTotalCost

public void setTotalCost(java.math.BigDecimal totalCost)

getWoItemPk

public WorkOrderItemPK getWoItemPk()

getPartPk

public PartPK getPartPk()

getPartFrom

public java.lang.String getPartFrom()

getDescription

public java.lang.String getDescription()

getQuantity

public java.math.BigDecimal getQuantity()

getStartDate

public java.util.Date getStartDate()

getDeliveryDate

public java.util.Date getDeliveryDate()

getWiSetId

public java.lang.String getWiSetId()

getStatus

public java.lang.String getStatus()

getItems

public java.util.List<WorkOrderItemTimeDetailVO> getItems()

setItems

public void setItems(java.util.List<WorkOrderItemTimeDetailVO> items)

getTotalCost

public java.math.BigDecimal getTotalCost()

getTotalLabor

public java.math.BigDecimal getTotalLabor()

setTotalLabor

public void setTotalLabor(java.math.BigDecimal totalLabor)

getTotal

public java.math.BigDecimal getTotal()

setTotal

public void setTotal(java.math.BigDecimal total)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderItemTimeDetailVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderItemTimeDetailVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.WorkOrderItemTimeDetailVO
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderItemTimeDetailVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_EMPLOYEE
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PARTTYPE
static java.lang.String | ORDER_BY_REVISION
static java.lang.String | ORDER_BY_SERIALNUMBER
static java.lang.String | ORDER_BY_TIMEOFF
static java.lang.String | ORDER_BY_TIMEON
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_WORKCENTER
static java.lang.String | ORDER_BY_WORKORDERNUMBER
Constructor Summary
WorkOrderItemTimeDetailVO()
Method Summary
java.lang.String | getComments()
java.math.BigDecimal | getCost()
java.lang.String | getDescription()
java.lang.String | getEmployee()
java.lang.String | getEmployeeId()
java.math.BigDecimal | getEstHours()
java.math.BigDecimal | getHours()
java.lang.Long | getIi()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getLot()
java.lang.String | getModelNumber()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getPqty()
java.math.BigDecimal | getQty()
java.math.BigDecimal | getReject()
java.lang.String | getRevision()
java.lang.String | getSerialNumber()
java.util.Date | getTimeOff()
java.util.Date | getTimeOn()
java.lang.String | getUnit()
java.lang.String | getVendorId()
java.lang.String | getWcActivity()
java.lang.String | getWorkCenter()
java.lang.String | getWorkInstructionSequence()
java.lang.String | getWorkOrderItemNumber()
java.lang.String | getWorkOrderNumber()
boolean | isEmployeeLaborCost()
void | setComments(java.lang.String comments)
void | setCost(java.math.BigDecimal cost)
void | setDescription(java.lang.String description)
void | setEmployee(java.lang.String employee)
void | setEmployeeId(java.lang.String employeeId)
void | setEmployeeLaborCost(boolean employeeLaborCost)
void | setEstHours(java.math.BigDecimal estHours)
void | setHours(java.math.BigDecimal hours)
void | setIi(java.lang.Long ii)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLot(java.lang.String lot)
void | setModelNumber(java.lang.String modelNumber)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPqty(java.math.BigDecimal pqty)
void | setQty(java.math.BigDecimal qty)
void | setReject(java.math.BigDecimal reject)
void | setRevision(java.lang.String revision)
void | setSerialNumber(java.lang.String serialNumber)
void | setTimeOff(java.util.Date timeOff)
void | setTimeOn(java.util.Date timeOn)
void | setUnit(java.lang.String unit)
void | setVendorId(java.lang.String vendorId)
void | setWcActivity(java.lang.String wcActivity)
void | setWorkCenter(java.lang.String workCenter)
void | setWorkInstructionSequence(java.lang.String workInstructionSequence)
void | setWorkOrderItemNumber(java.lang.String workOrderItemNumber)
void | setWorkOrderNumber(java.lang.String workOrderNumber)
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_WORKORDERNUMBER

public static final java.lang.String ORDER_BY_WORKORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_WORKCENTER

public static final java.lang.String ORDER_BY_WORKCENTER
See Also:
Constant Field Values

ORDER_BY_EMPLOYEE

public static final java.lang.String ORDER_BY_EMPLOYEE
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTTYPE

public static final java.lang.String ORDER_BY_PARTTYPE
See Also:
Constant Field Values

ORDER_BY_REVISION

public static final java.lang.String ORDER_BY_REVISION
See Also:
Constant Field Values

ORDER_BY_SERIALNUMBER

public static final java.lang.String ORDER_BY_SERIALNUMBER
See Also:
Constant Field Values

ORDER_BY_TIMEON

public static final java.lang.String ORDER_BY_TIMEON
See Also:
Constant Field Values

ORDER_BY_TIMEOFF

public static final java.lang.String ORDER_BY_TIMEOFF
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values
Constructor Detail

WorkOrderItemTimeDetailVO

public WorkOrderItemTimeDetailVO()
Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getWorkCenter

public java.lang.String getWorkCenter()

setWorkCenter

public void setWorkCenter(java.lang.String workCenter)

getWcActivity

public java.lang.String getWcActivity()

setWcActivity

public void setWcActivity(java.lang.String wcActivity)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

getReject

public java.math.BigDecimal getReject()

setReject

public void setReject(java.math.BigDecimal reject)

getEmployee

public java.lang.String getEmployee()

setEmployee

public void setEmployee(java.lang.String employee)

getTimeOn

public java.util.Date getTimeOn()

setTimeOn

public void setTimeOn(java.util.Date timeOn)

getTimeOff

public java.util.Date getTimeOff()

setTimeOff

public void setTimeOff(java.util.Date timeOff)

getEstHours

public java.math.BigDecimal getEstHours()

setEstHours

public void setEstHours(java.math.BigDecimal estHours)

getHours

public java.math.BigDecimal getHours()

setHours

public void setHours(java.math.BigDecimal hours)

getCost

public java.math.BigDecimal getCost()

setCost

public void setCost(java.math.BigDecimal cost)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getPqty

public java.math.BigDecimal getPqty()

setPqty

public void setPqty(java.math.BigDecimal pqty)

getSerialNumber

public java.lang.String getSerialNumber()

setSerialNumber

public void setSerialNumber(java.lang.String serialNumber)

getLot

public java.lang.String getLot()

setLot

public void setLot(java.lang.String lot)

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getLastChangeDate

public java.util.Date getLastChangeDate()

getEmployeeId

public java.lang.String getEmployeeId()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

isEmployeeLaborCost

public boolean isEmployeeLaborCost()

setEmployeeLaborCost

public void setEmployeeLaborCost(boolean employeeLaborCost)

getWorkInstructionSequence

public java.lang.String getWorkInstructionSequence()

setWorkInstructionSequence

public void setWorkInstructionSequence(java.lang.String workInstructionSequence)

getWorkOrderItemNumber

public java.lang.String getWorkOrderItemNumber()

setWorkOrderItemNumber

public void setWorkOrderItemNumber(java.lang.String workOrderItemNumber)

getWorkOrderNumber

public java.lang.String getWorkOrderNumber()

setWorkOrderNumber

public void setWorkOrderNumber(java.lang.String workOrderNumber)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderItemToIssueResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderItemToIssueResult

java.lang.Object
    extended by  bb.common.WorkOrderItemToIssueResult
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderItemToIssueResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DELIVERY
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_PK
static java.lang.String | ORDER_BY_STARTDATE
static java.lang.String | ORDER_BY_VENDORID
Constructor Summary
WorkOrderItemToIssueResult()
Method Summary
java.math.BigDecimal | getAsm()
java.util.Date | getDelivery()
java.lang.String | getDescription()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
WorkOrderItemPK | getPk()
java.math.BigDecimal | getQty()
java.util.Date | getStartDate()
java.lang.String | getVendorID()
void | setAsm(java.math.BigDecimal asm)
void | setDelivery(java.util.Date delivery)
void | setDescription(java.lang.String description)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(WorkOrderItemPK pk)
void | setQty(java.math.BigDecimal qty)
void | setStartDate(java.util.Date startDate)
void | setVendorID(java.lang.String vendorID)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_PK

public static final java.lang.String ORDER_BY_PK
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values

ORDER_BY_STARTDATE

public static final java.lang.String ORDER_BY_STARTDATE
See Also:
Constant Field Values

ORDER_BY_DELIVERY

public static final java.lang.String ORDER_BY_DELIVERY
See Also:
Constant Field Values
Constructor Detail

WorkOrderItemToIssueResult

public WorkOrderItemToIssueResult()
Method Detail

getAsm

public java.math.BigDecimal getAsm()

setAsm

public void setAsm(java.math.BigDecimal asm)

getDelivery

public java.util.Date getDelivery()

setDelivery

public void setDelivery(java.util.Date delivery)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPk

public WorkOrderItemPK getPk()

setPk

public void setPk(WorkOrderItemPK pk)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

getStartDate

public java.util.Date getStartDate()

setStartDate

public void setStartDate(java.util.Date startDate)

getVendorID

public java.lang.String getVendorID()

setVendorID

public void setVendorID(java.lang.String vendorID)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.WorkOrderItemVO
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderItemVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
WorkOrderItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getActual()
java.lang.String | getChangeOrder()
java.math.BigDecimal | getCostPerUnit()
java.util.Date | getDateRequired()
int | getDelayDays()
java.lang.String | getDescription()
java.util.Date | getDesired()
java.math.BigDecimal | getDiscount()
java.lang.String | getDwg()
java.math.BigDecimal | getExtendPrice()
java.math.BigDecimal | getFreight()
java.lang.String | getHold()
java.math.BigDecimal | getHqa()
java.math.BigDecimal | getLeadTime()
java.math.BigDecimal | getList()
java.lang.String | getLocation()
java.lang.String | getMfg()
java.lang.String | getMfgStatus()
java.lang.String | getModelNumber()
java.lang.String | getMpn()
java.lang.String | getMpnRev()
java.util.Date | getOriginal()
java.math.BigDecimal | getOriginalCost()
java.math.BigDecimal | getOverPercent()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.lang.String | getPartUnit()
WorkOrderItemPK | getPk()
java.lang.String | getPriority()
java.lang.String | getQr()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getQuantityAsm()
java.util.Set | getRefDocOnes()
java.util.Set | getRefDocTwoes()
java.lang.String | getReferenceDoc1()
java.lang.String | getReferenceDoc2()
java.lang.String | getRelatedDoc()
java.lang.String | getReviewDescription()
java.lang.String | getReviewedBy()
java.util.Date | getReviewedDate()
java.lang.String | getRevision()
java.lang.String | getSetId()
java.lang.String | getShipVia()
java.util.Date | getStartDate()
java.lang.String | getStatus()
java.math.BigDecimal | getStdCostPerUnit()
java.math.BigDecimal | getTaxRate()
java.lang.String | getUnit()
java.lang.String | getWiFlag()
java.math.BigDecimal | getWoDisc()
java.math.BigDecimal | getWoMade()
java.math.BigDecimal | getWoOpen()
java.lang.String | getWorkOrderItemComments()
java.lang.String | getWorkOrderItemPrivateNotes()
java.math.BigDecimal | getWoSub()
java.math.BigDecimal | getWoTax()
java.math.BigDecimal | getWoTotal()
java.lang.String | getWowiCurrentInstrucationSeq()
java.lang.String | getWowiCurrentInstrucationSeqWC()
java.lang.String | getWowiCurrentInstrucationSeqWCDesc()
int | hashCode()
boolean | isCostAlarm()
boolean | isIcrRequiredWhenReceiverNa()
boolean | isMasterWorkOrder()
void | setActual(java.util.Date actual)
void | setChangeOrder(java.lang.String changeOrder)
void | setCostAlarm(boolean costAlarm)
void | setCostPerUnit(java.math.BigDecimal costPerUnit)
void | setDateRequired(java.util.Date dateRequired)
void | setDelayDays(int delayDays)
void | setDescription(java.lang.String description)
void | setDesired(java.util.Date desired)
void | setDiscount(java.math.BigDecimal discount)
void | setDwg(java.lang.String dwg)
void | setExtendPrice(java.math.BigDecimal extendPrice)
void | setFreight(java.math.BigDecimal freight)
void | setHold(java.lang.String hold)
void | setHqa(java.math.BigDecimal hqa)
void | setIcrRequiredWhenReceiverNa(boolean icrRequiredWhenReceiverNa)
void | setLeadTime(java.math.BigDecimal leadTime)
void | setList(java.math.BigDecimal list)
void | setLocation(java.lang.String location)
void | setMasterWorkOrder(boolean masterWorkOrder)
void | setMfg(java.lang.String mfg)
void | setMfgStatus(java.lang.String mfgStatus)
void | setModelNumber(java.lang.String modelNumber)
void | setMpn(java.lang.String mpn)
void | setMpnRev(java.lang.String mpnRev)
void | setOriginal(java.util.Date original)
void | setOriginalCost(java.math.BigDecimal originalCost)
void | setOverPercent(java.math.BigDecimal overPercent)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPartUnit(java.lang.String partUnit)
void | setPk(WorkOrderItemPK pk)
void | setPriority(java.lang.String priority)
void | setQr(java.lang.String qr)
void | setQuantity(java.math.BigDecimal quantity)
void | setQuantityAsm(java.math.BigDecimal quantityAsm)
void | setRefDocOnes(java.util.Set refDocOnes)
void | setRefDocTwoes(java.util.Set refDocTwoes)
void | setReferenceDoc1(java.lang.String referenceDoc1)
void | setReferenceDoc2(java.lang.String referenceDoc2)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setReviewDescription(java.lang.String reviewDescription)
void | setReviewedBy(java.lang.String reviewedBy)
void | setReviewedDate(java.util.Date reviewedDate)
void | setRevision(java.lang.String revision)
void | setSetId(java.lang.String setId)
void | setShipVia(java.lang.String shipVia)
void | setStartDate(java.util.Date startDate)
void | setStatus(java.lang.String status)
void | setStdCostPerUnit(java.math.BigDecimal stdCostPerUnit)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setUnit(java.lang.String unit)
void | setWiFlag(java.lang.String wiFlag)
void | setWoDisc(java.math.BigDecimal woDisc)
void | setWoMade(java.math.BigDecimal woMade)
void | setWoOpen(java.math.BigDecimal woOpen)
void | setWorkOrderItemComments(java.lang.String workOrderItemComments)
void | setWorkOrderItemPrivateNotes(java.lang.String workOrderItemPrivateNotes)
void | setWoSub(java.math.BigDecimal woSub)
void | setWoTax(java.math.BigDecimal woTax)
void | setWoTotal(java.math.BigDecimal woTotal)
void | setWowiCurrentInstrucationSeq(java.lang.String wowiCurrentInstrucationSeq)
void | setWowiCurrentInstrucationSeqWC(java.lang.String wowiCurrentInstrucationSeqWC)
void | setWowiCurrentInstrucationSeqWCDesc(java.lang.String wowiCurrentInstrucationSeqWCDesc)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WorkOrderItemVO

public WorkOrderItemVO()
Method Detail

getPk

public WorkOrderItemPK getPk()

setPk

public void setPk(WorkOrderItemPK pk)

getSetId

public java.lang.String getSetId()

setSetId

public void setSetId(java.lang.String setId)

getWoSub

public java.math.BigDecimal getWoSub()

setWoSub

public void setWoSub(java.math.BigDecimal woSub)

getWoDisc

public java.math.BigDecimal getWoDisc()

setWoDisc

public void setWoDisc(java.math.BigDecimal woDisc)

getExtendPrice

public java.math.BigDecimal getExtendPrice()

setExtendPrice

public void setExtendPrice(java.math.BigDecimal extendPrice)

getWoMade

public java.math.BigDecimal getWoMade()

setWoMade

public void setWoMade(java.math.BigDecimal woMade)

getWoOpen

public java.math.BigDecimal getWoOpen()

setWoOpen

public void setWoOpen(java.math.BigDecimal woOpen)

getWoTax

public java.math.BigDecimal getWoTax()

setWoTax

public void setWoTax(java.math.BigDecimal woTax)

getWoTotal

public java.math.BigDecimal getWoTotal()

setWoTotal

public void setWoTotal(java.math.BigDecimal woTotal)

getReferenceDoc1

public java.lang.String getReferenceDoc1()

setReferenceDoc1

public void setReferenceDoc1(java.lang.String referenceDoc1)

getReferenceDoc2

public java.lang.String getReferenceDoc2()

setReferenceDoc2

public void setReferenceDoc2(java.lang.String referenceDoc2)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getQr

public java.lang.String getQr()

setQr

public void setQr(java.lang.String qr)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getMfgStatus

public java.lang.String getMfgStatus()

setMfgStatus

public void setMfgStatus(java.lang.String mfgStatus)

getStartDate

public java.util.Date getStartDate()

setStartDate

public void setStartDate(java.util.Date startDate)

getDateRequired

public java.util.Date getDateRequired()

setDateRequired

public void setDateRequired(java.util.Date dateRequired)

getDesired

public java.util.Date getDesired()

setDesired

public void setDesired(java.util.Date desired)

getDelayDays

public int getDelayDays()

setDelayDays

public void setDelayDays(int delayDays)

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getOriginal

public java.util.Date getOriginal()

setOriginal

public void setOriginal(java.util.Date original)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getFreight

public java.math.BigDecimal getFreight()

setFreight

public void setFreight(java.math.BigDecimal freight)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getDwg

public java.lang.String getDwg()

setDwg

public void setDwg(java.lang.String dwg)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getQuantityAsm

public java.math.BigDecimal getQuantityAsm()

setQuantityAsm

public void setQuantityAsm(java.math.BigDecimal quantityAsm)

getHqa

public java.math.BigDecimal getHqa()

setHqa

public void setHqa(java.math.BigDecimal hqa)

getCostPerUnit

public java.math.BigDecimal getCostPerUnit()

setCostPerUnit

public void setCostPerUnit(java.math.BigDecimal costPerUnit)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getList

public java.math.BigDecimal getList()

setList

public void setList(java.math.BigDecimal list)

getDiscount

public java.math.BigDecimal getDiscount()

setDiscount

public void setDiscount(java.math.BigDecimal discount)

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getMfg

public java.lang.String getMfg()

setMfg

public void setMfg(java.lang.String mfg)

getMpn

public java.lang.String getMpn()

setMpn

public void setMpn(java.lang.String mpn)

getMpnRev

public java.lang.String getMpnRev()

setMpnRev

public void setMpnRev(java.lang.String mpnRev)

getWorkOrderItemComments

public java.lang.String getWorkOrderItemComments()

setWorkOrderItemComments

public void setWorkOrderItemComments(java.lang.String workOrderItemComments)

getWorkOrderItemPrivateNotes

public java.lang.String getWorkOrderItemPrivateNotes()

getRefDocOnes

public java.util.Set getRefDocOnes()

setWorkOrderItemPrivateNotes

public void setWorkOrderItemPrivateNotes(java.lang.String workOrderItemPrivateNotes)

setRefDocOnes

public void setRefDocOnes(java.util.Set refDocOnes)

getRefDocTwoes

public java.util.Set getRefDocTwoes()

setRefDocTwoes

public void setRefDocTwoes(java.util.Set refDocTwoes)

isCostAlarm

public boolean isCostAlarm()

setCostAlarm

public void setCostAlarm(boolean costAlarm)

getReviewedBy

public java.lang.String getReviewedBy()

setReviewedBy

public void setReviewedBy(java.lang.String reviewedBy)

getReviewedDate

public java.util.Date getReviewedDate()

setReviewedDate

public void setReviewedDate(java.util.Date reviewedDate)

getReviewDescription

public java.lang.String getReviewDescription()

setReviewDescription

public void setReviewDescription(java.lang.String reviewDescription)

getOriginalCost

public java.math.BigDecimal getOriginalCost()

setOriginalCost

public void setOriginalCost(java.math.BigDecimal originalCost)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getWiFlag

public java.lang.String getWiFlag()

setWiFlag

public void setWiFlag(java.lang.String wiFlag)

isMasterWorkOrder

public boolean isMasterWorkOrder()

setMasterWorkOrder

public void setMasterWorkOrder(boolean masterWorkOrder)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getActual

public java.util.Date getActual()

setActual

public void setActual(java.util.Date actual)

getOverPercent

public java.math.BigDecimal getOverPercent()

setOverPercent

public void setOverPercent(java.math.BigDecimal overPercent)

getStdCostPerUnit

public java.math.BigDecimal getStdCostPerUnit()

setStdCostPerUnit

public void setStdCostPerUnit(java.math.BigDecimal stdCostPerUnit)

getWowiCurrentInstrucationSeq

public java.lang.String getWowiCurrentInstrucationSeq()

setWowiCurrentInstrucationSeq

public void setWowiCurrentInstrucationSeq(java.lang.String wowiCurrentInstrucationSeq)

getWowiCurrentInstrucationSeqWC

public java.lang.String getWowiCurrentInstrucationSeqWC()

setWowiCurrentInstrucationSeqWC

public void setWowiCurrentInstrucationSeqWC(java.lang.String wowiCurrentInstrucationSeqWC)

getWowiCurrentInstrucationSeqWCDesc

public java.lang.String getWowiCurrentInstrucationSeqWCDesc()

setWowiCurrentInstrucationSeqWCDesc

public void setWowiCurrentInstrucationSeqWCDesc(java.lang.String wowiCurrentInstrucationSeqWCDesc)

getHold

public java.lang.String getHold()

setHold

public void setHold(java.lang.String hold)

getPartUnit

public java.lang.String getPartUnit()

setPartUnit

public void setPartUnit(java.lang.String partUnit)

getLeadTime

public java.math.BigDecimal getLeadTime()

setLeadTime

public void setLeadTime(java.math.BigDecimal leadTime)

isIcrRequiredWhenReceiverNa

public boolean isIcrRequiredWhenReceiverNa()

setIcrRequiredWhenReceiverNa

public void setIcrRequiredWhenReceiverNa(boolean icrRequiredWhenReceiverNa)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderItemWCLoadResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderItemWCLoadResult

java.lang.Object
    extended by  bb.common.WorkOrderItemWCLoadResult
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderItemWCLoadResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkOrderItemWCLoadResult()
Method Summary
java.util.Date | getDelivery()
java.lang.String | getDescription()
java.util.List<WorkOrderItemSeqWCLoadResult> | getItems()
BB2Part | getPart()
WorkOrderItemPK | getPk()
java.math.BigDecimal | getQty()
java.util.Date | getStartDate()
boolean | isFinishable()
void | setDelivery(java.util.Date delivery)
void | setDescription(java.lang.String description)
void | setFinishable(boolean finishable)
void | setItems(java.util.List<WorkOrderItemSeqWCLoadResult> items)
void | setPart(BB2Part part)
void | setPk(WorkOrderItemPK pk)
void | setQty(java.math.BigDecimal qty)
void | setStartDate(java.util.Date startDate)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkOrderItemWCLoadResult

public WorkOrderItemWCLoadResult()
Method Detail

getDelivery

public java.util.Date getDelivery()

setDelivery

public void setDelivery(java.util.Date delivery)

getItems

public java.util.List<WorkOrderItemSeqWCLoadResult> getItems()

setItems

public void setItems(java.util.List<WorkOrderItemSeqWCLoadResult> items)

getPart

public BB2Part getPart()

setPart

public void setPart(BB2Part part)

getPk

public WorkOrderItemPK getPk()

setPk

public void setPk(WorkOrderItemPK pk)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

getStartDate

public java.util.Date getStartDate()

setStartDate

public void setStartDate(java.util.Date startDate)

isFinishable

public boolean isFinishable()

setFinishable

public void setFinishable(boolean finishable)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderListResult

java.lang.Object
    extended by  bb.common.WorkOrderListResult
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_PROJECT
static java.lang.String | ORDER_BY_STATUS
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_VENDORNAME
static java.lang.String | ORDER_BY_WONUMBER
Constructor Summary
WorkOrderListResult()
Method Summary
java.lang.String | getChangeOrder()
java.lang.String | getComments()
java.util.Date | getDelivery()
java.lang.String | getOriginator()
java.lang.String | getPriority()
java.lang.String | getProject()
java.lang.String | getStatus()
java.lang.String | getVendorId()
java.lang.String | getVendorName()
java.util.Date | getWoDate()
java.lang.String | getWoNumber()
void | setChangeOrder(java.lang.String changeOrder)
void | setComments(java.lang.String comments)
void | setDelivery(java.util.Date delivery)
void | setOriginator(java.lang.String originator)
void | setPriority(java.lang.String priority)
void | setProject(java.lang.String project)
void | setStatus(java.lang.String status)
void | setVendorId(java.lang.String vendorId)
void | setVendorName(java.lang.String vendorName)
void | setWoDate(java.util.Date woDate)
void | setWoNumber(java.lang.String woNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_WONUMBER

public static final java.lang.String ORDER_BY_WONUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_VENDORNAME

public static final java.lang.String ORDER_BY_VENDORNAME
See Also:
Constant Field Values

ORDER_BY_PROJECT

public static final java.lang.String ORDER_BY_PROJECT
See Also:
Constant Field Values

ORDER_BY_STATUS

public static final java.lang.String ORDER_BY_STATUS
See Also:
Constant Field Values
Constructor Detail

WorkOrderListResult

public WorkOrderListResult()
Method Detail

getWoNumber

public java.lang.String getWoNumber()

getWoDate

public java.util.Date getWoDate()

getDelivery

public java.util.Date getDelivery()

getVendorId

public java.lang.String getVendorId()

getVendorName

public java.lang.String getVendorName()

getPriority

public java.lang.String getPriority()

getProject

public java.lang.String getProject()

getComments

public java.lang.String getComments()

getStatus

public java.lang.String getStatus()

getOriginator

public java.lang.String getOriginator()

getChangeOrder

public java.lang.String getChangeOrder()

setWoNumber

public void setWoNumber(java.lang.String woNumber)

setWoDate

public void setWoDate(java.util.Date woDate)

setDelivery

public void setDelivery(java.util.Date delivery)

setVendorId

public void setVendorId(java.lang.String vendorId)

setVendorName

public void setVendorName(java.lang.String vendorName)

setPriority

public void setPriority(java.lang.String priority)

setProject

public void setProject(java.lang.String project)

setComments

public void setComments(java.lang.String comments)

setStatus

public void setStatus(java.lang.String status)

setOriginator

public void setOriginator(java.lang.String originator)

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderNotSetupResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderNotSetupResult

java.lang.Object
    extended by  bb.common.WorkOrderOnDemandResult
        extended by  bb.common.WorkOrderNotSetupResult
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderNotSetupResult
extends WorkOrderOnDemandResult
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkOrderNotSetupResult()
Method Summary
Methods inherited from class bb.common.WorkOrderOnDemandResult
getArriveDate, getDelayDays, getDeliveryDate, getDescription, getId, getLocations, getPartFrom, getPartPk, getQuantityAsm, getQuantityDemanded, getQuantityIssued, getQuantityNotAsm, getQuantityOnDemand, getRefDoc1, getRefDoc2, getStartDate, getWorkOrderItemPk, getWorkOrderItemQuantity, setArriveDate, setDelayDays, setDeliveryDate, setDescription, setId, setLocations, setPartFrom, setPartPk, setQuantityAsm, setQuantityDemanded, setQuantityIssued, setQuantityNotAsm, setQuantityOnDemand, setRefDoc1, setRefDoc2, setStartDate, setWorkOrderItemPk, setWorkOrderItemQuantity
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkOrderNotSetupResult

public WorkOrderNotSetupResult()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderOnDemandResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderOnDemandResult

java.lang.Object
    extended by  bb.common.WorkOrderOnDemandResult
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
WorkOrderNotSetupResult
public class WorkOrderOnDemandResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkOrderOnDemandResult()
Method Summary
java.util.Date | getArriveDate()
int | getDelayDays()
java.util.Date | getDeliveryDate()
java.lang.String | getDescription()
java.lang.String | getId()
java.util.Map | getLocations()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.math.BigDecimal | getQuantityAsm()
java.math.BigDecimal | getQuantityDemanded()
java.math.BigDecimal | getQuantityIssued()
java.math.BigDecimal | getQuantityNotAsm()
java.math.BigDecimal | getQuantityOnDemand()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.util.Date | getStartDate()
WorkOrderItemPK | getWorkOrderItemPk()
java.math.BigDecimal | getWorkOrderItemQuantity()
void | setArriveDate(java.util.Date arriveDate)
void | setDelayDays(int delayDays)
void | setDeliveryDate(java.util.Date deliveryDate)
void | setDescription(java.lang.String description)
void | setId(java.lang.String id)
void | setLocations(java.util.Map locations)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setQuantityAsm(java.math.BigDecimal quantityAsm)
void | setQuantityDemanded(java.math.BigDecimal quantityDemanded)
void | setQuantityIssued(java.math.BigDecimal quantityIssued)
void | setQuantityNotAsm(java.math.BigDecimal quantityNotAsm)
void | setQuantityOnDemand(java.math.BigDecimal quantityOnDemand)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setStartDate(java.util.Date startDate)
void | setWorkOrderItemPk(WorkOrderItemPK workOrderItemPk)
void | setWorkOrderItemQuantity(java.math.BigDecimal workOrderItemQuantity)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkOrderOnDemandResult

public WorkOrderOnDemandResult()
Method Detail

getPartPk

public PartPK getPartPk()

setPartPk

public void setPartPk(PartPK partPk)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getWorkOrderItemPk

public WorkOrderItemPK getWorkOrderItemPk()

setWorkOrderItemPk

public void setWorkOrderItemPk(WorkOrderItemPK workOrderItemPk)

getWorkOrderItemQuantity

public java.math.BigDecimal getWorkOrderItemQuantity()

setWorkOrderItemQuantity

public void setWorkOrderItemQuantity(java.math.BigDecimal workOrderItemQuantity)

setQuantityAsm

public void setQuantityAsm(java.math.BigDecimal quantityAsm)

getQuantityNotAsm

public java.math.BigDecimal getQuantityNotAsm()

setQuantityNotAsm

public void setQuantityNotAsm(java.math.BigDecimal quantityNotAsm)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getQuantityDemanded

public java.math.BigDecimal getQuantityDemanded()

setQuantityDemanded

public void setQuantityDemanded(java.math.BigDecimal quantityDemanded)

getQuantityIssued

public java.math.BigDecimal getQuantityIssued()

setQuantityIssued

public void setQuantityIssued(java.math.BigDecimal quantityIssued)

getQuantityOnDemand

public java.math.BigDecimal getQuantityOnDemand()

setQuantityOnDemand

public void setQuantityOnDemand(java.math.BigDecimal quantityOnDemand)

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getDeliveryDate

public java.util.Date getDeliveryDate()

setDeliveryDate

public void setDeliveryDate(java.util.Date deliveryDate)

getDelayDays

public int getDelayDays()

getQuantityAsm

public java.math.BigDecimal getQuantityAsm()

setDelayDays

public void setDelayDays(int delayDays)

getStartDate

public java.util.Date getStartDate()

setStartDate

public void setStartDate(java.util.Date startDate)

getArriveDate

public java.util.Date getArriveDate()

setArriveDate

public void setArriveDate(java.util.Date arriveDate)

getLocations

public java.util.Map getLocations()

setLocations

public void setLocations(java.util.Map locations)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderOnOrderResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderOnOrderResult

java.lang.Object
    extended by  bb.common.WorkOrderOnOrderResult
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderOnOrderResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkOrderOnOrderResult()
Method Summary
java.util.Date | getArriveDate()
int | getDelayDays()
java.util.Date | getDeliveryDate()
java.lang.String | getDescription()
java.lang.String | getId()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.math.BigDecimal | getQuantityAsm()
java.math.BigDecimal | getQuantityOnOrder()
java.math.BigDecimal | getQuantityOrdered()
java.lang.String | getRefDoc1()
java.lang.String | getRefDoc2()
java.lang.String | getShipToId()
WorkOrderItemPK | getWorkOrderItemPk()
void | setArriveDate(java.util.Date arriveDate)
void | setDelayDays(int delayDays)
void | setDeliveryDate(java.util.Date deliveryDate)
void | setDescription(java.lang.String description)
void | setId(java.lang.String id)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setQuantityAsm(java.math.BigDecimal quantityAsm)
void | setQuantityOnOrder(java.math.BigDecimal quantityOnOrder)
void | setQuantityOrdered(java.math.BigDecimal quantityOrdered)
void | setRefDoc1(java.lang.String refDoc1)
void | setRefDoc2(java.lang.String refDoc2)
void | setShipToId(java.lang.String shipToId)
void | setWorkOrderItemPk(WorkOrderItemPK workOrderItemPk)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkOrderOnOrderResult

public WorkOrderOnOrderResult()
Method Detail

getPartPk

public PartPK getPartPk()

setPartPk

public void setPartPk(PartPK partPk)

getWorkOrderItemPk

public WorkOrderItemPK getWorkOrderItemPk()

setWorkOrderItemPk

public void setWorkOrderItemPk(WorkOrderItemPK workOrderItemPk)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getRefDoc1

public java.lang.String getRefDoc1()

setRefDoc1

public void setRefDoc1(java.lang.String refDoc1)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getQuantityOrdered

public java.math.BigDecimal getQuantityOrdered()

setQuantityOrdered

public void setQuantityOrdered(java.math.BigDecimal quantityOrdered)

getQuantityAsm

public java.math.BigDecimal getQuantityAsm()

setQuantityAsm

public void setQuantityAsm(java.math.BigDecimal quantityAsm)

getQuantityOnOrder

public java.math.BigDecimal getQuantityOnOrder()

setQuantityOnOrder

public void setQuantityOnOrder(java.math.BigDecimal quantityOnOrder)

getId

public java.lang.String getId()

setId

public void setId(java.lang.String id)

getDeliveryDate

public java.util.Date getDeliveryDate()

setDeliveryDate

public void setDeliveryDate(java.util.Date deliveryDate)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getDelayDays

public int getDelayDays()

setDelayDays

public void setDelayDays(int delayDays)

getShipToId

public java.lang.String getShipToId()

setShipToId

public void setShipToId(java.lang.String shipToId)

getArriveDate

public java.util.Date getArriveDate()

setArriveDate

public void setArriveDate(java.util.Date arriveDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderOnTimeItemResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderOnTimeItemResult

java.lang.Object
    extended by  bb.common.WorkOrderOnTimeItemResult
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderOnTimeItemResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | FISCAL_YEAR
static java.lang.String | MONTH_12_AVG
static java.lang.String | YEAR_TO_DATE
Constructor Summary
WorkOrderOnTimeItemResult()
Method Summary
java.math.BigDecimal | getDays()
java.lang.String | getMonth()
java.math.BigDecimal | getNotRecItemsOnTimeQty()
java.math.BigDecimal | getNotRecTotalOnTime()
int | getRecItemsOnTimeCount()
java.math.BigDecimal | getRecTotalOnTime()
int | getWoItemCount()
java.math.BigDecimal | getWoTotal()
void | setDays(java.math.BigDecimal days)
void | setMonth(java.lang.String month)
void | setNotRecItemsOnTimeQty(java.math.BigDecimal notRecItemsOnTimeQty)
void | setNotRecTotalOnTime(java.math.BigDecimal notRecTotalOnTime)
void | setRecItemsOnTimeCount(int recItemsOnTimeCount)
void | setRecTotalOnTime(java.math.BigDecimal recTotalOnTime)
void | setWoItemCount(int woItemCount)
void | setWoTotal(java.math.BigDecimal woTotal)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

FISCAL_YEAR

public static final java.lang.String FISCAL_YEAR
See Also:
Constant Field Values

YEAR_TO_DATE

public static final java.lang.String YEAR_TO_DATE
See Also:
Constant Field Values

MONTH_12_AVG

public static final java.lang.String MONTH_12_AVG
See Also:
Constant Field Values
Constructor Detail

WorkOrderOnTimeItemResult

public WorkOrderOnTimeItemResult()
Method Detail

getDays

public java.math.BigDecimal getDays()

setDays

public void setDays(java.math.BigDecimal days)

getMonth

public java.lang.String getMonth()

setMonth

public void setMonth(java.lang.String month)

getNotRecItemsOnTimeQty

public java.math.BigDecimal getNotRecItemsOnTimeQty()

setNotRecItemsOnTimeQty

public void setNotRecItemsOnTimeQty(java.math.BigDecimal notRecItemsOnTimeQty)

getNotRecTotalOnTime

public java.math.BigDecimal getNotRecTotalOnTime()

setNotRecTotalOnTime

public void setNotRecTotalOnTime(java.math.BigDecimal notRecTotalOnTime)

getRecItemsOnTimeCount

public int getRecItemsOnTimeCount()

setRecItemsOnTimeCount

public void setRecItemsOnTimeCount(int recItemsOnTimeCount)

getRecTotalOnTime

public java.math.BigDecimal getRecTotalOnTime()

setRecTotalOnTime

public void setRecTotalOnTime(java.math.BigDecimal recTotalOnTime)

getWoItemCount

public int getWoItemCount()

setWoItemCount

public void setWoItemCount(int woItemCount)

getWoTotal

public java.math.BigDecimal getWoTotal()

setWoTotal

public void setWoTotal(java.math.BigDecimal woTotal)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderOnTimeResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderOnTimeResult

java.lang.Object
    extended by  bb.common.WorkOrderOnTimeResult
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderOnTimeResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkOrderOnTimeResult()
Method Summary
java.lang.String | getCurrency()
int | getDay1()
int | getDay2()
java.util.List<WorkOrderOnTimeItemResult> | getItems()
void | setCurrency(java.lang.String currency)
void | setDay1(int day1)
void | setDay2(int day2)
void | setItems(java.util.List<WorkOrderOnTimeItemResult> items)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkOrderOnTimeResult

public WorkOrderOnTimeResult()
Method Detail

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getItems

public java.util.List<WorkOrderOnTimeItemResult> getItems()

setItems

public void setItems(java.util.List<WorkOrderOnTimeItemResult> items)

getDay1

public int getDay1()

setDay1

public void setDay1(int day1)

getDay2

public int getDay2()

setDay2

public void setDay2(int day2)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderOverIssueListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderOverIssueListResult

java.lang.Object
    extended by  bb.common.WorkOrderOverIssueListResult
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderOverIssueListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_ISSUEQUANTITY
static java.lang.String | ORDER_BY_PARTDESCRIPTION
static java.lang.String | ORDER_BY_PARTPK
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_WORKORDERNUMBER
Constructor Summary
WorkOrderOverIssueListResult()
Method Summary
java.math.BigDecimal | getBomQty()
java.util.Date | getDateRequired()
java.math.BigDecimal | getIssueQuantity()
java.util.Set<java.util.Map<java.lang.String,java.math.BigDecimal>> | getNcr()
java.lang.String | getPartDescription()
java.lang.String | getPartFrom()
PartPK | getPartPk()
java.math.BigDecimal | getSetupQty()
java.util.Date | getStartDate()
java.lang.String | getVendorId()
java.lang.String | getWorkOrderItemNumber()
java.lang.String | getWorkOrderNumber()
void | setBomQty(java.math.BigDecimal bomQty)
void | setDateRequired(java.util.Date dateRequired)
void | setIssueQuantity(java.math.BigDecimal issueQuantity)
void | setNcr(java.util.Set<java.util.Map<java.lang.String,java.math.BigDecimal>> ncr)
void | setPartDescription(java.lang.String partDescription)
void | setPartFrom(java.lang.String partFrom)
void | setPartPk(PartPK partPk)
void | setSetupQty(java.math.BigDecimal setupQty)
void | setStartDate(java.util.Date startDate)
void | setVendorId(java.lang.String vendorId)
void | setWorkOrderItemNumber(java.lang.String workOrderItemNumber)
void | setWorkOrderNumber(java.lang.String workOrderNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_WORKORDERNUMBER

public static final java.lang.String ORDER_BY_WORKORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values

ORDER_BY_PARTPK

public static final java.lang.String ORDER_BY_PARTPK
See Also:
Constant Field Values

ORDER_BY_ISSUEQUANTITY

public static final java.lang.String ORDER_BY_ISSUEQUANTITY
See Also:
Constant Field Values

ORDER_BY_PARTDESCRIPTION

public static final java.lang.String ORDER_BY_PARTDESCRIPTION
See Also:
Constant Field Values
Constructor Detail

WorkOrderOverIssueListResult

public WorkOrderOverIssueListResult()
Method Detail

getBomQty

public java.math.BigDecimal getBomQty()

setBomQty

public void setBomQty(java.math.BigDecimal bomQty)

getIssueQuantity

public java.math.BigDecimal getIssueQuantity()

setIssueQuantity

public void setIssueQuantity(java.math.BigDecimal issueQuantity)

getPartDescription

public java.lang.String getPartDescription()

setPartDescription

public void setPartDescription(java.lang.String partDescription)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getSetupQty

public java.math.BigDecimal getSetupQty()

setSetupQty

public void setSetupQty(java.math.BigDecimal setupQty)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getWorkOrderItemNumber

public java.lang.String getWorkOrderItemNumber()

setWorkOrderItemNumber

public void setWorkOrderItemNumber(java.lang.String workOrderItemNumber)

getWorkOrderNumber

public java.lang.String getWorkOrderNumber()

setWorkOrderNumber

public void setWorkOrderNumber(java.lang.String workOrderNumber)

getNcr

public java.util.Set<java.util.Map<java.lang.String,java.math.BigDecimal>> getNcr()

setNcr

public void setNcr(java.util.Set<java.util.Map<java.lang.String,java.math.BigDecimal>> ncr)

getPartPk

public PartPK getPartPk()

setPartPk

public void setPartPk(PartPK partPk)

getDateRequired

public java.util.Date getDateRequired()

setDateRequired

public void setDateRequired(java.util.Date dateRequired)

getStartDate

public java.util.Date getStartDate()

setStartDate

public void setStartDate(java.util.Date startDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderQueryInfo

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderQueryInfo

java.lang.Object
    extended by  bb.common.WorkOrderQueryInfo
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderQueryInfo
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkOrderQueryInfo()
Method Summary
java.lang.String | getCustomerId()
java.lang.String | getDescription()
java.sql.Date | getDueDate()
java.lang.String | getPartNumber()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getQuantityAsm()
java.lang.String | getRelatedDoc()
java.sql.Date | getStartDate()
java.lang.String | getStatus()
java.lang.String | getWI()
java.lang.String | getWO()
void | setCustomerId(java.lang.String customerId)
void | setDescription(java.lang.String description)
void | setDueDate(java.sql.Date dueDate)
void | setPartNumber(java.lang.String partNumber)
void | setQuantity(java.math.BigDecimal quantity)
void | setQuantityAsm(java.math.BigDecimal quantityAsm)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setStartDate(java.sql.Date startDate)
void | setStatus(java.lang.String status)
void | setWO(java.lang.String wo)
void | setWOI(java.lang.String wi)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkOrderQueryInfo

public WorkOrderQueryInfo()
Method Detail

getStartDate

public java.sql.Date getStartDate()

getDueDate

public java.sql.Date getDueDate()

getWO

public java.lang.String getWO()

getWI

public java.lang.String getWI()

getPartNumber

public java.lang.String getPartNumber()

getDescription

public java.lang.String getDescription()

getStatus

public java.lang.String getStatus()

getRelatedDoc

public java.lang.String getRelatedDoc()

getCustomerId

public java.lang.String getCustomerId()

getQuantity

public java.math.BigDecimal getQuantity()

getQuantityAsm

public java.math.BigDecimal getQuantityAsm()

setStartDate

public void setStartDate(java.sql.Date startDate)

setDueDate

public void setDueDate(java.sql.Date dueDate)

setWO

public void setWO(java.lang.String wo)

setWOI

public void setWOI(java.lang.String wi)

setPartNumber

public void setPartNumber(java.lang.String partNumber)

setDescription

public void setDescription(java.lang.String description)

setStatus

public void setStatus(java.lang.String status)

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

setCustomerId

public void setCustomerId(java.lang.String customerId)

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

setQuantityAsm

public void setQuantityAsm(java.math.BigDecimal quantityAsm)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderReceiverVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderReceiverVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.WorkOrderReceiverVO
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderReceiverVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkOrderReceiverVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCompanyUnitId()
java.lang.String | getCondition()
java.math.BigDecimal | getCost()
java.util.Date | getDateMade()
java.lang.String | getDescription()
java.math.BigDecimal | getEmployeeLaborCost()
java.lang.Long | getIi()
java.lang.String | getIrNumber()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getLocation()
java.lang.String | getLot()
java.lang.String | getModelNumber()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getQtyAssy()
java.lang.String | getRefDoc2()
java.lang.String | getRevision()
java.lang.String | getSerial()
java.math.BigDecimal | getStdCost()
java.util.Map | getTrackings()
java.lang.String | getTransactionNumber()
java.lang.String | getUnit()
java.math.BigDecimal | getWoicCost()
java.math.BigDecimal | getWoisCost()
java.math.BigDecimal | getWoisStdCost()
java.lang.String | getWorkOrderItemNumber()
java.lang.String | getWorkOrderNumber()
int | hashCode()
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setCondition(java.lang.String condition)
void | setCost(java.math.BigDecimal cost)
void | setDateMade(java.util.Date dateMade)
void | setDescription(java.lang.String description)
void | setEmployeeLaborCost(java.math.BigDecimal employeeLaborCost)
void | setIi(java.lang.Long ii)
void | setIrNumber(java.lang.String irNumber)
void | setLastChangeDate(java.util.Date LastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLocation(java.lang.String location)
void | setLot(java.lang.String lot)
void | setModelNumber(java.lang.String modelNumber)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setQtyAssy(java.math.BigDecimal qtyAssy)
void | setRefDoc2(java.lang.String refDoc2)
void | setRevision(java.lang.String revision)
void | setSerial(java.lang.String serial)
void | setStdCost(java.math.BigDecimal stdCost)
void | setTrackings(java.util.Map trackings)
void | setTransactionNumber(java.lang.String transactionNumber)
void | setUnit(java.lang.String unit)
void | setWoicCost(java.math.BigDecimal woicCost)
void | setWoisCost(java.math.BigDecimal woisCost)
void | setWoisStdCost(java.math.BigDecimal woisStdCost)
void | setWorkOrderItemNumber(java.lang.String workOrderItemNumber)
void | setWorkOrderNumber(java.lang.String workOrderNumber)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WorkOrderReceiverVO

public WorkOrderReceiverVO()
default constructor

Method Detail

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date LastChangeDate)

getRefDoc2

public java.lang.String getRefDoc2()

setRefDoc2

public void setRefDoc2(java.lang.String refDoc2)

getDateMade

public java.util.Date getDateMade()

setDateMade

public void setDateMade(java.util.Date dateMade)

getQtyAssy

public java.math.BigDecimal getQtyAssy()

setQtyAssy

public void setQtyAssy(java.math.BigDecimal qtyAssy)

getCondition

public java.lang.String getCondition()

setCondition

public void setCondition(java.lang.String condition)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getModelNumber

public java.lang.String getModelNumber()

setModelNumber

public void setModelNumber(java.lang.String modelNumber)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getCost

public java.math.BigDecimal getCost()

setCost

public void setCost(java.math.BigDecimal cost)

getUnit

public java.lang.String getUnit()

setUnit

public void setUnit(java.lang.String unit)

getSerial

public java.lang.String getSerial()

setSerial

public void setSerial(java.lang.String serial)

getLot

public java.lang.String getLot()

setLot

public void setLot(java.lang.String lot)

getTransactionNumber

public java.lang.String getTransactionNumber()

setTransactionNumber

public void setTransactionNumber(java.lang.String transactionNumber)

getWoicCost

public java.math.BigDecimal getWoicCost()

setWoicCost

public void setWoicCost(java.math.BigDecimal woicCost)

getWoisCost

public java.math.BigDecimal getWoisCost()

setWoisCost

public void setWoisCost(java.math.BigDecimal woisCost)

getEmployeeLaborCost

public java.math.BigDecimal getEmployeeLaborCost()

setEmployeeLaborCost

public void setEmployeeLaborCost(java.math.BigDecimal employeeLaborCost)

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getWorkOrderItemNumber

public java.lang.String getWorkOrderItemNumber()

setWorkOrderItemNumber

public void setWorkOrderItemNumber(java.lang.String workOrderItemNumber)

getWorkOrderNumber

public java.lang.String getWorkOrderNumber()

setWorkOrderNumber

public void setWorkOrderNumber(java.lang.String workOrderNumber)

getStdCost

public java.math.BigDecimal getStdCost()

setStdCost

public void setStdCost(java.math.BigDecimal stdCost)

getWoisStdCost

public java.math.BigDecimal getWoisStdCost()

setWoisStdCost

public void setWoisStdCost(java.math.BigDecimal woisStdCost)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getIrNumber

public java.lang.String getIrNumber()

setIrNumber

public void setIrNumber(java.lang.String irNumber)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getTrackings

public java.util.Map getTrackings()

setTrackings

public void setTrackings(java.util.Map trackings)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderTimeCardVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderTimeCardVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.WorkOrderTimeCardVO
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderTimeCardVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_EMPLOYEEID
static java.lang.String | ORDER_BY_EMPLOYEENAME
static java.lang.String | ORDER_BY_II
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_VENDORID
static java.lang.String | ORDER_BY_WORKCENTER
static java.lang.String | ORDER_BY_WORKINSCTRUCTIONSEQUENCE
static java.lang.String | ORDER_BY_WORKORDERITEMNUMBER
static java.lang.String | ORDER_BY_WORKORDERNUMBER
Constructor Summary
WorkOrderTimeCardVO()
Method Summary
java.lang.String | getEmployeeId()
java.lang.String | getEmployeeName()
java.lang.Long | getIi()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.math.BigDecimal | getQuantity()
java.math.BigDecimal | getRejectQty()
java.lang.String | getRevision()
java.lang.String | getSpecialProcess()
java.lang.String | getStatus()
java.util.Date | getTimeOff()
java.util.Date | getTimeOn()
java.lang.String | getVendorId()
short | getWoicItem()
short | getWoisItem()
java.lang.String | getWorkCenter()
java.lang.String | getWorkInsctructionSequence()
java.lang.String | getWorkOrderItemNumber()
java.lang.String | getWorkOrderNumber()
boolean | isFinished()
void | setEmployeeId(java.lang.String employeeId)
void | setEmployeeName(java.lang.String employeeName)
void | setFinished(boolean finished)
void | setIi(java.lang.Long ii)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setQuantity(java.math.BigDecimal quantity)
void | setRejectQty(java.math.BigDecimal rejectQty)
void | setRevision(java.lang.String revision)
void | setSpecialProcess(java.lang.String specialProcess)
void | setStatus(java.lang.String status)
void | setTimeOff(java.util.Date timeOff)
void | setTimeOn(java.util.Date timeOn)
void | setVendorId(java.lang.String vendorId)
void | setWoicItem(short woicItem)
void | setWoisItem(short woisItem)
void | setWorkCenter(java.lang.String workCenter)
void | setWorkInsctructionSequence(java.lang.String workInsctructionSequence)
void | setWorkOrderItemNumber(java.lang.String workOrderItemNumber)
void | setWorkOrderNumber(java.lang.String workOrderNumber)
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_II

public static final java.lang.String ORDER_BY_II
See Also:
Constant Field Values

ORDER_BY_EMPLOYEEID

public static final java.lang.String ORDER_BY_EMPLOYEEID
See Also:
Constant Field Values

ORDER_BY_EMPLOYEENAME

public static final java.lang.String ORDER_BY_EMPLOYEENAME
See Also:
Constant Field Values

ORDER_BY_WORKORDERNUMBER

public static final java.lang.String ORDER_BY_WORKORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_WORKORDERITEMNUMBER

public static final java.lang.String ORDER_BY_WORKORDERITEMNUMBER
See Also:
Constant Field Values

ORDER_BY_WORKCENTER

public static final java.lang.String ORDER_BY_WORKCENTER
See Also:
Constant Field Values

ORDER_BY_WORKINSCTRUCTIONSEQUENCE

public static final java.lang.String ORDER_BY_WORKINSCTRUCTIONSEQUENCE
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_VENDORID

public static final java.lang.String ORDER_BY_VENDORID
See Also:
Constant Field Values
Constructor Detail

WorkOrderTimeCardVO

public WorkOrderTimeCardVO()
Method Detail

getIi

public java.lang.Long getIi()

setIi

public void setIi(java.lang.Long ii)

getWorkOrderNumber

public java.lang.String getWorkOrderNumber()

setWorkOrderNumber

public void setWorkOrderNumber(java.lang.String workOrderNumber)

getWorkOrderItemNumber

public java.lang.String getWorkOrderItemNumber()

setWorkOrderItemNumber

public void setWorkOrderItemNumber(java.lang.String workOrderItemNumber)

getWorkCenter

public java.lang.String getWorkCenter()

setWorkCenter

public void setWorkCenter(java.lang.String workCenter)

getWorkInsctructionSequence

public java.lang.String getWorkInsctructionSequence()

setWorkInsctructionSequence

public void setWorkInsctructionSequence(java.lang.String workInsctructionSequence)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getRevision

public java.lang.String getRevision()

setRevision

public void setRevision(java.lang.String revision)

getSpecialProcess

public java.lang.String getSpecialProcess()

setSpecialProcess

public void setSpecialProcess(java.lang.String specialProcess)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getRejectQty

public java.math.BigDecimal getRejectQty()

setRejectQty

public void setRejectQty(java.math.BigDecimal rejectQty)

getWoicItem

public short getWoicItem()

setWoicItem

public void setWoicItem(short woicItem)

getWoisItem

public short getWoisItem()

setWoisItem

public void setWoisItem(short woisItem)

getTimeOn

public java.util.Date getTimeOn()

setTimeOn

public void setTimeOn(java.util.Date timeOn)

getTimeOff

public java.util.Date getTimeOff()

getEmployeeName

public java.lang.String getEmployeeName()

setTimeOff

public void setTimeOff(java.util.Date timeOff)

setEmployeeName

public void setEmployeeName(java.lang.String employeeName)

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

isFinished

public boolean isFinished()

setFinished

public void setFinished(boolean finished)

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.WorkOrderVO
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
WorkOrderVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getActual()
java.util.Date | getAdate()
java.util.Date | getApproved()
java.lang.String | getApprovedBy()
CustomerVendorAddressInfoVO | getBillToAddressInfo()
java.lang.String | getBillToId()
java.util.Set | getBoilerplates()
java.lang.String | getBp()
java.lang.String | getChangeOrder()
java.lang.String | getCoComments()
java.lang.String | getCompanyUnitId()
java.lang.String | getContact()
java.lang.String | getCurrency()
java.lang.String | getDebitAccount()
int | getDelay()
java.util.Date | getDelivery()
java.util.Date | getDesired()
java.util.Date | getEntered()
java.math.BigDecimal | getGrantTotal()
java.lang.String | getLanguage()
java.util.Date | getLastChangeDate()
int | getLastChangeTimes()
java.lang.String | getLastChangeUser()
java.lang.String | getLocation()
java.lang.String | getOrigin()
java.util.Date | getOriginal()
java.lang.String | getOriginator()
java.lang.String | getPo()
java.lang.String | getPriority()
java.lang.String | getProject()
java.lang.String | getRelatedDoc()
java.lang.String | getRequestor()
java.lang.String | getSalesman()
java.lang.String | getShippingAccount()
CustomerVendorAddressInfoVO | getShipToAddressInfo()
java.lang.String | getShipToId()
java.lang.String | getShipVia()
java.lang.String | getStatus()
java.math.BigDecimal | getSubTotal()
java.lang.String | getTerms()
java.math.BigDecimal | getTotalFreight()
java.math.BigDecimal | getTotalTax()
CustomerVendorAddressInfoVO | getVendorAddressInfo()
java.lang.String | getVendorId()
java.math.BigDecimal | getWoDisc()
java.math.BigDecimal | getWoMade()
java.math.BigDecimal | getWoOpen()
java.lang.String | getWorkOrderComments()
java.util.Set | getWorkOrderItem()
java.lang.String | getWorkOrderNumber()
java.lang.String | getWorkOrderPrivateNotes()
java.math.BigDecimal | getWoSub()
int | hashCode()
boolean | isHold()
boolean | isUseWip()
void | setActual(java.lang.String actual)
void | setAdate(java.util.Date adate)
void | setApproved(java.util.Date approved)
void | setApprovedBy(java.lang.String approvedBy)
void | setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)
void | setBillToId(java.lang.String billToId)
void | setBoilerplates(java.util.Set boilerplates)
void | setBp(java.lang.String bp)
void | setChangeOrder(java.lang.String changeOrder)
void | setCoComments(java.lang.String coComments)
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setContact(java.lang.String contact)
void | setCurrency(java.lang.String currency)
void | setDebitAccount(java.lang.String debitAccount)
void | setDelay(int delay)
void | setDelivery(java.util.Date delivery)
void | setDesired(java.util.Date desired)
void | setEntered(java.util.Date entered)
void | setGrantTotal(java.math.BigDecimal grantTotal)
void | setHold(boolean hold)
void | setLanguage(java.lang.String language)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeTimes(int lastChangeTimes)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setLocation(java.lang.String location)
void | setOrigin(java.lang.String origin)
void | setOriginal(java.util.Date original)
void | setOriginator(java.lang.String originator)
void | setPo(java.lang.String po)
void | setPriority(java.lang.String priority)
void | setProject(java.lang.String project)
void | setRelatedDoc(java.lang.String relatedDoc)
void | setRequestor(java.lang.String requestor)
void | setSalesman(java.lang.String salesman)
void | setShippingAccount(java.lang.String shippingAccount)
void | setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)
void | setShipToId(java.lang.String shipToId)
void | setShipVia(java.lang.String shipVia)
void | setStatus(java.lang.String status)
void | setSubTotal(java.math.BigDecimal subTotal)
void | setTerms(java.lang.String terms)
void | setTotalFreight(java.math.BigDecimal totalFreight)
void | setTotalTax(java.math.BigDecimal totalTax)
void | setUseWip(boolean useWip)
void | setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)
void | setVendorId(java.lang.String vendorId)
void | setWoDisc(java.math.BigDecimal woDisc)
void | setWoMade(java.math.BigDecimal woMade)
void | setWoOpen(java.math.BigDecimal woOpen)
void | setWorkOrderComments(java.lang.String workOrderComments)
void | setWorkOrderItem(java.util.Set workOrderItem)
void | setWorkOrderNumber(java.lang.String workOrderNumber)
void | setWorkOrderPrivateNotes(java.lang.String workOrderPrivateNotes)
void | setWoSub(java.math.BigDecimal woSub)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WorkOrderVO

public WorkOrderVO()
Method Detail

getWorkOrderNumber

public java.lang.String getWorkOrderNumber()

setWorkOrderNumber

public void setWorkOrderNumber(java.lang.String workOrderNumber)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getOrigin

public java.lang.String getOrigin()

setOrigin

public void setOrigin(java.lang.String origin)

getWoSub

public java.math.BigDecimal getWoSub()

setWoSub

public void setWoSub(java.math.BigDecimal woSub)

getWoDisc

public java.math.BigDecimal getWoDisc()

setWoDisc

public void setWoDisc(java.math.BigDecimal woDisc)

getSubTotal

public java.math.BigDecimal getSubTotal()

setSubTotal

public void setSubTotal(java.math.BigDecimal subTotal)

getWoMade

public java.math.BigDecimal getWoMade()

setWoMade

public void setWoMade(java.math.BigDecimal woMade)

getWoOpen

public java.math.BigDecimal getWoOpen()

setWoOpen

public void setWoOpen(java.math.BigDecimal woOpen)

getTotalTax

public java.math.BigDecimal getTotalTax()

setTotalTax

public void setTotalTax(java.math.BigDecimal totalTax)

getTotalFreight

public java.math.BigDecimal getTotalFreight()

setTotalFreight

public void setTotalFreight(java.math.BigDecimal totalFreight)

getGrantTotal

public java.math.BigDecimal getGrantTotal()

setGrantTotal

public void setGrantTotal(java.math.BigDecimal grantTotal)

getChangeOrder

public java.lang.String getChangeOrder()

setChangeOrder

public void setChangeOrder(java.lang.String changeOrder)

getVendorId

public java.lang.String getVendorId()

setVendorId

public void setVendorId(java.lang.String vendorId)

getBillToId

public java.lang.String getBillToId()

setBillToId

public void setBillToId(java.lang.String billToId)

getPo

public java.lang.String getPo()

setPo

public void setPo(java.lang.String po)

getContact

public java.lang.String getContact()

setContact

public void setContact(java.lang.String contact)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getApproved

public java.util.Date getApproved()

setApproved

public void setApproved(java.util.Date approved)

getApprovedBy

public java.lang.String getApprovedBy()

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)

getOriginator

public java.lang.String getOriginator()

setOriginator

public void setOriginator(java.lang.String originator)

getDelivery

public java.util.Date getDelivery()

setDelivery

public void setDelivery(java.util.Date delivery)

getDesired

public java.util.Date getDesired()

setDesired

public void setDesired(java.util.Date desired)

getDelay

public int getDelay()

setDelay

public void setDelay(int delay)

getPriority

public java.lang.String getPriority()

setPriority

public void setPriority(java.lang.String priority)

getOriginal

public java.util.Date getOriginal()

setOriginal

public void setOriginal(java.util.Date original)

getActual

public java.lang.String getActual()

setActual

public void setActual(java.lang.String actual)

getShipToId

public java.lang.String getShipToId()

setShipToId

public void setShipToId(java.lang.String shipToId)

getShipVia

public java.lang.String getShipVia()

setShipVia

public void setShipVia(java.lang.String shipVia)

getShippingAccount

public java.lang.String getShippingAccount()

setShippingAccount

public void setShippingAccount(java.lang.String shippingAccount)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getLanguage

public java.lang.String getLanguage()

setLanguage

public void setLanguage(java.lang.String language)

getCurrency

public java.lang.String getCurrency()

setCurrency

public void setCurrency(java.lang.String currency)

getTerms

public java.lang.String getTerms()

setTerms

public void setTerms(java.lang.String terms)

getEntered

public java.util.Date getEntered()

setEntered

public void setEntered(java.util.Date entered)

getSalesman

public java.lang.String getSalesman()

setSalesman

public void setSalesman(java.lang.String salesman)

getRequestor

public java.lang.String getRequestor()

setRequestor

public void setRequestor(java.lang.String requestor)

getProject

public java.lang.String getProject()

setProject

public void setProject(java.lang.String project)

getRelatedDoc

public java.lang.String getRelatedDoc()

setRelatedDoc

public void setRelatedDoc(java.lang.String relatedDoc)

getDebitAccount

public java.lang.String getDebitAccount()

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

getBp

public java.lang.String getBp()

setBp

public void setBp(java.lang.String bp)

getWorkOrderComments

public java.lang.String getWorkOrderComments()

setWorkOrderComments

public void setWorkOrderComments(java.lang.String workOrderComments)

getWorkOrderPrivateNotes

public java.lang.String getWorkOrderPrivateNotes()

setWorkOrderPrivateNotes

public void setWorkOrderPrivateNotes(java.lang.String workOrderPrivateNotes)

getLastChangeTimes

public int getLastChangeTimes()

setLastChangeTimes

public void setLastChangeTimes(int lastChangeTimes)

getVendorAddressInfo

public CustomerVendorAddressInfoVO getVendorAddressInfo()

setVendorAddressInfo

public void setVendorAddressInfo(CustomerVendorAddressInfoVO vendorAddressInfo)

getShipToAddressInfo

public CustomerVendorAddressInfoVO getShipToAddressInfo()

setShipToAddressInfo

public void setShipToAddressInfo(CustomerVendorAddressInfoVO shipToAddressInfo)

getBillToAddressInfo

public CustomerVendorAddressInfoVO getBillToAddressInfo()

setBillToAddressInfo

public void setBillToAddressInfo(CustomerVendorAddressInfoVO billToAddressInfo)

getWorkOrderItem

public java.util.Set getWorkOrderItem()

getBoilerplates

public java.util.Set getBoilerplates()

getCoComments

public java.lang.String getCoComments()

setWorkOrderItem

public void setWorkOrderItem(java.util.Set workOrderItem)

setBoilerplates

public void setBoilerplates(java.util.Set boilerplates)

setCoComments

public void setCoComments(java.lang.String coComments)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

isUseWip

public boolean isUseWip()

setUseWip

public void setUseWip(boolean useWip)

isHold

public boolean isHold()

setHold

public void setHold(boolean hold)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderWorkInstructionListResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderWorkInstructionListResult

java.lang.Object
    extended by  bb.common.WorkOrderWorkInstructionListResult
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderWorkInstructionListResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_DESCRIPTION
static java.lang.String | ORDER_BY_PARTNUMBER
static java.lang.String | ORDER_BY_WORKORDERITEMNUMBER
static java.lang.String | ORDER_BY_WORKORDERNUMBER
Constructor Summary
WorkOrderWorkInstructionListResult()
Method Summary
java.util.Date | getActualShipDate()
java.lang.String | getDescription()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
java.util.Set<RefdocVO> | getRefDoc()
java.util.Date | getRequiredDate()
java.util.Set<WorkOrderWorkInstructionSequenceVO> | getSequences()
java.util.Date | getShipDate()
java.lang.String | getStatus()
java.lang.String | getWorkOrderItemNumber()
java.lang.String | getWorkOrderNumber()
void | setActualShipDate(java.util.Date actualShipDate)
void | setDescription(java.lang.String description)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setRefDoc(java.util.Set<RefdocVO> refDoc)
void | setRequiredDate(java.util.Date requiredDate)
void | setSequences(java.util.Set<WorkOrderWorkInstructionSequenceVO> sequences)
void | setShipDate(java.util.Date shipDate)
void | setStatus(java.lang.String status)
void | setWorkOrderItemNumber(java.lang.String workOrderItemNumber)
void | setWorkOrderNumber(java.lang.String workOrderNumber)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORDER_BY_WORKORDERNUMBER

public static final java.lang.String ORDER_BY_WORKORDERNUMBER
See Also:
Constant Field Values

ORDER_BY_WORKORDERITEMNUMBER

public static final java.lang.String ORDER_BY_WORKORDERITEMNUMBER
See Also:
Constant Field Values

ORDER_BY_PARTNUMBER

public static final java.lang.String ORDER_BY_PARTNUMBER
See Also:
Constant Field Values

ORDER_BY_DESCRIPTION

public static final java.lang.String ORDER_BY_DESCRIPTION
See Also:
Constant Field Values
Constructor Detail

WorkOrderWorkInstructionListResult

public WorkOrderWorkInstructionListResult()
Method Detail

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getSequences

public java.util.Set<WorkOrderWorkInstructionSequenceVO> getSequences()

setSequences

public void setSequences(java.util.Set<WorkOrderWorkInstructionSequenceVO> sequences)

getWorkOrderItemNumber

public java.lang.String getWorkOrderItemNumber()

setWorkOrderItemNumber

public void setWorkOrderItemNumber(java.lang.String workOrderItemNumber)

getWorkOrderNumber

public java.lang.String getWorkOrderNumber()

setWorkOrderNumber

public void setWorkOrderNumber(java.lang.String workOrderNumber)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getRefDoc

public java.util.Set<RefdocVO> getRefDoc()

setRefDoc

public void setRefDoc(java.util.Set<RefdocVO> refDoc)

getActualShipDate

public java.util.Date getActualShipDate()

setActualShipDate

public void setActualShipDate(java.util.Date actualShipDate)

getRequiredDate

public java.util.Date getRequiredDate()

setRequiredDate

public void setRequiredDate(java.util.Date requiredDate)

getShipDate

public java.util.Date getShipDate()

setShipDate

public void setShipDate(java.util.Date shipDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderWorkInstructionPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderWorkInstructionPK

java.lang.Object
    extended by  bb.common.WorkOrderWorkInstructionPK
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderWorkInstructionPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
WorkOrderWorkInstructionPK()
default constructor
WorkOrderWorkInstructionPK(java.lang.String workOrderNumber, java.lang.String workOrderItemNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getWorkOrderItemNumber()
java.lang.String | getWorkOrderNumber()
int | hashCode()
void | setWorkOrderItemNumber(java.lang.String workOrderItemNumber)
void | setWorkOrderNumber(java.lang.String workOrderNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WorkOrderWorkInstructionPK

public WorkOrderWorkInstructionPK(java.lang.String workOrderNumber,
                                  java.lang.String workOrderItemNumber)
full constructor

WorkOrderWorkInstructionPK

public WorkOrderWorkInstructionPK()
default constructor

Method Detail

getWorkOrderNumber

public java.lang.String getWorkOrderNumber()

setWorkOrderNumber

public void setWorkOrderNumber(java.lang.String workOrderNumber)

getWorkOrderItemNumber

public java.lang.String getWorkOrderItemNumber()

setWorkOrderItemNumber

public void setWorkOrderItemNumber(java.lang.String workOrderItemNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderWorkInstructionSequenceDateAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderWorkInstructionSequenceDateAgent

java.lang.Object
    extended by  bb.common.WorkOrderWorkInstructionSequenceDateAgent
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderWorkInstructionSequenceDateAgent
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
WorkOrderWorkInstructionSequenceDateAgent()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getActualEndDate()
java.util.Date | getActualStartDate()
double | getCompletePercent()
java.util.Date | getEndDate()
java.math.BigDecimal | getHours()
WorkOrderWorkInstructionSequencePK | getPk()
java.util.Date | getStartDate()
int | getWorkCenterItem()
int | hashCode()
void | setActualEndDate(java.util.Date actualEndDate)
void | setActualStartDate(java.util.Date actualStartDate)
void | setCompletePercent(double completePercent)
void | setEndDate(java.util.Date endDate)
void | setHours(java.math.BigDecimal hours)
void | setPk(WorkOrderWorkInstructionSequencePK pk)
void | setStartDate(java.util.Date startDate)
void | setWorkCenterItem(int workCenterItem)
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkOrderWorkInstructionSequenceDateAgent

public WorkOrderWorkInstructionSequenceDateAgent()
default constructor

Method Detail

getHours

public java.math.BigDecimal getHours()

setHours

public void setHours(java.math.BigDecimal hours)

getPk

public WorkOrderWorkInstructionSequencePK getPk()

setPk

public void setPk(WorkOrderWorkInstructionSequencePK pk)

getStartDate

public java.util.Date getStartDate()

setStartDate

public void setStartDate(java.util.Date startDate)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getActualEndDate

public java.util.Date getActualEndDate()

setActualEndDate

public void setActualEndDate(java.util.Date actualEndDate)

getActualStartDate

public java.util.Date getActualStartDate()

setActualStartDate

public void setActualStartDate(java.util.Date actualStartDate)

getCompletePercent

public double getCompletePercent()

setCompletePercent

public void setCompletePercent(double completePercent)

getEndDate

public java.util.Date getEndDate()

setEndDate

public void setEndDate(java.util.Date endDate)

getWorkCenterItem

public int getWorkCenterItem()

setWorkCenterItem

public void setWorkCenterItem(int workCenterItem)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderWorkInstructionSequencePK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderWorkInstructionSequencePK

java.lang.Object
    extended by  bb.common.WorkOrderWorkInstructionSequencePK
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderWorkInstructionSequencePK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
WorkOrderWorkInstructionSequencePK()
default constructor
WorkOrderWorkInstructionSequencePK(java.lang.String workOrderNumber, java.lang.String workOrderItemNumber, java.lang.String workInstructionSequence)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getWorkInstructionSequence()
java.lang.String | getWorkOrderItemNumber()
java.lang.String | getWorkOrderNumber()
int | hashCode()
void | setWorkInstructionSequence(java.lang.String workInstructionSequence)
void | setWorkOrderItemNumber(java.lang.String workOrderItemNumber)
void | setWorkOrderNumber(java.lang.String workOrderNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WorkOrderWorkInstructionSequencePK

public WorkOrderWorkInstructionSequencePK(java.lang.String workOrderNumber,
                                          java.lang.String workOrderItemNumber,
                                          java.lang.String workInstructionSequence)
full constructor

WorkOrderWorkInstructionSequencePK

public WorkOrderWorkInstructionSequencePK()
default constructor

Method Detail

getWorkOrderNumber

public java.lang.String getWorkOrderNumber()

setWorkOrderNumber

public void setWorkOrderNumber(java.lang.String workOrderNumber)

getWorkOrderItemNumber

public java.lang.String getWorkOrderItemNumber()

setWorkOrderItemNumber

public void setWorkOrderItemNumber(java.lang.String workOrderItemNumber)

getWorkInstructionSequence

public java.lang.String getWorkInstructionSequence()

setWorkInstructionSequence

public void setWorkInstructionSequence(java.lang.String workInstructionSequence)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderWorkInstructionSequenceVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderWorkInstructionSequenceVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.WorkOrderWorkInstructionSequenceVO
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderWorkInstructionSequenceVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
WorkOrderWorkInstructionSequenceVO()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.math.BigDecimal | getAvgHrs()
int | getAvgHrsH()
int | getAvgHrsM()
int | getAvgHrsS()
java.math.BigDecimal | getAvgSetup()
int | getAvgSetupH()
int | getAvgSetupM()
int | getAvgSetupS()
java.util.Date | getBeginDate()
java.lang.String | getCalcLoad()
java.lang.String | getDescription()
java.lang.String | getDescription2()
java.lang.String | getDescription3()
java.util.Date | getEndDate()
java.math.BigDecimal | getEstHrs()
int | getEstHrsH()
int | getEstHrsM()
int | getEstHrsS()
java.math.BigDecimal | getEstSetup()
int | getEstSetupH()
int | getEstSetupM()
int | getEstSetupS()
java.util.Date | getFinishedDate()
java.math.BigDecimal | getFinishPercent()
java.lang.String | getLanguage2()
java.lang.String | getLanguage3()
static int | getMinite(java.math.BigDecimal time)
java.lang.String | getOutSourcing()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
WorkOrderWorkInstructionSequencePK | getPk()
java.lang.String | getRef()
static int | getSecond(java.math.BigDecimal time)
java.lang.String | getSequanceRev()
java.lang.String | getSetId()
java.lang.String | getSpecialProcess()
java.util.Date | getStartDate()
java.lang.String | getStatus()
java.math.BigDecimal | getStdHrs()
int | getStdHrsH()
int | getStdHrsM()
int | getStdHrsS()
java.math.BigDecimal | getStdSetup()
int | getStdSetupH()
int | getStdSetupM()
int | getStdSetupS()
java.lang.String | getToolNumber()
java.lang.String | getWorkCenterId()
int | getWorkCenterItem()
int | hashCode()
boolean | isFinished()
void | setAvgHrs(java.math.BigDecimal avgHrs)
void | setAvgHrsH(int avgHrsH)
void | setAvgHrsM(int avgHrsM)
void | setAvgHrsS(int avgHrsS)
void | setAvgSetup(java.math.BigDecimal avgSetup)
void | setAvgSetupH(int avgSetupH)
void | setAvgSetupM(int avgSetupM)
void | setAvgSetupS(int avgSetupS)
void | setBeginDate(java.util.Date beginDate)
void | setCalcLoad(java.lang.String calcLoad)
void | setDescription(java.lang.String description)
void | setDescription2(java.lang.String description2)
void | setDescription3(java.lang.String description3)
void | setEndDate(java.util.Date endDate)
void | setEstHrs(java.math.BigDecimal estHrs)
void | setEstHrsH(int estHrsH)
void | setEstHrsM(int estHrsM)
void | setEstHrsS(int estHrsS)
void | setEstSetup(java.math.BigDecimal estSetup)
void | setEstSetupH(int estSetupH)
void | setEstSetupM(int estSetupM)
void | setEstSetupS(int estSetupS)
void | setFinished(boolean finished)
void | setFinishedDate(java.util.Date finishedDate)
void | setFinishPercent(java.math.BigDecimal finishPercent)
void | setLanguage2(java.lang.String language2)
void | setLanguage3(java.lang.String language3)
void | setOutSourcing(java.lang.String outSourcing)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(WorkOrderWorkInstructionSequencePK pk)
void | setRef(java.lang.String ref)
void | setSequanceRev(java.lang.String sequanceRev)
void | setSetId(java.lang.String setId)
void | setSpecialProcess(java.lang.String specialProcess)
void | setStartDate(java.util.Date startDate)
void | setStatus(java.lang.String status)
void | setStdHrs(java.math.BigDecimal stdHrs)
void | setStdHrsH(int stdHrsH)
void | setStdHrsM(int stdHrsM)
void | setStdHrsS(int stdHrsS)
void | setStdSetup(java.math.BigDecimal stdSetup)
void | setStdSetupH(int stdSetupH)
void | setStdSetupM(int stdSetupM)
void | setToolNumber(java.lang.String toolNumber)
void | setWorkCenterId(java.lang.String workCenterId)
void | setWorkCenterItem(int workCenterItem)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WorkOrderWorkInstructionSequenceVO

public WorkOrderWorkInstructionSequenceVO()
default constructor

Method Detail

getCalcLoad

public java.lang.String getCalcLoad()

setCalcLoad

public void setCalcLoad(java.lang.String calcLoad)

isFinished

public boolean isFinished()

setFinished

public void setFinished(boolean finished)

getFinishedDate

public java.util.Date getFinishedDate()

setFinishedDate

public void setFinishedDate(java.util.Date finishedDate)

getPk

public WorkOrderWorkInstructionSequencePK getPk()

setPk

public void setPk(WorkOrderWorkInstructionSequencePK pk)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getSetId

public java.lang.String getSetId()

setSetId

public void setSetId(java.lang.String setId)

getEndDate

public java.util.Date getEndDate()

setEndDate

public void setEndDate(java.util.Date endDate)

getStartDate

public java.util.Date getStartDate()

setStartDate

public void setStartDate(java.util.Date startDate)

getSequanceRev

public java.lang.String getSequanceRev()

setSequanceRev

public void setSequanceRev(java.lang.String sequanceRev)

getSpecialProcess

public java.lang.String getSpecialProcess()

setSpecialProcess

public void setSpecialProcess(java.lang.String specialProcess)

getToolNumber

public java.lang.String getToolNumber()

setToolNumber

public void setToolNumber(java.lang.String toolNumber)

getWorkCenterId

public java.lang.String getWorkCenterId()

setWorkCenterId

public void setWorkCenterId(java.lang.String workCenterId)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getLanguage2

public java.lang.String getLanguage2()

setLanguage2

public void setLanguage2(java.lang.String language2)

getDescription2

public java.lang.String getDescription2()

setDescription2

public void setDescription2(java.lang.String description2)

getLanguage3

public java.lang.String getLanguage3()

setLanguage3

public void setLanguage3(java.lang.String language3)

getDescription3

public java.lang.String getDescription3()

setDescription3

public void setDescription3(java.lang.String description3)

getEstSetup

public java.math.BigDecimal getEstSetup()

setEstSetup

public void setEstSetup(java.math.BigDecimal estSetup)

getAvgSetup

public java.math.BigDecimal getAvgSetup()

setAvgSetup

public void setAvgSetup(java.math.BigDecimal avgSetup)

getStdSetup

public java.math.BigDecimal getStdSetup()

setStdSetup

public void setStdSetup(java.math.BigDecimal stdSetup)

getEstHrs

public java.math.BigDecimal getEstHrs()

setEstHrs

public void setEstHrs(java.math.BigDecimal estHrs)

getAvgHrs

public java.math.BigDecimal getAvgHrs()

setAvgHrs

public void setAvgHrs(java.math.BigDecimal avgHrs)

getStdHrs

public java.math.BigDecimal getStdHrs()

setStdHrs

public void setStdHrs(java.math.BigDecimal stdHrs)

getRef

public java.lang.String getRef()

setRef

public void setRef(java.lang.String ref)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getBeginDate

public java.util.Date getBeginDate()

setBeginDate

public void setBeginDate(java.util.Date beginDate)

getFinishPercent

public java.math.BigDecimal getFinishPercent()

setFinishPercent

public void setFinishPercent(java.math.BigDecimal finishPercent)

getOutSourcing

public java.lang.String getOutSourcing()

setOutSourcing

public void setOutSourcing(java.lang.String outSourcing)

getWorkCenterItem

public int getWorkCenterItem()

setWorkCenterItem

public void setWorkCenterItem(int workCenterItem)

getAvgHrsH

public int getAvgHrsH()

setAvgHrsH

public void setAvgHrsH(int avgHrsH)

setAvgHrsM

public void setAvgHrsM(int avgHrsM)

getAvgSetupH

public int getAvgSetupH()

setAvgSetupH

public void setAvgSetupH(int avgSetupH)

getAvgSetupM

public int getAvgSetupM()

setAvgSetupM

public void setAvgSetupM(int avgSetupM)

getEstHrsH

public int getEstHrsH()

setEstHrsH

public void setEstHrsH(int estHrsH)

getEstHrsM

public int getEstHrsM()

getEstHrsS

public int getEstHrsS()

setEstHrsM

public void setEstHrsM(int estHrsM)

getEstSetupH

public int getEstSetupH()

setEstSetupH

public void setEstSetupH(int estSetupH)

getEstSetupM

public int getEstSetupM()

getEstSetupS

public int getEstSetupS()

setEstSetupM

public void setEstSetupM(int estSetupM)

getStdHrsH

public int getStdHrsH()

setStdHrsH

public void setStdHrsH(int stdHrsH)

getAvgSetupS

public int getAvgSetupS()

getStdHrsM

public int getStdHrsM()

getStdSetupM

public int getStdSetupM()

getAvgHrsM

public int getAvgHrsM()

getStdHrsS

public int getStdHrsS()

setStdHrsM

public void setStdHrsM(int stdHrsM)

getStdSetupH

public int getStdSetupH()

setStdSetupH

public void setStdSetupH(int stdSetupH)

getStdSetupS

public int getStdSetupS()

setStdSetupM

public void setStdSetupM(int stdSetupM)

getMinite

public static int getMinite(java.math.BigDecimal time)

getSecond

public static int getSecond(java.math.BigDecimal time)

setAvgHrsS

public void setAvgHrsS(int avgHrsS)

setAvgSetupS

public void setAvgSetupS(int avgSetupS)

setEstSetupS

public void setEstSetupS(int estSetupS)

setStdHrsS

public void setStdHrsS(int stdHrsS)

setEstHrsS

public void setEstHrsS(int estHrsS)

getAvgHrsS

public int getAvgHrsS()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderWorkInstructionVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderWorkInstructionVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.WorkOrderWorkInstructionVO
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderWorkInstructionVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkOrderWorkInstructionVO()
defaultWi constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getAdate()
java.util.Date | getApproved()
java.lang.String | getApprovedBy()
java.lang.String | getAuthor()
java.lang.String | getComment()
java.lang.String | getDefaultWi()
java.lang.String | getDescription()
java.util.Date | getEffectiveDate()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getPartFrom()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
WorkOrderWorkInstructionPK | getPk()
java.lang.String | getProofreader()
java.math.BigDecimal | getQty()
java.util.Set | getSequences()
java.lang.String | getSetId()
java.lang.String | getStatus()
java.lang.Integer | getVersion()
java.util.Date | getWoRequireDate()
java.lang.String | getWorkInstructionRev()
java.util.Date | getWoStartDate()
int | hashCode()
void | setAdate(java.util.Date adate)
void | setApproved(java.util.Date approved)
void | setApprovedBy(java.lang.String approvedBy)
void | setAuthor(java.lang.String author)
void | setComment(java.lang.String comment)
void | setDefaultWi(java.lang.String defaultWi)
void | setDescription(java.lang.String description)
void | setEffectiveDate(java.util.Date effectiveDate)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setPartFrom(java.lang.String partFrom)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(WorkOrderWorkInstructionPK pk)
void | setProofreader(java.lang.String proofreader)
void | setQty(java.math.BigDecimal qty)
void | setSequences(java.util.Set sequences)
void | setSetId(java.lang.String setId)
void | setStatus(java.lang.String status)
void | setVersion(java.lang.Integer version)
void | setWoRequireDate(java.util.Date woRequireDate)
void | setWorkInstructionRev(java.lang.String workInstructionRev)
void | setWoStartDate(java.util.Date woStartDate)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WorkOrderWorkInstructionVO

public WorkOrderWorkInstructionVO()
defaultWi constructor

Method Detail

getPk

public WorkOrderWorkInstructionPK getPk()

setPk

public void setPk(WorkOrderWorkInstructionPK pk)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPartFrom

public java.lang.String getPartFrom()

setPartFrom

public void setPartFrom(java.lang.String partFrom)

getSetId

public java.lang.String getSetId()

setSetId

public void setSetId(java.lang.String setId)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getVersion

public java.lang.Integer getVersion()

setVersion

public void setVersion(java.lang.Integer version)

getAdate

public java.util.Date getAdate()

setAdate

public void setAdate(java.util.Date adate)

getWorkInstructionRev

public java.lang.String getWorkInstructionRev()

setWorkInstructionRev

public void setWorkInstructionRev(java.lang.String workInstructionRev)

getDefaultWi

public java.lang.String getDefaultWi()

setDefaultWi

public void setDefaultWi(java.lang.String defaultWi)

getAuthor

public java.lang.String getAuthor()

setAuthor

public void setAuthor(java.lang.String author)

getApprovedBy

public java.lang.String getApprovedBy()

setApprovedBy

public void setApprovedBy(java.lang.String approvedBy)

getApproved

public java.util.Date getApproved()

setApproved

public void setApproved(java.util.Date approved)

getEffectiveDate

public java.util.Date getEffectiveDate()

setEffectiveDate

public void setEffectiveDate(java.util.Date effectiveDate)

getStatus

public java.lang.String getStatus()

setStatus

public void setStatus(java.lang.String status)

getSequences

public java.util.Set getSequences()

setSequences

public void setSequences(java.util.Set sequences)

getProofreader

public java.lang.String getProofreader()

setProofreader

public void setProofreader(java.lang.String proofreader)

getWoRequireDate

public java.util.Date getWoRequireDate()

setWoRequireDate

public void setWoRequireDate(java.util.Date woRequireDate)

getWoStartDate

public java.util.Date getWoStartDate()

setWoStartDate

public void setWoStartDate(java.util.Date woStartDate)

getQty

public java.math.BigDecimal getQty()

setQty

public void setQty(java.math.BigDecimal qty)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getComment

public java.lang.String getComment()

setComment

public void setComment(java.lang.String comment)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderWorkItemDateAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderWorkItemDateAgent

java.lang.Object
    extended by  bb.common.WorkOrderWorkItemDateAgent
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderWorkItemDateAgent
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
WorkOrderWorkItemDateAgent()
default constructor
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getDateRequired()
WorkOrderItemPK | getPk()
java.util.Date | getStartDate()
int | hashCode()
void | setDateRequired(java.util.Date dateRequired)
void | setPk(WorkOrderItemPK pk)
void | setStartDate(java.util.Date startDate)
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkOrderWorkItemDateAgent

public WorkOrderWorkItemDateAgent()
default constructor

Method Detail

getDateRequired

public java.util.Date getDateRequired()

setDateRequired

public void setDateRequired(java.util.Date dateRequired)

getPk

public WorkOrderItemPK getPk()

setPk

public void setPk(WorkOrderItemPK pk)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

getStartDate

public java.util.Date getStartDate()

setStartDate

public void setStartDate(java.util.Date startDate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderWorkSheetItemPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderWorkSheetItemPK

java.lang.Object
    extended by  bb.common.WorkOrderWorkSheetItemPK
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderWorkSheetItemPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
WorkOrderWorkSheetItemPK()
default constructor
WorkOrderWorkSheetItemPK(java.lang.String employeeId, java.lang.String cartType, java.lang.Integer workSheetNumber, java.lang.Integer itemNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCartType()
java.lang.String | getEmployeeId()
java.lang.Integer | getItemNumber()
java.lang.Integer | getWorkSheetNumber()
int | hashCode()
void | setCartType(java.lang.String cartType)
void | setEmployeeId(java.lang.String employeeId)
void | setItemNumber(java.lang.Integer itemNumber)
void | setWorkSheetNumber(java.lang.Integer workSheetNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WorkOrderWorkSheetItemPK

public WorkOrderWorkSheetItemPK(java.lang.String employeeId,
                                java.lang.String cartType,
                                java.lang.Integer workSheetNumber,
                                java.lang.Integer itemNumber)
full constructor

WorkOrderWorkSheetItemPK

public WorkOrderWorkSheetItemPK()
default constructor

Method Detail

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getCartType

public java.lang.String getCartType()

setCartType

public void setCartType(java.lang.String cartType)

getWorkSheetNumber

public java.lang.Integer getWorkSheetNumber()

setWorkSheetNumber

public void setWorkSheetNumber(java.lang.Integer workSheetNumber)

getItemNumber

public java.lang.Integer getItemNumber()

setItemNumber

public void setItemNumber(java.lang.Integer itemNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderWorkSheetItemVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderWorkSheetItemVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.WorkOrderWorkSheetItemVO
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderWorkSheetItemVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
WorkOrderWorkSheetItemVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getComments()
java.util.Date | getDelivery()
java.util.Date | getLastChangeDate()
java.lang.String | getLastChangeUser()
java.lang.String | getMakeRfq()
java.lang.String | getMakeWo()
short | getMfgId()
java.lang.String | getMfgIds()
java.math.BigDecimal | getMonthQty()
int | getMonths()
java.lang.String | getPartNumber()
java.lang.String | getPartType()
WorkOrderWorkSheetItemPK | getPk()
java.lang.String | getPrivateNotes()
java.math.BigDecimal | getQuantity()
java.lang.String | getRfqIds()
java.lang.String | getRfqIdWritein()
java.lang.Byte | getVendId()
java.lang.String | getVendIdWritein()
int | hashCode()
void | setComments(java.lang.String comments)
void | setDelivery(java.util.Date delivery)
void | setLastChangeDate(java.util.Date lastChangeDate)
void | setLastChangeUser(java.lang.String lastChangeUser)
void | setMakeRfq(java.lang.String makeRfq)
void | setMakeWo(java.lang.String makeWo)
void | setMfgId(short mfgId)
void | setMfgIds(java.lang.String mfgIds)
void | setMonthQty(java.math.BigDecimal monthQty)
void | setMonths(int months)
void | setPartNumber(java.lang.String partNumber)
void | setPartType(java.lang.String partType)
void | setPk(WorkOrderWorkSheetItemPK pk)
void | setPrivateNotes(java.lang.String privateNotes)
void | setQuantity(java.math.BigDecimal quantity)
void | setRfqIds(java.lang.String rfqIds)
void | setRfqIdWritein(java.lang.String rfqIdWritein)
void | setVendId(java.lang.Byte vendId)
void | setVendIdWritein(java.lang.String vendIdWritein)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WorkOrderWorkSheetItemVO

public WorkOrderWorkSheetItemVO()
Method Detail

getComments

public java.lang.String getComments()

setComments

public void setComments(java.lang.String comments)

getDelivery

public java.util.Date getDelivery()

setDelivery

public void setDelivery(java.util.Date delivery)

getLastChangeDate

public java.util.Date getLastChangeDate()

setLastChangeDate

public void setLastChangeDate(java.util.Date lastChangeDate)

getLastChangeUser

public java.lang.String getLastChangeUser()

setLastChangeUser

public void setLastChangeUser(java.lang.String lastChangeUser)

getMakeRfq

public java.lang.String getMakeRfq()

setMakeRfq

public void setMakeRfq(java.lang.String makeRfq)

getMakeWo

public java.lang.String getMakeWo()

setMakeWo

public void setMakeWo(java.lang.String makeWo)

getMfgId

public short getMfgId()

setMfgId

public void setMfgId(short mfgId)

getMfgIds

public java.lang.String getMfgIds()

setMfgIds

public void setMfgIds(java.lang.String mfgIds)

getMonthQty

public java.math.BigDecimal getMonthQty()

setMonthQty

public void setMonthQty(java.math.BigDecimal monthQty)

getMonths

public int getMonths()

setMonths

public void setMonths(int months)

getPartNumber

public java.lang.String getPartNumber()

setPartNumber

public void setPartNumber(java.lang.String partNumber)

getPartType

public java.lang.String getPartType()

setPartType

public void setPartType(java.lang.String partType)

getPk

public WorkOrderWorkSheetItemPK getPk()

setPk

public void setPk(WorkOrderWorkSheetItemPK pk)

getPrivateNotes

public java.lang.String getPrivateNotes()

setPrivateNotes

public void setPrivateNotes(java.lang.String privateNotes)

getQuantity

public java.math.BigDecimal getQuantity()

setQuantity

public void setQuantity(java.math.BigDecimal quantity)

getRfqIds

public java.lang.String getRfqIds()

setRfqIds

public void setRfqIds(java.lang.String rfqIds)

getRfqIdWritein

public java.lang.String getRfqIdWritein()

setRfqIdWritein

public void setRfqIdWritein(java.lang.String rfqIdWritein)

getVendId

public java.lang.Byte getVendId()

setVendId

public void setVendId(java.lang.Byte vendId)

getVendIdWritein

public java.lang.String getVendIdWritein()

setVendIdWritein

public void setVendIdWritein(java.lang.String vendIdWritein)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderWorkSheetItemWithRelatedInfoResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderWorkSheetItemWithRelatedInfoResult

java.lang.Object
    extended by  bb.common.WorkOrderWorkSheetItemWithRelatedInfoResult
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderWorkSheetItemWithRelatedInfoResult
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkOrderWorkSheetItemWithRelatedInfoResult()
Method Summary
PartBasicInfo | getPartBasicInfo()
PartInventoryVO | getPartInventoryVO()
java.util.List | getPartManufacturers()
java.util.List | getPartVendors()
ToolBasicInfo | getToolBasicInfo()
ToolInventoryVO | getToolInventoryVO()
WorkOrderWorkSheetItemVO | getWorkSheetItem()
void | setPartBasicInfo(PartBasicInfo partBasicInfo)
void | setPartInventoryVO(PartInventoryVO partInventoryVO)
void | setPartManufacturers(java.util.List partManufacturers)
void | setPartVendors(java.util.List partVendors)
void | setToolBasicInfo(ToolBasicInfo toolBasicInfo)
void | setToolInventoryVO(ToolInventoryVO toolInventoryVO)
void | setWorkSheetItem(WorkOrderWorkSheetItemVO workSheetItem)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkOrderWorkSheetItemWithRelatedInfoResult

public WorkOrderWorkSheetItemWithRelatedInfoResult()
Method Detail

getPartBasicInfo

public PartBasicInfo getPartBasicInfo()

setPartBasicInfo

public void setPartBasicInfo(PartBasicInfo partBasicInfo)

getPartInventoryVO

public PartInventoryVO getPartInventoryVO()

setPartInventoryVO

public void setPartInventoryVO(PartInventoryVO partInventoryVO)

getPartVendors

public java.util.List getPartVendors()

setPartVendors

public void setPartVendors(java.util.List partVendors)

getPartManufacturers

public java.util.List getPartManufacturers()

getToolBasicInfo

public ToolBasicInfo getToolBasicInfo()

getToolInventoryVO

public ToolInventoryVO getToolInventoryVO()

getWorkSheetItem

public WorkOrderWorkSheetItemVO getWorkSheetItem()

setPartManufacturers

public void setPartManufacturers(java.util.List partManufacturers)

setToolBasicInfo

public void setToolBasicInfo(ToolBasicInfo toolBasicInfo)

setToolInventoryVO

public void setToolInventoryVO(ToolInventoryVO toolInventoryVO)

setWorkSheetItem

public void setWorkSheetItem(WorkOrderWorkSheetItemVO workSheetItem)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderWorkSheetPK

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderWorkSheetPK

java.lang.Object
    extended by  bb.common.WorkOrderWorkSheetPK
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderWorkSheetPK
extends java.lang.Object
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Constructor Summary
WorkOrderWorkSheetPK()
default constructor
WorkOrderWorkSheetPK(java.lang.String employeeId, java.lang.String cartType, java.lang.Integer workSheetNumber)
full constructor
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCartType()
java.lang.String | getEmployeeId()
java.lang.Integer | getWorkSheetNumber()
int | hashCode()
void | setCartType(java.lang.String cartType)
void | setEmployeeId(java.lang.String employeeId)
void | setWorkSheetNumber(java.lang.Integer workSheetNumber)
java.lang.String | toString()
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WorkOrderWorkSheetPK

public WorkOrderWorkSheetPK(java.lang.String employeeId,
                            java.lang.String cartType,
                            java.lang.Integer workSheetNumber)
full constructor

WorkOrderWorkSheetPK

public WorkOrderWorkSheetPK()
default constructor

Method Detail

getEmployeeId

public java.lang.String getEmployeeId()

setEmployeeId

public void setEmployeeId(java.lang.String employeeId)

getCartType

public java.lang.String getCartType()

setCartType

public void setCartType(java.lang.String cartType)

getWorkSheetNumber

public java.lang.Integer getWorkSheetNumber()

setWorkSheetNumber

public void setWorkSheetNumber(java.lang.Integer workSheetNumber)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkOrderWorkSheetVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkOrderWorkSheetVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.WorkOrderWorkSheetVO
All Implemented Interfaces:
java.io.Serializable
public class WorkOrderWorkSheetVO
extends VO
implements java.io.Serializable

Author:
Hibernate CodeGenerator
See Also:
Serialized Form

Field Summary
static java.lang.String | ORDER_BY_COMPANYUNITID
static java.lang.String | ORDER_BY_DUEDATE
static java.lang.String | ORDER_BY_EMPLOYEEEMAIL
static java.lang.String | ORDER_BY_PK
Constructor Summary
WorkOrderWorkSheetVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getCompanyUnitId()
java.lang.String | getDebitAccount()
java.lang.String | getDescription()
java.util.Date | getDueDate()
java.lang.String | getEmployeeEmail()
WorkOrderWorkSheetPK | getPk()
java.lang.String | getPublicToUser()
java.util.Set | getWorkOrderWorkSheetItem()
int | hashCode()
boolean | isPublicToEvery()
boolean | isPublicWorkSheet()
void | setCompanyUnitId(java.lang.String companyUnitId)
void | setDebitAccount(java.lang.String debitAccount)
void | setDescription(java.lang.String description)
void | setDueDate(java.util.Date dueDate)
void | setEmployeeEmail(java.lang.String employeeEmail)
void | setPk(WorkOrderWorkSheetPK pk)
void | setPublicToEvery(boolean publicToEvery)
void | setPublicToUser(java.lang.String publicToUser)
void | setPublicWorkSheet(boolean publicWorkSheet)
void | setWorkOrderWorkSheetItem(java.util.Set workOrderWorkSheetItem)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_PK

public static final java.lang.String ORDER_BY_PK
See Also:
Constant Field Values

ORDER_BY_EMPLOYEEEMAIL

public static final java.lang.String ORDER_BY_EMPLOYEEEMAIL
See Also:
Constant Field Values

ORDER_BY_DUEDATE

public static final java.lang.String ORDER_BY_DUEDATE
See Also:
Constant Field Values

ORDER_BY_COMPANYUNITID

public static final java.lang.String ORDER_BY_COMPANYUNITID
See Also:
Constant Field Values
Constructor Detail

WorkOrderWorkSheetVO

public WorkOrderWorkSheetVO()
Method Detail

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getDueDate

public java.util.Date getDueDate()

setDueDate

public void setDueDate(java.util.Date dueDate)

getEmployeeEmail

public java.lang.String getEmployeeEmail()

setEmployeeEmail

public void setEmployeeEmail(java.lang.String employeeEmail)

getPk

public WorkOrderWorkSheetPK getPk()

setPk

public void setPk(WorkOrderWorkSheetPK pk)

getWorkOrderWorkSheetItem

public java.util.Set getWorkOrderWorkSheetItem()

setWorkOrderWorkSheetItem

public void setWorkOrderWorkSheetItem(java.util.Set workOrderWorkSheetItem)

getCompanyUnitId

public java.lang.String getCompanyUnitId()

setCompanyUnitId

public void setCompanyUnitId(java.lang.String companyUnitId)

getDebitAccount

public java.lang.String getDebitAccount()

setDebitAccount

public void setDebitAccount(java.lang.String debitAccount)

isPublicToEvery

public boolean isPublicToEvery()

setPublicToEvery

public void setPublicToEvery(boolean publicToEvery)

getPublicToUser

public java.lang.String getPublicToUser()

setPublicToUser

public void setPublicToUser(java.lang.String publicToUser)

isPublicWorkSheet

public boolean isPublicWorkSheet()

setPublicWorkSheet

public void setPublicWorkSheet(boolean publicWorkSheet)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkPeriodVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkPeriodVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.WorkPeriodVO
All Implemented Interfaces:
java.io.Serializable
public class WorkPeriodVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkPeriodVO()
Method Summary
java.util.Date | getDateFrom()
java.util.Date | getDateTo()
long | getIi()
java.lang.Long | getWorkDate()
void | setDateFrom(java.util.Date dateFrom)
void | setDateTo(java.util.Date dateTo)
void | setIi(long ii)
void | setWorkDate(java.lang.Long workDate)
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkPeriodVO

public WorkPeriodVO()
Method Detail

getIi

public long getIi()

setIi

public void setIi(long ii)

getWorkDate

public java.lang.Long getWorkDate()

setWorkDate

public void setWorkDate(java.lang.Long workDate)

getDateFrom

public java.util.Date getDateFrom()

setDateFrom

public void setDateFrom(java.util.Date dateFrom)

getDateTo

public java.util.Date getDateTo()

setDateTo

public void setDateTo(java.util.Date dateTo)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WorkSheetPartAgent

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class WorkSheetPartAgent

java.lang.Object
    extended by  bb.common.WorkSheetPartAgent
All Implemented Interfaces:
java.io.Serializable
public class WorkSheetPartAgent
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
WorkSheetPartAgent()
Method Summary
boolean | equals(java.lang.Object other)
java.util.Date | getDelivery()
java.lang.Integer | getMonths()
PartPK | getPartPk()
java.math.BigDecimal | getQty()
java.math.BigDecimal | getQtyMonths()
int | hashCode()
void | setDelivery(java.util.Date delivery)
void | setMonths(java.lang.Integer months)
void | setPartPk(PartPK partPk)
void | setQty(java.math.BigDecimal qty)
void | setQtyMonths(java.math.BigDecimal qtyMonths)
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkSheetPartAgent

public WorkSheetPartAgent()
Method Detail

getPartPk

public PartPK getPartPk()

getQty

public java.math.BigDecimal getQty()

getQtyMonths

public java.math.BigDecimal getQtyMonths()

getMonths

public java.lang.Integer getMonths()

getDelivery

public java.util.Date getDelivery()

setPartPk

public void setPartPk(PartPK partPk)

setQty

public void setQty(java.math.BigDecimal qty)

setQtyMonths

public void setQtyMonths(java.math.BigDecimal qtyMonths)

setMonths

public void setMonths(java.lang.Integer months)

setDelivery

public void setDelivery(java.util.Date delivery)

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


X-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M N O P Q R S T U V W X Y Z

X

X - Static variable in class bb.common.Constant.MakeBuy
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M N O P Q R S T U V W X Y Z


YearMonthManager

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class YearMonthManager

java.lang.Object
    extended by  bb.common.YearMonthManager

public final class YearMonthManager
extends java.lang.Object

Constructor Summary
YearMonthManager()
Method Summary
static java.lang.String | getFullYear(java.lang.String yearMonth)
static java.lang.String | getLastMonthYearMonth(java.lang.String yearMonth)
static java.util.Date | getLastYearEndDateByYearMonth(java.lang.String yearMonth)
static java.util.Date | getMonthEndDate(java.lang.String yearMonth)
static java.util.Date | getMonthFirstDate(java.lang.String yearMonth)
static java.lang.String | getMonthName(java.util.Date date)
static java.lang.String | getMonthName(int i)
static java.lang.String | getMonthName(java.lang.String yearMonth)
static int | getMonthNumber(java.lang.String month)
static java.lang.String | getNextMonthYearMonth(java.lang.String yearMonth)
static java.lang.String | getYearMonth(java.util.Date date)
static java.lang.String | getYearMonth(java.util.Date date, boolean fullYear)
static java.util.Set<java.lang.String> | getYearMonths(java.util.Date fDate, java.util.Date toDate)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

YearMonthManager

public YearMonthManager()
Method Detail

getYearMonth

public static java.lang.String getYearMonth(java.util.Date date,
                                            boolean fullYear)

getMonthFirstDate

public static java.util.Date getMonthFirstDate(java.lang.String yearMonth)

getMonthEndDate

public static java.util.Date getMonthEndDate(java.lang.String yearMonth)

getFullYear

public static java.lang.String getFullYear(java.lang.String yearMonth)

getYearMonth

public static java.lang.String getYearMonth(java.util.Date date)

getYearMonths

public static java.util.Set<java.lang.String> getYearMonths(java.util.Date fDate,
                                                            java.util.Date toDate)

getLastMonthYearMonth

public static java.lang.String getLastMonthYearMonth(java.lang.String yearMonth)

getNextMonthYearMonth

public static java.lang.String getNextMonthYearMonth(java.lang.String yearMonth)

getMonthName

public static java.lang.String getMonthName(int i)

getMonthNumber

public static int getMonthNumber(java.lang.String month)

getMonthName

public static java.lang.String getMonthName(java.util.Date date)

getMonthName

public static java.lang.String getMonthName(java.lang.String yearMonth)

getLastYearEndDateByYearMonth

public static java.util.Date getLastYearEndDateByYearMonth(java.lang.String yearMonth)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Y-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M N O P Q R S T U V W X Y Z

Y

Y - Static variable in class bb.common.Constant.YesNO
YEAR - Static variable in class bb.common.Constant.CycleCountPeriodUnit
YEAR - Static variable in class bb.common.Constant.PeriodUnit
YEAR_TO_DATE - Static variable in class bb.common.PurchaseOrderOnTimeItemResult
YEAR_TO_DATE - Static variable in class bb.common.SalesOrderOnTimeItemResult
YEAR_TO_DATE - Static variable in class bb.common.WorkOrderOnTimeItemResult
YearMonthManager - Class in bb.common
YearMonthManager() - Constructor for class bb.common.YearMonthManager
yes - Static variable in class bb.common.Constant.ActiveStatus
YES - Static variable in class bb.common.Constant.YesNO
YOU_CAN_NOT_CHANGE_THE_OTHERS_EXPENSE - Static variable in class bb.common.BIZReason
YOU_CAN_NOT_CHANGE_TOTAL_ONHAND - Static variable in class bb.common.BIZReason
YOU_DID_NOT_LOG_OFF - Static variable in class bb.common.BIZReason
YOU_HAVE_NO_PERMISSION_APPROVAL_OWN_RMA - Static variable in class bb.common.BIZReason
YOU_HAVE_NO_PERMISSION_REVIEW_OWN_ONLOAN - Static variable in class bb.common.BIZReason
YOU_HAVE_NO_PERMISSION_REVIEW_OWN_QUOTE - Static variable in class bb.common.BIZReason
YOU_HAVE_NO_PERMISSION_REVIEW_OWN_SALES_ORDER - Static variable in class bb.common.BIZReason
YOU_HAVE_NOT_APPROVED_GL - Static variable in class bb.common.BIZReason
YOU_HAVE_NOT_OVER_CARRY_ALL_PROFIT_AND_LOSS_ACCOUNT - Static variable in class bb.common.BIZReason
YOU_HAVE_NOT_POST_GL - Static variable in class bb.common.BIZReason
YOUR_ACCOUNT_EXPIRED - Static variable in class bb.common.BIZReason
YrUsage - Static variable in class bb.common.MrpReportAgent
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M N O P Q R S T U V W X Y Z


Z-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M N O P Q R S T U V W X Y Z

Z

ZERO - Static variable in class bb.common.Constant.OITypeSerialNumberType
zip(String, String, String) - Static method in class bb.common.BB2Zip
zip(ZipOutputStream, File, String) - Static method in class bb.common.BB2Zip
zip(OutputStream, InputStream, String) - Static method in class bb.common.BB2Zip
ZIP - Static variable in class bb.common.Constant.FileExt
ZipCodeTaxVO - Class in bb.common
ZipCodeTaxVO() - Constructor for class bb.common.ZipCodeTaxVO
ZipcodeTotalsResult - Class in bb.common
ZipcodeTotalsResult() - Constructor for class bb.common.ZipcodeTotalsResult
ZipCodeVO - Class in bb.common
ZipCodeVO() - Constructor for class bb.common.ZipCodeVO
ZipCodeVO(String, String) - Constructor for class bb.common.ZipCodeVO
zipObject(Collection) - Static method in class bb.common.BB2Util
ZippedByteArray - Class in bb.common
ZippedByteArray(byte[]) - Constructor for class bb.common.ZippedByteArray
Overview Package Class Use Tree Deprecated Index Help
PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M N O P Q R S T U V W X Y Z


ZipCodeTaxVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ZipCodeTaxVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ZipCodeTaxVO
All Implemented Interfaces:
java.io.Serializable
public class ZipCodeTaxVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Field Summary
static java.lang.String ORDER_BY_ZIPTO
Constructor Summary
ZipCodeTaxVO()
Method Summary
boolean | equals(java.lang.Object other)
java.lang.Integer | getIi()
java.math.BigDecimal | getTaxRate()
java.lang.String | getTaxType()
java.lang.String | getZipTo()
int | hashCode()
void | setIi(java.lang.Integer ii)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setTaxType(java.lang.String taxType)
void | setZipTo(java.lang.String zipTo)
java.lang.String | toString()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField, uniqueStr
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Field Detail

ORDER_BY_ZIPTO

public static final java.lang.String ORDER_BY_ZIPTO
See Also:
Constant Field Values
Constructor Detail

ZipCodeTaxVO

public ZipCodeTaxVO()
Method Detail

setIi

public void setIi(java.lang.Integer ii)

getIi

public java.lang.Integer getIi()

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getTaxType

public java.lang.String getTaxType()

setTaxType

public void setTaxType(java.lang.String taxType)

getZipTo

public java.lang.String getZipTo()

setZipTo

public void setZipTo(java.lang.String zipTo)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ZipcodeTotalsResult

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ZipcodeTotalsResult

java.lang.Object
    extended by  bb.common.ZipcodeTotalsResult
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<ZipcodeTotalsResult>
public class ZipcodeTotalsResult
extends java.lang.Object
implements java.io.Serializable, java.lang.Comparable<ZipcodeTotalsResult>

See Also:
Serialized Form

Constructor Summary
ZipcodeTotalsResult()
Method Summary
int | compareTo(ZipcodeTotalsResult other)
java.lang.String | getAddress1()
java.lang.String | getAddress2()
java.lang.String | getCityName()
java.lang.String | getCityOrCountyCode()
java.lang.String | getCustomerID()
java.lang.String | getCustomerName()
java.util.Date | getDate()
java.lang.String | getDescription()
java.math.BigDecimal | getGrandTotal()
java.lang.String | getItem()
java.math.BigDecimal | getNetTaxableSales()
java.lang.String | getOrderNumber()
java.lang.String | getParentName()
java.lang.String | getRunningAccountNumber()
java.lang.String | getShipToID()
java.lang.String | getShipToName()
java.lang.String | getTaxNumber()
java.math.BigDecimal | getTaxRate()
java.lang.String | getTaxType()
java.math.BigDecimal | getTotalExemptions()
java.math.BigDecimal | getTotalSales()
java.math.BigDecimal | getTotalTax()
java.util.Date | getValidDate()
java.lang.String | getZipCode()
java.lang.String | getZipCodeFrom()
java.lang.String | getZipCodeTo()
boolean | isTaxExempt()
void | setAddress1(java.lang.String address1)
void | setAddress2(java.lang.String address2)
void | setCityName(java.lang.String cityName)
void | setCityOrCountyCode(java.lang.String cityOrCountyCode)
void | setCustomerID(java.lang.String customerID)
void | setCustomerName(java.lang.String customerName)
void | setDate(java.util.Date date)
void | setDescription(java.lang.String description)
void | setGrandTotal(java.math.BigDecimal grandTotal)
void | setItem(java.lang.String item)
void | setNetTaxableSales(java.math.BigDecimal netTaxableSales)
void | setOrderNumber(java.lang.String orderNumber)
void | setParentName(java.lang.String parentName)
void | setRunningAccountNumber(java.lang.String runningAccountNumber)
void | setShipToID(java.lang.String shipToID)
void | setShipToName(java.lang.String shipToName)
void | setTaxExempt(boolean taxExempt)
void | setTaxNumber(java.lang.String taxNumber)
void | setTaxRate(java.math.BigDecimal taxRate)
void | setTaxType(java.lang.String taxType)
void | setTotalExemptions(java.math.BigDecimal totalExemptions)
void | setTotalSales(java.math.BigDecimal totalSales)
void | setTotalTax(java.math.BigDecimal totalTax)
void | setValidDate(java.util.Date validDate)
void | setZipCode(java.lang.String zipCode)
void | setZipCodeFrom(java.lang.String zipCodeFrom)
void | setZipCodeTo(java.lang.String zipCodeTo)
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ZipcodeTotalsResult

public ZipcodeTotalsResult()
Method Detail

getZipCode

public java.lang.String getZipCode()

setZipCode

public void setZipCode(java.lang.String zipCode)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getTotalTax

public java.math.BigDecimal getTotalTax()

setTotalTax

public void setTotalTax(java.math.BigDecimal totalTax)

getCustomerID

public java.lang.String getCustomerID()

setCustomerID

public void setCustomerID(java.lang.String customerID)

getCustomerName

public java.lang.String getCustomerName()

setCustomerName

public void setCustomerName(java.lang.String customerName)

getAddress1

public java.lang.String getAddress1()

setAddress1

public void setAddress1(java.lang.String address1)

getAddress2

public java.lang.String getAddress2()

setAddress2

public void setAddress2(java.lang.String address2)

getTaxRate

public java.math.BigDecimal getTaxRate()

setTaxRate

public void setTaxRate(java.math.BigDecimal taxRate)

getGrandTotal

public java.math.BigDecimal getGrandTotal()

setGrandTotal

public void setGrandTotal(java.math.BigDecimal grandTotal)

compareTo

public int compareTo(ZipcodeTotalsResult other)
Specified by:
compareTo in interface java.lang.Comparable<ZipcodeTotalsResult>

getZipCodeFrom

public java.lang.String getZipCodeFrom()

setZipCodeFrom

public void setZipCodeFrom(java.lang.String zipCodeFrom)

getZipCodeTo

public java.lang.String getZipCodeTo()

setZipCodeTo

public void setZipCodeTo(java.lang.String zipCodeTo)

getShipToID

public java.lang.String getShipToID()

setShipToID

public void setShipToID(java.lang.String shipToID)

getShipToName

public java.lang.String getShipToName()

setShipToName

public void setShipToName(java.lang.String shipToName)

getTaxType

public java.lang.String getTaxType()

setTaxType

public void setTaxType(java.lang.String taxType)

getCityName

public java.lang.String getCityName()

setCityName

public void setCityName(java.lang.String cityName)

getParentName

public java.lang.String getParentName()

setParentName

public void setParentName(java.lang.String parentName)

isTaxExempt

public boolean isTaxExempt()

setTaxExempt

public void setTaxExempt(boolean taxExempt)

getValidDate

public java.util.Date getValidDate()

setValidDate

public void setValidDate(java.util.Date validDate)

getTaxNumber

public java.lang.String getTaxNumber()

setTaxNumber

public void setTaxNumber(java.lang.String taxNumber)

getRunningAccountNumber

public java.lang.String getRunningAccountNumber()

setRunningAccountNumber

public void setRunningAccountNumber(java.lang.String runningAccountNumber)

getCityOrCountyCode

public java.lang.String getCityOrCountyCode()

setCityOrCountyCode

public void setCityOrCountyCode(java.lang.String cityOrCountyCode)

getTotalSales

public java.math.BigDecimal getTotalSales()

setTotalSales

public void setTotalSales(java.math.BigDecimal totalSales)

getTotalExemptions

public java.math.BigDecimal getTotalExemptions()

setTotalExemptions

public void setTotalExemptions(java.math.BigDecimal totalExemptions)

getNetTaxableSales

public java.math.BigDecimal getNetTaxableSales()

setNetTaxableSales

public void setNetTaxableSales(java.math.BigDecimal netTaxableSales)

getItem

public java.lang.String getItem()

setItem

public void setItem(java.lang.String item)

getDate

public java.util.Date getDate()

setDate

public void setDate(java.util.Date date)

getOrderNumber

public java.lang.String getOrderNumber()

setOrderNumber

public void setOrderNumber(java.lang.String orderNumber)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ZipCodeVO

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ZipCodeVO

java.lang.Object
    extended by  bb.common.VO
        extended by  bb.common.ZipCodeVO
All Implemented Interfaces:
java.io.Serializable
public class ZipCodeVO
extends VO
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ZipCodeVO()
ZipCodeVO(java.lang.String zipId, java.lang.String zipName)
Method Summary
boolean | equals(java.lang.Object other)
java.lang.String | getZipId()
java.lang.String | getZipName()
int | hashCode()
void | setZipId(java.lang.String zipId)
void | setZipName(java.lang.String zipName)
java.lang.String | toString()
java.lang.String | uniqueStr()
Methods inherited from class bb.common.VO
getClientProperties, getCustomProperties, getValueOfCustomField, setClientProperties, setCustomProperties, setValueOfCustomField
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ZipCodeVO

public ZipCodeVO()

ZipCodeVO

public ZipCodeVO(java.lang.String zipId,
                 java.lang.String zipName)
Method Detail

getZipId

public java.lang.String getZipId()

setZipId

public void setZipId(java.lang.String zipId)

getZipName

public java.lang.String getZipName()

setZipName

public void setZipName(java.lang.String zipName)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

equals

public boolean equals(java.lang.Object other)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

uniqueStr

public java.lang.String uniqueStr()
Overrides:
uniqueStr in class VO
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ZippedByteArray

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

bb.common
Class ZippedByteArray

java.lang.Object
    extended by  bb.common.ZippedByteArray
All Implemented Interfaces:
java.io.Serializable
public class ZippedByteArray
extends java.lang.Object
implements java.io.Serializable

See Also:
Serialized Form

Constructor Summary
ZippedByteArray(byte[] data)
Method Summary
 byte[] getByteArray()
Methods inherited from class java.lang.Object
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ZippedByteArray

public ZippedByteArray(byte[] data)
Method Detail

getByteArray

public byte[] getByteArray()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD